PHP Kılavuzu

Yazan:
Mehdi Achour
Friedhelm Betz
Antony Dovgal
Nuno Lopes
Hannes Magnusson
Georg Richter
Damien Seguy
Jakub Vrana
Devamı burada
22-02-2017
Düzenleyen: Peter Cowburn
Mustafa Aldemir
Nilgün Belma Bugüner
Yücel Haluk Bugüner
Emre Çamalan
Yaşar Dereli
Faruk Enes
Behzat Erte
Alper Ersoy
Hilmi Erdem Keren
Ekin Koç
Buğra Gökalp Okçu
Cumhur Onat
Onur Özgür Özkan
Sinan Polat
Serdar Soydemir
Mesut Tunga
Aydın Uzun
Bünyamin Vıcıl
Sezer Yalçın
çeviriye katkıda bulunmuşlardır.
© 1997-2017 PHP Belgelendirme Grubu
  • Telif Hakkı
  • PHP Kılavuzu
    • Önsöz
  • Başlarken
    • Giriş
    • Basit bir eğitmen
  • Yapılandırma ve Kurulum
    • Genel Kurulum Değerlendirmesi
    • Unix Sistemlere Kurulum
    • Mac OS X üzerine Kurulum
    • Windows Sistemlerine Kurulum
    • Installation on Cloud Computing platforms
    • FastCGI Process Manager (FPM)
    • PECL eklentilerinin kurulması
    • Sorunlar?
    • Çalışma Anı Yapılandırması
  • Dil Başvuru Kılavuzu
    • Temel Sözdizimi
    • Türler
    • Değişkenler
    • Sabitler
    • İfadeler
    • İşleçler
    • Denetim Yapıları
    • İşlevler
    • Sınıflar ve Nesneler
    • İsim Alanları
    • Errors
    • İstisnalar
    • Generators
    • Gönderimlerle İlgili Herşey
    • Öntanımlı Değişkenler
    • Öntanımlı İstisnalar
    • Öntanımlı Arayüzler ve Sınıflar
    • Bağlam seçenekleri ve değiştirgeleri
    • Supported Protocols and Wrappers
  • Güvenlik
    • Giriş
    • Genel değerlendirmeler
    • Installed as CGI binary
    • Apache'ye modül olarak kurulum
    • Session Security
    • Dosya Sistemi Güvenliği
    • Database Security
    • Error Reporting
    • register_globals Kullanımı
    • Kullanıcıdan Gelen Bilgi
    • Sihirli Tırnak
    • PHP'yi gizlemek
    • Güncel Tutmak
  • Özellikler
    • PHP ile HTTP Kimlik Doğrulaması
    • Çerezler
    • Oturumlar
    • XForms ile çalışmak
    • Karşıya dosya yükleme
    • Uzak dosyaların kullanımı
    • Bağlantı yönetimi
    • Kalıcı Bağlantılı Veritabanı Bağlantıları
    • Güvenli Kip
    • Komut satırından kullanım — PHP'nin komut satırından kullanımı
    • Garbage Collection
    • DTrace Dynamic Tracing
  • İşlev Başvuru Kılavuzu
    • PHP'nin Davranışını Etkileyenler
    • Ses Biçemleme İşlemleri
    • Kimlik Doğrulama Hizmetleri
    • Komut Satırına Özgü Eklentiler
    • Sıkıştırma ve Arşivleme Eklentileri
    • Kredi Kartı İşlemleri
    • Şifresel Eklentiler
    • Veritabanı Eklentileri
    • Tarih ve Saat ile İlgili Eklentiler
    • Dosya Sistemiyle İlgili Eklentiler
    • İnsan Dilleri ve Karakter Kodlaması Desteği
    • Resim İşleme ve Resim Üretimi
    • Postayla İlgili Eklentiler
    • Matematiksel Eklentiler
    • Salt Metin Olmayan MIME Çıktılama
    • Süreç Denetim Eklentileri
    • Diğer Temel Eklentiler
    • Diğer Hizmetler
    • Arama Motoru Eklentileri
    • Sunuculara Özgü Eklentiler
    • Oturum Eklentileri
    • Metin İşleme
    • Değişkenler ve Veri Türleriyle İlgili Eklentiler
    • HTTP Hizmetleri
    • Windows’a Özgü Eklentiler
    • XML İşleme
    • GUI Extensions
  • PHP’nin Çekirdeği; Çekirdek geliştiricilerin Rehberi
    • Preface
    • Bellek Yönetimi
    • Değişkenlerle Çalışmak
    • İşlevlerin Yazılması
    • Sınıflar ve Nesnelerle Çalışma
    • Özkaynaklarla Çalışmak
    • INI ayarlarıyla çalışma
    • Akımlarla Çalışmak
    • The "counter" Extension - A Continuing Example
    • The PHP 5 build system
    • Extension structure
    • PDO Driver How-To
    • Eklentilerin SSS'leri
    • Zend Motoru 2 Başvuru Kılavuzu
    • Zend Engine 2 Opcodes
    • Zend Engine 1
  • SSS — Sıkça Sorulan Sorular
    • Genel Bilgi
    • Eposta listeleri — Posta Listeleri
    • PHP'nin Temini
    • Veritabanı Sorunları
    • Kurulum
    • Derleme Sorunları
    • PHP Kullanımı
    • Parola Karıştırma — Güvenli Parola Karıştırma
    • PHP ve HTML
    • PHP ve COM
    • Çeşitli Sorular
  • Ekler
    • History of PHP and Related Projects
    • Migrating from PHP 7.0.x to PHP 7.1.x
    • Migrating from PHP 5.6.x to PHP 7.0.x
    • Migrating from PHP 5.5.x to PHP 5.6.x
    • Migrating from PHP 5.4.x to PHP 5.5.x
    • Migrating from PHP 5.3.x to PHP 5.4.x
    • Migrating from PHP 5.2.x to PHP 5.3.x
    • Migrating from PHP 5.1.x to PHP 5.2.x
    • Migrating from PHP 5.0.x to PHP 5.1.x
    • Migrating from PHP 4 to PHP 5.0.x
    • PHP'de Hata Ayıklama
    • Yapılandırma Seçenekleri
    • php.ini Yönergeleri
    • Eklenti Grupları/Listesi
    • İşlev Takma Adlarının Listesi
    • Yerleşik Sözcüklerin Listesi
    • Özkaynak Türlerinin Listesi
    • Kullanılabilir Süzgeçlerin Listesi
    • Desteklenen Soket Aktarımlarının Listesi
    • PHP Tür Karşılaştırma Tabloları
    • Çözümleyici Dizgeciklerinin Listesi
    • Kullanıcı Alanı İsimlendirme Kılavuzu
    • About the manual
    • Creative Commons Attribution 3.0
    • Genel Dizin
    • Changelog
  • HTML Yardım Dosyası (.chm) Sürümü
    • About This Edition
    • Using PHP Manual CHM Edition
    • The Full Text Search
    • Integrating the PHP Manual
Telif Hakkı
PHP Manual


Telif Hakkı

Copyright © 1997 - 2017 PHP Belgelendirme Grubu. Bu belge, sadece Creative Commons Attribution lisansının 3.0 veya sonraki sürümlerinin koşullarına bağlı kalınarak dağıtılabilir. Creative Commons Attribution lisansının 3.0 sürümü bu kılavuzla birlikte dağıtılmaktadır. Şu anki son sürümü » http://creativecommons.org/licenses/by/3.0/ adresinden temin edilebilir.

Bu belgenin kısmen veya tamamen, değiştirilerek veya aynen yayınlanması veya dağıtılması ile ilgileniyorsanız ve bu konuda sorularınız varsa, lütfen » doc-license@lists.php.net adresinden telif hakkı sahiplerine yazınız. Bu adres içeriği halka açık olarak arşivlenen bir eposta listesine aittir.

PHP Kılavuzu
PHP Kılavuzu
PHP Kılavuzu


PHP Kılavuzu
PHP Manual

PHP Kılavuzu

  • Önsöz
Telif Hakkı
Önsöz
PHP Kılavuzu
PHP Manual


Önsöz

PHP, "PHP: Hypertext Preprocessor" sözcüklerinin baş harfleriyle temsil edilen HTML içine gömülebilir açık kaynak kodlu, genel amaçlı, özellikle site geliştirmeye uygun bir betik dilidir. Dil yapısının önemli bir kısmını C, Java ve Perl gibi dillerden almış, kendisine has özelliklerle bu yapıyı pekiştirmiş, kolay öğrenilen bir dildir. Dilin ana amacı, site geliştiricilerinin devingen sayfalar oluşturmasını çabuklaştırmaksa da PHP ile çok daha fazlasını yapabilirsiniz.

Bu kılavuz temel olarak bir işlev başvuru kılavuzudur. Fakat bunun yanında bir dil kılavuzu, PHP'nin önemli özelliklerinin bazılarının açıklamaları ile tamamlayıcı bazı bilgiler de içermektedir.

Bu kılavuzu çeşitli biçemlerde » http://www.php.net/download-docs.php adresinden temin edebilirsiniz. Bu kılavuzun nasıl geliştirildiğiyle ilgili daha ayrıntılı bilgi edinmek için eklerdeki 'Kılavuz Hakkında' bölümüne bakabilirsiniz. PHP'nin tarihçesi ile ilgileniyorsanız onu da ek bölümler arasında bulabilirsiniz.

Yazarlar ve Katkıda Bulunanlar

Kılavuzun ön sayfasında şu anda en etkin kişileri ön plana çıkartıyoruz, ancak çalışmamıza halen katkıda bulunmakta olan birçok kişi ve geçmişte önemli katkılarda bulunmuş birçok insan var. Kılavuz sayfalarında kullanıcı önerileri üzerinden katılımda bulunarak destek veren birçok isimsiz kişi var. Bu kişiler düzenli olarak buradaki listelere ekleniyor, tüm katılımcılara destekleri için müteşekkiriz. Aşağıdaki listelerde isimler alfabetik olarak sıralanmıştır.

Yazarlar ve Düzeltmenler

Burada yer alan katılımcılar kılavuzun içeriğine yaptıkları ve/veya yapmakta oldukları eklemelerden dolayı takdir edilmelidirler: Bill Abt, Jouni Ahto, Alexander Aulbach, Christoph Michael Becker, Daniel Beckham, Stig Bakken, Nilgün Belma Bugüner, Jesus M. Castagnetto, Ron Chmara, Sean Coates, John Coggeshall, Simone Cortesi, Peter Cowburn, Daniel Egeberg, Markus Fischer, Wez Furlong, Sara Golemon, Rui Hirokawa, Brad House, Pierre-Alain Joye, Etienne Kneuss, Moriyoshi Koizumi, Rasmus Lerdorf, Andrew Lindeman, Stanislav Malyshev, Justin Martin, Rafael Martinez, Rick McGuire, Moacir de Oliveira Miranda Júnior, Kalle Sommer Nielsen, Yasuo Ohgaki, Philip Olson, Richard Quadling, Derick Rethans, Rob Richards, Sander Roobol, Egon Schmid, Thomas Schoefbeck, Sascha Schumann, Dan Scott, Masahiro Takagi, Yannick Torres, Michael Wallner, Lars Torben Wilson, Jim Winstead, Jeroen van Wolffelaar ve Andrei Zmievski.

Burada yer alan katılımcılar kılavuzun düzenlenmesi çalışmasında kayda değer katkılarda bulunmuşlardır: Stig Bakken, Gabor Hojtsy, Hartmut Holzgraefe, Philip Olson ve Egon Schmid.

Kullanıcı Önerilerini Sürdürenler

Şu anki en etkin geliştiriciler: Daniel Brown, Nuno Lopes, Felipe Pena, Thiago Pojda ve Maciek Sokolewicz.

Bu kişiler kullanıcı önerilerinin yönetiminde çok ciddi çaba sarfetmişlerdir: Mehdi Achour, Daniel Beckham, Friedhelm Betz, Victor Boivie, Jesus M. Castagnetto, Nicolas Chaillan, Ron Chmara, Sean Coates, James Cox, Vincent Gevers, Sara Golemon, Zak Greant, Szabolcs Heilig, Oliver Hinckel, Hartmut Holzgraefe, Etienne Kneuss, Rasmus Lerdorf, Matthew Li, Andrew Lindeman, Aidan Lister, Hannes Magnusson, Maxim Maletsky, Bobby Matthis, James Moore, Philip Olson, Sebastian Picklum, Derick Rethans, Sander Roobol, Damien Seguy, Jason Sheets, Tom Sommer, Jani Taskinen, Yasuo Ohgaki, Jakub Vrana, Lars Torben Wilson, Jim Winstead, Jared Wyles ve Jeroen van Wolffelaar.

PHP Kılavuzu
Başlarken
PHP Kılavuzu


Başlarken

  • Giriş
    • PHP nedir?
    • PHP neler yapabilir?
  • Basit bir eğitmen
    • Neye ihtiyacım var?
    • İlk PHP-etkin sayfanız
    • İşe yarar bir şey
    • Form Kullanımı
    • PHP'nin yeni sürümleri ile eski kod yapısını kullanmak
    • Sonraki adım nedir?
Önsöz
Giriş
PHP Kılavuzu


Giriş

İçindekiler

  • PHP nedir?
  • PHP neler yapabilir?
Başlarken
PHP nedir?
Başlarken


PHP nedir?

PHP (açılımı PHP: Hypertext Preprocessor) geniş bir kitle tarafından kullanılan, özellikle sanal yöreler üzerinde geliştirme için tasarlanmış HTML içine gömülebilen bir betik dilidir.

Tamam da, bu tam olarak ne anlama gelmektedir? Bir örnek:

Örnek 1 - Başlangıç olarak bir örnek

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
    "http://www.w3.org/TR/html4/loose.dtd">
<html>
    <head>
        <title>Örnek</title>
    </head>
    <body>

        <?php
            echo "Merhaba, ben bir PHP betiğiyim!";
        ?>

    </body>
</html>

Bir PHP betiğinin Perl ya da C gibi dillerden ne kadar farklı bir yapıda olduğuna dikkat edin. HTML kodu oluşturmak için bir sürü kod yazacağınıza, istediğiniz işi yapan bir PHP kodu yazıp onu HTML kodunun içine gömüyorsunuz (bu örnekte, yapılan iş ekrana yazı yazmak). PHP kodu <?php ve ?> özel başlangıç ve bitiş etiketleri arasına yazılır. Bu etiketler "PHP kipine" rahatlıkla girip çıkabilmenizi sağlarlar.

PHP'yi Javascript gibi kullanıcı tarafında çalışan dillerden ayıran, sunucu tarafında çalıştırılıyor olmasıdır. Yukardaki örnekteki kodu kendi sunucunuzda çalıştırırsanız, sitenize bağlanan kullanıcılar kodu göremeyecekler ve müdahale edemeyecekler, yalnızca sonucu görebileceklerdir. Dilerseniz HTTP sunucunuzu bütün HTML dosyalarınızı PHP dosyası olarak görüp işleyecek hale bile getirebilirsiniz. Buna rağmen kullanıcılar sizin gerçekte sunucu taraflı bir uygulama kullandığınızı fark edemeyebilirler.

PHP kullanmanın en güzel yanlarından biri, yeni kullanıcılar için öğreniminin oldukça kolay olması ve aynı zamanda profesyonel kullanıcılar için ileri seviyede özellikler içermesidir. PHP'nin uzun özellikler listesini okumaktan korkmayın. Kısa sürede PHP ile programlamaya başlayabilir ve birkaç saat içersinde basit programlar yazmaya başlayabilirsiniz.

PHP'nin gelişimi sunucu-taraflı programlamaya odaklanmışsa da, çok daha fazlasını yapmanıza olanak tanıyan araçlara da sahiptir. PHP neler yapabilir? bölümünde bu araçlar hakkında daha fazla bilgiye ulaşabilirsiniz. Eğer yalnızca site programlama ile ilgileniyorsanız, Basit bir eğitmen bölümünden devam edebilirsiniz.

Giriş
PHP neler yapabilir?
Giriş


PHP neler yapabilir?

Her şeyi. PHP temel olarak sunucu-taraflı programlamaya odaklanmıştır, bu nedenle CGI uygulamalarının yaptığı her şeyi, örneğin formdan veri toplama, devingen sayfa içeriği oluşturma, ya da çerez alıp gönderme gibi işlemleri yapabilirsiniz. Ancak PHP bunlardan çok daha fazlasını yapabilecek yetenektedir.

PHP betiklerinin kullanıldığı başlıca üç alan vardır.

  • Sunucu-taraflı programlama. Bu PHP için en geleneksel ve en temel olan alandır. Sunucu-taraflı programlama için üç şeye sahip olmanız gerekir. PHP çözümleyici (CGI ya da sunucu modülü), bir HTTP sunucusu ve bir tarayıcı. PHP programlamada deneyimliyseniz tüm bunları evinizdeki makinede çalıştırabilirsiniz. Yapılandırma ve Kurulum bölümünden bununla ilgili daha fazla bilgiye ulaşabilirsiniz.
  • Komut satırı uygulamaları. Bir PHP uygulamasını komut satırından hiçbir sunucu ya da tarayıcı uygulama kullanmadan çalıştırabilirsiniz. Burada tek ihtiyacınız olan PHP çözümleyicidir. Bu tür kullanım cron üzerinden (Windows eşdeğeri görev yöneticisi) düzenli çalıştırılan işlemler ya da basit metin işleme görevleri için idealdir. PHP'nin komut satırında kullanımı bölümünde daha ayrıntılı bilgiye ulaşaşabilirsiniz.
  • Masaüstü uygulamalarının yazımı. PHP için görsel uygulamaların yazılabileceği en iyi dil diyemeyiz, ancak PHP'yi iyi biliyorsanız ve PHP'nin birtakım ileri seviye özelliklerini kendi istemci taraflı uygulamalarınızda kullanmak istiyorsanız, PHP-GTK eklentisini bu tip programlar yazmak için kullanabilirsiniz. Bu şekilde platformdan bağımsız uygulamalar yazma şansına da kavuşacaksınız. PHP-GTK, PHP için bir eklentidir ve ana dağıtımda yer almaz. PHP-GTK ilginizi çektiyse, » kendi sitesini ziyaret edebilirsiniz.

PHP bütün büyük işletim sistemlerinde, Linux, birçok Unix türevi (HP-UX, Solaris, OpenBSD vb.), Microsoft Windows, Mac OS X, RISC OS dahil olmak üzere çok çeşitli platformlarda çalışabilir. PHP benzer biçimde bugün yaygın biçimde kullanılan HTTP sunucularının büyük kısmını destekler. Bunlara Apache, IIS ve daha birçok sunucuyu örnek gösterebiliriz. Bunlara FastCGI PHP çalıştırılabilirini kullanan lighttpd ve nginx gibi sunucular da dahildir. PHP modül olarak kullanılabildiği gibi bir CGI işleyici olarak da çalıştırılabilir.

Sonuç olarak, PHP ile işletim sistemi ve HTTP sunucusu seçme özgürlüğüne sahipsiniz. Dahası, hangi programlama yöntemini kullanacağınıza, işlevsel yaklaşımı mı yoksa nesne yönelimli yaklaşımı mı yoksa her ikisini birden mi kullanacağınıza kendiniz karar verebilirsiniz.

PHP'nin yetenekleri yalnızca HTML çıktı üretmekle sınırlı değildir. PHP'nin yetenekleri arasında resim çıktısı üretebilme, PDF oluşturabilme ve hatta Flash filmleri oluşturabilme (libswf ve Ming kullanarak) bulunmaktadır. Aynı şekilde XHTML ya da XML gibi her tür metin tabanlı dosyayı oluşturabilmeniz mümkündür. PHP bu dosyaları özdevinimli olarak oluşturabilir ve ekrana yazdırmanın yanında sizin için dosya sisteminde saklayabilir, böylece devingen içeriğiniz için sunucu-taraflı bir depo sistemini kullanımınıza sunabilir.

PHP'nin en güçlü ve en çok üstünde durulan özelliklerinden biri, sahip olduğu geniş ve gelişmiş veritabanı desteğidir. Veritabanlarına özgü eklentilerden birini (örn. mysql) kullanarak veya PDO gibi bir soyutlama katmanı kullanarak PHP ile veritabanı bağlantılı site sayfaları oluşturmak ya da ODBC eklentisi üzerinden bu standardı destekleyen bir bağlantı açmak son derece basittir. Diğer veritabanları için cURL eklentisi veya soketler (CouchDB gibi) kullanılabilir.

PHP, farklı hizmetlerle LDAP, IMAP, SNMP, NNTP, POP3, HTTP, COM (Windows için) ve daha sayısız protokol aracılığıyla iletişim kurabilecek bir altyapıya da sahiptir. Hazır modüllerin haricinde ham ağ soketleri açıp bu soketler üzerinden istediğiniz bütün protokollerle çalışabilirsiniz. PHP, WDDX üzerinden sanal olarak sanal doku üzerinde hangi dilde yazılmış olursa olsun tüm uygulamalarla haberleşebilir. Ayrıca Java nesnelerinin oluşturulabilmesi ve şeffaf biçimde PHP nesneleri olarak kullanılabilmeleri önemli bir diğer özelliktir.

PHP oldukça faydalı belge işleme özelliklerine sahiptir. Bu yelpaze Genişletilmiş POSIX ya da Perl düzenli ifade komutlarından (PCRE) XML dosyalarını okumaya ve çözümlemeye kadar uzanır. PHP tüm XML uzantılarını libxml2 tabanında tek bir standartta toplamış ve SimpleXML ile XMLReader ve XMLWriter desteğini de bünyesine katarak sunduğu imkan yelpazesini genişletmiştir.

Alfabetik olarak ve sınıflandırılarak belgelenmiş daha pek çok ilginç eklenti vardır. Bunlara ek olarak » XDebug gibi PHP kılavuzu içinde belgelenmiş ya da belgelenmemiş PECL eklentileri de mevcuttur.

Sizin de görebildiğiniz gibi bu sayfa PHP'nin sunabileceği bütün özellikleri ve faydaları anlatabilmek için yeterli değil. Yapılandırma ve Kurulum bölümünde ve İşlev başvuru kılavuzunda listelenen eklentilerin başlangıç bölümlerindeki açıklamalardan her bir eklenti için daha fazla bilgiye ulaşabilirsiniz.

PHP nedir?
Basit bir eğitmen
Giriş


Basit bir eğitmen

İçindekiler

  • Neye ihtiyacım var?
  • İlk PHP-etkin sayfanız
  • İşe yarar bir şey
  • Form Kullanımı
  • PHP'nin yeni sürümleri ile eski kod yapısını kullanmak
  • Sonraki adım nedir?

Bu bölümde PHP ile ilgili en temel bilgileri kısa ve basit bir eğitmen üzerinde anlatmak istiyoruz. Bu metin yalnızca PHP ile devingen site sayfaları geliştirmeyi ele alır, ancak PHP'nin yeteneği yalnızca site sayfaları oluşturmakla sınırlı değildir. Daha fazla bilgi için PHP'nin yapabildikleri bölümünü inceleyebilirsiniz.

PHP tarafından etkinleştirilen site sayfaları normal HTML sayfaları gibidir ve bu sayfaları normal HTML sayfaları için kullandığınız yöntemlerle oluşturabilir ve düzenleyebilirsiniz.

PHP neler yapabilir?
Neye ihtiyacım var?
Başlarken


Neye ihtiyacım var?

Bu eğitmen süresince HTTP sunucunuzun PHP desteğinin etkinleştirilmiş olduğunu ve tüm .php uzantılı dosyaların PHP tarafından yorumlandığını varsayacağız. Çoğu sunucuda, bu uzantı PHP dosyaları için öntanımlı dosya uzantısıdır, ancak emin olmak için sunucunuzun yöneticisinden doğru bilgiyi edinebilirsiniz. Sunucunuz PHP'yi destekliyorsa, başka hiçbir şeye ihtiyacınız yok demektir. Yalnızca .php uzantılı dosyalarınızı oluşturmanız sunucunuzun belge dizinlerine koymanız, sunucunuzun bu dosyayı sizin için özdevinimli olarak işleme koyması için yeterli olacaktır. Herhangi bir şeyi derlemeniz ya da fazladan bir araç kurulumu yapmanız gerekmemektedir. PHP tarafından etkinleştirilen dosyaları yeni bir tür HTML dosyası olarak kafanızda canlandırabilirsiniz. Düşünün ki, artık HTML dosyasının içine sihirli birtakım etiketler koyabiliyor ve bu etiketler sayesinde istediğiniz her tür işlemi gerçekleştirebiliyorsunuz.

Diyelim ki çok değerli olan band genişliğinizi boşa harcamamak ve kendi sisteminizde yerel olarak geliştirme yapmak istiyorsunuz. Bu durumda, » Apache gibi bir HTTP sunucusunu ve elbette » PHP'yi indirmeniz ve kurmanız gerekecektir. Bu ikilinin yanında, » MySQL gibi bir veritabanını da indirip kurmanız iyi olacaktır.

Bu üçlüyü tek tek kurmak yerine daha basit bir yol izleyebilirsiniz. Kılavuzumuz PHP için kurulum bilgileri (HTTP sunucunuzun halihazırda kurulu olduğunu öngörür) bölümüne sahiptir. PHP'yi kendiniz kurmakta sorun yaşarsanız, sorularınızın çözümü için » kurulum posta listesi'ne başvurabilirsiniz. Daha basit bir yoldan gitmek istiyorsanız, işletim sisteminize uygun olan » ön yapılandırmalı paketleri seçebilir ve tüm bu araçları bir kaç fare tıklamasıyla özdevinimli olarak yükleyebilirsiniz. MacOSX, Linux ve Windows dahil olmak üzere birçok işletim sistemine PHP destekli bir HTTP sunucusu kurmak oldukça kolaydır. Linux üzerinde, » rpmfind ve » PBone araçlar RPM dosyalarını bulmakta size yardımcı olacaklardır. Debian için ise » apt-get sayfasını ziyaret edebilirsiniz.

Basit bir eğitmen
İlk PHP-etkin sayfanız
Basit bir eğitmen


İlk PHP-etkin sayfanız

merhaba.php isimli bir dosya oluşturun ve HTML sunucunuzun belge kök dizinine (DOCUMENT_ROOT) aşağıdaki içerikle kaydedin:

Örnek 1 - İlk PHP betiğimiz: merhaba.php

<html>
 <head>
  <title>PHP Denemesi</title>
 </head>
 <body>
 <?php echo '<p>Merhaba Dunya</p>'; ?>
 </body>
</html>

Tarayıcınızı kullanarak HTTP sunucunuzun adresine erişebilirsiniz, sunucunuzun alan adının sonuna /merhaba.php eklemeniz yeterli olacaktır. Yerel olarak geliştirme yaparken bu URL http://localhost/merhaba.php ya da http://127.0.0.1/merhaba.php gibi bir şey olacaktır, ancak bu HTTP sunucusunun yapılandırma ayarlarına bağlıdır. Eğer her şey düzgün yapılandırılmışsa, bu dosya PHP tarafından işlenecek ve aşağıdaki çıktı tarayıcınıza gönderilecektir:

<html>
 <head>
  <title>PHP Denemesi</title>
 </head>
 <body>
 <p>Merhaba Dunya</p>
 </body>
</html>

Bu program gördüğünüz gibi son derece basittir ve esasında böyle bir sayfa oluşturmak için PHP'ye gereksiniminiz yoktur. Görüntülenen: PHP'nin echo deyimi kullanılarak elde edilen Merhaba Dünya cümlesidir. Bu dosyanın hiçbir şekilde çalıştırılabilir olmasına ya da özel bir türde olmasına ihtiyaç duyulmadığına dikkat edin. Sunucu dosyanın PHP tarafından işlenmesi gerektiğini bilir çünkü dosyaya ".php" uzantısını tanımladınız. Sunucu bu uzantıya sahip dosyaları PHP'ye aktaracak biçimde yapılandırılmıştır. Bunu size birtakım özel etiketlerle birçok ilginç işlem yapmanızı sağlayan bir tür HTML dosyası olarak düşünebilirsiniz.

Bu örneği denediyseniz ve hiçbir çıktı alamadıysanız, sizden dosyayı indirmenizi istediyse ya da dosyanın tüm içeriğini metin olarak ekranda gördüyseniz, büyük ihtimalle sunucunuzun PHP desteği etkinleştirilmemiştir ya da sunucunuz doğru yapılandırılmamıştır. Yöneticinizden kılavuzdaki Kurulum bölümünü kullanarak PHP'yi etkinleştirmesini rica edebilirsiniz. Yerel olarak geliştirme yapıyorsanız, kurulum bölümünü okuyarak herşeyin doğru yapılandırıldığından emin olun. Size çıktıyı sağlayan sunucudaki dosyaya http üzerinden erişmeye çalışıp çalışmadığınızı kontrol edin. Dosyayı doğrudan kendi dosya sisteminizden çağırıyorsanız, PHP tarafından işlenmeyecektir. Sorun her şeye rağmen devam ediyorsa, » PHP desteği alma yöntemlerini kullanmakta tereddüt etmeyin.

Bu örneğin amacı özel PHP etiketi biçemini göstermektir. Örnekte <?php ile PHP etiketinin başlangıcını belirledik. Sonra PHP komutunu yazdık ve kapanış etiketi ?> kullanarak PHP kipinden çıktık. Bir HTML dosyasında bu yöntemi kullanarak istediğiniz yerde PHP kipine girip çıkabilirsiniz. Daha fazla bilgi için, kılavuzun temel PHP sözdimi bölümünü okuyabilirsiniz.

Bilginize: Satırsonları hakkında

Satırsonu karakterlerinin HTML içinde bir önemi yoktur, bununla birlikte HTML kodunun göze hoş görünmesi için satırsonu karakterlerini kullanmak gerekir. ?> kapama etiketinin hemen ardından gelen satırsonu karakterini PHP silecektir. Dosyanın içine çok sayıda PHP bloğu koyarsanız veya hiçbir şey çıktılamayan betikleri dosyaya dahil etmeniz durumunda bu çok işe yarar. Ancak bu biraz kafa karıştırıcı olabilir. ?> kapama etiketinden sonra bir satırsonu karakterinin çıktılanmasını zorlamak isterseniz, ya kapama etiketinden sonra bir boşluk bırakıp onun ardına satırsonu karakterini koyun ya da PHP bloğunun son echo/print deyiminin sonuna bir satır sonu karakteri ekleyin.

Bilginize: Metin Düzenleyiciler Hakkında

PHP dosyalarını yaratabileceğiniz, düzenleyebileceğiniz ve yönetebileceğiniz birçok metin düzenleyici ve Bütünleşik Geliştirme Ortamı (IDE) bulunmaktadır. Bu araçların bir kısmı » PHP Düzenleyicileri Listesi bölümünde listelenmiştir. Sizin önermek istediğiniz bir düzenleyici varsa, lütfen yukarıdaki sayfayı ziyaret edin ve sayfa idarecisinden önermek istediğiniz düzenleyiciyi bu listeye eklemesini rica edin. Söz dizimi vurgulaması olan bir düzenleyici size yardımcı olabilir.

Bilginize: Kelime İşlemciler Hakkında

StarOffice Writer, Microsoft Word ve Abiword gibi kelime işlemciler PHP dosyalarını düzenlemek için uygun değillerdir. Eğer bu deneme betiği için bunlardan birini kullanmak istiyorsanız, dosyanın salt metin olarak kaydedildiğinden emin olun, aksi takdirde PHP'nin betiği okuması ve çalıştırması mümkün olmayacaktır.

Bilginize: Windows Not Defteri Hakkında

PHP betiklerinizi Windows Not Defteri ile yazıyorsanız, dosyalarınızın .php uzantısı ile kaydedildiğinden emin olmalısınız (Notepad birazdan bahsedeceğimiz önlemleri almadığınız takdirde dosyaların sonuna özdevinimli olarak .txt uzantısı ekler). Dosyayı kaydetmek istediğinizde, sizden dosyanız için bir isim belirtmeniz istenecektir. Dosya ismini tırnak içinde (örn. "hello.php") yazın. Bundan başka, 'Kaydet' iletişim kutusunun içindeki 'Metin Belgeleri' açılır menüsüne tıkladıktan sonra buradaki değeri "Tüm Dosyalar" olarak değiştirin. Artık dosya isminizi tırnak işareti kullanmadan yazabilirsiniz.

Artık çalışır bir PHP betiğini başarıyla oluşturduğunza göre, PHP betiklerinin en ünlüsünü oluşturma zamanı geldi demektir! phpinfo() işlevini çalıştıracağız ve sisteminiz ve yapılandırmanızla ilgili öntanımlı değişkenler, yüklü PHP modülleri ve yapılandırma ayarları gibi konularda faydalı birçok bilgiye ulaşacağız. Bu önemli bilgiler için biraz vakit ayırmanızı ve bunları incelemenizi öneririz.

Örnek 2 - PHP ile sistem bilgisine ulaşmak

<?php phpinfo(); ?>

Neye ihtiyacım var?
İşe yarar bir şey
Basit bir eğitmen


İşe yarar bir şey

Şimdi daha işe yarar bir şey yapalım. Ziyaretçilerinizin hangi tarayıcıyı kullandığını tespit edelim. Bunun için, ziyaretçinizin tarayıcısı tarafından HTTP isteği ile birlikte gönderilen kullanıcı aracısı dizgesine bakacağız. Bu bilgi bir değişkende saklanır. Değişkenler PHP'de her zaman dolar işareti ile başlar. Bizim şu an için ilgilendiğimiz değişken $_SERVER['HTTP_USER_AGENT']'tir.

Bilginize:

$_SERVER PHP kullanımına ayrılmış özel bir değişken olup HTTP sunucusunun tüm bilgilerini içerir. Bu tür değişkenlere süper küreseller denir. Bu konuda daha ayrıntılı bilgiyi Süper küreseller bölümünde bulabilirsiniz. Bu özel değişkenler PHP » 4.1.0 sürümünden itibaren kullanılmaya başlanmıştır. Daha öncesinde, $HTTP_SERVER_VARS gibi eski $HTTP_*_VARS dizileri kullanılmaktaydı. Ömrünü doldurmuş olsa da, bu eski tarz değişkenler hala kullanılabilmektedir. (Eski kod bölümüne de bakınız.)

Bu değişkenin değerini görüntülemek için yapmanız gereken:

Örnek 1 - Bir değişkeni (dizi öğesini) yazdırmak

<?php echo $_SERVER['HTTP_USER_AGENT']; ?>

Bu betiğin çıktısı şöyle bir dizge olabilirdi:

Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

PHP'de birçok farklı değişken türü mevcuttur. Yukardaki örnekte bir diziye ait bir öğeyi yazdırdık. Diziler çok kullanışlı olabilirler.

$_SERVER PHP tarafından kullanımınıza özdevinimli olarak sunulan bir değişkendir. Kullanım kılavuzunun Öntanımlı Değişkenler bölümünden tümünün listesine ulaşabilirsiniz ya da önceki örnekte kullandığımız phpinfo() işlevi ile üretilen çıktıya bakarak bütün listeye ulaşabilirsiniz.

PHP etiketinin içine birden çok PHP komutu koyabilir ve tek bir echo komutundan daha fazlasını yapan küçük kod blokları oluşturabilirsiniz. Örneğin, ziyaretçinizin Internet Explorer kullanıp kullanmadığını şöyle öğrenebilirsiniz:

Örnek 2 - Denetim yapılarının ve işlevlerin kullanım örneği

<?php
if (strpos($_SERVER['HTTP_USER_AGENT'], 'MSIE') !== FALSE) {
    echo 'Internet Explorer kullanmaktasınız.<br />';
}
?>

Bu betiğin çıktısı şöyle olabilirdi:

Internet Explorer kullanmaktasınız.<br />

Burada birkaç yeni kavramı devreye soktuk. Bir if deyimimiz var. Eğer C dilinde kullanılan temel sözdizimine aşinalığınız varsa, bu kullanım size tanıdık gelecektir. Aksi takdirde, giriş düzeyinde bir PHP kitabı almanız ve ilk birkaç bölümünü okumanız ya da kılavuzun Dil Başvuru Kılavuzu bölümünü okumanız faydalı olacaktır.

Devreye soktuğumuz ikinci kavram, strpos() işlevi ile yaptığımız çağrı oldu. strpos(), bir dizgeyi başka bir dizgenin içinde arayan yerleşik bir PHP işlevidir. Burada 'MSIE' dizgesini (iğne) $_SERVER['HTTP_USER_AGENT'] içinde (samanlık) arıyoruz. Eğer iğne samanlıkta bulunursa işlev iğnenin konumunu samanlığın başlangıcına göreli olarak döndürür. Aksi takdirde FALSE döner. if ifadesinin sonucu TRUE olduğu takdirde FALSE dönmez ve kaşlı ayraçlar arasındaki kod çalıştırılır. Aksi takdirde kod çalıştırılmaz. If, else gibi denetim yapıları ile strtoupper() ve strlen() gibi işlevleri kullanarak siz de benzer örnekler yazabilirsiniz. İlgili her kılavuz sayfası aynı zamanda örnekler de içermektedir. Bu işlevleri nasıl kullanmanız gerektiğinden emin değilseniz, kılavuzdaki bir işlev tanımı nasıl okunur ve PHP işlevleri bölümlerini okuyabilirsiniz.

Bunu bir adım öteye taşıyabilir ve bir PHP bloğunun tam ortasındayken bile PHP kipine nasıl girip çıkabileceğimize bakabiliriz:

Örnek 3 - HTML ve PHP kiplerini karıştırmak

<?php
if (strpos($_SERVER['HTTP_USER_AGENT'], 'MSIE') !== FALSE) {
?>
<h3>strpos() false olmayan bir değer döndürmelidir</h3>
<p>Internet Explorer kullanmaktasınız</p>
<?php
} else {
?>
<h3>strpos() false döndürmelidir</h3>
<p>Internet Explorer kullanmıyorsunuz</p>
<?php
}
?>

Bu betikten elde edilebilecek sonuçlardan biri:

<h3>strpos() false olmayan bir değer döndürmelidir</h3>
<p>Internet Explorer kullanmaktasınız</p>

Bir çıktı üretmek için PHP echo komutunu kullanmak yerine, PHP kipinden çıktık ve sadece düz HTML gönderdik. Burada dikkat edilmesi gereken önemli nokta, betiğin mantıksal akışının değişmiyor olmasıdır. strpos() işlevinden edinilen sonuca göre HTML bloklarından yalnızca biri görüntüleyiciye gönderilmektedir. Başka bir deyişle, bu işleyiş MSIE değişkeninin bulunup bulunmamasına bağlıdır.

İlk PHP-etkin sayfanız
Form Kullanımı
Basit bir eğitmen


Form Kullanımı

PHP'nin en güçlü özelliklerinden biri HTML formlarına yaklaşım biçimidir. Bilinmesi gereken ilk önemli durum, form içindeki tüm elemanların PHP tarafından özdevinimli olarak kullanılabilir olacağıdır. PHP ile formların kullanımı ve daha ayrıntılı bilgi için Dış kaynaklı değişkenler bölümünü okuyabilirsiniz. Örnek bir HTML formu:

Örnek 1 - Örnek bir HTML formu

<form action="action.php" method="post">
 <p>İsminiz: <input type="text" name="isim" /></p>
 <p>Yaşınız: <input type="text" name="yaş" /></p>
 <p><input type="submit" /></p>
</form>

Bu formda özel hiçbir şey yoktur. Hiçbir özel etiket içermeyen düz bir HTML formudur. Kullanıcı formu doldurup gönder tuşuna bastığında, action.php sayfası çağrılır. Bu dosyaya aşağıdakileri yazabiliriz:

Örnek 2 - Formdan veri yazdırmak

Merhaba <?php echo htmlspecialchars($_POST['isim']); ?>.
Siz <?php echo (int)$_POST['yaş']; ?> yaşındasınız.

Bu betikten elde edilecek örnek çıktı:

Merhaba Ahmet. Siz 22 yaşındasınız.

htmlspecialchars() ve (int) kısımları harcinde yapılan iş oldukça açık. htmlspecialchars() işlevi HTML'ye özel karakterlerin doğru şekilde kodlandığından emin olunmasını sağlar, dolayısıyla başkaları sayfanıza dışardan HTML etiketleri veya Javascript yerleştiremez. Yaş alanınında ise değerin bir tamsayı olması gerektiğini bildiğimiz için değeri integer türüne dönüştürmekle özdevinimli olarak bu alana girilmesi olası başı boş karakterlerden de kurtulmuş olduk. Ayrıca, bunun PHP'de sizin yerinize özdevinimli olarak yapılmasını sağlamak için süzgeç eklentisini de kullanabilirdiniz. $_POST['isim'] değişkeni ve $_POST['yaş'] değişkenleri sizin yerinize PHP tarafından özdevinimli olarak oluşturulur. Daha önce $_SERVER süper küresel değişkenini kullanmıştık, yukarıda ise tüm POST verisini içeren $_POST süper küresel değişkenini tanımış olduk. Formumuz için tanımlı yöntemin POST oluşuna dikkat edin. GET yöntemini kullanmış olsaydık, form bilgilerimiz $_GET süper küresel değişkenine atanmış olacaktı. Bunların haricinde, istemciden gelen verinin hangi kaynaktan geldiği sizin için önemli değilse $_REQUEST süper küreselini de kullanabilirdiniz. Bu değişken GET, POST ve COOKIE verilerinin birleşiminden oluşur.

PHP içinde XForms öğelerini de kullanabilirsiniz, ancak başlangıç aşamasında çok iyi desteklenen HTML formları sizin işinizi görecektir. XForms ile çalışmak yeni başlayanlar için uygun olmasa da, ilginizi çekebilir. XForms ile çalışmak belgesinde bu konu ile ilgili daha fazla bilgi bulabilirsiniz.

İşe yarar bir şey
PHP'nin yeni sürümleri ile eski kod yapısını kullanmak
Basit bir eğitmen


PHP'nin yeni sürümleri ile eski kod yapısını kullanmak

PHP'nin günümüzün çok kullanılan bir betik dili olmasıyla birlikte, hazır kullanabileceğiniz kodlar üreten halka açık birçok depo ve kütüphane oluşturuldu. PHP geliştiricileri geriye dönük uyumluluğu mümkün olduğunca korumaya çalıştılar, dolayısıyla eski bir PHP sürümü ile birlikte yazılmış bir PHP kodu hiçbir değişiklik yapılmasına gerek duyulmadan (ideal olarak) yeni PHP sürümleri ile çalışabilir halde kaldı. Ancak uygulamada, bazı değişikliklerin yapılması gerekebilir.

Eski kodları etkileyen yakın geçmişe ait iki önemli değişiklik:

  • Eski $HTTP_*_VARS dizileri PHP 5.4.0'dan itibaren kullanımdan kaldırılmıştır. Bunların yerini alan süper küresel diziler PHP'nin » 4.1.0 sürümünden itibaren kullanılabilir olmuştur. Bunlar: $_GET, $_POST, $_COOKIE, $_SERVER, $_FILES, $_ENV, $_REQUEST ve $_SESSION dizileridir.
  • Dış kaynaklı değişkenler artık küresel etki alanında örtanımlı olarak yer almamaktadır. Başka bir deyişle, PHP » 4.2.0 sürümünden itibaren register_globals php.ini yönergesinin öntanımlı değeri off'tur (kapalıdır). Bu değerlere erişim için tercih edilen süper küresel dizi kullanımından yukarıda bahsettik. Eski betikler, kitaplar ve öğreticiler bu yönergenin on olduğu kabul edilerek yazılmış olabilir. Bu yönerge on olduğunda, örneğin http://mesela.dom/foo.php?id=42 URL'sine gelen bir istek ile $id değişkeni özdevinimli olarak oluşturulur. Bu yönergenin açık ya da kapalı olduğuna bakılmazsızın, $_GET['id()] daima kullanılabilir olacaktır.
Bu değişiklikler ile ilgili daha fazla bilgi için, Öntanımlı Değişkenler bölümünden ve oradaki diğer bağlantılardan faydalanabilirsiniz.

Form Kullanımı
Sonraki adım nedir?
Basit bir eğitmen


Sonraki adım nedir?

Sahip olduğunuz yeni bilgilerle kılavuzun birçok bölümünü anlayabilir ve örnek arşivinde bulunan birçok betiği okuyabilir hale gelmiş olmalısınız.

PHP ile neler yapabileceğiniz ile ilgili sunumlara ulaşmak isterseniz, » http://talks.php.net/ adresindeki PHP Konferans Malzemeleri Sitesini ziyaret edebilirsiniz.

PHP'nin yeni sürümleri ile eski kod yapısını kullanmak
Yapılandırma ve Kurulum
Basit bir eğitmen


Yapılandırma ve Kurulum

  • Genel Kurulum Değerlendirmesi
  • Unix Sistemlere Kurulum
    • Unix sistemler ve Apache 1.3.x
    • Unix sistemler ve Apache 2.x
    • Nginx 1.4.x on Unix systems
    • Unix sistemlerde Lighttpd 1.4
    • Sun Solaris'te Sun, iPlanet ve Netscape Sunucuları
    • CGI ve Komut Satırı Ayarları
    • HP-UX'e Özgü Kurulum Bilgileri
    • OpenBSD Kurulum Bilgiler
    • Solaris'e özgü Kurulum İpuçları
    • Debian GNU/Linux Kurulum Bilgileri
  • Mac OS X üzerine Kurulum
    • Paketlerin Kullanımı
    • Paketlenmiş PHP Kullanımı
    • Compiling PHP on Mac OS X
  • Windows Sistemlerine Kurulum
    • PHP Installer Tools on Windows
    • Recommended Configuration on Windows systems
    • Manual PHP Installation on Windows
    • Troubleshooting PHP on Windows
    • Installation on old Windows systems
  • Installation on Cloud Computing platforms
    • Azure App Services
    • Amazon EC2
  • FastCGI Process Manager (FPM)
    • Installation
    • Configuration
  • PECL eklentilerinin kurulması
    • PECL Kurulumları Hakkında
    • PECL Eklentilerinin İndirilmesi
    • Bir PHP Eklentisinin Windows Kurulumu
    • Paylaşımlı PECL eklentilerinin pecl komutu ile derlenmesi
    • Paylaşımlı PECL eklentilerinin phpize ile derlenmesi
    • php-config
    • PECL eklentilerinin PHP içinde duruk olarak derlenmesi
  • Sorunlar?
    • SSS'yi okuyun
    • Diğer Sorunlar
    • Hata Bildirme
  • Çalışma Anı Yapılandırması
    • Yapılandırma Dosyası
    • .user.ini dosyaları
    • Yapılandırma ayarlarının yeri
    • Yapılandırma ayarlarının değiştirilmesi
Sonraki adım nedir?
Genel Kurulum Değerlendirmesi
PHP Kılavuzu


Genel Kurulum Değerlendirmesi

Kuruluma başlamadan önce PHP'yi ne amaçla kullanacağınızı bilmeniz faydalı olur. Kullanım amaçları PHP ile ne yapılabilir? bölümünde anlatıldığı üzere 3 bölümde incelenebilir:

  • Genel Ağ siteleri ve uygulamaları (Sunucu taraflı)
  • Komut satırı uygulamaları
  • Masaüstü uygulamaları

İlk ve en önemli amaç için üç şeye ihtiyacınız bulunmaktadır: PHP'nin kendisi, bir HTTP Sunucusu ve bir tarayıcı. Muhtemelen bir tarayıcınız zaten vardır. Kullanmakta olduğunuz işletim sistemine bağlı olarak bir HTTP Sunucunuz da olabilir (Linux ve MacOS üzerinde Apache, Windows üzerinde IIS gibi). Yoksa, bir firmadan site barındırma hizmeti alabilirsiniz. Böylece herşeyi kendiniz ayarlamak zorunda kalmazsınız. Sadece PHP betiklerinizi yazmakla ilgilenir ve onları kiraladığınız alana yükleyip tarayıcınızla sonuçları görürsünüz.

Sunucuyu ve PHP'yi kendiniz yapılandıracaksanız, PHP'yi sunucuya bağlamak için iki seçeneğiniz olacak. Bir çok sunucunun PHP için (SAPI de denilen) bir modülü vardır. Apache, Microsoft Internet Information Server, Netscape and iPlanet sunucuları bu tür sunuculardandır. Bir çok sunucunun da Microsoft modül arayüzü, ISAPI için desteği vardır (OmniHTTPd gibi). Eğer sunucunuzda PHP için modül desteği yoksa sunucunuz ne türde olursa olsun onu bir CGI veya FastCGI işlemcisi olarak kullanabilirsiniz. Yani, sunucuya gelen tüm PHP dosyası isteklerini işleme sokmak için PHP'nin CGI çalıştırılabilirini kullanmak üzere sunucunuzu yapılandırabilirsiniz.

PHP'yi komut satırı betikleri yazmak için kullanmayı düşünüyorsanız (özdevinimli olarak resim üreten veya komut satırından aktardığınız değiştirgelerle metin dosyalarını işleyen betikler gibi), bir komut satırı betik yorumlayıcısına ihtiyacınız var demektir. Bu konuda daha fazla bigi edinmek için Komut satırı PHP uygulamalarının yazılması bölümüne bakınız. Bu durumda ne sunucuya ne de tarayıcıya ihtiyacınız olur.

PHP ile PHP-GTK eklentisini kullanarak masaüstü uygulamaları da yazabilirsiniz. Herhangi bir HTML çıktı üretilmediği için Genel Ağ sayfaları yazmaktan tamamen farklı bir yaklaşıma sahiptir. Bu araçlarla sadece pencereleri ve nesneleri yönetirsiniz. PHP-GTK hakkında daha ayrıntılı bilgi edinmek için lütfen » bu eklentinin kendi sitesini ziyaret ediniz. PHP-GTK, resmi PHP dağıtımlarıyla gelmez.

Bu noktadan itibaren belgede, daha çok Unix ve Windows üzerinde çalışan modüllü HTTP sunucuları ve CGI çalıştırılabilirlerinin yapılandırılması üzerinde durulacaktır. Ayrıca, komut satırı çalıştırılabiliri hakkında da bilgi bulabileceksiniz.

PHP'nin kaynak kodu ve Windows için çalıştırılabilir sürümleri » http://www.php.net/downloads.php adresinden temin edilebilir. Dağıtımları indirmek için yakınınızdaki » yansıları kullanmanızı öneririz.

Yapılandırma ve Kurulum
Unix Sistemlere Kurulum
Yapılandırma ve Kurulum


Unix Sistemlere Kurulum

İçindekiler

  • Unix sistemler ve Apache 1.3.x
  • Unix sistemler ve Apache 2.x
  • Nginx 1.4.x on Unix systems
  • Unix sistemlerde Lighttpd 1.4
  • Sun Solaris'te Sun, iPlanet ve Netscape Sunucuları
  • CGI ve Komut Satırı Ayarları
  • HP-UX'e Özgü Kurulum Bilgileri
  • OpenBSD Kurulum Bilgiler
  • Solaris'e özgü Kurulum İpuçları
  • Debian GNU/Linux Kurulum Bilgileri

Bu bölümde, PHP'nin Unix sistemleri üzerindeki yapılandırmasından ve kurulumundan ana hatları ile bahsedilecektir. Kuruluma başlamadan önce platformunuza ve kullandığınız HTTP sunucusuna özgü bölümleri incelemenizi öneririz.

Kılavuzun Genel Kurulum Değerlendirmesi bölümünde ana hatlarıyla bahsettiğimiz gibi, bu bölümde esas olarak HTTP sunucusunu ilgilendiren ayarlardan bahseceksek de PHP'nin komut satırından kullanımı ile ilgili ayarlara da değineceğiz.

PHP'yi Unix platformlarına kurmanın çeşitli yolları vardır. Kaynak kod paketinden kendiniz derleyip kurabileceğiniz gibi başkaları tarafından derlenip paketlenmiş sürümleri de kurabilirsiniz. Bu belgelerde esas olarak kaynak kod paketinden derleme, kurulum ve yapılandırma sürecinden bahsedeceğiz. Çoğu Unix benzeri sistemin kendine özgü paket kurulum yöntemi vardır. Bu, standart yapılandırmaya yardımcı olabilirse de farklı özelliklere ihtiyaç duyduğunuzda (örneğin, güvenli sunucu veya veritabanı sunucusu), HTTP sunucunuzu ve PHP'yi kendiniz derlemek zorunda kalırsınız. Yazılımları kendiniz derleyip kuracak bilgiye sahip değilseniz, sizin istediğiniz özelliklerde başkaları paket derlemiş mi diye bir araştırma yapmanızı öneririz.

Derleme işlemi için gerekli bilgi ve yazılımlar:

  • Temel Unix kullanım bilgisi ("make" komutunu ve bir C derleyicisini kullanabiliyor olmak)
  • Bir ANSI C derleyici
  • Bir HTTP sunucusu
  • Modüllere özgü bileşenler (GD, PDF kütüphaneleri, vs.)

Git kaynaklarıdan derlerken veya özel değişiklikler yaptıktan sonra şunlar da gerekebilir:

  • autoconf: 2.13+ (PHP < 5.4.0 için), 2.59+ (PHP >= 5.4.0 için)
  • automake: 1.4+
  • libtool: 1.4.x+ (1.4.2 hariç)
  • re2c: 0.13.4 veya daha yeni sürümü
  • flex: 2.5.4 sürümü (PHP <= 5.2 için)
  • bison:
    • PHP 5.4: 1.28, 1.35, 1.75, 1.875, 2.0, 2.1, 2.2, 2.3, 2.4, 2.4.1, 2.4.2, 2.4.3, 2.5, 2.5.1, 2.6, 2.6.1, 2.6.2, 2.6.4
    • PHP 5.5: 2.4, 2.4.1, 2.4.2, 2.4.3, 2.5, 2.5.1, 2.6, 2.6.1, 2.6.2, 2.6.3, 2.6.4, 2.6.5, 2.7
    • PHP 5.6: 2.4 ve üstü, 3.0 hariç (3.0.1 ve üstü OK)
    • PHP 7.0: 2.4 ve üstü

PHP kaynak kod paketinin derleme için ayar ve yapılandırma işlemi configure betiğinin komut satırı seçenekleri kullanılarak yapılır. Bu seçeneklerin neler olduğunu görmek için kaynak paketinin kök dizininde komut satırından ./configure --help komutunu verebilirsiniz. Ayrıca, bu kılavuzda da bazı seçeneklerin açıklamalarına yer verilmiştir. Temel yapılandırma seçeneklerini eklerde bulabilirsiniz. Eklentilere özgü yapılandırma seçenekleri ise eklentilerin kılavuzdaki belgelerinde bulunabilir.

PHP'yi yapılandırdığınızda modülleri ve çalıştırılabilirleri derlemeye hazırsınız demektir. Artık make komutunu verebilirsiniz. Derleme işlemi bir noktada başarısız olursa ve bunun sebebini anlayamazsanız, Sorunlar bölümüne bakınız.

Genel Kurulum Değerlendirmesi
Unix sistemler ve Apache 1.3.x
Yapılandırma ve Kurulum


Unix sistemler ve Apache 1.3.x

Bu bölümde, PHP'nin Unix platformlarında Apache kurulumlarına özgü bilgilere ve ipuçlarına yer verilmiştir. Apache 2 ile ilgili bilgiler ve ipuçları ayrı bir sayfada verilmiştir.

Aşağıda, 10. şıkta kullanacağınız configure betiğinin temel yapılandırma seçeneklerini eklerde bulabilirsiniz. Eklentilere özgü yapılandırma seçenekleri ise eklentilerin kılavuzdaki belgelerinde bulunabilir. Örneklerde yazılımların sürüm numaraları, belgeyi sürüm numarasına bağlı kılmamak için 'xxx' ile gösterilmiştir. Siz bu çarpıların yerine kurduğunuz paketlerin sürüm numaralarını yazacaksınız.

Örnek 1 - PHP'nin Paylaşımlı Apache Modülü olarak kurulumu

1.  gunzip apache_xxx.tar.gz
2.  tar -xvf apache_xxx.tar
3.  gunzip php-xxx.tar.gz
4.  tar -xvf php-xxx.tar
5.  cd apache_xxx
6.  ./configure --prefix=/usr --enable-module=so
7.  make
8.  make install
9.  cd ../php-xxx

10. Artık PHP'yi yapılandırabilirsiniz. Burada PHP'yi eklentileri
    etkinleştiren çeşitli seçeneklerle özelleştirebilirsiniz. Olası
    seçeneklerin listesini almak için ./configure --help komutunu
    çalıştırabilirsiniz. Bu örnekte Apache 1 için MySQL destekli
    basit bir yapılandırmaya yer verilmiştir. Ayrıca, apxs komutunun
    bulunduğu yer de buradakinden farklı olabilir.

      ./configure --with-mysql --with-apxs=/usr/bin/apxs

11. make
12. make install

    Kurulumdan sonra yapılandırmanızı değiştirmek isterseniz son üç adımı
    yinelemek yeterlidir. Yeni modülün etkili olması için tek ihtiyacınız
    Apache'yi yeniden başlatmaktır. Apache'nin yeniden derlenmesine gerek
    yoktur.

    Aksi özellikle belirtilmedikçe 'make install' ile phpize gibi çeşitli PHP
    araçları, PEAR, PHP CLI ve bir takım başka şeylerin de kurulumu yapılır.

13. php.ini dosyanızı yapılandırın:

      cp php.ini-development /usr/local/lib/php.ini

    PHP seçeneklerini ayarlamak için .ini dosyanızı düzenleyebilirsiniz. .ini
    dosyanızın başka bir yerde durmasını istiyorsanız, 10. şıkta
    --with-config-file-path=/başka/bir/yer seçeneği ile dosyanız için başka
    bir yer belirtebilirsiniz.

    php.ini-dist yerine php.ini-production (dağıtımın standart .ini dosyası
    yerine önerilen yapılandırmalar dosyasını) kullanmayı tercih ederseniz,
    değişiklik listesini okumayı ihmal etmeyin, çünkü bunlar PHP'nin
    davranışını etkileyecektir.

14. PHP modülünün yüklenmesi için httpd.conf dosyasını düzenlemelisiniz.
    LoadModule yönergesinin değeri PHP modülünün sistemdeki yerini
    göstermelidir. Yukarıdaki 'make install' bunu sizin yerinize yapmıştır
    ama emin olmak için siz yine de bir bakın.

      LoadModule php5_module libexec/libphp5.so

15. httpd.conf'un AddModule bölümünde ClearModuleList yönergesinin altına
    şunu ekleyin:

      AddModule mod_php5.c

16. Apache'ye belli dosya uzantılarını PHP uzantıları olarak ele almasını
    söyleyin. Örneğin, .php uzantılı dosyaları Apache'nin PHP dosyaları
    olarak ele almasını isteyebiliriz. Başka uzantıları da buraya
    ekleyebilirsiniz. Bunları aralarında boşluk bırakarak aynı satıra
    yazabilirsiniz. Biz örnek olsun diye .phtml uzantısını ekledik.

      AddType application/x-httpd-php .php .phtml

    PHP kaynak kodlarını renklendirilmiş olarak göstermek için .phps
    uzantısını da yapılandırmanıza ekleyebilirsiniz. Bu, şöyle yapılır:

      AddType application/x-httpd-php-source .phps

17. Artık Apache'yi başlatabilirsiniz. Bunun için Apache'yi her zaman ki gibi
    başlatmanız yetecektir. (Sunucunun bir HUP veya USR1 sinyali kullanılarak
    yeniden yüklenmemesi için sunucunuzu yeniden başlatmadan önce
    durdurmalısınız.)

PHP'yi bir duruk nesne olarak da kurabilirsiniz:

Örnek 2 - PHP'nin Duruk Apache Modülü olarak kurulumu

1.  gunzip -c apache_1.3.x.tar.gz | tar xf -
2.  cd apache_1.3.x
3.  ./configure
4.  cd ..

5.  gunzip -c php-5.x.y.tar.gz | tar xf -
6.  cd php-5.x.y
7.  ./configure --with-mysql --with-apache=../apache_1.3.x
8.  make
9.  make install

10. cd ../apache_1.3.x

11. ./configure --prefix=/www --activate-module=src/modules/php5/libphp5.a
    (Bu satırda bir hata yok! libphp5.a'nın henüz mevcut olmadığının
    farkındayız. PHP derlenince mevcut olacak.)

12. make
    (Artık httpd çalıştırılabilirini Apache bin dizinine kopyalayabilirsiniz.
    Apache'yi ilk defa kuruyorsanız bu komuttan sonra "make install" komutunu
    da verin.)

13. cd ../php-5.x.y
14. cp php.ini-development /usr/local/lib/php.ini

15. PHP seçeneklerini ayarlamak için artık /usr/local/lib/php.ini dosyasını
    düzenleyebilirsiniz. httpd.conf veya srm.conf dosyasını açıp şunu ekleyin:

    AddType application/x-httpd-php .php

Kullandığınız Unix türevine ve Apache kurulumuna bağlı olarak, sunucuyu durdurmanın ve yeniden başlatmanın çeşitli yolları vardır. Aşağıda farklı Unix/Apache kurulumları için sunucuyu yeniden başlatırkan kullanılabilecek komutlara yer verilmiştir. /bir/yer/ yerine bu uygulamaların dosya sistemindeki yerlerini yazınız.

Örnek 3 - Apache'yi yeniden başlatmak için örnek komutlar

1. Çeşitli Linux ve SysV türevleri için:
/etc/rc.d/init.d/httpd restart

2. apachectl betiği ile:
/bir/yer/apachectl stop
/bir/yer/apachectl start

3. httpdctl ve httpsdctl (OpenSSL kullanarak), apachectl gibidir:
/bir/yer/httpsdctl stop
/bir/yer/httpsdctl start

4. mod_ssl veya başka bir SSL sunucu kullanıyorsanız, elle durdurup
başlatmanız gerekebilir:
/bir/yer/apachectl stop
/bir/yer/apachectl startssl

apachectl and http(s)dctl çalıştırılabilirlerinin yerleri sık sık değişir. Sisteminizde locate, whereis, which gibi araçlar kuruluysa bunların yerlerini bu araçları kullanarak öğrenebilirsiniz.

PHP'yi Apache için derlerken kullanılabilecek farklı yapılandırma örnekleri:

./configure --with-apxs --with-pgsql

Bu yapılandırmayla, Apache'nin httpd.conf dosyasında LoadModule yönergesi ile Apache'ye yüklenebilecek şekilde bir libphp5.so paylaşımlı kütüphanesi oluşturulacak, PostgreSQL desteği bu kütüphaneye gömülü olacaktır.

./configure --with-apxs --with-pgsql=shared

Bu yapılandırmayla, Apache için bir libphp5.so paylaşımlı kütüphanesi oluşturulacak fakat önceki örnekten farklı olarak PostgreSQL desteği için pgsql.so adında ayrı bir paylaşımlı kütüphane oluşturulacaktır. PHP'ye PostgreSQL desteğini, eklentiyi php.ini içinde bir extension yönergesinde belirterek veya doğrudan bir betik içinde dl() işlevini kullanarak verebilirsiniz.

./configure --with-apache=/bir/yer/apache_kaynak_paketi --with-pgsql

Bu yapılandırmayla, bir libmodphp5.a kütüphanesi, mod_php5.c diye bir dosya ve bunlara eşlik eden bazı dosyalar oluşturulacak ve bunlar Apache kaynak ağacının altında src/modules/php5 dizinine kopyalanacaktır. Bundan sonra Apache --activate-module=src/modules/php5/libphp5.a seçeneği kullanılarak derlendiğinde Apache libphp5.a kütüphanesini oluşturacak ve onu httpd çalıştırılabiliri ile duruk olarak ilintileyecektir. PostgreSQL desteği de doğrudan httpd çalıştırılabiliri içinde olacaktır. Böylece sonuçta tek bir httpd çalıştırılabiliri Apache ve PHP'nin tamamını içerecektir.

./configure --with-apache=/bir/yer/apache_kaynak_paketi --with-pgsql=shared

Yukarıdakinden farklı olarak PostgreSQL desteği, doğrudan sonuncu httpd çalıştırılabiliri içinde değil, ayrı bir pgsql.so paylaşımlı kütüphanesiyle php.ini dosyası üzerinden veya doğrudan dl() işlevi kullanılarak PHP'ye yüklemek suretiyle elde edilecektir.

PHP'yi derlemek için seçtiğiniz her yolun getirileri olacağı gibi götürüleri de olacaktır. Paylaşımlı nesne olarak derlemek, Apache'yi ayrı olarak derleyip, PHP ile ilgili hiçbir şey için Apache'yi tekrar derleme ihtiyacı duymamak demektir. PHP'yi Apache içinde (duruk yöntem) derlerseniz PHP daha çabuk yüklenecek ve daha hızlı çalışacaktır. Bu konularda daha ayrıntılı bilgi edinmek için Apache'nin » DSO desteği sayfasına bakınız.

Bilginize:

Apache'nin öntanımlı httpd.conf dosyası şöyle bir bölümle gelmektedir:

User nobody
Group "#-1"
Burada Group satırı, Group nogroup veya Group daemon gibi bir satırla değiştirilmedikçe, PHP dosyaları açamayacaktır.

Bilginize:

--with-apxs=/bir/yer/apxs seçeneğini kullanırken apxs'in kaynak paketindeki yerini değil, sisteminizde kurulu olduğu yeri belirtmeye dikkat edin.

Unix Sistemlere Kurulum
Unix sistemler ve Apache 2.x
Unix Sistemlere Kurulum


Unix sistemler ve Apache 2.x

Bu bölüm Unix sistemlerde PHP'nin Apache 2.x'e kurulumu hakkında bilgiler ve ipuçları içerir.

Uyarı

Apache 2'nin bir hizmet ortamında evreli MPM'lerle kullanımını önermiyoruz. Bunun yerine Apache 2.0 ve 2.2'de öntanımlı MPM olan Prefork MPM'sini kullanmanızı öneririz. Bunun sebebini SSS altında Apache ve evreli MPM'ler başlığı altında bulabilirsiniz.

Apache 2.x HTTP Sunucusu hakkında temel bir bilgi edinmek için mutlaka » Apache HTTP Sunucusu Sürüm 2.x Belgelerine bakmanızı öneririz.

En son sürümü » Apache 2.x indirme sitesinden ve buna uygun PHP sürümünü yukarıda bahsedilen yerlerden indirebilirsiniz. Bu kısa kılavuz Apache 2.x ve PHP hakkında sadece temel bilgi sağlar. Daha ayrıntılı bilgi edinmek için » Apache HTTP Sunucusu Belgelerine bakınız. Kurulum talimatlarının sürüm numaralarından ötürü geçerliliğini yitirmemesi için sürüm numaraları 'NN' şeklinde belirtilmiştir, NN yerine kurulan Apache sürümünün sürüm numarası yazılmalıdır.

Apache 2.x'in şu an iki sürümü mevcuttur: 2.0 ve 2.2. Bunlardan birini seçmek için çeşitli sebepler olabilirse de 2.2 şu an için en son ve önerilen sürümdür. Ancak, burada sözü edilen talimatlar hem 2.0 hem de 2.x için çalışır.

  1. Apache HTTP sunucusunu edindikten sonra şu komutları verin:

    gzip -d httpd-2_x_NN.tar.gz
tar -xf httpd-2_x_NN.tar

  2. Benzer işlemleri PHP için de yapın:

    gunzip php-NN.tar.gz
tar -xf php-NN.tar

  3. Apache'yi derleyip kurun. Apache'nin nasıl derleneceğini Apache kurulumu belgesinden öğrenebilirsinz.

    cd httpd-2_x_NN
./configure --enable-so
make
make install

  4. Böylece standart prefork MPM'si ve yüklenebilir modül desteği ile Apache 2.x.NN /usr/local/apache2 altına kurulmuş oldu. Kurulumu denemek için Apache HTTP sunucusunu normal yollardan başlatabilirsiniz. Örnek:

    /usr/local/apache2/bin/apachectl start
    PHP yapılandırması ile çalıştırmak üzere sunucuyu durdurun:
    /usr/local/apache2/bin/apachectl stop

  5. Şimdi PHP'yi yapılandırıp kurun. Bunu hangi eklentileri etkin kılacaksanız onların seçeneklerini kullanarak yapabilirsiniz. Olası seçeneklerin listesini almak için komut satırına ./configure --help yazın. Örneğimizde Apache ve MySQL desteğini etkin kılacağız.

    Apache'yi yukarıda açklandığı gibi kaynak paketinden derlediyseniz aşağıdaki örnek sizin apxs yolunuzla eşleşecektir. Fakat Apache'yi başka bir şekilde kurduysanız apxs yolunu buna uygun olarak ayarlamalısınız. Bazı dağıtımlar apxs yerine apxs2 ismini kullanır, buna dikkat edin.

    cd ../php-NN
./configure --with-apxs2=/usr/local/apache2/bin/apxs --with-mysql
make
make install

    Eğer kurulumdan sonra yapılandırmanızı değiştirmek isterseniz sadece configure, make ve make install adımlarını yinelemeniz yeterli olacaktır. Yeni modülün etkin olabilmesi için Apache'yi yeniden başlatmanız gerekir. Apache'yi yeniden derlemeniz gerekmez. Aksi özellikle belirtilmedikçe 'make install' ile phpize gibi çeşitli PHP araçları, PEAR, PHP CLI ve bir takım başka şeylerin de kurulumu yapılır.

    Aksi belirtilmedikçe, 'make install' ile phpize gibi çeşitli PHP araçları, PEAR, PHP CLI ve benzerleri de kurulacaktır.

  6. php.ini dosyanızı yapılandırın.

    cp php.ini-development /usr/local/lib/php.ini

    PHP seçeneklerini ayarlamak için .ini dosyanızı düzenleyebilirsiniz. .ini dosyanızın başka bir yerde durmasını istiyorsanız, 5. şıkta --with-config-file-path=/başka/bir/yer seçeneği ile dosyanız için başka bir yer belirtebilirsiniz.

    php.ini-dist yerine php.ini-production (dağıtımın standart .ini dosyası yerine önerilen yapılandırmalar dosyasını) kullanmayı tercih ederseniz, değişiklik listesini okumayı ihmal etmeyin, çünkü bunlar PHP'nin davranışını etkileyecektir.

  7. PHP modülünün yüklenmesi için httpd.conf dosyasını düzenlemelisiniz. LoadModule yönergesinin değeri PHP modülünün sistemdeki yerini göstermelidir. Yukarıdaki 'make install' bunu sizin yerinize yapmıştır ama emin olmak için siz yine de bir bakın.

    LoadModule php5_module modules/libphp5.so

  8. Apache'ye belli dosya uzantılarını PHP uzantıları olarak ele almasını söyleyin. Örneğin, .php uzantılı dosyaları Apache'nin PHP dosyaları olarak ele almasını isteyebiliriz. Apache AddType yönergesini kullanmamak suretiyle, PHP tarafından çalıştırılmak üzere istismar.php.jpg gibi dosyaların oluşturulması ve yüklenmesi gibi tehlikeli durumlardan kaçınmak isteyebilirsiniz. Biz örnek olsun diye .php uzantısını ekledik. Başka uzantıları da buraya ekleyebilirsiniz. Bunları aralarında boşluk bırakarak aynı satıra yazabilirsiniz.

    <FilesMatch \.php$>
    SetHandler application/x-httpd-php
</FilesMatch>

    Veya .php, .php2, .php3, .php4, .php5, .php6 ve .phtml gibi dosyalar dışında hiçbir dosyanın PHP tarafından çalıştırılmamasını şöyle sağlayabilirsiniz:

    <FilesMatch "\.ph(p[2-6]?|tml)$">
    SetHandler application/x-httpd-php
</FilesMatch>

    PHP kaynak kodlarını renklendirilmiş olarak göstermek için .phps uzantısını da yapılandırmanıza ekleyebilirsiniz. Bu, şöyle yapılır:

    <FilesMatch "\.phps$">
    SetHandler application/x-httpd-php-source
</FilesMatch>

    .php dosyalarının uzantılarını .phps olarak değiştirmeden kaynak kodlarını renklendirilmiş olarak göstermek isterseniz bunu şöyle yapabilirsiniz:

    RewriteEngine On
RewriteRule (.*\.php)s$ $1 [H=application/x-httpd-php-source]

    PHP kaynak süzgeci, gizli kalması gereken bilgiler içeren genel kullanıma açık sunucularda kullanılmamalıdır. Aksi takdirde gizli kalması gereken bilgiler kaynak koda eklenebilir.

  9. Artık Apache'yi başlatabilirsiniz. Bunun için Apache'yi her zaman ki gibi başlatmanız yetecektir:

    /usr/local/apache2/bin/apachectl start

    VEYA

    service httpd restart

Yukarıdaki adımları izleyerek PHP'nin bir SAPI modülü olarak çalıştığı bir Apache 2 HTTP sunucusuna sahip olursunuz. Apache ve PHP için şüphesiz birçok farklı yapılandırma seçeneği vardır. Yapılandırma seçeneklerinin listesi için her kaynak ağacında ./configure --help çalıştırabilirsiniz.

Apache derlenirken prefork MPM modülü yerine , worker MPM modülü seçilerek çok evreli derlenebilir. Bunu yapmak için 3. şıkta derleme seçeneklerinize şu seçeneğini ekleyebilirsiniz:

--with-mpm=worker

Bunu yapmadan önce, bunun olası sonuçları hakkında bilgi sahibi olmaya, azından ne gibi etkilerinin olacağını anlamaya çalışın. Bu konuda daha ayrıntılı bilgi edinmek için Apache HTTP sunucusunun belgelerinden » Çok Süreçlilik Modülleri (MPM'ler) belgesini okuyunuz.

Bilginize:

İçerik dili uzlaşımı kullanmak isterseniz Apache MultiViews SSS'ine bakınız.

Bilginize:

Ayrıca, PHP'yi deneysel Zend Thread Safety (ZTS) motoru ile de derleyebilirsiniz. Böyle bir yapılandırmada bütün eklentiler kullanılamayacaktır. Bu bakımdan Apache'yi standart prefork MPM'si ile derlemenizi öneriyoruz.

Unix sistemler ve Apache 1.3.x
Nginx 1.4.x on Unix systems
Unix Sistemlere Kurulum


Nginx 1.4.x on Unix systems

This documentation will cover installing and configuring PHP with PHP-FPM for a Nginx 1.4.x HTTP server.

This guide will assume that you have built Nginx from source and therefore all binaries and configuration files are located at /usr/local/nginx. If this is not the case and you have obtained Nginx through other means then please refer to the » Nginx Wiki in order to translate this manual to your setup.

This guide will cover the basics of configuring an Nginx server to process PHP applications and serve them on port 80, it is recommended that you study the Nginx and PHP-FPM documentation if you wish to optimise your setup past the scope of this documentation.

Please note that throughout this documentation version numbers have been replaced with an 'x' to ensure this documentation stays correct in the future, please replace these as necessary with the corresponding version numbers.

  1. It is recomended that you visit the Nginx Wiki » install page in order to obtain and install Nginx on your system.

  2. Obtain and unpack the PHP source:

    tar zxf php-x.x.x

  3. Configure and build PHP. This is where you customize PHP with various options, like which extensions will be enabled. Run ./configure --help for a list of available options. In our example we'll do a simple configure with PHP-FPM and MySQL support.

    cd ../php-x.x.x
./configure --enable-fpm --with-mysql
make
sudo make install

  4. Obtain and move configuration files to their correct locations

    cp php.ini-development /usr/local/php/php.ini
cp /usr/local/etc/php-fpm.conf.default /usr/local/etc/php-fpm.conf
cp sapi/fpm/php-fpm /usr/local/bin

  5. It is important that we prevent Nginx from passing requests to the PHP-FPM backend if the file does not exists, allowing us to prevent arbitrarily script injection.

    We can fix this by setting the cgi.fix_pathinfo directive to 0 within our php.ini file.

    Load up php.ini:

    vim /usr/local/php/php.ini

    Locate cgi.fix_pathinfo= and modify it as follows:

    cgi.fix_pathinfo=0

  6. php-fpm.conf must be modified to specify that php-fpm must run as the user www-data and the group www-data before we can start the service:

    vim /usr/local/etc/php-fpm.conf

    Find and modify the following:

    ; Unix user/group of processes
; Note: The user is mandatory. If the group is not set, the default user's group
;       will be used.
user = www-data
group = www-data

    The php-fpm service can now be started:

    /usr/local/bin/php-fpm

    This guide will not configure php-fpm any further, if you are interested in further configuring php-fpm then please consult the documentation.

  7. Nginx must now be configured to support the processing of PHP applications:

    vim /usr/local/nginx/conf/nginx.conf

    Modify the default location block to be aware it must attempt to serve .php files:

    location / {
    root   html;
    index  index.php index.html index.htm;
}

    The next step is to ensure that .php files are passed to the PHP-FPM backend. Below the commented default PHP location block, enter the following:

    location ~* \.php$ {
    fastcgi_index   index.php;
    fastcgi_pass    127.0.0.1:9000;
    include         fastcgi_params;
    fastcgi_param   SCRIPT_FILENAME    $document_root$fastcgi_script_name;
    fastcgi_param   SCRIPT_NAME        $fastcgi_script_name;
}

    Restart Nginx.

    sudo /usr/local/nginx/sbin/nginx -s stop
sudo /usr/local/nginx/sbin/nginx

  8. Create a test file

    rm /usr/local/nginx/html/index.html
echo "<?php phpinfo(); ?>" >> /usr/local/nginx/html/index.php

    Now navigate to http://localhost. The phpinfo() should now be shown.

Following the steps above you will have a running Nginx web server with support for PHP as a SAPI module. Of course there are many more configuration options available for Nginx and PHP. For more information type ./configure --help in the corresponding source tree.

Unix sistemler ve Apache 2.x
Unix sistemlerde Lighttpd 1.4
Unix Sistemlere Kurulum


Unix sistemlerde Lighttpd 1.4

Bu bölüm PHP'nin Unix sistemlerde Lighttpd 1.4 ile kurulumu hakkında bilgiler ve ipuçları içerir.

Lütfen devam etmeden önce » Lighttpd redmine sitesini ziyaret edip Lighttpd'nin doğru düzgün nasıl kurulacağını öğreniniz.

PHP ve Lighttpd'ye bağlanmak için tercih edilen SAPI Fastcgi'dir. Fastcgi, PHP 5.3'te php-cgi'yi özdevinimli olarak sihirli bir şekilde etkin kılar. Fakat, eski sürümler için PHP'nin --enable-fastcgi ile derlenmesi gerekir. PHP'nin fastcgi için hazır olduğunu doğrulamak için php -v çıktısının PHP 5.2.5 (cgi-fcgi) içermesi gerekir. PHP 5.2.3 öncesinde, fastcgi, php çalıştırılabiliri üzerinde etkindi (php-cgi diye birşey yoktu).

Letting Lighttpd'ye PHP süreçlerini çatallattırmak

Lighttpd'nin PHP'ye bağlanmasını ve fastcgi süreçlerini çatallamasını sağlamak üzere yapılandırmak için lighttpd.conf dosyasını düzenlemeniz gerekir. Fastcgi süreçlerine yerel sistemden bağlanmak için soketler tercih edilir.

Örnek 1 - lighttpd.conf'tan bir bölüm

server.modules += ( "mod_fastcgi" )

fastcgi.server = ( ".php" =>
  ((
    "socket" => "/tmp/php.socket",
    "bin-path" => "/usr/local/bin/php-cgi",
    "bin-environment" => (
      "PHP_FCGI_CHILDREN" => "16",
      "PHP_FCGI_MAX_REQUESTS" => "10000"
    ),
    "min-procs" => 1,
    "max-procs" => 1,
    "idle-timeout" => 20
  ))
)

bin-path yönergesi lighttpd'nin fastcgi süreçlerini devingen olarak çatallamasına izin verir. PHP kendi çocuklarını PHP_FCGI_CHILDREN ortam değişkenine göre çatallayacaktır. PHP, PHP_FCGI_MAX_REQUESTS değerinin aşılmasına sebep olan çocuk süreci öldürür. PHP'de min-procs ve max-procs yönergelerinden genel olarak kaçınılması gerekir. PHP kendi çocuklarını yönetir ve makine kodu önbelleklerini APC gibi çocukları arasında paylaştırır. min-procs yönergesine 1'den büyük bir değer atanmışsa PHP yanıtçılarının sayısı PHP_FCGI_CHILDREN değerinin katları olacaktır (2 min-procs * 16 çocuk eşittir 32 yanıtçı).

Spawn-fcgi ile çatallama

Lighttpd, fastcgi süreçlerinin çatallanmasını kolaylaştırmak için spawn-fcgi adında bir programla gelir.

php-cgi'nin çatallanması

Süreçleri spawn-fcgi kullanmaksızın çatallamak mümkünse de, biraz ağır kaldırma çalışmak gerekir. Gelen istekleri karşılamak için PHP'nin kaç çocuk çatallayacağı PHP_FCGI_CHILDREN ortam değişkeni ile belirlenir. PHP'nin her çocuğunun kaç isteklik yaşayacağını ise PHP_FCGI_MAX_REQUESTS belirler. Aşağıda, PHP yanıtçılarının çatallanmasına yardımcı olan basit bir bash betiği verilmiştir.

Örnek 2 - FastCGI Yanıtçılarının Çatallanması

#!/bin/sh

# php-cgi çalıştırılabilirinin yeri
PHP=/usr/local/bin/php-cgi

# PID dosyasının yeri
PHP_PID=/tmp/php.pid

# Dinlenecek adres
#FCGI_BIND_ADDRESS=10.0.1.1:10000
# Dinlenecek soket
FCGI_BIND_ADDRESS=/tmp/php.sock

PHP_FCGI_CHILDREN=16
PHP_FCGI_MAX_REQUESTS=10000

env -i PHP_FCGI_CHILDREN=$PHP_FCGI_CHILDREN \
       PHP_FCGI_MAX_REQUESTS=$PHP_FCGI_MAX_REQUESTS \
       $PHP -b $FCGI_BIND_ADDRESS &

echo $! > "$PHP_PID"

Uzak FCGI (nesnel) örneklerine bağlanmak

Uygulamaları dengelemek için Fastcgi örnekleri çok sayıda uzak makineye çatallanabilir.

Örnek 3 - Uzak FCGI örneklerine bağlanmak

fastcgi.server = ( ".php" =>
   (( "host" => "10.0.0.2", "port" => 1030 ),
    ( "host" => "10.0.0.3", "port" => 1030 ))
)
Nginx 1.4.x on Unix systems
Sun Solaris'te Sun, iPlanet ve Netscape Sunucuları
Unix Sistemlere Kurulum


Sun Solaris'te Sun, iPlanet ve Netscape Sunucuları

Bu bölümde, PHP'nin Sun Solaris üzerinde Sun Java Sistem, Sun ONE, iPlanet ve Netscape HTTP Sunucusu kurulumlarına özgü bilgilere ve ipuçlarına yer verilmiştir.

PHP 4.3.3'ten itibaren PHP betikleri NSAPI modülü ile kullanılarak özel dizin listeleri ve hata sayfaları üretebilebilmektedir. Apache uyumluluğu sağlamak için ek işlevler de mevcuttur. Mevcut HTTP sunucuları desteği hakkında bilgi edinmek için alt istekler ile ilgili bölümü okuyunuz.

Netscape Girişimci Sunucusu (NES) için PHP yapılandırması hakkında daha ayrıntılı bilgiyi » http://benoit.noss.free.fr/php/install-php4.html adresinde bulabilirsiniz.

PHP'yi Sun Java Sistem, Sun ONE, iPlanet ve Netscape HTTP sunucularında derlemek için, kurulum dizinini --with-nsapi=[DiZiN] seçeneği ile belirtin; öntanımlı dizin: /opt/netscape/suitespot/. Ayrıca /php-xxx-version/sapi/nsapi/nsapi-readme.txt dosyasını da okuyun.

  1. Aşağıdaki paketleri » http://www.sunfreeware.com/ veya başka bir siteden indirip kurabilirsiniz:

    • autoconf-2.13
    • automake-1.4
    • bison-1_25-sol26-sparc-local
    • flex-2_5_4a-sol26-sparc-local
    • gcc-2_95_2-sol26-sparc-local
    • gzip-1.2.4-sol26-sparc-local
    • m4-1_4-sol26-sparc-local
    • make-3_76_1-sol26-sparc-local
    • mysql-3.23.24-beta (mysql desteği istiyorsanız)
    • perl-5_005_03-sol26-sparc-local
    • tar-1.13 (GNU tar)

  2. PATH ortam değişkeninde gerekli dizinlerin bulunduğundan emin olun ( PATH=.:/usr/local/bin:/usr/sbin:/usr/bin:/usr/ccs/bin) ve export PATH ile sisteminizde kullanılabilir olmasını sağlayın.
  3. gunzip php-x.x.x.tar.gz (.gz paketi değilse 4'e gidin).
  4. tar xvf php-x.x.x.tar
  5. Bu işlem sonucunda oluşan PHP dizinine geçin: cd ../php-x.x.x

  6. Netscape sunucunuz /opt/netscape/suitespot/ dizininde kurulu değilse, aşağıdaki seçeneğe bulunduğu yeri yazın:

    ./configure --with-mysql=/usr/local/mysql \
            --with-nsapi=/opt/netscape/suitespot/ \
            --enable-libgcc

  7. Bir make ve ardından make install yapın.

Temel kurulum bitip ilgili benioku dosyalarını da okuduktan sonra bir kaç adımlık yapılandırma işlemi kalmış olacak.

Sun/iPlanet/Netscape için Yapılandırma Talimatları

Öncelikle, sunucunun bütün paylaşımlı kütüphaneleri bulabilmesi için bazı dizinleri LD_LIBRARY_PATH ortam değişkenine eklemeniz gerekebilir. Bunun yapılacağı en uygun yer HTTP sunucunuzu başlatan betiktir. Bu betik genellikle, /bir/yol/server/https-sunucuismi/start gibi bir dosyadır. HTTP sunucunuzun /bir/yol/server/https-sunucuismi/config/ dizininde yer alan yapılandırma dosyalarını da düzenlemeniz gerekecek.

  1. Aşağıdaki satırı mime.types dosyasına ekleyin (bunu yönetim sunucusunda yapabilirsiniz):

    type=magnus-internal/x-httpd-php exts=php

  2. magnus.conf (>= 6 sürümü sunucular için) veya obj.conf (< 6 sürümü sunucular için) dosyalarını düzenlemek için açın ve aşağıdaki satırları mime types init satırının sonrasına ekleyin. shlib (paylaşımlı kütüphane) sisteminize göre değişiklik gösterebilir, genellikle /opt/netscape/suitespot/bin/libphp4.so gibi bir dosyadır.

    Init fn="load-modules" funcs="php4_init,php4_execute,php4_auth_trans" shlib="/opt/netscape/suitespot/bin/libphp4.so"
Init fn="php4_init" LateInit="yes" errorString="PHP ilklendirilemedi!" [php_ini="/bir/yol/php.ini"]
    (PHP >= 4.3.3) php_ini değiştirgesi isteğe bağlı olsa da oraya HTTP sunucunuzun yapılandırma dizininde bulunan php.ini dosyanızı yerleştirebilirsiniz.

  3. obj.conf dosyasındaki öntanımlı nesneyi yapılandırın (vserver.obj.conf dosyasında sanal sunucu sınıfları [sürüm 6.0+] için):

    <Object name="default">
.
.
.
.#DiKKAT: Bu satır tüm 'ObjectType' satırlarından sonra ve
.#        tüm 'AddLog' satırlarından önce yer almalıdır.
Service fn="php4_execute" type="magnus-internal/x-httpd-php" [inikey=value inikey=value ...]
.
.
</Object>
    (PHP >= 4.3.3) Bazı özel php.ini değerlerini ek değiştirgeler olarak ekleyebilirsiniz, örneğin php4_execute çağrısı bağlamına özgü docroot="/bir/yol/docroot" atamasını yapabilirsiniz. Mantıksal ini yönergeleri için lütfen "On","Off",... değil (çünkü doğru çalışmayacaktır), 0 ve 1 değerlerini kullanınız. Örneğin, zlib.output_compression="On" yerine zlib.output_compression=1 yazın.

  4. Bu sadece, içinde PHP betiklerinden başka dosya bulunmayan (bir cgi-bin dizini gibi) bir dizini yapılandırmak istediğiniz takdirde gerekir :

    <Object name="x-httpd-php">
ObjectType fn="force-type" type="magnus-internal/x-httpd-php"
Service fn=php4_execute [inikey=value inikey=value ...]
</Object>
    Bundan sonra, Yönetim sunucusunda bir dizini yapılandırıp ona x-httpd-php MIME türünü atayabilirsiniz. Bu dizindeki tüm dosyalar PHP tarafından çalıştırılacağından oradaki dosyaların uzantılarını .html olarak değiştirip PHP kullanıldığını gizleyebilirsiniz.

  5. Kimlik doğrulama ayarları: PHP kimlik doğrulaması diğer kimlik doğrulamalarıyla kullanılamaz. Bu işlem tamamen PHP betikleriniz üzerinden geçer. PHP kimlik doğrulamasını sunucunun tamamı için yapılandırmak isterseniz aşağıdaki satırı öntanımlı nesnenize ekleyiniz:

    <Object name="default">
AuthTrans fn=php4_auth_trans
.
.
.
</Object>

  6. PHP kimlik doğrulamasını tek bir dizin için kullanmak istiyorsanız şunu ekleyin:

    <Object ppath="d:\kimlik\dogrulaması\yapilacak\dizin\*">
AuthTrans fn=php4_auth_trans
</Object>

Bilginize:

PHP'nin kullanacağı yığıt boyutu HTTP sunucusunun yapılandırmasına bağlıdır. Çok büyük PHP betiklerinin çalışmaması halinde Yönetim sunucusundan ("MAGNUS EDITOR" bölümünden) boyutu arttırmanızı öneririz.

CGI ortamı ve php.ini dosyasında önerilen değişiklikler

Bir Sun JSWS/Sun ONE WS/iPlanet/Netscape sunucusu çok evreli bir HTTP sunucusu olarak çalıştığı takdirde PHP betiklerinin yazımı özel bir dikkat gerektirir. Bunun sebebi, tüm isteklerin aynı süreç uzayında (HTTP sunucusunun kendi uzayı) çalışması ve bu uzayın (ortam değişkenlerince) tek bir ortama sahip olmasıdır. PATH_INFO, HTTP_HOST gibi CGI ortam değişkenlerini almak isterseniz, bunu getenv() işlevli eski PHP yöntemleriyle veya benzer yollarla ($_ENV gibi küresellerle) yapmaya çalışmak doğru değildir. Geçerli CGI değişkenleri olmaksızın sadece çalışan HTTP sunucusunun ortamını alırsınız!

Bilginize:

Soru: Ortamda neden (geçersiz) CGI değişkenleri var?

Yanıt: Bunun sebebi, HTTP sunucusu sürecini Yönetim sunucusundan başlatmanız ve başlatma betiğinin bir CGI betiği olarak çalışmasıdır (yönetim sunucusu içinde bir CGI betiği!!). Başlatılan HTTP sunucusunun bazı CGI ortam değişkenlerine sahip olmasının sebebi budur. HTTP sunucusunu yönetim sunucusunun dışında çalıştırırsanız bunun sebebini daha iyi anlarsınız. HTTP sunucusunu root kullanıcısı olarak komut satırından kendiniz başlatın ve ortamda artık CGI tarzı ortam değişkenlerinin bulunmadığını görün.

CGI değişkenlerini doğru yöntemle almak için betiklerinizde değişiklik yapmalısınız. PHP 4'te bu işlem için $_SERVER süper küreselini kullanabilirsiniz. $HTTP_HOST gibi değişkenleri kullanan eski betikleriniz varsa php.ini içinde register_globals=On yaptıktan başka değişken sırasını da değiştirin (önemli: Artık ortama ihtiyacınız olmayacağından "E"yi silin):

variables_order = "GPCS"
register_globals = On

Özel dizin listeleri ve hata sayfaları (PHP >= 4.3.3)

"404 Not Found" ve benzeri durumlarda hata sayfaları üretimi için PHP'yi kullanabilirsiniz. Üzerine yazmak istediğiniz her hata sayfası için obj.conf dosyasındaki nesneye aşağıdaki satırı ekleyiniz:

Error fn="php4_execute" code=XXX script="/bir/yol/betik.php" [inikey=value inikey=value...]
Burada XXX, HTTP hata kodudur. Sizinkiyle çelişen başka Error yönergeleri varsa onları silin. Tüm hatalar için hep aynı sayfayı kullanacaksanız code değiştirgesini belirtmeyin. Betiğiniz hata kodunu $_SERVER['ERROR_TYPE'] ile alacaktır.

Bir diğer olanak, özel yapım dizin listeleri üretimidir. Dizin içeriğini gösteren bir PHP betiği yazdıktan sonra, obj.conf dosyasında öntanımlı type="magnus-internal/directory" Service satırını şöyle değiştirin:

Service fn="php4_execute" type="magnus-internal/directory" script="/bir/yol/betik.php" [inikey=value inikey=value...]
Hata sayfaları ve dizin listeleri için özgün yol ve dönüşmüş yol $_SERVER['PATH_INFO'] ve $_SERVER['PATH_TRANSLATED'] değişkenlerinden alınabilir.

nsapi_virtual() ve alt istekler (PHP >= 4.3.3)

NSAPI modülü, HTTP sunucusunda alt istekler yapmak ve sonuçları bir sayfaya yerleştirmek için artık nsapi_virtual() işlevine sahiptir (rumuz: virtual()). Bu işlev NSAPI kütüphanesinin bazı belgelenmemiş özelliklerini kullanır. Unix üzerinde modül özdevinimli olarak gerekli işlevlerin varlığını araştırır ve kullanılabilecekse kullanır. Aksi takdirde, nsapi_virtual() iptal edilir.

Bilginize:

ÖNEMLİ: nsapi_virtual() desteği DENEYSEL'dir!!!

Unix sistemlerde Lighttpd 1.4
CGI ve Komut Satırı Ayarları
Unix Sistemlere Kurulum


CGI ve Komut Satırı Ayarları

PHP, CGI işlemleri için öntanımlı olarak hem bir CLI hem de bir CGI programı olarak derlenir. Bu sayede HTTP sunucuda çalışmayacak betikleri yorumlamak için veya CGI işlemleri için kullanılabilecek bir komut satırı yorumlayıcısı oluşturulmuş olur. PHP'nin bir modül olarak çalıştığı bir HTTP sunucusu genellikle başarım sorunlarına bir çözüm olarak kullanılır. Bununla birlikte, CGI sürümü, farklı PHP sayfalarını farklı kullanıcı kimlikleriyle çalıştırabilme imkanı sunar.

Uyarı

CGI kipinde çalışan bir sunucu olası saldırılara açık hale gelir. Sunucunuzu böyle saldırılardan nasıl koruyacağınızı öğrenmek için CGI güvenliği bölümünü okuyunuz.

Sınama

PHP'yi bir CGI programı olarak derlediyseniz, derlemenizi make test komutunu vererek sınayabilirsiniz. Derlemenizi sınamak daima iyidir. Bu yolla sonradan karşılaşabileceğiniz sorunları daha ortaya çıkmadan yakalama şansınız olur.

Değişkenlerin kullanımı

Bazı sunucu kaynaklı ortam değişkenleri geçerli » CGI/1.1 belirtiminde tanımlanmamıştır; sadece şu değişkenler tanımlıdır: AUTH_TYPE, CONTENT_LENGTH, CONTENT_TYPE, GATEWAY_INTERFACE, PATH_INFO, PATH_TRANSLATED, QUERY_STRING, REMOTE_ADDR, REMOTE_HOST, REMOTE_IDENT, REMOTE_USER, REQUEST_METHOD, SCRIPT_NAME, SERVER_NAME, SERVER_PORT, SERVER_PROTOCOL ve SERVER_SOFTWARE. Bunların dışında kalan herşey 'üretici eklentileri' olarak ele alınmalıdır.

Sun Solaris'te Sun, iPlanet ve Netscape Sunucuları
HP-UX'e Özgü Kurulum Bilgileri
Unix Sistemlere Kurulum


HP-UX'e Özgü Kurulum Bilgileri

Bu bölüm PHP'nin HP-UX sistemlere kurulumu hakkında bilgiler ve ipuçları içerir.

PHP'nin HP-UX sistemlere kurulumunda iki seçenek söz konusudur: Ya kendiniz derlersiniz ya da bir başkasının derlediği çalıştırılabiliri kurarsınız.

Resmi derlenmiş paketleri » http://software.hp.com/ adresinden edinebilirsiniz.

Kılavuzun bu bölümü yazılana kadar, PHP'nin (ve ilgili eklentilerin) HP-UX sistemlerde derlenmesi ile ilgili belgeler kaldırılmıştı. Bunları artık bir dış kaynaktan okuyabileceksiniz: » Building Apache and PHP on HP-UX 11.11

CGI ve Komut Satırı Ayarları
OpenBSD Kurulum Bilgiler
Unix Sistemlere Kurulum


OpenBSD Kurulum Bilgiler

Bu bölüm PHP'nin » OpenBSD 5.8 sistemlere kurulumu hakkında bilgiler ve ipuçları içerir.

İkil Paketlerin Kullanımı

PHP'yi OpenBSD üzerine kurmak için ikil paketlerin kullanımı en basit ve önerilen bir yoldur. Temel paket, modül paketlerinden ayrıdır ve her modül paketi diğerlerinden bağımsız olarak kurulup kaldırılabilir. İhtiyaç duyacağınız dosyaları OpenBSD CD'nizde veya FTP sitesinde bulabilirsiniz.

İhtiyacınız olan ana paket php olup, temel motoru (artı gettext ve iconv) içerir. Modül paketleri ise php-mysql veya php-imap gibi isimler alırlar. Bu modülleri php.ini dosyanızda etkin ve etkisiz kılmak için phpxs komutuna ihtiyacınız olacak.

Örnek 1 - OpenBSD Paket Kurulum Örneği

# pkg_add php
# pkg_add php-fpm
# pkg_add php-mysql
  (PEAR kütüphanesini kur)
# pkg_add pear

Paketlerle ilgili talimatları izle
  (paketleri kaldırmak için)
# pkg_delete php
# pkg_delete php-fpm
# pkg_delete php-mysql
# pkg_delete pear

OpenBSD'deki ikil paketler hakkında ayrıntılı bilgi edinmek için » packages(7) kılavuz sayfasını okuyunuz.

Portların Kullanımı

Ayrıca, PHP'yi kaynak paketinden » port ağacını kullanarak da derleyebilirsiniz. Ancak, bu sadece OpenBSD üzerinde tecrübeli kullanıcılar için önerilebilecek bir yoldur. PHP4 portu iki alt dizine ayrılır: çekirdek ve eklentiler. Eklentilerin bulunduğu dizin desteklenen tüm PHP modülleri için alt paketler üretir. Bu modüllerden üretilmesini istemedikleriniz için no_* FLAVOR'unu kullanınız. Örneğin imap modülünün derlenmeden geçilmesi için FLAVOR'a no_imap atayınız.

Bilinen Sorunlar

  • Apache ve Nginx artık OpenBSD'nin öntanımlı sunucusu olmamakla beraber her ikiksi de portlarda ve paketlerde kolayca bulunabilir. Yeni öntanımlı sunucu 'httpd'dir.
  • httpd'nin öntanımlı kurulumu bir » chroot(2) hücresinde çalışır, böylece PHP betiklerinin /var/www altındaki dosyalara erişmesi engellenir. Bu bakımdan PHP oturum dosyalarının saklanması için ya /var/www/tmp diye bir dizine ya da başka bir oturum arayüzü kullanmaya ihtiyacınız olacaktır. Buna ek olarak, veritabanı soketlerinin de hücre içine yerleştirilmesi veya localhost arayüzünü dinlemesi gerekir. Ağ işlevleri kullanıyorsanız, /etc dizinindeki /etc/resolv.conf ve /etc/services gibi dosyaların /var/www/etc dizinine taşınması gerekecektir. OpenBSD PEAR paketi özdevinimli olarak doğru chroot dizinlerine kurulur.
  • » gd eklentisi için, OpenBSD 5.7+ paketi XFree86'nın kurulu olmasını gerektirir. Bu, kurulum sonrası paketlere eklenerek kurulabilir (OpenBSD FAQ#4'e bakınız).

Eski Dağıtımlar

OpenBSD'nin eski dağıtımları PHP'yi duruk ilintili derlemek için FLAVORS sistemini kullanırlar. Bu yöntemle ikil paketleri üretmek zor olduğundan artık bu yol önerilmemektedir. İsterseniz hala eski port ağaçlarını kullanabilirsiniz fakat OpenBSD ekibi tarafından artık desteklenmemektedirler. Bu konuda fikirleriniz varsa port'un şu anki sürdürücüsü: Anil Madhavapeddy (avsm at openbsd dot org).

HP-UX'e Özgü Kurulum Bilgileri
Solaris'e özgü Kurulum İpuçları
Unix Sistemlere Kurulum


Solaris'e özgü Kurulum İpuçları

Bu bölüm PHP'nin Solaris sistemlere kurulumu hakkında bilgiler ve ipuçları içerir.

Gerekli Yazılımlar

Solaris kurulumlarında sıklıkla C derleyicilerin ve bunlarla ilgili araçların yokluğu sözkonusu olur. Bu araçların GNU sürümlerinin gerekliliği hakkında bilgi edinmek için lütfen SSS'nin bu bölümünü okuyunuz.

PHP paketini açmak için gerekenler:

  • tar
  • gzip veya
  • bzip2

PHP'yi derlemek için gerekenler:

  • gcc (önerilir, fakat başka C derleyiciler de iş görür)
  • make
  • GNU sed

PHP koduyla oynamak veya eklentileri derlemek için ayrıca gerekenler:

  • flex (PHP 5.2'ye kadar)
  • re2c
  • bison
  • m4
  • autoconf
  • automake
Bunlara ek olarak, Oracle veya MySQL gibi yapılandırmanıza özgü bir takım ek yazılımların kurulması da gerekebilir.

Paketlerin kullanımı

Kurulması gereken bileşinlerin çoğunu kurmak için pkgadd kullanarak Solaris kurulum işlemlerini kolaylaştırabilirsiniz. Solaris 11 Express için Image Packaging System (IPS) de pkg komutunu kullanarak kurulum için gereken bileşenlerin çoğunu içermektedir.

OpenBSD Kurulum Bilgiler
Debian GNU/Linux Kurulum Bilgileri
Unix Sistemlere Kurulum


Debian GNU/Linux Kurulum Bilgileri

Bu bölüm Unix sistemlerde PHP'nin » Debian GNU/Linux kurulumu hakkında bilgiler ve ipuçları içerir.

Uyarı

Üçüncü partilerdeki resmi olmayan derlemeler burada desteklenmemektedir. » İndirme alanımızdaki en son paketi alıp aynı hatanın devam ettiğini görmedikçe Debian ekibine herhangi bir yazılım hatası raporlanmamalıdır.

PHP'nin Unix üzerinde derlenmesi ile ilgili talimatlar Debian için de geçerli olsa da bu kılavuz sayfasında ayrıca, hem apt-get hem de aptitude komutlarının kullanımı gibi diğer seçeneklere özgü bilgilere de yer verilmiştir. Bu kılavuz sayfasında bu iki komut kimi zaman diğerinin yerine kullanılmıştır.

APT kullanımı

Öncelikle dikkat edeceğiniz şey, Apache2 ile tümleştirmek için libapache2-mod-php5 ve PEAR ile tümleştirmek için php-pear gibi PHP ile ilgili diğer paketlerinde gerekli olabileceğidir.

İkinci olarak, bir paketi kurmadan önce paket listesini güncellemeniz yerinde bir hareket olacaktır. Bu işlem genellikle apt-get update komutu çalıştırılarık yapılır.

Örnek 1 - Apache2 ile kurulum örneği

# apt-get install php5-common libapache2-mod-php5 php5-cli

APT, Apache2 için hazırlanmış PHP 5 modülünü ve bu modülü etkinleştirmek için bağımlı olduğu diğer paketleri özdevinimli olarak kuracaktır. Yapılan değişikliğin geçerli olması için Apache2 yeniden başlatılmalıdır. Örnek:

Artık herşey yerli yerine oturduğuna göre aşağıdaki örneği izleyerek Apache ve PHP'yi kurabilirsiniz:

Örnek 2 - PHP kurulduktan sonra Apache2'nin dirdirilip yeniden başlatılması

# /etc/init.d/apache2 stop
# /etc/init.d/apache2 start

Yapılandırma üzerinde daha iyi denetim

Bir önceki bölümde PHP sadece çekirdek modüllerle kurulmuştu. Çok geçmeden MySQL, cURL, GD ve benzeri modülleri etkinleştirme ihtiyacı duyabilirsiniz. Bunları da apt-get komutuyla kurabilirsiniz.

Örnek 3 - Ek PHP 5 paketleri listesinin alınma yöntemleri

# apt-cache search php5
# aptitude search php5
# aptitude search php5 |grep -i mysql

Bu örnek komutların çıktısından da görebileceğiniz gibi, php5-cgi, php5-cli ve php5-dev gibi özel paketlerde dahil olmak üzere kurabileceğiniz çok sayıda PHP modülü vardır. Listeyi dikkatlice inceleyip ihtiyacınız olanları seçtikten sonra apt-get veya aptitude ile bunları kurabilirsiniz. Debian bunlar içinde bağımlılık denetimleri yapacağından, örneğin MySQL ve cURL kurmak istediğinizde bunların bağımlı olduğu paketleri de kurmayı teklif edecektir:

Örnek 4 - MySQL ve cURL PHP modüllerinin kurulumu

# apt-get install php5-mysql php5-curl

APT özdevinimli olarak farklı php.ini (/etc/php5/apache2/php.ini, /etc/php5/conf.d/pdo.ini ve benzeri) dosyalarına uygun satırları ve eklentinin türüne bağlı olarak extension=foo.so benzeri girdileri ekleyecektir. Bu değişikliklerin de etkili olabilmesi için Apache2'nin yeniden başlatılması gerekir.

Bilinen sorunlar

  • Bir betiğin sonucu yerine betiğin PHP kaynak kodlarını görüyorsanız, Debian muhtemelen /etc/apache2/apache2.conf dosyasına (veya benzeri bir dosyaya) PHP ile ilgili satırları eklememiştir. Bu konu ile ilgili ayrıntılar için Debian kılavuzuna bakınız.
  • Eğer bir eklenti tanımlı gibi gözüktüğü halde işlevlerini kullanamıyorsanız ilgili ini dosyasının yüklendiğinden ve Apache2'nin yeniden başlatıldığından emin olmalısınız.
  • Debian üzerinde paket kurmak için kullanılabilecek iki temel komut vardır: apt-get ve aptitude. Bu iki komut arasındaki farklar için dağıtımınızla gelen belgelere bakınız.
Solaris'e özgü Kurulum İpuçları
Mac OS X üzerine Kurulum
Unix Sistemlere Kurulum


Mac OS X üzerine Kurulum

İçindekiler

  • Paketlerin Kullanımı
  • Paketlenmiş PHP Kullanımı
  • Compiling PHP on Mac OS X

Bu bölümde, PHP'nin Mac OS X üzerindeki kurulumlarına özgü bilgilere ve ipuçlarına yer verilmiştir. Macs üzerinde PHP'nin kurulumu Unix kurulum kılavuzundakine benzer şekilde yapılır.

Debian GNU/Linux Kurulum Bilgileri
Paketlerin Kullanımı
Yapılandırma ve Kurulum


Paketlerin Kullanımı

PHP'nin Mac OS X için bir kaç tane paketlenmiş ve derlenmiş sürümü vardır. Standart bir yapılandırma için bunlar yeterlidir, ancak farklı özelliklere ihtiyaç duyarsanız (güvenli sunucu, farklı bir veritabanı sürücüsü gibi), kendi PHP'nizi ve/veya HTTP sunucunuzu derlemeniz gerekebilir. Bu işleri yapacak tecrübeniz yoksa, sizin ihtiyaçlarınıza uygun olarak derlenmiş paketlerin olup olmadığını araştırmalısınız.

Aşağıdakiler, Mac OS üzerinde PHP için paket ve derlenmiş ikillerin kurulumunu kolaylaştıracaktır:

  • MacPorts: » http://www.macports.org/
  • Liip: » http://php-osx.liip.ch/
  • Fink: » http://www.finkproject.org/
  • Homebrew: » https://github.com/Homebrew/homebrew-php

Mac OS X üzerine Kurulum
Paketlenmiş PHP Kullanımı
Mac OS X üzerine Kurulum


Paketlenmiş PHP Kullanımı

OS X'in 10.0.0 sürümünden itibaren PHP Meklerde standart hale geldi. PHP'yi öntanımlı HTTP sunucusunda etkin kılmak için Apache yapılandırma dosyası httpd.conf'ta bir kaç satırı etkin duruma getirmek gerekir, bunun yanında CGI ve/veya CLI öntanımlı olarak etkin (Terminal programından kolayca erişilebilir) kılınabilir.

Aşağıdaki talimatları kullanarak PHP'yi etkin kılmak demek çabucak bir yerel geliştirme ortamına sahip olmak demektir. Daima PHP'nin en yeni sürümünü kullanmanızı hararetle öneririz. Gelişimi sürmekte olan çoğu yazılım gibi yeni sürümlerde eski hatalar sürekli düzeltilmekte ve yeni özellikler eklenmektedir. Ayrıntılar için MAC OS X kurulum belgelerine bakınız. Aşağıdaki talimatların ayrıntı düzeyi başlangıç düzeyinde bir kullanıcıya göre olup öntanımlı ayarlarla çalışmak üzere düzenlenmiştir. Daha yeni sürümlerin derlenmesi veya daha yeni paketlerin kurulması tüm kullanıcılara tavsiye edilmektedir.

Standard kurulum türü mod_php kullanmak olup Mac OS X üzerinde Apache HTTP Sunucusu için mod_php'yi etkin kılmak (öntanımlı HTTP sunucusuna Sistem Tercihlerinden erişilebilir) amacıyla şu adımlar izlenmelidir:

  1. Apache yapılandırma dosyasını bulup açın. Öntanımlı olarak yeri: /etc/apache2/httpd.conf Bu dosyanın sahibi root olduğundan ve öntanımlı olarak onun özelinde olduğundan Finder veya Spotlight kullanarak dosyayı bulmak zor olabilir.

    Bilginize: Dosyayı açmanın tek yolu Terminal'de nano gibi Unix temelli bir metin düzenleyici kullanmaktır. Dosyanın sahibi root olduğundan dosyayı (root olarak) açmak için Terminal'de sudo komutunu kullanmalıyız (root parolası istenecektir): sudo nano /etc/apache2/httpd.conf Önemli nano komutları: ^w (arama), ^o (kayıt), and ^x (çıkış). Burada ^ imi, Ctrl tuşu anlamındadır.

    Bilginize: Mac OS X'in 10.5'ten önceki sürümleri PHP ve Apache'nin eski sürümleriyle gelir. Böyle makinelerde Apache yapılandırma dosyası /etc/httpd/httpd.conf olabilir.

  2. Bir metin düzenleyici ile aşağıdaki satırların başlarındaki # imlerini kaldırın (bu iki satır genelde birarada değildir, onları arayıp bulmalısınız):

    # LoadModule php5_module libexec/httpd/libphp5.so

# AddModule mod_php5.c
    Konuma/yola dikkat. PHP'yi gelecekte tekrar derlerseniz yukarıdaki dosyaların yerine yenilerini koymayı unutmayın. Yoksa bu satırları tekrar açıklama haline getirmelisiniz.

  3. PHP olarak yorumlanacak uzantıları belirleyiniz (örnekler: .php .html ve .inc)

    (Mac Panther'den itibaren) httpd.conf dosyasında bulunan aşağıdaki deyimden dolayı PHP etkin kılındığı anda .php uzantılı dosyalar özdevinimli olarak PHP tarafından yorumlanır.

    <IfModule mod_php5.c>
    # php etkinse, .php ve .phps dosyalarını yorumlasın isteriz.
    AddType application/x-httpd-php .php
    AddType application/x-httpd-php-source .phps

    # Çoğu kullanıcı index.php'yi ister
    <IfModule mod_dir.c>
        DirectoryIndex index.html index.php
    </IfModule>
</IfModule>

    Bilginize:

    OS X 10.5 (Leopard) öncesinde, PHP 5 yerine PHP 4 kullanılırdı; dolayısıyla yukarıdaki 5'leri 4'lere çevirmeniz gerekir.

  4. DirectoryIndex yönergesinde belirtilen öntanımlı dizin içerik dosyasının yüklendiğinden emin olun. Bu ayrıca httpd.conf içinde de atanır. Bu amaçla genellikle index.php ve index.html kullanılır. PHP'nin varlığını sınayan yukarıdakı satırlardan dolayı öntanımlı olarak index.php etkindir. Gerekirse bu ayarı kendinize göre değiştirin.
  5. Ya php.ini dosyasının yerini ayarlayın ya da öntanımlıyı kullanın Mac OS X üzerindeki öntanımlı yeri genellikle /usr/local/php/php.ini olup bir phpinfo() işlev çağrısı da yerini gösterecektir. Eğer bir php.ini kullanılmamışsa, PHP öntanımlı değerleri kullanacaktır. php.ini'yi bulmak için SSS'ye bakabilirsiniz.
  6. DocumentRoot'u belirleyip ayarlayın. Bu, HTTP sunucusunun belge kök dizinidir. Bu dizindeki dosyalar HTTP sunucusu tarafından sunulur. Dolayısıyla PHP dosyaları da tarayıcıya gönderilmeden önce PHP tarafından yorumlanır. Genelde öntanımlı belge kök dizini /Library/WebServer/Documents olup httpd.conf dosyasında belirtilmesi gerekir. Ayrıca, her kullanıcının kendi öntanımlı belge kök dizini vardır: /Users/kullanıcı/Sites
  7. Bir phpinfo() dosyası oluşturun

    phpinfo() işlevi PHP ile ilgili bilgileri gösterir. Aşağıdaki içeriğe sahip bir dosyayı belge kök dizininde oluşturun:

    <?php phpinfo(); ?>

  8. Apache'yi yeniden başlatın ve yukarıdaki PHP dosyasını yükleyin

    Apache'yi başlatmak için ya kabukta sudo apachectl graceful komutunu verin ya da OS X Sistem Tercihlerinden "Kişisel HTTP Sunucusu" seçeneğini durdurup başlatın. Öntanımlı olarak, yerel dosyaları tarayıcıya yüklemek için şöyle bir URL kullanılır: http://localhost/info.php. Kullanıcı dizinizdeki belge kök dizinini kullanarak bunu şöyle yapabilirsiniz: http://localhost/~kullanıcı/info.php

CLI (veya eski sürümlerde CGI) çalıştırılabilirinin ismi php olup genellikle bulunduğu yer /usr/bin/php'dir. PHP kılavuzunun komut satırı bölümünü okuyun ve Terminal'i açıp PHP çalıştırılabilirinin sürümünü öğrenmek için php -v komutunu çalıştırın. phpinfo() işlevine yapılacak bir çağrı da bu bilgiyi gösterecektir.

Paketlerin Kullanımı
Compiling PHP on Mac OS X
Mac OS X üzerine Kurulum


Compiling PHP on Mac OS X

Use the Unix installation guide to compile PHP on OS X.

Paketlenmiş PHP Kullanımı
Windows Sistemlerine Kurulum
Mac OS X üzerine Kurulum


Windows Sistemlerine Kurulum

İçindekiler

  • PHP Installer Tools on Windows
  • Recommended Configuration on Windows systems
  • Manual PHP Installation on Windows
  • Troubleshooting PHP on Windows
  • Installation on old Windows systems

PHP'nin günümüz Microsoft Windows sistemlerine kurulumu ve bilinen HTTP sunucularında yapılandırma önerileri.

Bilginize:

Windows XP, 2003, 98 veya Apache 1.x gibi eski sistemler hakkında bilgi arıyorsanız, Eski Bilgiler bölümüne bakınız.

Üretimde kullanım için PHP'nin remi Windows dağıtımlarını kullanmanızı öneririz. Bununla birlikte PHP'yi kaynak kodlarından da derleyebilirsiniz. Bunun için Visual Studio ortamına ihtiyacınız olacak. » Adım Adım Kurulum belgesine bakınız.

  • Windows Komut Satırında PHP Kullanımı

  • Azure üzerinde PHP Kurulumu (Nam-ı diğer Microsoft Azure, Windows Azure veya (Windows) Azure Web Apps).

Compiling PHP on Mac OS X
PHP Installer Tools on Windows
Yapılandırma ve Kurulum


PHP Installer Tools on Windows

PHP Install Tools

If you want to setup PHP, some common PHP applications and are using IIS, the easiest way is to use Microsoft's Web Platform Installer (WebPI).

XAMPP, WampServer and BitNami will setup PHP applications for use with Apache on Windows.

Windows Sistemlerine Kurulum
Recommended Configuration on Windows systems
Windows Sistemlerine Kurulum


Recommended Configuration on Windows systems

OpCache

Highly Recommended that you enable OpCache. This extension is included with PHP for Windows. It compiles and optimizes PHP scripts and caches them in memory so that they aren't compiled every time the page is loaded.

In your php.ini, set

Örnek 1 Recommended OpCache configuration

zend_extension=php_opcache.dll
opcache.enable=On
opcache.cli_enable=On
And restart your web server. For more info, see: OpCache Configuration

WinCache

Recommended that you use WinCache if using IIS, especially if in a shared web hosting environment or using networked file storage (NAS). All PHP Applications automatically benefit from WinCache's file cache feature. File system operations are cached in memory. WinCache also can cache user objects in memory and share them between php.exe or php-cgi.exe processes (share objects between requests). Many major web applications have a plugin or extension or configuration option to make use of the WinCache user object cache. If you need high performance, you should use the object cache in your applications. See: » http://pecl.php.net/package/WinCache to download a WinCache DLL (or tgz) to your PHP extensions directory (extensions_dir in your php.ini). In your php.ini, set

Örnek 2 Recommended WinCache configuration

extension=php_wincache.dll
wincache.fcenabled=1
wincache.ocenabled=1
For more info, see: » http://php.net/manual/en/wincache.configuration.php

IIS Configuration

In IIS Manager, Install FastCGI module and add a handler mapping for `.php` to the path to PHP-CGI.exe (not PHP.exe)

You may use the APPCMD command line tool to script IIS configuration.

Database

You'll probably need a Database Server. Popular databases provide PHP extensions to use them. If your web site doesn't get a lot of traffic, you can run your database server on the same server as your web server. Many popular database servers run on Windows.

PHP includes mysqli and pdo_mysql extensions. PHP 5.5 and 5.6 include mysql extension (deprecated in 7.0).

See » https://dev.mysql.com/downloads/windows/

PHP Installer Tools on Windows
Manual PHP Installation on Windows
Windows Sistemlerine Kurulum


Manual PHP Installation on Windows

Choose Web Server

  • IIS is builtin to Windows. On Windows Server, use Server Manager to add the IIS role. Be sure to include the CGI Role Feature. On Windows Desktop, use Control Panel's Add/Remove Programs to add IIS. See: » https://msdn.microsoft.com/en-us/library/ms181052%28v=vs.80%29.aspx?f=255&MSPPError=-2147217396 For desktop web apps and web-development, you can also use IIS/Express or PHP Desktop

    Örnek 1 Command line to configure IIS and PHP

    @echo off

    REM download .ZIP file of PHP build from http://windows.php.net/downloads/
    REM
    REM path to directory you decompressed PHP .ZIP file into
set phpdir=c:\php
set phppath=php-5.6.19-nts-Win32-VC11-x86

REM Clear current PHP handlers
%windir%\system32\inetsrv\appcmd clear config /section:system.webServer/fastCGI
%windir%\system32\inetsrv\appcmd set config /section:system.webServer/handlers /-[name='PHP_via_FastCGI']

REM Set up the PHP handler
%windir%\system32\inetsrv\appcmd set config /section:system.webServer/fastCGI /+[fullPath='%phpdir%\%phppath%\php-cgi.exe']
%windir%\system32\inetsrv\appcmd set config /section:system.webServer/handlers /+[name='PHP_via_FastCGI',path='*.php',verb='*',modules='FastCgiModule',scriptProcessor='%phpdir%\%phppath%\php-cgi.exe',resourceType='Unspecified']
%windir%\system32\inetsrv\appcmd set config /section:system.webServer/handlers /accessPolicy:Read,Script

REM Configure FastCGI Variables
%windir%\system32\inetsrv\appcmd set config -section:system.webServer/fastCgi /[fullPath='%phpdir%\%phppath%\php-cgi.exe'].instanceMaxRequests:10000
%windir%\system32\inetsrv\appcmd.exe set config -section:system.webServer/fastCgi /+"[fullPath='%phpdir%\%phppath%\php-cgi.exe'].environmentVariables.[name='PHP_FCGI_MAX_REQUESTS',value='10000']"
%windir%\system32\inetsrv\appcmd.exe set config -section:system.webServer/fastCgi /+"[fullPath='%phpdir%\%phppath%\php-cgi.exe'].environmentVariables.[name='PHPRC',value='%phpdir%\%phppath%\php.ini']"
    How to manually configure IIS

  • There are several builds of Apache2 for Windows. We support ApacheLounge, but other options include XAMPP, WampServer and BitNami, which provide automatic installer tools. You may use mod_php or mod_fastcgi to load PHP on Apache. If you use mod_php, you MUST use a TS build of Apache built with same version of Visual C and same CPU (x86 or x64). How to manually configure Apache2

Choose Build

Download PHP production releases from » http://windows.php.net/download/. A lot of testing and optimization is already done on the snapshot and qa releases, but you are welcome to help us do more. There are 4 types of PHP builds:

  • Thread-Safe(TS) - use for single process web serves, like Apache with mod_php

  • Non-Thread-Safe(NTS) - use for IIS and other FastCGI web servers (Apache with mod_fastcgi) and recommended for command-line scripts

  • x86 - production use of PHP 5.5 or 5.6 or 7.0.

  • x64 - production use of PHP 7.0+ unless its a 32-bit only version of Windows. 5.5 and 5.6 x64 are expiremental.

Recommended Configuration on Windows systems
Troubleshooting PHP on Windows
Windows Sistemlerine Kurulum


Troubleshooting PHP on Windows

Check Temp Directory Permissions

  1. Right-click temp directory in File Explorer to get the permissions.

  2. For IIS, check that user IIS_User has MODIFY permission. You can get the temporary directory from the configuration or php info.

Manual PHP Installation on Windows
Installation on old Windows systems
Windows Sistemlerine Kurulum


Installation on old Windows systems

This section applies to Windows 98/Me and Windows NT/2000/XP/2003. PHP will not work on 16 bit platforms such as Windows 3.1 and sometimes we refer to the supported Windows platforms as Win32.

Bilginize:

Windows XP/2003 are no longer supported as of PHP 5.5.0.

Bilginize:

Windows 98/Me/NT4/2000 are no longer supported as of PHP 5.3.0.

Bilginize:

Windows 95 is no longer supported as of PHP 4.3.0.

If you have a development environment such as Microsoft Visual Studio, you can also PHP from the original source code.

Once you have PHP installed on your Windows system, you may also want to load various extensions for added functionality.

Manual Installation Steps

This section contains instructions for manually installing and configuring PHP on Microsoft Windows.

Selecting and downloading the PHP distribution package

Download the PHP zip binary distribution from » PHP for Windows: Binaries and Sources. There are several different versions of the zip package - to choose the right version for you, follow the detailed guide on the » download page.

The PHP package structure and content

Unpack the content of the zip archive into a directory of your choice, for example C:\PHP\. The directory and file structure extracted from the zip will look as below:

Örnek 1 PHP 5 package structure

c:\php
   |
   +--dev
   |  |
   |  |-php5ts.lib                 -- php5.lib in non thread safe version
   |
   +--ext                          -- extension DLLs for PHP
   |  |
   |  |-php_bz2.dll
   |  |
   |  |-php_cpdf.dll
   |  |
   |  |-...
   |
   +--extras                       -- empty
   |
   +--pear                         -- initial copy of PEAR
   |
   |
   |-go-pear.bat                   -- PEAR setup script
   |
   |-...
   |
   |-php-cgi.exe                   -- CGI executable
   |
   |-php-win.exe                   -- executes scripts without an opened command prompt
   |
   |-php.exe                       -- Command line PHP executable (CLI)
   |
   |-...
   |
   |-php.ini-development           -- default php.ini settings
   |
   |-php.ini-production            -- recommended php.ini settings
   |
   |-php5apache2_2.dll             -- does not exist in non thread safe version
   |
   |-php5apache2_2_filter.dll      -- does not exist in non thread safe version
   |
   |-...
   |
   |-php5ts.dll                    -- core PHP DLL ( php5.dll in non thread safe version)
   |
   |-...

Below is the list of the modules and executables included in the PHP zip distribution:

  • go-pear.bat - the PEAR setup script. Refer to » Installation (PEAR) for more details.

  • php-cgi.exe - CGI executable that can be used when running PHP on IIS via CGI or FastCGI.

  • php-win.exe - the PHP executable for executing PHP scripts without using a command line window (for example PHP applications that use Windows GUI).

  • php.exe - the PHP executable for executing PHP scripts within a command line interface (CLI).

  • php5apache2_2.dll - Apache 2.2.X module.

  • php5apache2_2_filter.dll - Apache 2.2.X filter.

Changing the php.ini file

After the php package content has been extracted, copy the php.ini-production into php.ini in the same folder. If necessary, it is also possible to place the php.ini into any other location of your choice but that will require additional configuration steps as described in PHP Configuration.

The php.ini file tells PHP how to configure itself, and how to work with the environment that it runs in. Here are a number of settings for the php.ini file that help PHP work better with Windows. Some of these are optional. There are many other directives that may be relevant to your environment - refer to the list of php.ini directives for more information.

Required directives:

  • extension_dir = <path to extension directory> - The extension_dir needs to point to the directory where PHP extensions files are stored. The path can be absolute (i.e. "C:\PHP\ext") or relative (i.e. ".\ext"). Extensions that are listed lower in the php.ini file need to be located in the extension_dir.

  • extension = xxxxx.dll - For each extension you wish to enable, you need a corresponding "extension=" directive that tells PHP which extensions in the extension_dir to load at startup time.

  • log_errors = On - PHP has an error logging facility that can be used to send errors to a file, or to a service (i.e. syslog) and works in conjunction with the error_log directive below. When running under IIS, the log_errors should be enabled, with a valid error_log.

  • error_log = <path to the error log file> - The error_log needs to specify the absolute, or relative path to the file where PHP errors should be logged. This file needs to be writable for the web server. The most common places for this file are in various TEMP directories, for example "C:\inetpub\temp\php-errors.log".

  • cgi.force_redirect = 0 - This directive is required for running under IIS. It is a directory security facility required by many other web servers. However, enabling it under IIS will cause the PHP engine to fail on Windows.

  • cgi.fix_pathinfo = 1 - This lets PHP access real path info following the CGI Spec. The IIS FastCGI implementation needs this set.

  • fastcgi.impersonate = 1 - FastCGI under IIS supports the ability to impersonate security tokens of the calling client. This allows IIS to define the security context that the request runs under.

  • fastcgi.logging = 0 - FastCGI logging should be disabled on IIS. If it is left enabled, then any messages of any class are treated by FastCGI as error conditions which will cause IIS to generate an HTTP 500 exception.

Optional directives

  • max_execution_time = ## - This directive tells PHP the maximum amount of time that it can spend executing any given script. The default for this is 30 seconds. Increase the value of this directive if PHP application take long time to execute.

  • memory_limit = ###M - The amount of memory available for the PHP process, in Megabytes. The default is 128, which is fine for most PHP applications. Some of the more complex ones might need more.

  • display_errors = Off - This directive tells PHP whether to include any error messages in the stream that it returns to the Web server. If this is set to "On", then PHP will send whichever classes of errors that you define with the error_reporting directive back to web server as part of the error stream. For security reasons it is recommended to set it to "Off" on production servers in order not to reveal any security sensitive information that is often included in the error messages.

  • open_basedir = <paths to directories, separated by semicolon>, e.g. openbasedir="C:\inetpub\wwwroot;C:\inetpub\temp". This directive specified the directory paths where PHP is allowed to perform file system operations. Any file operation outside of the specified paths will result in an error. This directive is especially useful for locking down the PHP installation in shared hosting environments to prevent PHP scripts from accessing any files outside of the web site's root directory.

  • upload_max_filesize = ###M and post_max_size = ###M - The maximum allowed size of an uploaded file and post data respectively. The values of these directives should be increased if PHP applications need to perform large uploads, such as for example photos or video files.

PHP is now setup on your system. The next step is to choose a web server, and enable it to run PHP. Choose a web server from the table of contents.

In addition to running PHP via a web server, PHP can run from the command line just like a .BAT script. See

Microsoft IIS

This section contains PHP installation instructions specific to Microsoft Internet Information Services (IIS).

  • Manually installing PHP on Microsoft IIS 5.1 and IIS 6.0
  • Manually installing PHP on Microsoft IIS 7.0 and later

Microsoft IIS 5.1 and IIS 6.0

This section contains instructions for manually setting up Internet Information Services (IIS) 5.1 and IIS 6.0 to work with PHP on Microsoft Windows XP and Windows Server 2003. For instructions on setting up IIS 7.0 and later versions on Windows Vista, Windows Server 2008, Windows 7 and Windows Server 2008 R2 refer to Microsoft IIS 7.0 and later.

Configuring IIS to process PHP requests

Download and install PHP in accordance to the instructions described in manual installation steps

Bilginize:

Non-thread-safe build of PHP is recommended when using IIS. The non-thread-safe builds are available at » PHP for Windows: Binaries and Sources Releases.

Configure the CGI- and FastCGI-specific settings in php.ini file as shown below:

Örnek 2 CGI and FastCGI settings in php.ini

fastcgi.impersonate = 1
fastcgi.logging = 0
cgi.fix_pathinfo=1
cgi.force_redirect = 0

Download and install the » Microsoft FastCGI Extension for IIS 5.1 and 6.0. The extension is available for 32-bit and 64-bit platforms - select the right download package for your platform.

Configure the FastCGI extension to handle PHP-specific requests by running the command shown below. Replace the value of the "-path" parameter with the absolute file path to the php-cgi.exe file.

Örnek 3 Configuring FastCGI extension to handle PHP requests

cscript %windir%\system32\inetsrv\fcgiconfig.js -add -section:"PHP" ^
-extension:php -path:"C:\PHP\php-cgi.exe"

This command will create an IIS script mapping for *.php file extension, which will result in all URLs that end with .php being handled by FastCGI extension. Also, it will configure FastCGI extension to use the executable php-cgi.exe to process the PHP requests.

Bilginize:

At this point the required installation and configuration steps are completed. The remaining instructions below are optional but highly recommended for achieving optimal functionality and performance of PHP on IIS.

Impersonation and file system access

It is recommended to enable FastCGI impersonation in PHP when using IIS. This is controlled by the fastcgi.impersonate directive in php.ini file. When impersonation is enabled, PHP will perform all the file system operations on behalf of the user account that has been determined by IIS authentication. This ensures that even if the same PHP process is shared across different IIS web sites, the PHP scripts in those web sites will not be able to access each others' files as long as different user accounts are used for IIS authentication on each web site.

For example IIS 5.1 and IIS 6.0, in its default configuration, has anonymous authentication enabled with built-in user account IUSR_<MACHINE_NAME> used as a default identity. This means that in order for IIS to execute PHP scripts, it is necessary to grant IUSR_<MACHINE_NAME> account read permission on those scripts. If PHP applications need to perform write operations on certain files or write files into some folders then IUSR_<MACHINE_NAME> account should have write permission to those.

To determine which user account is used by IIS anonymous authentication, follow these steps:

  1. In the Windows Start Menu choose "Run:", type "inetmgr" and click "Ok";

  2. Expand the list of web sites under the "Web Sites" node in the tree view, right-click on a web site that is being used and select "Properties";

  3. Click the "Directory Security" tab;

  4. Take note of a "User name:" field in the "Authentication Methods" dialog

Anonymous authenication for IIS 5.1 and IIS 6.0

To modify the permissions settings on files and folders, use the Windows Explorer user interface or icacls command.

Örnek 4 Configuring file access permissions

icacls C:\inetpub\wwwroot\upload /grant IUSR:(OI)(CI)(M)

Set index.php as a default document in IIS

The IIS default documents are used for HTTP requests that do not specify a document name. With PHP applications, index.php usually acts as a default document. To add index.php to the list of IIS default documents, follow these steps:

  1. In the Windows Start Menu choose "Run:", type "inetmgr" and click "Ok";

  2. Right-click on the "Web Sites" node in the tree view and select "Properties";

  3. Click the "Documents" tab;

  4. Click the "Add..." button and enter "index.php" for the "Default content page:".

Setting index.php as default document for IIS

FastCGI and PHP Recycling configuration

Configure IIS FastCGI extension settings for recycling of PHP processes by using the commands shown below. The FastCGI setting instanceMaxRequests controls how many requests will be processed by a single php-cgi.exe process before FastCGI extension shuts it down. The PHP environment variable PHP_FCGI_MAX_REQUESTS controls how many requests a single php-cgi.exe process will handle before it recycles itself. Make sure that the value specified for FastCGI InstanceMaxRequests setting is less than or equal to the value specified for PHP_FCGI_MAX_REQUESTS.

Örnek 5 Configuring FastCGI and PHP recycling

cscript %windir%\system32\inetsrv\fcgiconfig.js -set -section:"PHP" ^
-InstanceMaxRequests:10000

cscript %windir%\system32\inetsrv\fcgiconfig.js -set -section:"PHP" ^
-EnvironmentVars:PHP_FCGI_MAX_REQUESTS:10000

Configuring FastCGI timeout settings

Increase the timeout settings for FastCGI extension if there are applications that have long running PHP scripts. The two settings that control timeouts are ActivityTimeout and RequestTimeout. Refer to » Configuring FastCGI Extension for IIS 6.0 for more information about those settings.

Örnek 6 Configuring FastCGI timeout settings

cscript %windir%\system32\inetsrv\fcgiconfig.js -set -section:"PHP" ^
-ActivityTimeout:90

cscript %windir%\system32\inetsrv\fcgiconfig.js -set -section:"PHP" ^
-RequestTimeout:90

Changing the Location of php.ini file

PHP searches for php.ini file in several locations and it is possible to change the default locations of php.ini file by using PHPRC environment variable. To instruct PHP to load the configuration file from a custom location run the command shown below. The absolute path to the directory with php.ini file should be specified as a value of PHPRC environment variable.

Örnek 7 Changing the location of php.ini file

cscript %windir%\system32\inetsrv\fcgiconfig.js -set -section:"PHP" ^
-EnvironmentVars:PHPRC:"C:\Some\Directory\"

Microsoft IIS 7.0 and later

This section contains instructions for manually setting up Internet Information Services (IIS) 7.0 and later to work with PHP on Microsoft Windows Vista SP1, Windows 7, Windows Server 2008 and Windows Server 2008 R2. For instructions on setting up IIS 5.1 and IIS 6.0 on Windows XP and Windows Server 2003 refer to Microsoft IIS 5.1 and IIS 6.0.

Enabling FastCGI support in IIS

FastCGI module is disabled in default installation of IIS. The steps to enable it differ based on the version of Windows being used.

To enable FastCGI support on Windows Vista SP1 and Windows 7:

  1. In the Windows Start Menu choose "Run:", type "optionalfeatures.exe" and click "Ok";

  2. In the "Windows Features" dialog expand "Internet Information Services", "World Wide Web Services", "Application Development Features" and then enable the "CGI" checkbox;

  3. Click OK and wait until the installation is complete.

Enabling FastCGI support for IIS7 on Windows Vista SP1 and Windows 7

To enable FastCGI support on Windows Server 2008 and Windows Server 2008 R2:

  1. In the Windows Start Menu choose "Run:", type "CompMgmtLauncher" and click "Ok";

  2. If the "Web Server (IIS)" role is not present under the "Roles" node, then add it by clicking "Add Roles";

  3. If the "Web Server (IIS)" role is present, then click "Add Role Services" and then enable the "CGI" checkbox under "Application Development" group;

  4. Click "Next" and then "Install" and wait for the installation to complete.

Enabling FastCGI support on Windows Server 2008 and Windows Server 2008 R2

Configuring IIS to process PHP requests

Download and install PHP in accordance to the instructions described in manual installation steps

Bilginize:

Non-thread-safe build of PHP is recommended when using IIS. The non-thread-safe builds are available at » PHP for Windows: Binaries and Sources Releases.

Configure the CGI- and FastCGI-specific settings in php.ini file as shown below:

Örnek 8 CGI and FastCGI settings in php.ini

fastcgi.impersonate = 1
fastcgi.logging = 0
cgi.fix_pathinfo=1
cgi.force_redirect = 0

Configure IIS handler mapping for PHP by using either IIS Manager user interface or a command line tool.

Using IIS Manager user interface to create a handler mapping for PHP

Follow these steps to create an IIS handler mapping for PHP in IIS Manager user interface:

  1. In the Windows Start Menu choose "Run:", type "inetmgr" and click "Ok";

  2. In the IIS Manager user interface select the server node in the "Connections" tree view;

  3. In the "Features View" page open the "Handler Mappings" feature;

    Create IIS handler mapping for PHP : Locate Handler Mappings

  4. In the "Actions" pane click "Add Module Mapping...";

  5. In the "Add Module Mapping" dialog enter the following:

    • Request path: *.php
    • Module: FastCgiModule
    • Executable: C:\[Path to PHP installation]\php-cgi.exe
    • Name: PHP_via_FastCGI

  6. Click "Request Restrictions" button and then configure the mapping to invoke handler only if request is mapped to a file or a folder;

  7. Click OK on all the dialogs to save the configuration.

Create IIS handler mapping for PHP : Add Handler Mapping

Using command line tool to create a handler mapping for PHP

Use the command shown below to create an IIS FastCGI process pool which will use php-cgi.exe executable for processing PHP requests. Replace the value of the fullPath parameter with the absolute file path to the php-cgi.exe file.

Örnek 9 Creating IIS FastCGI process pool

%windir%\system32\inetsrv\appcmd set config /section:system.webServer/fastCGI ^
/+[fullPath='c:\PHP\php-cgi.exe']

Configure IIS to handle PHP specific requests by running the command shown below. Replace the value of the scriptProcessor parameter with the absolute file path to the php-cgi.exe file.

Örnek 10 Creating handler mapping for PHP requests

%windir%\system32\inetsrv\appcmd set config /section:system.webServer/handlers ^
/+[name='PHP_via_FastCGI', path='*.php',verb='*',modules='FastCgiModule',^
scriptProcessor='c:\PHP\php-cgi.exe',resourceType='Either']

This command creates an IIS handler mapping for *.php file extension, which will result in all URLs that end with .php being handled by FastCGI module.

Bilginize:

At this point the required installation and configuration steps are completed. The remaining instructions below are optional but highly recommended for achieving optimal functionality and performance of PHP on IIS.

Impersonation and file system access

It is recommended to enable FastCGI impersonation in PHP when using IIS. This is controlled by the fastcgi.impersonate directive in php.ini file. When impersonation is enabled, PHP will perform all the file system operations on behalf of the user account that has been determined by IIS authentication. This ensures that even if the same PHP process is shared across different IIS web sites, the PHP scripts in those web sites will not be able to access each other's files as long as different user accounts are used for IIS authentication on each web site.

For example IIS 7, in its default configuration, has anonymous authentication enabled with built-in user account IUSR used as a default identity. This means that in order for IIS to execute PHP scripts, it is necessary to grant IUSR account read permission on those scripts. If PHP applications need to perform write operations on certain files or write files into some folders then IUSR account should have write permission to those.

To determine what user account is used as an anonymous identity in IIS 7 use the following command. Replace the "Default Web Site" with the name of IIS web site that you use. In the output XML configuration element look for the userName attribute.

Örnek 11 Determining the account used as IIS anonymous identity

%windir%\system32\inetsrv\appcmd.exe list config "Default Web Site" ^
/section:anonymousAuthentication

<system.webServer>
  <security>
    <authentication>
      <anonymousAuthentication enabled="true" userName="IUSR" />
    </authentication>
   </security>
</system.webServer>

Bilginize:

If userName attribute is not present in the anonymousAuthentication element, or is set to an empty string, then it means that the application pool identity is used as an anonymous identity for that web site.

To modify the permissions settings on files and folders, use the Windows Explorer user interface or icacls command.

Örnek 12 Configuring file access permissions

icacls C:\inetpub\wwwroot\upload /grant IUSR:(OI)(CI)(M)

Set index.php as a default document in IIS

The IIS default documents are used for HTTP requests that do not specify a document name. With PHP applications, index.php usually acts as a default document. To add index.php to the list of IIS default documents, use this command:

Örnek 13 Set index.php as a default document in IIS

%windir%\system32\inetsrv\appcmd.exe set config ^
-section:system.webServer/defaultDocument /+"files.[value='index.php']" ^
/commit:apphost

FastCGI and PHP Recycling configuration

Configure IIS FastCGI settings for recycling of PHP processes by using the commands shown below. The FastCGI setting instanceMaxRequests controls how many requests will be processed by a single php-cgi.exe process before IIS shuts it down. The PHP environment variable PHP_FCGI_MAX_REQUESTS controls how many requests a single php-cgi.exe process will handle before it recycles itself. Make sure that the value specified for FastCGI InstanceMaxRequests setting is less than or equal to the value specified for PHP_FCGI_MAX_REQUESTS.

Örnek 14 Configuring FastCGI and PHP recycling

%windir%\system32\inetsrv\appcmd.exe set config -section:system.webServer/fastCgi ^
/[fullPath='c:\php\php-cgi.exe'].instanceMaxRequests:10000

%windir%\system32\inetsrv\appcmd.exe set config -section:system.webServer/fastCgi ^
/+"[fullPath='C:\{php_folder}\php-cgi.exe'].environmentVariables.^
[name='PHP_FCGI_MAX_REQUESTS',value='10000']"

FastCGI timeout settings

Increase the timeout settings for FastCGI if it is expected to have long running PHP scripts. The two settings that control timeouts are activityTimeout and requestTimeout. Use the commands below to change the timeout settings. Make sure to replace the value in the fullPath parameter to contain the absolute path to the php-cgi.exe file.

Örnek 15 Configuring FastCGI timeout settings

%windir%\system32\inetsrv\appcmd.exe set config -section:system.webServer/fastCgi ^
/[fullPath='C:\php\php-cgi.exe',arguments=''].activityTimeout:"90"  /commit:apphost

%windir%\system32\inetsrv\appcmd.exe set config -section:system.webServer/fastCgi ^
/[fullPath='C:\php\php-cgi.exe',arguments=''].requestTimeout:"90"  /commit:apphost

Changing the Location of php.ini file

PHP searches for php.ini file in several locations and it is possible to change the default locations of php.ini file by using PHPRC environment variable. To instruct PHP to load the configuration file from a custom location run the command shown below. The absolute path to the directory with php.ini file should be specified as a value of PHPRC environment variable.

Örnek 16 Changing the location of php.ini file

appcmd.exe set config  -section:system.webServer/fastCgi ^
/+"[fullPath='C:\php\php.exe',arguments=''].environmentVariables.^
[name='PHPRC',value='C:\Some\Directory\']" /commit:apphost

Apache 1.3.x on Microsoft Windows

This section contains notes and hints specific to Apache 1.3.x installs of PHP on Microsoft Windows systems. There are also

Bilginize:

Please read the manual installation steps first!

There are two ways to set up PHP to work with Apache 1.3.x on Windows. One is to use the CGI binary (php.exe for PHP 4 and php-cgi.exe for PHP 5), the other is to use the Apache Module DLL. In either case you need to edit your httpd.conf to configure Apache to work with PHP, and then restart the server.

It is worth noting here that now the SAPI module has been made more stable under Windows, we recommend it's use above the CGI binary, since it is more transparent and secure.

Although there can be a few variations of configuring PHP under Apache, these are simple enough to be used by the newcomer. Please consult the Apache Documentation for further configuration directives.

After changing the configuration file, remember to restart the server, for example, NET STOP APACHE followed by NET START APACHE, if you run Apache as a Windows Service, or use your regular shortcuts.

Bilginize: Windows üzerinde, Apache yapılandırma dosyalarına c:\dizin\dosya.uzn gibi dosya yollarını eklerken tüm tersbölü çizgilerini normal bölü çizgilerine çevirmeyi unutmayınız: c:/dizin/dosya.uzn. Dizin yollarını eklerken sona da bir bölü çizgisi eklemeniz gerekebilir.

Installing as an Apache module

You should add the following lines to your Apache httpd.conf file:

Örnek 17 PHP as an Apache 1.3.x module

This assumes PHP is installed to c:\php. Adjust the path if this is not the case.

For PHP 4:

# Add to the end of the LoadModule section
# Don't forget to copy this file from the sapi directory!
LoadModule php4_module "C:/php/php4apache.dll"

# Add to the end of the AddModule section
AddModule mod_php4.c

For PHP 5:

# Add to the end of the LoadModule section
LoadModule php5_module "C:/php/php5apache.dll"

# Add to the end of the AddModule section
AddModule mod_php5.c

For both:

# Add this line inside the <IfModule mod_mime.c> conditional brace
AddType application/x-httpd-php .php

# For syntax highlighted .phps files, also add
AddType application/x-httpd-php-source .phps

Installing as a CGI binary

If you unzipped the PHP package to C:\php\ as described in the Manual Installation Steps section, you need to insert these lines to your Apache configuration file to set up the CGI binary:

Örnek 18 PHP and Apache 1.3.x as CGI

ScriptAlias /php/ "c:/php/"
AddType application/x-httpd-php .php

# For PHP 4
Action application/x-httpd-php "/php/php.exe"

# For PHP 5
Action application/x-httpd-php "/php/php-cgi.exe"

# specify the directory where php.ini is
SetEnv PHPRC C:/php
Note that the second line in the list above can be found in the actual versions of httpd.conf, but it is commented out. Remember also to substitute the c:/php/ for your actual path to PHP.

Uyarı

CGI kipinde çalışan bir sunucu olası saldırılara açık hale gelir. Sunucunuzu böyle saldırılardan nasıl koruyacağınızı öğrenmek için CGI güvenliği bölümünü okuyunuz.

If you would like to present PHP source files syntax highlighted, there is no such convenient option as with the module version of PHP. If you chose to configure Apache to use PHP as a CGI binary, you will need to use the highlight_file() function. To do this simply create a PHP script file and add this code: <?php highlight_file('some_php_script.php'); ?>.

Apache 2.x on Microsoft Windows

This section contains notes and hints specific to Apache 2.x installs of PHP on Microsoft Windows systems. We also

Bilginize:

You should read the manual installation steps first!

Bilginize: Apache 2.2 Support

Users of Apache 2.2 should note that the DLL file for Apache 2.2 is named php5apache2_2.dll rather than php5apache2.dll and is available only for PHP 5.2.0 and later.

You are strongly encouraged to consult the » Apache Documentation to get a basic understanding of the Apache 2.x Server. Also consider reading the » Windows specific notes for Apache 2.x before reading on here.

Apache 2.x is designed to run on the Windows version designated as server platforms, such as Windows NT 4.0, Windows 2000, Windows XP, or Windows 7. While Apache 2.x works tolerably well on Windows 9x, support on these platforms is incomplete, and some things will not work correctly. There is no plan to remedy this situation.

Download the most recent version of » Apache 2.x and a fitting PHP version. Follow the Manual Installation Steps and come back to go on with the integration of PHP and Apache.

There are three ways to set up PHP to work with Apache 2.x on Windows. You can run PHP as a handler, as a CGI, or under FastCGI.

Bilginize: Windows üzerinde, Apache yapılandırma dosyalarına c:\dizin\dosya.uzn gibi dosya yollarını eklerken tüm tersbölü çizgilerini normal bölü çizgilerine çevirmeyi unutmayınız: c:/dizin/dosya.uzn. Dizin yollarını eklerken sona da bir bölü çizgisi eklemeniz gerekebilir.

Installing as an Apache handler

You need to insert the following lines into your Apache httpd.conf configuration file to load the PHP module for Apache 2.x:

Örnek 19 PHP and Apache 2.x as handler

#
LoadModule php5_module "c:/php/php5apache2.dll"
AddHandler application/x-httpd-php .php

# configure the path to php.ini
PHPIniDir "C:/php"

Bilginize: Remember to substitute your actual path to PHP for the C:/php/ in the above examples. Take care to use either php5apache2.dll or php5apache2_2.dll in your LoadModule directive and verify that the referenced file is in fact located at the file path that you point to in this directive.

The above configuration will enable PHP handling of any file that has a .php extension, even if there are other file extensions. For example, a file named example.php.txt will be executed by the PHP handler. To ensure that only files that end in .php are executed, use the following configuration instead:

<FilesMatch \.php$>
      SetHandler application/x-httpd-php
 </FilesMatch>

Running PHP as CGI

You should consult the » Apache CGI documentation for a more complete understanding of running CGI on Apache.

To run PHP as CGI, you'll need to place your php-cgi files in a directory designated as a CGI directory using the ScriptAlias directive.

You will then need to insert a #! line in the PHP files, pointing to the location of your PHP binary:

Örnek 20 PHP and Apache 2.x as CGI

#!C:/php/php.exe
<?php
  phpinfo();
?>

Uyarı

CGI kipinde çalışan bir sunucu olası saldırılara açık hale gelir. Sunucunuzu böyle saldırılardan nasıl koruyacağınızı öğrenmek için CGI güvenliği bölümünü okuyunuz.

Running PHP under FastCGI

Running PHP under FastCGI has a number of advantages over running it as a CGI. Setting it up this way is fairly straightforward:

Obtain mod_fcgid from » http://httpd.apache.org/mod_fcgid/. Win32 binaries are available for download from that site. Install the module according to the instructions that will come with it.

Configure your web server as shown below, taking care to adjust any paths to reflect your how you have installed things on your particular system:

Örnek 21 Configure Apache to run PHP as FastCGI

LoadModule fcgid_module modules/mod_fcgid.so

# Where is your php.ini file?
FcgidInitialEnv PHPRC        "c:/php"

AddHandler fcgid-script .php
FcgidWrapper "c:/php/php-cgi.exe" .php
Files with a .php extension will now be executed by the PHP FastCGI wrapper.

Sun, iPlanet and Netscape servers on Microsoft Windows

This section contains notes and hints specific to Sun Java System Web Server, Sun ONE Web Server, iPlanet and Netscape server installs of PHP on Windows.

From PHP 4.3.3 on you can use PHP scripts with the NSAPI module to Apache compatibility are also available. For support in current web servers

CGI setup on Sun, iPlanet and Netscape servers

To install PHP as a CGI handler, do the following:

  • Copy php4ts.dll to your systemroot (the directory where you installed Windows)

  • Make a file association from the command line. Type the following two lines:

    assoc .php=PHPScript
ftype PHPScript=c:\php\php.exe %1 %*

  • In the Netscape Enterprise Administration Server create a dummy shellcgi directory and remove it just after (this step creates 5 important lines in obj.conf and allow the web server to handle shellcgi scripts).
  • In the Netscape Enterprise Administration Server create a new mime type (Category: type, Content-Type: magnus-internal/shellcgi, File Suffix:php).
  • Do it for each web server instance you want PHP to run

More details about setting up PHP as a CGI executable can be found here: » http://benoit.noss.free.fr/php/install-php.html

NSAPI setup on Sun, iPlanet and Netscape servers

To install PHP with NSAPI, do the following:

  • Copy php4ts.dll to your systemroot (the directory where you installed Windows)

  • Make a file association from the command line. Type the following two lines:

    assoc .php=PHPScript
ftype PHPScript=c:\php\php.exe %1 %*

  • In the Netscape Enterprise Administration Server create a new mime type (Category: type, Content-Type: magnus-internal/x-httpd-php, File Suffix: php).

  • Edit magnus.conf (for servers >= 6) or obj.conf (for servers < 6) and add the following: You should place the lines after mime types init.

    Init fn="load-modules" funcs="php4_init,php4_execute,php4_auth_trans" shlib="c:/php/sapi/php4nsapi.dll"
Init fn="php4_init" LateInit="yes" errorString="Failed to initialise PHP!" [php_ini="c:/path/to/php.ini"]
    (PHP >= 4.3.3) The php_ini parameter is optional but with it you can place your php.ini in your web server configuration directory.

  • Configure the default object in obj.conf (for virtual server classes [Sun Web Server 6.0+] in their vserver.obj.conf): In the <Object name="default"> section, place this line necessarily after all 'ObjectType' and before all 'AddLog' lines:

    Service fn="php4_execute" type="magnus-internal/x-httpd-php" [inikey=value inikey=value ...]
    (PHP >= 4.3.3) As additional parameters you can add some special php.ini-values, for example you can set a docroot="/path/to/docroot" specific to the context php4_execute is called. For boolean ini-keys please use 0/1 as value, not "On","Off",... (this will not work correctly), e.g. zlib.output_compression=1 instead of zlib.output_compression="On"

  • This is only needed if you want to configure a directory that only consists of PHP scripts (same like a cgi-bin directory):

    <Object name="x-httpd-php">
ObjectType fn="force-type" type="magnus-internal/x-httpd-php"
Service fn=php4_execute [inikey=value inikey=value ...]
</Object>
    After that you can configure a directory in the Administration server and assign it the style x-httpd-php. All files in it will get executed as PHP. This is nice to hide PHP usage by renaming files to .html.

  • Restart your web service and apply changes
  • Do it for each web server instance you want PHP to run

Bilginize:

More details about setting up PHP as an NSAPI filter can be found here: » http://benoit.noss.free.fr/php/install-php4.html

Bilginize:

The stacksize that PHP uses depends on the configuration of the web server. If you get crashes with very large PHP scripts, it is recommended to raise it with the Admin Server (in the section "MAGNUS EDITOR").

CGI environment and recommended modifications in php.ini

Important when writing PHP scripts is the fact that Sun JSWS/Sun ONE WS/iPlanet/Netscape is a multithreaded web server. Because of that all requests are running in the same process space (the space of the web server itself) and this space has only one environment. If you want to get CGI variables like PATH_INFO, HTTP_HOST etc. it is not the correct way to try this in the old PHP way with getenv() or a similar way (register globals to environment, $_ENV). You would only get the environment of the running web server without any valid CGI variables!

Bilginize:

Why are there (invalid) CGI variables in the environment?

Answer: This is because you started the web server process from the admin server which runs the startup script of the web server, you wanted to start, as a CGI script (a CGI script inside of the admin server!). This is why the environment of the started web server has some CGI environment variables in it. You can test this by starting the web server not from the administration server. Use the command line as root user and start it manually - you will see there are no CGI-like environment variables.

Simply change your scripts to get CGI variables in the correct way for PHP 4.x by using the superglobal $_SERVER. If you have older scripts which use $HTTP_HOST, etc., you should turn on register_globals in php.ini and change the variable order too (important: remove "E" from it, because you do not need the environment here):

variables_order = "GPCS"
register_globals = On

Special use for error pages or self-made directory listings (PHP >= 4.3.3)

You can use PHP to generate the error pages for "404 Not Found" or similar. Add the following line to the object in obj.conf for every error page you want to overwrite:

Error fn="php4_execute" code=XXX script="/path/to/script.php" [inikey=value inikey=value...]
where XXX is the HTTP error code. Please delete any other Error directives which could interfere with yours. If you want to place a page for all errors that could exist, leave the code parameter out. Your script can get the HTTP status code with $_SERVER['ERROR_TYPE'].

Another possibility is to generate self-made directory listings. Just create a PHP script which displays a directory listing and replace the corresponding default Service line for type="magnus-internal/directory" in obj.conf with the following:

Service fn="php4_execute" type="magnus-internal/directory" script="/path/to/script.php" [inikey=value inikey=value...]
For both error and directory listing pages the original URI and translated URI are in the variables $_SERVER['PATH_INFO'] and $_SERVER['PATH_TRANSLATED'].

Note about nsapi_virtual() and subrequests (PHP >= 4.3.3)

The NSAPI module now supports the nsapi_virtual() function (alias: virtual()) to make subrequests on the web server and insert the result in the web page. The problem is, that this function uses some undocumented features from the NSAPI library.

Under Unix this is not a problem, because the module automatically looks for the needed functions and uses them if available. If not, nsapi_virtual() is disabled.

Under Windows limitations in the DLL handling need the use of a automatic detection of the most recent ns-httpdXX.dll file. This is tested for servers till version 6.1. If a newer version of the Sun server is used, the detection fails and nsapi_virtual() is disabled.

If this is the case, try the following: Add the following parameter to php4_init in magnus.conf/obj.conf:

Init fn=php4_init ... server_lib="ns-httpdXX.dll"
where XX is the correct DLL version number. To get it, look in the server-root for the correct DLL name. The DLL with the biggest filesize is the right one.

You can check the status by using the phpinfo() function.

Bilginize:

But be warned: Support for nsapi_virtual() is EXPERIMENTAL!!!

Sambar Server on Microsoft Windows

This section contains notes and hints specific to the » Sambar Server for Windows.

Bilginize:

You should read the manual installation steps first!

This list describes how to set up the ISAPI module to work with the Sambar server on Windows.

  • Find the file called mappings.ini (in the config directory) in the Sambar install directory.

  • Open mappings.ini and add the following line under [ISAPI]:

    Örnek 22 ISAPI configuration of Sambar

    #for PHP 4
*.php = c:\php\php4isapi.dll

#for PHP 5
*.php = c:\php\php5isapi.dll
    (This line assumes that PHP was installed in c:\php.)

  • Now restart the Sambar server for the changes to take effect.

Bilginize:

If you intend to use PHP to communicate with resources which are held on a different computer on your network, then you will need to alter the account used by the Sambar Server Service. The default account used for the Sambar Server Service is LocalSystem which will not have access to remote resources. The account can be amended by using the Services option from within the Windows Control Panel Administation Tools.

Xitami on Microsoft Windows

This section contains notes and hints specific to » Xitami on Windows.

Bilginize:

You should read the manual installation steps first!

This list describes how to set up the PHP CGI binary to work with Xitami on Windows.

Bilginize: Important for CGI users

Read the faq on cgi.force_redirect for important details. This directive needs to be set to 0. If you want to use $_SERVER['PHP_SELF'] you have to enable the cgi.fix_pathinfo directive.

Uyarı

CGI kipinde çalışan bir sunucu olası saldırılara açık hale gelir. Sunucunuzu böyle saldırılardan nasıl koruyacağınızı öğrenmek için CGI güvenliği bölümünü okuyunuz.

  • Make sure the web server is running, and point your browser to xitamis admin console (usually http://127.0.0.1/admin), and click on Configuration.

  • Navigate to the Filters, and put the extension which PHP should parse (i.e. .php) into the field File extensions (.xxx).

  • In Filter command or script put the path and name of your PHP CGI executable i.e. C:\php\php.exe for PHP 4, or C:\php\php-cgi.exe for PHP 5.

  • Press the 'Save' icon.

  • Restart the server to reflect changes.

Building from source

This chapter teaches how to compile PHP from sources on windows, using Microsoft's tools. To compile PHP with cygwin, please refer to Unix Sistemlere Kurulum.

See the Wiki documentation at: » http://wiki.php.net/internals/windows/stepbystepbuild

Installation of extensions on Windows

After installing PHP and a web server on Windows, you will probably want to install some extensions for added functionality. You can choose which extensions you would like to load when PHP starts by modifying your php.ini. You can also load a module dynamically in your script using dl().

The DLLs for PHP extensions are prefixed with php_.

Many extensions are built into the Windows version of PHP. This means additional DLL files, and the extension directive, are not used to load these extensions. The Windows PHP Extensions table lists extensions that require, or used to require, additional PHP DLL files. Here's a list of built in extensions (updated PHP 5.0.4): BCMath, Caledar, COM, Ctype, DOM, FTP, LibXML, Iconv, ODBC, PCRE, Session, SimpleXML, SPL, SQLite, WDDX, XML ve Zlib.

The default location PHP searches for extensions is C:\php5. To change this setting to reflect your setup of PHP edit your php.ini file:

  • You will need to change the extension_dir setting to point to the directory where your extensions lives, or where you have placed your php_*.dll files. For example:

    extension_dir = C:\php\extensions

  • Enable the extension(s) in php.ini you want to use by uncommenting the extension=php_*.dll lines in php.ini. This is done by deleting the leading ; from the extension you want to load.

    Örnek 23 Enable Bzip2 extension for PHP-Windows

    // change the following line from ...
;extension=php_bz2.dll

// ... to
extension=php_bz2.dll

  • Some of the extensions need extra DLLs to work. Couple of them can be found in the distribution package, in the main folder, but some, for example Oracle (php_oci8.dll) require DLLs which are not bundled with the distribution package. Don't forget to include C:\php in the system PATH (this process is explained in a separate FAQ entry).

  • Some of these DLLs are not bundled with the PHP distribution. See each extensions documentation page for details. Also, read the manual section titled Installation of PECL extensions for details on PECL. An increasingly large number of PHP extensions are found in PECL, and these extensions require a separate download.

Bilginize: If you are running a server module version of PHP remember to restart your web server to reflect your changes to php.ini.

The following table describes some of the extensions available and required additional dlls.

PHP Extensions
Extension | Description | Notes
php_bz2.dll | bzip2 compression functions | None
php_calendar.dll | Calendar conversion functions | None
php_crack.dll | Crack functions | None
php_ctype.dll | ctype family functions | None
php_curl.dll | CURL, Client URL library functions | Requires: libeay32.dll, ssleay32.dll (bundled)
php_dba.dll | DBA: DataBase (dbm-style) Abstraction layer functions | None
php_dbase.dll | dBase functions | None
php_dbx.dll | dbx functions |
php_exif.dll | EXIF functions | php_mbstring.dll. And, php_exif.dll must be loaded after php_mbstring.dll in php.ini.
php_fbsql.dll | FrontBase functions | None
php_fdf.dll | FDF: Forms Data Format functions. | Requires: fdftk.dll (bundled)
php_filepro.dll | filePro functions | Read-only access
php_ftp.dll | FTP functions | None
php_gd2.dll | GD library image functions | GD2
php_gettext.dll | Gettext functions | PHP <= 4.2.0 requires gnu_gettext.dll (bundled), PHP >= 4.2.3 requires libintl-1.dll, iconv.dll (bundled).
php_hyperwave.dll | HyperWave functions | None
php_iconv.dll | ICONV characterset conversion | Requires: iconv-1.3.dll (bundled), iconv.dll
php_ifx.dll | Informix functions | Requires: Informix libraries
php_iisfunc.dll | IIS management functions | None
php_imap.dll | IMAP POP3 and NNTP functions | None
php_ingres.dll | Ingres functions | Requires: Ingres libraries
php_interbase.dll | InterBase functions | Requires: gds32.dll (bundled)
php_ldap.dll | LDAP functions | Requires libeay32.dll, ssleay32.dll (bundled)
php_mbstring.dll | Multi-Byte String functions | None
php_mcrypt.dll | Mcrypt Encryption functions | Requires: libmcrypt.dll
php_mhash.dll | Mhash functions | Requires: libmhash.dll (bundled)
php_mime_magic.dll | Mimetype functions | Requires: magic.mime (bundled)
php_ming.dll | Ming functions for Flash | None
php_msql.dll | mSQL functions | Requires: msql.dll (bundled)
php_mssql.dll | MSSQL functions | Requires: ntwdblib.dll (bundled)
php_mysql.dll | MySQL functions | Requires libmysql.dll (bundled)
php_mysqli.dll | MySQLi functions | Requires libmysql.dll (libmysqli.dll in PHP <= 5.0.2) (bundled)
php_oci8.dll | Oracle 8 functions | Requires: Oracle 8.1+ client libraries
php_openssl.dll | OpenSSL functions | Requires: libeay32.dll (bundled)
php_pdf.dll | PDF functions | None
php_pgsql.dll | PostgreSQL functions | None
php_shmop.dll | Shared Memory functions | None
php_snmp.dll | SNMP get and walk functions | NT only!
php_soap.dll | SOAP functions | None
php_sockets.dll | Socket functions | None
php_sybase_ct.dll | Sybase functions | Requires: Sybase client libraries
php_tidy.dll | Tidy functions | None
php_tokenizer.dll | Tokenizer functions | None
php_w32api.dll | W32api functions | None
php_xmlrpc.dll | XML-RPC functions | Requires: iconv.dll (bundled)
php_xslt.dll | XSLT functions | Requires sablot.dll, expat.dll, iconv.dll (bundled).
php_yaz.dll | YAZ functions | Requires: yaz.dll (bundled)
php_zip.dll | Zip File functions | Read only access
php_zlib.dll | ZLib compression functions | None

Command Line PHP on Microsoft Windows

This section contains notes and hints specific to getting PHP running from the command line for Windows.

Bilginize:

You should read the manual installation steps first!

Getting PHP to run from the command line can be performed without making any changes to Windows.

C:\PHP5\php.exe -f "C:\PHP Scripts\script.php" -- -arg1 -arg2 -arg3

But there are some easy steps that can be followed to make this simpler. Some of these steps should already have been taken, but are repeated here to be able to provide a complete step-by-step sequence.

    Bilginize:

    Both PATH and PATHEXT are important pre-existing system variables in Windows, and care should be taken to not overwrite either variable, only to add to them.

  • Append the location of the PHP executable (php.exe, php-win.exe or php-cli.exe depending upon your PHP version and display preferences) to the PATH environment variable. Read more about how to add your PHP directory to PATH in the corresponding FAQ entry.

  • Append the .PHP extension to the PATHEXT environment variable. This can be done at the same time as amending the PATH environment variable. Follow the same steps as described in the FAQ but amend the PATHEXT environment variable rather than the PATH environment variable.

    Bilginize:

    The position in which you place the .PHP will determine which script or program is executed when there are matching filenames. For example, placing .PHP before .BAT will cause your script to run, rather than the batch file, if there is a batch file with the same name.

  • Associate the .PHP extension with a file type. This is done by running the following command:

    assoc .php=phpfile

  • Associate the phpfile file type with the appropriate PHP executable. This is done by running the following command:

    ftype phpfile="C:\PHP5\php.exe" -f "%1" -- %~2

Following these steps will allow PHP scripts to be run from any directory without the need to type the PHP executable or the .PHP extension and all parameters will be supplied to the script for processing.

The example below details some of the registry changes that can be made manually.

Örnek 24 Registry changes

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\.php]
@="phpfile"
"Content Type"="application/php"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\phpfile]
@="PHP Script"
"EditFlags"=dword:00000000
"BrowserFlags"=dword:00000008
"AlwaysShowExt"=""

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\phpfile\DefaultIcon]
@="C:\\PHP5\\php-win.exe,0"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\phpfile\shell]
@="Open"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\phpfile\shell\Open]
@="&Open"

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\phpfile\shell\Open\command]
@="\"C:\\PHP5\\php.exe\" -f \"%1\" -- %~2"

With these changes the same command can be written as:

"C:\PHP Scripts\script" -arg1 -arg2 -arg3
or, if your "C:\PHP Scripts" path is in the PATH environment variable:
script -arg1 -arg2 -arg3

Bilginize:

There is a small problem if you intend to use this technique and use your PHP scripts as a command line filter, like the example below:

dir | "C:\PHP Scripts\script" -arg1 -arg2 -arg3
or
dir | script -arg1 -arg2 -arg3
You may find that the script simply hangs and nothing is output. To get this operational, you need to make another registry change.
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer]
"InheritConsoleHandles"=dword:00000001
Further information regarding this issue can be found in this » Microsoft Knowledgebase Article : 321788. As of Windows 10, this setting seems to be reversed, making the default install of Windows 10 support inherited console handles automatically. This » Microsoft forum post provides the explanation.

Troubleshooting PHP on Windows
Installation on Cloud Computing platforms
Windows Sistemlerine Kurulum


Installation on Cloud Computing platforms

İçindekiler

  • Azure App Services
  • Amazon EC2

PHP installs on the cloud. To the PHP cloud!

Installation on old Windows systems
Azure App Services
Yapılandırma ve Kurulum


Azure App Services

PHP is frequently used on Azure App Services (aka Microsoft Azure, Windows Azure, Azure Web Apps).

Azure App Services manages pools of Windows Web Servers to host your web application, as an alternative to managing your own web server on your own Azure Compute VMs or other servers.

PHP is already enabled for your Azure App Services web site automatically. In the Azure Portal, select your web site, and you can choose which version of PHP to use. You may want to choose a newer version than the default.

As such, PHP and extensions will run on Azure App Services just as it will on other Windows servers. Much of the knowledgebase is also portable, so see the Windows Troubleshooting Page too. However, the management interface for Azure App Services is different:

  • Azure portal: create, edit settings and delete web sites. » Azure Portal

  • Kudu Dashboard: [your web site name].azurewebsites.net Then, the Kudu dashboard is » https://[your web site name].scm.azurewebsites.net/. The Dashboard gives you access to some debugging capabilities, file management and site extensions. Site extensions are an Azure mechanism to add extra programs, like PHP preview builds, to your web site.

  • You can not use IIS Manager, Server Manager, or RDP.

There is also a PHP SDK for programmatically using many Azure Services from your PHP code. See » Azure SDK for PHP.

For more information, see » Azure PHP Developer Center

WinCache

WinCache is enabled by default on Azure App Services and it is recommended that you leave it enabled. If you install your own build of PHP, you should enable WinCache on that too.

Custom PHP Build

You may upload your own PHP build to your D:\Home (C:\ is NOT writable). Then in the Azure Portal, set SCRIPT_PROCESSOR for .php to the absolute path to php-cgi.exe file in your build.

Installation on Cloud Computing platforms
Amazon EC2
Installation on Cloud Computing platforms


Amazon EC2

PHP installs on the » EC2 cloud platform.

See also the » AWS SDK for PHP.

Azure App Services
FastCGI Process Manager (FPM)
Installation on Cloud Computing platforms


FastCGI Process Manager (FPM)

İçindekiler

  • Installation
  • Configuration

FPM (FastCGI Process Manager) is an alternative PHP FastCGI implementation with some additional features (mostly) useful for heavy-loaded sites.

These features include:

  • advanced process management with graceful stop/start;

  • ability to start workers with different uid/gid/chroot/environment, listening on different ports and using different php.ini (replaces safe_mode);

  • stdout and stderr logging;

  • emergency restart in case of accidental opcode cache destruction;

  • accelerated upload support;

  • "slowlog" - logging scripts (not just their names, but their PHP backtraces too, using ptrace and similar things to read remote process' execute_data) that are executed unusually slow;

  • fastcgi_finish_request() - special function to finish request and flush all data while continuing to do something time-consuming (video converting, stats processing etc.);

  • dynamic/static child spawning;

  • basic SAPI status info (similar to Apache mod_status);

  • php.ini-based config file.

Amazon EC2
Installation
Yapılandırma ve Kurulum


Installation

Compiling from sources

In order to enable FPM in your PHP build you need to add --enable-fpm to your configure line.

There are several other FPM-specific configure options (all of them optional):

  • --with-fpm-user - set FPM user (default - nobody).

  • --with-fpm-group - set FPM group (default - nobody).

  • --with-fpm-systemd - Activate systemd integration (default - no).

  • --with-fpm-acl - Use POSIX Access Control Lists (default - no). Since PHP 5.6.5.

FastCGI Process Manager (FPM)
Configuration
FastCGI Process Manager (FPM)


Configuration

FPM uses php.ini syntax for its configuration file - php-fpm.conf, and pool configuration files.

List of global php-fpm.conf directives

pid string

Path to PID file. Default value: none.

error_log string

Path to error log file. Default value: #INSTALL_PREFIX#/log/php-fpm.log. If it's set to "syslog", log is sent to syslogd instead of being written in a local file.

log_level string

Error log level. Possible values: alert, error, warning, notice, debug. Default value: notice.

syslog.facility string

used to specify what type of program is logging the message. Default value: daemon.

syslog.ident string

Prepended to every message. If you have multiple FPM instances running on the same server, you can change the default value which must suit common needs. Default value: php-fpm.

emergency_restart_threshold int

If this number of child processes exit with SIGSEGV or SIGBUS within the time interval set by emergency_restart_interval, then FPM will restart. A value of 0 means 'Off'. Default value: 0 (Off).

emergency_restart_interval mixed

Interval of time used by emergency_restart_interval to determine when a graceful restart will be initiated. This can be useful to work around accidental corruptions in an accelerator's shared memory. Available Units: s(econds), m(inutes), h(ours), or d(ays). Default Unit: seconds. Default value: 0 (Off).

process_control_timeout mixed

Time limit for child processes to wait for a reaction on signals from master. Available units: s(econds), m(inutes), h(ours), or d(ays) Default Unit: seconds. Default value: 0.

process.max int

The maximum number of processes FPM will fork. This has been design to control the global number of processes when using dynamic PM within a lot of pools. Use it with caution. Default value: 0.

process.priority int

Specify the nice(2) priority to apply to the master process (only if set). The value can vary from -19 (highest priority) to 20 (lower priority). Default value: not set.

daemonize boolean

Send FPM to background. Set to 'no' to keep FPM in foreground for debugging. Default value: yes.

rlimit_files int

Set open file descriptor rlimit for the master process. Default value: Set open file descriptor rlimit for the master process.

rlimit_core int

Set max core size rlimit for the master process. Default value: 0.

events.mechanism string

Specify the event mechanism FPM will use. The following is available: select, pool, epoll, kqueue (*BSD), port (Solaris). Default value: not set (auto detection).

systemd_interval int

When FPM is build with systemd integration, specify the interval, in second, between health report notification to systemd. Set to 0 to disable. Default value: 10.

List of pool directives

With FPM you can run several pools of processes with different setting. These are settings that can be tweaked per pool.

listen string

The address on which to accept FastCGI requests. Valid syntaxes are: 'ip.add.re.ss:port', 'port', '/path/to/unix/socket'. This option is mandatory for each pool.

listen.backlog int

Set listen(2) backlog. A value of '-1' means unlimited. Default value: -1.

listen.allowed_clients string

List of IPv4 addresses of FastCGI clients which are allowed to connect. Equivalent to the FCGI_WEB_SERVER_ADDRS environment variable in the original PHP FastCGI (5.2.2+). Makes sense only with a tcp listening socket. Each address must be separated by a comma. If this value is left blank, connections will be accepted from any ip address. Default value: any. IPv6 addresses are allowed since PHP 5.5.20 and 5.6.4.

listen.owner string

Set permissions for unix socket, if one is used. In Linux, read/write permissions must be set in order to allow connections from a web server. Many BSD-derived systems allow connections regardless of permissions. Default values: user and group are set as the running user, mode is set to 0660.

listen.group string

See listen.owner.

listen.mode string

See listen.owner.

listen.acl_users string

When POSIX Access Control Lists are supported you can set them using this option. When set, listen.owner and listen.group are ignored. Value is a comma separated list of user names. Since PHP 5.6.5.

listen.acl_groups string

See listen.acl_users. Value is a comma separated list of group names. Since PHP 5.6.5.

user string

Unix user of FPM processes. This option is mandatory.

group string

Unix group of FPM processes. If not set, the default user's group is used.

pm string

Choose how the process manager will control the number of child processes. Possible values: static, ondemand, dynamic. This option is mandatory.

static - the number of child processes is fixed (pm.max_children).

ondemand - the processes spawn on demand (when requested, as opposed to dynamic, where pm.start_servers are started when the service is started.

dynamic - the number of child processes is set dynamically based on the following directives: pm.max_children, pm.start_servers, pm.min_spare_servers, pm.max_spare_servers.

pm.max_children int

The number of child processes to be created when pm is set to static and the maximum number of child processes to be created when pm is set to dynamic. This option is mandatory.

This option sets the limit on the number of simultaneous requests that will be served. Equivalent to the ApacheMaxClients directive with mpm_prefork and to the PHP_FCGI_CHILDREN environment variable in the original PHP FastCGI.

pm.start_servers int

The number of child processes created on startup. Used only when pm is set to dynamic. Default Value: min_spare_servers + (max_spare_servers - min_spare_servers) / 2.

pm.min_spare_servers int

The desired minimum number of idle server processes. Used only when pm is set to dynamic. Also mandatory in this case.

pm.max_spare_servers int

The desired maximum number of idle server processes. Used only when pm is set to dynamic. Also mandatory in this case.

pm.process_idle_timeout mixed

The number of seconds after which an idle process will be killed. Used only when pm is set to ondemand. Available units: s(econds)(default), m(inutes), h(ours), or d(ays). Default value: 10s.

pm.max_requests int

The number of requests each child process should execute before respawning. This can be useful to work around memory leaks in 3rd party libraries. For endless request processing specify '0'. Equivalent to PHP_FCGI_MAX_REQUESTS. Default value: 0.

pm.status_path string

The URI to view the FPM status page. If this value is not set, no URI will be recognized as a status page. Default value: none.

ping.path string

The ping URI to call the monitoring page of FPM. If this value is not set, no URI will be recognized as a ping page. This could be used to test from outside that FPM is alive and responding. Please note that the value must start with a leading slash (/).

ping.response string

This directive may be used to customize the response to a ping request. The response is formatted as text/plain with a 200 response code. Default value: pong.

process.priority int

Specify the nice(2) priority to apply to the worker process (only if set). The value can vary from -19 (highest priority) to 20 (lower priority). Default value: not set.

prefix string

Specify prefix for path evaluation

request_terminate_timeout mixed

The timeout for serving a single request after which the worker process will be killed. This option should be used when the 'max_execution_time' ini option does not stop script execution for some reason. A value of '0' means 'Off'. Available units: s(econds)(default), m(inutes), h(ours), or d(ays). Default value: 0.

request_slowlog_timeout mixed

The timeout for serving a single request after which a PHP backtrace will be dumped to the 'slowlog' file. A value of '0' means 'Off'. Available units: s(econds)(default), m(inutes), h(ours), or d(ays). Default value: 0.

slowlog string

The log file for slow requests. Default value: #INSTALL_PREFIX#/log/php-fpm.log.slow.

rlimit_files int

Set open file descriptor rlimit for child processes in this pool. Default value: system defined value.

rlimit_core int

Set max core size rlimit for child processes in this pool. Possible Values: 'unlimited' or an integer greater or equal to 0. Default value: system defined value.

chroot string

Chroot to this directory at the start. This value must be defined as an absolute path. When this value is not set, chroot is not used.

chdir string

Chdir to this directory at the start. This value must be an absolute path. Default value: current directory or / when chroot.

catch_workers_output boolean

Redirect worker stdout and stderr into main error log. If not set, stdout and stderr will be redirected to /dev/null according to FastCGI specs. Default value: no.

clear_env boolean

Clear environment in FPM workers. Prevents arbitrary environment variables from reaching FPM worker processes by clearing the environment in workers before env vars specified in this pool configuration are added. Since PHP 5.4.27, 5.5.11, and 5.6.0. Default value: Yes.

security.limit_extensions string

Limits the extensions of the main script FPM will allow to parse. This can prevent configuration mistakes on the web server side. You should only limit FPM to .php extensions to prevent malicious users to use other extensions to execute php code. Default value: .php .phar

access.log string

The access log file. Default value: not set

access.format string

The access log format. Default value: "%R - %u %t \"%m %r\" %s"

It's possible to pass additional environment variables and update PHP settings of a certain pool. To do this, you need to add the following options to the pool configuration file.

Örnek 1 Passing environment variables and PHP settings to a pool

env[HOSTNAME] = $HOSTNAME
env[PATH] = /usr/local/bin:/usr/bin:/bin
env[TMP] = /tmp
env[TMPDIR] = /tmp
env[TEMP] = /tmp

php_admin_value[sendmail_path] = /usr/sbin/sendmail -t -i -f www@my.domain.com
php_flag[display_errors] = off
php_admin_value[error_log] = /var/log/fpm-php.www.log
php_admin_flag[log_errors] = on
php_admin_value[memory_limit] = 32M
PHP settings passed with php_value or php_flag will overwrite their previous value. Please note that defining disable_functions or disable_classes will not overwrite previously defined php.ini values, but will append the new value instead.

Settings defined with php_admin_value and php_admin_flag cannot be overriden with ini_set().

As of 5.3.3, PHP settings are also possible to be set in webserver.

Örnek 2 set PHP settings in nginx.conf

set $php_value "pcre.backtrack_limit=424242";
set $php_value "$php_value \n pcre.recursion_limit=99999";
fastcgi_param  PHP_VALUE $php_value;

fastcgi_param  PHP_ADMIN_VALUE "open_basedir=/var/www/htdocs";
Dikkat

Because these settings are passed to php-fpm as fastcgi headers, php-fpm should not be bound to a worldwide accessible address. Otherwise, anyone could alter the PHP configuration options. See also listen.allowed_clients.

Installation
PECL eklentilerinin kurulması
FastCGI Process Manager (FPM)


PECL eklentilerinin kurulması

İçindekiler

  • PECL Kurulumları Hakkında
  • PECL Eklentilerinin İndirilmesi
  • Bir PHP Eklentisinin Windows Kurulumu
  • Paylaşımlı PECL eklentilerinin pecl komutu ile derlenmesi
  • Paylaşımlı PECL eklentilerinin phpize ile derlenmesi
  • php-config
  • PECL eklentilerinin PHP içinde duruk olarak derlenmesi
Configuration
PECL Kurulumları Hakkında
Yapılandırma ve Kurulum


PECL Kurulumları Hakkında

» PECL, » PEAR üzerinden kullanılabililen bir PHP eklentileri deposudur. Kılavuzun bu bölümü PECL eklentilerinin nasıl edinileceği ve nasıl kurulacağını göstermek için tasarlanmıştır.

Bu talimatlarda, PHP kaynak kodunun /php/kaynak/dizininiz/ altında bulunduğu ve PECL eklentisinin isminin eklenti olduğu varsayılacaktır. Hazırlıklarınızı buna göre yapın. Bu talimatlarda ayrıca, » pear komutunu kullanmayı bildiğiniz varsayılacaktır. PEAR kılavuzundaki pear komutu ile ilgili bilgiler pecl komutu için de geçerlidir.

Burada genel olarak eklentinin paylaşımlı olarak derlenmesi, kurulması ve yüklenmesi üzerinde durulacaktır. Sonraki bölümlerde açıklanan yöntemler eklentiyi nasıl derleyip kuracağınızla ilgili çeşitli talimatlar içerir, fakat bunları sizin yerinize özdevinimli olarak yüklemezler. Eklentiler bir extension yönergesi eklenerek yüklenebilirler. Bunun için php.ini dosyasını veya dl() işlevini kullanabilirsiniz.

PHP modüllerini derlerken, derleme için gerekli araçların (autoconf, automake, libtool gibi) birbirleriyle en uyumlu sürümlerini kullanıyor olmak önemlidir. Gerekli araçlar ve bunların gerekli sürümleriyle ilgili ayrıntılı bilgiyi » Anonim Git Talimatları sayfasında bulabilirsiniz.

PECL eklentilerinin kurulması
PECL Eklentilerinin İndirilmesi
PECL eklentilerinin kurulması


PECL Eklentilerinin İndirilmesi

PECL eklentilerini indirmek için çeşitli seçenekler vardır:

  • pecl install eklenti komutu eklenti kodunu özdevinimli olarak indirir, dolayısıyla ayrı bir indirme işlemine gerek kalmaz.
  • » http://pecl.php.net/ PECL sitesi, PHP Geliştirme Ekibi tarafından önerilen farklı eklentiler hakkında bilgiler içerir. Burada bulunan bilgilerden bazıları: ChangeLog dosyaları, dağıtım notları, gereksinimler ve benzeri ayrıntılar.
  • pecl download eklenti komutu PECL sitesinine dağıtım listesinde bulunan eklentileri indirip kurmak için » pecl komutu kullanılabilir. İstenen sürümler ayrıca belirtilebilir.
  • SVN Çoğu PECL eklentisi ayrıca SVN'de de bulunmaktadır. SVN içeriğini tarayıcınızla » http://svn.php.net/viewvc/pecl/ adresinde inceleyebilirsiniz. Eklentileri doğrudan SVN'den indirmek için sırayla aşağıdaki komutları verebilirsiniz.

    $ svn checkout http://svn.php.net/repository/pecl/extname/trunk eklenti

  • Windows için PHP projesi çoğu PECL eklentisinin Windows çalıştırılabilirlerini derlemekte ve ilgili yere kurmaktadır.
PECL Kurulumları Hakkında
Bir PHP Eklentisinin Windows Kurulumu
PECL eklentilerinin kurulması


Bir PHP Eklentisinin Windows Kurulumu

Windows'ta bir PHP eklentisini yüklemenin iki yolu vardır: Ya eklentiyi PHP içinde derlersiniz ya da DLL olarak yüklersiniz. Derlenmiş bir eklentiyi yüklemek en kolay ve en çok tercih edilen yoldur.

Bir eklentiyi yüklemek için sisteminizde o eklentinin ".dll" dosyasının bulunması gerekir. Tüm eklentiler özdevinimli olarak belirli aralıklarla PHP Grubu tarafından derlenirler (bunları indirmek için sonraki bölüme bakınız).

Bir eklentiyi PHP içinde derlemek için Kaynak kod paketinden derleme belgesine bakınız.

Bir eklentiyi tek başına (yani bir DLL olarak) derlemek için Kaynak kod paketinden derleme belgesine bakınız. Eğer DLL dosyası ne PHP dağıtımınızda ne de PECL sitesinde mevcutsa, eklentiyi kullanmaya başlamadan önce derlemek zorunda kalabilirsiniz.

Bir eklenti nereden bulunur?

PHP eklentileri genellikle "php_*.dll" biçeminde isimlendirilir (yıldız iminin yerine eklentinin ismi gelir) ve "PHP\ext" dizini altında bulunur.

PHP, geliştiricilerin büyük çoğunluğunca en faydalı bulunan eklentilerle birlikte gelir. Bunlara "çekirdek" eklentiler adı verilir.

Bununla birlikte, çekirdek eklentilerle sağlanmamış bir işlevselliğe ihtiyaç duyarsanız, PECL sitesinde bakabilirsiniz. PHP Eklentileri Halk Kütüphanesi (PECL - PHP Extension Community Library) bir PHP Eklentileri deposu olup PHP eklentilerinin geliştirilmesi ve indirilmesi için barındırma oluşumlarını ve bilinen tüm eklentilerin bir dizinini içerir.

Kendi kullanımınız için bir eklenti geliştiriyorsanız PECL'de barındırılmasını isteyebilirsiniz, böylece ihtiyaçları aynı olan başkaları da eklentinizden yararlanabilir. Bunun bazı olumlu yan etkileri de vardır: Geribildirim, teşekkür, hata bildirimi, hatta düzeltme ve yama alma şansınız olur. Eklentinizi barındırılmak üzere PECL'ye göndermeden önce lütfen » PECL submit adresini ziyaret ediniz.

Hangi eklenti indirilecek?

Çoğu zaman her DLL'nin çok sayıda sürümü vardır:

  • Farklı sürüm numaraları (en azından ilk iki sayı tutmalı)
  • Farklı evre güvenceli olanlar
  • Farklı işlemciler için olanlar (x86, x64, ...)
  • Farklı hata ayıklama seçenekli olanlar
  • vs.

Şunu aklınızdan çıkarmayın: Eklenti ayarlarınız kullandığınız PHP çalıştırılabilirinin ayarları ile aynı olmalıdır. Aşağıdaki PHP betiği PHP ayarlarınızın tamamını size söyleyecektir:

Örnek 1 phpinfo() kullanımı

<?php
phpinfo();
?>

Ya da komut satırından şunu çalıştırın:

sürücü:\\dizin\yolu\php\executable\php.exe -i

Bir eklentinin yüklenmesi

Bir PHP eklentisini yüklemenin en bilinen yolu eklentiyi php.ini dosyasına eklemektir. Dikkatli incelerseniz php.ini dosyanızda bir çok eklentinin zaten ekli olduğunu görürsünüz. Eklentiyi etkin kılmak için tek yapacağınız eklentinin belirtildiği satırın başındaki noktalı virgülü silmek olacaktır.

;extension=php_eklenti.dll

extension=php_eklenti.dll

Bununla birlikte, bazı HTTP sunucuları, PHP çalıştırılabilirinin yanına konmuş php.ini dosyasını kullanmadıklarından eklentinizi göremeyebilirler. HTTP sunucunuzun kullandığı php.ini dosyasının bulunduğu yeri phpinfo() işlevini kullanarak öğrenebilirsiniz:

Configuration File (php.ini) Path C:\WINDOWS

Loaded Configuration File         C:\Program Files\PHP\5.2\php.ini

Eklentiyi etkin kıldıktan sonra php.ini dosyanızı kaydedin ve HTTP sunucunuzu yeniden başlattıktan sonra tekrar phpinfo() çıktısına bakın. Yeni eklentiyi artık kendi bölümünde görüyor olmanız gerekir.

Sorunların çözümlenmesi

Eğer eklenti phpinfo() çıktısında görünmüyorsa sorunun kaynağını bulmak için günlük dosyalarınıza bakmalısınız.

PHP'yi komut satırından kullanıyorsanız (CGI), eklenti yükleme hatasını doğrudan ekranda görebilirsiniz.

PHP'yi bir HTTP sunucusu ile kullanıyorsanız günlük dosyalarının yeri ve biçemi kullandığınız yazılıma göre değişir. Günlüklerin yerini bulmak için kullandığınız HTTP sunucusunun belgelerine bakınız.

Sorunların çoğu DLL dosyasının yeri ile ilgilidir. php.ini içindeki "extension_dir" yönergesinin değeri ile derleme sırasında yapılan ayarlar arasında bir tutarsızlık olabilir.

Eğer sorun derleme sırasında yapılan ayarlarla uyumsuzluktan kaynaklanıyorsa muhtemelen indirdiğiniz DLL dosyasını doğru yere koymamışsınız demektir. Eklentiyi doğru ayarlarla tekrar indirmeyi deneyin. Bunu yaptıktan sonra tekrar phpinfo() çıktısına bakmayı unutmayın.

PECL Eklentilerinin İndirilmesi
Paylaşımlı PECL eklentilerinin pecl komutu ile derlenmesi
PECL eklentilerinin kurulması


Paylaşımlı PECL eklentilerinin pecl komutu ile derlenmesi

PECL, paylaşımlı PHP eklentilerinin oluşturulmasını kolaylaştırır. » pecl komutunu şöyle kullanabilirsiniz:

$ pecl install eklenti

Bu komutla eklentinin kaynak kodu indirilecek, derlenecek ve eklenti.so adıyla extension_dir yönergesinde belirtilen dizine kurulacaktır. Böylece eklenti.so php.ini üzerinden yüklenebilir duruma gelmiş olacaktır.

Öntanımlı olarak, pecl komutu, alfa veya beta olarak imlenmiş paketleri kurmaz. Eklentinin henüz kararlı bir sürümü yoksa, beta sürümü şöyle kurabilirsiniz:

$ pecl install eklenti-beta

Ayrıca belli bir sürümü şu şekilde kurabilirsiniz:

$ pecl install eklenti-0.1

Bilginize:

Eklentiyi php.ini dosyasında etkin kıldıktan sonra değişikliklerin etkin olması için HTTP sunucunuzu (hizmetini) yeniden başlatın.

Bir PHP Eklentisinin Windows Kurulumu
Paylaşımlı PECL eklentilerinin phpize ile derlenmesi
PECL eklentilerinin kurulması


Paylaşımlı PECL eklentilerinin phpize ile derlenmesi

pecl komutu ile kurulumun mümkün olmadığı durumlar olabilir. Bir güvenlik duvarı arkasındasınızdır veya eklentinin PECL uyumlu paketi yoktur ya da henüz dağıtılmamış SVN sürümünü kurmak istiyorsunuzdur, vs. Böyle bir eklentinin derleme işlemini daha alt seviye derleme araçlarını kullanarak kendiniz gerçekleştirebilirsiniz.

Bir PHP eklentisini derleme işlemine hazırlamak için phpize komutu kullanılır. Aşağıdaki örnekte, eklentinin kaynak kod paketinin eklenti dizininde bulunduğu varsayılmıştır:

$ cd eklenti
$ phpize
$ ./configure
$ make
# make install

Başarılı bir kurulum sonucunda eklenti PHP eklentileri dizinine eklenti.so adıyla yerleştirilir. Eklentiyi etkin kılmak için php.ini dosyanıza bir extension=eklenti.so satırı eklemeniz gerekecektir.

Eğer sisteminizde phpize komutu yoksa ve RPM gibi önceden derlenmiş paketleri kullanabiliyorsanız, phpize komutunu ve PHP eklentilerini derlemek için gerekli başlık dosyalarını içermesi muhtemel uygun bir PHP geliştirme sürümünü kurmanız gerekebilir.

Komutun kullanım bilgilerini görmek için phpize --help komutunu verin.

Paylaşımlı PECL eklentilerinin pecl komutu ile derlenmesi
php-config
PECL eklentilerinin kurulması


php-config

php-config basit bir kabuk betiği olup kurulu PHP yapılandırması hakkında bilgi edinmek için kullanılır.

Eklentiler derlenirken, birden fazla PHP sürümü kuruluysa yapılandırma sırasında --with-php-config seçeneğinde ilgili php-config betiğinin yolunu yazarak hangi kurulumu kurmak istediğinizi belirtebilirsiniz.

php-config betiği tarafından sağlanan komut satırı seçeneklerinin listesini, betiği -h seçeneği ile çalıştırarak istediğiniz zaman alabilirsiniz:

Usage: /usr/local/bin/php-config [OPTION]
Options:
  --prefix            [...]
  --includes          [...]
  --ldflags           [...]
  --libs              [...]
  --extension-dir     [...]
  --include-dir       [...]
  --php-binary        [...]
  --php-sapis         [...]
  --configure-options [...]
  --version           [...]
  --vernum            [...]

Komut satırı seçenekleri
Seçenek | Açıklama
--prefix | PHP'nin kurulu olduğu dizinin öneki, /usr/local gibi.
--includes | Tüm başlık dosyaları ile -I seçeneklerinin listesi
--ldflags | PHP'nin birlikte derlendiği LD seçenekleri
--libs | PHP'nin birlikte derlendiği ek kütüphaneler
--extension-dir | Eklentilerin aranacağı öntanımlı dizin
--include-dir | Başlık dosyalarının bulunduğu öntanımlı dizininin öneki
--php-binary | PHP CLI veya CGI çalıştırılabilirinin tam yolu
--php-sapis | Kullanılabilir tüm SAPI modüllerini gösterir
--configure-options | Geçerli PHP kurulumunu yeniden oluşturmak için yapılandırma seçenekleri
--version | PHP sürümü
--vernum | Tamsayı olarak PHP sürümü

Paylaşımlı PECL eklentilerinin phpize ile derlenmesi
PECL eklentilerinin PHP içinde duruk olarak derlenmesi
PECL eklentilerinin kurulması


PECL eklentilerinin PHP içinde duruk olarak derlenmesi

Bazen bir PECL eklentisini PHP çalıştırılabilirinin içinde duruk olarak derlemeniz gerekebilir. Bunu yapmak için eklentiyi /php/kaynak/dizininiz/ext/ dizinine yerleştirmeniz ve PHP kaynak paketinin configure betiğini yeniden çalıştırmanız gerekir.

$ cd /php/kaynak/dizininiz/ext
$ pecl download eklenti
$ gzip -d < eklenti.tgz | tar -xvf -
$ mv eklenti-x.x.x eklenti

Bu işlemin sonucunda eklenti şöyle bir dizinin altına yerleştirilmiş olacaktır:

/php/kaynak/dizininiz/ext/eklenti

Artık PHP kaynak paketinin configure betiğini yeniden oluşturup PHP'yi her zamanki gibi derleyebilirsiniz:

$ cd /php/kaynak/dizininiz/
$ rm configure
$ ./buildconf --force
$ ./configure --help
$ ./configure --with-eklenti --enable-baskabireklenti --with-filanca
$ make
$ make install

Bilginize: buildconf betiğini çalıştırabilmek için autoconf 2.13 ve automake 1.4+ paketlerinin sisteminizde kurulu olması gerekir (daha yeni autoconf sürümleri de çalışır ama onlar desteklenmemektedir).

--enable-eklenti seçeneğinin mi yoksa --with-eklenti seçeneğinin mi kullanılacağı eklentiye bağlıdır. Genellikle harici kütüphanelere ihtiyacı olmayan eklentiler --enable seçeneğini kullanırlar. Hangisinin kullanılacağından emin olmak için buildconf'tan sonra şunu çalıştırın:

$ ./configure --help | grep eklenti

php-config
Sorunlar?
PECL eklentilerinin kurulması


Sorunlar?

İçindekiler

  • SSS'yi okuyun
  • Diğer Sorunlar
  • Hata Bildirme
PECL eklentilerinin PHP içinde duruk olarak derlenmesi
SSS'yi okuyun
Yapılandırma ve Kurulum


SSS'yi okuyun

Bazı sorunlar diğerlerine göre daha sık karşımıza çıkar. En bilinenlerini bu kılavuzun SSS bölümünde liste halinde bulabilirsiniz.

Sorunlar?
Diğer Sorunlar
Sorunlar?


Diğer Sorunlar

Hala bir çözüme ulaşamadıysanız, PHP kurulum posta listesinden birileri belki size yardımcı olabilir. Sizin sorununuzla daha önce karşılaşan biri olmuş mu acaba diye önce liste arşivlerini bir araştırın, hala uygun bir çözüm bulamadıysanız sorununuzu listeye yazın, aynı sorunla daha önce karşılaşmış biri size yardımcı olabilir. Liste arşivlerine » http://www.php.net/support.php adresindeki destek sayfasından erişebilirsiniz. PHP kurulum listesine üye olmak için » php-install-subscribe@lists.php.net adresine boş bir ileti gönderiniz. Posta listesinin adresi: » php-install@lists.php.net.

Posta listesinde yardım almak istiyorsanız, ortamınız hakkında gerekli bilgiler (kullandığınız işletim sistemi, PHP sürümü, HTTP sunucusu, PHP'yi CGI olarak mı yoksa modül olarak mı çalıştırdığınız, safe_mode, vs. kullanımı) dikkatlice ve ayrıntılı olarak vermeye çalışın. Bunun yanında sorununuzu denemeyi veya aynı sorunu üretmeyi mümkün kılacak kodları veya ayrıntıları vermeye çalışın.

SSS'yi okuyun
Hata Bildirme
Sorunlar?


Hata Bildirme

PHP'de bir hata bulduğunuzu düşünüyorsanız, lütfen bize bildirin. Siz bildirmezseniz PHP geliştiricilerinin muhtemelen bundan haberleri olmayacak ve gerekli değişiklikleri yapmayacaklardır. Hataları » http://bugs.php.net/ adresindeki hata izleme sistemini kullanarak bildirebilirsiniz. Hataları lütfen posta listelerine ve kişisel posta adreslerine bildirmeyiniz. Hata izleme sistemine özellik isteklerinizi de bildirebilirsiniz.

Bir hatayı bildirmeden önce lütfen » Hata nasıl bildirilir? sayfasını okuyunuz!

Diğer Sorunlar
Çalışma Anı Yapılandırması
Sorunlar?


Çalışma Anı Yapılandırması

İçindekiler

  • Yapılandırma Dosyası
  • .user.ini dosyaları
  • Yapılandırma ayarlarının yeri
  • Yapılandırma ayarlarının değiştirilmesi
Hata Bildirme
Yapılandırma Dosyası
Yapılandırma ve Kurulum


Yapılandırma Dosyası

Yapılandırma dosyası (php.ini) PHP başlatıldığında okunur. PHP'nin sunucu modülü sürümlerinde bu işlem bir kereliğine HTTP sunucusu başlatıldığında gerçekleşir. CGI ve CLI sürümlerinde ise PHP'nin her çağrılışında işlem tekrarlanır.

php.ini sırasıyla şuralarda aranır:

  • SAPI modülüne özgü konum (Apache 2'de PHPIniDir yönergesi, CGI ve CLI için -c komut satırı seçeneği, NSAPI'de php_ini değiştirgesi, THTTPD'de PHP_INI_PATH ortam değişkeni)

  • PHPRC ortam değişkeni. PHP 5.2.0 öncesinde aşağıda bahsedilen kayıt defteri anahtarından sonra bu değişkene bakılırdı.

  • PHP 5.2.0'dan itibaren, PHP'nin farklı sürümlerine ait php.ini dosyaları için Windows kayıt defterinde sırayla aşağıdaki yerlere bakılmaktadır: [HKEY_LOCAL_MACHINE\SOFTWARE\PHP\x.y.z], [HKEY_LOCAL_MACHINE\SOFTWARE\PHP\x.y] ve [HKEY_LOCAL_MACHINE\SOFTWARE\PHP\x]. Burada x, y ve z harfleri PHP'nin ana, alt ve yama sürümlerini belirtir. Bu anahtarlarda bir IniFilePath değeri varsa ilk bulunan php.ini konumu kullanılır.

  • [HKEY_LOCAL_MACHINE\SOFTWARE\PHP] anahtarının \IniFilePath değeri. (Windows Kayıt Defteri kaydı)

  • Geçerli çalışma dizini (CLI dışında)

  • HTTP sunucusunun dizini (SAPI modülleri için) veya PHP dizini (Windows için)

  • Windows dizini (C:\windows veya C:\winnt) (Windows için) veya --with-config-file-path derleme seçeneği ile belirtilen dizin.

php-SAPI.ini mevcutsa (burada SAPI, kullanılan SAPI'dir, dolayısıyla php-cli.ini veya php-apache.ini gibi bir dosya ismidir), php.ini yerine bu dosya kullanılır. SAPI ismi php_sapi_name() işlevi ile saptanabilir.

Bilginize:

Apache HTTP sunucusunun başlatıldığında kök dizine geçmesi PHP'nin php.ini dosyasını dosya sisteminin kök dizininde aramasına sebep olur.

php.ini içinde kullanılabilen ortam değişkenlerinin kullanımı aşağıda gösterilmiştir.

Örnek 1 php.ini Ortam Değişkenleri

; PHP_MEMORY_LIMIT'in ortamdan alınışı
memory_limit = ${PHP_MEMORY_LIMIT}

php.ini yönergelerinin eklentilerle ilgili olanlarının belgeleri her eklentinin kendi belgeleri içindedir. Temel yönergelerin listesini eklerde bulabilirsiniz. Tamamı olmasa da yönergelerin büyük çoğunluğu kılavuzda belgelenmiş durumdadır. Kurulu PHP sürümünüzde geçerli yönergelerin tam listesi için kendi içinde iyi açıklanmış php.ini dosyanızı okuyun. Ayrıca, Git'te bulunan » en son php.ini dosyası da bu konuda size yardımcı olabilir.

Örnek 2 - php.ini örneği

; bir noktalı virgülden (;) sonra gelen tüm metin parçaları yok sayılır
[php] ; bölüm imleyiciler de (köşeli ayraç içindeki metinler) yok sayılır
; Mantıksal değerler için şu değerlerden herhangi biri kullanılabilir:
;      true,  on,  yes
;      false, off, no, none
register_globals = off
track_errors = yes

; Dizgeleri çift tırnak imlerinin arasında belirtebilirsiniz
include_path = ".:/usr/local/lib/php"

; tersbölü karakterleri diğer karakterler gibi ele alınır
include_path = ".;c:\php\lib"

PHP'nin 5.1.0 sürümünden beri .ini dosyalarında bulunan yönergelere isimleriyle değişken olarak erişilebilmektedir. Örnek: open_basedir = ${open_basedir} ":/new/dir".

Sürüm Bilgisi

Sürüm: | Açıklama
7.0.0 | # karakteri artık açıklama olarak ele alınmıyor.
5.3.0 | # karakteri artık açıklama olarak ele alınmıyor ve kullanılırsa kullanımımın önerilmediğini belirten bir uyarı çıktılanıyor.
5.1.0 | I. ini dosyalarının içindeki mevcut .ini değişkenlerine atıfta bulunmak artık mümkün.

Çalışma Anı Yapılandırması
.user.ini dosyaları
Çalışma Anı Yapılandırması


.user.ini dosyaları

PHP 5.3.0'dan beri, dizinler için .htaccess tarzı INI dosyaları desteklenmektedir. Bu dosyalar sadece CGI/FastCGI SAPI tarafından işlenir. Bu işlevsellik ile PECL htscanner eklentisi atıl duruma düşmüştür. Apache kullanıyorsanız aynı etkiyi elde etmek için .htaccess dosyalarını kullanın.

Ana php.ini dosyasına ek olarak, PHP istenen PHP dosyasının bulunduğu dizinden itibaren her dizini INI dosyaları için tarar ve bunları geçerli belge kök dizinine uygulanıyormuş gibi uygular ($_SERVER['DOCUMENT_ROOT'] değişkenine atandığı gibi). PHP dosyasının belge kökü dışında olduğu durumlarda sadece onun dizini taranır.

.user.ini tarzı INI dosyalarında sadece PHP_INI_PERDIR ve PHP_INI_USER kipindeki INI ayarları işleme sokulur.

Kullanıcı INI dosyalarını denetlemek için iki yeni INI yönergesi kullanılmaktadır: user_ini.filename ve user_ini.cache_ttl.

user_ini.filename ile PHP'nin dizinlerde arayacağı dosyanın ismi belirtilir. .user.ini öntanımlı değerdir.

user_ini.cache_ttl ile kullanıcı INI dosyalarının ne sıklıkta denetleneceği belirtilir. 300 saniye (5 dakika) öntanımlı değerdir.

Yapılandırma Dosyası
Yapılandırma ayarlarının yeri
Çalışma Anı Yapılandırması


Yapılandırma ayarlarının yeri

Bu kipler, bir PHP yönergesinin nerede ve ne zaman atanabileceğini belirlerler ve bu kılavuzdaki her yönerge bu kiplerden biri ile ilişkilidir. Örneğin, bazı ayarlar bir PHP betiğinin içinde ini_set() kullanarak atanabilirken bazıları da php.ini veya httpd.conf dosyasında atanabilirler.

Örneğin, output_buffering ayarı için kip PHP_INI_PERDIR olup ini_set() kullanarak atanamaz. Bununla birlikte, display_errors yönergesinin kipi PHP_INI_ALL olup ini_set() kullanımı dahil her yerde atanabilir.

PHP_INI_* kiplerinin tanımları
Kip | Anlamı
PHP_INI_USER | Girdi Windows registry veya kullanıcı betiklerinde (örneğin ini_set() ile) atanabilir.
PHP_INI_PERDIR | Girdi php.ini, .htaccess, httpd.conf veya (PHP 5.3 itibariyle) .user.ini dosyasında atanabilir.
PHP_INI_SYSTEM | Girdi php.ini veya httpd.conf dosyasında atanabilir.
PHP_INI_ALL | Girdi herhangi bir yerde atanabilir.
.user.ini dosyaları
Yapılandırma ayarlarının değiştirilmesi
Çalışma Anı Yapılandırması


Yapılandırma ayarlarının değiştirilmesi

PHP'nin bir Apache modülü olarak çalıştırılması

PHP'yi bir Apache modülü olarak kullanırken, yapılandırma ayarlarını Apache yapılandırma dosyalarındaki (httpd.conf ve .htaccess dosyaları) yönergeleri kullanarak da değiştirebilirsiniz. Bunu yapabilmek için Apache yapılandırmasında "AllowOverride Options" veya "AllowOverride All" olması gerekir.

PHP yapılandırmasını Apache yapılandırma dosyaları içinden değiştirmenize imkan veren çeşitli Apache yönergeleri vardır. PHP_INI_ALL, PHP_INI_PERDIR veya PHP_INI_SYSTEM olarak belirtilebilen yönergeleri eklerdeki php.ini yönergelerinin listesi sayfasında bulabilirsiniz.

php_value isim değer

Belirtilen değeri ismi belirtilen yönergeye atar. Sadece PHP_INI_ALL ve PHP_INI_PERDIR türü yönergeler için kullanılabilir. Önceki atanan değeri silmek için değer olarak none kullanın.

Bilginize: Mantıksal değer atamak için php_value yönergesini değil, php_flag (aşağıya bakınız) yönergesini kullanmalısınız.

php_flag isim on|off

Bir mantıksal yapılandırma yönergesi atamak için kullanılır. Sadece PHP_INI_ALL ve PHP_INI_PERDIR türü yönergeler için kullanılabilir.

php_admin_value isim değer

İsmi belirtilen yönergeye belirtilen değeri atar. .htaccess dosyalarında kullanılamaz. Bu yönerge ile atanan hiçbir yönerge türü ini_set() veya .htaccess tarafından geçersiz kılınamaz. Önceki atanan değeri silmek için değer olarak none kullanın.

php_admin_flag isim on|off

Bir mantıksal yapılandırma yönergesi atamak için kullanılır. .htaccess dosyalarında kullanılamaz. Bu yönerge ile atanan hiçbir yönerge türü .htaccess veya ini_set() tarafından geçersiz kılınamaz.

Örnek 1 - Apache yapılandırma örneği

<IfModule mod_php5.c>
  php_value include_path ".:/usr/local/lib/php"
  php_admin_flag engine on
</IfModule>
<IfModule mod_php4.c>
  php_value include_path ".:/usr/local/lib/php"
  php_admin_flag engine on
</IfModule>

Dikkat

PHP sabitleri PHP dışında mevcut değildir. Örneğin, httpd.conf dosyasında error_reporting yönergesine E_ALL veya E_NOTICE PHP sabitlerini atayamazsınız. Bunu yaparsanız daima 0 olarak değerlendirileceklerdir. Sabitleri kullanmak yerine bunların bit maskelerini kullanın. Bu sabitler php.ini içinde kullanılabilir.

PHP yapılandırmasının Windows kayıt defteri üzerinden değiştirilmesi

PHP, Windows üzerinde çalışırken, yapılandırma değerleri Windows kayıt defteri kullanılarak her dizin için ayrı ayrı değiştirilebilir. Yapılandırma değerleri defterde HKLM\SOFTWARE\PHP\Per Directory Values anahtarının dizin isimlerine karşılık gelen alt anahtarlarında saklanır. Örneğin, c:\inetpub\wwwroot dizini için yapılandırma değerleri HKLM\SOFTWARE\PHP\Per Directory Values\c\inetpub\wwwroot anahtarında saklanır. Dizin ile ilgili ayarlar, dizin içinde ve alt dizinlerde çalıştırılan her betik için geçerli olur. Anahtar altındaki değerler PHP yapılandırma yönergelerinin isimlerini ve dizge değerlerini içermelidir. Değerlerde bulunan PHP sabitleri çözümlenmez. Sadece, PHP_INI_USER türü değişebilir yapılandırma değerleri bu yolla atanabilir, PHP_INI_PERDIR değerleri atanamaz.

Diğer PHP arayüzleri

PHP'yi nasıl çalıştırdığınızdan bağımsız olarak, belli değerleri betiğinizin çalışması sırasında ini_set() işlevi sayesinde değiştirebilirsiniz. Bu konuda daha ayrıntılı bilgi için ini_set() sayfasına bakınız.

Sistem yapılandırmanızla ilgili ayarlar ve mevcut değerleri ilginizi çekiyorsa phpinfo() işlevini çalıştırabilir ve elde ettiğiniz sayfayı inceleyebilirsiniz. Ayrıca, yapılandırma yönergelerinin her birine çalışma anında ini_get() veya get_cfg_var() işlevini kullanarak erişebilirsiniz.

Yapılandırma ayarlarının yeri
Dil Başvuru Kılavuzu
Çalışma Anı Yapılandırması


Dil Başvuru Kılavuzu

  • Temel Sözdizimi
    • HTML'den Kaçmak
    • Deyim Ayrımı
    • Açıklamalar
  • Türler
    • Giriş
    • boolean
    • integer
    • float
    • string
    • array
    • object
    • resource
    • NULL
    • Geriçağırımlar / Çağırılılabilirler
    • Bu belgede kullanılan sözde türler ve değişkenler
    • Tür Dönüşümü
  • Değişkenler
    • Temeller
    • Öntanımlı Değişkenler
    • Değişken etki alanı
    • Değişken değişkenler
    • Dış Kaynaklı Değişkenler
  • Sabitler
    • Söz dizimi
    • Sihirli Sabitler
  • İfadeler
  • İşleçler
    • İşleç Önceliği
    • Aritmetik İşleçler
    • Atama İşleçleri
    • Bitsel İşleçler
    • Karşılaştırma İşleçleri
    • Hata Denetim İşleçleri
    • Çalıştırma İşleci
    • Arttırım ve Eksiltim İşleçleri
    • Mantıksal İşleçler
    • Dizge İşleçleri
    • Dizi İşleçleri
    • Tür İşleçleri
  • Denetim Yapıları
    • Giriş
    • if
    • else
    • elseif/else if
    • Denetim yapıları için diğer sözdizimi
    • while
    • do-while
    • for
    • foreach
    • break
    • continue
    • switch
    • declare
    • return
    • require
    • include
    • require_once
    • include_once
    • goto
  • İşlevler
    • Kullanıcı tanımlı işlevler
    • İşlev değiştirgeleri
    • Dönen değerler
    • Değişken işlevler
    • Yerleşik işlevler
    • Anonim işlevler
  • Sınıflar ve Nesneler
    • Giriş
    • Temel Kavramlar
    • Özellikler
    • Sınıf Sabitleri
    • Özdevinimli Sınıf Yükleme
    • Kurucular ve Yıkıcılar
    • Görünürlük
    • Nesnelerin Kalıtımı
    • Etki Alanı Çözünürlük İşleci (::)
    • static Anahtar Sözcüğü
    • Sınıf Soyutlama
    • Nesne Arayüzleri
    • Nitelikler
    • Anonymous classes
    • Aşırı Yükleme
    • Nesne Yineleme
    • Sihirli Yöntemler
    • final Anahtar Sözcüğü
    • Nesne Kopyalama
    • Nesnelerin Karşılaştırılması
    • Tür Dayatma
    • Duruk İçselleştirim
    • Nesneler ve Gönderimler
    • Object Serialization
    • OOP Changelog
  • İsim Alanları
    • Giriş
    • İsim Alanlarının Tanımlanması
    • Alt İsim Alanlarının Bildirilmesi
    • Birden Fazla İsim Alanının Aynı Dosyada Tanımlanması
    • İsim alanlarının kullanımı: Temeller
    • İsim alanları ve devingen dil özellikleri
    • namespace sözcüğü ve __NAMESPACE__ sabiti
    • İsim alanlarının kullanımı: İthal/Rumuz
    • Küresel Alan
    • İsim alanlarının kullanımı: son çare olarak küresel işlev ve sabitler
    • İsim çözünürlük kuralları
    • SSS: İsim alanları hakkında bilinmesi gerekenler
  • Errors
    • Temeller
    • Errors in PHP 7
  • İstisnalar
    • İstisnaları Genişletmek
  • Generators
    • Generators overview
    • Generator syntax
    • Comparing generators with Iterator objects
  • Gönderimlerle İlgili Herşey
    • Gönderim Nedir?
    • Gönderim Ne Yapar?
    • Gönderimler Ne Değildir?
    • Gönderimle Aktarım
    • Gönderimle Döndürme
    • Gönderimi Tanımsız Yapmak
    • Gönderimleri kullanan diğer oluşumlar
  • Öntanımlı Değişkenler
    • Süper küreseller — Süper küreseller bütün etki alanlarında daima mevcut olan yerleşik değişkenlerdir
    • $GLOBALS — Küresel alanda bulunan bütün değişkenleri içerir
    • $_SERVER — Sunucu ve işletme ortamı bilgisi
    • $_GET — HTTP GET değişkenleri
    • $_POST — HTTP POST değişkenleri
    • $_FILES — HTTP Dosya Yükleme değişkenleri
    • $_REQUEST — HTTP İstek değişkenleri
    • $_SESSION — Oturum değişkenleri
    • $_ENV — Ortam değişkenleri
    • $_COOKIE — HTTP Çerezleri
    • $php_errormsg — Önceki hata iletisi
    • $HTTP_RAW_POST_DATA — Ham POST verisi
    • $http_response_header — HTTP yanıt başlıkları
    • $argc — Betiğe geçirilen ifade sayısı
    • $argv — Betiğe geçirilen ifade dizisi
  • Öntanımlı İstisnalar
    • Exception — Exception Sınıfı
    • ErrorException — ErrorException Sınıfı
  • Öntanımlı Arayüzler ve Sınıflar
    • Traversable — Traversable arayüzü
    • Iterator — Iterator Arayüzü
    • IteratorAggregate — IteratorAggregate Arayüzü
    • ArrayAccess — ArrayAccess arayüzü
    • Serializable — Serializable arayüzü
    • Closure — The Closure class
    • Generator — The Generator class
  • Bağlam seçenekleri ve değiştirgeleri
    • Soket bağlamı seçenekleri — Soket bağlamı seçeneklerinin listesi
    • HTTP bağlamı seçenekleri — HTTP bağlamı seçeneklerinin listesi
    • FTP bağlamı seçenekleri — FTP bağlamı seçeneklerinin listesi
    • SSL bağlamı seçenekleri — SSL bağlamı seçeneklerinin listesi
    • CURL bağlamı seçenekleri — CURL bağlamı seçeneklerinin listesi
    • Phar bağlam seçenekleri — Phar bağlamı seçeneklerinin listesi
    • MongoDB için bağlamsal seçenekler — MongoDB için bağlamsal seçeneklerin listesi
    • Bağlam değiştirgeleri — Bağlam değiştirgesi listeleme
  • Supported Protocols and Wrappers
    • file:// — Accessing local filesystem
    • http:// — Accessing HTTP(s) URLs
    • ftp:// — Accessing FTP(s) URLs
    • php:// — Accessing various I/O streams
    • zlib:// — Compression Streams
    • data:// — Data (RFC 2397)
    • glob:// — Find pathnames matching pattern
    • phar:// — PHP Archive
    • ssh2:// — Secure Shell 2
    • rar:// — RAR
    • ogg:// — Audio streams
    • expect:// — Process Interaction Streams
Yapılandırma ayarlarının değiştirilmesi
Temel Sözdizimi
PHP Kılavuzu


Temel Sözdizimi

İçindekiler

  • HTML'den Kaçmak
  • Deyim Ayrımı
  • Açıklamalar
Dil Başvuru Kılavuzu
HTML'den Kaçmak
Dil Başvuru Kılavuzu


HTML'den Kaçmak

PHP bir dosyayı çözümlerken, hangi bölümü yorumlayıp hangi bölümü yorumlamadan geçeceğine açılış ve kapanış etiketlerine bakarak karar verir. PHP'nin bu şekilde çalışıyor olması, PHP'nin çesitli türde birçok belgenin içine gömülebilmesini sağlar, çünkü PHP başlangıç ve bitiş etiketlerinin dışında kalan her şey PHP çözümleyicisi tarafından gözardı edilir. Çoğu zaman, bu örnekte olduğu gibi PHP'nin HTML içine gömülmüş olduğunu göreceksiniz.

<p>Bu bölüm gözardı edilecektir.</p>
<?php echo 'Bu bölüm PHP tarafından çözümlenecektir.'; ?>
<p>Bu bölüm de gözardı edilecektir.</p>

Daha gelişmiş yapılar da kullanmanız mümkündür:

Örnek 1 - Gelişmiş önceleme

<?php
if ($ifade) {
    ?>
    <strong>Bu önerme doğrudur.</strong>
    <?php
} else {
    ?>
    <strong>Bu önerme yanlıştır.</strong>
    <?php
}
?>
Bu beklendiği gibi çalışacaktır, çünkü PHP, ?> kapanış etiketi ile karşılaştığında, tekrar bir açılış etiketi ile karşılaşana kadar bulduğu herşeyi (kapanış etiketinden sonraki satırsonu karakteri hariç - bkz, deyim ayırma) çıktılayacaktır. Buradaki örnek oldukça basit, ancak büyük metin bloklarını görüntülemek istediğimizde PHP'yi çözümleme kipinden çıkartmak çoğu zaman tüm metni echo ya da print ile görüntülemekten daha verimlidir.

PHP ile kullanılabilecek dört farklı açılış ve kapanış etiketi çifti vardır. Bunlardan ikisi, <?php ?> ve <script language="php"> </script> her zaman kullanılabilir durumdadır. Diğer ikisi, kısa etiketler ve ASP tarzı etiketler olup php.ini yapılandırma dosyası içersinden açılıp kapatılabilirler. Bazı kişiler kısa etiketleri ve ASP tarzı etiketleri daha kullanışlı bulmaktadır, ancak bu ikisi daha az taşınabilir olduklarından genellikle tavsiye edilmemektedir.

Bilginize:

Bir diğer önemli nokta, PHP'yi XML ya da XHTML içine gömmek istiyorsanız standartlarla uyumlu kalabilmek için <?php ?> etiketlerini kullanmanız gerektiğidir.

Örnek 2 - PHP Açılış ve Kapanış Etiketleri

1.  <?php echo 'XHTML ya da XML belgeleri sunacaksanız, böyle yapın'; ?>

2.  <script language="php">
        echo 'bazı düzenleyiciler (FrontPage gibi) işlem
             yönergelerini sevmezler';
    </script>

3.  <? echo 'Bu en basit, SGML işlem yönergesidir'; ?>
    <?= ifade ?> Bu "<? echo ifade ?>" için bir kısayoldur.

4.  <% echo 'İsterseniz ASP tarzı etiketler kullanabilirsiniz'; %>
    <%= $degisken; # Bu "<% echo . . ." %> için bir kısayoldur.

Bir ve iki numaralı örneklerde gözüken etiketler her zaman kullanılabilirler. Bu ikisinden birincisi en geniş kullanıma sahip olanı ve en çok tercih edilenidir.

Kısa etiketler (üçüncü gibi) yalnızca php.ini içersinde short_open_tag yapılandırma yönergesiyle etkinleştirilmişlerse ya da PHP, --enable-short-tags derleme seçeneği ile yapılandırılmışsa kullanılabilirler.

ASP tarzı etiketler (dördüncü örnek) php.ini dosyasında asp_tags yapılandırma yönergesiyle etkinleştirilmişlerse kullanılabilirler.

Bilginize:

Geliştirdiğiniz uygulamaları ya da kütüphaneleri başkalarına dağıtacaksanız ya da bu uygulamaları denetiminizde olmayan PHP sunucularına kuracaksanız kısa etiketleri kullanmaktan kaçınmalısınız, çünkü hedef sunucu kısa etiketleri desteklemiyor olabilir. Kodlarınızın taşınabilir ve yeniden dağıtılabilir olması için, alışkanlıkla kısa etiketleri kullanmadığınızdan emin olun.

Bilginize:

PHP 5.2 ve öncesinde, çözümleyici, bir dosya içindeki tek şey olarak <?php başlangıç etiketine izin vermezdi. PHP 5.3'ten itibaren izin verilmektedir.

Temel Sözdizimi
Deyim Ayrımı
Temel Sözdizimi


Deyim Ayrımı

C ya da Perl'de olduğu gibi, PHP de deyimlerin birbirlerinden her bir deyimin sonuna konulacak noktalı virgülle ayrılmasını gerektirir. Bir PHP kod bloğunun sonunda yer alan kapanış etiketi kendinden önceki deyim için noktalı virgül işlevi görür; yani, bir PHP bloğunun son satırının sonuna noktalı virgül koymak zorunda değilsiniz. Kapanış etiketi aynı zamanda satırsonu karakterini de kendisi ekleyecektir.

<?php
    echo 'Bu bir denemedir';
?>

<?php echo 'Bu bir denemedir' ?>

<?php echo 'Son kapanış etiketini koymadık';

Bilginize:

Dosya sonunda PHP kapanış etiketini kullanmak isteğe bağlıdır, hatta dosya sonlarında istemdışı boş satırlar oluşması gibi durumlarda include, require gibi işlevlerin kullanımında yararlı bile olabilir, dahası sonradan yanıta başlık eklemeye devam edebilirsiniz. Bu özellik ayrıca, çıktı tamponlama kullanıyorsanız ve betiğe include ile eklediğiniz dosyalar tarafından üretilen kısımların sonunda gereksiz boş satırların oluşmasını istemediğinizde de işe yarar.

HTML'den Kaçmak
Açıklamalar
Temel Sözdizimi


Açıklamalar

PHP, 'C', 'C++' ve Unix kabuk tarzı (Perl tarzı) açıklamaların hepsini destekler. Örnegin:

<?php
    echo 'Bu bir denemedir'; // Bu tek satırlık c++ tarzı açıklamadır
    /* Bu, C tarzı çok satırlı
       bir açıklamadır */
    echo 'Bir deneme daha';
    echo 'Bu da sonuncusu'; # Bu tek satırlık kabuk tarzı açıklamadır
?>

"Tek satırlık" bir açıklamanın etki alanı yalnızca satır sonuna ya da PHP kod bloğunun sonuna kadardır. Yani, // ... ?> ya da # ... ?> kullanımından sonra gelecek HTML kodu YAZDIRILACAKTIR: ?> etiketi PHP kipinden çıkılmasına ve HTML kipine dönülmesini sağlar, // ya da # kullanımı bunu etkileyemez asp_tags yapılandırma yönergesi etkinse, asp tarzı // %> ve # %> kullanımı da böyle çalışır. Bununla birlikte, </script> etiketi tek satırlık açıklama için böyle duruma yol açmaz.

<h1>Bu <?php # echo 'basit';?> bir örnektir.</h1>
<p>Yukarıdaki başlık 'Bu bir örnektir' diye gösterilecektir.</p>

Bir 'C' tarzı açıklama ilk */ ile karşılaşıldığı noktada sona erer. 'C' tarzı açıklamaları iç içe kullanmamalısınız. Büyük miktarda kod bloğunu açıklama haline getirirken bu yanlış genellikle yapılır.

<?php
 /*
    echo 'Bu bir denemedir'; /* Bu açıklama sorun çıkaracak. */
 */
?>

Deyim Ayrımı
Türler
Temel Sözdizimi


Türler

İçindekiler

  • Giriş
  • boolean
  • integer
  • float
  • string
  • array
  • object
  • resource
  • NULL
  • Geriçağırımlar / Çağırılılabilirler
  • Bu belgede kullanılan sözde türler ve değişkenler
  • Tür Dönüşümü
Açıklamalar
Giriş
Dil Başvuru Kılavuzu


Giriş

PHP sekiz ilkel veri türü destekler.

Dört sayıl tür:

  • boolean
  • integer
  • float (kayan noktalı sayılar, namı-diğer double)
  • string

İki bileşik tür:

  • array
  • object

Ve son olarak üç özel tür:

  • resource
  • NULL
  • callable

Bu kılavuzda ayrıca, okunabilirliği arttırmak için bazı sözde türlere de yer verilmiştir:

  • mixed
  • number
  • callback
  • void

Ve sözde değişken: $....

Kılavuzun bazı yerlerinde tür ismi olarak "double" hala kalmış olabilir. Bunları "float" olarak ele alın; iki isminde varlık sebebi tamamen tarihseldir.

Normal olarak, değişken türünü programcı belirlemez; çalışma anında değişkenin bulunduğu bağlama göre buna PHP karar verir.

Bilginize: Bir ifadenin değerinin ve türünün ne olduğuna bakmak için var_dump() işlevini kullanabilirsiniz.

Hata ayıklama amacıyla bir değişkenin türünü öğrenmek için gettype() işlevini kullanın. Belli bir türü sınamak için gettype() değil is_tür işlevlerini kullanın. Bazı örnekler:

<?php
$a_bool = TRUE;   // boolean türünde
$a_str  = "foo";  // string türünde
$a_str2 = 'foo';  // string türünde
$an_int = 12;     // integer  türünde

echo gettype($a_bool); // boolean basar
echo gettype($a_str);  // string basar

// Değişken bir tamsayı ise değeri dört arttır
if (is_int($an_int)) {
    $an_int += 4;
}

// $a_bool bir dizge ise değeri çıktıla
// (hiçbir şey çıktılanmayacaktır)
if (is_string($a_bool)) {
    echo "Dizge: $a_bool";
}
?>

Bir değişkenin türünün mutlaka belli bir türe dönüşmesini isterseniz ya tür çarpıtma yapın ya da settype() işlevini kullanın.

Yerine göre bazı durumlarda bir değişkenin değeri farklı değerlendirilir. Daha ayrıntılı bilgi için Tür Dönüşümü bölümüne bakınız. Ayrıca, türlerle ilgili çeşitli karşılaştırmaların listelendiği Tür karşılaştırma tabloları da yararlı olabilir.

Türler
boolean
Türler


boolean

En basit türdür. Bir mantıksal ifadenin sonucu TRUE veya FALSE olan bir doğruluk değeridir.

Bilginize: boolean türü PHP 4'ten beri vardır.

Sözdizimi

Bir boolean sayılını belirtmek için TRUE veya FALSE anahtar sözcüğü kullanılır. Her ikisi de harf büyüklüğüne duyarsızdır.

<?php
$foo = True; // $foo değişkenine TRUE değeri atanır.
?>

Genelde, boolean türünde bir değer döndüren bir çeşit işleç vardır ve bu değer bir denetim yapısına aktarılır.

<?php
// == işleci, eşitliği sınar ve
// boolean türünde bir değer döndürür
if ($eylem == "sürümü göster") {
    echo "Sürüm numarası 1.23'tür.";
}

// Bu gereksizdir...
if ($ayırıcı_göster == TRUE) {
    echo "<hr>\n";
}

// ... böylesi daha iyidir:
if ($ayırıcı_göster) {
    echo "<hr>\n";
}
?>

boolean türüne dönüşüm

Bir değeri doğrudan boolean türüne dönüştürmek için (bool) veya (boolean) çarpıtmalarını kullanabilirsiniz. Ancak, bir boolean değiştirge gerektiren bir işleç, işlev veya denetim yapısı dönüşümün özdevinimli olarak yapılmasını sağladığından çoğu durumda tür çarpıtma gereksizdir.

Ayrıca, Tür Dönüşümü bölümüne de bakınız.

Aşağıdaki değerler boolean türüne dönüşümde FALSE olarak ele alınırlar:

  • boolean FALSE (kendisi)
  • integer 0 (sıfır)
  • the float 0.0 (sıfır)
  • boş string, ve string "0"
  • hiç elemanı olmayan array
  • hiç üye değişkeni olmayan object (sadece PHP 4)
  • NULL türü (tanımsız değişkenler dahil)
  • boş etiketlerle oluşturulmuş SimpleXML nesneleri

Bunların dışında kalan tüm değerler TRUE olarak ele alınır (resource türler dahil).

Uyarı

-1 ve sıfırdan farklı diğer değerler (pozitif veya negatif) TRUE olarak ele alınır.

<?php
var_dump((bool) "");        // bool(false)
var_dump((bool) 1);         // bool(true)
var_dump((bool) -2);        // bool(true)
var_dump((bool) "foo");     // bool(true)
var_dump((bool) 2.3e5);     // bool(true)
var_dump((bool) array(12)); // bool(true)
var_dump((bool) array());   // bool(false)
var_dump((bool) "false");   // bool(true)
?>
Giriş
integer
Türler


integer

Bir integer türünde değer şu kümeden bir tamsayıdır: Z = {..., -2, -1, 0, 1, 2, ...}.

Bunlara da bakınız:

  • Keyfi uzunlukta tamsayı / GMP
  • Kayan noktalı sayılar
  • Keyfi ondalık hassasiyet / BCMath

Syntax

integer türünde değerler onluk, sekizlik veya onaltılık tabanda belirtilebilirler ve önlerinde isteğe bağlı bir + veya - işareti bulunabilir.

Sekizlik gösterimde sayıların önüne 0 (sıfır), onaltılık gösterimde ise 0x getirilir.

Örnek 1 - Tamsayı sayıllar

<?php
$a = 1234; // onluk tabanda bir sayı
$a = -123; // negatif bir sayı
$a = 0123; // sekizlik tabanda bir sayı (onluk: 83)
$a = 0x1A; // onaltılık tabanda bir sayı (onluk: 26)
?>

Biçimsel olarak integer sayılların yapısı:

onluk     : [1-9][0-9]*
          | 0

onaltılık : 0[xX][0-9a-fA-F]+

sekizlik  : 0[0-7]+

tamsayı   : [+-]?onluk
          | [+-]?onaltılık
          | [+-]?sekizlik

Bir integer türün genişliği platforma göre değişir. 32 bitlik sistemlerde azami değer 2 milyon civarında iken 64 bitlik sistemlerde 9E18 civarındadır. PHP işaretsiz tamsayıları (C'deki unsigned) desteklemez. integer türün genişliği PHP 4.4.0'da PHP_INT_SIZE sabitine ve olası en büyük değeri ise PHP 5.0.5'te PHP_INT_MAX sabitine atanmıştır.

Uyarı

Sekizlik bir değer içinde geçersiz bir rakam kullanılmışsa (8, 9 gibi) o ve kalan tüm rakamlar yok sayılır.

Örnek 2 - Sekizlik garabeti

<?php
var_dump(01090); // sekizlik: 010, onluk: 8
?>

Tamsayılarda taşma

PHP, integer türünde bir değerin bellekte integer türüne ayrılan genişliğe sığmadığını saptarsa float türünde bir değer olarak ele alır ve bu durum yapılan bir işlem sırasında ortaya çıkmışsa işlemden dönen değer float türünde olur.

Örnek 3 32 bitlik sistemlerde tamsayı taşması

<?php
$büyük_sayı =  2147483647;
var_dump($büyük_sayı);

$büyük_sayı =  2147483648;
var_dump($büyük_sayı);

$milyon = 1000000;
$büyük_sayı =  50000 * $million;
var_dump($büyük_sayı);
?>

Örnek 4 64 bitlik sistemlerde tamsayı taşması

<?php
$büyük_sayı = 9223372036854775807;
var_dump($büyük_sayı);                     // int(9223372036854775807)

$büyük_sayı = 9223372036854775808;
var_dump($büyük_sayı);                     // float(9.2233720368548E+18)

$milyon = 1000000;
$büyük_sayı=  50000000000000 * $milyon;
var_dump($büyük_sayı);                     // float(5.0E+19)
?>
Uyarı

Ne yazık ki, bunun negatif sayılar için her zaman çalışmaması şeklinde kendini gösteren bir PHP yazılım hatası mevcuttu. Örneğin, -50000 * $milyon işleminin sonucu -429496728 olmaktadır. Ancak, her iki terimin işareti pozitif olduğunda hiçbir sorun çıkmamaktadır.

Bu hata PHP 4.1.0'da düzeltilmiştir.

PHP'de sonucun integer türünde elde edileceği bir bölme işlemi mevcut değildir. 1/2 işleminin sonucu float türünde 0.5 değeridir. Bu değer (integer) ile çarpıtılarak aşağı yuvarlamak suretiyle bir tamsayıya dönüştürülebilirse de round() işlevini kullanırsanız dönüşümün nasıl yapılacağını kendiniz belirleyebilirsiniz.

<?php
var_dump(25/7);         // float(3.5714285714286)
var_dump((int) (25/7)); // int(3)
var_dump(round(25/7));  // float(4)
?>

integer türüne dönüşüm

Bir değeri doğrudan integer türüne dönüştürmek için (int) veya (integer) çarpıtmasını kullanabilirsiniz. Ancak, çoğu durumda türü çarpıtmak gerekmez, bir tamsayı değer gerektiren bir işlev veya denetim yapısı, değeri özdevinimli olarak integer türüne dönüştürecektir. Ayrıca, bir değer integer türüne intval() işleviyle de dönüştürülebilir.

Ayrıca, Tür Dönüşümü bölümüne de bakınız.

boolean türünden dönüşüm

FALSE, 0'a (sıfır); TRUE, 1'e (bir) dönüştürülür.

float türünden dönüşüm

float türünden integer türüne dönüşümde sayı sıfıra yaklaştırılarak yuvarlanır.

Dönüşüm sonucu integer türüne ayrılan genişliğe (normalde 32 bitlik sistemlerde +/- 2.15e+9 = 2^31, 64 bitlik sistemlerde ise +/- 9.22e+18 = 2^63) sığmıyorsa, float türün hassasiyeti integer türünde tam bir sonuç vermeyeceğinden sonuç tanımsızdır. Bu durumda ne bir uyarı ne de bir bilgi verilir!

Uyarı

Ondalık kısmı integer türüne asla dönüştürmeyin, yoksa beklenmedik sonuçlar elde edebilirsiniz.

<?php
echo (int) ( (0.1+0.7) * 10 ); // çıktısı: 7!
?>

Ayrıca bakınız: Kayan noktalı sayılarda hassasiyet uyarısı.

string türünden dönüşüm

Dizgelerin sayılara dönüşümü bölümüne bakınız.

Diğer türlerden dönüşüm

Dikkat

Diğer türlerden integer türüne dönüşümün nasıl davranacağı henüz kesin olarak tanımlanmamıştır. Gözlemlediğiniz bir davranışın doğruluğuna güvenmeyiniz, ileride bu davranış hiçbir bilgi verilmeden değiştirilebilir.

boolean
float
Türler


float

Gerçek sayılar (veya kayan noktalı sayılar) şu sözdizimleri ile belirtilebilir:

<?php
$a = 1.234;
$b = 1.2e3;
$c = 7E-10;
?>

Biçimsel olarak:

LNUM          [0-9]+
DNUM          ([0-9]*[\.]{LNUM}) | ({LNUM}[\.][0-9]*)
USTEL_DNUM    [+-]?(({LNUM} | {DNUM}) [eE][+-]? {LNUM})

Bir gerçek sayının bellekte kapladığı genişlik platforma göre değişmekteyse de kabaca 14 hanelik bir hassasiyetle ~1.8e308'lik olası bir en büyük değer (64 bitlik IEEE biçemi) hepsi için sağlanır.

Uyarı

Kayan nokta hassasiyeti

Kayan noktalı sayılar sınırlı bir hassasiyete sahiptir. Sisteme bağımlı olmakla birlikte PHP normalde (1.11e-16'lık bir yuvarlamadan dolayı görece en büyük hatayı verecek olan) IEEE 754 çift hassasiyetli biçimi kullanır. 4 temel işlemden daha karmaşık aritmetik işlemler daha büyük hatalar verebilir, dolayısıyla işlemler karmaşık hale gelmeye başlayınca hatanın açıklanması bir önkabul olarak ele alınmalıdır.

Ek olarak, 0.1 veya 0.7 gibi 10 tabanında kayan noktalı sayılar olarak tamamiyle gösterilebilen gerçel sayılar, 2 tabanında kayan noktalı sayılar olarak tamamiyle gösterilemezler. Bu bakımdan, az da olsa bir kayıp olmaksızın dahili ikil karşılıklarına dönüştürülemezler. Bunun şöyle bir sonucu olur: örneğin, floor((0.1+0.7)*10) işlevinden beklendiği gibi 8 değil, 7 döner; bunun sebebi dahili gösterimin aslında 7.9999999999999991118... gibi bir değer olmasıdır.

Bu bakımdan, son ondalık hanesine bakarak sonucun ne olacağına karar verilemez, bu bakımdan kayan noktalı sayılar arasında asla eşitlik karşılaştırmaları yapılmaz. Eğer daha yüksek hassasiyet isteniyorsa keyfi hassasiyetli matematik işlevleri ve gmp işlevleri kullanılabilir.

"Basit" bir açıklama için » kayan noktalı sayılar kılavuzuna bakınız.

float türüne dönüşüm

string türleri float türlere dönüştürmek için gereken bilgileri Dizgelerin sayılara dönüşümü bölümünde bulabilirsiniz. Diğer türlerden float türüne dönüşüm için değer önce integer türüne dönüştürülür. Daha fazla bilgi için integer türüne dönüşüm bölümüne bakınız. PHP 5 itibariyle, bir object tür float türe dönüştürülmeye çalışılırsa bir uyarı üretilir.

Kayan noktalı sayıların karşılaştırılması

Yukarıdaki uyarıda kısaca değinildiği gibi kayan noktalı sayılar arasında eşitlik karşılaştırmaları, bunların dahili gösterimlerinden dolayı biraz sorunludur. Bununla birlikte, bu sınırlamaların aşılmasını ve kayan noktalı sayılar arasında karşılaştırma yapılmasını sağlayan yollar vardır.

Kayan noktalı değerlerin eşitliğini sınamak için yuvarlamadan dolayı ortaya çıkan göreli hatanın bir üst sınırı kullanılır. Bu değer makine epsilonu veya yuvarlama birimi olarak bilinir ve hesaplamalardaki kabul edilebilir en küçük farktır.

$a ve $b 5 haneli hassasiyetle eşittir.

<?php
$a = 1.23456789;
$b = 1.23456780;
$epsilon = 0.00001;

if(abs($a-$b) < $epsilon) {
    echo "doğru";
}
?>

NaN

Bazı sayısal işlemler NAN sabiti ile gösterilen bir değerle sonuçlanabilir. Bu sonuç, kayan noktalı hesaplamalarda tanımlanamayan veya gösterilemeyen bir değeri gösterir. Bu değerin, kendisi dahil herhangi bir değerle gevşek ya da sıkı bir karşılaştırması FALSE sonucuna sebep olur.

NAN farklı değerdeki herhangi bir sayıyı temsil ettiğinden kendisi dahil başka bir değerle karşılaştırılmamalı, bunun yerine değer is_nan() ile sınanmalıdır.

integer
string
Türler


string

Bir dizge string türünde bir sayıl değer olup bir dizi karakterden oluşur. Bu bakımdan her karakter tek bayt ile ifade edilir. Yani, olası karakter sayısı 256'dan ibarettir. Bu yüzden PHP Evrenkod için yerleşik desteğe sahip olamıyor. Temel Evrenkod işlevselliği hakkında bilgi edinmek için utf8_encode() ve utf8_decode() işlevlerine bakınız.

Bilginize: Bir dizgenin çok büyük olması bir sorun teşkil etmez. PHP, string türünde bir değer için boyut sınırlaması yapmaz; tek sınırlama PHP'nin çalıştığı makinede PHP'nin kullanımına ayrılan bellek miktarıdır.

Sözdizimi

string türünde bir sayıl dört şekilde belirtilebilir:

  • tek tırnaklı dizge
  • çift tırnaklı dizge
  • yorumlu metin (heredoc)
  • yorumsuz metin (nowdoc) - (PHP 5.3.0 ve sonrası)

Tek tırnaklı dizgeler

Bir dizgeyi belirtmenin en basit yolu dizgeyi tek tırnak (') imlerinin arasına almaktır.

Tek tırnaklı bir dizge içinde tek tırnağı sayıl değeriyle kullanmak isterseniz önüne bir tersbölü imi getirmelisiniz (\). Bir tersbölü imini sayıl değeriyle kullanmak isterseniz onun da önüne bir tersbölü imi getirmelisiniz (\\). Tersbölü imini bunlardan başka bir karakterin önünde kullanırsanız, tersbölü imi karakterle birlikte basılır.

Bilginize: Diğer üç sözdiziminin aksine, değişkenler ve özel karakterlerin öncelemleri tek tırnaklı dizgelerin içinde kullanıldıklarında yorumlanmazlar.

<?php
echo 'Bu basit bir dizgedir';

echo 'Dizgelerin içinde satırsonu karakterlerini
tıpkı buradaki gibi
kullanabilirsiniz';

// Çıktısı: Arnold dedi ki: "I'll be back"
echo 'Arnold dedi ki: "I\'ll be back"';

// Çıktısı: You deleted C:\*.*?
echo 'You deleted C:\\*.*?';

// Çıktısı: You deleted C:\*.*?
echo 'You deleted C:\*.*?';

// Çıktısı: This will not expand: \n a newline
echo 'This will not expand: \n a newline';

// Çıktısı: Variables do not $expand $either
echo 'Variables do not $expand $either';
?>

Çift tırnaklı dizgeler

Eğer bir dizge çift tırnak (") içine alınmışsa PHP, aşağıdaki özel karakter öncelemlerini yorumlayacaktır:

Tersbölü ile öncelenmiş karakterler
Öncelem | Anlamı
\n | satırsonu (LF veya ASCII 10 (0x0A))
\r | satırbaşı (CR veya ASCII 13 (0x0D))
\t | yatay sekme (HT veya ASCII 9 (0x09))
\v | düşey sekme (VT veya ASCII 11 (0x0B)) (PHP 5.2.5 ve sonrası)
\f | sayfa ileri (FF veya ASCII 12 (0x0C)) (PHP 5.2.5 ve sonrası)
\\ | tersbölü
\$ | dolar imi
\" | çift tırnak
\[0-7]{1,3} | Bu düzenli ifade ile eşleşen dizilim, karakterin sekizlik gösterimidir.
\x[0-9A-Fa-f]{1,2} | Bu düzenli ifade ile eşleşen dizilim, karakterin onaltılık gösterimidir.

Tersbölü imini bunlardan başka bir karakterin önünde kullanırsanız, tersbölü imi karakterle birlikte basılır. PHP 5.1.1'den önce, \{$var} içindeki tersbölü imi basılmıyordu.

Çift tırnaklı dizgelerin en önemli özelliği içerdiği değişkenlerin yorumlanmasıdır. Bu konuda daha ayrıntılı bilgi edinmek için Değişken çözümleme bölümüne bakınız.

Yorumlu metinler

Bir dizgenin sınırlarını belirlemenin üçüncü yolu, yorumlu metin sözdizimidir. Bir yorumlu metin daima <<< karakterleri ile başlar ve hemen ardından bir betimleyici ve bir satırsonu karakteri gelir. Asıl dizge satırsonu karakterinden sonra yer alır. Dizgenin sonunu belirtmek üzere dizgenin sonuna, baştaki betimleyici konur.

Kapanış betimleyicisinin dizgeden sonraki satırın başında olması gerekir. Ayrıca, betimleyici PHP'deki diğer isimlere uygulanan kurallara uygun olmalıdır: Sadece bir harfle veya alt çizgi imi ile başlayabilir; sadece harfler, rakamlar veya alt çizgi imleri içerebilir.

Uyarı

Kapanış betimleyicisinin bulunduğu satırda betimleyicinin hemen ardına konan noktalı virgül (;) dışında hiçbir karakter bulunmaması çok önemli olup buna özellikle dikkat etmelisiniz. Yani, betimleyici özellikle girintilenmemeli; noktalı virgülden önce ve sonra herhangi bir boşluk karakteri bulunmamalıdır. Ayrıca, kapanış betimleyicisinden hemen önce gelen karakterin yerel işletim sistemine özgü satırsonu karakteri olması çok önemlidir. Bu karakter Unix ve Mac OS X için \n'dir. Kapanış betimleyicisinden (ve olası noktalı virgül karakterinden) sonraki karakter de böyle bir satırsonu karakteri olmalıdır.

Eğer bu kurallara uyulmaz ve kapanış betimleyicisinin etrafı temiz tutulmazsa kapanış betimleyicisi algılanamayacağından PHP kapanış betimleyicisini aramaya devam edecektir. Eğer dosyanın sonuna kadar uygun bir kapanış betimleyicisi bulunamazsa son satırda bir çözümleme hatası oluşacaktır.

Yorumlu metinler sınıf özelliklerini ilklendirmek için kullanılamazlar. PHP 5.3'ten beri bu sınırlama sadece değişken içeren yorumlu metinler için geçerlidir. Bunun yerine yorumsuz metinler kullanılabilir.

Örnek 1 - Geçersiz örnek

<?php
class foo {
    public $bar = <<<EOT
bar
EOT;
}
?>

Yorumlu metinler tıpkı çift tırnaklı dizgeler gibi davranırlar. Yorumlu metin çift tırnaklar arasına alınmaz ve metin içindeki çift tırnak imlerinin tersbölü ile öncelenmesi gerekmez, ancak yukarıda çift tırnaklı dizgeler için belirtilen öncelem kodları kullanılabilir. Değişkenler yorumlanır, fakat yorumlanan metin içinde yer alan karmaşık değişkenler ifade edilirken dizgelerde dikkate alınması gerekenler yorumlu metinlerde de dikkate alınmalıdır.

Örnek 2 - Yorumlu metin örneği

<?php
$str = <<<EOD
Yorumlu metin sözdizimi
kullanılarak çok sayıda
satıra bölünmüş dizge örneği.
EOD;

/* Değişkenlerin de kullanıldığı daha karmaşık bir örnek */
class foo
{
    var $foo;
    var $bar;

    function foo()
    {
        $this->foo = 'Foo';
        $this->bar = array('Bar1', 'Bar2', 'Bar3');
    }
}

$foo = new foo();
$name = 'Kimimben';

echo <<<EOT
Adım "$name" ve işim $foo->foo basmak.
Şimdi {$foo->bar[1]} basıyorum.
Bu büyük 'A' basmalı: \x41\n
EOT;
?>

Yukarıdaki örneğin çıktısı:

Adım "Kimimben" ve işim Foo basmak.
Şimdi Bar2 basıyorum.
Bu büyük 'A' basmalı: A

Ayrıca işlev değiştirgesinde veri aktarırken de yorumlu metin kullanılabilir:

Örnek 3 - Değiştirgelerde yorumlu metin kullanımı

<?php
var_dump(array(<<<EOD
foobar!
EOD
));
?>

PHP 5.3.0'dan itibaren, duruk değişkenleri ve sınıf özelliklerini veya sabitlerini yorumlu metin sözdizimini kullanarak ilklendirmek mümkündür:

Örnek 4 - Duruk değer olarak yorumlu metin kullanımı

<?php
// Duruk değişkenler
function foo()
{
  static $bar = <<<LABEL
Burada  hiçbir şey yok...
LABEL;
}

// Sınıf özellikleri ve sabitleri
class foo
{
  const BAR = <<<FOOBAR
Sınıf sabiti örneği
FOOBAR;

  public $baz = <<<FOOBAR
Özellik örneği
FOOBAR;
}
?>

PHP 5.3.0 ile ayrıca, yorumlu metinlerin bildiriminde çift tırnak kullanımı olasılığı da dikkate alınmıştır:

Örnek 5 - Yorumlu metin bildiriminde çift tırnak kullanımı

<?php
echo <<<"TIRNAKLI"
Merhaba Dünya!
TIRNAKLI;
?>

Bilginize:

Yorumlu metin desteği PHP 4'te eklenmiştir.

Yorumsuz metinler

Yorumlu metinlerin çift tırnaklı dizgelere karşılık gelmesi gibi yorumsuz metinler de tek tırnaklı dizgelere karşılık gelir. Yorumsuz metinler de yorumlular gibi belirtilir ama, yorumsuz metin içinde çözümleme yapılmaz. Yorumsuz metinler, PHP kodlarını veya büyük metin bloklarını herhangi bir önlem almaksızın içine yerleştirmek için elverişlidirler. Belirtilen metin bloğunun çözümlenmemesinden dolayı SGML'nin <![CDATA[ ]]> oluşumu ile benzer özelliklere sahiptir.

Yorumsuz metin de yorumlu metindeki <<< dizgesini kullanır fakat betimleyicisi tek tırnak içine alınır; yani, şuna benzer: <<<'EOT'. Yorumlu metin için geçerli tüm diğer kurallar yorumsuz metin için de geçerlidir; özellikle de kapanış betimleyici ile ilgili olanlar.

Örnek 6 - Yorumsuz metin örneği

<?php
$str = <<<'EOD'
Yorumlu metin sözdizimi
kullanılarak çok sayıda
satıra bölünmüş dizge örneği.
EOD;

/* Değişkenli daha karmaşık bir örnek. */
class foo
{
    public $foo;
    public $bar;

    function foo()
    {
        $this->foo = 'Foo';
        $this->bar = array('Bar1', 'Bar2', 'Bar3');
    }
}

$foo = new foo();
$name = 'Kimimben';

echo <<<'EOT'
İsmim "$name" ve işim $foo->foo basmak.
Artık {$foo->bar[1]} basıyorum.
Bu büyük 'A' basmalı: \x41
EOT;
?>

Yukarıdaki örneğin çıktısı:

İsmim "$name" ve işim $foo->foo basmak.
Artık {$foo->bar[1]} basıyorum.
Bu büyük 'A' basmalı: \x41

Bilginize:

Yorumlu metinlerin aksine yorumsuz metinler herhangi bir duruk veri bağlamında kullanılabilirler. Sınıf özelliklerini veya sabitlerini yorumsuz metin kullanarak ilklendirme örneği:

Örnek 7 - Duruk veri örneği

<?php
class foo {
    public $bar = <<<'EOT'
bar
EOT;
}
?>

Bilginize:

Yorumlu metin desteği PHP 5.3.0'da eklenmiştir.

Değişken çözümleme

Bir dizge çift tırnaklar arasında veya bir yorumlu metin olarak belirtilmişse içindeki değişkenler çözümlenir.

İki sözdizimi türü vardır: Biri basit, diğeri karmaşık. Basit sözdizimi en çok kullanılanı ve elverişli olanıdır; bir değişken, bir dizi değeri veya bir nesne özelliğini bir dizge içinde en az çabayla kullanmayı sağlar.

Karmaşık sözdizimi PHP4'ten itibaren kullanılmakta olup ifadeyi sarmalayan kaşlı ayraçlar biçiminde kendini gösterir.

Basit Sözdizimi

Çözümleyici, bir dolar imine ($) rastlandığında, geçerli bir değişken ismi oluşturmak için alabildiği bütün dizgecikleri açgözlülükle toplar. Değişken isminin kaşlı ayraçlar arasına alınması ismin sonunun açıkça belirtilmesini sağlar.

<?php
$bira = 'Bira';
echo "$bira'nın tadı berbattır"; // çalışır; "'" değişken adında geçersizdir
echo "$biralar geldi";   // çalışmaz; 'lar' değişken isminde geçerlidir
                         // ama değişken "$biralar" değildir.
echo "${bira}lar geldi"; // çalışır
echo "{$bira}lar geldi"; // çalışır
?>

Bir dizi indisi veya bir nesne özelliği de benzer şekilde çözümlenebilir. Dizi indislerinde indis sonunu, kapayan köşeli ayraç (]) belirler. Aynı kural, basit değişkenler olarak nesne özelliklerine de uygulanır.

<?php
// Bu örnekler dizge içinde dizi kullanımına özgüdür.
// Dizilerin dizgesel anahtarları daima tırnak içine alınır,
// bu amaçla kaşlı ayraçlar kullanılmaz.

// Bütün hataları görelim
error_reporting(E_ALL);

$meyve = array('çilek' => 'kırmızı', 'muz' => 'sarı');

// Çalışır, fakat bunun dizge dışında farklı çalışacağına dikkat edin
echo "Bir muz $meyve[muz] renktedir.";

// Çalışır
echo "Bir muz {$meyve['muz']} renktedir.";

// çalışır, fakat PHP aşağıda açıklandığı gibi önce muz adında bir sabit arar
echo "Bir muz {$meyve[muz]} renktedir.";

// Çalışmaz, kaşlı ayraç kullanın. Bir çözümleme hatasına yol açar.
echo "Bir muz $meyve['muz'] renktedir.";

// Çalışır
echo "Bir muz " . $meyve['muz'] . " renktedir.";

// Çalışır
echo "Bu karenin bir kenarı $square->width metre uzunluktadır.";

// Çalışmaz. Çözüm için karmaşık sözdizimine bakın.
echo "Bu karenin bir kenarı $square->width00 santimetre uzunluktadır.";
?>

Bunlardan daha karmaşık herşey için karmaşık sözdizimini kullanmalısınız.

Karmaşık (kaşlı ayraçlı) sözdizimi

Buna karmaşık denmesinin sebebi sözdiziminin karmaşıklığı değil, karmaşık ifadelerin kullanımını mümkün kılmasıdır.

Aslında, isim alanındaki her değer, bir dizge içinde bu sözdizimi ile yer alabilir. İfade basitçe dizge dışındaki gösterimiyle yazılıp { ve } arasına alınır. { öncelenemeyeceğinden bu sözdizimi sadece $ iminin { iminin hemen ardında yer aldığı durumlarda tanınır. {\$ kullanımı bir sayıl {$ alınmasıyla sonuçlanır. Bazı örnekler:

<?php
// Tüm hataları görelim
error_reporting(E_ALL);

$şahane = 'harika';

// Çalışmaz, çıktısı: Bu çok { harika}
echo "Bu çok { $şahane}";

// Çalışır, çıktısı: Bu çok harika
echo "Bu çok {$şahane}";
echo "Bu çok ${şahane}";

// Çalışır
echo "Bu karenin bir kenarı {$square->width}00 santimetre uzunluktadır.";

// Çalışır
echo "Bu çalışır: {$arr[4][3]}";

// $foo[bar] bir dizge dışında neden yanlışsa bu da o yüzden yanlıştır.
// Yani, bu yine de çalışır fakat PHP önce foo adında bir sabit
// arayacağından çalışır; bununla birlikte E_NOTICE seviyesinde
// bir hata oluşacaktır (tanımsız sabit).
echo "Bu yanlış: {$arr[foo][3]}";

// Çalışır. Çok boyutlu dizileri dizgelerin içinde kullanılırken,
// dizileri daima kaşlı ayraçlar arasına alın.
echo "Bu çalışır: {$arr['foo'][3]}";

// Çalışır.
echo "Bu çalışır: " . $arr['foo'][3];

echo "Bu da çalışır: {$obj->values[3]->name}";

echo "$name adlı değişkenin değeri: {${$name}}";

echo "Adı getName() işlevinin dönüş değeri olan değişkenin değeri: {${getName()}}";

echo "Adı \$object->getName() yönteminin dönüş değeri olan değişkenin değeri: {${$object->getName()}}";
?>

Bu sözdizimini kullanan dizgeler içindeki değişkenler üzerinden de sınıf özelliklerine erişmek mümkündür.

<?php
class foo {
    var $bar = 'I am bar.';
}

$foo = new foo();
$bar = 'bar';
$baz = array('foo', 'bar', 'baz', 'quux');
echo "{$foo->$bar}\n";
echo "{$foo->$baz[1]}\n";
?>

Yukarıdaki örneğin çıktısı:

I am bar.
I am bar.

Bilginize:

İşlev ve yöntem çağrılarının, duruk sınıf değişkenlerinin ve sınıf sabitlerinin {$} içinde çağrılması PHP 5'ten beri çalışmaktadır. Erişilen değer, dizgenin tanımlandığı etki alanındaki bir değişkenin ismi olarak yorumlanır. Kaşlı ayraçların tek başına kullanımı ({}), duruk sınıf değişkenlerinin veya sınıf sabitlerinin değerlerine veya işlev ve yöntemlerin dönüş değerlerine erişim için kullanılmaz.

<?php
// Tüm hatalar gösterilsin.
error_reporting(E_ALL);

class beers {
    const softdrink = 'rootbeer';
    public static $ale = 'ipa';
}

$rootbeer = 'A & W';
$ipa = 'Alexander Keith\'s';

// Bu çalışır; çıktısı: I'd like an A & W
echo "I'd like an {${beers::softdrink}}\n";

// Bu da çalışır; çıktısı: I'd like an Alexander Keith's
echo "I'd like an {${beers::$ale}}\n";
?>

Dizge erişimi ve karaktere göre değişiklik

Dizgelerin içindeki karakterlere, dizilerin köşeli ayraçları arasında karakterin dizinin başlangıcından itibaren (ilk karakterin indisi sıfır olmak üzere) kaçıncı karakter olduğu belirtilerek ($dizge[42] gibi) erişilebilir veya o karakterde değişiklik yapılabilir. Dizgeler bu nedenle bir karakter dizisi olarak düşünülür. 1 karakterden fazlasını elde etmek veya yer değiştirmek isterseniz substr() ve substr_replace() işlevlerini kullanabilirsiniz.

Bilginize: Dizge karakterlerine ayrıca $str{42} biçeminde kaşlı ayraçlar kullanılarak da erişilebilirse de bu sözdiziminin kullanımı PHP 5.3.0 itibariyle önerilmemektedir. Bu amaçla kaşlı ayraçları değil, daima köşeli ayraçları tercih edin; örnek: $str[42].

Uyarı

Karakter indisi olarak dizgenin uzunluğundan büyük bir değer belirtmek, dizgenin sonuna boşlukların eklenmesine sebep olur. Tamsayı olmayan indis değerleri tamsayıya dönüştürülür. Kuraldışı indis belirtimi E_NOTICE'e sebep olur. Yazma sırasında negatif indisler bir E_NOTICE çıktılanmasına sebep olurken okuma işlemi boş dizge okunmasıyla sonuçlanır. Atanmış bir dizgenin sadece ilk karakteri kullanılır. Boş dizge atamak NULL atamasıyla sonuçlanır.

Örnek 8 - Bazı dizge örnekleri

<?php
// Dizgenin ilk karakterini alalım
$str = 'This is a test.';
$first = $str[0];

// Dizgenin üçüncü karakterini alalım
$third = $str[2];

// Dizgenin son karakterini alalım
$str = 'This is still a test.';
$last = $str[strlen($str)-1];

// Dizgenin son karakterini değiştirelim
$str = 'Look at the sea';
$str[strlen($str)-1] = 'e';

?>

Bilginize:

Diğer türlerdeki değişkenlere [] veya {} kullanarak erişme çabası NULL dönmesiyle sonuçlanır.

Kullanışlı işlevler ve işleçler

Dizgeler '.' (nokta) işleci kullanılarak ardarda eklenebilir. '+' (toplama) işlecinin bu amaçla kullanımının yararsız oluşuna dikkat ediniz. Daha ayrıntılı bilgi edinmek için Dizge İşleçleri belgesine bakınız.

Dizgelerde değişiklik yapmak için çok sayıda yararlı işlev mevcuttur.

Genel işlevler için Dizge İşlevlerine, ileri düzey bul ve değiştir işlevselliği için düzenli ifade işlevlerine veya Perl uyumlu düzenli ifade işlevlerine bakınız.

Ayrıca, URL dizgeleri için işlevler ve dizgeleri şifrelemek veya şifrelerini çözmek için mcrypt ve mhash işlevleri vardır.

Son olarak, karakter türü işlevlerine de bakabilirsiniz.

Dizgeye dönüşüm

Bir değer bir dizgeye (string) tür çarpıtması veya strval() işleviyle dönüştürülür. Bir dizgenin gerekli olduğu ifade bağlamlarında dizgeye dönüşüm özdevinimli olarak gerçekleşir. Bu genellikle, echo veya print işlevleri kullanılırken veya bir değişken bir dizge ile karşılaştırılırken gerçekleşir. Aşağıdakilere, Türler ve Tür Dönüşümü bölümlerinde daha ayrıntılı değinilmiştir. Ayrıca, settype() işlevine de bakabilirsiniz.

boolean türündeki TRUE değeri string türündeki "1" değerine dönüştürülür. boolean türündeki FALSE değeri string türündeki "" değerine (boş dizgeye) dönüştürülür. Bu şekilde, boolean ve string değerler arasında her iki yönde de dönüşüm yapılabilmektedir.

integer veya float türünde bir değerin string türüne dönüşümü sayının dizgesel gösterimiyle (üstel gösterim dahil) sonuçlanır. Kayan noktalı sayılar üstel gösterim kullanılarak dönüştürülebilir (4.1E+6 gibi).

Bilginize:

Ondalık nokta karakteri betiğin çalıştığı yerele (LC_NUMERIC) özgüdür. Bakınız: setlocale() işlevi.

Diziler daima "Array" dizgesine dönüştürülür; bundan dolayı echo ve print bir dizinin içeriğini kendiliklerinden gösteremezler. Tek bir dizi elemanını görüntüleyebilmek için echo $arr['foo'] gibi bir oluşum kullanınız. İçeriğin tamamının görüntülenebilmesiyle ilgili ipuçları için aşağıya bakınız.

object türler PHP 4'te daima "Object" dizgesine dönüştürülür. Nesne özelliklerinin değerlerini hata ayıklama amacıyla basmak için aşağıdaki paragrafı okuyunuz. Nesne sınıfının ismini öğrenmek için get_class() işlevini kullanınız. PHP 5 itibariyle, uygulanabildiği takdirde, __toString yöntemi kullanılır.

resource türler daima "Resource id #1" benzeri bir dizgeye dönüştürülürler; buradaki 1, özkaynağa PHP tarafından çalışma anında atanan eşsiz bir sayıdır. Bu yapıya güvenmeseniz iyi olur; ilerde değişebilir. Özkaynağın türünü öğrenmek için get_resource_type() işlevini kullanınız.

NULL daima boş bir dizgeye dönüştürülür.

Yukarıda bahsedildiği gibi, bir diziyi, nesneyi veya özkaynağı doğrudan dönüştürmek, bunların değerleri hakkında işe yarar hiçbir bilgi sağlamaz. Bu tür içerikleri daha verimli şekilde incelemek isterseniz print_r() ve var_dump() işlevlerine bakınız.

Çoğu PHP değeri kalıcı olarak saklamak amacıyla dizgelere dönüştürülebilir. Bu yönteme dizgeleştirme adı verilir ve serialize() işlevi tarafından gerçekleştirilir. Eğer PHP motoru WDDX desteğiyle derlenmişse PHP değerleri ayrıca iyi biçimli XML metin olarak da dizgeleştirilebilir.

Dizgelerin sayılara dönüşümü

Bir dizge, sayısal bir bağlamda değerlendirildiğinde sonuçlanacak değer ve türün nasıl belirleneceği aşağıda açıklanmıştır.

Dizge, '.', 'e' veya 'E' karakterlerini içermiyorsa ve sayısal değeri PHP_INT_MAX ile tanımlanan genişlikte bir tamsayı ise string tür bir integer tür olarak, aksi takdirde bir float olarak değerlendirilir.

Değerin dizgenin başında belirtileceği varsayılır. Eğer dizge geçerli bir sayısal veri ile başlıyorsa sayısal değer olarak bu kullanılır. Aksi takdirde değer 0 (sıfır) olacaktır. Geçerli sayısal veri isteğe bağlı bir işaret ile başlar, bir veya daha fazla sayıda rakam ile isteğe bağlı bir ondalık nokta içerebilir ve isteğe bağlı bir üstel gösterimle sona erer. Üs, 'e' veya 'E' harfini takibeden bir veya daha fazla rakamdan oluşur.

<?php
$foo = 1 + "10.5";                // $foo float'tır (11.5)
$foo = 1 + "-1.3e3";              // $foo float'tır (-1299)
$foo = 1 + "bob-1.3e3";           // $foo integer'dir (1)
$foo = 1 + "bob3";                // $foo integer'dir (1)
$foo = 1 + "10 Small Pigs";       // $foo integer'dir (11)
$foo = 4 + "10.2 Little Piggies"; // $foo float'tır (14.2)
$foo = "10.0 pigs " + 1;          // $foo float'tır (11)
$foo = "10.0 pigs " + 1.0;        // $foo float'tır (11)
?>

Bu dönüşüm nakkında daha ayrıntılı bilgi edinmek için strtod(3) Unix kılavuz sayfasına bakınız.

Bu bölümdeki örneklerden birini denemek isterseniz örnekleri kopyala/yapıştır yöntemiyle aşağıdaki satıra yerleştirip neler olup bittiğini görebilirsiniz:

<?php
echo "\$foo==$foo; " . gettype ($foo) . " türündedir<br />\n";
?>

Tamsayıya dönüştürerek C'deki gibi bir karakterin kodunu alabilmeyi beklemeyin. Karakter/ASCII kod dönüşümleri için ord() ve chr() işlevlerini kullanınız.

float
array
Türler


array

PHP'de bir dizi aslında sıralı bir eşlemdir. Bir eşlem, değerleri anahtarlarla ilişkilendiren bir veri türüdür. Bu veri türü farklı kullanım amaçları için en iyilenebilir; bir dizi, bir yöneysel liste, bir isim-değer çiftleri tablosu, bir sözlük, bir nesne listesi, yığıt, kuyruk ve daha bir sürü başka şey olarak ele alınabilir. Dizilerin değerleri, ağaçlar, diziler ve hatta çok boyutlu diziler bile olabilir.

Tüm bu veri yapılarının açıklanması bu kılavuzun amacını aşar. Fakat, en azından her biri için birer örnek verilebilir. Bu konuda daha fazla bilgi edinmek için bu konuyla ilgili olarak yayımlanmış eserleri inceleyiniz.

Sözdizimi

Bir dizinin array() ile belirtilmesi

Bir dizi array() işlevi kullanılarak belirtilebilir. Değiştirge olarak, birbirlerinden virgüllerle ayrılmış çok sayıda anahtar => değer çifti alabilir.

array(  anahtar  =>  değer
     , ...
     )
// anahtar sadece integer veya string türünde olabilir.
// değer herhangi bir türde herhangi bir değer olabilir.
<?php
$dizi = array("fu" => "bar", 12 => true);

echo $dizi["fu"]; // bar
echo $dizi[12];    // 1
?>

Bir anahtar ya integer ya da string türünde olabilir. Bir anahtar, sadece onluk tamsayı gösterimiyle belirtilmişse bir tamsayı anahtar olarak yorumlanır. Yani, "8" belirtilmeşse bu tamsayı 8 olarak ele alınacak ama "08" belirtilmişse dizge "08" olarak ele alınacaktır. float türünde belirtilen bir anahtar integer türüne aşağı yuvarlanır. PHP için indisli ve ilişkisel diziler, her ikisi de integer ve string türünde indisler içerebildiğinden aynı çeşitten dizilerdir.

değer herhangi bir PHP türünde herhangi bir değer olabilir.

Bilginize:

Tanımlanmamış bir dizi anahtarına erişmeye çalışmakla tanımsız bir değişkene erişmeye çalışmak arasında fark yoktur: E_NOTICE seviyesinde bir hata iletisi çıktılanır ve sonuç NULL olur

<?php
$dizi = array("birdizi" => array(6 => 5, 13 => 9, "a" => 42));

echo $dizi["birdizi"][6];    // 5
echo $dizi["birdizi"][13];   // 9
echo $dizi["birdizi"]["a"];  // 42
?>

Bir anahtar belirtmeksizin bir değer atanıyorsa değer, mevcut tamsayı anahtarların en büyüğüne bir eklenerek elde edilen tamsayı anahtarlı elemana atanır. Bir anahtar mevcut anahtarlardan biriyle değer atıyorsa, yeni değer mevcut eleman değerinin üzerine yazılır.

<?php
// Bu iki dizi birbirinin aynıdır:
array(5 => 43, 32, 56, "b" => 12);

array(5 => 43, 6 => 32, 7 => 56, "b" => 12);
?>
Uyarı

PHP 4.3.0 öncesinde, en büyük indisi bir negatif tamsayı olan bir diziye anahtarsız değer atanması durumunda değere anahtarı yukarıda açıklandığı gibi atanırdı. PHP 4.3.0 ve sonrasında ise böyle bir durumda yeni değer 0 anahtarına atanmaktadır.

anahtar olarak TRUE belirtilirse bu tamsayı 1 olarak, FALSE belirtilirse tamsayı 0 olarak yorumlanır. anahtar olarak NULL kullanımı bir boş dizge olarak yorumlanır. Boş dizgeyle anahtar belirtimi, yeni değerin boş dizge anahtarlı olarak atanmasına sebep olur ve bu, anahtar belirtmeksizin (boş köşeli ayraçlarla) atama yapmak anlamında değerlendirilmez.

array veya object türünde anahtar belirtilemez. Aksi takdirde şöyle bir uyarı alırsınız: Illegal offset type (Kuraldışı konumlama türü).

Köşeli ayraçlarla atama ve değişiklik yapmak

Mevcut bir dizi, doğrudan değer atamak suretiyle değiştirilebilir.

Bu işlem, diziye köşeli ayraçlar arasında belirtilen bir anahtar kullanılarak değer atamak biçeminde yapılır. Diziye yeni bir değer atamak için köşeli ayraçlar boş olarak ([]) belirtilebilir.

$dizi[anahtar] = değer;
$dizi[] = değer;

// anahtar sadece integer veya string türünde olabilir.
// değer herhangi bir türde herhangi bir değer olabilir.

$dizi mevcut değilse oluşturulur, dolayısıyla bu da yeni bir dizi oluşturma yöntemidir. Belli bir değeri değiştirmek için yeni değer elemana mevcut anahtar kullanılarak atanır. Belli bir elemanı (anahtar/değer çiftini) diziden silmek için unset() işlevi kullanılır.

<?php
$dizi = array(5 => 1, 12 => 2);

$dizi[] = 56;    // Betiğin bu noktasında bu atama
                 // $dizi[13] = 56; ile aynıdır

$dizi["x"] = 42; // "x" anahtarlı yeni bir eleman atar

unset($dizi[5]); // Elemanı diziden siler

unset($dizi);    // Dizinin tamamını siler
?>

Bilginize:

Yukarıda değinildiği gibi, bir diziye yeni değeri bir anahtar belirtmeden atamak, mevcut en büyük tamsayı indisine bir eklenerek elde edilen anahtar kullanılarak gerçekleşir. Dizide henüz bir tamsayı indis yoksa anahtar olarak 0 (sıfır) kullanılır.

Dikkat ederseniz, dizinin mevcut olması halinde, yeni bir değer atamak için en büyük tamsayı indisli anahtar kullanmaya gerek yoktur. Buna sadece dizi yeniden indislenmişse gerek olabilir. Aşağıdaki örnek anlatımı pekiştirecektir:

<?php
// Basit bir dizi oluşturalım.
$dizi = array(1, 2, 3, 4, 5);
print_r($dizi);

// Şimdi bütün elemanları silelim ama dizi kalsın:
foreach ($dizi as $i => $value) {
    unset($dizi[$i]);
}
print_r($dizi);

// Bir eleman ekleyelim (dikkat: yeni anahtar 0 değil 5 olacak!)
$dizi[] = 6;
print_r($dizi);

// Yeniden indisleyelim:
$dizi = array_values($dizi);
$dizi[] = 7;
print_r($dizi);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
    [4] => 5
)
Array
(
)
Array
(
    [5] => 6
)
Array
(
    [0] => 6
    [1] => 7
)

Kullanışlı işlevler

Dizilerle çalışmak için kullanılabilecek işlevlerin tamamını Dizi İşlevleri bölümünde bulabilirsiniz.

Bilginize:

unset() işlevi bir diziden anahtar silmeyi mümkün kılar. Ama bu silme işlemi dizinin yeniden indislenmesiyle sonuçlanmaz. Eğer silme işleminin gerçekten "sil ve kaydır" yapmasını istiyorsanız, anahtarı sildikten sonra array_values() işlevini kullanarak diziyi yeniden indislemelisiniz.

<?php
$a = array(1 => 'bir', 2 => 'iki', 3 => 'üç');
unset($a[2]);
/* Bu silme işlemi dizi şöyle tanımlanmış gibi sonuçlanacaktır:
   $a = array(1 => 'bir', 3 => 'üç');
   böyle DEĞİL:
   $a = array(1 => 'bir', 2 =>'üç');
*/

$b = array_values($a);
// $b artık array(0 => 'bir', 1 =>'üç') olmuştur
?>

foreach denetim yapısı özellikle diziler için tasarlanmıştır. Diziler üzerinde hareket edilmesini kolaylaştırır.

Diziler ne yapar, ne yapmaz?

$foo[bar] niye yanlıştır?

Bir dizge sayıllı indis daima tırnak içinde kullanılır. Örneğin, $foo[bar] yanlışken $foo['bar'] doğrudur. Ama, neden? Eski betiklerde şu sözdizimine sıkça rastlanır:

<?php
$foo[bar] = 'düşman';
echo $foo[bar];
// ve saire
?>

Bu yanlıştır, ama çalışır. Bunun sebebi, bu kodun bir dizgeden ziyade tanımsız bir sabit (bar) belirtiyor olmasıdır. PHP ilerde şans eseri ismi aynı zamanda değeri olan bir sabit tanımlayabilir. PHP özdevinimli olarak bir çıplak dizgeyi (tırnak içine alınmamış bir dizgeyi), bu çıplak dizgeyi içeren bir dizgeye dönüştüreceğinden bu çalışır. Örneğin, bar isminde tanımlanmış bir sabit yoksa, PHP bar sabitine 'bar' dizgesini yerleştirecek ve bunu kullanacaktır.

Bilginize: Bu, "anahtarlar daima tırnak içine alınır" demek değildir. sabitleri ve değişkenleri tek tırnak içine almayın, çünkü o zaman yorumlanmazlar.

<?php
error_reporting(E_ALL);
ini_set('display_errors', true);
ini_set('html_errors', false);
// Basit bir dizi:
$dizi = array(1, 2);
$sayaç = count($dizi);
for ($i = 0; $i < $sayaç; $i++) {
    echo "\n$i indisi inceleniyor: \n";
    echo "Kötü: " . $dizi['$i'] . "\n";
    echo "İyi: " . $dizi[$i] . "\n";
    echo "Kötü: {$dizi['$i']}\n";
    echo "İyi: {$dizi[$i]}\n";
}
?>

Yukarıdaki örneğin çıktısı:

0 indisi inceleniyor:

Notice: Undefined index: $i in /dosya/yolu/betik.php on line 10
Kötü:
İyi: 1

Notice: Undefined index: $i in /dosya/yolu/betik.php on line 12
Kötü:
İyi: 1

1 indisi inceleniyor:

Notice: Undefined index: $i in /dosya/yolu/betik.php on line 10
Kötü:
İyi: 2

Notice: Undefined index: $i in /dosya/yolu/betik.php on line 12
Kötü:
İyi: 2

Bu davranışla ilgili diğer örnekler:

<?php
// Tüm hataları görelim
error_reporting(E_ALL);

$dizi = array('meyve' => 'elma', 'sebze' => 'havuç');

// Doğru
print $dizi['meyve'];  // elma
print $dizi['sebze'];  // havuç

// Yanlış. Bu çalışır, fakat meyve tanımlanmamış bir sabit
// olmadığından E_NOTICE seviyesinde bir PHP hatası oluşur
//
// Notice: Use of undefined constant meyve - assumed 'meyve'...
print $dizi[meyve];    // elma

// Bu, neler olup bittiğini gösteren bir sabit tanımlar;
// 'sebze' değeri meyve sabitine atanır.
define('meyve', 'sebze');

// Şimdi farkı görelim
print $dizi['meyve'];  // elma
print $dizi[meyve];    // havuç

// Bir dizge içinde olduğundan bu da doğrudur.
// Dizge içinde kalan sabitler, sabit olarak ele alınmazlar;
// dolayısıyla burada bir E_NOTICE oluşmaz.
print "Turfanda $dizi[meyve]";      // Turfanda elma

// Bir istisna: Dizge içinde kaşlı ayraç içine alınmış
// sabitler, sabit olarak ele alınırlar.
print "Turfanda {$dizi[meyve]}";     // Turfanda havuç
print "Turfanda {$dizi['meyve']}";   // Turfanda elma

// Bu çalışmaz ve şöyle bir çözümleme hatasıyla sonuçlanır:
// Parse error: parse error, expecting T_STRING' or T_VARIABLE' or T_NUM_STRING'
// Bu, dizgeler içindeki süper küresellere de uygulanır.
print "Turfanda $dizi['meyve']";
print "Turfanda $_GET['foo']";

// Ard arda eklemek de bir seçenektir
print "Turfanda " . $dizi['meyve']; // Turfanda elma
?>

error_reporting yönergesine E_NOTICE seviyesinden hataları gösterecek bir atama yapılırsa (örneğin, E_ALL atanarak), böyle kullanımlar hemen görünür duruma gelir. error_reporting yönergesinin öntanımlı değeriyle E_NOTICE seviyesinden hatalar gösterilmez.

Sözdizimi bölümünde değinildiği gibi, köşeli ayraçlar ('[' ve ']') içinde belirtilenlerin birer ifade olması gerekir. Yani, aşağıdaki gibi bir kod çalışacaktır:

<?php
echo $dizi[birişlev($bar)];
?>

Bu, bir işlevin dönüş değerinin dizi indisi olarak kullanımına bir örnektir. PHP kendi sabitlerini de tanır:

<?php
$error_descriptions[E_ERROR]   = "Ölümcül bir hata oluştu";
$error_descriptions[E_WARNING] = "PHP bir uyarı verdi";
$error_descriptions[E_NOTICE]  = "Bu sadece bilgilendirici bir uyarı";
?>

E_ERROR sabitinin de ilk örnekteki bar kadar geçerli bir betimleyici oluşuna dikkat ediniz. Fakat, E_ERROR eşittir 1, vb. olduğundan aşağıdaki örnek de aynı işi yapar:

<?php
$error_descriptions[1] = "Ölümcül bir hata oluştu";
$error_descriptions[2] = "PHP bir uyarı verdi";
$error_descriptions[8] = "Bu sadece bilgilendirici bir uyarı";
?>

O halde bunun nesi kötü?

Bilinmeyen bir gelecekte PHP ekibi başkalarının kodlarıyla çelişen bir sabit, bir anahtar sözcük veya bir değişken eklemek isteyebilir. Örneğin, empty ve default birer anahtar sözcük olduklarından bu amaçla kullanılmaları yanlıştır.

Bilginize: Yinelemek gerekirse, çift tırnak imleri arasına alınmış bir dizge, dizi indisini tırnak içine almadığından geçerlidir; yani, "$foo[bar]" geçeridir. Yukarıdaki örnekleri bu gözle tekrar inceleyin ve ayrıca dizgelerin içinde değişken çözümleme bölümüne de bakın.

Diziye dönüşüm

integer, float, string, boolean veya resource türünde bir değeri array türünde bir değere dönüştürme işlemi, sıfır indisli bir elemana bu değerin atanması ile sonuçlanır. Başka bir deyişle, (array)$sayılDeğer ile array($sayılDeğer) arasında bir fark yoktur.

Bir object türü array türüne dönüştürme işlemi, elemanları nesnenin üyeleri olan bir dizi ile sonuçlanır. Anahtarlar, bir kaç istisnai durum dışında üyelerin isimleridir: Tamsayı özellikler erişilebilir değildir; private değişkenlerin önüne sınıf isimleri getirilir; public değişkenlerin önünde bir '*' olur. Diğer taraftan, başlarına birşeyler eklenmiş böyle değişkenlerin değerleri NULL olur. Bu durum beklenmedik davranışlara yol açabilir:

<?php

class A {
    private $A; // Bu '\0A\0A' haline gelir.
}

class B extends A {
    private $A; // Bu '\0B\0A' haline gelir.
    public $AA; // Bu 'AA' haline gelir.
}

var_dump((array) new B());
?>

Bu örneğin çıktısı 'AA' isimli iki anahtar görüntülerse de onlardan birinin ismi aslında '\0A\0A''dır.

NULL, bir diziye dönüştürülmek istenirse sonuç boş bir dizi olur.

Karşılaştırma

Dizileri array_diff() işleviyle veya dizi işleçleri kullanılarak karşılaştırmak mümkündür.

Örnekler

PHP'nin array türü çok yeteneklidir. Bazı örnekler:

<?php
// Bu:
$a = array( 'renk'   => 'kırmızı',
            'lezzet' => 'tatlı',
            'şekil'  => 'yuvarlak',
            'isim'   => 'elma',
            4        // anahtarı 0 olacaktır
          );

$b = array('a', 'b', 'c');

// . . . buna tamamen eşdeğerdir:
$a = array();
$a['renk']   = 'kırmızı';
$a['lezzet'] = 'tatlı';
$a['şekil']  = 'yuvarlak';
$a['isim']   = 'elma';
$a[]         = 4;        // anahtarı 0 olacaktır

$b = array();
$b[] = 'a';
$b[] = 'b';
$b[] = 'c';

// Yukarıdaki kod çalıştırıldığında $a, array('renk' => 'kırmızı',
// 'lezzet' => 'tatlı', 'şekil' => 'yuvarlak', 'isim' => 'elma', 0 => 4)
// dizisiyle, $b ise array(0 => 'a', 1 => 'b', 2 => 'c') veya basitçe
// array('a', 'b', 'c') dizisiyle sonuçlanacaktır.
?>

Örnek 1 - array() kullanımı

<?php
// Özellik eşlemeli dizi
$map = array( 'sürüm'    => 4,
              'sistem'   => 'Linux',
              'dil'      => 'english',
              'kısaltma' => true
            );

// tamamen sayısal anahtarlar
$dizi = array(  7,
                8,
                0,
              156,
              -10
              );
// Bu, array(0 => 7, 1 => 8, ...) ile aynıdır

$geçişli = array(        10, // key = 0
                 5    =>  6,
                 3    =>  7,
                 'a'  =>  4,
                         11, // anahtar = 6 (en büyük tamsayı indis 5 idi)
                 '8'  =>  2, // anahtar = 8 (tamsayı!)
                 '02' => 77, // anahtar = '02'
                 0    => 12  // 10 değerinin üzerine 12 yazılacak
                  );

// boş dizi
$boş = array();
?>

Örnek 2 - Döngü içinde elemen değiştirme

<?php
$renkler = array('Turuncu', 'Pembe', 'Mor', 'Turkuaz');

foreach ($renkler as $renk) {
    echo "$renk rengi sever misiniz?\n";
}

?>

Yukarıdaki örneğin çıktısı:

Turuncu rengi sever misiniz?
Pembe rengi sever misiniz?
Mor rengi sever misiniz?
Turkuaz rengi sever misiniz?

PHP5'ten beri dizi değerleri gönderimli aktarıldıklarından dizi değerlerini doğrudan değiştirmek mümkündür. Fakat arada bazı şeyler yapmak gerekir:

Örnek 3 - Derlem

<?php
<?php
$renkler = array('Turuncu', 'Pembe', 'Mor', 'Turkuaz');

// PHP 5
foreach ($renkler as &$renk) {
    $renk = strtoupper($renk);
}

unset($renk); /* Aşağıdaki atamalarda $renk son
                 dizi elemanını değiştirmesin */

// Eski sürümü yeniden elde edelim
foreach ($renkler as $anahtar => $renk) {
    $renkler[$anahtar] = strtoupper($renk);
}

print_r($renkler);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [0] => TURUNCU
    [1] => PEMBE
    [2] => MOR
    [3] => TURKUAZ
)

Bu örnekte dizi indisleri 1'den başlatılmaktadır.

Örnek 4 - İndisi 1'den başlatmak

<?php
$ilkçeyrek  = array(1 => 'Ocak', 'Şubat', 'Mart');
print_r($ilkçeyrek);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [1] => Ocak
    [2] => Şubat
    [3] => Mart
)

Örnek 5 - Diziyi doldurmak

<?php
// bir diziyi bir dizin'in içeriği ile dolduralım
$tutamak = opendir('.');
while (false !== ($dosya = readdir($tutamak))) {
    $dosyalar[] = $dosya;
}
closedir($tutamak);
?>

Diziler sıralıdır. Sıralama çeşitli sıralama işlevleri ile değiştirilebilir. Daha fazla bilgi için Dizi İşlevleri bölümüne bakınız. Bir dizinin eleman sayısını öğrenmek için count()işlevi kullanılabilir.

Örnek 6 - Dizi elemanlarının sıraya sokulması

<?php
sort($dosyalar);
print_r($dosyalar);
?>

Bir dizinin elemanlarına her türlü değer atanabileceğinden başka bir dizi de atanabilir. Böylece iç içe ve çok boyutlu dizilerin oluşturulması mümkün olur.

Örnek 7 - İç içe ve çok boyutlu diziler

<?php
$yemişler = array ( "yemişler"  => array ( "a" => "iğde",
                                           "b" => "badem",
                                           "c" => "ceviz"
                                         ),
                    "sayılar"   => array ( 1,
                                           2,
                                           3,
                                           4,
                                           5,
                                           6
                                         ),
                    "yuvalar"   => array (        "birinci",
                                            5  => "ikinci",
                                                  "üçüncü"
                                          )
                );

// Yukarıdaki dizinin değerlerinin kullanıldığı bazı örnekler
echo $yemişler["yuvalar"][5];    // "ikinci" basar
echo $yemişler["meyveler"]["a"]; // "iğde" basar
unset($yemişler["yuvalar"][0]);  // "birinci" silinir

// Yeni bir çok boyutlu dizi oluşturalım
$meyveler["elma"]["yeşil"] = "ekşi";
?>

Dizi atamaları daima değerleri kopyalamak şeklinde gerçekleşir. Bir diziyi gönderimli olarak kopyalamak için gönderim işleci kullanılır.

<?php
$dizi1 = array(2, 3);
$dizi2 = $dizi1;
$dizi2[] = 4; // $dizi2 değişti,
              // $dizi1 hala array(2, 3)

$dizi3 = &$dizi1;
$dizi3[] = 4; // şimdi $dizi1 ve $dizi3 aynı
?>
string
object
Türler


object

Nesne İlklendirme

Yeni bir nesne oluşturmak için (bir sınıfın bir örneğini oluşturmak için) new deyimi kullanılır:

<?php
class kediler
{
    function birŞeySöyle()
    {
        echo "Miyav.";
    }
}

$kedi = new kediler;
$kedi->birŞeySöyle();
?>

Çok daha ayrıntılı bilgiyi Sınıflar ve Nesneler faslında bulabilirsiniz.

object türüne dönüşüm

Eğer object türünde bir değer object türüne dönüştürülürse bir değişiklik olmaz. Başka türde bir değer object türüne dönüştürülürse yerleşik stdClass sınıfının yeni bir örneği oluşturulmuş olur. Eğer değer NULL ise yeni örnek boş olur. Bir dizi object türüne dönüştürülürse dizi elemanlarının isimleri değerleriyle birlikte nesnenin özellikleri haline gelirler. Diğer değerler ise, scalar adlı üye değişkenin değeri haline gelirler.

<?php
$nesne = (object) 'heyo';
echo $nesne->scalar;  // çıktısı: 'heyo'
?>
array
resource
Türler


resource

resource türünde bir değişken harici bir özkaynağa bir gönderim içeren özel bir değişkendir. Özkaynaklar özel işlevler tarafından oluşturulur ve kullanılırlar. resource türüyle ilişkilendirilebilen özkaynakların ve özel işlevlerin bir listesini eklerde bulabilirsiniz.

Bilginize: resource türü PHP 4'ten itibaren mevcuttur.

Ayrıca, get_resource_type() işlevine de bakınız.

resource türüne dönüşüm

Açık dosyalara, veritabanı bağlantılarına, resim tuval alanlarına ve benzerlerine birer tanıtıcı sağlayan değişkenleri resource türüne dönüştürmenin bir anlamı yoktur.

Özkaynakları serbest bırakmak

PHP 4'ün Zend Motoru sayesinde gönderimsiz kalan özkaynaklar özdevinimli olarak saptanarak bunlara ayrılan bellek çöp toplayıcı tarafından serbest bırakılmaktadır. Bu sebeple bir özkaynağa ayrılan belleği serbest bırakmak ihtiyacı nadiren ortaya çıkar.

Bilginize: Kalıcı veritabanı bağlantıları bu kuralın bir istisnasıdır. Çöp toplayıcı tarafından yok edilmezler. Bu konuda daha ayrıntılı bilgi edinmek için kalıcı bağlantılar bölümüne bakınız.

object
NULL
Türler


NULL

Özel NULL değeri, değeri olmayan bir değişken anlamına gelir. NULL değerinin olası tek türü NULL'dur.

Bilginize: NULL türü PHP 4'ten itibaren mevcuttur.

Bir değişken NULL türündeyse:

  • Kendisine NULL sabiti atanmış demektir.

  • Kendisine herhangi bir değer atanmamış demektir.

  • unset() işlevine aktarılmış demektir.

Sözdizimi

NULL türünde, büyük-küçük harfe duyarlı olarak tek bir değer vardır: NULL.

<?php
$var = NULL;
?>

Ayrıca, is_null() ve unset() işlevlerine de bakınız.

NULL türüne çarpıtım

Bir değişkenin türü (null) ile çarpıtılırsa değişken değersiz bırakılarak tanımsız hale getirilmiş olur.

resource
Geriçağırımlar / Çağırılılabilirler
Türler


Geriçağırımlar / Çağırılılabilirler

Geriçağırımlar PHP 5.4.'ten itibaren callable tür ipucu ile belirtilebilirler. Bu belgelerde callback tür bilgisi aynı amaçla kullanıldı.

call_user_func() ya da usort() gibi bazı işlevler değiştirge olarak kullanıcı tarafından belirlenen geriçağırım işlevleri kabul eder. Geriçağırım işlevleri basit işlevler olabileceği gibi, duruk işlevler de dâhil olmak üzere object türünde nesne yöntemleri de olabilirler.

Aktarım

 Bir PHP işlevi adı ile string türünde aktarılır. Her türlü
 yerleşik ve kullanıcı tanımlı işlev kullanılabilir, ancak;
array(), echo,
empty(), eval(),
exit(), isset(),
list(), print ya da
unset() gibi dil sabitleri müstesna.

Örneklenmiş bir nesne yöntemi, 0 indisinde nesne, 1 indisinde yöntem adı olan bir dizi ile aktarılır.

Duruk sınıf yöntemleri, 0 indisinde nesne yerine sınıf adı kullanılarak, sınıfın nesnesi örneklendirilmeden de aktarılabilir. PHP 5.2.3.'ten itibaren, 'SınıfAdı::yöntemAdı' kullanarak aktarmak da mümkündür.

Kullanıcı tanımlı işlevler haricinde, isimsiz işlevler de geriçağırım değiştirgesi olarak aktarılabilirler.

Örnek 1 Geriçağırım işlev örnekleri

<?php

// Örnek bir geriçağırım işlevi
function benim_gericagirim_islevim() {
    echo 'merhaba dünya!';
}

// Örnek bir geriçağırım yöntemi
class BenimSinifim {
    static function benimGericagirimYontemim() {
        echo 'Merhaba Dünya!';
    }
}

// Tür 1: Basit geriçağırım
call_user_func('benim_gericagirim_islevim');

// Tür 2: Duruk sınıf yöntemi çağrısı
call_user_func(array('BenimSinifim', 'benimGericagirimYontemim'));

// Tür 3: Nesne yöntem çağrısı
$nesne = new BenimSinifim();
call_user_func(array($nesne, 'benimGericagirimYontemim'));

// Tür 4: Duruk sınıf yöntemi çağrısı (PHP 5.2.3 itibariyle)
call_user_func('BenimSinifim::benimGericagirimYontemim');

// Tür 5: İlişkisel duruk sınıf yöntem çağrısı (PHP 5.3.0 itibariyle)
class A {
    public static function kim() {
        echo "A\n";
    }
}

class B extends A {
    public static function kim() {
        echo "B\n";
    }
}

call_user_func(array('B', 'parent::kim')); // A

// Tür 6: Nesneler, __invoke uyguluyorlarsa çağırılabilir olarak kullanılabilirler (PHP 5.3 sonrası)
class C {
    public function __invoke($ad) {
        echo 'Merhaba ', $ad, "\n";
    }
}

$c = new C();
call_user_func($c, 'PHP!');
?>

Örnek 2 Örtme kullanan Geriçağırım örneği

<?php
// Bizim örtücümüz
$iki_misli = function($a) {
    return $a * 2;
};

// Bu bizim sayı aralığımız
$sayilar = range(1, 5);

// Sayı aralığımızın her bir elemanını
// ikiye katlamak için burada örtücüyü
// bir geriçağırım olarak kullandık
$yeni_sayilar = array_map($iki_misli, $sayilar);

print implode(' ', $yeni_sayilar);
?>

Yukarıdaki örneğin çıktısı:

2 4 6 8 10

Bilginize: PHP 4'te, bir geriçağırım yaratmak için, kopyasını değil; gerçek nesne'yi işaret eden bir gönderim kullanmak gerekiyordu. Daha fazla bilgi için bkz: Gönderimlerle İlgili Herşey.

Bilginize:

call_user_func() ve call_user_func_array() gibi işlevlerle kayıt altına alınmış geriçağırım işlevleri, bir önceki geriçağırım işlevinde oluşmuş ve yakalanmamış bir istisna varsa çağrılmaz.

NULL
Bu belgede kullanılan sözde türler ve değişkenler
Türler


Bu belgede kullanılan sözde türler ve değişkenler

mixed

mixed anahtar sözcüğü, bir değiştirgenin çok sayıda tür (ama hepsini değil) kabul edebileceğini belirtir.

Örneğin, str_replace() işlevi sadece string veya array türünde değer kabul ederken, gettype() işlevi tüm PHP türlerini kabul eder.

number

number anahtar sözcüğü, bir değiştirgenin integer veya float türünde değer kabul edeceğini belirtir.

callback

call_user_func(), usort() gibi işlevler değiştirge olarak kullanıcı tanımlı geriçağırım işlevlerini kabul ederler. Geriçağırım işlevleri her zaman basit işlevler olmayabilir, nesne yöntemleri ve hatta duruk sınıf yöntemleri bile olabilirler.

Bir PHP işlevi, string türündeki ismiyle aktarılır. Şu dil
oluşumları dışında herhangi bir yerleşik veya kullanıcı tanımlı işlev
kullanılabilir:
array(), echo,
empty(), eval(),
exit(), isset(),
list(), print veya
unset().

Örneklenmiş bir nesnenin bir yöntemi, nesnenin ismi 0. indiste, yöntem ismi 1. indiste yer alan bir dizi olarak aktarılır.

Duruk sınıf yöntemleri de sınıf ismi 0. indiste içerilerek, sınıf bir nesne olarak örneklenmeksizin aktarılabilir.

create_function() işlevi bildik kullanıcı tanımlı işlevlerden başka, bir anonim geriçağırım işlevi oluşturmak için de kullanılabilir. PHP 5.3.0'dan itibaren işleve değiştirge olarak bir anonim işlev aktarmak mümkün oldu.

Örnek 1 - Geriçağırım işlevi örnekleri

<?php

// Bir geriçağırım işlevi örneği
function geriçağırım_işlevim() {
    echo 'merhaba dünya!';
}

// Bir geriçağırım yöntemi örneği
class Sınıfım {
    static function geriçağırımYöntemim() {
        echo 'Merhaba Dünya!';
    }
}

// 1. tür: Basit geriçağırım
call_user_func('geriçağırım_işlevim');

// 2. tür: Duruk sınıf yöntemi çağrısı
call_user_func(array('Sınıfım', 'geriçağırımYöntemim'));

// 3. tür: Nesne yöntemi çağrısı
$nesne = new Sınıfım();
call_user_func(array($nesne, 'geriçağırımYöntemim'));

// 4. tür: Duruk sınıf yöntemi çağrısı (PHP 5.2.3 ve sonrası)
call_user_func('Sınıfım::geriçağırımYöntemim');

// 5. tür: Göreli duruk sınıf yöntemi çağrısı (PHP 5.2.3 ve sonrası)
class A {
    public static function kimsin() {
        echo "A\n";
    }
}

class B extends A {
    public static function kimsin() {
        echo "B\n";
    }
}

call_user_func(array('B', 'parent::kimsin')); // A
?>

Örnek 2 - Anonim işlev kullanan bir geriçağırım işlevi örneği

<?php
// Anonim işlevimiz
$double = function($a) {
    return $a * 2;
};

// Sayı aralığımız
$numbers = range(1, 5);

// Aralık içindeki her elemanın boyutunu
// ikiye katlamak için geriçağırım işlevi
// olarak burada anonim bir işlev kullanalım
$new_numbers = array_map($double, $numbers);

print implode(' ', $new_numbers);
?>

Yukarıdaki örneğin çıktısı:

2 4 6 8 10

Bilginize: PHP4'te, kopyayı değil de asıl nesneyi işaret eden bir geriçağırım oluşturmak için gönderim kullanmak gerekir. Daha fazla bilgi için Gönderimler Hakkında bölümüne bakınız.

Bilginize:

call_user_func() ve call_user_func_array() gibi işlevlerle kayıt altına alınmış geriçağırım işlevleri, bir önceki geriçağırım işlevinde oluşmuş ve yakalanmamış bir istisna varsa çağrılmaz.

void

void bir dönüş türü olarak dönüş değerinin yararsız olduğu anlamına gelir. void bir değiştirge listesinde kullanıldığında işlevin değiştirge kabul etmediği anlamına gelir.

... (üçlü nokta)

$... değiştirgesi işlev bildirimlerinde "ve benzerleri" anlamına gelir. Bu değişken ismi bir işlevde kullanıldığında işlev sonsuz sayıda değiştirge alabilir.

Geriçağırımlar / Çağırılılabilirler
Tür Dönüşümü
Türler


Tür Dönüşümü

PHP değişken bildiriminde tür tanımlamayı gerektirmez (veya desteklemez); bir değişkenin türü kullanıldığı bağlama göre saptanır. Yani, string türünde bir değer $var değişkenine atanırsa $var, string türünde bir değişken haline gelir. $var değişkenine bir integer değer atanırsa $var, integer türünde bir değişken haline gelir.

Toplama işleci '+', PHP'nin özdevinimli tür dönüşümüne iyi bir örnektir. Bir toplama işleminde terimlerden biri float türündeyse her iki terim float olarak ele alınır ve sonuç float türünde olur. Aksi takdirde, terimler integer olarak yorumlanır ve sonuç integer türünde olur. Yalnız dikkat edin, bu işlem ne terimlerin kendi türlerini ne de ifadenin kendi türünü değiştirir.

<?php
$foo = "0";  // $foo string türündedir (ASCII 48)
$foo += 2;   // $foo integer türündedir (2)
$foo = $foo + 1.3;  // $foo float türündedir (3.3)
$foo = 5 + "10 Little Piggies"; // $foo integer türündedir (15)
$foo = 5 + "10 Small Pigs";     // $foo integer türündedir (15)
?>

Eğer yukarıdaki son iki örnek size tuhaf geldiyse Dizgelerin sayıya dönüşümü konusuna bakınız.

Bir değişkeni belli bir türe dönüşmeye zorlamak istiyorsanız Tür Çarpıtma konusuna bakınız. Bir değişkenin türünü değiştirmek istiyorsanız settype() işlevine bakınız.

Bu bölümdeki örnekleri sınamak için var_dump() işlevini kullanınız.

Bilginize:

array türüne özdevinimli dönüşüm şimdilik tanımsızdır.

Ayrıca, PHP dizgelerde konumlar üzerinden indislemeyi dizi indislemede kullanılan sözdizimiyle desteklediğinden aşağıdaki örnek tüm PHP sürümleri için geçerli bir örnektir:

<?php
$a    = 'car'; // $a string türündedir
$a[0] = 'b';   // $a hala string türündedir
echo $a;       // -> bar
?>

Daha fazla bilgi edinmek için Karakterinden dizgeye erişim konusuna bakınız.

Tür Çarpıtma

PHP'de tür çarpıtma (type casting) C'deki gibi çalışır: İstenen türün ismi parantez içinde türü çarpıtılacak değişkenin önüne yazılır.

<?php
$foo = 10;               // $foo integer türündedir
$bar = (boolean) $foo;   // $bar boolean türündedir
?>

İzin verilen çarpıtmalar:

  • (int), (integer) - integer türüne dönüşüm
  • (bool), (boolean) - boolean türüne dönüşüm
  • (float), (double), (real) - float türüne dönüşüm
  • (string) - string türüne dönüşüm
  • (array) - array türüne dönüşüm
  • (object) - object türüne dönüşüm
  • (unset) - NULL'a dönüşüm (PHP 5)

(binary) çarpıtması ve b önekinin ileriye dönük desteği PHP 5.2.1'de eklenmiştir.

Parantezler içinde sekmelere ve boşluklara izin verildiğinden aşağıdaki iki deyim eşdeğerdir:

<?php
$foo = (int) $bar;
$foo = ( int ) $bar;
?>

Normal dizgelerin ikil dizgelere dönüştürülmesi:

<?php
$binary = (binary) $string;
$binary = b"ikil dizge";
?>

Bilginize:

Bir değişkenin türünü string türüne çarpıtmak yerine değişkeni çift tırnak içine almak aynı sonucu sağlar:

<?php
$foo = 10;            // $foo integer türündedir
$str = "$foo";        // $str string türündedir
$fst = (string) $foo; // $fst de string türündedir

// Bu, "bunlar aynı" basar
if ($fst === $str) {
    echo "bunlar aynı";
}
?>

Belli türler arasında çarpıtma yapılırken tam olarak ne olup bittiği açıkça belli olmayabilir. Daha fazla bilgi için şu bölümlere bakınız:

  • boolean türüne dönüşüm
  • integer türüne dönüşüm
  • float türüne dönüşüm
  • string türüne dönüşüm
  • array türüne dönüşüm
  • object türüne dönüşüm
  • resource türüne dönüşüm
  • NULL'a dönüşüm
  • Tür karşılaştırma tabloları
Bu belgede kullanılan sözde türler ve değişkenler
Değişkenler
Türler


Değişkenler

İçindekiler

  • Temeller
  • Öntanımlı Değişkenler
  • Değişken etki alanı
  • Değişken değişkenler
  • Dış Kaynaklı Değişkenler
Tür Dönüşümü
Temeller
Dil Başvuru Kılavuzu


Temeller

PHP'de değişkenler dolar işaretini takip eden bir değişken adı ile gösterilir. Değişken adı büyük-küçük harf duyarlıdır.

Değişken isimleri PHP'deki diğer yaftalarla aynı kurallara tabidir. Geçerli bir değişken ismi bir harf veya alt çizgi imi ile başlar, herhangi sayıda harf, sayı veya alt çizgi iminden oluşur. Düzenli ifade olarak, şu şekilde ifade edilebilir: '[a-zA-Z_\x7f-\xff][a-zA-Z0-9_\x7f-\xff]*'

Bilginize: Burada kastedilen harf a-z veya A-Z arasındaki ASCII harfler ve 127 ile 255 (0x7f-0xff) arasındaki baytlardır.

Bilginize: $this atama yapılamayan özel bir değişkendir.

İpucu

Ayrıca Kullanıcı Alanı İsimlendirme Kılavuzu belgesine de bakınız.

Değişkenlerle ilgili işlevler hakkında bilgi için, Değişkenlerle ilgili işlevler belgesine bakınız.

<?php
$var = 'Kemal';
$Var = 'gel';
echo "$var, $Var";      // "Kemal, gel" yazdırır

$4site = 'dene bakalım';     // geçersiz; sayı ile başlar
$_4site = 'dene bakalım';    // geçerli; alt çizgi ile başlar
$diğer = 'gerekirse diye';   // geçerli; ISO-8859-9'da 'ğ' harfi 127-255
                             // arasında, UTF-8'de ise iki baytı 127-255
                             // arasındadır.
?>

Öntanımlı olarak, değişkenler her zaman değerleriyle atanır. Başka bir deyişle, bir değişkene bir ifade atandığında özgün ifade bütün değeriyle hedef değişkene kopyalanır. Bu demektir ki, örneğin, bir değişkenin değerini başka bir değişkene atadıktan sonra, değişkenlerden birisinin değerini değiştirmenin diğeri üzerinde etkisi olmayacaktır. Bu çeşit atama hakkında daha fazla bilgi için, İfadeler bölümüne bakınız.

PHP değişkenlere değer atamak için başka bir yol daha sunar: Gönderimli atama. Yani, yeni değişken sadece asıl değişkene gönderim yapar (diğer bir deyişle, "onun takma adı olur" veya "onu gösterir") Gönderim yapılan değişkendeki değişiklikler aslını da etkiler, tersi de geçerlidir.

Gönderimli atama için, gönderim yapılacak (daha önce değer atanmış) değişkenin başına ve imi (&) ekleyin. Örneğin, aşağıdaki kod parçası iki kez 'Benim adım Mustafa' yazar:

<?php
$foo = 'Mustafa';          // 'Mustafa' değerini $foo değişkenine ata
$bar = &$foo;              // $foo değişkenini $bar değişkenine gönderimli ata
$bar = "Benim adım $bar";  // $bar değişkenini değiştir ...
echo $bar;
echo $foo;                 // $foo değişkeninin değeri de değişti.
?>

Dikkat edilmesi gereken önemli bir şey de sadece isimli değişkenlerin gönderimle atanabileceğidir.

<?php
$foo = 25;
$bar = &$foo;      // Bu geçerli bir atamadır.
$bar = &(24 * 7);  // Geçersiz; isimlendirilmemiş bir ifadeye gönderim yapıyor

function test()
{
   return 25;
}

$bar = &test();    // Geçersiz.
?>

PHP'de değişkenleri ilklendirmek gerekmez ancak baştan bir değer atamak oldukça iyi bir alışkanlıktır. İlklendirilmeyen değişkenlerin kullanıldıkları bağlamda türlerine bağlı olarak öntanımlı değerleri vardır; öntanımlı değer boolean için FALSE, integer ve float için sıfır, string için boş metin (örnekte echo da kullanıldı), array için ise boş bir dizidir.

Örnek 1 - İlklendirilmemiş değişkenlerin öntanımlı değerleri

<?php
// Herhangi bir bağlamda tanımlanmamış veya
// gönderim yapılmamış değişken;  NULL sonuç verir.
var_dump($tanımsız_değişken);

// Mantıksal değer kullanımı;  'false' çıktısı verir
// (Bu sözdizimi için üç terimli işlecine bakınız)
echo($tanımsız_mantıksallık ? "true\n" : "false\n");

// Dizge kullanımı;  çıktısı: 'string(3) "abc"'
$tanımsız_metin .= 'abc';
var_dump($tanımsız_metin);

// Tamsayı kullanımı;  'int(25)' çıktılar.
$tanımsız_tamsayı += 25;    // 0 + 25 => 25
var_dump($tanımsız_tamsayı);

// Gerçek sayı kullanımı;  'float(1.25)' çıktılar.
$tanımsız_sayı += 1.25;
var_dump($tanımsız_sayı);

// Dizi kullanımı; çıktısı: array(1) {  [3]=>  string(3) "def" }
$tanımsız_dizi[3] = "def"; // array() + array(3 => "def") => array(3 => "def")
var_dump($tanımsız_dizi);

// Nesne kullanımı; yeni stdClass nesnesi oluşturur
// (Öntanımlı sınıflar belgesine bakınız:
// http://www.php.net/manual/tr/reserved.classes.php)
// Çıktısı: object(stdClass)#1 (1) {  ["foo"]=>  string(3) "bar" }
$tanımsız_nesne->foo = 'bar';
var_dump($tanımsız_nesne);
?>

İlklendirilmemiş bir değişkenin öntanımlı değerine güvenmek, içinde aynı değişken isminin kullanıldığı bir dosyayı betiğe dahil ettiğinizde sorun çıkarır. Bunun aynı zamanda büyük bir güvenlik riski omuşturmaması için register_globals yönergesine 'on' değeri atanmalıdır. İlklendirilmemiş değişken kullanımı E_NOTICE seviyesinde hata oluşturur, ancak ilklendirilmemiş bir diziye eleman eklenmesi halinde hata oluşmaz. isset() dil oluşumu bir değişkenin ilklendirilip ilklendirilmediğini öğrenmek için kullanılabilir.

Değişkenler
Öntanımlı Değişkenler
Değişkenler


Öntanımlı Değişkenler

PHP çalıştırdığı herhangi bir betiğe çok sayıda önceden tanımlı değişken sağlar. Ancak, bu değişkenlerin çoğu hangi sunucunun çalıştığına, sunucunun sürümüne ve kurulumuna ve başka bir çok şeye bağlı olduğu için tam olarak belgelendirilememektedir. Bu değişkenlerden bazıları PHP komut satırından çalıştığında mevcut olmayacaktır. Bu değişkenlerin listesi için, lütfen Öntanımlı Değişkenler kısmına bakınız.

Uyarı

PHP 4.2.0 ve sonrasında, register_globals PHP yönergesinin öntanımlı değeri off'tur. Bu PHP'de büyük bir değişikliktir. register_globals'ın off olması betik genelinde geçerli önceden tanımlı bir gurup değişkeni etkiler. Örneğin, DOCUMENT_ROOT'u almak için $DOCUMENT_ROOT yerine $_SERVER['DOCUMENT_ROOT'], http://mesela.dom/dnm.php?id=3 adresi için $id yerine $_GET['id'] veya $HOME yerine $_ENV['HOME'] kullanmalısınız.

Bu değişiklikle ilgili bilgi için, register_globals yapılandırma yönergesini, güvenlik bölümündeki Küresel Kayıtların Kullanımı belgesini, PHP » 4.1.0 ve » 4.2.0 sürüm duyurularını okuyun.

Süper küresel diziler gibi PHP'nin Önceden Tanımlı Değişkenlerinin de kullanımı önerilmektedir.

PHP, 4.1.0 sürümünden sonra, ortam değişkenleri ve kullanıcı girdi değişkenleri ile HTTP sunucusundaki değişkenleri (eğer uygulanabiliyorsa) içeren bir takım önceden tanımlı diziler sağlamaktadır. Bu yeni diziler özel olmaktan ziyade özdevinimli olarak küreseldir, yani, özdevinimli olarak her etki alanında bulunurlar. Bu nedenle, "Süper küreseller" olarak bilinirler. (PHP'de kullanıcı-tanımlı süper küreseller için bir mekanizma yoktur.) Süper küreseller aşağıda listelenmiştir; PHP önceden tanımlı değişkenlerin açıklamaları ve doğaları ise Öntanımlı Değişkenler bölümünde listelenmiştir. Ayrıca, eskiden kalma öntanımlı değişkenlerin de ($HTTP_*_VARS) hala mevcut olduğunu bilmenizde yarar var. PHP 5.0.0'dan itibaren öntanımlı değişken dizileri register_long_arrays yönergesi ile iptal edilebilmektedir.

Bilginize: Değişken değişkenler

İşlevler veya sınıf yöntemleri içinde süper küreseller değişken değişkenleri olarak kullanılamazlar.

Bilginize:

Süper küreseller ve HTTP_*_VARS aynı anda var olabilirlerse de birbirlerinin yerine kullanılamazlar, yani birini değiştirmekle diğerini değiştirmiş olmazsınız.

Eğer variables_order yönergesine uygun değişkenler atanmamışsa, ilgili oldukları PHP önceden tanımlı dizileri de boş bırakılır.

Temeller
Değişken etki alanı
Değişkenler


Değişken etki alanı

Bir değişkenin etki alanı içinde tanımlandığı bağlamdır. Hemen her PHP değişkeninin sadece tek bir etki alanı vardır. Bu tek etki alanı betiğe include ve require ile dahil edilen dosyalara da uzanır. Örneğin:

<?php
$a = 1;
include 'b.inc';
?>

Burada $a değişkeni içerilen b.inc betiğinin içinde mevcut olacaktır. Fakat, kullanıcı tanımlı işlevlerin etki alanı işleve özeldir. Yani, bir işlev içinde kullanılan herhangi bir değişkenin etki alanı öntanımlı olarak işlevin yerel etki alanı ile sınırlıdır. Örneğin:

<?php
$a = 1; /* küresel etki alanı */

function deneme()
{
    echo $a; /* işlevin etki alanı */
}

deneme();
?>

Bu betik herhangi bir çıktı üretmeyecektir, çünkü echo ifadesi $a değişkeninin yerel sürümüne atıf yapmakta olup bu etki alanı içinde değişkene bir değer atanmamıştır. Bunun C dilinden bir miktar farklı olduğuna dikkat etmiş olabilirsiniz, C dilinde küresel değişkenler, özellikle yerel bir tanımla geçersiz kılınmadıkları sürece, işlevler tarafından özdevinimli olarak erişilebilir olacaktır. Bu bazı sorunlara neden olabilir, öyle ki birileri dikkatsizlikle küresel değişkeni değiştirebilir. PHP'de küresel değişkenler eğer bir işlev içinde kullanılacaksa, o işlev içinde global sözcüğü ile bildirilmeleri gerekir.

global anahtar sözcüğü

İlk olarak, global kullanımına bir örnek verelim:

Örnek 1 - global kullanımı

<?php
$a = 1;
$b = 2;

function topla()
{
    global $a, $b;

    $b = $a + $b;
}

topla();
echo $b;
?>

Yukarıdaki betik 3 çıktısı verecektir. $a ve $b işlev içinde küresel tanımlanarak, her iki değişkene yapılan bütün atıflar küresel sürüme yapılmış olacaktır. Bir işlev tarafından işlenebilecek küresel değişken sayısında bir sınır yoktur.

Küresel etki alanındaki değişkenlere erişimin ikinci yolu PHP tarafından tanımlanmış özel $GLOBALS dizisini kullanmaktır. Önceki örnek şu şekilde yazılabilir:

Örnek 2 - global yerine $GLOBALS kullanımı

<?php
$a = 1;
$b = 2;

function topla()
{
    $GLOBALS['b'] = $GLOBALS['a'] + $GLOBALS['b'];
}

topla();
echo $b;
?>

$GLOBALS dizisi, anahtarı küresel değişkenin ismi, elemanının değeri değişkenin içeriği olan bir ilişkisel dizidir. $GLOBALS dizisinin her etki alanında mevcut oluşuna dikkat edin, bunun sebebi$GLOBALS dizisinin bir süper küresel olmasıdır. Süper küresellerin gücünü gösteren bir örnek aşağıda verilmiştir:

Örnek 3 - Süper küreselleri ve etki alanlarını gösteren örnek

<?php
function test_global()
{
    // Çoğu öntanımlı değişken "süper" değildir ve işlev etki
    // alanında geçerli olmak 'global' olmayı gerektirir.
    global $HTTP_POST_VARS;

    echo $HTTP_POST_VARS['isim'];

    // Süper küreseller her etki alanında geçerlidirler ve
    // 'global' olarak bildirilmeleri gerekmez. Süper küreseller
    // PHP 4.1.0'dan beri mevcutturlar ve HTTP_POST_VARS'ın
    // kullanımı artık önerilmemektedir.
    echo $_POST['isim'];
}
?>

Bilginize:

Eğer içerildiği dosya bir işlevin içinde içerilmişse global anahtar sözcüğünün işlevlerin dışında kullanımı bir hataya yol açmaz.

Duruk değişkenlerin kullanımı

Değişken etki alanı ile ilgili önemli özelliklerden biri duruk değişkenlerdir. Bir duruk bir değişken sadece işlevin etki alanında geçerli olup, programın çalışması bu etki alanını terkettiği zaman değerini kaybetmez. Aşağıdaki örneğı ele alalım:

Örnek 4 - Duruk değişkenlere ihtiyacı gösteren örnek

<?php
function dene()
{
    $a = 0;
    echo $a;
    $a++;
}
?>

Bu işlev her çağrıldığında $a'yı 0 yapar ve 0 yazdırır, bu nedenle oldukça kullanışsızdır. Değişkeni artıran $a++ bir işe yaramaz çünkü işlev çıktığı gibi $a değişkeni kaybolur. Kaldığı değeri kaybetmeyecek kullanışlı bir sayaç işlevi yapması için $a değişkeni aşağıda static olarak bildirilmiştir.

Örnek 5 - Duruk değişkenlerin kullanım örneği

<?php
function dene()
{
    static $a = 0;
    echo $a;
    $a++;
}
?>

Artık, $a değişkeni sadece dene() işlevinin ilk çağrılışında ilklendirilecek ve işlevin her çağrılışında $a değişkeninin değerini bastıktan sonra değerini bir artıracaktır.

Duruk değişkenler aynı zamanda kendini çağıran işlevlerle çalışmak için de bir yol sunar. Kendini çağıran (recursive) işlev kendi kendini çağırır. Böyle bir işlev dikkatli yazılmazsa sonsuza kadar kendi kendini çağırır. Kendini çağırmayı bir noktada sonlandıracak uygun bir yönteminiz olmalıdır. Aşağıdaki basit işlev, kendini çağırmayı nerede durduracağını bilerek 10'a kadar sayar:

Örnek 6 - Kendini çağıran işlevlerle duruk değişkenler

<?php
function say()
{
    static $sayaç = 0;

    $sayaç++;
    echo "$sayaç\n";
    if ($sayaç < 10) {
        say();
    }
    $sayaç--;
}
say();
?>

Bilginize:

Duruk değişkenler yukarıdaki örneklerde yapıldığı gibi tanımlanabilir. PHP 5.6 itibariyle, bu değişkenlere ifadelerin sonuçlarını değer olarak atayabilirsiniz fakat burada herhangi bir işlev kullanamazsınız, bu bir çözümleme hatasına sebep olur.

Örnek 7 - Duruk değişken bildirimi

<?php
function foo(){
    static $int = 0;          // doğru
    static $int = 1+2;        // doğru  (PHP 5.6 itibariyle)
    static $int = sqrt(121);  // yanlış (bir işlevle atandığı için)

    $int++;
    echo $int;
}
?>

Bilginize:

Duruk bildirimler derleme sırasında çözümlenir.

global ve static değişkenlere gönderim

PHP 4'ün işletmeni olan Zend Motoru 1, static ve global değişken niteleyicilerini gönderim olarak gerçeklemiştir. Örneğin, global deyimi ile bir işlevin etki alanında geçerli kılınan bir küresel değişken aslında kendine bir gönderim oluşturur. Bu durum aşağıdaki örnekte de görüldüğü gibi beklenmedik davranışlara yol açabilir:

<?php
function gönderimli_küresel_dene() {
    global $nesne;
    $nesne = &new stdclass;
}

function gönderimsiz_küresel_dene() {
    global $nesne;
    $nesne = new stdclass;
}

gönderimli_küresel_dene();
var_dump($nesne);
gönderimsiz_küresel_dene();
var_dump($nesne);
?>

Yukarıdaki örneğin çıktısı:

NULL
object(stdClass)#1 (0) {
}

Aynı davranış static deyimine de uyar. Gönderimler duruk olarak saklanmazlar:

<?php
function &gönderimli_örnek() {
    static $obj;

    echo 'Duruk nesne: ';
    var_dump($obj);
    if (!isset($obj)) {
        // Duruk değişkene gönderim atayalım
        $obj = &new stdclass;
    }
    $obj->property++;
    return $obj;
}

function &gönderimsiz_örnek() {
    static $obj;

    echo 'Duruk nesne: ';
    var_dump($obj);
    if (!isset($obj)) {
        // Duruk değişkene nesne atayalım
        $obj = new stdclass;
    }
    $obj->property++;
    return $obj;
}

$nesne1 = gönderimli_örnek();
$bu_da_nesne1 = gönderimli_örnek();
echo "\n";
$nesne2 = gönderimsiz_örnek();
$bu_da_nesne2 = gönderimsiz_örnek();
?>

Yukarıdaki örneğin çıktısı:

Duruk nesne: NULL
Duruk nesne: NULL

Duruk nesne: NULL
Duruk nesne: object(stdClass)#3 (1) {
["property"]=>
int(1)
}

Bu örnek, bir duruk değişkene gönderimli atama yapılması halinde, &gönderimli_örnek() işlevi ikinci kez çağrıldığında değişkene atanan değerin saklanmadığını gösterir.

Öntanımlı Değişkenler
Değişken değişkenler
Değişkenler


Değişken değişkenler

Bazen değişken değişken isimlerine sahip olabilmek kullanışlı olur. Bu, devingen olarak belirtilebilen ve kullanılabilen bir değişken ismidir. Normal bir değişken şöyle bir deyimle atanır:

<?php
$a = 'merhaba';
?>

Bir değişken değişken bir değişkenin değerini alır ve bir değişkenin ismi gibi davranır. Yukarıdaki örnekteki, merhaba, iki tane dolar imi ile bir değişken ismi olarak kullanlabilir

<?php
$$a = 'dünya';
?>

Bu noktada PHP sembol ağacında iki değişken tanımlanmış ve saklanmış olur: $a "merhaba" içerirken $merhaba ise "dünya" içerir. Bu nedenle, aşağıdaki iki örnek aynı sonucu üretir:

<?php
echo "$a ${$a}";
?>
<?php
echo "$a $merhaba";
?>

Her ikisi de 'merhaba dünya' üretir.

Değişken değişkenleri dizilerle kullanmak için, bir anlam karmaşası sorununu çözümlemeniz gerekir. $$a[1] yazdığınızda değişken olarak $a[1]'i mi kastettiğiniz, yoksa $$a'nın değişken olmasını isteyip [1] ile o değişkenin indisini mi kastettiğinizi çözümleyicinin bilmesi gerekir. Bu anlam karmaşasını çözümleyen söz dizimi, birinci durum için ${$a[1]} ve ikinci için ${$a}[1]'dir.

Sınıf özelliklerine değişken özellik isimlerinden de erişilebilir. Değişken özellik ismi çağrının yapıldığı etki alanı içinde çözümlenir. Örneğin, $foo->$zam gibi bir değişkeniniz olsun; burada $zam'ın etki alanı incelenir ve $foo özelliğinin ismi olarak kullanılır. $zam, bir diziye erişim için kullanılıyorsa yine aynı durum geçerlidir.

Dikkat

Bir değişken özelliğinin atıfla bırakılması bir dizi içindeyse PHP 5 ve PHP 7'de farklı sözdizimlerine sahiptir. PHP 7.0 göç rehberinde ifade türlerindeki değişiklikler ve karışıklıktan kaçınmak için kaşlı ayraçların nasıl kullanılacağı ile ilgili ayrıntıları bulabilirsiniz.

Kaşlı ayraçlar, özellik ismini açıkça sınırlamak için de kullanılabilir. Bir dizi içinde bulunan bir özelliğin değerlerine erişmek için ya da özellik ismi başka türlü geçerli olmayan karakterler (örn, json_decode() veya SimpleXML ile üretilmiş) içeriyorsa çok kullanışlıdır.

Örnek 1 - Değişken özellik örneği

<?php
class foo {
    var $bar = 'I am bar.';
    var $arr = array('I am A.', 'I am B.', 'I am C.');
    var $r   = 'I am r.';
}

$foo = new foo();
$bar = 'bar';
$baz = array('foo', 'bar', 'baz', 'quux');
echo $foo->$bar . "\n";
echo $foo->{$baz[1]} . "\n";

$start = 'b';
$end   = 'ar';
echo $foo->{$start . $end} . "\n";

$arr = 'arr';
echo $foo->{$arr[1]} . "\n";

?>

Yukarıdaki örneğin çıktısı:

I am bar.
I am bar.
I am bar.
I am r.

Uyarı

Değişken değişkenlerin işlev ve sınıf yöntemleri içinde PHP'nin Süper küresel dizileri ile kullanılamayacağını unutmayınız. $this değişkeni de devingen olarak gönderimli olamayan özel bir değişkendir.

Değişken etki alanı
Dış Kaynaklı Değişkenler
Değişkenler


Dış Kaynaklı Değişkenler

HTML Formları (GET ve POST)

Bir PHP betiğine bir form gönderildiğinde o formdaki bilgi betik tarafından özdevinimli olarak kullanılır. Bu bilgiye erişmek için birçok yol vardır, örneğin:

Örnek 1 - Basit bir HTML formu

<form action="foo.php" method="post">
    Name:  <input type="text" name="kullanici_adi" /><br />
    Email: <input type="text" name="eposta" /><br />
    <input type="submit" name="submit" value="Beni gönder!" />
</form>

PHP 5.4.0 itibariyle, HTML formlarınızdaki bilgiye erişimin iki yolu vardır. Şu an için kullanılabilen yöntemler aşağıda sıralanmıştır:

Örnek 2 - Basit bir POST HTML formundan bilgiye erişim

<?php

echo $_POST['kullanici_adi'];
echo $_REQUEST['kullanici_adi'];
?>

There were some other ways of accessing user input in old PHP versions. These are listed below. See changelog at the bottom of the page for more details.

Örnek 3 Old methods of accessing user input

<?php
// DİKKAT: Bu yöntemler artık desteklenMEmektedir.
// Geçerli olanlar yukarıda gösterilmiştir.

// import_request_variables() kullanımı - Bu işlev PHP 5.4.0'da kaldırılmıştır

   import_request_variables('p', 'p_');
   echo $p_kullanici_adi;

// PHP 5.4.0'dan itibaren, bu uzun öntanımlı değişkenler kaldırılmıştır
   echo $HTTP_POST_VARS['kullanici_adi'];

// register_globals kullanımı - Bu özellik PHP 5.4.0'da kaldırılmıştır
   echo $kullanici_adi;
?>

Bunun yerine önceden tanımlı uygun bir GET değişkeni kullanmak dışında, GET formunun kullanımı aynıdır. GET ayrıca QUERY_STRING (Bir URL'de '?' iminden sonraki bilgi) sorgu dizgesine de uygulanır. Bu bakımdan örneğin, http://mesela.dom/dnm.php?id=3 $_GET['id'] ile erişilebilen GET verisini içerir. Ayrıca, $_REQUEST değişkenine de bakınız.

Bilginize:

Değişken isimlerindeki noktalar ve boşluklar altçizgi karakterine dönüştürülür. Örneğin, <input name="a.b" /> ifadesi $_REQUEST["a_b"] haline gelir.

PHP form değişkenleri bağlamında dizileri de anlar (ilgili SSS'ye bakınız). Örneğin, ilgili değişkenleri birlikte gruplayabilir veya bu özelliği çoklu seçim girdisinden değerleri almak için kullanabilirsiniz. Örneğin, bir formu kendine gönderelim ve gönderilen veriyi gösterelim:

Örnek 4 - Daha karmaşık form değişkenleri

<?php
if ($_POST) {
    echo '<pre>';
    echo htmlspecialchars(print_r($_POST, true));
    echo '</pre>';
}
?>
<form action="" method="post">
    Adı:  <input type="text" name="personal[isim]" /><br />
    Eposta: <input type="text" name="personal[eposta]" /><br />
    Bira: <br />
    <select multiple name="bira[]">
        <option value="efes">Efes</option>
        <option value="tuborg">Tuborg</option>
        <option value="venus">Venüs</option>
    </select><br />
    <input type="submit" value="Gönder!" />
</form>

Gönder düğmesi değişken isimleri

Bir formu gönderirken, şöyle bir etiketle standart gönder düğmesi yerine resim kullanılabilir:

<input type="image" src="image.gif" name="sub" />

Kullanıcı resim üzerinde bir yere tıkladığında, eşlik eden form iki ek değişkenle sunucuya iletilmiş olur: sub_x ve sub_y. Bunlar kullanıcın resim üzerinde tıkladığı noktanın koordinatlarını içerir. Deneyimliler tarayıcı tarafından gönderilen asıl değişken isimlerinin alt çizgi yerine nokta içerdiğine dikkat etmiş olabilirler, fakat PHP noktaları özdevinimli olarak alt çizgiye çevirir.

HTTP Çerezleri

PHP, » RFC 6265'de tanımlandığı gibi HTTP çerezlerini şeffaf olarak destekler. Çerezler kullanıcıları izleyip tanımlamak amacıyla kullanıcının tarayıcısında veri saklamak için kullanılan bir yöntemdir. Çerezleri setcookie() işlevini kullanarak belirtebilirsiniz. Çerezler HTTP başlığının bir parçasıdır, bu nedenle setcookie() işlevi tarayıcıya herhangi bir çıktı gönderilmeden önce çağrılmak zorundadır. Bu kısıtlama header() işlevi için de geçerlidir. Çerez verisi $_COOKIE veya $_REQUEST gibi uygun çerez veri dizisinde bulunur. Ayrıntılar ve örnekler için setcookie() kılavuz sayfasına bakınız.

Eğer tek bir çerez değişkenine birden fazla değer atamak isterseniz, değişkeni bir dizi olarak atayabilirsiniz. Örneğin:

<?php
  setcookie("Cerezim[foo]", 'Deneme 1', time()+3600);
  setcookie("Cerezim[bar]", 'Deneme 2', time()+3600);
?>

Her ne kadar betiğinizde Cerezim tek bir dizi olsa da bu iki ayrı çerez oluşturacaktır. Eğer birden fazla değere sahip tek bir çerez atamak isterseniz, önce değer üzerinde serialize() veya explode() kullanmayı düşünün.

Yolu veya alan adı farklı olmadığı sürece aynı isimdeki bir çerez önceki çerezin üzerine yazılır. Böylece, isterseniz örneğin bir alışveriş sepeti uygulaması için bir sayaç tutabilir ve bunu karşıya aktarabilirsiniz.

Örnek 5 - setcookie() örneği

<?php
if (isset($_COOKIE['sayac'])) {
    $sayac = $_COOKIE['sayac'] + 1;
} else {
    $sayac = 1;
}
setcookie('sayac', $sayac, time()+3600);
setcookie("Sepet[$sayac]", $mal, time()+3600);
?>

Gelen değişken isimleri içindeki noktalar

Genellikle, PHP bir betiğe aktarılan değişken isimlerini değiştirmez. Fakat, nokta iminin PHP'de değişken isimlerinde geçerli bir karakter olmadığına dikkat edilmelidir. Örnek:

<?php
$varname.ext;  /* geçersiz değişken ismi */
?>
Burada, yazım denetleyicinin gördüğü $varname isimli bir değişkeni takip eden bir dizge birleştirme işlemi ve çıplak bir (tırnaklarla çevrilmemiş, herhangi bir anahtar veya anahtar sözcük ile eşleşmeyen dizge) 'ext' metnidir. Açıkça görülüyor ki, bu istenen sonucu vermemektedir.

Bu nedenle, PHP'nin gelen değişken isimlerindeki nokta imlerini alt çizgi imi ile değiştirdiğini bilmekte yarar vardır.

Değişken türlerini belirlemek

Değişken türlerini PHP belirlediği ve (genellikle) gerektiği gibi değiştirdiği için, verilen bir değişkenin herhangi bir anda hangi türde olduğu sorgulanmadan bilinemez. PHP'de bir değişkenin hangi türde olduğunu bulan birçok işlev vardır. Örnek: gettype(), is_array(), is_float(), is_int(), is_object() ve is_string(). Ayrıca Türler bölümüne de bakınız.

Sürüm Bilgisi

Sürüm: | Açıklama
5.4.0 | Küresel Kayıtlar, Sihirli tırnak ve register_long_arrays kaldırıldı.
5.3.0 | Küresel Kayıtlar, Sihirli tırnak ve register_long_arrays kulllanımı önerilmez duruma geldi.
4.2.0 | register_globals yönergesinin öntanımlı değeri off oldu.
4.1.0 | $_POST ve $_GET gibi Süper küresel diziler kullanılabilir oldu.

Değişken değişkenler
Sabitler
Değişkenler


Sabitler

İçindekiler

  • Söz dizimi
  • Sihirli Sabitler

Bir sabit basit bir değerin betimleyicisidir (ismidir). İsminden de anlaşılacağı gibi, betiğin çalışması sırasında bu değer değiştirilemez (aslında birer sabit olmayan sihirli sabitler hariç). Sabitler öntanımlı olarak büyük-küçük harf duyarlıdır. Geleneksel olarak, sabit isimleri daima büyük harfle yazılır.

Bir sabite verilen isim PHP'de varolan diğer tüm isimlerle aynı kurallara tabidir. Geçerli bir sabit ismi bir harfle ya da alt çizgi imi ile başlar, herhangi bir sayıda harf, rakam ya da alt çizgi ile devam eder. Bir sabit ismi düzenli ifade olarak, şu şekilde ifade edilebilir: [a-zA-Z_\x7f-\xff][a-zA-Z0-9_\x7f-\xff]*

İpucu

Ayrıca Kullanıcı Alanı İsimlendirme Kılavuzu belgesine de bakınız.

Örnek 1 - Geçerli ve geçersiz sabit isimleri

<?php

// Geçerli sabit isimleri
define("FOO",     "bir şey");
define("FOO2",    "başka bir şey");
define("FOO_BAR", "daha başka bir şey");

// Geçersiz sabit isimleri
define("2FOO",    "bir şey");

// Bu geçerli olmasına rağmen kullanmaktan kaçınılmalıdır.
// PHP bir gün betiğinizin çalışmasını bozacak bir sihirli
// sabit kullanmaya karar verebilir.
define("__FOO__", "bir şey");

?>

Bilginize: Burada bir harften söz ettiğimiz zaman, ASCII a-Z veya A-Z arasındaki ki bir karakterden veya karakter kodu 127-255 (0x7f-0xff) arasındaki bir karakterden bahsetmiş oluyoruz.

Süper küresellerde olduğu gibi, sabitlerin etki alanı da betiklerin genelidir. "Etki alanı" hakkında daha ayrıntılı bilgi edinmek için Değişken Etki Alanı bölümünü okuyunuz.

Dış Kaynaklı Değişkenler
Söz dizimi
Dil Başvuru Kılavuzu


Söz dizimi

Bir sabiti define() işlevini kullanarak veya PHP 5.3.0'dan 5.6.0'a kadar sınıf tanımlarının dışında const anahtar sözcüğünü kullanarak tanımlayabilirsiniz. PHP 5.6.0'dan itibaren ise, bir sabiti bir sayısal sabit olarak veya array türünde bir sabit olarak tanımlamak mümkündür. Sabitleri resource türünde tanımlamak mümkünse de beklenmedik sorunlara yol açabileceğinden bundan kaçınılmalıdır.

Bir sabit ismine yalnızca bir sayıl değer (boolean, integer, float veya string) atanabilir. Sabitleri resource olarak kayıt altına almak mümkündür, fakat umulmadık sonuçlara yol açabileceğinden bundan kaçınılmalıdır.

Bir sabitin değerini basitçe ismini belirterek alabilirsiniz. Değişkenlerin aksine, sabitlerin önüne $ imi eklemeniz gerekmez. Bunun yanında, bir sabitin ismini devingen şekilde elde etmek isterseniz, sabitin değerini okumak için constant() işlevini de kullanabilirsiniz. Tanımlanmış sabitlerin tamamının bir listesini almak için, get_defined_constants() işlevini kullanabilirsiniz.

Bilginize: Sabitlerin ve (genel) değişkenlerin isim alanları farklıdır. Bu, örneğin TRUE ile $TRUE değerlerinin farklı olabilecekleri anlamına gelir.

Tanımlanmamış bir sabit ismi kullanırsanız, PHP, bir sabit değil bir sayıl değer kullanmak istediğinizi varsayar ve sabiti string türünde bir değer (SABIT yerine "SABIT" ) olarak ele alır. Böyle bir durumda E_NOTICE seviyesinde bir hata çıktılanır. Ayrıca, $foo[bar] kullanımının (evvelce define() işleviyle bar isminde bir sabit tanımlamamışsanız) neden yanlış olduğuyla ilgili açıklamayı $foo[bar] neden yanlıştır? başlığı altında bulabilirsiniz. Bu (tamamen) nitelenmiş sabitlere uygulanmaz, çünkü tanımsız olduğunda ölümcül bir hataya yol açar. Bir sabitin tanımlı olup olmadığını defined() işlevi sayesinde kolayca öğrenebilirsiniz.

Sabitler ve değişkenler arasındaki farklar:

  • Bir sabit ismi $ imi ile başlamaz.
  • PHP 5.3 ve öncesinde, sabitler basit bir atama ile değil, sadece define() işlevi kullanılarak tanımlanabilirler.
  • Sabitler, değişken etki alanı kurallarına bağlı olmaksızın her yerde tanımlanabilir ve her yerden erişilebilir.
  • Sabitler tanımlandıktan sonra yeniden tanımlanamaz ya da tanımsız duruma getirilemez.
  • Bir sabit sadece bir sayıl değerlerle (boolean, integer, float veya string türünde bir değer) sonuçlanabilir. PHP 5.6 ve sonrasında const sözcüğünü kullanarak, PHP 7.0 ve sonrasında ise define() kullanarak dizi sabitler tanımlamak mümkündür.

Örnek 1 - Sabitlerin Tanımlanması

<?php
define("CONSTANT", "Merhaba dünya.");
echo CONSTANT; // "Merhaba dünya" çıktılar.
echo Constant; // "Constant" çıktılar ve bir bilgi iletisi gösterir.
?>

Örnek 2 - Sabitlerin const ile tanımlanması

<?php
// PHP 5.3.0 ve sonrasında çalışır
const SABIT = 'Merhaba Dünya';

echo SABIT;

// PHP 5.6.0 ve sonrasında çalışır
const DIGER_SABIT = SABIT.'; Elveda Dünya';
echo DIGER_SABIT;

const HAYVANLAR = array('köpek', 'kedi', 'kuş');
echo HAYVANLAR[1]; // "kedi" çıktılanır

// PHP 7 ve sonrasında çalışır
define('HAYVANLAR', array(
    'köpek',
    'kedi',
    'kuş'
));
echo HAYVANLAR[1]; // "kedi" çıktılanır
?>

Bilginize:

Sabitlerin define() kullanılarak tanımlanmasının tersine, const anahtar sözcüğü ile tanımlanan sabitler derleme sırasında tanımlandıklarından en üst seviye etki alanında bildirilmiş olmalıdır. Yani bunlar işlevlerin, döngülerin, if deyimlerinin veya try/catch bloklarının içinde bildirilemez.

Ayrıca, Sınıf Sabitleri belgesine de bakınız.

Sabitler
Sihirli Sabitler
Sabitler


Sihirli Sabitler

PHP, çalışan her betiğin erişebileceği çok sayıda öntanımlı sabit'e sahiptir. Öte yandan, bu sabitlerin çoğu, çeşitli eklentiler tarafından tanımlandığından, sadece eklenti bir modül olarak veya PHP içinde derlenmişse kullanılabilir.

Değerleri kullanıldıkları yere göre değişen sekiz sihirli sabit vardır. Örneğin, __LINE__ sabitinin değeri betiğin hangi satırında kullanıldığına bağlıdır. Bu özel sabitler büyük-küçük harf farkına duyarsızdır ve aşağıda listelenmişlerdir:

Birkaç "sihirli" PHP sabiti
İsim | Açıklama
__LINE__ | Dosyada bu sabitin bulunduğu satırın numarası.
__FILE__ | Dosyanın veya sembolik bağdan çözümlenen dosyanın tam dosya yolu ve dosya ismi. include işlevi ile betiğe eklenen bir dosyanın içinde kullanıldığında betiğin ismini değil, eklenen dosyanın ismini içerir.
__DIR__ | Dosyanın bulurduğu dizin. Dahil edilen bir dosyanın içinde kullanıldığında dahil edilen dosyanın dizini döner. Bu dirname(__FILE__) işlevine eşdeğerder. Bu dizin isminin sonuna bir kök dizin olmadıkça bir bölü imi konmaz.
__FUNCTION__ | İşlev ismi.
__CLASS__ | Sınıf ismi. Bbildirildiği isim alanını (Foo\Bar gibi) içerir. PHP 5.4 ve sonrasında __CLASS__ ayrıca kalıtsal özelliklerin içinde de çalışır. Böyle bir yöntemin içinde kullanıldığında __CLASS__, kalıtsal özelliğin içinde kullanıldığı sınıfın ismidir.
__TRAIT__ | Kalıtsal özellik ismi. Bildirildiği isim alanını (Foo\Bar gibi) içerir.
__METHOD__ | Yöntem ismi.
__NAMESPACE__ | Geçerli isim alanının adı.

Ayrıca bakınız:
get_class(),
get_object_vars(),
file_exists() ve
function_exists().

Sürüm Bilgisi

Sürüm: | Açıklama
5.4.0 | __TRAIT__ sabiti eklendi
5.3.0 | __DIR__ ve __NAMESPACE__ sabitleri eklendi
5.0.0 | __METHOD__ sabiti eklendi
5.0.0 | Bu sürümden önce bazı sihirli sabitlerin değerleri daima küçük harfliydi. Şimdi bunların hepsi harf büyüklüğüne duyarlıdır (isimler bildirildikleri gibi içerilir).
4.3.0 | __FUNCTION__ ve __CLASS__ sabitleri eklendi
4.0.2 | __FILE__ daima sembolik bağları çözümlenmiş mutlak bir yol içerir, halbuki eski sürümlerde bazı durumlarda göreli yollar da içerirdi.

Söz dizimi
İfadeler
Sabitler


İfadeler

İfadeler, PHP'nin en önemli yapı taşlarındandır. PHP'de, hemen hemen yazdığınız her şey bir ifadedir. Bir ifadenin en basit ama en etkili tanımı şudur: "Bir değere sahip olan herşey".

İfadelerin en basit şekli sabitler ve değişkenlerdir. "$a = 5" yazdığınızda, '5' değerini $a değişkenine atamış olursunuz. '5', açık bir şekilde, 5 değerine sahiptir, ya da başka bir deyişle '5', değeri 5 olan bir ifadedir (bu durumda, '5' bir tamsayı sabittir).

Bu atamadan sonra, $a'nın değerinin 5 olmasını beklersiniz, dolayısıyla $b = $a yazdığınızda, bunun $b = 5 yazmışsınız gibi davranmasını beklersiniz. Başka bir deyişle, $a da değeri 5 olan ifadedir. Her şey doğru çalışırsa, olması gereken de tam budur.

İşlevler, ifadelerin biraz daha karmaşık örnekleridir. Örneğin, aşağıdaki işleve bakalım:

<?php
function foo ()
{
    return 5;
}
?>

İşlev kavramına aşina iseniz (değilseniz, işlevler bölümünü inceleyebilirsiniz), şu örnekten hareketle $c = foo() yazmak ile $c = 5 yazmak arasında bir fark olmadığını bilirsiniz. İşlevler, değeri dönüş değeri olan ifadelerdir. foo() işlevi 5 değerini döndürdüğünden, "foo()" ifadesinin değeri 5'tir. İşlevlerin amacı normalde duruk bir değer döndürmek değildir, bir hesaplamanın sonucunu döndürürler.

Elbette, PHP'deki değerlerin hep tamsayılar olması gerekmez, zaten çoğunlukla değildirler. PHP dört çeşit sayıl değer destekler: Tamsayı (integer) değerler, kayan noktalı (float) değerler, dizge (string) değerler ve mantıksal boolean değerler (sayıl değerler, dizilerin aksine daha küçük parçalara bölemeyeceğiniz değerlerdir). PHP ayrıca iki bileşik (sayıl olmayan) tür destekler: Diziler ve nesneler. Bu değer türlerinden her biri bir değişkene atanabilir ya da bir işlevden döndürülebilir.

PHP, birçok başka dilin yaptığı gibi ifadeleri çok ileriye götürmüştür. PHP ifade-yönelimli bir dildir, bunun sebebi hemen hemen her şeyin bir ifade olmasıdır. Az önce üzerinde çalıştığımız '$a = 5' örneğini ele alalım. Burada iki değer kullanımı sözkonusudur, bir tamsayı sabit olan '5' ve 5 olarak değiştirilmiş $a'nın değeri. Ancak gerçek şu ki, burada bu ikiliye ek olarak başka bir değer daha vardır, o da atamanın kendi değeridir. Atamanın kendisi atanan değerle değerlendirilir, bu örnekte bu 5'tir. Uygulamada, ne yaptığından bağımsız olarak "$a = 5", değeri 5 olan bir ifadedir. Böylece, "$b = ($a = 5)" yazmak, "$a = 5; $b = 5;" yazmak gibidir (noktalı virgül deyimin sonlandırıldığını gösterir). Atamalar sağdan sola doğru işlendiğinden, "$b = $a = 5" de yazabilirsiniz.

İfade yönelimi ile ilgili diğer güzel bir örnek atama öncesi ve sonrası arttırma ve eksiltme işlemleridir. PHP ve diğer birçok dilin kullanıcıları, değişken++ ve değişken-- gösterimine az çok aşinadır. Bunlar arttırma ve eksiltme işleçleridir. PHP/FI 2'de, $a++ deyiminin bir değeri yoktur (bir ifade değildir), bu yüzden onu atayamaz ya da herhangi bir yerde kullanamazsınız. PHP, arttırma/eksiltme ifadelerinin yeteneklerini, bu ifadeleri C dilindekine benzer şekilde iyileştirerek genişletmiştir. PHP'de, C'de olduğu gibi önceden arttırma ve sonradan arttırma diye iki tür arttırma vardır. Bunların her ikisi de değişkenin değerini bir arttırır ve değişken üzerindeki etkileri aynıdır. Fark, arttırma ifadesinin değerindedir. Önceden arttırma, ++$değişken olarak yazılır ve arttırılmış değer öncelik alır (PHP değişkenin değerini önce arttırır, sonra okur, bu sebeple önceden arttırma ismi verilmiştir). Sonradan arttırma ise, $değişken++ olarak yazılır ve değer arttırılmadan önceki özgün değer önceliklidir (PHP değişkenin değerini okuduktan sonra değerini arttırır, bu sebeple sonradan arttırma ismi verilmiştir).

Çok geniş bir kullanıma sahip olan ifade türlerinden birisi de karşılaştırma ifadeleridir. Bu ifadeler FALSE ya da TRUE değerlerinden birini alırlar. PHP > (büyüktür), >= (büyüktür ya da eşittir), == (eşittir), != (eşit değildir), < (küçüktür) ve <= (küçüktür ya da eşittir) gösterimlerini destekler. Dil aynı zamanda aynılık işleçlerini de destekler: === (eşit ve aynı türdedir) ve !== (ne eşit ne de aynı türdedir). Bu ifadeler çoğunlukla if deyimleri gibi koşula bağlı işlemlerde kullanılmaktadırlar.

Vereceğimiz son ifade örneği işleçli atama ifadeleridir. $a'nın değerini 1 arttırmak istediğinizde, basitçe '$a++' ya da '++$a' yazmanızın yeterli olduğunu zaten biliyorsunuz. Ama ya birden daha büyük bir değer, örneğin 3 eklemek isterseniz? '$a++' ifadesini birkaç kez yazabilirsiniz, ama bunun pek verimli ya da kullanışlı yöntem olmadığı oldukça açık. '$a = $a + 3' çok daha yaygın bir kullanımdır. '$a + 3' ifadesi $a'nın değerini önce 3 arttırır sonra sonucu $a'ya atar, böylece $a'nın değeri 3 arttırılmış olur. PHP'de, birkaç dilde olduğu gibi C benzeri, daha temiz gözükecek ve daha kısa biçimde yazabileceğiniz bir gösterim daha vardır. $a'nın mevcut değerine 3 ekleme işlemi '$a += 3' biçiminde yazılabilir. Bunun anlamı tam olarak "$a'nın değerini al, 3 ekle ve yeni değeri $a'ya ata" olacaktır. Daha kısa ve temiz olmasının yanında, bu kod daha hızlı çalıştırılacaktır. '$a += 3' işleminin değeri, normal bir atama işleminde olduğu gibi, atanan değerdir. Bu değerin 3 OLMADIĞINA dikkat edin, bu değer $a ile 3'ün toplamıdır ($a'ya bu değer atanır). İşleçli atama kipinde herhangi bir iki terimli işleç kullanılabilir, örneğin '$a -= 5' ($a'nın değerinden 5 çıkarılır), '$b *= 7' ($b'nin değeri 7 ile çarpılır), vs.

Diğer dillerde görmediyseniz size farklı gözükebilecek bir ifade daha vardır, o da üç terimli koşul işlecidir:

<?php
$birinci ? $ikinci : $üçüncü
?>

İlk alt ifadenin değeri TRUE (sıfırdan farklı) ise, ikinci alt ifade değerlendirilir ve koşullu ifadenin sonucu bu olur. Aksi takdirde, üçüncü alt ifade değerlendirilir ve koşullu ifadenin sonucu bu olur.

Aşağıdaki örnek, önceden ve sonradan arttırma işleçlerini ve ifadelerini genelde biraz daha iyi anlamanıza yardımcı olacaktır:

<?php
function double($i)
{
    return $i*2;
}
$b = $a = 5;    /* beş değerini $a ve $b değişkenlerine atar */
$c = $a++;      /* sonradan arttırma, $a'nın özgün değerini (5) $c'ye atar */
$e = $d = ++$b; /* önceden arttırma, $b'nin arttırılmış değerini (6) $d
                   ve $e'ye atar */

/* bu noktada, $d ve $e 6'ya eşittir */

$f = double($d++);  /* $d'nin değerini arttırmadan önce $d'nin değerinin iki
                       katını $f'ye atar,  2*6 = 12 */
$g = double(++$e);  /* $e'nin değerini arttırdıktan sonra iki katını alıp
                       $g'ye atar,  2*7 = 14 */
$h = $g += 10;      /* önce, $g 10 arttırılır ve değeri 24 olur. Sonra bu
                       değer (24) $h'ye atanır ve onun da değeri 24 olur. */
?>

Bazı ifadeler deyim olarak ele alınabilir. Bu durumda, deyim 'ifade' ';' şeklinde, noktalı virgülle sonlandırılmış bir ifade şeklinde olacaktır. '$=$a=5;' olduğunda, $a=5 geçerli bir ifadedir, ancak kendi başına bir deyim değildir. '$b=$a=5;' ise geçerli bir deyimdir.

Son olarak bahsetmemiz gereken bir konu da ifadelerin gerçek değeridir. Birçok olayda, çoğunlukla da koşula bağlı çalışmalarda ve döngülerde, ifadenin kendi değeri ile değil, TRUE ya da FALSE olması ile ilgileniyor olacaksınız. TRUE ve FALSE sabitleri (büyük-küçük harf duyarsız) olası iki mantıksal değerdir. Gerektiğinde, bir ifade özdevinimli olarak mantıksal değere dönüştürülür. Tür çarpıtma bölümünde bunun nasıl gerçekleştiği ayrıntılı olarak anlatılmıştır.

PHP ifadeleri tümüyle ve çok güçlü bir biçimde uygulamaya geçirmiştir ve bunların tamamını belgelemek bu kılavuzun kapsamının dışında kalır. Yukarıdaki örnekler hangi ifadelerle nasıl kullanışlı ifadeler oluşturabileceğiniz hakkında yeterli fikir verecektir. Bu kılavuzun geri kalanında, geçerli herhangi bir PHP ifadesini belirtmek için ifade sözcüğünü kullanacağız.

Sihirli Sabitler
İşleçler
Dil Başvuru Kılavuzu


İşleçler

İçindekiler

  • İşleç Önceliği
  • Aritmetik İşleçler
  • Atama İşleçleri
  • Bitsel İşleçler
  • Karşılaştırma İşleçleri
  • Hata Denetim İşleçleri
  • Çalıştırma İşleci
  • Arttırım ve Eksiltim İşleçleri
  • Mantıksal İşleçler
  • Dizge İşleçleri
  • Dizi İşleçleri
  • Tür İşleçleri

Bir işleç, başka bir değer üretmek üzere bir veya daha fazla değerle (programcı dilinde ifadeyle) beslenen bir şeydir (yani, değerler işleçle birlikte bir ifade haline gelir). Bu bakımdan, bir değer döndüren işlevler ve benzeri oluşumlar (print gibi) ya da belirtilenden başka bir şey döndürmeyen (echo gibi) oluşumlar birer işleç olarak düşünülebilir.

Üç tür işleç vardır. İlki tek bir değerle çalışan tek terimli işleç olup ! (olumsuzlama işleci) veya ++ (arttırım işleci) buna birer örnektir. İkinci işleç grubu iki terimlilerdir; PHP'nin desteklediği işleçlerin çoğunluğu bu grupta olup aşağıda İşleç Önceliği bölümünde liste halinde verilmişlerdir.

Üçüncü grupta üç terimli işleç yer alır: ?:. Bir ifadeye bağlı olarak iki deyim veya çalıştırma yolunu seçmekten ziyade diğer iki ifadeden birini seçmek için kullanılır. İşlecin üç ifadesini parantez içinde belirtmek iyi bir uygulamadır.

İfadeler
İşleç Önceliği
Dil Başvuru Kılavuzu


İşleç Önceliği

İşleç önceliği iki ifadenin birbirine hangi sıkılıkta bağlı olduğunu belirtir. Örneğin, 1 + 5 * 3 ifadesinin sonucu 18 değil, 16'dır. Çünkü, çarpma ("*") işlecinin önceliği toplama ("+") işlecinden yüksektir. Önceliği arttırmak için gerekirse parantezler kullanılabilir. Örneğin, (1 + 5) * 3 ifadesinin sonucu 18 olacaktır. Eğer işleç önceliklerinde eşitlik sözkonusu olursa soldaki işleç sağdakinden öncelikli olur.

Aşağıdaki listede işleçler en yüksek öncelikliden başlayıp en düşük öncelikliye doğru sıralanmışlardır. Aynı satırda yer alan işleçler eşöncelikli olup hangi sırada ele alınacaklarına değerlendirme sırasında karar verilir.

İşleç Öncelikleri
İlişkilendirme | İşleçler | Ek bilgi
yönsüz | clone new | clone ve new
soldan | [ | array()
yönsüz | ++ -- | arttırım/eksiltim
sağdan | ~ - (int) (float) (string) (array) (object) (bool) @ | Türler
yönsüz | instanceof | Türler
sağdan | ! | mantıksal
soldan | * / % | aritmetik
soldan | + - . | aritmetik ve dizge
soldan | << >> | bitsel
yönsüz | < <= > >= <> | karşılaştırma
yönsüz | == != === !== | karşılaştırma
left | & | bitsel ve gönderimler
soldan | ^ | bitsel
soldan | | | bitsel
soldan | && | mantıksal
soldan | || | mantıksal
soldan | ? : | üç terimli
sağdan | = += -= *= /= .= %= &= |= ^= <<= >>= => | atama
soldan | and | mantıksal
soldan | xor | mantıksal
soldan | or | mantıksal
soldan | , | birçok kullanım

Soldan ilişkilendirme, ifadenin soldan sağa, sağdan ilişkilendirme ise sağdan sola değerlendirileceği anlamına gelir.

Örnek 1 - Öncelik yönü

<?php
$a = 3 * 3 % 5; // (3 * 3) % 5 = 4
$a = true ? 0 : true ? 1 : 2; // (true ? 0 : true) ? 1 : 2 = 2

$a = 1;
$b = 2;
$a = $b += 3; // $a = ($b += 3) -> $a = 5, $b = 5
?>
Parantezleri kodun okunabilirliğini arttırmak için kullanın.

Bilginize:

Eşitlik (=) işleci çoğu işleçten daha düşük önceliğe sahip olduğundan PHP halen şuna benzer ifadelere izin vermektedir: foo() işlevinin dönüş değerini $a değişkenine atayan if (!$a = foo()) ifadesi.

İşleçler
Aritmetik İşleçler
İşleçler


Aritmetik İşleçler

Okulda öğrendiğiniz temel aritmetiği hatırlıyor musunuz? Bu işleçler tam da öyle çalışır.

Aritmetik İşleçler
Örnek | İsim | Sonuç
-$a | Olumsuzlama | $a'nın eksi işaretlisi.
$a + $b | Toplama | $a ile $b'nin toplamı.
$a - $b | Çıkarma | $a'nın $b'den farkı.
$a * $b | Çarpma | $a ile $b'nin çarpımı.
$a / $b | Bölme | $a'nın $b'ye bölümü.
$a % $b | Kalan | $a'nın $b'ye bölümünden kalan.

Bölme işlecinin tamsayı bölüm vermesi için iki teriminin de tamsayı (veya dönüşüm sonucu tamsayı olan dizge) olması ve birbirlerine tam olarak bölünmesi gerekir, aksi takdirde bölüm gerçek sayı olacaktır.

Kalan işlecinin (%) terimleri gerçek sayılarsa ondalık kısımları atılarak tamsayıya dönüştürülürler.

Bilginize: $a % $b işleminin sonucu, $a negatifse negatif olacaktır.

Matematik işlevleri bölümüne de bakınız.

İşleç Önceliği
Atama İşleçleri
İşleçler


Atama İşleçleri

Temel atama işleci "=" imidir. Programlamaya yeni başlayanlar bu işleci"eşittir" diye okurlar. Aslında yapılan işlem bir şeyleri birbirlerine eşitlemek değildir. Yaptığı iş sağındaki ifadenin değerini solundaki terimin değeri haline getirmektir, yani imleci içeren ifadeyi birşey'in değeri diye okumak daha doğrudur.

Bir atama ifadesinin değeri atanan değerdir. Yani, "$a = 3" ifadesinin değeri 3'tür. Bunun bir takım yan sonuçları da vardır:

<?php

$a = ($b = 4) + 5; // $a'nın değeri 9, $b'nin değeri 4 olur.

?>

Diziler içi bir değerin bir isimli anahtara atanması "=>" işleci kullanılarak gerçekleştirilir. Bu işlecin önceliği diğer atama işleçlerinin önceliğiyle aynıdır.

Temel atama işlecinden başka atama işlemini temel aritmetik, ikil aritmetik işlemleriyle veya dizi ya da dizge birleştirme işlemleriyle birleştiren, "birleşik atama işleçleri" vardır. Örnek:

<?php

$a = 3;
$a += 5; // $a'nın değeri 8 olur, asıl işlem: $a = $a + 5;
$b = "Herkese ";
$b .= "Merhaba!"; // $b'nin değeri "Herkese Merhaba!" olur.
                  // asıl işlem: $b = $b . "Merhaba!";

?>

Atama işleminin özgün değişkeni yeni değişkene kopyaladığına (değeriyle atadığına) dikkat ediniz. Dolayısıyla birinde yapılan değişiklik diğerini etkilemeyecektir. Kapalı bir döngü içinde büyükçe bir diziye atama işlemleri yapma ihtiyacı duyarsanız bu ayrı bir anlam kazanır. Gönderimli atama $değişken = &$diğerdeğişken; sözdizimi ile desteklenmektedir. 'Gönderimli atama' denince, iki değişkenin aynı veriyi gösterdiğini ve birbirlerinden birşeyler kopyalamadıklarını anlıyoruz. Gönderimler hakkında daha ayrıntılı bilgi edinmek için Gönderimlerle ilgili herşey bölümüne bakınız. PHP 5'ten itibaren, clone anahtar sözcüğü ile yeni bir nesneye atama yapılmadıkça, nesneler gönderimli olarak atanırlar.

Aritmetik İşleçler
Bitsel İşleçler
İşleçler


Bitsel İşleçler

Bitsel işleçler, bir tamsayının içindeki belli bitleri 0 ya da 1 yaparlar.

Bitsel İşleçler
Örnek | İsim | Sonuç
$a & $b | Ve | Hem $a hem de $b'de 1 olan bitler sonuçta 1 yapılır.
$a | $b | Veya | $a veya $b'de 1 olan bitler sonuçta 1 yapılır.
$a ^ $b | Ayrıcalıklı Veya | Hem $a hem de $b'de 0 veya 1 olan bitler sonuçta 0, diğerleri 1 yapılır.
~ $a | Değil | $a'nın 0 olan bitleri 1, 1 olanları 0 yapılır.
$a << $b | Sola kaydırma | $a'nın bitleri $b adım sola kaydırılır (her adım ikiyle çarpma işlemine denktir).
$a >> $b | Sağa kaydırma | $a'nın bitleri $b adım sağa kaydırılır (her adım ikiye bölme işlemine denktir).

PHP'de bit kaydırma bir aritmetik işlemdir. Kaydırma sonucu her iki uçtan da taşan bitler silinir. Sola kaydırmada sağdan eksilen bitler sıfırlarla doldurulur, bu arada işaret biti soldan taşarak silinir, yani sola kaydırmada terimin işareti korunmaz. Sağa kaldırmada ise işaret biti yerinden oynatılmaz, yani sağa kaydırmada terimin işareti korunur.

Bir işlemin öncelik almasını istiyorsanız yaylı ayraçları kullanın. Örneğin, $a & $b == true işleminde önce eşitlik sonra bitsel VE uygulanırken ($a & $b) == true işleminde ise önce bitsel VE sonra eşitlik uygulanır.

Veri türü dönüşümlerinde dikkatli olun. Eğer sol ve sağ taraf değiştirgelerinin ikisi de dizge ise bitsel işleçler terimlerdeki karakterlerin ASCII değerleri üzerinde işlem yapacaktır.

PHP'nin error_reporting yönergesi gerçekte neler olup bittiğini göstermek
için bitsel değerler kullanır. Sadece bilgilendirmeleri değil hataların
tümünü görmek isterseniz php.ini dosyasında ilgili yere şunu yazın:
E_ALL & ~E_NOTICE

Bu E_ALL için şöyle çalışır:
00000000000000000111011111111111
Keza E_NOTICE...
00000000000000000000000000001000
... ve ~ ile ters çevrilerek:
11111111111111111111111111110111
Son olarak, her iki değer üzerinde etkin bitleri bulmak için
VE (&) işlecini kullanır:
00000000000000000111011111110111

Bunu sağlamanın bir başka yolu da sadece bir değerde veya diğerinde etkin
bitleri bulmak için XOR (^) kullanmaktır:
E_ALL ^ E_NOTICE

error_reporting yönergesi bitleri etkin kılmayı göstermek için de
kullanılabilir. Sadece hataları ve kurtarılabilir göstermenin yolu:
E_ERROR | E_RECOVERABLE_ERROR

Bu işlem etkin bitleri almak için
00000000000000000000000000000001
ve
00000000000000000001000000000000
E_ERROR'ları üzerinde VEYA (|) işlecini kullanır:
00000000000000000001000000000001

Örnek 1 - Tamsayılar üzerinde bitsel işlemler

<?php
/*
 * Üstteki bölümü yoksayın,
 * çıktıyı iyileştirmek için biçemlemekten başka birşey yapmıyor.
 */

$format = '(%1$2d = %1$04b) = (%2$2d = %2$04b)'
        . ' %3$s (%4$2d = %4$04b)' . "\n";

echo <<<EOH
 ---------     ---------  -- ---------
   sonuç         değer    işl   dnm
 ---------     ---------  -- ---------
EOH;

/*
 * Örnekler burada.
 */

$değerler = array(0, 1, 2, 4, 8);
$dnm = 1 + 4;

echo "\n Bitsel VE \n";
foreach ($değerler as $değer) {
    $sonuç = $değer & $dnm;
    printf($format, $sonuç, $değer, '&', $dnm);
}

echo "\n Bitsel Ayrıcalıklı VEYA \n";
foreach ($değerler as $değer) {
    $sonuç = $değer | $dnm;
    printf($format, $sonuç, $değer, '|', $dnm);
}

echo "\n Bitsel Ayrıcalıklı VEYA (XOR) \n";
foreach ($değerler as $değer) {
    $sonuç = $değer ^ $dnm;
    printf($format, $sonuç, $değer, '^', $dnm);
}
?>

Yukarıdaki örneğin çıktısı:

 ---------     ---------  -- ---------
   sonuç         değer    işl   dnm
 ---------     ---------  -- ---------
 Bitsel VE
( 0 = 0000) = ( 0 = 0000) & ( 5 = 0101)
( 1 = 0001) = ( 1 = 0001) & ( 5 = 0101)
( 0 = 0000) = ( 2 = 0010) & ( 5 = 0101)
( 4 = 0100) = ( 4 = 0100) & ( 5 = 0101)
( 0 = 0000) = ( 8 = 1000) & ( 5 = 0101)

 Bitsel Ayrıcalıklı VEYA
( 5 = 0101) = ( 0 = 0000) | ( 5 = 0101)
( 5 = 0101) = ( 1 = 0001) | ( 5 = 0101)
( 7 = 0111) = ( 2 = 0010) | ( 5 = 0101)
( 5 = 0101) = ( 4 = 0100) | ( 5 = 0101)
(13 = 1101) = ( 8 = 1000) | ( 5 = 0101)

 Bitsel Ayrıcalıklı VEYA (XOR)
( 5 = 0101) = ( 0 = 0000) ^ ( 5 = 0101)
( 4 = 0100) = ( 1 = 0001) ^ ( 5 = 0101)
( 7 = 0111) = ( 2 = 0010) ^ ( 5 = 0101)
( 1 = 0001) = ( 4 = 0100) ^ ( 5 = 0101)
(13 = 1101) = ( 8 = 1000) ^ ( 5 = 0101)

Örnek 2 - Dizgeler üzerinde bitsel işlemler

<?php
echo 12 ^ 9; // '5' çıktılar

echo "12" ^ "9"; // Gerisilme karakterini çıktılar (ASCII 8)
                 // ('1' (ascii 49)) ^ ('9' (ascii 57)) =  ASCII 8

echo "hallo" ^ "hello"; // Çıktılanan ASCII değerler #0 #4 #0 #0 #0
                        // 'a' ^ 'e' = #4

echo 2 ^ "3"; // 1 çıktılar
              // 2 ^ ((int)"3") == 1

echo "2" ^ 3; // 1 çıktılar
              // ((int)"2") ^ 3 == 1
?>

Örnek 3 - Tamsayılarda bit kaydırma

<?php
/*
 * Bunlar örnektir.
 */

echo "\n--- POZİTİF TAMSAYILARDA SAĞA BİT KAYDIRMA ---\n";

$dgr = 4;
$hane = 1;
$snç = $dgr >> $hane;
p($snç, $dgr, '>>', $hane, 'işaret bitinin kopyası sola kaydırıldı');

$dgr = 4;
$hane = 2;
$snç = $dgr >> $hane;
p($snç, $dgr, '>>', $hane);

$dgr = 4;
$hane = 3;
$snç = $dgr >> $hane;
p($snç, $dgr, '>>', $hane, 'bitler sağa kaydırıldı');

$dgr = 4;
$hane = 4;
$snç = $dgr >> $hane;
p($snç, $dgr, '>>', $hane, 'yukarıdakiyle aynı; 0\'dan sonrası kaydırılamaz');

echo "\n--- NEGATİF TAMSAYILARDA SAĞA BİT KAYDIRMA ---\n";

$dgr = -4;
$hane = 1;
$snç = $dgr >> $hane;
p($snç, $dgr, '>>', $hane, 'işaret bitinin kopyası sola kaydırıldı');

$dgr = -4;
$hane = 2;
$snç = $dgr >> $hane;
p($snç, $dgr, '>>', $hane, 'bitler sağa kaydırıldı');

$dgr = -4;
$hane = 3;
$snç = $dgr >> $hane;
p($snç, $dgr, '>>', $hane, 'yukarıdakiyle aynı; -1\'dan sonrası kaydırılamaz');

echo "\n--- POZİTİF TAMSAYILARDA SOLA BİT KAYDIRMA ---\n";

$dgr = 4;
$hane = 1;
$snç = $dgr << $hane;
p($snç, $dgr, '<<', $hane, 'sağ taraf sıfırlarla doldurulur');

$dgr = 4;
$hane = (PHP_INT_SIZE * 8) - 4;
$snç = $dgr << $hane;
p($snç, $dgr, '<<', $hane);

$dgr = 4;
$hane = (PHP_INT_SIZE * 8) - 3;
$snç = $dgr << $hane;
p($snç, $dgr, '<<', $hane, 'işaret bitleri dışa kaydırılır');

$dgr = 4;
$hane = (PHP_INT_SIZE * 8) - 2;
$snç = $dgr << $hane;
p($snç, $dgr, '<<', $hane, 'bitler sola kaydırıldı');

echo "\n--- NEGATİF TAMSAYILARDA SOLA BİT KAYDIRMA ---\n";

$dgr = -4;
$hane = 1;
$snç = $dgr << $hane;
p($snç, $dgr, '<<', $hane, 'sağ taraf sıfırlarla doldurulur');

$dgr = -4;
$hane = (PHP_INT_SIZE * 8) - 3;
$snç = $dgr << $hane;
p($snç, $dgr, '<<', $hane);

$dgr = -4;
$hane = (PHP_INT_SIZE * 8) - 2;
$snç = $dgr << $hane;
p($snç, $dgr, '<<', $hane, 'işaret biti dahil, bitler soldan dışa kaydırıldı');

/*
 * Bundan sonrasını yoksayın; çıktıyı biçemlemekten başka bir şey yapmıyor.
 */

function p($snç, $dgr, $op, $hane, $ilt = '') {
    $format = '%0' . (PHP_INT_SIZE * 8) . "b\n";

    printf("İfade: %d = %d %s %d\n", $snç, $dgr, $op, $hane);

    echo " Onluk:\n";
    printf("  değer=%d\n", $dgr);
    printf("  sonuç=%d\n", $snç);

    echo " İkilik:\n";
    printf('  değer=' . $format, $dgr);
    printf('  sonuç=' . $format, $snç);

    if ($ilt) {
        echo " DİKKAT: $ilt\n";
    }

    echo "\n";
}
?>

Yukarıdaki örneğin 32 bitlik makinelerdeki çıktısı:

--- POZİTİF TAMSAYILARDA SAĞA BİT KAYDIRMA ---
İfade: 2 = 4 >> 1
 Onluk:
  değer=4
  sonuç=2
 İkilik:
  değer=000000000000000000000000000100
  sonuç=000000000000000000000000000010
 DİKKAT: işaret bitinin kopyası sola kaydırıldı

İfade: 1 = 4 >> 2
 Onluk:
  değer=4
  sonuç=1
 İkilik:
  değer=000000000000000000000000000100
  sonuç=000000000000000000000000000001

İfade: 0 = 4 >> 3
 Onluk:
  değer=4
  sonuç=0
 İkilik:
  değer=000000000000000000000000000100
  sonuç=000000000000000000000000000000
 DİKKAT: bitler sağa kaydırıldı

İfade: 0 = 4 >> 4
 Onluk:
  değer=4
  sonuç=0
 İkilik:
  değer=000000000000000000000000000100
  sonuç=000000000000000000000000000000
 DİKKAT: yukarıdakiyle aynı; 0'dan sonrası kaydırılamaz

--- NEGATİF TAMSAYILARDA SAĞA BİT KAYDIRMA ---
İfade: -2 = -4 >> 1
 Onluk:
  değer=-4
  sonuç=-2
 İkilik:
  değer=111111111111111111111111111100
  sonuç=111111111111111111111111111110
 DİKKAT: işaret bitinin kopyası sola kaydırıldı

İfade: -1 = -4 >> 2
 Onluk:
  değer=-4
  sonuç=-1
 İkilik:
  değer=111111111111111111111111111100
  sonuç=111111111111111111111111111111
 DİKKAT: bitler sağa kaydırıldı

İfade: -1 = -4 >> 3
 Onluk:
  değer=-4
  sonuç=-1
 İkilik:
  değer=111111111111111111111111111100
  sonuç=111111111111111111111111111111
 DİKKAT: yukarıdakiyle aynı; -1'dan sonrası kaydırılamaz

--- POZİTİF TAMSAYILARDA SOLA BİT KAYDIRMA ---
İfade: 8 = 4 << 1
 Onluk:
  değer=4
  sonuç=8
 İkilik:
  değer=000000000000000000000000000100
  sonuç=000000000000000000000000001000
 DİKKAT: sağ taraf sıfırlarla doldurulur

İfade: 4611686018427387904 = 4 << 60
 Onluk:
  değer=4
  sonuç=4611686018427387904
 İkilik:
  değer=000000000000000000000000000100
  sonuç=010000000000000000000000000000

İfade: -9223372036854775808 = 4 << 61
 Onluk:
  değer=4
  sonuç=-9223372036854775808
 İkilik:
  değer=000000000000000000000000000100
  sonuç=100000000000000000000000000000
 DİKKAT: işaret bitleri dışa kaydırılır

İfade: 0 = 4 << 62
 Onluk:
  değer=4
  sonuç=0
 İkilik:
  değer=000000000000000000000000000100
  sonuç=000000000000000000000000000000
 DİKKAT: bitler sola kaydırıldı

--- NEGATİF TAMSAYILARDA SOLA BİT KAYDIRMA ---
İfade: -8 = -4 << 1
 Onluk:
  değer=-4
  sonuç=-8
 İkilik:
  değer=111111111111111111111111111100
  sonuç=111111111111111111111111111000
 DİKKAT: sağ taraf sıfırlarla doldurulur

İfade: -9223372036854775808 = -4 << 61
 Onluk:
  değer=-4
  sonuç=-9223372036854775808
 İkilik:
  değer=111111111111111111111111111100
  sonuç=100000000000000000000000000000

İfade: 0 = -4 << 62
 Onluk:
  değer=-4
  sonuç=0
 İkilik:
  değer=111111111111111111111111111100
  sonuç=000000000000000000000000000000
 DİKKAT: işaret biti dahil, bitler soldan dışa kaydırıldı

Yukarıdaki örneğin 64 bitlik makinelerdeki çıktısı:

--- POZİTİF TAMSAYILARDA SAĞA BİT KAYDIRMA ---
İfade: 2 = 4 >> 1
 Onluk:
  değer=4
  sonuç=2
 İkilik:
  değer=0000000000000000000000000000000000000000000000000000000000000100
  sonuç=0000000000000000000000000000000000000000000000000000000000000010
 DİKKAT: işaret bitinin kopyası sola kaydırıldı

İfade: 1 = 4 >> 2
 Onluk:
  değer=4
  sonuç=1
 İkilik:
  değer=0000000000000000000000000000000000000000000000000000000000000100
  sonuç=0000000000000000000000000000000000000000000000000000000000000001

İfade: 0 = 4 >> 3
 Onluk:
  değer=4
  sonuç=0
 İkilik:
  değer=0000000000000000000000000000000000000000000000000000000000000100
  sonuç=0000000000000000000000000000000000000000000000000000000000000000
 DİKKAT: bitler sağa kaydırıldı

İfade: 0 = 4 >> 4
 Onluk:
  değer=4
  sonuç=0
 İkilik:
  değer=0000000000000000000000000000000000000000000000000000000000000100
  sonuç=0000000000000000000000000000000000000000000000000000000000000000
 DİKKAT: yukarıdakiyle aynı; 0'dan sonrası kaydırılamaz

--- NEGATİF TAMSAYILARDA SAĞA BİT KAYDIRMA ---
İfade: -2 = -4 >> 1
 Onluk:
  değer=-4
  sonuç=-2
 İkilik:
  değer=1111111111111111111111111111111111111111111111111111111111111100
  sonuç=1111111111111111111111111111111111111111111111111111111111111110
 DİKKAT: işaret bitinin kopyası sola kaydırıldı

İfade: -1 = -4 >> 2
 Onluk:
  değer=-4
  sonuç=-1
 İkilik:
  değer=1111111111111111111111111111111111111111111111111111111111111100
  sonuç=1111111111111111111111111111111111111111111111111111111111111111
 DİKKAT: bitler sağa kaydırıldı

İfade: -1 = -4 >> 3
 Onluk:
  değer=-4
  sonuç=-1
 İkilik:
  değer=1111111111111111111111111111111111111111111111111111111111111100
  sonuç=1111111111111111111111111111111111111111111111111111111111111111
 DİKKAT: yukarıdakiyle aynı; -1'dan sonrası kaydırılamaz

--- POZİTİF TAMSAYILARDA SOLA BİT KAYDIRMA ---
İfade: 8 = 4 << 1
 Onluk:
  değer=4
  sonuç=8
 İkilik:
  değer=0000000000000000000000000000000000000000000000000000000000000100
  sonuç=0000000000000000000000000000000000000000000000000000000000001000
 DİKKAT: sağ taraf sıfırlarla doldurulur

İfade: 4611686018427387904 = 4 << 60
 Onluk:
  değer=4
  sonuç=4611686018427387904
 İkilik:
  değer=0000000000000000000000000000000000000000000000000000000000000100
  sonuç=0100000000000000000000000000000000000000000000000000000000000000

İfade: -9223372036854775808 = 4 << 61
 Onluk:
  değer=4
  sonuç=-9223372036854775808
 İkilik:
  değer=0000000000000000000000000000000000000000000000000000000000000100
  sonuç=1000000000000000000000000000000000000000000000000000000000000000
 DİKKAT: işaret bitleri dışa kaydırılır

İfade: 0 = 4 << 62
 Onluk:
  değer=4
  sonuç=0
 İkilik:
  değer=0000000000000000000000000000000000000000000000000000000000000100
  sonuç=0000000000000000000000000000000000000000000000000000000000000000
 DİKKAT: bitler sola kaydırıldı

--- NEGATİF TAMSAYILARDA SOLA BİT KAYDIRMA ---
İfade: -8 = -4 << 1
 Onluk:
  değer=-4
  sonuç=-8
 İkilik:
  değer=1111111111111111111111111111111111111111111111111111111111111100
  sonuç=1111111111111111111111111111111111111111111111111111111111111000
 DİKKAT: sağ taraf sıfırlarla doldurulur

İfade: -9223372036854775808 = -4 << 61
 Onluk:
  değer=-4
  sonuç=-9223372036854775808
 İkilik:
  değer=1111111111111111111111111111111111111111111111111111111111111100
  sonuç=1000000000000000000000000000000000000000000000000000000000000000

İfade: 0 = -4 << 62
 Onluk:
  değer=-4
  sonuç=0
 İkilik:
  değer=1111111111111111111111111111111111111111111111111111111111111100
  sonuç=0000000000000000000000000000000000000000000000000000000000000000
 DİKKAT: işaret biti dahil, bitler soldan dışa kaydırıldı

Uyarı

32 bitlik sistemlerde 32 bitten fazla sağa kaydırma yapmayın. 32 bitten daha geniş bir sayıyla sonuçlanacak şekilde sola kaydırma yapmayın. PHP_INT_MAX'tan büyük sayılar üzerinde bitsel işlemler yapacaksanız gmp eklentisindeki işlevleri kullanın.

Ayrıca bakınız:
pack(),
unpack(),
gmp_and(),
gmp_or(),
gmp_xor(),
gmp_testbit(),
gmp_clrbit()

Atama İşleçleri
Karşılaştırma İşleçleri
İşleçler


Karşılaştırma İşleçleri

Karşılaştırma işleçleri isminden de anlaşılacağı üzere iki değerin karşılaştırılmasını sağlarlar. Çeşitli veri türleri arasındaki karşılaştırma örneklerinin yer aldığı tür karşılaştırma tabloları ilginizi çekebilir.

Karşılaştırma İşleçleri
Örnek | İsim | Sonuç
$a == $b | Eşittir | $a ve $b aynı değere sahipse sonuç TRUE olur.
$a === $b | Aynıdır | $a ve $b aynı değere sahipse ve türleri de aynıysa sonuç TRUE olur. (PHP 4'ten beri vardır.)
$a != $b | Eşit değildir | $a ve $b aynı değere sahip değilse sonuç TRUE olur.
$a <> $b | Eşit değildir | $a ve $b aynı değere sahip değilse sonuç TRUE olur.
$a !== $b | Farklıdır | $a ve $b aynı değere sahip değilse veya türleri aynı değilse sonuç TRUE olur. (PHP 4'ten beri vardır.)
$a < $b | Küçüktür | $a kesin olarak $b'den küçükse sonuç TRUE olur.
$a > $b | Büyüktür | $a kesin olarak $b'den büyükse sonuç TRUE olur.
$a <= $b | Küçük veya eşittir | $a, $b'den küçük veya ona eşitse sonuç TRUE olur.
$a >= $b | Büyük veya eşittir | $a, $b'den büyük veya ona eşitse sonuç TRUE olur.

Bir sayıyı bir dizge ile veya iki sayısal dizgeyi karşılaştırmak isterseniz dizge önce bir sayıya dönüştürülür ve karşılaştırma sayısal olarak yapılır. Bu kurallar ayrıca switch deyimine de uygulanır. === veya !== ile tür ve dolayısıyla değer karşılaştırıldığından böyle karşılaştırmalarda tür dönüşümü yapılmaz.

<?php
var_dump(0 == "a"); // 0 == 0 -> doğru
var_dump("1" == "01"); // 1 == 1 -> doğru
var_dump("10" == "1e1"); // 10 == 10 -> doğru
var_dump(100 == "1e2"); // 100 == 100 -> doğru

switch ("a") {
case 0:
    echo "0";
    break;
case "a": // burası hiç işlem görmez, çünkü "a" daima 0 ile eşleşir
    echo "a";
    break;
}
?>

Çeşitli türler arasında karşılaştırma aşağıdaki tabloya ve tablodaki sıralamaya uygun olarak yapılır.

Çeşitli Türlerin Karşılaştırılması
1. Terimin Türü | 2. Terimin Türü | Sonuç
null veya string | string | NULL, "" dizgesine dönüştürülür, sayısal veya alfabetik karşılaştırma yapılır.
bool veya null | herhangi bir tür | bool türüne dönüşümden sonra FALSE < TRUE karşılaştırması yapılır
object | object | Yerleşik sınıflar kendi karşılaştırmalarını tanımlayabilir. Farklı sınıflar karşılaştırılamazlar. Aynı sınıfın özellikleri dizilerdeki gibi (PHP 4) karşılaştırırılır. PHP 5'in uygulaması farklıdır.
string, resource veya number | string, resource veya number | Diziler ve özkaynaklar sayılara dönüştürülür, sayısal karşılaştırma yapılır.
array | array | Daha az üyeye sahip dizi diğerinden küçüktür. Eğer 1. terimin anahtarı 2. terimde yoksa diziler karşılaştırılamaz. Karşılaştırma daima değerler karşılaştırılarak yapılır (aşağıdaki örneğe bakınız).
array | herhangi bir tür | array daima büyüktür.
object | herhangi bir tür | object daima büyüktür

Örnek 1 - Özetle Standard Dizi Karşılaştırması

<?php
// Diziler bunun gibi standart karşılaştırma işleçleri ile karşılaştırılır
function standard_dizi_karşılaştır($trm1, $trm2)
{
    if (count($ter1) < count($ter2)) {
      return -1;                          // $ter1 < $ter2
    } elseif (count($op1) > count($op2)) {
        return 1;                         // $ter1 > $ter2
    }
    foreach ($ter1 as $anh => $değ) {
        if (!array_key_exists($anh, $ter2)) {
            return null;                   // karşılaştırılamaz
        } elseif ($değ < $ter2[$anh]) {
            return -1;
        } elseif ($değ > $ter2[$anh]) {
            return 1;
        }
    }
    return 0; // $ter1 == $ter2
}
?>

Ayrıca, strcasecmp(), strcmp() işlevlerine, Dizi işleçlerine ve Türler bölümüne de bakınız.

Uyarı

Gerçek sayıların karşılaştırılması

float türlerinin dahili gösteriminden dolayı iki float sayının eşitliğine bakamazsınız.

Bu konuda daha ayrıntıl bilgi için float türünün belgesine bakınız.

Üç Terimli İşleç

Diğer bir karşılaştırma işleci ?: (üç terimli) işlecidir.

Örnek 2 - Öntanımlı bir değer atama

<?php
// Üç terimli işleç için kullanım örneği
$action = (empty($_POST['action'])) ? 'default' : $_POST['action'];

// Yukarıdaki kod ile buradaki if/else deyimi aynı işlemi yapar.
if (empty($_POST['action'])) {
    $action = 'default';
} else {
    $action = $_POST['action'];
}

?>
(ifade1) ? (ifade2) : (ifade3) ifadesinin sonucu, ifade1 doğruysa ifade2 değilse ifade3'dir.

PHP 5.3'ten itibaren üç terimli işlecin orta parçasını dışarda bırakmak mümkündür. ifade1 ?: ifade3 ifadesinin sonucu ifade1 TRUE ise ifade1 ile değilse ifade3'tür.

Bilginize: Üç terimli işleç aslında bir deyimdir, dolayısıyla sonucu bir değişkene atanamaz. Bir değişkeni gönderimli döndürmek istediğiniz takdirde bu önem kazanır. Gönderimli olarak değer döndüren bir işlevde return $var == 42 ? $a : $b; deyimi bu bakımdan çalışmaz ve güncel PHP sürümlerinde bir uyarı gösterilir.

Bilginize:

Üç terimli işleçleri iç içe kullanmanız önerilmez. PHP'nin böyle bir işlemin tek bir deyimde yapılmak istenmesi durumundaki davranışı beklendiği gibi olmayabilir.

Örnek 3 - İç içe üç terimli davranışı

<?php
// ilk bakışta aşağıdaki deyimin sonucu 'true' olacak sanılır.
echo (true?'true':false?'t':'f');

// ancak gerçekte çıktı 't' olur.
// Çünkü üç terimli ifade soldan sağa değerlendirilir.

// Aynı deyimi şöyle yazarsanız, durum anlaşılır hale gelir
echo ((true ? 'true' : false) ? 't' : 'f');

// Burada, ilk ifade mantıksal olarak doğru olduğundan sonuç 'true'
// olacak, böylece ikinci üç terimlinin ilk terimi 'true' olacak ve
// ikinci üç terimliden 't' dönecektir.
?>

Bitsel İşleçler
Hata Denetim İşleçleri
İşleçler


Hata Denetim İşleçleri

PHP tek bir hata denetim işlecini destekler: kuyruklu a imi (@). PHP'de bir deyimin başına getirildiğinde, bu deyimin üreteceği olası hata iletileri yok sayılır.

Eğer track_errors özelliği etkinse bu deyimin ürettiği hata iletileri $php_errormsg değişkenine kaydedilir. Her hata oluşunda yeni hata eskisinin yerini alacağından bu değişkene yeterli sıklıkta bakmanız gerekir.

<?php
/* Kasıtlı dosya hatası */
$dosyam = @file ('var_olmayan_dosya') or
    die ("Dosya açılamadı: hata '$php_errormsg' değişkeninde kayıtlı");

// İfadelerle çalışır ama işlevlerle çalışmaz:
$değer = @$cache[$key];
// $key indisi mevcut değilse bir uyarı çıktılanır.

?>

Bilginize: Kuyruklu a işleci sadece ifadelerin başında kullanıldığında çalışır. Kısaca: Bir değer elde edebildiğiniz herşeyin başına @ getirebilirsiniz. Örneğin, değişkenlerin işlev veya include çağrılarının, sabitlerin ve benzerlerinin başına @ getirebilirsiniz. Ama işlev veya sınıf tanımlarının veya if ve foreach gibi denetim yapılarının başına @ koyamazsınız.

Ayrıca, error_reporting() işlevine ve Hata İşleme ve Günce Kayıt İşlevleri bölümüne bakınız.

Uyarı

Şu an @ hata denetim işleci, betiğin çalışmasını sonlandıracak önemli hataların raporlanmasını bile iptal edebilmektedir. Bu bakımdan, işleci örneğin bir işlevden kaynaklanabilecek hataları bastırmak için kullanıyorsanız, işlev tanımında yaptığınız yazım hataları veya işlevin yokluğu halinde ne olup bittiğini anlamadan betiğiniz sonlanıverebilir.

Karşılaştırma İşleçleri
Çalıştırma İşleci
İşleçler


Çalıştırma İşleci

PHP tek bir çalıştırma işlecini destekmektedir: ters tırnak imleri (``). Bunların bildiğiniz tek tırnaklar olmadığına dikkat edin! Ters tırnak imlerinin arasına yazılmış komutları PHP komut satırında çalıştıracak ve çıktısını döndürecektir. Yani, komut satırına birşey çıktılanmaz; ama sonucu bir değişkene atayabilirsiniz. Çalıştırma işleci shell_exec() işlevinin yaptığı işi yapar.

<?php
$output = `ls -al`;
echo "<pre>$output</pre>";
?>

Bilginize:

safe_mode etkinse veya shell_exec() işlevi etkin değilse, çalıştırma işleci etkin değildir.

Ayrıca, Program Çalıştırma İşlevleri, popen(), proc_open() işlevleri ve PHP'nin komut satırından kullanılması bölümüne de bakınız.

Hata Denetim İşleçleri
Arttırım ve Eksiltim İşleçleri
İşleçler


Arttırım ve Eksiltim İşleçleri

PHP, C tarzı önceden ve sonradan arttırım ve eksiltim işleçlerini destekler.

Bilginize: Arttırım ve eksiltim işleçleri mantıksal değerler üzerinde etkisizdir. NULL değerini eksiltmenin bir etkisi yoktur fakat arttırmanın sonucu 1'dir.

Arttırım ve Eksiltim İşleçleri
Örnek | İsim | Etkisi
++$a | Önceden arttırım | $a bir arttırıldıktan sonra döndürülür.
$a++ | Sonradan arttırım | $a döndürüldükten sonra değeri bir arttırılır.
--$a | Önceden eksiltim | $a bir eksiltildikten sonra döndürülür.
$a-- | Sonradan eksiltim | $a döndürüldükten sonra değeri bir eksiltilir.

Basit bir betik örneği:

<?php
echo "<h3>Sonradan arttırım</h3>\n";
$a = 5;
echo "5 olmalı: " . $a++ . "<br />\n";
echo "6 olmalı: " . $a . "<br />\n";

echo "<h3>Önceden arttırım</h3>\n";
$a = 5;
echo "6 olmalı: " . ++$a . "<br />\n";
echo "6 olmalı: " . $a . "<br />\n";

echo "<h3>Sonradan eksiltim</h3>\n";
$a = 5;
echo "5 olmalı: " . $a-- . "<br />\n";
echo "4 olmalı: " . $a . "<br />\n";

echo "<h3>Önceden eksiltim</h3>\n";
$a = 5;
echo "4 olmalı: " . --$a . "<br />\n";
echo "4 olmalı: " . $a . "<br />\n";
?>

PHP, karakter değişkenleri üzerinde çalışırken C'nin değil Perl'in yöntemlerini izler. Örneğin, Perl'de 'Z'+1 ifadesi 'AA' değerini döndürürken, C'de '[' döner ( ord('Z') == 90, ord('[') == 91 ). Karakterlerin arttırılabileceğini fakat azaltılamayacağını ve sadece ASCII harflerin (a-z ve A-Z) desteklendiğine dikkat ediniz.

Örnek 1 - Karakter değişkenleri üzerinde aritmetik işlemler

<?php
$i = 'W';
for ($n=0; $n<6; $n++) {
    echo ++$i . "\n";
}
?>

Yukarıdaki örneğin çıktısı:

X
Y
Z
AA
AB
AC

Mantıksal değerlere arttırım ve eksiltim uygulamanın bir etkisi olmaz.

Çalıştırma İşleci
Mantıksal İşleçler
İşleçler


Mantıksal İşleçler

Mantıksal İşleçler
Örnek | İsim | Sonuç
$a and $b | Ve | $a ve $b her ikisi de doğruysa sonuç doğrudur (TRUE).
$a or $b | Veya | $a veya $b doğruysa sonuç doğrudur.
$a xor $b | Ayrıcalıklı Veya | $a veya $b doğruysa sonuç doğru, her ikiside doğruysa sonuç yanlıştır (FALSE).
! $a | Değil | $a doğru değilse sonuç doğrudur.
$a && $b | Ve | $a ve $b her ikisi de doğruysa sonuç doğrudur.
$a || $b | Veya | $a veya $b doğruysa sonuç doğrudur.

Ve, Veya işleçlerinin iki farklı türü olmasının sebebi önceliklerinin farklı oluşudur. (Bakınız: İşleç Önceliği.)

Örnek 1 - Örneklerle mantıksal işleçler

<?php
// --------------------
// Aşağıdaki ifadelerde ilk terim sonucu belirlediğinden ikinci
// terime hiç bakılmayacak, yani foo() işlevi hiç çağrılmayacaktır.
$a = (false && foo());
$b = (true  || foo());
$c = (false and foo());
$d = (true  or  foo());

// --------------------
// "||" işlecinin önceliği "or" işlecinden yüksektir.
// İfadenin sonucu $e'ye atanır (false || true)
// Tıpkı şöyle: ($e = (false || true))
$e = false || true;

// false sabiti $f'ye atanır ve true yoksayılır
// Tıpkı böyle: (($e = false) or true)
$f = false or true;

var_dump($e, $f);

// --------------------
// "&&" işlecinin önceliği "and" işlecinden yüksektir.
// İfadenin sonucu $g'ye atanır (true && false)
// Tıpkı böyle: ($g = (true && false))
$g = true && false;

// true sabiti $h'ya atanır ve false yoksayılır
// Tıpkı böyle: (($h = true) and false)
$h = true and false;

var_dump($g, $h);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(true)
bool(false)
bool(false)
bool(true)
Arttırım ve Eksiltim İşleçleri
Dizge İşleçleri
İşleçler


Dizge İşleçleri

İki tane dizge işleci vardır. İlki sol ve sağ terimlerini ard arda ekleyen birleştirme işleci ('.'), ikincisi ise sağ taraftaki değiştirgeyi sol taraftaki değiştirgeye ekleyen birleştirerek atama işlecidir (.=). Daha fazla bilgi için atama işleçleri bölümüne bakınız.

<?php
$a = "Merhaba ";
$b = $a . "Dünyalı!"; // $b artık "Merhaba Dünyalı!" içeriyor

$a = "Merhaba ";
$a .= "Dünyalı!";     // $a artık "Merhaba Dünyalı!" içeriyor
?>

Ayrıca, string türünün açıklamasına ve Dizge İşlevleri bölümüne bakınız.

Mantıksal İşleçler
Dizi İşleçleri
İşleçler


Dizi İşleçleri

Dizi İşleçleri
Örnek | İsim | Sonuç
$a + $b | Birleşim | $a ve $b'nin birleşimi.
$a == $b | Eşitlik | $a ve $b aynı anahtar/değer çiftlerine sahipse sonuç doğrudur.
$a === $b | Aynılık | $a ve $b aynı anahtar/değer çiftlerine sahipse ve bunların sırası ve türleri aynıysa sonuç doğrudur.
$a != $b | Eşitsizlik | $a ve $b birbirine eşit değilse sonuç doğrudur.
$a <> $b | Eşitsizlik | $a ve $b birbirine eşit değilse sonuç doğrudur.
$a !== $b | Farklılık | $a ve $b aynı dizi değilse sonuç doğrudur.

+ işleci sağ taraftaki dizinin elemanlarını sol taraftaki dizinin elemanlarının arasına ekler. Bunu yaparken anahtarları aynı olan elemanların üzerine yazılmaz.

<?php
$a = array("a" => "elma", "b" => "armut");
$b = array("a" => "vişne", "b" => "kiraz", "c" => "çilek");

$c = $a + $b;
echo "\$a ve \$b'nin birleşimi: \n";
var_dump($c);

$c = $b + $a;
echo "\$b ve \$a'nın birleşimi: \n";
var_dump($c);
?>
Betik çalıştırıldığında şu çıktıyı verir:
$a ve $b'nin birleşimi:
array(3) {
  ["a"]=>
  string(4) "elma"
  ["b"]=>
  string(5) "armut"
  ["c"]=>
  string(6) "çilek"
}
$b ve $a'nın birleşimi:
array(3) {
  ["a"]=>
  string(6) "vişne"
  ["b"]=>
  string(5) "kiraz"
  ["c"]=>
  string(6) "çilek"
}

Aynı anahtar ve değere sahip dizi elemanları birbirine eşit kabul edilir.

Örnek 1 - Dizilerin karşılaştırılması

<?php
$a = array("elma", "armut");
$b = array(1 => "armut", "0" => "elma");

var_dump($a == $b); // bool(true)
var_dump($a === $b); // bool(false)
?>

Ayrıca, array türünün açıklamasına ve Dizi İşlevleri bölümüne de bakınız.

Dizge İşleçleri
Tür İşleçleri
İşleçler


Tür İşleçleri

instanceof işleci, bir PHP değişkeninin belli bir sınıfın nesnel örneği olup olmadığını saptar:

Örnek 1 - instanceof ve sınıflar

<?php
class Sınıfım
{
}

class BaşkaSınıf
{
}
$a = new Sınıfım;

var_dump($a instanceof Sınıfım);
var_dump($a instanceof BaşkaSınıf);
?>

Yukarıdaki örneğin çıktısı:

bool(true)
bool(false)

instanceof ayrıca, bir değişkenin, bir ebeveyn sınıftan miras alınan bir sınıfın nesnel örneği olup olmadığını saptamak için de kullanılabilir:

Örnek 2 - Miras alınan sınıflar ve instanceof kullanımı

<?php
class EbeveynSınıf
{
}

class Sınıfım extends EbeveynSınıf
{
}

$a = new Sınıfım;

var_dump($a instanceof Sınıfım);
var_dump($a instanceof EbeveynSınıf);
?>

Yukarıdaki örneğin çıktısı:

bool(true)
bool(true)

Bir nesne bir sınıfın örneği değilse bunu sınamak için mantıksal değil işleci kullanılabilir.

Örnek 3 - Bir sınıfın örneği olmayan bir sınıfın instanceof ile sınanması

<?php
class Sınıfım
{
}

$a = new Sınıfım;
var_dump(!($a instanceof stdClass));
?>

Yukarıdaki örneğin çıktısı:

bool(true)

Son olarak, instanceof işleci, bir değişkenin, bir arayüzü gerçekleyen bir sınıfın örneği olup olmadığını sınamak için kullanılabilir:

Örnek 4 - Arayüzler için instanceof kullanımı

<?php
interface Arayüzüm
{
}

class Sınıfım implements Arayüzüm
{
}

$a = new Sınıfım;

var_dump($a instanceof Sınıfım);
var_dump($a instanceof Arayüzüm);
?>

Yukarıdaki örneğin çıktısı:

bool(true)
bool(true)

instanceof işlecinin normal olarak bir sayıl sınıf ismi ile kullanılmasının yanında başka bir nesne veya bir dizge değişkeni ile de kullanılabilir:

Örnek 5 - Başka değişkenlerle instanceof kullanımı

<?php
interface Arayüzüm
{
}

class Sınıfım implements Arayüzüm
{
}

$a = new Sınıfım;
$b = new Sınıfım;
$c = 'Sınıfım';
$d = 'BaşkaSınıf';

var_dump($a instanceof $b); // $b, Sınıfım sınıfının bir nesnesidir
var_dump($a instanceof $c); // $c 'Sınıfım' dizgesini içerir
var_dump($a instanceof $d); // $d 'BaşkaSınıf' dizgesini içerir
?>

Yukarıdaki örneğin çıktısı:

bool(true)
bool(true)
bool(false)

Burada bilmeniz gereken bir kaç zorluk vardır. PHP 5.1.0 öncesinde, instanceof işleci, sınıf mevcut değilse __autoload() çağrısı yapardı. Buna ek olarak, sınıf yüklenmemişse bir ölümcül hata oluşurdu. Bunun olmaması için bir devingen sınıf gönderimi veya sınıf ismini içeren bir dizge değişkeni kullanılabilir:

Örnek 6 - PHP 5.0'da instanceof ile ölümcül hatalardan ve sınıf ismi aramalarından kaçınmak

<?php
$d = 'BaşkaSınıf';
var_dump($a instanceof $d); // burada ölümcül hata oluşmaz
?>

Yukarıdaki örneğin çıktısı:

bool(false)

instanceof işleci PHP 5'ten itibaren mevcuttur. Evvelce is_a() işlevi kullanılırdı fakat instanceof kullanımını teşvik etmek için is_a() kullanımı önerilmemekteyse de PHP 5.3.0'dan itibaren bundan vazgeçilmiştir.

Ayrıca, get_class() ve is_a() işlevlerine de bakınız.

Dizi İşleçleri
Denetim Yapıları
İşleçler


Denetim Yapıları

İçindekiler

  • Giriş
  • if
  • else
  • elseif/else if
  • Denetim yapıları için diğer sözdizimi
  • while
  • do-while
  • for
  • foreach
  • break
  • continue
  • switch
  • declare
  • return
  • require
  • include
  • require_once
  • include_once
  • goto
Tür İşleçleri
Giriş
Dil Başvuru Kılavuzu


Giriş

Bütün PHP betikleri bir dizi deyimden oluşur. Bir deyim; bir atama, bir işlev çağrısı, bir döngü, bir koşullu deyim hatta hiçbir şey yapmayan bir deyim (boş bir deyim) olabilir. Deyimler bir noktalı virgülle sonlandırılır. Ek olarak, deyimler kaşlı ayraçlar içine alınarak deyim grupları haline getirilebilirler. Bir deyim grubu da kendi başına bir deyim olarak kabul edilir. Bu fasılda deyim türlerinden bahsedeğiz.

Denetim Yapıları
if
Denetim Yapıları


if

if oluşumu, PHP dahil olmak üzere birçok programlama dilindeki en önemli yapı taşlarından biri olup kod bölümlerinin koşullu olarak çalıştırılabilmelerini sağlar. PHP, C dilindekine benzer bir if yapısı sunar:

if (ifade)
    deyim

İfadelerle ilgili bölümde de anlatıldığı gibi, ifade kendi mantıksal değeri üzerinden değerlendirilir. ifade'nin sonucu TRUE ise, PHP deyim'i çalıştırır, FALSE ise gözardı eder. Hangi değerlerin FALSE olarak değerlendirildiği hakkında daha fazla bilgiyi boolean türüne dönüşüm bölümünde bulabilirsiniz.

Aşağıdaki örnek, $a değeri $b değerinden büyük olduğu takdirde a büyüktür b metnini görüntüleyecektir:

<?php
if ($a > $b)
    echo "a büyüktür b";
?>

Çoğunlukla birden çok deyimin koşullu olarak çalıştırılmasını isteyeceksiniz. Elbette, her deyimi ayrı ayrı if cümlecikleri içine almanıza gerek yoktur. Birden çok deyimi tek bir deyim grubu içine toplayabilirsiniz. Örneğin, aşağıdaki kod $a değeri $b değerinden büyük olduğu takdirde a büyüktür b metnini görüntüleyecektir ve sonrasında $a değişkeninin değerini $b değişkenine atayacaktır:

<?php
if ($a > $b) {
    echo "a büyüktür b";
  $b = $a;
}
?>

Sonsuz sayıda if deyimi bir başka if deyiminin içine gömülebilir. Bu, uygulamanızın çeşitli bölümlerine koşullu deyimler uygulayabilmeniz için tam bir esneklik sağlar.

Giriş
else
Denetim Yapıları


else

Çoğu zaman belli bir koşul sağlandığında bir deyimin, o koşul sağlanmadığında başka bir deyimin çalıştırılmasını isteyeceksiniz. Bunun için else kullanılmaktadır. Else, bir if deyimini FALSE döndürdüğü takdirde bir deyim çalıştırmak üzere genişletir. Örneğin, aşağıdaki kod $a değeri $b değerinden büyükse a büyüktür b, büyük değilse a büyük değildir b iletisini görüntüleyecektir:

<?php
if ($a > $b) {
    echo "a büyüktür b";
} else {
    echo "a büyük değildir b";
}
?>
Else deyimi yalnızca if deyiminin FALSE döndürdüğü durumda çalıştırılacaktır. Aynı durum, FALSE döndüren herhangi bir elseif ifadesinin olması durumunda da geçerlidir (bakınız elseif).

if
elseif/else if
Denetim Yapıları


elseif/else if

elseif, isminden de anlaşılacağı gibi, if ve else deyimlerinin biraraya gelmesiyle oluşur. else gibi, orijinal if ifadesinin FALSE döndürdüğü durumda farklı bir deyimin çalıştırılması için kullanılır. Ancak, else'ten farklı olarak, ilgili deyimi sadece kendisine ait koşullu ifade TRUE değerini döndürdüğü takdirde çalıştıracaktır. Örneğin, aşağıdaki kod a büyüktür b, a eşittir b ya da a küçüktür b iletisini görüntüleyecektir:

<?php
if ($a > $b) {
    echo "a büyüktür b";
} elseif ($a == $b) {
    echo "a eşittir b";
} else {
    echo "a küçüktür b";
}
?>

Aynı if deyimine ait birden çok elseif bulunabilir. İlk önce hangi elseif deyimi TRUE değerini döndürürse (eğer döndüren varsa) o deyim çalıştırılır. Bu deyimi 'elseif' biçiminde tek sözcük olarak kullanabileceğiniz gibi, 'else if' biçiminde iki sözcük olarak da kullanabilirsiniz, sonuç aynı olacaktır. Sözdiziminin anlamlandırılması açısından küçük bir farklılık olsa da (C diline aşinaysanız, onda da böyledir) sonuç olarak her ikisi de aynı sonucu üretecektir.

elseif ifadesi yalnızca kendisinden önceki if ifadesi ve bu ifadeye bağlı kendisinden önce gelen diğer tüm elseif ifadeleri FALSE ile sonuçlandığında çalıştırılır ve TRUE olarak değerlendirilir.

Bilginize: elseif ve else if, yukarıdaki örnekten anlaşılacağı üzere sadece kaşlı ayraçlar kullanıldığı zaman tamamen aynı şekilde ele alınacaktır. if ve elseif için iki noktalı sözdizimi kullanıldığında elseif'i iki sözcüğe ayırmamanız gerekir, yoksa PHP bir çözümleme hatası vererek başarısız olur.

<?php

/* Yanlış Yöntem: */
if($a > $b):
    echo $a." büyüktür ".$b;
else if($a == $b): // Bu derlenmez.
    echo "Üstteki satır bir çözümleme hatasına yol açar.";
endif;

/* Doğru Yöntem: */
if($a > $b):
    echo $a." büyüktür ".$b;
elseif($a == $b): // Sözcüklerin birleşik oluşuna dikkat!
    echo $a." eşittir ".$b;
else:
    echo $a." ne büyük ne de eşittir ".$b;
endif;

?>

else
Denetim yapıları için diğer sözdizimi
Denetim Yapıları


Denetim yapıları için diğer sözdizimi

PHP bazı denetim yapıları için farklı bir sözdizimi sağlar. Bu yapılar if, while, for, foreach ve switch yapılarıdır. Her durumda, bu farklı sözdiziminin basit şekli açılışta kullanılan kaşlı ayracın yerine iki nokta imi (:) ve kapanışta kullanılan kaşlı ayraç yerine de sırasıyla endif;, endwhile;, endfor;, endforeach; ya da endswitch; deyimlerinden birini kullanmaktır.

<?php if ($a == 5): ?>
A eşittir 5
<?php endif; ?>

Yukarıdaki örnekte, içeriği "A eşittir 5" olan HTML bloğu iki noktalı sözdimi kullanılarak yazılmış bir if deyiminin içine gömülmüştür. HTML bloğu yalnızca $a değişkeni 5'e eşit olduğunda gösterilecektir.

İki noktalı sözdimi, else ve elseif için de kullanılabilir. Birazdan vereceğimiz örnek, iki noktalı sözdizimi ile yazılmış elseif ve else içeren bir if yapısıdır:

<?php
if ($a == 5):
    echo "a eşittir 5";
    echo "...";
elseif ($a == 6):
    echo "a eşittir 6";
    echo "!!!";
else:
    echo "a ne 5 ne de 6'dır";
endif;
?>

Bilginize:

Aynı denetim kümesi içinde karışık sözdizimi desteklenmemektedir.

Daha fazla örnek için while, for ve if cümleciklerine bakabilirsiniz.

elseif/else if
while
Denetim Yapıları


while

while döngüsü PHP'de yer alan en basit döngü türüdür. C'deki karşılığı ile aynı şekilde çalışır. Bir while deyiminin basit kullanımı:

while (ifade)
    deyim

While deyiminin anlamı basittir. while deyimindeki ifade TRUE olduğu müddetçe etki alanındaki deyimleri PHP tekrar tekrar çalıştırır. İfadenin değeri döngünün her yinelenişinde yeniden değerlendirilir, deyimlerin çalıştırılması sırasında bu ifadenin değeri FALSE olsa bile, etki alanındaki deyimlerin tamamı çalıştırılıncaya kadar işlem devam eder. (PHP döngü içindeki deyimleri her yinelemede bir kere çalıştırır.) Bazen, while ifadesi daha başlangıçta FALSE değerini verir, bu durumda while etki alanındaki deyimler tek bir defa bile çalıştırılmazlar.

if deyiminde olduğu gibi, birden çok deyimi aynı while döngüsü içinde kaşlı ayraçlar arasında veya iki noktalı sözdizimini kullanarak gruplayabilirsiniz:

while (ifade):
    deyimler
    ...
endwhile;

Aşağıdaki örnekler birbirleri ile aynıdırlar, her ikisi de sayıları 1'den 10'a kadar yazacaktır:

<?php
/* örnek 1 */

$i = 1;
while ($i <= 10) {
    echo $i++;  /* yazdırılan değer $i
                    değerinin artıştan önceki
                    değeridir (sonda-arttırım) */
}

/* örnek 2 */

$i = 1;
while ($i <= 10):
    echo $i;
    $i++;
endwhile;
?>

Denetim yapıları için diğer sözdizimi
do-while
Denetim Yapıları


do-while

do-while döngüsü, while döngüsüne çok benzer; farkı, doğrulama ifadesinin her yinelemenin başında değil sonunda değerlendiriliyor olmasıdır. while döngüsü ile temek farklılık, do-while kullanıldığında ilk yinelemenin daima yapılıyor olmasıdır (ifadenin doğruluğuna yalnızca yinelemenin sonunda bakılır); halbuki while döngüsünde, ifadenin doğruluğuna her yinelemenin öncesinde bakılmakta ve ifadenin sonucu doğru değilse yineleme hiç başlatılmadan döngü sonlandırılmaktadır.

do-while döngüsü için yalnızca tek bir sözdizimi mevcuttur:

<?php
$i = 0;
do {
    echo $i;
} while ($i > 0);
?>

Yukarıdaki döngü tam olarak bir defa çalışacaktır, ilk tekrardan sonra ifadenin doğruluğuna bakıldığında FALSE değerini verecek ($i sıfırdan büyük değildir) ve döngünün çalışması sonlanacaktır.

<?php
do {
    if ($i < 5) {
        echo "i yeterince büyük değil";
        break;
    }
    $i *= $çarpan;
    if ($i < $alt_sınır) {
        break;
    }
   echo "i uygun";

    /* i değerini işle */

} while (0);
?>

Burada neler olup bittiğini anlamadıysanız endişelenmeyin. Bu 'özelliği' kullanmadan da oldukça gelişmiş ve güçlü uygulamalar geliştirebilirsiniz. PHP 5.3.0'dan beri bu özelliğin yerine goto kullanılabilmektedir.

while
for
Denetim Yapıları


for

for döngüsü, PHP'deki en karmaşık döngü yapısıdır. C'deki karşılığıyla aynı biçimde çalışır. for döngüsünün sözdimi:

for (ifade1; ifade2; ifade3)
    deyim

İlk ifade (ifade1) döngünün en başında bir kereliğine koşulsuz olarak çalıştırılır.

Her yinelemenin başında ifade2 yeniden değerlendirilir. Bu ifadeden TRUE sonucu elde edilirse, döngüye devam edilir ve döngünün etki alanındaki deyimler çalıştırılır. Bu ifadeden FALSE sonucu elde edildiğinde etki alanındaki deyimler çalıştırılmaksızın döngü sonlandırılır.

ifade3 ise her yinelemenin sonunda çalıştırılır.

Bu ifadelerin herbirini boş bırakmak da mümkündür. ifade2nin boş olması, döngünün sonsuza kadar çalıştırılacağı anlamına gelir (PHP, C'deki gibi bu durumu TRUE olarak değerlendirir). Döngülerden genellikle bir şarta bağlı olarak break deyimi ile çıkmak isteyeceğiniz düşünüldüğünde, bu durum düşündüğünüz kadar kullanışsız değildir.

Aşağıdaki örnekleri ele alalım. Hepsi de 1'den 10'a kadar sayıları görüntülemektedir:

<?php
/* örnek 1 */

for ($i = 1; $i <= 10; $i++) {
    echo $i;
}

/* örnek 2 */

for ($i = 1; ; $i++) {
    if ($i > 10) {
        break;
    }
    echo $i;
}

/* örnek 3 */

$i = 1;
for (; ; ) {
    if ($i > 10) {
        break;
    }
    echo $i;
    $i++;
}

/* örnek 4 */

for ($i = 1, $j = 0; $i <= 10; $j += $i, print $i, $i++);
?>

Elbette, kullandığımız ilk örnek en güzel örnek olarak gözükmektedir (ya da belki dördüncü örnek), ancak birçok durumda for döngüsü içerisinde boş ifadeler kullanmayı oldukça kullanışlı bulabilirsiniz.

PHP, iki noktalı sözdizimini for döngüleri için de desteklemektedir.

for (ifade1; ifade2; ifade3):
    deyimler
    ...
endfor;

Çoğu kullanıcının yaptığı gibi diziler üzerindeki yinelemeleri şöyle yapabilirsiniz:

<?php
/*
 * Diziye baştan bir kaç veri atıp daha sonra
 * döngü içinde verilerde değişiklik yapacağız.
 */
$bizimkiler = Array(
        Array('isim' => 'Ali', 'tuz' => 856412),
        Array('isim' => 'Veli', 'tuz' => 215863)
        );

for($i = 0; $i < sizeof($bizimkiler); ++$i)
{
    $bizimkiler[$i]['tuz'] = rand(000000, 999999);
}
?>

Sorun ikinci ifadede gizlidir. Her yinelemede dizinin boyutları yeniden hesaplandığından kod yavaş çalışabilir. Örnekte boyut değişmediğinden dizi boyutunu önce bir değişkene atıp ifadede bu değişken kullanılarak kod en iyilenebilir. Aşağıdaki bunun yapılışı örneklenmiştir:

<?php
$bizimkiler = Array(
        Array('isim' => 'Ali', 'tuz' => 856412),
        Array('isim' => 'Veli', 'tuz' => 215863)
        );

for($i = 0, $size = sizeof($bizimkiler); $i < $size; ++$i)
{
    $bizimkiler[$i]['salt'] = rand(000000, 999999);
}
?>

do-while
foreach
Denetim Yapıları


foreach

(PHP 4, PHP 5, PHP 7)

foreach yapısı diziler üzerinde yineleme yapmayı kolaylaştırmaktadır. foreach yalnızca diziler ve nesneler için kullanılabilir; farklı veri türünde veya ilklendirilmemiş bir değişken ile kullanmak istediğinizde hata verir. İki sözdizimi mevcuttur:

foreach (dizi_ifadesi as $değer)
    deyim
foreach (dizi_ifadesi as $isim => $değer)
    deyim

İlk sözdizimi dizi_ifadesi ile belirtilen dizinin üzerinde döngü oluşturur. Her yinelemede, sırası gelen elemanın değeri $değer değişkenine atanır ve dizi göstericisi bir arttırılır (böylece bir sonraki yinelemede dizinin bir sonraki elemanına bakılması sağlanmış olur).

İkinci yöntem de aynı şeyi yapar, ek olarak her yinelemede sırası gelen elemanın anahtarı $isim değişkenine atanır.

PHP 5'den itibaren, nesneleri yinelemek mümkün olmuştur.

Bilginize:

foreach ilk çalışmaya başladığında, dizi göstericisi özdevinimli olarak ilk elemanı gösterecek biçimde sıfırlanır. Bu sebeple, foreach deyiminden önce reset() işlevini çalıştırmanıza gerek yoktur.

foreach dahili bir dizi göstericisi ile çalışması nedeniyle bunun döngü içinde değiştirilmesi beklenmedik sonuçlara yol açabilir.

$değer değişkeninin önüne & koyarak dizi elemanları üzerinde kolayca değişiklik yapılabilir. Böylece değer gönderimli hale gelir.

<?php
$dizi = array(1, 2, 3, 4);
foreach ($dizi as &$değer) {
    $değer = $değer * 2;
}
// $dizi artık array(2, 4, 6, 8) olmuştur
unset($değer); // son eleman da işlendiğine göre gönderimi kaldıralım
?>

$değer değişkeninin gönderimli hale getirilebilmesi, sadece yinelenen dizi gönderimli (örn, bir değişkene) olabiliyorsa mümkündür, yani aşağıdaki kod çalışmaz:

<?php
foreach (array(1, 2, 3, 4) as &$value) {
    $value = $value * 2;
}
?>

Uyarı

$değer gönderim için kullanıldığından foreach döngüsünün sonunda son dizi elemanına gönderimli olarak kalır, bu bakımdan döngünün sonunda bu gönderimin unset() işlevi kullanılarak kaldırılması önerilir.

Bilginize:

foreach, hata iletilerinin '@' kullanılarak gözardı edilmesi özelliğini desteklemez.

Aşağıdaki iki döngünün aynı işi yaptığını farkedeceksiniz:

<?php
$dizi = array("bir", "iki", "üç");
reset($dizi);
while (list(, $değer) = each($dizi)) {
    echo "Değer: $değer<br />\n";
}

foreach ($dizi as $değer) {
    echo "Değer: $değer<br />\n";
}
?>

Aşağıdakiler de işlevsel olarak aynıdır:

<?php
$dizi = array("bir", "iki", "üç");
reset($dizi);
while (list($isim, $değer) = each($dizi)) {
    echo "Anahtar: $isim; Değer: $değer<br />\n";
}

foreach ($dizi as $isim => $değer) {
    echo "Anahtar: $isim; Değer: $değer<br />\n";
}
?>

Değişik kullanımlara örnekler:

<?php
/* foreach örneği 1: yalnızca değer */

$a = array(1, 2, 3, 17);

foreach ($a as $v) {
   echo "\$a değişkeninin şu anki değeri: $v.\n";
}

/* foreach örneği 2: değer (örnek olması için anahtar
 *  ile birlikte yazdırılmıştır) */

$a = array(1, 2, 3, 17);

$i = 0; /* yalnızca örnekleme için */

foreach ($a as $v) {
    echo "\$a[$i] => $v.\n";
    $i++;
}

/* foreach örneği 3: anahtar ve değer */

$a = array(
    "bir" => 1,
    "iki" => 2,
    "üç"  => 3,
    "on yedi" => 17
);

foreach ($a as $k => $v) {
    echo "\$a[$k] => $v.\n";
}

/* foreach örneği 4: çok boyutlu diziler */
$a = array();
$a[0][0] = "a";
$a[0][1] = "b";
$a[1][0] = "y";
$a[1][1] = "z";

foreach ($a as $v1) {
    foreach ($v1 as $v2) {
        echo "$v2\n";
    }
}

/* foreach örneği 5: devingen diziler */

foreach (array(1, 2, 3, 4, 5) as $v) {
    echo "$v\n";
}
?>

İç içe dizilerin list() ile ayrıştırılması

(PHP 5 >= 5.5.0, PHP 7)

PHP 5.5 ile yeni bir yetenek eklendi. Dizi dizileri üzerinde döngü oluşturmak ve list() işlevini değer olarak kullanmak suretiyle içteki diziyi döngü değişkenlerine atayarak onu da açmak artık mümkündür.

Örneğin:

<?php
$dizi = [
    [1, 2],
    [3, 4],
];

foreach ($dizi as list($a, $b)) {
    // $a içteki dizinin ilk elemanını,
    // $b ikinci elemanını içerecektir.
    echo "A: $a; B: $b\n";
}
?>

Yukarıdaki örneğin çıktısı:

A: 1; B: 2
A: 3; B: 4

İçteki dizinin gerekmeyen elemanlarını list() içinde içermeyebilirsiniz:

<?php
$dizi = [
    [1, 2],
    [3, 4],
];

foreach ($dizi as list($a)) {
    // Burada artık $b yok.
    echo "$a\n";
}
?>

Yukarıdaki örneğin çıktısı:

1
3

list() için yeterli sayıda dizi elemanı yoksa bir uyarı üretilir.:

<?php
$dizi = [
    [1, 2],
    [3, 4],
];

foreach ($dizi as list($a, $b, $c)) {
    echo "A: $a; B: $b; C: $c\n";
}
?>

Yukarıdaki örneğin çıktısı:

Notice: Undefined offset: 2 in example.php on line 7
A: 1; B: 2; C:

Notice: Undefined offset: 2 in example.php on line 7
A: 3; B: 4; C:

for
break
Denetim Yapıları


break

break deyimi, for, foreach, while, do-while ve switch yapılarının çalışmasını sonlandırmak için kullanılır.

break deyiminde istenirse bir sayısal ifade belirtilebilir. Bu sayı iç içe yapılardan içten dışa kaç yapının aynı anda durdurulacağını belirler.

<?php
$arr = array('sıfır', 'bir', 'iki', 'üç', 'dur', 'dört', 'beş');
while (list(, $val) = each($arr)) {
    if ($val == 'dur') {
        break;    /* Burada 'break 1;' de yazabilirsiniz. */
    }
    echo "$val<br />\n";
}

/* Sayısal değer kullanımı. */

$i = 0;
while (++$i) {
    switch ($i) {
    case 5:
        echo "5'de<br />\n";
        break 1;  /* Yalnızca switch'ten çıkar. */
    case 10:
        echo "10'da; çıkılıyor<br />\n";
        break 2;  /* switch ve while'dan aynı anda çıkılır. */
    default:
        break;
    }
}
?>

foreach
continue
Denetim Yapıları


continue

continue deyimi döngü yapılarının içinde kullanılır. Bu deyim kullanıldığında, döngünün kalan kısmı atlanır ve sonraki yineleme başlatılır.

Bilginize: PHP'de switch deyimi continue deyiminin kullanılabileceği döngülerden biri olarak kabul edilmektedir.

continue deyimi ile seçime bağlı sayısal bir değer kullanılarak, atlama işleminin kaç seviye üstteki döngüye kadar uygulanacağı belirtilebilir.

Bilginize:

continue 0; ve continue 1; continue; deyimi ile aynıdır.

<?php
while (list($key, $value) = each($arr)) {
    if (!($key % 2)) { // tek sayıları atla
        continue;
    }
    do_something_odd($value);
}

$i = 0;
while ($i++ < 5) {
    echo "Dış<br />\n";
    while (1) {
        echo "&nbsp;&nbsp;Orta<br />\n";
        while (1) {
            echo "&nbsp;&nbsp;İç<br />\n";
            continue 3;
        }
        echo "Bu hiçbir zaman çıktı vermez.<br />\n";
    }
    echo "Bundan da çıktı alamazsınız.<br />\n";
}
?>

continue deyiminden sonra noktalı virgül konmazsa bu durum karışıklığa yol açabilir. Yapmamanız gereken ile ilgili bir örnek:

<?php
for ($i = 0; $i < 5; ++$i) {
    if ($i == 2)
        continue
    print "$i\n";
}
?>

Şu biçimde bir çıktı almayı bekleyebilirsiniz:

0
1
3
4

Ancak çıktı şu şekilde olacaktır:

2

Bunun sebebi print işlevinden dönen değerin int(1) olması ve bu dönen değerin PHP tarafından yukarıda bahsedilen seçime sağlı sayısal değer olarak algılanmasıdır.

break
switch
Denetim Yapıları


switch

switch deyimi, aynı ifade içersinde yer alan bir dizi IF deyimine benzer. Birçok durumda, aynı değişkeni (ya da ifadeyi) birden çok değerle karşılaştırmak ve her karşılaştırmanın sonucunu ayrı bir kod parçası çalıştırarak değerlendirmek istersiniz. İşte bu, switch deyiminin varlık sebebidir.

Bilginize: Başka bazı dillerden farklı olarak, continue deyimi switch ile uygulanabilir ve break ile benzerlik gösterir. Bir döngü içerisinde switch kullandıysanız ve kodun yürütülmesine dıştaki döngünün sonraki yinelemeden devam etmesini istiyorsanız, continue 2 kullanabilirsiniz.

Bilginize:

switch ve case gevşek karşılaştırma yapar.

Aşağıdaki iki örnek aynı şeyi yazmanın iki farklı yolunu göstermektedir. Birincisi bir dizi if ve elseif deyiminin kullanımını, ikincisi ise switch deyiminin kullanımını örneklemektedir:

Örnek 1 - switch yapısı

<?php
if ($i == 0) {
    echo "i eşittir 0";
} elseif ($i == 1) {
    echo "i eşittir 1";
} elseif ($i == 2) {
    echo "i eşittir 2";
}

switch ($i) {
case 0:
    echo "i eşittir 0";
    break;
case 1:
    echo "i eşittir 1";
    break;
case 2:
    echo "i eşittir 2";
    break;
}
?>

Örnek 2 - switch ile dizge kullanımı

<?php
switch ($i) {
case "elma":
    echo "i bir elmadır";
    break;
case "çikolata":
    echo "i bir çikolatadır";
    break;
case "kek":
    echo "i bir kektir";
    break;
}
?>

Hatalardan kaçınmak için switch deyiminin nasıl çalıştığını anlamak önemlidir. switch deyimi satır satır ele alınır (aslında deyim deyim). Başlangıçta, hiçbir kod çalıştırılmaz. Yalnızca switch ifadesiyle birlikte verilen değer ile uyuşan case deyimi bulunduğunda PHP ilgili deyimleri çalıştırmaya başlar. PHP switch bloğu sonlanana kadar ya da ilk break deyimi ile karşılaşıncaya kadar çalışmasına devam eder. Bir case bloğunun sonuna break koymazsanız, PHP sonraki case deyiminden kodları çalıştırmaya devam eder. Örnek:

<?php
switch ($i) {
case 0:
    echo "i eşittir 0";
case 1:
    echo "i eşittir 1";
case 2:
    echo "i eşittir 2";
}
?>

Burada, $i 0'a eşit ise, PHP tüm echo deyimlerini çalıştıracaktır! $i 1'e eşit ise, PHP son iki echo deyimini çalıştıracaktır! Beklediğiniz sonucu ('i eşittir 2' metninin görüntülenmesi) yalnızca $i 2'ye eşitse almanız mümkün olacaktır. Bu durumun oluşmaması için, break deyimini kullanmayı unutmamanız önemlidir (yine de, bazı durumlarda break deyimini kullanmak istemeyebilirsiniz).

Bir switch deyiminde, koşul yalnızca bir defa sorgulanır ve sonuç her bir case deyimi ile karşılaştırılır. Bir elseif deyiminde ise, koşul tekrar sorgulanır. Kullanmak istediğiniz koşul basit bir karşılaştırma işleminden daha karmaşıksa ve/veya bir döngü içerisindeyse, switch kullanmak daha hızlı olabilir.

case bloğu kod içermeyebilir ve amacı yalnızca denetimi bir sonraki case bloğuna geçirmek olabilir.

<?php
switch ($i) {
case 0:
case 1:
case 2:
    echo "i 3'ten küçüktür ama negatif değildir";
    break;
case 3:
    echo "i eşittir 3";
}
?>

default durumu özel bir durumdur. Bu durum diğer hiçbir case ile uyuşmayan değerler için kullanılır ve en sonda yer almalıdır. Örneğin:

<?php
switch ($i) {
case 0:
    echo "i eşittir 0";
    break;
case 1:
    echo "i eşittir 1";
    break;
case 2:
    echo "i eşittir 2";
    break;
default:
    echo "i ne 0, ne 1 ne de 2'ye eşittir";
}
?>

case ifadesi bir basit tür olarak değerlendirilebilecek herhangi bir tür olabilir; yani, tam sayı (integer), gerçel sayı (float) veya dizge (string) olabilir. Diziler (array) ya da nesneler (object), bir basit türe indirgenmedikleri sürece kullanılamazlar.

İki noktalı sözdizimi switch deyimi için de desteklenmektedir. Daha fazla bilgi için, Denetim yapıları için diğer söz dizimi bölümünü inceleyebilirsiniz.

<?php
switch ($i):
case 0:
    echo "i eşittir 0";
    break;
case 1:
    echo "i eşittir 1";
    break;
case 2:
    echo "i eşittir 2";
    break;
default:
    echo "i ne 0, ne 1 ne de 2'ye eşittir;
endswitch;
?>

case'ten sonraki iki nokta yerine aşağıdaki gibi deyim sonunda noktalı virgül kullanmak da mümkündür:

<?php
switch($içecek)
{
    case 'su';
    case 'süt';
    case 'ayran';
        echo 'İyi seçim';
    default;
        echo 'Lütfen yeniden seçiniz...';
    break;
}
?>

continue
declare
Denetim Yapıları


declare

declare yapısı bir kod bloğunun çalıştırılması esnasında uygulanacak yönergeleri belirlemek için kullanılır. declare yapısının sözdizimi diğer akış denetim yapılarının söz dizimi ile benzerdir:

declare (yönerge)
    deyim

yönerge bölümü, declare bloğunun davranışını belirlemek için kullanılır. Şimdilik yalnızca iki yönerge kullanılabilmektedir: ticks yönergesi (Daha fazla bilgi edinmek için aşağıya, ticks yönergesine bakınız.) ve encoding yönergesi.

Bilginize: encoding yönergesi PHP 5.3.0'da eklenmiştir.

declare bloğunun deyim bölümünün nasıl çalıştırılacağı ve çalışma esnasındaki yan etkilerinin ne olacağı yönerge bölümünde belirtilen yönergeye bağlı olabilir.

declare bloğu kendinden sonra gelen tüm kodu etkilemesi için genel betik kapsamında da kullanılabilir. Bununla birlikte, declare bloğu dahil edilen bir dosyanın içindeyse ebeveyn dosya bundan etkilenmez.

<?php
// aşağıdaki iki örnek aynıdır:

// bunu kullanabilirsiniz:
declare(ticks=1) {
    // betiğin tamamı burada
}

// ya da bunu kullanabilirsiniz:
declare(ticks=1);
    // betiğin tamamı burada
?>

Tikler

Bir "tik", declare bloğu içersinde çözümleyici tarafından çalıştırılan her N tiklenebilir deyimde bir ortaya çıkan bir olaydır. N değeri, declare bloğunun yönerge bölümünde ticks=N kullanılarak belirtilir.

Her deyim tik sayımına dahil edilebilir değildir. Koşullu ifadeler ve değiştirge ifadeleri bu tür deyimlerdendir.

Her tik ile oluşturulacak eylem register_tick_function() işlevi ile belirtilir. Daha ayrıntılı bilgi için aşağıdaki örneğe bakınız. Her tik için birden fazla olayın oluşabileceğini gözardı etmeyiniz.

Örnek 1 - Tik kullanım örneği 1

<?php

declare(ticks=1);

// Her tik deyimde bir çalıştırılacak işlev
function tik_eylemci()
{
    echo "tik_eylemci() çağrıldı\n" ;
}

// Tik eylemcisini belirtelim
register_tick_function("tik_eylemci");

$a = 1;

if ($a > 0) {
        $a += 2;
        print($a);
}
?>

Örnek 2 - Tik kullanım örneği 2

<?php

function tik_eylemci()
{
    echo "tik_eylemci() çağrıldı\n" ;
}

$a = 1;
tik_eylemci();

if ($a > 0) {
        $a += 2;
        tik_eylemci();
        print($a);
        tik_eylemci();
}
tik_eylemci();

?>

Ayrıca, register_tick_function() ve unregister_tick_function() işlevlerini de inceleyin.

encoding

Her betiğin karakter kodlaması betiğin başında encoding yönergesi ile belirtilebilir.

Örnek 3 - Betik için kodlama belirtmek

<?php
declare(encoding='ISO-8859-1');
// kodlar burada
?>

Dikkat

İsim alanları ile birlikte kullanıldığında, tek geçerli sözdizimi declare(encoding='...'); olup, buradaki ... kodlama değeridir. declare(encoding='...') {} sözdizimi isim alanları ile birlikte kullanıldığında bir çözümleme hatası ile sonuçlanacaktır.

Karakter kodlaması bildirim değeri, PHP, --enable-zend-multibyte yapılandırma seçeneği ile derlenmediği takdirde PHP 5.3'te yoksayılır. PHP 6.0'da --enable-zend-multibyte etkindir.

switch
return
Denetim Yapıları


return

Bir işlevin içinde kullanıldığında, return deyimi çalışmakta olan işlevi hemen sonlandırıp değiştirgesini çağrılan işlevin değeri olarak döndürür. return ayrıca, bir betiğin veya bir eval() deyiminin çalışmasını sonlandırmak için de kullanılabilir.

Betik genelinde çağrıldığında, betik dosyasının çalışmasını sonlandırılır. Eğer dosya include ya da require ile betik dosyasına dahil edilmiş bir dosya ise, return deyimi akış denetiminin ana dosyaya aktarılmasını sağlar. Dahası, return deyiminin çağrıldığı dosya include ile dahil edilmişse return değeri include çağrısının değeri olarak dönecektir. return ana betik dosyasının içinden çağrıldığı takdirde, betiğin çalışması sonlandırılacaktır. Eğer return deyiminin çağrıldığı dosya, ismi php.ini içindeki auto_prepend_file veya auto_append_file yapılandırma seçenekleri ile atanan bir dosya ise bu betik dosyasının da çalışmasını sonlandıracaktır.

Daha fazla bilgi için, Dönüş değerleri bölümüne bakınız.

Bilginize: return bir işlev değil bir dil oluşumu olduğundan, değiştirgesini içeren parantez yalnızca değiştirge bir ifade içeriyorsa zorunludur. Bir değişken döndürürken genellikle parantez kullanılmaz. Böyle bir durumda, PHP'nin daha az işlem yapması için bu yöntemi izlemeniz gerekir.

Bilginize: Değiştirgesiz kullanılacaksa yaylı ayraçlar konulmamalıdır bu durumda dönen değer NULL olur. Değiştirge içermeyen yaylı ayraçların kullanımı bir çözümleme hatası ile sonuçlanır.

Bilginize: Bir değişkeni gönderimli olarak döndürüyorsanız, asla parantez kullanmamalısınız, bu çalışmayacaktır. Bir deyimin sonucunu gönderimli olarak döndüremezsiniz, yalnızca değişkenler gönderimli olarak döndürülebilir. return ($a); kullanıyorsanız, bir değişken değil, bir ifadenin sonucunu ($a) döndürüyorsunuz demektir (bu da elbette, $a değişkeninin değeridir).

declare
require
Denetim Yapıları


require

require deyimi bir başarısızlıkta E_ERROR seviyesinden ölümcül bir hata vermesi dışında include deyimi ile aynıdır. Başka bir deyişle, include deyiminin sadece bir uyarı (E_WARNING) vererek çalışmayı sürdürdüğü durumda require deyimi betiğin hata vererek durmasına sebep olur.

Deyimin nasıl çalıştığını öğrenmek için include belgesine bakınız.

return
include
Denetim Yapıları


include

(PHP 4, PHP 5, PHP 7)

include deyimi belirtilen dosyayı betiğe ekler ve içeriğini değerlendirir.

Betiğe dahil edilecek dosyalar önce belirtilen dizinde aranır, eğer bir dizin belirtilmemişse include_path yönergesinde belirtilen yollarda aranır. Dosya include_path içinde yoksa include son çare olarak çağrıcı betiğin kendi dizinine ve o anki çalışma dizinine bakar, bulamazsa bir uyarı çıktılar; require için bu davranış bir ölümcül hata olarak kendini gösterir.

Bir dizin belirtilmişse - mutlak (Windows'ta bir sürücü harfi veya \ ile başlıyorsa veya Unix sistemlerinde / ile başlıyorsa) veya geçerli dizine göreli (. veya .. ile başlıyorsa)- include_path yönergesine bakılmaz. Örneğin bir dosya ../ ili başlıyorsa PHP çözümleyicisi dosyayı betiğin bulunduğu dizinin üst dizininde arayacaktır.

PHP'nin dahil edilen dosyaları nasıl ele aldığı include_path yönergesinin açıklamasında ayrıntılı olarak anlatılmıştır.

Bir dosya bir betiğe dahil edildiğinde, bu dosyanın içerdiği kod, dosyanın dahil edildiği satır itibariyle ana betikte geçerli olan değişken uzayını miras alır. Yani, dosyanın dahil edildiği satıra kadar mevcut değişkenlerin hepsi dahil edilen dosyanın içinde kullanılabilir olacaktır. Bunun yanında, dahil edilen dosyada tanımlanmış işlevlerin ve sınıfların tamamı ana betiğin genelinde tanımlanmış sayılır.

Örnek 1 - Basit bir include örneği

vars.php
<?php

$renk = 'yeşil';
$meyve = 'elma';

?>

dnm.php
<?php

echo "Bir $renk $meyve"; // -> Bir

include 'vars.php';

echo "Bir $renk $meyve"; // -> Bir yeşil elma

?>

include deyimi, bir işlevin içinde kullanılırsa dahil edilmek istenen dosyanın içindeki tüm kodlar sanki o işlev içinde tanımlanmış gibi çalıştırılacaktır. Bu durumda dahil edilen dosyadaki kodlar, işlevin, dosyanın dahil edildiği noktadaki değişken uzayını miras alacaktır. Bu kuralın istisnası dosya dahil edilmeden önce çözümleyici tarafından işleme sokulan sihirli sabitlerdir.

Örnek 2 - İşlev içi include kullanımı

<?php

function foo()
{
    global $renk;

    include 'vars.php';

    echo 'Bir $renk $meyve';
}

/* vars.php, foo() işlevinin etki alanındadır
 * dolayısıyla $meyve bu alanın dışında
 * kullanılamamaktadır. $renk ise global olarak
 * tanımlandığından kullanılabilir
 */
foo();                      // Bir yeşil elma
echo 'Bir $renk $meyve';    // Bir yeşil

?>

Bir dosya bir betiğe dahil edildiğinde, çözümleme işlemi PHP kipinden çıkıp hedef dosyanın başlangıcında HTML kipine geçer ve dosyanın sonuna kadar HTML kipinde kalır. Bu sebeple, hedef dosyanın içindeki kodlardan PHP kodları olarak çalıştırılacaklar PHP başlangıç ve bitiş etiketleri arasına alınmalıdır.

"URL include sarmalayıcıları" PHP'de etkinleştirilmiş ise (öntanımlı yapılandırmada etkindirler), include deyiminde yerel dosya yolu belirtmek yerine (HTTP ya da desteklenen başka bir sarmalayıcı üzerinden - Supported Protocols and Wrappers bölümününe bakınız) bir URL kullanabilirsiniz. Hedef sunucu, hedef dosyayı PHP kodu olarak çalıştırabiliyorsa, ana betikteki değişkenler dahil edilen dosyaya bir URL istek dizgesi olarak HTTP GET ile aktarılabilir. Bu durum dahil edilen dosyaya ana dosyanın değişken uzayını miras olarak bırakmaktan biraz farklı bir şeydir; betik aslında uzak sunucuda çalıştırılıp yerel betiğe sonuçlar dahil edilmektedir.

Örnek 3 - HTTP üzerinden include

<?php

/* Bu örnekte  mesela.dom sitesinin .php uzantılı dosyaları
 * çalıştırabildiği ama .txt uzantılıları çalıştırmadığı
 * varsayılmıştır. Ayrıca, buradaki 'Çalışır'ın manası
 * $foo ve $bar değişkenlerinin dahil edilen dosyada kullanılabilir
 * olduğudur. */

// Çalışmaz; dosya.txt dosyası mesela.dom sitesinde çalıştırılmaz
include 'http://mesela.dom/dosya.txt?foo=1&bar=2';

// Çalışmaz; yerel dosya sisteminde 'dosya.php?foo=1&bar=2'
// adında bir dosya olarak aranır.
include 'dosya.php?foo=1&bar=2';

// Çalışır.
include 'http://mesela.dom/dosya.php?foo=1&bar=2';

$foo = 1;
$bar = 2;
include 'dosya.txt';  // Çalışır.
include 'dosya.php';  // Çalışır.

?>

Uyarı

Güvenlik uyarısı

Uzaktaki dosya uzaktaki sunucu tarafından işlenebilir (dosyanın uzantısına ve uzaktaki sunucunun PHP çalıştırıp çalıştırmadığına bağlı olarak). Ancak, elde edilecek çıktı yerel sunucuda çalıştırılacağından bu işlemin sonucu mutlaka geçerli bir PHP betiği üretmek olmalıdır. Dosyanın uzaktaki sunucuda işlenip sadece sonucun çıktılanmasını istiyorsanız readfile() işlevi daha iyi bir seçim olacaktır. Aksi takdirde, uzakta çalıştırılan betiğin geçerli ve istenen kodu üretebilmesini güvence altına alabilmek için özel bir çaba harcamak gerekir.

Ayrıca, bu konuyla ilgili olarak Uzaktaki dosyaların kullanımı belgesiyle fopen() ve file() işlevlerine de bakınız.

return kullanımı: include başarısız olursa FALSE döndürür ve bir uyarı verir. Başarılı olursa, içerildikleri dosya tarafından aksi belirtilmedikçe 1 döndürür. Dahil edilen dosyanın içersinde, bu dosyanın işlenmesi durdurmak ve dahil eden betiğe geri dönmek için return kullanılabilir. Ayrıca, dahil edilen dosyalardan değer döndürmek de mümkündür. Normal bir işlevde olduğu gibi, include çağrısından elde edilen değeri bir değişkene atayabilirsiniz. Ancak bu durum, uzaktaki dosyalar için, sadece uzaktaki dosyanın çıktısı geçerli PHP başlangıç ve bitiş etiketlerine sahipse (herhangi yerel bir dosyada olduğu gibi), kullanılabilir. Gerekli değişkenler bu etiketlerin arasında tanımlandığında dosyanın dahil edildiği noktadan itibaren kullanılabilir olacaklardır.

include özel bir dil oluşumu olduğundan, değiştirgesinin parantez içine alınması gerekmez. Dönüş değerini karşılaştırırken buna dikkat edin.

Örnek 4 - include dönüş değerinin karşılaştırılması

<?php
// çalışmaz, include(('vars.php') == TRUE) olarak değerlendirilir,
// sonuç include('') olur
if (include('vars.php') == TRUE) {
    echo 'TAMAM';
}

// çalışır
if ((include 'vars.php') == TRUE) {
    echo 'TAMAM';
}
?>

Örnek 5 - include ve return deyimleri

return.php
<?php

$var = 'PHP';

return $var;

?>

noreturn.php
<?php

$var = 'PHP';

?>

testreturns.php
<?php

$foo = include 'return.php';

echo $foo; // 'PHP' basar

$bar = include 'noreturn.php';

echo $bar; // 1 basar

?>

include işlemi başarılı olduğundan $bar, 1 değerine sahiptir. Yukarıdaki örnekler arasındaki farklara dikkat edin. Birincisi return deyimini dahil edilen dosyada kullanırken ikincisi kullanmıyor. Dosya dahil edilemediği durumda, FALSE döndürülüyor ve bir E_WARNING üretiliyor.

Dahil edilen dosyanın içinde tanımlanmış işlevler varsa, return deyiminden önce ya da sonra olduğundan bağımsız olarak ana betik içersinde kullanılabilirler. Dosya iki defa dahil edilmişse, PHP 5 ölümcül hata verir çünkü bildirilmiş işlevler tekrar bildirilmeye calışılmış olur. PHP 4 ise return'den sonra tanımlanmış işlevler için şikayetçi olmayacaktır. Dosyanın halihazırda dahil edilip edilmediğini kendiniz tespit edip koşula bağlı return çalıştırmak yerine, include_once kullanmanız önerilir.

Bir PHP dosyasını bir değişkene "dahil" etmenin diğer bir yolu, çıktıyı Çıktı Denetim İşlevlerini include ile birlikte kullanarak yakalamaktır. Örnek:

Örnek 6 - Bir PHP dosyasını bir dizgeye dahil etmek için tampon kullanımı

<?php
$string = get_include_contents('somefile.php');

function get_include_contents($filename) {
    if (is_file($filename)) {
        ob_start();
        include $filename;
        return ob_get_clean();
    }
    return false;
}

?>

Betiğinize dosyaları özdevinimli olarak dahil etmek için, php.ini içersindeki auto_prepend_file ve auto_append_file yapılandırma seçeneklerini inceleyebilirsiniz.

Bilginize: Bu bir işlev değil, dil oluşumu olduğundan değişken işlevler kullanılarak çağrılamaz.

Ayrıca, require, require_once, include_once, readfile(), virtual() ve include_path'a da bakınız.

require
require_once
Denetim Yapıları


require_once

require_once deyimi, dosyayı evvelce dahil edilmişse tekrar dahil etmemesi dışında require deyimiyle aynıdır.

_once eki olup olmamasının ne gibi farklara yol açtığı ve varlığının davranışı nasıl değiştirdiğini öğrenmek için include_once belgesine bakınız.

include
include_once
Denetim Yapıları


include_once

include_once deyimi belirtilen dosyayı betiğin çalışması esnasında okur ve çalıştırır. Bu deyimin çalışma biçimi include deyimi ile benzerdir, kendisiyle dahil edilmiş bir dosya betiğin başka bir yerinde tekrar dahil edilmek istenirse buna izin vermemesidir. Daha fazla bilgi için include belgesine bakabilirsiniz.

include_once deyimi, bir betiğin çalışması esnasında aynı dosyanın bir kereden fazla dahil edilme ihtimaline karşı, bu dosyanın yalnızca bir kere dahil edileceğinden emin olunmak istenirse kullanılmalıdır. Bu sayede işlev bildirimlerinin yinelenmesi, değişkenlere tekrar değer atanması gibi sorunlar ortaya çıkmaz.

Bu işlevin nasıl çalıştığı hakkında ayrıntılı bilgi edinmek için include belgesine bakınız.

Bilginize:

Büyük-küçük harf duyarlı olmayan işletim sistemlerinde (Windows gibi), require_once ve include_once deyimlerinin PHP 4'ten itibaren beklediğiniz sonucu üretmeyebileceğine dikkat edin.

Örnek 1 - Harf büyükyüğüne duyarsız işletim sistemlerinde include_once

<?php
include_once("a.php"); // bu a.php dosyasını include edecektir
include_once("A.php"); // bu yine a.php dosyasını include edecektir! (yalnızca PHP 4)
?>

Bu davranış PHP 5'te değişmiştir - öncelikle yol normalleştirilir, böylece örneğin, C:\PROGRA~1\A.php ile C:\Program Files\a.php aynı kabul edilir ve dosya yalnızca bir defa işlenir.

require_once
goto
Denetim Yapıları


goto

goto işleci betik içinde başka bir komuta atlamak için kullanılabilir. Hedefin yeri, bir yafta ve ikinokta imi ile belirtilebilir. goto bu yaftaya göre hedefi bulur. Bu, goto deyiminin tamamen sınırsız olduğu anlamına gelmez. Hedef yaftasının aynı dosya ve aynı bağlam içinde kalması gerekir, yani bir işlev veya yöntemin dışına atlayamayacağınız gibi bir başka işlev veya yöntemin içine de atlayamazsınız. Ayrıca bir switch veya döngünün içine de atlayamazsınız, fakat bunların dışına atlayabilirsiniz, yani çok seviyeli bir break yerine bir goto kullanabilirsiniz.

Örnek 1 - goto örneği

<?php
goto a;
echo 'Foo';

a:
echo 'Bar';
?>

Yukarıdaki örneğin çıktısı:

Bar

Örnek 2 - Döngüden goto ile çıkma örneği

<?php
for($i=0,$j=50; $i<100; $i++) {
  while($j--) {
    if($j==17) goto end;
  }
}
echo "i = $i";
end:
echo 'j hit 17';
?>

Yukarıdaki örneğin çıktısı:

j hit 17

Örnek 3 - Bu çalışmaz

<?php
goto loop;
for($i=0,$j=50; $i<100; $i++) {
  while($j--) {
    loop:
  }
}
echo "$i = $i";
?>

Yukarıdaki örneğin çıktısı:

Fatal error: 'goto' into loop or switch statement is disallowed in
script on line 2

Bilginize:

goto işleci PHP 5.3'ten beri kullanılabilmektedir.

include_once
İşlevler
Denetim Yapıları


İşlevler

İçindekiler

  • Kullanıcı tanımlı işlevler
  • İşlev değiştirgeleri
  • Dönen değerler
  • Değişken işlevler
  • Yerleşik işlevler
  • Anonim işlevler
goto
Kullanıcı tanımlı işlevler
Dil Başvuru Kılavuzu


Kullanıcı tanımlı işlevler

Bir işlev, şöyle bir söz dizimi kullanılarak tanımlanabilir:

Örnek 1 - İşlev kullanımını gösteren sözde kod

<?php
function foo($arg_1, $arg_2, /* ..., */ $arg_n)
{
    echo "Örnek işlev.\n";
    return $retval;
}
?>

Bir işlevin içerisinde geçerli her tür PHP kodu kullanılabilir, buna başka işlevler ve sınıf tanımları da dahildir.

İşlev isimleri, PHP'deki diğer isimlerle aynı kurallara tabidir. Geçerli bir işlev ismi bir harf ya da alt çizgi ile başlar, herhangi bir sayıda geçerli harf, sayı ya da alt çizgi ile devam eder. Düzenli ifade olarak, şu şekilde ifade edebiliriz: [a-zA-Z_\x7f-\xff][a-zA-Z0-9_\x7f-\xff]*.

İşlevlerin çağrılmadan önce tanımlanmaları, aşağıdaki iki örnekte görüldüğü gibi koşullu olarak tanımlandıkları durumlar haricinde gerekmez.

Bir işlev aşağıdaki iki örnekte gösterildiği gibi koşullu olarak tanımlandıysa, bu işlev tanımının işlev çağrılmadan önce yapılması gerekmektedir.

Örnek 2 - Koşula bağlı işlevler

<?php

$makefoo = true;

/* Henüz varolmadığı için foo() buradan çağrılamaz,
   ancak bar() çağrılabilir */

bar();

if ($makefoo) {
  function foo()
  {
    echo "Uygulamanın çalışması bana erişene kadar ben yokum.\n";
  }
}

/* $makefoo doğru olduğundan
   artık foo() çağrılabilir */

if ($makefoo) foo();

function bar()
{
  echo "Program başlatıldığı anda ben de varolurum.\n";
}

?>

Örnek 3 - İşlev içinde işlev

<?php
function foo()
{
  function bar()
  {
    echo "foo() çağrılana kadar yokum.\n";
  }
}

/* Henüz varolmadığı için
   bar() çağrılamaz. */

foo();

/* Artık bar() çağrılabilir,
   foo() çağrıldığında bar()
   erişilebilir hale gelir */

bar();

?>

PHP'de tüm işlevler ve sınıflar betik genelinde geçerlidir - bir işlevin içinden bile tanımlanmış olsalar işlevin dışından çağrılabilirler.

PHP işlevlerin farklı değiştirgeli yeni tanımlarının yapılmasını desteklemediği gibi, işlevler yeniden tanımlanamaz veya tanımsız kılınamaz.

Bilginize: İşlev isimleri büyük-küçük harf duyarsızdır, ancak işlev isimlerini tanımlandıkları halleriyle kullanmak daha iyidir.

Değiştirge sayısı değişken işlevler desteklendiği gibi işlevlerde öntanımlı değiştirge kullanımı da desteklenmektedir. Daha ayrıntılı bilgi edinmek için func_num_args(), func_get_arg() ve func_get_args() işlevlerine de bakınız.

PHP'de işlevlerin kendilerini çağırması da mümkündür.

Örnek 4 - Kendini çağıran işlev

<?php
function recursion($a)
{
    if ($a < 20) {
        echo "$a\n";
        recursion($a + 1);
    }
}
?>

Bilginize: Kendini çağıran işlev ve yöntemler bunu 100-200 kere yaparsa yığıt taşabilir ve çalışan betiğin durdurulmasına sebep olabilir. Özellikle, kendini çağırma sayısı sonsuza giderse bu bir programlama hatası sayılır.

İşlevler
İşlev değiştirgeleri
İşlevler


İşlev değiştirgeleri

Bir işleve veri, virgül ayraçlı ifadelerden oluşan bir değiştirge listesi ile aktarılır. Değitirgeler soldan sağa doğru değerlendirilir.

PHP, değiştirgelerin değerleriyle aktarılmalarını (öntanımlı), gönderimli aktarımı ve öntanımlı değiştirge kullanımını destekler. Değiştirge sayısı değişken işlevler de desteklenmektedir.

Örnek 1 - İşlevlere dizi aktarımı

<?php
function dizi_kabul_eder($girdi)
{
    echo "$girde[0] + $girdi[1] = ", $girdi[0]+$girdi[1];
}
?>

Gönderimli değiştirge kullanımı

Öntanımlı olarak, işlev değiştirgeleri değerleriyle aktarılırlar (bu durumda bir değiştirgenin değeri işlev içinde değiştirildiğinde işlevin çağrıldığı yerdeki değeri bundan etkilenmez. İşlevin çağrıldığı yerdeki değerinin de değişmesini istiyorsanız gönderimli değiştirge kullanmalısınız.

Bir işleve bir değiştirgenin daima gönderimli olarak aktarılmasını istiyorsanız, işlev tanımladığınız yerde o değiştirgenin başına & karakterini koyarak bunu sağlayabilirsiniz:

Örnek 2 - Gönderimli işlev değiştirgelerinin aktarımı

<?php
function şunu_da_ekle(&$dizge)
{
    $dizge .= 've bir kaç karakter eklenmiştir.';
}
$dzg = 'Bu bir dizgedir ';
şunu_da_ekle($dzg);
echo $dzg;    // 'Bu bir dizgedir ve bir kaç karakter eklenmiştir.'
              //  çıktısını verir.
?>

Öntanımlı değiştirge değerleri

Bir işlevde, sayıl değiştirgeler için C++ tarzı öntanımlı değerler aşağıdaki biçimde tanımlanabilir:

Örnek 3 - İşlev içinde öntanımlı değiştirge kullanımı

<?php
function kahveyap($hangisi = "orta şekerli")
{
    return "Bir fincan $hangisi kahve yapalım.\n";
}
echo kahveyap();
echo makecoffee(null);
echo kahveyap("az şekerli");
?>

Yukarıdaki örneğin çıktısı:

Bir fincan orta şekerli kahve yapalım.
Bir fincan kahve yapalım.
Bir fincan az şekerli kahve yapalım.

PHP ayrıca, öntanımlı değer olarak dizilerin ve özel NULL türünün kullanımına da izin verir, örneğin:

Örnek 4 - Sayıl olmayan türlerin öntanımlı değer olarak kullanımı

<?php
function kahveyap($hangi = array("orta şekerli"), $neyde = NULL)
{
    $neyde = is_null($neyde) ? "ocakta" : $neyde;
    return "Bir fincan ".join(" bir fincan ", $hangi)." kahve $neyde yapıldı.\n";
}
echo kahveyap();
echo kahveyap(array("çok şekerli", "az şekerli"), "mangalda");
?>

Öntanımlı değer bir değişken, bir sınıf üyesi ya da bir işlev çağrısı değil, bir sabit ifadesi olmalıdır.

Öntanımlı değiştirgeleri kullanırken, öntanımlama yapılmış tüm değiştirgelerin öntanımlama yapılmamış tüm değiştirgelerin sağında yer almasına gerektiğine dikkat edin. Aksi takdirde işler yolunda gitmeyebilir. Aşağıdaki kod parçasını inceleyin:

Örnek 5 - Öntanımlı değiştirgelerin hatalı kullanımı

<?php
function yoğurtyap($nekadar = "az", $neli)
{
    return "Bir kase $nekadar $neli yoğurt yap.\n";
}

echo yoğurtyap("çilekli");   // beklendiği gibi çalışmayacaktır
?>

Yukarıdaki örneğin çıktısı:

Warning: Missing argument 2 for yoğurtyap(), called in
/home/nilgun/dnm/php-dnm on line 7 and defined in
/home/nilgun/dnm/php-dnm on line 2
Bir kase çilekli  yoğurt yap.

Şimdi, yukarıdakini bununla karşılaştıralım:

Örnek 6 - Öntanımlı değiştirgelerin doğru kullanımı

<?php
function yoğurtyap($neli, $nekadar= "az")
{
    return "Bir kase $nekadar $neli yoğurt yap.\n";
}

echo yoğurtyap("çilekli");   // beklendiği gibi çalışır
?>

Yukarıdaki örneğin çıktısı:

Bir kase az çilekli yoğurt yap.

Bilginize: PHP 5'den itibaren, gönderimli aktarılabilen değiştirgeler öntanımlı değer içerebilmektedir.

Tür Bildirimleri

Bilginize:

Tür bildirimleri PHP 5'de tür önerileri olarak da bilinir.

Tür bildirimleri işlevlerin çalıştırılması sırasında belli bir tür gerektirmesini sağlar. Eğer değer uygun olmayan bir türdeyse PHP 5'de kurtarılabilir bir ölümcül hata oluşurken, PHP 7'de TypeError istisnası oluşur.

Tür bildirimini belirtmek için, tür ismi değiştirge isminden önce gelmelidir. Değiştirgenin öntanımlı değeri NULL olacaksa bildirim NULL kabul edecek şekilde yapılabilir.

Geçerli türler

Tür | Açıklama | Minimum PHP sürümü
Sınıf/arayüz ismi | Tür olarak bir sınıf veya arayüz ismi belirtilmişse değiştirge bir instanceof olmalıdır. | PHP 5.0.0
self | Tür, yöntemin tanımlandığı sınıf olarak belirtilirse değiştirge bir instanceof olmalıdır. Bu sadece sınıfın veya örneğinin yöntemlerinde kullanılabilir. | PHP 5.0.0
array | Değiştirge geçerli bir dizi olmalıdır. | PHP 5.1.0
callable | Değiştirge geçerli bir işlev olmalıdır. | PHP 5.4.0
bool | Değiştirge geçerli bir mantıksal değer olmalıdır. | PHP 7.0.0
float | Değiştirge geçerli bir gerçel değer olmalıdır. | PHP 7.0.0
int | Değiştirge geçerli bir tamsayı olmalıdır. | PHP 7.0.0
string | Değiştirge geçerli bir dizge olmalıdır. | PHP 7.0.0
Uyarı

Yukarıdaki türler için takma ad kullanımı desteklenmemektedir. Ancak, bunlar bir sınıf veya arayüz adı olarak ele alınabilir. Örneğin, boolean türünün bool türü yerine, bir değiştirge gerektiren bir dönüş türü veya instanceof sınıfı bir dönüş değeri veya boolean arayüzü veya bir değiştirge olarak kullanımı:

<?php
 function test(boolean $param) {}
 test(true);
 ?>

Yukarıdaki örneğin çıktısı:

 Fatal error: Uncaught TypeError: Argument 1 passed to test() must be an instance of boolean, boolean given, called in - on line 1 and defined in -:1

Örnekler

Örnek 7 Temel sınıf türü bildirimi

<?php
class C {}
class D extends C {}

// Bu C sınıfını örnek almıyor.
class E {}

function f(C $c) {
    echo get_class($c)."\n";
}

f(new C);
f(new D);
f(new E);
?>

Yukarıdaki örneğin çıktısı:

C
D

Fatal error: Uncaught TypeError: Argument 1 passed to f() must be an instance of C, instance of E given, called in - on line 14 and defined in -:8
Stack trace:
#0 -(14): f(Object(E))
#1 {main}
  thrown in - on line 8

Örnek 8 Temel arayüz türü bildirimi

<?php
interface I { public function f(); }
class C implements I { public function f() {} }

// Bu I'yi gerçeklemez.
class E {}

function f(I $i) {
    echo get_class($i)."\n";
}

f(new C);
f(new E);
?>

Yukarıdaki örneğin çıktısı:

C

Fatal error: Uncaught TypeError: Argument 1 passed to f() must implement interface I, instance of E given, called in - on line 13 and defined in -:8
Stack trace:
#0 -(13): f(Object(E))
#1 {main}
  thrown in - on line 8

Örnek 9 Boş olabilen tür bildirimi

<?php
class C {}

function f(C $c = null) {
    var_dump($c);
}

f(new C);
f(null);
?>

Yukarıdaki örneğin çıktısı:

object(C)#1 (0) {
}
NULL

Kesin tür belirtimi

Öntanımlı olarak PHP yanlış türde belirtilmiş değerleri eğer mümkünse bilinen bir türe zorlar. Örneğin, bir işleve string türünde beklenirken integer türünde bir değer belirtilmişse string türünde bir değişken elde edilir.

Dosyaya özel olmak kaydıyla kesin kipi etkin kılmak mümkündür. Kesin kipte sadece tür belirtiminde belirtilmiş türde bir değer kabul edilir, aksi takdirde bir TypeError istisnası oluşur. Bu kuralın tek istisnası, float türünde bir değer beklenen bir işleve integer türünde bir değer belirtilebilmesidir. Dahili işlevlerin içinden yapılan işlev çağrıları kesin tür belirtiminden etkilenmez.

Kesin kipi etkin kılmak için declare deyimi strict_types bildirimi ile birlikte kullanılır:

Dikkat

Kesin kipi etkin kılmak ayrıca dönen tür bildirimlerini de etkiler.

Bilginize:

Kesin kipin uygulanabilmesi için işlev tanımlarının işlev çağrısının yapıldığı kesin kipli dosyada bulunması gerekmez. Ancak kesin kipli olmayan bir dosyadan yapılan bir işlev çağrısı kesin kipli dosyada tanımlı bir işlevi çağırıyorsa çağrıcının tercihine (zayıf tür) uyulur ve değer zorlanabilir.

Bilginize:

Kesin tür sadece sayısal tür bildirimlerine uygulanır dolayısıyla bunun için PHP 7.0.0 ve sonrası gerekir. Bunun sebebi sayısal tür bildirimlerinin bu sürümde eklenmiş olmasıdır.

Örnek 10 Kesin tür örneği

<?php
declare(strict_types=1);

function sum(int $a, int $b) {
    return $a + $b;
}

var_dump(sum(1, 2));
var_dump(sum(1.5, 2.5));
?>

Yukarıdaki örneğin çıktısı:

int(3)

Fatal error: Uncaught TypeError: Argument 1 passed to sum() must be of the type integer, float given, called in - on line 9 and defined in -:4
Stack trace:
#0 -(9): sum(1.5, 2.5)
#1 {main}
  thrown in - on line 4

Örnek 11 Zayıf tür örneği

<?php
function sum(int $a, int $b) {
    return $a + $b;
}

var_dump(sum(1, 2));

// bunlar tamsayıya zorlanacaktır; aşağıdaki çıktıya bakın!
var_dump(sum(1.5, 2.5));
?>

Yukarıdaki örneğin çıktısı:

int(3)
int(3)

Örnek 12 TypeError yakalama

<?php
declare(strict_types=1);

function sum(int $a, int $b) {
    return $a + $b;
}

try {
    var_dump(sum(1, 2));
    var_dump(sum(1.5, 2.5));
} catch (TypeError $e) {
    echo 'Error: '.$e->getMessage();
}
?>

Yukarıdaki örneğin çıktısı:

int(3)
Error: Argument 1 passed to sum() must be of the type integer, float given, called in - on line 10

Değiştirge sayısı değişken işlevler

Değiştirge sayısı değişken kullanıcı tanımlı işlevler desteklenmektedir. PHP 5.6 ve sonrasında bu ... ile, PHP 5.5 ve öncesinde ise func_num_args(), func_get_arg() ve func_get_args() işlevleri sayesinde bu özelliği kolayca kullanabilirsiniz.

PHP 5.6 ve sonrasında ...

PHP 5.6 ve sonrasında, işlevin değişken sayıda değiştirge içerebilmesini sağlamak için değiştirge listesine ... dizgeciği konulabilir. Değiştirgeler belirtilen değikene bir dizi olarak aktarılır. Örnek:

Örnek 13 Değişkenin değiştirgelerine erişim için ... kullanımı

<?php
function sum(...$numbers) {
    $acc = 0;
    foreach ($numbers as $n) {
        $acc += $n;
    }
    return $acc;
}

echo sum(1, 2, 3, 4);
?>

Yukarıdaki örneğin çıktısı:

10

Bir diziyi, bir Traversable değişkeni veya bir sabiti değiştirge listesi haline getirmek için işlev çağrılırken de ... kullanılabilir. Örnek:

Örnek 14 Değiştirgelere erişmek için ... kullanımı

<?php
function add($a, $b) {
    return $a + $b;
}

echo add(...[1, 2])."\n";

$a = [1, 2];
echo add(...$a);
?>

Yukarıdaki örneğin çıktısı:

3
3

... dizgeciğinden önce normal konumsal değiştirgeler belirtilebilir. Bu durumda ... ile üretilen diziye sadece bir konumsal değiştirge ile eşleşmeyen tokeni izleyen değiştirgeler eklenir.

... dizgeciğinin önüne bir tür dayatıcı eklemek de mümkündür. Böyle bir durumda, ... tarafından işleme sokulacak tüm değiştirgeler dayatılan sınıfın nesneleri olmalıdır

Örnek 15 Değişken değiştirgelerinde tür dayatma

<?php
function total_intervals($unit, DateInterval ...$intervals) {
    $time = 0;
    foreach ($intervals as $interval) {
        $time += $interval->$unit;
    }
    return $time;
}

$a = new DateInterval('P1D');
$b = new DateInterval('P2D');
echo total_intervals('d', $a, $b).' gün';

// Bir DateInterval nesnesi olmadığından bu başarısız olur.
echo total_intervals('d', null);
?>

Yukarıdaki örneğin çıktısı:

3 gün
Catchable fatal error: Argument 2 passed to total_intervals() must be an instance of DateInterval, null given, called in - on line 14 and defined in - on line 2

Son olarak, ... dizgeciğinin önüne bir & ekleyerek değişken değiştirgelerini gönderimli olarak da aktarabilirsiniz.

Daha eski PHP sürümlerinde

Bir işlevin değişken sayıda değiştirge içerebilmesi özel bir sözdizimi gerekmez; ancak işlevin değiştirgelerine erişim için func_num_args(), func_get_arg() ve func_get_args() kullanmak gerekir.

PHP 5.5 ve öncesinde yukarıdaki ilk örnek şöyle gerçeklenirdi;

Örnek 16 PHP 5.5 ve öncesinde değişken değiştirgelerine erişim

<?php
function sum() {
    $acc = 0;
    foreach (func_get_args() as $n) {
        $acc += $n;
    }
    return $acc;
}

echo sum(1, 2, 3, 4);
?>

Yukarıdaki örneğin çıktısı:

10

Kullanıcı tanımlı işlevler
Dönen değerler
İşlevler


Dönen değerler

Değerler, kullanımı seçime bağlı olan return deyimi kullanılarak döndürülür. Her türde değer döndürülebilir, buna diziler ve nesneler dahildir. return kullanıldığında işlevin çalışması o noktada hemen durdurulur ve denetim işlevin çağrıldığı satıra aktarılır. Daha ayrıntılı bilgi için return bölümüne bakınız.

Bilginize:

return belirtilmezse NULL değeri döner.

return kullanımı

Örnek 1 - return kullanımı

<?php
function square($num)
{
    return $num * $num;
}
echo square(4);   // '16' çıktılar.
?>

Bir işlevden birden fazla değer döndüremezsiniz, ancak böyle bir sonucu bir dizi döndürülerek elde edebilirsiniz.

Örnek 2 - Bir diziyle birden fazla değerin döndürülmesi

<?php
function küçük_sayılar()
{
    return array (0, 1, 2);
}
list ($sıfır, $bir, $iki) = küçük_sayılar();
?>

Bir işlevden gönderimli bir değer döndürmek için, & işlecini hem işlev bildiriminde hem de dönen değeri bir değişkene atarken kullanmalısınız:

Örnek 3 - Bir işlevden gönderimli değer döndürmek

<?php
function &gönderimli_döndür()
{
    return $gönderim;
}

$yenigönderim =& gönderimli_döndür();
?>

Gönderimler hakkında daha fazla bilgi edinmek için Gönderimler Hakkında bölümüne bakınız.

Dönen tür bildirimleri

PHP 7'de dönen tür bildirimleri desteği eklenmiştir. Değiştirge türünde bildirimlere benzer şekilde, dönen tür bildirimlerinde değerin türünü bir işlevden dönen değerin türü belirler. Dönen tür belirtimlerinde kullanılabilen türler değiştirge türü bildirimlerdeki türlerle aynıdır.

Kesin tür belirtimi dönen tür belirtimlerini de etkiler. Öntanımlı zayıf kipte, dönen türler istenen türde değilse doğru türe zorlanır. Kesin tipte ise dönen değer doğru türde değilse TypeError istisnası oluşur.

Bilginize:

Bir ebeveyn yöntem geçersizleştirilirken çocuğun yönteminin ebeveyn üstündeki dönen tür bildirimiyle eşleşmesi gerekir. Eğer ebeveyn bir dönen tür tanımlamıyorsa çocuğun yöntemi de öyle yapabilir.

Örnekler

Örnek 4 Temel dönen tür bildirimi

<?php
function sum($a, $b): float {
    return $a + $b;
}

// float döneceğini unutmayın.
var_dump(sum(1, 2));
?>

Yukarıdaki örneğin çıktısı:

float(3)

Örnek 5 Kesin kip işe karışırsa

<?php
declare(strict_types=1);

function sum($a, $b): int {
    return $a + $b;
}

var_dump(sum(1, 2));
var_dump(sum(1, 2.5));
?>

Yukarıdaki örneğin çıktısı:

int(3)

Fatal error: Uncaught TypeError: Return value of sum() must be of the type integer, float returned in - on line 5 in -:5
Stack trace:
#0 -(9): sum(1, 2.5)
#1 {main}
  thrown in - on line 5

Örnek 6 Bir nesne döndürmek

<?php
class C {}

function getC(): C {
    return new C;
}

var_dump(getC());
?>

Yukarıdaki örneğin çıktısı:

object(C)#1 (0) {
}
İşlev değiştirgeleri
Değişken işlevler
İşlevler


Değişken işlevler

PHP değişken işlev kavramını desteklemektedir. Yani, bir değişken isminin sonuna parantez eklenmişse, PHP aynı isimde bir işlev olup olmadığına bakar ve bulduğu takdirde bu işlevi çalıştırmaya çalışır. Başka olası işlemlerin yanında, bu özellik geri çağırımların, işlev tablolarının ve benzerlerinin gerçeklenmesinde kullanılabilir.

Değişken işlevler, echo, print, unset(), isset(), empty(), include, require ve benzeri dil yapılarında çalışmayacaktır. Bu yapıları değişken işlev olarak kullanmak istediğiniz takdirde, gerekli sarmalayıcı işlevleri kendiniz yazmalısınız.

Örnek 1 - Değişken işlev örneği

<?php
function foo() {
    echo "In foo()<br />\n";
}

function bar($arg = '')
{
    echo "In bar(); argument was '$arg'.<br />\n";
}

// Bu echo için sarmalayıcı işlevdir
function echoit($string)
{
    echo $string;
}

$func = 'foo';
$func();        // foo() çağrılır

$func = 'bar';
$func('test');  // bar() çağrılır

$func = 'echoit';
$func('test');  // echoit() çağrılır
?>

Değişken işlev özelliğini kullanarak bir nesnenin bir yöntemini de çağırabilmeniz mümkündür.

Örnek 2 - Değişken yöntem örneği

<?php
class Foo
{
    function Variable()
    {
        $name = 'Bar';
        $this->$name(); // Bu Bar() yöntemini çağıracaktır
    }

    function Bar()
    {
        echo "Bu bir Bar";
    }
}

$foo = new Foo();
$funcname = "Variable";
$foo->$funcname();  // Bu $foo->Variable() işlevini çağıracaktır

?>

Static türünden yöntemleri çağırırken işlev çağrısı 'static property' işlecinden daha güçlüdür:

Örnek 3 Duruk özellikli yöntem çağrısı örneği

<?php
class Foo
{
    static $variable = 'static property';
    static function Variable()
    {
        echo 'Method Variable called';
    }
}

echo Foo::$variable; // Bu 'static property' basar. Bu bağlamda $variable gerekmez.
$variable = "Variable";
Foo::$variable();  // Bu bağlamda $variable değişkenini okuyan $foo->Variable() çağrılır.

?>

PHP 5.4.0'dan itibaren bir değişkene saklanmış callable türünde bir işlevi çağırabilirsiniz.

Örnek 4 Karmaşık çağrılar

<?php
class Foo
{
    static function bar()
    {
        echo "bar\n";
    }
    function baz()
    {
        echo "baz\n";
    }
}

$func = array("Foo", "bar");
$func(); // prints "bar"
$func = array(new Foo, "baz");
$func(); // prints "baz"
$func = "Foo::bar";;
$func(); // PHP 7.0.0 öncesinde "bar" basar ve ölümcül hata üretirdi
?>

Ayrıca bakınız: is_callable(), call_user_func(), değişken değişkenleri ve function_exists().

Sürüm Bilgisi

Sürüm: | Açıklama
7.0.0 | 'SınıfAdı::yöntemAdı' bir değişken ismi olabilir.
5.4.0 | Diziler de değişken işlev olabilir.

Dönen değerler
Yerleşik işlevler
İşlevler


Yerleşik işlevler

PHP standart olarak birçok işlev ve oluşum ile birlikte gelmektedir. Bunun yanında, özel PHP eklentilerinin derlenmesini gerektiren, aksi takdirde "tanımsız işlev" hatası üreten işlevler de mevcuttur. Örneğin, imagecreatetruecolor() gibi resim işlevlerini kullanabilmek için, PHP'yi GD desteğiyle derlemiş olmanız gerekir. Ya da, mysql_connect() işlevini kullanabilmek için, PHP'nin MySQL desteği ile derlenmiş olması gerekmektedir. Bunların yanında, bütün PHP sürümlerine eklenen dizge ve değişken işlevleri gibi birçok çekirdek işlev de mevcuttur. phpinfo() ya da get_loaded_extensions() işlevlerine yapılacak bir çağrı ile PHP'ye hangi eklentilerin yüklenmiş olduğunu görebilirsiniz. Birçok uzantı öntanımlı olarak etkinleştirilmiş olup PHP Kılavuzunda bu eklentilerle ilgili geniş bilgi verilmiştir. PHP'yi nasıl yapılandırmanız gerektiğiyle ilgili bilgiyi yapılandırma ve kurulum bölümleri ile eklerdeki özel bölümlerde bulabilirsiniz.

Kılavuzun işlev tanımı nasıl okunur bölümünde bir işlev tanımının nasıl okunup anlaşılabileceği ile ilgili bilgiler bulunmaktadır. Bir işlevin bir değer mi döndürdüğü yoksa aktarılan değerlerle sadece işlem mi yaptığını anlamak önemlidir. Örneğin, str_replace() değiştirilmiş dizgeyle dönerken, usort() sadece kendisine aktarılan değer üzerinde çalışır. Ayrıca, her kılavuz sayfasında her işlevin değiştirgeleri, davranış değişiklikleri, başarı ya da başarısızlık durumunda döndürülen değerler ve kullanılabilirlik bilgileri bulunmaktadır. Bu önemli (ve sıklıkla algılanması güç) farklılıkların bilinmesi, doğru PHP kodunun yazılabilmesi için büyük önem taşımaktadır.

Ayrıca bakınız: function_exists(), İşlev Başvuru Kılavuzu, get_extension_funcs() ve dl().

Değişken işlevler
Anonim işlevler
İşlevler


Anonim işlevler

Anonim işlevler isim belirtmeksizin oluşturulabilen işlevlerdir. Çoğunlukla geriçağırım işlevi olarak işlev değiştirgelerinde kullanılırsa da kullanımı bununla sınırlı değildir.

Anonim işlevler Closure sınıfı kullanılarak gerçeklenir.

Örnek 1 - Anonim işlev örneği

<?php
echo preg_replace_callback('~-([a-z])~',
      function ($match) {
       return strtoupper($match[1]);
      },
      'hello-world');
// Çıktısı: helloWorld
?>

Anonim işlevler birer değişken değeri olarak da bildirilebilir. Bu durumda PHP, işlevi özdevinimli olarak sınıfının nesnel bir örneği haline getirir. Bir anonim işlev, bir değişkene sıradan bir deyim gibi, bir noktalı virgül ile biten bir işlev olarak atanabilir:

Örnek 2 - Değişkene anonim işlev atama örneği

<?php
$greet = function($isim)
{
    printf("Merhaba %s\r\n", $isim);
};

$greet('Dünya');
$greet('PHP');
?>

Anonim işlevler değişkenleri üst etki alanından miras alabilirler. Böyle değişkenler use dil oluşumuna aktarılmalıdır.

Örnek 3 Değikenleri üst etki alanından miras almak

<?php
$message = 'hello';

// "use" olmaksızın
$example = function () {
    var_dump($message);
};
$example();

// $message miras alınır
$example = function () use ($message) {
    var_dump($message);
};
$example();

// Miras alınan deşkenin değeri işlevin tanımından gelir, çağrısından değil.
$message = 'world';
$example();

// message sıfırlanır
$message = 'hello';

// Gönderimle miras alma
$example = function () use (&$message) {
    var_dump($message);
};
$example();

// Üst etki alanında değişen değer
// işlev çağrısı içinde yansıtılır.
$message = 'world';
$example();

// Anonim işlevler sıradan değiştirgeleri de kabul edebilir
$example = function ($arg) use ($message) {
    var_dump($arg . ' ' . $message);
};
$example("hello");
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Notice: Undefined variable: message in /example.php on line 6
NULL
string(5) "hello"
string(5) "hello"
string(5) "hello"
string(5) "world"
string(11) "hello world"

Üst etki alanından miras alınan değişkenler küresel değişkenler gibi ele alınmazlar. Küresel değişkenler, işlevin çalıştığı etki alanında tanımlı değişkenlerdir. Anonim işlevin üst etki alanı ise içinde bildirildiği işlevin etki alanıdır (Anonim işlevin bildirildiği etki alanı ile çağrıldığı etki alanı aynı olmak zorunda değildir). Aşağıdaki örneğe bakalım:

Örnek 4 - Anonim işlevler ve etki alanı

<?php
// Ürünleri eklemek üzere bir Sepet oluşturalım.
// Eklenen ürünlerin toplam fiyatını döndürmek
// üzere bir geriçağırım işlevi kullanalım.
class Sepet
{
  const PRICE_BUTTER = 1.00;
  const PRICE_MILK = 3.00;
  const PRICE_EGGS = 6.95;

  protected $ürünler = Array();

  public static function ekle($ürün, $miktar)
  {
    $this->ürünler[$ürün] = $miktar;
  }

 public static function miktarıGetir($ürün)
 {
    return isset($this->ürünler[$ürün]) ? $this->ürünler[$ürün] : FALSE;

  }

  public function Toplam($kdv)
  {
      $toplam = 0.00;

      $işlev =
          function ($miktar, $ürün) use ($kdv, &$toplam)
          {
              $birimFiyat = constant(__CLASS__ . "::FiYAT_" .
                  strtoupper($ürün));
              $toplam += ($birimFiyat * $miktar) * ($kdv + 1.0);
          };

      array_walk($this->ürünler, $işlev);
      return round($toplam, 2);
  }
}

$sepetim = new Sepet;

// Sepete birşeyler ekleyelim
$sepetim->ekle('Peynir', 1);
$sepetim->ekle('Süt', 3);
$sepetim->ekle('Yumurta', 6);

// %5 KDV ile toplamı döndürelim
print $sepetim->Toplam(0.05) . "\n";
// sonuç: is 54.29
?>

Örnek 5 $this'in özdevinimli bağlanması

<?php

class Test
{
    public function testing()
    {
        return function() {
            var_dump($this);
        };
    }
}

$object = new Test;
$function = $object->testing();
$function();

?>

Yukarıdaki örneğin çıktısı:

object(Test)#1 (0) {
}

Yukarıdaki örneğin PHP 5.3 çıktısı:

Notice: Undefined variable: this in script.php on line 8
NULL

PHP 5.4.0 itibariyle, bir sınıf başka bir sınıfın içinde bildirildiğinde $this'i işlevin etki alanı içinde kullanılabilir kılarak özdevinimli olarak ona bağlanır. Bu özdevinimli bağlantı istenmiyorsa bunun yerine duruk anonim işlevler kullanılabilir.

Duruk anonim işlevler

PHP 5.4 itibariyle, anonim işlevler duruk olarak bildirilebilmektedir. Böylece, geçerli sınıfın özdevinimli olarak bunlara bağlanamaması sağlanabilir. Çalışma anında nesneler de özdevinimli olarak bunlara bağlanamayacaktır.

Örnek 6 - Duruk anonim bir işlevin içinde $this kullanmaya çalışmak

<?php

new class {
    function __construct()
    {
        (static function() {
            var_dump($this);
        })();
    }
};
?>

Yukarıdaki örneğin çıktısı:

Notice: Undefined variable: this in %s on line %d
NULL

Örnek 7 - Duruk anonim bir işleve bir nesne bağlamaya çalışmak

<?php

(static function() {
    // function body
})->call(new StdClass);
?>

Yukarıdaki örneğin çıktısı:

Warning: Cannot bind an instance to a static closure in /in/sLLS9 on line 5

Sürüm Bilgisi

Sürüm: | Açıklama
5.4.0 | Duruk olarak bildirilmek koşuluyla anonim işlevlerde $this kullanılabilir.
5.3.0 | Anonim işlevler kullanılabilir oldu.

Notlar

Bilginize: func_num_args(), func_get_args() ve func_get_args() işlevini bir anonim işlev içinde kullanmak mümkündür.

Yerleşik işlevler
Sınıflar ve Nesneler
İşlevler


Sınıflar ve Nesneler

İçindekiler

  • Giriş
  • Temel Kavramlar
  • Özellikler
  • Sınıf Sabitleri
  • Özdevinimli Sınıf Yükleme
  • Kurucular ve Yıkıcılar
  • Görünürlük
  • Nesnelerin Kalıtımı
  • Etki Alanı Çözünürlük İşleci (::)
  • static Anahtar Sözcüğü
  • Sınıf Soyutlama
  • Nesne Arayüzleri
  • Nitelikler
  • Anonymous classes
  • Aşırı Yükleme
  • Nesne Yineleme
  • Sihirli Yöntemler
  • final Anahtar Sözcüğü
  • Nesne Kopyalama
  • Nesnelerin Karşılaştırılması
  • Tür Dayatma
  • Duruk İçselleştirim
  • Nesneler ve Gönderimler
  • Object Serialization
  • OOP Changelog
Anonim işlevler
Giriş
Dil Başvuru Kılavuzu


Giriş

PHP 5 yeni bir Nesne Modeli'ne sahiptir. PHP'nin nesne yönetimi tamamen yeni baştan yazılarak daha iyi başarım elde edilmesi ve daha fazla özellik sunulması sağlanmıştır. Bu PHP4'te yapılan en büyük değişikliklerden biridir. PHP5 tam bir nesne modeline sahiptir.

PHP 5 özelliklerinden bazılar3: Görünürlük, Sınıf Soyutlama, final Anahtar Sözcüğü, Sihirli Yöntemler, Nesne Arayüzleri, Nesne Kopyalama ve Tür Dayatma.

PHP'deki her nesne değişkeni nesnenin tamamının bir kopyasını değil, nesne başvurusunu içerir. Ayrıntılar için Nesneler ve Gönderimler bölümüne bakınız.

İpucu

Ayrıca Kullanıcı Alanı İsimlendirme Kılavuzu belgesine de bakınız.

Sınıflar ve Nesneler
Temel Kavramlar
Sınıflar ve Nesneler


Temel Kavramlar

class Anahtar Sözcüğü

Temel sınıf tanımı class anahtar sözcüğü ile başlar sınıf isminin ardından gelen bir çift kaşlı ayracın arasında sınıfa ait özelliklerin ve yöntemlerin tanımları bulunur.

Sınıf ismi olarak herhangi bir geçerli yafta kullanılabilir ancak bu PHP için ayrılmış sözcüklerden biri olmamalıdır. Geçerli bir sınıf ısmı bir harf veya alt çizgi ile başlar, sayılar, harfler veya alt çizgiler içerebilir. Bir düzenli ifade olarak şöyle bir şablonla eşleşmelidir: [a-zA-Z_\x7f-\xff][a-zA-Z0-9_\x7f-\xff]*.

Bir sınıfın kendi sabitleri, değişkenleri (bunlara "özellik" de denir) ve işlevleri (bunlara "yöntem" de denir) olabilir.

Örnek 1 - Basit bir sınıf tanımı

<?php
class BasitSınıf
{
    // özellik bildirimi
    public $öntanımlı = 'öntanımlı bir değer';

    // yöntem tanımı
    public function ÖntanımlıyıGöster() {
        echo $this->öntanımlı;
    }
}
?>

Bir nesne bağlamı içinden bir yöntem çağırmak için $this diye bir sözde değişken kullanılır. $this çağrılan nesneye bir gönderimdir (normalde yöntemin ait olduğu nesnedir, ancak eğer nesne diğer nesnenin bağlamından duruk olarak çağrılıyorsa, bu başka bir nesne de olabilir).

Örnek 2 - $this sözde değişkeninin kullanımı

<?php
class A
{
    function foo()
    {
        if (isset($this)) {
            echo '$this tanımlı (';
            echo get_class($this);
            echo ")\n";
        } else {
            echo "\$this tanımsız.\n";
        }
    }
}

class B
{
    function bar()
    {
        // Dikkat: E_STRICT etkinse bu satır bir uyarı
        // çıktılanmasına sebep olur.
        A::foo();
    }
}

$a = new A();
$a->foo();

// Dikkat: E_STRICT etkinse bu satır bir uyarı çıktılanmasına sebep olur.
A::foo();
$b = new B();
$b->bar();

// Dikkat: E_STRICT etkinse bu satır bir uyarı çıktılanmasına sebep olur.
B::bar();
?>

Yukarıdaki örneğin çıktısı:

$this tanımlı (A)
$this tanımsız.
$this tanımlı (B)
$this tanımsız.

new Anahtar Sözcüğü

Bir sınıfın örneğini oluşturmak için new anahtar sözcüğü kullanılmalıdır. Nesnenin hata durumunda daima yeni bir değişkene atanarak oluşturulması için kurucusunun bir istisna oluşturmaması gerekir. Sınıflar, örnekleme öncesi tanımlanmış olmalıdır (ve bu, bazı durumlarda bir gereksinimdir).

Bir string türünde dizge new ile kullanılmış bir sınıf ismi içeriyorsa bu sınıfın yeni bir örneği oluşturulur. Eğer sınıf bir isim alanı içersindeyse bu yapılırken sınıfın tam nitelenmiş ismi kullanılmalıdır.

Örnek 3 - Bir sınıf örneğinin oluşturulması

<?php
$örnek = new BasitSınıf();

// Bu bir değişkenle de yapılabilir:
$sınıf = 'BasitSınıf';
$örnek = new $sınıf(); // BasitSınıf()
?>

Sınıf bağlamında yeni bir nesneyi new self veya new parent kullanarak oluşturmak mümkündür.

Oluşturulmuş bir sınıf örneğinin yeni bir değişkene atanması sırasında, yeni değişken, atanan nesneyle aynı örneğe erişecektir. Bu davranışın örneklerin bir işleve aktarılmasından bir farkı yoktur. Kopyalamak suretiyle oluşturulmuş bir nesnenin daima bir kopyası yapılabilir.

Örnek 4 - Nesne Atama

<?php
$örnek = new BasitSınıf();

$atama     =  $örnek;
$gönderim  =& $örnek;

$örnek->var = '$atama bu değere sahip olacak';

$örnek = null; // $örnek ve $gönderim null olur

var_dump($örnek);
var_dump($gönderim);
var_dump($atama);
?>

Yukarıdaki örneğin çıktısı:

NULL
NULL
object(BasitSınıf)#1 (1) {
  ["var"]=>
  string(30) "$atama bu değere sahip olacak"
}

Bir nesnenin örneğini oluşturmak için PHP 5.3.0 ve sonrasında yeni yollar kullanılabilmektedir:

Örnek 5 - Yeni nesneler oluşturmak

<?php
class Test
{
    static public function getNew()
    {
        return new static;
    }
}

class Child extends Test
{}

$obj1 = new Test();
$obj2 = new $obj1;
var_dump($obj1 !== $obj2);

$obj3 = Test::getNew();
var_dump($obj3 instanceof Test);

$obj4 = Child::getNew();
var_dump($obj4 instanceof Child);
?>

Yukarıdaki örneğin çıktısı:

bool(true)
bool(true)
bool(true)

extends Anahtar Sözcüğü

Bir sınıfın bildiriminde extends anahtar sözcüğü kullanılarak başka bir sınıfın yöntemleri ve özellikleri miras alınabilir. Çok sayıda sınıfı miras alarak genişlemek mümkün değildir, bir sınıf sadece bir ana sınıfı miras alabilir.

Miras alınan yöntemler ve özellikler, ebeveyn sınıfta tanımlı isimleriyle yeniden bildirilerek geçersiz kılınabilir; bu sadece ebeveyn sınıfın final tanımlı yöntemleri için yapılamaz. Geçersiz kılınmış yöntemlere ve duruk özelliklere parent:: öneki ile atıfta bulunarak erişilebilir.

Yöntemler geçersiz kılınırken, değiştirgelerin yerleri korunmalıdır, aksi takdirde PHP E_STRICT seviyesinde bir hata üretir. Farklı değiştirgeler kullanarak geçersiz kılmayı mümkün kılan kurucuya bu uygulanmaz.

Örnek 6 - Basit bir sınıfın miras alınması

<?php
class EkSınıf extends BasitSınıf
{
    // ebeveyn yöntemi yeniden bildirelim
    function değerGöster()
    {
        echo "Sınıf genişletiliyor\n";
        parent::değerGöster();
    }
}

$ek = new EkSınıf();
$ek->değerGöster();
?>

Yukarıdaki örneğin çıktısı:

Sınıf genişletiliyor
bir öntanımlı değer

::class

PHP 5.5'ten itibaren, class anahtar sözcüğü, ayrıca sınıf isim çözünürlüğü için de kullanılabilmektedir. SınıfAdı sınıfının tam nitelenmiş ismini SınıfAdı::class biçeminde kullanarak bir dizge elde edebilirsiniz. Bu, özellikle isim alanlı sınıflarda çok kullanışlıdır.

Örnek 7 - Sınıf adı çözünürlüğü

<?php
namespace NS {
    class SınıfAdı {
    }

    echo SınıfAdı::class;
}
?>

Yukarıdaki örneğin çıktısı:

NS\SınıfAdı

Giriş
Özellikler
Sınıflar ve Nesneler


Özellikler

Sınıf üyesi değişkenlere "özellik" denir. Bunlara bazan "öznitelik" veya "alan" dendiğini de görürsünüz, fakat bu kılavuzun amaçları doğrultusunda biz "özellik" terimini kullanacağız. Bunlar normal değişken bildiriminin önüne public, protected, veya private anahtar sözcükleri getirilerek bildirilir. Bildirim, bir ilklendirme olarak da yapılabilir; bu durumda bir sabit değerle ilklendirme yapılmalıdır. Yani, derleme sırasında değerlendirilebilmeli, çalışma anında değerlendirilebilecek bilgiler içermemelidir.

public, protected, ve private sözcüklerinin anlamları için Görünürlük belgesine bakınız.

Bilginize:

PHP 4 ile geriye uyumluluğu sağlamak için, PHP 5 özellik bildiriminde public, protected, veya private yerine (veya ek olarak) hala var sözcüğü kabul edilmektedir. Ancak, var artık gerekli değildir. PHP'nin 5.0'dan 5.1.3'e kadar olan sürümlerinde, var kullanımı önerilmeyen kullanım olarak ele alınır ve bir E_STRICT uyarısı çıktılanırdı; PHP 5.1.3'ten beri önerilmeme durumu ortadan kalkmış olup bir uyarı çıktılanmamaktadır.

Bir özelliği public, protected, veya private yerine var kullanarak bildirirseniz PHP 5 özelliği public olarak bildirilmiş gibi ele alır.

Özelliklere, sabitlere ve yöntemlere sınıf yöntemleri içinden erişilirken yöntem duruk ise self::$özellik, değilse $this- >özellik sözdizimi kullanılabilir (burada "özellik" özelliğin ismidir). Daha ayrıntılı bilgi için static Anahtar Sözcüğü bölümüne bakınız.

Yöntem bir nesne bağlamından çağrılıyorsa $this sözde değişkeni sınıf yöntemleri içinde de kullanılabilir. $this, yöntemi çağıran nesneye (yöntemin ait olduğu nesneye) bir gönderimdir. Fakat yöntem, bir ikincil nesne bağlamından duruk olarak çağrılıyorsa, bu, birincil nesne de olabilir.

Örnek 1 - Özellik bildirimi

<?php
class SimpleClass
{
   // geçersiz özellik bildirimleri:
   public $var1 = 'hello ' . 'world';
   public $var2 = <<<EOD
hello world
EOD;
   public $var3 = 1+2;
   public $var4 = self::myStaticMethod();
   public $var5 = $myVar;

   // geçerli özellik bildirimleri:
   public $var6 = myConstant;
   public $var7 = array(true, false);

   // Buna sadece PHP 5.3.0 ve sonrasında izin verilir.
   public $var8 = <<<'EOD'
hello world
EOD;
}
?>

Bilginize:

Sınıflar ve nesnelerle çalışan bazı işlevler vardır. Bunlar için Sınıf ve Nesne İşlevleri bölümüne bakınız.

Yorumsuz metinler, yorumlu metinlerin tersine özellik bildirimleri dahil herhangi bir duruk veri bağlamında kullanılabilir.

Örnek 2 - Özellik ilklendirmede yorumsuz metin kullanımı

<?php
class foo {
   // PHP 5.3.0'dan beri
   public $bar = <<<'EOT'
bar
EOT;
}
?>

Bilginize:

Yorumsuz metin desteği PHP 5.3.0'da eklenmiştir.

Temel Kavramlar
Sınıf Sabitleri
Sınıflar ve Nesneler


Sınıf Sabitleri

Sabitlerin her sınıf için ayrı ayrı tanımlanabilmesi mümkündür. Sabitler diğer değişkenlerden tanımlanmaları ve kullanılmaları sırasında başlarına getirilmeyen $ imi sayesinde ayrılırlar.

Değer, örneğin, bir değişken, bir sınıf özelliği, bir matematiksel işlemin sonucu veya bir işlev çağrısı değil, bir sabit ifade olmalıdır.

Ayrıca, sınıf arayüzlerinin de kendi sabitlerinin olması mümkündür. Örnekler için Nesne Arayüzleri belgesine bakınız.

PHP 5.3.0'dan itibaren, bir sınıfa bir değişken kullanarak atıfta bulunmak mümkündür. Değişkenin değeri, self, parent, static gibi bir anahtar sözcük olamaz.

Örnek 1 - Bir sabitin tanımlanması ve kullanımı

<?php
class MyClass
{
    const constant = 'sabit değer';

    function showConstant() {
        echo  self::constant . "\n";
    }
}

echo MyClass::constant . "\n";

$classname = "MyClass";
echo $classname::constant . "\n"; // PHP 5.3.0'dan itibaren

$class = new MyClass();
$class->showConstant();

echo $class::constant."\n"; // PHP 5.3.0'dan itibaren
?>

Örnek 2 - Duruk veri örneği

<?php
class foo {
    // PHP 5.3.0'dan itibaren
    const bar = <<<'EOT'
bar
EOT;
}
?>

Duruk veri bağlamında yorumlanan çok satırlı metinler değil (heredoc), yorumlanmayan çok satırlı metinler (nowdoc) kullanılabilir.

Bilginize:

Yorumlanmayan çok satırlı metin (nowdoc) desteği 5.3.0'da eklenmiştir.

Özellikler
Özdevinimli Sınıf Yükleme
Sınıflar ve Nesneler


Özdevinimli Sınıf Yükleme

Nesne-yönelimli uygulama yazan birçok geliştirici, her bir sınıf tanımı için ayrı bir PHP kaynak dosyası oluşturmaktadır. Bu kullanımın en can sıkıcı noktalarından bir tanesi, betiklerin en tepesinde bir sürü dosyanın betiğe dahil edilmesini gerektirmesidir (her bir sınıf için ayrı bir dosya).

PHP 5 ile birlikte bu durum zorunluluk olmaktan çıkmıştır. Henüz tanımlanmamış bir sınıfı özdevinimli olarak çağırmak istediğinizde, bir __autoload işlevi tanımlayabilirsiniz. Bu işlevi çağırmakla PHP'nin çalışması hata ile sonuçlanmadan önce betik yorumlama motoruna sınıfı yüklemek için son bir şans verilmiş olur.

Bilginize:

5.3.0 öncesinde, __autoload işlevinde oluşan istisnalar catch bloğu ile yakalanamaz, dolayısıyla ölümcül hata ile sonuçlanır. 5.3.0 ve sonrasında ise, bir tane olması şartıyla yakalanabilir. Özel bir istisna yakalanacaksa özel istisna sınıfı mevcut olmalıdır. __autoload işlevi özel istisna sınıflarını ardışık (iç içe) olarak yüklemek için kullanılabilir.

Bilginize:

PHP CLI'yi etkileşimli kipte kullanıyorsanız özdevinimli yükleme kullanılamayacaktır.

Bilginize:

Sınıf ismini call_user_func() gibi bir işlevde kullanırsanız ../ gibi bazı tehlikeli karakterler içerebilir. Böyle işlevlerde kullanıcı girdilerini kullanmamanız ya da en azından girdiyi __autoload() ile doğrulamanızı öneririz.

Örnek 1 - Özdevinimli yükleme örneği

Bu örnek MyClass1 ve MyClass2 sınıflarını yüklemeye çalışmaktadır. Sınıflar aynı isimli MyClass1.php ve MyClass2.php dosyalarının içinde yer almaktadırlar.

<?php
function __autoload($class_name) {
    require_once $class_name . '.php';
}

$obj  = new MyClass1();
$obj2 = new MyClass2();
?>

Örnek 2 - Başka bir özdevinimli yükleme örneği

Bu örnek DenemeA arayüzünü yüklemeye çalışır.

<?php

function __autoload($isim) {
    var_dump($isim);
}

class Fan implements DenemeA {
}

/*
string(5) "DenemeA"

Fatal error: Interface 'DenemeA' not found in ...
*/
?>

Örnek 3 - 5.3.0 ve sonrasında istisnalı özdevinimli yükleme

Bu örnekte bir istisna yakalanmakta ve try/catch kullanımı gösterilmektedir.

<?php
function __autoload($name) {
    echo "$name yüklenmek isteniyor.\n";
    throw new Exception("$name yüklenemedi.");
}

try {
    $obj = new YüklenemezSınıf();
} catch (Exception $e) {
    echo $e->getMessage(), "\n";
}
?>

Yukarıdaki örneğin çıktısı:

YüklenemezSınıf yüklenmek isteniyor.
YüklenemezSınıf yüklenemedi.

Örnek 4 Autoloading with exception handling for 5.3.0+ - Missing custom exception

This example throws an exception for a non-loadable, custom exception.

<?php
function __autoload($name) {
    echo "Want to load $name.\n";
    throw new MissingException("Unable to load $name.");
}

try {
    $obj = new NonLoadableClass();
} catch (Exception $e) {
    echo $e->getMessage(), "\n";
}
?>

Yukarıdaki örneğin çıktısı:

Want to load NonLoadableClass.
Want to load MissingException.

Fatal error: Class 'MissingException' not found in testMissingException.php on line 4

Ayrıca Bakınız

  • unserialize()
  • unserialize_callback_func
  • spl_autoload()
  • spl_autoload_register()

Sınıf Sabitleri
Kurucular ve Yıkıcılar
Sınıflar ve Nesneler


Kurucular ve Yıkıcılar

Kurucular

void __construct ([ mixed $değiştirge [, $... ]] )

PHP 5 geliştiricilerin sınıflar için kurucu yöntemler bildirmesine imkan verir. Bir kurucu yöntemi olan sınıflar her yeni nesne oluşturuluşunda bu yöntemi çağırırlar, bu bakımdan nesne kullanılmadan önce yapılması gereken ilklendirmeler için kurucular çok uygundur.

Bilginize: Çocuk sınıflardan kurucusu olanlar için örtük olarak ebeveyn sınıfın kurucusu çağrılmaz. Ebeveyn sınıfın kurucusunu çocuk sınıftan çağırmak için, çocuk sınıf içinden parent::__construct() çağrısı yapılması gerekir.

Örnek 1 - Yeni tekilleşmiş kurucuların kullanımı

<?php
class AnaSınıf {
   function __construct() {
       print "AnaSınıf kurucusundayız\n";
   }
}

class AltSınıf extends AnaSınıf {
   function __construct() {
       parent::__construct();
       print "AltSınıf kurucusundayız\n";
   }
}

$obj = new AnaSınıf();
$obj = new AltSınıf();
?>

Geriye dönük uyumluluk için, PHP 5 belirtilen sınıfa ait bir __construct() yöntemi bulamazsa, sınıfın ismine bakarak eski tarz bir kurucu arayacaktır. Dolayısıyla, uyumluluk sorunu yaşayacağınız tek durum sınıf dahilinde __construct() isimli bir yöntemin amacı dışında kullanılması olabilir.

Diğer yöntemlerin tersine, __construct() ebeveyn __construct() yöntemindekilerden farklı değiştirgelerle kullanılmaya çalışıldığında PHP E_STRICT seviyesinden bir hata iletisi üretmeyecektir.

PHP 5.3.3 itibariyle, bir isim alanlı sınıf isminin son elemanı ile aynı isimdeki yöntemler artık kurucu olarak ele alınmayacaktır. Bu değişiklik isim alanlı olmayan sınıfları etkilemez.

Örnek 2 - İsim alanlı sınıflarda kurucular

<?php
namespace Foo;
class Bar
{
    public function Bar()
    {
        // PHP 5.3.0-5.3.2'de kurucu olarak ele alınır
        // PHP 5.3.3 itibariyle sıradan bir yöntem olarak ele alınır
    }
}
?>

Yıkıcılar

void __destruct ( void )

PHP 5, C++ gibi nesne yönelimli dillerdekine benzer bir yıkıcı tasarımına sahiptir. Yıkıcı yöntem, belli bir nesneye başka bir gönderim yoksa veya nesne kapanma sırasında açıkça yok edildiği anda çalıştırılacaktır.

Örnek 3 - Yıkıcı Örneği

<?php
class YıkıcıSınıf
{
   function __construct()
   {
       print "Kurucu çalıştı\n";
       $this->name = "YıkıcıSınıf";
   }

   function __destruct()
   {
       print "" . $this->name . " yok ediliyor\n";
   }
}

$obj = new YıkıcıSınıf();
?>

Kurucularda olduğu gibi ebeveyn yıkıcılar çocuk sınıflar için dolaylı olarak çağrılmayacaktır. Ebeveyn sınıfın yıkıcısının çalışması için çocuk sınıfın yıkıcısından parent::__destruct() çağrısının yapılması gerekir.

Betiğin icrası exit() kullanılarak durdurulsa bile yıkıcı çağrılacaktır. exit() işlevinin bir yıkıcı içersinde çağrılması kalan kapanma yordamlarının icrasını engelleyecektir.

Bilginize:

Yıkıcılar, HTTP başlıklarının gönderilmiş olmasını sağlamak için betik sonlanırken çağrılırlar. Betiğin kapanma aşamasındaki çalışma dizini bazı SAPI'lerde (Apache gibi) farklı olabilir.

Bilginize:

Bir yıkıcı içinden bir istisna oluşturmaya çalışmak (betiğin sonlandırılması sırasında) ölümcül hata ile sonuçlanır.

Özdevinimli Sınıf Yükleme
Görünürlük
Sınıflar ve Nesneler


Görünürlük

Bir özelliğin ya da bir yöntemin görünürlüğü, bildirim sırasında önüne şu anahtar sözcüklerden biri getirilerek belirlenebilir: public, protected ya da private. public olarak bildirilmiş özelliklere ve yöntemlere her yerden erişilebilir. protected bildirimli özelliklere ve yöntemlere sadece miras alınmış ve ebeveyn sınıflardan (ve özelliğin tanımlandığı nesneden), private bildirimli özelliklere ve yöntemlere ise sadece özelliğin tanımlandığı sınıfın içinden erişilebilir.

Özelliklerin Görünürlüğü

Sınıf özellikleri public, protected ya da private olarak tanımlanmalıdır. Bir özellik bunlardan biri olmadan sadece var kullanarak bildirilmişse public olarak bildirilmiş gibi ele alınır.

Örnek 1 - Özellik bildirimi

<?php
/**
 * Sınıfım tanımı
 */
class Sınıfım
{
    public $genel = 'Genel';
    protected $korumalı = 'Korumalı';
    private $özel = 'Özel';

    function selamVer()
    {
        echo $this->genel;
        echo $this->korumalı;
        echo $this->özel;
    }
}

$nesne = new Sınıfım();
echo $nesne->genel;    // Çalışır
echo $nesne->korumalı; // Ölümcül Hata
echo $nesne->özel;     // Ölümcül Hata
$nesne->selamVer();    // Genel, Korumalı ve Özel görüntüler

/**
 * ÖbürSınıfım tanımı
 */
class ÖbürSınıfım extends Sınıfım
{
    // public ve protected yöntemleri yeniden tanımlayabiliriz,
    // ancak private olanlar tanımlanamaz
    protected $korumalı = 'Öbür korumalı';

    function selamVer()
    {
        echo $this->genel;
        echo $this->korumalı;
        echo $this->özel;
    }
}

$nesne2 = new ÖbürSınıfım();
echo $nesne2->genel;    // Çalışır
echo $nesne2->özel;     // Tanımsız
echo $nesne2->korumalı; // Ölümcül Hata
$nesne2->selamVer();    // Genel, Öbür korumalı ve Undefined görüntülenir

?>

Bilginize: PHP 4'te bir değişken bildiriminde (public yerine) kullanılan var anahtar sözcüğü uyumluluk adına hala desteklenmektedir. PHP 5'in 5.1.3 sürümünden önceki sürümlerinde var kullanımı bir E_STRICT uyarısına sebep olurdu.

Yöntem Görünürlüğü

Sınıf yöntemleri public, protected ya da private olarak tanımlanmalıdır. Bunlardan herhangi biri kullanılmadan yapılmış yöntem tanımlarının public kullanılarak tanımlandığı varsayılır.

Örnek 2 - Yöntem bildirimi

<?php
/**
 * Sınıfım tanımı
 */
class Sınıfım
{
    // public kurucu bildirimi
    public function __construct() { }

    // public yöntem bildirimi
    public function Genel() { }

    // protected yöntem bildirimi
    protected function Korumalı() { }

    // private yöntem bildirimi
    private function Özel() { }

    // Bu da public bir yöntem
    function Falanca()
    {
        $this->Genel();
        $this->Korumalı();
        $this->Özel();
    }
}

$sınıfım = new Sınıfım;
$sınıfım->Genel();    // Çalışır
$sınıfım->Korumalı(); // Ölümcül Hata
$sınıfım->Özel();     // Ölümcül Hata
$sınıfım->Falanca();  // Public, Protected ve Private çalisir

/**
 * ÖbürSınıfım tanımı
 */
class ÖbürSınıfım extends Sınıfım
{
    // Bu public bir yöntemdir
    function Filanca()
    {
        $this->Genel();
        $this->Korumalı();
        $this->Özel();  // Ölümcül Hata
    }
}

$öbürSınıfım = new Sınıfım;
$öbürSınıfım->Genel();   // Çalışır
$öbürSınıfım->Filanca(); // Genel ve Korumalı çalışır, Özel çalışmaz

class Bar
{
    public function dnm() {
        $this->dnmÖzel();
        $this->dnmGenel();
    }

    public function dnmGenel() {
        echo "Bar::dnmGenel\n";
    }

    private function dnmÖzel() {
        echo "Bar::dnmÖzel\n";
    }
}

class Foo extends Bar
{
    public function dnmGenel() {
        echo "Foo::dnmGenel\n";
    }

    private function dnmÖzel() {
        echo "Foo::dnmÖzel\n";
    }
}

$fo = new Foo();
$fo->dnm();  // Bar::dnmÖzel
             // Foo::dnmGenel

?>

Kurucular ve Yıkıcılar
Nesnelerin Kalıtımı
Sınıflar ve Nesneler


Nesnelerin Kalıtımı

Kalıtım iyi kurgulanmış bir programlama prensibidir ve PHP bu prensibi kendi nesne modelinde kullanır. Bu prensip çoğu sınıf ve nesnenin bir diğeri ile ilişkisini düzenler.

Örneğin, bir sınıfı (extend ile) genişlettiğinizde alt sınıf üst sınıftaki genel ve korunmuş yöntemlerin tümünü miras alır. Bir sınıf bu yöntemleri aynı isimdeki yöntemlerle geçersizleştirmedikçe bunlar özgün işlevselliklerini korur.

Bu, işlevselliği tanımlamak ve soyutlamak için ve paylaşılan işlevselliğin tamamını yeni baştan gerçeklemeksizin benzer nesnelerde ek işlevsellikleri gerçeklemek için kullanışlıdır.

Bilginize:

Özdevinimli yükleme kullanılmadıkça, sınıflar kullanılmadan önce tanımlanmalıdır. Eğer bir sınıf diğerini genişletiyorsa ebeveyn sınıf çocuk sınıfın yapısı kurulmadan önce bildirilmiş olmalıdır. Bu kural diğer sınıfları ve arayüzleri miras alan tüm sınıflara uygulanır.

Örnek 1 Kalıtım Örneği

<?php

class Foo
{
    public function printItem($string)
    {
        echo 'Foo: ' . $string . PHP_EOL;
    }

    public function printPHP()
    {
        echo 'PHP is great.' . PHP_EOL;
    }
}

class Bar extends Foo
{
    public function printItem($string)
    {
        echo 'Bar: ' . $string . PHP_EOL;
    }
}

$foo = new Foo();
$bar = new Bar();
$foo->printItem('baz'); // Çıktısı: 'Foo: baz'
$foo->printPHP();       // Çıktısı: 'PHP is great'
$bar->printItem('baz'); // Çıktısı: 'Bar: baz'
$bar->printPHP();       // Çıktısı: 'PHP is great'

?>
Görünürlük
Etki Alanı Çözünürlük İşleci (::)
Sınıflar ve Nesneler


Etki Alanı Çözünürlük İşleci (::)

Etki Alanı Çözünürlük İşleci (Paamayim Nekudotayim de denirmiş), basitçe bir çift iki nokta iminden ibaret olup (biz "iki nokta çifti" diyebiliriz), bir sınıfın duruk, sabit ve geçersiz kılınmış özellik ve yöntemlerine erişilebilmesini sağlayan bir simgedir.

Bu öğelere sınıf tanımının dışından erişirken bu işlecin solunda sınıfın ismini kullanın.

PHP 5.3.0 ve sonrasında, bu işlecin solunda sınıf ismi yerine bir değişken kullanmak da mümkündür. Değişken ismi, (self, parent, static gibi) bir anahtar sözcük olmamalıdır.

"Paamayim Nekudotayim" ilk bakışta iki nokta üst üste için garip bir adlandırma gibi gözükebilir. Ancak, Zend Engine 0.5 (php 3'ün kalbidir) yazıldığı esnada Zend ekibinin kullanmak istediği terim bu oldu. Esasında bu iki sözcük de iki nokta çifti anlamına gelmektedir - İbranice'de!

Örnek 1 - Sınıf tanımı dışında ::

<?php
class Sınıfım {
    const SABİT_DEĞER = 'Bir sabit değer';
}

echo Sınıfım::SABİT_DEĞER;
?>

Bir sınıfın özellik ve yöntemlerine bu işleç sayesinde sınıfın içinden erişilmek istendiğinde işlecin solunda self veya parent anahtar sözcüğü kullanılır.

Örnek 2 - Sınıf tanımı içinde ::

<?php
class BaşkaSınıf extends Sınıfım
{
    public static $duruk = 'Bir duruk değişken';

    public static function ikiNoktaÇifti() {
        echo parent::SABİT_DEĞER . "\n";
        echo self::$duruk . "\n";
    }
}

$sınıfadı = 'BaşkaSınıf';
echo $sınıfadı::ikiNoktaÇifti(); // PHP 5.3.0 ve sonrası

BaşkaSınıf::ikiNoktaÇifti();
?>

Çocuk sınıf ebeveyninin yöntem tanımlarından birini geçersiz kıldığı takdirde PHP ebeveyne ait yöntemi çağıramayacaktır. Ebeveynin yönteminin çağrılıp çağrılmayacağı çocuk sınıfın inisiyatifindedir. Bu durum aynı zamanda Kurucular ve Yıkıcılar, Aşırı Yükleme ve Sihirli yöntem tanımları için de geçerlidir.

Örnek 3 - Ebeveynin yöntemini çağırmak

<?php
class Sınıfım
{
    protected function işlevim() {
        echo "Sınıfım::işlevim()\n";
    }
}

class BaşkaSınıf extends Sınıfım
{
    // Ebeveynin tanımını geçersiz kılalım
    public function işlevim()
    {
        // Ama hala ebeveynin işlevini çağırabiliriz
        parent::işlevim();
        echo "BaşkaSınıf::işlevim()\n";
    }
}

$class = new BaşkaSınıf();
$class->işlevim();
?>
Nesnelerin Kalıtımı
static Anahtar Sözcüğü
Sınıflar ve Nesneler


static Anahtar Sözcüğü

Sınıf özelliklerinin ya da yöntemlerinin static olarak tanımlanması, o özelliklerin ve yöntemlerin sınıf örneğinin oluşturulmasına gerek kalmadan erişilebilir olmalarını sağlar. Ancak, static olarak bildirilmiş bir özelliğe (duruk özellik) örneklenmiş sınıf nesnesinden erişilemez (ise de static olarak bildirilmiş bir yöntemle erişebilir).

PHP 4 ile uyumluluğun sağlanabilmesi için, eğer bir özellik veya yöntem için hiçbir görünürlük tanımı yapılmamışsa public olarak tanımlanmış varsayılır.

Duruk yöntemlerin, nesnenin bir örneği oluşturulmadan erişilebilir olmalarından dolayı, $this sözde değişkeni, static olarak bildirilmiş bir yöntemin içinde kullanılamaz.

Duruk özelliklere, nesne üzerinden ok işleci (->) kullanılarak erişilemez.

Duruk olmayan özellikler durukmuş gibi çağrılırsa E_STRICT seviyesinde bir uyarı üretilir.

PHP'nin diğer duruk değişkenlerinde olduğu gibi duruk özellikler de sadece bir sayıl veya sabit kullanılarak ilklendirilebilir; ifadelere izin verilmez. Yani, bir duruk özelliği örneğin, bir tamsayı veya bir dizi ile ilklendirebilirsiniz ama örneğin, bir işlevin dönen değeri, bir değişken veya bir nesne ile ilklendiremezsiniz.

PHP 5.3.0 ve sonrasında, bir sınıfa bir değişken kullanarak gönderim yapılabilmektedir. Böyle bir değişkenin değeri self, parent veya static gibi bir anahtar sözcük olamaz.

Örnek 1 - Duruk özellik örneği

<?php
class Falanca
{
    public static $duruk = 'falanca';

    public function durukDeğer() {
        return self::$duruk;
    }
}

class Feşmekan extends Falanca
{
    public function falancaDuruk() {
        return parent::$duruk;
    }
}

print Falanca::$duruk . "\n";

$falanca = new Falanca();
print $falanca->durukDeğer() . "\n";
print $falanca->duruk . "\n";      // Tanımsız "Özellik" duruk

print $falanca::$duruk . "\n";
$sınıfadı = 'Falanca';
print $sınıfadı::$duruk . "\n"; // PHP 5.3.0 ve sonrası

print Feşmekan::$duruk . "\n";
$feşmekan = new Feşmekan();
print $feşmekan->falancaDuruk() . "\n";
?>

Örnek 2 - Duruk yöntem örneği

<?php
class Falanca {
    public static function birDurukYöntem() {
        // ...
    }
}

Falanca::birDurukYöntem();
$sınıfadı = 'Falanca';
$sınıfadı::birDurukYöntem(); // PHP 5.3.0 ve sonrası

?>
Etki Alanı Çözünürlük İşleci (::)
Sınıf Soyutlama
Sınıflar ve Nesneler


Sınıf Soyutlama

PHP 5, soyut sınıf ve yöntemlerin kullanımını mümkün kılmıştır. Soyut olarak tanımlanmış bir sınıftan örnek oluşturmaya izin verilmemektedir. Bir sınıf en az bir soyut yöntem içeriyorsa, o sınıf da soyut olarak tanımlanmalıdır. Soyut olarak tanımlanmış yöntemler o yöntemlerin imzasıdırlar, gerçeklemenin bütününü temsil edemezler.

Soyut bir sınıftan kalıtsal özellikler devralınırken, ebeveyn sınıf bildiriminde soyut olarak bildirilmiş tüm yöntemlerin çocuk sınıf tarafından da tanımlanması gerekir. Ek olarak, bu yöntemlerin aynı (ya da daha az sınırlı) görünürlükle tanımlanması gerekir. Örneğin, soyut yöntem protected olarak tanımlanmışsa, işlev gerçeklenimi private değil, protected ya da public olarak tanımlanmalıdır.

Örnek 1 - Soyut sınıf örneği

<?php
abstract class SoyutSınıf
{
    // Genişletilen sınıfı bu yöntemi tanımlamaya zorla
    abstract protected function değeriAl();
    abstract protected function önekDeğeri($önek);

    // Ortak yöntem
    public function yazdır() {
        print $this->değeriAl() . "\n";
    }
}

class SomutSınıf1 extends SoyutSınıf
{
    protected function değeriAl() {
        return "SomutSınıf1";
    }

    public function önekDeğeri($önek) {
        return "{$önek}SomutSınıf1";
    }
}

class SomutSınıf2 extends SoyutSınıf
{
    public function değeriAl() {
        return "SomutSınıf2";
    }

    public function önekDeğeri($önek) {
        return "{$önek}SomutSınıf2";
    }
}

$class1 = new SomutSınıf1;
$class1->yazdır();
echo $class1->önekDeğeri('FOO_') ."\n";

$class2 = new SomutSınıf2;
$class2->yazdır();
echo $class2->önekDeğeri('FOO_') ."\n";
?>

Yukarıdaki örneğin çıktısı:

SomutSınıf1
FOO_SomutSınıf1
SomutSınıf2
FOO_SomutSınıf2

Kullanıcı tanımlı sınıfları veya 'abstract' isimli işlevleri olmayan eski kodun bir değişikliğe gerek duyulmadan çalışabilmesi gerekir.

static Anahtar Sözcüğü
Nesne Arayüzleri
Sınıflar ve Nesneler


Nesne Arayüzleri

Nesne arayüzleri, bir sınıfın gerçeklemesi gereken yöntemlerin belirtildiği kodu, bu yöntemlerin nasıl yönetileceğini tanımlamaksızın oluşturmanıza imkan sağlar.

Arayüzler, standart sınıflardan farklı olarak hiçbir yöntemin içeriği tanımlanmaksızın interface anahtar sözcüğü kullanılarak tanımlanırlar.

Bir arayüzdeki tüm yöntemler, arayüzün doğası gereği public olarak bildirilmelidir.

implements işleci

Bir arayüzü gerçeklemek için, implements işleci kullanılır. Arayüzdeki tüm yöntemler bir sınıf içersinde gerçeklenmelidir; aksi takdirde bir ölümcül hata alırsınız. Bir sınıfın, birden fazla arayüz tanımlaması arayüzler virgülle ayrılarak sağlanabilir.

Bilginize:

Belirsizliğe yol açacağından, bir sınıf aynı işlev isimlerine sahip iki arayüz gerçekleyemez.

Bilginize:

Arayüzler, sınıflar gibi extends işleciyle genişletilebilir.

Bilginize:

Bir arayüzü tanımlayan bir sınıf, bunu arayüzde tanımlı yöntemleri kullanarak yapmalıdır, yoksa işlem ölümcül hata ile sonuçlanır.

Sabitler

Arayüzlerin sabitlerinin olması mümkündür. Arayüz sabitleri tıpkı sınıf sabitleri gibi çalışırlar. Kendilerini miras alan sınıflar veya arayüzler tarafından geçersiz kılınamazlar.

Örnekler

Örnek 1 - Arayüz örneği

<?php
// 'iTemplate' arayüzünü tanımlayalım
interface iTemplate
{
    public function setVariable($name, $var);
    public function getHtml($template);
}

// Arayüzü gerçekleyelim
// Bu çalışacaktır
class Template implements iTemplate
{
    private $vars = array();

    public function setVariable($name, $var)
    {
        $this->vars[$name] = $var;
    }

    public function getHtml($template)
    {
        foreach($this->vars as $name => $value) {
            $template = str_replace('{' . $name . '}', $value, $template);
        }

        return $template;
    }
}

// Bu çalışmayacaktır
// Ölümcül hata: BadTemplate sınıfı 1 soyut yöntem içermektedir
// dolayısıyla soyut olarak tanımlanması gerekir (iTemplate::getHtml)
class BadTemplate implements iTemplate
{
    private $vars = array();

    public function setVariable($name, $var)
    {
        $this->vars[$name] = $var;
    }
}

?>

Örnek 2 - Genişletilebilir Arayüzler

<?php
interface a
{
    public function foo();
}

interface b extends a
{
    public function baz(Baz $baz);
}

// Bu çalışır
class c implements b
{
    public function foo()
    {
    }

    public function baz(Baz $baz)
    {
    }
}

// Bu çalışmaz, ölümcül hatayla sonuçlanır
class d implements b
{
    public function foo()
    {
    }

    public function baz(Foo $foo)
    {
    }
}
?>

Örnek 3 - Çok sayıda anayüz oluşturma

<?php
interface a
{
    public function foo();
}

interface b
{
    public function bar();
}

interface c extends a, b
{
    public function baz();
}

class d implements c
{
    public function foo()
    {
    }

    public function bar()
    {
    }

    public function baz()
    {
    }
}
?>

Örnek 4 - Arayüzler ve sabitleri

<?php
interface a
{
    const b = 'Arayüz sabiti';
}

// Şunu basar: Arayüz sabiti
echo a::b;

// Sabitler geçersiz kılınamayacağından bu çalışmaz.
// Sınıf sabitleri için de bu böyledir.
class b implements a
{
    const b = 'Sınıf sabiti';
}
?>

Bir arayüz tür dayatarak belli bir nesnenin belli yöntemleri içermesini sağlayabilir. Ayrıca bakınız: instanceof işleci ve Tür Dayatma.

Sınıf Soyutlama
Nitelikler
Sınıflar ve Nesneler


Nitelikler

PHP 5.4.0 itibariyle, PHP tekrar tekrar kullanılabilen bir yöntem kodu olarak trait isminı kullanarak nitelikleri tanımlamıştır.

Nitelikler, PHP gibi tek kalıtımlı dillerde kodun yeniden kullanımını sağlayan bir mekanizmadır. Yöntem kümelerini farklı sınıf hiyerarşilerinde yaşayan birçok bağımsız sınıfın içinde özgürce yeniden kullanımını mümkün kılarak tek kalıtımlı dillerdeki bazı sınırlamaları azaltmak için tasarlanmıştır. Sınıfların ve niteliklerin birleşiminden doğan anlamlılık, karmaşıklığı azaltan ve çoklu kalıtım ve iç içeliklerle ilgili bilinen sorunlardan kaçınan bir yol izlenerek tanımlanmıştır.

Nitelikler sınıflara benzemekle birlikte işlevselliği gruplamak için daha bir ince elenip sık dokunarak tasarlanmıştır. Bir niteliği kendi içinde örneklemek mümkün değildir. Geleneksel kalıtıma bir ekleme olup yatay davranış düzenini, yani kalıtım gerekmeksizin sınıf üyesi olmayı mümkün kılar.

Örnek 1 Nitelik örneği

<?php
trait ezcReflectionReturnInfo {
    function getReturnType() { /*1*/ }
    function getReturnDescription() { /*2*/ }
}

class ezcReflectionMethod extends ReflectionMethod {
    use ezcReflectionReturnInfo;
    /* ... */
}

class ezcReflectionFunction extends ReflectionFunction {
    use ezcReflectionReturnInfo;
    /* ... */
}
?>

Öncelik sırası

Bir nitelikle gelen bir üye, bir temel sınıftan miras alınan bir üyenin yerine geçerse onu geçersiz kılar; sınıfın kendi üyeleri de niteliğin yerine geçerse onu geçersiz kılar.

Örnek 2 Öncelik sırası örneği

Temel sınıftan miras alınan yöntem, DünyaDe niteliğinden MerhabaDünyam içine yerleştirilen üye tarafından geçersizleştirilmektedir. MerhabaDünyam sınıfı içinde tanımlı yöntemler için de davranış aynıdır. Öncelik sırası şöyledir: Temel sınıftan alınan yöntemleri geçersizleştiren nitelikleri geçerli sınıfın yöntemleri geçersizleştirir.

<?php
class Temel {
    public function merhabaDe() {
        echo 'Merhaba ';
    }
}

trait DünyaDe {
    public function merhabaDe() {
        parent::merhabaDe();
        echo 'Dünya!';
    }
}

class MerhabaDünyam extends Temel {
    use DünyaDe;
}

$o = new MerhabaDünyam();
$o->merhabaDe();
?>

Yukarıdaki örneğin çıktısı:

Merhaba Dünya!

Örnek 3 Bir diğer öncelik sırası örneği

<?php
trait MerhabaDünya {
    public function merhabaDe() {
        echo 'Merhaba Dünya!';
    }
}

class DünyaYetmez {
    use MerhabaDünya;
    public function merhabaDe() {
        echo 'Merhaba Evren!';
    }
}

$o = new DünyaYetmez();
$o->merhabaDe();
?>

Yukarıdaki örneğin çıktısı:

Merhaba Evren!

Çoklu Nitelikler

Çok sayıda nitelik bir sınıfın içine use deyiminde virgüllerle ayrılarak yerleştirilebilir.

Örnek 4 Çok sayıda niteliğin kullanımı

<?php
trait Merhaba {
    public function merhabaDe() {
        echo 'Merhaba ';
    }
}

trait Dünya {
    public function dünyaDe() {
        echo 'Dünya';
    }
}

class MerhabaDünyam {
    use Merhaba, Dünya;
    public function Bağır() {
        echo '!';
    }
}

$o = new MerhabaDünyam();
$o->merhabaDe();
$o->dünyaDe();
$o->Bağır();
?>

Yukarıdaki örneğin çıktısı:

Merhaba Dünya!

Çelişki Çözümleme

Bir yönteme aynı isme sahip iki nitelik yerleştirilirse çelişki açıkça çözümlenmediği takdirde ölümcül bir hataya sebep olur.

Aynı sınıfta kullanılan nitelikler arasındaki adlandırma çakışmasını çözümlemek için insteadof işleci birini seçmek amacıyla kullanılabilir.

Bu işlem niteliklerin birini dışlamayı sağladığından diğerini de farklı bir isimle içermek için as işleci kullanılabilir.

Örnek 5 Çelişki çözümleme örneği

Bu örnekte, Talker A ve B niteliklerini kullanıyor. A ve B çakışan yöntemlere sahip olduğundan B niteliğinden smallTalk ve A niteliğinden bigTalk kullanılmaktadır.

Aliased_Talker ise B'nin bigTalk gerçeklenimini talk diye bir takma ad altında kullanmak için as işlecinden yararlanmaktadır.

<?php
trait A {
    public function smallTalk() {
        echo 'a';
    }
    public function bigTalk() {
        echo 'A';
    }
}

trait B {
    public function smallTalk() {
        echo 'b';
    }
    public function bigTalk() {
        echo 'B';
    }
}

class Talker {
    use A, B {
        B::smallTalk insteadof A;
        A::bigTalk insteadof B;
    }
}

class Aliased_Talker {
    use A, B {
        B::smallTalk insteadof A;
        A::bigTalk insteadof B;
        B::bigTalk as talk;
    }
}
?>

Yöntem Görünürlüğünü Değiştirme

Sergileyen sınıf içinde yöntemin görünürlüğünü ayarlamak için as sözdizimi kullanılabilir.

Örnek 6 Yöntem görünürlüğünü değiştirme örneği

<?php
trait MerhabaDünya {
    public function merhabaDe() {
        echo 'Merhaba Dünya!';
    }
}

// merhabaDe görünürlüğünü değiştir
class Sınıfım1 {
    use MerhabaDünya { merhabaDe as protected; }
}

// Görünürlüğü ve ismi değişmiş yöntem
// merhabaDe görünürlüğü değişmedi
class Sınıfım2 {
    use MerhabaDünya { merhabaDe as private özelMerhabam; }
}
?>

Niteliklerden oluşturulmuş Nitelikler

Sınıflarda olduğu gibi nitelikler de bir diğerinin içinde kullanılabilir. Birden fazla nitelik kısmen veya tamamen bir diğer niteliğin içinde kullanılabilir.

Örnek 7 Niteliklerden nitelik oluşturma örneği

<?php
trait Merhaba {
    public function merhabaDe() {
        echo 'Merhaba ';
    }
}

trait Dünya {
    public function dünyaDe() {
        echo 'Dünya!';
    }
}

trait MerhabaDünya {
    use Merhaba, Dünya;
}

class MerhabaDünyam {
    use MerhabaDünya;
}

$o = new MerhabaDünyam();
$o->merhabaDe();
$o->dünyaDe();
?>

Yukarıdaki örneğin çıktısı:

Merhaba Dünya!

Soyut Nitelik Yöntemleri

Nitelikler, sergileyen sınıfa gereksinimleri aşılamak amacıyla yöntem soyutlamayı destekler.

Örnek 8 Gereksinimlerin soyut yöntemlerle ifadesi

<?php
trait Merhaba {
    public function merhabaDünyaDe() {
        echo 'Merhaba'.$this->dünyaGetir();
    }
    abstract public function dünyaGetir();
}

class MerhabaDünyam {
    private $dünya;
    use Merhaba;
    public function dünyaGetir() {
        return $this->dünya;
    }
    public function dünyaAta($val) {
        $this->dünya = $val;
    }
}
?>

Duruk Nitelik Yöntemleri

Nitelikler hem duruk üyeleri hem de duruk yöntemleri tanımlayabilir.

Örnek 9 Duruk Değişkenler

<?php
trait Sayaç {
    public function arttır() {
        static $c = 0;
        $c = $c + 1;
        echo "$c\n";
    }
}

class C1 {
    use Sayaç;
}

class C2 {
    use Sayaç;
}

$o = new C1(); $o->arttır(); // 1 basar
$p = new C2(); $p->arttır(); // 1 basar
?>

Örnek 10 Duruk Yöntemler

<?php
trait DurukÖrnek {
    public static function bişeyYap() {
        return 'Bir şey yapıyorum';
    }
}

class Örnek {
    use DurukÖrnek;
}

Örnek::bişeyYap();
?>

Özellikler

Nitelikler özellik tanımlayabilir.

Örnek 11 Özellik tanımlama örneği

<?php
trait NitelikliÖzellik {
    public $x = 1;
}

class ÖzellikÖrneği {
    use NitelikliÖzellik;
}

$örnek = new ÖzellikÖrneği;
örnek->x;
?>

Bir nitelik bir özellik tanımlarsa sınıf aynı isimde bir özellik tanımlayamaz, aksi takdirde bir hata oluşur. Eğer sınıf tanımı (aynı görünürlük ve ilk değer olarak) uyumluysa E_STRICT çıktılanır değilse ölümcül bir hata oluşur.

Örnek 12 Çelişki yaratma örneği

<?php
trait NitelikliÖzellik {
    public $aynı = true;
    public $farklı = false;
}

class ÖzellikÖrneği {
    use NitelikliÖzellik;
    public $aynı = true; // Strict
    public $farklı = true; // ölümcül hata
}
?>
Nesne Arayüzleri
Anonymous classes
Sınıflar ve Nesneler


Anonymous classes

Support for anonymous classes was added in PHP 7. Anonymous classes are useful when simple, one-off objects need to be created.

<?php

// Pre PHP 7 code
class Logger
{
    public function log($msg)
    {
        echo $msg;
    }
}

$util->setLogger(new Logger());

// PHP 7+ code
$util->setLogger(new class {
    public function log($msg)
    {
        echo $msg;
    }
});

They can pass arguments through to their constructors, extend other classes, implement interfaces, and use traits just like a normal class can:

<?php

class SomeClass {}
interface SomeInterface {}
trait SomeTrait {}

var_dump(new class(10) extends SomeClass implements SomeInterface {
    private $num;

    public function __construct($num)
    {
        $this->num = $num;
    }

    use SomeTrait;
});

Yukarıdaki örneğin çıktısı:

object(class@anonymous)#1 (1) {
  ["Command line code0x104c5b612":"class@anonymous":private]=>
  int(10)
}

Nesting an anonymous class within another class does not give it access to any private or protected methods or properties of that outer class. In order to use the outer class' protected properties or methods, the anonymous class can extend the outer class. To use the private properties of the outer class in the anonymous class, they must be passed through its constructor:

<?php

class Outer
{
    private $prop = 1;
    protected $prop2 = 2;

    protected function func1()
    {
        return 3;
    }

    public function func2()
    {
        return new class($this->prop) extends Outer {
            private $prop3;

            public function __construct($prop)
            {
                $this->prop3 = $prop;
            }

            public function func3()
            {
                return $this->prop2 + $this->prop3 + $this->func1();
            }
        };
    }
}

echo (new Outer)->func2()->func3();

Yukarıdaki örneğin çıktısı:

6

All objects created by the same anonymous class declaration are instances of that very class.

<?php
function anonymous_class()
{
    return new class {};
}

if (get_class(anonymous_class()) === get_class(anonymous_class())) {
    echo 'same class';
} else {
    echo 'different class';
}

Yukarıdaki örneğin çıktısı:

same class

Bilginize:

Note that anonymous classes are assigned a name by the engine, as demonstrated in the following example. This name has to be regarded an implementation detail, which should not be relied upon.

<?php
echo get_class(new class {});

Yukarıdaki örnek şuna benzer bir çıktı üretir:

class@anonymous/in/oNi1A0x7f8636ad2021

Nitelikler
Aşırı Yükleme
Sınıflar ve Nesneler


Aşırı Yükleme

PHP'deki aşırı yükleme, bir sınıfın özelliklerini ve yöntemlerini devingen olarak "oluşturmak" anlamına gelmektedir. Bu devingen öğeler, çeşitli eylem türleri için sınıf içinde oluşturulabilen sihirli yöntemler üzerinden işleme sokulurlar.

Aşırı yükleme yöntemleri, henüz bildirilmemiş veya geçerli etki alanında görünür olmayan özellik ve yöntemlerle etkileşilmek istendiğinde çağrılırlar. Bu bölümün kalanında bu bildirim ve görünürlükle ilgili durumdan bahsederken "erişilemeyen özellikler" ve "erişilemeyen yöntemler" terimlerini kullanacağız.

Tüm aşırı yükleme yöntemlerinin public olarak tanımlanması gerekir.

Bu sihirli yöntemlerin değiştirgelerinin hiçbiri gönderimli olarak aktarılamaz.

Bilginize:

PHP'nin "aşırı yükleme" konusundaki yorumu çoğu nesne yönelimli dilden farklıdır. Aşırı yükleme geleneksel olarak, dile, farklı miktar ve türde değiştirgeye sahip aynı isimde çok sayıda yönteme sahip olabilme yeteneği sağlar.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | __callStatic() eklendi. Genel etki alanında görünürlüğü ve devingen bildirimini zorunlu kılacak uyarı eklendi.
5.1.0 | __isset() ve __unset() eklendi.

Özelliklerde aşırı yükleme

public void __set ( string $isim , mixed $değer )
public mixed __get ( string $isim )
public bool __isset ( string $isim )
public void __unset ( string $isim )

__set() erişilemeyen özelliklere veri yazarken çalıştırılır.

__get() erişilemeyen özelliklerden veri okurken devreye sokulur.

__isset() erişilemeyen özellikler için isset() veya empty() çağrıldığında tetiklenir.

__unset() erişilemeyen özellikler için unset() kullanıldığında çağrılır.

$isim değiştirgesi etkileşime girilecek özelliğin ismidir. __set() yönteminin $değer değiştirgesi, $isim adlı özelliğe atanacak değeri belirler.

Özellikler üzerindeki aşırı yükleme sadece nesne bağlamında çalışır. Bu sihirli yöntemler duruk bağlamda tetiklenmeyecektir. Bu bakımdan, bu yöntemler static bildirilmemelidir. PHP 5.3.0'dan itibaren, sihirli aşırı yükleme yöntemleri static bildirildiğinde bir uyarı çıktılanmaktadır.

Bilginize:

PHP'nin atama işlecini ele alış yönteminden dolayı __set() yönteminin dönüş değeri yoksayılır. Benzer şekilde,

 $a = $obj->b = 8;
örneğindeki gibi zincirleme atamalarda __get() asla çağrılmaz.

Bilginize:

isset() dışında hiçbir dil yapısında aşırı yüklü özellikleri kullanmak mümkün değildir. Yani, eğer bir aşırı yüklü özellik üzerinde empty() çağrılırsa aşırı yüklü yöntem çağrılmaz.

Bu sınırlamadan kurtulmak için aşırı yüklü özellik önce aynı bağlamdaki bir yerel değişkene kopyalanmalı, ondan sonra empty() çağrılmalıdır.

Örnek 1 - __get(),
    __set(),
    __isset() ve
    __unset() ile
    aşırı yükleme örneği

<?php
class ÖzellikSınama
{
    /*  Aşırı yüklemeye konu veriler burada.  */
    private $veri = array();

    /*  Bildirilmiş özellikler için aşırı yükleme kullanılmaz.  */
    public $bildirilmiş = 1;

    /*  Aşırı yükleme sadece sınıf dışından erişilemeyen özellikler içindir.
     */
    private $gizli = 2;

    public function __set($isim, $değer)
    {
        echo "'$isim' adlı özelliğe '$değer' atanıyor.\n";
        $this->veri[$isim] = $değer;
    }

    public function __get($isim)
    {
        echo "'$isim' adlı özelliğin değeri isteniyor\n";
        if (array_key_exists($isim, $this->veri)) {
            return $this->veri[$isim];
        }

        $trace = debug_backtrace();
        trigger_error(
            $trace[0]['file'] . ' dosyasının ' .
            $trace[0]['line'] . '. satırında ' .
            '__get() ile tanımsız özellik istendi: ' . $isim,
            E_USER_NOTICE);
        return null;
    }

    /**  PHP 5.1.0'dan itibaren  */
    public function __isset($isim)
    {
        echo "'$isim' atanmış mı?\n";
        return isset($this->veri[$isim]);
    }

    /**  PHP 5.1.0'dan itibaren  */
    public function __unset($isim)
    {
        echo "'$name' siliniyor\n";
        unset($this->veri[$isim]);
    }

    /**  Sihirli bir yöntem değil; sadece örnek olsun diye.  */
    public function gizliyiOku()
    {
        return $this->gizli;
    }
}

echo "<pre>\n";

$obj = new ÖzellikSınama;

$obj->a = 1;
echo $obj->a . "\n\n";

var_dump(isset($obj->a));
unset($obj->a);
var_dump(isset($obj->a));
echo "\n";

echo $obj->bildirilmiş . "\n\n";

echo "'gizli' isimli 'private' özellik ile bir deneme yapalım:\n";
echo "'private' özellikler sadece sınıf içinde görünürdürler,\n";
echo "bu yüzden __get() kullanılmaz...\n";
echo $obj->gizliyiOku() . "\n";
echo "'private' özellikler sınıf dışında görünür değildirler,\n";
echo "dolayısıyla __get() kullanılır...\n";
echo $obj->gizli . "\n";
?>

Yukarıdaki örneğin çıktısı:

'a' adlı özelliğe '1' atanıyor.
'a' adlı özelliğin değeri isteniyor
1

'a' atanmış mı?
bool(true)
'' siliniyor
'a' atanmış mı?
bool(false)

1

'gizli' isimli 'private' özellik ile bir deneme yapalım:
'private' özellikler sadece sınıf içinde görünürdürler,
bu yüzden __get() kullanılmaz...
2
'private' özellikler sınıf dışında görünür değildirler,
dolayısıyla __get() kullanılır...
'gizli' adlı özelliğin değeri isteniyor

Notice: <dosya> dosyasının 71. satırında __get() ile tanımsız özellik istendi: gizli

Yöntemlerde aşırı yükleme

public mixed __call ( string $isim , array $değiştirgeler )
public static mixed __callStatic ( string $isim , array $değiştirgeler )

__call(), erişilemeyen yöntemler bir nesne bağlamından çağrıldığında tetiklenir.

__callStatic(), erişilemeyen yöntemler duruk bir bağlamdan çağrıldığında tetiklenir.

$isim değiştirgesi çağrılan yöntemin ismidir. $değiştirgeler değiştirgesi ise $isim adlı yönteme aktarılan değiştirgeleri içeren numararalı bir dizidir.

Örnek 2 - __call() ve __callStatic() ile aşırı yüklü örneklenmiş yöntemler

<?php
class YöntemSınama
{
    public function __call($isim, $değiştirgeler)
    {
        // Bilgi: $isim değeri büyük-küçük harfe duyarlıdır.
        echo "Nesnenin '$isim' yöntemi çağrılıyor: "
             . implode(', ', $değiştirgeler). "\n";
    }

    /**  PHP 5.3.0 ve sonrası  */
    public static function __callStatic($isim, $değiştirgeler)
    {
        // Bilgi: $isim değeri büyük-küçük harfe duyarlıdır.
        echo "Duruk yöntem '$isim' çağrılıyor: "
             . implode(', ', $değiştirgeler). "\n";
    }
}

$obj = new YöntemSınama;
$obj->deneBakalım('nesne bağlamında');

YöntemSınama::deneBakalım('duruk bağlamda');  // PHP 5.3.0 ve sonrası
?>

Yukarıdaki örneğin çıktısı:

Nesnenin 'deneBakalım' yöntemi çağrılıyor: nesne bağlamında
Duruk yöntem 'deneBakalım' çağrılıyor: duruk bağlamda
Anonymous classes
Nesne Yineleme
Sınıflar ve Nesneler


Nesne Yineleme

PHP 5 ile tanımlanan nesneler, foreach gibi bir deyim kullanılarak bir öğe listesi üzerinden yinelenebilirler. Öntanımlı olarak, tüm görünür özellikler yineleme için kullanılacaktır.

Örnek 1 - Basit Nesne Yineleme

<?php
class MyClass
{
    public $var1 = 'değer 1';
    public $var2 = 'değer 2';
    public $var3 = 'değer 3';

    protected $protected = 'protected var';
    private   $private   = 'private var';

    function iterateVisible() {
       echo "MyClass::iterateVisible:\n";
       foreach($this as $key => $value) {
           print "$key => $value\n";
       }
    }
}

$class = new MyClass();

foreach($class as $key => $value) {
    print "$key => $value\n";
}
echo "\n";

$class->iterateVisible();

?>

Yukarıdaki örneğin çıktısı:

var1 => değer 1
var2 => değer 2
var3 => değer 3

MyClass::iterateVisible:
var1 => değer 1
var2 => değer 2
var3 => değer 3
protected => protected var
private => private var

Çıktıdan görüleceği gibi, foreach erişilebilir olan tüm görünür değişkenleri yineledi. Bir adım öteye giderek, PHP'nin yerleşik arayüzlerinden biri olan Iterator'ü gerçekleyebilirsiniz. Iterator kullanılarak, hangi nesnenin nasıl yineleneceğine bir nesnenin karar verebilmesi mümkündür.

Örnek 2 - Iterator kullanılarak Nesne Yineleme

<?php
class MyIterator implements Iterator
{
    private $var = array();

    public function __construct($array)
    {
        if (is_array($array)) {
            $this->var = $array;
        }
    }

    public function rewind() {
        echo "başa al\n";
        reset($this->var);
    }

    public function current() {
        $var = current($this->var);
        echo "mevcut: $var\n";
        return $var;
    }

    public function key() {
        $var = key($this->var);
        echo "anahtar: $var\n";
        return $var;
    }

    public function next() {
        $var = next($this->var);
        echo "sonraki: $var\n";
        return $var;
    }

    public function valid() {
        $var = $this->current() !== false;
        echo "geçerli: {$var}\n";
        return $var;
    }
}

$values = array(1,2,3);
$it = new MyIterator($values);

foreach ($it as $a => $b) {
    print "$a: $b\n";
}
?>

Yukarıdaki örneğin çıktısı:

başa al
mevcut: 1
geçerli: 1
mevcut: 1
anahtar: 0
0: 1
sonraki: 2
mevcut: 2
geçerli: 1
mevcut: 2
anahtar: 1
1: 2
sonraki: 3
mevcut: 3
geçerli: 1
mevcut: 3
anahtar: 2
2: 3
sonraki:
mevcut:
geçerli:

Ayrıca, kendi sınıfınızı, Iterator işlevlerinin tümünü her defasında yeniden tanımlamadan, PHP 5 ile birlikte gelen IteratorAggregate arayüzünü gerçekleyerek tanımlayabilirsiniz.

Örnek 3 - IteratorAggregate ile Nesne Yineleme

<?php
class MyCollection implements IteratorAggregate
{
    private $items = array();
    private $count = 0;

    // IteratorAggregate için gerekli arayüz tanımı
    public function getIterator() {
        return new MyIterator($this->items);
    }

    public function add($value) {
        $this->items[$this->count++] = $value;
    }
}

$coll = new MyCollection();
$coll->add('değer 1');
$coll->add('değer 2');
$coll->add('değer 3');

foreach ($coll as $key => $val) {
    echo "key/value: [$key -> $val]\n\n";
}
?>

Yukarıdaki örneğin çıktısı:

başa al
mevcut: değer 1
geçerli: 1
mevcut: değer 1
anahtar: 0
anahtar/değer: [0 -> değer 1]

sonraki: değer 2
mevcut: değer 2
geçerli: 1
mevcut: değer 2
anahtar: 1
anahtar/değer: [1 -> değer 2]

sonraki: değer 3
mevcut: değer 3
geçerli: 1
mevcut: değer 3
anahtar: 2
anahtar/değer: [2 -> değer 3]

sonraki:
mevcut:
geçerli:

Bilginize:

Yineleyiciler ile ilgili daha fazla örnek için, Iterators bölümüne bakınız.

Aşırı Yükleme
Sihirli Yöntemler
Sınıflar ve Nesneler


Sihirli Yöntemler

__construct(),
__destruct(),
__call(),
__callStatic(),
__get(),
__set(),
__isset(),
__unset(),
__sleep(),
__wakeup(),
__toString(),
__invoke(),
__set_state(),
__clone() ve
__debugInfo()
işlev isimleri PHP
sınıflarında sihirli işlemler yaparlar. İşlevlerinize sihirli bir
işlevsellik kazandırmak istemedikçe bu isimleri sınıfınızın içinde işlev
ismi olarak kullanamazsınız.

Dikkat

PHP, __ ile baslayan tüm işlev isimlerini sihirli işlevlere ayırmıştır. Belgelenmiş bir kaç sihirli işlevsellik dışında __ ile başlayan işlev isimleri kullanmamanızı öneririz.

__sleep() ve __wakeup()

public array __sleep ( void )
void __wakeup ( void )

serialize() işlevi, sınıfınızın __sleep() adında sihirli bir işleve sahip olup olmadığına bakar. Böyle bir işlev varsa herhangi bir serileştirme işleminden önce bu işlev çalıştırılır. Bu işlev ile nesne üzerinde temizlik yapabilir ve serileştirilmesi gereken nesnenin tüm değişken isimlerinin bir dizi halinde döndürülmesini sağlayabilirsiniz. Eğer işlev hiçbir şey döndürmemişse NULL serileştirilir ve bir E_NOTICE çıktılanır.

Bilginize:

Ebeveyn sınıflardaki private özelliklerin isimlerini döndürmek __sleep() için imkansızdır. Bunu yapmaya kalkışırsanız E_NOTICE seviyesinde bir hata iletisi alırsınız. Bunun yerine Serializable arayüzünü kullanabilirsiniz.

__sleep() işlevinin asıl kullanım amacı askıdaki veriyi göndermek gibi temizliğe benzer işlemler yapmaktır. Ayrıca, tümüyle kaydedilmesi gerekmeyen büyük veri parçaları sözkonusu olduğunda da bu işlevden yararlanabilirsiniz.

unserialize() işlevi tersine bir işlem yaparak __wakeup() adında bir sihirli işlevin varlığını araştırır. Böyle bir işlev varsa, bu işlev nesnenin sahip olduğu tüm özkaynakları yeniden oluşturabilir.

__wakeup() işlevinin asıl kullanım amacı, serileştirme sırasında kaybedilebilen veritabanı bağlantılarını yeniden oluşturmak ve diğer ilklendirme işlemlerini yeniden yapmaktır.

Örnek 1 - Uyutma ve uyandırma

<?php
class Bağlantı
{
    protected $hat;
    private $dsn, $kullanıcı, $parola, $db;

    public function __construct($dsn, $kullanıcı, $parola, $db)
    {
        $this->dsn = $dsn;
        $this->kullanıcı = $kullanıcı;
        $this->parola = $parola;
        $this->db = $db;
        $this->connect();
    }

    private function bağlan()
    {
        $this->hat = new PDO($this->dsn, $this->kullanıcı, $this->parola);
    }

    public function __sleep()
    {
       return array('dsn', 'kullanıcı', 'parola');
    }

    public function __wakeup()
    {
        $this->bağlan();
    }
}?>

__toString()

public string __toString ( void )

__toString() yöntemi, sınıf bir dizgeye dönüştürüldüğünde sınıfın nasıl tepki vereceğine karar vermeyi sağlar. Bu yöntem bir dizge döndürmelidir, aksi takdirde E_RECOVERABLE_ERROR seviyesinde ölümcül bir hata çıktılanır.

Uyarı

You cannot throw an exception from within a __toString() yöntemin içinden bir istisna oluşturamazsınız. Bunu yapılması ölümcül hata ile sonuçlanır.

Örnek 2 - Basit bir örnek

<?php
// Basit bir sınıf tanımlayalım
class TestClass
{
    public $foo;

    public function __construct($foo)
    {
        $this->foo = $foo;
    }

    public function __toString()
    {
        return $this->foo;
    }
}

$class = new TestClass('Merhaba');
echo $class;
?>

Yukarıdaki örneğin çıktısı:

Merhaba

PHP 5.2.0'dan önce __toString() yönteminin, doğrudan echo ya da print işlevleri ile birlikte çağrılmadıkça bir önemi yoktu. PHP 5.2.0'dan beri sadece dizge bağlamlarında (%s değiştiricili printf() gibi) çağrılabilmekte, diğer bağlamlarda (%d değiştiricili printf() gibi) çağrılamamaktadır. PHP 5.2.0'dan beri nesneleri __toString() yöntemi olmaksızın dizgeye dönüştürme işlemi E_RECOVERABLE_ERROR hatasına yol açmaktadır.

__invoke()

mixed __invoke ([ $... ] )

__invoke() yöntemi, bir betik bir nesneyi bir işlev olarak çağırmaya çalışırsa çağrılır.

Bilginize:

Bu özellik PHP 5.3.0'dan beri mevcuttur.

Örnek 3 - __invoke() kullanımı

<?php
class CallableClass
{
  public function __invoke($x)
  {
    var_dump($x);
  }
}
$obj = new CallableClass;
$obj(5);
var_dump(is_callable($obj));
?>

Yukarıdaki örneğin çıktısı:

int(5)
bool(true)

__set_state()

static object __set_state ( array $özellikler )

Bu duruk yöntem, PHP 5.1.0 sürümünden beri var_export() tarafından ihraç edilen sınıflar için çağrılmaktadır.

Bu yöntemin tek değiştirgesi array('özellik' => değer, ...) biçeminde ihraç edilen özellikleri içeren bir dizidir.

Örnek 4 - __set_state() kullanımı (PHP 5.1.0 ve sonrası)

<?php

class A
{
    public $var1;
    public $var2;

    public static function __set_state($bir_dizi) // PHP 5.1.0'dan beri
    {
        $obj = new A;
        $obj->var1 = $bir_dizi['var1'];
        $obj->var2 = $bir_dizi['var2'];
        return $obj;
    }
}

$a = new A;
$a->var1 = 5;
$a->var2 = 'foo';

eval('$b = ' . var_export($a, true) . ';'); // $b = A::__set_state(array(
                                            //    'var1' => 5,
                                            //    'var2' => 'foo',
                                            // ));
var_dump($b);

?>

Yukarıdaki örneğin çıktısı:

object(A)#2 (2) {
  ["var1"]=>
  int(5)
  ["var2"]=>
  string(3) "foo"
}

__debugInfo()

array __debugInfo ( void )

Gösterilmesi gereken özelliklerini döndürmek için bir nesne dökümleneceği zaman bu yöntem var_dump() tarafından çağrılır.

Bu özellik PHP 5.6.0 sürümünde eklendi.

Örnek 5 __debugInfo() kullanımı

<?php
class C {
    private $prop;

    public function __construct($val) {
        $this->prop = $val;
    }

    public function __debugInfo() {
        return [
            'propSquared' => $this->prop ** 2,
        ];
    }
}

var_dump(new C(42));
?>

Yukarıdaki örneğin çıktısı:

object(C)#1 (1) {
  ["propSquared"]=>
  int(1764)
}
Nesne Yineleme
final Anahtar Sözcüğü
Sınıflar ve Nesneler


final Anahtar Sözcüğü

PHP 5 ile birlikte gelen diğer bir yenilik final anahtar sözcüğüdür. Bu anahtar sözcükle tanımlanmış bir yöntemi çocuk sınıflar geçersiz kılamazlar. Eğer bir sınıf kendini final sözcüğüyle tanımlamışsa o sınıf genişletilemez.

Örnek 1 - final yöntem örneği

<?php
class AnaSınıf {
   public function deneme() {
       echo "AnaSınıf::deneme() çağrıldı\n";
   }

   final public function başkaDeneme() {
       echo "AnaSınıf::başkaDeneme() çağrıldı\n";
   }
}

class ÇocukSınıf extends AnaSınıf {
   public function başkaDeneme() {
       echo "ÇocukSınıf::başkaDeneme() çağrıldı\n";
   }
}
// Ölümcül hata ile sonuçlanır: AnaSınıf:başkaDeneme() final yöntemi
// ÇocukSınıf::başkaDeneme() yöntemiyle geçersiz kılınamaz
?>

Örnek 2 - final sınıf örneği

<?php
final class AnaSınıf {
   public function deneme() {
       echo "AnaSınıf::deneme() çağrıldı\n";
   }

   // Burada işlevi final olarak belirtmenin bir önemi yoktur
   final public function başkaDeneme() {
       echo "AnaSınıf::başkaDeneme() çağrıldı\n";
   }
}

class ÇocukSınıf extends AnaSınıf {
}
// Ölümcül hata ile sonuçlanır: ÇocukSınıf final bir sınıf
// olan AnaSınıf'ın çocuğu olarak oluşturulamaz
?>

Bilginize: Özellikler final olarak bildirilemez, sadece sınıflar ve yöntemler final olarak bildirilebilir.

Sihirli Yöntemler
Nesne Kopyalama
Sınıflar ve Nesneler


Nesne Kopyalama

Bir nesnenin tüm özelliklerinin aynen kopyalanarak çoğaltılması her zaman istenilen durum değildir. Kurucuların kopyalanması iyi bir örnektir, bir GTK penceresini temsil eden bir nesneniz varsa ve bu nesne GTK penceresine ait özkaynağı tutuyorsa, bu nesnenin kopyasını oluşturduğunuzda, yeni nesnenin önceki pencere ile aynı özelliklere sahip yeni bir pencereye sahip olmasını ve önceki nesne ile aynı şekilde pencereye ait özkaynağı tutuyor olmasını isteyebilirsiniz. Bir diğer örnek, nesneniz kullandığı başka bir nesneye ait bir gönderim tutuyorsa, ebeveyn nesne kopyalandığında diğer nesnenin de yeni bir örneğinin oluşturulmasını isteyebilirsiniz, yani ebeveynin kopyasının kendine ait ayrı bir kopyası olur.

Bir nesnenin kopyası (mümkünse nesnenin __clone() yöntemini çağıran) clone anahtar sözcüğü kullanılarak oluşturulur. Bir nesnenin __clone() yöntemi doğrudan doğruya çağrılamaz.

$nesnenin_kopyası = clone $object;

Bir nesne kopyalandığında, PHP 5 nesnenin tüm özelliklerinin yüzeysel bir kopyasını çıkartacaktır. Diğer değişkenlere birer gönderim olan tüm özellikler gönderim olarak kalacaktır.

void __clone ( void )

Kopyalama tamamlanır tamamlanmaz, bir __clone() yöntemi tanımlanmışsa, değişmesi gereken lüzumlu tüm özelliklere izin vermek için yeni oluşturulan nesnenin __clone() yöntemi çağrılacaktır.

Örnek 1 - Bir nesnenin kopyalanması

<?php
class AltNesne
{
    static $örnek_sayısı = 0;
    public $örnek;

    public function __construct()
    {
        $this->örnek = ++self::$örnek_sayısı;
    }

    public function __clone()
    {
        $this->örnek = ++self::$örnek_sayısı;
    }
}

class KopyalanabilirNesnem
{
    public $nesne1;
    public $nesne2;

    function __clone()
    {
        // this->nesne1'in bir kopyasını oluşturmak için
        // zorlayalım, yoksa aynı nesneyi gösterecek.
        $this->nesne1 = clone $this->nesne1;
    }
}

$nes = new KopyalanabilirNesnem();

$nes->nesne1 = new AltNesne();
$nes->nesne2 = new AltNesne();

$nes2 = clone $nes;

print("Özgün Nesne:\n");
print_r($nes);

print("Kopya Nesne:\n");
print_r($nes2);
?>

Yukarıdaki örneğin çıktısı:

Özgün Nesne:
KopyalanabilirNesnem Object
(
    [nesne1] => AltNesne Object
        (
            [örnek] => 1
        )

    [nesne2] => AltNesne Object
        (
            [örnek] => 2
        )

)
Kopya Nesne:
KopyalanabilirNesnem Object
(
    [nesne1] => AltNesne Object
        (
            [örnek] => 3
        )

    [nesne2] => AltNesne Object
        (
            [örnek] => 2
        )

)
final Anahtar Sözcüğü
Nesnelerin Karşılaştırılması
Sınıflar ve Nesneler


Nesnelerin Karşılaştırılması

Nesne karşılaştırma, PHP 5'te PHP 4'e nazaran daha karmaşıktır. PHP 5, bir Nesne Yönelimli Dil'den beklenenleri daha iyi karşılar (ancak, PHP 5 böyle bir dildir, demiyoruz).

Eşitlik işleci (==) kullanıldığında, nesne değişkenleri basit bir mantıkla karşılaştırılır: İki nesne örneği aynı özniteliklere ve aynı değerlere sahipse ve ikisi de aynı sınıf tarafından oluşturulmuşsa bu iki nesne örneği birbirine eşittir.

Öte yandan, aynılık işleci (===) kullanıldığında, iki nesne değişkeni yalnız ve yalnız aynı sınıfın aynı örneği iseler birbirlerinin aynısıdırlar.

Bu kuralları bir örnek ile pekiştirelim.

Örnek 1 - PHP 5'te nesne karşılaştırma örneği

<?php
function bool2str($bool)
{
    if ($bool === false) {
        return 'YANLIŞ';
    } else {
        return 'DOĞRU';
    }
}

function compareObjects(&$o1, &$o2)
{
    echo 'o1 == o2 : ' . bool2str($o1 == $o2) . "\n";
    echo 'o1 != o2 : ' . bool2str($o1 != $o2) . "\n";
    echo 'o1 === o2 : ' . bool2str($o1 === $o2) . "\n";
    echo 'o1 !== o2 : ' . bool2str($o1 !== $o2) . "\n";
}

class Flag
{
    public $flag;

    function Flag($flag = true) {
        $this->flag = $flag;
    }
}

class OtherFlag
{
    public $flag;

    function OtherFlag($flag = true) {
        $this->flag = $flag;
    }
}

$o = new Flag();
$p = new Flag();
$q = $o;
$r = new OtherFlag();

echo "Aynı sınıfın iki örneği\n";
compareObjects($o, $p);

echo "\nAynı örneğe iki gönderim\n";
compareObjects($o, $q);

echo "\nİki farklı sınıfın örnekleri\n";
compareObjects($o, $r);
?>

Yukarıdaki örneğin çıktısı:

Aynı sınıfın iki örneği
o1 == o2 : DOĞRU
o1 != o2 : YANLIŞ
o1 === o2 : FALSE
o1 !== o2 : DOĞRU

Aynı örneğe iki gönderim
o1 == o2 : DOĞRU
o1 != o2 : YANLIŞ
o1 === o2 : DOĞRU
o1 !== o2 : YANLIŞ

İki farklı sınıfın örnekleri
o1 == o2 : YANLIŞ
o1 != o2 : DOĞRU
o1 === o2 : YANLIŞ
o1 !== o2 : DOĞRU

Bilginize:

Eklentiler, kendi nesne karşılaştırmaları için kendi kurallarını tanımlayabilirler.

Nesne Kopyalama
Tür Dayatma
Sınıflar ve Nesneler


Tür Dayatma

PHP 5, Tür Dayatma özelliğine sahiptir. İşlevler artık değiştirgelerinde belli bir nesne veya (PHP 5.1 ve sonrasında) bir dizi belirtilmesi için zorlayıcı olabilmektedir.

Örnek 1 - Tür dayatma örnekleri

<?php
// Şöyle bir sınıfımız olsun
class Sınıfım
{
    /**
     * Bir nesne sınama işlevi
     *
     * İlk değiştirge ÖbürSınıf türünde bir nesne olmalı
     */
    public function nesne_dnm(ÖbürSınıf $diğersınıf) {
        echo $diğersınıf->değişken;
    }

    /**
     * Bir dizi sınama işlevi
     *
     * İlk değiştirge bir dizi olmalı
     */
    public function dizi_dnm(array $dizi_girdisi) {
        print_r($dizi_girdisi);
    }
}

// Bu da öbür sınıfımız olsun
class ÖbürSınıf {
    public $değişken = 'Merhaba Dünya';
}
?>

Dayatılan türe uymamanın sonucu yakalanabilir bir ölümcül hatadır.

<?php
// Her iki sınıftan birer örnek oluşturalım
$sınıfım = new Sınıfım;
$diğersınıf = new ÖbürSınıf;

// Ölümcül Hata: 1. değiştirge ÖbürSınıf türünde bir nesne olmalıdır
$sınıfım->nesne_dnm('hello');

// Ölümcül Hata: 1. değiştirge ÖbürSınıf türünde bir nesne örneği olmalıdır
$foo = new stdSınıf;
$sınıfım->nesne_dnm($foo);

// Ölümcül Hata: 1. değiştirge null olmamalıdır
$sınıfım->nesne_dnm(null);

// Bu çalışır: Merhaba Dünya yazdırır
$sınıfım->nesne_dnm($otherclass);

// Ölümcül Hata: 1. değiştirge bir dizi olmalıdır
$sınıfım->dizi_dnm('bir metin');

// Bu çalışır: Diziyi yazdırır
$sınıfım->dizi_dnm(array('a', 'b', 'c'));
?>

Tür dayatma işlevlerle de çalışır:

<?php
// Şöyle bir sınıfımız olsun
class Sınıfım {
    public $değişken = 'Merhaba Dünya';
}

/**
 * Bir işlev sınama işlevi
 *
 * İlk değiştirge Sınıfım türünde bir nesne olmalı
 */
function İşlevim (Sınıfım $birsınıf) {
    echo $birsınıf->değişken;
}

// Bu çalışır
$sınıfım = new Sınıfım;
İşlevim($sınıfım);
?>

Tür dayatırken NULL değere izin verilir:

<?php

/* NULL değerin kabul edilmesi */
function deneme(stdSınıf $obj = NULL) {

}

deneme(NULL);
deneme(new stdSınıf);

?>

Tür dayatma (PHP 5.1 itibariyle) sadece object veya array türünde olabilir. int ve string ile yapılan geleneksel tür dayatma desteklenmemektedir.

Nesnelerin Karşılaştırılması
Duruk İçselleştirim
Sınıflar ve Nesneler


Duruk İçselleştirim

PHP 5.3.0'dan itibaren, miras alınan duruk bağlamın çağrıldığı nesne bağlamında değerlendirilmesini sağlayan ve duruk içselleştirim (İng.: late static bindings) adı verilen bir özellik eklenmiştir.

"Duruk içselleştirme", static:: yöntemin çalışma anında, tanımlandığı nesnenin bağlamında değil, çağrıldığı nesnenin bağlamında değerlendirilmesi olgusunu betimler.

self:: ile ilgili sınırlamalar

self:: veya __CLASS__ gibi bulunduğu sınıfa duruk gönderim yapan öğeler, örnekten de görüleceği üzere, yöntemi miras alan sınıf bağlamında değil, yöntemin ait olduğu sınıf bağlamında değerlendirilirler:

Örnek 1 - self:: kullanımı

<?php
class A {
    public static function kimsin() {
        echo __CLASS__;
    }
    public static function dene() {
        self::kimsin();
    }
}

class B extends A {
    public static function kimsin() {
        echo __CLASS__;
    }
}

B::dene();
?>

Yukarıdaki örneğin çıktısı:

A

Duruk İçselleştirimin uygulanması

Duruk içselleştirimde çözümlemenin, gönderimin çalışma anında ilk çağrıldığı sınıfla sınırlandırılması, gönderim için özel bir anahtar sözcük kullanılarak sağlanır. Temel olarak, böyle bir anahtar sözcük, yukarıdaki örnekteki dene() yönteminin aşağıdaki gibi B döndürmesini sağlar. Bunun için yeni bir anahtar sözcük atamaktansa, zaten bir anahtar sözcük olan static sözcüğü kullanılmıştır.

Örnek 2 - static:: kullanımı

<?php
class A {
    public static function kimsin() {
        echo __CLASS__;
    }
    public static function dene() {
        static::kimsin(); // Burada duruk içselleştirim yapılıyor
    }
}

class B extends A {
    public static function kimsin() {
         echo __CLASS__;
    }
}

B::dene();
?>

Yukarıdaki örneğin çıktısı:

B

Bilginize:

Duruk yöntemler için static::, $this gibi çalışmaz! $this-> kalıtım kurallarına bağlıdır, static:: değildir.

Örnek 3 - Duruk olmayan bağlamda static:: kullanımı

<?php
class Çocuk extends Ebeveyn {
    public function __construct() {
        static::kimsin();
    }

    public function dene() {
        $o = new Ebeveyn();
    }

    public static function kimsin() {
        echo __CLASS__."\n";
    }
}

class Ebeveyn {
    public function __construct() {
        static::kimsin();
    }

    public static function kimsin() {
        echo __CLASS__."\n";
    }
}
$o = new Çocuk;
$o->dene();

?>

Yukarıdaki örneğin çıktısı:

Çocuk
Ebeveyn

Bilginize:

Duruk içselleştirimin çözümlemesi duruk çağrının tamamen çözümlendiği noktada durdurulur, daha öteye gidilmez. Diğer taraftan, parent:: veya self:: gibi anahtar sözcükler kullanılarak yapılan duruk çağrılar çağrı bilgisini ötelerler.

Örnek 4 Ötelenen ve ötelenmeyen çağrılar

<?php
class A {
    public static function nesin() {
        static::kimsin();
    }

    public static function kimsin() {
        echo __CLASS__."\n";
    }
}

class B extends A {
    public static function dene() {
        A::nesin();
        parent::nesin();
        self::nesin();
    }

    public static function kimsin() {
        echo __CLASS__."\n";
    }
}
class C extends B {
    public static function kimsin() {
        echo __CLASS__."\n";
    }
}

C::dene();
?>

Yukarıdaki örneğin çıktısı:

A
C
C

Yan etkiler

PHP'de bir yöntem çağrısını tetiklemenin çok çeşitli yolları vardır; geri çağırımlar ve sihirli yöntemler gibi. Bunlar duruk içselleştirime tabi tutulduklarında, çalışma anında beklenmeyen sonuçlara sebep olurlar.

Örnek 5 - Sihirli yöntemlerin içinde duruk içselleştirim

<?php
class A {

   protected static function kimsin() {
        echo __CLASS__."\n";
   }

   public function __get($var) {
       return static::kimsin();
   }
}

class B extends A {

   protected static function kimsin() {
        echo __CLASS__."\n";
   }
}

$b = new B;
$b->nesin;
?>

Yukarıdaki örneğin çıktısı:

B
Tür Dayatma
Nesneler ve Gönderimler
Sınıflar ve Nesneler


Nesneler ve Gönderimler

PHP 5 için nesne yönelimli programlama ile ilgili olarak "öntanımlı olarak nesneler gönderimli aktarılır" diye bir kanı oluşmuştur, fakat bu tamamen doğru değildir. Bu bölümde bir örnek üzerinden bu genel kanı düzeltilmeye çalışılmıştır.

Bir PHP gönderimi, aynı değeri iki farklı değişkene yazmayı mümkün kılan bir takma addır. PHP 5'ten itibaren bir nesne değişkeni artık değer olarak nesnenin kendisini içermemektedir. Bunun yerine, nesne erişimcilerin asıl nesneyi bulmasını sağlayacak bir nesne tanıtıcısı içerir. Bir nesne değiştirgesi ile aktarılırken, döndürülürken veya başka bir değişkene atanırken bunlar takma ad değil, farklı değişkenlerdir: Aynı nesneyi gösteren tanıtıcının birer kopyasını içerirler.

Örnek 1 - Gönderimler ve Nesneler

<?php
class A {
    public $foo = 1;
}

$a = new A;
$b = $a;     // $a ve $b aynı nesne tanıtıcısının kopyalarını içerir
             // ($a) = ($b) = <tanıtıcı>
$b->foo = 2;
echo $a->foo."\n";

$c = new A;
$d = &$c;    // $c ve $d gönderimdir
             // ($c,$d) = <tanıtıcı>

$d->foo = 2;
echo $c->foo."\n";

$e = new A;

function foo($obj) {
    // ($obj) = ($e) = <tanıtıcı>
    $obj->foo = 2;
}

foo($e);
echo $e->foo."\n";

?>

Yukarıdaki örneğin çıktısı:

2
2
2
Duruk İçselleştirim
Object Serialization
Sınıflar ve Nesneler


Object Serialization

Serializing objects - objects in sessions

serialize() returns a string containing a byte-stream representation of any value that can be stored in PHP. unserialize() can use this string to recreate the original variable values. Using serialize to save an object will save all variables in an object. The methods in an object will not be saved, only the name of the class.

In order to be able to unserialize() an object, the class of that object needs to be defined. That is, if you have an object of class A and serialize this, you'll get a string that refers to class A and contains all values of variables contained in it. If you want to be able to unserialize this in another file, an object of class A, the definition of class A must be present in that file first. This can be done for example by storing the class definition of class A in an include file and including this file or making use of the spl_autoload_register() function.

<?php
// classa.inc:

  class A {
      public $one = 1;

      public function show_one() {
          echo $this->one;
      }
  }

// page1.php:

  include("classa.inc");

  $a = new A;
  $s = serialize($a);
  // store $s somewhere where page2.php can find it.
  file_put_contents('store', $s);

// page2.php:

  // this is needed for the unserialize to work properly.
  include("classa.inc");

  $s = file_get_contents('store');
  $a = unserialize($s);

  // now use the function show_one() of the $a object.
  $a->show_one();
?>

If an application is using sessions and uses session_register() to register objects, these objects are serialized automatically at the end of each PHP page, and are unserialized automatically on each of the following pages. This means that these objects can show up on any of the application's pages once they become part of the session. However, the session_register() is removed since PHP 5.4.0.

It is strongly recommended that if an application serializes objects, for use later in the application, that the application includes the class definition for that object throughout the application. Not doing so might result in an object being unserialized without a class definition, which will result in PHP giving the object a class of __PHP_Incomplete_Class_Name, which has no methods and would render the object useless.

So if in the example above $a became part of a session by running session_register("a"), you should include the file classa.inc on all of your pages, not only page1.php and page2.php.

Beyond the above advice, note that you can also hook into the serialization and unserialization events on an object using the __sleep() and __wakeup() methods. Using __sleep() also allows you to only serialize a subset of the object's properties.

Nesneler ve Gönderimler
OOP Changelog
Sınıflar ve Nesneler


OOP Changelog

Changes to the PHP 5 OOP model are logged here. Descriptions and other notes regarding these features are documented within the OOP 5 documentation.

Sürüm: | Açıklama
5.6.0 | Added: The __debugInfo() method.
5.5.0 | Added: The ::class magic constant.
5.5.0 | Added: finally to handle exceptions.
5.4.0 | Added: traits.
5.4.0 | Changed: If an abstract class defines a signature for the constructor it will now be enforced.
5.3.3 | Changed: Methods with the same name as the last element of a namespaced class name will no longer be treated as constructor. This change doesn't affect non-namespaced classes.
5.3.0 | Changed: Classes that implement interfaces with methods that have default values in the prototype are no longer required to match the interface's default value.
5.3.0 | Changed: It's now possible to reference the class using a variable (e.g., echo $classname::constant;). The variable's value can not be a keyword (e.g., self, parent or static).
5.3.0 | Changed: An E_WARNING level error is issued if the magic overloading methods are declared static. It also enforces the public visibility requirement.
5.3.0 | Changed: Prior to 5.3.0, exceptions thrown in the __autoload() function could not be caught in the catch block, and would result in a fatal error. Exceptions now thrown in the __autoload function can be caught in the catch block, with one provison. If throwing a custom exception, then the custom exception class must be available. The __autoload function may be used recursively to autoload the custom exception class.
5.3.0 | Added: The __callStatic method.
5.3.0 | Added: heredoc and nowdoc support for class const and property definitions. Note: heredoc values must follow the same rules as double-quoted strings, (e.g., no variables within).
5.3.0 | Added: Late Static Bindings.
5.3.0 | Added: The __invoke() method.
5.2.0 | Changed: The __toString() method was only called when it was directly combined with echo or print. But now, it is called in any string context (e.g. in printf() with %s modifier) but not in other types contexts (e.g. with %d modifier). Since PHP 5.2.0, converting objects without a __toString method to string emits a E_RECOVERABLE_ERROR level error.
5.1.3 | Changed: In previous versions of PHP 5, the use of var was considered deprecated and would issue an E_STRICT level error. It's no longer deprecated, therefore does not emit the error.
5.1.0 | Changed: The __set_state() static method is now called for classes exported by var_export().
5.1.0 | Added: The __isset() and __unset() methods.

Object Serialization
İsim Alanları
Sınıflar ve Nesneler


İsim Alanları

İçindekiler

  • Giriş
  • İsim Alanlarının Tanımlanması
  • Alt İsim Alanlarının Bildirilmesi
  • Birden Fazla İsim Alanının Aynı Dosyada Tanımlanması
  • İsim alanlarının kullanımı: Temeller
  • İsim alanları ve devingen dil özellikleri
  • namespace sözcüğü ve __NAMESPACE__ sabiti
  • İsim alanlarının kullanımı: İthal/Rumuz
  • Küresel Alan
  • İsim alanlarının kullanımı: son çare olarak küresel işlev ve sabitler
  • İsim çözünürlük kuralları
  • SSS: İsim alanları hakkında bilinmesi gerekenler
OOP Changelog
Giriş
Dil Başvuru Kılavuzu


Giriş

İsim alanı nedir? En dar tanımıyla, öğeleri sarmalamanın bir yoludur. Çoğu bakımdan bu soyut bir kavram gibi görünebilir. Örneğin, bir işletim sisteminin dizinleri bir birleriyle ilgili dosyaları gruplamaya yarar ve içerdiği dosyalar için bir isim alanı görevi yapar. Daha belirgin bir örnek olarak, /home/ali ve /home/veli dizinlerinde mesela.txt adında birer dosya bulunduğunu varsayalım. /home/ali dizinindeki dosyaya dizin dışından erişmek istersek dosyanın önüne dizin ayracı ile dizin adını yerleştiririz. Programcılık dünyasındaki isim alanlarına da aynı kurallar uygulanır.

PHP dünyasında isim alanları, kütüphane ve uygulama yazarlarının aşağıdaki gibi sınıflar ve işlevler gibi yeniden kullanılabilir elemanları oluşturken karşılaştıkları iki soruna çözüm getirmek amacıyla tasarlanmıştır:

  1. Yazdığınız kod ile yerleşik PHP sınıfları/işlevleri/sabitleri veya üçüncü şahısların sınıfları/işlevleri/sabitleri arasındaki isim çakışmaları.
  2. İlk sorunu hafifletmek ve kaynak kodun okunabilirliğini arttırmak için epeyce_uzun_isimlere takma ad tanımlama (veya kısaltma) yeteneği.

PHP isim alanları birbirleriyle ilişkili sınıflar, sabitler ve işlevleri gruplamak için bir yol sunar. PHP'deki isim alanı söz dizimi için bir örnek:

Örnek 1 - İsim alanı söz dizimi örneği

<?php
namespace isim\alanım; // "İsim Alanlarının Tanımlanması" bölümüne bakınız

class Sınıfım {}
function işlevim() {}
const SABİTİM = 1;

$a = new Sınıfım;
$c = new \isim\alanım\Sınıfım; // "Küresel Etki Alanı" bölümüne bakınız

$a = strlen('selam'); // "İsim alanlarının kullanımı: Son çare olarak
                      // küresel işlev ve sabitler" bölümüne bakınız

$d = \isim\alanım\SABİTİM;        // isim alanı işleci ve __NAMESPACE__
$d = __NAMESPACE__ . '\SABİTİM';  // sabiti" bölümüne bakınız
echo constant($d); // "İsim alanları ve devingen dil özellikleri"
                   // bölümüne bakınız
?>

İsim alanları PHP 5.3.0 sürümünden beri mevcuttur.

İsim Alanları
İsim Alanlarının Tanımlanması
İsim Alanları


İsim Alanlarının Tanımlanması

İsim alanları içinde her çeşit PHP kodu bulunabilirse de sadece üç tür kod isim alanlarından etkilenir: Sınıflar, işlevler ve sabitler.

İsim alanları, namespace anahtar sözcüğü ile bildirilirler. Bir isim alanını içeren bir dosyada isim alanı bütün diğer kodlardan önce (ama bir declare satırından önce değil) dosyanın başlarında bildirilmelidir.

Örnek 1 - Tek bir isim alanı bildirimi

<?php
namespace Projem;

const BAĞLANTI_TAMAM = 1;
class Bağlantı { /* ... */ }
function bağlan() { /* ... */  }

?>
Bir isim alanı bildiriminden önce bulunmasına izin verilen tek oluşum, kaynak dosyanın kodlamasının tanımlandığı declare deyimidir. Bunun dışında, baştaki fazladan boşluklar da dahil hiçbir PHP-dışı kod, bir isim alanı bildiriminden önce yer alamaz. Örnek:

Örnek 2 - Tek bir isim alanı bildirimi

<html>
<?php
namespace Sınıfım; // ölümcül hata - namespace, betikteki ilk deyim olmalıdır
?>

Diğer tüm PHP oluşumlarının tersine, isim alanının dosya sistemi içinde parçalara bölünebilmesi için aynı isim alanı birden fazla dosyada tanımlanabilir.

Giriş
Alt İsim Alanlarının Bildirilmesi
İsim Alanları


Alt İsim Alanlarının Bildirilmesi

Dizinler ve dosyalardaki gibi PHP isim alanı isimleri arasında da bir hiyeraraşi belirtmek mümkündür. Bu bakımdan, bir isim alanı başka isim alanlarının altında tanımlanabilir:

Örnek 1 - Tek bir isim alanının hiyerarşik bildirimi

<?php
namespace Projem\Alt\Seviye;

const BAĞLANTI_TAMAM = 1;
class Bağlantı { /* ... */ }
function bağlan() { /* ... */  }

?>
Yukarıdaki örnekte, Projem\Alt\Seviye\BAĞLANTI_TAMAM sabiti, Projem\Alt\Seviye\Bağlantı sınıfı ve Projem\Alt\Seviye\bağlan işlevi oluşturulmaktadır.

İsim Alanlarının Tanımlanması
Birden Fazla İsim Alanının Aynı Dosyada Tanımlanması
İsim Alanları


Birden Fazla İsim Alanının Aynı Dosyada Tanımlanması

Birden fazla isim alanı aynı dosya içinde bildirilebilir. İki çeşit söz dizimine izin verilir.

Örnek 1 - Birden fazla isim alanın ayrımsız ardarda bildirilmesi

<?php
namespace Projem;

const BAĞLANTI_TAMAM = 1;
class Bağlantı { /* ... */ }
function bağlan() { /* ... */  }

namespace DiğerProjem;

const BAĞLANTI_TAMAM = 1;
class Bağlantı { /* ... */ }
function bağlan() { /* ... */  }
?>

Bu söz dizimi aynı dosya içinde birden fazla isim alanı bildirimi için önerilmez. Bunun yerine ayraçlı söz dizimi önerilir.

Örnek 2 - Birden fazla isim alanın ayraçlı olarak bildirilmesi

<?php
namespace Projem {

const BAĞLANTI_TAMAM = 1;
class Bağlantı { /* ... */ }
function bağlan() { /* ... */  }
}

namespace DiğerProjem {

const BAĞLANTI_TAMAM = 1;
class Bağlantı { /* ... */ }
function bağlan() { /* ... */  }
}
?>

Aynı dosya içinde birden fazla isim alanını birleştirmek iyi bir kodlama uygulaması olarak teşvik edilmektedir. Çoğunlukla çok sayıda PHP betiğini aynı dosyada birleştirmek amacıyla kullanılır.

İsim alansız küresel kodu isim alanlı kodla bir arada kullanmanın tek yolu ayraçlı söz dizimini kullanmaktır (diğerine izin verilmemektedir). Küresel kod isimsiz bir isim alanı bildirimi ile aynı dosyada şöyle bildirilebilir:

Örnek 3 - Birden fazla isim alanın isim alansız kodla birlikte bildirilmesi

<?php
namespace Projem {

const BAĞLANTI_TAMAM = 1;
class Bağlantı { /* ... */ }
function bağlan() { /* ... */  }
}

namespace { // küresel kod
session_start();
$a = Projem\bağlan();
echo Projem\Bağlantı::başlat();
}
?>

İsim alanı ayraçlarının dışında, kodlama belirten declare deyimi dışında hiçbir PHP kodu bulunamaz.

Örnek 4 - Birden fazla isim alanın isim alansız kodla birlikte bildirilmesi

<?php
declare(encoding='UTF-8');
namespace Projem {

const BAĞLANTI_TAMAM = 1;
class Bağlantı { /* ... */ }
function bağlan() { /* ... */  }
}

namespace { // küresel kod
session_start();
$a = Projem\bağlan();
echo Projem\Bağlantı::başlat();
?>

Alt İsim Alanlarının Bildirilmesi
İsim alanlarının kullanımı: Temeller
İsim Alanları


İsim alanlarının kullanımı: Temeller

İsim alanlarının kullanımından önce PHP'nin kodunuzdaki hangi isim alanlı kodu isteğinizi nasıl anlayabildiğinden bahsetmek gerekir. Bunu daha kolay anlayabilmek için PHP isim alanları ile dosya sistemleri arasındaki benzerlikten yola çıkılabilir. Bir dosya sistemindeki bir dosyaya üç yolla erişilebilir:

  1. fan.txt şeklinde göreli dosya ismiyle. Bu isim dosya sisteminde içinde bulunulan dizin geçerlidizin/ olmak üzere geçerlidizin/fan.txt olarak çözümlenir. Dolayısıyla geçerli dizin /home/veli ise dosya ismi /home/veli/fan.txt olarak çözümlenecektir.
  2. altdizin/fan.txt şeklinde göreli dosya yolu. Bu isim dosya sisteminde içinde bulunulan dizin geçerlidizin/ olmak üzere geçerlidizin/altdizin/fan.txt olarak çözümlenir.
  3. /home/veli/fan.txt şeklinde mutlak dosya yolu. Bu, /home/veli/fan.txt olarak çözümlenir.
Aynı kurallar PHP'deki isim alanlı elemanlara da uygulanabilir. Örneğin bir sınıf ismine üç şekilde başvurulabilir:
  1. $a = new fan(); veya fan::durukyöntem(); gibi bir nitelenmemiş isim veya öneksiz bir sınıf ismi. Eğer geçerli isim alanı ismi geçerlisimalanı ise bu isim, geçerlisimalanı\fan olarak çözümlenir. Eğer kod küresel ve isim alansız ise, isim fan olarak çözümlenecektir. Bir ayrıntı: Eğer isim alanlı işlev ve sabitler tanımlı ise nitelenmemiş isimli işlevler ve sabitler küresel işlevler ve sabitler olarak çözümlenir. Ayrıntılar için İsim alanlarının kullanımı: Son çare olarak küresel işlev ve sabitler bölümüne bakınız.
  2. $a = new altisimalanı\fan(); veya altisimalanı\fan::durukyöntem(); gibi bir nitelenmemiş isim veya öneksiz bir sınıf ismi. Eğer geçerli isim alanı ismi geçerlisimalanı ise bu isim, geçerlisimalanı\altisimalanı\fan olarak çözümlenir. Eğer kod küresel ve isim alansız ise, isim altisimalanı\fan olarak çözümlenecektir.
  3. $a = new \geçerlisimalanı\fan(); veya \geçerlisimalanı\fan::durukyöntem(); gibi tamamen nitelenmiş isim veya küresel önekli bir isim. Bu isim daima kodda belirtildiği gibi geçerlisimalanı\fan olarak çözümlenir.

Üç söz dizimi aşağıda örneklenmiştir:

dosya1.php

<?php
namespace Fan\Fin\altisimalanı;

const FAN = 1;
function fan() {}
class fan
{
    static function durukyöntem() {}
}
?>

dosya2.php

<?php
namespace Fan\Fin;
include 'dosya1.php';

const FAN = 2;
function fan() {}
class fan
{
    static function durukyöntem() {}
}

/* Nitelenmemiş isim */
fan();              // Fan\Fin\fan işlevine çözümlenir
fan::durukyöntem(); // Fan\Fin\fan sınıfının durukyöntem yöntemine çözümlenir
echo FAN;           // Fan\Fin\FAN sabitine çözümlenir

/* Nitelenmiş isim */
altisimalanı\fan(); // Fan\Fin\altisimalanı\fan işlevine çözümlenir
altisimalanı\fan::durukyöntem(); // Fan\Fin\altisimalanı\fan sınıfının
                                 // durukyöntem yöntemine çözümlenir
echo altisimalanı\FAN; // Fan\Fin\altisimalanı\FAN sabitine çözümlenir

/* Tamamen nitelenmiş isim */
\Fan\Fin\fan();              // Fan\Fin\fan işlevine,
\Fan\Fin\fan::durukyöntem(); // Fan\Fin\fan sınıfının durukyöntem yöntemine,
echo \Fan\Fin\FAN;           // Fan\Fin\FAN sabitine çözümlenir
?>

Herhangi bir küresel sınıf, işlev veya sabite \strlen(), \Exception veya \INI_ALL gibi tamamen nitelenmiş isimleriyle erişilebileceğine dikkat ediniz.

Örnek 1 - Küresel sınıf, işlev ve sabitlere bir isim alanı içinden erişim

<?php
namespace Fan;

function strlen() {}
const INI_ALL = 3;
class Exception {}

$a = \strlen('merhaba');      // strlen küresel işlevini çağırır
$b = \INI_ALL;                // INI_ALL küresel sabitini çağırır
$c = new \Exception('error'); // Exception küresel sınıfını örnekler
?>

Birden Fazla İsim Alanının Aynı Dosyada Tanımlanması
İsim alanları ve devingen dil özellikleri
İsim Alanları


İsim alanları ve devingen dil özellikleri

PHP'nin isim alanları gerçeklenimi bir programlama dili olarak PHP'nin kendi devingen doğasından etkilenir. Örnek olarak aşağıdaki kodu isim alanlı koda dönüştürmek istersek:

Örnek 1 - Devingen olarak erişilen elemanlar

örnek1.php:

<?php
class sınıfadı
{
    function __construct()
    {
        echo __METHOD__,"\n";
    }
}
function işlevadı()
{
    echo __FUNCTION__,"\n";
}
const sabitadı = "küresel";

$a = 'sınıfadı';
$obj = new $a;                   // sınıfadı::__construct basar
$b = 'işlevadı';
$b();                            // işlevadı basar
echo constant('sabitadı'), "\n"; // küresel basar
?>
Tamamen nitelenmiş isim kullanmak gerekir (isim alanı önekli sınıf adı). Bir devingen sınıf, işlev veya sabit ismi içinde bir nitelenmiş isim ile tamamen nitelenmiş isim arasında bir fark olmadığından baştaki ters bölünün gereksiz oluşuna dikkat edin.

Örnek 2 - Devingen olarak erişilen isim alanlı elemanlar

<?php
namespace isimalanıadı;
class sınıfadı
{
    function __construct()
    {
        echo __METHOD__,"\n";
    }
}
function işlevadı()
{
    echo __FUNCTION__,"\n";
}
const sabitadı = "isimalanlı";

include 'örnek1.php';

$a = 'sınıfadı';
$obj = new $a;                    // sınıfadı::__construct basar
$b = 'işlevadı';
$b(); // prints funcname
echo constant('sabitadı'), "\n"; // küresel basar

/* çift tırnakları kullanacaksanız, "\\isimalanıadı\\sınıfadı"
   biçiminde olmalıdır */
$a = '\isimalanıadı\sınıfadı';
$obj = new $a; // isimalanıadı\sınıfadı::__construct basar
$a = 'isimalanıadı\sınıfadı';
$obj = new $a; // bu da isimalanıadı\sınıfadı::__construct basar
$b = 'isimalanıadı\işlevadı';
$b(); // isimalanıadı\işlevadı basar
$b = '\isimalanıadı\işlevadı';
$b(); //bu da isimalanıadı\işlevadı basan
echo constant('\isimalanıadı\sabitadı'), "\n"; // isimalanlı basar
echo constant('isimalanıadı\sabitadı'), "\n"; // bu da isimalanlı basar
?>

SSS arasındaki Dizgelerdeki isim alanı adlarının öncelenmesi konusuna da bakmayı unutmayın.

İsim alanlarının kullanımı: Temeller
namespace sözcüğü ve __NAMESPACE__ sabiti
İsim Alanları


namespace sözcüğü ve __NAMESPACE__ sabiti

PHP, geçerli isim alanı içindeki elemanlara mutlak olarak iki yolla erişimi destekler: sihirli __NAMESPACE__ sabiti ve namespace anahtar sözcüğü.

__NAMESPACE__ sabitinin değeri içinde bulunulan isim alanının adını içeren bir dizgedir. Küresel alandaki isim alansız kod için sabitin değeri boş dizgedir.

Örnek 1 - İsim alanlı kod, __NAMESPACE__ örneği

<?php
namespace Projem;

echo '"', __NAMESPACE__, '"'; // "Projem" basar
?>

Örnek 2 - Küresel kod, __NAMESPACE__ örneği

<?php

echo '"', __NAMESPACE__, '"'; // "" basar
?>
__NAMESPACE__ sabiti devingen olarak oluşturulan isimler için kullanışlıdır.

Örnek 3 - Devingen isim oluşturmak için __NAMESPACE__ kullanımı

<?php
namespace Projem;

function get($sınıfadı)
{
    $a = __NAMESPACE__ . '\\' . $sınıfadı;
    return new $a;
}
?>

namespace sözcüğü, geçerli isim alanından veya bir alt isim alanından doğrudan doğruya bir eleman isteği yaparken kullanılabilir. Sınıflardaki self işlecinin isim alanlarındaki karşılığıdır.

Örnek 4 - Bir isim alanı içinde namespace işleci

<?php
namespace Projem;

use fan\fin as fon;  // "İsim alanlarının kullanımı: ithal/rumuz"

fin\fon();           // Projem\fin\fon() işlevini çağırır
namespace\fin\fon(); // Projem\fin\fon() işlevini çağırır

namespace\işlev();   // Projem\işlev() işlevini çağırır
namespace\alt\işlev();    // Projem\alt\işlev() işlevini çağırır
namespace\isim::yöntem(); // Projem\isim sınıfının duruk "yöntem"
                          // yöntemini çağırır
$a = new namespace\alt\isim(); // Projem\alt\isim sınıfını örnekler
$b = namespace\SABİT;     // Projem\SABİT sabitinin değerini $b'ye atar
?>

Örnek 5 - Küresel kod içinde namespace işleci

<?php

namespace\işlev();        // işlev() işlevini çağırır
namespace\alt\işlev();    // alt\işlev() işlevini çağırır
namespace\isim::yöntem(); // isim sınıfının duruk "yöntem" yöntemini çağırır
$a = new namespace\alt\isim(); // alt\isim sınıfını örnekler
$b = namespace\SABİT;     // SABİT sabitinin değerini $b'ye atar
?>

İsim alanları ve devingen dil özellikleri
İsim alanlarının kullanımı: İthal/Rumuz
İsim Alanları


İsim alanlarının kullanımı: İthal/Rumuz

Dış kaynaklı tamamen nitelenmiş bir isme bir takma adla veya ithal ederek başvurma yeteneği isim alanlarının önemli bir özelliğidir. Bu özellik, Unix dosya sistemlerinin bir dizin veya dosyaya bir sembolik bağ oluşturma yeteneğine benzer.

PHP isim alanları iki çeşit takma ad kullanımını veya ithalini destekler: bir sınıf adına takma ad ve bir isim alanı adına takma ad. Bir işlevin veya sabitin ithalinin desteklenmediğine dikkat ediniz.

PHP'da takma ad kullanımı use işleci üzerinden sağlanır. Aşağıda 3 çeşit ithal örneğine yer verilmiştir:

Örnek 1 - use işleci ile ithal/rumuz kullanımı

<?php
namespace fan;
use Bir\Tam\Sınıfadı as BirBaşkası;

// use Bir\Tam\iAadı as iAadı ile aynıdır
use Bir\Tam\iAadı;

// küresel bir sınıfın ithali
use \DiziNesnesi;

$nesne = new namespace\BirBaşkası; // fan\BirBaşkası sınıfını örnekler
$nesne = new BirBaşkası; // Bir\Tam\Sınıfadı  sınıfını örnekler
iAadı\altia\işlev(); // Bir\Tam\iAadı\altia\işlev işlevini çağırır
$a = new DiziNesnesi(array(1)); // DiziNesnesi sınıfını örnekler
// "use \DiziNesnesi" olmasaydı fan\DiziNesnesi sınıfını örneklerdik
?>
İsim alanlı adlar için baştaki terbölü gereksiz olup izin verilmediği gibi bunlar geçerli isim alanına göre işlenmezler. İthal edilen isimler ise tamamen nitelenmiş olmalıdır. (Tamamen nitelenmiş isimler Fan\Fin şeklinde isim alanı ayracı içermelerine karşın küresel isimler FanFin şeklinde isim alanı ayracı içermezler.)

PHP bunlara ek olarak çok sayıda use deyiminin aynı satırda kullanılmasına imkan veren bir kısayola da sahiptir.

Örnek 2 - use işleci ile rumuz/ithal, çoklu use kullanımı

<?php
use Bir\Tam\Sınıfadı as BirBaşkası, Bir\Tam\iAadı;

$nesne = new BirBaşkası; // Bir\Tam\Sınıfadı sınıfını örnekler
iAadı\altia\işlev();     // Bir\Tam\iAadı\altia\işlev işlevini çağırır
?>

İthal işlemi derleme sırasında yerine getirilir ve dolayısıyla devingen sınıf, işlev ve sabit isimlerini etkilemez.

Örnek 3 - İthal işlemi ve devingen isimler

<?php
use Bir\Tam\Sınıfadı as BirBaşkası, Bir\Tam\iAadı;

$nesne = new BirBaşkası; // Bir\Tam\Sınıfadı sınıfını örnekler
$a = 'BirBaşkası';
$nesne = new $a;         // BirBaşkası sınıfını örnekler
?>

Bunlara ek olarak, ithal işlemi sadece nitelenmemiş ve nitelenmiş isimleri etkiler. Tamamen nitelenmiş isimler mutlak olup ithal işleminden etkilenmez.

Örnek 4 - İthal işlemi ve tamamen nitelenmiş isimler

<?php
use Bir\Tam\Sınıfadı as BirBaşkası, Bir\Tam\iAadı;

$nesne = new BirBaşkası;       // Bir\Tam\Sınıfadı sınıfını örnekler
$nesne = new \BirBaşkası;        // BirBaşkası sınıfını örnekler
$nesne = new BirBaşkası\birşey;  // Bir\Tam\Sınıfadı\birşey sınıfını örnekler
$nesne = new \BirBaşkası\birşey; // BirBaşkası\birşey sınıfını örnekler
?>

namespace sözcüğü ve __NAMESPACE__ sabiti
Küresel Alan
İsim Alanları


Küresel Alan

Herhangi bir isim alanı tanımı olmaksızın, tüm sınıf ve işlev tanımları PHP'de isim alanlarının desteklenmediği zamanlardaki gibi küresel alana yerleştirilir. Bir ismin önüne doğrudan doğruya \ konulması, bu ismin bir isim alanı bağlamında bile küresel alandan bir isim olarak işlem görmesini sağlar.

Örnek 1 - Küresel alan belirtiminin kullanımı

<?php
namespace A\B\C;

/* A\B\C\fopen işlevidir */
function fopen() {
     /* ... */
     $f = \fopen(...); // küresel fopen çağrılır
     return $f;
}
?>

İsim alanlarının kullanımı: İthal/Rumuz
İsim alanlarının kullanımı: son çare olarak küresel işlev ve sabitler
İsim Alanları


İsim alanlarının kullanımı: son çare olarak küresel işlev ve sabitler

Bir isim alanı içinde PHP, bir sınıf ismi, işlev veya sabitin bağlamında nitelenmemiş isimlere rastlarsa bunları farklı önceliklerle ele alır. Sınıf isimleri daima geçerli isim alanı ismine çözümlenir. Dolayısıyla yerleşik veya isim alansız kullanıcı sınıflarına erişmek için, bunların aşağıdaki gibi tamamen nitelenmiş isimlerinin kullanılması gerekir:

Örnek 1 - Küresel sınıflara bir isim alanı içinde erişim

<?php
namespace A\B\C;
class Exception extends \Exception {}

$a = new Exception('hi'); // $a, A\B\C\Exception sınıfının bir nesnesidir
$b = new \Exception('hi'); // $b, Exception sınıfının bir nesnesidir

$c = new ArrayObject; // ölümcül hata, A\B\C\ArrayObject yoktur
?>

İşlevler ve sabitler açısından PHP, bir isim alanlı işlev veya sabit mevcut değilse son çare olarak küresel işlevlere ve sabitlere başvurur.

Örnek 2 - Bir isim alanı içinde son çare olarak küresel işlev ve sabitlerin kullanımı

<?php
namespace A\B\C;

const E_ERROR = 45;
function strlen($str)
{
    return \strlen($str) - 1;
}

echo E_ERROR, "\n"; // "45" basar
echo INI_ALL, "\n"; // "7" basar - son çare olarak küresel INI_ALL

echo strlen('hi'), "\n"; // "1" basar
if (is_array('hi')) { // "dizi değil" basar
    echo "dizi\n";
} else {
    echo "dizi değil\n";
}
?>

Küresel Alan
İsim çözünürlük kuralları
İsim Alanları


İsim çözünürlük kuralları

İsim çözünürlük kurallarının amaçları gereği bazı önemli tanımlar:

İsim alanı adı tanımları
Nitelenmemiş isim

Fan gibi bir isim alanı ayracı içermeyen bir betimleyici.

Nitelenmiş isim

Fan\Fin gibi bir isim alanı ayracı içeren bir betimleyici.

Tamamen nitelenmiş isim

\Fan\Fin gibi bir isim alanı ayracı ile başlayan isim alanı ayraçlı bir betimleyici. namespace\Fan da tamamen nitelenmiş bir isimdir.

İsimler şu kurallara göre çözümlenir:

  1. Tamamen nitelenmiş işlev, sınıf ve sabit isimleri derleme sırasında çözümlenir. Örneğin, new \A\B deyimi A\B sınıfı olarak çözümlenir.
  2. Tamamen nitelenmemiş (nitelenmemiş ve nitelenmiş) isimlerin tamamı derleme sırasında geçerli ithal kurallarına göre dönüştürülür. Örneğin, A\B\C isim alanı C olarak ithal edilmişse bir C\D\e() çağrısı A\B\C\D\e() çağrısına dönüştürülür.
  3. Bir isim alanı içinde ithal kurallarına göre dönüştürülmeyen tüm nitelenmiş isimlerin önüne geçerli isim alanı ismi getirilir. Örneğin, A\B isim alanında yapılmış bir C\D\e() çağrısı A\B\C\D\e() çağrısına dönüştürülecektir.
  4. Nitelenmemiş sınıf isimleri derleme sırasında geçerli ithal kurallarına göre dönüştürülür (kısa ithal ismi için tam isim kullanılır). Örneğin, A\B\C isim alanı C olarak ithal edilmişse new C() deyimi new A\B\C() deyimine dönüştürülür.
  5. İsim alanı içindeki (A\B olsun), nitelenmemiş işlev çağrıları çalışma anında çözümlenir. fan() diye bir işlev şöyle çözümlenir:
    1. Geçerli isim alanında A\B\fan() işlevi aranır.
    2. Küresel fan() işlevi bulunmaya ve çağrılmaya çalışılır.
  6. İsim alanı içindeki (A\B olsun), nitelenmemiş (tamamen nitelenmemiş) veya nitelenmiş sınıf ismi çağrıları çalışma anında çözümlenir. new C() ve new D\E() deyimlerinin çözümlenişi aşağıda verilmiştir. new C() için:
    1. Geçerli isim alanında A\B\C sınıfı aranır.
    2. A\B\C özdevinimli olarak yüklenmeye çalışılır.
    new D\E() için:
    1. Geçerli isim alanı ile öncelenmiş olarak A\B\D\E sınıfı aranır.
    2. A\B\D\E özdevinimli olarak yüklenmeye çalışılır.
    Küresel isim alanındaki bir küresel sınıfa başvururken new \C() şeklinde tamamen nitelenmiş isim kullanılmalıdır.

Örnek 1 - Örneklerle İsim Çözünürlüğü

<?php
namespace A;
use B\D, C\E as F;

// işlev çağrıları

fan();      // Varsa "A" isim alanında tanımlı "fan", yoksa küresel "fan"

\fan();     // Küresel alanda tanımlı "fan" çağrılır

my\fan();   // "A\my" isim alanında tanımlı "fan" çağrılır

F();        // Varsa "A" isim alanında tanımlı "F", yoksa küresel "F"

//sınıf adı çağrıları

new B();    // Varsa "A" isim alanında tanımlı "B" örneklenir
            // Yoksa "A\B" sınıfı özdevinimli olarak yüklenmeye çalışılır

new D();    // ithal kuralları ile, "B" isim alanında tanımlı "D" örneklenir
            // yoksa "B\D" sınıfı özdevinimli olarak yüklenmeye çalışılır

new F();    // ithal kuralları ile, "C" isim alanında tanımlı "E" örneklenir
            // yoksa "C\E" sınıfı özdevinimli olarak yüklenmeye çalışılır

new \B();   // Varsa küresel alanda tanımlı "B" örneklenir
            // yoksa "B" sınıfı özdevinimli olarak yüklenmeye çalışılır

new \D();   // Varsa küresel alanda tanımlı "D" örneklenir
            // yoksa "D" sınıfı özdevinimli olarak yüklenmeye çalışılır

new \F();   // Varsa küresel alanda tanımlı "F" örneklenir
            // yoksa "F" sınıfı özdevinimli olarak yüklenmeye çalışılır

// başka bir isim alanından duruk yöntem/isim alanı işlevleri

B\fan();    // "A\B" isim alanında tanımlı "fan" çağrılır

B::fan();   // "A" isim alanında tanımlı "B" sınıfının "fan" yöntemi çağrılır
            // "A\B" sınıfı yoksa, "A\B" özdevinimli yüklenmeye çalışılır

D::fan();   // ithal kuralları ile, "B" isim alanında tanımlı "D" sınıfının
            // "fan" yöntemi çağrılır; "B\D"  sınıfı yoksa, "B\D"
            // özdevinimli yüklenmeye çalışılır

\B\fan();   // "B" isim alanında tanımlı "fan" çağrılır

\B::fan();  // Küresel alandaki "B" sınıfının "fan" yöntemi çağrılır
            // "B" sınıfı yoksa, "B" özdevinimli yüklenmeye çalışılır

// geçerli isim alanının duruk yöntemleri ve isim alanı işlevleri

A\B::fan();   // "A\A" isim alanında tanımlı "B" sınıfının "fan" yöntemi
              // çağrılır; "A\A\B" sınıfı yoksa, "A\A\B" özdevinimli
              // yüklenmeye çalışılır

\A\B::fan();  // "A\B" isim alanında tanımlı "B" sınıfının "fan" yöntemi
              // çağrılır; "A\B" sınıfı yoksa, "A\B" özdevinimli yüklenmeye
              // çalışılır
?>
İsim alanlarının kullanımı: son çare olarak küresel işlev ve sabitler
SSS: İsim alanları hakkında bilinmesi gerekenler
İsim Alanları


SSS: İsim alanları hakkında bilinmesi gerekenler

Bu SSS iki bölüme ayrılır: genel sorular ve isim alanlarını tamamen anlamaya yardımcı olacak gerçeklenime özgü ayrıntılar.

Önce genel sorularla başlıyoruz.

  1. İsim alanlarını kullanmayacak olsam bile bu konuyla yine de ilgilenmeli miyim?
  2. Yerleşik ve küresel sınıfları bir isim alanı içinde nasıl kullanabilirim?
  3. İsim alanlarının sınıflarını, işlevlerini ve sabitlerini kendi isim alanlarında nasıl kullanabilirim?
  4. \bir\isim veya \isim gibi bir isim nasıl çözümlenir?
  5. bir\isim gibi bir isim nasıl çözümlenir?
  6. isim gibi bir nitelenmemiş sınıf ismi nasıl çözümlenir?
  7. isim gibi bir nitelenmemiş işlev veya sabit ismi nasıl çözümlenir?

İsim alanları gerçeklenimini tamamen anlamaya yardımcı olacak gerçeklenime özgü bir kaç ayrıntı vardır.

  1. İthal edilen isimler aynı dosyada tanımlı sınıf isimleriyle çakışmamalıdır.
  2. İç içe isim alanlarına izin verilmez.
  3. use deyimi üzerinden ne işlevler ne de sabitler ithal edilebilir.
  4. Devingen isim alanları isimlerinin (tırnak içine alınmış betimleyiciler) içindeki tersbölülerin öncelenmesi gerekir.
  5. Tersbölü kullanılarak atıf yapılan tanımsız sabitler ölümcül hataya sebep olur.
  6. Özel NULL, TRUE, FALSE, ZEND_THREAD_SAFE ve ZEND_DEBUG_BUILD sabitleri geçersiz kılınamaz.

İsim alanlarını kullanmayacak olsam bile bu konuyla yine de ilgilenmeli miyim?

Hayır. Ne isim alanları mevcut koddan etkilenir ne de isim alanlarını içermeyen kodlar isim alanlarından etkilenir. İsterseniz kodu böyle yazabilirsiniz:

Örnek 1 - Küresel sınıflara bir isim alanı dışından erişim

<?php
$a = new \stdClass;

Bu kod şuna eşdeğerdir:

Örnek 2 - Küresel sınıflara bir isim alanı dışından erişim

<?php
$a = new stdClass;

Yerleşik ve küresel sınıfları bir isim alanı içinde nasıl kullanabilirim?

Örnek 3 - İsim alanı içinden yerleşik sınıflara erişim

<?php
namespace fan;
$a = new \stdClass;

function test(\ArrayObject $typehintexample = null) {}

$a = \DirectoryIterator::CURRENT_AS_FILEINFO;

// Bir yerleşik veya küresel sınıfın genişletilmesi
class MyException extends \Exception {}
?>

İsim alanlarının sınıflarını, işlevlerini ve sabitlerini kendi isim alanlarında nasıl kullanabilirim?

Örnek 4 - İsim alanındaki dahili sınıf, işlev ve sabitlere erişim

<?php
namespace fan;

class Sınıfım {}

// bir ipucu yazdırmak için geçerli isim alanındaki bir sınıfın kullanımı
function dnm(Sınıfım $biripucuörneği = null) {}
// ipucu yazdırmak için geçerli isim alanındaki bir sınıfın başka
// bir yolla kullanımı
function dnm(\fan\Sınıfım $biripucuörneği = null) {}

// geçerli isim alanındaki bir sınıfın genişletilmesi
class AltSınıfım extends Sınıfım {}

// bir küresel işleve erişim
$a = \küreselişlev();

// bir küresel sabite erişim
$b = \INI_ALL;
?>

\bir\isim veya \isim gibi bir isim nasıl çözümlenir?

\ ile başlayan isimler daima yazıldıkları gibi çözümlenirler, bu bakımdan \bir\isim aslında bir\isim'dir; \Exception da aslında Exception'dır.

Örnek 5 - Tamamen nitelenmiş isimler

<?php
namespace fan;
$a = new \bir\isim(); // "bir\isim" sınıfını örnekler
echo \strlen('hi');   // "strlen" işlevini çağırır
$a = \INI_ALL;        // $a değişkenine "INI_ALL" sabitinin değeri atanır
?>

bir\isim gibi bir isim nasıl çözümlenir?

Bir tersbölü içeren, ancak tersbölü ile başlamayan bir\isim gibi isimler iki farklı yolla çözümlenebilir.

bir ismini başka bir isimle ithal eden bir deyim varsa bu takma isim bir\isim içindeki bir'e uygulanır.

Aksi takdirde, bir\isim isminin önüne geçerli isim alanı adı getirilir.

Örnek 6 - Nitelenmiş isimler

<?php
namespace fon;
use fan\fin as fon;

$a = new bir\isim(); // "fon\bir\isim" sınıfını örnekler
fon\bar::isim(); // "fan\fin\bar" sınıfının "isim" duruk yöntemi çağrılır
bir\bar();        // "fon\bir\bar" işlevi çağrılır
$a = bir\BAR;    // $a değişkenine "fon\bir\BAR" sabitinin değeri atanır
?>

isim gibi bir nitelenmemiş sınıf ismi nasıl çözümlenir?

isim gibi tersbölü içermeyen sınıf isimleri 2 farklı yolla çözümlenebilir.

isim ismini başka bir isimle ithal eden bir deyim varsa bu takma isim isim'e uygulanır.

Aksi takdirde, isim ismininin önüne geçerli isim alanı getirilir.

Örnek 7 - Nitelenmemiş sınıf isimleri

<?php
namespace fon;
use fan\fin as fon;

$a = new isim(); // "fon\isim" sınıfı örneklenir
fon::isim();     // "fan\fin" sınıfının "isim" duruk yöntemi çağrılır
?>

isim gibi bir nitelenmemiş işlev veya sabit ismi nasıl çözümlenir?

isim gibi tersbölü içermeyen işlev ve sabit isimleri 2 farklı yolla çözümlenebilir.

Önce isim isminin önüne geçerli isim alanı ismi getirilir.

Son olarak, eğer isim alanında isim diye bir işlev veya sabit yoksa ve isim diye bir küresel işlev veya sabit varsa küresel alandaki kullanılır.

Örnek 8 - Nitelenmemiş işlev veya sabit isimleri

<?php
namespace fon;
use fan\fin as fon;

const FON = 1;

function bir() {}
function fon() {}
function sort(&$a)
{
    sort($a);
    $a = array_flip($a);
    return $a;
}

bir(); // "fon\bir" çarılır
$a = strlen('hi');  // "fon\strlen" mevcut olmadığından küresel
                    // "strlen" işlevi çağrılır
$arr = array(1,3,2);
$b = sort($arr);    // "fon\sort" işlevi çağrılır
$c = fon(); // "fon\fon" işlevi çağrılır - ithal işlemi uygulanmaz

$a = FON;     // $a değişkenine "fon\FON" sabitinin değeri
              // atanır - ithal işlemi uygulanmaz
$b = INI_ALL; // $b değişkenine "INI_ALL" küresel sabitinin değeri atanır
?>

İthal edilen isimler aynı dosyada tanımlı sınıf isimleriyle çakışmamalıdır.

Aşağıdaki iki betik birlikte kurallara uygundur:

dosya1.php

<?php
namespace bir\isim;
class Sınıfım {}
?>

dosya2.php

<?php
namespace diğer;
class BirŞey {}
?>

dosya.php

<?php
namespace bir\isim;
include 'dosya1.php';
include 'dosya2.php';

use diğer\BirŞey as Sınıfım;
$a = new Sınıfım; // "diğer" isim alanındaki "BirŞey" sınıfını örnekler
?>

Sınıfım sınıfı bir\isim isim alanında mevcut olduğu halde Sınıfım ayrı bir dosyada tanımlandığından herhangi bir isim çakışması olmaz. Ancak, sonraki örnekte, Sınıfım sınıfı use deyimi ile aynı dosyada tanımlandığından isim çakışmasından dolayı ölümcül hata oluşur.

<?php
namespace bir\isim;
use diğer\BirŞey as Sınıfım;
class Sınıfım {} // ölümcül hata: Sınıfım ithal edilen sınıfla çakışır
$a = new Sınıfım;
?>

İç içe isim alanlarına izin verilmez.

PHP isim alanlarının böyle iç içe tanımlanmasına izin vermez:

<?php
namespace bir\isim {
    namespace içiçe {
        class fan {}
    }
}
?>
Bununla birlikte, isim alanlarını birbirinin içinde şöyle tanımlamak mümkündür:
<?php
namespace bir\isim\içiçe {
    class fan {}
}
?>

use deyimi üzerinden ne işlevler ne de sabitler ithal edilebilir.

use deyimlerinden sadece isim alanları ve sınıf isimleri etkilenir. Uzunca bir işlev veya sabit ismini kısaltmak için kendilerini içeren isim alanını ithal etmeniz yeterlidir.

<?php
namespace benimki;
use epeyce\fazla\uzun\isim;

$a = isim\SABİT;
isim\işlev();
?>

Devingen isim alanları isimlerinin (tırnak içine alınmış betimleyiciler) içindeki tersbölülerin öncelenmesi gerekir.

Tersbölü imi dizgelerin içinde bir önceleme karakteri olarak kullanıldığından çift tırnaklar arasına alınmış bir dizge içindeki bir tersbölü karakterinin tersbölü ile öncelenmesi gerekir. Aksi takdirde, istenmeyen durumlar ortaya çıkabilir:

Örnek 9 - İsim alanlı isimleri çift tırnaklar arasında kullanmak tehlikelidir

<?php
$a = new "tehlikeli\nesne"; // \n, çift tırnaklı dizge içinde
                            // satırsonu karakteridir!
$obj = new $a;

$a = new 'bu\tamamen\tehlikesiz\nesne'; // burada sorun yok.
$obj = new $a;
?>
Tersbölüleri tek tırnakları arasına alınmış bir dizge içinde kullanmak daha güvenli olsa da her iki dizge türünde de tersbölüleri öncelemek en güvenlisidir.

Tersbölü kullanılarak atıf yapılan tanımsız sabitler ölümcül hataya sebep olur.

FAN gibi nitelenmemiş olarak tanımsız sabitlere rastlandığında PHP, bunun FAN değerli bir sabit varsayıldığını belirten bir uyarı üretecektir. İster nitelenmiş olsun ister tamamen nitelenmiş olsun tanımsız bir sabit daima ölümcül hataya sebep olur.

Örnek 10 - Tanımsız sabitler

<?php
namespace bar;
$a = FAN;  // uyarı üretir - "FAN" sabit olarak tanımsız olduğundan
           // bir sabit ismi değil, bir sabit değer olarak ele alınır.
$a = \FAN;     // ölümcül hata, isim alanlı tanımsız sabit: FAN
$a = Fin\FAN;  // ölümcül hata, isim alanlı tanımsız sabit: bar\Fin\FAN
$a = \Fin\FAN; // ölümcül hata, isim alanlı tanımsız sabit: Fin\FAN
?>

Özel NULL, TRUE, FALSE, ZEND_THREAD_SAFE ve ZEND_DEBUG_BUILD sabitleri geçersiz kılınamaz.

Bir özel, yerleşik sabiti bir isim alanlı sabit olarak tanımlamaya kalkışmak ölümcül hatayla sonuçlanır.

Örnek 11 - Tanımsız sabitler

<?php
namespace bar;
const NULL = 0;       // ölümcül hata;
const true = 'ahmak'; // bu da ölümcül hata;
// etc.
?>

İsim çözünürlük kuralları
Errors
İsim Alanları


Errors

İçindekiler

  • Temeller
  • Errors in PHP 7

Introduction

Sadly, no matter how careful we are when writing our code, errors are a fact of life. PHP will report errors, warnings and notices for many common coding and runtime problems, and knowing how to detect and handle these errors will make debugging much easier.

SSS: İsim alanları hakkında bilinmesi gerekenler
Temeller
Dil Başvuru Kılavuzu


Temeller

PHP, hataları bir takım iç hata koşuluna karşılık olarak raporlar. Bu hatalar, farklı koşullarda bir işaretçi olarak kullanılabilir ve ihtiyaca göre gösterilip / günlüklenebilir.

PHP tarafından oluşturulan her hata bir türe sahiptir. Bu türlerin bir listesi, beraberinde hangi durumlarda karşılaşılacağı ve davranışın kısa bir açıklaması ile mevcuttur.

PHP ile hata işlemek

Eğer hiçbir hata işleyici belirlenmemişse, PHP hataları yapılandırmasına bağlı olarak işleyecektir. Hangi hataların raporlandığı ve hangilerinin gözardı edildiği error_reporting adlı php.ini yönergesi ile kontrol edilir ya da işleyiş sürecinde error_reporting() işlevi çağırılır. Bununla birlikte, bazı hatalar betiğiniz çalıştırılmaya başlanmadan meydana gelebildiğinden, yapılandırma yönergelerinin ayarlanması şiddetle tavsiye edilir.

Bir geliştirme ortamında, PHP tarafından üretilen sorunları fark etmeniz ve çözmeniz gerektiğinden, error_reporting yönergesini daima E_ALL olarak yapılandırmalısınız. Üretimde ise, E_ALL & ~E_NOTICE & ~E_STRICT & ~E_DEPRECATED gibi daha az ayrıntılı bir seviyeye ayarlamak isteyebilirsiniz. Ancak bir çok durumda olası sorunlar hakkında erken uyarı sağlayabileceği için E_ALL da uygundur.

PHP'nin bu hatalarla ne yapacağı az sonra değineceğimiz iki php.ini yönergesine bağlıdır. display_errors hatanın betik çıktısının bir parçası olarak gösterilip gösterilmeyeceğini denetler. Hata veritabanı parolaları gibi hassas bilgiler içerebileceğinden, üretim ortamında bu ayar her zaman etkisiz kılınmış olmalıdır. Ancak geliştirme ortamında, hataların anında raporlandığından emin olabilmek için etkin hale getirmek çoğu zaman kullanışlı olacaktır.

Hataların gösterilmesine ek olarak, PHP log_errors yönergesi etkinleştirildiğinde hataları günlükleyebilir. Bu tüm hataları error_log ile belirlenen bir dosyaya ya da sistem raporlama aracına günlükleyecektir. Hataları günlükleyebildiğiniz ve daha sonra bu hataları temel alarak raporlama yapabileceğiniz için bu yönerge üretim ortamlarında ziyadesiyle kullanışlı olabilir.

Kullanıcı hata işleyiciler

Eğer PHP'nin öntanımlı hata işleyicileri yetersizse, bir çok hata türünü kendi hata işleyicilerinizle set_error_handler() yönergesini kurarak işleyebilirsiniz. Bazı hata türleri bu şekilde işlenemese de, işlenebilen hatalar betiğinizin uygun gördüğü şekilde işlenebilecektir. Örneğin, bu özelleştirilmiş bir hata sayfasının kullanıcıya gösterilmesi ve daha sonra ayrıntılı bilginin e-posta aracılığı ile günlüklenmesi olabilir.

Errors
Errors in PHP 7
Errors


Errors in PHP 7

PHP 7 changes how most errors are reported by PHP. Instead of reporting errors through the traditional error reporting mechanism used by PHP 5, most errors are now reported by throwing Error exceptions.

As with normal exceptions, these Error exceptions will bubble up until they reach the first matching catch block. If there are no matching blocks, then any default exception handler installed with set_exception_handler() will be called, and if there is no default exception handler, then the exception will be converted to a fatal error and will be handled like a traditional error.

As the Error hierarchy does not inherit from Exception, code that uses catch (Exception $e) { ... } blocks to handle uncaught exceptions in PHP 5 will find that these Errors are not caught by these blocks. Either a catch (Error $e) { ... } block or a set_exception_handler() handler is required.

Error hierarchy

  • Throwable
    • Error
      • ArithmeticError
        • DivisionByZeroError
      • AssertionError
      • ParseError
      • TypeError
    • Exception
      • ...
Temeller
İstisnalar
Errors


İstisnalar

İçindekiler

  • İstisnaları Genişletmek

PHP 5 diğer programlama dillerindekine benzer bir istisna modeline sahiptir. Bir istisna oluşturulabilir (throw) ve yakalanabilir (catch). Olası istisnaların yakalanabilmesi için, kod bir try bloğu içine alınabilir. Her try bloğuna karşılık en az bir tane catch veya finally bloğu olması gerekir.

Oluşturulan nesne ya bir Exception sınıfı ya da bir Exception alsınıfınıb örneği olmalıdır. Bunu sağlamayan bir nesne oluşturmaya çalışmak (throw) ölümcül bir PHP hatasına yol açmaz.

catch

Farklı sınıflara ait istisnaları yakalamak için birden fazla catch bloğu kullanılabilir. Normal çalışma sıradaki son catch bloğundan sonra devam eder. Buradaki normal çalışma (try bloğu içinde hiçbir istisna oluşmadığı veya bir catch bloğu ile eşleşen bir oluşmuş istisnalar sınıfının mevcut olmadığı duruma karşılıktır) sıradaki tanımlanmış son catch bloğundan sora devam eder. İstisnalar bir catch bloğu içerisinde oluşmuş olabileceği gibi yeniden de oluşabilir (throw).

Bir istisna oluştuğunda, istisnanın oluştuğu yerden sonraki kodlar çalıştırılmaz ve PHP oluşan istisna ile uyuşan ilk catch bloğunu bulmaya çalışır. Bir istisnanın yakalanmaması durumunda, set_exception_handler() işlevi ile evvelce bir istisna eylemcisi tanımlanmamışsa, PHP bir ölümcül hata durumu oluşturur ve bir "Uncaught Exception ..." ("Yakalanmamış istisna ...") iletisi çıktılar.

finally

PHP 5.5 ve sonrasında catch bloklarının yerine veya sonrasında bir finally bloğu da belirtilebilir. Bir istisnanın oluşmamışsa bile ve normal çalışmaya dönülmeden önce finally bloğu içindeki kodlar daima try ve catch bloklarından sonra çalıştırılır.

Notlar

Bilginize:

Yerleşik PHP işlevleri aslında hata raporlama yapmakta, istisnaları sadece nesne yönelimli güncel eklentiler kullanmaktadır. Bununla birlikte hatalar ErrorException ile kolayca istisnalara dönüştürülebilir.

İpucu

Standard PHP Kütüphanesi (SPL) bol bol yerleşik istisna içerir.

Örnekler

Örnek 3 - Bir İstisna Oluşturmak

<?php
function inverse($x) {
    if (!$x) {
        throw new Exception('Sıfıra bölme.');
    }
    else return 1/$x;
}

try {
    echo inverse(5) . "\n";
    echo inverse(0) . "\n";
} catch (Exception $e) {
    echo 'Yakalanan olağandışılık: ',  $e->getMessage(), "\n";
}

// Çalışma sürer
echo 'Merhaba Dünya';
?>

Yukarıdaki örneğin çıktısı:

0.2
Yakalanan olağandışılık: Sıfıra bölme.
Merhaba Dünya

Örnek 4 - Bir finally bloğu ile istisnanın işleme sokulması

<?php
function inverse($x) {
    if (!$x) {
        throw new Exception('Sıfıra bölme.');
    }
    return 1/$x;
}

try {
    echo inverse(5) . "\n";
} catch (Exception $e) {
    echo 'İstisna yakalandı: ',  $e->getMessage(), "\n";
} finally {
    echo "İlk finally bloğu.\n";
}

try {
    echo inverse(0) . "\n";
} catch (Exception $e) {
    echo 'İstisna yakalandı: ',  $e->getMessage(), "\n";
} finally {
    echo "İkinci finally bloğu.\n";
}

// İcra sürer
echo "Merhaba Dünya\n";
?>

Yukarıdaki örneğin çıktısı:

0.2
İlk finally bloğu.
İstisna yakalandı: Sıfıra bölme..
İkinci finally bloğu.
Merhaba Dünya

Örnek 5 - İç içe istisnalar

<?php

class MyException extends Exception { }

class Test {
    public function testing() {
        try {
            try {
                throw new MyException('foo!');
            } catch (MyException $e) {
                /* yeniden yakala */
                throw $e;
            }
        } catch (Exception $e) {
            var_dump($e->getMessage());
        }
    }
}

$foo = new Test;
$foo->testing();

?>

Yukarıdaki örneğin çıktısı:

string(4) "foo!"
Errors in PHP 7
İstisnaları Genişletmek
Dil Başvuru Kılavuzu


İstisnaları Genişletmek

Yerleşik Exception sınıfını genişleten kullanıcı tanımlı bir istisna sınıfı tanımlanabilir. Aşağıdaki üyeler ve özellikler, yerleşik Exception sınıfından türetilen alt sınıf içerisinde nelerin erişilebilir olduğunu göstermektedir.

Örnek 1 - Yerleşik Exception sınıfı

<?php
class Exception
{
    protected $message = 'Bilinmeyen istisna';  // istisna iletisi
    private   $string;                          // __toString önbelleği
    protected $code = 0;                     // kullanıcı tanımlı istisna kodu
    protected $file;                         // istisnanın kaynak dosyası
    protected $line;                  // istisnanın kaynak dosyasındaki satırı
    private   $trace;                           // geriye doğru hata izleme
    private   $previous;              // istisnalar iç içe ise önceki istisna

    public function __construct($message = null, $code = 0,
                                  Exception $previous = null);

    final private function __clone();           // İstisna kopyalamayı engeller
    final public function getMessage();         // istisna iletisi
    final public function getCode();            // istisnanın kodu
    final public function getFile();            // kaynak dosya
    final public function getLine();            // kaynak dosya satırı
    final public function getTrace();           // backtrace() dizisi
    final public function getTraceAsString();   // biçemli hata izleme dizgesi
    final public  function getPrevious();       // önceki istisna

    // Geçersiz kılınabilir //
    public function __toString();  // görüntüleme için biçemlenmiş dizge
}
?>

Bir sınıf yerleşik Exception sınıfını genişletiyor ve nesne kurucuyu yeniden tanımlıyorsa, mevcut tüm verinin düzgün biçimde atandığından emin olmak için parent::__construct() işlevinin de çağrılması hararetle önerilir. Nesne bir karakter dizisi olarak sunulduğunda özelleştirilmiş bir çıktı sağlayabilmek için __toString() yöntemi geçersiz kılınabilir.

Bilginize:

İstisnaların kopyaları yapılamaz. Bir istisnanın kopyasını yapmaya çalışmak ölümcül hatayla (E_FATAL seviyesinden bir hata) ile sonuçlanır.

Örnek 2 - Exception sınıfının genişletilmesi (PHP 5.3.0+)

<?php
/**
 * Özelleştirilmiş bir istisna sınıfı tanımlayalım
 */
class MyException extends Exception
{
    // İstisnayı yeniden tanımlayalım, böylece ileti seçimlik olmaktan çıkar
    public function __construct($message, $code = 0,
                                Exception $previous = null) {
        // biraz kod

        // her şeyin düzgün atandığından emin olalım
        parent::__construct($message, $code, $previous);
    }

    // nesnenin özelleştirilmiş karakter dizisi gösterimi
    public function __toString() {
        return __CLASS__ . ": [{$this->code}]: {$this->message}\n";
    }

    public function customFunction() {
        echo "Bu türdeki istisnalar için özelleştirilmiş işlev\n";
    }
}

/**
 * İstisnayı denemek için bir sınıf oluşturalım
 */
class TestException
{
    public $var;

    const THROW_NONE    = 0;
    const THROW_CUSTOM  = 1;
    const THROW_DEFAULT = 2;

    function __construct($avalue = self::THROW_NONE) {

        switch ($avalue) {
            case self::THROW_CUSTOM:
                // özelleştirilmiş istisna oluştur
                throw new MyException('1 geçersiz bir değiştirgedir', 5);
                break;

            case self::THROW_DEFAULT:
                // öntanımlı olarak bir oluşturulur.
                throw new Exception('2 geçerli bir değiştirge değildir', 6);
                break;

            default:
                // İstisna yok; nesne oluşturulacak.
                $this->var = $avalue;
                break;
        }
    }
}

// Örnek 1
try {
    $o = new TestException(TestException::THROW_CUSTOM);
} catch (MyException $e) {      // Yakalanacaktır
    echo "Benim istisnam yakalandı\n", $e;
    $e->customFunction();
} catch (Exception $e) {        // Bu atlanır
    echo "Öntanımlı istisna yakalandı\n", $e;
}

// Çalışmaya devam et
var_dump($o);  // Null
echo "\n\n";

// Örnek 2
try {
    $o = new TestException(TestException::THROW_DEFAULT);
} catch (MyException $e) {      // Bu tür ile uyuşmuyor
    echo "Benim istisnam yakalandı\n", $e;
    $e->customFunction();
} catch (Exception $e) {        // Bu yakalanacaktır
    echo "Öntanımlı istisna yakalandı\n", $e;
}

// Çalışmaya devam et
var_dump($o);  // Null
echo "\n\n";

// Örnek 3
try {
    $o = new TestException(TestException::THROW_CUSTOM);
} catch (Exception $e) {        // Yakalanacaktır
    echo "Öntanımlı İstisna yakalandı\n", $e;
}

// Çalışmaya devam et
var_dump($o);  // Null
echo "\n\n";

// Örnek 4
try {
    $o = new TestException();
} catch (Exception $e) {        // Bu atlandır; istisna yok
    echo "Öntanımlı İstisna yakalandı\n", $e;
}

// Çalışmaya devam et
var_dump($o); // TestException
echo "\n\n";
?>

Bilginize:

Versions of PHP 5, prior to PHP 5.3.0'dan önceki PHP 5 sürümleri iç içe istisnaları desteklemez. Aşağıdaki kod parçası bu örneği çalıştırmak isterseniz MyException sınıfının yerine kullanılabilir.

<?php
/**
 * İstisnayı denemek için bir sınıf oluşturalım
 */
class MyException extends Exception
{
    // İstisnayı yeniden tanımlayalım, böylece ileti seçimlik olmaktan çıkar
    public function __construct($message, $code = 0) {
        // some code

        // Herşeyin düzgün olarak atandığından emin olalım
        parent::__construct($message, $code);
    }

    // Nesnenin özel dizge gösterimi
    public function __toString() {
        return __CLASS__ . ": [{$this->code}]: {$this->message}\n";
    }

    public function customFunction() {
        echo "İstisnanın bu türü için özel işlev\n";
    }
}
?>

İstisnalar
Generators
İstisnalar


Generators

İçindekiler

  • Generators overview
  • Generator syntax
  • Comparing generators with Iterator objects
İstisnaları Genişletmek
Generators overview
Dil Başvuru Kılavuzu


Generators overview

(PHP 5 >= 5.5.0, PHP 7)

Generators provide an easy way to implement simple iterators without the overhead or complexity of implementing a class that implements the Iterator interface.

A generator allows you to write code that uses foreach to iterate over a set of data without needing to build an array in memory, which may cause you to exceed a memory limit, or require a considerable amount of processing time to generate. Instead, you can write a generator function, which is the same as a normal function, except that instead of returning once, a generator can yield as many times as it needs to in order to provide the values to be iterated over.

A simple example of this is to reimplement the range() function as a generator. The standard range() function has to generate an array with every value in it and return it, which can result in large arrays: for example, calling range(0, 1000000) will result in well over 100 MB of memory being used.

As an alternative, we can implement an xrange() generator, which will only ever need enough memory to create an Iterator object and track the current state of the generator internally, which turns out to be less than 1 kilobyte.

Örnek 1 Implementing range() as a generator

<?php
function xrange($start, $limit, $step = 1) {
    if ($start < $limit) {
        if ($step <= 0) {
            throw new LogicException('Step must be +ve');
        }

        for ($i = $start; $i <= $limit; $i += $step) {
            yield $i;
        }
    } else {
        if ($step >= 0) {
            throw new LogicException('Step must be -ve');
        }

        for ($i = $start; $i >= $limit; $i += $step) {
            yield $i;
        }
    }
}

/*
 * Note that both range() and xrange() result in the same
 * output below.
 */

echo 'Single digit odd numbers from range():  ';
foreach (range(1, 9, 2) as $number) {
    echo "$number ";
}
echo "\n";

echo 'Single digit odd numbers from xrange(): ';
foreach (xrange(1, 9, 2) as $number) {
    echo "$number ";
}
?>

Yukarıdaki örneğin çıktısı:

Single digit odd numbers from range():  1 3 5 7 9
Single digit odd numbers from xrange(): 1 3 5 7 9

Generator objects

When a generator function is called for the first time, an object of the internal Generator class is returned. This object implements the Iterator interface in much the same way as a forward-only iterator object would, and provides methods that can be called to manipulate the state of the generator, including sending values to and returning values from it.

Generators
Generator syntax
Generators


Generator syntax

A generator function looks just like a normal function, except that instead of returning a value, a generator yields as many values as it needs to.

When a generator function is called, it returns an object that can be iterated over. When you iterate over that object (for instance, via a foreach loop), PHP will call the generator function each time it needs a value, then saves the state of the generator when the generator yields a value so that it can be resumed when the next value is required.

Once there are no more values to be yielded, then the generator function can simply exit, and the calling code continues just as if an array has run out of values.

Bilginize:

A generator cannot return a value: doing so will result in a compile error. An empty return statement is valid syntax within a generator and it will terminate the generator.

yield keyword

The heart of a generator function is the yield keyword. In its simplest form, a yield statement looks much like a return statement, except that instead of stopping execution of the function and returning, yield instead provides a value to the code looping over the generator and pauses execution of the generator function.

Örnek 1 A simple example of yielding values

<?php
function gen_one_to_three() {
    for ($i = 1; $i <= 3; $i++) {
        // Note that $i is preserved between yields.
        yield $i;
    }
}

$generator = gen_one_to_three();
foreach ($generator as $value) {
    echo "$value\n";
}
?>

Yukarıdaki örneğin çıktısı:

1
2
3

Bilginize:

Internally, sequential integer keys will be paired with the yielded values, just as with a non-associative array.

Dikkat

If you use yield in an expression context (for example, on the right hand side of an assignment), you must surround the yield statement with parentheses in PHP 5. For example, this is valid:

$data = (yield $value);

But this is not, and will result in a parse error in PHP 5:

$data = yield $value;

The parenthetical restrictions do not apply in PHP 7.

This syntax may be used in conjunction with the Generator::send() method.

Yielding values with keys

PHP also supports associative arrays, and generators are no different. In addition to yielding simple values, as shown above, you can also yield a key at the same time.

The syntax for yielding a key/value pair is very similar to that used to define an associative array, as shown below.

Örnek 2 Yielding a key/value pair

<?php
/*
 * The input is semi-colon separated fields, with the first
 * field being an ID to use as a key.
 */

$input = <<<'EOF'
1;PHP;Likes dollar signs
2;Python;Likes whitespace
3;Ruby;Likes blocks
EOF;

function input_parser($input) {
    foreach (explode("\n", $input) as $line) {
        $fields = explode(';', $line);
        $id = array_shift($fields);

        yield $id => $fields;
    }
}

foreach (input_parser($input) as $id => $fields) {
    echo "$id:\n";
    echo "    $fields[0]\n";
    echo "    $fields[1]\n";
}
?>

Yukarıdaki örneğin çıktısı:

1:
    PHP
    Likes dollar signs
2:
    Python
    Likes whitespace
3:
    Ruby
    Likes blocks
Dikkat

As with the simple value yields shown earlier, yielding a key/value pair in an expression context requires the yield statement to be parenthesised:

$data = (yield $key => $value);

Yielding null values

Yield can be called without an argument to yield a NULL value with an automatic key.

Örnek 3 Yielding NULLs

<?php
function gen_three_nulls() {
    foreach (range(1, 3) as $i) {
        yield;
    }
}

var_dump(iterator_to_array(gen_three_nulls()));
?>

Yukarıdaki örneğin çıktısı:

array(3) {
  [0]=>
  NULL
  [1]=>
  NULL
  [2]=>
  NULL
}

Yielding by reference

Generator functions are able to yield values by reference as well as by value. This is done in the same way as returning references from functions: by prepending an ampersand to the function name.

Örnek 4 Yielding values by reference

<?php
function &gen_reference() {
    $value = 3;

    while ($value > 0) {
        yield $value;
    }
}

/*
 * Note that we can change $number within the loop, and
 * because the generator is yielding references, $value
 * within gen_reference() changes.
 */
foreach (gen_reference() as &$number) {
    echo (--$number).'... ';
}
?>

Yukarıdaki örneğin çıktısı:

2... 1... 0...

Generator delegation via yield from

In PHP 7, generator delegation allows you to yield values from another generator, Traversable object, or array by using the yield from keyword. The outer generator will then yield all values from the inner generator, object, or array until that is no longer valid, after which execution will continue in the outer generator.

If a generator is used with yield from, the yield from expression will also return any value returned by the inner generator.

Dikkat

Storing into an array (e.g. with iterator_to_array())

yield from does not reset the keys. It preserves the keys returned by the Traversable object, or array. Thus some values may share a common key with another yield or yield from, which, upon insertion into an array, will overwrite former values with that key.

A common case where this matters is iterator_to_array() returning a keyed array by default, leading to possibly unexpected results. iterator_to_array() has a second parameter use_keys which can be set to FALSE to collect all the values while ignoring the keys returned by the Generator.

Örnek 5 yield from with iterator_to_array()

<?php
function from() {
    yield 1; // key 0
    yield 2; // key 1
    yield 3; // key 2
}
function gen() {
    yield 0; // key 0
    yield from from(); // keys 0-2
    yield 4; // key 1
}
// pass false as second parameter to get an array [0, 1, 2, 3, 4]
var_dump(iterator_to_array(gen()));
?>

Yukarıdaki örneğin çıktısı:

array(3) {
  [0]=>
  int(1)
  [1]=>
  int(4)
  [2]=>
  int(3)
}

Örnek 6 Basic use of yield from

<?php
function count_to_ten() {
    yield 1;
    yield 2;
    yield from [3, 4];
    yield from new ArrayIterator([5, 6]);
    yield from seven_eight();
    yield 9;
    yield 10;
}

function seven_eight() {
    yield 7;
    yield from eight();
}

function eight() {
    yield 8;
}

foreach (count_to_ten() as $num) {
    echo "$num ";
}
?>

Yukarıdaki örneğin çıktısı:

1 2 3 4 5 6 7 8 9 10

Örnek 7 yield from and return values

<?php
function count_to_ten() {
    yield 1;
    yield 2;
    yield from [3, 4];
    yield from new ArrayIterator([5, 6]);
    yield from seven_eight();
    return yield from nine_ten();
}

function seven_eight() {
    yield 7;
    yield from eight();
}

function eight() {
    yield 8;
}

function nine_ten() {
    yield 9;
    return 10;
}

$gen = count_to_ten();
foreach ($gen as $num) {
    echo "$num ";
}
echo $gen->getReturn();
?>

Yukarıdaki örneğin çıktısı:

1 2 3 4 5 6 7 8 9 10
Generators overview
Comparing generators with Iterator objects
Generators


Comparing generators with Iterator objects

The primary advantage of generators is their simplicity. Much less boilerplate code has to be written compared to implementing an Iterator class, and the code is generally much more readable. For example, the following function and class are equivalent:

<?php
function getLinesFromFile($fileName) {
    if (!$fileHandle = fopen($fileName, 'r')) {
        return;
    }

    while (false !== $line = fgets($fileHandle)) {
        yield $line;
    }

    fclose($fileHandle);
}

// versus...

class LineIterator implements Iterator {
    protected $fileHandle;

    protected $line;
    protected $i;

    public function __construct($fileName) {
        if (!$this->fileHandle = fopen($fileName, 'r')) {
            throw new RuntimeException('Couldn\'t open file "' . $fileName . '"');
        }
    }

    public function rewind() {
        fseek($this->fileHandle, 0);
        $this->line = fgets($this->fileHandle);
        $this->i = 0;
    }

    public function valid() {
        return false !== $this->line;
    }

    public function current() {
        return $this->line;
    }

    public function key() {
        return $this->i;
    }

    public function next() {
        if (false !== $this->line) {
            $this->line = fgets($this->fileHandle);
            $this->i++;
        }
    }

    public function __destruct() {
        fclose($this->fileHandle);
    }
}
?>

This flexibility does come at a cost, however: generators are forward-only iterators, and cannot be rewound once iteration has started. This also means that the same generator can't be iterated over multiple times: the generator will need to be rebuilt by calling the generator function again.

Generator syntax
Gönderimlerle İlgili Herşey
Generators


Gönderimlerle İlgili Herşey

İçindekiler

  • Gönderim Nedir?
  • Gönderim Ne Yapar?
  • Gönderimler Ne Değildir?
  • Gönderimle Aktarım
  • Gönderimle Döndürme
  • Gönderimi Tanımsız Yapmak
  • Gönderimleri kullanan diğer oluşumlar
Comparing generators with Iterator objects
Gönderim Nedir?
Dil Başvuru Kılavuzu


Gönderim Nedir?

PHP'de gönderimler aynı değişken içeriğine farklı isimlerle erişmek demektir. C'deki göstericilere benzemezler; örneğin, üzerlerinde gösterici aritmetiği kullanamazsınız, çünkü gerçekte bellek adresleri değillerdir.Ayrıntılar için Gönderimler Ne Değildir? bölümüne bakınız. daha çok simge tablosu PHP'de şuna dikkat edin: Değişken içeriği ve değişken ismi farklı şeylerdir. Bu bakımdan, aynı içeriğin farklı isimleri olabilir. En yakın benzerlik, Unix dosya isimleri ve dosyaları ile kurulabilir; değişken isimleri dizinlerse, değişken içeriği de dizinin içindeki dosyadır. Gönderimler ise Unix dosya sistemindeki sabit bağlar olarak düşünülebilir.

Gönderimlerle İlgili Herşey
Gönderim Ne Yapar?
Gönderimlerle İlgili Herşey


Gönderim Ne Yapar?

Gönderimleri kullanıldığı üç temel işlem vardır: gönderimli atama, gönderimli aktarma, ve gönderimli döndürme. Bu bölümde bu işlemlerle ilgili bağlantılar verilerek bir başlangıç yapılmıştır.

Gönderimli atama

Bu ilk temel işlemde, iki değişkenin aynı içeriğe atıf yapmasına izin verilir. Örnek:

<?php
$a =& $b;
?>
Bunun anlamı, $a ve $b değişkenlerinin aynı içeriği gösterdiğidir.

Bilginize:

Burada $a ve $b tamamen eşittir; ne $a, $b'yi göstermekte ne de $b, $a'yı göstermektedir; $a ve $b aynı yeri göstermektedir.

Bilginize:

Eğer bir dizi gönderimle kopyalanmışsa gösterilen şey değerler değildir. Bu ayrıca işlevlere değerleriyle aktarılan diziler için de geçerlidir.

Bilginize:

Eğer tanımlanmamış bir değişken gönderimle atanır, aktarılır veya döndürülürse oluşturulmuş olur.

Örnek 1 - Gönderimlerin tanımlanmamış değişkenlerle kullanımı

<?php
function foo(&$var) { }

foo($a); // $a "oluşturulur" ve değer olarak null atanır

$b = array();
foo($b['b']);
var_dump(array_key_exists('b', $b)); // bool(true)

$c = new StdClass;
foo($c->d);
var_dump(property_exists($c, 'd')); // bool(true)
?>

Aynı sözdizimi, gönderim döndüren işlevler ve new işleci (PHP 4.0.4 ve sonrası, PHP 5.0.0'a kadar) ile kullanılabilir:

<?php
$foo =& dğşkn_bul($bar);
?>
PHP 5'ten beri, new özdevinimli olarak gönderim döndürmekte, bu bakımdan böyle bir bağlamda =& kullanımı önerilmemekte ve kullanıldığında E_STRICT seviyesinde ileti üretmektedir.

Uyarı

Bir işlevin içinde global olarak bildirilmiş bir değişkeni gönderimli olarak atarsanız gönderim sadece işlevin içinde görünür olur. $GLOBALS dizisini kullanarak bundan kaçınabilirsiniz.

Örnek 2 - İşlev içinde küresel değişkenlere gönderim

<?php
$var1 = "Örnek değişken";
$var2 = "";

function küresel_gönderimler($küreselleri_kullan)
{
    global $var1, $var2;
    if (!$küreselleri_kullan) {
        $var2 =& $var1; // sadece işlev içinde görünürdür
    } else {
        $GLOBALS["var2"] =& $var1; // küresel alanda da görünürdür
    }
}

küresel_gönderimler(false);
echo "var2'ye '$var2' atanır\n"; // var2'ye '' atanır
küresel_gönderimler(true);
echo "var2'ye '$var2' atanır\n"; // var2'ye 'Örnek değişken' atanır
?>
global $var; deyimi $var =& $GLOBALS['var']; deyimine bir kısayol olarak düşünülür. Bu bakımdan $var'a başka bir gönderim atamak sadece yerel değişkenin gönderimini değiştirir.

Bilginize:

Eğer bir değişkene foreach döngüsü içinde gönderimle bir değer atarsanız gönderimde de değişiklik yapılmış olur.

Örnek 3 - foreach döngüsü içinde gönderim

<?php
$ref = 0;
$row =& $ref;
foreach (array(1, 2, 3) as $row) {
    // işlemler
}
echo $ref; // 3 - yinelenen dizinin son elemanı
?>

Gönderimli aktarım

Gönderimlerle yapılan ikinci şey değişkenleri gönderimle aktarmaktır. Bir işlev içinde bir yerel değişken oluşturup çağrı etki alanında bir değişkenle aynı içeriğe gönderim yaparak bu gerçeklenebilir. Örnek:

<?php
function foo(&$var)
{
    $var++;
}

$a=5;
foo($a);
echo $a; // 6 çıktılar
?>
$a'nın 6 olmasının sebebi foo işlevinde $var değişkeninin $a'nın içeriğine gönderimli olmasıdır. Daha ayrıntılı açıklamayı gönderimle aktarım bölümünde bulabilirsiniz.

Gönderimli değer döndürme

Gönderimlerle yapılan üçüncü şey gönderimli değer döndürmedir.

Gönderim Nedir?
Gönderimler Ne Değildir?
Gönderimlerle İlgili Herşey


Gönderimler Ne Değildir?

Evvelce de değinildiği gibi bir gönderim bir gösterici değildir. Yani, aşağıdaki oluşum bekleneni yapmayacaktır:

<?php
function foo(&$var)
{
    $var =& $GLOBALS["baz"];
}
foo($bar);
?>

Burada foo işlevindeki $var değişkeni çağrı yapılan yerde $bar değişkenine bağlanmakla kalmayıp bir de işlevin içinde $GLOBALS["baz"] değişkenine bağlanmaktadır. $bar'ın işlev etki alanı içinde gönderim mekanizması ile başka bir değişkene bağlanması mümkün değildir, çünkü $bar değişkeni foo işlevinin etki alanında mevcut değildir (işlev etki alanında $var tarafından temsil edilmekteyse de $var sadece değişkenin içeriğine sahiptir ve çağrı simgeleri tablosunda ismi değere bağlayan şey değildir). İşlev tarafından seçilen değişkenlere gönderim yapabilmek için değeri gönderimle döndürmelisiniz.

Gönderim Ne Yapar?
Gönderimle Aktarım
Gönderimlerle İlgili Herşey


Gönderimle Aktarım

Bir değişkeni bir işleve gönderimle aktarabilirsiniz, böylece işlevin değiştirgelerini değiştirebilirsiniz. Sözdizimi şöyledir:

<?php
function işlev(&$değişken)
{
    $değişken++;
}

$a=5;
foo($a);
// Burada $a artık 6'dır
?>

Bilginize: İşlevin çağrıldığı yerde gönderim yapıldığına dair bir belirtinin olmadığına dikkat ediniz; gönderim sadece işlevin üzerindedir. İşlev tanımı değiştirgeyi gönderimle gerektiği gibi aktarmak için tek başına yeterlidir. PHP'nin son sürümlerinde & imini işlev(&$a); biçeminde kullandığınız takdirde "Çağrı sırasında gönderimle aktarım" anlamına gelen bir uyarı alırsınız.

Aşağıdakiler bir işleve gönderimle aktarılabilir:

  • işlev($a) şeklinde bir değişken.
  • işlev(new sınıf()) şeklinde new deyimi.

  • Bir işlevden döndürerek bir gönderim. Örnek:

    <?php
    function foo(&$var)
    {
            $var++;
    }
    function &    bar()
    {
            $a = 5;
        return     $a;
    }
    foo(bar());
    ?>
    Ayrıca, gönderimle değer döndürme konusuna da bakınız.

Sonuç tanımsız olacağından, başka hiçbir ifade gönderimle aktarılamaz. Örneğin, aşağıdaki gönderimle aktarım örneği geçersizdir:

<?php
function foo(&$var)
{
    $var++;
}
function bar() // Dikkat, & yok
{
    $a = 5;
    return $a;
}
foo(bar()); // PHP 5.0.5'ten beri ölümcül hata üretmekte

foo($a = 5); // Bir ifade, değişken değil
foo(5);      // Ölümcül hata üretir
?>
Bunlar PHP 4.0.4 ve sonrası için gereklidir.

Gönderimler Ne Değildir?
Gönderimle Döndürme
Gönderimlerle İlgili Herşey


Gönderimle Döndürme

Gönderimle döndürme, gönderimin bağlayacağı değişkeni hedefleyen bir işlev kullanmak istediğiniz takdirde yararlıdır. Gönderimle döndürmeyi başarımı arttırmak amacıyla kullanmayın. Motor, bunu kendine göre en iyileyecek yeteneğe sahiptir. Sadece geçerli bir teknik sebebiniz olduğunda gönderimle döndürme yapın! Gönderimle döndürmek için şu söz dizimi kullanılır:

<?php
class sınıf {
    public $değer = 42;

    public function &değeriBağla() {
        return $this->değer;
    }
}

$obj = new sınıf;
$değerim = &$obj->değeriBağla(); // $değerim, $obj->değer için bir gönderimdir
echo $değerim;                   // 42 basar
$obj->değer = 2;
echo $değerim;                   // 2 basar
?>
Bu örnekte, değeriBağla işlevi ile döndürülen nesne özelliği değişkene atanmaktadır, eğer gönderim söz dizimi kullanılmamış olsaydı özelliğin kendisi değil bir kopyası atanmış olacaktı.

Bilginize: Değiştirge aktarmanın tersine, burada her iki taraftada (çağıran ve çağrılan) & kullanımı zorunludur. Çağıran tarafta $değerim değişkenine yapılanın bir atama değil gönderim bağlantısı olduğunu, çağrılan tarafta ise yapılanın sıradan bir değer kopyalama değil bir gönderimle döndürme olduğunu belirtmektedir.

Bilginize: return ($this->değer); söz dizimi ile bir işlevden bir gönderim döndürmek isterseniz bir değişkeni değil de bir ifadenin sonucunu döndürmeye çalışmış olacağınızdan bu istediğinizi yapmayacaktır. Bir işlevden gönderimle sadece değişkenleri döndürebilirsiniz, başka bir şey döndüremezsiniz. PHP 4.4.0 ve PHP 5.1.0'dan beri gönderimle döndürme söz dizimini kullanan bir işlevden bir devingen ifadenin veya bir new işlecinin sonucunu döndürmeye çalışmak E_NOTICE seviyesinden bir hata oluşturmaktadır.

Gönderimle Aktarım
Gönderimi Tanımsız Yapmak
Gönderimlerle İlgili Herşey


Gönderimi Tanımsız Yapmak

Bir gönderimi unset() ile tanımsız yapmakla aslında değişken ismiyle değeri arasındaki bağlantıyı bozmuş olursunuz, değişkeni içeriksiz bırakmış olmazsınız (aynı değeri gösteren iki değişkenden sadece birini ortadan kaldırmış olursunuz). Örnek:

<?php
$a = 1;
$b =& $a;
unset($a);
?>
Burada $b değil $a tanımsız olur.

Bu işlem, Unix unlink komutunun yaptığı işlemden pek de farklı değildir.

Gönderimle Döndürme
Gönderimleri kullanan diğer oluşumlar
Gönderimlerle İlgili Herşey


Gönderimleri kullanan diğer oluşumlar

PHP'deki çoğu söz dizimi oluşumu, gönderim mekanizması üzerinden gerçeklenir, bu bakımdan yukarıda gönderimle ilgili bahsedilenlerin tümü bu oluşumlara da uygulanır. Gönderimle aktarma veya döndürme gibi bazı oluşumlardan yukarıda söz edilmiştir. Gönderimleri kullanan diğer oluşumlar şunlardır:

Küresel Gönderimler

Bir değişkeni global $değişken deyimi ile bildirdiğiniz zaman aslında küresel bir değişkene bir gönderim oluşturmuş olursunuz. Aşağıdaki örnekte de aynı işlem yapılmaktadır:

<?php
$değişken =& $GLOBALS["değişken"];
?>

Yani, küresel olarak bildirildikten sonra unset($değişken) ile küresel değişkeni tanımsız yapamazsınız, sadece yerel değişken tanımsız olur.

$this

Bir nesne yönteminde, $this daima çağrılan nesneye bir gönderimdir.

Gönderimi Tanımsız Yapmak
Öntanımlı Değişkenler
Gönderimlerle İlgili Herşey


Öntanımlı Değişkenler

PHP çalıştırdığı her betiğe çok sayıda evvelce tanımlanmış değişken sağlar. Değişkenler dış kaynaklı değişkenlerden yerleşik ortam değişkenlerine, son hata iletisinden son elde edilen başlıklara kadar geniş bir sahada kendilerini gösterirler.

Ayrıca " register_globals beni nasıl etkiler?" başlıklı SSS kısmına da bakınız.

İçindekiler

  • Süper küreseller — Süper küreseller bütün etki alanlarında daima mevcut olan yerleşik değişkenlerdir
  • $GLOBALS — Küresel alanda bulunan bütün değişkenleri içerir
  • $_SERVER — Sunucu ve işletme ortamı bilgisi
  • $_GET — HTTP GET değişkenleri
  • $_POST — HTTP POST değişkenleri
  • $_FILES — HTTP Dosya Yükleme değişkenleri
  • $_REQUEST — HTTP İstek değişkenleri
  • $_SESSION — Oturum değişkenleri
  • $_ENV — Ortam değişkenleri
  • $_COOKIE — HTTP Çerezleri
  • $php_errormsg — Önceki hata iletisi
  • $HTTP_RAW_POST_DATA — Ham POST verisi
  • $http_response_header — HTTP yanıt başlıkları
  • $argc — Betiğe geçirilen ifade sayısı
  • $argv — Betiğe geçirilen ifade dizisi
Gönderimleri kullanan diğer oluşumlar
Süper küreseller
Dil Başvuru Kılavuzu


Süper küreseller bütün etki alanlarında daima mevcut olan yerleşik değişkenlerdir

Öntanımlı Değişkenler
$GLOBALS
Öntanımlı Değişkenler
PHP Manual

Süper küreseller

Süper küreseller — Süper küreseller bütün etki alanlarında daima mevcut olan yerleşik değişkenlerdir

Açıklama

PHP'de öntanımlı değişkenlerin çoğu "süper küresel"dir. Bu, betik boyunca bütün etki alanlarında kullanılabilir oldukları anlamına gelir. İşlevler veya yöntemler içinde bu değişkenlere erişmek için global $değişken; yapmak gerekmez.

Süper küresel değişkenler şunlardır:

  • $GLOBALS
  • $_SERVER
  • $_GET
  • $_POST
  • $_FILES
  • $_COOKIE
  • $_SESSION
  • $_REQUEST
  • $_ENV

Sürüm Bilgisi

Sürüm: | Açıklama
4.1.0 | PHP'ye süper küreseller getirildi.

Notlar

Bilginize: Değişken kullanılabilirliği

Öntanımlı olarak, bütün süper küreseller mevcuttur, fakat bunların kullanılabilirliğini etkileyen yönergeler vardır. Daha fazla bilgi için variables_order yönergesine bakınız.

Bilginize: register_globals ile ilgilenmek

Eğer kullanımdan kaldırılmış olan register_globals yönergesi on olarak belirtilirse değişkenler betiğin küresel etki alanında da kullanılabilir olacaklardır. Örneğin, $_POST['foo'] aynı zamanda $foo olarak da mevcut olacaktır.

İlgili bilgi için, "register_globals beni nasıl etkiler?" başlıklı SSS kısmına bakınız.

Bilginize: Değişken değişkenler

Süper küreseller, işlevler veya sınıf yöntemleri içinde değişken değişkenler olarak kullanılamazlar.

Ayrıca Bakınız

  • değişken etki alanı
  • variables_order yönergesi
  • Süzme eklentisi

Öntanımlı Değişkenler
$GLOBALS
Öntanımlı Değişkenler


Küresel alanda bulunan bütün değişkenleri içerir

Süper küreseller
$_SERVER
Öntanımlı Değişkenler
PHP Manual

$GLOBALS

$GLOBALS — Küresel alanda bulunan bütün değişkenleri içerir

Açıklama

Geçerli betiğin küresel alanında tanımlı bütün değişkenleri içeren bütünleşik bir dizidir. Değişken isimleri dizinin anahtarlarıdır.

Örnekler

Örnek 1 - $GLOBALS örneği

<?php
function test() {
    $foo = "yerel değişken";

    echo '$foo küresel alanda: ' . $GLOBALS["foo"] . "\n";
    echo '$foo yerel alanda: ' . $foo . "\n";
}

$foo = "Örnek içerik";
test();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

$foo küresel alanda: Örnek içerik
$foo yerel alanda: yerel değişken

Notlar

Bilginize:

Bu bir süper küreseldir. Yani bir betiğin her yerinde geçerlidir. Değişkene işlevler ve yöntemlerin içinden erişmek için global $değişken; deyimine gerek yoktur.

Bilginize: Değişken kullanılabilirliği

Diğer süper küresellerden farklı olarak, $GLOBALS PHP'de her zaman var olmuştur.

Süper küreseller
$_SERVER
Öntanımlı Değişkenler


Sunucu ve işletme ortamı bilgisi

$GLOBALS
$_GET
Öntanımlı Değişkenler
PHP Manual

$_SERVER

$HTTP_SERVER_VARS [kaldırıldı]

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

$_SERVER -- $HTTP_SERVER_VARS [kaldırıldı] — Sunucu ve işletme ortamı bilgisi

Açıklama

$_SERVER başlıklar, yollar ve betiklerin yerleri gibi bilgileri içeren bir dizidir. Bu dizideki girdiler HTTP sunucusu tarafından oluşturulur. Her HTTP sunucusu bunları sunacak diye bir garanti yoktur; sunucular bazıları ile işlem yapmayabilir veya burada listelenmeyen başkalarını sağlayabilirler. Bu değişkenlerden çoğu » CGI/1.1 Belirtimi içinde ele alınırlar; yani bunlar genellikle her HTTP sunucusunda desteklenirler.

PHP 5.4.0 öncesinde, $HTTP_SERVER_VARS aynı başlangıç bilgisini içeriyordu, fakat bir süper küresel değildi ($HTTP_SERVER_VARS ve $_SERVER farklı değişkenlerdir ve PHP de bu şekilde ele alır).

İndisler

Aşağıdaki elemanlardan bazılarını $_SERVER içinde belki bulursunuz belki de bulamazsınız. PHP komut satırında çalıştırıldığında bu değişkenlerden bazılarının herhangi bir anlamı varsa komut satırında da kullanılabileceğine dikkat ediniz.

'PHP_SELF'
Çalıştırılmakta olan betiğin, belge kök dizinine göreli dosya adıdır. Örneğin, http://example.com/foo/bar.php adresindeki bir betik için $_SERVER['PHP_SELF'] değeri /foo/bar.php olacaktır. __FILE__ sabiti geçerli dosyanın tam yolunu ve dosya adını içerir. PHP 4.3.0 dan beri, eğer PHP komut satırı işlemcisi olarak çalışıyorsa bu değişken betik adını içerir. Önceki sürümlerde bu mevcut değildi.
'argv'
Betiğe aktarılan değiştirge dizisidir. Betik komut satırında çalıştığında, komut satırı değiştirgelerine C gibi erişim imkanı verir. Betik GET yöntemi üzerinden çağrıldığında, bu değişken sorgu dizgesini içerir.
'argc'
Betiğe aktarılan komut satırı değiştirgelerinin sayısını içerir (betik eğer komut satırından çalıştırılıyorsa).
'GATEWAY_INTERFACE'
Sunucunun desteklediği CGI belirtiminin sürümünü içerir; 'CGI/1.1' gibi.
'SERVER_ADDR'
Geçerli betiğin altında çalıştığı sunucunun IP adresidir.
'SERVER_NAME'
Geçerli betiğin altında çalıştığı sunucunun adıdır. Eğer betik bir sanal konak üzerinde çalışıyorsa, o sanal konağın adını içerir.

Bilginize: Apache 2 altında, UseCanonicalName = On ve ServerName atamalarını yapmalısınız. Aksi takdirde, bu değer istemci tarafından belirtilmiş muhtemelen sahte bir konak ismi içerebilir. Güvenliliğin önemli olduğu içeriklerde bu değere güvenmek doğru değildir.

'SERVER_SOFTWARE'
Sunucu kimlik dizgesi, isteklere verilen cevap başlıklarının içinde verilir.
'SERVER_PROTOCOL'
Sayfa isteğinin yapıldığı protokolün ismi ve sürümüdür; 'HTTP/1.1' gibi;
'REQUEST_METHOD'
Sayfaya erişim için kullanılan istek yöntemi; 'GET', 'HEAD', 'POST', 'PUT' gibi.

Bilginize:

Eğer istek yöntemi HEAD ise PHP betiği başlıklar gönderildikten sonra (çıktının çıktı tamponu olmadan üretilmesinden sonra anlamında) sonlandırılır.

'REQUEST_TIME'
İsteğin başlangıç zaman etiketidir. PHP 5.1.0'dan beri mevcuttur.
'REQUEST_TIME_FLOAT'
Mikrosaniye cinsinden isteğin başlangıç zaman damgası. PHP 5.4.0 itibariyle geçerlidir.
'QUERY_STRING'
Sorgu dizgesi, sayfaya erişirken kullanılabilir.
'DOCUMENT_ROOT'
Sunucunun ayar dosyasında da tanımlandığı gibi, geçerli betiğin altında çalıştığı belge kök dizinidir.
'HTTP_ACCEPT'
Geçerli isteğin Accept: başlığının içeriğidir.
'HTTP_ACCEPT_CHARSET'
Geçerli isteğin Accept-Charset: başlığının içeriğidir. Örnek: 'iso-8859-9,*,utf-8'.
'HTTP_ACCEPT_ENCODING'
Geçerli isteğin Accept-Encoding: başlığının içeriğidir. Örnek: 'gzip'.
'HTTP_ACCEPT_LANGUAGE'
Geçerli isteğin Accept-Language: başlığının içeriğidir. Örnek: 'tr'.
'HTTP_CONNECTION'
Geçerli isteğin Connection: başlığının içeriğidir. Örnek: 'Keep-Alive'.
'HTTP_HOST'
Geçerli isteğin Host: başlığının içeriğidir.
'HTTP_REFERER'
Kullanıcı tarayıcısını geçerli sayfaya gönderen sayfanın (varsa) adresidir. Bu kullanıcı tarayıcısı tarafından belirtilir. Her kullanıcı tarayıcısı bunu belirtmez ve bazıları HTTP_REFERER değiştirmeyi bir özellik olarak sunar. Kısaca, buna güvenilemez.
'HTTP_USER_AGENT'
Geçerli isteğin User-Agent: başlığının içeriğidir. Bu sayfaya erişen kullanıcı tarayıcısını ifade eden bir dizgedir. Örneğin: Mozilla/4.5 [en] (X11; U; Linux 2.2.9 i586) get_browser() işlevi ile elde edebileceğiniz bu değeri sayfanın çıktısını kullanıcının tarayıcısına göre şekillendirmek için kullanabilirsiniz.
'HTTPS'
Eğer betik HTTPS protokolü ile sorgulanmışsa boş olmayan bir değer atanır.

Bilginize: IIS ile ISAPI kullanırken, eğer istek HTTPS protokolü ile yapılmamışsa, bu değerin off olacağına dikkat ediniz.

'REMOTE_ADDR'
Geçerli sayfayı görüntüleyen kullanıcının IP adresidir.
'REMOTE_HOST'
Geçerli sayfayı görüntüleyen kullanıcının sunucu adıdır. Kullanıcının REMOTE_ADDR değerinden ters dns sorgusuyla elde edilir.

Bilginize: HTTP sunucunuz bu değişkeni oluşturmak için ayarlanmak zorundadır. Örneğin Apache'de httpd.conf içinde HostnameLookups On olmalıdır. Ayrıca gethostbyaddr() işlevine de bakınız.

'REMOTE_PORT'
Kullanıcının makinesinin HTTP sunucusu ile haberleşmek için kullandığı porttur.
'REMOTE_USER'
Kimliği kanıtlanmış kullanıcı.
'REDIRECT_REMOTE_USER'
İstek dahilen yönlendirilmişse kimliğİ kanıtlanmış kullanıcı.
'SCRIPT_FILENAME'

Geçerli betiğin mutlak yoludur.

Bilginize:

Eğer betik file.php veya ../file.php gibi göreli bir yolla komut satırından çalıştırılırsa, $_SERVER['SCRIPT_FILENAME'] kullanıcı tarafından belirtilen göreli yolu içerir.

'SERVER_ADMIN'
HTTP sunucusu ayar dosyasındaki SERVER_ADMIN (Apache için) yönergesine verilen değerdir. Eğer betik bir sanal konak üzerinde çalışıyorsa, o sanal konak için için tanımlanmış değer olur.
'SERVER_PORT'
Haberleşme için HTTP sunucusu tarafından kullanılan porttur. Öntanımlı kurulumlar için değeri '80'dir; örneğin SSL kullanımında bunu güvenli HTTP portu olarak ne tanımladıysanız ona değiştirebilirsiniz.

Bilginize: Apache 2 altında, fiziksel (gerçek) portu almak için UseCanonicalName = On'dan başka UseCanonicalPhysicalPort = On da tanımlamalısınız, aksi takdirde, bu değer sahte olabilir ve fiziksel port değerini döndürüp döndürmeyeceği belli olmaz. Güvenliliğin önemli olduğu içeriklerde bu değere güvenmek doğru değildir.

'SERVER_SIGNATURE'
Eğer etkinse, sunucu tarafından üretilen sayfalara eklenen, sunucu sürümünü ve sanal konak adını içeren dizgidir.
'PATH_TRANSLATED'
Sunucu gerekli sanaldan gerçeğe dönüşümleri yaptıktan sonra geçerli betiğin dosya sistemini (belge kökü değil) temel alan yoludur.

Bilginize: PHP 4.3.2'den itibaren PATH_TRANSLATED değeri Apache 2'de Apache 1'in tersine SAPI altında örtük olarak belirtilmez. Apache 1'de bu değer Apache tarafından yerleştirilmediğinde bu değer SCRIPT_FILENAME sunucu değişkeni ile aynı olurdu. Bu değişiklik, PATH_TRANSLATED değişkeninin sadece PATH_INFO değişkeninin tanımlı olması durumunda var olmasını gerektiren CGI belirtimi ile uyum sağlamak için yapılmıştır. Apache 2 kullanıcıları PATH_INFO tanımlatmak için httpd.conf içinde AcceptPathInfo = On yapılandırmasını kullanabilirler.

'SCRIPT_NAME'
Geçerli betiğin yolunu içerir. Kendi kendilerini göstermesi gereken sayfalar için kullanışlıdırlar. __FILE__ sabiti geçerli (örn. içerilen) dosyanın tam yolunu vedosya adını içerir.
'REQUEST_URI'
Sayfaya erişim için belirtilen URI; örneğin, '/index.html'.
'PHP_AUTH_DIGEST'
Özetli HTTP kimlik doğrulaması yapılırken bu değişken istemci tarafından gönderilen 'Authorization' başlığında belirtilir (böylece siz de uygun geçerlilik denetimini yapmak için bunu kullanabilirsiniz).
'PHP_AUTH_USER'
HTTP kimlik doğrulaması yapılırken bu değişkene kullanıcı tarafından sağlanan kullanıcı adı atanır.
'PHP_AUTH_PW'
HTTP kimlik doğrulaması yapılırken bu değişkene kullanıcı tarafından sağlanan parola atanır.
'AUTH_TYPE'
Apache altında modül olarak HTTP kimlik doğrulaması yapılırken bu değişkene kullanılan kimlik doğrulama türü atanır.
'PATH_INFO'
İstemci tarafından sağlanan dosya yolunu içerir; dosya isminin ardında bir sorgu dizgesi olsa bile bu gösterilmez. Örneğin, betiğe şu URL ile erişiliyor olsun: http://www.example.com/php/path_info.php/some/stuff?foo=bar. Bu durumda $_SERVER['PATH_INFO'], /some/stuff değerini içerecektir.
'ORIG_PATH_INFO'
PHP tarafından işlenmeden önceki özgün 'PATH_INFO'.

Sürüm Bilgisi

Sürüm: | Açıklama
5.4.0 | Uzun dizili kayıtlar kullanımdan kaldırıldığından dolayı $HTTP_SERVER_VARS artık kullanılmamaktadır.
5.3.0 | $HTTP_SERVER_VARS kullanımını sağlayan register_long_arrays yönergesinin kullanımı önerilmemektedir.
4.1.0 | $_SERVER ortaya çıkmıştır ve $HTTP_SERVER_VARS kullanımı önerilmemektedir.

Örnekler

Örnek 1 - $_SERVER örneği

<?php
echo $_SERVER['SERVER_NAME'];
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

www.example.com

Notlar

Bilginize:

Bu bir süper küreseldir. Yani bir betiğin her yerinde geçerlidir. Değişkene işlevler ve yöntemlerin içinden erişmek için global $değişken; deyimine gerek yoktur.

Ayrıca Bakınız

  • Süzme eklentisi

$GLOBALS
$_GET
Öntanımlı Değişkenler


HTTP GET değişkenleri

$_SERVER
$_POST
Öntanımlı Değişkenler
PHP Manual

$_GET

$HTTP_GET_VARS [kullanımdan kalktı]

$_GET -- $HTTP_GET_VARS [kullanımdan kalktı] — HTTP GET değişkenleri

Açıklama

URL değiştirgeleri üzerinden geçerli betiğe aktarılan değişkenlerden oluşan bir ilişkisel dizi.

$HTTP_GET_VARS aynı başlangıç bilgisini içerir, fakat bir süper küresel değildir. ($HTTP_GET_VARS ve $_GET farklı değişkenlerdir ve PHP de bu şekilde ele alır.)

Sürüm Bilgisi

Sürüm: | Açıklama
4.1.0 | $_GET ortaya çıkmış ve $HTTP_GET_VARS kullanımdan kaldırılmıştır.

Örnekler

Örnek 1 - $_GET örneği

<?php
echo 'Merhaba ' . htmlspecialchars($_GET["isim"]) . '!';
?>

Kullanıcının http://mesela.dom/?isim=Elif adresini çağırdığı varsayılarak

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Merhaba Elif!

Notlar

Bilginize:

Bu bir süper küreseldir. Yani bir betiğin her yerinde geçerlidir. Değişkene işlevler ve yöntemlerin içinden erişmek için global $değişken; deyimine gerek yoktur.

Bilginize:

GET değişkenleri urldecode() üzerinden aktarılır.

Ayrıca Bakınız

  • Dış kaynaklı değişkenlerin ele alınması
  • Süzme eklentisi

$_SERVER
$_POST
Öntanımlı Değişkenler


HTTP POST değişkenleri

$_GET
$_FILES
Öntanımlı Değişkenler
PHP Manual

$_POST

$HTTP_POST_VARS [kullanımdan kalktı]

$_POST -- $HTTP_POST_VARS [kullanımdan kalktı] — HTTP POST değişkenleri

Açıklama

HTTP POST yöntemi kullanılarak geçerli betiğe aktarılan bütünleşik değişkenler dizisi.

$HTTP_POST_VARS aynı başlangıç bilgisini içerir, fakat bir süper küresel değildir. ($HTTP_POST_VARS ve $_POST farklı değişkenlerdir ve PHP de bu şekilde ele alır.)

Sürüm Bilgisi

Sürüm: | Açıklama
4.1.0 | $_POST ortaya çıkmış ve $HTTP_POST_VARS kullanımdan kaldırılmıştır.

Örnekler

Örnek 1 - $_POST örneği

<?php
echo 'Merhaba ' . htmlspecialchars($_POST["isim"]) . '!';
?>

Kullanıcının POST ile isim=Gizem gönderdiği varsayılarak

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Merhaba Gizem!

Notlar

Bilginize:

Bu bir süper küreseldir. Yani bir betiğin her yerinde geçerlidir. Değişkene işlevler ve yöntemlerin içinden erişmek için global $değişken; deyimine gerek yoktur.

Ayrıca Bakınız

  • Dış kaynaklı değişkenlerin ele alınması
  • Süzme eklentisi

$_GET
$_FILES
Öntanımlı Değişkenler


HTTP Dosya Yükleme değişkenleri

$_POST
$_REQUEST
Öntanımlı Değişkenler
PHP Manual

$_FILES

$HTTP_POST_FILES [kullanımdan kalktı]

$_FILES -- $HTTP_POST_FILES [kullanımdan kalktı] — HTTP Dosya Yükleme değişkenleri

Açıklama

HTTP POST yönetimi kullanılarak geçerli betiğe yüklenen bütünleşik öğe dizisi.

$HTTP_POST_FILES aynı başlangıç bilgisini içerir, fakat bir süper küresel değildir. ($HTTP_POST_FILES ve $_FILES farklı değişkenlerdir ve PHP de bu şekilde ele alır.)

Sürüm Bilgisi

Sürüm: | Açıklama
4.1.0 | $_FILES ortaya çıkmış ve $HTTP_POST_FILES kullanımdan kaldırılmıştır.

Notlar

Bilginize:

Bu bir süper küreseldir. Yani bir betiğin her yerinde geçerlidir. Değişkene işlevler ve yöntemlerin içinden erişmek için global $değişken; deyimine gerek yoktur.

Ayrıca Bakınız

  • move_uploaded_file() - Karşıya yüklenen bir dosyayı yeni bir yere taşır
  • Dosya Yüklemelerini İşlemek

$_POST
$_REQUEST
Öntanımlı Değişkenler


HTTP İstek değişkenleri

$_FILES
$_SESSION
Öntanımlı Değişkenler
PHP Manual

$_REQUEST

$_REQUEST — HTTP İstek değişkenleri

Açıklama

Öntanımlı olarak $_GET, $_POST ve $_COOKIE değişkenlerini içeren ilişkisel bir dizidir.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | request_order yönergesi ilk olarak bu sürümde kullanılmıştır. Bu yönerge $_REQUEST içeriğini etkiler.
4.3.0 | $_FILES bilgisi $_REQUEST'ten çıkarılmıştır.
4.1.0 | $_REQUEST ortaya çıkmıştır.

Notlar

Bilginize:

Bu bir süper küreseldir. Yani bir betiğin her yerinde geçerlidir. Değişkene işlevler ve yöntemlerin içinden erişmek için global $değişken; deyimine gerek yoktur.

Bilginize:

Komut satırından çalışmada, bu dizi argv ve argc girdilerinde içerilmez; bunlar $_SERVER dizisinde bulunur.

Bilginize:

$_REQUEST içindeki değişkenler betiğe GET, POST, ve COOKIE girdi mekanizmaları ile sağlanır ve bu nedenle uzak kullanıcı tarafından değiştirilebilir ve bunlara güvenilemez. Bu dizide listelenen değişkenlerin varlıkları ve sıraları PHP variables_order yapılandırma yönergesine göre tanımlanır.

Ayrıca Bakınız

  • import_request_variables() - GET/POST/Çerez değişkenlerini küresel etki alanına dahil eder
  • Dış kaynaklı değişkenlerle çalışmak
  • Süzme eklentisi
$_FILES
$_SESSION
Öntanımlı Değişkenler


Oturum değişkenleri

$_REQUEST
$_ENV
Öntanımlı Değişkenler
PHP Manual

$_SESSION

$HTTP_SESSION_VARS [kullanımdan kalktı]

$_SESSION -- $HTTP_SESSION_VARS [kullanımdan kalktı] — Oturum değişkenleri

Açıklama

Geçerli betikte kullanılabilecek oturum değişkenlerini içeren bir ilişkisel dizidir. Nasıl kullanıldığıyla ilgili daha fazla bilgi için Oturum İşlevleri belgesine bakınız.

$HTTP_SESSION_VARS aynı başlangıç bilgisini içerir, fakat bir süper küresel değildir ($HTTP_SESSION_VARS ve $_SESSION farklı değişkenlerdir ve PHP de bu şekilde ele alır).

Sürüm Bilgisi

Sürüm: | Açıklama
4.1.0 | $_SESSION ortaya çıkmış ve $HTTP_SESSION_VARS kullanımdan kaldırılmıştır.

Notlar

Bilginize:

Bu bir süper küreseldir. Yani bir betiğin her yerinde geçerlidir. Değişkene işlevler ve yöntemlerin içinden erişmek için global $değişken; deyimine gerek yoktur.

Ayrıca Bakınız

  • session_start() - Oturum verisini ilklendirir

$_REQUEST
$_ENV
Öntanımlı Değişkenler


Ortam değişkenleri

$_SESSION
$_COOKIE
Öntanımlı Değişkenler
PHP Manual

$_ENV

$HTTP_ENV_VARS [kullanımdan kalktı]

$_ENV -- $HTTP_ENV_VARS [kullanımdan kalktı] — Ortam değişkenleri

Açıklama

Ortam yönetimi kullanılarak geçerli betiğe aktarılan bütünleşik ortam değişkenleri dizisi.

Bu değişkenler PHP yazım denetleyicisinin çalıştığı ortamdan PHP'nin küresel isim alanına ithal edilir. Çoğu PHP'nin altında çalıştığı kabuk (shell) tarafından sağlanır. Farklı sistemler farklı türde kabuklar çalıştırırlar, bu bakımdan tam bir tanımlı ortam değişkenleri listesi verilemez. Lütfen tanımlı ortam değişkenleri listesi için kullandığınız kabuğun belgelerine bakınız.

Diğer ortam değişkenleri, CGI değişkenlerini içerir ve PHP'nin bir sunucu hizmeti olarak mı yoksa CGI işlemcisi olarak mı çalıştığına bakmaksızın yerleştirilirler.

$HTTP_ENV_VARS aynı başlangıç bilgisini içerir, fakat bir süper küresel değildir. ($HTTP_ENV_VARS ve $_ENV farklı değişkenlerdir ve PHP de bu şekilde ele alır.)

Sürüm Bilgisi

Sürüm: | Açıklama
4.1.0 | $_ENV ortaya çıkmış ve $HTTP_ENV_VARS kullanımdan kaldırılmıştır.

Örnekler

Örnek 1 - $_ENV örneği

<?php
echo 'Benim adım ' .$_ENV["USER"] . '!';
?>

Bu betiği "yasar" isimli kullanıcının çalıştırdığı varsayılarak

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Benim adım yasar!

Notlar

Bilginize:

Bu bir süper küreseldir. Yani bir betiğin her yerinde geçerlidir. Değişkene işlevler ve yöntemlerin içinden erişmek için global $değişken; deyimine gerek yoktur.

Ayrıca Bakınız

  • getenv() - Bir ortam değişkeninin değerini döndürür
  • Süzme eklentisi

$_SESSION
$_COOKIE
Öntanımlı Değişkenler


HTTP Çerezleri

$_ENV
$php_errormsg
Öntanımlı Değişkenler
PHP Manual

$_COOKIE

$HTTP_COOKIE_VARS [kullanımdan kalktı]

$_COOKIE -- $HTTP_COOKIE_VARS [kullanımdan kalktı] — HTTP Çerezleri

Açıklama

Geçerli betiğe HTTP Çerezleri üzerinden aktarılan bütünleşik bir değişken dizisi

$HTTP_COOKIE_VARS aynı başlangıç bilgisini içerir, fakat süper küresel değildir. ($HTTP_COOKIE_VARS ve $_COOKIE farklı değişkenlerdir ve PHP de bu şekilde ele alır.)

Sürüm Bilgisi

Sürüm: | Açıklama
4.1.0 | $_COOKIE ortaya çıkmış ve $HTTP_COOKIE_VARS kullanımdan kaldırılmıştır.

Örnekler

Örnek 1 $_COOKIE örneği

<?php
echo 'Merhaba ' . htmlspecialchars($_COOKIE["isim"]) . '!';
?>

"isim" çerezinin önceden atandığı varsayılmıştır.

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Merhaba Yaşar!

Notlar

Bilginize:

Bu bir süper küreseldir. Yani bir betiğin her yerinde geçerlidir. Değişkene işlevler ve yöntemlerin içinden erişmek için global $değişken; deyimine gerek yoktur.

Ayrıca Bakınız

  • setcookie() - Bir çerez gönderir
  • Dış kaynaklı değişkenlerin ele alınması
  • Süzme eklentisi

$_ENV
$php_errormsg
Öntanımlı Değişkenler


Önceki hata iletisi

$_COOKIE
$HTTP_RAW_POST_DATA
Öntanımlı Değişkenler
PHP Manual

$php_errormsg

$php_errormsg — Önceki hata iletisi

Açıklama

$php_errormsg PHP tarafından üretilen son hata iletisinin metnini içeren bir değişkendir. Bu değişken sadece hatanın oluştuğu alan içinde ve sadece track_errors ayar seçeneği açıldıysa (öntanımlı değeri kapalıdır) geçerlidir.

Bilginize: Bu değişken sadece php.ini içindeki track_errors yönergesi etkin olduğunda kullanılabilir.

Uyarı

Eğer bir kullanıcı tanımlı hata eylemcisi (set_error_handler()) atanmışsa $php_errormsg değişkenine sadece hata eylemcisi FALSE döndürürse bir değer atanır.

Örnekler

Örnek 1 - $php_errormsg örneği

<?php
@strpos();
echo $php_errormsg;
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Wrong parameter count for strpos()

$_COOKIE
$HTTP_RAW_POST_DATA
Öntanımlı Değişkenler


Ham POST verisi

$php_errormsg
$http_response_header
Öntanımlı Değişkenler
PHP Manual

$HTTP_RAW_POST_DATA

$HTTP_RAW_POST_DATA — Ham POST verisi

Açıklama

$HTTP_RAW_POST_DATA ham POST verisi içerir. Bakınız, always_populate_raw_post_data

$php_errormsg
$http_response_header
Öntanımlı Değişkenler


HTTP yanıt başlıkları

$HTTP_RAW_POST_DATA
$argc
Öntanımlı Değişkenler
PHP Manual

$http_response_header

$http_response_header — HTTP yanıt başlıkları

Açıklama

$http_response_header dizisi get_headers() işlevi gibidir. HTTP sarmalayıcı kullanılırken, $http_response_header HTTP yanıt başlıklarından oluşturulur.

Örnekler

Örnek 1 - $http_response_header örneği

<?php
file_get_contents("http://mesela.dom");
var_dump($http_response_header);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(9) {
  [0]=>
  string(15) "HTTP/1.1 200 OK"
  [1]=>
  string(35) "Date: Sat, 12 Apr 2008 17:30:38 GMT"
  [2]=>
  string(29) "Server: Apache/2.2.3 (CentOS)"
  [3]=>
  string(44) "Last-Modified: Tue, 15 Nov 2005 13:24:10 GMT"
  [4]=>
  string(27) "ETag: "280100-1b6-80bfd280""
  [5]=>
  string(20) "Accept-Ranges: bytes"
  [6]=>
  string(19) "Content-Length: 438"
  [7]=>
  string(17) "Connection: close"
  [8]=>
  string(38) "Content-Type: text/html; CHARSET=Windows-1254"
}

$HTTP_RAW_POST_DATA
$argc
Öntanımlı Değişkenler


Betiğe geçirilen ifade sayısı

$http_response_header
$argv
Öntanımlı Değişkenler
PHP Manual

$argc

$argc — Betiğe geçirilen ifade sayısı

Açıklama

Komut satırından çalıştığında geçerli betiğe aktarılan ifade sayısını içerir.

Bilginize: Betiğin dosya adı her zaman ilk ifade olarak betiğe geçirilir, bu nedenle $argc'nin asgari değeri 1'dir.

Bilginize: Bu değişken sadece register_argc_argv etkin olduğunda kullanılabilir.

Örnekler

Örnek 1 - $argc örneği

<?php
var_dump($argc);
?>

Örneği şu şekilde çalıştırınca: php betik.php arg1 arg2 arg3

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(4)

$http_response_header
$argv
Öntanımlı Değişkenler


Betiğe geçirilen ifade dizisi

$argc
Öntanımlı İstisnalar
Öntanımlı Değişkenler
PHP Manual

$argv

$argv — Betiğe geçirilen ifade dizisi

Açıklama

komut satırından çalıştığında betiğe aktarılan ifade dizi'sini içerir.

Bilginize: İlk ifade her zaman geçerli betiğin adıdır, bu nedenle $argv[0] betiğin adıdır.

Bilginize: Bu değişken sadece register_argc_argv etkin olduğunda kullanılabilir.

Örnekler

Örnek 1 - $argv örneği

<?php
var_dump($argv);
?>

Örneği şu şekilde çalıştırınca: php betik.php arg1 arg2 arg3

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(4) {
  [0]=>
  string(10) "betik.php"
  [1]=>
  string(4) "arg1"
  [2]=>
  string(4) "arg2"
  [3]=>
  string(4) "arg3"
}

$argc
Öntanımlı İstisnalar
Öntanımlı Değişkenler


Öntanımlı İstisnalar

İçindekiler

  • Exception
  • ErrorException

Ayrıca bakınız: SPL İstisnaları

$argv
Exception
Dil Başvuru Kılavuzu


Exception Sınıfı

(PHP 5 >= 5.1.0, PHP 7)

Giriş

Exception tüm istisnalar için temel sınıftır.

Sınıf Sözdizimi

Exception {
/* Özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Yöntemler */
public __construct ([ string $message = "" [, int $code = 0 [, Exception $previous = NULL ]]] )
final public string getMessage ( void )
final public Exception getPrevious ( void )
final public int getCode ( void )
final public string getFile ( void )
final public int getLine ( void )
final public array getTrace ( void )
final public string getTraceAsString ( void )
public string __toString ( void )
final private void __clone ( void )
}

Özellikler

message

İstisna iletisi.

code

İstisna kodu.

file

İstisnanın oluştuğu dosyanın ismi.

line

İstisnanın oluştuğu satırın numarası.

İçindekiler

  • Exception::__construct — İstisna oluşturur
  • Exception::getMessage — İstisna iletisi ile döner
  • Exception::getPrevious — Önceki istisnayı döndürür
  • Exception::getCode — İstisnanın numarası ile döner
  • Exception::getFile — İstisnanın oluştuğu dosyanın adı ile döner
  • Exception::getLine — İstisnanın oluştuğu satırın numarası ile döner
  • Exception::getTrace — Yığıt iziyle döner
  • Exception::getTraceAsString — Yığıt izini bir dizge olarak döndürür
  • Exception::__toString — İstisnanın dizgesel gösterimiyle döner
  • Exception::__clone — İstisna kopyası
Öntanımlı İstisnalar
Exception::__construct
Öntanımlı İstisnalar


İstisna oluşturur

Exception
Exception::getMessage
Exception
PHP Manual

Exception::__construct

(PHP 5 >= 5.1.0, PHP 7)

Exception::__construct — İstisna oluşturur

Açıklama

public Exception::__construct ([ string $message = "" [, int $code = 0 [, Exception $previous = NULL ]]] )

İstisna oluşturur.

Değiştirgeler

message

Oluşturulan istisna iletisi.

code

İstisna kodu.

previous

İstisna zincirindeki önceki istisna.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | previous değiştirgesi eklendi.

Exception
Exception::getMessage
Exception


İstisna iletisi ile döner

Exception::__construct
Exception::getPrevious
Exception
PHP Manual

Exception::getMessage

(PHP 5 >= 5.1.0, PHP 7)

Exception::getMessage — İstisna iletisi ile döner

Açıklama

final public string Exception::getMessage ( void )

İstisna iletisi ile döner.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

İstisna iletisi bir dizge olarak döner.

Örnekler

Örnek 1 - Exception::getMessage() örneği

<?php
try {
    throw new Exception("Bir hata iletisi");
} catch(Exception $e) {
    echo $e->getMessage();
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Bir hata iletisi

Exception::__construct
Exception::getPrevious
Exception


Önceki istisnayı döndürür

Exception::getMessage
Exception::getCode
Exception
PHP Manual

Exception::getPrevious

(PHP 5 >= 5.3.0, PHP 7)

Exception::getPrevious — Önceki istisnayı döndürür

Açıklama

final public Exception Exception::getPrevious ( void )

Önceki istisnayı döndürür (Exception::__construct() kurucusunun üçüncü değiştirgesi).

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Mümkünse önceki Exception nesnesi, yoksa NULL döner.

Örnekler

Örnek 1 - Exception::getPrevious() örneği

Döngüsel olarak ve çıktılıyarak istisna izleme.

<?php
class MyCustomException extends Exception {}

function doStuff() {
    try {
        throw new InvalidArgumentException("Yanlış yapıyorsunuz!", 112);
    } catch(Exception $e) {
        throw new MyCustomException("Bir şeyler oldu", 911, $e);
    }
}

try {
    doStuff();
} catch(Exception $e) {
    do {
        printf("%s:%d %s (%d) [%s]\n", $e->getFile(), $e->getLine(),
                $e->getMessage(), $e->getCode(), get_class($e));
    } while($e = $e->getPrevious());
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

/home/bjori/ex.php:8 Bir şeyler oldu (911) [MyCustomException]
/home/bjori/ex.php:6 Yanlış yapıyorsunuz! (112) [InvalidArgumentException]

Exception::getMessage
Exception::getCode
Exception


İstisnanın numarası ile döner

Exception::getPrevious
Exception::getFile
Exception
PHP Manual

Exception::getCode

(PHP 5 >= 5.1.0, PHP 7)

Exception::getCode — İstisnanın numarası ile döner

Açıklama

final public int Exception::getCode ( void )

İstisna numarasıyla döner.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

İstisna numarası bir integer olarak döner.

Örnekler

Örnek 1 - Exception::getCode() örneği

<?php
try {
    throw new Exception("Bir hata iletisi", 30);
} catch(Exception $e) {
    echo "İstisna numarası: " . $e->getCode();
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

İstisna numarası: 30

Exception::getPrevious
Exception::getFile
Exception


İstisnanın oluştuğu dosyanın adı ile döner

Exception::getCode
Exception::getLine
Exception
PHP Manual

Exception::getFile

(PHP 5 >= 5.1.0, PHP 7)

Exception::getFile — İstisnanın oluştuğu dosyanın adı ile döner

Açıklama

final public string Exception::getFile ( void )

İstisnanın oluştuğu dosyanın adı ile döner.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

İstisnanın oluştuğu dosyanın adı ile döner.

Örnekler

Örnek 1 - Exception::getFile() örneği

<?php
try {
    throw new Exception;
} catch(Exception $e) {
    echo $e->getFile();
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

/home/bjori/tmp/ex.php

Exception::getCode
Exception::getLine
Exception


İstisnanın oluştuğu satırın numarası ile döner

Exception::getFile
Exception::getTrace
Exception
PHP Manual

Exception::getLine

(PHP 5 >= 5.1.0, PHP 7)

Exception::getLine — İstisnanın oluştuğu satırın numarası ile döner

Açıklama

final public int Exception::getLine ( void )

İstisnanın oluştuğu satırın numarası ile döner.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

İstisnanın oluştuğu satırın numarası ile döner.

Örnekler

Örnek 1 - Exception::getLine() örneği

<?php
try {
    throw new Exception("Bir hata iletisi");
} catch(Exception $e) {
    echo "İstisnanın oluştuğu satırın numarası: " . $e->getLine();
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

İstisnanın oluştuğu satırın numarası: 3

Exception::getFile
Exception::getTrace
Exception


Yığıt iziyle döner

Exception::getLine
Exception::getTraceAsString
Exception
PHP Manual

Exception::getTrace

(PHP 5 >= 5.1.0, PHP 7)

Exception::getTrace — Yığıt iziyle döner

Açıklama

final public array Exception::getTrace ( void )

İstisna yığıtının iziyle döner.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

İstisna yığıtının izini bir dizi olarak döndürür.

Örnekler

Örnek 1 - Exception::getTrace() örneği

<?php
function test() {
 throw new Exception;
}

try {
 test();
} catch(Exception $e) {
 var_dump($e->getTrace());
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(1) {
  [0]=>
  array(4) {
    ["file"]=>
    string(22) "/home/bjori/tmp/ex.php"
    ["line"]=>
    int(7)
    ["function"]=>
    string(4) "test"
    ["args"]=>
    array(0) {
    }
  }
}

Exception::getLine
Exception::getTraceAsString
Exception


Yığıt izini bir dizge olarak döndürür

Exception::getTrace
Exception::__toString
Exception
PHP Manual

Exception::getTraceAsString

(PHP 5 >= 5.1.0, PHP 7)

Exception::getTraceAsString — Yığıt izini bir dizge olarak döndürür

Açıklama

final public string Exception::getTraceAsString ( void )

İstisna yığıtının izini bir dizge olarak döndürür.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

İstisna yığıtının izini bir dizge olarak döndürür.

Örnekler

Örnek 1 - Exception::getTraceAsString() örneği

<?php
function test() {
    throw new Exception;
}

try {
    test();
} catch(Exception $e) {
    echo $e->getTraceAsString();
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

#0 /home/bjori/tmp/ex.php(7): test()
#1 {main}

Exception::getTrace
Exception::__toString
Exception


İstisnanın dizgesel gösterimiyle döner

Exception::getTraceAsString
Exception::__clone
Exception
PHP Manual

Exception::__toString

(PHP 5 >= 5.1.0, PHP 7)

Exception::__toString — İstisnanın dizgesel gösterimiyle döner

Açıklama

public string Exception::__toString ( void )

İstisnanın string türündeki gösterimiyle döner.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

İstisnanın string türündeki gösterimiyle döner.

Örnekler

Örnek 1 - Exception::__toString() örneği

<?php
try {
    throw new Exception("Bir hata iletisi");
} catch(Exception $e) {
    echo $e;
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

exception 'Exception' with message 'Bir hata iletisi' in /home/nilgun/tmp/ex.php:3
Stack trace:
#0 {main}

Exception::getTraceAsString
Exception::__clone
Exception


İstisna kopyası

Exception::__toString
ErrorException
Exception
PHP Manual

Exception::__clone

(PHP 5 >= 5.1.0, PHP 7)

Exception::__clone — İstisna kopyası

Açıklama

final private void Exception::__clone ( void )

Ölümcül hatayla sonuçlanan istisnayı kopyalamaya çalışır.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

İstisnalar kopyalanabilir değildir.

Exception::__toString
ErrorException
Exception


ErrorException Sınıfı

(PHP 5 >= 5.1.0, PHP 7)

Giriş

Bir hata istisnası.

Sınıf Sözdizimi

ErrorException extends Exception {
/* Özellikler */
protected int $severity ;
/* Yöntemler */
public __construct ([ string $ileti [, int $num [, int $önem [, string $dosyaismi [, int $satırnum ]]]]] )
final public int getSeverity ( void )
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}

Özellikler

severity

İstisnanın önem derecesi

Örnekler

Örnek 1 - Hata iletilerinin set_error_handler() ile ErrorException içinde döndürülmesi

<?php
function exception_error_handler($errno, $errstr, $errfile, $errline ) {
    throw new ErrorException($errstr, 0, $errno, $errfile, $errline);
}
set_error_handler("exception_error_handler");

/* İstisnayı oluşturalım */
strpos();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Fatal error: Uncaught exception 'ErrorException' with message 'Wrong parameter count for strpos()' in /home/bjori/tmp/ex.php:8
Stack trace:
#0 [internal function]: exception_error_handler(2, 'Wrong parameter...', '/home/bjori/php...', 8, Array)
#1 /home/bjori/php/cleandocs/test.php(8): strpos()
#2 {main}
  thrown in /home/bjori/tmp/ex.php on line 8

İçindekiler

  • ErrorException::__construct — İstisna oluşturur
  • ErrorException::getSeverity — İstisnanın önem derecesi ile döner
Exception::__clone
ErrorException::__construct
Öntanımlı İstisnalar


İstisna oluşturur

ErrorException
ErrorException::getSeverity
ErrorException
PHP Manual

ErrorException::__construct

(PHP 5 >= 5.1.0, PHP 7)

ErrorException::__construct — İstisna oluşturur

Açıklama

public ErrorException::__construct ([ string $ileti [, int $num [, int $önem [, string $dosyaismi [, int $satırnum ]]]]] )

İstisna oluşturur.

Değiştirgeler

ileti

Oluşturulan istisna iletisi.

num

İstisnanın numarası.

önem

İstisnanın önem derecesi.

dosyaismi

İstisnanın oluştuğu dosyanın adı.

satırnum

İstisnanın oluştuğu satırın numarası.

ErrorException
ErrorException::getSeverity
ErrorException


İstisnanın önem derecesi ile döner

ErrorException::__construct
Öntanımlı Arayüzler ve Sınıflar
ErrorException
PHP Manual

ErrorException::getSeverity

(PHP 5 >= 5.1.0, PHP 7)

ErrorException::getSeverity — İstisnanın önem derecesi ile döner

Açıklama

final public int ErrorException::getSeverity ( void )

İstisnanın önem derecesini döndürür.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

İstisnanın önem derecesini döndürür.

Örnekler

Örnek 1 - ErrorException::getSeverity() örneği

<?php
try {
    throw new ErrorException("İstisna iletisi", 0, 75);
} catch(ErrorException $e) {
    echo "Bu istisnanın önem derecesi: " . $e->getSeverity();
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Bu istisnanın önem derecesi: 75

ErrorException::__construct
Öntanımlı Arayüzler ve Sınıflar
ErrorException


Öntanımlı Arayüzler ve Sınıflar

İçindekiler

  • Traversable
  • Iterator
  • IteratorAggregate
  • ArrayAccess
  • Serializable
  • Closure
  • Generator

Ayrıca bakınız: SPL Arayüzleri ve ayrılmış sınıflar.

ErrorException::getSeverity
Traversable
Dil Başvuru Kılavuzu


Traversable arayüzü

(PHP 5 >= 5.0.0, PHP 7)

Giriş

Bir sınıf foreach kullanarak çaprazlanabiliyorsa bunu saptayan arayüz.

Tek başına gerçeklenemeyen bir soyut temel arayüz olup ya IteratorAggregate ya da Iterator olarak gerçeklenmelidir.

Bilginize:

Bu arayüzü gerçekleyen yerleşik sınıflar bir foreach oluşumunda kullanılabilir ve IteratorAggregate ya da Iterator olarak gerçeklenmeleri gerekmez.

Bilginize:

Bu dahili bir motor arayüz olup PHP betiklerinde gerçeklenemez. Yerine IteratorAggregate veya Iterator kullanılmalıdır.

Arayüz Sözdizimi

Traversable {
}

Bu arayüzün yöntemleri yoktur. Tek amacı çaprazlanabilir tüm sınıflar için temel arayüz olmaktır.

Öntanımlı Arayüzler ve Sınıflar
Iterator
Öntanımlı Arayüzler ve Sınıflar


Iterator Arayüzü

(PHP 5 >= 5.0.0, PHP 7)

Giriş

Kendilerini dahili olarak yineleyebilen nesneler ve harici yineleyiciler için arayüz.

Arayüz Sözdizimi

Iterator extends Traversable {
/* Yöntemler */
abstract public mixed current ( void )
abstract public scalar key ( void )
abstract public void next ( void )
abstract public void rewind ( void )
abstract public boolean valid ( void )
}

Örnek 1 Temel Kullanımı

Bu örnekte, bir yineleyici üzerinde foreach yaparken hangi yöntemlerin çağrıldığı gösterilmiştir.

<?php
class Yineleyicim implements Iterator {
    private $position = 0;
    private $array = array(
        "ilkeleman",
        "ikincieleman",
        "soneleman",
    );

    public function __construct() {
        $this->position = 0;
    }

    function rewind() {
        var_dump(__METHOD__);
        $this->position = 0;
    }

    function current() {
        var_dump(__METHOD__);
        return $this->array[$this->position];
    }

    function key() {
        var_dump(__METHOD__);
        return $this->position;
    }

    function next() {
        var_dump(__METHOD__);
        ++$this->position;
    }

    function valid() {
        var_dump(__METHOD__);
        return isset($this->array[$this->position]);
    }
}

$it = new Yineleyicim;

foreach($it as $key => $value) {
    var_dump($key, $value);
    echo "\n";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(19) "Yineleyicim::rewind"
string(18) "Yineleyicim::valid"
string(20) "Yineleyicim::current"
string(16) "Yineleyicim::key"
int(0)
string(9) "ilkeleman"

string(17) "Yineleyicim::next"
string(18) "Yineleyicim::valid"
string(20) "Yineleyicim::current"
string(16) "Yineleyicim::key"
int(1)
string(12) "ikincieleman"

string(17) "Yineleyicim::next"
string(18) "Yineleyicim::valid"
string(20) "Yineleyicim::current"
string(16) "Yineleyicim::key"
int(2)
string(9) "soneleman"

string(17) "Yineleyicim::next"
string(18) "Yineleyicim::valid"

İçindekiler

  • Iterator::current — O anki elemanı döndürür
  • Iterator::key — O anki elemanın anahtarını döndürür
  • Iterator::next — Konumu sonraki elemana ilerletir
  • Iterator::rewind — Yineleyiciyi ilk elemana konumlandırır
  • Iterator::valid — O anki konum geçerli mi diye bakar
Traversable
Iterator::current
Öntanımlı Arayüzler ve Sınıflar


O anki elemanı döndürür

Iterator
Iterator::key
Iterator
PHP Manual

Iterator::current

(PHP 5 >= 5.0.0, PHP 7)

Iterator::current — O anki elemanı döndürür

Açıklama

abstract public mixed Iterator::current ( void )

O anki elemanı döndürür.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Her türde değer dönebilir.

Iterator
Iterator::key
Iterator


O anki elemanın anahtarını döndürür

Iterator::current
Iterator::next
Iterator
PHP Manual

Iterator::key

(PHP 5 >= 5.0.0, PHP 7)

Iterator::key — O anki elemanın anahtarını döndürür

Açıklama

abstract public scalar Iterator::key ( void )

O anki elemanın anahtarını döndürür.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda scalar türünde bir değer, aksi takdirde NULL döner.

Hatalar/İstisnalar

Başarısızlık durumunda bir E_NOTICE çıktılanır.

Iterator::current
Iterator::next
Iterator


Konumu sonraki elemana ilerletir

Iterator::key
Iterator::rewind
Iterator
PHP Manual

Iterator::next

(PHP 5 >= 5.0.0, PHP 7)

Iterator::next — Konumu sonraki elemana ilerletir

Açıklama

abstract public void Iterator::next ( void )

O anki konumu sonraki elemana ilerletir.

Bilginize:

Bu işlev her foreach döngüsünün ardından çağrılır.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Dönen değer olursa yok sayılır.

Iterator::key
Iterator::rewind
Iterator


Yineleyiciyi ilk elemana konumlandırır

Iterator::next
Iterator::valid
Iterator
PHP Manual

Iterator::rewind

(PHP 5 >= 5.0.0, PHP 7)

Iterator::rewind — Yineleyiciyi ilk elemana konumlandırır

Açıklama

abstract public void Iterator::rewind ( void )

Yineleyiciyi başa ilk elemana döndürür.

Bilginize:

Bir foreach döngüsü başlatılırkan çağrılan ilk yöntemdir. foreach döngüsünden sonra çalıştırılmaz.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Dönen değer olursa yok sayılır.

Iterator::next
Iterator::valid
Iterator


O anki konum geçerli mi diye bakar

Iterator::rewind
IteratorAggregate
Iterator
PHP Manual

Iterator::valid

(PHP 5 >= 5.0.0, PHP 7)

Iterator::valid — O anki konum geçerli mi diye bakar

Açıklama

abstract public boolean Iterator::valid ( void )

Bu yöntem o anki konumun geçerli olup olmadığını sınamak için Iterator::rewind() ve Iterator::next() yöntemlerinden sonra çağrılır.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Dönüş değeri boolean türüne dönüştürüldükten sonra döndürülür. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Iterator::rewind
IteratorAggregate
Iterator


IteratorAggregate Arayüzü

(PHP 5 >= 5.0.0, PHP 7)

Giriş

Harici bir yineleyici oluşturmak için arayüz.

Arayüz Sözdizimi

IteratorAggregate extends Traversable {
/* Yöntemler */
abstract public Traversable getIterator ( void )
}

Örnek 1 - Temel kullanımı

<?php
class Verilerim implements IteratorAggregate {
    public $özellik1 = "Birinci genel özellik";
    public $özellik2 = "İkinci genel özellik";
    public $özellik3 = "Üçüncü genel özellik";

    public function __construct() {
        $this->özellik4 = "son özellik";
    }

/* PHP, tr_TR yerelinde bu yöntemi de arıyor, yoksa
 * "Fatal error: Couldn't find implementation for method
 * Verilerim::getiterator in Unknown on line 0"
 * hatasını veriyor.
 */
    public function getiterator() {
        return new ArrayIterator($this);
    }

    public function getIterator() {
        return new ArrayIterator($this);
    }
}

$obj = new Verilerim;

foreach($obj as $key => $value) {
    var_dump($key, $value);
    echo "\n";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(9) "özellik1"
string(22) "Birinci genel özellik"

string(9) "özellik2"
string(22) "İkinci genel özellik"

string(9) "özellik3"
string(25) "Üçüncü genel özellik"

string(9) "özellik4"
string(12) "son özellik"

İçindekiler

  • IteratorAggregate::getIterator — Harici bir yineleyici ile döner
Iterator::valid
IteratorAggregate::getIterator
Öntanımlı Arayüzler ve Sınıflar


Harici bir yineleyici ile döner

IteratorAggregate
ArrayAccess
IteratorAggregate
PHP Manual

IteratorAggregate::getIterator

(PHP 5 >= 5.0.0, PHP 7)

IteratorAggregate::getIterator — Harici bir yineleyici ile döner

Açıklama

abstract public Traversable IteratorAggregate::getIterator ( void )

Harici bir yineleyici ile döner.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Traversable veya Iterator arayüzünü gerçekleyen nesnenin bir örneğiyle döner.

Hatalar/İstisnalar

Başarısızlık durumunda bir istisna (Exception) oluşur.

IteratorAggregate
ArrayAccess
IteratorAggregate


ArrayAccess arayüzü

(PHP 5 >= 5.0.0, PHP 7)

Giriş

Nesnelere birer dizi olarak erişmeyi sağlayan arayüz.

Arayüz Sözdizimi

ArrayAccess {
/* Yöntemler */
abstract public boolean offsetExists ( mixed $konum )
abstract public mixed offsetGet ( mixed $konum )
abstract public void offsetSet ( mixed $konum , mixed $değer )
abstract public void offsetUnset ( mixed $konum )
}

Örnek 1 Temel kullanım

<?php
class obj implements arrayaccess {
    private $container = array();
    public function __construct() {
        $this->container = array(
            "bir"   => 1,
            "iki"   => 2,
            "üç"    => 3,
        );
    }
    public function offsetSet($offset, $value) {
        $this->container[$offset] = $value;
    }
    public function offsetExists($offset) {
        return isset($this->container[$offset]);
    }
    public function offsetUnset($offset) {
        unset($this->container[$offset]);
    }
    public function offsetGet($offset) {
        return isset($this->container[$offset]) ? $this->container[$offset] : null;
    }
}

$obj = new obj;

var_dump(isset($obj["iki"]));
var_dump($obj["iki"]);
unset($obj["iki"]);
var_dump(isset($obj["iki"]));
$obj["iki"] = "Bir değer";
var_dump($obj["iki"]);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(true)
int(2)
bool(false)
string(7) "Bir değer"

İçindekiler

  • ArrayAccess::offsetExists — Bir konumun mevcut olup olmadığına bakar
  • ArrayAccess::offsetGet — Konumdaki değeri döndürür
  • ArrayAccess::offsetSet — Konuma değer atanır
  • ArrayAccess::offsetUnset — Konum boşaltılır
IteratorAggregate::getIterator
ArrayAccess::offsetExists
Öntanımlı Arayüzler ve Sınıflar


Bir konumun mevcut olup olmadığına bakar

ArrayAccess
ArrayAccess::offsetGet
ArrayAccess
PHP Manual

ArrayAccess::offsetExists

(PHP 5 >= 5.0.0, PHP 7)

ArrayAccess::offsetExists — Bir konumun mevcut olup olmadığına bakar

Açıklama

abstract public boolean ArrayAccess::offsetExists ( mixed $konum )

Bir konumun mevcut olup olmadığına bakar.

ArrayAccess arayüzünü gerçekleyen nesneler üzerinde isset() veya empty() kullanıldığında bu yöntem çalıştırılır.

Bilginize:

empty() işlevi kullanıldığında ArrayAccess::offsetGet() çağrılır ve sadece dönen değer TRUE olduğu takdirde konumun boş olup olmadığına bakılır.

Değiştirgeler

konum

Varlığı sınanacak konum.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Bilginize:

Dönüş değeri boolean türünde değilse tür dönüşümü yapıldıktan sonra döndürülür.

Örnekler

Örnek 1 - ArrayAccess::offsetExists() örneği

<?php
class Sınıf implements arrayaccess {
    public function offsetSet($konum, $değer) {
        var_dump(__METHOD__);
    }
    public function offsetExists($var) {
        var_dump(__METHOD__);
        if ($var == "filanca") {
            return true;
        }
        return false;
    }
    public function offsetUnset($var) {
        var_dump(__METHOD__);
    }
    public function offsetGet($var) {
        var_dump(__METHOD__);
        return "değer";
    }
}

$nesne = new Sınıf;

echo "Sınıf::offsetExists() çalışır\n";
var_dump(isset($nesne["filanca"]));

echo "\nSınıf::offsetExists() ve Sınıf::offsetGet() çalışır\n";
var_dump(empty($nesne["filanca"]));

echo "\nSınıf::offsetExists() çalışır, alınacak bir şey olmadığından Sınıf::offsetGet() çalışmaz\n";
var_dump(empty($nesne["falanca"]));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Sınıf::offsetExists() çalışır
string(21) "Sınıf::offsetExists"
bool(true)

Sınıf::offsetExists() ve Sınıf::offsetGet() çalışır
string(21) "Sınıf::offsetExists"
string(18) "Sınıf::offsetGet"
bool(false)

Sınıf::offsetExists() çalışır, alınacak bir şey olmadığından Sınıf::offsetGet() çalışmaz
string(21) "Sınıf::offsetExists"
bool(true)

ArrayAccess
ArrayAccess::offsetGet
ArrayAccess


Konumdaki değeri döndürür

ArrayAccess::offsetExists
ArrayAccess::offsetSet
ArrayAccess
PHP Manual

ArrayAccess::offsetGet

(PHP 5 >= 5.0.0, PHP 7)

ArrayAccess::offsetGet — Konumdaki değeri döndürür

Açıklama

abstract public mixed ArrayAccess::offsetGet ( mixed $konum )

Belirtilen konumdaki değeri döndürür.

Bu yöntem, empty() işlevi ile konumun boş olup olmadığına bakılırken çalıştırılır.

Değiştirgeler

konum

Değerin döndürüleceği konum.

Dönen Değerler

Her türde değer dönebilir.

Ayrıca Bakınız

  • ArrayAccess::offsetExists() - Bir konumun mevcut olup olmadığına bakar

ArrayAccess::offsetExists
ArrayAccess::offsetSet
ArrayAccess


Konuma değer atanır

ArrayAccess::offsetGet
ArrayAccess::offsetUnset
ArrayAccess
PHP Manual

ArrayAccess::offsetSet

(PHP 5 >= 5.0.0, PHP 7)

ArrayAccess::offsetSet — Konuma değer atanır

Açıklama

abstract public void ArrayAccess::offsetSet ( mixed $konum , mixed $değer )

Belirtilen konuma belirtilen değer atanır.

Değiştirgeler

konum

Değerin atanacağı konum.

değer

Atanacak değer.

Dönen Değerler

Hiçbir değer dönmez.

Notlar

Bilginize:

Aşağıdaki örnekte olduğu gibi, başka bir değer mümkün değilse konum değiştirgesine NULL atanır.

<?php
$arrayaccess[] = "value";
?>

ArrayAccess::offsetGet
ArrayAccess::offsetUnset
ArrayAccess


Konum boşaltılır

ArrayAccess::offsetSet
Serializable
ArrayAccess
PHP Manual

ArrayAccess::offsetUnset

(PHP 5 >= 5.0.0, PHP 7)

ArrayAccess::offsetUnset — Konum boşaltılır

Açıklama

abstract public void ArrayAccess::offsetUnset ( mixed $konum )

Bir konumu boşaltır.

Bilginize:

(unset)'e tür çarpıtması yapıldığında bu yöntem çağrılmaz.

Değiştirgeler

konum

Boşaltılacak konum.

Dönen Değerler

Hiçbir değer dönmez.

ArrayAccess::offsetSet
Serializable
ArrayAccess


Serializable arayüzü

(PHP 5 >= 5.1.0, PHP 7)

Giriş

Dizgeleştirmeyi özelleştirme arayüzü.

Bu arayüzü gerçekleyen sınıflar __sleep() ve __wakeup() işlevlerini desteklemezler. Bir örneğin dizgeleştirilmesi gerektiğinde serialize yöntemi çağrılır. Bunun __destruct() çağırmak veya yöntem içinde tanımlanmamış bir işlemi yapmak gibi bir yan etkisi yoktur. Dizgeleştirilmiş nesne yeniden oluşturulmak istendiğinde sınıf bilinmekte olur ve kurucu olarak __construct() yerine ilgili unserialize() yöntemi çağrılır. Eğer standart kurucuyu çalıştırmak isterseniz bunu yöntemin içinde yapmanız gerekir.

Arayüz Sözdizimi

Serializable {
/* Yöntemler */
abstract public string serialize ( void )
abstract public mixed unserialize ( string $dizgeleşmiş )
}

Örnek 1 Temel kullanım

<?php
class obj implements Serializable {
    private $data;
    public function __construct() {
        $this->data = "Özel verim";
    }
    public function serialize() {
        return serialize($this->data);
    }
    public function unserialize($data) {
        $this->data = unserialize($data);
    }
    public function getData() {
        return $this->data;
    }
}

$obj = new obj;
$ser = serialize($obj);

$newobj = unserialize($ser);

var_dump($newobj->getData());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(11) "Özel verim"

İçindekiler

  • Serializable::serialize — Nesnenin dizgesel gösterimiyle döner
  • Serializable::unserialize — Dizgeleştirilmiş nesneyi yeniden oluşturur
ArrayAccess::offsetUnset
Serializable::serialize
Öntanımlı Arayüzler ve Sınıflar


Nesnenin dizgesel gösterimiyle döner

Serializable
Serializable::unserialize
Serializable
PHP Manual

Serializable::serialize

(PHP 5 >= 5.1.0, PHP 7)

Serializable::serialize — Nesnenin dizgesel gösterimiyle döner

Açıklama

abstract public string Serializable::serialize ( void )

Nesnenin dizgesel gösterimi ile döner.

Bilginize:

Bu yöntem nesnenin bir yıkıcısı olarak işlem görür. Bu yöntemden sonra __destruct() yöntemi çağrılmaz.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Bir hata oluşmamışsa nesnenin dizgesel gösterimi ile, aksi takdirde NULL ile döner.

Hatalar/İstisnalar

Dönüş türü string veya NULL değilse bir istisna (Exception) oluşur.

Ayrıca Bakınız

  • __sleep()

Serializable
Serializable::unserialize
Serializable


Dizgeleştirilmiş nesneyi yeniden oluşturur

Serializable::serialize
Closure
Serializable
PHP Manual

Serializable::unserialize

(PHP 5 >= 5.1.0, PHP 7)

Serializable::unserialize — Dizgeleştirilmiş nesneyi yeniden oluşturur

Açıklama

abstract public mixed Serializable::unserialize ( string $dizgeleşmiş )

Dizgeleştirilmiş nesne yeniden oluşturulmak istendiğinde çağrılır.

Bilginize:

Bu yöntem nesnenin kurucusu olarak işlem görür. Bu yöntemin ardından __construct() yöntemi çağrılmaz.

Değiştirgeler

dizgeleşmiş

Nesnenin dizgesel gösterimi.

Dönen Değerler

Dizgeleşmiş nesnenin yeniden oluşturulan özgün halini döndürür.

Ayrıca Bakınız

  • __wakeup()

Serializable::serialize
Closure
Serializable


The Closure class

(PHP 5 >= 5.3.0, PHP 7)

Giriş

Class used to represent anonymous functions.

Anonymous functions, implemented in PHP 5.3, yield objects of this type. This fact used to be considered an implementation detail, but it can now be relied upon. Starting with PHP 5.4, this class has methods that allow further control of the anonymous function after it has been created.

Besides the methods listed here, this class also has an __invoke method. This is for consistency with other classes that implement calling magic, as this method is not used for calling the function.

Sınıf Sözdizimi

Closure {
/* Yöntemler */
private __construct ( void )
public static Closure bind ( Closure $closure , object $newthis [, mixed $newscope = "static" ] )
public Closure bindTo ( object $newthis [, mixed $newscope = "static" ] )
public mixed call ( object $newthis [, mixed $... ] )
}

İçindekiler

  • Closure::__construct — Constructor that disallows instantiation
  • Closure::bind — Duplicates a closure with a specific bound object and class scope
  • Closure::bindTo — Duplicates the closure with a new bound object and class scope
  • Closure::call — Binds and calls the closure
Serializable::unserialize
Closure::__construct
Öntanımlı Arayüzler ve Sınıflar


Constructor that disallows instantiation

Closure
Closure::bind
Closure
PHP Manual

Closure::__construct

(PHP 5 >= 5.3.0, PHP 7)

Closure::__construct — Constructor that disallows instantiation

Açıklama

private Closure::__construct ( void )

This method exists only to disallow instantiation of the Closure class. Objects of this class are created in the fashion described on the anonymous functions page.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

This method has no return value; it simply emits an error (of type E_RECOVERABLE_ERROR).

Ayrıca Bakınız

  • Anonymous functions
Closure
Closure::bind
Closure


Duplicates a closure with a specific bound object and class scope

Closure::__construct
Closure::bindTo
Closure
PHP Manual

Closure::bind

(PHP 5 >= 5.4.0, PHP 7)

Closure::bind — Duplicates a closure with a specific bound object and class scope

Açıklama

public static Closure Closure::bind ( Closure $closure , object $newthis [, mixed $newscope = "static" ] )

This method is a static version of Closure::bindTo(). See the documentation of that method for more information.

Değiştirgeler

closure

The anonymous functions to bind.

newthis

The object to which the given anonymous function should be bound, or NULL for the closure to be unbound.

newscope

The class scope to which associate the closure is to be associated, or 'static' to keep the current one. If an object is given, the type of the object will be used instead. This determines the visibility of protected and private methods of the bound object. It is not allowed to pass (an object of) an internal class as this parameter.

Dönen Değerler

Returns a new Closure object başarısızlık durumunda FALSE döner

Sürüm Bilgisi

Sürüm: | Açıklama
7.0.0 | newscope can not be (an object of) an internal class anymore, what was possible prior to this version.

Örnekler

Örnek 1 Closure::bind() example

<?php
class A {
    private static $sfoo = 1;
    private $ifoo = 2;
}
$cl1 = static function() {
    return A::$sfoo;
};
$cl2 = function() {
    return $this->ifoo;
};

$bcl1 = Closure::bind($cl1, null, 'A');
$bcl2 = Closure::bind($cl2, new A(), 'A');
echo $bcl1(), "\n";
echo $bcl2(), "\n";
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

1
2

Ayrıca Bakınız

  • Anonymous functions
  • Closure::bindTo() - Duplicates the closure with a new bound object and class scope
Closure::__construct
Closure::bindTo
Closure


Duplicates the closure with a new bound object and class scope

Closure::bind
Closure::call
Closure
PHP Manual

Closure::bindTo

(PHP 5 >= 5.4.0, PHP 7)

Closure::bindTo — Duplicates the closure with a new bound object and class scope

Açıklama

public Closure Closure::bindTo ( object $newthis [, mixed $newscope = "static" ] )

Create and return a new anonymous function with the same body and bound variables as this one, but possibly with a different bound object and a new class scope.

The "bound object" determines the value $this will have in the function body and the "class scope" represents a class which determines which private and protected members the anonymous function will be able to access. Namely, the members that will be visible are the same as if the anonymous function were a method of the class given as value of the newscope parameter.

Static closures cannot have any bound object (the value of the parameter newthis should be NULL), but this function can nevertheless be used to change their class scope.

This function will ensure that for a non-static closure, having a bound instance will imply being scoped and vice-versa. To this end, non-static closures that are given a scope but a NULL instance are made static and non-static non-scoped closures that are given a non-null instance are scoped to an unspecified class.

Bilginize:

If you only want to duplicate the anonymous functions, you can use cloning instead.

Değiştirgeler

newthis

The object to which the given anonymous function should be bound, or NULL for the closure to be unbound.

newscope

The class scope to which associate the closure is to be associated, or 'static' to keep the current one. If an object is given, the type of the object will be used instead. This determines the visibility of protected and private methods of the bound object.

Dönen Değerler

Returns the newly created Closure object başarısızlık durumunda FALSE döner

Örnekler

Örnek 1 Closure::bindTo() example

<?php

class A {
    function __construct($val) {
        $this->val = $val;
    }
    function getClosure() {
        //returns closure bound to this object and scope
        return function() { return $this->val; };
    }
}

$ob1 = new A(1);
$ob2 = new A(2);

$cl = $ob1->getClosure();
echo $cl(), "\n";
$cl = $cl->bindTo($ob2);
echo $cl(), "\n";
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

1
2

Ayrıca Bakınız

  • Anonymous functions
  • Closure::bind() - Duplicates a closure with a specific bound object and class scope
Closure::bind
Closure::call
Closure


Binds and calls the closure

Closure::bindTo
Generator
Closure
PHP Manual

Closure::call

(PHP 7)

Closure::call — Binds and calls the closure

Açıklama

public mixed Closure::call ( object $newthis [, mixed $... ] )

Temporarily binds the closure to newthis, and calls it with any given parameters.

Değiştirgeler

newthis

The object to bind the closure to for the duration of the call.

...

Zero or more parameters, which will be given as parameters to the closure.

Dönen Değerler

Returns the return value of the closure.

Örnekler

Örnek 1 Closure::call() example

<?php
class Value {
    protected $value;

    public function __construct($value) {
        $this->value = $value;
    }

    public function getValue() {
        return $this->value;
    }
}

$three = new Value(3);
$four = new Value(4);

$closure = function ($delta) { var_dump($this->getValue() + $delta); };
$closure->call($three, 4);
$closure->call($four, 4);
?>

Yukarıdaki örneğin çıktısı:

int(7)
int(8)
Closure::bindTo
Generator
Closure


The Generator class

(PHP 5 >= 5.5.0, PHP 7)

Giriş

Generator objects are returned from generators.

Dikkat

Generator objects cannot be instantiated via new.

Sınıf Sözdizimi

Generator implements Iterator {
/* Yöntemler */
public mixed current ( void )
public mixed getReturn ( void )
public mixed key ( void )
public void next ( void )
public void rewind ( void )
public mixed send ( mixed $value )
public mixed throw ( Throwable $exception )
public bool valid ( void )
public void __wakeup ( void )
}

İçindekiler

  • Generator::current — Get the yielded value
  • Generator::getReturn — Get the return value of a generator
  • Generator::key — Get the yielded key
  • Generator::next — Resume execution of the generator
  • Generator::rewind — Rewind the iterator
  • Generator::send — Send a value to the generator
  • Generator::throw — Throw an exception into the generator
  • Generator::valid — Check if the iterator has been closed
  • Generator::__wakeup — Serialize callback
Closure::call
Generator::current
Öntanımlı Arayüzler ve Sınıflar


Get the yielded value

Generator
Generator::getReturn
Generator
PHP Manual

Generator::current

(PHP 5 >= 5.5.0, PHP 7)

Generator::current — Get the yielded value

Açıklama

public mixed Generator::current ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the yielded value.

Generator
Generator::getReturn
Generator


Get the return value of a generator

Generator::current
Generator::key
Generator
PHP Manual

Generator::getReturn

(PHP 7)

Generator::getReturn — Get the return value of a generator

Açıklama

public mixed Generator::getReturn ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the generator's return value once it has finished executing.

Örnekler

Örnek 1 Generator::getReturn() example

<?php

$gen = (function() {
    yield 1;
    yield 2;

    return 3;
})();

foreach ($gen as $val) {
    echo $val, PHP_EOL;
}

echo $gen->getReturn(), PHP_EOL;

Yukarıdaki örneğin çıktısı:

1
2
3

Generator::current
Generator::key
Generator


Get the yielded key

Generator::getReturn
Generator::next
Generator
PHP Manual

Generator::key

(PHP 5 >= 5.5.0, PHP 7)

Generator::key — Get the yielded key

Açıklama

public mixed Generator::key ( void )

Gets the key of the yielded value.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the yielded key.

Örnekler

Örnek 1 Generator::key() example

<?php

function Gen()
{
    yield 'key' => 'value';
}

$gen = Gen();

echo "{$gen->key()} => {$gen->current()}";

Yukarıdaki örneğin çıktısı:

key => value

Generator::getReturn
Generator::next
Generator


Resume execution of the generator

Generator::key
Generator::rewind
Generator
PHP Manual

Generator::next

(PHP 5 >= 5.5.0, PHP 7)

Generator::next — Resume execution of the generator

Açıklama

public void Generator::next ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Generator::key
Generator::rewind
Generator


Rewind the iterator

Generator::next
Generator::send
Generator
PHP Manual

Generator::rewind

(PHP 5 >= 5.5.0, PHP 7)

Generator::rewind — Rewind the iterator

Açıklama

public void Generator::rewind ( void )

If iteration has already begun, this will throw an exception.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Generator::next
Generator::send
Generator


Send a value to the generator

Generator::rewind
Generator::throw
Generator
PHP Manual

Generator::send

(PHP 5 >= 5.5.0, PHP 7)

Generator::send — Send a value to the generator

Açıklama

public mixed Generator::send ( mixed $value )

Sends the given value to the generator as the result of the current yield expression and resumes execution of the generator.

If the generator is not at a yield expression when this method is called, it will first be let to advance to the first yield expression before sending the value. As such it is not necessary to "prime" PHP generators with a Generator::next() call (like it is done in Python).

Değiştirgeler

value

Value to send into the generator. This value will be the return value of the yield expression the generator is currently at.

Dönen Değerler

Returns the yielded value.

Örnekler

Örnek 1 Using Generator::send() to inject values

<?php
function printer() {
    echo "I'm printer!".PHP_EOL;
    while (true) {
        $string = yield;
        echo $string.PHP_EOL;
    }
}

$printer = printer();
$printer->send('Hello world!');
$printer->send('Bye world!');
?>

Yukarıdaki örneğin çıktısı:

I'm printer!
Hello world!
Bye world!

Generator::rewind
Generator::throw
Generator


Throw an exception into the generator

Generator::send
Generator::valid
Generator
PHP Manual

Generator::throw

(PHP 5 >= 5.5.0, PHP 7)

Generator::throw — Throw an exception into the generator

Açıklama

public mixed Generator::throw ( Throwable $exception )

Throws an exception into the generator and resumes execution of the generator. The behavior will be the same as if the current yield expression was replaced with a throw $exception statement.

If the generator is already closed when this method is invoked, the exception will be thrown in the caller's context instead.

Değiştirgeler

exception

Exception to throw into the generator.

Dönen Değerler

Returns the yielded value.

Sürüm Bilgisi

Sürüm: | Açıklama
7.0.0 | The exception parameter also accepts Throwable now.

Örnekler

Örnek 1 Throwing an exception into a generator

<?php
function gen() {
    echo "Foo\n";
    try {
        yield;
    } catch (Exception $e) {
        echo "Exception: {$e->getMessage()}\n";
    }
    echo "Bar\n";
}

$gen = gen();
$gen->rewind();
$gen->throw(new Exception('Test'));
?>

Yukarıdaki örneğin çıktısı:

Foo
Exception: Test
Bar

Generator::send
Generator::valid
Generator


Check if the iterator has been closed

Generator::throw
Generator::__wakeup
Generator
PHP Manual

Generator::valid

(PHP 5 >= 5.5.0, PHP 7)

Generator::valid — Check if the iterator has been closed

Açıklama

public bool Generator::valid ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns FALSE if the iterator has been closed. Otherwise returns TRUE.

Generator::throw
Generator::__wakeup
Generator


Serialize callback

Generator::valid
Bağlam seçenekleri ve değiştirgeleri
Generator
PHP Manual

Generator::__wakeup

(PHP 5 >= 5.5.0, PHP 7)

Generator::__wakeup — Serialize callback

Açıklama

public void Generator::__wakeup ( void )

Throws an exception as generators can't be serialized.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Generator::valid
Bağlam seçenekleri ve değiştirgeleri
Generator


Bağlam seçenekleri ve değiştirgeleri

PHP, tüm dosya sistemi ve akım sarmalayıcılarla kullanılabilen
çeşitli bağlam seçenekleri ve değiştirgelerine sahiptir. Bağlam
stream_context_create() ile oluşturulur. Seçenekler
stream_context_set_option() ile değiştirgeleri ise
stream_context_set_params() ile atanır.

İçindekiler

  • Soket bağlamı seçenekleri — Soket bağlamı seçeneklerinin listesi
  • HTTP bağlamı seçenekleri — HTTP bağlamı seçeneklerinin listesi
  • FTP bağlamı seçenekleri — FTP bağlamı seçeneklerinin listesi
  • SSL bağlamı seçenekleri — SSL bağlamı seçeneklerinin listesi
  • CURL bağlamı seçenekleri — CURL bağlamı seçeneklerinin listesi
  • Phar bağlam seçenekleri — Phar bağlamı seçeneklerinin listesi
  • MongoDB için bağlamsal seçenekler — MongoDB için bağlamsal seçeneklerin listesi
  • Bağlam değiştirgeleri — Bağlam değiştirgesi listeleme
Generator::__wakeup
Soket bağlamı seçenekleri
Dil Başvuru Kılavuzu


Soket bağlamı seçeneklerinin listesi

Bağlam seçenekleri ve değiştirgeleri
HTTP bağlamı seçenekleri
Bağlam seçenekleri ve değiştirgeleri
PHP Manual

Soket bağlamı seçenekleri

Soket bağlamı seçenekleri — Soket bağlamı seçeneklerinin listesi

Açıklama

Soket bağlamı seçenekleri, tcp, http ve ftp gibi soketler üzerinde çalışan tüm sarmalayıcılar için kullanılabilir.

Seçenekler

bindto

PHP'nin ağa erişmek için kullanacağı IP adresini (IPv4 veya IPv6) ve port numarasını belirtmek için kullanılır. Söz dizimi: ip:port. IP veya porta 0 belirtilirse IP veya portu sistem seçer.

Bilginize:

FTP'de normal işlem sırasında iki soket bağlantısı oluşturulur, port numarası bu seçenek kullanılarak belirtilemez.

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.0 | bindto eklendi.

Örnekler

Örnek 1 - Temel bindto kullanım örneği

<?php
// internete '192.168.0.100' IP'yi kullanarak bağlanalım
$seçenekler = array(
    'socket' => array(
        'bindto' => '192.168.0.100:0',
    ),
);

// internete '192.168.0.100' IP ve port '7000' üzerinden bağlanalım
$seçenekler = array(
    'socket' => array(
        'bindto' => '192.168.0.100:7000',
    ),
);

// internete port '7000' üzerinden bağlanalım
$seçenekler = array(
    'socket' => array(
        'bindto' => '0:7000',
    ),
);

// bağlamı oluşturalım...
$bağlam = stream_context_create($seçenekler);

// ...ve veri çekmek için kullanalım
echo file_get_contents('http://misal.dom', false, $bağlam);

?>

Bağlam seçenekleri ve değiştirgeleri
HTTP bağlamı seçenekleri
Bağlam seçenekleri ve değiştirgeleri


HTTP bağlamı seçeneklerinin listesi

Soket bağlamı seçenekleri
FTP bağlamı seçenekleri
Bağlam seçenekleri ve değiştirgeleri
PHP Manual

HTTP bağlamı seçenekleri

HTTP bağlamı seçenekleri — HTTP bağlamı seçeneklerinin listesi

Açıklama

http:// ve https:// aktarımları için bağlam seçenekleri.

Seçenekler

method string

Uzak sunucu tarafından desteklenen GET, POST veya başka bir HTTP yöntemi.

GET öntanımlıdır.

header string

İstek sırasında gönderilecek ek başlıklar. Bu seçenekte belirtilen değerler diğer değerleri geçersiz kılar (User-agent:, Host:, Authentication: gibi).

user_agent string

User-Agent: başlığı ile gönderilecek değer. Bu değer sadece, tarayıcı header seçeneği ile belirtilmemişse kullanılır.

Öntanımlı olarak, php.ini dosyasındaki user_agent değeri kullanılır.

content string

Başlıklardan sonra gönderilecek ek veri. Normalde POST veya PUT istekleriyle kullanılır.

proxy string

Vekil sunucunun adresini belirten URI (tcp://vekil.mesela.dom:5100 gibi).

request_fulluri boolean

TRUE atanırsa, istek oluşturulurken URI'nin tamamı kullanılır (GET http://mesela.dom/dizin/yolu/dosya.html HTTP/1.0 gibi). Bu standart dışı bir istek biçimi olsa da bazı vekil sunucular bunun böyle olmasını gerektirirler.

FALSE öntanımlıdır.

max_redirects integer

İzlenecek yönlendirmelerin azami sayısı. 1 veya daha az bir değer belirtilmesi hiçbir yönlendirmenin izlenmeyeceği anlamına gelir.

20 öntanımlıdır.

protocol_version float

HTTP protokolünün sürümü.

1.0 öntanımlıdır.

Bilginize:

PHP'nin 5.3.0 sürümünden önce parçalı aktarım gerçeklenmemişti. Dolayısıyla bu değeri 1.1 olarak belirtirseniz, 1.1 uyumluluğundan kendiniz sorumlu olursunuz.

timeout float

Bir float değer olarak saniye cinsinden okuma zaman aşımı. (10.5 gibi).

Öntanımlı olarak, php.ini dosyasındaki default_socket_timeout yönergesinin değeri kullanılır.

ignore_errors boolean

Başarısızlık durumu kodlarında bile içerik alınır.

FALSE öntanımlıdır.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | protocol_version yönergesine 1.1 atandığında parçalı aktarım kodlaması artık desteklenmektedir.
5.2.10 | ignore_errors eklendi.
5.2.10 | Artık header sayısal indisli bir dizi olabilmektedir.
5.2.1 | timeout eklendi.
5.1.0 | HTTP vekilleri üzerinden HTTPS vekaleti eklendi.
5.1.0 | max_redirects eklendi.
5.1.0 | protocol_version eklendi.

Örnekler

Örnek 1 - Bir sayfayı çekip veriyi POST ile göndermek

<?php

$postverisi = http_build_query(
    array(
        'var1' => 'biraz içerik',
        'var2' => 'eh işte'
    )
);

$seçenekler = array('http' =>
    array(
        'method'  => 'POST',
        'header'  => 'Content-type: application/x-www-form-urlencoded',
        'content' => $postverisi
    )
);

$bağlam  = stream_context_create($seçenekler);

$sonuç = file_get_contents('http://mesela.dom/submit.php', false, $bağlam);

?>

Notlar

Bilginize: Temel soket akımı bağlamı seçenekleri
Ek bağlamsal seçenekler temel aktarım tarafından desteklenebilir. http:// akımları için tcp:// aktarımının bağlamsal seçeneklerine atıf yapılır. https:// akımları için ise ssl:// aktarımının bağlamsal seçeneklerine atıf yapılır.

Ayrıca Bakınız

  • Soket bağlamı seçenekleri
  • SSL bağlamı seçenekleri

Soket bağlamı seçenekleri
FTP bağlamı seçenekleri
Bağlam seçenekleri ve değiştirgeleri


FTP bağlamı seçeneklerinin listesi

HTTP bağlamı seçenekleri
SSL bağlamı seçenekleri
Bağlam seçenekleri ve değiştirgeleri
PHP Manual

FTP bağlamı seçenekleri

FTP bağlamı seçenekleri — FTP bağlamı seçeneklerinin listesi

Açıklama

ftp:// ve ftps:// aktarımları için bağlamsal seçenekler.

Seçenekler

overwrite boolean

Uzak sunucuda mevcut dosyaların üzerine yazılmasına izin verir. Sadece yazma kipine (dosya gönderme) uygulanır.

FALSE öntanımlıdır.

resume_pos integer

Aktarımın başlatılacağı dosya konumu. Sadece okuma kipine (indirme) uygulanır.

0 (dosyanın başlangıcı) öntanımlıdır.

proxy string

HTTP vekil sunucu üzerinden vekil FTP isteği. Sadece dosya okuma işlemlerine uygulanır. Örnek: tcp://vekil.mesela.dom:8000.

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.0 | proxy eklendi.
5.0.0 | overwrite ve resume_pos eklendi.

Notlar

Bilginize: Temel soket akımı bağlamı seçenekleri
Ek bağlamsal seçenekler temel aktarım tarafından desteklenebilir. ftp://akımları için tcp:// aktarımının bağlamsal seçeneklerine atıf yapılır. ftps:// akımları için ise ssl:// aktarımının bağlamsal seçeneklerine atıf yapılır.

Ayrıca Bakınız

  • Soket bağlamı seçenekleri
  • SSL bağlamı seçenekleri

HTTP bağlamı seçenekleri
SSL bağlamı seçenekleri
Bağlam seçenekleri ve değiştirgeleri


SSL bağlamı seçeneklerinin listesi

FTP bağlamı seçenekleri
CURL bağlamı seçenekleri
Bağlam seçenekleri ve değiştirgeleri
PHP Manual

SSL bağlamı seçenekleri

SSL bağlamı seçenekleri — SSL bağlamı seçeneklerinin listesi

Açıklama

ssl:// ve tls:// aktarımları için bağlamsal seçenekler.

Seçenekler

peer_name string

Kullanılan görevdeşin ismi.Bu değer yoksa akım açılırken kullanılan konağın ismine dayalı olarak tahmin edilir.

verify_peer boolean

SSL sertifikası kullanımının doğrulanmasını gerektirir.

TRUE öntanımlıdır.

verify_peer_name boolean

Görevdeş isminin doğrulanması gerekir.

TRUE öntanımlıdır.

allow_self_signed boolean

Öz imzalı sertifikalara izin verilir. verify_peer gerekir.

FALSE öntanımlıdır.

cafile string

Uzak görevdeşin kimliğini doğrulamak için verify_peer bağlam seçeneği ile kullanmak üzere yerel dosya sistemindeki Sertifika Yetkilisi dosyasının yeri.

capath string

cafile belirtilmemişse veya sertifika yerinde yoksa uygun sertifikayı bulmak için capath tarafından işaret edilen dizin araştırılır. capath doğru olarak betimlenmiş sertifika dizini olmalıdır.

local_cert string

Yerel sertifikanın dosya sistemindeki yeri. Sertifikanızı ve özel anahtarınızı içeren PEM kodlamalı bir dosya olmalıdır. Seçimlik olarak sertifika sağlayıcıların sertifika zincirini içerebilir.

passphrase string

local_cert dosyanızı kodlayan anahtar parolası.

CN_match string

Beklenen bilinen isim (Common Name). PHP sınırlı bir dosya kalıbı eşletirmesi yapmaya çalışır. Eğer bu bilinen isim bununla eşleşmiyorsa bağlantı gerçekleşmeyecektir.

Bilginize: Bu seçeneğin kullanımı önerilmemektedir. PHP 5.6.0 itibariyle peer_name kullanılmalıdır.

verify_depth integer

Sertifika zinciri çok derinse çıkılır.

Doğrulama yapılmaması öntanımlıdır.

ciphers string

Kullanılabilir şifrelerin listesi belirtilir. Dizge biçemi » ciphers(1) kılavuz sayfasında açıklanmıştır.

DEFAULT öntanımlıdır.

capture_peer_cert boolean

TRUE belirtilirse peer_certificate bağlam seçeneği görevdeşin sertifikasını içererek oluşturulur.

capture_peer_cert_chain boolean

TRUE belirtilirse peer_certificate_chain bağlam seçeneği sertifika zincirini içererek oluşturulur.

SNI_enabled boolean

TRUE atanırsa sunucu ismi belirteci (SNI) etkin olur. Böylece aynı IP adresinde çok sayıda sertifika mümkün olur.

SNI_server_name string

Atanan değer sunucu ismi belirteci için sunucu ismi olarak kullanılır. Bir değer atanmazsa, sunucu ismi akım açılırken kullanılan konak ismine dayanarak tahmin edilir.

Bilginize: Bu seçeneğin kullanımı önerilmemektedir. PHP 5.6.0 itibariyle peer_name kullanılmalıdır.

disable_compression boolean

TRUE atanırsa TLS sıkıştırması yapılmaz. Bu, CRIME (SUÇ) saldırı vektörünü azaltmaya yardımcı olabililir.

peer_fingerprint string | array

Uzak sertifika özeti belirtilenle eşleşmezse çıkar.

Değer string türünde belirtilmişse, uzunluk katıştırma algoritmasından belirlenir ("md5" için 32, "sha1" için 40 gibi).

Değer array türünde belirtilmişse, anahtarlar katıştırma algoritmasının ismini, değerler umulan özeti içerir.

Sürüm Bilgisi

Sürüm: | Açıklama
5.6.0 | peer_fingerprint ve verify_peer_name eklendi. verify_peer için öntanımlı değer TRUE oldu.
5.4.13 | disable_compression eklendi. OpenSSL >= 1.0.0 gerekir.
5.3.2 | SNI_enabled ve SNI_server_name eklendi.
5.0.0 | capture_peer_cert, capture_peer_chain ve ciphers eklendi.

Notlar

Bilginize: https:// ve ftps:// sarmalayıcıları için ssl:// temel aktarım olduğundan, ssl://'e uygulanan bağlamsal seçenekler ayrıca https:// ve ftps://'e de uygulanır.

Bilginize: SNI'nin (Server Name Indication - Sunucu ismi belirteci) kullanılabilmesi için PHP'nin OpenSSL 0.9.8j veya daha üst sürümü ile derlenmesi gerekir. SNI desteği olup olmadığını anlamak için OPENSSL_TLSEXT_SERVER_NAME kullanılır.

Ayrıca Bakınız

  • Soket bağlamı seçenekleri

FTP bağlamı seçenekleri
CURL bağlamı seçenekleri
Bağlam seçenekleri ve değiştirgeleri


CURL bağlamı seçeneklerinin listesi

SSL bağlamı seçenekleri
Phar bağlam seçenekleri
Bağlam seçenekleri ve değiştirgeleri
PHP Manual

CURL bağlamı seçenekleri

CURL bağlamı seçenekleri — CURL bağlamı seçeneklerinin listesi

Açıklama

CURL bağlam seçenekleri, CURL eklentisi --with-curlwrappers yapılandırma seçeneği kullanılarak derlenmişse kullanılabilir.

Seçenekler

method string

Uzak sunucu tarafından desteklenen GET, POST veya başka bir HTTP yöntemi.

GET öntanımlıdır.

header string

İstek sırasında gönderilecek ek başlıklar. Bu seçenekte belirtilen değerler diğer değerleri geçersiz kılar (User-agent:, Host:, Authentication: gibi).

user_agent string

User-Agent: başlığı ile gönderilecek değer.

Öntanımlı olarak, php.ini dosyasındaki user_agent değeri kullanılır.

content string

Başlıklardan sonra gönderilecek ek veri.Bu seçenek GET veya HEAD istekleri için kullanılmaz.

proxy string

Vekil sunucunun adresini belirten URI (tcp://vekil.mesela.dom:5100 gibi).

max_redirects integer

İzlenecek yönlendirmelerin azami sayısı. 1 veya daha az bir değer belirtilmesi hiçbir yönlendirmenin izlenmeyeceği anlamına gelir.

20 öntanımlıdır.

curl_verify_ssl_host boolean

Konak doğrulanır.

FALSE öntanımlıdır.

Bilginize:

Bu seçenek hem http hem de ftp sarmalayıcıları tarafından kullanılabilir.

curl_verify_ssl_peer boolean

SSL sertifikası kullanımının doğrulanmasını gerektirir.

FALSE öntanımlıdır.

Bilginize:

Bu seçenek hem http hem de ftp sarmalayıcıları tarafından kullanılabilir.

Örnekler

Örnek 1 - Bir sayfayı çekip veriyi POST ile göndermek

<?php

$postverisi = http_build_query(
    array(
        'var1' => 'biraz içerik',
        'var2' => 'eh işte'
    )
);

$seçenekler = array('http' =>
    array(
        'method'  => 'POST',
        'header'  => 'Content-type: application/x-www-form-urlencoded',
        'content' => $postverisi
    )
);

$bağlam  = stream_context_create($seçenekler);

$sonuç = file_get_contents('http://mesela.dom/submit.php', false, $bağlam);

?>

Ayrıca Bakınız

  • Soket bağlamı seçenekleri

SSL bağlamı seçenekleri
Phar bağlam seçenekleri
Bağlam seçenekleri ve değiştirgeleri


Phar bağlamı seçeneklerinin listesi

CURL bağlamı seçenekleri
MongoDB için bağlamsal seçenekler
Bağlam seçenekleri ve değiştirgeleri
PHP Manual

Phar bağlam seçenekleri

Phar bağlam seçenekleri — Phar bağlamı seçeneklerinin listesi

Açıklama

phar:// sarmalayıcısı için bağlam seçenekleri.

Seçenekler

compress int

Phar sıkıştırma sabitlerinden biri.

metadata mixed

Phar meta verisi. Bakınız: Phar::setMetadata().

Ayrıca Bakınız

  • Phar bağlam seçenekleri
  • Phar akım sarmalayıcısı

CURL bağlamı seçenekleri
MongoDB için bağlamsal seçenekler
Bağlam seçenekleri ve değiştirgeleri


MongoDB için bağlamsal seçeneklerin listesi

Phar bağlam seçenekleri
Bağlam değiştirgeleri
Bağlam seçenekleri ve değiştirgeleri
PHP Manual

MongoDB için bağlamsal seçenekler

MongoDB için bağlamsal seçenekler — MongoDB için bağlamsal seçeneklerin listesi

Açıklama

mongodb:// aktarımları için bağlamsal seçenekler.

Seçenekler

log_cmd_insert callable

Bir belge yerleştirirken çağrılan geri çağırım işlevi, log_cmd_insert() işlevine bakınız.

log_cmd_delete callable

Bir belge silinirken çağrılan geri çağırım işlevi, log_cmd_delete() işlevine bakınız.

log_cmd_update callable

Bir belge güncellenirken çağrılan geri çağırım işlevi, log_cmd_update() işlevine bakınız.

log_write_batch callable

Bir Write Batch çalıştırılırken çağrılan geri çağırım işlevi, log_write_batch() işlevine bakınız.

log_reply callable

MongoDB'den bir yanıt okunurken çağrılan geri çağırım işlevi, log_reply() işlevine bakınız.

log_getmore callable

Bir MongoDB imlecinden daha fazla sonuç döndürürken çağrılan geri çağırım işlevi, log_getmore() işlevine bakınız.

log_killcursor callable

Bir killcursor opkodu çalıştırılırken çağrılan geri çağırım işlevi, log_killcursor() işlevine bakınız.

Sürüm Bilgisi

Sürüm: | Açıklama
pecl/mongo 1.5.0 | Write API Bağlamsal seçenekleri eklendi.

Ayrıca Bakınız

  • Soket bağlamı seçenekleri
  • SSL bağlamı seçenekleri

Phar bağlam seçenekleri
Bağlam değiştirgeleri
Bağlam seçenekleri ve değiştirgeleri


Bağlam değiştirgesi listeleme

MongoDB için bağlamsal seçenekler
Supported Protocols and Wrappers
Bağlam seçenekleri ve değiştirgeleri
PHP Manual

Bağlam değiştirgeleri

Bağlam değiştirgeleri — Bağlam değiştirgesi listeleme

Açıklama

Bu değiştirgeler bir bağlama stream_context_set_params() işlevi kullanılarak atanabilir.

Değiştirgeler

notification callback

Bir akımda bir olayın sonucunda tetiklenecek geri çağırım işlevi.

Daha fazla bilgi için stream_notification_callback() işlevine bakınız.

MongoDB için bağlamsal seçenekler
Supported Protocols and Wrappers
Bağlam seçenekleri ve değiştirgeleri


Supported Protocols and Wrappers

PHP comes with many built-in wrappers for various URL-style protocols for use with the filesystem functions such as fopen(), copy(), file_exists() and filesize(). In addition to these wrappers, it is possible to register custom wrappers using the stream_wrapper_register() function.

Bilginize: The URL syntax used to describe a wrapper only supports the scheme://... syntax. The scheme:/ and scheme: syntaxes are not supported.

İçindekiler

  • file:// — Accessing local filesystem
  • http:// — Accessing HTTP(s) URLs
  • ftp:// — Accessing FTP(s) URLs
  • php:// — Accessing various I/O streams
  • zlib:// — Compression Streams
  • data:// — Data (RFC 2397)
  • glob:// — Find pathnames matching pattern
  • phar:// — PHP Archive
  • ssh2:// — Secure Shell 2
  • rar:// — RAR
  • ogg:// — Audio streams
  • expect:// — Process Interaction Streams
Bağlam değiştirgeleri
file://
Dil Başvuru Kılavuzu


Accessing local filesystem

Supported Protocols and Wrappers
http://
Supported Protocols and Wrappers
PHP Manual

file://

file:// — Accessing local filesystem

Açıklama

Filesystem is the default wrapper used with PHP and represents the local filesystem. When a relative path is specified (a path which does not begin with /, \, \\, or a Windows drive letter) the path provided will be applied against the current working directory. In many cases this is the directory in which the script resides unless it has been changed. Using the CLI sapi, this defaults to the directory from which the script was called.

With some functions, such as fopen() and file_get_contents(), include_path may be optionally searched for relative paths as well.

Kullanımı

  • /path/to/file.ext
  • relative/path/to/file.ext
  • fileInCwd.ext
  • C:/path/to/winfile.ext
  • C:\path\to\winfile.ext
  • \\smbserver\share\path\to\winfile.ext
  • file:///path/to/file.ext

Seçenekler

Wrapper Summary
Attribute | Supported
Restricted by allow_url_fopen | No
Allows Reading | Yes
Allows Writing | Yes
Allows Appending | Yes
Allows Simultaneous Reading and Writing | Yes
Supports stat() | Yes
Supports unlink() | Yes
Supports rename() | Yes
Supports mkdir() | Yes
Supports rmdir() | Yes

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.0 | Added file://.

Supported Protocols and Wrappers
http://
Supported Protocols and Wrappers


Accessing HTTP(s) URLs

file://
ftp://
Supported Protocols and Wrappers
PHP Manual

http://

https://

http:// -- https:// — Accessing HTTP(s) URLs

Açıklama

Allows read-only access to files/resources via HTTP 1.0, using the HTTP GET method. A Host: header is sent with the request to handle name-based virtual hosts. If you have configured a user_agent string using your php.ini file or the stream context, it will also be included in the request.

The stream allows access to the body of the resource; the headers are stored in the $http_response_header variable.

If it's important to know the URL of the resource where your document came from (after all redirects have been processed), you'll need to process the series of response headers returned by the stream.

The from directive will be used for the From: header if set and not overwritten by the Bağlam seçenekleri ve değiştirgeleri.

Kullanımı

  • http://example.com
  • http://example.com/file.php?var1=val1&var2=val2
  • http://user:password@example.com
  • https://example.com
  • https://example.com/file.php?var1=val1&var2=val2
  • https://user:password@example.com

Seçenekler

Wrapper Summary
Attribute | Supported
Restricted by allow_url_fopen | Yes
Allows Reading | Yes
Allows Writing | No
Allows Appending | No
Allows Simultaneous Reading and Writing | N/A
Supports stat() | No
Supports unlink() | No
Supports rename() | No
Supports mkdir() | No
Supports rmdir() | No

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.7 | Detect buggy IIS servers to avoid "SSL: Fatal Protocol Error" errors.
4.3.0 | Added https://.
4.0.5 | Added support for redirects.

Örnekler

Örnek 1 Detecting which URL we ended up on after redirects

<?php
$url = 'http://www.example.com/redirecting_page.php';

$fp = fopen($url, 'r');

$meta_data = stream_get_meta_data($fp);
foreach ($meta_data['wrapper_data'] as $response) {

    /* Were we redirected? */
    if (strtolower(substr($response, 0, 10)) == 'location: ') {

        /* update $url with where we were redirected to */
        $url = substr($response, 10);
    }

}

?>

Notlar

Bilginize: HTTPS is only supported when the openssl extension is enabled.

HTTP connections are read-only; writing data or copying files to an HTTP resource is not supported.

Sending POST and PUT requests, for example, can be done with the help of HTTP Contexts.

Ayrıca Bakınız

  • HTTP bağlamı seçenekleri
  • $http_response_header
  • stream_get_meta_data() - Akımdan başlıkları/meta verileri döndürür
file://
ftp://
Supported Protocols and Wrappers


Accessing FTP(s) URLs

http://
php://
Supported Protocols and Wrappers
PHP Manual

ftp://

ftps://

ftp:// -- ftps:// — Accessing FTP(s) URLs

Açıklama

Allows read access to existing files and creation of new files via FTP. If the server does not support passive mode ftp, the connection will fail.

You can open files for either reading or writing, but not both simultaneously. If the remote file already exists on the ftp server and you attempt to open it for writing but have not specified the context option overwrite, the connection will fail. If you need to overwrite existing files over ftp, specify the overwrite option in the context and open the file for writing. Alternatively, you can use the FTP extension.

If you have set the from directive in php.ini, then this value will be sent as the anonymous FTP password.

Kullanımı

  • ftp://example.com/pub/file.txt
  • ftp://user:password@example.com/pub/file.txt
  • ftps://example.com/pub/file.txt
  • ftps://user:password@example.com/pub/file.txt

Seçenekler

Wrapper Summary
Attribute | PHP 4 | PHP 5
Restricted by allow_url_fopen | Yes | Yes
Allows Reading | Yes | Yes
Allows Writing | Yes (new files only) | Yes (new files/existing files with overwrite)
Allows Appending | No | Yes
Allows Simultaneous Reading and Writing | No | No
Supports stat() | No | As of PHP 5.0.0: filesize(), filetype(), file_exists(), is_file(), and is_dir() elements only. As of PHP 5.1.0: filemtime().
Supports unlink() | No | Yes
Supports rename() | No | Yes
Supports mkdir() | No | Yes
Supports rmdir() | No | Yes

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.0 | Added ftps://.

Notlar

Bilginize:

FTPS is only supported when the openssl extension is enabled.

If the server does not support SSL, then the connection falls back to regular unencrypted ftp.

Bilginize: Appending
As of PHP 5.0.0 files may be appended via the ftp:// URL wrapper. In prior versions, attempting to append to a file via ftp:// will result in failure.

Ayrıca Bakınız

  • FTP bağlamı seçenekleri
http://
php://
Supported Protocols and Wrappers


Accessing various I/O streams

ftp://
zlib://
Supported Protocols and Wrappers
PHP Manual

php://

php:// — Accessing various I/O streams

Açıklama

PHP provides a number of miscellaneous I/O streams that allow access to PHP's own input and output streams, the standard input, output and error file descriptors, in-memory and disk-backed temporary file streams, and filters that can manipulate other file resources as they are read from and written to.

php://stdin, php://stdout and php://stderr

php://stdin, php://stdout and php://stderr allow direct access to the corresponding input or output stream of the PHP process. The stream references a duplicate file descriptor, so if you open php://stdin and later close it, you close only your copy of the descriptor-the actual stream referenced by STDIN is unaffected. Note that PHP exhibited buggy behavior in this regard until PHP 5.2.1. It is recommended that you simply use the constants STDIN, STDOUT and STDERR instead of manually opening streams using these wrappers.

php://stdin is read-only, whereas php://stdout and php://stderr are write-only.

php://input

php://input is a read-only stream that allows you to read raw data from the request body. In the case of POST requests, it is preferable to use php://input instead of $HTTP_RAW_POST_DATA as it does not depend on special php.ini directives. Moreover, for those cases where $HTTP_RAW_POST_DATA is not populated by default, it is a potentially less memory intensive alternative to activating always_populate_raw_post_data. php://input is not available with enctype="multipart/form-data".

Bilginize: Prior to PHP 5.6, a stream opened with php://input could only be read once; the stream did not support seek operations. However, depending on the SAPI implementation, it may be possible to open another php://input stream and restart reading. This is only possible if the request body data has been saved. Typically, this is the case for POST requests, but not other request methods, such as PUT or PROPFIND.

php://output

php://output is a write-only stream that allows you to write to the output buffer mechanism in the same way as print and echo.

php://fd

php://fd allows direct access to the given file descriptor. For example, php://fd/3 refers to file descriptor 3.

php://memory and php://temp

php://memory and php://temp are read-write streams that allow temporary data to be stored in a file-like wrapper. The only difference between the two is that php://memory will always store its data in memory, whereas php://temp will use a temporary file once the amount of data stored hits a predefined limit (the default is 2 MB). The location of this temporary file is determined in the same way as the sys_get_temp_dir() function.

The memory limit of php://temp can be controlled by appending /maxmemory:NN, where NN is the maximum amount of data to keep in memory before using a temporary file, in bytes.

php://filter

php://filter is a kind of meta-wrapper designed to permit the application of filters to a stream at the time of opening. This is useful with all-in-one file functions such as readfile(), file(), and file_get_contents() where there is otherwise no opportunity to apply a filter to the stream prior the contents being read.

The php://filter target takes the following parameters as part of its path. Multiple filter chains can be specified on one path. Please refer to the examples for specifics on using these parameters.

php://filter parameters
Name | Description
resource=<stream to be filtered> | This parameter is required. It specifies the stream that you would like to filter.
read=<filter list to apply to read chain> | This parameter is optional. One or more filter names can be provided here, separated by the pipe character (|).
write=<filter list to apply to write chain> | This parameter is optional. One or more filter names can be provided here, separated by the pipe character (|).
<filter list to apply to both chains> | Any filter lists which are not prefixed by read= or write= will be applied to both the read and write chains as appropriate.

Seçenekler

Wrapper Summary (for php://filter, refer to the summary of the wrapper being filtered)
Attribute | Supported
Restricted by allow_url_fopen | No
Restricted by allow_url_include | php://input, php://stdin, php://memory and php://temp only.
Allows Reading | php://stdin, php://input, php://fd, php://memory and php://temp only.
Allows Writing | php://stdout, php://stderr, php://output, php://fd, php://memory and php://temp only.
Allows Appending | php://stdout, php://stderr, php://output, php://fd, php://memory and php://temp only. (Equivalent to writing)
Allows Simultaneous Reading and Writing | php://fd, php://memory and php://temp only.
Supports stat() | php://memory and php://temp only.
Supports unlink() | No
Supports rename() | No
Supports mkdir() | No
Supports rmdir() | No
Supports stream_select() | php://stdin, php://stdout, php://stderr, php://fd and php://temp only.

Sürüm Bilgisi

Sürüm: | Açıklama
5.6.0 | php://input was made reusable.
5.3.6 | php://fd was added.
5.1.0 | php://memory and php://temp were added.
5.0.0 | php://filter was added.

Örnekler

Örnek 1 php://temp/maxmemory

This optional parameter allows setting the memory limit before php://temp starts using a temporary file.

<?php
// Set the limit to 5 MB.
$fiveMBs = 5 * 1024 * 1024;
$fp = fopen("php://temp/maxmemory:$fiveMBs", 'r+');

fputs($fp, "hello\n");

// Read what we have written.
rewind($fp);
echo stream_get_contents($fp);
?>

Örnek 2 php://filter/resource=<stream to be filtered>

This parameter must be located at the end of your php://filter specification and should point to the stream which you want filtered.

<?php
/* This is equivalent to simply:
  readfile("http://www.example.com");
  since no filters are actually specified */

readfile("php://filter/resource=http://www.example.com");
?>

Örnek 3 php://filter/read=<filter list to apply to read chain>

This parameter takes one or more filternames separated by the pipe character |.

<?php
/* This will output the contents of
  www.example.com entirely in uppercase */
readfile("php://filter/read=string.toupper/resource=http://www.example.com");

/* This will do the same as above
  but will also ROT13 encode it */
readfile("php://filter/read=string.toupper|string.rot13/resource=http://www.example.com");
?>

Örnek 4 php://filter/write=<filter list to apply to write chain>

This parameter takes one or more filternames separated by the pipe character |.

<?php
/* This will filter the string "Hello World"
  through the rot13 filter, then write to
  example.txt in the current directory */
file_put_contents("php://filter/write=string.rot13/resource=example.txt","Hello World");
?>

Örnek 5 php://memory and php://temp are not reusable

php://memory and php://temp and not reusable, i.e. after the streams have been closed there is no way to refer to them again.

file_put_contents('php://memory', 'PHP');
echo file_get_contents('php://memory'); // prints nothing
ftp://
zlib://
Supported Protocols and Wrappers


Compression Streams

php://
data://
Supported Protocols and Wrappers
PHP Manual

zlib://

bzip2://

zip://

zlib:// -- bzip2:// -- zip:// — Compression Streams

Açıklama

zlib: PHP 4.0.4 - PHP 4.2.3 (systems with fopencookie only)

compress.zlib:// and compress.bzip2:// PHP 4.3.0 and up

zlib: works like gzopen(), except that the stream can be used with fread() and the other filesystem functions. This is deprecated as of PHP 4.3.0 due to ambiguities with filenames containing ':' characters; use compress.zlib:// instead.

compress.zlib:// and compress.bzip2:// are equivalent to gzopen() and bzopen() respectively, and operate even on systems that do not support fopencookie.

ZIP extension registers zip: wrapper.

Kullanımı

  • compress.zlib://file.gz
  • compress.bzip2://file.bz2
  • zip://archive.zip#dir/file.txt

Seçenekler

Wrapper Summary
Attribute | Supported
Restricted by allow_url_fopen | No
Allows Reading | Yes
Allows Writing | Yes (except zip://)
Allows Appending | Yes (except zip://)
Allows Simultaneous Reading and Writing | No
Supports stat() | No, use the normal file:// wrapper to stat compressed files.
Supports unlink() | No, use the normal file:// wrapper to unlink compressed files.
Supports rename() | No
Supports mkdir() | No
Supports rmdir() | No

php://
data://
Supported Protocols and Wrappers


Data (RFC 2397)

zlib://
glob://
Supported Protocols and Wrappers
PHP Manual

data://

data:// — Data (RFC 2397)

Açıklama

The data: (» RFC 2397) stream wrapper is available since PHP 5.2.0.

Kullanımı

  • data://text/plain;base64,

Seçenekler

Wrapper Summary
Attribute | Supported
Restricted by allow_url_fopen | No
Restricted by allow_url_include | Yes
Allows Reading | Yes
Allows Writing | No
Allows Appending | No
Allows Simultaneous Reading and Writing | No
Supports stat() | No
Supports unlink() | No
Supports rename() | No
Supports mkdir() | No
Supports rmdir() | No

Örnekler

Örnek 1 Print data:// contents

<?php
// prints "I love PHP"
echo file_get_contents('data://text/plain;base64,SSBsb3ZlIFBIUAo=');
?>

Örnek 2 Fetch the media type

<?php
$fp   = fopen('data://text/plain;base64,', 'r');
$meta = stream_get_meta_data($fp);

// prints "text/plain"
echo $meta['mediatype'];
?>
zlib://
glob://
Supported Protocols and Wrappers


Find pathnames matching pattern

data://
phar://
Supported Protocols and Wrappers
PHP Manual

glob://

glob:// — Find pathnames matching pattern

Açıklama

The glob: stream wrapper is available since PHP 5.3.0.

Kullanımı

  • glob://

Seçenekler

Wrapper Summary
Attribute | Supported
Restricted by allow_url_fopen | No
Restricted by allow_url_include | No
Allows Reading | No
Allows Writing | No
Allows Appending | No
Allows Simultaneous Reading and Writing | No
Supports stat() | No
Supports unlink() | No
Supports rename() | No
Supports mkdir() | No
Supports rmdir() | No

Örnekler

Örnek 1 Basic usage

<?php
// Loop over all *.php files in ext/spl/examples/ directory
// and print the filename and its size
$it = new DirectoryIterator("glob://ext/spl/examples/*.php");
foreach($it as $f) {
    printf("%s: %.1FK\n", $f->getFilename(), $f->getSize()/1024);
}
?>
tree.php: 1.0K
findregex.php: 0.6K
findfile.php: 0.7K
dba_dump.php: 0.9K
nocvsdir.php: 1.1K
phar_from_dir.php: 1.0K
ini_groups.php: 0.9K
directorytree.php: 0.9K
dba_array.php: 1.1K
class_tree.php: 1.8K
data://
phar://
Supported Protocols and Wrappers


PHP Archive

glob://
ssh2://
Supported Protocols and Wrappers
PHP Manual

phar://

phar:// — PHP Archive

Açıklama

The phar:// stream wrapper is available since PHP 5.3.0. See Phar stream wrapper for detailed description.

Kullanımı

  • phar://

Seçenekler

Wrapper Summary
Attribute | Supported
Restricted by allow_url_fopen | No
Restricted by allow_url_include | No
Allows Reading | Yes
Allows Writing | Yes
Allows Appending | No
Allows Simultaneous Reading and Writing | Yes
Supports stat() | Yes
Supports unlink() | Yes
Supports rename() | Yes
Supports mkdir() | Yes
Supports rmdir() | Yes

Ayrıca Bakınız

  • Phar bağlam seçenekleri
glob://
ssh2://
Supported Protocols and Wrappers


Secure Shell 2

phar://
rar://
Supported Protocols and Wrappers
PHP Manual

ssh2://

ssh2:// — Secure Shell 2

Açıklama

ssh2.shell:// ssh2.exec:// ssh2.tunnel:// ssh2.sftp:// ssh2.scp:// PHP 4.3.0 and up (PECL)

Bilginize: This wrapper is not enabled by default
In order to use the ssh2.*:// wrappers you must install the » SSH2 extension available from » PECL.

In addition to accepting traditional URI login details, the ssh2 wrappers will also reuse open connections by passing the connection resource in the host portion of the URL.

Kullanımı

  • ssh2.shell://user:pass@example.com:22/xterm
  • ssh2.exec://user:pass@example.com:22/usr/local/bin/somecmd
  • ssh2.tunnel://user:pass@example.com:22/192.168.0.1:14
  • ssh2.sftp://user:pass@example.com:22/path/to/filename

Seçenekler

Wrapper Summary
Attribute | ssh2.shell | ssh2.exec | ssh2.tunnel | ssh2.sftp | ssh2.scp
Restricted by allow_url_fopen | Yes | Yes | Yes | Yes | Yes
Allows Reading | Yes | Yes | Yes | Yes | Yes
Allows Writing | Yes | Yes | Yes | Yes | No
Allows Appending | No | No | No | Yes (When supported by server) | No
Allows Simultaneous Reading and Writing | Yes | Yes | Yes | Yes | No
Supports stat() | No | No | No | Yes | No
Supports unlink() | No | No | No | Yes | No
Supports rename() | No | No | No | Yes | No
Supports mkdir() | No | No | No | Yes | No
Supports rmdir() | No | No | No | Yes | No

Context options
Name | Usage | Default
session | Preconnected ssh2 resource to be reused |
sftp | Preallocated sftp resource to be reused |
methods | Key exchange, hostkey, cipher, compression, and MAC methods to use |
callbacks |  |
username | Username to connect as |
password | Password to use with password authentication |
pubkey_file | Name of public key file to use for authentication |
privkey_file | Name of private key file to use for authentication |
env | Associate array of environment variables to set |
term | Terminal emulation type to request when allocating a pty |
term_width | Width of terminal requested when allocating a pty |
term_height | Height of terminal requested when allocating a pty |
term_units | Units to use with term_width and term_height | SSH2_TERM_UNIT_CHARS

Örnekler

Örnek 1 Opening a stream from an active connection

<?php
$session = ssh2_connect('example.com', 22);
ssh2_auth_pubkey_file($session, 'username', '/home/username/.ssh/id_rsa.pub',
                                            '/home/username/.ssh/id_rsa', 'secret');
$stream = fopen("ssh2.tunnel://$session/remote.example.com:1234", 'r');
?>

Örnek 2 This $session variable must be kept available!

In order to use the ssh2.*://$session wrappers you must keep the $session resouce variable. The code below will not have the desired effect:

<?php
$session = ssh2_connect('example.com', 22);
ssh2_auth_pubkey_file($session, 'username', '/home/username/.ssh/id_rsa.pub',
                                            '/home/username/.ssh/id_rsa', 'secret');
$connection_string = "ssh2.sftp://$session/";
unset($session);
$stream = fopen($connection_string . "path/to/file", 'r');
?>

unset() closes the session, because $connection_string does not hold a reference to the $session variable, just a string cast derived from it. This also happens when the unset() is implicit because of leaving scope (like in a function).

phar://
rar://
Supported Protocols and Wrappers


RAR

ssh2://
ogg://
Supported Protocols and Wrappers
PHP Manual

rar://

rar:// — RAR

Açıklama

The wrapper takes the url encoded path to the RAR archive (relative or absolute), an optional asterik (*), an optional number sign (#) and an optional url encoded entry name, as stored in the archive. Specifying an entry name requires the number sign; a leading forward slash in the entry name is optional.

This wrapper can open both files and directories. When opening directories, the asterisk sign forces the directory entries names to be returned unencoded. If it's not specified, they will be returned url encoded - the reason for this is to allow the wrapper to be correctly used with built-in functionality like the RecursiveDirectoryIterator in the presence of file names that seem like url encoded data.

If the pound sign and the entry name part are not included, the root of the archive will be displayed. This differs from regular directories in that the resulting stream will not contain information such as the modification time, as the root directory is not stored in an individual entry in the archive. The usage of the wrapper with RecursiveDirectoryIterator requires the number sign to be included in the URL when accessing the root, so that the URLs of the children may be constructed correctly.

Bilginize: This wrapper is not enabled by default
In order to use the rar:// wrapper, you must install the » rar extension available from » PECL.

rar:// Available since PECL rar 3.0.0

Kullanımı

  • rar://<url encoded archive name>[*][#[<url encoded entry name>]]

Seçenekler

Wrapper Summary
Attribute | Supported
Restricted by allow_url_fopen | No
Restricted by allow_url_include | No
Allows Reading | Yes
Allows Writing | No
Allows Appending | No
Allows Simultaneous Reading and Writing | No
Supports stat() | Yes
Supports unlink() | No
Supports rename() | No
Supports mkdir() | No
Supports rmdir() | No

Context options
Name | Usage | Default
open_password | The password used to encrypt the headers of the archive, if any. WinRAR will encrypt all the files with the same password as the headers password when the later is present, so for archives with encrypted headers, file_password will be ignored. |
file_password | The password used to encrypt a file, if any. If the headers are also encrypted, this option will be ignored in favor of open_password. The reason there are two options is to cover the possibility of supporting archives with different headers and file passwords, should those archives arise. Note that if the archive does not have its headers encrypted, open_password will be ignored and this option must be used instead. |
volume_callback | A callback to determine the path of missing volumes. See RarArchive::open() for more information. |

Örnekler

Örnek 1 Traversing a RAR archive

<?php

class MyRecDirIt extends RecursiveDirectoryIterator {
    function current() {
        return rawurldecode($this->getSubPathName()) .
            (is_dir(parent::current())?" [DIR]":"");
    }
}

$f = "rar://" . rawurlencode(dirname(__FILE__)) .
    DIRECTORY_SEPARATOR . 'dirs_and_extra_headers.rar#';

$it = new RecursiveTreeIterator(new MyRecDirIt($f));

foreach ($it as $s) {
    echo $s, "\n";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

|-allow_everyone_ni [DIR]
|-file1.txt
|-file2_?.txt
|-with_streams.txt
\-? [DIR]
  |-?\%2Fempty%2E [DIR]
  | \-?\%2Fempty%2E\file7.txt
  |-?\empty [DIR]
  |-?\file3.txt
  |-?\file4_?.txt
  \-?\?_2 [DIR]
    |-?\?_2\file5.txt
    \-?\?_2\file6_?.txt

Örnek 2 Opening an encrypted file (header encryption)

<?php
$stream = fopen("rar://" .
    rawurlencode(dirname(__FILE__)) . DIRECTORY_SEPARATOR .
    'encrypted_headers.rar' . '#encfile1.txt', "r", false,
    stream_context_create(
        array(
            'rar' =>
                array(
                    'open_password' => 'samplepassword'
                )
            )
        )
    );
var_dump(stream_get_contents($stream));
/* creation and last access date is opt-in in WinRAR, hence most
 * files don't have them */
var_dump(fstat($stream));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(26) "Encrypted file 1 contents."
Array
(
    [0] => 0
    [1] => 0
    [2] => 33206
    [3] => 1
    [4] => 0
    [5] => 0
    [6] => 0
    [7] => 26
    [8] => 0
    [9] => 1259550052
    [10] => 0
    [11] => -1
    [12] => -1
    [dev] => 0
    [ino] => 0
    [mode] => 33206
    [nlink] => 1
    [uid] => 0
    [gid] => 0
    [rdev] => 0
    [size] => 26
    [atime] => 0
    [mtime] => 1259550052
    [ctime] => 0
    [blksize] => -1
    [blocks] => -1
)
ssh2://
ogg://
Supported Protocols and Wrappers


Audio streams

rar://
expect://
Supported Protocols and Wrappers
PHP Manual

ogg://

ogg:// — Audio streams

Açıklama

Files opened for reading via the ogg:// wrapper are treated as compressed audio encoded using the OGG/Vorbis codec. Similarly, files opened for writing or appending via the ogg:// wrapper are writen as compressed audio data. stream_get_meta_data(), when used on an OGG/Vorbis file opened for reading will return various details about the stream including the vendor tag, any included comments, the number of channels, the sampling rate, and the encoding rate range described by: bitrate_lower, bitrate_upper, bitrate_nominal, and bitrate_window.

ogg:// PHP 4.3.0 and up (PECL)

Bilginize: This wrapper is not enabled by default
In order to use the ogg:// wrapper you must install the » OGG/Vorbis extension available from » PECL.

Kullanımı

  • ogg://soundfile.ogg
  • ogg:///path/to/soundfile.ogg
  • ogg://http://www.example.com/path/to/soundstream.ogg

Seçenekler

Wrapper Summary
Attribute | Supported
Restricted by allow_url_fopen | No
Allows Reading | Yes
Allows Writing | Yes
Allows Appending | Yes
Allows Simultaneous Reading and Writing | No
Supports stat() | No
Supports unlink() | No
Supports rename() | No
Supports mkdir() | No
Supports rmdir() | No

Context options
Name | Usage | Default | Mode
pcm_mode | PCM encoding to apply while reading, one of: OGGVORBIS_PCM_U8, OGGVORBIS_PCM_S8, OGGVORBIS_PCM_U16_BE, OGGVORBIS_PCM_S16_BE, OGGVORBIS_PCM_U16_LE, and OGGVORBIS_PCM_S16_LE. (8 vs 16 bit, signed or unsigned, big or little endian) | OGGVORBIS_PCM_S16_LE | Read
rate | Sampling rate of input data, expressed in Hz | 44100 | Write/Append
bitrate | When given as an integer, the fixed bitrate at which to encode. (16000 to 131072) When given as a float, the variable bitrate quality to use. (-1.0 to 1.0) | 128000 | Write/Append
channels | The number of audio channels to encode, typically 1 (Mono), or 2 (Stereo). May range as high as 16. | 2 | Write/Append
comments | An array of string values to encode into the track header. |  | Write/Append

Örnekler

rar://
expect://
Supported Protocols and Wrappers


Process Interaction Streams

ogg://
Güvenlik
Supported Protocols and Wrappers
PHP Manual

expect://

expect:// — Process Interaction Streams

Açıklama

Streams opened via the expect:// wrapper provide access to process'es stdio, stdout and stderr via PTY.

Bilginize: This wrapper is not enabled by default
In order to use the expect:// wrapper you must install the » Expect extension available from » PECL.

expect:// PHP 4.3.0 and up (PECL)

Kullanımı

  • expect://command

Seçenekler

Wrapper Summary
Attribute | Supported
Restricted by allow_url_fopen | No
Allows Reading | Yes
Allows Writing | Yes
Allows Appending | Yes
Allows Simultaneous Reading and Writing | No
Supports stat() | No
Supports unlink() | No
Supports rename() | No
Supports mkdir() | No
Supports rmdir() | No

Örnekler

ogg://
Güvenlik
Supported Protocols and Wrappers


Güvenlik

  • Giriş
  • Genel değerlendirmeler
  • Installed as CGI binary
    • Possible attacks
    • Case 1: only public files served
    • Case 2: using cgi.force_redirect
    • Case 3: setting doc_root or user_dir
    • Case 4: PHP parser outside of web tree
  • Apache'ye modül olarak kurulum
  • Session Security
  • Dosya Sistemi Güvenliği
    • Boş baytlı girdiler
  • Database Security
    • Designing Databases
    • Connecting to Database
    • Encrypted Storage Model
    • SQL Injection
  • Error Reporting
  • register_globals Kullanımı
  • Kullanıcıdan Gelen Bilgi
  • Sihirli Tırnak
    • Sihirli Tırnaklar nedir?
    • Sihirli Tırnaklar Neden Kullanılır?
    • Sihirli Tırnaklar Neden Kullanılmamalıdır?
    • Sihirli Tırnakların İptali
  • PHP'yi gizlemek
  • Güncel Tutmak
expect://
Giriş
PHP Kılavuzu


Giriş

PHP güçlü bir dil ve yorumlayıcıdır. İster bir HTTP sunucusunun modülü olarak ister ayrı bir CGI çalıştırılabiliri olarak çalışıyor olsun, sunucu üzerinde ağ bağlantıları açabilir, dosyalara erişebilir ve onları çalıştırabilir. Herşeyi çalıştırılabilir yapan bu özellikler öntanımlı haliyle bir HTTP sunucusunu güvensiz duruma getirir. PHP, CGI programları yazmak için özellikle Perl ve C'den daha güvenli bir dil olması için tasarlanmıştır. Doğru derleme seçenekleri ile derlenir, doğru çalışma anı seçenekleriyle yapılandırılır ve uygun bir kodlama deneyimiyle kullanılırsa arzuladığınız güvenlik ve özgürlüğü size sunar.

PHP ile birçok şey yapmak mümkün olduğu gibi, ayarları da oldukça fazladır. Bu ayarların çokluğu size istediğiniz şekilde bir sunucu ortamını kurmanızı sağlarsa da bu seçeneklerle sunucunun yapılandırması bir araya geldiğinde güvensiz bir ortam oluşma riski anlamına da gelebilir.

PHP yapılandırmasındaki bu esneklik, kod esnekliğiyle rekabet halinde gelişir. PHP ile bir kabuk kullanıcısının tüm gücüne sahip eksiksiz sunucu uygulamaları geliştirlebileceği gibi sıkı bir şekilde denetlenen bir ortamda küçük bir güvenlik riskiyle sunucu taraflı sayfalar oluşturmakta da kullanılabilir. Bu ortamın nasıl kurulacağı ve güvenliğinin nasıl sağlanacağı büyük oranda PHP geliştiricisine bırakılmıştır.

Bu kısıma genel güvenlik tavsiyeleri vererek başlayacağız. Ardından değişik ayarların nasıl yapıldığına dair bilgiler verecek ve hangi güvenlik seviyesinde hangi güvenlik ayarlarının kullanılması gerektiğinden bahsedeceğiz.

Güvenlik
Genel değerlendirmeler
Güvenlik


Genel değerlendirmeler

Tamamen güvenli ve korunaklı bir sistem oluşturduk diyebilmek neredeyse imkansızdır. Bu sebepten dolayı en uygun davranış riskleri ve kullanılabilirliği uygun şekilde dengelemek olmalıdır. Eğer kullanıcıların bilgi göndermeden önce parmak izi ve gözbebeği taraması gibi ileri güvenlikli bir sistemden geçmesi gerekirse, çok güvenli bir sistem oluşturulduğundan söz edebiliriz. Ancak bu şekilde kullanımı çok zor bir sistem halini alacaktır. Aynı şekilde basit bir amaç için hazırlanmış bir formu doldurmak çok zorsa ve vakit alıyorsa, bunu dolduran kullanıcı güvenliği atlatıp bazı kestirme yolları deneyerek formu göndermek isteyebilir.

En iyi güvenlik sisteminin yolu istenen güvenlik denetimlerinin kullanıcı çok uğraştırılıp bıktırılmadan, yapmak istediği şeye engel olunmadan kurulan bir sistemden geçer. Güvenliği etkileyen bazı saldırıların asıl amacı bazen güvenlik amaçlı kurulan bazı sistemlerin kullanıcıları bıktırması ve bunların kullanıcıyı farklı birşeyler yapmaya itmesidir.

Unutmayın ki, bir zincir ancak en zayıf halkası kadar güçlü olabilir. Tüm hareketleri, zaman, mekan, hareket türü gibi en ince ayrıntısına kadar günlüklere kaydetseniz bile kullanıcı sadece basit bir çerez ile doğrulanıyorsa, kullanıcılarla hareket günlükleri arasındaki ilişki zayıf olacaktır.

Yaptıklarınızı denerken, en basit sayfada bile tüm olasılıkları denemenin imkansız olduğunu unutmayınız. Uygulamanıza ulaşan bilgi şirketinizde çalışan bir tanıdıktan gelebileceği gibi, klavyenin üzerinde dolaşan bir kediden veya dünyanın öteki ucundan sistemlerde açıklar arayan sistem kırıcı birinden de gelebilir. Bu yüzden beklenmeyen bir bilgi geldiğinde nasıl davranılacağını önceden tespit edip, bu durumda kullanıcının uygulamayı kullanarak sisteme erişmesini engellemelisiniz.

Günümüz Genel Ağ'ı, kodunuzu kırarak, sitenizi çökerterek, uygunsuz içerik göndererek veya gününüzü bir şekilde ziyan ederek kendilerine isim yapmaya çalışan kişilerle doludur. Sitenizin küçük ya da büyük olmasının bir önemi yoktur, siz basitçe hatta kalmayı, bağlanacağınız bir sunucu olmasını hedeflersiniz fakat, çoğu kırıcı program için büyüklüğün önemi yoktur, basitçe devasa IP bloklarını tarayarak kendilerine kurban ararlar. Onların kurbanlarından biri olmamaya çalışın.

Giriş
Installed as CGI binary
Güvenlik


Installed as CGI binary

İçindekiler

  • Possible attacks
  • Case 1: only public files served
  • Case 2: using cgi.force_redirect
  • Case 3: setting doc_root or user_dir
  • Case 4: PHP parser outside of web tree
Genel değerlendirmeler
Possible attacks
Güvenlik


Possible attacks

Using PHP as a CGI binary is an option for setups that for some reason do not wish to integrate PHP as a module into server software (like Apache), or will use PHP with different kinds of CGI wrappers to create safe chroot and setuid environments for scripts. This setup usually involves installing executable PHP binary to the web server cgi-bin directory. CERT advisory » CA-96.11 recommends against placing any interpreters into cgi-bin. Even if the PHP binary can be used as a standalone interpreter, PHP is designed to prevent the attacks this setup makes possible:

  • Accessing system files: http://my.host/cgi-bin/php?/etc/passwd The query information in a URL after the question mark (?) is passed as command line arguments to the interpreter by the CGI interface. Usually interpreters open and execute the file specified as the first argument on the command line. When invoked as a CGI binary, PHP refuses to interpret the command line arguments.
  • Accessing any web document on server: http://my.host/cgi-bin/php/secret/doc.html The path information part of the URL after the PHP binary name, /secret/doc.html is conventionally used to specify the name of the file to be opened and interpreted by the CGI program. Usually some web server configuration directives (Apache: Action) are used to redirect requests to documents like http://my.host/secret/script.php to the PHP interpreter. With this setup, the web server first checks the access permissions to the directory /secret, and after that creates the redirected request http://my.host/cgi-bin/php/secret/script.php. Unfortunately, if the request is originally given in this form, no access checks are made by web server for file /secret/script.php, but only for the /cgi-bin/php file. This way any user able to access /cgi-bin/php is able to access any protected document on the web server. In PHP, runtime configuration directives cgi.force_redirect, doc_root and user_dir can be used to prevent this attack, if the server document tree has any directories with access restrictions. See below for full the explanation of the different combinations.
Installed as CGI binary
Case 1: only public files served
Installed as CGI binary


Case 1: only public files served

If your server does not have any content that is not restricted by password or ip based access control, there is no need for these configuration options. If your web server does not allow you to do redirects, or the server does not have a way to communicate to the PHP binary that the request is a safely redirected request, you can specify the option --enable-force-cgi-redirect to the configure script. You still have to make sure your PHP scripts do not rely on one or another way of calling the script, neither by directly http://my.host/cgi-bin/php/dir/script.php nor by redirection http://my.host/dir/script.php.

Redirection can be configured in Apache by using AddHandler and Action directives (see below).

Possible attacks
Case 2: using cgi.force_redirect
Installed as CGI binary


Case 2: using cgi.force_redirect

The configuration directive cgi.force_redirect prevents anyone from calling PHP directly with a URL like http://my.host/cgi-bin/php/secretdir/script.php. Instead, PHP will only parse in this mode if it has gone through a web server redirect rule. PHP older than 4.2.0 used --enable-force-cgi-redirect compile time option for this.

Usually the redirection in the Apache configuration is done with the following directives:

Action php-script /cgi-bin/php
AddHandler php-script .php

This option has only been tested with the Apache web server, and relies on Apache to set the non-standard CGI environment variable REDIRECT_STATUS on redirected requests. If your web server does not support any way of telling if the request is direct or redirected, you cannot use this option and you must use one of the other ways of running the CGI version documented here.

Case 1: only public files served
Case 3: setting doc_root or user_dir
Installed as CGI binary


Case 3: setting doc_root or user_dir

To include active content, like scripts and executables, in the web server document directories is sometimes considered an insecure practice. If, because of some configuration mistake, the scripts are not executed but displayed as regular HTML documents, this may result in leakage of intellectual property or security information like passwords. Therefore many sysadmins will prefer setting up another directory structure for scripts that are accessible only through the PHP CGI, and therefore always interpreted and not displayed as such.

Also if the method for making sure the requests are not redirected, as described in the previous section, is not available, it is necessary to set up a script doc_root that is different from web document root.

You can set the PHP script document root by the configuration directive doc_root in the configuration file, or you can set the environment variable PHP_DOCUMENT_ROOT. If it is set, the CGI version of PHP will always construct the file name to open with this doc_root and the path information in the request, so you can be sure no script is executed outside this directory (except for user_dir below).

Another option usable here is user_dir. When user_dir is unset, only thing controlling the opened file name is doc_root. Opening a URL like http://my.host/~user/doc.php does not result in opening a file under users home directory, but a file called ~user/doc.php under doc_root (yes, a directory name starting with a tilde [~]).

If user_dir is set to for example public_php, a request like http://my.host/~user/doc.php will open a file called doc.php under the directory named public_php under the home directory of the user. If the home of the user is /home/user, the file executed is /home/user/public_php/doc.php.

user_dir expansion happens regardless of the doc_root setting, so you can control the document root and user directory access separately.

Case 2: using cgi.force_redirect
Case 4: PHP parser outside of web tree
Installed as CGI binary


Case 4: PHP parser outside of web tree

A very secure option is to put the PHP parser binary somewhere outside of the web tree of files. In /usr/local/bin, for example. The only real downside to this option is that you will now have to put a line similar to:

#!/usr/local/bin/php
as the first line of any file containing PHP tags. You will also need to make the file executable. That is, treat it exactly as you would treat any other CGI script written in Perl or sh or any other common scripting language which uses the #! shell-escape mechanism for launching itself.

To get PHP to handle PATH_INFO and PATH_TRANSLATED information correctly with this setup, the PHP parser should be compiled with the --enable-discard-path configure option.

Case 3: setting doc_root or user_dir
Apache'ye modül olarak kurulum
Installed as CGI binary


Apache'ye modül olarak kurulum

PHP bir Apache modülü olarak kullanıldığında Apache kullanıcısının (Apache yapılandırma dosyasında user yönergesine bakın) yetkilerini miras alır. Bu kullanıcı genellikle 'nobody' kullanıcısı olur fakat bunun güvenlikle ve kimlik doğrulama ile ilgili olumsuz etkileri olabilir. Örneğin PHP'yi bir veritabanına erişmek için kullanıyorsanız ve bu veritabanına yerleşik olarak erişim izniniz yoksa "nobody" kullanıcısına bu veritabanına erişim izni vermek zorunda kalırsınız. Bu, kötücül bir betiğin bir kullanıcı ismi ve parola belirtmeksizin veritabanına erişebilmesi ve değişiklik yapabilmesi anlamına gelir. Bir ağ örümceğinin veritabanı yönetici sayfasına rast gelmesi ve tüm veritabanınızı yok etmesi çok mümkündür. Bu gibi durumlardan Apache kimlik doğrulaması ile korunabileceğiniz gibi LDAP, .htaccess dosyaları, vs. kullanarak kendi erişim modelinizi tasarlayabilir ve bu kodu PHP betiklerinize dahil edebilirsiniz.

Güvenliğin sağlanması, PHP'nin tamamen etkisiz hale getirilmesi, dosya yazma, veritabanı erişiminin kısıtlanması demek değildir. Bunlar sağlanırsa güvenli bir işlem ortamı oluşmuş olabilir ancak PHP özellikleri kaybolmuş olur.

Sık yapılan bir güvenlik hatası Apache'yi root kullanıcısının aidiyetinde çalıştırmak veya Apache'nin yeteneklerini başka yollarla arttırmaktır.

Apache kullanıcısının yetkilerini root seviyesine yükseltmek, oldukça tehlikeli olup sistemin tamamını tehlikeye atmak demektir. Dolayısıyla, güvenlik profesyoneli olmayanların sudo veya chroot yapmayı ya da Apache'yi root olarak başka bir şekilde çalıştırmayı düşünmemesi gerekir.

PHP bazı basit çözümler içermektedir. Örneğin, open_basedir kullanarak PHP tarafından kullanımına izin verilen dizinlere erişimi denetleyebilir ve kısıtlayabilirsiniz. Ayrıca, sadece Apache'nin erişimine açık bölgeler tanımlayabilir, kullanıcılara ve sisteme ait dosyalara erişimi kısıtlayabilirsiniz.

Case 4: PHP parser outside of web tree
Session Security
Güvenlik


Session Security

It is important keeping HTTP session mangement secure. Session releated security is described in Session Security section of Session module reference.

Apache'ye modül olarak kurulum
Dosya Sistemi Güvenliği
Güvenlik


Dosya Sistemi Güvenliği

İçindekiler

  • Boş baytlı girdiler

PHP, çoğu sunucu sisteminde bulunan dizin ve dosya erişim izinleri ile ilgili yerleşik güvenlik önlemlerinden etkilenir. Bu izinlerle dosya sisteminden kimin hangi dosyaları okuyabileceğini denetleyebilirsiniz. Dosya sistemine erişimi olan tüm kullanıcıların sadece herkesçe okunabilen dosyaları okuyabilmesini sağlamalısınız.

PHP, dosya sistemine kullanıcı seviyesinde düşük seviyeli erişime izin verecek şekilde tasarlandığından, /etc/passwd gibi sistem dosyalarını okumak, eternet bağlantılarını değiştirmek, yazıcılara iş göndermek ve benzerleri tamamen mümkündür. Bu durum sizin bazı önlemler almanızı gerektirir; dosyaları kimlerin okuyabileceğine ve kimlerin yazabileceğine karar vermeniz gerekir.

Örneğin, aşağıdaki betiği ele alalım. Kullanıcı, ev dizinindeki bazı dosyaları silmek istiyor olsun. Bir sayfanın, kullanıcının ev dizinindeki bazı dosyaları Apache kullanıcısına sildirmek için bir arayüz olarak kullanıldığını varsayalım.

Örnek 1 - Değişkenler başınıza iş açabilir...

<?php
// Kullanıcının ev dizininden bir dosya silelim
$kullanıcı = $_POST['kullanıcının_belirttiği_isim'];
$kullanıcı_dosyası = $_POST['kullanıcının_belirttiği_dosyaismi'];
$evdizini  = "/home/$kullanıcı";

unlink("$evdizini/$kullanıcı_dosyası");

echo "Dosya silindi!";
?>
Birine ait bir kullanıcı ve dosya ismi bir formdan gönderilebileceğinden bunu yapmaya izni olmayan biri bile bu betikle dosya silebilir. Bu durumda kimlik doğrulaması yapabilen bir betik kullanmak daha iyi olabilir. Birinin formu kullanarak "../etc/" ve "passwd" girdiğini varsayalım ve betikte neler oluyor bakalım:

Örnek 2 ... Bir dosya sistemi saldırısı

<?php
// PHP kullanıcısının erişebildiği bir yerden bir dosyayı silelim.
// PHP root yetkilerine sahip olsun.
$kullanıcı = $_POST['kullanıcının_belirttiği_isim']; // "../etc"
$kullanıcı_dosyası = $_POST['kullanıcının_belirttiği_dosyaismi']; // "passwd"
$evdizini  = "/home/$kullanıcı"; // "/home/../etc"

unlink("$evdizini/$kullanıcı_dosyası"); // "/home/../etc/passwd"

echo "Dosya silindi!";
?>
Bu saldırıyı önlemek için dikkate alacağınız iki ölçüt vardır.
  • PHP çalıştırılabilirini çalıştıran kullanıcının izinlerini sınırlamak.
  • Form ile gönderilen tüm değişkenleri denetlemek.
Düzeltilmiş betik:

Örnek 3 - Daha güvenilir bir dosya silme betiği

<?php
// PHP kullanıcısının erişebildiği bir dosyayı silelim.
$kullanıcı = $_SERVER['REMOTE_USER']; // kimlik doğrulaması yapıyoruz
$dosya = basename($_POST['kullanıcının_belirttiği_dosyaismi']);
$evdizini  = "/home/$kullanıcı";

$dosyayolu = "$evdizini/$dosya";

if (file_exists($dosyayolu) && unlink($dosyayolu)) {
    $günce = "$dosyayolu silindi\n";
} else {
    $günce = "$dosyayolu silinemedi\n";
}
$dt = fopen("/home/logging/filedelete.log", "a");
fwrite($dt, $günce);
fclose($dt);

echo htmlentities($logstring, ENT_QUOTES);

?>
Ancak, bu bile kusurları örtmeye yetmez. Eğer kimlik doğrulama sisteminiz kullanıcıya kendi ev dizinini belirtmesine izin veriyorsa ve kullanıcı "../etc/" dizinine oturum açmayı istiyorsa sistem hala tehdit altında demektir. Bu nedenle, sınanacak noktaları genişletmelisiniz:

Örnek 4 - Daha da güvenilir bir dosya silme betiği

<?php
$kullanıcı = $_SERVER['REMOTE_USER']; // kimlik doğrulaması yapıyoruz
$dosya = $_POST['kullanıcının_belirttiği_dosyaismi'];
$evdizini  = "/home/$kullanıcı";

$dosyayolu = "$evdizini/$dosya";

if (!ctype_alnum($kullanıcı) ||
    !preg_match('/^(?:[a-z0-9_-]|\.(?!\.))+$/iD', $dosyayolu)) {
        die("Kullanıcı veya dosya ismi hatalı");
}

//vs...
?>

Kullandığınız işletim sistemine bağlı olarak, dikkate alacağınız geniş bir dosya isimleri yelpazesi vardır: aygıt dosyaları (/dev/ veya COM1 gibi), yapılandırma dosyaları (/etc/ ve .ini dosyaları), bildik saklama alanları (/home/, My Documents), vb. Bu nedenle, açıkça izin verilenler dışında kalan herşeyi yasaklamak en kolayıdır.

Session Security
Boş baytlı girdiler
Güvenlik


Boş baytlı girdiler

PHP, dosya sistemi ile ilgili işlemler için kod seviyesinde C işlevlerini kullandığından boş baytlı (\0) dizgeler beklenmedik davranışlara yol açabilir. Boş bayt, C'de dizgeleri sonlandırmak için kullanıldığından boş bayt içeren dizgelerin tamamı değil, boş bayta kadar olan bölüm işleme sokulur. Aşağıdaki örnekte bunun sebep olduğu bir sorun ele alınmıştır:

Örnek 1 - Boş baytlardan olumsuz etkilenen bir betik

<?php
$dosya = $_GET['dosya']; // "../../etc/passwd\0"
if (file_exists('/home/siteler/'.$dosya.'.php')) {
    /* /home/siteler/../../etc/passwd mevcut olduğundan
       file_exists işlevi TRUE döndürür */
    include '/home/siteler/'.$dosya.'.php';
    // /etc/passwd dosyası betiğe dahil edildi
}
?>

Bu bakımdan, bir dosya sistemi işleminde kullanılan her dizge daima denetlenmelidir. Aşağıda, önceki örneğin iyileştirilmişi verilmiştir:

Örnek 2 - Girdiyi doğru şekilde ele almak

<?php
$dosya = $_GET['dosya'];

// Kabul edilebilir değerlerin listesi
switch ($file) {
    case 'main':
    case 'foo':
    case 'bar':
        include '/home/siteler/include/'.$dosya.'.php';
        break;
    default:
        include '/home/siteler/include/main.php';
}
?>
Dosya Sistemi Güvenliği
Database Security
Dosya Sistemi Güvenliği


Database Security

İçindekiler

  • Designing Databases
  • Connecting to Database
  • Encrypted Storage Model
  • SQL Injection

Nowadays, databases are cardinal components of any web based application by enabling websites to provide varying dynamic content. Since very sensitive or secret information can be stored in a database, you should strongly consider protecting your databases.

To retrieve or to store any information you need to connect to the database, send a legitimate query, fetch the result, and close the connection. Nowadays, the commonly used query language in this interaction is the Structured Query Language (SQL). See how an attacker can tamper with an SQL query.

As you can surmise, PHP cannot protect your database by itself. The following sections aim to be an introduction into the very basics of how to access and manipulate databases within PHP scripts.

Keep in mind this simple rule: defense in depth. The more places you take action to increase the protection of your database, the less probability of an attacker succeeding in exposing or abusing any stored information. Good design of the database schema and the application deals with your greatest fears.

Boş baytlı girdiler
Designing Databases
Güvenlik


Designing Databases

The first step is always to create the database, unless you want to use one from a third party. When a database is created, it is assigned to an owner, who executed the creation statement. Usually, only the owner (or a superuser) can do anything with the objects in that database, and in order to allow other users to use it, privileges must be granted.

Applications should never connect to the database as its owner or a superuser, because these users can execute any query at will, for example, modifying the schema (e.g. dropping tables) or deleting its entire content.

You may create different database users for every aspect of your application with very limited rights to database objects. The most required privileges should be granted only, and avoid that the same user can interact with the database in different use cases. This means that if intruders gain access to your database using your applications credentials, they can only effect as many changes as your application can.

You are encouraged not to implement all the business logic in the web application (i.e. your script), instead do it in the database schema using views, triggers or rules. If the system evolves, new ports will be intended to open to the database, and you have to re-implement the logic in each separate database client. Over and above, triggers can be used to transparently and automatically handle fields, which often provides insight when debugging problems with your application or tracing back transactions.

Database Security
Connecting to Database
Database Security


Connecting to Database

You may want to establish the connections over SSL to encrypt client/server communications for increased security, or you can use ssh to encrypt the network connection between clients and the database server. If either of these is used, then monitoring your traffic and gaining information about your database will be difficult for a would-be attacker.

Designing Databases
Encrypted Storage Model
Database Security


Encrypted Storage Model

SSL/SSH protects data travelling from the client to the server: SSL/SSH does not protect persistent data stored in a database. SSL is an on-the-wire protocol.

Once an attacker gains access to your database directly (bypassing the webserver), stored sensitive data may be exposed or misused, unless the information is protected by the database itself. Encrypting the data is a good way to mitigate this threat, but very few databases offer this type of data encryption.

The easiest way to work around this problem is to first create your own encryption package, and then use it from within your PHP scripts. PHP can assist you in this with several extensions, such as Mcrypt and Mhash, covering a wide variety of encryption algorithms. The script encrypts the data before inserting it into the database, and decrypts it when retrieving. See the references for further examples of how encryption works.

Hashing

In the case of truly hidden data, if its raw representation is not needed (i.e. will not be displayed), hashing should be taken into consideration. The well-known example for hashing is storing the cryptographic hash of a password in a database, instead of the password itself.

In PHP 5.5 or newer password functions provide a convenient way to hash sensitive data and work with these hashes. In PHP 5.3.7+ » password_compat library can also be used.

password_hash() is used to hash a given string using the strongest algorithm currently available and password_verify() checks whether the given password matches the hash stored in database.

Örnek 1 Hashing password field

<?php

// storing password hash
$query  = sprintf("INSERT INTO users(name,pwd) VALUES('%s','%s');",
            pg_escape_string($username),
            password_hash($password, PASSWORD_DEFAULT));
$result = pg_query($connection, $query);

// querying if user submitted the right password
$query = sprintf("SELECT pwd FROM users WHERE name='%s';",
            pg_escape_string($username));
$row = pg_fetch_assoc(pg_query($connection, $query));

if ($row && password_verify($password, $row['pwd'])) {
    echo 'Welcome, ' . htmlspecialchars($username) . '!';
} else {
    echo 'Authentication failed for ' . htmlspecialchars($username) . '.';
}

?>

In older versions of PHP this can be achieved using crypt() function.

Örnek 2 Hashing password using crypt()s

<?php

// storing password hash
// $random_chars retrieved e.g. using /dev/random
$query  = sprintf("INSERT INTO users(name,pwd) VALUES('%s','%s');",
            pg_escape_string($username),
            pg_escape_string(crypt($password, '$2a$07$' . $random_chars . '$')));
$result = pg_query($connection, $query);

// querying if user submitted the right password
$query = sprintf("SELECT pwd FROM users WHERE name='%s';",
            pg_escape_string($username));
$row = pg_fetch_assoc(pg_query($connection, $query));

if ($row && crypt($password, $row['pwd']) == $row['pwd']) {
    echo 'Welcome, ' . htmlspecialchars($username) . '!';
} else {
    echo 'Authentication failed for ' . htmlspecialchars($username) . '.';
}

?>
Connecting to Database
SQL Injection
Database Security


SQL Injection

Many web developers are unaware of how SQL queries can be tampered with, and assume that an SQL query is a trusted command. It means that SQL queries are able to circumvent access controls, thereby bypassing standard authentication and authorization checks, and sometimes SQL queries even may allow access to host operating system level commands.

Direct SQL Command Injection is a technique where an attacker creates or alters existing SQL commands to expose hidden data, or to override valuable ones, or even to execute dangerous system level commands on the database host. This is accomplished by the application taking user input and combining it with static parameters to build an SQL query. The following examples are based on true stories, unfortunately.

Owing to the lack of input validation and connecting to the database on behalf of a superuser or the one who can create users, the attacker may create a superuser in your database.

Örnek 1 Splitting the result set into pages ... and making superusers (PostgreSQL)

<?php

$offset = $argv[0]; // beware, no input validation!
$query  = "SELECT id, name FROM products ORDER BY name LIMIT 20 OFFSET $offset;";
$result = pg_query($conn, $query);

?>
Normal users click on the 'next', 'prev' links where the $offset is encoded into the URL. The script expects that the incoming $offset is a decimal number. However, what if someone tries to break in by appending a urlencode()'d form of the following to the URL
0;
insert into pg_shadow(usename,usesysid,usesuper,usecatupd,passwd)
    select 'crack', usesysid, 't','t','crack'
    from pg_shadow where usename='postgres';
--
If it happened, then the script would present a superuser access to him. Note that 0; is to supply a valid offset to the original query and to terminate it.

Bilginize:

It is common technique to force the SQL parser to ignore the rest of the query written by the developer with -- which is the comment sign in SQL.

A feasible way to gain passwords is to circumvent your search result pages. The only thing the attacker needs to do is to see if there are any submitted variables used in SQL statements which are not handled properly. These filters can be set commonly in a preceding form to customize WHERE, ORDER BY, LIMIT and OFFSET clauses in SELECT statements. If your database supports the UNION construct, the attacker may try to append an entire query to the original one to list passwords from an arbitrary table. Using encrypted password fields is strongly encouraged.

Örnek 2 Listing out articles ... and some passwords (any database server)

<?php

$query  = "SELECT id, name, inserted, size FROM products
           WHERE size = '$size'";
$result = odbc_exec($conn, $query);

?>
The static part of the query can be combined with another SELECT statement which reveals all passwords:
'
union select '1', concat(uname||'-'||passwd) as name, '1971-01-01', '0' from usertable;
--
If this query (playing with the ' and --) were assigned to one of the variables used in $query, the query beast awakened.

SQL UPDATE's are also susceptible to attack. These queries are also threatened by chopping and appending an entirely new query to it. But the attacker might fiddle with the SET clause. In this case some schema information must be possessed to manipulate the query successfully. This can be acquired by examining the form variable names, or just simply brute forcing. There are not so many naming conventions for fields storing passwords or usernames.

Örnek 3 From resetting a password ... to gaining more privileges (any database server)

<?php
$query = "UPDATE usertable SET pwd='$pwd' WHERE uid='$uid';";
?>
But a malicious user sumbits the value ' or uid like'%admin% to $uid to change the admin's password, or simply sets $pwd to hehehe', trusted=100, admin='yes to gain more privileges. Then, the query will be twisted:
<?php

// $uid: ' or uid like '%admin%
$query = "UPDATE usertable SET pwd='...' WHERE uid='' or uid like '%admin%';";

// $pwd: hehehe', trusted=100, admin='yes
$query = "UPDATE usertable SET pwd='hehehe', trusted=100, admin='yes' WHERE
...;";

?>

A frightening example how operating system level commands can be accessed on some database hosts.

Örnek 4 Attacking the database hosts operating system (MSSQL Server)

<?php

$query  = "SELECT * FROM products WHERE id LIKE '%$prod%'";
$result = mssql_query($query);

?>
If attacker submits the value a%' exec master..xp_cmdshell 'net user test testpass /ADD' -- to $prod, then the $query will be:
<?php

$query  = "SELECT * FROM products
           WHERE id LIKE '%a%'
           exec master..xp_cmdshell 'net user test testpass /ADD' --%'";
$result = mssql_query($query);

?>
MSSQL Server executes the SQL statements in the batch including a command to add a new user to the local accounts database. If this application were running as sa and the MSSQLSERVER service is running with sufficient privileges, the attacker would now have an account with which to access this machine.

Bilginize:

Some of the examples above is tied to a specific database server. This does not mean that a similar attack is impossible against other products. Your database server may be similarly vulnerable in another manner.

A worked example of the issues regarding SQL Injection
Image courtesy of » xkcd

Avoidance Techniques

While it remains obvious that an attacker must possess at least some knowledge of the database architecture in order to conduct a successful attack, obtaining this information is often very simple. For example, if the database is part of an open source or other publicly-available software package with a default installation, this information is completely open and available. This information may also be divulged by closed-source code - even if it's encoded, obfuscated, or compiled - and even by your very own code through the display of error messages. Other methods include the user of common table and column names. For example, a login form that uses a 'users' table with column names 'id', 'username', and 'password'.

These attacks are mainly based on exploiting the code not being written with security in mind. Never trust any kind of input, especially that which comes from the client side, even though it comes from a select box, a hidden input field or a cookie. The first example shows that such a blameless query can cause disasters.

  • Never connect to the database as a superuser or as the database owner. Use always customized users with very limited privileges.
  • Use prepared statements with bound variables. They are provided by PDO, by MySQLi and by other libraries.
  • Check if the given input has the expected data type. PHP has a wide range of input validating functions, from the simplest ones found in Variable Functions and in Character Type Functions (e.g. is_numeric(), ctype_digit() respectively) and onwards to the Perl compatible Regular Expressions support.

  • If the application waits for numerical input, consider verifying data with ctype_digit(), or silently change its type using settype(), or use its numeric representation by sprintf().

    Örnek 5 A more secure way to compose a query for paging

    <?php

    settype    ($offset, 'integer');
    $query = "SELECT id, name FROM products ORDER BY name LIMIT 20 OFFSET $offset;";

    // please note %d in the format string, using %s would be meaningless
    $query = sprintf("SELECT id, name FROM products ORDER BY name LIMIT 20 OFFSET %d;",
                         $offset);

    ?>

  • If the database layer doesn't support binding variables then quote each non numeric user supplied value that is passed to the database with the database-specific string escape function (e.g. mysql_real_escape_string(), sqlite_escape_string(), etc.). Generic functions like addslashes() are useful only in a very specific environment (e.g. MySQL in a single-byte character set with disabled NO_BACKSLASH_ESCAPES) so it is better to avoid them.
  • Do not print out any database specific information, especially about the schema, by fair means or foul. See also Error Reporting and Error Handling and Logging Functions.
  • You may use stored procedures and previously defined cursors to abstract data access so that users do not directly access tables or views, but this solution has another impacts.

Besides these, you benefit from logging queries either within your script or by the database itself, if it supports logging. Obviously, the logging is unable to prevent any harmful attempt, but it can be helpful to trace back which application has been circumvented. The log is not useful by itself, but through the information it contains. More detail is generally better than less.

Encrypted Storage Model
Error Reporting
Database Security


Error Reporting

With PHP security, there are two sides to error reporting. One is beneficial to increasing security, the other is detrimental.

A standard attack tactic involves profiling a system by feeding it improper data, and checking for the kinds, and contexts, of the errors which are returned. This allows the system cracker to probe for information about the server, to determine possible weaknesses. For example, if an attacker had gleaned information about a page based on a prior form submission, they may attempt to override variables, or modify them:

Örnek 1 Attacking Variables with a custom HTML page

<form method="post" action="attacktarget?username=badfoo&amp;password=badfoo">
<input type="hidden" name="username" value="badfoo" />
<input type="hidden" name="password" value="badfoo" />
</form>

The PHP errors which are normally returned can be quite helpful to a developer who is trying to debug a script, indicating such things as the function or file that failed, the PHP file it failed in, and the line number which the failure occurred in. This is all information that can be exploited. It is not uncommon for a php developer to use show_source(), highlight_string(), or highlight_file() as a debugging measure, but in a live site, this can expose hidden variables, unchecked syntax, and other dangerous information. Especially dangerous is running code from known sources with built-in debugging handlers, or using common debugging techniques. If the attacker can determine what general technique you are using, they may try to brute-force a page, by sending various common debugging strings:

Örnek 2 Exploiting common debugging variables

<form method="post" action="attacktarget?errors=Y&amp;showerrors=1&amp;debug=1">
<input type="hidden" name="errors" value="Y" />
<input type="hidden" name="showerrors" value="1" />
<input type="hidden" name="debug" value="1" />
</form>

Regardless of the method of error handling, the ability to probe a system for errors leads to providing an attacker with more information.

For example, the very style of a generic PHP error indicates a system is running PHP. If the attacker was looking at an .html page, and wanted to probe for the back-end (to look for known weaknesses in the system), by feeding it the wrong data they may be able to determine that a system was built with PHP.

A function error can indicate whether a system may be running a specific database engine, or give clues as to how a web page or programmed or designed. This allows for deeper investigation into open database ports, or to look for specific bugs or weaknesses in a web page. By feeding different pieces of bad data, for example, an attacker can determine the order of authentication in a script, (from the line number errors) as well as probe for exploits that may be exploited in different locations in the script.

A filesystem or general PHP error can indicate what permissions the web server has, as well as the structure and organization of files on the web server. Developer written error code can aggravate this problem, leading to easy exploitation of formerly "hidden" information.

There are three major solutions to this issue. The first is to scrutinize all functions, and attempt to compensate for the bulk of the errors. The second is to disable error reporting entirely on the running code. The third is to use PHP's custom error handling functions to create your own error handler. Depending on your security policy, you may find all three to be applicable to your situation.

One way of catching this issue ahead of time is to make use of PHP's own error_reporting(), to help you secure your code and find variable usage that may be dangerous. By testing your code, prior to deployment, with E_ALL, you can quickly find areas where your variables may be open to poisoning or modification in other ways. Once you are ready for deployment, you should either disable error reporting completely by setting error_reporting() to 0, or turn off the error display using the php.ini option display_errors, to insulate your code from probing. If you choose to do the latter, you should also define the path to your log file using the error_log ini directive, and turn log_errors on.

Örnek 3 Finding dangerous variables with E_ALL

<?php
if ($username) {  // Not initialized or checked before usage
    $good_login = 1;
}
if ($good_login == 1) { // If above test fails, not initialized or checked before usage
    readfile ("/highly/sensitive/data/index.html");
}
?>

SQL Injection
register_globals Kullanımı
Güvenlik


register_globals Kullanımı

Uyarı

Bu özelliğin kullanımı PHP 5.3.0 itibariyle ÖNERİLMEMEKTE olup PHP 5.4.0'da tamamen KALDIRILMIŞTIR.

PHP'deki belki de en tartışmalı değişiklik, register_globals PHP yönergesinin öntanımlı değerinin PHP » 4.2.0'da On iken Off yapılmasıdır. Bu yönerge üzerindeki geçmiş deneyimlere dayanmak oldukça yaygındı ve çoğu kişi yönergenin varlığını bile bilmediği gibi PHP'nin böyle çalıştığını varsayardı. Bu sayfada, bu yönerge ile yazılan kodun nasıl güvensiz olabileceği gösterilecek, fakat güvensizliğin yönergenin kendisinden ziyade nasıl yanlış kullanımından kaynaklandığı açıklanacaktır.

register_globals On iken, HTML formlarındaki istek değişkenleri gibi bir takım değişkenler betiğinize dahil edilir. PHP'nin değişken ilklendirme gerektirmeme olgusu güvensiz kod yazımını daha da kolaylaştırır. Zor bir karar olmasına rağmen PHP topluluğu bu yönergeyi öntanımlı olarak iptal etmeyi uygun gördü. Yönergenin değeri On iken, kullanıcılar, değişkenleri, aslında ne olup bittiğini bilmeden sadece varsayımla kullanırdı. Betiğin kendisi tarafından tanımlanmış dahili değişkenler kullanıcı tarafından gönderilen istek verileri ile karışırdı. register_globals Off yapılınca bu değişti. Yönergenin yanlış kullanımını bir örnekle açıklamaya çalışalım:

Örnek 1 - register_globals = on ile yanlış kullanım örneği

<?php
// Sadece kullanıcı kimliği doğrulanıyorsa $yetkili = true olmalı
if (authenticated_user()) {
    $yetkili = true;
}

// $yetkili değişkenini başta false ile ilklendirmediğimizden
// bu atama GET auth.php?yetkili=1 şeklinde register_globals
// üzerinden yapılmış olabilir. Dolayısıyla, kullanıcı kendini
// yetkiliymiş gibi gösterebilir!
if ($yetkili) {
    include "/gayet/hassas/veriler.php";
}
?>

register_globals = on iken yukarıda yürüttüğümüz mantık zarar görebilir. register_globals = off olduğunda, $yetkili değişkenine istek üzerinden değer atanamayacağından bir açık söz konunu olmayacaktır. Aslında değişkenleri baştan ilklendirmek iyi bir programcılık alışkanlığıdır. Yukarıdaki örnekte baştan $yetkili = false yapabilirdik. Bu ilklendirme yapılmış olsaydı, kullanıcı öntanımlı olarak yetkisiz olacağından register_globals yönergesinin değerinin ne olduğunun bir önemi olmayacaktı.

Diğer bir örnek oturumlarla ilgilidir. register_globals = on iken, aşağıdaki örnekte $kullanici değişkenini de kullanabilirdik, fakat tekrar hatırlatmakta yarar var: $kullanici, GET gibi başka bir kaynaktan da (örn, URL üzerinden) gelebilirdi.

Örnek 2 - register_globals On veya Off iken oturum örneği

<?php
// $kullanici'nin nereden geleceğini bilemezdik
// Fakat oturum verisi için $_SESSION kullanınca biliriz
if (isset($_SESSION['kullanici'])) {

    echo "Merhaba <b>{$_SESSION['kullanici']}</b>";

} else {

    echo "Merhaba <b>Ziyaretçi</b><br />";
    echo "Oturum açmak ister misiniz?";

}
?>

Sahtecilik yapılmaya çalışıldığında uyaracak önleyici tedbirler almak da mümkündür. Bir değişken vaktinden önce geliyorsa, gönderilen verinin ilgisiz bir teslimat çeşidinden gelip gelmediğini sınayabilirsiniz. Verinin sahte olmadığını garanti etmese de saldırganın yaptığı sahtecilik türünün tahmin edilmesi gerekir. İstek verisinin geldiği yeri önemsemiyorsanız, GET, POST ve COOKIE verilerinin bir karışımını içeren $_REQUEST dizisini kullanabilirsiniz. Ayrıca, Dış Kaynaklı Değişkenler bölümüne de bakınız.

Örnek 3 - Basit değişken sahteciliğinin saptanması

<?php
if (isset($_COOKIE['MAGIC_COOKIE'])) {

    // MAGIC_COOKIE bir çerezden gelir.
    // Çerez verisini doğrulamayı unutmayın!

} elseif (isset($_GET['MAGIC_COOKIE']) || isset($_POST['MAGIC_COOKIE'])) {

   mail("admin@example.com", "Olası kırma çabası", $_SERVER['REMOTE_ADDR']);
   echo "Güvenlik ihlali; yönetici uyarıldı.";
   exit;

} else {

   // MAGIC_COOKIE bu istek (REQUEST) üzerinden atanmamış.

}
?>

Şüphesiz, tek başına register_globals = off, kodunuzun güvenli olduğu anlamına gelmez. Gönderilen her veri parçası başka yollarla da ayrıca sınanmalıdır. Kullanıcı verinizi daima doğrulayın ve değişkenlerinizi daima ilklendirin! İlklendirilmemiş değişkenleri görmek için error_reporting() işlevi ile E_NOTICE seviyesinden hataların gösterilmesini sağlamalısınız.

register_globals'in On veya Off olmasının taklit edilmesi hakkında bilgi edinmek için SSS'deki register_globals ile nasıl çalışacağım? sorusuna bakınız.

Error Reporting
Kullanıcıdan Gelen Bilgi
Güvenlik


Kullanıcıdan Gelen Bilgi

PHP de yazılmış bir uygulamanın en zayıf noktası, dilin kendisinde olan bir sorun değil, yazılan uygulamanın bazı varsayımlara dayanarak güvenliği göz önünde bulundurmamasıdır. Bundan dolayı bir uygulama yazarken güvenliğe önem vermeli ve kullanıcıdan gelen bilginin varsayıma dayanmadan denetlenmesini sağlamasınız.

Örnek 1 - Tehlikeli Değişken Kullanımı

<?php
// kullanıcının ev dizininden bir dosyayı silelim...
// acaba başka birininkini mi silecek?
unlink ($fena_veri);

// Girişle ilgili kayıt tutalım...
// acaba /etc/passwd dosyasına mı yazacak?
fwrite ($fp, $fena_veri);

// Denemek için birşeyler çalıştıralım...
// acaba tüm dosyaları silecek bir 'rm -rf' komutu mu?
exec ($fena_veri);

?>

Kod yazarken her zaman yazdıklarınızı dikkatlice inceleyip, kullanıcıdan gelen bilgilerin doğru ve tam şekilde denetlenip onaylandığına emin olmanız gerekir. Kullanıcıdan gelen bilgiyi alıp işleme koyduğunuz her durumda kendinize şu soruları sorabilirsiniz:

  • Bu betik benim istemediğim dosyalara erişim, değişiklik veya silme imkanı veriyor mu?
  • Beklenmeyen bir bilgi geldiğinde de istenilen işlem yapılacak mı?
  • Bu betik başka bir amaç için kullanılabilir mi?
  • Bu betik sistemde varolan başka betiklerle birlikte kötü amaçlı kullanılabilir mi?
  • Yapılan işlemler daha sonra inceleme amacıyla kayda alınacak mı?

Yaptığınız projenin uygunluğuna göre kod yazmadan önce ve yazarken bu soruları sık sık kendinize sormanız, proje bittiğinde değerlendirme yapıp değişiklikler yapmanızdan çok daha faydalı olacaktır. Bu sayede proje tasarımını güvenlik düşünülerek yapmış olacak ve daha sonra güvenlik dolayısıyla ciddi değişiklikler yapma zorunluluğunuz ortadan kalkacaktır. Güvenliğe vereceğiniz öncelikli önem, daha sonra yapacağınız ve güvenliği riske atacak değişikliklerden çok daha faydalıdır.

Belirtilen bir değişkenin değerini, kaynağı veya geçerliliği bozacağını düşündüğünüz register_globals, magic_quotes ve benzeri ayarlarları kapatmanız iyi olabilir. Hata bildirim kipi 'error_reporting(E_ALL)' kullanımı, aynı zamanda uyarıları da göstereceği için kodunuzda sorun olup olmadığı hakkında daha iyi bilgi verebilir.

register_globals Kullanımı
Sihirli Tırnak
Güvenlik


Sihirli Tırnak

İçindekiler

  • Sihirli Tırnaklar nedir?
  • Sihirli Tırnaklar Neden Kullanılır?
  • Sihirli Tırnaklar Neden Kullanılmamalıdır?
  • Sihirli Tırnakların İptali
Uyarı

Bu özelliğin kullanımı PHP 5.3.0'dan beri ÖNERİLMEMEKTEDİR ve PHP 6.0.0'da tamamen KALDIRILMIŞTIR. Bu özelliğe kesinlikle güvenmemelisiniz.

Sihirli Tırnaklar, PHP betiklerine gelen veriyi sihirli bir şekilde önceleyen bir işlemdir. Kodlamayı sihirli tırnakları kullanmadan yapıp bu işlemi çalışma anına bırakmak gerektiğinde de tercih edilebilir.

Kullanıcıdan Gelen Bilgi
Sihirli Tırnaklar nedir?
Güvenlik


Sihirli Tırnaklar nedir?

Uyarı

Bu özelliğin kullanımı PHP 5.3.0'dan beri ÖNERİLMEMEKTEDİR ve PHP 6.0.0'da tamamen KALDIRILMIŞTIR. Bu özelliğe kesinlikle güvenmemelisiniz.

Etkin olduğunda, ' (tek tırnak), " (çift tırnak), \ (tersbölü) ve NULL karakterlerinin önüne özdevinimli olarak bir tersbölü imi getirilir. Bu işlem addslashes() işlevinin yaptığı işle aynıdır.

Toplam üç adet sihirli tırnak yönergesi vardır:

  • magic_quotes_gpc HTTP istek verisini (GET, POST ve COOKIE) etkiler. Çalışma anında ayarlanamaz ve öntanımlı değeri on'dur. Ayrıca bakınız: get_magic_quotes_gpc().
  • magic_quotes_runtime Etkin olduğunda, veritabanları ve metin dosyaları dahil, bir dış kaynaktan veri döndüren çoğu işlev veriyi tersbölü imiyle önceleyecektir. Çalışma anında ayarlanabilir ve öntanımlı değeri off yani kapalıdır. Ayrıca bakınız: set_magic_quotes_runtime() ve get_magic_quotes_runtime().
  • magic_quotes_sybase Etkin olduğunda tek tırnak karakterini öncelerken tersbölü değil yine bir tek tırnak kullanılır. Değeri on olduğunda, magic_quotes_gpc ayarını geçersiz kılar. Yani her iki yönerge de etkin olduğunda tek tırnaklar '' biçeminde öncelenir. Çift tırnaklar, tersbölüler ve NULL'lar öncelenmeden bırakılır. Ayrıca bir yönergenin değerinin alınması ile ilgili olarak ini_get() işlevine de bakınız.
Sihirli Tırnak
Sihirli Tırnaklar Neden Kullanılır?
Sihirli Tırnak


Sihirli Tırnaklar Neden Kullanılır?

Uyarı

Bu özelliğin kullanımı PHP 5.3.0'dan beri ÖNERİLMEMEKTEDİR ve PHP 6.0.0'da tamamen KALDIRILMIŞTIR. Bu özelliğe kesinlikle güvenmemelisiniz.

  • Sihirli tırnaklar, PHP'nin artık desteklenmeyen bir parçası olduğundan artık kullanmamak gerekir. Bununla birlikte, yeni kod yazmaya başlayanlardan kaynaklanan tehlikeleri bertaraf etmeye yardımcı olması için hala tutulmaktadır. Fakat böyle kodları olduğu gibi kullanmak ve sihirli tırnakları etkin kılmak yerine bu kodları sihirli tırnaklardan arındırmak daha yararlıdır.
  • O halde bu özellik niye hala var? Yanıt basit, SQL Enjeksiyon riskini ortadan kaldırmak için. Günümüz geliştiricileri, güvenlik konusunda daha bilgilidirler ve sihirli tırnaklara ödün vermek yerine hazır deyimleri ve/veya veritabanlarına özgü önceleme mekanizmalarını kullanmaktadırlar.
Sihirli Tırnaklar nedir?
Sihirli Tırnaklar Neden Kullanılmamalıdır?
Sihirli Tırnak


Sihirli Tırnaklar Neden Kullanılmamalıdır?

Uyarı

Bu özelliğin kullanımı PHP 5.3.0'dan beri ÖNERİLMEMEKTEDİR ve PHP 6.0.0'da tamamen KALDIRILMIŞTIR. Bu özelliğe kesinlikle güvenmemelisiniz.

  • Taşınabilirlik. Bu özelliğin açık veya kapalı olmasının taşınabilirliği etkilediği varsayılır. Böyle bir durumun varlığını get_magic_quotes_gpc() ile denetledikten sonra kodlamayı buna uygun yapın.
  • Başarım. Bir veritabanına yerleştirilen her veri parçası öncelenmediğinden, tüm bu verinin öncelenmeye çalışılması başarım kaybına sebep olur. Bu bakımdan (addslashes() gibi) önceleme işlevlerinin çalışma anında çağrılması daha verimli olur. php.ini-development bu yönergeleri öntanımlı olarak etkin kılsa da php.ini-production bunu etkisiz kılar. İkincisinin sebebi tamamen başarım ile ilgilidir.
  • Elverişsizlik. Tüm verinin öncelenmesi gerekmediğinden, gerekmediği halde verinin öncelenmiş olduğunu görmek çoğunlukla can sıkıcıdır. Örneğin bir formdan gönderilen epostada bir sürü \' görmek. Bu durumu düzeltmek için aşırı miktarda stripslashes() işlevi kullanmak gerekebilir.
Sihirli Tırnaklar Neden Kullanılır?
Sihirli Tırnakların İptali
Sihirli Tırnak


Sihirli Tırnakların İptali

magic_quotes_gpc yönergesi sadece sistem seviyesinde etkisiz kılınabilir, çalışma anında yapılamaz. Başka bir deyişle, ini_set() işlevi bir seçenek değildir.

Örnek 1 - Sihirli tırnakların sunucu taraflı iptali

Aşağıdaki örnekte php.ini içinde bu yönergelere değer olarak Off atanmaktadır. Bu konuda daha ayrıntılı bilgi edinmek için Yapılandırma ayarlarının değiştirilmesi bölümüne bakınız.

; Sihirli tırnakların iptali
;

; Gelen GET/POST/Cookie verisi için sihirli tırnaklar
magic_quotes_gpc = Off

; Çalışma anında üretilen (SQL veya exec() kaynaklı) veri için
magic_quotes_runtime = Off

; Sybase-tarzı sihirli tırnak kullanımı (' yerine \' değil '').
magic_quotes_sybase = Off

Eğer sunucuda yapılandırma dosyasına erişim ve değişiklik mümkün değilse, .htaccess kullanmak da bir seçenektir. Örnek:

php_flag magic_quotes_gpc Off

Taşınabilir kod (her ortamda çalışan kod) yazmaya yönelik olarak, ayarların sunucu seviyesinde değiştirilmesi mümkün değilse magic_quotes_gpc yönergesi örnekteki gibi çalışma anında etkisiz kılınabilir. Bu yol fevkalade verimsizdir ancak uygun yönergeleri başka bir yerden atamaya tercih edilir.

Örnek 2 - Sihirli tırnakların çalışma anında iptali

<?php
if (get_magic_quotes_gpc()) {
    $process = array(&$_GET, &$_POST, &$_COOKIE, &$_REQUEST);
    while (list($key, $val) = each($process)) {
        foreach ($val as $k => $v) {
            unset($process[$key][$k]);
            if (is_array($v)) {
                $process[$key][stripslashes($k)] = $v;
                $process[] = &$process[$key][stripslashes($k)];
            } else {
                $process[$key][stripslashes($k)] = stripslashes($v);
            }
        }
}
    unset($process);
?>

Sihirli Tırnaklar Neden Kullanılmamalıdır?
PHP'yi gizlemek
Sihirli Tırnak


PHP'yi gizlemek

Bazı şeyleri gizleyerek güvenlik sağlama girişimleri en alt düzeydeki çabalardır. Ancak bazı durumlarda en küçük güvenlik arttırıcı önlem bile yararlı olabilir.

Bir kaç basit teknikle PHP'yi gizleyebilir, sisteminizin zayıflıklarını keşfetmeye çalışan bir saldırganı belki de yavaşlatabilirsiniz. php.ini dosyanızda expose_php = off yaparak bir saldırganın erişebileceği bilgiyi en aza indirebilirsiniz.

Başka bir yol da HTTP sunucusuna PHP kodu olarak başka dosya uzantıları belirtmektir. Bu işlem Apache yapılandırma dosyasında veya .htaccess dosyalarında yapılabilir. Yanıltıcı dosya uzantılarını şöyle kullanabilirsiniz:

Örnek 1 - PHP'yi başka bir dil olarak göstermek

# PHP kodlarını başka bir dilin kodları gibi gösterelim
AddType application/x-httpd-php .asp .py .pl
Veya tamamen gizleyelim:

Örnek 2 - PHP uzantısı olarak bilinmeyen bir uzantı kullanmak

# PHP kodunu türü bilinmeyen bir dosya gibi gösterelim
AddType application/x-httpd-php .hop .yep
Ya da HTML kodu gibi gösterek gizleyelim. Ancak tüm HTML dosyalarını PHP işleyeceği için bu bir miktar başarım kaybına sebep olur:

Örnek 3 - PHP uzantısı olarak HTML uzantılarını kullanmak

# Tüm PHP kodu HTML kodu gibi görünsün
AddType application/x-httpd-php .htm .html
Bunun verimli çalışması için tüm PHP dosyalarınızın uzantılarını yukardaki uzantılarla değiştirmeniz gerekir. Dosya adı değiştirme zorunluluğu için bu alt düzey güvenlik önleminin size çıkardığı bir zorluktur diyebiliriz.

Sihirli Tırnakların İptali
Güncel Tutmak
Güvenlik


Güncel Tutmak

PHP, diğer büyük sistemler gibi devamlı ilerlemeler ve yenilikler içermektedir. Her yeni sürümde sistemin güvenliğini ve kararlılığını etkileyen yapılandırma kazalarını ve diğer açıkları kapatmak veya güvenliği arttırmak amacıyla mutlaka büyük ya da küçük değişiklikler ortaya çıkmaktadır.

Yapılması gereken en akılcı yaklaşım, benzeri diğer sistem secviyesinde betik dilleri ve programlarında olduğu gibi, sık sık güncellemeleri takip etmek ve kullanılan sürüme göre daha yeni bir sürüme geçiş yapmak olmalıdır.

PHP'yi gizlemek
Özellikler
Güvenlik


Özellikler

  • PHP ile HTTP Kimlik Doğrulaması
  • Çerezler
  • Oturumlar
  • XForms ile çalışmak
  • Karşıya dosya yükleme
    • POST yöntemi ile karşıya dosya yükleme
    • Hata İletilerinin Açıklamaları
    • Bilinen zorluklar
    • Çoklu dosya yükleme
    • PUT yöntemi desteği
  • Uzak dosyaların kullanımı
  • Bağlantı yönetimi
  • Kalıcı Bağlantılı Veritabanı Bağlantıları
  • Güvenli Kip
    • Güvenlik ve Güvenli Kip
    • Güvenli kipte yasaklı/kısıtlı işlevler
  • Komut satırından kullanım — PHP'nin komut satırından kullanımı
    • Giriş
    • Diğer SAPI'lerden dikkate değer farklılıklar
    • Seçenekler — Komut satırı seçenekleri
    • Kullanım — PHP dosyalarının çalıştırılması
    • G/Ç Akımları — Giriş/Çıkış Akımları
    • Etkileşimli kabuk
    • Yerleşik HTTP sunucusu
    • INI Ayarları
  • Garbage Collection
    • Reference Counting Basics
    • Collecting Cycles
    • Performance Considerations
  • DTrace Dynamic Tracing
    • Introduction to PHP and DTrace
    • Using PHP and DTrace
    • Using SystemTap with PHP DTrace Static Probes
Güncel Tutmak
PHP ile HTTP Kimlik Doğrulaması
PHP Kılavuzu


PHP ile HTTP Kimlik Doğrulaması

header() işlevi kullanılarak istemci tarayıcısına "Kimlik Doğrulaması Gerekli" ("Authentication Required") iletisini göndererilir ve bunun sonucunda Kullanıcı Adı/Parola giriş penceresi açılır. Kullanıcı kullanıcı adı ve parolasını girdiğinde, PHP betiğini içeren URL, kullanıcı adı, parola ve kimlik doğrulama türünü atayan PHP_AUTH_USER, PHP_AUTH_PW ve AUTH_TYPE öntanımlı değişkenleri ile tekrar çağrılır. Bu öntanımlı değişkenler $_SERVER dizileri içinde bulunur. "Temel" ve "Özet" (PHP 5.1.0'dan itibaren) kimlik doğrulama yöntemlerinin ikisi de desteklenir. Daha fazla bilgi için header() işlevine bakınız.

İstemci sayfasını kimlik doğrulamaya zorlayacak örnek betik aşağıdaki gibidir:

Örnek 1 - Temel HTTP Kimlik Doğrulaması örneği

<?php
if (!isset($_SERVER['PHP_AUTH_USER'])) {
    header('WWW-Authenticate: Basic realm="Benim bölgem"');
    header('HTTP/1.0 401 Unauthorized');
    echo 'Kullanıcı İptal düğmesine basınca çıkacak metin';
    exit;
} else {
    echo "<p>Merhaba {$_SERVER['PHP_AUTH_USER']}.</p>";
    echo "<p>Parola olarak {$_SERVER['PHP_AUTH_PW']} verdiniz.</p>";
}
?>

Örnek 2 - Özet HTTP Kimlik Doğrulaması örneği

Bu örnek basit bir Özet HTTP kimlik doğrulama betiğinin nasıl uygulanacağını gösterir. Daha fazla bilgi için » RFC 2617 belgesini okuyunuz.

<?php
$saha = 'Kısıtlanmış alan';

// kullanici => parola
$kullanicilar = array('yonetici' => 'gizlisifre', 'misafir' => 'misafir');

if (empty($_SERVER['PHP_AUTH_DIGEST'])) {
    header('HTTP/1.1 401 Unauthorized');
    header('WWW-Authenticate: Digest realm="'.$saha.
           '",qop="auth",nonce="'.uniqid().'",opaque="'.md5($saha).'"');

    die('Kullanıcı İptal düğmesine basınca çıkacak metin');
}

// PHP_AUTH_DIGEST değişkenini inceleyelim
if (!($veri = http_ozet_cozumle($_SERVER['PHP_AUTH_DIGEST'])) ||
    !isset($kullanicilar[$veri['username']]))
    die('Kimlik Doğrulama Hatası!');

// geçerli yanıt üretimi
$A1 = md5($veri['username'] . ':' . $saha . ':' .
      $kullanicilar[$veri['username']]);
$A2 = md5($_SERVER['REQUEST_METHOD'].':'.$veri['uri']);
$gecerli_yanit = md5($A1.':'.$veri['nonce'].':'.$veri['nc'].':'.
      $veri['cnonce'].':'.$veri['qop'].':'.$A2);

if ($veri['response'] != $gecerli_yanit)
    die('Kimlik Doğrulama Hatası!');

// tamam, geçerli kullanıcı adı & parolası
echo 'Hoşgeldiniz : ' . $veri['username'];

// http kimlik doğrulama başlığını çözümleyecek işlev
function http_ozet_cozumle($metin)
{
    // eksik veriye karşı koruma
    $gerekli_kisimlar = array('nonce'=>1, 'nc'=>1, 'cnonce'=>1, 'qop'=>1,
                              'username'=>1, 'uri'=>1, 'response'=>1);
    $veri = array();
    $keys = implode('|', array_keys($gerekli_kisimlar));

    preg_match_all('@(' . $keys . ')=(?:([\'"])([^\2]+?)\2|([^\s,]+))@',
                    $metin, $eslesen, PREG_SET_ORDER);

    foreach ($eslesen as $m) {
        $veri[$m[1]] = $m[3] ? $m[3] : $m[4];
        unset($gerekli_kisimlar[$m[1]]);
    }

    return $gerekli_kisimlar ? false : $veri;
}
?>

Bilginize: Uyumluluk Bilgisi

Lütfen HTTP başlık satırlarını kodlarken dikkatli olun. Bütün istemcilerle uyumluluğu garantilemek için, "Basic" anahtar sözcüğünün "B" harfi büyük yazılmalı, realm metni çift tırnak (tek tırnak değil) ile yazılmalı, ve HTTP/1.0 401 başlık satırındaki 401 kodundan önce tam olarak bir adet boşluk olmalıdır. Yukarıdaki özet örneğinde olduğu gibi kimlik doğrulama değiştirgeleri virgülle ayrılmış olmalıdır.

Yukarıdaki örnekte yapıldığı gibi sadece PHP_AUTH_USER ve PHP_AUTH_PW yazdırmak yerine, kullanıcı adı ve parolasının doğruluğunu denetlemek isteyebilirsiniz. Bunun için belki bir veritabanı sorgusu gönderebilir veya kullanıcıyı bir dbm dosyası içinde arayabilirsiniz.

Burada hatalı Internet Explorer tarayıcılarına dikkat ediniz. Başlıkların sırası konusunda çok seçici görünürler. WWW-Authenticate başlığını HTTP/1.0 401 başlığından önce göndermek hileye neden olabilir.

Geleneksel harici kimlik doğrulama yönteminden geçmiş bir sayfa için girilmiş parolayı gösteren bir betik yazılmasını engellemek için, harici kimlik doğrulaması yapılan sayfa için güvenli kip (safe_mode) etkinleştirilir, böylece PHP_AUTH değişkenlerine değer atanmaz. Harici kimlik doğrulaması yapılan kullanıcıyı kimliklendirmek için REMOTE_USER değişkeni $_SERVER['REMOTE_USER'] olarak kullanılabilir.

Bilginize: Yapılandırma Bilgisi

PHP harici kimlik doğrulamasının etkin olup olmadığnı tespit etmek için AuthType yönergesininin varlığını bakar.

Yukarıdaki örnek, aynı sunucudaki kimlik doğrulamalı URL'lerden girilen parolaları çalmak için kimlik doğrulamasız bir URL'yi kullanmak isteyenleri önlemez.

Hem Netscape Navigator hem de Internet Explorer, 401 sunucu yanıtını almak için yerel tarayıcı penceresinin kimlik doğrulama önbelleğini temizler. Bu işlem, kullanıcıları tekrar kullanıcı adı ve parolasını girmeye zorlayacak şekilde "oturumu kapatır". Bazıları bunu "zaman aşımlı" kullanıcı girişi için kullanırlar veya bir "Çıkış" düğmesi sunarlar.

Örnek 3 - Yeni kullanıcı adı va parolası girmeye zorlayan bir HTTP kimlik doğrulama örneği

<?php
function authenticate() {
    header('WWW-Authenticate: Basic realm="Kimlik Doğrulaması Deneme Sistemi"');
    header('HTTP/1.0 401 Unauthorized');
    echo "Bu kaynağa erişmek için geçerli bir kullanıcı adı ve " .
         "parolası girmelisiniz.\n";
    exit;
}

if (!isset($_SERVER['PHP_AUTH_USER']) ||
    ($_POST['SeenBefore'] == 1 && $_POST['OldAuth'] == $_SERVER['PHP_AUTH_USER'])) {
    authenticate();
} else {
    echo "<p>Merhaba: " . htmlspecialchars($_SERVER['PHP_AUTH_USER']) . "<br />";
    echo "Eski: " . htmlspecialchars($_REQUEST['OldAuth']);
    echo "<form action='' method='post'>\n";
    echo "<input type='hidden' name='SeenBefore' value='1' />\n";
    echo "<input type='hidden' name='OldAuth' value='{$_SERVER['PHP_AUTH_USER']}' />\n";
    echo "<input type='submit' value='Kimliği Yeniden Doğrula />\n";
    echo "</form></p>\n";
}
?>

Bu davranış şekli HTTP Temel kimlik doğrulama standardı için gerekli değildir, bu nedenle buna güvenmemelisiniz. Lynx ile denendiğinde Lynx'in kimlik doğrulama kartlarını 401 sunucu yanıtı ile temizlemediğini göstermiştir, bu nedenle kimlik bilgisi değişmediği sürece geri ve ileri düğmesine basmak aynı kaynağı açacaktır. Kullanıcı '_' tuşu ile kimlik doğrulama bilgisini temizleyebilir.

HTTP kimlik doğrulamasının çalışması için IIS yapılandırmasındaki "Dizin Güvenliği"ni değiştirmelisiniz. "Düzenle"ye basınız ve sadece "Anonim Erişim"leri seçiniz, diğer bütün sahalar seçimsiz olmalıdır.

Bilginize: IIS Bilgisi:
HTTP kimlik doğrulamasının IIS ile çalışması için, PHP yönergesi cgi.rfc2616_headers değeri 0 olmaldır (öntanımlı değer).

Bilginize:

Eğer güvenli kip etkinse, betiğin kullanıcı kimliği değeri WWW-Authenticate başlığının realm kısmına eklenir.

Özellikler
Çerezler
Özellikler


Çerezler

PHP HTTP çerezlerini şeffaf olarak destekler. Çerezler, uzak tarayıcıda veri saklamayı ve böylece geri dönen kullanıcılar hakkında veri takibi yapmayı sağlar. Çerezleri, setcookie() ya da setrawcookie() işlevleri ile atayabilirsiniz. Çerezler, HTTP başlığının birer parçasıdır, bu yüzden tarayıcıya bir veri göndermeden önce setcookie() işlevini çağırmalısınız. Aynı kısıtlama header() işlevi için de vardır. çıktı tamponlama işlevlerini kullanarak betik çıktısını, herhangi bir başlık ya da çerez atayıp atamayacağınıza karar verene kadar geciktirebilirsiniz.

İstemci tarafından size gönderilen herhangi bir çerez, variables_order yönergesi "C" değerini içeriyorsa $_COOKIE süper küresel dizisine atanır. Eğer tek bir çereze, birden fazla değer atamak isterseniz, çerez ismine [] eklemeniz yeterli olacaktır.

register_globals yönergesinin değerine bağlı olarak, normal PHP değişkenleri çerezler tarafından oluşturulabilir. Ancak, çoğu zaman güvenlik dolayısıyla bu özellik kapalı olduğundan bunların kullanımı önerilmemektedir.

Tarayıcı hataları dahil, daha fazla bilgi edinmek için setcookie() ve setrawcookie() işlevlerine bakınız.

PHP ile HTTP Kimlik Doğrulaması
Oturumlar
Özellikler


Oturumlar

PHP'de oturum desteği belirli bir veriyi birbirini izleyen erişimler arasında korumak üzere bulunur. Bu size daha özelleştirilmiş uygulamalar yapma ve sitenizin cazibesini artırma imkanı verir. Bu konuyla ilgili bütün bilgi Oturum kılavuzu bölümündedir.

Çerezler
XForms ile çalışmak
Özellikler


XForms ile çalışmak

» XForms geleneksel HTML formları üzerinde bir çeşitleme tanımlayarak, formların daha çeşitli platformlarda, tarayıcılarda ve hatta PDF belgeleri gibi geleneksel olmayan ortamlarda kullanılmasına imkan verir.

XForms'daki ilk önemli fark formun istemciye nasıl gönderildiğidir. » HTML Yazarları için XForms XForms yaratılışıyla ilgili ayrıntılı açıklama içerir, bu öğreticinin amacı için aşağıdaki basit örneğe bakınız:

Örnek 1 - Basit bir XForms arama formu

<h:html xmlns:h="http://www.w3.org/1999/xhtml"
        xmlns="http://www.w3.org/2002/xforms">
<h:head>
 <h:title>Arama</h:title>
 <model>
  <submission action="http://ornek.dom/arama"
              method="post" id="s"/>
 </model>
</h:head>
<h:body>
 <h:p>
  <input ref="q"><label>Bul</label></input>
  <submit submission="s"><label>Gönder</label></submit>
 </h:p>
</h:body>
</h:html>

Yukarıdaki form (q isimli) bir metin kutusu ve gönder düğmesi gösterir. Gönder düğmesine tıklandığında, form action ile gösterilen sayfaya gönderilir.

Normal bir HTML formunda, veri application/x-www-form-urlencoded olarak gönderilir, XForms'da ise bu bilgi XML biçimli veri olarak gönderilir.

Eğer XForms ile çalışmayı seçerseniz muhtemelen bu verinin XML olmasını istiyorsunuz demektir, bu durumda, $HTTP_RAW_POST_DATA içine bakınız, orada tarayıcı tarafından üretilen XML belgesini bulacaksınız; bunu istediğiniz XSLT motoruna veya belge çözümleyiciye aktarabilirsiniz.

Eğer biçimlendirmeyle ilgilenmiyorsanız ve sadece verinizin geleneksel $_POST değişkenine yüklenmesini istiyorsanız, method özelliğini urlencoded-post olarak değiştirebilir ve istemci tarayacıya veriyi application/x-www-form-urlencoded olarak gönderme talimatı verebilirsiniz.

Örnek 2 - $_POST elde etmek için bir XFrom kullanımı

<h:html xmlns:h="http://www.w3.org/1999/xhtml"
        xmlns="http://www.w3.org/2002/xforms">
<h:head>
 <h:title>Ara</h:title>
 <model>
  <submission action="http://ornek.dom/arama"
              method="urlencoded-post" id="s"/>
 </model>
</h:head>
<h:body>
 <h:p>
  <input ref="q"><label>Bul</label></input>
  <submit submission="s"><label>Gönder</label></submit>
 </h:p>
</h:body>
</h:html>

Bilginize: Bu belge yazılırken birçok tarayıcı XForms'u destemiyordu. Eğer yukarıdaki örnek çalışmıyorsa tarayıcınızın sürümüne bakınız.

Oturumlar
Karşıya dosya yükleme
Özellikler


Karşıya dosya yükleme

İçindekiler

  • POST yöntemi ile karşıya dosya yükleme
  • Hata İletilerinin Açıklamaları
  • Bilinen zorluklar
  • Çoklu dosya yükleme
  • PUT yöntemi desteği
XForms ile çalışmak
POST yöntemi ile karşıya dosya yükleme
Özellikler


POST yöntemi ile karşıya dosya yükleme

Bu özellik metin ve ikil dosyaları yükleme imkanı verir. PHP'nin kimlik doğrulama ve dosya işletim işlevleri ile kimin karşıya dosya yükleme yetkisi olacağına ve yüklenen dosya ile ne yapılacağı hakkında tam denetime sahip olursunuz.

PHP, herhangi bir RFC 1867 uyumlu tarayıcıdan gelen dosya yüklemelerini alabilir.

Bilginize: İlgili Yapılandırmalar

Ayrıca php.ini içindeki file_uploads, upload_max_filesize, upload_tmp_dir, post_max_size ve max_input_time yönergelerine bakınız.

PHP ayrıca Netscape Composer ve W3C'nin Amaya istemcileri tarafından kullanılan PUT yöntemiyle dosya yüklemeleri de destekler. Ayrıntılı bilgi için PUT Yöntemi Desteği'ne bakınız.

Örnek 1 - Karşıya Dosya Yükleme Formu

Bir dosya yükleme ekranı aşağıdaki gibi özel bir form ile oluşturulabilir:

<!-- Veri kodlama türü, enctype, aşağıdaki gibi belirtilmek ZORUNDADIR -->
<form enctype="multipart/form-data" action="__URL__" method="POST">
    <!-- MAX_FILE_SIZE dosya giriş alanından önce bulunmak zorundadır -->
    <input type="hidden" name="MAX_FILE_SIZE" value="30000" />
    <!-- input elemanının adı $_FILES dizisinin içindeki ismi belirler -->
    Bu dosyayı gönder: <input name="kullanici_dosyasi" type="file" />
    <input type="submit" value="Dosyayı Gönder" />
</form>

Yukarıdaki örnekteki __URL__ bir PHP dosyası ile değiştirilmelidir.

MAX_FILE_SIZE gizli alanı (bayt cinsinden) dosya giriş alanından önce bulunmak zorundadır ve değeri PHP tarafından kabul edilecek azami dosya boyutudur. Bu form elemanı azami-büyüklüğü aşan bir dosyanın gönderilmesini baştan engelleyeceği için büyük dosyaları boşuna beklememek açısından kullanıcılara zaman kazandırır; bu nedenle her zaman kullanılmalıdır. Ancak unutmayın: Bu ayarı tarayıcı tarafında devre dışı bırakmak oldukça kolaydır, bu nedenle daha büyük boyuttaki dosyaların bu özellik tarafından engelleneceğine güvenmeyiniz. Bunula birlikte, PHP'nin azami-büyüklük ayarı devre dışı bırakılamaz.

Bilginize:

Dosya yükleme formunuzun enctype="multipart/form-data" özniteliğine sahip olduğundan emin olun, aksi takdirde dosya yükleme çalışmaz.

Küresel $_FILES karşıdan yüklenen tüm dosyaların bilgisini içerir. Örnek formdaki $_FILES içeriği aşağıda verilmiştir. Yukarıdaki örneğe göre yüklenen dosya adı kullanici_dosyasi'dır. Bu herhangi bir isim olabilir.

$_FILES['kullanici_dosyasi']['name']

İstemci makinasındaki asıl dosya adıdır.

$_FILES['kullanici_dosyasi']['type']

Eğer tarayıcı bu bilgiyi sağladıysa dosyanın MIME türüdür. Örneğin, "image/gif". Bu MIME türü PHP tarafında denetlenmez; bu bakımdan bu değeri dikkate almayın.

$_FILES['kullanici_dosyasi']['size']

Yüklenen dosyanın bayt cinsinden boyutudur.

$_FILES['kullanici_dosyasi']['tmp_name']

Yüklenen dosyanın sunucuda saklandığı sıradaki geçici dosya adıdır.

$_FILES['kullanici_dosyasi']['error']

Bu dosya yüklemesiyle ilişkili hata kodudur.

php.ini içindeki upload_tmp_dir yönergesi ile başka bir yer belirtilmediyse, dosyalar, öntanımlı olarak sunucunun öntanımlı geçici dizininde saklanır. Sunucunun öntanımlı geçici dizini PHP'nin içinde çalıştığı ortamdaki TMPDIR ortam değişkenine başka bir değer vererek değiştirilebilir. Buna PHP betiği içinden putenv() işlevi ile değer verirseniz çalışmaz. Bu ortam değişkeni diğer işlemlerin yüklenen dosyalar üzerinde çalıştığından emin olmak için de kullanılabilir.

Örnek 2 - Dosya yüklemelerinin doğrulanması

Daha fazla bilgi için is_uploaded_file() ve move_uploaded_file() işlev girdilerine de bakınız. Aşağıdaki örnek bir formdan gelen dosya yükleme isteğini işleyecektir.

<?php
// 4.1.0'dan önceki PHP sürümlerinde, $_FILES yerine
// $HTTP_POST_FILES kullanılmalıdır.

$dizin = '/var/siteler/uploads/';
$yuklenecek_dosya = $dizin . basename($_FILES['kulldosyasi']['name']);

echo '<pre>';
if (move_uploaded_file($_FILES['kulldosyasi']['tmp_name'], $yuklenecek_dosya))
{
    echo "Dosya geçerli ve başarıyla yüklendi.\n";
} else {
    echo "Olası dosya yükleme saldırısı!\n";
}

echo 'Diğer hata ayıklama bilgileri:';
print_r($_FILES);

print "</pre>";

?>

Yüklenen dosyayı alan PHP betiği yüklenen dosya ile ne yapılacağını belirlemek için gerekli mantığı uygulamalıdır. Örneğin, $_FILES['kullanici_dosyasi']['size'] değişkenini çok küçük ve büyük dosyaları engellemek için kullanabilirsiniz. $_FILES['kullanici_dosyasi']['type'] değişkenini belirli türlere uymayan dosyaları engellemek için kullanabilirsiniz, fakat bunu sadece birincil denetimlerde kullanın, çünkü bu değer tamamen istemci kontrolündedir ve PHP tarafında denetlenmez. Ayrıca $_FILES['kullanici_dosyasi']['error'] kullanabileceği gibi mantığınızı da hata kodlarına göre planlayabilirsiniz. Her şartta dosyayı ya geçici dizinden silmeli ya da başka bir yere taşımalısınız.

Eğer formunuzda yüklemek için bir dosya seçilmediyse, PHP $_FILES['kullanici_dosyasi']['size'] değerini 0 ve $_FILES['kullanici_dosyasi']['tmp_name'] değerini boş döndürür.

İstemin sonunda dosya başka bir yere taşınmadı veya adı değiştirilmediyse geçici dizinden silinir.

Örnek 3 - Dosya dizisi yükleme

PHP HTML dizisi özelliğini dosyalar için de destekler.

<form action="" method="post" enctype="multipart/form-data">
<p>Resimler:
<input type="file" name="resimler[]" />
<input type="file" name="resimler[]" />
<input type="file" name="resimler[]" />
<input type="submit" value="Gönder" />
</p>
</form>
<?php
foreach ($_FILES["resimler"]["error"] as $anahtar => $hata) {
    if ($hata == UPLOAD_ERR_OK) {
        $tmp_name = $_FILES["resimler"]["tmp_name"][$anahtar];
        $name = $_FILES["resimler"]["name"][$anahtar];
        move_uploaded_file($tmp_name, "data/$name");
    }
}
?>

Dosya yükleme ilerleme çubuğu Dosya Yüklemeyi İzleme seçeneği kullanılarak gerçeklenebilir.

Karşıya dosya yükleme
Hata İletilerinin Açıklamaları
Karşıya dosya yükleme


Hata İletilerinin Açıklamaları

PHP, dosya dizisi ile birlikte uygun bir hata kodu döndürür. Hata kodu PHP tarafından dosya yüklenirken oluşturulan dosya dizisinin error bölümünde bulunur. Diğer bir deyişle, hata $_FILES['kullanici_dosyasi']['error'] içinde olabilir.

UPLOAD_ERR_OK

Değeri: 0; Hata yoktur, dosya yükleme başarılıdır.

UPLOAD_ERR_INI_SIZE

Değeri: 1; Yüklenen dosya php.ini içindeki upload_max_filesize yönergesindeki değeri aşmaktadır.

UPLOAD_ERR_FORM_SIZE

Değeri: 2; Yüklenen dosya HTML form içinde belirtilen MAX_FILE_SIZE değerini aşmaktadır.

UPLOAD_ERR_PARTIAL

Değeri: 3; Dosya kısmen yüklenmiştir.

UPLOAD_ERR_NO_FILE

Değeri: 4; Dosya yüklenmemiştir.

UPLOAD_ERR_NO_TMP_DIR

Değeri: 6; Geçici dizin yoktur. PHP 5.0.3'de gelmiştir.

UPLOAD_ERR_CANT_WRITE

Değeri: 7; Dosya diske yazılamamıştır. PHP 5.1.0'da gelmiştir.

UPLOAD_ERR_EXTENSION

Değeri: 8; Dosya yükleme bir PHP eklentisi nedeniyle durmuştur. PHP buna hangi eklentinin sebep olduğunu bulmak için bir yol sağlamaz. phpinfo() ile yüklenen eklentilerin listesini alıp incelemek işe yarayabilir.PHP 5.2.0'da gelmiştir.

POST yöntemi ile karşıya dosya yükleme
Bilinen zorluklar
Karşıya dosya yükleme


Bilinen zorluklar

MAX_FILE_SIZE dosya boyutu php.ini dosyasında upload_max_filesize yönergesinde belirtilenden büyük olamaz. Öntanımlı değeri 2 Megabayt'tır.

Eğer bir bellek sınırı etkinleştirildiyse, daha büyük bir memory_limit gerekebilir. memory_limit değerinin yeterli olduğundan emin olun.

Eğer max_execution_time çok küçük verildiyse, betiğin çalışma süresi bu süreyi aşabilir. max_execution_time değerinin yeterli olduğundan emin olun.

Bilginize: max_execution_time sadece betiğin kendi çalışma süresini etkiler. Sistem çağrıları system(), sleep() işlevleri, veritabanı sorguları, dosya yükleme işlemi gibi betiğin işletimi dışında yaşanan etkinliklerde harcanan zaman betiğin azami çalışma süresinin belirlenmesinde hesaba katılmaz.

Uyarı

max_input_time betiğin girdi almak için harcayacağı azami süreyi saniye cinsinden belirler, buna dosya yüklemeleri de dahildir. Büyük veya çoklu dosyalar için veya yavaş bağlantılı kullanıcılar için 60 saniyelik öntanımlı değer aşılabilir.

Eğer post_max_size çok küçük verildiyse, büyük dosyalar yüklenemez. post_max_size değerinin yeterli olduğundan emin olun.

PHP 5.2.12'den itibaren, max_file_uploads yapılandırma seçeneği bir istekte yüklenebilecek azami dosya sayısını belirtmek için kullanılabilmektedir. Bu sayıdan fazla dosya yüklenmek istendiğinde $_FILES bu sayıya ulaşıldığında dosya yüklemeyi durduracaktır. Örneğin, max_file_uploads için 10 belirtilmişse $_FILES asla 10 üyeden fazlasını içermeyecektir.

Üzerinde çalıştığınız dosyanın doğrulanmaması kullanıcıların diğer dizinlerde bulunan hassas bilgilere erişebileceği anlamına gelebilir.

CERN httpd istemciden aldığı content-type mime başlığındaki ilk boşluktan itibaren herşeyi soyar. Bu durumda CERN httpd dosya yükleme özelliğini desteklemez.

Bir çok dizin listeleme şeklinin olmasından dolayı özgün isimlerin (örneğin boşluk içerenler) uygun şekilde işlenebileceğinin garantisi yoktur.

Normal girdi alanlarıyla dosya yükleme alanları karıştırılıp aynı form değişkeninde (örneğin foo[] gibi) kullanılamaz.

Hata İletilerinin Açıklamaları
Çoklu dosya yükleme
Karşıya dosya yükleme


Çoklu dosya yükleme

inputlar için farklı name değerleri kullanarak çoklu dosya gönderilebilir.

Ayrıca bilgilerin özdevinimli olarak dizilerde düzenlendiği bir eşzamanlı dosya gönderimi de mümkündür. Bunun için, HTML formunda birden fazla input için aynı dizi söz dizimini kullanmalısınız:

Örnek 1 - Çoklu dosya yükleme

<form action="dosya-yukle.php" method="post" enctype="multipart/form-data">
  Bu dosyaları gönder:<br />
  <input name="kullanici_dosyasi[]" type="file" /><br />
  <input name="kullanici_dosyasi[]" type="file" /><br />
  <input type="submit" value="Dosyaları gönder" />
</form>

Yukarıdaki form gönderildiğinde, $_FILES['kullanici_dosyasi'], $_FILES['kullanici_dosyasi']['name'] ve $_FILES['kullanici_dosyasi']['size'] dizileri ilklendirilir (4.1.0'dan önceki PHP sürümleri için $HTTP_POST_FILES). register_globals değeri "on" olduğunda, yüklenen dosyalar içinde küreseller ilklendirilir. Bunlardan her biri gönderilen dosyanın değerine uygun olarak sayısal indisli bir dizi olurlar.

Örneğin, gönderilen dosya isimleri /home/test/review.html ve /home/test/xwp.out olsun. Bu durumda, $_FILES['kullanici_dosyasi']['name'][0] review.html değerini içerir ve $_FILES['kullanici_dosyasi']['name'][1] xwp.out değerini içerir. Benzer şekilde, $_FILES['kullanici_dosyasi']['size'][0] review.html'in dosya boyutunu içerir ve böyle devam eder.

$_FILES['kullanici_dosyasi']['name'][0], $_FILES['kullanici_dosyasi']['tmp_name'][0], $_FILES['kullanici_dosyasi']['size'][0] ve $_FILES['kullanici_dosyasi']['type'][0]'a da ayrıca değerleri atanır.

Uyarı

PHP 5.2.12'den itibaren, max_file_uploads yapılandırma seçeneği bir istekte yüklenebilecek azami dosya sayısını belirtmek için kullanılabilmektedir. Formunuzun bir istekte bu sayıdan fazla dosya yüklemeye çalışmamasını sağlamalısınız.

Bilinen zorluklar
PUT yöntemi desteği
Karşıya dosya yükleme


PUT yöntemi desteği

PHP bazı istemciler tarafından sunucuda dosya saklamak için kullanılan HTTP PUT yöntemini de destekler. PUT istemleri POST istemleri ile dosya yüklemesinden daha basittir ve şu şekildedir:

PUT /dizin_adi/dosyaismi.html HTTP/1.1

Bu normalde uzak istemci /dizin_adi/dosyaismi.html içeriğini site ağacında saklamak istiyor anlamına gelir. Bu Apache veya PHP'nin herkese site ağacındaki herhangi bir dosya üzerine yazma yetkisi verme anlamına geleceği için iyi bir fikir değildir. Bu nedenle böyle bir istem geldiğinde öncelikle HTTP sunucunuza bu istemin belirli bir PHP betiği tarafından karşılanacağını söylemelisiniz. Apache'de bunu Script yönergesi ile yapabilirsiniz. Bu Apache yapılandırma dosyasının herhangi bir yerine konulabilir. Genellikle <Directory> bloğu içine veya <VirtualHost> bloğu içine konulur. Bu, aşağıdaki gibi bir satır olabilir:

Script PUT /put.php

Bu Apache'ye URI'ler için bütün PUT istemlerinin put.php betiğine gönderilmesini söyler. Tabii ki bu durumda .php uzantısının ve PHP'nin etkin olduğu varsayılmaktadır. Bu betiğe gelen bütün PUT istemleri için hedef kaynağı betiğin kendisi olmalıdır.

PHP ile put.php içinde şunu yapabilirsiniz. Bu yüklenen dosyanın içeriğini sunucudaki myputfile.ext dosyasına kopyalar. Bu dosya kopyalamayı gerçekleştirmeden önce bazı denetimlerin yanında kimlik doğrulaması da yapmak isteyebilirsiniz.

Örnek 1 - HTTP PUT dosyalarının kaydedilmesi

<?php
/* PUT verisi stdin akımına gelir */
$putdata = fopen("php://input", "r");

/* Yazmak için bir dosya aç */
$fp = fopen("put_dosyam.ekl", "w");

/* Bir kerede 1 KB veri oku ve dosyaya yaz  */
while ($veri = fread($putdata, 1024))
  fwrite($fp, $veri);

/* Akımları kapat */
fclose($fp);
fclose($putdata);
?>

Çoklu dosya yükleme
Uzak dosyaların kullanımı
Karşıya dosya yükleme


Uzak dosyaların kullanımı

php.ini içinde allow_url_fopen seçeneği etkin olduğu sürece, dosya adını değiştirge olarak alan birçok işlevde HTTP ve FTP URL'lerini kullanabilirsiniz. Ek olarak, URL'ler include, include_once, require ve require_once deyimleri ile kullanılabilir (PHP 5.2.0'dan beri bunun için allow_url_include seçeneğini etkinleştirmek gerekmektedir). PHP tarafından desteklenen protokoller hakkında daha fazla bilgi için bakınız: Supported Protocols and Wrappers

Örneğin, bunu uzak web sunucusunda bir dosya açmak, istediğiniz veri için çıktıyı çözümlemek ve bu veriyi bir veritabanı sorgusunda kullanmak veya sadece çıktılamak için kullanabilirsiniz.

Örnek 1 - Uzak sayfanın başlığını elde etmek

<?php
$dosya = fopen ("http://www.ornek_bir_site.com/", "r");
if (!$dosya) {
    echo "<p>Uzak dosya açılamıyor.\n";
    exit;
}
while (!feof ($dosya)) {
    $satir = fgets ($dosya, 1024);
    /* Bu sadece başlığın title etiketleri aynı satır üzerindeyse çalışır */
    if (preg_match ("@\<title\>(.*)\</title\>@i", $satir, $cikti)) {
        $baslik = $cikti[1];
        break;
    }
}
fclose($dosya);
?>

Aynı zamanda bir FTP sunucusundaki dosyalara da yazabilirsiniz (doğru erişim haklarına sahip bir kullanıcı olarak bağlandığınızda). Bu yöntemi kullanarak sadece yeni dosyalar oluşturabilirsiniz; eğer varolan bir dosyanın üzerine yazmayı denerseniz, fopen() çağrısı başarısız olur.

'anonymous' haricinde bir kullanıcı olarak bağlanmak için, 'ftp://kullanici:parola@ftp.ornek_bir_site.com/ornek/bir/dosya' örneğindeki gibi kullanıcı adı (ve parola) URL içinde belirtilmelidir. (Basit kimlik doğrulaması gerektiren HTTP dosya erişimleri içinde aynı söz dizimini kullanabilirsiniz.)

Örnek 2 - Veriyi uzak sunucuda saklamak

<?php
$dosya = fopen ("ftp://ftp.ornek_bir_site.com/gelen/yazilan_dosya", "w");
if (!$dosya) {
    echo "<p>Uzak dosya yazmak için açılamıyor.\n";
    exit;
}
/* Veriyi burada yaz. */
fwrite ($dosya, $_SERVER['HTTP_USER_AGENT'] . "\n");
fclose ($dosya);
?>

Bilginize:

Yukarıdaki örnek, bu tekniğin uzak günlük dosyası yazmak için kullanılabileceği fikrini vermiş olabilir. Ne yazık ki bu çalışmaz çünkü eğer uzak dosya zaten varsa fopen() çağrısı başarısız olur. Böyle bir dağıtık günlüklerle için syslog() işlevine göz atmalısınız.

PUT yöntemi desteği
Bağlantı yönetimi
Özellikler


Bağlantı yönetimi

PHP içinde yerleşik olarak bağlantı durumu saklanır. Olası 4 durum vardır:

  • 0 - NORMAL
  • 1 - ABORTED
  • 2 - TIMEOUT
  • 3 - ABORTED ve TIMEOUT

PHP betiği normal olarak çalıştığında, NORMAL durumu etkindir. Eğer uzak istemci bağlantıyı keserse ABORTED durumu etkin olur. Uzak istemci bağlantı kesilmesi genellikle kullanıcının DUR düğmesine basmasından kaynaklanır. Eğer PHP tarafından bir zaman sınırı (set_time_limit() işlevine bakınız) tetiklendiyse, TIMEOUT durumu etkin olur.

Kullanıcının bağlantı kesmesiyle betiğinizin iptal edilip edilmeyeceğine karar verebilirsiniz. Bazen uzak tarayıcı çıktıyı almasa da betiğinizin işini bitirinceye kadar çalışmasını gerektiren durumlar olabilir. Öntanımlı davranış uzak istemci bağlantıyı kestiğinde betik çalışmasının iptal edilmesidir. Bu davranış şekli ignore_user_abort php.ini yönergesi veya ona ilişkin php_value ignore_user_abort Apache httpd.conf yapılandırma yönergesi veya ignore_user_abort() işlevi ile belirlenebilir. Eğer PHP'ye kullanıcı iptallerini gözardı etmesini söylemezseniz ve kullanıcı iptal ederse betiğiniz sonlanır. Tek istisnası register_shutdown_function() işleviyle kapatma işlevinin kayıtlanmasıdır. Bir kapatma işlevi ile, uzak kullanıcı DUR düğmesine bastığında, betiğinizin sonraki çıktılama denemesinde PHP bağlantının iptal edildiğini tespit eder ve kapatma işlevi çağrılır. Bu kapatma işlevi ayrıca normal olarak sonlandırmada betiğinizin sonunda çağrılacaktır, istemci tarafından bağlantı iptalinde farklı birşey yapmak için connection_aborted() işlevini kullanabilirsiniz. Eğer bağlantı iptal edilirse bu işlev TRUE döndürecektir.

Betiğinizi yerleşik betik zamanlayıcı ile de sonlandırabilirsiniz. Öntanımlı zaman aşımı 30 saniyedir. Bu max_execution_time php.ini yönergesi veya ilişkili php_value max_execution_time Apache httpd.conf yapılandırma yönergesi veya set_time_limit() işlevi ile değiştirilebilir. Zaman aşımında betik iptal edilir ve yukarıdaki istemci bağlantı kesilmesindeki gibi, eğer kayıtlı bir kapatma işlevi varsa çağrılır. Bu kapatma işlevi içinde connection_status() işlevi ile kapatma işlevinin zaman aşımı nedeniyle mi çağrıldığını denetleyebilirsiniz. Kapatma işlevinin çağrılmasına zaman aşımı neden olduysa bu işlev 2 döndürür.

ABORTED ve TIMEOUT durumlarının aynı zamanda etkin olabileceğine dikkat edilmesi gerekir. Eğer PHP'ye kullanıcı iptallerini gözardı etmesini söylediyseniz bu mümkündür. PHP kullanıcının bağlantıyı koparmış olabileceğini bilir, fakat betik çalışmaya devam eder. Eğer zaman sınırına ulaşırsa çalışması iptal edilir ve kapatma işleviniz varsa çağrılır. Bu noktada connection_status() işlevinin 3 döndürdüğünü göreceksiniz.

Uzak dosyaların kullanımı
Kalıcı Bağlantılı Veritabanı Bağlantıları
Özellikler


Kalıcı Bağlantılı Veritabanı Bağlantıları

Kalıcı bağlantılar betiğinizin çalışması bittiğinde kapanmayan bağlantılardır. Bir kalıcı bağlantı istendiğinde PHP evvelce açılmış eşdeğer bir kalıcı bağlantı var mı diye bakar ve varsa onu kullanır. Yoksa yeni bir bağlantı oluşturur. Bir 'eşdeğer' bağlantı, aynı konağa (uygulanabildiği takdirde) aynı kullanıcı adı ve parola kullanılarak açılmış bağlantıdır.

HTTP sunucuları hakkında tam bilgi sahibi olmayan kişiler ne yaptıklarını bilmeden yükü yanlış kalıcı bağlantılara dağıtabilir ve bu yanlış bağlantılarla çalışabilirler. Özellikle, size aynı bağlantı üzerinde 'kullanıcı oturumları' açma olanağını, verimli hareket işlemleri kurulmasını ve başka birçok şeyi bir bütün halinde sağlamazlar. Aslında, son derece net olarak, kalıcı bağlantılar, kalıcı olmayan bağlantılarla mümkün olmayan işlevselliği size sağlayamazlar.

Neden?

Bu HTTP sunucusunun işi nasıl yaptığı ile ilgilidir. PHP'nin HTML sayfalarını üretmek için HTTP sunucusunu üç şekilde kullanabilir.

İlk yöntem, PHP'yi bir CGI "sarmalayıcı" olarak kullanmaktır. Bu yolla, HTTP sunucusundan her PHP sayfası isteğinde PHP yorumlayıcısının yeni bir örneği oluşturulup yok edilir. Yorumlayıcı her istekten sonra yok edildiğinden kazanılan özkaynaklar da (bir SQL veritabanı bağlantısı gibi) kaybedilir. Bu durumda, kalıcı bağlantılar kullanarak da hiç bir şey kazanamazsınız; çünkü özkaynaklar kalıcı olmayacaktır.

İkinci ve en çok kullanılan yöntem, PHP'yi çok süreçli bir sunucuda bir modül olarak çalıştırmaktır. Bu olanak şimdilik sadece Apache HTTP sunucusu ile mümkündür. Çok süreçli bir sunucu, işleri sayfaları sunmak olan bir çok (alt) süreci denetimi altında tutan bir ana sürece sahiptir. Bir istemciden bir istek geldiğinde, başka istemcilere hizmet sunmayan alt süreçlerden birini bu isteğe tahsis eder. Eğer aynı istemci ikinci bir istek yaparsa bu isteğe başka bir alt süreç yanıt verebilir. Kalıcı bir bağlantı açıldığında SQL hizmeti isteği yapılan her sayfa isteği SQL sunucuya tahsis edilen aynı bağlantıdan sunulur.

Son yöntem, PHP'yi çok evreli bir sunucuda bir eklenti olarak kullanmaktır. PHP4 şimdilik, PHP'nin bir eklenti olarak kullanımına izin veren Netscape FastTrack (iPlanet), Microsoft's Internet Information Server (IIS) ve O'Reilly's WebSite Pro gibi çok evreli HTTP sunucularında ISAPI, WSAPI ve (Windows üzerinde) NSAPI için destek vermektedir. Davranış esas olarak ikinci yöntemde açıklanan çok süreçli yöntemle aynıdır.

Kalıcı bağlantılar ek bir işlevselliğe sahip değilseler bunlar neden tercih ediliyorlar?

Yanıtı oldukça basittir: Verimlilik. SQL sunucunuza bağlantı açmak çok masraflıysa kalıcı bağlantılar kurmak daha iyidir. Bu bedel gerçekte birçok sebebe bağlı olabileceği gibi olmayabilir de. Bu, veritabanının, HTTP sunucunun bulunduğu makinede olup olmamasından SQL sunucusunun makineye ne kadar yük bindirdiğine kadar geniş bir yelpazede değerlendirilebilir. Son değerlendirmede, eğer bu bedel yüksekse kalıcı bağlantıların büyük ölçüde yardımı olacaktır. SQL sunucuya yapılan her bağlantı isteğinde alt süreç sadece o sayfayı işleyeceği yerde, kalıcı bağlantı durumunda her alt sürecin ömrü boyunca bir bağlantı krmasına olanak tanınır. Yani, bir kalıcı bağlantı açmış her alt sürecin kendine ait bir kalıcı bağlantısı vardır. Örneğin, SQl sunucunuza kalıcı bağlantı açan betiğiniz 20 ayrı alt süreç çalıştırıyorsa alt süreç başına bir tane olmak 20 ayrı bağlantı var demektir.

Ancak şuna dikkat edin, bağlantı sayısı sınırlı bir veritabanını bu sınırın üstünde kalıcı bağlantılarla kullanıyorsanız bunun bazı götürüleri olabilir. Eğer veritabanınız aynı anda 16 bağlantılık bir sınıra sahipse ve çok meşgul bir sunucu oturumunda 17 alt evre bağlantı açmaya çalışıyorsa biri bunu başaramayacaktır. Eğer betiğinizde (sonsuz döngü gibi durumlarda) bağlantıların kapatılmasına izin vermeyen hatalar varsa, veritabanı sadece 16 bağlantı ile hızla batağa saplanacaktır. Terkedilmiş ve boştaki bağlantıların devreye sokulması hakkında bilgi edinmek için veritabanınızın belgelerine bakınız.

Uyarı

Kalıcı bağlantıları kullanırken hesaba katmanız gereken bir çok yetersizlik vardır. Bunlardan biri, bir kalıcı bağlantı üzerinden tablo kilitlemesi yapıyorsanız ve betiğiniz herhangi bir şekilde kilidi serbest bırakamazsa aynı bağlantıyı kullanan sonraki betikler sonsuza kadar engellenebilir ve bunun sonucu olarak HTTP sunucunuzu veya veritabanı sunucunuzu yeniden başlatmak zorunda kalabilirsiniz. Bir diğer durumda, hareketleri (transaction) kullanırken, bir hareket bloğu tamamlanmadan betiğiniz çalışmasını bitirirse aynı bağlantıyı kullanan sonraki betiklerin işleri başlarından aşacaktır. Her durumda, tablolarınızın kilitlerini açmak ve hareketleri başa sarmak için register_shutdown_function() işlevini kullanarak bir temizlik işlevi tanımlayabilirsiniz. Daha da iyisi, tablo kilitleri veya hareket blokları kullanan betiklerde kalıcı bağlantıları kullanmayarak bu sorunlardan tamamiyle kurtulabilirsiniz.

Özetle, kalıcı bağlantılar normal bağlantılarla bire bir eşleşecek şekilde tasarlanmışlardır. Yani, betiğinizin davranışını değiştirmeden kalıcı bağlantılar yerine her zaman kalıcı olmayan bağlantılar kullanabilirsiniz. Bu, muhtemelen betiğinizin verimliliğini etkileyecektir ama davranışında bir değişikliğe yol açmayacaktır!

Ayrıca bakınız: fbsql_pconnect(),
ibase_pconnect(), ifx_pconnect(),
ingres_pconnect(),
msql_pconnect(), mssql_pconnect(),
mysql_pconnect(), ociplogon(),
odbc_pconnect(), oci_pconnect(),
pfsockopen(), pg_pconnect() ve
sybase_pconnect().

Bağlantı yönetimi
Güvenli Kip
Özellikler


Güvenli Kip

İçindekiler

  • Güvenlik ve Güvenli Kip
  • Güvenli kipte yasaklı/kısıtlı işlevler

PHP güvenli kipi, paylaşımlı sunucu güvenliği sorunlarını çözümlemeye çalışır. Bu tür sorunları PHP seviyesinde çözümlemeye çalışmak mimari olarak doğru değildir, fakat HTTP sunucusu ve işletim sistemi seviyesindeki çözümler pek gerçekçi olmadığından çoğu kişi, özellikle de ISP'ler güvenli kipi halen kullanmaktadırlar.

Uyarı

Bu özelliğin kullanımı PHP 5.3.0 itibariyle ÖNERİLMEMEKTE olup PHP 5.4.0'da tamamen KALDIRILMIŞTIR.

safe mode için değişiklik bilgisi
Sürüm: | Açıklama
5.4.0 | PHP'den kaldırıldı. Etkinleştirilirse, ölümcül seviyede E_CORE_ERROR hatası verilir.
5.3.0 | Kullanımı önerilmemekte olup E_DEPRECATED hataları eklenmiştir.

Kalıcı Bağlantılı Veritabanı Bağlantıları
Güvenlik ve Güvenli Kip
Özellikler


Güvenlik ve Güvenli Kip

Güvenlik ve Güvenli Kip Yapılandırma Yönergeleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
safe_mode | "0" | PHP_INI_SYSTEM | PHP 5.4.0'da kaldırıldı.
safe_mode_gid | "0" | PHP_INI_SYSTEM | PHP 5.4.0'da kaldırıldı.
safe_mode_include_dir | NULL | PHP_INI_SYSTEM | PHP 5.4.0'da kaldırıldı.
safe_mode_exec_dir | "" | PHP_INI_SYSTEM | PHP 5.4.0'da kaldırıldı.
safe_mode_allowed_env_vars | "PHP_" | PHP_INI_SYSTEM | PHP 5.4.0'da kaldırıldı.
safe_mode_protected_env_vars | "LD_LIBRARY_PATH" | PHP_INI_SYSTEM | PHP 5.4.0'da kaldırıldı.
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

safe_mode boolean

PHP'nin güvenli kipinin etkin olup olmayacağı. PHP --enable-safe-mode seçeneği ile derlenmişse öntanımlı olarak On (etkin), aksi takdirde Off'tur (etkisiz).

Uyarı

Bu özelliğin kullanımı PHP 5.3.0 itibariyle ÖNERİLMEMEKTE olup PHP 5.4.0'da tamamen KALDIRILMIŞTIR.

safe_mode_gid boolean

Dosya erişiminde UID (FALSE) veya GID (TRUE) denetimi yapılıp yapılmayacağı. Öntanımlı olarak güvenli kipte, dosyalar açılırken bir kullanıcı kimliği (UID) karşılaştırması yapılır. Bunu grup kimliğini (GID) denetleterek esnetmek isterseniz safe_mode_gid yönergesine On değerini atayabilirisiniz.

safe_mode_include_dir string

UID/GID denetimleri bu dizinde ve alt dizinlerinde es geçilir. (Dizinin ya tam yolu belirtilmeli ya da include_path yönergesinde de belirtilmelidir).

Bu yönergede include_path yönergesinde olduğu gibi, tek bir dizin belirtmek yerine aralarına ikinokta imi (Windows'da noktalı virgül imi) koymak suretiyle birden fazla dizin belirtilebilmektedir. Belirtilen dizinin sonuna bir bölü çizgisi konmadıkça dizin ismi bir önek olarak değerlerdirilir. Örneğin, "safe_mode_include_dir = /dir/incl" ile (varsa) hem "/dir/include" hem de "/dir/incls" dizini belirtilmiş olur. "safe_mode_include_dir = /dir/incl/" durumunda ise sadece /dir/incl dizini belirtilmiş olur. Bu yönergede boş değer belirtilirse farklı UID/GID'e sahip hiçbir dosya dahil edilmez.
safe_mode_exec_dir string

PHP güvenli kipte kullanılıyorsa system() ve sistem programlarını çalıştırılan diğer işlevlerin bu dizinde olmayan programları çalıştırmasına izin verilmez. Windows dahil tüm ortamlarda dizin ayracı olarak / kullanmanız gerekir.

safe_mode_allowed_env_vars string

Bazı ortam değişkenlerinin kullanımı güvenlik açığı riski içerir. Bu yönergede virgül ayraçlı bir liste olarak önekler belirtilir. Güvenli kipte, kullanıcıların sadece bu yönergede önekleri belirtilen ortam değişkenlerini değiştirmelerine izin verilir. Kullanıcılar öntanımlı olarak sadece PHP_ ile başlayan ortam değişkenlerinde değişiklik yapabilirler (PHP_FOO=BAR gibi).

Bilginize:

Bu yönergede boş değer belirtilmişse kullanıcıların tüm ortam değişkenlerinde değişiklik yapmalarına izin verilir!

safe_mode_protected_env_vars string

Bu yönergede, son kullanıcının putenv() kullanarak değiştiremeyeceği ortam değişkenleri virgül ayraçlı bir liste olarak belirtilir. Bu değişkenlerin önekleri safe_mode_allowed_env_vars yönergesinde belirtilmiş olsalar dahi, değiştirilmelerine izin verilmez.

Ayrıca bakınız: open_basedir, disable_functions, disable_classes, register_globals, display_errors ve log_errors.

safe_mode yönergesinin değeri On olduğu takdirde, PHP, betik sahibinin üzerinde çalışılan dosya veya dizin sahibiyle eşleşip eşleşmediğini denetler. Örneğin,

<?php
 readfile('/etc/passwd');
?>
kodunu içeren betik.php betiği,
-rw-rw-r--    1 rasmus   rasmus       33 Jul  1 19:20 betik.php
-rw-r--r--    1 root     root       1116 May 26 18:01 /etc/passwd
ortamında çalıştırılırsa, güvenli kip etkin olduğu takdirde işlem şöyle bir hatayla sonuçlanır:
Warning: SAFE MODE Restriction in effect. The script whose uid is 500 is not
allowed to access /etc/passwd owned by uid 0 in /docroot/betik.php on line 2

Bununla birlikte, kesin UID sınamasının uygun olmadığı, esnek GID sınamasının yeterli olduğu sistemler olabilir. Bu durum, safe_mode_gid yönergesi ile sağlanabilir. Bu yönergeye On değeri vererek esnek GID sınaması, Off değeri (öntanımlıdır) vererek UID sınaması yaptırmak mümkündür.

safe_mode yönergesini etkin kılmak yerine, tüm dosya işlemlerini belli bir dizin altındaki dosyalarla sınırlamak için open_basedir yönergesini kullanabilirsiniz. Örneğin, bunu Apache httpd.conf dosyasında şöyle yapabilirsiniz:

<Directory /docroot>
  php_admin_value open_basedir /docroot
</Directory>
Önceki örnekteki betik.php dosyanızı bu open_basedir ayarı ile kullanırsanız şöyle bir sonuç alırsınız:
Warning: open_basedir restriction in effect. File is in wrong directory in
/docroot/betik.php on line 2

Ayrıca, işlevleri tek tek de iptal etmek mümkündür. Ancak, disable_functions yönergesi php.ini dosyası dışında kullanılamaz. Yani, bazı işlevlere erişimi, httpd.conf dosyanızda sanal konak veya dizin temelinde yasaklayamazsınız. php.ini dosyanızda şöyle bir satır varsa:

disable_functions = readfile,system
betik.php dosyanızdan şöyle bir sonuç alırsınız:
Warning: readfile() has been disabled for security reasons in
/docroot/betik.php on line 2

Uyarı

Şüphesiz, bu PHP kısıtlamaları çalıştırılabilir dosyalar için geçerli değildir.

Güvenli Kip
Güvenli kipte yasaklı/kısıtlı işlevler
Güvenli Kip


Güvenli kipte yasaklı/kısıtlı işlevler

Güvenli kip ile sınırlanmış işlev listesi hala yanlış veya eksik olabilir.

Güvenli kiple sınırlı işlevler
İşlev | Kısıtlama
dbmopen() | Üzerinde işlem yapılan dosya ve dizinlerin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığı sınanır.
dbase_open() | Üzerinde işlem yapılan dosya ve dizinlerin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığı sınanır.
filepro() | Üzerinde işlem yapılan dosya ve dizinlerin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığı sınanır.
filepro_rowcount() | Üzerinde işlem yapılan dosya ve dizinlerin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığı sınanır.
filepro_retrieve() | Üzerinde işlem yapılan dosya ve dizinlerin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığı sınanır.
ifx_* | sql_safe_mode kısıtlamaları, (!= safe mode)
ingres_* | sql_safe_mode kısıtlamaları, (!= safe mode)
mysql_* | sql_safe_mode kısıtlamaları, (!= safe mode)
pg_lo_import() | Üzerinde işlem yapılan dosya ve dizinlerin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığı sınanır.
posix_mkfifo() | Betiğin çalıştığı dizinin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığı sınanır.
putenv() | safe_mode_protected_env_vars ve safe_mode_allowed_env_vars yönergelerine tabidir. Ayrıca, putenv() işlevine de bakınız.
move_uploaded_file() | Üzerinde işlem yapılan dosya ve dizinlerin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığı sınanır.
chdir() | Betiğin çalıştığı dizinin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığı sınanır.
dl() | Bu işlev, PHP güvenli kipte çalışırken iptal edilir.
ter tırnak işleci | Bu işlev, PHP güvenli kipte çalışırken iptal edilir.
shell_exec() (ters tırnakların işlevsel eşdeğeri) | Bu işlev, PHP güvenli kipte çalışırken iptal edilir.
exec() | Sadece safe_mode_exec_dir altındaki çalıştırılabilirleri bu işlevle çalıştırabilirsiniz. Uygulamaya bağlı sebeplerle çalıştırılabilirlerin dosya yolunda .. bileşenlerine izin verilmez. Bu işlevin değiştirgeleri üzerinde escapeshellcmd()işlevi çalıştırılır.
system() | Sadece safe_mode_exec_dir altındaki çalıştırılabilirleri bu işlevle çalıştırabilirsiniz. Uygulamaya bağlı sebeplerle çalıştırılabilirlerin dosya yolunda .. bileşenlerine izin verilmez. Bu işlevin değiştirgeleri üzerinde escapeshellcmd()işlevi çalıştırılır.
passthru() | Sadece safe_mode_exec_dir altındaki çalıştırılabilirleri bu işlevle çalıştırabilirsiniz. Uygulamaya bağlı sebeplerle çalıştırılabilirlerin dosya yolunda .. bileşenlerine izin verilmez. Bu işlevin değiştirgeleri üzerinde escapeshellcmd()işlevi çalıştırılır.
popen() | Sadece safe_mode_exec_dir altındaki çalıştırılabilirleri bu işlevle çalıştırabilirsiniz. Uygulamaya bağlı sebeplerle çalıştırılabilirlerin dosya yolunda .. bileşenlerine izin verilmez. Bu işlevin değiştirgeleri üzerinde escapeshellcmd()işlevi çalıştırılır.
fopen() | Betiğin çalıştığı dizinin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığı sınanır.
mkdir() | Betiğin çalıştığı dizinin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığı sınanır.
rmdir() | Betiğin çalıştığı dizinin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığı sınanır.
rename() | Üzerinde işlem yapılan dosya ve dizinlerin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığı sınanır. Betiğin çalıştığı dizinin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığı sınanır.
unlink() | Üzerinde işlem yapılan dosya ve dizinlerin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığı sınanır. Betiğin çalıştığı dizinin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığı sınanır.
copy() | Üzerinde işlem yapılan dosya ve dizinlerin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığı sınanır. Betiğin çalıştığı dizinin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığı sınanır. (kaynak ve hedef üzerinde)
chgrp() | Üzerinde işlem yapılan dosya ve dizinlerin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığı sınanır.
chown() | Üzerinde işlem yapılan dosya ve dizinlerin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığı sınanır.
chmod() | Üzerinde işlem yapılan dosya ve dizinlerin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığı sınanır. Ek olarak, SUID, SGID ve yapışkan bitleri tanımlayamazsınız.
touch() | Üzerinde işlem yapılan dosya ve dizinlerin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığı sınanır. Betiğin çalıştığı dizinin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığı sınanır.
symlink() | Üzerinde işlem yapılan dosya ve dizinlerin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığı sınanır. Betiğin çalıştığı dizinin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığı sınanır. (bilgi: sadece hedef sınanır)
link() | Üzerinde işlem yapılan dosya ve dizinlerin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığı sınanır. Betiğin çalıştığı dizinin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığı sınanır. (bilgi: sadece hedef sınanır)
apache_request_headers() | Güvenli kipte, authorization ile başlayan başlıklar (harf büyüklüğüne duyarsız) döndürülmeyecektir.
header() | Güvenli kipte, betiğin kullanıcı kimliği WWW-Authenticate başlığının realm kısmına eklenir (HTTP Kimlik doğrulamasında bu başlık etkinse).
PHP_AUTH değişkenleri | Güvenli kipte, PHP_AUTH_USER, PHP_AUTH_PW ve AUTH_TYPE değişkenleri $_SERVER içinde bulunmaz. Yine de, bundan bağımsız olarak, USER yerine REMOTE_USER kullanabilirsiniz (bilgi: sadece PHP 4.3.0'dan beri etkindir).
highlight_file(), show_source() | Üzerinde işlem yapılan dosya ve dizinlerin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığı sınanır. Betiğin çalıştığı dizinin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığı sınanır.
parse_ini_file() | Üzerinde işlem yapılan dosya ve dizinlerin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığı sınanır. Betiğin çalıştığı dizinin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığı sınanır.
set_time_limit() | safe_mode etkinse etkisizdir.
max_execution_time | safe_mode etkinse etkisizdir.
mail() | Güvenli kipte, 5. değiştirge iptal edilir.
session_start() | session.save_handler yönergesinde files öntanımlı ise betiğin sahibi session.save_path dizininin sahibi ile aynı olmak zorundadır.
Tüm dosya sistemi ve akım işlevleri. | Üzerinde işlem yapılan dosya ve dizinlerin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığı sınanır. Betiğin çalıştığı dizinin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığı sınanır. (safe_mode_include_dir php.ini yönergesine bakınız.)

Güvenlik ve Güvenli Kip
Komut satırından kullanım
Güvenli Kip


PHP'nin komut satırından kullanımı

İçindekiler

  • Giriş
  • Diğer SAPI'lerden dikkate değer farklılıklar
  • Seçenekler
  • Kullanım
  • G/Ç Akımları
  • Etkileşimli kabuk
  • Yerleşik HTTP sunucusu
  • INI Ayarları
Güvenli kipte yasaklı/kısıtlı işlevler
Giriş
Özellikler


Giriş

CLI SAPI'nin ana odağı PHP ile kabuk (veya masaüstü) uygulamaları geliştirmektir. CLI SAPI'nin bu bölümde anlatılan diğer SAPI'lerden az bir farkı vardır. Söylemek gerekir ki, her ne kadar CLI ve CGI birçok aynı davranışı paylaşsa da farklı SAPI'lerdir.

CLI SAPI --enable-cli ile öntanımlı olarak etkin kılınır. Etkinliğini kaldırmak için ./configure betiğinde --disable-cli seçeneğini kullanabilirsiniz.

PHP 4.3.0'dan beri, CLI/CGI çalıştırılabilirinin adı, yeri ve mevcudiyeti PHP'nin sisteminize nasıl kurulduğuna bağlı olarak değişecektir. make çalıştırıldığında öntanımlı olarak, hem CGI hem de CLI derlenir ve PHP kaynak ağacında sapi/cgi/php-cgi ve sapi/cli/php dizinlerine ayrı yerleştirilirler. Her ikisinin de adının php olduğunu farkedeceksiniz. make install çalıştırıldığında ne yaşanacağı yapılandırma satırınıza bağlıdır. Eğer yapılandırma sırasında apxs gibi bir SAPI modülü seçildiyse, veya --disable-cgi seçeneği kullanıldıysa, make install sırasında CLI {PREFIX}/bin/php dizinine kopyalanır, aksi takdirde buraya CGI yerleştirilir. Örneğin, --with-apxs yapılandırma satırınızda ise make install sırasında CLI {PREFIX}/bin/php dizinine kopyalanır. Eğer CGI kurulumunu etkisiz kılmak isterseniz, make install'dan sonra make install-cli kullanın. Ya da yapılandırma satırınızda --disable-cgi belirtebilirsiniz.

Bilginize:

--enable-cli ve --enable-cgi öntanımlı olarak etkinleştirildiği için, yapılandırma satırınızda sadece --enable-cli olması CLI'nin make install sırasında {PREFIX}/bin/php dizinine kopyalanacağı anlamına gelmez.

PHP 4.2.0 ve PHP 4.2.3 arasındaki Windows paketlerinde CLI php-cli.exe olarak, CGI da aynı dizinde php.exe olarak dağıtılmıştır. PHP 4.3.0'la başlayarak Windows paketlerinde CLI, cli adlı farklı bir dizinde php.exe olarak dağıtılmıştır, böylece cli/php.exe olmuştur. PHP 5'le başlayarak, CLI ana dizinde php.exe adıyla dağıtılmıştır. CGI sürümü php-cgi.exe olarak dağıtılmaktadır.

PHP 5'den beri, CLI sürümü ana dizinde php.exe isminde CGI sürümü ise php-cgi.exe isminde bir dosya ile dağıtılmaktadır. Buna ek olarak, PHP'nin --enable-cli-win32 ile yapılandırılması halinde dağıtım php-win.exe dosyasını da içerir. php-win.exe CLI sürümü ile aynıdır, fakatphp-win.exe herhangi çıktı vermez, bu nedenle konsolu desteklemez (ekranda "dos penceresi" görünmez).

Bilginize: Bende hangi SAPI var?

Kabuktan, php -v yazımı php CGI mı CLI mi olduğunu söyler. Ayrıca php_sapi_name() işlevine ve PHP_SAPI sabitine bakınız.

Bilginize:

PHP 4.3.2'de bir Unix kılavuz (man) sayfası eklendi. Bunu kabuk ortamında man php yazarak görüntüleyebilirsiniz.

Komut satırından kullanım
Diğer SAPI'lerden dikkate değer farklılıklar
Komut satırından kullanım


Diğer SAPI'lerden dikkate değer farklılıklar

CLI SAPI'nin diğer SAPI'lerden dikkate değer farklılıkları:

  • CLI SAPI'den farklı olarak, çıktıya hiçbir başlık yazılmaz.

    CGI SAPI HTTP başlıklarını önlemek için bir yol sunsa da, CLI SAPI'de onları etkinleştirecek eşdeğer bir seçenek yoktur.

    CLI öntanımlı olarak sessiz kipte başlar, -q ve --no-header seçenekleri eski CGI betiklerinin kullanımına uyumluluk için tutulmaktadır.

    Çalışma dizinini betiğinki ile aynı yapmaz. (-C ve --no-chdir seçenekleri uyumluluk için tutulmaktadır)

    Düz metin hata iletileri (HTML biçimlendirmesi yok).

  • Kabuk ortamında birşey ifade etmedikleri için CLI SAPI tarafından geçersiz kılınan bazı php.ini yönergeleri vardır:

    Geçersiz kılınan php.ini yönergeleri
    Yönerge | CLI SAPI öntanımlı değeri | Yorum
    html_errors | FALSE | Hata iletileri HTML etiketleri ile karıştırılmışken, kabukta bunları okumak oldukça zor olacağı için bu yönerge öntanımlı olarak FALSE değerlidir.
    implicit_flush | TRUE | Kabuk ortamında, print, echo ve arkadaşlarından gelen çıktıların önbellekte tutulmadan hemen çıktıya yazılması istenir. Eğer standart çıktıyı ertelemek veya işlemek isterseniz çıktı önbellekleme kullanabilirsiniz.
    max_execution_time | 0 (sınırsız) | HTML üretmek için yazılan uygulamalar genellikle çok çabuk işletilse de, kabuk ortamlarında PHP kullanımının sonsuz olasılığı olduğu için, kabuk uygulamaları daha fazla işletim zamanı harcama eğilimindedirler, bu nedenle azami işletim süresi sınırsız olarak belirtilmiştir.
    register_argc_argv TRUE

    Bu ayarın TRUE olması, CLI SAPIde çalıştırılan betiklerin argc (uygulamaya aktarılan değiştirge sayısı) ve argv (gerçek değiştirgeler dizisi) değerlerine her zaman erişebilmesi anlamına gelir.

    CLI SAPI kullanırken $argc ve $argv PHP değişkenleri uygun değerlere ayarlanır. Bu değerleri $_SERVER dizisinde de bulabilirsiniz. Örnek: $_SERVER['argv']

    output_buffering FALSE

    Bu yönergenin öntanımlı değeri FALSE olmasına rağmen Çıktı tamponlama işlevleri kullanılabilmektedir. functions are available.

    max_input_time FALSE

    PHP CLI, GET, POST ve dosyaların karşıya yüklenmesini desteklemez.

    Bilginize:

    Bu yönergeler php.ini yapılandırma dosyasından veya özel bir yapılandırma dosyasından başka bir değerle ilklendirilemezler. Bu sınırlamanın sebebi bu değerlerin bütün yapılandırma dosyaları çözümlendikten sonra uygulanmasıdır. Fakat, çalışma anında bunların değerleri değişirilebilir (olsa da register_argc_argv gibi bazıları için bu bir şey değiştirmez).

    Bilginize:

    Komut satırı betikleri için ignore_user_abort yönergesinin On olması önerilir. Daha fazla bilgi için ignore_user_abort() işlevine bakınız.

  • Kabuk ortamında G/Ç akımları ile kolay çalışmak için bazı sabitler tanımlanmıştır.

  • CLI SAPI geçerli dizini betiğin işletildiği dizine değiştirmez.

    Örnek 1 - CLI SAPI farkını gösteren örnek:

    <?php
    // deneme.php isimli basit deneme uygulamamız
    echo getcwd(), "\n";
    ?>

    CGI sürümününü kullanınca, çıktı şöyle olur:

    $ pwd
/tmp

$ php -q bir_dizin/deneme.php
/tmp/bir_dizin

    Bu açıkça gösteriyor ki PHP geçerli dizinini betiğin çalıştığı dizine değiştiriyor.

    CLI SAPI kullanımı sonucu:

    $ pwd
/tmp

$ php -f bir_dizin/deneme.php
/tmp

    Bu, PHP'de kabuk araçları yazarken daha fazla esneklik imkanı verir.

    Bilginize:

    CGI SAPI bu CLI SAPI davranışını komut satırından çalışırken -C seçeneği ile destekler.

Giriş
Seçenekler
Komut satırından kullanım


Komut satırı seçenekleri

PHP çalıştırılabiliri tarafından desteklenen komut satırı seçenekleri listesi istenirse PHP -h seçeneği ile çalıştırılarak sorgulanabilir:

Kullanım: php [seçenekler] [-f] <dosya> [--] [değiştirgeler...]
  php [seçenekler] -r <kod> [--] [değiştirgeler...]
  php [seçenekler] [-B <başlangıç_kodu>] -R <kod> [-E <bitiş_kodu>] [--] [değiştirgeler...]
  php [seçenekler] [-B <başlangıç_kodu>] -F <dosya> [-E <bitiş_kodu>] [--] [değiştirgeler...]
  php [seçenekler] -- [değiştirgeler...]
  php [seçenekler] -a

  -a               Etkileşimli çalışır
  -c <yol>|<dosya> php.ini dosyası bu dizinde aranır
  -n               Hiçbir php.ini dosyası kullanılmayacak
  -d foo[=bar]     'bar' değerli bir foo INI girdisi tanımlar
  -e               Hata ayıklayıcı/profilci için genişletilmiş bilgi üretir
  -f <dosya>       <dosya>'yı çözümler ve çalıştırır
  -h               Bu yardım iletisini gösterir
  -i               PHP bilgisi
  -l               Sadece söz dizimi denetimi (lint)
  -m               Modül olarak derlenenleri gösterir
  -r <kod>         PHP <kod>unu <?..?> betik etiketleri olmadan çalıştırır
  -B <başlangıç_kodu>  PHP <başlangıç_kodu>nu girdi satırlarından önce
                   çalıştırır
  -R <kod>         PHP <kod>unu her girdi satırı için çalıştırır
  -F <dosya>       Her girdi satırı için <dosya>yı çözümler ve çalıştırır
  -E <bitiş_kodu>  PHP <bitiş_kodu>nu bütün girdi satırlarını işledikten
                   sonra çalıştırır
  -H               Harici araçlardan aktarılan bütün değiştirgeleri gizler
  -S <addr>:<port> Yerleşik HTTP sunucusu ile çalıştırır
  -t <belgekök>     Yerleşik HTTP sunucusu için belge kök dizini belirtilir
  -s               Kaynağı renklendirilmiş söz dizimi ile çıktılar
  -v               Sürüm bilgilerini gösterir
  -w               Kaynağı boşluklar ve yorumlardan arındırılmış olarak
                   çıktılar
  -z <dosya>       <dosya> Zend eklentisini yükler

  değiştirgeler... Betiğe aktarılan değiştirgeler. Eğer betik stdin'den
                   okunuyorsa veya ilk değiştirge - ile başlıyorsa
                   -- değiştirgeler kullanın

  --ini            Yapılandırma dosyası isimlerini gösterir

  --rf <isim>      <isim> işlevi hakkında bilgi gösterir
  --rc <isim>      <isim> sınıfı hakkında bilgi gösterir
  --re <isim>      <isim> eklentisi hakkında bilgi gösterir
  --rz <isim>      <isim> Zend eklentisi hakkında bilgi gösterir
  --ri <isim>      <isim> eklentisi için yapılandırmayı gösterir

Komut satırı seçenekleri
Seçenek | Uzun Seçenek | Açıklama
-a --interactive

PHP'yi etkileşimli çalıştırır.Daha ayrıntılı bilgi için Etkileşimli kabuk konusuna bakınız.

-b --bindpath

Harici FASTCGI Sunucusu kipi için dizin yolu (sadece CGI için).

-C --no-chdir

Betiğin bulunduğu dizine chdir yapılmaz (sadece CGI için).

-q --no-header

Sessiz kip. HTTP başlığının çıktılanmasını engeller (sadece CGI için).

-T --timing

Betiğin çalışma süresini sayı kere ölçer (sadece CGI için).

-c --php-ini

Bu seçenek php.ini dosyasının aranacağı dizini veya özel bir INI dosyasını (adı php.ini olmak zorunda değildir) belirtebilir. Örneğin:

$ php -c /ozel/dizin/ ornek_betik.php

$ php -c /ozel/dizin/ozel-dosya.ini ornek_betik.php

Eğer bu seçeneği belirtmezseniz, php.ini öntanımlı dizinlerde aranır.

-n --no-php-ini

php.iniyi tamamen görmezden gel.

-d --define

php.inide izin verilen yapılandırma yönergelerinden herhangi birine özel değer atamanıza imkan verir. Söz dizimi:

-d ayar_yönergesi[=değer]

# Değer kısmını atlamak yapılandırma yönergesini "1" yapar
$ php -d max_execution_time
        -r '$foo = ini_get("max_execution_time"); var_dump($foo);'
string(1) "1"

# Boş değer aktarınca yapılandırma yönergesinine "" atanır
php -d max_execution_time=
        -r '$foo = ini_get("max_execution_time"); var_dump($foo);'
string(0) ""

# Yapılandırma yönergesine '=' karakterinden sonra aktarılan değer atanır
$  php -d max_execution_time=20
        -r '$foo = ini_get("max_execution_time"); var_dump($foo);'
string(2) "20"
$  php
        -d max_execution_time=herhangi_bir_sey
        -r '$foo = ini_get("max_execution_time"); var_dump($foo);'
string(15) "herhangi_bir_sey"

-e --profile-info

Hata ayıklayıcı/profilci için kullanılmak üzere genişletilmiş bilgi kipini etkinleştirir.

-f --file

Belirtilen dosya adını çözümler ve çalıştırır. -f seçeneği isteğe bağlıdır; verilmese de olur. Sadece çalıştırılacak dosya adını belirtmek yeterlidir.

Bilginize:

Betiğe değiştirge aktarmak için ilk değiştirge -- olmalıdır, aksi halde PHP bunları PHP seçeneği olarak yorumlar.

-h ve -? | --help ve --usage | Komut satırı seçenekleri tek satırlık açıklamalarıyla listelenir.
-i | --info | phpinfo() işlevini çağırır ve sonuçları yazdırır. Eğer PHP doğru çalışmıyorsa, php -i komutunu kullanmanız ve bilgi tablolarından önce herhangi bir hata iletisi yazdırılmış mı diye bakmanız tavsiye edilir. CGI kipini kullanırken çıktının HTML biçiminde olacağını ve bu nedenle çok büyük ve karmaşık olacağını dikkate alınız.
-l --syntax-check

Bu seçenek verilen PHP kodunun sadece söz dizimini denetlemek için uygun bir yol sağlar. Başarı halinde, No syntax errors detected in <filename> metni standart çıktıya yazılır ve kabuk dönüş kodu 0 olur. Başarısızlık halinde, iç çözümleyici hatasına ilaveten Errors parsing <filename> metni standart çıktıya yazılır ve kabuk dönüş kodu -1 olur.

Bu seçenek ölümcül hataları bulamaz (tanımlanmamış işlevler gibi). Ölümcül hataları da denetlemek için -f seçeneğini kullanın.

Bilginize:

Bu seçenek -r seçeneği ile birlikte kullanılamaz.

-m --modules

Örnek 1 - Yerleşik (ve yüklü) PHP ve Zend modüllerinin listelenmesi

$ php -m
[PHP Modules]
xml
tokenizer
standard
session
posix
pcre
overload
mysql
mbstring
ctype

[Zend Modules]

-r --run

PHP'nin komut satırından çalıştırılmasına izin verir. PHP başlangıç ve bitiş etiketleri (<?php ve ?>) gerekmez ve eğer bulunurlarsa çözümleme hatasına neden olurlar.

Bilginize:

PHP'nin bu şekilde kullanımı halinde kabuk tarafından yapılan komut satırı değişken değişimleri ile çakışmamak için özen göstermek gerekir.

Örnek 2 Çift tırnak kullanımında bir çözümleme hatasının gösterilmesi

$ php -r "$foo = get_defined_constants();"
Command line code(1) : Parse error - parse error, unexpected '='

Buradaki sorun sh/bash kabuklarının çift tırnak " kullanıldığında bile değişken değişimi yapmalarından kaynaklanır. $foo değişkeni kabukta tanımlanmış olmayacağı için, PHP'ye çalıştırılmak üzere aktarılan kodda hiçbir şey olarak yorumlanacaktır:

$ php -r " = get_defined_constants();"

Doğru yol tek tırnak ' kullanımıdır. Tek tırnak içindeki değişkenler sh/bash tarafından dönüştürülmezler.

Örnek 3 Kabuğun değişken dönüşümü yapmasını engellemek için tek tırnakların kullanımı

$ php -r '$foo = get_defined_constants(); var_dump($foo);'
array(370) {
  ["E_ERROR"]=>
  int(1)
  ["E_WARNING"]=>
  int(2)
  ["E_PARSE"]=>
  int(4)
  ["E_NOTICE"]=>
  int(8)
  ["E_CORE_ERROR"]=>
  [...]

Eğer sh/bash haricinde bir kabuk kullanıyorsanız, daha farklı sorunlarla karşılaşabilirsiniz. Bu gibi durumlarda » http://bugs.php.net/ adresinde hata raporu açmaktan çekinmeyiniz. Kabuk değişkenlerini kodunuza almaya çalıştığınızda veya önceleme için ters bölü kullanımında sıkıntılar yaşayabilirsiniz.

Bilginize:

-r seçeneği CLI SAPI'de bulunur, CGI SAPI'de bulunmaz.

Bilginize:

Bu seçenek çok temel kodlar için tasarlanmıştır. Bazı yapılandırma yönergeleri (örn. auto_prepend_file ve auto_append_file) bu kipte görmezden gelinir.

-B --process-begin

Standart girdi işlenmeden çalıştırılacak PHP kodudur. PHP 5'de eklenmiştir.

-R --process-code

Her girdi satırı için işletilecek PHP kodudur. PHP 5'de eklenmiştir.

Bu kipte iki özel değişken bulunur: $argn ve $argi. $argn PHP'nin o anda işlediği satırı içerirken, $argi satır numarasını içerir.

-F --process-file

Her girdi satırı için işletilecek PHP dosyasıdır. PHP 5'de eklenmiştir.

-E --process-end

Girdi işlendikten sonra işletilecek PHP kodudur. PHP 5'de eklenmiştir.

Örnek 4 - Bir projedeki satır sayısını saymak için -B , -R ve -E seçeneklerinin kullanımı

$ find projem | php -B '$l=0;' -R '$l += count(@file($argn));' -E 'echo "Toplam Satır Sayısı: $l\n";'
Toplam Satır Sayısı: 37328

-S --server

Yerleşik HTTP sunucusunu başlatır. PHP 5.4.0'dan beri kullanılabilmektedir.

-t | --docroot | Yerleşik HTTP sunucusuna belge kökünü belirtir. PHP 5.4.0'dan beri kullanılabilmektedir.
-s --syntax-highlight ve --syntax-highlighting

Renklendirilmiş söz dizimi ile kaynak gösterimi.

Bu seçenek dosyayı çözümlemek için içsel yöntemleri kullanır ve renklendirilmiş bir HTML sürümü üreterek standart çıktıya yazar. Bütün yaptığı HTML başlıkları olmadan <code> [...] </code> HTML etiketlerinden oluşan bir blok üretmektir.

Bilginize:

Bu seçenek -r seçeneği ile birlikte çalışmaz.

-v --version

Örnek 5 PHP ve Zend sürümleri ile SAPI ismini çıktılamak için -v kullanımı

$ php -v
PHP 5.3.0alpha3-dev (cli) (built: Nov 13 2008 18:20:00)
Copyright (c) 1997-2008 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2008 Zend Technologies

-w --strip

Kaynağı boşluklar ve yorumlardan arındırılmış olarak gösterir.

Bilginize:

Bu seçenek -r seçeneği ile birlikte çalışmaz.

-z --zend-extension

Zend eklentisini yükler. Eğer sadece dosya ismi verilirse, PHP bu eklentiyi sisteminizde geçerli öntanımlı kütüphane yolundan yüklemeye çalışır (Linux sistemlerde genellikle /etc/ld.so.conf dosyasında belirtilir). Dosya adı tam yol bilgisi ile aktarılırsa sistem kütüphanesi arama yolu kullanılmaz. Bir dizin bilgisiyle göreceli bir dosya ismi kullanımı PHP'ye sadece geçerli dizine göreceli eklentinin yüklenmesini söyler.

--ini

Yapılandırma dosya isimlerini ve taranan dizinleri gösterir. PHP 5.2.3'den beri mevcuttur.

Örnek 6 --ini örneği

$ php --ini
Configuration File (php.ini) Path: /usr/dev/php/5.2/lib
Loaded Configuration File:         /usr/dev/php/5.2/lib/php.ini
Scan for additional .ini files in: (none)
Additional .ini files parsed:      (none)
--rf --rfunction

Verilen işlev veya sınıf yöntemi hakkında bilgi gösterir (örneğin, değiştirge adlarını ve sayısını). PHP 5.1.2'den beri vardır.

Bu seçenek sadece PHP Reflection desteği ile derlendiyse mevcuttur.

Örnek 7 - Temel --rf kullanımı

$ php --rf var_dump
Function [ <internal> public function var_dump ] {

  - Parameters [2] {
    Parameter #0 [ <required> $var ]
    Parameter #1 [ <optional> $... ]
  }
}
--rc --rclass

Verilen sınıf hakkında bilgi gösterir (sabitler, özellikler ve yöntemler listesi). PHP 5.1.2'den beri vardır.

Bu seçenek sadece PHP Reflection desteği ile derlendiyse mevcuttur.

Örnek 8 --rc örneği

$ php --rc Directory
Class [ <internal:standard> class Directory ] {

  - Constants [0] {
  }

  - Static properties [0] {
  }

  - Static methods [0] {
  }

  - Properties [0] {
  }

  - Methods [3] {
    Method [ <internal> public method close ] {
    }

    Method [ <internal> public method rewind ] {
    }

    Method [ <internal> public method read ] {
    }
  }
}
--re --rextension

Verilen eklenti hakkında bilgi gösterir (php.ini seçenekleri, tanımlı işlevler, sabitler ve sınıflar listesi). PHP 5.1.2'den beri vardır.

Bu seçenek sadece PHP Reflection desteği ile derlendiyse mevcuttur.

Örnek 9 --re örneği

$ php --re json
Extension [ <persistent> extension #19 json version 1.2.1 ] {

  - Functions {
    Function [ <internal> function json_encode ] {
    }
    Function [ <internal> function json_decode ] {
    }
  }
}
--rz --rzendextension

Belirtilen Zend eklentisi için yapılandırma bilgisini gösterir (bu bilgi phpinfo() ile de elde edilebilir). PHP 5.4.0'dan beri kullanılabilmektedir.

--ri --rextinfo

Verilen eklenti için yapılandırma bilgisini gösterir (phpinfo() ile aynı bilgiyi döndürür). PHP 5.2.2'den beri vardır. Çekirdek yapılandırma bilgisi "main" eklenti adı kullanılarak bulunabilir.

Örnek 10 --ri örneği

$ php --ri date

date

date/time support => enabled
"Olson" Timezone Database Version => 2008.20
Timezone Database => internal
Default timezone => Europe/Helsinki

Directive => Local Value => Master Value
date.timezone => no value => no value
date.default_latitude => 31.7667 => 31.7667
date.default_longitude => 35.2333 => 35.2333
date.sunset_zenith => 90.583333 => 90.583333
date.sunrise_zenith => 90.583333 => 90.583333

Bilginize:

Uzun seçenekler (--no-chdir gibi) PHP 4.3.3'ten beri kullanılabilmektedir.

Bilginize:

-rBRFEH, --ini ve --r[fcezi] seçenekleri sadece CLI'de kullanılabilir.

Diğer SAPI'lerden dikkate değer farklılıklar
Kullanım
Komut satırından kullanım


PHP dosyalarının çalıştırılması

CLI SAPI çalıştırmak istediğiniz PHP kodunu getirmek için üç farklı yola sahiptir:

  1. PHP'ye belli bir dosyayı çalıştırmasını söyleyerek.

    php ornek_betik.php

php -f ornek_betik.php

    Her iki yolla da (-f seçeneğini olsun olmasın) ornek_betik.php dosyası çalıştırılır. Çalıştırmak için herhangi bir dosyayı seçebilirsiniz - PHP betikleriniz .php uzantısı ile bitmek zorunda değildir, istediğiniz herhangi bir isim ve uzantıya sahip olabilirler.

    Bilginize:

    Eğer betiklerinize değiştirgeler aktarmanız gerekirse -f seçeneğini kullandığınızda ilk değiştirge olarak -- aktarmanız gerekir.

  2. Doğrudan komut satırında işletmek üzere PHP kodunu aktararak.

    php -r 'print_r(get_defined_constants());'

    Kabuk değişken değişimi ve tırnak kullanımı için özel bir çaba sarfetmek gerekir.

    Bilginize:

    Örneği dikkatle okuyunuz, hiçbir başlangıç veya bitiş etiketi yok! -r seçeneği bunlara ihtiyaç duymaz. Bunların kullanımı çözümleme hatasına yol açar.

  3. Çalıştırılacak PHP kodunu standart girdiden (stdin) yollamak suretiyle.

    Bu, PHP kodunu devingen olarak oluşturma ve bunu çalıştırma yeteneği sağlar. Örneğin:

    $ bir_uygulama | bir_suzgec | php | sort -u > nihai_sonuc.txt
Kodu çalıştırmak için bu üç yol birlikte kullanılamaz.

Her kabuk uygulamasındaki gibi, PHP çalıştırılabiliri bir takım değiştirgeler alabildiği gibi PHP betiğiniz de değiştirgeler alabilir. Betiğinize aktarabileceğiniz değiştirge sayısı PHP tarafından sınırlandırılmamıştır (kabukta aktarılabilecek karakter sayısı sınırlıdır; genellikle bu sınıra ulaşmazsınız). Betiğinize aktarılan değiştirgeler $argv küresel dizisinde bulunur. Sıfır indisi her zaman betik adını içerir. PHP kodu standart girdiden veya -r komut satırı seçeneğiyle çalıştıysa betik adı - olur. Eğer kod standart girdiden bir boru ile çalıştırılırsa bu yine geçerlidir.

İkinci kayıtlı küresel değişken $argc'dir ve $argv dizisindeki eleman sayısını içerir (betiğe aktarılan değiştirge sayısını değil).

Betiğinize aktarmak istediğiniz değiştirgeler - karakteriyle başlamadığı sürece, özel bir şeye dikkat etmeniz gerekmez. Betiğinize - ile başlayan bir değiştirge aktarımı sorun yaratır çünkü PHP yorumlayıcısı bunu kendisinin işlemesi gerektiğini düşünecektir. Bunu önlemek için, değiştirge listesi ayracı olan -- kullanın, bunu izleyen her değiştirge ellenmeden betiğinize aktarılır.

# Bu verilen kodu çalıştırmaz fakat PHP kullanımını gösterir
$ php -r 'var_dump($argv);' -h
Usage: php [options] [-f] <file> [args...]
[...]

# Bu '-h' değiştirgesini betiğinize aktarır ve
# PHP'nin değiştirgeyi görmesini önler
$ php -r 'var_dump($argv);' -- -h
array(2) {
  [0]=>
  string(1) "-"
  [1]=>
  string(2) "-h"
}

Kabuk betikleri için PHP farklı bir yoldan kullanılabilir. İlk satırı #!/usr/bin/php ile başlayan bir betik yazabilirsiniz. Bunu takip eden satırlara başlangıç ve bitiş etiketlerine sahip normal PHP kodunuzu yerleştirebilirsiniz. Dosyanın çalıştırma izinlerini ayarladığınızda (örn. chmod +x deneme) betiğiniz normal bir kabuk veya perl betiği gibi işletilir.

Örnek 1 - PHP betiğini kabuk betiği olarak çalıştırmak

#!/usr/bin/php
<?php
var_dump($argv);
?>

Geçerli dizindeki bu dosyanın isminin deneme olduğunu varsayarsak, aşağıdakini yapabiliriz:

$ chmod +x deneme
$ ./deneme -h -- foo
array(4) {
  [0]=>
  string(6) "./deneme"
  [1]=>
  string(2) "-h"
  [2]=>
  string(2) "--"
  [3]=>
  string(3) "foo"
}

Gördüğünüz gibi, bu durumda betiğinize - ile başlayan değiştirge aktarırken hiçbir şeye dikkat etmeniz gerekmez.

PHP çalıştırılabiliri HTTP sunucusundan tamamen bağımsız olarak PHP betikleri çalıştırmak için kullanılabilir. Eğer Unix sistemi üzerindeyseniz, PHP betiğinizin başına özel bir #! satırı eklemeli ve dosyanızı çalıştırılabilir yapmalısınız; böylece sistem betiğinizi hangi programın çalıştıracağını bilir. Windows üzerinde .php dosyalarına çift tıklama seçeneği ile php.exeilişkilendirebilir veya betiği PHP üzerinden çalıştıracak bir yığın dosyası yapabilirsiniz. Unix'de çalışması için betiğe eklenen ilk satır Windows'da sorun çıkarmaz, böylece platformdan bağımsız programlar yazabilirsiniz. Örnek basit bir komut satırı PHP programı aşağıdaki gibi olabilir.

Örnek 2 - Komut satırından çalıştırılması planlanan betik (betik.php)

#!/usr/bin/php
<?php

if ($argc != 2 || in_array($argv[1], array('--help', '-help', '-h', '-?'))) {
?>
Bu tek seçenekli bir komut satırı PHP betiğidir.

  Kullanımı:
  <?php echo $argv[0]; ?> <secenek>

  <secenek> yazdırmak istediğiniz bir kelime olabilir.
  --help, -help, -h,
  veya -? seçenekleriyle, bu yardımı alabilirsiniz.

<?php
} else {
    echo $argv[1];
}
?>

Yukarıdaki betikte, bu dosyanın PHP tarafından çalıştırılması gerektiğini belirten özel bir ilk satır kullandık. Burada CLI sürümü ile çalışıyoruz, böylece HTTP başlık çıktıları olmayacak. PHP ile komut satırı uygulamaları yazarken kullanabileceğiniz iki değişken vardır: $argc ve $argv. Birincisi değiştirge sayısından bir fazlasıdır (çalışan betiğin adı). İkincisi değiştirgeleri içeren bir dizidir, sıfır numarayla başlar ve ilk elemanında betik adını içerir ($argv[0]).

Yukarıdaki programda birden farklı sayıda değiştirge olup olmadığı kontrol ettik. Ayrıca eğer değiştirge --help , -help , -h veya -? ise yardım iletisini yazdırdık ve $argv[0] ile betik adını devingen olarak yazdırdık. Bunlardan başka değiştirgeler aldıysak bunlar yerine onları yazdırdık.

Eğer yukarıdaki betiği Unix üzerinde çalıştırmak isterseniz betiği çalıştırılabilir yapmalı ve betik.php echothis veya betik.php -h ile çağırmalısınız. Windows'da bu iş için bir yığın dosyası yapabilirsiniz:

Örnek 3 - Bir komut satırı PHP betiği çalıştırmak için yığın dosyası (betik.bat)

@echo OFF
"C:\php\php.exe" script.php %*

Yukarıdaki programı betik.php olarak adlandırdığınız ve C:\php\php.exe içinde CLI'nin php.exe olduğu varsayılarak bu yığın dosyası sizin eklediğiniz seçeneklerle çalışacaktır: betik.bat echothis veya betik.bat -h.

PHP'deki komut satırı uygulamalarını iyileştirmek için kullanabileceğiniz işlevlerle ilgili bilgi için Readline eklentisinin belgesine bakınız.

Windows üzerindeyseniz PHP, Microsoft Windows üzerinde PHP Komut Satırı bölümünde açıklandığı gibi .php uzantısına veya C:\php\php.exe çalıştırılabilirinin belirtilmesine gerek kalmadan çalıştırılmak üzere yapılandırılabilir.

Seçenekler
G/Ç Akımları
Komut satırından kullanım


Giriş/Çıkış Akımları

Kabuk ortamında G/Ç akımları ile kolay çalışmak için şu sabitler tanımlanmıştır:

CLI'ye özel Sabitler
Sabit Açıklama
STDIN

stdin'e açılmış bir akımdır. Aşağıdaki örnek akımı açıp geleni kaydeder:

<?php

$stdin = fopen('php://stdin', 'r');

?>
Eğer stdin'den tek satır okumak istenirse şu kullanılabilir:
<?php
$line = trim(fgets(STDIN));     //  STDIN'den bir satır okur
fscanf(STDIN, "%d\n", $number); // STDIN'den sayı okur
?>

STDOUT

stdout'a açılmış bir akımdır. Aşağıdaki örnek akımı açıp gideni kaydeder:

<?php

$stdout = fopen('php://stdout', 'w');

?>

STDERR

stderr'e açılmış bir akımdır. Aşağıdaki örnek akımı açıp çıktıyı kaydeder:

<?php

$stderr = fopen('php://stderr', 'w');

?>

Yukarıda verilene göre, örneğin stderr için bir akım açmanız gerekmez, ancak akım kaynağı yerine sabit kullanabilirsiniz:

php -r 'fwrite(STDERR, "stderr\n");'
Betik sonlandığında PHP özdevinimli olarak akımları kapattığı için sizin ayrıca kapatmanız gerekmez.

Bilginize:

Bu sabitler, PHP betiğinin stdin'den okunması halinde mevcut değildir.

Kullanım
Etkileşimli kabuk
Komut satırından kullanım


Etkileşimli kabuk

PHP 5.1.0'dan itibaren, PHP --with-readline seçeneği ile derlenmişse, CLI SAPI -a seçeneği kullanıldığında etkileşimli bir kabuk açar.

Etkileşimli kabuğu kullanarak PHP kodu yazabilir ve bunları doğrudan çalıştırabilirsiniz.

Örnek 1 - Etkileşimli kabuk kullanarak kod çalıştırmak

$ php -a
Interactive shell

php > echo 5+8;
13
php > function ikiEkle($n)
php > {
php { return $n + 2;
php { }
php > var_dump(ikiEkle(2));
int(4)
php >

Etkileşimli kabuk ayrıca, işlevler, sabitler, sınıf isimleri, değişkenler duruk yöntem çağrıları ve sınıf sabitleri için sekme ile kod tamalama özelliklerine sahiptir.

Örnek 2 Kod tamamlama

Sekme tuşuna iki kere basarak yazdığınız harflerle başlayan anahtar sözcükleri listeleyebilirsiniz:

php > strp[TAB][TAB]
strpbrk   strpos    strptime
php > strp

Olası tek seçenek olduğunda sekme tuşuna ilk basışınızda sözcük aynı satırda tamamlanır:

php > strpt[TAB]ime(

Tamamlama, bulunduğunuz etkileşimli kabuk ortamında tanımlanmış isimler için de çalışacaktır::

php > $fooThisIsAReallyLongVariableName = 42;
php > $foo[TAB]ThisIsAReallyLongVariableName

Etkileşimli kabukta yukarı ve aşağı ok tuşlerını kullanarak geçmiş üzerinde dolaşabilirsiniz. Geçmiş ~/.php_history dosyasına kaydedilir.

PHP 5.4.0'dan itibaren, cli.pager ve cli.prompt php.ini değişkenleri devreye girmiştir. cli.pager ile çıktıyı ekranda göstermek yerine çıktıyı sayfalayacak bir programda (less gibi) göstermek mümkündür. cli.prompt ile php > çıktısını değiştirebilirsiniz.

PHP 5.4.0'dan itibaren, php.ini ayarlarını etkileşimli kabukta bir kısayol ile değiştirmek de mümkündür.

Örnek 3 Etkileşimli kabukta php.ini ayarlarını değiştirmek

cli.prompt ile:

php > #cli.prompt=hello world :>
hello world :>

Ters tırnakları kullanarak komut isteminde kod çalıştırabilirsiniz:

php > #cli.prompt=`echo date('H:i:s');` php >
15:49:35 php > echo 'hi';
hi
15:49:43 php > sleep(2);
15:49:45 php >

Sayfalayıcı olarak less belirtmek:

php > #cli.pager=less
php > phpinfo();
(çıktı less içinde gösterilir)
php >

cli.prompt içinde bir kaç öncelem belirtilebilir:

- cli.prompt öcelemleri
Öncelem | Açıklama
\e | Komut istemine renk eklemek için kullanılır. Örnek: \e[032m\v \e[031m\b \e[34m\> \e[0m
\v | PHP sürümü.
\b | Neyin içindekinin engelleneceğini belirtir. Örneğin, çok satırlı bir açıklama içinde olmayı belirtmek için: /* Dış kapsam php tarafından belirtilir.
\> | Komut istemi karakterini belirtir. By default this is > öntanımlı olsa da kabuk sonlandırılmamış bir dizge veya blok içindeyse bu değişir. Olası karakterler: ' " { ( >

Bilginize:

auto_prepend_file ve auto_append_file ile içselleştirilen dosyalar bu kipte bazı sınırlamalarla çözümlenebilir; örneğin çağrılmadan önce işlevler bu dosyalarda tanımlanabilir.

Bilginize:

PHP CLI etkileşimli kipte kullanılıyorsa Özdevinimli Sınıf Yükleme kullanılamaz.

G/Ç Akımları
Yerleşik HTTP sunucusu
Komut satırından kullanım


Yerleşik HTTP sunucusu

Uyarı

Bu HTTP sunucusu uygulama geliştirmeye yardımcı olmak üzere tasarlanmıştır. Ayrıca, denetimli bir ortam olarak uygulamaların denenmesi amacıyla da kullanılabilir. Herşeyiyle eksiksiz bir HTTP sunucusu olarak tasarlanmamıştır. Halka açık ağlarda kullanılmamalıdır.

PHP 5.4.0'dan itibaren, CLI SAPI yerleşik bir HTTP sunucusu içermektedir.

Bu HTTP sunucusu tek evreli bir süreç çalıştırır. Dolayısıyla, PHP uygulamaları istek engellendiği zaman yavaşlayıp duracaktır.

İstenen adres PHP'nin başlatıldığı çalışma dizinine göre sunulur. Bu kök dizin PHP çalıştırılırken -t seçeneği kullanılarak değiştirlebilir. İstek bir dosya belirtmiyorsa belirtilen dizindeki index.php veya index.html dosyası sunulur. Bu iki dosya da mevcut değilse index.php veya index.html araması üst dizinde devam eder ve bu belge kök dizinine ulaşılıncaya dek devam eder. Bulunduğu takdirde, döndürülür ve URI'nin devamına $_SERVER['PATH_INFO'] atanır. Aksi takdirde 404 yanıt kodu döndürülür.

İstenen adres bir dosya belirtmezse, belirtilen dizindeki index.php veya index.html gösterilir. Bu dosyalar da mevcut değilse, bir 404 yanıtı döndürülür.

.3gp,.apk, .avi, .bmp, .css, .csv, .doc, .docx, .flac, .gif, .gz, .gzip, .htm, .html, .ics, .jpe, .jpeg, .jpg, .js, .kml, .kmz, .m4a, .mov, .mp3, .mp4, .mpeg, .mpg, .odp, .ods, .odt, .oga, .ogg, .ogv, .pdf, .pdf, .png, .pps, .pptx, .qt, .svg, .swf, .tar, .text, .tif, .txt, .wav, .webm, .wmv, .xls, .xlsx, .xml, .xsl, .xsd ve .zip uzantılı dosyalar için standart MIME türleri döndürülür.

Desteklenen MIME Türleri (dosya uzantıları) için değişiklik bilgisi
Sürüm: | Açıklama
5.5.12 | .xml, .xsl ve .xsd
5.5.7 | .3gp, .apk, .avi, .bmp, .csv, .doc, .docx, .flac, .gz, .gzip, .ics, .kml, .kmz, .m4a, .mp3, .mp4, .mpg, .mpeg, .mov, .odp, .ods, .odt, .oga, .pdf, .pptx, .pps, .qt, .swf, .tar, .text, .tif, .wav, .wmv, .xls, .xlsx ve .zip
5.5.5 | .pdf
5.4.11 | .ogg, .ogv ve .webm
5.4.4 | .htm ve .svg

Örnek 1 HTTP sunucusunun başlatılması

$ cd ~/public_html
$ php -S localhost:8000

Uçbirim çıktısı:

PHP 5.4.0 Development Server started at Thu Jul 21 10:43:28 2011
Listening on localhost:8000
Document root is /home/me/public_html
Press Ctrl-C to quit

http://localhost:8000/ ve http://localhost:8000/myscript.html isteklerinden sonra uçbirim çıktısı şuna benzer:

PHP 5.4.0 Development Server started at Thu Jul 21 10:43:28 2011
Listening on localhost:8000
Document root is /home/me/public_html
Press Ctrl-C to quit.
[Thu Jul 21 10:48:48 2011] ::1:39144 GET /favicon.ico - Request read
[Thu Jul 21 10:48:50 2011] ::1:39146 GET / - Request read
[Thu Jul 21 10:48:50 2011] ::1:39147 GET /favicon.ico - Request read
[Thu Jul 21 10:48:52 2011] ::1:39148 GET /myscript.html - Request read
[Thu Jul 21 10:48:52 2011] ::1:39149 GET /favicon.ico - Request read

Örnek 2 - Belge kök dizini belirterek başlatma

$ cd ~/public_html
$ php -S localhost:8000 -t foo/

Uçbirim çıktısı:

PHP 5.4.0 Development Server started at Thu Jul 21 10:50:26 2011
Listening on localhost:8000
Document root is /home/me/public_html/foo
Press Ctrl-C to quit

Örnek 3 - Yönlendirici betik belirtmek

Resim isteklerinde resimler gösterildiği halde bir HTML dosyası istendiğinde "Welcome to PHP" göstermek:

<?php
// router.php
if (preg_match('/\.(?:png|jpg|jpeg|gif)$/', $_SERVER["REQUEST_URI"])) {
    return false;    // kaynak olduğu gibi gösterilir.
} else {
    echo "<p>Welcome to PHP</p>";
}
?>
$ php -S localhost:8000 router.php

Örnek 4 Checking for CLI Web Server Use

Bir yönlendirici betiği geliştirici CLI sunucusunda kullandıktan sonra asıl HTTP sunucusunda yeniden kullanmak:

<?php
// router.php
if (php_sapi_name() == 'cli-server') {
    /* duruk varlıkları yönlendir ve false ile dön */
}
/* normal index.php işlemleri ile devam et */
?>
$ php -S localhost:8000 router.php

Örnek 5 Desteklenmeyen Dosya Türlerinin İşlenmesi

MIME türleri CLI sunucusu tarafından işlenmeyen duruk kaynakları sunmanız gerekirse:

<?php
// router.php
$path = pathinfo($_SERVER["SCRIPT_FILENAME"]);
if ($path["extension"] == "el") {
    header("Content-Type: text/x-script.elisp");
    readfile($_SERVER["SCRIPT_FILENAME"]);
}
else {
    return FALSE;
}
?>
$ php -S localhost:8000 router.php

Örnek 6 CLI sunucusuna uzak makinelerden erişim

HTTP sunucusuna port 8000'den şöyle erişebilirsiniz:

$ php -S 0.0.0.0:8000
Etkileşimli kabuk
INI Ayarları
Komut satırından kullanım


INI Ayarları

CLI SAPI Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
cli_server.color | "0" | PHP_INI_ALL | PHP 5.4.0'dan beri kullanılabilmektedir.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

cli_server.color boolean

Geliştirici HTTP sunucusunun uçbirim çıktısında ANSI renk kodlaması kullanımını etkinleştirir.

Yerleşik HTTP sunucusu
Garbage Collection
Komut satırından kullanım


Garbage Collection

İçindekiler

  • Reference Counting Basics
  • Collecting Cycles
  • Performance Considerations

This section explains the merits of the new Garbage Collection (also known as GC) mechanism that is part of PHP 5.3.

INI Ayarları
Reference Counting Basics
Özellikler


Reference Counting Basics

A PHP variable is stored in a container called a "zval". A zval container contains, besides the variable's type and value, two additional bits of information. The first is called "is_ref" and is a boolean value indicating whether or not the variable is part of a "reference set". With this bit, PHP's engine knows how to differentiate between normal variables and references. Since PHP allows user-land references, as created by the & operator, a zval container also has an internal reference counting mechanism to optimize memory usage. This second piece of additional information, called "refcount", contains how many variable names (also called symbols) point to this one zval container. All symbols are stored in a symbol table, of which there is one per scope. There is a scope for the main script (i.e., the one requested through the browser), as well as one for every function or method.

A zval container is created when a new variable is created with a constant value, such as:

Örnek 1 Creating a new zval container

<?php
$a = "new string";
?>

In this case, the new symbol name, a, is created in the current scope, and a new variable container is created with the type string and the value new string. The "is_ref" bit is by default set to FALSE because no user-land reference has been created. The "refcount" is set to 1 as there is only one symbol that makes use of this variable container. Note that if "refcount" is 1, "is_ref" is always FALSE. If you have » Xdebug installed, you can display this information by calling xdebug_debug_zval().

Örnek 2 Displaying zval information

<?php
xdebug_debug_zval('a');
?>

Yukarıdaki örneğin çıktısı:

a: (refcount=1, is_ref=0)='new string'

Assigning this variable to another variable name will increase the refcount.

Örnek 3 Increasing refcount of a zval

<?php
$a = "new string";
$b = $a;
xdebug_debug_zval( 'a' );
?>

Yukarıdaki örneğin çıktısı:

a: (refcount=2, is_ref=0)='new string'

The refcount is 2 here, because the same variable container is linked with both a and b. PHP is smart enough not to copy the actual variable container when it is not necessary. Variable containers get destroyed when the "refcount" reaches zero. The "refcount" gets decreased by one when any symbol linked to the variable container leaves the scope (e.g. when the function ends) or when a symbol is unassigned (e.g. by calling unset()). The following example shows this:

Örnek 4 Decreasing zval refcount

<?php
$a = "new string";
$c = $b = $a;
xdebug_debug_zval( 'a' );
$b = 42;
xdebug_debug_zval( 'a' );
unset( $c );
xdebug_debug_zval( 'a' );
?>

Yukarıdaki örneğin çıktısı:

a: (refcount=3, is_ref=0)='new string'
a: (refcount=2, is_ref=0)='new string'
a: (refcount=1, is_ref=0)='new string'

If we now call unset($a);, the variable container, including the type and value, will be removed from memory.

Compound Types

Things get a tad more complex with compound types such as arrays and objects. As opposed to scalar values, arrays and objects store their properties in a symbol table of their own. This means that the following example creates three zval containers:

Örnek 5 Creating a array zval

<?php
$a = array( 'meaning' => 'life', 'number' => 42 );
xdebug_debug_zval( 'a' );
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

a: (refcount=1, is_ref=0)=array (
   'meaning' => (refcount=1, is_ref=0)='life',
   'number' => (refcount=1, is_ref=0)=42
)

Or graphically

Zvals for a simple array

The three zval containers are: a, meaning, and number. Similar rules apply for increasing and decreasing "refcounts". Below, we add another element to the array, and set its value to the contents of an already existing element:

Örnek 6 Adding already existing element to an array

<?php
$a = array( 'meaning' => 'life', 'number' => 42 );
$a['life'] = $a['meaning'];
xdebug_debug_zval( 'a' );
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

a: (refcount=1, is_ref=0)=array (
   'meaning' => (refcount=2, is_ref=0)='life',
   'number' => (refcount=1, is_ref=0)=42,
   'life' => (refcount=2, is_ref=0)='life'
)

Or graphically

Zvals for a simple array with a reference

From the above Xdebug output, we see that both the old and new array elements now point to a zval container whose "refcount" is 2. Although Xdebug's output shows two zval containers with value 'life', they are the same one. The xdebug_debug_zval() function does not show this, but you could see it by also displaying the memory pointer.

Removing an element from the array is like removing a symbol from a scope. By doing so, the "refcount" of a container that an array element points to is decreased. Again, when the "refcount" reaches zero, the variable container is removed from memory. Again, an example to show this:

Örnek 7 Removing an element from an array

<?php
$a = array( 'meaning' => 'life', 'number' => 42 );
$a['life'] = $a['meaning'];
unset( $a['meaning'], $a['number'] );
xdebug_debug_zval( 'a' );
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

a: (refcount=1, is_ref=0)=array (
   'life' => (refcount=1, is_ref=0)='life'
)

Now, things get interesting if we add the array itself as an element of the array, which we do in the next example, in which we also sneak in a reference operator, since otherwise PHP would create a copy:

Örnek 8 Adding the array itself as an element of it self

<?php
$a = array( 'one' );
$a[] =& $a;
xdebug_debug_zval( 'a' );
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

a: (refcount=2, is_ref=1)=array (
   0 => (refcount=1, is_ref=0)='one',
   1 => (refcount=2, is_ref=1)=...
)

Or graphically

Zvals for an array with a circular reference

You can see that the array variable (a) as well as the second element (1) now point to a variable container that has a "refcount" of 2. The "..." in the display above shows that there is recursion involved, which, of course, in this case means that the "..." points back to the original array.

Just like before, unsetting a variable removes the symbol, and the reference count of the variable container it points to is decreased by one. So, if we unset variable $a after running the above code, the reference count of the variable container that $a and element "1" point to gets decreased by one, from "2" to "1". This can be represented as:

Örnek 9 Unsetting $a

(refcount=1, is_ref=1)=array (
   0 => (refcount=1, is_ref=0)='one',
   1 => (refcount=1, is_ref=1)=...
)

Or graphically

Zvals after removal of array with a circular reference demonstrating the memory leak

Cleanup Problems

Although there is no longer a symbol in any scope pointing to this structure, it cannot be cleaned up because the array element "1" still points to this same array. Because there is no external symbol pointing to it, there is no way for a user to clean up this structure; thus you get a memory leak. Fortunately, PHP will clean up this data structure at the end of the request, but before then, this is taking up valuable space in memory. This situation happens often if you're implementing parsing algorithms or other things where you have a child point back at a "parent" element. The same situation can also happen with objects of course, where it actually is more likely to occur, as objects are always implicitly used by reference.

This might not be a problem if this only happens once or twice, but if there are thousands, or even millions, of these memory losses, this obviously starts being a problem. This is especially problematic in long running scripts, such as daemons where the request basically never ends, or in large sets of unit tests. The latter caused problems while running the unit tests for the Template component of the eZ Components library. In some cases, it would require over 2 GB of memory, which the test server didn't quite have.

Garbage Collection
Collecting Cycles
Garbage Collection


Collecting Cycles

Traditionally, reference counting memory mechanisms, such as that used previously by PHP, fail to address circular reference memory leaks; however, as of 5.3.0, PHP implements the synchronous algorithm from the » Concurrent Cycle Collection in Reference Counted Systems paper which addresses that issue.

A full explanation of how the algorithm works would be slightly beyond the scope of this section, but the basics are explained here. First of all, we have to establish a few ground rules. If a refcount is increased, it's still in use and therefore, not garbage. If the refcount is decreased and hits zero, the zval can be freed. This means that garbage cycles can only be created when a refcount argument is decreased to a non-zero value. Secondly, in a garbage cycle, it is possible to discover which parts are garbage by checking whether it is possible to decrease their refcount by one, and then checking which of the zvals have a refcount of zero.

Garbage collection algorithm

To avoid having to call the checking of garbage cycles with every possible decrease of a refcount, the algorithm instead puts all possible roots (zvals) in the "root buffer" (marking them "purple"). It also makes sure that each possible garbage root ends up in the buffer only once. Only when the root buffer is full does the collection mechanism start for all the different zvals inside. See step A in the figure above.

In step B, the algorithm runs a depth-first search on all possible roots to decrease by one the refcounts of each zval it finds, making sure not to decrease a refcount on the same zval twice (by marking them as "grey"). In step C, the algorithm again runs a depth-first search from each root node, to check the refcount of each zval again. If it finds that the refcount is zero, the zval is marked "white" (blue in the figure). If it's larger than zero, it reverts the decreasing of the refcount by one with a depth-first search from that point on, and they are marked "black" again. In the last step (D), the algorithm walks over the root buffer removing the zval roots from there, and meanwhile, checks which zvals have been marked "white" in the previous step. Every zval marked as "white" will be freed.

Now that you have a basic understanding of how the algorithm works, we will look back at how this integrates with PHP. By default, PHP's garbage collector is turned on. There is, however, a php.ini setting that allows you to change this: zend.enable_gc.

When the garbage collector is turned on, the cycle-finding algorithm as described above is executed whenever the root buffer runs full. The root buffer has a fixed size of 10,000 possible roots (although you can alter this by changing the GC_ROOT_BUFFER_MAX_ENTRIES constant in Zend/zend_gc.c in the PHP source code, and re-compiling PHP). When the garbage collector is turned off, the cycle-finding algorithm will never run. However, possible roots will always be recorded in the root buffer, no matter whether the garbage collection mechanism has been activated with this configuration setting.

If the root buffer becomes full with possible roots while the garbage collection mechanism is turned off, further possible roots will simply not be recorded. Those possible roots that are not recorded will never be analyzed by the algorithm. If they were part of a circular reference cycle, they would never be cleaned up and would create a memory leak.

The reason why possible roots are recorded even if the mechanism has been disabled is because it's faster to record possible roots than to have to check whether the mechanism is turned on every time a possible root could be found. The garbage collection and analysis mechanism itself, however, can take a considerable amount of time.

Besides changing the zend.enable_gc configuration setting, it is also possible to turn the garbage collecting mechanism on and off by calling gc_enable() or gc_disable() respectively. Calling those functions has the same effect as turning on or off the mechanism with the configuration setting. It is also possible to force the collection of cycles even if the possible root buffer is not full yet. For this, you can use the gc_collect_cycles() function. This function will return how many cycles were collected by the algorithm.

The rationale behind the ability to turn the mechanism on and off, and to initiate cycle collection yourself, is that some parts of your application could be highly time-sensitive. In those cases, you might not want the garbage collection mechanism to kick in. Of course, by turning off the garbage collection for certain parts of your application, you do risk creating memory leaks because some possible roots might not fit into the limited root buffer. Therefore, it is probably wise to call gc_collect_cycles() just before you call gc_disable() to free up the memory that could be lost through possible roots that are already recorded in the root buffer. This then leaves an empty buffer so that there is more space for storing possible roots while the cycle collecting mechanism is turned off.

Reference Counting Basics
Performance Considerations
Garbage Collection


Performance Considerations

We have already mentioned in the previous section that simply collecting the possible roots had a very tiny performance impact, but this is when you compare PHP 5.2 against PHP 5.3. Although the recording of possible roots compared to not recording them at all, like in PHP 5.2, is slower, other changes to the PHP runtime in PHP 5.3 prevented this particular performance loss from even showing.

There are two major areas in which performance is affected. The first area is reduced memory usage, and the second area is run-time delay when the garbage collection mechanism performs its memory cleanups. We will look at both of those issues.

Reduced Memory Usage

First of all, the whole reason for implementing the garbage collection mechanism is to reduce memory usage by cleaning up circular-referenced variables as soon as the prerequisites are fulfilled. In PHP's implementation, this happens as soon as the root-buffer is full, or when the function gc_collect_cycles() is called. In the graph below, we display the memory usage of the script below, in both PHP 5.2 and PHP 5.3, excluding the base memory that PHP itself uses when starting up.

Örnek 1 Memory usage example

<?php
class Foo
{
    public $var = '3.14159265359';
}

$baseMemory = memory_get_usage();

for ( $i = 0; $i <= 100000; $i++ )
{
    $a = new Foo;
    $a->self = $a;
    if ( $i % 500 === 0 )
    {
        echo sprintf( '%8d: ', $i ), memory_get_usage() - $baseMemory, "\n";
    }
}
?>
Comparison of memory usage between PHP 5.2 and PHP 5.3

In this very academic example, we are creating an object in which a property is set to point back to the object itself. When the $a variable in the script is re-assigned in the next iteration of the loop, a memory leak would typically occur. In this case, two zval-containers are leaked (the object zval, and the property zval), but only one possible root is found: the variable that was unset. When the root-buffer is full after 10,000 iterations (with a total of 10,000 possible roots), the garbage collection mechanism kicks in and frees the memory associated with those possible roots. This can very clearly be seen in the jagged memory-usage graph for PHP 5.3. After each 10,000 iterations, the mechanism kicks in and frees the memory associated with the circular referenced variables. The mechanism itself does not have to do a whole lot of work in this example, because the structure that is leaked is extremely simple. From the diagram, you see that the maximum memory usage in PHP 5.3 is about 9 Mb, whereas in PHP 5.2 the memory usage keeps increasing.

Run-Time Slowdowns

The second area where the garbage collection mechanism influences performance is the time taken when the garbage collection mechanism kicks in to free the "leaked" memory. In order to see how much this is, we slightly modify the previous script to allow for a larger number of iterations and the removal of the intermediate memory usage figures. The second script is here:

Örnek 2 GC performance influences

<?php
class Foo
{
    public $var = '3.14159265359';
}

for ( $i = 0; $i <= 1000000; $i++ )
{
    $a = new Foo;
    $a->self = $a;
}

echo memory_get_peak_usage(), "\n";
?>

We will run this script two times, once with the zend.enable_gc setting turned on, and once with it turned off:

Örnek 3 Running the above script

time php -dzend.enable_gc=0 -dmemory_limit=-1 -n example2.php
# and
time php -dzend.enable_gc=1 -dmemory_limit=-1 -n example2.php

On my machine, the first command seems to take consistently about 10.7 seconds, whereas the second command takes about 11.4 seconds. This is a slowdown of about 7%. However, the maximum amount of memory used by the script is reduced by 98% from 931Mb to 10Mb. This benchmark is not very scientific, or even representative of real-life applications, but it does demonstrate the memory usage benefits that this garbage collection mechanism provides. The good thing is that the slowdown is always the same 7%, for this particular script, while the memory saving capabilities save more and more memory as more circular references are found during script execution.

PHP's Internal GC Statistics

It is possible to coax a little bit more information about how the garbage collection mechanism is run from within PHP. But in order to do so, you will have to re-compile PHP to enable the benchmark and data-collecting code. You will have to set the CFLAGS environment variable to -DGC_BENCH=1 prior to running ./configure with your desired options. The following sequence should do the trick:

Örnek 4 Recompiling PHP to enable GC benchmarking

export CFLAGS=-DGC_BENCH=1
./config.nice
make clean
make

When you run the above example code again with the newly built PHP binary, you will see the following being shown after PHP has finished execution:

Örnek 5 GC statistics

GC Statistics
-------------
Runs:               110
Collected:          2072204
Root buffer length: 0
Root buffer peak:   10000

      Possible            Remove from  Marked
        Root    Buffered     buffer     grey
      --------  --------  -----------  ------
ZVAL   7175487   1491291    1241690   3611871
ZOBJ  28506264   1527980     677581   1025731

The most informative statistics are displayed in the first block. You can see here that the garbage collection mechanism ran 110 times, and in total, more than 2 million memory allocations were freed during those 110 runs. As soon as the garbage collection mechanism has run at least one time, the "Root buffer peak" is always 10000.

Conclusion

In general the garbage collector in PHP will only cause a slowdown when the cycle collecting algorithm actually runs, whereas in normal (smaller) scripts there should be no performance hit at all.

However, in the cases where the cycle collection mechanism does run for normal scripts, the memory reduction it will provide allows more of those scripts to run concurrently on your server, since not so much memory is used in total.

The benefits are most apparent for longer-running scripts, such as lengthy test suites or daemon scripts. Also, for » PHP-GTK applications that generally tend to run longer than scripts for the Web, the new mechanism should make quite a bit of a difference regarding memory leaks creeping in over time.

Collecting Cycles
DTrace Dynamic Tracing
Garbage Collection


DTrace Dynamic Tracing

İçindekiler

  • Introduction to PHP and DTrace
  • Using PHP and DTrace
  • Using SystemTap with PHP DTrace Static Probes
Performance Considerations
Introduction to PHP and DTrace
Özellikler


Introduction to PHP and DTrace

DTrace is an always-available, low overhead, tracing framework available on a number of platforms including Solaris, Mac OS X, Oracle Linux and BSD. DTrace can trace operating system behavior and user program execution. It can display argument values and be used to infer performance statistics. Probes are monitored by user created scripts written in the DTrace D scripting language. This allows efficient analysis of data points.

PHP probes that are not being actively monitored by a user's DTrace D script do not contain instrumented code so there is no performance degradation during normal application execution. Probes that are being monitored incur an overhead low enough to generally allow DTrace monitoring on live production systems.

PHP incorporates "User-level Statically Defined Tracing" (USDT) probes that are triggered at runtime. For example, when a D script is monitoring PHP's function-entry probe, then, every time a PHP script function is called, this probe is fired and the associated D script action code is executed. This action code could, for example, print probe arguments such as the source file location of the PHP function. Or the action could aggregate data such as the number of times each function is called.

Only the PHP USDT probes are described here. Refer to external general and operating system-specific DTrace literature to see how DTrace can be used to trace arbitrary functions, and how it can be used to trace operating system behavior. Note not all DTrace features are available in all DTrace implementations.

DTrace static probes are included in PHP 5.4. Prior to this they were available via a » PECL extension, which is now obsolete.

The static DTrace probes in PHP can alternatively be used with the SystemTap facility on some Linux distributions.

DTrace Dynamic Tracing
Using PHP and DTrace
DTrace Dynamic Tracing


Using PHP and DTrace

PHP can be configured with DTrace static probes on platforms that support DTrace Dynamic Tracing.

Configuring PHP for DTrace Static Probes

Refer to external platform specific documentation for enabling operating system DTrace support. For example, on Oracle Linux boot a UEK3 kernel and do:

# modprobe fasttrap
# chmod 666 /dev/dtrace/helper

Instead of using chmod, you could instead use an ACL package rule to limit device access to a specific user.

Build PHP with the --enable-dtrace configuration parameter:

# ./configure --enable-dtrace ...
# make
# make install

This enables the static probes in core PHP. Any PHP extensions that provide their own probes should be built separately as shared extensions.

DTrace Static Probes in Core PHP

The following static probes are available in PHP
Probe Name | Probe Description | Probe Arguments
request-startup | Fires when a request starts. | char *file, char *request_uri, char *request_method
request-shutdown | Fires when a request shutdown. | char *file, char *request_uri, char *request_method
compile-file-entry | Fires when the compilation of a script starts. | char *compile_file, char *compile_file_translated
compile-file-return | Fires when the compilation of a script finishes. | char *compile_file, char *compile_file_translated
execute-entry | Fires when an opcode array is to be executed. For example, it fires on function calls, includes, and generator resumes. | char *request_file, int lineno
execute-return | Fires after execution of an opcode array. | char *request_file, int lineno
function-entry | Fires when the PHP engine enters a PHP function or method call. | char *function_name, char *request_file, int lineno, char *classname, char *scope
function-return | Fires when the PHP engine returns from a PHP function or method call. | char *function_name, char *request_file, int lineno, char *classname, char *scope
exception-thrown | Fires when an exception is thrown. | char *classname
exception-caught | Fires when an exception is caught. | char *classname
error | Fires when an error occurs, regardless of the error_reporting level. | char *errormsg, char *request_file, int lineno

PHP extensions may also have additional static probes.

Listing DTrace Static Probes in PHP

To list available probes, start a PHP process and then run:

# dtrace -l

The output will be similar to:

   ID   PROVIDER            MODULE                          FUNCTION NAME
   [ . . . ]
    4   php15271               php               dtrace_compile_file compile-file-entry
    5   php15271               php               dtrace_compile_file compile-file-return
    6   php15271               php                        zend_error error
    7   php15271               php  ZEND_CATCH_SPEC_CONST_CV_HANDLER exception-caught
    8   php15271               php     zend_throw_exception_internal exception-thrown
    9   php15271               php                 dtrace_execute_ex execute-entry
   10   php15271               php           dtrace_execute_internal execute-entry
   11   php15271               php                 dtrace_execute_ex execute-return
   12   php15271               php           dtrace_execute_internal execute-return
   13   php15271               php                 dtrace_execute_ex function-entry
   14   php15271               php                 dtrace_execute_ex function-return
   15   php15271               php              php_request_shutdown request-shutdown
   16   php15271               php               php_request_startup request-startup

The Provider column values consist of php and the process id of the currently running PHP process.

If the Apache web server is running, the module name might be, for example, libphp5.so, and there would be multiple blocks of listings, one per running Apache process.

The Function column refers to PHP's internal C implementation function names where each provider is located.

If a PHP process is not running, then no PHP probes will be shown.

DTrace with PHP Example

This example shows the basics of the DTrace D scripting language.

Örnek 1 all_probes.d for tracing all PHP Static Probes with DTrace

#!/usr/sbin/dtrace -Zs

#pragma D option quiet

php*:::compile-file-entry
{
    printf("PHP compile-file-entry\n");
    printf("  compile_file              %s\n", copyinstr(arg0));
    printf("  compile_file_translated   %s\n", copyinstr(arg1));
}

php*:::compile-file-return
{
    printf("PHP compile-file-return\n");
    printf("  compile_file              %s\n", copyinstr(arg0));
    printf("  compile_file_translated   %s\n", copyinstr(arg1));
}

php*:::error
{
    printf("PHP error\n");
    printf("  errormsg                  %s\n", copyinstr(arg0));
    printf("  request_file              %s\n", copyinstr(arg1));
    printf("  lineno                    %d\n", (int)arg2);
}

php*:::exception-caught
{
    printf("PHP exception-caught\n");
    printf("  classname                 %s\n", copyinstr(arg0));
}

php*:::exception-thrown
{
    printf("PHP exception-thrown\n");
    printf("  classname                 %s\n", copyinstr(arg0));
}

php*:::execute-entry
{
    printf("PHP execute-entry\n");
    printf("  request_file              %s\n", copyinstr(arg0));
    printf("  lineno                    %d\n", (int)arg1);
}

php*:::execute-return
{
    printf("PHP execute-return\n");
    printf("  request_file              %s\n", copyinstr(arg0));
    printf("  lineno                    %d\n", (int)arg1);
}

php*:::function-entry
{
    printf("PHP function-entry\n");
    printf("  function_name             %s\n", copyinstr(arg0));
    printf("  request_file              %s\n", copyinstr(arg1));
    printf("  lineno                    %d\n", (int)arg2);
    printf("  classname                 %s\n", copyinstr(arg3));
    printf("  scope                     %s\n", copyinstr(arg4));
}

php*:::function-return
{
    printf("PHP function-return\n");
    printf("  function_name             %s\n", copyinstr(arg0));
    printf("  request_file              %s\n", copyinstr(arg1));
    printf("  lineno                    %d\n", (int)arg2);
    printf("  classname                 %s\n", copyinstr(arg3));
    printf("  scope                     %s\n", copyinstr(arg4));
}

php*:::request-shutdown
{
    printf("PHP request-shutdown\n");
    printf("  file                      %s\n", copyinstr(arg0));
    printf("  request_uri               %s\n", copyinstr(arg1));
    printf("  request_method            %s\n", copyinstr(arg2));
}

php*:::request-startup
{
    printf("PHP request-startup\n");
    printf("  file                      %s\n", copyinstr(arg0));
    printf("  request_uri               %s\n", copyinstr(arg1));
    printf("  request_method            %s\n", copyinstr(arg2));
}

This script uses the -Z option to dtrace, allowing it to be run when there is no PHP process executing. If this option were omitted the script would immediately terminate because it knows none of the probes to be monitored are in existence.

The script traces all core PHP static probe points throughout the duration of a running PHP script. Run the D script:

# ./all_probes.d

Run a PHP script or application. The monitoring D script will output each probe's arguments as it fires.

When monitoring is complete, the D script can be terminated with a ^C.

On multi-CPU machines the probe ordering might not appear to be sequential. This depends on which CPU was processing the probes, and how threads migrate across CPUs. Displaying probe time stamps will help reduce confusion, for example:

php*:::function-entry
{
      printf("%lld: PHP function-entry ", walltimestamp);
      [ . . .]
}

See Also

  • OCI8 and DTrace Dynamic Tracing
Introduction to PHP and DTrace
Using SystemTap with PHP DTrace Static Probes
DTrace Dynamic Tracing


Using SystemTap with PHP DTrace Static Probes

On some Linux distributions, the SystemTap tracing utility can be used to trace PHP's static DTrace probes. This is available with PHP 5.4.20 and PHP 5.5.

Installing PHP with SystemTap

Install the SystemTap SDT development package:

# yum install systemtap-sdt-devel

Install PHP with the DTrace probes enabled:

# ./configure --enable-dtrace ...
# make

Listing Static Probes with SystemTap

The static probes in PHP can be listed using stap:

# stap -l 'process.provider("php").mark("*")' -c 'sapi/cli/php -i'

This outputs:

process("sapi/cli/php").provider("php").mark("compile__file__entry")
process("sapi/cli/php").provider("php").mark("compile__file__return")
process("sapi/cli/php").provider("php").mark("error")
process("sapi/cli/php").provider("php").mark("exception__caught")
process("sapi/cli/php").provider("php").mark("exception__thrown")
process("sapi/cli/php").provider("php").mark("execute__entry")
process("sapi/cli/php").provider("php").mark("execute__return")
process("sapi/cli/php").provider("php").mark("function__entry")
process("sapi/cli/php").provider("php").mark("function__return")
process("sapi/cli/php").provider("php").mark("request__shutdown")
process("sapi/cli/php").provider("php").mark("request__startup")

SystemTap with PHP Example

Örnek 1 all_probes.stp for tracing all PHP Static Probes with SystemTap

probe process("sapi/cli/php").provider("php").mark("compile__file__entry") {
    printf("Probe compile__file__entry\n");
    printf("  compile_file %s\n", user_string($arg1));
    printf("  compile_file_translated %s\n", user_string($arg2));
}
probe process("sapi/cli/php").provider("php").mark("compile__file__return") {
    printf("Probe compile__file__return\n");
    printf("  compile_file %s\n", user_string($arg1));
    printf("  compile_file_translated %s\n", user_string($arg2));
}
probe process("sapi/cli/php").provider("php").mark("error") {
    printf("Probe error\n");
    printf("  errormsg %s\n", user_string($arg1));
    printf("  request_file %s\n", user_string($arg2));
    printf("  lineno %d\n", $arg3);
}
probe process("sapi/cli/php").provider("php").mark("exception__caught") {
    printf("Probe exception__caught\n");
    printf("  classname %s\n", user_string($arg1));
}
probe process("sapi/cli/php").provider("php").mark("exception__thrown") {
    printf("Probe exception__thrown\n");
    printf("  classname %s\n", user_string($arg1));
}
probe process("sapi/cli/php").provider("php").mark("execute__entry") {
    printf("Probe execute__entry\n");
    printf("  request_file %s\n", user_string($arg1));
    printf("  lineno %d\n", $arg2);
}
probe process("sapi/cli/php").provider("php").mark("execute__return") {
    printf("Probe execute__return\n");
    printf("  request_file %s\n", user_string($arg1));
    printf("  lineno %d\n", $arg2);
}
probe process("sapi/cli/php").provider("php").mark("function__entry") {
    printf("Probe function__entry\n");
    printf("  function_name %s\n", user_string($arg1));
    printf("  request_file %s\n", user_string($arg2));
    printf("  lineno %d\n", $arg3);
    printf("  classname %s\n", user_string($arg4));
    printf("  scope %s\n", user_string($arg5));
}
probe process("sapi/cli/php").provider("php").mark("function__return") {
    printf("Probe function__return: %s\n", user_string($arg1));
    printf(" function_name %s\n", user_string($arg1));
    printf("  request_file %s\n", user_string($arg2));
    printf("  lineno %d\n", $arg3);
    printf("  classname %s\n", user_string($arg4));
    printf("  scope %s\n", user_string($arg5));
}
probe process("sapi/cli/php").provider("php").mark("request__shutdown") {
    printf("Probe request__shutdown\n");
    printf("  file %s\n", user_string($arg1));
    printf("  request_uri %s\n", user_string($arg2));
    printf("  request_method %s\n", user_string($arg3));
}
probe process("sapi/cli/php").provider("php").mark("request__startup") {
    printf("Probe request__startup\n");
    printf("  file %s\n", user_string($arg1));
    printf("  request_uri %s\n", user_string($arg2));
    printf("  request_method %s\n", user_string($arg3));
}

The above script will trace all core PHP static probe points throughout the duration of a running PHP script:

# stap -c 'sapi/cli/php test.php' all_probes.stp

Using PHP and DTrace
İşlev Başvuru Kılavuzu
DTrace Dynamic Tracing


İşlev Başvuru Kılavuzu

İpucu

Ayrıca bakınız: Eklenti Grupları/Listesi.

  • PHP'nin Davranışını Etkileyenler
    • APC — Alternatif PHP Önbelleği
    • APCu — APC User Cache
    • APD — Gelişmiş PHP Hata Ayıklayıcısı (Advanced PHP debugger)
    • bcompiler — PHP için derleyici
    • BLENC — Blenc - BLowfish ENCoder for PHP source scripts
    • Hata İşleme — Hata İşleme ve Günlükleme
    • htscanner — htaccess-like support for all SAPIs
    • inclued — Inclusion hierarchy viewer
    • Memtrack
    • OPcache
    • Çıktı Denetimi — Çıktı Tamponlama Denetimi
    • PHP Seçenek ve Bilgileri
    • runkit
    • scream — Break the silence operator
    • uopz
    • Weakref — Weak References
    • WinCache — Windows Cache for PHP
    • Xhprof — Hierarchical Profiler
  • Ses Biçemleme İşlemleri
    • ID3 — ID3 Tags
    • KTaglib
    • oggvorbis — OGG/Vorbis
    • OpenAL — OpenAL Audio Bindings
  • Kimlik Doğrulama Hizmetleri
    • KADM5 — Kerberos V
    • Radius
  • Komut Satırına Özgü Eklentiler
    • Ncurses — Ncurses Terminal Screen Control
    • Newt
    • Readline — GNU Readline
  • Sıkıştırma ve Arşivleme Eklentileri
    • Bzip2 Sıkıştırma
    • LZF
    • Phar
    • Rar — Rar Archiving
    • Zip
    • Zlib Eklentisi — Zlib Sıkıştırması
  • Kredi Kartı İşlemleri
    • MCVE — MCVE (Monetra) Payment
  • Şifresel Eklentiler
    • Crack — Cracklib Parola Sınama Eklentisi
    • CSPRNG
    • Hash — HASH İleti Özeti Çerçevesi
    • Mcrypt
    • Mhash
    • OpenSSL
    • Password Hashing
  • Veritabanı Eklentileri
    • Soyutlama Katmanları
    • Sağlayıcıya Göre Veritabanı Eklentileri
  • Tarih ve Saat ile İlgili Eklentiler
    • Takvim
    • Tarih ve Zaman
    • HRTime — High resolution timing
  • Dosya Sistemiyle İlgili Eklentiler
    • Doğrudan G/Ç
    • Dizinler
    • Fileinfo — Dosya Bilgileri
    • Dosya Sistemi
    • Inotify
    • MIME Türü
    • Proctitle
    • xattr
    • xdiff
  • İnsan Dilleri ve Karakter Kodlaması Desteği
    • Enchant — Enchant spelling library
    • FriBiDi
    • Gender — Determine gender of firstnames
    • Gettext
    • iconv
    • intl — Uluslararasılaştırma İşlevleri
    • Çok Baytlı Dizgeler
    • Pspell
    • Recode — GNU Recode
  • Resim İşleme ve Resim Üretimi
    • Cairo
    • Exif — Değiş Tokuş Edilebilir Resim Bilgileri
    • GD — Resim İşleme ve GD
    • Gmagick
    • ImageMagick — Resim İşleme (ImageMagick)
  • Postayla İlgili Eklentiler
    • Cyrus — Cyrus IMAP administration
    • IMAP — IMAP, POP3 ve NNTP
    • Eposta
    • Mailparse
    • vpopmail
  • Matematiksel Eklentiler
    • BC Math — BCMath Keyfi Duyarlıklı Matematik
    • GMP — GNU Multiple Precision
    • Lapack
    • Math — Mathematical Functions
    • Statistics
    • Trader — Technical Analysis for Traders
  • Salt Metin Olmayan MIME Çıktılama
    • FDF — Forms Data Format
    • GnuPG — GNU Privacy Guard
    • haru — Haru PDF
    • Ming — Ming (flash)
    • PDF
    • PS — PostScript document creation
    • RPM Reader — RPM Header Reading
  • Süreç Denetim Eklentileri
    • Eio
    • Ev
    • Expect
    • Libevent
    • PCNTL — Süreç Denetimi
    • POSIX
    • Program Çalıştırma — Sistem Programlarının Çalıştırılması
    • pthreads
    • Semaphore — Semaphore, Shared Memory and IPC
    • Shared Memory
    • Sync
  • Diğer Temel Eklentiler
    • GeoIP — Geo IP Location
    • FANN — FANN (Fast Artificial Neural Network)
    • JSON — JavaScript Nesne Bildirimi
    • Judy — Judy Arrays
    • Lua
    • Muhtelif — Çeşitli İşlevler
    • Parsekit
    • SPL — Standard PHP Library (SPL)
    • SPL Types — SPL Type Handling
    • Akımlar
    • Tidy
    • Simgeleştirici
    • URL'ler
    • V8js — V8 Javascript Engine Integration
    • Yaml — YAML Data Serialization
    • Yaf — Yet Another Framework
    • Taint
  • Diğer Hizmetler
    • chdb — Constant hash database
    • cURL — İstemci URL Kütüphanesi
    • Event
    • FAM — File Alteration Monitor
    • FTP
    • Gearman
    • Gopher — Net Gopher
    • Gupnp
    • Hyperwave API
    • LDAP — Lightweight Directory Access Protocol
    • Memcache
    • Memcached
    • mqseries
    • Ağ
    • RRD — RRDtool
    • SAM — Simple Asynchronous Messaging
    • SNMP
    • Soketler
    • SSH2 — Güvenli Kabuk 2
    • Stomp — Stomp Client
    • SVM — Support Vector Machine
    • SVN — Subversion
    • TCP — TCP Sarmalayıcıları
    • Varnish
    • YAZ
    • YP/NIS
    • 0MQ messaging — ZMQ
    • ZooKeeper
  • Arama Motoru Eklentileri
    • mnoGoSearch
    • Solr — Apache Solr
    • Sphinx — Sphinx Client
    • Swish — Swish Indexing
  • Sunuculara Özgü Eklentiler
    • Apache
    • FastCGI Process Manager
    • IIS — IIS Administration
    • NSAPI
  • Oturum Eklentileri
    • Msession — Mohawk Software Session Handler Functions
    • Oturumlar — Oturum Yönetim Sistemi
    • Session PgSQL — PostgreSQL Session Save Handler
  • Metin İşleme
    • BBCode — Bulletin Board Code
    • Perl Uyumlu Düzenli İfadeler — PCRE Eklentisi
    • POSIX Düzenli İfadeleri — Düzenli İfadeler (Gelişmiş POSIX)
    • ssdeep — ssdeep Fuzzy Hashing
    • Dizgeler
  • Değişkenler ve Veri Türleriyle İlgili Eklentiler
    • Diziler
    • Sınıflar ve Nesneler — Sınıf ve Nesne Bilgileri
    • Classkit
    • Ctype — Karakter Türü Sınaması
    • Data Structures
    • Filter — Data Filtering
    • İşlevlerle İlgili İşlemler
    • Quickhash
    • Reflection — Yansıtma
    • Değişken İşlemleri
  • HTTP Hizmetleri
    • OAuth
    • SCA
    • SOAP
    • Yar — Yet Another RPC Framework
    • XML-RPC
  • Windows’a Özgü Eklentiler
    • COM — COM ve .Net (Windows)
    • win32ps
    • win32service
  • XML İşleme
    • DOM — Belge Nesne Modeli
    • libxml
    • SDO — Service Data Objects
    • SDO-DAS-Relational — SDO Relational Data Access Service
    • SDO DAS XML — SDO XML Data Access Service
    • Basit XML
    • WDDX
    • XMLDiff — XML diff and merge
    • XML Çözümleyici
    • XMLReader
    • XMLWriter
    • XSL
  • GUI Extensions
    • UI
Using SystemTap with PHP DTrace Static Probes
PHP'nin Davranışını Etkileyenler
PHP Kılavuzu


PHP'nin Davranışını Etkileyenler

  • APC — Alternatif PHP Önbelleği
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • APC İşlevleri
  • APCu — APC User Cache
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • APCu İşlevleri
    • APCUIterator — The APCUIterator class
  • APD — Gelişmiş PHP Hata Ayıklayıcısı (Advanced PHP debugger)
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • APD İşlevleri
  • bcompiler — PHP için derleyici
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • bcompiler İşlevleri
  • BLENC — Blenc - BLowfish ENCoder for PHP source scripts
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Blenc İşlevleri
  • Hata İşleme — Hata İşleme ve Günlükleme
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • Hata İşleme İşlevleri
  • htscanner — htaccess-like support for all SAPIs
    • Giriş
    • Yapılandırma/Kurulum
  • inclued — Inclusion hierarchy viewer
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • inclued İşlevleri
  • Memtrack
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
  • OPcache
    • Giriş
    • Yapılandırma/Kurulum
    • OPcache İşlevleri
  • Çıktı Denetimi — Çıktı Tamponlama Denetimi
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • Çıktı Denetim İşlevleri
  • PHP Seçenek ve Bilgileri
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • PHP Seçenek/Bilgi İşlevleri
  • runkit
    • Giriş
    • Öntanımlı Sabitler
    • Yapılandırma/Kurulum
    • runkit İşlevleri
  • scream — Break the silence operator
    • Giriş
    • Yapılandırma/Kurulum
    • Örnekler
  • uopz
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Uopz İşlevleri
  • Weakref — Weak References
    • Giriş
    • Yapılandırma/Kurulum
    • WeakRef — The WeakRef class
    • WeakMap — The WeakMap class
  • WinCache — Windows Cache for PHP
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • WinCache İşlevleri
    • Building for Windows
  • Xhprof — Hierarchical Profiler
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • Xhprof İşlevleri
İşlev Başvuru Kılavuzu
APC
İşlev Başvuru Kılavuzu


Alternatif PHP Önbelleği

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • APC İşlevleri
    • apc_add — Bir değişkeni önbellek veri deposunda saklar
    • apc_bin_dump — Get a binary dump of the given files and user variables
    • apc_bin_dumpfile — Output a binary dump of cached files and user variables to a file
    • apc_bin_load — Load a binary dump into the APC file/user cache
    • apc_bin_loadfile — Load a binary dump from a file into the APC file/user cache
    • apc_cache_info — APC'nin veri deposundan önbellek bilgisini gösterir
    • apc_cas — Updates an old value with a new value
    • apc_clear_cache — APC önbelleğini temizler
    • apc_compile_file — Bir dosyayı, süzgeçlere aldırmadan, arakod (bytecode) önbelleğinde depolar.
    • apc_dec — Decrease a stored number
    • apc_define_constants — Yeniden çağırmak ve yığın tanımlama için bir grup sabit tanımlar
    • apc_delete_file — Deletes files from the opcode cache
    • apc_delete — Depolanmış bir değişkeni önbellekten siler
    • apc_exists — Checks if APC key exists
    • apc_fetch — Depolanmış bir değişkeni önbellekten alır
    • apc_inc — Increase a stored number
    • apc_load_constants — Önbellekten bir sabit kümesini yükler
    • apc_sma_info — APC paylaşımlı bellek tahsis durumu bilgisini verir
    • apc_store — Bir değişkeni veri deposunda saklar
PHP'nin Davranışını Etkileyenler
Giriş
PHP'nin Davranışını Etkileyenler


Giriş

Alternatif PHP Önbelleği (APC), PHP için işlem kodu önbelleklemesi sağlayan özgür ve açık kaynaklı bir yazılımdır. PHP ara kodlarını en iyilemek, önbellekleme sağlamak için tasarlanmıştır.

APC
Yapılandırma/Kurulum
APC


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
APC


Gereksinimler

Bu eklentiyi derlemek için harici kütüphanelere gerek yoktur.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu » PECL eklentisi PHP ile gelmez.

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/apc.

Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız.

Bilginize: Windows'ta, APC bir geçici dizinin varlığını ve HTTP sunucusu tarafından yazılabilir olmasını gerektirir. Bunun için TMP, TEMP, USERPROFILE ortam değişkenlerine bakar ve hiçbiri atanmamışsa son olarak WINDOWS dizinini dener.

Bilginize: Gerçeklenimle ilgili daha derinliğine ve daha teknik ayrıntılar için » geliştiriciler tarafından yazılmış TECHNOTES dosyasına bakınız.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

APC öntanımlı ayarları çoğu kurulum için yeterli olsa da daha fazla başarım için aşağıdaki değiştirgelerde ince ayarlar yapmak gerekebilir.

Başlıca iki önemli ayara karar vermek gerekir. Birincisi, APC için ne kadar paylaşımlı bellek ayıracaksınız, ikincisi APC'nin her istekte dosya değiştirilmiş mi diye bakmasını istiyor musunuz? Bu ayarların ini yönergeleri sırası ile apc.shm_size ve apc.stat'dır.

Çalışır halde bir sunucuda, eklenti ile birlikte gelen apc.php betiğini sunucunun belge kök dizinindeki bir yere koymak ve tarayıcıdan çağırmak önbellek ile ilgili ayrıntılı bilgiler sağlayacaktır. Eğer PHP kurulumunda GD desteği varsa grafikler de görüntülenecektir. Denetlenmesi gereken ilk şey önbelleğe alınan dosyalardır. Önbelleğin çalıştığını varsayar isek Önbellek tam dolma sayısı'na dikkat etmek gerekir. Bu sayı önbelleğin dolup son apc.ttl saniyede erişilmeyen girdilerin kaç kez zorla temizlenmek zorunda kalındığını gösterir. Ayarlarınızı bu sayıyı küçüktecek şekilde yapmanız gerekir. Eğer sürekli önbelleğinizi dolduruyor iseniz bu önbellek başarımınızı kötü etkileyecektir. APC için daha fazla bellek ayırmanız veya apc.filters kullanarak daha az betiği önbelleğe almanız sorunu çözebilir.

APC Yapılandırma Seçenekleri
İsim | Öntanımlı değeri | Değişiklik yeri | Değişiklik bilgisi
apc.enabled | "1" | PHP_INI_SYSTEM | APC 2'de PHP_INI_SYSTEM. APC <= 3.0.12'de PHP_INI_ALL.
apc.shm_segments | "1" | PHP_INI_SYSTEM |
apc.shm_size | "30" | PHP_INI_SYSTEM |
apc.optimization | "0" | PHP_INI_ALL | APC 2'de PHP_INI_SYSTEM. APC 3.0.13 sürümünde çıkartılmıştır.
apc.num_files_hint | "1000" | PHP_INI_SYSTEM |
apc.user_entries_hint | "4096" | PHP_INI_SYSTEM | APC 3.0.0'dan beri kullanılabilmektedir.
apc.ttl | "0" | PHP_INI_SYSTEM | APC 3.0.0'dan beri kullanılabilmektedir.
apc.user_ttl | "0" | PHP_INI_SYSTEM | APC 3.0.0'dan beri kullanılabilmektedir.
apc.gc_ttl | "3600" | PHP_INI_SYSTEM |
apc.cache_by_default | "1" | PHP_INI_ALL | APC <= 3.0.12'de PHP_INI_SYSTEM. APC 3.0.0'dan beri kullanılabilmektedir.
apc.filters | NULL | PHP_INI_SYSTEM |
apc.mmap_file_mask | NULL | PHP_INI_SYSTEM |
apc.slam_defense | "0" | PHP_INI_SYSTEM | APC 3.0.0'dan beri kullanılabilmektedir.
apc.file_update_protection | "2" | PHP_INI_SYSTEM | APC 3.0.6'dan beri kullanılabilmektedir.
apc.enable_cli | "0" | PHP_INI_SYSTEM | APC 3.0.7'den beri kullanılabilmektedir.
apc.max_file_size | "1M" | PHP_INI_SYSTEM | APC 3.0.7'dan beri kullanılabilmektedir.
apc.stat | "1" | PHP_INI_SYSTEM | APC 3.0.10'dan beri kullanılabilmektedir.
apc.write_lock | "1" | PHP_INI_SYSTEM | APC 3.0.11'den beri kullanılabilmektedir.
apc.report_autofilter | "0" | PHP_INI_SYSTEM | APC 3.0.11'den beri kullanılabilmektedir.
apc.include_once_override | "0" | PHP_INI_SYSTEM | APC 3.0.12'den beri kullanılabilmektedir.
apc.rfc1867 | "0" | PHP_INI_SYSTEM | APC 3.0.13'den beri kullanılabilmektedir.
apc.rfc1867_prefix | "upload_" | PHP_INI_SYSTEM |
apc.rfc1867_name | "APC_UPLOAD_PROGRESS" | PHP_INI_SYSTEM |
apc.rfc1867_freq | "0" | PHP_INI_SYSTEM |
apc.localcache | "0" | PHP_INI_SYSTEM | APC 3.0.14'den beri kullanılabilmektedir.
apc.localcache.size | "512" | PHP_INI_SYSTEM | APC 3.0.14'den beri kullanılabilmektedir.
apc.coredump_unmap | "0" | PHP_INI_SYSTEM | APC 3.0.16'dan beri kullanılabilmektedir.
apc.stat_ctime | "0" | PHP_INI_SYSTEM | APC 3.0.13'den beri kullanılabilmektedir.
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

apc.enabled boolean

APC'yi etkisiz duruma getirmek için apc.enabled 0 olarak ayarlanabilir. Bu APC durağan bir şekilde PHP içine derlendi ise özellikle yararlıdır, zaten bu şekilde derlendi ise etkisiz kılmanın başka bir yolu yoktur (DSO olarak derlendi ise php.ini içindeki ilgili extension satırı çıkartılabilir).

apc.shm_segments integer

Derleyici önbelleği için ayrılan paylaşılan bellek bölümlerinin sayısı. Eğer APC paylaşılan belleğin dışına taşıyorsa ve apc.shm_size için sisteminizin izin verdiği en yüksek değeri verdiyseniz bu değeri yükseltmeyi deneyebilirsiniz.

apc.shm_size integer

MB olarak her bir paylaşılan bellek kesiminin boyutu. Öntanımlı olarak bazı sistemler (çoğu BSD türevi dahil) paylaşılan bellek kesimi için çok düşük sınırlara sahiptir.

apc.optimization integer

Eniyileme seviyesi. Sıfır eniyilemeyi iptal eder, daha yüksek değerler daha etkili eniyileme sağlar. Hız artışlarının pek fazla olmamasını bekleyin, deneyseldir.

apc.num_files_hint integer

HTTP sunucundan dahil edilecek veya istenecek bağımsız kaynak dosyalarının sayısı ile ilgili bir "ipucu". Emin değilseniz sıfıra ayarlayın veya ihmal edin; Bu ayar binlerce kaynak dosyası olan sitelerde yararlıdır.

apc.user_entries_hint integer

Depolanacak kullanıcı önbellek değişkenlerinin sayısı ile ilgili bir "ipucu" olup apc.num_files_hint'e benzer. Emin değilseniz sıfıra ayarlayın veya ihmal edin.

apc.ttl integer

Bir önbellek girdisinin bellek yuvasında kullanılmadan kalma süresidir, saniye olarak verilir. Sıfır olarak bırakmak eski girdilerin sürekli olarak bellekte kalmasına ve yeni girdi alınmamasına neden olacaktır.

apc.user_ttl integer

Bir önbellek girdisinin bellek yuvasında kullanılmadan kalma süresidir, saniye olarak verilir. Sıfır olarak bırakmak eski girdilerin sürekli olarak bellekte kalmasına ve yeni girdi alınmamasına neden olacaktır. Önbellekte yer kalmaması durumunda ttl sıfır ise önbellek tamamen silinir; ttl sıfırdan büyük ise sadece süresi dolmuş girdiler silinmeye çalışılır.

apc.gc_ttl integer

Bir önbellek girdisinin bellek yuvasında kullanılmadan kalma süresidir, saniye olarak verilir. Sıfır olarak bırakmak eski girdilerin sürekli olarak bellekte kalmasına ve yeni girdi alınmamasına neden olacaktır. Önbellekte yer kalmaması durumunda ttl sıfır ise önbellek tamamen silinir; ttl sıfırdan büyük ise sadece süresi dolmuş girdiler silinmeye çalışılır.

apc.cache_by_default boolean

Öntanımlı olarak etkindir ("On"), fakat sadece olumlu süzgece uyan dosyaların önbelleğe alınması için etkisiz ("Off") hale getirilerek, apc.filters ile birlikte kullanılabilir.

apc.filters string

Genişletilmiş POSIX düzenli ifadelerine uyan virgülle ayrılmış dizge değerlerin listesidir. Eğer kaynak dosya adı, listedeki herhangi bir kalıba uyarsa bu dosya önbelleğe alınmaz. Eşleştirme için include / require işlevlerine aktarılmış olan dosya adı kullanılır, mutlak yol kullanılmaz. Eğer deyimin ilk karakteri + ise, süzgeç ile eşleşen dosyalar önbelleğe alınır, - ise alınmaz. - öntanımlıdır, bu yüzden yazılmayabilir.

apc.mmap_file_mask string

Eğer --enable-mmap kullanılarak MMAP desteği ile derlendiyse, mmap hafıza bölgesinin dosya mı yoksa paylaşımlı bellek desteği ile mi hazırlandığını belirlemek için mmap modülüne aktarılacak mktemp tarzı dosya maskesidir. Doğrudan dosya destekli mmap için /tmp/apc.XXXXXX'a benzer şekilde ayarlayın (tam olarak 6 adet X). POSIX tarzı shm_open/mmap kullanmak için dosya kalıbına .shm koyun. Örnek olarak /apc.shm.XXXXXX. Ayrıca /dev/zero şeklinde ayarlanarak, anonim mmap bellek için çekirdeğin /dev/zero arabirimi kullanılabilir. Tanımsız olarak bırakmak anonim mmap'e zorlayacaktır.

apc.slam_defense integer

Çok yoğun sunucularda, sunucuyu başlattığınızda veya dosyaları değiştirdiğinizde, aynı zamanda, aynı dosyayı önbelleğe almaya çalışan birçok sürecin birbiriyle yarışmasına neden olabilirsiniz. Bu ayar önbelleğe alınmamış bir dosya üzerinde süreçlerin es geçme yüzdesini ayarlar. Diğer bir deyişle tek bir sürecin bir dosyayı önbelleğe almama olasılığı olarak düşünebilirsiniz. Örnek olarak, apc.slam_defense'i 75'e ayarlamak %75 olasılıkla sürecin önbellekleme yapmayacağını gösterir. Bu yüzden yüksek değerler daha iyi savunma sağlar. Bu özelliği iptal etmek için 0 olarak ayarlayın.

Sonraki sürümlerde apc.write_lock ile değiştirilmiştir.

apc.file_update_protection integer

Etkin kullanılan bir HTML sunucusunda bir dosyayı değiştirdiğiniz zaman bunu çok kısa atomik bir zaman diliminde yapmalısınız, geçici bir dosyaya yazma işlemi yapılır ve hazır olduğunda özgün dosya adıyla yeniden isimlendirilir (mv). Çoğu metin düzenleyici, cp, tar ve diğer bu türden programlar bu şekilde çalışmaz. Metin düzenleyicileri dosyayı düzenlerken, APC, dosyanın hazır olmayan halinin, önbelleğe alınmasına yol açabilir. apc.file_update_protection ayarı yeni dosyaların önbelleklemesi üzerinde bir geciktirme sağlar. Varsayılan değeri 2 saniyedir. Bu dosyalara erişildiğinde, değişiklik zaman damgası (mtime) 2 saniyeden küçükse önbelleğe alınmayacakları anlamına gelir. Bu tür yarım yazılmış dosyalara erişen ziyaretçiler uygulamalarda tuhaf durumlar ile karşılaşabilir, en azından bu tuhaflıklar kalıcı değildir. Eğer dosyalarınızın güncellemesini atomik zamanlama ile yaptığınızdan eminseniz, rsync bunu doğru bir şekilde yapar, bu koruma mekanizmasını 0'a ayarlayarak kapatabilirsiniz. Eğer yüksek girdi-çıktı nedeniyle 2 saniyeden daha uzun süren güncelleme süreçlerine sahipseniz bunu bir miktar arttırmak isteyebilirsiniz.

apc.enable_cli integer

Çoğunlukla deneme ve hata arama için kullanılır. Bunu ayarlamak PHP'nin CLI sürümü için APC'nin yetkilendirilmesini sağlar. Normalde her CLI isteği için APC önbelleğinin yeniden oluşturulmasını istemezsiniz, fakat çeşitli deneme senaryoları için APC'nin kolay bir şekilde yetkilendirilmesi yararlı olabilir.

apc.max_file_size integer

Bu değerden daha büyük dosyaların önbelleğe alınmasını engeller, varsayılan değeri 1M'dır.

apc.stat integer

Bu ayarı değiştirirseniz dikkatli olun, ayarın varsayılan durumunda APC her istekte betik dosyasının değiştirilme durumu denetlenecektir. Eğer betik değiştirildi ise yeni betiği işleyecek ve önbelleğe alacaktır. Eğer bu ayarı etkisiz duruma getirirseniz APC betiği değiştirilme durumu için denetlemeyecektir. Bu da betik üzerindeki değişikliklerin etkin olması için HTML sunucunuzu yeniden başlatmanızı gerektirir. Ürün ortamında kullanılan bir sunucuda nadiren kod değiştirmeleri yapılır, bu yüzden etkisiz duruma getirilmesi önemli başarım artışlarına neden olabilir.

Betiğe dışardan dahil edilen (include/require) dosyalar için de bu seçenek geçerlidir, fakat eğer göreli dosya yolları (Unix üzerinde / ile başlamayan herhangi bir yol) kullanarak dahil ediyorsanız APC dosyayı benzersiz olarak diğerlerinden ayırabilmek için denetlemek zorundadır. Eğer mutlak yol kullanıyorsanız APC bu denetimi atlayacak ve dosya için benzersiz tanımlayıcı olarak mutlak yolu kullanacaktır.

apc.write_lock boolean

Yoğun sunucularda, sunucu başlatıldığında veya birçok dosya değiştirildiğinde, bütün süreçlerinizin aynı dosyaları derleyip önbelleğe almaya çalışması gibi bir durumla karşılabilirsiniz, write_lock etkin durumda iken önbelleğe alınmamış bir betiği sadece bir süreç işleyecektir diğer süreçler kilitli durumun açılmasını beklemek yerine önbelleğe alınmamış bir betiği çalıştıracaklardır.

apc.report_autofilter boolean

Erken/Geç bağlama konuları nedeni ile özdevinimli olarak hariç bırakılan betiklerin raporlanmasını sağlar.

apc.include_once_override boolean

include_once ve require_once çağrılarında eniyileştirme sağlar ve pahalı sistem çağrılarının kullanımından sakınır.

apc.rfc1867 boolean

RFC1867 dosya yükleme aşamalarını kancalama yalnızca APC'yi PHP 5.2.0 veya sonraki sürümlerde derlediyseniz geçerlidir. Etkin duruma getirildiğinde, bir yükleme formunda dosya alanından önce APC_UPLOAD_PROGRESS alanına rastlandığında özdevinimli olarak upload_anahtar içeren bir kullanıcı önbelleği oluşturulur. Burada anahtar, form girdisindeki APC_UPLOAD_PROGRESS elemanının değeridir.

Şuna dikkat edin: APC_UPLOAD_PROGRESS ile belirtilen gizli alan dosya alanından önce gelmelidir, yoksa karşıya yükleme işlemi gerektiği gibi yürümez.

Karşıya dosya yükleme izlemesi, evre korumalı değildir, bu yüzden yeni yapılan yüklemeler bir önceki devam eden izlemeyi devre dışı bırakır.

Örnek 1 - Bir apc.rfc1867 örneği

<?php
print_r(apc_fetch("upload_$_POST[APC_UPLOAD_PROGRESS]"));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [total] => 1142543
    [current] => 1142543
    [rate] => 1828068.8
    [filename] => test
    [name] => file
    [temp_filename] => /tmp/php8F
    [cancel_upload] => 0
    [done] => 1
)

apc.rfc1867_prefix string

rfc1867 karşıya dosya yükleme işlevselliğince üretilen kullanıcı önbellek girdisi için kullanılacak anahtar öneki.

apc.rfc1867_name string

APC karşıya dosya yükleme aşamalarını etkin hale getiren gizli form girdi adını ve kullanıcı önbellek sonekini bildirir.

apc.rfc1867_freq string

Karşıya yükleme işlemleri için kullanıcı önbelleğinin güncellenme sıklığını belirler. Toplam dosya boyutunun belirli bir yüzdesi ya da bayt olarak boyut verilir. Boyuta seçime bağlı olarak kilobayt için 'k', megabayt için 'm', gigabayt için 'g' son ekleri ile belirtilir (büyük veya küçük harf farketmez). Sıfır olarak ayarlamak, mümkün olduğu kadar sık güncellenmesine neden olur fakat bu yükleme işlemlerininin yavaşlamasına neden olabilir.

apc.localcache boolean

Yerel işlemler için gölge önbelleği etkin hale getirir, bu kilitsiz işlemler yaparak kilitlerden kaynaklanan çakışmaları azaltır.

apc.localcache.size integer

Yerel işlemlerin gölge önbellek boyutu, yeteri kadar büyük bir değere ayarlanmalıdır. Yaklaşık olarak apc.num_files_hint değerinin yarısı kadar.

apc.coredump_unmap boolean

APC'nin idaresi için, sinyal verildiği zaman çekirdek döküm dosyaları yazan SIGSEGV gibi sinyallerin işlenmesini etkin kılar. Bu sinyaller alındığı zaman, APC paylaşılan belleği kaldırarak çekirdek döküm dosyasından yeniden oluşturmayı deneyecektir. Bu ayar ölümcül sinyaller alındığı zaman büyük bir paylaşılan bellek alanı olan sistemlerde istikrarı iyi yönde etkileyebilir.

Uyarı

Bu özelliğin tehlikeli olma olasılığı yüksektir. Ölümcül bir hata meydana geldiğinde, paylaşılan belleği kaldırmak, belirsiz davranışlara neden olabilir.

Bilginize:

Bazı sistem çekirdekleri, çekirdek döküm dosyaları oluşturulurken, çeşitli paylaşılan bellek bölümlerinin dökümünü görmezden gelecek araçlar sağlasa da, bu uygulamalar önemli paylaşılan bellek bölümlerini de görmezden gelebilir, Apache puan tahtası gibi.

apc.stat_ctime integer

Düğümlerin değişmediğininden emin olmak için ctime kullanmak svn veya rsync gibi programların neden olduğu sorunları engelleyebilir. APC normalde sadece mtime ile denetim yapar.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Özkaynak Türleri

Bu eklentinin tanımlı hiçbir özkaynak türü yoktur.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
APC İşlevleri
APC


APC İşlevleri

İçindekiler

  • apc_add — Bir değişkeni önbellek veri deposunda saklar
  • apc_bin_dump — Get a binary dump of the given files and user variables
  • apc_bin_dumpfile — Output a binary dump of cached files and user variables to a file
  • apc_bin_load — Load a binary dump into the APC file/user cache
  • apc_bin_loadfile — Load a binary dump from a file into the APC file/user cache
  • apc_cache_info — APC'nin veri deposundan önbellek bilgisini gösterir
  • apc_cas — Updates an old value with a new value
  • apc_clear_cache — APC önbelleğini temizler
  • apc_compile_file — Bir dosyayı, süzgeçlere aldırmadan, arakod (bytecode) önbelleğinde depolar.
  • apc_dec — Decrease a stored number
  • apc_define_constants — Yeniden çağırmak ve yığın tanımlama için bir grup sabit tanımlar
  • apc_delete_file — Deletes files from the opcode cache
  • apc_delete — Depolanmış bir değişkeni önbellekten siler
  • apc_exists — Checks if APC key exists
  • apc_fetch — Depolanmış bir değişkeni önbellekten alır
  • apc_inc — Increase a stored number
  • apc_load_constants — Önbellekten bir sabit kümesini yükler
  • apc_sma_info — APC paylaşımlı bellek tahsis durumu bilgisini verir
  • apc_store — Bir değişkeni veri deposunda saklar
Öntanımlı Sabitler
apc_add
APC


Bir değişkeni önbellek veri deposunda saklar

APC İşlevleri
apc_bin_dump
APC İşlevleri
PHP Manual

apc_add

(PECL apc >= 3.0.13)

apc_add — Bir değişkeni önbellek veri deposunda saklar

Açıklama

bool apc_add ( string $anahtar , mixed $değişken [, int $yaşam_süresi = 0 ] )

Eğer daha önceden saklanmadı ise, bir değişkeni önbellek veri deposunda saklar.

Bilginize: apc_add() işlevi ile saklanan değişkenler, PHP'nin diğer saklama yöntemlerine aykırı olarak, HTTP sunucu istekleri arasında kalıcı olarak saklanacaktır (değişken önbellekten kaldırılana kadar).

Değiştirgeler

anahtar

Değişken depoda bu anahtar ismi kullanılarak saklanacaktır. anahtar'lar önbellek içinde benzersizdir, yani apc_add() işlevi kullanarak aynı isimde varolan bir değişkeni saklamaya çalışmak, eski değeri değiştirmeyecek bunun yerine işlevin FALSE dönmesine neden olacaktır. (apc_add() ile apc_store() arasındaki tek fark budur).

degişken

Saklanacak değişken

yaşam_süresi

Yaşam Süresi; değişken, yaşam_süresi saniye süresince depoda saklanacaktır. yaşam_süresi geçildikten sonraki istekte önbellekten çıkartılacaktır. Eğer yaşam_süresi verilmediyse veya 0 olarak ayarlandıysa, değer el yordamıyla silinmediği veya önbellek boşaltılma, yeniden başlatma, vs. gibi süreçler ile temizlenmediği sürece saklanacaktır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - apc_add() örneği

<?php
$bilgi = 'bilgi';
apc_add('sakla', $bilgi);
var_dump(apc_fetch('sakla'));
echo "\n";
$bilgi = 'önbelleğe alınmayacak';
apc_add('sakla', $bilgi);
var_dump(apc_fetch('sakla'));
echo "\n";
?>

Yukarıdaki örneğin çıktısı:

string(5) "bilgi"
string(5) "bilgi"

Ayrıca Bakınız

  • apc_store() - Bir değişkeni veri deposunda saklar
  • apc_fetch() - Depolanmış bir değişkeni önbellekten alır
  • apc_delete() - Depolanmış bir değişkeni önbellekten siler

APC İşlevleri
apc_bin_dump
APC İşlevleri


Get a binary dump of the given files and user variables

apc_add
apc_bin_dumpfile
APC İşlevleri
PHP Manual

apc_bin_dump

(PECL apc >= 3.1.4)

apc_bin_dump — Get a binary dump of the given files and user variables

Açıklama

string apc_bin_dump ([ array $files = NULL [, array $user_vars = NULL ]] )

Returns a binary dump of the given files and user variables from the APC cache. A NULL for files or user_vars signals a dump of every entry, whereas array() will dump nothing.

Değiştirgeler

files

The files. Passing in NULL signals a dump of every entry, while passing in array() will dump nothing.

user_vars

The user vars. Passing in NULL signals a dump of every entry, while passing in array() will dump nothing.

Dönen Değerler

Returns a binary dump of the given files and user variables from the APC cache, FALSE if APC is not enabled, or NULL if an unknown error is encountered.

Ayrıca Bakınız

  • apc_bin_dumpfile() - Output a binary dump of cached files and user variables to a file
  • apc_bin_load() - Load a binary dump into the APC file/user cache
apc_add
apc_bin_dumpfile
APC İşlevleri


Output a binary dump of cached files and user variables to a file

apc_bin_dump
apc_bin_load
APC İşlevleri
PHP Manual

apc_bin_dumpfile

(PECL apc >= 3.1.4)

apc_bin_dumpfile — Output a binary dump of cached files and user variables to a file

Açıklama

int apc_bin_dumpfile ( array $files , array $user_vars , string $filename [, int $flags = 0 [, resource $context = NULL ]] )

Outputs a binary dump of the given files and user variables from the APC cache to the named file.

Değiştirgeler

files

The file names being dumped.

user_vars

The user variables being dumped.

filename

The filename where the dump is being saved.

flags

Flags passed to the filename stream. See the file_put_contents() documentation for details.

context

The context passed to the filename stream. See the file_put_contents() documentation for details.

Dönen Değerler

The number of bytes written to the file, otherwise FALSE if APC is not enabled, filename is an invalid file name, filename can't be opened, the file dump can't be completed (e.g., the hard drive is out of disk space), or an unknown error was encountered.

Ayrıca Bakınız

  • apc_bin_dump() - Get a binary dump of the given files and user variables
  • apc_bin_load() - Load a binary dump into the APC file/user cache
apc_bin_dump
apc_bin_load
APC İşlevleri


Load a binary dump into the APC file/user cache

apc_bin_dumpfile
apc_bin_loadfile
APC İşlevleri
PHP Manual

apc_bin_load

(PECL apc >= 3.1.4)

apc_bin_load — Load a binary dump into the APC file/user cache

Açıklama

bool apc_bin_load ( string $data [, int $flags = 0 ] )

Loads the given binary dump into the APC file/user cache.

Değiştirgeler

data

The binary dump being loaded, likely from apc_bin_dump().

flags

Either APC_BIN_VERIFY_CRC32, APC_BIN_VERIFY_MD5, or both.

Dönen Değerler

Returns TRUE if the binary dump data was loaded with success, otherwise FALSE is returned. FALSE is returned if APC is not enabled, or if the data is not a valid APC binary dump (e.g., unexpected size).

Örnekler

Örnek 1 apc_bin_load() example

<?php
$data = apc_bin_dump(NULL, NULL);
apc_bin_load($data, APC_BIN_VERIFY_MD5 | APC_BIN_VERIFY_CRC32);
?>

Ayrıca Bakınız

  • apc_bin_dump() - Get a binary dump of the given files and user variables
  • apc_bin_loadfile() - Load a binary dump from a file into the APC file/user cache
apc_bin_dumpfile
apc_bin_loadfile
APC İşlevleri


Load a binary dump from a file into the APC file/user cache

apc_bin_load
apc_cache_info
APC İşlevleri
PHP Manual

apc_bin_loadfile

(PECL apc >= 3.1.4)

apc_bin_loadfile — Load a binary dump from a file into the APC file/user cache

Açıklama

bool apc_bin_loadfile ( string $filename [, resource $context = NULL [, int $flags = 0 ]] )

Loads a binary dump from a file into the APC file/user cache.

Değiştirgeler

filename

The file name containing the dump, likely from apc_bin_dumpfile().

context

The files context.

flags

Either APC_BIN_VERIFY_CRC32, APC_BIN_VERIFY_MD5, or both.

Dönen Değerler

Returns TRUE on success, otherwise FALSE Reasons it may return FALSE include APC is not enabled, filename is an invalid file name or empty, filename can't be opened, the file dump can't be completed, or if the data is not a valid APC binary dump (e.g., unexpected size).

Ayrıca Bakınız

  • apc_bin_dumpfile() - Output a binary dump of cached files and user variables to a file
  • apc_bin_load() - Load a binary dump into the APC file/user cache
apc_bin_load
apc_cache_info
APC İşlevleri


APC'nin veri deposundan önbellek bilgisini gösterir

apc_bin_loadfile
apc_cas
APC İşlevleri
PHP Manual

apc_cache_info

(PECL apc >= 2.0.0)

apc_cache_info — APC'nin veri deposundan önbellek bilgisini gösterir

Açıklama

array apc_cache_info ([ string $önbellek_türü [, bool $sınırlı = false ]] )

APC'nin veri deposundan önbellek ve tanımlayıcı (meta-data) bilgileri gösterir.

Dönen Değerler

Önbelleğe alınmış veri ve tanımlayıcı veriler dizisi; hata durumunda FALSE

Bilginize: apc_cache_info() eğer önbellek verisini elde edemez ise uyarı verecektir. Genelde APC etkin değilken bu durumla karşılaşırsınız.

Değiştirgeler

önbellek_türü

Eğer önbellek_türü "user", ise, kullanıcı önbellek bilgisi geri dönecektir.

Eğer önbellek_türü "filehits", ise, güncel istek için hangi dosyalar önbelleğe alınmış bilgisi dönecektir. Bu özelliğin etkin olabilmesi için derleme sırasında --enable-filehits kullanmak gerekir.

Eğer önbellek_türü geçersiz ise veya belirtilmediyse, sistem önbellek bilgisi (önbelleğe alınmış dosyalar) geri dönecektir.

sınırlı

Eğer limited TRUE ise, önbellek girdilerinin bir bölümünü listelemeyecektir. Bu istatistik elde etmek için yapılan çağrıların eniyileştirilmesinde yararlıdır.

Sürüm Bilgisi

Sürüm: | Açıklama
3.0.11 | sınırlı değiştirgesi eklenmiştir.
3.0.16 | önbellek_türü değiştirgesi için "filehits" seçeneği eklenmiştir.

Örnekler

Örnek 1 Bir apc_cache_info() örneği

<?php
print_r(apc_cache_info());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [num_slots] => 2000
    [ttl] => 0
    [num_hits] => 9
    [num_misses] => 3
    [start_time] => 1123958803
    [cache_list] => Array
        (
            [0] => Array
                (
                    [filename] => /path/to/apc_test.php
                    [device] => 29954
                    [inode] => 1130511
                    [type] => file
                    [num_hits] => 1
                    [mtime] => 1123960686
                    [creation_time] => 1123960696
                    [deletion_time] => 0
                    [access_time] => 1123962864
                    [ref_count] => 1
                    [mem_size] => 677
                )
            [1] => Array (...her önbellek dosyası için yinelenir)
)

Ayrıca Bakınız

  • APC Yapılandırma Seçenekleri

apc_bin_loadfile
apc_cas
APC İşlevleri


Updates an old value with a new value

apc_cache_info
apc_clear_cache
APC İşlevleri
PHP Manual

apc_cas

(PECL apc >= 3.1.1)

apc_cas — Updates an old value with a new value

Açıklama

bool apc_cas ( string $key , int $old , int $new )

apc_cas() updates an already existing integer value if the old parameter matches the currently stored value with the value of the new parameter.

Değiştirgeler

key

The key of the value being updated.

old

The old value (the value currently stored).

new

The new value to update to.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 apc_cas() example

<?php
apc_store('foobar', 2);
echo '$foobar = 2', PHP_EOL;
echo '$foobar == 1 ? 2 : 1 = ', (apc_cas('foobar', 1, 2) ? 'ok' : 'fail'), PHP_EOL;
echo '$foobar == 2 ? 1 : 2 = ', (apc_cas('foobar', 2, 1) ? 'ok' : 'fail'), PHP_EOL;

echo '$foobar = ', apc_fetch('foobar'), PHP_EOL;

echo '$f__bar == 1 ? 2 : 1 = ', (apc_cas('f__bar', 1, 2) ? 'ok' : 'fail'), PHP_EOL;

apc_store('perfection', 'xyz');
echo '$perfection == 2 ? 1 : 2 = ', (apc_cas('perfection', 2, 1) ? 'ok' : 'epic fail'), PHP_EOL;

echo '$foobar = ', apc_fetch('foobar'), PHP_EOL;
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

$foobar = 2
$foobar == 1 ? 2 : 1 = fail
$foobar == 2 ? 1 : 2 = ok
$foobar = 1
$f__bar == 1 ? 2 : 1 = fail
$perfection == 2 ? 1 : 2 = epic fail
$foobar = 1

Ayrıca Bakınız

  • apc_dec() - Decrease a stored number
  • apc_store() - Bir değişkeni veri deposunda saklar
apc_cache_info
apc_clear_cache
APC İşlevleri


APC önbelleğini temizler

apc_cas
apc_compile_file
APC İşlevleri
PHP Manual

apc_clear_cache

(PECL apc >= 2.0.0)

apc_clear_cache — APC önbelleğini temizler

Açıklama

bool apc_clear_cache ([ string $önbellek_türü ] )

Kullanıcı veya sistem önbelleğini temizler.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Değiştirgeler

önbellek_türü

Eğer önbellek_türü "user" ise, kullanıcı önbelleği temizlenecektir, aksi durumda sistem önbelleği (önbelleğe alınmış dosyalar) temizlenecektir.

Ayrıca Bakınız

  • apc_cache_info() - APC'nin veri deposundan önbellek bilgisini gösterir

apc_cas
apc_compile_file
APC İşlevleri


Bir dosyayı, süzgeçlere aldırmadan, arakod (bytecode) önbelleğinde depolar.

apc_clear_cache
apc_dec
APC İşlevleri
PHP Manual

apc_compile_file

(PECL apc >= 3.0.13)

apc_compile_file — Bir dosyayı, süzgeçlere aldırmadan, arakod (bytecode) önbelleğinde depolar.

Açıklama

bool apc_compile_file ( string $dosyaadi )

Bir dosyayı, süzgeçlere aldırmadan, arakod önbelleğinde depolar.

Değiştirgeler

dosyaadi

Derlenip arakod önbelleğinde depolanacak bir PHP dosyasının mutlak veya göreli yol bilgisi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

apc_clear_cache
apc_dec
APC İşlevleri


Decrease a stored number

apc_compile_file
apc_define_constants
APC İşlevleri
PHP Manual

apc_dec

(PECL apc >= 3.1.1)

apc_dec — Decrease a stored number

Açıklama

int apc_dec ( string $key [, int $step = 1 [, bool &$success ]] )

Decreases a stored integer value.

Değiştirgeler

key

The key of the value being decreased.

step

The step, or value to decrease.

success

Optionally pass the success or fail boolean value to this referenced variable.

Dönen Değerler

Returns the current value of key's value on success, başarısızlık durumunda FALSE döner

Örnekler

Örnek 1 apc_dec() example

<?php
echo "Let's do something with success", PHP_EOL;

apc_store('anumber', 42);

echo apc_fetch('anumber'), PHP_EOL;

echo apc_dec('anumber'), PHP_EOL;
echo apc_dec('anumber', 10), PHP_EOL;
echo apc_dec('anumber', 10, $success), PHP_EOL;

var_dump($success);

echo "Now, let's fail", PHP_EOL, PHP_EOL;

apc_store('astring', 'foo');

$ret = apc_dec('astring', 1, $fail);

var_dump($ret);
var_dump($fail);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Let's do something with success
42
41
31
21
bool(true)

Now, let's fail
bool(false)
bool(false)

Ayrıca Bakınız

  • apc_inc() - Increase a stored number
apc_compile_file
apc_define_constants
APC İşlevleri


Yeniden çağırmak ve yığın tanımlama için bir grup sabit tanımlar

apc_dec
apc_delete_file
APC İşlevleri
PHP Manual

apc_define_constants

(PECL apc >= 3.0.0)

apc_define_constants — Yeniden çağırmak ve yığın tanımlama için bir grup sabit tanımlar

Açıklama

bool apc_define_constants ( string $anahtar , array $sabitler [, bool $buyukluk_duyarli = true ] )

define() işlevi herkesin bildiği gibi yavaştır. APC'nin esas faydası betik ve uygulamaların başarımını arttırmak olduğu için böyle bir mekanizma ile yığın sabit tanımlama imkanı sağlanmak istenmiştir. Bununla birlikte bu işlev beklenen başarımı sağlamamaktadır.

Daha iyi başarım sağlayan bir çözüm için, PECL'de bulunan » hidef eklentisini deneyin.

Bilginize: Bütün önbelleği temizlemeden bir grup sabiti depodan silmek için boş bir dizi, sabitler değiştirgesi olarak geçirilebilir.

Değiştirgeler

anahtar

anahtar depolanan sabitleri isimlendirmekte kullanılır. apc_load_constants() işlevine değiştirge olarak geçirilerek tanımlanan sabitlere ulaşılabilir.

sabitler

sabit_adi => deger çiftlerinden oluşan bir ilişkisel dizi. sabit_adi normal sabit isimlendirme kurallarına uymalıdır. deger sayıl (scalar) bir değer olmalıdır.

buyukluk_duyarli

İşlevin öntanımlı davranışı harf büyüklüğüne duyarlıdır, yani SABIT ile Sabit farklı değerlerdir. Eğer bu değiştirge FALSE olarak ayarlanırsa sabitler harf büyüklüğüne duyarsız sembollerle tanımlanacaktır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - apc_define_constants() örneği

<?php
$sabitler = array(
    'BIR'   => 1,
    'IKI'   => 2,
    'UC'    => 3,
);
apc_define_constants('sayilar', $sabitler);
echo BIR, IKI, UC;
?>

Yukarıdaki örneğin çıktısı:

123

Ayrıca Bakınız

  • apc_load_constants() - Önbellekten bir sabit kümesini yükler
  • define() - Bir isimli sabit tanımlar
  • constant() - Bir sabitin değerini döndürür
  • veya PHP Sabitleri belgesi

apc_dec
apc_delete_file
APC İşlevleri


Deletes files from the opcode cache

apc_define_constants
apc_delete
APC İşlevleri
PHP Manual

apc_delete_file

(PECL apc >= 3.1.1)

apc_delete_file — Deletes files from the opcode cache

Açıklama

mixed apc_delete_file ( mixed $keys )

Deletes the given files from the opcode cache.

Değiştirgeler

keys

The files to be deleted. Accepts a string, array of strings, or an APCIterator object.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. Or if keys is an array, then an empty array is returned on success, or an array of failed files is returned.

Örnekler

Örnek 1 apc_delete_file() example

<?php
$filename = 'file.php';

if (apc_compile_file($filename)) {

    if (apc_delete_file($filename)) {
        echo "Successfully deleted file $filename from APC cache.", PHP_EOL;
    }
}

if (apc_compile_file($filename)) {

    if ($good = apc_delete_file(array($filename, 'donotexist.php'))) {
        var_dump($good);
    }
}

$bad = apc_delete_file('donotexist.php');
var_dump($bad);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Successfully deleted file file.php from APC cache.
[Mon May 24 09:30:33 2010] [apc-warning] Could not stat file donotexist.php, unable to delete from cache. in /tmp/test.php on line 13.
array(1) {
  [0]=>
  string(14) "donotexist.php"
}
[Mon May 24 09:30:33 2010] [apc-warning] Could not stat file donotexist.php, unable to delete from cache. in /tmp/test.php on line 18.
bool(false)

Ayrıca Bakınız

  • apc_clear_cache() - APC önbelleğini temizler
  • apc_delete() - Depolanmış bir değişkeni önbellekten siler
  • apc_exists() - Checks if APC key exists
apc_define_constants
apc_delete
APC İşlevleri


Depolanmış bir değişkeni önbellekten siler

apc_delete_file
apc_exists
APC İşlevleri
PHP Manual

apc_delete

(PECL apc >= 3.0.0)

apc_delete — Depolanmış bir değişkeni önbellekten siler

Açıklama

bool apc_delete ( string $anahtar )

Depolanmış bir değişkeni önbellekten siler.

Değiştirgeler

anahtar

Değeri saklamakta kullanılmak üzere apc_store() işlevi ile verilmiş anahtar.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - apc_delete() örneği

<?php
$bar = 'BAR';
apc_store('foo', $bar);
apc_delete('foo');
// saklayip, hemen arkasindan silmek, elbette bir ise yaramaz.
?>

Ayrıca Bakınız

  • apc_store() - Bir değişkeni veri deposunda saklar
  • apc_fetch() - Depolanmış bir değişkeni önbellekten alır

apc_delete_file
apc_exists
APC İşlevleri


Checks if APC key exists

apc_delete
apc_fetch
APC İşlevleri
PHP Manual

apc_exists

(PECL apc >= 3.1.4)

apc_exists — Checks if APC key exists

Açıklama

mixed apc_exists ( mixed $keys )

Checks if one or more APC keys exist.

Değiştirgeler

keys

A string, or an array of strings, that contain keys.

Dönen Değerler

Returns TRUE if the key exists, otherwise FALSE Or if an array was passed to keys, then an array is returned that contains all existing keys, or an empty array if none exist.

Örnekler

Örnek 1 apc_exists() example

<?php
$fruit  = 'apple';
$veggie = 'carrot';

apc_store('foo', $fruit);
apc_store('bar', $veggie);

if (apc_exists('foo')) {
    echo "Foo exists: ";
    echo apc_fetch('foo');
} else {
    echo "Foo does not exist";
}

echo PHP_EOL;
if (apc_exists('baz')) {
    echo "Baz exists.";
} else {
    echo "Baz does not exist";
}

echo PHP_EOL;

$ret = apc_exists(array('foo', 'donotexist', 'bar'));
var_dump($ret);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Foo exists: apple
Baz does not exist
array(2) {
  ["foo"]=>
  bool(true)
  ["bar"]=>
  bool(true)
}

Ayrıca Bakınız

  • apc_cache_info() - APC'nin veri deposundan önbellek bilgisini gösterir
  • apc_fetch() - Depolanmış bir değişkeni önbellekten alır
apc_delete
apc_fetch
APC İşlevleri


Depolanmış bir değişkeni önbellekten alır

apc_exists
apc_inc
APC İşlevleri
PHP Manual

apc_fetch

(PECL apc >= 3.0.0)

apc_fetch — Depolanmış bir değişkeni önbellekten alır

Açıklama

mixed apc_fetch ( string $anahtar [, bool &$durum ] )

Depolanmış bir değişkeni önbellekten alır.

Değiştirgeler

anahtar

apc_store() işlevi ile değeri depolamak için kullanılan anahtar.

durum

Başarı durumunda TRUE, aksi durumda FALSE değerini alır.

Dönen Değerler

Başarı durumda depolanmış değişken, aksi durumda FALSE

Örnekler

Örnek 1 - apc_fetch() örneği

<?php
$bar = 'BAR';
apc_store('foo', $bar);
var_dump(apc_fetch('foo'));
?>

Yukarıdaki örneğin çıktısı:

string(3) "BAR"

Ayrıca Bakınız

  • apc_store() - Bir değişkeni veri deposunda saklar
  • apc_delete() - Depolanmış bir değişkeni önbellekten siler

apc_exists
apc_inc
APC İşlevleri


Increase a stored number

apc_fetch
apc_load_constants
APC İşlevleri
PHP Manual

apc_inc

(PECL apc >= 3.1.1)

apc_inc — Increase a stored number

Açıklama

int apc_inc ( string $key [, int $step = 1 [, bool &$success ]] )

Increases a stored number.

Değiştirgeler

key

The key of the value being increased.

step

The step, or value to increase.

success

Optionally pass the success or fail boolean value to this referenced variable.

Dönen Değerler

Returns the current value of key's value on success, başarısızlık durumunda FALSE döner

Örnekler

Örnek 1 apc_inc() example

<?php
echo "Let's do something with success", PHP_EOL;

apc_store('anumber', 42);

echo apc_fetch('anumber'), PHP_EOL;

echo apc_inc('anumber'), PHP_EOL;
echo apc_inc('anumber', 10), PHP_EOL;
echo apc_inc('anumber', 10, $success), PHP_EOL;

var_dump($success);

echo "Now, let's fail", PHP_EOL, PHP_EOL;

apc_store('astring', 'foo');

$ret = apc_inc('astring', 1, $fail);

var_dump($ret);
var_dump($fail);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

42
43
53
63
bool(true)
Now, let's fail

bool(false)
bool(false)

Ayrıca Bakınız

  • apc_dec() - Decrease a stored number
apc_fetch
apc_load_constants
APC İşlevleri


Önbellekten bir sabit kümesini yükler

apc_inc
apc_sma_info
APC İşlevleri
PHP Manual

apc_load_constants

(PECL apc >= 3.0.0)

apc_load_constants — Önbellekten bir sabit kümesini yükler

Açıklama

bool apc_load_constants ( string $anahtar [, bool $buyukluk_duyarli = true ] )

Önbellekten bir dizi sabiti yükler.

Değiştirgeler

anahtar

Sabitleri yığın halinde apc_define_constants() ile önbelleğe saklarken verilmiş isim.

buyukluk_duyarli

İşlevin öntanımlı davranışı harf büyüklüğüne duyarlıdır, yani SABIT ile Sabit farklı değerlerdir. Eğer bu değiştirge FALSE olarak ayarlanırsa sabitler harf büyüklüğüne duyarsız sembollerle tanımlanacaktır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - apc_load_constants() örneği

<?php
$sabitler = array(
    'BIR'   => 1,
    'IKI'   => 2,
    'UC' => 3,
);
apc_define_constants('sayilar', $sabitler);
apc_load_constants('sayilar');
echo BIR, IKI, UC;
?>

Yukarıdaki örneğin çıktısı:

123

Ayrıca Bakınız

  • apc_define_constants() - Yeniden çağırmak ve yığın tanımlama için bir grup sabit tanımlar
  • define() - Bir isimli sabit tanımlar
  • constant() - Bir sabitin değerini döndürür
  • veya PHP Sabitleri Belgesi

apc_inc
apc_sma_info
APC İşlevleri


APC paylaşımlı bellek tahsis durumu bilgisini verir

apc_load_constants
apc_store
APC İşlevleri
PHP Manual

apc_sma_info

(PECL apc >= 2.0.0)

apc_sma_info — APC paylaşımlı bellek tahsis durumu bilgisini verir

Açıklama

array apc_sma_info ([ bool $sınırlı = false ] )

APC paylaşımlı bellek tahsis durumu bilgisini verir.

Değiştirgeler

sınırlı

Bu değiştirge FALSE olarak ayarlandığı zaman apc_sma_info() işlevi her bir bölüm için daha ayrıntılı bilgi verecektir. FALSE öntanımlı değerdir.

Dönen Değerler

Başarı durumunda paylaşımlı bellek tahsis verileri, hata durumunda FALSE.

Örnekler

Örnek 1 - apc_sma_info() örneği

<?php
print_r(apc_sma_info());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [num_seg] => 1
    [seg_size] => 31457280
    [avail_mem] => 31448408
    [block_lists] => Array
        (
            [0] => Array
                (
                    [0] => Array
                        (
                            [size] => 31448408
                            [offset] => 8864
                        )

                )

        )

)

Ayrıca Bakınız

  • APC yapılandırma yönergeleri

apc_load_constants
apc_store
APC İşlevleri


Bir değişkeni veri deposunda saklar

apc_sma_info
APCu
APC İşlevleri
PHP Manual

apc_store

(PECL apc >= 3.0.0)

apc_store — Bir değişkeni veri deposunda saklar

Açıklama

bool apc_store ( string $anahtar , mixed $degisken [, int $yasam_suresi = 0 ] )

Bir değişkeni veri deposunda saklar.

Bilginize: apc_store() işlevi ile saklanan değişkenler, PHP'nin diğer saklama yöntemlerinin aksine, istekler arasında kalıcı olacaktır (değer önbellekten kaldırılana kadar).

Değiştirgeler

anahtar

Değişken depoda bu isimle saklanacaktır. anahtarlar önbellekte benzersizdir, aynı isimde ikinci bir değer saklamaya çalışmak asıl değerin üzerine yazacaktır.

degisken

Saklanacak değişken.

yasam_suresi

Yaşam Süresi (ttl); degisken, yasam_suresi saniye süresince depoda saklanacaktır. yasam_suresi geçildikten sonraki istekte önbellekten çıkartılacaktır. Eğer yasam_suresi verilmediyse veya 0 olarak ayarlandıysa, değer el yordamıyla silinmediği veya önbellek boşaltılma, yeniden başlatma, vs. gibi süreçler ile temizlenmediği sürece saklanacaktır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - apc_store() örneği

<?php
$bilgi = 'bilgi';
apc_store('sakla', $bilgi);
var_dump(apc_fetch('sakla'));
?>

Yukarıdaki örneğin çıktısı:

string(5) "bilgi"

Ayrıca Bakınız

  • apc_add() - Bir değişkeni önbellek veri deposunda saklar
  • apc_fetch() - Depolanmış bir değişkeni önbellekten alır
  • apc_delete() - Depolanmış bir değişkeni önbellekten siler

apc_sma_info
APCu
APC İşlevleri


APC User Cache

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • APCu İşlevleri
    • apcu_add — Cache a new variable in the data store
    • apcu_cache_info — Retrieves cached information from APCu's data store
    • apcu_cas — Updates an old value with a new value
    • apcu_clear_cache — Clears the APCu cache
    • apcu_dec — Decrease a stored number
    • apcu_delete — Removes a stored variable from the cache
    • apcu_entry — Atomically fetch or generate a cache entry
    • apcu_exists — Checks if entry exists
    • apcu_fetch — Fetch a stored variable from the cache
    • apcu_inc — Increase a stored number
    • apcu_sma_info — Retrieves APCu Shared Memory Allocation information
    • apcu_store — Cache a variable in the data store
  • APCUIterator — The APCUIterator class
    • APCUIterator::__construct — Constructs an APCUIterator iterator object
    • APCUIterator::current — Get current item
    • APCUIterator::getTotalCount — Get total count
    • APCUIterator::getTotalHits — Get total cache hits
    • APCUIterator::getTotalSize — Get total cache size
    • APCUIterator::key — Get iterator key
    • APCUIterator::next — Move pointer to next item
    • APCUIterator::rewind — Rewinds iterator
    • APCUIterator::valid — Checks if current position is valid
apc_store
Giriş
PHP'nin Davranışını Etkileyenler


Giriş

APCu is APC stripped of opcode caching.

The first APCu codebase was versioned 4.0.0, it was forked from the head of the APC master branch at the time.

PHP 7 support is available as of APCu 5.0.0.

APCu can provide a compatibility mode, such that it can provide a drop in replacement for the applicable parts of APC.

APCu
Yapılandırma/Kurulum
APCu


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
APCu


Kurulum

If backward compatibility with the applicable parts of APC is required, APCu must be configured with the option --enable-apcu-bc.

Uyarı

PHP 7 has a separate module (» apc.so) for backwards compatibility with APC.

In backward compatibility mode, APCu registers the applicable APC functions with backward compatible prototypes.

Where an APC function accepted cache_type, it is simply ignored by the backward compatible version, and omitted from the prototype for the APCu version.

Bilginize: On Windows, APCu needs a temp path to exist, and be writable by the web server. It checks the TMP, TEMP and USERPROFILE environment variables in that order and finally tries the WINDOWS directory if none of those are set.

Bilginize: For more in-depth, highly technical implementation details, see the » developer-supplied TECHNOTES file .

APCu sources can be found » here.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Although the default APCu settings are fine for many installations, serious users should consider tuning the following parameters.

There is one decision to be made configuring APCu. How much memory is going to be allocated to APCu. The ini directive that controls this is apc.shm_size Read the sections on this carefully below.

Once the server is running, the apc.php script that is bundled with the extension should be copied somewhere into the docroot and viewed with a browser as it provides a detailed analysis of the internal workings of APCu. If GD is enabled in PHP, it will even display some interesting graphs. If APCu is working, the Cache full count number (on the left) will display the number of times the cache has reached maximum capacity and has had to forcefully clean any entries that haven't been accessed in the last apc.ttl seconds. This number is minimized in a well-configured cache. If the cache is constantly being filled, and thusly forcefully freed, the resulting churning will have disparaging effects on script performance. The easiest way to minimize this number is to allocate more memory for APCu.

When APCu is compiled with mmap support (Memory Mapping), it will use only one memory segment, unlike when APCu is built with SHM (SysV Shared Memory) support that uses multiple memory segments. MMAP does not have a maximum limit like SHM does in /proc/sys/kernel/shmmax. In general MMAP support is recommeded because it will reclaim the memory faster when the webserver is restarted and all in all reduces memory allocation impact at startup.

APCu configuration options
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
apc.enabled | "1" | PHP_INI_SYSTEM |
apc.shm_segments | "1" | PHP_INI_SYSTEM |
apc.shm_size | "32M" | PHP_INI_SYSTEM |
apc.entries_hint | "4096" | PHP_INI_SYSTEM |
apc.ttl | "0" | PHP_INI_SYSTEM |
apc.gc_ttl | "3600" | PHP_INI_SYSTEM |
apc.mmap_file_mask | NULL | PHP_INI_SYSTEM |
apc.slam_defense | "1" | PHP_INI_SYSTEM |
apc.enable_cli | "0" | PHP_INI_SYSTEM |
apc.use_request_time | "1" | PHP_INI_ALL |
apc.serializer | "default" | PHP_INI_SYSTEM |
apc.rfc1867 | "0" | PHP_INI_SYSTEM |
apc.rfc1867_prefix | "upload_" | PHP_INI_SYSTEM |
apc.rfc1867_name | "APC_UPLOAD_PROGRESS" | PHP_INI_SYSTEM |
apc.rfc1867_freq | "0" | PHP_INI_SYSTEM |
apc.rfc1867_ttl | "3600" | PHP_INI_SYSTEM |
apc.coredump_unmap | "0" | PHP_INI_SYSTEM |
apc.preload_path | NULL | PHP_INI_SYSTEM |
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

apc.enabled boolean

apc.enabled can be set to 0 to disable APC. This is primarily useful when APC is statically compiled into PHP, since there is no other way to disable it (when compiled as a DSO, the extension line in php.ini can just be commented-out).

apc.shm_segments integer

The number of shared memory segments to allocate for the compiler cache. If APC is running out of shared memory but apc.shm_size is set as high as the system allows, raising this value might prevent APC from exhausting its memory.

apc.shm_size string

The size of each shared memory segment given by a shorthand notation as described in this FAQ. By default, some systems (including most BSD variants) have very low limits on the size of a shared memory segment.

apc.entries_hint integer

A "hint" about the number of distinct variables that might be stored. Set to zero or omit if not sure.

apc.ttl integer

The number of seconds a cache entry is allowed to idle in a slot in case this cache entry slot is needed by another entry. Leaving this at zero means that APC's cache could potentially fill up with stale entries while newer entries won't be cached. In the event of a cache running out of available memory, the cache will be completely expunged if ttl is equal to 0. Otherwise, if the ttl is greater than 0, APC will attempt to remove expired entries.

apc.gc_ttl integer

The number of seconds that a cache entry may remain on the garbage-collection list. This value provides a fail-safe in the event that a server process dies while executing a cached source file; if that source file is modified, the memory allocated for the old version will not be reclaimed until this TTL reached. Set to zero to disable this feature.

apc.mmap_file_mask string

If compiled with MMAP support by using --enable-mmap this is the mktemp-style file_mask to pass to the mmap module for determining whether your mmap'ed memory region is going to be file-backed or shared memory backed. For straight file-backed mmap, set it to something like /tmp/apc.XXXXXX (exactly 6 Xs). To use POSIX-style shm_open/mmap put a .shm somewhere in your mask. e.g. /apc.shm.XXXXXX You can also set it to /dev/zero to use your kernel's /dev/zero interface to anonymous mmap'ed memory. Leaving it undefined will force an anonymous mmap.

apc.slam_defense integer

On very busy servers whenever you start the server or modify files you can create a race of many processes all trying to cache the same file at the same time. This option sets the percentage of processes that will skip trying to cache an uncached file. Or think of it as the probability of a single process to skip caching. For example, setting apc.slam_defense to 75 would mean that there is a 75% chance that the process will not cache an uncached file. So, the higher the setting the greater the defense against cache slams. Setting this to 0 disables this feature.

apc.enable_cli integer

Mostly for testing and debugging. Setting this enables APC for the CLI version of PHP. Under normal circumstances, it is not ideal to create, populate and destroy the APC cache on every CLI request, but for various test scenarios it is useful to be able to enable APC for the CLI version of PHP easily.

apc.serializer string

Used to configure APC to use a third party serializer.

apc.rfc1867 boolean

RFC1867 File Upload Progress hook handler is only available if APC was compiled against PHP 5.2.0 or later. When enabled, any file uploads which includes a field called APC_UPLOAD_PROGRESS before the file field in an upload form will cause APC to automatically create an upload_key user cache entry where key is the value of the APC_UPLOAD_PROGRESS form entry.

Note that the hidden field specified by APC_UPLOAD_PROGRESS must come before the file field, otherwise the upload progress will not work correctly.

Note that the file upload tracking is not threadsafe at this point, so new uploads that happen while a previous one is still going will disable the tracking for the previous.

Note that the rate is only available once all file transfers are completed.

Örnek 1 An apc.rfc1867 example

<?php
print_r(apcu_fetch("upload_$_POST[APC_UPLOAD_PROGRESS]"));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [total] => 1142543
    [current] => 1142543
    [rate] => 1828068.8
    [filename] => test
    [name] => file
    [temp_filename] => /tmp/php8F
    [cancel_upload] => 0
    [done] => 1
)

apc.rfc1867_prefix string

Key prefix to use for the user cache entry generated by rfc1867 upload progress functionality.

apc.rfc1867_name string

Specify the hidden form entry name that activates APC upload progress and specifies the user cache key suffix.

apc.rfc1867_freq string

The frequency that updates should be made to the user cache entry for upload progress. This can take the form of a percentage of the total file size or a size in bytes optionally suffixed with "k", "m", or "g" for kilobytes, megabytes, or gigabytes respectively (case insensitive). A setting of 0 updates as often as possible, which may cause slower uploads.

apc.rfc1867_ttl integer

TTL for rfc1867 entries.

apc.coredump_unmap boolean

Enables APC handling of signals, such as SIGSEGV, that write core files when signaled. When these signals are received, APC will attempt to unmap the shared memory segment in order to exclude it from the core file. This setting may improve system stability when fatal signals are received and a large APC shared memory segment is configured.

Uyarı

This feature is potentially dangerous. Unmapping the shared memory segment in a fatal signal handler may cause undefined behaviour if a fatal error occurs.

Bilginize:

Although some kernels may provide a facility to ignore various types of shared memory when generating a core dump file, these implementations may also ignore important shared memory segments such as the Apache scoreboard.

apc.preload_path string

Optionally, set a path to the directory that APC will load cache data at startup.

apc.use_request_time bool

Use the SAPI request start time for TTL.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

APC_ITER_ALL (integer)
APC_ITER_ATIME (integer)
APC_ITER_CTIME (integer)
APC_ITER_DEVICE (integer)
APC_ITER_DTIME (integer)
APC_ITER_FILENAME (integer)
APC_ITER_INODE (integer)
APC_ITER_KEY (integer)
APC_ITER_MD5 (integer)
APC_ITER_MEM_SIZE (integer)
APC_ITER_MTIME (integer)
APC_ITER_NONE (integer)
APC_ITER_NUM_HITS (integer)
APC_ITER_REFCOUNT (integer)
APC_ITER_TTL (integer)
APC_ITER_TYPE (integer)
APC_ITER_VALUE (integer)
APC_LIST_ACTIVE (integer)
APC_LIST_DELETED (integer)

Özkaynak Türleri
APCu İşlevleri
APCu


APCu İşlevleri

İçindekiler

  • apcu_add — Cache a new variable in the data store
  • apcu_cache_info — Retrieves cached information from APCu's data store
  • apcu_cas — Updates an old value with a new value
  • apcu_clear_cache — Clears the APCu cache
  • apcu_dec — Decrease a stored number
  • apcu_delete — Removes a stored variable from the cache
  • apcu_entry — Atomically fetch or generate a cache entry
  • apcu_exists — Checks if entry exists
  • apcu_fetch — Fetch a stored variable from the cache
  • apcu_inc — Increase a stored number
  • apcu_sma_info — Retrieves APCu Shared Memory Allocation information
  • apcu_store — Cache a variable in the data store
Öntanımlı Sabitler
apcu_add
APCu


Cache a new variable in the data store

APCu İşlevleri
apcu_cache_info
APCu İşlevleri
PHP Manual

apcu_add

(PECL apcu >= 4.0.0)

apcu_add — Cache a new variable in the data store

Açıklama

bool apcu_add ( string $key , mixed $var [, int $ttl = 0 ] )
array apcu_add ( array $values [, mixed $unused = NULL [, int $ttl = 0 ]] )

Caches a variable in the data store, only if it's not already stored.

Bilginize: Unlike many other mechanisms in PHP, variables stored using apcu_add() will persist between requests (until the value is removed from the cache).

Değiştirgeler

key

Store the variable using this name. keys are cache-unique, so attempting to use apcu_add() to store data with a key that already exists will not overwrite the existing data, and will instead return FALSE. (This is the only difference between apcu_add() and apcu_store().)

var

The variable to store

ttl

Time To Live; store var in the cache for ttl seconds. After the ttl has passed, the stored variable will be expunged from the cache (on the next request). If no ttl is supplied (or if the ttl is 0), the value will persist until it is removed from the cache manually, or otherwise fails to exist in the cache (clear, restart, etc.).

values

Names in key, variables in value.

Dönen Değerler

Returns TRUE if something has effectively been added into the cache, FALSE otherwise. Second syntax returns array with error keys.

Örnekler

Örnek 1 A apcu_add() example

<?php
$bar = 'BAR';
apcu_add('foo', $bar);
var_dump(apcu_fetch('foo'));
echo "\n";
$bar = 'NEVER GETS SET';
apcu_add('foo', $bar);
var_dump(apcu_fetch('foo'));
echo "\n";
?>

Yukarıdaki örneğin çıktısı:

string(3) "BAR"
string(3) "BAR"

Ayrıca Bakınız

  • apcu_store() - Cache a variable in the data store
  • apcu_fetch() - Fetch a stored variable from the cache
  • apcu_delete() - Removes a stored variable from the cache

APCu İşlevleri
apcu_cache_info
APCu İşlevleri


Retrieves cached information from APCu's data store

apcu_add
apcu_cas
APCu İşlevleri
PHP Manual

apcu_cache_info

(PECL apcu >= 4.0.0)

apcu_cache_info — Retrieves cached information from APCu's data store

Açıklama

array apcu_cache_info ([ bool $limited = false ] )

Retrieves cached information and meta-data from APC's data store.

Değiştirgeler

limited

If limited is TRUE, the return value will exclude the individual list of cache entries. This is useful when trying to optimize calls for statistics gathering.

Dönen Değerler

Array of cached data (and meta-data) başarısızlık durumunda FALSE döner

Bilginize: apcu_cache_info() will raise a warning if it is unable to retrieve APC cache data. This typically occurs when APC is not enabled.

Sürüm Bilgisi

Sürüm: | Açıklama
3.0.11 | The limited parameter was introduced.
3.0.16 | The "filehits" option for the cache_type parameter was introduced.

Örnekler

Örnek 1 A apcu_cache_info() example

<?php
print_r(apcu_cache_info());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [num_slots] => 2000
    [ttl] => 0
    [num_hits] => 9
    [num_misses] => 3
    [start_time] => 1123958803
    [cache_list] => Array
        (
            [0] => Array
                (
                    [filename] => /path/to/apcu_test.php
                    [device] => 29954
                    [inode] => 1130511
                    [type] => file
                    [num_hits] => 1
                    [mtime] => 1123960686
                    [creation_time] => 1123960696
                    [deletion_time] => 0
                    [access_time] => 1123962864
                    [ref_count] => 1
                    [mem_size] => 677
                )
            [1] => Array (...iterates for each cached file)
)

Ayrıca Bakınız

  • APCu configuration directives
  • APCUIterator::getTotalSize() - Get total cache size
  • APCUIterator::getTotalHits() - Get total cache hits
  • APCUIterator::getTotalCount() - Get total count

apcu_add
apcu_cas
APCu İşlevleri


Updates an old value with a new value

apcu_cache_info
apcu_clear_cache
APCu İşlevleri
PHP Manual

apcu_cas

(PECL apcu >= 4.0.0)

apcu_cas — Updates an old value with a new value

Açıklama

bool apcu_cas ( string $key , int $old , int $new )

apcu_cas() updates an already existing integer value if the old parameter matches the currently stored value with the value of the new parameter.

Değiştirgeler

key

The key of the value being updated.

old

The old value (the value currently stored).

new

The new value to update to.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 apcu_cas() example

<?php
apcu_store('foobar', 2);
echo '$foobar = 2', PHP_EOL;
echo '$foobar == 1 ? 2 : 1 = ', (apcu_cas('foobar', 1, 2) ? 'ok' : 'fail'), PHP_EOL;
echo '$foobar == 2 ? 1 : 2 = ', (apcu_cas('foobar', 2, 1) ? 'ok' : 'fail'), PHP_EOL;

echo '$foobar = ', apcu_fetch('foobar'), PHP_EOL;

echo '$f__bar == 1 ? 2 : 1 = ', (apcu_cas('f__bar', 1, 2) ? 'ok' : 'fail'), PHP_EOL;

apcu_store('perfection', 'xyz');
echo '$perfection == 2 ? 1 : 2 = ', (apcu_cas('perfection', 2, 1) ? 'ok' : 'epic fail'), PHP_EOL;

echo '$foobar = ', apcu_fetch('foobar'), PHP_EOL;
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

$foobar = 2
$foobar == 1 ? 2 : 1 = fail
$foobar == 2 ? 1 : 2 = ok
$foobar = 1
$f__bar == 1 ? 2 : 1 = fail
$perfection == 2 ? 1 : 2 = epic fail
$foobar = 1

Ayrıca Bakınız

  • apcu_dec() - Decrease a stored number
  • apcu_store() - Cache a variable in the data store
apcu_cache_info
apcu_clear_cache
APCu İşlevleri


Clears the APCu cache

apcu_cas
apcu_dec
APCu İşlevleri
PHP Manual

apcu_clear_cache

(PECL apcu >= 4.0.0)

apcu_clear_cache — Clears the APCu cache

Açıklama

bool apcu_clear_cache ( void )

Clears the cache.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE always

Ayrıca Bakınız

  • apcu_cache_info() - Retrieves cached information from APCu's data store

apcu_cas
apcu_dec
APCu İşlevleri


Decrease a stored number

apcu_clear_cache
apcu_delete
APCu İşlevleri
PHP Manual

apcu_dec

(PECL apcu >= 4.0.0)

apcu_dec — Decrease a stored number

Açıklama

int apcu_dec ( string $key [, int $step = 1 [, bool &$success ]] )

Decreases a stored integer value.

Değiştirgeler

key

The key of the value being decreased.

step

The step, or value to decrease.

success

Optionally pass the success or fail boolean value to this referenced variable.

Dönen Değerler

Returns the current value of key's value on success, başarısızlık durumunda FALSE döner

Örnekler

Örnek 1 apcu_dec() example

<?php
echo "Let's do something with success", PHP_EOL;

apcu_store('anumber', 42);

echo apcu_fetch('anumber'), PHP_EOL;

echo apcu_dec('anumber'), PHP_EOL;
echo apcu_dec('anumber', 10), PHP_EOL;
echo apcu_dec('anumber', 10, $success), PHP_EOL;

var_dump($success);

echo "Now, let's fail", PHP_EOL, PHP_EOL;

apcu_store('astring', 'foo');

$ret = apcu_dec('astring', 1, $fail);

var_dump($ret);
var_dump($fail);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Let's do something with success
42
41
31
21
bool(true)
Now, let's fail

bool(false)
bool(false)

Ayrıca Bakınız

  • apcu_inc() - Increase a stored number
apcu_clear_cache
apcu_delete
APCu İşlevleri


Removes a stored variable from the cache

apcu_dec
apcu_entry
APCu İşlevleri
PHP Manual

apcu_delete

(PECL apcu >= 4.0.0)

apcu_delete — Removes a stored variable from the cache

Açıklama

bool apcu_delete ( mixed $key )

Removes a stored variable from the cache.

Değiştirgeler

key

A key used to store the value as a string for a single key, or as an array of strings for several keys, or as an APCUIterator object.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 A apcu_delete() example

<?php
$bar = 'BAR';
apcu_store('foo', $bar);
apcu_delete('foo');
// this is obviously useless in this form

// Alternatively delete multiple keys.
apcu_delete(['foo', 'bar', 'baz']);

// Or use an Iterator with a regular expression.
apcu_delete(new APCUIterator('#^myprefix_#'));
?>

Ayrıca Bakınız

  • apcu_store() - Cache a variable in the data store
  • apcu_fetch() - Fetch a stored variable from the cache
  • apcu_clear_cache() - Clears the APCu cache
  • APCUIterator

apcu_dec
apcu_entry
APCu İşlevleri


Atomically fetch or generate a cache entry

apcu_delete
apcu_exists
APCu İşlevleri
PHP Manual

apcu_entry

(PECL apcu >= 5.1.0)

apcu_entry — Atomically fetch or generate a cache entry

Açıklama

mixed apcu_entry ( string $key , callable $generator [, int $ttl = 0 ] )

Atomically attempts to find key in the cache, if it cannot be found generator is called, passing key as the only argument. The return value of the call is then cached with the optionally specified ttl, and returned.

Bilginize: When control enters apcu_entry() the lock for the cache is acquired exclusively, it is released when control leaves apcu_entry(): In effect, this turns the body of generator into a critical section, disallowing two processes from executing the same code paths concurrently. In addition, it prohibits the concurrent execution of any other APCu functions, since they will acquire the same lock.

Uyarı

The only APCu function that can be called safely by generator is apcu_entry().

Değiştirgeler

key

Identity of cache entry

generator

A callable that accepts key as the only argument and returns the value to cache.

ttl

Time To Live; store var in the cache for ttl seconds. After the ttl has passed, the stored variable will be expunged from the cache (on the next request). If no ttl is supplied (or if the ttl is 0), the value will persist until it is removed from the cache manually, or otherwise fails to exist in the cache (clear, restart, etc.).

Dönen Değerler

Returns the cached value

Örnekler

Örnek 1 An apcu_entry() example

<?php
$config = apcu_entry("config", function($key) {
 return [
   "fruit" => apcu_entry("config.fruit", function($key){
     return [
       "apples",
       "pears"
     ];
   }),
   "people" => apcu_entry("config.people", function($key){
     return [
      "bob",
      "joe",
      "niki"
     ];
   })
 ];
});

var_dump($config);
?>

Yukarıdaki örneğin çıktısı:

array(2) {
  ["fruit"]=>
  array(2) {
    [0]=>
    string(6) "apples"
    [1]=>
    string(5) "pears"
  }
  ["people"]=>
  array(3) {
    [0]=>
    string(3) "bob"
    [1]=>
    string(3) "joe"
    [2]=>
    string(4) "niki"
  }
}

Ayrıca Bakınız

  • apcu_store() - Cache a variable in the data store
  • apcu_fetch() - Fetch a stored variable from the cache
  • apcu_delete() - Removes a stored variable from the cache

apcu_delete
apcu_exists
APCu İşlevleri


Checks if entry exists

apcu_entry
apcu_fetch
APCu İşlevleri
PHP Manual

apcu_exists

(PECL apcu >= 4.0.0)

apcu_exists — Checks if entry exists

Açıklama

mixed apcu_exists ( mixed $keys )

Checks if one or more APCu entries exist.

Değiştirgeler

keys

A string, or an array of strings, that contain keys.

Dönen Değerler

Returns TRUE if the key exists, otherwise FALSE Or if an array was passed to keys, then an array is returned that contains all existing keys, or an empty array if none exist.

Örnekler

Örnek 1 apcu_exists() example

<?php
$fruit  = 'apple';
$veggie = 'carrot';

apcu_store('foo', $fruit);
apcu_store('bar', $veggie);

if (apcu_exists('foo')) {
    echo "Foo exists: ";
    echo apcu_fetch('foo');
} else {
    echo "Foo does not exist";
}

echo PHP_EOL;
if (apcu_exists('baz')) {
    echo "Baz exists.";
} else {
    echo "Baz does not exist";
}

echo PHP_EOL;

$ret = apcu_exists(array('foo', 'donotexist', 'bar'));
var_dump($ret);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Foo exists: apple
Baz does not exist
array(2) {
  ["foo"]=>
  bool(true)
  ["bar"]=>
  bool(true)
}

Ayrıca Bakınız

  • apcu_cache_info() - Retrieves cached information from APCu's data store
  • apcu_fetch() - Fetch a stored variable from the cache
apcu_entry
apcu_fetch
APCu İşlevleri


Fetch a stored variable from the cache

apcu_exists
apcu_inc
APCu İşlevleri
PHP Manual

apcu_fetch

(PECL apcu >= 4.0.0)

apcu_fetch — Fetch a stored variable from the cache

Açıklama

mixed apcu_fetch ( mixed $key [, bool &$success ] )

Fetchs an entry from the cache.

Değiştirgeler

key

The key used to store the value (with apcu_store()). If an array is passed then each element is fetched and returned.

success

Set to TRUE in success and FALSE in failure.

Dönen Değerler

The stored variable or array of variables on success; FALSE on failure

Örnekler

Örnek 1 A apcu_fetch() example

<?php
$bar = 'BAR';
apcu_store('foo', $bar);
var_dump(apcu_fetch('foo'));
?>

Yukarıdaki örneğin çıktısı:

string(3) "BAR"

Sürüm Bilgisi

Sürüm: | Açıklama
3.0.17 | The success parameter was added.

Ayrıca Bakınız

  • apcu_store() - Cache a variable in the data store
  • apcu_delete() - Removes a stored variable from the cache
  • APCUIterator

apcu_exists
apcu_inc
APCu İşlevleri


Increase a stored number

apcu_fetch
apcu_sma_info
APCu İşlevleri
PHP Manual

apcu_inc

(PECL apcu >= 4.0.0)

apcu_inc — Increase a stored number

Açıklama

int apcu_inc ( string $key [, int $step = 1 [, bool &$success ]] )

Increases a stored number.

Değiştirgeler

key

The key of the value being increased.

step

The step, or value to increase.

success

Optionally pass the success or fail boolean value to this referenced variable.

Dönen Değerler

Returns the current value of key's value on success, başarısızlık durumunda FALSE döner

Örnekler

Örnek 1 apcu_inc() example

<?php
echo "Let's do something with success", PHP_EOL;

apcu_store('anumber', 42);

echo apcu_fetch('anumber'), PHP_EOL;

echo apcu_inc('anumber'), PHP_EOL;
echo apcu_inc('anumber', 10), PHP_EOL;
echo apcu_inc('anumber', 10, $success), PHP_EOL;

var_dump($success);

echo "Now, let's fail", PHP_EOL, PHP_EOL;

apcu_store('astring', 'foo');

$ret = apcu_inc('astring', 1, $fail);

var_dump($ret);
var_dump($fail);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Let's do something with success
42
43
53
63
bool(true)
Now, let's fail

bool(false)
bool(false)

Ayrıca Bakınız

  • apcu_dec() - Decrease a stored number
apcu_fetch
apcu_sma_info
APCu İşlevleri


Retrieves APCu Shared Memory Allocation information

apcu_inc
apcu_store
APCu İşlevleri
PHP Manual

apcu_sma_info

(PECL apcu >= 4.0.0)

apcu_sma_info — Retrieves APCu Shared Memory Allocation information

Açıklama

array apcu_sma_info ([ bool $limited = false ] )

Retrieves APCu Shared Memory Allocation information.

Değiştirgeler

limited

When set to FALSE (default) apcu_sma_info() will return a detailed information about each segment.

Dönen Değerler

Array of Shared Memory Allocation data; FALSE on failure.

Örnekler

Örnek 1 A apcu_sma_info() example

<?php
print_r(apcu_sma_info());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [num_seg] => 1
    [seg_size] => 31457280
    [avail_mem] => 31448408
    [block_lists] => Array
        (
            [0] => Array
                (
                    [0] => Array
                        (
                            [size] => 31448408
                            [offset] => 8864
                        )

                )

        )

)

Ayrıca Bakınız

  • APCu configuration directives

apcu_inc
apcu_store
APCu İşlevleri


Cache a variable in the data store

apcu_sma_info
APCUIterator
APCu İşlevleri
PHP Manual

apcu_store

(PECL apcu >= 4.0.0)

apcu_store — Cache a variable in the data store

Açıklama

bool apcu_store ( string $key , mixed $var [, int $ttl = 0 ] )
array apcu_store ( array $values [, mixed $unused = NULL [, int $ttl = 0 ]] )

Cache a variable in the data store.

Bilginize: Unlike many other mechanisms in PHP, variables stored using apcu_store() will persist between requests (until the value is removed from the cache).

Değiştirgeler

key

Store the variable using this name. keys are cache-unique, so storing a second value with the same key will overwrite the original value.

var

The variable to store

ttl

Time To Live; store var in the cache for ttl seconds. After the ttl has passed, the stored variable will be expunged from the cache (on the next request). If no ttl is supplied (or if the ttl is 0), the value will persist until it is removed from the cache manually, or otherwise fails to exist in the cache (clear, restart, etc.).

values

Names in key, variables in value.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. Second syntax returns array with error keys.

Örnekler

Örnek 1 A apcu_store() example

<?php
$bar = 'BAR';
apcu_store('foo', $bar);
var_dump(apcu_fetch('foo'));
?>

Yukarıdaki örneğin çıktısı:

string(3) "BAR"

Ayrıca Bakınız

  • apcu_add() - Cache a new variable in the data store
  • apcu_fetch() - Fetch a stored variable from the cache
  • apcu_delete() - Removes a stored variable from the cache

apcu_sma_info
APCUIterator
APCu İşlevleri


The APCUIterator class

(PECL apcu >= 5.0.0)

Giriş

The APCUIterator class makes it easier to iterate over large APCu caches. This is helpful as it allows iterating over large caches in steps, while grabbing a defined number of entries per lock instance, so it frees the cache locks for other activities rather than hold up the entire cache to grab 100 (the default) entries. Also, using regular expression matching is more efficient as it's been moved to the C level.

Sınıf Sözdizimi

APCUIterator implements Iterator {
/* Methods */
public __construct ([ mixed $search = null [, int $format = APCU_ITER_ALL [, int $chunk_size = 100 [, int $list = APCU_LIST_ACTIVE ]]]] )
public mixed current ( void )
public int getTotalCount ( void )
public int getTotalHits ( void )
public int getTotalSize ( void )
public string key ( void )
public void next ( void )
public void rewind ( void )
public void valid ( void )
}

İçindekiler

  • APCUIterator::__construct — Constructs an APCUIterator iterator object
  • APCUIterator::current — Get current item
  • APCUIterator::getTotalCount — Get total count
  • APCUIterator::getTotalHits — Get total cache hits
  • APCUIterator::getTotalSize — Get total cache size
  • APCUIterator::key — Get iterator key
  • APCUIterator::next — Move pointer to next item
  • APCUIterator::rewind — Rewinds iterator
  • APCUIterator::valid — Checks if current position is valid
apcu_store
APCUIterator::__construct
APCu


Constructs an APCUIterator iterator object

APCUIterator
APCUIterator::current
APCUIterator
PHP Manual

APCUIterator::__construct

(PECL apcu >= 5.0.0)

APCUIterator::__construct — Constructs an APCUIterator iterator object

Açıklama

public APCUIterator::__construct ([ mixed $search = null [, int $format = APCU_ITER_ALL [, int $chunk_size = 100 [, int $list = APCU_LIST_ACTIVE ]]]] )

Constructs an APCUIterator object.

Değiştirgeler

search

A PCRE regular expression that matches against APCu key names, either as a string for a single regular expression, or as an array of regular expressions. Or, optionally pass in NULL to skip the search.

format

The desired format, as configured with one or more of the APCU_ITER_* constants.

chunk_size

The chunk size. Must be a value greater than 0. The default value is 100.

list

The type to list. Either pass in APCU_LIST_ACTIVE or APCU_LIST_DELETED.

Dönen Değerler

An APCUIterator object on success, or NULL on failure.

Örnekler

Örnek 1 A APCUIterator::__construct() example

<?php
foreach (new APCUIterator('/^counter\./') as $counter) {
    echo "$counter[key]: $counter[value]\n";
    apc_dec($counter['key'], $counter['value']);
}
?>

Ayrıca Bakınız

  • apcu_exists() - Checks if entry exists
  • apcu_cache_info() - Retrieves cached information from APCu's data store
APCUIterator
APCUIterator::current
APCUIterator


Get current item

APCUIterator::__construct
APCUIterator::getTotalCount
APCUIterator
PHP Manual

APCUIterator::current

(PECL apcu >= 5.0.0)

APCUIterator::current — Get current item

Açıklama

public mixed APCUIterator::current ( void )

Gets the current item from the APCUIterator stack.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the current item on success, or FALSE if no more items or exist, or on failure.

Ayrıca Bakınız

  • APCUIterator::next() - Move pointer to next item
  • Iterator::current() - O anki elemanı döndürür
APCUIterator::__construct
APCUIterator::getTotalCount
APCUIterator


Get total count

APCUIterator::current
APCUIterator::getTotalHits
APCUIterator
PHP Manual

APCUIterator::getTotalCount

(PECL apcu >= 5.0.0)

APCUIterator::getTotalCount — Get total count

Açıklama

public int APCUIterator::getTotalCount ( void )

Get the total count.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The total count.

Ayrıca Bakınız

  • APCUIterator::getTotalHits() - Get total cache hits
  • APCUIterator::getTotalSize() - Get total cache size
  • apcu_cache_info() - Retrieves cached information from APCu's data store
APCUIterator::current
APCUIterator::getTotalHits
APCUIterator


Get total cache hits

APCUIterator::getTotalCount
APCUIterator::getTotalSize
APCUIterator
PHP Manual

APCUIterator::getTotalHits

(PECL apcu >= 5.0.0)

APCUIterator::getTotalHits — Get total cache hits

Açıklama

public int APCUIterator::getTotalHits ( void )

Gets the total number of cache hits.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The number of hits on success, or FALSE on failure.

Ayrıca Bakınız

  • APCUIterator::getTotalCount() - Get total count
  • APCUIterator::getTotalSize() - Get total cache size
  • apcu_cache_info() - Retrieves cached information from APCu's data store
APCUIterator::getTotalCount
APCUIterator::getTotalSize
APCUIterator


Get total cache size

APCUIterator::getTotalHits
APCUIterator::key
APCUIterator
PHP Manual

APCUIterator::getTotalSize

(PECL apcu >= 5.0.0)

APCUIterator::getTotalSize — Get total cache size

Açıklama

public int APCUIterator::getTotalSize ( void )

Gets the total cache size.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The total cache size.

Ayrıca Bakınız

  • APCUIterator::getTotalCount() - Get total count
  • APCUIterator::getTotalHits() - Get total cache hits
  • apc_cache_info() - APC'nin veri deposundan önbellek bilgisini gösterir
APCUIterator::getTotalHits
APCUIterator::key
APCUIterator


Get iterator key

APCUIterator::getTotalSize
APCUIterator::next
APCUIterator
PHP Manual

APCUIterator::key

(PECL apcu >= 5.0.0)

APCUIterator::key — Get iterator key

Açıklama

public string APCUIterator::key ( void )

Gets the current iterator key.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the key on success, or FALSE upon failure.

Ayrıca Bakınız

  • APCUIterator::current() - Get current item
  • Iterator::key() - O anki elemanın anahtarını döndürür
APCUIterator::getTotalSize
APCUIterator::next
APCUIterator


Move pointer to next item

APCUIterator::key
APCUIterator::rewind
APCUIterator
PHP Manual

APCUIterator::next

(PECL apcu >= 5.0.0)

APCUIterator::next — Move pointer to next item

Açıklama

public void APCUIterator::next ( void )

Moves the iterator pointer to the next element.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • APCUIterator::current() - Get current item
  • APCUIterator::rewind() - Rewinds iterator
  • Iterator::next() - Konumu sonraki elemana ilerletir
APCUIterator::key
APCUIterator::rewind
APCUIterator


Rewinds iterator

APCUIterator::next
APCUIterator::valid
APCUIterator
PHP Manual

APCUIterator::rewind

(PECL apcu >= 5.0.0)

APCUIterator::rewind — Rewinds iterator

Açıklama

public void APCUIterator::rewind ( void )

Rewinds back the iterator to the first element.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • APCUIterator::next() - Move pointer to next item
  • Iterator::next() - Konumu sonraki elemana ilerletir
APCUIterator::next
APCUIterator::valid
APCUIterator


Checks if current position is valid

APCUIterator::rewind
APD
APCUIterator
PHP Manual

APCUIterator::valid

(PECL apcu >= 5.0.0)

APCUIterator::valid — Checks if current position is valid

Açıklama

public void APCUIterator::valid ( void )

Checks if the current iterator position is valid.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the current iterator position is valid, otherwise FALSE.

Ayrıca Bakınız

  • APCUIterator::current() - Get current item
  • Iterator::valid() - O anki konum geçerli mi diye bakar
APCUIterator::rewind
APD
APCUIterator


Gelişmiş PHP Hata Ayıklayıcısı (Advanced PHP debugger)

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Win32 üzerinde Derleme
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
    • PHP-APD'yi betiklerde kullanmak
  • APD İşlevleri
    • apd_breakpoint — Yorumlayıcıyı durdurur ve soketten bir satırbaşı bekler
    • apd_callstack — Geçerli yordam dökümünü bir dizi olarak döndürür
    • apd_clunk — Bir uyarı ve yordam dökümü verip çıkar
    • apd_continue — Yorumlayıcıyı yeniden başlatır
    • apd_croak — Bir hata ve yordam dökümü verip çıkar
    • apd_dump_function_table — Geçerli işlev tablosunu çıktılar
    • apd_dump_persistent_resources — Tüm kalıcı özkaynakları bir dizi içinde döndürür
    • apd_dump_regular_resources — Geçerli normal özkaynakların tümünü bir dizi olarak döndürür
    • apd_echo — Çıktıyı hata ayıklama soketine gönderir
    • apd_get_active_symbols — Yerel etki alanında geçerli değişken isimlerinden oluşan bir dizi döndürür
    • apd_set_pprof_trace — Hata ayıklama oturumunu başlatır
    • apd_set_session_trace_socket — Uzaktan oturumla hata ayıklamayı başlatır
    • apd_set_session_trace — Hata ayıklama oturumunu başlatır
    • apd_set_session — Geçerli hata ayıklama seviyesini belirtir ya da değiştirir
    • override_function — Yerleşik işlevleri geçersiz kılar
    • rename_function — Küresel işlev tablosunda bir işlevin ismini değiştirir
APCUIterator::valid
Giriş
PHP'nin Davranışını Etkileyenler


Giriş

APD Gelişmiş PHP hata ayıklayıcısıdır (Advanced PHP Debugger). PHP kodları için profil oluşturma ve hata ayıklama imkanları sunmanın yanında tam bir yığın geri izlemesi çıkartabilme özelliği vardır. Etkileşimli hata ayıklamayı desteklemesine rağmen APD, öntanımlı olarak verileri izleme dosyalarına yazar. Ayrıca olay tabanlı günlük tutma özelliği sayesinde farklı betikler için farklı düzeylerdeki bilgiler (işlev çağrıları, değiştirge geçişleri, zamanlamalar vb. gibi) açılıp kapatılabilir.

Dikkat

APD bir Zend Eklentisidir, PHP'nin iç işleyişinin işlev çağrılarını ele alış şeklini değiştirir ve bu yüzden diğer Zend Eklentileri (örneğin Zend Optimizer - Zend Verimlileştiricisi) ile uyumlu olmayabilir.

APD
Yapılandırma/Kurulum
APD


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Win32 üzerinde Derleme
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
APD


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/apd

Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız.

INI dosyanıza aşağıdaki satırları ekleyin:

zend_extension = /mutlak/dosya/yolu/apd.so
apd.dumpdir = /mutlak/dosya/yolu/trace/directory
apd.statement_tracing = 0

PHP kurulumunuza bağlı olarak zend_extension yönergesinde şunlardan biri belirtilebilir:

zend_extension              (ZTS'siz, hata ayıklamasız derleme)
zend_extension_ts           (ZTS'li,  hata ayıklamasız derleme)
zend_extension_debug        (ZTS'siz, hata ayıklamalı derleme)
zend_extension_debug_ts     (ZTS'li,  hata ayıklamalı derleme)

Gereksinimler
Win32 üzerinde Derleme
Yapılandırma/Kurulum


Win32 üzerinde Derleme

APD'yi Windows altında derlemek için http://php.net/ adresinde açıklandığı gibi çalışan bir PHP derleme ortamına ihtiyacınız var. Temel olarak Microsoft Visual C++, win32build.zip, bison/flex ve biraz da bilgi gerekir. Ayrıca, adp.dsp'nin satır sonlandırmasının da DOS türünde olmasına dikkat edin, Unix türünde olduğu takdirde Microsoft Visual C++ bundan şikayet edecektir.

Kurulum
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

APD Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişiklik Yeri | Sürüm Bilgisi
apd.dumpdir | NULL | PHP_INI_ALL |
apd.statement_tracing | "0" | PHP_INI_ALL | 0.9'dan beri kullanılabilmektedir.
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

apd.dumpdir string

APD'nin profil döküm dosyalarını yazacağı dizini belirler. Dizini bir mutlak yol olarak belirtebileceğiniz gibi bir göreli yol olarak da belirtebilirsiniz.

apd_set_pprof_trace() işlevine değiştirge olarak farklı bir dizin belirtebilirsiniz.

apd.statement_tracing boolean

Satır satır izleme yapılıp yapılmayacağı belirtilir. Bu yönergeye 'On' (1) değeri atarsanız uygulamanızın başarısı bundan etkilenecektir.

Win32 üzerinde Derleme
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

APD sabitleri
Sabit | Değer | Açıklama
FUNCTION_TRACE (integer) | 1 |
ARGS_TRACE (integer) | 2 |
ASSIGNMENT_TRACE (integer) | 4 |
STATEMENT_TRACE (integer) | 8 |
MEMORY_TRACE (integer) | 16 |
TIMING_TRACE (integer) | 32 |
SUMMARY_TRACE (integer) | 64 |
ERROR_TRACE (integer) | 128 |
PROF_TRACE (integer) | 256 |
APD_VERSION (string) | örnek: 1.0.2-dev |
Özkaynak Türleri
Örnekler
APD


Örnekler

İçindekiler

  • PHP-APD'yi betiklerde kullanmak
Öntanımlı Sabitler
PHP-APD'yi betiklerde kullanmak
APD


PHP-APD'yi betiklerde kullanmak

  1. İzlemeyi başlatmak için PHP betiğinizin ilk satırında apd_set_pprof_trace() işlevini çağırın.

    apd_set_pprof_trace();

    İşlevi betiğinizdeki herhangi bir satıra da ekleyebilirsiniz, fakat eğer izlemeye betiğinizin başından başlamazsanız diğer şekilde sizi bir başarım dar boğazına sürükleyebilecek olan profil bilgisini atmış olacaksınız.

  2. Şimdi betiği çalıştırın. Döküm çıktısı apd.dumpdir/pprof_pid.ext dosyasına yazılacaktır.

    İpucu

    Eğer PHP'nin CGI sürümünde çalışıyorsanız, apd'nin doğru şekilde çalışması için '-e' seçeneğini kullanarak genişletilmiş bilgiyi etkinleştirmeniz gerekecek. Örneğin: php -e -f script.php

  3. Biçimlendirilmiş profil bilgisini göstermek için, pprofp komutunu istediğiniz sıralama ve gösterme seçenekleri ile çalıştırın. Biçimlendirilmiş çıktı aşağıdaki gibi görünecektir:

    bash-2.05b$ pprofp -R /tmp/pprof.22141.0

Trace for /home/dan/testapd.php
Total Elapsed Time = 0.00
Total System Time  = 0.00
Total User Time    = 0.00

Real         User        System             secs/    cumm
%Time (excl/cumm)  (excl/cumm)  (excl/cumm) Calls    call    s/call  Memory Usage Name
--------------------------------------------------------------------------------------
100.0 0.00 0.00  0.00 0.00  0.00 0.00     1  0.0000   0.0009            0 main
 56.9 0.00 0.00  0.00 0.00  0.00 0.00     1  0.0005   0.0005            0 apd_set_pprof_trace
 28.0 0.00 0.00  0.00 0.00  0.00 0.00    10  0.0000   0.0000            0 preg_replace
 14.3 0.00 0.00  0.00 0.00  0.00 0.00    10  0.0000   0.0000            0 str_replace

    Bu örnekte kullanılan -R seçeneği profil tablosunu betiğin verili işlevi yürütürken kullandığı gerçek zaman miktarına göre sıralar. "cumm call" sütunu her işlevin ortalama kaç kez çağrıldığını, "s/call" sütunu da her işlev çağrısı için ortalama kaç saniye gerektiğini gösterir

  4. KCacheGrind profil çözümleme uygulamasına aktarabileceğiniz bir çağrı-ağacı dosyası oluşturmak için, pprof2calltree komutunu verin.

Örnekler
APD İşlevleri
Örnekler


APD İşlevleri

Erişim bilgileri

Açıklama, hata düzeltmesi, genişletme, veya geliştirmeye yardım istekleriniz için » apd@mail.communityconnect.com adresine bir eposta gönderiniz. Her türlü yardımı memnuniyetle kabul ederiz.

İçindekiler

  • apd_breakpoint — Yorumlayıcıyı durdurur ve soketten bir satırbaşı bekler
  • apd_callstack — Geçerli yordam dökümünü bir dizi olarak döndürür
  • apd_clunk — Bir uyarı ve yordam dökümü verip çıkar
  • apd_continue — Yorumlayıcıyı yeniden başlatır
  • apd_croak — Bir hata ve yordam dökümü verip çıkar
  • apd_dump_function_table — Geçerli işlev tablosunu çıktılar
  • apd_dump_persistent_resources — Tüm kalıcı özkaynakları bir dizi içinde döndürür
  • apd_dump_regular_resources — Geçerli normal özkaynakların tümünü bir dizi olarak döndürür
  • apd_echo — Çıktıyı hata ayıklama soketine gönderir
  • apd_get_active_symbols — Yerel etki alanında geçerli değişken isimlerinden oluşan bir dizi döndürür
  • apd_set_pprof_trace — Hata ayıklama oturumunu başlatır
  • apd_set_session_trace_socket — Uzaktan oturumla hata ayıklamayı başlatır
  • apd_set_session_trace — Hata ayıklama oturumunu başlatır
  • apd_set_session — Geçerli hata ayıklama seviyesini belirtir ya da değiştirir
  • override_function — Yerleşik işlevleri geçersiz kılar
  • rename_function — Küresel işlev tablosunda bir işlevin ismini değiştirir
PHP-APD'yi betiklerde kullanmak
apd_breakpoint
APD


Yorumlayıcıyı durdurur ve soketten bir satırbaşı bekler

APD İşlevleri
apd_callstack
APD İşlevleri
PHP Manual

apd_breakpoint

(PECL apd >= 0.2)

apd_breakpoint — Yorumlayıcıyı durdurur ve soketten bir satırbaşı bekler

Açıklama

bool apd_breakpoint ( int $hata_ayıklama_seviyesi )

Bu işlev betiğinizin çalışmasını durdurur ve bağlı soketten yanıt bekler. Programa adım attırmak için sadece satırbaşı karakteri yollayın ya da çalıştırılacak bir php komutu girin.

Değiştirgeler

hata_ayıklama_düzeyi

XXX_TRACE sabitlerinin toplamından (VEYAlanmasından) oluşan bir tamsayı.

MEMORY_TRACE sabitini kullanmanız önerilmez; çok yavaş olup gerekli doğruluğa sahip görünmemektedir. ASSIGNMENT_TRACE sabiti ise henüz gerçeklenmemiştir.

Tüm işlevselliğe (TIMING, FUNCTIONS, ARGS SUMMARY (strace -c gibi)) sahip olmak için 99 değerini kullanınız.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - tcplisten kullanılan sıradan bir oturum

bash#tcplisten localhost 7777

APD - Advanced PHP Debugger Trace File
---------------------------------------------------------------------------
Process Pid (6118)
Trace Begun at Sun Mar 10 23:13:12 2002
---------------------------------------------------------------------------
(  0.000000): apd_set_session_trace called at /home/alan/Projects/project2/test.
php:5
(  0.074824): apd_set_session_trace_socket() at /home/alan/Projects/project2/tes
t.php:5 returned.  Elapsed (0.074824)
(  0.074918): apd_breakpoint() /home/alan/Projects/project2/test.php:7
              ++ argv[0] $(??) = 9
apd_breakpoint() at /home/alan/Projects/project2/test.php:7 returned.  Elapsed (
-2089521468.1073275368)
>\n
statement: /home/alan/Projects/project2/test.php:8
>\n
statement: /home/alan/Projects/project2/test.php:8
>\n
statement: /home/alan/Projects/project2/test.php:10
>apd_echo($i);
EXEC: apd_echo($i);
0
>apd_echo(serialize(apd_get_active_symbols()));
EXEC:  apd_echo(serialize(apd_get_active_symbols()));
a:47:{i:0;s:4:"PWD";i:1;s:10:"COLORFGBG";i:2;s:11:"XAUTHORITY";i:3;s:14:"
COLORTERM_BCE";i:4;s:9:"WINDOWID";i:5;s:14:"ETERM_VERSION";i:6;s:16:"SE
SSION_MANAGER";i:7;s:4:"PS1";i:8;s:11:"GDMSESSION";i:9;s:5:"USER";i:10;s:5:"
MAIL";i:11;s:7:"OLDPWD";i:12;s:5:"LANG";i:13;s:10:"COLORTERM";i:14;s:8:"DISP
LAY";i:15;s:8:"LOGNAME";i:16;s:6:"
>apd_echo(system('ls /home/mydir'));
........
>apd_continue(0);

APD İşlevleri
apd_callstack
APD İşlevleri


Geçerli yordam dökümünü bir dizi olarak döndürür

apd_breakpoint
apd_clunk
APD İşlevleri
PHP Manual

apd_callstack

(PECL apd 0.2-0.4)

apd_callstack — Geçerli yordam dökümünü bir dizi olarak döndürür

Açıklama

array apd_callstack ( void )

Geçerli yordam dökümünü bir dizi olarak döndürür.

Dönen Değerler

Geçerli yordam dökümünü içeren bir dizi.

Örnekler

Örnek 1 - apd_callstack() örneği

<?php
print_r(apd_callstack());
?>

apd_breakpoint
apd_clunk
APD İşlevleri


Bir uyarı ve yordam dökümü verip çıkar

apd_callstack
apd_continue
APD İşlevleri
PHP Manual

apd_clunk

(PECL apd 0.2-0.4)

apd_clunk — Bir uyarı ve yordam dökümü verip çıkar

Açıklama

void apd_clunk ( string $uyarı [, string $delimiter ] )

Perl'ün Carp::clunk işlevine benzer davranır. Bir uyarı ve yordam dökümü verip çıkar.

Değiştirgeler

uyarı

Verilecek uyarı.

ayraç

Ayraç. <BR /> öntanımlıdır.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 - apd_clunk() örneği

<?php
apd_clunk("Herhangi bir uyarı...", "<br/>");
?>

Ayrıca Bakınız

  • apd_croak() - Bir hata ve yordam dökümü verip çıkar

apd_callstack
apd_continue
APD İşlevleri


Yorumlayıcıyı yeniden başlatır

apd_clunk
apd_croak
APD İşlevleri
PHP Manual

apd_continue

(PECL apd >= 0.2)

apd_continue — Yorumlayıcıyı yeniden başlatır

Açıklama

bool apd_continue ( int $hata_ayıklama_seviyesi )

Yorumlayıcıyı tekrar başlatmak isteği genelde hata ayıklama soketi aracılığıyla gönderilir.

Değiştirgeler

hata_ayıklama_düzeyi

XXX_TRACE sabitlerinin toplamından (VEYAlanmasından) oluşan bir tamsayı.

MEMORY_TRACE sabitini kullanmanız önerilmez; çok yavaş olup gerekli doğruluğa sahip görünmemektedir. ASSIGNMENT_TRACE sabiti ise henüz gerçeklenmemiştir.

Tüm işlevselliğe (TIMING, FUNCTIONS, ARGS SUMMARY (strace -c gibi)) sahip olmak için 99 değerini kullanınız.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - apd_continue() örneği

<?php
apd_continue(0);
?>

apd_clunk
apd_croak
APD İşlevleri


Bir hata ve yordam dökümü verip çıkar

apd_continue
apd_dump_function_table
APD İşlevleri
PHP Manual

apd_croak

(PECL apd 0.2-0.4)

apd_croak — Bir hata ve yordam dökümü verip çıkar

Açıklama

void apd_croak ( string $hata_iletisi [, string $ayraç ] )

Perl'ün Carp::croak işlevi gibi davranır. Bir hata ve yordam dökümü verip çıkar.

Değiştirgeler

hata_iletisi

Verilecek hatanın iletisi.

ayraç

Ayraç. <BR /> öntanımlıdır.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 - apd_croak() örneği

<?php
apd_croak("Bir hata iletisi...","<P>");
?>

Ayrıca Bakınız

  • apd_clunk() - Bir uyarı ve yordam dökümü verip çıkar

apd_continue
apd_dump_function_table
APD İşlevleri


Geçerli işlev tablosunu çıktılar

apd_croak
apd_dump_persistent_resources
APD İşlevleri
PHP Manual

apd_dump_function_table

(Unknown)

apd_dump_function_table — Geçerli işlev tablosunu çıktılar

Açıklama

void apd_dump_function_table ( void )

Geçerli işlev tablosunu çıktılar.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 - apd_dump_function_table() örneği

<?php
apd_dump_function_table();
?>

apd_croak
apd_dump_persistent_resources
APD İşlevleri


Tüm kalıcı özkaynakları bir dizi içinde döndürür

apd_dump_function_table
apd_dump_regular_resources
APD İşlevleri
PHP Manual

apd_dump_persistent_resources

(PECL apd 0.2-0.4)

apd_dump_persistent_resources — Tüm kalıcı özkaynakları bir dizi içinde döndürür

Açıklama

array apd_dump_persistent_resources ( void )

Tüm kalıcı özkaynakları dizi halinde döndürür.

Dönen Değerler

Geçerli çağrı yığınını içeren bir dizi.

Örnekler

Örnek 1 - apd_dump_persistent_resources() örneği

<?php
print_r(apd_dump_persistent_resources());
?>

Ayrıca Bakınız

  • apd_dump_regular_resources() - Geçerli normal özkaynakların tümünü bir dizi olarak döndürür

apd_dump_function_table
apd_dump_regular_resources
APD İşlevleri


Geçerli normal özkaynakların tümünü bir dizi olarak döndürür

apd_dump_persistent_resources
apd_echo
APD İşlevleri
PHP Manual

apd_dump_regular_resources

(PECL apd 0.2-0.4)

apd_dump_regular_resources — Geçerli normal özkaynakların tümünü bir dizi olarak döndürür

Açıklama

array apd_dump_regular_resources ( void )

Geçerli normal özkaynakların tümünü bir dizi olarak döndürür.

Dönen Değerler

Geçerli normal özkaynakları içeren bir dizi.

Örnekler

Örnek 1 - apd_dump_regular_resources() örneği

<?php
print_r(apd_dump_regular_resources());
?>

Ayrıca Bakınız

  • apd_dump_persistent_resources() - Tüm kalıcı özkaynakları bir dizi içinde döndürür

apd_dump_persistent_resources
apd_echo
APD İşlevleri


Çıktıyı hata ayıklama soketine gönderir

apd_dump_regular_resources
apd_get_active_symbols
APD İşlevleri
PHP Manual

apd_echo

(PECL apd >= 0.2)

apd_echo — Çıktıyı hata ayıklama soketine gönderir

Açıklama

bool apd_echo ( string $çıktı )

Çalışan betik hakkında bilgi isteğini hata ayıklama soketi üzerinden gönderilir.

Değiştirgeler

çıktı

Hata ayıklama sürecindeki değişken.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - apd_echo() örneği

<?php
apd_echo($i);
?>

apd_dump_regular_resources
apd_get_active_symbols
APD İşlevleri


Yerel etki alanında geçerli değişken isimlerinden oluşan bir dizi döndürür

apd_echo
apd_set_pprof_trace
APD İşlevleri
PHP Manual

apd_get_active_symbols

(PECL apd 0.2)

apd_get_active_symbols — Yerel etki alanında geçerli değişken isimlerinden oluşan bir dizi döndürür

Açıklama

array apd_get_active_symbols ( void )

Etkin etki alanında tanımlı tüm değişkenlerin isimlerini döndürür (değerlerini değil!).

Dönen Değerler

Tüm değişkenleri içeren çok boyutlu bir dizi.

Örnekler

Örnek 1 - apd_get_active_symbols() örneği

<?php
apd_echo(apd_get_active_symbols());
?>

apd_echo
apd_set_pprof_trace
APD İşlevleri


Hata ayıklama oturumunu başlatır

apd_get_active_symbols
apd_set_session_trace_socket
APD İşlevleri
PHP Manual

apd_set_pprof_trace

(PECL apd >= 0.2)

apd_set_pprof_trace — Hata ayıklama oturumunu başlatır

Açıklama

string apd_set_pprof_trace ([ string $döküm_dizini [, string $önek = "pprof" ]] )

Döküm dizininde pprof_{süreç_kimliği} dosyasına hata ayıklamayı başlatır.

Değiştirgeler

döküm_dizini

Profil döküm dosyasının kaydedileceği dizin. Belirtilmez ise, php.ini dosyasındaki apd.dumpdir ayarı kullanılır.

önek

Dosya ismi için önek; "pprof" öntanımlıdır.

Dönen Değerler

Hedef dosyanın dosya yolunu döndürür.

Örnekler

Örnek 1 - apd_set_pprof_trace() örneği

<?php
apd_set_pprof_trace();
?>

Ayrıca Bakınız

  • apd_set_session_trace() - Hata ayıklama oturumunu başlatır

apd_get_active_symbols
apd_set_session_trace_socket
APD İşlevleri


Uzaktan oturumla hata ayıklamayı başlatır

apd_set_pprof_trace
apd_set_session_trace
APD İşlevleri
PHP Manual

apd_set_session_trace_socket

(PECL apd >= 0.2)

apd_set_session_trace_socket — Uzaktan oturumla hata ayıklamayı başlatır

Açıklama

bool apd_set_session_trace_socket ( string $tcp_sunucusu , int $soket_türü , int $port , int $hata_ayıklama_seviyesi )

Belirtilen tcp_sunucusu'na (örneğin, tcplisten) bağlanır ve hata ayıklama verilerini o bağlantı noktasına gönderir.

Değiştirgeler

tcp_sunucusu

TCP sunucunun IP'si ya da Unix Alanı bağlantı noktası (bir dosya olarak).

soket_türü

Dosya tabanlı bağlantı noktaları için AF_UNIX ya da standart tcp/ip için APD_AF_INET olabilir.

port

Herhangi bir portu kullanabilirsiniz, fakat 1024'ten büyük sayıları kullanmanız küçük sayıların diğer sistem tarafından kullanılıyor olma olasılığı nedeniyle daha iyidir.

hata_ayıklama_düzeyi

XXX_TRACE sabitlerinin toplamından (VEYAlanmasından) oluşan bir tamsayı.

MEMORY_TRACE sabitini kullanmanız önerilmez; çok yavaş olup gerekli doğruluğa sahip görünmemektedir. ASSIGNMENT_TRACE sabiti ise henüz gerçeklenmemiştir.

Tüm işlevselliğe (TIMING, FUNCTIONS, ARGS SUMMARY (strace -c gibi)) sahip olmak için 99 değerini kullanınız.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - apd_set_session_trace_socket() örneği

<?php
  apd_set_session_trace_socket ("127.0.0.1", APD_AF_INET, 7112, 0);
?>

apd_set_pprof_trace
apd_set_session_trace
APD İşlevleri


Hata ayıklama oturumunu başlatır

apd_set_session_trace_socket
apd_set_session
APD İşlevleri
PHP Manual

apd_set_session_trace

(PECL apd 0.2-0.4)

apd_set_session_trace — Hata ayıklama oturumunu başlatır

Açıklama

void apd_set_session_trace ( int $hata_ayıklama_seviyesi [, string $döküm_dizini ] )

Döküm dizininde pprof_{süreç_kimliği} dosyasına hata ayıklamayı başlatır.

Değiştirgeler

hata_ayıklama_düzeyi

XXX_TRACE sabitlerinin toplamından (VEYAlanmasından) oluşan bir tamsayı.

MEMORY_TRACE sabitini kullanmanız önerilmez; çok yavaş olup gerekli doğruluğa sahip görünmemektedir. ASSIGNMENT_TRACE sabiti ise henüz gerçeklenmemiştir.

Tüm işlevselliğe (TIMING, FUNCTIONS, ARGS SUMMARY (strace -c gibi)) sahip olmak için 99 değerini kullanınız.

döküm_dizini

Profil döküm dosyasının kaydedileceği dizin. Belirtilmez ise, php.ini dosyasındaki apd.dumpdir ayarı kullanılır.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 - apd_set_session_trace() örneği

<?php
apd_set_session_trace(99);
?>

apd_set_session_trace_socket
apd_set_session
APD İşlevleri


Geçerli hata ayıklama seviyesini belirtir ya da değiştirir

apd_set_session_trace
override_function
APD İşlevleri
PHP Manual

apd_set_session

(PECL apd 0.2-0.4)

apd_set_session — Geçerli hata ayıklama seviyesini belirtir ya da değiştirir

Açıklama

void apd_set_session ( int $hata_ayıklama_seviyesi )

Bu işlev uygulamanızın belli bir yerinde hata ayıklama seviyesini arttırmak ya da azaltmak için kullanılır.

Değiştirgeler

hata_ayıklama_düzeyi

XXX_TRACE sabitlerinin toplamından (VEYAlanmasından) oluşan bir tamsayı.

MEMORY_TRACE sabitini kullanmanız önerilmez; çok yavaş olup gerekli doğruluğa sahip görünmemektedir. ASSIGNMENT_TRACE sabiti ise henüz gerçeklenmemiştir.

Tüm işlevselliğe (TIMING, FUNCTIONS, ARGS SUMMARY (strace -c gibi)) sahip olmak için 99 değerini kullanınız.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 - apd_set_session() örneği

<?php
apd_set_session(9);
?>

apd_set_session_trace
override_function
APD İşlevleri


Yerleşik işlevleri geçersiz kılar

apd_set_session
rename_function
APD İşlevleri
PHP Manual

override_function

(PECL apd >= 0.2)

override_function — Yerleşik işlevleri geçersiz kılar

Açıklama

bool override_function ( string $işlev_ismi , string $işlev_değiştirgeleri , string $işlev_kodu )

Simge tablosunda değişiklik yaparak yerleşik işlevleri geçersiz kılar.

Değiştirgeler

işlev_ismi

Geçersiz kılınacak işlev.

işlev_değiştirgeleri

Virgülle ayrılmış dizgeler halinde işlev değiştirgeleri.

Genellikle bu değiştirgeleri ve işlev_kodu değiştirgelerini tek tırnakla sınırlanmış dizge olarak geçirmek isteyeceksiniz. Tek tırnaklı dizge kullanımının sebebi değişken isimlerinin işlenmesini engellemektir, aksi durumda, çift tırnak kullanırsanız değişken isimlerinde önceleme karakteri kullanmanız gerekir (\$değişken gibi).

işlev_kodu

İşlevin yeni kodu.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - override_function() örneği

<?php
override_function('test', '$a,$b', 'echo "DNM 123"; return $a * $b;');
?>

apd_set_session
rename_function
APD İşlevleri


Küresel işlev tablosunda bir işlevin ismini değiştirir

override_function
bcompiler
APD İşlevleri
PHP Manual

rename_function

(PECL apd >= 0.2)

rename_function — Küresel işlev tablosunda bir işlevin ismini değiştirir

Açıklama

bool rename_function ( string $özgün_isim , string $yeni_isim )

Küresel işlev tablosunda bir işlevin ismini değiştirir. Yerleşik işlevleri geçici olarak geçersiz kılmak için kullanışlıdır.

Değiştirgeler

özgün_isim

Asıl işlev ismi.

yeni_isim

İşlevin özgün isminin yerini alacak isim.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - rename_function() örneği

<?php
rename_function('mysql_connect', ';debug_mysql_connect' );
?>

override_function
bcompiler
APD İşlevleri


PHP için derleyici

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • bcompiler İşlevleri
    • bcompiler_load_exe — bcompiler exe dosyasından sınıfları okur ve oluşturur
    • bcompiler_load — bz biçiminde sıkıştırılmış dosyadan, sınıfları okur ve oluşturur
    • bcompiler_parse_class — Derlenmiş koddan sınıfı okur ve kullanıcı tanımlı işleve geriçağırım yapar
    • bcompiler_read — Bir dosya tanıtıcısından sınıfları okur ve oluşturur
    • bcompiler_write_class — Tanımlanmış bir sınıfı dosyaya yazar
    • bcompiler_write_constant — Tanımlanmış sabiti dosyaya yazar
    • bcompiler_write_exe_footer — Derlenmiş kodun başlangıç konumunu ve imzasını, exe türü bir dosyanın sonuna yazar
    • bcompiler_write_file — Bir php kaynak dosyasını derleyerek yazar
    • bcompiler_write_footer — Derlenmiş verinin sona erdiğini göstermek için \x00 karakterini yazar
    • bcompiler_write_function — Tanımlı bir işlevi derlenmiş olarak yazar
    • bcompiler_write_functions_from_file — Bir dosya içinde tanımlanmış bütün işlevleri derleyerek yazar
    • bcompiler_write_header — bcompiler dosya başlığını yazar
    • bcompiler_write_included_filename — Eklenmiş bir dosyayı derlenmiş olarak yazar
rename_function
Giriş
PHP'nin Davranışını Etkileyenler


Giriş

Uyarı

Bu eklenti DENEYSELDİR. Bu eklentinin davranışı, işlev isimleri ve tüm belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu eklentiyi kullanmayın.

Bcompiler eklentisi birkaç amacı, görevi gerçekleştirmek için yazılmıştır:

  • Özel PHP uygulamalarında bütün betiğin kodlanmasını sağlamak
  • Özel PHP uygulamalarında bazı sınıf veya işlevlerin kodlanmasını sağlamak
  • İstemci masaüstlerinde çalışan php-gtk uygulamalarında, uygulamanın php.exe'ye ihtiyaç duymadan çalışmasını sağlamak.
  • PHP'den C'ye dönüştürücü için ölçeklenebilir çalışma yapmak
Bunların ilki bcompiler_write_header(), bcompiler_write_file() ve bcompiler_write_footer() işlevleri kullanılarak gerçekleştirilir. Derlenen dosyalar sıkıştırılmamış veya salt metin olarak yazılabilir. Derlenmiş dosyayı kullanabilmek için basit bir şekilde include veya require deyimleri kullanılabilir.

İkinci tip görevler bcompiler_write_header(),
bcompiler_write_class(),
bcompiler_write_footer(),
bcompiler_read(), ve
bcompiler_load() işlevleri kullanılarak
gerçekleştirilebilir. Derlenmiş dosyalar sıkıştırılmamış veya salt metin
olarak yazılabilir. bcompiler_load() işlevi
sıkıştırılmış bir derlenmiş dosyayı okuyabilir, bu sıkıştırılmış dosyalar
özgün dosyanın 1/3 boyutunda olabilirler.

EXE türünde dosyalar oluşturmak için, bcompiler değiştirilmiş bir sapi dosyası veya paylaşımlı kütüphane şeklinde derlenmiş bir PHP sürümü ile birlikte kullanılmalıdır. Bu durumda, bcompiler sıkıştırılmış kodları exe dosyasının sonundan okur.

Bcompiler sıkıştırılmamış kodlarla kullanıldığı zaman yaklaşık %30 daha verimli çalışabilir. Sıkıştırılmamış kodların özgün kaynak kodundan 5 kez daha büyük olduğunu unutmayın. Kodları sıkıştırılmış şekilde kullanmak size alan kazandırır fakat sıkıştırılmış kodun açılması kaynağın çözümlenmesinden çok daha fazla zaman ister. Bcompiler herhangi bir kod en iyileştirmesi yapmaz, en iyileştirme gelecekte eklenebilir...

Kod koruması bakış açısından, kodun derlenmiş halinden yorumlu kaynak koda ulaşmanın imkansız olduğunu söyleyebiliriz. Bcompiler ile derlenmiş koddan tekrar oluşturulmuş ve değiştirilmiş bir sınıf etkin şekilde kullanılamaz. Bununla birlikte derlenmiş dosyadan veri elde etmek mümkündür, yani şifreleri veya özel olan herhangi bir şeyi derlenecek dosyalara koymayın.

bcompiler
Yapılandırma/Kurulum
bcompiler


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
bcompiler


Kurulum

Bu » PECL eklentisi PHP ile gelmez.

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/bcompiler.

Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu eklentinin php.ini'de tanımlı yapılandırma yönergesi yoktur.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
bcompiler İşlevleri
bcompiler


bcompiler İşlevleri

İletişim Bilgileri

Yorum, hata düzeltmeleri, öneri veya geliştirmeye yardım etmek için bana » alan_k@php.net adresinden eposta gönderebilirsiniz. Şimdiden teşekkürler.

İçindekiler

  • bcompiler_load_exe — bcompiler exe dosyasından sınıfları okur ve oluşturur
  • bcompiler_load — bz biçiminde sıkıştırılmış dosyadan, sınıfları okur ve oluşturur
  • bcompiler_parse_class — Derlenmiş koddan sınıfı okur ve kullanıcı tanımlı işleve geriçağırım yapar
  • bcompiler_read — Bir dosya tanıtıcısından sınıfları okur ve oluşturur
  • bcompiler_write_class — Tanımlanmış bir sınıfı dosyaya yazar
  • bcompiler_write_constant — Tanımlanmış sabiti dosyaya yazar
  • bcompiler_write_exe_footer — Derlenmiş kodun başlangıç konumunu ve imzasını, exe türü bir dosyanın sonuna yazar
  • bcompiler_write_file — Bir php kaynak dosyasını derleyerek yazar
  • bcompiler_write_footer — Derlenmiş verinin sona erdiğini göstermek için \x00 karakterini yazar
  • bcompiler_write_function — Tanımlı bir işlevi derlenmiş olarak yazar
  • bcompiler_write_functions_from_file — Bir dosya içinde tanımlanmış bütün işlevleri derleyerek yazar
  • bcompiler_write_header — bcompiler dosya başlığını yazar
  • bcompiler_write_included_filename — Eklenmiş bir dosyayı derlenmiş olarak yazar
Öntanımlı Sabitler
bcompiler_load_exe
bcompiler


bcompiler exe dosyasından sınıfları okur ve oluşturur

bcompiler İşlevleri
bcompiler_load
bcompiler İşlevleri
PHP Manual

bcompiler_load_exe

(PECL bcompiler >= 0.4)

bcompiler_load_exe — bcompiler exe dosyasından sınıfları okur ve oluşturur

Açıklama

bool bcompiler_load_exe ( string $dosyaadi )

bcompiler exe dosyasından veriyi okur ve derlenmiş koddan sınıfları oluşturur.

Değiştirgeler

dosyaadi

Dizge olarak exe dosya yolu.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - bcompiler_load_exe() örneği

<?php

bcompiler_load_exe("/tmp/example.exe");
print_r(get_defined_classes());

?>

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Ayrıca Bakınız

  • bcompiler_load() - bz biçiminde sıkıştırılmış dosyadan, sınıfları okur ve oluşturur

bcompiler İşlevleri
bcompiler_load
bcompiler İşlevleri


bz biçiminde sıkıştırılmış dosyadan, sınıfları okur ve oluşturur

bcompiler_load_exe
bcompiler_parse_class
bcompiler İşlevleri
PHP Manual

bcompiler_load

(PECL bcompiler >= 0.4)

bcompiler_load — bz biçiminde sıkıştırılmış dosyadan, sınıfları okur ve oluşturur

Açıklama

bool bcompiler_load ( string $dosyaadi )

bz biçiminde sıkıştırılmış dosyadan veriyi okur ve derlenmiş koddan sınıfları oluşturur.

Değiştirgeler

dosyaadi

Dizge olarak, bz sıkıştırılmış dosya yolu.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - bcompiler_load() örneği

<?php

bcompiler_load("/tmp/example");

print_r(get_defined_classes());

?>

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Bilginize:

Derlenmiş kodları çözümlemek için lütfen include veya require deyimlerini kullanın, bu işlevler bcompiler_load işlevinden daha uygun ve taşınabilirdir.

Bu işlevin, derlenmiş dosyanın gövdesinde bulunan betiği çalıştırmadığına dikkat edin.

Ayrıca Bakınız

  • bcompiler_load_exe() - bcompiler exe dosyasından sınıfları okur ve oluşturur

bcompiler_load_exe
bcompiler_parse_class
bcompiler İşlevleri


Derlenmiş koddan sınıfı okur ve kullanıcı tanımlı işleve geriçağırım yapar

bcompiler_load
bcompiler_read
bcompiler İşlevleri
PHP Manual

bcompiler_parse_class

(PECL bcompiler >= 0.4)

bcompiler_parse_class — Derlenmiş koddan sınıfı okur ve kullanıcı tanımlı işleve geriçağırım yapar

Açıklama

bool bcompiler_parse_class ( string $sinif , string $gericagirim )

Derlenmiş koddan sınıfı okur ve kullanıcı tanımlı işleve geriçağırım yapar.

Değiştirgeler

sinif

Dizge olarak sınıf adı.

gericagirim

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - bcompiler_parse_class() örneği

<?php

function readByteCodes($data) {
    print_r($data);
}

bcompiler_parse_class("DB","readByteCodes");

?>

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Bilginize:

Bu işlev, bcompiler'dan çıkartılmıştır. 0.5 ve sonraki bcompiler sürümlerinde geçerli değildir.

bcompiler_load
bcompiler_read
bcompiler İşlevleri


Bir dosya tanıtıcısından sınıfları okur ve oluşturur

bcompiler_parse_class
bcompiler_write_class
bcompiler İşlevleri
PHP Manual

bcompiler_read

(PECL bcompiler >= 0.4)

bcompiler_read — Bir dosya tanıtıcısından sınıfları okur ve oluşturur

Açıklama

bool bcompiler_read ( resource $dosyatanitici )

Açık bir dosya tanıtıcısından derlenmiş veri okur ve sınıflar oluşturur.

Değiştirgeler

dosyatanitici

fopen() işlevinden elde edilmiş bir tanıtıcı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - bcompiler_read() örneği

<?php
$fh = fopen("/tmp/example","r");
bcompiler_read($fh);
fclose($fh);
print_r(get_defined_classes());

?>

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Bilginize:

Derlenmiş kodları çözümlemek için lütfen include veya require deyimlerini kullanının, bu işlevler bcompiler_load işlevinden daha uygun ve taşınabilirdir.

Bu işlevin, derlenmiş dosyanın gövdesinde bulunan betiği çalıştırmadığına dikkat edin.

bcompiler_parse_class
bcompiler_write_class
bcompiler İşlevleri


Tanımlanmış bir sınıfı dosyaya yazar

bcompiler_read
bcompiler_write_constant
bcompiler İşlevleri
PHP Manual

bcompiler_write_class

(PECL bcompiler >= 0.4)

bcompiler_write_class — Tanımlanmış bir sınıfı dosyaya yazar

Açıklama

bool bcompiler_write_class ( resource $dosyatanitici , string $sinifadi [, string $genisletme ] )

Tanımlanmış sınıfı derlenmiş koddan okur ve açık bir dosya tanıtıcısına yazar.

Değiştirgeler

dosyatanitici

fopen() işlevinden elde edilmiş bir tanıtıcı.

sinifadi

Dizge olarak sınıf adı.

genisletme

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - bcompiler_write_class() örneği

<?php
$fh = fopen("/tmp/example","w");
bcompiler_write_header($fh);
bcompiler_write_class($fh,"DB");
// DB_common'u DB_mysql'den önce yazmalısınız, DB_mysql DB_common'u
// genişletir.
bcompiler_write_class($fh,"DB_common");
bcompiler_write_class($fh,"DB_mysql");
bcompiler_write_footer($fh);
fclose($fh);

?>

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Bilginize:

Bu işlev bağımlılık denetlemesi yapmaz, yükleme sırasında undefined class hatası almamak için sınıfları doğru sırada yazdığınızdan emin olmalısınız.

Ayrıca Bakınız

  • bcompiler_write_header() - bcompiler dosya başlığını yazar
  • bcompiler_write_footer() - Derlenmiş verinin sona erdiğini göstermek için \x00 karakterini yazar

bcompiler_read
bcompiler_write_constant
bcompiler İşlevleri


Tanımlanmış sabiti dosyaya yazar

bcompiler_write_class
bcompiler_write_exe_footer
bcompiler İşlevleri
PHP Manual

bcompiler_write_constant

(PECL bcompiler >= 0.5)

bcompiler_write_constant — Tanımlanmış sabiti dosyaya yazar

Açıklama

bool bcompiler_write_constant ( resource $dosyatanitici , string $sabitadi )

PHP kodunda tanımlanmış sabiti okur ve açık bir dosya tanıtıcısına yazar.

Değiştirgeler

dosyatanitici

fopen() işlevinden elde edilmiş bir tanıtıcı.

sabitadi

Dizge olarak, tanımlanmış sabitin adı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - bcompiler_write_constant() örneği

<?php
define("MODULE_MAX", 30);

$fh = fopen("/tmp/example","w");
bcompiler_write_header($fh);
bcompiler_write_constant($fh,"MODULE_MAX");
bcompiler_write_footer($fh);
fclose($fh);

?>

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Ayrıca Bakınız

  • bcompiler_write_header() - bcompiler dosya başlığını yazar
  • bcompiler_write_footer() - Derlenmiş verinin sona erdiğini göstermek için \x00 karakterini yazar

bcompiler_write_class
bcompiler_write_exe_footer
bcompiler İşlevleri


Derlenmiş kodun başlangıç konumunu ve imzasını, exe türü bir dosyanın sonuna yazar

bcompiler_write_constant
bcompiler_write_file
bcompiler İşlevleri
PHP Manual

bcompiler_write_exe_footer

(PECL bcompiler >= 0.4)

bcompiler_write_exe_footer — Derlenmiş kodun başlangıç konumunu ve imzasını, exe türü bir dosyanın sonuna yazar

Açıklama

bool bcompiler_write_exe_footer ( resource $dosyatanitici , int $baslangickonum )

Bir EXE (veya kendiliğinden çalıştırılabilir) dosya 3 bölümden oluşur:

  • arayüz (çalıştırılabilir kod, örneğin derlenmiş bir C kodu) PHP yorumlayıcısını, bcompiler genişletmesini, derlenmiş kodu yükler ve belirli bir işlev (main) veya sınıf yöntemi (main::main) için çağrı başlatır.
  • Derlenmiş kod (sadece o an için sıkıştırılmamış)
  • bcompiler EXE dosya sonu

Arayüz elde etmek için bcompiler examples/embed CVS dizinininde bulunan phpe.c php_embed-based kodunu derleyebilirsiniz.

Değiştirgeler

dosyatanitici

fopen() işlevinden elde edilmiş bir tanıtıcı.

baslangickonum

Derlenmiş kodun başladığı dosya konum bilgisi, ftell() işlevi kullanılarak elde edilebilir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - bcompiler_write_exe_footer() örneği

<?php

/* çıktı dosyasını oluştur (example.exe) */
$fh = fopen("example.exe", "w");

/* 1) arayüz yaz (phpe.exe) */
$size = filesize("phpe.exe");
$fr = fopen("phpe.exe", "r");
fwrite($fh, fread($fr, $size), $size);
$startpos = ftell($fh);

/* 2) derlenmiş kod yaz */
bcompiler_write_header($fh);
bcompiler_write_class($fh, "myclass");
bcompiler_write_function($fh, "main");
bcompiler_write_footer($fh);

/* 3) EXE dosya sonu yaz */
bcompiler_write_exe_footer($fh, $startpos);

/* çıktı dosyasını kapat */
fclose($fh);
?>

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Ayrıca Bakınız

  • bcompiler_write_header() - bcompiler dosya başlığını yazar
  • bcompiler_write_class() - Tanımlanmış bir sınıfı dosyaya yazar
  • bcompiler_write_footer() - Derlenmiş verinin sona erdiğini göstermek için \x00 karakterini yazar

bcompiler_write_constant
bcompiler_write_file
bcompiler İşlevleri


Bir php kaynak dosyasını derleyerek yazar

bcompiler_write_exe_footer
bcompiler_write_footer
bcompiler İşlevleri
PHP Manual

bcompiler_write_file

(PECL bcompiler >= 0.6)

bcompiler_write_file — Bir php kaynak dosyasını derleyerek yazar

Açıklama

bool bcompiler_write_file ( resource $dosyatanitici , string $dosyaadi )

Bu işlev, verilmiş php kaynak dosyasını derler ve açık bir dosya tanıtıcısına yazar.

Değiştirgeler

dosyatanitici

fopen() işlevinden dönen bir tanıtıcı.

dosyaadi

Dizge olarak kaynak dosya yolu.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - bcompiler_write_file() örneği

<?php
$fh = fopen("example.phb", "w");
bcompiler_write_header($fh);
bcompiler_write_file($fh, "example.php");
bcompiler_write_footer($fh);
fclose($fh);
/* aşağıdaki iki deyim denk olmalıdır:
include "example.php";
   ve
include "example.phb";
*/
?>

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Ayrıca Bakınız

  • bcompiler_write_header() - bcompiler dosya başlığını yazar
  • bcompiler_write_footer() - Derlenmiş verinin sona erdiğini göstermek için \x00 karakterini yazar

bcompiler_write_exe_footer
bcompiler_write_footer
bcompiler İşlevleri


Derlenmiş verinin sona erdiğini göstermek için \x00 karakterini yazar

bcompiler_write_file
bcompiler_write_function
bcompiler İşlevleri
PHP Manual

bcompiler_write_footer

(PECL bcompiler >= 0.4)

bcompiler_write_footer — Derlenmiş verinin sona erdiğini göstermek için \x00 karakterini yazar

Açıklama

bool bcompiler_write_footer ( resource $dosyatanitici )

Derlenmiş verinin sona erdiğini göstermek için \x00 karakterini yazar.

Değiştirgeler

dosyatanitici

fopen() işlevinden dönen dosya tanıtıcısı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - bcompiler_write_footer() örneği

<?php
$fh = fopen("/tmp/example","w");
bcompiler_write_header($fh);
bcompiler_write_class($fh,"DB");
bcompiler_write_class($fh,"DB_common");
bcompiler_write_footer($fh);
fclose($fh);

?>

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Ayrıca Bakınız

  • bcompiler_write_header() - bcompiler dosya başlığını yazar

bcompiler_write_file
bcompiler_write_function
bcompiler İşlevleri


Tanımlı bir işlevi derlenmiş olarak yazar

bcompiler_write_footer
bcompiler_write_functions_from_file
bcompiler İşlevleri
PHP Manual

bcompiler_write_function

(PECL bcompiler >= 0.5)

bcompiler_write_function — Tanımlı bir işlevi derlenmiş olarak yazar

Açıklama

bool bcompiler_write_function ( resource $dosyatanitici , string $islevAdi )

İşlevi PHP kodundan okur ve açık dosya tanıtıcısına derlenmiş olarak yazar. Sıralama önemli değildir (aşağıdaki örnekte işlev b, işlev a'yı kullanıyor olsa bile düzgün çalışacaktır).

Değiştirgeler

dosyatanitici

fopen() işlevinden dönen tanıtıcı.

islevAdi

Dizge olarak işlev adı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - bcompiler_write_function() örneği

<?php
$fh = fopen("/tmp/example","w");
bcompiler_write_header($fh);
bcompiler_write_function($fh,"my_function_a");
bcompiler_write_function($fh,"my_function_b");
bcompiler_write_footer($fh);
fclose($fh);

?>

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Ayrıca Bakınız

  • bcompiler_write_header() - bcompiler dosya başlığını yazar
  • bcompiler_write_footer() - Derlenmiş verinin sona erdiğini göstermek için \x00 karakterini yazar

bcompiler_write_footer
bcompiler_write_functions_from_file
bcompiler İşlevleri


Bir dosya içinde tanımlanmış bütün işlevleri derleyerek yazar

bcompiler_write_function
bcompiler_write_header
bcompiler İşlevleri
PHP Manual

bcompiler_write_functions_from_file

(PECL bcompiler >= 0.5)

bcompiler_write_functions_from_file — Bir dosya içinde tanımlanmış bütün işlevleri derleyerek yazar

Açıklama

bool bcompiler_write_functions_from_file ( resource $dosyatanitici , string $dosyaAdi )

Dosya içindeki bütün tanımlı işlevleri arar ve derlenmiş karşılıklarını açık dosya tanıtıcısına yazar.

Değiştirgeler

dosyatanitici

fopen() işlevinden dönen tanıtıcı.

dosyaAdi

Derlenecek dosya, bu dosyayı daima include veya require deyimleri ile eklemelisiniz.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - bcompiler_write_functions_from_file() örneği

<?php
require('module.php');

$fh = fopen("/tmp/example","w");
bcompiler_write_header($fh);
bcompiler_write_functions_from_file($fh,'module.php');
bcompiler_write_footer($fh);
fclose($fh);

?>

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Ayrıca Bakınız

  • bcompiler_write_header() - bcompiler dosya başlığını yazar
  • bcompiler_write_footer() - Derlenmiş verinin sona erdiğini göstermek için \x00 karakterini yazar

bcompiler_write_function
bcompiler_write_header
bcompiler İşlevleri


bcompiler dosya başlığını yazar

bcompiler_write_functions_from_file
bcompiler_write_included_filename
bcompiler İşlevleri
PHP Manual

bcompiler_write_header

(PECL bcompiler >= 0.3)

bcompiler_write_header — bcompiler dosya başlığını yazar

Açıklama

bool bcompiler_write_header ( resource $dosyatanitici [, string $surum ] )

bcompiler dosyasındaki başlık kısmını yazar.

Değiştirgeler

dosyatanitici

fopen() işlevinden dönen tanıtıcı.

surum

Derlenmiş kodu bcompiler'ın eski sürümleri ile birlikte kullanabilmek için dosyayı yazarken önceki sürüm biçimi seçeneği kullanılabilir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - bcompiler_write_header() örneği

<?php
$fh = fopen("/tmp/example","w");
bcompiler_write_header($fh);
bcompiler_write_class($fh,"DB");
bcompiler_write_footer($fh);
fclose($fh);

?>

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Ayrıca Bakınız

  • bcompiler_write_footer() - Derlenmiş verinin sona erdiğini göstermek için \x00 karakterini yazar

bcompiler_write_functions_from_file
bcompiler_write_included_filename
bcompiler İşlevleri


Eklenmiş bir dosyayı derlenmiş olarak yazar

bcompiler_write_header
BLENC
bcompiler İşlevleri
PHP Manual

bcompiler_write_included_filename

(PECL bcompiler >= 0.5)

bcompiler_write_included_filename — Eklenmiş bir dosyayı derlenmiş olarak yazar

Açıklama

bool bcompiler_write_included_filename ( resource $dosyatanitici , string $dosyaadi )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

bcompiler_write_header
BLENC
bcompiler İşlevleri


Blenc - BLowfish ENCoder for PHP source scripts

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Blenc İşlevleri
    • blenc_encrypt — Encrypt a PHP script with BLENC.
bcompiler_write_included_filename
Giriş
PHP'nin Davranışını Etkileyenler


Giriş

Uyarı

Bu eklenti DENEYSELDİR. Bu eklentinin davranışı, işlev isimleri ve tüm belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu eklentiyi kullanmayın.

BLENC is a PHP source script protector that:

  • Encodes your source code with the blowfish algorithm.
  • Allows transparent decryption and execution of PHP scripts previously encoded with BLENC.

BLENC is an extension which hooks into the Zend Engine, allowing for transparent encryption and execution of PHP scripts using the blowfish algorithm. It is not designed for complete security (it is still possible to disassemble the script into op codes using a package such as XDebug), however it does keep people out of your code and make reverse engineering difficult.

In order to protect your PHP script you must encrypt each script with blenc_encrypt() function. After you can include the encoded script like the example below:

<?php

/* PHP script encoded with BLENC */
$my_source_encoded = 'my_source_encoded.phpe';

include($my_source_encoded);
?>

BLENC supports also expiration time for the module. So, if you want deploy your source code with a expiration time, you have to compile the extension modifying the header file related to encryption and expiration time. Please see configuration section for further informations.

BLENC
Yapılandırma/Kurulum
BLENC


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
BLENC


Gereksinimler

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu » PECL eklentisi PHP ile gelmez.

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/blenc

It's strongly recommended to install BLENC from sources without 'pecl' command. In this way you can:

  • Specify your personal encryption key used to create redistributable keys. Your sourcecode will be more difficult to decrypt also for users that can read your key_file on webserver.
  • Specify a expiration date for the BLENC module. With expiration date you can decide that BLENC module on target system will work until a date. After that BLENC will not decrypt any files.
All these configuration options are stored into header file: blenc_protect.h

Please read the content of blenc_protect.h in sources of BLENC to know how set these hardcoded options.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Blenc Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
blenc.key_file | /usr/local/etc/blenckeys | PHP_INI_ALL |

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

blenc.key_file string

It's the location where BLENC can find the file containing a list of available decryption keys. This file must be readable by webserver.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Özkaynak Türleri

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

BLENC_EXT_VERSION (string)

Özkaynak Türleri
Blenc İşlevleri
BLENC


Blenc İşlevleri

İçindekiler

  • blenc_encrypt — Encrypt a PHP script with BLENC.
Öntanımlı Sabitler
blenc_encrypt
BLENC


Encrypt a PHP script with BLENC.

Blenc İşlevleri
Hata İşleme
Blenc İşlevleri
PHP Manual

blenc_encrypt

(PECL blenc >= 5)

blenc_encrypt — Encrypt a PHP script with BLENC.

Açıklama

string blenc_encrypt ( string $plaintext , string $encodedfile [, string $encryption_key ] )

Encrypt the plaintext content and write it into encodedfile

Değiştirgeler

plaintext

A source code to encrypt. Does not need to contain opening/closing PHP tags

encodedfile

The filename where BLENC will save the encoded source.

encryption_key

The key that BLENC will use to encrypt plaintext content. If not given BLENC will create a valid key.

Dönen Değerler

BLENC will return the redistributable key that must be saved into key_file: the path of key_file is specified at runtime with the option blenc.key_file

Örnekler

Örnek 1 blenc_encrypt() example

<?php

/* read the PHP source code */
$source_code = file_get_contents("my_source_to_protect.php");

/* create the encrypted version */
$redistributable_key = blenc_encrypt($source_code, "my_source_encoded.php");

/* read which is the key_file */
$key_file = ini_get('blenc.key_file');

/* save the redistributable key */
file_put_contents($key_file, $redistributable_key, FILE_APPEND);
?>

Blenc İşlevleri
Hata İşleme
Blenc İşlevleri


Hata İşleme ve Günlükleme

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
  • Hata İşleme İşlevleri
    • debug_backtrace — Hata izleme raporunu bir dizi olarak üretir
    • debug_print_backtrace — Bir hata izleme raporu basar
    • error_clear_last — Clear the most recent error
    • error_get_last — Son oluşan hata hakkında bilgi verir
    • error_log — Bir yerlere bir hata iletisi gönderir
    • error_reporting — Hangi PHP hatalarının raporlanacağını tanımlar
    • restore_error_handler — Bir önceki hata eylemcisini devreye sokar
    • restore_exception_handler — Bir önceki istisna eylemcisini devreye sokar
    • set_error_handler — Kullanıcı tanımlı bir hata eylemcisi bildirir
    • set_exception_handler — Kullanıcı tanımlı bir istisna eylemcisi bildirir
    • trigger_error — Kullanıcı seviyesinde bir hata/uyarı/bilgi iletisi üretir
    • user_error — trigger_error işlevinin takma adıdır
blenc_encrypt
Giriş
PHP'nin Davranışını Etkileyenler


Giriş

Bu işlevler hataların elde edilmesi ve günlük kayıtlarının tutulması ile ilgilidir. Bu işlevlerle kendi hata işleme kurallarınızı tanımlayabileceğiniz gibi hataların günlük dosyalarına nasıl kaydedileceğiyle ilgili değişiklikler de yapabilirsiniz. Böylece hata bildirimini ihtiyaçlarınıza uygun bir biçimde değiştirebilir veya genişletebilirsiniz.

Hata iletilerini günlük kayıt işlevleriyle doğrudan diğer makinelere, bir eposta adresine, sistem günlüklerine ve benzerlerine gönderebilirsiniz. Dolayısıyla, uygulamanızın veya sitenizin en önemli kısımlarını gözlem altında tutabilir ve bunlardan istediklerinizi günlük dosyalarına kaydedebilirsiniz.

Hata bildirim işlevleri, basit uyarılardan özel işlevlerin döndürdükleri hatalara kadar bir yelpazede geribildirim çeşidini ve seviyesini belirleyebilme olanağını verır.

Hata İşleme
Yapılandırma/Kurulum
Hata İşleme


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Hata İşleme


Kurulum

Bu işlevleri kullanmak için hiçbir şey kurmaya gerek yoktur; PHP çekirdeğinin parçasıdırlar.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Hatalar ve Günlük Kaydı ile ilgili Yapılandırma Yönergeleri
İsim | Öntanımlı | Değişiklik Yeri | Sürüm Bilgisi
error_reporting | NULL | PHP_INI_ALL |
display_errors | "1" | PHP_INI_ALL |
display_startup_errors | "0" | PHP_INI_ALL |
log_errors | "0" | PHP_INI_ALL |
log_errors_max_len | "1024" | PHP_INI_ALL | PHP 4.3.0'dan beri kullanılabilmektedir.
ignore_repeated_errors | "0" | PHP_INI_ALL | PHP 4.3.0'dan beri kullanılabilmektedir.
ignore_repeated_source | "0" | PHP_INI_ALL | PHP 4.3.0'dan beri kullanılabilmektedir.
report_memleaks | "1" | PHP_INI_ALL | PHP 4.3.0'dan beri kullanılabilmektedir.
track_errors | "0" | PHP_INI_ALL |
html_errors | "1" | PHP_INI_ALL | PHP <= 4.2.3'te PHP_INI_SYSTEM.
xmlrpc_errors | "0" | PHP_INI_SYSTEM | PHP 4.1.0'dan beri kullanılabilmektedir.
xmlrpc_error_number | "0" | PHP_INI_ALL | PHP 4.1.0'dan beri kullanılabilmektedir.
docref_root | "" | PHP_INI_ALL | PHP 4.3.0'dan beri kullanılabilmektedir.
docref_ext | "" | PHP_INI_ALL | since PHP 4.3.2'den beri kullanılabilmektedir.
error_prepend_string | NULL | PHP_INI_ALL |
error_append_string | NULL | PHP_INI_ALL |
error_log | NULL | PHP_INI_ALL |
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

error_reporting integer

Hata raporlama seviyesini tanımlar. Değiştirge olarak ya bir bit alanını ifade eden bir tamsayı ya da isimli sabitler verilebilir. Hata raporlama seviyeleri ve sabitleri Öntanımlı Sabitler sayfasında ve php.ini içinde açıklanmıştır. Hata raporlama seviyesini çalışma anında belirtmek için error_reporting() işlevini kullanabilirsiniz. Ayrıca, display_errors yönergesine de bakınız.

PHP 4 ve PHP 5'te öntanımlı değer E_ALL & ~E_NOTICE olup bu ayarla E_NOTICE seviyesindeki hatalar gösterilmez. Betiğinizi geliştirirken onları da görmek isteyebilirsiniz.

Bilginize:

E_NOTICE seviyesindeki hataların geliştirme aşamasında gösterilmesinin bazı yararları vardır. Hata ayıklama amacıyla kullanıldığında E_NOTICE iletileri kodunuzdaki olası hatalar hakkında sizi uyarır. Örneğin atanmamış değerlerin kullanımı hakkında bir uyarı alırsınız. Özellikle yazım hatalarını bulmakta yardımcı olarak hata ayıklamakla zaman kaybetmekten sizi kurtarır. E_NOTICE iletileri kötü yazım tarzı için de sizi uyarır. Örneğin, PHP "item" indisini bir sabit olarak ele almayı deneyeceğinden $arr[item] yerine $arr['item'] yazmak daha iyidir. Belirttiğiniz indis bir sabit değilse PHP bunu dizinin bir anahtarı (dizgesel indisi) olarak kabul edecektir.

Bilginize:

PHP 5'te E_STRICT yeni bir hata seviyesi olarak devreye girmiştir. E_ALL ile birlikte açıkça belirtilmedikçe E_STRICT seviyesinden hata raporları etkin olmayacaktır. E_STRICT seviyesinden hataların geliştirme aşamasında gösterilmesinin bazı yararları vardır. Bu iletiler, en son ve en çok önerilen kodlama yöntemini kullanmanız için size yardımcı olacaktır. Örneğin, kullanımı artık önerilmeyen işlevler hakkında uyarılacaksınız.

Bilginize: PHP dışında PHP sabitleri

httpd.conf gibi PHP dışı yerlerde PHP sabitlerini kullanmak isterseniz, bunların tamsayı değerlerini kullanmak zorunda kalmak anlamlarını anlamayı zorlaştırdığı için elverişli olmayacaktır. Zamanla başka hata seviyeleri ekleneceğinden azami değer de (E_ALL değeri) değişecektir. Bu bakımdan E_ALL yerine şimdiki ve gelecekteki tüm bit alanlarını kapsamak üzere 2147483647 gibi büyük bir değer kullanabilirsiniz (E_ALL'dan başka tüm hataları da içerir).

display_errors string

Hataların çıktının bir parçası olarak ekrana basılıp basılmayacağını veya bunların kullanıcıdan gizlenip gizlenmeyeceğini belirler.

"stderr" değeri hataları stdout (standart çıktı) yerine stderr'e (standart hataya) gönderir. Bu değer PHP'nin 5.2.4 sürümünden beri kullanılabilmektedir. Eski sürümlerde bu yönerge sadece boolean türünde değer kabul ederdi.

Bilginize:

Bu özellik sizi geliştirme aşamasında desteklemek amacıyla konmuştur ve kullanıcıya yönelik işlemler için asla kullanılmamalıdır.

Bilginize:

Bu yönergeye çalışma anında (ini_set() ile) değer atanabilse de, eğer betik ölümcül bir hataya sahipse bunun herhangi bir etkisi olmayacaktır. Bunun sebebi çalışma anında istenen eylemin yerine getirilmeyecek olmasıdır.

display_startup_errors boolean

display_errors etkin olsa bile PHP ilk başlatılırken oluşan hatalar gösterilmez. Hata ayıklamıyorsanız display_startup_errors yönergesinin değerini off olarak bırakın.

log_errors boolean

Betiğin hata iletilerinin sunucunun hata günlüğüne veya error_log ile belirtilen dosyaya kaydedilip kaydedilmeyeceğini belirler. Bu seçenek sunucuya özgüdür.

Bilginize:

Sitenizde hataları kullanıcıya göstermek yerine hata günlüklerine kaydetmenizi hararetle tavsiye ederiz.

log_errors_max_len integer

Hata günlüğü iletilerinin azami uzunluğunu bayt cinsinden belirlemek için kullanılır. Kaynak hakkındaki error_log bilgisi buna eklenir. 1024 öntanımlı değer olup, 0 belirtildiği takdirde hata günlüğü iletilerininin uzunlukları sınırlanmaz. Bu uzunluk günlüğe kaydedilen ve gösterilen hata iletilerinden başka $php_errormsg iletilerine de uygulanır.

integer türünde bir değer kullanıldığında değer baytların sayısıdır. Büyük bayt değerleri için kullanılabilecek birimlerin gösterimleri hakkında bilgiyi bu SSS altında bulabilirsiniz.
ignore_repeated_errors boolean

Yinelenen hata iletileri günlüğe kaydedilmez. ignore_repeated_source yönergesinin değeri true olmadıkça yinelenen hataların aynı dosyanın aynı satırında oluşması gerekir.

ignore_repeated_source boolean

Yinelenen iletiler yok sayılırken ileti kaynağının da yoksayılmasını sağlar. Bu yönergenin değeri On olduğu takdirde, farklı dosyalardan veya farklı satırlardan kaynaklanan yinelenmiş iletileri hata günlüklerine kaydedemezsiniz.

report_memleaks boolean

Bu yönergenin değeri Off olduğu takdirde, bellek sızıntıları (stdout'ta veya günlük dosyasında) gösterilmez. Bu sadece, hata ayıklama derlemesinde ve error_reporting yönergesinde E_WARNING listeye dahil edilmişse etkilidir.

track_errors boolean

Bu yönergenin değeri On olduğu takdirde, son hata iletisi daima $php_errormsg değişkenine atanır.

html_errors boolean

Hata iletilerine HTML etiketleri dahil edilmez. Yeni HTML hataları biçeminde, doğrudan kullanıcıyı hatayı veya hataya sebep olan işlemi açıklayan bir sayfaya yönlendiren tıklanabilir hatalar üretilir. Bu gönderimler docref_root ve docref_ext yönergelerinden etkilenir.

xmlrpc_errors boolean

Normal hata raporlaması kapatılıp, hatalar XML-RPC hata iletileri olarak biçemlenir.

xmlrpc_error_number integer

XML-RPC hata dizisinin faultCode elemanının değeri olarak bu değer kullanılır (bkz. xmlrpc_is_fault()).

docref_root string

Yeni hata biçemi, hatayı veya hataya sebep olan işlemi açıklayan bir sayfaya bir gönderim içerir. Bu gönderimin bir kılavuz sayfasına yönlendirmesi durumunda, kılavuzun dilinizdeki çevirisini indirebilir ve bu yerel kopyanın bulunduğu yeri bu yönergede belirtebilirsiniz. Örneğin, kılavuzun yerel kopyasına "/manual/" ile erişilebiliyorsa bunu docref_root=/manual/ şeklinde belirtebilirsiniz. Buna ek olarak, kopyanızın dosya uzantısını docref_ext yönergesinde belirtebilirsiniz (örnek: docref_ext=.html). Harici kaynaklara gönderimler de mümkündür. Örnekler: docref_root=http://manual/en/ veya docref_root="http://landonize.it/?how=url&theme=classic&filter=Landon &url=http%3A%2F%2Fwww.php.net%2F"

Bazı durumlarda docref_root değerinin sonuna bir bölü çizgisi "/" eklemeniz gerekebilir. Fakat yukarıdaki ikinci örnekteki gibi bir durumda buna asla gerek yoktur.

Bilginize:

Bu özellik, bir işlevin açıklamasına bakmayı kolaylaştırması nedeniyle daha ziyade geliştirme aşamasında kullanmanız için tasarlanmıştır. Hataları son kullanıcıya göstermek amacıyla kullanılmamalıdır.

docref_ext string

docref_root yönergesine bakınız.

Bilginize:

docref_ext değeri bir nokta "." ile başlamalıdır.

error_prepend_string string

Bir hata iletisinden önce çıktılanacak dizge.

error_append_string string

Bir hata iletisinden sonra çıktılanacak dizge.

error_log string

Hataların kaydedileceği dosyanın adı. Dosya, HTTP sunucunun kullanıcısı tarafından yazılabilir olmalıdır. Eğer syslog özel değeri kullanılmışsa hatalar bir dosya yerine sistemin hata günlüğüne gönderilir (Unix'te syslog(3), Windows NT'de olay günlüğü). Windows 95'te sistem günlükçüsü desteği yoktur. Ayrıca, syslog() işlevine de bakınız. Yönerge tanımsız bırakılmışsa hatalar SAPI hata günlükçüsüne gönderilir. Örneğin bu, Apache'nin hata günlüğü veya CLI için stderr olabilir.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Aşağıdaki sabitler PHP çekirdeğinin parçası olarak daima kullanılabilir durumdadır.

Bilginize: Bu sabit isimlerini php.ini dosyasında kullanabilirsiniz, fakat httpd.conf gibi PHP dışı yerlerde isimlerini değil değerlerini bit maskesi olarak kullanabilirsiniz.

Hatalar ve Günlük Kaydı
Değer | Sabit | Açıklama | Ek Bilgi
1 | E_ERROR (integer) | Ölümcül çalışma anı hataları. Bellek ayırma sorunu gibi giderilemeyen hatalar bu sınıfa girer. Böyle hatalar betiğin çalışmasının durmasına sebep olur. |
2 | E_WARNING (integer) | Çalışma anı uyarıları (ölümcül olmayan hatalar). Betiğin çalışması durmaz. |
4 | E_PARSE (integer) | Derleme anı çözümleme hataları. Çözümleme hatalarını sadece çözümleyici üretir. |
8 | E_NOTICE (integer) | Çalışma anı bildirimleri. Betikte bir hataya sebep olabilecek fakat betiğin normal çalışmasını esnasında oluşmayabilecek bir şeylerin saptandığını belirtir. |
16 | E_CORE_ERROR (integer) | PHP'nin başlatılması sırasında oluşan ölümcül hatalar. PHP çekirdeği tarafından üretilmesi dışında E_ERROR gibidir. | PHP 4'ten beri
32 | E_CORE_WARNING (integer) | PHP'nin başlatılması sırasında oluşan uyarılar (ölümcül olmayan hatalar). PHP çekirdeği tarafından üretilmesi dışında E_WARNING gibidir. | PHP 4'ten beri
64 | E_COMPILE_ERROR (integer) | Ölümcül derleme anı hataları. Zend betik motoru tarafından üretilmesi dışında E_ERROR gibidir. | PHP 4'ten beri
128 | E_COMPILE_WARNING (integer) | Derleme anı uyarıları (ölümcül olmayan hatalar). Zend betik motoru tarafından üretilmesi dışında E_WARNING gibidir. | PHP 4'ten beri
256 | E_USER_ERROR (integer) | Kullanıcı üretimi hata iletileri. PHP işlevi trigger_error() tarafından PHP kodunda üretilmesi dışında E_ERROR gibidir. | PHP 4'ten beri
512 | E_USER_WARNING (integer) | Kullanıcı üretimi uyarı iletileri. PHP işlevi trigger_error() tarafından PHP kodunda üretilmesi dışında E_WARNING gibidir. | PHP 4'ten beri
1024 | E_USER_NOTICE (integer) | Kullanıcı üretimi bildirim iletileri. PHP işlevi trigger_error() tarafından PHP kodunda üretilmesi dışında E_NOTICE gibidir. | PHP 4'ten beri
2048 | E_STRICT (integer) | Yazdığınızı PHP kodunun ileriye dönük uyumluluğunu ve birlikte çalışabilirliğini en iyilemek amacıyla PHP tarafından yapılan önerileri etkin kılar. | PHP 5'ten beri
4096 | E_RECOVERABLE_ERROR (integer) | Yakalanabilir ölümcül hata. Tehlikeli olma olasılığı bulunan bir hata oluştuğunu fakat yorumlayıcıyı kararsız durumda bırakmadığını belirtir. Hata, kullanıcı tarafından bir eylemci tanımlanarak yakalanmadığı (set_error_handler() işlevine bakınız) takdirde betik E_ERROR hatasıyla sonlanır. | PHP 5.2.0'dan beri
8192 | E_DEPRECATED (integer) | Çalışma anı bildirimleri. Gelecek sürümlerle çalışmayacak kodlar hakkındaki uyarıları etkin kılar. | PHP 5.3.0'dan beri
16384 | E_USER_DEPRECATED (integer) | Kullanıcı üretimi kullanımı önerilmiyor bildirimleri. PHP işlevi trigger_error() tarafından PHP kodunda üretilmesi dışında E_DEPRECATED gibidir. | PHP 5.3.0'dan beri
30719 | E_ALL (integer) | Desteklenen (PHP 6'da E_STRICT dışında kalan) tüm hatalar ve uyarılar. | PHP 6'da 32767, PHP 5.3.x'te 30719, PHP 5.2.x'te 6143, öncekilerde 2047.

Gerek sayısal gerekse simgesel olarak yukarıdaki değerler raporlanacak hataları belirten bir bit maskesi oluşturmakta kullanılabilir. Bu değerlerden bir bit maskesi oluşturmak veya bunları çözümlemek için bitsel işleçleri kullanabilirsiniz. php.ini içinde sadece '|', '~', '!', '^' ve '&' işleç karakterlerinin tanındığına dikkat ediniz.

Özkaynak Türleri
Örnekler
Hata İşleme


Örnekler

Aşağıda, PHP hata işleme yeteneklerinin kullanımına ilişkin bir örneğe yer verilmiştir. Hataları işleme sokan işlevin iletilerinin (XML biçeminde) bir dosyaya yazılması; kodlama mantığıyla çelişen önemli hataların ise geliştiriciye eposta ile gönderilmesi sağlanmıştır.

Örnek 1 Bir betikte hataların yakalanıp işleme sokulması

<?php
// Kendi hata işleme sistemimizi oluşturacağız.
error_reporting(0);

// kullanıcı tanımlı hata eylemcisi
function userErrorHandler($errno, $errmsg, $filename, $linenum, $vars)
{
    // Hata iletisi için zaman damgası
    $dt = date("Y-m-d H:i:s (T)");

    // Hata iletisi türlerini bir ilişkisel dizi olarak tanımlayalım.
    // Aslında sadece E_WARNING, E_NOTICE, E_USER_ERROR,
    // E_USER_WARNING ve E_USER_NOTICE kullanılacak.
    $errortype = array (
                E_ERROR              => 'Hata',
                E_WARNING            => 'Uyarı',
                E_PARSE              => 'Çözümleme Hatası',
                E_NOTICE             => 'Bilginize',
                E_CORE_ERROR         => 'PHP Hatası',
                E_CORE_WARNING       => 'PHP Uyarısı',
                E_COMPILE_ERROR      => 'Derleme Hatası',
                E_COMPILE_WARNING    => 'Derleme Uyarısı',
                E_USER_ERROR         => 'Kullanıcı Hatası',
                E_USER_WARNING       => 'Kullanıcı Uyarısı',
                E_USER_NOTICE        => 'Kullanıcı Bildirimi',
                E_STRICT             => 'Çalışma Anı Bildirimi',
                E_RECOVERABLE_ERROR  => 'Yakalanabilir Ölümcül Hata'
                );
    // Hataların oluşumunu izlemek için hataları bir değişkene kaydedelim
    $user_errors = array(E_USER_ERROR, E_USER_WARNING, E_USER_NOTICE);

    $err = "<errorentry>\n";
    $err .= "\t<datetime>" . $dt . "</datetime>\n";
    $err .= "\t<errornum>" . $errno . "</errornum>\n";
    $err .= "\t<errortype>" . $errortype[$errno] . "</errortype>\n";
    $err .= "\t<errormsg>" . $errmsg . "</errormsg>\n";
    $err .= "\t<scriptname>" . $filename . "</scriptname>\n";
    $err .= "\t<scriptlinenum>" . $linenum . "</scriptlinenum>\n";

    if (in_array($errno, $user_errors)) {
        $err .= "\t<vartrace>" . wddx_serialize_value($vars, "Variables") . "</vartrace>\n";
    }
    $err .= "</errorentry>\n\n";

    // Denemek için:
    // echo $err;

    // Hatayı günlüğe kaydedelim ve önemliyse ayrıca bana postalayalım
    error_log($err, 3, "/usr/local/php4/error.log");
    if ($errno == E_USER_ERROR) {
        mail("phpdev@example.com", "Critical User Error", $err);
    }
}

function distance($vect1, $vect2)
{
    if (!is_array($vect1) || !is_array($vect2)) {
        trigger_error("Değiştirgeler yanlış, dizi belirtilmesi bekleniyor",
                       E_USER_ERROR);
        return NULL;
    }

    if (count($vect1) != count($vect2)) {
        trigger_error("Vektörlerin aynı boyutta olması gerekir", E_USER_ERROR);
        return NULL;
    }

    for ($i=0; $i<count($vect1); $i++) {
        $c1 = $vect1[$i]; $c2 = $vect2[$i];
        $d = 0.0;
        if (!is_numeric($c1)) {
            trigger_error(
                "1. vektörün $i konumu bir sayı değil, 0 kullanılıyor",
                E_USER_WARNING);
            $c1 = 0.0;
        }
        if (!is_numeric($c2)) {
            trigger_error(
                "2. vektörün $i konumu bir sayı değil, 0 kullanılıyor",
                E_USER_WARNING);
            $c2 = 0.0;
        }
        $d += $c2*$c2 - $c1*$c1;
    }
    return sqrt($d);
}

$old_error_handler = set_error_handler("userErrorHandler");

// Tanımsız sabit, bir uyarı üretir
$t = TANIMSIZIM;

// bazı "vektörler" tanımlayalım
$a = array(2, 3, "foo");
$b = array(5.5, 4.3, -1.6);
$c = array(1, -3);

// bir kullanıcı hatası üretelim
$t1 = distance($c, $b) . "\n";

// başka bir bir kullanıcı hatası üretelim
$t2 = distance($b, "ben bir dizi değilim") . "\n";

// bir uyarı üretelim
$t3 = distance($a, $b) . "\n";

?>

Öntanımlı Sabitler
Hata İşleme İşlevleri
Hata İşleme


Hata İşleme İşlevleri

Ayrıca Bakınız

Ayrıca bakınız: syslog().

İçindekiler

  • debug_backtrace — Hata izleme raporunu bir dizi olarak üretir
  • debug_print_backtrace — Bir hata izleme raporu basar
  • error_clear_last — Clear the most recent error
  • error_get_last — Son oluşan hata hakkında bilgi verir
  • error_log — Bir yerlere bir hata iletisi gönderir
  • error_reporting — Hangi PHP hatalarının raporlanacağını tanımlar
  • restore_error_handler — Bir önceki hata eylemcisini devreye sokar
  • restore_exception_handler — Bir önceki istisna eylemcisini devreye sokar
  • set_error_handler — Kullanıcı tanımlı bir hata eylemcisi bildirir
  • set_exception_handler — Kullanıcı tanımlı bir istisna eylemcisi bildirir
  • trigger_error — Kullanıcı seviyesinde bir hata/uyarı/bilgi iletisi üretir
  • user_error — trigger_error işlevinin takma adıdır
Örnekler
debug_backtrace
Hata İşleme


Hata izleme raporunu bir dizi olarak üretir

Hata İşleme İşlevleri
debug_print_backtrace
Hata İşleme İşlevleri
PHP Manual

debug_backtrace

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

debug_backtrace — Hata izleme raporunu bir dizi olarak üretir

Açıklama

array debug_backtrace ([ bool $nesne_sağla = true ] )

Hata izleme raporunu (backtrace) bir dizi olarak üretir.

Değiştirgeler

nesne_sağla

Dönen dizide "object" anahtarının bulunup bulunmayacağı belirtilir.

Dönen Değerler

Bir ilişkisel dizi döner. Dönmesi olası değerler:

debug_backtrace() işlevinden dönmesi olası elemanlar
İsim | Tür | Açıklama
function | string | O anki işlev ismi. Ayrıca bakınız: __FUNCTION__.
line | integer | O anki satır numarası. Ayrıca bakınız: __LINE__.
file | string | O anki dosya ismi. Ayrıca bakınız: __FILE__.
class | string | O anki sınıf ismi. Ayrıca bakınız: __CLASS__
object | object | O anki nesne.
type | string | O anki çağrı türü. Bir yöntem çağrısı ise "->", bir duruk yöntem çağrısı ise "::" içerir. Bir işlev çağrısı ise hiçbir şey içermez.
args | array | Bir işlevde, işlevin değiştirgelerini; bir dosyada, dahil edilen dosyalar varsa dahil edilen dosya isimlerini içerir.

Sürüm Bilgisi

Sürüm: | Açıklama
5.2.5 | Seçimlik nesne_sağla değiştirgesi eklendi.
5.1.1 | Dönmesi olası elemanlara object eklendi.

Örnekler

Örnek 1 - debug_backtrace() örneği

<?php
// /tmp/a.php dosyası

function a_test($str)
{
    echo "\nHi: $str";
    var_dump(debug_backtrace());
}

a_test('friend');
?>

<?php
// /tmp/b.php dosyası
include_once '/tmp/a.php';
?>

Results similar to the following when executing /tmp/b.php:

Hi: friend
array(2) {
[0]=>
array(4) {
    ["file"] => string(10) "/tmp/a.php"
    ["line"] => int(10)
    ["function"] => string(6) "a_test"
    ["args"]=>
    array(1) {
      [0] => &string(6) "friend"
    }
}
[1]=>
array(4) {
    ["file"] => string(10) "/tmp/b.php"
    ["line"] => int(2)
    ["args"] =>
    array(1) {
      [0] => string(10) "/tmp/a.php"
    }
    ["function"] => string(12) "include_once"
  }
}

Ayrıca Bakınız

  • trigger_error() - Kullanıcı seviyesinde bir hata/uyarı/bilgi iletisi üretir
  • debug_print_backtrace() - Bir hata izleme raporu basar

Hata İşleme İşlevleri
debug_print_backtrace
Hata İşleme İşlevleri


Bir hata izleme raporu basar

debug_backtrace
error_clear_last
Hata İşleme İşlevleri
PHP Manual

debug_print_backtrace

(PHP 5, PHP 7)

debug_print_backtrace — Bir hata izleme raporu basar

Açıklama

void debug_print_backtrace ( void )

debug_print_backtrace() bir PHP hata izleme raporu (backtrace) basar. İşlev çağrılarını, include/require ile dahil edilen dosyaları ve eval() kodlarını basar.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 - debug_print_backtrace() örneği

<?php
// include.php dosyası

function a() {
    b();
}

function b() {
    c();
}

function c(){
    debug_print_backtrace();
}

a();

?>
<?php
// test.php dosyası
// Bu dosya çalıştırılacak.

include 'include.php';
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

#0  eval() called at [/tmp/include.php:5]
#1  a() called at [/tmp/include.php:17]
#2  include(/tmp/include.php) called at [/tmp/test.php:3]

#0  c() called at [/tmp/include.php:10]
#1  b() called at [/tmp/include.php:6]
#2  a() called at [/tmp/include.php:17]
#3  include(/tmp/include.php) called at [/tmp/test.php:3]

Ayrıca Bakınız

  • debug_backtrace() - Hata izleme raporunu bir dizi olarak üretir

debug_backtrace
error_clear_last
Hata İşleme İşlevleri


Clear the most recent error

debug_print_backtrace
error_get_last
Hata İşleme İşlevleri
PHP Manual

error_clear_last

(PHP 7)

error_clear_last — Clear the most recent error

Açıklama

void error_clear_last ( void )

Dönen Değerler

Clears the most recent errors, making it unable to be retrieved with error_get_last().

Örnekler

Örnek 1 An error_clear_last() example

<?php
var_dump(error_get_last());
error_clear_last();
var_dump(error_get_last());

@$a = $b;

var_dump(error_get_last());
error_clear_last();
var_dump(error_get_last());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

NULL
NULL
array(4) {
  ["type"]=>
  int(8)
  ["message"]=>
  string(21) "Undefined variable: b"
  ["file"]=>
  string(9) "%s"
  ["line"]=>
  int(6)
}
NULL

Ayrıca Bakınız

  • Error constants

debug_print_backtrace
error_get_last
Hata İşleme İşlevleri


Son oluşan hata hakkında bilgi verir

error_clear_last
error_log
Hata İşleme İşlevleri
PHP Manual

error_get_last

(PHP 5 >= 5.2.0, PHP 7)

error_get_last — Son oluşan hata hakkında bilgi verir

Açıklama

array error_get_last ( void )

Son oluşan hata hakkında bilgi verir.

Dönen Değerler

Son oluşan hata hakkındaki bilgileri "type", "message", "file" ve "line" anahtarlı bir ilişkisel dizi olarak döndürür. Henüz bir hata oluşmamışsa NULL döner.

Örnekler

Örnek 1 - error_get_last() örneği

<?php
echo $a;
print_r(error_get_last());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [type] => 8
    [message] => Undefined variable: a
    [file] => C:\WWW\index.php
    [line] => 2
)

Ayrıca Bakınız

  • Hata sabitleri
  • $php_errormsg değişkeni
  • display_errors yönergesi
  • html_errors yönergesi
  • xmlrpc_errors yönergesi

error_clear_last
error_log
Hata İşleme İşlevleri


Bir yerlere bir hata iletisi gönderir

error_get_last
error_reporting
Hata İşleme İşlevleri
PHP Manual

error_log

(PHP 4, PHP 5, PHP 7)

error_log — Bir yerlere bir hata iletisi gönderir

Açıklama

bool error_log ( string $ileti [, int $günlük_türü = 0 [, string $hedef [, string $ek_başlıklar ]]] )

Bir hata iletisini, HTTP sunucusunun hata günlüğüne, bir TCP portuna veya bir dosyaya gönderir.

Değiştirgeler

ileti

Günlüğe kaydedilecek hata iletisi.

günlük_türü

Hata iletilerinin nereye gönderileceğini belirler. Olası günlük türleri şunlardır:

error_log() günlük türleri
0 | error_log yönergesinin değerine bağlı olarak, ileti ya işletim sisteminin sistem günlük kayıtları mekanizması kullanılarak PHP'nin sistem günlüğüne ya da bir dosyaya gönderilir.
1 | ileti, hedef değiştirgesinde belirtilen eposta adresine gönderilir. Dördüncü, ek_başlıklar değiştirgesinin kullanıldığı tek günlük türü budur.
2 | Artık bir seçenek değildir.
3 | ileti, hedef dosyasına eklenir. ileti dizgesinin sonuna satırsonu karakteri özdevinimli olarak eklenir.
4 | ileti doğrudan SAPI günlükleme mekanizmasına gönderilir.

hedef

Bu değiştirgenin değeri yukarıda açıklanan günlük_türü değiştirgesine bağlıdır.

ek_başlıklar

günlük_türü değiştirgesinde 1 belirtildiğinde kullanılır. Bu günlük türü mail() işlevinin kullandığı iç işlevi kullanır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.2.7 | günlük_türü değiştirgesi kullanılabilir oldu.

Örnekler

Örnek 1 - error_log() örnekleri

<?php
// Veritabanına bağlanamazsak sunucunun hata günlüğüne bir bildirim gönderir.
if (!Ora_Logon($username, $password)) {
    error_log("Oracle database not available!", 0);
}

// FOO'nun dışına çıkmışsak yöneticiye bir eposta ile durumu bildirelim
if (!($foo = allocate_new_foo())) {
    error_log("Büyük bir sorun var, FOO'nun dışına çıktık!", 1,
               "operator@example.com");
}

// error_log() işlevini çağırmanın başka bir yolu:
error_log("Herşeyi yüzüne gözüne bulaştırdın!", 3,
          "/var/tmp/herkes_hata_yapar.log");
?>

error_get_last
error_reporting
Hata İşleme İşlevleri


Hangi PHP hatalarının raporlanacağını tanımlar

error_log
restore_error_handler
Hata İşleme İşlevleri
PHP Manual

error_reporting

(PHP 4, PHP 5, PHP 7)

error_reporting — Hangi PHP hatalarının raporlanacağını tanımlar

Açıklama

int error_reporting ([ int $seviye ] )

error_reporting() işlevi error_reporting yönergesinin değerini çalışma anında tanımlar. PHP bir çok hata seviyesine sahiptir. Bu işlevi kullanarak betiğinizin çalışması esnasında hangi seviyelerin raporlanacağını belirleyebilirsiniz.

Değiştirgeler

seviye

Yeni hata raporlama seviyesi. Bir bit maskesi veya isimli sabitler belirtilebilir. Gelecek sürümlerle uyumluluk bakımından bir bit maskesi değil, isimli sabitlerin kullanılması hararetle tavsiye edilir. Yeni hata seviyeleri eklendikçe tamsayı aralığı genişler. Dolayısıyla tamsayı olarak belirtilmiş hata seviyeleri her zaman beklendiği gibi davranmayabilir.

Kullanılabilecek hata seviyesi sabitleri ve anlamları Öntanımlı Sabitler sayfasında açıklanmıştır.

Dönen Değerler

Eski error_reporting değeri döner.

Sürüm Bilgisi

Sürüm: | Açıklama
6.0.0 | E_STRICT sabiti E_ALL sabitine dahil edildi.
5.3.0 | E_DEPRECATED ve E_USER_DEPRECATED devreye girdi.
5.2.0 | E_RECOVERABLE_ERROR devreye girdi.
5.0.0 | E_STRICT devreye girdi (E_ALL sabitine dahil değildir).

Örnekler

Örnek 1 - error_reporting() örnekleri

<?php

// Hata raporlamayı tamamen kapatalım
error_reporting(0);

// Basit hataları raporlayalım
error_reporting(E_ERROR | E_WARNING | E_PARSE);

// E_NOTICE de raporlansa iyi olur (ilklendirilmemiş değişkenleri
// veya yanlış yazılmış değişken isimlerini yakalamak için, vb)
error_reporting(E_ERROR | E_WARNING | E_PARSE | E_NOTICE);

// E_NOTICE hariç bütün hatalar raporlansın
// Bu php.ini içindeki öntanımlı değerdir
error_reporting(E_ALL ^ E_NOTICE);

// Tüm PHP hatalarını raporlayalım (changelog dosyasına bakınız)
error_reporting(E_ALL);

// Tüm PHP hatalarını raporlayalım
error_reporting(-1);

// error_reporting(E_ALL) ile aynı;
ini_set('error_reporting', E_ALL);

?>

Notlar

Uyarı

E_STRICT hatalarının çoğu derleme anında değerlendirilir, bu bakımdan error_reporting yönergesi E_STRICT hatalarını içerse bile böyle hatalar raporlanmaz.

İpucu

-1 değeri belirtildiği takdirde olası tüm hatalar hatta PHP'nin gelecek sürümlerinde eklenen seviyeler bile raporlanır. Ayrıca PHP 6'daki E_ALL sabiti de bu şekilde davranır.

Ayrıca Bakınız

  • The display_errors yönergesi
  • The html_errors yönergesi
  • The xmlrpc_errors yönergesi
  • ini_set() - Bir yapılandırma yönergesine değer atar

error_log
restore_error_handler
Hata İşleme İşlevleri


Bir önceki hata eylemcisini devreye sokar

error_reporting
restore_exception_handler
Hata İşleme İşlevleri
PHP Manual

restore_error_handler

(PHP 4 >= 4.0.1, PHP 5, PHP 7)

restore_error_handler — Bir önceki hata eylemcisini devreye sokar

Açıklama

bool restore_error_handler ( void )

set_error_handler() ile hata eylemcisini değiştirdikten sonra önceki hata eylemcisini (yerleşik veya kullanıcı tanımlı bir işlev) devreye sokmak için kullanılır.

Dönen Değerler

Bu işlev daima TRUE döndürür.

Örnekler

Örnek 1 - restore_error_handler() örneği

unserialize() bir hataya sebep olsun, böylece özgün hata eylemcisini devreye sokalım.

<?php
function unserialize_handler($errno, $errstr)
{
    echo "Dizgeleştirilmiş değer geçersiz.\n";
}

$serialized = 'foo';
set_error_handler('unserialize_handler');
$original = unserialize($serialized);
restore_error_handler();
?>

Yukarıdaki örneğin çıktısı:

Dizgeleştirilmiş değer geçersiz.

Notlar

Bilginize:

restore_error_handler() işlevi hata_eylemci işlevinden çağrıldığında yok sayılır.

Ayrıca Bakınız

  • error_reporting() - Hangi PHP hatalarının raporlanacağını tanımlar
  • set_error_handler() - Kullanıcı tanımlı bir hata eylemcisi bildirir
  • restore_exception_handler() - Bir önceki istisna eylemcisini devreye sokar
  • trigger_error() - Kullanıcı seviyesinde bir hata/uyarı/bilgi iletisi üretir

error_reporting
restore_exception_handler
Hata İşleme İşlevleri


Bir önceki istisna eylemcisini devreye sokar

restore_error_handler
set_error_handler
Hata İşleme İşlevleri
PHP Manual

restore_exception_handler

(PHP 5, PHP 7)

restore_exception_handler — Bir önceki istisna eylemcisini devreye sokar

Açıklama

bool restore_exception_handler ( void )

set_exception_handler() ile istisna eylemcisini değiştirdikten sonra önceki istisna eylemcisini (yerleşik veya kullanıcı tanımlı bir işlev) devreye sokmak için kullanılır.

Dönen Değerler

Bu işlev daima TRUE döndürür.

Örnekler

Örnek 1 - restore_exception_handler() örneği

<?php
  function istisna_eylemci_1(Exception $e)
  {
    echo '[' . __FUNCTION__ . '] ' . $e->getMessage();
  }

  function istisna_eylemci_2(Exception $e)
  {
    echo '[' . __FUNCTION__ . '] ' . $e->getMessage();
  }

  set_exception_handler('istisna_eylemci_1');
  set_exception_handler('istisna_eylemci_2');

  restore_exception_handler();

  throw new Exception('İlk istisna eylemcisi tetiklenir...');
?>

Yukarıdaki örneğin çıktısı:

[istisna_eylemci_1] İlk istisna eylemcisi tetiklenir...

Ayrıca Bakınız

  • set_exception_handler() - Kullanıcı tanımlı bir istisna eylemcisi bildirir
  • set_error_handler() - Kullanıcı tanımlı bir hata eylemcisi bildirir
  • restore_error_handler() - Bir önceki hata eylemcisini devreye sokar
  • error_reporting() - Hangi PHP hatalarının raporlanacağını tanımlar

restore_error_handler
set_error_handler
Hata İşleme İşlevleri


Kullanıcı tanımlı bir hata eylemcisi bildirir

restore_exception_handler
set_exception_handler
Hata İşleme İşlevleri
PHP Manual

set_error_handler

(PHP 4 >= 4.0.1, PHP 5, PHP 7)

set_error_handler — Kullanıcı tanımlı bir hata eylemcisi bildirir

Açıklama

mixed set_error_handler ( callback $hata_eylemci [, int $hata_türü = E_ALL | E_STRICT ] )

Betikteki hatalarda devreye girmek üzere kullanıcı tanımlı bir işlev (hata_eylemci) bildirir.

Bu işlev çalışma anında oluşan hatalardan kurtulmak için yapılacak işlemleri tanımladığınız bir işlevi PHP'ye bildirmek için kullanılır. Örneğin, verilerinizi veya dosyalarınızı temizlemek isterken işlemlerin durmasına yol açacak bir hata oluştuğunda veya belli durumlar için (trigger_error() ile) bir hatayı tetiklemek gerektiğinde PHP tarafından çağrılacak bir işlev tanımlayıp, bu işlevin ismini set_error_handler() ile PHP'ye bildirebilirsiniz.

Bu işlevin çağrılmasıyla PHP'nin standart hata eylemcisi tamamen devre dışı kalacaktır. Bunu asla aklınızdan çıkarmayın. error_reporting() ayarları etkisiz olacak ve her durumda sizin hata eylemciniz çağrılacaktır. Ancak, error_reporting yönergesindeki değeri hala okuyabilecek ve buna göre davranabileceksiniz. Özellikle şuna dikkat edin: Eğer hataya sebep olan deyimin önüne bir @ hata denetim işleci konmuşsa bu değer 0 olacaktır.

Ayrıca şunu da aklınızdan çıkarmayın: Gerektiği takdirde die() işlevi de sizin sorumluluğunuzdadır. hata_eylemci işlevi döndükten sonra betiğin çalışması, hataya sebep olan deyimden sonraki deyimden devam edecektir.

Kullanıcı tanımlı bir işlev ile üzerinde herhangi bir işlem yapılamayacak hatalar vardır, bunlar: E_ERROR, E_PARSE, E_CORE_ERROR, E_CORE_WARNING, E_COMPILE_ERROR, E_COMPILE_WARNING ve set_error_handler() işlevinin çağrıldığı dosyada oluşan E_STRICT hatalarının çoğu.

Eğer betik çalıştırılmadan önce oluşan hatalar varsa (karşıya dosya yükleme sırasında oluşan hatalar gibi), bu gibi durumlar için bildirdiğiniz hata_eylemci işlevi çağrılamayacaktır.

Değiştirgeler

hata_eylemci

Kullanıcının tanımlayacağı bu işlev iki değiştirge kabul etmelidir: hata kodu ve hatayı açıklayan bir dizge. Bu iki değiştirgeden sonra isteğe bağlı üç değiştirge daha kabul edilebilir: hatanın oluştuğu dosya adı, hatanın oluştuğu satırın numarası ve hatanın oluştuğu bağlam (hatanın oluştuğu noktada etkin simge tablosuna işaret eden bir dizi). hata_eylemci işlevinin söz dizimi:

hata_eylemci ( int $hatano , string $ileti [, string $betik_adı [, int $hata_satırı [, array $hata_bağlamı ]]] )
hatano
Oluşan hatanın seviyesini içeren bir tamsayı. İlk değiştirge olmalıdır.
ileti
Hata iletisini içeren bir dizge. İkinci değiştirge olmalıdır.
betik_adı
Hatanın oluştuğu betik dosyasının ismini bir dizge olarak içeren, belirtilmesi isteğe bağlı üçüncü değiştirge.
hata_satırı
Hatanın oluştuğu deyimin satır numarasını bir tamsayı olarak içeren, belirtilmesi isteğe bağlı dördüncü değiştirge.
hata_bağlamı
Hatanın oluştuğu noktada etkin simge tablosuna işaret eden bir diziyi kabul eden, belirtilmesi isteğe bağlı beşinci değiştirge. Bu değiştirge, başka bir deyişle, hatanın tetiklendiği etki alanında etkin değişkenleri içeren bir dizidir. İşlev bu değişkenlerde bir değişiklik yapmamalıdır.

İşlev FALSE döndürdüğü takdirde normal hata eylemcisi kaldığı yerden devam eder.

hata_türü

hata_eylemci işlevini tetikleyecek hatalar sabitleriyle, error_reporting yönergesine gösterilecek hataların değerleri belirtilirken yapıldığı gibi bir bit maskesi olarak belirtilebilir. Bu maskenin belirtilmediği durumda, error_reporting yönergesinde belirtilen değere bakılmaksızın her hatada hata_eylemci işlevi çağrılacaktır.

Dönen Değerler

(Varsa) Evvelce tanımlanmış hata eylemcisinin ismini bir dizge olarak döndürür. Eğer yerleşik hata eylemcisi kullanılmışsa NULL döner. Ayrıca belirtilen geriçağırım işlevinin geçersiz olduğu durumda da NULL döner. Eğer evvelki hata eylemcisi bir sınıfın yöntemi ise bu sınıfın ve yöntemin isimlerini içeren bir dizi döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.2.0 | $php_errormsg kullanılması durumunda hata eylemcisi FALSE döndürmelidir.
5.0.0 | hata_türü değiştirgesi kullanılabilir oldu.
4.3.0 | hata_eylemci değiştirgesinde bir işlev ismi yerine bir nesne başvurusu ve bir yöntem ismi içeren bir dizi belirtebilmek mümkün oldu.
4.0.2 | hata_eylemci işlevinin isteğe bağlı ek üç değiştirge (betik ismi, satır numarası ve bağlam) kabul edebilmesi mümkün oldu.

Örnekler

Örnek 1 - set_error_handler() ve trigger_error() ile hataların ele alınması

Bu örnekte hatalar tetiklenerek oluşan dahili istisnaların kullanıcı tanımlı bir işlev ile ele alınması gösterilmiştir.

<?php
// hata eylemci işlevi
function hataEylemcim($hatanum, $ileti, $betik, $satırnum)
{
    switch ($hatanum) {
    case E_USER_ERROR:
        echo "<b>HATA</b> [$hatanum] $ileti<br />\n";
        echo "  $betik dosyasının $satırnum. satırında  ölümcül hata";
        echo ", PHP " . PHP_VERSION . " (" . PHP_OS . ")<br />\n";
        echo "Çıkılıyor...<br />\n";
        exit(1);
        break;

    case E_USER_WARNING:
        echo "<b>UYARI</b> [$hatanum] $ileti<br />\n";
        break;

    case E_USER_NOTICE:
        echo "<b>BİLGİ</b> [$hatanum] $ileti<br />\n";
        break;

    default:
        echo "Bilinmeyen hata türü: [$hatanum] $ileti<br />\n";
        break;
    }

    /* PHP'nin yerleşik hata eylemcisi çalışmasın */
    return true;
}

// Hatanın oluşacağı işlev
function scale_by_log($vect, $scale)
{
    if (!is_numeric($scale) || $scale <= 0) {
        trigger_error("x <= 0 için log(x) tanımsız, scale = $scale verilmiş",
                      E_USER_ERROR);
    }

    if (!is_array($vect)) {
        trigger_error("Yanlış girdi, değerler dizi olarak verilmeliydi",
                      E_USER_WARNING);
        return null;
    }

    $temp = array();
    foreach($vect as $pos => $value) {
        if (!is_numeric($value)) {
            trigger_error("$pos. değer bir sayı değil, 0 kullanılıyor",
                          E_USER_NOTICE);
            $value = 0;
        }
        $temp[$pos] = log($scale) * $value;
    }

    return $temp;
}

// kullanıcı tanımlı hata eylemcisini bildirelim
$old_error_handler = set_error_handler("hataEylemcim");

// Bazı hataları tetikleyelim.
// Önce sayısal olmayan bir eleman içeren bir dizi tanımlayalım.
echo "ilk durum; bir hata: sayı yerine dizge\n";
$a = array(2, 3, "foo", 5.5, 43.3, 21.11);
print_r($a);

// burada ikinci hatayı üretiyoruz
echo "----\nikinci durum - bir uyarı (b = log(PI) * a)\n";
/* $pos. değer bir sayı değil, 0 kullanılıyor */
$b = scale_by_log($a, M_PI);
print_r($b);

// Bir dizi yerine bir dizge aktarıp yine sorun çıkarıyoruz
echo "----\nüçüncü durum - bir uyarı\n";
/* Yanlış girdi, değerler dizi olarak verilmeliydi */
$c = scale_by_log("not array", 2.3);
var_dump($c); // NULL

// Bu önemli bir hata; sıfır veya negatif bir sayının logaritması.
echo "----\ndördüncü durum - ölümcül hata\n";
/* x <= 0 için log(x) tanımsız, scale = $scale olmalıydı */
$d = scale_by_log($a, -2.5);
var_dump($d); // Bu satır hiç çalışmayacak.
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

ilk durum; bir hata: sayı yerine dizge
Array
(
    [0] => 2
    [1] => 3
    [2] => foo
    [3] => 5.5
    [4] => 43.3
    [5] => 21.11
)
----
ikinci durum - bir uyarı (b = log(PI) * a)
<b>BİLGİ</b> [1024] 2. değer bir sayı değil, 0 kullanılıyor<br />
Array
(
    [0] => 2.2894597716988
    [1] => 3.4341896575482
    [2] => 0
    [3] => 6.2960143721717
    [4] => 49.566804057279
    [5] => 24.165247890281
)
----
üçüncü durum - bir uyarı
<b>UYARI</b> [512] Yanlış girdi, değerler dizi olarak verilmeliydi<br />
NULL
----
dördüncü durum - ölümcül hata
<b>HATA</b> [256] x <= 0 için log(x) tanımsız, scale = -2.5 verilmiş<br />
  php-dnm dosyasının 36. satırında  ölümcül hata, PHP 5.3.0beta2-dev
  (Linux)<br />
Çıkılıyor...<br />

Ayrıca Bakınız

  • ErrorException
  • error_reporting() - Hangi PHP hatalarının raporlanacağını tanımlar
  • restore_error_handler() - Bir önceki hata eylemcisini devreye sokar
  • trigger_error() - Kullanıcı seviyesinde bir hata/uyarı/bilgi iletisi üretir
  • Hata seviyesi sabitleri
  • callback türü hakkında bilgi

restore_exception_handler
set_exception_handler
Hata İşleme İşlevleri


Kullanıcı tanımlı bir istisna eylemcisi bildirir

set_error_handler
trigger_error
Hata İşleme İşlevleri
PHP Manual

set_exception_handler

(PHP 5, PHP 7)

set_exception_handler — Kullanıcı tanımlı bir istisna eylemcisi bildirir

Açıklama

callback set_exception_handler ( callback $istisna_eylemcisi )

İstisna bir try/catch bloğu içinde yakalanamadığı durumlarda kullanılmak üzere bir istisna eylemcisi bildirir. istisna_eylemcisi işlevinin çağrılmasıyla istisna durdurulmuş olur.

Değiştirgeler

istisna_eylemcisi

Yakalanmamış bir istisna olduğunda çağrılacak işlevin ismi. Bu işlev set_exception_handler() çağrılmadan önce tanımlanmış olmalıdır. Bu eylemci işlevin tek bir değiştirge kabul etmesi gerekir: Oluşan istisna nesnesi.

Dönen Değerler

Hata durumunda NULL aksi takdirde evvelce tanımlanmış istisna eylemcisinin ismini döndürür. Evvelce tanımlanmış bir eylemci olmaması durumunda da NULL döner.

Örnekler

Örnek 1 - set_exception_handler() örneği

<?php
function istisna_eylemcisi($istisna) {
  echo "Yakalanmamış istisna: " , $istisna->getMessage(), "\n";
}

set_exception_handler('istisna_eylemcisi');

throw new Exception('Yakalanmamış İstisna');
echo "Çalışmadı\n";
?>

Ayrıca Bakınız

  • restore_exception_handler() - Bir önceki istisna eylemcisini devreye sokar
  • restore_error_handler() - Bir önceki hata eylemcisini devreye sokar
  • error_reporting() - Hangi PHP hatalarının raporlanacağını tanımlar
  • callback türü hakkında bilgi
  • PHP 5 İstisnaları

set_error_handler
trigger_error
Hata İşleme İşlevleri


Kullanıcı seviyesinde bir hata/uyarı/bilgi iletisi üretir

set_exception_handler
user_error
Hata İşleme İşlevleri
PHP Manual

trigger_error

(PHP 4 >= 4.0.1, PHP 5, PHP 7)

trigger_error — Kullanıcı seviyesinde bir hata/uyarı/bilgi iletisi üretir

Açıklama

bool trigger_error ( string $ileti [, int $tür = E_USER_NOTICE ] )

Bir kullanıcı hatası durumunu tetiklemek için kullanır. Yerleşik bir hata eylemcisi ile birlikte kullanılabileceği gibi (set_error_handler() ile) yeni bir hata eylemcisi olarak bildirilmiş bir kullanıcı tanımlı işlev ile birlikte de kullanılabilir.

Bu işlev çalışma anında, bir olağandışılık durumunda, belli bir yanıt üretmek gerektiğinde çok kullanışlıdır.

Değiştirgeler

ileti

Tetiklenen hata için tasarlanmış hata iletisi. En fazla 1024 karakter uzunluğunda olabilir. 1024'ten sonraki karakterler kırpılır.

tür

Tetiklenen hata için tasarlanmış hata türü. Sadece E_USER_ ailesinden sabitler belirtilebilir. E_USER_NOTICE öntanımlıdır.

Dönen Değerler

tür yanlış belirtilmişse FALSE aksi takdirde TRUE döner.

Örnekler

Örnek 1 - trigger_error() örneği

Daha kapsamlı bir örnek için set_error_handler() işlevine bakınız.

<?php
if (assert($divisor == 0)) {
    trigger_error("Sıfır bir bölen olamaz", E_USER_ERROR);
}
?>

Notlar

Uyarı

error_msg içindeki HTML öğeleri öncelenmez. Hta tarayıcıda gösterilecekse htmlentities() kullanın.

Ayrıca Bakınız

  • error_reporting() - Hangi PHP hatalarının raporlanacağını tanımlar
  • set_error_handler() - Kullanıcı tanımlı bir hata eylemcisi bildirir
  • restore_error_handler() - Bir önceki hata eylemcisini devreye sokar
  • Hata seviyesi sabitleri

set_exception_handler
user_error
Hata İşleme İşlevleri


trigger_error işlevinin takma adıdır

trigger_error
htscanner
Hata İşleme İşlevleri
PHP Manual

user_error

(PHP 4, PHP 5, PHP 7)

user_error — trigger_error() işlevinin takma adıdır

Açıklama

Bu işlev, trigger_error() işlevinin takma adıdır.

trigger_error
htscanner
Hata İşleme İşlevleri


htaccess-like support for all SAPIs

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
user_error
Giriş
PHP'nin Davranışını Etkileyenler


Giriş

The htscanner extension gives the possibility to use htaccess-like file to configure PHP per directory, just like apache's htaccess. It is especially useful with fastcgi (IIS5/6/7, lighttpd, etc.).

htscanner
Yapılandırma/Kurulum
htscanner


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
htscanner


Gereksinimler

PHP version 5.2.0 or greater.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/htscanner

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

htscanner Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Changelog
htscanner.config_file | ".htscanner" | PHP_INI_SYSTEM |
htscanner.default_docroot | "/" | PHP_INI_SYSTEM |
htscanner.default_ttl | "300" | PHP_INI_SYSTEM |
htscanner.stop_on_error | "Off" | PHP_INI_SYSTEM |
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

htscanner.config_file string

Filename to use as configuration file.

htscanner.default_docroot string

Default document root.

htscanner.default_ttl int

Cache time out for the configuration data, in seconds.

htscanner.stop_on_error int

Stop on error (parse error, cannot set an ini setting).

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Özkaynak Türleri

Bu eklentinin tanımlı hiçbir özkaynak türü yoktur.

Çalışma Anı Yapılandırması
inclued
Yapılandırma/Kurulum


Inclusion hierarchy viewer

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
    • Example that implements inclued into an application
  • inclued İşlevleri
    • inclued_get_data — Get the inclued data
Özkaynak Türleri
Giriş
PHP'nin Davranışını Etkileyenler


Giriş

Traces through and dumps the hierarchy of file inclusions and class inheritance at runtime.

The files may have been included using include, include_once, require, or require_once.

Class inheritance dependencies are also reported.

inclued
Yapılandırma/Kurulum
inclued


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
inclued


Gereksinimler

PHP version 5.1.0 or greater.

The included gengraph.php file utilizes the » graphviz library, however, this is not required.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/inclued

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

inclued Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
inclued.enabled | Off | PHP_INI_SYSTEM |
inclued.dumpdir | NULL | PHP_INI_SYSTEM |
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

inclued.enabled bool

Whether or not to enable inclued.

inclued.dumpdir string

Location (path) to the directory that stores inclued files. If set, each PHP request will create a file. These files are serialized versions of what inclued_get_data() would produce, so may be unserialized with unserialize().

Dikkat

Because every request creates a file, this directory may fill up fast!

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
Örnekler
inclued


Örnekler

İçindekiler

  • Example that implements inclued into an application
Öntanımlı Sabitler
Example that implements inclued into an application
inclued


Example that implements inclued into an application

This example demonstrates the process of implementing inclued into an existing application, and viewing the results.

Örnek 1 Getting the data within the PHP application itself (function)

<?php
// File to store the inclued information
$fp = fopen('/tmp/wp.ser', 'w');
if ($fp) {
    $clue = inclued_get_data();
    if ($clue) {
        fwrite($fp, serialize($clue));
    }
    fclose($fp);
}
?>

Now that some data exists, it's time to make sense of it in the form of a graph. The inclued extension includes a PHP file named gengraph.php that creates a dot file that requires the » graphviz library. However, this form is not required.

Örnek 2 Example use of gengraph.php

This example creates an image named inclued.png that shows the inclued data.

# First, create the dot file
$ php gengraph.php -i /tmp/wp.ser -o wp.dot

# Next, create the image
$ dot -Tpng -o inclued.png wp.dot

Örnek 3 Listing data via inclued dumps (configuration)

When using the inclued.dumpdir directive, files (include clues) are dumped with every request. Here's one way to list those files, and unserialize() them.

<?php
$path = ini_get('inclued.dumpdir');
if ($path && is_dir($path)) {

    echo "Path: $path", PHP_EOL;

    $inclues = new GlobIterator($path . DIRECTORY_SEPARATOR . 'inclued*');

    if ($inclues->count() === 0) {
        echo 'No clues today', PHP_EOL;
        exit;
    }

    foreach ($inclues as $inclue) {

        echo 'Inclued file: ', $inclue->getFilename(), PHP_EOL;

        $data = file_get_contents($inclue->getPathname());
        if ($data) {
            $inc = unserialize($data);
            echo ' -- filename: ', $inc['request']['SCRIPT_FILENAME'], PHP_EOL;
            echo ' -- number of includes: ', count($inc['includes']), PHP_EOL;
        }
        echo PHP_EOL;
    }
} else {
    echo 'I am totally clueless today.', PHP_EOL;
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

PATH: /tmp/inclued
Inclued file: inclued.56521.1
 -- filename: /Users/philip/test.php
 -- number of includes: 1

Inclued file: inclued.56563.1
 -- filename: /tmp/none.php
 -- number of includes: 0

Inclued file: inclued.56636.1
 -- filename: /tmp/three.php
 -- number of includes: 3

Örnekler
inclued İşlevleri
Örnekler


inclued İşlevleri

İçindekiler

  • inclued_get_data — Get the inclued data
Example that implements inclued into an application
inclued_get_data
inclued


Get the inclued data

inclued İşlevleri
Memtrack
inclued İşlevleri
PHP Manual

inclued_get_data

(PECL inclued >= 0.1.0)

inclued_get_data — Get the inclued data

Açıklama

array inclued_get_data ( void )

Get the inclued data.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The inclued data.

Örnekler

Örnek 1 inclued_get_data() example

See the inclued examples section for ways to create graphs with this data.

<?php
include 'x.php';

$clue = inclued_get_data();

print_r($clue);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
  [includes] => Array
    (
      [0] => Array
        (
          [operation] => include
          [op_type] => 2
          [filename] => x.php
          [opened_path] => /tmp/x.php
          [fromfile] => /tmp/z.php
          [fromline] => 2
        )
    )
)

Ayrıca Bakınız

  • inclued examples
  • debug_backtrace() - Hata izleme raporunu bir dizi olarak üretir
  • include - include

inclued İşlevleri
Memtrack
inclued İşlevleri


Memtrack

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
    • Basic usage
inclued_get_data
Giriş
PHP'nin Davranışını Etkileyenler


Giriş

The purpose of this extension is to detect the most memory hungry scripts and functions.

memtrack tracks memory consumption in PHP scripts and produces reports (warnings) when the consumption reaches certain levels set by the user. This is achieved by replacing default executor function by a special function which compares memory usage before and after running the original executor - this way we can tell how much the memory usage has changed during the execution of the current part of the code.

Zend Engine runs its executor for each opcode array (op_array), which usually means function, plain script and such, so memtrack doesn't have any noticeable effect on performance.

memtrack doesn't provide any functions, there are only INI directives which allow you to configure the way it should work.

Uyarı

Bu eklenti DENEYSELDİR. Bu eklentinin davranışı, işlev isimleri ve tüm belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu eklentiyi kullanmayın.

Memtrack
Yapılandırma/Kurulum
Memtrack


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Memtrack


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/memtrack

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Memtrack Configuration Options
İsim | Öntanımlı | Değişlik Yeri
memtrack.enabled | "0" | PHP_INI_SYSTEM
memtrack.soft_limit | "0" | PHP_INI_ALL
memtrack.hard_limit | "0" | PHP_INI_ALL
memtrack.vm_limit | "0" | PHP_INI_ALL
memtrack.ignore_functions | "" | PHP_INI_SYSTEM
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

memtrack.enabled boolean

Disables or enables the extension. Default value is 0, i.e. disabled.

memtrack.soft_limit int

Soft memory limit.

The extension checks memory consumption before and after executing an op_array and produces a warning is the difference between the two values is equal to or greater than the soft limit, but only if the function is not ignored.

Setting this option to 0 also disables both soft and hard limit warnings. Default value is 0, i.e. no warnings is produced.

memtrack.hard_limit int

Hard memory limit.

The extension checks memory consumption before and after executing an op_array and produces a warning is the difference between the two values is equal to or greater than the hard limit, even if the function is ignored. Setting this option to 0 disables hard limit warnings completely. Default value is 0, i.e. no hard limit warnings is produced.

memtrack.vm_limit int

Virtual memory limit (set on a process).

This limit is checked only on shutdown and a warning is produced if the value is greater than or equal to the limit.

This option is currently supported only on OSes where mallinfo() function is available (i.e. Linux).

memtrack.ignore_functions string

A comma or whitespace-separated list of functions which are to be ignored by soft_limit. The values are case-insensitive, for class methods use class::method syntax.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
Örnekler
Memtrack


Örnekler

İçindekiler

  • Basic usage
Öntanımlı Sabitler
Basic usage
Memtrack


Basic usage

Basic example on using memtrack extension:

Örnek 1 Creating large array in a function

<?php

/* /tmp/example1.php */

function foo() {
    $a = array();
    for ($i = 0; $i < 10000; $i++) $a[] = "test";
    return $a;
}
$arr = foo();

?>

Run the example with the following command:

php -d memtrack.enabled=1 -d memtrack.soft_limit=1M -d memtrack.vm_limit=3M /tmp/example1.php

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Warning: [memtrack] [pid 26177] user function foo() executed in /tmp/example1.php on line 10 allocated 4194304 bytes in /tmp/example1.php on line 0
Warning: [memtrack] [pid 26177] virtual memory usage on shutdown: 32911360 bytes in Unknown on line 0
Örnekler
OPcache
Örnekler


OPcache

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • OPcache İşlevleri
    • opcache_compile_file — Compiles and caches a PHP script without executing it
    • opcache_get_configuration — Get configuration information about the cache
    • opcache_get_status — Get status information about the cache
    • opcache_invalidate — Invalidates a cached script
    • opcache_is_script_cached — Tells whether a script is cached in OPCache
    • opcache_reset — Resets the contents of the opcode cache
Basic usage
Giriş
PHP'nin Davranışını Etkileyenler


Giriş

OPcache improves PHP performance by storing precompiled script bytecode in shared memory, thereby removing the need for PHP to load and parse scripts on each request.

This extension is bundled with PHP 5.5.0 and later, and is » available in PECL for PHP versions 5.2, 5.3 and 5.4.

OPcache
Yapılandırma/Kurulum
OPcache


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
OPcache


Kurulum

The process of installing OPcache varies depending on which version of PHP you're running. Please refer to the appropriate section below.

Bilginize:

If you want to use OPcache with » Xdebug, you must load OPcache before Xdebug.

PHP 5.5.0 and later

OPcache can only be compiled as a shared extension. If you have disabled the building of default extensions with --disable-all , you must compile PHP with the --enable-opcache option for OPcache to be available.

Once compiled, you can use the zend_extension configuration directive to load the OPcache extension into PHP. This can be done with zend_extension=/full/path/to/opcache.so on non-Windows platforms, and zend_extension=C:\path\to\php_opcache.dll on Windows.

PHP 5.2, 5.3 and 5.4

Bu » PECL eklentisi PHP ile gelmez.

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/ZendOpcache.

Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız.

Recommended php.ini settings

The following settings are generally recommended as providing good performance:

opcache.memory_consumption=128
opcache.interned_strings_buffer=8
opcache.max_accelerated_files=4000
opcache.revalidate_freq=60
opcache.fast_shutdown=1
opcache.enable_cli=1

You may also want to consider disabling opcache.save_comments and enabling opcache.enable_file_override, however note that you will have to test your code before using these in production as they are known to break some frameworks and applications, particularly in cases where documentation comment annotations are used.

A full list of configuration directives supported by OPcache is also available.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

OPcache configuration options
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
opcache.enable | "1" | PHP_INI_ALL |
opcache.enable_cli | "0" | PHP_INI_SYSTEM |
opcache.memory_consumption | "64" | PHP_INI_SYSTEM |
opcache.interned_strings_buffer | "4" | PHP_INI_SYSTEM |
opcache.max_accelerated_files | "2000" | PHP_INI_SYSTEM |
opcache.max_wasted_percentage | "5" | PHP_INI_SYSTEM |
opcache.use_cwd | "1" | PHP_INI_SYSTEM |
opcache.validate_timestamps | "1" | PHP_INI_ALL |
opcache.revalidate_freq | "2" | PHP_INI_ALL |
opcache.revalidate_path | "0" | PHP_INI_ALL |
opcache.save_comments | "1" | PHP_INI_SYSTEM |
opcache.load_comments | "1" | PHP_INI_ALL |
opcache.fast_shutdown | "0" | PHP_INI_SYSTEM |
opcache.enable_file_override | "0" | PHP_INI_SYSTEM |
opcache.optimization_level | "0xffffffff" | PHP_INI_SYSTEM |
opcache.inherited_hack | "1" | PHP_INI_SYSTEM |
opcache.dups_fix | "0" | PHP_INI_ALL |
opcache.blacklist_filename | "" | PHP_INI_SYSTEM |
opcache.max_file_size | "0" | PHP_INI_SYSTEM |
opcache.consistency_checks | "0" | PHP_INI_ALL |
opcache.force_restart_timeout | "180" | PHP_INI_SYSTEM |
opcache.error_log | "" | PHP_INI_SYSTEM |
opcache.log_verbosity_level | "1" | PHP_INI_SYSTEM |
opcache.preferred_memory_model | "" | PHP_INI_SYSTEM |
opcache.protect_memory | "0" | PHP_INI_SYSTEM |
opcache.mmap_base | NULL | PHP_INI_SYSTEM |
opcache.restrict_api | "" | PHP_INI_SYSTEM |
opcache.file_cache | NULL | PHP_INI_SYSTEM | Available as of PHP 7.0.0
opcache.file_cache_only | "0" | PHP_INI_SYSTEM | Available as of PHP 7.0.0
opcache.file_cache_consistency_checks | "1" | PHP_INI_SYSTEM | Available as of PHP 7.0.0
opcache.file_cache_fallback | "1" | PHP_INI_SYSTEM | Available as of PHP 7.0.0
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

opcache.enable boolean

Enables the opcode cache. When disabled, code is not optimised or cached. The setting opcache.enable can not be enabled at runtime through ini_set(), it can only be disabled. Trying to enable it at in a script will generate a warning.

opcache.enable_cli boolean

Enables the opcode cache for the CLI version of PHP. This is mostly useful for testing and debugging.

opcache.memory_consumption integer

The size of the shared memory storage used by OPcache, in megabytes.

opcache.interned_strings_buffer integer

The amount of memory used to store interned strings, in megabytes. This configuration directive is ignored in PHP < 5.3.0.

opcache.max_accelerated_files integer

The maximum number of keys (and therefore scripts) in the OPcache hash table. The actual value used will be the first number in the set of prime numbers { 223, 463, 983, 1979, 3907, 7963, 16229, 32531, 65407, 130987 } that is greater than or equal to the configured value. The minimum value is 200. The maximum value is 100000 in PHP < 5.5.6, and 1000000 in later versions.

opcache.max_wasted_percentage integer

The maximum percentage of wasted memory that is allowed before a restart is scheduled.

opcache.use_cwd boolean

If enabled, OPcache appends the current working directory to the script key, thereby eliminating possible collisions between files with the same base name. Disabling this directive improves performance, but may break existing applications.

opcache.validate_timestamps boolean

If enabled, OPcache will check for updated scripts every opcache.revalidate_freq seconds. When this directive is disabled, you must reset OPcache manually via opcache_reset(), opcache_invalidate() or by restarting the Web server for changes to the filesystem to take effect.

opcache.revalidate_freq integer

How often to check script timestamps for updates, in seconds. 0 will result in OPcache checking for updates on every request.

This configuration directive is ignored if opcache.validate_timestamps is disabled.

opcache.revalidate_path boolean

If disabled, existing cached files using the same include_path will be reused. Thus, if a file with the same name is elsewhere in the include_path, it won't be found.

opcache.save_comments boolean

If disabled, all documentation comments will be discarded from the opcode cache to reduce the size of the optimised code. Disabling this configuration directive may break applications and frameworks that rely on comment parsing for annotations, including Doctrine, Zend Framework 2 and PHPUnit.

opcache.load_comments boolean

If disabled, documentation comments won't be loaded from the opcode cache even if they exist. This can be used with opcache.save_comments to only load comments for applications that require them.

opcache.fast_shutdown boolean

If enabled, a fast shutdown sequence is used that doesn't free each allocated block, but relies on the Zend Engine memory manager to deallocate the entire set of request variables en masse.

opcache.enable_file_override boolean

When enabled, the opcode cache will be checked for whether a file has already been cached when file_exists(), is_file() and is_readable() are called. This may increase performance in applications that check the existence and readability of PHP scripts, but risks returning stale data if opcache.validate_timestamps is disabled.

opcache.optimization_level integer

A bitmask that controls which optimisation passes are executed.

opcache.inherited_hack boolean

In PHP < 5.3, OPcache stores the places where DECLARE_CLASS opcodes used inheritance; when the file is loaded, OPcache then tries to bind the inherited classes using the current environment. The problem is that while the DECLARE_CLASS opcode may not be needed for the current script, if the script requires that the opcode be defined, it may not run.

This configuration directive is ignored in PHP 5.3 and later.

opcache.dups_fix boolean

This hack should only be enabled to work around "Cannot redeclare class" errors.

opcache.blacklist_filename string

The location of the OPcache blacklist file. A blacklist file is a text file containing the names of files that should not be accelerated, one per line. Wildcards are allowed, and prefixes can also be provided. Lines starting with a semi-colon are ignored as comments.

A simple blacklist file might look as follows:

; Matches a specific file.
/var/www/broken.php
; A prefix that matches all files starting with x.
/var/www/x
; A wildcard match.
/var/www/*-broken.php
opcache.max_file_size integer

The maximum file size that will be cached, in bytes. If this is 0, all files will be cached.

opcache.consistency_checks integer

If non-zero, OPcache will verify the cache checksum every N requests, where N is the value of this configuration directive. This should only be enabled when debugging, as it will impair performance.

opcache.force_restart_timeout integer

The length of time to wait for a scheduled restart to begin if the cache isn't active, in seconds. If the timeout is hit, then OPcache assumes that something is wrong and will kill the processes holding locks on the cache to permit a restart.

If opcache.log_verbosity_level is set to 2 or above, a warning will be recorded in the error log when this occurs.

opcache.error_log string

The error log for OPcache errors. An empty string is treated the same as stderr, and will result in logs being sent to standard error (which will be the Web server error log in most cases).

opcache.log_verbosity_level integer

The log verbosity level. By default, only fatal errors (level 0) and errors (level 1) are logged. Other levels available are warnings (level 2), information messages (level 3) and debug messages (level 4).

opcache.preferred_memory_model string

The preferred memory model for OPcache to use. If left empty, OPcache will choose the most appropriate model, which is the correct behaviour in virtually all cases.

Possible values include mmap, shm, posix and win32.

opcache.protect_memory boolean

Protects shared memory from unexpected writes while executing scripts. This is useful for internal debugging only.

opcache.mmap_base string

The base used for shared memory segments on Windows. All PHP processes have to map shared memory into the same address space. Using this directive allows "Unable to reattach to base address" errors to be fixed.

opcache.restrict_api string

Allows calling OPcache API functions only from PHP scripts which path is started from specified string. The default "" means no restriction.

opcache.file_cache string

Enables and sets the second level cache directory. It should improve performance when SHM memory is full, at server restart or SHM reset. The default "" disables file based caching.

opcache.file_cache_only boolean

Enables or disables opcode caching in shared memory.

opcache.file_cache_consistency_checks boolean

Enables or disables checksum validation when script loaded from file cache.

opcache.file_cache_fallback boolean

Implies opcache.file_cache_only=1 for a certain process that failed to reattach to the shared memory (for Windows only). Explicitly enabled file cache is required.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Özkaynak Türleri

Bu eklentinin tanımlı hiçbir özkaynak türü yoktur.

Çalışma Anı Yapılandırması
OPcache İşlevleri
Yapılandırma/Kurulum


OPcache İşlevleri

İçindekiler

  • opcache_compile_file — Compiles and caches a PHP script without executing it
  • opcache_get_configuration — Get configuration information about the cache
  • opcache_get_status — Get status information about the cache
  • opcache_invalidate — Invalidates a cached script
  • opcache_is_script_cached — Tells whether a script is cached in OPCache
  • opcache_reset — Resets the contents of the opcode cache
Özkaynak Türleri
opcache_compile_file
OPcache


Compiles and caches a PHP script without executing it

OPcache İşlevleri
opcache_get_configuration
OPcache İşlevleri
PHP Manual

opcache_compile_file

(PHP 5 >= 5.5.5, PHP 7, PECL ZendOpcache > 7.0.2)

opcache_compile_file — Compiles and caches a PHP script without executing it

Açıklama

boolean opcache_compile_file ( string $file )

This function compiles a PHP script and adds it to the opcode cache without executing it. This can be used to prime the cache after a Web server restart by pre-caching files that will be included in later requests.

Değiştirgeler

file

The path to the PHP script to be compiled.

Dönen Değerler

Returns TRUE if file was compiled successfully başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

If file cannot be loaded or compiled, an error of level E_WARNING is generated. You may use @ to suppress this warning.

Ayrıca Bakınız

  • opcache_invalidate() - Invalidates a cached script

OPcache İşlevleri
opcache_get_configuration
OPcache İşlevleri


Get configuration information about the cache

opcache_compile_file
opcache_get_status
OPcache İşlevleri
PHP Manual

opcache_get_configuration

(PHP 5 >= 5.5.5, PHP 7, PECL ZendOpcache > 7.0.2)

opcache_get_configuration — Get configuration information about the cache

Açıklama

array opcache_get_configuration ( void )

This function returns configuration information about the cache instance

Dönen Değerler

Returns an array of information, including ini, blacklist and version

Hatalar/İstisnalar

If opcache.restrict_api is in use and the current path is in violation of the rule, an E_WARNING will be raised; no status information will be returned.

Ayrıca Bakınız

  • opcache_get_status() - Get status information about the cache

opcache_compile_file
opcache_get_status
OPcache İşlevleri


Get status information about the cache

opcache_get_configuration
opcache_invalidate
OPcache İşlevleri
PHP Manual

opcache_get_status

(PHP 5 >= 5.5.5, PHP 7, PECL ZendOpcache > 7.0.2)

opcache_get_status — Get status information about the cache

Açıklama

array opcache_get_status ([ boolean $get_scripts = TRUE ] )

This function returns state information about the cache instance

Değiştirgeler

get_scripts

Include script specific state information

Dönen Değerler

Returns an array of information, optionally containing script specific state information

Hatalar/İstisnalar

If opcache.restrict_api is in use and the current path is in violation of the rule, an E_WARNING will be raised; no status information will be returned.

Ayrıca Bakınız

  • opcache_get_configuration() - Get configuration information about the cache

opcache_get_configuration
opcache_invalidate
OPcache İşlevleri


Invalidates a cached script

opcache_get_status
opcache_is_script_cached
OPcache İşlevleri
PHP Manual

opcache_invalidate

(PHP 5 >= 5.5.0, PHP 7, PECL ZendOpcache >= 7.0.0)

opcache_invalidate — Invalidates a cached script

Açıklama

boolean opcache_invalidate ( string $script [, boolean $force = FALSE ] )

This function invalidates a particular script from the opcode cache. If force is unset or FALSE, the script will only be invalidated if the modification time of the script is newer than the cached opcodes.

Değiştirgeler

script

The path to the script being invalidated.

force

If set to TRUE, the script will be invalidated regardless of whether invalidation is necessary.

Dönen Değerler

Returns TRUE if the opcode cache for script was invalidated or if there was nothing to invalidate, or FALSE if the opcode cache is disabled.

Ayrıca Bakınız

  • opcache_compile_file() - Compiles and caches a PHP script without executing it
  • opcache_reset() - Resets the contents of the opcode cache

opcache_get_status
opcache_is_script_cached
OPcache İşlevleri


Tells whether a script is cached in OPCache

opcache_invalidate
opcache_reset
OPcache İşlevleri
PHP Manual

opcache_is_script_cached

(PHP 5 >= 5.6.0, PHP 7, PECL ZendOpcache >= 7.0.4)

opcache_is_script_cached — Tells whether a script is cached in OPCache

Açıklama

boolean opcache_is_script_cached ( string $file )

This function checks if a PHP script has been cached in OPCache. This can be used to more easily detect the "warming" of the cache for a particular script.

Değiştirgeler

file

The path to the PHP script to be checked.

Dönen Değerler

Returns TRUE if file is cached in OPCache, FALSE otherwise.

Ayrıca Bakınız

  • opcache_compile_file() - Compiles and caches a PHP script without executing it

opcache_invalidate
opcache_reset
OPcache İşlevleri


Resets the contents of the opcode cache

opcache_is_script_cached
Çıktı Denetimi
OPcache İşlevleri
PHP Manual

opcache_reset

(PHP 5 >= 5.5.0, PHP 7, PECL ZendOpcache >= 7.0.0)

opcache_reset — Resets the contents of the opcode cache

Açıklama

boolean opcache_reset ( void )

This function resets the entire opcode cache. After calling opcache_reset(), all scripts will be reloaded and reparsed the next time they are hit.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the opcode cache was reset, or FALSE if the opcode cache is disabled.

Ayrıca Bakınız

  • opcache_invalidate() - Invalidates a cached script

opcache_is_script_cached
Çıktı Denetimi
OPcache İşlevleri


Çıktı Tamponlama Denetimi

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
    • Örnekler
  • Çıktı Denetim İşlevleri
    • flush — Çıktı tamponunu boşaltır
    • ob_clean — Çıktı tamponunu temizler (siler)
    • ob_end_clean — Çıktı tamponunu temizler (siler) ve tamponu kapatır
    • ob_end_flush — Çıktı tamponunu boşaltır (gönderir) ve tamponu kapatır
    • ob_flush — Çıktı tamponunu boşaltır (gönderir)
    • ob_get_clean — Geçerli çıktı tamponun içeriğini döndürüp tamponu siler
    • ob_get_contents — Çıktı tamponunun içeriği ile döner
    • ob_get_flush — Çıktı tamponunu boşaltır, içeriğini bir dizge olarak döndürür ve çıktı tamponlamasını kapatır
    • ob_get_length — Çıktı tamponunundaki içeriğin uzunluğunu döndürür
    • ob_get_level — Çıktı tamponlama mekanizmasının iç içelik seviyesini döndürür
    • ob_get_status — Çıktı tamponlarının durumu ile döner
    • ob_gzhandler — Çıktı tamponunu gziplemek için ob_start geriçağırım işlevi
    • ob_implicit_flush — Örtük boşaltmayı açar/kapar
    • ob_list_handlers — Kullanımdaki çıktı eylemcileri listeler
    • ob_start — Çıktı tamponlamasını başlatır
    • output_add_rewrite_var — URL yeniden yazım değerlerini ekler
    • output_reset_rewrite_vars — URL yeniden yazma değerlerini sıfırlar
opcache_reset
Giriş
PHP'nin Davranışını Etkileyenler


Giriş

Çıktı denetim işlevleri, betikten gönderilen çıktıyı denetiminizde tutmaya yardımcı olurlar. Bu özellik, çok çeşitli durumlarda yararlı olabilir, özellikle de betiğiniz veriyi çıktılamaya başladıktan sonra bir başlık göndermek isterseniz. Çıktı denetim işlevleri, header() ve setcookie() işlevlerini kullanarak başlık gönderimini etkilemez, sadece PHP kod blokları arasındaki veriler ve echo gibi işlevler etkilenir.

Bilginize:

PHP 4.1.x'ten (ve 4.2.x'ten) 4.3.x'e sürüm yükseltirken önceki sürümlerdeki bir yazılım hatasından dolayı php.ini dosyanızda implict_flush yönergesine OFF atamak zorunda kalacaksınız, aksi takdirde ob_start() ile yapılan bir çıktı, çıktıdan gizlenmeyecektir.

Çıktı Denetimi
Yapılandırma/Kurulum
Çıktı Denetimi


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Çıktı Denetimi


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Çıktı Denetimi yapılandırma seçenekleri
İsim | Öntanımlı | Değişiklik yeri | Sürüm bilgisi
output_buffering | "0" | PHP_INI_PERDIR |
output_handler | NULL | PHP_INI_PERDIR | PHP 4.0.4'ten beri kullanılabilmektedir.
implicit_flush | "0" | PHP_INI_ALL | PHP <= 4.2.3'te PHP_INI_PERDIR.
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

output_buffering boolean/integer

Bu yönergeye 'On' değeri atamak suretiyle çıktı tamponlamasını bütün dosyalar için etkin kılabilirsiniz. Tamponun boyunu belli bir değerle sınırlamak isterseniz 'On' yerine bu değeri bayt cinsinden yazabilirsiniz (örnek: output_buffering=4096). PHP 4.3.5'ten itibaren PHP-CLI'de bu yönergenin değeri daima 'Off'tur.

output_handler string

Betiğinizin tüm çıktısını bir işleve yönlendirebilirsiniz. Örneğin, bu yönergeye mb_output_handler() atarsanız karakter kodlaması şeffaf olarak belirtilen kodlamaya dönüştürülür. Bu yönergeye herhangi bir çıktı eylemcisinin atanması özdevinimli olarak çıktı tamponlamasını etkin kılar.

Bilginize:

mb_output_handler() ve
ob_iconv_handler() işlevlerini birlikte
kullanamazsınız, bu durum ob_gzhandler() ve
zlib.output_compression
çifti için de geçerlidir.

Bilginize:

Bu yönergede sadece yerleşik işlevler belirtilebilir. Kullanıcı tanımlı işlevler için ob_start() işlevini kullanın.

implicit_flush boolean

FALSE öntanımlıdır. TRUE atandığında her çıktı bloğundan sonra çıktı tamponu kendi kendini özdevinimli olarak boşaltır. Bu işlem, her HTML bloğundan, her print veya echo çağrısından sonra flush() işlevini çağırmaya eşdeğerdir.

PHP'yi HTTP ortamında kullanırken bu seçeneğe TRUE atandığında bir takım başarım sorunları ortaya çıkabilir, bu bakımdan genellikle sadece hata ayıklama amacıyla kullanılması önerilir. CLI SAPI altında bu yönergenin öntanımlı değeri TRUE'dur.

Ayrıca bakınız: ob_implicit_flush().

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
Örnekler
Çıktı Denetimi


Örnekler
Çıktı Denetimi
PHP Manual

Örnekler

İçindekiler

  • Örnekler
Öntanımlı Sabitler
Örnekler
Çıktı Denetimi


Örnekler
Çıktı Denetim İşlevleri
Örnekler
PHP Manual

Örnekler

Örnek 1 - Çıktı Denetimi örneği

<?php

ob_start();
echo "Hello\n";

setcookie("cookiename", "cookiedata");

ob_end_flush();

?>

Yukarıdaki örnekte, ob_end_flush() işlevi çağrılana kadar echo çıktısı çıktı tamponunda saklanır. Bu süre zarfında, setcookie() çağrısı çerezi bir hataya yol açmadan başarıyla saklar. (Normalde, tarayıcıya veri gönderildikten sonra başlıkları gönderemezsiniz.)

Örnekler
Çıktı Denetim İşlevleri
Örnekler
PHP Manual


Çıktı Denetim İşlevleri

Ayrıca Bakınız

header() ve setcookie().

İçindekiler

  • flush — Çıktı tamponunu boşaltır
  • ob_clean — Çıktı tamponunu temizler (siler)
  • ob_end_clean — Çıktı tamponunu temizler (siler) ve tamponu kapatır
  • ob_end_flush — Çıktı tamponunu boşaltır (gönderir) ve tamponu kapatır
  • ob_flush — Çıktı tamponunu boşaltır (gönderir)
  • ob_get_clean — Geçerli çıktı tamponun içeriğini döndürüp tamponu siler
  • ob_get_contents — Çıktı tamponunun içeriği ile döner
  • ob_get_flush — Çıktı tamponunu boşaltır, içeriğini bir dizge olarak döndürür ve çıktı tamponlamasını kapatır
  • ob_get_length — Çıktı tamponunundaki içeriğin uzunluğunu döndürür
  • ob_get_level — Çıktı tamponlama mekanizmasının iç içelik seviyesini döndürür
  • ob_get_status — Çıktı tamponlarının durumu ile döner
  • ob_gzhandler — Çıktı tamponunu gziplemek için ob_start geriçağırım işlevi
  • ob_implicit_flush — Örtük boşaltmayı açar/kapar
  • ob_list_handlers — Kullanımdaki çıktı eylemcileri listeler
  • ob_start — Çıktı tamponlamasını başlatır
  • output_add_rewrite_var — URL yeniden yazım değerlerini ekler
  • output_reset_rewrite_vars — URL yeniden yazma değerlerini sıfırlar
Örnekler
flush
Çıktı Denetimi


Çıktı tamponunu boşaltır

Çıktı Denetim İşlevleri
ob_clean
Çıktı Denetim İşlevleri
PHP Manual

flush

(PHP 4, PHP 5, PHP 7)

flush — Çıktı tamponunu boşaltır

Açıklama

void flush ( void )

PHP'nin kullandığı ve PHP'nin artalanında kullanılan (CGI, HTTP sunucusu gibi) yazma tamponlarını boşaltır. Bu işlem, çıktı tamponları boşalıncaya kadar çıktının kullanıcının tarayıcısına gönderilmesi demektir.

flush() işlevi HTTP sunucunuzun veya istemci tarafında tarayıcının tamponlama ayarlarını ve PHP'nin kullanıcı alanı çıktı tamponlama mekanizmasını etkilemez. Bu bakımdan, çıktı tamponlarını boşaltmak için hem ob_flush() hem de flush() çağrısı yapmalısınız.

Çeşitli sunucular, özellikle de Win32 üstünde, tarayıcıya sonuçların aktarılması bitmemişse betiğiniz sonlanıncaya kadar betiğinizin çıktısı tamponlanmaya devam eder.

mod_gzip gibi Apache sunucu modülleri, verinin istemciye gönderimi bitmeden kendi tamponunu boşaltırken bir flush() işlemine sebep olabilir.

Tarayıcı, göstermeden önce girdisini tamponlayabilir. Örneğin, Netscape, bir satırsonu veya bir kapama etiketi alana kadar metni tamponlar ve en dıştaki tablonun </table> kapama etiketini almadan tabloyu oluşturmaz.

Microsoft Internet Explorer'ın bazı sürümleri 256 baytlık çıktı almadan sayfayı göstermeye başlamaz, yani, bu tarayıcının daha önce birşeyler göstermesini istiyorsanız boşaltma öncesi ek boşluk karakterleri göndermeniz gerekebilir.

Dönen Değerler

Hiçbir değer dönmez.

Çıktı Denetim İşlevleri
ob_clean
Çıktı Denetim İşlevleri


Çıktı tamponunu temizler (siler)

flush
ob_end_clean
Çıktı Denetim İşlevleri
PHP Manual

ob_clean

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

ob_clean — Çıktı tamponunu temizler (siler)

Açıklama

void ob_clean ( void )

Bu işlev, en üst seviye çıktı tamponunun içeriğini siler.

Bu işlev, ob_end_clean() gibi tamponu yok etmez.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • ob_flush() - Çıktı tamponunu boşaltır (gönderir)
  • ob_end_flush() - Çıktı tamponunu boşaltır (gönderir) ve tamponu kapatır
  • ob_end_clean() - Çıktı tamponunu temizler (siler) ve tamponu kapatır

flush
ob_end_clean
Çıktı Denetim İşlevleri


Çıktı tamponunu temizler (siler) ve tamponu kapatır

ob_clean
ob_end_flush
Çıktı Denetim İşlevleri
PHP Manual

ob_end_clean

(PHP 4, PHP 5, PHP 7)

ob_end_clean — Çıktı tamponunu temizler (siler) ve tamponu kapatır

Açıklama

bool ob_end_clean ( void )

Bu işlev, en üst seviye çıktı tamponunun içeriğini siler ve bu çıktı tamponunu kapatır. ob_end_clean() çağrısından sonra tampon yok edildiğinden eğer gönderilen tampon içeriğin saklamak istiyorsanız ob_end_clean() çağrısından önce bir ob_get_contents() çağrısı yapmalısınız.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. Başarısızlık sebeplerinden biri etkin bir tamponun bulunmaması diğeri ise tamponun silinememesi (özel bir tamponsa) olabilir.

Hatalar/İstisnalar

İşlev başarısız olursa E_NOTICE seviyesinde bir ileti üretir.

Sürüm Bilgisi

Sürüm: | Açıklama
4.2.0 | Mantıksal dönüş değeri eklendi.

Örnekler

Aşağıda çıktı tamponlarından kurtulmanın kolay bir yolu gösterilmiştir:

Örnek 1 - ob_end_clean() örneği

<?php
ob_start();
echo 'Gösterilmek istenmeyen metin.';
ob_end_clean();
?>

Ayrıca Bakınız

  • ob_start() - Çıktı tamponlamasını başlatır
  • ob_get_contents() - Çıktı tamponunun içeriği ile döner
  • ob_flush() - Çıktı tamponunu boşaltır (gönderir)

ob_clean
ob_end_flush
Çıktı Denetim İşlevleri


Çıktı tamponunu boşaltır (gönderir) ve tamponu kapatır

ob_end_clean
ob_flush
Çıktı Denetim İşlevleri
PHP Manual

ob_end_flush

(PHP 4, PHP 5, PHP 7)

ob_end_flush — Çıktı tamponunu boşaltır (gönderir) ve tamponu kapatır

Açıklama

bool ob_end_flush ( void )

Bu işlev en üst seviye çıktı tamponunun (varsa) içeriğini gönderir ve bu tamponu kapatır. ob_end_flush() çağrısından sonra tampon yok edildiğinden eğer gönderilen tampon içeriğin saklamak istiyorsanız ob_end_flush() çağrısından önce bir ob_get_contents() çağrısı yapmalısınız.

Bilginize: ob_get_flush() işlevi, bu işlevden farklı olarak tampon içeriğini bir dizge olarak döndürür.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. Başarısızlık sebeplerinden biri etkin bir tamponun bulunmaması diğeri ise tamponun silinememesi (özel bir tamponsa) olabilir.

Hatalar/İstisnalar

İşlev başarısız olursa E_NOTICE seviyesinde bir ileti üretir.

Sürüm Bilgisi

Sürüm: | Açıklama
4.2.0 | Mantıksal dönüş değeri eklendi.

Örnekler

Örnek 1 - ob_end_flush() örneği

Aşağıda çıktı tamponlarının boşaltılıp silinmesinin kolay bir yolu gösterilmiştir:

<?php
  while (@ob_end_flush());
?>

Ayrıca Bakınız

  • ob_start() - Çıktı tamponlamasını başlatır
  • ob_get_contents() - Çıktı tamponunun içeriği ile döner
  • ob_get_flush() - Çıktı tamponunu boşaltır, içeriğini bir dizge olarak döndürür ve çıktı tamponlamasını kapatır
  • ob_flush() - Çıktı tamponunu boşaltır (gönderir)
  • ob_end_clean() - Çıktı tamponunu temizler (siler) ve tamponu kapatır

ob_end_clean
ob_flush
Çıktı Denetim İşlevleri


Çıktı tamponunu boşaltır (gönderir)

ob_end_flush
ob_get_clean
Çıktı Denetim İşlevleri
PHP Manual

ob_flush

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

ob_flush — Çıktı tamponunu boşaltır (gönderir)

Açıklama

void ob_flush ( void )

Bu işlev (varsa) çıktı tamponunun içeriğini gönderir.
ob_flush() sonrası tampon içeriği temizlendiğinden eğer
gönderilen içeriği saklamak istiyorsanız ob_flush()
çağrısından önce bir ob_get_contents() çağrısı
yapmalısınız.

Bu işlev, ob_end_flush() işlevinin yaptığı gibi çıktı tamponunu yok etmez.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • ob_get_contents() - Çıktı tamponunun içeriği ile döner
  • ob_clean() - Çıktı tamponunu temizler (siler)
  • ob_end_flush() - Çıktı tamponunu boşaltır (gönderir) ve tamponu kapatır
  • ob_end_clean() - Çıktı tamponunu temizler (siler) ve tamponu kapatır

ob_end_flush
ob_get_clean
Çıktı Denetim İşlevleri


Geçerli çıktı tamponun içeriğini döndürüp tamponu siler

ob_flush
ob_get_contents
Çıktı Denetim İşlevleri
PHP Manual

ob_get_clean

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

ob_get_clean — Geçerli çıktı tamponun içeriğini döndürüp tamponu siler

Açıklama

string ob_get_clean ( void )

Geçerli çıktı tamponun içeriğini döndürüp tamponu siler.

ob_get_clean() esasen
ob_get_contents() ve
ob_end_clean() işlevlerini çağırır.

Dönen Değerler

Çıktı tamponlaması etkin değilse FALSE, aksi takdirde çıktı tamponunun içeriğini döndürür.

Örnekler

Örnek 1 - Basit bir ob_get_clean() örneği

<?php

ob_start();

echo "Hello World";

$out = ob_get_clean();
$out = strtolower($out);

var_dump($out);
?>

Yukarıdaki örneğin çıktısı:

string(11) "hello world"

Ayrıca Bakınız

  • ob_get_contents() - Çıktı tamponunun içeriği ile döner
  • ob_start() - Çıktı tamponlamasını başlatır

ob_flush
ob_get_contents
Çıktı Denetim İşlevleri


Çıktı tamponunun içeriği ile döner

ob_get_clean
ob_get_flush
Çıktı Denetim İşlevleri
PHP Manual

ob_get_contents

(PHP 4, PHP 5, PHP 7)

ob_get_contents — Çıktı tamponunun içeriği ile döner

Açıklama

string ob_get_contents ( void )

Çıktı tamponunu temizlemeden içeriği ile döner.

Dönen Değerler

Çıktı tamponlaması etkin değilse FALSE, aksi takdirde çıktı tamponunun içeriğini döndürür.

Örnekler

Örnek 1 - ob_get_contents() örneği

<?php

ob_start();

echo "Hello ";

$out1 = ob_get_contents();

echo "World";

$out2 = ob_get_contents();

ob_end_clean();

var_dump($out1, $out2);
?>

Yukarıdaki örneğin çıktısı:

string(6) "Hello "
string(11) "Hello World"

Ayrıca Bakınız

  • ob_start() - Çıktı tamponlamasını başlatır
  • ob_get_length() - Çıktı tamponunundaki içeriğin uzunluğunu döndürür

ob_get_clean
ob_get_flush
Çıktı Denetim İşlevleri


Çıktı tamponunu boşaltır, içeriğini bir dizge olarak döndürür ve çıktı tamponlamasını kapatır

ob_get_contents
ob_get_length
Çıktı Denetim İşlevleri
PHP Manual

ob_get_flush

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

ob_get_flush — Çıktı tamponunu boşaltır, içeriğini bir dizge olarak döndürür ve çıktı tamponlamasını kapatır

Açıklama

string ob_get_flush ( void )

ob_get_flush() işlevi, çıktı tamponunu boşaltır, içeriğini bir dizge olarak döndürür ve çıktı tamponlamasını kapatır.

Bilginize: Tampon içeriğini bir dizge olarak döndürmesi dışında ob_end_flush() işlevine benzer.

Dönen Değerler

Çıktı tamponlaması etkin değilse FALSE aksi takdirde çıktı tamponunun içeriğini döndürür.

Örnekler

Örnek 1 - ob_get_flush() örneği

<?php
// output_buffering=On
print_r(ob_list_handlers());

// tamponu bir dosyaya kaydedelim
$buffer = ob_get_flush();
file_put_contents('buffer.txt', $buffer);

print_r(ob_list_handlers());
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [0] => default output handler
)
Array
(
)

Ayrıca Bakınız

  • ob_end_clean() - Çıktı tamponunu temizler (siler) ve tamponu kapatır
  • ob_end_flush() - Çıktı tamponunu boşaltır (gönderir) ve tamponu kapatır
  • ob_list_handlers() - Kullanımdaki çıktı eylemcileri listeler

ob_get_contents
ob_get_length
Çıktı Denetim İşlevleri


Çıktı tamponunundaki içeriğin uzunluğunu döndürür

ob_get_flush
ob_get_level
Çıktı Denetim İşlevleri
PHP Manual

ob_get_length

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

ob_get_length — Çıktı tamponunundaki içeriğin uzunluğunu döndürür

Açıklama

int ob_get_length ( void )

Çıktı tamponunundaki içeriğin uzunluğunu döndürür.

Dönen Değerler

Çıktı tamponu etkin değilse FALSE, aksi takdirde bayt cinsinden çıktı tamponunundaki içeriğin uzunluğunu döndürür.

Örnekler

Örnek 1 - ob_get_length() örneği

<?php

ob_start();

echo "Hello ";

$len1 = ob_get_length();

echo "World";

$len2 = ob_get_length();

ob_end_clean();

echo $len1 . ", ." . $len2;
?>

Yukarıdaki örneğin çıktısı:

6, 11

Ayrıca Bakınız

  • ob_start() - Çıktı tamponlamasını başlatır
  • ob_get_contents() - Çıktı tamponunun içeriği ile döner

ob_get_flush
ob_get_level
Çıktı Denetim İşlevleri


Çıktı tamponlama mekanizmasının iç içelik seviyesini döndürür

ob_get_length
ob_get_status
Çıktı Denetim İşlevleri
PHP Manual

ob_get_level

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

ob_get_level — Çıktı tamponlama mekanizmasının iç içelik seviyesini döndürür

Açıklama

int ob_get_level ( void )

Çıktı tamponlama mekanizmasının iç içelik seviyesini döndürür

Dönen Değerler

Çıktı tamponlaması etkin değilse sıfır, aksi takdirde çıktı tamponlama eylemcilerinin iç içelik seviyesini döndürür.

Ayrıca Bakınız

  • ob_start() - Çıktı tamponlamasını başlatır
  • ob_get_contents() - Çıktı tamponunun içeriği ile döner

ob_get_length
ob_get_status
Çıktı Denetim İşlevleri


Çıktı tamponlarının durumu ile döner

ob_get_level
ob_gzhandler
Çıktı Denetim İşlevleri
PHP Manual

ob_get_status

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

ob_get_status — Çıktı tamponlarının durumu ile döner

Açıklama

array ob_get_status ([ bool $tam_durum = FALSE ] )

ob_get_status() işlevi, tam_durum değiştirgesinde TRUE belirtilmişse her seviyeden etkin çıktı tamponlarının tamamının durumunu, aksi takdirde üst seviye çıktı tamponunun durumunu döndürür.

Değiştirgeler

tam_durum

TRUE her seviyeden etkin çıktı tamponlarının tamamının durumunu, FALSE ise veya belirtilmezse sadece üst seviye çıktı tamponunun durumunu döndürür.

Dönen Değerler

tam_durum değiştirgesi belirtilmezse veya tam_durum = FALSE olduğunda aşağıdaki elemanlarla basit bir dizi döner:

Array
(
    [level] => 2
    [type] => 0
    [status] => 0
    [name] => URL-Rewriter
    [del] => 1
)
ob_get_status() işlevinin basit sonuçları
Anahtar | Değer
level | Çıktı iç içelik seviyesi
type | PHP_OUTPUT_HANDLER_INTERNAL (0) veya PHP_OUTPUT_HANDLER_USER (1)
status | PHP_OUTPUT_HANDLER_START (0), PHP_OUTPUT_HANDLER_CONT (1) veya PHP_OUTPUT_HANDLER_END (2) değerlerinden biri
name | Etkin çıktı eylemcisinin ismi veya atanmamışsa ' default output handler'
del | ob_start() tarafından belirlenen silme seçeneği

İşlev, tam_durum = TRUE değeriyle çağrılırsa, her ektin çıktı tamponu seviyesi için bir eleman içeren bir dizi döner. Çıktı seviyesi üst seviye dizinin anahtarı olarak kullanılır ve bu anahtarların değerleri de kendi etkin çıktı seviyelerine ilişkin durum bilgisi içeren birer dizi içerirler.

Array
(
    [0] => Array
        (
            [chunk_size] => 0
            [size] => 40960
            [block_size] => 10240
            [type] => 1
            [status] => 0
            [name] => default output handler
            [del] => 1
        )

    [1] => Array
        (
            [chunk_size] => 0
            [size] => 40960
            [block_size] => 10240
            [type] => 0
            [buffer_size] => 0
            [status] => 0
            [name] => URL-Rewriter
            [del] => 1
        )

)

Tam çıktı ek olarak şu elemanları içerir:

ob_get_status() işlevinin tam sonuçları
Anahtar | Değer
chunk_size | ob_start() tarafından atanan parça boyutu
size | ...
blocksize | ...

Ayrıca Bakınız

  • ob_get_level() - Çıktı tamponlama mekanizmasının iç içelik seviyesini döndürür
  • ob_list_handlers() - Kullanımdaki çıktı eylemcileri listeler

ob_get_level
ob_gzhandler
Çıktı Denetim İşlevleri


Çıktı tamponunu gziplemek için ob_start geriçağırım işlevi

ob_get_status
ob_implicit_flush
Çıktı Denetim İşlevleri
PHP Manual

ob_gzhandler

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

ob_gzhandler — Çıktı tamponunu gziplemek için ob_start geriçağırım işlevi

Açıklama

string ob_gzhandler ( string $tampon , int $kip )

ob_gzhandler() işlevi, sıkıştırılmış sayfaları destekleyen tarayıcılara gziplenmiş veri gönderim oluşumuna yardımcı olmak için ob_start() işlevinde bir geriçağırım işlevi olarak belirtilmek üzere tasarlanmıştır. ob_gzhandler() asıl veriyi sıkıştırılmış olarak göndermeden önce tarayıcının kabul edeceği içerik kodlamasının türünü ("gzip", "deflate" veya hiçbiri) tespit edip tampon içeriğini buna uygun olarak kodlayıp çıktılar. Hangi sıkıştırma türünü kabul edeceğini doğru başlıkları göndererek tarayıcı belirlediğinden tüm tarayıcılar desteklenir. Eğer bir tarayıcı sıkıştırılmış sayfaları desteklemiyorsa işlev FALSE döndürecektir.

Değiştirgeler

tampon

kip

Dönen Değerler

Sürüm Bilgisi

Sürüm: | Açıklama
4.0.5 | kip değiştirgesi eklendi.

Örnekler

Örnek 1 - ob_gzhandler() örneği

<?php

ob_start("ob_gzhandler");

?>
<html>
<body>
<p>Bu sayfa sıkıştırılmış olabilir.</p>
</html>
<body>

Notlar

Bilginize:

ob_gzhandler() işlevi zlib eklentisini gerektirir.

Bilginize:

ob_gzhandler() işlevini ve zlib.output_compression yönergesini birlikte kullanamazsınız. Ayrıca, zlib.output_compression yörengesinin ob_gzhandler() işlevine tercih edildiğini bilmenizde yarar var.

Ayrıca Bakınız

  • ob_start() - Çıktı tamponlamasını başlatır
  • ob_end_flush() - Çıktı tamponunu boşaltır (gönderir) ve tamponu kapatır

ob_get_status
ob_implicit_flush
Çıktı Denetim İşlevleri


Örtük boşaltmayı açar/kapar

ob_gzhandler
ob_list_handlers
Çıktı Denetim İşlevleri
PHP Manual

ob_implicit_flush

(PHP 4, PHP 5, PHP 7)

ob_implicit_flush — Örtük boşaltmayı açar/kapar

Açıklama

void ob_implicit_flush ([ int $seçenek ] )

ob_implicit_flush() işlevi örtük tampon boşalmayı açar veya kapatır. Örtük boşaltma işlemi, her çıktı çağrısından sonra bir boşaltma işlemiyle sonuçlanır, dolayısıyla açıkça flush() çağrıları yapma gereği ortadan kalkar.

Değiştirgeler

seçenek

TRUE ise örtük boşaltma açılır FALSE ise kapatılır. TRUE öntanımlıdır.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • flush() - Çıktı tamponunu boşaltır
  • ob_start() - Çıktı tamponlamasını başlatır
  • ob_end_flush() - Çıktı tamponunu boşaltır (gönderir) ve tamponu kapatır

ob_gzhandler
ob_list_handlers
Çıktı Denetim İşlevleri


Kullanımdaki çıktı eylemcileri listeler

ob_implicit_flush
ob_start
Çıktı Denetim İşlevleri
PHP Manual

ob_list_handlers

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

ob_list_handlers — Kullanımdaki çıktı eylemcileri listeler

Açıklama

array ob_list_handlers ( void )

Kullanımdaki çıktı eylemcileri listeler.

Dönen Değerler

Kullanımdaki çıktı eylemcileri (varsa) içeren bir dizi döndürür. Eğer output_buffering etkinse veya ob_start() ile bir anonim işlev belirtilmişse ob_list_handlers() işlevi "default output handler" (öntanımlı çıktı eylemcisi) dizgesini döndürür.

Örnekler

Örnek 1 - ob_list_handlers() işlevi

<?php
// output_buffering=On
print_r(ob_list_handlers());
ob_end_flush();

ob_start("ob_gzhandler");
print_r(ob_list_handlers());
ob_end_flush();

// anonim işlev
ob_start(create_function('$string', 'return $string;'));
print_r(ob_list_handlers());
ob_end_flush();
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [0] => default output handler
)

Array
(
    [0] => ob_gzhandler
)

Array
(
    [0] => default output handler
)

Ayrıca Bakınız

  • ob_end_clean() - Çıktı tamponunu temizler (siler) ve tamponu kapatır
  • ob_end_flush() - Çıktı tamponunu boşaltır (gönderir) ve tamponu kapatır
  • ob_get_flush() - Çıktı tamponunu boşaltır, içeriğini bir dizge olarak döndürür ve çıktı tamponlamasını kapatır
  • ob_start() - Çıktı tamponlamasını başlatır

ob_implicit_flush
ob_start
Çıktı Denetim İşlevleri


Çıktı tamponlamasını başlatır

ob_list_handlers
output_add_rewrite_var
Çıktı Denetim İşlevleri
PHP Manual

ob_start

(PHP 4, PHP 5, PHP 7)

ob_start — Çıktı tamponlamasını başlatır

Açıklama

bool ob_start ([ callable $çıktı_geriçağırıcı = NULL [, int $parça_boyu = 0 [, int $seçenekler = PHP_OUTPUT_HANDLER_STDFLAGS ]]] )

Bu işlev çıktı tamponlamasını ektin kılar. Çıktı tamponlaması etkinken betikten (başlıklar dışında) hiçbir çıktı gönderilmez ve çıktı dahili bir tamponda saklanır.

Bu dahili tamponun içeriği ob_get_contents() işleviyle bir dizge değişkenine kopyalanabilir. Dahili tamponda birikenleri çıktılamak için ob_end_flush() işlevini kullanın. Çıktılamak istemiyorsanız, ob_end_clean() işlevi ile tampon içeriğini sessiz sedasız silebilirsiniz.

Uyarı

Bazı HTTP sunucuları (Apache gibi) geriçağırım işlevini çağırırken betiğin çalışma dizinini değiştirir. Geriçağırım işlevinde chdir(dirname($_SERVER['SCRIPT_FILENAME'])) gibi bir çağrıyla betiğin bulunduğu dizine dönebilirsiniz.

Çıktı tamponlaması bir yığıt gibi çalışabilir, bir ob_start() etkinken başka bir ob_start() çağrısı yapabilirsiniz. Yalnız aynı sayıda ob_end_flush() çağrısı yapmayı unutmayın. Eğer çok sayıda çıktı geriçağırım işlevi etkinse, her biri iç içelik sırası gözetilerek çıktıyı süzerler.

Değiştirgeler

çıktı_geriçağırıcı

Bu değiştirge ile isteğe bağlı bir çıktı eylemcisi işlev belirtilebilir. Bu işlev değiştirge olarak bir dizge almalı ve bir dizge döndürmelidir. Bu işlev, çıktı tamponu boşaltılırken (gönderim), tampon temizlenirken (ob_flush(), ob_clean() ve benzeri bir işlevle) veya isteğin sonunda çıktı tamponu kullanıcının tarayıcısına boşaltılırken çağrılacaktır. İşlev çağrıldığında çıktı tamponunu değiştirge olarak alması ve sonuçta tarayıcıya gönderilmek üzere yeni bir çıktı tamponu döndürmesi beklenir. Eğer bu değiştirge ile belirtilen işlev çağrılabilir değilse ob_start() FALSE döndürür. İşlevinin sözdizimi:

bool işlev_ismi ( string $tampon [, int $kip ] )
tampon
Çıktı tamponunun içeriği.
kip
PHP_OUTPUT_HANDLER_* sabitlerinin bit maskesi.

çıktı_geriçağırıcı FALSE döndürdüğü takdirde özgün çıktı tarayıcıya gönderilir.

çıktı_geriçağırıcı, değiştirgesine bir NULL değer aktarılarak atlanabilir.

ob_end_clean(), ob_end_flush(), ob_clean(), ob_flush() ve ob_start() bir geriçağırım işlevi olarak belirtilemez. Bunlardan biri belirtilirse, davranışın nasıl olacağı belirsizdir. Bir tamponun içeriğini silmek isterseniz geriçağrıcıdan "" (boş dizge) döndürmelisiniz. Bir geriçağırım işlevinden, çıktı tamponlama işlevlerini kullanarak print_r($ifade, true) veya highlight_file($dosyaismi, true) gibi işlevleri çağıramazsınız.

Bilginize:

PHP 4.0.4'ten itibaren, sıkıştırılmış sayfaları destekleyen tarayıcılara gziplenmiş veri göndermek için ob_gzhandler() işlevi kullanılabilmektedir. ob_gzhandler() işlevi tarayıcının kabul edeceği içerik kodlamasının türünü tespit ettikten sonra buna uygun çıktı döndürür.

parça_boyu

İsteğe bağlı parça_boyu belirtildiği takdirde, parça_boyunu aşan veya tamponun tam dolmasına sebep olan bir çıktılama çağrısından sonra tampon boşaltılır. Öntanımlı 0 değerinin anlamı işlevin sadece çıktı tamponu kapandığında çağrılacağı anlamına gelir.

PHP 5.4.0 öncesinde, özel 1 değeri parça_boyu olarak 4096 kullanılacağı anlamına gelirdi.

kip

kip, çıktı tamponuna uygulanabilecek işlemleri denetleyen bir bitmaskesidir. Çıktı tamponunun temizlenmesi, boşaltılması ve silinmesine izin vermek öntanımlı olup, bunun karşılığı PHP_OUTPUT_HANDLER_CLEANABLE | PHP_OUTPUT_HANDLER_FLUSHABLE | PHP_OUTPUT_HANDLER_REMOVABLE veya kısaca PHP_OUTPUT_HANDLER_STDFLAGS sabitidir.

Her sabit aşağıda açıklandığı gibi belli bir işlev kümesine erişimi denetler:

Sabit | İşlevler
PHP_OUTPUT_HANDLER_CLEANABLE | ob_clean(), ob_end_clean() ve ob_get_clean().
PHP_OUTPUT_HANDLER_FLUSHABLE | ob_end_flush(), ob_flush() ve ob_get_flush().
PHP_OUTPUT_HANDLER_REMOVABLE | ob_end_clean(), ob_end_flush() ve ob_get_flush().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.4.0 | ob_start() işlevinin (FALSE belirtildiğinde betiğin çalışması bitene kadar çıktı tamponunu silinmesini engelleyen) üçüncü değiştirgesi (çıktı tamponuna uygulanabilecek işlemleri denetleyen bir bitmaskesi olarak) integer türünde kip değiştirgesi olarak değiştirildi. Ne yazık ki bu değişiklikle, 5.4.0 öncesinde yazılmış ve üçüncü değiştirgenin kullanıldığı kodların API uyumluluğunun bozulmasına sebep olunmuştur. Bu kodun her iki sürümle de uyumlu olmasının nasıl sağlanabileceği ile ilgili örnek için kip örneğine bakınız.
5.4.0 | 1 değeri artık çıktı tamponuna gönderilecek parçaların 1 baytlık olacağı anlamına geliyor.
4.3.2 | çıktı_geriçağırıcı çalıştırılamadığı zaman işlevin FALSE döndürmesi sağlandı.
4.2.0 | sil değiştirgesi eklendi.

Örnekler

Örnek 1 - Kullanıcı tanımlı geriçağırım işlevi örneği

<?php

function geriçağırım($tampon)
{
  // elmaları armutlarla değiştirelim
  return (str_replace("elmalar", "armutlar", $tampon));
}

ob_start("geriçağırım");

?>
<html>
<body>
<p>Bizden elmalarla armutların karşılaştırılması isteniyor.</p>
</body>
</html>
<?php

ob_end_flush();

?>

Yukarıdaki örneğin çıktısı:

<html>
<body>
<p>Bizden armutlarla armutların karşılaştırılması isteniyor.</p>
</body>
</html>

Örnek 2 Çıktı tamponunun hem PHP 5.3 hem de 5.4 ile uyumlu olmasını sağlayan ve çıktı tamponunun silinmesini önleyen kod örneği

<?php

if (version_compare(PHP_VERSION, '5.4.0', '>=')) {
  ob_start(null, 0, PHP_OUTPUT_HANDLER_STDFLAGS ^
    PHP_OUTPUT_HANDLER_REMOVABLE);
} else {
  ob_start(null, 0, false);
}

?>

Ayrıca Bakınız

  • ob_get_contents() - Çıktı tamponunun içeriği ile döner
  • ob_end_clean() - Çıktı tamponunu temizler (siler) ve tamponu kapatır
  • ob_end_flush() - Çıktı tamponunu boşaltır (gönderir) ve tamponu kapatır
  • ob_implicit_flush() - Örtük boşaltmayı açar/kapar
  • ob_gzhandler() - Çıktı tamponunu gziplemek için ob_start geriçağırım işlevi
  • ob_iconv_handler() - Çıktı tamponu eylemcisi olarak karakter kodlaması dönüşümü yapar
  • mb_output_handler() - Çıktı tamporundaki karakter kodlamasını dönüştüren geriçağırım işlevi
  • ob_tidyhandler() - Tampon onarımı için ob_start geriçağırım işlevi

ob_list_handlers
output_add_rewrite_var
Çıktı Denetim İşlevleri


URL yeniden yazım değerlerini ekler

ob_start
output_reset_rewrite_vars
Çıktı Denetim İşlevleri
PHP Manual

output_add_rewrite_var

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

output_add_rewrite_var — URL yeniden yazım değerlerini ekler

Açıklama

bool output_add_rewrite_var ( string $isim , string $değer )

Bu işlev URL yeniden yazım mekanizmasına yeni bir isim/değer çifti ekler. İsim ve değer URL'lere (GET değiştirgesi olarak) ve formlara (gizli girdi alanı olarak), session.use_trans_sid ile şeffaf URL yeniden yazımı etkinleştirilmiş gibi oturum ID'sinin eklendiği tarzda eklenir. Bu yolla mutlak URL'lerin (http://example.com/.. gibi) yeniden yazılmayacağına lütfen dikkat ediniz.

Bu işlevin davranışı url_rewriter.tags php.ini yönergesi ile denetlenir.

Bilginize: Bu işlevin çağrılması örtük olarak çıktı tamponlamasını henüz başlamamışsa başlatır.

Değiştirgeler

isim

Değişkenin ismi.

değer

Değişkenin değeri.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - output_add_rewrite_var() örneği

<?php
output_add_rewrite_var('var', 'value');

// bazı bağlar
echo '<a href="file.php">bağlantı</a>
<a href="http://example.com">diğer bağlantı</a>';

// bir form
echo '<form action="script.php" method="post">
<input type="text" name="var2" />
</form>';

print_r(ob_list_handlers());
?>

Yukarıdaki örneğin çıktısı:

<a href="file.php?var=value">bağlantı</a>
<a href="http://example.com">diğer bağlantı</a>

<form action="script.php" method="post">
<input type="hidden" name="var" value="value" />
<input type="text" name="var2" />
</form>

Array
(
    [0] => URL-Rewriter
)

Ayrıca Bakınız

  • output_reset_rewrite_vars() - URL yeniden yazma değerlerini sıfırlar
  • ob_flush() - Çıktı tamponunu boşaltır (gönderir)
  • ob_list_handlers() - Kullanımdaki çıktı eylemcileri listeler

ob_start
output_reset_rewrite_vars
Çıktı Denetim İşlevleri


URL yeniden yazma değerlerini sıfırlar

output_add_rewrite_var
PHP Seçenek ve Bilgileri
Çıktı Denetim İşlevleri
PHP Manual

output_reset_rewrite_vars

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

output_reset_rewrite_vars — URL yeniden yazma değerlerini sıfırlar

Açıklama

bool output_reset_rewrite_vars ( void )

Bu işlev URL yeniden yazım mekanizmasını sıfırlar ve output_add_rewrite_var() işleviyle veya (session_start() işleviyle session.use_trans_sid tanımlanmışsa) oturum mekanizmasıyla evvelce atanmış olan tüm yeniden yazım çiftlerini siler.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - output_reset_rewrite_vars() örneği

<?php
session_start();
output_add_rewrite_var('var', 'value');

echo '<a href="file.php">bağlantı</a>';
ob_flush();

output_reset_rewrite_vars();
echo '<a href="file.php">bağlantı</a>';
?>

Yukarıdaki örneğin çıktısı:

<a href="file.php?PHPSESSID=xxx&var=value">bağlantı</a>
<a href="file.php">bağlantı</a>

Ayrıca Bakınız

  • output_add_rewrite_var() - URL yeniden yazım değerlerini ekler
  • ob_flush() - Çıktı tamponunu boşaltır (gönderir)
  • ob_list_handlers() - Kullanımdaki çıktı eylemcileri listeler
  • session_start() - Oturum verisini ilklendirir

output_add_rewrite_var
PHP Seçenek ve Bilgileri
Çıktı Denetim İşlevleri


PHP Seçenek ve Bilgileri

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • PHP Seçenek/Bilgi İşlevleri
    • assert_options — Çeşitli kararlılık denetim seçeneklerini açar/kapar
    • assert — Checks if assertion is FALSE
    • cli_get_process_title — Returns the current process title
    • cli_set_process_title — Sets the process title
    • dl — Belirtilen PHP eklentisini çalışma anında yükler
    • extension_loaded — Belirtilen eklenti yüklü mü diye bakar
    • gc_collect_cycles — Çöp döngülerin toplanması için zorlar
    • gc_disable — Döngüsel gönderim toplayıcısını etkisiz kılar
    • gc_enable — Döngüsel gönderim toplayıcısını etkin kılar
    • gc_enabled — Döngüsel gönderim toplayıcısının durumunu döndürür
    • gc_mem_caches — Reclaims memory used by the Zend Engine memory manager
    • get_cfg_var — Belirtilen PHP yönergesinin değerini döndürür
    • get_current_user — PHP betiğinin sahibininin kullanıcı ismini döndürür
    • get_defined_constants — Tüm sabitlerin isimlerini ve değerlerini içeren bir ilişkisel dizi döndürür
    • get_extension_funcs — Bir modülün işlevlerinin isimlerini içeren bir dizi döndürür
    • get_include_path — include_path yönergesinin değerini döndürür
    • get_included_files — Betiğe dahil edilen dosyaların isimlerini içeren bir dizi döndürür
    • get_loaded_extensions — Derlenmiş ve yüklenmiş tüm modüllerin isimlerini içeren bir dizi döndürür
    • get_magic_quotes_gpc — magic_quotes_gpc yönergesinin değerini döndürür
    • get_magic_quotes_runtime — magic_quotes_runtime yönergesinin çalışma anı değerini döndürür
    • get_required_files — get_included_files işlevinin takma adıdır
    • get_resources — Returns active resources
    • getenv — Bir ortam değişkeninin değerini döndürür
    • getlastmod — Geçerli sayfanın son değişiklik zamanını döndürür
    • getmygid — PHP betiğinin sahibinin grup kimliğini döndürür
    • getmyinode — Çalışan betiğin dosya düğümü numarasını döndürür
    • getmypid — PHP'nin süreç kimliğini (PID) döndürür
    • getmyuid — PHP betiğinin sahibinin kullanıcı kimliğini döndürür
    • getopt — Komut satırı değiştirgeleri listesinden seçenekleri döndürür
    • getrusage — Geçerli özkaynak kullanımlarını döndürür
    • ini_alter — ini_set işlevinin takma adıdır
    • ini_get_all — Tüm yapılandırma yönergelerini döndürür
    • ini_get — Bir yapılandırma yönergesinin değerini döndürür
    • ini_restore — Bir yapılandırma yönergesine eski değerini atar
    • ini_set — Bir yapılandırma yönergesine değer atar
    • magic_quotes_runtime — Takma Adı: set_magic_quotes_runtime
    • main — Böyle bir işlev yoktur
    • memory_get_peak_usage — PHP'ye ayrılan belleğin azami miktarını döndürür
    • memory_get_usage — PHP'ye ayrılan belleğin miktarını döndürür
    • php_ini_loaded_file — Yüklü php.ini dosyasının dosya yolunu döndürür
    • php_ini_scanned_files — Ek ini dizininden ayrıştırılan dosyaların listesi ile döner
    • php_logo_guid — PHP logo kimliğini döndürür
    • php_sapi_name — HTTP sunucusu ile PHP arasındaki arayüzün türünü döndürür
    • php_uname — PHP'nin çalıştığı işletim sistemi hakkında bilgi döndürür
    • phpcredits — PHP'ya katkıda bulunanları gösterir
    • phpinfo — PHP'nin o anki durumu hakkında büyük miktarda bilgi çıktılar
    • phpversion — Çalışan PHP'nin sürümünü döndürür
    • putenv — Bir ortam değişkenine değer atar
    • restore_include_path — include_path yönergesini eski değerine ayarlar
    • set_include_path — include_path yönergesinin çalışma anı değerini belirler
    • set_magic_quotes_runtime — magic_quotes_runtime yönergesinin çalışma anı değerini belirler
    • set_time_limit — Azami çalıştırma süresini sınırlar
    • sys_get_temp_dir — Geçici dosyalar için kullanılan dizini döndürür
    • version_compare — PHP standardına uygun hale getirilmiş iki sürüm numarası dizgesini karşılaştırır
    • zend_logo_guid — Zend logo kimliğini döndürür
    • zend_thread_id — Geçerli evre için eşsiz bir betimleyici döndürür
    • zend_version — Zend motorunun sürümünü döndürür
output_reset_rewrite_vars
Giriş
PHP'nin Davranışını Etkileyenler


Giriş

Bu işlevler PHP'nin kendisi hakkında pek çok bilgi almanızı sağlarlar. Çalışma anı yapılandırması, yüklü eklentiler, sürüm ve daha pek çok bilgi. Ayrıca, çalışmakta olan PHP'nin seçeneklerini atayacak işlevleri de burada bulabilirsiniz. PHP'nin belki de en bilinen işlevi phpinfo()'yu da burada bulabilirsiniz.

PHP Seçenek ve Bilgileri
Yapılandırma/Kurulum
PHP Seçenek ve Bilgileri


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
PHP Seçenek ve Bilgileri


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

PHP Seçenekleri ve Bilgileri için Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
assert.active | "1" | PHP_INI_ALL |
assert.bail | "0" | PHP_INI_ALL |
assert.warning | "1" | PHP_INI_ALL |
assert.callback | NULL | PHP_INI_ALL |
assert.quiet_eval | "0" | PHP_INI_ALL |
assert.exception | "0" | PHP_INI_ALL | PHP 7.0.0'dan beri kullanılmaktadır.
enable_dl | "1" | PHP_INI_SYSTEM | Bu kullanımı önerilmeyen özellik gelecekte kesinlikle KALDIRILACAKTIR.
max_execution_time | "30" | PHP_INI_ALL |
max_input_time | "-1" | PHP_INI_PERDIR | PHP 4.3.0'dan beri kullanılmaktadır.
max_input_nesting_level | "64" | PHP_INI_PERDIR | PHP 4.4.8 ve 5.2.3'den beri kullanılmaktadır.
max_input_vars | 1000 | PHP_INI_PERDIR | PHP 5.3.9'dan beri kullanılmaktadır.
magic_quotes_gpc | "1" | PHP_INI_PERDIR | PHP <= 4.2.3'te PHP_INI_ALL. PHP 5.4.0'da kaldırıldı.
magic_quotes_runtime | "0" | PHP_INI_ALL | PHP 5.4.0'da kaldırıldı.
zend.enable_gc | "1" | PHP_INI_ALL | PHP 5.3.0'dan beri kullanılmaktadır.

PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

assert.active boolean

assert() değerlendirmesini etkin kılar.

assert.bail boolean

Kararlılık denetimleri başarısız olduğunda betiğin çalışmasını sonlandırır.

assert.warning boolean

Başarısız olan her kararlılık denetimi için bir PHP uyarısı çıktılar.

assert.callback string

Kararlılık denetimleri başarısız olduğunda çağrılacak kullanıcı işlevi.

assert.quiet_eval boolean

Kararlılık denetimini sağlayan ifadenin değerlendirilmesi sırasında error_reporting() işlevinin o anki ayarları kullanılır. Etkin olduğunda değerlendirme sırasında hiçbir hata gösterilmez (örtük error_reporting(0)). Aksi takdirde, hatalar error_reporting() ayarlarına uygun olarak gösterilir.

assert.exception boolean

Kararlılık denetimleri başarısız olduğunda AssertionError istisnası çalıştırılır.

enable_dl boolean

Bu yönerge gerçekte sadece PHP'nin Apache modülünde yararlıdır. PHP eklentilerinin dl() işleviyle sanal konak veya dizin temelinde devingen olarak yüklenmesini veya yüklenmemesini etkin kılabilirsiniz.

Devingen yüklemenin devre dışı bırakılmasının asıl sebebi güvenliktir. Devingen yükleme ile, tüm open_basedir sınırlamalarını yok saymak mümkündür. Devingen yüklemeye safe_mode kullanımı dışında öntanımlı olarak izin verilir. Güvenli kipte dl() işlevi asla kullanılamaz.

max_execution_time integer

Çözümleyici tarafından sonlandırılmadan önce bir betiğin çalışabileceği azami süreyi saniye cinsinden tanımlar. Bu, yetersizce yazılmış betiklerin sunucuya bağlanmasına engel olur. Öntanımlı süre 30 saniyedir. PHP komut satırından çalıştırıldığında bu süre 0 saniyedir.

Azami çalışma süresi sistem çağrılarından, akım işlemlerinden ve benzerlerinden etkilenmez. Daha ayrıntılı bilgi için set_time_limit() işlevinin açıklamasına bakınız.

Güvenli kipte (safe_mode) çalışırken ini_set() ile bu ayarı değiştiremezsiniz. Bunu yapmanın tek çaresi php.ini içinde güvenli kipi kapatmak ya da süre sınırlamasını değiştirmektir.

HTTP sunucunuzun PHP'nin çalışmasını kesintiye uğratacak başka zaman aşımı yapılandırmaları olabilir. Apache'nin bir Timeout yönergesi ve IIS'nin bir CGI zaman aşımı işlevi vardır. Bu konuda daha ayrıntılı bilgi edinmek için HTTP sunucunuzun belgelerine bakınız.

max_input_time integer

Bir betiğin POST ve GET gibi girdileri çözümlemesi için gereken azami süre saniye cinsinden burada belirtilir. Süre, sunucu PHP'yi çağırdığı an başlar betik çalışmaya başladığı an biter.

max_input_nesting_level integer

girdi değişkenlerinin ($_GET, $_POST... gibi) azami iç içelik derinliğini ayarlar.

max_input_vars integer

Kabul edilebilecek girdi değişkenlerinin sayısı (Bu sınırlama $_GET, $_POST and $_COOKIE değişkenlerine ayrı ayrı uygulanır.). Çırpı çatışmalarını kullanan hizmet reddi saldırıları olasılığını azaltmak için kullanılır. Bu yönergede belirtilenden daha fazla girdi değişkeni varsa bir E_WARNING çıktılanır ve istekteki fazla değişkenler yoksayılır.

magic_quotes_gpc boolean
Uyarı

Bu özelliğin kullanımı PHP 5.3.0 itibariyle ÖNERİLMEMEKTE olup PHP 5.4.0'da tamamen KALDIRILMIŞTIR.

GPC (Get/Post/Cookie) işlemleri için sihirli tırnakların durumunu ayarlar. Bu yönergeye 'On' atandığında tüm ' (tek tırnak), " (çift tırnak), \ (tersbölü) ve NULL karakterleri özdevinimli olarak bir tersbölü ile öncelenecektir.

Bilginize:

PHP 4'te bunlardan başka $_ENV değişkenleri de öncelenir.

Bilginize:

Eğer magic_quotes_sybase yönergesine de ON atanmışsa bu magic_quotes_gpc yönergesini tamamen geçersiz kılacaktır. Her iki yönergenin etkin olmasının anlamı, sadece tek tırnakların '' biçiminde öncelenmesi, çift tırnakların, tersbölülerin ve NULL'ların olduğu gibi bırakılması, öncelenmemesi demektir.

Ayrıca, get_magic_quotes_gpc() işlevinin açıklamasına da bakınız.

magic_quotes_runtime boolean
Uyarı

Bu özelliğin kullanımı PHP 5.3.0 itibariyle ÖNERİLMEMEKTE olup PHP 5.4.0'da tamamen KALDIRILMIŞTIR.

magic_quotes_runtime yönergesi etkinse, veritabanları ve metin dosyaları gibi her tür harici kaynaktan veri döndüren çoğu işlev öncelem için tersbölü karakterini kullanacaktır. Eğer magic_quotes_sybase yönergesi de ON ise, tek tırnaklar tersbölü yerine bir tek tırnak ile öncelenir.

magic_quotes_runtime yönergesinden etkilenen işlevler (PECL'dekiler hariç):

  • get_meta_tags()
  • file_get_contents()
  • file()
  • fgets()
  • fwrite()
  • fread()
  • fputcsv()
  • stream_socket_recvfrom()
  • exec()
  • system()
  • passthru()
  • stream_get_contents()
  • bzread()
  • gzfile()
  • gzgets()
  • gzwrite()
  • gzread()
  • exif_read_data()
  • dba_insert()
  • dba_replace()
  • dba_fetch()
  • ibase_fetch_row()
  • ibase_fetch_assoc()
  • ibase_fetch_object()
  • mssql_fetch_row()
  • mssql_fetch_object()
  • mssql_fetch_array()
  • mssql_fetch_assoc()
  • mysqli_fetch_row()
  • mysqli_fetch_array()
  • mysqli_fetch_assoc()
  • mysqli_fetch_object()
  • pg_fetch_row()
  • pg_fetch_assoc()
  • pg_fetch_array()
  • pg_fetch_object()
  • pg_fetch_all()
  • pg_select()
  • sybase_fetch_object()
  • sybase_fetch_array()
  • sybase_fetch_assoc()
  • SplFileObject::fgets()
  • SplFileObject::fgetcsv()
  • SplFileObject::fwrite()

zend.enable_gc boolean

Döngüsel gönderim toplayıcısını açıp kapar.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Aşağıdaki sabitler PHP çekirdeğinin parçası olarak daima kullanılabilir durumdadır.

Öntanımlı phpcredits() sabitleri
Sabit | Değer | Açıklama
CREDITS_GROUP | 1 | PHP geliştiricilerinin listesi.
CREDITS_GENERAL | 2 | Genel katkıcılar: Dil tasarımı ve kavramlar, PHP ve SAPI modülü yazarları.
CREDITS_SAPI | 4 | PHP için sunucu API modüllerinin listesi ve bunların yazarları.
CREDITS_MODULES | 8 | PHP için eklenti modüllerinin listesi ve bunların yazarları.
CREDITS_DOCS | 16 | Belgelendirme ekibi.
CREDITS_FULLPAGE | 32 | Genellikle diğer seçeneklerle birlikte kullanılır. Diğer seçeneklerin gösterilmesini gerektirdiği bilgilerin tamamının tek bir HTML sayfasına basılmasını sağlar.
CREDITS_QA | 64 | Kalite güvencesi ekibi.
CREDITS_ALL | -1 | Tüm katkıcılar; şu sabitlere eşdeğerdir: CREDITS_DOCS + CREDITS_GENERAL + CREDITS_GROUP + CREDITS_MODULES + CREDITS_QA + CREDITS_FULLPAGE. Bu sabitlerle ilgili bilgilerin uygun başlıklarla tek bir HTML sayfasında gösterilmesini sağlar. Bu öntanımlı değerdir.
phpinfo() sabitleri
Sabit | Değer | Açıklama
INFO_GENERAL | 1 | Yapılandırma satırı, php.ini dosyasının yeri, derleme tarihi, HTTP Sunucusu, Sistem ve benzerleri.
INFO_CREDITS | 2 | PHP Katkıcıları. Ayrıca bakınız: phpcredits().
INFO_CONFIGURATION | 4 | PHP yönergelerinin geçerli yerel ve asıl değerleri. Ayrıca bakınız: ini_get().
INFO_MODULES | 8 | Yüklü modüller ve bunlarla ilgili ayarlar.
INFO_ENVIRONMENT | 16 | $_ENV ile de kullanılabilen ortam değişkenleri bilgisi.
INFO_VARIABLES | 32 | EGPCS (Environment, GET, POST, Cookie, Server) ile ilgili tüm öntanımlı değişkenleri listeler.
INFO_LICENSE | 64 | PHP Lisans bilgisi. Ayrıca bakınız: » Lisans SSS.
INFO_ALL | -1 | Yukarıdakilerin tamamı gösterilir. Bu öntanımlı değerdir.
ASSERT_ACTIVE (integer)
ASSERT_CALLBACK (integer)
ASSERT_BAIL (integer)
ASSERT_WARNING (integer)
ASSERT_QUIET_EVAL (integer)

Aşağıdaki sabitler sadece Windows içindir. Çeşitli özellikleri saptamak için sürüm bilgileri verirler. Bu sabitler PHP 5.3.0'dan itibaren kullanılabilmektedir

Windows' specific constantsa özgü sabitler
Sabit | Açıklama
PHP_WINDOWS_VERSION_MAJOR | Windows ana sürüm numarası; 4 (NT4/ME/98/95), 5 (XP/2003 R2/2003/2000) veya 6 (Vista/2008) olabilir.
PHP_WINDOWS_VERSION_MINOR | Windows alt sürüm numarası; 0 (Vista/2008/2000/NT4/95), 1 (XP), 2 (2003 R2/2003/XP x64), 10 (98) veya 90 (ME) olabilir.
PHP_WINDOWS_VERSION_BUILD | Windows derleme sürümü (örneğin, Windows Vista + SP1 için 6001'dir).
PHP_WINDOWS_VERSION_PLATFORM | PHP'nin üzerinde çalıştığı platform sürüm numarası; Windows Vista/XP/2000/NT4 ve Server 2008/2003 için 2, Windows ME/98/95 için 1 olabilir.
PHP_WINDOWS_VERSION_SP_MAJOR | Kurulu SP ana sürümü; hiçbir SP kurulu değilse 0'dır. Örneğin SP 3 kurulu Windows XP için bu değer 3'tür.
PHP_WINDOWS_VERSION_SP_MINOR | Kurulu SP ana sürümü; hiçbir SP kurulu değilse 0'dır.
PHP_WINDOWS_VERSION_SUITEMASK | Çeşitli kurulu Windows özelliklerini betimleyen bir bit maskesi, Olası değerler için aşağıdaki tabloya bakınız.
PHP_WINDOWS_VERSION_PRODUCTTYPE | This contains the value used to determine the PHP_WINDOWS_NT_* sabitlerini saptamakta kullanılan değer; platform türünü belirleyen PHP_WINDOWS_NT_*sabitlerinden biri olabilir.
PHP_WINDOWS_NT_DOMAIN_CONTROLLER | Bir etki alanı denetleyicisidir.
PHP_WINDOWS_NT_SERVER | Bir sunucu sistemi belirtir (Server 2008/2003/2000 gibi); ancak, sunucu aynı zamanda bir etki alanı denetleyicisi ise PHP_WINDOWS_NT_DOMAIN_CONTROLLER olarak raporlanır.
PHP_WINDOWS_NT_WORKSTATION | Bir istemci sistemi belirtir (Vista/XP/2000/NT4 gibi).

PHP_WINDOWS_VERSION_SUITEMASK bit maskesinde kullanılabilecek bitsel değerler aşağıdaki tablada gösterilmiştir.

PHP_WINDOWS_VERSION_SUITEMASK bit alanları
Bit alanı | Açıklama
0x00000004 | Microsoft BackOffice bileşenleri kurulu.
0x00000400 | Windows Server 2003, Web Edition kurulu.
0x00004000 | Windows Server 2003, Compute Cluster Edition kurulu.
0x00000080 | Windows Server 2008 Datacenter, Windows Server 2003, Datacenter Edition veya Windows 2000 Datacenter Server kurulu.
0x00000002 | Windows Server 2008 Enterprise, Windows Server 2003, Enterprise Edition, Windows 2000 Advanced Server veya Windows NT Server 4.0 Enterprise Edition kurulu.
0x00000040 | Windows XP Embedded kurulu.
0x00000200 | Windows Vista Home Premium, Windows Vista Home Basic, or Windows XP Home Edition kurulu
0x00000100 | Remote Desktop sadece etkileşimli tek oturumla desteklenir. Sistem bir uygulama sunucusu olarak çalışmadıkça bu değer atanır.
0x00000001 | Evvelce sistemde Microsoft Small Business Server kuruluymuş fakat başka bir Windows sürümüne yükseltilmiş.
0x00000020 | Microsoft Small Business Server, sınırlı istemci lisansı ile kurulu.
0x00002000 | Windows Storage Server 2003 R2 veya Windows Storage Server 2003 kurulu.
0x00000010 | Terminal Services kurulu. Bu değer daima atanır. Bu değer atanmışsa ancak 0x00000100 değilse sistem uygulama sunucusu kipinde çalışıyor demektir.
0x00008000 | Windows Home Server kurulu.
Özkaynak Türleri
PHP Seçenek/Bilgi İşlevleri
PHP Seçenek ve Bilgileri


PHP Seçenek/Bilgi İşlevleri

İçindekiler

  • assert_options — Çeşitli kararlılık denetim seçeneklerini açar/kapar
  • assert — Checks if assertion is FALSE
  • cli_get_process_title — Returns the current process title
  • cli_set_process_title — Sets the process title
  • dl — Belirtilen PHP eklentisini çalışma anında yükler
  • extension_loaded — Belirtilen eklenti yüklü mü diye bakar
  • gc_collect_cycles — Çöp döngülerin toplanması için zorlar
  • gc_disable — Döngüsel gönderim toplayıcısını etkisiz kılar
  • gc_enable — Döngüsel gönderim toplayıcısını etkin kılar
  • gc_enabled — Döngüsel gönderim toplayıcısının durumunu döndürür
  • gc_mem_caches — Reclaims memory used by the Zend Engine memory manager
  • get_cfg_var — Belirtilen PHP yönergesinin değerini döndürür
  • get_current_user — PHP betiğinin sahibininin kullanıcı ismini döndürür
  • get_defined_constants — Tüm sabitlerin isimlerini ve değerlerini içeren bir ilişkisel dizi döndürür
  • get_extension_funcs — Bir modülün işlevlerinin isimlerini içeren bir dizi döndürür
  • get_include_path — include_path yönergesinin değerini döndürür
  • get_included_files — Betiğe dahil edilen dosyaların isimlerini içeren bir dizi döndürür
  • get_loaded_extensions — Derlenmiş ve yüklenmiş tüm modüllerin isimlerini içeren bir dizi döndürür
  • get_magic_quotes_gpc — magic_quotes_gpc yönergesinin değerini döndürür
  • get_magic_quotes_runtime — magic_quotes_runtime yönergesinin çalışma anı değerini döndürür
  • get_required_files — get_included_files işlevinin takma adıdır
  • get_resources — Returns active resources
  • getenv — Bir ortam değişkeninin değerini döndürür
  • getlastmod — Geçerli sayfanın son değişiklik zamanını döndürür
  • getmygid — PHP betiğinin sahibinin grup kimliğini döndürür
  • getmyinode — Çalışan betiğin dosya düğümü numarasını döndürür
  • getmypid — PHP'nin süreç kimliğini (PID) döndürür
  • getmyuid — PHP betiğinin sahibinin kullanıcı kimliğini döndürür
  • getopt — Komut satırı değiştirgeleri listesinden seçenekleri döndürür
  • getrusage — Geçerli özkaynak kullanımlarını döndürür
  • ini_alter — ini_set işlevinin takma adıdır
  • ini_get_all — Tüm yapılandırma yönergelerini döndürür
  • ini_get — Bir yapılandırma yönergesinin değerini döndürür
  • ini_restore — Bir yapılandırma yönergesine eski değerini atar
  • ini_set — Bir yapılandırma yönergesine değer atar
  • magic_quotes_runtime — Takma Adı: set_magic_quotes_runtime
  • main — Böyle bir işlev yoktur
  • memory_get_peak_usage — PHP'ye ayrılan belleğin azami miktarını döndürür
  • memory_get_usage — PHP'ye ayrılan belleğin miktarını döndürür
  • php_ini_loaded_file — Yüklü php.ini dosyasının dosya yolunu döndürür
  • php_ini_scanned_files — Ek ini dizininden ayrıştırılan dosyaların listesi ile döner
  • php_logo_guid — PHP logo kimliğini döndürür
  • php_sapi_name — HTTP sunucusu ile PHP arasındaki arayüzün türünü döndürür
  • php_uname — PHP'nin çalıştığı işletim sistemi hakkında bilgi döndürür
  • phpcredits — PHP'ya katkıda bulunanları gösterir
  • phpinfo — PHP'nin o anki durumu hakkında büyük miktarda bilgi çıktılar
  • phpversion — Çalışan PHP'nin sürümünü döndürür
  • putenv — Bir ortam değişkenine değer atar
  • restore_include_path — include_path yönergesini eski değerine ayarlar
  • set_include_path — include_path yönergesinin çalışma anı değerini belirler
  • set_magic_quotes_runtime — magic_quotes_runtime yönergesinin çalışma anı değerini belirler
  • set_time_limit — Azami çalıştırma süresini sınırlar
  • sys_get_temp_dir — Geçici dosyalar için kullanılan dizini döndürür
  • version_compare — PHP standardına uygun hale getirilmiş iki sürüm numarası dizgesini karşılaştırır
  • zend_logo_guid — Zend logo kimliğini döndürür
  • zend_thread_id — Geçerli evre için eşsiz bir betimleyici döndürür
  • zend_version — Zend motorunun sürümünü döndürür
Öntanımlı Sabitler
assert_options
PHP Seçenek ve Bilgileri


Çeşitli kararlılık denetim seçeneklerini açar/kapar

PHP Seçenek/Bilgi İşlevleri
assert
PHP Seçenek/Bilgi İşlevleri
PHP Manual

assert_options

(PHP 4, PHP 5, PHP 7)

assert_options — Çeşitli kararlılık denetim seçeneklerini açar/kapar

Açıklama

mixed assert_options ( int $seçenek [, mixed $değer ] )

assert() işlevi için çeşitli denetim seçeneklerini tanımlar veya mevcut değerlerini sorgular.

Değiştirgeler

seçenek

Sav Seçenekleri
Seçenek | INI değiştirgesi | Öntanımlı | Açıklama
ASSERT_ACTIVE | assert.active | 1 | assert() değerlendirmesi etkin kılınır.
ASSERT_WARNING | assert.warning | 1 | Her başarısız sav için bir PHP uyarısı çıktılanır
ASSERT_BAIL | assert.bail | 0 | Savın başarısızlığı halinde çalışma durdurulur.
ASSERT_QUIET_EVAL | assert.quiet_eval | 0 | Sav ifadesinin değerlendirilmesi sırasında hata raporlama kapatılır.
ASSERT_CALLBACK | assert.callback | (NULL) | Savın başarısızlığı halinde çağrılacak geriçağırım işlevi.

değer

Seçenek için isteğe bağlı yeni değer.

Dönen Değerler

Hata oluşursa FALSE, aksi takdirde belirtilen seçeneğin özgün değeri döner.

Örnekler

Örnek 1 - assert_options() örneği

<?php
// Sav başarısızlıklarında çalışacak işlevimiz
function assert_failure()
{
  echo 'İddia geçersiz';
}

// Sınama işlevimiz
function test_assert($parameter)
{
  assert(is_bool($parameter));
}

// Sav seçeneklerini atayalım
assert_options(ASSERT_ACTIVE,   true);
assert_options(ASSERT_BAIL,     true);
assert_options(ASSERT_WARNING,  false);
assert_options(ASSERT_CALLBACK, 'assert_failure');

// Başarısız olmasını umarak bir sav ileri sürelim
test_assert(1);

// ASSERT_BAIL true olduğundan buraya asla gelinmez
echo 'Buraya gelinmemesi gerekir';
?>

Ayrıca Bakınız

  • assert() - Checks if assertion is FALSE

PHP Seçenek/Bilgi İşlevleri
assert
PHP Seçenek/Bilgi İşlevleri


Checks if assertion is FALSE

assert_options
cli_get_process_title
PHP Seçenek/Bilgi İşlevleri
PHP Manual

assert

(PHP 4, PHP 5, PHP 7)

assert — Checks if assertion is FALSE

Açıklama

PHP 5 and 7

bool assert ( mixed $assertion [, string $description ] )

PHP 7

bool assert ( mixed $assertion [, Throwable $exception ] )

assert() will check the given assertion and take appropriate action if its result is FALSE.

Traditional assertions (PHP 5 and 7)

If the assertion is given as a string it will be evaluated as PHP code by assert(). The advantages of a string assertion are less overhead when assertion checking is off and messages containing the assertion expression when an assertion fails. This means that if you pass a boolean condition as assertion this condition will not show up as parameter to the assertion function which you may have defined with the assert_options() function, the condition is converted to a string before calling that handler function, and the boolean FALSE is converted as the empty string.

Assertions should be used as a debugging feature only. You may use them for sanity-checks that test for conditions that should always be TRUE and that indicate some programming errors if not or to check for the presence of certain features like extension functions or certain system limits and features.

Assertions should not be used for normal runtime operations like input parameter checks. As a rule of thumb your code should always be able to work correctly if assertion checking is not activated.

The behavior of assert() may be configured by assert_options() or by .ini-settings described in that functions manual page.

The assert_options() function and/or ASSERT_CALLBACK configuration directive allow a callback function to be set to handle failed assertions.

assert() callbacks are particularly useful for building automated test suites because they allow you to easily capture the code passed to the assertion, along with information on where the assertion was made. While this information can be captured via other methods, using assertions makes it much faster and easier!

The callback function should accept three arguments. The first argument will contain the file the assertion failed in. The second argument will contain the line the assertion failed on and the third argument will contain the expression that failed (if any — literal values such as 1 or "two" will not be passed via this argument). Users of PHP 5.4.8 and later may also provide a fourth optional argument, which will contain the description given to assert(), if it was set.

Expectations (PHP 7 only)

assert() is a language construct in PHP 7, allowing for the definition of expectations: assertions that take effect in development and testing environments, but are optimised away to have zero cost in production.

While assert_options() can still be used to control behaviour as described above for backward compatibility reasons, PHP 7 only code should use the two new configuration directives to control the behaviour of assert() and not call assert_options().

PHP 7 configuration directives for assert()
Directive Default value Possible values
zend.assertions 1
  • 1: generate and execute code (development mode)
  • 0: generate code but jump around it at runtime
  • -1: do not generate code (production mode)
assert.exception 0
  • 1: throw when the assertion fails, either by throwing the object provided as the exception or by throwing a new AssertionError object if exception wasn't provided
  • 0: use or generate a Throwable as described above, but only generate a warning based on that object rather than throwing it (compatible with PHP 5 behaviour)

Değiştirgeler

assertion

The assertion. In PHP 5, this must be either a string to be evaluated or a boolean to be tested. In PHP 7, this may also be any expression that returns a value, which will be executed and the result used to indicate whether the assertion succeeded or failed.

description

An optional description that will be included in the failure message if the assertion fails.

exception

In PHP 7, the second parameter can be a Throwable object instead of a descriptive string, in which case this is the object that will be thrown if the assertion fails and the assert.exception configuration directive is enabled.

Dönen Değerler

FALSE if the assertion is false, TRUE otherwise.

Sürüm Bilgisi

Sürüm: | Açıklama
7.0.0 | assert() is now a language construct and not a function. assertion() can now be an expression. The second parameter is now interpreted either as an exception (if a Throwable object is given), or as the description supported from PHP 5.4.8 onwards.
5.4.8 | The description parameter was added. The description is also now provided to a callback function in ASSERT_CALLBACK mode as the fourth argument.

Örnekler

Traditional assertions (PHP 5 and 7)

Örnek 1 Handle a failed assertion with a custom handler

<?php
// Active assert and make it quiet
assert_options(ASSERT_ACTIVE, 1);
assert_options(ASSERT_WARNING, 0);
assert_options(ASSERT_QUIET_EVAL, 1);

// Create a handler function
function my_assert_handler($file, $line, $code)
{
    echo "<hr>Assertion Failed:
        File '$file'<br />
        Line '$line'<br />
        Code '$code'<br /><hr />";
}

// Set up the callback
assert_options(ASSERT_CALLBACK, 'my_assert_handler');

// Make an assertion that should fail
assert('mysql_query("")');
?>

Örnek 2 Using a custom handler to print a description

<?php
// Active assert and make it quiet
assert_options(ASSERT_ACTIVE, 1);
assert_options(ASSERT_WARNING, 0);
assert_options(ASSERT_QUIET_EVAL, 1);

// Create a handler function
function my_assert_handler($file, $line, $code, $desc = null)
{
    echo "Assertion failed at $file:$line: $code";
    if ($desc) {
        echo ": $desc";
    }
    echo "\n";
}

// Set up the callback
assert_options(ASSERT_CALLBACK, 'my_assert_handler');

// Make an assertion that should fail
assert('2 < 1');
assert('2 < 1', 'Two is less than one');
?>

Yukarıdaki örneğin çıktısı:

 Assertion failed at test.php:21: 2 < 1
 Assertion failed at test.php:22: 2 < 1: Two is less than one

Expectations (PHP 7 only)

Örnek 3 Expectations without a custom exception

<?php
assert(true == false);
echo 'Hi!';
?>

With zend.assertions set to 0, the above example will output:

Hi!

With zend.assertions set to 1 and assert.exception set to 0, the above example will output:

Warning: assert(): assert(true == false) failed in - on line 2
Hi!

With zend.assertions set to 1 and assert.exception set to 1, the above example will output:

Fatal error: Uncaught AssertionError: assert(true == false) in -:2
Stack trace:
#0 -(2): assert(false, 'assert(true == ...')
#1 {main}
  thrown in - on line 2

Örnek 4 Expectations with a custom exception

<?php
class CustomError extends AssertionError {}

assert(true == false, new CustomError('True is not false!'));
echo 'Hi!';
?>

With zend.assertions set to 0, the above example will output:

Hi!

With zend.assertions set to 1 and assert.exception set to 0, the above example will output:

Warning: assert(): CustomError: True is not false! in -:4
Stack trace:
#0 {main} failed in - on line 4
Hi!

With zend.assertions set to 1 and assert.exception set to 1, the above example will output:

Fatal error: Uncaught CustomError: True is not false! in -:4
Stack trace:
#0 {main}
  thrown in - on line 4

Ayrıca Bakınız

  • assert_options() - Çeşitli kararlılık denetim seçeneklerini açar/kapar

assert_options
cli_get_process_title
PHP Seçenek/Bilgi İşlevleri


Returns the current process title

assert
cli_set_process_title
PHP Seçenek/Bilgi İşlevleri
PHP Manual

cli_get_process_title

(PHP 5 >= 5.5.0, PHP 7)

cli_get_process_title — Returns the current process title

Açıklama

string cli_get_process_title ( void )

Returns the current process title, as set by cli_set_process_title(). Note that this may not exactly match what is shown in ps or top, depending on your operating system.

This function is available only in CLI mode.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Return a string with the current process title or NULL on error.

Hatalar/İstisnalar

An E_WARNING will be generated if the operating system is unsupported.

Örnekler

Örnek 1 cli_get_process_title() example

<?php
echo "Process title: " . cli_get_process_title() . "\n";
?>

Ayrıca Bakınız

  • cli_set_process_title() - Sets the process title

assert
cli_set_process_title
PHP Seçenek/Bilgi İşlevleri


Sets the process title

cli_get_process_title
dl
PHP Seçenek/Bilgi İşlevleri
PHP Manual

cli_set_process_title

(PHP 5 >= 5.5.0, PHP 7)

cli_set_process_title — Sets the process title

Açıklama

bool cli_set_process_title ( string $title )

Sets the process title visible in tools such as top and ps. This function is available only in CLI mode.

Değiştirgeler

title

The new title.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

An E_WARNING will be generated if the operating system is unsupported.

Örnekler

Örnek 1 cli_set_process_title() example

<?php
$title = "My Amazing PHP Script";
$pid = getmypid(); // you can use this to see your process title in ps

if (!cli_set_process_title($title)) {
    echo "Unable to set process title for PID $pid...\n";
    exit(1);
} else {
    echo "The process title '$title' for PID $pid has been set for your process!\n";
    sleep(5);
}
?>

Ayrıca Bakınız

  • cli_get_process_title() - Returns the current process title
  • setproctitle() - Set the process title

cli_get_process_title
dl
PHP Seçenek/Bilgi İşlevleri


Belirtilen PHP eklentisini çalışma anında yükler

cli_set_process_title
extension_loaded
PHP Seçenek/Bilgi İşlevleri
PHP Manual

dl

(PHP 4, PHP 5, PHP 7)

dl — Belirtilen PHP eklentisini çalışma anında yükler

Açıklama

int dl ( string $kütüphane )

Kütüphane dosyası kütüphane değiştirgesi ile belirtilen PHP eklentisini yükler.

Belli bir eklentinin yüklü olup olmadığını sınamak için, hem yerleşik (php.ini ile yüklenen) hem de devingen olarak (dl() ile) yüklenen eklentileri bulan extension_loaded() işlevini kullanın.

Uyarı

Bu işlevin kullanımı PHP 5.3.0'dan beri ÖNERİLMEMEKTEDİR ve PHP 6.0.0'da tamamen KALDIRILMIŞTIR. Bu işleve kesinlikle güvenmemelisiniz.

Değiştirgeler

eklenti

Bu değiştirge ile eklentinin platforma özgü kütüphane dosyasının ismi belirtilir. Örneğin sockets eklentisini Windows platformunda yüklemek için php_sockets.dll ismini kullanmak gerekirken Unix platformlarında sockets.so kullanmak gerekir (bir paylaşımlı modül olarak derlenmişse).

Eklentinin yükleneceği dizin platforma göre değişiklik gösterir:

Windows - php.ini içinde açıkça belirtilmemişse, eklenti öntanımlı olarak c:\php4\extensions\ dizininden yüklenir.

Unix - php.ini içinde açıkça belirtilmemişse, öntanımlı eklenti dizinin yeri şunlara bağlıdır:

  • PHP'nin --enable-debug seçeneği ile derlenip derlenmediği;
  • PHP'nin (deneysel) ZTS (Zend Thread Safety) desteği ile derlenip derlenmediği;
  • geçerli yerleşik ZEND_MODULE_API_NO sabiti (Zend yerleşik modülü API numarası; genelde API modülünün değişiklik tarihidir. 20010901 gibi).
Bu durumlar hesaba katılarak eklentilerin öntanımlı yeri şöyle saptanır: <kurulum-dizini>/lib/php/extensions/ <debug/no-debug>-<zts/non-zts>-ZEND_MODULE_API_NO. Örnek: /usr/local/php/lib/php/extensions/debug-non-zts-20010901 veya /usr/local/php/lib/php/extensions/no-debug-zts-20010901.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. Eğer modül yükleme işlevsel değilse (enable_dl ile iptal edilmiş veya php.ini içinde safe_mode etkin kılınmışsa) bir E_ERROR iletisi çıktılanıp çalışma durdurulur. Eğer işlev, kütüphane yüklenemediğinden dolayı başarısız olursa bir E_WARNING iletisi çıktılayarak FALSEdöndürür.

Örnekler

Örnek 1 - dl() örnekleri

<?php
// Platforma göre eklenti yüklemek
if (!extension_loaded('sqlite')) {
    if (strtoupper(substr(PHP_OS, 0, 3)) === 'WIN') {
        dl('php_sqlite.dll');
    } else {
        dl('sqlite.so');
    }
}

// PHP 4.3.0 ve sonrası için PHP_SHLIB_SUFFIX sabiti de kullanılabilir
if (!extension_loaded('sqlite')) {
    $prefix = (PHP_SHLIB_SUFFIX === 'dll') ? 'php_' : '';
    dl($prefix . 'sqlite.' . PHP_SHLIB_SUFFIX);
}
?>

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | Artık CLI, CGI ve Embed hariç tüm SAPI'lerde bir E_DEPRECATED üretiliyor.

Notlar

Bilginize:

dl() işlevi çok evreli HTTP sunucularında desteklenmez. Böyle bir ortamda çalışıyorsanız php.ini içinde extensions deyimini kullanın. Ancak, CGI ve CLI sürümleri bundan etkilenmez.

Bilginize:

PHP 5'ten beri, dl() işlevinin CLI dışında kullanımı önerilmemektidir. Yerine Eklenti Yükleme Yönergelerini kullanın.

Bilginize:

PHP 6'dan beri bu işlev CLI, CGI ve embed dışında kalan tüm SAPI'lerde kaldırılmıştır.

Bilginize:

dl() işlevinin değiştirgesi Unix platformlarında harf büyüklüğüne duyarlıdır.

Bilginize: Bu işlev, PHP güvenli kipte çalışırken iptal edilir.

Ayrıca Bakınız

  • Eklenti Yükleme Yönergeleri
  • extension_loaded() - Belirtilen eklenti yüklü mü diye bakar

cli_set_process_title
extension_loaded
PHP Seçenek/Bilgi İşlevleri


Belirtilen eklenti yüklü mü diye bakar

dl
gc_collect_cycles
PHP Seçenek/Bilgi İşlevleri
PHP Manual

extension_loaded

(PHP 4, PHP 5, PHP 7)

extension_loaded — Belirtilen eklenti yüklü mü diye bakar

Açıklama

bool extension_loaded ( string $eklenti )

Belirtilen eklenti yüklü mü diye bakar.

Değiştirgeler

eklenti

Eklentinin ismi.

Eklentilerin isimlerini phpinfo() işlevini kullanarak veya CGI / CLI sürümlerini kullanıyorsanız -m seçeneği ile listeleyebilirsiniz:

$ php -m
[PHP Modules]
xml
tokenizer
standard
sockets
session
posix
pcre
overload
mysql
mbstring
ctype

[Zend Modules]

Dönen Değerler

İsmi belirtilen eklenti yüklü ise TRUE, değilse FALSE döner.

Örnekler

Örnek 1 - extension_loaded() örneği

<?php
if (!extension_loaded('gd')) {
    if (!dl('gd.so')) {
        exit;
    }
}
?>

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.0 | extension_loaded() işlevi belli bir eklentinin varlığını sınamak için eklentinin dahili ismini kullanır. Çoğu eklentinin ismi küçük harflerle yazılmışsa da büyük harfler kullanılarak yazılmış olanları da vardır. Bu işlev, PHP 5 öncesinde eklenti isimleri bakımından harf büyüklüğüne duyarlı idi.

Ayrıca Bakınız

  • get_loaded_extensions() - Derlenmiş ve yüklenmiş tüm modüllerin isimlerini içeren bir dizi döndürür
  • get_extension_funcs() - Bir modülün işlevlerinin isimlerini içeren bir dizi döndürür
  • phpinfo() - PHP'nin o anki durumu hakkında büyük miktarda bilgi çıktılar
  • dl() - Belirtilen PHP eklentisini çalışma anında yükler

dl
gc_collect_cycles
PHP Seçenek/Bilgi İşlevleri


Çöp döngülerin toplanması için zorlar

extension_loaded
gc_disable
PHP Seçenek/Bilgi İşlevleri
PHP Manual

gc_collect_cycles

(PHP 5 >= 5.3.0, PHP 7)

gc_collect_cycles — Çöp döngülerin toplanması için zorlar

Açıklama

int gc_collect_cycles ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Çöp döngülerin toplanması için zorlar.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Toplanan çöp döngü sayısı ile döner.

extension_loaded
gc_disable
PHP Seçenek/Bilgi İşlevleri


Döngüsel gönderim toplayıcısını etkisiz kılar

gc_collect_cycles
gc_enable
PHP Seçenek/Bilgi İşlevleri
PHP Manual

gc_disable

(PHP 5 >= 5.3.0, PHP 7)

gc_disable — Döngüsel gönderim toplayıcısını etkisiz kılar

Açıklama

void gc_disable ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Döngüsel gönderim toplayıcısını etkisiz kılar.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

gc_collect_cycles
gc_enable
PHP Seçenek/Bilgi İşlevleri


Döngüsel gönderim toplayıcısını etkin kılar

gc_disable
gc_enabled
PHP Seçenek/Bilgi İşlevleri
PHP Manual

gc_enable

(PHP 5 >= 5.3.0, PHP 7)

gc_enable — Döngüsel gönderim toplayıcısını etkin kılar

Açıklama

void gc_enable ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Döngüsel gönderim toplayıcısını etkin kılar.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

gc_disable
gc_enabled
PHP Seçenek/Bilgi İşlevleri


Döngüsel gönderim toplayıcısının durumunu döndürür

gc_enable
gc_mem_caches
PHP Seçenek/Bilgi İşlevleri
PHP Manual

gc_enabled

(PHP 5 >= 5.3.0, PHP 7)

gc_enabled — Döngüsel gönderim toplayıcısının durumunu döndürür

Açıklama

bool gc_enabled ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Döngüsel gönderim toplayıcısının (çöp toplayıcı) durumunu döndürür.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Çöp toplayıcı etkinse TRUE değilse FALSE döner.

gc_enable
gc_mem_caches
PHP Seçenek/Bilgi İşlevleri


Reclaims memory used by the Zend Engine memory manager

gc_enabled
get_cfg_var
PHP Seçenek/Bilgi İşlevleri
PHP Manual

gc_mem_caches

(PHP 7)

gc_mem_caches — Reclaims memory used by the Zend Engine memory manager

Açıklama

int gc_mem_caches ( void )

Reclaims memory used by the Zend Engine memory manager.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the number of bytes freed.

Ayrıca Bakınız

  • Garbage Collection

gc_enabled
get_cfg_var
PHP Seçenek/Bilgi İşlevleri


Belirtilen PHP yönergesinin değerini döndürür

gc_mem_caches
get_current_user
PHP Seçenek/Bilgi İşlevleri
PHP Manual

get_cfg_var

(PHP 4, PHP 5, PHP 7)

get_cfg_var — Belirtilen PHP yönergesinin değerini döndürür

Açıklama

string get_cfg_var ( string $yönerge )

Belirtilen PHP yapılandırma yönergesininin değerini döndürür.

Bu işlev, PHP yapılandırılırken kullanılan yapılandırma seçeneklerini döndürmediği gibi Apache yapılandırma dosyasını da okumaz.

Sistemin bir yapılandırma dosyası kullanıp kullanmadığını cfg_file_path yönergesinin değerine bakarak öğrenebilirsiniz. Bir değer atanmışsa yapılandırma dosyası kullanılıyordur.

Değiştirgeler

yönerge

Yapılandırma yönergesinin ismi.

Dönen Değerler

Bir hata oluşursa FALSE, aksi takdirde belirtilen PHP yapılandırma yönergesinin değerini döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | Dizi değerli yapılandırma yönergelerinin değerlerinin döndürülmesi sağlandı.

Ayrıca Bakınız

  • ini_get() - Bir yapılandırma yönergesinin değerini döndürür
  • ini_get_all() - Tüm yapılandırma yönergelerini döndürür

gc_mem_caches
get_current_user
PHP Seçenek/Bilgi İşlevleri


PHP betiğinin sahibininin kullanıcı ismini döndürür

get_cfg_var
get_defined_constants
PHP Seçenek/Bilgi İşlevleri
PHP Manual

get_current_user

(PHP 4, PHP 5, PHP 7)

get_current_user — PHP betiğinin sahibininin kullanıcı ismini döndürür

Açıklama

string get_current_user ( void )

Betik sahibininin kullanıcı ismini döndürür.

Dönen Değerler

Kullanıcı ismi bir dizge olarak döner.

Örnekler

Örnek 1 - get_current_user() örneği

<?php
echo 'Betiğin sahibi: ' . get_current_user();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Betiğin sahibi: SYSTEM

Ayrıca Bakınız

  • getmyuid() - PHP betiğinin sahibinin kullanıcı kimliğini döndürür
  • getmygid() - PHP betiğinin sahibinin grup kimliğini döndürür
  • getmypid() - PHP'nin süreç kimliğini (PID) döndürür
  • getmyinode() - Çalışan betiğin dosya düğümü numarasını döndürür
  • getlastmod() - Geçerli sayfanın son değişiklik zamanını döndürür

get_cfg_var
get_defined_constants
PHP Seçenek/Bilgi İşlevleri


Tüm sabitlerin isimlerini ve değerlerini içeren bir ilişkisel dizi döndürür

get_current_user
get_extension_funcs
PHP Seçenek/Bilgi İşlevleri
PHP Manual

get_defined_constants

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

get_defined_constants — Tüm sabitlerin isimlerini ve değerlerini içeren bir ilişkisel dizi döndürür

Açıklama

array get_defined_constants ([ bool $sınıfla ] )

Tanımlı olan tüm sabitlerin isimlerini ve değerlerini içeren bir ilişkisel dizi döndürür. Eklentilerce oluşturulanların yanında define() işleviyle tanımlananları da döndürür.

Değiştirgeler

sınıfla

TRUE belirtildiği takdirde, dizinin içerdiği sabitler dizinin ilk anahtarlarının altında sınıflandırılırlar.

<?php
define("SABİT", 1);
print_r(get_defined_constants(true));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [internal] => Array
        (
            [E_ERROR] => 1
            [E_WARNING] => 2
            [E_PARSE] => 4
            [E_NOTICE] => 8
            [E_CORE_ERROR] => 16
            [E_CORE_WARNING] => 32
            [E_COMPILE_ERROR] => 64
            [E_COMPILE_WARNING] => 128
            [E_USER_ERROR] => 256
            [E_USER_WARNING] => 512
            [E_USER_NOTICE] => 1024
            [E_ALL] => 2047
            [TRUE] => 1
        )

    [pcre] => Array
        (
            [PREG_PATTERN_ORDER] => 1
            [PREG_SET_ORDER] => 2
            [PREG_OFFSET_CAPTURE] => 256
            [PREG_SPLIT_NO_EMPTY] => 1
            [PREG_SPLIT_DELIM_CAPTURE] => 2
            [PREG_SPLIT_OFFSET_CAPTURE] => 4
            [PREG_GREP_INVERT] => 1
        )

    [user] => Array
        (
            [SABİT] => 1
        )

)

Dönen Değerler

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.0 | sınıfla değiştirgesi eklendi.

Örnekler

Örnek 1 - get_defined_constants() örneği

<?php
print_r(get_defined_constants());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [E_ERROR] => 1
    [E_WARNING] => 2
    [E_PARSE] => 4
    [E_NOTICE] => 8
    [E_CORE_ERROR] => 16
    [E_CORE_WARNING] => 32
    [E_COMPILE_ERROR] => 64
    [E_COMPILE_WARNING] => 128
    [E_USER_ERROR] => 256
    [E_USER_WARNING] => 512
    [E_USER_NOTICE] => 1024
    [E_ALL] => 2047
    [TRUE] => 1
)

Ayrıca Bakınız

  • defined() - Belirtilen isimli sabit tanımlı mı diye bakar
  • get_loaded_extensions() - Derlenmiş ve yüklenmiş tüm modüllerin isimlerini içeren bir dizi döndürür
  • get_defined_functions() - Tanımlanmış bütün işlevleri içeren bir dizi döndürür
  • get_defined_vars() - Tüm tanımlı değişkenleri içeren bir dizi döndürür

get_current_user
get_extension_funcs
PHP Seçenek/Bilgi İşlevleri


Bir modülün işlevlerinin isimlerini içeren bir dizi döndürür

get_defined_constants
get_include_path
PHP Seçenek/Bilgi İşlevleri
PHP Manual

get_extension_funcs

(PHP 4, PHP 5, PHP 7)

get_extension_funcs — Bir modülün işlevlerinin isimlerini içeren bir dizi döndürür

Açıklama

array get_extension_funcs ( string $modül_ismi )

modül_ismi ile belirtilen modülde tanımlı tüm işlevlerin isimlerini bir dizi içinde döndürür.

Değiştirgeler

modül_ismi

Modülün ismi.

Bilginize:

Bu değiştirge küçük harflerle yazılmalıdır.

Dönen Değerler

modül_ismi geçerli bir eklenti ismi değilse FALSE, aksi takdirde tüm işlev isimlerini içeren bir dizi döner.

Örnekler

Örnek 1 - XML işlevlerinin listesi

<?php
print_r(get_extension_funcs("xml"));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [0] => xml_parser_create
    [1] => xml_parser_create_ns
    [2] => xml_set_object
    [3] => xml_set_element_handler
    [4] => xml_set_character_data_handler
    [5] => xml_set_processing_instruction_handler
    [6] => xml_set_default_handler
    [7] => xml_set_unparsed_entity_decl_handler
    [8] => xml_set_notation_decl_handler
    [9] => xml_set_external_entity_ref_handler
    [10] => xml_set_start_namespace_decl_handler
    [11] => xml_set_end_namespace_decl_handler
    [12] => xml_parse
    [13] => xml_parse_into_struct
    [14] => xml_get_error_code
    [15] => xml_error_string
    [16] => xml_get_current_line_number
    [17] => xml_get_current_column_number
    [18] => xml_get_current_byte_index
    [19] => xml_parser_free
    [20] => xml_parser_set_option
    [21] => xml_parser_get_option
    [22] => utf8_encode
    [23] => utf8_decode
)

Ayrıca Bakınız

  • get_loaded_extensions() - Derlenmiş ve yüklenmiş tüm modüllerin isimlerini içeren bir dizi döndürür

get_defined_constants
get_include_path
PHP Seçenek/Bilgi İşlevleri


include_path yönergesinin değerini döndürür

get_extension_funcs
get_included_files
PHP Seçenek/Bilgi İşlevleri
PHP Manual

get_include_path

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

get_include_path — include_path yönergesinin değerini döndürür

Açıklama

string get_include_path ( void )

include_path yönergesinin değerini döndürür.

Dönen Değerler

Dosya arama yolları bir dizge olarak döner.

Örnekler

Örnek 1 - get_include_path() örneği

<?php
// PHP 4.3.0 ve sonrasında çalışır
echo get_include_path();

// Tüm PHP sürümlerinde çalışır
echo ini_get('include_path');
?>

Ayrıca Bakınız

  • ini_get() - Bir yapılandırma yönergesinin değerini döndürür
  • restore_include_path() - include_path yönergesini eski değerine ayarlar
  • set_include_path() - include_path yönergesinin çalışma anı değerini belirler
  • include - include

get_extension_funcs
get_included_files
PHP Seçenek/Bilgi İşlevleri


Betiğe dahil edilen dosyaların isimlerini içeren bir dizi döndürür

get_include_path
get_loaded_extensions
PHP Seçenek/Bilgi İşlevleri
PHP Manual

get_included_files

(PHP 4, PHP 5, PHP 7)

get_included_files — Betiğe dahil edilen dosyaların isimlerini içeren bir dizi döndürür

Açıklama

array get_included_files ( void )

include, include_once, require veya require_once kullanarak betiğe dahil edilen tüm dosyaların isimlerini döndürür.

Dönen Değerler

Betiğe dahil edilen dosyaların isimlerini içeren bir dizi döndürür.

Betiğin kendisi de içerilmiş bir dosya olarak ele alınır ve ismi dönen diziye dahil edilir.

Betiğe birden fazla dahil edilen dosyaların isimleri dönen dizi içinde bir kere zikredilir.

Sürüm Bilgisi

Sürüm: | Açıklama
4.0.1 | PHP 4.0.1 ve öncesinde, bu işlev betiğe dahil edilen dosyaların .php uzantısına sahip olduklarını varsayar, diğer dosyaların isimlerini döndürmezdi. get_included_files() tarafından döndürülen ilişkisel dizi sadece include ve include_once kullanılarak betiğe dahil edilen dosyaların isimlerini döndürürdü.

Örnekler

Örnek 1 - get_included_files() örneği

<?php
// Dosyanın kendi ismi: abc.php

include 'test1.php';
include_once 'test2.php';
require 'test3.php';
require_once 'test4.php';

$included_files = get_included_files();

foreach ($included_files as $filename) {
    echo "$filename\n";
}

?>

Yukarıdaki örneğin çıktısı:

abc.php
test1.php
test2.php
test3.php
test4.php

Notlar

Bilginize:

auto_prepend_file yönergesinde belirtilerek dahil edilen dosyaların isimleri dönen dizide bulunmaz.

Ayrıca Bakınız

  • include - include
  • include_once - include_once
  • require - require
  • require_once - require_once
  • get_required_files() - get_included_files işlevinin takma adıdır

get_include_path
get_loaded_extensions
PHP Seçenek/Bilgi İşlevleri


Derlenmiş ve yüklenmiş tüm modüllerin isimlerini içeren bir dizi döndürür

get_included_files
get_magic_quotes_gpc
PHP Seçenek/Bilgi İşlevleri
PHP Manual

get_loaded_extensions

(PHP 4, PHP 5, PHP 7)

get_loaded_extensions — Derlenmiş ve yüklenmiş tüm modüllerin isimlerini içeren bir dizi döndürür

Açıklama

array get_loaded_extensions ([ bool $zend_eklentileri = false ] )

PHP yorumlayıcı içinde derlenmiş ve yüklenmiş tüm modüllerin isimlerini içeren bir dizi döndürür.

Değiştirgeler

zend_eklentileri

Öntanımlı değeri FALSE olup, bu durumda Zend eklentilerini listelemez.

Dönen Değerler

Tüm modül isimlerini içeren indisli bir dizi ile döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.2.4 | Seçimlik zend_eklentileri değiştirgesi eklendi.

Örnekler

Örnek 1 - get_loaded_extensions() örneği

<?php
print_r(get_loaded_extensions());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
   [0] => xml
   [1] => wddx
   [2] => standard
   [3] => session
   [4] => posix
   [5] => pgsql
   [6] => pcre
   [7] => gd
   [8] => ftp
   [9] => db
   [10] => calendar
   [11] => bcmath
)

Ayrıca Bakınız

  • get_extension_funcs() - Bir modülün işlevlerinin isimlerini içeren bir dizi döndürür
  • extension_loaded() - Belirtilen eklenti yüklü mü diye bakar
  • dl() - Belirtilen PHP eklentisini çalışma anında yükler
  • phpinfo() - PHP'nin o anki durumu hakkında büyük miktarda bilgi çıktılar

get_included_files
get_magic_quotes_gpc
PHP Seçenek/Bilgi İşlevleri


magic_quotes_gpc yönergesinin değerini döndürür

get_loaded_extensions
get_magic_quotes_runtime
PHP Seçenek/Bilgi İşlevleri
PHP Manual

get_magic_quotes_gpc

(PHP 4, PHP 5, PHP 7)

get_magic_quotes_gpc — magic_quotes_gpc yönergesinin değerini döndürür

Açıklama

int get_magic_quotes_gpc ( void )

magic_quotes_gpc yönergesinin değerini döndürür.

magic_quotes_gpc yönergesine çalışma anında değer atanamadığını unutmayın.

Sihirli tırnaklar hakkında daha ayrıntılı bilgi edinmek için güvenlik bölümüne bakınız.

Dönen Değerler

magic_quotes_gpc yönergesinin değeri "off" ise 0, "on" ise 1 döner.

Örnekler

Örnek 1 - get_magic_quotes_gpc() örneği

<?php
echo get_magic_quotes_gpc();         // 1
echo $_POST['lastname'];             // O\'reilly
echo addslashes($_POST['lastname']); // O\\\'reilly

if (!get_magic_quotes_gpc()) {
    $lastname = addslashes($_POST['lastname']);
} else {
    $lastname = $_POST['lastname'];
}

echo $lastname; // O\'reilly
$sql = "INSERT INTO lastnames (lastname) VALUES ('$lastname')";
?>

Notlar

Bilginize:

Eğer magic_quotes_sybase yönergesinin değeri ON ise magic_quotes_gpc geçersiz olacaktır. Bu bakımdan, get_magic_quotes_gpc() TRUE döndürse bile ne çift tırnaklar ne tersbölüler ne de NULL değerler öncelenecektir. Bu durumda bunlar '' olarak görünecektir.

Ayrıca Bakınız

  • addslashes() - Özel karakterlerin önüne tersbölü yerleştirir
  • stripslashes() - Bir dizgeden tersbölüleri ayıklar
  • get_magic_quotes_runtime() - magic_quotes_runtime yönergesinin çalışma anı değerini döndürür
  • ini_get() - Bir yapılandırma yönergesinin değerini döndürür

get_loaded_extensions
get_magic_quotes_runtime
PHP Seçenek/Bilgi İşlevleri


magic_quotes_runtime yönergesinin çalışma anı değerini döndürür

get_magic_quotes_gpc
get_required_files
PHP Seçenek/Bilgi İşlevleri
PHP Manual

get_magic_quotes_runtime

(PHP 4, PHP 5, PHP 7)

get_magic_quotes_runtime — magic_quotes_runtime yönergesinin çalışma anı değerini döndürür

Açıklama

int get_magic_quotes_runtime ( void )

magic_quotes_runtime yönergesinin çalışma anı değerini döndürür.

Dönen Değerler

Sihirli tırnaklar çalışma anında etkinse 1 değilse 0 döndürür.

Örnekler

Örnek 1 - get_magic_quotes_runtime() örneği

<?php
// magic_quotes_runtime etkinse kapatalım
if(get_magic_quotes_runtime())
{
  // Kapat
  set_magic_quotes_runtime(false);
}
?>

Ayrıca Bakınız

  • get_magic_quotes_gpc() - magic_quotes_gpc yönergesinin değerini döndürür
  • set_magic_quotes_runtime() - magic_quotes_runtime yönergesinin çalışma anı değerini belirler

get_magic_quotes_gpc
get_required_files
PHP Seçenek/Bilgi İşlevleri


get_included_files işlevinin takma adıdır

get_magic_quotes_runtime
get_resources
PHP Seçenek/Bilgi İşlevleri
PHP Manual

get_required_files

(PHP 4, PHP 5, PHP 7)

get_required_files — get_included_files() işlevinin takma adıdır

Açıklama

Bu işlev get_included_files() işlevinin takma adıdır.

get_magic_quotes_runtime
get_resources
PHP Seçenek/Bilgi İşlevleri


Returns active resources

get_required_files
getenv
PHP Seçenek/Bilgi İşlevleri
PHP Manual

get_resources

(PHP 7)

get_resources — Returns active resources

Açıklama

array get_resources ([ string $type ] )

Returns an array of all currently active resources, optionally filtered by resource type.

Değiştirgeler

type

If defined, this will cause get_resources() to only return resources of the given type. A list of resource types is available.

If the string Unknown is provided as the type, then only resources that are of an unknown type will be returned.

If omitted, all resources will be returned.

Dönen Değerler

Returns an array of currently active resources, indexed by resource number.

Örnekler

Örnek 1 Unfiltered get_resources()

<?php
$fp = tmpfile();
var_dump(get_resources());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(1) {
  [1]=>
  resource(1) of type (stream)
}

Örnek 2 Filtered get_resources()

<?php
$fp = tmpfile();
var_dump(get_resources('stream'));
var_dump(get_resources('curl'));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(1) {
  [1]=>
  resource(1) of type (stream)
}
array(0) {
}

Ayrıca Bakınız

  • get_loaded_extensions() - Derlenmiş ve yüklenmiş tüm modüllerin isimlerini içeren bir dizi döndürür
  • get_defined_constants() - Tüm sabitlerin isimlerini ve değerlerini içeren bir ilişkisel dizi döndürür
  • get_defined_functions() - Tanımlanmış bütün işlevleri içeren bir dizi döndürür
  • get_defined_vars() - Tüm tanımlı değişkenleri içeren bir dizi döndürür

get_required_files
getenv
PHP Seçenek/Bilgi İşlevleri


Bir ortam değişkeninin değerini döndürür

get_resources
getlastmod
PHP Seçenek/Bilgi İşlevleri
PHP Manual

getenv

(PHP 4, PHP 5, PHP 7)

getenv — Bir ortam değişkeninin değerini döndürür

Açıklama

string getenv ( string $değişken )

Belirtilen ortam değişkeninin değerini döndürür.

Tüm ortam değişkenlerini phpinfo() işlevini kullanarak bir liste halinde görebilirsiniz. Bunların pek çoğunun anlamlarını » RFC 3875 belgesinin özellikle 4.1 "Request Meta-Variables" bölümünde bulabilirsiniz.

Değiştirgeler

değişken

Ortam değişkeninin ismi.

Dönen Değerler

değişken diye bir ortam değişkeni yoksa FALSE aksi takdirde değişken ile belirtilen ortam değişkeninin değerini döndürür.

Örnekler

Örnek 1 - getenv() örneği

<?php
// getenv() kullanım örneği
$ip = getenv('REMOTE_ADDR');

//Veya basitçe bir süper küresel kullan ($_SERVER veya $_ENV)
$ip = $_SERVER['REMOTE_ADDR'];
?>

Ayrıca Bakınız

  • putenv() - Bir ortam değişkenine değer atar
  • apache_getenv() - Bir Apache ortam değişkeninin değerini döndürür
  • Süper Küreseller

get_resources
getlastmod
PHP Seçenek/Bilgi İşlevleri


Geçerli sayfanın son değişiklik zamanını döndürür

getenv
getmygid
PHP Seçenek/Bilgi İşlevleri
PHP Manual

getlastmod

(PHP 4, PHP 5, PHP 7)

getlastmod — Geçerli sayfanın son değişiklik zamanını döndürür

Açıklama

int getlastmod ( void )

Geçerli sayfanın son değişiklik zamanını döndürür.

Başka bir dosyanın değişiklik zamanıyla ilgileniyorsanız filemtime() işlevine bakın.

Dönen Değerler

Geçerli sayfanın son değişiklik zamanını date() işlevinde kullanılabilen bir Unix zaman damgası olarak döndürür. Hata oluşursa FALSE döner.

Örnekler

Örnek 1 - getlastmod() örneği

<?php
$fmt = datefmt_create("tr_TR", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL,'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN, "dd MMMM yyyy HH:mm:ss");
// Çıktısı: 'Son değişiklik: Son değişiklik: 13 Şubat 2009 14:10:09'
echo "Son değişiklik: " . datefmt_format ($fmt, getlastmod());
?>

Ayrıca Bakınız

  • date() - Yerel tarihi/saati biçimlendirir
  • getmyuid() - PHP betiğinin sahibinin kullanıcı kimliğini döndürür
  • getmygid() - PHP betiğinin sahibinin grup kimliğini döndürür
  • get_current_user() - PHP betiğinin sahibininin kullanıcı ismini döndürür
  • getmyinode() - Çalışan betiğin dosya düğümü numarasını döndürür
  • getmypid() - PHP'nin süreç kimliğini (PID) döndürür
  • filemtime() - Dosyanın değişiklik zamanını döndürür

getenv
getmygid
PHP Seçenek/Bilgi İşlevleri


PHP betiğinin sahibinin grup kimliğini döndürür

getlastmod
getmyinode
PHP Seçenek/Bilgi İşlevleri
PHP Manual

getmygid

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

getmygid — PHP betiğinin sahibinin grup kimliğini döndürür

Açıklama

int getmygid ( void )

Betik sahibinin grup kimliğini döndürür.

Dönen Değerler

Hata oluşursa FALSE, aksi takdirde betik sahibinin grup kimliğini döndürür.

Ayrıca Bakınız

  • getmyuid() - PHP betiğinin sahibinin kullanıcı kimliğini döndürür
  • getmypid() - PHP'nin süreç kimliğini (PID) döndürür
  • get_current_user() - PHP betiğinin sahibininin kullanıcı ismini döndürür
  • getmyinode() - Çalışan betiğin dosya düğümü numarasını döndürür
  • getlastmod() - Geçerli sayfanın son değişiklik zamanını döndürür

getlastmod
getmyinode
PHP Seçenek/Bilgi İşlevleri


Çalışan betiğin dosya düğümü numarasını döndürür

getmygid
getmypid
PHP Seçenek/Bilgi İşlevleri
PHP Manual

getmyinode

(PHP 4, PHP 5, PHP 7)

getmyinode — Çalışan betiğin dosya düğümü numarasını döndürür

Açıklama

int getmyinode ( void )

Çalışan betiğin dosya düğümü numarasını döndürür.

Dönen Değerler

Hata oluşursa FALSE, aksi takdirde çalışan betiğin dosya düğümü numarasını bir tamsayı olarak döndürür.

Ayrıca Bakınız

  • getmygid() - PHP betiğinin sahibinin grup kimliğini döndürür
  • getmyuid() - PHP betiğinin sahibinin kullanıcı kimliğini döndürür
  • getmypid() - PHP'nin süreç kimliğini (PID) döndürür
  • get_current_user() - PHP betiğinin sahibininin kullanıcı ismini döndürür
  • getlastmod() - Geçerli sayfanın son değişiklik zamanını döndürür

getmygid
getmypid
PHP Seçenek/Bilgi İşlevleri


PHP'nin süreç kimliğini (PID) döndürür

getmyinode
getmyuid
PHP Seçenek/Bilgi İşlevleri
PHP Manual

getmypid

(PHP 4, PHP 5, PHP 7)

getmypid — PHP'nin süreç kimliğini (PID) döndürür

Açıklama

int getmypid ( void )

PHP'nin süreç kimliğini döndürür.

Dönen Değerler

Hata oluşursa FALSE, aksi takdirde PHP süreç kimliği döner.

Notlar

Uyarı

Süreç kimlikleri eşsiz değildir, bu bakımdan güvenlikle ilgili konularda güvenilir değildir.

Ayrıca Bakınız

  • getmygid() - PHP betiğinin sahibinin grup kimliğini döndürür
  • getmyuid() - PHP betiğinin sahibinin kullanıcı kimliğini döndürür
  • get_current_user() - PHP betiğinin sahibininin kullanıcı ismini döndürür
  • getmyinode() - Çalışan betiğin dosya düğümü numarasını döndürür
  • getlastmod() - Geçerli sayfanın son değişiklik zamanını döndürür

getmyinode
getmyuid
PHP Seçenek/Bilgi İşlevleri


PHP betiğinin sahibinin kullanıcı kimliğini döndürür

getmypid
getopt
PHP Seçenek/Bilgi İşlevleri
PHP Manual

getmyuid

(PHP 4, PHP 5, PHP 7)

getmyuid — PHP betiğinin sahibinin kullanıcı kimliğini döndürür

Açıklama

int getmyuid ( void )

Betik sahibinin kullanıcı kimliğini döndürür.

Dönen Değerler

Hata oluşursa FALSE, aksi takdirde betik sahibinin kullanıcı kimliğini döndürür.

Ayrıca Bakınız

  • getmygid() - PHP betiğinin sahibinin grup kimliğini döndürür
  • getmypid() - PHP'nin süreç kimliğini (PID) döndürür
  • get_current_user() - PHP betiğinin sahibininin kullanıcı ismini döndürür
  • getmyinode() - Çalışan betiğin dosya düğümü numarasını döndürür
  • getlastmod() - Geçerli sayfanın son değişiklik zamanını döndürür

getmypid
getopt
PHP Seçenek/Bilgi İşlevleri


Komut satırı değiştirgeleri listesinden seçenekleri döndürür

getmyuid
getrusage
PHP Seçenek/Bilgi İşlevleri
PHP Manual

getopt

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

getopt — Komut satırı değiştirgeleri listesinden seçenekleri döndürür

Açıklama

array getopt ( string $kısa_seçenekler [, array $uzun_seçenekler ] )

Betiğe aktarılan seçenekleri çözümler.

Değiştirgeler

kısa_seçenekler
Bir dizge olup, dizgenin her karakteri bir seçenek karakteri olarak kullanılır ve bu karakterlerle eşleşen seçenekler önlerine birer tire imi (-) konarak betik çalıştırılırken komut satırından belirtilebilir. Örneğin, "x" seçenek dizgesi -x seçeneğinin tanınmasını sağlar.
uzun_seçenekler
Bir dizi olup, dizinin her elemanı bir seçenek dizgesi olarak kullanılır ve bu dizgelerle eşleşen seçenekler önlerine birer çift tire imi (--) konarak betik çalıştırılırken komut satırından belirtilebilir. Örneğin, "opt" elemanı --opt seçeneğinin tanınmasını sağlar.

Bilginize: PHP 5.3.0 öncesinde bu değiştirge sadece bir kaç sistemde kullanılabiliyordu.

kısa_seçenekler değiştirgesi şu bileşenleri içerebilir:

  • Tek tek karakterler (değerler kabul edilmez)
  • Ardına tek bir iki nokta imi konmuş karakterler (değiştirgenin değer gerektirdiğini belirtir)
  • Ardına bir çift iki nokta imi konmuş karakterler (değiştirgenin isteğe bağlı değer kabul ettiğini belirtir)
Seçenek değerleri dizgeden sonraki ilk değiştirgedir. Bir değerin sonunda boşluk bulunup bulunmadığına bakılmaz.

Bilginize: İsteğe bağlı değerler bir ayraç olarak " " (boşluk) kabul etmezler.

Bilginize:

kısa_seçenekler ve uzun_seçenekler için biçem hemen hemen aynıdır. Tek fark, birincisinin bir dizge (her karakter bir seçenek) ikincisinin bir dizi (her eleman bir seçenek) almasıdır.

Dönen Değerler

Bu işlev başarısız olursa FALSE, aksi takdirde seçenek / değiştirge çiftlerini içeren bir dizi döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | Değiştirge/değer ayracı olarak "=" desteği eklendi.
5.3.0 | İsteğe bağlı değerler için destek eklendi ("::" ile belirtilir).
5.3.0 | İşlev sisteme bağlı olmaktan çıktı. Artık Windows üzerinde de çalışmaktadır.

Örnekler

Örnek 1 - getopt() örneği - 1

<?php
$options = getopt("f:hp:");
var_dump($options);
?>

Yukarıdaki betik php betik.php -fdeğer -h komut satırı için aşağıdaki çıktıyı üretir:

array(2) {
  ["f"]=>
  string(5) "değer"
  ["h"]=>
  bool(false)
}

Örnek 2 - getopt() örneği - 2

<?php
$kısalar  = "";
$kısalar .= "f:";  // Değer, zorunlu
$kısalar .= "v::"; // Değer, seçimlik
$kısalar .= "abc"; // Bunlar değer kabul etmez

$uzunlar  = array(
    "gerekli:",     // Değer, zorunlu
    "seçimlik::",   // Değer, seçimlik
    "seçenek",      // Değer kabul etmez
    "sçnk",         // Değer kabul etmez
);
$seçenekler = getopt($kısalar, $uzunlar);
var_dump($seçenekler);
?>

Yukarıdaki betik php betik.php -f "f değeri" -v -a --gerekli değer --seçimlik="seçimlik değer" --seçenek komut satırı için aşağıdaki çıktıyı üretir:

array(6) {
  ["f"]=>
  string(9) "f değeri"
  ["v"]=>
  bool(false)
  ["a"]=>
  bool(false)
  ["gerekli"]=>
  string(6) "değer"
  ["seçimlik"]=>
  string(16) "seçimlik değer"
  ["seçenek"]=>
  bool(false)
}

Örnek 3 - getopt() örneği - 3

Çok sayıda seçeneğin tek bir seçenek olarak verilmesi:

<?php
$options = getopt("abc");
var_dump($options);
?>

Yukarıdaki betik php betik.php -aaac komut satırı için aşağıdaki çıktıyı üretir:

array(2) {
  ["a"]=>
  array(3) {
    [0]=>
    bool(false)
    [1]=>
    bool(false)
    [2]=>
    bool(false)
  }
  ["c"]=>
  bool(false)
}

getmyuid
getrusage
PHP Seçenek/Bilgi İşlevleri


Geçerli özkaynak kullanımlarını döndürür

getopt
ini_alter
PHP Seçenek/Bilgi İşlevleri
PHP Manual

getrusage

(PHP 4, PHP 5, PHP 7)

getrusage — Geçerli özkaynak kullanımlarını döndürür

Açıklama

array getrusage ([ int $kim = 0 ] )

getrusage(2) için bir arayüz olup sistem çağırısından dönen veriyi döndürür.

Değiştirgeler

kim

1 belirtilirse işlev RUSAGE_CHILDREN ile çağrılır.

Dönen Değerler

Sistem çağrısından dönen veriyi içeren bir ilişkisel dizi döner. Tüm girdilere belgelenmiş alan isimleri kullanılarak erişilebilir.

Örnekler

Örnek 1 - getrusage() örneği

<?php
$dat = getrusage();
echo $dat["ru_nswap"];         // takas alanlarının sayısı
echo $dat["ru_majflt"];        // sayfa hatalarının sayısı
echo $dat["ru_utime.tv_sec"];  // kullanılan kullanıcı zamanı (saniye)
echo $dat["ru_utime.tv_usec"]; // kullanılan kullanıcı zamanı (mikrosaniye)
?>

Notlar

Bilginize: Bu işlev Windows sistemlerinde çalışmaz.

Ayrıca Bakınız

  • Sisteminizdeki getrusage(2) kılavuz sayfası

getopt
ini_alter
PHP Seçenek/Bilgi İşlevleri


ini_set işlevinin takma adıdır

getrusage
ini_get_all
PHP Seçenek/Bilgi İşlevleri
PHP Manual

ini_alter

(PHP 4, PHP 5, PHP 7)

ini_alter — ini_set() işlevinin takma adıdır

Açıklama

Bu işlev, ini_set() işlevinin takma adıdır.

getrusage
ini_get_all
PHP Seçenek/Bilgi İşlevleri


Tüm yapılandırma yönergelerini döndürür

ini_alter
ini_get
PHP Seçenek/Bilgi İşlevleri
PHP Manual

ini_get_all

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

ini_get_all — Tüm yapılandırma yönergelerini döndürür

Açıklama

array ini_get_all ([ string $eklenti [, bool $ayrıntılı = true ]] )

Kayıtlı yapılandırma seçeneklerinin hepsini değerleriyle döndürür.

Değiştirgeler

eklenti

İsteğe bağlı olarak bir eklenti ismi. Belirtildiği takdirde sadece bu eklentiye özgü yönergeler döndürülür.

ayrıntılı

Ya her ayarın geçerli değeri ya da her ayarın ayrıntılı değerleri döndürülür. Öntanımlı olan TRUE değeri ayrıntılı bir çıktı üretir.

Dönen Değerler

Yönerge isimlerinin dizinin anahtarları olduğu bir dizi döner.

ayrıntılı değiştirgesi TRUE (öntanımlı) olduğu takdirde dizinin her elemanı, anahtarları global_value (php.ini'de atanmış değer), local_value (ini_set() veya .htaccess üzerinden atanmış değer), ve access (erişim seviyesi) olan bir alt dizi içerir.

ayrıntılı değiştirgesi FALSE olduğu takdirde her elemanın değeri sadece yönergenin geçerli değerini içerecektir.

Bilginize:

Bir yönergenin, access anahtarı altında bir bit maskesi değeri olarak çok sayıda erişim seviyesine sahip olması mümkündür.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | ayrıntılı değiştirgesi eklendi.

Örnekler

Örnek 1 - ini_get_all() örnekleri

<?php
print_r(ini_get_all("pcre"));
print_r(ini_get_all());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [pcre.backtrack_limit] => Array
        (
            [global_value] => 100000
            [local_value] => 100000
            [access] => 7
        )

    [pcre.recursion_limit] => Array
        (
            [global_value] => 100000
            [local_value] => 100000
            [access] => 7
        )

)
Array
(
    [allow_call_time_pass_reference] => Array
        (
            [global_value] => 0
            [local_value] => 0
            [access] => 6
        )

    [allow_url_fopen] => Array
        (
            [global_value] => 1
            [local_value] => 1
            [access] => 4
        )

    ...

)

Örnek 2 - Ayrıntısız listeleme

<?php
print_r(ini_get_all("pcre", false)); // PHP 5.3.0'dan itibaren
print_r(ini_get_all(null, false));   // PHP 5.3.0'dan itibaren
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [pcre.backtrack_limit] => 100000
    [pcre.recursion_limit] => 100000
)
Array
(
    [allow_call_time_pass_reference] => 0
    [allow_url_fopen] => 1
    ...
)

Ayrıca Bakınız

  • Yapılandırma ayarlarının değiştirilmesi
  • ini_get() - Bir yapılandırma yönergesinin değerini döndürür
  • ini_restore() - Bir yapılandırma yönergesine eski değerini atar
  • ini_set() - Bir yapılandırma yönergesine değer atar
  • get_loaded_extensions() - Derlenmiş ve yüklenmiş tüm modüllerin isimlerini içeren bir dizi döndürür
  • phpinfo() - PHP'nin o anki durumu hakkında büyük miktarda bilgi çıktılar

ini_alter
ini_get
PHP Seçenek/Bilgi İşlevleri


Bir yapılandırma yönergesinin değerini döndürür

ini_get_all
ini_restore
PHP Seçenek/Bilgi İşlevleri
PHP Manual

ini_get

(PHP 4, PHP 5, PHP 7)

ini_get — Bir yapılandırma yönergesinin değerini döndürür

Açıklama

string ini_get ( string $yönerge )

Belirtilen yapılandırma yönergesinin değerini döndürür.

Değiştirgeler

yönerge

yapılandırma yönergesinin ismi.

Dönen Değerler

Başarısızlık durumunda ve NULL değerler için boş bir dizge, aksi takdirde yapılandırma yönergesinin değeri ile döner.

Örnekler

Örnek 1 - ini_get() örnekleri

<?php
/*
php.ini dosyamız şu ayarları içeriyor:

display_errors = On
register_globals = Off
post_max_size = 8M
*/

echo 'display_errors = ' . ini_get('display_errors') . "\n";
echo 'register_globals = ' . ini_get('register_globals') . "\n";
echo 'post_max_size = ' . ini_get('post_max_size') . "\n";
echo 'post_max_size+1 = ' . (ini_get('post_max_size')+1) . "\n";
echo 'post_max_size (bayt olarak) = ' . return_bytes(ini_get('post_max_size'));

function return_bytes($val) {
    $val = trim($val);
    $last = strtolower($val[strlen($val)-1]);
    switch($last) {
        // 'G' birimi PHP 5.1.0 sürümünden beri var.
        case 'g':
            $val *= 1024;
        case 'm':
            $val *= 1024;
        case 'k':
            $val *= 1024;
    }

    return $val;
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

display_errors = 1
register_globals = 0
post_max_size = 8M
post_max_size+1 = 9
post_max_size (bayt olarak) = 8388608

Notlar

Bilginize: Mantıksal değerleri sorgularken

Bir mantıksal ini değeri olarak off, boş bir dizge veya "0" olarak dönerken, on değeri "1" olarak dönecektir. Bu işlev ayrıca yönergenin değerini birebir dizge olarak da döndürebilir.

Bilginize: Bellek miktarı değerlerini sorgularken

upload_max_filesize yönergesinde olduğu gibi pek çok bellek miktarı değeri, php.ini dosyasında kısa gösterimleriyle saklanabilir. ini_get() işlevi, yönergenin değeri olarak değerin tamsayı karşılığını değil, php.ini dosyasında saklandığı haliyle dizge değerini döndürür. Bu bakımdan, bu değer üzerindeki aritmetik işlemler beklenen sonuçları vermeyebilir. Yukarıdaki örnekte, kısa gösterimi bayt cinsinden bir değere dönüştürmenin yolu gösterilmektedir.

Ayrıca Bakınız

  • get_cfg_var() - Belirtilen PHP yönergesinin değerini döndürür
  • ini_get_all() - Tüm yapılandırma yönergelerini döndürür
  • ini_restore() - Bir yapılandırma yönergesine eski değerini atar
  • ini_set() - Bir yapılandırma yönergesine değer atar

ini_get_all
ini_restore
PHP Seçenek/Bilgi İşlevleri


Bir yapılandırma yönergesine eski değerini atar

ini_get
ini_set
PHP Seçenek/Bilgi İşlevleri
PHP Manual

ini_restore

(PHP 4, PHP 5, PHP 7)

ini_restore — Bir yapılandırma yönergesine eski değerini atar

Açıklama

void ini_restore ( string $yönerge )

Belirtilen yapılandırma yönergesine eski değeri atanır.

Değiştirgeler

yönerge

Yönergenin ismi.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 - ini_restore() örneği

<?php
$setting = 'y2k_compliance';

echo '\'' . $setting . '\' yönergesinin şu anki değeri: ' . ini_get($setting), PHP_EOL;

ini_set($setting, ini_get($setting) ? 0 : 1);
echo '\'' . $setting . '\' yönergesinin yeni değeri: ' . ini_get($setting), PHP_EOL;

ini_restore($setting);
echo '\'' . $setting . '\' yönergesinin özgün değeri: ' . ini_get($setting), PHP_EOL;
?>

Yukarıdaki örneğin çıktısı:

'y2k_compliance' yönergesinin şu anki değeri: 1
'y2k_compliance' yönergesinin yeni değeri: 0
'y2k_compliance' yönergesinin özgün değeri: 1

Ayrıca Bakınız

  • ini_get() - Bir yapılandırma yönergesinin değerini döndürür
  • ini_get_all() - Tüm yapılandırma yönergelerini döndürür
  • ini_set() - Bir yapılandırma yönergesine değer atar

ini_get
ini_set
PHP Seçenek/Bilgi İşlevleri


Bir yapılandırma yönergesine değer atar

ini_restore
magic_quotes_runtime
PHP Seçenek/Bilgi İşlevleri
PHP Manual

ini_set

(PHP 4, PHP 5, PHP 7)

ini_set — Bir yapılandırma yönergesine değer atar

Açıklama

string ini_set ( string $yönerge , string $değer )

Belirtilen yapılandırma yönergesine belirtilen değeri atar. Bu ayarlama betiğinizin çalışma süresince geçerli kalır, betik sonlandığında eski değer geçerli olur.

Değiştirgeler

yönerge

ini_set() işlevi ile tüm yapılandırma yönergelerine değer atanamaz. Mevcut yapılandırma yönergelerinin listesini eklerde bulabilirsiniz.

değer

Yönergeye atanacak yeni değer.

Dönen Değerler

Atama işlemi başarılı olursa eski değer, aksi takdirde FALSE döner.

Örnekler

Örnek 1 - Bir INI yönergesine değer atamak

<?php
echo ini_get('display_errors');

if (!ini_get('display_errors')) {
    ini_set('display_errors', 1);
}

echo ini_get('display_errors');
?>

Ayrıca Bakınız

  • get_cfg_var() - Belirtilen PHP yönergesinin değerini döndürür
  • ini_get() - Bir yapılandırma yönergesinin değerini döndürür
  • ini_get_all() - Tüm yapılandırma yönergelerini döndürür
  • ini_restore() - Bir yapılandırma yönergesine eski değerini atar
  • Yapılandırma ayarlarının değiştirilmesi

ini_restore
magic_quotes_runtime
PHP Seçenek/Bilgi İşlevleri


Takma Adı: set_magic_quotes_runtime

ini_set
main
PHP Seçenek/Bilgi İşlevleri
PHP Manual

magic_quotes_runtime

(PHP 4, PHP 5)

magic_quotes_runtime — Takma Adı: set_magic_quotes_runtime()

Uyarı

Bu takma adın kullanımı PHP 5.3.0 itibariyle ÖNERİLMEMEKTE olup PHP 7.0.0'da tamamen KALDIRILMIŞTIR.

Açıklama

Bu işlev şu işlevin takma adıdır: set_magic_quotes_runtime()

ini_set
main
PHP Seçenek/Bilgi İşlevleri


Böyle bir işlev yoktur

magic_quotes_runtime
memory_get_peak_usage
PHP Seçenek/Bilgi İşlevleri
PHP Manual

main

main — Böyle bir işlev yoktur

Açıklama

PHP kaynak kodunun main() işlevinden başka main() işlevi yoktur. PHP 4.3.0 sürümünde PHP kaynak kodunda yeni bir hata eylemci türü (php_error_docref) devreye girdi. html_errors (öntanımlı olarak 'On') ve docref_root (PHP 4.3.2'ye kadar öntanımlı olarak 'On') yapılandırma yönergelerine 'On' atandığı takdirde, bu özellik, PHP hata iletilerinde bir kılavuz sayfasına atıfta bulunmayı sağlamaktadır.

Bazı hata iletilerinde, bu sayfanın mevcudiyet sebebi olarak, main() işlevi için bir kılavuz sayfasına atıf yapılır. Bir PHP işlevinde main() işlevi ile ilişkili olarak bir hata alırsanız lütfen bunun için » bir hata raporu oluşturun. Bu hata giderilecek ve gerektiği gibi belgelenecektir.

main() işlevine atıflı bilinen hatalar
İşlev ismi | Hatanın artık görülmediği sürüm
include | 5.1.0
include_once | 5.1.0
require | 5.1.0
require_once | 5.1.0

Ayrıca Bakınız

  • html_errors
  • display_errors

magic_quotes_runtime
memory_get_peak_usage
PHP Seçenek/Bilgi İşlevleri


PHP'ye ayrılan belleğin azami miktarını döndürür

main
memory_get_usage
PHP Seçenek/Bilgi İşlevleri
PHP Manual

memory_get_peak_usage

(PHP 5 >= 5.2.0, PHP 7)

memory_get_peak_usage — PHP'ye ayrılan belleğin azami miktarını döndürür

Açıklama

int memory_get_peak_usage ([ bool $gerçek_kullanım = false ] )

PHP betiğinize ayrılan azami belleğin bayt cinsinden miktarını döndürür.

Değiştirgeler

gerçek_kullanım

TRUE olduğu takdirde sistem tarafından PHP'ye ayrılan gerçek bellek miktarı, FALSE olduğunda veya değiştirge belirtilmediğinde emalloc() tarafından kullanılan bellek miktarı raporlanır.

Dönen Değerler

Ayrılan azami belleğin bayt cinsinden miktarı.

Sürüm Bilgisi

Sürüm: | Açıklama
5.2.1 | Bu işlevin kullanılabilmesi için derleme sırasında --enable-memory-limit seçeneğini belirtme ihtiyacı ortadan kalktı.
5.2.0 | real_usage değiştirgesi eklendi.

Ayrıca Bakınız

  • memory_get_usage() - PHP'ye ayrılan belleğin miktarını döndürür
  • memory_limit

main
memory_get_usage
PHP Seçenek/Bilgi İşlevleri


PHP'ye ayrılan belleğin miktarını döndürür

memory_get_peak_usage
php_ini_loaded_file
PHP Seçenek/Bilgi İşlevleri
PHP Manual

memory_get_usage

(PHP 4 >= 4.3.2, PHP 5, PHP 7)

memory_get_usage — PHP'ye ayrılan belleğin miktarını döndürür

Açıklama

int memory_get_usage ([ bool $gerçek_kullanım = false ] )

PHP betiğinize ayrılan belleğin bayt cinsinden miktarını döndürür.

Değiştirgeler

gerçek_kullanım

TRUE olduğu takdirde sistem tarafından PHP'ye ayrılan gerçek bellek miktarı, FALSE olduğunda veya değiştirge belirtilmediğinde emalloc() tarafından kullanılan bellek miktarı raporlanır.

Dönen Değerler

Ayrılan belleğin bayt cinsinden miktarı.

Sürüm Bilgisi

Sürüm: | Açıklama
5.2.1 | Bu işlevin kullanılabilmesi için derleme sırasında --enable-memory-limit seçeneğini belirtme ihtiyacı ortadan kalktı.
5.2.0 | gerçek_kullanım değiştirgesi eklendi.

Örnekler

Örnek 1 - memory_get_usage() örneği

<?php
// Bu sadece bir örnektir.
// Miktarlar, sisteminizde farklı olabilir.

echo memory_get_usage() . "\n"; // 36640

$a = str_repeat("Hello", 4242);

echo memory_get_usage() . "\n"; // 57960

unset($a);

echo memory_get_usage() . "\n"; // 36744

?>

Ayrıca Bakınız

  • memory_get_peak_usage() - PHP'ye ayrılan belleğin azami miktarını döndürür
  • memory_limit

memory_get_peak_usage
php_ini_loaded_file
PHP Seçenek/Bilgi İşlevleri


Yüklü php.ini dosyasının dosya yolunu döndürür

memory_get_usage
php_ini_scanned_files
PHP Seçenek/Bilgi İşlevleri
PHP Manual

php_ini_loaded_file

(PHP 5 >= 5.2.4, PHP 7)

php_ini_loaded_file — Yüklü php.ini dosyasının dosya yolunu döndürür

Açıklama

string php_ini_loaded_file ( void )

Bir php.ini dosyası yüklü mü diye bakar ve dosyanın yolunu döndürür.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

php.ini yüklüyse dosyanın yolu, değilse FALSE döner.

Örnekler

Örnek 1 - php_ini_loaded_file() örneği

<?php
$inipath = php_ini_loaded_file();

if ($inipath) {
    echo 'Yüklü php.ini: ' . $inipath;
} else {
    echo 'Bir php.ini dosyası yüklü değil';
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Yüklü php.ini: /usr/local/php/php.ini

Ayrıca Bakınız

  • php_ini_scanned_files() - Ek ini dizininden ayrıştırılan dosyaların listesi ile döner
  • phpinfo() - PHP'nin o anki durumu hakkında büyük miktarda bilgi çıktılar
  • Yapılandırma Dosyası

memory_get_usage
php_ini_scanned_files
PHP Seçenek/Bilgi İşlevleri


Ek ini dizininden ayrıştırılan dosyaların listesi ile döner

php_ini_loaded_file
php_logo_guid
PHP Seçenek/Bilgi İşlevleri
PHP Manual

php_ini_scanned_files

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

php_ini_scanned_files — Ek ini dizininden ayrıştırılan dosyaların listesi ile döner

Açıklama

string php_ini_scanned_files ( void )

php_ini_scanned_files() işlevi php.ini dosyasından sonra ayrıştırılan yapılandırma dosyalarını bir virgül ayraçlı liste olarak döndürür. Bu dosyalar, derleme sırasında --with-config-file-scan-dir seçeneği tarafından tanımlanan bir dizinde bulunur.

Döndürülen yapılandırma dosyaları --with-config-file-scan-dir seçeneğinde bildirilen yolu da içerir.

Dönen Değerler

Başarı durumunda .ini dosyalarının virgül ayraçlı listesini bir dizge olarak döndürür. Derleme sırasında --with-config-file-scan-dir seçeneği kullanılmamışsa FALSE döner. Seçenek kullanılmışsa fakat dizin boşsa bir boş dizge döner. INI dosyası olmayan bir dosyanın varlığı halinde dosya ismi listeye konur, fakat ek olarak bir PHP hatası çıktılanır. Bu PHP hatası hem derleme sırasında hem de php_ini_scanned_files() işlevi kullanıldığında görüntülenir.

Örnekler

Örnek 1 - Dönen ini dosyalarının listelenmesi

<?php
if ($filelist = php_ini_scanned_files()) {
    if (strlen($filelist) > 0) {
        $files = explode(',', $filelist);

        foreach ($files as $file) {
            echo "<li>" . trim($file) . "</li>\n";
        }
    }
}
?>

Ayrıca Bakınız

  • ini_set() - Bir yapılandırma yönergesine değer atar
  • phpinfo() - PHP'nin o anki durumu hakkında büyük miktarda bilgi çıktılar
  • php_ini_loaded_file() - Yüklü php.ini dosyasının dosya yolunu döndürür

php_ini_loaded_file
php_logo_guid
PHP Seçenek/Bilgi İşlevleri


PHP logo kimliğini döndürür

php_ini_scanned_files
php_sapi_name
PHP Seçenek/Bilgi İşlevleri
PHP Manual

php_logo_guid

(PHP 4, PHP 5 < 5.5)

php_logo_guid — PHP logo kimliğini döndürür

Açıklama

string php_logo_guid ( void )

Bu işlev, yerleşik resmi kullanarak PHP logosunu göstermekte kullanılacak kimliği döndürür. Logonunu gösterilip gösterilmeyeceğini expose_php yönergesi belirler.

Dönen Değerler

PHPE9568F34-D428-11d2-A769-00AA001ACF42 döner.

Örnekler

Örnek 1 - php_logo_guid() örneği

<?php

echo '<img src="' . $_SERVER['PHP_SELF'] .
     '?=' . php_logo_guid() . '" alt="PHP Logo !" />';

?>

Ayrıca Bakınız

  • phpinfo() - PHP'nin o anki durumu hakkında büyük miktarda bilgi çıktılar
  • phpversion() - Çalışan PHP'nin sürümünü döndürür
  • phpcredits() - PHP'ya katkıda bulunanları gösterir
  • zend_logo_guid() - Zend logo kimliğini döndürür

php_ini_scanned_files
php_sapi_name
PHP Seçenek/Bilgi İşlevleri


HTTP sunucusu ile PHP arasındaki arayüzün türünü döndürür

php_logo_guid
php_uname
PHP Seçenek/Bilgi İşlevleri
PHP Manual

php_sapi_name

(PHP 4 >= 4.0.1, PHP 5, PHP 7)

php_sapi_name — HTTP sunucusu ile PHP arasındaki arayüzün türünü döndürür

Açıklama

string php_sapi_name ( void )

PHP'nin kullandığı arayüz (Sunucu API'si, SAPI) türünü belirten küçük harfli bir dizge döndürür. Örneğin CLI PHP için bu dizge "cli" olurken Apache ile kullanılan API'ye bağlı olarak değişiklik gösteribilir. Olası değerler aşağıda listelenmiştir.

Dönen Değerler

Arayüz türünü küçük harfli bir dizge olarak döndürür.

Tamamı olmasa da olası değerler şunlardır: aolserver, apache, apache2filter, apache2handler, caudium, cgi (PHP 5.3'ten beri), cgi-fcgi, cli, continuity, embed, isapi, litespeed, milter, nsapi, phttpd, pi3web, roxen, thttpd, tux ve webjames.

Örnekler

Örnek 1 - php_sapi_name() örneği

Bu örnektecgi-fcgi değerini de kapsayan cgi alt dizgesinin varlığı aranmaktadır.

<?php
$sapi_type = php_sapi_name();
if (substr($sapi_type, 0, 3) == 'cgi') {
    echo "CGI PHP kullanıyorsunuz\n";
} else {
    echo "CGI PHP kullanmıyorsunuz\n";
}
?>

Notlar

Bilginize: Başka bir yaklaşım

PHP sabiti PHP_SAPI, php_sapi_name() işlevinden dönen değerin aynını içerir.

İpucu

Olası bir yanlış anlama

Tanımlı SAPI her zaman apaçık belli değildir. Apache örneğindeki gibi apache2handler veya apache2filter olarak tanımlanmış olabilir.

Ayrıca Bakınız

  • PHP_SAPI

php_logo_guid
php_uname
PHP Seçenek/Bilgi İşlevleri


PHP'nin çalıştığı işletim sistemi hakkında bilgi döndürür

php_sapi_name
phpcredits
PHP Seçenek/Bilgi İşlevleri
PHP Manual

php_uname

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

php_uname — PHP'nin çalıştığı işletim sistemi hakkında bilgi döndürür

Açıklama

string php_uname ([ string $kip = "a" ] )

php_uname() işlevi PHP'nin üzerinde çalıştığı işletim sistemi hakkında bilgi döndürür. Bu bilgiyi phpinfo() çıktısının üst satırlarında da görebilirsiniz. İşletim sisteminin sadece ismini öğrenmek isterseniz PHP_OS sabitini kullanabilirsiniz; fakat bu sabiti kullanırken, sabitin, PHP'nin derlendiği işletim sistemi adını içereceğini unutmayın.

Bazı eski Unix sürümlerinde, üzerinde çalışılan işletim sistemi saptanamaz ve PHP üzerinde derlendiği işletim sistemi bilgisi gösterilir. Buna genellikle uname() kütüphane çağrısının mevcut olmadığı veya çalışmadığı sistemlerde rastlanır.

Değiştirgeler

kip

kip döndürülecek bilgi çeşidini belirtmek için kullanılan tek bir karakter içerebilir. Olası değerler:

  • 'a': Bu öntanımlıdır. "s n r v m" kiplerinin hepsini içerir.
  • 's': işletim sisteminin ismi. Örnek: FreeBSD.
  • 'n': Konak ismi. Örnek: localhost.example.com.
  • 'r': Dağıtım ismi. Örnek: 5.1.2-RELEASE.
  • 'v': Sürüm bilgisi. İşletim sistemine göre değişiklik gösterir.
  • 'm': Makine türü. Örnek: i386.

Dönen Değerler

Bilgiyi bir dizge olarak döndürür.

Örnekler

Örnek 1 - php_uname() örnekleri

<?php
echo php_uname();
echo PHP_OS;

/* Bazı olası çıktılar:
Linux localhost 2.4.21-0.13mdk #1 Fri Mar 14 15:08:06 EST 2003 i686
Linux

FreeBSD localhost 3.2-RELEASE #15: Mon Dec 17 08:46:02 GMT 2001
FreeBSD

Windows NT XN1 5.1 build 2600
WINNT
*/

if (strtoupper(substr(PHP_OS, 0, 3)) === 'WIN') {
    echo 'Bu sunucu Windows üzerinde!';
} else {
    echo 'Bu sunucu Windows üzerinde değil!';
}

?>

İşinizi yarayacak bazı öntanımlı PHP sabitleri vardır. Örneğin:

Örnek 2 - İşletim sistemine göre bazı sabit örnekleri

<?php
// *nix
echo DIRECTORY_SEPARATOR; // /
echo PHP_SHLIB_SUFFIX;    // so
echo PATH_SEPARATOR;      // :

// Win*
echo DIRECTORY_SEPARATOR; // \
echo PHP_SHLIB_SUFFIX;    // dll
echo PATH_SEPARATOR;      // ;
?>

Ayrıca Bakınız

  • phpversion() - Çalışan PHP'nin sürümünü döndürür
  • php_sapi_name() - HTTP sunucusu ile PHP arasındaki arayüzün türünü döndürür
  • phpinfo() - PHP'nin o anki durumu hakkında büyük miktarda bilgi çıktılar

php_sapi_name
phpcredits
PHP Seçenek/Bilgi İşlevleri


PHP'ya katkıda bulunanları gösterir

php_uname
phpinfo
PHP Seçenek/Bilgi İşlevleri
PHP Manual

phpcredits

(PHP 4, PHP 5, PHP 7)

phpcredits — PHP'ya katkıda bulunanları gösterir

Açıklama

bool phpcredits ([ int $seçenek = CREDITS_ALL ] )

PHP ve eklenti geliştiricilerinin listesini basar. Uygun HTML kodlarını üretip içine bu bilgiyi yerleştirir.

Değiştirgeler

seçenek

Bu değiştirgeyi sayfayı özelleştirmek için kullanabilirsiniz. Değiştirge isteğe bağlıdır ve CREDITS_ALL öntanımlıdır.

Olası phpcredits() seçenekleri
Seçenek | Açıklama
CREDITS_ALL | Tüm katkıcılar. CREDITS_DOCS, CREDITS_GENERAL, CREDITS_GROUP, CREDITS_MODULES ve CREDITS_FULLPAGE seçeneklerinin tamamına eşdeğerdir. Uygun başlıklarla tek bir HTML sayfası üretilir.
CREDITS_DOCS | Belgelendirme ekibi.
CREDITS_FULLPAGE | Diğer seçeneklerin çıktılarının birleşiminden oluşan tek bir HTML sayfası üretilir.
CREDITS_GENERAL | Genel katkıcılar: Dil tasarımı ve kavramlar, PHP 4.0 ve SAPI modülünün yazarları.
CREDITS_GROUP | Çekirdek geliştiricilerin listesi
CREDITS_MODULES | Eklenti modüllerinin ve yazarlarının listesi.
CREDITS_SAPI | Sunucu API modüllerinin ve yazarlarının listesi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Genel katkıcıların listelenmesi

<?php
phpcredits(CREDITS_GENERAL);
?>

Örnek 2 - Çekirdek geliştiricilerin ve belgelendirme ekibinin listelenmesi

<?php
phpcredits(CREDITS_GROUP + CREDITS_DOCS + CREDITS_FULLPAGE);
?>

Örnek 3 - Tüm katkıcıların listelenmesi

<html>
 <head>
  <title>Katılımcılar</title>
 </head>
 <body>
<?php
// bazı kodlar
phpcredits(CREDITS_ALL - CREDITS_FULLPAGE);
// bazı kodlar
?>
 </body>
</html>

Ayrıca Bakınız

  • phpversion() - Çalışan PHP'nin sürümünü döndürür
  • php_logo_guid() - PHP logo kimliğini döndürür
  • phpinfo() - PHP'nin o anki durumu hakkında büyük miktarda bilgi çıktılar

php_uname
phpinfo
PHP Seçenek/Bilgi İşlevleri


PHP'nin o anki durumu hakkında büyük miktarda bilgi çıktılar

phpcredits
phpversion
PHP Seçenek/Bilgi İşlevleri
PHP Manual

phpinfo

(PHP 4, PHP 5, PHP 7)

phpinfo — PHP'nin o anki durumu hakkında büyük miktarda bilgi çıktılar

Açıklama

bool phpinfo ([ int $ne = INFO_ALL ] )

PHP'nin o anki durumu hakkında büyük miktarda bilgi çıktılar. Bu bilgi, PHP derleme seçenekleri, kurulu eklentiler, PHP sürümü, sunucu bilgisi, (PHP bir modül olarak derlenmişse) sunucu ortam değişkenleri, PHP ortam değişkenleri, işletim sistemi sürüm bilgileri, dosya yolları, asıl ve yerel yapılandırma seçenekleri, HTTP başlıkları ve PHP lisansını içerir.

Her sistemin yapılandırması farklı olduğundan phpinfo() işlevi genellikle, yapılandırma ayarlarını ve kullanılabilecek öntanımlı değişkenleri öğrenmek için kullanılır.

phpinfo() tüm EGPCS (Environment, GET, POST, Cookie, Server) verisini içerdiğinden ayrıca değerli bir hata ayıklama aracıdır.

Değiştirgeler

ne

İsteğe bağlı bu değiştirgede aşağıdaki sabitlerin bitsel değerlerinin toplamı belirtilerek işlevin çıktısı özelleştirilebilir. Bu sabitleri veya bitsel değerlerini VEYA işleci ile birleştirerek belirtebilirsiniz.

phpinfo() seçenekleri
Sabit | Değer | Açıklama
INFO_GENERAL | 1 | Yapılandırma satırı, php.ini dosyasının yeri, derleme tarihi, HTTP Sunucusu, Sistem, vesaire.
INFO_CREDITS | 2 | PHP'ye katkıda bulunanlar. Ayrıca, phpcredits() işlevine de bakınız.
INFO_CONFIGURATION | 4 | PHP yönergelerinin asıl ve yerel değerleri. Ayrıca ini_get() işlevine de bakınız.
INFO_MODULES | 8 | Yüklü modüller ve binlerğn ayarları. Ayrıca get_loaded_extensions() işlevine de bakınız.
INFO_ENVIRONMENT | 16 | $_ENV dizisi ile de edinilebilen ortam değişkenleri bilgileri.
INFO_VARIABLES | 32 | EGPCS (Environment, GET, POST, Cookie, Server) verisinden elde edilen tüm öntanımlı değişkenler.
INFO_LICENSE | 64 | PHP Lisans bilgileri. Ayıca bakınız: » Lisans SSS.
INFO_ALL | -1 | Yukarıdakiler hepsi gösterilir. Bu öntanımlı değerdir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.2.2 | "Loaded Configuration File" başlığı altında yüklü yapılandırma dosyası bilgi eklendi. Evvelce sadece "Configuration File (php.ini) Path" başlığı altında yapılandırma dosyasının yolu bulunurdu.

Örnekler

Örnek 1 - phpinfo() örneği

<?php

// Tüm bilgiyi gösterelim (INFO_ALL sabitine eşdeğer)
phpinfo();

// Sadece modül bilgisini gösterelim.
// phpinfo(8) de aynı sonucu verir.
phpinfo(INFO_MODULES);

?>

Notlar

Bilginize:

Parts of the information displayed are disabled when the expose_php yapılandırma seçeneğine off atanmışsa bazı bilgiler gösterilmez. PHP ve Zend logoları ve katkıcılar bunlardan bazılarıdır.

Bilginize:

PHP'yi komut satırından kullanıyorsanız phpinfo() işlevi HTML çıktı yerine düz metin çıktı verir.

Ayrıca Bakınız

  • phpversion() - Çalışan PHP'nin sürümünü döndürür
  • phpcredits() - PHP'ya katkıda bulunanları gösterir
  • php_logo_guid() - PHP logo kimliğini döndürür
  • ini_get() - Bir yapılandırma yönergesinin değerini döndürür
  • ini_set() - Bir yapılandırma yönergesine değer atar
  • get_loaded_extensions() - Derlenmiş ve yüklenmiş tüm modüllerin isimlerini içeren bir dizi döndürür
  • Öntanımlı Değişkenler

phpcredits
phpversion
PHP Seçenek/Bilgi İşlevleri


Çalışan PHP'nin sürümünü döndürür

phpinfo
putenv
PHP Seçenek/Bilgi İşlevleri
PHP Manual

phpversion

(PHP 4, PHP 5, PHP 7)

phpversion — Çalışan PHP'nin sürümünü döndürür

Açıklama

string phpversion ([ string $eklenti ] )

Çalışan PHP'nin veya belirtilen eklentinin sürüm numarasını bir dizge olarak döndürür.

Değiştirgeler

eklenti

İsteğe bağlı bir eklenti ismi.

Dönen Değerler

İsteğe bağlı eklenti değiştirgesi belirtilmişse işlev bu eklentinin sürüm bilgisini döndürür. Eklenti ile ilgili bir sürüm bilgisi yoksa veya eklenti etkin değilse FALSE döner.

Örnekler

Örnek 1 - phpversion() örneği

<?php
// prints e.g. 'Current PHP version: 4.1.1'
echo 'Çalışan PHP\'nin sürümü: ' . phpversion();

// eklenti etkinse '2.0' gibi bir değer basar
// eklenti etkin değilse hiçbir şey basılmaz
echo phpversion('tidy');
?>

Örnek 2 - PHP_VERSION_ID örneği

<?php
// PHP_VERSION_ID, PHP 5.2.7'den beri kullanılabilmektedir.
// Kullandığınız sürüm daha düşükse taklit edin
if(!defined('PHP_VERSION_ID'))
{
 $version = explode('.',PHP_VERSION);

 define('PHP_VERSION_ID',
        ($version[0] * 10000 + $version[1] * 100 + $version[2]));
}

// PHP_VERSION_ID bir sayı olarak tanımlanır. PHP sürümü yükseldikçe
// sayı büyür. Şu ifade ile tanımlanır:
//
// $version_id = $major_version * 10000 + $minor_version * 100 + $release_version;
//
// Artık PHP sürümlerinin özellikleri için PHP_VERSION_ID'ye bakabiliriz.
// Kullandığınız PHP sürümü bir özelliği desteklemezse version_compare()
// kullanmanız gerekmez. Örneğin 5.2.7 öncesi sürümlerden birini
// kullanıyorsanız PHP_VERSION_* sabitlerini şöyle tanımlayabilirsiniz:

if(PHP_VERSION_ID < 50207)
{
 define('PHP_MAJOR_VERSION',   $version[0]);
 define('PHP_MINOR_VERSION',   $version[1]);
 define('PHP_RELEASE_VERSION',   $version[2]);

 // ve böyle gider, ...
}
?>

Notlar

Bilginize:

Bu bilgi ayrıca PHP_VERSION öntanımlı sabitinde de bulunur.

Ayrıca Bakınız

  • version_compare() - PHP standardına uygun hale getirilmiş iki sürüm numarası dizgesini karşılaştırır
  • phpinfo() - PHP'nin o anki durumu hakkında büyük miktarda bilgi çıktılar
  • phpcredits() - PHP'ya katkıda bulunanları gösterir
  • php_logo_guid() - PHP logo kimliğini döndürür
  • zend_version() - Zend motorunun sürümünü döndürür

phpinfo
putenv
PHP Seçenek/Bilgi İşlevleri


Bir ortam değişkenine değer atar

phpversion
restore_include_path
PHP Seçenek/Bilgi İşlevleri
PHP Manual

putenv

(PHP 4, PHP 5, PHP 7)

putenv — Bir ortam değişkenine değer atar

Açıklama

bool putenv ( string $atama_dizgesi )

atama_dizgesi'ni sunucu ortamına ekler. Yeni ortam değişkeni sadece o anki istek için istek süresince geçerli olacaktır. İstek sunumunun sonunda ortam özgün durumuna getirilir.

Belli ortam değişkenlerinin atanması bir güvenlik sorunun ortaya çıkma ihtimalini arttırır. safe_mode_allowed_env_vars yönergesi virgül ayraçlı bir önekler listesi içerir. Güvenli kipte kullanıcı sadece bu yönergede belirtilen öneklerden biriyle başlayan ortam değişkenlerini değiştirebilir. Öntanımlı olarak, kullanıcılar sadece PHP_ önekiyle başlayan (PHP_FOO=BAR gibi) ortam değişkenlerine değer atayabilirler. Dikkat: Eğer yönergeye değer olarak boş bir dizge atanmışsa kullanıcı her ortam değişkenine değer atayabilir!

safe_mode_protected_env_vars yönergesi, kullanıcının putenv() işlevini kullanarak değiştiremeyeceği ortam değişkenlerinin virgül ayraçlı listesini içerir. safe_mode_allowed_env_vars yönergesinde belirtilen önekler safe_mode_protected_env_vars yönergesinde belirtilen ortam değişkenlerine uysa bile bu ortam değişkenlerine putenv() ile değer atanamaz.

Değiştirgeler

atama_dizgesi

"FOO=BAR" gibi bir atama dizgesi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Bir ortam değişkeninin atanması

<?php
putenv("UNIQID=$uniqid");
?>

Notlar

Uyarı

Bu yönergeler sadece güvenli kip etkinken geçerlidir!

Ayrıca Bakınız

  • getenv() - Bir ortam değişkeninin değerini döndürür

phpversion
restore_include_path
PHP Seçenek/Bilgi İşlevleri


include_path yönergesini eski değerine ayarlar

putenv
set_include_path
PHP Seçenek/Bilgi İşlevleri
PHP Manual

restore_include_path

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

restore_include_path — include_path yönergesini eski değerine ayarlar

Açıklama

void restore_include_path ( void )

include_path yönergesinin çalışma anı değerini tekrar php.ini dosyasında belirtilen değerine ayarlar.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 - restore_include_path() örneği

<?php

echo get_include_path();  // .:/usr/local/lib/php

set_include_path('/inc');

echo get_include_path();  // /inc

// PHP 4.3.0 ve sonrasında çalışır
restore_include_path();

// Bütün PHP sürümlerinde çalışır
ini_restore('include_path');

echo get_include_path();  // .:/usr/local/lib/php

?>

Ayrıca Bakınız

  • ini_restore() - Bir yapılandırma yönergesine eski değerini atar
  • get_include_path() - include_path yönergesinin değerini döndürür
  • set_include_path() - include_path yönergesinin çalışma anı değerini belirler
  • include - include

putenv
set_include_path
PHP Seçenek/Bilgi İşlevleri


include_path yönergesinin çalışma anı değerini belirler

restore_include_path
set_magic_quotes_runtime
PHP Seçenek/Bilgi İşlevleri
PHP Manual

set_include_path

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

set_include_path — include_path yönergesinin çalışma anı değerini belirler

Açıklama

string set_include_path ( string $yeni_değer )

include_path yönergesinin, betiğin çalışma süresince geçerli olacak değerini belirler.

Değiştirgeler

yeni_değer

include_path yönergesini yeni değeri.

Dönen Değerler

Başarısızlık durumunda FALSE, aksi takdirde include_path yönergesinin eski değeriyle döner.

Örnekler

Örnek 1 - set_include_path() örneği

<?php
// PHP 4.3.0 ve sonrasında çalışır
set_include_path('/inc');

// PHP'nin tüm sürümlerinde çalışır
ini_set('include_path', '/inc');
?>

Örnek 2 - İçerilecek dosyaların aranacağı yollara bir yenisini eklemek

PATH_SEPARATOR sabitini kullanarak bu yolları işletim sisteminden bağımsız olarak çoğaltmak mümkündür.

Bu örnekte, include_path yönergesinde belirtilen dosya yollarına /usr/lib/pear dizinini ekleyeceğiz.

<?php
$path = '/usr/lib/pear';
set_include_path(get_include_path() . PATH_SEPARATOR . $path);
?>

Ayrıca Bakınız

  • ini_set() - Bir yapılandırma yönergesine değer atar
  • get_include_path() - include_path yönergesinin değerini döndürür
  • restore_include_path() - include_path yönergesini eski değerine ayarlar
  • include - include
restore_include_path
set_magic_quotes_runtime
PHP Seçenek/Bilgi İşlevleri


magic_quotes_runtime yönergesinin çalışma anı değerini belirler

set_include_path
set_time_limit
PHP Seçenek/Bilgi İşlevleri
PHP Manual

set_magic_quotes_runtime

(PHP 4, PHP 5)

set_magic_quotes_runtime — magic_quotes_runtime yönergesinin çalışma anı değerini belirler

Açıklama

bool set_magic_quotes_runtime ( bool $yeni_değer )

magic_quotes_runtime yönergesinin çalışma anı değerini belirler.

Uyarı

Bu işlevin kullanımı PHP 5.3.0'dan beri ÖNERİLMEMEKTEDİR ve PHP 6.0.0'da tamamen KALDIRILMIŞTIR. Bu işleve kesinlikle güvenmemelisiniz.

Değiştirgeler

yeni_değer

Off için FALSE. On için TRUE olmalıdır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - set_magic_quotes_runtime() örneği

<?php
// Geçici bir dosya tanıtıcısı oluşturalım
$fp = tmpfile();

// Biraz veri yazalım
fwrite($fp, '\'PHP\' ardışık bir kısaltmadır');

// magic_quotes_runtime olmaksızın
rewind($fp);
set_magic_quotes_runtime(false);

echo 'magic_quotes_runtime olmaksızın: ' . fread($fp, 64), PHP_EOL;

// magic_quotes_runtime ile
rewind($fp);
set_magic_quotes_runtime(true);

echo 'magic_quotes_runtime ile: ' . fread($fp, 64), PHP_EOL;

// Ortalığı temizleyelim
fclose($fp);
?>

Yukarıdaki örneğin çıktısı:

magic_quotes_runtime olmaksızın: 'PHP' ardışık bir kısaltmadır
magic_quotes_runtime ile: \'PHP\' ardışık bir kısaltmadır

Ayrıca Bakınız

  • get_magic_quotes_gpc() - magic_quotes_gpc yönergesinin değerini döndürür
  • get_magic_quotes_runtime() - magic_quotes_runtime yönergesinin çalışma anı değerini döndürür
set_include_path
set_time_limit
PHP Seçenek/Bilgi İşlevleri


Azami çalıştırma süresini sınırlar

set_magic_quotes_runtime
sys_get_temp_dir
PHP Seçenek/Bilgi İşlevleri
PHP Manual

set_time_limit

(PHP 4, PHP 5, PHP 7)

set_time_limit — Azami çalıştırma süresini sınırlar

Açıklama

void set_time_limit ( int $saniye )

Bir betiğin çalıştırılabileceği süreyi saniye cinsinden belirler. Bu süre aşıldığında betik ölümcül hata ile döner. php.ini dosyasında max_execution_time yönergesi ile başka bir değer belirtilmemişse öntanımlı süre 30 saniyedir.

set_time_limit() işlevi çağrıldığı anda süre sıfırdan başlatılır. Başka bir deyişle, betik örneğin 30 saniyelik öntanımlı zaman aşımı dahilinde 25 saniye çalıştıktan sonra set_time_limit(20) çağrısı yapılırsa süre bitiminde betik 45 saniye çalışmış olacaktır.

Değiştirgeler

saniye

Betiğin çalıştırılabileceği azami süre (saniye cinsinden). Sıfır belirtilirse bir zaman sınırlaması kaldırılmış olur.

Dönen Değerler

Hiçbir değer dönmez.

Notlar

Uyarı

PHP güvenli kipte (safe_mode) çalışıyorsa bu işlevin bir etkisi olmaz. Azami süreyi değiştirmek için php.ini dosyasında güvenli kipi iptal etmek veya azami süreyi php.ini dosyasında değiştirmekten başka çare yoktur.

Bilginize:

max_execution_time yönergesi veya set_time_limit() işlevi sadece betiğin kendi çalışma süresini etkilerler. Betiğin çalışması sırasında, akım işlemleri, veritabanı sorguları ve system() işlevi kullanılarak yapılan sistem çağrıları gibi betiğin dışında gerçekleşen işlemler için harcanan zaman betiğin azami çalışma süresinin hesaplanmasında hesaba katılmaz. Gerçek zamanın ölçüldüğü Windows üzerinde bu geçerli değildir.

Ayrıca Bakınız

  • max_execution_time
  • max_input_time

set_magic_quotes_runtime
sys_get_temp_dir
PHP Seçenek/Bilgi İşlevleri


Geçici dosyalar için kullanılan dizini döndürür

set_time_limit
version_compare
PHP Seçenek/Bilgi İşlevleri
PHP Manual

sys_get_temp_dir

(PHP 5 >= 5.2.1, PHP 7)

sys_get_temp_dir — Geçici dosyalar için kullanılan dizini döndürür

Açıklama

string sys_get_temp_dir ( void )

PHP'nin geçici dosyaları sakladığı öntanımlı dizinin tam yolunu döndürür.

Dönen Değerler

Geçici dosyaların saklandığı dizinin tam yolunu döndürür.

Örnekler

Örnek 1 - sys_get_temp_dir() örneği

<?php
// sys_get_temp_dir() kullanarak geçici dosyaların
// tutulduğu dizinde bir geçici dosya oluşturalım
$temp_file = tempnam(sys_get_temp_dir(), 'Tux');

echo $temp_file;
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

C:\Windows\Temp\TuxA318.tmp

Ayrıca Bakınız

  • tmpfile() - Geçici bir dosya oluşturur
  • tempnam() - Eşsiz bir isimle dosya oluşturur
set_time_limit
version_compare
PHP Seçenek/Bilgi İşlevleri


PHP standardına uygun hale getirilmiş iki sürüm numarası dizgesini karşılaştırır

sys_get_temp_dir
zend_logo_guid
PHP Seçenek/Bilgi İşlevleri
PHP Manual

version_compare

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

version_compare — PHP standardına uygun hale getirilmiş iki sürüm numarası dizgesini karşılaştırır

Açıklama

mixed version_compare ( string $sürüm1 , string $sürüm2 [, string $işleç ] )

version_compare() işlevi PHP standardına uygun hale getirilmiş iki sürüm numarası dizgesini karşılaştırır. PHP'nin sadece belli bir sürümü ile çalışabilecek betikler yazıyorsanız bu işleve ihtiyacınız olacaktır.

İşlev önce _, - ve + karakterlerini birer nokta . ile değiştirir, ardından numara olmayan dizgeciklerin önüne ve ardına birer nokta konur. Örneğin, '4.3.2RC1' dizgesi '4.3.2.RC.1' haline gelir. Elde edilen dizge, explode('.', $sürüm) kullanılmışçasına bileşenlerine ayrıldıktan sonra her bileşen soldan sağa karşılaştırılır. Bileşenlerin içerdiği özel sürüm dizgeleri şu sıralamaya göre ele alınırlar: bu listede olmayan bir dizge < dev < alpha = a < beta = b < RC = rc < # < pl = p. Bu yöntemle, '4.1' ve '4.1.2' gibi farklı seviyelerden sürümler karşılaştırabileceği gibi geliştirme sürümlerinin karşılaştırılması için de kullanılabilir.

Değiştirgeler

sürüm1

İlk sürüm numarası.

sürüm2

İkinci sürüm numarası.

işleç

İsteğe bağlı bu değiştirge ile sürümler arasında belli ilişkileri sınayabilirsiniz. Olası işleçler şunlardır: <, lt, <=, le, >, gt, >=, ge, ==, =, eq, !=, <>, ne.

Bu değiştirge harf büyüklüğüne duyarlıdır, yani değerlerin hepsi küçük harfli olmalıdır.

Dönen Değerler

Öntanımlı olarak, version_compare() işlevi, birinci sürüm ikincisinden küçükse -1, büyükse 1, eşitlerse 0 döndürür.

İsteğe bağlı işleç değiştirgesi kullanılırsa ve sürümler arasında belirtilen ilişki varsa TRUE aksi takdirde FALSE döner.

Örnekler

Aşağıdaki örnekte, kodu çalıştıran PHP sürümüne içermesi nedeniyle PHP_VERSION sabiti kullanılmıştır.

Örnek 1 - version_compare() örnekleri

<?php
if (version_compare(PHP_VERSION, '6.0.0') === 1) {
    echo 'PHP sürümüm en azından 6.0.0, gerçek sürüm: ' . PHP_VERSION . "\n";
}

if (version_compare(PHP_VERSION, '5.3.0') === 1) {
    echo 'PHP sürümüm en azından 5.3.0, gerçek sürüm: ' . PHP_VERSION . "\n";
}

if (version_compare(PHP_VERSION, '5.0.0', '>')) {
    echo 'PHP 5 kullanıyorum, gerçek sürüm: ' . PHP_VERSION . "\n";
}

if (version_compare(PHP_VERSION, '5.0.0', '<')) {
    echo 'PHP 4 kullanıyorum, gerçek sürüm: ' . PHP_VERSION . "\n";
}
?>

Notlar

Bilginize:

PHP_VERSION sabiti kullanılan PHP'nin sürüm numarasını içerir.

Bilginize:

5.3.0-dev gibi ön dağıtım sürümleri için, alt sürümün, ulaşacakları asıl sürümün numarası (PHP 5.3.0) olduğu varsayılır.

Ayrıca Bakınız

  • phpversion() - Çalışan PHP'nin sürümünü döndürür
  • php_uname() - PHP'nin çalıştığı işletim sistemi hakkında bilgi döndürür
  • function_exists() - Eğer işlev tanımlanmış ise TRUE döndürür

sys_get_temp_dir
zend_logo_guid
PHP Seçenek/Bilgi İşlevleri


Zend logo kimliğini döndürür

version_compare
zend_thread_id
PHP Seçenek/Bilgi İşlevleri
PHP Manual

zend_logo_guid

(PHP 4, PHP < 5.5)

zend_logo_guid — Zend logo kimliğini döndürür

Açıklama

string zend_logo_guid ( void )

Bu işlev, yerleşik resmi kullanarak Zend logosunu göstermekte kullanılacak kimliği döndürür.

Dönen Değerler

PHPE9568F35-D428-11d2-A769-00AA001ACF42 dizgesini döndürür.

Örnekler

Örnek 1 zend_logo_guid() örneği

<?php

echo '<img src="' . $_SERVER['PHP_SELF'] .
     '?=' . zend_logo_guid() . '" alt="Zend Logo!" />';

?>

Ayrıca Bakınız

  • php_logo_guid() - PHP logo kimliğini döndürür

version_compare
zend_thread_id
PHP Seçenek/Bilgi İşlevleri


Geçerli evre için eşsiz bir betimleyici döndürür

zend_logo_guid
zend_version
PHP Seçenek/Bilgi İşlevleri
PHP Manual

zend_thread_id

(PHP 5, PHP 7)

zend_thread_id — Geçerli evre için eşsiz bir betimleyici döndürür

Açıklama

int zend_thread_id ( void )

Bu işlev geçerli evre için eşsiz bir betimleyici döndürür.

Dönen Değerler

Evre kimliğini bir tamsayı olarak döndürür.

Örnekler

Örnek 1 - zend_thread_id() örneği

<?php
$thread_id = zend_thread_id();

echo 'Evre kimliği: ' . $thread_id;
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Evre kimliği: 7864

Notlar

Bilginize:

Bu işlev, PHP, ZTS (Zend Thread Safety) desteği ve hata ayıklama kipi (--enable-debug) ile derlendiği takdirde kullanılabilir.

zend_logo_guid
zend_version
PHP Seçenek/Bilgi İşlevleri


Zend motorunun sürümünü döndürür

zend_thread_id
runkit
PHP Seçenek/Bilgi İşlevleri
PHP Manual

zend_version

(PHP 4, PHP 5, PHP 7)

zend_version — Zend motorunun sürümünü döndürür

Açıklama

string zend_version ( void )

Kurulu Zend Motorunun sürümünü içeren bir dizge döndürür.

Dönen Değerler

Zend Motorunun sürüm numarasını bir dizge olarak döndürür.

Örnekler

Örnek 1 - zend_version() örneği

<?php
echo "Zend motorunun sürümü: " . zend_version();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Zend motorunun sürümü: 2.3.0

Ayrıca Bakınız

  • phpinfo() - PHP'nin o anki durumu hakkında büyük miktarda bilgi çıktılar
  • phpcredits() - PHP'ya katkıda bulunanları gösterir
  • php_logo_guid() - PHP logo kimliğini döndürür
  • phpversion() - Çalışan PHP'nin sürümünü döndürür

zend_thread_id
runkit
PHP Seçenek/Bilgi İşlevleri


runkit

  • Giriş
  • Öntanımlı Sabitler
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • runkit İşlevleri
    • Runkit_Sandbox — Runkit Sandbox Class -- PHP Virtual Machine
    • Runkit_Sandbox_Parent — Runkit Anti-Sandbox Class
    • runkit_class_adopt — Convert a base class to an inherited class, add ancestral methods when appropriate
    • runkit_class_emancipate — Convert an inherited class to a base class, removes any method whose scope is ancestral
    • runkit_constant_add — Similar to define(), but allows defining in class definitions as well
    • runkit_constant_redefine — Redefine an already defined constant
    • runkit_constant_remove — Remove/Delete an already defined constant
    • runkit_function_add — Add a new function, similar to create_function
    • runkit_function_copy — Copy a function to a new function name
    • runkit_function_redefine — Replace a function definition with a new implementation
    • runkit_function_remove — Remove a function definition
    • runkit_function_rename — Change a function's name
    • runkit_import — Process a PHP file importing function and class definitions, overwriting where appropriate
    • runkit_lint_file — Check the PHP syntax of the specified file
    • runkit_lint — Check the PHP syntax of the specified php code
    • runkit_method_add — Dynamically adds a new method to a given class
    • runkit_method_copy — Copies a method from class to another
    • runkit_method_redefine — Dynamically changes the code of the given method
    • runkit_method_remove — Dynamically removes the given method
    • runkit_method_rename — Dynamically changes the name of the given method
    • runkit_return_value_used — Determines if the current functions return value will be used
    • runkit_sandbox_output_handler — Specify a function to capture and/or process output from a runkit sandbox
    • runkit_superglobals — Return numerically indexed array of registered superglobals
zend_version
Giriş
PHP'nin Davranışını Etkileyenler


Giriş

The runkit extension provides means to modify constants, user-defined functions, and user-defined classes. It also provides for custom superglobal variables and embeddable sub-interpreters via sandboxing.

This package is meant as a feature added replacement for the » classkit package. When compiled with the --enable-runkit=classkit option to ./configure, it will export classkit compatible function definitions and constants.

runkit
Öntanımlı Sabitler
runkit


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

RUNKIT_IMPORT_FUNCTIONS (integer)
runkit_import() flag indicating that normal functions should be imported from the specified file.
RUNKIT_IMPORT_CLASS_METHODS (integer)
runkit_import() flag indicating that class methods should be imported from the specified file.
RUNKIT_IMPORT_CLASS_CONSTS (integer)
runkit_import() flag indicating that class constants should be imported from the specified file. Note that this flag is only meaningful in PHP versions 5.1.0 and above.
RUNKIT_IMPORT_CLASS_PROPS (integer)
runkit_import() flag indicating that class standard properties should be imported from the specified file.
RUNKIT_IMPORT_CLASS_STATIC_PROPS (integer)
runkit_import() flag indicating that class static properties should be imported from the specified file. Available since Runkit 1.0.1.
RUNKIT_IMPORT_CLASSES (integer)
runkit_import() flag representing a bitwise OR of the RUNKIT_IMPORT_CLASS_* constants.
RUNKIT_IMPORT_OVERRIDE (integer)
runkit_import() flag indicating that if any of the imported functions, methods, constants, or properties already exist, they should be replaced with the new definitions. If this flag is not set, then any imported definitions which already exist will be discarded.
RUNKIT_ACC_PUBLIC (integer)
PHP 5 specific flag to runkit_method_add() and runkit_method_redefine()
RUNKIT_ACC_PROTECTED (integer)
PHP 5 specific flag to runkit_method_add() and runkit_method_redefine()
RUNKIT_ACC_PRIVATE (integer)
PHP 5 specific flag to runkit_method_add() and runkit_method_redefine()
RUNKIT_ACC_STATIC (integer)
PHP 5 specific flag to runkit_method_add() and runkit_method_redefine(). Available since Runkit 1.0.1.
CLASSKIT_ACC_PUBLIC (integer)
PHP 5 specific flag to classkit_method_add() Only defined when classkit compatibility is enabled.
CLASSKIT_ACC_PROTECTED (integer)
PHP 5 specific flag to classkit_method_add() Only defined when classkit compatibility is enabled.
CLASSKIT_ACC_PRIVATE (integer)
PHP 5 specific flag to classkit_method_add() Only defined when classkit compatibility is enabled.
CLASSKIT_AGGREGATE_OVERRIDE (integer)
PHP 5 specific flag to classkit_import() Only defined when classkit compatibility is enabled.
RUNKIT_VERSION (string)
Defined to the current version of the runkit package.
CLASSKIT_VERSION (string)
Defined to the current version of the runkit package. Only defined when classkit compatibility is enabled.
Giriş
Yapılandırma/Kurulum
runkit


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Öntanımlı Sabitler
Gereksinimler
runkit


Gereksinimler

Modifying Constants, Functions, Classes, and Methods as well as Custom Superglobals works with all releases of PHP 5. No special requirements are necessary.

Sandboxing requires PHP 5.1.0 or later, or PHP 5.0.0 with a special TSRM patch applied. Regardless of which version of PHP is in use it must be compiled with the --enable-maintainer-zts option. See the README file in the runkit package for additional information.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu » PECL eklentisi PHP ile gelmez.

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/runkit.

Windows binaries (DLL files) for this PECL extension are available from the PECL website.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Runkit Configuration Options
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
runkit.superglobal | "" | PHP_INI_PERDIR |
runkit.internal_override | "0" | PHP_INI_SYSTEM |
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

runkit.superglobal string
Comma-separated list of variable names to be treated as superglobals. This value should be set in the systemwide php.ini file, but may work in perdir configuration contexts depending on your SAPI.

Örnek 1 Custom Superglobals with runkit.superglobal=_FOO,_BAR in php.ini

<?php
function show_values() {
  echo "Foo is $_FOO\n";
  echo "Bar is $_BAR\n";
  echo "Baz is $_BAZ\n";
}

$_FOO = 'foo';
$_BAR = 'bar';
$_BAZ = 'baz';

/* Displays foo and bar, but not baz */
show_values();
?>
runkit.internal_override boolean
Enables ability to modify/rename/remove internal functions.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Özkaynak Türleri

Bu eklentinin tanımlı hiçbir özkaynak türü yoktur.

Çalışma Anı Yapılandırması
runkit İşlevleri
Yapılandırma/Kurulum


runkit İşlevleri

İçindekiler

  • Runkit_Sandbox — Runkit Sandbox Class -- PHP Virtual Machine
  • Runkit_Sandbox_Parent — Runkit Anti-Sandbox Class
  • runkit_class_adopt — Convert a base class to an inherited class, add ancestral methods when appropriate
  • runkit_class_emancipate — Convert an inherited class to a base class, removes any method whose scope is ancestral
  • runkit_constant_add — Similar to define(), but allows defining in class definitions as well
  • runkit_constant_redefine — Redefine an already defined constant
  • runkit_constant_remove — Remove/Delete an already defined constant
  • runkit_function_add — Add a new function, similar to create_function
  • runkit_function_copy — Copy a function to a new function name
  • runkit_function_redefine — Replace a function definition with a new implementation
  • runkit_function_remove — Remove a function definition
  • runkit_function_rename — Change a function's name
  • runkit_import — Process a PHP file importing function and class definitions, overwriting where appropriate
  • runkit_lint_file — Check the PHP syntax of the specified file
  • runkit_lint — Check the PHP syntax of the specified php code
  • runkit_method_add — Dynamically adds a new method to a given class
  • runkit_method_copy — Copies a method from class to another
  • runkit_method_redefine — Dynamically changes the code of the given method
  • runkit_method_remove — Dynamically removes the given method
  • runkit_method_rename — Dynamically changes the name of the given method
  • runkit_return_value_used — Determines if the current functions return value will be used
  • runkit_sandbox_output_handler — Specify a function to capture and/or process output from a runkit sandbox
  • runkit_superglobals — Return numerically indexed array of registered superglobals
Özkaynak Türleri
Runkit_Sandbox
runkit


Runkit Sandbox Class -- PHP Virtual Machine

runkit İşlevleri
Runkit_Sandbox_Parent
runkit İşlevleri
PHP Manual

Runkit_Sandbox

(PECL runkit >= 0.7.0)

Runkit_Sandbox — Runkit Sandbox Class -- PHP Virtual Machine

Açıklama

Instantiating the Runkit_Sandbox class creates a new thread with its own scope and program stack. Using a set of options passed to the constructor, this environment may be restricted to a subset of what the primary interpreter can do and provide a safer environment for executing user supplied code.

Bilginize: Sandbox support (required for runkit_lint(), runkit_lint_file(), and the Runkit_Sandbox class) is only available as of PHP 5.1.0 or specially patched versions of PHP 5.0, and requires that thread safety be enabled. See the README file included in the runkit package for more information.

Constructor

void Runkit_Sandbox::__construct ([ array $options ] )

options is an associative array containing any combination of the special ini options listed below.

safe_mode

If the outer script which is instantiating the Runkit_Sandbox class is configured with safe_mode = off, then safe_mode may be turned on for the sandbox environment. This setting can not be used to disable safe_mode when it's already enabled in the outer script.

safe_mode_gid

If the outer script which is instantiating the Runkit_Sandbox class is configured with safe_mode_gid = on, then safe_mode_gid may be turned off for the sandbox environment. This setting can not be used to enable safe_mode_gid when it's already disabled in the outer script.

safe_mode_include_dir

If the outer script which is instantiating the Runkit_Sandbox class is configured with a safe_mode_include_dir, then a new safe_mode_include_dir may be set for sandbox environments below the currently defined value. safe_mode_include_dir may also be cleared to indicate that the bypass feature is disabled. If safe_mode_include_dir was blank in the outer script, but safe_mode was not enabled, then any arbitrary safe_mode_include_dir may be set while turning safe_mode on.

open_basedir

open_basedir may be set to any path below the current setting of open_basedir. If open_basedir is not set within the global scope, then it is assumed to be the root directory and may be set to any location.

allow_url_fopen

Like safe_mode, this setting can only be made more restrictive, in this case by setting it to FALSE when it is previously set to TRUE

disable_functions

Comma separated list of functions to disable within the sandbox sub-interpreter. This list need not contain the names of the currently disabled functions, they will remain disabled whether listed here or not.

disable_classes

Comma separated list of classes to disable within the sandbox sub-interpreter. This list need not contain the names of the currently disabled classes, they will remain disabled whether listed here or not.

runkit.superglobal

Comma separated list of variables to be treated as superglobals within the sandbox sub-interpreter. These variables will be used in addition to any variables defined internally or through the global runkit.superglobal setting.

runkit.internal_override

Ini option runkit.internal_override may be disabled (but not re-enabled) within sandboxes.

Örnek 1 Instantiating a restricted sandbox

<?php
$options = array(
  'safe_mode'=>true,
  'open_basedir'=>'/var/www/users/jdoe/',
  'allow_url_fopen'=>'false',
  'disable_functions'=>'exec,shell_exec,passthru,system',
  'disable_classes'=>'myAppClass');
$sandbox = new Runkit_Sandbox($options);
/* Non-protected ini settings may set normally */
$sandbox->ini_set('html_errors',true);
?>

Accessing Variables

All variables in the global scope of the sandbox environment are accessible as properties of the sandbox object. The first thing to note is that because of the way memory between these two threads is managed, object and resource variables can not currently be exchanged between interpreters. Additionally, all arrays are deep copied and any references will be lost. This also means that references between interpreters are not possible.

Örnek 2 Working with variables in a sandbox

<?php
$sandbox = new Runkit_Sandbox();

$sandbox->foo = 'bar';
$sandbox->eval('echo "$foo\n"; $bar = $foo . "baz";');
echo "{$sandbox->bar}\n";
if (isset($sandbox->foo)) unset($sandbox->foo);
$sandbox->eval('var_dump(isset($foo));');
?>

Yukarıdaki örneğin çıktısı:

bar
barbaz
bool(false)

Calling PHP Functions

Any function defined within the sandbox may be called as a method on the sandbox object. This also includes a few pseudo-function language constructs: eval(), include, include_once, require, require_once, echo, print, die(), and exit().

Örnek 3 Calling sandbox functions

<?php
$sandbox = new Runkit_Sandbox();

echo $sandbox->str_replace('a','f','abc');
?>

Yukarıdaki örneğin çıktısı:

fbc

When passing arguments to a sandbox function, the arguments are taken from the outer instance of PHP. If you wish to pass arguments from the sandbox's scope, be sure to access them as properties of the sandbox object as illustrated above.

Örnek 4 Passing arguments to sandbox functions

<?php
$sandbox = new Runkit_Sandbox();

$foo = 'bar';
$sandbox->foo = 'baz';
echo $sandbox->str_replace('a',$foo,'a');
echo $sandbox->str_replace('a',$sandbox->foo,'a');
?>

Yukarıdaki örneğin çıktısı:

bar
baz

Changing Sandbox Settings

As of runkit version 0.5, certain Sandbox settings may be modified on the fly using ArrayAccess syntax. Some settings, such as active are read-only and meant to provide status information. Other settings, such as output_handler may be set and read much like a normal array offset. Future settings may be write-only, however no such settings currently exist.

Sandbox Settings / Status Indicators
Setting | Type | Purpose | Default
active | Boolean (Read Only) | TRUE if the Sandbox is still in a usable state, FALSE if the request is in bailout due to a call to die(), exit(), or because of a fatal error condition. | TRUE (Initial)
output_handler | Callback | When set to a valid callback, all output generated by the Sandbox instance will be processed through the named function. Sandbox output handlers follow the same calling conventions as the system-wide output handler. | None
parent_access | Boolean | May the sandbox use instances of the Runkit_Sandbox_Parent class? Must be enabled for other Runkit_Sandbox_Parent related settings to work. | FALSE
parent_read | Boolean | May the sandbox read variables in its parent's context? | FALSE
parent_write | Boolean | May the sandbox modify variables in its parent's context? | FALSE
parent_eval | Boolean | May the sandbox evaluate arbitrary code in its parent's context? DANGEROUS | FALSE
parent_include | Boolean | May the sandbox include php code files in its parent's context? DANGEROUS | FALSE
parent_echo | Boolean | May the sandbox echo data in its parent's context effectively bypassing its own output_handler? | FALSE
parent_call | Boolean | May the sandbox call functions in its parent's context? | FALSE
parent_die | Boolean | May the sandbox kill its own parent? (And thus itself) | FALSE
parent_scope | Integer | What scope will parental property access look at? 0 == Global scope, 1 == Calling scope, 2 == Scope preceding calling scope, 3 == The scope before that, etc..., etc... | 0 (Global)
parent_scope | String | When parent_scope is set to a string value, it refers to a named array variable in the global scope. If the named variable does not exist at the time of access it will be created as an empty array. If the variable exists but it not an array, a dummy array will be created containing a reference to the named global variable. |

runkit İşlevleri
Runkit_Sandbox_Parent
runkit İşlevleri


Runkit Anti-Sandbox Class

Runkit_Sandbox
runkit_class_adopt
runkit İşlevleri
PHP Manual

Runkit_Sandbox_Parent

(PECL runkit >= 0.7.0)

Runkit_Sandbox_Parent — Runkit Anti-Sandbox Class

Açıklama

void Runkit_Sandbox_Parent::__construct ( void )

Instantiating the Runkit_Sandbox_Parent class from within a sandbox environment created from the Runkit_Sandbox class provides some (controlled) means for a sandbox child to access its parent.

Bilginize: Sandbox support (required for runkit_lint(), runkit_lint_file(), and the Runkit_Sandbox class) is only available as of PHP 5.1.0 or specially patched versions of PHP 5.0, and requires that thread safety be enabled. See the README file included in the runkit package for more information.

In order for any of the Runkit_Sandbox_Parent features to function. Support must be enabled on a per-sandbox basis by enabling the parent_access flag from the parent's context.

Örnek 1 Working with variables in a sandbox

<?php
$sandbox = new Runkit_Sandbox();
$sandbox['parent_access'] = true;
?>

Accessing the Parent's Variables

Just as with sandbox variable access, a sandbox parent's variables may be read from and written to as properties of the Runkit_Sandbox_Parent class. Read access to parental variables may be enabled with the parent_read setting (in addition to the base parent_access setting). Write access, in turn, is enabled through the parent_write setting.

Unlike sandbox child variable access, the variable scope is not limited to globals only. By setting the parent_scope setting to an appropriate integer value, other scopes in the active call stack may be inspected instead. A value of 0 (Default) will direct variable access at the global scope. 1 will point variable access at whatever variable scope was active at the time the current block of sandbox code was executed. Higher values progress back through the functions that called the functions that led to the sandbox executing code that tried to access its own parent's variables.

Örnek 2 Accessing parental variables

<?php
$php = new Runkit_Sandbox();
$php['parent_access'] = true;
$php['parent_read'] = true;

$test = "Global";

$php->eval('$PARENT = new Runkit_Sandbox_Parent;');

$php['parent_scope'] = 0;
one();

$php['parent_scope'] = 1;
one();

$php['parent_scope'] = 2;
one();

$php['parent_scope'] = 3;
one();

$php['parent_scope'] = 4;
one();

$php['parent_scope'] = 5;
one();

function one() {
    $test = "one()";
    two();
}

function two() {
    $test = "two()";
    three();
}

function three() {
    $test = "three()";
    $GLOBALS['php']->eval('var_dump($PARENT->test);');
}
?>

Yukarıdaki örneğin çıktısı:

string(6) "Global"
string(7) "three()"
string(5) "two()"
string(5) "one()"
string(6) "Global"
string(6) "Global"

Calling the Parent's Functions

Just as with sandbox access, a sandbox may access its parents functions providing that the proper settings have been enabled. Enabling parent_call will allow the sandbox to call all functions available to the parent scope. Language constructs are each controlled by their own setting: print and echo are enabled with parent_echo. die() and exit() are enabled with parent_die. eval() is enabled with parent_eval while include, include_once, require, and require_once are enabled through parent_include.

Runkit_Sandbox
runkit_class_adopt
runkit İşlevleri


Convert a base class to an inherited class, add ancestral methods when appropriate

Runkit_Sandbox_Parent
runkit_class_emancipate
runkit İşlevleri
PHP Manual

runkit_class_adopt

(PECL runkit >= 0.7.0)

runkit_class_adopt — Convert a base class to an inherited class, add ancestral methods when appropriate

Açıklama

bool runkit_class_adopt ( string $classname , string $parentname )

Değiştirgeler

classname

Name of class to be adopted

parentname

Parent class which child class is extending

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 A runkit_class_adopt() example

<?php
class myParent {
  function parentFunc() {
    echo "Parent Function Output\n";
  }
}

class myChild {
}

runkit_class_adopt('myChild','myParent');
myChild::parentFunc();
?>

Yukarıdaki örneğin çıktısı:

Parent Function Output

Ayrıca Bakınız

  • runkit_class_emancipate() - Convert an inherited class to a base class, removes any method whose scope is ancestral

Runkit_Sandbox_Parent
runkit_class_emancipate
runkit İşlevleri


Convert an inherited class to a base class, removes any method whose scope is ancestral

runkit_class_adopt
runkit_constant_add
runkit İşlevleri
PHP Manual

runkit_class_emancipate

(PECL runkit >= 0.7.0)

runkit_class_emancipate — Convert an inherited class to a base class, removes any method whose scope is ancestral

Açıklama

bool runkit_class_emancipate ( string $classname )

Değiştirgeler

classname

Name of class to emancipate

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 A runkit_class_emancipate() example

<?php
class myParent {
  function parentFunc () {
    echo "Parent Function Output\n";
  }
}
class myChild extends myParent {
}

myChild::parentFunc();
runkit_class_emancipate('myChild');
myChild::parentFunc();
?>

Yukarıdaki örneğin çıktısı:

Parent Function Output
Fatal error: Call to undefined function:  parentFunc() in example.php on line 12

Ayrıca Bakınız

  • runkit_class_adopt() - Convert a base class to an inherited class, add ancestral methods when appropriate

runkit_class_adopt
runkit_constant_add
runkit İşlevleri


Similar to define(), but allows defining in class definitions as well

runkit_class_emancipate
runkit_constant_redefine
runkit İşlevleri
PHP Manual

runkit_constant_add

(PECL runkit >= 0.7.0)

runkit_constant_add — Similar to define(), but allows defining in class definitions as well

Açıklama

bool runkit_constant_add ( string $constname , mixed $value )

Değiştirgeler

constname

Name of constant to declare. Either a string to indicate a global constant, or classname::constname to indicate a class constant.

value

NULL, Bool, Long, Double, String, or Resource value to store in the new constant.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • define() - Bir isimli sabit tanımlar
  • runkit_constant_redefine() - Redefine an already defined constant
  • runkit_constant_remove() - Remove/Delete an already defined constant

runkit_class_emancipate
runkit_constant_redefine
runkit İşlevleri


Redefine an already defined constant

runkit_constant_add
runkit_constant_remove
runkit İşlevleri
PHP Manual

runkit_constant_redefine

(PECL runkit >= 0.7.0)

runkit_constant_redefine — Redefine an already defined constant

Açıklama

bool runkit_constant_redefine ( string $constname , mixed $newvalue )

Değiştirgeler

constname

Constant to redefine. Either string indicating global constant, or classname::constname indicating class constant.

newvalue

New value to assign to constant.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • runkit_constant_add() - Similar to define(), but allows defining in class definitions as well
  • runkit_constant_remove() - Remove/Delete an already defined constant

runkit_constant_add
runkit_constant_remove
runkit İşlevleri


Remove/Delete an already defined constant

runkit_constant_redefine
runkit_function_add
runkit İşlevleri
PHP Manual

runkit_constant_remove

(PECL runkit >= 0.7.0)

runkit_constant_remove — Remove/Delete an already defined constant

Açıklama

bool runkit_constant_remove ( string $constname )

Değiştirgeler

constname

Name of constant to remove. Either a string indicating a global constant, or classname::constname indicating a class constant.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • define() - Bir isimli sabit tanımlar
  • runkit_constant_add() - Similar to define(), but allows defining in class definitions as well
  • runkit_constant_redefine() - Redefine an already defined constant

runkit_constant_redefine
runkit_function_add
runkit İşlevleri


Add a new function, similar to create_function

runkit_constant_remove
runkit_function_copy
runkit İşlevleri
PHP Manual

runkit_function_add

(PECL runkit >= 0.7.0)

runkit_function_add — Add a new function, similar to create_function()

Açıklama

bool runkit_function_add ( string $funcname , string $arglist , string $code [, bool $return_by_reference = NULL [, string $doc_comment = NULL ]] )
bool runkit_function_add ( string $funcname , Closure $closure [, string $doc_comment = NULL ] )

Değiştirgeler

funcname

Name of function to be created

arglist

Comma separated argument list

code

Code making up the function

closure

A closure that defines the function.

return_by_reference

Whether the function should return by reference.

doc_comment

The doc comment of the function.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
runkit 1.0.4 | An alternative syntax expecting a closure has been added.
runkit 1.0.4 | The optional parameters return_by_reference and doc_comment have been added.

Örnekler

Örnek 1 A runkit_function_add() example

<?php
runkit_function_add('testme','$a,$b','echo "The value of a is $a\n"; echo "The value of b is $b\n";');
testme(1,2);
?>

Yukarıdaki örneğin çıktısı:

The value of a is 1
The value of b is 2

Ayrıca Bakınız

  • create_function() - Bir anonim (lamda tarzı) işlev oluşturur
  • runkit_function_redefine() - Replace a function definition with a new implementation
  • runkit_function_copy() - Copy a function to a new function name
  • runkit_function_rename() - Change a function's name
  • runkit_function_remove() - Remove a function definition
  • runkit_method_add() - Dynamically adds a new method to a given class

runkit_constant_remove
runkit_function_copy
runkit İşlevleri


Copy a function to a new function name

runkit_function_add
runkit_function_redefine
runkit İşlevleri
PHP Manual

runkit_function_copy

(PECL runkit >= 0.7.0)

runkit_function_copy — Copy a function to a new function name

Açıklama

bool runkit_function_copy ( string $funcname , string $targetname )

Değiştirgeler

funcname

Name of existing function

targetname

Name of new function to copy definition to

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 A runkit_function_copy() example

<?php
function original() {
  echo "In a function\n";
}
runkit_function_copy('original','duplicate');
original();
duplicate();
?>

Yukarıdaki örneğin çıktısı:

In a function
In a function

Ayrıca Bakınız

  • runkit_function_add() - Add a new function, similar to create_function
  • runkit_function_redefine() - Replace a function definition with a new implementation
  • runkit_function_rename() - Change a function's name
  • runkit_function_remove() - Remove a function definition

runkit_function_add
runkit_function_redefine
runkit İşlevleri


Replace a function definition with a new implementation

runkit_function_copy
runkit_function_remove
runkit İşlevleri
PHP Manual

runkit_function_redefine

(PECL runkit >= 0.7.0)

runkit_function_redefine — Replace a function definition with a new implementation

Açıklama

bool runkit_function_redefine ( string $funcname , string $arglist , string $code [, bool $return_by_reference = NULL [, string $doc_comment = NULL ]] )
bool runkit_function_redefine ( string $funcname , Closure $closure [, string $doc_comment = NULL ] )

Bilginize: By default, only userspace functions may be removed, renamed, or modified. In order to override internal functions, you must enable the runkit.internal_override setting in php.ini.

Değiştirgeler

funcname

Name of function to redefine

arglist

New list of arguments to be accepted by function

code

New code implementation

closure

A closure that defines the function.

return_by_reference

Whether the function should return by reference.

doc_comment

The doc comment of the function.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
runkit 1.0.4 | An alternative syntax expecting a closure has been added.
runkit 1.0.4 | The optional parameters return_by_reference and doc_comment have been added.

Örnekler

Örnek 1 A runkit_function_redefine() example

<?php
function testme() {
  echo "Original Testme Implementation\n";
}
testme();
runkit_function_redefine('testme','','echo "New Testme Implementation\n";');
testme();
?>

Yukarıdaki örneğin çıktısı:

Original Testme Implementation
New Testme Implementation

Ayrıca Bakınız

  • runkit_function_add() - Add a new function, similar to create_function
  • runkit_function_copy() - Copy a function to a new function name
  • runkit_function_rename() - Change a function's name
  • runkit_function_remove() - Remove a function definition
  • runkit_method_redefine() - Dynamically changes the code of the given method

runkit_function_copy
runkit_function_remove
runkit İşlevleri


Remove a function definition

runkit_function_redefine
runkit_function_rename
runkit İşlevleri
PHP Manual

runkit_function_remove

(PECL runkit >= 0.7.0)

runkit_function_remove — Remove a function definition

Açıklama

bool runkit_function_remove ( string $funcname )

Bilginize: By default, only userspace functions may be removed, renamed, or modified. In order to override internal functions, you must enable the runkit.internal_override setting in php.ini.

Değiştirgeler

funcname

Name of function to be deleted

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • runkit_function_add() - Add a new function, similar to create_function
  • runkit_function_copy() - Copy a function to a new function name
  • runkit_function_redefine() - Replace a function definition with a new implementation
  • runkit_function_rename() - Change a function's name

runkit_function_redefine
runkit_function_rename
runkit İşlevleri


Change a function's name

runkit_function_remove
runkit_import
runkit İşlevleri
PHP Manual

runkit_function_rename

(PECL runkit >= 0.7.0)

runkit_function_rename — Change a function's name

Açıklama

bool runkit_function_rename ( string $funcname , string $newname )

Bilginize: By default, only userspace functions may be removed, renamed, or modified. In order to override internal functions, you must enable the runkit.internal_override setting in php.ini.

Değiştirgeler

funcname

Current function name

newname

New function name

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • runkit_function_add() - Add a new function, similar to create_function
  • runkit_function_copy() - Copy a function to a new function name
  • runkit_function_redefine() - Replace a function definition with a new implementation
  • runkit_function_remove() - Remove a function definition

runkit_function_remove
runkit_import
runkit İşlevleri


Process a PHP file importing function and class definitions, overwriting where appropriate

runkit_function_rename
runkit_lint_file
runkit İşlevleri
PHP Manual

runkit_import

(PECL runkit >= 0.7.0)

runkit_import — Process a PHP file importing function and class definitions, overwriting where appropriate

Açıklama

bool runkit_import ( string $filename [, int $flags = RUNKIT_IMPORT_CLASS_METHODS ] )

Similar to include however any code residing outside of a function or class is simply ignored. Additionally, depending on the value of flags, any functions or classes which already exist in the currently running environment may be automatically overwritten by their new definitions.

Değiştirgeler

filename

Filename to import function and class definitions from

flags

Bitwise OR of the RUNKIT_IMPORT_* family of constants.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 runkit_import() example

<?php
// import classes entirely
runkit_import('myfile.inc', RUNKIT_IMPORT_CLASSES);

/* import classes, but not imports their static properties
   (RUNKIT_IMPORT_CLASS_STATIC_PROPS is available since 1.0.1) */
runkit_import('myfile.inc', RUNKIT_IMPORT_CLASSES & ~RUNKIT_IMPORT_CLASS_STATIC_PROPS);

/* import only static properties of classes
   (RUNKIT_IMPORT_CLASS_STATIC_PROPS is available since 1.0.1) */
runkit_import('myfile.inc', RUNKIT_IMPORT_CLASS_STATIC_PROPS);
?>

runkit_function_rename
runkit_lint_file
runkit İşlevleri


Check the PHP syntax of the specified file

runkit_import
runkit_lint
runkit İşlevleri
PHP Manual

runkit_lint_file

(PECL runkit >= 0.7.0)

runkit_lint_file — Check the PHP syntax of the specified file

Açıklama

bool runkit_lint_file ( string $filename )

The runkit_lint_file() function performs a syntax (lint) check on the specified filename testing for scripting errors. This is similar to using php -l from the commandline.

Bilginize: Sandbox support (required for runkit_lint(), runkit_lint_file(), and the Runkit_Sandbox class) is only available as of PHP 5.1.0 or specially patched versions of PHP 5.0, and requires that thread safety be enabled. See the README file included in the runkit package for more information.

Değiştirgeler

filename

File containing PHP Code to be lint checked

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • runkit_lint() - Check the PHP syntax of the specified php code

runkit_import
runkit_lint
runkit İşlevleri


Check the PHP syntax of the specified php code

runkit_lint_file
runkit_method_add
runkit İşlevleri
PHP Manual

runkit_lint

(PECL runkit >= 0.7.0)

runkit_lint — Check the PHP syntax of the specified php code

Açıklama

bool runkit_lint ( string $code )

The runkit_lint() function performs a syntax (lint) check on the specified php code testing for scripting errors. This is similar to using php -l from the command line except runkit_lint() accepts actual code rather than a filename.

Bilginize: Sandbox support (required for runkit_lint(), runkit_lint_file(), and the Runkit_Sandbox class) is only available as of PHP 5.1.0 or specially patched versions of PHP 5.0, and requires that thread safety be enabled. See the README file included in the runkit package for more information.

Değiştirgeler

code

PHP Code to be lint checked

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • runkit_lint_file() - Check the PHP syntax of the specified file

runkit_lint_file
runkit_method_add
runkit İşlevleri


Dynamically adds a new method to a given class

runkit_lint
runkit_method_copy
runkit İşlevleri
PHP Manual

runkit_method_add

(PECL runkit >= 0.7.0)

runkit_method_add — Dynamically adds a new method to a given class

Açıklama

bool runkit_method_add ( string $classname , string $methodname , string $args , string $code [, int $flags = RUNKIT_ACC_PUBLIC [, string $doc_comment = NULL ]] )
bool runkit_method_add ( string $classname , string $methodname , Closure $closure [, int $flags = RUNKIT_ACC_PUBLIC [, string $doc_comment = NULL ]] )

Değiştirgeler

classname

The class to which this method will be added

methodname

The name of the method to add

args

Comma-delimited list of arguments for the newly-created method

code

The code to be evaluated when methodname is called

closure

A closure that defines the method.

flags

The type of method to create, can be RUNKIT_ACC_PUBLIC, RUNKIT_ACC_PROTECTED or RUNKIT_ACC_PRIVATE optionally combined via bitwise OR with RUNKIT_ACC_STATIC (since 1.0.1)

Bilginize:

This parameter is only used as of PHP 5, because, prior to this, all methods were public.

doc_comment

The doc comment of the function.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
runkit 1.0.4 | An alternative syntax expecting a closure has been added.
runkit 1.0.4 | The optional parameter doc_comment has been added.

Örnekler

Örnek 1 runkit_method_add() example

<?php
class Example {
    function foo() {
        echo "foo!\n";
    }
}

// create an Example object
$e = new Example();

// Add a new public method
runkit_method_add(
    'Example',
    'add',
    '$num1, $num2',
    'return $num1 + $num2;',
    RUNKIT_ACC_PUBLIC
);

// add 12 + 4
echo $e->add(12, 4);
?>

Yukarıdaki örneğin çıktısı:

16

Ayrıca Bakınız

  • runkit_method_copy() - Copies a method from class to another
  • runkit_method_redefine() - Dynamically changes the code of the given method
  • runkit_method_remove() - Dynamically removes the given method
  • runkit_method_rename() - Dynamically changes the name of the given method
  • runkit_function_add() - Add a new function, similar to create_function

runkit_lint
runkit_method_copy
runkit İşlevleri


Copies a method from class to another

runkit_method_add
runkit_method_redefine
runkit İşlevleri
PHP Manual

runkit_method_copy

(PECL runkit >= 0.7.0)

runkit_method_copy — Copies a method from class to another

Açıklama

bool runkit_method_copy ( string $dClass , string $dMethod , string $sClass [, string $sMethod ] )

Değiştirgeler

dClass

Destination class for copied method

dMethod

Destination method name

sClass

Source class of the method to copy

sMethod

Name of the method to copy from the source class. If this parameter is omitted, the value of dMethod is assumed.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 runkit_method_copy() example

<?php
class Foo {
    function example() {
        return "foo!\n";
    }
}

class Bar {
    // initially, no methods
}

// copy the example() method from the Foo class to the Bar class, as baz()
runkit_method_copy('Bar', 'baz', 'Foo', 'example');

// output copied function
echo Bar::baz();
?>

Yukarıdaki örneğin çıktısı:

foo!

Ayrıca Bakınız

  • runkit_method_add() - Dynamically adds a new method to a given class
  • runkit_method_redefine() - Dynamically changes the code of the given method
  • runkit_method_remove() - Dynamically removes the given method
  • runkit_method_rename() - Dynamically changes the name of the given method
  • runkit_function_copy() - Copy a function to a new function name

runkit_method_add
runkit_method_redefine
runkit İşlevleri


Dynamically changes the code of the given method

runkit_method_copy
runkit_method_remove
runkit İşlevleri
PHP Manual

runkit_method_redefine

(PECL runkit >= 0.7.0)

runkit_method_redefine — Dynamically changes the code of the given method

Açıklama

bool runkit_method_redefine ( string $classname , string $methodname , string $args , string $code [, int $flags = RUNKIT_ACC_PUBLIC [, string $doc_comment = NULL ]] )
bool runkit_method_redefine ( string $classname , string $methodname , Closure $closure [, int $flags = RUNKIT_ACC_PUBLIC [, string $doc_comment = NULL ]] )

Bilginize: Bu işlev çalışmakta olan yöntemi değiştirmekte kullanılamaz.

Değiştirgeler

classname

The class in which to redefine the method

methodname

The name of the method to redefine

args

Comma-delimited list of arguments for the redefined method

code

The new code to be evaluated when methodname is called

closure

A closure that defines the method.

flags

The redefined method can be RUNKIT_ACC_PUBLIC, RUNKIT_ACC_PROTECTED or RUNKIT_ACC_PRIVATE optionally combined via bitwise OR with RUNKIT_ACC_STATIC (since 1.0.1)

doc_comment

The doc comment of the function.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
runkit 1.0.4 | An alternative syntax expecting a closure has been added.
runkit 1.0.4 | The optional parameter doc_comment has been added.

Örnekler

Örnek 1 runkit_method_redefine() example

<?php
class Example {
    function foo() {
        return "foo!\n";
    }
}

// create an Example object
$e = new Example();

// output Example::foo() (before redefine)
echo "Before: " . $e->foo();

// Redefine the 'foo' method
runkit_method_redefine(
    'Example',
    'foo',
    '',
    'return "bar!\n";',
    RUNKIT_ACC_PUBLIC
);

// output Example::foo() (after redefine)
echo "After: " . $e->foo();
?>

Yukarıdaki örneğin çıktısı:

Before: foo!
After: bar!

Ayrıca Bakınız

  • runkit_method_add() - Dynamically adds a new method to a given class
  • runkit_method_copy() - Copies a method from class to another
  • runkit_method_remove() - Dynamically removes the given method
  • runkit_method_rename() - Dynamically changes the name of the given method
  • runkit_function_redefine() - Replace a function definition with a new implementation

runkit_method_copy
runkit_method_remove
runkit İşlevleri


Dynamically removes the given method

runkit_method_redefine
runkit_method_rename
runkit İşlevleri
PHP Manual

runkit_method_remove

(PECL runkit >= 0.7.0)

runkit_method_remove — Dynamically removes the given method

Açıklama

bool runkit_method_remove ( string $classname , string $methodname )

Bilginize: Bu işlev çalışmakta olan yöntemi değiştirmekte kullanılamaz.

Değiştirgeler

classname

The class in which to remove the method

methodname

The name of the method to remove

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 runkit_method_remove() example

<?php
class Example {
    function foo() {
        return "foo!\n";
    }

    function bar() {
        return "bar!\n";
    }
}

// Remove the 'foo' method
runkit_method_remove(
    'Example',
    'foo'
);

echo implode(' ', get_class_methods('Example'));

?>

Yukarıdaki örneğin çıktısı:

bar

Ayrıca Bakınız

  • runkit_method_add() - Dynamically adds a new method to a given class
  • runkit_method_copy() - Copies a method from class to another
  • runkit_method_redefine() - Dynamically changes the code of the given method
  • runkit_method_rename() - Dynamically changes the name of the given method
  • runkit_function_remove() - Remove a function definition

runkit_method_redefine
runkit_method_rename
runkit İşlevleri


Dynamically changes the name of the given method

runkit_method_remove
runkit_return_value_used
runkit İşlevleri
PHP Manual

runkit_method_rename

(PECL runkit >= 0.7.0)

runkit_method_rename — Dynamically changes the name of the given method

Açıklama

bool runkit_method_rename ( string $classname , string $methodname , string $newname )

Bilginize: Bu işlev çalışmakta olan yöntemi değiştirmekte kullanılamaz.

Değiştirgeler

classname

The class in which to rename the method

methodname

The name of the method to rename

newname

The new name to give to the renamed method

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 runkit_method_rename() example

<?php
class Example {
    function foo() {
        return "foo!\n";
    }
}

// Rename the 'foo' method to 'bar'
runkit_method_rename(
    'Example',
    'foo',
    'bar'
);

// output renamed function
echo Example::bar();
?>

Yukarıdaki örneğin çıktısı:

foo!

Ayrıca Bakınız

  • runkit_method_add() - Dynamically adds a new method to a given class
  • runkit_method_copy() - Copies a method from class to another
  • runkit_method_redefine() - Dynamically changes the code of the given method
  • runkit_method_remove() - Dynamically removes the given method
  • runkit_function_rename() - Change a function's name

runkit_method_remove
runkit_return_value_used
runkit İşlevleri


Determines if the current functions return value will be used

runkit_method_rename
runkit_sandbox_output_handler
runkit İşlevleri
PHP Manual

runkit_return_value_used

(PECL runkit >= 0.8.0)

runkit_return_value_used — Determines if the current functions return value will be used

Açıklama

bool runkit_return_value_used ( void )

Dönen Değerler

Returns TRUE if the function's return value is used by the calling scope, otherwise FALSE

Örnekler

Örnek 1 runkit_return_value_used() example

<?php
function foo() {
  var_dump(runkit_return_value_used());
}

foo();
$f = foo();
?>

Yukarıdaki örneğin çıktısı:

bool(false)
bool(true)

runkit_method_rename
runkit_sandbox_output_handler
runkit İşlevleri


Specify a function to capture and/or process output from a runkit sandbox

runkit_return_value_used
runkit_superglobals
runkit İşlevleri
PHP Manual

runkit_sandbox_output_handler

(PECL runkit >= 0.7.0)

runkit_sandbox_output_handler — Specify a function to capture and/or process output from a runkit sandbox

Açıklama

mixed runkit_sandbox_output_handler ( object $sandbox [, mixed $callback ] )

Ordinarily, anything output (such as with echo or print) will be output as though it were printed from the parent's scope. Using runkit_sandbox_output_handler() however, output generated by the sandbox (including errors), can be captured by a function outside of the sandbox.

Bilginize: Sandbox support (required for runkit_lint(), runkit_lint_file(), and the Runkit_Sandbox class) is only available as of PHP 5.1.0 or specially patched versions of PHP 5.0, and requires that thread safety be enabled. See the README file included in the runkit package for more information.

Bilginize: Deprecated

As of runkit version 0.5, this function is deprecated and is scheduled to be removed from the package prior to a 1.0 release. The output handler for a given Runkit_Sandbox instance may be read/set using the array offset syntax shown on the Runkit_Sandbox class definition page.

Değiştirgeler

sandbox

Object instance of Runkit_Sandbox class on which to set output handling.

callback

Name of a function which expects one parameter. Output generated by sandbox will be passed to this callback. Anything returned by the callback will be displayed normally. If this parameter is not passed then output handling will not be changed. If a non-truth value is passed, output handling will be disabled and will revert to direct display.

Dönen Değerler

Returns the name of the previously defined output handler callback, or FALSE if no handler was previously defined.

Örnekler

Örnek 1 Feeding output to a variable

<?php
function capture_output($str) {
  $GLOBALS['sandbox_output'] .= $str;

  return '';
}

$sandbox_output = '';

$php = new Runkit_Sandbox();
runkit_sandbox_output_handler($php, 'capture_output');
$php->echo("Hello\n");
$php->eval('var_dump("Excuse me");');
$php->die("I lost myself.");
unset($php);

echo "Sandbox Complete\n\n";
echo $sandbox_output;
?>

Yukarıdaki örneğin çıktısı:

Sandbox Complete

Hello
string(9) "Excuse me"
I lost myself.

runkit_return_value_used
runkit_superglobals
runkit İşlevleri


Return numerically indexed array of registered superglobals

runkit_sandbox_output_handler
scream
runkit İşlevleri
PHP Manual

runkit_superglobals

(PECL runkit >= 0.7.0)

runkit_superglobals — Return numerically indexed array of registered superglobals

Açıklama

array runkit_superglobals ( void )

Dönen Değerler

Returns a numerically indexed array of the currently registered superglobals. i.e. _GET, _POST, _REQUEST, _COOKIE, _SESSION, _SERVER, _ENV, _FILES

Ayrıca Bakınız

  • Variable Scope

runkit_sandbox_output_handler
scream
runkit İşlevleri


Break the silence operator

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Örnekler
    • Example that shows the effect of scream
runkit_superglobals
Giriş
PHP'nin Davranışını Etkileyenler


Giriş

The scream extension gives the possibility to disable the silencing error control operator so all errors are being reported. This feature is controlled by an ini setting.

scream
Yapılandırma/Kurulum
scream


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
scream


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/scream

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

scream Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Changelog
scream.enabled | Off | PHP_INI_ALL |
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

scream.enabled int

Whether or not to enable scream.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Özkaynak Türleri

Bu eklentinin tanımlı hiçbir özkaynak türü yoktur.

Çalışma Anı Yapılandırması
Örnekler
Yapılandırma/Kurulum


Örnekler

İçindekiler

  • Example that shows the effect of scream
Özkaynak Türleri
Example that shows the effect of scream
scream


Example that shows the effect of scream

This example demonstrates how scream affects the behaviour of PHP's error handler.

Örnek 1 Enabling and disabling scream at runtime

<?php
// Make sure errors will be shown
ini_set('display_errors', true);
error_reporting(E_ALL);

// Disable scream - this is the default and produce an error
ini_set('scream.enabled', false);
echo "Opening http://example.com/not-existing-file\n";
@fopen('http://example.com/not-existing-file', 'r');

// Now enable scream and try again
ini_set('scream.enabled', true);
echo "Opening http://example.com/not-existing-file\n";
@fopen('http://example.com/not-existing-file', 'r');
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Opening http://example.com/not-existing-file
Opening http://example.com/not-existing-file

Warning: fopen(http://example.com/not-existing-file): failed to open stream: HTTP request failed! HTTP/1.1 404 Not Found in example.php on line 14

Bilginize: Usually one would set this in the php.ini configuration file instead of changing the code.

Örnekler
uopz
Örnekler


uopz

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Uopz İşlevleri
    • uopz_backup — Backup a function
    • uopz_compose — Compose a class
    • uopz_copy — Copy a function
    • uopz_delete — Delete a function
    • uopz_extend — Extend a class at runtime
    • uopz_flags — Get or set flags on function or class
    • uopz_function — Creates a function at runtime
    • uopz_implement — Implements an interface at runtime
    • uopz_overload — Overload a VM opcode
    • uopz_redefine — Redefine a constant
    • uopz_rename — Rename a function at runtime
    • uopz_restore — Restore a previously backed up function
    • uopz_undefine — Undefine a constant
Example that shows the effect of scream
Giriş
PHP'nin Davranışını Etkileyenler


Giriş

The uopz - User Operations for Zend - extension exposes Zend Engine functionality normally used at compilation and execution time in order to allow modification of the internal structures that represent PHP code, and for user code to interact with the VM.

uopz supports the following activities:

  • Overloading some opcodes including ZEND_EXIT and ZEND_NEW
  • Backup and restore functions and methods
  • Renaming functions and methods
  • Copying of functions and methods
  • Deletion of functions and methods
  • Redefinition of global and class constants
  • Deletion of global and class constants
  • Runtime composition and modification of classes

Bilginize:

All of the activities supported are compatible with opcache

uopz
Yapılandırma/Kurulum
uopz


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
uopz


Gereksinimler

uopz requires 5.4+

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

uopz releases are hosted by PECL and the source code by » github, the easiest route to installation is the normal PECL route: » http://pecl.php.net/package/uopz.

Windows users can download prebuilt release binaries from the » PECL website.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

uopz must be loaded as a zend_extension

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

The following opcodes are defined as constants by uopz:

ZEND_EXIT (integer)
Invoked by exit() and die(), recieves no arguments. Return boolean TRUE to exit, FALSE to continue
ZEND_NEW (integer)
Invoked by object construction, receives the class of object being created as the only argument
ZEND_THROW (integer)
Invoked by the throw construct, receives the class of exception being thrown as the only argument
ZEND_FETCH_CLASS (integer)
Invoked upon composure, recieves the class the name of the class being fetched as the only argument
ZEND_ADD_TRAIT (integer)
Invoked upon composure, recieves the class the trait is being added to as the first argument, and the name of the trait as the second argument
ZEND_ADD_INTERFACE (integer)
Invoked upon composure, recieves the class the interface is being added to as the first argument, and the name of the interface as the second argument
ZEND_INSTANCEOF (integer)
Invoked by instanceof operator, recieves the object being verified as the first argument, and the name of the class which that object should be as the second argument

The following constants control the VM's behaviour after a user handler is invoked, be extremely careful!

ZEND_USER_OPCODE_CONTINUE (integer)
Advance 1 opcode and continuue
ZEND_USER_OPCODE_ENTER (integer)
Enter into new op_array without recursion
ZEND_USER_OPCODE_LEAVE (integer)
Return to calling op_array within the same executor
ZEND_USER_OPCODE_DISPATCH (integer)
Dispatch to original opcode handler
ZEND_USER_OPCODE_DISPATCH_TO (integer)
Dispatch to a specific handler (OR'd with ZEND opcode constant)
ZEND_USER_OPCODE_RETURN (integer)
Exit from executor (return from function)

The following modifiers are registered as constants by uopz

ZEND_ACC_PUBLIC (integer)
Mark function as public, the default
ZEND_ACC_PROTECTED (integer)
Mark function as protected
ZEND_ACC_PRIVATE (integer)
Mark function as private
ZEND_ACC_STATIC (integer)
Mark function as static
ZEND_ACC_FINAL (integer)
Mark function as final
ZEND_ACC_ABSTRACT (integer)
Mark function as abstract
ZEND_ACC_CLASS (integer)
Dummy registered for consistency, the default kind of class entry
ZEND_ACC_INTERFACE (integer)
Mark class as interface
ZEND_ACC_TRAIT (integer)
Mark class as trait
ZEND_ACC_FETCH (integer)
Used for getting flags only

Özkaynak Türleri
Uopz İşlevleri
uopz


Uopz İşlevleri

İçindekiler

  • uopz_backup — Backup a function
  • uopz_compose — Compose a class
  • uopz_copy — Copy a function
  • uopz_delete — Delete a function
  • uopz_extend — Extend a class at runtime
  • uopz_flags — Get or set flags on function or class
  • uopz_function — Creates a function at runtime
  • uopz_implement — Implements an interface at runtime
  • uopz_overload — Overload a VM opcode
  • uopz_redefine — Redefine a constant
  • uopz_rename — Rename a function at runtime
  • uopz_restore — Restore a previously backed up function
  • uopz_undefine — Undefine a constant
Öntanımlı Sabitler
uopz_backup
uopz


Backup a function

Uopz İşlevleri
uopz_compose
Uopz İşlevleri
PHP Manual

uopz_backup

(PECL uopz >= 1.0.3)

uopz_backup — Backup a function

Açıklama

void uopz_backup ( string $class , string $function )
void uopz_backup ( string $function )

Backup a function at runtime, to be restored on shutdown

Değiştirgeler

class

The name of the class containing the function to backup

function

The name of the function

Dönen Değerler

Örnekler

Örnek 1 uopz_backup() example

<?php
uopz_backup("fgets");
uopz_function("fgets", function(){
    return true;
});
var_dump(fgets());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(true)
Uopz İşlevleri
uopz_compose
Uopz İşlevleri


Compose a class

uopz_backup
uopz_copy
Uopz İşlevleri
PHP Manual

uopz_compose

(PECL uopz >= 1.0.0)

uopz_compose — Compose a class

Açıklama

void uopz_compose ( string $name , array $classes [, array $methods [, array $properties [, int $flags ]]] )

Creates a new class of the given name that implements, extends, or uses all of the provided classes

Değiştirgeler

name

A legal class name

classes

An array of class, interface and trait names

methods

An associative array of methods, values are either closures or [modifiers => closure]

properties

An associative array of properties, keys are names, values are modifiers

flags

Entry type, by default ZEND_ACC_CLASS

Dönen Değerler

Örnekler

Örnek 1 uopz_compose() example

<?php
class myClass {}
trait myTrait {}
interface myInterface {}

uopz_compose(
    Composed::class, [
        myClass::class,
        myTrait::class,
        myInterface::class
    ], [
    "__construct" => function() {
        /* ... */
    }
]);

var_dump(
 class_uses(Composed::class),
 class_parents(Composed::class),
 class_implements(Composed::class));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(1) {
  ["myTrait"]=>
  string(7) "myTrait"
}
array(1) {
  ["myClass"]=>
  string(7) "myClass"
}
array(1) {
  ["myInterface"]=>
  string(11) "myInterface"
}
uopz_backup
uopz_copy
Uopz İşlevleri


Copy a function

uopz_compose
uopz_delete
Uopz İşlevleri
PHP Manual

uopz_copy

(PECL uopz >= 1.0.4)

uopz_copy — Copy a function

Açıklama

Closure uopz_copy ( string $class , string $function )
Closure uopz_copy ( string $function )

Copy a function by name

Değiştirgeler

class

The name of the class containing the function to copy

function

The name of the function

Dönen Değerler

A Closure for the specified function

Örnekler

Örnek 1 uopz_copy() example

<?php
$strtotime = uopz_copy('strtotime');

uopz_function("strtotime", function($arg1, $arg2) use($strtotime) {
    /* can call original strtotime from here */
    var_dump($arg1);
});

var_dump(strtotime('dummy'));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(5) "dummy"
uopz_compose
uopz_delete
Uopz İşlevleri


Delete a function

uopz_copy
uopz_extend
Uopz İşlevleri
PHP Manual

uopz_delete

(PECL uopz >= 1.0.0)

uopz_delete — Delete a function

Açıklama

void uopz_delete ( string $class , string $function )
void uopz_delete ( string $function )

Deletes a function or method

Değiştirgeler

class

function

Dönen Değerler

Örnekler

Örnek 1 uopz_delete() example

<?php
uopz_delete("strlen");

echo strlen("Hello World");
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

PHP Fatal error: Call to undefined function strlen() in /path/to/script.php on line 4

Örnek 2 uopz_delete() class example

<?php
class My {
    public static function strlen($arg) {
        return strlen($arg);
    }
}

uopz_delete(My::class, "strlen");

echo My::strlen("Hello World");
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

PHP Fatal error: Call to undefined method My::strlen() in /path/to/script.php on line 10
uopz_copy
uopz_extend
Uopz İşlevleri


Extend a class at runtime

uopz_delete
uopz_flags
Uopz İşlevleri
PHP Manual

uopz_extend

(PECL uopz >= 1.0.0)

uopz_extend — Extend a class at runtime

Açıklama

void uopz_extend ( string $class , string $parent )

Makes class extend parent

Değiştirgeler

class

The name of the class to extend

parent

The name of the class to inherit

Dönen Değerler

Örnekler

Örnek 1 uopz_extend() example

<?php
class A {}
class B {}

uopz_extend(A::class, B::class);

var_dump(class_parents(A::class));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(1) {
  ["B"]=>
  string(1) "B"
}
uopz_delete
uopz_flags
Uopz İşlevleri


Get or set flags on function or class

uopz_extend
uopz_function
Uopz İşlevleri
PHP Manual

uopz_flags

(PECL uopz >= 2.0.2)

uopz_flags — Get or set flags on function or class

Açıklama

int uopz_flags ( string $class , string $function , int $flags )
int uopz_flags ( string $function , int $flags )

Get or set the flags on a class or function entry at runtime

Değiştirgeler

class

The name of a class

function

The name of the function

flags

A valid set of ZEND_ACC_ flags, ZEND_ACC_FETCH to read flags

Dönen Değerler

If setting, returns old flags, else returns flags

Örnekler

Örnek 1 uopz_flags() example

<?php
class Test {
    public function method() {
        return __CLASS__;
    }
}

$flags = uopz_flags("Test", "method", ZEND_ACC_FETCH);

var_dump((bool) (uopz_flags("Test", "method", ZEND_ACC_FETCH) & ZEND_ACC_PRIVATE));
var_dump((bool) (uopz_flags("Test", "method", ZEND_ACC_FETCH) & ZEND_ACC_STATIC));

var_dump(uopz_flags("Test", "method", $flags|ZEND_ACC_STATIC|ZEND_ACC_PRIVATE));

var_dump((bool) (uopz_flags("Test", "method", ZEND_ACC_FETCH) & ZEND_ACC_PRIVATE));
var_dump((bool) (uopz_flags("Test", "method", ZEND_ACC_FETCH) & ZEND_ACC_STATIC));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(false)
bool(false)
int(1234567890)
bool(true)
bool(true)
uopz_extend
uopz_function
Uopz İşlevleri


Creates a function at runtime

uopz_flags
uopz_implement
Uopz İşlevleri
PHP Manual

uopz_function

(PECL uopz >= 1.0.0)

uopz_function — Creates a function at runtime

Açıklama

void uopz_function ( string $class , string $function , Closure $handler [, int $modifiers ] )
void uopz_function ( string $function , Closure $handler [, int $modifiers ] )

Creates a function at runtime

Değiştirgeler

class

The name of the class to receive the new function

function

The name of the function

handler

The Closure for the function

modifiers

The modifiers for the function, by default copied or ZEND_ACC_PUBLIC

Dönen Değerler

Örnekler

Örnek 1 uopz_function() example

<?php
uopz_function("my_strlen", function($arg) {
    return strlen($arg);
});
echo my_strlen("Hello World");
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

11

Örnek 2 uopz_function() class example

<?php
class My {}

uopz_function(My::class, "strlen", function($arg) {
    return strlen($arg);
}, ZEND_ACC_STATIC);

echo My::strlen("Hello World");
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

11
uopz_flags
uopz_implement
Uopz İşlevleri


Implements an interface at runtime

uopz_function
uopz_overload
Uopz İşlevleri
PHP Manual

uopz_implement

(PECL uopz >= 1.0.0)

uopz_implement — Implements an interface at runtime

Açıklama

void uopz_implement ( string $class , string $interface )

Makes class implement interface

Değiştirgeler

class

interface

Dönen Değerler

Örnekler

Örnek 1 uopz_implement() example

<?php
interface myInterface {}

class myClass {}

uopz_implement(myClass::class, myInterface::class);

var_dump(class_implements(myClass::class));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(1) {
  ["myInterface"]=>
  string(11) "myInterface"
}
uopz_function
uopz_overload
Uopz İşlevleri


Overload a VM opcode

uopz_implement
uopz_redefine
Uopz İşlevleri
PHP Manual

uopz_overload

(PECL uopz >= 1.0.0)

uopz_overload — Overload a VM opcode

Açıklama

void uopz_overload ( int $opcode , Callable $callable )

Overloads the specified opcode with the user defined function

Değiştirgeler

opcode

A valid opcode, see constants for details of supported codes

callable

Dönen Değerler

Örnekler

Örnek 1 uopz_overload() example

<?php
uopz_overload(ZEND_EXIT, function(){});

exit();
echo "Hello World";
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Hello World
uopz_implement
uopz_redefine
Uopz İşlevleri


Redefine a constant

uopz_overload
uopz_rename
Uopz İşlevleri
PHP Manual

uopz_redefine

(PECL uopz >= 1.0.0)

uopz_redefine — Redefine a constant

Açıklama

void uopz_redefine ( string $class , string $constant , mixed $value )
void uopz_redefine ( string $constant , mixed $value )

Redefines the given constant as value

Değiştirgeler

class

The name of the class containing the constant

constant

The name of the constant

value

The new value for the constant, must be a valid type for a constant variable

Dönen Değerler

Örnekler

Örnek 1 uopz_redefine() example

<?php
define("MY", 100);

uopz_redefine("MY", 1000);

echo MY;
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

1000
uopz_overload
uopz_rename
Uopz İşlevleri


Rename a function at runtime

uopz_redefine
uopz_restore
Uopz İşlevleri
PHP Manual

uopz_rename

(PECL uopz >= 1.0.0)

uopz_rename — Rename a function at runtime

Açıklama

void uopz_rename ( string $class , string $function , string $rename )
void uopz_rename ( string $function , string $rename )

Renames function to rename

Bilginize:

If both functions exist, this effectively swaps their names

Değiştirgeler

class

The name of the class containing the function

function

The name of an existing function

rename

The new name for the function

Dönen Değerler

Örnekler

Örnek 1 uopz_rename() example

<?php
uopz_rename("strlen", "original_strlen");

echo original_strlen("Hello World");
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

11

Örnek 2 uopz_rename() class example

<?php
class My {
    public function strlen($arg) {
        return strlen($arg);
    }
}

uopz_rename(My::class, "strlen", "original_strlen");

echo My::original_strlen("Hello World");
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

11
uopz_redefine
uopz_restore
Uopz İşlevleri


Restore a previously backed up function

uopz_rename
uopz_undefine
Uopz İşlevleri
PHP Manual

uopz_restore

(PECL uopz >= 1.0.3)

uopz_restore — Restore a previously backed up function

Açıklama

void uopz_restore ( string $class , string $function )
void uopz_restore ( string $function )

Restore a previously backed up function

Değiştirgeler

class

The name of the class containing the function to restore

function

The name of the function

Dönen Değerler

Örnekler

Örnek 1 uopz_restore() example

<?php
uopz_backup("fgets");
uopz_function("fgets", function(){
    return true;
});
var_dump(fgets());
uopz_restore('fgets');
fgets();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Warning: fgets() expects at least 1 parameter, 0 given in /path/to/script.php on line 8
uopz_rename
uopz_undefine
Uopz İşlevleri


Undefine a constant

uopz_restore
Weakref
Uopz İşlevleri
PHP Manual

uopz_undefine

(PECL uopz >= 1.0.0)

uopz_undefine — Undefine a constant

Açıklama

void uopz_undefine ( string $class , string $constant )
void uopz_undefine ( string $constant )

Removes the constant at runtime

Değiştirgeler

class

The name of the class containing constant

constant

The name of an existing constant

Dönen Değerler

Örnekler

Örnek 1 uopz_undefine() example

<?php
define("MY", true);

uopz_undefine("MY");

var_dump(defined("MY"));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(false)
uopz_restore
Weakref
Uopz İşlevleri


Weak References

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Özkaynak Türleri
  • WeakRef — The WeakRef class
    • Weakref::acquire — Acquires a strong reference on that object
    • Weakref::__construct — Constructs a new weak reference
    • Weakref::get — Returns the object pointed to by the weak reference
    • Weakref::release — Releases a previously acquired reference
    • Weakref::valid — Checks whether the object referenced still exists
  • WeakMap — The WeakMap class
    • WeakMap::__construct — Constructs a new map
    • WeakMap::count — Counts the number of live entries in the map
    • WeakMap::current — Returns the current value under iteration
    • WeakMap::key — Returns the current key under iteration.
    • WeakMap::next — Advances to the next map element
    • WeakMap::offsetExists — Checks whether a certain object is in the map
    • WeakMap::offsetGet — Returns the value pointed to by a certain object
    • WeakMap::offsetSet — Updates the map with a new key-value pair
    • WeakMap::offsetUnset — Removes an entry from the map
    • WeakMap::rewind — Rewinds the iterator to the beginning of the map
    • WeakMap::valid — Returns whether the iterator is still on a valid map element
uopz_undefine
Giriş
PHP'nin Davranışını Etkileyenler


Giriş

Weak references provide a non-intrusive gateway to ephemeral objects. Unlike normal (strong) references, weak references do not prevent the garbage collector from freeing that object. For this reason, an object may be destroyed even though a weak reference to that object still exists. In such conditions, the weak reference seamlessly becomes invalid.

Örnek 1 Weakref usage example

<?php
class MyClass {
    public function __destruct() {
        echo "Destroying object!\n";
    }
}

$o1 = new MyClass;

$r1 = new Weakref($o1);

if ($r1->valid()) {
    echo "Object still exists!\n";
    var_dump($r1->get());
} else {
    echo "Object is dead!\n";
}

unset($o1);

if ($r1->valid()) {
    echo "Object still exists!\n";
    var_dump($r1->get());
} else {
    echo "Object is dead!\n";
}
?>

Yukarıdaki örneğin çıktısı:

Object still exists!
object(MyClass)#1 (0) {
}
Destroying object!
Object is dead!

Weakref
Yapılandırma/Kurulum
Weakref


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Özkaynak Türleri
Giriş
Gereksinimler
Weakref


Kurulum

Bu » PECL eklentisi PHP ile gelmez.

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/weakref.

Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız.

Gereksinimler
Özkaynak Türleri
Yapılandırma/Kurulum


Özkaynak Türleri

Bu eklentinin tanımlı hiçbir özkaynak türü yoktur.

Kurulum
WeakRef
Yapılandırma/Kurulum


The WeakRef class

(PECL weakref >= 0.1.0)

Giriş

The WeakRef class provides a gateway to objects without preventing the garbage collector from freeing those objects. It also provides a way to turn a weak reference into a strong one.

Sınıf Sözdizimi

WeakRef {
/* Yöntemler */
public Weakref::__construct ( object $object )
public bool Weakref::acquire ( void )
public object Weakref::get ( void )
public bool Weakref::release ( void )
public bool Weakref::valid ( void )
}

Örnekler

Örnek 1 WeakRef usage example

<?php
class MyClass {
    public function __destruct() {
        echo "Destroying object!\n";
    }
}

$o1 = new MyClass;

$r1 = new WeakRef($o1);

if ($r1->valid()) {
    echo "Object still exists!\n";
    var_dump($r1->get());
} else {
    echo "Object is dead!\n";
}

unset($o1);

if ($r1->valid()) {
    echo "Object still exists!\n";
    var_dump($r1->get());
} else {
    echo "Object is dead!\n";
}
?>

Yukarıdaki örneğin çıktısı:

Object still exists!
object(MyClass)#1 (0) {
}
Destroying object!
Object is dead!

İçindekiler

  • Weakref::acquire — Acquires a strong reference on that object
  • Weakref::__construct — Constructs a new weak reference
  • Weakref::get — Returns the object pointed to by the weak reference
  • Weakref::release — Releases a previously acquired reference
  • Weakref::valid — Checks whether the object referenced still exists
Özkaynak Türleri
Weakref::acquire
Weakref


Acquires a strong reference on that object

WeakRef
Weakref::__construct
WeakRef
PHP Manual

Weakref::acquire

(PECL weakref >= 0.1.0)

Weakref::acquire — Acquires a strong reference on that object

Açıklama

public bool Weakref::acquire ( void )

Acquires a strong reference on that object, virtually turning the weak reference into a strong one.

The Weakref instance maintains an internal acquired counter to track outstanding strong references. If the call to Weakref::acquire() is successful, this counter will be incremented by one.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the reference was valid and could be turned into a strong reference, FALSE otherwise.

Örnekler

Örnek 1 Weakref::acquire() example

<?php
class MyClass {
    public function __destruct() {
        echo "Destroying object!\n";
    }
}

$o1 = new MyClass;

$r1 = new Weakref($o1);

$r1->acquire();

echo "Unsetting o1...\n";
unset($o1);

$o2 = $r1->get();

$r1->release();

echo "Unsetting o2...\n";
unset($o2);
?>

Yukarıdaki örneğin çıktısı:

Unsetting o1...
Unsetting o2...
Destroying object!

Örnek 2 Nested acquire/release example

<?php
class MyClass {
    public function __destruct() {
        echo "Destroying object!\n";
    }
}

$o1 = new MyClass;

$r1 = new Weakref($o1);

echo "Acquiring...\n";
$r1->acquire();

echo "  Unsetting...\n";
unset($o1);

echo "  Acquiring...\n";
$r1->acquire();

echo "    Acquiring...\n";
$r1->acquire();

echo "    Releasing...\n";
$r1->release();

echo "  Releasing...\n";
$r1->release();

echo "Releasing...\n";
$r1->release();

?>

Yukarıdaki örneğin çıktısı:

Acquiring...
  Unsetting...
  Acquiring...
    Acquiring...
    Releasing...
  Releasing...
Releasing...
Destroying object!

Ayrıca Bakınız

  • Weakref::release() - Releases a previously acquired reference

WeakRef
Weakref::__construct
WeakRef


Constructs a new weak reference

Weakref::acquire
Weakref::get
WeakRef
PHP Manual

Weakref::__construct

(PECL weakref >= 0.1.0)

Weakref::__construct — Constructs a new weak reference

Açıklama

public Weakref::__construct ( object $object )

Constructs a new weak reference.

Değiştirgeler

object

The object to reference.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Weakref::__construct() example

<?php
class MyClass {
    public function __destruct() {
        echo "Destroying object!\n";
    }
}

$o1 = new MyClass;

$r1 = new Weakref($o1);

if ($r1->valid()) {
    echo "Object still exists!\n";
    var_dump($r1->get());
} else {
    echo "Object is dead!\n";
}

unset($o1);

if ($r1->valid()) {
    echo "Object still exists!\n";
    var_dump($r1->get());
} else {
    echo "Object is dead!\n";
}
?>

Yukarıdaki örneğin çıktısı:

Object still exists!
object(MyClass)#1 (0) {
}
Destroying object!
Object is dead!

Weakref::acquire
Weakref::get
WeakRef


Returns the object pointed to by the weak reference

Weakref::__construct
Weakref::release
WeakRef
PHP Manual

Weakref::get

(PECL weakref >= 0.1.0)

Weakref::get — Returns the object pointed to by the weak reference

Açıklama

public object Weakref::get ( void )

Returns the object pointed to by the weak reference.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the object if the reference is still valid, NULL otherwise.

Ayrıca Bakınız

  • Weakref::valid() - Checks whether the object referenced still exists

Weakref::__construct
Weakref::release
WeakRef


Releases a previously acquired reference

Weakref::get
Weakref::valid
WeakRef
PHP Manual

Weakref::release

(PECL weakref >= 0.1.0)

Weakref::release — Releases a previously acquired reference

Açıklama

public bool Weakref::release ( void )

Releases a previously acquired reference, potentially turning a strong reference back into a weak reference.

The Weakref instance maintains an internal acquired counter to track outstanding strong references. If the call to Weakref::release() is successful, this counter will be decremented by one. Once this counter reaches zero, the strong reference is turned back into a weak reference.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the reference was previously acquired and thus could be released, FALSE otherwise.

Örnekler

Örnek 1 Weakref::release() example

<?php
class MyClass {
    public function __destruct() {
        echo "Destroying object!\n";
    }
}

$o1 = new MyClass;

$r1 = new Weakref($o1);

$r1->acquire();

echo "Unsetting o1...\n";
unset($o1);

$o2 = $r1->get();

$r1->release();

echo "Unsetting o2...\n";
unset($o2);
?>

Yukarıdaki örneğin çıktısı:

Unsetting o1...
Unsetting o2...
Destroying object!

Ayrıca Bakınız

  • Weakref::acquire() - Acquires a strong reference on that object

Weakref::get
Weakref::valid
WeakRef


Checks whether the object referenced still exists

Weakref::release
WeakMap
WeakRef
PHP Manual

Weakref::valid

(PECL weakref >= 0.1.0)

Weakref::valid — Checks whether the object referenced still exists

Açıklama

public bool Weakref::valid ( void )

Checks whether the object referenced still exists.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the object still exists and is thus still accessible via Weakref::get(), FALSE otherwise.

Ayrıca Bakınız

  • Weakref::get() - Returns the object pointed to by the weak reference

Weakref::release
WeakMap
WeakRef


The WeakMap class

(PECL weakref >= 0.2.0)

Giriş

Sınıf Sözdizimi

WeakMap implements Countable , ArrayAccess , Iterator {
/* Yöntemler */
public __construct ( void )
public int count ( void )
public mixed current ( void )
public object key ( void )
public void next ( void )
public bool offsetExists ( object $object )
public mixed offsetGet ( object $object )
public void offsetSet ( object $object , mixed $value )
public void offsetUnset ( object $object )
public void rewind ( void )
public bool valid ( void )
}

Örnekler

Örnek 1 Weakmap usage example

<?php
$wm = new WeakMap();

$o = new StdClass;

class A {
    public function __destruct() {
        echo "Dead!\n";
    }
}

$wm[$o] = new A;

var_dump(count($wm));
echo "Unsetting..\n";
unset($o);
echo "Done\n";
var_dump(count($wm));

Yukarıdaki örneğin çıktısı:

int(1)
Unsetting..
Dead!
Done
int(0)

İçindekiler

  • WeakMap::__construct — Constructs a new map
  • WeakMap::count — Counts the number of live entries in the map
  • WeakMap::current — Returns the current value under iteration
  • WeakMap::key — Returns the current key under iteration.
  • WeakMap::next — Advances to the next map element
  • WeakMap::offsetExists — Checks whether a certain object is in the map
  • WeakMap::offsetGet — Returns the value pointed to by a certain object
  • WeakMap::offsetSet — Updates the map with a new key-value pair
  • WeakMap::offsetUnset — Removes an entry from the map
  • WeakMap::rewind — Rewinds the iterator to the beginning of the map
  • WeakMap::valid — Returns whether the iterator is still on a valid map element
Weakref::valid
WeakMap::__construct
Weakref


Constructs a new map

WeakMap
WeakMap::count
WeakMap
PHP Manual

WeakMap::__construct

(PECL weakref >= 0.2.0)

WeakMap::__construct — Constructs a new map

Açıklama

public WeakMap::__construct ( void )

Constructs a new map.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

WeakMap
WeakMap::count
WeakMap


Counts the number of live entries in the map

WeakMap::__construct
WeakMap::current
WeakMap
PHP Manual

WeakMap::count

(PECL weakref >= 0.2.0)

WeakMap::count — Counts the number of live entries in the map

Açıklama

public int WeakMap::count ( void )

Counts the number of live entries in the map.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the number of live entries in the map.

WeakMap::__construct
WeakMap::current
WeakMap


Returns the current value under iteration

WeakMap::count
WeakMap::key
WeakMap
PHP Manual

WeakMap::current

(PECL weakref >= 0.2.0)

WeakMap::current — Returns the current value under iteration

Açıklama

public mixed WeakMap::current ( void )

Returns the current value being iterated on in the map.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The value currently being iterated on.

WeakMap::count
WeakMap::key
WeakMap


Returns the current key under iteration.

WeakMap::current
WeakMap::next
WeakMap
PHP Manual

WeakMap::key

(PECL weakref >= 0.2.0)

WeakMap::key — Returns the current key under iteration.

Açıklama

public object WeakMap::key ( void )

Returns the object serving as key in the map, at the current iterating position.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The object key currently being iterated.

WeakMap::current
WeakMap::next
WeakMap


Advances to the next map element

WeakMap::key
WeakMap::offsetExists
WeakMap
PHP Manual

WeakMap::next

(PECL weakref >= 0.2.0)

WeakMap::next — Advances to the next map element

Açıklama

public void WeakMap::next ( void )

Advances to the next map element.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

WeakMap::key
WeakMap::offsetExists
WeakMap


Checks whether a certain object is in the map

WeakMap::next
WeakMap::offsetGet
WeakMap
PHP Manual

WeakMap::offsetExists

(PECL weakref >= 0.2.0)

WeakMap::offsetExists — Checks whether a certain object is in the map

Açıklama

public bool WeakMap::offsetExists ( object $object )

Checks whether the passed object is referenced in the map.

Değiştirgeler

object

Object to check for.

Dönen Değerler

Returns TRUE if the object is contained in the map, FALSE otherwise.

WeakMap::next
WeakMap::offsetGet
WeakMap


Returns the value pointed to by a certain object

WeakMap::offsetExists
WeakMap::offsetSet
WeakMap
PHP Manual

WeakMap::offsetGet

(PECL weakref >= 0.2.0)

WeakMap::offsetGet — Returns the value pointed to by a certain object

Açıklama

public mixed WeakMap::offsetGet ( object $object )

Returns the value pointed to by a certain object.

Değiştirgeler

object

Some object contained as key in the map.

Dönen Değerler

Returns the value associated to the object passed as argument, NULL otherwise.

WeakMap::offsetExists
WeakMap::offsetSet
WeakMap


Updates the map with a new key-value pair

WeakMap::offsetGet
WeakMap::offsetUnset
WeakMap
PHP Manual

WeakMap::offsetSet

(PECL weakref >= 0.2.0)

WeakMap::offsetSet — Updates the map with a new key-value pair

Açıklama

public void WeakMap::offsetSet ( object $object , mixed $value )

Updates the map with a new key-value pair. If the key already existed in the map, the old value is replaced with the new.

Değiştirgeler

object

The object serving as key of the key-value pair.

value

The arbitrary data serving as value of the key-value pair.

Dönen Değerler

Hiçbir değer dönmez.

WeakMap::offsetGet
WeakMap::offsetUnset
WeakMap


Removes an entry from the map

WeakMap::offsetSet
WeakMap::rewind
WeakMap
PHP Manual

WeakMap::offsetUnset

(PECL weakref >= 0.2.0)

WeakMap::offsetUnset — Removes an entry from the map

Açıklama

public void WeakMap::offsetUnset ( object $object )

Removes an entry from the map.

Değiştirgeler

object

The key object to remove from the map.

Dönen Değerler

Hiçbir değer dönmez.

WeakMap::offsetSet
WeakMap::rewind
WeakMap


Rewinds the iterator to the beginning of the map

WeakMap::offsetUnset
WeakMap::valid
WeakMap
PHP Manual

WeakMap::rewind

(PECL weakref >= 0.2.0)

WeakMap::rewind — Rewinds the iterator to the beginning of the map

Açıklama

public void WeakMap::rewind ( void )

Rewinds the iterator to the beginning of the map.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

WeakMap::offsetUnset
WeakMap::valid
WeakMap


Returns whether the iterator is still on a valid map element

WeakMap::rewind
WinCache
WeakMap
PHP Manual

WeakMap::valid

(PECL weakref >= 0.2.0)

WeakMap::valid — Returns whether the iterator is still on a valid map element

Açıklama

public bool WeakMap::valid ( void )

Returns whether the iterator is still on a valid map element.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the iterator is on a valid element that can be accessed, FALSE otherwise.

WeakMap::rewind
WinCache
WeakMap


Windows Cache for PHP

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • WinCache Statistics Script
    • WinCache Session Handler
    • WinCache Functions Reroutes
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • WinCache İşlevleri
    • wincache_fcache_fileinfo — Retrieves information about files cached in the file cache
    • wincache_fcache_meminfo — Retrieves information about file cache memory usage
    • wincache_lock — Acquires an exclusive lock on a given key
    • wincache_ocache_fileinfo — Retrieves information about files cached in the opcode cache
    • wincache_ocache_meminfo — Retrieves information about opcode cache memory usage
    • wincache_refresh_if_changed — Refreshes the cache entries for the cached files
    • wincache_rplist_fileinfo — Retrieves information about resolve file path cache
    • wincache_rplist_meminfo — Retrieves information about memory usage by the resolve file path cache
    • wincache_scache_info — Retrieves information about files cached in the session cache
    • wincache_scache_meminfo — Retrieves information about session cache memory usage
    • wincache_ucache_add — Adds a variable in user cache only if variable does not already exist in the cache
    • wincache_ucache_cas — Compares the variable with old value and assigns new value to it
    • wincache_ucache_clear — Deletes entire content of the user cache
    • wincache_ucache_dec — Decrements the value associated with the key
    • wincache_ucache_delete — Deletes variables from the user cache
    • wincache_ucache_exists — Checks if a variable exists in the user cache
    • wincache_ucache_get — Gets a variable stored in the user cache
    • wincache_ucache_inc — Increments the value associated with the key
    • wincache_ucache_info — Retrieves information about data stored in the user cache
    • wincache_ucache_meminfo — Retrieves information about user cache memory usage
    • wincache_ucache_set — Adds a variable in user cache and overwrites a variable if it already exists in the cache
    • wincache_unlock — Releases an exclusive lock on a given key
  • Building for Windows
    • Prerequisites
    • Compiling and building
    • Verifying the build
WeakMap::valid
Giriş
PHP'nin Davranışını Etkileyenler


Giriş

Windows Cache Extension for PHP is a PHP accelerator that is used to increase the speed of PHP applications running on Windows and Windows Server. Once the Windows Cache Extension for PHP is enabled and loaded by the PHP engine, PHP applications can take advantage of the functionality without any code modifications.

The Windows Cache Extension includes 5 different types of caches. The following describes the purpose of each cache type and the benefits it provides.

  • PHP Opcode Cache - PHP is a script processing engine, which reads an input stream of data that contains text and/or PHP instructions and produces another stream of data, most commonly in the HTML format. This means that on a web server the PHP engine reads, parses, compiles and executes a PHP script each time that it is requested by a Web client. The reading, parsing and compilation operations put additional load on the web server's CPU and file system and thus affect the overall performance of a PHP web application. The PHP bytecode (opcode) cache is used to store the compiled script bytecode in shared memory so that it can be re-used by PHP engine for subsequent executions of the same script.

  • File Cache - Even with the PHP opcode cache enabled, the PHP engine has to accesses the script files on a file system. When PHP scripts are stored on a remote UNC file share, the file operations introduce a significant performance overhead. The Windows Cache Extension for PHP includes a file cache that is used to store the content of the PHP script files in shared memory, which reduces the amount of file system operations performed by PHP engine.

  • Resolve File Path Cache - PHP scripts very often include or operate with files by using relative file paths. Every file path has to be normalized to an absolute file path by the PHP engine. When a PHP application uses many PHP files and accesses them by relative paths, the operation of resolving the paths may negatively impact the application's performance. The Windows Cache Extension for PHP provides a Resolve File Path cache, which is used to store the mappings between relative and absolute file paths, thereby reducing the number of path resolutions that the PHP engine has to perform.

  • User Cache (available since version 1.1.0) - PHP scripts can take advantage of the shared memory cache by using the user cache API's. PHP objects and variables can be stored in the user cache and then re-used on subsequent requests. This can be used to improve performance of PHP scripts and to share the data across multiple PHP processes.

  • Session Handler (available since version 1.1.0) - The WinCache session handler can be used to store the PHP session data in the shared memory cache. This avoids file system operations for reading and writing session data, which improves performance when large amount of data is stored in PHP session.

WinCache
Yapılandırma/Kurulum
WinCache


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • WinCache Statistics Script
  • WinCache Session Handler
  • WinCache Functions Reroutes
  • Özkaynak Türleri
Giriş
Gereksinimler
WinCache


Gereksinimler

The extension is currently supported only on the following configurations:

Windows OS:

  • Windows XP SP3 with IIS 5.1 and » FastCGI Extension
  • Windows Server 2003 with IIS 6.0 and » FastCGI Extension
  • Windows Vista SP1 with IIS 7.0 and FastCGI Module
  • Windows Server 2008 with IIS 7.0 and FastCGI Module
  • Windows 7 with IIS 7.5 and FastCGI Module
  • Windows Server 2008 R2 with IIS 7.5 and FastCGI Module

PHP:

  • PHP 5.2.X, Non-thread-safe build
  • PHP 5.3 X86, Non-thread-safe VC9 build

Bilginize: The WinCache Extension can only be used when IIS is configured to run PHP via FastCGI.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu » PECL eklentisi PHP ile gelmez.

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/wincache.

There are two packages for this extension: one package is for PHP versions 5.2.X, and the other package is for PHP 5.3.X. Select the package that is appropriate for the PHP version being used.

To install and enable the extension, follow these steps:

  1. Unpack the package into some temporary location.

  2. Copy the php_wincache.dll file into the PHP extensions folder. Typically this folder is called "ext" and it is located in the same folder with all PHP binary files. For example: C:\Program Files\PHP\ext.

  3. Using a text editor, open the php.ini file, which is usually located in the same folder where all PHP binary files are. For example: C:\Program Files\PHP\php.ini.

  4. Add the following line at the end of the php.ini file: extension = php_wincache.dll.

  5. Save and close the php.ini file.

  6. Recycle the IIS Application Pools for PHP to pick up the configuration changes. To check that the extension has been enabled, create a file called phpinfo.php with a PHP code that calls phpinfo function.

  7. Save the phpinfo.php file in the root folder of a IIS web site that uses PHP, then open a browser and make a request to http://localhost/phpinfo.php. Search within the returned web page for a section called wincache. If the extension is enabled, then the phpinfo output will list the configuration settings provided by the WinCache.

Bilginize: Do not forget to remove phpinfo.php file from the web site's root folder after verifying that extension has been enabled.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

The following table lists and explains the configuration settings provided by the WinCache extension:

WinCache configuration options
İsim | Öntanımlı | Minimum | Maximum | Değişlik Yeri | Sürüm Bilgisi
wincache.fcenabled | "1" | "0" | "1" | PHP_INI_ALL | Available as of WinCache 1.0.0
wincache.fcenabledfilter | "NULL" | "NULL" | "NULL" | PHP_INI_SYSTEM | Available as of WinCache 1.0.0
wincache.fcachesize | "24" | "5" | "255" | PHP_INI_SYSTEM | Available as of WinCache 1.0.0
wincache.fcndetect | "1" | "0" | "1" | PHP_INI_SYSTEM | Available as of WinCache 1.1.0
wincache.maxfilesize | "256" | "10" | "2048" | PHP_INI_SYSTEM | Available as of WinCache 1.0.0
wincache.ocenabled | "1" | "0" | "1" | PHP_INI_ALL | Available as of WinCache 1.0.0. Removed as of 2.0.0.0
wincache.ocenabledfilter | "NULL" | "NULL" | "NULL" | PHP_INI_SYSTEM | Available as of WinCache 1.0.0. Removed as of 2.0.0.0
wincache.ocachesize | "96" | "15" | "255" | PHP_INI_SYSTEM | Available as of WinCache 1.0.0. Removed as of 2.0.0.0
wincache.filecount | "4096" | "1024" | "16384" | PHP_INI_SYSTEM | Available as of WinCache 1.0.0
wincache.chkinterval | "30" | "0" | "300" | PHP_INI_SYSTEM | Available as of WinCache 1.0.0
wincache.ttlmax | "1200" | "0" | "7200" | PHP_INI_SYSTEM | Available as of WinCache 1.0.0
wincache.enablecli | 0 | 0 | 1 | PHP_INI_SYSTEM | Available as of WinCache 1.0.0
wincache.ignorelist | NULL | NULL | NULL | PHP_INI_ALL | Available as of WinCache 1.0.0
wincache.namesalt | NULL | NULL | NULL | PHP_INI_SYSTEM | Available as of WinCache 1.0.0
wincache.ucenabled | 1 | 0 | 1 | PHP_INI_SYSTEM | Available as of WinCache 1.1.0
wincache.ucachesize | 8 | 5 | 85 | PHP_INI_SYSTEM | Available as of WinCache 1.1.0
wincache.scachesize | 8 | 5 | 85 | PHP_INI_SYSTEM | Available as of WinCache 1.1.0
wincache.rerouteini | NULL | NULL | NULL | PHP_INI_SYSTEM | Available as of WinCache 1.2.0. Removed as of 1.3.7
wincache.reroute_enabled | 1 | 0 | 1 | PHP_INI_SYSTEM | PHP_INI_PERDIR | Available as of WinCache 1.3.7
wincache.srwlocks | 1 | 0 | 1 | PHP_INI_SYSTEM | Available as of WinCache 1.3.6.3. Removed as of 2.0.0.0
wincache.filemapdir | NULL | NULL | NULL | PHP_INI_SYSTEM | Available as of WinCache 1.3.7.4
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

wincache.fcenabled boolean
Enables or disables the file cache functionality.
wincache.fcenabledfilter string
Defines a comma-separated list of IIS web site identifiers where file cache should be enabled or disabled. This setting works in conjunction with wincache.fcenabled: if wincache.fcenabled is set to 1, then the sites listed in the wincache.fcenabledfilter will have the file cache turned off; if wincache.fcenabled is set to 0, then the sites listed in the wincache.fcenabledfilter will have the file cache turned on.
wincache.fcachesize integer
Defines the maximum memory size (in megabytes) that is allocated for the file cache. If the total size of all the cached files exceeds the value specified in this setting, then most stale files will be removed from the file cache.
wincache.fcndetect boolean
Enables or disables the file change notification detection functionality. If file change notification is supported then it will be used to refresh the opcode and file cache entries as soon as the corresponding files are modified on a file system. If file change notification is not supported, for example when using network file shares, then wincache will poll for file changes at regular time intervals specified by wincache.chkinterval.
wincache.maxfilesize integer
Defines the maximum allowed size (in kilobytes) for a single file to be cached. If a file size exceeds the specified value, the file will not be cached. This setting applies to the file cache only.
wincache.ocenabled boolean
Uyarı

This option has been REMOVED as of 2.0.0.0

Enables or disables the opcode cache functionality
wincache.ocenabledfilter string
Uyarı

This option has been REMOVED as of 2.0.0.0

Defines a comma-separated list of IIS web site identifiers where opcode cache should be enabled or disabled. This setting works in conjunction with wincache.ocenabled: if wincache.ocenabled is set to 1, then the sites listed in the wincache.ocenabledfilter will have the opcode cache turned off; if wincache.ocenabled is set to 0, then the sites listed in the wincache.ocenabledfilter will have the opcode cache turned on.
wincache.ocachesize integer
Uyarı

This option has been REMOVED as of 2.0.0.0

Defines the maximum memory size (in megabytes) that is allocated for the opcode cache. If the cached opcode size exceeds the specified value, then most stale opcode will be removed from the cache. Note that the opcode cache size must be at least 3 times bigger than file cache size. If that is not the case the opcode cache size will be automatically increased.
wincache.filecount integer
Defines how many files are expected to be cached by the extension, so that appropriate memory size is allocated at the startup time. If the number of files exceeds the specified value, the WinCache will re-allocate more memory as needed.
wincache.chkinterval integer
Defines how often (in seconds) the extension checks for file changes in order to refresh the cache. Setting it to 0 will disable the refreshing of the cache. The file changes will not be reflected in the cache unless the cache entry for that file is removed by scavenger or IIS application pool is recycled or wincache_refresh_if_changed function is called.
wincache.ttlmax integer
Defines the maximum time to live (in seconds) for a cached entry without being used. Setting it to 0 will disable the cache scavenger, so the cached entries will never be removed from the cache during the lifetime of the IIS worker process.
wincache.enablecli boolean
Defines if caching is enabled when PHP is running in command line (CLI) mode.
wincache.ignorelist string

Defines a list of files that should not be cached by the extension. The files list is specified by using file names only, separated by the pipe symbol - "|".

Örnek 1 wincache.ignorelist example

wincache.ignorelist = "index.php|misc.php|admin.php"

wincache.namesalt string
Defines a string that will be used when naming the extension specific objects that are stored in shared memory. This is used to avoid conflicts that may be caused if other applications within an IIS worker process tries to access shared memory. The length of the namesalt string cannot exceed 8 characters.
wincache.ucenabled boolean
Enables or disables the user cache functionality.
wincache.ucachesize integer
Defines the maximum memory size in megabytes that is allocated for the user cache. If the total size of variables stored in the user cache exceeds the specified value, then the most stale variables will be removed from the cache.
wincache.scachesize integer
Defines the maximum memory size in megabytes that is allocated for the session cache. If the total size of data stored in the session cache exceeds the specified value, then the most stale data will be removed from the cache.
wincache.rerouteini string
Uyarı

This option has been REMOVED as of 1.3.7. See wincache.reroute_enabled for similar functionality as of 1.3.7.

Specifies an absolute or a relateve path to the reroute.ini file that contains the list of PHP functions whose implementation should be replaced with the WinCache function equivalents. If a relative path is specified then it is assumed to be relative to the location of php-cgi.exe file.
wincache.reroute_enabled boolean
Enables or disables the rerouting of certain file I/O functions through the file cache.
wincache.srwlocks boolean
Uyarı

This option has been REMOVED as of 2.0.0.0

Enables or disables the use of shared reader/writer locks. Disabling is useful when troubleshooting deadlock conditions in WinCache.
wincache.filemapdir string
Specifies an absolute path to a directory where WinCache will store the temporary files used for shared memory segments. This directory must be on the local machine and not on a networked file system. If the directory is not specified, WinCache will use the Windows System Page File for all shared memory segments.

Kurulum
WinCache Statistics Script
Yapılandırma/Kurulum


WinCache Statistics Script

The installation package for WinCache includes a PHP script, wincache.php, that can be used to obtain cache information and statistics.

If the WinCache extension was installed via the Microsoft Web Platform Installer, then this script is located in %SystemDrive%\Program Files\IIS\Windows Cache for PHP\. On a 64-bit version of the Windows Server operating system, the script is located in %SystemDrive%\Program Files (x86)\IIS\Windows Cache for PHP. If the extension was installed manually, then the wincache.php will be located in the same folder from which the content of the installation package was extracted.

To use wincache.php, copy it into a root folder of a Web site or into any subfolder. To protect the script, open it in any text editor and replace the values for USERNAME and PASSWORD constants. If any other IIS authentication is enabled on the server, then follow the instructions in the comments:

Örnek 1 Authentication configuration for wincache.php

<?php
/**
 * ======================== CONFIGURATION SETTINGS ==============================
 * If you do not want to use authentication for this page, set USE_AUTHENTICATION to 0.
 * If you use authentication then replace the default password.
 */
define('USE_AUTHENTICATION', 1);
define('USERNAME', 'wincache');
define('PASSWORD', 'wincache');

/**
 * The Basic PHP authentication will work only when IIS is configured to support
 * Anonymous Authentication' and nothing else. If IIS is configured to support/use
 * any other kind of authentication like Basic/Negotiate/Digest etc, this will not work.
 * In that case use the array below to define the names of users in your
 * domain/network/workgroup which you want to grant access to.
 */
$user_allowed = array('DOMAIN\user1', 'DOMAIN\user2', 'DOMAIN\user3');

/**
 * If the array contains string 'all', then all the users authenticated by IIS
 * will have access to the page. Uncomment the below line and comment above line
 * to grant access to all users who gets authenticated by IIS.
 */
/* $user_allowed = array('all'); */

/** ===================== END OF CONFIGURATION SETTINGS ========================== */
?>

Bilginize: Always protect the wincache.php script by using either the built-in authentication or the server's authentication mechanism. Leaving this script unprotected may compromise the security of your web application and web server.

Çalışma Anı Yapılandırması
WinCache Session Handler
Yapılandırma/Kurulum


WinCache Session Handler

The WinCache session handler (available since WinCache 1.1.0) can be used to configure PHP to store the session data in shared memory session cache. Using shared memory instead of the default file session storage helps improve performance of PHP applications that store large amount of data in session objects. Wincache session cache uses file-backed shared memory, which ensures that the session data is not lost during recycling of IIS application pools.

To configure PHP to use WinCache session handler set the php.ini setting session.save_handler to wincache. By default the Windows temporary file location is used for storing the session data. To change the location of the session file use session.save_path directive.

Örnek 1 Enabling WinCache session handler

session.save_handler = wincache
session.save_path = C:\inetpub\temp\session\

WinCache Statistics Script
WinCache Functions Reroutes
Yapılandırma/Kurulum


WinCache Functions Reroutes

NOTE: wincache.rerouteini was removed as of WinCache 1.3.7.0. It has been replaced with automatic function reroutes. See: wincache.reroute_enabled.

The WinCache functions reroutes (available since WinCache 1.2.0, removed since WinCache 1.3.7.0) can be used to replace built-in PHP functions with their equivalents that are optimized for a particular purpose. WinCache extension includes Windows-optimized implementation of PHP file functions that may improve performance of PHP applications in cases when PHP has to access files on network shares. The optimized implementation is provided for the following functions:

  • file_exists
  • file_get_contents
  • readfile
  • is_readable
  • is_writable
  • is_dir
  • realpath
  • filesize

To configure WinCache to use the functions reroutes use the file reroute.ini that is included in WinCache installation package. Copy this file into the same directory where php.ini file is located. After that add the wincache.rerouteini setting in php.ini and specify an absolute or relative path to the reroute.ini file.

Örnek 1 Enabling WinCache functions reroutes

wincache.rerouteini = C:\PHP\reroute.ini

Bilginize: If WinCache functions reroutes are enabled it is recommended to increase the WinCache file cache size. This can be done by using wincache.fcachesize setting.

The reroute.ini file contains the mappings between the native PHP functions and their equivalents in WinCache. Each line in the file defines a mapping by using the following syntax:

<PHP function name>:[<number of function parameters>]=<wincache function name>

The example of the file is shown below. In this example the calls to PHP function file_get_contents() will be replaced with calls to wincache_file_get_contents() only if the number of parameters passed to the function is less than or equals to 2. Specifying the number of parameters is useful when replacement function does not handle all the function's parameters.

Örnek 2 Reroute.ini file content

[FunctionRerouteList]
file_exists=wincache_file_exists
file_get_contents:2=wincache_file_get_contents
readfile:2=wincache_readfile
is_readable=wincache_is_readable
is_writable=wincache_is_writable
is_writeable=wincache_is_writable
is_file=wincache_is_file
is_dir=wincache_is_dir
realpath=wincache_realpath
filesize=wincache_filesize

WinCache Session Handler
Özkaynak Türleri
Yapılandırma/Kurulum


Özkaynak Türleri

Bu eklentinin tanımlı hiçbir özkaynak türü yoktur.

WinCache Functions Reroutes
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
WinCache İşlevleri
WinCache


WinCache İşlevleri

İçindekiler

  • wincache_fcache_fileinfo — Retrieves information about files cached in the file cache
  • wincache_fcache_meminfo — Retrieves information about file cache memory usage
  • wincache_lock — Acquires an exclusive lock on a given key
  • wincache_ocache_fileinfo — Retrieves information about files cached in the opcode cache
  • wincache_ocache_meminfo — Retrieves information about opcode cache memory usage
  • wincache_refresh_if_changed — Refreshes the cache entries for the cached files
  • wincache_rplist_fileinfo — Retrieves information about resolve file path cache
  • wincache_rplist_meminfo — Retrieves information about memory usage by the resolve file path cache
  • wincache_scache_info — Retrieves information about files cached in the session cache
  • wincache_scache_meminfo — Retrieves information about session cache memory usage
  • wincache_ucache_add — Adds a variable in user cache only if variable does not already exist in the cache
  • wincache_ucache_cas — Compares the variable with old value and assigns new value to it
  • wincache_ucache_clear — Deletes entire content of the user cache
  • wincache_ucache_dec — Decrements the value associated with the key
  • wincache_ucache_delete — Deletes variables from the user cache
  • wincache_ucache_exists — Checks if a variable exists in the user cache
  • wincache_ucache_get — Gets a variable stored in the user cache
  • wincache_ucache_inc — Increments the value associated with the key
  • wincache_ucache_info — Retrieves information about data stored in the user cache
  • wincache_ucache_meminfo — Retrieves information about user cache memory usage
  • wincache_ucache_set — Adds a variable in user cache and overwrites a variable if it already exists in the cache
  • wincache_unlock — Releases an exclusive lock on a given key
Öntanımlı Sabitler
wincache_fcache_fileinfo
WinCache


Retrieves information about files cached in the file cache

WinCache İşlevleri
wincache_fcache_meminfo
WinCache İşlevleri
PHP Manual

wincache_fcache_fileinfo

(PECL wincache >= 1.0.0)

wincache_fcache_fileinfo — Retrieves information about files cached in the file cache

Açıklama

array wincache_fcache_fileinfo ([ bool $summaryonly = false ] )

Retrieves information about file cache content and its usage.

Değiştirgeler

summaryonly

Controls whether the returned array will contain information about individual cache entries along with the file cache summary.

Dönen Değerler

Array of meta data about file cache başarısızlık durumunda FALSE döner

The array returned by this function contains the following elements:

  • total_cache_uptime - total time in seconds that the file cache has been active
  • total_file_count - total number of files that are currently in the file cache
  • total_hit_count - number of times the files have been served from the file cache
  • total_miss_count - number of times the files have not been found in the file cache

  • file_entries - an array that contains the information about all the cached files:

    • file_name - absolute file name of the cached file
    • add_time - time in seconds since the file has been added to the file cache
    • use_time - time in seconds since the file has been accessed in the file cache
    • last_check - time in seconds since the file has been checked for modifications
    • hit_count - number of times the file has been served from the cache
    • file_size - size of the cached file in bytes

Örnekler

Örnek 1 A wincache_fcache_fileinfo() example

<pre>
<?php
print_r(wincache_fcache_fileinfo());
?>
</pre>

Yukarıdaki örneğin çıktısı:

Array
(   [total_cache_uptime] => 3234
    [total_file_count] => 5
    [total_hit_count] => 0
    [total_miss_count] => 1
    [file_entries] => Array
        (
            [1] => Array
                (
                    [file_name] => c:\inetpub\wwwroot\checkcache.php
                    [add_time] => 1
                    [use_time] => 0
                    [last_check] => 1
                    [hit_count] => 1
                    [file_size] => 2435
                )
            [2] => Array (...iterates for each cached file)
        )
)

Ayrıca Bakınız

  • wincache_fcache_meminfo() - Retrieves information about file cache memory usage
  • wincache_ocache_fileinfo() - Retrieves information about files cached in the opcode cache
  • wincache_ocache_meminfo() - Retrieves information about opcode cache memory usage
  • wincache_rplist_fileinfo() - Retrieves information about resolve file path cache
  • wincache_rplist_meminfo() - Retrieves information about memory usage by the resolve file path cache
  • wincache_refresh_if_changed() - Refreshes the cache entries for the cached files
  • wincache_ucache_meminfo() - Retrieves information about user cache memory usage
  • wincache_ucache_info() - Retrieves information about data stored in the user cache
  • wincache_scache_info() - Retrieves information about files cached in the session cache
  • wincache_scache_meminfo() - Retrieves information about session cache memory usage

WinCache İşlevleri
wincache_fcache_meminfo
WinCache İşlevleri


Retrieves information about file cache memory usage

wincache_fcache_fileinfo
wincache_lock
WinCache İşlevleri
PHP Manual

wincache_fcache_meminfo

(PECL wincache >= 1.0.0)

wincache_fcache_meminfo — Retrieves information about file cache memory usage

Açıklama

array wincache_fcache_meminfo ( void )

Retrieves information about memory usage by file cache.

Dönen Değerler

Array of meta data about file cache memory usage başarısızlık durumunda FALSE döner

The array returned by this function contains the following elements:

  • memory_total - amount of memory in bytes allocated for the file cache
  • memory_free - amount of free memory in bytes available for the file cache
  • num_used_blks - number of memory blocks used by the file cache
  • num_free_blks - number of free memory blocks available for the file cache
  • memory_overhead - amount of memory in bytes used for the file cache internal structures

Örnekler

Örnek 1 A wincache_fcache_meminfo() example

<pre>
<?php
print_r(wincache_fcache_meminfo());
?>
</pre>

Yukarıdaki örneğin çıktısı:

Array
(
    [memory_total] => 134217728
    [memory_free] => 131339120
    [num_used_blks] => 361
    [num_free_blks] => 3
    [memory_overhead] => 5856
)

Ayrıca Bakınız

  • wincache_fcache_fileinfo() - Retrieves information about files cached in the file cache
  • wincache_ocache_fileinfo() - Retrieves information about files cached in the opcode cache
  • wincache_ocache_meminfo() - Retrieves information about opcode cache memory usage
  • wincache_rplist_fileinfo() - Retrieves information about resolve file path cache
  • wincache_rplist_meminfo() - Retrieves information about memory usage by the resolve file path cache
  • wincache_refresh_if_changed() - Refreshes the cache entries for the cached files
  • wincache_ucache_meminfo() - Retrieves information about user cache memory usage
  • wincache_ucache_info() - Retrieves information about data stored in the user cache
  • wincache_scache_info() - Retrieves information about files cached in the session cache
  • wincache_scache_meminfo() - Retrieves information about session cache memory usage

wincache_fcache_fileinfo
wincache_lock
WinCache İşlevleri


Acquires an exclusive lock on a given key

wincache_fcache_meminfo
wincache_ocache_fileinfo
WinCache İşlevleri
PHP Manual

wincache_lock

(PECL wincache >= 1.1.0)

wincache_lock — Acquires an exclusive lock on a given key

Açıklama

bool wincache_lock ( string $key [, bool $isglobal = false ] )

Obtains an exclusive lock on a given key. The execution of the current script will be blocked until the lock can be obtained. Once the lock is obtained, the other scripts that try to request the lock by using the same key will be blocked, until the current script releases the lock by using wincache_unlock().

Uyarı

Using of the wincache_lock() and wincache_unlock() can cause deadlocks when executing PHP scripts in a multi-process environment like FastCGI. Do not use these functions unless you are absolutely sure you need to use them. For the majority of the operations on the user cache it is not necessary to use these functions.

Değiştirgeler

key

Name of the key in the cache to get the lock on.

isglobal

Controls whether the scope of the lock is system-wide or local. Local locks are scoped to the application pool in IIS FastCGI case or to all php processes that have the same parent process identifier.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Using wincache_lock()

<?php
$fp = fopen("/tmp/lock.txt", "r+");
if (wincache_lock("lock_txt_lock")) { // do an exclusive lock
    ftruncate($fp, 0); // truncate file
    fwrite($fp, "Write something here\n");
    wincache_unlock("lock_txt_lock"); // release the lock
} else {
    echo "Couldn't get the lock!";
}
fclose($fp);
?>

Ayrıca Bakınız

  • wincache_unlock() - Releases an exclusive lock on a given key
  • wincache_ucache_set() - Adds a variable in user cache and overwrites a variable if it already exists in the cache
  • wincache_ucache_get() - Gets a variable stored in the user cache
  • wincache_ucache_delete() - Deletes variables from the user cache
  • wincache_ucache_clear() - Deletes entire content of the user cache
  • wincache_ucache_exists() - Checks if a variable exists in the user cache
  • wincache_ucache_meminfo() - Retrieves information about user cache memory usage
  • wincache_ucache_info() - Retrieves information about data stored in the user cache
  • wincache_scache_info() - Retrieves information about files cached in the session cache

wincache_fcache_meminfo
wincache_ocache_fileinfo
WinCache İşlevleri


Retrieves information about files cached in the opcode cache

wincache_lock
wincache_ocache_meminfo
WinCache İşlevleri
PHP Manual

wincache_ocache_fileinfo

(PECL wincache >= 1.0.0)

wincache_ocache_fileinfo — Retrieves information about files cached in the opcode cache

Açıklama

array wincache_ocache_fileinfo ([ bool $summaryonly = false ] )

Retrieves information about opcode cache content and its usage.

Uyarı

Bu işlev PHP 7.0.0'da tamamen KALDIRILMIŞTIR.

Değiştirgeler

summaryonly

Controls whether the returned array will contain information about individual cache entries along with the opcode cache summary.

Dönen Değerler

Array of meta data about opcode cache başarısızlık durumunda FALSE döner

The array returned by this function contains the following elements:

  • total_cache_uptime - total time in seconds that the opcode cache has been active
  • total_file_count - total number of files that are currently in the opcode cache
  • total_hit_count - number of times the compiled opcode have been served from the cache
  • total_miss_count - number of times the compiled opcode have not been found in the cache
  • is_local_cache - true is the cache metadata is for a local cache instance, false if the metadata is for the global cache

  • file_entries - an array that contains the information about all the cached files:

    • file_name - absolute file name of the cached file
    • add_time - time in seconds since the file has been added to the opcode cache
    • use_time - time in seconds since the file has been accessed in the opcode cache
    • last_check - time in seconds since the file has been checked for modifications
    • hit_count - number of times the file has been served from the cache
    • function_count - number of functions in the cached file
    • class_count - number of classes in the cached file

Örnekler

Örnek 1 A wincache_ocache_fileinfo() example

<pre>
<?php
print_r(wincache_ocache_fileinfo());
?>
</pre>

Yukarıdaki örneğin çıktısı:

Array
(
    [total_cache_uptime] => 17357
    [total_file_count] => 121
    [total_hit_count] => 36562
    [total_miss_count] => 201
    [file_entries] => Array
        (
            [1] => Array
                (
                    [file_name] => c:\inetpub\wwwroot\checkcache.php
                    [add_time] => 17356
                    [use_time] => 7
                    [last_check] => 10
                    [hit_count] => 454
                    [function_count] => 0
                    [class_count] => 1
                )
            [2] => Array (...iterates for each cached file)
        )
)

Ayrıca Bakınız

  • wincache_fcache_fileinfo() - Retrieves information about files cached in the file cache
  • wincache_fcache_meminfo() - Retrieves information about file cache memory usage
  • wincache_ocache_meminfo() - Retrieves information about opcode cache memory usage
  • wincache_rplist_fileinfo() - Retrieves information about resolve file path cache
  • wincache_rplist_meminfo() - Retrieves information about memory usage by the resolve file path cache
  • wincache_refresh_if_changed() - Refreshes the cache entries for the cached files
  • wincache_ucache_meminfo() - Retrieves information about user cache memory usage
  • wincache_ucache_info() - Retrieves information about data stored in the user cache
  • wincache_scache_info() - Retrieves information about files cached in the session cache
  • wincache_scache_meminfo() - Retrieves information about session cache memory usage

wincache_lock
wincache_ocache_meminfo
WinCache İşlevleri


Retrieves information about opcode cache memory usage

wincache_ocache_fileinfo
wincache_refresh_if_changed
WinCache İşlevleri
PHP Manual

wincache_ocache_meminfo

(PECL wincache >= 1.0.0)

wincache_ocache_meminfo — Retrieves information about opcode cache memory usage

Açıklama

array wincache_ocache_meminfo ( void )

Retrieves information about memory usage by opcode cache.

Dönen Değerler

Array of meta data about opcode cache memory usage başarısızlık durumunda FALSE döner

The array returned by this function contains the following elements:

  • memory_total - amount of memory in bytes allocated for the opcode cache
  • memory_free - amount of free memory in bytes available for the opcode cache
  • num_used_blks - number of memory blocks used by the opcode cache
  • num_free_blks - number of free memory blocks available for the opcode cache
  • memory_overhead - amount of memory in bytes used for the opcode cache internal structures

Uyarı

Bu işlev PHP 7.0.0'da tamamen KALDIRILMIŞTIR.

Örnekler

Örnek 1 A wincache_ocache_meminfo() example

<pre>
<?php
print_r(wincache_ocache_meminfo());
?>
</pre>

Yukarıdaki örneğin çıktısı:

Array
(
    [memory_total] => 134217728
    [memory_free] => 112106972
    [num_used_blks] => 15469
    [num_free_blks] => 4
    [memory_overhead] => 247600
)

Ayrıca Bakınız

  • wincache_fcache_fileinfo() - Retrieves information about files cached in the file cache
  • wincache_fcache_meminfo() - Retrieves information about file cache memory usage
  • wincache_ocache_fileinfo() - Retrieves information about files cached in the opcode cache
  • wincache_rplist_fileinfo() - Retrieves information about resolve file path cache
  • wincache_rplist_meminfo() - Retrieves information about memory usage by the resolve file path cache
  • wincache_refresh_if_changed() - Refreshes the cache entries for the cached files
  • wincache_ucache_meminfo() - Retrieves information about user cache memory usage
  • wincache_ucache_info() - Retrieves information about data stored in the user cache
  • wincache_scache_info() - Retrieves information about files cached in the session cache
  • wincache_scache_meminfo() - Retrieves information about session cache memory usage

wincache_ocache_fileinfo
wincache_refresh_if_changed
WinCache İşlevleri


Refreshes the cache entries for the cached files

wincache_ocache_meminfo
wincache_rplist_fileinfo
WinCache İşlevleri
PHP Manual

wincache_refresh_if_changed

(PECL wincache >= 1.0.0)

wincache_refresh_if_changed — Refreshes the cache entries for the cached files

Açıklama

bool wincache_refresh_if_changed ([ array $files = NULL ] )

Refreshes the cache entries for the files, whose names were passed in the input argument. If no argument is specified then refreshes all the entries in the cache.

Değiştirgeler

files

An array of file names for files that need to be refreshed. An absolute or relative file paths can be used.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

WinCache performs regular checks on the cached files to ensure that if any file has changed then the corresponding entry in the cache is updated. By default this check is performed every 30 seconds. If, for example, a PHP script updates another PHP script where the application's configuration settings are stored, then it may happen that after the configuration settings have been saved to a file, the application is still using old settings for some time until the cache is refreshed. In those cases it may be preferrable to refresh the cache right after the file has been changed. The following example shows how this can be done.

Örnek 1 A wincache_refresh_if_changed() example

<?php
$filename = 'C:\inetpub\wwwroot\config.php';
$handle = fopen($filename, 'w+');
if ($handle === FALSE) die('Failed to open file '.$filename.' for writing');
fwrite($handle, '<?php $setting=something; ?>');
fclose($handle);
wincache_refresh_if_changed(array($filename));
?>

Ayrıca Bakınız

  • wincache_fcache_fileinfo() - Retrieves information about files cached in the file cache
  • wincache_fcache_meminfo() - Retrieves information about file cache memory usage
  • wincache_ocache_fileinfo() - Retrieves information about files cached in the opcode cache
  • wincache_ocache_meminfo() - Retrieves information about opcode cache memory usage
  • wincache_rplist_fileinfo() - Retrieves information about resolve file path cache
  • wincache_rplist_meminfo() - Retrieves information about memory usage by the resolve file path cache
  • wincache_ucache_meminfo() - Retrieves information about user cache memory usage
  • wincache_ucache_info() - Retrieves information about data stored in the user cache

wincache_ocache_meminfo
wincache_rplist_fileinfo
WinCache İşlevleri


Retrieves information about resolve file path cache

wincache_refresh_if_changed
wincache_rplist_meminfo
WinCache İşlevleri
PHP Manual

wincache_rplist_fileinfo

(PECL wincache >= 1.0.0)

wincache_rplist_fileinfo — Retrieves information about resolve file path cache

Açıklama

array wincache_rplist_fileinfo ([ bool $summaryonly = false ] )

Retrieves information about cached mappings between relative file paths and corresponding absolute file paths.

Dönen Değerler

Array of meta data about the resolve file path cache başarısızlık durumunda FALSE döner

The array returned by this function contains the following elements:

  • total_file_count - total number of file path mappings stored in the cache

  • rplist_entries - an array that contains the information about all the cached file paths:

    • resolve_path - path to a file
    • subkey_data - corresponding absolute path to a file

Örnekler

Örnek 1 A wincache_rplist_fileinfo() example

<pre>
<?php
print_r(wincache_rplist_fileinfo());
?>
</pre>

Yukarıdaki örneğin çıktısı:

Array
(
    [total_file_count] => 5
    [rplist_entries] => Array
        (
            [1] => Array
                (
                    [resolve_path] => checkcache.php
                    [subkey_data] => c:\inetpub\wwwroot|c:\inetpub\wwwroot\checkcache.php
                )

            [2] => Array (...iterates for each cached file)
        )
)

Ayrıca Bakınız

  • wincache_fcache_meminfo() - Retrieves information about file cache memory usage
  • wincache_fcache_fileinfo() - Retrieves information about files cached in the file cache
  • wincache_ocache_fileinfo() - Retrieves information about files cached in the opcode cache
  • wincache_ocache_meminfo() - Retrieves information about opcode cache memory usage
  • wincache_rplist_meminfo() - Retrieves information about memory usage by the resolve file path cache
  • wincache_refresh_if_changed() - Refreshes the cache entries for the cached files
  • wincache_ucache_meminfo() - Retrieves information about user cache memory usage
  • wincache_ucache_info() - Retrieves information about data stored in the user cache
  • wincache_scache_info() - Retrieves information about files cached in the session cache
  • wincache_scache_meminfo() - Retrieves information about session cache memory usage

wincache_refresh_if_changed
wincache_rplist_meminfo
WinCache İşlevleri


Retrieves information about memory usage by the resolve file path cache

wincache_rplist_fileinfo
wincache_scache_info
WinCache İşlevleri
PHP Manual

wincache_rplist_meminfo

(PECL wincache >= 1.0.0)

wincache_rplist_meminfo — Retrieves information about memory usage by the resolve file path cache

Açıklama

array wincache_rplist_meminfo ( void )

Retrieves information about memory usage by resolve file path cache.

Dönen Değerler

Array of meta data that describes memory usage by resolve file path cache. başarısızlık durumunda FALSE döner

The array returned by this function contains the following elements:

  • memory_total - amount of memory in bytes allocated for the resolve file path cache
  • memory_free - amount of free memory in bytes available for the resolve file path cache
  • num_used_blks - number of memory blocks used by the resolve file path cache
  • num_free_blks - number of free memory blocks available for the resolve file path cache
  • memory_overhead - amount of memory in bytes used for the internal structures of resolve file path cache

Örnekler

Örnek 1 A wincache_rplist_meminfo() example

<pre>
<?php
print_r(wincache_rplist_meminfo());
?>
</pre>

Yukarıdaki örneğin çıktısı:

Array
(
    [memory_total] => 9437184
    [memory_free] => 9416744
    [num_used_blks] => 23
    [num_free_blks] => 1
    [memory_overhead] => 416
)

Ayrıca Bakınız

  • wincache_fcache_fileinfo() - Retrieves information about files cached in the file cache
  • wincache_fcache_meminfo() - Retrieves information about file cache memory usage
  • wincache_ocache_fileinfo() - Retrieves information about files cached in the opcode cache
  • wincache_ocache_meminfo() - Retrieves information about opcode cache memory usage
  • wincache_rplist_fileinfo() - Retrieves information about resolve file path cache
  • wincache_refresh_if_changed() - Refreshes the cache entries for the cached files
  • wincache_ucache_meminfo() - Retrieves information about user cache memory usage
  • wincache_ucache_info() - Retrieves information about data stored in the user cache
  • wincache_scache_info() - Retrieves information about files cached in the session cache
  • wincache_scache_meminfo() - Retrieves information about session cache memory usage

wincache_rplist_fileinfo
wincache_scache_info
WinCache İşlevleri


Retrieves information about files cached in the session cache

wincache_rplist_meminfo
wincache_scache_meminfo
WinCache İşlevleri
PHP Manual

wincache_scache_info

(PECL wincache >= 1.1.0)

wincache_scache_info — Retrieves information about files cached in the session cache

Açıklama

array wincache_scache_info ([ bool $summaryonly = false ] )

Retrieves information about session cache content and its usage.

Değiştirgeler

summaryonly

Controls whether the returned array will contain information about individual cache entries along with the session cache summary.

Dönen Değerler

Array of meta data about session cache başarısızlık durumunda FALSE döner

The array returned by this function contains the following elements:

  • total_cache_uptime - total time in seconds that the session cache has been active
  • total_item_count - total number of elements that are currently in the session cache
  • is_local_cache - true is the cache metadata is for a local cache instance, false if the metadata is for the global cache
  • total_hit_count - number of times the data has been served from the cache
  • total_miss_count - number of times the data has not been found in the cache

  • scache_entries - an array that contains the information about all the cached items:

    • key_name - name of the key which is used to store the data
    • value_type - type of value stored by the key
    • use_time - time in seconds since the file has been accessed in the opcode cache
    • last_check - time in seconds since the file has been checked for modifications
    • ttl_seconds - time remaining for the data to live in the cache, 0 meaning infinite
    • age_seconds - time elapsed from the time data has been added in the cache
    • hitcount - number of times data has been served from the cache

Örnekler

Örnek 1 A wincache_scache_info() example

<pre>
<?php
print_r(wincache_scache_info());
?>
</pre>

Yukarıdaki örneğin çıktısı:

Array
(
    [total_cache_uptime] => 17357
    [total_file_count] => 121
    [total_hit_count] => 36562
    [total_miss_count] => 201
    [scache_entries] => Array
        (
            [1] => Array
                (
                    [file_name] => c:\inetpub\wwwroot\checkcache.php
                    [add_time] => 17356
                    [use_time] => 7
                    [last_check] => 10
                    [hit_count] => 454
                    [function_count] => 0
                    [class_count] => 1
                )
            [2] => Array (...iterates for each cached file)
        )
)

Ayrıca Bakınız

  • wincache_fcache_fileinfo() - Retrieves information about files cached in the file cache
  • wincache_fcache_meminfo() - Retrieves information about file cache memory usage
  • wincache_ocache_meminfo() - Retrieves information about opcode cache memory usage
  • wincache_rplist_fileinfo() - Retrieves information about resolve file path cache
  • wincache_rplist_meminfo() - Retrieves information about memory usage by the resolve file path cache
  • wincache_refresh_if_changed() - Refreshes the cache entries for the cached files
  • wincache_ucache_meminfo() - Retrieves information about user cache memory usage
  • wincache_ucache_info() - Retrieves information about data stored in the user cache
  • wincache_scache_meminfo() - Retrieves information about session cache memory usage

wincache_rplist_meminfo
wincache_scache_meminfo
WinCache İşlevleri


Retrieves information about session cache memory usage

wincache_scache_info
wincache_ucache_add
WinCache İşlevleri
PHP Manual

wincache_scache_meminfo

(PECL wincache >= 1.1.0)

wincache_scache_meminfo — Retrieves information about session cache memory usage

Açıklama

array wincache_scache_meminfo ( void )

Retrieves information about memory usage by session cache.

Dönen Değerler

Array of meta data about session cache memory usage başarısızlık durumunda FALSE döner

The array returned by this function contains the following elements:

  • memory_total - amount of memory in bytes allocated for the session cache
  • memory_free - amount of free memory in bytes available for the session cache
  • num_used_blks - number of memory blocks used by the session cache
  • num_free_blks - number of free memory blocks available for the session cache
  • memory_overhead - amount of memory in bytes used for the session cache internal structures

Örnekler

Örnek 1 A wincache_scache_meminfo() example

<pre>
<?php
print_r(wincache_scache_meminfo());
?>
</pre>

Yukarıdaki örneğin çıktısı:

Array
(
    [memory_total] => 5242880
    [memory_free] => 5215056
    [num_used_blks] => 6
    [num_free_blks] => 3
    [memory_overhead] => 176
)

Ayrıca Bakınız

  • wincache_fcache_fileinfo() - Retrieves information about files cached in the file cache
  • wincache_fcache_meminfo() - Retrieves information about file cache memory usage
  • wincache_ocache_fileinfo() - Retrieves information about files cached in the opcode cache
  • wincache_rplist_fileinfo() - Retrieves information about resolve file path cache
  • wincache_rplist_meminfo() - Retrieves information about memory usage by the resolve file path cache
  • wincache_refresh_if_changed() - Refreshes the cache entries for the cached files
  • wincache_ucache_info() - Retrieves information about data stored in the user cache
  • wincache_scache_info() - Retrieves information about files cached in the session cache

wincache_scache_info
wincache_ucache_add
WinCache İşlevleri


Adds a variable in user cache only if variable does not already exist in the cache

wincache_scache_meminfo
wincache_ucache_cas
WinCache İşlevleri
PHP Manual

wincache_ucache_add

(PECL wincache >= 1.1.0)

wincache_ucache_add — Adds a variable in user cache only if variable does not already exist in the cache

Açıklama

bool wincache_ucache_add ( string $key , mixed $value [, int $ttl = 0 ] )
bool wincache_ucache_add ( array $values [, mixed $unused = NULL [, int $ttl = 0 ]] )

Adds a variable in user cache, only if this variable doesn't already exist in the cache. The added variable remains in the user cache unless its time to live expires or it is deleted by using wincache_ucache_delete() or wincache_ucache_clear() functions.

Değiştirgeler

key

Store the variable using this key name. If a variable with same key is already present the function will fail and return FALSE. key is case sensitive. To override the value even if key is present use wincache_ucache_set() function instad. key can also take array of name => value pairs where names will be used as keys. This can be used to add multiple values in the cache in one operation, thus avoiding race condition.

value

Value of a variable to store. Value supports all data types except resources, such as file handles. This paramter is ignored if first argument is an array. A general guidance is to pass NULL as value while using array as key. If value is an object, or an array containing objects, then the objects will be serialized. See __sleep() for details on serializing objects.

values

Associative array of keys and values.

ttl

Time for the variable to live in the cache in seconds. After the value specified in ttl has passed the stored variable will be deleted from the cache. This parameter takes a default value of 0 which means the variable will stay in the cache unless explicitly deleted by using wincache_ucache_delete() or wincache_ucache_clear() functions.

Dönen Değerler

If key is string, the function returns TRUE on success and FALSE on failure.

If key is an array, the function returns:

  • If all the name => value pairs in the array can be set, function returns an empty array;
  • If all the name => value pairs in the array cannot be set, function returns FALSE;
  • If some can be set while others cannot, function returns an array with name=>value pair for which the addition failed in the user cache.

Örnekler

Örnek 1 wincache_ucache_add() with key as a string

<?php
$bar = 'BAR';
var_dump(wincache_ucache_add('foo', $bar));
var_dump(wincache_ucache_add('foo', $bar));
var_dump(wincache_ucache_get('foo'));
?>

Yukarıdaki örneğin çıktısı:

bool(true)
bool(false)
string(3) "BAR"

Örnek 2 wincache_ucache_add() with key as an array

<?php
$colors_array = array('green' => '5', 'Blue' => '6', 'yellow' => '7', 'cyan' => '8');
var_dump(wincache_ucache_add($colors_array));
var_dump(wincache_ucache_add($colors_array));
var_dump(wincache_ucache_get('Blue'));
?>

Yukarıdaki örneğin çıktısı:

array(0) { }
array(4) {
  ["green"]=> int(-1)
  ["Blue"]=> int(-1)
  ["yellow"]=> int(-1)
  ["cyan"]=> int(-1)
}
string(1) "6"

Ayrıca Bakınız

  • wincache_ucache_set() - Adds a variable in user cache and overwrites a variable if it already exists in the cache
  • wincache_ucache_get() - Gets a variable stored in the user cache
  • wincache_ucache_delete() - Deletes variables from the user cache
  • wincache_ucache_clear() - Deletes entire content of the user cache
  • wincache_ucache_exists() - Checks if a variable exists in the user cache
  • wincache_ucache_meminfo() - Retrieves information about user cache memory usage
  • wincache_ucache_info() - Retrieves information about data stored in the user cache
  • __sleep()

wincache_scache_meminfo
wincache_ucache_cas
WinCache İşlevleri


Compares the variable with old value and assigns new value to it

wincache_ucache_add
wincache_ucache_clear
WinCache İşlevleri
PHP Manual

wincache_ucache_cas

(PECL wincache >= 1.1.0)

wincache_ucache_cas — Compares the variable with old value and assigns new value to it

Açıklama

bool wincache_ucache_cas ( string $key , int $old_value , int $new_value )

Compares the variable associated with the key with old_value and if it matches then assigns the new_value to it.

Değiştirgeler

key

The key that is used to store the variable in the cache. key is case sensitive.

old_value

Old value of the variable pointed by key in the user cache. The value should be of type long, otherwise the function returns FALSE.

new_value

New value which will get assigned to variable pointer by key if a match is found. The value should be of type long, otherwise the function returns FALSE.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Using wincache_ucache_cas()

<?php
wincache_ucache_set('counter', 2922);
var_dump(wincache_ucache_cas('counter', 2922, 1));
var_dump(wincache_ucache_get('counter'));
?>

Yukarıdaki örneğin çıktısı:

bool(true)
int(1)

Ayrıca Bakınız

  • wincache_ucache_inc() - Increments the value associated with the key
  • wincache_ucache_dec() - Decrements the value associated with the key

wincache_ucache_add
wincache_ucache_clear
WinCache İşlevleri


Deletes entire content of the user cache

wincache_ucache_cas
wincache_ucache_dec
WinCache İşlevleri
PHP Manual

wincache_ucache_clear

(PECL wincache >= 1.1.0)

wincache_ucache_clear — Deletes entire content of the user cache

Açıklama

bool wincache_ucache_clear ( void )

Clears/deletes all the values stored in the user cache.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 using wincache_ucache_clear()

<?php
wincache_ucache_set('green', 1);
wincache_ucache_set('red', 2);
wincache_ucache_set('orange', 4);
wincache_ucache_set('blue', 8);
wincache_ucache_set('cyan', 16);
$array1 = array('green', 'red', 'orange', 'blue', 'cyan');
var_dump(wincache_ucache_get($array1));
var_dump(wincache_ucache_clear());
var_dump(wincache_ucache_get($array1));
?>

Yukarıdaki örneğin çıktısı:

array(5) { ["green"]=> int(1)
           ["red"]=> int(2)
           ["orange"]=> int(4)
           ["blue"]=> int(8)
           ["cyan"]=> int(16) }
bool(true)
bool(false)

Ayrıca Bakınız

  • wincache_ucache_set() - Adds a variable in user cache and overwrites a variable if it already exists in the cache
  • wincache_ucache_add() - Adds a variable in user cache only if variable does not already exist in the cache
  • wincache_ucache_delete() - Deletes variables from the user cache
  • wincache_ucache_get() - Gets a variable stored in the user cache
  • wincache_ucache_exists() - Checks if a variable exists in the user cache
  • wincache_ucache_meminfo() - Retrieves information about user cache memory usage
  • wincache_ucache_info() - Retrieves information about data stored in the user cache

wincache_ucache_cas
wincache_ucache_dec
WinCache İşlevleri


Decrements the value associated with the key

wincache_ucache_clear
wincache_ucache_delete
WinCache İşlevleri
PHP Manual

wincache_ucache_dec

(PECL wincache >= 1.1.0)

wincache_ucache_dec — Decrements the value associated with the key

Açıklama

mixed wincache_ucache_dec ( string $key [, int $dec_by = 1 [, bool &$success ]] )

Decrements the value associated with the key by 1 or as specified by dec_by.

Değiştirgeler

key

The key that was used to store the variable in the cache. key is case sensitive.

dec_by

The value by which the variable associated with the key will get decremented. If the argument is a floating point number it will be truncated to nearest integer. The variable associated with the key should be of type long, otherwise the function fails and returns FALSE.

success

Will be set to TRUE on success and FALSE on failure.

Dönen Değerler

Returns the decremented value on success and FALSE on failure.

Örnekler

Örnek 1 Using wincache_ucache_dec()

<?php
wincache_ucache_set('counter', 1);
var_dump(wincache_ucache_dec('counter', 2923, $success));
var_dump($success);
?>

Yukarıdaki örneğin çıktısı:

int(2922)
bool(true)

Ayrıca Bakınız

  • wincache_ucache_inc() - Increments the value associated with the key
  • wincache_ucache_cas() - Compares the variable with old value and assigns new value to it

wincache_ucache_clear
wincache_ucache_delete
WinCache İşlevleri


Deletes variables from the user cache

wincache_ucache_dec
wincache_ucache_exists
WinCache İşlevleri
PHP Manual

wincache_ucache_delete

(PECL wincache >= 1.1.0)

wincache_ucache_delete — Deletes variables from the user cache

Açıklama

bool wincache_ucache_delete ( mixed $key )

Deletes the elements in the user cache pointed by key.

Değiştirgeler

key

The key that was used to store the variable in the cache. key is case sensitive. key can be an array of keys.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

If key is an array then the function returns FALSE if every element of the array fails to get deleted from the user cache, otherwise returns an array which consists of all the keys that are deleted.

Örnekler

Örnek 1 Using wincache_ucache_delete() with key as a string

<?php
wincache_ucache_set('foo', 'bar');
var_dump(wincache_ucache_delete('foo'));
var_dump(wincache_ucache_exists('foo'));
?>

Yukarıdaki örneğin çıktısı:

bool(true)
bool(false)

Örnek 2 Usingwincache_ucache_delete() with key as an array

<?php
$array1 = array('green' => '5', 'blue' => '6', 'yellow' => '7', 'cyan' => '8');
wincache_ucache_set($array1);
$array2 = array('green', 'blue', 'yellow', 'cyan');
var_dump(wincache_ucache_delete($array2));
?>

Yukarıdaki örneğin çıktısı:

array(4) { [0]=> string(5) "green"
           [1]=> string(4) "Blue"
           [2]=> string(6) "yellow"
           [3]=> string(4) "cyan" }

Örnek 3 Using wincache_ucache_delete() with key as an array where some elements cannot be deleted

<?php
$array1 = array('green' => '5', 'blue' => '6', 'yellow' => '7', 'cyan' => '8');
wincache_ucache_set($array1);
$array2 = array('orange', 'red', 'yellow', 'cyan');
var_dump(wincache_ucache_delete($array2));
?>

Yukarıdaki örneğin çıktısı:

array(2) { [0]=> string(6) "yellow"
           [1]=> string(4) "cyan" }

Ayrıca Bakınız

  • wincache_ucache_set() - Adds a variable in user cache and overwrites a variable if it already exists in the cache
  • wincache_ucache_add() - Adds a variable in user cache only if variable does not already exist in the cache
  • wincache_ucache_get() - Gets a variable stored in the user cache
  • wincache_ucache_clear() - Deletes entire content of the user cache
  • wincache_ucache_exists() - Checks if a variable exists in the user cache
  • wincache_ucache_meminfo() - Retrieves information about user cache memory usage
  • wincache_ucache_info() - Retrieves information about data stored in the user cache

wincache_ucache_dec
wincache_ucache_exists
WinCache İşlevleri


Checks if a variable exists in the user cache

wincache_ucache_delete
wincache_ucache_get
WinCache İşlevleri
PHP Manual

wincache_ucache_exists

(PECL wincache >= 1.1.0)

wincache_ucache_exists — Checks if a variable exists in the user cache

Açıklama

bool wincache_ucache_exists ( string $key )

Checks if a variable with the key exists in the user cache or not.

Değiştirgeler

key

The key that was used to store the variable in the cache. key is case sensitive.

Dönen Değerler

Returns TRUE if variable with the key exitsts, otherwise returns FALSE.

Örnekler

Örnek 1 Using wincache_ucache_exists()

<?php
if (!wincache_ucache_exists('green'))
    wincache_ucache_set('green', 1);
var_dump(wincache_ucache_exists('green'));
?>

Yukarıdaki örneğin çıktısı:

bool(true)

Ayrıca Bakınız

  • wincache_ucache_set() - Adds a variable in user cache and overwrites a variable if it already exists in the cache
  • wincache_ucache_add() - Adds a variable in user cache only if variable does not already exist in the cache
  • wincache_ucache_get() - Gets a variable stored in the user cache
  • wincache_ucache_clear() - Deletes entire content of the user cache
  • wincache_ucache_delete() - Deletes variables from the user cache
  • wincache_ucache_meminfo() - Retrieves information about user cache memory usage
  • wincache_ucache_info() - Retrieves information about data stored in the user cache

wincache_ucache_delete
wincache_ucache_get
WinCache İşlevleri


Gets a variable stored in the user cache

wincache_ucache_exists
wincache_ucache_inc
WinCache İşlevleri
PHP Manual

wincache_ucache_get

(PECL wincache >= 1.1.0)

wincache_ucache_get — Gets a variable stored in the user cache

Açıklama

mixed wincache_ucache_get ( mixed $key [, bool &$success ] )

Gets a variable stored in the user cache.

Değiştirgeler

key

The key that was used to store the variable in the cache. key is case sensitive. key can be an array of keys. In this case the return value will be an array of values of each element in the key array. If an object, or an array containing objects, is returned, then the objects will be unserialized. See __wakeup() for details on unserializing objects.

success

Will be set to TRUE on success and FALSE on failure.

Dönen Değerler

If key is a string, the function returns the value of the variable stored with that key. The success is set to TRUE on success and to FALSE on failure.

The key is an array, the parameter success is always set to TRUE. The returned array (name => value pairs) will contain only those name => value pairs for which the get operation in user cache was successful. If none of the keys in the key array finds a match in the user cache an empty array will be returned.

Örnekler

Örnek 1 wincache_ucache_get() with key as a string

<?php
wincache_ucache_add('color', 'blue');
var_dump(wincache_ucache_get('color', $success));
var_dump($success);
?>

Yukarıdaki örneğin çıktısı:

string(4) "blue"
bool(true)

Örnek 2 wincache_ucache_get() with key as an array

<?php
$array1 = array('green' => '5', 'Blue' => '6', 'yellow' => '7', 'cyan' => '8');
wincache_ucache_set($array1);
$array2 = array('green', 'Blue', 'yellow', 'cyan');
var_dump(wincache_ucache_get($array2, $success));
var_dump($success);
?>

Yukarıdaki örneğin çıktısı:

array(4) { ["green"]=> string(1) "5"
           ["Blue"]=> string(1) "6"
           ["yellow"]=> string(1) "7"
           ["cyan"]=> string(1) "8" }
bool(true)

Ayrıca Bakınız

  • wincache_ucache_add() - Adds a variable in user cache only if variable does not already exist in the cache
  • wincache_ucache_set() - Adds a variable in user cache and overwrites a variable if it already exists in the cache
  • wincache_ucache_delete() - Deletes variables from the user cache
  • wincache_ucache_clear() - Deletes entire content of the user cache
  • wincache_ucache_exists() - Checks if a variable exists in the user cache
  • wincache_ucache_meminfo() - Retrieves information about user cache memory usage
  • wincache_ucache_info() - Retrieves information about data stored in the user cache
  • __wakeup()

wincache_ucache_exists
wincache_ucache_inc
WinCache İşlevleri


Increments the value associated with the key

wincache_ucache_get
wincache_ucache_info
WinCache İşlevleri
PHP Manual

wincache_ucache_inc

(PECL wincache >= 1.1.0)

wincache_ucache_inc — Increments the value associated with the key

Açıklama

mixed wincache_ucache_inc ( string $key [, int $inc_by = 1 [, bool &$success ]] )

Increments the value associated with the key by 1 or as specified by inc_by.

Değiştirgeler

key

The key that was used to store the variable in the cache. key is case sensitive.

inc_by

The value by which the variable associated with the key will get incremented. If the argument is a floating point number it will be truncated to nearest integer. The variable associated with the key should be of type long, otherwise the function fails and returns FALSE.

success

Will be set to TRUE on success and FALSE on failure.

Dönen Değerler

Returns the incremented value on success and FALSE on failure.

Örnekler

Örnek 1 Using wincache_ucache_inc()

<?php
wincache_ucache_set('counter', 1);
var_dump(wincache_ucache_inc('counter', 2921, $success));
var_dump($success);
?>

Yukarıdaki örneğin çıktısı:

int(2922)
bool(true)

Ayrıca Bakınız

  • wincache_ucache_dec() - Decrements the value associated with the key
  • wincache_ucache_cas() - Compares the variable with old value and assigns new value to it

wincache_ucache_get
wincache_ucache_info
WinCache İşlevleri


Retrieves information about data stored in the user cache

wincache_ucache_inc
wincache_ucache_meminfo
WinCache İşlevleri
PHP Manual

wincache_ucache_info

(PECL wincache >= 1.1.0)

wincache_ucache_info — Retrieves information about data stored in the user cache

Açıklama

array wincache_ucache_info ([ bool $summaryonly = false [, string $key = NULL ]] )

Retrieves information about data stored in the user cache.

Değiştirgeler

summaryonly

Controls whether the returned array will contain information about individual cache entries along with the user cache summary.

key

The key of an entry in the user cache. If specified then the returned array will contain information only about that cache entry. If not specified and summaryonly is set to FALSE then the returned array will contain information about all entries in the cache.

Dönen Değerler

Array of meta data about user cache başarısızlık durumunda FALSE döner

The array returned by this function contains the following elements:

  • total_cache_uptime - total time in seconds that the user cache has been active
  • total_item_count - total number of elements that are currently in the user cache
  • is_local_cache - true is the cache metadata is for a local cache instance, false if the metadata is for the global cache
  • total_hit_count - number of times the data has been served from the cache
  • total_miss_count - number of times the data has not been found in the cache

  • ucache_entries - an array that contains the information about all the cached items:

    • key_name - name of the key which is used to store the data
    • value_type - type of value stored by the key
    • use_time - time in seconds since the file has been accessed in the opcode cache
    • last_check - time in seconds since the file has been checked for modifications
    • is_session - indicates if the data is a session variable
    • ttl_seconds - time remaining for the data to live in the cache, 0 meaning infinite
    • age_seconds - time elapsed from the time data has been added in the cache
    • hitcount - number of times data has been served from the cache

Örnekler

Örnek 1 Using wincache_ucache_info()

<?php
wincache_ucache_get('green');
wincache_ucache_set('green', 2922);
wincache_ucache_get('green');
wincache_ucache_get('green');
wincache_ucache_get('green');
print_r(wincache_ucache_info());
?>

Yukarıdaki örneğin çıktısı:

Array
( ["total_cache_uptime"] => int(0)
  ["is_local_cache"] => bool(false)
  ["total_item_count"] => int(1)
  ["total_hit_count"] => int(3)
  ["total_miss_count"] => int(1)
  ["ucache_entries"] => Array(1)
    ( [1] => Array(6)
      (
        ["key_name"] => string(5) "green"
        ["value_type"] => string(4) "long"
        ["is_session"] => int(0)
        ["ttl_seconds"] => int(0)
        ["age_seconds"] => int(0)
        ["hitcount"] => int(3)
       )
    )
)

Ayrıca Bakınız

  • wincache_fcache_meminfo() - Retrieves information about file cache memory usage
  • wincache_ocache_fileinfo() - Retrieves information about files cached in the opcode cache
  • wincache_ocache_meminfo() - Retrieves information about opcode cache memory usage
  • wincache_rplist_meminfo() - Retrieves information about memory usage by the resolve file path cache
  • wincache_rplist_fileinfo() - Retrieves information about resolve file path cache
  • wincache_refresh_if_changed() - Refreshes the cache entries for the cached files
  • wincache_ucache_meminfo() - Retrieves information about user cache memory usage
  • wincache_scache_info() - Retrieves information about files cached in the session cache
  • wincache_scache_meminfo() - Retrieves information about session cache memory usage

wincache_ucache_inc
wincache_ucache_meminfo
WinCache İşlevleri


Retrieves information about user cache memory usage

wincache_ucache_info
wincache_ucache_set
WinCache İşlevleri
PHP Manual

wincache_ucache_meminfo

(PECL wincache >= 1.1.0)

wincache_ucache_meminfo — Retrieves information about user cache memory usage

Açıklama

array wincache_ucache_meminfo ( void )

Retrieves information about memory usage by user cache.

Dönen Değerler

Array of meta data about user cache memory usage başarısızlık durumunda FALSE döner

The array returned by this function contains the following elements:

  • memory_total - amount of memory in bytes allocated for the user cache
  • memory_free - amount of free memory in bytes available for the user cache
  • num_used_blks - number of memory blocks used by the user cache
  • num_free_blks - number of free memory blocks available for the user cache
  • memory_overhead - amount of memory in bytes used for the user cache internal structures

Örnekler

Örnek 1 A wincache_ucache_meminfo() example

<pre>
<?php
print_r(wincache_ucache_meminfo());
?>
</pre>

Yukarıdaki örneğin çıktısı:

Array
(
    [memory_total] => 5242880
    [memory_free] => 5215056
    [num_used_blks] => 6
    [num_free_blks] => 3
    [memory_overhead] => 176
)

Ayrıca Bakınız

  • wincache_fcache_fileinfo() - Retrieves information about files cached in the file cache
  • wincache_fcache_meminfo() - Retrieves information about file cache memory usage
  • wincache_ocache_fileinfo() - Retrieves information about files cached in the opcode cache
  • wincache_rplist_fileinfo() - Retrieves information about resolve file path cache
  • wincache_rplist_meminfo() - Retrieves information about memory usage by the resolve file path cache
  • wincache_refresh_if_changed() - Refreshes the cache entries for the cached files
  • wincache_ucache_info() - Retrieves information about data stored in the user cache
  • wincache_scache_info() - Retrieves information about files cached in the session cache
  • wincache_scache_meminfo() - Retrieves information about session cache memory usage

wincache_ucache_info
wincache_ucache_set
WinCache İşlevleri


Adds a variable in user cache and overwrites a variable if it already exists in the cache

wincache_ucache_meminfo
wincache_unlock
WinCache İşlevleri
PHP Manual

wincache_ucache_set

(PECL wincache >= 1.1.0)

wincache_ucache_set — Adds a variable in user cache and overwrites a variable if it already exists in the cache

Açıklama

bool wincache_ucache_set ( mixed $key , mixed $value [, int $ttl = 0 ] )
bool wincache_ucache_set ( array $values [, mixed $unused = NULL [, int $ttl = 0 ]] )

Adds a variable in user cache. Overwrites a variable if it already exists in the cache. The added or updated variable remains in the user cache unless its time to live expires or it is deleted by using wincache_ucache_delete() or wincache_ucache_clear() functions.

Değiştirgeler

key

Store the variable using this key name. If a variable with same key is already present the function will overwrite the previous value with the new one. key is case sensitive. key can also take array of name => value pairs where names will be used as keys. This can be used to add multiple values in the cache in one operation, thus avoiding race condition.

value

Value of a variable to store. Value supports all data types except resources, such as file handles. This paramter is ignored if first argument is an array. A general guidance is to pass NULL as value while using array as key. If value is an object, or an array containing objects, then the objects will be serialized. See __sleep() for details on serializing objects.

values

Associative array of keys and values.

ttl

Time for the variable to live in the cache in seconds. After the value specified in ttl has passed the stored variable will be deleted from the cache. This parameter takes a default value of 0 which means the variable will stay in the cache unless explicitly deleted by using wincache_ucache_delete() or wincache_ucache_clear() functions.

Dönen Değerler

If key is string, the function returns TRUE on success and FALSE on failure.

If key is an array, the function returns:

  • If all the name => value pairs in the array can be set, function returns an empty array;
  • If all the name => value pairs in the array cannot be set, function returns FALSE;
  • If some can be set while others cannot, function returns an array with name=>value pair for which the addition failed in the user cache.

Örnekler

Örnek 1 wincache_ucache_set() with key as a string

<?php
$bar = 'BAR';
var_dump(wincache_ucache_set('foo', $bar));
var_dump(wincache_ucache_get('foo'));
$bar1 = 'BAR1';
var_dump(wincache_ucache_set('foo', $bar1));
var_dump(wincache_ucache_get('foo'));
?>

Yukarıdaki örneğin çıktısı:

bool(true)
string(3) "BAR"
bool(true)
string(3) "BAR1"

Örnek 2 wincache_ucache_set() with key as an array

<?php
$colors_array = array('green' => '5', 'Blue' => '6', 'yellow' => '7', 'cyan' => '8');
var_dump(wincache_ucache_set($colors_array));
var_dump(wincache_ucache_set($colors_array));
var_dump(wincache_ucache_get('Blue'));
?>

Yukarıdaki örneğin çıktısı:

array(0) {}
array(0) {}
string(1) "6"

Ayrıca Bakınız

  • wincache_ucache_add() - Adds a variable in user cache only if variable does not already exist in the cache
  • wincache_ucache_get() - Gets a variable stored in the user cache
  • wincache_ucache_delete() - Deletes variables from the user cache
  • wincache_ucache_clear() - Deletes entire content of the user cache
  • wincache_ucache_exists() - Checks if a variable exists in the user cache
  • wincache_ucache_meminfo() - Retrieves information about user cache memory usage
  • wincache_ucache_info() - Retrieves information about data stored in the user cache
  • __sleep()

wincache_ucache_meminfo
wincache_unlock
WinCache İşlevleri


Releases an exclusive lock on a given key

wincache_ucache_set
Building for Windows
WinCache İşlevleri
PHP Manual

wincache_unlock

(PECL wincache >= 1.1.0)

wincache_unlock — Releases an exclusive lock on a given key

Açıklama

bool wincache_unlock ( string $key )

Releases an exclusive lock that was obtained on a given key by using wincache_lock(). If any other process was blocked waiting for the lock on this key, that process will be able to obtain the lock.

Uyarı

Using of the wincache_lock() and wincache_unlock() can cause deadlocks when executing PHP scripts in a multi-process environment like FastCGI. Do not use these functions unless you are absolutely sure you need to use them. For the majority of the operations on the user cache it is not necessary to use these functions.

Değiştirgeler

key

Name of the key in the cache to release the lock on.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Using wincache_unlock()

<?php
$fp = fopen("/tmp/lock.txt", "r+");
if (wincache_lock("lock_txt_lock")) { // do an exclusive lock
    ftruncate($fp, 0); // truncate file
    fwrite($fp, "Write something here\n");
    wincache_unlock("lock_txt_lock"); // release the lock
} else {
    echo "Couldn't get the lock!";
}
fclose($fp);
?>

Ayrıca Bakınız

  • wincache_lock() - Acquires an exclusive lock on a given key
  • wincache_ucache_set() - Adds a variable in user cache and overwrites a variable if it already exists in the cache
  • wincache_ucache_get() - Gets a variable stored in the user cache
  • wincache_ucache_delete() - Deletes variables from the user cache
  • wincache_ucache_clear() - Deletes entire content of the user cache
  • wincache_ucache_exists() - Checks if a variable exists in the user cache
  • wincache_ucache_meminfo() - Retrieves information about user cache memory usage
  • wincache_ucache_info() - Retrieves information about data stored in the user cache
  • wincache_scache_info() - Retrieves information about files cached in the session cache

wincache_ucache_set
Building for Windows
WinCache İşlevleri


Building for Windows

İçindekiler

  • Prerequisites
  • Compiling and building
  • Verifying the build
wincache_unlock
Prerequisites
WinCache


Prerequisites

Building WinCache extension will require:

  1. PHP source code
  2. PHP build environment
  3. WinCache source code

For completing first two steps, follow the step-by-step guide for how to » build PHP on Windows.

For getting the WinCache source code follow the instructions described in Downloading PECL extensions.

Building for Windows
Compiling and building
Building for Windows


Compiling and building

The following steps describe how to compile and build WinCache on Windows OS:

  1. Open a command prompt which is used to build PHP

  2. Go to the root folder where PHP sources are present

  3. Run the command:

    cscript.exe win32\build\buildconf.js

  4. Run the command:

    configure.bat --help
    The output will contain a new flag --enable-wincache.

  5. Run the command:

    configure.js [all options used to build PHP] --enable-wincache
    --enable-wincache is the only extra option which is required to ensure that WinCache extension gets built properly. This option will build WinCache and will statically link it with PHP dll. To build WinCache extension as a stand-alone DLL use the option --enable-wincache=shared.

  6. Run the command:

    nmake

Prerequisites
Verifying the build
Building for Windows


Verifying the build

The following steps describe how to verify that WinCache has been built correctly:

  1. Go to the folder where the PHP binaries are built

  2. Run the command:

    php.exe -n -d extension=php_wincache.dll -re wincache
    If WinCache has been built properly, the output of this command will list the INI directives and functions supported by WinCache.

Compiling and building
Xhprof
Building for Windows


Hierarchical Profiler

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
  • Xhprof İşlevleri
    • xhprof_disable — Stops xhprof profiler
    • xhprof_enable — Start xhprof profiler
    • xhprof_sample_disable — Stops xhprof sample profiler
    • xhprof_sample_enable — Start XHProf profiling in sampling mode
Verifying the build
Giriş
PHP'nin Davranışını Etkileyenler


Giriş

XHProf is a light-weight hierarchical and instrumentation based profiler. During the data collection phase, it keeps track of call counts and inclusive metrics for arcs in the dynamic callgraph of a program. It computes exclusive metrics in the reporting/post processing phase, such as wall (elapsed) time, CPU time and memory usage. A functions profile can be broken down by callers or callees. XHProf handles recursive functions by detecting cycles in the callgraph at data collection time itself and avoiding the cycles by giving unique depth qualified names for the recursive invocations.

XHProf includes a simple HTML based user interface (written in PHP). The browser based UI for viewing profiler results makes it easy to view results or to share results with peers. A callgraph image view is also supported.

XHProf reports can often be helpful in understanding the structure of the code being executed. The hierarchical nature of the reports can be used to determine, for example, what chain of calls led to a particular function getting called.

XHProf supports ability to compare two runs (a.k.a. "diff" reports) or aggregate data from multiple runs. Diff and aggregate reports, much like single run reports, offer "flat" as well as "hierarchical" views of the profile.

Additional documentation can be found via the » facebook xhprof website.

Xhprof
Yapılandırma/Kurulum
Xhprof


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Xhprof


Gereksinimler

Although not required, xhprof includes an interface that's written in PHP. It's used to save and display the profiled data in a usable way, where viewing is done via a web browser. So, a PHP enabled web server will likely make the xhprof experience more useful.

There's also a fork of the GUI interface at » http://github.com/preinheimer/xhprof

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/xhprof

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Xhprof Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
xhprof.output_dir | "" | PHP_INI_ALL |

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

xhprof.output_dir string

Directory used by the default implementation of the iXHProfRuns interface (namely, the XHProfRuns_Default class) for storing XHProf runs.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

XHPROF_FLAGS_NO_BUILTINS (integer)
Used to skip all built-in (internal) functions.
XHPROF_FLAGS_CPU (integer)
Used to add CPU profiling information to the output.
XHPROF_FLAGS_MEMORY (integer)
Used to add memory profiling information to the output.
Özkaynak Türleri
Örnekler
Xhprof


Örnekler

Örnek 1 Xhprof example with the optional GUI

This example starts and stops the profiler, then uses the bundled GUI interface to save and parse the results. In other words, the code from the extension itself ends at the call to xhprof_disable().

<?php
xhprof_enable(XHPROF_FLAGS_CPU + XHPROF_FLAGS_MEMORY);

for ($i = 0; $i <= 1000; $i++) {
    $a = $i * $i;
}

$xhprof_data = xhprof_disable();

$XHPROF_ROOT = "/tools/xhprof/";
include_once $XHPROF_ROOT . "/xhprof_lib/utils/xhprof_lib.php";
include_once $XHPROF_ROOT . "/xhprof_lib/utils/xhprof_runs.php";

$xhprof_runs = new XHProfRuns_Default();
$run_id = $xhprof_runs->save_run($xhprof_data, "xhprof_testing");

echo "http://localhost/xhprof/xhprof_html/index.php?run={$run_id}&source=xhprof_testing\n";

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

http://localhost/xhprof/xhprof_html/index.php?run=t11_4bdf44d21121f&source=xhprof_testing
Öntanımlı Sabitler
Xhprof İşlevleri
Xhprof


Xhprof İşlevleri

İçindekiler

  • xhprof_disable — Stops xhprof profiler
  • xhprof_enable — Start xhprof profiler
  • xhprof_sample_disable — Stops xhprof sample profiler
  • xhprof_sample_enable — Start XHProf profiling in sampling mode
Örnekler
xhprof_disable
Xhprof


Stops xhprof profiler

Xhprof İşlevleri
xhprof_enable
Xhprof İşlevleri
PHP Manual

xhprof_disable

(PECL xhprof >= 0.9.0)

xhprof_disable — Stops xhprof profiler

Açıklama

array xhprof_disable ( void )

Stops the profiler, and returns xhprof data from the run.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

An array of xhprof data, from the run.

Örnekler

Örnek 1 xhprof_disable() example

<?php
xhprof_enable();

$foo = strlen("foo bar");

$xhprof_data = xhprof_disable();

print_r($xhprof_data);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [main()==>strlen] => Array
        (
            [ct] => 1
            [wt] => 279
        )

    [main()==>xhprof_disable] => Array
        (
            [ct] => 1
            [wt] => 9
        )

    [main()] => Array
        (
            [ct] => 1
            [wt] => 610
        )

)
Xhprof İşlevleri
xhprof_enable
Xhprof İşlevleri


Start xhprof profiler

xhprof_disable
xhprof_sample_disable
Xhprof İşlevleri
PHP Manual

xhprof_enable

(PECL xhprof >= 0.9.0)

xhprof_enable — Start xhprof profiler

Açıklama

void xhprof_enable ([ int $flags = 0 [, array $options ]] )

Start xhprof profiling.

Değiştirgeler

flags

Optional flags to add additional information to the profiling. See the XHprof constants for further information about these flags, e.g., XHPROF_FLAGS_MEMORY to enable memory profiling.

options

An array of optional options, namely, the 'ignored_functions' option to pass in functions to be ignored during profiling.

Dönen Değerler

NULL

Sürüm Bilgisi

Sürüm: | Açıklama
0.9.2 | The optional options parameter was added.

Örnekler

Örnek 1 xhprof_enable() examples

<?php
// 1. elapsed time + memory + CPU profiling; and ignore built-in (internal) functions
xhprof_enable(XHPROF_FLAGS_NO_BUILTINS | XHPROF_FLAGS_CPU | XHPROF_FLAGS_MEMORY);

// 2. elapsed time profiling; ignore call_user_func* during profiling
xhprof_enable(
    0,
    array('ignored_functions' =>  array('call_user_func',
                                        'call_user_func_array')));

// 3. elapsed time + memory profiling; ignore call_user_func* during profiling
xhprof_enable(
    XHPROF_FLAGS_MEMORY,
    array('ignored_functions' =>  array('call_user_func',
                                        'call_user_func_array')));
?>

Ayrıca Bakınız

  • xhprof_disable() - Stops xhprof profiler
  • xhprof_sample_enable() - Start XHProf profiling in sampling mode
  • memory_get_usage() - PHP'ye ayrılan belleğin miktarını döndürür
  • getrusage() - Geçerli özkaynak kullanımlarını döndürür
xhprof_disable
xhprof_sample_disable
Xhprof İşlevleri


Stops xhprof sample profiler

xhprof_enable
xhprof_sample_enable
Xhprof İşlevleri
PHP Manual

xhprof_sample_disable

(PECL xhprof >= 0.9.0)

xhprof_sample_disable — Stops xhprof sample profiler

Açıklama

array xhprof_sample_disable ( void )

Stops the sample mode xhprof profiler, and

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

An array of xhprof sample data, from the run.

Örnekler

Örnek 1 xhprof_sample_disable() example

<?php
xhprof_sample_enable();

for ($i = 0; $i <= 10000; $i++) {
    $a = strlen($i);
    $b = $i * $a;
    $c = rand();
}

$xhprof_data = xhprof_sample_disable();

print_r($xhprof_data);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [1272935300.800000] => main()
    [1272935300.900000] => main()
)
xhprof_enable
xhprof_sample_enable
Xhprof İşlevleri


Start XHProf profiling in sampling mode

xhprof_sample_disable
Ses Biçemleme İşlemleri
Xhprof İşlevleri
PHP Manual

xhprof_sample_enable

(PECL xhprof >= 0.9.0)

xhprof_sample_enable — Start XHProf profiling in sampling mode

Açıklama

void xhprof_sample_enable ( void )

Starts profiling in sample mode, which is a lighter weight version of xhprof_enable(). The sampling interval is 0.1 seconds, and samples record the full function call stack. The main use case is when lower overhead is required when doing performance monitoring and diagnostics.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

NULL

Ayrıca Bakınız

  • xhprof_sample_disable() - Stops xhprof sample profiler
  • xhprof_enable() - Start xhprof profiler
  • memory_get_usage() - PHP'ye ayrılan belleğin miktarını döndürür
  • getrusage() - Geçerli özkaynak kullanımlarını döndürür
xhprof_sample_disable
Ses Biçemleme İşlemleri
Xhprof İşlevleri


Ses Biçemleme İşlemleri

  • ID3 — ID3 Tags
    • Giriş
    • Yapılandırma/Kurulum
    • Predefined Constants
    • ID3 İşlevleri
  • KTaglib
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • KTaglib_MPEG_File — The KTaglib_MPEG_File class
    • KTaglib_MPEG_AudioProperties — The KTaglib_MPEG_AudioProperties class
    • KTaglib_Tag — The KTaglib_Tag class
    • KTaglib_ID3v2_Tag — The KTaglib_ID3v2_Tag class
    • KTaglib_ID3v2_Frame — The KTaglib_ID3v2_Frame class
    • KTaglib_ID3v2_AttachedPictureFrame — The KTaglib_ID3v2_AttachedPictureFrame class
  • oggvorbis — OGG/Vorbis
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Context options
    • Örnekler
  • OpenAL — OpenAL Audio Bindings
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • OpenAL İşlevleri
xhprof_sample_enable
ID3
İşlev Başvuru Kılavuzu


ID3 Tags

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Predefined Constants
  • ID3 İşlevleri
    • id3_get_frame_long_name — Get the long name of an ID3v2 frame
    • id3_get_frame_short_name — Get the short name of an ID3v2 frame
    • id3_get_genre_id — Get the id for a genre
    • id3_get_genre_list — Get all possible genre values
    • id3_get_genre_name — Get the name for a genre id
    • id3_get_tag — Get all information stored in an ID3 tag
    • id3_get_version — Get version of an ID3 tag
    • id3_remove_tag — Remove an existing ID3 tag
    • id3_set_tag — Update information stored in an ID3 tag
Ses Biçemleme İşlemleri
Giriş
Ses Biçemleme İşlemleri


Giriş

These functions let you read and manipulate ID3 tags. ID3 tags are used in MP3 files to store title of the song, as well as information about the artist, album, genre, year and track number.

Since version 0.2 it is also possible to extract text frames from ID3 v2.2+ tags.

ID3
Yapılandırma/Kurulum
ID3


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
ID3


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/id3.

Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Özkaynak Türleri

Bu eklentinin tanımlı hiçbir özkaynak türü yoktur.

Çalışma Anı Yapılandırması
Predefined Constants
Yapılandırma/Kurulum


Predefined Constants

Most of the id3 functions either let you specify or return a tag version. In order to specify the version please use on of these constants.

ID3_V1_0 (integer)
ID3_V1_0 is used if you are working with ID3 V1.0 tags. These tags may contain the fields title, artist, album, genre, year and comment.
ID3_V1_1 (integer)
ID3_V1_1 is used if you are working with ID3 V1.1 tags. These tags may all information contained in v1.0 tags plus the track number.
ID3_V2_1 (integer)
ID3_V2_1 is used if you are working with ID3 V2.1 tags.
ID3_V2_2 (integer)
ID3_V2_2 is used if you are working with ID3 V2.2 tags.
ID3_V2_3 (integer)
ID3_V2_3 is used if you are working with ID3 V2.3 tags.
ID3_V2_4 (integer)
ID3_V2_4 is used if you are working with ID3 V2.4 tags.
ID3_BEST (integer)
ID3_BEST is used if would like to let the id3 functions determine which tag version should be used.

Özkaynak Türleri
ID3 İşlevleri
ID3


ID3 İşlevleri

İçindekiler

  • id3_get_frame_long_name — Get the long name of an ID3v2 frame
  • id3_get_frame_short_name — Get the short name of an ID3v2 frame
  • id3_get_genre_id — Get the id for a genre
  • id3_get_genre_list — Get all possible genre values
  • id3_get_genre_name — Get the name for a genre id
  • id3_get_tag — Get all information stored in an ID3 tag
  • id3_get_version — Get version of an ID3 tag
  • id3_remove_tag — Remove an existing ID3 tag
  • id3_set_tag — Update information stored in an ID3 tag
Predefined Constants
id3_get_frame_long_name
ID3


Get the long name of an ID3v2 frame

ID3 İşlevleri
id3_get_frame_short_name
ID3 İşlevleri
PHP Manual

id3_get_frame_long_name

(PECL id3 >= 0.2)

id3_get_frame_long_name — Get the long name of an ID3v2 frame

Açıklama

string id3_get_frame_long_name ( string $frameId )

id3_get_frame_long_name() returns the long name for an ID3v2 frame.

Değiştirgeler

frameId

An ID3v2 frame

Dönen Değerler

Returns the frame long name or FALSE on errors.

Örnekler

Örnek 1 id3_get_frame_long_name() example

<?php
$longName = id3_get_frame_long_name("TOLY");
echo $longName;
?>

Yukarıdaki örneğin çıktısı:

Original lyricist(s)/text writer(s)

Ayrıca Bakınız

  • id3_get_frame_short_name() - Get the short name of an ID3v2 frame

ID3 İşlevleri
id3_get_frame_short_name
ID3 İşlevleri


Get the short name of an ID3v2 frame

id3_get_frame_long_name
id3_get_genre_id
ID3 İşlevleri
PHP Manual

id3_get_frame_short_name

(PECL id3 >= 0.2)

id3_get_frame_short_name — Get the short name of an ID3v2 frame

Açıklama

string id3_get_frame_short_name ( string $frameId )

id3_get_frame_short_name() returns the short name for an ID3v2 frame.

Değiştirgeler

frameId

An ID3v2 frame

Dönen Değerler

Returns the frame short name or FALSE on errors.

The values returned by id3_get_frame_short_name() are used in the array returned by id3_get_tag().

Örnekler

Örnek 1 id3_get_frame_short_name() example

<?php
$shortName = id3_get_frame_short_name("TOLY");
echo $shortName;
?>

Yukarıdaki örneğin çıktısı:

originalLyricist

Ayrıca Bakınız

  • id3_get_frame_long_name() - Get the long name of an ID3v2 frame

id3_get_frame_long_name
id3_get_genre_id
ID3 İşlevleri


Get the id for a genre

id3_get_frame_short_name
id3_get_genre_list
ID3 İşlevleri
PHP Manual

id3_get_genre_id

(PECL id3 >= 0.1)

id3_get_genre_id — Get the id for a genre

Açıklama

int id3_get_genre_id ( string $genre )

id3_get_genre_id() returns the id for a genre.

Değiştirgeler

genre

Genre name as string.

Dönen Değerler

The genre id or FALSE on errors.

Örnekler

Örnek 1 id3_get_genre_id() example

<?php
$id = id3_get_genre_id("Alternative");
echo $id;
?>

Yukarıdaki örneğin çıktısı:

20

Ayrıca Bakınız

  • id3_get_genre_name() - Get the name for a genre id
  • id3_get_genre_list() - Get all possible genre values

id3_get_frame_short_name
id3_get_genre_list
ID3 İşlevleri


Get all possible genre values

id3_get_genre_id
id3_get_genre_name
ID3 İşlevleri
PHP Manual

id3_get_genre_list

(PECL id3 >= 0.1)

id3_get_genre_list — Get all possible genre values

Açıklama

array id3_get_genre_list ( void )

id3_get_genre_list() returns an array containing all possible genres that may be stored in an ID3 tag. This list has been created by Eric Kemp and later extended by WinAmp.

This function is useful to provide you users a list of genres from which they may choose one. When updating the ID3 tag you will always have to specify the genre as an integer ranging from 0 to 147.

Dönen Değerler

Returns an array containing all possible genres that may be stored in an ID3 tag.

Örnekler

Örnek 1 id3_get_genre_list() example

<?php
$genres = id3_get_genre_list();
print_r($genres);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [0] => Blues
    [1] => Classic Rock
    [2] => Country
    [3] => Dance
    [4] => Disco
    [5] => Funk
    [6] => Grunge
    [7] => Hip-Hop
    [8] => Jazz
    [9] => Metal
    [10] => New Age
    [11] => Oldies
    [12] => Other
    [13] => Pop
    [14] => R&B
    [15] => Rap
    [16] => Reggae
    [17] => Rock
    [18] => Techno
    [19] => Industrial
    [20] => Alternative
    [21] => Ska
    [22] => Death Metal
    [23] => Pranks
    [24] => Soundtrack
    [25] => Euro-Techno
    [26] => Ambient
    [27] => Trip-Hop
    [28] => Vocal
    [29] => Jazz+Funk
    [30] => Fusion
    [31] => Trance
    [32] => Classical
    [33] => Instrumental
    [34] => Acid
    [35] => House
    [36] => Game
    [37] => Sound Clip
    [38] => Gospel
    [39] => Noise
    [40] => Alternative Rock
    [41] => Bass
    [42] => Soul
    [43] => Punk
    [44] => Space
    [45] => Meditative
    [46] => Instrumental Pop
    [47] => Instrumental Rock
    [48] => Ethnic
    [49] => Gothic
    [50] => Darkwave
    [51] => Techno-Industrial
    [52] => Electronic
    [53] => Pop-Folk
    [54] => Eurodance
    [55] => Dream
    [56] => Southern Rock
    [57] => Comedy
    [58] => Cult
    [59] => Gangsta
    [60] => Top 40
    [61] => Christian Rap
    [62] => Pop/Funk
    [63] => Jungle
    [64] => Native US
    [65] => Cabaret
    [66] => New Wave
    [67] => Psychadelic
    [68] => Rave
    [69] => Showtunes
    [70] => Trailer
    [71] => Lo-Fi
    [72] => Tribal
    [73] => Acid Punk
    [74] => Acid Jazz
    [75] => Polka
    [76] => Retro
    [77] => Musical
    [78] => Rock & Roll
    [79] => Hard Rock
    [80] => Folk
    [81] => Folk-Rock
    [82] => National Folk
    [83] => Swing
    [84] => Fast Fusion
    [85] => Bebob
    [86] => Latin
    [87] => Revival
    [88] => Celtic
    [89] => Bluegrass
    [90] => Avantgarde
    [91] => Gothic Rock
    [92] => Progressive Rock
    [93] => Psychedelic Rock
    [94] => Symphonic Rock
    [95] => Slow Rock
    [96] => Big Band
    [97] => Chorus
    [98] => Easy Listening
    [99] => Acoustic
    [100] => Humour
    [101] => Speech
    [102] => Chanson
    [103] => Opera
    [104] => Chamber Music
    [105] => Sonata
    [106] => Symphony
    [107] => Booty Bass
    [108] => Primus
    [109] => Porn Groove
    [110] => Satire
    [111] => Slow Jam
    [112] => Club
    [113] => Tango
    [114] => Samba
    [115] => Folklore
    [116] => Ballad
    [117] => Power Ballad
    [118] => Rhytmic Soul
    [119] => Freestyle
    [120] => Duet
    [121] => Punk Rock
    [122] => Drum Solo
    [123] => Acapella
    [124] => Euro-House
    [125] => Dance Hall
    [126] => Goa
    [127] => Drum & Bass
    [128] => Club-House
    [129] => Hardcore
    [130] => Terror
    [131] => Indie
    [132] => BritPop
    [133] => Negerpunk
    [134] => Polsk Punk
    [135] => Beat
    [136] => Christian Gangsta
    [137] => Heavy Metal
    [138] => Black Metal
    [139] => Crossover
    [140] => Contemporary C
    [141] => Christian Rock
    [142] => Merengue
    [143] => Salsa
    [144] => Thrash Metal
    [145] => Anime
    [146] => JPop
    [147] => SynthPop
)

Ayrıca Bakınız

  • id3_get_genre_name() - Get the name for a genre id
  • id3_get_genre_id() - Get the id for a genre

id3_get_genre_id
id3_get_genre_name
ID3 İşlevleri


Get the name for a genre id

id3_get_genre_list
id3_get_tag
ID3 İşlevleri
PHP Manual

id3_get_genre_name

(PECL id3 >= 0.1)

id3_get_genre_name — Get the name for a genre id

Açıklama

string id3_get_genre_name ( int $genre_id )

id3_get_genre_name() returns the name for a genre id.

Değiştirgeler

genre_id

An integer ranging from 0 to 147

Dönen Değerler

Returns the name as a string.

Örnekler

Örnek 1 id3_get_genre_name() example

<?php
$genre = id3_get_genre_name(20);
echo $genre;
?>

Yukarıdaki örneğin çıktısı:

Alternative

Ayrıca Bakınız

  • id3_get_genre_list() - Get all possible genre values
  • id3_get_genre_id() - Get the id for a genre

id3_get_genre_list
id3_get_tag
ID3 İşlevleri


Get all information stored in an ID3 tag

id3_get_genre_name
id3_get_version
ID3 İşlevleri
PHP Manual

id3_get_tag

(PECL id3 >= 0.1)

id3_get_tag — Get all information stored in an ID3 tag

Açıklama

array id3_get_tag ( string $filename [, int $version = ID3_BEST ] )

id3_get_tag() is used to get all information stored in the id3 tag of the specified file.

Değiştirgeler

filename

The path to the MP3 file

Instead of a filename you may also pass a valid stream resource

version

Allows you to specify the version of the tag as MP3 files may contain both, version 1.x and version 2.x tags

Since version 0.2 id3_get_tag() also supports ID3 tags of version 2.2, 2.3 and 2.4. To extract information from these tags, pass one of the constants ID3_V2_2, ID3_V2_3 or ID3_V2_4 as the second parameter. ID3 v2.x tags can contain a lot more information about the MP3 file than ID3 v1.x tags.

Dönen Değerler

Returns an associative array with various keys like: title, artist, ..

The key genre will contain an integer between 0 and 147. You may use id3_get_genre_name() to convert it to a human readable string.

Örnekler

Örnek 1 id3_get_tag() example

<?php
$tag = id3_get_tag( "path/to/example.mp3" );
print_r($tag);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [title] => DN-38416
    [artist] => Re:\Legion
    [album] => Reflections
    [year] => 2004
    [genre] => 19
)

Örnek 2 id3_get_tag() example

<?php
$tag = id3_get_tag( "path/to/example2.mp3", ID3_V2_3 );
print_r($tag);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [copyright] => Dirty Mac
    [originalArtist] => Dirty Mac
    [composer] => Marcus Götze
    [artist] => Dirty Mac
    [title] => Little Big Man
    [album] => Demo-Tape
    [track] => 5/12
    [genre] => (17)Rock
    [year] => 2001
)

Ayrıca Bakınız

  • id3_set_tag() - Update information stored in an ID3 tag
  • id3_remove_tag() - Remove an existing ID3 tag
  • id3_get_version() - Get version of an ID3 tag

id3_get_genre_name
id3_get_version
ID3 İşlevleri


Get version of an ID3 tag

id3_get_tag
id3_remove_tag
ID3 İşlevleri
PHP Manual

id3_get_version

(PECL id3 >= 0.1)

id3_get_version — Get version of an ID3 tag

Açıklama

int id3_get_version ( string $filename )

id3_get_version() retrieves the version(s) of the ID3 tag(s) in the MP3 file.

If a file contains an ID3 v1.1 tag, it always contains a 1.0 tag, as version 1.1 is just an extension of 1.0.

Değiştirgeler

filename

The path to the MP3 file

Instead of a filename you may also pass a valid stream resource

Dönen Değerler

Returns the version number of the ID3 tag of the file. As a tag can contain ID3 v1.x and v2.x tags, the return value of this function should be bitwise compared with the predefined constants ID3_V1_0, ID3_V1_1 and ID3_V2.

Örnekler

Örnek 1 id3_get_version() example

<?php
$version = id3_get_version( "path/to/example.mp3" );
if ($version & ID3_V1_0) {
    echo "Contains a 1.x tag\n";
}
if ($version & ID3_V1_1) {
    echo "Contains a 1.1 tag\n";
}
if ($version & ID3_V2) {
    echo "Contains a 2.x tag\n";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Contains a 1.x tag
Contains a 1.1 tag

Ayrıca Bakınız

  • id3_set_tag() - Update information stored in an ID3 tag
  • id3_get_tag() - Get all information stored in an ID3 tag
  • id3_remove_tag() - Remove an existing ID3 tag

id3_get_tag
id3_remove_tag
ID3 İşlevleri


Remove an existing ID3 tag

id3_get_version
id3_set_tag
ID3 İşlevleri
PHP Manual

id3_remove_tag

(PECL id3 >= 0.1)

id3_remove_tag — Remove an existing ID3 tag

Açıklama

bool id3_remove_tag ( string $filename [, int $version = ID3_V1_0 ] )

id3_remove_tag() is used to remove the information stored of an ID3 tag.

Değiştirgeler

filename

The path to the MP3 file

Instead of a filename you may also pass a valid stream resource

version

Allows you to specify the version of the tag as MP3 files may contain both, version 1.x and version 2.x tags.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 id3_remove_tag() example

<?php
$result = id3_remove_tag( "path/to/example.mp3", ID3_V1_0 );
if ($result === true) {
    echo "Tag successfully removed\n";
}
?>

If the file is writable and contained a 1.0 tag, this will output:

Tag successfully removed

Notlar

Bilginize: Currently id3_remove_tag() only supports version 1.0 and 1.1. If you choose to remove a 1.0 tag and the file contains a 1.1 tag, this tag will be removed, as v1.1 is only an extension of 1.0.

Ayrıca Bakınız

  • id3_set_tag() - Update information stored in an ID3 tag
  • id3_get_tag() - Get all information stored in an ID3 tag
  • id3_get_version() - Get version of an ID3 tag

id3_get_version
id3_set_tag
ID3 İşlevleri


Update information stored in an ID3 tag

id3_remove_tag
KTaglib
ID3 İşlevleri
PHP Manual

id3_set_tag

(PECL id3 >= 0.1)

id3_set_tag — Update information stored in an ID3 tag

Açıklama

bool id3_set_tag ( string $filename , array $tag [, int $version = ID3_V1_0 ] )

id3_set_tag() is used to change the information stored of an ID3 tag. If no tag has been present, it will be added to the file.

Değiştirgeler

filename

The path to the MP3 file

Instead of a filename you may also pass a valid stream resource

tag

An associative array of tag keys and values

The following keys may be used in the associative array:

Keys in the associative array
key | possible value | available in version
title | string with maximum of 30 characters | v1.0, v1.1
artist | string with maximum of 30 characters | v1.0, v1.1
album | string with maximum of 30 characters | v1.0, v1.1
year | 4 digits | v1.0, v1.1
genre | integer value between 0 and 147 | v1.0, v1.1
comment | string with maximum of 30 characters (28 in v1.1) | v1.0, v1.1
track | integer between 0 and 255 | v1.1

version

Allows you to specify the version of the tag as MP3 files may contain both, version 1.x and version 2.x tags

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 id3_set_tag() example

<?php
$data = array(
              "title" => "Re:Start",
              "artist" => "Re:\Legion",
              "comment" => "A nice track"
             );
$result = id3_set_tag( "path/to/example.mp3", $data, ID3_V1_0 );
if ($result === true) {
    echo "Tag successfully updated\n";
}
?>

If the file is writable, this will output:

Tag successfully updated

Notlar

Bilginize: Currently id3_set_tag() only supports version 1.0 and 1.1.

Ayrıca Bakınız

  • id3_remove_tag() - Remove an existing ID3 tag
  • id3_get_tag() - Get all information stored in an ID3 tag
  • id3_get_version() - Get version of an ID3 tag

id3_remove_tag
KTaglib
ID3 İşlevleri


KTaglib

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
  • Öntanımlı Sabitler
  • KTaglib_MPEG_File — The KTaglib_MPEG_File class
    • KTaglib_MPEG_File::__construct — Opens a new file
    • KTaglib_MPEG_File::getAudioProperties — Returns an object that provides access to the audio properties
    • KTaglib_MPEG_File::getID3v1Tag — Returns an object representing an ID3v1 tag
    • KTaglib_MPEG_File::getID3v2Tag — Returns a ID3v2 object
  • KTaglib_MPEG_AudioProperties — The KTaglib_MPEG_AudioProperties class
    • KTaglib_MPEG_AudioProperties::getBitrate — Returns the bitrate of the MPEG file
    • KTaglib_MPEG_AudioProperties::getChannels — Returns the amount of channels of a MPEG file
    • KTaglib_MPEG_AudioProperties::getLayer — Returns the layer of a MPEG file
    • KTaglib_MPEG_AudioProperties::getLength — Returns the length of a MPEG file
    • KTaglib_MPEG_AudioProperties::getSampleBitrate — Returns the sample bitrate of a MPEG file
    • KTaglib_MPEG_AudioProperties::getVersion — Returns the version of a MPEG file
    • KTaglib_MPEG_AudioProperties::isCopyrighted — Returns the copyright status of an MPEG file
    • KTaglib_MPEG_AudioProperties::isOriginal — Returns if the file is marked as the original file
    • KTaglib_MPEG_AudioProperties::isProtectionEnabled — Returns if protection mechanisms of an MPEG file are enabled
  • KTaglib_Tag — The KTaglib_Tag class
    • KTaglib_Tag::getAlbum — Returns the title string from a ID3 tag
    • KTaglib_Tag::getArtist — Returns the artist string from a ID3 tag
    • KTaglib_Tag::getComment — Returns the comment from a ID3 tag
    • KTaglib_Tag::getGenre — Returns the genre from a ID3 tag
    • KTaglib_Tag::getTitle — Returns the title string from a ID3 tag
    • KTaglib_Tag::getTrack — Returns the track number from a ID3 tag
    • KTaglib_Tag::getYear — Returns the year from a ID3 tag
    • KTaglib_Tag::isEmpty — Returns true if the tag is empty
  • KTaglib_ID3v2_Tag — The KTaglib_ID3v2_Tag class
    • KTaglib_ID3v2_Tag::addFrame — Add a frame to the ID3v2 tag
    • KTaglib_ID3v2_Tag::getFrameList — Returns an array of ID3v2 frames, associated with the ID3v2 tag
  • KTaglib_ID3v2_Frame — The KTaglib_ID3v2_Frame class
    • KTaglib_ID3v2_Frame::getSize — Returns the size of the frame in bytes
    • KTaglib_ID3v2_Frame::__toString — Returns a string representation of the frame
  • KTaglib_ID3v2_AttachedPictureFrame — The KTaglib_ID3v2_AttachedPictureFrame class
    • KTaglib_ID3v2_AttachedPictureFrame::getDescription — Returns a description for the picture in a picture frame
    • KTaglib_ID3v2_AttachedPictureFrame::getMimeType — Returns the mime type of the picture
    • KTaglib_ID3v2_AttachedPictureFrame::getType — Returns the type of the image
    • KTaglib_ID3v2_AttachedPictureFrame::savePicture — Saves the picture to a file
    • KTaglib_ID3v2_AttachedPictureFrame::setMimeType — Set's the mime type of the picture
    • KTaglib_ID3v2_AttachedPictureFrame::setPicture — Sets the frame picture to the given image
    • KTaglib_ID3v2_AttachedPictureFrame::setType — Set the type of the image
id3_set_tag
Giriş
Ses Biçemleme İşlemleri


Giriş

KTaglib is an object oriented binding to the taglib library from the KDE project used in projects like Amarok to read and write ID3 and Ogg tags. The library also provides access to audio information. The bindings are designed usually follow the underlying C++ API, but were changed whenever there is a more PHP-like way.

Bilginize:

At the moment ktaglib is able to read and write ID3v1 and ID3v2 tags.

KTaglib
Yapılandırma/Kurulum
KTaglib


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
Giriş
Gereksinimler
KTaglib


Gereksinimler

If you want to build ktaglib you need at least taglib 1.5 installed. To obtain the taglib see the » taglib project page. Windows DLL's are build static against taglib, therefore there is no need to have taglib installed.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/ktaglib.

Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız.

Gereksinimler
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

KTaglib uses class constants. Most of the constants are mappings to the according Taglib enums and constants.

KTaglib_MPEG_Header::Version1 (integer)
ID3 version is 1.0
KTaglib_MPEG_Header::Version2 (integer)
ID3 version is 2.0
KTaglib_MPEG_Header::Version2_5 (integer)
ID3 version is 2.5
KTaglib_ID3v2_AttachedPictureFrame::Other (integer)
Picture type Other
KTaglib_ID3v2_AttachedPictureFrame::FileIcon (integer)
Picture type FileIcon
KTaglib_ID3v2_AttachedPictureFrame::OtherFileIcon (integer)
Picture type OtherFileIcon
KTaglib_ID3v2_AttachedPictureFrame::FrontCover (integer)
Picture type FrontCover
KTaglib_ID3v2_AttachedPictureFrame::BackCover (integer)
Picture type BackCover
KTaglib_ID3v2_AttachedPictureFrame::LeafletPage (integer)
Picture type LeafletPage
KTaglib_ID3v2_AttachedPictureFrame::Media (integer)
Picture type Media
KTaglib_ID3v2_AttachedPictureFrame::LeadArtist (integer)
Picture type LeadArtist
KTaglib_ID3v2_AttachedPictureFrame::Artist (integer)
Picture type Artist
KTaglib_ID3v2_AttachedPictureFrame::Conductor (integer)
Picture type Condutor
KTaglib_ID3v2_AttachedPictureFrame::Band (integer)
Picture type Band
KTaglib_ID3v2_AttachedPictureFrame::Composer (integer)
Picture type Composer
KTaglib_ID3v2_AttachedPictureFrame::Lyricist (integer)
Picture type Lyricist
KTaglib_ID3v2_AttachedPictureFrame::RecordingLocation (integer)
Picture type RecordingLocation
KTaglib_ID3v2_AttachedPictureFrame::DuringRecording (integer)
Picture type DuringRecording
KTaglib_ID3v2_AttachedPictureFrame::DuringPerformance (integer)
Picture type DuringPerformance
KTaglib_ID3v2_AttachedPictureFrame::MovieScreenCapture (integer)
Picture type MovieScreenCapture
KTaglib_ID3v2_AttachedPictureFrame::ColouredFish (integer)
Picture type ColouredFish
KTaglib_ID3v2_AttachedPictureFrame::Illustration (integer)
Picture type Illustration
KTaglib_ID3v2_AttachedPictureFrame::BandLogo (integer)
Picture type BandLogo
Kurulum
KTaglib_MPEG_File
KTaglib


The KTaglib_MPEG_File class

(0.0.1)

Giriş

Represents an MPEG file. MPEG files can have ID3v1, ID3v2 tags and audio properties.

Class synopsis

KTaglib_MPEG_File {
/* Yöntemler */
public KTaglib_MPEG_File getAudioProperties ( void )
public KTaglib_ID3v1_Tag getID3v1Tag ([ bool $create = false ] )
public KTaglib_ID3v2_Tag getID3v2Tag ([ bool $create = false ] )
}

İçindekiler

  • KTaglib_MPEG_File::__construct — Opens a new file
  • KTaglib_MPEG_File::getAudioProperties — Returns an object that provides access to the audio properties
  • KTaglib_MPEG_File::getID3v1Tag — Returns an object representing an ID3v1 tag
  • KTaglib_MPEG_File::getID3v2Tag — Returns a ID3v2 object
Öntanımlı Sabitler
KTaglib_MPEG_File::__construct
KTaglib


Opens a new file

KTaglib_MPEG_File
KTaglib_MPEG_File::getAudioProperties
KTaglib_MPEG_File
PHP Manual

KTaglib_MPEG_File::__construct

(0.0.1)

KTaglib_MPEG_File::__construct — Opens a new file

Açıklama

public KTaglib_MPEG_File::__construct ( string $filename )

Opens a new MPEG file.

Değiştirgeler

filename

The file to read

Örnekler

Örnek 1 Opens a new MP3 file and read the title

<?php
$mpeg = new KTaglib_MPEG_File('example.mp3');
echo $mpeg->getID3v1Tag()->getTitle();
?>

KTaglib_MPEG_File
KTaglib_MPEG_File::getAudioProperties
KTaglib_MPEG_File


Returns an object that provides access to the audio properties

KTaglib_MPEG_File::__construct
KTaglib_MPEG_File::getID3v1Tag
KTaglib_MPEG_File
PHP Manual

KTaglib_MPEG_File::getAudioProperties

(0.0.1)

KTaglib_MPEG_File::getAudioProperties — Returns an object that provides access to the audio properties

Açıklama

public KTaglib_MPEG_File KTaglib_MPEG_File::getAudioProperties ( void )

Returns an object that provides access to the audio properties of the mpeg file.

Dönen Değerler

Returns an KTaglib_MPEG_AudioProperties object or false.

KTaglib_MPEG_File::__construct
KTaglib_MPEG_File::getID3v1Tag
KTaglib_MPEG_File


Returns an object representing an ID3v1 tag

KTaglib_MPEG_File::getAudioProperties
KTaglib_MPEG_File::getID3v2Tag
KTaglib_MPEG_File
PHP Manual

KTaglib_MPEG_File::getID3v1Tag

(0.0.1)

KTaglib_MPEG_File::getID3v1Tag — Returns an object representing an ID3v1 tag

Açıklama

public KTaglib_ID3v1_Tag KTaglib_MPEG_File::getID3v1Tag ([ bool $create = false ] )

Returns an object that represents an ID3v1 tag, which can be used to get information about the ID3v1 tag.

Dönen Değerler

Returns an KTaglib_MPEG_ID3v1Tag object or false if there is no ID3v1 tag.

KTaglib_MPEG_File::getAudioProperties
KTaglib_MPEG_File::getID3v2Tag
KTaglib_MPEG_File


Returns a ID3v2 object

KTaglib_MPEG_File::getID3v1Tag
KTaglib_MPEG_AudioProperties
KTaglib_MPEG_File
PHP Manual

KTaglib_MPEG_File::getID3v2Tag

(0.0.1)

KTaglib_MPEG_File::getID3v2Tag — Returns a ID3v2 object

Açıklama

public KTaglib_ID3v2_Tag KTaglib_MPEG_File::getID3v2Tag ([ bool $create = false ] )

Returns a ID3v2 object for the mpeg file. If no ID3v2 Tag is present, an KTaglib_TagNotFoundException is thrown.

Dönen Değerler

Returns the KTaglib_ID3v2_Tag object of the MPEG file or false if there is no ID3v2 tag

KTaglib_MPEG_File::getID3v1Tag
KTaglib_MPEG_AudioProperties
KTaglib_MPEG_File


The KTaglib_MPEG_AudioProperties class

(0.0.1)

Giriş

Represents the audio properties of a MPEG file, like length, bitrate or samplerate.

Class synopsis

KTaglib_MPEG_AudioProperties {
/* Yöntemler */
public int KTaglib_MPEG_AudioProperties::getBitrate ( void )
public int KTaglib_MPEG_AudioProperties::getChannels ( void )
public int KTaglib_MPEG_AudioProperties::getLayer ( void )
public int KTaglib_MPEG_AudioProperties::getLength ( void )
public int KTaglib_MPEG_AudioProperties::getSampleBitrate ( void )
public int KTaglib_MPEG_AudioProperties::getVersion ( void )
public bool KTaglib_MPEG_AudioProperties::isCopyrighted ( void )
public bool KTaglib_MPEG_AudioProperties::isOriginal ( void )
public bool KTaglib_MPEG_AudioProperties::isProtectionEnabled ( void )
}

İçindekiler

  • KTaglib_MPEG_AudioProperties::getBitrate — Returns the bitrate of the MPEG file
  • KTaglib_MPEG_AudioProperties::getChannels — Returns the amount of channels of a MPEG file
  • KTaglib_MPEG_AudioProperties::getLayer — Returns the layer of a MPEG file
  • KTaglib_MPEG_AudioProperties::getLength — Returns the length of a MPEG file
  • KTaglib_MPEG_AudioProperties::getSampleBitrate — Returns the sample bitrate of a MPEG file
  • KTaglib_MPEG_AudioProperties::getVersion — Returns the version of a MPEG file
  • KTaglib_MPEG_AudioProperties::isCopyrighted — Returns the copyright status of an MPEG file
  • KTaglib_MPEG_AudioProperties::isOriginal — Returns if the file is marked as the original file
  • KTaglib_MPEG_AudioProperties::isProtectionEnabled — Returns if protection mechanisms of an MPEG file are enabled
KTaglib_MPEG_File::getID3v2Tag
KTaglib_MPEG_AudioProperties::getBitrate
KTaglib


Returns the bitrate of the MPEG file

KTaglib_MPEG_AudioProperties
KTaglib_MPEG_AudioProperties::getChannels
KTaglib_MPEG_AudioProperties
PHP Manual

KTaglib_MPEG_AudioProperties::getBitrate

(0.0.1)

KTaglib_MPEG_AudioProperties::getBitrate — Returns the bitrate of the MPEG file

Açıklama

public int KTaglib_MPEG_AudioProperties::getBitrate ( void )

Returns the bitrate of the MPEG file

Dönen Değerler

Returns the bitrate as an integer

KTaglib_MPEG_AudioProperties
KTaglib_MPEG_AudioProperties::getChannels
KTaglib_MPEG_AudioProperties


Returns the amount of channels of a MPEG file

KTaglib_MPEG_AudioProperties::getBitrate
KTaglib_MPEG_AudioProperties::getLayer
KTaglib_MPEG_AudioProperties
PHP Manual

KTaglib_MPEG_AudioProperties::getChannels

(0.0.1)

KTaglib_MPEG_AudioProperties::getChannels — Returns the amount of channels of a MPEG file

Açıklama

public int KTaglib_MPEG_AudioProperties::getChannels ( void )

Returns the amount of channels of the MPEG file

Dönen Değerler

Returns the channel count as an integer

KTaglib_MPEG_AudioProperties::getBitrate
KTaglib_MPEG_AudioProperties::getLayer
KTaglib_MPEG_AudioProperties


Returns the layer of a MPEG file

KTaglib_MPEG_AudioProperties::getChannels
KTaglib_MPEG_AudioProperties::getLength
KTaglib_MPEG_AudioProperties
PHP Manual

KTaglib_MPEG_AudioProperties::getLayer

(0.0.1)

KTaglib_MPEG_AudioProperties::getLayer — Returns the layer of a MPEG file

Açıklama

public int KTaglib_MPEG_AudioProperties::getLayer ( void )

Returns the layer of the MPEG file (usually 3 for MP3).

Dönen Değerler

Returns the layer as an integer

KTaglib_MPEG_AudioProperties::getChannels
KTaglib_MPEG_AudioProperties::getLength
KTaglib_MPEG_AudioProperties


Returns the length of a MPEG file

KTaglib_MPEG_AudioProperties::getLayer
KTaglib_MPEG_AudioProperties::getSampleBitrate
KTaglib_MPEG_AudioProperties
PHP Manual

KTaglib_MPEG_AudioProperties::getLength

(0.0.1)

KTaglib_MPEG_AudioProperties::getLength — Returns the length of a MPEG file

Açıklama

public int KTaglib_MPEG_AudioProperties::getLength ( void )

Returns the length of the MPEG file

Dönen Değerler

Returns the length as an integer

KTaglib_MPEG_AudioProperties::getLayer
KTaglib_MPEG_AudioProperties::getSampleBitrate
KTaglib_MPEG_AudioProperties


Returns the sample bitrate of a MPEG file

KTaglib_MPEG_AudioProperties::getLength
KTaglib_MPEG_AudioProperties::getVersion
KTaglib_MPEG_AudioProperties
PHP Manual

KTaglib_MPEG_AudioProperties::getSampleBitrate

(0.0.1)

KTaglib_MPEG_AudioProperties::getSampleBitrate — Returns the sample bitrate of a MPEG file

Açıklama

public int KTaglib_MPEG_AudioProperties::getSampleBitrate ( void )

Returns the sample bitrate of the MPEG file

Dönen Değerler

Returns the sample bitrate as an integer

KTaglib_MPEG_AudioProperties::getLength
KTaglib_MPEG_AudioProperties::getVersion
KTaglib_MPEG_AudioProperties


Returns the version of a MPEG file

KTaglib_MPEG_AudioProperties::getSampleBitrate
KTaglib_MPEG_AudioProperties::isCopyrighted
KTaglib_MPEG_AudioProperties
PHP Manual

KTaglib_MPEG_AudioProperties::getVersion

(0.0.1)

KTaglib_MPEG_AudioProperties::getVersion — Returns the version of a MPEG file

Açıklama

public int KTaglib_MPEG_AudioProperties::getVersion ( void )

Returns the version of the MPEG file header. The possible versions are defined in Tag_MPEG_Header (Version1, Version2, Version2.5).

Dönen Değerler

Returns the version

KTaglib_MPEG_AudioProperties::getSampleBitrate
KTaglib_MPEG_AudioProperties::isCopyrighted
KTaglib_MPEG_AudioProperties


Returns the copyright status of an MPEG file

KTaglib_MPEG_AudioProperties::getVersion
KTaglib_MPEG_AudioProperties::isOriginal
KTaglib_MPEG_AudioProperties
PHP Manual

KTaglib_MPEG_AudioProperties::isCopyrighted

(0.0.1)

KTaglib_MPEG_AudioProperties::isCopyrighted — Returns the copyright status of an MPEG file

Açıklama

public bool KTaglib_MPEG_AudioProperties::isCopyrighted ( void )

Returns true if the MPEG file is copyrighted

Dönen Değerler

Returns true if the MPEG file is copyrighted

KTaglib_MPEG_AudioProperties::getVersion
KTaglib_MPEG_AudioProperties::isOriginal
KTaglib_MPEG_AudioProperties


Returns if the file is marked as the original file

KTaglib_MPEG_AudioProperties::isCopyrighted
KTaglib_MPEG_AudioProperties::isProtectionEnabled
KTaglib_MPEG_AudioProperties
PHP Manual

KTaglib_MPEG_AudioProperties::isOriginal

(0.0.1)

KTaglib_MPEG_AudioProperties::isOriginal — Returns if the file is marked as the original file

Açıklama

public bool KTaglib_MPEG_AudioProperties::isOriginal ( void )

Returns true if the file is marked as the original file

Dönen Değerler

Returns true if the file is marked as the original file

KTaglib_MPEG_AudioProperties::isCopyrighted
KTaglib_MPEG_AudioProperties::isProtectionEnabled
KTaglib_MPEG_AudioProperties


Returns if protection mechanisms of an MPEG file are enabled

KTaglib_MPEG_AudioProperties::isOriginal
KTaglib_Tag
KTaglib_MPEG_AudioProperties
PHP Manual

KTaglib_MPEG_AudioProperties::isProtectionEnabled

(0.0.1)

KTaglib_MPEG_AudioProperties::isProtectionEnabled — Returns if protection mechanisms of an MPEG file are enabled

Açıklama

public bool KTaglib_MPEG_AudioProperties::isProtectionEnabled ( void )

Returns true if protection mechanisms (like DRM) are enabled for this file

Dönen Değerler

Returns true if protection mechanisms (like DRM) are enabled for this file

KTaglib_MPEG_AudioProperties::isOriginal
KTaglib_Tag
KTaglib_MPEG_AudioProperties


The KTaglib_Tag class

(0.0.1)

Giriş

Base class for ID3v1 or ID3v2 tags

Class synopsis

KTaglib_Tag {
/* Yöntemler */
public string getAlbum ( void )
public string getArtist ( void )
public string getComment ( void )
public string getGenre ( void )
public string getTitle ( void )
public int getTrack ( void )
public int getYear ( void )
public bool isEmpty ( void )
}

İçindekiler

  • KTaglib_Tag::getAlbum — Returns the title string from a ID3 tag
  • KTaglib_Tag::getArtist — Returns the artist string from a ID3 tag
  • KTaglib_Tag::getComment — Returns the comment from a ID3 tag
  • KTaglib_Tag::getGenre — Returns the genre from a ID3 tag
  • KTaglib_Tag::getTitle — Returns the title string from a ID3 tag
  • KTaglib_Tag::getTrack — Returns the track number from a ID3 tag
  • KTaglib_Tag::getYear — Returns the year from a ID3 tag
  • KTaglib_Tag::isEmpty — Returns true if the tag is empty
KTaglib_MPEG_AudioProperties::isProtectionEnabled
KTaglib_Tag::getAlbum
KTaglib


Returns the title string from a ID3 tag

KTaglib_Tag
KTaglib_Tag::getArtist
KTaglib_Tag
PHP Manual

KTaglib_Tag::getAlbum

(0.0.1)

KTaglib_Tag::getAlbum — Returns the title string from a ID3 tag

Açıklama

public string KTaglib_Tag::getAlbum ( void )

Returns the album string of an ID3 tag. This method is implemented in ID3v1 and ID3v2 tags.

Dönen Değerler

Returns the album string

KTaglib_Tag
KTaglib_Tag::getArtist
KTaglib_Tag


Returns the artist string from a ID3 tag

KTaglib_Tag::getAlbum
KTaglib_Tag::getComment
KTaglib_Tag
PHP Manual

KTaglib_Tag::getArtist

(0.0.1)

KTaglib_Tag::getArtist — Returns the artist string from a ID3 tag

Açıklama

public string KTaglib_Tag::getArtist ( void )

Returns the artist string of an ID3 tag. This method is implemented in ID3v1 and ID3v2 tags.

Dönen Değerler

Returns the artist string

KTaglib_Tag::getAlbum
KTaglib_Tag::getComment
KTaglib_Tag


Returns the comment from a ID3 tag

KTaglib_Tag::getArtist
KTaglib_Tag::getGenre
KTaglib_Tag
PHP Manual

KTaglib_Tag::getComment

(0.0.1)

KTaglib_Tag::getComment — Returns the comment from a ID3 tag

Açıklama

public string KTaglib_Tag::getComment ( void )

Returns the comment of an ID3 tag. This method is implemented in ID3v1 and ID3v2 tags.

Dönen Değerler

Returns the comment string

KTaglib_Tag::getArtist
KTaglib_Tag::getGenre
KTaglib_Tag


Returns the genre from a ID3 tag

KTaglib_Tag::getComment
KTaglib_Tag::getTitle
KTaglib_Tag
PHP Manual

KTaglib_Tag::getGenre

(0.0.1)

KTaglib_Tag::getGenre — Returns the genre from a ID3 tag

Açıklama

public string KTaglib_Tag::getGenre ( void )

Returns the genre of an ID3 tag. This method is implemented in ID3v1 and ID3v2 tags.

Dönen Değerler

Returns the genre string

KTaglib_Tag::getComment
KTaglib_Tag::getTitle
KTaglib_Tag


Returns the title string from a ID3 tag

KTaglib_Tag::getGenre
KTaglib_Tag::getTrack
KTaglib_Tag
PHP Manual

KTaglib_Tag::getTitle

(0.0.1)

KTaglib_Tag::getTitle — Returns the title string from a ID3 tag

Açıklama

public string KTaglib_Tag::getTitle ( void )

Returns the title string of an ID3 tag. This method is implemented in ID3v1 and ID3v2 tags.

Dönen Değerler

Returns the title string

KTaglib_Tag::getGenre
KTaglib_Tag::getTrack
KTaglib_Tag


Returns the track number from a ID3 tag

KTaglib_Tag::getTitle
KTaglib_Tag::getYear
KTaglib_Tag
PHP Manual

KTaglib_Tag::getTrack

(0.0.1)

KTaglib_Tag::getTrack — Returns the track number from a ID3 tag

Açıklama

public int KTaglib_Tag::getTrack ( void )

Returns the track number of an ID3 tag. This method is implemented in ID3v1 and ID3v2 tags.

Dönen Değerler

Returns the track number as an integer

KTaglib_Tag::getTitle
KTaglib_Tag::getYear
KTaglib_Tag


Returns the year from a ID3 tag

KTaglib_Tag::getTrack
KTaglib_Tag::isEmpty
KTaglib_Tag
PHP Manual

KTaglib_Tag::getYear

(0.0.1)

KTaglib_Tag::getYear — Returns the year from a ID3 tag

Açıklama

public int KTaglib_Tag::getYear ( void )

Returns the year of an ID3 tag. This method is implemented in ID3v1 and ID3v2 tags.

Dönen Değerler

Returns the year as an integer

KTaglib_Tag::getTrack
KTaglib_Tag::isEmpty
KTaglib_Tag


Returns true if the tag is empty

KTaglib_Tag::getYear
KTaglib_ID3v2_Tag
KTaglib_Tag
PHP Manual

KTaglib_Tag::isEmpty

(0.0.1)

KTaglib_Tag::isEmpty — Returns true if the tag is empty

Açıklama

public bool KTaglib_Tag::isEmpty ( void )

Returns true if the tag exists, but is empty. This method is implemented in ID3v1 and ID3v2 tags.

Dönen Değerler

Returns true if the tag is empty, otherwise false.

KTaglib_Tag::getYear
KTaglib_ID3v2_Tag
KTaglib_Tag


The KTaglib_ID3v2_Tag class

(0.0.1)

Giriş

Represents and ID3v2 tag. It provides a list of ID3v2 frames and can be used to add and remove additional frames.

Class synopsis

extends KTaglib_Tag {
/* Yöntemler */
public bool addFrame ( KTaglib_ID3v2_Frame $frame )
public array getFrameList ( void )
/* Miras alınan yöntemler */
public string KTaglib_Tag::getAlbum ( void )
public string KTaglib_Tag::getArtist ( void )
public string KTaglib_Tag::getComment ( void )
public string KTaglib_Tag::getGenre ( void )
public string KTaglib_Tag::getTitle ( void )
public int KTaglib_Tag::getTrack ( void )
public int KTaglib_Tag::getYear ( void )
public bool KTaglib_Tag::isEmpty ( void )
}

İçindekiler

  • KTaglib_ID3v2_Tag::addFrame — Add a frame to the ID3v2 tag
  • KTaglib_ID3v2_Tag::getFrameList — Returns an array of ID3v2 frames, associated with the ID3v2 tag
KTaglib_Tag::isEmpty
KTaglib_ID3v2_Tag::addFrame
KTaglib


Add a frame to the ID3v2 tag

KTaglib_ID3v2_Tag
KTaglib_ID3v2_Tag::getFrameList
KTaglib_ID3v2_Tag
PHP Manual

KTaglib_ID3v2_Tag::addFrame

(0.0.1)

KTaglib_ID3v2_Tag::addFrame — Add a frame to the ID3v2 tag

Açıklama

public bool KTaglib_ID3v2_Tag::addFrame ( KTaglib_ID3v2_Frame $frame )

Adds a frame to the ID3v2 tag. The frame must be a valid KTaglib_ID3v2_Frame object. To save the tag, the save function needs to be invoked.

Dönen Değerler

Returns true on success, otherwise false.

KTaglib_ID3v2_Tag
KTaglib_ID3v2_Tag::getFrameList
KTaglib_ID3v2_Tag


Returns an array of ID3v2 frames, associated with the ID3v2 tag

KTaglib_ID3v2_Tag::addFrame
KTaglib_ID3v2_Frame
KTaglib_ID3v2_Tag
PHP Manual

KTaglib_ID3v2_Tag::getFrameList

(0.0.1)

KTaglib_ID3v2_Tag::getFrameList — Returns an array of ID3v2 frames, associated with the ID3v2 tag

Açıklama

public array KTaglib_ID3v2_Tag::getFrameList ( void )

Returns an array of ID3v2 frames, associated with the ID3v2 tag.

Dönen Değerler

Return an array of KTaglib_ID3v2_Frame objects

KTaglib_ID3v2_Tag::addFrame
KTaglib_ID3v2_Frame
KTaglib_ID3v2_Tag


The KTaglib_ID3v2_Frame class

(0.0.1)

Giriş

The base class for ID3v2 frames. ID3v2 tags are separated in various specialized frames. Some frames can exists multiple times.

Class synopsis

extends KTaglib_Tag {
/* Yöntemler */
public int getSize ( void )
public string __toString ( void )
/* Miras alınan yöntemler */
public string KTaglib_Tag::getAlbum ( void )
public string KTaglib_Tag::getArtist ( void )
public string KTaglib_Tag::getComment ( void )
public string KTaglib_Tag::getGenre ( void )
public string KTaglib_Tag::getTitle ( void )
public int KTaglib_Tag::getTrack ( void )
public int KTaglib_Tag::getYear ( void )
public bool KTaglib_Tag::isEmpty ( void )
}

İçindekiler

  • KTaglib_ID3v2_Frame::getSize — Returns the size of the frame in bytes
  • KTaglib_ID3v2_Frame::__toString — Returns a string representation of the frame
KTaglib_ID3v2_Tag::getFrameList
KTaglib_ID3v2_Frame::getSize
KTaglib


Returns the size of the frame in bytes

KTaglib_ID3v2_Frame
KTaglib_ID3v2_Frame::__toString
KTaglib_ID3v2_Frame
PHP Manual

KTaglib_ID3v2_Frame::getSize

(0.0.1)

KTaglib_ID3v2_Frame::getSize — Returns the size of the frame in bytes

Açıklama

public int KTaglib_ID3v2_Frame::getSize ( void )

Returns the size of the frame in bytes. Please refer to id3.org to see what ID3v2 frames are and how they are defined.

Dönen Değerler

Returns the size of the frame in bytes

KTaglib_ID3v2_Frame
KTaglib_ID3v2_Frame::__toString
KTaglib_ID3v2_Frame


Returns a string representation of the frame

KTaglib_ID3v2_Frame::getSize
KTaglib_ID3v2_AttachedPictureFrame
KTaglib_ID3v2_Frame
PHP Manual

KTaglib_ID3v2_Frame::__toString

(0.0.1)

KTaglib_ID3v2_Frame::__toString — Returns a string representation of the frame

Açıklama

public string KTaglib_ID3v2_Frame::__toString ( void )

Returns a string representation of the frame. This might be just the frame id, but might contain more information. Please see the ktaglib documentation for more information

Dönen Değerler

Returns a string representation of the frame.

KTaglib_ID3v2_Frame::getSize
KTaglib_ID3v2_AttachedPictureFrame
KTaglib_ID3v2_Frame


The KTaglib_ID3v2_AttachedPictureFrame class

(0.0.1)

Giriş

Represents an ID3v2 frame that can hold a picture.

Class synopsis

extends KTaglib_ID3v2_Frame {
/* Yöntemler */
public string getDescription ( void )
public string getMimeType ( void )
public int getType ( void )
public bool savePicture ( string $filename )
public string getMimeType ( string $type )
public void setPicture ( string $filename )
public void setType ( int $type )
/* Miras alınan yöntemler */
public int KTaglib_ID3v2_Frame::getSize ( void )
public string KTaglib_ID3v2_Frame::__toString ( void )
public string KTaglib_Tag::getAlbum ( void )
public string KTaglib_Tag::getArtist ( void )
public string KTaglib_Tag::getComment ( void )
public string KTaglib_Tag::getGenre ( void )
public string KTaglib_Tag::getTitle ( void )
public int KTaglib_Tag::getTrack ( void )
public int KTaglib_Tag::getYear ( void )
public bool KTaglib_Tag::isEmpty ( void )
}

İçindekiler

  • KTaglib_ID3v2_AttachedPictureFrame::getDescription — Returns a description for the picture in a picture frame
  • KTaglib_ID3v2_AttachedPictureFrame::getMimeType — Returns the mime type of the picture
  • KTaglib_ID3v2_AttachedPictureFrame::getType — Returns the type of the image
  • KTaglib_ID3v2_AttachedPictureFrame::savePicture — Saves the picture to a file
  • KTaglib_ID3v2_AttachedPictureFrame::setMimeType — Set's the mime type of the picture
  • KTaglib_ID3v2_AttachedPictureFrame::setPicture — Sets the frame picture to the given image
  • KTaglib_ID3v2_AttachedPictureFrame::setType — Set the type of the image
KTaglib_ID3v2_Frame::__toString
KTaglib_ID3v2_AttachedPictureFrame::getDescription
KTaglib


Returns a description for the picture in a picture frame

KTaglib_ID3v2_AttachedPictureFrame
KTaglib_ID3v2_AttachedPictureFrame::getMimeType
KTaglib_ID3v2_AttachedPictureFrame
PHP Manual

KTaglib_ID3v2_AttachedPictureFrame::getDescription

(0.0.1)

KTaglib_ID3v2_AttachedPictureFrame::getDescription — Returns a description for the picture in a picture frame

Açıklama

public string KTaglib_ID3v2_AttachedPictureFrame::getDescription ( void )

Returns the attached description for a picture frame in an ID3v2.x frame.

Dönen Değerler

Returns a description for the picture in a picture frame

KTaglib_ID3v2_AttachedPictureFrame
KTaglib_ID3v2_AttachedPictureFrame::getMimeType
KTaglib_ID3v2_AttachedPictureFrame


Returns the mime type of the picture

KTaglib_ID3v2_AttachedPictureFrame::getDescription
KTaglib_ID3v2_AttachedPictureFrame::getType
KTaglib_ID3v2_AttachedPictureFrame
PHP Manual

KTaglib_ID3v2_AttachedPictureFrame::getMimeType

(0.2.0)

KTaglib_ID3v2_AttachedPictureFrame::getMimeType — Returns the mime type of the picture

Açıklama

public string KTaglib_ID3v2_AttachedPictureFrame::getMimeType ( void )

Returns the mime type of the image represented by the attached picture frame.

Please notice that this method might return different types. While ID3v2.2 have a mime type that doesn't start with "image/", ID3v2.3 and v2.4 usually start with "image/". Therefore the method might return "image/png" for IDv2.3 frames and just "PNG" for ID3v2.2 frames.

Notice that even the frame is an attached picture, the mime type might not be set and therefore an empty string might be returned.

Dönen Değerler

Returns the mime type of the image represented by the attached picture frame.

KTaglib_ID3v2_AttachedPictureFrame::getDescription
KTaglib_ID3v2_AttachedPictureFrame::getType
KTaglib_ID3v2_AttachedPictureFrame


Returns the type of the image

KTaglib_ID3v2_AttachedPictureFrame::getMimeType
KTaglib_ID3v2_AttachedPictureFrame::savePicture
KTaglib_ID3v2_AttachedPictureFrame
PHP Manual

KTaglib_ID3v2_AttachedPictureFrame::getType

(0.2.0)

KTaglib_ID3v2_AttachedPictureFrame::getType — Returns the type of the image

Açıklama

public int KTaglib_ID3v2_AttachedPictureFrame::getType ( void )

Returns the type of the image.

The ID3v2 specification allows an AttachedPictureFrame to set the type of an image. This can be e.g. FrontCover or FileIcon. Please refer to the KTaglib_ID3v2_AttachedPictureFrame class description for a list of available types.

Dönen Değerler

Returns the integer representation of the type.

KTaglib_ID3v2_AttachedPictureFrame::getMimeType
KTaglib_ID3v2_AttachedPictureFrame::savePicture
KTaglib_ID3v2_AttachedPictureFrame


Saves the picture to a file

KTaglib_ID3v2_AttachedPictureFrame::getType
KTaglib_ID3v2_AttachedPictureFrame::setMimeType
KTaglib_ID3v2_AttachedPictureFrame
PHP Manual

KTaglib_ID3v2_AttachedPictureFrame::savePicture

(0.0.1)

KTaglib_ID3v2_AttachedPictureFrame::savePicture — Saves the picture to a file

Açıklama

public bool KTaglib_ID3v2_AttachedPictureFrame::savePicture ( string $filename )

Saves the attached picture to the given filename.

Dönen Değerler

Returns true on success, otherwise false

KTaglib_ID3v2_AttachedPictureFrame::getType
KTaglib_ID3v2_AttachedPictureFrame::setMimeType
KTaglib_ID3v2_AttachedPictureFrame


Set's the mime type of the picture

KTaglib_ID3v2_AttachedPictureFrame::savePicture
KTaglib_ID3v2_AttachedPictureFrame::setPicture
KTaglib_ID3v2_AttachedPictureFrame
PHP Manual

KTaglib_ID3v2_AttachedPictureFrame::setMimeType

(0.2.0)

KTaglib_ID3v2_AttachedPictureFrame::setMimeType — Set's the mime type of the picture

Açıklama

public string KTaglib_ID3v2_AttachedPictureFrame::getMimeType ( string $type )

Sets the mime type of the image. This should in most cases be "image/png" or "image/jpeg".

KTaglib_ID3v2_AttachedPictureFrame::savePicture
KTaglib_ID3v2_AttachedPictureFrame::setPicture
KTaglib_ID3v2_AttachedPictureFrame


Sets the frame picture to the given image

KTaglib_ID3v2_AttachedPictureFrame::setMimeType
KTaglib_ID3v2_AttachedPictureFrame::setType
KTaglib_ID3v2_AttachedPictureFrame
PHP Manual

KTaglib_ID3v2_AttachedPictureFrame::setPicture

(0.0.1)

KTaglib_ID3v2_AttachedPictureFrame::setPicture — Sets the frame picture to the given image

Açıklama

public void KTaglib_ID3v2_AttachedPictureFrame::setPicture ( string $filename )

Sets the picture to the give image. The image is loaded from the given filename. Please note that the picture is not saved unless you call the save method of the corresponding file object.

Dönen Değerler

Returns true on success, otherwise false

KTaglib_ID3v2_AttachedPictureFrame::setMimeType
KTaglib_ID3v2_AttachedPictureFrame::setType
KTaglib_ID3v2_AttachedPictureFrame


Set the type of the image

KTaglib_ID3v2_AttachedPictureFrame::setPicture
oggvorbis
KTaglib_ID3v2_AttachedPictureFrame
PHP Manual

KTaglib_ID3v2_AttachedPictureFrame::setType

(0.2.0)

KTaglib_ID3v2_AttachedPictureFrame::setType — Set the type of the image

Açıklama

public void KTaglib_ID3v2_AttachedPictureFrame::setType ( int $type )

Sets the type of the image. This can be e.g. FrontCover or FileIcon. Please refer to the KTaglib_ID3v2_AttachedPictureFrame class description for a list of available types and their constant mappings.

KTaglib_ID3v2_AttachedPictureFrame::setPicture
oggvorbis
KTaglib_ID3v2_AttachedPictureFrame


OGG/Vorbis

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Context options
  • Örnekler
    • Examples on using the ogg:// wrapper.
KTaglib_ID3v2_AttachedPictureFrame::setType
Giriş
Ses Biçemleme İşlemleri


Giriş

The OGG/Vorbis file format, as defined by » http://www.vorbis.com/, is a scheme for compressing audio streams by multiple factors with a minimum of quality loss. This extension adds Ogg Vorbis support to PHP's URL Wrappers. When used in read mode, compressed OGG/Vorbis data is expanded to raw PCM audio in one of six PCM encoding formats listed in the predefined constants section.

oggvorbis
Yapılandırma/Kurulum
oggvorbis


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
oggvorbis


Gereksinimler

This extension requires PHP >= 4.3.0, » libogg >= 1.0, and » libvorbis >= 1.0.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/oggvorbis

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

OGG/Vorbis supports PCM encodings in the following formats
Constant | Definition
OGGVORBIS_PCM_U8 | Unsigned 8-bit PCM.
OGGVORBIS_PCM_S8 | Signed 8-bit PCM.
OGGVORBIS_PCM_U16_LE | Unsigned 16-bit PCM. Little Endian byte order.
OGGVORBIS_PCM_U16_BE | Unsigned 16-bit PCM. Big Endian byte order.
OGGVORBIS_PCM_S16_LE | Signed 16-bit PCM. Little Endian byte order.
OGGVORBIS_PCM_S16_BE | Signed 16-bit PCM. Big Endian byte order.
Özkaynak Türleri
Context options
oggvorbis


Context options

OGG/Vorbis tuning options
Option | Definition | Relevance | Default
pcm_mode | PCM byte encoding used. See constants below. | Read / Write | OGGVORBIS_PCM_S16_LE
rate | PCM Sampling rate. Measured in Hz. | Write only | 44100
bitrate | Vorbis Average Bitrate Encoding / Variable Bitrate Encoding. Measured in bps (ABR) or Quality level (VBR: 0.0 to 1.0). 128000 ABR is rough equal to 0.4 VBR. | Write only | 128000
channels | Number of PCM channels. 1 == Mono, 2 == Stereo. | Write only | 2
serialno | Serial Number of stream within file. Must be unique within file. Because of the potential to select a duplicate serial number within a chained file, make efforts to manually assign unique numbers when encoding. | Write only | Random
comments | Associative array of file comments. Will be translated to strtoupper($name) . "=$value". Note: This context option is not available in oggvorbis-0.1 | Write only | array('ENCODER' => 'PHP/OggVorbis, http://pear.php.net/oggvorbis')
Öntanımlı Sabitler
Örnekler
oggvorbis


Örnekler

İçindekiler

  • Examples on using the ogg:// wrapper.
Context options
Examples on using the ogg:// wrapper.
oggvorbis


Examples on using the ogg:// wrapper.

Örnek 1 Reading an OGG/Vorbis file

<?php
dl("oggvorbis.so");

/* By default, ogg:// will decode to Signed 16-bit Little Endian */
$fp = fopen('ogg://myaudio.ogg', 'r');

/* Collect some information about the file. */
$metadata = stream_get_meta_data($fp);

/* Inspect the first song (usually the only song,
   but OGG/Vorbis files may be chained) */
$songdata = $metadata['wrapper_data'][0];

echo "OGG/Vorbis file encoded by: {$songdata['vendor']}\n.";
echo "  {$songdata['channels']} channels of {$songdata['rate']}Hz sampling encoded at {$songdata['bitrate_nominal']}bps.\n";
foreach($songdata['comments'] as $comment) {
    echo "  $comment\n";
}

while ($audio_data = fread($fp, 8192)) {
  /* Do something with the PCM audio we're extracting from the OGG.
     Copying to /dev/dsp is a good target on linux systems,
     just remember to setup the device for your sampling mode first. */
}

fclose($fp);

?>

Örnek 2 Encode an audio file to OGG/Vorbis

<?php
dl('oggvorbis.so');

$context = stream_context_create(array('ogg'=>array(
             'pcm_mode' => OGGVORBIS_PCM_S8,  /* Signed 8bit audio */
             'rate' => 44100,                 /* 44kHz CD quality */
             'bitrate' => 0.5,                /* Midquality VBR */
             'channels' => 1,                 /* Mono */
             'serialno' => 12345)));          /* Unique within our stream */

/* Open file for appending.  This will "chain" a second OGG stream at the end of the first. */
$ogg = fopen('ogg://mysong.ogg', 'a', false, $context);

$pcm = fopen('mysample.pcm', 'r');

/* Compress the raw PCM audio from mysample.pcm into mysong.ogg */
stream_copy_to_stream($pcm, $ogg);

fclose($pcm);
fclose($ogg);
?>

Örnekler
OpenAL
Örnekler


OpenAL Audio Bindings

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • OpenAL İşlevleri
    • openal_buffer_create — Generate OpenAL buffer
    • openal_buffer_data — Load a buffer with data
    • openal_buffer_destroy — Destroys an OpenAL buffer
    • openal_buffer_get — Retrieve an OpenAL buffer property
    • openal_buffer_loadwav — Load a .wav file into a buffer
    • openal_context_create — Create an audio processing context
    • openal_context_current — Make the specified context current
    • openal_context_destroy — Destroys a context
    • openal_context_process — Process the specified context
    • openal_context_suspend — Suspend the specified context
    • openal_device_close — Close an OpenAL device
    • openal_device_open — Initialize the OpenAL audio layer
    • openal_listener_get — Retrieve a listener property
    • openal_listener_set — Set a listener property
    • openal_source_create — Generate a source resource
    • openal_source_destroy — Destroy a source resource
    • openal_source_get — Retrieve an OpenAL source property
    • openal_source_pause — Pause the source
    • openal_source_play — Start playing the source
    • openal_source_rewind — Rewind the source
    • openal_source_set — Set source property
    • openal_source_stop — Stop playing the source
    • openal_stream — Begin streaming on a source
Examples on using the ogg:// wrapper.
Giriş
Ses Biçemleme İşlemleri


Giriş

Platform independent audio bindings. Requires the » OpenAL library.

OpenAL
Yapılandırma/Kurulum
OpenAL


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
OpenAL


Kurulum

Bu » PECL eklentisi PHP ile gelmez.

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/openal.

Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Özkaynak Türleri

This extension defines four resource types:
Open AL(Device) - Returned by openal_device_open(),
Open AL(Context) - Returned by openal_context_create(),
Open AL(Buffer) - Returned by openal_buffer_create(),
and Open AL(Source) - Returned by openal_source_create().

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

ALC_FREQUENCY (integer)
Context Attribute
ALC_REFRESH (integer)
Context Attribute
ALC_SYNC (integer)
Context Attribute
AL_FREQUENCY (integer)
Buffer Setting
AL_BITS (integer)
Buffer Setting
AL_CHANNELS (integer)
Buffer Setting
AL_SIZE (integer)
Buffer Setting
AL_BUFFER (integer)
Source/Listener Setting (Integer)
AL_SOURCE_RELATIVE (integer)
Source/Listener Setting (Integer)
AL_SOURCE_STATE (integer)
Source/Listener Setting (Integer)
AL_PITCH (integer)
Source/Listener Setting (Float)
AL_GAIN (integer)
Source/Listener Setting (Float)
AL_MIN_GAIN (integer)
Source/Listener Setting (Float)
AL_MAX_GAIN (integer)
Source/Listener Setting (Float)
AL_MAX_DISTANCE (integer)
Source/Listener Setting (Float)
AL_ROLLOFF_FACTOR (integer)
Source/Listener Setting (Float)
AL_CONE_OUTER_GAIN (integer)
Source/Listener Setting (Float)
AL_CONE_INNER_ANGLE (integer)
Source/Listener Setting (Float)
AL_CONE_OUTER_ANGLE (integer)
Source/Listener Setting (Float)
AL_REFERENCE_DISTANCE (integer)
Source/Listener Setting (Float)
AL_POSITION (integer)
Source/Listener Setting (Float Vector)
AL_VELOCITY (integer)
Source/Listener Setting (Float Vector)
AL_DIRECTION (integer)
Source/Listener Setting (Float Vector)
AL_ORIENTATION (integer)
Source/Listener Setting (Float Vector)
AL_FORMAT_MONO8 (integer)
PCM Format
AL_FORMAT_MONO16 (integer)
PCM Format
AL_FORMAT_STEREO8 (integer)
PCM Format
AL_FORMAT_STEREO16 (integer)
PCM Format
AL_INITIAL (integer)
Source State
AL_PLAYING (integer)
Source State
AL_PAUSED (integer)
Source State
AL_STOPPED (integer)
Source State
AL_LOOPING (integer)
Source State
AL_TRUE (integer)
Boolean value recognized by OpenAL
AL_FALSE (integer)
Boolean value recognized by OpenAL
Özkaynak Türleri
OpenAL İşlevleri
OpenAL


OpenAL İşlevleri

İçindekiler

  • openal_buffer_create — Generate OpenAL buffer
  • openal_buffer_data — Load a buffer with data
  • openal_buffer_destroy — Destroys an OpenAL buffer
  • openal_buffer_get — Retrieve an OpenAL buffer property
  • openal_buffer_loadwav — Load a .wav file into a buffer
  • openal_context_create — Create an audio processing context
  • openal_context_current — Make the specified context current
  • openal_context_destroy — Destroys a context
  • openal_context_process — Process the specified context
  • openal_context_suspend — Suspend the specified context
  • openal_device_close — Close an OpenAL device
  • openal_device_open — Initialize the OpenAL audio layer
  • openal_listener_get — Retrieve a listener property
  • openal_listener_set — Set a listener property
  • openal_source_create — Generate a source resource
  • openal_source_destroy — Destroy a source resource
  • openal_source_get — Retrieve an OpenAL source property
  • openal_source_pause — Pause the source
  • openal_source_play — Start playing the source
  • openal_source_rewind — Rewind the source
  • openal_source_set — Set source property
  • openal_source_stop — Stop playing the source
  • openal_stream — Begin streaming on a source
Öntanımlı Sabitler
openal_buffer_create
OpenAL


Generate OpenAL buffer

OpenAL İşlevleri
openal_buffer_data
OpenAL İşlevleri
PHP Manual

openal_buffer_create

(PECL openal >= 0.1.0)

openal_buffer_create — Generate OpenAL buffer

Açıklama

resource openal_buffer_create ( void )

Dönen Değerler

Returns an Open AL(Buffer) resource on success or FALSE on failure.

Ayrıca Bakınız

  • openal_buffer_loadwav() - Load a .wav file into a buffer
  • openal_buffer_data() - Load a buffer with data

OpenAL İşlevleri
openal_buffer_data
OpenAL İşlevleri


Load a buffer with data

openal_buffer_create
openal_buffer_destroy
OpenAL İşlevleri
PHP Manual

openal_buffer_data

(PECL openal >= 0.1.0)

openal_buffer_data — Load a buffer with data

Açıklama

bool openal_buffer_data ( resource $buffer , int $format , string $data , int $freq )

Değiştirgeler

buffer

An Open AL(Buffer) resource (previously created by openal_buffer_create()).

format

Format of data, one of: AL_FORMAT_MONO8, AL_FORMAT_MONO16, AL_FORMAT_STEREO8 ve AL_FORMAT_STEREO16

data

Block of binary audio data in the format and freq specified.

freq

Frequency of data given in Hz.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • openal_buffer_loadwav() - Load a .wav file into a buffer
  • openal_stream() - Begin streaming on a source

openal_buffer_create
openal_buffer_destroy
OpenAL İşlevleri


Destroys an OpenAL buffer

openal_buffer_data
openal_buffer_get
OpenAL İşlevleri
PHP Manual

openal_buffer_destroy

(PECL openal >= 0.1.0)

openal_buffer_destroy — Destroys an OpenAL buffer

Açıklama

bool openal_buffer_destroy ( resource $buffer )

Değiştirgeler

buffer

An Open AL(Buffer) resource (previously created by openal_buffer_create()).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • openal_buffer_create() - Generate OpenAL buffer

openal_buffer_data
openal_buffer_get
OpenAL İşlevleri


Retrieve an OpenAL buffer property

openal_buffer_destroy
openal_buffer_loadwav
OpenAL İşlevleri
PHP Manual

openal_buffer_get

(PECL openal >= 0.1.0)

openal_buffer_get — Retrieve an OpenAL buffer property

Açıklama

int openal_buffer_get ( resource $buffer , int $property )

Değiştirgeler

buffer

An Open AL(Buffer) resource (previously created by openal_buffer_create()).

property

Specific property, one of: AL_FREQUENCY, AL_BITS, AL_CHANNELS ve AL_SIZE.

Dönen Değerler

Returns an integer value appropriate to the property requested başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • openal_buffer_create() - Generate OpenAL buffer

openal_buffer_destroy
openal_buffer_loadwav
OpenAL İşlevleri


Load a .wav file into a buffer

openal_buffer_get
openal_context_create
OpenAL İşlevleri
PHP Manual

openal_buffer_loadwav

(PECL openal >= 0.1.0)

openal_buffer_loadwav — Load a .wav file into a buffer

Açıklama

bool openal_buffer_loadwav ( resource $buffer , string $wavfile )

Değiştirgeler

buffer

An Open AL(Buffer) resource (previously created by openal_buffer_create()).

wavfile

Path to .wav file on local file system.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • openal_buffer_data() - Load a buffer with data
  • openal_stream() - Begin streaming on a source

openal_buffer_get
openal_context_create
OpenAL İşlevleri


Create an audio processing context

openal_buffer_loadwav
openal_context_current
OpenAL İşlevleri
PHP Manual

openal_context_create

(PECL openal >= 0.1.0)

openal_context_create — Create an audio processing context

Açıklama

resource openal_context_create ( resource $device )

Değiştirgeler

device

An Open AL(Device) resource (previously created by openal_device_open()).

Dönen Değerler

Returns an Open AL(Context) resource on success or FALSE on failure.

Ayrıca Bakınız

  • openal_device_open() - Initialize the OpenAL audio layer
  • openal_context_destroy() - Destroys a context

openal_buffer_loadwav
openal_context_current
OpenAL İşlevleri


Make the specified context current

openal_context_create
openal_context_destroy
OpenAL İşlevleri
PHP Manual

openal_context_current

(PECL openal >= 0.1.0)

openal_context_current — Make the specified context current

Açıklama

bool openal_context_current ( resource $context )

Değiştirgeler

context

An Open AL(Context) resource (previously created by openal_context_create()).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • openal_context_create() - Create an audio processing context

openal_context_create
openal_context_destroy
OpenAL İşlevleri


Destroys a context

openal_context_current
openal_context_process
OpenAL İşlevleri
PHP Manual

openal_context_destroy

(PECL openal >= 0.1.0)

openal_context_destroy — Destroys a context

Açıklama

bool openal_context_destroy ( resource $context )

Değiştirgeler

context

An Open AL(Context) resource (previously created by openal_context_create()).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • openal_context_create() - Create an audio processing context

openal_context_current
openal_context_process
OpenAL İşlevleri


Process the specified context

openal_context_destroy
openal_context_suspend
OpenAL İşlevleri
PHP Manual

openal_context_process

(PECL openal >= 0.1.0)

openal_context_process — Process the specified context

Açıklama

bool openal_context_process ( resource $context )

Değiştirgeler

context

An Open AL(Context) resource (previously created by openal_context_create()).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • openal_context_create() - Create an audio processing context
  • openal_context_current() - Make the specified context current
  • openal_context_suspend() - Suspend the specified context

openal_context_destroy
openal_context_suspend
OpenAL İşlevleri


Suspend the specified context

openal_context_process
openal_device_close
OpenAL İşlevleri
PHP Manual

openal_context_suspend

(PECL openal >= 0.1.0)

openal_context_suspend — Suspend the specified context

Açıklama

bool openal_context_suspend ( resource $context )

Değiştirgeler

context

An Open AL(Context) resource (previously created by openal_context_create()).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • openal_context_create() - Create an audio processing context
  • openal_context_current() - Make the specified context current
  • openal_context_process() - Process the specified context

openal_context_process
openal_device_close
OpenAL İşlevleri


Close an OpenAL device

openal_context_suspend
openal_device_open
OpenAL İşlevleri
PHP Manual

openal_device_close

(PECL openal >= 0.1.0)

openal_device_close — Close an OpenAL device

Açıklama

bool openal_device_close ( resource $device )

Değiştirgeler

device

An Open AL(Device) resource (previously created by openal_device_open()) to be closed.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • openal_device_open() - Initialize the OpenAL audio layer

openal_context_suspend
openal_device_open
OpenAL İşlevleri


Initialize the OpenAL audio layer

openal_device_close
openal_listener_get
OpenAL İşlevleri
PHP Manual

openal_device_open

(PECL openal >= 0.1.0)

openal_device_open — Initialize the OpenAL audio layer

Açıklama

resource openal_device_open ([ string $device_desc ] )

Değiştirgeler

device_desc

Open an audio device optionally specified by device_desc. If device_desc is not specified the first available audio device will be used.

Dönen Değerler

Returns an Open AL(Device) resource on success or FALSE on failure.

Ayrıca Bakınız

  • openal_device_close() - Close an OpenAL device
  • openal_context_create() - Create an audio processing context

openal_device_close
openal_listener_get
OpenAL İşlevleri


Retrieve a listener property

openal_device_open
openal_listener_set
OpenAL İşlevleri
PHP Manual

openal_listener_get

(PECL openal >= 0.1.0)

openal_listener_get — Retrieve a listener property

Açıklama

mixed openal_listener_get ( int $property )

Değiştirgeler

property

Property to retrieve, one of:
AL_GAIN (float),
AL_POSITION (array(float,float,float)),
AL_VELOCITY (array(float,float,float)) ve
AL_ORIENTATION (array(float,float,float)).

Dönen Değerler

Returns a float or array of floats (as appropriate) başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • openal_listener_set() - Set a listener property

openal_device_open
openal_listener_set
OpenAL İşlevleri


Set a listener property

openal_listener_get
openal_source_create
OpenAL İşlevleri
PHP Manual

openal_listener_set

(PECL openal >= 0.1.0)

openal_listener_set — Set a listener property

Açıklama

bool openal_listener_set ( int $property , mixed $setting )

Değiştirgeler

property

Property to set, one of:
AL_GAIN (float),
AL_POSITION (array(float,float,float)),
AL_VELOCITY (array(float,float,float)) ve
AL_ORIENTATION (array(float,float,float)).

setting

Value to set, either float, or an array of floats as appropriate.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • openal_listener_get() - Retrieve a listener property

openal_listener_get
openal_source_create
OpenAL İşlevleri


Generate a source resource

openal_listener_set
openal_source_destroy
OpenAL İşlevleri
PHP Manual

openal_source_create

(PECL openal >= 0.1.0)

openal_source_create — Generate a source resource

Açıklama

resource openal_source_create ( void )

Dönen Değerler

Returns an Open AL(Source) resource on success or FALSE on failure.

Ayrıca Bakınız

  • openal_source_set() - Set source property
  • openal_source_play() - Start playing the source
  • openal_source_destroy() - Destroy a source resource

openal_listener_set
openal_source_destroy
OpenAL İşlevleri


Destroy a source resource

openal_source_create
openal_source_get
OpenAL İşlevleri
PHP Manual

openal_source_destroy

(PECL openal >= 0.1.0)

openal_source_destroy — Destroy a source resource

Açıklama

bool openal_source_destroy ( resource $source )

Değiştirgeler

source

An Open AL(Source) resource (previously created by openal_source_create()).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • openal_source_create() - Generate a source resource

openal_source_create
openal_source_get
OpenAL İşlevleri


Retrieve an OpenAL source property

openal_source_destroy
openal_source_pause
OpenAL İşlevleri
PHP Manual

openal_source_get

(PECL openal >= 0.1.0)

openal_source_get — Retrieve an OpenAL source property

Açıklama

mixed openal_source_get ( resource $source , int $property )

Değiştirgeler

source

An Open AL(Source) resource (previously created by openal_source_create()).

property

Property to get, one of: AL_SOURCE_RELATIVE (int), AL_SOURCE_STATE (int), AL_PITCH (float), AL_GAIN (float), AL_MIN_GAIN (float), AL_MAX_GAIN (float), AL_MAX_DISTANCE (float), AL_ROLLOFF_FACTOR (float), AL_CONE_OUTER_GAIN (float), AL_CONE_INNER_ANGLE (float), AL_CONE_OUTER_ANGLE (float), AL_REFERENCE_DISTANCE (float), AL_POSITION (array(float,float,float)), AL_VELOCITY (array(float,float,float)), AL_DIRECTION (array(float,float,float)).

Dönen Değerler

Returns the type associated with the property being retrieved başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • openal_source_create() - Generate a source resource
  • openal_source_set() - Set source property
  • openal_source_play() - Start playing the source

openal_source_destroy
openal_source_pause
OpenAL İşlevleri


Pause the source

openal_source_get
openal_source_play
OpenAL İşlevleri
PHP Manual

openal_source_pause

(PECL openal >= 0.1.0)

openal_source_pause — Pause the source

Açıklama

bool openal_source_pause ( resource $source )

Değiştirgeler

source

An Open AL(Source) resource (previously created by openal_source_create()).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • openal_source_stop() - Stop playing the source
  • openal_source_play() - Start playing the source
  • openal_source_rewind() - Rewind the source

openal_source_get
openal_source_play
OpenAL İşlevleri


Start playing the source

openal_source_pause
openal_source_rewind
OpenAL İşlevleri
PHP Manual

openal_source_play

(PECL openal >= 0.1.0)

openal_source_play — Start playing the source

Açıklama

bool openal_source_play ( resource $source )

Değiştirgeler

source

An Open AL(Source) resource (previously created by openal_source_create()).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • openal_source_stop() - Stop playing the source
  • openal_source_pause() - Pause the source
  • openal_source_rewind() - Rewind the source

openal_source_pause
openal_source_rewind
OpenAL İşlevleri


Rewind the source

openal_source_play
openal_source_set
OpenAL İşlevleri
PHP Manual

openal_source_rewind

(PECL openal >= 0.1.0)

openal_source_rewind — Rewind the source

Açıklama

bool openal_source_rewind ( resource $source )

Değiştirgeler

source

An Open AL(Source) resource (previously created by openal_source_create()).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • openal_source_stop() - Stop playing the source
  • openal_source_pause() - Pause the source
  • openal_source_play() - Start playing the source

openal_source_play
openal_source_set
OpenAL İşlevleri


Set source property

openal_source_rewind
openal_source_stop
OpenAL İşlevleri
PHP Manual

openal_source_set

(PECL openal >= 0.1.0)

openal_source_set — Set source property

Açıklama

bool openal_source_set ( resource $source , int $property , mixed $setting )

Değiştirgeler

source

An Open AL(Source) resource (previously created by openal_source_create()).

property

Property to set, one of: AL_BUFFER (OpenAL(Source)), AL_LOOPING (bool), AL_SOURCE_RELATIVE (int), AL_SOURCE_STATE (int), AL_PITCH (float), AL_GAIN (float), AL_MIN_GAIN (float), AL_MAX_GAIN (float), AL_MAX_DISTANCE (float), AL_ROLLOFF_FACTOR (float), AL_CONE_OUTER_GAIN (float), AL_CONE_INNER_ANGLE (float), AL_CONE_OUTER_ANGLE (float), AL_REFERENCE_DISTANCE (float), AL_POSITION (array(float,float,float)), AL_VELOCITY (array(float,float,float)), AL_DIRECTION (array(float,float,float)).

setting

Value to assign to specified property. Refer to the description of property for a description of the value(s) expected.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • openal_source_create() - Generate a source resource
  • openal_source_get() - Retrieve an OpenAL source property
  • openal_source_play() - Start playing the source

openal_source_rewind
openal_source_stop
OpenAL İşlevleri


Stop playing the source

openal_source_set
openal_stream
OpenAL İşlevleri
PHP Manual

openal_source_stop

(PECL openal >= 0.1.0)

openal_source_stop — Stop playing the source

Açıklama

bool openal_source_stop ( resource $source )

Değiştirgeler

source

An Open AL(Source) resource (previously created by openal_source_create()).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • openal_source_play() - Start playing the source
  • openal_source_pause() - Pause the source
  • openal_source_rewind() - Rewind the source

openal_source_set
openal_stream
OpenAL İşlevleri


Begin streaming on a source

openal_source_stop
Kimlik Doğrulama Hizmetleri
OpenAL İşlevleri
PHP Manual

openal_stream

(PECL openal >= 0.1.0)

openal_stream — Begin streaming on a source

Açıklama

resource openal_stream ( resource $source , int $format , int $rate )

Değiştirgeler

source

An Open AL(Source) resource (previously created by openal_source_create()).

format

Format of data, one of: AL_FORMAT_MONO8, AL_FORMAT_MONO16, AL_FORMAT_STEREO8 ve AL_FORMAT_STEREO16

rate

Frequency of data to stream given in Hz.

Dönen Değerler

Returns a stream resource on success başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • openal_source_create() - Generate a source resource
  • fwrite() - Dosyaya ikil kipte yazar

openal_source_stop
Kimlik Doğrulama Hizmetleri
OpenAL İşlevleri


Kimlik Doğrulama Hizmetleri

  • KADM5 — Kerberos V
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • KADM5 İşlevleri
  • Radius
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • Radius İşlevleri
openal_stream
KADM5
İşlev Başvuru Kılavuzu


Kerberos V

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
    • Constants for Attribute Flags
    • Constants for Options
  • Örnekler
    • Basic usage
  • KADM5 İşlevleri
    • kadm5_chpass_principal — Changes the principal's password
    • kadm5_create_principal — Creates a kerberos principal with the given parameters
    • kadm5_delete_principal — Deletes a kerberos principal
    • kadm5_destroy — Closes the connection to the admin server and releases all related resources
    • kadm5_flush — Flush all changes to the Kerberos database
    • kadm5_get_policies — Gets all policies from the Kerberos database
    • kadm5_get_principal — Gets the principal's entries from the Kerberos database
    • kadm5_get_principals — Gets all principals from the Kerberos database
    • kadm5_init_with_password — Opens a connection to the KADM5 library
    • kadm5_modify_principal — Modifies a kerberos principal with the given parameters
Kimlik Doğrulama Hizmetleri
Giriş
Kimlik Doğrulama Hizmetleri


Giriş

These package allows you to access Kerberos V administration servers. You can create, modify, and delete Kerberos V principals and policies.

More information about Kerberos can be found at » http://web.mit.edu/kerberos/www/.

Documentation for Kerberos and KADM5 can be found at » http://web.mit.edu/kerberos/www/krb5-1.2/krb5-1.2.8/doc/admin_toc.html.

KADM5
Yapılandırma/Kurulum
KADM5


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
KADM5


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/kadm5.

Bilginize:

If this option is used without specifying the path to KADM5, PHP will use the built-in KADM5 client libraries. Users who run other applications that use KADM5 (for example, running PHP 4 and PHP 5 as concurrent apache modules, or auth-kadm5) should always specify the path to KADM5: --with-kadm5=/path/to/kadm5. This will force PHP to use the client libraries installed by KADM5, avoiding any conflicts.

Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Özkaynak Türleri

This extension defines a KADM5 handle returned by kadm5_init_with_password().

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

İçindekiler

  • Constants for Attribute Flags
  • Constants for Options

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

Özkaynak Türleri
Constants for Attribute Flags
KADM5


Constants for Attribute Flags

The functions kadm5_create_principal(),
kadm5_modify_principal(), and
kadm5_modify_principal() allow to specify
special attributes using a bitfield. The symbols are defined below:

Attributes for use by the KDC
constant
KRB5_KDB_DISALLOW_POSTDATED
KRB5_KDB_DISALLOW_FORWARDABLE
KRB5_KDB_DISALLOW_TGT_BASED
KRB5_KDB_DISALLOW_RENEWABLE
KRB5_KDB_DISALLOW_PROXIABLE
KRB5_KDB_DISALLOW_DUP_SKEY
KRB5_KDB_DISALLOW_ALL_TIX
KRB5_KDB_REQUIRES_PRE_AUTH
KRB5_KDB_REQUIRES_HW_AUTH
KRB5_KDB_REQUIRES_PWCHANGE
KRB5_KDB_DISALLOW_SVR
KRB5_KDB_PWCHANGE_SERVER
KRB5_KDB_SUPPORT_DESMD5
KRB5_KDB_NEW_PRINC

Öntanımlı Sabitler
Constants for Options
Öntanımlı Sabitler


Constants for Options

The functions kadm5_create_principal(),
kadm5_modify_principal(), and
kadm5_get_principal() allow to specify or return
principal's options as an associative array. The keys for the associative
array are defined as string constants below:

Options for creating/modifying/retrieving principals
constant | funcdef | description
KADM5_PRINCIPAL | long | The expire time of the princial as a Kerberos timestamp.
KADM5_PRINC_EXPIRE_TIME | long | The expire time of the princial as a Kerberos timestamp.
KADM5_LAST_PW_CHANGE | long | The time this principal's password was last changed.
KADM5_PW_EXPIRATION | long | The expire time of the principal's current password, as a Kerberos timestamp.
KADM5_MAX_LIFE | long | The maximum lifetime of any Kerberos ticket issued to this principal.
KADM5_MAX_RLIFE | long | The maximum renewable lifetime of any Kerberos ticket issued to or for this principal.
KADM5_MOD_NAME | string | The name of the Kerberos principal that most recently modified this principal.
KADM5_MOD_TIME | long | The time this principal was last modified, as a Kerberos timestamp.
KADM5_KVNO | long | The version of the principal's current key.
KADM5_POLICY | string | The name of the policy controlling this principal.
KADM5_CLEARPOLICY | long | Standard procedure is to assign the 'default' policy to new principals. KADM5_CLEARPOLICY suppresses this behaviour.
KADM5_LAST_SUCCESS | long | The KDC time of the last successfull AS_REQ.
KADM5_LAST_FAILED | long | The KDC time of the last failed AS_REQ.
KADM5_FAIL_AUTH_COUNT | long | The number of consecutive failed AS_REQs.
KADM5_RANDKEY | long | Generates a random password for the principal. The parameter password will be ignored.
KADM5_ATTRIBUTES | long | A bitfield of attributes for use by the KDC.

Constants for Attribute Flags
Örnekler
Öntanımlı Sabitler


Örnekler

İçindekiler

  • Basic usage
Constants for Options
Basic usage
KADM5


Basic usage

This simple example shows how to connect, query, print resulting principals and disconnect from a KADM5 database.

Örnek 1 KADM5 extension overview example

<?php

  $handle = kadm5_init_with_password("afs-1", "GONICUS.LOCAL", "admin/admin", "password");

  print "<h1>get_principals</h1>\n";
  $principals = kadm5_get_principals($handle);
  for( $i=0; $i<count($principals); $i++)
      print "$principals[$i]<br>\n";

  print "<h1>get_policies</h1>\n";
  $policies = kadm5_get_policies($handle);
  for( $i=0; $i<count($policies); $i++)
      print "$policies[$i]<br>\n";

  print "<h1>get_principal burbach@GONICUS.LOCAL</h1>\n";

  $options = kadm5_get_principal($handle, "burbach@GONICUS.LOCAL" );
  $keys = array_keys($options);
  for( $i=0; $i<count($keys); $i++) {
    $value = $options[$keys[$i]];
    print "$keys[$i]: $value<br>\n";
  }

  $options = array(KADM5_PRINC_EXPIRE_TIME => 0);
  kadm5_modify_principal($handle, "burbach@GONICUS.LOCAL", $options);

  kadm5_destroy($handle);
?>

Örnekler
KADM5 İşlevleri
Örnekler


KADM5 İşlevleri

İçindekiler

  • kadm5_chpass_principal — Changes the principal's password
  • kadm5_create_principal — Creates a kerberos principal with the given parameters
  • kadm5_delete_principal — Deletes a kerberos principal
  • kadm5_destroy — Closes the connection to the admin server and releases all related resources
  • kadm5_flush — Flush all changes to the Kerberos database
  • kadm5_get_policies — Gets all policies from the Kerberos database
  • kadm5_get_principal — Gets the principal's entries from the Kerberos database
  • kadm5_get_principals — Gets all principals from the Kerberos database
  • kadm5_init_with_password — Opens a connection to the KADM5 library
  • kadm5_modify_principal — Modifies a kerberos principal with the given parameters
Basic usage
kadm5_chpass_principal
KADM5


Changes the principal's password

KADM5 İşlevleri
kadm5_create_principal
KADM5 İşlevleri
PHP Manual

kadm5_chpass_principal

(PECL kadm5 >= 0.2.3)

kadm5_chpass_principal — Changes the principal's password

Açıklama

bool kadm5_chpass_principal ( resource $handle , string $principal , string $password )

kadm5_chpass_principal() sets the new password password for the principal.

Değiştirgeler

handle

A KADM5 handle.

principal

The principal.

password

The new password.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Example of changing principal's password

<?php

$handle = kadm5_init_with_password("afs-1", "GONICUS.LOCAL", "admin/admin", "password");

kadm5_chpass_principal($handle, "burbach@GONICUS.LOCAL", "newpassword");

kadm5_destroy($handle);
?>

KADM5 İşlevleri
kadm5_create_principal
KADM5 İşlevleri


Creates a kerberos principal with the given parameters

kadm5_chpass_principal
kadm5_delete_principal
KADM5 İşlevleri
PHP Manual

kadm5_create_principal

(PECL kadm5 >= 0.2.3)

kadm5_create_principal — Creates a kerberos principal with the given parameters

Açıklama

bool kadm5_create_principal ( resource $handle , string $principal [, string $password [, array $options ]] )

Creates a principal with the given password.

Değiştirgeler

handle

A KADM5 handle.

principal

The principal.

password

If password is omitted or is NULL, a random key will be generated.

options

It is possible to specify several optional parameters within the array options. Allowed are the following options: KADM5_PRINC_EXPIRE_TIME, KADM5_PW_EXPIRATION, KADM5_ATTRIBUTES, KADM5_MAX_LIFE, KADM5_KVNO, KADM5_POLICY, KADM5_CLEARPOLICY, KADM5_MAX_RLIFE.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Example of principal's creation

<?php

$handle = kadm5_init_with_password("afs-1", "GONICUS.LOCAL", "admin/admin", "password");

$attributes = KRB5_KDB_REQUIRES_PRE_AUTH | KRB5_KDB_DISALLOW_PROXIABLE;
$options = array(KADM5_PRINC_EXPIRE_TIME => 0,
                 KADM5_POLICY => "default",
                 KADM5_ATTRIBUTES => $attributes);

kadm5_create_principal($handle, "burbach@GONICUS.LOCAL", "password", $options);

kadm5_destroy($handle);
?>

Ayrıca Bakınız

  • kadm5_modify_principal() - Modifies a kerberos principal with the given parameters
  • kadm5_delete_principal() - Deletes a kerberos principal

kadm5_chpass_principal
kadm5_delete_principal
KADM5 İşlevleri


Deletes a kerberos principal

kadm5_create_principal
kadm5_destroy
KADM5 İşlevleri
PHP Manual

kadm5_delete_principal

(PECL kadm5 >= 0.2.3)

kadm5_delete_principal — Deletes a kerberos principal

Açıklama

bool kadm5_delete_principal ( resource $handle , string $principal )

Removes the principal from the Kerberos database.

Değiştirgeler

handle

A KADM5 handle.

principal

The removed principal.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 kadm5_delete_principal() example

<?php

$handle = kadm5_init_with_password("afs-1", "GONICUS.LOCAL", "admin/admin", "password");

kadm5_delete_principal($handle, "burbach@GONICUS.LOCAL");

kadm5_destroy($handle);
?>

Ayrıca Bakınız

  • kadm5_modify_principal() - Modifies a kerberos principal with the given parameters
  • kadm5_create_principal() - Creates a kerberos principal with the given parameters

kadm5_create_principal
kadm5_destroy
KADM5 İşlevleri


Closes the connection to the admin server and releases all related resources

kadm5_delete_principal
kadm5_flush
KADM5 İşlevleri
PHP Manual

kadm5_destroy

(PECL kadm5 >= 0.2.3)

kadm5_destroy — Closes the connection to the admin server and releases all related resources

Açıklama

bool kadm5_destroy ( resource $handle )

Closes the connection to the admin server and releases all related resources.

Değiştirgeler

handle

A KADM5 handle.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • kadm5_init_with_password() - Opens a connection to the KADM5 library

kadm5_delete_principal
kadm5_flush
KADM5 İşlevleri


Flush all changes to the Kerberos database

kadm5_destroy
kadm5_get_policies
KADM5 İşlevleri
PHP Manual

kadm5_flush

(PECL kadm5 >= 0.2.3)

kadm5_flush — Flush all changes to the Kerberos database

Açıklama

bool kadm5_flush ( resource $handle )

Flush all changes to the Kerberos database, leaving the connection to the Kerberos admin server open.

Değiştirgeler

handle

A KADM5 handle.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

kadm5_destroy
kadm5_get_policies
KADM5 İşlevleri


Gets all policies from the Kerberos database

kadm5_flush
kadm5_get_principal
KADM5 İşlevleri
PHP Manual

kadm5_get_policies

(PECL kadm5 >= 0.2.3)

kadm5_get_policies — Gets all policies from the Kerberos database

Açıklama

array kadm5_get_policies ( resource $handle )

Gets an array containing the policies's names.

Değiştirgeler

handle

A KADM5 handle.

Dönen Değerler

Returns array of policies on success başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 kadm5_get_policies() example

<?php
$handle = kadm5_init_with_password("afs-1", "GONICUS.LOCAL", "admin/admin", "password");

print "<h1>get_policies</h1>\n";
foreach (kadm5_get_policies($handle) as $policy) {
    echo "$policy<br />\n";
}

kadm5_destroy($handle);
?>

kadm5_flush
kadm5_get_principal
KADM5 İşlevleri


Gets the principal's entries from the Kerberos database

kadm5_get_policies
kadm5_get_principals
KADM5 İşlevleri
PHP Manual

kadm5_get_principal

(PECL kadm5 >= 0.2.3)

kadm5_get_principal — Gets the principal's entries from the Kerberos database

Açıklama

array kadm5_get_principal ( resource $handle , string $principal )

Gets the principal's entries from the Kerberos database.

Değiştirgeler

handle

A KADM5 handle.

principal

The principal.

Dönen Değerler

Returns array of options containing the following keys: KADM5_PRINCIPAL, KADM5_PRINC_EXPIRE_TIME, KADM5_PW_EXPIRATION, KADM5_ATTRIBUTES, KADM5_MAX_LIFE, KADM5_MOD_NAME, KADM5_MOD_TIME, KADM5_KVNO, KADM5_POLICY, KADM5_MAX_RLIFE, KADM5_LAST_SUCCESS, KADM5_LAST_FAILED, KADM5_FAIL_AUTH_COUNT on success başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 kadm5_get_principal() example

<?php
$handle = kadm5_init_with_password("afs-1", "GONICUS.LOCAL", "admin/admin", "password");

print "<h1>get_principal burbach@GONICUS.LOCAL</h1>\n";

$options = kadm5_get_principal($handle, "burbach@GONICUS.LOCAL" );

foreach ($options as $key => $value) {
    echo "$key: $value<br />\n";
}

kadm5_destroy($handle);
?>

Ayrıca Bakınız

  • kadm5_get_principals() - Gets all principals from the Kerberos database

kadm5_get_policies
kadm5_get_principals
KADM5 İşlevleri


Gets all principals from the Kerberos database

kadm5_get_principal
kadm5_init_with_password
KADM5 İşlevleri
PHP Manual

kadm5_get_principals

(PECL kadm5 >= 0.2.3)

kadm5_get_principals — Gets all principals from the Kerberos database

Açıklama

array kadm5_get_principals ( resource $handle )

kadm5_get_principals() returns an array containing the principals's names.

Değiştirgeler

handle

A KADM5 handle.

Dönen Değerler

Returns array of principals on success başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 kadm5_get_principals() example

<?php
$handle = kadm5_init_with_password("afs-1", "GONICUS.LOCAL", "admin/admin", "password");

print "<h1>get_principals</h1>\n";
foreach (kadm5_get_principals($handle) as $principal) {
    echo "$principal<br />\n";
}

kadm5_destroy($handle);
?>

Ayrıca Bakınız

  • kadm5_get_principal() - Gets the principal's entries from the Kerberos database

kadm5_get_principal
kadm5_init_with_password
KADM5 İşlevleri


Opens a connection to the KADM5 library

kadm5_get_principals
kadm5_modify_principal
KADM5 İşlevleri
PHP Manual

kadm5_init_with_password

(PECL kadm5 >= 0.2.3)

kadm5_init_with_password — Opens a connection to the KADM5 library

Açıklama

resource kadm5_init_with_password ( string $admin_server , string $realm , string $principal , string $password )

Opens a connection with the KADM5 library using the principal and the given password to obtain initial credentials from the admin_server.

Değiştirgeler

admin_server

The server.

realm

Defines the authentication domain for the connection.

principal

The principal.

password

If password is omitted or is NULL, a random key will be generated.

Dönen Değerler

Returns a KADM5 handle on success başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 KADM5 initialization example

<?php

$handle = kadm5_init_with_password("afs-1", "GONICUS.LOCAL", "admin/admin", "password");

$attributes = KRB5_KDB_REQUIRES_PRE_AUTH | KRB5_KDB_DISALLOW_PROXIABLE;
$options = array(KADM5_PRINC_EXPIRE_TIME => 0,
                 KADM5_POLICY => "default",
                 KADM5_ATTRIBUTES => $attributes);

kadm5_create_principal($handle, "burbach@GONICUS.LOCAL", "password", $options);

kadm5_destroy($handle);
?>

Notlar

Bilginize:

Connection should be closed after use with kadm5_destroy().

Ayrıca Bakınız

  • kadm5_destroy() - Closes the connection to the admin server and releases all related resources

kadm5_get_principals
kadm5_modify_principal
KADM5 İşlevleri


Modifies a kerberos principal with the given parameters

kadm5_init_with_password
Radius
KADM5 İşlevleri
PHP Manual

kadm5_modify_principal

(PECL kadm5 >= 0.2.3)

kadm5_modify_principal — Modifies a kerberos principal with the given parameters

Açıklama

bool kadm5_modify_principal ( resource $handle , string $principal , array $options )

Modifies a principal according to the given options.

Değiştirgeler

handle

A KADM5 handle.

principal

The principal.

options

It is possible to specify several optional parameters within the array options. Allowed are the following options: KADM5_PRINC_EXPIRE_TIME, KADM5_PW_EXPIRATION, KADM5_ATTRIBUTES, KADM5_MAX_LIFE, KADM5_KVNO, KADM5_POLICY, KADM5_CLEARPOLICY, KADM5_MAX_RLIFE. KADM5_FAIL_AUTH_COUNT.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Example of modifying principal

<?php

$handle = kadm5_init_with_password("afs-1", "GONICUS.LOCAL", "admin/admin", "password");

$attributes = KRB5_KDB_REQUIRES_PRE_AUTH;
$options = array(KADM5_PRINC_EXPIRE_TIME => 3451234,
                 KADM5_POLICY => "gonicus",
                 KADM5_ATTRIBUTES => $attributes);

kadm5_modify_principal($handle, "burbach@GONICUS.LOCAL", $options);

kadm5_destroy($handle);
?>

Ayrıca Bakınız

  • kadm5_create_principal() - Creates a kerberos principal with the given parameters
  • kadm5_delete_principal() - Deletes a kerberos principal

kadm5_init_with_password
Radius
KADM5 İşlevleri


Radius

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
    • RADIUS Options
    • RADIUS Packet Types
    • RADIUS Attribute Types
    • RADIUS Vendor Specific Attribute Types
  • Örnekler
  • Radius İşlevleri
    • radius_acct_open — Creates a Radius handle for accounting
    • radius_add_server — Adds a server
    • radius_auth_open — Creates a Radius handle for authentication
    • radius_close — Frees all ressources
    • radius_config — Causes the library to read the given configuration file
    • radius_create_request — Create accounting or authentication request
    • radius_cvt_addr — Converts raw data to IP-Address
    • radius_cvt_int — Converts raw data to integer
    • radius_cvt_string — Converts raw data to string
    • radius_demangle_mppe_key — Derives mppe-keys from mangled data
    • radius_demangle — Demangles data
    • radius_get_attr — Extracts an attribute
    • radius_get_tagged_attr_data — Extracts the data from a tagged attribute
    • radius_get_tagged_attr_tag — Extracts the tag from a tagged attribute
    • radius_get_vendor_attr — Extracts a vendor specific attribute
    • radius_put_addr — Attaches an IP address attribute
    • radius_put_attr — Attaches a binary attribute
    • radius_put_int — Attaches an integer attribute
    • radius_put_string — Attaches a string attribute
    • radius_put_vendor_addr — Attaches a vendor specific IP address attribute
    • radius_put_vendor_attr — Attaches a vendor specific binary attribute
    • radius_put_vendor_int — Attaches a vendor specific integer attribute
    • radius_put_vendor_string — Attaches a vendor specific string attribute
    • radius_request_authenticator — Returns the request authenticator
    • radius_salt_encrypt_attr — Salt-encrypts a value
    • radius_send_request — Sends the request and waites for a reply
    • radius_server_secret — Returns the shared secret
    • radius_strerror — Returns an error message
kadm5_modify_principal
Giriş
Kimlik Doğrulama Hizmetleri


Giriş

This package is based on the libradius (Remote Authentication Dial In User Service) of FreeBSD. It allows clients to perform authentication and accounting by means of network requests to remote servers.

This PECL extension adds full support for Radius Authentication (» RFC 2865) and Radius Accounting (» RFC 2866). This package is available for Unix (tested on FreeBSD and Linux) and for Windows.

Bilginize:

An exact description for libradius can be found » here. A detailed description of the configuration file can be found » here.

Radius
Yapılandırma/Kurulum
Radius


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Radius


Kurulum

Bu » PECL eklentisi PHP ile gelmez.

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/radius.

Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

İçindekiler

  • RADIUS Options
  • RADIUS Packet Types
  • RADIUS Attribute Types
  • RADIUS Vendor Specific Attribute Types

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

RADIUS_MPPE_KEY_LEN (integer)
The maximum length of MPPE keys.
Özkaynak Türleri
RADIUS Options
Radius


RADIUS Options

Several RADIUS functions accept option flags as bitmasks. The constants representing those flags are listed below.

RADIUS_OPTION_SALT (integer)

When set, this option will result in the attribute value being salt-encrypted.

RADIUS_OPTION_TAGGED (integer)

When set, this option will result in the attribute value being tagged with the value of the tag parameter.

Öntanımlı Sabitler
RADIUS Packet Types
Öntanımlı Sabitler


RADIUS Packet Types

RADIUS packets, whether requests or responses, always include a type. These constants are provided to make it easier to specify types when using radius_create_request() and when comparing the result of radius_send_request().

RADIUS_ACCESS_REQUEST (integer)

An Access-Request, used to authenticate a user against a RADIUS server. Access request packets must include a RADIUS_NAS_IP_ADDRESS or a RADIUS_NAS_IDENTIFIER attribute, must also include a RADIUS_USER_PASSWORD, RADIUS_CHAP_PASSWORD or a RADIUS_STATE attribute, and should include a RADIUS_USER_NAME attribute.

RADIUS_ACCESS_ACCEPT (integer)

An Access-Accept response to an Access-Request indicating that the RADIUS server authenticated the user successfully.

RADIUS_ACCESS_REJECT (integer)

An Access-Reject response to an Access-Request indicating that the RADIUS server could not authenticate the user.

RADIUS_ACCESS_CHALLENGE (integer)

An Access-Challenge response to an Access-Request indicating that the RADIUS server requires further information in another Access-Request before authenticating the user.

RADIUS_ACCOUNTING_REQUEST (integer)

An Accounting-Request, used to convey accounting information for a service to the RADIUS server.

RADIUS_ACCOUNTING_RESPONSE (integer)

An Accounting-Response response to an Accounting-Request.

RADIUS_COA_REQUEST (integer)

A CoA-Request, sent from the RADIUS server to indicate that the authorisations within the user session have changed. A response must be sent in the form of a CoA-ACK or a CoA-NAK.

This constant is available in PECL radius 1.3.0 and later.

RADIUS_COA_ACK (integer)

A CoA-ACK, sent to the RADIUS server to indicate that the user authorisations have been updated.

This constant is available in PECL radius 1.3.0 and later.

RADIUS_COA_NAK (integer)

A CoA-NAK, sent to the RADIUS server to indicate that the user authorisations could not be updated.

This constant is available in PECL radius 1.3.0 and later.

RADIUS_DISCONNECT_REQUEST (integer)

A Disconnect-Request, sent from the RADIUS server to indicate that the user session must be terminated.

This constant is available in PECL radius 1.3.0 and later.

RADIUS_DISCONNECT_ACK (integer)

A Disconnect-ACK, sent to the RADIUS server to indicate that the user session has been terminated.

This constant is available in PECL radius 1.3.0 and later.

RADIUS_DISCONNECT_NAK (integer)

A Disconnect-NAK, sent to the RADIUS server to indicate that the user session could not be terminated.

This constant is available in PECL radius 1.3.0 and later.

RADIUS Options
RADIUS Attribute Types
Öntanımlı Sabitler


RADIUS Attribute Types

These constants define RADIUS attribute types that can be used with
radius_put_addr(), radius_put_attr(),
radius_put_int() and
radius_put_string().

RADIUS_USER_NAME (integer)

The User-Name attribute. The attribute value is expected to be a string containing the name of the user being authenticated, and can be set using radius_put_attr().

RADIUS_USER_PASSWORD (integer)

The User-Password attribute. The attribute value is expected to be a string containing the user's password, and can be set using radius_put_attr(). This value will be obfuscated on transmission as described in » section 5.2 of RFC 2865.

RADIUS_CHAP_PASSWORD (integer)

The Chap-Password attribute. The attribute value is expected to be a string with the first byte containing the CHAP identifier, and the subsequent 16 bytes containing the MD5 hash of the CHAP identifier, the plaintext password and the CHAP challenge value concatenated together. Note that the CHAP challenge value should also be sent separately in a RADIUS_CHAP_CHALLENGE attribute.

Örnek 1 Using CHAP passwords

<?php
// Firstly, we'll create an authentication handle and request.
$radh = radius_auth_open();
radius_add_server($radh, $server, $port, $secret, 3, 3);
radius_create_request($radh, RADIUS_ACCESS_REQUEST);

// Assuming $password contains the plaintext password, we now:

// Generate a challenge.
$challenge = mt_rand();

// Specify a CHAP identifier.
$ident = 1;

// Add the Chap-Password attribute.
$cp = md5(pack('Ca*', $ident, $password.$challenge), true);
radius_put_attr($radh, RADIUS_CHAP_PASSWORD, pack('C', $ident).$cp);

// Add the Chap-Challenge attribute.
radius_put_attr($radh, RADIUS_CHAP_CHALLENGE, $challenge);

/* From here, you would add the remaining attributes and
 * call radius_send_request(). */
?>

RADIUS_NAS_IP_ADDRESS (integer)

The NAS-IP-Address attribute. The attribute value is expected to the IP address of the RADIUS client encoded as an integer, which can be set using radius_put_addr().

RADIUS_NAS_PORT (integer)

The NAS-Port attribute. The attribute value is expected to be the physical port of the user on the RADIUS client encoded as an integer, which can be set using radius_put_int().

RADIUS_SERVICE_TYPE (integer)

The Service-Type attribute. The attribute value indicates the service type the user is requesting, and is expected to be an integer, which can be set using radius_put_int().

A number of constants are provided to represent the possible values of this attribute. They include:

  • RADIUS_LOGIN
  • RADIUS_FRAMED
  • RADIUS_CALLBACK_LOGIN
  • RADIUS_CALLBACK_FRAMED
  • RADIUS_OUTBOUND
  • RADIUS_ADMINISTRATIVE
  • RADIUS_NAS_PROMPT
  • RADIUS_AUTHENTICATE_ONLY
  • RADIUS_CALLBACK_NAS_PROMPT

RADIUS_FRAMED_PROTOCOL (integer)

The Framed-Protocol attribute. The attribute value is expected to be an integer indicating the framing to be used for framed access, and can be set using radius_put_int(). The possible attribute values include these constants:

  • RADIUS_PPP
  • RADIUS_SLIP
  • RADIUS_ARAP
  • RADIUS_GANDALF
  • RADIUS_XYLOGICS

RADIUS_FRAMED_IP_ADDRESS (integer)

The Framed-IP-Address attribute. The attribute value is expected to be the address of the user's network encoded as an integer, which can be set using radius_put_addr() and retrieved using radius_cvt_addr().

RADIUS_FRAMED_IP_NETMASK (integer)

The Framed-IP-Netmask attribute. The attribute value is expected to be the netmask of the user's network encoded as an integer, which can be set using radius_put_addr() and retrieved using radius_cvt_addr().

RADIUS_FRAMED_ROUTING (integer)

The Framed-Routing attribute. The attribute value is expected to be an integer indicating the routing method for the user, which can be set using radius_put_int().

Possible values include:

  • 0: No routing
  • 1: Send routing packets
  • 2: Listen for routing packets
  • 3: Send and listen

RADIUS_FILTER_ID (integer)

The Filter-ID attribute. The attribute value is expected to be an implementation-specific, human-readable string of filters, which can be set using radius_put_attr().

RADIUS_FRAMED_MTU (integer)

The Framed-MTU attribute. The attribute value is expected to be an integer indicating the MTU to be configured for the user, and can be set using radius_put_int().

RADIUS_FRAMED_COMPRESSION (integer)

The Framed-Compression attribute. The attribute value is expected to be an integer indicating the compression protocol to be used, and can be set using radius_put_int(). Possible values include these constants:

  • RADIUS_COMP_NONE: No compression
  • RADIUS_COMP_VJ: VJ TCP/IP header compression
  • RADIUS_COMP_IPXHDR: IPX header compression
  • RADIUS_COMP_STAC_LZS: Stac-LZS compression (added in PECL radius 1.3.0b2)

RADIUS_LOGIN_IP_HOST (integer)

The Login-IP-Host attribute. The attribute value is expected to the IP address to connect the user to, encoded as an integer, which can be set using radius_put_addr().

RADIUS_LOGIN_SERVICE (integer)

The Login-Service attribute. The attribute value is an integer indicating the service to connect the user to on the login host. The value can be converted to a PHP integer via radius_cvt_int().

RADIUS_LOGIN_TCP_PORT (integer)

The Login-TCP-Port attribute. The attribute value is an integer indicating the port to connect the user to on the login host. The value can be converted to a PHP integer via radius_cvt_int().

RADIUS_REPLY_MESSAGE (integer)

The Reply-Message attribute. The attribute value is a string containing text that may be displayed to the user in response to an access request.

RADIUS_CALLBACK_NUMBER (integer)

The Callback-Number attribute. The attribute value is a string containing the dialing string to use for callback.

RADIUS_CALLBACK_ID (integer)

The Callback-Id attribute. The attribute value is a string containing an implementation-specific name of the place to be called.

RADIUS_FRAMED_ROUTE (integer)

The Framed-Route attribute. The attribute value is a string containing an implementation-specific set of routes to be configured for the user.

RADIUS_FRAMED_IPX_NETWORK (integer)

The Framed-IPX-Network attribute. The attribute value is an integer containing the IPX network to be configured for the user, or 0xFFFFFFFE to indicate that the RADIUS client should select the network, and can be accessed via radius_cvt_int().

RADIUS_STATE (integer)

The State attribute. The attribute value is an implementation-defined string included in an Access-Challenge from a server that must be included in the subsequent Access-Request, and can be set using radius_put_attr().

RADIUS_CLASS (integer)

The Class attribute. The attribute value is an arbitrary string included in an Access-Accept message that should then be sent to the accounting server in Accounting-Request messages, and can be set using radius_put_attr().

RADIUS_VENDOR_SPECIFIC (integer)

The Vendor-Specific attribute. In general, vendor attribute values
should be set using radius_put_vendor_addr(),
radius_put_vendor_attr(),
radius_put_vendor_int() and
radius_put_vendor_string(), rather than directly.

This constant is mostly useful when interpreting vendor specific attributes in responses from a RADIUS server; when a vendor specific attribute is received, the radius_get_vendor_attr() function should be used to access the vendor ID, attribute type and attribute value.

RADIUS_SESSION_TIMEOUT (integer)

Session timeout

RADIUS_IDLE_TIMEOUT (integer)

Idle timeout

RADIUS_TERMINATION_ACTION (integer)

Termination action

RADIUS_CALLED_STATION_ID (integer)

Called Station Id

RADIUS_CALLING_STATION_ID (integer)

Calling Station Id

RADIUS_NAS_IDENTIFIER (integer)

NAS ID

RADIUS_PROXY_STATE (integer)

Proxy State

RADIUS_LOGIN_LAT_SERVICE (integer)

Login LAT Service

RADIUS_LOGIN_LAT_NODE (integer)

Login LAT Node

RADIUS_LOGIN_LAT_GROUP (integer)

Login LAT Group

RADIUS_FRAMED_APPLETALK_LINK (integer)

Framed Appletalk Link

RADIUS_FRAMED_APPLETALK_NETWORK (integer)

Framed Appletalk Network

RADIUS_FRAMED_APPLETALK_ZONE (integer)

Framed Appletalk Zone

RADIUS_CHAP_CHALLENGE (integer)

Challenge

RADIUS_NAS_PORT_TYPE (integer)

NAS port type, one of:

  • RADIUS_ASYNC
  • RADIUS_SYNC
  • RADIUS_ISDN_SYNC
  • RADIUS_ISDN_ASYNC_V120
  • RADIUS_ISDN_ASYNC_V110
  • RADIUS_VIRTUAL
  • RADIUS_PIAFS
  • RADIUS_HDLC_CLEAR_CHANNEL
  • RADIUS_X_25
  • RADIUS_X_75
  • RADIUS_G_3_FAX
  • RADIUS_SDSL
  • RADIUS_ADSL_CAP
  • RADIUS_ADSL_DMT
  • RADIUS_IDSL
  • RADIUS_ETHERNET
  • RADIUS_XDSL
  • RADIUS_CABLE
  • RADIUS_WIRELESS_OTHER
  • RADIUS_WIRELESS_IEEE_802_11

RADIUS_PORT_LIMIT (integer)

Port Limit

RADIUS_LOGIN_LAT_PORT (integer)

Login LAT Port

RADIUS_CONNECT_INFO (integer)

Connect info

RADIUS_ACCT_STATUS_TYPE (integer)

Accounting status type, one of:

  • RADIUS_START
  • RADIUS_STOP
  • RADIUS_ACCOUNTING_ON
  • RADIUS_ACCOUNTING_OFF

RADIUS_ACCT_DELAY_TIME (integer)

Accounting delay time

RADIUS_ACCT_INPUT_OCTETS (integer)

Accounting input bytes

RADIUS_ACCT_OUTPUT_OCTETS (integer)

Accounting output bytes

RADIUS_ACCT_SESSION_ID (integer)

Accounting session ID

RADIUS_ACCT_AUTHENTIC (integer)

Accounting authentic, one of:

  • RADIUS_AUTH_RADIUS
  • RADIUS_AUTH_LOCAL
  • RADIUS_AUTH_REMOTE

RADIUS_ACCT_SESSION_TIME (integer)

Accounting session time

RADIUS_ACCT_INPUT_PACKETS (integer)

Accounting input packets

RADIUS_ACCT_OUTPUT_PACKETS (integer)

Accounting output packets

RADIUS_ACCT_TERMINATE_CAUSE (integer)

Accounting terminate cause, one of:

  • RADIUS_TERM_USER_REQUEST
  • RADIUS_TERM_LOST_CARRIER
  • RADIUS_TERM_LOST_SERVICE
  • RADIUS_TERM_IDLE_TIMEOUT
  • RADIUS_TERM_SESSION_TIMEOUT
  • RADIUS_TERM_ADMIN_RESET
  • RADIUS_TERM_ADMIN_REBOOT
  • RADIUS_TERM_PORT_ERROR
  • RADIUS_TERM_NAS_ERROR
  • RADIUS_TERM_NAS_REQUEST
  • RADIUS_TERM_NAS_REBOOT
  • RADIUS_TERM_PORT_UNNEEDED
  • RADIUS_TERM_PORT_PREEMPTED
  • RADIUS_TERM_PORT_SUSPENDED
  • RADIUS_TERM_SERVICE_UNAVAILABLE
  • RADIUS_TERM_CALLBACK
  • RADIUS_TERM_USER_ERROR
  • RADIUS_TERM_HOST_REQUEST

RADIUS_ACCT_MULTI_SESSION_ID (integer)

Accounting multi session ID

RADIUS_ACCT_LINK_COUNT (integer)

Accounting link count

RADIUS Packet Types
RADIUS Vendor Specific Attribute Types
Öntanımlı Sabitler


RADIUS Vendor Specific Attribute Types

RADIUS_VENDOR_MICROSOFT (integer)

Microsoft specific vendor attributes (» RFC 2548), one of:

  • RADIUS_MICROSOFT_MS_CHAP_RESPONSE
  • RADIUS_MICROSOFT_MS_CHAP_ERROR
  • RADIUS_MICROSOFT_MS_CHAP_PW_1
  • RADIUS_MICROSOFT_MS_CHAP_PW_2
  • RADIUS_MICROSOFT_MS_CHAP_LM_ENC_PW
  • RADIUS_MICROSOFT_MS_CHAP_NT_ENC_PW
  • RADIUS_MICROSOFT_MS_MPPE_ENCRYPTION_POLICY
  • RADIUS_MICROSOFT_MS_MPPE_ENCRYPTION_TYPES
  • RADIUS_MICROSOFT_MS_RAS_VENDOR
  • RADIUS_MICROSOFT_MS_CHAP_DOMAIN
  • RADIUS_MICROSOFT_MS_CHAP_CHALLENGE
  • RADIUS_MICROSOFT_MS_CHAP_MPPE_KEYS
  • RADIUS_MICROSOFT_MS_BAP_USAGE
  • RADIUS_MICROSOFT_MS_LINK_UTILIZATION_THRESHOLD
  • RADIUS_MICROSOFT_MS_LINK_DROP_TIME_LIMIT
  • RADIUS_MICROSOFT_MS_MPPE_SEND_KEY
  • RADIUS_MICROSOFT_MS_MPPE_RECV_KEY
  • RADIUS_MICROSOFT_MS_RAS_VERSION
  • RADIUS_MICROSOFT_MS_OLD_ARAP_PASSWORD
  • RADIUS_MICROSOFT_MS_NEW_ARAP_PASSWORD
  • RADIUS_MICROSOFT_MS_ARAP_PASSWORD_CHANGE_REASON
  • RADIUS_MICROSOFT_MS_FILTER
  • RADIUS_MICROSOFT_MS_ACCT_AUTH_TYPE
  • RADIUS_MICROSOFT_MS_ACCT_EAP_TYPE
  • RADIUS_MICROSOFT_MS_CHAP2_RESPONSE
  • RADIUS_MICROSOFT_MS_CHAP2_SUCCESS
  • RADIUS_MICROSOFT_MS_CHAP2_PW
  • RADIUS_MICROSOFT_MS_PRIMARY_DNS_SERVER
  • RADIUS_MICROSOFT_MS_SECONDARY_DNS_SERVER
  • RADIUS_MICROSOFT_MS_PRIMARY_NBNS_SERVER
  • RADIUS_MICROSOFT_MS_SECONDARY_NBNS_SERVER
  • RADIUS_MICROSOFT_MS_ARAP_CHALLENGE

RADIUS Attribute Types
Örnekler
Öntanımlı Sabitler


Örnekler

Howto start?

  • get a radius resource
  • configure the library
  • create the request
  • put attributes
  • send the request
  • receive attributes
  • close the radius resource (optional)
Take also a look at the examples in this package.

The package contains an example php script. This script demonstrates howto authenticate with radius using PAP or CHAP (md5). If you authenticate with Microsoft Radius servers then its not possible to use CHAP (md5). If you would like to authenticate with Microsoft Servers you have to use MS-CHAPv1 or MS-CHAPv2, but its more complicated, because you need md4, sha1 and des to generate the right data. The enclosed examples demonstrate all authentication-methods, including MS-CHAPv1 and MS-CHAPv2. To get the MS-CHAP to work you need the mcrypt and the mhash extension, starting with version 1.2 of the package, the mcrypt extension is no longer needed.

RADIUS Vendor Specific Attribute Types
Radius İşlevleri
Radius


Radius İşlevleri

İçindekiler

  • radius_acct_open — Creates a Radius handle for accounting
  • radius_add_server — Adds a server
  • radius_auth_open — Creates a Radius handle for authentication
  • radius_close — Frees all ressources
  • radius_config — Causes the library to read the given configuration file
  • radius_create_request — Create accounting or authentication request
  • radius_cvt_addr — Converts raw data to IP-Address
  • radius_cvt_int — Converts raw data to integer
  • radius_cvt_string — Converts raw data to string
  • radius_demangle_mppe_key — Derives mppe-keys from mangled data
  • radius_demangle — Demangles data
  • radius_get_attr — Extracts an attribute
  • radius_get_tagged_attr_data — Extracts the data from a tagged attribute
  • radius_get_tagged_attr_tag — Extracts the tag from a tagged attribute
  • radius_get_vendor_attr — Extracts a vendor specific attribute
  • radius_put_addr — Attaches an IP address attribute
  • radius_put_attr — Attaches a binary attribute
  • radius_put_int — Attaches an integer attribute
  • radius_put_string — Attaches a string attribute
  • radius_put_vendor_addr — Attaches a vendor specific IP address attribute
  • radius_put_vendor_attr — Attaches a vendor specific binary attribute
  • radius_put_vendor_int — Attaches a vendor specific integer attribute
  • radius_put_vendor_string — Attaches a vendor specific string attribute
  • radius_request_authenticator — Returns the request authenticator
  • radius_salt_encrypt_attr — Salt-encrypts a value
  • radius_send_request — Sends the request and waites for a reply
  • radius_server_secret — Returns the shared secret
  • radius_strerror — Returns an error message
Örnekler
radius_acct_open
Radius


Creates a Radius handle for accounting

Radius İşlevleri
radius_add_server
Radius İşlevleri
PHP Manual

radius_acct_open

(PECL radius >= 1.1.0)

radius_acct_open — Creates a Radius handle for accounting

Açıklama

resource radius_acct_open ( void )

Dönen Değerler

Returns a handle on success, FALSE on error. This function only fails if insufficient memory is available.

Örnekler

Örnek 1 radius_acct_open() example

<?php
$res = radius_acct_open ()
    or die ("Could not create handle");
print("Handle successfully created");
?>

Radius İşlevleri
radius_add_server
Radius İşlevleri


Adds a server

radius_acct_open
radius_auth_open
Radius İşlevleri
PHP Manual

radius_add_server

(PECL radius >= 1.1.0)

radius_add_server — Adds a server

Açıklama

bool radius_add_server ( resource $radius_handle , string $hostname , int $port , string $secret , int $timeout , int $max_tries )

radius_add_server() may be called multiple times, and it may be used together with radius_config(). At most 10 servers may be specified. When multiple servers are given, they are tried in round-robin fashion until a valid response is received, or until each server's max_tries limit has been reached.

Değiştirgeler

radius_handle

hostname

The hostname parameter specifies the server host, either as a fully qualified domain name or as a dotted-quad IP address in text form.

port

The port specifies the UDP port to contact on the server. If port is given as 0, the library looks up the radius/udp or radacct/udp service in the network services database, and uses the port found there. If no entry is found, the library uses the standard Radius ports, 1812 for authentication and 1813 for accounting.

secret

The shared secret for the server host is passed to the secret parameter. The Radius protocol ignores all but the leading 128 bytes of the shared secret.

timeout

The timeout for receiving replies from the server is passed to the timeout parameter, in units of seconds.

max_tries

The maximum number of repeated requests to make before giving up is passed into the max_tries.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 radius_add_server() example

<?php
if (!radius_add_server($res, 'radius.example.com', 1812, 'testing123', 3, 3)) {
    echo 'RadiusError:' . radius_strerror($res). "\n<br>";
    exit;
}
?>

Ayrıca Bakınız

  • radius_config() - Causes the library to read the given configuration file

radius_acct_open
radius_auth_open
Radius İşlevleri


Creates a Radius handle for authentication

radius_add_server
radius_close
Radius İşlevleri
PHP Manual

radius_auth_open

(PECL radius >= 1.1.0)

radius_auth_open — Creates a Radius handle for authentication

Açıklama

resource radius_auth_open ( void )

Dönen Değerler

Returns a handle on success, FALSE on error. This function only fails if insufficient memory is available.

Örnekler

Örnek 1 radius_auth_open() example

<?php
$radh = radius_auth_open()
    or die ("Could not create handle");
echo "Handle successfully created";
?>

radius_add_server
radius_close
Radius İşlevleri


Frees all ressources

radius_auth_open
radius_config
Radius İşlevleri
PHP Manual

radius_close

(PECL radius >= 1.1.0)

radius_close — Frees all ressources

Açıklama

bool radius_close ( resource $radius_handle )

It is not needed to call this function because php frees all resources at the end of each request.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

radius_auth_open
radius_config
Radius İşlevleri


Causes the library to read the given configuration file

radius_close
radius_create_request
Radius İşlevleri
PHP Manual

radius_config

(PECL radius >= 1.1.0)

radius_config — Causes the library to read the given configuration file

Açıklama

bool radius_config ( resource $radius_handle , string $file )

Before issuing any Radius requests, the library must be made aware of the servers it can contact. The easiest way to configure the library is to call radius_config(). radius_config() causes the library to read a configuration file whose format is described in » radius.conf.

Değiştirgeler

radius_handle

file

The pathname of the configuration file is passed as the file argument to radius_config(). The library can also be configured programmatically by calls to radius_add_server().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • radius_add_server() - Adds a server

radius_close
radius_create_request
Radius İşlevleri


Create accounting or authentication request

radius_config
radius_cvt_addr
Radius İşlevleri
PHP Manual

radius_create_request

(PECL radius >= 1.1.0)

radius_create_request — Create accounting or authentication request

Açıklama

bool radius_create_request ( resource $radius_handle , int $type )

A Radius request consists of a code specifying the kind of request, and zero or more attributes which provide additional information. To begin constructing a new request, call radius_create_request().

Bilginize: Attention: You must call this function, before you can put any attribute!

Değiştirgeler

radius_handle

type

Type is RADIUS_ACCESS_REQUEST or RADIUS_ACCOUNTING_REQUEST.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 radius_create_request() example

<?php
if (!radius_create_request($res, RADIUS_ACCESS_REQUEST)) {
    echo 'RadiusError:' . radius_strerror($res). "\n<br />";
    exit;
}
?>

Ayrıca Bakınız

  • radius_send_request() - Sends the request and waites for a reply

radius_config
radius_cvt_addr
Radius İşlevleri


Converts raw data to IP-Address

radius_create_request
radius_cvt_int
Radius İşlevleri
PHP Manual

radius_cvt_addr

(PECL radius >= 1.1.0)

radius_cvt_addr — Converts raw data to IP-Address

Açıklama

string radius_cvt_addr ( string $data )

Örnekler

Örnek 1 radius_cvt_addr() example

<?php
while ($resa = radius_get_attr($res)) {

    if (!is_array($resa)) {
        printf ("Error getting attribute: %s\n",  radius_strerror($res));
        exit;
    }

    $attr = $resa['attr'];
    $data = $resa['data'];

    switch ($attr) {

    case RADIUS_FRAMED_IP_ADDRESS:
        $ip = radius_cvt_addr($data);
        echo "IP: $ip<br>\n";
        break;

    case RADIUS_FRAMED_IP_NETMASK:
        $mask = radius_cvt_addr($data);
        echo "MASK: $mask<br>\n";
        break;
    }
}
?>

Ayrıca Bakınız

  • radius_cvt_int() - Converts raw data to integer
  • radius_cvt_string() - Converts raw data to string

radius_create_request
radius_cvt_int
Radius İşlevleri


Converts raw data to integer

radius_cvt_addr
radius_cvt_string
Radius İşlevleri
PHP Manual

radius_cvt_int

(PECL radius >= 1.1.0)

radius_cvt_int — Converts raw data to integer

Açıklama

int radius_cvt_int ( string $data )

Örnekler

Örnek 1 radius_cvt_int() example

<?php
while ($resa = radius_get_attr($res)) {

    if (!is_array($resa)) {
        printf ("Error getting attribute: %s\n",  radius_strerror($res));
        exit;
    }

    $attr = $resa['attr'];
    $data = $resa['data'];

    switch ($attr) {

    case RADIUS_FRAMED_MTU:
        $mtu = radius_cvt_int($data);
        echo "MTU: $mtu<br>\n";
        break;
    }
}
?>

Ayrıca Bakınız

  • radius_cvt_addr() - Converts raw data to IP-Address
  • radius_cvt_string() - Converts raw data to string

radius_cvt_addr
radius_cvt_string
Radius İşlevleri


Converts raw data to string

radius_cvt_int
radius_demangle_mppe_key
Radius İşlevleri
PHP Manual

radius_cvt_string

(PECL radius >= 1.1.0)

radius_cvt_string — Converts raw data to string

Açıklama

string radius_cvt_string ( string $data )

Örnekler

Örnek 1 radius_cvt_string() example

<?php
while ($resa = radius_get_attr($res)) {

    if (!is_array($resa)) {
        printf ("Error getting attribute: %s\n",  radius_strerror($res));
        exit;
    }

    $attr = $resa['attr'];
    $data = $resa['data'];

    switch ($attr) {

    case RADIUS_FILTER_ID:
        $id = radius_cvt_string($data);
        echo "Filter ID: $id<br>\n";
        break;
    }
}
?>

Ayrıca Bakınız

  • radius_cvt_addr() - Converts raw data to IP-Address
  • radius_cvt_int() - Converts raw data to integer

radius_cvt_int
radius_demangle_mppe_key
Radius İşlevleri


Derives mppe-keys from mangled data

radius_cvt_string
radius_demangle
Radius İşlevleri
PHP Manual

radius_demangle_mppe_key

(PECL radius >= 1.2.0)

radius_demangle_mppe_key — Derives mppe-keys from mangled data

Açıklama

string radius_demangle_mppe_key ( resource $radius_handle , string $mangled )

When using MPPE with MS-CHAPv2, the send- and recv-keys are mangled (see » RFC 2548), however this function is useless, because I don't think that there is or will be a PPTP-MPPE implementation in PHP.

Dönen Değerler

Returns the demangled string, or FALSE on error.

radius_cvt_string
radius_demangle
Radius İşlevleri


Demangles data

radius_demangle_mppe_key
radius_get_attr
Radius İşlevleri
PHP Manual

radius_demangle

(PECL radius >= 1.2.0)

radius_demangle — Demangles data

Açıklama

string radius_demangle ( resource $radius_handle , string $mangled )

Some data (Passwords, MS-CHAPv1 MPPE-Keys) is mangled for security reasons, and must be demangled before you can use them.

Dönen Değerler

Returns the demangled string, or FALSE on error.

radius_demangle_mppe_key
radius_get_attr
Radius İşlevleri


Extracts an attribute

radius_demangle
radius_get_tagged_attr_data
Radius İşlevleri
PHP Manual

radius_get_attr

(PECL radius >= 1.1.0)

radius_get_attr — Extracts an attribute

Açıklama

mixed radius_get_attr ( resource $radius_handle )

Like Radius requests, each response may contain zero or more attributes. After a response has been received successfully by radius_send_request(), its attributes can be extracted one by one using radius_get_attr(). Each time radius_get_attr() is called, it gets the next attribute from the current response.

Dönen Değerler

Returns an associative array containing the attribute-type and the data, or error number <= 0.

Örnekler

Örnek 1 radius_get_attr() example

<?php
while ($resa = radius_get_attr($res)) {

    if (!is_array($resa)) {
        printf("Error getting attribute: %s\n",  radius_strerror($res));
        exit;
    }

    $attr = $resa['attr'];
    $data = $resa['data'];
    printf("Got Attr:%d %d Bytes %s\n", $attr, strlen($data), bin2hex($data));
}
?>

Ayrıca Bakınız

  • radius_put_attr() - Attaches a binary attribute
  • radius_get_vendor_attr() - Extracts a vendor specific attribute
  • radius_put_vendor_attr() - Attaches a vendor specific binary attribute
  • radius_send_request() - Sends the request and waites for a reply

radius_demangle
radius_get_tagged_attr_data
Radius İşlevleri


Extracts the data from a tagged attribute

radius_get_attr
radius_get_tagged_attr_tag
Radius İşlevleri
PHP Manual

radius_get_tagged_attr_data

(PECL radius >= 1.3.0)

radius_get_tagged_attr_data — Extracts the data from a tagged attribute

Açıklama

string radius_get_tagged_attr_data ( string $data )

If a tagged attribute has been returned from radius_get_attr(), radius_get_tagged_attr_data() will return the data from the attribute.

Değiştirgeler

data

The tagged attribute to be decoded.

Dönen Değerler

Returns the data from the tagged attribute başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 radius_get_tagged_attr_data() example

<?php
while ($resa = radius_get_attr($res)) {
    if (!is_array($resa)) {
        printf ("Error getting attribute: %s\n",  radius_strerror($res));
        exit;
    }

    $attr = $resa['attr'];
    $data = $resa['data'];

    $tag = radius_get_tagged_attr_tag($data);
    $value = radius_get_tagged_attr_data($data);

    printf("Got tagged attribute with tag %d and value %s\n", $tag, $value);
}
?>

Ayrıca Bakınız

  • radius_get_attr() - Extracts an attribute
  • radius_get_tagged_attr_tag() - Extracts the tag from a tagged attribute

radius_get_attr
radius_get_tagged_attr_tag
Radius İşlevleri


Extracts the tag from a tagged attribute

radius_get_tagged_attr_data
radius_get_vendor_attr
Radius İşlevleri
PHP Manual

radius_get_tagged_attr_tag

(PECL radius >= 1.3.0)

radius_get_tagged_attr_tag — Extracts the tag from a tagged attribute

Açıklama

integer radius_get_tagged_attr_tag ( string $data )

If a tagged attribute has been returned from radius_get_attr(), radius_get_tagged_attr_data() will return the tag from the attribute.

Değiştirgeler

data

The tagged attribute to be decoded.

Dönen Değerler

Returns the tag from the tagged attribute başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 radius_get_tagged_attr_tag() example

<?php
while ($resa = radius_get_attr($res)) {
    if (!is_array($resa)) {
        printf ("Error getting attribute: %s\n",  radius_strerror($res));
        exit;
    }

    $attr = $resa['attr'];
    $data = $resa['data'];

    $tag = radius_get_tagged_attr_tag($data);
    $value = radius_get_tagged_attr_data($data);

    printf("Got tagged attribute with tag %d and value %s\n", $tag, $value);
}
?>

Ayrıca Bakınız

  • radius_get_attr() - Extracts an attribute
  • radius_get_tagged_attr_data() - Extracts the data from a tagged attribute

radius_get_tagged_attr_data
radius_get_vendor_attr
Radius İşlevleri


Extracts a vendor specific attribute

radius_get_tagged_attr_tag
radius_put_addr
Radius İşlevleri
PHP Manual

radius_get_vendor_attr

(PECL radius >= 1.1.0)

radius_get_vendor_attr — Extracts a vendor specific attribute

Açıklama

array radius_get_vendor_attr ( string $data )

If radius_get_attr() returns RADIUS_VENDOR_SPECIFIC, radius_get_vendor_attr() may be called to determine the vendor.

Dönen Değerler

Returns an associative array containing the attribute-type, vendor and the data, or FALSE on error.

Örnekler

Örnek 1 radius_get_vendor_attr() example

<?php
while ($resa = radius_get_attr($res)) {

    if (!is_array($resa)) {
        printf ("Error getting attribute: %s\n",  radius_strerror($res));
        exit;
    }

    $attr = $resa['attr'];
    $data = $resa['data'];
    printf("Got Attr:%d %d Bytes %s\n", $attr, strlen($data), bin2hex($data));
    if ($attr == RADIUS_VENDOR_SPECIFIC) {

        $resv = radius_get_vendor_attr($data);
        if (is_array($resv)) {
            $vendor = $resv['vendor'];
            $attrv = $resv['attr'];
            $datav = $resv['data'];
            printf("Got Vendor Attr:%d %d Bytes %s\n", $attrv, strlen($datav), bin2hex($datav));
        }

    }
}
?>

Ayrıca Bakınız

  • radius_get_attr() - Extracts an attribute
  • radius_put_vendor_attr() - Attaches a vendor specific binary attribute

radius_get_tagged_attr_tag
radius_put_addr
Radius İşlevleri


Attaches an IP address attribute

radius_get_vendor_attr
radius_put_attr
Radius İşlevleri
PHP Manual

radius_put_addr

(PECL radius >= 1.1.0)

radius_put_addr — Attaches an IP address attribute

Açıklama

bool radius_put_addr ( resource $radius_handle , int $type , string $addr [, int $options = 0 [, int $tag ]] )

Attaches an IP address attribute to the current RADIUS request.

Bilginize:

A request must be created via radius_create_request() before this function can be called.

Değiştirgeler

radius_handle

The RADIUS resource.

type

The attribute type.

addr

An IPv4 address in string form, such as 10.0.0.1.

options

A bitmask of the attribute options. The available options include RADIUS_OPTION_TAGGED and RADIUS_OPTION_SALT.

tag

The attribute tag. This parameter is ignored unless the RADIUS_OPTION_TAGGED option is set.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
PECL radius 1.3.0 | The options and tag parameters were added.

radius_get_vendor_attr
radius_put_attr
Radius İşlevleri


Attaches a binary attribute

radius_put_addr
radius_put_int
Radius İşlevleri
PHP Manual

radius_put_attr

(PECL radius >= 1.1.0)

radius_put_attr — Attaches a binary attribute

Açıklama

bool radius_put_attr ( resource $radius_handle , int $type , string $value [, int $options = 0 [, int $tag ]] )

Attaches a binary attribute to the current RADIUS request.

Bilginize:

A request must be created via radius_create_request() before this function can be called.

Değiştirgeler

radius_handle

The RADIUS resource.

type

The attribute type.

value

The attribute value, which will be treated as a raw binary string.

options

A bitmask of the attribute options. The available options include RADIUS_OPTION_TAGGED and RADIUS_OPTION_SALT.

tag

The attribute tag. This parameter is ignored unless the RADIUS_OPTION_TAGGED option is set.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 radius_put_attr() example

<?php
mt_srand(time());
$chall = mt_rand();
$chapval = md5(pack('Ca*',1 , 'sepp' . $chall));
$pass = pack('CH*', 1, $chapval);
if (!radius_put_attr($res, RADIUS_CHAP_PASSWORD, $pass)) {
    echo 'RadiusError:' . radius_strerror($res). "\n<br />";
    exit;
}
?>

Sürüm Bilgisi

Sürüm: | Açıklama
PECL radius 1.3.0 | The options and tag parameters were added.

Ayrıca Bakınız

  • radius_get_attr() - Extracts an attribute
  • radius_get_vendor_attr() - Extracts a vendor specific attribute
  • radius_put_vendor_attr() - Attaches a vendor specific binary attribute

radius_put_addr
radius_put_int
Radius İşlevleri


Attaches an integer attribute

radius_put_attr
radius_put_string
Radius İşlevleri
PHP Manual

radius_put_int

(PECL radius >= 1.1.0)

radius_put_int — Attaches an integer attribute

Açıklama

bool radius_put_int ( resource $radius_handle , int $type , int $value [, int $options = 0 [, int $tag ]] )

Attaches an integer attribute to the current RADIUS request.

Bilginize:

A request must be created via radius_create_request() before this function can be called.

Değiştirgeler

radius_handle

The RADIUS resource.

type

The attribute type.

value

The attribute value.

options

A bitmask of the attribute options. The available options include RADIUS_OPTION_TAGGED and RADIUS_OPTION_SALT.

tag

The attribute tag. This parameter is ignored unless the RADIUS_OPTION_TAGGED option is set.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
PECL radius 1.3.0 | The options and tag parameters were added.

Örnekler

Örnek 1 radius_put_int() example

<?php
if (!radius_put_int($res, RAD_FRAMED_PROTOCOL, RAD_PPP)) {
   echo 'RadiusError:' . radius_strerror($res). "\n<br />";
   exit;
}
?>

Ayrıca Bakınız

  • radius_put_string() - Attaches a string attribute
  • radius_put_vendor_int() - Attaches a vendor specific integer attribute
  • radius_put_vendor_string() - Attaches a vendor specific string attribute

radius_put_attr
radius_put_string
Radius İşlevleri


Attaches a string attribute

radius_put_int
radius_put_vendor_addr
Radius İşlevleri
PHP Manual

radius_put_string

(PECL radius >= 1.1.0)

radius_put_string — Attaches a string attribute

Açıklama

bool radius_put_string ( resource $radius_handle , int $type , string $value [, int $options = 0 [, int $tag ]] )

Attaches a string attribute to the current RADIUS request. In general, radius_put_attr() is a more useful function for attaching string attributes, as it is binary safe.

Bilginize:

A request must be created via radius_create_request() before this function can be called.

Değiştirgeler

radius_handle

The RADIUS resource.

type

The attribute type.

value

The attribute value. This value is expected by the underlying library to be null terminated, therefore this parameter is not binary safe.

options

A bitmask of the attribute options. The available options include RADIUS_OPTION_TAGGED and RADIUS_OPTION_SALT.

tag

The attribute tag. This parameter is ignored unless the RADIUS_OPTION_TAGGED option is set.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
PECL radius 1.3.0 | The options and tag parameters were added.

Örnekler

Örnek 1 radius_put_string() example

<?php
if (!radius_put_string($res, RADIUS_USER_NAME, 'billy')) {
    echo 'RadiusError:' . radius_strerror($res). "\n<br />";
    exit;
}
?>

Ayrıca Bakınız

  • radius_put_int() - Attaches an integer attribute
  • radius_put_vendor_int() - Attaches a vendor specific integer attribute
  • radius_put_vendor_string() - Attaches a vendor specific string attribute

radius_put_int
radius_put_vendor_addr
Radius İşlevleri


Attaches a vendor specific IP address attribute

radius_put_string
radius_put_vendor_attr
Radius İşlevleri
PHP Manual

radius_put_vendor_addr

(PECL radius >= 1.1.0)

radius_put_vendor_addr — Attaches a vendor specific IP address attribute

Açıklama

bool radius_put_vendor_addr ( resource $radius_handle , int $vendor , int $type , string $addr )

Attaches an IP address vendor specific attribute to the current RADIUS request.

Bilginize:

A request must be created via radius_create_request() before this function can be called.

Değiştirgeler

radius_handle

The RADIUS resource.

vendor

The vendor ID.

type

The attribute type.

addr

An IPv4 address in string form, such as 10.0.0.1.

options

A bitmask of the attribute options. The available options include RADIUS_OPTION_TAGGED and RADIUS_OPTION_SALT.

tag

The attribute tag. This parameter is ignored unless the RADIUS_OPTION_TAGGED option is set.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
PECL radius 1.3.0 | The options and tag parameters were added.

radius_put_string
radius_put_vendor_attr
Radius İşlevleri


Attaches a vendor specific binary attribute

radius_put_vendor_addr
radius_put_vendor_int
Radius İşlevleri
PHP Manual

radius_put_vendor_attr

(PECL radius >= 1.1.0)

radius_put_vendor_attr — Attaches a vendor specific binary attribute

Açıklama

bool radius_put_vendor_attr ( resource $radius_handle , int $vendor , int $type , string $value [, int $options = 0 [, int $tag ]] )

Attaches a vendor specific binary attribute to the current RADIUS request.

Bilginize:

A request must be created via radius_create_request() before this function can be called.

Değiştirgeler

radius_handle

The RADIUS resource.

vendor

The vendor ID.

type

The attribute type.

value

The attribute value, which will be treated as a raw binary string.

options

A bitmask of the attribute options. The available options include RADIUS_OPTION_TAGGED and RADIUS_OPTION_SALT.

tag

The attribute tag. This parameter is ignored unless the RADIUS_OPTION_TAGGED option is set.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
PECL radius 1.3.0 | The options and tag parameters were added.

Örnekler

Örnek 1 radius_put_vendor_attr() example

<?php
if (!radius_put_vendor_attr($res, RADIUS_VENDOR_MICROSOFT, RAD_MICROSOFT_MS_CHAP_CHALLENGE, $challenge)) {
    echo 'RadiusError:' . radius_strerror($res). "\n<br />";
    exit;
}
?>

Ayrıca Bakınız

  • radius_get_vendor_attr() - Extracts a vendor specific attribute

radius_put_vendor_addr
radius_put_vendor_int
Radius İşlevleri


Attaches a vendor specific integer attribute

radius_put_vendor_attr
radius_put_vendor_string
Radius İşlevleri
PHP Manual

radius_put_vendor_int

(PECL radius >= 1.1.0)

radius_put_vendor_int — Attaches a vendor specific integer attribute

Açıklama

bool radius_put_vendor_int ( resource $radius_handle , int $vendor , int $type , int $value [, int $options = 0 [, int $tag ]] )

Attaches a vendor specific integer attribute to the current RADIUS request.

Bilginize:

A request must be created via radius_create_request() before this function can be called.

Değiştirgeler

radius_handle

The RADIUS resource.

vendor

The vendor ID.

type

The attribute type.

value

The attribute value.

options

A bitmask of the attribute options. The available options include RADIUS_OPTION_TAGGED and RADIUS_OPTION_SALT.

tag

The attribute tag. This parameter is ignored unless the RADIUS_OPTION_TAGGED option is set.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
PECL radius 1.3.0 | The options and tag parameters were added.

Ayrıca Bakınız

  • radius_put_vendor_string() - Attaches a vendor specific string attribute

radius_put_vendor_attr
radius_put_vendor_string
Radius İşlevleri


Attaches a vendor specific string attribute

radius_put_vendor_int
radius_request_authenticator
Radius İşlevleri
PHP Manual

radius_put_vendor_string

(PECL radius >= 1.1.0)

radius_put_vendor_string — Attaches a vendor specific string attribute

Açıklama

bool radius_put_vendor_string ( resource $radius_handle , int $vendor , int $type , string $value [, int $options = 0 [, int $tag ]] )

Attaches a vendor specific string attribute to the current RADIUS request. In general, radius_put_vendor_attr() is a more useful function for attaching string attributes, as it is binary safe.

Bilginize:

A request must be created via radius_create_request() before this function can be called.

Değiştirgeler

radius_handle

The RADIUS resource.

vendor

The vendor ID.

type

The attribute type.

value

The attribute value. This value is expected by the underlying library to be null terminated, therefore this parameter is not binary safe.

options

A bitmask of the attribute options. The available options include RADIUS_OPTION_TAGGED and RADIUS_OPTION_SALT.

tag

The attribute tag. This parameter is ignored unless the RADIUS_OPTION_TAGGED option is set.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
PECL radius 1.3.0 | The options and tag parameters were added.

Ayrıca Bakınız

  • radius_put_vendor_int() - Attaches a vendor specific integer attribute

radius_put_vendor_int
radius_request_authenticator
Radius İşlevleri


Returns the request authenticator

radius_put_vendor_string
radius_salt_encrypt_attr
Radius İşlevleri
PHP Manual

radius_request_authenticator

(PECL radius >= 1.1.0)

radius_request_authenticator — Returns the request authenticator

Açıklama

string radius_request_authenticator ( resource $radius_handle )

The request authenticator is needed for demangling mangled data like passwords and encryption-keys.

Dönen Değerler

Returns the request authenticator as string, or FALSE on error.

Ayrıca Bakınız

  • radius_demangle() - Demangles data

radius_put_vendor_string
radius_salt_encrypt_attr
Radius İşlevleri


Salt-encrypts a value

radius_request_authenticator
radius_send_request
Radius İşlevleri
PHP Manual

radius_salt_encrypt_attr

(PECL radius >= 1.3.0)

radius_salt_encrypt_attr — Salt-encrypts a value

Açıklama

string radius_salt_encrypt_attr ( resource $radius_handle , string $data )

Applies the RADIUS salt-encryption algorithm to the given value.

In general, this is achieved automatically by providing the RADIUS_OPTION_SALT option to an attribute setter function, but this function can be used if low-level request construction is required.

Değiştirgeler

data

The data to be salt-encrypted.

Dönen Değerler

Returns the salt-encrypted data başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • radius_put_addr() - Attaches an IP address attribute
  • radius_put_attr() - Attaches a binary attribute
  • radius_put_int() - Attaches an integer attribute
  • radius_put_string() - Attaches a string attribute

radius_request_authenticator
radius_send_request
Radius İşlevleri


Sends the request and waites for a reply

radius_salt_encrypt_attr
radius_server_secret
Radius İşlevleri
PHP Manual

radius_send_request

(PECL radius >= 1.1.0)

radius_send_request — Sends the request and waites for a reply

Açıklama

int radius_send_request ( resource $radius_handle )

After the Radius request has been constructed, it is sent by radius_send_request().

The radius_send_request() function sends the request and waits for a valid reply, retrying the defined servers in round-robin fashion as necessary.

Dönen Değerler

If a valid response is received, radius_send_request() returns the Radius code which specifies the type of the response. This will typically be RADIUS_ACCESS_ACCEPT, RADIUS_ACCESS_REJECT, or RADIUS_ACCESS_CHALLENGE. If no valid response is received, radius_send_request() returns FALSE.

Ayrıca Bakınız

  • radius_create_request() - Create accounting or authentication request

radius_salt_encrypt_attr
radius_server_secret
Radius İşlevleri


Returns the shared secret

radius_send_request
radius_strerror
Radius İşlevleri
PHP Manual

radius_server_secret

(PECL radius >= 1.1.0)

radius_server_secret — Returns the shared secret

Açıklama

string radius_server_secret ( resource $radius_handle )

The shared secret is needed as salt for demangling mangled data like passwords and encryption-keys.

Dönen Değerler

Returns the server's shared secret as string, or FALSE on error.

radius_send_request
radius_strerror
Radius İşlevleri


Returns an error message

radius_server_secret
Komut Satırına Özgü Eklentiler
Radius İşlevleri
PHP Manual

radius_strerror

(PECL radius >= 1.1.0)

radius_strerror — Returns an error message

Açıklama

string radius_strerror ( resource $radius_handle )

If Radius-functions fail then they record an error message. This error message can be retrieved with this function.

Dönen Değerler

Returns error messages as string from failed radius functions.

radius_server_secret
Komut Satırına Özgü Eklentiler
Radius İşlevleri


Komut Satırına Özgü Eklentiler

  • Ncurses — Ncurses Terminal Screen Control
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Ncurses İşlevleri
  • Newt
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • Newt İşlevleri
  • Readline — GNU Readline
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Readline İşlevleri
radius_strerror
Ncurses
İşlev Başvuru Kılavuzu


Ncurses Terminal Screen Control

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
    • Error codes
    • Colors
    • Keys
    • Mouse
  • Ncurses İşlevleri
    • ncurses_addch — Add character at current position and advance cursor
    • ncurses_addchnstr — Add attributed string with specified length at current position
    • ncurses_addchstr — Add attributed string at current position
    • ncurses_addnstr — Add string with specified length at current position
    • ncurses_addstr — Output text at current position
    • ncurses_assume_default_colors — Define default colors for color 0
    • ncurses_attroff — Turn off the given attributes
    • ncurses_attron — Turn on the given attributes
    • ncurses_attrset — Set given attributes
    • ncurses_baudrate — Returns baudrate of terminal
    • ncurses_beep — Let the terminal beep
    • ncurses_bkgd — Set background property for terminal screen
    • ncurses_bkgdset — Control screen background
    • ncurses_border — Draw a border around the screen using attributed characters
    • ncurses_bottom_panel — Moves a visible panel to the bottom of the stack
    • ncurses_can_change_color — Checks if terminal color definitions can be changed
    • ncurses_cbreak — Switch off input buffering
    • ncurses_clear — Clear screen
    • ncurses_clrtobot — Clear screen from current position to bottom
    • ncurses_clrtoeol — Clear screen from current position to end of line
    • ncurses_color_content — Retrieves RGB components of a color
    • ncurses_color_set — Set active foreground and background colors
    • ncurses_curs_set — Set cursor state
    • ncurses_def_prog_mode — Saves terminals (program) mode
    • ncurses_def_shell_mode — Saves terminals (shell) mode
    • ncurses_define_key — Define a keycode
    • ncurses_del_panel — Remove panel from the stack and delete it (but not the associated window)
    • ncurses_delay_output — Delay output on terminal using padding characters
    • ncurses_delch — Delete character at current position, move rest of line left
    • ncurses_deleteln — Delete line at current position, move rest of screen up
    • ncurses_delwin — Delete a ncurses window
    • ncurses_doupdate — Write all prepared refreshes to terminal
    • ncurses_echo — Activate keyboard input echo
    • ncurses_echochar — Single character output including refresh
    • ncurses_end — Stop using ncurses, clean up the screen
    • ncurses_erase — Erase terminal screen
    • ncurses_erasechar — Returns current erase character
    • ncurses_filter — Set LINES for iniscr() and newterm() to 1
    • ncurses_flash — Flash terminal screen (visual bell)
    • ncurses_flushinp — Flush keyboard input buffer
    • ncurses_getch — Read a character from keyboard
    • ncurses_getmaxyx — Returns the size of a window
    • ncurses_getmouse — Reads mouse event
    • ncurses_getyx — Returns the current cursor position for a window
    • ncurses_halfdelay — Put terminal into halfdelay mode
    • ncurses_has_colors — Checks if terminal has color capabilities
    • ncurses_has_ic — Check for insert- and delete-capabilities
    • ncurses_has_il — Check for line insert- and delete-capabilities
    • ncurses_has_key — Check for presence of a function key on terminal keyboard
    • ncurses_hide_panel — Remove panel from the stack, making it invisible
    • ncurses_hline — Draw a horizontal line at current position using an attributed character and max. n characters long
    • ncurses_inch — Get character and attribute at current position
    • ncurses_init_color — Define a terminal color
    • ncurses_init_pair — Define a color pair
    • ncurses_init — Initialize ncurses
    • ncurses_insch — Insert character moving rest of line including character at current position
    • ncurses_insdelln — Insert lines before current line scrolling down (negative numbers delete and scroll up)
    • ncurses_insertln — Insert a line, move rest of screen down
    • ncurses_insstr — Insert string at current position, moving rest of line right
    • ncurses_instr — Reads string from terminal screen
    • ncurses_isendwin — Ncurses is in endwin mode, normal screen output may be performed
    • ncurses_keyok — Enable or disable a keycode
    • ncurses_keypad — Turns keypad on or off
    • ncurses_killchar — Returns current line kill character
    • ncurses_longname — Returns terminals description
    • ncurses_meta — Enables/Disable 8-bit meta key information
    • ncurses_mouse_trafo — Transforms coordinates
    • ncurses_mouseinterval — Set timeout for mouse button clicks
    • ncurses_mousemask — Sets mouse options
    • ncurses_move_panel — Moves a panel so that its upper-left corner is at [startx, starty]
    • ncurses_move — Move output position
    • ncurses_mvaddch — Move current position and add character
    • ncurses_mvaddchnstr — Move position and add attributed string with specified length
    • ncurses_mvaddchstr — Move position and add attributed string
    • ncurses_mvaddnstr — Move position and add string with specified length
    • ncurses_mvaddstr — Move position and add string
    • ncurses_mvcur — Move cursor immediately
    • ncurses_mvdelch — Move position and delete character, shift rest of line left
    • ncurses_mvgetch — Move position and get character at new position
    • ncurses_mvhline — Set new position and draw a horizontal line using an attributed character and max. n characters long
    • ncurses_mvinch — Move position and get attributed character at new position
    • ncurses_mvvline — Set new position and draw a vertical line using an attributed character and max. n characters long
    • ncurses_mvwaddstr — Add string at new position in window
    • ncurses_napms — Sleep
    • ncurses_new_panel — Create a new panel and associate it with window
    • ncurses_newpad — Creates a new pad (window)
    • ncurses_newwin — Create a new window
    • ncurses_nl — Translate newline and carriage return / line feed
    • ncurses_nocbreak — Switch terminal to cooked mode
    • ncurses_noecho — Switch off keyboard input echo
    • ncurses_nonl — Do not translate newline and carriage return / line feed
    • ncurses_noqiflush — Do not flush on signal characters
    • ncurses_noraw — Switch terminal out of raw mode
    • ncurses_pair_content — Retrieves foreground and background colors of a color pair
    • ncurses_panel_above — Returns the panel above panel
    • ncurses_panel_below — Returns the panel below panel
    • ncurses_panel_window — Returns the window associated with panel
    • ncurses_pnoutrefresh — Copies a region from a pad into the virtual screen
    • ncurses_prefresh — Copies a region from a pad into the virtual screen
    • ncurses_putp — Apply padding information to the string and output it
    • ncurses_qiflush — Flush on signal characters
    • ncurses_raw — Switch terminal into raw mode
    • ncurses_refresh — Refresh screen
    • ncurses_replace_panel — Replaces the window associated with panel
    • ncurses_reset_prog_mode — Resets the prog mode saved by def_prog_mode
    • ncurses_reset_shell_mode — Resets the shell mode saved by def_shell_mode
    • ncurses_resetty — Restores saved terminal state
    • ncurses_savetty — Saves terminal state
    • ncurses_scr_dump — Dump screen content to file
    • ncurses_scr_init — Initialize screen from file dump
    • ncurses_scr_restore — Restore screen from file dump
    • ncurses_scr_set — Inherit screen from file dump
    • ncurses_scrl — Scroll window content up or down without changing current position
    • ncurses_show_panel — Places an invisible panel on top of the stack, making it visible
    • ncurses_slk_attr — Returns current soft label key attribute
    • ncurses_slk_attroff — Turn off the given attributes for soft function-key labels
    • ncurses_slk_attron — Turn on the given attributes for soft function-key labels
    • ncurses_slk_attrset — Set given attributes for soft function-key labels
    • ncurses_slk_clear — Clears soft labels from screen
    • ncurses_slk_color — Sets color for soft label keys
    • ncurses_slk_init — Initializes soft label key functions
    • ncurses_slk_noutrefresh — Copies soft label keys to virtual screen
    • ncurses_slk_refresh — Copies soft label keys to screen
    • ncurses_slk_restore — Restores soft label keys
    • ncurses_slk_set — Sets function key labels
    • ncurses_slk_touch — Forces output when ncurses_slk_noutrefresh is performed
    • ncurses_standend — Stop using 'standout' attribute
    • ncurses_standout — Start using 'standout' attribute
    • ncurses_start_color — Initializes color functionality
    • ncurses_termattrs — Returns a logical OR of all attribute flags supported by terminal
    • ncurses_termname — Returns terminals (short)-name
    • ncurses_timeout — Set timeout for special key sequences
    • ncurses_top_panel — Moves a visible panel to the top of the stack
    • ncurses_typeahead — Specify different filedescriptor for typeahead checking
    • ncurses_ungetch — Put a character back into the input stream
    • ncurses_ungetmouse — Pushes mouse event to queue
    • ncurses_update_panels — Refreshes the virtual screen to reflect the relations between panels in the stack
    • ncurses_use_default_colors — Assign terminal default colors to color id -1
    • ncurses_use_env — Control use of environment information about terminal size
    • ncurses_use_extended_names — Control use of extended names in terminfo descriptions
    • ncurses_vidattr — Display the string on the terminal in the video attribute mode
    • ncurses_vline — Draw a vertical line at current position using an attributed character and max. n characters long
    • ncurses_waddch — Adds character at current position in a window and advance cursor
    • ncurses_waddstr — Outputs text at current postion in window
    • ncurses_wattroff — Turns off attributes for a window
    • ncurses_wattron — Turns on attributes for a window
    • ncurses_wattrset — Set the attributes for a window
    • ncurses_wborder — Draws a border around the window using attributed characters
    • ncurses_wclear — Clears window
    • ncurses_wcolor_set — Sets windows color pairings
    • ncurses_werase — Erase window contents
    • ncurses_wgetch — Reads a character from keyboard (window)
    • ncurses_whline — Draws a horizontal line in a window at current position using an attributed character and max. n characters long
    • ncurses_wmouse_trafo — Transforms window/stdscr coordinates
    • ncurses_wmove — Moves windows output position
    • ncurses_wnoutrefresh — Copies window to virtual screen
    • ncurses_wrefresh — Refresh window on terminal screen
    • ncurses_wstandend — End standout mode for a window
    • ncurses_wstandout — Enter standout mode for a window
    • ncurses_wvline — Draws a vertical line in a window at current position using an attributed character and max. n characters long
Komut Satırına Özgü Eklentiler
Giriş
Komut Satırına Özgü Eklentiler


Giriş

ncurses (new curses) is a free software emulation of curses in System V Rel 4.0 (and above). It uses terminfo format, supports pads, colors, multiple highlights, form characters and function key mapping. Because of the interactive nature of this library, it will be of little use for writing Web applications, but may be useful when writing scripts meant using PHP from the command line.

The features available, such as colors, depend on the terminal that you are using. Use functions such as ncurses_has_colors(), ncurses_can_change_color(), and ncurses_has_ic() to check for individual capabilities.

Bilginize:

Bu eklenti » PECL deposuna taşınmış olup şu sürümden itibaren PHP kaynak paketinde dağıtılmamaktatır: PHP 5.3.0.

ncurses is available for the following platforms:

  • AIX
  • BeOS
  • BSD variants (FreeBSD, NetBSD, OpenBSD)
  • Cygwin
  • Digital Unix (aka OSF1)
  • GNU/Linux
  • HPUX
  • IRIX64
  • Mac OS X
  • OS/2
  • QNX
  • SCO OpenServer
  • Solaris
  • Tru64

Ncurses
Yapılandırma/Kurulum
Ncurses


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Ncurses


Gereksinimler

You need the ncurses libraries and headerfiles. Download the latest version from the » ftp://ftp.gnu.org/pub/gnu/ncurses/ or from an other GNU-Mirror.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/ncurses.

Wide character CRT screen handling (ncursesw) support was added in version 1.0.1 of this PECL extension.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Özkaynak Türleri

This extension defines window, panel and pad resources.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

İçindekiler

  • Error codes
  • Colors
  • Keys
  • Mouse

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

Özkaynak Türleri
Error codes
Ncurses


Error codes

On error ncurses functions return -1. Some functions return 0 on success. See the relevant pages in the documentation for actual return values.

Öntanımlı Sabitler
Colors
Öntanımlı Sabitler


Colors

ncurses color constants
constant | meaning
NCURSES_COLOR_BLACK | no color (black)
NCURSES_COLOR_WHITE | white
NCURSES_COLOR_RED | red - supported when terminal is in color mode
NCURSES_COLOR_GREEN | green - supported when terminal is in color mode
NCURSES_COLOR_YELLOW | yellow - supported when terminal is in color mode
NCURSES_COLOR_BLUE | blue - supported when terminal is in color mode
NCURSES_COLOR_CYAN | cyan - supported when terminal is in color mode
NCURSES_COLOR_MAGENTA | magenta - supported when terminal is in color mode
Error codes
Keys
Öntanımlı Sabitler


Keys

ncurses key constants
constant | meaning
NCURSES_KEY_F0 - NCURSES_KEY_F64 | function keys F1 - F64
NCURSES_KEY_DOWN | down arrow
NCURSES_KEY_UP | up arrow
NCURSES_KEY_LEFT | left arrow
NCURSES_KEY_RIGHT | right arrow
NCURSES_KEY_HOME | home key (upward+left arrow)
NCURSES_KEY_BACKSPACE | backspace
NCURSES_KEY_DL | delete line
NCURSES_KEY_IL | insert line
NCURSES_KEY_DC | delete character
NCURSES_KEY_IC | insert char or enter insert mode
NCURSES_KEY_EIC | exit insert char mode
NCURSES_KEY_CLEAR | clear screen
NCURSES_KEY_EOS | clear to end of screen
NCURSES_KEY_EOL | clear to end of line
NCURSES_KEY_SF | scroll one line forward
NCURSES_KEY_SR | scroll one line backward
NCURSES_KEY_NPAGE | next page
NCURSES_KEY_PPAGE | previous page
NCURSES_KEY_STAB | set tab
NCURSES_KEY_CTAB | clear tab
NCURSES_KEY_CATAB | clear all tabs
NCURSES_KEY_SRESET | soft (partial) reset
NCURSES_KEY_RESET | reset or hard reset
NCURSES_KEY_PRINT | print
NCURSES_KEY_LL | lower left
NCURSES_KEY_A1 | upper left of keypad
NCURSES_KEY_A3 | upper right of keypad
NCURSES_KEY_B2 | center of keypad
NCURSES_KEY_C1 | lower left of keypad
NCURSES_KEY_C3 | lower right of keypad
NCURSES_KEY_BTAB | back tab
NCURSES_KEY_BEG | beginning
NCURSES_KEY_CANCEL | cancel
NCURSES_KEY_CLOSE | close
NCURSES_KEY_COMMAND | cmd (command)
NCURSES_KEY_COPY | copy
NCURSES_KEY_CREATE | create
NCURSES_KEY_END | end
NCURSES_KEY_EXIT | exit
NCURSES_KEY_FIND | find
NCURSES_KEY_HELP | help
NCURSES_KEY_MARK | mark
NCURSES_KEY_MESSAGE | message
NCURSES_KEY_MOVE | move
NCURSES_KEY_NEXT | next
NCURSES_KEY_OPEN | open
NCURSES_KEY_OPTIONS | options
NCURSES_KEY_PREVIOUS | previous
NCURSES_KEY_REDO | redo
NCURSES_KEY_REFERENCE | ref (reference)
NCURSES_KEY_REFRESH | refresh
NCURSES_KEY_REPLACE | replace
NCURSES_KEY_RESTART | restart
NCURSES_KEY_RESUME | resume
NCURSES_KEY_SAVE | save
NCURSES_KEY_SBEG | shiftet beg (beginning)
NCURSES_KEY_SCANCEL | shifted cancel
NCURSES_KEY_SCOMMAND | shifted command
NCURSES_KEY_SCOPY | shifted copy
NCURSES_KEY_SCREATE | shifted create
NCURSES_KEY_SDC | shifted delete char
NCURSES_KEY_SDL | shifted delete line
NCURSES_KEY_SELECT | select
NCURSES_KEY_SEND | shifted end
NCURSES_KEY_SEOL | shifted end of line
NCURSES_KEY_SEXIT | shifted exit
NCURSES_KEY_SFIND | shifted find
NCURSES_KEY_SHELP | shifted help
NCURSES_KEY_SHOME | shifted home
NCURSES_KEY_SIC | shifted input
NCURSES_KEY_SLEFT | shifted left arrow
NCURSES_KEY_SMESSAGE | shifted message
NCURSES_KEY_SMOVE | shifted move
NCURSES_KEY_SNEXT | shifted next
NCURSES_KEY_SOPTIONS | shifted options
NCURSES_KEY_SPREVIOUS | shifted previous
NCURSES_KEY_SPRINT | shifted print
NCURSES_KEY_SREDO | shifted redo
NCURSES_KEY_SREPLACE | shifted replace
NCURSES_KEY_SRIGHT | shifted right arrow
NCURSES_KEY_SRSUME | shifted resume
NCURSES_KEY_SSAVE | shifted save
NCURSES_KEY_SSUSPEND | shifted suspend
NCURSES_KEY_UNDO | undo
NCURSES_KEY_MOUSE | mouse event has occurred
NCURSES_KEY_MAX | maximum key value
Colors
Mouse
Öntanımlı Sabitler


Mouse

mouse constants
Constant | meaning
NCURSES_BUTTON1_RELEASED - NCURSES_BUTTON4_RELEASED | button (1-4) released
NCURSES_BUTTON1_PRESSED - NCURSES_BUTTON4_PRESSED | button (1-4) pressed
NCURSES_BUTTON1_CLICKED - NCURSES_BUTTON4_CLICKED | button (1-4) clicked
NCURSES_BUTTON1_DOUBLE_CLICKED - NCURSES_BUTTON4_DOUBLE_CLICKED | button (1-4) double clicked
NCURSES_BUTTON1_TRIPLE_CLICKED - NCURSES_BUTTON4_TRIPLE_CLICKED | button (1-4) triple clicked
NCURSES_BUTTON_CTRL | ctrl pressed during click
NCURSES_BUTTON_SHIFT | shift pressed during click
NCURSES_BUTTON_ALT | alt pressed during click
NCURSES_ALL_MOUSE_EVENTS | report all mouse events
NCURSES_REPORT_MOUSE_POSITION | report mouse position
Keys
Ncurses İşlevleri
Öntanımlı Sabitler


Ncurses İşlevleri

İçindekiler

  • ncurses_addch — Add character at current position and advance cursor
  • ncurses_addchnstr — Add attributed string with specified length at current position
  • ncurses_addchstr — Add attributed string at current position
  • ncurses_addnstr — Add string with specified length at current position
  • ncurses_addstr — Output text at current position
  • ncurses_assume_default_colors — Define default colors for color 0
  • ncurses_attroff — Turn off the given attributes
  • ncurses_attron — Turn on the given attributes
  • ncurses_attrset — Set given attributes
  • ncurses_baudrate — Returns baudrate of terminal
  • ncurses_beep — Let the terminal beep
  • ncurses_bkgd — Set background property for terminal screen
  • ncurses_bkgdset — Control screen background
  • ncurses_border — Draw a border around the screen using attributed characters
  • ncurses_bottom_panel — Moves a visible panel to the bottom of the stack
  • ncurses_can_change_color — Checks if terminal color definitions can be changed
  • ncurses_cbreak — Switch off input buffering
  • ncurses_clear — Clear screen
  • ncurses_clrtobot — Clear screen from current position to bottom
  • ncurses_clrtoeol — Clear screen from current position to end of line
  • ncurses_color_content — Retrieves RGB components of a color
  • ncurses_color_set — Set active foreground and background colors
  • ncurses_curs_set — Set cursor state
  • ncurses_def_prog_mode — Saves terminals (program) mode
  • ncurses_def_shell_mode — Saves terminals (shell) mode
  • ncurses_define_key — Define a keycode
  • ncurses_del_panel — Remove panel from the stack and delete it (but not the associated window)
  • ncurses_delay_output — Delay output on terminal using padding characters
  • ncurses_delch — Delete character at current position, move rest of line left
  • ncurses_deleteln — Delete line at current position, move rest of screen up
  • ncurses_delwin — Delete a ncurses window
  • ncurses_doupdate — Write all prepared refreshes to terminal
  • ncurses_echo — Activate keyboard input echo
  • ncurses_echochar — Single character output including refresh
  • ncurses_end — Stop using ncurses, clean up the screen
  • ncurses_erase — Erase terminal screen
  • ncurses_erasechar — Returns current erase character
  • ncurses_filter — Set LINES for iniscr() and newterm() to 1
  • ncurses_flash — Flash terminal screen (visual bell)
  • ncurses_flushinp — Flush keyboard input buffer
  • ncurses_getch — Read a character from keyboard
  • ncurses_getmaxyx — Returns the size of a window
  • ncurses_getmouse — Reads mouse event
  • ncurses_getyx — Returns the current cursor position for a window
  • ncurses_halfdelay — Put terminal into halfdelay mode
  • ncurses_has_colors — Checks if terminal has color capabilities
  • ncurses_has_ic — Check for insert- and delete-capabilities
  • ncurses_has_il — Check for line insert- and delete-capabilities
  • ncurses_has_key — Check for presence of a function key on terminal keyboard
  • ncurses_hide_panel — Remove panel from the stack, making it invisible
  • ncurses_hline — Draw a horizontal line at current position using an attributed character and max. n characters long
  • ncurses_inch — Get character and attribute at current position
  • ncurses_init_color — Define a terminal color
  • ncurses_init_pair — Define a color pair
  • ncurses_init — Initialize ncurses
  • ncurses_insch — Insert character moving rest of line including character at current position
  • ncurses_insdelln — Insert lines before current line scrolling down (negative numbers delete and scroll up)
  • ncurses_insertln — Insert a line, move rest of screen down
  • ncurses_insstr — Insert string at current position, moving rest of line right
  • ncurses_instr — Reads string from terminal screen
  • ncurses_isendwin — Ncurses is in endwin mode, normal screen output may be performed
  • ncurses_keyok — Enable or disable a keycode
  • ncurses_keypad — Turns keypad on or off
  • ncurses_killchar — Returns current line kill character
  • ncurses_longname — Returns terminals description
  • ncurses_meta — Enables/Disable 8-bit meta key information
  • ncurses_mouse_trafo — Transforms coordinates
  • ncurses_mouseinterval — Set timeout for mouse button clicks
  • ncurses_mousemask — Sets mouse options
  • ncurses_move_panel — Moves a panel so that its upper-left corner is at [startx, starty]
  • ncurses_move — Move output position
  • ncurses_mvaddch — Move current position and add character
  • ncurses_mvaddchnstr — Move position and add attributed string with specified length
  • ncurses_mvaddchstr — Move position and add attributed string
  • ncurses_mvaddnstr — Move position and add string with specified length
  • ncurses_mvaddstr — Move position and add string
  • ncurses_mvcur — Move cursor immediately
  • ncurses_mvdelch — Move position and delete character, shift rest of line left
  • ncurses_mvgetch — Move position and get character at new position
  • ncurses_mvhline — Set new position and draw a horizontal line using an attributed character and max. n characters long
  • ncurses_mvinch — Move position and get attributed character at new position
  • ncurses_mvvline — Set new position and draw a vertical line using an attributed character and max. n characters long
  • ncurses_mvwaddstr — Add string at new position in window
  • ncurses_napms — Sleep
  • ncurses_new_panel — Create a new panel and associate it with window
  • ncurses_newpad — Creates a new pad (window)
  • ncurses_newwin — Create a new window
  • ncurses_nl — Translate newline and carriage return / line feed
  • ncurses_nocbreak — Switch terminal to cooked mode
  • ncurses_noecho — Switch off keyboard input echo
  • ncurses_nonl — Do not translate newline and carriage return / line feed
  • ncurses_noqiflush — Do not flush on signal characters
  • ncurses_noraw — Switch terminal out of raw mode
  • ncurses_pair_content — Retrieves foreground and background colors of a color pair
  • ncurses_panel_above — Returns the panel above panel
  • ncurses_panel_below — Returns the panel below panel
  • ncurses_panel_window — Returns the window associated with panel
  • ncurses_pnoutrefresh — Copies a region from a pad into the virtual screen
  • ncurses_prefresh — Copies a region from a pad into the virtual screen
  • ncurses_putp — Apply padding information to the string and output it
  • ncurses_qiflush — Flush on signal characters
  • ncurses_raw — Switch terminal into raw mode
  • ncurses_refresh — Refresh screen
  • ncurses_replace_panel — Replaces the window associated with panel
  • ncurses_reset_prog_mode — Resets the prog mode saved by def_prog_mode
  • ncurses_reset_shell_mode — Resets the shell mode saved by def_shell_mode
  • ncurses_resetty — Restores saved terminal state
  • ncurses_savetty — Saves terminal state
  • ncurses_scr_dump — Dump screen content to file
  • ncurses_scr_init — Initialize screen from file dump
  • ncurses_scr_restore — Restore screen from file dump
  • ncurses_scr_set — Inherit screen from file dump
  • ncurses_scrl — Scroll window content up or down without changing current position
  • ncurses_show_panel — Places an invisible panel on top of the stack, making it visible
  • ncurses_slk_attr — Returns current soft label key attribute
  • ncurses_slk_attroff — Turn off the given attributes for soft function-key labels
  • ncurses_slk_attron — Turn on the given attributes for soft function-key labels
  • ncurses_slk_attrset — Set given attributes for soft function-key labels
  • ncurses_slk_clear — Clears soft labels from screen
  • ncurses_slk_color — Sets color for soft label keys
  • ncurses_slk_init — Initializes soft label key functions
  • ncurses_slk_noutrefresh — Copies soft label keys to virtual screen
  • ncurses_slk_refresh — Copies soft label keys to screen
  • ncurses_slk_restore — Restores soft label keys
  • ncurses_slk_set — Sets function key labels
  • ncurses_slk_touch — Forces output when ncurses_slk_noutrefresh is performed
  • ncurses_standend — Stop using 'standout' attribute
  • ncurses_standout — Start using 'standout' attribute
  • ncurses_start_color — Initializes color functionality
  • ncurses_termattrs — Returns a logical OR of all attribute flags supported by terminal
  • ncurses_termname — Returns terminals (short)-name
  • ncurses_timeout — Set timeout for special key sequences
  • ncurses_top_panel — Moves a visible panel to the top of the stack
  • ncurses_typeahead — Specify different filedescriptor for typeahead checking
  • ncurses_ungetch — Put a character back into the input stream
  • ncurses_ungetmouse — Pushes mouse event to queue
  • ncurses_update_panels — Refreshes the virtual screen to reflect the relations between panels in the stack
  • ncurses_use_default_colors — Assign terminal default colors to color id -1
  • ncurses_use_env — Control use of environment information about terminal size
  • ncurses_use_extended_names — Control use of extended names in terminfo descriptions
  • ncurses_vidattr — Display the string on the terminal in the video attribute mode
  • ncurses_vline — Draw a vertical line at current position using an attributed character and max. n characters long
  • ncurses_waddch — Adds character at current position in a window and advance cursor
  • ncurses_waddstr — Outputs text at current postion in window
  • ncurses_wattroff — Turns off attributes for a window
  • ncurses_wattron — Turns on attributes for a window
  • ncurses_wattrset — Set the attributes for a window
  • ncurses_wborder — Draws a border around the window using attributed characters
  • ncurses_wclear — Clears window
  • ncurses_wcolor_set — Sets windows color pairings
  • ncurses_werase — Erase window contents
  • ncurses_wgetch — Reads a character from keyboard (window)
  • ncurses_whline — Draws a horizontal line in a window at current position using an attributed character and max. n characters long
  • ncurses_wmouse_trafo — Transforms window/stdscr coordinates
  • ncurses_wmove — Moves windows output position
  • ncurses_wnoutrefresh — Copies window to virtual screen
  • ncurses_wrefresh — Refresh window on terminal screen
  • ncurses_wstandend — End standout mode for a window
  • ncurses_wstandout — Enter standout mode for a window
  • ncurses_wvline — Draws a vertical line in a window at current position using an attributed character and max. n characters long
Mouse
ncurses_addch
Ncurses


Add character at current position and advance cursor

Ncurses İşlevleri
ncurses_addchnstr
Ncurses İşlevleri
PHP Manual

ncurses_addch

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_addch — Add character at current position and advance cursor

Açıklama

int ncurses_addch ( int $ch )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

ch

Ncurses İşlevleri
ncurses_addchnstr
Ncurses İşlevleri


Add attributed string with specified length at current position

ncurses_addch
ncurses_addchstr
Ncurses İşlevleri
PHP Manual

ncurses_addchnstr

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_addchnstr — Add attributed string with specified length at current position

Açıklama

int ncurses_addchnstr ( string $s , int $n )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

s

n

ncurses_addch
ncurses_addchstr
Ncurses İşlevleri


Add attributed string at current position

ncurses_addchnstr
ncurses_addnstr
Ncurses İşlevleri
PHP Manual

ncurses_addchstr

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_addchstr — Add attributed string at current position

Açıklama

int ncurses_addchstr ( string $s )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

s

ncurses_addchnstr
ncurses_addnstr
Ncurses İşlevleri


Add string with specified length at current position

ncurses_addchstr
ncurses_addstr
Ncurses İşlevleri
PHP Manual

ncurses_addnstr

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_addnstr — Add string with specified length at current position

Açıklama

int ncurses_addnstr ( string $s , int $n )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

s

n

ncurses_addchstr
ncurses_addstr
Ncurses İşlevleri


Output text at current position

ncurses_addnstr
ncurses_assume_default_colors
Ncurses İşlevleri
PHP Manual

ncurses_addstr

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_addstr — Output text at current position

Açıklama

int ncurses_addstr ( string $text )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

text

ncurses_addnstr
ncurses_assume_default_colors
Ncurses İşlevleri


Define default colors for color 0

ncurses_addstr
ncurses_attroff
Ncurses İşlevleri
PHP Manual

ncurses_assume_default_colors

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_assume_default_colors — Define default colors for color 0

Açıklama

int ncurses_assume_default_colors ( int $fg , int $bg )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

fg

bg

ncurses_addstr
ncurses_attroff
Ncurses İşlevleri


Turn off the given attributes

ncurses_assume_default_colors
ncurses_attron
Ncurses İşlevleri
PHP Manual

ncurses_attroff

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_attroff — Turn off the given attributes

Açıklama

int ncurses_attroff ( int $attributes )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

attributes

ncurses_assume_default_colors
ncurses_attron
Ncurses İşlevleri


Turn on the given attributes

ncurses_attroff
ncurses_attrset
Ncurses İşlevleri
PHP Manual

ncurses_attron

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_attron — Turn on the given attributes

Açıklama

int ncurses_attron ( int $attributes )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

attributes

ncurses_attroff
ncurses_attrset
Ncurses İşlevleri


Set given attributes

ncurses_attron
ncurses_baudrate
Ncurses İşlevleri
PHP Manual

ncurses_attrset

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_attrset — Set given attributes

Açıklama

int ncurses_attrset ( int $attributes )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

attributes

ncurses_attron
ncurses_baudrate
Ncurses İşlevleri


Returns baudrate of terminal

ncurses_attrset
ncurses_beep
Ncurses İşlevleri
PHP Manual

ncurses_baudrate

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_baudrate — Returns baudrate of terminal

Açıklama

int ncurses_baudrate ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ncurses_attrset
ncurses_beep
Ncurses İşlevleri


Let the terminal beep

ncurses_baudrate
ncurses_bkgd
Ncurses İşlevleri
PHP Manual

ncurses_beep

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_beep — Let the terminal beep

Açıklama

int ncurses_beep ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

ncurses_beep() sends an audible alert (bell) and if its not possible flashes the screen.

Ayrıca Bakınız

  • ncurses_flash() - Flash terminal screen (visual bell)

ncurses_baudrate
ncurses_bkgd
Ncurses İşlevleri


Set background property for terminal screen

ncurses_beep
ncurses_bkgdset
Ncurses İşlevleri
PHP Manual

ncurses_bkgd

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_bkgd — Set background property for terminal screen

Açıklama

int ncurses_bkgd ( int $attrchar )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

attrchar

ncurses_beep
ncurses_bkgdset
Ncurses İşlevleri


Control screen background

ncurses_bkgd
ncurses_border
Ncurses İşlevleri
PHP Manual

ncurses_bkgdset

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_bkgdset — Control screen background

Açıklama

void ncurses_bkgdset ( int $attrchar )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

attrchar

ncurses_bkgd
ncurses_border
Ncurses İşlevleri


Draw a border around the screen using attributed characters

ncurses_bkgdset
ncurses_bottom_panel
Ncurses İşlevleri
PHP Manual

ncurses_border

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_border — Draw a border around the screen using attributed characters

Açıklama

int ncurses_border ( int $left , int $right , int $top , int $bottom , int $tl_corner , int $tr_corner , int $bl_corner , int $br_corner )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Draws the specified lines and corners around the main window.

Use ncurses_wborder() for borders around subwindows!

Değiştirgeler

Every parameter expects 0 to draw a line or 1 to skip it.

left

right

top

bottom

tl_corner

Top left corner

tr_corner

Top right corner

bl_corner

Bottom left corner

br_corner

Bottom right corner

Ayrıca Bakınız

  • ncurses_wborder() - Draws a border around the window using attributed characters

ncurses_bkgdset
ncurses_bottom_panel
Ncurses İşlevleri


Moves a visible panel to the bottom of the stack

ncurses_border
ncurses_can_change_color
Ncurses İşlevleri
PHP Manual

ncurses_bottom_panel

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_bottom_panel — Moves a visible panel to the bottom of the stack

Açıklama

int ncurses_bottom_panel ( resource $panel )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

panel

ncurses_border
ncurses_can_change_color
Ncurses İşlevleri


Checks if terminal color definitions can be changed

ncurses_bottom_panel
ncurses_cbreak
Ncurses İşlevleri
PHP Manual

ncurses_can_change_color

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_can_change_color — Checks if terminal color definitions can be changed

Açıklama

bool ncurses_can_change_color ( void )

Checks whether the terminal has color capabilities and whether the programmer can change color definitions using ncurses_init_color(). ncurses must be initialized using ncurses_init() before calling this function.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Return TRUE if the programmer can change color definitions, FALSE otherwise.

Ayrıca Bakınız

  • ncurses_has_colors() - Checks if terminal has color capabilities
  • ncurses_init_color() - Define a terminal color
  • ncurses_start_color() - Initializes color functionality

ncurses_bottom_panel
ncurses_cbreak
Ncurses İşlevleri


Switch off input buffering

ncurses_can_change_color
ncurses_clear
Ncurses İşlevleri
PHP Manual

ncurses_cbreak

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_cbreak — Switch off input buffering

Açıklama

bool ncurses_cbreak ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Disables line buffering and character processing (interrupt and flow control characters are unaffected), making characters typed by the user immediately available to the program.

Dönen Değerler

Returns TRUE or NCURSES_ERR if any error occurred.

Ayrıca Bakınız

  • ncurses_nocbreak() - Switch terminal to cooked mode

ncurses_can_change_color
ncurses_clear
Ncurses İşlevleri


Clear screen

ncurses_cbreak
ncurses_clrtobot
Ncurses İşlevleri
PHP Manual

ncurses_clear

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_clear — Clear screen

Açıklama

bool ncurses_clear ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Clears the screen completely without setting blanks.

Note: ncurses_clear() clears the screen without setting blanks, which have the current background rendition. To clear screen with blanks, use ncurses_erase().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ncurses_erase() - Erase terminal screen

ncurses_cbreak
ncurses_clrtobot
Ncurses İşlevleri


Clear screen from current position to bottom

ncurses_clear
ncurses_clrtoeol
Ncurses İşlevleri
PHP Manual

ncurses_clrtobot

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_clrtobot — Clear screen from current position to bottom

Açıklama

bool ncurses_clrtobot ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Erases all lines from cursor to end of screen and creates blanks. Blanks created by ncurses_clrtobot() have the current background rendition.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ncurses_clear() - Clear screen
  • ncurses_clrtoeol() - Clear screen from current position to end of line

ncurses_clear
ncurses_clrtoeol
Ncurses İşlevleri


Clear screen from current position to end of line

ncurses_clrtobot
ncurses_color_content
Ncurses İşlevleri
PHP Manual

ncurses_clrtoeol

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_clrtoeol — Clear screen from current position to end of line

Açıklama

bool ncurses_clrtoeol ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Erases the current line from cursor position to the end. Blanks created by ncurses_clrtoeol() have the current background rendition.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ncurses_clear() - Clear screen
  • ncurses_clrtobot() - Clear screen from current position to bottom

ncurses_clrtobot
ncurses_color_content
Ncurses İşlevleri


Retrieves RGB components of a color

ncurses_clrtoeol
ncurses_color_set
Ncurses İşlevleri
PHP Manual

ncurses_color_content

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_color_content — Retrieves RGB components of a color

Açıklama

int ncurses_color_content ( int $color , int &$r , int &$g , int &$b )

Retrieves the red, green, and blue components for the given color definition. Terminal color capabilities must be initialized with ncurses_start_color() prior to calling this function.

Değiştirgeler

color

The number of the color to retrieve information for. May be one of the pre-defined color constants.

r

A reference to which to return the red component of the color. The value returned to the reference will be between 0 and 1000.

g

A reference to which to return the green component of the color. The value returned to the reference will be between 0 and 1000.

b

A reference to which to return the blue component of the color. The value returned to the reference will be between 0 and 1000.

Dönen Değerler

Returns -1 if the function was successful, and 0 if ncurses or terminal color capabilities have not been initialized.

Ayrıca Bakınız

  • ncurses_init_color() - Define a terminal color
  • ncurses_start_color() - Initializes color functionality

ncurses_clrtoeol
ncurses_color_set
Ncurses İşlevleri


Set active foreground and background colors

ncurses_color_content
ncurses_curs_set
Ncurses İşlevleri
PHP Manual

ncurses_color_set

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_color_set — Set active foreground and background colors

Açıklama

int ncurses_color_set ( int $pair )

Sets the active foreground and background colors. Any characters written after this function is invoked will have these colors. This function requires terminal colors to be supported and initialized using ncurses_start_color() beforehand.

ncurses uses color pairs to specify both foreground and background colors. Use ncurses_init_pair() to define a color pair.

Değiştirgeler

pair

The color pair from which to get the foreground and background colors to set as the active colors.

Dönen Değerler

Returns -1 on success, and 0 on failure.

Örnekler

Örnek 1 Writing a string with a specified color to the screen

<?php
ncurses_init();

// If the terminal supports colors, initialize and set active color
if (ncurses_has_colors()) {
    ncurses_start_color();
    ncurses_init_pair(1, NCURSES_COLOR_YELLOW, NCURSES_COLOR_BLUE);
    ncurses_color_set(1);
}

// Write a string at specified location
ncurses_mvaddstr(10, 10, "Hello world! Yellow on blue text!");

// Flush output to screen
ncurses_refresh();

ncurses_end();
?>

Ayrıca Bakınız

  • ncurses_init_pair() - Define a color pair
  • ncurses_start_color() - Initializes color functionality

ncurses_color_content
ncurses_curs_set
Ncurses İşlevleri


Set cursor state

ncurses_color_set
ncurses_def_prog_mode
Ncurses İşlevleri
PHP Manual

ncurses_curs_set

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_curs_set — Set cursor state

Açıklama

int ncurses_curs_set ( int $visibility )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

visibility

ncurses_color_set
ncurses_def_prog_mode
Ncurses İşlevleri


Saves terminals (program) mode

ncurses_curs_set
ncurses_def_shell_mode
Ncurses İşlevleri
PHP Manual

ncurses_def_prog_mode

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_def_prog_mode — Saves terminals (program) mode

Açıklama

bool ncurses_def_prog_mode ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Saves the current terminal modes for program (in curses) for use by ncurses_reset_prog_mode().

Dönen Değerler

Returns FALSE on success, otherwise TRUE.

Ayrıca Bakınız

  • ncurses_reset_prog_mode() - Resets the prog mode saved by def_prog_mode

ncurses_curs_set
ncurses_def_shell_mode
Ncurses İşlevleri


Saves terminals (shell) mode

ncurses_def_prog_mode
ncurses_define_key
Ncurses İşlevleri
PHP Manual

ncurses_def_shell_mode

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_def_shell_mode — Saves terminals (shell) mode

Açıklama

bool ncurses_def_shell_mode ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Saves the current terminal modes for shell (not in curses) for use by ncurses_reset_shell_mode().

Dönen Değerler

Returns FALSE on success, TRUE otherwise.

Ayrıca Bakınız

  • ncurses_reset_shell_mode() - Resets the shell mode saved by def_shell_mode

ncurses_def_prog_mode
ncurses_define_key
Ncurses İşlevleri


Define a keycode

ncurses_def_shell_mode
ncurses_del_panel
Ncurses İşlevleri
PHP Manual

ncurses_define_key

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_define_key — Define a keycode

Açıklama

int ncurses_define_key ( string $definition , int $keycode )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

definition

keycode

ncurses_def_shell_mode
ncurses_del_panel
Ncurses İşlevleri


Remove panel from the stack and delete it (but not the associated window)

ncurses_define_key
ncurses_delay_output
Ncurses İşlevleri
PHP Manual

ncurses_del_panel

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_del_panel — Remove panel from the stack and delete it (but not the associated window)

Açıklama

bool ncurses_del_panel ( resource $panel )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

panel

ncurses_define_key
ncurses_delay_output
Ncurses İşlevleri


Delay output on terminal using padding characters

ncurses_del_panel
ncurses_delch
Ncurses İşlevleri
PHP Manual

ncurses_delay_output

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_delay_output — Delay output on terminal using padding characters

Açıklama

int ncurses_delay_output ( int $milliseconds )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

milliseconds

ncurses_del_panel
ncurses_delch
Ncurses İşlevleri


Delete character at current position, move rest of line left

ncurses_delay_output
ncurses_deleteln
Ncurses İşlevleri
PHP Manual

ncurses_delch

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_delch — Delete character at current position, move rest of line left

Açıklama

bool ncurses_delch ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Deletes the character under the cursor. All characters to the right of the cursor on the same line are moved to the left one position and the last character on the line is filled with a blank. The cursor position does not change.

Dönen Değerler

Returns FALSE on success, TRUE otherwise.

Ayrıca Bakınız

  • ncurses_deleteln() - Delete line at current position, move rest of screen up

ncurses_delay_output
ncurses_deleteln
Ncurses İşlevleri


Delete line at current position, move rest of screen up

ncurses_delch
ncurses_delwin
Ncurses İşlevleri
PHP Manual

ncurses_deleteln

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_deleteln — Delete line at current position, move rest of screen up

Açıklama

bool ncurses_deleteln ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Deletes the current line under cursor position. All lines below the current line are moved up one line. The bottom line of window is cleared. Cursor position does not change.

Dönen Değerler

Returns FALSE on success, otherwise TRUE.

Ayrıca Bakınız

  • ncurses_delch() - Delete character at current position, move rest of line left

ncurses_delch
ncurses_delwin
Ncurses İşlevleri


Delete a ncurses window

ncurses_deleteln
ncurses_doupdate
Ncurses İşlevleri
PHP Manual

ncurses_delwin

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_delwin — Delete a ncurses window

Açıklama

bool ncurses_delwin ( resource $window )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

window

ncurses_deleteln
ncurses_doupdate
Ncurses İşlevleri


Write all prepared refreshes to terminal

ncurses_delwin
ncurses_echo
Ncurses İşlevleri
PHP Manual

ncurses_doupdate

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_doupdate — Write all prepared refreshes to terminal

Açıklama

bool ncurses_doupdate ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Compares the virtual screen to the physical screen and updates the physical screen. This way is more effective than using multiple refresh calls.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

ncurses_delwin
ncurses_echo
Ncurses İşlevleri


Activate keyboard input echo

ncurses_doupdate
ncurses_echochar
Ncurses İşlevleri
PHP Manual

ncurses_echo

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_echo — Activate keyboard input echo

Açıklama

bool ncurses_echo ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Enables echo mode. All characters typed by user are echoed by ncurses_getch().

Dönen Değerler

Returns FALSE on success, TRUE if any error occurred.

Ayrıca Bakınız

  • ncurses_noecho() - Switch off keyboard input echo to disable echo mode

ncurses_doupdate
ncurses_echochar
Ncurses İşlevleri


Single character output including refresh

ncurses_echo
ncurses_end
Ncurses İşlevleri
PHP Manual

ncurses_echochar

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_echochar — Single character output including refresh

Açıklama

int ncurses_echochar ( int $character )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

character

ncurses_echo
ncurses_end
Ncurses İşlevleri


Stop using ncurses, clean up the screen

ncurses_echochar
ncurses_erase
Ncurses İşlevleri
PHP Manual

ncurses_end

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_end — Stop using ncurses, clean up the screen

Açıklama

int ncurses_end ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ncurses_echochar
ncurses_erase
Ncurses İşlevleri


Erase terminal screen

ncurses_end
ncurses_erasechar
Ncurses İşlevleri
PHP Manual

ncurses_erase

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_erase — Erase terminal screen

Açıklama

bool ncurses_erase ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Fills the terminal screen with blanks.

Created blanks have the current background rendition, set by ncurses_bkgd().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ncurses_bkgd() - Set background property for terminal screen
  • ncurses_clear() - Clear screen

ncurses_end
ncurses_erasechar
Ncurses İşlevleri


Returns current erase character

ncurses_erase
ncurses_filter
Ncurses İşlevleri
PHP Manual

ncurses_erasechar

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_erasechar — Returns current erase character

Açıklama

string ncurses_erasechar ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Returns the current erase character.

Dönen Değerler

The current erase char, as a string.

Ayrıca Bakınız

  • ncurses_killchar() - Returns current line kill character

ncurses_erase
ncurses_filter
Ncurses İşlevleri


Set LINES for iniscr() and newterm() to 1

ncurses_erasechar
ncurses_flash
Ncurses İşlevleri
PHP Manual

ncurses_filter

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_filter — Set LINES for iniscr() and newterm() to 1

Açıklama

void ncurses_filter ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ncurses_erasechar
ncurses_flash
Ncurses İşlevleri


Flash terminal screen (visual bell)

ncurses_filter
ncurses_flushinp
Ncurses İşlevleri
PHP Manual

ncurses_flash

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_flash — Flash terminal screen (visual bell)

Açıklama

bool ncurses_flash ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Flashes the screen, and if its not possible, sends an audible alert (bell).

Dönen Değerler

Returns FALSE on success, otherwise TRUE.

Ayrıca Bakınız

  • ncurses_beep() - Let the terminal beep

ncurses_filter
ncurses_flushinp
Ncurses İşlevleri


Flush keyboard input buffer

ncurses_flash
ncurses_getch
Ncurses İşlevleri
PHP Manual

ncurses_flushinp

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_flushinp — Flush keyboard input buffer

Açıklama

bool ncurses_flushinp ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Throws away any typeahead that has been typed and has not yet been read by your program.

Dönen Değerler

Returns FALSE on success, otherwise TRUE.

ncurses_flash
ncurses_getch
Ncurses İşlevleri


Read a character from keyboard

ncurses_flushinp
ncurses_getmaxyx
Ncurses İşlevleri
PHP Manual

ncurses_getch

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_getch — Read a character from keyboard

Açıklama

int ncurses_getch ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ncurses_flushinp
ncurses_getmaxyx
Ncurses İşlevleri


Returns the size of a window

ncurses_getch
ncurses_getmouse
Ncurses İşlevleri
PHP Manual

ncurses_getmaxyx

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_getmaxyx — Returns the size of a window

Açıklama

void ncurses_getmaxyx ( resource $window , int &$y , int &$x )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Gets the horizontal and vertical size of the given window into the given variables.

Variables must be passed as reference, so they are updated when the user changes the terminal size.

Değiştirgeler

window

The measured window

y

This will be set to the window height

x

This will be set to the window width

Dönen Değerler

Hiçbir değer dönmez.

ncurses_getch
ncurses_getmouse
Ncurses İşlevleri


Reads mouse event

ncurses_getmaxyx
ncurses_getyx
Ncurses İşlevleri
PHP Manual

ncurses_getmouse

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_getmouse — Reads mouse event

Açıklama

bool ncurses_getmouse ( array &$mevent )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

ncurses_getmouse() reads mouse event out of queue.

Değiştirgeler

mevent

Event options will be delivered in this parameter which has to be an array, passed by reference (see example below).

On success an associative array with following keys will be delivered:

  • "id" : Id to distinguish multiple devices

  • "x" : screen relative x-position in character cells

  • "y" : screen relative y-position in character cells

  • "z" : currently not supported

  • "mmask" : Mouse action

Dönen Değerler

Returns FALSE if a mouse event is actually visible in the given window, otherwise returns TRUE.

Örnekler

Örnek 1 ncurses_getmouse() example

<?php
switch (ncurses_getch()){
  case NCURSES_KEY_MOUSE:
    if (!ncurses_getmouse($mevent)){
      if ($mevent["mmask"] & NCURSES_MOUSE_BUTTON1_PRESSED){
        $mouse_x = $mevent["x"]; // Save mouse position
        $mouse_y = $mevent["y"];
      }
    }
  break;

  default:
    /* .... */
}
?>

Ayrıca Bakınız

  • ncurses_ungetmouse() - Pushes mouse event to queue

ncurses_getmaxyx
ncurses_getyx
Ncurses İşlevleri


Returns the current cursor position for a window

ncurses_getmouse
ncurses_halfdelay
Ncurses İşlevleri
PHP Manual

ncurses_getyx

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_getyx — Returns the current cursor position for a window

Açıklama

void ncurses_getyx ( resource $window , int &$y , int &$x )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

window

y

x

ncurses_getmouse
ncurses_halfdelay
Ncurses İşlevleri


Put terminal into halfdelay mode

ncurses_getyx
ncurses_has_colors
Ncurses İşlevleri
PHP Manual

ncurses_halfdelay

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_halfdelay — Put terminal into halfdelay mode

Açıklama

int ncurses_halfdelay ( int $tenth )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

tenth

ncurses_getyx
ncurses_has_colors
Ncurses İşlevleri


Checks if terminal has color capabilities

ncurses_halfdelay
ncurses_has_ic
Ncurses İşlevleri
PHP Manual

ncurses_has_colors

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_has_colors — Checks if terminal has color capabilities

Açıklama

bool ncurses_has_colors ( void )

Checks whether the terminal has color capabilities. This function can be used to write terminal-independent programs. ncurses must be initialized using ncurses_init() before calling this function.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Return TRUE if the terminal has color capabilities, FALSE otherwise.

Örnekler

Örnek 1 Writing a string with a specified color to the screen

<?php
ncurses_init();

// If the terminal supports colors, initialize and set active color
if (ncurses_has_colors()) {
    ncurses_start_color();
    ncurses_init_pair(1, NCURSES_COLOR_YELLOW, NCURSES_COLOR_BLUE);
    ncurses_color_set(1);
}

// Write a string at specified location
ncurses_mvaddstr(10, 10, "Hello world! Yellow on blue text!");

// Flush output to screen
ncurses_refresh();

ncurses_end();
?>

Ayrıca Bakınız

  • ncurses_can_change_color() - Checks if terminal color definitions can be changed
  • ncurses_start_color() - Initializes color functionality

ncurses_halfdelay
ncurses_has_ic
Ncurses İşlevleri


Check for insert- and delete-capabilities

ncurses_has_colors
ncurses_has_il
Ncurses İşlevleri
PHP Manual

ncurses_has_ic

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_has_ic — Check for insert- and delete-capabilities

Açıklama

bool ncurses_has_ic ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Checks whether the terminal has insert and delete capabilities.

Dönen Değerler

Returns TRUE if the terminal has insert/delete-capabilities, FALSE otherwise.

Ayrıca Bakınız

  • ncurses_has_il() - Check for line insert- and delete-capabilities

ncurses_has_colors
ncurses_has_il
Ncurses İşlevleri


Check for line insert- and delete-capabilities

ncurses_has_ic
ncurses_has_key
Ncurses İşlevleri
PHP Manual

ncurses_has_il

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_has_il — Check for line insert- and delete-capabilities

Açıklama

bool ncurses_has_il ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Checks whether the terminal has insert- and delete-line-capabilities.

Dönen Değerler

Returns TRUE if the terminal has insert/delete-line capabilities, FALSE otherwise.

Ayrıca Bakınız

  • ncurses_has_ic() - Check for insert- and delete-capabilities

ncurses_has_ic
ncurses_has_key
Ncurses İşlevleri


Check for presence of a function key on terminal keyboard

ncurses_has_il
ncurses_hide_panel
Ncurses İşlevleri
PHP Manual

ncurses_has_key

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_has_key — Check for presence of a function key on terminal keyboard

Açıklama

int ncurses_has_key ( int $keycode )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

keycode

ncurses_has_il
ncurses_hide_panel
Ncurses İşlevleri


Remove panel from the stack, making it invisible

ncurses_has_key
ncurses_hline
Ncurses İşlevleri
PHP Manual

ncurses_hide_panel

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_hide_panel — Remove panel from the stack, making it invisible

Açıklama

int ncurses_hide_panel ( resource $panel )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

panel

ncurses_has_key
ncurses_hline
Ncurses İşlevleri


Draw a horizontal line at current position using an attributed character and max. n characters long

ncurses_hide_panel
ncurses_inch
Ncurses İşlevleri
PHP Manual

ncurses_hline

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_hline — Draw a horizontal line at current position using an attributed character and max. n characters long

Açıklama

int ncurses_hline ( int $charattr , int $n )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

charattr

n

ncurses_hide_panel
ncurses_inch
Ncurses İşlevleri


Get character and attribute at current position

ncurses_hline
ncurses_init_color
Ncurses İşlevleri
PHP Manual

ncurses_inch

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_inch — Get character and attribute at current position

Açıklama

string ncurses_inch ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Returns the character from the current position.

Dönen Değerler

Returns the character, as a string.

ncurses_hline
ncurses_init_color
Ncurses İşlevleri


Define a terminal color

ncurses_inch
ncurses_init_pair
Ncurses İşlevleri
PHP Manual

ncurses_init_color

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_init_color — Define a terminal color

Açıklama

int ncurses_init_color ( int $color , int $r , int $g , int $b )

Defines or redefines the given color. When this function is called, all occurrences of the given color on the screen, if any, immediately change to the new definition.

Color capabilities must be supported by the terminal and initialized using ncurses_start_color() prior to calling this function. In addition, the terminal must have color changing capabilities; use ncurses_can_change_color() to check for this.

Değiştirgeler

color

The identification number of the color to redefine. It may be one of the default color constants.

r

A color value, between 0 and 1000, for the red component.

g

A color value, between 0 and 1000, for the green component.

b

A color value, between 0 and 1000, for the blue component.

Dönen Değerler

Returns -1 if the function was successful, and 0 if ncurses or terminal color capabilities have not been initialized or the terminal does not have color changing capabilities.

Ayrıca Bakınız

  • ncurses_color_content() - Retrieves RGB components of a color
  • ncurses_start_color() - Initializes color functionality

ncurses_inch
ncurses_init_pair
Ncurses İşlevleri


Define a color pair

ncurses_init_color
ncurses_init
Ncurses İşlevleri
PHP Manual

ncurses_init_pair

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_init_pair — Define a color pair

Açıklama

int ncurses_init_pair ( int $pair , int $fg , int $bg )

Defines or redefines the given color pair to have the given foreground and background colors. If the color pair was previously initialized, the screen is refreshed and all occurrences of it are changed to reflect the new definition.

Color capabilities must be initialized using ncurses_start_color() before calling this function. The first color pair (color pair 0) is assumed to be white on black by default, but can be changed using ncurses_assume_default_colors().

Değiştirgeler

pair

The number of the color pair to define.

fg

The foreground color for the color pair. May be one of the pre-defined colors or one defined by ncurses_init_color() if the terminal has color changing capabilities.

bg

The background color for the color pair. May be one of the pre-defined colors or one defined by ncurses_init_color() if the terminal has color changing capabilities.

Dönen Değerler

Returns -1 if the function was successful, and 0 if ncurses or color support were not initialized.

Notlar

Note that color changing capabilities are not required for defining color pairs of pre-existing colors, but only for changing definitions (red, green, and blue components) of colors themselves per ncurses_init_color().

Örnekler

Örnek 1 Writing a string with a specified color to the screen

<?php
ncurses_init();

// If the terminal supports colors, initialize and set active color
if (ncurses_has_colors()) {
    ncurses_start_color();
    ncurses_init_pair(1, NCURSES_COLOR_YELLOW, NCURSES_COLOR_BLUE);
    ncurses_color_set(1);
}

// Write a string at specified location
ncurses_mvaddstr(10, 10, "Hello world! Yellow on blue text!");

// Flush output to screen
ncurses_refresh();

ncurses_end();
?>

Ayrıca Bakınız

  • ncurses_pair_content() - Retrieves foreground and background colors of a color pair
  • ncurses_start_color() - Initializes color functionality

ncurses_init_color
ncurses_init
Ncurses İşlevleri


Initialize ncurses

ncurses_init_pair
ncurses_insch
Ncurses İşlevleri
PHP Manual

ncurses_init

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_init — Initialize ncurses

Açıklama

void ncurses_init ( void )

Initializes the ncurses interface. This function must be used before any other ncurses function call.

Note that ncurses_end() must be called before exiting from the program, or the terminal will not be restored to its proper non-visual mode.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • ncurses_end() - Stop using ncurses, clean up the screen

ncurses_init_pair
ncurses_insch
Ncurses İşlevleri


Insert character moving rest of line including character at current position

ncurses_init
ncurses_insdelln
Ncurses İşlevleri
PHP Manual

ncurses_insch

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_insch — Insert character moving rest of line including character at current position

Açıklama

int ncurses_insch ( int $character )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

character

ncurses_init
ncurses_insdelln
Ncurses İşlevleri


Insert lines before current line scrolling down (negative numbers delete and scroll up)

ncurses_insch
ncurses_insertln
Ncurses İşlevleri
PHP Manual

ncurses_insdelln

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_insdelln — Insert lines before current line scrolling down (negative numbers delete and scroll up)

Açıklama

int ncurses_insdelln ( int $count )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

count

ncurses_insch
ncurses_insertln
Ncurses İşlevleri


Insert a line, move rest of screen down

ncurses_insdelln
ncurses_insstr
Ncurses İşlevleri
PHP Manual

ncurses_insertln

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_insertln — Insert a line, move rest of screen down

Açıklama

int ncurses_insertln ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Inserts a new line above the current line. The bottom line will be lost.

ncurses_insdelln
ncurses_insstr
Ncurses İşlevleri


Insert string at current position, moving rest of line right

ncurses_insertln
ncurses_instr
Ncurses İşlevleri
PHP Manual

ncurses_insstr

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_insstr — Insert string at current position, moving rest of line right

Açıklama

int ncurses_insstr ( string $text )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

text

ncurses_insertln
ncurses_instr
Ncurses İşlevleri


Reads string from terminal screen

ncurses_insstr
ncurses_isendwin
Ncurses İşlevleri
PHP Manual

ncurses_instr

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_instr — Reads string from terminal screen

Açıklama

int ncurses_instr ( string &$buffer )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Reads a string from the terminal screen and returns the number of characters read from the current character position until end of line.

Değiştirgeler

buffer

The characters. Attributes will be stripped.

Dönen Değerler

Returns the number of characters.

ncurses_insstr
ncurses_isendwin
Ncurses İşlevleri


Ncurses is in endwin mode, normal screen output may be performed

ncurses_instr
ncurses_keyok
Ncurses İşlevleri
PHP Manual

ncurses_isendwin

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_isendwin — Ncurses is in endwin mode, normal screen output may be performed

Açıklama

bool ncurses_isendwin ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Checks if ncurses is in endwin mode.

Dönen Değerler

Returns TRUE, if ncurses_end() has been called without any subsequent calls to ncurses_wrefresh(), FALSE otherwise.

Ayrıca Bakınız

  • ncurses_end() - Stop using ncurses, clean up the screen
  • ncurses_wrefresh() - Refresh window on terminal screen

ncurses_instr
ncurses_keyok
Ncurses İşlevleri


Enable or disable a keycode

ncurses_isendwin
ncurses_keypad
Ncurses İşlevleri
PHP Manual

ncurses_keyok

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_keyok — Enable or disable a keycode

Açıklama

int ncurses_keyok ( int $keycode , bool $enable )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

keycode

enable

ncurses_isendwin
ncurses_keypad
Ncurses İşlevleri


Turns keypad on or off

ncurses_keyok
ncurses_killchar
Ncurses İşlevleri
PHP Manual

ncurses_keypad

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_keypad — Turns keypad on or off

Açıklama

int ncurses_keypad ( resource $window , bool $bf )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

window

bf

ncurses_keyok
ncurses_killchar
Ncurses İşlevleri


Returns current line kill character

ncurses_keypad
ncurses_longname
Ncurses İşlevleri
PHP Manual

ncurses_killchar

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_killchar — Returns current line kill character

Açıklama

string ncurses_killchar ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Returns the current line kill character.

Dönen Değerler

Returns the kill character, as a string.

Ayrıca Bakınız

  • ncurses_erasechar() - Returns current erase character

ncurses_keypad
ncurses_longname
Ncurses İşlevleri


Returns terminals description

ncurses_killchar
ncurses_meta
Ncurses İşlevleri
PHP Manual

ncurses_longname

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_longname — Returns terminals description

Açıklama

string ncurses_longname ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Returns a verbose description of the terminal.

Dönen Değerler

Returns the description, as a string truncated to 128 characters. On errors, returns NULL.

Ayrıca Bakınız

  • ncurses_termname() - Returns terminals (short)-name

ncurses_killchar
ncurses_meta
Ncurses İşlevleri


Enables/Disable 8-bit meta key information

ncurses_longname
ncurses_mouse_trafo
Ncurses İşlevleri
PHP Manual

ncurses_meta

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_meta — Enables/Disable 8-bit meta key information

Açıklama

int ncurses_meta ( resource $window , bool $8bit )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

window

8bit

ncurses_longname
ncurses_mouse_trafo
Ncurses İşlevleri


Transforms coordinates

ncurses_meta
ncurses_mouseinterval
Ncurses İşlevleri
PHP Manual

ncurses_mouse_trafo

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mouse_trafo — Transforms coordinates

Açıklama

bool ncurses_mouse_trafo ( int &$y , int &$x , bool $toscreen )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

y

x

toscreen

ncurses_meta
ncurses_mouseinterval
Ncurses İşlevleri


Set timeout for mouse button clicks

ncurses_mouse_trafo
ncurses_mousemask
Ncurses İşlevleri
PHP Manual

ncurses_mouseinterval

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mouseinterval — Set timeout for mouse button clicks

Açıklama

int ncurses_mouseinterval ( int $milliseconds )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

milliseconds

ncurses_mouse_trafo
ncurses_mousemask
Ncurses İşlevleri


Sets mouse options

ncurses_mouseinterval
ncurses_move_panel
Ncurses İşlevleri
PHP Manual

ncurses_mousemask

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mousemask — Sets mouse options

Açıklama

int ncurses_mousemask ( int $newmask , int &$oldmask )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Sets mouse events to be reported. By default no mouse events will be reported.

Mouse events are represented by NCURSES_KEY_MOUSE in the ncurses_wgetch() input stream. To read the event data and pop the event of queue, call ncurses_getmouse().

Değiştirgeler

newmask

Mouse mask options can be set with the following predefined constants:

  • NCURSES_BUTTON1_PRESSED

  • NCURSES_BUTTON1_RELEASED

  • NCURSES_BUTTON1_CLICKED

  • NCURSES_BUTTON1_DOUBLE_CLICKED

  • NCURSES_BUTTON1_TRIPLE_CLICKED

  • NCURSES_BUTTON2_PRESSED

  • NCURSES_BUTTON2_RELEASED

  • NCURSES_BUTTON2_CLICKED

  • NCURSES_BUTTON2_DOUBLE_CLICKED

  • NCURSES_BUTTON2_TRIPLE_CLICKED

  • NCURSES_BUTTON3_PRESSED

  • NCURSES_BUTTON3_RELEASED

  • NCURSES_BUTTON3_CLICKED

  • NCURSES_BUTTON3_DOUBLE_CLICKED

  • NCURSES_BUTTON3_TRIPLE_CLICKED

  • NCURSES_BUTTON4_PRESSED

  • NCURSES_BUTTON4_RELEASED

  • NCURSES_BUTTON4_CLICKED

  • NCURSES_BUTTON4_DOUBLE_CLICKED

  • NCURSES_BUTTON4_TRIPLE_CLICKED

  • NCURSES_BUTTON_SHIFT>

  • NCURSES_BUTTON_CTRL

  • NCURSES_BUTTON_ALT

  • NCURSES_ALL_MOUSE_EVENTS

  • NCURSES_REPORT_MOUSE_POSITION

As a side effect, setting a zero mousemask in newmask turns off the mouse pointer. Setting a non zero value turns mouse pointer on.

oldmask

This will be set to the previous value of the mouse event mask.

Dönen Değerler

Returns the mask of reportable events. On complete failure, it returns 0.

Örnekler

Örnek 1 ncurses_mousemask() example

<?php
$newmask = NCURSES_BUTTON1_CLICKED + NCURSES_BUTTON1_RELEASED;
$mask = ncurses_mousemask($newmask, $oldmask);
if ($mask & $newmask){
    printf("All specified mouse options will be supported\n");
}
?>

Ayrıca Bakınız

  • ncurses_getch() - Read a character from keyboard
  • ncurses_getmouse() - Reads mouse event
  • ncurses_ungetmouse() - Pushes mouse event to queue

ncurses_mouseinterval
ncurses_move_panel
Ncurses İşlevleri


Moves a panel so that its upper-left corner is at [startx, starty]

ncurses_mousemask
ncurses_move
Ncurses İşlevleri
PHP Manual

ncurses_move_panel

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_move_panel — Moves a panel so that its upper-left corner is at [startx, starty]

Açıklama

int ncurses_move_panel ( resource $panel , int $startx , int $starty )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

panel

startx

starty

ncurses_mousemask
ncurses_move
Ncurses İşlevleri


Move output position

ncurses_move_panel
ncurses_mvaddch
Ncurses İşlevleri
PHP Manual

ncurses_move

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_move — Move output position

Açıklama

int ncurses_move ( int $y , int $x )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

y

x

ncurses_move_panel
ncurses_mvaddch
Ncurses İşlevleri


Move current position and add character

ncurses_move
ncurses_mvaddchnstr
Ncurses İşlevleri
PHP Manual

ncurses_mvaddch

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mvaddch — Move current position and add character

Açıklama

int ncurses_mvaddch ( int $y , int $x , int $c )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

y

x

c

ncurses_move
ncurses_mvaddchnstr
Ncurses İşlevleri


Move position and add attributed string with specified length

ncurses_mvaddch
ncurses_mvaddchstr
Ncurses İşlevleri
PHP Manual

ncurses_mvaddchnstr

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mvaddchnstr — Move position and add attributed string with specified length

Açıklama

int ncurses_mvaddchnstr ( int $y , int $x , string $s , int $n )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

y

x

s

n

ncurses_mvaddch
ncurses_mvaddchstr
Ncurses İşlevleri


Move position and add attributed string

ncurses_mvaddchnstr
ncurses_mvaddnstr
Ncurses İşlevleri
PHP Manual

ncurses_mvaddchstr

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mvaddchstr — Move position and add attributed string

Açıklama

int ncurses_mvaddchstr ( int $y , int $x , string $s )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

y

x

s

ncurses_mvaddchnstr
ncurses_mvaddnstr
Ncurses İşlevleri


Move position and add string with specified length

ncurses_mvaddchstr
ncurses_mvaddstr
Ncurses İşlevleri
PHP Manual

ncurses_mvaddnstr

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mvaddnstr — Move position and add string with specified length

Açıklama

int ncurses_mvaddnstr ( int $y , int $x , string $s , int $n )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

y

x

s

n

ncurses_mvaddchstr
ncurses_mvaddstr
Ncurses İşlevleri


Move position and add string

ncurses_mvaddnstr
ncurses_mvcur
Ncurses İşlevleri
PHP Manual

ncurses_mvaddstr

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mvaddstr — Move position and add string

Açıklama

int ncurses_mvaddstr ( int $y , int $x , string $s )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

y

x

s

ncurses_mvaddnstr
ncurses_mvcur
Ncurses İşlevleri


Move cursor immediately

ncurses_mvaddstr
ncurses_mvdelch
Ncurses İşlevleri
PHP Manual

ncurses_mvcur

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mvcur — Move cursor immediately

Açıklama

int ncurses_mvcur ( int $old_y , int $old_x , int $new_y , int $new_x )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

old_y

old_x

new_y

new_x

ncurses_mvaddstr
ncurses_mvdelch
Ncurses İşlevleri


Move position and delete character, shift rest of line left

ncurses_mvcur
ncurses_mvgetch
Ncurses İşlevleri
PHP Manual

ncurses_mvdelch

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mvdelch — Move position and delete character, shift rest of line left

Açıklama

int ncurses_mvdelch ( int $y , int $x )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

y

x

ncurses_mvcur
ncurses_mvgetch
Ncurses İşlevleri


Move position and get character at new position

ncurses_mvdelch
ncurses_mvhline
Ncurses İşlevleri
PHP Manual

ncurses_mvgetch

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mvgetch — Move position and get character at new position

Açıklama

int ncurses_mvgetch ( int $y , int $x )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

y

x

ncurses_mvdelch
ncurses_mvhline
Ncurses İşlevleri


Set new position and draw a horizontal line using an attributed character and max. n characters long

ncurses_mvgetch
ncurses_mvinch
Ncurses İşlevleri
PHP Manual

ncurses_mvhline

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mvhline — Set new position and draw a horizontal line using an attributed character and max. n characters long

Açıklama

int ncurses_mvhline ( int $y , int $x , int $attrchar , int $n )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

y

x

attrchar

n

ncurses_mvgetch
ncurses_mvinch
Ncurses İşlevleri


Move position and get attributed character at new position

ncurses_mvhline
ncurses_mvvline
Ncurses İşlevleri
PHP Manual

ncurses_mvinch

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mvinch — Move position and get attributed character at new position

Açıklama

int ncurses_mvinch ( int $y , int $x )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

y

x

ncurses_mvhline
ncurses_mvvline
Ncurses İşlevleri


Set new position and draw a vertical line using an attributed character and max. n characters long

ncurses_mvinch
ncurses_mvwaddstr
Ncurses İşlevleri
PHP Manual

ncurses_mvvline

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mvvline — Set new position and draw a vertical line using an attributed character and max. n characters long

Açıklama

int ncurses_mvvline ( int $y , int $x , int $attrchar , int $n )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

y

x

attrchar

n

ncurses_mvinch
ncurses_mvwaddstr
Ncurses İşlevleri


Add string at new position in window

ncurses_mvvline
ncurses_napms
Ncurses İşlevleri
PHP Manual

ncurses_mvwaddstr

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_mvwaddstr — Add string at new position in window

Açıklama

int ncurses_mvwaddstr ( resource $window , int $y , int $x , string $text )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

window

y

x

text

ncurses_mvvline
ncurses_napms
Ncurses İşlevleri


Sleep

ncurses_mvwaddstr
ncurses_new_panel
Ncurses İşlevleri
PHP Manual

ncurses_napms

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_napms — Sleep

Açıklama

int ncurses_napms ( int $milliseconds )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

milliseconds

ncurses_mvwaddstr
ncurses_new_panel
Ncurses İşlevleri


Create a new panel and associate it with window

ncurses_napms
ncurses_newpad
Ncurses İşlevleri
PHP Manual

ncurses_new_panel

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_new_panel — Create a new panel and associate it with window

Açıklama

resource ncurses_new_panel ( resource $window )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

window

ncurses_napms
ncurses_newpad
Ncurses İşlevleri


Creates a new pad (window)

ncurses_new_panel
ncurses_newwin
Ncurses İşlevleri
PHP Manual

ncurses_newpad

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_newpad — Creates a new pad (window)

Açıklama

resource ncurses_newpad ( int $rows , int $cols )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

rows

cols

ncurses_new_panel
ncurses_newwin
Ncurses İşlevleri


Create a new window

ncurses_newpad
ncurses_nl
Ncurses İşlevleri
PHP Manual

ncurses_newwin

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_newwin — Create a new window

Açıklama

resource ncurses_newwin ( int $rows , int $cols , int $y , int $x )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Creates a new window to draw elements in.

When creating additional windows, remember to use ncurses_getmaxyx() to check for available space, as terminal size is individual and may vary.

Değiştirgeler

rows

Number of rows

cols

Number of columns

y

y-coordinate of the origin

x

x-coordinate of the origin

Dönen Değerler

Returns a resource ID for the new window.

ncurses_newpad
ncurses_nl
Ncurses İşlevleri


Translate newline and carriage return / line feed

ncurses_newwin
ncurses_nocbreak
Ncurses İşlevleri
PHP Manual

ncurses_nl

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_nl — Translate newline and carriage return / line feed

Açıklama

bool ncurses_nl ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ncurses_newwin
ncurses_nocbreak
Ncurses İşlevleri


Switch terminal to cooked mode

ncurses_nl
ncurses_noecho
Ncurses İşlevleri
PHP Manual

ncurses_nocbreak

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_nocbreak — Switch terminal to cooked mode

Açıklama

bool ncurses_nocbreak ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Returns terminal to normal (cooked) mode. Initially the terminal may or may not be in cbreak mode as the mode is inherited. Therefore a program should call ncurses_cbreak() and ncurses_nocbreak() explicitly.

Dönen Değerler

Returns TRUE if any error occurred, otherwise FALSE.

Ayrıca Bakınız

  • ncurses_cbreak() - Switch off input buffering

ncurses_nl
ncurses_noecho
Ncurses İşlevleri


Switch off keyboard input echo

ncurses_nocbreak
ncurses_nonl
Ncurses İşlevleri
PHP Manual

ncurses_noecho

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_noecho — Switch off keyboard input echo

Açıklama

bool ncurses_noecho ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Prevents echoing of user typed characters.

Dönen Değerler

Returns TRUE if any error occurred, FALSE otherwise.

Ayrıca Bakınız

  • ncurses_echo() - Activate keyboard input echo
  • ncurses_getch() - Read a character from keyboard

ncurses_nocbreak
ncurses_nonl
Ncurses İşlevleri


Do not translate newline and carriage return / line feed

ncurses_noecho
ncurses_noqiflush
Ncurses İşlevleri
PHP Manual

ncurses_nonl

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_nonl — Do not translate newline and carriage return / line feed

Açıklama

bool ncurses_nonl ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ncurses_noecho
ncurses_noqiflush
Ncurses İşlevleri


Do not flush on signal characters

ncurses_nonl
ncurses_noraw
Ncurses İşlevleri
PHP Manual

ncurses_noqiflush

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_noqiflush — Do not flush on signal characters

Açıklama

void ncurses_noqiflush ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ncurses_nonl
ncurses_noraw
Ncurses İşlevleri


Switch terminal out of raw mode

ncurses_noqiflush
ncurses_pair_content
Ncurses İşlevleri
PHP Manual

ncurses_noraw

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_noraw — Switch terminal out of raw mode

Açıklama

bool ncurses_noraw ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Switches the terminal out of raw mode. Raw mode is similar to cbreak mode, in that characters typed are immediately passed through to the user program. The difference is that in raw mode, the interrupt, quit, suspend and flow control characters are all passed through uninterpreted, instead of generating a signal.

Dönen Değerler

Returns TRUE if any error occurred, otherwise FALSE.

Ayrıca Bakınız

  • ncurses_raw() - Switch terminal into raw mode
  • ncurses_cbreak() - Switch off input buffering
  • ncurses_nocbreak() - Switch terminal to cooked mode

ncurses_noqiflush
ncurses_pair_content
Ncurses İşlevleri


Retrieves foreground and background colors of a color pair

ncurses_noraw
ncurses_panel_above
Ncurses İşlevleri
PHP Manual

ncurses_pair_content

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_pair_content — Retrieves foreground and background colors of a color pair

Açıklama

int ncurses_pair_content ( int $pair , int &$f , int &$b )

Retrieves the foreground and background colors that constitute the given color pair. Terminal color capabilities must be initialized with ncurses_start_color() prior to calling this function.

Değiştirgeler

pair

The number of the color pair to retrieve information for.

f

A reference to which to return the foreground color of the color pair. The information returned will be a color number referring to one of the pre-defined colors or a color defined previously by ncurses_init_color() if the terminal supports color changing.

b

A reference to which to return the background color of the color pair. The information returned will be a color number referring to one of the pre-defined colors or a color defined previously by ncurses_init_color() if the terminal supports color changing.

Dönen Değerler

Returns -1 if the function was successful, and 0 if ncurses or terminal color capabilities have not been initialized.

Ayrıca Bakınız

  • ncurses_init_pair() - Define a color pair
  • ncurses_start_color() - Initializes color functionality

ncurses_noraw
ncurses_panel_above
Ncurses İşlevleri


Returns the panel above panel

ncurses_pair_content
ncurses_panel_below
Ncurses İşlevleri
PHP Manual

ncurses_panel_above

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_panel_above — Returns the panel above panel

Açıklama

resource ncurses_panel_above ( resource $panel )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

panel

Dönen Değerler

If panel is null, returns the bottom panel in the stack.

ncurses_pair_content
ncurses_panel_below
Ncurses İşlevleri


Returns the panel below panel

ncurses_panel_above
ncurses_panel_window
Ncurses İşlevleri
PHP Manual

ncurses_panel_below

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_panel_below — Returns the panel below panel

Açıklama

resource ncurses_panel_below ( resource $panel )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

panel

Değiştirgeler

If panel is null, returns the top panel in the stack.

ncurses_panel_above
ncurses_panel_window
Ncurses İşlevleri


Returns the window associated with panel

ncurses_panel_below
ncurses_pnoutrefresh
Ncurses İşlevleri
PHP Manual

ncurses_panel_window

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_panel_window — Returns the window associated with panel

Açıklama

resource ncurses_panel_window ( resource $panel )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

panel

ncurses_panel_below
ncurses_pnoutrefresh
Ncurses İşlevleri


Copies a region from a pad into the virtual screen

ncurses_panel_window
ncurses_prefresh
Ncurses İşlevleri
PHP Manual

ncurses_pnoutrefresh

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_pnoutrefresh — Copies a region from a pad into the virtual screen

Açıklama

int ncurses_pnoutrefresh ( resource $pad , int $pminrow , int $pmincol , int $sminrow , int $smincol , int $smaxrow , int $smaxcol )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

pad

pminrow

pmincol

sminrow

smincol

smaxrow

smaxcol

ncurses_panel_window
ncurses_prefresh
Ncurses İşlevleri


Copies a region from a pad into the virtual screen

ncurses_pnoutrefresh
ncurses_putp
Ncurses İşlevleri
PHP Manual

ncurses_prefresh

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_prefresh — Copies a region from a pad into the virtual screen

Açıklama

int ncurses_prefresh ( resource $pad , int $pminrow , int $pmincol , int $sminrow , int $smincol , int $smaxrow , int $smaxcol )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

pad

pminrow

pmincol

sminrow

smincol

smaxrow

smaxcol

ncurses_pnoutrefresh
ncurses_putp
Ncurses İşlevleri


Apply padding information to the string and output it

ncurses_prefresh
ncurses_qiflush
Ncurses İşlevleri
PHP Manual

ncurses_putp

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_putp — Apply padding information to the string and output it

Açıklama

int ncurses_putp ( string $text )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

text

ncurses_prefresh
ncurses_qiflush
Ncurses İşlevleri


Flush on signal characters

ncurses_putp
ncurses_raw
Ncurses İşlevleri
PHP Manual

ncurses_qiflush

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_qiflush — Flush on signal characters

Açıklama

void ncurses_qiflush ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ncurses_putp
ncurses_raw
Ncurses İşlevleri


Switch terminal into raw mode

ncurses_qiflush
ncurses_refresh
Ncurses İşlevleri
PHP Manual

ncurses_raw

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_raw — Switch terminal into raw mode

Açıklama

bool ncurses_raw ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Places the terminal in raw mode. Raw mode is similar to cbreak mode, in that characters typed are immediately passed through to the user program. The difference is that in raw mode, the interrupt, quit, suspend and flow control characters are all passed through uninterpreted, instead of generating a signal.

Dönen Değerler

Returns TRUE if any error occurred, otherwise FALSE.

Ayrıca Bakınız

  • ncurses_noraw() - Switch terminal out of raw mode
  • ncurses_cbreak() - Switch off input buffering
  • ncurses_nocbreak() - Switch terminal to cooked mode

ncurses_qiflush
ncurses_refresh
Ncurses İşlevleri


Refresh screen

ncurses_raw
ncurses_replace_panel
Ncurses İşlevleri
PHP Manual

ncurses_refresh

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_refresh — Refresh screen

Açıklama

int ncurses_refresh ( int $ch )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

ch

ncurses_raw
ncurses_replace_panel
Ncurses İşlevleri


Replaces the window associated with panel

ncurses_refresh
ncurses_reset_prog_mode
Ncurses İşlevleri
PHP Manual

ncurses_replace_panel

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_replace_panel — Replaces the window associated with panel

Açıklama

int ncurses_replace_panel ( resource $panel , resource $window )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

panel

window

ncurses_refresh
ncurses_reset_prog_mode
Ncurses İşlevleri


Resets the prog mode saved by def_prog_mode

ncurses_replace_panel
ncurses_reset_shell_mode
Ncurses İşlevleri
PHP Manual

ncurses_reset_prog_mode

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_reset_prog_mode — Resets the prog mode saved by def_prog_mode

Açıklama

int ncurses_reset_prog_mode ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ncurses_replace_panel
ncurses_reset_shell_mode
Ncurses İşlevleri


Resets the shell mode saved by def_shell_mode

ncurses_reset_prog_mode
ncurses_resetty
Ncurses İşlevleri
PHP Manual

ncurses_reset_shell_mode

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_reset_shell_mode — Resets the shell mode saved by def_shell_mode

Açıklama

int ncurses_reset_shell_mode ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ncurses_reset_prog_mode
ncurses_resetty
Ncurses İşlevleri


Restores saved terminal state

ncurses_reset_shell_mode
ncurses_savetty
Ncurses İşlevleri
PHP Manual

ncurses_resetty

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_resetty — Restores saved terminal state

Açıklama

bool ncurses_resetty ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Restores the terminal state, which was previously saved by calling ncurses_savetty().

Dönen Değerler

Always returns FALSE.

Ayrıca Bakınız

  • ncurses_savetty() - Saves terminal state

ncurses_reset_shell_mode
ncurses_savetty
Ncurses İşlevleri


Saves terminal state

ncurses_resetty
ncurses_scr_dump
Ncurses İşlevleri
PHP Manual

ncurses_savetty

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_savetty — Saves terminal state

Açıklama

bool ncurses_savetty ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Saves the current terminal state. The saved terminal state can be restored with ncurses_resetty().

Dönen Değerler

Always returns FALSE.

Ayrıca Bakınız

  • ncurses_resetty() - Restores saved terminal state

ncurses_resetty
ncurses_scr_dump
Ncurses İşlevleri


Dump screen content to file

ncurses_savetty
ncurses_scr_init
Ncurses İşlevleri
PHP Manual

ncurses_scr_dump

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_scr_dump — Dump screen content to file

Açıklama

int ncurses_scr_dump ( string $filename )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

filename

ncurses_savetty
ncurses_scr_init
Ncurses İşlevleri


Initialize screen from file dump

ncurses_scr_dump
ncurses_scr_restore
Ncurses İşlevleri
PHP Manual

ncurses_scr_init

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_scr_init — Initialize screen from file dump

Açıklama

int ncurses_scr_init ( string $filename )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

filename

ncurses_scr_dump
ncurses_scr_restore
Ncurses İşlevleri


Restore screen from file dump

ncurses_scr_init
ncurses_scr_set
Ncurses İşlevleri
PHP Manual

ncurses_scr_restore

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_scr_restore — Restore screen from file dump

Açıklama

int ncurses_scr_restore ( string $filename )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

filename

ncurses_scr_init
ncurses_scr_set
Ncurses İşlevleri


Inherit screen from file dump

ncurses_scr_restore
ncurses_scrl
Ncurses İşlevleri
PHP Manual

ncurses_scr_set

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_scr_set — Inherit screen from file dump

Açıklama

int ncurses_scr_set ( string $filename )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

filename

ncurses_scr_restore
ncurses_scrl
Ncurses İşlevleri


Scroll window content up or down without changing current position

ncurses_scr_set
ncurses_show_panel
Ncurses İşlevleri
PHP Manual

ncurses_scrl

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_scrl — Scroll window content up or down without changing current position

Açıklama

int ncurses_scrl ( int $count )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

count

ncurses_scr_set
ncurses_show_panel
Ncurses İşlevleri


Places an invisible panel on top of the stack, making it visible

ncurses_scrl
ncurses_slk_attr
Ncurses İşlevleri
PHP Manual

ncurses_show_panel

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_show_panel — Places an invisible panel on top of the stack, making it visible

Açıklama

int ncurses_show_panel ( resource $panel )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

panel

ncurses_scrl
ncurses_slk_attr
Ncurses İşlevleri


Returns current soft label key attribute

ncurses_show_panel
ncurses_slk_attroff
Ncurses İşlevleri
PHP Manual

ncurses_slk_attr

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_slk_attr — Returns current soft label key attribute

Açıklama

int ncurses_slk_attr ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Returns the current soft label key attribute.

Dönen Değerler

The attribute, as an integer.

ncurses_show_panel
ncurses_slk_attroff
Ncurses İşlevleri


Turn off the given attributes for soft function-key labels

ncurses_slk_attr
ncurses_slk_attron
Ncurses İşlevleri
PHP Manual

ncurses_slk_attroff

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_slk_attroff — Turn off the given attributes for soft function-key labels

Açıklama

int ncurses_slk_attroff ( int $intarg )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

intarg

ncurses_slk_attr
ncurses_slk_attron
Ncurses İşlevleri


Turn on the given attributes for soft function-key labels

ncurses_slk_attroff
ncurses_slk_attrset
Ncurses İşlevleri
PHP Manual

ncurses_slk_attron

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_slk_attron — Turn on the given attributes for soft function-key labels

Açıklama

int ncurses_slk_attron ( int $intarg )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

intarg

ncurses_slk_attroff
ncurses_slk_attrset
Ncurses İşlevleri


Set given attributes for soft function-key labels

ncurses_slk_attron
ncurses_slk_clear
Ncurses İşlevleri
PHP Manual

ncurses_slk_attrset

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_slk_attrset — Set given attributes for soft function-key labels

Açıklama

int ncurses_slk_attrset ( int $intarg )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

intarg

ncurses_slk_attron
ncurses_slk_clear
Ncurses İşlevleri


Clears soft labels from screen

ncurses_slk_attrset
ncurses_slk_color
Ncurses İşlevleri
PHP Manual

ncurses_slk_clear

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_slk_clear — Clears soft labels from screen

Açıklama

bool ncurses_slk_clear ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

The function ncurses_slk_clear() clears soft label keys from screen.

Dönen Değerler

Returns TRUE on errors, FALSE otherwise.

ncurses_slk_attrset
ncurses_slk_color
Ncurses İşlevleri


Sets color for soft label keys

ncurses_slk_clear
ncurses_slk_init
Ncurses İşlevleri
PHP Manual

ncurses_slk_color

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_slk_color — Sets color for soft label keys

Açıklama

int ncurses_slk_color ( int $intarg )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

intarg

ncurses_slk_clear
ncurses_slk_init
Ncurses İşlevleri


Initializes soft label key functions

ncurses_slk_color
ncurses_slk_noutrefresh
Ncurses İşlevleri
PHP Manual

ncurses_slk_init

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_slk_init — Initializes soft label key functions

Açıklama

bool ncurses_slk_init ( int $format )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Initializes soft label key functions

This function must be called before ncurses_init() or ncurses_newwin() is called.

Değiştirgeler

format

If ncurses_init() eventually uses a line from stdscr to emulate the soft labels, then this parameter determines how the labels are arranged of the screen.

0 indicates a 3-2-3 arrangement of the labels, 1 indicates a 4-4 arrangement and 2 indicates the PC like 4-4-4 mode, but in addition an index line will be created.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

ncurses_slk_color
ncurses_slk_noutrefresh
Ncurses İşlevleri


Copies soft label keys to virtual screen

ncurses_slk_init
ncurses_slk_refresh
Ncurses İşlevleri
PHP Manual

ncurses_slk_noutrefresh

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_slk_noutrefresh — Copies soft label keys to virtual screen

Açıklama

bool ncurses_slk_noutrefresh ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ncurses_slk_init
ncurses_slk_refresh
Ncurses İşlevleri


Copies soft label keys to screen

ncurses_slk_noutrefresh
ncurses_slk_restore
Ncurses İşlevleri
PHP Manual

ncurses_slk_refresh

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_slk_refresh — Copies soft label keys to screen

Açıklama

int ncurses_slk_refresh ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Copies soft label keys from virtual screen to physical screen.

ncurses_slk_noutrefresh
ncurses_slk_restore
Ncurses İşlevleri


Restores soft label keys

ncurses_slk_refresh
ncurses_slk_set
Ncurses İşlevleri
PHP Manual

ncurses_slk_restore

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_slk_restore — Restores soft label keys

Açıklama

int ncurses_slk_restore ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Restores the soft label keys after ncurses_slk_clear() has been performed.

ncurses_slk_refresh
ncurses_slk_set
Ncurses İşlevleri


Sets function key labels

ncurses_slk_restore
ncurses_slk_touch
Ncurses İşlevleri
PHP Manual

ncurses_slk_set

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_slk_set — Sets function key labels

Açıklama

bool ncurses_slk_set ( int $labelnr , string $label , int $format )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

labelnr

label

format

ncurses_slk_restore
ncurses_slk_touch
Ncurses İşlevleri


Forces output when ncurses_slk_noutrefresh is performed

ncurses_slk_set
ncurses_standend
Ncurses İşlevleri
PHP Manual

ncurses_slk_touch

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_slk_touch — Forces output when ncurses_slk_noutrefresh is performed

Açıklama

int ncurses_slk_touch ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Forces all the soft labels to be output the next time a ncurses_slk_noutrefresh() is performed.

ncurses_slk_set
ncurses_standend
Ncurses İşlevleri


Stop using 'standout' attribute

ncurses_slk_touch
ncurses_standout
Ncurses İşlevleri
PHP Manual

ncurses_standend

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_standend — Stop using 'standout' attribute

Açıklama

int ncurses_standend ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ncurses_slk_touch
ncurses_standout
Ncurses İşlevleri


Start using 'standout' attribute

ncurses_standend
ncurses_start_color
Ncurses İşlevleri
PHP Manual

ncurses_standout

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_standout — Start using 'standout' attribute

Açıklama

int ncurses_standout ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ncurses_standend
ncurses_start_color
Ncurses İşlevleri


Initializes color functionality

ncurses_standout
ncurses_termattrs
Ncurses İşlevleri
PHP Manual

ncurses_start_color

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_start_color — Initializes color functionality

Açıklama

int ncurses_start_color ( void )

Initializes color functionality in ncurses. This function must be called before any color manipulation functions are called and after ncurses_init() is called. It is good practice to call this function right after ncurses_init().

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns 0 on success, or -1 if the color table could not be allocated or ncurses was not initialized.

Örnekler

Örnek 1 Writing a string with a specified color to the screen

<?php
ncurses_init();

// If the terminal supports colors, initialize and set active color
if (ncurses_has_colors()) {
    ncurses_start_color();
    ncurses_init_pair(1, NCURSES_COLOR_YELLOW, NCURSES_COLOR_BLUE);
    ncurses_color_set(1);
}

// Write a string at specified location
ncurses_mvaddstr(10, 10, "Hello world! Yellow on blue text!");

// Flush output to screen
ncurses_refresh();

ncurses_end();
?>

Ayrıca Bakınız

  • ncurses_can_change_color() - Checks if terminal color definitions can be changed
  • ncurses_has_colors() - Checks if terminal has color capabilities

ncurses_standout
ncurses_termattrs
Ncurses İşlevleri


Returns a logical OR of all attribute flags supported by terminal

ncurses_start_color
ncurses_termname
Ncurses İşlevleri
PHP Manual

ncurses_termattrs

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_termattrs — Returns a logical OR of all attribute flags supported by terminal

Açıklama

bool ncurses_termattrs ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ncurses_start_color
ncurses_termname
Ncurses İşlevleri


Returns terminals (short)-name

ncurses_termattrs
ncurses_timeout
Ncurses İşlevleri
PHP Manual

ncurses_termname

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_termname — Returns terminals (short)-name

Açıklama

string ncurses_termname ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Returns terminals shortname.

Dönen Değerler

Returns the shortname of the terminal, truncated to 14 characters. On errors, returns NULL.

Ayrıca Bakınız

  • ncurses_longname() - Returns terminals description

ncurses_termattrs
ncurses_timeout
Ncurses İşlevleri


Set timeout for special key sequences

ncurses_termname
ncurses_top_panel
Ncurses İşlevleri
PHP Manual

ncurses_timeout

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_timeout — Set timeout for special key sequences

Açıklama

void ncurses_timeout ( int $millisec )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

millisec

ncurses_termname
ncurses_top_panel
Ncurses İşlevleri


Moves a visible panel to the top of the stack

ncurses_timeout
ncurses_typeahead
Ncurses İşlevleri
PHP Manual

ncurses_top_panel

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_top_panel — Moves a visible panel to the top of the stack

Açıklama

int ncurses_top_panel ( resource $panel )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

panel

ncurses_timeout
ncurses_typeahead
Ncurses İşlevleri


Specify different filedescriptor for typeahead checking

ncurses_top_panel
ncurses_ungetch
Ncurses İşlevleri
PHP Manual

ncurses_typeahead

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_typeahead — Specify different filedescriptor for typeahead checking

Açıklama

int ncurses_typeahead ( int $fd )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

fd

ncurses_top_panel
ncurses_ungetch
Ncurses İşlevleri


Put a character back into the input stream

ncurses_typeahead
ncurses_ungetmouse
Ncurses İşlevleri
PHP Manual

ncurses_ungetch

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_ungetch — Put a character back into the input stream

Açıklama

int ncurses_ungetch ( int $keycode )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

keycode

ncurses_typeahead
ncurses_ungetmouse
Ncurses İşlevleri


Pushes mouse event to queue

ncurses_ungetch
ncurses_update_panels
Ncurses İşlevleri
PHP Manual

ncurses_ungetmouse

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_ungetmouse — Pushes mouse event to queue

Açıklama

bool ncurses_ungetmouse ( array $mevent )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Pushes a KEY_MOUSE event onto the input queue and associates with this event the given state data and screen-relative character cell coordinates, specified in mevent.

Değiştirgeler

mevent

An associative array specifying the event options:

  • "id" : Id to distinguish multiple devices

  • "x" : screen relative x-position in character cells

  • "y" : screen relative y-position in character cells

  • "z" : currently not supported

  • "mmask" : Mouse action

Dönen Değerler

Returns FALSE on success, TRUE otherwise.

Ayrıca Bakınız

  • ncurses_getmouse() - Reads mouse event

ncurses_ungetch
ncurses_update_panels
Ncurses İşlevleri


Refreshes the virtual screen to reflect the relations between panels in the stack

ncurses_ungetmouse
ncurses_use_default_colors
Ncurses İşlevleri
PHP Manual

ncurses_update_panels

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_update_panels — Refreshes the virtual screen to reflect the relations between panels in the stack

Açıklama

void ncurses_update_panels ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ncurses_ungetmouse
ncurses_use_default_colors
Ncurses İşlevleri


Assign terminal default colors to color id -1

ncurses_update_panels
ncurses_use_env
Ncurses İşlevleri
PHP Manual

ncurses_use_default_colors

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_use_default_colors — Assign terminal default colors to color id -1

Açıklama

bool ncurses_use_default_colors ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ncurses_update_panels
ncurses_use_env
Ncurses İşlevleri


Control use of environment information about terminal size

ncurses_use_default_colors
ncurses_use_extended_names
Ncurses İşlevleri
PHP Manual

ncurses_use_env

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_use_env — Control use of environment information about terminal size

Açıklama

void ncurses_use_env ( bool $flag )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

flag

ncurses_use_default_colors
ncurses_use_extended_names
Ncurses İşlevleri


Control use of extended names in terminfo descriptions

ncurses_use_env
ncurses_vidattr
Ncurses İşlevleri
PHP Manual

ncurses_use_extended_names

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_use_extended_names — Control use of extended names in terminfo descriptions

Açıklama

int ncurses_use_extended_names ( bool $flag )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

flag

ncurses_use_env
ncurses_vidattr
Ncurses İşlevleri


Display the string on the terminal in the video attribute mode

ncurses_use_extended_names
ncurses_vline
Ncurses İşlevleri
PHP Manual

ncurses_vidattr

(PHP 4 >= 4.0.7, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_vidattr — Display the string on the terminal in the video attribute mode

Açıklama

int ncurses_vidattr ( int $intarg )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

intarg

ncurses_use_extended_names
ncurses_vline
Ncurses İşlevleri


Draw a vertical line at current position using an attributed character and max. n characters long

ncurses_vidattr
ncurses_waddch
Ncurses İşlevleri
PHP Manual

ncurses_vline

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_vline — Draw a vertical line at current position using an attributed character and max. n characters long

Açıklama

int ncurses_vline ( int $charattr , int $n )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

charattr

n

ncurses_vidattr
ncurses_waddch
Ncurses İşlevleri


Adds character at current position in a window and advance cursor

ncurses_vline
ncurses_waddstr
Ncurses İşlevleri
PHP Manual

ncurses_waddch

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_waddch — Adds character at current position in a window and advance cursor

Açıklama

int ncurses_waddch ( resource $window , int $ch )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

window

ch

ncurses_vline
ncurses_waddstr
Ncurses İşlevleri


Outputs text at current postion in window

ncurses_waddch
ncurses_wattroff
Ncurses İşlevleri
PHP Manual

ncurses_waddstr

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_waddstr — Outputs text at current postion in window

Açıklama

int ncurses_waddstr ( resource $window , string $str [, int $n ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

window

str

n

ncurses_waddch
ncurses_wattroff
Ncurses İşlevleri


Turns off attributes for a window

ncurses_waddstr
ncurses_wattron
Ncurses İşlevleri
PHP Manual

ncurses_wattroff

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_wattroff — Turns off attributes for a window

Açıklama

int ncurses_wattroff ( resource $window , int $attrs )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

window

attrs

ncurses_waddstr
ncurses_wattron
Ncurses İşlevleri


Turns on attributes for a window

ncurses_wattroff
ncurses_wattrset
Ncurses İşlevleri
PHP Manual

ncurses_wattron

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_wattron — Turns on attributes for a window

Açıklama

int ncurses_wattron ( resource $window , int $attrs )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

window

attrs

ncurses_wattroff
ncurses_wattrset
Ncurses İşlevleri


Set the attributes for a window

ncurses_wattron
ncurses_wborder
Ncurses İşlevleri
PHP Manual

ncurses_wattrset

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_wattrset — Set the attributes for a window

Açıklama

int ncurses_wattrset ( resource $window , int $attrs )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

window

attrs

ncurses_wattron
ncurses_wborder
Ncurses İşlevleri


Draws a border around the window using attributed characters

ncurses_wattrset
ncurses_wclear
Ncurses İşlevleri
PHP Manual

ncurses_wborder

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_wborder — Draws a border around the window using attributed characters

Açıklama

int ncurses_wborder ( resource $window , int $left , int $right , int $top , int $bottom , int $tl_corner , int $tr_corner , int $bl_corner , int $br_corner )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Draws the specified lines and corners around the passed window.

Use ncurses_border() for borders around the main window.

Değiştirgeler

Each parameter expects 0 to draw a line and 1 to skip it.

window

The window on which we operate

left

right

top

bottom

tl_corner

Top left corner

tr_corner

Top right corner

bl_corner

Bottom left corner

br_corner

Bottom right corner

Ayrıca Bakınız

  • ncurses_border() - Draw a border around the screen using attributed characters

ncurses_wattrset
ncurses_wclear
Ncurses İşlevleri


Clears window

ncurses_wborder
ncurses_wcolor_set
Ncurses İşlevleri
PHP Manual

ncurses_wclear

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_wclear — Clears window

Açıklama

int ncurses_wclear ( resource $window )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

window

ncurses_wborder
ncurses_wcolor_set
Ncurses İşlevleri


Sets windows color pairings

ncurses_wclear
ncurses_werase
Ncurses İşlevleri
PHP Manual

ncurses_wcolor_set

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_wcolor_set — Sets windows color pairings

Açıklama

int ncurses_wcolor_set ( resource $window , int $color_pair )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

window

color_pair

ncurses_wclear
ncurses_werase
Ncurses İşlevleri


Erase window contents

ncurses_wcolor_set
ncurses_wgetch
Ncurses İşlevleri
PHP Manual

ncurses_werase

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_werase — Erase window contents

Açıklama

int ncurses_werase ( resource $window )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

window

ncurses_wcolor_set
ncurses_wgetch
Ncurses İşlevleri


Reads a character from keyboard (window)

ncurses_werase
ncurses_whline
Ncurses İşlevleri
PHP Manual

ncurses_wgetch

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_wgetch — Reads a character from keyboard (window)

Açıklama

int ncurses_wgetch ( resource $window )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

window

ncurses_werase
ncurses_whline
Ncurses İşlevleri


Draws a horizontal line in a window at current position using an attributed character and max. n characters long

ncurses_wgetch
ncurses_wmouse_trafo
Ncurses İşlevleri
PHP Manual

ncurses_whline

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_whline — Draws a horizontal line in a window at current position using an attributed character and max. n characters long

Açıklama

int ncurses_whline ( resource $window , int $charattr , int $n )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

window

charattr

n

ncurses_wgetch
ncurses_wmouse_trafo
Ncurses İşlevleri


Transforms window/stdscr coordinates

ncurses_whline
ncurses_wmove
Ncurses İşlevleri
PHP Manual

ncurses_wmouse_trafo

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_wmouse_trafo — Transforms window/stdscr coordinates

Açıklama

bool ncurses_wmouse_trafo ( resource $window , int &$y , int &$x , bool $toscreen )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

window

x

y

toscreen

ncurses_whline
ncurses_wmove
Ncurses İşlevleri


Moves windows output position

ncurses_wmouse_trafo
ncurses_wnoutrefresh
Ncurses İşlevleri
PHP Manual

ncurses_wmove

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_wmove — Moves windows output position

Açıklama

int ncurses_wmove ( resource $window , int $y , int $x )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

window

y

x

ncurses_wmouse_trafo
ncurses_wnoutrefresh
Ncurses İşlevleri


Copies window to virtual screen

ncurses_wmove
ncurses_wrefresh
Ncurses İşlevleri
PHP Manual

ncurses_wnoutrefresh

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_wnoutrefresh — Copies window to virtual screen

Açıklama

int ncurses_wnoutrefresh ( resource $window )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

window

ncurses_wmove
ncurses_wrefresh
Ncurses İşlevleri


Refresh window on terminal screen

ncurses_wnoutrefresh
ncurses_wstandend
Ncurses İşlevleri
PHP Manual

ncurses_wrefresh

(PHP 4 >= 4.2.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_wrefresh — Refresh window on terminal screen

Açıklama

int ncurses_wrefresh ( resource $window )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

window

ncurses_wnoutrefresh
ncurses_wstandend
Ncurses İşlevleri


End standout mode for a window

ncurses_wrefresh
ncurses_wstandout
Ncurses İşlevleri
PHP Manual

ncurses_wstandend

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_wstandend — End standout mode for a window

Açıklama

int ncurses_wstandend ( resource $window )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

window

ncurses_wrefresh
ncurses_wstandout
Ncurses İşlevleri


Enter standout mode for a window

ncurses_wstandend
ncurses_wvline
Ncurses İşlevleri
PHP Manual

ncurses_wstandout

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_wstandout — Enter standout mode for a window

Açıklama

int ncurses_wstandout ( resource $window )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

window

ncurses_wstandend
ncurses_wvline
Ncurses İşlevleri


Draws a vertical line in a window at current position using an attributed character and max. n characters long

ncurses_wstandout
Newt
Ncurses İşlevleri
PHP Manual

ncurses_wvline

(PHP 4 >= 4.3.0, PHP 5 < 5.3.0, PECL ncurses >= 1.0.0)

ncurses_wvline — Draws a vertical line in a window at current position using an attributed character and max. n characters long

Açıklama

int ncurses_wvline ( resource $window , int $charattr , int $n )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

window

charattr

n

ncurses_wstandout
Newt
Ncurses İşlevleri


Newt

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
    • Newt form exit reasons
    • Newt colorsets
    • Newt argument flags
    • Newt Flags Sense
    • Newt Components Flags
    • File Descriptor Flags
    • Checkbox Tree Flags
    • Entry Flags
    • Listbox Flags
    • Textbox Flags
    • Form Flags
    • Newt Keys
    • Newt Anchors
    • Grid Flags
  • Örnekler
    • Basic usage
  • Newt İşlevleri
    • newt_bell — Send a beep to the terminal
    • newt_button_bar — This function returns a grid containing the buttons created.
    • newt_button — Create a new button
    • newt_centered_window — Open a centered window of the specified size
    • newt_checkbox_get_value — Retreives value of checkox resource
    • newt_checkbox_set_flags — Configures checkbox resource
    • newt_checkbox_set_value — Sets the value of the checkbox
    • newt_checkbox_tree_add_item — Adds new item to the checkbox tree
    • newt_checkbox_tree_find_item — Finds an item in the checkbox tree
    • newt_checkbox_tree_get_current — Returns checkbox tree selected item
    • newt_checkbox_tree_get_entry_value — Açıklama
    • newt_checkbox_tree_get_multi_selection — Açıklama
    • newt_checkbox_tree_get_selection — Açıklama
    • newt_checkbox_tree_multi — Açıklama
    • newt_checkbox_tree_set_current — Açıklama
    • newt_checkbox_tree_set_entry_value — Açıklama
    • newt_checkbox_tree_set_entry — Açıklama
    • newt_checkbox_tree_set_width — Açıklama
    • newt_checkbox_tree — Açıklama
    • newt_checkbox — Açıklama
    • newt_clear_key_buffer — Discards the contents of the terminal's input buffer without waiting for additional input
    • newt_cls — Açıklama
    • newt_compact_button — Açıklama
    • newt_component_add_callback — Açıklama
    • newt_component_takes_focus — Açıklama
    • newt_create_grid — Açıklama
    • newt_cursor_off — Açıklama
    • newt_cursor_on — Açıklama
    • newt_delay — Açıklama
    • newt_draw_form — Açıklama
    • newt_draw_root_text — Displays the string text at the position indicated
    • newt_entry_get_value — Açıklama
    • newt_entry_set_filter — Açıklama
    • newt_entry_set_flags — Açıklama
    • newt_entry_set — Açıklama
    • newt_entry — Açıklama
    • newt_finished — Uninitializes newt interface
    • newt_form_add_component — Adds a single component to the form
    • newt_form_add_components — Add several components to the form
    • newt_form_add_hot_key — Açıklama
    • newt_form_destroy — Destroys a form
    • newt_form_get_current — Açıklama
    • newt_form_run — Runs a form
    • newt_form_set_background — Açıklama
    • newt_form_set_height — Açıklama
    • newt_form_set_size — Açıklama
    • newt_form_set_timer — Açıklama
    • newt_form_set_width — Açıklama
    • newt_form_watch_fd — Açıklama
    • newt_form — Create a form
    • newt_get_screen_size — Fills in the passed references with the current size of the terminal
    • newt_grid_add_components_to_form — Açıklama
    • newt_grid_basic_window — Açıklama
    • newt_grid_free — Açıklama
    • newt_grid_get_size — Açıklama
    • newt_grid_h_close_stacked — Açıklama
    • newt_grid_h_stacked — Açıklama
    • newt_grid_place — Açıklama
    • newt_grid_set_field — Açıklama
    • newt_grid_simple_window — Açıklama
    • newt_grid_v_close_stacked — Açıklama
    • newt_grid_v_stacked — Açıklama
    • newt_grid_wrapped_window_at — Açıklama
    • newt_grid_wrapped_window — Açıklama
    • newt_init — Initialize newt
    • newt_label_set_text — Açıklama
    • newt_label — Açıklama
    • newt_listbox_append_entry — Açıklama
    • newt_listbox_clear_selection — Açıklama
    • newt_listbox_clear — Açıklama
    • newt_listbox_delete_entry — Açıklama
    • newt_listbox_get_current — Açıklama
    • newt_listbox_get_selection — Açıklama
    • newt_listbox_insert_entry — Açıklama
    • newt_listbox_item_count — Açıklama
    • newt_listbox_select_item — Açıklama
    • newt_listbox_set_current_by_key — Açıklama
    • newt_listbox_set_current — Açıklama
    • newt_listbox_set_data — Açıklama
    • newt_listbox_set_entry — Açıklama
    • newt_listbox_set_width — Açıklama
    • newt_listbox — Açıklama
    • newt_listitem_get_data — Açıklama
    • newt_listitem_set — Açıklama
    • newt_listitem — Açıklama
    • newt_open_window — Open a window of the specified size and position
    • newt_pop_help_line — Replaces the current help line with the one from the stack
    • newt_pop_window — Removes the top window from the display
    • newt_push_help_line — Saves the current help line on a stack, and displays the new line
    • newt_radio_get_current — Açıklama
    • newt_radiobutton — Açıklama
    • newt_redraw_help_line — Açıklama
    • newt_reflow_text — Açıklama
    • newt_refresh — Updates modified portions of the screen
    • newt_resize_screen — Açıklama
    • newt_resume — Resume using the newt interface after calling newt_suspend
    • newt_run_form — Runs a form
    • newt_scale_set — Açıklama
    • newt_scale — Açıklama
    • newt_scrollbar_set — Açıklama
    • newt_set_help_callback — Açıklama
    • newt_set_suspend_callback — Set a callback function which gets invoked when user presses the suspend key
    • newt_suspend — Tells newt to return the terminal to its initial state
    • newt_textbox_get_num_lines — Açıklama
    • newt_textbox_reflowed — Açıklama
    • newt_textbox_set_height — Açıklama
    • newt_textbox_set_text — Açıklama
    • newt_textbox — Açıklama
    • newt_vertical_scrollbar — Açıklama
    • newt_wait_for_key — Doesn't return until a key has been pressed
    • newt_win_choice — Açıklama
    • newt_win_entries — Açıklama
    • newt_win_menu — Açıklama
    • newt_win_message — Açıklama
    • newt_win_messagev — Açıklama
    • newt_win_ternary — Açıklama
ncurses_wvline
Giriş
Komut Satırına Özgü Eklentiler


Giriş

This is a PHP language extension for RedHat Newt library, a terminal-based window and widget library for writing applications with user friendly interface. Once this extension is enabled in PHP it will provide the use of Newt widgets, such as windows, buttons, checkboxes, radiobuttons, labels, editboxes, scrolls, textareas, scales, etc. Use of this extension is very similar to the original Newt API of C programming language.

Newt
Yapılandırma/Kurulum
Newt


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Newt


Gereksinimler

This module uses the functions of the RedHat Newt library. You need libnewt version >= 0.51.0.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu » PECL eklentisi PHP ile gelmez. Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/newt.

In order to use these functions you must compile CGI or CLI PHP with newt support by using the --with-newt[=DIR] configure option.

Bilginize:

This extension is not available for Windows platform.

You may need also curses and slang libraries, in order to compile this extension. To specify locations of these libraries, use the following configuration options: --with-curses-dir=/path/to/libcurses --with-slang-dir=/path/to/libslang

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Özkaynak Türleri

This extension uses two resource types: "newt component" and "newt grid".

Resource type "newt component" is returned by functions, which create common newt widgets (for example: newt_button())

Resource type "newt grid" is a special link identifier for components, returned by newt grid factory functions (for example: newt_create_grid())

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

İçindekiler

  • Newt form exit reasons
  • Newt colorsets
  • Newt argument flags
  • Newt Flags Sense
  • Newt Components Flags
  • File Descriptor Flags
  • Checkbox Tree Flags
  • Entry Flags
  • Listbox Flags
  • Textbox Flags
  • Form Flags
  • Newt Keys
  • Newt Anchors
  • Grid Flags

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

Özkaynak Türleri
Newt form exit reasons
Newt


Newt form exit reasons

Newt form exit reasons
constant | meaning
NEWT_EXIT_HOTKEY | hotkey defined by newt_form_add_hot_key() was pressed
NEWT_EXIT_COMPONENT | some component has caused form to exit
NEWT_EXIT_FDREADY | file descriptor specified in newt_form_watch_fd() is ready to be read or written to
NEWT_EXIT_TIMER | time specified in newt_form_set_timer() has elapsed
Öntanımlı Sabitler
Newt colorsets
Öntanımlı Sabitler


Newt colorsets

Newt colorsets
constant | meaning
NEWT_COLORSET_ROOT |
NEWT_COLORSET_BORDER |
NEWT_COLORSET_WINDOW |
NEWT_COLORSET_SHADOW |
NEWT_COLORSET_TITLE |
NEWT_COLORSET_BUTTON |
NEWT_COLORSET_ACTBUTTON |
NEWT_COLORSET_CHECKBOX |
NEWT_COLORSET_ACTCHECKBOX |
NEWT_COLORSET_ENTRY |
NEWT_COLORSET_LABEL |
NEWT_COLORSET_LISTBOX |
NEWT_COLORSET_ACTLISTBOX |
NEWT_COLORSET_TEXTBOX |
NEWT_COLORSET_ACTTEXTBOX |
NEWT_COLORSET_HELPLINE |
NEWT_COLORSET_ROOTTEXT |
NEWT_COLORSET_EMPTYSCALE |
NEWT_COLORSET_FULLSCALE |
NEWT_COLORSET_DISENTRY |
NEWT_COLORSET_COMPACTBUTTON |
NEWT_COLORSET_ACTSELLISTBOX |
NEWT_COLORSET_SELLISTBOX |
Newt form exit reasons
Newt argument flags
Öntanımlı Sabitler


Newt argument flags

Newt argument flags
constant | meaning
NEWT_ARG_LAST |
NEWT_ARG_APPEND |
Newt colorsets
Newt Flags Sense
Öntanımlı Sabitler


Newt Flags Sense

Newt Flags Sense
constant | meaning
NEWT_FLAGS_SET |
NEWT_FLAGS_RESET |
NEWT_FLAGS_TOGGLE |
Newt argument flags
Newt Components Flags
Öntanımlı Sabitler


Newt Components Flags

Newt Components Flags
constant | meaning
NEWT_FLAG_RETURNEXIT | Exit form, when component is activated
NEWT_FLAG_HIDDEN | Component is hidden
NEWT_FLAG_SCROLL | Component is scrollable
NEWT_FLAG_DISABLED | Component is disabled
NEWT_FLAG_BORDER |
NEWT_FLAG_WRAP | Wrap text
NEWT_FLAG_NOF12 | Don't exit form on pressing F12
NEWT_FLAG_MULTIPLE |
NEWT_FLAG_SELECTED | Component is selected
NEWT_FLAG_CHECKBOX | Component is checkbox
NEWT_FLAG_PASSWORD | Entry component is password entry
NEWT_FLAG_SHOWCURSOR | Show cursor
Newt Flags Sense
File Descriptor Flags
Öntanımlı Sabitler


File Descriptor Flags

File Descriptor Flags
constant | meaning
NEWT_FD_READ |
NEWT_FD_WRITE |
NEWT_FD_EXCEPT |
Newt Components Flags
Checkbox Tree Flags
Öntanımlı Sabitler


Checkbox Tree Flags

Checkbox Tree Flags
constant | meaning
NEWT_CHECKBOXTREE_UNSELECTABLE |
NEWT_CHECKBOXTREE_HIDE_BOX |
NEWT_CHECKBOXTREE_COLLAPSED |
NEWT_CHECKBOXTREE_EXPANDED |
NEWT_CHECKBOXTREE_UNSELECTED |
NEWT_CHECKBOXTREE_SELECTED |
File Descriptor Flags
Entry Flags
Öntanımlı Sabitler


Entry Flags

Entry Flags
constant | meaning
NEWT_ENTRY_SCROLL |
NEWT_ENTRY_HIDDEN |
NEWT_ENTRY_RETURNEXIT |
NEWT_ENTRY_DISABLED |
Checkbox Tree Flags
Listbox Flags
Öntanımlı Sabitler


Listbox Flags

Listbox Flags
constant | meaning
NEWT_LISTBOX_RETURNEXIT |
Entry Flags
Textbox Flags
Öntanımlı Sabitler


Textbox Flags

Textbox Flags
constant | meaning
NEWT_TEXTBOX_WRAP | Wrap text in the textbox
NEWT_TEXTBOX_SCROLL | Scroll text in the textbox
Listbox Flags
Form Flags
Öntanımlı Sabitler


Form Flags

Form Flags
constant | meaning
NEWT_FORM_NOF12 | Don't exit form on F12 press
Textbox Flags
Newt Keys
Öntanımlı Sabitler


Newt Keys

Newt Keys
constant | meaning
NEWT_KEY_TAB |
NEWT_KEY_ENTER |
NEWT_KEY_SUSPEND |
NEWT_KEY_ESCAPE |
NEWT_KEY_RETURN |
NEWT_KEY_EXTRA_BASE |
NEWT_KEY_UP |
NEWT_KEY_DOWN |
NEWT_KEY_LEFT |
NEWT_KEY_RIGHT |
NEWT_KEY_BKSPC |
NEWT_KEY_DELETE |
NEWT_KEY_HOME |
NEWT_KEY_END |
NEWT_KEY_UNTAB |
NEWT_KEY_PGUP |
NEWT_KEY_PGDN |
NEWT_KEY_INSERT |
NEWT_KEY_F1 |
NEWT_KEY_F2 |
NEWT_KEY_F3 |
NEWT_KEY_F4 |
NEWT_KEY_F5 |
NEWT_KEY_F6 |
NEWT_KEY_F7 |
NEWT_KEY_F8 |
NEWT_KEY_F9 |
NEWT_KEY_F10 |
NEWT_KEY_F11 |
NEWT_KEY_F12 |
NEWT_KEY_RESIZE |
Form Flags
Newt Anchors
Öntanımlı Sabitler


Newt Anchors

Newt Anchors
constant | meaning
NEWT_ANCHOR_LEFT |
NEWT_ANCHOR_RIGHT |
NEWT_ANCHOR_TOP |
NEWT_ANCHOR_BOTTOM |
Newt Keys
Grid Flags
Öntanımlı Sabitler


Grid Flags

Grid Flags
constant | meaning
NEWT_GRID_FLAG_GROWX |
NEWT_GRID_FLAG_GROWY |
NEWT_GRID_EMPTY |
NEWT_GRID_COMPONENT |
NEWT_GRID_SUBGRID |
Newt Anchors
Örnekler
Öntanımlı Sabitler


Örnekler

İçindekiler

  • Basic usage
Grid Flags
Basic usage
Newt


Basic usage

This example is a PHP port of RedHat 'setup' utility dialog, executed in text mode.

Örnek 1 Newt Usage Example

<?php
newt_init ();
newt_cls ();

newt_draw_root_text (0, 0, "Test Mode Setup Utility 1.12");
newt_push_help_line (null);
newt_draw_root_text (-30, 0, "(c) 1999-2002 RedHat, Inc");

newt_get_screen_size ($rows, $cols);

newt_open_window ($rows/2-17, $cols/2-10, 34, 17, "Choose a Tool");

$form = newt_form ();

$list = newt_listbox (3, 2, 10);

foreach (array (
    "Authentication configuration",
    "Firewall configuration",
    "Mouse configuration",
    "Network configuration",
    "Printer configuration",
    "System services") as $l_item)
{
    newt_listbox_add_entry ($list, $l_item, $l_item);
}

$b1 = newt_button (5, 12, "Run Tool");
$b2 = newt_button (21, 12, "Quit");

newt_form_add_component ($form, $list);
newt_form_add_components ($form, array($b1, $b2));

newt_refresh ();
newt_run_form ($form);

newt_pop_window ();
newt_pop_help_line ();
newt_finished ();
newt_form_destroy ($form);
?>
Örnekler
Newt İşlevleri
Örnekler


Newt İşlevleri

İçindekiler

  • newt_bell — Send a beep to the terminal
  • newt_button_bar — This function returns a grid containing the buttons created.
  • newt_button — Create a new button
  • newt_centered_window — Open a centered window of the specified size
  • newt_checkbox_get_value — Retreives value of checkox resource
  • newt_checkbox_set_flags — Configures checkbox resource
  • newt_checkbox_set_value — Sets the value of the checkbox
  • newt_checkbox_tree_add_item — Adds new item to the checkbox tree
  • newt_checkbox_tree_find_item — Finds an item in the checkbox tree
  • newt_checkbox_tree_get_current — Returns checkbox tree selected item
  • newt_checkbox_tree_get_entry_value — Açıklama
  • newt_checkbox_tree_get_multi_selection — Açıklama
  • newt_checkbox_tree_get_selection — Açıklama
  • newt_checkbox_tree_multi — Açıklama
  • newt_checkbox_tree_set_current — Açıklama
  • newt_checkbox_tree_set_entry_value — Açıklama
  • newt_checkbox_tree_set_entry — Açıklama
  • newt_checkbox_tree_set_width — Açıklama
  • newt_checkbox_tree — Açıklama
  • newt_checkbox — Açıklama
  • newt_clear_key_buffer — Discards the contents of the terminal's input buffer without waiting for additional input
  • newt_cls — Açıklama
  • newt_compact_button — Açıklama
  • newt_component_add_callback — Açıklama
  • newt_component_takes_focus — Açıklama
  • newt_create_grid — Açıklama
  • newt_cursor_off — Açıklama
  • newt_cursor_on — Açıklama
  • newt_delay — Açıklama
  • newt_draw_form — Açıklama
  • newt_draw_root_text — Displays the string text at the position indicated
  • newt_entry_get_value — Açıklama
  • newt_entry_set_filter — Açıklama
  • newt_entry_set_flags — Açıklama
  • newt_entry_set — Açıklama
  • newt_entry — Açıklama
  • newt_finished — Uninitializes newt interface
  • newt_form_add_component — Adds a single component to the form
  • newt_form_add_components — Add several components to the form
  • newt_form_add_hot_key — Açıklama
  • newt_form_destroy — Destroys a form
  • newt_form_get_current — Açıklama
  • newt_form_run — Runs a form
  • newt_form_set_background — Açıklama
  • newt_form_set_height — Açıklama
  • newt_form_set_size — Açıklama
  • newt_form_set_timer — Açıklama
  • newt_form_set_width — Açıklama
  • newt_form_watch_fd — Açıklama
  • newt_form — Create a form
  • newt_get_screen_size — Fills in the passed references with the current size of the terminal
  • newt_grid_add_components_to_form — Açıklama
  • newt_grid_basic_window — Açıklama
  • newt_grid_free — Açıklama
  • newt_grid_get_size — Açıklama
  • newt_grid_h_close_stacked — Açıklama
  • newt_grid_h_stacked — Açıklama
  • newt_grid_place — Açıklama
  • newt_grid_set_field — Açıklama
  • newt_grid_simple_window — Açıklama
  • newt_grid_v_close_stacked — Açıklama
  • newt_grid_v_stacked — Açıklama
  • newt_grid_wrapped_window_at — Açıklama
  • newt_grid_wrapped_window — Açıklama
  • newt_init — Initialize newt
  • newt_label_set_text — Açıklama
  • newt_label — Açıklama
  • newt_listbox_append_entry — Açıklama
  • newt_listbox_clear_selection — Açıklama
  • newt_listbox_clear — Açıklama
  • newt_listbox_delete_entry — Açıklama
  • newt_listbox_get_current — Açıklama
  • newt_listbox_get_selection — Açıklama
  • newt_listbox_insert_entry — Açıklama
  • newt_listbox_item_count — Açıklama
  • newt_listbox_select_item — Açıklama
  • newt_listbox_set_current_by_key — Açıklama
  • newt_listbox_set_current — Açıklama
  • newt_listbox_set_data — Açıklama
  • newt_listbox_set_entry — Açıklama
  • newt_listbox_set_width — Açıklama
  • newt_listbox — Açıklama
  • newt_listitem_get_data — Açıklama
  • newt_listitem_set — Açıklama
  • newt_listitem — Açıklama
  • newt_open_window — Open a window of the specified size and position
  • newt_pop_help_line — Replaces the current help line with the one from the stack
  • newt_pop_window — Removes the top window from the display
  • newt_push_help_line — Saves the current help line on a stack, and displays the new line
  • newt_radio_get_current — Açıklama
  • newt_radiobutton — Açıklama
  • newt_redraw_help_line — Açıklama
  • newt_reflow_text — Açıklama
  • newt_refresh — Updates modified portions of the screen
  • newt_resize_screen — Açıklama
  • newt_resume — Resume using the newt interface after calling newt_suspend
  • newt_run_form — Runs a form
  • newt_scale_set — Açıklama
  • newt_scale — Açıklama
  • newt_scrollbar_set — Açıklama
  • newt_set_help_callback — Açıklama
  • newt_set_suspend_callback — Set a callback function which gets invoked when user presses the suspend key
  • newt_suspend — Tells newt to return the terminal to its initial state
  • newt_textbox_get_num_lines — Açıklama
  • newt_textbox_reflowed — Açıklama
  • newt_textbox_set_height — Açıklama
  • newt_textbox_set_text — Açıklama
  • newt_textbox — Açıklama
  • newt_vertical_scrollbar — Açıklama
  • newt_wait_for_key — Doesn't return until a key has been pressed
  • newt_win_choice — Açıklama
  • newt_win_entries — Açıklama
  • newt_win_menu — Açıklama
  • newt_win_message — Açıklama
  • newt_win_messagev — Açıklama
  • newt_win_ternary — Açıklama
Basic usage
newt_bell
Newt


Send a beep to the terminal

Newt İşlevleri
newt_button_bar
Newt İşlevleri
PHP Manual

newt_bell

(PECL newt >= 0.1)

newt_bell — Send a beep to the terminal

Açıklama

void newt_bell ( void )

This function sends a beep to the terminal.

Bilginize:

Depending on the terminal's settings, this beep may or may not be audible.

Dönen Değerler

Hiçbir değer dönmez.

Newt İşlevleri
newt_button_bar
Newt İşlevleri


This function returns a grid containing the buttons created.

newt_bell
newt_button
Newt İşlevleri
PHP Manual

newt_button_bar

(PECL newt >= 0.1)

newt_button_bar — This function returns a grid containing the buttons created.

Açıklama

resource newt_button_bar ( array &$buttons )

This function returns a grid containing the buttons created.

Değiştirgeler

buttons

Dönen Değerler

Returns grid containing the buttons created.

newt_bell
newt_button
Newt İşlevleri


Create a new button

newt_button_bar
newt_centered_window
Newt İşlevleri
PHP Manual

newt_button

(PECL newt >= 0.1)

newt_button — Create a new button

Açıklama

resource newt_button ( int $left , int $top , string $text )

Creates a new button.

Değiştirgeler

left

X-coordinate of the button.

top

Y-coordinate of the button.

text

The text which should be displayed in the button.

Dönen Değerler

Returns a resource link to the created button component, or FALSE on error.

Örnekler

Örnek 1 A newt_button() example

<?php

$form = newt_form();

$ok_button = newt_button(5, 12, "Run Tool");

newt_form_add_component($form, $ok_button);

?>

Ayrıca Bakınız

  • newt_button_bar() - This function returns a grid containing the buttons created.

newt_button_bar
newt_centered_window
Newt İşlevleri


Open a centered window of the specified size

newt_button
newt_checkbox_get_value
Newt İşlevleri
PHP Manual

newt_centered_window

(PECL newt >= 0.1)

newt_centered_window — Open a centered window of the specified size

Açıklama

int newt_centered_window ( int $width , int $height [, string $title ] )

Open a centered window of the specified size.

Değiştirgeler

width

Window width

height

Window height

title

Window title

Dönen Değerler

Undefined value.

Ayrıca Bakınız

  • newt_pop_window() - Removes the top window from the display
  • newt_open_window() - Open a window of the specified size and position

newt_button
newt_checkbox_get_value
Newt İşlevleri


Retreives value of checkox resource

newt_centered_window
newt_checkbox_set_flags
Newt İşlevleri
PHP Manual

newt_checkbox_get_value

(PECL newt >= 0.1)

newt_checkbox_get_value — Retreives value of checkox resource

Açıklama

string newt_checkbox_get_value ( resource $checkbox )

This function returns the character in the sequence which indicates the current value of the checkbox.

Değiştirgeler

checkbox

Dönen Değerler

Returns character indicating the value of the checkbox.

newt_centered_window
newt_checkbox_set_flags
Newt İşlevleri


Configures checkbox resource

newt_checkbox_get_value
newt_checkbox_set_value
Newt İşlevleri
PHP Manual

newt_checkbox_set_flags

(PECL newt >= 0.1)

newt_checkbox_set_flags — Configures checkbox resource

Açıklama

void newt_checkbox_set_flags ( resource $checkbox , int $flags , int $sense )

This function allows to set various flags on checkbox resource.

Değiştirgeler

checkbox

flags

sense

Dönen Değerler

Hiçbir değer dönmez.

newt_checkbox_get_value
newt_checkbox_set_value
Newt İşlevleri


Sets the value of the checkbox

newt_checkbox_set_flags
newt_checkbox_tree_add_item
Newt İşlevleri
PHP Manual

newt_checkbox_set_value

(PECL newt >= 0.1)

newt_checkbox_set_value — Sets the value of the checkbox

Açıklama

void newt_checkbox_set_value ( resource $checkbox , string $value )

This function allows to set the current value of the checkbox resource.

Değiştirgeler

checkbox

value

Dönen Değerler

Hiçbir değer dönmez.

newt_checkbox_set_flags
newt_checkbox_tree_add_item
Newt İşlevleri


Adds new item to the checkbox tree

newt_checkbox_set_value
newt_checkbox_tree_find_item
Newt İşlevleri
PHP Manual

newt_checkbox_tree_add_item

(PECL newt >= 0.1)

newt_checkbox_tree_add_item — Adds new item to the checkbox tree

Açıklama

void newt_checkbox_tree_add_item ( resource $checkboxtree , string $text , mixed $data , int $flags , int $index [, int $... ] )

This function allows to add new item to the checkbox tree.

Değiştirgeler

checkboxtree

text

data

flags

index

Dönen Değerler

Hiçbir değer dönmez.

newt_checkbox_set_value
newt_checkbox_tree_find_item
Newt İşlevleri


Finds an item in the checkbox tree

newt_checkbox_tree_add_item
newt_checkbox_tree_get_current
Newt İşlevleri
PHP Manual

newt_checkbox_tree_find_item

(PECL newt >= 0.1)

newt_checkbox_tree_find_item — Finds an item in the checkbox tree

Açıklama

array newt_checkbox_tree_find_item ( resource $checkboxtree , mixed $data )

Finds an item in the checkbox tree by item's data.

Değiştirgeler

checkboxtree

data

Dönen Değerler

Returns checkbox tree item resource, or NULL if it wasn't found.

newt_checkbox_tree_add_item
newt_checkbox_tree_get_current
Newt İşlevleri


Returns checkbox tree selected item

newt_checkbox_tree_find_item
newt_checkbox_tree_get_entry_value
Newt İşlevleri
PHP Manual

newt_checkbox_tree_get_current

(PECL newt >= 0.1)

newt_checkbox_tree_get_current — Returns checkbox tree selected item

Açıklama

mixed newt_checkbox_tree_get_current ( resource $checkboxtree )

This method returns checkbox tree selected tem.

Değiştirgeler

checkboxtree

Dönen Değerler

Returns current (selected) checkbox tree item.

newt_checkbox_tree_find_item
newt_checkbox_tree_get_entry_value
Newt İşlevleri


newt_checkbox_tree_get_current
newt_checkbox_tree_get_multi_selection
Newt İşlevleri
PHP Manual

newt_checkbox_tree_get_entry_value

(PECL newt >= 0.1)

newt_checkbox_tree_get_entry_value —

Açıklama

string newt_checkbox_tree_get_entry_value ( resource $checkboxtree , mixed $data )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

checkboxtree

data

Dönen Değerler

newt_checkbox_tree_get_current
newt_checkbox_tree_get_multi_selection
Newt İşlevleri


newt_checkbox_tree_get_entry_value
newt_checkbox_tree_get_selection
Newt İşlevleri
PHP Manual

newt_checkbox_tree_get_multi_selection

(PECL newt >= 0.1)

newt_checkbox_tree_get_multi_selection —

Açıklama

array newt_checkbox_tree_get_multi_selection ( resource $checkboxtree , string $seqnum )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

checkboxtree

seqnum

Dönen Değerler

newt_checkbox_tree_get_entry_value
newt_checkbox_tree_get_selection
Newt İşlevleri


newt_checkbox_tree_get_multi_selection
newt_checkbox_tree_multi
Newt İşlevleri
PHP Manual

newt_checkbox_tree_get_selection

(PECL newt >= 0.1)

newt_checkbox_tree_get_selection —

Açıklama

array newt_checkbox_tree_get_selection ( resource $checkboxtree )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

checkboxtree

Dönen Değerler

newt_checkbox_tree_get_multi_selection
newt_checkbox_tree_multi
Newt İşlevleri


newt_checkbox_tree_get_selection
newt_checkbox_tree_set_current
Newt İşlevleri
PHP Manual

newt_checkbox_tree_multi

(PECL newt >= 0.1)

newt_checkbox_tree_multi —

Açıklama

resource newt_checkbox_tree_multi ( int $left , int $top , int $height , string $seq [, int $flags ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

left

top

height

seq

flags

Dönen Değerler

newt_checkbox_tree_get_selection
newt_checkbox_tree_set_current
Newt İşlevleri


newt_checkbox_tree_multi
newt_checkbox_tree_set_entry_value
Newt İşlevleri
PHP Manual

newt_checkbox_tree_set_current

(PECL newt >= 0.1)

newt_checkbox_tree_set_current —

Açıklama

void newt_checkbox_tree_set_current ( resource $checkboxtree , mixed $data )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

checkboxtree

data

Dönen Değerler

Hiçbir değer dönmez.

newt_checkbox_tree_multi
newt_checkbox_tree_set_entry_value
Newt İşlevleri


newt_checkbox_tree_set_current
newt_checkbox_tree_set_entry
Newt İşlevleri
PHP Manual

newt_checkbox_tree_set_entry_value

(PECL newt >= 0.1)

newt_checkbox_tree_set_entry_value —

Açıklama

void newt_checkbox_tree_set_entry_value ( resource $checkboxtree , mixed $data , string $value )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

checkboxtree

data

value

Dönen Değerler

Hiçbir değer dönmez.

newt_checkbox_tree_set_current
newt_checkbox_tree_set_entry
Newt İşlevleri


newt_checkbox_tree_set_entry_value
newt_checkbox_tree_set_width
Newt İşlevleri
PHP Manual

newt_checkbox_tree_set_entry

(PECL newt >= 0.1)

newt_checkbox_tree_set_entry —

Açıklama

void newt_checkbox_tree_set_entry ( resource $checkboxtree , mixed $data , string $text )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

checkboxtree

data

text

Dönen Değerler

Hiçbir değer dönmez.

newt_checkbox_tree_set_entry_value
newt_checkbox_tree_set_width
Newt İşlevleri


newt_checkbox_tree_set_entry
newt_checkbox_tree
Newt İşlevleri
PHP Manual

newt_checkbox_tree_set_width

(PECL newt >= 0.1)

newt_checkbox_tree_set_width —

Açıklama

void newt_checkbox_tree_set_width ( resource $checkbox_tree , int $width )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

checkbox_tree

width

Dönen Değerler

Hiçbir değer dönmez.

newt_checkbox_tree_set_entry
newt_checkbox_tree
Newt İşlevleri


newt_checkbox_tree_set_width
newt_checkbox
Newt İşlevleri
PHP Manual

newt_checkbox_tree

(PECL newt >= 0.1)

newt_checkbox_tree —

Açıklama

resource newt_checkbox_tree ( int $left , int $top , int $height [, int $flags ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

left

top

height

flags

Dönen Değerler

newt_checkbox_tree_set_width
newt_checkbox
Newt İşlevleri


newt_checkbox_tree
newt_clear_key_buffer
Newt İşlevleri
PHP Manual

newt_checkbox

(PECL newt >= 0.1)

newt_checkbox —

Açıklama

resource newt_checkbox ( int $left , int $top , string $text , string $def_value [, string $seq ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

left

top

text

def_value

seq

Dönen Değerler

newt_checkbox_tree
newt_clear_key_buffer
Newt İşlevleri


Discards the contents of the terminal's input buffer without waiting for additional input

newt_checkbox
newt_cls
Newt İşlevleri
PHP Manual

newt_clear_key_buffer

(PECL newt >= 0.1)

newt_clear_key_buffer — Discards the contents of the terminal's input buffer without waiting for additional input

Açıklama

void newt_clear_key_buffer ( void )

Discards the contents of the terminal's input buffer without waiting for additional input.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • newt_wait_for_key() - Doesn't return until a key has been pressed

newt_checkbox
newt_cls
Newt İşlevleri


newt_clear_key_buffer
newt_compact_button
Newt İşlevleri
PHP Manual

newt_cls

(PECL newt >= 0.1)

newt_cls —

Açıklama

void newt_cls ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Dönen Değerler

Hiçbir değer dönmez.

newt_clear_key_buffer
newt_compact_button
Newt İşlevleri


newt_cls
newt_component_add_callback
Newt İşlevleri
PHP Manual

newt_compact_button

(PECL newt >= 0.1)

newt_compact_button —

Açıklama

resource newt_compact_button ( int $left , int $top , string $text )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

left

top

text

Dönen Değerler

newt_cls
newt_component_add_callback
Newt İşlevleri


newt_compact_button
newt_component_takes_focus
Newt İşlevleri
PHP Manual

newt_component_add_callback

(PECL newt >= 0.1)

newt_component_add_callback —

Açıklama

void newt_component_add_callback ( resource $component , mixed $func_name , mixed $data )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

component

func_name

data

Dönen Değerler

Hiçbir değer dönmez.

newt_compact_button
newt_component_takes_focus
Newt İşlevleri


newt_component_add_callback
newt_create_grid
Newt İşlevleri
PHP Manual

newt_component_takes_focus

(PECL newt >= 0.1)

newt_component_takes_focus —

Açıklama

void newt_component_takes_focus ( resource $component , bool $takes_focus )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

component

takes_focus

Dönen Değerler

Hiçbir değer dönmez.

newt_component_add_callback
newt_create_grid
Newt İşlevleri


newt_component_takes_focus
newt_cursor_off
Newt İşlevleri
PHP Manual

newt_create_grid

(PECL newt >= 0.1)

newt_create_grid —

Açıklama

resource newt_create_grid ( int $cols , int $rows )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

cols

rows

Dönen Değerler

newt_component_takes_focus
newt_cursor_off
Newt İşlevleri


newt_create_grid
newt_cursor_on
Newt İşlevleri
PHP Manual

newt_cursor_off

(PECL newt >= 0.1)

newt_cursor_off —

Açıklama

void newt_cursor_off ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Dönen Değerler

Hiçbir değer dönmez.

newt_create_grid
newt_cursor_on
Newt İşlevleri


newt_cursor_off
newt_delay
Newt İşlevleri
PHP Manual

newt_cursor_on

(PECL newt >= 0.1)

newt_cursor_on —

Açıklama

void newt_cursor_on ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Dönen Değerler

Hiçbir değer dönmez.

newt_cursor_off
newt_delay
Newt İşlevleri


newt_cursor_on
newt_draw_form
Newt İşlevleri
PHP Manual

newt_delay

(PECL newt >= 0.1)

newt_delay —

Açıklama

void newt_delay ( int $microseconds )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

microseconds

Dönen Değerler

Hiçbir değer dönmez.

newt_cursor_on
newt_draw_form
Newt İşlevleri


newt_delay
newt_draw_root_text
Newt İşlevleri
PHP Manual

newt_draw_form

(PECL newt >= 0.1)

newt_draw_form —

Açıklama

void newt_draw_form ( resource $form )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

form

Dönen Değerler

Hiçbir değer dönmez.

newt_delay
newt_draw_root_text
Newt İşlevleri


Displays the string text at the position indicated

newt_draw_form
newt_entry_get_value
Newt İşlevleri
PHP Manual

newt_draw_root_text

(PECL newt >= 0.1)

newt_draw_root_text — Displays the string text at the position indicated

Açıklama

void newt_draw_root_text ( int $left , int $top , string $text )

Displays the string text at the position indicated.

Değiştirgeler

left

Column number

Bilginize:

If left is negative, the position is measured from the opposite side of the screen.

top

Line number

Bilginize:

If top is negative, the position is measured from the opposite side of the screen.

text

Text to display.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 A newt_draw_root_text() example

This code demonstrates drawing of titles in the both corners of the screen.

<?php
 newt_init();
 newt_cls();

 newt_draw_root_text (2, 0, "Some root text");
 newt_refresh();
 sleep(1);

 newt_draw_root_text (-30, 0, "Root text in the other corner");
 newt_refresh();
 sleep(1);

 newt_finished();
?>

Ayrıca Bakınız

  • newt_push_help_line() - Saves the current help line on a stack, and displays the new line
  • newt_pop_help_line() - Replaces the current help line with the one from the stack

newt_draw_form
newt_entry_get_value
Newt İşlevleri


newt_draw_root_text
newt_entry_set_filter
Newt İşlevleri
PHP Manual

newt_entry_get_value

(PECL newt >= 0.1)

newt_entry_get_value —

Açıklama

string newt_entry_get_value ( resource $entry )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

entry

Dönen Değerler

newt_draw_root_text
newt_entry_set_filter
Newt İşlevleri


newt_entry_get_value
newt_entry_set_flags
Newt İşlevleri
PHP Manual

newt_entry_set_filter

(PECL newt >= 0.1)

newt_entry_set_filter —

Açıklama

void newt_entry_set_filter ( resource $entry , callable $filter , mixed $data )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

entry

filter

data

Dönen Değerler

Hiçbir değer dönmez.

newt_entry_get_value
newt_entry_set_flags
Newt İşlevleri


newt_entry_set_filter
newt_entry_set
Newt İşlevleri
PHP Manual

newt_entry_set_flags

(PECL newt >= 0.1)

newt_entry_set_flags —

Açıklama

void newt_entry_set_flags ( resource $entry , int $flags , int $sense )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

entry

flags

sense

Dönen Değerler

Hiçbir değer dönmez.

newt_entry_set_filter
newt_entry_set
Newt İşlevleri


newt_entry_set_flags
newt_entry
Newt İşlevleri
PHP Manual

newt_entry_set

(PECL newt >= 0.1)

newt_entry_set —

Açıklama

void newt_entry_set ( resource $entry , string $value [, bool $cursor_at_end ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

entry

value

cursor_at_end

Dönen Değerler

Hiçbir değer dönmez.

newt_entry_set_flags
newt_entry
Newt İşlevleri


newt_entry_set
newt_finished
Newt İşlevleri
PHP Manual

newt_entry

(PECL newt >= 0.1)

newt_entry —

Açıklama

resource newt_entry ( int $left , int $top , int $width [, string $init_value [, int $flags ]] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

left

top

width

init_value

flags

Dönen Değerler

newt_entry_set
newt_finished
Newt İşlevleri


Uninitializes newt interface

newt_entry
newt_form_add_component
Newt İşlevleri
PHP Manual

newt_finished

(PECL newt >= 0.1)

newt_finished — Uninitializes newt interface

Açıklama

int newt_finished ( void )

Uninitializes newt interface. This function be called, when program is ready to exit.

Dönen Değerler

Returns 1 on success, 0 on failure.

Ayrıca Bakınız

  • newt_init() - Initialize newt

newt_entry
newt_form_add_component
Newt İşlevleri


Adds a single component to the form

newt_finished
newt_form_add_components
Newt İşlevleri
PHP Manual

newt_form_add_component

(PECL newt >= 0.1)

newt_form_add_component — Adds a single component to the form

Açıklama

void newt_form_add_component ( resource $form , resource $component )

Adds a single component to the form.

Değiştirgeler

form

Form to which component will be added

component

Component to add to the form

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 A newt_form_add_component() example

<?php
$form = newt_form();

$options = array("Authentication configuration", "Firewall configuration",
"Mouse configuration", "Network configuration", "Printer configuration",
"System services");

$list = newt_listbox(3, 2, 10);

foreach ($options as $l_item) {
    newt_listbox_add_entry($list, $l_item, $l_item);
}

newt_form_add_component($form, $list);
?>

Ayrıca Bakınız

  • newt_form_add_components() - Add several components to the form

newt_finished
newt_form_add_components
Newt İşlevleri


Add several components to the form

newt_form_add_component
newt_form_add_hot_key
Newt İşlevleri
PHP Manual

newt_form_add_components

(PECL newt >= 0.1)

newt_form_add_components — Add several components to the form

Açıklama

void newt_form_add_components ( resource $form , array $components )

Adds several components to the form.

Değiştirgeler

form

Form to which components will be added

components

Array of components to add to the form

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 A newt_form_add_components() example

<?php
$form = newt_form();

$b1 = newt_button(5, 12, "Run Tool");
$b2 = newt_button(21, 12, "Quit");

newt_form_add_components($form, array($b1, $b2));
?>

Ayrıca Bakınız

  • newt_form_add_component() - Adds a single component to the form

newt_form_add_component
newt_form_add_hot_key
Newt İşlevleri


newt_form_add_components
newt_form_destroy
Newt İşlevleri
PHP Manual

newt_form_add_hot_key

(PECL newt >= 0.1)

newt_form_add_hot_key —

Açıklama

void newt_form_add_hot_key ( resource $form , int $key )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

form

key

Dönen Değerler

Hiçbir değer dönmez.

newt_form_add_components
newt_form_destroy
Newt İşlevleri


Destroys a form

newt_form_add_hot_key
newt_form_get_current
Newt İşlevleri
PHP Manual

newt_form_destroy

(PECL newt >= 0.1)

newt_form_destroy — Destroys a form

Açıklama

void newt_form_destroy ( resource $form )

This function frees the memory resources used by the form and all of the components which have been added to the form (including those components which are on subforms). Once a form has been destroyed, none of the form's components can be used.

Değiştirgeler

form

Form component, which is going to be destroyed

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • newt_form_run() - Runs a form
  • newt_run_form() - Runs a form

newt_form_add_hot_key
newt_form_get_current
Newt İşlevleri


newt_form_destroy
newt_form_run
Newt İşlevleri
PHP Manual

newt_form_get_current

(PECL newt >= 0.1)

newt_form_get_current —

Açıklama

resource newt_form_get_current ( resource $form )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

form

Dönen Değerler

newt_form_destroy
newt_form_run
Newt İşlevleri


Runs a form

newt_form_get_current
newt_form_set_background
Newt İşlevleri
PHP Manual

newt_form_run

(PECL newt >= 0.1)

newt_form_run — Runs a form

Açıklama

void newt_form_run ( resource $form , array &$exit_struct )

This function runs the form passed to it.

Değiştirgeler

form

Form component

exit_struct

Array, used for returning information after running the form component. Keys and values are described in the following table:

Form Exit Structure
Index Key | Value Type | Description
reason | integer | The reason, why the form has been exited. Possible values are defined here.
watch | resource | Resource link, specified in newt_form_watch_fd()
key | integer | Hotkey
component | resource | Component, which caused the form to exit

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • newt_run_form() - Runs a form

newt_form_get_current
newt_form_set_background
Newt İşlevleri


newt_form_run
newt_form_set_height
Newt İşlevleri
PHP Manual

newt_form_set_background

(PECL newt >= 0.1)

newt_form_set_background —

Açıklama

void newt_form_set_background ( resource $from , int $background )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

from

background

Dönen Değerler

Hiçbir değer dönmez.

newt_form_run
newt_form_set_height
Newt İşlevleri


newt_form_set_background
newt_form_set_size
Newt İşlevleri
PHP Manual

newt_form_set_height

(PECL newt >= 0.1)

newt_form_set_height —

Açıklama

void newt_form_set_height ( resource $form , int $height )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

form

height

Dönen Değerler

Hiçbir değer dönmez.

newt_form_set_background
newt_form_set_size
Newt İşlevleri


newt_form_set_height
newt_form_set_timer
Newt İşlevleri
PHP Manual

newt_form_set_size

(PECL newt >= 0.1)

newt_form_set_size —

Açıklama

void newt_form_set_size ( resource $form )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

form

Dönen Değerler

Hiçbir değer dönmez.

newt_form_set_height
newt_form_set_timer
Newt İşlevleri


newt_form_set_size
newt_form_set_width
Newt İşlevleri
PHP Manual

newt_form_set_timer

(PECL newt >= 0.1)

newt_form_set_timer —

Açıklama

void newt_form_set_timer ( resource $form , int $milliseconds )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

form

milliseconds

Dönen Değerler

Hiçbir değer dönmez.

newt_form_set_size
newt_form_set_width
Newt İşlevleri


newt_form_set_timer
newt_form_watch_fd
Newt İşlevleri
PHP Manual

newt_form_set_width

(PECL newt >= 0.1)

newt_form_set_width —

Açıklama

void newt_form_set_width ( resource $form , int $width )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

form

width

Dönen Değerler

Hiçbir değer dönmez.

newt_form_set_timer
newt_form_watch_fd
Newt İşlevleri


newt_form_set_width
newt_form
Newt İşlevleri
PHP Manual

newt_form_watch_fd

(PECL newt >= 0.1)

newt_form_watch_fd —

Açıklama

void newt_form_watch_fd ( resource $form , resource $stream [, int $flags ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

form

stream

flags

Dönen Değerler

Hiçbir değer dönmez.

newt_form_set_width
newt_form
Newt İşlevleri


Create a form

newt_form_watch_fd
newt_get_screen_size
Newt İşlevleri
PHP Manual

newt_form

(PECL newt >= 0.1)

newt_form — Create a form

Açıklama

resource newt_form ([ resource $vert_bar [, string $help [, int $flags ]]] )

Create a new form.

Değiştirgeler

vert_bar

Vertical scrollbar which should be associated with the form

help

Help text string

flags

Various flags

Dönen Değerler

Returns a resource link to the created form component, or FALSE on error.

Örnekler

Örnek 1 A newt_form() example

Displays a single button "Quit", which closes the application once it's pressed.

<?php
newt_init();
newt_cls();

$myform = newt_form();
$button = newt_button (5, 12, "Quit");

newt_form_add_component ($myform, $button);
newt_refresh ();
newt_run_form ($myform);

newt_finished ();
newt_form_destroy ($myform);
?>

Ayrıca Bakınız

  • newt_form_run() - Runs a form
  • newt_run_form() - Runs a form
  • newt_form_add_component() - Adds a single component to the form
  • newt_form_add_components() - Add several components to the form
  • newt_form_destroy() - Destroys a form

newt_form_watch_fd
newt_get_screen_size
Newt İşlevleri


Fills in the passed references with the current size of the terminal

newt_form
newt_grid_add_components_to_form
Newt İşlevleri
PHP Manual

newt_get_screen_size

(PECL newt >= 0.1)

newt_get_screen_size — Fills in the passed references with the current size of the terminal

Açıklama

void newt_get_screen_size ( int &$cols , int &$rows )

Fills in the passed references with the current size of the terminal.

Değiştirgeler

cols

Number of columns in the terminal

rows

Number of rows in the terminal

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 A newt_get_screen_size() example

This code prints out the screen size of your terminal.

<?php
 newt_init();
 newt_get_screen_size (&$cols, &$rows);
 newt_finished();

 print "Your terminal size is: {$cols}x{$rows}\n";
?>

Yukarıdaki örneğin çıktısı:

Your terminal size is: 138x47

newt_form
newt_grid_add_components_to_form
Newt İşlevleri


newt_get_screen_size
newt_grid_basic_window
Newt İşlevleri
PHP Manual

newt_grid_add_components_to_form

(PECL newt >= 0.1)

newt_grid_add_components_to_form —

Açıklama

void newt_grid_add_components_to_form ( resource $grid , resource $form , bool $recurse )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

grid

form

recurse

Dönen Değerler

Hiçbir değer dönmez.

newt_get_screen_size
newt_grid_basic_window
Newt İşlevleri


newt_grid_add_components_to_form
newt_grid_free
Newt İşlevleri
PHP Manual

newt_grid_basic_window

(PECL newt >= 0.1)

newt_grid_basic_window —

Açıklama

resource newt_grid_basic_window ( resource $text , resource $middle , resource $buttons )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

text

middle

buttons

Dönen Değerler

newt_grid_add_components_to_form
newt_grid_free
Newt İşlevleri


newt_grid_basic_window
newt_grid_get_size
Newt İşlevleri
PHP Manual

newt_grid_free

(PECL newt >= 0.1)

newt_grid_free —

Açıklama

void newt_grid_free ( resource $grid , bool $recurse )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

grid

recurse

Dönen Değerler

Hiçbir değer dönmez.

newt_grid_basic_window
newt_grid_get_size
Newt İşlevleri


newt_grid_free
newt_grid_h_close_stacked
Newt İşlevleri
PHP Manual

newt_grid_get_size

(PECL newt >= 0.1)

newt_grid_get_size —

Açıklama

void newt_grid_get_size ( resouce $grid , int &$width , int &$height )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

grid

width

height

Dönen Değerler

Hiçbir değer dönmez.

newt_grid_free
newt_grid_h_close_stacked
Newt İşlevleri


newt_grid_get_size
newt_grid_h_stacked
Newt İşlevleri
PHP Manual

newt_grid_h_close_stacked

(PECL newt >= 0.1)

newt_grid_h_close_stacked —

Açıklama

resource newt_grid_h_close_stacked ( int $element1_type , resource $element1 [, int $... [, resource $... ]] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

element1_type

element1

Dönen Değerler

newt_grid_get_size
newt_grid_h_stacked
Newt İşlevleri


newt_grid_h_close_stacked
newt_grid_place
Newt İşlevleri
PHP Manual

newt_grid_h_stacked

(PECL newt >= 0.1)

newt_grid_h_stacked —

Açıklama

resource newt_grid_h_stacked ( int $element1_type , resource $element1 [, int $... [, resource $... ]] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

element1_type

element1

Dönen Değerler

newt_grid_h_close_stacked
newt_grid_place
Newt İşlevleri


newt_grid_h_stacked
newt_grid_set_field
Newt İşlevleri
PHP Manual

newt_grid_place

(PECL newt >= 0.1)

newt_grid_place —

Açıklama

void newt_grid_place ( resource $grid , int $left , int $top )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

grid

left

top

Dönen Değerler

Hiçbir değer dönmez.

newt_grid_h_stacked
newt_grid_set_field
Newt İşlevleri


newt_grid_place
newt_grid_simple_window
Newt İşlevleri
PHP Manual

newt_grid_set_field

(PECL newt >= 0.1)

newt_grid_set_field —

Açıklama

void newt_grid_set_field ( resource $grid , int $col , int $row , int $type , resource $val , int $pad_left , int $pad_top , int $pad_right , int $pad_bottom , int $anchor [, int $flags ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

grid

col

row

type

val

pad_left

pad_top

pad_right

pad_bottom

anchor

flags

Dönen Değerler

Hiçbir değer dönmez.

newt_grid_place
newt_grid_simple_window
Newt İşlevleri


newt_grid_set_field
newt_grid_v_close_stacked
Newt İşlevleri
PHP Manual

newt_grid_simple_window

(PECL newt >= 0.1)

newt_grid_simple_window —

Açıklama

resource newt_grid_simple_window ( resource $text , resource $middle , resource $buttons )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

text

middle

buttons

Dönen Değerler

newt_grid_set_field
newt_grid_v_close_stacked
Newt İşlevleri


newt_grid_simple_window
newt_grid_v_stacked
Newt İşlevleri
PHP Manual

newt_grid_v_close_stacked

(PECL newt >= 0.1)

newt_grid_v_close_stacked —

Açıklama

resource newt_grid_v_close_stacked ( int $element1_type , resource $element1 [, int $... [, resource $... ]] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

element1_type

element1

Dönen Değerler

newt_grid_simple_window
newt_grid_v_stacked
Newt İşlevleri


newt_grid_v_close_stacked
newt_grid_wrapped_window_at
Newt İşlevleri
PHP Manual

newt_grid_v_stacked

(PECL newt >= 0.1)

newt_grid_v_stacked —

Açıklama

resource newt_grid_v_stacked ( int $element1_type , resource $element1 [, int $... [, resource $... ]] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

element1_type

element1

Dönen Değerler

newt_grid_v_close_stacked
newt_grid_wrapped_window_at
Newt İşlevleri


newt_grid_v_stacked
newt_grid_wrapped_window
Newt İşlevleri
PHP Manual

newt_grid_wrapped_window_at

(PECL newt >= 0.1)

newt_grid_wrapped_window_at —

Açıklama

void newt_grid_wrapped_window_at ( resource $grid , string $title , int $left , int $top )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

grid

title

left

top

Dönen Değerler

Hiçbir değer dönmez.

newt_grid_v_stacked
newt_grid_wrapped_window
Newt İşlevleri


newt_grid_wrapped_window_at
newt_init
Newt İşlevleri
PHP Manual

newt_grid_wrapped_window

(PECL newt >= 0.1)

newt_grid_wrapped_window —

Açıklama

void newt_grid_wrapped_window ( resource $grid , string $title )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

grid

title

Dönen Değerler

Hiçbir değer dönmez.

newt_grid_wrapped_window_at
newt_init
Newt İşlevleri


Initialize newt

newt_grid_wrapped_window
newt_label_set_text
Newt İşlevleri
PHP Manual

newt_init

(PECL newt >= 0.1)

newt_init — Initialize newt

Açıklama

int newt_init ( void )

Initializes the newt interface. This function must be called before any other newt function.

Dönen Değerler

Returns 1 on success, 0 on failure.

Ayrıca Bakınız

  • newt_finished() - Uninitializes newt interface

newt_grid_wrapped_window
newt_label_set_text
Newt İşlevleri


newt_init
newt_label
Newt İşlevleri
PHP Manual

newt_label_set_text

(PECL newt >= 0.1)

newt_label_set_text —

Açıklama

void newt_label_set_text ( resource $label , string $text )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

label

text

Dönen Değerler

Hiçbir değer dönmez.

newt_init
newt_label
Newt İşlevleri


newt_label_set_text
newt_listbox_append_entry
Newt İşlevleri
PHP Manual

newt_label

(PECL newt >= 0.1)

newt_label —

Açıklama

resource newt_label ( int $left , int $top , string $text )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

left

top

text

Dönen Değerler

newt_label_set_text
newt_listbox_append_entry
Newt İşlevleri


newt_label
newt_listbox_clear_selection
Newt İşlevleri
PHP Manual

newt_listbox_append_entry

(PECL newt >= 0.1)

newt_listbox_append_entry —

Açıklama

void newt_listbox_append_entry ( resource $listbox , string $text , mixed $data )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

listbox

text

data

Dönen Değerler

Hiçbir değer dönmez.

newt_label
newt_listbox_clear_selection
Newt İşlevleri


newt_listbox_append_entry
newt_listbox_clear
Newt İşlevleri
PHP Manual

newt_listbox_clear_selection

(PECL newt >= 0.1)

newt_listbox_clear_selection —

Açıklama

void newt_listbox_clear_selection ( resource $listbox )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

listbox

Dönen Değerler

Hiçbir değer dönmez.

newt_listbox_append_entry
newt_listbox_clear
Newt İşlevleri


newt_listbox_clear_selection
newt_listbox_delete_entry
Newt İşlevleri
PHP Manual

newt_listbox_clear

(PECL newt >= 0.1)

newt_listbox_clear —

Açıklama

void newt_listbox_clear ( resource $listobx )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

listobx

Dönen Değerler

Hiçbir değer dönmez.

newt_listbox_clear_selection
newt_listbox_delete_entry
Newt İşlevleri


newt_listbox_clear
newt_listbox_get_current
Newt İşlevleri
PHP Manual

newt_listbox_delete_entry

(PECL newt >= 0.1)

newt_listbox_delete_entry —

Açıklama

void newt_listbox_delete_entry ( resource $listbox , mixed $key )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

listbox

key

Dönen Değerler

Hiçbir değer dönmez.

newt_listbox_clear
newt_listbox_get_current
Newt İşlevleri


newt_listbox_delete_entry
newt_listbox_get_selection
Newt İşlevleri
PHP Manual

newt_listbox_get_current

(PECL newt >= 0.1)

newt_listbox_get_current —

Açıklama

string newt_listbox_get_current ( resource $listbox )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

listbox

Dönen Değerler

newt_listbox_delete_entry
newt_listbox_get_selection
Newt İşlevleri


newt_listbox_get_current
newt_listbox_insert_entry
Newt İşlevleri
PHP Manual

newt_listbox_get_selection

(PECL newt >= 0.1)

newt_listbox_get_selection —

Açıklama

array newt_listbox_get_selection ( resource $listbox )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

listbox

Dönen Değerler

newt_listbox_get_current
newt_listbox_insert_entry
Newt İşlevleri


newt_listbox_get_selection
newt_listbox_item_count
Newt İşlevleri
PHP Manual

newt_listbox_insert_entry

(PECL newt >= 0.1)

newt_listbox_insert_entry —

Açıklama

void newt_listbox_insert_entry ( resource $listbox , string $text , mixed $data , mixed $key )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

listbox

text

data

key

Dönen Değerler

Hiçbir değer dönmez.

newt_listbox_get_selection
newt_listbox_item_count
Newt İşlevleri


newt_listbox_insert_entry
newt_listbox_select_item
Newt İşlevleri
PHP Manual

newt_listbox_item_count

(PECL newt >= 0.1)

newt_listbox_item_count —

Açıklama

int newt_listbox_item_count ( resource $listbox )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

listbox

Dönen Değerler

newt_listbox_insert_entry
newt_listbox_select_item
Newt İşlevleri


newt_listbox_item_count
newt_listbox_set_current_by_key
Newt İşlevleri
PHP Manual

newt_listbox_select_item

(PECL newt >= 0.1)

newt_listbox_select_item —

Açıklama

void newt_listbox_select_item ( resource $listbox , mixed $key , int $sense )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

listbox

key

sense

Dönen Değerler

Hiçbir değer dönmez.

newt_listbox_item_count
newt_listbox_set_current_by_key
Newt İşlevleri


newt_listbox_select_item
newt_listbox_set_current
Newt İşlevleri
PHP Manual

newt_listbox_set_current_by_key

(PECL newt >= 0.1)

newt_listbox_set_current_by_key —

Açıklama

void newt_listbox_set_current_by_key ( resource $listbox , mixed $key )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

listbox

key

Dönen Değerler

Hiçbir değer dönmez.

newt_listbox_select_item
newt_listbox_set_current
Newt İşlevleri


newt_listbox_set_current_by_key
newt_listbox_set_data
Newt İşlevleri
PHP Manual

newt_listbox_set_current

(PECL newt >= 0.1)

newt_listbox_set_current —

Açıklama

void newt_listbox_set_current ( resource $listbox , int $num )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

listbox

num

Dönen Değerler

Hiçbir değer dönmez.

newt_listbox_set_current_by_key
newt_listbox_set_data
Newt İşlevleri


newt_listbox_set_current
newt_listbox_set_entry
Newt İşlevleri
PHP Manual

newt_listbox_set_data

(PECL newt >= 0.1)

newt_listbox_set_data —

Açıklama

void newt_listbox_set_data ( resource $listbox , int $num , mixed $data )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

listbox

num

data

Dönen Değerler

Hiçbir değer dönmez.

newt_listbox_set_current
newt_listbox_set_entry
Newt İşlevleri


newt_listbox_set_data
newt_listbox_set_width
Newt İşlevleri
PHP Manual

newt_listbox_set_entry

(PECL newt >= 0.1)

newt_listbox_set_entry —

Açıklama

void newt_listbox_set_entry ( resource $listbox , int $num , string $text )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

listbox

num

text

Dönen Değerler

Hiçbir değer dönmez.

newt_listbox_set_data
newt_listbox_set_width
Newt İşlevleri


newt_listbox_set_entry
newt_listbox
Newt İşlevleri
PHP Manual

newt_listbox_set_width

(PECL newt >= 0.1)

newt_listbox_set_width —

Açıklama

void newt_listbox_set_width ( resource $listbox , int $width )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

listbox

width

Dönen Değerler

Hiçbir değer dönmez.

newt_listbox_set_entry
newt_listbox
Newt İşlevleri


newt_listbox_set_width
newt_listitem_get_data
Newt İşlevleri
PHP Manual

newt_listbox

(PECL newt >= 0.1)

newt_listbox —

Açıklama

resource newt_listbox ( int $left , int $top , int $height [, int $flags ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

left

top

height

flags

Dönen Değerler

newt_listbox_set_width
newt_listitem_get_data
Newt İşlevleri


newt_listbox
newt_listitem_set
Newt İşlevleri
PHP Manual

newt_listitem_get_data

(PECL newt >= 0.1)

newt_listitem_get_data —

Açıklama

mixed newt_listitem_get_data ( resource $item )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

item

Dönen Değerler

newt_listbox
newt_listitem_set
Newt İşlevleri


newt_listitem_get_data
newt_listitem
Newt İşlevleri
PHP Manual

newt_listitem_set

(PECL newt >= 0.1)

newt_listitem_set —

Açıklama

void newt_listitem_set ( resource $item , string $text )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

item

text

Dönen Değerler

Hiçbir değer dönmez.

newt_listitem_get_data
newt_listitem
Newt İşlevleri


newt_listitem_set
newt_open_window
Newt İşlevleri
PHP Manual

newt_listitem

(PECL newt >= 0.1)

newt_listitem —

Açıklama

resource newt_listitem ( int $left , int $top , string $text , bool $is_default , resouce $prev_item , mixed $data [, int $flags ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

left

top

text

is_default

prev_item

data

flags

Dönen Değerler

newt_listitem_set
newt_open_window
Newt İşlevleri


Open a window of the specified size and position

newt_listitem
newt_pop_help_line
Newt İşlevleri
PHP Manual

newt_open_window

(PECL newt >= 0.1)

newt_open_window — Open a window of the specified size and position

Açıklama

int newt_open_window ( int $left , int $top , int $width , int $height [, string $title ] )

Open a window of the specified size and position.

Değiştirgeler

left

Location of the upper left-hand corner of the window (column number)

top

Location of the upper left-hand corner of the window (row number)

width

Window width

height

Window height

title

Window title

Dönen Değerler

Returns 1 on success, 0 on failure.

Ayrıca Bakınız

  • newt_pop_window() - Removes the top window from the display
  • newt_centered_window() - Open a centered window of the specified size

newt_listitem
newt_pop_help_line
Newt İşlevleri


Replaces the current help line with the one from the stack

newt_open_window
newt_pop_window
Newt İşlevleri
PHP Manual

newt_pop_help_line

(PECL newt >= 0.1)

newt_pop_help_line — Replaces the current help line with the one from the stack

Açıklama

void newt_pop_help_line ( void )

Replaces the current help line with the one from the stack.

Bilginize:

It's important not to call to newt_pop_help_line() more than newt_push_help_line().

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • newt_push_help_line() - Saves the current help line on a stack, and displays the new line

newt_open_window
newt_pop_window
Newt İşlevleri


Removes the top window from the display

newt_pop_help_line
newt_push_help_line
Newt İşlevleri
PHP Manual

newt_pop_window

(PECL newt >= 0.1)

newt_pop_window — Removes the top window from the display

Açıklama

void newt_pop_window ( void )

Removes the top window from the display, and redraws the display areas which the window overwrote.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • newt_open_window() - Open a window of the specified size and position
  • newt_centered_window() - Open a centered window of the specified size

newt_pop_help_line
newt_push_help_line
Newt İşlevleri


Saves the current help line on a stack, and displays the new line

newt_pop_window
newt_radio_get_current
Newt İşlevleri
PHP Manual

newt_push_help_line

(PECL newt >= 0.1)

newt_push_help_line — Saves the current help line on a stack, and displays the new line

Açıklama

void newt_push_help_line ([ string $text ] )

Saves the current help line on a stack, and displays the new line.

Değiştirgeler

text

New help text message

Bilginize:

If not specified, the help line is cleared.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • newt_pop_help_line() - Replaces the current help line with the one from the stack

newt_pop_window
newt_radio_get_current
Newt İşlevleri


newt_push_help_line
newt_radiobutton
Newt İşlevleri
PHP Manual

newt_radio_get_current

(PECL newt >= 0.1)

newt_radio_get_current —

Açıklama

resource newt_radio_get_current ( resource $set_member )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

set_member

Dönen Değerler

newt_push_help_line
newt_radiobutton
Newt İşlevleri


newt_radio_get_current
newt_redraw_help_line
Newt İşlevleri
PHP Manual

newt_radiobutton

(PECL newt >= 0.1)

newt_radiobutton —

Açıklama

resource newt_radiobutton ( int $left , int $top , string $text , bool $is_default [, resource $prev_button ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

left

top

text

is_default

prev_button

Dönen Değerler

newt_radio_get_current
newt_redraw_help_line
Newt İşlevleri


newt_radiobutton
newt_reflow_text
Newt İşlevleri
PHP Manual

newt_redraw_help_line

(PECL newt >= 0.1)

newt_redraw_help_line —

Açıklama

void newt_redraw_help_line ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Dönen Değerler

Hiçbir değer dönmez.

newt_radiobutton
newt_reflow_text
Newt İşlevleri


newt_redraw_help_line
newt_refresh
Newt İşlevleri
PHP Manual

newt_reflow_text

(PECL newt >= 0.1)

newt_reflow_text —

Açıklama

string newt_reflow_text ( string $text , int $width , int $flex_down , int $flex_up , int &$actual_width , int &$actual_height )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

text

width

flex_down

flex_up

actual_width

actual_height

Dönen Değerler

newt_redraw_help_line
newt_refresh
Newt İşlevleri


Updates modified portions of the screen

newt_reflow_text
newt_resize_screen
Newt İşlevleri
PHP Manual

newt_refresh

(PECL newt >= 0.1)

newt_refresh — Updates modified portions of the screen

Açıklama

void newt_refresh ( void )

To increase performance, newt only updates the display when it needs to, not when the program tells it to write to the terminal. Applications can force newt to immediately update modified portions of the screen by calling this function.

Dönen Değerler

Hiçbir değer dönmez.

newt_reflow_text
newt_resize_screen
Newt İşlevleri


newt_refresh
newt_resume
Newt İşlevleri
PHP Manual

newt_resize_screen

(PECL newt >= 0.1)

newt_resize_screen —

Açıklama

void newt_resize_screen ([ bool $redraw ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

redraw

Dönen Değerler

Hiçbir değer dönmez.

newt_refresh
newt_resume
Newt İşlevleri


Resume using the newt interface after calling newt_suspend

newt_resize_screen
newt_run_form
Newt İşlevleri
PHP Manual

newt_resume

(PECL newt >= 0.1)

newt_resume — Resume using the newt interface after calling newt_suspend()

Açıklama

void newt_resume ( void )

Resume using the newt interface after calling newt_suspend().

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • newt_suspend() - Tells newt to return the terminal to its initial state

newt_resize_screen
newt_run_form
Newt İşlevleri


Runs a form

newt_resume
newt_scale_set
Newt İşlevleri
PHP Manual

newt_run_form

(PECL newt >= 0.1)

newt_run_form — Runs a form

Açıklama

resource newt_run_form ( resource $form )

This function runs the form passed to it.

Değiştirgeler

form

Form component

Dönen Değerler

The component which caused the form to stop running.

Bilginize:

Notice that this function doesn't fit in with newt's normal naming convention. It is an older interface which will not work for all forms. It was left in newt only for legacy applications. It is a simpler interface than the new newt_form_run() though, and is still used quite often as a result. When an application is done with a form, it destroys the form and all of the components the form contains.

Ayrıca Bakınız

  • newt_form_run() - Runs a form
  • newt_form_destroy() - Destroys a form

newt_resume
newt_scale_set
Newt İşlevleri


newt_run_form
newt_scale
Newt İşlevleri
PHP Manual

newt_scale_set

(PECL newt >= 0.1)

newt_scale_set —

Açıklama

void newt_scale_set ( resource $scale , int $amount )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

scale

amount

Dönen Değerler

Hiçbir değer dönmez.

newt_run_form
newt_scale
Newt İşlevleri


newt_scale_set
newt_scrollbar_set
Newt İşlevleri
PHP Manual

newt_scale

(PECL newt >= 0.1)

newt_scale —

Açıklama

resource newt_scale ( int $left , int $top , int $width , int $full_value )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

left

top

width

full_value

Dönen Değerler

newt_scale_set
newt_scrollbar_set
Newt İşlevleri


newt_scale
newt_set_help_callback
Newt İşlevleri
PHP Manual

newt_scrollbar_set

(PECL newt >= 0.1)

newt_scrollbar_set —

Açıklama

void newt_scrollbar_set ( resource $scrollbar , int $where , int $total )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

scrollbar

where

total

Dönen Değerler

Hiçbir değer dönmez.

newt_scale
newt_set_help_callback
Newt İşlevleri


newt_scrollbar_set
newt_set_suspend_callback
Newt İşlevleri
PHP Manual

newt_set_help_callback

(PECL newt >= 0.1)

newt_set_help_callback —

Açıklama

void newt_set_help_callback ( mixed $function )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

function

Dönen Değerler

Hiçbir değer dönmez.

newt_scrollbar_set
newt_set_suspend_callback
Newt İşlevleri


Set a callback function which gets invoked when user presses the suspend key

newt_set_help_callback
newt_suspend
Newt İşlevleri
PHP Manual

newt_set_suspend_callback

(PECL newt >= 0.1)

newt_set_suspend_callback — Set a callback function which gets invoked when user presses the suspend key

Açıklama

void newt_set_suspend_callback ( callable $function , mixed $data )

Set a callback function which gets invoked when user presses the suspend key (normally ^Z). If no suspend callback is registered, the suspend keystroke is ignored.

Değiştirgeler

function

A callback function, which accepts one argument: data

data

This data is been passed to the callback function

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • newt_suspend() - Tells newt to return the terminal to its initial state
  • newt_resume() - Resume using the newt interface after calling newt_suspend

newt_set_help_callback
newt_suspend
Newt İşlevleri


Tells newt to return the terminal to its initial state

newt_set_suspend_callback
newt_textbox_get_num_lines
Newt İşlevleri
PHP Manual

newt_suspend

(PECL newt >= 0.1)

newt_suspend — Tells newt to return the terminal to its initial state

Açıklama

void newt_suspend ( void )

Tells newt to return the terminal to its initial state. Once this is done, the application can suspend itself (by sending itself a SIGTSTP, fork a child program, or do whatever else it likes).

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • newt_resume() - Resume using the newt interface after calling newt_suspend

newt_set_suspend_callback
newt_textbox_get_num_lines
Newt İşlevleri


newt_suspend
newt_textbox_reflowed
Newt İşlevleri
PHP Manual

newt_textbox_get_num_lines

(PECL newt >= 0.1)

newt_textbox_get_num_lines —

Açıklama

int newt_textbox_get_num_lines ( resource $textbox )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

textbox

Dönen Değerler

newt_suspend
newt_textbox_reflowed
Newt İşlevleri


newt_textbox_get_num_lines
newt_textbox_set_height
Newt İşlevleri
PHP Manual

newt_textbox_reflowed

(PECL newt >= 0.1)

newt_textbox_reflowed —

Açıklama

resource newt_textbox_reflowed ( int $left , int $top , char $*text , int $width , int $flex_down , int $flex_up [, int $flags ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

left

top

*text

width

flex_down

flex_up

flags

Dönen Değerler

newt_textbox_get_num_lines
newt_textbox_set_height
Newt İşlevleri


newt_textbox_reflowed
newt_textbox_set_text
Newt İşlevleri
PHP Manual

newt_textbox_set_height

(PECL newt >= 0.1)

newt_textbox_set_height —

Açıklama

void newt_textbox_set_height ( resource $textbox , int $height )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

textbox

height

Dönen Değerler

Hiçbir değer dönmez.

newt_textbox_reflowed
newt_textbox_set_text
Newt İşlevleri


newt_textbox_set_height
newt_textbox
Newt İşlevleri
PHP Manual

newt_textbox_set_text

(PECL newt >= 0.1)

newt_textbox_set_text —

Açıklama

void newt_textbox_set_text ( resource $textbox , string $text )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

textbox

text

Dönen Değerler

Hiçbir değer dönmez.

newt_textbox_set_height
newt_textbox
Newt İşlevleri


newt_textbox_set_text
newt_vertical_scrollbar
Newt İşlevleri
PHP Manual

newt_textbox

(PECL newt >= 0.1)

newt_textbox —

Açıklama

resource newt_textbox ( int $left , int $top , int $width , int $height [, int $flags ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

left

top

width

height

flags

Dönen Değerler

newt_textbox_set_text
newt_vertical_scrollbar
Newt İşlevleri


newt_textbox
newt_wait_for_key
Newt İşlevleri
PHP Manual

newt_vertical_scrollbar

(PECL newt >= 0.1)

newt_vertical_scrollbar —

Açıklama

resource newt_vertical_scrollbar ( int $left , int $top , int $height [, int $normal_colorset [, int $thumb_colorset ]] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

left

top

height

normal_colorset

thumb_colorset

Dönen Değerler

newt_textbox
newt_wait_for_key
Newt İşlevleri


Doesn't return until a key has been pressed

newt_vertical_scrollbar
newt_win_choice
Newt İşlevleri
PHP Manual

newt_wait_for_key

(PECL newt >= 0.1)

newt_wait_for_key — Doesn't return until a key has been pressed

Açıklama

void newt_wait_for_key ( void )

This function doesn't return until a key has been pressed. The keystroke is then ignored. If a key is already in the terminal's buffer, this function discards a keystroke and returns immediately.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • newt_clear_key_buffer() - Discards the contents of the terminal's input buffer without waiting for additional input

newt_vertical_scrollbar
newt_win_choice
Newt İşlevleri


newt_wait_for_key
newt_win_entries
Newt İşlevleri
PHP Manual

newt_win_choice

(PECL newt >= 0.1)

newt_win_choice —

Açıklama

int newt_win_choice ( string $title , string $button1_text , string $button2_text , string $format [, mixed $args [, mixed $... ]] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

title

button1_text

button2_text

format

args

Dönen Değerler

newt_wait_for_key
newt_win_entries
Newt İşlevleri


newt_win_choice
newt_win_menu
Newt İşlevleri
PHP Manual

newt_win_entries

(PECL newt >= 0.1)

newt_win_entries —

Açıklama

int newt_win_entries ( string $title , string $text , int $suggested_width , int $flex_down , int $flex_up , int $data_width , array &$items , string $button1 [, string $... ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

title

text

suggested_width

flex_down

flex_up

data_width

items

button1

button2

Dönen Değerler

Örnekler

Örnek 1 A newt_win_entries() example

<?php

newt_init();
newt_cls();

$entries[] = array('text' => 'First name:', 'value' => &$f_name);
$entries[] = array('text' => 'Last name:',  'value' => &$l_name);

$rc = newt_win_entries("User information", "Please enter your credentials:", 50, 7, 7, 30, $entries, "Ok", "Back");
newt_finished ();

if ($rc != 2) {
    echo "Your name is: $f_name $l_name\n";
}
?>

newt_win_choice
newt_win_menu
Newt İşlevleri


newt_win_entries
newt_win_message
Newt İşlevleri
PHP Manual

newt_win_menu

(PECL newt >= 0.1)

newt_win_menu —

Açıklama

int newt_win_menu ( string $title , string $text , int $suggestedWidth , int $flexDown , int $flexUp , int $maxListHeight , array $items , int &$listItem [, string $button1 [, string $... ]] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

title

text

suggestedWidth

flexDown

flexUp

maxListHeight

items

listItem

button1

Dönen Değerler

Hiçbir değer dönmez.

newt_win_entries
newt_win_message
Newt İşlevleri


newt_win_menu
newt_win_messagev
Newt İşlevleri
PHP Manual

newt_win_message

(PECL newt >= 0.1)

newt_win_message —

Açıklama

void newt_win_message ( string $title , string $button_text , string $format [, mixed $args [, mixed $... ]] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

title

button_text

format

args

Dönen Değerler

Hiçbir değer dönmez.

newt_win_menu
newt_win_messagev
Newt İşlevleri


newt_win_message
newt_win_ternary
Newt İşlevleri
PHP Manual

newt_win_messagev

(PECL newt >= 0.1)

newt_win_messagev —

Açıklama

void newt_win_messagev ( string $title , string $button_text , string $format , array $args )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

title

button_text

format

args

Dönen Değerler

Hiçbir değer dönmez.

newt_win_message
newt_win_ternary
Newt İşlevleri


newt_win_messagev
Readline
Newt İşlevleri
PHP Manual

newt_win_ternary

(PECL newt >= 0.1)

newt_win_ternary —

Açıklama

int newt_win_ternary ( string $title , string $button1_text , string $button2_text , string $button3_text , string $format [, mixed $args [, mixed $... ]] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

title

Its description

button1_text

Its description

button2_text

Its description

button3_text

Its description

format

Its description

args

Its description

Dönen Değerler

What the function returns, first on success, then on failure. See also the &return.success; entity

newt_win_messagev
Readline
Newt İşlevleri


GNU Readline

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Readline İşlevleri
    • readline_add_history — Adds a line to the history
    • readline_callback_handler_install — Initializes the readline callback interface and terminal, prints the prompt and returns immediately
    • readline_callback_handler_remove — Removes a previously installed callback handler and restores terminal settings
    • readline_callback_read_char — Reads a character and informs the readline callback interface when a line is received
    • readline_clear_history — Clears the history
    • readline_completion_function — Registers a completion function
    • readline_info — Gets/sets various internal readline variables
    • readline_list_history — Lists the history
    • readline_on_new_line — Inform readline that the cursor has moved to a new line
    • readline_read_history — Reads the history
    • readline_redisplay — Redraws the display
    • readline_write_history — Writes the history
    • readline — Reads a line
newt_win_ternary
Giriş
Komut Satırına Özgü Eklentiler


Giriş

The readline functions implement an interface to the GNU Readline library. These are functions that provide editable command lines. An example being the way Bash allows you to use the arrow keys to insert characters or scroll through command history. Because of the interactive nature of this library, it will be of little use for writing Web applications, but may be useful when writing scripts used from a command line.

As of PHP 7.1.0 this extension is supported on Windows.

Dikkat

The readline extension is not thread-safe! Thus, the usage of it with any true thread safe SAPI (like Apache mod_winnt) is strongly discouraged.

Readline
Yapılandırma/Kurulum
Readline


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Readline


Gereksinimler

To use the readline functions, you need to install libreadline. You can find libreadline on the home page of the GNU Readline project, at » http://cnswww.cns.cwru.edu/~chet/readline/rltop.html. It's maintained by Chet Ramey, who's also the author of Bash.

You can also use these functions with the libedit library, a non-GPL replacement for the readline library. The libedit library is BSD licensed and available for download from » http://www.thrysoee.dk/editline/.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

To use these functions you must compile the CGI or CLI version of PHP with readline support. You need to configure PHP --with-readline[=DIR] . If you want to use the libedit readline replacement, configure PHP --with-libedit[=DIR] .

On Windows this extension is available by default as of PHP 7.1.0.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Readline Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
cli.pager | "" | PHP_INI_ALL | Available since PHP 5.4.0.
cli.prompt | "\\b \\> " | PHP_INI_ALL | Available since PHP 5.4.0.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

cli.pager string

External tool to display output from command line.

cli.prompt string

Command line prompt.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
Readline İşlevleri
Readline


Readline İşlevleri

İçindekiler

  • readline_add_history — Adds a line to the history
  • readline_callback_handler_install — Initializes the readline callback interface and terminal, prints the prompt and returns immediately
  • readline_callback_handler_remove — Removes a previously installed callback handler and restores terminal settings
  • readline_callback_read_char — Reads a character and informs the readline callback interface when a line is received
  • readline_clear_history — Clears the history
  • readline_completion_function — Registers a completion function
  • readline_info — Gets/sets various internal readline variables
  • readline_list_history — Lists the history
  • readline_on_new_line — Inform readline that the cursor has moved to a new line
  • readline_read_history — Reads the history
  • readline_redisplay — Redraws the display
  • readline_write_history — Writes the history
  • readline — Reads a line
Öntanımlı Sabitler
readline_add_history
Readline


Adds a line to the history

Readline İşlevleri
readline_callback_handler_install
Readline İşlevleri
PHP Manual

readline_add_history

(PHP 4, PHP 5, PHP 7)

readline_add_history — Adds a line to the history

Açıklama

bool readline_add_history ( string $line )

This function adds a line to the command line history.

Değiştirgeler

line

The line to be added in the history.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Readline İşlevleri
readline_callback_handler_install
Readline İşlevleri


Initializes the readline callback interface and terminal, prints the prompt and returns immediately

readline_add_history
readline_callback_handler_remove
Readline İşlevleri
PHP Manual

readline_callback_handler_install

(PHP 5 >= 5.1.0, PHP 7)

readline_callback_handler_install — Initializes the readline callback interface and terminal, prints the prompt and returns immediately

Açıklama

bool readline_callback_handler_install ( string $prompt , callable $callback )

Sets up a readline callback interface then prints prompt and immediately returns. Calling this function twice without removing the previous callback interface will automatically and conveniently overwrite the old interface.

The callback feature is useful when combined with stream_select() as it allows interleaving of IO and user input, unlike readline().

Değiştirgeler

prompt

The prompt message.

callback

The callback function takes one parameter; the user input returned.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Readline Callback Interface Example

<?php
function rl_callback($ret)
{
    global $c, $prompting;

    echo "You entered: $ret\n";
    $c++;

    if ($c > 10) {
        $prompting = false;
        readline_callback_handler_remove();
    } else {
        readline_callback_handler_install("[$c] Enter something: ", 'rl_callback');
    }
}

$c = 1;
$prompting = true;

readline_callback_handler_install("[$c] Enter something: ", 'rl_callback');

while ($prompting) {
    $w = NULL;
    $e = NULL;
    $n = stream_select($r = array(STDIN), $w, $e, null);
    if ($n && in_array(STDIN, $r)) {
        // read a character, will call the callback when a newline is entered
        readline_callback_read_char();
    }
}

echo "Prompting disabled. All done.\n";
?>

Ayrıca Bakınız

  • readline_callback_handler_remove() - Removes a previously installed callback handler and restores terminal settings
  • readline_callback_read_char() - Reads a character and informs the readline callback interface when a line is received
  • stream_select() - Belirtilen akım dizisi üzerinde belirtilen zaman aşımı ile select() sistem çağrısının eşdeğeri olarak çalışır

readline_add_history
readline_callback_handler_remove
Readline İşlevleri


Removes a previously installed callback handler and restores terminal settings

readline_callback_handler_install
readline_callback_read_char
Readline İşlevleri
PHP Manual

readline_callback_handler_remove

(PHP 5 >= 5.1.0, PHP 7)

readline_callback_handler_remove — Removes a previously installed callback handler and restores terminal settings

Açıklama

bool readline_callback_handler_remove ( void )

Removes a previously installed callback handler and restores terminal settings.

Dönen Değerler

Returns TRUE if a previously installed callback handler was removed, or FALSE if one could not be found.

Örnekler

See readline_callback_handler_install() for an example of how to use the readline callback interface.

Ayrıca Bakınız

  • readline_callback_handler_install() - Initializes the readline callback interface and terminal, prints the prompt and returns immediately
  • readline_callback_read_char() - Reads a character and informs the readline callback interface when a line is received

readline_callback_handler_install
readline_callback_read_char
Readline İşlevleri


Reads a character and informs the readline callback interface when a line is received

readline_callback_handler_remove
readline_clear_history
Readline İşlevleri
PHP Manual

readline_callback_read_char

(PHP 5 >= 5.1.0, PHP 7)

readline_callback_read_char — Reads a character and informs the readline callback interface when a line is received

Açıklama

void readline_callback_read_char ( void )

Reads a character of user input. When a line is received, this function informs the readline callback interface installed using readline_callback_handler_install() that a line is ready for input.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

See readline_callback_handler_install() for an example of how to use the readline callback interface.

Ayrıca Bakınız

  • readline_callback_handler_install() - Initializes the readline callback interface and terminal, prints the prompt and returns immediately
  • readline_callback_handler_remove() - Removes a previously installed callback handler and restores terminal settings

readline_callback_handler_remove
readline_clear_history
Readline İşlevleri


Clears the history

readline_callback_read_char
readline_completion_function
Readline İşlevleri
PHP Manual

readline_clear_history

(PHP 4, PHP 5, PHP 7)

readline_clear_history — Clears the history

Açıklama

bool readline_clear_history ( void )

This function clears the entire command line history.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

readline_callback_read_char
readline_completion_function
Readline İşlevleri


Registers a completion function

readline_clear_history
readline_info
Readline İşlevleri
PHP Manual

readline_completion_function

(PHP 4, PHP 5, PHP 7)

readline_completion_function — Registers a completion function

Açıklama

bool readline_completion_function ( callable $function )

This function registers a completion function. This is the same kind of functionality you'd get if you hit your tab key while using Bash.

Değiştirgeler

function

You must supply the name of an existing function which accepts a partial command line and returns an array of possible matches.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

readline_clear_history
readline_info
Readline İşlevleri


Gets/sets various internal readline variables

readline_completion_function
readline_list_history
Readline İşlevleri
PHP Manual

readline_info

(PHP 4, PHP 5, PHP 7)

readline_info — Gets/sets various internal readline variables

Açıklama

mixed readline_info ([ string $varname [, string $newvalue ]] )

Gets or sets various internal readline variables.

Değiştirgeler

varname

A variable name.

newvalue

If provided, this will be the new value of the setting.

Dönen Değerler

If called with no parameters, this function returns an array of values for all the setting readline uses. The elements will be indexed by the following values: done, end, erase_empty_line, library_version, line_buffer, mark, pending_input, point, prompt, readline_name, and terminal_name.

If called with one or two parameters, the old value is returned.

readline_completion_function
readline_list_history
Readline İşlevleri


Lists the history

readline_info
readline_on_new_line
Readline İşlevleri
PHP Manual

readline_list_history

(PHP 4, PHP 5, PHP 7)

readline_list_history — Lists the history

Açıklama

array readline_list_history ( void )

Gets the entire command line history.

Dönen Değerler

Returns an array of the entire command line history. The elements are indexed by integers starting at zero.

readline_info
readline_on_new_line
Readline İşlevleri


Inform readline that the cursor has moved to a new line

readline_list_history
readline_read_history
Readline İşlevleri
PHP Manual

readline_on_new_line

(PHP 5 >= 5.1.0, PHP 7)

readline_on_new_line — Inform readline that the cursor has moved to a new line

Açıklama

void readline_on_new_line ( void )

Tells readline that the cursor has moved to a new line.

Dönen Değerler

Hiçbir değer dönmez.

readline_list_history
readline_read_history
Readline İşlevleri


Reads the history

readline_on_new_line
readline_redisplay
Readline İşlevleri
PHP Manual

readline_read_history

(PHP 4, PHP 5, PHP 7)

readline_read_history — Reads the history

Açıklama

bool readline_read_history ([ string $filename ] )

This function reads a command history from a file.

Değiştirgeler

filename

Path to the filename containing the command history.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

readline_on_new_line
readline_redisplay
Readline İşlevleri


Redraws the display

readline_read_history
readline_write_history
Readline İşlevleri
PHP Manual

readline_redisplay

(PHP 5 >= 5.1.0, PHP 7)

readline_redisplay — Redraws the display

Açıklama

void readline_redisplay ( void )

Redraws readline to redraw the display.

Dönen Değerler

Hiçbir değer dönmez.

readline_read_history
readline_write_history
Readline İşlevleri


Writes the history

readline_redisplay
readline
Readline İşlevleri
PHP Manual

readline_write_history

(PHP 4, PHP 5, PHP 7)

readline_write_history — Writes the history

Açıklama

bool readline_write_history ([ string $filename ] )

This function writes the command history to a file.

Değiştirgeler

filename

Path to the saved file.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

readline_redisplay
readline
Readline İşlevleri


Reads a line

readline_write_history
Sıkıştırma ve Arşivleme Eklentileri
Readline İşlevleri
PHP Manual

readline

(PHP 4, PHP 5, PHP 7)

readline — Reads a line

Açıklama

string readline ([ string $prompt ] )

Reads a single line from the user. You must add this line to the history yourself using readline_add_history().

Değiştirgeler

prompt

You may specify a string with which to prompt the user.

Dönen Değerler

Returns a single string from the user. The line returned has the ending newline removed.

Örnekler

Örnek 1 readline() Example

<?php
//get 3 commands from user
for ($i=0; $i < 3; $i++) {
        $line = readline("Command: ");
        readline_add_history($line);
}

//dump history
print_r(readline_list_history());

//dump variables
print_r(readline_info());
?>

readline_write_history
Sıkıştırma ve Arşivleme Eklentileri
Readline İşlevleri


Sıkıştırma ve Arşivleme Eklentileri

  • Bzip2 Sıkıştırma
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • Bzip2 İşlevleri
  • LZF
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • LZF İşlevleri
  • Phar
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Using Phar Archives
    • Creating Phar Archives
    • What makes a phar a phar and not a tar or a zip?
    • Phar — The Phar class
    • PharData — The PharData class
    • PharFileInfo — The PharFileInfo class
    • PharException — The PharException class
  • Rar — Rar Archiving
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • Rar İşlevleri
    • RarArchive — The RarArchive class
    • RarEntry — The RarEntry class
    • RarException — The RarException class
  • Zip
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • ZipArchive — ZipArchive sınıfı
    • Zip İşlevleri
  • Zlib Eklentisi — Zlib Sıkıştırması
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • Zlib İşlevleri
readline
Bzip2 Sıkıştırma
İşlev Başvuru Kılavuzu


Bzip2 Sıkıştırma

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
  • Bzip2 İşlevleri
    • bzclose — Bzip2 dosyasını kapatır
    • bzcompress — Verilen dizgiyi bzip2 kodlamalı olarak sıkıştırır
    • bzdecompress — Bzip2 ile sıkıştırılmış veriyi açar
    • bzerrno — Bzip2 hata numarası ile döner
    • bzerror — Bzip2 hata numarasını ve hata iletisini bir dizi içerisinde döndürür
    • bzerrstr — Bzip2 hata iletisini döndürür
    • bzflush — Tampondaki bilginin tamamını yazmaya zorlar
    • bzopen — Bzip2 sıkıştırmalı bir dosyayı açar
    • bzread — Bzip2 dosyasını ikil olarak okur
    • bzwrite — Bzip2 dosyasını ikil olarak yazar
Sıkıştırma ve Arşivleme Eklentileri
Giriş
Sıkıştırma ve Arşivleme Eklentileri


Giriş

Bzip2 işlevleri bzip2 (.bz2) sıkıştırılmış dosyalarını şeffaf olarak okuyup yazmakta kullanılır.

Bzip2 Sıkıştırma
Yapılandırma/Kurulum
Bzip2 Sıkıştırma


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Bzip2 Sıkıştırma


Gereksinimler

Bu modül Julian Seward tarafından hazırlanan » bzip2 kütüphanesindeki işlevleri kullanır. Bu modül için bzip2/libbzip2 sürüm >= 1.0.x gereklidir.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

PHP'de Bzip2 desteği öntanımlı olarak etkin değildir. PHP'yi derlerken bzip2 desteğini etkin kılmak için --with-bz2[=DİZİN] yapılandırma seçeneğini kullanmanız gerekir.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Özkaynak Türleri

Bu eklenti tek bir özkaynak türü tanımlar: çalışılacak bz2 dosyasını betimleyen bir dosya tanıtıcısı.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
Örnekler
Bzip2 Sıkıştırma


Örnekler

Bu örnekte geçici bir dosya oluşturup, içine bir deneme dizgesi yazıldıktan sonra dosya içeriği çıktılanmaktadır.

Örnek 1 - Basit bzip2 örneği

<?php

$dosya = '/tmp/deneme.bz2';
$dzg = "Bu dizgi bir denemedir.\n";

// dosyayı yazma amacıyla aç
$bz = bzopen($dosya, 'w');

// dosyaya dizgiyi yaz
bzwrite($bz, $dzg);

// dosyayı kapat
bzclose($bz);

// dosyayı okuma amacıyla aç
$bz = bzopen($dosya, 'r');

// 10 karakter oku
echo bzread($bz, 10);

// dosya bitene kadar (veya sonraki 1024 karaktere kadar)
// çıkışa yazdır ve dosyayı kapat
echo bzread($bz);

bzclose($bz);
?>
Öntanımlı Sabitler
Bzip2 İşlevleri
Bzip2 Sıkıştırma


Bzip2 İşlevleri

İçindekiler

  • bzclose — Bzip2 dosyasını kapatır
  • bzcompress — Verilen dizgiyi bzip2 kodlamalı olarak sıkıştırır
  • bzdecompress — Bzip2 ile sıkıştırılmış veriyi açar
  • bzerrno — Bzip2 hata numarası ile döner
  • bzerror — Bzip2 hata numarasını ve hata iletisini bir dizi içerisinde döndürür
  • bzerrstr — Bzip2 hata iletisini döndürür
  • bzflush — Tampondaki bilginin tamamını yazmaya zorlar
  • bzopen — Bzip2 sıkıştırmalı bir dosyayı açar
  • bzread — Bzip2 dosyasını ikil olarak okur
  • bzwrite — Bzip2 dosyasını ikil olarak yazar
Örnekler
bzclose
Bzip2 Sıkıştırma


Bzip2 dosyasını kapatır

Bzip2 İşlevleri
bzcompress
Bzip2 İşlevleri
PHP Manual

bzclose

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

bzclose — Bzip2 dosyasını kapatır

Açıklama

int bzclose ( resource $bz )

Dosya tanıtıcısı belirtilen bzip2 dosyasını kapatır.

Değiştirgeler

bz

Dosya tanıtıcı. Geçerli ve bzopen() işlevi tarafından başarılı bir şekilde açılmış olan bir dosyayı göstermelidir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • bzopen() - Bzip2 sıkıştırmalı bir dosyayı açar

Bzip2 İşlevleri
bzcompress
Bzip2 İşlevleri


Verilen dizgiyi bzip2 kodlamalı olarak sıkıştırır

bzclose
bzdecompress
Bzip2 İşlevleri
PHP Manual

bzcompress

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

bzcompress — Verilen dizgiyi bzip2 kodlamalı olarak sıkıştırır

Açıklama

mixed bzcompress ( string $kaynak [, int $blokboyu = 4 [, int $katsayı = 0 ]] )

bzcompress() verilen dizgiyi bzip2 türünde sıkıştırır ve bzip2 kodlu veri olarak döndürür.

Değiştirgeler

kaynak

Sıkıştırılacak dizgi.

blokboyu

Sıkıştırma esnasında kullanılacak blok boyu belirtilir. Bu değer 1 ile 9 arasında olmalıdır. 9 değeri en iyi sıkıştırmayı sağlamakla birlikte daha fazla özkaynak kullanır.

katsayı

Bu değer verilen sıkıştırma aşamasının en kötü senaryo durumunda nasıl davranacağını belirtir. (Sık tekrarlı, asimetrik) Bu değer 0 ile 250 arasında değişir. 0 özel bir durumdur.

katsayı değerinden bağımsız olarak, üretilen çıktı aynı olur.

Dönen Değerler

Bir hata oluşmamışsa sıkıştırılmış dizgi ile aksi takdirde hata numarası ile döner.

Örnekler

Örnek 1 - Veri sıkıştırma

<?php
$bilgi = "örnek bilgi";
$bzbilgi = bzcompress($bilgi, 9);
echo $bzbilgi;
?>

Ayrıca Bakınız

  • bzdecompress() - Bzip2 ile sıkıştırılmış veriyi açar

bzclose
bzdecompress
Bzip2 İşlevleri


Bzip2 ile sıkıştırılmış veriyi açar

bzcompress
bzerrno
Bzip2 İşlevleri
PHP Manual

bzdecompress

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

bzdecompress — Bzip2 ile sıkıştırılmış veriyi açar

Açıklama

mixed bzdecompress ( string $kaynak [, int $ufak = 0 ] )

bzdecompress() verilen bzip2 kodlu verinin sıkıştırmasını açar.

Değiştirgeler

kaynak

Sıkıştırılmış haldeki dizge.

ufak

Eğer TRUE ise farklı bir açma algoritması uygulanır ve işlem sırasında daha az bellek kullanılır ancak işlem hızı yarıya düşer. (Gereksinim duyulan azami bellek miktarı yaklaşık 2300K civarına düşer)

Ayrıntılı bilgi için » bzip2 belgelerine bakınız.

Dönen Değerler

Hata oluşmamışsa sıkıştırması açılmış dizgeyle aksi takdirde hata numarası ile döner.

Örnekler

Örnek 1 - Bir dizgenin sıkıştırmasının açılması

<?php
$ilk = "Bu dizgiyi sıkıştıralım...";
$bzilk = bzcompress($ilk);

echo "Sıkıştırılmış Dizgi: ";
echo $bzilk;
echo "\n<br />\n";

$ikinci = bzdecompress($bzilk);
echo "Açılmış Dizgi: ";
echo $ikinci;
echo "\n<br />\n";
?>

Ayrıca Bakınız

  • bzcompress() - Verilen dizgiyi bzip2 kodlamalı olarak sıkıştırır

bzcompress
bzerrno
Bzip2 İşlevleri


Bzip2 hata numarası ile döner

bzdecompress
bzerror
Bzip2 İşlevleri
PHP Manual

bzerrno

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

bzerrno — Bzip2 hata numarası ile döner

Açıklama

int bzerrno ( resource $bz )

Verilen dosya tanıtıcı tarafından döndürülen bzip2 hatasının numarasını bildirir.

Değiştirgeler

bz

Dosya tanıtıcı. Geçerli ve bzopen() işleve tarafından açılmış bir dosyayı göstermelidir.

Dönen Değerler

Hata numarası bir tamsayı olarak döner.

Ayrıca Bakınız

  • bzerror() - Bzip2 hata numarasını ve hata iletisini bir dizi içerisinde döndürür
  • bzerrstr() - Bzip2 hata iletisini döndürür

bzdecompress
bzerror
Bzip2 İşlevleri


Bzip2 hata numarasını ve hata iletisini bir dizi içerisinde döndürür

bzerrno
bzerrstr
Bzip2 İşlevleri
PHP Manual

bzerror

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

bzerror — Bzip2 hata numarasını ve hata iletisini bir dizi içerisinde döndürür

Açıklama

array bzerror ( resource $bz )

Verilen bzip2 dosya tanıtıcısı tarafından döndürülen hatanın tamsayı karşılığını ve hata iletisini birlikte bir dizi içerisinde döndürür.

Değiştirgeler

bz

Dosya tanıtıcısı. Geçerli ve bzopen() işlevi tarafından açılmış bir dosyayı göstermelidir.

Dönen Değerler

Geriye bir ilişkisel dizi döndürür. Bu dizide hata numarası errno girdisinde, hata iletisi ise errstr girdisinde bulunur.

Örnekler

Örnek 1 - bzerror() örneği

<?php
$hata = bzerror($bz);

echo $hata["errno"];
echo $hata["errstr"];
?>

Ayrıca Bakınız

  • bzerrno() - Bzip2 hata numarası ile döner
  • bzerrstr() - Bzip2 hata iletisini döndürür

bzerrno
bzerrstr
Bzip2 İşlevleri


Bzip2 hata iletisini döndürür

bzerror
bzflush
Bzip2 İşlevleri
PHP Manual

bzerrstr

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

bzerrstr — Bzip2 hata iletisini döndürür

Açıklama

string bzerrstr ( resource $bz )

Verilen dosya tanıtıcısı tarafından döndürülen bzip2 hatasının iletisini döndürür.

Değiştirgeler

bz

Dosya tanıtıcısı. Gerçek ve bzopen() işlevi tarafından açılmış varolan bir dosyayı göstermelidir.

Dönen Değerler

Hata iletisini içeren bir dizge geri döndürür.

Ayrıca Bakınız

  • bzerrno() - Bzip2 hata numarası ile döner
  • bzerror() - Bzip2 hata numarasını ve hata iletisini bir dizi içerisinde döndürür

bzerror
bzflush
Bzip2 İşlevleri


Tampondaki bilginin tamamını yazmaya zorlar

bzerrstr
bzopen
Bzip2 İşlevleri
PHP Manual

bzflush

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

bzflush — Tampondaki bilginin tamamını yazmaya zorlar

Açıklama

int bzflush ( resource $bz )

bz dosya tanıtıcısı için tamponda tutulan bzip2 verisinin tümünü yazmaya zorlar.

Değiştirgeler

bz

Dosya tanıtıcısı. Geçerli ve bzopen() işlevi tarafından açılmış bir dosyayı göstermelidir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • bzread() - Bzip2 dosyasını ikil olarak okur
  • bzwrite() - Bzip2 dosyasını ikil olarak yazar

bzerrstr
bzopen
Bzip2 İşlevleri


Bzip2 sıkıştırmalı bir dosyayı açar

bzflush
bzread
Bzip2 İşlevleri
PHP Manual

bzopen

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

bzopen — Bzip2 sıkıştırmalı bir dosyayı açar

Açıklama

resource bzopen ( string $dosyaadı , string $kip )

bzopen() bzip2 (.bz2) türündeki dosyaları okuma ve yazma amacıyla açar.

Değiştirgeler

dosyaadı

Açılacak dosyanın adı.

kip

fopen() işlevine benzer şekilde sadece okuma amaçlı ise 'r', sadece yazma amaçlı ise 'w' desteklenir. Bunlar dışındaki herşey için işlev FALSE döndürür.

Dönen Değerler

Eğer dosya açma işlemi başarılamazsa bzopen() geriye FALSE döndürür. Aksi takdirde yeni açılan dosyaya ait bir bzip2 dosya tanıtıcısı döndürür.

Örnekler

Örnek 1 - bzopen() örneği

<?php

$dosya = '/tmp/abc.bz2';

$bz = bzopen($file, 'r') or die("Belirtilen $dosya dosyası açılamadı.");

bzclose($bz);

?>

Ayrıca Bakınız

  • bzclose() - Bzip2 dosyasını kapatır

bzflush
bzread
Bzip2 İşlevleri


Bzip2 dosyasını ikil olarak okur

bzopen
bzwrite
Bzip2 İşlevleri
PHP Manual

bzread

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

bzread — Bzip2 dosyasını ikil olarak okur

Açıklama

string bzread ( resource $bz [, int $uzunluk = 1024 ] )

bzread(), bzip2 dosya tanıtıcısı verilen dosyayı okur.

Sıkıştırıması açılmış veri belirtilen uzunluk baytlık uzunluğa eriştiği zaman veya dosya sonuna varıldığı zaman okuma işlemi sona erer.

Değiştirgeler

bz

Dosya tanıtıcısı. Geçerli ve bzopen() işlevi tarafından açılmış bir dosyayı göstermelidir.

uzunluk

Eğer belirtilmemişse, bzread() her seferinde 1024 baytlık sıkıştırması açılmış veri okuyacaktır.

Dönen Değerler

Sıkıştırması açılmış veriyi veya hata durumunda FALSE döndürür.

Örnekler

Örnek 1 - bzread() örneği

<?php

$dosya = '/tmp/foo.bz2';
$bz = bzopen($dosya, 'r') or die("Belirtilen $dosya dosyası açılamadı.");

$acilmis_icerik = '';
while (!feof($bz)) {
  $acilmis_icerik .= bzread($bz, 4096);
}
bzclose($bz);

echo "Belirtilen dosya $dosya içeriği: <br />\n";
echo $acilmis_icerik;

?>

Ayrıca Bakınız

  • bzwrite() - Bzip2 dosyasını ikil olarak yazar
  • feof() - Bir dosya tanıtıcısı üzerinde konum dosya sonunda mı diye bakar
  • bzopen() - Bzip2 sıkıştırmalı bir dosyayı açar

bzopen
bzwrite
Bzip2 İşlevleri


Bzip2 dosyasını ikil olarak yazar

bzread
LZF
Bzip2 İşlevleri
PHP Manual

bzwrite

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

bzwrite — Bzip2 dosyasını ikil olarak yazar

Açıklama

int bzwrite ( resource $bz , string $veri [, int $uzunluk ] )

bzwrite() verilen dizgeyi sıkıştırarak belirtilen bzip2 akımına yazar.

Değiştirgeler

bz

Dosya tanıtıcı. Geçerli ve bzopen() işlevi tarafından açılmış bir dosyayı göstermelidir.

veri

Yazılacak veri.

uzunluk

Eğer belirtilmişse, belirtilen uzunluk bayta erişilince (açılmış halde) veya belirtilen veri'nin sonuna gelinmişse yazma işlemi sona erer.

Dönen Değerler

Yazılan baytların sayısı ile veya hata durumunda FALSE ile döner.

Örnekler

Örnek 1 - bzwrite() örneği

<?php

$str = 'bu yazıyı sıkıştırıp yazalım';
$bz = bzopen('/tmp/abc.bz2', 'w');
bzwrite($bz, $str, strlen($str));
bzclose($bz);

?>

Ayrıca Bakınız

  • bzread() - Bzip2 dosyasını ikil olarak okur
  • bzopen() - Bzip2 sıkıştırmalı bir dosyayı açar

bzread
LZF
Bzip2 İşlevleri


LZF

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • LZF İşlevleri
    • lzf_compress — LZF sıkıştırma işlemi
    • lzf_decompress — LZF sıkıştırmasını açma işlemi
    • lzf_optimized_for — LZF eklentisinin neye göre en iyilendirildiğini bildirir
bzwrite
Giriş
Sıkıştırma ve Arşivleme Eklentileri


Giriş

LZF çok hızlı bir sıkıştırma algoritmasıdır ve genellikle hızdan çok az ödün vererek disk alanından tasarruf etmek amacıyla kullanılır. Kullanım alanına göre hızlı çalışması veya daha çok sıkıştırma yapması amacıyla derleme anında ayarlama yapılabilir. Bu eklentide, işlemler için Marc Lehmann tarafından yazılan » liblzf kütüphanesi kullanılmıştır.

LZF
Yapılandırma/Kurulum
LZF


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
LZF


Kurulum

Bu » PECL eklentisi PHP ile gelmez. Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/lzf.

Bu işlevleri kullanabilmek için PHP'yi lzf desteğiyle derlemeniz gereklidir. Bunun için derleme derleme sırasında --with-lzf[=DİZİN] yapılandırma seçeneğini kullanmalısınız. Temel ayarlarla LZF hızlı çalışır ancak az sıkıştırma yapar. Dilerseniz derleme sırasında --enable-lzf-better-compression yapılandırma seçeneğini kullanarak daha çok sıkıştırma ancak daha yavaş çalışma kipine ayarlayabilirsiniz.

Windows kullanıcıları bu işlevleri kullanmak için php.ini dosyası içinden php_lzf.dll dosyasını kullanılır hale getirmeleri gerekir. Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
LZF İşlevleri
LZF


LZF İşlevleri

İçindekiler

  • lzf_compress — LZF sıkıştırma işlemi
  • lzf_decompress — LZF sıkıştırmasını açma işlemi
  • lzf_optimized_for — LZF eklentisinin neye göre en iyilendirildiğini bildirir
Öntanımlı Sabitler
lzf_compress
LZF


LZF sıkıştırma işlemi

LZF İşlevleri
lzf_decompress
LZF İşlevleri
PHP Manual

lzf_compress

(PECL lzf >= 0.1.0)

lzf_compress — LZF sıkıştırma işlemi

Açıklama

string lzf_compress ( string $veri )

lzf_compress() işlevi, belirtilen veri dizgesini LZF kodlamasını kullanarak sıkıştırır.

Değiştirgeler

veri

Sıkıştırılmak istenen dizge.

Dönen Değerler

Hata oluşmuşsa, FALSE yoksa sıkıştırılmış veriyi döndürür.

Ayrıca Bakınız

  • lzf_decompress() - LZF sıkıştırmasını açma işlemi

LZF İşlevleri
lzf_decompress
LZF İşlevleri


LZF sıkıştırmasını açma işlemi

lzf_compress
lzf_optimized_for
LZF İşlevleri
PHP Manual

lzf_decompress

(PECL lzf >= 0.1.0)

lzf_decompress — LZF sıkıştırmasını açma işlemi

Açıklama

string lzf_decompress ( string $veri )

lzf_compress() işlevi verilen lzf sıkıştırmalı dizgi içeren veri dizgisi açar.

Değiştirgeler

veri

Sıkıştırılmış haldeki dizgi.

Dönen Değerler

Hata oluşursa FALSE oluşmazsa verinin sıkıştırılmamış halini döndürür.

Ayrıca Bakınız

  • lzf_compress() - LZF sıkıştırma işlemi

lzf_compress
lzf_optimized_for
LZF İşlevleri


LZF eklentisinin neye göre en iyilendirildiğini bildirir

lzf_decompress
Phar
LZF İşlevleri
PHP Manual

lzf_optimized_for

(PECL lzf >= 1.0.0)

lzf_optimized_for — LZF eklentisinin neye göre en iyilendirildiğini bildirir

Açıklama

int lzf_optimized_for ( void )

LZF uzantısının derleme esnasında hangi amaca yönelik eniyilendirildiğini bildirir.

Dönen Değerler

Eğer LZF hız için eniyilenmişse 1, daha çok sıkıştırması için eniyilenmişse 0 ile döner.

lzf_decompress
Phar
LZF İşlevleri


Phar

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Using Phar Archives
    • Using Phar Archives: Introduction
    • Using Phar Archives: the phar stream wrapper
    • Using Phar Archives: the Phar and PharData class
  • Creating Phar Archives
    • Creating Phar Archives: Introduction
  • What makes a phar a phar and not a tar or a zip?
    • Ingredients of all Phar archives, independent of file format
    • Phar file stub
    • Head-to-head comparison of Phar, Tar and Zip
    • Tar-based phars
    • Zip-based phars
    • Phar File Format
    • Global Phar bitmapped flags
    • Phar manifest file entry definition
    • Phar Signature format
  • Phar — The Phar class
    • Phar::addEmptyDir — Add an empty directory to the phar archive
    • Phar::addFile — Add a file from the filesystem to the phar archive
    • Phar::addFromString — Add a file from a string to the phar archive
    • Phar::apiVersion — Returns the api version
    • Phar::buildFromDirectory — Construct a phar archive from the files within a directory.
    • Phar::buildFromIterator — Construct a phar archive from an iterator.
    • Phar::canCompress — Returns whether phar extension supports compression using either zlib or bzip2
    • Phar::canWrite — Returns whether phar extension supports writing and creating phars
    • Phar::compress — Compresses the entire Phar archive using Gzip or Bzip2 compression
    • Phar::compressAllFilesBZIP2 — Compresses all files in the current Phar archive using Bzip2 compression
    • Phar::compressAllFilesGZ — Compresses all files in the current Phar archive using Gzip compression
    • Phar::compressFiles — Compresses all files in the current Phar archive
    • Phar::__construct — Construct a Phar archive object
    • Phar::convertToData — Convert a phar archive to a non-executable tar or zip file
    • Phar::convertToExecutable — Convert a phar archive to another executable phar archive file format
    • Phar::copy — Copy a file internal to the phar archive to another new file within the phar
    • Phar::count — Returns the number of entries (files) in the Phar archive
    • Phar::createDefaultStub — Create a phar-file format specific stub
    • Phar::decompress — Decompresses the entire Phar archive
    • Phar::decompressFiles — Decompresses all files in the current Phar archive
    • Phar::delMetadata — Deletes the global metadata of the phar
    • Phar::delete — Delete a file within a phar archive
    • Phar::extractTo — Extract the contents of a phar archive to a directory
    • Phar::getMetadata — Returns phar archive meta-data
    • Phar::getModified — Return whether phar was modified
    • Phar::getSignature — Return MD5/SHA1/SHA256/SHA512/OpenSSL signature of a Phar archive
    • Phar::getStub — Return the PHP loader or bootstrap stub of a Phar archive
    • Phar::getSupportedCompression — Return array of supported compression algorithms
    • Phar::getSupportedSignatures — Return array of supported signature types
    • Phar::getVersion — Return version info of Phar archive
    • Phar::hasMetadata — Returns whether phar has global meta-data
    • Phar::interceptFileFuncs — instructs phar to intercept fopen, file_get_contents, opendir, and all of the stat-related functions
    • Phar::isBuffering — Used to determine whether Phar write operations are being buffered, or are flushing directly to disk
    • Phar::isCompressed — Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)
    • Phar::isFileFormat — Returns true if the phar archive is based on the tar/phar/zip file format depending on the parameter
    • Phar::isValidPharFilename — Returns whether the given filename is a valid phar filename
    • Phar::isWritable — Returns true if the phar archive can be modified
    • Phar::loadPhar — Loads any phar archive with an alias
    • Phar::mapPhar — Reads the currently executed file (a phar) and registers its manifest
    • Phar::mount — Mount an external path or file to a virtual location within the phar archive
    • Phar::mungServer — Defines a list of up to 4 $_SERVER variables that should be modified for execution
    • Phar::offsetExists — determines whether a file exists in the phar
    • Phar::offsetGet — Gets a PharFileInfo object for a specific file
    • Phar::offsetSet — set the contents of an internal file to those of an external file
    • Phar::offsetUnset — remove a file from a phar
    • Phar::running — Returns the full path on disk or full phar URL to the currently executing Phar archive
    • Phar::setAlias — Set the alias for the Phar archive
    • Phar::setDefaultStub — Used to set the PHP loader or bootstrap stub of a Phar archive to the default loader
    • Phar::setMetadata — Sets phar archive meta-data
    • Phar::setSignatureAlgorithm — set the signature algorithm for a phar and apply it.
    • Phar::setStub — Used to set the PHP loader or bootstrap stub of a Phar archive
    • Phar::startBuffering — Start buffering Phar write operations, do not modify the Phar object on disk
    • Phar::stopBuffering — Stop buffering write requests to the Phar archive, and save changes to disk
    • Phar::uncompressAllFiles — Uncompresses all files in the current Phar archive
    • Phar::unlinkArchive — Completely remove a phar archive from disk and from memory
    • Phar::webPhar — mapPhar for web-based phars. front controller for web applications
  • PharData — The PharData class
    • PharData::addEmptyDir — Add an empty directory to the tar/zip archive
    • PharData::addFile — Add a file from the filesystem to the tar/zip archive
    • PharData::addFromString — Add a file from the filesystem to the tar/zip archive
    • PharData::buildFromDirectory — Construct a tar/zip archive from the files within a directory.
    • PharData::buildFromIterator — Construct a tar or zip archive from an iterator.
    • PharData::compress — Compresses the entire tar/zip archive using Gzip or Bzip2 compression
    • PharData::compressFiles — Compresses all files in the current tar/zip archive
    • PharData::__construct — Construct a non-executable tar or zip archive object
    • PharData::convertToData — Convert a phar archive to a non-executable tar or zip file
    • PharData::convertToExecutable — Convert a non-executable tar/zip archive to an executable phar archive
    • PharData::copy — Copy a file internal to the phar archive to another new file within the phar
    • PharData::decompress — Decompresses the entire Phar archive
    • PharData::decompressFiles — Decompresses all files in the current zip archive
    • PharData::delMetadata — Deletes the global metadata of a zip archive
    • PharData::delete — Delete a file within a tar/zip archive
    • PharData::extractTo — Extract the contents of a tar/zip archive to a directory
    • PharData::isWritable — Returns true if the tar/zip archive can be modified
    • PharData::offsetSet — set the contents of a file within the tar/zip to those of an external file or string
    • PharData::offsetUnset — remove a file from a tar/zip archive
    • PharData::setAlias — dummy function (Phar::setAlias is not valid for PharData)
    • PharData::setDefaultStub — dummy function (Phar::setDefaultStub is not valid for PharData)
    • Phar::setMetadata — Sets phar archive meta-data
    • Phar::setSignatureAlgorithm — set the signature algorithm for a phar and apply it.
    • PharData::setStub — dummy function (Phar::setStub is not valid for PharData)
  • PharFileInfo — The PharFileInfo class
    • PharFileInfo::chmod — Sets file-specific permission bits
    • PharFileInfo::compress — Compresses the current Phar entry with either zlib or bzip2 compression
    • PharFileInfo::__construct — Construct a Phar entry object
    • PharFileInfo::decompress — Decompresses the current Phar entry within the phar
    • PharFileInfo::delMetadata — Deletes the metadata of the entry
    • PharFileInfo::getCRC32 — Returns CRC32 code or throws an exception if CRC has not been verified
    • PharFileInfo::getCompressedSize — Returns the actual size of the file (with compression) inside the Phar archive
    • PharFileInfo::getMetadata — Returns file-specific meta-data saved with a file
    • PharFileInfo::getPharFlags — Returns the Phar file entry flags
    • PharFileInfo::hasMetadata — Returns the metadata of the entry
    • PharFileInfo::isCRCChecked — Returns whether file entry has had its CRC verified
    • PharFileInfo::isCompressed — Returns whether the entry is compressed
    • PharFileInfo::isCompressedBZIP2 — Returns whether the entry is compressed using bzip2
    • PharFileInfo::isCompressedGZ — Returns whether the entry is compressed using gz
    • PharFileInfo::setCompressedBZIP2 — Compresses the current Phar entry within the phar using Bzip2 compression
    • PharFileInfo::setCompressedGZ — Compresses the current Phar entry within the phar using gz compression
    • PharFileInfo::setMetadata — Sets file-specific meta-data saved with a file
    • PharFileInfo::setUncompressed — Uncompresses the current Phar entry within the phar, if it is compressed
  • PharException — The PharException class
    • PharException — The PharException class provides a phar-specific exception class for try/catch blocks.
lzf_optimized_for
Giriş
Sıkıştırma ve Arşivleme Eklentileri


Giriş

The phar extension provides a way to put entire PHP applications into a single file called a "phar" (PHP Archive) for easy distribution and installation. In addition to providing this service, the phar extension also provides a file-format abstraction method for creating and manipulating tar and zip files through the PharData class, much as PDO provides a unified interface for accessing different databases. Unlike PDO, which cannot convert between different databases, Phar also can convert between tar, zip and phar file formats with a single line of code. see Phar::convertToExecutable() for one example.

What is phar? Phar archives are best characterized as a convenient way to group several files into a single file. As such, a phar archive provides a way to distribute a complete PHP application in a single file and run it from that file without the need to extract it to disk. Additionally, phar archives can be executed by PHP as easily as any other file, both on the commandline and from a web server. Phar is kind of like a thumb drive for PHP applications.

Phar implements this functionality through a Stream Wrapper. Normally, to use an external file within a PHP script, you would use include

Örnek 1 Using an external file

<?php
 include '/path/to/external/file.php';
 ?>

PHP can be thought of as actually translating /path/to/external/file.php into a stream wrapper as file:///path/to/external/file.php, and under the hood it does in fact use the plain file stream wrapper stream functions to access all local files.

To use a file named file.php contained with a phar archive /path/to/myphar.phar, the syntax is very similar to the file:// syntax above.

Örnek 2 Using a file within a phar archive

<?php
 include 'phar:///path/to/myphar.phar/file.php';
 ?>

In fact, one can treat a phar archive exactly as if it were an external disk, using any of fopen()-related functions, opendir() and mkdir()-related functions to read, change, or create new files and directories within the phar archive. This allows complete PHP applications to be distributed in a single file and run directly from that file.

The most common usage for a phar archive is to distribute a complete application in a single file. For instance, the PEAR Installer that is bundled with PHP versions is distributed as a phar archive. To use a phar archive distributed in this way, the archive can be executed on the command-line or via a web server.

Phar archives can be distributed as tar archives, zip archives, or as the custom phar file format designed specifically for the phar extension. Each file format has advantages and disadvantages. The tar and zip file formats can be read or extracted by any third-party tool that can read the format, but require the phar extension in order to run with PHP. The phar file format is customized and unique to the phar extension, and can only be created by the phar extension or the PEAR package » PHP_Archive, but has the advantage that applications created in this format will run even if the phar extension is not enabled.

In other words, even with the phar extension disabled, one can execute or include a phar-based archive. Accessing individual files within a phar archive is only possible with the phar extension unless the phar archive was created by PHP_Archive.

The phar extension is also capable of converting a phar archive from tar to zip or to phar file format in a single command:

Örnek 3 Converting a phar archive from phar to tar file format

<?php
 $phar = new Phar('myphar.phar');
 $pgz = $phar->convertToExecutable(Phar::TAR, Phar::GZ); // makes myphar.phar.tar.gz
 ?>

Phar can compress individual files or an entire archive using gzip compression or bzip2 compression, and can verify archive integrity automatically through the use of MD5, SHA-1, SHA-256 or SHA-512 signatures.

Lastly, the Phar extension is security-conscious, and disables write access to executable phar archives by default, and requires system-level disabling of the phar.readonly php.ini setting in order to create or modify phar archives. Normal tar and zip archives without an executable stub can always be created or modified using the PharData class.

If you are creating applications for distribution, you will want to read How to create Phar Archives. If you want more information on the differences between the three file formats that phar supports, you should read Phar, Tar and Zip.

If you are using phar applications, there are helpful tips in How to use Phar Archives

The word phar is a portmanteau of PHP and Archive and is based loosely on the jar (Java Archive) familiar to Java developers.

The implementation for Phar archives is based on the PEAR package » PHP_Archive, and the implementation details are similar, although the Phar extension is much more powerful. In addition, the Phar extension allows most PHP applications to be run unmodified while PHP_Archive-based phar archives often require extensive modification in order to work.

Phar
Yapılandırma/Kurulum
Phar


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Phar


Gereksinimler

Phar requires PHP 5.2.0 or newer. Additional features require the SPL extension in order to take advantage of iteration and array access to a Phar's file contents. The phar stream does not require any additional extensions to function.

You may optionally wish to enable the zlib and bzip2 extensions to take advantage of compressed phar support. In addition, to take advantage of OpenSSL signing, the OpenSSL extension must be enabled.

Note that a bug in the zlib.deflate stream filter fixed in PHP version 5.2.6 and newer may cause truncation of gzip and bzip2-compressed phar archives.

PHP 5.3 configured with --enable-zend-multibyte makes phar dependant on the ini option detect_unicode.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

The Phar extension is built into PHP as of PHP version 5.3.0. Phar may be installed via the PECL extension with previous PHP versions, and the » Phar PECL page contains further information and history.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Filesystem and Streams Configuration Options
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
phar.readonly | "1" | PHP_INI_ALL |
phar.require_hash | "1" | PHP_INI_ALL |
phar.extract_list | "" | PHP_INI_ALL | Available from phar 1.1.0 to 1.2.3, removed in 2.0.0.
phar.cache_list | "" | PHP_INI_SYSTEM | Available from phar 2.0.0.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

phar.readonly boolean

This option disables creation or modification of Phar archives using the phar stream or Phar object's write support. This setting should always be enabled on production machines, as the phar extension's convenient write support could allow straightforward creation of a php-based virus when coupled with other common security vulnerabilities.

Bilginize:

This setting can only be unset in php.ini due to security reasons. If phar.readonly is disabled in php.ini, the user may enable phar.readonly in a script or disable it later. If phar.readonly is enabled in php.ini, a script may harmlessly "re-enable" the INI variable, but may not disable it.

phar.require_hash boolean

This option will force all opened Phar archives to contain some kind of signature (currently MD5, SHA1, SHA256 and SHA512 are supported), and will refuse to process any Phar archive that does not contain a signature.

Bilginize:

This setting can only be unset in php.ini due to security reasons. If phar.require_hash is disabled in php.ini, the user may enable phar.require_hash in a script or disable it later. If phar.require_hash is enabled in php.ini, a script may harmlessly "re-enable" the INI variable, but may not disable it.

This setting does not affect reading plain tar files with the PharData class.

phar.extract_list string

This INI setting has been removed as of phar 2.0.0

Allows mappings from a full path to a phar archive or its alias to the location of its extracted files. The format of the parameter is name=archive,name2=archive2. This allows extraction of phar files to disk, and allows phar to act as a kind of mapper to extracted disk files. This is often done for performance reasons, or to assist with debugging a phar.

Örnek 1 phar.extract_list usage example

in php.ini:
phar.extract_list = archive=/full/path/to/archive/,arch2=/full/path/to/arch2
<?php
include "phar://archive/content.php";
include "phar://arch2/foo.php";
?>

phar.cache_list string

This INI setting was added in phar 2.0.0

Allows mapping phar archives to be pre-parsed at web server startup, providing a performance improvement that brings running files out of a phar archive very close to the speed of running those files from a traditional disk-based installation.

Örnek 2 phar.cache_list usage example

in php.ini (windows):
phar.cache_list =C:\path\to\phar1.phar;C:\path\to\phar2.phar
in php.ini (unix):
phar.cache_list =/path/to/phar1.phar:/path/to/phar2.phar

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Özkaynak Türleri

The Phar extension provides the phar stream, which allows accessing files contained within a phar transparently. See also the description of the Phar file format.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

Phar compression constants
Constant | Value | Description
Phar::NONE (integer) | 0x00000000 | no compression
Phar::COMPRESSED (integer) | 0x0000F000 | bitmask that can be used with file flags to determine if any compression is present
Phar::GZ (integer) | 0x00001000 | zlib (gzip) compression
Phar::BZ2 (integer) | 0x00002000 | bzip2 compression
Phar file format constants
Constant | Value | Description
Phar::SAME (integer) | 0 | retain the same file format
Phar::PHAR (integer) | 1 | phar file format
Phar::TAR (integer) | 2 | tar file format
Phar::ZIP (integer) | 3 | zip file format
Phar signature constants
Constant | Value | Description
Phar::MD5 (integer) | 0x0001 | signature with md5 hash algorithm
Phar::SHA1 (integer) | 0x0002 | signature with sha1 hash algorithm
Phar::SHA256 (integer) | 0x0003 | signature with sha256 hash algorithm (requires hash extension)
Phar::SHA512 (integer) | 0x0004 | signature with sha512 hash algorithm (requires hash extension)
Phar::OPENSSL (integer) | 0x0010 | signature with OpenSSL public/private key pair. This is a true, asymmetric key signature.
Phar webPhar mime override constants
Constant | Value | Description
Phar::PHP (integer) | 1 | used to instruct the mimeoverrides parameter of Phar::webPhar() that the extension should be parsed as a PHP file
Phar::PHPS (integer) | 2 | used to instruct the mimeoverrides parameter of Phar::webPhar() that the extension should be parsed as a PHP source file through highlight_file()
Özkaynak Türleri
Using Phar Archives
Phar


Using Phar Archives

İçindekiler

  • Using Phar Archives: Introduction
  • Using Phar Archives: the phar stream wrapper
  • Using Phar Archives: the Phar and PharData class
Öntanımlı Sabitler
Using Phar Archives: Introduction
Phar


Using Phar Archives: Introduction

Phar archives are similar in concept to Java JAR archives, but are tailored to the needs and to the flexibility of PHP applications. A Phar archive is used to distribute a complete PHP application or library in a single file. A Phar archive application is used exactly like any other PHP application:

php coolapplication.phar

Using a Phar archive library is identical to using any other PHP library:

<?php
include 'coollibrary.phar';
?>

The phar stream wrapper provides the core of the phar extension, and is explained in detail here. The phar stream wrapper allows accessing the files within a phar archive using PHP's standard file functions fopen(), opendir(), and others that work on regular files. The phar stream wrapper supports all read/write operations on both files and directories.

<?php
include 'phar://coollibrary.phar/internal/file.php';
header('Content-type: image/jpeg');
// phars can be accessed by full path or by alias
echo file_get_contents('phar:///fullpath/to/coollibrary.phar/images/wow.jpg');
?>

The Phar class implements advanced functionality for accessing files and for creating phar archives. The Phar class is explained in detail here.

<?php
try {
    // open an existing phar
    $p = new Phar('coollibrary.phar', 0);
    // Phar extends SPL's DirectoryIterator class
    foreach (new RecursiveIteratorIterator($p) as $file) {
        // $file is a PharFileInfo class, and inherits from SplFileInfo
        echo $file->getFileName() . "\n";
        echo file_get_contents($file->getPathName()) . "\n"; // display contents;
    }
    if (isset($p['internal/file.php'])) {
        var_dump($p['internal/file.php']->getMetadata());
    }

    // create a new phar - phar.readonly must be 0 in php.ini
    // phar.readonly is enabled by default for security reasons.
    // On production servers, Phars need never be created,
    // only executed.
    if (Phar::canWrite()) {
        $p = new Phar('newphar.tar.phar', 0, 'newphar.tar.phar');
        // make this a tar-based phar archive, compressed with gzip compression (.tar.gz)
        $p = $p->convertToExecutable(Phar::TAR, Phar::GZ);

        // create transaction - nothing is written to newphar.phar
        // until stopBuffering() is called, although temporary storage is needed
        $p->startBuffering();
        // add all files in /path/to/project, saving in the phar with the prefix "project"
        $p->buildFromIterator(new RecursiveIteratorIterator(new DirectoryIterator('/path/to/project')), '/path/to/');

        // add a new file via the array access API
        $p['file1.txt'] = 'Information';
        $fp = fopen('hugefile.dat', 'rb');
        // copy all data from the stream
        $p['data/hugefile.dat'] = $fp;

        if (Phar::canCompress(Phar::GZ)) {
            $p['data/hugefile.dat']->compress(Phar::GZ);
        }

        $p['images/wow.jpg'] = file_get_contents('images/wow.jpg');
        // any value can be saved as file-specific meta-data
        $p['images/wow.jpg']->setMetadata(array('mime-type' => 'image/jpeg'));
        $p['index.php'] = file_get_contents('index.php');
        $p->setMetadata(array('bootstrap' => 'index.php'));

        // save the phar archive to disk
        $p->stopBuffering();
    }
} catch (Exception $e) {
    echo 'Could not open Phar: ', $e;
}
?>

In addition, verification of phar file contents can be done using any of the supported symmetric hash algorithms (MD5, SHA1, SHA256 and SHA512 if ext/hash is enabled) and using asymmetric public/private key signing using OpenSSL (new in Phar 2.0.0). To take advantage of OpenSSL signing, you need to generate a public/private key pair, and use the private key to set the signature using Phar::setSignatureAlgorithm(). In addition, the public key as extracted using this code:

<?php
$public = openssl_get_publickey(file_get_contents('private.pem'));
$pkey = '';
openssl_pkey_export($public, $pkey);
?>
must be saved adjacent to the phar archive it verifies. If the phar archive is saved as /path/to/my.phar, the public key must be saved as /path/to/my.phar.pubkey, or phar will be unable to verify the OpenSSL signature.

As of version 2.0.0, The Phar class also provides 3 static methods, Phar::webPhar(), Phar::mungServer() and Phar::interceptFileFuncs() that are crucial to packaging up PHP applications designed for usage on regular filesystems and for web-based applications. Phar::webPhar() implements a front controller that routes HTTP calls to the correct location within the phar archive. Phar::mungServer() is used to modify the values of the $_SERVER array to trick applications that process these values. Phar::interceptFileFuncs() instructs Phar to intercept calls to fopen(), file_get_contents(), opendir(), and all of the stat-based functions (file_exists(), is_readable() and so on) and route all relative paths to locations within the phar archive.

As an example, packaging up a release of the popular phpMyAdmin application for use as a phar archive requires only this simple script and then phpMyAdmin.phar.tar.php can be accessed as a regular file from your web server after modifying the user/password:

<?php
@unlink('phpMyAdmin.phar.tar.php');
copy('phpMyAdmin-2.11.3-english.tar.gz', 'phpMyAdmin.phar.tar.php');
$a = new Phar('phpMyAdmin.phar.tar.php');
$a->startBuffering();
$a["phpMyAdmin-2.11.3-english/config.inc.php"] = '<?php
/* Servers configuration */
$i = 0;

/* Server localhost (config:root) [1] */
$i++;
$cfg[\'Servers\'][$i][\'host\'] = \'localhost\';
$cfg[\'Servers\'][$i][\'extension\'] = \'mysqli\';
$cfg[\'Servers\'][$i][\'connect_type\'] = \'tcp\';
$cfg[\'Servers\'][$i][\'compress\'] = false;
$cfg[\'Servers\'][$i][\'auth_type\'] = \'config\';
$cfg[\'Servers\'][$i][\'user\'] = \'root\';
$cfg[\'Servers\'][$i][\'password\'] = \'\';

/* End of servers configuration */
if (strpos(PHP_OS, \'WIN\') !== false) {
    $cfg[\'UploadDir\'] = getcwd();
} else {
    $cfg[\'UploadDir\'] = \'/tmp/pharphpmyadmin\';
    @mkdir(\'/tmp/pharphpmyadmin\');
    @chmod(\'/tmp/pharphpmyadmin\', 0777);
}';
$a->setStub('<?php
Phar::interceptFileFuncs();
Phar::webPhar("phpMyAdmin.phar", "phpMyAdmin-2.11.3-english/index.php");
echo "phpMyAdmin is intended to be executed from a web browser\n";
exit -1;
__HALT_COMPILER();
');
$a->stopBuffering();
?>

Using Phar Archives
Using Phar Archives: the phar stream wrapper
Using Phar Archives


Using Phar Archives: the phar stream wrapper

The Phar stream wrapper fully supports fopen() for read and write (not append), unlink(), stat(), fstat(), fseek(), rename() and directory stream operations opendir() and as of version 2.0.0, rmdir() and mkdir().

Individual file compression and per-file metadata can also be manipulated in a Phar archive using stream contexts:

<?php
$context = stream_context_create(array('phar' =>
                                    array('compress' => Phar::GZ)),
                                    array('metadata' => array('user' => 'cellog')));
file_put_contents('phar://my.phar/somefile.php', 0, $context);
?>

The phar stream wrapper does not operate on remote files, and cannot operate on remote files, and so is allowed even when the allow_url_fopen and allow_url_include INI options are disabled.

Although it is possible to create phar archives from scratch just using stream operations, it is best to use the functionality built into the Phar class. The stream wrapper is best used for read-only operations.

Using Phar Archives: Introduction
Using Phar Archives: the Phar and PharData class
Using Phar Archives


Using Phar Archives: the Phar and PharData class

The Phar class supports reading and manipulation of Phar archives, as well as iteration through inherited functionality of the RecursiveDirectoryIterator class. With support for the ArrayAccess interface, files inside a Phar archive can be accessed as if they were part of an associative array.

The PharData class extends the Phar, and allows creating and modifying non-executable (data) tar and zip archives even if phar.readonly=1 in php.ini. As such, PharData::setAlias() and PharData::setStub() are both disabled as the concept of alias and stub are unique to executable phar archives.

It is important to note that when creating a Phar archive, the full path should be passed to the Phar object constructor. Relative paths will fail to initialize.

Assuming that $p is a Phar object initialized as follows:

<?php
$p = new Phar('/path/to/myphar.phar', 0, 'myphar.phar');
?>

An empty Phar archive will be created at /path/to/myphar.phar, or if /path/to/myphar.phar already exists, it will be opened again. The literal myphar.phar demonstrates the concept of an alias that can be used to reference /path/to/myphar.phar in URLs as in:

<?php
// these two calls to file_get_contents() are equivalent if
// /path/to/myphar.phar has an explicit alias of "myphar.phar"
// in its manifest, or if the phar was initialized with the
// previous example's Phar object setup
$f = file_get_contents('phar:///path/to/myphar.phar/whatever.txt');
$f = file_get_contents('phar://myphar.phar/whatever.txt');
?>

With the newly created $p Phar object, the following is possible:

  • $a = $p['file.php'] creates a PharFileInfo class that refers to the contents of phar://myphar.phar/file.php
  • $p['file.php'] = $v creates a new file (phar://myphar.phar/file.php), or overwrites an existing file within myphar.phar. $v can be either a string or an open file pointer, in which case the entire contents of the file will be used to create the new file. Note that $p->addFromString('file.php', $v) is functionally equivalent to the above. Also possible is to add the contents of a file with $p->addFile('/path/to/file.php', 'file.php'). Lastly, an empty directory can be created with $p->addEmptyDir('empty').
  • isset($p['file.php']) can be used to determine whether phar://myphar.phar/file.php exists within myphar.phar.
  • unset($p['file.php']) erases phar://myphar.phar/file.php from myphar.phar.

In addition, the Phar object is the only way to access Phar-specific metadata, through Phar::getMetadata(), and the only way to set or retrieve a Phar archive's PHP loader stub through Phar::getStub() and Phar::setStub(). Additionally, compression for the entire Phar archive at once can only be manipulated using the Phar class.

The full list of Phar object functionality is documented below.

The PharFileInfo class extends the SplFileInfo class, and adds several methods for manipulating Phar-specific details of a file contained within a Phar, such as manipulating compression and metadata.

Using Phar Archives: the phar stream wrapper
Creating Phar Archives
Using Phar Archives


Creating Phar Archives

İçindekiler

  • Creating Phar Archives: Introduction
Using Phar Archives: the Phar and PharData class
Creating Phar Archives: Introduction
Phar


Creating Phar Archives: Introduction

To be written fully in the near future. Before reading this, be sure to read How to use Phar Archives.

A great place to start is by reading about Phar::buildFromIterator(), and the specifics of the file format choices available for archives. A healthy understanding of what a stub is and does is crucial to phar archive creation, and so Phar::setStub() and Phar::createDefaultStub() are good places to start as well. If you are distributing a web-based application, it is crucial to know about Phar::webPhar() and related method Phar::mungServer(). Any application that accesses its own files should also consider using Phar::interceptFileFuncs().

Creating Phar Archives
What makes a phar a phar and not a tar or a zip?
Creating Phar Archives


What makes a phar a phar and not a tar or a zip?

İçindekiler

  • Ingredients of all Phar archives, independent of file format
  • Phar file stub
  • Head-to-head comparison of Phar, Tar and Zip
  • Tar-based phars
  • Zip-based phars
  • Phar File Format
  • Global Phar bitmapped flags
  • Phar manifest file entry definition
  • Phar Signature format
Creating Phar Archives: Introduction
Ingredients of all Phar archives, independent of file format
Phar


Ingredients of all Phar archives, independent of file format

All Phar archives contain three to four sections:

  1. a stub

  2. a manifest describing the contents

  3. the file contents

  4. [optional] a signature for verifying Phar integrity (phar file format only)

What makes a phar a phar and not a tar or a zip?
Phar file stub
What makes a phar a phar and not a tar or a zip?


Phar file stub

A Phar's stub is a simple PHP file. The smallest possible stub follows:

<?php __HALT_COMPILER();

A stub must contain as a minimum, the __HALT_COMPILER(); token at its conclusion. Typically, a stub will contain loader functionality like so:

<?php
Phar::mapPhar();
include 'phar://myphar.phar/index.php';
__HALT_COMPILER();

There are no restrictions on the contents of a Phar stub, except for the requirement that it conclude with __HALT_COMPILER();. The closing PHP tag

?>
may be included or omitted, but there can be no more than 1 space between the ; and the close tag
?>
 or the phar extension will be unable to process the Phar archive's manifest.

In a tar or zip-based phar archive, the stub is stored in the .phar/stub.php file. The default stub for phar-based Phar archives contains approximately 7k of code to extract the contents of the phar and execute them. See Phar::createDefaultStub() for more detail.

The phar alias is stored in a tar or zip-based phar archive in the .phar/alias.txt file as plain text.

Ingredients of all Phar archives, independent of file format
Head-to-head comparison of Phar, Tar and Zip
What makes a phar a phar and not a tar or a zip?


Head-to-head comparison of Phar, Tar and Zip

What are the good and the bad things about the three supported file formats in the phar extension? This table attempts to address that question.

Feature matrix: Phar vs. Tar vs. Zip
Feature | Phar | Tar | Zip
Standard File Format | No | Yes | Yes
Can be executed without the Phar Extension [1] | Yes | No | No
Per-file compression | Yes | No | Yes
Whole-archive compression | Yes | Yes | No
Whole-archive signature validation | Yes | Yes | Yes (PHP 5.3.1+)
Web-specific application support | Yes | Yes | Yes
Per-file Meta-data | Yes | Yes | Yes
Whole-Archive Meta-data | Yes | Yes | Yes
Archive creation/modification [2] | Yes | Yes | Yes
Full support for all stream wrapper functions | Yes | Yes | Yes
Can be created/modified even if phar.readonly=1 [3] | No | Yes | Yes

İpucu

[1] PHP can only directly access the contents of a Phar archive without the Phar extension if it is using a stub that extracts the contents of the phar archive. The stub created by Phar::createDefaultStub() extracts the phar archive and runs its contents from a temporary directory if no phar extension is found.

İpucu

[2] All write access requires phar.readonly to be disabled in php.ini or on the command-line directly.

İpucu

[3] Only tar and zip archives without .phar in their filename and without an executable stub .phar/stub.php can be created if phar.readonly=1.

Phar file stub
Tar-based phars
What makes a phar a phar and not a tar or a zip?


Tar-based phars

Archives based on the tar file format follow the more modern USTAR file format. The design of the tar file header makes them more efficient to access than the zip file format, and almost as efficient as the phar file format. File names are limited to 255 bytes, including full path within the phar archive. There is no limit on the number of files within a tar-based phar archive. These archives can fully compressed in gzip or bzip2 format and still be executed by the Phar extension.

To compress an entire archive, use Phar::compress(). To decompress an entire archive, use Phar::decompress().

Head-to-head comparison of Phar, Tar and Zip
Zip-based phars
What makes a phar a phar and not a tar or a zip?


Zip-based phars

Archives based on the zip file format support several features built into the zip file format. Per-file and whole-archive metadata is stored in the zip file comment and zip archive comment as a serialized string. Pre-existing zip comments will be successfully read as a string. Per-file compression read/write is supported with zlib compression, and read access is supported with bzip2 compression. There is no limit on the number of files within a zip-based phar archive. Empty directories are stored in the zip archive as files with a trailing slash like my/directory/

Tar-based phars
Phar File Format
What makes a phar a phar and not a tar or a zip?


Phar File Format

The phar file format is literally laid out as stub/manifest/contents/signature, and stores the crucial information of what is included in the phar archive in its manifest.

The Phar manifest is a highly optimized format that allows per-file specification of file compression, file permissions, and even user-defined meta-data such as file user or group. All values greater than 1 byte are stored in little-endian byte order, with the exception of the API version, which for historical reasons is stored as 3 nibbles in big-endian order.

All unused flags are reserved for future use, and must not be used to store custom information. Use the per-file meta-data facility to store customized information about particular files.

The basic file format of a Phar archive manifest is as follows:

Global Phar manifest format
Size in bytes | Description
4 bytes | Length of manifest in bytes (1 MB limit)
4 bytes | Number of files in the Phar
2 bytes | API version of the Phar manifest (currently 1.0.0)
4 bytes | Global Phar bitmapped flags
4 bytes | Length of Phar alias
?? | Phar alias (length based on previous)
4 bytes | Length of Phar metadata (0 for none)
?? | Serialized Phar Meta-data, stored in serialize() format
at least 24 * number of entries bytes | entries for each file

Zip-based phars
Global Phar bitmapped flags
What makes a phar a phar and not a tar or a zip?


Global Phar bitmapped flags

Here are the bitmapped flags currently recognized by the Phar extension for the global Phar flat bitmap:

Bitmap values recognized
Value | Description
0x00010000 | If set, this Phar contains a verification signature
0x00001000 | If set, this Phar contains at least 1 file that is compressed with zlib compression
0x00002000 | If set, this Phar contains at least 1 file that is compressed with bzip compression

Phar File Format
Phar manifest file entry definition
What makes a phar a phar and not a tar or a zip?


Phar manifest file entry definition

Each file in the manifest contains the following information:

Phar Manifest file entry
Size in bytes | Description
4 bytes | Filename length in bytes
?? | Filename (length specified in previous)
4 bytes | Un-compressed file size in bytes
4 bytes | Unix timestamp of file
4 bytes | Compressed file size in bytes
4 bytes | CRC32 checksum of un-compressed file contents
4 bytes | Bit-mapped File-specific flags
4 bytes | Serialized File Meta-data length (0 for none)
?? | Serialized File Meta-data, stored in serialize() format

Note that as of API version 1.1.1, empty directories are stored as filenames with a trailing slash like my/directory/

The File-specific bitmap values recognized are:

Bitmap values recognized
Value | Description
0x000001FF | These bits are reserved for defining specific file permissions of a file. Permissions are used for fstat() and can be used to recreate desired permissions upon extraction.
0x00001000 | If set, this file is compressed with zlib compression
0x00002000 | If set, this file is compressed with bzip compression

Global Phar bitmapped flags
Phar Signature format
What makes a phar a phar and not a tar or a zip?


Phar Signature format

Phars containing a signature always have the signature appended to the end of the Phar archive after the loader, manifest, and file contents. The two signature formats supported at this time are MD5 and SHA1.

Signature format
Length in bytes | Description
16 or 20 bytes | The actual signature, 20 bytes for an SHA1 signature, 16 bytes for an MD5 signature, 32 bytes for an SHA256 signature, and 64 bytes for an SHA512 signature.
4 bytes | Signature flags. 0x0001 is used to define an MD5 signature, 0x0002 is used to define an SHA1 signature, 0x0004 is used to define an SHA256 signature, and 0x0008 is used to define an SHA512 signature. The SHA256 and SHA512 signature support was introduced with API version 1.1.0.
4 bytes | Magic GBMB used to define the presence of a signature.

Phar manifest file entry definition
Phar
What makes a phar a phar and not a tar or a zip?


The Phar class

(PHP >= 5.3.0, PECL phar >= 1.0.0)

Giriş

The Phar class provides a high-level interface to accessing and creating phar archives.

Sınıf Sözdizimi

Phar extends RecursiveDirectoryIterator implements Countable , ArrayAccess {
/* Yöntemler */
public void addEmptyDir ( string $dirname )
public void addFile ( string $file [, string $localname ] )
public void addFromString ( string $localname , string $contents )
final public static string apiVersion ( void )
public array buildFromDirectory ( string $base_dir [, string $regex ] )
public array buildFromIterator ( Iterator $iter [, string $base_directory ] )
final public static bool canCompress ([ int $type = 0 ] )
final public static bool canWrite ( void )
public object compress ( int $compression [, string $extension ] )
public bool compressAllFilesBZIP2 ( void )
public bool compressAllFilesGZ ( void )
public void compressFiles ( int $compression )
public __construct ( string $fname [, int $flags [, string $alias ]] )
public PharData convertToData ([ int $format = 9021976 [, int $compression = 9021976 [, string $extension ]]] )
public Phar convertToExecutable ([ int $format = 9021976 [, int $compression = 9021976 [, string $extension ]]] )
public bool copy ( string $oldfile , string $newfile )
public int count ( void )
final public static string createDefaultStub ([ string $indexfile [, string $webindexfile ]] )
public object decompress ([ string $extension ] )
public bool decompressFiles ( void )
public bool delMetadata ( void )
public bool delete ( string $entry )
public bool extractTo ( string $pathto [, string|array $files [, bool $overwrite = false ]] )
public mixed getMetadata ( void )
public bool getModified ( void )
public array getSignature ( void )
public string getStub ( void )
final public static array getSupportedCompression ( void )
final public static array getSupportedSignatures ( void )
public string getVersion ( void )
public bool hasMetadata ( void )
final public static void interceptFileFuncs ( void )
public bool isBuffering ( void )
public mixed isCompressed ( void )
public bool isFileFormat ( int $format )
final public static bool isValidPharFilename ( string $filename [, bool $executable = true ] )
public bool isWritable ( void )
final public static bool loadPhar ( string $filename [, string $alias ] )
final public static bool mapPhar ([ string $alias [, int $dataoffset = 0 ]] )
final public static void mount ( string $pharpath , string $externalpath )
final public static void mungServer ( array $munglist )
public bool offsetExists ( string $offset )
public int offsetGet ( string $offset )
public void offsetSet ( string $offset , string $value )
public bool offsetUnset ( string $offset )
final public static string running ([ bool $retphar = true ] )
public bool setAlias ( string $alias )
public bool setDefaultStub ([ string $index [, string $webindex ]] )
public void setMetadata ( mixed $metadata )
public void setSignatureAlgorithm ( int $sigtype [, string $privatekey ] )
public bool setStub ( string $stub [, int $len = -1 ] )
public void startBuffering ( void )
public void stopBuffering ( void )
public bool uncompressAllFiles ( void )
final public static bool unlinkArchive ( string $archive )
final public static void webPhar ([ string $alias [, string $index = "index.php" [, string $f404 [, array $mimetypes [, callable $rewrites ]]]]] )
}

İçindekiler

  • Phar::addEmptyDir — Add an empty directory to the phar archive
  • Phar::addFile — Add a file from the filesystem to the phar archive
  • Phar::addFromString — Add a file from a string to the phar archive
  • Phar::apiVersion — Returns the api version
  • Phar::buildFromDirectory — Construct a phar archive from the files within a directory.
  • Phar::buildFromIterator — Construct a phar archive from an iterator.
  • Phar::canCompress — Returns whether phar extension supports compression using either zlib or bzip2
  • Phar::canWrite — Returns whether phar extension supports writing and creating phars
  • Phar::compress — Compresses the entire Phar archive using Gzip or Bzip2 compression
  • Phar::compressAllFilesBZIP2 — Compresses all files in the current Phar archive using Bzip2 compression
  • Phar::compressAllFilesGZ — Compresses all files in the current Phar archive using Gzip compression
  • Phar::compressFiles — Compresses all files in the current Phar archive
  • Phar::__construct — Construct a Phar archive object
  • Phar::convertToData — Convert a phar archive to a non-executable tar or zip file
  • Phar::convertToExecutable — Convert a phar archive to another executable phar archive file format
  • Phar::copy — Copy a file internal to the phar archive to another new file within the phar
  • Phar::count — Returns the number of entries (files) in the Phar archive
  • Phar::createDefaultStub — Create a phar-file format specific stub
  • Phar::decompress — Decompresses the entire Phar archive
  • Phar::decompressFiles — Decompresses all files in the current Phar archive
  • Phar::delMetadata — Deletes the global metadata of the phar
  • Phar::delete — Delete a file within a phar archive
  • Phar::extractTo — Extract the contents of a phar archive to a directory
  • Phar::getMetadata — Returns phar archive meta-data
  • Phar::getModified — Return whether phar was modified
  • Phar::getSignature — Return MD5/SHA1/SHA256/SHA512/OpenSSL signature of a Phar archive
  • Phar::getStub — Return the PHP loader or bootstrap stub of a Phar archive
  • Phar::getSupportedCompression — Return array of supported compression algorithms
  • Phar::getSupportedSignatures — Return array of supported signature types
  • Phar::getVersion — Return version info of Phar archive
  • Phar::hasMetadata — Returns whether phar has global meta-data
  • Phar::interceptFileFuncs — instructs phar to intercept fopen, file_get_contents, opendir, and all of the stat-related functions
  • Phar::isBuffering — Used to determine whether Phar write operations are being buffered, or are flushing directly to disk
  • Phar::isCompressed — Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)
  • Phar::isFileFormat — Returns true if the phar archive is based on the tar/phar/zip file format depending on the parameter
  • Phar::isValidPharFilename — Returns whether the given filename is a valid phar filename
  • Phar::isWritable — Returns true if the phar archive can be modified
  • Phar::loadPhar — Loads any phar archive with an alias
  • Phar::mapPhar — Reads the currently executed file (a phar) and registers its manifest
  • Phar::mount — Mount an external path or file to a virtual location within the phar archive
  • Phar::mungServer — Defines a list of up to 4 $_SERVER variables that should be modified for execution
  • Phar::offsetExists — determines whether a file exists in the phar
  • Phar::offsetGet — Gets a PharFileInfo object for a specific file
  • Phar::offsetSet — set the contents of an internal file to those of an external file
  • Phar::offsetUnset — remove a file from a phar
  • Phar::running — Returns the full path on disk or full phar URL to the currently executing Phar archive
  • Phar::setAlias — Set the alias for the Phar archive
  • Phar::setDefaultStub — Used to set the PHP loader or bootstrap stub of a Phar archive to the default loader
  • Phar::setMetadata — Sets phar archive meta-data
  • Phar::setSignatureAlgorithm — set the signature algorithm for a phar and apply it.
  • Phar::setStub — Used to set the PHP loader or bootstrap stub of a Phar archive
  • Phar::startBuffering — Start buffering Phar write operations, do not modify the Phar object on disk
  • Phar::stopBuffering — Stop buffering write requests to the Phar archive, and save changes to disk
  • Phar::uncompressAllFiles — Uncompresses all files in the current Phar archive
  • Phar::unlinkArchive — Completely remove a phar archive from disk and from memory
  • Phar::webPhar — mapPhar for web-based phars. front controller for web applications
Phar Signature format
Phar::addEmptyDir
Phar


Add an empty directory to the phar archive

Phar
Phar::addFile
Phar
PHP Manual

Phar::addEmptyDir

(Unknown)

Phar::addEmptyDir — Add an empty directory to the phar archive

Açıklama

public void Phar::addEmptyDir ( string $dirname )

Bilginize:

Phar nesneleri ile çalışmak için, bu yöntem phar.readonly php.ini yönergesine 0 atanmış olmasını gerektirir. Aksi takdirde bir PharException istisnası oluşur.

With this method, an empty directory is created with path dirname. This method is similar to ZipArchive::addEmptyDir().

Değiştirgeler

dirname

The name of the empty directory to create in the phar archive

Dönen Değerler

no return value, exception is thrown on failure.

Örnekler

Örnek 1 A Phar::addEmptyDir() example

<?php
try {
    $a = new Phar('/path/to/phar.phar');

    $a->addEmptyDir('/full/path/to/file');
    // demonstrates how this file is stored
    $b = $a['full/path/to/file']->isDir();
} catch (Exception $e) {
    // handle errors here
}
?>

Ayrıca Bakınız

  • PharData::addEmptyDir() - Add an empty directory to the tar/zip archive
  • Phar::addFile() - Add a file from the filesystem to the phar archive
  • Phar::addFromString() - Add a file from a string to the phar archive

Phar
Phar::addFile
Phar


Add a file from the filesystem to the phar archive

Phar::addEmptyDir
Phar::addFromString
Phar
PHP Manual

Phar::addFile

(Unknown)

Phar::addFile — Add a file from the filesystem to the phar archive

Açıklama

public void Phar::addFile ( string $file [, string $localname ] )

Bilginize:

Phar nesneleri ile çalışmak için, bu yöntem phar.readonly php.ini yönergesine 0 atanmış olmasını gerektirir. Aksi takdirde bir PharException istisnası oluşur.

With this method, any file or URL can be added to the phar archive. If the optional second parameter localname is specified, the file will be stored in the archive with that name, otherwise the file parameter is used as the path to store within the archive. URLs must have a localname or an exception is thrown. This method is similar to ZipArchive::addFile().

Değiştirgeler

file

Full or relative path to a file on disk to be added to the phar archive.

localname

Path that the file will be stored in the archive.

Dönen Değerler

no return value, exception is thrown on failure.

Örnekler

Örnek 1 A Phar::addFile() example

<?php
try {
    $a = new Phar('/path/to/phar.phar');

    $a->addFile('/full/path/to/file');
    // demonstrates how this file is stored
    $b = $a['full/path/to/file']->getContent();

    $a->addFile('/full/path/to/file', 'my/file.txt');
    $c = $a['my/file.txt']->getContent();

    // demonstrate URL usage
    $a->addFile('http://www.example.com', 'example.html');
} catch (Exception $e) {
    // handle errors here
}
?>

Ayrıca Bakınız

  • Phar::offsetSet() - set the contents of an internal file to those of an external file
  • PharData::addFile() - Add a file from the filesystem to the tar/zip archive
  • Phar::addFromString() - Add a file from a string to the phar archive
  • Phar::addEmptyDir() - Add an empty directory to the phar archive

Phar::addEmptyDir
Phar::addFromString
Phar


Add a file from a string to the phar archive

Phar::addFile
Phar::apiVersion
Phar
PHP Manual

Phar::addFromString

(Unknown)

Phar::addFromString — Add a file from a string to the phar archive

Açıklama

public void Phar::addFromString ( string $localname , string $contents )

Bilginize:

Phar nesneleri ile çalışmak için, bu yöntem phar.readonly php.ini yönergesine 0 atanmış olmasını gerektirir. Aksi takdirde bir PharException istisnası oluşur.

With this method, any string can be added to the phar archive. The file will be stored in the archive with localname as its path. This method is similar to ZipArchive::addFromString().

Değiştirgeler

localname

Path that the file will be stored in the archive.

contents

The file contents to store

Dönen Değerler

no return value, exception is thrown on failure.

Örnekler

Örnek 1 A Phar::addFromString() example

<?php
try {
    $a = new Phar('/path/to/phar.phar');

    $a->addFromString('path/to/file.txt', 'my simple file');
    $b = $a['path/to/file.txt']->getContent();

    // to add contents from a stream handle for large files, use offsetSet()
    $c = fopen('/path/to/hugefile.bin');
    $a['largefile.bin'] = $c;
    fclose($c);
} catch (Exception $e) {
    // handle errors here
}
?>

Ayrıca Bakınız

  • Phar::offsetSet() - set the contents of an internal file to those of an external file
  • PharData::addFromString() - Add a file from the filesystem to the tar/zip archive
  • Phar::addFile() - Add a file from the filesystem to the phar archive
  • Phar::addEmptyDir() - Add an empty directory to the phar archive

Phar::addFile
Phar::apiVersion
Phar


Returns the api version

Phar::addFromString
Phar::buildFromDirectory
Phar
PHP Manual

Phar::apiVersion

(PHP >= 5.3.0, PECL phar >= 1.0.0)

Phar::apiVersion — Returns the api version

Açıklama

final public static string Phar::apiVersion ( void )

Return the API version of the phar file format that will be used when creating phars. The Phar extension supports reading API version 1.0.0 or newer. API version 1.1.0 is required for SHA-256 and SHA-512 hash, and API version 1.1.1 is required to store empty directories.

Değiştirgeler

Dönen Değerler

The API version string as in "1.0.0".

Örnekler

Örnek 1 A Phar::apiVersion() example

<?php
echo Phar::apiVersion();
?>

Yukarıdaki örneğin çıktısı:

1.1.1

Phar::addFromString
Phar::buildFromDirectory
Phar


Construct a phar archive from the files within a directory.

Phar::apiVersion
Phar::buildFromIterator
Phar
PHP Manual

Phar::buildFromDirectory

(PHP >= 5.3.0, PECL phar >= 2.0.0)

Phar::buildFromDirectory — Construct a phar archive from the files within a directory.

Açıklama

public array Phar::buildFromDirectory ( string $base_dir [, string $regex ] )

Bilginize:

Phar nesneleri ile çalışmak için, bu yöntem phar.readonly php.ini yönergesine 0 atanmış olmasını gerektirir. Aksi takdirde bir PharException istisnası oluşur.

Populate a phar archive from directory contents. The optional second parameter is a regular expression (pcre) that is used to exclude files. Any filename that matches the regular expression will be included, all others will be excluded. For more fine-grained control, use Phar::buildFromIterator().

Değiştirgeler

base_dir

The full or relative path to the directory that contains all files to add to the archive.

regex

An optional pcre regular expression that is used to filter the list of files. Only file paths matching the regular expression will be included in the archive.

Dönen Değerler

Phar::buildFromDirectory() returns an associative array mapping internal path of file to the full path of the file on the filesystem.

Hatalar/İstisnalar

This method throws BadMethodCallException when unable to instantiate the internal directory iterators, or a PharException if there were errors saving the phar archive.

Örnekler

Örnek 1 A Phar::buildFromDirectory() example

<?php
// create with alias "project.phar"
$phar = new Phar('project.phar', 0, 'project.phar');
// add all files in the project
$phar->buildFromDirectory(dirname(__FILE__) . '/project');
$phar->setStub($phar->createDefaultStub('cli/index.php', 'www/index.php'));

$phar2 = new Phar('project2.phar', 0, 'project2.phar');
// add all files in the project, only include php files
$phar2->buildFromDirectory(dirname(__FILE__) . '/project', '/\.php$/');
$phar2->setStub($phar->createDefaultStub('cli/index.php', 'www/index.php'));
?>

Ayrıca Bakınız

  • Phar::buildFromIterator() - Construct a phar archive from an iterator.

Phar::apiVersion
Phar::buildFromIterator
Phar


Construct a phar archive from an iterator.

Phar::buildFromDirectory
Phar::canCompress
Phar
PHP Manual

Phar::buildFromIterator

(PHP >= 5.3.0, PECL phar >= 2.0.0)

Phar::buildFromIterator — Construct a phar archive from an iterator.

Açıklama

public array Phar::buildFromIterator ( Iterator $iter [, string $base_directory ] )

Bilginize:

Phar nesneleri ile çalışmak için, bu yöntem phar.readonly php.ini yönergesine 0 atanmış olmasını gerektirir. Aksi takdirde bir PharException istisnası oluşur.

Populate a phar archive from an iterator. Two styles of iterators are supported, iterators that map the filename within the phar to the name of a file on disk, and iterators like DirectoryIterator that return SplFileInfo objects. For iterators that return SplFileInfo objects, the second parameter is required.

Değiştirgeler

iter

Any iterator that either associatively maps phar file to location or returns SplFileInfo objects

base_directory

For iterators that return SplFileInfo objects, the portion of each file's full path to remove when adding to the phar archive

Dönen Değerler

Phar::buildFromIterator() returns an associative array mapping internal path of file to the full path of the file on the filesystem.

Örnekler

Örnek 1 A Phar::buildFromIterator() with SplFileInfo

For most phar archives, the archive will reflect an actual directory layout, and the second style is the most useful. For instance, to create a phar archive containing the files in this sample directory layout:

/path/to/project/
                 config/
                        dist.xml
                        debug.xml
                 lib/
                     file1.php
                     file2.php
                 src/
                     processthing.php
                 www/
                     index.php
                 cli/
                     index.php

This code could be used to add these files to the "project.phar" phar archive:

<?php
// create with alias "project.phar"
$phar = new Phar('project.phar', 0, 'project.phar');
$phar->buildFromIterator(
    new RecursiveIteratorIterator(
     new RecursiveDirectoryIterator('/path/to/project')),
    '/path/to/project');
$phar->setStub($phar->createDefaultStub('cli/index.php', 'www/index.php'));
?>

The file project.phar can then be used immediately. Phar::buildFromIterator() does not set values such as compression, metadata, and this can be done after creating the phar archive.

As an interesting note, Phar::buildFromIterator() can also be used to copy the contents of an existing phar archive, as the Phar object descends from DirectoryIterator:

<?php
// create with alias "project.phar"
$phar = new Phar('project.phar', 0, 'project.phar');
$phar->buildFromIterator(
    new RecursiveIteratorIterator(
     new Phar('/path/to/anotherphar.phar')),
    'phar:///path/to/anotherphar.phar/path/to/project');
$phar->setStub($phar->createDefaultStub('cli/index.php', 'www/index.php'));
?>

Örnek 2 A Phar::buildFromIterator() with other iterators

The second form of the iterator can be used with any iterator that returns a key => value mapping, such as an ArrayIterator:

<?php
// create with alias "project.phar"
$phar = new Phar('project.phar', 0, 'project.phar');
$phar->buildFromIterator(
    new ArrayIterator(
     array(
        'internal/file.php' => dirname(__FILE__) . '/somefile.php',
        'another/file.jpg' => fopen('/path/to/bigfile.jpg', 'rb'),
     )));
$phar->setStub($phar->createDefaultStub('cli/index.php', 'www/index.php'));
?>

Hatalar/İstisnalar

This method returns UnexpectedValueException when the iterator returns incorrect values, such as an integer key instead of a string, a BadMethodCallException when an SplFileInfo-based iterator is passed without a base_directory parameter, or a PharException if there were errors saving the phar archive.

Ayrıca Bakınız

  • Phar::buildFromDirectory() - Construct a phar archive from the files within a directory.

Phar::buildFromDirectory
Phar::canCompress
Phar


Returns whether phar extension supports compression using either zlib or bzip2

Phar::buildFromIterator
Phar::canWrite
Phar
PHP Manual

Phar::canCompress

(PHP >= 5.3.0, PECL phar >= 1.0.0)

Phar::canCompress — Returns whether phar extension supports compression using either zlib or bzip2

Açıklama

final public static bool Phar::canCompress ([ int $type = 0 ] )

This should be used to test whether compression is possible prior to loading a phar archive containing compressed files.

Değiştirgeler

type

Either Phar::GZ or Phar::BZ2 can be used to test whether compression is possible with a specific compression algorithm (zlib or bzip2).

Dönen Değerler

TRUE if compression/decompression is available, FALSE if not.

Örnekler

Örnek 1 A Phar::canCompress() example

<?php
if (Phar::canCompress()) {
    echo file_get_contents('phar://compressedphar.phar/internal/file.txt');
} else {
    echo 'no compression available';
}
?>

Ayrıca Bakınız

  • PharFileInfo::getCompressedSize() - Returns the actual size of the file (with compression) inside the Phar archive
  • PharFileInfo::isCompressed() - Returns whether the entry is compressed
  • PharFileInfo::compress() - Compresses the current Phar entry with either zlib or bzip2 compression
  • PharFileInfo::decompress() - Decompresses the current Phar entry within the phar
  • Phar::isCompressed() - Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)
  • Phar::compressFiles() - Compresses all files in the current Phar archive
  • Phar::decompressFiles() - Decompresses all files in the current Phar archive
  • Phar::getSupportedCompression() - Return array of supported compression algorithms
  • Phar::convertToExecutable() - Convert a phar archive to another executable phar archive file format
  • Phar::convertToData() - Convert a phar archive to a non-executable tar or zip file

Phar::buildFromIterator
Phar::canWrite
Phar


Returns whether phar extension supports writing and creating phars

Phar::canCompress
Phar::compress
Phar
PHP Manual

Phar::canWrite

(PHP >= 5.3.0, PECL phar >= 1.0.0)

Phar::canWrite — Returns whether phar extension supports writing and creating phars

Açıklama

final public static bool Phar::canWrite ( void )

This static method determines whether write access has been disabled in the system php.ini via the phar.readonly ini variable.

Değiştirgeler

Dönen Değerler

TRUE if write access is enabled, FALSE if it is disabled.

Örnekler

Örnek 1 A Phar::canWrite() example

<?php
if (Phar::canWrite()) {
    file_put_contents('phar://myphar.phar/file.txt', 'hi there');
}
?>

Ayrıca Bakınız

  • phar.readonly
  • Phar::isWritable() - Returns true if the phar archive can be modified

Phar::canCompress
Phar::compress
Phar


Compresses the entire Phar archive using Gzip or Bzip2 compression

Phar::canWrite
Phar::compressAllFilesBZIP2
Phar
PHP Manual

Phar::compress

(PHP >= 5.3.0, PECL phar >= 2.0.0)

Phar::compress — Compresses the entire Phar archive using Gzip or Bzip2 compression

Açıklama

public object Phar::compress ( int $compression [, string $extension ] )

Bilginize:

Phar nesneleri ile çalışmak için, bu yöntem phar.readonly php.ini yönergesine 0 atanmış olmasını gerektirir. Aksi takdirde bir PharException istisnası oluşur.

For tar-based and phar-based phar archives, this method compresses the entire archive using gzip compression or bzip2 compression. The resulting file can be processed with the gunzip command/bunzip command, or accessed directly and transparently with the Phar extension.

For Zip-based phar archives, this method fails with an exception. The zlib extension must be enabled to compress with gzip compression, the bzip2 extension must be enabled in order to compress with bzip2 compression. As with all functionality that modifies the contents of a phar, the phar.readonly INI variable must be off in order to succeed.

In addition, this method automatically renames the archive, appending .gz, .bz2 or removing the extension if passed Phar::NONE to remove compression. Alternatively, a file extension may be specified with the second parameter.

Değiştirgeler

compression

Compression must be one of Phar::GZ, Phar::BZ2 to add compression, or Phar::NONE to remove compression.

extension

By default, the extension is .phar.gz or .phar.bz2 for compressing phar archives, and .phar.tar.gz or .phar.tar.bz2 for compressing tar archives. For decompressing, the default file extensions are .phar and .phar.tar.

Dönen Değerler

Returns a Phar object.

Hatalar/İstisnalar

Throws BadMethodCallException if the phar.readonly INI variable is on, the zlib extension is not available, or the bzip2 extension is not enabled.

Örnekler

Örnek 1 A Phar::compress() example

<?php
$p = new Phar('/path/to/my.phar', 0, 'my.phar');
$p['myfile.txt'] = 'hi';
$p['myfile2.txt'] = 'hi';
$p1 = $p->compress(Phar::GZ); // copies to /path/to/my.phar.gz
$p2 = $p->compress(Phar::BZ2); // copies to /path/to/my.phar.bz2
$p3 = $p2->compress(Phar::NONE); // exception: /path/to/my.phar already exists
?>

Ayrıca Bakınız

  • PharFileInfo::getCompressedSize() - Returns the actual size of the file (with compression) inside the Phar archive
  • PharFileInfo::isCompressed() - Returns whether the entry is compressed
  • PharFileInfo::compress() - Compresses the current Phar entry with either zlib or bzip2 compression
  • PharFileInfo::decompress() - Decompresses the current Phar entry within the phar
  • PharData::compress() - Compresses the entire tar/zip archive using Gzip or Bzip2 compression
  • Phar::canCompress() - Returns whether phar extension supports compression using either zlib or bzip2
  • Phar::isCompressed() - Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)
  • Phar::decompress() - Decompresses the entire Phar archive
  • Phar::getSupportedCompression() - Return array of supported compression algorithms
  • Phar::compressFiles() - Compresses all files in the current Phar archive
  • Phar::decompressFiles() - Decompresses all files in the current Phar archive

Phar::canWrite
Phar::compressAllFilesBZIP2
Phar


Compresses all files in the current Phar archive using Bzip2 compression

Phar::compress
Phar::compressAllFilesGZ
Phar
PHP Manual

Phar::compressAllFilesBZIP2

(PHP >= 5.3.0, PECL phar >= 1.0.0)

Phar::compressAllFilesBZIP2 — Compresses all files in the current Phar archive using Bzip2 compression

Açıklama

public bool Phar::compressAllFilesBZIP2 ( void )

Bilginize:

Bu yöntem Phar eklentisinin 2.0.0
sürümünde kaldırıldı. Yerine Phar::compress(),
Phar::decompress(),
Phar::compressFiles() ve
Phar::decompressFiles() kullanılabilir.

Bilginize:

Phar nesneleri ile çalışmak için, bu yöntem phar.readonly php.ini yönergesine 0 atanmış olmasını gerektirir. Aksi takdirde bir PharException istisnası oluşur.

This method compresses all files in the Phar archive using bzip2 compression. The bzip2 extension must be enabled to take advantage of this feature. In addition, if any files are already compressed using gzip compression, the zlib extension must be enabled in order to decompress the files prior to re-compressing with bzip2 compression. As with all functionality that modifies the contents of a phar, the phar.readonly INI variable must be off in order to succeed.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

Throws BadMethodCallException if the phar.readonly INI variable is on, the bzip2 extension is not available, or if any files are compressed using gzip compression and the zlib extension is not enabled.

Örnekler

Örnek 1 A Phar::compressAllFilesBZIP2() example

<?php
$p = new Phar('/path/to/my.phar', 0, 'my.phar');
$p['myfile.txt'] = 'hi';
$p['myfile2.txt'] = 'hi';
foreach ($p as $file) {
    var_dump($file->getFileName());
    var_dump($file->isCompressed());
    var_dump($file->isCompressedBZIP2());
    var_dump($file->isCompressedGZ());
}
$p->compressAllFilesBZIP2();
foreach ($p as $file) {
    var_dump($file->getFileName());
    var_dump($file->isCompressed());
    var_dump($file->isCompressedBZIP2());
    var_dump($file->isCompressedGZ());
}
?>

Yukarıdaki örneğin çıktısı:

string(10) "myfile.txt"
bool(false)
bool(false)
bool(false)
string(11) "myfile2.txt"
bool(false)
bool(false)
bool(false)
string(10) "myfile.txt"
bool(true)
bool(true)
bool(false)
string(11) "myfile2.txt"
bool(true)
bool(true)
bool(false)

Ayrıca Bakınız

  • PharFileInfo::getCompressedSize() - Returns the actual size of the file (with compression) inside the Phar archive
  • PharFileInfo::isCompressedBZIP2() - Returns whether the entry is compressed using bzip2
  • PharFileInfo::isCompressed() - Returns whether the entry is compressed
  • PharFileInfo::isCompressedGZ() - Returns whether the entry is compressed using gz
  • PharFileInfo::setCompressedBZIP2() - Compresses the current Phar entry within the phar using Bzip2 compression
  • PharFileInfo::setUncompressed() - Uncompresses the current Phar entry within the phar, if it is compressed
  • PharFileInfo::setCompressedGZ() - Compresses the current Phar entry within the phar using gz compression
  • Phar::canCompress() - Returns whether phar extension supports compression using either zlib or bzip2
  • Phar::isCompressed() - Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)
  • Phar::compressAllFilesGZ() - Compresses all files in the current Phar archive using Gzip compression
  • Phar::getSupportedCompression() - Return array of supported compression algorithms
  • Phar::uncompressAllFiles() - Uncompresses all files in the current Phar archive

Phar::compress
Phar::compressAllFilesGZ
Phar


Compresses all files in the current Phar archive using Gzip compression

Phar::compressAllFilesBZIP2
Phar::compressFiles
Phar
PHP Manual

Phar::compressAllFilesGZ

(PHP >= 5.3.0, PECL phar >= 1.0.0)

Phar::compressAllFilesGZ — Compresses all files in the current Phar archive using Gzip compression

Açıklama

public bool Phar::compressAllFilesGZ ( void )

Bilginize:

Bu yöntem Phar eklentisinin 2.0.0
sürümünde kaldırıldı. Yerine Phar::compress(),
Phar::decompress(),
Phar::compressFiles() ve
Phar::decompressFiles() kullanılabilir.

Bilginize:

Phar nesneleri ile çalışmak için, bu yöntem phar.readonly php.ini yönergesine 0 atanmış olmasını gerektirir. Aksi takdirde bir PharException istisnası oluşur.

For tar-based phar archives, this method compresses the entire archive using gzip compression. The resulting file can be processed with the gunzip command, or accessed directly and transparently with the Phar extension.

For Zip-based and phar-based phar archives, this method compresses all files in the Phar archive using gzip compression. The zlib extension must be enabled to take advantage of this feature. In addition, if any files are already compressed using bzip2 compression, the bzip2 extension must be enabled in order to decompress the files prior to re-compressing with gzip compression. As with all functionality that modifies the contents of a phar, the phar.readonly INI variable must be off in order to succeed.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

Throws BadMethodCallException if the phar.readonly INI variable is on, the zlib extension is not available, or if any files are compressed using bzip2 compression and the bzip2 extension is not enabled.

Örnekler

Örnek 1 A Phar::compressAllFilesGZ() example

<?php
$p = new Phar('/path/to/my.phar', 0, 'my.phar');
$p['myfile.txt'] = 'hi';
$p['myfile2.txt'] = 'hi';
foreach ($p as $file) {
    var_dump($file->getFileName());
    var_dump($file->isCompressed());
    var_dump($file->isCompressedBZIP2());
    var_dump($file->isCompressedGZ());
}
$p->compressAllFilesGZ();
foreach ($p as $file) {
    var_dump($file->getFileName());
    var_dump($file->isCompressed());
    var_dump($file->isCompressedBZIP2());
    var_dump($file->isCompressedGZ());
}
?>

Yukarıdaki örneğin çıktısı:

string(10) "myfile.txt"
bool(false)
bool(false)
bool(false)
string(11) "myfile2.txt"
bool(false)
bool(false)
bool(false)
string(10) "myfile.txt"
bool(true)
bool(false)
bool(true)
string(11) "myfile2.txt"
bool(true)
bool(false)
bool(true)

Ayrıca Bakınız

  • PharFileInfo::getCompressedSize() - Returns the actual size of the file (with compression) inside the Phar archive
  • PharFileInfo::isCompressedBZIP2() - Returns whether the entry is compressed using bzip2
  • PharFileInfo::isCompressed() - Returns whether the entry is compressed
  • PharFileInfo::isCompressedGZ() - Returns whether the entry is compressed using gz
  • PharFileInfo::setCompressedBZIP2() - Compresses the current Phar entry within the phar using Bzip2 compression
  • PharFileInfo::setUncompressed() - Uncompresses the current Phar entry within the phar, if it is compressed
  • PharFileInfo::setCompressedGZ() - Compresses the current Phar entry within the phar using gz compression
  • Phar::canCompress() - Returns whether phar extension supports compression using either zlib or bzip2
  • Phar::isCompressed() - Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)
  • Phar::compressAllFilesBZIP2() - Compresses all files in the current Phar archive using Bzip2 compression
  • Phar::getSupportedCompression() - Return array of supported compression algorithms
  • Phar::uncompressAllFiles() - Uncompresses all files in the current Phar archive

Phar::compressAllFilesBZIP2
Phar::compressFiles
Phar


Compresses all files in the current Phar archive

Phar::compressAllFilesGZ
Phar::__construct
Phar
PHP Manual

Phar::compressFiles

(PHP >= 5.3.0, PECL phar >= 2.0.0)

Phar::compressFiles — Compresses all files in the current Phar archive

Açıklama

public void Phar::compressFiles ( int $compression )

Bilginize:

Phar nesneleri ile çalışmak için, bu yöntem phar.readonly php.ini yönergesine 0 atanmış olmasını gerektirir. Aksi takdirde bir PharException istisnası oluşur.

For tar-based phar archives, this method throws a BadMethodCallException, as compression of individual files within a tar archive is not supported by the file format. Use Phar::compress() to compress an entire tar-based phar archive.

For Zip-based and phar-based phar archives, this method compresses all files in the Phar archive using the specified compression. The zlib or bzip2 extensions must be enabled to take advantage of this feature. In addition, if any files are already compressed using bzip2/zlib compression, the respective extension must be enabled in order to decompress the files prior to re-compressing. As with all functionality that modifies the contents of a phar, the phar.readonly INI variable must be off in order to succeed.

Değiştirgeler

compression

Compression must be one of Phar::GZ, Phar::BZ2 to add compression, or Phar::NONE to remove compression.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

Throws BadMethodCallException if the phar.readonly INI variable is on, the zlib extension is not available, or if any files are compressed using bzip2 compression and the bzip2 extension is not enabled.

Örnekler

Örnek 1 A Phar::compressFiles() example

<?php
$p = new Phar('/path/to/my.phar', 0, 'my.phar');
$p['myfile.txt'] = 'hi';
$p['myfile2.txt'] = 'hi';
foreach ($p as $file) {
    var_dump($file->getFileName());
    var_dump($file->isCompressed());
    var_dump($file->isCompressed(Phar::BZ2));
    var_dump($file->isCompressed(Phar::GZ));
}
$p->compressFiles(Phar::GZ);
foreach ($p as $file) {
    var_dump($file->getFileName());
    var_dump($file->isCompressed());
    var_dump($file->isCompressed(Phar::BZ2));
    var_dump($file->isCompressed(Phar::GZ));
}
?>

Yukarıdaki örneğin çıktısı:

string(10) "myfile.txt"
bool(false)
bool(false)
bool(false)
string(11) "myfile2.txt"
bool(false)
bool(false)
bool(false)
string(10) "myfile.txt"
int(4096)
bool(false)
bool(true)
string(11) "myfile2.txt"
int(4096)
bool(false)
bool(true)

Ayrıca Bakınız

  • PharFileInfo::getCompressedSize() - Returns the actual size of the file (with compression) inside the Phar archive
  • PharFileInfo::isCompressed() - Returns whether the entry is compressed
  • PharFileInfo::compress() - Compresses the current Phar entry with either zlib or bzip2 compression
  • PharFileInfo::decompress() - Decompresses the current Phar entry within the phar
  • Phar::canCompress() - Returns whether phar extension supports compression using either zlib or bzip2
  • Phar::isCompressed() - Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)
  • Phar::decompressFiles() - Decompresses all files in the current Phar archive
  • Phar::getSupportedCompression() - Return array of supported compression algorithms
  • Phar::compress() - Compresses the entire Phar archive using Gzip or Bzip2 compression
  • Phar::decompress() - Decompresses the entire Phar archive

Phar::compressAllFilesGZ
Phar::__construct
Phar


Construct a Phar archive object

Phar::compressFiles
Phar::convertToData
Phar
PHP Manual

Phar::__construct

(PHP >= 5.3.0, PECL phar >= 1.0.0)

Phar::__construct — Construct a Phar archive object

Açıklama

public Phar::__construct ( string $fname [, int $flags [, string $alias ]] )

Değiştirgeler

fname

Path to an existing Phar archive or to-be-created archive. The file name's extension must contain .phar.

flags

Flags to pass to parent class RecursiveDirectoryIterator.

alias

Alias with which this Phar archive should be referred to in calls to stream functionality.

Hatalar/İstisnalar

Throws BadMethodCallException if called twice, UnexpectedValueException if the phar archive can't be opened.

Örnekler

Örnek 1 A Phar::__construct() example

<?php
try {
    $p = new Phar('/path/to/my.phar', FilesystemIterator::CURRENT_AS_FILEINFO | FilesystemIterator::KEY_AS_FILENAME,
                  'my.phar');
} catch (UnexpectedValueException $e) {
    die('Could not open my.phar');
} catch (BadMethodCallException $e) {
    echo 'technically, this cannot happen';
}
// this works now
echo file_get_contents('phar://my.phar/example.txt');
// and works as if we had typed
echo file_get_contents('phar:///path/to/my.phar/example.txt');
?>

Phar::compressFiles
Phar::convertToData
Phar


Convert a phar archive to a non-executable tar or zip file

Phar::__construct
Phar::convertToExecutable
Phar
PHP Manual

Phar::convertToData

(PHP >= 5.3.0, PECL phar >= 2.0.0)

Phar::convertToData — Convert a phar archive to a non-executable tar or zip file

Açıklama

public PharData Phar::convertToData ([ int $format = 9021976 [, int $compression = 9021976 [, string $extension ]]] )

This method is used to convert an executable phar archive to either a tar or zip file. To make the tar or zip non-executable, the phar stub and phar alias files are removed from the newly created archive.

If no changes are specified, this method throws a BadMethodCallException if the archive is in phar file format. For archives in tar or zip file format, this method converts the archive to a non-executable archive.

If successful, the method creates a new archive on disk and returns a PharData object. The old archive is not removed from disk, and should be done manually after the process has finished.

Değiştirgeler

format

This should be one of Phar::TAR or Phar::ZIP. If set to NULL, the existing file format will be preserved.

compression

This should be one of Phar::NONE for no whole-archive compression, Phar::GZ for zlib-based compression, and Phar::BZ2 for bzip-based compression.

extension

This parameter is used to override the default file extension for a converted archive. Note that .phar cannot be used anywhere in the filename for a non-executable tar or zip archive.

If converting to a tar-based phar archive, the default extensions are .tar, .tar.gz, and .tar.bz2 depending on specified compression. For zip-based archives, the default extension is .zip.

Dönen Değerler

The method returns a PharData object on success and throws an exception on failure.

Hatalar/İstisnalar

This method throws BadMethodCallException when unable to compress, an unknown compression method has been specified, the requested archive is buffering with Phar::startBuffering() and has not concluded with Phar::stopBuffering(), and a PharException if any problems are encountered during the phar creation process.

Örnekler

Örnek 1 A Phar::convertToData() example

Using Phar::convertToData():

<?php
try {
    $tarphar = new Phar('myphar.phar.tar');
    // note that myphar.phar.tar is *not* unlinked
    // convert it to the non-executable tar file format
    // creates myphar.tar
    $tar = $tarphar->convertToData();
    // convert to non-executable zip format, creates myphar.zip
    $zip = $tarphar->convertToData(Phar::ZIP);
    // create myphar.tbz
    $tgz = $tarphar->convertToData(Phar::TAR, Phar::BZ2, '.tbz');
    // creates myphar.phar.tgz
    $phar = $tarphar->convertToData(Phar::PHAR); // throws exception
} catch (Exception $e) {
    // handle the error here
}
?>

Ayrıca Bakınız

  • Phar::convertToExecutable() - Convert a phar archive to another executable phar archive file format
  • PharData::convertToExecutable() - Convert a non-executable tar/zip archive to an executable phar archive
  • PharData::convertToData() - Convert a phar archive to a non-executable tar or zip file

Phar::__construct
Phar::convertToExecutable
Phar


Convert a phar archive to another executable phar archive file format

Phar::convertToData
Phar::copy
Phar
PHP Manual

Phar::convertToExecutable

(PHP >= 5.3.0, PECL phar >= 2.0.0)

Phar::convertToExecutable — Convert a phar archive to another executable phar archive file format

Açıklama

public Phar Phar::convertToExecutable ([ int $format = 9021976 [, int $compression = 9021976 [, string $extension ]]] )

Bilginize:

Phar nesneleri ile çalışmak için, bu yöntem phar.readonly php.ini yönergesine 0 atanmış olmasını gerektirir. Aksi takdirde bir PharException istisnası oluşur.

This method is used to convert a phar archive to another file format. For instance, it can be used to create a tar-based executable phar archive from a zip-based executable phar archive, or from an executable phar archive in the phar file format. In addition, it can be used to apply whole-archive compression to a tar or phar-based archive.

If no changes are specified, this method throws a BadMethodCallException.

If successful, the method creates a new archive on disk and returns a Phar object. The old archive is not removed from disk, and should be done manually after the process has finished.

Değiştirgeler

format

This should be one of Phar::PHAR, Phar::TAR, or Phar::ZIP. If set to NULL, the existing file format will be preserved.

compression

This should be one of Phar::NONE for no whole-archive compression, Phar::GZ for zlib-based compression, and Phar::BZ2 for bzip-based compression.

extension

This parameter is used to override the default file extension for a converted archive. Note that all zip- and tar-based phar archives must contain .phar in their file extension in order to be processed as a phar archive.

If converting to a phar-based archive, the default extensions are .phar, .phar.gz, or .phar.bz2 depending on the specified compression. For tar-based phar archives, the default extensions are .phar.tar, .phar.tar.gz, and .phar.tar.bz2. For zip-based phar archives, the default extension is .phar.zip.

Dönen Değerler

The method returns a Phar object on success and throws an exception on failure.

Hatalar/İstisnalar

This method throws BadMethodCallException when unable to compress, an unknown compression method has been specified, the requested archive is buffering with Phar::startBuffering() and has not concluded with Phar::stopBuffering(), an UnexpectedValueException if write support is disabled, and a PharException if any problems are encountered during the phar creation process.

Örnekler

Örnek 1 A Phar::convertToExecutable() example

Using Phar::convertToExecutable():

<?php
try {
    $tarphar = new Phar('myphar.phar.tar');
    // convert it to the phar file format
    // note that myphar.phar.tar is *not* unlinked
    $phar = $tarphar->convertToExecutable(Phar::PHAR); // creates myphar.phar
    $phar->setStub($phar->createDefaultStub('cli.php', 'web/index.php'));
    // creates myphar.phar.tgz
    $compressed = $phar->convertToExecutable(Phar::TAR, Phar::GZ, '.phar.tgz');
} catch (Exception $e) {
    // handle the error here
}
?>

Ayrıca Bakınız

  • Phar::convertToData() - Convert a phar archive to a non-executable tar or zip file
  • PharData::convertToExecutable() - Convert a non-executable tar/zip archive to an executable phar archive
  • PharData::convertToData() - Convert a phar archive to a non-executable tar or zip file

Phar::convertToData
Phar::copy
Phar


Copy a file internal to the phar archive to another new file within the phar

Phar::convertToExecutable
Phar::count
Phar
PHP Manual

Phar::copy

(PHP >= 5.3.0, PECL phar >= 2.0.0)

Phar::copy — Copy a file internal to the phar archive to another new file within the phar

Açıklama

public bool Phar::copy ( string $oldfile , string $newfile )

Bilginize:

Phar nesneleri ile çalışmak için, bu yöntem phar.readonly php.ini yönergesine 0 atanmış olmasını gerektirir. Aksi takdirde bir PharException istisnası oluşur.

Copy a file internal to the phar archive to another new file within the phar. This is an object-oriented alternative to using copy() with the phar stream wrapper.

Değiştirgeler

oldfile

newfile

Dönen Değerler

returns TRUE on success, but it is safer to encase method call in a try/catch block and assume success if no exception is thrown.

Hatalar/İstisnalar

throws UnexpectedValueException if the source file does not exist, the destination file already exists, write access is disabled, opening either file fails, reading the source file fails, or a PharException if writing the changes to the phar fails.

Örnekler

Örnek 1 A Phar::copy() example

This example shows using Phar::copy() and the equivalent stream wrapper performance of the same thing. The primary difference between the two approaches is error handling. All Phar methods throw exceptions, whereas the stream wrapper uses trigger_error().

<?php
try {
    $phar = new Phar('myphar.phar');
    $phar['a'] = 'hi';
    $phar->copy('a', 'b');
    echo $phar['b']; // outputs "hi"
} catch (Exception $e) {
    // handle error
}

// the stream wrapper equivalent of the above code.
// E_WARNINGS are triggered on error rather than exceptions.
copy('phar://myphar.phar/a', 'phar//myphar.phar/c');
echo file_get_contents('phar://myphar.phar/c'); // outputs "hi"
?>

Phar::convertToExecutable
Phar::count
Phar


Returns the number of entries (files) in the Phar archive

Phar::copy
Phar::createDefaultStub
Phar
PHP Manual

Phar::count

(PHP >= 5.3.0, PECL phar >= 1.0.0)

Phar::count — Returns the number of entries (files) in the Phar archive

Açıklama

public int Phar::count ( void )

Değiştirgeler

Dönen Değerler

The number of files contained within this phar, or 0 (the number zero) if none.

Örnekler

Örnek 1 A Phar::count() example

<?php
// make sure it doesn't exist
@unlink('brandnewphar.phar');
try {
    $p = new Phar(dirname(__FILE__) . '/brandnewphar.phar', 0, 'brandnewphar.phar');
} catch (Exception $e) {
    echo 'Could not create phar:', $e;
}
echo 'The new phar has ' . $p->count() . " entries\n";
$p['file.txt'] = 'hi';
echo 'The new phar has ' . $p->count() . " entries\n";
?>

Yukarıdaki örneğin çıktısı:

The new phar has 0 entries
The new phar has 1 entries

Phar::copy
Phar::createDefaultStub
Phar


Create a phar-file format specific stub

Phar::count
Phar::decompress
Phar
PHP Manual

Phar::createDefaultStub

(Unknown)

Phar::createDefaultStub — Create a phar-file format specific stub

Açıklama

final public static string Phar::createDefaultStub ([ string $indexfile [, string $webindexfile ]] )

This method is intended for creation of phar-file format-specific stubs, and is not intended for use with tar- or zip-based phar archives.

Phar archives contain a bootstrap loader, or stub written in PHP that is executed when the archive is executed in PHP either via include:

<?php
include 'myphar.phar';
?>
or by simple execution:
php myphar.phar

This method provides a simple and easy method to create a stub that will run a startup file from the phar archive. In addition, different files can be specified for running the phar archive from the command line versus through a web server. The loader stub also calls Phar::interceptFileFuncs() to allow easy bundling of a PHP application that accesses the file system. If the phar extension is not present, the loader stub will extract the phar archive to a temporary directory and then operate on the files. A shutdown function erases the temporary files on exit.

Dönen Değerler

Returns a string containing the contents of a customized bootstrap loader (stub) that allows the created Phar archive to work with or without the Phar extension enabled.

Hatalar/İstisnalar

Throws UnexpectedValueException if either parameter is longer than 400 bytes.

Örnekler

Örnek 1 A Phar::createDefaultStub() example

<?php
try {
    $phar = new Phar('myphar.phar');
    $phar->setStub($phar->createDefaultStub('cli.php', 'web/index.php'));
} catch (Exception $e) {
    // handle errors
}
?>

Ayrıca Bakınız

  • Phar::setStub() - Used to set the PHP loader or bootstrap stub of a Phar archive
  • Phar::getStub() - Return the PHP loader or bootstrap stub of a Phar archive

Phar::count
Phar::decompress
Phar


Decompresses the entire Phar archive

Phar::createDefaultStub
Phar::decompressFiles
Phar
PHP Manual

Phar::decompress

(PHP >= 5.3.0, PECL phar >= 2.0.0)

Phar::decompress — Decompresses the entire Phar archive

Açıklama

public object Phar::decompress ([ string $extension ] )

Bilginize:

Phar nesneleri ile çalışmak için, bu yöntem phar.readonly php.ini yönergesine 0 atanmış olmasını gerektirir. Aksi takdirde bir PharException istisnası oluşur.

For tar-based and phar-based phar archives, this method decompresses the entire archive.

For Zip-based phar archives, this method fails with an exception. The zlib extension must be enabled to decompress an archive compressed with gzip compression, and the bzip2 extension must be enabled in order to decompress an archive compressed with bzip2 compression. As with all functionality that modifies the contents of a phar, the phar.readonly INI variable must be off in order to succeed.

In addition, this method automatically changes the file extension of the archive, .phar by default for phar archives, or .phar.tar for tar-based phar archives. Alternatively, a file extension may be specified with the second parameter.

Değiştirgeler

extension

For decompressing, the default file extensions are .phar and .phar.tar. Use this parameter to specify another file extension. Be aware that all executable phar archives must contain .phar in their filename.

Dönen Değerler

A Phar object is returned.

Hatalar/İstisnalar

Throws BadMethodCallException if the phar.readonly INI variable is on, the zlib extension is not available, or the bzip2 extension is not enabled.

Örnekler

Örnek 1 A Phar::decompress() example

<?php
$p = new Phar('/path/to/my.phar', 0, 'my.phar.gz');
$p['myfile.txt'] = 'hi';
$p['myfile2.txt'] = 'hi';
$p3 = $p2->decompress(); // creates /path/to/my.phar
?>

Ayrıca Bakınız

  • PharFileInfo::getCompressedSize() - Returns the actual size of the file (with compression) inside the Phar archive
  • PharFileInfo::isCompressed() - Returns whether the entry is compressed
  • PharFileInfo::compress() - Compresses the current Phar entry with either zlib or bzip2 compression
  • PharFileInfo::decompress() - Decompresses the current Phar entry within the phar
  • PharData::compress() - Compresses the entire tar/zip archive using Gzip or Bzip2 compression
  • Phar::canCompress() - Returns whether phar extension supports compression using either zlib or bzip2
  • Phar::isCompressed() - Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)
  • Phar::compress() - Compresses the entire Phar archive using Gzip or Bzip2 compression
  • Phar::getSupportedCompression() - Return array of supported compression algorithms
  • Phar::compressFiles() - Compresses all files in the current Phar archive
  • Phar::decompressFiles() - Decompresses all files in the current Phar archive

Phar::createDefaultStub
Phar::decompressFiles
Phar


Decompresses all files in the current Phar archive

Phar::decompress
Phar::delMetadata
Phar
PHP Manual

Phar::decompressFiles

(PHP >= 5.3.0, PECL phar >= 2.0.0)

Phar::decompressFiles — Decompresses all files in the current Phar archive

Açıklama

public bool Phar::decompressFiles ( void )

Bilginize:

Phar nesneleri ile çalışmak için, bu yöntem phar.readonly php.ini yönergesine 0 atanmış olmasını gerektirir. Aksi takdirde bir PharException istisnası oluşur.

For tar-based phar archives, this method throws a BadMethodCallException, as compression of individual files within a tar archive is not supported by the file format. Use Phar::compress() to compress an entire tar-based phar archive.

For Zip-based and phar-based phar archives, this method decompresses all files in the Phar archive. The zlib or bzip2 extensions must be enabled to take advantage of this feature if any files are compressed using bzip2/zlib compression. As with all functionality that modifies the contents of a phar, the phar.readonly INI variable must be off in order to succeed.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

Throws BadMethodCallException if the phar.readonly INI variable is on, the zlib extension is not available, or if any files are compressed using bzip2 compression and the bzip2 extension is not enabled.

Örnekler

Örnek 1 A Phar::decompressFiles() example

<?php
$p = new Phar('/path/to/my.phar', 0, 'my.phar');
$p['myfile.txt'] = 'hi';
$p['myfile2.txt'] = 'hi';
$p->compressFiles(Phar::GZ);
foreach ($p as $file) {
    var_dump($file->getFileName());
    var_dump($file->isCompressed());
    var_dump($file->isCompressed(Phar::BZ2));
    var_dump($file->isCompressed(Phar::GZ));
}
$p->decompressFiles();
foreach ($p as $file) {
    var_dump($file->getFileName());
    var_dump($file->isCompressed());
    var_dump($file->isCompressed(Phar::BZ2));
    var_dump($file->isCompressed(Phar::GZ));
}
?>

Yukarıdaki örneğin çıktısı:

string(10) "myfile.txt"
int(4096)
bool(false)
bool(true)
string(11) "myfile2.txt"
int(4096)
bool(false)
bool(true)
string(10) "myfile.txt"
bool(false)
bool(false)
bool(false)
string(11) "myfile2.txt"
bool(false)
bool(false)
bool(false)

Ayrıca Bakınız

  • PharFileInfo::getCompressedSize() - Returns the actual size of the file (with compression) inside the Phar archive
  • PharFileInfo::isCompressed() - Returns whether the entry is compressed
  • PharFileInfo::compress() - Compresses the current Phar entry with either zlib or bzip2 compression
  • PharFileInfo::decompress() - Decompresses the current Phar entry within the phar
  • Phar::canCompress() - Returns whether phar extension supports compression using either zlib or bzip2
  • Phar::isCompressed() - Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)
  • Phar::compressFiles() - Compresses all files in the current Phar archive
  • Phar::getSupportedCompression() - Return array of supported compression algorithms
  • Phar::compress() - Compresses the entire Phar archive using Gzip or Bzip2 compression
  • Phar::decompress() - Decompresses the entire Phar archive

Phar::decompress
Phar::delMetadata
Phar


Deletes the global metadata of the phar

Phar::decompressFiles
Phar::delete
Phar
PHP Manual

Phar::delMetadata

(PHP >= 5.3.0, PECL phar >= 1.2.0)

Phar::delMetadata — Deletes the global metadata of the phar

Açıklama

public bool Phar::delMetadata ( void )

Bilginize:

Phar nesneleri ile çalışmak için, bu yöntem phar.readonly php.ini yönergesine 0 atanmış olmasını gerektirir. Aksi takdirde bir PharException istisnası oluşur.

Deletes the global metadata of the phar

Değiştirgeler

Dönen Değerler

returns TRUE on success, but it is better to check for thrown exception, and assume success if none is thrown.

Hatalar/İstisnalar

Throws PharException if errors occur while flushing changes to disk.

Örnekler

Örnek 1 A Phar::delMetaData() example

<?php
try {
    $phar = new Phar('myphar.phar');
    var_dump($phar->getMetadata());
    $phar->setMetadata("hi there");
    var_dump($phar->getMetadata());
    $phar->delMetadata();
    var_dump($phar->getMetadata());
} catch (Exception $e) {
    // handle errors
}
?>

Yukarıdaki örneğin çıktısı:

NULL
string(8) "hi there"
NULL

Ayrıca Bakınız

  • Phar::getMetadata() - Returns phar archive meta-data
  • Phar::setMetadata() - Sets phar archive meta-data
  • Phar::hasMetadata() - Returns whether phar has global meta-data

Phar::decompressFiles
Phar::delete
Phar


Delete a file within a phar archive

Phar::delMetadata
Phar::extractTo
Phar
PHP Manual

Phar::delete

(PHP >= 5.3.0, PECL phar >= 2.0.0)

Phar::delete — Delete a file within a phar archive

Açıklama

public bool Phar::delete ( string $entry )

Bilginize:

Phar nesneleri ile çalışmak için, bu yöntem phar.readonly php.ini yönergesine 0 atanmış olmasını gerektirir. Aksi takdirde bir PharException istisnası oluşur.

Delete a file within an archive. This is the functional equivalent of calling unlink() on the stream wrapper equivalent, as shown in the example below.

Değiştirgeler

entry

Path within an archive to the file to delete.

Dönen Değerler

returns TRUE on success, but it is better to check for thrown exception, and assume success if none is thrown.

Hatalar/İstisnalar

Throws PharException if errors occur while flushing changes to disk.

Örnekler

Örnek 1 A Phar::delete() example

<?php
try {
    $phar = new Phar('myphar.phar');
    $phar->delete('unlink/me.php');
    // this is equivalent to:
    unlink('phar://myphar.phar/unlink/me.php');
} catch (Exception $e) {
    // handle errors
}
?>

Ayrıca Bakınız

  • PharData::delete() - Delete a file within a tar/zip archive
  • Phar::unlinkArchive() - Completely remove a phar archive from disk and from memory

Phar::delMetadata
Phar::extractTo
Phar


Extract the contents of a phar archive to a directory

Phar::delete
Phar::getMetadata
Phar
PHP Manual

Phar::extractTo

(Unknown)

Phar::extractTo — Extract the contents of a phar archive to a directory

Açıklama

public bool Phar::extractTo ( string $pathto [, string|array $files [, bool $overwrite = false ]] )

Extract all files within a phar archive to disk. Extracted files and directories preserve permissions as stored in the archive. The optional parameters allow optional control over which files are extracted, and whether existing files on disk can be overwritten. The second parameter files can be either the name of a file or directory to extract, or an array of names of files and directories to extract. By default, this method will not overwrite existing files, the third parameter can be set to true to enable overwriting of files. This method is similar to ZipArchive::extractTo().

Değiştirgeler

pathto

Path to extract the given files to

files

The name of a file or directory to extract, or an array of files/directories to extract

overwrite

Set to TRUE to enable overwriting existing files

Dönen Değerler

returns TRUE on success, but it is better to check for thrown exception, and assume success if none is thrown.

Hatalar/İstisnalar

Throws PharException if errors occur while flushing changes to disk.

Örnekler

Örnek 1 A Phar::extractTo() example

<?php
try {
    $phar = new Phar('myphar.phar');
    $phar->extractTo('/full/path'); // extract all files
    $phar->extractTo('/another/path', 'file.txt'); // extract only file.txt
    $phar->extractTo('/this/path',
        array('file1.txt', 'file2.txt')); // extract 2 files only
    $phar->extractTo('/third/path', null, true); // extract all files, and overwrite
} catch (Exception $e) {
    // handle errors
}
?>

Ayrıca Bakınız

  • PharData::extractTo() - Extract the contents of a tar/zip archive to a directory

Phar::delete
Phar::getMetadata
Phar


Returns phar archive meta-data

Phar::extractTo
Phar::getModified
Phar
PHP Manual

Phar::getMetadata

(PHP >= 5.3.0, PECL phar >= 1.0.0)

Phar::getMetadata — Returns phar archive meta-data

Açıklama

public mixed Phar::getMetadata ( void )

Retrieve archive meta-data. Meta-data can be any PHP variable that can be serialized.

Değiştirgeler

No parameters.

Dönen Değerler

any PHP variable that can be serialized and is stored as meta-data for the Phar archive, or NULL if no meta-data is stored.

Örnekler

Örnek 1 A Phar::getMetadata() example

<?php
// make sure it doesn't exist
@unlink('brandnewphar.phar');
try {
    $p = new Phar(dirname(__FILE__) . '/brandnewphar.phar', 0, 'brandnewphar.phar');
    $p['file.php'] = '<?php echo "hello";';
    $p->setMetadata(array('bootstrap' => 'file.php'));
    var_dump($p->getMetadata());
} catch (Exception $e) {
    echo 'Could not modify phar:', $e;
}
?>

Yukarıdaki örneğin çıktısı:

array(1) {
  ["bootstrap"]=>
  string(8) "file.php"
}

Ayrıca Bakınız

  • Phar::setMetadata() - Sets phar archive meta-data
  • Phar::delMetadata() - Deletes the global metadata of the phar
  • Phar::hasMetadata() - Returns whether phar has global meta-data

Phar::extractTo
Phar::getModified
Phar


Return whether phar was modified

Phar::getMetadata
Phar::getSignature
Phar
PHP Manual

Phar::getModified

(PHP >= 5.3.0, PECL phar >= 1.0.0)

Phar::getModified — Return whether phar was modified

Açıklama

public bool Phar::getModified ( void )

This method can be used to determine whether a phar has either had an internal file deleted, or contents of a file changed in some way.

Değiştirgeler

No parameters.

Dönen Değerler

TRUE if the phar has been modified since opened, FALSE if not.

Phar::getMetadata
Phar::getSignature
Phar


Return MD5/SHA1/SHA256/SHA512/OpenSSL signature of a Phar archive

Phar::getModified
Phar::getStub
Phar
PHP Manual

Phar::getSignature

(PHP >= 5.3.0, PECL phar >= 1.0.0)

Phar::getSignature — Return MD5/SHA1/SHA256/SHA512/OpenSSL signature of a Phar archive

Açıklama

public array Phar::getSignature ( void )

Returns the verification signature of a phar archive in a hexadecimal string.

Değiştirgeler

Dönen Değerler

Array with the opened archive's signature in hash key and MD5, SHA-1, SHA-256, SHA-512, or OpenSSL in hash_type. This signature is a hash calculated on the entire phar's contents, and may be used to verify the integrity of the archive. A valid signature is absolutely required of all executable phar archives if the phar.require_hash INI variable is set to true.

Phar::getModified
Phar::getStub
Phar


Return the PHP loader or bootstrap stub of a Phar archive

Phar::getSignature
Phar::getSupportedCompression
Phar
PHP Manual

Phar::getStub

(PHP >= 5.3.0, PECL phar >= 1.0.0)

Phar::getStub — Return the PHP loader or bootstrap stub of a Phar archive

Açıklama

public string Phar::getStub ( void )

Phar archives contain a bootstrap loader, or stub written in PHP that is executed when the archive is executed in PHP either via include:

<?php
include 'myphar.phar';
?>
or by simple execution:
php myphar.phar

Dönen Değerler

Returns a string containing the contents of the bootstrap loader (stub) of the current Phar archive.

Hatalar/İstisnalar

Throws RuntimeException if it is not possible to read the stub from the Phar archive.

Örnekler

Örnek 1 A Phar::getStub() example

<?php
$p = new Phar('/path/to/my.phar', 0, 'my.phar');
echo $p->getStub();
echo "==NEXT==\n";
$p->setStub("<?php
function __autoload($class)
{
    include 'phar://' . str_replace('_', '/', $class);
}
Phar::mapPhar('myphar.phar');
include 'phar://myphar.phar/startup.php';
__HALT_COMPILER(); ?>");
echo $p->getStub();
?>

Yukarıdaki örneğin çıktısı:

<?php __HALT_COMPILER(); ?>
==NEXT==
<?php
function __autoload($class)
{
    include 'phar://' . str_replace('_', '/', $class);
}
Phar::mapPhar('myphar.phar');
include 'phar://myphar.phar/startup.php';
__HALT_COMPILER(); ?>

Ayrıca Bakınız

  • Phar::setStub() - Used to set the PHP loader or bootstrap stub of a Phar archive
  • Phar::createDefaultStub() - Create a phar-file format specific stub

Phar::getSignature
Phar::getSupportedCompression
Phar


Return array of supported compression algorithms

Phar::getStub
Phar::getSupportedSignatures
Phar
PHP Manual

Phar::getSupportedCompression

(PHP >= 5.3.0, PECL phar >= 1.2.0)

Phar::getSupportedCompression — Return array of supported compression algorithms

Açıklama

final public static array Phar::getSupportedCompression ( void )

Değiştirgeler

No parameters.

Dönen Değerler

Returns an array containing any of Phar::GZ or Phar::BZ2, depending on the availability of the zlib extension or the bz2 extension.

Ayrıca Bakınız

  • PharFileInfo::getCompressedSize() - Returns the actual size of the file (with compression) inside the Phar archive
  • PharFileInfo::isCompressed() - Returns whether the entry is compressed
  • PharFileInfo::compress() - Compresses the current Phar entry with either zlib or bzip2 compression
  • PharFileInfo::decompress() - Decompresses the current Phar entry within the phar
  • Phar::compress() - Compresses the entire Phar archive using Gzip or Bzip2 compression
  • Phar::decompress() - Decompresses the entire Phar archive
  • Phar::canCompress() - Returns whether phar extension supports compression using either zlib or bzip2
  • Phar::isCompressed() - Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)
  • Phar::compressFiles() - Compresses all files in the current Phar archive
  • Phar::decompressFiles() - Decompresses all files in the current Phar archive

Phar::getStub
Phar::getSupportedSignatures
Phar


Return array of supported signature types

Phar::getSupportedCompression
Phar::getVersion
Phar
PHP Manual

Phar::getSupportedSignatures

(PHP >= 5.3.0, PECL phar >= 1.1.0)

Phar::getSupportedSignatures — Return array of supported signature types

Açıklama

final public static array Phar::getSupportedSignatures ( void )

Return array of supported signature types

Değiştirgeler

No parameters.

Dönen Değerler

Returns an array containing any of MD5, SHA-1, SHA-256, SHA-512, or OpenSSL.

Ayrıca Bakınız

  • Phar::getSignature() - Return MD5/SHA1/SHA256/SHA512/OpenSSL signature of a Phar archive
  • Phar::setSignatureAlgorithm() - set the signature algorithm for a phar and apply it.

Phar::getSupportedCompression
Phar::getVersion
Phar


Return version info of Phar archive

Phar::getSupportedSignatures
Phar::hasMetadata
Phar
PHP Manual

Phar::getVersion

(PHP >= 5.3.0, PECL phar >= 1.0.0)

Phar::getVersion — Return version info of Phar archive

Açıklama

public string Phar::getVersion ( void )

Returns the API version of an opened Phar archive.

Değiştirgeler

Dönen Değerler

The opened archive's API version. This is not to be confused with the API version that the loaded phar extension will use to create new phars. Each Phar archive has the API version hard-coded into its manifest. See Phar file format documentation for more information.

Ayrıca Bakınız

  • Phar::apiVersion() - Returns the api version

Phar::getSupportedSignatures
Phar::hasMetadata
Phar


Returns whether phar has global meta-data

Phar::getVersion
Phar::interceptFileFuncs
Phar
PHP Manual

Phar::hasMetadata

(PHP >= 5.3.0, PECL phar >= 1.2.0)

Phar::hasMetadata — Returns whether phar has global meta-data

Açıklama

public bool Phar::hasMetadata ( void )

Returns whether phar has global meta-data set.

Değiştirgeler

No parameters.

Dönen Değerler

Returns TRUE if meta-data has been set, and FALSE if not.

Örnekler

Örnek 1 A Phar::hasMetadata() example

<?php
try {
    $phar = new Phar('myphar.phar');
    var_dump($phar->hasMetadata());
    $phar->setMetadata(array('thing' => 'hi'));
    var_dump($phar->hasMetadata());
    $phar->delMetadata();
    var_dump($phar->hasMetadata());
} catch (Exception $e) {
    // handle error
}
?>

Yukarıdaki örneğin çıktısı:

bool(false)
bool(true)
bool(false)

Ayrıca Bakınız

  • Phar::getMetadata() - Returns phar archive meta-data
  • Phar::setMetadata() - Sets phar archive meta-data
  • Phar::delMetadata() - Deletes the global metadata of the phar

Phar::getVersion
Phar::interceptFileFuncs
Phar


instructs phar to intercept fopen, file_get_contents, opendir, and all of the stat-related functions

Phar::hasMetadata
Phar::isBuffering
Phar
PHP Manual

Phar::interceptFileFuncs

(PHP >= 5.3.0, PECL phar >= 2.0.0)

Phar::interceptFileFuncs — instructs phar to intercept fopen, file_get_contents, opendir, and all of the stat-related functions

Açıklama

final public static void Phar::interceptFileFuncs ( void )

instructs phar to intercept fopen(), readfile(), file_get_contents(), opendir(), and all of the stat-related functions. If any of these functions is called from within a phar archive with a relative path, the call is modified to access a file within the phar archive. Absolute paths are assumed to be attempts to load external files from the filesystem.

This function makes it possible to run PHP applications designed to run off of a hard disk as a phar application.

Değiştirgeler

No parameters.

Dönen Değerler

Örnekler

Örnek 1 A Phar::interceptFileFuncs() example

<?php
Phar::interceptFileFuncs();
include 'phar://' . __FILE__ . '/file.php';
?>

Assuming that this phar is at /path/to/myphar.phar and it contains file.php and file2.txt, if file.php contains this code:

Örnek 2 A Phar::interceptFileFuncs() example

<?php
echo file_get_contents('file2.txt');
?>

Normally PHP would search the current directory for file2.txt, which would translate as the directory of file.php, or the current directory of a command-line user. Phar::interceptFileFuncs() instructs PHP to consider the current directory to be phar:///path/to/myphar.phar/ and so opens phar:///path/to/myphar.phar/file2.txt in the above example code.

Phar::hasMetadata
Phar::isBuffering
Phar


Used to determine whether Phar write operations are being buffered, or are flushing directly to disk

Phar::interceptFileFuncs
Phar::isCompressed
Phar
PHP Manual

Phar::isBuffering

(PHP >= 5.3.0, PECL phar >= 1.0.0)

Phar::isBuffering — Used to determine whether Phar write operations are being buffered, or are flushing directly to disk

Açıklama

public bool Phar::isBuffering ( void )

This method can be used to determine whether a Phar will save changes to disk immediately, or whether a call to Phar::stopBuffering() is needed to enable saving changes.

Phar write buffering is per-archive, buffering active for the foo.phar Phar archive does not affect changes to the bar.phar Phar archive.

Dönen Değerler

Returns TRUE if the write operations are being buffer, FALSE otherwise.

Örnekler

Örnek 1 A Phar::isBuffering() example

<?php
$p = new Phar(dirname(__FILE__) . '/brandnewphar.phar', 0, 'brandnewphar.phar');
$p2 = new Phar('existingphar.phar');
$p['file1.txt'] = 'hi';
var_dump($p->isBuffering());
var_dump($p2->isBuffering());
?>
=2=
<?php
$p->startBuffering();
var_dump($p->isBuffering());
var_dump($p2->isBuffering());
$p->stopBuffering();
?>
=3=
<?php
var_dump($p->isBuffering());
var_dump($p2->isBuffering());
?>

Yukarıdaki örneğin çıktısı:

bool(false)
bool(false)
=2=
bool(true)
bool(false)
=3=
bool(false)
bool(false)

Ayrıca Bakınız

  • Phar::startBuffering() - Start buffering Phar write operations, do not modify the Phar object on disk
  • Phar::stopBuffering() - Stop buffering write requests to the Phar archive, and save changes to disk

Phar::interceptFileFuncs
Phar::isCompressed
Phar


Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)

Phar::isBuffering
Phar::isFileFormat
Phar
PHP Manual

Phar::isCompressed

(PHP >= 5.3.0, PECL phar >= 2.0.0)

Phar::isCompressed — Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)

Açıklama

public mixed Phar::isCompressed ( void )

Bilginize:

Phar nesneleri ile çalışmak için, bu yöntem phar.readonly php.ini yönergesine 0 atanmış olmasını gerektirir. Aksi takdirde bir PharException istisnası oluşur.

Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on). Zip-based phar archives cannot be compressed as a file, and so this method will always return FALSE if a zip-based phar archive is queried.

Değiştirgeler

No parameters.

Dönen Değerler

Phar::GZ, Phar::BZ2 or FALSE

Örnekler

Örnek 1 A Phar::isCompressed() example

<?php
try {
    $phar1 = new Phar('myphar.zip.phar');
    var_dump($phar1->isCompressed());
    $phar2 = new Phar('myuncompressed.tar.phar');
    var_dump($phar2->isCompressed());
    $phar2->compress(Phar::GZ);
    var_dump($phar2->isCompressed() == Phar::GZ);
} catch (Exception $e) {
}
?>

Yukarıdaki örneğin çıktısı:

bool(false)
bool(false)
bool(true)

Ayrıca Bakınız

  • PharFileInfo::getCompressedSize() - Returns the actual size of the file (with compression) inside the Phar archive
  • PharFileInfo::isCompressed() - Returns whether the entry is compressed
  • PharFileInfo::decompress() - Decompresses the current Phar entry within the phar
  • PharFileInfo::compress() - Compresses the current Phar entry with either zlib or bzip2 compression
  • Phar::decompress() - Decompresses the entire Phar archive
  • Phar::compress() - Compresses the entire Phar archive using Gzip or Bzip2 compression
  • Phar::canCompress() - Returns whether phar extension supports compression using either zlib or bzip2
  • Phar::compressFiles() - Compresses all files in the current Phar archive
  • Phar::decompressFiles() - Decompresses all files in the current Phar archive
  • Phar::getSupportedCompression() - Return array of supported compression algorithms

Phar::isBuffering
Phar::isFileFormat
Phar


Returns true if the phar archive is based on the tar/phar/zip file format depending on the parameter

Phar::isCompressed
Phar::isValidPharFilename
Phar
PHP Manual

Phar::isFileFormat

(PHP >= 5.3.0, PECL phar >= 2.0.0)

Phar::isFileFormat — Returns true if the phar archive is based on the tar/phar/zip file format depending on the parameter

Açıklama

public bool Phar::isFileFormat ( int $format )

Değiştirgeler

format

Either Phar::PHAR, Phar::TAR, or Phar::ZIP to test for the format of the archive.

Dönen Değerler

Returns TRUE if the phar archive matches the file format requested by the parameter

Hatalar/İstisnalar

PharException is thrown if the parameter is an unknown file format specifier.

Ayrıca Bakınız

  • Phar::convertToExecutable() - Convert a phar archive to another executable phar archive file format
  • Phar::convertToData() - Convert a phar archive to a non-executable tar or zip file

Phar::isCompressed
Phar::isValidPharFilename
Phar


Returns whether the given filename is a valid phar filename

Phar::isFileFormat
Phar::isWritable
Phar
PHP Manual

Phar::isValidPharFilename

(PHP >= 5.3.0, PECL phar >= 1.2.0)

Phar::isValidPharFilename — Returns whether the given filename is a valid phar filename

Açıklama

final public static bool Phar::isValidPharFilename ( string $filename [, bool $executable = true ] )

Returns whether the given filename is a valid phar filename that will be recognized as a phar archive by the phar extension. This can be used to test a name without having to instantiate a phar archive and catch the inevitable Exception that will be thrown if an invalid name is specified.

Değiştirgeler

filename

The name or full path to a phar archive not yet created

executable

This parameter determines whether the filename should be treated as a phar executable archive, or a data non-executable archive

Dönen Değerler

Returns TRUE if the filename is valid, FALSE if not.

Phar::isFileFormat
Phar::isWritable
Phar


Returns true if the phar archive can be modified

Phar::isValidPharFilename
Phar::loadPhar
Phar
PHP Manual

Phar::isWritable

(Unknown)

Phar::isWritable — Returns true if the phar archive can be modified

Açıklama

public bool Phar::isWritable ( void )

This method returns TRUE if phar.readonly is 0, and the actual phar archive on disk is not read-only.

Değiştirgeler

No parameters.

Dönen Değerler

Returns TRUE if the phar archive can be modified

Ayrıca Bakınız

  • Phar::canWrite() - Returns whether phar extension supports writing and creating phars
  • PharData::isWritable() - Returns true if the tar/zip archive can be modified

Phar::isValidPharFilename
Phar::loadPhar
Phar


Loads any phar archive with an alias

Phar::isWritable
Phar::mapPhar
Phar
PHP Manual

Phar::loadPhar

(PHP >= 5.3.0, PECL phar >= 1.0.0)

Phar::loadPhar — Loads any phar archive with an alias

Açıklama

final public static bool Phar::loadPhar ( string $filename [, string $alias ] )

This can be used to read the contents of an external Phar archive. This is most useful for assigning an alias to a phar so that subsequent references to the phar can use the shorter alias, or for loading Phar archives that only contain data and are not intended for execution/inclusion in PHP scripts.

Değiştirgeler

filename

the full or relative path to the phar archive to open

alias

The alias that may be used to refer to the phar archive. Note that many phar archives specify an explicit alias inside the phar archive, and a PharException will be thrown if a new alias is specified in this case.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

PharException is thrown if an alias is passed in and the phar archive already has an explicit alias

Örnekler

Örnek 1 A Phar::loadPhar() example

Phar::loadPhar can be used anywhere to load an external Phar archive, whereas Phar::mapPhar should be used in a loader stub for a Phar.

<?php
try {
    Phar::loadPhar('/path/to/phar.phar', 'my.phar');
    echo file_get_contents('phar://my.phar/file.txt');
} catch (PharException $e) {
    echo $e;
}
?>

Ayrıca Bakınız

  • Phar::mapPhar() - Reads the currently executed file (a phar) and registers its manifest

Phar::isWritable
Phar::mapPhar
Phar


Reads the currently executed file (a phar) and registers its manifest

Phar::loadPhar
Phar::mount
Phar
PHP Manual

Phar::mapPhar

(PHP >= 5.3.0, PECL phar >= 1.0.0)

Phar::mapPhar — Reads the currently executed file (a phar) and registers its manifest

Açıklama

final public static bool Phar::mapPhar ([ string $alias [, int $dataoffset = 0 ]] )

This static method can only be used inside a Phar archive's loader stub in order to initialize the phar when it is directly executed, or when it is included in another script.

Değiştirgeler

alias

The alias that can be used in phar:// URLs to refer to this archive, rather than its full path.

dataoffset

Unused variable, here for compatibility with PEAR's PHP_Archive.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

PharException is thrown if not called directly within PHP execution, if no __HALT_COMPILER(); token is found in the current source file, or if the file cannot be opened for reading.

Örnekler

Örnek 1 A Phar::mapPhar() example

mapPhar should be used only inside a phar's loader stub. Use loadPhar to load an external phar into memory.

Here is a sample Phar loader stub that uses mapPhar.

<?php
function __autoload($class)
{
    include 'phar://me.phar/' . str_replace('_', '/', $class) . '.php';
}
try {
    Phar::mapPhar('me.phar');
    include 'phar://me.phar/startup.php';
} catch (PharException $e) {
    echo $e->getMessage();
    die('Cannot initialize Phar');
}
__HALT_COMPILER();

Ayrıca Bakınız

  • Phar::loadPhar() - Loads any phar archive with an alias

Phar::loadPhar
Phar::mount
Phar


Mount an external path or file to a virtual location within the phar archive

Phar::mapPhar
Phar::mungServer
Phar
PHP Manual

Phar::mount

(PHP >= 5.3.0, PECL phar >= 2.0.0)

Phar::mount — Mount an external path or file to a virtual location within the phar archive

Açıklama

final public static void Phar::mount ( string $pharpath , string $externalpath )

Much like the unix file system concept of mounting external devices to paths within the directory tree, Phar::mount() allows referring to external files and directories as if they were inside of an archive. This allows powerful abstraction such as referring to external configuration files as if they were inside the archive.

Değiştirgeler

pharpath

The internal path within the phar archive to use as the mounted path location. This must be a relative path within the phar archive, and must not already exist.

externalpath

A path or URL to an external file or directory to mount within the phar archive

Dönen Değerler

No return. PharException is thrown on failure.

Hatalar/İstisnalar

Throws PharException if any problems occur mounting the path.

Örnekler

Örnek 1 A Phar::mount() example

The following example shows accessing an external configuration file as if it were a path within a phar archive.

First, the code inside of a phar archive:

<?php
$configuration = simplexml_load_string(file_get_contents(
    Phar::running(false) . '/config.xml'));
?>

Next the external code used to mount the configuration file:

<?php
// first set up the association between the abstract config.xml
// and the actual one on disk
Phar::mount('phar://config.xml', '/home/example/config.xml');
// now run the application
include '/path/to/archive.phar';
?>

Another method is to put the mounting code inside the stub of the phar archive. Here is an example of setting up a default configuration file if no user configuration is specified:

<?php
// first set up the association between the abstract config.xml
// and the actual one on disk
if (defined('EXTERNAL_CONFIG')) {
    Phar::mount('config.xml', EXTERNAL_CONFIG);
    if (file_exists(__DIR__ . '/extra_config.xml')) {
        Phar::mount('extra.xml', __DIR__ . '/extra_config.xml');
    }
} else {
    Phar::mount('config.xml', 'phar://' . __FILE__ . '/default_config.xml');
    Phar::mount('extra.xml', 'phar://' . __FILE__ . '/default_extra.xml');
}
// now run the application
include 'phar://' . __FILE__ . '/index.php';
__HALT_COMPILER();
?>

...and the code externally to load this phar archive:

<?php
define('EXTERNAL_CONFIG', '/home/example/config.xml');
// now run the application
include '/path/to/archive.phar';
?>

Phar::mapPhar
Phar::mungServer
Phar


Defines a list of up to 4 $_SERVER variables that should be modified for execution

Phar::mount
Phar::offsetExists
Phar
PHP Manual

Phar::mungServer

(Unknown)

Phar::mungServer — Defines a list of up to 4 $_SERVER variables that should be modified for execution

Açıklama

final public static void Phar::mungServer ( array $munglist )

Phar::mungServer() should only be called within the stub of a phar archive.

Defines a list of up to 4 $_SERVER variables that should be modified for execution. Variables that can be modified to remove traces of phar execution are REQUEST_URI, PHP_SELF, SCRIPT_NAME and SCRIPT_FILENAME.

On its own, this method does nothing. Only when combined with Phar::webPhar() does it take effect, and only when the requested file is a PHP file to be parsed. Note that the PATH_INFO and PATH_TRANSLATED variables are always modified.

The original values of variables that are modified are stored in the SERVER array with PHAR_ prepended, so for instance SCRIPT_NAME would be saved as PHAR_SCRIPT_NAME.

Değiştirgeler

munglist

an array containing as string indices any of REQUEST_URI, PHP_SELF, SCRIPT_NAME and SCRIPT_FILENAME. Other values trigger an exception, and Phar::mungServer() is case-sensitive.

Dönen Değerler

No return.

Hatalar/İstisnalar

Throws UnexpectedValueException if any problems are found with the passed in data.

Örnekler

Örnek 1 A Phar::mungServer() example

<?php
// example stub
Phar::mungServer(array('REQUEST_URI'));
Phar::webPhar();
__HALT_COMPILER();
?>

Ayrıca Bakınız

  • Phar::webPhar() - mapPhar for web-based phars. front controller for web applications
  • Phar::setStub() - Used to set the PHP loader or bootstrap stub of a Phar archive

Phar::mount
Phar::offsetExists
Phar


determines whether a file exists in the phar

Phar::mungServer
Phar::offsetGet
Phar
PHP Manual

Phar::offsetExists

(PHP >= 5.3.0, PECL phar >= 1.0.0)

Phar::offsetExists — determines whether a file exists in the phar

Açıklama

public bool Phar::offsetExists ( string $offset )

This is an implementation of the ArrayAccess interface allowing direct manipulation of the contents of a Phar archive using array access brackets.

offsetExists() is called whenever isset() is called.

Değiştirgeler

offset

The filename (relative path) to look for in a Phar.

Dönen Değerler

Returns TRUE if the file exists within the phar, or FALSE if not.

Örnekler

Örnek 1 A Phar::offsetExists() example

<?php
$p = new Phar(dirname(__FILE__) . '/my.phar', 0, 'my.phar');
$p['firstfile.txt'] = 'first file';
$p['secondfile.txt'] = 'second file';
// the next set of lines call offsetExists() indirectly
var_dump(isset($p['firstfile.txt']));
var_dump(isset($p['nothere.txt']));
?>

Yukarıdaki örneğin çıktısı:

bool(true)
bool(false)

Ayrıca Bakınız

  • Phar::offsetGet() - Gets a PharFileInfo object for a specific file
  • Phar::offsetSet() - set the contents of an internal file to those of an external file
  • Phar::offsetUnset() - remove a file from a phar

Phar::mungServer
Phar::offsetGet
Phar


Gets a PharFileInfo object for a specific file

Phar::offsetExists
Phar::offsetSet
Phar
PHP Manual

Phar::offsetGet

(PHP >= 5.3.0, PECL phar >= 1.0.0)

Phar::offsetGet — Gets a PharFileInfo object for a specific file

Açıklama

public int Phar::offsetGet ( string $offset )

This is an implementation of the ArrayAccess interface allowing direct manipulation of the contents of a Phar archive using array access brackets. Phar::offsetGet() is used for retrieving files from a Phar archive.

Değiştirgeler

offset

The filename (relative path) to look for in a Phar.

Dönen Değerler

A PharFileInfo object is returned that can be used to iterate over a file's contents or to retrieve information about the current file.

Hatalar/İstisnalar

This method throws BadMethodCallException if the file does not exist in the Phar archive.

Örnekler

Örnek 1 Phar::offsetGet() example

As with all classes that implement the ArrayAccess interface, Phar::offsetGet() is automatically called when using the [] angle bracket operator.

<?php
$p = new Phar(dirname(__FILE__) . '/myphar.phar', 0, 'myphar.phar');
$p['exists.txt'] = "file exists\n";
try {
    // automatically calls offsetGet()
    echo $p['exists.txt'];
    echo $p['doesnotexist.txt'];
} catch (BadMethodCallException $e) {
    echo $e;
}
?>

Yukarıdaki örneğin çıktısı:

file exists
Entry doesnotexist.txt does not exist

Ayrıca Bakınız

  • Phar::offsetExists() - determines whether a file exists in the phar
  • Phar::offsetSet() - set the contents of an internal file to those of an external file
  • Phar::offsetUnset() - remove a file from a phar

Phar::offsetExists
Phar::offsetSet
Phar


set the contents of an internal file to those of an external file

Phar::offsetGet
Phar::offsetUnset
Phar
PHP Manual

Phar::offsetSet

(PHP >= 5.3.0, PECL phar >= 1.0.0)

Phar::offsetSet — set the contents of an internal file to those of an external file

Açıklama

public void Phar::offsetSet ( string $offset , string $value )

Bilginize:

Phar nesneleri ile çalışmak için, bu yöntem phar.readonly php.ini yönergesine 0 atanmış olmasını gerektirir. Aksi takdirde bir PharException istisnası oluşur.

This is an implementation of the ArrayAccess interface allowing direct manipulation of the contents of a Phar archive using array access brackets. offsetSet is used for modifying an existing file, or adding a new file to a Phar archive.

Değiştirgeler

offset

The filename (relative path) to modify in a Phar.

value

Content of the file.

Dönen Değerler

No return values.

Hatalar/İstisnalar

if phar.readonly is 1, BadMethodCallException is thrown, as modifying a Phar is only allowed when phar.readonly is set to 0. Throws PharException if there are any problems flushing changes made to the Phar archive to disk.

Örnekler

Örnek 1 A Phar::offsetSet() example

offsetSet should not be accessed directly, but instead used via array access with the [] operator.

<?php
$p = new Phar('/path/to/my.phar', 0, 'my.phar');
try {
    // calls offsetSet
    $p['file.txt'] = 'Hi there';
} catch (Exception $e) {
    echo 'Could not modify file.txt:', $e;
}
?>

Ayrıca Bakınız

  • Phar::offsetExists() - determines whether a file exists in the phar
  • Phar::offsetGet() - Gets a PharFileInfo object for a specific file
  • Phar::offsetUnset() - remove a file from a phar

Phar::offsetGet
Phar::offsetUnset
Phar


remove a file from a phar

Phar::offsetSet
Phar::running
Phar
PHP Manual

Phar::offsetUnset

(PHP >= 5.3.0, PECL phar >= 1.0.0)

Phar::offsetUnset — remove a file from a phar

Açıklama

public bool Phar::offsetUnset ( string $offset )

Bilginize:

Phar nesneleri ile çalışmak için, bu yöntem phar.readonly php.ini yönergesine 0 atanmış olmasını gerektirir. Aksi takdirde bir PharException istisnası oluşur.

This is an implementation of the ArrayAccess interface allowing direct manipulation of the contents of a Phar archive using array access brackets. offsetUnset is used for deleting an existing file, and is called by the unset() language construct.

Değiştirgeler

offset

The filename (relative path) to modify in a Phar.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

if phar.readonly is 1, BadMethodCallException is thrown, as modifying a Phar is only allowed when phar.readonly is set to 0. Throws PharException if there are any problems flushing changes made to the Phar archive to disk.

Örnekler

Örnek 1 A Phar::offsetUnset() example

<?php
$p = new Phar('/path/to/my.phar', 0, 'my.phar');
try {
    // deletes file.txt from my.phar by calling offsetUnset
    unset($p['file.txt']);
} catch (Exception $e) {
    echo 'Could not delete file.txt: ', $e;
}
?>

Ayrıca Bakınız

  • Phar::offsetExists() - determines whether a file exists in the phar
  • Phar::offsetGet() - Gets a PharFileInfo object for a specific file
  • Phar::offsetSet() - set the contents of an internal file to those of an external file
  • Phar::unlinkArchive() - Completely remove a phar archive from disk and from memory
  • Phar::delete() - Delete a file within a phar archive

Phar::offsetSet
Phar::running
Phar


Returns the full path on disk or full phar URL to the currently executing Phar archive

Phar::offsetUnset
Phar::setAlias
Phar
PHP Manual

Phar::running

(PHP >= 5.3.0, PECL phar >= 2.0.0)

Phar::running — Returns the full path on disk or full phar URL to the currently executing Phar archive

Açıklama

final public static string Phar::running ([ bool $retphar = true ] )

Returns the full path to the running phar archive. This is intended for use much like the __FILE__ magic constant, and only has effect inside an executing phar archive.

Inside the stub of an archive, Phar::running() returns "". Simply use __FILE__ to access the current running phar inside a stub.

Değiştirgeler

retphar

If FALSE, the full path on disk to the phar archive is returned. If TRUE, a full phar URL is returned.

Dönen Değerler

Returns the filename if valid, empty string otherwise.

Örnekler

Örnek 1 A Phar::running() example

For the following example, assume the phar archive is located at /path/to/phar/my.phar.

<?php
$a = Phar::running(); // $a is "phar:///path/to/my.phar"
$b = Phar::running(false); // $b is "/path/to/my.phar"
?>

Phar::offsetUnset
Phar::setAlias
Phar


Set the alias for the Phar archive

Phar::running
Phar::setDefaultStub
Phar
PHP Manual

Phar::setAlias

(PHP >= 5.3.0, PECL phar >= 1.2.1)

Phar::setAlias — Set the alias for the Phar archive

Açıklama

public bool Phar::setAlias ( string $alias )

Bilginize:

Phar nesneleri ile çalışmak için, bu yöntem phar.readonly php.ini yönergesine 0 atanmış olmasını gerektirir. Aksi takdirde bir PharException istisnası oluşur.

Set the alias for the Phar archive, and write it as the permanent alias for this phar archive. An alias can be used internally to a phar archive to ensure that use of the phar stream wrapper to access internal files always works regardless of the location of the phar archive on the filesystem. Another alternative is to rely upon Phar's interception of include or to use Phar::interceptFileFuncs() and use relative paths.

Değiştirgeler

alias

A shorthand string that this archive can be referred to in phar stream wrapper access.

Dönen Değerler

Hatalar/İstisnalar

Throws UnexpectedValueException when write access is disabled, and PharException if the alias is already in use or any problems were encountered flushing changes to disk.

Örnekler

Örnek 1 A Phar::setAlias() example

<?php
try {
    $phar = new Phar('myphar.phar');
    $phar->setAlias('myp.phar');
} catch (Exception $e) {
    // handle error
}
?>

Ayrıca Bakınız

  • Phar::__construct() - Construct a Phar archive object
  • Phar::interceptFileFuncs() - instructs phar to intercept fopen, file_get_contents, opendir, and all of the stat-related functions

Phar::running
Phar::setDefaultStub
Phar


Used to set the PHP loader or bootstrap stub of a Phar archive to the default loader

Phar::setAlias
Phar::setMetadata
Phar
PHP Manual

Phar::setDefaultStub

(Unknown)

Phar::setDefaultStub — Used to set the PHP loader or bootstrap stub of a Phar archive to the default loader

Açıklama

public bool Phar::setDefaultStub ([ string $index [, string $webindex ]] )

Bilginize:

Phar nesneleri ile çalışmak için, bu yöntem phar.readonly php.ini yönergesine 0 atanmış olmasını gerektirir. Aksi takdirde bir PharException istisnası oluşur.

This method is a convenience method that combines the functionality of Phar::createDefaultStub() and Phar::setStub().

Değiştirgeler

index

Relative path within the phar archive to run if accessed on the command-line

webindex

Relative path within the phar archive to run if accessed through a web browser

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

UnexpectedValueException is thrown if phar.readonly is enabled in php.ini. PharException is thrown if any problems are encountered flushing changes to disk.

Örnekler

Örnek 1 A Phar::setDefaultStub() example

<?php
try {
    $phar = new Phar('myphar.phar');
    $phar->setDefaultStub('cli.php', 'web/index.php');
    // this is the same as:
    // $phar->setStub($phar->createDefaultStub('cli.php', 'web/index.php'));
} catch (Exception $e) {
    // handle errors
}
?>

Ayrıca Bakınız

  • Phar::setStub() - Used to set the PHP loader or bootstrap stub of a Phar archive
  • Phar::createDefaultStub() - Create a phar-file format specific stub

Phar::setAlias
Phar::setMetadata
Phar


Sets phar archive meta-data

Phar::setDefaultStub
Phar::setSignatureAlgorithm
Phar
PHP Manual

Phar::setMetadata

(PHP >= 5.3.0, PECL phar >= 1.0.0)

Phar::setMetadata — Sets phar archive meta-data

Açıklama

public void Phar::setMetadata ( mixed $metadata )

Bilginize:

Phar nesneleri ile çalışmak için, bu yöntem phar.readonly php.ini yönergesine 0 atanmış olmasını gerektirir. Aksi takdirde bir PharException istisnası oluşur.

Phar::setMetadata() should be used to store customized data that describes something about the phar archive as a complete entity. PharFileInfo::setMetadata() should be used for file-specific meta-data. Meta-data can slow down the performance of loading a phar archive if the data is large.

Some possible uses for meta-data include specifying which file within the archive should be used to bootstrap the archive, or the location of a file manifest like » PEAR's package.xml file. However, any useful data that describes the phar archive may be stored.

Değiştirgeler

metadata

Any PHP variable containing information to store that describes the phar archive

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 A Phar::setMetadata() example

<?php
// make sure it doesn't exist
@unlink('brandnewphar.phar');
try {
    $p = new Phar(dirname(__FILE__) . '/brandnewphar.phar', 0, 'brandnewphar.phar');
    $p['file.php'] = '<?php echo "hello"';
    $p->setMetadata(array('bootstrap' => 'file.php'));
    var_dump($p->getMetadata());
} catch (Exception $e) {
    echo 'Could not create and/or modify phar:', $e;
}
?>

Yukarıdaki örneğin çıktısı:

array(1) {
  ["bootstrap"]=>
  string(8) "file.php"
}

Ayrıca Bakınız

  • Phar::getMetadata() - Returns phar archive meta-data
  • Phar::delMetadata() - Deletes the global metadata of the phar
  • Phar::hasMetadata() - Returns whether phar has global meta-data

Phar::setDefaultStub
Phar::setSignatureAlgorithm
Phar


set the signature algorithm for a phar and apply it.

Phar::setMetadata
Phar::setStub
Phar
PHP Manual

Phar::setSignatureAlgorithm

(PHP >= 5.3.0, PECL phar >= 1.1.0)

Phar::setSignatureAlgorithm — set the signature algorithm for a phar and apply it.

Açıklama

public void Phar::setSignatureAlgorithm ( int $sigtype [, string $privatekey ] )

Bilginize:

Phar nesneleri ile çalışmak için, bu yöntem phar.readonly php.ini yönergesine 0 atanmış olmasını gerektirir. Aksi takdirde bir PharException istisnası oluşur.

set the signature algorithm for a phar and apply it. The signature algorithm must be one of Phar::MD5, Phar::SHA1, Phar::SHA256, Phar::SHA512, or Phar::OPENSSL.

Note that all executable phar archives have a signature created automatically, SHA1 by default. data tar- or zip-based archives (archives created with the PharData class) must have their signature created and set explicitly via Phar::setSignatureAlgorithm().

Değiştirgeler

sigtype

    One of Phar::MD5,
Phar::SHA1, Phar::SHA256,
Phar::SHA512, or Phar::OPENSSL

privatekey

The contents of an OpenSSL private key, as extracted from a certificate or OpenSSL key file:

<?php
$private = openssl_get_privatekey(file_get_contents('private.pem'));
$pkey = '';
openssl_pkey_export($private, $pkey);
$p->setSignatureAlgorithm(Phar::OPENSSL, $pkey);
?>
See phar introduction for instructions on naming and placement of the public key file.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

Throws UnexpectedValueException for many errors, and a PharException if any problems occur flushing changes to disk.

Ayrıca Bakınız

  • Phar::getSupportedSignatures() - Return array of supported signature types
  • Phar::getSignature() - Return MD5/SHA1/SHA256/SHA512/OpenSSL signature of a Phar archive

Phar::setMetadata
Phar::setStub
Phar


Used to set the PHP loader or bootstrap stub of a Phar archive

Phar::setSignatureAlgorithm
Phar::startBuffering
Phar
PHP Manual

Phar::setStub

(PHP >= 5.3.0, PECL phar >= 1.0.0)

Phar::setStub — Used to set the PHP loader or bootstrap stub of a Phar archive

Açıklama

public bool Phar::setStub ( string $stub [, int $len = -1 ] )

Bilginize:

Phar nesneleri ile çalışmak için, bu yöntem phar.readonly php.ini yönergesine 0 atanmış olmasını gerektirir. Aksi takdirde bir PharException istisnası oluşur.

This method is used to add a PHP bootstrap loader stub to a new Phar archive, or to replace the loader stub in an existing Phar archive.

The loader stub for a Phar archive is used whenever an archive is included directly as in this example:

<?php
include 'myphar.phar';
?>

The loader is not accessed when including a file through the phar stream wrapper like so:

<?php
include 'phar://myphar.phar/somefile.php';
?>

Değiştirgeler

stub

A string or an open stream handle to use as the executable stub for this phar archive.

len

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

UnexpectedValueException is thrown if phar.readonly is enabled in php.ini. PharException is thrown if any problems are encountered flushing changes to disk.

Örnekler

Örnek 1 A Phar::setStub() example

<?php
try {
    $p = new Phar(dirname(__FILE__) . '/brandnewphar.phar', 0, 'brandnewphar.phar');
    $p['a.php'] = '<?php var_dump("Hello");';
    $p->setStub('<?php var_dump("First"); Phar::mapPhar("brandnewphar.phar"); __HALT_COMPILER(); ?>');
    include 'phar://brandnewphar.phar/a.php';
    var_dump($p->getStub());
    $p['b.php'] = '<?php var_dump("World");';
    $p->setStub('<?php var_dump("Second"); Phar::mapPhar("brandnewphar.phar"); __HALT_COMPILER(); ?>');
    include 'phar://brandnewphar.phar/b.php';
    var_dump($p->getStub());
} catch (Exception $e) {
    echo 'Write operations failed on brandnewphar.phar: ', $e;
}
?>

Yukarıdaki örneğin çıktısı:

string(5) "Hello"
string(82) "<?php var_dump("First"); Phar::mapPhar("brandnewphar.phar"); __HALT_COMPILER(); ?>"
string(5) "World"
string(83) "<?php var_dump("Second"); Phar::mapPhar("brandnewphar.phar"); __HALT_COMPILER(); ?>"

Sürüm Bilgisi

Sürüm: | Açıklama
5.4.0 | Added len parameter.

Ayrıca Bakınız

  • Phar::getStub() - Return the PHP loader or bootstrap stub of a Phar archive
  • Phar::createDefaultStub() - Create a phar-file format specific stub

Phar::setSignatureAlgorithm
Phar::startBuffering
Phar


Start buffering Phar write operations, do not modify the Phar object on disk

Phar::setStub
Phar::stopBuffering
Phar
PHP Manual

Phar::startBuffering

(PHP >= 5.3.0, PECL phar >= 1.0.0)

Phar::startBuffering — Start buffering Phar write operations, do not modify the Phar object on disk

Açıklama

public void Phar::startBuffering ( void )

Although technically unnecessary, the Phar::startBuffering() method can provide a significant performance boost when creating or modifying a Phar archive with a large number of files. Ordinarily, every time a file within a Phar archive is created or modified in any way, the entire Phar archive will be recreated with the changes. In this way, the archive will be up-to-date with the activity performed on it.

However, this can be unnecessary when simply creating a new Phar archive, when it would make more sense to write the entire archive out at once. Similarly, it is often necessary to make a series of changes and to ensure that they all are possible before making any changes on disk, similar to the relational database concept of transactions. the Phar::startBuffering()/Phar::stopBuffering() pair of methods is provided for this purpose.

Phar write buffering is per-archive, buffering active for the foo.phar Phar archive does not affect changes to the bar.phar Phar archive.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 A Phar::startBuffering() example

<?php
// make sure it doesn't exist
@unlink('brandnewphar.phar');
try {
    $p = new Phar(dirname(__FILE__) . '/brandnewphar.phar', 0, 'brandnewphar.phar');
} catch (Exception $e) {
    echo 'Could not create phar:', $e;
}
echo 'The new phar has ' . $p->count() . " entries\n";
$p->startBuffering();
$p['file.txt'] = 'hi';
$p['file2.txt'] = 'there';
$p['file2.txt']->setCompressedGZ();
$p['file3.txt'] = 'babyface';
$p['file3.txt']->setMetadata(42);
$p->setStub("<?php
function __autoload($class)
{
    include 'phar://myphar.phar/' . str_replace('_', '/', $class) . '.php';
}
Phar::mapPhar('myphar.phar');
include 'phar://myphar.phar/startup.php';
__HALT_COMPILER();");
$p->stopBuffering();
?>

Ayrıca Bakınız

  • Phar::stopBuffering() - Stop buffering write requests to the Phar archive, and save changes to disk
  • Phar::isBuffering() - Used to determine whether Phar write operations are being buffered, or are flushing directly to disk

Phar::setStub
Phar::stopBuffering
Phar


Stop buffering write requests to the Phar archive, and save changes to disk

Phar::startBuffering
Phar::uncompressAllFiles
Phar
PHP Manual

Phar::stopBuffering

(PHP >= 5.3.0, PECL phar >= 1.0.0)

Phar::stopBuffering — Stop buffering write requests to the Phar archive, and save changes to disk

Açıklama

public void Phar::stopBuffering ( void )

Phar::stopBuffering() is used in conjunction with the Phar::startBuffering() method. Phar::startBuffering() can provide a significant performance boost when creating or modifying a Phar archive with a large number of files. Ordinarily, every time a file within a Phar archive is created or modified in any way, the entire Phar archive will be recreated with the changes. In this way, the archive will be up-to-date with the activity performed on it.

However, this can be unnecessary when simply creating a new Phar archive, when it would make more sense to write the entire archive out at once. Similarly, it is often necessary to make a series of changes and to ensure that they all are possible before making any changes on disk, similar to the relational database concept of transactions. The Phar::startBuffering()/Phar::stopBuffering() pair of methods is provided for this purpose.

Phar write buffering is per-archive, buffering active for the foo.phar Phar archive does not affect changes to the bar.phar Phar archive.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

PharException is thrown if any problems are encountered flushing changes to disk.

Örnekler

Örnek 1 A Phar::stopBuffering() example

<?php
$p = new Phar(dirname(__FILE__) . '/brandnewphar.phar', 0, 'brandnewphar.phar');
$p['file1.txt'] = 'hi';
$p->startBuffering();
var_dump($p->getStub());
$p->setStub("<?php
function __autoload(\$class)
{
    include 'phar://brandnewphar.phar/' . str_replace('_', '/', \$class) . '.php';
}
Phar::mapPhar('brandnewphar.phar');
include 'phar://brandnewphar.phar/startup.php';
__HALT_COMPILER();");
$p->stopBuffering();
var_dump($p->getStub());
?>

Yukarıdaki örneğin çıktısı:

string(24) "<?php __HALT_COMPILER();"
string(195) "<?php
function __autoload($class)
{
    include 'phar://' . str_replace('_', '/', $class);
}
Phar::mapPhar('brandnewphar.phar');
include 'phar://brandnewphar.phar/startup.php';
__HALT_COMPILER();"

Ayrıca Bakınız

  • Phar::startBuffering() - Start buffering Phar write operations, do not modify the Phar object on disk
  • Phar::isBuffering() - Used to determine whether Phar write operations are being buffered, or are flushing directly to disk

Phar::startBuffering
Phar::uncompressAllFiles
Phar


Uncompresses all files in the current Phar archive

Phar::stopBuffering
Phar::unlinkArchive
Phar
PHP Manual

Phar::uncompressAllFiles

(PECL phar < 2.0.0)

Phar::uncompressAllFiles — Uncompresses all files in the current Phar archive

Açıklama

public bool Phar::uncompressAllFiles ( void )

Bilginize:

Bu yöntem Phar eklentisinin 2.0.0
sürümünde kaldırıldı. Yerine Phar::compress(),
Phar::decompress(),
Phar::compressFiles() ve
Phar::decompressFiles() kullanılabilir.

Bilginize:

Phar nesneleri ile çalışmak için, bu yöntem phar.readonly php.ini yönergesine 0 atanmış olmasını gerektirir. Aksi takdirde bir PharException istisnası oluşur.

This method decompresses all files in the Phar archive. If any files are already compressed using gzip compression, the zlib extension must be enabled in order to decompress the files, and any files compressed using bzip2 compression require the bzip2 extension to decompress the files. As with all functionality that modifies the contents of a phar, the phar.readonly INI variable must be off in order to succeed.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

Throws BadMethodCallException if the phar.readonly INI variable is on, the bzip2 extension is not enabled and any files are compressed using bzip2 compression, or if any files are compressed using gzip compression and the zlib extension is not enabled.

Örnekler

Örnek 1 A Phar::uncompressAllFiles() example

<?php
try {
    $p = new Phar('/path/to/my.phar', 0, 'my.phar');
    $p['myfile.txt'] = 'hi';
    $p['myfile2.txt'] = 'hi';
    $p->compressAllFilesGZ();
    foreach ($p as $file) {
        var_dump($file->getFileName());
        var_dump($file->isCompressed());
        var_dump($file->isCompressedBZIP2());
        var_dump($file->isCompressedGZ());
    }
    $p->uncompressAllFiles();
    foreach ($p as $file) {
        var_dump($file->getFileName());
        var_dump($file->isCompressed());
        var_dump($file->isCompressedBZIP2());
        var_dump($file->isCompressedGZ());
    }
} catch (Exception $e) {
    echo 'Write operations failed on my.phar: ', $e;
}
?>

Yukarıdaki örneğin çıktısı:

string(10) "myfile.txt"
bool(true)
bool(false)
bool(true)
string(11) "myfile2.txt"
bool(true)
bool(false)
bool(true)
string(10) "myfile.txt"
bool(false)
bool(false)
bool(false)
string(11) "myfile2.txt"
bool(false)
bool(false)
bool(false)

Ayrıca Bakınız

  • PharFileInfo::getCompressedSize() - Returns the actual size of the file (with compression) inside the Phar archive
  • PharFileInfo::isCompressedBZIP2() - Returns whether the entry is compressed using bzip2
  • PharFileInfo::isCompressed() - Returns whether the entry is compressed
  • PharFileInfo::isCompressedGZ() - Returns whether the entry is compressed using gz
  • PharFileInfo::setCompressedBZIP2() - Compresses the current Phar entry within the phar using Bzip2 compression
  • PharFileInfo::setUncompressed() - Uncompresses the current Phar entry within the phar, if it is compressed
  • PharFileInfo::setCompressedGZ() - Compresses the current Phar entry within the phar using gz compression
  • Phar::canCompress() - Returns whether phar extension supports compression using either zlib or bzip2
  • Phar::isCompressed() - Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)
  • Phar::compressAllFilesBZIP2() - Compresses all files in the current Phar archive using Bzip2 compression
  • Phar::compressAllFilesGZ() - Compresses all files in the current Phar archive using Gzip compression
  • Phar::getSupportedCompression() - Return array of supported compression algorithms

Phar::stopBuffering
Phar::unlinkArchive
Phar


Completely remove a phar archive from disk and from memory

Phar::uncompressAllFiles
Phar::webPhar
Phar
PHP Manual

Phar::unlinkArchive

(PHP >= 5.3.0, PECL phar >= 2.0.0)

Phar::unlinkArchive — Completely remove a phar archive from disk and from memory

Açıklama

final public static bool Phar::unlinkArchive ( string $archive )

Removes a phar archive from disk and memory.

Değiştirgeler

archive

The path on disk to the phar archive.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

PharException is thrown if there are any open file pointers to the phar archive, or any existing Phar, PharData, or PharFileInfo objects referring to the phar archive.

Örnekler

Örnek 1 A Phar::unlinkArchive() example

<?php
// simple usage
Phar::unlinkArchive('/path/to/my.phar');

// more common example:
$p = new Phar('my.phar');
$fp = fopen('phar://my.phar/file.txt', 'r');
// this creates 'my.phar.gz'
$gp = $p->compress(Phar::GZ);
// remove all references to the archive
unset($p);
fclose($fp);
// now remove all traces of the archive
Phar::unlinkArchive('my.phar');
?>

Ayrıca Bakınız

  • Phar::delete() - Delete a file within a phar archive
  • Phar::offsetUnset() - remove a file from a phar

Phar::uncompressAllFiles
Phar::webPhar
Phar


mapPhar for web-based phars. front controller for web applications

Phar::unlinkArchive
PharData
Phar
PHP Manual

Phar::webPhar

(PHP >= 5.3.0, PECL phar >= 2.0.0)

Phar::webPhar — mapPhar for web-based phars. front controller for web applications

Açıklama

final public static void Phar::webPhar ([ string $alias [, string $index = "index.php" [, string $f404 [, array $mimetypes [, callable $rewrites ]]]]] )

Phar::mapPhar() for web-based phars. This method parses $_SERVER['REQUEST_URI'] and routes a request from a web browser to an internal file within the phar archive. In essence, it simulates a web server, routing requests to the correct file, echoing the correct headers and parsing PHP files as needed. This powerful method is part of what makes it easy to convert an existing PHP application into a phar archive. Combined with Phar::mungServer() and Phar::interceptFileFuncs(), any web application can be used unmodified from a phar archive.

Phar::webPhar() should only be called from the stub of a phar archive (see here for more information on what a stub is).

Değiştirgeler

alias

The alias that can be used in phar:// URLs to refer to this archive, rather than its full path.

index

The location within the phar of the directory index.

f404

The location of the script to run when a file is not found. This script should output the proper HTTP 404 headers.

mimetypes

An array mapping additional file extensions to MIME type. If the default mapping is sufficient, pass an empty array. By default, these extensions are mapped to these MIME types:

<?php
$mimes = array(
    'phps' => Phar::PHPS, // pass to highlight_file()
    'c' => 'text/plain',
    'cc' => 'text/plain',
    'cpp' => 'text/plain',
    'c++' => 'text/plain',
    'dtd' => 'text/plain',
    'h' => 'text/plain',
    'log' => 'text/plain',
    'rng' => 'text/plain',
    'txt' => 'text/plain',
    'xsd' => 'text/plain',
    'php' => Phar::PHP, // parse as PHP
    'inc' => Phar::PHP, // parse as PHP
    'avi' => 'video/avi',
    'bmp' => 'image/bmp',
    'css' => 'text/css',
    'gif' => 'image/gif',
    'htm' => 'text/html',
    'html' => 'text/html',
    'htmls' => 'text/html',
    'ico' => 'image/x-ico',
    'jpe' => 'image/jpeg',
    'jpg' => 'image/jpeg',
    'jpeg' => 'image/jpeg',
    'js' => 'application/x-javascript',
    'midi' => 'audio/midi',
    'mid' => 'audio/midi',
    'mod' => 'audio/mod',
    'mov' => 'movie/quicktime',
    'mp3' => 'audio/mp3',
    'mpg' => 'video/mpeg',
    'mpeg' => 'video/mpeg',
    'pdf' => 'application/pdf',
    'png' => 'image/png',
    'swf' => 'application/shockwave-flash',
    'tif' => 'image/tiff',
    'tiff' => 'image/tiff',
    'wav' => 'audio/wav',
    'xbm' => 'image/xbm',
    'xml' => 'text/xml',
);
?>

rewrites

The rewrites function is passed a string as its only parameter and must return a string or FALSE.

If you are using fast-cgi or cgi then the parameter passed to the function is the value of the $_SERVER['PATH_INFO'] variable. Otherwise, the parameter passed to the function is the value of the $_SERVER['REQUEST_URI'] variable.

If a string is returned it is used as the internal file path. If FALSE is returned then webPhar() will send a HTTP 403 Denied Code.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

Throws PharException when unable to open the internal file to output, or if called from a non-stub. If an invalid array value is passed into mimetypes or an invalid callback is passed into rewrites, then UnexpectedValueException is thrown.

Örnekler

Örnek 1 A Phar::webPhar() example

With the example below, the created phar will display Hello World if one browses to /myphar.phar/index.php or to /myphar.phar, and will display the source of index.phps if one browses to /myphar.phar/index.phps.

<?php
// creating the phar archive:
try {
    $phar = new Phar('myphar.phar');
    $phar['index.php'] = '<?php echo "Hello World"; ?>';
    $phar['index.phps'] = '<?php echo "Hello World"; ?>';
    $phar->setStub('<?php
Phar::webPhar();
__HALT_COMPILER(); ?>');
} catch (Exception $e) {
    // handle error here
}
?>

Ayrıca Bakınız

  • Phar::mungServer() - Defines a list of up to 4 $_SERVER variables that should be modified for execution
  • Phar::interceptFileFuncs() - instructs phar to intercept fopen, file_get_contents, opendir, and all of the stat-related functions

Phar::unlinkArchive
PharData
Phar


The PharData class

(PHP >= 5.3.0, PECL phar >= 2.0.0)

Giriş

The PharData class provides a high-level interface to accessing and creating non-executable tar and zip archives. Because these archives do not contain a stub and cannot be executed by the phar extension, it is possible to create and manipulate regular zip and tar files using the PharData class even if phar.readonly php.ini setting is 1.

Sınıf Sözdizimi

PharData extends Phar {
/* Yöntemler */
bool addEmptyDir ( string $dirname )
public void Phar::addFile ( string $file [, string $localname ] )
bool addFromString ( string $localname , string $contents )
public array Phar::buildFromDirectory ( string $base_dir [, string $regex ] )
array buildFromIterator ( Iterator $iter [, string $base_directory ] )
object compress ( int $compression [, string $extension ] )
bool compressFiles ( int $compression )
__construct ( string $fname [, int $flags [, string $alias [, int $format = Phar::TAR ]]] )
PharData convertToData ([ int $format [, int $compression [, string $extension ]]] )
Phar convertToExecutable ([ int $format [, int $compression [, string $extension ]]] )
bool copy ( string $oldfile , string $newfile )
object decompress ([ string $extension ] )
bool decompressFiles ( void )
bool delMetadata ( void )
bool delete ( string $entry )
bool extractTo ( string $pathto [, string|array $files [, bool $overwrite = false ]] )
bool isWritable ( void )
void offsetSet ( string $offset , string $value )
bool offsetUnset ( string $offset )
bool setAlias ( string $alias )
bool setDefaultStub ([ string $index [, string $webindex ]] )
public void Phar::setMetadata ( mixed $metadata )
public void Phar::setSignatureAlgorithm ( int $sigtype )
bool setStub ( string $stub [, int $len = -1 ] )
/* Miras alınan yöntemler */
public void Phar::addEmptyDir ( string $dirname )
public void Phar::addFile ( string $file [, string $localname ] )
public void Phar::addFromString ( string $localname , string $contents )
final public static string Phar::apiVersion ( void )
public array Phar::buildFromDirectory ( string $base_dir [, string $regex ] )
public array Phar::buildFromIterator ( Iterator $iter [, string $base_directory ] )
final public static bool Phar::canCompress ([ int $type = 0 ] )
final public static bool Phar::canWrite ( void )
public object Phar::compress ( int $compression [, string $extension ] )
public bool Phar::compressAllFilesBZIP2 ( void )
public bool Phar::compressAllFilesGZ ( void )
public void Phar::compressFiles ( int $compression )
public Phar::__construct ( string $fname [, int $flags [, string $alias ]] )
public PharData Phar::convertToData ([ int $format = 9021976 [, int $compression = 9021976 [, string $extension ]]] )
public Phar Phar::convertToExecutable ([ int $format = 9021976 [, int $compression = 9021976 [, string $extension ]]] )
public bool Phar::copy ( string $oldfile , string $newfile )
public int Phar::count ( void )
final public static string Phar::createDefaultStub ([ string $indexfile [, string $webindexfile ]] )
public object Phar::decompress ([ string $extension ] )
public bool Phar::decompressFiles ( void )
public bool Phar::delMetadata ( void )
public bool Phar::delete ( string $entry )
public bool Phar::extractTo ( string $pathto [, string|array $files [, bool $overwrite = false ]] )
public mixed Phar::getMetadata ( void )
public bool Phar::getModified ( void )
public array Phar::getSignature ( void )
public string Phar::getStub ( void )
final public static array Phar::getSupportedCompression ( void )
final public static array Phar::getSupportedSignatures ( void )
public string Phar::getVersion ( void )
public bool Phar::hasMetadata ( void )
final public static void Phar::interceptFileFuncs ( void )
public bool Phar::isBuffering ( void )
public mixed Phar::isCompressed ( void )
public bool Phar::isFileFormat ( int $format )
final public static bool Phar::isValidPharFilename ( string $filename [, bool $executable = true ] )
public bool Phar::isWritable ( void )
final public static bool Phar::loadPhar ( string $filename [, string $alias ] )
final public static bool Phar::mapPhar ([ string $alias [, int $dataoffset = 0 ]] )
final public static void Phar::mount ( string $pharpath , string $externalpath )
final public static void Phar::mungServer ( array $munglist )
public bool Phar::offsetExists ( string $offset )
public int Phar::offsetGet ( string $offset )
public void Phar::offsetSet ( string $offset , string $value )
public bool Phar::offsetUnset ( string $offset )
final public static string Phar::running ([ bool $retphar = true ] )
public bool Phar::setAlias ( string $alias )
public bool Phar::setDefaultStub ([ string $index [, string $webindex ]] )
public void Phar::setMetadata ( mixed $metadata )
public void Phar::setSignatureAlgorithm ( int $sigtype [, string $privatekey ] )
public bool Phar::setStub ( string $stub [, int $len = -1 ] )
public void Phar::startBuffering ( void )
public void Phar::stopBuffering ( void )
public bool Phar::uncompressAllFiles ( void )
final public static bool Phar::unlinkArchive ( string $archive )
final public static void Phar::webPhar ([ string $alias [, string $index = "index.php" [, string $f404 [, array $mimetypes [, callable $rewrites ]]]]] )
}

İçindekiler

  • PharData::addEmptyDir — Add an empty directory to the tar/zip archive
  • PharData::addFile — Add a file from the filesystem to the tar/zip archive
  • PharData::addFromString — Add a file from the filesystem to the tar/zip archive
  • PharData::buildFromDirectory — Construct a tar/zip archive from the files within a directory.
  • PharData::buildFromIterator — Construct a tar or zip archive from an iterator.
  • PharData::compress — Compresses the entire tar/zip archive using Gzip or Bzip2 compression
  • PharData::compressFiles — Compresses all files in the current tar/zip archive
  • PharData::__construct — Construct a non-executable tar or zip archive object
  • PharData::convertToData — Convert a phar archive to a non-executable tar or zip file
  • PharData::convertToExecutable — Convert a non-executable tar/zip archive to an executable phar archive
  • PharData::copy — Copy a file internal to the phar archive to another new file within the phar
  • PharData::decompress — Decompresses the entire Phar archive
  • PharData::decompressFiles — Decompresses all files in the current zip archive
  • PharData::delMetadata — Deletes the global metadata of a zip archive
  • PharData::delete — Delete a file within a tar/zip archive
  • PharData::extractTo — Extract the contents of a tar/zip archive to a directory
  • PharData::isWritable — Returns true if the tar/zip archive can be modified
  • PharData::offsetSet — set the contents of a file within the tar/zip to those of an external file or string
  • PharData::offsetUnset — remove a file from a tar/zip archive
  • PharData::setAlias — dummy function (Phar::setAlias is not valid for PharData)
  • PharData::setDefaultStub — dummy function (Phar::setDefaultStub is not valid for PharData)
  • Phar::setMetadata — Sets phar archive meta-data
  • Phar::setSignatureAlgorithm — set the signature algorithm for a phar and apply it.
  • PharData::setStub — dummy function (Phar::setStub is not valid for PharData)
Phar::webPhar
PharData::addEmptyDir
Phar


Add an empty directory to the tar/zip archive

PharData
PharData::addFile
PharData
PHP Manual

PharData::addEmptyDir

(PHP >= 5.3.0, PECL phar >= 2.0.0)

PharData::addEmptyDir — Add an empty directory to the tar/zip archive

Açıklama

bool PharData::addEmptyDir ( string $dirname )

With this method, an empty directory is created with path dirname. This method is similar to ZipArchive::addEmptyDir().

Değiştirgeler

dirname

The name of the empty directory to create in the phar archive

Dönen Değerler

no return value, exception is thrown on failure.

Örnekler

Örnek 1 A PharData::addEmptyDir() example

<?php
try {
    $a = new PharData('/path/to/my.tar');

    $a->addEmptyDir('/full/path/to/file');
    // demonstrates how this file is stored
    $b = $a['full/path/to/file']->isDir();
} catch (Exception $e) {
    // handle errors here
}
?>

Ayrıca Bakınız

  • Phar::addEmptyDir() - Add an empty directory to the phar archive
  • PharData::addFile() - Add a file from the filesystem to the tar/zip archive
  • PharData::addFromString() - Add a file from the filesystem to the tar/zip archive

PharData
PharData::addFile
PharData


Add a file from the filesystem to the tar/zip archive

PharData::addEmptyDir
PharData::addFromString
PharData
PHP Manual

PharData::addFile

(PHP >= 5.3.0, PECL phar >= 2.0.0)

PharData::addFile — Add a file from the filesystem to the tar/zip archive

Açıklama

public void Phar::addFile ( string $file [, string $localname ] )

With this method, any file or URL can be added to the tar/zip archive. If the optional second parameter localname is specified, the file will be stored in the archive with that name, otherwise the file parameter is used as the path to store within the archive. URLs must have a localname or an exception is thrown. This method is similar to ZipArchive::addFile().

Değiştirgeler

file

Full or relative path to a file on disk to be added to the phar archive.

localname

Path that the file will be stored in the archive.

Dönen Değerler

no return value, exception is thrown on failure.

Örnekler

Örnek 1 A PharData::addFile() example

<?php
try {
    $a = new PharData('/path/to/my.tar');

    $a->addFile('/full/path/to/file');
    // demonstrates how this file is stored
    $b = $a['full/path/to/file']->getContent();

    $a->addFile('/full/path/to/file', 'my/file.txt');
    $c = $a['my/file.txt']->getContent();

    // demonstrate URL usage
    $a->addFile('http://www.example.com', 'example.html');
} catch (Exception $e) {
    // handle errors here
}
?>

Ayrıca Bakınız

  • PharData::offsetSet() - set the contents of a file within the tar/zip to those of an external file or string
  • Phar::addFile() - Add a file from the filesystem to the phar archive
  • PharData::addFromString() - Add a file from the filesystem to the tar/zip archive
  • PharData::addEmptyDir() - Add an empty directory to the tar/zip archive

PharData::addEmptyDir
PharData::addFromString
PharData


Add a file from the filesystem to the tar/zip archive

PharData::addFile
PharData::buildFromDirectory
PharData
PHP Manual

PharData::addFromString

(PHP >= 5.3.0, PECL phar >= 2.0.0)

PharData::addFromString — Add a file from the filesystem to the tar/zip archive

Açıklama

bool PharData::addFromString ( string $localname , string $contents )

With this method, any string can be added to the tar/zip archive. The file will be stored in the archive with localname as its path. This method is similar to ZipArchive::addFromString().

Değiştirgeler

localname

Path that the file will be stored in the archive.

contents

The file contents to store

Dönen Değerler

no return value, exception is thrown on failure.

Örnekler

Örnek 1 A PharData::addFromString() example

<?php
try {
    $a = new PharData('/path/to/my.tar');

    $a->addFromString('path/to/file.txt', 'my simple file');
    $b = $a['path/to/file.txt']->getContent();

    // to add contents from a stream handle for large files, use offsetSet()
    $c = fopen('/path/to/hugefile.bin');
    $a['largefile.bin'] = $c;
    fclose($c);
} catch (Exception $e) {
    // handle errors here
}
?>

Ayrıca Bakınız

  • PharData::offsetSet() - set the contents of a file within the tar/zip to those of an external file or string
  • Phar::addFromString() - Add a file from a string to the phar archive
  • PharData::addFile() - Add a file from the filesystem to the tar/zip archive
  • PharData::addEmptyDir() - Add an empty directory to the tar/zip archive

PharData::addFile
PharData::buildFromDirectory
PharData


Construct a tar/zip archive from the files within a directory.

PharData::addFromString
PharData::buildFromIterator
PharData
PHP Manual

PharData::buildFromDirectory

(PHP >= 5.3.0, PECL phar >= 2.0.0)

PharData::buildFromDirectory — Construct a tar/zip archive from the files within a directory.

Açıklama

public array Phar::buildFromDirectory ( string $base_dir [, string $regex ] )

Populate a tar/zip archive from directory contents. The optional second parameter is a regular expression (pcre) that is used to exclude files. Any filename that matches the regular expression will be included, all others will be excluded. For more fine-grained control, use PharData::buildFromIterator().

Değiştirgeler

base_dir

The full or relative path to the directory that contains all files to add to the archive.

regex

An optional pcre regular expression that is used to filter the list of files. Only file paths matching the regular expression will be included in the archive.

Dönen Değerler

Phar::buildFromDirectory() returns an associative array mapping internal path of file to the full path of the file on the filesystem.

Hatalar/İstisnalar

This method throws BadMethodCallException when unable to instantiate the internal directory iterators, or a PharException if there were errors saving the phar archive.

Örnekler

Örnek 1 A PharData::buildFromDirectory() example

<?php
$phar = new PharData('project.tar');
// add all files in the project
$phar->buildFromDirectory(dirname(__FILE__) . '/project');

$phar2 = new PharData('project2.zip');
// add all files in the project, only include php files
$phar2->buildFromDirectory(dirname(__FILE__) . '/project', '/\.php$/');
?>

Ayrıca Bakınız

  • Phar::buildFromDirectory() - Construct a phar archive from the files within a directory.
  • PharData::buildFromIterator() - Construct a tar or zip archive from an iterator.

PharData::addFromString
PharData::buildFromIterator
PharData


Construct a tar or zip archive from an iterator.

PharData::buildFromDirectory
PharData::compress
PharData
PHP Manual

PharData::buildFromIterator

(PHP >= 5.3.0, PECL phar >= 2.0.0)

PharData::buildFromIterator — Construct a tar or zip archive from an iterator.

Açıklama

array PharData::buildFromIterator ( Iterator $iter [, string $base_directory ] )

Populate a tar or zip archive from an iterator. Two styles of iterators are supported, iterators that map the filename within the tar/zip to the name of a file on disk, and iterators like DirectoryIterator that return SplFileInfo objects. For iterators that return SplFileInfo objects, the second parameter is required.

Örnekler

Örnek 1 A PharData::buildFromIterator() with SplFileInfo

For most tar/zip archives, the archive will reflect an actual directory layout, and the second style is the most useful. For instance, to create a tar/zip archive containing the files in this sample directory layout:

/path/to/project/
                 config/
                        dist.xml
                        debug.xml
                 lib/
                     file1.php
                     file2.php
                 src/
                     processthing.php
                 www/
                     index.php
                 cli/
                     index.php

This code could be used to add these files to the "project.tar" tar archive:

<?php
$phar = new PharData('project.tar');
$phar->buildFromIterator(
    new RecursiveIteratorIterator(
     new RecursiveDirectoryIterator('/path/to/project')),
    '/path/to/project');
?>

The file project.tar can then be used immediately. PharData::buildFromIterator() does not set values such as compression, metadata, and this can be done after creating the tar/zip archive.

As an interesting note, PharData::buildFromIterator() can also be used to copy the contents of an existing phar, tar or zip archive, as the PharData object descends from DirectoryIterator:

<?php
$phar = new PharData('project.tar');
$phar->buildFromIterator(
    new RecursiveIteratorIterator(
     new Phar('/path/to/anotherphar.phar')),
    'phar:///path/to/anotherphar.phar/path/to/project');
$phar->setStub($phar->createDefaultStub('cli/index.php', 'www/index.php'));
?>

Örnek 2 A PharData::buildFromIterator() with other iterators

The second form of the iterator can be used with any iterator that returns a key => value mapping, such as an ArrayIterator:

<?php
$phar = new PharData('project.tar');
$phar->buildFromIterator(
    new ArrayIterator(
     array(
        'internal/file.php' => dirname(__FILE__) . '/somefile.php',
        'another/file.jpg' => fopen('/path/to/bigfile.jpg', 'rb'),
     )));
?>

Değiştirgeler

iter

Any iterator that either associatively maps tar/zip file to location or returns SplFileInfo objects

base_directory

For iterators that return SplFileInfo objects, the portion of each file's full path to remove when adding to the tar/zip archive

Dönen Değerler

PharData::buildFromIterator() returns an associative array mapping internal path of file to the full path of the file on the filesystem.

Hatalar/İstisnalar

This method returns UnexpectedValueException when the iterator returns incorrect values, such as an integer key instead of a string, a BadMethodCallException when an SplFileInfo-based iterator is passed without a base_directory parameter, or a PharException if there were errors saving the phar archive.

Ayrıca Bakınız

  • Phar::buildFromIterator() - Construct a phar archive from an iterator.

PharData::buildFromDirectory
PharData::compress
PharData


Compresses the entire tar/zip archive using Gzip or Bzip2 compression

PharData::buildFromIterator
PharData::compressFiles
PharData
PHP Manual

PharData::compress

(PHP >= 5.3.0, PECL phar >= 2.0.0)

PharData::compress — Compresses the entire tar/zip archive using Gzip or Bzip2 compression

Açıklama

object PharData::compress ( int $compression [, string $extension ] )

For tar archives, this method compresses the entire archive using gzip compression or bzip2 compression. The resulting file can be processed with the gunzip command/bunzip command, or accessed directly and transparently with the Phar extension.

For zip archives, this method fails with an exception. The zlib extension must be enabled to compress with gzip compression, the bzip2 extension must be enabled in order to compress with bzip2 compression.

In addition, this method automatically renames the archive, appending .gz, .bz2 or removing the extension if passed Phar::NONE to remove compression. Alternatively, a file extension may be specified with the second parameter.

Değiştirgeler

compression

Compression must be one of Phar::GZ, Phar::BZ2 to add compression, or Phar::NONE to remove compression.

extension

By default, the extension is .tar.gz or .tar.bz2 for compressing a tar, and .tar for decompressing.

Dönen Değerler

A PharData object is returned.

Hatalar/İstisnalar

Throws BadMethodCallException if the zlib extension is not available, or the bzip2 extension is not enabled.

Örnekler

Örnek 1 A PharData::compress() example

<?php
$p = new PharData('/path/to/my.tar');
$p['myfile.txt'] = 'hi';
$p['myfile2.txt'] = 'hi';
$p1 = $p->compress(Phar::GZ); // copies to /path/to/my.tar.gz
$p2 = $p->compress(Phar::BZ2); // copies to /path/to/my.tar.bz2
$p3 = $p2->compress(Phar::NONE); // exception: /path/to/my.tar already exists
?>

Ayrıca Bakınız

  • Phar::compress() - Compresses the entire Phar archive using Gzip or Bzip2 compression

PharData::buildFromIterator
PharData::compressFiles
PharData


Compresses all files in the current tar/zip archive

PharData::compress
PharData::__construct
PharData
PHP Manual

PharData::compressFiles

(PHP >= 5.3.0, PECL phar >= 2.0.0)

PharData::compressFiles — Compresses all files in the current tar/zip archive

Açıklama

bool PharData::compressFiles ( int $compression )

For tar-based archives, this method throws a BadMethodCallException, as compression of individual files within a tar archive is not supported by the file format. Use PharData::compress() to compress an entire tar-based archive.

For Zip-based archives, this method compresses all files in the archive using the specified compression. The zlib or bzip2 extensions must be enabled to take advantage of this feature. In addition, if any files are already compressed using bzip2/zlib compression, the respective extension must be enabled in order to decompress the files prior to re-compressing.

Değiştirgeler

compression

Compression must be one of Phar::GZ, Phar::BZ2 to add compression, or Phar::NONE to remove compression.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

Throws BadMethodCallException if the phar.readonly INI variable is on, the zlib extension is not available, or if any files are compressed using bzip2 compression and the bzip2 extension is not enabled.

Örnekler

Örnek 1 A PharData::compressFiles() example

<?php
$p = new Phar('/path/to/my.phar', 0, 'my.phar');
$p['myfile.txt'] = 'hi';
$p['myfile2.txt'] = 'hi';
foreach ($p as $file) {
    var_dump($file->getFileName());
    var_dump($file->isCompressed());
    var_dump($file->isCompressed(Phar::BZ2));
    var_dump($file->isCompressed(Phar::GZ));
}
$p->compressFiles(Phar::GZ);
foreach ($p as $file) {
    var_dump($file->getFileName());
    var_dump($file->isCompressed());
    var_dump($file->isCompressed(Phar::BZ2));
    var_dump($file->isCompressed(Phar::GZ));
}
?>

Yukarıdaki örneğin çıktısı:

string(10) "myfile.txt"
bool(false)
bool(false)
bool(false)
string(11) "myfile2.txt"
bool(false)
bool(false)
bool(false)
string(10) "myfile.txt"
int(4096)
bool(false)
bool(true)
string(11) "myfile2.txt"
int(4096)
bool(false)
bool(true)

Ayrıca Bakınız

  • PharFileInfo::getCompressedSize() - Returns the actual size of the file (with compression) inside the Phar archive
  • PharFileInfo::isCompressed() - Returns whether the entry is compressed
  • PharFileInfo::compress() - Compresses the current Phar entry with either zlib or bzip2 compression
  • PharFileInfo::decompress() - Decompresses the current Phar entry within the phar
  • Phar::canCompress() - Returns whether phar extension supports compression using either zlib or bzip2
  • Phar::isCompressed() - Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)
  • PharData::decompressFiles() - Decompresses all files in the current zip archive
  • Phar::getSupportedCompression() - Return array of supported compression algorithms
  • PharData::compress() - Compresses the entire tar/zip archive using Gzip or Bzip2 compression
  • PharData::decompress() - Decompresses the entire Phar archive

PharData::compress
PharData::__construct
PharData


Construct a non-executable tar or zip archive object

PharData::compressFiles
PharData::convertToData
PharData
PHP Manual

PharData::__construct

(PHP >= 5.3.0, PECL phar >= 2.0.0)

PharData::__construct — Construct a non-executable tar or zip archive object

Açıklama

PharData::__construct ( string $fname [, int $flags [, string $alias [, int $format = Phar::TAR ]]] )

Değiştirgeler

fname

Path to an existing tar/zip archive or to-be-created archive

flags

Flags to pass to Phar parent class RecursiveDirectoryIterator.

alias

Alias with which this Phar archive should be referred to in calls to stream functionality.

format

One of the file format constants available within the Phar class.

Hatalar/İstisnalar

Throws BadMethodCallException if called twice; UnexpectedValueException if the Phar archive can't be opened.

Örnekler

Örnek 1 A PharData::__construct() example

<?php
try {
    $p = new PharData('/path/to/my.tar', Phar::CURRENT_AS_FILEINFO | Phar::KEY_AS_FILENAME);
} catch (UnexpectedValueException $e) {
    die('Could not open my.tar');
} catch (BadMethodCallException $e) {
    echo 'technically, this cannot happen';
}
echo file_get_contents('phar:///path/to/my.tar/example.txt');
?>

PharData::compressFiles
PharData::convertToData
PharData


Convert a phar archive to a non-executable tar or zip file

PharData::__construct
PharData::convertToExecutable
PharData
PHP Manual

PharData::convertToData

(PHP >= 5.3.0, PECL phar >= 2.0.0)

PharData::convertToData — Convert a phar archive to a non-executable tar or zip file

Açıklama

PharData PharData::convertToData ([ int $format [, int $compression [, string $extension ]]] )

This method is used to convert a non-executable tar or zip archive to another non-executable format.

If no changes are specified, this method throws a BadMethodCallException. This method should be used to convert a tar archive to zip format or vice-versa. Although it is possible to simply change the compression of a tar archive using this method, it is better to use the PharData::compress() method for logical consistency.

If successful, the method creates a new archive on disk and returns a PharData object. The old archive is not removed from disk, and should be done manually after the process has finished.

Değiştirgeler

format

This should be one of Phar::TAR or Phar::ZIP. If set to NULL, the existing file format will be preserved.

compression

This should be one of Phar::NONE for no whole-archive compression, Phar::GZ for zlib-based compression, and Phar::BZ2 for bzip-based compression.

extension

This parameter is used to override the default file extension for a converted archive. Note that .phar cannot be used anywhere in the filename for a non-executable tar or zip archive.

If converting to a tar-based phar archive, the default extensions are .tar, .tar.gz, and .tar.bz2 depending on specified compression. For zip-based archives, the default extension is .zip.

Dönen Değerler

The method returns a PharData object on success and throws an exception on failure.

Hatalar/İstisnalar

This method throws BadMethodCallException when unable to compress, an unknown compression method has been specified, the requested archive is buffering with Phar::startBuffering() and has not concluded with Phar::stopBuffering(), and a PharException if any problems are encountered during the phar creation process.

Örnekler

Örnek 1 A PharData::convertToData() example

Using PharData::convertToData():

<?php
try {
    $tarphar = new PharData('myphar.tar');
    // note that myphar.tar is *not* unlinked
    // convert it to the non-executable tar file format
    // creates myphar.zip
    $zip = $tarphar->convertToData(Phar::ZIP);
    // create myphar.tbz
    $tgz = $zip->convertToData(Phar::TAR, Phar::BZ2, '.tbz');
    // creates myphar.phar.tgz
    $phar = $tarphar->convertToData(Phar::PHAR); // throws exception
} catch (Exception $e) {
    // handle the error here
}
?>

Ayrıca Bakınız

  • Phar::convertToExecutable() - Convert a phar archive to another executable phar archive file format
  • Phar::convertToData() - Convert a phar archive to a non-executable tar or zip file
  • PharData::convertToExecutable() - Convert a non-executable tar/zip archive to an executable phar archive

PharData::__construct
PharData::convertToExecutable
PharData


Convert a non-executable tar/zip archive to an executable phar archive

PharData::convertToData
PharData::copy
PharData
PHP Manual

PharData::convertToExecutable

(PHP >= 5.3.0, PECL phar >= 2.0.0)

PharData::convertToExecutable — Convert a non-executable tar/zip archive to an executable phar archive

Açıklama

Phar PharData::convertToExecutable ([ int $format [, int $compression [, string $extension ]]] )

Bilginize:

Phar nesneleri ile çalışmak için, bu yöntem phar.readonly php.ini yönergesine 0 atanmış olmasını gerektirir. Aksi takdirde bir PharException istisnası oluşur.

This method is used to convert a non-executable tar or zip archive to an executable phar archive. Any of the three executable file formats (phar, tar or zip) can be used, and whole-archive compression can also be performed.

If no changes are specified, this method throws a BadMethodCallException.

If successful, the method creates a new archive on disk and returns a Phar object. The old archive is not removed from disk, and should be done manually after the process has finished.

Değiştirgeler

format

This should be one of Phar::PHAR, Phar::TAR, or Phar::ZIP. If set to NULL, the existing file format will be preserved.

compression

This should be one of Phar::NONE for no whole-archive compression, Phar::GZ for zlib-based compression, and Phar::BZ2 for bzip-based compression.

extension

This parameter is used to override the default file extension for a converted archive. Note that all zip- and tar-based phar archives must contain .phar in their file extension in order to be processed as a phar archive.

If converting to a phar-based archive, the default extensions are .phar, .phar.gz, or .phar.bz2 depending on the specified compression. For tar-based phar archives, the default extensions are .phar.tar, .phar.tar.gz, and .phar.tar.bz2. For zip-based phar archives, the default extension is .phar.zip.

Dönen Değerler

The method returns a Phar object on success and throws an exception on failure.

Hatalar/İstisnalar

This method throws BadMethodCallException when unable to compress, an unknown compression method has been specified, the requested archive is buffering with Phar::startBuffering() and has not concluded with Phar::stopBuffering(), an UnexpectedValueException if write support is disabled, and a PharException if any problems are encountered during the phar creation process.

Örnekler

Örnek 1 A PharData::convertToExecutable() example

Using PharData::convertToExecutable():

<?php
try {
    $tarphar = new PharData('myphar.tar');
    // convert it to the phar file format
    // note that myphar.tar is *not* unlinked
    $phar = $tarphar->convertToExecutable(Phar::PHAR); // creates myphar.phar
    $phar->setStub($phar->createDefaultStub('cli.php', 'web/index.php'));
    // creates myphar.phar.tgz
    $compressed = $tarphar->convertToExecutable(Phar::TAR, Phar::GZ, '.phar.tgz');
} catch (Exception $e) {
    // handle the error here
}
?>

Ayrıca Bakınız

  • Phar::convertToExecutable() - Convert a phar archive to another executable phar archive file format
  • Phar::convertToData() - Convert a phar archive to a non-executable tar or zip file
  • PharData::convertToData() - Convert a phar archive to a non-executable tar or zip file

PharData::convertToData
PharData::copy
PharData


Copy a file internal to the phar archive to another new file within the phar

PharData::convertToExecutable
PharData::decompress
PharData
PHP Manual

PharData::copy

(PHP >= 5.3.0, PECL phar >= 2.0.0)

PharData::copy — Copy a file internal to the phar archive to another new file within the phar

Açıklama

bool PharData::copy ( string $oldfile , string $newfile )

Copy a file internal to the tar/zip archive to another new file within the same archive. This is an object-oriented alternative to using copy() with the phar stream wrapper.

Değiştirgeler

oldfile

newfile

Dönen Değerler

returns TRUE on success, but it is safer to encase method call in a try/catch block and assume success if no exception is thrown.

Hatalar/İstisnalar

throws UnexpectedValueException if the source file does not exist, the destination file already exists, write access is disabled, opening either file fails, reading the source file fails, or a PharException if writing the changes to the phar fails.

Örnekler

Örnek 1 A PharData::copy() example

This example shows using PharData::copy() and the equivalent stream wrapper performance of the same thing. The primary difference between the two approaches is error handling. All PharData methods throw exceptions, whereas the stream wrapper uses trigger_error().

<?php
try {
    $phar = new PharData('myphar.tar');
    $phar['a'] = 'hi';
    $phar->copy('a', 'b');
    echo $phar['b']; // outputs "phar://myphar.tar/b"
} catch (Exception $e) {
    // handle error
}

// the stream wrapper equivalent of the above code.
// E_WARNINGS are triggered on error rather than exceptions.
copy('phar://myphar.tar/a', 'phar//myphar.tar/c');
echo file_get_contents('phar://myphar.tar/c'); // outputs "hi"
?>

PharData::convertToExecutable
PharData::decompress
PharData


Decompresses the entire Phar archive

PharData::copy
PharData::decompressFiles
PharData
PHP Manual

PharData::decompress

(PHP >= 5.3.0, PECL phar >= 2.0.0)

PharData::decompress — Decompresses the entire Phar archive

Açıklama

object PharData::decompress ([ string $extension ] )

For tar-based archives, this method decompresses the entire archive.

For Zip-based archives, this method fails with an exception. The zlib extension must be enabled to decompress an archive compressed with gzip compression, and the bzip2 extension must be enabled in order to decompress an archive compressed with bzip2 compression.

In addition, this method automatically renames the file extension of the archive, .tar by default. Alternatively, a file extension may be specified with the second parameter.

Değiştirgeler

extension

For decompressing, the default file extension is .phar.tar. Use this parameter to specify another file extension. Be aware that no non-executable archives cannot contain .phar in their filename.

Dönen Değerler

A PharData object is returned.

Hatalar/İstisnalar

Throws BadMethodCallException if the zlib extension is not available, or the bzip2 extension is not enabled.

Örnekler

Örnek 1 A PharData::decompress() example

<?php
$p = new PharData('/path/to/my.tar.gz');
$p->decompress(); // creates /path/to/my.tar
?>

Ayrıca Bakınız

  • PharFileInfo::getCompressedSize() - Returns the actual size of the file (with compression) inside the Phar archive
  • PharFileInfo::isCompressed() - Returns whether the entry is compressed
  • PharFileInfo::compress() - Compresses the current Phar entry with either zlib or bzip2 compression
  • PharFileInfo::decompress() - Decompresses the current Phar entry within the phar
  • PharData::compress() - Compresses the entire tar/zip archive using Gzip or Bzip2 compression
  • Phar::canCompress() - Returns whether phar extension supports compression using either zlib or bzip2
  • Phar::isCompressed() - Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)
  • PharData::compress() - Compresses the entire tar/zip archive using Gzip or Bzip2 compression
  • Phar::getSupportedCompression() - Return array of supported compression algorithms
  • PharData::compressFiles() - Compresses all files in the current tar/zip archive
  • PharData::decompressFiles() - Decompresses all files in the current zip archive

PharData::copy
PharData::decompressFiles
PharData


Decompresses all files in the current zip archive

PharData::decompress
PharData::delMetadata
PharData
PHP Manual

PharData::decompressFiles

(PHP >= 5.3.0, PECL phar >= 2.0.0)

PharData::decompressFiles — Decompresses all files in the current zip archive

Açıklama

bool PharData::decompressFiles ( void )

Bilginize:

Phar nesneleri ile çalışmak için, bu yöntem phar.readonly php.ini yönergesine 0 atanmış olmasını gerektirir. Aksi takdirde bir PharException istisnası oluşur.

For tar-based archives, this method throws a BadMethodCallException, as compression of individual files within a tar archive is not supported by the file format. Use PharData::compress() to compress an entire tar-based archive.

For Zip-based archives, this method decompresses all files in the archive. The zlib or bzip2 extensions must be enabled to take advantage of this feature if any files are compressed using bzip2/zlib compression.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

Throws BadMethodCallException if the zlib extension is not available, or if any files are compressed using bzip2 compression and the bzip2 extension is not enabled.

Örnekler

Örnek 1 A PharData::decompressFiles() example

<?php
$p = new PharData('/path/to/my.zip');
$p['myfile.txt'] = 'hi';
$p['myfile2.txt'] = 'hi';
$p->compressFiles(Phar::GZ);
foreach ($p as $file) {
    var_dump($file->getFileName());
    var_dump($file->isCompressed());
    var_dump($file->isCompressed(Phar::BZ2));
    var_dump($file->isCompressed(Phar::GZ));
}
$p->decompressFiles();
foreach ($p as $file) {
    var_dump($file->getFileName());
    var_dump($file->isCompressed());
    var_dump($file->isCompressed(Phar::BZ2));
    var_dump($file->isCompressed(Phar::GZ));
}
?>

Yukarıdaki örneğin çıktısı:

string(10) "myfile.txt"
int(4096)
bool(false)
bool(true)
string(11) "myfile2.txt"
int(4096)
bool(false)
bool(true)
string(10) "myfile.txt"
bool(false)
bool(false)
bool(false)
string(11) "myfile2.txt"
bool(false)
bool(false)
bool(false)

Ayrıca Bakınız

  • PharFileInfo::getCompressedSize() - Returns the actual size of the file (with compression) inside the Phar archive
  • PharFileInfo::isCompressed() - Returns whether the entry is compressed
  • PharFileInfo::compress() - Compresses the current Phar entry with either zlib or bzip2 compression
  • PharFileInfo::decompress() - Decompresses the current Phar entry within the phar
  • Phar::canCompress() - Returns whether phar extension supports compression using either zlib or bzip2
  • Phar::isCompressed() - Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)
  • PharData::compressFiles() - Compresses all files in the current tar/zip archive
  • Phar::getSupportedCompression() - Return array of supported compression algorithms
  • PharData::compress() - Compresses the entire tar/zip archive using Gzip or Bzip2 compression
  • PharData::decompress() - Decompresses the entire Phar archive

PharData::decompress
PharData::delMetadata
PharData


Deletes the global metadata of a zip archive

PharData::decompressFiles
PharData::delete
PharData
PHP Manual

PharData::delMetadata

(PHP >= 5.3.0, PECL phar >= 2.0.0)

PharData::delMetadata — Deletes the global metadata of a zip archive

Açıklama

bool PharData::delMetadata ( void )

Bilginize:

Phar nesneleri ile çalışmak için, bu yöntem phar.readonly php.ini yönergesine 0 atanmış olmasını gerektirir. Aksi takdirde bir PharException istisnası oluşur.

Deletes the global metadata of the zip archive

Değiştirgeler

Dönen Değerler

returns TRUE on success, but it is better to check for thrown exception, and assume success if none is thrown.

Hatalar/İstisnalar

Throws PharException if errors occur while flushing changes to disk.

Örnekler

Örnek 1 A PharData::delMetaData() example

<?php
try {
    $phar = new PharData('myphar.zip');
    var_dump($phar->getMetadata());
    $phar->setMetadata("hi there");
    var_dump($phar->getMetadata());
    $phar->delMetadata();
    var_dump($phar->getMetadata());
} catch (Exception $e) {
    // handle errors
}
?>

Yukarıdaki örneğin çıktısı:

NULL
string(8) "hi there"
NULL

Ayrıca Bakınız

  • Phar::delMetadata() - Deletes the global metadata of the phar

PharData::decompressFiles
PharData::delete
PharData


Delete a file within a tar/zip archive

PharData::delMetadata
PharData::extractTo
PharData
PHP Manual

PharData::delete

(PHP >= 5.3.0, PECL phar >= 2.0.0)

PharData::delete — Delete a file within a tar/zip archive

Açıklama

bool PharData::delete ( string $entry )

Delete a file within an archive. This is the functional equivalent of calling unlink() on the stream wrapper equivalent, as shown in the example below.

Değiştirgeler

entry

Path within an archive to the file to delete.

Dönen Değerler

returns TRUE on success, but it is better to check for thrown exception, and assume success if none is thrown.

Hatalar/İstisnalar

Throws PharException if errors occur while flushing changes to disk.

Örnekler

Örnek 1 A PharData::delete() example

<?php
try {
    $phar = new PharData('myphar.zip');
    $phar->delete('unlink/me.php');
    // this is equivalent to:
    unlink('phar://myphar.phar/unlink/me.php');
} catch (Exception $e) {
    // handle errors
}
?>

Ayrıca Bakınız

  • Phar::delete() - Delete a file within a phar archive

PharData::delMetadata
PharData::extractTo
PharData


Extract the contents of a tar/zip archive to a directory

PharData::delete
PharData::isWritable
PharData
PHP Manual

PharData::extractTo

(PHP >= 5.3.0, PECL phar >= 2.0.0)

PharData::extractTo — Extract the contents of a tar/zip archive to a directory

Açıklama

bool PharData::extractTo ( string $pathto [, string|array $files [, bool $overwrite = false ]] )

Extract all files within a tar/zip archive to disk. Extracted files and directories preserve permissions as stored in the archive. The optional parameters allow optional control over which files are extracted, and whether existing files on disk can be overwritten. The second parameter files can be either the name of a file or directory to extract, or an array of names of files and directories to extract. By default, this method will not overwrite existing files, the third parameter can be set to true to enable overwriting of files. This method is similar to ZipArchive::extractTo().

Değiştirgeler

pathto

Path to extract the given files to

files

The name of a file or directory to extract, or an array of files/directories to extract

overwrite

Set to TRUE to enable overwriting existing files

Dönen Değerler

returns TRUE on success, but it is better to check for thrown exception, and assume success if none is thrown.

Hatalar/İstisnalar

Throws PharException if errors occur while flushing changes to disk.

Örnekler

Örnek 1 A PharData::extractTo() example

<?php
try {
    $phar = new PharData('myphar.tar');
    $phar->extractTo('/full/path'); // extract all files
    $phar->extractTo('/another/path', 'file.txt'); // extract only file.txt
    $phar->extractTo('/this/path',
        array('file1.txt', 'file2.txt')); // extract 2 files only
    $phar->extractTo('/third/path', null, true); // extract all files, and overwrite
} catch (Exception $e) {
    // handle errors
}
?>

Ayrıca Bakınız

  • Phar::extractTo() - Extract the contents of a phar archive to a directory

PharData::delete
PharData::isWritable
PharData


Returns true if the tar/zip archive can be modified

PharData::extractTo
PharData::offsetSet
PharData
PHP Manual

PharData::isWritable

(PHP >= 5.3.0, PECL phar >= 2.0.0)

PharData::isWritable — Returns true if the tar/zip archive can be modified

Açıklama

bool PharData::isWritable ( void )

This method returns TRUE if the tar/zip archive on disk is not read-only. Unlike Phar::isWritable(), data-only tar/zip archives can be modified even if phar.readonly is set to 1.

Değiştirgeler

No parameters.

Dönen Değerler

Returns TRUE if the tar/zip archive can be modified

Ayrıca Bakınız

  • Phar::canWrite() - Returns whether phar extension supports writing and creating phars
  • Phar::isWritable() - Returns true if the phar archive can be modified

PharData::extractTo
PharData::offsetSet
PharData


set the contents of a file within the tar/zip to those of an external file or string

PharData::isWritable
PharData::offsetUnset
PharData
PHP Manual

PharData::offsetSet

(PHP >= 5.3.0, PECL phar >= 2.0.0)

PharData::offsetSet — set the contents of a file within the tar/zip to those of an external file or string

Açıklama

void PharData::offsetSet ( string $offset , string $value )

This is an implementation of the ArrayAccess interface allowing direct manipulation of the contents of a tar/zip archive using array access brackets. offsetSet is used for modifying an existing file, or adding a new file to a tar/zip archive.

Değiştirgeler

offset

The filename (relative path) to modify in a tar or zip archive.

value

Content of the file.

Dönen Değerler

No return values.

Hatalar/İstisnalar

Throws PharException if there are any problems flushing changes made to the tar/zip archive to disk.

Örnekler

Örnek 1 A PharData::offsetSet() example

offsetSet should not be accessed directly, but instead used via array access with the [] operator.

<?php
$p = new PharData('/path/to/my.tar');
try {
    // calls offsetSet
    $p['file.txt'] = 'Hi there';
} catch (Exception $e) {
    echo 'Could not modify file.txt:', $e;
}
?>

Ayrıca Bakınız

  • Phar::offsetSet() - set the contents of an internal file to those of an external file

PharData::isWritable
PharData::offsetUnset
PharData


remove a file from a tar/zip archive

PharData::offsetSet
PharData::setAlias
PharData
PHP Manual

PharData::offsetUnset

(PHP >= 5.3.0, PECL phar >= 2.0.0)

PharData::offsetUnset — remove a file from a tar/zip archive

Açıklama

bool PharData::offsetUnset ( string $offset )

This is an implementation of the ArrayAccess interface allowing direct manipulation of the contents of a tar/zip archive using array access brackets. offsetUnset is used for deleting an existing file, and is called by the unset() language construct.

Değiştirgeler

offset

The filename (relative path) to modify in the tar/zip archive.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

Throws PharException if there are any problems flushing changes made to the tar/zip archive to disk.

Örnekler

Örnek 1 A PharData::offsetUnset() example

<?php
$p = new PharData('/path/to/my.zip');
try {
    // deletes file.txt from my.zip by calling offsetUnset
    unset($p['file.txt']);
} catch (Exception $e) {
    echo 'Could not delete file.txt: ', $e;
}
?>

Ayrıca Bakınız

  • Phar::offsetUnset() - remove a file from a phar

PharData::offsetSet
PharData::setAlias
PharData


dummy function (Phar::setAlias is not valid for PharData)

PharData::offsetUnset
PharData::setDefaultStub
PharData
PHP Manual

PharData::setAlias

(PHP >= 5.3.0, PECL phar >= 2.0.0)

PharData::setAlias — dummy function (Phar::setAlias is not valid for PharData)

Açıklama

bool PharData::setAlias ( string $alias )

Non-executable tar/zip archives cannot have an alias, so this method simply throws an exception.

Değiştirgeler

alias

A shorthand string that this archive can be referred to in phar stream wrapper access. This parameter is ignored.

Dönen Değerler

Hatalar/İstisnalar

Throws PharException on all method calls

Ayrıca Bakınız

  • Phar::setAlias() - Set the alias for the Phar archive

PharData::offsetUnset
PharData::setDefaultStub
PharData


dummy function (Phar::setDefaultStub is not valid for PharData)

PharData::setAlias
Phar::setMetadata
PharData
PHP Manual

PharData::setDefaultStub

(PHP >= 5.3.0, PECL phar >= 2.0.0)

PharData::setDefaultStub — dummy function (Phar::setDefaultStub is not valid for PharData)

Açıklama

bool PharData::setDefaultStub ([ string $index [, string $webindex ]] )

Non-executable tar/zip archives cannot have a stub, so this method simply throws an exception.

Değiştirgeler

index

Relative path within the phar archive to run if accessed on the command-line

webindex

Relative path within the phar archive to run if accessed through a web browser

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

Throws PharException on all method calls

Ayrıca Bakınız

  • Phar::setDefaultStub() - Used to set the PHP loader or bootstrap stub of a Phar archive to the default loader

PharData::setAlias
Phar::setMetadata
PharData


Sets phar archive meta-data

PharData::setDefaultStub
Phar::setSignatureAlgorithm
PharData
PHP Manual

Phar::setMetadata

(PHP >= 5.3.0, PECL phar >= 1.0.0)

Phar::setMetadata — Sets phar archive meta-data

Açıklama

public void Phar::setMetadata ( mixed $metadata )

Bilginize:

Phar nesneleri ile çalışmak için, bu yöntem phar.readonly php.ini yönergesine 0 atanmış olmasını gerektirir. Aksi takdirde bir PharException istisnası oluşur.

Phar::setMetadata() should be used to store customized data that describes something about the phar archive as a complete entity. PharFileInfo::setMetadata() should be used for file-specific meta-data. Meta-data can slow down the performance of loading a phar archive if the data is large.

Some possible uses for meta-data include specifying which file within the archive should be used to bootstrap the archive, or the location of a file manifest like » PEAR's package.xml file. However, any useful data that describes the phar archive may be stored.

Değiştirgeler

metadata

Any PHP variable containing information to store that describes the phar archive

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 A Phar::setMetadata() example

<?php
// make sure it doesn't exist
@unlink('brandnewphar.phar');
try {
    $p = new Phar(dirname(__FILE__) . '/brandnewphar.phar', 0, 'brandnewphar.phar');
    $p['file.php'] = '<?php echo "hello"';
    $p->setMetadata(array('bootstrap' => 'file.php'));
    var_dump($p->getMetadata());
} catch (Exception $e) {
    echo 'Could not create and/or modify phar:', $e;
}
?>

Yukarıdaki örneğin çıktısı:

array(1) {
  ["bootstrap"]=>
  string(8) "file.php"
}

Ayrıca Bakınız

  • Phar::getMetadata() - Returns phar archive meta-data
  • Phar::delMetadata() - Deletes the global metadata of the phar
  • Phar::hasMetadata() - Returns whether phar has global meta-data

PharData::setDefaultStub
Phar::setSignatureAlgorithm
PharData


set the signature algorithm for a phar and apply it.

Phar::setMetadata
PharData::setStub
PharData
PHP Manual

Phar::setSignatureAlgorithm

(PHP >= 5.3.0, PECL phar >= 1.1.0)

Phar::setSignatureAlgorithm — set the signature algorithm for a phar and apply it.

Açıklama

public void Phar::setSignatureAlgorithm ( int $sigtype )

Bilginize:

Phar nesneleri ile çalışmak için, bu yöntem phar.readonly php.ini yönergesine 0 atanmış olmasını gerektirir. Aksi takdirde bir PharException istisnası oluşur.

Set the signature algorithm for a phar and apply it. The signature algorithm must be one of Phar::MD5, Phar::SHA1, Phar::SHA256, Phar::SHA512, or Phar::PGP (pgp not yet supported and falls back to SHA-1).

Değiştirgeler

sigtype

    One of Phar::MD5,
Phar::SHA1, Phar::SHA256,
Phar::SHA512, or Phar::PGP

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

Throws UnexpectedValueException for many errors, BadMethodCallException if called for a zip- or a tar-based phar archive, and a PharException if any problems occur flushing changes to disk.

Ayrıca Bakınız

  • Phar::getSupportedSignatures() - Return array of supported signature types
  • Phar::getSignature() - Return MD5/SHA1/SHA256/SHA512/OpenSSL signature of a Phar archive

Phar::setMetadata
PharData::setStub
PharData


dummy function (Phar::setStub is not valid for PharData)

Phar::setSignatureAlgorithm
PharFileInfo
PharData
PHP Manual

PharData::setStub

(PHP >= 5.3.0, PECL phar >= 2.0.0)

PharData::setStub — dummy function (Phar::setStub is not valid for PharData)

Açıklama

bool PharData::setStub ( string $stub [, int $len = -1 ] )

Non-executable tar/zip archives cannot have a stub, so this method simply throws an exception.

Değiştirgeler

stub

A string or an open stream handle to use as the executable stub for this phar archive. This parameter is ignored.

len

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

Throws PharException on all method calls

Sürüm Bilgisi

Sürüm: | Açıklama
5.4.0 | Added len parameter.

Ayrıca Bakınız

  • Phar::setStub() - Used to set the PHP loader or bootstrap stub of a Phar archive

Phar::setSignatureAlgorithm
PharFileInfo
PharData


The PharFileInfo class

(PHP >= 5.3.0, PECL phar >= 1.0.0)

Giriş

The PharFileInfo class provides a high-level interface to the contents and attributes of a single file within a phar archive.

Sınıf Sözdizimi

PharFileInfo extends SplFileInfo {
/* Yöntemler */
public void chmod ( int $permissions )
public bool compress ( int $compression )
public __construct ( string $entry )
public bool decompress ( void )
public bool delMetadata ( void )
public int getCRC32 ( void )
public int getCompressedSize ( void )
public mixed getMetadata ( void )
public int getPharFlags ( void )
public bool hasMetadata ( void )
public bool isCRCChecked ( void )
public bool isCompressed ([ int $compression_type = 9021976 ] )
public bool isCompressedBZIP2 ( void )
public bool isCompressedGZ ( void )
public bool setCompressedBZIP2 ( void )
public bool setCompressedGZ ( void )
public void setMetadata ( mixed $metadata )
public bool setUncompressed ( void )
}

İçindekiler

  • PharFileInfo::chmod — Sets file-specific permission bits
  • PharFileInfo::compress — Compresses the current Phar entry with either zlib or bzip2 compression
  • PharFileInfo::__construct — Construct a Phar entry object
  • PharFileInfo::decompress — Decompresses the current Phar entry within the phar
  • PharFileInfo::delMetadata — Deletes the metadata of the entry
  • PharFileInfo::getCRC32 — Returns CRC32 code or throws an exception if CRC has not been verified
  • PharFileInfo::getCompressedSize — Returns the actual size of the file (with compression) inside the Phar archive
  • PharFileInfo::getMetadata — Returns file-specific meta-data saved with a file
  • PharFileInfo::getPharFlags — Returns the Phar file entry flags
  • PharFileInfo::hasMetadata — Returns the metadata of the entry
  • PharFileInfo::isCRCChecked — Returns whether file entry has had its CRC verified
  • PharFileInfo::isCompressed — Returns whether the entry is compressed
  • PharFileInfo::isCompressedBZIP2 — Returns whether the entry is compressed using bzip2
  • PharFileInfo::isCompressedGZ — Returns whether the entry is compressed using gz
  • PharFileInfo::setCompressedBZIP2 — Compresses the current Phar entry within the phar using Bzip2 compression
  • PharFileInfo::setCompressedGZ — Compresses the current Phar entry within the phar using gz compression
  • PharFileInfo::setMetadata — Sets file-specific meta-data saved with a file
  • PharFileInfo::setUncompressed — Uncompresses the current Phar entry within the phar, if it is compressed
PharData::setStub
PharFileInfo::chmod
Phar


Sets file-specific permission bits

PharFileInfo
PharFileInfo::compress
PharFileInfo
PHP Manual

PharFileInfo::chmod

(PHP >= 5.3.0, PECL phar >= 1.0.0)

PharFileInfo::chmod — Sets file-specific permission bits

Açıklama

public void PharFileInfo::chmod ( int $permissions )

PharFileInfo::chmod() allows setting of the executable file permissions bit, as well as read-only bits. Writeable bits are ignored, and set at runtime based on the phar.readonly INI variable. As with all functionality that modifies the contents of a phar, the phar.readonly INI variable must be off in order to succeed if the file is within a Phar archive. Files within PharData archives do not have this restriction.

Değiştirgeler

permissions

permissions (see chmod())

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 A PharFileInfo::chmod() example

<?php
// make sure it doesn't exist
@unlink('brandnewphar.phar');
try {
    $p = new Phar('brandnewphar.phar', 0, 'brandnewphar.phar');
    $p['file.sh'] = '#!/usr/local/lib/php
    <?php echo "hi"; ?>';
    // set executable bit
    $p['file.sh']->chmod(0555);
    var_dump($p['file.sh']->isExecutable());
} catch (Exception $e) {
    echo 'Could not create/modify phar: ', $e;
}
?>

Yukarıdaki örneğin çıktısı:

bool(true)

PharFileInfo
PharFileInfo::compress
PharFileInfo


Compresses the current Phar entry with either zlib or bzip2 compression

PharFileInfo::chmod
PharFileInfo::__construct
PharFileInfo
PHP Manual

PharFileInfo::compress

(PHP >= 5.3.0, PECL phar >= 2.0.0)

PharFileInfo::compress — Compresses the current Phar entry with either zlib or bzip2 compression

Açıklama

public bool PharFileInfo::compress ( int $compression )

This method compresses the file inside the Phar archive using either bzip2 compression or zlib compression. The bzip2 or zlib extension must be enabled to take advantage of this feature. In addition, if the file is already compressed, the respective extension must be enabled in order to decompress the file. As with all functionality that modifies the contents of a phar, the phar.readonly INI variable must be off in order to succeed if the file is within a Phar archive. Files within PharData archives do not have this restriction.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

Throws BadMethodCallException if the phar.readonly INI variable is on, or if the bzip2/zlib extension is not available.

Örnekler

Örnek 1 A PharFileInfo::compress() example

<?php
try {
    $p = new Phar('/path/to/my.phar', 0, 'my.phar');
    $p['myfile.txt'] = 'hi';
    $file = $p['myfile.txt'];
    var_dump($file->isCompressed(Phar::BZ2));
    $p['myfile.txt']->compress(Phar::BZ2);
    var_dump($file->isCompressed(Phar::BZ2));
} catch (Exception $e) {
    echo 'Create/modify operations on my.phar failed: ', $e;
}
?>

Yukarıdaki örneğin çıktısı:

bool(false)
bool(true)

Ayrıca Bakınız

  • PharFileInfo::getCompressedSize() - Returns the actual size of the file (with compression) inside the Phar archive
  • PharFileInfo::isCompressed() - Returns whether the entry is compressed
  • PharFileInfo::decompress() - Decompresses the current Phar entry within the phar
  • Phar::canCompress() - Returns whether phar extension supports compression using either zlib or bzip2
  • Phar::isCompressed() - Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)
  • Phar::compressFiles() - Compresses all files in the current Phar archive
  • Phar::decompressFiles() - Decompresses all files in the current Phar archive
  • Phar::compress() - Compresses the entire Phar archive using Gzip or Bzip2 compression
  • Phar::decompress() - Decompresses the entire Phar archive
  • Phar::getSupportedCompression() - Return array of supported compression algorithms

PharFileInfo::chmod
PharFileInfo::__construct
PharFileInfo


Construct a Phar entry object

PharFileInfo::compress
PharFileInfo::decompress
PharFileInfo
PHP Manual

PharFileInfo::__construct

(PHP >= 5.3.0, PECL phar >= 1.0.0)

PharFileInfo::__construct — Construct a Phar entry object

Açıklama

public PharFileInfo::__construct ( string $entry )

This should not be called directly. Instead, a PharFileInfo object is initialized by calling Phar::offsetGet() through array access.

Değiştirgeler

entry

The full url to retrieve a file. If you wish to retrieve the information for the file my/file.php from the phar boo.phar, the entry should be phar://boo.phar/my/file.php.

Hatalar/İstisnalar

Throws BadMethodCallException if __construct() is called twice. Throws UnexpectedValueException if the phar URL requested is malformed, the requested phar cannot be opened, or the file can't be found within the phar.

Örnekler

Örnek 1 A PharFileInfo::__construct() example

<?php
try {
    $p = new Phar('/path/to/my.phar', 0, 'my.phar');
    $p['testfile.txt'] = "hi\nthere\ndude";
    $file = $p['testfile.txt'];
    foreach ($file as $line => $text) {
        echo "line number $line: $text";
    }
    // this also works
    $file = new PharFileInfo('phar:///path/to/my.phar/testfile.txt');
    foreach ($file as $line => $text) {
        echo "line number $line: $text";
    }
} catch (Exception $e) {
    echo 'Phar operations failed: ', $e;
}
?>

Yukarıdaki örneğin çıktısı:

line number 1: hi
line number 2: there
line number 3: dude
line number 1: hi
line number 2: there
line number 3: dude

PharFileInfo::compress
PharFileInfo::decompress
PharFileInfo


Decompresses the current Phar entry within the phar

PharFileInfo::__construct
PharFileInfo::delMetadata
PharFileInfo
PHP Manual

PharFileInfo::decompress

(PHP >= 5.3.0, PECL phar >= 2.0.0)

PharFileInfo::decompress — Decompresses the current Phar entry within the phar

Açıklama

public bool PharFileInfo::decompress ( void )

This method decompresses the file inside the Phar archive. Depending on how the file is compressed, the bzip2 or zlib extensions must be enabled to take advantage of this feature. As with all functionality that modifies the contents of a phar, the phar.readonly INI variable must be off in order to succeed if the file is within a Phar archive. Files within PharData archives do not have this restriction.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

Throws BadMethodCallException if the phar.readonly INI variable is on, or if the bzip2/zlib extension is not available.

Örnekler

Örnek 1 A PharFileInfo::decompress() example

<?php
try {
    $p = new Phar('/path/to/my.phar', 0, 'my.phar');
    $p['myfile.txt'] = 'hi';
    $file = $p['myfile.txt'];
    $file->compress(Phar::GZ);
    var_dump($file->isCompressed());
    $p['myfile.txt']->decompress();
    var_dump($file->isCompressed());
} catch (Exception $e) {
    echo 'Create/modify failed for my.phar: ', $e;
}
?>

Yukarıdaki örneğin çıktısı:

int(4096)
bool(false)

Ayrıca Bakınız

  • PharFileInfo::getCompressedSize() - Returns the actual size of the file (with compression) inside the Phar archive
  • PharFileInfo::isCompressed() - Returns whether the entry is compressed
  • PharFileInfo::compress() - Compresses the current Phar entry with either zlib or bzip2 compression
  • Phar::canCompress() - Returns whether phar extension supports compression using either zlib or bzip2
  • Phar::isCompressed() - Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)
  • Phar::compressFiles() - Compresses all files in the current Phar archive
  • Phar::decompressFiles() - Decompresses all files in the current Phar archive
  • Phar::compress() - Compresses the entire Phar archive using Gzip or Bzip2 compression
  • Phar::decompress() - Decompresses the entire Phar archive
  • Phar::getSupportedCompression() - Return array of supported compression algorithms

PharFileInfo::__construct
PharFileInfo::delMetadata
PharFileInfo


Deletes the metadata of the entry

PharFileInfo::decompress
PharFileInfo::getCRC32
PharFileInfo
PHP Manual

PharFileInfo::delMetadata

(PHP >= 5.3.0, PECL phar >= 1.2.0)

PharFileInfo::delMetadata — Deletes the metadata of the entry

Açıklama

public bool PharFileInfo::delMetadata ( void )

Deletes the metadata of the entry, if any.

Değiştirgeler

No parameters.

Dönen Değerler

Returns TRUE if successful, FALSE if the entry had no metadata. As with all functionality that modifies the contents of a phar, the phar.readonly INI variable must be off in order to succeed if the file is within a Phar archive. Files within PharData archives do not have this restriction.

Hatalar/İstisnalar

Throws PharException if errors occurred while flushing changes to disk, and BadMethodCallException if write access is disabled.

Örnekler

Örnek 1 A PharFileInfo::delMetaData() example

<?php
try {
    $a = new Phar('myphar.phar');
    $a['hi'] = 'hi';
    var_dump($a['hi']->delMetadata());
    $a['hi']->setMetadata('there');
    var_dump($a['hi']->delMetadata());
    var_dump($a['hi']->delMetadata());
} catch (Exception $e) {
    // handle errors
}
?>

Yukarıdaki örneğin çıktısı:

bool(false)
bool(true)
bool(false)

Ayrıca Bakınız

  • PharFileInfo::setMetadata() - Sets file-specific meta-data saved with a file
  • PharFileInfo::hasMetadata() - Returns the metadata of the entry
  • PharFileInfo::getMetadata() - Returns file-specific meta-data saved with a file
  • Phar::setMetadata() - Sets phar archive meta-data
  • Phar::hasMetadata() - Returns whether phar has global meta-data
  • Phar::getMetadata() - Returns phar archive meta-data

PharFileInfo::decompress
PharFileInfo::getCRC32
PharFileInfo


Returns CRC32 code or throws an exception if CRC has not been verified

PharFileInfo::delMetadata
PharFileInfo::getCompressedSize
PharFileInfo
PHP Manual

PharFileInfo::getCRC32

(PHP >= 5.3.0, PECL phar >= 1.0.0)

PharFileInfo::getCRC32 — Returns CRC32 code or throws an exception if CRC has not been verified

Açıklama

public int PharFileInfo::getCRC32 ( void )

This returns the crc32() checksum of the file within the Phar archive.

Dönen Değerler

The crc32() checksum of the file within the Phar archive.

Hatalar/İstisnalar

Throws BadMethodCallException if the file has not yet had its CRC32 verified. This should be impossible with normal use, as the CRC is verified upon opening the file for reading or writing.

Örnekler

Örnek 1 A PharFileInfo::getCRC32() example

<?php
try {
    $p = new Phar('/path/to/my.phar', 0, 'my.phar');
    $p['myfile.txt'] = 'hi';
    $file = $p['myfile.txt'];
    echo $file->getCRC32();
} catch (Exception $e) {
    echo 'Write operations on my.phar.phar failed: ', $e;
}
?>

Yukarıdaki örneğin çıktısı:

3633523372

PharFileInfo::delMetadata
PharFileInfo::getCompressedSize
PharFileInfo


Returns the actual size of the file (with compression) inside the Phar archive

PharFileInfo::getCRC32
PharFileInfo::getMetadata
PharFileInfo
PHP Manual

PharFileInfo::getCompressedSize

(PHP >= 5.3.0, PECL phar >= 1.0.0)

PharFileInfo::getCompressedSize — Returns the actual size of the file (with compression) inside the Phar archive

Açıklama

public int PharFileInfo::getCompressedSize ( void )

This returns the size of the file within the Phar archive. Uncompressed files will return the same value for getCompressedSize as they will with filesize()

Dönen Değerler

The size in bytes of the file within the Phar archive on disk.

Örnekler

Örnek 1 A PharFileInfo::getCompressedSize() example

<?php
try {
    $p = new Phar('/path/to/my.phar', 0, 'my.phar');
    $p['myfile.txt'] = 'hi';
    $file = $p['myfile.txt'];
    echo $file->getCompressedSize();
} catch (Exception $e) {
    echo 'Write operations failed on my.phar: ', $e;
}
?>

Yukarıdaki örneğin çıktısı:

2

Ayrıca Bakınız

  • PharFileInfo::isCompressed() - Returns whether the entry is compressed
  • PharFileInfo::decompress() - Decompresses the current Phar entry within the phar
  • PharFileInfo::compress() - Compresses the current Phar entry with either zlib or bzip2 compression
  • Phar::canCompress() - Returns whether phar extension supports compression using either zlib or bzip2
  • Phar::isCompressed() - Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)
  • Phar::compress() - Compresses the entire Phar archive using Gzip or Bzip2 compression
  • Phar::decompress() - Decompresses the entire Phar archive
  • Phar::getSupportedCompression() - Return array of supported compression algorithms
  • Phar::decompressFiles() - Decompresses all files in the current Phar archive
  • Phar::compressFiles() - Compresses all files in the current Phar archive

PharFileInfo::getCRC32
PharFileInfo::getMetadata
PharFileInfo


Returns file-specific meta-data saved with a file

PharFileInfo::getCompressedSize
PharFileInfo::getPharFlags
PharFileInfo
PHP Manual

PharFileInfo::getMetadata

(PHP >= 5.3.0, PECL phar >= 1.0.0)

PharFileInfo::getMetadata — Returns file-specific meta-data saved with a file

Açıklama

public mixed PharFileInfo::getMetadata ( void )

Return meta-data that was saved in the Phar archive's manifest for this file.

Değiştirgeler

Dönen Değerler

any PHP variable that can be serialized and is stored as meta-data for the file, or NULL if no meta-data is stored.

Örnekler

Örnek 1 A PharFileInfo::getMetadata() example

<?php
// make sure it doesn't exist
@unlink('brandnewphar.phar');
try {
    $p = new Phar(dirname(__FILE__) . '/brandnewphar.phar', 0, 'brandnewphar.phar');
    $p['file.txt'] = 'hello';
    $p['file.txt']->setMetadata(array('user' => 'bill', 'mime-type' => 'text/plain'));
    var_dump($p['file.txt']->getMetadata());
} catch (Exception $e) {
    echo 'Could not create/modify brandnewphar.phar: ', $e;
}
?>

Yukarıdaki örneğin çıktısı:

array(2) {
  ["user"]=>
  string(4) "bill"
  ["mime-type"]=>
  string(10) "text/plain"
}

Ayrıca Bakınız

  • PharFileInfo::setMetadata() - Sets file-specific meta-data saved with a file
  • PharFileInfo::hasMetadata() - Returns the metadata of the entry
  • PharFileInfo::delMetadata() - Deletes the metadata of the entry
  • Phar::setMetadata() - Sets phar archive meta-data
  • Phar::hasMetadata() - Returns whether phar has global meta-data
  • Phar::getMetadata() - Returns phar archive meta-data

PharFileInfo::getCompressedSize
PharFileInfo::getPharFlags
PharFileInfo


Returns the Phar file entry flags

PharFileInfo::getMetadata
PharFileInfo::hasMetadata
PharFileInfo
PHP Manual

PharFileInfo::getPharFlags

(PHP >= 5.3.0, PECL phar >= 1.0.0)

PharFileInfo::getPharFlags — Returns the Phar file entry flags

Açıklama

public int PharFileInfo::getPharFlags ( void )

This returns the flags set in the manifest for a Phar. This will always return 0 in the current implementation.

Dönen Değerler

The Phar flags (always 0 in the current implementation)

Örnekler

Örnek 1 A PharFileInfo::getPharFlags() example

<?php
try {
    $p = new Phar('/path/to/my.phar', 0, 'my.phar');
    $p['myfile.txt'] = 'hi';
    $file = $p['myfile.txt'];
    var_dump($file->getPharFlags());
} catch (Exception $e) {
    echo 'Could not create/modify my.phar: ', $e;
}
?>

Yukarıdaki örneğin çıktısı:

int(0)

PharFileInfo::getMetadata
PharFileInfo::hasMetadata
PharFileInfo


Returns the metadata of the entry

PharFileInfo::getPharFlags
PharFileInfo::isCRCChecked
PharFileInfo
PHP Manual

PharFileInfo::hasMetadata

(PHP >= 5.3.0, PECL phar >= 1.2.0)

PharFileInfo::hasMetadata — Returns the metadata of the entry

Açıklama

public bool PharFileInfo::hasMetadata ( void )

Returns the metadata of a file within a phar archive.

Değiştirgeler

No parameters.

Dönen Değerler

Returns FALSE if no metadata is set or is NULL, TRUE if metadata is not NULL

Ayrıca Bakınız

  • PharFileInfo::setMetadata() - Sets file-specific meta-data saved with a file
  • PharFileInfo::getMetadata() - Returns file-specific meta-data saved with a file
  • PharFileInfo::delMetadata() - Deletes the metadata of the entry
  • Phar::setMetadata() - Sets phar archive meta-data
  • Phar::hasMetadata() - Returns whether phar has global meta-data
  • Phar::getMetadata() - Returns phar archive meta-data

PharFileInfo::getPharFlags
PharFileInfo::isCRCChecked
PharFileInfo


Returns whether file entry has had its CRC verified

PharFileInfo::hasMetadata
PharFileInfo::isCompressed
PharFileInfo
PHP Manual

PharFileInfo::isCRCChecked

(PHP >= 5.3.0, PECL phar >= 1.0.0)

PharFileInfo::isCRCChecked — Returns whether file entry has had its CRC verified

Açıklama

public bool PharFileInfo::isCRCChecked ( void )

This returns whether a file within a Phar archive has had its CRC verified.

Dönen Değerler

TRUE if the file has had its CRC verified, FALSE if not.

Örnekler

Örnek 1 A PharFileInfo::isCRCChecked() example

<?php
try {
    $p = new Phar('/path/to/my.phar', 0, 'my.phar');
    $p['myfile.txt'] = 'hi';
    $file = $p['myfile.txt'];
    var_dump($file->isCRCChecked());
} catch (Exception $e) {
    echo 'Create/modify operations failed on my.phar: ', $e;
}
?>

Yukarıdaki örneğin çıktısı:

bool(true)

PharFileInfo::hasMetadata
PharFileInfo::isCompressed
PharFileInfo


Returns whether the entry is compressed

PharFileInfo::isCRCChecked
PharFileInfo::isCompressedBZIP2
PharFileInfo
PHP Manual

PharFileInfo::isCompressed

(PHP >= 5.3.0, PECL phar >= 1.0.0)

PharFileInfo::isCompressed — Returns whether the entry is compressed

Açıklama

public bool PharFileInfo::isCompressed ([ int $compression_type = 9021976 ] )

This returns whether a file is compressed within a Phar archive with either Gzip or Bzip2 compression.

Değiştirgeler

compression_type

One of Phar::GZ or Phar::BZ2, defaults to any compression.

Dönen Değerler

TRUE if the file is compressed within the Phar archive, FALSE if not.

Örnekler

Örnek 1 A PharFileInfo::isCompressed() example

<?php
try {
    $p = new Phar('/path/to/my.phar', 0, 'my.phar');
    $p['myfile.txt'] = 'hi';
    $p['myfile2.txt'] = 'hi';
    $p['myfile2.txt']->setCompressedGZ();
    $file = $p['myfile.txt'];
    $file2 = $p['myfile2.txt'];
    var_dump($file->isCompressed());
    var_dump($file2->isCompressed());
} catch (Exception $e) {
    echo 'Create/modify on phar my.phar failed: ', $e;
}
?>

Yukarıdaki örneğin çıktısı:

bool(false)
bool(true)

Ayrıca Bakınız

  • PharFileInfo::getCompressedSize() - Returns the actual size of the file (with compression) inside the Phar archive
  • PharFileInfo::decompress() - Decompresses the current Phar entry within the phar
  • PharFileInfo::compress() - Compresses the current Phar entry with either zlib or bzip2 compression
  • Phar::decompress() - Decompresses the entire Phar archive
  • Phar::compress() - Compresses the entire Phar archive using Gzip or Bzip2 compression
  • Phar::canCompress() - Returns whether phar extension supports compression using either zlib or bzip2
  • Phar::isCompressed() - Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)
  • Phar::getSupportedCompression() - Return array of supported compression algorithms
  • Phar::decompressFiles() - Decompresses all files in the current Phar archive
  • Phar::compressFiles() - Compresses all files in the current Phar archive

PharFileInfo::isCRCChecked
PharFileInfo::isCompressedBZIP2
PharFileInfo


Returns whether the entry is compressed using bzip2

PharFileInfo::isCompressed
PharFileInfo::isCompressedGZ
PharFileInfo
PHP Manual

PharFileInfo::isCompressedBZIP2

(PHP >= 5.3.0, PECL phar >= 1.0.0)

PharFileInfo::isCompressedBZIP2 — Returns whether the entry is compressed using bzip2

Açıklama

public bool PharFileInfo::isCompressedBZIP2 ( void )

Bilginize:

Bu yöntem Phar eklentisinin 2.0.0
sürümünde kaldırıldı. Yerine PharFileInfo::isCompressed(),
PharFileInfo::decompress() ve
PharFileInfo::compress() kullanılabilir.

This returns whether a file is compressed within a Phar archive with Bzip2 compression.

Dönen Değerler

TRUE if the file is compressed within the Phar archive using Bzip2, FALSE if not.

Örnekler

Örnek 1 A PharFileInfo::isCompressedBZIP2() example

<?php
try {
    $p = new Phar('/path/to/my.phar', 0, 'my.phar');
    $p['myfile.txt'] = 'hi';
    $p['myfile2.txt'] = 'hi';
    $p['myfile3.txt'] = 'hi';
    $p['myfile2.txt']->setCompressedGZ();
    $p['myfile3.txt']->setCompressedBZIP2();
    $file = $p['myfile.txt'];
    $file2 = $p['myfile2.txt'];
    $file3 = $p['myfile3.txt'];
    var_dump($file->isCompressedBZIP2());
    var_dump($file2->isCompressedBZIP2());
    var_dump($file3->isCompressedBZIP2());
} catch (Exception $e) {
    echo 'Create/modify on phar my.phar failed: ', $e;
}
?>

Yukarıdaki örneğin çıktısı:

bool(false)
bool(false)
bool(true)

Ayrıca Bakınız

  • PharFileInfo::getCompressedSize() - Returns the actual size of the file (with compression) inside the Phar archive
  • PharFileInfo::isCompressed() - Returns whether the entry is compressed
  • PharFileInfo::isCompressedGZ() - Returns whether the entry is compressed using gz
  • PharFileInfo::setCompressedBZIP2() - Compresses the current Phar entry within the phar using Bzip2 compression
  • PharFileInfo::setUncompressed() - Uncompresses the current Phar entry within the phar, if it is compressed
  • PharFileInfo::setCompressedGZ() - Compresses the current Phar entry within the phar using gz compression
  • Phar::canCompress() - Returns whether phar extension supports compression using either zlib or bzip2
  • Phar::isCompressed() - Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)
  • Phar::compressAllFilesBZIP2() - Compresses all files in the current Phar archive using Bzip2 compression
  • Phar::compressAllFilesGZ() - Compresses all files in the current Phar archive using Gzip compression
  • Phar::getSupportedCompression() - Return array of supported compression algorithms
  • Phar::uncompressAllFiles() - Uncompresses all files in the current Phar archive

PharFileInfo::isCompressed
PharFileInfo::isCompressedGZ
PharFileInfo


Returns whether the entry is compressed using gz

PharFileInfo::isCompressedBZIP2
PharFileInfo::setCompressedBZIP2
PharFileInfo
PHP Manual

PharFileInfo::isCompressedGZ

(PHP >= 5.3.0, PECL phar >= 1.0.0)

PharFileInfo::isCompressedGZ — Returns whether the entry is compressed using gz

Açıklama

public bool PharFileInfo::isCompressedGZ ( void )

Bilginize:

Bu yöntem Phar eklentisinin 2.0.0
sürümünde kaldırıldı. Yerine PharFileInfo::isCompressed(),
PharFileInfo::decompress() ve
PharFileInfo::compress() kullanılabilir.

This returns whether a file is compressed within a Phar archive with Gzip compression.

Dönen Değerler

TRUE if the file is compressed within the Phar archive using Gzip, FALSE if not.

Örnekler

Örnek 1 A PharFileInfo::isCompressedGZ() example

<?php
try {
    $p = new Phar('/path/to/my.phar', 0, 'my.phar');
    $p['myfile.txt'] = 'hi';
    $p['myfile2.txt'] = 'hi';
    $p['myfile3.txt'] = 'hi';
    $p['myfile2.txt']->setCompressedGZ();
    $p['myfile3.txt']->setCompressedBZIP2();
    $file = $p['myfile.txt'];
    $file2 = $p['myfile2.txt'];
    $file3 = $p['myfile3.txt'];
    var_dump($file->isCompressedGZ());
    var_dump($file2->isCompressedGZ());
    var_dump($file3->isCompressedGZ());
} catch (Exception $e) {
    echo 'Create/modify on phar my.phar failed: ', $e;
}
?>

Yukarıdaki örneğin çıktısı:

bool(false)
bool(true)
bool(false)

Ayrıca Bakınız

  • PharFileInfo::getCompressedSize() - Returns the actual size of the file (with compression) inside the Phar archive
  • PharFileInfo::isCompressedBZIP2() - Returns whether the entry is compressed using bzip2
  • PharFileInfo::isCompressed() - Returns whether the entry is compressed
  • PharFileInfo::setCompressedBZIP2() - Compresses the current Phar entry within the phar using Bzip2 compression
  • PharFileInfo::setUncompressed() - Uncompresses the current Phar entry within the phar, if it is compressed
  • PharFileInfo::setCompressedGZ() - Compresses the current Phar entry within the phar using gz compression
  • Phar::canCompress() - Returns whether phar extension supports compression using either zlib or bzip2
  • Phar::isCompressed() - Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)
  • Phar::compressAllFilesBZIP2() - Compresses all files in the current Phar archive using Bzip2 compression
  • Phar::compressAllFilesGZ() - Compresses all files in the current Phar archive using Gzip compression
  • Phar::getSupportedCompression() - Return array of supported compression algorithms
  • Phar::uncompressAllFiles() - Uncompresses all files in the current Phar archive

PharFileInfo::isCompressedBZIP2
PharFileInfo::setCompressedBZIP2
PharFileInfo


Compresses the current Phar entry within the phar using Bzip2 compression

PharFileInfo::isCompressedGZ
PharFileInfo::setCompressedGZ
PharFileInfo
PHP Manual

PharFileInfo::setCompressedBZIP2

(PHP >= 5.3.0, PECL phar >= 1.0.0)

PharFileInfo::setCompressedBZIP2 — Compresses the current Phar entry within the phar using Bzip2 compression

Açıklama

public bool PharFileInfo::setCompressedBZIP2 ( void )

Bilginize:

Bu yöntem Phar eklentisinin 2.0.0
sürümünde kaldırıldı. Yerine PharFileInfo::isCompressed(),
PharFileInfo::decompress() ve
PharFileInfo::compress() kullanılabilir.

This method compresses the file inside the Phar archive using bzip2 compression. The bzip2 extension must be enabled to take advantage of this feature. In addition, if the file is already compressed using gzip compression, the zlib extension must be enabled in order to decompress the file. As with all functionality that modifies the contents of a phar, the phar.readonly INI variable must be off in order to succeed.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

Throws BadMethodCallException if the phar.readonly INI variable is on, or if the bzip2 extension is not available.

Örnekler

Örnek 1 A PharFileInfo::setCompressedBZIP2() example

<?php
try {
    $p = new Phar('/path/to/my.phar', 0, 'my.phar');
    $p['myfile.txt'] = 'hi';
    $file = $p['myfile.txt'];
    var_dump($file->isCompressedBZIP2());
    $p['myfile.txt']->setCompressedBZIP2();
    var_dump($file->isCompressedBZIP2());
} catch (Exception $e) {
    echo 'Create/modify operations on my.phar failed: ', $e;
}
?>

Yukarıdaki örneğin çıktısı:

bool(false)
bool(true)

Ayrıca Bakınız

  • PharFileInfo::getCompressedSize() - Returns the actual size of the file (with compression) inside the Phar archive
  • PharFileInfo::isCompressedBZIP2() - Returns whether the entry is compressed using bzip2
  • PharFileInfo::isCompressed() - Returns whether the entry is compressed
  • PharFileInfo::isCompressedGZ() - Returns whether the entry is compressed using gz
  • PharFileInfo::setUncompressed() - Uncompresses the current Phar entry within the phar, if it is compressed
  • PharFileInfo::setCompressedGZ() - Compresses the current Phar entry within the phar using gz compression
  • Phar::canCompress() - Returns whether phar extension supports compression using either zlib or bzip2
  • Phar::isCompressed() - Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)
  • Phar::compressAllFilesBZIP2() - Compresses all files in the current Phar archive using Bzip2 compression
  • Phar::compressAllFilesGZ() - Compresses all files in the current Phar archive using Gzip compression
  • Phar::getSupportedCompression() - Return array of supported compression algorithms
  • Phar::uncompressAllFiles() - Uncompresses all files in the current Phar archive

PharFileInfo::isCompressedGZ
PharFileInfo::setCompressedGZ
PharFileInfo


Compresses the current Phar entry within the phar using gz compression

PharFileInfo::setCompressedBZIP2
PharFileInfo::setMetadata
PharFileInfo
PHP Manual

PharFileInfo::setCompressedGZ

(PHP >= 5.3.0, PECL phar >= 1.0.0)

PharFileInfo::setCompressedGZ — Compresses the current Phar entry within the phar using gz compression

Açıklama

public bool PharFileInfo::setCompressedGZ ( void )

Bilginize:

Bu yöntem Phar eklentisinin 2.0.0
sürümünde kaldırıldı. Yerine PharFileInfo::isCompressed(),
PharFileInfo::decompress() ve
PharFileInfo::compress() kullanılabilir.

This method compresses the file inside the Phar archive using gzip compression. The zlib extension must be enabled to take advantage of this feature. In addition, if the file is already compressed using bzip2 compression, the bzip2 extension must be enabled in order to decompress the file. As with all functionality that modifies the contents of a phar, the phar.readonly INI variable must be off in order to succeed.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

Throws BadMethodCallException if the phar.readonly INI variable is on, or if the zlib extension is not available.

Örnekler

Örnek 1 A PharFileInfo::setCompressedGZ() example

<?php
try {
    $p = new Phar('/path/to/my.phar', 0, 'my.phar');
    $p['myfile.txt'] = 'hi';
    $file = $p['myfile.txt'];
    var_dump($file->isCompressedGZ());
    $p['myfile.txt']->setCompressedGZ();
    var_dump($file->isCompressedGZ());
} catch (Exception $e) {
    echo 'Create/modify operations on my.phar failed: ', $e;
}
?>

Yukarıdaki örneğin çıktısı:

bool(false)
bool(true)

Ayrıca Bakınız

  • PharFileInfo::getCompressedSize() - Returns the actual size of the file (with compression) inside the Phar archive
  • PharFileInfo::isCompressedBZIP2() - Returns whether the entry is compressed using bzip2
  • PharFileInfo::isCompressed() - Returns whether the entry is compressed
  • PharFileInfo::isCompressedGZ() - Returns whether the entry is compressed using gz
  • PharFileInfo::setCompressedBZIP2() - Compresses the current Phar entry within the phar using Bzip2 compression
  • PharFileInfo::setUncompressed() - Uncompresses the current Phar entry within the phar, if it is compressed
  • Phar::canCompress() - Returns whether phar extension supports compression using either zlib or bzip2
  • Phar::isCompressed() - Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)
  • Phar::compressAllFilesBZIP2() - Compresses all files in the current Phar archive using Bzip2 compression
  • Phar::compressAllFilesGZ() - Compresses all files in the current Phar archive using Gzip compression
  • Phar::getSupportedCompression() - Return array of supported compression algorithms
  • Phar::uncompressAllFiles() - Uncompresses all files in the current Phar archive

PharFileInfo::setCompressedBZIP2
PharFileInfo::setMetadata
PharFileInfo


Sets file-specific meta-data saved with a file

PharFileInfo::setCompressedGZ
PharFileInfo::setUncompressed
PharFileInfo
PHP Manual

PharFileInfo::setMetadata

(PHP >= 5.3.0, PECL phar >= 1.0.0)

PharFileInfo::setMetadata — Sets file-specific meta-data saved with a file

Açıklama

public void PharFileInfo::setMetadata ( mixed $metadata )

PharFileInfo::setMetadata() should only be used to store customized data in a file that cannot be represented with existing information stored with a file. Meta-data can significantly slow down the performance of loading a phar archive if the data is large, or if there are many files containing meta-data. It is important to note that file permissions are natively supported inside a phar; it is possible to set them with the PharFileInfo::chmod() method. As with all functionality that modifies the contents of a phar, the phar.readonly INI variable must be off in order to succeed if the file is within a Phar archive. Files within PharData archives do not have this restriction.

Some possible uses for meta-data include passing a user/group that should be set when a file is extracted from the phar to disk. Other uses could include explicitly specifying a MIME type to return. However, any useful data that describes a file, but should not be contained inside of it may be stored.

Değiştirgeler

metadata

Any PHP variable containing information to store alongside a file

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 A PharFileInfo::setMetadata() example

<?php
// make sure it doesn't exist
@unlink('brandnewphar.phar');
try {
    $p = new Phar(dirname(__FILE__) . '/brandnewphar.phar', 0, 'brandnewphar.phar');
    $p['file.txt'] = 'hello';
    $p['file.txt']->setMetadata(array('user' => 'bill', 'mime-type' => 'text/plain'));
    var_dump($p['file.txt']->getMetaData());
} catch (Exception $e) {
    echo 'Could not create/modify phar: ', $e;
}
?>

Yukarıdaki örneğin çıktısı:

array(2) {
  ["user"]=>
  string(4) "bill"
  ["mime-type"]=>
  string(10) "text/plain"
}

Ayrıca Bakınız

  • PharFileInfo::hasMetadata() - Returns the metadata of the entry
  • PharFileInfo::getMetadata() - Returns file-specific meta-data saved with a file
  • PharFileInfo::delMetadata() - Deletes the metadata of the entry
  • Phar::setMetadata() - Sets phar archive meta-data
  • Phar::hasMetadata() - Returns whether phar has global meta-data
  • Phar::getMetadata() - Returns phar archive meta-data

PharFileInfo::setCompressedGZ
PharFileInfo::setUncompressed
PharFileInfo


Uncompresses the current Phar entry within the phar, if it is compressed

PharFileInfo::setMetadata
PharException
PharFileInfo
PHP Manual

PharFileInfo::setUncompressed

(PHP >= 5.3.0, PECL phar >= 1.0.0)

PharFileInfo::setUncompressed — Uncompresses the current Phar entry within the phar, if it is compressed

Açıklama

public bool PharFileInfo::setUncompressed ( void )

Bilginize:

Bu yöntem Phar eklentisinin 2.0.0
sürümünde kaldırıldı. Yerine PharFileInfo::isCompressed(),
PharFileInfo::decompress() ve
PharFileInfo::compress() kullanılabilir.

This method decompresses the file inside the Phar archive. Depending on how the file is compressed, the bzip2 or zlib extensions must be enabled to take advantage of this feature. As with all functionality that modifies the contents of a phar, the phar.readonly INI variable must be off in order to succeed.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

Throws BadMethodCallException if the phar.readonly INI variable is on, or if the bzip2/zlib extension is not available.

Örnekler

Örnek 1 A PharFileInfo::setUncompressed() example

<?php
try {
    $p = new Phar('/path/to/my.phar', 0, 'my.phar');
    $p['myfile.txt'] = 'hi';
    $file = $p['myfile.txt'];
    $file->setCompressedGZ();
    var_dump($file->isCompressed());
    $p['myfile.txt']->setUncompressed();
    var_dump($file->isCompressed());
} catch (Exception $e) {
    echo 'Create/modify failed for my.phar: ', $e;
}
?>

Yukarıdaki örneğin çıktısı:

bool(true)
bool(false)

Ayrıca Bakınız

  • PharFileInfo::getCompressedSize() - Returns the actual size of the file (with compression) inside the Phar archive
  • PharFileInfo::isCompressedBZIP2() - Returns whether the entry is compressed using bzip2
  • PharFileInfo::isCompressed() - Returns whether the entry is compressed
  • PharFileInfo::isCompressedGZ() - Returns whether the entry is compressed using gz
  • PharFileInfo::setCompressedBZIP2() - Compresses the current Phar entry within the phar using Bzip2 compression
  • PharFileInfo::setCompressedGZ() - Compresses the current Phar entry within the phar using gz compression
  • Phar::canCompress() - Returns whether phar extension supports compression using either zlib or bzip2
  • Phar::isCompressed() - Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)
  • Phar::compressAllFilesBZIP2() - Compresses all files in the current Phar archive using Bzip2 compression
  • Phar::compressAllFilesGZ() - Compresses all files in the current Phar archive using Gzip compression
  • Phar::getSupportedCompression() - Return array of supported compression algorithms
  • Phar::uncompressAllFiles() - Uncompresses all files in the current Phar archive

PharFileInfo::setMetadata
PharException
PharFileInfo


The PharException class

(Unknown)

Giriş

The PharException class provides a phar-specific exception class for try/catch blocks.

Sınıf Sözdizimi

PharException extends Exception {
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}

İçindekiler

  • PharException — The PharException class provides a phar-specific exception class for try/catch blocks.
PharFileInfo::setUncompressed
PharException
Phar


The PharException class provides a phar-specific exception class for try/catch blocks.

PharException
Rar
PharException
PHP Manual

PharException

(Unknown)

PharException — The PharException class provides a phar-specific exception class for try/catch blocks.

Açıklama

PharException
Rar
PharException
PHP Manual


Rar Archiving

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
  • Rar İşlevleri
    • rar_wrapper_cache_stats — Cache hits and misses for the URL wrapper
  • RarArchive — The RarArchive class
    • RarArchive::close — Close RAR archive and free all resources
    • RarArchive::getComment — Get comment text from the RAR archive
    • RarArchive::getEntries — Get full list of entries from the RAR archive
    • RarArchive::getEntry — Get entry object from the RAR archive
    • RarArchive::isBroken — Test whether an archive is broken (incomplete)
    • RarArchive::isSolid — Check whether the RAR archive is solid
    • RarArchive::open — Open RAR archive
    • RarArchive::setAllowBroken — Whether opening broken archives is allowed
    • RarArchive::__toString — Get text representation
  • RarEntry — The RarEntry class
    • RarEntry::extract — Extract entry from the archive
    • RarEntry::getAttr — Get attributes of the entry
    • RarEntry::getCrc — Get CRC of the entry
    • RarEntry::getFileTime — Get entry last modification time
    • RarEntry::getHostOs — Get entry host OS
    • RarEntry::getMethod — Get pack method of the entry
    • RarEntry::getName — Get name of the entry
    • RarEntry::getPackedSize — Get packed size of the entry
    • RarEntry::getStream — Get file handler for entry
    • RarEntry::getUnpackedSize — Get unpacked size of the entry
    • RarEntry::getVersion — Get minimum version of RAR program required to unpack the entry
    • RarEntry::isDirectory — Test whether an entry represents a directory
    • RarEntry::isEncrypted — Test whether an entry is encrypted
    • RarEntry::__toString — Get text representation of entry
  • RarException — The RarException class
    • RarException::isUsingExceptions — Check whether error handling with exceptions is in use
    • RarException::setUsingExceptions — Activate and deactivate error handling with exceptions
PharException
Giriş
Sıkıştırma ve Arşivleme Eklentileri


Giriş

Rar is a powerful and effective archiver created by Eugene Roshal. This extension gives you possibility to read Rar archives but doesn't support writing Rar archives, because this is not supported by the UnRar library and is directly prohibited by its license.

More information about Rar and UnRar can be found at » http://www.rarlabs.com/.

Rar
Yapılandırma/Kurulum
Rar


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Rar


Kurulum

Rar is currently available through PECL » http://pecl.php.net/package/rar.

Also you can use the PECL installer to install the Rar extension, using the following command: pecl -v install rar.

You can always download the tar.gz package and install Rar by hand:

Örnek 1 Rar installation

gunzip rar-xxx.tgz
tar -xvf rar-xxx.tar
cd rar-xxx
phpize
./configure && make && make install

Windows users will enable php_rar.dll inside of php.ini in order to use these functions. Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Özkaynak Türleri

This extension registers three internal classes: The archive representations returned by rar_open() - RarArchive -, the entry representations returned by rar_list() and rar_entry_get() - RarEntry and the exception type RarException.

This extension also register a stream resource, called "rar" and a URL wrapper called "rar wrapper" and registered under the prefix "rar".

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

RAR_HOST_MSDOS (integer)
Use RarEntry::HOST_MSDOS instead.
RAR_HOST_OS2 (integer)
Use RarEntry::HOST_OS2 instead.
RAR_HOST_WIN32 (integer)
Use RarEntry::HOST_WIN32 instead.
RAR_HOST_UNIX (integer)
Use RarEntry::HOST_UNIX instead.
RAR_HOST_BEOS (integer)
Use RarEntry::HOST_BEOS instead.
Özkaynak Türleri
Örnekler
Rar


Örnekler

See also the examples under rar:// wrapper.

Örnek 1 On-the-fly decompression

<?php

if (!array_key_exists("i", $_GET) || !is_numeric($_GET["i"]))
    die("Index unspecified or non-numeric");
$index = (int) $_GET["i"];

$arch = RarArchive::open("example.rar");
if ($arch === FALSE)
    die("Cannot open example.rar");

$entries = $arch->getEntries();
if ($entries === FALSE)
    die("Cannot retrieve entries");

if (!array_key_exists($index, $entries))
    die("No such index: $index");

$orfilename = $entries[$index]->getName(); //UTF-8 encoded

$filesize = $entries[$index]->getUnpackedSize();

/* you could check HTTP_IF_MODIFIED_SINCE here and compare with
 * $entries[$index]->getFileTime(). You could also send a
 * "Last modified" header */

$fp = $entries[$index]->getStream();
if ($fp === FALSE)
    die("Cannot open file with index $index insided the archive.");

$arch->close(); //no longer needed; stream is independent

function detectUserAgent() {
    if (!array_key_exists('HTTP_USER_AGENT', $_SERVER))
        return "Other";

    $uas = $_SERVER['HTTP_USER_AGENT'];
    if (preg_match("@Opera/@", $uas))
        return "Opera";
    if (preg_match("@Firefox/@", $uas))
        return "Firefox";
    if (preg_match("@Chrome/@", $uas))
        return "Chrome";
    if (preg_match("@MSIE ([0-9.]+);@", $uas, $matches)) {
        if (((float)$matches[1]) >= 7.0)
            return "IE";
    }

    return "Other";
}

/*
 * We have 3 options:
 * - For FF and Opera, which support RFC 2231, use that format.
 * - For IE and Chrome, use attwithfnrawpctenclong
 *   (http://greenbytes.de/tech/tc2231/#attwithfnrawpctenclong)
 * - For the others, convert to ISO-8859-1, if possible
 */
$formatRFC2231 = 'Content-Disposition: attachment; filename*=UTF-8\'\'%s';
$formatDef = 'Content-Disposition: attachment; filename="%s"';

switch (detectUserAgent()) {
    case "Opera":
    case "Firefox":
        $orfilename = rawurlencode($orfilename);
        $format = $formatRFC2231;
        break;

    case "IE":
    case "Chrome":
        $orfilename = rawurlencode($orfilename);
        $format = $formatDef;
        break;
    default:
        if (function_exists('iconv'))
            $orfilename =
                @iconv("UTF-8", "ISO-8859-1//TRANSLIT", $orfilename);
        $format = $formatDef;
}

header(sprintf($format, $orfilename));
//cannot send error messages from now on (headers already sent)

//replace by real content type, perhaps infering from the file extension
$contentType = "application/octet-stream";
header("Content-Type: $contentType");

header("Content-Transfer-Encoding: binary");

header("Content-Length: $filesize");

if ($_SERVER['REQUEST_METHOD'] == "HEAD")
    die();

while (!feof($fp)) {
    $s = @fread($fp, 8192);
    if ($s === false)
        break; //useless to send error messages

    echo $s;
}
?>

This example opens a RAR file and presents the requested file inside the RAR archive for download to the client.

Örnek 2 RAR extension filesystem extraction example

<?php

$rar_file = rar_open('example.rar') or die("Can't open Rar archive");

$entries = rar_list($rar_file);

foreach ($entries as $entry) {
    echo 'Filename: ' . $entry->getName() . "\n";
    echo 'Packed size: ' . $entry->getPackedSize() . "\n";
    echo 'Unpacked size: ' . $entry->getUnpackedSize() . "\n";

    $entry->extract('/dir/extract/to/');
}

rar_close($rar_file);

?>

This example opens a RAR file archive and extracts each entry to the specified directory.

Öntanımlı Sabitler
Rar İşlevleri
Rar


Rar İşlevleri

İçindekiler

  • rar_wrapper_cache_stats — Cache hits and misses for the URL wrapper
Örnekler
rar_wrapper_cache_stats
Rar


Cache hits and misses for the URL wrapper

Rar İşlevleri
RarArchive
Rar İşlevleri
PHP Manual

rar_wrapper_cache_stats

(PECL rar >= 3.0.0)

rar_wrapper_cache_stats — Cache hits and misses for the URL wrapper

Açıklama

string rar_wrapper_cache_stats ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Rar İşlevleri
RarArchive
Rar İşlevleri


The RarArchive class

(PECL rar >= 2.0.0)

Giriş

This class represents a RAR archive, which may be formed by several volumes (parts) and which contains a number of RAR entries (i.e., files, directories and other special objects such as symbolic links).

Objects of this class can be traversed, yielding the entries stored in the respective RAR archive. Those entries can also be obtained through RarArchive::getEntry() and RarArchive::getEntries().

Sınıf Sözdizimi

final RarArchive implements Traversable {
/* Yöntemler */
public bool close ( void )
public string getComment ( void )
public array getEntries ( void )
public RarEntry getEntry ( string $entryname )
public bool isBroken ( void )
public bool isSolid ( void )
public static RarArchive open ( string $filename [, string $password = NULL [, callable $volume_callback = NULL ]] )
public bool setAllowBroken ( bool $allow_broken )
public string __toString ( void )
}

İçindekiler

  • RarArchive::close — Close RAR archive and free all resources
  • RarArchive::getComment — Get comment text from the RAR archive
  • RarArchive::getEntries — Get full list of entries from the RAR archive
  • RarArchive::getEntry — Get entry object from the RAR archive
  • RarArchive::isBroken — Test whether an archive is broken (incomplete)
  • RarArchive::isSolid — Check whether the RAR archive is solid
  • RarArchive::open — Open RAR archive
  • RarArchive::setAllowBroken — Whether opening broken archives is allowed
  • RarArchive::__toString — Get text representation
rar_wrapper_cache_stats
RarArchive::close
Rar


Close RAR archive and free all resources

RarArchive
RarArchive::getComment
RarArchive
PHP Manual

RarArchive::close

rar_close

(PECL rar >= 2.0.0)

RarArchive::close -- rar_close — Close RAR archive and free all resources

Açıklama

Nesne yönelimli kullanım (method):

public bool RarArchive::close ( void )

Yordamsal kullanım:

bool rar_close ( RarArchive $rarfile )

Close RAR archive and free all allocated resources.

Değiştirgeler

rarfile

A RarArchive object, opened with rar_open().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
2.0.0 | The RAR entries returned by RarArchive::getEntry() and RarArchive::getEntries() are now invalidated when calling this method. This means that all instance methods called for such entries and not guaranteed to succeed.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$rar_arch = RarArchive::open('latest_winrar.rar');
echo $rar_arch."\n";
$rar_arch->close();
echo $rar_arch."\n";
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

RAR Archive "D:\php_rar\trunk\tests\latest_winrar.rar"
RAR Archive "D:\php_rar\trunk\tests\latest_winrar.rar" (closed)

Örnek 2 Yordamsal kullanım

<?php
$rar_arch = rar_open('latest_winrar.rar');
echo $rar_arch."\n";
rar_close($rar_arch);
echo $rar_arch."\n";
?>

RarArchive
RarArchive::getComment
RarArchive


Get comment text from the RAR archive

RarArchive::close
RarArchive::getEntries
RarArchive
PHP Manual

RarArchive::getComment

rar_comment_get

(PECL rar >= 2.0.0)

RarArchive::getComment -- rar_comment_get — Get comment text from the RAR archive

Açıklama

Nesne yönelimli kullanım (method):

public string RarArchive::getComment ( void )

Yordamsal kullanım:

string rar_comment_get ( RarArchive $rarfile )

Get the (global) comment stored in the RAR archive. It may be up to 64 KiB long.

Bilginize:

This extension does not support comments at the entry level.

Değiştirgeler

rarfile

A RarArchive object, opened with rar_open().

Dönen Değerler

Returns the comment or NULL if there is none.

Bilginize:

RAR has currently no support for unicode comments. The encoding of the result of this function is not specified, but it will probably be Windows-1252.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$rar_arch = RarArchive::open('commented.rar');
echo $rar_arch->getComment();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

This is the comment of the file commented.rar.

Örnek 2 Yordamsal kullanım

<?php
$rar_arch = rar_open('commented.rar');
echo rar_comment_get($rar_arch);
?>

RarArchive::close
RarArchive::getEntries
RarArchive


Get full list of entries from the RAR archive

RarArchive::getComment
RarArchive::getEntry
RarArchive
PHP Manual

RarArchive::getEntries

rar_list

(PECL rar >= 2.0.0)

RarArchive::getEntries -- rar_list — Get full list of entries from the RAR archive

Açıklama

Nesne yönelimli kullanım (method):

public array RarArchive::getEntries ( void )

Yordamsal kullanım:

array rar_list ( RarArchive $rarfile )

Get entries list (files and directories) from the RAR archive.

Bilginize:

If the archive has entries with the same name, this method, together with RarArchive foreach iteration and array-like access with numeric indexes, are the only ones to access all the entries (i.e., RarArchive::getEntry() and the rar:// wrapper are insufficient).

Değiştirgeler

rarfile

A RarArchive object, opened with rar_open().

Dönen Değerler

rar_list() returns array of RarEntry objects başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
3.0.0 | Support for RAR archives with repeated entry names is no longer defective.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$rar_arch = RarArchive::open('solid.rar');
if ($rar_arch === FALSE)
    die("Could not open RAR archive.");

$rar_entries = $rar_arch->getEntries();
if ($rar_entries === FALSE)
    die("Could not retrieve entries.");

echo "Found " . count($rar_entries) . " entries.\n";

foreach ($rar_entries as $e) {
    echo $e;
    echo "\n";
}
$rar_arch->close();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Found 2 entries.
RarEntry for file "tese.txt" (23b93a7a)
RarEntry for file "unrardll.txt" (2ed64b6e)

Örnek 2 Yordamsal kullanım

<?php
$rar_arch = rar_open('solid.rar');
if ($rar_arch === FALSE)
    die("Could not open RAR archive.");

$rar_entries = rar_list($rar_arch);
if ($rar_entries === FALSE)
    die("Could retrieve entries.");

echo "Found " . count($rar_entries) . " entries.\n";

foreach ($rar_entries as $e) {
    echo $e;
    echo "\n";
}
rar_close($rar_arch);
?>

Ayrıca Bakınız

  • RarArchive::getEntry() - Get entry object from the RAR archive
  • rar:// wrapper

RarArchive::getComment
RarArchive::getEntry
RarArchive


Get entry object from the RAR archive

RarArchive::getEntries
RarArchive::isBroken
RarArchive
PHP Manual

RarArchive::getEntry

rar_entry_get

(PECL rar >= 2.0.0)

RarArchive::getEntry -- rar_entry_get — Get entry object from the RAR archive

Açıklama

Nesne yönelimli kullanım (method):

public RarEntry RarArchive::getEntry ( string $entryname )

Yordamsal kullanım:

RarEntry rar_entry_get ( RarArchive $rarfile , string $entryname )

Get entry object (file or directory) from the RAR archive.

Bilginize:

You can also get entry objects using RarArchive::getEntries().

Note that a RAR archive can have multiple entries with the same name; this method will retrieve only the first.

Değiştirgeler

rarfile

A RarArchive object, opened with rar_open().

entryname

Path to the entry within the RAR archive.

Bilginize:

The path must be the same returned by RarEntry::getName().

Dönen Değerler

Returns the matching RarEntry object başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$rar_arch = RarArchive::open('solid.rar');
if ($rar_arch === FALSE)
    die("Could not open RAR archive.");
$rar_entry = $rar_arch->getEntry('tese.txt');
if ($rar_entry === FALSE)
    die("Could not get such entry");
echo get_class($rar_entry)."\n";
echo $rar_entry;
$rar_arch->close();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

RarEntry
RarEntry for file "tese.txt" (23b93a7a)

Örnek 2 Yordamsal kullanım

<?php
$rar_arch = rar_open('solid.rar');
if ($rar_arch === FALSE)
    die("Could not open RAR archive.");
$rar_entry = rar_entry_get($rar_arch, 'tese.txt');
if ($rar_entry === FALSE)
    die("Could not get such entry");
echo get_class($rar_entry)."\n";
echo $rar_entry;
rar_close($rar_arch);
?>

Ayrıca Bakınız

  • RarArchive::getEntries() - Get full list of entries from the RAR archive
  • rar:// wrapper

RarArchive::getEntries
RarArchive::isBroken
RarArchive


Test whether an archive is broken (incomplete)

RarArchive::getEntry
RarArchive::isSolid
RarArchive
PHP Manual

RarArchive::isBroken

rar_broken_is

(PECL rar >= 3.0.0)

RarArchive::isBroken -- rar_broken_is — Test whether an archive is broken (incomplete)

Açıklama

Nesne yönelimli kullanım (method):

public bool RarArchive::isBroken ( void )

Yordamsal kullanım:

bool rar_broken_is ( RarArchive $rarfile )

This function determines whether an archive is incomplete, i.e., if a volume is missing or a volume is truncated.

Değiştirgeler

rarfile

A RarArchive object, opened with rar_open().

Dönen Değerler

Returns TRUE if the archive is broken, FALSE otherwise. This function may also return FALSE if the passed file has already been closed. The only way to tell the two cases apart is to enable exceptions with RarException::setUsingExceptions(); however, this should be unnecessary as a program should not operate on closed files.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
function retnull() { return null; }
$file = dirname(__FILE__) . "/multi_broken.part1.rar";
/* Third argument is used to omit notice */
$arch = RarArchive::open($file, null, 'retnull');
var_dump($arch->isBroken());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(true)

Örnek 2 Yordamsal kullanım

<?php
function retnull() { return null; }
$file = dirname(__FILE__) . "/multi_broken.part1.rar";
/* Third argument is used to omit notice */
$arch = rar_open($file, null, 'retnull');
var_dump(rar_broken_is($arch));
?>

Ayrıca Bakınız

  • RarArchive::setAllowBroken() - Whether opening broken archives is allowed

RarArchive::getEntry
RarArchive::isSolid
RarArchive


Check whether the RAR archive is solid

RarArchive::isBroken
RarArchive::open
RarArchive
PHP Manual

RarArchive::isSolid

rar_solid_is

(PECL rar >= 2.0.0)

RarArchive::isSolid -- rar_solid_is — Check whether the RAR archive is solid

Açıklama

Nesne yönelimli kullanım (method):

public bool RarArchive::isSolid ( void )

Yordamsal kullanım:

bool rar_solid_is ( RarArchive $rarfile )

Check whether the RAR archive is solid. Individual file extraction is slower on solid archives.

Değiştirgeler

rarfile

A RarArchive object, opened with rar_open().

Dönen Değerler

Returns TRUE if the archive is solid, FALSE otherwise.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$arch1 = RarArchive::open("store_method.rar");
$arch2 = RarArchive::open("solid.rar");
echo "$arch1: " . ($arch1->isSolid()?'yes':'no') ."\n";
echo "$arch2: " . ($arch2->isSolid()?'yes':'no') . "\n";
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

RAR Archive "C:\php_rar\trunk\tests\store_method.rar": no
RAR Archive "C:\php_rar\trunk\tests\solid.rar": yes

Örnek 2 Yordamsal kullanım

<?php
$arch1 = rar_open("store_method.rar");
$arch2 = rar_open("solid.rar");
echo "$arch1: " . (rar_solid_is($arch1)?'yes':'no') ."\n";
echo "$arch2: " . (rar_solid_is($arch2)?'yes':'no') . "\n";
?>

RarArchive::isBroken
RarArchive::open
RarArchive


Open RAR archive

RarArchive::isSolid
RarArchive::setAllowBroken
RarArchive
PHP Manual

RarArchive::open

rar_open

(PECL rar >= 2.0.0)

RarArchive::open -- rar_open — Open RAR archive

Açıklama

Nesne yönelimli kullanım (method):

public static RarArchive RarArchive::open ( string $filename [, string $password = NULL [, callable $volume_callback = NULL ]] )

Yordamsal kullanım:

RarArchive rar_open ( string $filename [, string $password = NULL [, callable $volume_callback = NULL ]] )

Open specified RAR archive and return RarArchive instance representing it.

Bilginize:

If opening a multi-volume archive, the path of the first volume should be passed as the first parameter. Otherwise, not all files will be shown. This is by design.

Değiştirgeler

filename

Path to the Rar archive.

password

A plain password, if needed to decrypt the headers. It will also be used by default if encrypted files are found. Note that the files may have different passwords in respect to the headers and among them.

volume_callback

A function that receives one parameter - the path of the volume that was not found - and returns a string with the correct path for such volume or NULL if such volume does not exist or is not known. The programmer should ensure the passed function doesn't cause loops as this function is called repeatedly if the path returned in a previous call did not correspond to the needed volume. Specifying this parameter omits the notice that would otherwise be emitted whenever a volume is not found; an implementation that only returns NULL can therefore be used to merely omit such notices.

Uyarı

Prior to version 2.0.0, this function would not handle relative paths correctly. Use realpath() as a workaround.

Dönen Değerler

Returns the requested RarArchive instance başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
3.0.0 | volume_callback was added.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$rar_arch = RarArchive::open('encrypted_headers.rar', 'samplepassword');
if ($rar_arch === FALSE)
    die("Failed opening file");

$entries = $rar_arch->getEntries();
if ($entries === FALSE)
    die("Failed fetching entries");

echo "Found " . count($entries) . " files.\n";

if (empty($entries))
    die("No valid entries found.");

$stream = reset($entries)->getStream();
if ($stream === FALSE)
    die("Failed opening first file");

$rar_arch->close();

echo "Content of first one follows:\n";
echo stream_get_contents($stream);

fclose($stream);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Found 2 files.
Content of first one follows:
Encrypted file 1 contents.

Örnek 2 Yordamsal kullanım

<?php
$rar_arch = rar_open('encrypted_headers.rar', 'samplepassword');
if ($rar_arch === FALSE)
    die("Failed opening file");

$entries = rar_list($rar_arch);
if ($entries === FALSE)
    die("Failed fetching entries");

echo "Found " . count($entries) . " files.\n";

if (empty($entries))
    die("No valid entries found.");

$stream = reset($entries)->getStream();
if ($stream === FALSE)
    die("Failed opening first file");

rar_close($rar_arch);

echo "Content of first one follows:\n";
echo stream_get_contents($stream);

fclose($stream);
?>

Örnek 3 Volume Callback

<?php
/* In this example, there's a volume named multi_broken.part1.rar
 * whose next volume is named multi.part2.rar */
function resolve($vol) {
    if (preg_match('/_broken/', $vol))
        return str_replace('_broken', '', $vol);
    else
        return null;
}
$rar_file1 = rar_open(dirname(__FILE__).'/multi_broken.part1.rar', null, 'resolve');
$entry = $rar_file1->getEntry('file2.txt');
$entry->extract(null, dirname(__FILE__) . "/temp_file2.txt");
?>

Ayrıca Bakınız

  • rar:// wrapper

RarArchive::isSolid
RarArchive::setAllowBroken
RarArchive


Whether opening broken archives is allowed

RarArchive::open
RarArchive::__toString
RarArchive
PHP Manual

RarArchive::setAllowBroken

(PECL rar >= 3.0.0)

RarArchive::setAllowBroken — Whether opening broken archives is allowed

Açıklama

Nesne yönelimli kullanım (method):

public bool RarArchive::setAllowBroken ( bool $allow_broken )

Yordamsal kullanım:

bool rar_allow_broken_set ( RarArchive $rarfile , bool $allow_broken )

This method defines whether broken archives can be read or all the operations that attempt to extract the archive entries will fail. Broken archives are archives for which no error is detected when the file is opened but an error occurs when reading the entries.

Değiştirgeler

rarfile

A RarArchive object, opened with rar_open().

allow_broken

Whether to allow reading broken files (TRUE) or not (FALSE).

Dönen Değerler

Returns TRUE başarısızlık durumunda FALSE döner. It will only fail if the file has already been closed.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
function retnull() { return null; }
$file = dirname(__FILE__) . "/multi_broken.part1.rar";
/* Third argument omits "volume not found" message */
$a = RarArchive::open($file, null, 'retnull');
$a->setAllowBroken(true);
foreach ($a->getEntries() as $e) {
    echo "$e\n";
}
var_dump(count($a));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

RarEntry for file "file1.txt" (52b28202)
int(1)

Örnek 2 Yordamsal kullanım

<?php
function retnull() { return null; }
$file = dirname(__FILE__) . "/multi_broken.part1.rar";
/* Third argument omits "volume not found" message */
$a = rar_open($file, null, 'retnull');
rar_allow_broken_set($a, true);
foreach (rar_list($a) as $e) {
    echo "$e\n";
}
var_dump(count($a));
?>

Ayrıca Bakınız

  • RarArchive::isBroken() - Test whether an archive is broken (incomplete)

RarArchive::open
RarArchive::__toString
RarArchive


Get text representation

RarArchive::setAllowBroken
RarEntry
RarArchive
PHP Manual

RarArchive::__toString

(PECL rar >= 2.0.0)

RarArchive::__toString — Get text representation

Açıklama

public string RarArchive::__toString ( void )

Provides a string representation for this RarArchive object. It currently shows the full path name of the archive volume that was opened and whether the resource is valid or was already closed through a call to RarArchive::close().

This method may be used only for debugging purposes, as there are no guarantees as to which information the result contains or how it is formatted.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A textual representation of this RarArchive object. The content of this representation is unspecified.

Örnekler

Örnek 1 RarArchive::__toString() example

<?php
$rar_arch = RarArchive::open('latest_winrar.rar');
echo $rar_arch."\n";
$rar_arch->close();
echo $rar_arch."\n";
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

RAR Archive "D:\php_rar\trunk\tests\latest_winrar.rar"
RAR Archive "D:\php_rar\trunk\tests\latest_winrar.rar" (closed)

RarArchive::setAllowBroken
RarEntry
RarArchive


The RarEntry class

(PECL rar >= 0.1)

Giriş

A RAR entry, representing a directory or a compressed file inside a RAR archive.

Sınıf Sözdizimi

final RarEntry {
/* Sabitler */
const integer HOST_MSDOS = 0 ;
const integer HOST_OS2 = 1 ;
const integer HOST_WIN32 = 2 ;
const integer HOST_UNIX = 3 ;
const integer HOST_MACOS = 4 ;
const integer HOST_BEOS = 5 ;
const integer ATTRIBUTE_WIN_READONLY = 1 ;
const integer ATTRIBUTE_WIN_HIDDEN = 2 ;
const integer ATTRIBUTE_WIN_SYSTEM = 4 ;
const integer ATTRIBUTE_WIN_DIRECTORY = 16 ;
const integer ATTRIBUTE_WIN_ARCHIVE = 32 ;
const integer ATTRIBUTE_WIN_DEVICE = 64 ;
const integer ATTRIBUTE_WIN_NORMAL = 128 ;
const integer ATTRIBUTE_WIN_TEMPORARY = 256 ;
const integer ATTRIBUTE_WIN_SPARSE_FILE = 512 ;
const integer ATTRIBUTE_WIN_REPARSE_POINT = 1024 ;
const integer ATTRIBUTE_WIN_COMPRESSED = 2048 ;
const integer ATTRIBUTE_WIN_OFFLINE = 4096 ;
const integer ATTRIBUTE_WIN_NOT_CONTENT_INDEXED = 8192 ;
const integer ATTRIBUTE_WIN_ENCRYPTED = 16384 ;
const integer ATTRIBUTE_WIN_VIRTUAL = 65536 ;
const integer ATTRIBUTE_UNIX_WORLD_EXECUTE = 1 ;
const integer ATTRIBUTE_UNIX_WORLD_WRITE = 2 ;
const integer ATTRIBUTE_UNIX_WORLD_READ = 4 ;
const integer ATTRIBUTE_UNIX_GROUP_EXECUTE = 8 ;
const integer ATTRIBUTE_UNIX_GROUP_WRITE = 16 ;
const integer ATTRIBUTE_UNIX_GROUP_READ = 32 ;
const integer ATTRIBUTE_UNIX_OWNER_EXECUTE = 64 ;
const integer ATTRIBUTE_UNIX_OWNER_WRITE = 128 ;
const integer ATTRIBUTE_UNIX_OWNER_READ = 256 ;
const integer ATTRIBUTE_UNIX_STICKY = 512 ;
const integer ATTRIBUTE_UNIX_SETGID = 1024 ;
const integer ATTRIBUTE_UNIX_SETUID = 2048 ;
const integer ATTRIBUTE_UNIX_FINAL_QUARTET = 61440 ;
const integer ATTRIBUTE_UNIX_FIFO = 4096 ;
const integer ATTRIBUTE_UNIX_CHAR_DEV = 8192 ;
const integer ATTRIBUTE_UNIX_DIRECTORY = 16384 ;
const integer ATTRIBUTE_UNIX_BLOCK_DEV = 24576 ;
const integer ATTRIBUTE_UNIX_REGULAR_FILE = 32768 ;
const integer ATTRIBUTE_UNIX_SYM_LINK = 40960 ;
const integer ATTRIBUTE_UNIX_SOCKET = 49152 ;
/* Yöntemler */
public bool extract ( string $dir [, string $filepath = "" [, string $password = NULL [, bool $extended_data = false ]]] )
public int getAttr ( void )
public string getCrc ( void )
public string getFileTime ( void )
public int getHostOs ( void )
public int getMethod ( void )
public string getName ( void )
public int getPackedSize ( void )
public resource getStream ([ string $password ] )
public int getUnpackedSize ( void )
public int getVersion ( void )
public bool isDirectory ( void )
public bool isEncrypted ( void )
public string __toString ( void )
}

Öntanımlı Sabitler

RarEntry::HOST_MSDOS

If the return value of RarEntry::getHostOs() equals this constant, MS-DOS was used to add this entry. Use instead of RAR_HOST_MSDOS.

RarEntry::HOST_OS2

If the return value of RarEntry::getHostOs() equals this constant, OS/2 was used to add this entry. Intended to replace RAR_HOST_OS2.

RarEntry::HOST_WIN32

If the return value of RarEntry::getHostOs() equals this constant, Microsoft Windows was used to add this entry. Intended to replace RAR_HOST_WIN32.

RarEntry::HOST_UNIX

If the return value of RarEntry::getHostOs() equals this constant, an unspecified UNIX OS was used to add this entry. Intended to replace RAR_HOST_UNIX.

RarEntry::HOST_MACOS

If the return value of RarEntry::getHostOs() equals this constant, Mac OS was used to add this entry.

RarEntry::HOST_BEOS

If the return value of RarEntry::getHostOs() equals this constant, BeOS was used to add this entry. Intended to replace RAR_HOST_BEOS.

RarEntry::ATTRIBUTE_WIN_READONLY

Bit that represents a Windows entry with a read-only attribute. To be used with RarEntry::getAttr() on entries whose host OS is Microsoft Windows.

RarEntry::ATTRIBUTE_WIN_HIDDEN

Bit that represents a Windows entry with a hidden attribute. To be used with RarEntry::getAttr() on entries whose host OS is Microsoft Windows.

RarEntry::ATTRIBUTE_WIN_SYSTEM

Bit that represents a Windows entry with a system attribute. To be used with RarEntry::getAttr() on entries whose host OS is Microsoft Windows.

RarEntry::ATTRIBUTE_WIN_DIRECTORY

Bit that represents a Windows entry with a directory attribute (entry is a directory). To be used with RarEntry::getAttr() on entries whose host OS is Microsoft Windows. See also RarEntry::isDirectory(), which also works with entries that were not added in WinRAR.

RarEntry::ATTRIBUTE_WIN_ARCHIVE

Bit that represents a Windows entry with an archive attribute. To be used with RarEntry::getAttr() on entries whose host OS is Microsoft Windows.

RarEntry::ATTRIBUTE_WIN_DEVICE

Bit that represents a Windows entry with a device attribute. To be used with RarEntry::getAttr() on entries whose host OS is Microsoft Windows.

RarEntry::ATTRIBUTE_WIN_NORMAL

Bit that represents a Windows entry with a normal file attribute (entry is NOT a directory). To be used with RarEntry::getAttr() on entries whose host OS is Microsoft Windows. See also RarEntry::isDirectory(), which also works with entries that were not added in WinRAR.

RarEntry::ATTRIBUTE_WIN_TEMPORARY

Bit that represents a Windows entry with a temporary attribute. To be used with RarEntry::getAttr() on entries whose host OS is Microsoft Windows.

RarEntry::ATTRIBUTE_WIN_SPARSE_FILE

Bit that represents a Windows entry with a sparse file attribute (file is an NTFS sparse file). To be used with RarEntry::getAttr() on entries whose host OS is Microsoft Windows.

RarEntry::ATTRIBUTE_WIN_REPARSE_POINT

Bit that represents a Windows entry with a reparse point attribute (entry is an NTFS reparse point, e.g. a directory junction or a mount file system). To be used with RarEntry::getAttr() on entries whose host OS is Microsoft Windows.

RarEntry::ATTRIBUTE_WIN_COMPRESSED

Bit that represents a Windows entry with a compressed attribute (NTFS only). To be used with RarEntry::getAttr() on entries whose host OS is Microsoft Windows.

RarEntry::ATTRIBUTE_WIN_OFFLINE

Bit that represents a Windows entry with an offline attribute (entry is offline and not accessible). To be used with RarEntry::getAttr() on entries whose host OS is Microsoft Windows.

RarEntry::ATTRIBUTE_WIN_NOT_CONTENT_INDEXED

Bit that represents a Windows entry with a not content indexed attribute (entry is to be indexed). To be used with RarEntry::getAttr() on entries whose host OS is Microsoft Windows.

RarEntry::ATTRIBUTE_WIN_ENCRYPTED

Bit that represents a Windows entry with an encrypted attribute (NTFS only). To be used with RarEntry::getAttr() on entries whose host OS is Microsoft Windows.

RarEntry::ATTRIBUTE_WIN_VIRTUAL

Bit that represents a Windows entry with a virtual attribute. To be used with RarEntry::getAttr() on entries whose host OS is Microsoft Windows.

RarEntry::ATTRIBUTE_UNIX_WORLD_EXECUTE

Bit that represents a UNIX entry that is world executable. To be used with RarEntry::getAttr() on entries whose host OS is UNIX.

RarEntry::ATTRIBUTE_UNIX_WORLD_WRITE

Bit that represents a UNIX entry that is world writable. To be used with RarEntry::getAttr() on entries whose host OS is UNIX.

RarEntry::ATTRIBUTE_UNIX_WORLD_READ

Bit that represents a UNIX entry that is world readable. To be used with RarEntry::getAttr() on entries whose host OS is UNIX.

RarEntry::ATTRIBUTE_UNIX_GROUP_EXECUTE

Bit that represents a UNIX entry that is group executable. To be used with RarEntry::getAttr() on entries whose host OS is UNIX.

RarEntry::ATTRIBUTE_UNIX_GROUP_WRITE

Bit that represents a UNIX entry that is group writable. To be used with RarEntry::getAttr() on entries whose host OS is UNIX.

RarEntry::ATTRIBUTE_UNIX_GROUP_READ

Bit that represents a UNIX entry that is group readable. To be used with RarEntry::getAttr() on entries whose host OS is UNIX.

RarEntry::ATTRIBUTE_UNIX_OWNER_EXECUTE

Bit that represents a UNIX entry that is owner executable. To be used with RarEntry::getAttr() on entries whose host OS is UNIX.

RarEntry::ATTRIBUTE_UNIX_OWNER_WRITE

Bit that represents a UNIX entry that is owner writable. To be used with RarEntry::getAttr() on entries whose host OS is UNIX.

RarEntry::ATTRIBUTE_UNIX_OWNER_READ

Bit that represents a UNIX entry that is owner readable. To be used with RarEntry::getAttr() on entries whose host OS is UNIX.

RarEntry::ATTRIBUTE_UNIX_STICKY

Bit that represents the UNIX sticky bit. To be used with RarEntry::getAttr() on entries whose host OS is UNIX.

RarEntry::ATTRIBUTE_UNIX_SETGID

Bit that represents the UNIX setgid attribute. To be used with RarEntry::getAttr() on entries whose host OS is UNIX.

RarEntry::ATTRIBUTE_UNIX_SETUID

Bit that represents the UNIX setuid attribute. To be used with RarEntry::getAttr() on entries whose host OS is UNIX.

RarEntry::ATTRIBUTE_UNIX_FINAL_QUARTET

Mask to isolate the last four bits (nibble) of UNIX attributes
      (_S_IFMT, the type of file mask). To be used with
      RarEntry::getAttr() on entries whose host OS is UNIX and with the
      constants RarEntry::ATTRIBUTE_UNIX_FIFO,
      RarEntry::ATTRIBUTE_UNIX_CHAR_DEV,
      RarEntry::ATTRIBUTE_UNIX_DIRECTORY,
      RarEntry::ATTRIBUTE_UNIX_BLOCK_DEV,
      RarEntry::ATTRIBUTE_UNIX_REGULAR_FILE,
      RarEntry::ATTRIBUTE_UNIX_SYM_LINK and
      RarEntry::ATTRIBUTE_UNIX_SOCKET.

RarEntry::ATTRIBUTE_UNIX_FIFO

Unix FIFOs will have attributes whose last four bits have this value. To be used with RarEntry::getAttr() on entries whose host OS is UNIX and with the constant RarEntry::ATTRIBUTE_UNIX_FINAL_QUARTET.

RarEntry::ATTRIBUTE_UNIX_CHAR_DEV

Unix character devices will have attributes whose last four bits have this value. To be used with RarEntry::getAttr() on entries whose host OS is UNIX and with the constant RarEntry::ATTRIBUTE_UNIX_FINAL_QUARTET.

RarEntry::ATTRIBUTE_UNIX_DIRECTORY

Unix directories will have attributes whose last four bits have this value. To be used with RarEntry::getAttr() on entries whose host OS is UNIX and with the constant RarEntry::ATTRIBUTE_UNIX_FINAL_QUARTET. See also RarEntry::isDirectory(), which also works with entries that were added in other operating systems.

RarEntry::ATTRIBUTE_UNIX_BLOCK_DEV

Unix block devices will have attributes whose last four bits have this value. To be used with RarEntry::getAttr() on entries whose host OS is UNIX and with the constant RarEntry::ATTRIBUTE_UNIX_FINAL_QUARTET.

RarEntry::ATTRIBUTE_UNIX_REGULAR_FILE

Unix regular files (not directories) will have attributes whose last four bits have this value. To be used with RarEntry::getAttr() on entries whose host OS is UNIX and with the constant RarEntry::ATTRIBUTE_UNIX_FINAL_QUARTET. See also RarEntry::isDirectory(), which also works with entries that were added in other operating systems.

RarEntry::ATTRIBUTE_UNIX_SYM_LINK

Unix symbolic links will have attributes whose last four bits have this value. To be used with RarEntry::getAttr() on entries whose host OS is UNIX and with the constant RarEntry::ATTRIBUTE_UNIX_FINAL_QUARTET.

RarEntry::ATTRIBUTE_UNIX_SOCKET

Unix sockets will have attributes whose last four bits have this value. To be used with RarEntry::getAttr() on entries whose host OS is UNIX and with the constant RarEntry::ATTRIBUTE_UNIX_FINAL_QUARTET.

İçindekiler

  • RarEntry::extract — Extract entry from the archive
  • RarEntry::getAttr — Get attributes of the entry
  • RarEntry::getCrc — Get CRC of the entry
  • RarEntry::getFileTime — Get entry last modification time
  • RarEntry::getHostOs — Get entry host OS
  • RarEntry::getMethod — Get pack method of the entry
  • RarEntry::getName — Get name of the entry
  • RarEntry::getPackedSize — Get packed size of the entry
  • RarEntry::getStream — Get file handler for entry
  • RarEntry::getUnpackedSize — Get unpacked size of the entry
  • RarEntry::getVersion — Get minimum version of RAR program required to unpack the entry
  • RarEntry::isDirectory — Test whether an entry represents a directory
  • RarEntry::isEncrypted — Test whether an entry is encrypted
  • RarEntry::__toString — Get text representation of entry
RarArchive::__toString
RarEntry::extract
Rar


Extract entry from the archive

RarEntry
RarEntry::getAttr
RarEntry
PHP Manual

RarEntry::extract

(PECL rar >= 0.1)

RarEntry::extract — Extract entry from the archive

Açıklama

public bool RarEntry::extract ( string $dir [, string $filepath = "" [, string $password = NULL [, bool $extended_data = false ]]] )

RarEntry::extract() extracts the entry's data. It will create new file in the specified dir with the name identical to the entry's name, unless the second argument is specified. See below for more information.

Değiştirgeler

dir

Path to the directory where files should be extracted. This parameter is considered if and only if filepath is not. If both parameters are empty an extraction to the current directory will be attempted.

filepath

Path (relative or absolute) containing the directory and filename of the extracted file. This parameter overrides both the parameter dir and the original file name.

password

The password used to encrypt this entry. If the entry is not encrypted, this value will not be used and can be omitted. If this parameter is omitted and the entry is encrypted, the password given to rar_open(), if any, will be used. If a wrong password is given, either explicitly or implicitly via rar_open(), CRC checking will fail and this method will fail and return FALSE. If no password is given and one is required, this method will fail and return FALSE. You can check whether an entry is encrypted with RarEntry::isEncrypted().

extended_data

If TRUE, extended information such as NTFS ACLs and Unix owner information will be set in the extract files, as long as it's present in the archive.

Uyarı

Prior to version 2.0.0, this function would not handle relative paths correctly. Use realpath() as a workaround.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
3.0.0 | extended_data was added.
3.0.0 | Support for RAR archives with repeated entry names is no longer defective.

Örnekler

Örnek 1 RarEntry::extract() example

<?php

$rar_file = rar_open('example.rar') or die("Failed to open Rar archive");

$entry = rar_entry_get($rar_file, 'Dir/file.txt') or die("Failed to find such entry");

$entry->extract('/dir/to'); // create /dir/to/Dir/file.txt
$entry->extract(false, '/dir/to/new_name.txt'); // create /dir/to/new_name.txt

?>

Örnek 2 How to extract all files in archive:

<?php

/* example by Erik Jenssen aka erix */

$filename = "foobar.rar";
$filepath = "/home/foo/bar/";

$rar_file = rar_open($filepath.$filename);
$list = rar_list($rar_file);
foreach($list as $file) {
    $entry = rar_entry_get($rar_file, $file);
    $entry->extract("."); // extract to the current dir
}
rar_close($rar_file);

?>

Ayrıca Bakınız

  • RarEntry::getStream() - Get file handler for entry
  • rar:// wrapper

RarEntry
RarEntry::getAttr
RarEntry


Get attributes of the entry

RarEntry::extract
RarEntry::getCrc
RarEntry
PHP Manual

RarEntry::getAttr

(PECL rar >= 0.1)

RarEntry::getAttr — Get attributes of the entry

Açıklama

public int RarEntry::getAttr ( void )

Returns the OS-dependent attributes of the archive entry.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the attributes or FALSE on error.

Örnekler

Örnek 1 RarEntry::getAttr() example

<?php

$rar_file = rar_open('example.rar') or die("Can't open Rar archive");

$entry = rar_entry_get($rar_file, 'dir/in/the/archive') or die("Can't find such entry");

$host_os = $entry->getHostOs();
$attr = $entry->getAttr();

switch($host_os) {
    case RAR_HOST_MSDOS:
    case RAR_HOST_OS2:
    case RAR_HOST_WIN32:
    case RAR_HOST_MACOS:
        printf("%c%c%c%c%c%c\n",
                ($attr & 0x08) ? 'V' : '.',
                ($attr & 0x10) ? 'D' : '.',
                ($attr & 0x01) ? 'R' : '.',
                ($attr & 0x02) ? 'H' : '.',
                ($attr & 0x04) ? 'S' : '.',
                ($attr & 0x20) ? 'A' : '.');
        break;
    case RAR_HOST_UNIX:
    case RAR_HOST_BEOS:
        switch ($attr & 0xF000)
        {
            case 0x4000:
                printf("d");
                break;
            case 0xA000:
                printf("l");
                break;
            default:
                printf("-");
                break;
        }
        printf("%c%c%c%c%c%c%c%c%c\n",
                ($attr & 0x0100) ? 'r' : '-',
                ($attr & 0x0080) ? 'w' : '-',
                ($attr & 0x0040) ? (($attr & 0x0800) ? 's':'x'):(($attr & 0x0800) ? 'S':'-'),
                ($attr & 0x0020) ? 'r' : '-',
                ($attr & 0x0010) ? 'w' : '-',
                ($attr & 0x0008) ? (($attr & 0x0400) ? 's':'x'):(($attr & 0x0400) ? 'S':'-'),
                ($attr & 0x0004) ? 'r' : '-',
                ($attr & 0x0002) ? 'w' : '-',
                ($attr & 0x0001) ? 'x' : '-');
        break;
}

rar_close($rar_file);

?>

Ayrıca Bakınız

  • RarEntry::getHostOs() - Get entry host OS
  • The constants in RarEntry

RarEntry::extract
RarEntry::getCrc
RarEntry


Get CRC of the entry

RarEntry::getAttr
RarEntry::getFileTime
RarEntry
PHP Manual

RarEntry::getCrc

(PECL rar >= 0.1)

RarEntry::getCrc — Get CRC of the entry

Açıklama

public string RarEntry::getCrc ( void )

Returns an hexadecimal string representation of the CRC of the archive entry.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the CRC of the archive entry or FALSE on error.

Sürüm Bilgisi

Sürüm: | Açıklama
2.0.0 | This method now returns correct values for multiple volume archives.

RarEntry::getAttr
RarEntry::getFileTime
RarEntry


Get entry last modification time

RarEntry::getCrc
RarEntry::getHostOs
RarEntry
PHP Manual

RarEntry::getFileTime

(PECL rar >= 0.1)

RarEntry::getFileTime — Get entry last modification time

Açıklama

public string RarEntry::getFileTime ( void )

Gets entry last modification time.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns entry last modification time as string in format YYYY-MM-DD HH:II:SS, or FALSE on error.

RarEntry::getCrc
RarEntry::getHostOs
RarEntry


Get entry host OS

RarEntry::getFileTime
RarEntry::getMethod
RarEntry
PHP Manual

RarEntry::getHostOs

(PECL rar >= 0.1)

RarEntry::getHostOs — Get entry host OS

Açıklama

public int RarEntry::getHostOs ( void )

Returns the code of the host OS of the archive entry.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the code of the host OS, or FALSE on error.

Örnekler

Örnek 1 RarEntry::getHostOs() example (version >= 2.0.0)

<?php

$rar_file = rar_open('example.rar') or die("Failed to open Rar archive");

$entry = rar_entry_get($rar_file, 'Dir/file.txt') or die("Failed to find such entry");

switch ($entry->getHostOs()) {
    case RarEntry::HOST_MSDOS:
        echo "MS-DOS\n";
        break;
    case RarEntry::HOST_OS2:
        echo "OS2\n";
        break;
    case RarEntry::HOST_WIN32:
        echo "Win32\n";
        break;
    case RarEntry::HOST_MACOS:
        echo "MacOS\n";
        break;
    case RarEntry::HOST_UNIX:
        echo "Unix/Linux\n";
        break;
    case RarEntry::HOST_BEOS:
        echo "BeOS\n";
        break;
}

?>

Örnek 2 RarEntry::getHostOs() example (version <= 1.0.0)

<?php

$rar_file = rar_open('example.rar') or die("Failed to open Rar archive");

$entry = rar_entry_get($rar_file, 'Dir/file.txt') or die("Failed to find such entry");

switch ($entry->getHostOs()) {
    case RAR_HOST_MSDOS:
        echo "MS-DOS\n";
        break;
    case RAR_HOST_OS2:
        echo "OS2\n";
        break;
    case RAR_HOST_WIN32:
        echo "Win32\n";
        break;
    case RAR_HOST_MACOS:
        echo "MacOS\n";
        break;
    case RAR_HOST_UNIX:
        echo "Unix/Linux\n";
        break;
    case RAR_HOST_BEOS:
        echo "BeOS\n";
        break;
}

?>

Ayrıca Bakınız

  • RarEntry::extract() - Extract entry from the archive

RarEntry::getFileTime
RarEntry::getMethod
RarEntry


Get pack method of the entry

RarEntry::getHostOs
RarEntry::getName
RarEntry
PHP Manual

RarEntry::getMethod

(PECL rar >= 0.1)

RarEntry::getMethod — Get pack method of the entry

Açıklama

public int RarEntry::getMethod ( void )

RarEntry::getMethod() returns number of the method used when adding current archive entry.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the method number or FALSE on error.

Örnekler

Örnek 1 RarEntry::getMethod() example

<?php

$rar_file = rar_open('example.rar') or die("Failed to open Rar archive");

$entry = rar_entry_get($rar_file, 'Dir/file.txt') or die("Failed to find such entry");

echo "Method number: " . $entry->getMethod();

?>

RarEntry::getHostOs
RarEntry::getName
RarEntry


Get name of the entry

RarEntry::getMethod
RarEntry::getPackedSize
RarEntry
PHP Manual

RarEntry::getName

(PECL rar >= 0.1)

RarEntry::getName — Get name of the entry

Açıklama

public string RarEntry::getName ( void )

Returns the name (with path) of the archive entry.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the entry name as a string, or FALSE on error.

Sürüm Bilgisi

Sürüm: | Açıklama
2.0.0 | As of version 2.0.0, the returned string is encoded in Unicode/UTF-8.

Örnekler

Örnek 1 RarEntry::getName() example

<?php

//this example is safe even in pages not encoded in UTF-8
//for those encoded in UTF-8, the call to mb_convert_encoding is unnecessary

$rar_file = rar_open('example.rar') or die("Failed to open Rar archive");

$entry = rar_entry_get($rar_file, 'Dir/file.txt') or die("Failed to find such entry");

echo "Entry name: " . mb_convert_encoding(
    htmlentities(
        $entry->getName(),
        ENT_COMPAT,
        "UTF-8"
    ),
    "HTML-ENTITIES",
    "UTF-8"
);

?>

RarEntry::getMethod
RarEntry::getPackedSize
RarEntry


Get packed size of the entry

RarEntry::getName
RarEntry::getStream
RarEntry
PHP Manual

RarEntry::getPackedSize

(PECL rar >= 0.1)

RarEntry::getPackedSize — Get packed size of the entry

Açıklama

public int RarEntry::getPackedSize ( void )

Get packed size of the archive entry.

Bilginize:

Note that on platforms with 32-bit longs (that includes Windows x64), the maximum size returned is capped at 2 GiB. Check the constant PHP_INT_MAX.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the packed size, or FALSE on error.

Sürüm Bilgisi

Sürüm: | Açıklama
2.0.0 | This method now returns correct values of packed sizes bigger than 2 GiB on platforms with 64-bit integers and never returns negative values on other platforms.

Örnekler

Örnek 1 RarEntry::getPackedSize() example

<?php

$rar_file = rar_open('example.rar') or die("Failed to open Rar archive");

$entry = rar_entry_get($rar_file, 'Dir/file.txt') or die("Failed to find such entry");

echo "Packed size of " . $entry->getName() . " = " . $entry->getPackedSize() . " bytes";

?>

RarEntry::getName
RarEntry::getStream
RarEntry


Get file handler for entry

RarEntry::getPackedSize
RarEntry::getUnpackedSize
RarEntry
PHP Manual

RarEntry::getStream

(PECL rar >= 2.0.0)

RarEntry::getStream — Get file handler for entry

Açıklama

public resource RarEntry::getStream ([ string $password ] )

Returns a file handler that supports read operations. This handler provides on-the-fly decompression for this entry.

The handler is not invalidated by calling rar_close().

Uyarı

The resulting stream has no integrity verification. In particular, file corruption and decryption with a wrong a key will not be detected. It is the programmer's responsability to use the entry's CRC to check for integrity, if he so wishes.

Değiştirgeler

password

The password used to encrypt this entry. If the entry is not encrypted, this value will not be used and can be omitted. If this parameter is omitted and the entry is encrypted, the password given to rar_open(), if any, will be used. If a wrong password is given, either explicitly or implicitly via rar_open(), this method's resulting stream will produce wrong output. If no password is given and one is required, this method will fail and return FALSE. You can check whether an entry is encrypted with RarEntry::isEncrypted().

Dönen Değerler

The file handler başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
3.0.0 | Support for RAR archives with repeated entry names is no longer defective.

Örnekler

Örnek 1 RarEntry::getStream() example

<?php

$rar_file = rar_open('example.rar');
if ($rar_file === false)
    die("Failed to open Rar archive");

$entry = rar_entry_get($rar_file, 'Dir/file.txt');
if ($entry === false)
    die("Failed to find such entry");

$stream = $entry->getStream();
if ($stream === false)
    die("Failed to obtain stream.");

rar_close($rar_file); //stream is independent from file

while (!feof($stream)) {
    $buff = fread($stream, 8192);
    if ($buff !== false)
        echo $buff;
    else
        break; //fread error
}

fclose($stream);

?>

Ayrıca Bakınız

  • RarEntry::extract() - Extract entry from the archive
  • rar:// wrapper

RarEntry::getPackedSize
RarEntry::getUnpackedSize
RarEntry


Get unpacked size of the entry

RarEntry::getStream
RarEntry::getVersion
RarEntry
PHP Manual

RarEntry::getUnpackedSize

(PECL rar >= 0.1)

RarEntry::getUnpackedSize — Get unpacked size of the entry

Açıklama

public int RarEntry::getUnpackedSize ( void )

Get unpacked size of the archive entry.

Bilginize:

Note that on platforms with 32-bit longs (that includes Windows x64), the maximum size returned is capped at 2 GiB. Check the constant PHP_INT_MAX.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the unpacked size, or FALSE on error.

Sürüm Bilgisi

Sürüm: | Açıklama
2.0.0 | This method now returns correct values of unpacked sizes bigger than 2 GiB on platforms with 64-bit integers and never returns negative values on other platforms.

Dönen Değerler

Örnek 1 RarEntry::getUnpackedSize() example

<?php

$rar_file = rar_open('example.rar') or die("Failed to open Rar archive");

$entry = rar_entry_get($rar_file, 'Dir/file.txt') or die("Failed to find such entry");

echo "Unpacked size of " . $entry->getName() . " = " . $entry->getPackedSize() . " bytes";

?>

RarEntry::getStream
RarEntry::getVersion
RarEntry


Get minimum version of RAR program required to unpack the entry

RarEntry::getUnpackedSize
RarEntry::isDirectory
RarEntry
PHP Manual

RarEntry::getVersion

(PECL rar >= 0.1)

RarEntry::getVersion — Get minimum version of RAR program required to unpack the entry

Açıklama

public int RarEntry::getVersion ( void )

Returns minimum version of RAR program (e.g. WinRAR) required to unpack the entry. It is encoded as 10 * major version + minor version.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the version or FALSE on error.

Örnekler

Örnek 1 RarEntry::getVersion() example

<?php

$rar_file = rar_open('example.rar') or die("Failed to open Rar archive");

$entry = rar_entry_get($rar_file, 'Dir/file.txt') or die("Failed to find such entry");

echo "Rar version required for unpacking: " . $entry->getVersion();

?>

RarEntry::getUnpackedSize
RarEntry::isDirectory
RarEntry


Test whether an entry represents a directory

RarEntry::getVersion
RarEntry::isEncrypted
RarEntry
PHP Manual

RarEntry::isDirectory

(PECL rar >= 2.0.0)

RarEntry::isDirectory — Test whether an entry represents a directory

Açıklama

public bool RarEntry::isDirectory ( void )

Tests whether the current entry is a directory.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if this entry is a directory and FALSE otherwise.

Notlar

This function is only available starting with version 2.0.0, but one can also test whether an entry is a directory by checking the entry attributes, like this (only works for files compressed in RAR for Windows or Unix):

<?php
//...
//Open file, get entry and store in variable $e...
//...

$isDirectory = (bool) ((($e->getHostOs() == RAR_HOST_WIN32) && ($e->getAttr() & 0x10)) ||
    (($e->getHostOs() == RAR_HOST_UNIX) && (($e->getAttr() & 0xf000) == 0x4000)));
?>

RarEntry::getVersion
RarEntry::isEncrypted
RarEntry


Test whether an entry is encrypted

RarEntry::isDirectory
RarEntry::__toString
RarEntry
PHP Manual

RarEntry::isEncrypted

(PECL rar >= 2.0.0)

RarEntry::isEncrypted — Test whether an entry is encrypted

Açıklama

public bool RarEntry::isEncrypted ( void )

Tests whether the current entry contents are encrypted.

Bilginize:

The password used may differ between files inside the same RAR archive.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the current entry is encrypted and FALSE otherwise.

RarEntry::isDirectory
RarEntry::__toString
RarEntry


Get text representation of entry

RarEntry::isEncrypted
RarException
RarEntry
PHP Manual

RarEntry::__toString

(PECL rar >= 2.0.0)

RarEntry::__toString — Get text representation of entry

Açıklama

public string RarEntry::__toString ( void )

RarEntry::__toString() returns a textual representation for this entry. It includes whether the entry is a file or a directory (symbolic links and other special objects will be treated as files), the UTF-8 name of the entry and its CRC. The form and content of this representation may be changed in the future, so they cannot be relied upon.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A textual representation for the entry.

RarEntry::isEncrypted
RarException
RarEntry


The RarException class

(PECL rar >= 2.0.0)

Giriş

This class serves two purposes: it is the type of the exceptions thrown by the RAR extension functions and methods and it allows, through static methods to query and define the error behaviour of the extension, i.e., whether exceptions are thrown or only warnings are emitted.

The following error codes are used:

  • -1 - error outside UnRAR library
  • 11 - insufficient memory
  • 12 - bad data
  • 13 - bad archive
  • 14 - unknown format
  • 15 - file open error
  • 16 - file create error
  • 17 - file close error
  • 18 - read error
  • 19 - write error
  • 20 - buffer too small
  • 21 - unkown RAR error
  • 22 - password required but not given

Sınıf Sözdizimi

final RarException extends Exception {
/* Yöntemler */
public static bool isUsingExceptions ( void )
public static void setUsingExceptions ( bool $using_exceptions )
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}

İçindekiler

  • RarException::isUsingExceptions — Check whether error handling with exceptions is in use
  • RarException::setUsingExceptions — Activate and deactivate error handling with exceptions
RarEntry::__toString
RarException::isUsingExceptions
Rar


Check whether error handling with exceptions is in use

RarException
RarException::setUsingExceptions
RarException
PHP Manual

RarException::isUsingExceptions

(PECL rar >= 2.0.0)

RarException::isUsingExceptions — Check whether error handling with exceptions is in use

Açıklama

public static bool RarException::isUsingExceptions ( void )

Checks whether the RAR functions will emit warnings and return error values or whether they will throw exceptions in most of the circumstances (does not include some programmatic errors such as passing the wrong type of arguments).

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if exceptions are being used, FALSE otherwise.

Örnekler

Örnek 1 RarException::isUsingExceptions() example

<?php
//The default is not to use exceptions
var_dump(RarException::isUsingExceptions());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(false)

Ayrıca Bakınız

  • RarException::setUsingExceptions() - Activate and deactivate error handling with exceptions

RarException
RarException::setUsingExceptions
RarException


Activate and deactivate error handling with exceptions

RarException::isUsingExceptions
Zip
RarException
PHP Manual

RarException::setUsingExceptions

(PECL rar >= 2.0.0)

RarException::setUsingExceptions — Activate and deactivate error handling with exceptions

Açıklama

public static void RarException::setUsingExceptions ( bool $using_exceptions )

If and only if the argument is TRUE, then, instead of emitting warnings and returning a special value indicating error when the UnRAR library encounters an error, an exception of type RarException will be thrown.

Exceptions will also be thrown for the following errors, which occur outside the library (their error code will be -1):

  • attempting some operations on a closed RarArchive object or a RarEntry object relative to the first;
  • attempting to get an entry that does not exist with RarArchive::getEntry().

Değiştirgeler

using_exceptions

Should be TRUE to activate exception throwing, FALSE to deactivate (the default).

Örnekler

Örnek 1 RarException::setUsingExceptions() example

<?php
var_dump(RarException::isUsingExceptions());
$arch = RarArchive::open("does_not_exist.rar");
var_dump($arch);

RarException::setUsingExceptions(true);
var_dump(RarException::isUsingExceptions());
$arch = RarArchive::open("does_not_exist.rar");
var_dump($arch); //not reached
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(false)

Warning: RarArchive::open(): Failed to open does_not_exist.rar: ERAR_EOPEN (file open error) in C:\php_rar\trunk\tests\test.php on line 3
bool(false)
bool(true)

Fatal error: Uncaught exception 'RarException' with message 'unRAR internal error: Failed to open does_not_exist.rar: ERAR_EOPEN (file open error)' in C:\php_rar\trunk\tests\test.php:8
Stack trace:
#0 C:\php_rar\trunk\tests\test.php(8): RarArchive::open('does_not_exist....')
#1 {main}
  thrown in C:\php_rar\trunk\tests\test.php on line 8

Ayrıca Bakınız

  • RarException::isUsingExceptions() - Check whether error handling with exceptions is in use

RarException::isUsingExceptions
Zip
RarException


Zip

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
  • ZipArchive — ZipArchive sınıfı
    • ZipArchive::addEmptyDir — Yeni bir dizin ekler
    • ZipArchive::addFile — Yolu belirtilen dosyayı arşive ekler
    • ZipArchive::addFromString — İsmi ve içeriği belirtilen dosyayı arşive ekler
    • ZipArchive::addGlob — Add files from a directory by glob pattern
    • ZipArchive::addPattern — Add files from a directory by PCRE pattern
    • ZipArchive::close — Etkin (açık veya oluşturulmuş) arşivi kapatır
    • ZipArchive::deleteIndex — İndisi belirtilen girdiyi siler
    • ZipArchive::deleteName — İsmi belirtilen girdiyi siler
    • ZipArchive::extractTo — Arşiv içeriğini çıkarır
    • ZipArchive::getArchiveComment — Zip arşivinin açıklamasını döndürür
    • ZipArchive::getCommentIndex — İndisi belirtilen girdinin açıklamasını döndürür
    • ZipArchive::getCommentName — İsmi belirtilen girdinin açıklamasını döndürür
    • ZipArchive::getExternalAttributesIndex — Retrieve the external attributes of an entry defined by its index
    • ZipArchive::getExternalAttributesName — Retrieve the external attributes of an entry defined by its name
    • ZipArchive::getFromIndex — İndisi belirtilen girdinin içeriğini döndürür
    • ZipArchive::getFromName — İsmi belirtilen girdinin içeriğini döndürür
    • ZipArchive::getNameIndex — İndisi belirtilen girdinin ismini döndürür
    • ZipArchive::GetStatusString — Durum hata iletilerini, sistem ve/veya zip iletilerini döndürür
    • ZipArchive::getStream — İsmi belirtilen girdi için dosya tanıtıcısı (salt okunur) döndürür
    • ZipArchive::locateName — İsmi belirtilen girdinin indisini döndürür
    • ZipArchive::open — Bir ZIP dosya arşivi açar
    • ZipArchive::renameIndex — İndisi belirtilen girdinin ismini değiştirir
    • ZipArchive::renameName — İsmi belirtilen girdinin ismini değiştirir
    • ZipArchive::setArchiveComment — Bir ZIP arşivine açıklama ekler
    • ZipArchive::setCommentIndex — İndisi belirtilen girdiye bir açıklama ekler
    • ZipArchive::setCommentName — İsmi belirtilen girdiye bir açıklama ekler
    • ZipArchive::setCompressionIndex — Set the compression method of an entry defined by its index
    • ZipArchive::setCompressionName — Set the compression method of an entry defined by its name
    • ZipArchive::setExternalAttributesIndex — Set the external attributes of an entry defined by its index
    • ZipArchive::setExternalAttributesName — Set the external attributes of an entry defined by its name
    • ZipArchive::setPassword — Set the password for the active archive
    • ZipArchive::statIndex — İndisi belirtilen girdiyle ilgili bilgileri döndürür
    • ZipArchive::statName — İsmi belirtilen girdiyle ilgili bilgileri döndürür
    • ZipArchive::unchangeAll — Arşivde yapılmış değişikliklerin tamamını geri alır
    • ZipArchive::unchangeArchive — Arşiv bilgilerinde yapılmış değişiklikleri geri alır
    • ZipArchive::unchangeIndex — İndisi belirtilen girdideki değişiklikleri geri alır
    • ZipArchive::unchangeName — İsmi belirtilen girdideki değişiklikleri geri alır
  • Zip İşlevleri
    • zip_close — Bir ZIP dosya arşivini kapatır
    • zip_entry_close — Bir dizin girdisini kapatır
    • zip_entry_compressedsize — Dizin girdisinin sıkıştırılmış uzunluğunu döndürür
    • zip_entry_compressionmethod — Dizin girdisinin sıkıştırma yöntemini döndürür
    • zip_entry_filesize — Bir dizin girdisinin uzunluğunu döndürür
    • zip_entry_name — Bir dizin girdisinin ismini döndürür
    • zip_entry_open — Okumak için bir dizin girdisi açar
    • zip_entry_read — Bir açık dizin girdisini okur
    • zip_open — Bir ZIP dosya arşivi açar
    • zip_read — Bir ZIP dosya arşivindeki bir sonraki girdiyi okur
RarException::setUsingExceptions
Giriş
Sıkıştırma ve Arşivleme Eklentileri


Giriş

Bu eklenti, sıkıştırılmış ZIP arşivlerini ve içindeki dosyaları şeffaf olarak okuyup yazmayı etkin kılar.

Zip
Yapılandırma/Kurulum
Zip


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Zip


Gereksinimler

Bu eklenti PHP ile gelen » libzip kütüphanesini gerektirir.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

PHP 5.2.0 ve sonrası

Linux sistemleri

Bu işlevleri kullanmak için PHP'yi --enable-zip yapılandırma seçeneğini kullanarak zip desteğiyle derlemelisiniz.

PHP 5.6.0 itibariyle sistemin libzip kurulumunu kullanmak için --with-libzip=DİZİN yapılandırma seçeneği eklenmiştir. Libzip 0.11 gerekli olup, 0.11.2 ve sonrası tavsiye edilir.

Windows

Windows kullanıcıları bu işlevleri kullanabilmek için php.ini içinde php_zip.dll'i etkin kılmalıdır.

PECL üzerinden kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/zip.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Özkaynak Türleri

Zip modülünde kullanılan iki özkaynak türü vardır. İlki, Zip arşivi için Zip dizini, ikincisi ise arşiv girdileri için Zip Girdisi'dir.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

ZipArchive, sınıf sabitleri kullanır. Üç çeşit sabit vardır: Seçenekler (FL_ önekli), hatalar (ER_ önekli) ve kipler (öneksiz).

ZIPARCHIVE::CREATE (integer)
Bir arşiv yoksa oluşturur.
ZIPARCHIVE::OVERWRITE (integer)
Daima yeni bir arşiv başlatır. Bir dosya varsa, bu kip dosyanın üzerine yazacaktır.
ZIPARCHIVE::EXCL (integer)
Arşiv mevcutsa hata verir.
ZIPARCHIVE::CHECKCONS (integer)
Arşiv üzerinde ek tutarlılık sınamaları yapar; sınamalar başarısız olursa hata verir.
ZIPARCHIVE::FL_NOCASE (integer)
İsim aramasında harf büyüklüğü dikkate alınmaz.
ZIPARCHIVE::FL_NODIR (integer)
Dizin bileşeni yok sayılır.
ZIPARCHIVE::FL_COMPRESSED (integer)
Sıkıştırılmış veri okunur.
ZIPARCHIVE::FL_UNCHANGED (integer)
Özgün veri kullanılır, değişiklikler dikkate alınmaz.
ZIPARCHIVE::CM_DEFAULT (integer)
Sıkıştırmak veya saklamaktan daha iyisi.
ZIPARCHIVE::CM_STORE (integer)
Sıkıştırmasız.
ZIPARCHIVE::CM_SHRINK (integer)
Sıkıştırmalı.
ZIPARCHIVE::CM_REDUCE_1 (integer)
1 çarpanıyla küçültülmüş.
ZIPARCHIVE::CM_REDUCE_2 (integer)
2 çarpanıyla küçültülmüş.
ZIPARCHIVE::CM_REDUCE_3 (integer)
3 çarpanıyla küçültülmüş.
ZIPARCHIVE::CM_REDUCE_4 (integer)
4 çarpanıyla küçültülmüş.
ZIPARCHIVE::CM_IMPLODE (integer)
Implode biçemli sıkıştırılmış.
ZIPARCHIVE::CM_DEFLATE (integer)
Deflate biçemli sıkıştırılmış.
ZIPARCHIVE::CM_DEFLATE64 (integer)
Deflate64 biçemli sıkıştırılmış.
ZIPARCHIVE::CM_PKWARE_IMPLODE (integer)
PKWARE implode biçemli sıkıştırılmış.
ZIPARCHIVE::CM_BZIP2 (integer)
BZIP2 algoritmasıyla sıkıştırılmış.
ZIPARCHIVE::ER_OK (integer)
Hata yok.
ZIPARCHIVE::ER_MULTIDISK (integer)
Çok diskli zip arşivleri desteklenmiyor.
ZIPARCHIVE::ER_RENAME (integer)
Geçici dosyanın ismi değiştirilemedi.
ZIPARCHIVE::ER_CLOSE (integer)
Zip arşivi kapatılamadı.
ZIPARCHIVE::ER_SEEK (integer)
Konumlama hatası.
ZIPARCHIVE::ER_READ (integer)
Okuma hatası.
ZIPARCHIVE::ER_WRITE (integer)
Yazma hatası.
ZIPARCHIVE::ER_CRC (integer)
CRC hatası
ZIPARCHIVE::ER_ZIPCLOSED (integer)
İçerilen zip arşivi kapalı.
ZIPARCHIVE::ER_NOENT (integer)
Böyle bir dosya yok.
ZIPARCHIVE::ER_EXISTS (integer)
Dosya zaten var.
ZIPARCHIVE::ER_OPEN (integer)
Dosya açılamadı.
ZIPARCHIVE::ER_TMPOPEN (integer)
Geçici dosya oluşturulamadı.
ZIPARCHIVE::ER_ZLIB (integer)
Zlib hatası.
ZIPARCHIVE::ER_MEMORY (integer)
Bellek ayırmada başarısızlık.
ZIPARCHIVE::ER_CHANGED (string)
Girdi değişmiş.
ZIPARCHIVE::ER_COMPNOTSUPP (integer)
Sıkıştırma yöntemi desteklenmiyor.
ZIPARCHIVE::ER_EOF (integer)
Dosya sonu eksik.
ZIPARCHIVE::ER_INVAL (integer)
Geçersiz değiştirge.
ZIPARCHIVE::ER_NOZIP (integer)
Bir zip arşivi değil.
ZIPARCHIVE::ER_INTERNAL (integer)
Dahili hata.
ZIPARCHIVE::ER_INCONS (integer)
Zip arşivi tutarsız.
ZIPARCHIVE::ER_REMOVE (integer)
Dosya silinemedi.
ZIPARCHIVE::ER_DELETED (integer)
Girdi silinmiş.
Özkaynak Türleri
Örnekler
Zip


Örnekler

Örnek 1 - Bir Zip arşivi oluşturmak

<?php

$zip = new ZipArchive();
$filename = "./test112.zip";

if ($zip->open($filename, ZIPARCHIVE::CREATE)!==TRUE) {
    exit("<$filename> açılamadı\n");
}

$zip->addFromString("testfilephp.txt" . time(),
    "#1 Bu, testfilephp.txt olarak eklenen bir deneme dizgesidir.\n");
$zip->addFromString("testfilephp2.txt" . time(),
    "#2 Bu, testfilephp2.txt olarak eklenen bir deneme dizgesidir.\n");
$zip->addFile($thisdir . "/too.php","/testfromfile.php");
echo "dosya sayısı: " . $zip->numFiles . "\n";
echo "durum:" . $zip->status . "\n";
$zip->close();
?>

Örnek 2 - Arşiv bilgilerinin dökümü ve listelenmesi

<?php
$za = new ZipArchive();

$za->open('test_with_comment.zip');
print_r($za);
var_dump($za);
echo "Dosya sayısı: " . $za->numFiles . "\n";
echo "Durumu: " . $za->status  . "\n";
echo "Sistem durumu: " . $za->statusSys . "\n";
echo "Dosya ismi: " . $za->filename . "\n";
echo "Açıklama: " . $za->comment . "\n";

for ($i=0; $i<$za->numFiles;$i++) {
    echo "İndis: $i\n";
    print_r($za->statIndex($i));
}
echo "Dosya sayısı:" . $za->numFiles . "\n";
?>

Örnek 3 - Zip akım sarmalayıcı; bir OpenOffice meta bilgisini okur

<?php
$reader = new XMLReader();

$reader->open('zip://' . dirname(__FILE__) . '/test.odt#meta.xml');
$odt_meta = array();
while ($reader->read()) {
    if ($reader->nodeType == XMLREADER::ELEMENT) {
        $elm = $reader->name;
    } else {
        if ($reader->nodeType == XMLREADER::END_ELEMENT &&
          $reader->name == 'office:meta') {
            break;
        }
        if (!trim($reader->value)) {
            continue;
        }
        $odt_meta[$elm] = $reader->value;
    }
}
print_r($odt_meta);
?>

Bu örnekte PHP 4'teki eski eklenti kullanılmıştır. Bir zip dosya arşivi açılmakta, arşivdeki her dosya okunup içeriği basılmaktadır. Bu örnekte ZZIPlib kaynak paketiyle dağıtılan deneme arşivlerinden test2.zip dosyası kullanılmıştır.

Örnek 4 - Zip kullanım örneği (PHP 4)

<?php

$zip = zip_open("/tmp/test2.zip");

if ($zip) {
    while ($zip_entry = zip_read($zip)) {
        echo "İsim:                " .
          zip_entry_name($zip_entry) . "\n";
        echo "Özgün dosya boyu:    " .
          zip_entry_filesize($zip_entry) . "\n";
        echo "Sıkıştırılmış boyut: " .
          zip_entry_compressedsize($zip_entry) . "\n";
        echo "Sıkıştırma yöntemi:  " .
          zip_entry_compressionmethod($zip_entry) . "\n";

        if (zip_entry_open($zip, $zip_entry, "r")) {
            echo "Dosya içeriği:\n";
            $buf = zip_entry_read($zip_entry, zip_entry_filesize($zip_entry));
            echo "$buf\n";

            zip_entry_close($zip_entry);
        }
        echo "\n";

    }

    zip_close($zip);

}
?>
Öntanımlı Sabitler
ZipArchive
Zip


ZipArchive sınıfı

(PHP 5 >= 5.2.0, PHP 7, PECL zip >= 1.1.0)

Giriş

Zip ile sıkıştırılmış bir dosya arşivi.

Sınıf Sözdizimi

ZipArchive {
/* Özellikler */
/* Yöntemler */
bool addEmptyDir ( string $dizin )
bool addFile ( string $dosya [, string $yerel_isim ] )
bool addFromString ( string $isim , string $içerik )
bool addGlob ( string $pattern [, int $flags = 0 [, array $options = array() ]] )
bool addPattern ( string $pattern [, string $path = "." [, array $options = array() ]] )
bool close ( void )
bool deleteIndex ( int $indis )
bool deleteName ( string $isim )
bool extractTo ( string $hedef [, mixed $girdiler ] )
string getArchiveComment ( void )
string getCommentIndex ( int $indis [, int $seçenekler ] )
string getCommentName ( string $isim [, int $seçenekler ] )
bool GetExternalAttributesIndex ( int $index , int &$opsys , int &$attr [, int $flags ] )
bool getExternalAttributesName ( string $name , int &$opsys , int &$attr [, int $flags ] )
mixed getFromIndex ( int $indis [, int $seçenekler ] )
mixed getFromName ( string $isim [, int $seçenekler ] )
string getNameIndex ( int $indis )
string GetStatusString ( void )
resource getStream ( string $name )
mixed locateName ( string $isim [, int $seçenekler ] )
mixed open ( string $dosya [, int $seçenekler ] )
bool renameIndex ( int $indis , string $yeni_isim )
bool renameName ( string $isim , string $yenisi )
mixed setArchiveComment ( string $açıklama )
mixed setCommentIndex ( int $indis , string $açıklama )
mixed setCommentName ( string $isim , string $açıklama )
bool setCompressionIndex ( int $index , int $comp_method [, int $comp_flags = 0 ] )
bool setCompressionName ( string $name , int $comp_method [, int $comp_flags = 0 ] )
bool setExternalAttributesIndex ( int $index , int $opsys , int $attr [, int $flags ] )
bool setExternalAttributesName ( string $name , int $opsys , int $attr [, int $flags ] )
public bool setPassword ( string $password )
mixed statIndex ( int $indis [, int $seçenekler ] )
mixed statName ( name $isim [, int $seçenekler ] )
mixed unchangeAll ( void )
mixed unchangeArchive ( void )
mixed unchangeIndex ( int $indis )
mixed unchangeName ( string $isim )
}

Özellikler

status

Zip Arşivinin durumu

statusSys

Zip Arşivinin sistem durumu

numFiles

Arşivdeki dosya sayısı

filename

Dosya sistemindeki dosya ismi

comment

Arşivle ilgili açıklama

İçindekiler

  • ZipArchive::addEmptyDir — Yeni bir dizin ekler
  • ZipArchive::addFile — Yolu belirtilen dosyayı arşive ekler
  • ZipArchive::addFromString — İsmi ve içeriği belirtilen dosyayı arşive ekler
  • ZipArchive::addGlob — Add files from a directory by glob pattern
  • ZipArchive::addPattern — Add files from a directory by PCRE pattern
  • ZipArchive::close — Etkin (açık veya oluşturulmuş) arşivi kapatır
  • ZipArchive::deleteIndex — İndisi belirtilen girdiyi siler
  • ZipArchive::deleteName — İsmi belirtilen girdiyi siler
  • ZipArchive::extractTo — Arşiv içeriğini çıkarır
  • ZipArchive::getArchiveComment — Zip arşivinin açıklamasını döndürür
  • ZipArchive::getCommentIndex — İndisi belirtilen girdinin açıklamasını döndürür
  • ZipArchive::getCommentName — İsmi belirtilen girdinin açıklamasını döndürür
  • ZipArchive::getExternalAttributesIndex — Retrieve the external attributes of an entry defined by its index
  • ZipArchive::getExternalAttributesName — Retrieve the external attributes of an entry defined by its name
  • ZipArchive::getFromIndex — İndisi belirtilen girdinin içeriğini döndürür
  • ZipArchive::getFromName — İsmi belirtilen girdinin içeriğini döndürür
  • ZipArchive::getNameIndex — İndisi belirtilen girdinin ismini döndürür
  • ZipArchive::GetStatusString — Durum hata iletilerini, sistem ve/veya zip iletilerini döndürür
  • ZipArchive::getStream — İsmi belirtilen girdi için dosya tanıtıcısı (salt okunur) döndürür
  • ZipArchive::locateName — İsmi belirtilen girdinin indisini döndürür
  • ZipArchive::open — Bir ZIP dosya arşivi açar
  • ZipArchive::renameIndex — İndisi belirtilen girdinin ismini değiştirir
  • ZipArchive::renameName — İsmi belirtilen girdinin ismini değiştirir
  • ZipArchive::setArchiveComment — Bir ZIP arşivine açıklama ekler
  • ZipArchive::setCommentIndex — İndisi belirtilen girdiye bir açıklama ekler
  • ZipArchive::setCommentName — İsmi belirtilen girdiye bir açıklama ekler
  • ZipArchive::setCompressionIndex — Set the compression method of an entry defined by its index
  • ZipArchive::setCompressionName — Set the compression method of an entry defined by its name
  • ZipArchive::setExternalAttributesIndex — Set the external attributes of an entry defined by its index
  • ZipArchive::setExternalAttributesName — Set the external attributes of an entry defined by its name
  • ZipArchive::setPassword — Set the password for the active archive
  • ZipArchive::statIndex — İndisi belirtilen girdiyle ilgili bilgileri döndürür
  • ZipArchive::statName — İsmi belirtilen girdiyle ilgili bilgileri döndürür
  • ZipArchive::unchangeAll — Arşivde yapılmış değişikliklerin tamamını geri alır
  • ZipArchive::unchangeArchive — Arşiv bilgilerinde yapılmış değişiklikleri geri alır
  • ZipArchive::unchangeIndex — İndisi belirtilen girdideki değişiklikleri geri alır
  • ZipArchive::unchangeName — İsmi belirtilen girdideki değişiklikleri geri alır
Örnekler
ZipArchive::addEmptyDir
Zip


Yeni bir dizin ekler

ZipArchive
ZipArchive::addFile
ZipArchive
PHP Manual

ZipArchive::addEmptyDir

(PHP 5 >= 5.2.0, PHP 7, PECL zip >= 1.8.0)

ZipArchive::addEmptyDir — Yeni bir dizin ekler

Açıklama

bool ZipArchive::addEmptyDir ( string $dizin )

Arşive boş bir dizin ekler.

Değiştirgeler

dizin

Eklenecek dizinin ismi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Bir arşivde boş bir dizin oluşturmak

<?php
$zip = new ZipArchive;
if ($zip->open('test.zip') === TRUE) {
    if($zip->addEmptyDir('newDirectory')) {
        echo 'Kök dizin oluşturuldu';
    } else {
        echo 'Dizin oluşturulamadı';
    }
    $zip->close();
} else {
    echo 'başarısız';
}
?>
ZipArchive
ZipArchive::addFile
ZipArchive


Yolu belirtilen dosyayı arşive ekler

ZipArchive::addEmptyDir
ZipArchive::addFromString
ZipArchive
PHP Manual

ZipArchive::addFile

(PHP 5 >= 5.2.0, PHP 7, PECL zip >= 1.1.0)

ZipArchive::addFile — Yolu belirtilen dosyayı arşive ekler

Açıklama

bool ZipArchive::addFile ( string $dosya [, string $yerel_isim ] )

Yolu belirtilen dosyayı arşive ekler.

Değiştirgeler

dosya

Eklenecek dosyanın yolu.

yerel_isim

Dosyanın ZIP arşivi içindeki ismi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Bu örnekte test.zip adında bir ZIP arşivi açılıp /path/to/index.txt dosyası newname.txt ismiyle arşive eklenmektedir.

Örnek 1 - Aç ve ekle

<?php
$zip = new ZipArchive;
if ($zip->open('test.zip') === TRUE) {
    $zip->addFile('/path/to/index.txt', 'newname.txt');
    $zip->close();
    echo 'Tamam';
} else {
    echo 'olmadı';
}
?>
ZipArchive::addEmptyDir
ZipArchive::addFromString
ZipArchive


İsmi ve içeriği belirtilen dosyayı arşive ekler

ZipArchive::addFile
ZipArchive::addGlob
ZipArchive
PHP Manual

ZipArchive::addFromString

(PHP 5 >= 5.2.0, PHP 7, PECL zip >= 1.1.0)

ZipArchive::addFromString — İsmi ve içeriği belirtilen dosyayı arşive ekler

Açıklama

bool ZipArchive::addFromString ( string $isim , string $içerik )

İsmi ve içeriği belirtilen dosyayı arşive ekler.

Değiştirgeler

isim

Oluşturulacak girdinin ismi.

içerik

Oluşturulacak girdinin içeriği. İkil olarak güvenli kipte yazılır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Arşive yeni bir girdi eklemek

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip', ZipArchive::CREATE);
if ($res === TRUE) {
    $zip->addFromString('test.txt', 'Bu dizge dosyanın içeriğidir.'');
    $zip->close();
    echo 'Tamam';
} else {
    echo 'olmadı';
}
?>

Örnek 2 - Bir dosyayı arşivdeki bir dizine eklemek

<?php
$zip = new ZipArchive;
if ($zip->open('test.zip') === TRUE) {
    $zip->addFromString('dir/test.txt', 'Bu dizge dosyanın içeriğidir.'');
    $zip->close();
    echo 'Tamam';
} else {
    echo 'olmadı';
}
?>
ZipArchive::addFile
ZipArchive::addGlob
ZipArchive


Add files from a directory by glob pattern

ZipArchive::addFromString
ZipArchive::addPattern
ZipArchive
PHP Manual

ZipArchive::addGlob

(PHP 5 >= 5.3.0, PHP 7, PECL zip >= 1.9.0)

ZipArchive::addGlob — Add files from a directory by glob pattern

Açıklama

bool ZipArchive::addGlob ( string $pattern [, int $flags = 0 [, array $options = array() ]] )

Add files from a directory which match the glob pattern.

Bilginize: For maximum portability, it is recommended to always use forward slashes (/) as directory separator in ZIP filenames.

Değiştirgeler

pattern

A glob() pattern against which files will be matched.

flags

A bit mask of glob() flags.

options

An associative array of options. Available options are:

  • "add_path"

    Prefix to prepend when translating to the local path of the file within the archive. This is applied after any remove operations defined by the "remove_path" or "remove_all_path" options.

  • "remove_path"

    Prefix to remove from matching file paths before adding to the archive.

  • "remove_all_path"

    TRUE to use the file name only and add to the root of the archive.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 ZipArchive::addGlob() example

Add all php scripts and text files from current working directory

<?php
$zip = new ZipArchive();
$ret = $zip->open('application.zip', ZipArchive::OVERWRITE);
if ($ret !== TRUE) {
    printf('Failed with code %d', $ret);
} else {
    $options = array('add_path' => 'sources/', 'remove_all_path' => TRUE);
    $zip->addGlob('*.{php,txt}', GLOB_BRACE, $options);
    $zip->close();
}
?>

Ayrıca Bakınız

  • ZipArchive::addFile() - Yolu belirtilen dosyayı arşive ekler
  • ZipArchive::addPattern() - Add files from a directory by PCRE pattern

ZipArchive::addFromString
ZipArchive::addPattern
ZipArchive


Add files from a directory by PCRE pattern

ZipArchive::addGlob
ZipArchive::close
ZipArchive
PHP Manual

ZipArchive::addPattern

(PHP 5 >= 5.3.0, PHP 7, PECL zip >= 1.9.0)

ZipArchive::addPattern — Add files from a directory by PCRE pattern

Açıklama

bool ZipArchive::addPattern ( string $pattern [, string $path = "." [, array $options = array() ]] )

Add files from a directory which match the regular expression pattern. The operation is not recursive. The pattern will be matched against the file name only.

Değiştirgeler

pattern

A PCRE pattern against which files will be matched.

path

The directory that will be scanned. Defaults to the current working directory.

options

An associative array of options accepted by ZipArchive::addGlob().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 ZipArchive::addPattern() example

Add all php scripts and text files from current directory

<?php
$zip = new ZipArchive();
$ret = $zip->open('application.zip', ZipArchive::OVERWRITE);
if ($ret !== TRUE) {
    printf('Failed with code %d', $ret);
} else {
    $directory = realpath('.');
    $options = array('add_path' => 'sources/', 'remove_path' => $directory);
    $zip->addPattern('/\.(?:php|txt)$/', $directory, $options);
    $zip->close();
}
?>

Ayrıca Bakınız

  • ZipArchive::addFile() - Yolu belirtilen dosyayı arşive ekler
  • ZipArchive::addGlob() - Add files from a directory by glob pattern

ZipArchive::addGlob
ZipArchive::close
ZipArchive


Etkin (açık veya oluşturulmuş) arşivi kapatır

ZipArchive::addPattern
ZipArchive::deleteIndex
ZipArchive
PHP Manual

ZipArchive::close

(PHP 5 >= 5.2.0, PHP 7, PECL zip >= 1.1.0)

ZipArchive::close — Etkin (açık veya oluşturulmuş) arşivi kapatır

Açıklama

bool ZipArchive::close ( void )

Açılmış veya yeni oluşturulmuş arşivi kapatır ve değişiklikleri kaydeder. Bu yöntem betiğin sonunda özdevinimli olarak çağrılır.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

ZipArchive::addPattern
ZipArchive::deleteIndex
ZipArchive


İndisi belirtilen girdiyi siler

ZipArchive::close
ZipArchive::deleteName
ZipArchive
PHP Manual

ZipArchive::deleteIndex

(PHP 5 >= 5.2.0, PHP 7, PECL zip >= 1.5.0)

ZipArchive::deleteIndex — İndisi belirtilen girdiyi siler

Açıklama

bool ZipArchive::deleteIndex ( int $indis )

İndisi belirtilen girdiyi arşivden siler.

Değiştirgeler

indis

Silinecek girdinin indisi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - İndisini kullanarak arşivden bir dosya silmek

<?php
$zip = new ZipArchive;
if ($zip->open('test.zip') === TRUE) {
    $zip->deleteIndex(2);
    $zip->close();
    echo 'Tamam';
} else {
    echo 'olmadı';
}
?>
ZipArchive::close
ZipArchive::deleteName
ZipArchive


İsmi belirtilen girdiyi siler

ZipArchive::deleteIndex
ZipArchive::extractTo
ZipArchive
PHP Manual

ZipArchive::deleteName

(PHP 5 >= 5.2.0, PHP 7, PECL zip >= 1.5.0)

ZipArchive::deleteName — İsmi belirtilen girdiyi siler

Açıklama

bool ZipArchive::deleteName ( string $isim )

İsmi belirtilen girdiyi arşivden siler.

Değiştirgeler

isim

Silinecek girdinin ismi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - İsmini kullanarak arşivden bir dosya silmek

<?php
$zip = new ZipArchive;
if ($zip->open('test1.zip') === TRUE) {
    $zip->deleteName('testfromfile.php');
    $zip->close();
    echo 'Tamam';
} else {
    echo 'olmadı';
}
?>
ZipArchive::deleteIndex
ZipArchive::extractTo
ZipArchive


Arşiv içeriğini çıkarır

ZipArchive::deleteName
ZipArchive::getArchiveComment
ZipArchive
PHP Manual

ZipArchive::extractTo

(PHP 5 >= 5.2.0, PHP 7, PECL zip >= 1.1.0)

ZipArchive::extractTo — Arşiv içeriğini çıkarır

Açıklama

bool ZipArchive::extractTo ( string $hedef [, mixed $girdiler ] )

Arşivin tamamını veya belirtilen dosyaları belirtilen hedefe çıkarır.

Değiştirgeler

hedef

Dosyaların çıkarılacağı yer.

girdiler

Çıkarılacak girdiler. Tek bir girdi ismi içeren bir dizge veya girdi isimlerini içeren bir dizi kabul eder.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnekte, bir ZIP dosya arşivi açılmakta, arşivdeki her dosyanın içeriği okunup basılmaktadır. Örnekte kullanılan test2.zip dosyası ZZIPlib kaynak paketiyle gelen deneme arşivlerinden biridir.

Örnek 1 - Tüm girdileri çıkarmak

<?php
$zip = new ZipArchive;
if ($zip->open('test.zip') === TRUE) {
    $zip->extractTo('/my/destination/dir/');
    $zip->close();
    echo 'Tamam';
} else {
    echo 'olmadı';
}
?>

Örnek 2 - Sadece iki girdi çıkarmak

<?php
$zip = new ZipArchive;
$res = $zip->open('test_im.zip');
if ($res === TRUE) {
    $zip->extractTo('/my/destination/dir/', array('pear_item.gif',
        'testfromfile.php'));
    $zip->close();
    echo 'Tamam';
} else {
    echo 'olmadı';
}
?>
ZipArchive::deleteName
ZipArchive::getArchiveComment
ZipArchive


Zip arşivinin açıklamasını döndürür

ZipArchive::extractTo
ZipArchive::getCommentIndex
ZipArchive
PHP Manual

ZipArchive::getArchiveComment

(PHP 5 >= 5.2.0, PHP 7, PECL zip >= 1.1.0)

ZipArchive::getArchiveComment — Zip arşivinin açıklamasını döndürür

Açıklama

string ZipArchive::getArchiveComment ( void )

Zip arşivinin açıklamasını döndürür.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarısızlık durumunda FALSE aksi takdirde açıklama dizgesi döner.

Örnekler

Örnek 1 - Bir arşiv açıklamasını basmak

<?php
$zip = new ZipArchive;
$res = $zip->open('test_with_comment.zip');
if ($res === TRUE) {
    var_dump($zip->getArchiveComment());
    /* Veya arşivin özelliğini kullanalım */
    var_dump($zip->comment);
} else {
    echo 'olmadı, kod:' . $res;
}
?>
ZipArchive::extractTo
ZipArchive::getCommentIndex
ZipArchive


İndisi belirtilen girdinin açıklamasını döndürür

ZipArchive::getArchiveComment
ZipArchive::getCommentName
ZipArchive
PHP Manual

ZipArchive::getCommentIndex

(PHP 5 >= 5.2.0, PHP 7, PECL zip >= 1.4.0)

ZipArchive::getCommentIndex — İndisi belirtilen girdinin açıklamasını döndürür

Açıklama

string ZipArchive::getCommentIndex ( int $indis [, int $seçenekler ] )

İndisi belirtilen girdinin açıklamasını döndürür.

Değiştirgeler

indis

Girdinin indisi.

seçenekler

Değer olarak ZIPARCHIVE::FL_UNCHANGED belirtilirse özgün açıklama döner.

Dönen Değerler

Başarısızlık durumunda FALSE aksi takdirde açıklama dizgesi döner.

Örnekler

Örnek 1 - Bir girdinin açıklamasını basmak

<?php
$zip = new ZipArchive;
$res = $zip->open('test1.zip');
if ($res === TRUE) {
    var_dump($zip->getCommentIndex(1));
} else {
    echo 'olmadı, kod:' . $res;
}
?>
ZipArchive::getArchiveComment
ZipArchive::getCommentName
ZipArchive


İsmi belirtilen girdinin açıklamasını döndürür

ZipArchive::getCommentIndex
ZipArchive::getExternalAttributesIndex
ZipArchive
PHP Manual

ZipArchive::getCommentName

(PHP 5 >= 5.2.0, PHP 7, PECL zip >= 1.4.0)

ZipArchive::getCommentName — İsmi belirtilen girdinin açıklamasını döndürür

Açıklama

string ZipArchive::getCommentName ( string $isim [, int $seçenekler ] )

İsmi belirtilen girdinin açıklamasını döndürür.

Değiştirgeler

isim

Girdinin ismi.

seçenekler

Değer olarak ZIPARCHIVE::FL_UNCHANGED belirtilirse özgün açıklama döner.

Dönen Değerler

Başarısızlık durumunda FALSE aksi takdirde açıklama dizgesi döner.

Örnekler

Örnek 1 - Bir girdinin açıklamasını basmak

<?php
$zip = new ZipArchive;
$res = $zip->open('test1.zip');
if ($res === TRUE) {
    var_dump($zip->getCommentName('test/entry1.txt'));
} else {
    echo 'olmadı, kod:' . $res;
}
?>
ZipArchive::getCommentIndex
ZipArchive::getExternalAttributesIndex
ZipArchive


Retrieve the external attributes of an entry defined by its index

ZipArchive::getCommentName
ZipArchive::getExternalAttributesName
ZipArchive
PHP Manual

ZipArchive::getExternalAttributesIndex

(PHP 5 >= 5.6.0, PHP 7, PECL zip >= 1.12.4)

ZipArchive::getExternalAttributesIndex — Retrieve the external attributes of an entry defined by its index

Açıklama

bool ZipArchive::GetExternalAttributesIndex ( int $index , int &$opsys , int &$attr [, int $flags ] )

Retrieve the external attributes of an entry defined by its index.

Değiştirgeler

index

Index of the entry.

opsys

On success, receive the operating system code defined by one of the ZipArchive::OPSYS_ constants.

attr

On success, receive the external attributes. Value depends on operating system.

flags

If flags is set to ZipArchive::FL_UNCHANGED, the original unchanged attributes are returned.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

This example extract all the entries of a ZIP archive test.zip and set the Unix rights from external attributes.

Örnek 1 Extract all entries with Unix rights

<?php
$zip = new ZipArchive();
if ($zip->open('test.zip') === TRUE) {
    for ($idx=0 ; $s = $zip->statIndex($idx) ; $idx++) {
        if ($zip->extractTo('.', $s['name'])) {
            if ($zip->getExternalAttributesIndex($idx, $opsys, $attr)
                && $opsys==ZipArchive::OPSYS_UNIX) {
               chmod($s['name'], ($attr >> 16) & 0777);
            }
        }
    }
    $zip->close();
    echo "Ok\n";
} else {
    echo "KO\n";
}
?>
ZipArchive::getCommentName
ZipArchive::getExternalAttributesName
ZipArchive


Retrieve the external attributes of an entry defined by its name

ZipArchive::getExternalAttributesIndex
ZipArchive::getFromIndex
ZipArchive
PHP Manual

ZipArchive::getExternalAttributesName

(PHP 5 >= 5.6.0, PHP 7, PECL zip >= 1.12.4)

ZipArchive::getExternalAttributesName — Retrieve the external attributes of an entry defined by its name

Açıklama

bool ZipArchive::getExternalAttributesName ( string $name , int &$opsys , int &$attr [, int $flags ] )

Retrieve the external attributes of an entry defined by its name.

Değiştirgeler

name

Name of the entry.

opsys

On success, receive the operating system code defined by one of the ZipArchive::OPSYS_ constants.

attr

On success, receive the external attributes. Value depends on operating system.

flags

If flags is set to ZipArchive::FL_UNCHANGED, the original unchanged attributes are returned.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

ZipArchive::getExternalAttributesIndex
ZipArchive::getFromIndex
ZipArchive


İndisi belirtilen girdinin içeriğini döndürür

ZipArchive::getExternalAttributesName
ZipArchive::getFromName
ZipArchive
PHP Manual

ZipArchive::getFromIndex

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

ZipArchive::getFromIndex — İndisi belirtilen girdinin içeriğini döndürür

Açıklama

mixed ZipArchive::getFromIndex ( int $indis [, int $seçenekler ] )

İndisi belirtilen girdinin içeriğini döndürür.

Değiştirgeler

indis

Girdi indisi.

seçenekler

Arşivi açmakta kullanılacak seçenekler, Aşağıdaki sabitler VEYAlanarak belirtilir:

  • ZIPARCHIVE::FL_UNCHANGED

  • ZIPARCHIVE::FL_COMPRESSED

Dönen Değerler

Başarısızlık durumunda FALSE aksi takdirde girdinin içeriği döner.

Örnekler

Örnek 1 - Dosya içeriğini basmak

<?php
$zip = new ZipArchive;
if ($zip->open('test.zip') === TRUE) {
    echo $zip->getFromIndex(2);
    $zip->close();
} else {
    echo 'olmadı';
}
?>
ZipArchive::getExternalAttributesName
ZipArchive::getFromName
ZipArchive


İsmi belirtilen girdinin içeriğini döndürür

ZipArchive::getFromIndex
ZipArchive::getNameIndex
ZipArchive
PHP Manual

ZipArchive::getFromName

(PHP 5 >= 5.2.0, PHP 7, PECL zip >= 1.1.0)

ZipArchive::getFromName — İsmi belirtilen girdinin içeriğini döndürür

Açıklama

mixed ZipArchive::getFromName ( string $isim [, int $seçenekler ] )

İsmi belirtilen girdinin içeriğini döndürür.

Değiştirgeler

isim

Girdinin ismi.

seçenekler

Arşivi açmakta kullanılacak seçenekler, Aşağıdaki sabitler VEYAlanarak belirtilir:

  • ZIPARCHIVE::FL_UNCHANGED

  • ZIPARCHIVE::FL_COMPRESSED

Dönen Değerler

Başarısızlık durumunda FALSE aksi takdirde girdinin içeriği döner.

Örnekler

Örnek 1 - Dosya içeriğinin basılması

<?php
$zip = new ZipArchive;
if ($zip->open('test1.zip') === TRUE) {
    echo $zip->getFromName('testfromfile.php');
    $zip->close();
} else {
    echo 'failed';
}
?>

Örnek 2 - Bir zip girdisindeki resimde dönüşüm

<?php
$z = new ZipArchive();
if ($z->open(dirname(__FILE__) . '/test_im.zip')) {
    $im_string = $z->getFromName("pear_item.gif");
    $im = imagecreatefromstring($im_string);
    imagepng($im, 'b.png');
}
?>
ZipArchive::getFromIndex
ZipArchive::getNameIndex
ZipArchive


İndisi belirtilen girdinin ismini döndürür

ZipArchive::getFromName
ZipArchive::GetStatusString
ZipArchive
PHP Manual

ZipArchive::getNameIndex

(PHP 5 >= 5.2.0, PHP 7, PECL zip >= 1.5.0)

ZipArchive::getNameIndex — İndisi belirtilen girdinin ismini döndürür

Açıklama

string ZipArchive::getNameIndex ( int $indis )

İndisi belirtilen girdinin ismini döndürür.

Değiştirgeler

indis

Girdi indisi.

Dönen Değerler

Başarısızlık durumunda FALSE aksi takdirde girdinin ismi döner.

ZipArchive::getFromName
ZipArchive::GetStatusString
ZipArchive


Durum hata iletilerini, sistem ve/veya zip iletilerini döndürür

ZipArchive::getNameIndex
ZipArchive::getStream
ZipArchive
PHP Manual

ZipArchive::GetStatusString

(PHP 5 >= 5.2.7, PHP 7)

ZipArchive::GetStatusString — Durum hata iletilerini, sistem ve/veya zip iletilerini döndürür

Açıklama

string ZipArchive::GetStatusString ( void )

Durum hata iletilerini, sistem ve/veya zip iletilerini döndürür

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarısızlık durumunda FALSE yoksa bir dizge döner.

ZipArchive::getNameIndex
ZipArchive::getStream
ZipArchive


İsmi belirtilen girdi için dosya tanıtıcısı (salt okunur) döndürür

ZipArchive::GetStatusString
ZipArchive::locateName
ZipArchive
PHP Manual

ZipArchive::getStream

(PHP 5 >= 5.2.0, PHP 7, PECL zip >= 1.1.0)

ZipArchive::getStream — İsmi belirtilen girdi için dosya tanıtıcısı (salt okunur) döndürür

Açıklama

resource ZipArchive::getStream ( string $name )

İsmi belirtilen girdi için dosya tanıtıcısı döndürür. Şimdilik sadece okuma işlemleri desteklenmektedir.

Değiştirgeler

isim

Kullanılacak girdinin ismi.

Dönen Değerler

Başarısızlık durumunda FALSE aksi takdirde girdinin dosya tanıtıcısı döner.

Örnekler

Örnek 1 - Girdi içeriğini fread() ile alıp saklamak

<?php
$content = '';
$z = new ZipArchive();
if ($z->open('test.zip')) {
    $fp = $z->getStream('test');
    if(!$fp) exit("olmadı\n");

    while (!feof($fp)) {
        $contents .= fread($fp, 2);
    }

    fclose($fp);
    file_put_contents('t',$contents);
    echo "bitti.\n";
}
?>

Örnek 2 - fopen() ve zip akım sarmalayıcı kullanmak dışında yukarıdaki ile aynı

<?php
$fp = fopen('zip://' . dirname(__FILE__) . '/test.zip#test', 'r');
if (!$fp) {
    exit("açılamadı\n");
}
while (!feof($fp)) {
    $contents .= fread($fp, 2);
    echo "$contents\n";
}
fclose($fp);
echo "bitti.\n";
?>

Örnek 3 - Akım sarmalayıcı ve resim, XML işleviyle de kullanılabilir

<?php
$im = imagecreatefromgif('zip://' . dirname(__FILE__) . '/test_im.zip#pear_item.gif');
imagepng($im, 'a.png');
?>
ZipArchive::GetStatusString
ZipArchive::locateName
ZipArchive


İsmi belirtilen girdinin indisini döndürür

ZipArchive::getStream
ZipArchive::open
ZipArchive
PHP Manual

ZipArchive::locateName

(PHP 5 >= 5.2.0, PHP 7, PECL zip >= 1.5.0)

ZipArchive::locateName — İsmi belirtilen girdinin indisini döndürür

Açıklama

mixed ZipArchive::locateName ( string $isim [, int $seçenekler ] )

İsmi belirtilen girdinin indisini döndürür.

Değiştirgeler

isim

Girdinin ismi.

seçenekler

İsmin nasıl aranacağı aşağıdaki sabitlerden oluşan bir bit maskesi olarak belirtilir. Hiçbiri belirtilmeyecekse 0 belirtilir.

  • ZIPARCHIVE::FL_NOCASE

  • ZIPARCHIVE::FL_NODIR

Dönen Değerler

Başarısızlık durumunda FALSE aksi takdirde girdinin indisi döner.

Örnekler

Örnek 1 - Bir arşiv oluşturup üzerinde ZipArchive::locateName() kullanmak

<?php
$file = 'testlocate.zip';

$zip = new ZipArchive;
if ($zip->open($file, ZIPARCHIVE::CREATE) !== TRUE) {
    exit('failed');
}

$zip->addFromString('entry1.txt', 'girdi #1');
$zip->addFromString('entry2.txt', 'girdi #2');
$zip->addFromString('dir/entry2d.txt', 'girdi #2');

if (!$zip->status == ZIPARCHIVE::ER_OK) {
    echo "ZIP yazılamadı\n";
}
$zip->close();

if ($zip->open($file) !== TRUE) {
    exit('Olmadı');
}

echo $zip->locateName('entry1.txt') . "\n";
echo $zip->locateName('eNtry2.txt') . "\n";
echo $zip->locateName('eNtry2.txt', ZIPARCHIVE::FL_NOCASE) . "\n";
echo $zip->locateName('enTRy2d.txt',
     ZIPARCHIVE::FL_NOCASE|ZIPARCHIVE::FL_NODIR) . "\n";
$zip->close();

?>

Yukarıdaki örneğin çıktısı:

0

1
2
ZipArchive::getStream
ZipArchive::open
ZipArchive


Bir ZIP dosya arşivi açar

ZipArchive::locateName
ZipArchive::renameIndex
ZipArchive
PHP Manual

ZipArchive::open

(PHP 5 >= 5.2.0, PHP 7, PECL zip >= 1.1.0)

ZipArchive::open — Bir ZIP dosya arşivi açar

Açıklama

mixed ZipArchive::open ( string $dosya [, int $seçenekler ] )

Okumak, yazmak veya değiştirmek amacıyla bir zip arşivi açar.

Değiştirgeler

dosya

Açılacak ZIP arşivinin dosya ismi.

seçenekler

Arşivin açılacağı kip; şu sabitlerden biridir:

  • ZIPARCHIVE::OVERWRITE

  • ZIPARCHIVE::CREATE

  • ZIPARCHIVE::EXCL

  • ZIPARCHIVE::CHECKCONS

Dönen Değerler

Başarı durumunda TRUE yoksa hata kodu döner.

Hata kodları

  • ZIPARCHIVE::ER_EXISTS

  • ZIPARCHIVE::ER_INCONS

  • ZIPARCHIVE::ER_INVAL

  • ZIPARCHIVE::ER_MEMORY

  • ZIPARCHIVE::ER_NOENT

  • ZIPARCHIVE::ER_NOZIP

  • ZIPARCHIVE::ER_OPEN

  • ZIPARCHIVE::ER_READ

  • ZIPARCHIVE::ER_SEEK

Örnekler

Örnekte, bir ZIP dosya arşivi açılmakta, arşivdeki her dosyanın içeriği okunup basılmaktadır. Örnekte kullanılan test2.zip dosyası ZZIPlib kaynak paketiyle gelen deneme arşivlerinden biridir.

Örnek 1 - Bir arşivi açıp içeriğini dökmek

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip');
if ($res === TRUE) {
    echo 'Tamam';
    $zip->extractTo('test');
    $zip->close();
} else {
    echo 'Olmadı, kod:' . $res;
}
?>

Örnek 2 - Bir arşiv oluşturmak

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip', ZipArchive::CREATE);
if ($res === TRUE) {
    $zip->addFromString('test.txt', 'Bu dizge dosyanın içeriğidir.');
    $zip->addFile('data.txt', 'entryname.txt');
    $zip->close();
    echo 'Tamam';
} else {
    echo 'Olmadı';
}
?>
ZipArchive::locateName
ZipArchive::renameIndex
ZipArchive


İndisi belirtilen girdinin ismini değiştirir

ZipArchive::open
ZipArchive::renameName
ZipArchive
PHP Manual

ZipArchive::renameIndex

(PHP 5 >= 5.2.0, PHP 7, PECL zip >= 1.5.0)

ZipArchive::renameIndex — İndisi belirtilen girdinin ismini değiştirir

Açıklama

bool ZipArchive::renameIndex ( int $indis , string $yeni_isim )

İndisi belirtilen girdinin ismini değiştirir.

Değiştirgeler

indis

İsmi değiştirilecek girdinin indisi.

yeni_isim

Girdinin yeni ismi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Bir girdinin ismini değiştirmek

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip');
if ($res === TRUE) {
    $zip->renameIndex(2,'newname.txt');
    $zip->close();
} else {
    echo 'olmadı, kod:' . $res;
}
?>
ZipArchive::open
ZipArchive::renameName
ZipArchive


İsmi belirtilen girdinin ismini değiştirir

ZipArchive::renameIndex
ZipArchive::setArchiveComment
ZipArchive
PHP Manual

ZipArchive::renameName

(PHP 5 >= 5.2.0, PHP 7, PECL zip >= 1.5.0)

ZipArchive::renameName — İsmi belirtilen girdinin ismini değiştirir

Açıklama

bool ZipArchive::renameName ( string $isim , string $yenisi )

İsmi belirtilen girdinin ismini değiştirir.

Değiştirgeler

isim

Girdinin değiştirilecek ismi.

yenisi

Girdinin yeni ismi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Bir girdinin ismini değiştirmek

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip');
if ($res === TRUE) {
    $zip->renameName('currentname.txt','newname.txt');
    $zip->close();
} else {
    echo 'Olmadı, kod:' . $res;
}
?>
ZipArchive::renameIndex
ZipArchive::setArchiveComment
ZipArchive


Bir ZIP arşivine açıklama ekler

ZipArchive::renameName
ZipArchive::setCommentIndex
ZipArchive
PHP Manual

ZipArchive::setArchiveComment

(PHP 5 >= 5.2.0, PHP 7, PECL zip >= 1.4.0)

ZipArchive::setArchiveComment — Bir ZIP arşivine açıklama ekler

Açıklama

mixed ZipArchive::setArchiveComment ( string $açıklama )

Bir ZIP arşivine açıklama ekler.

Değiştirgeler

açıklama

Açıklamanın içeriği.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Bir arşiv oluşturup bir açıklama eklemek

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip', ZipArchive::CREATE);
if ($res === TRUE) {
    $zip->addFromString('test.txt', 'Bu dizge dosyanın içeriğidir.');
    $zip->setArchiveComment('Yeni arşiv açıklaması');
    $zip->close();
    echo 'Tamam';
} else {
    echo 'Olmadı';
}
?>
ZipArchive::renameName
ZipArchive::setCommentIndex
ZipArchive


İndisi belirtilen girdiye bir açıklama ekler

ZipArchive::setArchiveComment
ZipArchive::setCommentName
ZipArchive
PHP Manual

ZipArchive::setCommentIndex

(PHP 5 >= 5.2.0, PHP 7, PECL zip >= 1.4.0)

ZipArchive::setCommentIndex — İndisi belirtilen girdiye bir açıklama ekler

Açıklama

mixed ZipArchive::setCommentIndex ( int $indis , string $açıklama )

İndisi belirtilen girdiye bir açıklama ekler.

Değiştirgeler

indis

Girdi indisi.

açıklama

Açıklamanın içeriği.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Bir arşiv açıp bir girdiye açıklama eklemek

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip');
if ($res === TRUE) {
    $zip->setCommentIndex(2, 'yeni girdi açıklaması');
    $zip->close();
    echo 'Tamam';
} else {
    echo 'Olmadı';
}
?>
ZipArchive::setArchiveComment
ZipArchive::setCommentName
ZipArchive


İsmi belirtilen girdiye bir açıklama ekler

ZipArchive::setCommentIndex
ZipArchive::setCompressionIndex
ZipArchive
PHP Manual

ZipArchive::setCommentName

(PHP 5 >= 5.2.0, PHP 7, PECL zip >= 1.4.0)

ZipArchive::setCommentName — İsmi belirtilen girdiye bir açıklama ekler

Açıklama

mixed ZipArchive::setCommentName ( string $isim , string $açıklama )

İsmi belirtilen girdiye bir açıklama ekler.

Değiştirgeler

isim

Girdinin ismi.

açıklama

Açıklamanın içeriği.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Bir arşiv açıp bir girdiye açıklama eklemek

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip');
if ($res === TRUE) {
    $zip->setCommentName('entry1.txt', 'yeni girdi açıklaması');
    $zip->close();
    echo 'Tamam';
} else {
    echo 'Olmadı';
}
?>
ZipArchive::setCommentIndex
ZipArchive::setCompressionIndex
ZipArchive


Set the compression method of an entry defined by its index

ZipArchive::setCommentName
ZipArchive::setCompressionName
ZipArchive
PHP Manual

ZipArchive::setCompressionIndex

(PHP 7, PECL zip >= 1.13.0)

ZipArchive::setCompressionIndex — Set the compression method of an entry defined by its index

Açıklama

bool ZipArchive::setCompressionIndex ( int $index , int $comp_method [, int $comp_flags = 0 ] )

Set the compression method of an entry defined by its index.

Değiştirgeler

index

Index of the entry.

comp_method

The compression method. Either
ZipArchive::CM_DEFAULT,
ZipArchive::CM_STORE or
ZipArchive::CM_DEFLATE.

comp_flags

Compression flags. Currently unused.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Add files with different compression methods to an archive

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip', ZipArchive::CREATE);
if ($res === TRUE) {
    $zip->addFromString('foo', 'Some text');
    $zip->addFromString('bar', 'Some other text');
    $zip->setCompressionIndex(0, ZipArchive::CM_STORE);
    $zip->setCompressionIndex(1, ZipArchive::CM_DEFLATE);
    $zip->close();
    echo 'ok';
} else {
    echo 'failed';
}
?>
ZipArchive::setCommentName
ZipArchive::setCompressionName
ZipArchive


Set the compression method of an entry defined by its name

ZipArchive::setCompressionIndex
ZipArchive::setExternalAttributesIndex
ZipArchive
PHP Manual

ZipArchive::setCompressionName

(PHP 7, PECL zip >= 1.13.0)

ZipArchive::setCompressionName — Set the compression method of an entry defined by its name

Açıklama

bool ZipArchive::setCompressionName ( string $name , int $comp_method [, int $comp_flags = 0 ] )

Set the compression method of an entry defined by its name.

Değiştirgeler

name

Name of the entry.

comp_method

The compression method. Either
ZipArchive::CM_DEFAULT,
ZipArchive::CM_STORE or
ZipArchive::CM_DEFLATE.

comp_flags

Compression flags. Currently unused.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Add files with different compression methods to an archive

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip', ZipArchive::CREATE);
if ($res === TRUE) {
    $zip->addFromString('foo', 'Some text');
    $zip->addFromString('bar', 'Some other text');
    $zip->setCompressionName('foo', ZipArchive::CM_STORE);
    $zip->setCompressionName('bar', ZipArchive::CM_DEFLATE);
    $zip->close();
    echo 'ok';
} else {
    echo 'failed';
}
?>
ZipArchive::setCompressionIndex
ZipArchive::setExternalAttributesIndex
ZipArchive


Set the external attributes of an entry defined by its index

ZipArchive::setCompressionName
ZipArchive::setExternalAttributesName
ZipArchive
PHP Manual

ZipArchive::setExternalAttributesIndex

(PHP 5 >= 5.6.0, PHP 7, PECL zip >= 1.12.4)

ZipArchive::setExternalAttributesIndex — Set the external attributes of an entry defined by its index

Açıklama

bool ZipArchive::setExternalAttributesIndex ( int $index , int $opsys , int $attr [, int $flags ] )

Set the external attributes of an entry defined by its index.

Değiştirgeler

index

Index of the entry.

opsys

The operating system code defined by one of the ZipArchive::OPSYS_ constants.

attr

The external attributes. Value depends on operating system.

flags

Optional flags. Currently unused.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

ZipArchive::setCompressionName
ZipArchive::setExternalAttributesName
ZipArchive


Set the external attributes of an entry defined by its name

ZipArchive::setExternalAttributesIndex
ZipArchive::setPassword
ZipArchive
PHP Manual

ZipArchive::setExternalAttributesName

(PHP 5 >= 5.6.0, PHP 7, PECL zip >= 1.12.4)

ZipArchive::setExternalAttributesName — Set the external attributes of an entry defined by its name

Açıklama

bool ZipArchive::setExternalAttributesName ( string $name , int $opsys , int $attr [, int $flags ] )

Set the external attributes of an entry defined by its name.

Değiştirgeler

name

Name of the entry.

opsys

The operating system code defined by one of the ZipArchive::OPSYS_ constants.

attr

The external attributes. Value depends on operating system.

flags

Optional flags. Currently unused.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

This example opens a ZIP file archive test.zip and add the file test.txt with its Unix rights as external attributes.

Örnek 1 Archive a file, with its Unix rights

<?php
$zip = new ZipArchive();
$stat = stat($filename='test.txt');
if (is_array($stat) && $zip->open('test.zip', ZipArchive::CREATE) === TRUE) {
    $zip->addFile($filename);
    $zip->setExternalAttributesName($filename, ZipArchive::OPSYS_UNIX, $stat['mode'] << 16);
    $zip->close();
    echo "Ok\n";
} else {
    echo "KO\n";
}
?>
ZipArchive::setExternalAttributesIndex
ZipArchive::setPassword
ZipArchive


Set the password for the active archive

ZipArchive::setExternalAttributesName
ZipArchive::statIndex
ZipArchive
PHP Manual

ZipArchive::setPassword

(PHP 5 >= 5.6.0, PHP 7, PECL zip >= 1.12.4)

ZipArchive::setPassword — Set the password for the active archive

Açıklama

public bool ZipArchive::setPassword ( string $password )

Sets the password for the active archive.

Değiştirgeler

password

The password to be used for the archive.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

Bilginize:

This function only sets the password to be used to decompress the archive; it does not turn a non-password-protected ZipArchive into a password-protected ZipArchive.

ZipArchive::setExternalAttributesName
ZipArchive::statIndex
ZipArchive


İndisi belirtilen girdiyle ilgili bilgileri döndürür

ZipArchive::setPassword
ZipArchive::statName
ZipArchive
PHP Manual

ZipArchive::statIndex

(PHP 5 >= 5.2.0, PHP 7, PECL zip >= 1.1.0)

ZipArchive::statIndex — İndisi belirtilen girdiyle ilgili bilgileri döndürür

Açıklama

mixed ZipArchive::statIndex ( int $indis [, int $seçenekler ] )

İndisi belirtilen girdiyle ilgili bilgileri döndürür.

Değiştirgeler

indis

Girdi indisi.

seçenekler

Değişiklikleri yok sayarak arşivin özgün dosyası hakkında bilgi istemek için ZIPARCHIVE::FL_UNCHANGED sabiti bit maskesine dahil edilebilir.

Dönen Değerler

Başarısızlık durumunda FALSE aksi takdirde girdi ile ilgili ayrıntıları içeren bir dizi döner.

Örnekler

Örnek 1 - Bir girdiyli ilgili bilgilerin dökümü

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip');
if ($res === TRUE) {
    print_r($zip->statIndex(3));
    $zip->close();
} else {
    echo 'Başarısız. Çıkış kodu:' . $res;
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [name] => foobar/baz
    [index] => 3
    [crc] => 499465816
    [size] => 27
    [mtime] => 1123164748
    [comp_size] => 24
    [comp_method] => 8
)
ZipArchive::setPassword
ZipArchive::statName
ZipArchive


İsmi belirtilen girdiyle ilgili bilgileri döndürür

ZipArchive::statIndex
ZipArchive::unchangeAll
ZipArchive
PHP Manual

ZipArchive::statName

(PHP 5 >= 5.2.0, PHP 7, PECL zip >= 1.5.0)

ZipArchive::statName — İsmi belirtilen girdiyle ilgili bilgileri döndürür

Açıklama

mixed ZipArchive::statName ( name $isim [, int $seçenekler ] )

İsmi belirtilen girdiyle ilgili bilgileri döndürür.

Değiştirgeler

isim

Girdi ismi.

seçenekler

İsmin nasıl aranacağı aşağıdaki sabitlerden oluşan bir bit maskesi olarak belirtilir. Ayrıca, değişiklikleri yok sayarak arşivin özgün dosyası hakkında bilgi istemek için ZIPARCHIVE::FL_UNCHANGED sabiti de bit maskesine dahil edilebilir. Sabitlerin açıklamalarını Öntanımlı Sabitler sayfasında bulabilirsiniz.

  • ZIPARCHIVE::FL_NOCASE

  • ZIPARCHIVE::FL_NODIR

  • ZIPARCHIVE::FL_UNCHANGED

Dönen Değerler

Başarısızlık durumunda FALSE aksi takdirde girdi ile ilgili ayrıntıları içeren bir dizi döner.

Örnekler

Örnek 1 - Bir girdiyli ilgili bilgilerin dökümü

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip');
if ($res === TRUE) {
    print_r($zip->statName('foobar/baz'));
    $zip->close();
} else {
    echo 'Başarısız. Çıkış kodu:' . $res;
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [name] => foobar/baz
    [index] => 3
    [crc] => 499465816
    [size] => 27
    [mtime] => 1123164748
    [comp_size] => 24
    [comp_method] => 8
)
ZipArchive::statIndex
ZipArchive::unchangeAll
ZipArchive


Arşivde yapılmış değişikliklerin tamamını geri alır

ZipArchive::statName
ZipArchive::unchangeArchive
ZipArchive
PHP Manual

ZipArchive::unchangeAll

(PHP 5 >= 5.2.0, PHP 7, PECL zip >= 1.1.0)

ZipArchive::unchangeAll — Arşivde yapılmış değişikliklerin tamamını geri alır

Açıklama

mixed ZipArchive::unchangeAll ( void )

Arşivde yapılmış değişikliklerin tamamını geri alır.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

ZipArchive::statName
ZipArchive::unchangeArchive
ZipArchive


Arşiv bilgilerinde yapılmış değişiklikleri geri alır

ZipArchive::unchangeAll
ZipArchive::unchangeIndex
ZipArchive
PHP Manual

ZipArchive::unchangeArchive

(PHP 5 >= 5.2.0, PHP 7, PECL zip >= 1.1.0)

ZipArchive::unchangeArchive — Arşiv bilgilerinde yapılmış değişiklikleri geri alır

Açıklama

mixed ZipArchive::unchangeArchive ( void )

Arşiv bilgilerinde yapılmış değişiklikleri geri alır. Şimdilik sadece açıklama değişiklikleri geri alınabilmektedir.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

ZipArchive::unchangeAll
ZipArchive::unchangeIndex
ZipArchive


İndisi belirtilen girdideki değişiklikleri geri alır

ZipArchive::unchangeArchive
ZipArchive::unchangeName
ZipArchive
PHP Manual

ZipArchive::unchangeIndex

(PHP 5 >= 5.2.0, PHP 7, PECL zip >= 1.1.0)

ZipArchive::unchangeIndex — İndisi belirtilen girdideki değişiklikleri geri alır

Açıklama

mixed ZipArchive::unchangeIndex ( int $indis )

İndisi belirtilen girdideki değişiklikleri geri alır.

Değiştirgeler

indis

Girdi indisi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

ZipArchive::unchangeArchive
ZipArchive::unchangeName
ZipArchive


İsmi belirtilen girdideki değişiklikleri geri alır

ZipArchive::unchangeIndex
Zip İşlevleri
ZipArchive
PHP Manual

ZipArchive::unchangeName

(PHP 5 >= 5.2.0, PHP 7, PECL zip >= 1.5.0)

ZipArchive::unchangeName — İsmi belirtilen girdideki değişiklikleri geri alır

Açıklama

mixed ZipArchive::unchangeName ( string $isim )

Belirtilen girdide yapılmış değişiklikleri geri alır.

Değiştirgeler

isim

Girdinin ismi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

ZipArchive::unchangeIndex
Zip İşlevleri
ZipArchive


Zip İşlevleri

İçindekiler

  • zip_close — Bir ZIP dosya arşivini kapatır
  • zip_entry_close — Bir dizin girdisini kapatır
  • zip_entry_compressedsize — Dizin girdisinin sıkıştırılmış uzunluğunu döndürür
  • zip_entry_compressionmethod — Dizin girdisinin sıkıştırma yöntemini döndürür
  • zip_entry_filesize — Bir dizin girdisinin uzunluğunu döndürür
  • zip_entry_name — Bir dizin girdisinin ismini döndürür
  • zip_entry_open — Okumak için bir dizin girdisi açar
  • zip_entry_read — Bir açık dizin girdisini okur
  • zip_open — Bir ZIP dosya arşivi açar
  • zip_read — Bir ZIP dosya arşivindeki bir sonraki girdiyi okur
ZipArchive::unchangeName
zip_close
Zip


Bir ZIP dosya arşivini kapatır

Zip İşlevleri
zip_entry_close
Zip İşlevleri
PHP Manual

zip_close

(PHP 4 >= 4.1.0, PHP 5 >= 5.2.0, PHP 7, PECL zip >= 1.0.0)

zip_close — Bir ZIP dosya arşivini kapatır

Açıklama

void zip_close ( resource $zip )

Belirtilen ZIP dosya arşivini kapatır.

Değiştirgeler

zip

zip_open() ile açılmış bir ZIP dosyası.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • zip_open() - Bir ZIP dosya arşivi açar
  • zip_read() - Bir ZIP dosya arşivindeki bir sonraki girdiyi okur

Zip İşlevleri
zip_entry_close
Zip İşlevleri


Bir dizin girdisini kapatır

zip_close
zip_entry_compressedsize
Zip İşlevleri
PHP Manual

zip_entry_close

(PHP 4 >= 4.1.0, PHP 5 >= 5.2.0, PHP 7, PECL zip >= 1.0.0)

zip_entry_close — Bir dizin girdisini kapatır

Açıklama

bool zip_entry_close ( resource $zip_girdisi )

Belirtilen dizin girdisini kapatır.

Değiştirgeler

zip_girdisi

zip_entry_open() ile açılmış bir dizin girdisi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • zip_entry_open() - Okumak için bir dizin girdisi açar
  • zip_entry_read() - Bir açık dizin girdisini okur

zip_close
zip_entry_compressedsize
Zip İşlevleri


Dizin girdisinin sıkıştırılmış uzunluğunu döndürür

zip_entry_close
zip_entry_compressionmethod
Zip İşlevleri
PHP Manual

zip_entry_compressedsize

(PHP 4 >= 4.1.0, PHP 5 >= 5.2.0, PHP 7, PECL zip >= 1.0.0)

zip_entry_compressedsize — Dizin girdisinin sıkıştırılmış uzunluğunu döndürür

Açıklama

int zip_entry_compressedsize ( resource $zip_girdisi )

Belirtilen dizin girdisinin sıkıştırılmış uzunluğunu döndürür.

Değiştirgeler

zip_girdisi

zip_read() ile döndürülmüş bir dizin girdisi.

Dönen Değerler

Sıkıştırılmış uzunluk..

Ayrıca Bakınız

  • zip_open() - Bir ZIP dosya arşivi açar
  • zip_read() - Bir ZIP dosya arşivindeki bir sonraki girdiyi okur

zip_entry_close
zip_entry_compressionmethod
Zip İşlevleri


Dizin girdisinin sıkıştırma yöntemini döndürür

zip_entry_compressedsize
zip_entry_filesize
Zip İşlevleri
PHP Manual

zip_entry_compressionmethod

(PHP 4 >= 4.1.0, PHP 5 >= 5.2.0, PHP 7, PECL zip >= 1.0.0)

zip_entry_compressionmethod — Dizin girdisinin sıkıştırma yöntemini döndürür

Açıklama

string zip_entry_compressionmethod ( resource $zip_girdisi )

zip_girdisi ile belirtilen dizin girdisinin sıkıştırma yöntemini döndürür.

Değiştirgeler

zip_girdisi

zip_read() ile döndürülmüş bir dizin girdisi.

Dönen Değerler

Sıkıştırma yöntemi.

Ayrıca Bakınız

  • zip_open() - Bir ZIP dosya arşivi açar
  • zip_read() - Bir ZIP dosya arşivindeki bir sonraki girdiyi okur

zip_entry_compressedsize
zip_entry_filesize
Zip İşlevleri


Bir dizin girdisinin uzunluğunu döndürür

zip_entry_compressionmethod
zip_entry_name
Zip İşlevleri
PHP Manual

zip_entry_filesize

(PHP 4 >= 4.1.0, PHP 5 >= 5.2.0, PHP 7, PECL zip >= 1.0.0)

zip_entry_filesize — Bir dizin girdisinin uzunluğunu döndürür

Açıklama

int zip_entry_filesize ( resource $zip_girdisi )

Belirtilen dizin girdisinin asıl uzunluğunu döndürür.

Değiştirgeler

zip_girdisi

zip_read() ile döndürülmüş bir dizin girdisi.

Dönen Değerler

Dizin girdisinin uzunluğu.

Ayrıca Bakınız

  • zip_open() - Bir ZIP dosya arşivi açar
  • zip_read() - Bir ZIP dosya arşivindeki bir sonraki girdiyi okur

zip_entry_compressionmethod
zip_entry_name
Zip İşlevleri


Bir dizin girdisinin ismini döndürür

zip_entry_filesize
zip_entry_open
Zip İşlevleri
PHP Manual

zip_entry_name

(PHP 4 >= 4.1.0, PHP 5 >= 5.2.0, PHP 7, PECL zip >= 1.0.0)

zip_entry_name — Bir dizin girdisinin ismini döndürür

Açıklama

string zip_entry_name ( resource $zip_girdisi )

Belirtilen dizin girdisinin ismini döndürür.

Değiştirgeler

zip_entry

zip_read() ile döndürülmüş bir dizin girdisi.

Dönen Değerler

Dizin girdisinin ismi.

Ayrıca Bakınız

  • zip_open() - Bir ZIP dosya arşivi açar
  • zip_read() - Bir ZIP dosya arşivindeki bir sonraki girdiyi okur

zip_entry_filesize
zip_entry_open
Zip İşlevleri


Okumak için bir dizin girdisi açar

zip_entry_name
zip_entry_read
Zip İşlevleri
PHP Manual

zip_entry_open

(PHP 4 >= 4.1.0, PHP 5 >= 5.2.0, PHP 7, PECL zip >= 1.0.0)

zip_entry_open — Okumak için bir dizin girdisi açar

Açıklama

bool zip_entry_open ( resource $zip , resource $zip_girdisi [, string $kip ] )

Bir zip dosyasında okumak için bir dizin girdisi açar.

Değiştirgeler

zip

zip_open() ile döndürülmüş geçerli bir dosya tanıtıcısı.

zip_girdisi

zip_read() ile döndürülmüş bir dizin girdisi.

kip

fopen() belgesinde belirtilen kiplerden biri.

Bilginize:

Normalde, kip yoksayılıp daima "rb" kipi kullanılır. Bunun sebebi PHP'deki zip desteğinin sadece okuma erişimi sağlamasıdır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Bilginize:

fopen() ve benzerlerinen aksine, zip_entry_open() işlevinin dönüş değeri sadece işlemin sonucunu gösterir ve dizin girdisini okumak veya kapatmak için gerekli değildir.

Ayrıca Bakınız

  • zip_entry_close() - Bir dizin girdisini kapatır
  • zip_entry_read() - Bir açık dizin girdisini okur

zip_entry_name
zip_entry_read
Zip İşlevleri


Bir açık dizin girdisini okur

zip_entry_open
zip_open
Zip İşlevleri
PHP Manual

zip_entry_read

(PHP 4 >= 4.1.0, PHP 5 >= 5.2.0, PHP 7, PECL zip >= 1.0.0)

zip_entry_read — Bir açık dizin girdisini okur

Açıklama

string zip_entry_read ( resource $zip_girdisi [, int $uzunluk ] )

Açık bir dizin girdisini okur.

Değiştirgeler

zip_girdisi

zip_read() ile döndürülmüş bir dizin girdisi.

uzunluk

Döndürülecek bayt sayısı. Belirtilmediği takdirde işlev 1024 bayt okumaya çalışır.

Bilginize:

Bu sıkıştırılmamış uzunluk olmalıdır.

Dönen Değerler

Dosya sonuna gelinmişse FALSE yoksa okunan veriyi bir dizge olarak döndürür.

Ayrıca Bakınız

  • zip_entry_open() - Okumak için bir dizin girdisi açar
  • zip_entry_close() - Bir dizin girdisini kapatır
  • zip_entry_filesize() - Bir dizin girdisinin uzunluğunu döndürür

zip_entry_open
zip_open
Zip İşlevleri


Bir ZIP dosya arşivi açar

zip_entry_read
zip_read
Zip İşlevleri
PHP Manual

zip_open

(PHP 4 >= 4.1.0, PHP 5 >= 5.2.0, PHP 7, PECL zip >= 1.0.0)

zip_open — Bir ZIP dosya arşivi açar

Açıklama

mixed zip_open ( string $dosya_adı )

Okumak için yeni bir ZIP dosya arşivi açar.

Değiştirgeler

dosya_adı

Açılacak ZIP arşivinin dosya ismi.

Dönen Değerler

Normalde, daha sonra zip_read() ve zip_close() ile kullanmak üzere bir dosya tanıtıcısı döndürür. dosya_adı diye bir dosya yoksa veya başka bir hata varsa hata numarası döner.

Ayrıca Bakınız

  • zip_read() - Bir ZIP dosya arşivindeki bir sonraki girdiyi okur
  • zip_close() - Bir ZIP dosya arşivini kapatır

zip_entry_read
zip_read
Zip İşlevleri


Bir ZIP dosya arşivindeki bir sonraki girdiyi okur

zip_open
Zlib Eklentisi
Zip İşlevleri
PHP Manual

zip_read

(PHP 4 >= 4.1.0, PHP 5 >= 5.2.0, PHP 7, PECL zip >= 1.0.0)

zip_read — Bir ZIP dosya arşivindeki bir sonraki girdiyi okur

Açıklama

mixed zip_read ( resource $zip )

Bir ZIP dosya arşivindeki bir sonraki girdiyi okur.

Değiştirgeler

zip

zip_open() ile açılmış bir ZIP dosyası.

Dönen Değerler

Normalde, daha sonra zip_entry_... işlevleri ile kullanmak üzere bir dizin girdisi özkaynağı döndürür. Okunacak girdi yoksa FALSE, bir hata oluşmuşsa hatanın numarasını döndürür.

Ayrıca Bakınız

  • zip_open() - Bir ZIP dosya arşivi açar
  • zip_close() - Bir ZIP dosya arşivini kapatır
  • zip_entry_open() - Okumak için bir dizin girdisi açar
  • zip_entry_read() - Bir açık dizin girdisini okur

zip_open
Zlib Eklentisi
Zip İşlevleri


Zlib Sıkıştırması

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
  • Zlib İşlevleri
    • deflate_add — Incrementally deflate data
    • deflate_init — Initialize an incremental deflate context
    • gzclose — Bir açık gzipli dosya tanıtıcısını kapar
    • gzcompress — Bir dizgeyi sıkıştırır
    • gzdecode — Gzipli bir dizgenin sıkıştırmasını açar
    • gzdeflate — Bir dizgeyi deflate biçeminde sıkıştırır
    • gzencode — Gzipli bir dizge oluşturur
    • gzeof — Gzipli dosya tanıtıcında dosya sonunu sınar
    • gzfile — Gzipli dosyayı bir dizi içinde döndürür
    • gzgetc — Gzipli dosya göstericisindeki karakteri döndürür
    • gzgets — Gzipli dosya tanıtıcısından bir satır döndürür
    • gzgetss — Gzipli dosya tanıtıcısından bir satır okuyup HTML etiketlerinden arındırır
    • gzinflate — Deflate sıkıştırmalı bir verinin sıkıştırmasını açar
    • gzopen — Bir gzipli dosya açar
    • gzpassthru — Gzipli dosya tanıtıcısında kalan verinin tamamını çıktılar
    • gzputs — gzwrite işlevinin takma adıdır
    • gzread — Gzipli dosyayı ikil kipte okur
    • gzrewind — Gzipli dosya göstericisini dosya başlangıcına taşır
    • gzseek — Gzipli dosya göstericisini konumlar
    • gztell — Gzipli dosya tanıtıcısının okuma/yazma konumunu döndürür
    • gzuncompress — Sıkıştırılmış bir dizgenin sıkıştırmasını açar
    • gzwrite — Bir dizgeyi bir gzipli dosyaya ikil kipte yazar
    • inflate_add — Incrementally inflate encoded data
    • inflate_init — Initialize an incremental inflate context
    • readgzfile — Bir .gz dosyası çıktılar
    • zlib_decode — Uncompress any raw/gzip/zlib encoded data
    • zlib_encode — Compress data with the specified encoding
    • zlib_get_coding_type — Çıktı sıkıştırması için kullanılan kodlama türünü döndürür
zip_read
Giriş
Sıkıştırma ve Arşivleme Eklentileri


Giriş

Bu modül, gzip sıkıştırmalı dosyalarla (sıkıştırılmamış olanlarla da fakat soketlerle değil) çalışabilen dosya sistemi işlevlerinin bazıları üzerinden gzip (.gz) sıkıştırmalı dosyaların okunup yazılabilmesini sağlar.

Bilginize:

4.0.4 sürümünde .gz dosyaları için bir fopen sarmalayıcısı devreye girmiştir. fopen() çağrısı sırasında dosya ismini veya dosya yolunu zlib: ile öncelerseniz normal f*() dosya erişim işlevlerini kullanarak sıkıştırılmış dosyalara şeffaf olarak erişmek için özel zlib: URL'lerini kullanabilirsiniz. Bu özellik, fopencookie() işlevini sağlayan bir C çalışma anı kütüphanesi gerektirir. Bu işlevi sağlayan tek kütüphane halen GNU libc kütüphanesidir.

PHP 4.3.0 sürümünden beri, ':' içeren dosya isimlerinden dolayı ortaya çıkan tuhaflıkları gidermek için zlib: yerine compress.zlib:// kullanılmaktadır. fopencookie() işlevine artık gerek kalmamıştır. Bu konuda daha fazla bilgi için zlib:// bölümüne bakınız.

Zlib Eklentisi
Yapılandırma/Kurulum
Zlib Eklentisi


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Zlib Eklentisi


Gereksinimler

Bu modül, Jean-loup Gailly ve Mark Adler tarafından geliştirilen » zlib işlevlerini kullanır. Bu modül ile zlib'in 1.0.9'dan sonraki sürümlerini kullanmalısınız.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Zlib desteği PHP'de öntanımlı olarak etkin değildir. Etkin olması için PHP'yi --with-zlib[=DiZiN] seçeneği ile derlemelisiniz.

PHP'nin Windows sürümünde bu eklenti yerleşik olarak gelmektedir. Bu işlevleri Windows'ta kullanmak için herhangi bir eklenti kurmanıza gerek yoktur.

Bilginize: Windows üzerinde yerleşik zlib desteği PHP 4.3.0'dan beri mevcuttur.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Zlib eklentisi, istek yapan tarayıcı desteklediği takdirde, sayfaların şeffaf olarak sıkıştırılmasını sağlar. Eklentinin php.ini yapılandırma dosyasında üç yönergesi vardır.

Zlib Yapılandırma Yönergeleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
zlib.output_compression | "0" | PHP_INI_ALL | PHP 4.0.5'dan beri kullanılabilmektedir.
zlib.output_compression_level | "-1" | PHP_INI_ALL | PHP 4.3.0'dan beri kullanılabilmektedir.
zlib.output_handler | "" | PHP_INI_ALL | PHP 4.3.0'dan beri kullanılabilmektedir.
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

zlib.output_compression boolean/integer

Sayfanın şeffaf olarak sıkıştırılıp sıkıştırılmayacağı. Bu yönergeye php.ini içinde veya Apache yapılandırmasında "On" değerini belirtirseniz ve tarayıcı istek yaparken bir "Accept-Encoding: gzip" veya "deflate" başlığı gönderirse sayfalar sıkıştırılır ve çıktıya istek yapılan başlığa göre (sırasıyla) "Content-Encoding: gzip" veya "Vary: Accept-Encoding" başlığı eklenir. Çalışma anında herhangi bir çıktı göndermeden önce de bu yönergeye "On" atanabilir.

Bu seçenek "On"/"Off" değerlerinden başka tamsayı değerler de kabul eder. Tamsayı değerle çıktı tamponunun boyutunu belirleyebilirsiniz (öntanımlı olarak 4 kB'tır).

Bilginize:

Bu yönergeye "On" atandığı takdirde output_handler boş olmalıdır! Yerine zlib.output_handler kullanılmalıdır.

zlib.output_compression_level integer

Çıktının şeffaf olarak sıkıştırılması için kullanılacak sıkıştırma seviyesi. 0 (sıkıştırma yok) ile 9 (en fazla sıkıştırma) arasında bir değer olarak belirtilir. Öntanımlı değer -1 olup, kullanılacak sıkıştırma seviyesine sunucu karar verir.

zlib.output_handler string

php.ini dosyanızda zlib.output_compression yönergesini etkin kılmışsanız ek çıktı eylemcileri belirtemezsiniz. Bu ayar output_handler gibi yapılır fakat birlikle kullanılamazlar.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Özkaynak Türleri

Bu eklenti gzopen() işlevinden dönen bir dosya tanıtıcısı tanımlar.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

FORCE_GZIP (integer)
FORCE_DEFLATE (integer)
Özkaynak Türleri
Örnekler
Zlib Eklentisi


Örnekler

Bu örnek geçici bir dosya açar ve içine bir deneme dizgesi yazdıktan sonra dosya içeriğini iki defa basar.

Örnek 1 - Küçük bir Zlib örneği

<?php

$filename = tempnam('/tmp', 'zlibtest') . '.gz';
echo "<html>\n<head></head>\n<body>\n<pre>\n";
$s = "Only a test, test, test, test, test, test, test, test!\n";

// dosyayı azami sıkıştırmayla açalım
$zp = gzopen($filename, "w9");

// dizgeyi dosyaya yazalım
gzwrite($zp, $s);

// dosyayı kapatalım
gzclose($zp);

// dosyayı okumak için açalım
$zp = gzopen($filename, "r");

// 3 karakter okuyalım
echo gzread($zp, 3);

// dosyayı sonuna kadar çıktılayıp kapatalım.
gzpassthru($zp);
gzclose($zp);

echo "\n";

// dosyayı açıp içeriğini basalım (ikinci kez).
if (readgzfile($filename) != strlen($s)) {
        echo "Zlib işlevlerinde hata!";
}
unlink($filename);
echo "</pre>\n</body>\n</html>\n";

?>
Öntanımlı Sabitler
Zlib İşlevleri
Zlib Eklentisi


Zlib İşlevleri

İçindekiler

  • deflate_add — Incrementally deflate data
  • deflate_init — Initialize an incremental deflate context
  • gzclose — Bir açık gzipli dosya tanıtıcısını kapar
  • gzcompress — Bir dizgeyi sıkıştırır
  • gzdecode — Gzipli bir dizgenin sıkıştırmasını açar
  • gzdeflate — Bir dizgeyi deflate biçeminde sıkıştırır
  • gzencode — Gzipli bir dizge oluşturur
  • gzeof — Gzipli dosya tanıtıcında dosya sonunu sınar
  • gzfile — Gzipli dosyayı bir dizi içinde döndürür
  • gzgetc — Gzipli dosya göstericisindeki karakteri döndürür
  • gzgets — Gzipli dosya tanıtıcısından bir satır döndürür
  • gzgetss — Gzipli dosya tanıtıcısından bir satır okuyup HTML etiketlerinden arındırır
  • gzinflate — Deflate sıkıştırmalı bir verinin sıkıştırmasını açar
  • gzopen — Bir gzipli dosya açar
  • gzpassthru — Gzipli dosya tanıtıcısında kalan verinin tamamını çıktılar
  • gzputs — gzwrite işlevinin takma adıdır
  • gzread — Gzipli dosyayı ikil kipte okur
  • gzrewind — Gzipli dosya göstericisini dosya başlangıcına taşır
  • gzseek — Gzipli dosya göstericisini konumlar
  • gztell — Gzipli dosya tanıtıcısının okuma/yazma konumunu döndürür
  • gzuncompress — Sıkıştırılmış bir dizgenin sıkıştırmasını açar
  • gzwrite — Bir dizgeyi bir gzipli dosyaya ikil kipte yazar
  • inflate_add — Incrementally inflate encoded data
  • inflate_init — Initialize an incremental inflate context
  • readgzfile — Bir .gz dosyası çıktılar
  • zlib_decode — Uncompress any raw/gzip/zlib encoded data
  • zlib_encode — Compress data with the specified encoding
  • zlib_get_coding_type — Çıktı sıkıştırması için kullanılan kodlama türünü döndürür
Örnekler
deflate_add
Zlib Eklentisi


Incrementally deflate data

Zlib İşlevleri
deflate_init
Zlib İşlevleri
PHP Manual

deflate_add

(PHP 7)

deflate_add — Incrementally deflate data

Açıklama

string deflate_add ( resource $context , string $data [, int $flush_mode = ZLIB_SYNC_FLUSH ] )

Incrementally deflates data in the specified context.

Değiştirgeler

context

A context created with deflate_init().

data

A chunk of data to compress.

flush_mode

One of ZLIB_BLOCK, ZLIB_NO_FLUSH, ZLIB_PARTIAL_FLUSH, ZLIB_SYNC_FLUSH (default), ZLIB_FULL_FLUSH, ZLIB_FINISH. Normally you will want to set ZLIB_NO_FLUSH to maximize compression, and ZLIB_FINISH to terminate with the last chunk of data. See the » zlib manual for a detailed description of these constants.

Dönen Değerler

Returns a chunk of compressed data, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

If invalid arguments are given, an error of level E_WARNING is generated.

Ayrıca Bakınız

  • deflate_init() - Initialize an incremental deflate context
Zlib İşlevleri
deflate_init
Zlib İşlevleri


Initialize an incremental deflate context

deflate_add
gzclose
Zlib İşlevleri
PHP Manual

deflate_init

(PHP 7)

deflate_init — Initialize an incremental deflate context

Açıklama

resource deflate_init ( int $encoding [, array $options = array() ] )

Initializes an incremental deflate context using the specified encoding.

Note that the window option here only sets the window size of the algorithm, differently from the zlib filters where the same parameter also sets the encoding to use; the encoding must be set with the encoding parameter.

Limitation: there is currently no way to set the header information on a GZIP compressed stream, which are set as follows: GZIP signature (\x1f\x8B); compression method (\x08 == DEFLATE); 6 zero bytes; the operating system set to the current system (\x00 = Windows, \x03 = Unix, etc.)

Değiştirgeler

encoding

One of the ZLIB_ENCODING_* constants.

options

An associative array which may contain the following elements:

level

The compression level in range -1..9; defaults to -1.

memory

The compression memory level in range 1..9; defaults to 8.

window

The zlib window size (logarithmic) in range 8..15; defaults to 15.

strategy

One of ZLIB_FILTERED, ZLIB_HUFFMAN_ONLY, ZLIB_RLE, ZLIB_FIXED or ZLIB_DEFAULT_STRATEGY (the default).

dictionary

A string or an array of strings of the preset dictionary (default: no preset dictionary).

Dönen Değerler

Returns a deflate context resource (zlib.deflate) on success, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

If an invalid option is passed to options or the context couldn't be created, an error of level E_WARNING is generated.

Ayrıca Bakınız

  • deflate_add() - Incrementally deflate data
  • inflate_init() - Initialize an incremental inflate context
deflate_add
gzclose
Zlib İşlevleri


Bir açık gzipli dosya tanıtıcısını kapar

deflate_init
gzcompress
Zlib İşlevleri
PHP Manual

gzclose

(PHP 4, PHP 5, PHP 7)

gzclose — Bir açık gzipli dosya tanıtıcısını kapar

Açıklama

bool gzclose ( resource $dt )

Belirtilen dosya tanıtıcısını kapatır.

Değiştirgeler

dt

Gzipli dosya tanıtıcısı. gzopen() tarafından açılmış bir dosyayı gösteren geçerli bir tanıtıcı olmalıdır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - gzclose() örneği

<?php
$gz = gzopen('birdosya.gz','w9');
gzputs ($gz, 'birdosya.gz dosyasına eklenecek veri');
gzclose($gz);
?>

Ayrıca Bakınız

  • gzopen() - Bir gzipli dosya açar

deflate_init
gzcompress
Zlib İşlevleri


Bir dizgeyi sıkıştırır

gzclose
gzdecode
Zlib İşlevleri
PHP Manual

gzcompress

(PHP 4 >= 4.0.1, PHP 5, PHP 7)

gzcompress — Bir dizgeyi sıkıştırır

Açıklama

string gzcompress ( string $veri [, int $seviye = -1 [, int $kodlama = ZLIB_ENCODING_DEFLATE ]] )

Bu işlev belirtilen dizgeyi ZLIB veri biçemini kullanarak sıkıştırır.

ZLIB sıkıştırma algoritması hakkında daha ayrıntılı bilgi edinmek için "» ZLIB Sıkıştırılmış Veri Biçemi Belirtiminin 3.3 sürümü" (RFC 1950) belgesine bakınız.

Bilginize:

Bu biçem bir takım başlık verileri içeren gzip sıkıştırması ile aynı değildir. Gzip sıkıştırması için gzencode() işlevine bakınız.

Değiştirgeler

veri

Sıkıştırılacak veri.

seviye

Sıkıştırma seviyesi. Sıkıştırma olmayacağını belirtmek için 0, azami sıkıştırma için 9'a kadar değer belirtilebilir.

-1 belitilirse, zlib kütüphanesinin 6 olan öntanımlı sıkıştırması kullanılır.

kodlama

ZLIB_ENCODING_* sabitlerinden biri.

Dönen Değerler

Bir hata oluşursa FALSE aksi takdirde sıkıştırılmış dizgeyi döndürür.

Örnekler

Örnek 1 - gzcompress() örneği

<?php
$sıkıveri = gzcompress('Sıkıştırılacak veri', 9);
echo $sıkıveri;
?>

Sürüm Bilgisi

Sürüm: | Açıklama
5.4.0 | kodlama değiştirgesi eklendi.

Ayrıca Bakınız

  • gzdeflate() - Bir dizgeyi deflate biçeminde sıkıştırır
  • gzinflate() - Deflate sıkıştırmalı bir verinin sıkıştırmasını açar
  • gzuncompress() - Sıkıştırılmış bir dizgenin sıkıştırmasını açar
  • gzencode() - Gzipli bir dizge oluşturur

gzclose
gzdecode
Zlib İşlevleri


Gzipli bir dizgenin sıkıştırmasını açar

gzcompress
gzdeflate
Zlib İşlevleri
PHP Manual

gzdecode

(PHP 5 >= 5.4.0, PHP 7)

gzdecode — Gzipli bir dizgenin sıkıştırmasını açar

Açıklama

string gzdecode ( string $veri [, int $uzunluk ] )

Belirtilen veri dizgesinin gzip sıkıştırmalı biçemini döndürür.

Değiştirgeler

veri

gzencode() tarafından sıkıştırılmış veri.

uzunluk

Kodu çözülecek verinin azami uzunluğu.

Dönen Değerler

Bir hata oluşursa FALSE aksi takdirde sıkıştırılmamış dizgeyi döndürür.

Ayrıca Bakınız

  • gzencode() - Gzipli bir dizge oluşturur

gzcompress
gzdeflate
Zlib İşlevleri


Bir dizgeyi deflate biçeminde sıkıştırır

gzdecode
gzencode
Zlib İşlevleri
PHP Manual

gzdeflate

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gzdeflate — Bir dizgeyi deflate biçeminde sıkıştırır

Açıklama

string gzdeflate ( string $veri [, int $seviye = -1 [, int $kodlama = ZLIB_ENCODING_RAW ]] )

Bu işlev belirtilen veriyi DEFLATE veri biçemini kullanarak sıkıştırır.

DEFLATE sıkıştırma algoritması hakkında daha ayrıntılı bilgi edinmek için "» DEFLATE Sıkıştırılmış Veri Biçemi Belirtiminin 1.3 sürümü" (RFC 1951) belgesine bakınız.

Değiştirgeler

data

Sıkıştırılacak veri.

seviye

Sıkıştırma seviyesi. Sıkıştırma olmayacağını belirtmek için 0, azami sıkıştırma için 9'a kadar değer belirtilebilir. Belirtilmezse, öntanımlı sıkıştırma seviyesi zlib kütüphanesinin öntanımlı sıkıştırma seviyesine eşit olacaktır.

kodlama

ZLIB_ENCODING_* sabitlerinden biri.

Dönen Değerler

Bir hata oluşursa FALSE aksi takdirde sıkıştırılmış dizgeyi döndürür.

Örnekler

Örnek 1 - gzdeflate() örneği

<?php
$sıkıveri = gzdeflate('Sıkıştırılacak veri', 9);
echo $sıkıveri;
?>

Sürüm Bilgisi

Sürüm: | Açıklama
5.4.0 | kodlama değiştirgesi eklendi.

Ayrıca Bakınız

  • gzinflate() - Deflate sıkıştırmalı bir verinin sıkıştırmasını açar
  • gzcompress() - Bir dizgeyi sıkıştırır
  • gzuncompress() - Sıkıştırılmış bir dizgenin sıkıştırmasını açar
  • gzencode() - Gzipli bir dizge oluşturur

gzdecode
gzencode
Zlib İşlevleri


Gzipli bir dizge oluşturur

gzdeflate
gzeof
Zlib İşlevleri
PHP Manual

gzencode

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gzencode — Gzipli bir dizge oluşturur

Açıklama

string gzencode ( string $veri [, int $seviye = -1 [, int $kodlama_kipi = FORCE_GZIP ]] )

Bu işlev veri dizgesinin gzip programının çıktısı ile uyumlu olarak sıkıştırılmış halini döndürür.

GZIP sıkıştırma algoritması hakkında daha ayrıntılı bilgi edinmek için "» GZIP Sıkıştırılmış Dosya Biçemi Belirtiminin 4.3 sürümü" (RFC 1952) belgesine bakınız.

Değiştirgeler

veri

Sıkıştırılacak veri.

seviye

Sıkıştırma seviyesi. Sıkıştırma olmayacağını belirtmek için 0, azami sıkıştırma için 9'a kadar değer belirtilebilir. Belirtilmezse, öntanımlı sıkıştırma seviyesi zlib kütüphanesinin öntanımlı sıkıştırma seviyesine eşit olacaktır.

kodlama_kipi

Kodlama kipi. FORCE_GZIP (öntanımlı) veya FORCE_DEFLATE olabilir.

PHP 5.4.0 öncesinde, FORCE_DEFLATE kullanımı, sonunda crc32 sınama toplamı bulunmayan gzip dosya başlığı altında standart zlib deflate biçemli (zlib başlıkları dahil) bir dizge ile sonuçlanırdı.

PHP 5.4.0 ve sonrasında, FORCE_DEFLATE bir zlib başlığı, deflate biçemli veri ve bir Adler sağlama toplamından oluşan RFC 1950 uyumlu bir çıktı üretir.

Dönen Değerler

Bir hata oluşursa FALSE aksi takdirde sıkıştırılmış dizgeyi döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
5.4.0 | FORCE_DEFLATE artık RFC 1950 uyumlu bir çıktı üretiyor.

Örnekler

Sonuçlanan dizge, standart bir .gz dosyasının içerebileceği uygun başlıkları ve veri yapısını içerir.

Örnek 1 - Bir gzip dosyası oluşturmak

<?php
$veri = implode("", file("iridosya.txt"));
$sıkıveri = gzencode($veri, 9);
$dt = fopen("iridosya.txt.gz", "w");
fwrite($dt, $sıkıveri);
fclose($dt);
?>

Ayrıca Bakınız

  • gzdecode() - Gzipli bir dizgenin sıkıştırmasını açar
  • gzdeflate() - Bir dizgeyi deflate biçeminde sıkıştırır
  • gzinflate() - Deflate sıkıştırmalı bir verinin sıkıştırmasını açar
  • gzuncompress() - Sıkıştırılmış bir dizgenin sıkıştırmasını açar
  • gzcompress() - Bir dizgeyi sıkıştırır
  • » ZLIB Sıkıştırmalı Veri Biçemi Belirtimi (RFC 1950)

gzdeflate
gzeof
Zlib İşlevleri


Gzipli dosya tanıtıcında dosya sonunu sınar

gzencode
gzfile
Zlib İşlevleri
PHP Manual

gzeof

(PHP 4, PHP 5, PHP 7)

gzeof — Gzipli dosya tanıtıcında dosya sonunu sınar

Açıklama

int gzeof ( resource $dt )

Gzipli dosya tanıtıcısında dosya sonuna gelinmişse TRUE döndürür.

Değiştirgeler

dt

Gzipli dosya tanıtıcısı. gzopen() tarafından açılmış bir dosyayı gösteren geçerli bir tanıtıcı olmalıdır.

Dönen Değerler

Gzipli dosya tanıtıcısında dosya sonuna gelinmişse veya bir hata oluşmuşsa TRUE aksi takdirde FALSE döndürür.

Örnekler

Örnek 1 - gzeof() örneği

<?php
$gz = gzopen('birdosya.gz', 'r');
while (!gzeof($gz)) {
  echo gzgetc($gz);
}
gzclose($gz);
?>

gzencode
gzfile
Zlib İşlevleri


Gzipli dosyayı bir dizi içinde döndürür

gzeof
gzgetc
Zlib İşlevleri
PHP Manual

gzfile

(PHP 4, PHP 5, PHP 7)

gzfile — Gzipli dosyayı bir dizi içinde döndürür

Açıklama

array gzfile ( string $dosyaismi [, int $include_path_kullan = 0 ] )

Dosyanın içeriğini bir dizide döndürmesi dışında readgzfile() ile aynıdır.

Değiştirgeler

dosyaismi

Okunacak dosyanın ismi.

include_path_kullan

Bu isteğe bağlı değiştirgeyle 1 değerini aktarırsanız dosyanın include_path yönergesindeki yollarda da aranmasını sağlamış olursunuz.

Dönen Değerler

Her elemanında bir satır olmak üzere dosyayı içeren dizi ile döner.

Örnekler

Örnek 1 - gzfile() örneği

<?php
$satırlar = gzfile('birdosya.gz');
foreach ($satırlar as $satır) {
    echo $satır;
}
?>

Ayrıca Bakınız

  • readgzfile() - Bir .gz dosyası çıktılar
  • gzopen() - Bir gzipli dosya açar

gzeof
gzgetc
Zlib İşlevleri


Gzipli dosya göstericisindeki karakteri döndürür

gzfile
gzgets
Zlib İşlevleri
PHP Manual

gzgetc

(PHP 4, PHP 5, PHP 7)

gzgetc — Gzipli dosya göstericisindeki karakteri döndürür

Açıklama

string gzgetc ( resource $dt )

Dosya tanıtıcı belirtilen akımdan (sıkıştırılmamış) tek bir karakter içeren bir dizge döndürür.

Değiştirgeler

dt

Gzipli dosya tanıtıcısı. gzopen() tarafından açılmış bir dosyayı gösteren geçerli bir tanıtıcı olmalıdır.

Dönen Değerler

Sıkıştırılmamış karakteri veya (gzeof()'tan farklı olarak) dosya sonuna gelinmişse FALSE döndürür.

Örnekler

Örnek 1 - gzgetc() örneği

<?php
$gz = gzopen('birdosya.gz', 'r');
while (!gzeof($gz)) {
  echo gzgetc($gz);
}
gzclose($gz);
?>

Ayrıca Bakınız

  • gzopen() - Bir gzipli dosya açar
  • gzgets() - Gzipli dosya tanıtıcısından bir satır döndürür

gzfile
gzgets
Zlib İşlevleri


Gzipli dosya tanıtıcısından bir satır döndürür

gzgetc
gzgetss
Zlib İşlevleri
PHP Manual

gzgets

(PHP 4, PHP 5, PHP 7)

gzgets — Gzipli dosya tanıtıcısından bir satır döndürür

Açıklama

string gzgets ( resource $dt [, int $uzunluk ] )

Belirtilen dosya tanıtıcısında mevcut konumdan itibaren en fazla (sıkıştırılmamış) uzunluk - 1 bayt okur. Okuma işlemi uzunluk - 1 baytta, ilk satırsonu karakterinde veya dosya sonuna gelindiğinde (hangisi önce olursa) durur.

Değiştirgeler

dt

Gzipli dosya tanıtıcısı. gzopen() tarafından açılmış bir dosyayı gösteren geçerli bir tanıtıcı olmalıdır.

uzunluk

Okunacak verinin uzunluğu.

Dönen Değerler

Bir hata oluşursa FALSE aksi takdirde sıkıştırılmamış dizgeyi döndürür.

Örnekler

Örnek 1 - gzgets() örneği

<?php
$dt = gzopen('birdosya.gz', 'r');
while (!gzeof($dt)) {
   $tampon = gzgets($dt, 4096);
   echo $tampon;
}
gzclose($dt);
?>

Ayrıca Bakınız

  • gzopen() - Bir gzipli dosya açar
  • gzgetc() - Gzipli dosya göstericisindeki karakteri döndürür
  • gzwrite() - Bir dizgeyi bir gzipli dosyaya ikil kipte yazar

gzgetc
gzgetss
Zlib İşlevleri


Gzipli dosya tanıtıcısından bir satır okuyup HTML etiketlerinden arındırır

gzgets
gzinflate
Zlib İşlevleri
PHP Manual

gzgetss

(PHP 4, PHP 5, PHP 7)

gzgetss — Gzipli dosya tanıtıcısından bir satır okuyup HTML etiketlerinden arındırır

Açıklama

string gzgetss ( resource $dt , int $uzunluk [, string $izinli_etiketler ] )

Okuduğu satırdan HTML ve PHP etiketlerini ayıklaması dışında gzgets() işlevi ile aynıdır.

Değiştirgeler

dt

Gzipli dosya tanıtıcısı. gzopen() tarafından açılmış bir dosyayı gösteren geçerli bir tanıtıcı olmalıdır.

uzunluk

Okunacak verinin uzunluğu.

izinli_etiketler

Bu isteğe bağlı değiştirgede ayıklanmayacak etiketleri belirtebilirsiniz.

Dönen Değerler

Bir hata oluşursa FALSE aksi takdirde sıkıştırılmamış ve etiketleri ayıklanmış dizgeyi döndürür.

Örnekler

Örnek 1 - gzgetss() örneği

<?php
$dt = gzopen('birdosya.gz', 'r');
while (!gzeof($dt)) {
   $tampon = gzgetss($dt, 4096);
   echo $tampon;
}
gzclose($dt);
?>

Ayrıca Bakınız

  • gzopen() - Bir gzipli dosya açar
  • gzgets() - Gzipli dosya tanıtıcısından bir satır döndürür
  • strip_tags() - Bir dizgeden HTML ve PHP etiketlerini ayıklar

gzgets
gzinflate
Zlib İşlevleri


Deflate sıkıştırmalı bir verinin sıkıştırmasını açar

gzgetss
gzopen
Zlib İşlevleri
PHP Manual

gzinflate

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gzinflate — Deflate sıkıştırmalı bir verinin sıkıştırmasını açar

Açıklama

string gzinflate ( string $veri [, int $uzunluk = 0 ] )

Deflate sıkıştırmalı bir verinin sıkıştırmasını açar.

Değiştirgeler

veri

gzdeflate() tarafından sıkıştırılmış veri.

uzunluk

Kodu çözülecek verinin azami uzunluğu.

Dönen Değerler

Bir hata durumunda FALSE aksi takdirde verinin sıkıştırılmamış halini döndürür.

Sıkıştırılmamış veri uzunluğu isteğe bağlı uzunluk ile belirtilenden veya sıkıştırılmış veri'nin 32768 mislinden uzunsa bu işlev bir hata döndürür.

Örnekler

Örnek 1 - gzinflate() örneği

<?php
$sımsıkı = gzdeflate('Sıkıştırılacak veri', 9);
$normal = gzinflate($sımsıkı);
echo $normal;
?>

Ayrıca Bakınız

  • gzdeflate() - Bir dizgeyi deflate biçeminde sıkıştırır
  • gzcompress() - Bir dizgeyi sıkıştırır
  • gzuncompress() - Sıkıştırılmış bir dizgenin sıkıştırmasını açar
  • gzencode() - Gzipli bir dizge oluşturur

gzgetss
gzopen
Zlib İşlevleri


Bir gzipli dosya açar

gzinflate
gzpassthru
Zlib İşlevleri
PHP Manual

gzopen

(PHP 4, PHP 5, PHP 7)

gzopen — Bir gzipli dosya açar

Açıklama

resource gzopen ( string $dosyaismi , string $kip [, int $include_path_kullan = 0 ] )

Okuma veya yazma amacıyla bir gzipli (.gz) dosya açar.

gzopen() işlevi henüz sıkıştırılmamış dosyaları okumak için açmakta da kullanılabilir. Bu durumda gzread(), sıkıştırmasız dosyayı doğrudan okuyacaktır.

Değiştirgeler

dosyaismi

Gzipli dosyanın ismi.

kip

fopen() işlevindeki gibi (rb veya wb) olmakla birlikte ayrıca bir sıkıştırma seviyesiyle (wb9 gibi) birlikte bir strateji de belirtilebilir: wb6f örneğindeki gibi süzgeçli veri için f; wb1h örneğindeki gibi sadece Huffman sıkıştırması için h. (Bu strateji değiştirgeleri hakkında daha ayrıntılı bilgi için zlib.h dosyasındaki deflateInit2 açıklamasına bakınız.)

include_path_kullan

Bu isteğe bağlı değiştirgeye 1 belirtirseniz dosya ayrıca include_path yönergesinde belirtilen yolarda da aranır.

Dönen Değerler

Açılan dosyaya bir dosya tanıtıcısı döndürür. Bu dosya tanıtıcısını kullanarak, (şeffaf olarak) sıkıştırılmış dosyadan herşeyi sıkıştırılmamış olarak okuyabilir ve dosyaya herşeyi sıkıştırılmış olarak yazabilirsiniz.

Açma işlemi başarısız olursa işlev FALSE döndürür.

Örnekler

Örnek 1 - gzopen() örneği

<?php
$dt = gzopen("/tmp/dosya.gz", "r");
?>

Ayrıca Bakınız

  • gzclose() - Bir açık gzipli dosya tanıtıcısını kapar

gzinflate
gzpassthru
Zlib İşlevleri


Gzipli dosya tanıtıcısında kalan verinin tamamını çıktılar

gzopen
gzputs
Zlib İşlevleri
PHP Manual

gzpassthru

(PHP 4, PHP 5, PHP 7)

gzpassthru — Gzipli dosya tanıtıcısında kalan verinin tamamını çıktılar

Açıklama

int gzpassthru ( resource $dt )

Belirtilen dosya tanıtıcısında mevcut konumdan dosya sonuna kadar okur ve (sıkıştırılmamış) sonucu standart çıktıya gönderir.

Bilginize:

Veriyi dosyaya yazdıktan sonra çıktılamak isterseniz dosya göstericisini akımın başlangıcına taşımak için gzrewind() işlevini kullanmalısınız.

İpucu

Tek isteğiniz dosya içeriğini değiştirmeden ve dosya içinde belli bir konuma gitmeden içeriği çıktı tamponuna dökümlemekse readgzfile() işlevini kullanarak fazladan bir gzopen() çağrısı yapmaktan kurtulursunuz.

Değiştirgeler

dt

Gzipli dosya tanıtıcısı. gzopen() tarafından açılmış bir dosyayı gösteren geçerli bir tanıtıcı olmalıdır.

Dönen Değerler

Belirtilen dosya tanıtıcısından okunan sıkıştırılmamış bayt sayısı veya bir hata oluşmuşsa FALSE döner.

Örnekler

Örnek 1 - gzpassthru() örneği

<?php
$dt = gzopen('dosya.gz', 'r');
gzpassthru($dt);
gzclose($dt);
?>

gzopen
gzputs
Zlib İşlevleri


gzwrite işlevinin takma adıdır

gzpassthru
gzread
Zlib İşlevleri
PHP Manual

gzputs

(PHP 4, PHP 5, PHP 7)

gzputs — gzwrite() işlevinin takma adıdır

Açıklama

Bu işlev gzwrite() işlevinin takma adıdır.

gzpassthru
gzread
Zlib İşlevleri


Gzipli dosyayı ikil kipte okur

gzputs
gzrewind
Zlib İşlevleri
PHP Manual

gzread

(PHP 4, PHP 5, PHP 7)

gzread — Gzipli dosyayı ikil kipte okur

Açıklama

string gzread ( resource $dt , int $uzunluk )

gzread() işlevi belirtilen dosya tanıtıcısından uzunluk bayt okur. Okuma işlemi, gzipli dosya akımından (sıkıştırılmamış) uzunluk bayt okununca veya dosya sonuna gelindiğinde (hangisi önce olursa) durur.

Değiştirgeler

dt

Gzipli dosya tanıtıcısı. gzopen() tarafından açılmış bir dosyayı gösteren geçerli bir tanıtıcı olmalıdır.

uzunluk

Okunacak sıkıştırılmamış bayt sayısı.

Dönen Değerler

Okunan veri ile döner.

Örnekler

Örnek 1 - gzread() örneği

<?php
// gzipli dosyanın içeriğini dizgeye yazar
$dosya = "/usr/local/birdosya.txt.gz";
$dt = gzopen($dosya, "r");
$içerik = gzread($dt, 10000);
gzclose($dt);
?>

Ayrıca Bakınız

  • gzwrite() - Bir dizgeyi bir gzipli dosyaya ikil kipte yazar
  • gzopen() - Bir gzipli dosya açar
  • gzgets() - Gzipli dosya tanıtıcısından bir satır döndürür
  • gzgetss() - Gzipli dosya tanıtıcısından bir satır okuyup HTML etiketlerinden arındırır
  • gzfile() - Gzipli dosyayı bir dizi içinde döndürür
  • gzpassthru() - Gzipli dosya tanıtıcısında kalan verinin tamamını çıktılar

gzputs
gzrewind
Zlib İşlevleri


Gzipli dosya göstericisini dosya başlangıcına taşır

gzread
gzseek
Zlib İşlevleri
PHP Manual

gzrewind

(PHP 4, PHP 5, PHP 7)

gzrewind — Gzipli dosya göstericisini dosya başlangıcına taşır

Açıklama

bool gzrewind ( resource $dt )

Belirtilen dosya tanıtıcısında dosya göstericisini dosya akımının başlangıcına taşır.

Değiştirgeler

dt

Gzipli dosya tanıtıcısı. gzopen() tarafından açılmış bir dosyayı gösteren geçerli bir tanıtıcı olmalıdır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • gzseek() - Gzipli dosya göstericisini konumlar
  • gztell() - Gzipli dosya tanıtıcısının okuma/yazma konumunu döndürür

gzread
gzseek
Zlib İşlevleri


Gzipli dosya göstericisini konumlar

gzrewind
gztell
Zlib İşlevleri
PHP Manual

gzseek

(PHP 4, PHP 5, PHP 7)

gzseek — Gzipli dosya göstericisini konumlar

Açıklama

int gzseek ( resource $dt , int $konum [, int $nereye = SEEK_SET ] )

Belirtilen dosya tanıtıcısında dosya göstericisini belirtilen konuma taşır. gzseek(dt, konum, SEEK_SET) C çağrısına eşdeğerdir.

Dosya okumak için açılmışsa bu işlev yine de taklit edilir ama işlem oldukça yavaşlar. Dosya yazmak için açılmışsa sadece ileri yönde konumlamalar desteklenir; gzseek() konumlamanın ardından yeni konuma kadar olan bölgeyi sıfırlarla doldurur.

Değiştirgeler

dt

Gzipli dosya tanıtıcısı. gzopen() tarafından açılmış bir dosyayı gösteren geçerli bir tanıtıcı olmalıdır.

konum

Göstericinin götürüleceği konum.

nereye

Olası nereye değerleri:

  • SEEK_SET - Gösterici, tam konumuncu bayta yerleştirilir.
  • SEEK_CUR - Gösterici, mevcut konum artı konumuncu bayta yerleştirilir.

nereye değiştirgesi belirtilmezse SEEK_SET belirtilmiş gibi işlem yapılır.

Dönen Değerler

Başarı durumunda 0, aksi takdirde -1 döner. Dosya sonunun sonrasına yapılan bir konumlama bir hata olarak değerlendirilmez.

Örnekler

Örnek 1 - gzseek() örneği

<?php
$gz = gzopen('birdosya.gz', 'r');
gzseek($gz,2);
echo gzgetc($gz);
gzclose($gz);
?>

Ayrıca Bakınız

  • gztell() - Gzipli dosya tanıtıcısının okuma/yazma konumunu döndürür
  • gzrewind() - Gzipli dosya göstericisini dosya başlangıcına taşır

gzrewind
gztell
Zlib İşlevleri


Gzipli dosya tanıtıcısının okuma/yazma konumunu döndürür

gzseek
gzuncompress
Zlib İşlevleri
PHP Manual

gztell

(PHP 4, PHP 5, PHP 7)

gztell — Gzipli dosya tanıtıcısının okuma/yazma konumunu döndürür

Açıklama

int gztell ( resource $dt )

Belirtilen dosya tanıtıcısının, yani sıkıştırılmamış dosya akımının okuma/yazma konumunu döndürür.

Değiştirgeler

dt

Gzipli dosya tanıtıcısı. gzopen() tarafından açılmış bir dosyayı gösteren geçerli bir tanıtıcı olmalıdır.

Dönen Değerler

Dosya göstericisinin yeri veya bir hata oluşmuşsa FALSE döner.

Ayrıca Bakınız

  • gzopen() - Bir gzipli dosya açar
  • gzseek() - Gzipli dosya göstericisini konumlar
  • gzrewind() - Gzipli dosya göstericisini dosya başlangıcına taşır

gzseek
gzuncompress
Zlib İşlevleri


Sıkıştırılmış bir dizgenin sıkıştırmasını açar

gztell
gzwrite
Zlib İşlevleri
PHP Manual

gzuncompress

(PHP 4 >= 4.0.1, PHP 5, PHP 7)

gzuncompress — Sıkıştırılmış bir dizgenin sıkıştırmasını açar

Açıklama

string gzuncompress ( string $veri [, int $uzunluk = 0 ] )

Bu işlev sıkıştırılmış bir dizgenin sıkıştırmasını açar.

Değiştirgeler

veri

gzcompress() tarafından sıkıştırılmış veri.

uzunluk

Kodu çözülecek verinin azami uzunluğu.

Dönen Değerler

Verinin sıkıştırılmamış halini veya bir hata oluşması halinde FALSE döndürür.

Sıkıştırılmamış veri uzunluğu isteğe bağlı uzunluk ile belirtilenden veya sıkıştırılmış veri'nin 32768 mislinden uzunsa bu işlev bir hata döndürür.

Örnekler

Örnek 1 - gzuncompress() örneği

<?php
$compressed   = gzcompress('Sıkıştırılacak veri', 9);
$uncompressed = gzuncompress($compressed);
echo $uncompressed;
?>

Ayrıca Bakınız

  • gzcompress() - Bir dizgeyi sıkıştırır
  • gzinflate() - Deflate sıkıştırmalı bir verinin sıkıştırmasını açar
  • gzdeflate() - Bir dizgeyi deflate biçeminde sıkıştırır
  • gzencode() - Gzipli bir dizge oluşturur

gztell
gzwrite
Zlib İşlevleri


Bir dizgeyi bir gzipli dosyaya ikil kipte yazar

gzuncompress
inflate_add
Zlib İşlevleri
PHP Manual

gzwrite

(PHP 4, PHP 5, PHP 7)

gzwrite — Bir dizgeyi bir gzipli dosyaya ikil kipte yazar

Açıklama

int gzwrite ( resource $dt , string $dizge [, int $uzunluk ] )

gzwrite() işleve belirtilen dizge dizgesini belirtilen dosya tanıtıcısına sıkıştırarak yazar.

Değiştirgeler

dt

Gzipli dosya tanıtıcısı. gzopen() tarafından açılmış bir dosyayı gösteren geçerli bir tanıtıcı olmalıdır.

dizge

Sıkıştırılarak dosyaya yazılacak dizge.

uzunluk

Yazılacak sıkıştırılmamış bayt sayısı. Belirtilmişse yazma işlemi sıkıştırılmamış uzunluk bayt yazıldıktan sonra veya dosya sonuna gelindiğinde (hangisi önce olursa) durur.

Bilginize:

uzunluk değiştirgesi belirtilmişse magic_quotes_runtime yapılandırma yönergesi yok sayılır ve dizge'deki hiçbir bölü çizgisi ayıklanmaz.

Dönen Değerler

Belirtilen sıkıştırılmış dosya akımına yazılan sıkıştırılmamış bayt sayısı ile döner.

Örnekler

Örnek 1 - gzwrite() örneği

<?php
$dizge = 'Sıkıştırılacak bir takım bilgiler';
$gz = gzopen('birdosya.gz','w9');
gzwrite($gz, $dizge);
gzclose($gz);
?>

Ayrıca Bakınız

  • gzread() - Gzipli dosyayı ikil kipte okur
  • gzopen() - Bir gzipli dosya açar

gzuncompress
inflate_add
Zlib İşlevleri


Incrementally inflate encoded data

gzwrite
inflate_init
Zlib İşlevleri
PHP Manual

inflate_add

(PHP 7)

inflate_add — Incrementally inflate encoded data

Açıklama

string inflate_add ( resource $context , string $encoded_data [, int $flush_mode = ZLIB_SYNC_FLUSH ] )

Incrementally inflates encoded data in the specified context.

Limitation: header information from GZIP compressed data are not made available.

Değiştirgeler

context

A context created with inflate_init().

encoded_data

A chunk of compressed data.

flush_mode

One of ZLIB_BLOCK, ZLIB_NO_FLUSH, ZLIB_PARTIAL_FLUSH, ZLIB_SYNC_FLUSH (default), ZLIB_FULL_FLUSH, ZLIB_FINISH. Normally you will want to set ZLIB_NO_FLUSH to maximize compression, and ZLIB_FINISH to terminate with the last chunk of data. See the » zlib manual for a detailed description of these constants.

Dönen Değerler

Returns a chunk of uncompressed data, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

If invalid parameters are given, inflating the data requires a preset dictionary, but none is specified, the compressed stream is corrupt or has an invalid checksum, an error of level E_WARNING is generated.

Ayrıca Bakınız

  • inflate_init() - Initialize an incremental inflate context
gzwrite
inflate_init
Zlib İşlevleri


Initialize an incremental inflate context

inflate_add
readgzfile
Zlib İşlevleri
PHP Manual

inflate_init

(PHP 7)

inflate_init — Initialize an incremental inflate context

Açıklama

resource inflate_init ( int $encoding [, array $options = array() ] )

Initialize an incremental inflate context with the specified encoding.

Değiştirgeler

encoding

One of the ZLIB_ENCODING_* constants.

options

An associative array which may contain the following elements:

level

The compression level in range -1..9; defaults to -1.

memory

The compression memory level in range 1..9; defaults to 8.

window

The zlib window size (logarithmic) in range 8..15; defaults to 15.

strategy

One of ZLIB_FILTERED, ZLIB_HUFFMAN_ONLY, ZLIB_RLE, ZLIB_FIXED or ZLIB_DEFAULT_STRATEGY (the default).

dictionary

A string or an array of strings of the preset dictionary (default: no preset dictionary).

Dönen Değerler

Returns an inflate context resource (zlib.inflate) on success, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

If an invalid encoding or option is passed to options, or the context couldn't be created, an error of level E_WARNING is generated.

Ayrıca Bakınız

  • inflate_add() - Incrementally inflate encoded data
  • deflate_init() - Initialize an incremental deflate context
inflate_add
readgzfile
Zlib İşlevleri


Bir .gz dosyası çıktılar

inflate_init
zlib_decode
Zlib İşlevleri
PHP Manual

readgzfile

(PHP 4, PHP 5, PHP 7)

readgzfile — Bir .gz dosyası çıktılar

Açıklama

int readgzfile ( string $dosyaismi [, int $include_path_kullan = 0 ] )

Bir dosyayı okur ve sıkıştırıp standart çıktıya gönderir.

readgzfile() işlevi gzipli olmayan dosyaları da okumakta kullanılabilir; bu durumda readgzfile() sıkıştırılmamış dosyayı doğrudan okur.

Değiştirgeler

dosyaismi

Dosya sisteminden okunup içeriği standart çıktıya yazılacak dosya.

use_include_path

Bu isteğe bağlı değiştirgeyle 1 değerini aktarırsanız dosyanın include_path yönergesindeki yollarda da aranmasını sağlamış olursunuz.

Dönen Değerler

Dosyadan okunan (sıkıştırılmamış) bayt sayısı ile döner. Bir hata oluşursa FALSE döner ve işlev @readgzfile olarak çağrılmamışsa hata iletisi basılır.

Ayrıca Bakınız

  • gzpassthru() - Gzipli dosya tanıtıcısında kalan verinin tamamını çıktılar
  • gzfile() - Gzipli dosyayı bir dizi içinde döndürür
  • gzopen() - Bir gzipli dosya açar

inflate_init
zlib_decode
Zlib İşlevleri


Uncompress any raw/gzip/zlib encoded data

readgzfile
zlib_encode
Zlib İşlevleri
PHP Manual

zlib_decode

(PHP 5 >= 5.4.0, PHP 7)

zlib_decode — Uncompress any raw/gzip/zlib encoded data

Açıklama

string zlib_decode ( string $data [, string $max_decoded_len ] )

Uncompress any raw/gzip/zlib encoded data.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

data

max_decoded_len

Dönen Değerler

Returns the uncompressed data, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • zlib_encode() - Compress data with the specified encoding
readgzfile
zlib_encode
Zlib İşlevleri


Compress data with the specified encoding

zlib_decode
zlib_get_coding_type
Zlib İşlevleri
PHP Manual

zlib_encode

(PHP 5 >= 5.4.0, PHP 7)

zlib_encode — Compress data with the specified encoding

Açıklama

string zlib_encode ( string $data , string $encoding [, string $level = -1 ] )

Compress data with the specified encoding.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

data

The data to compress.

encoding

The compression algorithm. Either ZLIB_ENCODING_RAW, ZLIB_ENCODING_DEFLATE or ZLIB_ENCODING_GZIP.

level

Dönen Değerler

Örnekler

Örnek 1 zlib_encode() example

<?php
$str = 'hello world';
$enc = zlib_encode($str, ZLIB_ENCODING_DEFLATE);
echo bin2hex($enc);
?>

Yukarıdaki örneğin çıktısı:

789ccb48cdc9c95728cf2fca4901001a0b045d

Ayrıca Bakınız

  • zlib_decode() - Uncompress any raw/gzip/zlib encoded data
zlib_decode
zlib_get_coding_type
Zlib İşlevleri


Çıktı sıkıştırması için kullanılan kodlama türünü döndürür

zlib_encode
Kredi Kartı İşlemleri
Zlib İşlevleri
PHP Manual

zlib_get_coding_type

(PHP 4 >= 4.3.2, PHP 5, PHP 7)

zlib_get_coding_type — Çıktı sıkıştırması için kullanılan kodlama türünü döndürür

Açıklama

string zlib_get_coding_type ( void )

Çıktı sıkıştırması için kullanılan kodlama türünü döndürür.

Dönen Değerler

Olası dönüş değerleri gzip, deflate, ya da FALSE'tır.

Ayrıca Bakınız

  • zlib.output_compression yönergesi.

zlib_encode
Kredi Kartı İşlemleri
Zlib İşlevleri


Kredi Kartı İşlemleri

  • MCVE — MCVE (Monetra) Payment
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • MCVE İşlevleri
zlib_get_coding_type
MCVE
İşlev Başvuru Kılavuzu


MCVE (Monetra) Payment

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • MCVE İşlevleri
    • m_checkstatus — Check to see if a transaction has completed
    • m_completeauthorizations — Number of complete authorizations in queue, returning an array of their identifiers
    • m_connect — Establish the connection to MCVE
    • m_connectionerror — Get a textual representation of why a connection failed
    • m_deletetrans — Delete specified transaction from MCVE_CONN structure
    • m_destroyconn — Destroy the connection and MCVE_CONN structure
    • m_destroyengine — Free memory associated with IP/SSL connectivity
    • m_getcell — Get a specific cell from a comma delimited response by column name
    • m_getcellbynum — Get a specific cell from a comma delimited response by column number
    • m_getcommadelimited — Get the RAW comma delimited data returned from MCVE
    • m_getheader — Get the name of the column in a comma-delimited response
    • m_initconn — Create and initialize an MCVE_CONN structure
    • m_initengine — Ready the client for IP/SSL Communication
    • m_iscommadelimited — Checks to see if response is comma delimited
    • m_maxconntimeout — The maximum amount of time the API will attempt a connection to MCVE
    • m_monitor — Perform communication with MCVE (send/receive data) Non-blocking
    • m_numcolumns — Number of columns returned in a comma delimited response
    • m_numrows — Number of rows returned in a comma delimited response
    • m_parsecommadelimited — Parse the comma delimited response so m_getcell, etc will work
    • m_responsekeys — Returns array of strings which represents the keys that can be used for response parameters on this transaction
    • m_responseparam — Get a custom response parameter
    • m_returnstatus — Check to see if the transaction was successful
    • m_setblocking — Set blocking/non-blocking mode for connection
    • m_setdropfile — Set the connection method to Drop-File
    • m_setip — Set the connection method to IP
    • m_setssl_cafile — Set SSL CA (Certificate Authority) file for verification of server certificate
    • m_setssl_files — Set certificate key files and certificates if server requires client certificate verification
    • m_setssl — Set the connection method to SSL
    • m_settimeout — Set maximum transaction time (per trans)
    • m_sslcert_gen_hash — Generate hash for SSL client certificate verification
    • m_transactionssent — Check to see if outgoing buffer is clear
    • m_transinqueue — Number of transactions in client-queue
    • m_transkeyval — Add key/value pair to a transaction. Replaces deprecated transparam()
    • m_transnew — Start a new transaction
    • m_transsend — Finalize and send the transaction
    • m_uwait — Wait x microsecs
    • m_validateidentifier — Whether or not to validate the passed identifier on any transaction it is passed to
    • m_verifyconnection — Set whether or not to PING upon connect to verify connection
    • m_verifysslcert — Set whether or not to verify the server ssl certificate
Kredi Kartı İşlemleri
Giriş
Kredi Kartı İşlemleri


Giriş

These functions interface the MCVE (Monetra) API (libmonetra, formerly known as libmcve), allowing you to work directly with MCVE/Monetra from your PHP scripts. MCVE/Monetra is Main Street Softworks' solution to direct credit/debit/gift card processing for Linux/Unix/MacOSX/Windows ( » http://www.mainstreetsoftworks.com/ ). It lets you directly address the credit card clearing houses via your *nix box, modem and/or internet connection (bypassing the need for an additional service such as Authorize.Net or Pay Flow Pro). Using the MCVE/Monetra module for PHP, you can process credit cards directly through MCVE/Monetra via your PHP scripts. The following references will outline the process.

Bilginize:

MCVE/Monetra is the replacement for RedHat's CCVS. They contracted with RedHat in late 2001 to migrate all existing clientele to the MCVE platform.

Bilginize:

Bu eklenti » PECL deposuna taşınmış olup şu sürümden itibaren PHP kaynak paketinde dağıtılmamaktatır: PHP 5.1.0.

Bilginize: Bu eklenti Windows sistemlerinde çalışmaz.

MCVE
Yapılandırma/Kurulum
MCVE


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
MCVE


Gereksinimler

The LibMonetra (formerly libmcve) library.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu » PECL eklentisi PHP ile gelmez.

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/mcve.

Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız.

If installing without specifying the libmonetra path, PHP will attempt to look in the default LibMonetra Install location (/usr/local). If Monetra (MCVE) is in a non-standard location, run configure with: --with-mcve=$mcve_path , where $mcve_path is the path to your MCVE/Monetra installation. Please note that MCVE/Monetra support requires that $mcve_path/lib and $mcve_path/include exist, and include mcve.h or monetra.h under the include directory and libmcve.so and/or libmcve.a and/or libmonetra.so and/or libmonetra.a under the lib directory.

Since MCVE/Monetra has true server/client separation, there are no additional requirements for running PHP with MCVE support. To test your MCVE/Monetra extension in PHP, you may connect to testbox.monetra.com on port 8333 for IP, or port 8444 for SSL using the MCVE/Monetra PHP API. Use 'vitale' for your username, and 'test' for your password. Additional information about test facilities are available at » http://www.mainstreetsoftworks.com/.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Özkaynak Türleri

This extension defines a MCVE_CONN resource returned by m_initconn().

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

M_PENDING (integer)
M_DONE (integer)
M_ERROR (integer)
M_FAIL (integer)
M_SUCCESS (integer)
Özkaynak Türleri
MCVE İşlevleri
MCVE


MCVE İşlevleri

Ayrıca Bakınız

Additional documentation about MCVE/Monetra's PHP API can be found at » http://www.mainstreetsoftworks.com/documentation.html. Main Street's documentation is complete and should be the primary reference for functions.

İçindekiler

  • m_checkstatus — Check to see if a transaction has completed
  • m_completeauthorizations — Number of complete authorizations in queue, returning an array of their identifiers
  • m_connect — Establish the connection to MCVE
  • m_connectionerror — Get a textual representation of why a connection failed
  • m_deletetrans — Delete specified transaction from MCVE_CONN structure
  • m_destroyconn — Destroy the connection and MCVE_CONN structure
  • m_destroyengine — Free memory associated with IP/SSL connectivity
  • m_getcell — Get a specific cell from a comma delimited response by column name
  • m_getcellbynum — Get a specific cell from a comma delimited response by column number
  • m_getcommadelimited — Get the RAW comma delimited data returned from MCVE
  • m_getheader — Get the name of the column in a comma-delimited response
  • m_initconn — Create and initialize an MCVE_CONN structure
  • m_initengine — Ready the client for IP/SSL Communication
  • m_iscommadelimited — Checks to see if response is comma delimited
  • m_maxconntimeout — The maximum amount of time the API will attempt a connection to MCVE
  • m_monitor — Perform communication with MCVE (send/receive data) Non-blocking
  • m_numcolumns — Number of columns returned in a comma delimited response
  • m_numrows — Number of rows returned in a comma delimited response
  • m_parsecommadelimited — Parse the comma delimited response so m_getcell, etc will work
  • m_responsekeys — Returns array of strings which represents the keys that can be used for response parameters on this transaction
  • m_responseparam — Get a custom response parameter
  • m_returnstatus — Check to see if the transaction was successful
  • m_setblocking — Set blocking/non-blocking mode for connection
  • m_setdropfile — Set the connection method to Drop-File
  • m_setip — Set the connection method to IP
  • m_setssl_cafile — Set SSL CA (Certificate Authority) file for verification of server certificate
  • m_setssl_files — Set certificate key files and certificates if server requires client certificate verification
  • m_setssl — Set the connection method to SSL
  • m_settimeout — Set maximum transaction time (per trans)
  • m_sslcert_gen_hash — Generate hash for SSL client certificate verification
  • m_transactionssent — Check to see if outgoing buffer is clear
  • m_transinqueue — Number of transactions in client-queue
  • m_transkeyval — Add key/value pair to a transaction. Replaces deprecated transparam()
  • m_transnew — Start a new transaction
  • m_transsend — Finalize and send the transaction
  • m_uwait — Wait x microsecs
  • m_validateidentifier — Whether or not to validate the passed identifier on any transaction it is passed to
  • m_verifyconnection — Set whether or not to PING upon connect to verify connection
  • m_verifysslcert — Set whether or not to verify the server ssl certificate
Öntanımlı Sabitler
m_checkstatus
MCVE


Check to see if a transaction has completed

MCVE İşlevleri
m_completeauthorizations
MCVE İşlevleri
PHP Manual

m_checkstatus

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve >= 1.0.0)

m_checkstatus — Check to see if a transaction has completed

Açıklama

int m_checkstatus ( resource $conn , int $identifier )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

bağlantı

m_initengine() işlevinden dönen MCVE_CONN verisi.

identifier

Dönen Değerler

MCVE İşlevleri
m_completeauthorizations
MCVE İşlevleri


Number of complete authorizations in queue, returning an array of their identifiers

m_checkstatus
m_connect
MCVE İşlevleri
PHP Manual

m_completeauthorizations

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve >= 1.0.0)

m_completeauthorizations — Number of complete authorizations in queue, returning an array of their identifiers

Açıklama

int m_completeauthorizations ( resource $conn , int &$array )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

bağlantı

m_initengine() işlevinden dönen MCVE_CONN verisi.

array

Its description

Dönen Değerler

What the function returns, first on success, then on failure. See also the &return.success; entity

m_checkstatus
m_connect
MCVE İşlevleri


Establish the connection to MCVE

m_completeauthorizations
m_connectionerror
MCVE İşlevleri
PHP Manual

m_connect

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve >= 1.0.0)

m_connect — Establish the connection to MCVE

Açıklama

int m_connect ( resource $conn )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

bağlantı

m_initengine() işlevinden dönen MCVE_CONN verisi.

Dönen Değerler

m_completeauthorizations
m_connectionerror
MCVE İşlevleri


Get a textual representation of why a connection failed

m_connect
m_deletetrans
MCVE İşlevleri
PHP Manual

m_connectionerror

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve >= 1.0.0)

m_connectionerror — Get a textual representation of why a connection failed

Açıklama

string m_connectionerror ( resource $conn )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

bağlantı

m_initengine() işlevinden dönen MCVE_CONN verisi.

Dönen Değerler

m_connect
m_deletetrans
MCVE İşlevleri


Delete specified transaction from MCVE_CONN structure

m_connectionerror
m_destroyconn
MCVE İşlevleri
PHP Manual

m_deletetrans

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve >= 1.0.0)

m_deletetrans — Delete specified transaction from MCVE_CONN structure

Açıklama

bool m_deletetrans ( resource $conn , int $identifier )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

bağlantı

m_initengine() işlevinden dönen MCVE_CONN verisi.

identifier

Dönen Değerler

m_connectionerror
m_destroyconn
MCVE İşlevleri


Destroy the connection and MCVE_CONN structure

m_deletetrans
m_destroyengine
MCVE İşlevleri
PHP Manual

m_destroyconn

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve >= 1.0.0)

m_destroyconn — Destroy the connection and MCVE_CONN structure

Açıklama

bool m_destroyconn ( resource $conn )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

bağlantı

m_initengine() işlevinden dönen MCVE_CONN verisi.

Dönen Değerler

Returns TRUE.

Ayrıca Bakınız

  • m_initconn() - Create and initialize an MCVE_CONN structure

m_deletetrans
m_destroyengine
MCVE İşlevleri


Free memory associated with IP/SSL connectivity

m_destroyconn
m_getcell
MCVE İşlevleri
PHP Manual

m_destroyengine

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve >= 1.0.0)

m_destroyengine — Free memory associated with IP/SSL connectivity

Açıklama

void m_destroyengine ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Dönen Değerler

Hiçbir değer dönmez.

m_destroyconn
m_getcell
MCVE İşlevleri


Get a specific cell from a comma delimited response by column name

m_destroyengine
m_getcellbynum
MCVE İşlevleri
PHP Manual

m_getcell

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve >= 1.0.0)

m_getcell — Get a specific cell from a comma delimited response by column name

Açıklama

string m_getcell ( resource $conn , int $identifier , string $column , int $row )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

bağlantı

m_initengine() işlevinden dönen MCVE_CONN verisi.

identifier

column

row

Dönen Değerler

m_destroyengine
m_getcellbynum
MCVE İşlevleri


Get a specific cell from a comma delimited response by column number

m_getcell
m_getcommadelimited
MCVE İşlevleri
PHP Manual

m_getcellbynum

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve >= 1.0.0)

m_getcellbynum — Get a specific cell from a comma delimited response by column number

Açıklama

string m_getcellbynum ( resource $conn , int $identifier , int $column , int $row )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

bağlantı

m_initengine() işlevinden dönen MCVE_CONN verisi.

identifier

column

row

Dönen Değerler

m_getcell
m_getcommadelimited
MCVE İşlevleri


Get the RAW comma delimited data returned from MCVE

m_getcellbynum
m_getheader
MCVE İşlevleri
PHP Manual

m_getcommadelimited

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve >= 1.0.0)

m_getcommadelimited — Get the RAW comma delimited data returned from MCVE

Açıklama

string m_getcommadelimited ( resource $conn , int $identifier )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

bağlantı

m_initengine() işlevinden dönen MCVE_CONN verisi.

identifier

Dönen Değerler

m_getcellbynum
m_getheader
MCVE İşlevleri


Get the name of the column in a comma-delimited response

m_getcommadelimited
m_initconn
MCVE İşlevleri
PHP Manual

m_getheader

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve >= 1.0.0)

m_getheader — Get the name of the column in a comma-delimited response

Açıklama

string m_getheader ( resource $conn , int $identifier , int $column_num )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

bağlantı

m_initengine() işlevinden dönen MCVE_CONN verisi.

identifier

column_num

Dönen Değerler

m_getcommadelimited
m_initconn
MCVE İşlevleri


Create and initialize an MCVE_CONN structure

m_getheader
m_initengine
MCVE İşlevleri
PHP Manual

m_initconn

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve >= 1.0.0)

m_initconn — Create and initialize an MCVE_CONN structure

Açıklama

resource m_initconn ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Dönen Değerler

Returns an MCVE_CONN resource.

Ayrıca Bakınız

  • m_destroyconn() - Destroy the connection and MCVE_CONN structure

m_getheader
m_initengine
MCVE İşlevleri


Ready the client for IP/SSL Communication

m_initconn
m_iscommadelimited
MCVE İşlevleri
PHP Manual

m_initengine

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve >= 1.0.0)

m_initengine — Ready the client for IP/SSL Communication

Açıklama

int m_initengine ( string $location )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

location

Dönen Değerler

m_initconn
m_iscommadelimited
MCVE İşlevleri


Checks to see if response is comma delimited

m_initengine
m_maxconntimeout
MCVE İşlevleri
PHP Manual

m_iscommadelimited

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve >= 1.0.0)

m_iscommadelimited — Checks to see if response is comma delimited

Açıklama

int m_iscommadelimited ( resource $conn , int $identifier )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

bağlantı

m_initengine() işlevinden dönen MCVE_CONN verisi.

identifier

Dönen Değerler

m_initengine
m_maxconntimeout
MCVE İşlevleri


The maximum amount of time the API will attempt a connection to MCVE

m_iscommadelimited
m_monitor
MCVE İşlevleri
PHP Manual

m_maxconntimeout

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve >= 1.0.0)

m_maxconntimeout — The maximum amount of time the API will attempt a connection to MCVE

Açıklama

bool m_maxconntimeout ( resource $conn , int $secs )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

bağlantı

m_initengine() işlevinden dönen MCVE_CONN verisi.

secs

Dönen Değerler

m_iscommadelimited
m_monitor
MCVE İşlevleri


Perform communication with MCVE (send/receive data) Non-blocking

m_maxconntimeout
m_numcolumns
MCVE İşlevleri
PHP Manual

m_monitor

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve >= 1.0.0)

m_monitor — Perform communication with MCVE (send/receive data) Non-blocking

Açıklama

int m_monitor ( resource $conn )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

bağlantı

m_initengine() işlevinden dönen MCVE_CONN verisi.

Dönen Değerler

m_maxconntimeout
m_numcolumns
MCVE İşlevleri


Number of columns returned in a comma delimited response

m_monitor
m_numrows
MCVE İşlevleri
PHP Manual

m_numcolumns

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve >= 1.0.0)

m_numcolumns — Number of columns returned in a comma delimited response

Açıklama

int m_numcolumns ( resource $conn , int $identifier )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

bağlantı

m_initengine() işlevinden dönen MCVE_CONN verisi.

identifier

Dönen Değerler

m_monitor
m_numrows
MCVE İşlevleri


Number of rows returned in a comma delimited response

m_numcolumns
m_parsecommadelimited
MCVE İşlevleri
PHP Manual

m_numrows

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve >= 1.0.0)

m_numrows — Number of rows returned in a comma delimited response

Açıklama

int m_numrows ( resource $conn , int $identifier )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

bağlantı

m_initengine() işlevinden dönen MCVE_CONN verisi.

identifier

Dönen Değerler

m_numcolumns
m_parsecommadelimited
MCVE İşlevleri


Parse the comma delimited response so m_getcell, etc will work

m_numrows
m_responsekeys
MCVE İşlevleri
PHP Manual

m_parsecommadelimited

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve >= 1.0.0)

m_parsecommadelimited — Parse the comma delimited response so m_getcell, etc will work

Açıklama

int m_parsecommadelimited ( resource $conn , int $identifier )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

bağlantı

m_initengine() işlevinden dönen MCVE_CONN verisi.

identifier

Dönen Değerler

m_numrows
m_responsekeys
MCVE İşlevleri


Returns array of strings which represents the keys that can be used for response parameters on this transaction

m_parsecommadelimited
m_responseparam
MCVE İşlevleri
PHP Manual

m_responsekeys

(PHP 5 >= 5.0.5, PHP 7, PECL mcve >= 1.0.0)

m_responsekeys — Returns array of strings which represents the keys that can be used for response parameters on this transaction

Açıklama

array m_responsekeys ( resource $conn , int $identifier )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

bağlantı

m_initengine() işlevinden dönen MCVE_CONN verisi.

identifier

Dönen Değerler

m_parsecommadelimited
m_responseparam
MCVE İşlevleri


Get a custom response parameter

m_responsekeys
m_returnstatus
MCVE İşlevleri
PHP Manual

m_responseparam

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve >= 1.0.0)

m_responseparam — Get a custom response parameter

Açıklama

string m_responseparam ( resource $conn , int $identifier , string $key )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

bağlantı

m_initengine() işlevinden dönen MCVE_CONN verisi.

identifier

key

Dönen Değerler

m_responsekeys
m_returnstatus
MCVE İşlevleri


Check to see if the transaction was successful

m_responseparam
m_setblocking
MCVE İşlevleri
PHP Manual

m_returnstatus

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve >= 1.0.0)

m_returnstatus — Check to see if the transaction was successful

Açıklama

int m_returnstatus ( resource $conn , int $identifier )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

bağlantı

m_initengine() işlevinden dönen MCVE_CONN verisi.

identifier

Dönen Değerler

m_responseparam
m_setblocking
MCVE İşlevleri


Set blocking/non-blocking mode for connection

m_returnstatus
m_setdropfile
MCVE İşlevleri
PHP Manual

m_setblocking

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve >= 1.0.0)

m_setblocking — Set blocking/non-blocking mode for connection

Açıklama

int m_setblocking ( resource $conn , int $tf )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

bağlantı

m_initengine() işlevinden dönen MCVE_CONN verisi.

tf

Dönen Değerler

m_returnstatus
m_setdropfile
MCVE İşlevleri


Set the connection method to Drop-File

m_setblocking
m_setip
MCVE İşlevleri
PHP Manual

m_setdropfile

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve >= 1.0.0)

m_setdropfile — Set the connection method to Drop-File

Açıklama

int m_setdropfile ( resource $conn , string $directory )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

bağlantı

m_initengine() işlevinden dönen MCVE_CONN verisi.

directory

Dönen Değerler

m_setblocking
m_setip
MCVE İşlevleri


Set the connection method to IP

m_setdropfile
m_setssl_cafile
MCVE İşlevleri
PHP Manual

m_setip

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve >= 1.0.0)

m_setip — Set the connection method to IP

Açıklama

int m_setip ( resource $conn , string $host , int $port )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

bağlantı

m_initengine() işlevinden dönen MCVE_CONN verisi.

host

port

Dönen Değerler

m_setdropfile
m_setssl_cafile
MCVE İşlevleri


Set SSL CA (Certificate Authority) file for verification of server certificate

m_setip
m_setssl_files
MCVE İşlevleri
PHP Manual

m_setssl_cafile

(PHP 5 >= 5.0.5, PHP 7, PECL mcve >= 1.0.0)

m_setssl_cafile — Set SSL CA (Certificate Authority) file for verification of server certificate

Açıklama

int m_setssl_cafile ( resource $conn , string $cafile )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

bağlantı

m_initengine() işlevinden dönen MCVE_CONN verisi.

cafile

Dönen Değerler

m_setip
m_setssl_files
MCVE İşlevleri


Set certificate key files and certificates if server requires client certificate verification

m_setssl_cafile
m_setssl
MCVE İşlevleri
PHP Manual

m_setssl_files

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve >= 1.0.0)

m_setssl_files — Set certificate key files and certificates if server requires client certificate verification

Açıklama

int m_setssl_files ( resource $conn , string $sslkeyfile , string $sslcertfile )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

bağlantı

m_initengine() işlevinden dönen MCVE_CONN verisi.

sslkeyfile

sslcertfile

Dönen Değerler

m_setssl_cafile
m_setssl
MCVE İşlevleri


Set the connection method to SSL

m_setssl_files
m_settimeout
MCVE İşlevleri
PHP Manual

m_setssl

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve >= 1.0.0)

m_setssl — Set the connection method to SSL

Açıklama

int m_setssl ( resource $conn , string $host , int $port )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

bağlantı

m_initengine() işlevinden dönen MCVE_CONN verisi.

host

port

Dönen Değerler

m_setssl_files
m_settimeout
MCVE İşlevleri


Set maximum transaction time (per trans)

m_setssl
m_sslcert_gen_hash
MCVE İşlevleri
PHP Manual

m_settimeout

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve >= 1.0.0)

m_settimeout — Set maximum transaction time (per trans)

Açıklama

int m_settimeout ( resource $conn , int $seconds )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

bağlantı

m_initengine() işlevinden dönen MCVE_CONN verisi.

seconds

Dönen Değerler

m_setssl
m_sslcert_gen_hash
MCVE İşlevleri


Generate hash for SSL client certificate verification

m_settimeout
m_transactionssent
MCVE İşlevleri
PHP Manual

m_sslcert_gen_hash

(PECL mcve >= 5.2.0)

m_sslcert_gen_hash — Generate hash for SSL client certificate verification

Açıklama

string m_sslcert_gen_hash ( string $filename )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

filename

Dönen Değerler

m_settimeout
m_transactionssent
MCVE İşlevleri


Check to see if outgoing buffer is clear

m_sslcert_gen_hash
m_transinqueue
MCVE İşlevleri
PHP Manual

m_transactionssent

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve >= 1.0.0)

m_transactionssent — Check to see if outgoing buffer is clear

Açıklama

int m_transactionssent ( resource $conn )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

bağlantı

m_initengine() işlevinden dönen MCVE_CONN verisi.

Dönen Değerler

m_sslcert_gen_hash
m_transinqueue
MCVE İşlevleri


Number of transactions in client-queue

m_transactionssent
m_transkeyval
MCVE İşlevleri
PHP Manual

m_transinqueue

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve >= 1.0.0)

m_transinqueue — Number of transactions in client-queue

Açıklama

int m_transinqueue ( resource $conn )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

bağlantı

m_initengine() işlevinden dönen MCVE_CONN verisi.

Dönen Değerler

m_transactionssent
m_transkeyval
MCVE İşlevleri


Add key/value pair to a transaction. Replaces deprecated transparam()

m_transinqueue
m_transnew
MCVE İşlevleri
PHP Manual

m_transkeyval

(PHP 5 >= 5.0.5, PHP 7, PECL mcve >= 1.0.0)

m_transkeyval — Add key/value pair to a transaction. Replaces deprecated transparam()

Açıklama

int m_transkeyval ( resource $conn , int $identifier , string $key , string $value )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

bağlantı

m_initengine() işlevinden dönen MCVE_CONN verisi.

identifier

key

value

Dönen Değerler

m_transinqueue
m_transnew
MCVE İşlevleri


Start a new transaction

m_transkeyval
m_transsend
MCVE İşlevleri
PHP Manual

m_transnew

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve >= 1.0.0)

m_transnew — Start a new transaction

Açıklama

int m_transnew ( resource $conn )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

bağlantı

m_initengine() işlevinden dönen MCVE_CONN verisi.

Dönen Değerler

m_transkeyval
m_transsend
MCVE İşlevleri


Finalize and send the transaction

m_transnew
m_uwait
MCVE İşlevleri
PHP Manual

m_transsend

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve >= 1.0.0)

m_transsend — Finalize and send the transaction

Açıklama

int m_transsend ( resource $conn , int $identifier )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

bağlantı

m_initengine() işlevinden dönen MCVE_CONN verisi.

identifier

Dönen Değerler

m_transnew
m_uwait
MCVE İşlevleri


Wait x microsecs

m_transsend
m_validateidentifier
MCVE İşlevleri
PHP Manual

m_uwait

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve >= 1.0.0)

m_uwait — Wait x microsecs

Açıklama

int m_uwait ( int $microsecs )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

microsecs

Dönen Değerler

m_transsend
m_validateidentifier
MCVE İşlevleri


Whether or not to validate the passed identifier on any transaction it is passed to

m_uwait
m_verifyconnection
MCVE İşlevleri
PHP Manual

m_validateidentifier

(PHP 5 >= 5.0.5, PHP 7, PECL mcve >= 1.0.0)

m_validateidentifier — Whether or not to validate the passed identifier on any transaction it is passed to

Açıklama

int m_validateidentifier ( resource $conn , int $tf )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

bağlantı

m_initengine() işlevinden dönen MCVE_CONN verisi.

tf

Dönen Değerler

m_uwait
m_verifyconnection
MCVE İşlevleri


Set whether or not to PING upon connect to verify connection

m_validateidentifier
m_verifysslcert
MCVE İşlevleri
PHP Manual

m_verifyconnection

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve >= 1.0.0)

m_verifyconnection — Set whether or not to PING upon connect to verify connection

Açıklama

bool m_verifyconnection ( resource $conn , int $tf )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

bağlantı

m_initengine() işlevinden dönen MCVE_CONN verisi.

tf

Dönen Değerler

m_validateidentifier
m_verifysslcert
MCVE İşlevleri


Set whether or not to verify the server ssl certificate

m_verifyconnection
Şifresel Eklentiler
MCVE İşlevleri
PHP Manual

m_verifysslcert

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve >= 1.0.0)

m_verifysslcert — Set whether or not to verify the server ssl certificate

Açıklama

bool m_verifysslcert ( resource $conn , int $tf )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

bağlantı

m_initengine() işlevinden dönen MCVE_CONN verisi.

tf

Dönen Değerler

m_verifyconnection
Şifresel Eklentiler
MCVE İşlevleri


Şifresel Eklentiler

  • Crack — Cracklib Parola Sınama Eklentisi
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • Crack Parola Sınama İşlevleri
  • CSPRNG
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • CSPRNG İşlevleri
  • Hash — HASH İleti Özeti Çerçevesi
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Hash İşlevleri
  • Mcrypt
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Mcrypt şifreleri
    • Örnekler
    • Mcrypt İşlevleri
  • Mhash
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • Mhash İşlevleri
  • OpenSSL
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Anahtar/Sertifika Değiştirgeleri
    • Sertifika Doğrulama
    • OpenSSL İşlevleri
  • Password Hashing
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Password Hashing İşlevleri
m_verifysslcert
Crack
İşlev Başvuru Kılavuzu


Cracklib Parola Sınama Eklentisi

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
  • Crack Parola Sınama İşlevleri
    • crack_check — Belirtilen parola üzerinde çapraşık bir sınama yapar
    • crack_closedict — Açık bir CrackLib sözlüğünü kapatır
    • crack_getlastmessage — Son sınamanın sonucuyla ilgili bir ileti döndürür
    • crack_opendict — Yeni bir CrackLib sözlüğü açar
Şifresel Eklentiler
Giriş
Şifresel Eklentiler


Giriş

Bu işlevlerle bir parolanın gücünü sınamak için CrackLib kütüphanesini kullanabilirsiniz. Bir parolanın gücü, uzunluğuna, büyük ve küçük harf kullanımına ve CrackLib sözlüğüne göre sınanır. CrackLib ayrıca, parolanın gücünü arttırmanıza yardımcı olacak tanısal iletiler de verir.

Bilginize:

Bu eklenti » PECL deposuna taşınmış olup PHP 5.0.0 sürümünden itibaren PHP kaynak paketinde dağıtılmamaktatır.

Crack
Yapılandırma/Kurulum
Crack


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Crack


Gereksinimler

CrackLib kütüphanesi hakkında daha ayrıntılı bilgi edinmek için » http://sourceforge.net/projects/cracklib adresine bakınız.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu » PECL eklentisi PHP ile gelmez. Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/crack.

Bu işlevleri kullanabilmek için --with-crack[=DiZiN] yapılandırma seçeneğini kullanarak PHP'yi Crack desteğiyle derlemelisiniz.

Windows kullanıcılarının bu işlevleri kullanabilmesi için php.ini içinde php_crack.dll'i etkin kılmaları gerekmektedir. Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Crack Yapılandırma Yönergeleri
İsim | Öntanımlı değeri | Değişiklik yeri | Sürüm bilgisi
crack.default_dictionary | NULL | PHP_INI_PERDIR | crack <= 0.2'de PHP_INI_SYSTEM. PHP 4.0.5'ten itibaren kullanılabilmektedir. PHP 5.0.0'da kaldırılmıştır.
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Özkaynak Türleri

CrackLib eklentisi crack_opendict() işlevi tarafından döndürülen bir sözlük özkaynağı tanıtıcısına sahiptir.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
Örnekler
Crack


Örnekler

Bu örnekte bir CrackLib sözlüğünün açılışı, belirtilen parolanın sınanması, tanısal iletilerin alınışı ve sözlüğün kapatılışı gösterilmiştir.

Örnek 1 - CrackLib örneği

<?php
//  CrackLib Sözlüğünü açalım
$sözlük = crack_opendict('/usr/local/lib/pw_dict')
     or die('CrackLib sözlüğü açılamadı');

// Parolayı sınatalım
$dene = crack_check($sözlük, 'gx9A2s0x');

// İletileri alalım
$sonuç = crack_getlastmessage();
echo $sonuç; // 'strong password'

// Sözlüğü kapatalım
crack_closedict($sözlük);
?>

Bilginize:

crack_check() işlevi TRUE ile dönerse, crack_getlastmessage() 'strong password' ('güçlü parola') iletisini döndürür.

Öntanımlı Sabitler
Crack Parola Sınama İşlevleri
Crack


Crack Parola Sınama İşlevleri

İçindekiler

  • crack_check — Belirtilen parola üzerinde çapraşık bir sınama yapar
  • crack_closedict — Açık bir CrackLib sözlüğünü kapatır
  • crack_getlastmessage — Son sınamanın sonucuyla ilgili bir ileti döndürür
  • crack_opendict — Yeni bir CrackLib sözlüğü açar
Örnekler
crack_check
Crack


Belirtilen parola üzerinde çapraşık bir sınama yapar

Crack Parola Sınama İşlevleri
crack_closedict
Crack Parola Sınama İşlevleri
PHP Manual

crack_check

(PECL crack >= 0.1)

crack_check — Belirtilen parola üzerinde çapraşık bir sınama yapar

Açıklama

bool crack_check ( resource $sözlük , string $parola )
bool crack_check ( string $parola )

Belirtilen parola üzerinde belirtilen sözlüğe göre çapraşık bir sınama yapar.

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Değiştirgeler

sözlük

CrackLib sözlüğü. Belirtilmezse açılan son sözlük kullanılır.

parola

Sınanacak parola.

Dönen Değerler

Parola güçlü ise TRUE değilse FALSE döndürür.

Crack Parola Sınama İşlevleri
crack_closedict
Crack Parola Sınama İşlevleri


Açık bir CrackLib sözlüğünü kapatır

crack_check
crack_getlastmessage
Crack Parola Sınama İşlevleri
PHP Manual

crack_closedict

(PECL crack >= 0.1)

crack_closedict — Açık bir CrackLib sözlüğünü kapatır

Açıklama

bool crack_closedict ([ resource $sözlük ] )

sözlük tanıtıcısının gösterdiği sözlük özkaynağını kapatır.

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Değiştirgeler

sözlük

Kapatılacak sözlük. Belirtilmezse açılan son sözlük kapatılır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • crack_opendict() - Yeni bir CrackLib sözlüğü açar

crack_check
crack_getlastmessage
Crack Parola Sınama İşlevleri


Son sınamanın sonucuyla ilgili bir ileti döndürür

crack_closedict
crack_opendict
Crack Parola Sınama İşlevleri
PHP Manual

crack_getlastmessage

(PECL crack >= 0.1)

crack_getlastmessage — Son sınamanın sonucuyla ilgili bir ileti döndürür

Açıklama

string crack_getlastmessage ( void )

crack_getlastmessage() işlevi son sınamanın sonucuyla ilgili bir ileti döndürür.

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Dönen Değerler

Henüz yapılmış bin sınama yoksa FALSE, varsa son sınamanın sonucu ile ilgili bir ileti döner.

Dönen ileti şunlardan biridir:

  • it's WAY too short - çok fazla kısa
  • it is too short - çok kısa
  • it does not contain enough DIFFERENT characters - yeterince farklı karakterler içermiyor
  • it is all whitespace - bunların hepsi boşluk karakteri
  • it is too simplistic/systematic - fazlasıyla basit ve kolaycı
  • it looks like a National Insurance number. - SSK numarası gibi duruyor
  • it is based on a dictionary word - Sözlükten alınmış gibi duruyor
  • it is based on a (reversed) dictionary word - Sözlükteki bir sözcük tersten yazılmış gibi görünüyor
  • strong password - bu güçlü bir parola

Ayrıca Bakınız

  • crack_check() - Belirtilen parola üzerinde çapraşık bir sınama yapar

crack_closedict
crack_opendict
Crack Parola Sınama İşlevleri


Yeni bir CrackLib sözlüğü açar

crack_getlastmessage
CSPRNG
Crack Parola Sınama İşlevleri
PHP Manual

crack_opendict

(PECL crack >= 0.1)

crack_opendict — Yeni bir CrackLib sözlüğü açar

Açıklama

resource crack_opendict ( string $sözlük )

crack_check() işlevinde kullanmak üzere yeri belirtilen sözlüğü açar.

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Bilginize:

Bir kerede en fazla bir sözlük açık olabilir.

Değiştirgeler

sözlük

Cracklib sözlük dosyasının yolu.

Dönen Değerler

Başarısızlık durumunda FALSE yoksa bir sözlük özkaynağı tanıtıcısı döndürür.

Ayrıca Bakınız

  • crack_check() - Belirtilen parola üzerinde çapraşık bir sınama yapar
  • crack_closedict() - Açık bir CrackLib sözlüğünü kapatır

crack_getlastmessage
CSPRNG
Crack Parola Sınama İşlevleri


CSPRNG

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • CSPRNG İşlevleri
    • random_bytes — Generates cryptographically secure pseudo-random bytes
    • random_int — Generates cryptographically secure pseudo-random integers
crack_opendict
Giriş
Şifresel Eklentiler


Giriş

The » cryptographically secure pseudo-random number generator (CSPRNG) API provides an easy and reliable way to generate crypto-strong random integers and bytes for use within cryptographic contexts.

This exists as of PHP 7.0.0 but there is also a » userland implementation for PHP >= 5.2.0.

CSPRNG
Yapılandırma/Kurulum
CSPRNG


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
CSPRNG


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
CSPRNG İşlevleri
CSPRNG


CSPRNG İşlevleri

İçindekiler

  • random_bytes — Generates cryptographically secure pseudo-random bytes
  • random_int — Generates cryptographically secure pseudo-random integers
Öntanımlı Sabitler
random_bytes
CSPRNG


Generates cryptographically secure pseudo-random bytes

CSPRNG İşlevleri
random_int
CSPRNG İşlevleri
PHP Manual

random_bytes

(PHP 7)

random_bytes — Generates cryptographically secure pseudo-random bytes

Açıklama

string random_bytes ( int $length )

Generates an arbitrary length string of cryptographic random bytes that are suitable for cryptographic use, such as when generating salts, keys or initialization vectors.

The sources of randomness used for this function are as follows:

  • On Windows, » CryptGenRandom() will always be used.
  • On Linux, the » getrandom(2) syscall will be used if available.
  • On other platforms, /dev/urandom will be used.
  • If none of the aforementioned sources are available, then an Exception will be thrown.

Bilginize: Although this function was added to PHP in PHP 7.0, a » userland implementation is available for PHP 5.2 to 5.6, inclusive.

Değiştirgeler

length

The length of the random string that should be returned in bytes.

Dönen Değerler

Returns a string containing the requested number of cryptographically secure random bytes.

Hatalar/İstisnalar

  • If an appropriate source of randomness cannot be found, an Exception will be thrown.
  • If invalid parameters are given, a TypeError will be thrown.
  • If an invalid length of bytes is given, an Error will be thrown.

Örnekler

Örnek 1 random_bytes() example

<?php
$bytes = random_bytes(5);
var_dump(bin2hex($bytes));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(10) "385e33f741"

Ayrıca Bakınız

  • random_int() - Generates cryptographically secure pseudo-random integers
  • openssl_random_pseudo_bytes() - Yarı-rasgele dizge üretir
  • bin2hex() - Bir ikil verinin onaltılık gösterimini elde eder
CSPRNG İşlevleri
random_int
CSPRNG İşlevleri


Generates cryptographically secure pseudo-random integers

random_bytes
Hash
CSPRNG İşlevleri
PHP Manual

random_int

(PHP 7)

random_int — Generates cryptographically secure pseudo-random integers

Açıklama

int random_int ( int $min , int $max )

Generates cryptographic random integers that are suitable for use where unbiased results are critical, such as when shuffling a deck of cards for a poker game.

The sources of randomness used for this function are as follows:

  • On Windows, » CryptGenRandom() will always be used.
  • On Linux, the » getrandom(2) syscall will be used if available.
  • On other platforms, /dev/urandom will be used.
  • If none of the aforementioned sources are available, then an Exception will be thrown.

Bilginize: Although this function was added to PHP in PHP 7.0, a » userland implementation is available for PHP 5.2 to 5.6, inclusive.

Değiştirgeler

min

The lowest value to be returned, which must be PHP_INT_MIN or higher.

max

The highest value to be returned, which must be less than or equal to PHP_INT_MAX.

Dönen Değerler

Returns a cryptographically secure random integer in the range min to max, inclusive.

Hatalar/İstisnalar

  • If an appropriate source of randomness cannot be found, an Exception will be thrown.
  • If invalid parameters are given, a TypeError will be thrown.
  • If max is less than min, an Error will be thrown.

Örnekler

Örnek 1 random_int() example

<?php
var_dump(random_int(100, 999));
var_dump(random_int(-1000, 0));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(248)
int(-898)

Ayrıca Bakınız

  • random_bytes() - Generates cryptographically secure pseudo-random bytes
random_bytes
Hash
CSPRNG İşlevleri


HASH İleti Özeti Çerçevesi

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Hash İşlevleri
    • hash_algos — Kayıtlı özetleme algoritmalarının bir listesini döndürür
    • hash_copy — Özetleme bağlamını kopyalar
    • hash_equals — Timing attack safe string comparison
    • hash_file — Belirtilen dosyanın içeriğinden bir ileti özeti üretir
    • hash_final — Bir ardışık özetleme işlemini bitirip üretilen özeti döndürür
    • hash_hmac_file — Bir dosyanın içeriğinden HMAC yöntemini kullanarak bir anahtarlı ileti özeti üretir
    • hash_hmac — HMAC yöntemini kullanarak bir anahtarlı ileti özeti üretir
    • hash_init — Ardışık özetleme bağlamını ilklendirir
    • hash_pbkdf2 — Generate a PBKDF2 key derivation of a supplied password
    • hash_update_file — Veriyi bir dosyadan etkin bir özetleme bağlamına dahil eder
    • hash_update_stream — Veriyi açık bir akımdan etkin bir özetleme bağlamına dahil eder
    • hash_update — Veriyi etkin bir özetleme bağlamına dahil eder
    • hash — Bir ileti özeti üretir
random_int
Giriş
Şifresel Eklentiler


Giriş

İleti Özeti (hash) motoru. Çeşitli özetleme algoritmalarının keyfi uzunluktaki iletilere doğrudan veya ardışık uygulanmasını sağlar.

Hash
Yapılandırma/Kurulum
Hash


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Hash


Gereksinimler

Hash eklentisinin hiçbir harici kütüphaneye gereksinimi yoktur ve PHP 5.1.2 itibariyle öntanımlı olarak etkindir. İptal edilmek istenirse PHP'yi derlemek için yapılandırırken --disable-hash seçeneğini belirtin. PHP'nin eski sürümleri Hash desteği için » PECL eklentisini kurabilirler.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Özkaynak Türleri

Bu eklentinin hash_init() işlevinden dönen bir Özetleme Bağlamı özkaynağı vardır.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

HASH_HMAC (integer)
hash_init() için isteğe bağlı seçenek. Geçerli özetleme bağlamına HMAC digest anahtar algoritmasının uygulanacağını belirtir.
Özkaynak Türleri
Hash İşlevleri
Hash


Hash İşlevleri

İçindekiler

  • hash_algos — Kayıtlı özetleme algoritmalarının bir listesini döndürür
  • hash_copy — Özetleme bağlamını kopyalar
  • hash_equals — Timing attack safe string comparison
  • hash_file — Belirtilen dosyanın içeriğinden bir ileti özeti üretir
  • hash_final — Bir ardışık özetleme işlemini bitirip üretilen özeti döndürür
  • hash_hmac_file — Bir dosyanın içeriğinden HMAC yöntemini kullanarak bir anahtarlı ileti özeti üretir
  • hash_hmac — HMAC yöntemini kullanarak bir anahtarlı ileti özeti üretir
  • hash_init — Ardışık özetleme bağlamını ilklendirir
  • hash_pbkdf2 — Generate a PBKDF2 key derivation of a supplied password
  • hash_update_file — Veriyi bir dosyadan etkin bir özetleme bağlamına dahil eder
  • hash_update_stream — Veriyi açık bir akımdan etkin bir özetleme bağlamına dahil eder
  • hash_update — Veriyi etkin bir özetleme bağlamına dahil eder
  • hash — Bir ileti özeti üretir
Öntanımlı Sabitler
hash_algos
Hash


Kayıtlı özetleme algoritmalarının bir listesini döndürür

Hash İşlevleri
hash_copy
Hash İşlevleri
PHP Manual

hash_algos

(PHP 5 >= 5.1.2, PHP 7, PECL hash >= 1.1)

hash_algos — Kayıtlı özetleme algoritmalarının bir listesini döndürür

Açıklama

array hash_algos ( void )

Kayıtlı özetleme algoritmalarının bir listesini döndürür.

Dönen Değerler

Desteklenen özetleme algoritmalarını içeren sayısal indisli bir dizi döndürür.

Örnekler

Örnek 1 - hash_algos() örneği

PHP 5.1.2 sürümde, hash_algos() aşağıdaki algoritma isimlerini döndürmekteydi:

<?php
print_r(hash_algos());
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [0] => md4
    [1] => md5
    [2] => sha1
    [3] => sha256
    [4] => sha384
    [5] => sha512
    [6] => ripemd128
    [7] => ripemd160
    [8] => whirlpool
    [9] => tiger128,3
    [10] => tiger160,3
    [11] => tiger192,3
    [12] => tiger128,4
    [13] => tiger160,4
    [14] => tiger192,4
    [15] => snefru
    [16] => gost
    [17] => adler32
    [18] => crc32
    [19] => crc32b
    [20] => haval128,3
    [21] => haval160,3
    [22] => haval192,3
    [23] => haval224,3
    [24] => haval256,3
    [25] => haval128,4
    [26] => haval160,4
    [27] => haval192,4
    [28] => haval224,4
    [29] => haval256,4
    [30] => haval128,5
    [31] => haval160,5
    [32] => haval192,5
    [33] => haval224,5
    [34] => haval256,5
)

Hash İşlevleri
hash_copy
Hash İşlevleri


Özetleme bağlamını kopyalar

hash_algos
hash_equals
Hash İşlevleri
PHP Manual

hash_copy

(PHP 5 >= 5.3.0, PHP 7)

hash_copy — Özetleme bağlamını kopyalar

Açıklama

resource hash_copy ( resource $bağlam )

Özetleme bağlamını kopyalar

Değiştirgeler

bağlam

hash_init() tarafından döndürülmüş özetleme bağlamı.

Dönen Değerler

Özetleme Bağlamı özkaynağının bir kopyasını döndürür.

Örnekler

Örnek 1 - hash_copy() örneği

<?php
$context = hash_init("md5");
hash_update($context, "data");

/* kulanmaya devem edebilmek için bağlamı kopyalayalım */
$copy_context = hash_copy($context);

echo hash_final($context), "\n";

hash_update($copy_context, "data");
echo hash_final($copy_context), "\n";
?>

Yukarıdaki örneğin çıktısı:

8d777f385d3dfec8815d20f7496026dc
511ae0b1c13f95e5f08f1a0dd3da3d93

hash_algos
hash_equals
Hash İşlevleri


Timing attack safe string comparison

hash_copy
hash_file
Hash İşlevleri
PHP Manual

hash_equals

(PHP 5 >= 5.6.0, PHP 7)

hash_equals — Timing attack safe string comparison

Açıklama

bool hash_equals ( string $known_string , string $user_string )

Compares two strings using the same time whether they're equal or not.

This function should be used to mitigate timing attacks; for instance, when testing crypt() password hashes.

Değiştirgeler

known_string

The string of known length to compare against

user_string

The user-supplied string

Dönen Değerler

Returns TRUE when the two strings are equal, FALSE otherwise.

Hatalar/İstisnalar

Emits an E_WARNING message when either of the supplied parameters is not a string.

Örnekler

Örnek 1 example

<?php
$expected  = crypt('12345', '$2a$07$usesomesillystringforsalt$');
$correct   = crypt('12345', '$2a$07$usesomesillystringforsalt$');
$incorrect = crypt('apple',  '$2a$07$usesomesillystringforsalt$');

var_dump(hash_equals($expected, $correct));
var_dump(hash_equals($expected, $incorrect));
?>

Yukarıdaki örneğin çıktısı:

bool(true)
bool(false)

Notlar

Bilginize:

Both arguments must be of the same length to be compared successfully. When arguments of differing length are supplied, FALSE is returned immediately and the length of the known string may be leaked in case of a timing attack.

Bilginize:

It is important to provide the user-supplied string as the second parameter, rather than the first.

hash_copy
hash_file
Hash İşlevleri


Belirtilen dosyanın içeriğinden bir ileti özeti üretir

hash_equals
hash_final
Hash İşlevleri
PHP Manual

hash_file

(PHP 5 >= 5.1.2, PHP 7, PECL hash >= 1.1)

hash_file — Belirtilen dosyanın içeriğinden bir ileti özeti üretir

Açıklama

string hash_file ( string $algo , string $dosya [, bool $ham_çıktı = false ] )

Belirtilen dosyanın içeriğinden bir ileti özeti üretir.

Değiştirgeler

algo

Özetleme algoritmasının ismi ("md5", "sha256", "haval160,4" ve benzerleri)

dosya

Özeti hesaplanacak dosyanın yeri; fopen() sarmalayıcıları desteklenir.

ham_çıktı

TRUE olduğu takdirde ham ikil veri çıktılanır, aksi takdirde (FALSE) küçük harfli onaltılıklar çıktılanır.

Dönen Değerler

Hesaplanan ileti özetini, ham_çıktı için TRUE belirtilmedikçe küçük harfli onaltılıklardan oluşan bir dizge olarak, aksi takdirde ham ikil gösterimi içeren bir dizge olarak çıktılar.

Örnekler

Örnek 1 - hash_file() örneği

<?php
/* Özeti hesaplanacak dosyayı oluşturalım */
file_put_contents('example.txt',
    'Dağ başını duman almış gümüş dere durmaz akar.');

echo hash_file('md5', 'example.txt');
?>

Yukarıdaki örneğin çıktısı:

44366f3bc27a70d68b5e77157d9644ec

Ayrıca Bakınız

  • hash() - Bir ileti özeti üretir
  • hash_hmac_file() - Bir dosyanın içeriğinden HMAC yöntemini kullanarak bir anahtarlı ileti özeti üretir
  • hash_update_file() - Veriyi bir dosyadan etkin bir özetleme bağlamına dahil eder
  • md5_file() - Belirtilen dosyanın md5 özetini hesaplar
  • sha1_file() - Bir dosyanın sha1 özetini hesaplar

hash_equals
hash_final
Hash İşlevleri


Bir ardışık özetleme işlemini bitirip üretilen özeti döndürür

hash_file
hash_hmac_file
Hash İşlevleri
PHP Manual

hash_final

(PHP 5 >= 5.1.2, PHP 7, PECL hash >= 1.1)

hash_final — Bir ardışık özetleme işlemini bitirip üretilen özeti döndürür

Açıklama

string hash_final ( resource $bağlam [, bool $ham_çıktı = false ] )

Bir ardışık özetleme işlemini bitirip üretilen özeti döndürür.

Değiştirgeler

bağlam

hash_init() tarafından döndürülmüş özetleme bağlamı.

ham_çıktı

TRUE olduğu takdirde ham ikil veri çıktılanır, aksi takdirde (FALSE) küçük harfli onaltılıklar çıktılanır.

Dönen Değerler

Hesaplanan ileti özetini, ham_çıktı için TRUE belirtilmedikçe küçük harfli onaltılıklardan oluşan bir dizge olarak, aksi takdirde ham ikil gösterimi içeren bir dizge olarak çıktılar.

Örnekler

Örnek 1 - hash_final() örneği

<?php
$ctx = hash_init('sha1');
hash_update($ctx, 'Dağ başını duman almış gümüş dere durmaz akar.');
echo hash_final($ctx);
?>

Yukarıdaki örneğin çıktısı:

5437dd7cc3b1a3572da12bf314963301f270e8

Ayrıca Bakınız

  • hash_init() - Ardışık özetleme bağlamını ilklendirir
  • hash_update() - Veriyi etkin bir özetleme bağlamına dahil eder
  • hash_update_stream() - Veriyi açık bir akımdan etkin bir özetleme bağlamına dahil eder
  • hash_update_file() - Veriyi bir dosyadan etkin bir özetleme bağlamına dahil eder

hash_file
hash_hmac_file
Hash İşlevleri


Bir dosyanın içeriğinden HMAC yöntemini kullanarak bir anahtarlı ileti özeti üretir

hash_final
hash_hmac
Hash İşlevleri
PHP Manual

hash_hmac_file

(PHP 5 >= 5.1.2, PHP 7, PECL hash >= 1.1)

hash_hmac_file — Bir dosyanın içeriğinden HMAC yöntemini kullanarak bir anahtarlı ileti özeti üretir

Açıklama

string hash_hmac_file ( string $algo , string $dosya , string $anahtar [, bool $ham_çıktı = false ] )

Bir dosyanın içeriğinden HMAC yöntemini kullanarak bir anahtarlı ileti özeti üretir.

Değiştirgeler

algo

Özetleme algoritmasının ismi ("md5", "sha256", "haval160,4" ve benzerleri)

dosya

Özeti hesaplanacak dosyanın yeri; fopen() sarmalayıcıları desteklenir.

anahtar

HMAC ileti özetinin üretiminde kullanılacak paylaşımlı gizli anahtar.

ham_çıktı

TRUE olduğu takdirde ham ikil veri çıktılanır, aksi takdirde (FALSE) küçük harfli onaltılıklar çıktılanır.

Dönen Değerler

Hesaplanan ileti özetini, ham_çıktı için TRUE belirtilmedikçe küçük harfli onaltılıklardan oluşan bir dizge olarak, aksi takdirde ham ikil gösterimi içeren bir dizge olarak çıktılar.

Örnekler

Örnek 1 - hash_hmac_file() örneği

<?php
/* Özeti hesaplanacak dosyayı oluşturalım */
file_put_contents('example.txt',
    'Dağ başını duman almış gümüş dere durmaz akar.');

echo hash_hmac_file('md5', 'example.txt', 'çokgizli');
?>

Yukarıdaki örneğin çıktısı:

51b361d728a6f44309941d09f1e6ba6f

Ayrıca Bakınız

  • hash_hmac() - HMAC yöntemini kullanarak bir anahtarlı ileti özeti üretir
  • hash_file() - Belirtilen dosyanın içeriğinden bir ileti özeti üretir

hash_final
hash_hmac
Hash İşlevleri


HMAC yöntemini kullanarak bir anahtarlı ileti özeti üretir

hash_hmac_file
hash_init
Hash İşlevleri
PHP Manual

hash_hmac

(PHP 5 >= 5.1.2, PHP 7, PECL hash >= 1.1)

hash_hmac — HMAC yöntemini kullanarak bir anahtarlı ileti özeti üretir

Açıklama

string hash_hmac ( string $algo , string $veri , string $anahtar [, bool $ham_çıktı = false ] )

HMAC yöntemini kullanarak bir anahtarlı ileti özeti üretir.

Değiştirgeler

algo

Özetleme algoritmasının ismi ("md5", "sha256", "haval160,4" ve benzerleri)

veri

Özetlenecek ileti.

anahtar

HMAC ileti özetinin üretiminde kullanılacak paylaşımlı gizli anahtar.

ham_çıktı

TRUE olduğu takdirde ham ikil veri çıktılanır, aksi takdirde (FALSE) küçük harfli onaltılıklar çıktılanır.

Dönen Değerler

Hesaplanan ileti özetini, ham_çıktı için TRUE belirtilmedikçe küçük harfli onaltılıklardan oluşan bir dizge olarak, aksi takdirde ham ikil gösterimi içeren bir dizge olarak çıktılar.

Örnekler

Örnek 1 - hash_hmac() örneği

<?php
echo hash_hmac('ripemd160',
    'Dağ başını duman almış gümüş dere durmaz akar.', 'çokgizli');
?>

Yukarıdaki örneğin çıktısı:

f23fd9908400e8fa4b388a7228c6aa686bbdf74e

Ayrıca Bakınız

  • hash() - Bir ileti özeti üretir
  • hash_init() - Ardışık özetleme bağlamını ilklendirir
  • hash_hmac_file() - Bir dosyanın içeriğinden HMAC yöntemini kullanarak bir anahtarlı ileti özeti üretir

hash_hmac_file
hash_init
Hash İşlevleri


Ardışık özetleme bağlamını ilklendirir

hash_hmac
hash_pbkdf2
Hash İşlevleri
PHP Manual

hash_init

(PHP 5 >= 5.1.2, PHP 7, PECL hash >= 1.1)

hash_init — Ardışık özetleme bağlamını ilklendirir

Açıklama

resource hash_init ( string $algo [, int $seçenekler = 0 [, string $anahtar = NULL ]] )

Ardışık özetleme bağlamını ilklendirir.

Değiştirgeler

algo

Özetleme algoritmasının ismi ("md5", "sha256", "haval160,4" vb.)

seçenekler

İleti özeti üretimi için isteğe bağlı seçenekler. Şimdilik tek bir seçenek desteklenmektedir: HASH_HMAC. Bu seçenek belirtildiği takdirde, anahtar değiştirgesi de belirtilmelidir.

anahtar

seçenekler değiştirgesinde HASH_HMAC belirtildiği takdirde, HMAC özetleme yöntemi ile kullanılacak paylaşımlı gizli anahtar.

Dönen Değerler

hash_update(), hash_update_stream(), hash_update_file(), ve hash_final() işlevlerinde kullanılmak üzere bir Özetleme Bağlamı özkaynağı döndürür.

Örnekler

Örnek 1 - Ardışık özetleme örneği

<?php
$ctx = hash_init('md5');
hash_update($ctx, 'Dağ başını duman almış ');
hash_update($ctx, 'Gümüş dere durmaz akar.');
echo hash_final($ctx);
?>

Yukarıdaki örneğin çıktısı:

57ef7029fa14e930500d3c6d371ef12b

Ayrıca Bakınız

  • hash() - Bir ileti özeti üretir
  • hash_file() - Belirtilen dosyanın içeriğinden bir ileti özeti üretir
  • hash_hmac() - HMAC yöntemini kullanarak bir anahtarlı ileti özeti üretir
  • hash_hmac_file() - Bir dosyanın içeriğinden HMAC yöntemini kullanarak bir anahtarlı ileti özeti üretir

hash_hmac
hash_pbkdf2
Hash İşlevleri


Generate a PBKDF2 key derivation of a supplied password

hash_init
hash_update_file
Hash İşlevleri
PHP Manual

hash_pbkdf2

(PHP 5 >= 5.5.0, PHP 7)

hash_pbkdf2 — Generate a PBKDF2 key derivation of a supplied password

Açıklama

string hash_pbkdf2 ( string $algo , string $password , string $salt , int $iterations [, int $length = 0 [, bool $raw_output = false ]] )

Değiştirgeler

algo

Name of selected hashing algorithm (i.e. md5, sha256, haval160,4, etc..) See hash_algos() for a list of supported algorithms.

password

The password to use for the derivation.

salt

The salt to use for the derivation. This value should be generated randomly.

iterations

The number of internal iterations to perform for the derivation.

length

The length of the output string. If raw_output is TRUE this corresponds to the byte-length of the derived key, if raw_output is FALSE this corresponds to twice the byte-length of the derived key (as every byte of the key is returned as two hexits).

If 0 is passed, the entire output of the supplied algorithm is used.

raw_output

When set to TRUE, outputs raw binary data. FALSE outputs lowercase hexits.

Dönen Değerler

Returns a string containing the derived key as lowercase hexits unless raw_output is set to TRUE in which case the raw binary representation of the derived key is returned.

Hatalar/İstisnalar

An E_WARNING will be raised if the algorithm is unknown, the iterations parameter is less than or equal to 0, the length is less than 0 or the salt is too long (greater than INT_MAX - 4).

Örnekler

Örnek 1 hash_pbkdf2() example, basic usage

<?php
$password = "password";
$iterations = 1000;

// Generate a random IV using mcrypt_create_iv(),
// openssl_random_pseudo_bytes() or another suitable source of randomness
$salt = mcrypt_create_iv(16, MCRYPT_DEV_URANDOM);

$hash = hash_pbkdf2("sha256", $password, $salt, $iterations, 20);
echo $hash;
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

120fb6cffcf8b32c43e7

Notlar

Dikkat

The PBKDF2 method can be used for hashing passwords for storage. However, it should be noted that password_hash() or crypt() with CRYPT_BLOWFISH are better suited for password storage.

Ayrıca Bakınız

  • crypt() - Tek yönlü dizge şifrelemesi yapar
  • password_hash() - Creates a password hash
  • hash() - Bir ileti özeti üretir
  • hash_algos() - Kayıtlı özetleme algoritmalarının bir listesini döndürür
  • hash_init() - Ardışık özetleme bağlamını ilklendirir
  • hash_hmac() - HMAC yöntemini kullanarak bir anahtarlı ileti özeti üretir
  • hash_hmac_file() - Bir dosyanın içeriğinden HMAC yöntemini kullanarak bir anahtarlı ileti özeti üretir

hash_init
hash_update_file
Hash İşlevleri


Veriyi bir dosyadan etkin bir özetleme bağlamına dahil eder

hash_pbkdf2
hash_update_stream
Hash İşlevleri
PHP Manual

hash_update_file

(PHP 5 >= 5.1.2, PHP 7, PECL hash >= 1.1)

hash_update_file — Veriyi bir dosyadan etkin bir özetleme bağlamına dahil eder

Açıklama

bool hash_update_file ( resource $bağlam , string $dosya [, resource $akım = NULL ] )

Veriyi bir dosyadan etkin bir özetleme bağlamına dahil eder.

Değiştirgeler

bağlam

hash_init() tarafından döndürülmüş özetleme bağlamı.

dosya

Özeti hesaplanacak dosyanın yeri; fopen() sarmalayıcıları desteklenir.

akım

stream_context_create() ile oluşturulmuş bir akım bağlamı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • hash_init() - Ardışık özetleme bağlamını ilklendirir
  • hash_update() - Veriyi etkin bir özetleme bağlamına dahil eder
  • hash_update_stream() - Veriyi açık bir akımdan etkin bir özetleme bağlamına dahil eder
  • hash_final() - Bir ardışık özetleme işlemini bitirip üretilen özeti döndürür
  • hash() - Bir ileti özeti üretir
  • hash_file() - Belirtilen dosyanın içeriğinden bir ileti özeti üretir

hash_pbkdf2
hash_update_stream
Hash İşlevleri


Veriyi açık bir akımdan etkin bir özetleme bağlamına dahil eder

hash_update_file
hash_update
Hash İşlevleri
PHP Manual

hash_update_stream

(PHP 5 >= 5.1.2, PHP 7, PECL hash >= 1.1)

hash_update_stream — Veriyi açık bir akımdan etkin bir özetleme bağlamına dahil eder

Açıklama

int hash_update_stream ( resource $bağlam , resource $dt [, int $uzunluk = -1 ] )

Veriyi açık bir akımdan etkin bir özetleme bağlamına dahil eder.

Değiştirgeler

bağlam

hash_init() tarafından döndürülmüş özetleme bağlamı.

dt

Bir akım oluşturma işlevi tarafından oluşturulmuş bir dosya tanıtıcısı.

uzunluk

Akımdan özetleme bağlamına kopyalanacak azami karakter sayısı.

Dönen Değerler

dt'den bağlam'a eklenebilen bayt sayısı.

Örnekler

Örnek 1 - hash_update_stream() örneği

<?php
$fp = tmpfile();
fwrite($fp, 'Dağ başını duman almış gümüş dere durmaz akar.');
rewind($fp);

$ctx = hash_init('md5');
hash_update_stream($ctx, $fp);
echo hash_final($ctx);
?>

Yukarıdaki örneğin çıktısı:

08badfbbc252d96b1e4615cca2b0424e

Ayrıca Bakınız

  • hash_init() - Ardışık özetleme bağlamını ilklendirir
  • hash_update() - Veriyi etkin bir özetleme bağlamına dahil eder
  • hash_final() - Bir ardışık özetleme işlemini bitirip üretilen özeti döndürür
  • hash() - Bir ileti özeti üretir
  • hash_file() - Belirtilen dosyanın içeriğinden bir ileti özeti üretir

hash_update_file
hash_update
Hash İşlevleri


Veriyi etkin bir özetleme bağlamına dahil eder

hash_update_stream
hash
Hash İşlevleri
PHP Manual

hash_update

(PHP 5 >= 5.1.2, PHP 7, PECL hash >= 1.1)

hash_update — Veriyi etkin bir özetleme bağlamına dahil eder

Açıklama

bool hash_update ( resource $bağlam , string $veri )

Veriyi etkin bir özetleme bağlamına dahil eder.

Değiştirgeler

bağlam

hash_init() tarafından döndürülmüş özetleme bağlamı.

veri

İleti özetine dahil edilecek ileti.

Dönen Değerler

TRUE döndürür.

Ayrıca Bakınız

  • hash_init() - Ardışık özetleme bağlamını ilklendirir
  • hash_update_file() - Veriyi bir dosyadan etkin bir özetleme bağlamına dahil eder
  • hash_update_stream() - Veriyi açık bir akımdan etkin bir özetleme bağlamına dahil eder
  • hash_final() - Bir ardışık özetleme işlemini bitirip üretilen özeti döndürür

hash_update_stream
hash
Hash İşlevleri


Bir ileti özeti üretir

hash_update
Mcrypt
Hash İşlevleri
PHP Manual

hash

(PHP 5 >= 5.1.2, PHP 7, PECL hash >= 1.1)

hash — Bir ileti özeti üretir

Açıklama

string hash ( string $algo , string $veri [, bool $ham_çıktı = false ] )

Bir ileti özeti üretir.

Değiştirgeler

algo

Özetleme algoritmasının ismi ("md5", "sha256", "haval160,4" ve benzerleri)

veri

Özeti çıkarılacak ileti.

ham_çıktı

TRUE olduğu takdirde ham ikil veri çıktılanır, aksi takdirde (FALSE) küçük harfli onaltılıklar çıktılanır.

Dönen Değerler

Hesaplanan ileti özetini, ham_çıktı için TRUE belirtilmedikçe küçük harfli onaltılıklardan oluşan bir dizge olarak, aksi takdirde ham ikil gösterimi içeren bir dizge olarak çıktılar.

Örnekler

Örnek 1 - hash() örneği

<?php
echo hash('ripemd160', 'Dağ başını duman almış gümüş dere durmaz akar.');
?>

Yukarıdaki örneğin çıktısı:

5397ae847c5c30e0ca3d8b2f3b3f71fd6be383bd

Ayrıca Bakınız

  • hash_file() - Belirtilen dosyanın içeriğinden bir ileti özeti üretir
  • hash_hmac() - HMAC yöntemini kullanarak bir anahtarlı ileti özeti üretir
  • hash_init() - Ardışık özetleme bağlamını ilklendirir
  • md5() - Bir dizgenin md5 özetini hesaplar
  • sha1() - Bir dizgenin sha1 özetini hesaplar

hash_update
Mcrypt
Hash İşlevleri


Mcrypt

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Mcrypt şifreleri
  • Örnekler
  • Mcrypt İşlevleri
    • mcrypt_cbc — Önerilmiyor: Veriyi CBC kipinde şifreler/çözer
    • mcrypt_cfb — Önerilmiyor: Veriyi CFB kipinde şifreler/çözer
    • mcrypt_create_iv — Rasgele bir kaynaktan bir ilklendirme vektörü (IV) oluşturur
    • mcrypt_decrypt — Belirtilen değiştirgelerle şifreli bir metnin şifresini çözer
    • mcrypt_ecb — Önerilmiyor: Veriyi ECB kipinde şifreler/çözer
    • mcrypt_enc_get_algorithms_name — Açık algoritmanın adını döndürür
    • mcrypt_enc_get_block_size — Açık algoritmanın küme boyunu döndürür
    • mcrypt_enc_get_iv_size — Açık algoritmanın ilklendirme vektörü uzunluğunu döndürür
    • mcrypt_enc_get_key_size — Açık kipin desteklediği azami anahtar uzunluğunu döndürür
    • mcrypt_enc_get_modes_name — Açık kipin ismini döndürür
    • mcrypt_enc_get_supported_key_sizes — Açık algoritmanın desteklediği anahtar boylarını listeler
    • mcrypt_enc_is_block_algorithm_mode — Açık kipte şifreleme kümeler halinde mi yapılıyor diye bakar
    • mcrypt_enc_is_block_algorithm — Açık kipin algoritması bir küme algoritması mı diye bakar
    • mcrypt_enc_is_block_mode — Açık kip küme çıktılayan türde mi diye bakar
    • mcrypt_enc_self_test — Şifreleme tanıtıcısı ile belirtilen modülün kendi kendini sınamasını sağlar
    • mcrypt_encrypt — Salt metin veriyi belirtilen değiştirgelerle şifreler
    • mcrypt_generic_deinit — Bir şifreleme tanıtıcısını yeniden ilklendirir
    • mcrypt_generic_end — Şifrelemeyi sonlandırır
    • mcrypt_generic_init — Şifreleme için gerekli tüm tamponları ilklendirir
    • mcrypt_generic — Veriyi şifreler
    • mcrypt_get_block_size — Belirtilen şifrenin küme uzunluğunu döndürür
    • mcrypt_get_cipher_name — Belirtilen şifrenin ismini döndürür
    • mcrypt_get_iv_size — Belirtilen şifre ve kipe özgü IV uzunluğunu döndürür
    • mcrypt_get_key_size — Belirtilen şifrenin anahtar uzunluğunu döndürür
    • mcrypt_list_algorithms — Desteklenen şifreleri listeler
    • mcrypt_list_modes — Desteklenen kiplerin listesini döndürür
    • mcrypt_module_close — Şifreleme tanıtıcısını kapatır
    • mcrypt_module_get_algo_block_size — Belirtilen algoritmanın küme boyunu döndürür
    • mcrypt_module_get_algo_key_size — Belirtilen algoritmanın desteklediği azami anahtar uzunluğunu döndürür
    • mcrypt_module_get_supported_key_sizes — Belirtilen algoritmanın desteklediği anahtar boyutlarını listeler
    • mcrypt_module_is_block_algorithm_mode — Belirtilen kip, küme algoritmaları ile kullanılabiliryor mu diye bakar
    • mcrypt_module_is_block_algorithm — Belirtilen algoritma bir küme algoritması mı diye bakar
    • mcrypt_module_is_block_mode — Belirtilen kip bir küme kipi mi diye bakar
    • mcrypt_module_open — Kullanılacak kipi ve algoritma modülünü açar
    • mcrypt_module_self_test — Belirtilen modülün kendini kendini sınamasını sağlar
    • mcrypt_ofb — Önerilmiyor: Veriyi OFB kipinde şifreler/çözer
    • mdecrypt_generic — Verinin şifresini çözer
hash
Giriş
Şifresel Eklentiler


Giriş

Bu eklenti, mcrypt kütüphanesi için bir arayüzdür. Mcrypt eklentisi, CBC, OFB, CFB ve ECB şifre kiplerinde DES, TripleDES, Blowfish (öntanımlı), 3-WAY, SAFER-SK64, SAFER-SK128, TWOFISH, TEA, RC2 ve GOST gibi bir çok algoritma çeşidini desteklemektedir. Ayrıca, özgür olmadığı düşünülen RC6 ve IDEA da desteklenmektedir.

Mcrypt
Yapılandırma/Kurulum
Mcrypt


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Mcrypt


Gereksinimler

Bu işlevler » mcrypt kütüphanesini kullanarak çalışır. » http://mcrypt.sourceforge.net/ adresinden libmcrypt-x.x.tar.gz paketini indirip kurulum yönergelerini izleyerek kütüphaneyi sisteminize kurabilirsiniz.

PHP 5.0.0'dan itibaren libmcrypt'in 2.5.6 ve üstü sürümleri gerekmektedir.

Windows kullanıcıları kütüphaneyi PHP 5.2 Windows çalıştırılabilirleri dağıtımında bulacaktır. PHP 5.3 Windows çalıştırılabilirleri MCrypt kütüphanesinin duruk sürümünü kullandığından DLL kütüphaneleri gerekli değildir.

Sisteminizde libmcrypt 2.4.x veya üstü kuruluysa CAST, LOKI97, RIJNDAEL, SAFERPLUS, SERPENT küme algoritmaları ve ENIGMA (crypt), PANAMA, RC4, WAKE akım şifrelerine ek olarak nOFB şifre kipi de destekleniyor olacaktır.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu eklentiyi etkin kılmak için PHP'yi --with-mcrypt[=DiZiN] seçeneğini kullanarak derlemelisiniz. DiZiN mcrypt kurulum dizinidir. Libmcrypt paketini --disable-posix-threads seçeneği ile derlemiş olmanız gerekmektedir.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Mcrypt yapılandırma yönergeleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
mcrypt.algorithms_dir | NULL | PHP_INI_ALL | PHP 4.0.2'den beri kullanılabilmektedir.
mcrypt.modes_dir | NULL | PHP_INI_ALL | PHP 4.0.2'den beri kullanılabilmektedir.
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

mcrypt.algorithms_dir string

Algoritmaları içeren dizin. Öntanımlı dizin libmcrypt içinde derlenmiş dizin olup genelde /usr/local/lib/libmcrypt dizinidir. Daha ayrıntılı bilgi için mcrypt_list_algorithms() işlevine bakınız.

mcrypt.modes_dir string

Kipleri içeren dizin. Öntanımlı dizin libmcrypt içinde derlenmiş dizin olup genelde /usr/local/lib/libmcrypt dizinidir. Daha ayrıntılı bilgi için mcrypt_list_modes() işlevine bakınız.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Özkaynak Türleri

mcrypt_module_open() işlevi bir şifreleme tanıtıcısı döndürür.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

Mcrypt dört şifreleme kipinde çalışabilir: CBC, OFB, CFB ve ECB. Sisteminizde libmcrypt-2.4.x veya üstü bir sürüm kuruluysa işlevler nOFB küme şifreleme kipinde ve STREAM kipinde çalışabilir. Desteklenen tüm şifreleme kiplerini kendileri için tanımlanmış sabitler ve bunların açıklamaları olarak aşağıda bulabilirsiniz. Daha ayrıntılı bilgi için Applied Cryptography by Schneier (ISBN 0-471-11709-9) kitabına bakınız.

  • MCRYPT_MODE_ECB (elektronik kod defteri), başka anahtarları şifrelemek gibi rasgele veri için elverişlidir. Veri küçük ve rasgele olduğundan ECB'nin yetersizliklerinin olumsuz etkileri yararlı hale gelir.
  • MCRYPT_MODE_CBC (şifre bloğu zinciri ) özellikle güvenliğin ECB'ye göre belirgin şekilde arttırılmasının gerektiği şifreli dosyalar için elverişlidir.
  • MCRYPT_MODE_CFB (şifre geribesleme), baytların tek tek şifrelenmesini gerektiren bayt akımlarının şifrelenmesi için en iyi kiptir.
  • MCRYPT_MODE_OFB (8 bitlik çıktı geribeslemesi) kipi ile CFB arasında seçim yapılacaksa, hata yayılımına katlanılamayacak uygulamalarda OFB tercih edilebilirse de 8 bitlik kipte çalıştığından güvenilir değildir, dolayısıyla kullanımı önerilmez.
  • MCRYPT_MODE_NOFB (n bitlik çıktı geribeslemesi)), algoritmaya özgü küme genişliğinde çalıştığından OFB'ye göre daha güvenilirdir.
  • MCRYPT_MODE_STREAM, "WAKE", "RC4" gibi başka akım algoritmalarını da içeren ek bir kiptir.

Diğer bazı kipler ve rasgele sayı üreteci sabitleri

MCRYPT_ENCRYPT (integer)
MCRYPT_DECRYPT (integer)
MCRYPT_DEV_RANDOM (integer)
MCRYPT_DEV_URANDOM (integer)
MCRYPT_RAND (integer)

Özkaynak Türleri
Mcrypt şifreleri
Mcrypt


Mcrypt şifreleri

Burada mcrypt eklentisi tarafından desteklenen şifrelere yer verilmiştir. Desteklenen şifrelerin tam listesini mcrypt.h başlık dosyasının sonunda bulabilirsiniz. mcrypt-2.2.x arayüzünün genel kuralı, PHP ile bir şifreye MCRYPT_şifreadı ile erişilebilmesidir. Ayrıca bu sabitler, libmcrypt-2.4.x ve libmcrypt-2.5.x ile de çalışmakta olup bir şifreye mcrypt_module_open() işlevinde ismini bir dizge olarak belirterek erişmek de mümkünür.

  • MCRYPT_3DES
  • MCRYPT_ARCFOUR_IV (sadece libmcrypt > 2.4.x)
  • MCRYPT_ARCFOUR (sadece libmcrypt > 2.4.x)
  • MCRYPT_BLOWFISH
  • MCRYPT_CAST_128
  • MCRYPT_CAST_256
  • MCRYPT_CRYPT
  • MCRYPT_DES
  • MCRYPT_DES_COMPAT (sadece libmcrypt 2.2.xonly)
  • MCRYPT_ENIGMA (sadece libmcrypt > 2.4.x , MCRYPT_CRYPT için takma ad)
  • MCRYPT_GOST
  • MCRYPT_IDEA (özgür değil)
  • MCRYPT_LOKI97 (sadece libmcrypt > 2.4.x)
  • MCRYPT_MARS (sadece libmcrypt > 2.4.x, özgür değil)
  • MCRYPT_PANAMA (sadece libmcrypt > 2.4.x)
  • MCRYPT_RIJNDAEL_128 (sadece libmcrypt > 2.4.x)
  • MCRYPT_RIJNDAEL_192 (sadece libmcrypt > 2.4.x)
  • MCRYPT_RIJNDAEL_256 (sadece libmcrypt > 2.4.x)
  • MCRYPT_RC2
  • MCRYPT_RC4 (sadece libmcrypt 2.2.x)
  • MCRYPT_RC6 (sadece libmcrypt > 2.4.x)
  • MCRYPT_RC6_128 (sadece libmcrypt 2.2.x)
  • MCRYPT_RC6_192 (sadece libmcrypt 2.2.x)
  • MCRYPT_RC6_256 (sadece libmcrypt 2.2.x)
  • MCRYPT_SAFER64
  • MCRYPT_SAFER128
  • MCRYPT_SAFERPLUS (sadece libmcrypt > 2.4.x)
  • MCRYPT_SERPENT(sadece libmcrypt > 2.4.x)
  • MCRYPT_SERPENT_128 (sadece libmcrypt 2.2.x)
  • MCRYPT_SERPENT_192 (sadece libmcrypt 2.2.x)
  • MCRYPT_SERPENT_256 (sadece libmcrypt 2.2.x)
  • MCRYPT_SKIPJACK (sadece libmcrypt > 2.4.x)
  • MCRYPT_TEAN (sadece libmcrypt 2.2.x)
  • MCRYPT_THREEWAY
  • MCRYPT_TRIPLEDES (sadece libmcrypt > 2.4.x)
  • MCRYPT_TWOFISH (eski mcrypt 2.x veya mcrypt > 2.4.x sürümleri için)
  • MCRYPT_TWOFISH128 (TWOFISHxxx şifreleri 2.4.x sürümlerinde değil, yeni 2.x sürümlerinde kullanılabilmektedir)
  • MCRYPT_TWOFISH192
  • MCRYPT_TWOFISH256
  • MCRYPT_WAKE (sadece libmcrypt > 2.4.x)
  • MCRYPT_XTEA (sadece libmcrypt > 2.4.x)

İlgili şifre işlevinde, CBC kipi için bir ilklendirme vektörü (İV) sağlamanız isteğe bağlı iken CFB ve OFB kiplerinde bir ilklendirme vektörü sağlamak zorundasınız. İV eşsiz olmalı ve şifreleme/çözme için aynı İV kullanılmalıdır. Şifreli saklanacak bir veriyi, verinin altında saklandığı indisle ilgili bir işlevinin çıktısı olarak alabilirsiniz (dosyanın MD5 anahtarı gibi). Bundan başka, İV'yi şifreli veri ile birlikte de aktarabilirsiniz. (Bu konuda daha ayrıntılı bilgi için Applied Cryptography by Schneier (ISBN 0-471-11709-9) kitabının 9.3. faslına bakınız.)

Öntanımlı Sabitler
Örnekler
Mcrypt


Örnekler

Mcrypt çeşitli şifreleri kullanarak şifreleme/çözme yapabilir. Sisteminizde libmcrypt-2.2.x kuruluysa, dört önemli mcrypt komutu (mcrypt_cfb(), mcrypt_cbc(), mcrypt_ecb() ve mcrypt_ofb()), MCRYPT_ENCRYPT ve MCRYPT_DECRYPT kiplerinin her ikisinde de çalışabilir.

Örnek 1 - Bir girdi değerinin 2.2.x altında ECB kipinde TripleDES ile şifrelenmesi

<?php
$key = "Bu gizli bir anahtar";
$input = "Saat 9'da gizli yerimizde buluşalım.";

$encrypted_data = mcrypt_ecb (MCRYPT_3DES, $key, $input, MCRYPT_ENCRYPT);
?>
Bu örnekte şifreli veriyi $encrypted_data değişkeninde bir dizge olarak alabilirsiniz.

Sisteminizde libmcrypt 2.4.x veya 2.5.x kuruluysa bu işlevler hala kullanılabilir olacaksa da gelişmiş işlevleri kullanmanız önerilir.

Örnek 2 - Bir girdi değerinin 2.4.x altında ECB kipinde TripleDES ile şifrelenmesi

<?php
    $key = "Bu gizli bir anahtar";
    $input = "Saat 9'da gizli yerimizde buluşalım.";

    $td = mcrypt_module_open('tripledes', '', 'ecb', '');
    $iv = mcrypt_create_iv (mcrypt_enc_get_iv_size($td), MCRYPT_RAND);
    mcrypt_generic_init($td, $key, $iv);
    $encrypted_data = mcrypt_generic($td, $input);
    mcrypt_generic_deinit($td);
    mcrypt_module_close($td);
?>
Bu örnekte şifreli veriyi $encrypted_data değişkeninde bir dizge olarak alabilirsiniz. Tam bir örnek için mcrypt_module_open() işlevine bakınız.

Mcrypt şifreleri
Mcrypt İşlevleri
Mcrypt


Mcrypt İşlevleri

İçindekiler

  • mcrypt_cbc — Önerilmiyor: Veriyi CBC kipinde şifreler/çözer
  • mcrypt_cfb — Önerilmiyor: Veriyi CFB kipinde şifreler/çözer
  • mcrypt_create_iv — Rasgele bir kaynaktan bir ilklendirme vektörü (IV) oluşturur
  • mcrypt_decrypt — Belirtilen değiştirgelerle şifreli bir metnin şifresini çözer
  • mcrypt_ecb — Önerilmiyor: Veriyi ECB kipinde şifreler/çözer
  • mcrypt_enc_get_algorithms_name — Açık algoritmanın adını döndürür
  • mcrypt_enc_get_block_size — Açık algoritmanın küme boyunu döndürür
  • mcrypt_enc_get_iv_size — Açık algoritmanın ilklendirme vektörü uzunluğunu döndürür
  • mcrypt_enc_get_key_size — Açık kipin desteklediği azami anahtar uzunluğunu döndürür
  • mcrypt_enc_get_modes_name — Açık kipin ismini döndürür
  • mcrypt_enc_get_supported_key_sizes — Açık algoritmanın desteklediği anahtar boylarını listeler
  • mcrypt_enc_is_block_algorithm_mode — Açık kipte şifreleme kümeler halinde mi yapılıyor diye bakar
  • mcrypt_enc_is_block_algorithm — Açık kipin algoritması bir küme algoritması mı diye bakar
  • mcrypt_enc_is_block_mode — Açık kip küme çıktılayan türde mi diye bakar
  • mcrypt_enc_self_test — Şifreleme tanıtıcısı ile belirtilen modülün kendi kendini sınamasını sağlar
  • mcrypt_encrypt — Salt metin veriyi belirtilen değiştirgelerle şifreler
  • mcrypt_generic_deinit — Bir şifreleme tanıtıcısını yeniden ilklendirir
  • mcrypt_generic_end — Şifrelemeyi sonlandırır
  • mcrypt_generic_init — Şifreleme için gerekli tüm tamponları ilklendirir
  • mcrypt_generic — Veriyi şifreler
  • mcrypt_get_block_size — Belirtilen şifrenin küme uzunluğunu döndürür
  • mcrypt_get_cipher_name — Belirtilen şifrenin ismini döndürür
  • mcrypt_get_iv_size — Belirtilen şifre ve kipe özgü IV uzunluğunu döndürür
  • mcrypt_get_key_size — Belirtilen şifrenin anahtar uzunluğunu döndürür
  • mcrypt_list_algorithms — Desteklenen şifreleri listeler
  • mcrypt_list_modes — Desteklenen kiplerin listesini döndürür
  • mcrypt_module_close — Şifreleme tanıtıcısını kapatır
  • mcrypt_module_get_algo_block_size — Belirtilen algoritmanın küme boyunu döndürür
  • mcrypt_module_get_algo_key_size — Belirtilen algoritmanın desteklediği azami anahtar uzunluğunu döndürür
  • mcrypt_module_get_supported_key_sizes — Belirtilen algoritmanın desteklediği anahtar boyutlarını listeler
  • mcrypt_module_is_block_algorithm_mode — Belirtilen kip, küme algoritmaları ile kullanılabiliryor mu diye bakar
  • mcrypt_module_is_block_algorithm — Belirtilen algoritma bir küme algoritması mı diye bakar
  • mcrypt_module_is_block_mode — Belirtilen kip bir küme kipi mi diye bakar
  • mcrypt_module_open — Kullanılacak kipi ve algoritma modülünü açar
  • mcrypt_module_self_test — Belirtilen modülün kendini kendini sınamasını sağlar
  • mcrypt_ofb — Önerilmiyor: Veriyi OFB kipinde şifreler/çözer
  • mdecrypt_generic — Verinin şifresini çözer
Örnekler
mcrypt_cbc
Mcrypt


Önerilmiyor: Veriyi CBC kipinde şifreler/çözer

Mcrypt İşlevleri
mcrypt_cfb
Mcrypt İşlevleri
PHP Manual

mcrypt_cbc

(PHP 4, PHP 5)

mcrypt_cbc — Önerilmiyor: Veriyi CBC kipinde şifreler/çözer

Açıklama

string mcrypt_cbc ( int $şifre , string $tuz , string $veri , int $kip , string $iv )
string mcrypt_cbc ( string $şifre , string $tuz , string $veri , int $kip [, string $iv ] )

İlk sözdizimi libmcrypt 2.2.x için, ikincisi ise libmcrypt 2.4.x ve üstü içindir. kip olarak MCRYPT_ENCRYPT veya MCRYPT_DECRYPT belirtilebilir.

Bu işlev artık kullanılmamalıdır. Yerine kullanılacak işlevler için mcrypt_generic() ve mdecrypt_generic() işlevine bakınız.

Mcrypt İşlevleri
mcrypt_cfb
Mcrypt İşlevleri


Önerilmiyor: Veriyi CFB kipinde şifreler/çözer

mcrypt_cbc
mcrypt_create_iv
Mcrypt İşlevleri
PHP Manual

mcrypt_cfb

(PHP 4, PHP 5)

mcrypt_cfb — Önerilmiyor: Veriyi CFB kipinde şifreler/çözer

Açıklama

string mcrypt_cfb ( int $şifre , string $tuz , string $veri , int $kip , string $iv )
string mcrypt_cfb ( string $şifre , string $tuz , string $veri , int $kip [, string $iv ] )

İlk sözdizimi libmcrypt 2.2.x için, ikincisi ise libmcrypt 2.4.x ve üstü içindir. kip olarak MCRYPT_ENCRYPT veya MCRYPT_DECRYPT belirtilebilir.

Bu işlev artık kullanılmamalıdır. Yerine kullanılacak işlevler için mcrypt_generic() ve mdecrypt_generic() işlevine bakınız.

mcrypt_cbc
mcrypt_create_iv
Mcrypt İşlevleri


Rasgele bir kaynaktan bir ilklendirme vektörü (IV) oluşturur

mcrypt_cfb
mcrypt_decrypt
Mcrypt İşlevleri
PHP Manual

mcrypt_create_iv

(PHP 4, PHP 5, PHP 7)

mcrypt_create_iv — Rasgele bir kaynaktan bir ilklendirme vektörü (IV) oluşturur

Açıklama

string mcrypt_create_iv ( int $boy [, int $kaynak = MCRYPT_DEV_RANDOM ] )

Rasgele bir kaynaktan bir ilklendirme vektörü (IV) oluşturur.

IV dizgesi, şifreleme yordamları için ek bir tohum olarak kullanılır. Bu IV'nin gizli olması gerekmediği gibi istenmez de. Hiçbir güvenlik kaybı oluşmadan şifreli metin ile birlikte gönderebilirsiniz.

Değiştirgeler

boy

IV boyu.

kaynak

Şu değerlerden biri olabilir: MCRYPT_RAND (sistem rasgele sayı üreteci), MCRYPT_DEV_RANDOM (veri /dev/random'dan okunur), MCRYPT_DEV_URANDOM (veri /dev/urandom'dan okunur). Windows (şüphesiz) /dev/random veya /dev/urandom aygıtlarına sahip olmadığından Windows için sadece MCRYPT_RAND desteklenmektedir.

Bilginize:

MCRYPT_RAND kullanıldığı takdirde, rasgele sayı üretecini ilklendirmek için önce bir srand() çağrısı yapmayı unutmayın; çünkü rand() gibi kendiliğinden tohumlanmaz.

Dönen Değerler

Bir hata durumunda FALSE yoksa ilklendirme vektörünü bir dizge olarak döndürür.

Örnekler

Örnek 1 - mcrypt_create_iv() örneği

<?php
    $boy = mcrypt_get_iv_size(MCRYPT_CAST_256, MCRYPT_MODE_CFB);
    $iv = mcrypt_create_iv($size, MCRYPT_DEV_RANDOM);
?>

Ayrıca Bakınız

  • » http://www.ciphersbyritter.com/GLOSSARY.HTM#IV
  • » http://www.quadibloc.com/crypto/co0409.htm
  • Schneier tarafından yazılan Applied Cryptography (ISBN 0-471-11709-9) kitabının 9.3. faslı

mcrypt_cfb
mcrypt_decrypt
Mcrypt İşlevleri


Belirtilen değiştirgelerle şifreli bir metnin şifresini çözer

mcrypt_create_iv
mcrypt_ecb
Mcrypt İşlevleri
PHP Manual

mcrypt_decrypt

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

mcrypt_decrypt — Belirtilen değiştirgelerle şifreli bir metnin şifresini çözer

Açıklama

string mcrypt_decrypt ( string $şifre , string $anahtar , string $veri , string $kip [, string $iv ] )

Belirtilen verinin şifresini çözer ve şifrelenmemiş dizgeyi döndürür.

Değiştirgeler

şifre

MCRYPT_şifre_adı sabitlerinden biri veya bir dizge olarak bir algoritma ismi.

key

Veriyi şifrelemekte kullanılan anahtar. Gereken anahtar uzunluğundan kısaysa dolgu olarak "\0" karakteri kullanılır.

data

Belirtilen şifre ve kip ile şifresi çözülecek veri. Verinin küme boyunun katları uzunlukta olmasını sağlamak için dolgu olarak "\0" karakteri kullanılır.

mode

MCRYPT_kip_adı sabitlerinden biri veya bir dizge olarak şunlardan biri: "ecb", "cbc", "cfb", "ofb", "nofb", "stream".

iv

CBC, CFB, OFB kiplerini ve STREAM kipindeki bazı algoritmaları ilklendirmek için kullanılan ilklendirme vektörü (IV). Bir IV belirtmezseniz tüm baytları "\0" karakterlerinden oluşan bir dizge kullanılır.

Dönen Değerler

Şifresi çözülmüş veriyi bir dizge olarak döndürür.

mcrypt_create_iv
mcrypt_ecb
Mcrypt İşlevleri


Önerilmiyor: Veriyi ECB kipinde şifreler/çözer

mcrypt_decrypt
mcrypt_enc_get_algorithms_name
Mcrypt İşlevleri
PHP Manual

mcrypt_ecb

(PHP 4, PHP 5)

mcrypt_ecb — Önerilmiyor: Veriyi ECB kipinde şifreler/çözer

Açıklama

string mcrypt_ecb ( int $şifre , string $tuz , string $veri , int $kip )
string mcrypt_ecb ( string $şifre , string $tuz , string $veri , int $kip [, string $iv ] )

İlk sözdizimi libmcrypt 2.2.x için, ikincisi ise libmcrypt 2.4.x ve üstü içindir. kip olarak MCRYPT_ENCRYPT veya MCRYPT_DECRYPT belirtilebilir.

Bu işlev artık kullanılmamalıdır. Yerine kullanılacak işlevler için mcrypt_generic() ve mdecrypt_generic() işlevine bakınız.

mcrypt_decrypt
mcrypt_enc_get_algorithms_name
Mcrypt İşlevleri


Açık algoritmanın adını döndürür

mcrypt_ecb
mcrypt_enc_get_block_size
Mcrypt İşlevleri
PHP Manual

mcrypt_enc_get_algorithms_name

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

mcrypt_enc_get_algorithms_name — Açık algoritmanın adını döndürür

Açıklama

string mcrypt_enc_get_algorithms_name ( resource $şt )

Açık algoritmanın adını döndürür.

Değiştirgeler

şt

mcrypt_module_open() tarafından döndürülmüş bir şifreleme tanıtıcısı.

Dönen Değerler

Açık algoritmanın adını içeren bir dizge döndürür.

Örnekler

Örnek 1 - mcrypt_enc_get_algorithms_name() örneği

<?php
$td = mcrypt_module_open(MCRYPT_CAST_256, '', MCRYPT_MODE_CFB, '');
echo mcrypt_enc_get_algorithms_name($td). "\n";

$td = mcrypt_module_open('cast-256', '', MCRYPT_MODE_CFB, '');
echo mcrypt_enc_get_algorithms_name($td). "\n";
?>

Yukarıdaki örneğin çıktısı:

CAST-256
CAST-256

mcrypt_ecb
mcrypt_enc_get_block_size
Mcrypt İşlevleri


Açık algoritmanın küme boyunu döndürür

mcrypt_enc_get_algorithms_name
mcrypt_enc_get_iv_size
Mcrypt İşlevleri
PHP Manual

mcrypt_enc_get_block_size

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

mcrypt_enc_get_block_size — Açık algoritmanın küme boyunu döndürür

Açıklama

int mcrypt_enc_get_block_size ( resource $şt )

Açık algoritmanın küme boyunu döndürür.

Değiştirgeler

şt

mcrypt_module_open() tarafından döndürülmüş bir şifreleme tanıtıcısı.

Dönen Değerler

Açık algoritmanın küme boyunu bayt sayısı olarak döndürür.

mcrypt_enc_get_algorithms_name
mcrypt_enc_get_iv_size
Mcrypt İşlevleri


Açık algoritmanın ilklendirme vektörü uzunluğunu döndürür

mcrypt_enc_get_block_size
mcrypt_enc_get_key_size
Mcrypt İşlevleri
PHP Manual

mcrypt_enc_get_iv_size

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

mcrypt_enc_get_iv_size — Açık algoritmanın ilklendirme vektörü uzunluğunu döndürür

Açıklama

int mcrypt_enc_get_iv_size ( resource $şt )

Şifreleme tanıtıcısı ile belirtilen algoritmanın ilklendirme vektörü (iv) uzunluğunu döndürür. CBC, CFB ve OFB kipleri ile akım kipindeki bazı algoritmalar bir ilklendirme vektörü kullanır.

Değiştirgeler

şt

mcrypt_module_open() tarafından döndürülmüş bir şifreleme tanıtıcısı.

Dönen Değerler

Açık algoritma tarafından iv yok sayılıyorsa 0, aksi takdirde iv boyunu döndürür.

mcrypt_enc_get_block_size
mcrypt_enc_get_key_size
Mcrypt İşlevleri


Açık kipin desteklediği azami anahtar uzunluğunu döndürür

mcrypt_enc_get_iv_size
mcrypt_enc_get_modes_name
Mcrypt İşlevleri
PHP Manual

mcrypt_enc_get_key_size

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

mcrypt_enc_get_key_size — Açık kipin desteklediği azami anahtar uzunluğunu döndürür

Açıklama

int mcrypt_enc_get_key_size ( resource $şt )

Açık kipin desteklediği azami anahtar uzunluğunu döndürür.

Değiştirgeler

şt

mcrypt_module_open() tarafından döndürülmüş bir şifreleme tanıtıcısı.

Dönen Değerler

Açık kipin desteklediği azami anahtar uzunluğunu bayt sayısı olarak döndürür.

mcrypt_enc_get_iv_size
mcrypt_enc_get_modes_name
Mcrypt İşlevleri


Açık kipin ismini döndürür

mcrypt_enc_get_key_size
mcrypt_enc_get_supported_key_sizes
Mcrypt İşlevleri
PHP Manual

mcrypt_enc_get_modes_name

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

mcrypt_enc_get_modes_name — Açık kipin ismini döndürür

Açıklama

string mcrypt_enc_get_modes_name ( resource $şt )

Bu işlev açık kipin ismini döndürür.

Değiştirgeler

şt

mcrypt_module_open() tarafından döndürülmüş bir şifreleme tanıtıcısı.

Dönen Değerler

İsim bir dizge olarak döner.

Örnekler

Örnek 1 - mcrypt_enc_get_modes_name() örneği

<?php
$td = mcrypt_module_open (MCRYPT_CAST_256, '', MCRYPT_MODE_CFB, '');
echo mcrypt_enc_get_modes_name($td). "\n";

$td = mcrypt_module_open ('cast-256', '', 'ecb', '');
echo mcrypt_enc_get_modes_name($td). "\n";
?>

Yukarıdaki örneğin çıktısı:

CFB
ECB

mcrypt_enc_get_key_size
mcrypt_enc_get_supported_key_sizes
Mcrypt İşlevleri


Açık algoritmanın desteklediği anahtar boylarını listeler

mcrypt_enc_get_modes_name
mcrypt_enc_is_block_algorithm_mode
Mcrypt İşlevleri
PHP Manual

mcrypt_enc_get_supported_key_sizes

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

mcrypt_enc_get_supported_key_sizes — Açık algoritmanın desteklediği anahtar boylarını listeler

Açıklama

array mcrypt_enc_get_supported_key_sizes ( resource $şt )

Açık algoritmanın desteklediği anahtar boylarını bir dizi içinde döndürür.

Değiştirgeler

şt

mcrypt_module_open() tarafından döndürülmüş bir şifreleme tanıtıcısı.

Dönen Değerler

Şifreleme tanıtıcısı ile belirtilen algoritmanın desteklediği anahtar boylarını içeren bir dizi döndürür. Boş bir dizi dönmüşse, 1 ile mcrypt_enc_get_key_size() arasındaki tüm anahtar boyları algoritma tarafından destekleniyor demektir.

Örnekler

Örnek 1 - mcrypt_enc_get_supported_key_sizes() örneği

<?php
    $td = mcrypt_module_open('rijndael-256', '', 'ecb', '');
    var_dump(mcrypt_enc_get_supported_key_sizes($td));
?>

Bunu basar:

array(3) {
  [0]=>
  int(16)
  [1]=>
  int(24)
  [2]=>
  int(32)
}

mcrypt_enc_get_modes_name
mcrypt_enc_is_block_algorithm_mode
Mcrypt İşlevleri


Açık kipte şifreleme kümeler halinde mi yapılıyor diye bakar

mcrypt_enc_get_supported_key_sizes
mcrypt_enc_is_block_algorithm
Mcrypt İşlevleri
PHP Manual

mcrypt_enc_is_block_algorithm_mode

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

mcrypt_enc_is_block_algorithm_mode — Açık kipte şifreleme kümeler halinde mi yapılıyor diye bakar

Açıklama

bool mcrypt_enc_is_block_algorithm_mode ( resource $şt )

Açık kipte, şifrelemenin kümeler üzerinde çalışıp çalışmadığına bakar (yani, akımlar için FALSE, cbc, cfb, ofb için TRUE döner).

Değiştirgeler

şt

mcrypt_module_open() tarafından döndürülmüş bir şifreleme tanıtıcısı.

Dönen Değerler

Kip, küme algoritmaları kullanmak için ise TRUE, değilse FALSE döner.

mcrypt_enc_get_supported_key_sizes
mcrypt_enc_is_block_algorithm
Mcrypt İşlevleri


Açık kipin algoritması bir küme algoritması mı diye bakar

mcrypt_enc_is_block_algorithm_mode
mcrypt_enc_is_block_mode
Mcrypt İşlevleri
PHP Manual

mcrypt_enc_is_block_algorithm

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

mcrypt_enc_is_block_algorithm — Açık kipin algoritması bir küme algoritması mı diye bakar

Açıklama

bool mcrypt_enc_is_block_algorithm ( resource $şt )

Açık kipin algoritmasının bir küme algoritması olup olmadığına bakar.

Değiştirgeler

şt

mcrypt_module_open() tarafından döndürülmüş bir şifreleme tanıtıcısı.

Dönen Değerler

Algoritma bir küme algoritması ise TRUE, bir akım algoritması ise FALSE döner.

mcrypt_enc_is_block_algorithm_mode
mcrypt_enc_is_block_mode
Mcrypt İşlevleri


Açık kip küme çıktılayan türde mi diye bakar

mcrypt_enc_is_block_algorithm
mcrypt_enc_self_test
Mcrypt İşlevleri
PHP Manual

mcrypt_enc_is_block_mode

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

mcrypt_enc_is_block_mode — Açık kip küme çıktılayan türde mi diye bakar

Açıklama

bool mcrypt_enc_is_block_mode ( resource $şt )

Açık kip küme çıktılayan türde mi diye bakar (yani, cbc ve ecb için TRUE, cfb ve akım kipleri için FALSE döndürür.

Değiştirgeler

şt

mcrypt_module_open() tarafından döndürülmüş bir şifreleme tanıtıcısı.

Dönen Değerler

Kip, bayt kümeleri halinde çıktılama yapıyorsa TRUE, baytları çıktılıyorsa FALSE döner.

mcrypt_enc_is_block_algorithm
mcrypt_enc_self_test
Mcrypt İşlevleri


Şifreleme tanıtıcısı ile belirtilen modülün kendi kendini sınamasını sağlar

mcrypt_enc_is_block_mode
mcrypt_encrypt
Mcrypt İşlevleri
PHP Manual

mcrypt_enc_self_test

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

mcrypt_enc_self_test — Şifreleme tanıtıcısı ile belirtilen modülün kendi kendini sınamasını sağlar

Açıklama

int mcrypt_enc_self_test ( resource $şt )

şt şifreleme tanıtıcısı ile belirtilen modülün kendi kendini sınamasını sağlar.

Değiştirgeler

şt

mcrypt_module_open() tarafından döndürülmüş bir şifreleme tanıtıcısı.

Dönen Değerler

Sınama başarılı olursa TRUE yoksa FALSE döner.

mcrypt_enc_is_block_mode
mcrypt_encrypt
Mcrypt İşlevleri


Salt metin veriyi belirtilen değiştirgelerle şifreler

mcrypt_enc_self_test
mcrypt_generic_deinit
Mcrypt İşlevleri
PHP Manual

mcrypt_encrypt

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

mcrypt_encrypt — Salt metin veriyi belirtilen değiştirgelerle şifreler

Açıklama

string mcrypt_encrypt ( string $şifre , string $anahtar , string $veri , string $kip [, string $iv ] )

Veriyi şifreleyip döndürür.

Değiştirgeler

şifre

MCRYPT_şifre_adı sabitlerinden biri veya bir dizge olarak bir algoritma ismi.

anahtar

Verinin şifreleneceği anahtar. Gereken boydan kısaysa eksik kısım "\0" karakteri ile doldurulur. Anahtar olarak ASCII dizgeler kullanmaya çalışın.

Bir dizgeden bir anahtar oluşturmak için hash işlevlerini kullanmanız önerilir.

veri

Belirtilen şifre ve kip ile şifrelenecek veri. Veri uzunluğu desteklenen küme boyunun katlarından farklıysa eksik kısım "\0" karakteri ile doldurulur.

Dönen şifreli veri girilen veriden daha uzun olabilir.

kip

MCRYPT_MODE_kip_adı sabitlerinden veya şu dizgelerden biri: "ecb", "cbc", "cfb", "ofb", "nofb", "stream".

iv

CBC, CFB, OFB kiplerini ve bazı akım kiplerini ilklendirmek için kullanılır. Bir IV belirtilmezse ve algoritma için bir IV gerekliyse tüm baytları "\0" karakterlerinden oluşan bir dizge kullanılır.

Dönen Değerler

Şifrelenmiş veriyi bir dizge olarak döndürür.

Örnekler

Örnek 1 - mcrypt_encrypt() örneği

<?php
    $iv_size = mcrypt_get_iv_size(MCRYPT_RIJNDAEL_256, MCRYPT_MODE_ECB);
    $iv = mcrypt_create_iv($iv_size, MCRYPT_RAND);
    $key = "Bu çok gizli bir anahtar";
    $text = "Saat 11'de gizli yerimizde buluşalım.";
    echo strlen($text) . "\n";

    $crypttext = mcrypt_encrypt(MCRYPT_RIJNDAEL_256, $key, $text,
                  MCRYPT_MODE_ECB, $iv);
    echo strlen($crypttext) . "\n";
?>

Yukarıdaki örneğin çıktısı:

42
64

Ayrıca Bakınız

  • mcrypt_module_open() - Kullanılacak kipi ve algoritma modülünü açar

mcrypt_enc_self_test
mcrypt_generic_deinit
Mcrypt İşlevleri


Bir şifreleme tanıtıcısını yeniden ilklendirir

mcrypt_encrypt
mcrypt_generic_end
Mcrypt İşlevleri
PHP Manual

mcrypt_generic_deinit

(PHP 4 >= 4.0.7, PHP 5, PHP 7)

mcrypt_generic_deinit — Bir şifreleme tanıtıcısını yeniden ilklendirir

Açıklama

bool mcrypt_generic_deinit ( resource $şt )

This function terminates encryption specified by the encryption Şifre tanıtıcısı (şt) ile belirtilen şifrelemeyi sonlandırır. Tüm tamporları temizler fakat modülü kapatmaz. Modülü kapatmak için mcrypt_module_close() işlevini kullanmalısınız. (Unutursanız, betik sonunda PHP bunu sizin yerinize yapacaktır).

Değiştirgeler

şt

mcrypt_module_open() tarafından döndürülmüş bir şifreleme tanıtıcısı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • mcrypt_module_open() - Kullanılacak kipi ve algoritma modülünü açar
  • mcrypt_generic_init() - Şifreleme için gerekli tüm tamponları ilklendirir

mcrypt_encrypt
mcrypt_generic_end
Mcrypt İşlevleri


Şifrelemeyi sonlandırır

mcrypt_generic_deinit
mcrypt_generic_init
Mcrypt İşlevleri
PHP Manual

mcrypt_generic_end

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_generic_end — Şifrelemeyi sonlandırır

Açıklama

bool mcrypt_generic_end ( resource $şt )

Uyarı

Bu işlevin kullanımı önerilmemektedir, yerine mcrypt_generic_deinit() işlevini kullanın. mcrypt_module_close() işlevi ile kullanıldığında çok sayıda tamponun serbest bırakılması sebebiyle çökmelere sebep olabilir.

şt ile belirtilen şifreleme tanıtıcısı ile gerçekleştirlen şifrelemeyi sonlandırır. Tüm tamponları temizler ve kullanılan tüm modülleri kapatır. Hete durumunda FALSE yoksa TRUE döndürür.

mcrypt_generic_deinit
mcrypt_generic_init
Mcrypt İşlevleri


Şifreleme için gerekli tüm tamponları ilklendirir

mcrypt_generic_end
mcrypt_generic
Mcrypt İşlevleri
PHP Manual

mcrypt_generic_init

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

mcrypt_generic_init — Şifreleme için gerekli tüm tamponları ilklendirir

Açıklama

int mcrypt_generic_init ( resource $şt , string $anahtar , string $iv )

mcrypt_generic() veya mdecrypt_generic() işlevinden önce bu işlevi çağırmanız gerekir.

Değiştirgeler

şt

mcrypt_module_open() tarafından döndürülmüş bir şifreleme tanıtıcısı.

anahtar

Azami anahtar uzunluğu mcrypt_enc_get_key_size() işlevi ile öğrenilebilir; işlevin döndürdüğü değer ve daha küçük her değer geçerlidir.

iv

Normalde algoritma küme uzunluğundadır, fakat gerçek boyu mcrypt_enc_get_iv_size() işleviyle de öğrenebilirsiniz. ECB kipinde IV yok sayılır. CFB, CBC, STREAM, nOFB ve OFB kipleri için bir IV olması ZORUNLUdur. Rasgele ve eşsiz (fakat gizli değil) olmalıdır. Şifreleme ve şifre çözme amacıyla aynı veri için aynı IV kullanılmalıdır. Bir IV kullanmak istemiyorsanız sıfırlarla (\0) doldubilirsiniz, fakat bunu yapmanız önerilmez.

Dönen Değerler

İşlev bir hata durumunda negatif bir değer döndürür. Anahtar uzunluğu hatalı ise -3, bellek ayırmada sorun çıkmışsa -4, bilinmeyen bir hata türü için bunlar dışında bir negatif değer döner. Hatayla birlikte bir de uyarı gösterilir.Yanlış sayıda değiştirge aktarılması halinde işlev FALSE döndürür.

Ayrıca Bakınız

  • mcrypt_module_open() - Kullanılacak kipi ve algoritma modülünü açar

mcrypt_generic_end
mcrypt_generic
Mcrypt İşlevleri


Veriyi şifreler

mcrypt_generic_init
mcrypt_get_block_size
Mcrypt İşlevleri
PHP Manual

mcrypt_generic

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

mcrypt_generic — Veriyi şifreler

Açıklama

string mcrypt_generic ( resource $şt , string $veri )

Bu işlev veriyi şifreler ve döndürür. Verinin küme boyunun katları uzunlukta olmasını sağlamak için dolgu olarak "\0" karakteri kullanılır, bu yüzden dönen şifresi çözülmüş veri özgün şifresiz veriden daha uzun olur.

Şifreli veriyi bir veritabanında saklamak isterseniz, işlevden dönen verinin tamamını sakladığınızdan emin olun, yoksa şifresini çözmek mümkün olmayabilir. Özgün dizgeniz 10 karakterlikse ve küme boyu da 8 bayt ise veritabanı alanının genişliği en az 16 bayt olmalıdır (küme boyunu öğrenmek için mcrypt_enc_get_block_size() işlevini kullanın. mdecrypt_generic() işlevi 10 baytlık veri için 16 bayt döndürmüşse fazlalıkları silmek için rtrim($str, "\0") işlevini kullanabilirsiniz.

Veriyi örneğin bir MySQL veritabanında saklıyorsanız varchar alanlarının veriyi saklarken verinin sonundaki fazladan boşlukları kendiliğinden sildiğini unutmayın. Boşluk karakteri (ASCII 32) ile biten bir şifreli veri bu yüzden kullanılmaz hale gelebilir. Bu bakımdan şifreli verileri bir tinyblob/tinytext (veya daha büyük) alanlarda saklamanız önerilir.

Değiştirgeler

şt

mcrypt_module_open() tarafından döndürülmüş bir şifreleme tanıtıcısı.

Bu işlevi kullanmadan önce şifreleme tanıtıcısını bir anahtar ve bir IV kullanarak mcrypt_generic_init() işlevi ile ilklendirmelisiniz. Şifreleme bittikten sonra şifreleme tampolarını mcrypt_generic_deinit() işlevi ile serbest bırakabilirsiniz. Kullanım örneği için mcrypt_module_open() işlevine bakınız.

veri

Şifrelenecek veri.

Dönen Değerler

Şifrelenmiş veriyi döndürür.

Ayrıca Bakınız

  • mdecrypt_generic() - Verinin şifresini çözer
  • mcrypt_generic_init() - Şifreleme için gerekli tüm tamponları ilklendirir
  • mcrypt_generic_deinit() - Bir şifreleme tanıtıcısını yeniden ilklendirir

mcrypt_generic_init
mcrypt_get_block_size
Mcrypt İşlevleri


Belirtilen şifrenin küme uzunluğunu döndürür

mcrypt_generic
mcrypt_get_cipher_name
Mcrypt İşlevleri
PHP Manual

mcrypt_get_block_size

(PHP 4, PHP 5, PHP 7)

mcrypt_get_block_size — Belirtilen şifrenin küme uzunluğunu döndürür

Açıklama

int mcrypt_get_block_size ( int $şifre )
int mcrypt_get_block_size ( string $şifre , string $kip )

İlk sözdizimi libmcrypt 2.2.x için, ikincisi libmcrypt 2.4.x ve üstü içindir.

mcrypt_get_block_size() işlevi belirtilen kip ve şifre için küme uzunluğunu döndürür.

mcrypt_module_open() ile döndürülen şifreleme tanıtıcısını kullanması nedeniyle mcrypt_enc_get_block_size() işlevi daha kullanışlıdır.

Değiştirgeler

şifre

Bir dizge olarak kullanılacak algoritmanın ismi veya MCRYPT_şifre_adı sabitlerinden biri.

kip

Kip.

Dönen Değerler

Blok uzunluğunu bayt sayısı olarak döndürür.

Örnekler

Örnek 1 - mcrypt_get_block_size() örneği

Bu örnekteki işlev libmcrypt 2.4.x ve üstü içindir.

<?php

echo mcrypt_get_block_size('tripledes', 'ecb'); // çıktısı: 8

?>

Ayrıca Bakınız

  • mcrypt_get_key_size() - Belirtilen şifrenin anahtar uzunluğunu döndürür
  • mcrypt_enc_get_block_size() - Açık algoritmanın küme boyunu döndürür
  • mcrypt_encrypt() - Salt metin veriyi belirtilen değiştirgelerle şifreler

mcrypt_generic
mcrypt_get_cipher_name
Mcrypt İşlevleri


Belirtilen şifrenin ismini döndürür

mcrypt_get_block_size
mcrypt_get_iv_size
Mcrypt İşlevleri
PHP Manual

mcrypt_get_cipher_name

(PHP 4, PHP 5, PHP 7)

mcrypt_get_cipher_name — Belirtilen şifrenin ismini döndürür

Açıklama

string mcrypt_get_cipher_name ( int $şifre )
string mcrypt_get_cipher_name ( string $şifre )

mcrypt_get_cipher_name() işlevi belirtilen şifrenin ismini öğrenmek için kulanılır.

mcrypt_get_cipher_name() işlevi değiştirge olarak bir şifre numarası (libmcrypt 2.2.x) veya bir şifre ismi (libmcrypt 2.4.x ve üstü) alır ve varsa şifrenin ismini yoksa FALSE döndürür.

Değiştirgeler

cipher

MCRYPT_şifre_adı sabitlerinden biri veya bir dizge olarak bir algoritma ismi.

Dönen Değerler

Belirtilen şifre yoksa FALSE aksi takdirde şifre ismini içeren bir dizge döndürür.

Örnekler

Örnek 1 - mcrypt_get_cipher_name() örneği

<?php
   $şifre = MCRYPT_TripleDES;

   echo mcrypt_get_cipher_name($şifre);
?>

Yukarıdaki örneğin çıktısı:

3DES

mcrypt_get_block_size
mcrypt_get_iv_size
Mcrypt İşlevleri


Belirtilen şifre ve kipe özgü IV uzunluğunu döndürür

mcrypt_get_cipher_name
mcrypt_get_key_size
Mcrypt İşlevleri
PHP Manual

mcrypt_get_iv_size

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

mcrypt_get_iv_size — Belirtilen şifre ve kipe özgü IV uzunluğunu döndürür

Açıklama

int mcrypt_get_iv_size ( string $şifre , string $kip )

Belirtilen şifre ve kipe özgü IV uzunluğunu döndürür.

mcrypt_module_open() ile döndürülen şifreme tanıtıcısını kullanan mcrypt_enc_get_iv_size() işlevi daha kullanışlıdır.

Değiştirgeler

şifre

Bir dizge olarak kullanılacak algoritmanın ismi veya MCRYPT_şifre_adı sabitlerinden biri.

kip

MCRYPT_MODE_kipadı sabitlerinden biri veya şu isimlerden biri: "ecb", "cbc", "cfb", "ofb", "nofb" veya "stream". Gerekli olmadığından ECB kipi yok sayılır. Şifreleme ve şifre çözme için aynı IV'yi kullanmak zorundasınız, aksi takdirde işlem başarısız olur.

Dönen Değerler

İlklendirme Vektörünün (IV) uzunluğu bayt sayısı olarak döner. Hata durumunda FALSE, belirtilen şifre ve kipte IV yok sayılıyorsa 0 döner.

Örnekler

Örnek 1 - mcrypt_get_iv_size() örneği

<?php
    echo mcrypt_get_iv_size(MCRYPT_CAST_256, MCRYPT_MODE_CFB) . "\n";

    echo mcrypt_get_iv_size('des', 'ecb') . "\n";
?>

Ayrıca Bakınız

  • mcrypt_get_block_size() - Belirtilen şifrenin küme uzunluğunu döndürür
  • mcrypt_enc_get_iv_size() - Açık algoritmanın ilklendirme vektörü uzunluğunu döndürür
  • mcrypt_create_iv() - Rasgele bir kaynaktan bir ilklendirme vektörü (IV) oluşturur

mcrypt_get_cipher_name
mcrypt_get_key_size
Mcrypt İşlevleri


Belirtilen şifrenin anahtar uzunluğunu döndürür

mcrypt_get_iv_size
mcrypt_list_algorithms
Mcrypt İşlevleri
PHP Manual

mcrypt_get_key_size

(PHP 4, PHP 5, PHP 7)

mcrypt_get_key_size — Belirtilen şifrenin anahtar uzunluğunu döndürür

Açıklama

int mcrypt_get_key_size ( int $şifre )
int mcrypt_get_key_size ( string $şifre , string $kip )

İlk sözdizimi libmcrypt 2.2.x için, ikincisi ise libmcrypt 2.4.x veya 2.5.x içindir.

mcrypt_get_key_size() işlevi belirtilen kipte şifre anahtarının uzunluğunu döndürür.

Değiştirgeler

şifre

Kullanılacak şifre.

kip

Kullanılacak kip.

Örnekler

Bu örnekteki işlev libmcrypt 2.4.x ve 2.5.x destekli sistemler içindir. mcrypt_module_open() ile döndürülen şifreleme tanıtıcısını kullanan mcrypt_enc_get_key_size() işlevi daha kullanışlıdır.

Örnek 1 - mcrypt_get_key_size() örneği

<?php
    echo mcrypt_get_key_size('tripledes', 'ecb');
?>

Çıktısı:
24

Ayrıca Bakınız

  • mcrypt_get_block_size() - Belirtilen şifrenin küme uzunluğunu döndürür
  • mcrypt_enc_get_key_size() - Açık kipin desteklediği azami anahtar uzunluğunu döndürür
  • mcrypt_encrypt() - Salt metin veriyi belirtilen değiştirgelerle şifreler

mcrypt_get_iv_size
mcrypt_list_algorithms
Mcrypt İşlevleri


Desteklenen şifreleri listeler

mcrypt_get_key_size
mcrypt_list_modes
Mcrypt İşlevleri
PHP Manual

mcrypt_list_algorithms

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

mcrypt_list_algorithms — Desteklenen şifreleri listeler

Açıklama

array mcrypt_list_algorithms ([ string $lib_dir = ini_get("mcrypt.algorithms_dir") ] )

lib_dir ile belirtilen dizinde bulunan dosyalar tarafından desteklenen algoritmaların listesini döndürür.

Değiştirgeler

lib_dir

Belirtilmesi isteğe bağlı olup algoritma modülünün sistemdeki yerini belirtmek için kullanılır. Belirtilmezse mcrypt.algorithms_dir php.ini yönergesinin değeri kullanılır.

Dönen Değerler

Desteklenen algoritmaları içeren bir dizi döner.

Örnekler

Örnek 1 - mcrypt_list_algorithms() örneği

<?php
    $algoritmalar = mcrypt_list_algorithms("/usr/local/lib/libmcrypt");

    foreach ($algoritmalar as $şifre) {
        echo "$şifre<br />\n";
    }
?>

Örnekte, "/usr/local/lib/libmcrypt" dizininde desteklenen tüm algoritmalar listelenmektedir.

mcrypt_get_key_size
mcrypt_list_modes
Mcrypt İşlevleri


Desteklenen kiplerin listesini döndürür

mcrypt_list_algorithms
mcrypt_module_close
Mcrypt İşlevleri
PHP Manual

mcrypt_list_modes

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

mcrypt_list_modes — Desteklenen kiplerin listesini döndürür

Açıklama

array mcrypt_list_modes ([ string $lib_dir = ini_get("mcrypt.algorithms_dir") ] )

lib_dir ile belirtilen dizinde bulunan dosyalar tarafından desteklenen kiplerin listesini döndürür.

Değiştirgeler

lib_dir

Belirtilmesi isteğe bağlı olup algoritma modülünün sistemdeki yerini belirtmek için kullanılır. Belirtilmezse mcrypt.algorithms_dir php.ini yönergesinin değeri kullanılır.

Dönen Değerler

Desteklenen kipleri içeren bir dizi döner.

Örnekler

Örnek 1 - mcrypt_list_modes() örneği

<?php
    $kipler = mcrypt_list_modes();

    foreach ($kipler as $kip) {
        echo "$kip <br />\n";
    }
?>

Örnek, öntanımlı kip dizininde desteklenen tüm algoritmaları listeler. mcrypt.modes_dir php.ini yönergesi ile bir dizin belirtilmemişse öntanımlı mcrypt dizini kullanılır (genellikle /usr/local/lib/libmcrypt).

mcrypt_list_algorithms
mcrypt_module_close
Mcrypt İşlevleri


Şifreleme tanıtıcısını kapatır

mcrypt_list_modes
mcrypt_module_get_algo_block_size
Mcrypt İşlevleri
PHP Manual

mcrypt_module_close

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

mcrypt_module_close — Şifreleme tanıtıcısını kapatır

Açıklama

bool mcrypt_module_close ( resource $şt )

Belirtilen şifreleme tanıtıcısını kapatır.

Değiştirgeler

şt

mcrypt_module_open() tarafından döndürülmüş bir şifreleme tanıtıcısı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • mcrypt_module_open() - Kullanılacak kipi ve algoritma modülünü açar

mcrypt_list_modes
mcrypt_module_get_algo_block_size
Mcrypt İşlevleri


Belirtilen algoritmanın küme boyunu döndürür

mcrypt_module_close
mcrypt_module_get_algo_key_size
Mcrypt İşlevleri
PHP Manual

mcrypt_module_get_algo_block_size

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

mcrypt_module_get_algo_block_size — Belirtilen algoritmanın küme boyunu döndürür

Açıklama

int mcrypt_module_get_algo_block_size ( string $algoritma [, string $lib_dir ] )

Belirtilen algoritmanın küme boyunu döndürür.

Değiştirgeler

algoritma

Kullanılacak algoritma.

lib_dir

Belirtilmesi isteğe bağlı olup algoritma modülünün sistemdeki yerini belirtmek için kullanılır. Belirtilmezse mcrypt.algorithms_dir php.ini yönergesinin değeri kullanılır.

Dönen Değerler

Belirtilen algoritmanın küme boyunu bayt sayısı olarak döndürür.

mcrypt_module_close
mcrypt_module_get_algo_key_size
Mcrypt İşlevleri


Belirtilen algoritmanın desteklediği azami anahtar uzunluğunu döndürür

mcrypt_module_get_algo_block_size
mcrypt_module_get_supported_key_sizes
Mcrypt İşlevleri
PHP Manual

mcrypt_module_get_algo_key_size

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

mcrypt_module_get_algo_key_size — Belirtilen algoritmanın desteklediği azami anahtar uzunluğunu döndürür

Açıklama

int mcrypt_module_get_algo_key_size ( string $algoritma [, string $lib_dir ] )

Belirtilen algoritmanın desteklediği azami anahtar uzunluğunu döndürür.

Değiştirgeler

algoritma

Kullanılacak algoritma.

lib_dir

Belirtilmesi isteğe bağlı olup algoritma modülünün sistemdeki yerini belirtmek için kullanılır. Belirtilmezse mcrypt.algorithms_dir php.ini yönergesinin değeri kullanılır.

Dönen Değerler

Belirtilen algoritmanın desteklediği azami anahtar uzunluğunu bayt sayısı olarak döndürür.

mcrypt_module_get_algo_block_size
mcrypt_module_get_supported_key_sizes
Mcrypt İşlevleri


Belirtilen algoritmanın desteklediği anahtar boyutlarını listeler

mcrypt_module_get_algo_key_size
mcrypt_module_is_block_algorithm_mode
Mcrypt İşlevleri
PHP Manual

mcrypt_module_get_supported_key_sizes

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

mcrypt_module_get_supported_key_sizes — Belirtilen algoritmanın desteklediği anahtar boyutlarını listeler

Açıklama

array mcrypt_module_get_supported_key_sizes ( string $algoritma [, string $lib_dir ] )

Belirtilen algoritmanın desteklediği anahtar boyutlarını bir dizi olarak döndürür. Boş bir dizi dönerse 1 ile mcrypt_module_get_algo_key_size() arasındaki tüm anahtar boyutları algoritma tarafından destekleniyor demektir.

Değiştirgeler

algoritma

Kullanılacak algoritma.

lib_dir

Belirtilmesi isteğe bağlı olup algoritma modülünün sistemdeki yerini belirtmek için kullanılır. Belirtilmezse mcrypt.algorithms_dir php.ini yönergesinin değeri kullanılır.

Dönen Değerler

Belirtilen algoritmanın desteklediği anahtar boyutlarını içeren bir dizi döndürür. Boş bir dizi dönerse 1 ile mcrypt_module_get_algo_key_size() arasındaki tüm anahtar boyutları algoritma tarafından destekleniyor demektir.

Ayrıca Bakınız

  • mcrypt_enc_get_supported_key_sizes() - Açık algoritmanın desteklediği anahtar boylarını listeler

mcrypt_module_get_algo_key_size
mcrypt_module_is_block_algorithm_mode
Mcrypt İşlevleri


Belirtilen kip, küme algoritmaları ile kullanılabiliryor mu diye bakar

mcrypt_module_get_supported_key_sizes
mcrypt_module_is_block_algorithm
Mcrypt İşlevleri
PHP Manual

mcrypt_module_is_block_algorithm_mode

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

mcrypt_module_is_block_algorithm_mode — Belirtilen kip, küme algoritmaları ile kullanılabiliryor mu diye bakar

Açıklama

bool mcrypt_module_is_block_algorithm_mode ( string $kip [, string $lib_dir ] )

Belirtilen kip küme algoritmaları ile kullanılıyorsa TRUE, yoksa FALSE döndürür. (Yani, akım algoritmaları için FALSE; cbc, cfb, ofb için TRUE döndürür).

Değiştirgeler

kip

Sınanacak kip.

lib_dir

Belirtilmesi isteğe bağlı olup algoritma modülünün sistemdeki yerini belirtmek için kullanılır. Belirtilmezse mcrypt.algorithms_dir php.ini yönergesinin değeri kullanılır.

Dönen Değerler

Belirtilen kip küme algoritmaları ile kullanılıyorsa TRUE, yoksa FALSE döndürür. (Yani, akım algoritmaları için FALSE; cbc, cfb, ofb için TRUE döndürür).

mcrypt_module_get_supported_key_sizes
mcrypt_module_is_block_algorithm
Mcrypt İşlevleri


Belirtilen algoritma bir küme algoritması mı diye bakar

mcrypt_module_is_block_algorithm_mode
mcrypt_module_is_block_mode
Mcrypt İşlevleri
PHP Manual

mcrypt_module_is_block_algorithm

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

mcrypt_module_is_block_algorithm — Belirtilen algoritma bir küme algoritması mı diye bakar

Açıklama

bool mcrypt_module_is_block_algorithm ( string $algoritma [, string $lib_dir ] )

Belirtilen algoritma bir küme algoritması ise TRUE akım algoritması ise FALSE döner.

Değiştirgeler

algoritma

Çıktılama kipine bakılacak algoritma.

lib_dir

Belirtilmesi isteğe bağlı olup algoritma modülünün sistemdeki yerini belirtmek için kullanılır. Belirtilmezse mcrypt.algorithms_dir php.ini yönergesinin değeri kullanılır.

Dönen Değerler

Belirtilen algoritma bir küme algoritması ise TRUE akım algoritması ise FALSE döner.

mcrypt_module_is_block_algorithm_mode
mcrypt_module_is_block_mode
Mcrypt İşlevleri


Belirtilen kip bir küme kipi mi diye bakar

mcrypt_module_is_block_algorithm
mcrypt_module_open
Mcrypt İşlevleri
PHP Manual

mcrypt_module_is_block_mode

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

mcrypt_module_is_block_mode — Belirtilen kip bir küme kipi mi diye bakar

Açıklama

bool mcrypt_module_is_block_mode ( string $kip [, string $lib_dir ] )

Belirtilen kip bayt kümeleri çıktılıyorsa TRUE sadece bir bayt dizisi çıktılıyorsa FALSE döner (örneğin, cbc ve icb için TRUE, vfb ve akım için FALSE döndürür).

Değiştirgeler

kip

Çıktılama kipine bakılacak kip.

lib_dir

Belirtilmesi isteğe bağlı olup algoritma modülünün sistemdeki yerini belirtmek için kullanılır. Belirtilmezse mcrypt.algorithms_dir php.ini yönergesinin değeri kullanılır.

Dönen Değerler

Belirtilen kip bayt kümeleri çıktılıyorsa TRUE sadece bir bayt dizisi çıktılıyorsa FALSE döner (örneğin, cbc ve icb için TRUE, vfb ve akım için FALSE döndürür).

mcrypt_module_is_block_algorithm
mcrypt_module_open
Mcrypt İşlevleri


Kullanılacak kipi ve algoritma modülünü açar

mcrypt_module_is_block_mode
mcrypt_module_self_test
Mcrypt İşlevleri
PHP Manual

mcrypt_module_open

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

mcrypt_module_open — Kullanılacak kipi ve algoritma modülünü açar

Açıklama

resource mcrypt_module_open ( string $algoritma , string $algoritma_dizini , string $kip , string $kip_dizini )

Kullanılacak kipi ve algoritma modülünü açar. Algoritma doğrudan ismiyle belirtilebileceği gibi ("twofish" gibi), MCRYPT_şifre_adı sabitlerinden biri de belirtilebilir. Modülü kapatmak için mcrypt_module_close() kullanılır.

Değiştirgeler

algoritma

Kullanılacak algoritma.

algoritma_dizini

algorithm_dizini ve mode_dizini şifreleme modüllerinin yerlerini belirtmek için kullanılır. Bir dizin yerine boş bir dizge belirtirseniz mcrypt.algorithms_dir veya mcrypt.modes_dir php.ini yönergelerinin değerleri kullanılır. Bunlar atanmamışsa libmcrypt derlenirken kullanılan öntanımlı dizinler kullanılır (genellikle /usr/local/lib/libmcrypt).

kip

Kullanılacak kip.

kip_dizini

Dönen Değerler

Bir hata durumunda FALSE yoksa bir şifreleme tanıtıcısı döndürür.

Örnekler

Örnek 1 - mcrypt_module_open() örnekleri

<?php
    $şt = mcrypt_module_open(MCRYPT_DES, '',
        MCRYPT_MODE_ECB, '/usr/lib/mcrypt-modes');

    $şt = mcrypt_module_open('rijndael-256', '', 'ofb', '');
?>

Yukarıdaki örnekteki ilk satır öntanımlı dizindeki DES şifre modülünü ve /usr/lib/mcrypt-modes dizinindeki EBC kip modülünü açacaktır. İkinci örnekte şifre ve kip için isimleri kullanılmaktadır. Bu örnek sadece eklenti, libmcrypt 2.4.x veya 2.5.x desteğiyle derlenmişse çalışacaktır.

Örnek 2 - Şifreleme için mcrypt_module_open() kullanımı

<?php
    /* Şifre modülünü açalım */
    $şt = mcrypt_module_open('rijndael-256', '', 'ofb', '');

    /* IV'yi oluşturup anahtar uzunluğunu belirleyelim.
       Windows'ta bunun yerine MCRYPT_RAND kullanın */
    $iv = mcrypt_create_iv(mcrypt_enc_get_iv_size($şt), MCRYPT_DEV_RANDOM);
    $ks = mcrypt_enc_get_key_size($şt);

    /* Anahtarı oluşturalım */
    $tuz = substr(md5('çok gizli anahtar'), 0, $ks);

    /* Şifreleme işlemini ilklendirelim */
    mcrypt_generic_init($şt, $tuz, $iv);

    /* Veriyi şifreleyelim */
    $şifreli = mcrypt_generic($şt, 'Bu çok önemli bir veridir.');

    /* Şifre tanıtıcısını sonlandıralım */
    mcrypt_generic_deinit($şt);

    /* Şifreleme modülünü şifre çözmek için ilklendirelim */
    mcrypt_generic_init($şt, $tuz, $iv);

    /* Verinin şifresini çözelim */
    $şifresiz = mdecrypt_generic($şt, $şifreli);

    /* Şifre çözme tanıtıcısını sonlandıralım ve modülü kapatalım */
    mcrypt_generic_deinit($şt);
    mcrypt_module_close($şt);

    /* Dizgeyi gösterelim */
    echo trim($şifresiz) . "\n";
?>

Ayrıca Bakınız

  • mcrypt_module_close() - Şifreleme tanıtıcısını kapatır
  • mcrypt_generic() - Veriyi şifreler
  • mdecrypt_generic() - Verinin şifresini çözer
  • mcrypt_generic_init() - Şifreleme için gerekli tüm tamponları ilklendirir
  • mcrypt_generic_deinit() - Bir şifreleme tanıtıcısını yeniden ilklendirir

mcrypt_module_is_block_mode
mcrypt_module_self_test
Mcrypt İşlevleri


Belirtilen modülün kendini kendini sınamasını sağlar

mcrypt_module_open
mcrypt_ofb
Mcrypt İşlevleri
PHP Manual

mcrypt_module_self_test

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

mcrypt_module_self_test — Belirtilen modülün kendini kendini sınamasını sağlar

Açıklama

bool mcrypt_module_self_test ( string $algoritma [, string $lib_dir ] )

Belirtilen modülün kendini kendini sınamasını sağlar.

Değiştirgeler

algoritma

Sınanacak algoritma.

lib_dir

Belirtilmesi isteğe bağlı olup algoritma modülünün sistemdeki yerini belirtmek için kullanılır. Belirtilmezse mcrypt.algorithms_dir php.ini yönergesinin değeri kullanılır.

Dönen Değerler

Sınama başarılı olursa TRUE yoksa FALSE döner.

Örnekler

Örnek 1 - mcrypt_module_self_test() örneği

<?php
var_dump(mcrypt_module_self_test(MCRYPT_RIJNDAEL_128)) . "\n";
var_dump(mcrypt_module_self_test(MCRYPT_BOGUS_CYPHER));
?>

Yukarıdaki örneğin çıktısı:

bool(true)
bool(false)

mcrypt_module_open
mcrypt_ofb
Mcrypt İşlevleri


Önerilmiyor: Veriyi OFB kipinde şifreler/çözer

mcrypt_module_self_test
mdecrypt_generic
Mcrypt İşlevleri
PHP Manual

mcrypt_ofb

(PHP 4, PHP 5)

mcrypt_ofb — Önerilmiyor: Veriyi OFB kipinde şifreler/çözer

Açıklama

string mcrypt_ofb ( int $şifre , string $tuz , string $veri , int $kip , string $iv )
string mcrypt_ofb ( string $şifre , string $tuz , string $veri , int $kip [, string $iv ] )

İlk sözdizimi libmcrypt 2.2.x için, ikincisi ise libmcrypt 2.4.x ve üstü içindir. kip olarak MCRYPT_ENCRYPT veya MCRYPT_DECRYPT belirtilebilir.

Bu işlev artık kullanılmamalıdır. Yerine kullanılacak işlevler için mcrypt_generic() ve mdecrypt_generic() işlevine bakınız.

mcrypt_module_self_test
mdecrypt_generic
Mcrypt İşlevleri


Verinin şifresini çözer

mcrypt_ofb
Mhash
Mcrypt İşlevleri
PHP Manual

mdecrypt_generic

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

mdecrypt_generic — Verinin şifresini çözer

Açıklama

string mdecrypt_generic ( resource $şt , string $veri )

Belirtilen verinin şifresini çözer. Şifresi çözülürken verinin sonuna eklenen baytlar yüzünden dönen dizge şifrelenmemiş dizgeden daha uzundur.

Değiştirgeler

şt

mcrypt_module_open() tarafından döndürülmüş bir şifreleme tanıtıcısı.

data

Şifrelenmiş veri.

Örnekler

Örnek 1 - mdecrypt_generic() örneği

<?php
    /* Veri */
    $tuz = 'Bu anahtar bu şifre için bile gereğinden uzun bir anahtar';
    $veri = 'çok önemli veri';

    /* Modülü açıp bir İV üretelim */
    $şt = mcrypt_module_open('des', '', 'ecb', '');
    $tuz = substr($tuz, 0, mcrypt_enc_get_key_size($şt));
    $iv_boyu = mcrypt_enc_get_iv_size($şt);
    $iv = mcrypt_create_iv($iv_boyu, MCRYPT_RAND);

    /* Şifreleme tanıtıcısını ilklendirelim */
    if (mcrypt_generic_init($şt, $tuz, $iv) != -1) {

        /* Veriyi şifreleyelim */
        $şifreli_veri = mcrypt_generic($şt, $veri);
        mcrypt_generic_deinit($şt);

        /* Şifreyi çözmek için tamponu ilklendirelim */
        mcrypt_generic_init($şt, $tuz, $iv);
        $sonuç = mdecrypt_generic($şt, $şifreli_veri);

        /* Temizlik */
        mcrypt_generic_deinit($şt);
        mcrypt_module_close($şt);
    }

    if (strncmp($sonuç, $veri, strlen($veri)) == 0) {
        echo "Tamam\n";
    } else {
        echo "Hata\n";
    }
?>

Yukarıdaki örnekte, şifreleme öncesi veri ile şifreleme sonrası şifresi çözülmüş verinin nasıl karşılaştırılacağı gösterilmiştir. Bir verinin şifresini çözmeden önce şifreleme tamponunu mcrypt_generic_init() ile yeniden ilklendirmek çok önemlidir.

Bu işlevi çağırmadan önce, mcrypt_generic_init() işlevini bir tuz ve bir İV (ilklendirme vektörü) ile çağırarak şifreleme tanıtıcısını daima ilklendirmelisiniz. Şifreleme bittikten sonra şifreleme tamponlarını mcrypt_generic_deinit() işleviyle serbest bırakmalısınız. Bununla ilgili bir örneği mcrypt_module_open() işlevinin açıklamasında bulabilirsiniz.

Ayrıca Bakınız

  • mcrypt_generic() - Veriyi şifreler
  • mcrypt_generic_init() - Şifreleme için gerekli tüm tamponları ilklendirir
  • mcrypt_generic_deinit() - Bir şifreleme tanıtıcısını yeniden ilklendirir

mcrypt_ofb
Mhash
Mcrypt İşlevleri


Mhash

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
  • Mhash İşlevleri
    • mhash_count — Kullanılabilecek en yüksek algoritma kimliğini döndürür
    • mhash_get_block_size — Belirtilen algoritmanın küme boyunu döndürür
    • mhash_get_hash_name — Belirtilen algoritmanın ismini döndürür
    • mhash_keygen_s2k — Bir anahtar üretir
    • mhash — İleti özetini hesaplar
mdecrypt_generic
Giriş
Şifresel Eklentiler


Giriş

Bu işlevler » mhash ile çalışmak için tasarlanmıştır. Mhash, sağlamalar, ileti özetleri, ileti kimlik doğrulama kodları ve benzerlerini oluşturmak için kullanılır.

Bu eklenti mhash kütüphanesine bir arayüz olup, MD5, SHA1, GOST ve benzeri özetleme algoritmalarını destekler. Desteklenen özet türlerinin tam listesini mhash belgelerinde bulabilirsiniz. PHP'den bir özetleme algoritmasına erişmek için genel kural MHASH_özet_türü sabitlerini kullanmaktır. Örneğin, TIGER algoritmasına erişim için MHASH_TIGER PHP sabiti kullanılır.

Bilginize:

Bu eklenti yerine artık Hash eklentisi kullanılmalıdır.

Mhash
Yapılandırma/Kurulum
Mhash


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Mhash


Gereksinimler

Mhash kullanmak için » Mhash sitesinden kaynak paketini indirip içindeki talimatlara uygun olarak kurun.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu eklentiyi etkin kılmak için PHP'yi --with-mhash[=DiZiN] seçeneği ile derlemelisiniz. DiZiN, mhash kurulum dizinidir.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

Buradaki sabitler Mhash tarafından desteklenen algoritmaların sabitleridir. Burada bulunmayıp da Mhash tarafından desteklenen bir algoritmanın varlığı bu listenin güncel olmadığını gösterir.

  • MHASH_ADLER32
  • MHASH_CRC32
  • MHASH_CRC32B
  • MHASH_GOST
  • MHASH_HAVAL128
  • MHASH_HAVAL160
  • MHASH_HAVAL192
  • MHASH_HAVAL256
  • MHASH_MD4
  • MHASH_MD5
  • MHASH_RIPEMD160
  • MHASH_SHA1
  • MHASH_SHA256
  • MHASH_TIGER
  • MHASH_TIGER128
  • MHASH_TIGER160

Özkaynak Türleri
Örnekler
Mhash


Örnekler

Örnek 1 - Bir dizgenin MD5 ve HMAC özetlerini hesaplayıp sonuçları birer onaltılık dizge olarak çıktılamak

<?php
$input = "what do ya want for nothing?";
$hash = mhash(MHASH_MD5, $input);
echo "MD5 özeti: " . bin2hex($hash) . "<br />\n";
$hash = mhash(MHASH_MD5, $input, "Jefe");
echo "HMAC özeti: " . bin2hex($hash) . "<br />\n";
?>

This will produce:

MD5 özeti: d03cb659cbf9192dcd066272249f8412
HMAC özeti: 750c783e6ab0b503eaa86e310a5db738

Öntanımlı Sabitler
Mhash İşlevleri
Mhash


Mhash İşlevleri

İçindekiler

  • mhash_count — Kullanılabilecek en yüksek algoritma kimliğini döndürür
  • mhash_get_block_size — Belirtilen algoritmanın küme boyunu döndürür
  • mhash_get_hash_name — Belirtilen algoritmanın ismini döndürür
  • mhash_keygen_s2k — Bir anahtar üretir
  • mhash — İleti özetini hesaplar
Örnekler
mhash_count
Mhash


Kullanılabilecek en yüksek algoritma kimliğini döndürür

Mhash İşlevleri
mhash_get_block_size
Mhash İşlevleri
PHP Manual

mhash_count

(PHP 4, PHP 5, PHP 7)

mhash_count — Kullanılabilecek en yüksek algoritma kimliğini döndürür

Açıklama

int mhash_count ( void )

Kullanılabilecek en yüksek algoritma kimliğini döndürür. Özet algoritmaları 0'dan bu algoritma kimliğine kadar numaralıdır.

Dönen Değerler

Kullanılabilecek en büyük algoritma numarasını döndürür.

Örnekler

Örnek 1 - Tüm algoritmaları sıradan geçmek

<?php

$nr = mhash_count();

for ($i = 0; $i <= $nr; $i++) {
    echo sprintf("%s için küme boyu %d bayttır\n",
        mhash_get_hash_name($i),
        mhash_get_block_size($i));
}
?>

Mhash İşlevleri
mhash_get_block_size
Mhash İşlevleri


Belirtilen algoritmanın küme boyunu döndürür

mhash_count
mhash_get_hash_name
Mhash İşlevleri
PHP Manual

mhash_get_block_size

(PHP 4, PHP 5, PHP 7)

mhash_get_block_size — Belirtilen algoritmanın küme boyunu döndürür

Açıklama

int mhash_get_block_size ( int $algoritma )

Belirtilen algoritmanın küme boyunu döndürür.

Değiştirgeler

algoritma

MHASH_XXX sabitlerinden biri olarak kullanılacak algoritma.

Dönen Değerler

algoritma mevcut değilse FALSE varsa bayt cinsinden küme uzunluğu döner.

Örnekler

Örnek 1 - mhash_get_block_size() örneği

<?php

echo mhash_get_block_size(MHASH_MD5); // 16

?>

mhash_count
mhash_get_hash_name
Mhash İşlevleri


Belirtilen algoritmanın ismini döndürür

mhash_get_block_size
mhash_keygen_s2k
Mhash İşlevleri
PHP Manual

mhash_get_hash_name

(PHP 4, PHP 5, PHP 7)

mhash_get_hash_name — Belirtilen algoritmanın ismini döndürür

Açıklama

string mhash_get_hash_name ( int $algoritma )

Belirtilen algoritmanın ismini döndürür.

Değiştirgeler

algoritma

MHASH_XXX sabitlerinden biri olarak kullanılacak algoritma.

Dönen Değerler

algoritma mevcut değilse FALSE varsa algoritmanın ismini döndürür.

Örnekler

Örnek 1 - mhash_get_hash_name() örneği

<?php

echo mhash_get_hash_name(MHASH_MD5); // MD5

?>

mhash_get_block_size
mhash_keygen_s2k
Mhash İşlevleri


Bir anahtar üretir

mhash_get_hash_name
mhash
Mhash İşlevleri
PHP Manual

mhash_keygen_s2k

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

mhash_keygen_s2k — Bir anahtar üretir

Açıklama

string mhash_keygen_s2k ( int $özet , string $parola , string $tuz , int $uzunluk )

Belirtilen özet için kullanıcı tarafından sağlanan parola ile bir anahtar üretir.

Kullanılan algoritma OpenPGP belgesinde (» RFC 2440) belirtilen Tuzlu S2K algoritmasıdır.

Kullanıcılar klavye ile yazabilecekleri anahtarlar seçeceklerinden kullanıcı tarafından sağlanan parolaların anahar olarak kullanılmaya elverişli olmadıklarını unutmayın. Bu parolalarda genelde 6, 7 (veya daha az) bitlik karakterler kullanılır. Kullanıcı tarafından sağlanan anahtara bir çeşit dönüşüm (bu işlev gibi) uygulamanızı hararetle öneririz.

Değiştirgeler

özet

MHASH_XXX sabitlerinden biri olarak anahtarı oluşturmak için kullanılacak özet.

parola

Kullanıcı tarafından sağlanmış parola.

tuz

Anahtar üretirken her anahtar için farklı bir tuz belirtilmelidir. Anahtarı denetlerken bu tuzu bilmeniz gerekir. Bu bakımdan en iyisi anahtara eklemektir. Tuz sabit 8 bayt uzunlukta olmalıdır, eğer daha kısa belirtilirse dolgu karakteri olarak "\0" kullanılır.

bytes

Bayt cinsinden anahtar uzunluğu.

Dönen Değerler

Bir hata durumunda FALSE, yoksa üretilen anahtarı bir dizge olarak döndürür.

mhash_get_hash_name
mhash
Mhash İşlevleri


İleti özetini hesaplar

mhash_keygen_s2k
OpenSSL
Mhash İşlevleri
PHP Manual

mhash

(PHP 4, PHP 5, PHP 7)

mhash — İleti özetini hesaplar

Açıklama

string mhash ( int $algoritma , string $veri [, string $anahtar ] )

Belirtilen algoritma kullanılarak belirtilen veri için bir özet üretilir.

Değiştirgeler

algoritma

MHASH_XXX sabitlerinden biri olarak özet üretiminde kullanılacak algoritma.

veri

Bir dizge olarak özeti üretilecek veri.

anahtar

Belirtilirse işlev bir ileti özeti yerine bir HMAC özeti döndürür. HMAC, ileti kimlik doğrulaması için anahtarlı bir özettir, başka bir deyişle belirtilen anahtara bağlı bir ileti özetidir. Mhash tarafından desteklenen algoritmaların bazıları HMAC kipinde kullanılamaz.

Dönen Değerler

Bir hata durumunda FALSE, yoksa elde edilen ileti özetini veya HMAC özetini bir dizge olarak döndürür.

mhash_keygen_s2k
OpenSSL
Mhash İşlevleri


OpenSSL

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
    • Amaç sınama seçenekleri
    • Dolgu seçenekleri
    • Anahtar türleri
    • PKCS7 Seçenekleri/Sabitleri
    • İmzalama Algoritmaları
    • Şifreler
    • Sürüm sabitleri
  • Anahtar/Sertifika Değiştirgeleri
  • Sertifika Doğrulama
  • OpenSSL İşlevleri
    • openssl_cipher_iv_length — Gets the cipher iv length
    • openssl_csr_export_to_file — Belirtilen CSR'yi bir dosyaya kaydeder
    • openssl_csr_export — Belirtilen CSR'yi bir dizge olarak döndürür
    • openssl_csr_get_public_key — Belirtilen sertifikanın genel anahtarını döndürür
    • openssl_csr_get_subject — Bir sertifika konusu döndürür
    • openssl_csr_new — Bir sertifika imzalama isteği (CSR) üretir
    • openssl_csr_sign — Bir CSR'yi başka bir sertifika (veya kendisi) ile imzalayıp bir sertifika üretir
    • openssl_decrypt — Verinin şifresini çözer
    • openssl_dh_compute_key — Uzak ve yerel özet hesaplama anahtarları için paylaşımlı anahtarı hesaplar
    • openssl_digest — Bir özet hesaplar
    • openssl_encrypt — Veriyi şifreler
    • openssl_error_string — OpenSSL hata iletisini döndürür
    • openssl_free_key — Anahtar özkaynağını serbest bırakır
    • openssl_get_cert_locations — Retrieve the available certificate locations
    • openssl_get_cipher_methods — Kullanılabilecek şifreleme yöntemlerini döndürür
    • openssl_get_md_methods — Kullanılabilecek özet yöntemlerini döndürür
    • openssl_get_privatekey — openssl_pkey_get_private işlevinin takma adıdır
    • openssl_get_publickey — openssl_pkey_get_public işlevinin takma adıdır
    • openssl_open — Mühürlü veriyi açar
    • openssl_pbkdf2 — Generates a PKCS5 v2 PBKDF2 string, defaults to SHA-1
    • openssl_pkcs12_export_to_file — Bir PKCS#12 uyumlu sertifika deposunu bir dosyaya kaydeder
    • openssl_pkcs12_export — PKCS#12 uyumlu sertifika deposu dosyasını bir değişkene yerleştirir
    • openssl_pkcs12_read — Bir PKCS#12 Sertifika Deposunu bir diziye çözümler
    • openssl_pkcs7_decrypt — S/MIME şifreli bir iletinin şifresini çözer
    • openssl_pkcs7_encrypt — Bir S/MIME iletiyi şifreler
    • openssl_pkcs7_sign — Bir S/MIME iletiyi imzalar
    • openssl_pkcs7_verify — S/MIME imzalı bir iletinin imzasını doğrular
    • openssl_pkey_export_to_file — Bir anahtarın ihraç edilebilir gösterimini bir dosyaya kaydeder
    • openssl_pkey_export — Bir anahtarın ihraç edilebilir gösterimini bir dizge olarak döndürür
    • openssl_pkey_free — Bir gizli anahtarı serbest bırakır
    • openssl_pkey_get_details — Anahtarla ilgili ayrıntıları bir dizi içinde döndürür
    • openssl_pkey_get_private — Bir gizli anahtar döndürür
    • openssl_pkey_get_public — Genel anahtarı sertifikadan elde edip kullanıma hazırlar
    • openssl_pkey_new — Yeni bir anahtar çifti üretir
    • openssl_private_decrypt — Genel anahtarla şifrelenmiş verinin şifresini gizli anahtarla çözer
    • openssl_private_encrypt — Veriyi gizli anahtarla şifreler
    • openssl_public_decrypt — Gizli anahtarla şifrelenmiş verinin şifresini genel anahtarla çözer
    • openssl_public_encrypt — Veriyi genel anahtarla şifreler
    • openssl_random_pseudo_bytes — Yarı-rasgele dizge üretir
    • openssl_seal — Veriyi mühürler
    • openssl_sign — İmza üretir
    • openssl_spki_export_challenge — Exports the challenge assoicated with a signed public key and challenge
    • openssl_spki_export — Exports a valid PEM formatted public key signed public key and challenge
    • openssl_spki_new — Generate a new signed public key and challenge
    • openssl_spki_verify — Verifies a signed public key and challenge
    • openssl_verify — İmzayı doğrular
    • openssl_x509_check_private_key — Bir gizli anahtarın bir sertifikaya karşılık olup olmadığına bakar
    • openssl_x509_checkpurpose — Sertifikanın belli bir amaçla kulanılıp kullanılmayacağına bakar
    • openssl_x509_export_to_file — Belirtilen sertifikayı bir dosyaya kaydeder
    • openssl_x509_export — Belirtilen sertifikayı bir dizge olarak döndürür
    • openssl_x509_fingerprint — Calculates the fingerprint, or digest, of a given X.509 certificate
    • openssl_x509_free — Sertifika özkaynağını serbest bırakır
    • openssl_x509_parse — Bir X509 sertifikasını çözümleyip bilgileri bir dizi içinde döndürür
    • openssl_x509_read — Bir X.509 sertifikasını çözümleyip sertifika için bir tanıtıcı döndürür
mhash
Giriş
Şifresel Eklentiler


Giriş

Bu modülde, imzaların üretimi ve doğrulanması, verilerin şifrelenmesi veya şifrelerinin çözülmesi için » OpenSSL işlevleri kullanılır. OpenSSL, bu modül tarafından şimdilik desteklenmeyen daha pek çok özelliğe sahiptir. Bunların bazıları gelecekte eklenebilecektir.

OpenSSL
Yapılandırma/Kurulum
OpenSSL


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
OpenSSL


Gereksinimler

OpenSSL işlevlerini kullanmak için » OpenSSL paketinin kurulu olması gerekir. PHP'nin 4.0.5'ten 4.3.1 sürümüne kadar OpenSSL >= 0.9.5, diğer sürümleri. (PHP <=4.0.4 ve >= 4.3.2) OpenSSL >= 0.9.6 gerektirir.

Uyarı

Daima OpenSSL'in en son sürümünü kullanmanızı öneririz yoksa HTTP sunucunuz saldırılardan zarar görebilir.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

PHP'nin OpenSSL desteğini kullanmak için PHP'yi --with-openssl[=DiZiN] seçeneği ile derlemelisiniz.

OpenSSL kütüphanesi çalışma anındaki normal işlemler için ek gereksinimlere sahiptir. En önemlisi, OpenSSL'in, rasgele veya yarı rasgele bir sayı üretecine erişebilmesi gerekir; çoğu Unix ve Unix benzeri (Linux dahil) platform için bu /dev/urandom veya /dev/random aygıtına erişebilmek anlamına gelir.

Bilginize: Win32 kullanıcıları için

Bu eklentinin çalışabilmesi için bazı DLL dosyalarının bulunduğu yerlerin Windows sistem PATH'ında tanımlı olması gerekir. Bunun nasıl yapılacağı SSS altında "PHP dizinimi Windows'ta PATH'a nasıl eklerim" başlığı altında açıklanmıştır. Eklenti, DLL dosyaları PHP dizininden Windows system dizinine taşındığında da çalışırsa da (çünkü system dizini sistem PATH'ında zaten vardır) bu önerilmez. Bu eklentinin çalışabilmesi için bulunduğu dizine PATH üzerinden erişilebilinmesi gereken dosyanın ismi: libeay32.dll

Anahtar üretim ve sertifika imzalama işlevlerini kullanmayı düşünüyorsanız sisteminizde ek olarak geçerli bir openssl.cnf kurulu olmalıdır. Win32 çalıştırılabilir paketlerine örnek bir yapılandırma dosyası ekliyoruz. Bu dosya openssl dizinine konmaktadır.

PHP openssl.cnf dosyasını şu mantıksal sırayla araştırır:

  • OPENSSL_CONF ortam değişkeni varsa, değişkenin değeri yapılandırma dosyasının yolu olarak (dosya ismi dahil) kullanılır.
  • SSLEAY_CONF ortam değişkeni varsa, değişkenin değeri yapılandırma dosyasının yolu olarak (dosya ismi dahil) kullanılır.
  • openssl.cnf dosyasının öntanımlı sertifika alanında bulunduğu varsayılır (openssl DLL'i derlenirken böyle yapılandırılır). Yani, dosyanın öntanımlı yeri: c:\usr\local\ssl\openssl.cnf.

Kurulum sırasında yapılandırma dosyasının aranacağı yerin c:\usr\local\ssl\openssl.cnf mi olacağına yoksa ortam değişkenlerini kullanarak başka bir yer mi belirtileceğine karar vermelisiniz. Bir yapılandırma dosyası gerektiren işlevlerdeki ayarlar değiştirgesini kullanarak dosyanın öntanımlı yerini geçersiz kılabilirsiniz.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

İçindekiler

  • Amaç sınama seçenekleri
  • Dolgu seçenekleri
  • Anahtar türleri
  • PKCS7 Seçenekleri/Sabitleri
  • İmzalama Algoritmaları
  • Şifreler
  • Sürüm sabitleri

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

Özkaynak Türleri
Amaç sınama seçenekleri
OpenSSL


Amaç sınama seçenekleri

X509_PURPOSE_SSL_CLIENT (integer)
X509_PURPOSE_SSL_SERVER (integer)
X509_PURPOSE_NS_SSL_SERVER (integer)
X509_PURPOSE_SMIME_SIGN (integer)
X509_PURPOSE_SMIME_ENCRYPT (integer)
X509_PURPOSE_CRL_SIGN (integer)
X509_PURPOSE_ANY (integer)
Öntanımlı Sabitler
Dolgu seçenekleri
Öntanımlı Sabitler


Dolgu seçenekleri

OPENSSL_PKCS1_PADDING (integer)
OPENSSL_SSLV23_PADDING (integer)
OPENSSL_NO_PADDING (integer)
OPENSSL_PKCS1_OAEP_PADDING (integer)
Amaç sınama seçenekleri
Anahtar türleri
Öntanımlı Sabitler


Anahtar türleri

OPENSSL_KEYTYPE_RSA (integer)
OPENSSL_KEYTYPE_DSA (integer)
OPENSSL_KEYTYPE_DH (integer)
Dolgu seçenekleri
PKCS7 Seçenekleri/Sabitleri
Öntanımlı Sabitler


PKCS7 Seçenekleri/Sabitleri

S/MIME işlevleri seçenek olarak aşağıdaki değerlerin bitsel olarak VEYAlanmasıyla elde edilen değerleri kullanırlar:

PKCS7 CONSTANTS
Sabit | Açıklama
PKCS7_TEXT | Şifreli/imzalı iletiye başlıklar text/plain içerik türüyle eklenir. Şifre çözme veya doğrulama yapılacaksa bu başlıklar çıktıdan ayıklanır; eğer şifresi çözülecek veya doğrulanacak iletinin MIME türü text/plain değilse bir hata oluşur.
PKCS7_BINARY | Normalde girdi iletisi, (S/MIME belirtiminin gereği olarak) satırsonu karakteri olarak CR ve LF kullanan "meşru" biçeme dönüştürülür. Bu seçenek kullanıldığı takdirde hiçbir dönüşüm yapılmaz. MIME biçeminde olmayan ikil verilerle çalışırken yararlıdır.
PKCS7_NOINTERN | Bir ileti doğrulanırken iletiye dahil edilmiş sertifikalar varsa bunlar imzalama sertifikaları olarak ele alınır. Bu seçenekle sadece openssl_pkcs7_verify() işlevinin ek_sertifikalar değiştirgesinde belirtilen sertifikalar kullanılır. Bununla birlikte, sağlanan sertifikalar hala güvencesiz CA olarak kullanılabilir.
PKCS7_NOVERIFY | İmzalı iletinin imzalama sertifikası doğrulanmaz.
PKCS7_NOCHAIN | İmzalama setifikalarına zincir doğrulama yapılmaz; yani, imzalı iletideki sertifikalar güvencesiz CA olarak kullanılmaz.
PKCS7_NOCERTS | Bir ileti imzalanırken normal olarak imzalama sertifikası iletiye eklenir. Bu seçenek belirtilmişse eklenmez. Böylece imzalanan iletinin boyu küçülmüş olur, ancak doğrulayıcının imzalama sertifikasının bir kopyasına sahip olması gerekir (örneğin, openssl_pkcs7_verify() işlevinin ek_sertifikalar değiştirgesinde aktarılabilir).
PKCS7_NOATTR | Normalde bir ileti imzalanırken desteklenen bakışımlı algoritmalar ve imzalama zamanı dahil bazı öznitelikler iletiye eklenir. Bu seçenek belirtilmişse bunlar iletiye eklenmez.
PKCS7_DETACHED | Bir ileti imzalanırken MIME türü "multipart/signed" olan salt metin imzalama yapılır. openssl_pkcs7_sign() işlevinin seçenekler değiştirgesinde hiçbir şey belirtmezseniz öntanımlı olarak bu uygulanır. Bu seçeneği belirtmezseniz ileti şeffaf olmayan bir biçimde imzalanır, ancak eposta aktarımlarına karşı daha dayanıklı olmakla birlikte, ileti S/MIME desteği olmayan eposta araçları ile okunamaz.
PKCS7_NOSIGS | Bir iletideki imzalar doğrulanmaz ve denenmez.

Bilginize:

Bu sabitler 4.0.6 sürümünde eklendi.

Anahtar türleri
İmzalama Algoritmaları
Öntanımlı Sabitler


İmzalama Algoritmaları

OPENSSL_ALGO_DSS1 (integer)
OPENSSL_ALGO_SHA1 (integer)
openssl_sign() ve openssl_verify() tarafından öntanımlı algoritma olarak kullanılır.
OPENSSL_ALGO_MD5 (integer)
OPENSSL_ALGO_MD4 (integer)
OPENSSL_ALGO_MD2 (integer)

Bilginize:

Bu sabitler 5.0.0 sürümünde eklendi.

PKCS7 Seçenekleri/Sabitleri
Şifreler
Öntanımlı Sabitler


Şifreler

OPENSSL_CIPHER_RC2_40 (integer)
OPENSSL_CIPHER_RC2_128 (integer)
OPENSSL_CIPHER_RC2_64 (integer)
OPENSSL_CIPHER_DES (integer)
OPENSSL_CIPHER_3DES (integer)

Bilginize:

Bu sabitler 4.3.0 sürümünde eklendi.

İmzalama Algoritmaları
Sürüm sabitleri
Öntanımlı Sabitler


Sürüm sabitleri

OPENSSL_VERSION_TEXT (string)
OPENSSL_VERSION_NUMBER (integer)

Bilginize:

Bu sabitler 5.2.0 sürümünde eklendi.

Şifreler
Anahtar/Sertifika Değiştirgeleri
Öntanımlı Sabitler


Anahtar/Sertifika Değiştirgeleri

Sadece bir kaç openssl işlevi bir anahtar veya sertifika değiştirgesi gerektirir. PHP 4.0.5 ve öncesinde openssl_get_xxx() işlevlerinden döndürülen bir anahtar veya sertifika özkaynağı kullanılmak zorundaydı. Sonraki sürümler için aşağıdaki yöntemlerden biri kullanılabilmektedir.

  • Sertifikalar

    1. openssl_x509_read() işlevinden dönen bir X.509 özkaynağı.
    2. file://bir/yol/sertifika.pem biçeminde bir dizge; İsmi belirtilen dosya PEM kodlamalı bir sertifika içermelidir.
    3. PEM kodlamalı bir sertifikanın içeriğinden oluşan bir dizge.

  • Genel ve Gizli Anahtarlar

    1. openssl_get_publickey() veya openssl_get_privatekey() işlevinden dönmüş bir anahtar özkaynağı.
    2. Sadece genel anahtarlar için: bir X.509 özkaynağı
    3. file://bir/yol/dosya.pem biçeminde bir dizge; belirtilen dosya PEM kodlamalı bir sertifika veya gizli anahtar (veya her ikisini de) içermelidir.
    4. PEM kodlamalı bir sertifika veya anahtarın içeriğinden oluşan bir dizge.
    5. Gizli anahtarlar için ayrıca, array($anahtar, $parolası) sözdizimini de kullanabilirsiniz; burada $anahtar file:// kullarak belirtilen bir anahtar veya bunun dizgesel içeriği, $parolası ise gizli anahtarın parolasını içeren bir dizge olmalıdır.

Sürüm sabitleri
Sertifika Doğrulama
OpenSSL


Sertifika Doğrulama

Bir imza veya sertifikayı doğrulayacak bir işlev çağrılırken CA_bilgisi değiştirgesinde güvenilir CA dosyalarının yerlerini belirten dosya ve dizin isimlerini içeren bir dizi belirtilir. Bir dizin belirtilirken, dizin dizgesi openssl komutunun kullanabileceği şekilde biçimlendirilmiş olmalıdır.

Anahtar/Sertifika Değiştirgeleri
OpenSSL İşlevleri
OpenSSL


OpenSSL İşlevleri

İçindekiler

  • openssl_cipher_iv_length — Gets the cipher iv length
  • openssl_csr_export_to_file — Belirtilen CSR'yi bir dosyaya kaydeder
  • openssl_csr_export — Belirtilen CSR'yi bir dizge olarak döndürür
  • openssl_csr_get_public_key — Belirtilen sertifikanın genel anahtarını döndürür
  • openssl_csr_get_subject — Bir sertifika konusu döndürür
  • openssl_csr_new — Bir sertifika imzalama isteği (CSR) üretir
  • openssl_csr_sign — Bir CSR'yi başka bir sertifika (veya kendisi) ile imzalayıp bir sertifika üretir
  • openssl_decrypt — Verinin şifresini çözer
  • openssl_dh_compute_key — Uzak ve yerel özet hesaplama anahtarları için paylaşımlı anahtarı hesaplar
  • openssl_digest — Bir özet hesaplar
  • openssl_encrypt — Veriyi şifreler
  • openssl_error_string — OpenSSL hata iletisini döndürür
  • openssl_free_key — Anahtar özkaynağını serbest bırakır
  • openssl_get_cert_locations — Retrieve the available certificate locations
  • openssl_get_cipher_methods — Kullanılabilecek şifreleme yöntemlerini döndürür
  • openssl_get_md_methods — Kullanılabilecek özet yöntemlerini döndürür
  • openssl_get_privatekey — openssl_pkey_get_private işlevinin takma adıdır
  • openssl_get_publickey — openssl_pkey_get_public işlevinin takma adıdır
  • openssl_open — Mühürlü veriyi açar
  • openssl_pbkdf2 — Generates a PKCS5 v2 PBKDF2 string, defaults to SHA-1
  • openssl_pkcs12_export_to_file — Bir PKCS#12 uyumlu sertifika deposunu bir dosyaya kaydeder
  • openssl_pkcs12_export — PKCS#12 uyumlu sertifika deposu dosyasını bir değişkene yerleştirir
  • openssl_pkcs12_read — Bir PKCS#12 Sertifika Deposunu bir diziye çözümler
  • openssl_pkcs7_decrypt — S/MIME şifreli bir iletinin şifresini çözer
  • openssl_pkcs7_encrypt — Bir S/MIME iletiyi şifreler
  • openssl_pkcs7_sign — Bir S/MIME iletiyi imzalar
  • openssl_pkcs7_verify — S/MIME imzalı bir iletinin imzasını doğrular
  • openssl_pkey_export_to_file — Bir anahtarın ihraç edilebilir gösterimini bir dosyaya kaydeder
  • openssl_pkey_export — Bir anahtarın ihraç edilebilir gösterimini bir dizge olarak döndürür
  • openssl_pkey_free — Bir gizli anahtarı serbest bırakır
  • openssl_pkey_get_details — Anahtarla ilgili ayrıntıları bir dizi içinde döndürür
  • openssl_pkey_get_private — Bir gizli anahtar döndürür
  • openssl_pkey_get_public — Genel anahtarı sertifikadan elde edip kullanıma hazırlar
  • openssl_pkey_new — Yeni bir anahtar çifti üretir
  • openssl_private_decrypt — Genel anahtarla şifrelenmiş verinin şifresini gizli anahtarla çözer
  • openssl_private_encrypt — Veriyi gizli anahtarla şifreler
  • openssl_public_decrypt — Gizli anahtarla şifrelenmiş verinin şifresini genel anahtarla çözer
  • openssl_public_encrypt — Veriyi genel anahtarla şifreler
  • openssl_random_pseudo_bytes — Yarı-rasgele dizge üretir
  • openssl_seal — Veriyi mühürler
  • openssl_sign — İmza üretir
  • openssl_spki_export_challenge — Exports the challenge assoicated with a signed public key and challenge
  • openssl_spki_export — Exports a valid PEM formatted public key signed public key and challenge
  • openssl_spki_new — Generate a new signed public key and challenge
  • openssl_spki_verify — Verifies a signed public key and challenge
  • openssl_verify — İmzayı doğrular
  • openssl_x509_check_private_key — Bir gizli anahtarın bir sertifikaya karşılık olup olmadığına bakar
  • openssl_x509_checkpurpose — Sertifikanın belli bir amaçla kulanılıp kullanılmayacağına bakar
  • openssl_x509_export_to_file — Belirtilen sertifikayı bir dosyaya kaydeder
  • openssl_x509_export — Belirtilen sertifikayı bir dizge olarak döndürür
  • openssl_x509_fingerprint — Calculates the fingerprint, or digest, of a given X.509 certificate
  • openssl_x509_free — Sertifika özkaynağını serbest bırakır
  • openssl_x509_parse — Bir X509 sertifikasını çözümleyip bilgileri bir dizi içinde döndürür
  • openssl_x509_read — Bir X.509 sertifikasını çözümleyip sertifika için bir tanıtıcı döndürür
Sertifika Doğrulama
openssl_cipher_iv_length
OpenSSL


Gets the cipher iv length

OpenSSL İşlevleri
openssl_csr_export_to_file
OpenSSL İşlevleri
PHP Manual

openssl_cipher_iv_length

(PHP 5 >= PHP 5.3.3, PHP 7)

openssl_cipher_iv_length — Gets the cipher iv length

Açıklama

int openssl_cipher_iv_length ( string $method )

Gets the cipher initialization vector (iv) length.

Değiştirgeler

method

The cipher method, see openssl_get_cipher_methods() for a list of potential values.

Dönen Değerler

Returns the cipher length on success, or FALSE on failure.

Hatalar/İstisnalar

Emits an E_WARNING level error when the cipher algorithm is unknown.

Örnekler

Örnek 1 openssl_cipher_iv_length() example

<?php
$method = 'AES-128-CBC';
$ivlen = openssl_cipher_iv_length($method);

echo $ivlen;
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

16
OpenSSL İşlevleri
openssl_csr_export_to_file
OpenSSL İşlevleri


Belirtilen CSR'yi bir dosyaya kaydeder

openssl_cipher_iv_length
openssl_csr_export
OpenSSL İşlevleri
PHP Manual

openssl_csr_export_to_file

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

openssl_csr_export_to_file — Belirtilen CSR'yi bir dosyaya kaydeder

Açıklama

bool openssl_csr_export_to_file ( resource $csr , string $dosya [, bool $metinsiz = true ] )

csr ile belirtilen sertifika imzalama isteğini ascii zırhlı bir metne dönüştürüp çıktı dosyasına kaydeder.

Değiştirgeler

csr

dosya

Çıktı dosyasının yolu.

metinsiz

Belirtilmesi isteğe bağlı olan metinsiz değiştirgesi çıktının ayrıntı seviyesini belirler. FALSE belirtilirse çıktıda insanlar için anlamlı bilgiler bulunmaz. Değiştirgenin öntanımlı değeri: TRUE

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • openssl_csr_export() - Belirtilen CSR'yi bir dizge olarak döndürür
  • openssl_csr_new() - Bir sertifika imzalama isteği (CSR) üretir
  • openssl_csr_sign() - Bir CSR'yi başka bir sertifika (veya kendisi) ile imzalayıp bir sertifika üretir

openssl_cipher_iv_length
openssl_csr_export
OpenSSL İşlevleri


Belirtilen CSR'yi bir dizge olarak döndürür

openssl_csr_export_to_file
openssl_csr_get_public_key
OpenSSL İşlevleri
PHP Manual

openssl_csr_export

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

openssl_csr_export — Belirtilen CSR'yi bir dizge olarak döndürür

Açıklama

bool openssl_csr_export ( resource $csr , string &$çıktı [, bool $metinsiz = true ] )

csr ile belirtilen sertifika imzalama isteğini ascii zırhlı bir metne dönüştürüp çıktı değiştirgesine kaydeder.

Değiştirgeler

csr

çıktı

metinsiz

Belirtilmesi isteğe bağlı olan metinsiz değiştirgesi çıktının ayrıntı seviyesini belirler. FALSE belirtilirse çıktıda insanlar için anlamlı bilgiler bulunmaz. Değiştirgenin öntanımlı değeri: TRUE

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • openssl_csr_export_to_file() - Belirtilen CSR'yi bir dosyaya kaydeder
  • openssl_csr_new() - Bir sertifika imzalama isteği (CSR) üretir
  • openssl_csr_sign() - Bir CSR'yi başka bir sertifika (veya kendisi) ile imzalayıp bir sertifika üretir

openssl_csr_export_to_file
openssl_csr_get_public_key
OpenSSL İşlevleri


Belirtilen sertifikanın genel anahtarını döndürür

openssl_csr_export
openssl_csr_get_subject
OpenSSL İşlevleri
PHP Manual

openssl_csr_get_public_key

(PHP 5 >= 5.2.0, PHP 7)

openssl_csr_get_public_key — Belirtilen sertifikanın genel anahtarını döndürür

Açıklama

resource openssl_csr_get_public_key ( mixed $csr [, bool $kısa_ad_kullan = true ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

openssl_csr_export
openssl_csr_get_subject
OpenSSL İşlevleri


Bir sertifika konusu döndürür

openssl_csr_get_public_key
openssl_csr_new
OpenSSL İşlevleri
PHP Manual

openssl_csr_get_subject

(PHP 5 >= 5.2.0, PHP 7)

openssl_csr_get_subject — Bir sertifika konusu döndürür

Açıklama

array openssl_csr_get_subject ( mixed $csr [, bool $kısa_ad_kullan = true ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

openssl_csr_get_public_key
openssl_csr_new
OpenSSL İşlevleri


Bir sertifika imzalama isteği (CSR) üretir

openssl_csr_get_subject
openssl_csr_sign
OpenSSL İşlevleri
PHP Manual

openssl_csr_new

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

openssl_csr_new — Bir sertifika imzalama isteği (CSR) üretir

Açıklama

mixed openssl_csr_new ( array $dn , resource &$gizanh [, array $ayarlar [, array $ek_seçenekler ]] )

dn ile belirtilen, sertifika için kullanılacak ayırt edilebilir isim ile sağlanan bilgiye dayanarak yeni bir sertifika imzalama isteği (CSR) üretir.

Bilginize: Bu işlevin gerektiği gibi çalışması için geçerli bir openssl.cnf kurulu olmalıdır. Daha ayrıntılı bilgi için kurulum bölümüne bakınız.

Değiştirgeler

dn

Sertifika için kullanılacak ayırt edilebilir isim.

gizanh

openssl_pkey_new() (veya başka bir openssl_pkey işlevi) ile üretilmiş bir gizli anahtar. Anahtar çiftinin genel anahtar parçası CSR'yi imzalamakta kullanılır.

ayarlar

İsteği ilklendirmek için öntanımlı olarak sisteminizdeki openssl.conf kullanılır. ayarlar dizisinin config_section_section anahtarında başka bir yapılandırma dosyası bölümü belirtebileceğiniz gibi config anahtarında başka bir openssl yapılandırma dosyasının yolunu da belirtebilirsiniz. ayarlar dizisi aşağıdaki anahtarları içerebilir. Bu anahtarlar openssl.conf dosyasındaki eşdeğerleri gibi davranırlar.

Yapılandırma Geçersizleştiricileri
ayarlar anahtarı | Türü | openssl.conf eşdeğeri | Açıklama
digest_alg | string | default_md | Kullanılacak özet yöntemini belirler.
x509_extensions | string | x509_extensions | Bir x509 sertifikası üretilirken kullanılacak eklentileri belirler.
req_extensions | string | req_extensions | Bir CSR üretilirken kullanılacak eklentileri belirler.
private_key_bits | integer | default_bits | Bir gizli anahtarın kaç bitlik olacağını belirler.
private_key_type | integer | none | Üretilecek gizli anahtarın türünü belirler. Şu sabitlerden biri olabilir: OPENSSL_KEYTYPE_DSA, OPENSSL_KEYTYPE_DH, OPENSSL_KEYTYPE_RSA. Öntanımlı değer OPENSSL_KEYTYPE_RSA olup şimdilik desteklenen tek anahtar türüdür.
encrypt_key | boolean | encrypt_key | İhraç edilecek anahtar (bir parola ile) şifrelenececek mi?

ek_seçenekler

CSR için kullanılacak ek seçenekleri belirtmek için kullanılır. dn ve ek_seçenekler birer ilişkisel dizi olup anahtarları nesne kimliklerine (OID) dönüştürülerek isteğin ilgili parçasına uygulanır.

Dönen Değerler

Üretilen CSR'yi döndürür.

Örnekler

Örnek 1 - Öz-imzalı sertifika üretimi

<?php
// Sertifikada ayırt edilebilir isim için kullanılacak veriyi oluşturalım.
// Bu anahtar değerlerinde, isminiz, şirketiniz ve hatta sertifikanın adına
// üretildiği şirketin veya şahsın isminin bulunmasını sağlayın.
// SSL sertifikaları için commonName genellikle sertifikayı kullanacak
// alan ismidir. Fakat S/MIME sertifikalar için commonName, sertifikayı
// kullanacak şahsın ismidir.
$dn = array(
    "countryName" => "UK",
    "stateOrProvinceName" => "Somerset",
    "localityName" => "Glastonbury",
    "organizationName" => "The Brain Room Limited",
    "organizationalUnitName" => "PHP Documentation Team",
    "commonName" => "Wez Furlong",
    "emailAddress" => "wez@example.com"
);

// Yeni bir gizli/genel anahtar çifti üretelim
$privkey = openssl_pkey_new();

// Bir sertifika imzalama isteği üretelim
$csr = openssl_csr_new($dn, $privkey);

// CA'nız isteği yerine getirene kadar bir öz-imzalı sertifika üretelim.
// Bu sertifika 365 günlük olsun.
$sscert = openssl_csr_sign($csr, null, $privkey, 365);

// (Sertifikanın kullanılacağı yere bağlı olarak) posta istemcisine,
// posta sunucusuna veya HTTP sunucusuna kurulacak öz-imzali sertifikayı,
// CSR'yi ve gizli anahtarı alalım. Örnekte bunlar değişkenlere atanmıştır.
// Fakat siz bunları doğrudan dosyalarına kaydedebilirsiniz.
// CSR genellikle "gerçek" sertifikayı üretecek CA'ya gönderilir.
openssl_csr_export($csr, $csrout); var_dump($csrout);
openssl_x509_export($sscert, $certout); var_dump($certout);
openssl_pkey_export($privkey, $pkeyout, "mypassword"); var_dump($pkeyout);

// Oluşan hatalar varsa gösterelim
while (($e = openssl_error_string()) !== false) {
    echo $e . "\n";
}
?>

openssl_csr_get_subject
openssl_csr_sign
OpenSSL İşlevleri


Bir CSR'yi başka bir sertifika (veya kendisi) ile imzalayıp bir sertifika üretir

openssl_csr_new
openssl_decrypt
OpenSSL İşlevleri
PHP Manual

openssl_csr_sign

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

openssl_csr_sign — Bir CSR'yi başka bir sertifika (veya kendisi) ile imzalayıp bir sertifika üretir

Açıklama

resource openssl_csr_sign ( mixed $csr , mixed $CA_sert , mixed $gizanh , int $gün [, array $ayarlar [, int $sıranum = 0 ]] )

csr ile belirtilen Sertifika İmzalama İsteğinden bir x509 sertifikesı üretir.

Bilginize: Bu işlevin gerektiği gibi çalışması için geçerli bir openssl.cnf kurulu olmalıdır. Daha ayrıntılı bilgi için kurulum bölümüne bakınız.

Değiştirgeler

csr

openssl_csr_new() tarafından üretilmiş bir sertifika imzalama isteği, file://bir/yol/csr biçeminde bir dizge olarak PEM kodlamalı bir CSR'nin dosya yolu veya openssl_csr_export() işlevinden dönen bir dizge olabilir.

CA_sert

Üretilen sertifikayı imzalamak için kullanılacak sertifika. NULL belirtilirse üretilen sertifika kendisiyle imzalanır.

gizanh

CA_sert ile ilişkili gizli anahtar.

gün

Üretilen sertifikanın kaç gün geçerli kalacağı belirtilir.

ayarlar

Üretilen sertifikanın ince ayarları için kullanılır. Bu değiştirge ile ilgili ayrıntılı bilgi için openssl_csr_new() işlevine bakınız.

sıranum

Üretilen sertifikanın sıra numarası. Belirtilmezse 0 öntanımlıdır.

Dönen Değerler

İşlem başarısız olursa FALSE yoksa bir x509 sertifika özkaynağı döner.

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.3 | sıranum değiştirgesi eklendi.

Örnekler

Örnek 1 - openssl_csr_sign() örneği - CSR imzalama (Kendi Sertifika Yetkilinizi nasıl oluşturursunuz?)

<?php
// Başka bir sayfadaki bir textarea'ya aktarılmak üzere bir
// CSR alındığını varsayalım
$csrdata = $_POST["CSR"];

// Sertifikayı kendi "sertifika yetkilimizin sertifikası" ile
// imzalayacağız. İmzalamak için başka bir sertifika da kullanılabilirdi,
// fakat imzalama sertifikası yazılım/kulllanıcılar için güvenilir
// olmadıkça işlem işe yaramayacak ve yeni bir imzalı sertifika gerekecektir.

// Kendi CA sertifikamıza ve gizli anahtarımıza ihtiyacımız var
$cacert = "file://bir/yol/ca.crt";
$gizanh = array("file://bir/yol/ca.key", "gizanh_parolası");

$userscert = openssl_csr_sign($csrdata, $cacert, $gizanh, 365);

// Üretilen sertifikayı gösterelim ki, kullanıcı onu kendi alanına
// kopyalayabilsin (örneğin SSL sunucusunun sertifikasının bulunduğu dosyaya)
openssl_x509_export($usercert, $certout);
echo $certout;

// Oluşan hata varsa gösterelim
while (($e = openssl_error_string()) !== false) {
    echo $e . "\n";
}
?>

openssl_csr_new
openssl_decrypt
OpenSSL İşlevleri


Verinin şifresini çözer

openssl_csr_sign
openssl_dh_compute_key
OpenSSL İşlevleri
PHP Manual

openssl_decrypt

(PHP 5 >= 5.3.0, PHP 7)

openssl_decrypt — Verinin şifresini çözer

Açıklama

string openssl_decrypt ( string $veri , string $yöntem , string $parola [, string $ham_girdi = false ] )

Bir ham veya base64 kodlu bir dizgeyi veri olarak alıp belirtilen yöntem ve parola'yı kullanarak verinin şifresini çözer.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

veri

Şifresi çözülecek veri.

yöntem

Şifreleme yöntemi.

parola

Parola.

ham_girdi

TRUE belirtilirse veri değiştirgesinde ham bir dizge, FALSE belirtilirse base64 kodlu bir dizge bulunduğu varsayılır.

Dönen Değerler

İşlem başarısız olursa FALSE yoksa şifresi çözülmüş veriyi bir dizge olarak döndürür.

Hatalar/İstisnalar

yöntem değiştirgesi ile bilinmeyen bir şifreleme algoritması belirtilmişse E_WARNING seviyesinde bir hata oluşur.

Ayrıca Bakınız

  • openssl_encrypt() - Veriyi şifreler

openssl_csr_sign
openssl_dh_compute_key
OpenSSL İşlevleri


Uzak ve yerel özet hesaplama anahtarları için paylaşımlı anahtarı hesaplar

openssl_decrypt
openssl_digest
OpenSSL İşlevleri
PHP Manual

openssl_dh_compute_key

(PHP 5 >= 5.3.11, PHP 7)

openssl_dh_compute_key — Uzak ve yerel özet hesaplama anahtarları için paylaşımlı anahtarı hesaplar

Açıklama

string openssl_dh_compute_key ( string $genanh , resource $özetanh )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

genanh

Genel anahtar.

özetanh

Özet hesaplama anahtarı.

Dönen Değerler

İşlem başarısız olursa FALSE yoksa hesaplanan anahtar dizgesi döner.

openssl_decrypt
openssl_digest
OpenSSL İşlevleri


Bir özet hesaplar

openssl_dh_compute_key
openssl_encrypt
OpenSSL İşlevleri
PHP Manual

openssl_digest

(PHP 5 >= 5.3.0, PHP 7)

openssl_digest — Bir özet hesaplar

Açıklama

string openssl_digest ( string $veri , string $yöntem [, bool $ham_çıktı = false ] )

Belirtilen verinin belirtilen yöntemle özetini çıkarıp ham veya onaltılık kodlanmış bir dizge olarak döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

veri

Özeti hesaplanacak veri.

yöntem

Özet yöntemi.

ham_çıktı

Çıktı ham dizge olacaksa TRUE, onaltılık kodlu dizge olacaksa FALSE olmalıdır.

Dönen Değerler

İşlem başarısız olursa FALSE yoksa özet dizgesi döner.

Hatalar/İstisnalar

yöntem değiştirgesi ile bilinmeyen bir imza algoritması belirtilmişse E_WARNING seviyesinde bir hata oluşur.

Ayrıca Bakınız

  • openssl_get_cipher_methods() - Kullanılabilecek şifreleme yöntemlerini döndürür

openssl_dh_compute_key
openssl_encrypt
OpenSSL İşlevleri


Veriyi şifreler

openssl_digest
openssl_error_string
OpenSSL İşlevleri
PHP Manual

openssl_encrypt

(PHP 5 >= 5.3.0, PHP 7)

openssl_encrypt — Veriyi şifreler

Açıklama

string openssl_encrypt ( string $veri , string $yöntem , string $parola [, bool $ham_çıktı = false ] )

Belirtilen veri'yi belirtilen yöntem ve parola ile şifreler ve bir base64 kodlu dizge olarak veya ham bir dizge olarak döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

veri

Şifrelenecek veri.

yöntem

Şifreleme yöntemi.

parola

Parola.

ham_çıktı

Çıktı ham olarak döndürülecekse TRUE, base64 kodlanmış olarak döndürülecekse FALSE olmalıdır.

Dönen Değerler

İşlem başarısız olursa FALSE yoksa şifrelenmiş veri dizgesi döner.

Hatalar/İstisnalar

yöntem değiştirgesi ile bilinmeyen bir şifreleme algoritması belirtilmişse E_WARNING seviyesinde bir hata oluşur.

Ayrıca Bakınız

  • openssl_decrypt() - Verinin şifresini çözer

openssl_digest
openssl_error_string
OpenSSL İşlevleri


OpenSSL hata iletisini döndürür

openssl_encrypt
openssl_free_key
OpenSSL İşlevleri
PHP Manual

openssl_error_string

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

openssl_error_string — OpenSSL hata iletisini döndürür

Açıklama

string openssl_error_string ( void )

OpenSSL kütüphanesinde son oluşan hatanın iletisini döndürür. Hata iletileri bir yığıta kaydedilir, dolayısıyla tüm hata iletilerini toplamak için bu işlevin defalarca çağrılması gerekir.

Dönen Değerler

Döndürülecek hata iletisi kalmamışsa FALSE, varsa bir hata dizgesi döndürür.

Örnekler

Örnek 1 - openssl_error_string() örneği

<?php
// Bazı openssl işlevlerinin başarısız olduğunu varsayalım
while ($msg = openssl_error_string())
    echo $msg . "<br />\n";
?>

openssl_encrypt
openssl_free_key
OpenSSL İşlevleri


Anahtar özkaynağını serbest bırakır

openssl_error_string
openssl_get_cert_locations
OpenSSL İşlevleri
PHP Manual

openssl_free_key

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

openssl_free_key — Anahtar özkaynağını serbest bırakır

Açıklama

void openssl_free_key ( resource $ankim )

ankim ile ilişkili anahtar için ayrılan belleği serbest bırakır.

Değiştirgeler

ankim

Dönen Değerler

Hiçbir değer dönmez.

openssl_error_string
openssl_get_cert_locations
OpenSSL İşlevleri


Retrieve the available certificate locations

openssl_free_key
openssl_get_cipher_methods
OpenSSL İşlevleri
PHP Manual

openssl_get_cert_locations

(PHP 5 >= 5.6.0, PHP 7)

openssl_get_cert_locations — Retrieve the available certificate locations

Açıklama

array openssl_get_cert_locations ( void )

openssl_get_cert_locations() returns an array with information about the available certificate locations that will be searched for SSL certificates.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array with the available certificate locations.

Örnekler

Örnek 1 openssl_get_cert_locations() example

<?php
var_dump(openssl_get_cert_locations());
?>

Yukarıdaki örneğin çıktısı:

array(8) {
  ["default_cert_file"]=>
  string(21) "/usr/lib/ssl/cert.pem"
  ["default_cert_file_env"]=>
  string(13) "SSL_CERT_FILE"
  ["default_cert_dir"]=>
  string(18) "/usr/lib/ssl/certs"
  ["default_cert_dir_env"]=>
  string(12) "SSL_CERT_DIR"
  ["default_private_dir"]=>
  string(20) "/usr/lib/ssl/private"
  ["default_default_cert_area"]=>
  string(12) "/usr/lib/ssl"
  ["ini_cafile"]=>
  string(0) ""
  ["ini_capath"]=>
  string(0) ""
}

openssl_free_key
openssl_get_cipher_methods
OpenSSL İşlevleri


Kullanılabilecek şifreleme yöntemlerini döndürür

openssl_get_cert_locations
openssl_get_md_methods
OpenSSL İşlevleri
PHP Manual

openssl_get_cipher_methods

(PHP 5 >= 5.3.0, PHP 7)

openssl_get_cipher_methods — Kullanılabilecek şifreleme yöntemlerini döndürür

Açıklama

array openssl_get_cipher_methods ([ bool $rumuzlar = false ] )

Kullanılabilecek şifreleme yöntemlerini döndürür.

Değiştirgeler

rumuzlar

Şifre rumuzları dönen diziye dahil edilecekse TRUE olmalıdır.

Dönen Değerler

Kullanılabilecek şifreleme yöntemlerini içeren bir dizi.

Örnekler

Örnek 1 - openssl_get_cipher_methods() örneği

Kullanılabilecek şifreleme yöntemlerini ve varsa rumuzlarını listeler.

<?php
$şifreler             = openssl_get_cipher_methods();
$şifreler_ve_rumuzlar = openssl_get_cipher_methods(true);
$rumuzlar             = array_diff($şifreler_ve_rumuzlar, $şifreler);

print_r($şifreler);

print_r($rumuzlar);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [0] => AES-128-CBC
    [1] => AES-128-CFB
    [2] => AES-128-CFB1
    [3] => AES-128-CFB8
    [4] => AES-128-ECB
    [5] => AES-128-OFB
    [6] => AES-192-CBC
    [7] => AES-192-CFB
    [8] => AES-192-CFB1
    [9] => AES-192-CFB8
    [10] => AES-192-ECB
    [11] => AES-192-OFB
    [12] => AES-256-CBC
    [13] => AES-256-CFB
    [14] => AES-256-CFB1
    [15] => AES-256-CFB8
    [16] => AES-256-ECB
    [17] => AES-256-OFB
    [18] => BF-CBC
    [19] => BF-CFB
    [20] => BF-ECB
    [21] => BF-OFB
    [22] => CAST5-CBC
    [23] => CAST5-CFB
    [24] => CAST5-ECB
    [25] => CAST5-OFB
    [26] => DES-CBC
    [27] => DES-CFB
    [28] => DES-CFB1
    [29] => DES-CFB8
    [30] => DES-ECB
    [31] => DES-EDE
    [32] => DES-EDE-CBC
    [33] => DES-EDE-CFB
    [34] => DES-EDE-OFB
    [35] => DES-EDE3
    [36] => DES-EDE3-CBC
    [37] => DES-EDE3-CFB
    [38] => DES-EDE3-OFB
    [39] => DES-OFB
    [40] => DESX-CBC
    [41] => IDEA-CBC
    [42] => IDEA-CFB
    [43] => IDEA-ECB
    [44] => IDEA-OFB
    [45] => RC2-40-CBC
    [46] => RC2-64-CBC
    [47] => RC2-CBC
    [48] => RC2-CFB
    [49] => RC2-ECB
    [50] => RC2-OFB
    [51] => RC4
    [52] => RC4-40
    [53] => aes-128-cbc
    [54] => aes-128-cfb
    [55] => aes-128-cfb1
    [56] => aes-128-cfb8
    [57] => aes-128-ecb
    [58] => aes-128-ofb
    [59] => aes-192-cbc
    [60] => aes-192-cfb
    [61] => aes-192-cfb1
    [62] => aes-192-cfb8
    [63] => aes-192-ecb
    [64] => aes-192-ofb
    [65] => aes-256-cbc
    [66] => aes-256-cfb
    [67] => aes-256-cfb1
    [68] => aes-256-cfb8
    [69] => aes-256-ecb
    [70] => aes-256-ofb
    [71] => bf-cbc
    [72] => bf-cfb
    [73] => bf-ecb
    [74] => bf-ofb
    [75] => cast5-cbc
    [76] => cast5-cfb
    [77] => cast5-ecb
    [78] => cast5-ofb
    [79] => des-cbc
    [80] => des-cfb
    [81] => des-cfb1
    [82] => des-cfb8
    [83] => des-ecb
    [84] => des-ede
    [85] => des-ede-cbc
    [86] => des-ede-cfb
    [87] => des-ede-ofb
    [88] => des-ede3
    [89] => des-ede3-cbc
    [90] => des-ede3-cfb
    [91] => des-ede3-ofb
    [92] => des-ofb
    [93] => desx-cbc
    [94] => idea-cbc
    [95] => idea-cfb
    [96] => idea-ecb
    [97] => idea-ofb
    [98] => rc2-40-cbc
    [99] => rc2-64-cbc
    [100] => rc2-cbc
    [101] => rc2-cfb
    [102] => rc2-ecb
    [103] => rc2-ofb
    [104] => rc4
    [105] => rc4-40
)
Array
(
    [18] => AES128
    [19] => AES192
    [20] => AES256
    [21] => BF
    [26] => CAST
    [27] => CAST-cbc
    [32] => DES
    [47] => DES3
    [48] => DESX
    [50] => IDEA
    [55] => RC2
    [82] => aes128
    [83] => aes192
    [84] => aes256
    [85] => bf
    [90] => blowfish
    [91] => cast
    [92] => cast-cbc
    [97] => des
    [112] => des3
    [113] => desx
    [115] => idea
    [120] => rc2
)

Ayrıca Bakınız

  • openssl_get_md_methods() - Kullanılabilecek özet yöntemlerini döndürür

openssl_get_cert_locations
openssl_get_md_methods
OpenSSL İşlevleri


Kullanılabilecek özet yöntemlerini döndürür

openssl_get_cipher_methods
openssl_get_privatekey
OpenSSL İşlevleri
PHP Manual

openssl_get_md_methods

(PHP 5 >= 5.3.0, PHP 7)

openssl_get_md_methods — Kullanılabilecek özet yöntemlerini döndürür

Açıklama

array openssl_get_md_methods ([ bool $rumuzlar = false ] )

Kullanılabilecek özet yöntemlerini döndürür.

Değiştirgeler

rumuzlar

Özet rumuzları dönen diziye dahil edilecekse TRUE olmalıdır.

Dönen Değerler

Kullanılabilecek özet yöntemlerini içeren bir dizi.

Örnekler

Örnek 1 - openssl_get_md_methods() örneği

Kullanılabilecek özet yöntemlerini ve varsa rumuzlarını listeler.

<?php
$yontemler             = openssl_get_md_methods();
$yontemler_ve_rumuzlar = openssl_get_md_methods(true);
$rumuzlar              = array_diff($yontemler_ve_rumuzlar, $yontemler);

print_r($yontemler);

print_r($rumuzlar);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [0] => DSA
    [1] => DSA-SHA
    [2] => MD2
    [3] => MD4
    [4] => MD5
    [5] => RIPEMD160
    [6] => SHA
    [7] => SHA1
    [8] => SHA224
    [9] => SHA256
    [10] => SHA384
    [11] => SHA512
    [12] => dsaEncryption
    [13] => dsaWithSHA
    [14] => ecdsa-with-SHA1
    [15] => md2
    [16] => md4
    [17] => md5
    [18] => ripemd160
    [19] => sha
    [20] => sha1
    [21] => sha224
    [22] => sha256
    [23] => sha384
    [24] => sha512
)
Array
(
    [2] => DSA-SHA1
    [3] => DSA-SHA1-old
    [4] => DSS1
    [9] => RSA-MD2
    [10] => RSA-MD4
    [11] => RSA-MD5
    [12] => RSA-RIPEMD160
    [13] => RSA-SHA
    [14] => RSA-SHA1
    [15] => RSA-SHA1-2
    [16] => RSA-SHA224
    [17] => RSA-SHA256
    [18] => RSA-SHA384
    [19] => RSA-SHA512
    [28] => dsaWithSHA1
    [29] => dss1
    [32] => md2WithRSAEncryption
    [34] => md4WithRSAEncryption
    [36] => md5WithRSAEncryption
    [37] => ripemd
    [39] => ripemd160WithRSA
    [40] => rmd160
    [43] => sha1WithRSAEncryption
    [45] => sha224WithRSAEncryption
    [47] => sha256WithRSAEncryption
    [49] => sha384WithRSAEncryption
    [51] => sha512WithRSAEncryption
    [52] => shaWithRSAEncryption
    [53] => ssl2-md5
    [54] => ssl3-md5
    [55] => ssl3-sha1
)

Ayrıca Bakınız

  • openssl_digest() - Bir özet hesaplar
  • openssl_get_cipher_methods() - Kullanılabilecek şifreleme yöntemlerini döndürür

openssl_get_cipher_methods
openssl_get_privatekey
OpenSSL İşlevleri


openssl_pkey_get_private işlevinin takma adıdır

openssl_get_md_methods
openssl_get_publickey
OpenSSL İşlevleri
PHP Manual

openssl_get_privatekey

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

openssl_get_privatekey — openssl_pkey_get_private() işlevinin takma adıdır

Açıklama

Bu işlev, openssl_pkey_get_private() işlevinin takma adıdır.

openssl_get_md_methods
openssl_get_publickey
OpenSSL İşlevleri


openssl_pkey_get_public işlevinin takma adıdır

openssl_get_privatekey
openssl_open
OpenSSL İşlevleri
PHP Manual

openssl_get_publickey

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

openssl_get_publickey — openssl_pkey_get_public() işlevinin takma adıdır

Açıklama

Bu işlev, openssl_pkey_get_public() işlevinin takma adıdır.

openssl_get_privatekey
openssl_open
OpenSSL İşlevleri


Mühürlü veriyi açar

openssl_get_publickey
openssl_pbkdf2
OpenSSL İşlevleri
PHP Manual

openssl_open

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

openssl_open — Mühürlü veriyi açar

Açıklama

bool openssl_open ( string $mühürlü_veri , string &$veri , string $zarf_anahtarı , mixed $gizankim )

gizankim ile ilgili gizli anahtar ve zarf_anahtarı kullanılarak mühürlü_veri'nin mühürü ve şifresi çözüldükten sonra veri değiştirgesine konur. zarf_anahtarı veri mühürlenirken üretilir ve sadece belli bir gizli anahtarla birlikte kullanılabilir. Daha fazla bilgi için openssl_seal() işlevine bakınız.

Değiştirgeler

mühürlü_veri

veri

İşlem başarılı olursa çözümlenen veri bu değiştirgeye konur.

zarf_anahtarı

gizankim

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - openssl_open() örneği

<?php
// $mühürlü ve $mühür değişkenlerinin zarfı mühürleyen tarafından
// gönderilen mühürlü veriyi ve zarf anahtarını içerdiği varsayılıyor

// Gizli anahtarı dosyadan okuyalım ve hazırlayalım
$dt = fopen("/src/openssl-0.9.6/demos/sign/key.pem", "r");
$gizanh = fread($dt, 8192);
fclose($dt);
$gizankim = openssl_get_privatekey($gizanh);

// Şifreyi çözüp veriyi $veri'ye saklayalım
if (openssl_open($mühürlü, $veri, $mühür, $gizankim)) {
    echo "Zarftaki veri: ", $veri;
} else {
    echo "Zarfın mühürü açılamadı";
}

// Gizli anahtara ayrılan belleği serbest bırakalım
openssl_free_key($gizankim);
?>

Ayrıca Bakınız

  • openssl_seal() - Veriyi mühürler

openssl_get_publickey
openssl_pbkdf2
OpenSSL İşlevleri


Generates a PKCS5 v2 PBKDF2 string, defaults to SHA-1

openssl_open
openssl_pkcs12_export_to_file
OpenSSL İşlevleri
PHP Manual

openssl_pbkdf2

(PHP 5 >= 5.5.0, PHP 7)

openssl_pbkdf2 — Generates a PKCS5 v2 PBKDF2 string, defaults to SHA-1

Açıklama

string openssl_pbkdf2 ( string $password , string $salt , int $key_length , int $iterations [, string $digest_algorithm ] )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

password

salt

key_length

iterations

digest_algorithm

Dönen Değerler

Returns string başarısızlık durumunda FALSE döner.

openssl_open
openssl_pkcs12_export_to_file
OpenSSL İşlevleri


Bir PKCS#12 uyumlu sertifika deposunu bir dosyaya kaydeder

openssl_pbkdf2
openssl_pkcs12_export
OpenSSL İşlevleri
PHP Manual

openssl_pkcs12_export_to_file

(PHP 5 >= 5.2.2, PHP 7)

openssl_pkcs12_export_to_file — Bir PKCS#12 uyumlu sertifika deposunu bir dosyaya kaydeder

Açıklama

bool openssl_pkcs12_export_to_file ( mixed $x509 , string $dosya , mixed $gizli_anh , string $parola [, array $değiştirgeler ] )

Belitilen x509 sertifikalarını, PKCS#12 dosya biçemiyle belirtilen dosya'ya kaydeder.

Değiştirgeler

x509

dosya

Çıktı dosyasının yolu.

gizli_anh

PKCS#12 dosyasının gizli anahtar bileşeni.

parola

PKCS#12 dosyasının şifreleme/çözme parolası.

değiştirgeler

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

openssl_pbkdf2
openssl_pkcs12_export
OpenSSL İşlevleri


PKCS#12 uyumlu sertifika deposu dosyasını bir değişkene yerleştirir

openssl_pkcs12_export_to_file
openssl_pkcs12_read
OpenSSL İşlevleri
PHP Manual

openssl_pkcs12_export

(PHP 5 >= 5.2.2, PHP 7)

openssl_pkcs12_export — PKCS#12 uyumlu sertifika deposu dosyasını bir değişkene yerleştirir

Açıklama

bool openssl_pkcs12_export ( mixed $x509 , string &$çıktı , mixed $gizli_anahtar , string $parola [, array $değiştirgeler ] )

Belitilen x509 sertifikalarını, PKCS#12 dosya biçemiyle belirtilen çıktı dizgesine yerleştirir.

Değiştirgeler

x509

çıktı

İşlem başarılı olursa PKCS#12 bu değiştirgeye konur.

gizli_anahtar

PKCS#12 dosyasını şifrelemek için gizli anahtar.

parola

PKCS#12 dosyasının şifreleme/çözme parolası.

değiştirgeler

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

openssl_pkcs12_export_to_file
openssl_pkcs12_read
OpenSSL İşlevleri


Bir PKCS#12 Sertifika Deposunu bir diziye çözümler

openssl_pkcs12_export
openssl_pkcs7_decrypt
OpenSSL İşlevleri
PHP Manual

openssl_pkcs12_read

(PHP 5 >= 5.2.2, PHP 7)

openssl_pkcs12_read — Bir PKCS#12 Sertifika Deposunu bir diziye çözümler

Açıklama

bool openssl_pkcs12_read ( string $pkcs12 , array &$sertifikalar , string $parola )

pkcs12 ile belirtilen PKCS#12 sertifika deposunu çözümler ve sertifikaları sertifikalar dizisine yerleştirir.

Değiştirgeler

pkcs12

PKCS#12 sertifika deposunu içeren dosyanın yolu.

sertifikalar

İşlem başarılı olursa sertifikalar bu diziye konur.

parola

PKCS#12 dosyasının şifresini açmak için parola.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

openssl_pkcs12_export
openssl_pkcs7_decrypt
OpenSSL İşlevleri


S/MIME şifreli bir iletinin şifresini çözer

openssl_pkcs12_read
openssl_pkcs7_encrypt
OpenSSL İşlevleri
PHP Manual

openssl_pkcs7_decrypt

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

openssl_pkcs7_decrypt — S/MIME şifreli bir iletinin şifresini çözer

Açıklama

bool openssl_pkcs7_decrypt ( string $girdi_dosyası , string $çıktı_dosyası , mixed $alıcı_sertifikaları [, mixed $alıcı_anahtarı ] )

Şifreli iletiyi girdi_dosyası'ndan okur, alıcı_sertifikaları ile belirtilen sertifikaları ve alıcı_anahtarı ile belirtilen gizli anahtarı kullanarak iletinin şifresini çözer ve sonucu çıktı_dosyası'na kaydeder.

Değiştirgeler

girdi_dosyası

çıktı_dosyası

Şifresi çözülen iletinin kaydedileceği dosyanın yolu.

alıcı_sertifikaları

alıcı_anahtarı

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - openssl_pkcs7_decrypt() örneği

<?php
// $sert ve $anahtar kişisel sertifikanızı ve gizli anahtarınızı içersin.
$şifreli = "encrypted.msg";   // Şifreli iletinin bulunduğu dosya
$şifresiz = "decrypted.msg";  // Şifresiz iletinin yazılacağı dosya

if (openssl_pkcs7_decrypt($şifreli, $şifresiz, $sert, $anahtar)) {
    echo "Şifre çözüldü!";
} else {
    echo "Şifre çözülemedi!";
}
?>

openssl_pkcs12_read
openssl_pkcs7_encrypt
OpenSSL İşlevleri


Bir S/MIME iletiyi şifreler

openssl_pkcs7_decrypt
openssl_pkcs7_sign
OpenSSL İşlevleri
PHP Manual

openssl_pkcs7_encrypt

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

openssl_pkcs7_encrypt — Bir S/MIME iletiyi şifreler

Açıklama

bool openssl_pkcs7_encrypt ( string $girdi_dosyası , string $çıktı_dosyası , mixed $alıcı_sertifikaları , array $başlıklar [, int $seçenekler = 0 [, int $şifre = OPENSSL_CIPHER_RC2_40 ]] )

Belirtilen alıcı_sertifikaları ile okunabilir hale getirmek üzere 40 bitlik bir RC2 şifresi kullanarak girdi_dosyası ile belirtilen içeriği şifreler ve şifreli iletiyi çıktı_dosyası'na kaydeder.

Değiştirgeler

girdi_dosyası

çıktı_dosyası

alıcı_sertifikaları

Ya tek bir X.509 setifikasını içeren bir dizge ya da X.509 sertifikalarını içeren bir dizi olmalıdır.

başlıklar

İleti şifrelendikten sonra hazırlanan başlıkları içerecek dizi.

Dizi elemanların her biri ya tek bir başlık satırı içermeli ya da başlık ismini anahtar olarak alan bir ilişkisel dizi olmalıdır.

seçenekler

Kodlama işlemini etkileyen seçenekler; PKCS7 sabitlerine bakınız.

şifre

Kullanılacak şifre.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.0 | şifre değiştirgesi eklendi.

Örnekler

Örnek 1 - openssl_pkcs7_encrypt() örneği

<?php
// Bir iletiyi şifreleyip Atmaca kod adlı araştırma
// elemanınıza göndermek istediğinizi varsayalım.
// Sertifikası atmaca.pem dosyasında olsun.
$data = <<<EOD
Atmaca,

Çok gizli, kişiye özel!

8:30'da gizli yerimizde buluşalım.

Başkan
EOD;

// anahtarı yükleyelim
$key = file_get_contents("atmaca.pem");

// iletiyi dosyaya kaydedelim
$fp = fopen("msg.txt", "w");
fwrite($fp, $data);
fclose($fp);

// encrypt it
if (openssl_pkcs7_encrypt("msg.txt", "enc.txt", $key,
    array("To" => "atmaca@example.com",  // anahtarlı sözdizimi
          "From: CEO <ceo@example.com>", // indisli sözdizimi
          "Subject" => "Kişiye özel"))) {
    // iletiyi şifreleyip gönderelim!
    exec(ini_get("sendmail_path") . " < enc.txt");
}
?>

openssl_pkcs7_decrypt
openssl_pkcs7_sign
OpenSSL İşlevleri


Bir S/MIME iletiyi imzalar

openssl_pkcs7_encrypt
openssl_pkcs7_verify
OpenSSL İşlevleri
PHP Manual

openssl_pkcs7_sign

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

openssl_pkcs7_sign — Bir S/MIME iletiyi imzalar

Açıklama

bool openssl_pkcs7_sign ( string $girdi_dosyası , string $çıktı_dosyası , mixed $imza_sertifikası , mixed $gizli_anahtar , array $başlıklar [, int $seçenekler = PKCS7_DETACHED [, string $ek_sertifikalar ]] )

İleti girdi_dosyası'ndan okunur, imza_sertifikası ve bununla ilgili gizli_anahtar kullanılarak imzalanır, elde edilen imzalı ileti çıktı_dosyası'na kaydedilir.

Değiştirgeler

girdi_dosyası

çıktı_dosyası

imza_sertifikası

gizli_anahtar

başlıklar

İleti imzalandıktan sonra hazırlanan başlıkları içeren bir dizidir. Bu değiştirge ile ilgili ayrıntılı bilgi için openssl_pkcs7_encrypt()işlevine bakınız.

seçenekler

Çıktıda değişiklik yapmak için kullanılır. PKCS7 sabitlerine bakınız. Belirtilmezse PKCS7_DETACHED öntanımlıdır.

ek_sertifikalar

Alıcının imzayı doğrulamasına yardımcı olması için imzaya eklenecek sertifikaları içeren dosyanın yolu.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - openssl_pkcs7_sign() örneği

<?php
// Alıcının, iletinin sizden geldiğinden emin olması için
// iletiyi imzalamak istediğinizi varsayalım.
$data = <<<EOD

Ağırlama giderleri için sana 10.000 TL harcama yetkisi veriyorum.

Başkan
EOD;

// İletiyi dosyaya kaydedelim
$fp = fopen("msg.txt", "w");
fwrite($fp, $data);
fclose($fp);

// şifreleyelim
if (openssl_pkcs7_sign("msg.txt", "signed.txt", "mycert.pem",
    array("file://mycert.pem", "mypassphrase"),
    array("To" => "joes@example.com",   // anahtarlı sözdizimi
          "From: HQ <ceo@example.com>", // indisli sözdizimi
          "Subject" => "Kişiye özel")
    )) {
    // ileti imzalandığına göre gönderebiliriz!
    exec(ini_get("sendmail_path") . " < signed.txt");
}
?>

openssl_pkcs7_encrypt
openssl_pkcs7_verify
OpenSSL İşlevleri


S/MIME imzalı bir iletinin imzasını doğrular

openssl_pkcs7_sign
openssl_pkey_export_to_file
OpenSSL İşlevleri
PHP Manual

openssl_pkcs7_verify

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

openssl_pkcs7_verify — S/MIME imzalı bir iletinin imzasını doğrular

Açıklama

mixed openssl_pkcs7_verify ( string $dosya , int $seçenekler [, string $sertifikalar [, array $CA_bilgisi [, string $ek_sertifikalar [, string $çıktı_dosyası ]]]] )

S/MIME imzalı iletiyi içeren dosya okunur ve iletinin imzası doğrulanmaya çalışılır.

Değiştirgeler

dosya

İletinin bulunduğu dosyanın yolu..

seçenekler

İmzanın nasıl doğrulanacağı belirtilir. Ayrıntılı bilgi için PKCS7 sabitlerine bakınız.

sertifikalar

Belirtildiği takdirde, şahsın iletileri imzalamakta kullandığı sertifikaların PEM biçemli olarak saklandığı dosyanın yolu olmalıdır.

CA_bilgisi

Belirtildiği takdirde, doğrulama işleminde kullanılacak güvenilir CA sertifikaları hakkında bilgileri içeren bir dizi olmalıdır. Ayrıntılı bilgi için Sertifika Doğrulama bölümüne bakınız.

ek_sertifikalar

Belirtildiği takdirde, güvenilmez CA'lar olarak kullanılacak sertifikaların bulunduğu dosyanın yolu olmalıdır.

çıktı_dosyası

Belirtildiği takdirde, imzası doğrulanmış iletinin içeriği imzasız olarak bu dosyaya kaydedilir.

Dönen Değerler

İmza doğru ise TRUE, değilse (ileti kurcalanmışsa veya sertifika geçersizse) FALSE, işlem sırasında bir hata oluşmuşsa -1 döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.0 | çıktı_dosyası değiştirgesi eklendi.

openssl_pkcs7_sign
openssl_pkey_export_to_file
OpenSSL İşlevleri


Bir anahtarın ihraç edilebilir gösterimini bir dosyaya kaydeder

openssl_pkcs7_verify
openssl_pkey_export
OpenSSL İşlevleri
PHP Manual

openssl_pkey_export_to_file

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

openssl_pkey_export_to_file — Bir anahtarın ihraç edilebilir gösterimini bir dosyaya kaydeder

Açıklama

bool openssl_pkey_export_to_file ( mixed $anahtar , string $dosya [, string $parolası [, array $ayarlar ]] )

Anahtarın ASCII zırhlı (PEM kodlu) eşdeğerini belirtilen dosyaya kaydeder.

Bilginize: Bu işlevin gerektiği gibi çalışması için geçerli bir openssl.cnf kurulu olmalıdır. Daha ayrıntılı bilgi için kurulum bölümüne bakınız.

Değiştirgeler

anahtar

dosya

ASCII zırhlı anahtarın kaydedileceği dosyanın yolu.

parolası

Belirtilen anahtar bir parola ile korunuyorsa bu parola burada belirtilir.

ayarlar

İhraç işlemine ince ayar çekmek için ve/veya openssl yapılandırma dosyasındaki seçenekleri geçersiz kılmak için kullanılabilir. Ayrıntılar için openssl_csr_new()işlevine bakınız.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

openssl_pkcs7_verify
openssl_pkey_export
OpenSSL İşlevleri


Bir anahtarın ihraç edilebilir gösterimini bir dizge olarak döndürür

openssl_pkey_export_to_file
openssl_pkey_free
OpenSSL İşlevleri
PHP Manual

openssl_pkey_export

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

openssl_pkey_export — Bir anahtarın ihraç edilebilir gösterimini bir dizge olarak döndürür

Açıklama

bool openssl_pkey_export ( mixed $anahtar , string &$çıktı [, string $parolası [, array $ayarlar ]] )

Belirtilen anahtar bir PEM kodlu dizge olarak ihraç edilmek üzere (gönderimli belirtilen) çıktı değiştirgesine yerleştirilir.

Bilginize: Bu işlevin gerektiği gibi çalışması için geçerli bir openssl.cnf kurulu olmalıdır. Daha ayrıntılı bilgi için kurulum bölümüne bakınız.

Değiştirgeler

anahtar

çıktı

parolası

Belirtilen anahtar bir parola ile korunuyorsa bu parola burada belirtilir.

ayarlar

İhraç işlemine ince ayar çekmek için ve/veya openssl yapılandırma dosyasındaki seçenekleri geçersiz kılmak için kullanılabilir. Ayrıntılar için openssl_csr_new()işlevine bakınız.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

openssl_pkey_export_to_file
openssl_pkey_free
OpenSSL İşlevleri


Bir gizli anahtarı serbest bırakır

openssl_pkey_export
openssl_pkey_get_details
OpenSSL İşlevleri
PHP Manual

openssl_pkey_free

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

openssl_pkey_free — Bir gizli anahtarı serbest bırakır

Açıklama

void openssl_pkey_free ( resource $anahtar )

openssl_pkey_new() ile oluşturulmuş bir gizli anahtarı serbest bırakır.

Değiştirgeler

anahtar

Anahtarı betimleyin özkaynak.

Dönen Değerler

Hiçbir değer dönmez.

openssl_pkey_export
openssl_pkey_get_details
OpenSSL İşlevleri


Anahtarla ilgili ayrıntıları bir dizi içinde döndürür

openssl_pkey_free
openssl_pkey_get_private
OpenSSL İşlevleri
PHP Manual

openssl_pkey_get_details

(PHP 5 >= 5.2.0, PHP 7)

openssl_pkey_get_details — Anahtarla ilgili ayrıntıları bir dizi içinde döndürür

Açıklama

array openssl_pkey_get_details ( resource $anahtar )

Anahtarla ilgili ayrıntıları (bit sayısı, anahtar, türü gibi) bir dizi içinde döndürür.

Değiştirgeler

anahtar

Anahtarı betimleyen özkaynak.

Dönen Değerler

İşlem başarısız olursa FALSE yoksa anahtarın ayrıntılarını içeren bir dizi döner. Dönen dizi şu indisleri içerir: bits (bit sayısı), key (genel anahtarın metinsel gösterimi) ve type (şunlardan biridir: OPENSSL_KEYTYPE_RSA, OPENSSL_KEYTYPE_DSA, OPENSSL_KEYTYPE_DH, OPENSSL_KEYTYPE_EC veya bilinmiyor anlamında -1).

openssl_pkey_free
openssl_pkey_get_private
OpenSSL İşlevleri


Bir gizli anahtar döndürür

openssl_pkey_get_details
openssl_pkey_get_public
OpenSSL İşlevleri
PHP Manual

openssl_pkey_get_private

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

openssl_pkey_get_private — Bir gizli anahtar döndürür

Açıklama

resource openssl_pkey_get_private ( mixed $anahtar [, string $parolası = "" ] )

Belirtilen anahtar çözümlenip diğer işlevlerin kullanımına hazırlanır.

Değiştirgeler

anahtar

Şunlardan biri olabilir:

  1. file://bir/yol/dosya.pem biçeminde bir dizge. İsmi belirtilen dosya PEM kodlu bir sertifika, bir gizli anahtar veya her ikisini birden içerebilir.
  2. PEM kodlu bir gizli anahtar.

parolası

Belirtilen anahtar bir parola ile korunuyorsa bu parola burada belirtilir.

Dönen Değerler

İşlem başarısız olursa FALSE yoksa gizli anahtar için bir özkaynak tanıtıcısı döner.

openssl_pkey_get_details
openssl_pkey_get_public
OpenSSL İşlevleri


Genel anahtarı sertifikadan elde edip kullanıma hazırlar

openssl_pkey_get_private
openssl_pkey_new
OpenSSL İşlevleri
PHP Manual

openssl_pkey_get_public

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

openssl_pkey_get_public — Genel anahtarı sertifikadan elde edip kullanıma hazırlar

Açıklama

resource openssl_pkey_get_public ( mixed $sertifika )

Genel anahtarı belirtilen sertifika'dan elde edip diğer işlevlerin kullanımına hazırlar.

Değiştirgeler

sertifika

Şunlardan biri olabilir:

  1. Bir X.509 sertifika özkaynağı.
  2. file://bir/yol/dosya.pem biçeminde bir dizge. İsmi belirtilen dosya PEM kodlu bir sertifika, bir gizli anahtar veya her ikisini birden içerebilir.
  3. PEM kodlu bir gizli anahtar.

Dönen Değerler

İşlem başarısız olursa FALSE yoksa genel anahtar için bir özkaynak tanıtıcısı döner.

openssl_pkey_get_private
openssl_pkey_new
OpenSSL İşlevleri


Yeni bir anahtar çifti üretir

openssl_pkey_get_public
openssl_private_decrypt
OpenSSL İşlevleri
PHP Manual

openssl_pkey_new

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

openssl_pkey_new — Yeni bir anahtar çifti üretir

Açıklama

resource openssl_pkey_new ([ array $ayarlar ] )

Yeni bir gizli/genel anahtar çifti üretir. Üretilen çiftin genel anahtarını openssl_pkey_get_public() işleviyle alabilirsiniz.

Bilginize: Bu işlevin gerektiği gibi çalışması için geçerli bir openssl.cnf kurulu olmalıdır. Daha ayrıntılı bilgi için kurulum bölümüne bakınız.

Değiştirgeler

ayarlar

Anahtar üretimine ince ayar çekmek için (bit sayısını belirtmek gibi) kullanılabilir. Daha ayrıntılı bilgi için openssl_csr_new()işlevine bakınız.

Dönen Değerler

İşlem başarısız olursa FALSE yoksa anahtar çifti için bir özkaynak tanıtıcısı döner.

openssl_pkey_get_public
openssl_private_decrypt
OpenSSL İşlevleri


Genel anahtarla şifrelenmiş verinin şifresini gizli anahtarla çözer

openssl_pkey_new
openssl_private_encrypt
OpenSSL İşlevleri
PHP Manual

openssl_private_decrypt

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

openssl_private_decrypt — Genel anahtarla şifrelenmiş verinin şifresini gizli anahtarla çözer

Açıklama

bool openssl_private_decrypt ( string $şifreli_veri , string &$veri , mixed $anahtar [, int $dolgu = OPENSSL_PKCS1_PADDING ] )

Evvelce openssl_public_encrypt() tarafından şifrelenmiş şifreli_veri'nin şifresini çözüp sonucu veri değiştirgesine yerleştirir.

Şifreli veriyi okuyup okuyamayacağınızı bu işlevle öğrenebilirsiniz.

Değiştirgeler

şifreli_veri

veri

anahtar

Veriyi şifrelemekte kullanılan genel anahtarın karşılığı olan gizli anahtar.

dolgu

OPENSSL_PKCS1_PADDING öntanımlı olup yerine şunlardan biri belirtilebilir: OPENSSL_SSLV23_PADDING, OPENSSL_PKCS1_OAEP_PADDING, OPENSSL_NO_PADDING.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • openssl_public_encrypt() - Veriyi genel anahtarla şifreler
  • openssl_public_decrypt() - Gizli anahtarla şifrelenmiş verinin şifresini genel anahtarla çözer

openssl_pkey_new
openssl_private_encrypt
OpenSSL İşlevleri


Veriyi gizli anahtarla şifreler

openssl_private_decrypt
openssl_public_decrypt
OpenSSL İşlevleri
PHP Manual

openssl_private_encrypt

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

openssl_private_encrypt — Veriyi gizli anahtarla şifreler

Açıklama

bool openssl_private_encrypt ( string $veri , string &$şifreli_veri , mixed $anahtar [, int $dolgu = OPENSSL_PKCS1_PADDING ] )

veri, anahtar gizli anahtarı ile şifrelenir ve sonuç şifreli_veri değiştirgesine konur. Şifrelenmiş verinin şifresi openssl_public_decrypt() işlevi ile çözülebilir.

Bu işlev bir iletiyi imzalamakta, dolayısıyla başkası tarafından yazılmadığını kanıtlamakta kullanılabilir.

Değiştirgeler

veri

Şifrelenecek veri.

şifreli_veri

Şifrelenen veri bu değişkene konur.

anahtar

Gizli anahtar.

dolgu

OPENSSL_PKCS1_PADDING öntanımlı olup yerine OPENSSL_NO_PADDING belirtilebilir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • openssl_public_encrypt() - Veriyi genel anahtarla şifreler
  • openssl_public_decrypt() - Gizli anahtarla şifrelenmiş verinin şifresini genel anahtarla çözer

openssl_private_decrypt
openssl_public_decrypt
OpenSSL İşlevleri


Gizli anahtarla şifrelenmiş verinin şifresini genel anahtarla çözer

openssl_private_encrypt
openssl_public_encrypt
OpenSSL İşlevleri
PHP Manual

openssl_public_decrypt

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

openssl_public_decrypt — Gizli anahtarla şifrelenmiş verinin şifresini genel anahtarla çözer

Açıklama

bool openssl_public_decrypt ( string $şifreli_veri , string &$veri , mixed $anahtar [, int $dolgu = OPENSSL_PKCS1_PADDING ] )

Evvelce openssl_private_encrypt() tarafından şifrelenmiş şifreli_veri'nin şifresini çözüp sonucu veri değiştirgesine yerleştirir.

Bu işlevi, şifrelenmiş iletinin gizli anahtarın sahibi tarafından yazılıp yazılmadığı öğrenmek için kullanabilirsiniz.

Değiştirgeler

şifreli_veri

veri

anahtar

Veriyi şifrelemekte kullanılan gizli anahtarın karşılığı olan genel anahtar.

dolgu

OPENSSL_PKCS1_PADDING öntanımlı olup yerine OPENSSL_NO_PADDING belirtilebilir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • openssl_private_encrypt() - Veriyi gizli anahtarla şifreler
  • openssl_private_decrypt() - Genel anahtarla şifrelenmiş verinin şifresini gizli anahtarla çözer

openssl_private_encrypt
openssl_public_encrypt
OpenSSL İşlevleri


Veriyi genel anahtarla şifreler

openssl_public_decrypt
openssl_random_pseudo_bytes
OpenSSL İşlevleri
PHP Manual

openssl_public_encrypt

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

openssl_public_encrypt — Veriyi genel anahtarla şifreler

Açıklama

bool openssl_public_encrypt ( string $veri , string &$şifreli_veri , mixed $anahtar [, int $dolgu = OPENSSL_PKCS1_PADDING ] )

veri, anahtar genel anahtarı ile şifrelenir ve sonuç şifreli_veri değiştirgesine konur. Şifrelenmiş verinin şifresi openssl_private_decrypt() işlevi ile çözülebilir.

Bu işlev, sadece gizli anahtarın sahibi tarafından okunabilecek şifreli iletiler oluşturmak için kullanılabileceği gibi verileri bir veritabanında şifreli saklamak için de kullanılabilir.

Değiştirgeler

veri

Şifrelenecek veri.

şifreli_veri

Şifrelenen veri bu değişkene konur.

anahtar

Genel anahtar.

dolgu

OPENSSL_PKCS1_PADDING öntanımlı olup yerine şunlardan biri belirtilebilir: OPENSSL_SSLV23_PADDING, OPENSSL_PKCS1_OAEP_PADDING, OPENSSL_NO_PADDING.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • openssl_private_encrypt() - Veriyi gizli anahtarla şifreler
  • openssl_private_decrypt() - Genel anahtarla şifrelenmiş verinin şifresini gizli anahtarla çözer

openssl_public_decrypt
openssl_random_pseudo_bytes
OpenSSL İşlevleri


Yarı-rasgele dizge üretir

openssl_public_encrypt
openssl_seal
OpenSSL İşlevleri
PHP Manual

openssl_random_pseudo_bytes

(PHP 5 >= 5.3.0, PHP 7)

openssl_random_pseudo_bytes — Yarı-rasgele dizge üretir

Açıklama

bool openssl_random_pseudo_bytes ( string $uzunluk , string $güçlü )

uzunluk karakterlik bir dizge döndürür. Ayrıca, ikinci değiştirgede bu yarı rasgele baytları üretmek için güçlü bir algoritma kullanılıp kullanılmadığı da belirtilecektir.

Değiştirgeler

uzunluk

İstenen dizgenin uzunluğu. Pozitif bir tamsayı olmalıdır. PHP, bu değiştirgeden bir pozitif tamsayı elde etmek için gerekli tür dönüşümünü yapacaktır.

güçlü

Güçlü bir algoritma kullanılmışsa bu değiştirgede TRUE döner. Bir hata oluşursa bu değer NULL olacaktır.

Dönen Değerler

İşlem başarılı olursa üretilen dizge, yoksa FALSE döner.

Örnekler

Örnek 1 - openssl_random_pseudo_bytes() örneği

<?php
for ($i = -1; $i < 5; $i++) {
    var_dump(bin2hex(openssl_random_pseudo_bytes($i, $guclu)));
    var_dump($guclu);
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(0) ""
NULL
string(0) ""
NULL
string(2) "f6"
bool(true)
string(4) "8999"
bool(true)
string(6) "c202c9"
bool(true)
string(8) "45261b8f"
bool(true)

openssl_public_encrypt
openssl_seal
OpenSSL İşlevleri


Veriyi mühürler

openssl_random_pseudo_bytes
openssl_sign
OpenSSL İşlevleri
PHP Manual

openssl_seal

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

openssl_seal — Veriyi mühürler

Açıklama

int openssl_seal ( string $veri , string &$mühürlü_veri , array &$zarf_mühürleri , array $genankim_dizisi )

Rasgele üretilmiş bir gizli anahtarla RC4 kullanarak veri'yi şifreler. Anahtar, genankim_dizisi içindeki kimliklerle ilişkili anahtarlarla ve zarf_mühürleri içindeki şifreli anahtarlarla şifrelenir. Böylece, şifreli veri çok sayıda alıcıya gönderilebilir (alıcıların genel anahtarları kullanılır). Her alıcının mühürlü veri ile birlikte alıcının genel anahtarı ile şifrelenmiş zarf anahtarını da alması gerekir.

Değiştirgeler

veri

Genel anahtarlarla şifrelenip zarf anahtarları ile mühürlenecek veri.

mühürlü_veri

Mühürlenen veri bu değiştirgeye konur.

zarf_mühürleri

genankim_dizisi

Genel anahtar kimliklerini içeren dizi.

Dönen Değerler

İşlem başarılı olursa mühürlü veri mühürlü_veri değiştirgesine, zarf anahtarları zarf_mühürleri değiştirgesine konup mühürlü verinin uzunluğu döndürülür. Hata oluşursa FALSE döner.

Örnekler

Örnek 1 - openssl_seal() örneği

<?php
// $veri'nin mühürlenecek veriyi içerdiği varsayılıyor.

// alıcıların genel anahtarlarını alıp hazırlayalım
$dt = fopen("/src/openssl-0.9.6/demos/maurice/cert.pem", "r");
$sert = fread($dt, 8192);
fclose($dt);
$ga1 = openssl_get_publickey($sert);

// İşlemi ikinci alıcı için yineleyelim.
$dt = fopen("/src/openssl-0.9.6/demos/sign/cert.pem", "r");
$sert = fread($dt, 8192);
fclose($dt);
$ga2 = openssl_get_publickey($sert);

// Veriyi mühürleyelim. $muhurlu_veri sadece $ga1 ve $ga2'nin sahipleri
// tarafından sırasıyla $muhurler[0] ve $muhurler[1] anahtarları ile
// çözülebilir.
openssl_seal($data, $muhurlu_veri, $muhurler, array($ga1, $ga2));

// anahtar belleklerini serbest bırakalım
openssl_free_key($ga1);
openssl_free_key($ga2);
?>

Ayrıca Bakınız

  • openssl_open() - Mühürlü veriyi açar

openssl_random_pseudo_bytes
openssl_sign
OpenSSL İşlevleri


İmza üretir

openssl_seal
openssl_spki_export_challenge
OpenSSL İşlevleri
PHP Manual

openssl_sign

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

openssl_sign — İmza üretir

Açıklama

bool openssl_sign ( string $veri , string &$imza , mixed $gizankim [, int $algoritma = OPENSSL_ALGO_SHA1 ] )

Belirtilen veri için gizankim ile ilişkili gizli anahtarı SHA1 özeti çıkarmak için kullanarak bir imza hesaplar. Veri şifrelenmez.

Değiştirgeler

veri

İmzalanacak veri.

imza

İşlem başarılı olursa imza bu değiştirgeye konur.

gizankim

İmza bu anahtar kullanılarak oluşturulur.

algoritma

OPENSSL_ALGO_SHA1 öntanımlıdır. Daha ayrıntılı bilgi için İmzalama Algoritmaları bölümüne bakınız.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.0 | algoritma değiştirgesi eklendi.

Örnekler

Örnek 1 - openssl_sign() örneği

<?php
// $veri'nin imzalanacak veriyi içerdiği varsayılıyor

// Gizli anahtarı dosyadan alıp hazırlayalım
$dt = fopen("/src/openssl-0.9.6/demos/sign/key.pem", "r");
$gizli_anh = fread($dt, 8192);
fclose($dt);
$genankim = openssl_get_privatekey($gizli_anh);

// İmzayı hesaplayalım
openssl_sign($veri, $imza, $genankim);

// Anahtar belleğini serbest bırakalım
openssl_free_key($genankim);
?>

Ayrıca Bakınız

  • openssl_verify() - İmzayı doğrular

openssl_seal
openssl_spki_export_challenge
OpenSSL İşlevleri


Exports the challenge assoicated with a signed public key and challenge

openssl_sign
openssl_spki_export
OpenSSL İşlevleri
PHP Manual

openssl_spki_export_challenge

(PHP 5 >= 5.6.0, PHP 7)

openssl_spki_export_challenge — Exports the challenge assoicated with a signed public key and challenge

Açıklama

string openssl_spki_export_challenge ( string &$spkac )

Exports challenge from encoded signed public key and challenge

Değiştirgeler

spkac

Expects a valid signed public key and challenge

Dönen Değerler

Returns the associated challenge string or NULL on failure.

Hatalar/İstisnalar

Emits an E_WARNING level error if an invalid argument is passed via the spkac parameter.

Örnekler

Örnek 1 openssl_spki_export_challenge() example

Extracts the associated challenge string or NULL on failure.

<?php
$pkey = openssl_pkey_new('secret password');
$spkac = openssl_spki_new($pkey, 'challenge string');
$challenge = openssl_spki_export_challenge(preg_replace('/SPKAC=/', '', $spkac));
?>

Örnek 2 openssl_spki_export_challenge() example from <keygen>

Extracts the associated challenge string issued from the <keygen> element

<?php
$challenge = openssl_spki_export_challenge(preg_replace('/SPKAC=/', '', $_POST['spkac']));
?>
<keygen name="spkac" challenge="challenge string" keytype="RSA">

Ayrıca Bakınız

  • openssl_spki_new() - Generate a new signed public key and challenge
  • openssl_spki_verify() - Verifies a signed public key and challenge
  • openssl_spki_export() - Exports a valid PEM formatted public key signed public key and challenge
  • openssl_md_method()
  • openssl_csr_new() - Bir sertifika imzalama isteği (CSR) üretir
  • openssl_csr_sign() - Bir CSR'yi başka bir sertifika (veya kendisi) ile imzalayıp bir sertifika üretir

openssl_sign
openssl_spki_export
OpenSSL İşlevleri


Exports a valid PEM formatted public key signed public key and challenge

openssl_spki_export_challenge
openssl_spki_new
OpenSSL İşlevleri
PHP Manual

openssl_spki_export

(PHP 5 >= 5.6.0, PHP 7)

openssl_spki_export — Exports a valid PEM formatted public key signed public key and challenge

Açıklama

string openssl_spki_export ( string &$spkac )

Exports PEM formatted public key from encoded signed public key and challenge

Değiştirgeler

spkac

Expects a valid signed public key and challenge

Dönen Değerler

Returns the associated PEM formatted public key or NULL on failure.

Hatalar/İstisnalar

Emits an E_WARNING level error if an invalid argument is passed via the spkac parameter.

Örnekler

Örnek 1 openssl_spki_export() example

Extracts the associated PEM formatted public key or NULL on failure.

<?php
$pkey = openssl_pkey_new('secret password');
$spkac = openssl_spki_new($pkey, 'challenge string');
$pubKey = openssl_spki_export(preg_replace('/SPKAC=/', '', $spkac));

if ($pubKey) {
    echo $pubKey;
}
?>

Örnek 2 openssl_spki_export() example from <keygen>

Extracts the associated PEM formatted public key issued from the <keygen> element

<?php
$spkac = openssl_spki_export(preg_replace('/SPKAC=/', '', $_POST['spkac']));
if ($spkac != NULL) {
    echo $spkac;
} else {
    echo "Extraction of pub key failed";
}
?>
<keygen name="spkac" challenge="challenge string" keytype="RSA">

Ayrıca Bakınız

  • openssl_spki_new() - Generate a new signed public key and challenge
  • openssl_spki_verify() - Verifies a signed public key and challenge
  • openssl_spki_export_challenge() - Exports the challenge assoicated with a signed public key and challenge
  • openssl_md_method()
  • openssl_csr_new() - Bir sertifika imzalama isteği (CSR) üretir
  • openssl_csr_sign() - Bir CSR'yi başka bir sertifika (veya kendisi) ile imzalayıp bir sertifika üretir

openssl_spki_export_challenge
openssl_spki_new
OpenSSL İşlevleri


Generate a new signed public key and challenge

openssl_spki_export
openssl_spki_verify
OpenSSL İşlevleri
PHP Manual

openssl_spki_new

(PHP 5 >= 5.6.0, PHP 7)

openssl_spki_new — Generate a new signed public key and challenge

Açıklama

string openssl_spki_new ( resource &$privkey , string &$challenge [, int $algorithm = 0 ] )

Generates a signed public key and challenge using specified hashing algorithm

Değiştirgeler

privkey

privkey should be set to a private key that was previously generated by openssl_pkey_new() (or otherwise obtained from the other openssl_pkey family of functions). The corresponding public portion of the key will be used to sign the CSR.

challenge

The challenge associated to associate with the SPKAC

algorithm

The digest algorithm. See openssl_get_md_method().

Dönen Değerler

Returns a signed public key and challenge string or NULL on failure.

Hatalar/İstisnalar

Emits an E_WARNING level error if an unknown signature algorithm is passed via the algorithm parameter.

Örnekler

Örnek 1 openssl_spki_new() example

Generate a new SPKAC with the default digest (MD5)

<?php
$pkey = openssl_pkey_new('secret password');
$spkac = openssl_spki_new($pkey, 'testing');

if ($spkac !== NULL) {
    echo $spkac;
} else {
    echo "SPKAC generation failed";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

MIICRzCCAS8wggEiMA0GCSqGSIb3DQEBAQUAA4IBDwAwggEKAoIBAQDM3V3sS4o4
mB9dczziRnjGAmSp+JwPrHoYMAFGvDNmZGyiWfU586X4BKs++BAj7e/FsAfno0Hd
hN9FwpCNFSox30L03nQvLYJE7f/WqigwBeMRT7Op/xvFks4sT70xP2HRYv4KqP9a
WRcKU6cFH8VxhFhqM2txEIxZKdFLaL28yT7bEDmcglf4JLDdgNMb9rET1dkgtKE6
dOaJHPGjf1uvnOH4YwkQr7n4sLUR3Kdbh0ZJAFuQVDZulo+LLzxBBkqJJcB6FhF+
oXCdHTKZnqAhpWDz+NXYytAmevab6IYm5TWPWsJUv1YKJA5lg2mXbbloIZlN9Mgc
i9fi03bdw+crAgMBAAEWB3Rlc3RpbmcwDQYJKoZIhvcNAQEEBQADggEBALyUvP/o
pPSoWBlorFyZ2RnGwKf9qMpE0q2IJP7G3oDR4LyK/m933DUiZ+YnqThrH/CWb4Ek
y5I3OCyl3S4wCuU1ibZZwDVwYShr5ELp0J9PEf7qMQZOhNsizoC7k+Czb2xB6hYW
sKfsfTKm3cXBtH3fdgc/Z1Z7VSWnAzYo38snqm72NTf5yFRnrQdphNNXi+kn1zHA
lxXRyFDXHOcYsOnwAWfyXFA4QDHQ0ezz0UoCY8gJXovcZb4GRYqOLUAsF2HcNboy
29WN8VqE29sL9QxVZFlwMcqyoLcNnyw38GvNvAGqSvzzbnEFP2MAQXJVe0H0hdp/
MML5G2iNVgNozAo=

Ayrıca Bakınız

  • openssl_spki_new()
  • openssl_spki_export_challenge() - Exports the challenge assoicated with a signed public key and challenge
  • openssl_spki_export() - Exports a valid PEM formatted public key signed public key and challenge
  • openssl_csr_new() - Bir sertifika imzalama isteği (CSR) üretir
  • openssl_csr_sign() - Bir CSR'yi başka bir sertifika (veya kendisi) ile imzalayıp bir sertifika üretir

openssl_spki_export
openssl_spki_verify
OpenSSL İşlevleri


Verifies a signed public key and challenge

openssl_spki_new
openssl_verify
OpenSSL İşlevleri
PHP Manual

openssl_spki_verify

(PHP 5 >= 5.6.0, PHP 7)

openssl_spki_verify — Verifies a signed public key and challenge

Açıklama

string openssl_spki_verify ( string &$spkac )

Validates the supplied signed public key and challenge

Değiştirgeler

spkac

Expects a valid signed public key and challenge

Dönen Değerler

Returns a boolean on success or failure.

Hatalar/İstisnalar

Emits an E_WARNING level error if an invalid argument is passed via the spkac parameter.

Örnekler

Örnek 1 openssl_spki_verify() example

Validates an existing signed public key and challenge

<?php
$pkey = openssl_pkey_new('secret password');
$spkac = openssl_spki_new($pkey, 'challenge string');

if (openssl_spki_verify(preg_replace('/SPKAC=/', '', $spkac))) {
    echo $spkac;
} else {
    echo "SPKAC validation failed";
}
?>

Örnek 2 openssl_spki_verify() example from <keygen>

Validates an existing signed public key and challenge issued from the <keygen> element

<?php
if (openssl_spki_verify(preg_replace('/SPKAC=/', '', $_POST['spkac']))) {
    echo $spkac;
} else {
    echo "SPKAC validation failed";
}
?>
<keygen name="spkac" challenge="challenge string" keytype="RSA">

Ayrıca Bakınız

  • openssl_spki_new() - Generate a new signed public key and challenge
  • openssl_spki_export_challenge() - Exports the challenge assoicated with a signed public key and challenge
  • openssl_spki_export() - Exports a valid PEM formatted public key signed public key and challenge
  • openssl_md_method()
  • openssl_csr_new() - Bir sertifika imzalama isteği (CSR) üretir
  • openssl_csr_sign() - Bir CSR'yi başka bir sertifika (veya kendisi) ile imzalayıp bir sertifika üretir

openssl_spki_new
openssl_verify
OpenSSL İşlevleri


İmzayı doğrular

openssl_spki_verify
openssl_x509_check_private_key
OpenSSL İşlevleri
PHP Manual

openssl_verify

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

openssl_verify — İmzayı doğrular

Açıklama

int openssl_verify ( string $veri , string $imza , mixed $genankim [, int $algoritma ] )

genankim ile ilişkili genel anahtarı kullanarak belirtilen veri için belirtilen imza ile imza doğrulaması yapar.

Değiştirgeler

veri

İmzalı veri.

imza

Doğrulama için kullanılacak imza.

genankim

Genel anahtarı tanımlayıcı kimlik.

algoritma

OPENSSL_ALGO_SHA1 öntanımlıdır. Daha ayrıntılı bilgi için İmzalama Algoritmaları bölümüne bakınız.

Dönen Değerler

İmza doğruysa 1, yanlışsa 0, hata oluşmuşsa -1 döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.0 | algoritma değiştirgesi eklendi.

Örnekler

Örnek 1 - openssl_verify() örneği

<?php
// $veri ve $imza'nın veriyi ve imzayı içerdiği varsayılıyor

// Genel anahtarı sertifikadan alıp hazırlayalım
$dt = fopen("/src/openssl-0.9.6/demos/sign/cert.pem", "r");
$sert = fread($dt, 8192);
fclose($dt);
$genankim = openssl_get_publickey($sert);

// imza doğru mu, bir bakıbakıverelim
$ok = openssl_verify($veri, $imza, $genankim);
if ($ok == 1) {
    echo "iyi";
} elseif ($ok == 0) {
    echo "kötü";
} else {
    echo "çirkin, bir hata oluştu";
}
// Anahtar belleğini serbest bırakalım
openssl_free_key($genankim);
?>

Ayrıca Bakınız

  • openssl_sign() - İmza üretir

openssl_spki_verify
openssl_x509_check_private_key
OpenSSL İşlevleri


Bir gizli anahtarın bir sertifikaya karşılık olup olmadığına bakar

openssl_verify
openssl_x509_checkpurpose
OpenSSL İşlevleri
PHP Manual

openssl_x509_check_private_key

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

openssl_x509_check_private_key — Bir gizli anahtarın bir sertifikaya karşılık olup olmadığına bakar

Açıklama

bool openssl_x509_check_private_key ( mixed $x509sert , mixed $anahtar )

Belirtilen gizli anahtarın belirtilen sertifikaya karşılık olup olmadığına bakar.

Değiştirgeler

x509sert

openssl_x509_read() tarafından döndürülen bir X509 sertifika özkaynağı.

anahtar

Gizli anahtar.

Dönen Değerler

Gizli anahtar, x509sert'in karşılığı ise TRUE yoksa FALSE döner.

openssl_verify
openssl_x509_checkpurpose
OpenSSL İşlevleri


Sertifikanın belli bir amaçla kulanılıp kullanılmayacağına bakar

openssl_x509_check_private_key
openssl_x509_export_to_file
OpenSSL İşlevleri
PHP Manual

openssl_x509_checkpurpose

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

openssl_x509_checkpurpose — Sertifikanın belli bir amaçla kulanılıp kullanılmayacağına bakar

Açıklama

int openssl_x509_checkpurpose ( mixed $x509sert , int $amaç [, array $CA_bilgisi [, string $güvencesiz_dosya ]] )

Belirtilen sertifikanın belirtilen amaç için kullanılıp kullanılmayacağına bakar.

Değiştirgeler

x509sert

openssl_x509_read() tarafından döndürülen bir X509 sertifika özkaynağı.

amaç

openssl_x509_checkpurpose() amaçlar
Sabit | Açıklama
X509_PURPOSE_SSL_CLIENT | Sertifika, bir SSL bağlantısının istemci tarafı için kullanılabilir mi?
X509_PURPOSE_SSL_SERVER | Sertifika, bir SSL bağlantısının sunucu tarafı için kullanılabilir mi?
X509_PURPOSE_NS_SSL_SERVER | Sertifika, Netscape SSL sunucusu için kullanılabilir mi?
X509_PURPOSE_SMIME_SIGN | Sertifika, S/MIME epostaları imzalamak için kullanılabilir mi?
X509_PURPOSE_SMIME_ENCRYPT | Sertifika, S/MIME epostaları şifrelemek için kullanılabilir mi?
X509_PURPOSE_CRL_SIGN | Sertifika, bir sertifika yürürlükten kaldırma listesi (CRL) için kullanılabilir mi?
X509_PURPOSE_ANY | Sertifika, her türlü amaç için kullanılabilir mi?
Bu seçenekler bit alanları değildir, dolayısıyla sadece biri belirtilebilir!

CA_bilgisi

Sertifika Doğrulama bölümünde açıklandığı gibi güvenilir yetkili sertifika dosya ve dizinlerini içeren bir dizi olmalıdır.

güvencesiz_dosya

Belirtildiği takdirde, sertifikayı doğrulamaya yardımcı olacak sertifikaların bulunduğu PEM kodlamalı dosyanın (bu dosyadan gelen sertifikalara güvenilmez ise de) ismi olmalıdır.

Dönen Değerler

Sertifika belirtilen amaç için kullanılabiliyorsa TRUE, kullanılamıyorsa FALSE, bir hata oluşmuşsa -1 döner.

openssl_x509_check_private_key
openssl_x509_export_to_file
OpenSSL İşlevleri


Belirtilen sertifikayı bir dosyaya kaydeder

openssl_x509_checkpurpose
openssl_x509_export
OpenSSL İşlevleri
PHP Manual

openssl_x509_export_to_file

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

openssl_x509_export_to_file — Belirtilen sertifikayı bir dosyaya kaydeder

Açıklama

bool openssl_x509_export_to_file ( mixed $x509sert , string $dosya [, bool $metinsiz ] )

x509sert ile belirtilen sertifikayı yolu dosya değiştirgesinde belirtilen dosyaya PEM kodlamalı bir dizge olarak kaydeder.

Değiştirgeler

x509sert

openssl_x509_read() tarafından döndürülen bir X509 sertifika özkaynağı.

dosya

Sertifikanın kaydedileceği dosyanın yolu.

metinsiz

Belirtilmesi isteğe bağlı olan metinsiz değiştirgesi çıktının ayrıntı seviyesini belirler. FALSE belirtilirse çıktıda insanlar için anlamlı bilgiler bulunmaz. Değiştirgenin öntanımlı değeri: TRUE

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

openssl_x509_checkpurpose
openssl_x509_export
OpenSSL İşlevleri


Belirtilen sertifikayı bir dizge olarak döndürür

openssl_x509_export_to_file
openssl_x509_fingerprint
OpenSSL İşlevleri
PHP Manual

openssl_x509_export

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

openssl_x509_export — Belirtilen sertifikayı bir dizge olarak döndürür

Açıklama

bool openssl_x509_export ( mixed $x509sert , string &$çıktı [, bool $metinsiz ] )

x509sert ile belirtilen sertifikayı çıktı değiştirgesinde PEM kodlamalı bir dizge olarak döndürür.

Değiştirgeler

x509sert

openssl_x509_read() tarafından döndürülen bir X509 sertifika özkaynağı.

çıktı

PEM kodlamalı dizgenin konulacağı değişken.

metinsiz

Belirtilmesi isteğe bağlı olan metinsiz değiştirgesi çıktının ayrıntı seviyesini belirler. FALSE belirtilirse çıktıda insanlar için anlamlı bilgiler bulunmaz. Değiştirgenin öntanımlı değeri: TRUE

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

openssl_x509_export_to_file
openssl_x509_fingerprint
OpenSSL İşlevleri


Calculates the fingerprint, or digest, of a given X.509 certificate

openssl_x509_export
openssl_x509_free
OpenSSL İşlevleri
PHP Manual

openssl_x509_fingerprint

(PHP 5.6, PHP 7)

openssl_x509_fingerprint — Calculates the fingerprint, or digest, of a given X.509 certificate

Açıklama

bool openssl_x509_fingerprint ( mixed $x509 [, string $hash_algorithm = "sha1" [, bool $raw_output = FALSE ]] )

openssl_x509_fingerprint() returns the digest of x509 as a string.

Değiştirgeler

x509

Geçerli değerleri Anahtar/Sertifika Değiştirgeleri sayfasında bulabilirsiniz.

hash_algorithm

The hash algorithm to use, e.g. "md5" or "sha1"

raw_output

When set to TRUE, outputs raw binary data. FALSE outputs lowercase hexits.

Dönen Değerler

Returns a string containing the calculated certificate fingerprint as lowercase hexits unless raw_output is set to TRUE in which case the raw binary representation of the message digest is returned.

Returns FALSE on failure.

openssl_x509_export
openssl_x509_free
OpenSSL İşlevleri


Sertifika özkaynağını serbest bırakır

openssl_x509_fingerprint
openssl_x509_parse
OpenSSL İşlevleri
PHP Manual

openssl_x509_free

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

openssl_x509_free — Sertifika özkaynağını serbest bırakır

Açıklama

void openssl_x509_free ( resource $x509sert )

x509sert ile belirtilen bellek özkaynağını serbest bırakır.

Değiştirgeler

x509sert

openssl_x509_read() tarafından döndürülen bir X509 sertifika özkaynağı.

Dönen Değerler

Hiçbir değer dönmez.

openssl_x509_fingerprint
openssl_x509_parse
OpenSSL İşlevleri


Bir X509 sertifikasını çözümleyip bilgileri bir dizi içinde döndürür

openssl_x509_free
openssl_x509_read
OpenSSL İşlevleri
PHP Manual

openssl_x509_parse

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

openssl_x509_parse — Bir X509 sertifikasını çözümleyip bilgileri bir dizi içinde döndürür

Açıklama

array openssl_x509_parse ( mixed $x509sert [, bool $kısa_adlar = true ] )

x509sert ile belirtilen sertifika ile ilgili (konu ismi, yayıncı ismi, amaçlar, geçerli olduğu tarihler gibi) bilgiler döndürür.

Değiştirgeler

x509sert

openssl_x509_read() tarafından döndürülen bir X509 sertifika özkaynağı.

kısa_adlar

Dizi içinde verinin nasıl indisleneceği belirtilir. TRUE belirtilirse (öntanımlıdır) indis olarak alanların kısa isimleri, aksi takdirde uzun isimleri kullanılır. Örneğin, CN, commonName için bir kısaltmadır.

Dönen Değerler

Dönen verinin yapısında değişiklik yapılma ihtimali olduğundan, yapı (ihtiyaten) henüz belgelenmemiştir.

openssl_x509_free
openssl_x509_read
OpenSSL İşlevleri


Bir X.509 sertifikasını çözümleyip sertifika için bir tanıtıcı döndürür

openssl_x509_parse
Password Hashing
OpenSSL İşlevleri
PHP Manual

openssl_x509_read

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

openssl_x509_read — Bir X.509 sertifikasını çözümleyip sertifika için bir tanıtıcı döndürür

Açıklama

resource openssl_x509_read ( mixed $x509srtfk_verisi )

x509srtfk_verisi ile belirtilen sertifikayı çözümleyip sertifika ile ilgili bir özkaynak tanıtıcısı döndürür.

Değiştirgeler

x509srtfk_verisi

Dönen Değerler

Başarısızlık durumunda FALSE yoksa bir özkaynak tanıtıcısı döner.

openssl_x509_parse
Password Hashing
OpenSSL İşlevleri


Password Hashing

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Password Hashing İşlevleri
    • password_get_info — Returns information about the given hash
    • password_hash — Creates a password hash
    • password_needs_rehash — Checks if the given hash matches the given options
    • password_verify — Verifies that a password matches a hash
openssl_x509_read
Giriş
Şifresel Eklentiler


Giriş

The password hashing API provides an easy to use wrapper around crypt() to make it easy to create and manage passwords in a secure manner.

This extension is available since PHP 5.5.0 but there is also an » userland implementation for PHP >= 5.3.7.

Password Hashing
Yapılandırma/Kurulum
Password Hashing


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Password Hashing


Öntanımlı Sabitler

Aşağıdaki sabitler PHP çekirdeğinin parçası olarak daima kullanılabilir durumdadır.

PASSWORD_BCRYPT (integer)

PASSWORD_BCRYPT is used to create new password hashes using the CRYPT_BLOWFISH algorithm.

This will always result in a hash using the "$2y$" crypt format, which is always 60 characters wide.

Supported Options:

  • salt - to manually provide a salt to use when hashing the password. Note that this will override and prevent a salt from being automatically generated.

    If omitted, a random salt will be generated by password_hash() for each password hashed. This is the intended mode of operation.

  • cost - which denotes the algorithmic cost that should be used. Examples of these values can be found on the crypt() page.

    If ommitted, a default value of 10 will be used. This is a good baseline cost, but you may want to consider increasing it depending on your hardware.

PASSWORD_DEFAULT (integer)

The default algorithm to use for hashing if no algorithm is provided. This may change in newer PHP releases when newer, stronger hashing algorithms are supported.

It is worth noting that over time this constant can (and likely will) change. Therefore you should be aware that the length of the resulting hash can change. Therefore, if you use PASSWORD_DEFAULT you should store the resulting hash in a way that can store more than 60 characters (255 is the recomended width).

Values for this constant:

  • PHP 5.5.0 - PASSWORD_BCRYPT

Özkaynak Türleri
Password Hashing İşlevleri
Password Hashing


Password Hashing İşlevleri

İçindekiler

  • password_get_info — Returns information about the given hash
  • password_hash — Creates a password hash
  • password_needs_rehash — Checks if the given hash matches the given options
  • password_verify — Verifies that a password matches a hash
Öntanımlı Sabitler
password_get_info
Password Hashing


Returns information about the given hash

Password Hashing İşlevleri
password_hash
Password Hashing İşlevleri
PHP Manual

password_get_info

(PHP 5 >= 5.5.0, PHP 7)

password_get_info — Returns information about the given hash

Açıklama

array password_get_info ( string $hash )

When passed in a valid hash created by an algorithm supported by password_hash(), this function will return an array of information about that hash.

Değiştirgeler

hash

A hash created by password_hash().

Dönen Değerler

Returns an associative array with three elements:

  • algo, which will match a password algorithm constant
  • algoName, which has the human readable name of the algorithm
  • options, which includes the options provided when calling password_hash()

Password Hashing İşlevleri
password_hash
Password Hashing İşlevleri


Creates a password hash

password_get_info
password_needs_rehash
Password Hashing İşlevleri
PHP Manual

password_hash

(PHP 5 >= 5.5.0, PHP 7)

password_hash — Creates a password hash

Açıklama

string password_hash ( string $password , integer $algo [, array $options ] )

password_hash() creates a new password hash using a strong one-way hashing algorithm. password_hash() is compatible with crypt(). Therefore, password hashes created by crypt() can be used with password_hash().

The following algorithms are currently supported:

  • PASSWORD_DEFAULT - Use the bcrypt algorithm (default as of PHP 5.5.0). Note that this constant is designed to change over time as new and stronger algorithms are added to PHP. For that reason, the length of the result from using this identifier can change over time. Therefore, it is recommended to store the result in a database column that can expand beyond 60 characters (255 characters would be a good choice).
  • PASSWORD_BCRYPT - Use the CRYPT_BLOWFISH algorithm to create the hash. This will produce a standard crypt() compatible hash using the "$2y$" identifier. The result will always be a 60 character string, başarısızlık durumunda FALSE döner.

Supported Options:

  • salt - to manually provide a salt to use when hashing the password. Note that this will override and prevent a salt from being automatically generated.

    If omitted, a random salt will be generated by password_hash() for each password hashed. This is the intended mode of operation.

    Uyarı

    The salt option has been deprecated as of PHP 7.0.0. It is now preferred to simply use the salt that is generated by default.

  • cost - which denotes the algorithmic cost that should be used. Examples of these values can be found on the crypt() page.

    If omitted, a default value of 10 will be used. This is a good baseline cost, but you may want to consider increasing it depending on your hardware.

Değiştirgeler

password

The user's password.

Dikkat

Using the PASSWORD_BCRYPT as the algorithm, will result in the password parameter being truncated to a maximum length of 72 characters.

algo

A password algorithm constant denoting the algorithm to use when hashing the password.

options

An associative array containing options. See the password algorithm constants for documentation on the supported options for each algorithm.

If omitted, a random salt will be created and the default cost will be used.

Dönen Değerler

Returns the hashed password, başarısızlık durumunda FALSE döner.

The used algorithm, cost and salt are returned as part of the hash. Therefore, all information that's needed to verify the hash is included in it. This allows the password_verify() function to verify the hash without needing separate storage for the salt or algorithm information.

Örnekler

Örnek 1 password_hash() example

<?php
/**
 * We just want to hash our password using the current DEFAULT algorithm.
 * This is presently BCRYPT, and will produce a 60 character result.
 *
 * Beware that DEFAULT may change over time, so you would want to prepare
 * By allowing your storage to expand past 60 characters (255 would be good)
 */
echo password_hash("rasmuslerdorf", PASSWORD_DEFAULT)."\n";
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

$2y$10$.vGA1O9wmRjrwAVXD98HNOgsNpDczlqm3Jq7KnEd1rVAGv3Fykk1a

Örnek 2 password_hash() example setting cost manually

<?php
/**
 * In this case, we want to increase the default cost for BCRYPT to 12.
 * Note that we also switched to BCRYPT, which will always be 60 characters.
 */
$options = [
    'cost' => 12,
];
echo password_hash("rasmuslerdorf", PASSWORD_BCRYPT, $options)."\n";
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

$2y$12$QjSH496pcT5CEbzjD/vtVeH03tfHKFy36d4J0Ltp3lRtee9HDxY3K

Örnek 3 password_hash() example setting salt manually

<?php
/**
 * Note that the salt here is randomly generated.
 * Never use a static salt or one that is not randomly generated.
 *
 * For the VAST majority of use-cases, let password_hash generate the salt randomly for you
 */
$options = [
    'cost' => 11,
    'salt' => mcrypt_create_iv(22, MCRYPT_DEV_URANDOM),
];
echo password_hash("rasmuslerdorf", PASSWORD_BCRYPT, $options)."\n";
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

$2y$11$q5MkhSBtlsJcNEVsYh64a.aCluzHnGog7TQAKVmQwO9C8xb.t89F.

Örnek 4 password_hash() example finding a good cost

<?php
/**
 * This code will benchmark your server to determine how high of a cost you can
 * afford. You want to set the highest cost that you can without slowing down
 * you server too much. 8-10 is a good baseline, and more is good if your servers
 * are fast enough. The code below aims for ? 50 milliseconds stretching time,
 * which is a good baseline for systems handling interactive logins.
 */
$timeTarget = 0.05; // 50 milliseconds

$cost = 8;
do {
    $cost++;
    $start = microtime(true);
    password_hash("test", PASSWORD_BCRYPT, ["cost" => $cost]);
    $end = microtime(true);
} while (($end - $start) < $timeTarget);

echo "Appropriate Cost Found: " . $cost . "\n";
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Appropriate Cost Found: 10

Notlar

Dikkat

It is strongly recommended that you do not generate your own salt for this function. It will create a secure salt automatically for you if you do not specify one.

As noted above, providing the salt option in PHP 7.0 will generate a deprecation warning. Support for providing a salt manually may be removed in a future PHP release.

Bilginize:

It is recommended that you test this function on your servers, and adjust the cost parameter so that execution of the function takes less than 100 milliseconds on interactive systems. The script in the above example will help you choose a good cost value for your hardware.

Bilginize: Updates to supported algorithms by this function (or changes to the default one) must follow the following rules:

  • Any new algorithm must be in core for at least 1 full release of PHP prior to becoming default. So if, for example, a new algorithm is added in 7.5.5, it would not be eligible for default until 7.7 (since 7.6 would be the first full release). But if a different algorithm was added in 7.6.0, it would also be eligible for default at 7.7.0.
  • The default should only change in a full release (7.3.0, 8.0.0, etc) and not in a revision release. The only exception to this is in an emergency when a critical security flaw is found in the current default.

Ayrıca Bakınız

  • password_verify() - Verifies that a password matches a hash
  • crypt() - Tek yönlü dizge şifrelemesi yapar
  • » userland implementation

password_get_info
password_needs_rehash
Password Hashing İşlevleri


Checks if the given hash matches the given options

password_hash
password_verify
Password Hashing İşlevleri
PHP Manual

password_needs_rehash

(PHP 5 >= 5.5.0, PHP 7)

password_needs_rehash — Checks if the given hash matches the given options

Açıklama

boolean password_needs_rehash ( string $hash , integer $algo [, array $options ] )

This function checks to see if the supplied hash implements the algorithm and options provided. If not, it is assumed that the hash needs to be rehashed.

Değiştirgeler

hash

A hash created by password_hash().

algo

A password algorithm constant denoting the algorithm to use when hashing the password.

options

An associative array containing options. See the password algorithm constants for documentation on the supported options for each algorithm.

Örnekler

Örnek 1 Usage of password_needs_rehash()

<?php

$password = 'rasmuslerdorf';
$hash = '$2y$10$YCFsG6elYca568hBi2pZ0.3LDL5wjgxct1N8w/oLR/jfHsiQwCqTS';

// The cost parameter can change over time as hardware improves
$options = array('cost' => 11);

// Verify stored hash against plain-text password
if (password_verify($password, $hash)) {
    // Check if a newer hashing algorithm is available
    // or the cost has changed
    if (password_needs_rehash($hash, PASSWORD_DEFAULT, $options)) {
        // If so, create a new hash, and replace the old one
        $newHash = password_hash($password, PASSWORD_DEFAULT, $options);
    }

    // Log user in
}
?>

Dönen Değerler

Returns TRUE if the hash should be rehashed to match the given algo and options, or FALSE otherwise.

password_hash
password_verify
Password Hashing İşlevleri


Verifies that a password matches a hash

password_needs_rehash
Veritabanı Eklentileri
Password Hashing İşlevleri
PHP Manual

password_verify

(PHP 5 >= 5.5.0, PHP 7)

password_verify — Verifies that a password matches a hash

Açıklama

boolean password_verify ( string $password , string $hash )

Verifies that the given hash matches the given password.

Note that password_hash() returns the algorithm, cost and salt as part of the returned hash. Therefore, all information that's needed to verify the hash is included in it. This allows the verify function to verify the hash without needing separate storage for the salt or algorithm information.

This function is safe against timing attacks.

Değiştirgeler

password

The user's password.

hash

A hash created by password_hash().

Dönen Değerler

Returns TRUE if the password and hash match, or FALSE otherwise.

Örnekler

Örnek 1 password_verify() example

<?php
// See the password_hash() example to see where this came from.
$hash = '$2y$07$BCryptRequires22Chrcte/VlQH0piJtjXl.0t1XkA8pw9dMXTpOq';

if (password_verify('rasmuslerdorf', $hash)) {
    echo 'Password is valid!';
} else {
    echo 'Invalid password.';
}
?>

Yukarıdaki örneğin çıktısı:

Password is valid!

Ayrıca Bakınız

  • password_hash() - Creates a password hash
  • » userland implementation

password_needs_rehash
Veritabanı Eklentileri
Password Hashing İşlevleri


Veritabanı Eklentileri

  • Soyutlama Katmanları
    • DBA — Database (dbm-style) Abstraction Layer
    • dbx
    • ODBC — ODBC (Tekilleştirilmiş)
    • PDO — PHP Veri Nesneleri
  • Sağlayıcıya Göre Veritabanı Eklentileri
    • CUBRID
    • DB++
    • dBase
    • filePro
    • Firebird/InterBase
    • FrontBase
    • IBM DB2 — IBM DB2, Cloudscape and Apache Derby
    • Informix
    • Ingres — Ingres DBMS, EDBC, and Enterprise Access Gateways
    • MaxDB
    • Mongo — MongoDB driver (legacy)
    • MongoDB — MongoDB driver
    • mSQL
    • Mssql — Microsoft SQL Server
    • MySQL — MySQL Drivers and Plugins
    • OCI8 — Oracle OCI8
    • Paradox — Paradox File Access
    • PostgreSQL
    • SQLite
    • SQLite3
    • SQLSRV — Microsoft SQL Server Driver for PHP
    • Sybase
    • tokyo_tyrant
password_verify
Soyutlama Katmanları
İşlev Başvuru Kılavuzu


Soyutlama Katmanları

  • DBA — Database (dbm-style) Abstraction Layer
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • DBA İşlevleri
  • dbx
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • dbx İşlevleri
  • ODBC — ODBC (Tekilleştirilmiş)
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • ODBC İşlevleri
  • PDO — PHP Veri Nesneleri
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Bağlantılar ve Bağlantı Yönetimi
    • Hareketler ve özdevinimli işlemler
    • Hazır deyimler ve Saklı Yordamlar
    • Hatalar ve Ele Alınışları
    • Büyük Veri Nesneleri (LOB'lar)
    • PDO — PDO sınıfı
    • PDOStatement — PDOStatement sınıfı
    • PDOException — PDOException sınıfı
    • PDO Sürücüleri
Veritabanı Eklentileri
DBA
Veritabanı Eklentileri


Database (dbm-style) Abstraction Layer

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
    • Basic usage
  • DBA İşlevleri
    • dba_close — Close a DBA database
    • dba_delete — Delete DBA entry specified by key
    • dba_exists — Check whether key exists
    • dba_fetch — Fetch data specified by key
    • dba_firstkey — Fetch first key
    • dba_handlers — List all the handlers available
    • dba_insert — Insert entry
    • dba_key_split — Splits a key in string representation into array representation
    • dba_list — List all open database files
    • dba_nextkey — Fetch next key
    • dba_open — Open database
    • dba_optimize — Optimize database
    • dba_popen — Open database persistently
    • dba_replace — Replace or insert entry
    • dba_sync — Synchronize database
Soyutlama Katmanları
Giriş
Soyutlama Katmanları


Giriş

These functions build the foundation for accessing Berkeley DB style databases.

This is a general abstraction layer for several file-based databases. As such, functionality is limited to a common subset of features supported by modern databases such as » Oracle Berkeley DB.

DBA
Yapılandırma/Kurulum
DBA


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
DBA


Gereksinimler

The behaviour of various aspects depends on the implementation of the underlying database. Functions such as dba_optimize() and dba_sync() will do what they promise for one database and will do nothing for others. You have to download and install supported dba-Handlers.

List of DBA handlers
Handler | Notes
dbm | Dbm is the oldest (original) type of Berkeley DB style databases. You should avoid it, if possible. We do not support the compatibility functions built into DB2 and gdbm, because they are only compatible on the source code level, but cannot handle the original dbm format.
ndbm | Ndbm is a newer type and more flexible than dbm. It still has most of the arbitrary limits of dbm (therefore it is deprecated).
gdbm | Gdbm is the » GNU database manager.
db2 | DB2 is for » Oracle Berkeley DB 2. It is described as "a programmatic toolkit that provides high-performance built-in database support for both standalone and client/server applications.
db3 | DB3 is for » Oracle Berkeley DB 3.
db4 | DB4 is for » Oracle Berkeley DB 4 or 5. This option is available from PHP 4.3.2. It can be used with BDB 5 from PHP 5.3.3.
cdb | Cdb is "a fast, reliable, lightweight package for creating and reading constant databases." It is from the author of qmail and can be found at » http://cr.yp.to/cdb.html. Since it is constant, we support only reading operations. And since PHP 4.3.0 we support writing (not updating) through the internal cdb library.
cdb_make | Since PHP 4.3.0 we support creation (not updating) of cdb files when the bundled cdb library is used.
flatfile | This is available since PHP 4.3.0 for compatibility with the deprecated dbm extension only and should be avoided. However you may use this where files were created in this format. That happens when configure could not find any external library.
inifile | This is available since PHP 4.3.3 to be able to modify php.ini files from within PHP scripts. When working with ini files you can pass arrays of the form array(0=>group,1=>value_name) or strings of the form "[group]value_name" where group is optional. As the functions dba_firstkey() and dba_nextkey() return string representations of the key there is a new function dba_key_split() available since PHP 5 which allows to convert the string keys into array keys without loosing FALSE.
qdbm | This is available since PHP 5.0.0. The qdbm library can be loaded from » http://fallabs.com/qdbm/index.html.
tcadb | This is available since PHP 5.4.0. The Tokyo Cabinet library can be loaded from » http://fallabs.com/tokyocabinet/.

When invoking the dba_open() or dba_popen() functions, one of the handler names must be supplied as an argument. The actually available list of handlers is displayed by invoking phpinfo() or dba_handlers().

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

By using the --enable-dba=shared configuration option you can build a dynamic loadable module to enable PHP for basic support of dbm-style databases. You also have to add support for at least one of the following handlers by specifying the --with-XXXX configure switch to your PHP configure line.

Uyarı

After configuring and compiling PHP you must execute the following test from commandline: php run-tests.php ext/dba. This shows whether your combination of handlers works. Most problematic are dbm and ndbm which conflict with many installations. The reason for this is that on several systems these libraries are part of more than one other library. The configuration test only prevents you from configuring malfunctioning single handlers but not combinations.

Supported DBA handlers
Handler | Configure Switch
dbm

To enable support for dbm add --with-dbm[=DIR] .

Bilginize:

dbm normally is a wrapper which often results in failures. This means you should only use dbm if you are sure it works and if you really need this format.

ndbm

To enable support for ndbm add --with-ndbm[=DIR] .

Bilginize:

ndbm normally is a wrapper which often results in failures. This means you should only use ndbm if you are sure it works and if you really need this format.

gdbm | To enable support for gdbm add --with-gdbm[=DIR] .
db2

To enable support for Oracle Berkeley DB 2 add --with-db2[=DIR] .

Bilginize:

db2 conflicts with db3 and db4.

db3

To enable support for Oracle Berkeley DB 3 add --with-db3[=DIR] .

Bilginize:

db3 conflicts with db2 and db4.

db4

To enable support for Oracle Berkeley DB 4 or 5 add --with-db4[=DIR] .

Bilginize:

db4 conflicts with db2 and db3.

Bilginize:

The db4 option was added in PHP 4.3.2. In earlier versions of PHP you need to use --with-db3=DIR with DIR being the path to db4 library. It is not possible to use db versions starting from 4.1 with PHP prior to version 4.3.0. Also, the db libraries with versions 4.1 through 4.1.24 cannot be used in any PHP version.

Support for BDB 5 was added in PHP 5.3.3.

cdb

To enable support for cdb add --with-cdb[=DIR] .

Bilginize:

Since PHP 4.3.0 you can omit DIR to use the bundled cdb library that adds the cdb_make handler which allows creation of cdb files and allows to access cdb files on the network using PHP's streams.

flatfile

To enable support for flatfile add --with-flatfile .

Bilginize:

This was added in PHP 4.3.0 to add compatibility with deprecated dbm extension. Use this handler only when you cannot install one of the libraries required by the other handlers and when you cannot use bundled cdb handler.

inifile

To enable support for inifile add --with-inifile .

Bilginize:

This was added in PHP 5.0.0 and allows to read and set microsoft style .ini files (like the php.ini file).

qdbm

To enable support for qdbm add --with-qdbm[=DIR] .

Bilginize:

qdbm conflicts with dbm and gdbm.

Bilginize:

This was added in PHP 5.0.0. The qdbm library can be loaded from » http://fallabs.com/qdbm/index.html.

tcadb

To enable support for Tokyo Cabinet add --with-tcadb[=DIR] .

Bilginize:

This was added in PHP 5.4.0. The Tokyo Cabinet library can be loaded from » http://fallabs.com/tokyocabinet/.

Bilginize:

Up to PHP 4.3.0 you are able to add both db2 and db3 handler but only one of them can be used internally. That means that you cannot have both file formats. Starting with PHP 5.0.0 there is a configuration check avoid such misconfigurations.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

DBA Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
dba.default_handler | DBA_DEFAULT | PHP_INI_ALL |

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

dba.default_handler string

The name of the default handler

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Özkaynak Türleri

The functions dba_open() and dba_popen() return a handle to the specified database file to access which is used by all other dba-function calls.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
Örnekler
DBA


Örnekler

İçindekiler

  • Basic usage
Öntanımlı Sabitler
Basic usage
DBA


Basic usage

Örnek 1 DBA example

<?php

$id = dba_open("/tmp/test.db", "n", "db2");

if (!$id) {
    echo "dba_open failed\n";
    exit;
}

dba_replace("key", "This is an example!", $id);

if (dba_exists("key", $id)) {
    echo dba_fetch("key", $id);
    dba_delete("key", $id);
}

dba_close($id);
?>

DBA is binary safe and does not have any arbitrary limits. However, it inherits all limits set by the underlying database implementation.

All file-based databases must provide a way of setting the file mode of a new created database, if that is possible at all. The file mode is commonly passed as the fourth argument to dba_open() or dba_popen().

You can access all entries of a database in a linear way by using the dba_firstkey() and dba_nextkey() functions. You may not change the database while traversing it.

Örnek 2 Traversing a database

<?php

// ...open database...

$key = dba_firstkey($id);

while ($key !== false) {
    if (true) {          // remember the key to perform some action later
        $handle_later[] = $key;
    }
    $key = dba_nextkey($id);
}

foreach ($handle_later as $val) {
    dba_delete($val, $id);
}

?>

Örnekler
DBA İşlevleri
Örnekler


DBA İşlevleri

İçindekiler

  • dba_close — Close a DBA database
  • dba_delete — Delete DBA entry specified by key
  • dba_exists — Check whether key exists
  • dba_fetch — Fetch data specified by key
  • dba_firstkey — Fetch first key
  • dba_handlers — List all the handlers available
  • dba_insert — Insert entry
  • dba_key_split — Splits a key in string representation into array representation
  • dba_list — List all open database files
  • dba_nextkey — Fetch next key
  • dba_open — Open database
  • dba_optimize — Optimize database
  • dba_popen — Open database persistently
  • dba_replace — Replace or insert entry
  • dba_sync — Synchronize database
Basic usage
dba_close
DBA


Close a DBA database

DBA İşlevleri
dba_delete
DBA İşlevleri
PHP Manual

dba_close

(PHP 4, PHP 5, PHP 7)

dba_close — Close a DBA database

Açıklama

void dba_close ( resource $handle )

dba_close() closes the established database and frees all resources of the specified database handle.

Değiştirgeler

handle

The database handler, returned by dba_open() or dba_popen().

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • dba_open() - Open database
  • dba_popen() - Open database persistently

DBA İşlevleri
dba_delete
DBA İşlevleri


Delete DBA entry specified by key

dba_close
dba_exists
DBA İşlevleri
PHP Manual

dba_delete

(PHP 4, PHP 5, PHP 7)

dba_delete — Delete DBA entry specified by key

Açıklama

bool dba_delete ( string $key , resource $handle )

dba_delete() deletes the specified entry from the database.

Değiştirgeler

key

The key of the entry which is deleted.

handle

The database handler, returned by dba_open() or dba_popen().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • dba_exists() - Check whether key exists
  • dba_fetch() - Fetch data specified by key
  • dba_insert() - Insert entry
  • dba_replace() - Replace or insert entry

dba_close
dba_exists
DBA İşlevleri


Check whether key exists

dba_delete
dba_fetch
DBA İşlevleri
PHP Manual

dba_exists

(PHP 4, PHP 5, PHP 7)

dba_exists — Check whether key exists

Açıklama

bool dba_exists ( string $key , resource $handle )

dba_exists() checks whether the specified key exists in the database.

Değiştirgeler

key

The key the check is performed for.

handle

The database handler, returned by dba_open() or dba_popen().

Dönen Değerler

Returns TRUE if the key exists, FALSE otherwise.

Ayrıca Bakınız

  • dba_delete() - Delete DBA entry specified by key
  • dba_fetch() - Fetch data specified by key
  • dba_insert() - Insert entry
  • dba_replace() - Replace or insert entry

dba_delete
dba_fetch
DBA İşlevleri


Fetch data specified by key

dba_exists
dba_firstkey
DBA İşlevleri
PHP Manual

dba_fetch

(PHP 4, PHP 5, PHP 7)

dba_fetch — Fetch data specified by key

Açıklama

string dba_fetch ( string $key , resource $handle )
string dba_fetch ( string $key , int $skip , resource $handle )

dba_fetch() fetches the data specified by key from the database specified with handle.

Değiştirgeler

key

The key the data is specified by.

Bilginize:

When working with inifiles this function accepts arrays as keys where index 0 is the group and index 1 is the value name. See: dba_key_split().

skip

The number of key-value pairs to ignore when using cdb databases. This value is ignored for all other databases which do not support multiple keys with the same name.

handle

The database handler, returned by dba_open() or dba_popen().

Dönen Değerler

Returns the associated string if the key/data pair is found, FALSE otherwise.

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.0 | The skip parameter is available to support cdb's capability of multiple keys having the same name.

Ayrıca Bakınız

  • dba_exists() - Check whether key exists
  • dba_delete() - Delete DBA entry specified by key
  • dba_insert() - Insert entry
  • dba_replace() - Replace or insert entry
  • dba_key_split() - Splits a key in string representation into array representation

dba_exists
dba_firstkey
DBA İşlevleri


Fetch first key

dba_fetch
dba_handlers
DBA İşlevleri
PHP Manual

dba_firstkey

(PHP 4, PHP 5, PHP 7)

dba_firstkey — Fetch first key

Açıklama

string dba_firstkey ( resource $handle )

dba_firstkey() returns the first key of the database and resets the internal key pointer. This permits a linear search through the whole database.

Değiştirgeler

handle

The database handler, returned by dba_open() or dba_popen().

Dönen Değerler

Returns the key on success başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • dba_nextkey() - Fetch next key
  • dba_key_split() - Splits a key in string representation into array representation
  • Example 2 in the DBA examples

dba_fetch
dba_handlers
DBA İşlevleri


List all the handlers available

dba_firstkey
dba_insert
DBA İşlevleri
PHP Manual

dba_handlers

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

dba_handlers — List all the handlers available

Açıklama

array dba_handlers ([ bool $full_info = false ] )

dba_handlers() list all the handlers supported by this extension.

Değiştirgeler

full_info

Turns on/off full information display in the result.

Dönen Değerler

Returns an array of database handlers. If full_info is set to TRUE, the array will be associative with the handlers names as keys, and their version information as value. Otherwise, the result will be an indexed array of handlers names.

Bilginize:

When the internal cdb library is used you will see cdb and cdb_make.

Örnekler

Örnek 1 dba_handlers() Example

<?php

echo "Available DBA handlers:\n";
foreach (dba_handlers(true) as $handler_name => $handler_version) {
  // clean the versions
  $handler_version = str_replace('$', '', $handler_version);
  echo " - $handler_name: $handler_version\n";
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Available DBA handlers:
 - cdb: 0.75, Revision: 1.3.2.3
 - cdb_make: 0.75, Revision: 1.2.2.4
 - db2: Sleepycat Software: Berkeley DB 2.7.7: (08/20/99)
 - inifile: 1.0, Revision: 1.6.2.3
 - flatfile: 1.0, Revision: 1.5.2.4

dba_firstkey
dba_insert
DBA İşlevleri


Insert entry

dba_handlers
dba_key_split
DBA İşlevleri
PHP Manual

dba_insert

(PHP 4, PHP 5, PHP 7)

dba_insert — Insert entry

Açıklama

bool dba_insert ( string $key , string $value , resource $handle )

dba_insert() inserts the entry described with key and value into the database.

Değiştirgeler

key

The key of the entry to be inserted. If this key already exist in the database, this function will fail. Use dba_replace() if you need to replace an existent key.

value

The value to be inserted.

handle

The database handler, returned by dba_open() or dba_popen().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • dba_exists() - Check whether key exists
  • dba_delete() - Delete DBA entry specified by key
  • dba_fetch() - Fetch data specified by key
  • dba_replace() - Replace or insert entry

dba_handlers
dba_key_split
DBA İşlevleri


Splits a key in string representation into array representation

dba_insert
dba_list
DBA İşlevleri
PHP Manual

dba_key_split

(PHP 5, PHP 7)

dba_key_split — Splits a key in string representation into array representation

Açıklama

mixed dba_key_split ( mixed $key )

dba_key_split() splits a key (string representation) into an array representation.

Değiştirgeler

key

The key in string representation.

Dönen Değerler

Returns an array of the form array(0 => group, 1 => value_name). This function will return FALSE if key is NULL or FALSE.

Ayrıca Bakınız

  • dba_firstkey() - Fetch first key
  • dba_nextkey() - Fetch next key
  • dba_fetch() - Fetch data specified by key

dba_insert
dba_list
DBA İşlevleri


List all open database files

dba_key_split
dba_nextkey
DBA İşlevleri
PHP Manual

dba_list

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

dba_list — List all open database files

Açıklama

array dba_list ( void )

dba_list() list all open database files.

Dönen Değerler

An associative array, in the form resourceid => filename.

dba_key_split
dba_nextkey
DBA İşlevleri


Fetch next key

dba_list
dba_open
DBA İşlevleri
PHP Manual

dba_nextkey

(PHP 4, PHP 5, PHP 7)

dba_nextkey — Fetch next key

Açıklama

string dba_nextkey ( resource $handle )

dba_nextkey() returns the next key of the database and advances the internal key pointer.

Değiştirgeler

handle

The database handler, returned by dba_open() or dba_popen().

Dönen Değerler

Returns the key on success başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • dba_firstkey() - Fetch first key
  • dba_key_split() - Splits a key in string representation into array representation
  • Example 2 in the DBA examples

dba_list
dba_open
DBA İşlevleri


Open database

dba_nextkey
dba_optimize
DBA İşlevleri
PHP Manual

dba_open

(PHP 4, PHP 5, PHP 7)

dba_open — Open database

Açıklama

resource dba_open ( string $path , string $mode [, string $handler [, mixed $... ]] )

dba_open() establishes a database instance for path with mode using handler.

Değiştirgeler

path

Commonly a regular path in your filesystem.

mode

It is r for read access, w for read/write access to an already existing database, c for read/write access and database creation if it doesn't currently exist, and n for create, truncate and read/write access. The database is created in BTree mode, other modes (like Hash or Queue) are not supported.

Additionally you can set the database lock method with the next char. Use l to lock the database with a .lck file or d to lock the databasefile itself. It is important that all of your applications do this consistently.

If you want to test the access and do not want to wait for the lock you can add t as third character. When you are absolutely sure that you do not require database locking you can do so by using - instead of l or d. When none of d, l or - is used, dba will lock on the database file as it would with d.

Bilginize:

There can only be one writer for one database file. When you use dba on a web server and more than one request requires write operations they can only be done one after another. Also read during write is not allowed. The dba extension uses locks to prevent this. See the following table:

DBA locking
already open | mode = "rl" | mode = "rlt" | mode = "wl" | mode = "wlt" | mode = "rd" | mode = "rdt" | mode = "wd" | mode = "wdt"
not open | ok | ok | ok | ok | ok | ok | ok | ok
mode = "rl" | ok | ok | wait | false | illegal | illegal | illegal | illegal
mode = "wl" | wait | false | wait | false | illegal | illegal | illegal | illegal
mode = "rd" | illegal | illegal | illegal | illegal | ok | ok | wait | false
mode = "wd" | illegal | illegal | illegal | illegal | wait | false | wait | false
  • ok: the second call will be successfull.
  • wait: the second call waits until dba_close() is called for the first.
  • false: the second call returns false.
  • illegal: you must not mix "l" and "d" modifiers for mode parameter.

handler

The name of the handler which shall be used for accessing path. It is passed all optional parameters given to dba_open() and can act on behalf of them.

Dönen Değerler

Returns a positive handle on success başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.0 | It's possible to open database files over network connection. However in cases a socket connection will be used (as with http or ftp) the connection will be locked instead of the resource itself. This is important to know since in such cases locking is simply ignored on the resource and other solutions have to be found.

Ayrıca Bakınız

  • dba_popen() - Open database persistently
  • dba_close() - Close a DBA database

dba_nextkey
dba_optimize
DBA İşlevleri


Optimize database

dba_open
dba_popen
DBA İşlevleri
PHP Manual

dba_optimize

(PHP 4, PHP 5, PHP 7)

dba_optimize — Optimize database

Açıklama

bool dba_optimize ( resource $handle )

dba_optimize() optimizes the underlying database.

Değiştirgeler

handle

The database handler, returned by dba_open() or dba_popen().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • dba_sync() - Synchronize database

dba_open
dba_popen
DBA İşlevleri


Open database persistently

dba_optimize
dba_replace
DBA İşlevleri
PHP Manual

dba_popen

(PHP 4, PHP 5, PHP 7)

dba_popen — Open database persistently

Açıklama

resource dba_popen ( string $path , string $mode [, string $handler [, mixed $... ]] )

dba_popen() establishes a persistent database instance for path with mode using handler.

Değiştirgeler

path

Commonly a regular path in your filesystem.

mode

It is r for read access, w for read/write access to an already existing database, c for read/write access and database creation if it doesn't currently exist, and n for create, truncate and read/write access.

handler

The name of the handler which shall be used for accessing path. It is passed all optional parameters given to dba_popen() and can act on behalf of them.

Dönen Değerler

Returns a positive handle on success başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • dba_open() - Open database
  • dba_close() - Close a DBA database

dba_optimize
dba_replace
DBA İşlevleri


Replace or insert entry

dba_popen
dba_sync
DBA İşlevleri
PHP Manual

dba_replace

(PHP 4, PHP 5, PHP 7)

dba_replace — Replace or insert entry

Açıklama

bool dba_replace ( string $key , string $value , resource $handle )

dba_replace() replaces or inserts the entry described with key and value into the database specified by handle.

Değiştirgeler

key

The key of the entry to be replaced.

value

The value to be replaced.

handle

The database handler, returned by dba_open() or dba_popen().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • dba_exists() - Check whether key exists
  • dba_delete() - Delete DBA entry specified by key
  • dba_fetch() - Fetch data specified by key
  • dba_insert() - Insert entry

dba_popen
dba_sync
DBA İşlevleri


Synchronize database

dba_replace
dbx
DBA İşlevleri
PHP Manual

dba_sync

(PHP 4, PHP 5, PHP 7)

dba_sync — Synchronize database

Açıklama

bool dba_sync ( resource $handle )

dba_sync() synchronizes the database. This will probably trigger a physical write to the disk, if supported.

Değiştirgeler

handle

The database handler, returned by dba_open() or dba_popen().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • dba_optimize() - Optimize database

dba_replace
dbx
DBA İşlevleri


dbx

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • dbx İşlevleri
    • dbx_close — Close an open connection/database
    • dbx_compare — Compare two rows for sorting purposes
    • dbx_connect — Open a connection/database
    • dbx_error — Report the error message of the latest function call in the module
    • dbx_escape_string — Escape a string so it can safely be used in an sql-statement
    • dbx_fetch_row — Fetches rows from a query-result that had the DBX_RESULT_UNBUFFERED flag set
    • dbx_query — Send a query and fetch all results (if any)
    • dbx_sort — Sort a result from a dbx_query by a custom sort function
dba_sync
Giriş
Soyutlama Katmanları


Giriş

The dbx module is a database abstraction layer (db 'X', where 'X' is a supported database). The dbx functions allow you to access all supported databases using a single calling convention. The dbx-functions themselves do not interface directly to the databases, but interface to the modules that are used to support these databases.

Bilginize:

Bu eklenti » PECL deposuna taşınmış olup şu sürümden itibaren PHP kaynak paketinde dağıtılmamaktatır: PHP 5.1.0.

dbx
Yapılandırma/Kurulum
dbx


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
dbx


Gereksinimler

To be able to use a database with the dbx-module, the module must be either linked or loaded into PHP, and the database module must be supported by the dbx-module. Currently, the following databases are supported, but others will follow:

  • FrontBase (available from PHP 4.1.0).
  • Microsoft SQL Server
  • MySQL
  • ODBC
  • PostgreSQL
  • Sybase-CT (available from PHP 4.2.0).
  • Oracle (oci8) (available from PHP 4.3.0).
  • SQLite (PHP 5).

Documentation for adding additional database support to dbx can be found at » http://www.guidance.nl/php/dbx/doc/.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

In order to have these functions available, you must compile PHP with dbx support by using the --enable-dbx option and all options for the databases that will be used, e.g. for MySQL you must also specify --with-mysql=[DIR] . To get other supported databases to work with the dbx-module refer to their specific documentation.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

DBX Configuration Options
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
dbx.colnames_case | "unchanged" | PHP_INI_SYSTEM | Available since PHP 4.3.0. Removed in PHP 5.1.0.
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

dbx.colnames_case string

Columns names can be returned "unchanged" or converted to "uppercase" or "lowercase". This directive can be overridden with a flag to dbx_query().

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Özkaynak Türleri

There are two resource types used in the dbx module. The first one is the link-object for a database connection, the second a result-object which holds the result of a query.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

DBX_MYSQL (integer)
DBX_ODBC (integer)
DBX_PGSQL (integer)
DBX_MSSQL (integer)
DBX_FBSQL (integer)
DBX_OCI8 (integer) (available from PHP 4.3.0)
DBX_SYBASECT (integer)
DBX_SQLITE (integer) (PHP 5)
DBX_PERSISTENT (integer)
DBX_RESULT_INFO (integer)
DBX_RESULT_INDEX (integer)
DBX_RESULT_ASSOC (integer)
DBX_RESULT_UNBUFFERED (integer) (PHP 5)
DBX_COLNAMES_UNCHANGED (integer) (available from PHP 4.3.0)
DBX_COLNAMES_UPPERCASE (integer) (available from PHP 4.3.0)
DBX_COLNAMES_LOWERCASE (integer) (available from PHP 4.3.0)
DBX_CMP_NATIVE (integer)
DBX_CMP_TEXT (integer)
DBX_CMP_NUMBER (integer)
DBX_CMP_ASC (integer)
DBX_CMP_DESC (integer)
Özkaynak Türleri
dbx İşlevleri
dbx


dbx İşlevleri

İçindekiler

  • dbx_close — Close an open connection/database
  • dbx_compare — Compare two rows for sorting purposes
  • dbx_connect — Open a connection/database
  • dbx_error — Report the error message of the latest function call in the module
  • dbx_escape_string — Escape a string so it can safely be used in an sql-statement
  • dbx_fetch_row — Fetches rows from a query-result that had the DBX_RESULT_UNBUFFERED flag set
  • dbx_query — Send a query and fetch all results (if any)
  • dbx_sort — Sort a result from a dbx_query by a custom sort function
Öntanımlı Sabitler
dbx_close
dbx


Close an open connection/database

dbx İşlevleri
dbx_compare
dbx İşlevleri
PHP Manual

dbx_close

(PHP 4 >= 4.0.6, PHP 5 <= 5.0.5, PECL dbx >= 1.1.0)

dbx_close — Close an open connection/database

Açıklama

int dbx_close ( object $link_identifier )

Değiştirgeler

link_identifier

The DBX link object to close.

Dönen Değerler

Returns 1 on success and 0 on errors.

Örnekler

Örnek 1 dbx_close() example

<?php
$link = dbx_connect(DBX_MYSQL, "localhost", "db", "username", "password")
    or die("Could not connect");

echo "Connected successfully";
dbx_close($link);
?>

Notlar

Bilginize:

Always refer to the module-specific documentation as well.

Ayrıca Bakınız

  • dbx_connect() - Open a connection/database

dbx İşlevleri
dbx_compare
dbx İşlevleri


Compare two rows for sorting purposes

dbx_close
dbx_connect
dbx İşlevleri
PHP Manual

dbx_compare

(PHP 4 >= 4.1.0, PHP 5 <= 5.0.5, PECL dbx >= 1.1.0)

dbx_compare — Compare two rows for sorting purposes

Açıklama

int dbx_compare ( array $row_a , array $row_b , string $column_key [, int $flags = DBX_CMP_ASC | DBX_CMP_NATIVE ] )

dbx_compare() is a helper function for dbx_sort() to ease the make and use of the custom sorting function.

Değiştirgeler

row_a

First row

row_b

Second row

column_key

The compared column

flags

The flags can be set to specify comparison direction:

  • DBX_CMP_ASC - ascending order
  • DBX_CMP_DESC - descending order
and the preferred comparison type:
  • DBX_CMP_NATIVE - no type conversion
  • DBX_CMP_TEXT - compare items as strings
  • DBX_CMP_NUMBER - compare items numerically
One of the direction and one of the type constant can be combined with bitwise OR operator (|).

Dönen Değerler

Returns 0 if the row_a[$column_key] is equal to row_b[$column_key], and 1 or -1 if the former is greater or is smaller than the latter one, respectively, or vice versa if the flag is set to DBX_CMP_DESC.

Örnekler

Örnek 1 dbx_compare() example

<?php
function user_re_order($a, $b)
{
    $rv = dbx_compare($a, $b, "parentid", DBX_CMP_DESC);
    if (!$rv) {
        $rv = dbx_compare($a, $b, "id", DBX_CMP_NUMBER);
    }
    return $rv;
}

$link   = dbx_connect(DBX_ODBC, "", "db", "username", "password")
    or die("Could not connect");

$result = dbx_query($link, "SELECT id, parentid, description FROM table ORDER BY id");
    // data in $result is now ordered by id

dbx_sort($result, "user_re_order");
    // date in $result is now ordered by parentid (descending), then by id

dbx_close($link);
?>

Ayrıca Bakınız

  • dbx_sort() - Sort a result from a dbx_query by a custom sort function

dbx_close
dbx_connect
dbx İşlevleri


Open a connection/database

dbx_compare
dbx_error
dbx İşlevleri
PHP Manual

dbx_connect

(PHP 4 >= 4.0.6, PHP 5 <= 5.0.5, PECL dbx >= 1.1.0)

dbx_connect — Open a connection/database

Açıklama

object dbx_connect ( mixed $module , string $host , string $database , string $username , string $password [, int $persistent ] )

Opens a connection to a database.

Değiştirgeler

module

The module parameter can be either a string or a constant, though the latter form is preferred. The possible values are given below, but keep in mind that they only work if the module is actually loaded.

  • DBX_MYSQL or "mysql"
  • DBX_ODBC or "odbc"
  • DBX_PGSQL or "pgsql"
  • DBX_MSSQL or "mssql"
  • DBX_FBSQL or "fbsql"
  • DBX_SYBASECT or "sybase_ct"
  • DBX_OCI8 or "oci8"
  • DBX_SQLITE or "sqlite"

host

The SQL server host

database

The database name

username

The username

password

The password

persistent

The persistent parameter can be set to DBX_PERSISTENT, if so, a persistent connection will be created.

The host, database, username and password parameters are expected, but not always used depending on the connect functions for the abstracted module.

Dönen Değerler

Returns an object on success, FALSE on error. If a connection has been made but the database could not be selected, the connection is closed and FALSE is returned.

The returned object has three properties:

database
It is the name of the currently selected database.
handle

It is a valid handle for the connected database, and as such it can be used in module-specific functions (if required).

<?php
$link = dbx_connect(DBX_MYSQL, "localhost", "db", "username", "password");
mysql_close($link->handle); // dbx_close($link) would be better here
?>

module
It is used internally by dbx only, and is actually the module number mentioned above.

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.0 | Introduced DBX_SQLITE.
4.3.0 | Introduced DBX_OCI8.
4.2.0 | Introduced DBX_SYBASECT.
4.1.0 | Introduced DBX_FBSQL.

Örnekler

Örnek 1 dbx_connect() example

<?php
$link = dbx_connect(DBX_ODBC, "", "db", "username", "password", DBX_PERSISTENT)
    or die("Could not connect");

echo "Connected successfully";
dbx_close($link);
?>

Notlar

Bilginize:

Always refer to the module-specific documentation as well.

Ayrıca Bakınız

  • dbx_close() - Close an open connection/database

dbx_compare
dbx_error
dbx İşlevleri


Report the error message of the latest function call in the module

dbx_connect
dbx_escape_string
dbx İşlevleri
PHP Manual

dbx_error

(PHP 4 >= 4.0.6, PHP 5 <= 5.0.5, PECL dbx >= 1.1.0)

dbx_error — Report the error message of the latest function call in the module

Açıklama

string dbx_error ( object $link_identifier )

dbx_error() returns the last error message.

Değiştirgeler

link_identifier

The DBX link object returned by dbx_connect()

Dönen Değerler

Returns a string containing the error message from the last function call of the abstracted module (e.g. mysql module). If there are multiple connections in the same module, just the last error is given. If there are connections on different modules, the latest error is returned for the module specified by the link_identifier parameter.

Örnekler

Örnek 1 dbx_error() example

<?php
$link   = dbx_connect(DBX_MYSQL, "localhost", "db", "username", "password")
    or die("Could not connect");

$result = dbx_query($link, "select id from non_existing_table");
if ($result == 0) {
    echo dbx_error($link);
}
dbx_close($link);
?>

Notlar

Bilginize:

Always refer to the module-specific documentation as well.

The error message for Microsoft SQL Server is actually the result of the mssql_get_last_message() function.

The error message for Oracle (oci8) is not implemented yet.

dbx_connect
dbx_escape_string
dbx İşlevleri


Escape a string so it can safely be used in an sql-statement

dbx_error
dbx_fetch_row
dbx İşlevleri
PHP Manual

dbx_escape_string

(PHP 4 >= 4.3.0, PHP 5 <= 5.0.5, PECL dbx >= 1.1.0)

dbx_escape_string — Escape a string so it can safely be used in an sql-statement

Açıklama

string dbx_escape_string ( object $link_identifier , string $text )

Escape the given string so that it can safely be used in an sql-statement.

Değiştirgeler

link_identifier

The DBX link object returned by dbx_connect()

text

The string to escape.

Dönen Değerler

Returns the text, escaped where necessary (such as quotes, backslashes etc). On error, NULL is returned.

Örnekler

Örnek 1 dbx_escape_string() example

<?php
$link   = dbx_connect(DBX_MYSQL, "localhost", "db", "username", "password")
    or die("Could not connect");

$text = dbx_escape_string($link, "It\'s quoted and backslashed (\\).");
$result = dbx_query($link, "insert into tbl (txt) values ('" . $text . "')");
if ($result == 0) {
    echo dbx_error($link);
}
dbx_close($link);
?>

Ayrıca Bakınız

  • dbx_query() - Send a query and fetch all results (if any)

dbx_error
dbx_fetch_row
dbx İşlevleri


Fetches rows from a query-result that had the DBX_RESULT_UNBUFFERED flag set

dbx_escape_string
dbx_query
dbx İşlevleri
PHP Manual

dbx_fetch_row

(PHP 5 <= 5.0.5, PECL dbx >= 1.1.0)

dbx_fetch_row — Fetches rows from a query-result that had the DBX_RESULT_UNBUFFERED flag set

Açıklama

mixed dbx_fetch_row ( object $result_identifier )

dbx_fetch_row() fetches rows from a result identifier that had the DBX_RESULT_UNBUFFERED flag set.

When the DBX_RESULT_UNBUFFERED is not set in the query, dbx_fetch_row() will fail as all rows have already been fetched into the results data property.

As a side effect, the rows property of the query-result object is incremented for each successful call to dbx_fetch_row().

Değiştirgeler

result_identifier

A result set returned by dbx_query().

Dönen Değerler

Returns an object on success that contains the same information as any row would have in the dbx_query() result data property, including columns accessible by index or fieldname when the flags for dbx_query() were set that way.

Upon failure, returns 0 (e.g. when no more rows are available).

Örnekler

Örnek 1 How to handle the returned value

<?php
$result = dbx_query($link, 'SELECT id, parentid, description FROM table', DBX_RESULT_UNBUFFERED);

echo "<table>\n";
while ($row = dbx_fetch_row($result)) {
    echo "<tr>\n";
    foreach ($row as $field) {
        echo "<td>$field</td>";
    }
    echo "</tr>\n";
}
echo "</table>\n";
?>

Ayrıca Bakınız

  • dbx_query() - Send a query and fetch all results (if any)

dbx_escape_string
dbx_query
dbx İşlevleri


Send a query and fetch all results (if any)

dbx_fetch_row
dbx_sort
dbx İşlevleri
PHP Manual

dbx_query

(PHP 4 >= 4.0.6, PHP 5 <= 5.0.5, PECL dbx >= 1.1.0)

dbx_query — Send a query and fetch all results (if any)

Açıklama

mixed dbx_query ( object $link_identifier , string $sql_statement [, int $flags ] )

Sends a query and fetch all results.

Değiştirgeler

link_identifier

The DBX link object returned by dbx_connect()

sql_statement

SQL statement.

Data inside the query should be properly escaped.

flags

The flags parameter is used to control the amount of information that is returned. It may be any combination of the following constants with the bitwise OR operator (|). The DBX_COLNAMES_* flags override the dbx.colnames_case setting from php.ini.

DBX_RESULT_INDEX
It is always set, that is, the returned object has a data property which is a 2 dimensional array indexed numerically. For example, in the expression data[2][3] 2 stands for the row (or record) number and 3 stands for the column (or field) number. The first row and column are indexed at 0. If DBX_RESULT_ASSOC is also specified, the returning object contains the information related to DBX_RESULT_INFO too, even if it was not specified.
DBX_RESULT_INFO
It provides info about columns, such as field names and field types.
DBX_RESULT_ASSOC
It effects that the field values can be accessed with the respective column names used as keys to the returned object's data property. Associated results are actually references to the numerically indexed data, so modifying data[0][0] causes that data[0]['field_name_for_first_column'] is modified as well.
DBX_RESULT_UNBUFFERED
This flag will not create the data property, and the rows property will initially be 0. Use this flag for large datasets, and use dbx_fetch_row() to retrieve the results row by row. The dbx_fetch_row() function will return rows that are conformant to the flags set with this query. Incidentally, it will also update the rows each time it is called.
DBX_COLNAMES_UNCHANGED
The case of the returned column names will not be changed.
DBX_COLNAMES_UPPERCASE
The case of the returned column names will be changed to uppercase.
DBX_COLNAMES_LOWERCASE
The case of the returned column names will be changed to lowercase.
Note that DBX_RESULT_INDEX is always used, regardless of the actual value of flags parameter. This means that only the following combinations are effective:
  • DBX_RESULT_INDEX
  • DBX_RESULT_INDEX | DBX_RESULT_INFO
  • DBX_RESULT_INDEX | DBX_RESULT_INFO | DBX_RESULT_ASSOC - this is the default, if flags is not specified.

Dönen Değerler

dbx_query() returns an object or 1 on success, and 0 on failure. The result object is returned only if the query given in sql_statement produces a result set (i.e. a SELECT query, even if the result set is empty).

The returned object has four or five properties depending on flags:

handle

It is a valid handle for the connected database, and as such it can be used in module specific functions (if required).

<?php
$result = dbx_query($link, "SELECT id FROM table");
mysql_field_len($result->handle, 0);
?>

cols and rows

These contain the number of columns (or fields) and rows (or records) respectively.

<?php
$result = dbx_query($link, 'SELECT id FROM table');
echo $result->rows; // number of records
echo $result->cols; // number of fields
?>

info (optional)
It is returned only if either DBX_RESULT_INFO or DBX_RESULT_ASSOC is specified in the flags parameter. It is a 2 dimensional array, that has two named rows (name and type) to retrieve column information.

Örnek 1 lists each field's name and type

<?php
$result = dbx_query($link, 'SELECT id FROM table',
                     DBX_RESULT_INDEX | DBX_RESULT_INFO);

for ($i = 0; $i < $result->cols; $i++ ) {
    echo $result->info['name'][$i] . "\n";
    echo $result->info['type'][$i] . "\n";
}
?>
data
This property contains the actual resulting data, possibly associated with column names as well depending on flags. If DBX_RESULT_ASSOC is set, it is possible to use $result->data[2]["field_name"].

Örnek 2 outputs the content of data property into HTML table

<?php
$result = dbx_query($link, 'SELECT id, parentid, description FROM table');

echo "<table>\n";
foreach ($result->data as $row) {
    echo "<tr>\n";
    foreach ($row as $field) {
        echo "<td>$field</td>";
    }
    echo "</tr>\n";
}
echo "</table>\n";
?>

Örnek 3 How to handle UNBUFFERED queries

<?php

$result = dbx_query ($link, 'SELECT id, parentid, description FROM table', DBX_RESULT_UNBUFFERED);

echo "<table>\n";
while ($row = dbx_fetch_row($result)) {
    echo "<tr>\n";
    foreach ($row as $field) {
        echo "<td>$field</td>";
    }
    echo "</tr>\n";
}
echo "</table>\n";

?>

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.0 | Introduced DBX_RESULT_UNBUFFERED.
4.3.0 | Introduced DBX_COLNAMES_UNCHANGED, DBX_COLNAMES_UPPERCASE, and DBX_COLNAMES_LOWERCASE.

Örnekler

Örnek 4 How to handle the returned value

<?php
$link   = dbx_connect(DBX_ODBC, "", "db", "username", "password")
    or die("Could not connect");

$result = dbx_query($link, 'SELECT id, parentid, description FROM table');

if (is_object($result) ) {
    // ... do some stuff here, see detailed examples below ...
    // first, print out field names and types
    // then, draw a table filled with the returned field values
} else {
    exit("Query failed");
}

dbx_close($link);
?>

Notlar

Bilginize:

Always refer to the module-specific documentation as well.

Column names for queries on an Oracle database are returned in lowercase.

Ayrıca Bakınız

  • dbx_escape_string() - Escape a string so it can safely be used in an sql-statement
  • dbx_fetch_row() - Fetches rows from a query-result that had the DBX_RESULT_UNBUFFERED flag set
  • dbx_connect() - Open a connection/database

dbx_fetch_row
dbx_sort
dbx İşlevleri


Sort a result from a dbx_query by a custom sort function

dbx_query
ODBC
dbx İşlevleri
PHP Manual

dbx_sort

(PHP 4 >= 4.0.6, PHP 5 <= 5.0.5, PECL dbx >= 1.1.0)

dbx_sort — Sort a result from a dbx_query by a custom sort function

Açıklama

bool dbx_sort ( object $result , string $user_compare_function )

Sort a result from a dbx_query() call with a custom sort function.

Değiştirgeler

result

A result set returned by dbx_query().

user_compare_function

The user-defined comparison function. It must accept two arguments and return an integer less than, equal to, or greater than zero if the first argument is considered to be respectively less than, equal to, or greater than the second.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 dbx_sort() example

<?php
function user_re_order($a, $b)
{
    $rv = dbx_compare($a, $b, "parentid", DBX_CMP_DESC);
    if (!$rv) {
        $rv = dbx_compare($a, $b, "id", DBX_CMP_NUMBER);
    }
    return $rv;
}

$link   = dbx_connect(DBX_ODBC, "", "db", "username", "password")
    or die("Could not connect");

$result = dbx_query($link, "SELECT id, parentid, description FROM tbl ORDER BY id");
    // data in $result is now ordered by id

dbx_sort($result, "user_re_order");
    // data in $result is now ordered by parentid (descending), then by id

dbx_close($link);
?>

Notlar

Bilginize:

It is always better to use ORDER BY SQL clause instead of dbx_sort() if possible.

Ayrıca Bakınız

  • dbx_compare() - Compare two rows for sorting purposes

dbx_query
ODBC
dbx İşlevleri


ODBC (Tekilleştirilmiş)

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • ODBC İşlevleri
    • odbc_autocommit — Özdevinimli teslimat davranışını açıp kapar
    • odbc_binmode — İkil sütun verileri ile çalışmayı etkin kılar
    • odbc_close_all — Tüm ODBC bağlantılarını kapatır
    • odbc_close — Bir ODBC bağlantısını kapatır
    • odbc_columnprivileges — Belirtilen tablo ile ilgili izinleri ve sütunları listeler
    • odbc_columns — Belirtilen tablolardaki sütun isimlerini listeler
    • odbc_commit — Bir ODBC hareket listesi gönderir
    • odbc_connect — Bir veri kaynağına bağlanır
    • odbc_cursor — İmleç ismini döndürür
    • odbc_data_source — Belirtilen bağlantı hakkında bilgi döndürür
    • odbc_do — odbc_exec işlevinin takma adıdır
    • odbc_error — Son hata kodunu döndürür
    • odbc_errormsg — Son hata iletisini döndürür
    • odbc_exec — Bir SQL deyimini hazırlar veya çalıştırır
    • odbc_execute — Bir hazır deyimi çalıştırır
    • odbc_fetch_array — Sonuç satırını bir ilişkisel dizi olarak döndürür
    • odbc_fetch_into — Sonuç satırını bir dizi olarak döndürür
    • odbc_fetch_object — Sonuç satırını bir nesne olarak döndürür
    • odbc_fetch_row — Bir satır döndürür
    • odbc_field_len — Bir alanın uzunluğunu (hassasiyetini) döndürür
    • odbc_alan_adı — Sütun ismini döndürür
    • odbc_field_num — Sütun numarasını döndürür
    • odbc_field_precision — odbc_field_len işlevinin takma adıdır
    • odbc_field_scale — Bir alanın skalasını döndürür
    • odbc_field_type — Bir alanın veri türünü döndürür
    • odbc_foreignkeys — Bir tablonun yabancı anahtarlarını listeler
    • odbc_free_result — Bir sonuç ile ilgili özkaynakları serbest bırakır
    • odbc_gettypeinfo — Veri kaynağınca desteklenen veri türleri hakkında bilgi döndürür
    • odbc_longreadlen — LONG sütunlarla çalışmayı etkin kılar
    • odbc_next_result — Kullanılabilecek çok sayıda sonuç var mı diye bakar
    • odbc_num_fields — Bir sonuçtaki sütun sayısını döndürür
    • odbc_num_rows — Bir sonuçtaki satır sayısını döndürür
    • odbc_pconnect — Bir kalıcı veritabanı bağlantısı açar
    • odbc_prepare — Çalıştırılmak üzere bir deyim hazırlar
    • odbc_primarykeys — Bir tablonun birincil anahtarlarını döndürür
    • odbc_procedurecolumns — Yordamların değiştirgeleri hakkında bilgi döndürür
    • odbc_procedures — Belirtilen veri kaynağında saklı yordamların listesini döndürür
    • odbc_result_all — Sonucu bir HTML tablosu olarak basar
    • odbc_result — Sonuçtan veri döndürür
    • odbc_rollback — Bir hareketi başa döndürür
    • odbc_setoption — ODBC ayarlarını yapar
    • odbc_specialcolumns — Özel sütunları döndürür
    • odbc_statistics — Bir tablo hakkındaki istatistikleri döndürür
    • odbc_tableprivileges — Tabloları izinleriyle birlikte listeler
    • odbc_tables — Belli bir veri kaynağında bulunan tablo isimlerini döndürür
dbx_sort
Giriş
Soyutlama Katmanları


Giriş

Normal ODBC desteğine ek olarak, PHP'nin çeşitli veritabanlarına erişimini mümkün kılmak için Tekilleştirilmiş ODBC desteği de sağlanmıştır. uODBC kendi programlama arayüzünü gerçeklemek için anlamsallığı ODBC programlama arayüzünden alır. Neredeyse birbirinin aynı bir sürü veritabanı sürücüsü yapmak yerine bu sürücüler tek bir ODBC işlevleri kümesiyle gerçeklenmiştir.

Tekilleştirilmiş ODBC işlevlerince desteklenen veritabanları: » Adabas D, » IBM DB2, » iODBC, » Solid, ve » Sybase SQL Anywhere.

Bilginize:

iODBC dışında, bu veritabanlarına bağlanırken başka ODBC gerekmez. Bunlarla çalışırken kullandığınız işlevler ODBC işlevleriyle aynı isimleri ve sözdizimini paylaşırlar. Bununla birlikte, PHP'yi iODBC desteğiyle derleyerek PHP uygulamalarınızda ODBC uyumlu sürücüleri de kullanabilirsiniz. iODBC hakkında ayrıntılı bilgi için » http://www.iodbc.org/ adresine unixODBC için ise » http://www.iodbc.org/ adresine bakınız.

ODBC
Yapılandırma/Kurulum
ODBC


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
ODBC


Gereksinimler

Desteklenen veritabanlarına erişmek için gerekli kütüphanelerin sisteminizde kurulu olması gerekir.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Derleme seçenekleri:

--with-adabas[=DiZiN]

PHP, Adabas D desteğiyle derlenir. DiZiN, Adabas ana kurulum dizini olup, /usr/local öntanımlıdır.

--with-sapdb[=DiZiN]

PHP, SAP DB desteğiyle derlenir. DiZiN, SAP DB ana kurulum dizini olup, /usr/local öntanımlıdır.

--with-solid[=DiZiN]

PHP, Solid desteğiyle derlenir. DiZiN, Solid ana kurulum dizini olup, /usr/local/solid öntanımlıdır.

--with-ibm-db2[=DiZiN]

PHP, IBM DB2 desteğiyle derlenir. DiZiN, DB2 ana kurulum dizini olup, /home/db2inst1/sqllib öntanımlıdır.

--with-empress[=DiZiN]

PHP, Empress desteğiyle derlenir. DiZiN, Empress ana kurulum dizini olup, $EMPRESSPATH öntanımlıdır. PHP 4'ten itibaren, bu seçenek Empress 8.60 ve üstünü gerektirmektedir.

--with-empress-bcs[=DiZiN]

PHP, "Empress Local Access" desteğiyle derlenir. DiZiN, Empress ana kurulum dizini olup, $EMPRESSPATH öntanımlıdır. PHP 4'ten itibaren, bu seçenek Empress 8.60 ve üstünü gerektirmektedir.

--with-birdstep[=DiZiN]

PHP, Birdstep desteğiyle derlenir. DiZiN, Birdstep ana kurulum dizini olup, /usr/local/birdstep öntanımlıdır.

--with-custom-odbc[=DiZiN]

PHP, kullanıcı tanımlı ODBC desteğiyle derlenir. DiZiN, ODBC ana kurulum dizini olup, /usr/local öntanımlıdır. CUSTOM_ODBC_LIBS ortam değişkenini tanımlamayı ve odbc.h dosyasını include dizinizde bulundurmayı unutmayın. Örneğin, QNX üzerinde Sybase SQL Anywhere 5.5.00 için configure betiğini çalıştırmadan önce şu tanımları yapmalısınız:

   CPPFLAGS="-DODBC_QNX -DSQLANY_BUG"
   LDFLAGS=-lunix
   CUSTOM_ODBC_LIBS="-ldblib -lodbc".

--with-iodbc[=DiZiN]

PHP, iODBC desteğiyle derlenir. DiZiN, iODBC ana kurulum dizini olup, /usr/local öntanımlıdır.

--with-esoob[=DiZiN]

PHP, Easysoft desteğiyle derlenir. DiZiN, OOB ana kurulum dizini olup, /usr/local/easysoft/oob/client öntanımlıdır.

--with-unixODBC[=DiZiN]

PHP, unixODBC desteğiyle derlenir. DiZiN, unixODBC ana kurulum dizini olup, /usr/local öntanımlıdır.

--with-openlink[=DiZiN]

PHP, OpenLink ODBC desteğiyle derlenir. DiZiN, OpenLink ana kurulum dizini olup, /usr/local öntanımlıdır. Bu, iODBC için de böyledir.

--with-dbmaker[=DiZiN]

PHP, DBMaker desteğiyle derlenir. DiZiN, DBMaker ana kurulum dizini olup, DBMaker'ın son kurulu olduğu yer öntanımlıdır (örneğin, /home/dbmaker/3.6).

PHP'nin Windows sürümünde bu eklenti yerleşik olarak gelmektedir. Bu işlevleri Windows'ta kullanmak için herhangi bir eklenti kurmanıza gerek yoktur.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Tekilleştirilmiş ODBC Yapılandırma Yönergeleri
İsim | Öntanımlı Değeri | Değişiklik Yeri | Sürüm Bilgisi
odbc.default_db * | NULL | PHP_INI_ALL |
odbc.default_user * | NULL | PHP_INI_ALL |
odbc.default_pw * | NULL | PHP_INI_ALL |
odbc.allow_persistent | "1" | PHP_INI_SYSTEM |
odbc.check_persistent | "1" | PHP_INI_SYSTEM |
odbc.max_persistent | "-1" | PHP_INI_SYSTEM |
odbc.max_links | "-1" | PHP_INI_SYSTEM |
odbc.defaultlrl | "4096" | PHP_INI_ALL |
odbc.defaultbinmode | "1" | PHP_INI_ALL |
odbc.default_cursortype | "3" | PHP_INI_ALL | PHP 5.3.0'dan beri kullanılabilmektedir.

Bilginize: * ile imlenmiş girdiler henüz gerçeklenmemiştir.

PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

odbc.default_db string

odbc_connect() veya odbc_pconnect() işlevinde belirtilmediği takdirde kullanılacak ODBC veri kaynağı.

odbc.default_user string

odbc_connect() veya odbc_pconnect() işlevinde belirtilmediği takdirde kullanılacak kullanıcı ismi.

odbc.default_pw string

odbc_connect() veya odbc_pconnect() işlevinde belirtilmediği takdirde kullanılacak parola.

odbc.allow_persistent boolean

Kalıcı ODBC bağlantılarına izin verilecekse: On.

odbc.check_persistent boolean

Tekrar kullanmadan önce bağlantı geçerli mi diye bakılacaksa: On

odbc.max_persistent integer

Süreç başına azami kalıcı ODBC bağlantı sayısı.

odbc.max_links integer

Kalıcı bağlantılar dahil, süreç başına azami ODBC bağlantı sayısı.

odbc.defaultlrl integer

LONG alanlar için değişkende döndürülen bayt sayısı.

integer türünde bir değer kullanıldığında değer baytların sayısıdır. Büyük bayt değerleri için kullanılabilecek birimlerin gösterimleri hakkında bilgiyi bu SSS altında bulabilirsiniz.
odbc.defaultbinmode integer

İkil verilerin ele alınış tarzı.

odbc.default_cursortype integer

ODBC imleç türü. Olası değerler: SQL_CURSOR_FORWARD_ONLY, SQL_CURSOR_KEYSET_DRIVEN, SQL_CURSOR_DYNAMIC ve SQL_CURSOR_STATIC (öntanımlı).

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Özkaynak Türleri

Bu eklenti iki özkaynak türü tanımlar: ODBC bağlantı tanıtıcısı ve ODBC sonuç tanıtıcısı.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

ODBC_TYPE (integer)
ODBC_BINMODE_PASSTHRU (integer)
ODBC_BINMODE_RETURN (integer)
ODBC_BINMODE_CONVERT (integer)
SQL_ODBC_CURSORS (integer)
SQL_CUR_USE_DRIVER (integer)
SQL_CUR_USE_IF_NEEDED (integer)
SQL_CUR_USE_ODBC (integer)
SQL_CONCURRENCY (integer)
SQL_CONCUR_READ_ONLY (integer)
SQL_CONCUR_LOCK (integer)
SQL_CONCUR_ROWVER (integer)
SQL_CONCUR_VALUES (integer)
SQL_CURSOR_TYPE (integer)
SQL_CURSOR_FORWARD_ONLY (integer)
SQL_CURSOR_KEYSET_DRIVEN (integer)
SQL_CURSOR_DYNAMIC (integer)
SQL_CURSOR_STATIC (integer)
SQL_KEYSET_SIZE (integer)
SQL_CHAR (integer)
SQL_VARCHAR (integer)
SQL_LONGVARCHAR (integer)
SQL_DECIMAL (integer)
SQL_NUMERIC (integer)
SQL_BIT (integer)
SQL_TINYINT (integer)
SQL_SMALLINT (integer)
SQL_INTEGER (integer)
SQL_BIGINT (integer)
SQL_REAL (integer)
SQL_FLOAT (integer)
SQL_DOUBLE (integer)
SQL_BINARY (integer)
SQL_VARBINARY (integer)
SQL_LONGVARBINARY (integer)
SQL_DATE (integer)
SQL_TIME (integer)
SQL_TIMESTAMP (integer)
SQL_TYPE_DATE (integer)
SQL_TYPE_TIME (integer)
SQL_TYPE_TIMESTAMP (integer)
SQL_BEST_ROWID (integer)
SQL_ROWVER (integer)
SQL_SCOPE_CURROW (integer)
SQL_SCOPE_TRANSACTION (integer)
SQL_SCOPE_SESSION (integer)
SQL_NO_NULLS (integer)
SQL_NULLABLE (integer)
SQL_INDEX_UNIQUE (integer)
SQL_INDEX_ALL (integer)
SQL_ENSURE (integer)
SQL_QUICK (integer)
Özkaynak Türleri
ODBC İşlevleri
ODBC


ODBC İşlevleri

İçindekiler

  • odbc_autocommit — Özdevinimli teslimat davranışını açıp kapar
  • odbc_binmode — İkil sütun verileri ile çalışmayı etkin kılar
  • odbc_close_all — Tüm ODBC bağlantılarını kapatır
  • odbc_close — Bir ODBC bağlantısını kapatır
  • odbc_columnprivileges — Belirtilen tablo ile ilgili izinleri ve sütunları listeler
  • odbc_columns — Belirtilen tablolardaki sütun isimlerini listeler
  • odbc_commit — Bir ODBC hareket listesi gönderir
  • odbc_connect — Bir veri kaynağına bağlanır
  • odbc_cursor — İmleç ismini döndürür
  • odbc_data_source — Belirtilen bağlantı hakkında bilgi döndürür
  • odbc_do — odbc_exec işlevinin takma adıdır
  • odbc_error — Son hata kodunu döndürür
  • odbc_errormsg — Son hata iletisini döndürür
  • odbc_exec — Bir SQL deyimini hazırlar veya çalıştırır
  • odbc_execute — Bir hazır deyimi çalıştırır
  • odbc_fetch_array — Sonuç satırını bir ilişkisel dizi olarak döndürür
  • odbc_fetch_into — Sonuç satırını bir dizi olarak döndürür
  • odbc_fetch_object — Sonuç satırını bir nesne olarak döndürür
  • odbc_fetch_row — Bir satır döndürür
  • odbc_field_len — Bir alanın uzunluğunu (hassasiyetini) döndürür
  • odbc_alan_adı — Sütun ismini döndürür
  • odbc_field_num — Sütun numarasını döndürür
  • odbc_field_precision — odbc_field_len işlevinin takma adıdır
  • odbc_field_scale — Bir alanın skalasını döndürür
  • odbc_field_type — Bir alanın veri türünü döndürür
  • odbc_foreignkeys — Bir tablonun yabancı anahtarlarını listeler
  • odbc_free_result — Bir sonuç ile ilgili özkaynakları serbest bırakır
  • odbc_gettypeinfo — Veri kaynağınca desteklenen veri türleri hakkında bilgi döndürür
  • odbc_longreadlen — LONG sütunlarla çalışmayı etkin kılar
  • odbc_next_result — Kullanılabilecek çok sayıda sonuç var mı diye bakar
  • odbc_num_fields — Bir sonuçtaki sütun sayısını döndürür
  • odbc_num_rows — Bir sonuçtaki satır sayısını döndürür
  • odbc_pconnect — Bir kalıcı veritabanı bağlantısı açar
  • odbc_prepare — Çalıştırılmak üzere bir deyim hazırlar
  • odbc_primarykeys — Bir tablonun birincil anahtarlarını döndürür
  • odbc_procedurecolumns — Yordamların değiştirgeleri hakkında bilgi döndürür
  • odbc_procedures — Belirtilen veri kaynağında saklı yordamların listesini döndürür
  • odbc_result_all — Sonucu bir HTML tablosu olarak basar
  • odbc_result — Sonuçtan veri döndürür
  • odbc_rollback — Bir hareketi başa döndürür
  • odbc_setoption — ODBC ayarlarını yapar
  • odbc_specialcolumns — Özel sütunları döndürür
  • odbc_statistics — Bir tablo hakkındaki istatistikleri döndürür
  • odbc_tableprivileges — Tabloları izinleriyle birlikte listeler
  • odbc_tables — Belli bir veri kaynağında bulunan tablo isimlerini döndürür
Öntanımlı Sabitler
odbc_autocommit
ODBC


Özdevinimli teslimat davranışını açıp kapar

ODBC İşlevleri
odbc_binmode
ODBC İşlevleri
PHP Manual

odbc_autocommit

(PHP 4, PHP 5, PHP 7)

odbc_autocommit — Özdevinimli teslimat davranışını açıp kapar

Açıklama

mixed odbc_autocommit ( resource $bağlantı_kimliği [, bool $AçKapa = false ] )

Özdevinimli teslimat davranışını açıp kapar

Bir bağlantı üzerinde öntanımlı olarak özdevinimli teslimat etkindir. İptal edilmesi bir hareket (transaction) başlatmaya eşdeğerdir.

Değiştirgeler

bağlantı_kimliği

ODBC bağlantı tanıtıcısı; ayrıntılar için odbc_connect() işlevine bakınız.

AçKapa

AçKapa TRUE ise özdevinimli teslimat etkin olur, FALSE ise iptal edilir.

Dönen Değerler

AçKapa değiştirgesi olmaksızın işlev, bağlantı ile ilgili durumu döndürür. Özdevinimli teslimat davranışı etkin değilse veya bir hata oluşmuşsa FALSE yoksa 0 döner.

AçKapa belirtilirse işlev başarı durumunda TRUE, yoksa FALSE döndürür.

Ayrıca Bakınız

  • odbc_commit() - Bir ODBC hareket listesi gönderir
  • odbc_rollback() - Bir hareketi başa döndürür

ODBC İşlevleri
odbc_binmode
ODBC İşlevleri


İkil sütun verileri ile çalışmayı etkin kılar

odbc_autocommit
odbc_close_all
ODBC İşlevleri
PHP Manual

odbc_binmode

(PHP 4, PHP 5, PHP 7)

odbc_binmode — İkil sütun verileri ile çalışmayı etkin kılar

Açıklama

bool odbc_binmode ( resource $sonuç_kimliği , int $kip )

İkil sütun verileri ile çalışmayı etkin kılar. Etkilenen ODBC SQL türleri: BINARY, VARBINARY ve LONGVARBINARY.

İkil SQL veri, karakter C verisine dönüştürüldüğünde kaynak verisinin her baytı (8 biti) iki ASCII karakteri ile temsil edilir. Bu karakterler sayının onaltılık tabandaki ASCII karakter gösterimidir. Örneğin, 00000001 sayısı "01" dizgesine dönüştürülürken 11111111 sayısı, "FF" dizgesine dönüştürülür.

LONGVARBINARY işlemi
odbc_binmode() | odbc_longreadlen() | sonuç
ODBC_BINMODE_PASSTHRU | 0 | düzgeçer
ODBC_BINMODE_RETURN | 0 | düzgeçer
ODBC_BINMODE_CONVERT | 0 | düzgeçer
ODBC_BINMODE_PASSTHRU | 0 | düzgeçer
ODBC_BINMODE_PASSTHRU | >0 | düzgeçer
ODBC_BINMODE_RETURN | >0 | olduğu gibi döner
ODBC_BINMODE_CONVERT | >0 | karakter olarak döner

odbc_fetch_into() kullanıldığında, düzgeçer, bu sütunlar için bir boş dizge döneceği anlamına gelir.

Değiştirgeler

sonuç_kimliği

Sonuç kimliği.

sonuç_kimliği 0 ise ayarlar öntanımlı olarak yeni sonuçlara uygulanır.

Bilginize: Öntanımlı değerler kip için ODBC_BINMODE_RETURN, longreadlen için 4096'dır. LONGVARBINARY sütunlarla ilgili işlemler ayrıca odbc_longreadlen() işlevinden de etkilenir.

kip

Olası kip değerleri:

  • ODBC_BINMODE_PASSTHRU: İkil veri düzgeçer.
  • ODBC_BINMODE_RETURN: Olduğu gibi döner.
  • ODBC_BINMODE_CONVERT: Karaktere dönüştürülüp döndürülür.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

odbc_autocommit
odbc_close_all
ODBC İşlevleri


Tüm ODBC bağlantılarını kapatır

odbc_binmode
odbc_close
ODBC İşlevleri
PHP Manual

odbc_close_all

(PHP 4, PHP 5, PHP 7)

odbc_close_all — Tüm ODBC bağlantılarını kapatır

Açıklama

void odbc_close_all ( void )

odbc_close_all() işlevi tüm veritabanı sunucularıyla kurulmuş bağlantıları sonlandırır.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Notlar

Bilginize:

Bir bağlantıda henüz tamamlanmamış bir hareket kalmışsa işlev başarısız olur. Böyle bir durumda o bağlantı açık kalır.

odbc_binmode
odbc_close
ODBC İşlevleri


Bir ODBC bağlantısını kapatır

odbc_close_all
odbc_columnprivileges
ODBC İşlevleri
PHP Manual

odbc_close

(PHP 4, PHP 5, PHP 7)

odbc_close — Bir ODBC bağlantısını kapatır

Açıklama

void odbc_close ( resource $bağlantı_kimliği )

Veritabanı sunucusuyla bağlantıyı sonlandırır.

Değiştirgeler

bağlantı_kimliği

ODBC bağlantı tanıtıcısı; ayrıntılar için odbc_connect() işlevine bakınız.

Dönen Değerler

Hiçbir değer dönmez.

Notlar

Bilginize:

Bağlantıda henüz tamamlanmamış bir hareket kalmışsa işlev başarısız olur. Böyle bir durumda bağlantı açık kalır.

odbc_close_all
odbc_columnprivileges
ODBC İşlevleri


Belirtilen tablo ile ilgili izinleri ve sütunları listeler

odbc_close
odbc_columns
ODBC İşlevleri
PHP Manual

odbc_columnprivileges

(PHP 4, PHP 5, PHP 7)

odbc_columnprivileges — Belirtilen tablo ile ilgili izinleri ve sütunları listeler

Açıklama

resource odbc_columnprivileges ( resource $bağlantı_kimliği , string $niteleyici , string $sahibi , string $tablo_ismi , string $sütun_ismi )

Belirtilen tablo ile ilgili izinleri ve sütunları listeler.

Değiştirgeler

bağlantı_kimliği

ODBC bağlantı tanıtıcısı; ayrıntılar için odbc_connect() işlevine bakınız.

niteleyici

Niteleyici.

sahibi

Sahibi.

tablo_ismi

Tablo ismi.

sütun_ismi

sütun_ismi değiştirgesinde arama şablonları belirtilebilir (sıfır veya daha fazla karakterle eşleşmek üzere '%' ve tek bir karakterle eşleşmek üzere '_').

sahibi, tablo_ismi ve sütun_ismi değiştirgesinde arama şablonları belirtilebilir (sıfır veya daha fazla karakterle eşleşmek üzere '%' ve tek bir karakterle eşleşmek üzere '_').

Dönen Değerler

Başarısızlık durumunda FALSE, yoksa bir ODBC sonuç tanıtıcısı döner. Bu sonuç tanıtıcısı ilgili izinlerin ve sütun listelerinin döndürülmesi için kullanılabilir.

Sonuç kümesi şu sütunlardan oluşur:

  • TABLE_QUALIFIER
  • TABLE_OWNER
  • TABLE_NAME
  • GRANTOR
  • GRANTEE
  • PRIVILEGE
  • IS_GRANTABLE

Sonuç kümesi TABLE_QUALIFIER, TABLE_OWNER ve TABLE_NAME sütunlarına göre sıralıdır.

odbc_close
odbc_columns
ODBC İşlevleri


Belirtilen tablolardaki sütun isimlerini listeler

odbc_columnprivileges
odbc_commit
ODBC İşlevleri
PHP Manual

odbc_columns

(PHP 4, PHP 5, PHP 7)

odbc_columns — Belirtilen tablolardaki sütun isimlerini listeler

Açıklama

resource odbc_columns ( resource $bağlantı_kimliği [, string $niteleyici [, string $şema [, string $tablo_ismi [, string $sütun_ismi ]]]] )

Belirtilen aralıktaki tüm sütunları listeler.

Değiştirgeler

bağlantı_kimliği

ODBC bağlantı tanıtıcısı; ayrıntılar için odbc_connect() işlevine bakınız.

niteleyici

Niteleyici.

şema

Sahibi.

tablo_ismi

Tablo ismi

sütun_ismi

Sütun ismi.

şema, tablo_ismi ve sütun_ismi olarak arama şablonları belirtilebilir (sıfır veya daha fazla karakterle eşleşmek üzere '%' ve tek bir karakterle eşleşmek üzere '_').

Dönen Değerler

Başarısızlık durumunda FALSE, yoksa bir ODBC sonuç tanıtıcısı döner.

Sonuç kümesi şu sütunlara sahiptir:

  • TABLE_QUALIFIER
  • TABLE_SCHEM
  • TABLE_NAME
  • COLUMN_NAME
  • DATA_TYPE
  • TYPE_NAME
  • PRECISION
  • LENGTH
  • SCALE
  • RADIX
  • NULLABLE
  • REMARKS

Sonuç, TABLE_QUALIFIER, TABLE_SCHEM ve TABLE_NAME sütunlarına göre sıralanır.

Ayrıca Bakınız

  • odbc_columnprivileges() - Belirtilen tablo ile ilgili izinleri ve sütunları listeler

odbc_columnprivileges
odbc_commit
ODBC İşlevleri


Bir ODBC hareket listesi gönderir

odbc_columns
odbc_connect
ODBC İşlevleri
PHP Manual

odbc_commit

(PHP 4, PHP 5, PHP 7)

odbc_commit — Bir ODBC hareket listesi gönderir

Açıklama

bool odbc_commit ( resource $bağlantı_kimliği )

Bağlantıda bekleyen tüm hareketleri işleme sokar.

Değiştirgeler

bağlantı_kimliği

ODBC bağlantı tanıtıcısı; ayrıntılar için odbc_connect() işlevine bakınız.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

odbc_columns
odbc_connect
ODBC İşlevleri


Bir veri kaynağına bağlanır

odbc_commit
odbc_cursor
ODBC İşlevleri
PHP Manual

odbc_connect

(PHP 4, PHP 5, PHP 7)

odbc_connect — Bir veri kaynağına bağlanır

Açıklama

resource odbc_connect ( string $dsn , string $kullanıcı , string $parola [, int $imleç_türü ] )

Diğer ODBC işlevleri tarafından kullanılmak üzere bir bağlantı tanıtıcısı döndürür. Farklı kullanıcı ve parola veya farklı veritabanları belirterek aynı anda birden fazla veri kaynağına bağlı olabilirsiniz.

Bazı ODBC sürücülerinde, karmaşık bir saklanmış yordamın çalıştırılması şuna benzer bir hata üretebilir: "Cannot open a cursor on a stored procedure that has anything other than a single select statement in it" (Türkçesi: tek bir seçim deyiminden fazlası için saklanmış yordam veya imleç açılamaz). SQL_CUR_USE_ODBC kullanarak bu hatadan kurtulabilirsiniz. Ayrıca bazı sürücüler, odbc_fetch_row() işlevindeki satırnum değiştirgesini de desteklemezler. Böyle bir durumda SQL_CUR_USE_ODBC sabitinin yardımı olabilir.

Değiştirgeler

dsn

Bağlanılacak veritabanı kaynağının ismi. Bir DNS'siz bağlantı dizgesi de belirtilebilir.

kullanıcı

Kullanıcı ismi.

parola

Parola.

imleç_türü

Bağlantı için kullanılacak imleç türü. Normalde bu değiştirgeye gerek yoktur, fakat bazı ODBC sürücüleriyle ilgili sorunlardan kurtulmak için yararlı olabilir.

İmleç türü olarak belirtilebilecek sabitler:

  • SQL_CUR_USE_IF_NEEDED
  • SQL_CUR_USE_ODBC
  • SQL_CUR_USE_DRIVER

Dönen Değerler

Bir hata varsa 0 (FALSE), yoksa bir bağlantı tanıtıcısı döner.

Örnekler

Örnek 1 DNS'siz bağlantı

<?php
// SQL Native Client 10.0 ODBC Sürücüsü kullanan Microsoft SQL Sunucusu
// SQL 7, 2000, 2005 ve 2008'e bağlantıya izin verir.
$connection = odbc_connect(
  "Driver={SQL Server Native Client 10.0};Server=$server;Database=$database;",
  $user, $password);

// Microsoft Access
$connection = odbc_connect(
    "Driver={Microsoft Access Driver (*.mdb)};Dbq=$mdbFilename",
    $user, $password);

// Microsoft Excel
$excelFile = realpath('C:/ExcelData.xls');
$excelDir = dirname($excelFile);
$connection = odbc_connect("Driver={Microsoft Excel Driver (*.xls)};
      DriverId=790;Dbq=$excelFile;DefaultDir=$excelDir" , '', '');
?>

Ayrıca Bakınız

  • odbc_pconnect() - Bir kalıcı veritabanı bağlantısı açar

odbc_commit
odbc_cursor
ODBC İşlevleri


İmleç ismini döndürür

odbc_connect
odbc_data_source
ODBC İşlevleri
PHP Manual

odbc_cursor

(PHP 4, PHP 5, PHP 7)

odbc_cursor — İmleç ismini döndürür

Açıklama

string odbc_cursor ( resource $sonuç_kimliği )

Belirtilen sonuç kimliği ile ilgili imleç ismini döndürür.

Değiştirgeler

sonuç_kimliği

Sonuç tanıtıcısı.

Dönen Değerler

İmleç ismini bir dizge olarak döndürür.

odbc_connect
odbc_data_source
ODBC İşlevleri


Belirtilen bağlantı hakkında bilgi döndürür

odbc_cursor
odbc_do
ODBC İşlevleri
PHP Manual

odbc_data_source

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

odbc_data_source — Belirtilen bağlantı hakkında bilgi döndürür

Açıklama

array odbc_data_source ( resource $bağlantı_kimliği , int $alım_türü )

(Defalarca çağırdıktan sonra) Kullanılabilir DSN'lerin listesini döndürür.

Değiştirgeler

bağlantı_kimliği

ODBC bağlantı tanıtıcısı; ayrıntılar için odbc_connect() işlevine bakınız.

alım_türü

Şu iki sabitten biri olabilir: SQL_FETCH_FIRST ve SQL_FETCH_NEXT. İşlevi ilk çağırışınızda SQL_FETCH_FIRST, sonrakilerde SQL_FETCH_NEXT sabitini kullanın.

Dönen Değerler

Bir hata oluşmuşsa FALSE yoksa bir dizi döner.

odbc_cursor
odbc_do
ODBC İşlevleri


odbc_exec işlevinin takma adıdır

odbc_data_source
odbc_error
ODBC İşlevleri
PHP Manual

odbc_do

(PHP 4, PHP 5, PHP 7)

odbc_do — odbc_exec() işlevinin takma adıdır

Açıklama

Bu işlev, odbc_exec() işlevinin takma adıdır.

odbc_data_source
odbc_error
ODBC İşlevleri


Son hata kodunu döndürür

odbc_do
odbc_errormsg
ODBC İşlevleri
PHP Manual

odbc_error

(PHP 4 >= 4.0.5, PHP 5, PHP 7)

odbc_error — Son hata kodunu döndürür

Açıklama

string odbc_error ([ resource $bağlantı_kimliği ] )

Hata oluşmuşsa altı haneli bir ODBC durum kodu yoksa boş bir dizge döner.

Değiştirgeler

bağlantı_kimliği

ODBC bağlantı tanıtıcısı; ayrıntılar için odbc_connect() işlevine bakınız.

Dönen Değerler

bağlantı_kimliği belirtilmişse bağlantının son durumu, yoksa herhangi bir bağlantının son durumu döner.

Bu işlev sadece son ODBC sorgusu başarısız olmuşsa anlamlı bir değer döndürür (odbc_exec() işlevinin FALSE döndürmesi gibi).

Ayrıca Bakınız

  • odbc_errormsg() - Son hata iletisini döndürür
  • odbc_exec() - Bir SQL deyimini hazırlar veya çalıştırır

odbc_do
odbc_errormsg
ODBC İşlevleri


Son hata iletisini döndürür

odbc_error
odbc_exec
ODBC İşlevleri
PHP Manual

odbc_errormsg

(PHP 4 >= 4.0.5, PHP 5, PHP 7)

odbc_errormsg — Son hata iletisini döndürür

Açıklama

string odbc_errormsg ([ resource $bağlantı_kimliği ] )

Son ODBC hata iletisini içeren bir dizge veya hata oluşmamışsa boş bir dizge döner.

Değiştirgeler

bağlantı_kimliği

ODBC bağlantı tanıtıcısı; ayrıntılar için odbc_connect() işlevine bakınız.

Dönen Değerler

Bir bağlantı_kimliği belirtilmişse bu bağlantının son durumu ile aksi takdirde herhangi bir bağlantının son durumu ile ilgili bir hata iletisi dizgesi döner.

Bu işlevin döndürdüğü dizge sadece son ODBC sorgusu başarısız olmuşsa anlamlıdır (odbc_exec() işlevinin FALSE döndürmesi gibi).

Ayrıca Bakınız

  • odbc_error() - Son hata kodunu döndürür
  • odbc_exec() - Bir SQL deyimini hazırlar veya çalıştırır

odbc_error
odbc_exec
ODBC İşlevleri


Bir SQL deyimini hazırlar veya çalıştırır

odbc_errormsg
odbc_execute
ODBC İşlevleri
PHP Manual

odbc_exec

(PHP 4, PHP 5, PHP 7)

odbc_exec — Bir SQL deyimini hazırlar veya çalıştırır

Açıklama

resource odbc_exec ( resource $bağlantı_kimliği , string $sorgu_dizgesi [, int $seçenekler ] )

Veritabanı sunucusuna bir SQL deyimi gönderir.

Değiştirgeler

bağlantı_kimliği

ODBC bağlantı tanıtıcısı; ayrıntılar için odbc_connect() işlevine bakınız.

sorgu_dizgesi

SQL deyimi.

seçenekler

Şimdilik kullanılmamaktadır.

Dönen Değerler

SQL deyimi çalıştırılabilmişse bir ODBC sonuç tanıtıcısı, yoksa FALSE döner.

Ayrıca Bakınız

  • odbc_prepare() - Çalıştırılmak üzere bir deyim hazırlar
  • odbc_execute() - Bir hazır deyimi çalıştırır

odbc_errormsg
odbc_execute
ODBC İşlevleri


Bir hazır deyimi çalıştırır

odbc_exec
odbc_fetch_array
ODBC İşlevleri
PHP Manual

odbc_execute

(PHP 4, PHP 5, PHP 7)

odbc_execute — Bir hazır deyimi çalıştırır

Açıklama

bool odbc_execute ( resource $sonuç_kimliği [, array $değiştirgeler ] )

odbc_prepare() ile hazırlanmış bir deyimi çalıştırır.

Değiştirgeler

sonuç_kimliği

odbc_prepare() işlevinden dönen bir sonuç tanıtıcısı.

değiştirgeler

değiştirgeler dizisindeki değiştirgelerin hazırlanmış deyimler için birer yer tutucu olduğu varsayılır. Bu dizideki elemanlar bu işlev çağrılarak dizgelere dönüştürülürler.

değiştirgeler dizisindeki isimlerden tek tırnak içine alınmış olanlar veritabanı sunucusuna gönderilecek veya alınacak verileri tutan dosya isimleri olarak ele alınır.

Belirttiğiniz dizgenin bir dosya değil de tek tırnak içine alınmış bir dizge olarak ele alınmasını isterseniz tek tırnaklı dizgenin başına ve sonuna bir boşluk veya tek tırnak dışında bir karakter ekleyin. Bu uygulanabilir değilse, dizgeyi saklamak için başka bir mekanizma kullanmalısınız (sorguyu doğrudan odbc_exec() ile çalıştırmak gibi).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - odbc_execute() ve odbc_prepare() örneği

Aşağıdaki kodda, myproc'un üç değiştirgesi de IN değiştirgesi ise $success daima TRUE olacaktır:

<?php
$a = 1;
$b = 2;
$c = 3;
$stmt    = odbc_prepare($conn, 'CALL myproc(?,?,?)');
$success = odbc_execute($stmt, array($a, $b, $c));
?>

Saklanmış bir yordamı INOUT veya OUT değiştirgeleri ile çağırmanız gerekirse bunun için veritabanınızın kendi eklentisini kullanmanızı öneririz (MS SQL sunucusu için mssql, Oracle için oci8 gibi).

Sürüm Bilgisi

Sürüm: | Açıklama
4.2.0 | Dosya okuma artık safe_mode ve değiştirgeler dizisindeki open-basedir kısıtlamalarının konusudur.
4.1.1 | değiştirgeler dizisindeki Uzak dosyalar artık desteklenmiyor.

Ayrıca Bakınız

  • odbc_prepare() - Çalıştırılmak üzere bir deyim hazırlar

odbc_exec
odbc_fetch_array
ODBC İşlevleri


Sonuç satırını bir ilişkisel dizi olarak döndürür

odbc_execute
odbc_fetch_into
ODBC İşlevleri
PHP Manual

odbc_fetch_array

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

odbc_fetch_array — Sonuç satırını bir ilişkisel dizi olarak döndürür

Açıklama

array odbc_fetch_array ( resource $sonuç [, int $satırnum ] )

Bir ODBC sorgusunun sonucunu bir ilişkisel dizi olarak döndürür. Bu işlevin kullanım yerleri için aşağıdaki sürüm bilgilerine bakınız.

Değiştirgeler

sonuç

odbc_exec() işlevinden dönen bir sonuç tanıtıcısı.

satırnum

Döndürülecek satır numarası; isteğe bağlıdır.

Dönen Değerler

Döndürülecek bir satır yoksa FALSE, aksi takdirde bir dizi döner.

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.3 | PHP, IBM DB2 veya UnixODBC desteği ile derlenmişse bu işlev mevcuttur.
4.3.2 | Bu işlev Windows için mevcuttur.
4.0.2 | PHP, DBMaker desteği ile derlenmişse bu işlev mevcuttur.

Ayrıca Bakınız

  • odbc_fetch_row() - Bir satır döndürür
  • odbc_fetch_object() - Sonuç satırını bir nesne olarak döndürür
  • odbc_num_rows() - Bir sonuçtaki satır sayısını döndürür

odbc_execute
odbc_fetch_into
ODBC İşlevleri


Sonuç satırını bir dizi olarak döndürür

odbc_fetch_array
odbc_fetch_object
ODBC İşlevleri
PHP Manual

odbc_fetch_into

(PHP 4, PHP 5, PHP 7)

odbc_fetch_into — Sonuç satırını bir dizi olarak döndürür

Açıklama

int odbc_fetch_into ( resource $sonuç_kimliği , array &$sonuç_dizisi [, int $satırnum ] )

Sonuç satırını bir dizi olarak döndürür.

Değiştirgeler

sonuç_kimliği

odbc_exec() ile döndürülmüş bir sonuç tanıtıcısı.

sonuç_dizisi

Döndürülecek sonuç satırını içerecek dizi. İşlev tarafından bir diziye dönüştürüleceğinden herhangi bir değişken belirtmek yeterlidir. Dizideki sütunların numaraları 0'dan başlar.

satırnum

Satır numarası.

Dönen Değerler

Hata durumunda FALSE, yoksa sonuçtaki sütun sayısını döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
4.2.0 | sonuç_dizisi ve satırnum değiştirgelerinin yerleri değiştirildi. Böylece satır numarası olarak bir sabit belirtilebilir oldu.
4.0.6 | satırnum artık bir sabit olarak belirtilemiyor, değişken belirtmek gerekiyor. Bu durum 4.2.0 sürümünde değişmiştir.
4.0.5 | sonuç_dizisi değiştirgesinin artık gönderimli belirtilmesi gerekmiyor.

Örnekler

Örnek 1 - odbc_fetch_into() örnekleri

<?php
$rc = odbc_fetch_into($res_id, $my_array);
?>

veya

<?php
$rc = odbc_fetch_into($res_id, $my_array, 2);
?>

odbc_fetch_array
odbc_fetch_object
ODBC İşlevleri


Sonuç satırını bir nesne olarak döndürür

odbc_fetch_into
odbc_fetch_row
ODBC İşlevleri
PHP Manual

odbc_fetch_object

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

odbc_fetch_object — Sonuç satırını bir nesne olarak döndürür

Açıklama

object odbc_fetch_object ( resource $sonuç_kimliği [, int $satırnum ] )

Bir ODBC sonuç kümesindeki bir satırı object türünde döndürür. Bu işlevin hangi sürümlerde kullanılabildiğini öğrenmek için aşağıdaki sürüm bilgilerine bakınız.

Değiştirgeler

sonuç_kimliği

odbc_exec() ile döndürülmüş bir sonuç tanıtıcısı.

satırnum

Döndürülecek satırın numarası; belirtilmesi isteğe bağlıdır.

Dönen Değerler

İstenen satırı içeren bir nesne döner. Satır kalmamışsa FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.3 | PHP, IBM DB2 veya UnixODBC destekli derlenmişse bu işlev kullanılabilir.
4.3.2 | PHP, Windows için derlenmişse bu işlev kullanılabilir.
4.0.2 | PHP, DBMaker destekli derlenmişse bu işlev kullanılabilir.

Ayrıca Bakınız

  • odbc_fetch_row() - Bir satır döndürür
  • odbc_fetch_array() - Sonuç satırını bir ilişkisel dizi olarak döndürür
  • odbc_num_rows() - Bir sonuçtaki satır sayısını döndürür

odbc_fetch_into
odbc_fetch_row
ODBC İşlevleri


Bir satır döndürür

odbc_fetch_object
odbc_field_len
ODBC İşlevleri
PHP Manual

odbc_fetch_row

(PHP 4, PHP 5, PHP 7)

odbc_fetch_row — Bir satır döndürür

Açıklama

bool odbc_fetch_row ( resource $sonuç_kimliği [, int $satırnum ] )

Sonuç kümesindeki bir satırı döndürür. odbc_fetch_row() çağrısından sonra bu satırın alanlarına odbc_result() ile ulaşılabilir.

Değiştirgeler

sonuç_kimliği

odbc_exec() ile döndürülmüş bir sonuç tanıtıcısı.

satırnum

satırnum belirtilmişse, işlev sonuç kümesindeki sonraki satırı döndürmeye çalışır. satırnum belirtilmeden yapılan ilk çağrının sonucu karmaşık olabilir.

Sonuç üzerinde satır satır ilerlemek için ilk çağrı satırnum değiştirgesine 1 belirterek, sonraki çağrılar satırnum belirtilmeksizin yapılır. Eğer sürücü satır numarası ile satır döndürmeyi desteklemiyorsa satırnum sürücü tarafından yok sayılır.

Dönen Değerler

Bir satır varsa TRUE, aksi takdirde FALSE döner

odbc_fetch_object
odbc_field_len
ODBC İşlevleri


Bir alanın uzunluğunu (hassasiyetini) döndürür

odbc_fetch_row
odbc_alan_adı
ODBC İşlevleri
PHP Manual

odbc_field_len

(PHP 4, PHP 5, PHP 7)

odbc_field_len — Bir alanın uzunluğunu (hassasiyetini) döndürür

Açıklama

int odbc_field_len ( resource $sonuç_kimliği , int $alannum )

Sonuç kümesindeki numarası belirtilen alanın uzunluğunu döndürür.

Değiştirgeler

sonuç_kimliği

odbc_exec() ile döndürülmüş bir sonuç tanıtıcısı.

alannum

Alan (sütun) numarası. Sütun numaraları 1'den başlar.

Dönen Değerler

Hata durumunda FALSE, yoksa alan uzunluğunu bir tamsayı olarak döndürür.

Ayrıca Bakınız

  • odbc_field_scale() - Bir alanın skalasını döndürür

odbc_fetch_row
odbc_alan_adı
ODBC İşlevleri


Sütun ismini döndürür

odbc_field_len
odbc_field_num
ODBC İşlevleri
PHP Manual

odbc_alan_adı

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

odbc_alan_adı — Sütun ismini döndürür

Açıklama

string odbc_alan_adı ( resource $sonuç_kimliği , int $alannum )

Sütun kümesindeki sütun numarası belirtilen alanın adını döndürür.

Değiştirgeler

sonuç_kimliği

odbc_exec() ile döndürülmüş bir sonuç tanıtıcısı.

alannum

Alan (sütun) numarası. Sütun numaraları 1'den başlar.

Dönen Değerler

Hata durumunda FALSE, yoksa alan adını bir dizge olarak döndürür.

odbc_field_len
odbc_field_num
ODBC İşlevleri


Sütun numarasını döndürür

odbc_alan_adı
odbc_field_precision
ODBC İşlevleri
PHP Manual

odbc_field_num

(PHP 4, PHP 5, PHP 7)

odbc_field_num — Sütun numarasını döndürür

Açıklama

int odbc_field_num ( resource $sonuç_kimliği , string $alan_adı )

İsmi belirtilen alanın sonuç kümesindeki sütun numarasını döndürür.

Değiştirgeler

sonuç_kimliği

odbc_exec() ile döndürülmüş bir sonuç tanıtıcısı.

alan_adı

Alan adı.

Dönen Değerler

Hata durumunda FALSE, yoksa alan (sütun) numarasını bir tamsayı olarak döndürür. Sütun numaraları 1'den başlar.

odbc_alan_adı
odbc_field_precision
ODBC İşlevleri


odbc_field_len işlevinin takma adıdır

odbc_field_num
odbc_field_scale
ODBC İşlevleri
PHP Manual

odbc_field_precision

(PHP 4, PHP 5, PHP 7)

odbc_field_precision — odbc_field_len() işlevinin takma adıdır

Açıklama

Bu işlev odbc_field_len() işlevinin takma adıdır.

Ayrıca Bakınız

  • odbc_field_scale() - Bir alanın skalasını döndürür

odbc_field_num
odbc_field_scale
ODBC İşlevleri


Bir alanın skalasını döndürür

odbc_field_precision
odbc_field_type
ODBC İşlevleri
PHP Manual

odbc_field_scale

(PHP 4, PHP 5, PHP 7)

odbc_field_scale — Bir alanın skalasını döndürür

Açıklama

int odbc_field_scale ( resource $sonuç_kimliği , int $alannum )

Sonuç içinde numarası belirtilen alanın skalasını döndürür.

Değiştirgeler

sonuç_kimliği

odbc_exec() ile döndürülmüş bir sonuç tanıtıcısı.

alannum

Alan (sütun) numarası. Sütun numaraları 1'den başlar.

Dönen Değerler

Hata durumunda FALSE, yoksa alan skalasını bir tamsayı olarak döndürür.

odbc_field_precision
odbc_field_type
ODBC İşlevleri


Bir alanın veri türünü döndürür

odbc_field_scale
odbc_foreignkeys
ODBC İşlevleri
PHP Manual

odbc_field_type

(PHP 4, PHP 5, PHP 7)

odbc_field_type — Bir alanın veri türünü döndürür

Açıklama

string odbc_field_type ( resource $sonuç_kimliği , int $alannum )

Sonuç içindeki, numarası belirtilen sütunun SQL türünü döndürür.

Değiştirgeler

sonuç_kimliği

odbc_exec() ile döndürülmüş bir sonuç tanıtıcısı.

alannum

Alan (sütun) numarası. Sütun numaraları 1'den başlar.

Dönen Değerler

Hata durumunda FALSE, yoksa alan türünü bir dizge olarak döndürür.

odbc_field_scale
odbc_foreignkeys
ODBC İşlevleri


Bir tablonun yabancı anahtarlarını listeler

odbc_field_type
odbc_free_result
ODBC İşlevleri
PHP Manual

odbc_foreignkeys

(PHP 4, PHP 5, PHP 7)

odbc_foreignkeys — Bir tablonun yabancı anahtarlarını listeler

Açıklama

resource odbc_foreignkeys ( resource $bağlantı_kimliği , string $ba_niteleyici , string $ba_sahibi , string $ba_tablo , string $ya_niteleyici , string $ya_sahibi , string $ya_tablo )

Belirtilen tablodaki yabancı anahtarları veya belirtilen tablodaki birincil anahtarlara atıf yapan başka bir tablonun yabancı anahtarlarını listeler.

Değiştirgeler

bağlantı_kimliği

ODBC bağlantı tanıtıcısı; ayrıntılar için odbc_connect() işlevine bakınız.

ba_niteleyici

Birincil anahtarın niteleyicisi.

ba_sahibi

Birincil anahtarın sahibi.

ba_tablo

Birincil anahtar tablosu.

ya_niteleyici

Yabancı anahtarın niteleyicisi.

ya_sahibi

Yabancı anahtarın sahibi.

ya_tablo

Yabancı anahtar tablosu.

Dönen Değerler

Hata durumunda FALSE yoksa istenen bilgiyi içeren bir ODBC sonuç tanıtıcısı döner.

Sonuç kümesi şu sütunlardan oluşur:

  • PKTABLE_QUALIFIER
  • PKTABLE_OWNER
  • PKTABLE_NAME
  • PKCOLUMN_NAME
  • FKTABLE_QUALIFIER
  • FKTABLE_OWNER
  • FKTABLE_NAME
  • FKCOLUMN_NAME
  • KEY_SEQ
  • UPDATE_RULE
  • DELETE_RULE
  • ya_NAME
  • ba_NAME

ba_tablo bir tablo ismi içeriyorsa, işlev bu tablonun birincil anahtarını ve ona atıf yapan tüm yabancı anahtarları içeren bir sonuç kümesi döndürür.

ya_tablo bir tablo ismi içeriyorsa, işlev bu tablodaki tüm yabancı anahtarları ve bunların atıfta bulunduğu (diğer tablodaki) birincil anahtarları içeren bir sonuç kümesi döndürür.

Hem ba_tablo hem de ya_tablo birer tablo ismi içeriyorsa, işlev ba_tablo'nun birincil anahtarlarına atıf yapan ya_tablo'daki yabancı anahtarları içeren bir sonuç kümesi döndürür. Bunu tek bir anahtardan ibaret olması gerekir.

odbc_field_type
odbc_free_result
ODBC İşlevleri


Bir sonuç ile ilgili özkaynakları serbest bırakır

odbc_foreignkeys
odbc_gettypeinfo
ODBC İşlevleri
PHP Manual

odbc_free_result

(PHP 4, PHP 5, PHP 7)

odbc_free_result — Bir sonuç ile ilgili özkaynakları serbest bırakır

Açıklama

bool odbc_free_result ( resource $sonuç_kimliği )

Bir sonuç ile ilgili özkaynakları serbest bırakır.

Sadece, betiğiniz çalışırken çok fazla bellek ayrıldığından endişeleniyorsanız bu işlevi kullanın. Betiğin işi bittiğinde zaten ayrılan tüm bellek serbest bırakılacaktır.

Değiştirgeler

sonuç_kimliği

odbc_exec() ile döndürülmüş bir sonuç tanıtıcısı.

Dönen Değerler

Daima TRUE döner.

Notlar

Bilginize:

Özdevinimli teslimat etkin değilse (bak: odbc_autocommit()) ve teslimat öncesi odbc_free_result() çağrısı yaparsanız bekleyen tüm hareketler başa sarılır.

odbc_foreignkeys
odbc_gettypeinfo
ODBC İşlevleri


Veri kaynağınca desteklenen veri türleri hakkında bilgi döndürür

odbc_free_result
odbc_longreadlen
ODBC İşlevleri
PHP Manual

odbc_gettypeinfo

(PHP 4, PHP 5, PHP 7)

odbc_gettypeinfo — Veri kaynağınca desteklenen veri türleri hakkında bilgi döndürür

Açıklama

resource odbc_gettypeinfo ( resource $bağlantı_kimliği [, int $veri_türü ] )

Veri kaynağınca desteklenen veri türleri hakkında bilgi döndürür.

Değiştirgeler

bağlantı_kimliği

ODBC bağlantı tanıtıcısı; ayrıntılar için odbc_connect() işlevine bakınız.

veri_türü

Bilgi döndürülecek veri türü. Dönen bilgiyi tek bir veri türü ile sınırlamak için kullanılır.

Dönen Değerler

Hata durumunda FALSE yoksa istenen bilgiyi içeren bir ODBC sonuç tanıtıcısı döner.

Sonuç kümesi şu sütunlardan oluşur:

  • TYPE_NAME
  • DATA_TYPE
  • PRECISION
  • LITERAL_PREFIX
  • LITERAL_SUFFIX
  • CREATE_PARAMS
  • NULLABLE
  • CASE_SENSITIVE
  • SEARCHABLE
  • UNSIGNED_ATTRIBUTE
  • MONEY
  • AUTO_INCREMENT
  • LOCAL_TYPE_NAME
  • MINIMUM_SCALE
  • MAXIMUM_SCALE

Sonuç kümesi şu sütunlara göre sıralanır: DATA_TYPE ve TYPE_NAME.

odbc_free_result
odbc_longreadlen
ODBC İşlevleri


LONG sütunlarla çalışmayı etkin kılar

odbc_gettypeinfo
odbc_next_result
ODBC İşlevleri
PHP Manual

odbc_longreadlen

(PHP 4, PHP 5, PHP 7)

odbc_longreadlen — LONG sütunlarla çalışmayı etkin kılar

Açıklama

bool odbc_longreadlen ( resource $sonuç_kimliği , int $uzunluk )

LONG ve LONGVARBINARY sütunlarla çalışmayı etkin kılar.

Değiştirgeler

sonuç_kimliği

odbc_exec() ile döndürülmüş bir sonuç tanıtıcısı.

uzunluk

PHP'ye döndürülecek bayt sayısı. 0 belirtilirse istemciye LONG sütun verisinin tamamı aktarılır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

Bilginize:

LONGVARBINARY sütunlarla çalışma odbc_binmode() işlevinden de etkilenir.

odbc_gettypeinfo
odbc_next_result
ODBC İşlevleri


Kullanılabilecek çok sayıda sonuç var mı diye bakar

odbc_longreadlen
odbc_num_fields
ODBC İşlevleri
PHP Manual

odbc_next_result

(PHP 4 >= 4.0.5, PHP 5, PHP 7)

odbc_next_result — Kullanılabilecek çok sayıda sonuç var mı diye bakar

Açıklama

bool odbc_next_result ( resource $sonuç_kimliği )

odbc_fetch_array(), odbc_fetch_row(), odbc_result() ve benzerleri üzerinden erişilebilecek başka sonuç kümesi varsa TRUE döner.

Değiştirgeler

sonuç_kimliği

odbc_exec() ile döndürülmüş bir sonuç tanıtıcısı.

Dönen Değerler

Başka sonuç kümesi varsa TRUE, yoksa FALSE döner.

Örnekler

Örnek 1 - odbc_next_result() örneği

<?php
$r_Connection = odbc_connect($dsn, $username, $password);

$s_SQL = <<<END_SQL
SELECT 'A'
SELECT 'B'
SELECT 'C'
END_SQL;

$r_Results = odbc_exec($r_Connection, $s_SQL);

$a_Row1 = odbc_fetch_array($r_Results);
$a_Row2 = odbc_fetch_array($r_Results);
echo "İlk sonuç kümesinin dökümü: ";
var_dump($a_Row1, $a_Row2);

echo "Başka sonuç kümesi var mı? ";
var_dump(odbc_next_result($r_Results));

$a_Row1 = odbc_fetch_array($r_Results);
$a_Row2 = odbc_fetch_array($r_Results);
echo "İkinci sonuç kümesinin dökümü: ";
var_dump($a_Row1, $a_Row2);

echo "Başka sonuç kümesi var mı? ";
var_dump(odbc_next_result($r_Results));

$a_Row1 = odbc_fetch_array($r_Results);
$a_Row2 = odbc_fetch_array($r_Results);
echo "Üçüncü sonuç kümesinin dökümü: ";
var_dump($a_Row1, $a_Row2);

echo "Başka sonuç kümesi var mı? ";
var_dump(odbc_next_result($r_Results));
?>

Yukarıdaki örneğin çıktısı:

İlk sonuç kümesinin dökümü: array(1) {
  ["A"]=>
  string(1) "A"
}
bool(false)
Başka sonuç kümesi var mı? bool(true)
İkinci sonuç kümesinin dökümü: array(1) {
  ["B"]=>
  string(1) "B"
}
bool(false)
Başka sonuç kümesi var mı? bool(true)
Üçüncü sonuç kümesinin dökümü: array(1) {
  ["C"]=>
  string(1) "C"
}
bool(false)
Başka sonuç kümesi var mı? bool(false)

odbc_longreadlen
odbc_num_fields
ODBC İşlevleri


Bir sonuçtaki sütun sayısını döndürür

odbc_next_result
odbc_num_rows
ODBC İşlevleri
PHP Manual

odbc_num_fields

(PHP 4, PHP 5, PHP 7)

odbc_num_fields — Bir sonuçtaki sütun sayısını döndürür

Açıklama

int odbc_num_fields ( resource $sonuç_kimliği )

Belirtilen ODBC sonucundaki sütun (alan) sayısını döndürür.

Değiştirgeler

sonuç_kimliği

odbc_exec() ile döndürülmüş bir sonuç tanıtıcısı.

Dönen Değerler

Belirtilen ODBC sonucundaki satırların sayısını döndürür. Bir hata oluşursa -1 döner.

odbc_next_result
odbc_num_rows
ODBC İşlevleri


Bir sonuçtaki satır sayısını döndürür

odbc_num_fields
odbc_pconnect
ODBC İşlevleri
PHP Manual

odbc_num_rows

(PHP 4, PHP 5, PHP 7)

odbc_num_rows — Bir sonuçtaki satır sayısını döndürür

Açıklama

int odbc_num_rows ( resource $sonuç_kimliği )

Bir sonuçtaki satır sayısını döndürür. INSERT, UPDATE ve DELETE deyimleri için odbc_num_rows() etkilenen satır sayısını döndürür. SELECT için ise dönen değer kullanılabilir satır sayısı olabilir.

Değiştirgeler

sonuç_kimliği

odbc_exec() ile döndürülmüş bir sonuç tanıtıcısı.

Dönen Değerler

Belirtilen ODBC sonucundakı satırların sayısını döndürür. Bir hata oluşursa -1 döner.

Notlar

Bilginize:

İşlevin, bir SELECT sonrası kullanılabilir satırların sayısını saptamak için kullanımı durumunda çoğu sürücü -1 döndürür.

odbc_num_fields
odbc_pconnect
ODBC İşlevleri


Bir kalıcı veritabanı bağlantısı açar

odbc_num_rows
odbc_prepare
ODBC İşlevleri
PHP Manual

odbc_pconnect

(PHP 4, PHP 5, PHP 7)

odbc_pconnect — Bir kalıcı veritabanı bağlantısı açar

Açıklama

resource odbc_pconnect ( string $dsn , string $kullanıcı , string $parola [, int $imleç_türü ] )

Bir kalıcı veritabanı bağlantısı açar.

Betiğin işi bettiğinde bağlantının kapanmaması dışında odbc_connect() işlevi gibidir. Aynı dsn, kullanıcı ve parola ile (odbc_connect() ve odbc_pconnect() üzerinden) istenen bağlantılar için aynı kalıcı bağlantı kullanılılabilir.

Değiştirgeler

Ayrıntılar için odbc_connect() işlevine bakınız.

Dönen Değerler

Hata durumunda FALSE yoksa istenen bilgiyi içeren bir ODBC sonuç tanıtıcısı döner.

Notlar

Bilginize: PHP bir CGI programı olarak kullanılıyorsa kalıcı bağlantıların hiçbir etkisi yoktur.

Ayrıca Bakınız

  • odbc_connect() - Bir veri kaynağına bağlanır
  • Kalıcı Veritabanı Bağlantıları

odbc_num_rows
odbc_prepare
ODBC İşlevleri


Çalıştırılmak üzere bir deyim hazırlar

odbc_pconnect
odbc_primarykeys
ODBC İşlevleri
PHP Manual

odbc_prepare

(PHP 4, PHP 5, PHP 7)

odbc_prepare — Çalıştırılmak üzere bir deyim hazırlar

Açıklama

resource odbc_prepare ( resource $bağlantı_kimliği , string $sorgu_dizgesi )

Çalıştırılmak üzere bir deyim hazırlar. Elde edilen sonuç tanıtıcısı odbc_execute() işlevinde kullanılarak deyim daha sonra çalıştırılabilir.

Bazı veritabanları (IBM DB2, MS SQL Server ve Oracle gibi), ODBC belirtiminde belirtildiği gibi IN, INOUT ve OUT türünde değiştirgeler kabul eden saklanmış yordamları destekler. Ancak, Tekilleştirilmiş ODBC sadece IN türündeki değiştirgeleri desteklemektedir.

Değiştirgeler

bağlantı_kimliği

ODBC bağlantı tanıtıcısı; ayrıntılar için odbc_connect() işlevine bakınız.

sorgu_dizgesi

Hazırlanan deyimi içeren sorgu dizgesi.

Dönen Değerler

Hata durumunda FALSE yoksa SQL komutu hazırlanabilmişse istenen bilgiyi içeren bir ODBC sonuç tanıtıcısı döner.

Örnekler

Örnek 1 - odbc_execute() ve odbc_prepare() örneği

Aşağıdaki örnekte, myproc'un üç değiştirgesi de IN türünde olduğu takdirde $success daima TRUE olacaktır:

<?php
$a = 1;
$b = 2;
$c = 3;
$stmt    = odbc_prepare($conn, 'CALL myproc(?,?,?)');
$success = odbc_execute($stmt, array($a, $b, $c));
?>

INOUT veya OUT türünde değiştirgeler kullanan saklanmış yordamlara ihtiyacınız varsa veritabanınızın kendi eklentisini kullanınız (örneğin, MS SQL Sunucusu için mssql, Oracle için oci8 gibi).

Ayrıca Bakınız

  • odbc_execute() - Bir hazır deyimi çalıştırır

odbc_pconnect
odbc_primarykeys
ODBC İşlevleri


Bir tablonun birincil anahtarlarını döndürür

odbc_prepare
odbc_procedurecolumns
ODBC İşlevleri
PHP Manual

odbc_primarykeys

(PHP 4, PHP 5, PHP 7)

odbc_primarykeys — Bir tablonun birincil anahtarlarını döndürür

Açıklama

resource odbc_primarykeys ( resource $bağlantı_kimliği , string $niteleyici , string $sahibi , string $tablo )

Bir tablonun birincil anahtarlarını içeren sütunlardan oluşan sonuç için bir sonuç tanıtıcısı döndürür.

Değiştirgeler

bağlantı_kimliği

ODBC bağlantı tanıtıcısı; ayrıntılar için odbc_connect() işlevine bakınız.

niteleyici

sahibi

tablo

Dönen Değerler

Hata durumunda FALSE yoksa istenen bilgiyi içeren bir ODBC sonuç tanıtıcısı döner.

Sonuç kümesi şu sütunlardan oluşur:

  • TABLE_QUALIFIER
  • TABLE_OWNER
  • TABLE_NAME
  • COLUMN_NAME
  • KEY_SEQ
  • PK_NAME

odbc_prepare
odbc_procedurecolumns
ODBC İşlevleri


Yordamların değiştirgeleri hakkında bilgi döndürür

odbc_primarykeys
odbc_procedures
ODBC İşlevleri
PHP Manual

odbc_procedurecolumns

(PHP 4, PHP 5, PHP 7)

odbc_procedurecolumns — Yordamların değiştirgeleri hakkında bilgi döndürür

Açıklama

resource odbc_procedurecolumns ( resource $bağlantı_kimliği )
resource odbc_procedurecolumns ( resource $bağlantı_kimliği , string $niteleyici , string $sahibi , string $yordam , string $sütun )

Belirtilen yordamların değiştirgeleri hakkında bilgi döndürür.

Değiştirgeler

bağlantı_kimliği

ODBC bağlantı tanıtıcısı; ayrıntılar için odbc_connect() işlevine bakınız.

niteleyici

Niteleyici.

sahibi

Sahibi. Arama şablonları belirtilebilir (sıfır veya daha fazla karakterle eşleşmek üzere "%" ve tek bir karakterle eşleşmek üzere "_".

yordam

Yordam. Arama şablonları belirtilebilir (sıfır veya daha fazla karakterle eşleşmek üzere "%" ve tek bir karakterle eşleşmek üzere "_".

sütun

Sütun. Arama şablonları belirtilebilir (sıfır veya daha fazla karakterle eşleşmek üzere "%" ve tek bir karakterle eşleşmek üzere "_".

Dönen Değerler

Belirtilen yordamlar için sonuç kümesini oluşturan girdi ve çıktı değiştirgeleriyle birlikte sütunları da döndürür. Hata durumunda FALSE yoksa istenen bilgiyi içeren bir ODBC sonuç tanıtıcısı döner.

Sonuç kümesi şu sütunlardan oluşur:

  • PROCEDURE_QUALIFIER
  • PROCEDURE_OWNER
  • PROCEDURE_NAME
  • COLUMN_NAME
  • COLUMN_TYPE
  • DATA_TYPE
  • TYPE_NAME
  • PRECISION
  • LENGTH
  • SCALE
  • RADIX
  • NULLABLE
  • REMARKS

Sonuç kümesi şu sütunlara göre sıralanır: PROCEDURE_QUALIFIER, PROCEDURE_OWNER, PROCEDURE_NAME ve COLUMN_TYPE.

odbc_primarykeys
odbc_procedures
ODBC İşlevleri


Belirtilen veri kaynağında saklı yordamların listesini döndürür

odbc_procedurecolumns
odbc_result_all
ODBC İşlevleri
PHP Manual

odbc_procedures

(PHP 4, PHP 5, PHP 7)

odbc_procedures — Belirtilen veri kaynağında saklı yordamların listesini döndürür

Açıklama

resource odbc_procedures ( resource $bağlantı_kimliği )
resource odbc_procedures ( resource $bağlantı_kimliği , string $niteleyici , string $sahibi , string $isim )

Belirtilen aralıktaki tüm yordamları listeler.

Değiştirgeler

bağlantı_kimliği

ODBC bağlantı tanıtıcısı; ayrıntılar için odbc_connect() işlevine bakınız.

niteleyici

Niteleyici.

sahibi

Sahibi. Arama şablonları belirtilebilir (sıfır veya daha fazla karakterle eşleşmek üzere "%" ve tek bir karakterle eşleşmek üzere "_".

isim

İsim. Arama şablonları belirtilebilir (sıfır veya daha fazla karakterle eşleşmek üzere "%" ve tek bir karakterle eşleşmek üzere "_".

Dönen Değerler

Hata durumunda FALSE yoksa istenen bilgiyi içeren bir ODBC sonuç tanıtıcısı döner.

Sonuç kümesi şu sütunlardan oluşur:

  • PROCEDURE_QUALIFIER
  • PROCEDURE_OWNER
  • PROCEDURE_NAME
  • NUM_INPUT_PARAMS
  • NUM_OUTPUT_PARAMS
  • NUM_RESULT_SETS
  • REMARKS
  • PROCEDURE_TYPE

odbc_procedurecolumns
odbc_result_all
ODBC İşlevleri


Sonucu bir HTML tablosu olarak basar

odbc_procedures
odbc_result
ODBC İşlevleri
PHP Manual

odbc_result_all

(PHP 4, PHP 5, PHP 7)

odbc_result_all — Sonucu bir HTML tablosu olarak basar

Açıklama

int odbc_result_all ( resource $sonuç_kimliği [, string $biçem ] )

odbc_exec() tarafından üretilen bir sonuç tanıtıcısındaki tüm satırları HTML tablosu biçeminde basar.

Değiştirgeler

sonuç_kimliği

Sonuç tanıtıcısı.

biçem

Tablo biçemi.

Dönen Değerler

Bir hata durumunda FALSE yoksa satır sayısı döner.

odbc_procedures
odbc_result
ODBC İşlevleri


Sonuçtan veri döndürür

odbc_result_all
odbc_rollback
ODBC İşlevleri
PHP Manual

odbc_result

(PHP 4, PHP 5, PHP 7)

odbc_result — Sonuçtan veri döndürür

Açıklama

mixed odbc_result ( resource $sonuç_kimliği , mixed $alan )

Sonuçtan veri döndürür.

Değiştirgeler

sonuç_kimliği

Bir ODBC sonuç tanıtıcısı.

alan

Veri döndürülecek alan ismi. Alan numarası olarak bir sayı veya alan ismi olarak bir dizi olabilir.

Dönen Değerler

Hata durumunda FALSE, NULL veri için NULL ikil veri için TRUE aksi takdirde alanı içeren bir dizge döner.

Örnekler

İlk odbc_result() çağrısında sorgu sonucundaki kaydın üçüncü alanının değeri, ikincisinde ise "miktar" alanının değeri dönmektedir. Belirtilen sütun numarası birden küçük veya kayıttaki alan sayısından büyükse bir hata oluşur. Benzer şekilde, belirtilen alan ismi, kayıtta bulunan alan isimlerinden biri değilse de bir hata oluşacaktır.

Örnek 1 - odbc_result() örnekleri

<?php
$öğe_3   = odbc_result($sorgum, 3);
$öğe_miktar = odbc_result($sorgum, "miktar");
?>

Notlar

Alan numaraları 1'den başlar. İkil ve uzun ikil veriler hakkında bilgi için odbc_binmode() ve odbc_longreadlen() işlevine bakınız.

odbc_result_all
odbc_rollback
ODBC İşlevleri


Bir hareketi başa döndürür

odbc_result
odbc_setoption
ODBC İşlevleri
PHP Manual

odbc_rollback

(PHP 4, PHP 5, PHP 7)

odbc_rollback — Bir hareketi başa döndürür

Açıklama

bool odbc_rollback ( resource $bağlantı_kimliği )

Bağlantıda bekleyen tüm sorguların en baştan ele alınmasını sağlar.

Değiştirgeler

bağlantı_kimliği

ODBC bağlantı tanıtıcısı; ayrıntılar için odbc_connect() işlevine bakınız.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

odbc_result
odbc_setoption
ODBC İşlevleri


ODBC ayarlarını yapar

odbc_rollback
odbc_specialcolumns
ODBC İşlevleri
PHP Manual

odbc_setoption

(PHP 4, PHP 5, PHP 7)

odbc_setoption — ODBC ayarlarını yapar

Açıklama

bool odbc_setoption ( resource $kimlik , int $işlev , int $seçenek , int $değer )

Bu işlevle ODBC seçenekleri, belli bir bağlantı veya sonuç kümesine uygun olarak ayarlanır. Çok oyuncaklı ODBC sürücülerinye ilgili sorunların üstesinden gelmek için tasarlanmıştır. Sadece bir ODBC programcısı iseniz veya çeşitli seçeneklerin ne anlama geldiğini öğrenmek isterseniz işe yarar. Farklı seçenekleri ve değerleri açıklayan iyi bir ODBC kılavuzuna mutlaka ihtiyacınız olacaktır. Farklı sürücü sürümleri farklı seçenekler sunar.

ODBC sürücüsüne bağlı olarak işlevin etkileri değişebildiğinden halka açık betiklerde bu işlevi kesinlikle kullanmamalısınız. Ayrıca, bağlantı kurulmadan veya sorgu hazırlanmadan önce atanması gereken bazı ODBC seçenekleri de bu işlevle kullanılamamaktadır. Bununla birlikte, belli bir işi PHP ile yapmanız mümkünse, açıktır ki, patronunuz bunların hepsini yapabilen bir ticari ürünü kullanmanızı istemeyecektir.

Değiştirgeler

kimlik

Ayar değişikliği yapılacak bağlantı veya sonuç kimliği. Bu, SQLSetConnectOption() için bir bağlantı kimliği, SQLSetStmtOption(), için ise bir sonuç kimliğidir.

işlev

ODBC işlevi kullanılacak mı?. Değer, SQLSetConnectOption() için 1, SQLSetStmtOption() için 2 olmalıdır.

seçenek

Değeri ayarlanacak seçenek.

değer

Ayarlanacak seçeneğin değeri.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - odbc_setoption() örnekleri

<?php
// 1. SQLSetConnectOption() için 102. seçenek: SQL_AUTOCOMMIT.
//    SQL_AUTOCOMMIT için 1. değer: SQL_AUTOCOMMIT_ON.
//    Bu örnek, odbc_autocommit($conn, true); işlevinin yaptığını yapar

odbc_setoption($conn, 1, 102, 1);

// 2. SQLSetStmtOption() için 0. seçenek: SQL_QUERY_TIMEOUT.
//    Bu örnek, sorgunun 30 saniyede zaman aşımına uğramasını sağlar.

$result = odbc_prepare($conn, $sql);
odbc_setoption($result, 2, 0, 30);
odbc_execute($result);
?>

odbc_rollback
odbc_specialcolumns
ODBC İşlevleri


Özel sütunları döndürür

odbc_setoption
odbc_statistics
ODBC İşlevleri
PHP Manual

odbc_specialcolumns

(PHP 4, PHP 5, PHP 7)

odbc_specialcolumns — Özel sütunları döndürür

Açıklama

resource odbc_specialcolumns ( resource $bağlantı_kimliği , int $türü , string $niteleyici , string $sahibi , string $tablo , int $kapsam , int $boş )

Tablo içindeki bir satırı eşsiz olarak betimleyen en uygun sütunların veya bir satırın bir hareket sonucunda güncellenmesi durumunda özdevinimli olarak güncellenen sütünların listesini döndürür.

Değiştirgeler

bağlantı_kimliği

ODBC bağlantı tanıtıcısı; ayrıntılar için odbc_connect() işlevine bakınız.

türü
SQL_BEST_ROWID belirtilirse, tablodaki her satırı eşsiz olarak betimleyin sütun veya sütunlar döner. SQL_ROWVER belirtilirse, bir satırın bir hareket sonucunda güncellenmesi durumunda özdevinimli olarak güncellenen sütunların listesini döndürür.
niteleyici

Niteliyici.

sahibi

Sahibi.

tablo

Tablo.

kapsam

Sonuç kümesinin kapsamı.

boş

nullable özniteliği.

Dönen Değerler

Hata durumunda FALSE yoksa istenen bilgiyi içeren bir ODBC sonuç tanıtıcısı döner.

Sonuç kümesi şu sütunlardan oluşur:

  • SCOPE
  • COLUMN_NAME
  • DATA_TYPE
  • TYPE_NAME
  • PRECISION
  • LENGTH
  • SCALE
  • PSEUDO_COLUMN

odbc_setoption
odbc_statistics
ODBC İşlevleri


Bir tablo hakkındaki istatistikleri döndürür

odbc_specialcolumns
odbc_tableprivileges
ODBC İşlevleri
PHP Manual

odbc_statistics

(PHP 4, PHP 5, PHP 7)

odbc_statistics — Bir tablo hakkındaki istatistikleri döndürür

Açıklama

resource odbc_statistics ( resource $bağlantı_kimliği , string $niteleyici , string $sahibi , string $tablo_ismi , int $eşsiz , int $doğruluk )

Bir tablo ve indisleri hakkında istatistiksel bilgi döndürür.

Değiştirgeler

bağlantı_kimliği

ODBC bağlantı tanıtıcısı; ayrıntılar için odbc_connect() işlevine bakınız.

niteleyici

Niteleyici.

sahibi

Sahibi.

tablo_ismi

Tablo ismi.

eşsiz

unique özniteliği.

doğruluk

Doğruluk.

Dönen Değerler

Hata durumunda FALSE yoksa istenen bilgiyi içeren bir ODBC sonuç tanıtıcısı döner.

Sonuç kümesi şu sütunlardan oluşur:

  • TABLE_QUALIFIER
  • TABLE_OWNER
  • TABLE_NAME
  • NON_UNIQUE
  • INDEX_QUALIFIER
  • INDEX_NAME
  • TYPE
  • SEQ_IN_INDEX
  • COLUMN_NAME
  • COLLATION
  • CARDINALITY
  • PAGES
  • FILTER_CONDITION

Sonuç kümesi şu sütunlara göre sıralanır: NON_UNIQUE, TYPE, INDEX_QUALIFIER, INDEX_NAME ve SEQ_IN_INDEX.

odbc_specialcolumns
odbc_tableprivileges
ODBC İşlevleri


Tabloları izinleriyle birlikte listeler

odbc_statistics
odbc_tables
ODBC İşlevleri
PHP Manual

odbc_tableprivileges

(PHP 4, PHP 5, PHP 7)

odbc_tableprivileges — Tabloları izinleriyle birlikte listeler

Açıklama

resource odbc_tableprivileges ( resource $bağlantı_kimliği , string $niteleyici , string $sahibi , string $isim )

Belirtilen aralıktaki tabloların izinlerini isimlerine göre listeler.

Değiştirgeler

bağlantı_kimliği

ODBC bağlantı tanıtıcısı; ayrıntılar için odbc_connect() işlevine bakınız.

niteleyici

Niteleyici.

sahibi

Sahibi. Arama şablonları belirtilebilir (sıfır veya daha fazla karakterle eşleşmek üzere "%" ve tek bir karakterle eşleşmek üzere "_".

isim

İsim. Arama şablonları belirtilebilir (sıfır veya daha fazla karakterle eşleşmek üzere "%" ve tek bir karakterle eşleşmek üzere "_".

Dönen Değerler

Hata durumunda FALSE yoksa istenen bilgiyi içeren bir ODBC sonuç tanıtıcısı döner.

Sonuç kümesi şu sütunlardan oluşur:

  • TABLE_QUALIFIER
  • TABLE_OWNER
  • TABLE_NAME
  • GRANTOR
  • GRANTEE
  • PRIVILEGE
  • IS_GRANTABLE

Sonuç kümesi TABLE_QUALIFIER, TABLE_OWNER ve TABLE_NAME sütunlarına göre sıralanır.

odbc_statistics
odbc_tables
ODBC İşlevleri


Belli bir veri kaynağında bulunan tablo isimlerini döndürür

odbc_tableprivileges
PDO
ODBC İşlevleri
PHP Manual

odbc_tables

(PHP 4, PHP 5, PHP 7)

odbc_tables — Belli bir veri kaynağında bulunan tablo isimlerini döndürür

Açıklama

resource odbc_tables ( resource $bağlantı_kimliği [, string $niteleyici [, string $sahibi [, string $isim [, string $tablo_türü ]]]] )

Belitilen aralıktaki tüm tablo isimlerini listeler.

niteleyici, sahibi, isim ve tablo_türü değiştirgeleri ile seçim şöyle yapılır:

  • niteleyici tek bir yüzde iminden (%) ibaretse ve, sahibi ve isim birer boş dizgeyse sonuç, veri kaynağındaki geçerli niteleyicileri içerir. (TABLE_QUALIFIER sütunu dışında tüm sütunlar NULL içerir.)
  • sahibi tek bir yüzde iminden (%) ibaretse ve, niteleyici ve isim birer boş dizgeyse sonuç, veri kaynağındaki geçerli sahipleri içerir. (TABLE_OWNER sütunu dışında tüm sütunlar NULL içerir.)
  • tablo_türü tek bir yüzde iminden (%) ibaretse ve, niteleyici, sahibi ve isim birer boş dizgeyse sonuç, veri kaynağındaki geçerli tablo türlerini içerir. (TABLE_TYPE sütunu dışında tüm sütunlar NULL içerir.)

Değiştirgeler

bağlantı_kimliği

ODBC bağlantı tanıtıcısı; ayrıntılar için odbc_connect() işlevine bakınız.

niteleyici

Niteleyici.

sahibi

Sahibi. Arama şablonları belirtilebilir (sıfır veya daha fazla karakterle eşleşmek üzere "%" ve tek bir karakterle eşleşmek üzere "_".

isim

İsim. Arama şablonları belirtilebilir (sıfır veya daha fazla karakterle eşleşmek üzere "%" ve tek bir karakterle eşleşmek üzere "_".

tablo_türü

tablo_türü boş bir dizge değilse tablo türlerinden oluşan virgül ayraçlı bir liste olmalıdır. Her değer ya tek tırnaklar (') arasına alınmalı ya da hiç tırnak içine alınmamalıdır. Örnek: "'TABLE','VIEW'" veya "TABLE, VIEW". Eğer veri kaynağı belirtilen tablo türlerini desteklemiyorsa, işlev, bu tablo türlerinde hiçbir sonuç döndürmez.

Dönen Değerler

Hata durumunda FALSE yoksa istenen bilgiyi içeren bir ODBC sonuç tanıtıcısı döner.

Sonuç kümesi şu sütunlardan oluşur:

  • TABLE_QUALIFIER
  • TABLE_OWNER
  • TABLE_NAME
  • TABLE_TYPE
  • REMARKS

Sonuç kümesi TABLE_TYPE, TABLE_QUALIFIER, TABLE_OWNER ve TABLE_NAME sütunlarına göre sıralanır.

Ayrıca Bakınız

  • odbc_tableprivileges() - Tabloları izinleriyle birlikte listeler

odbc_tableprivileges
PDO
ODBC İşlevleri


PHP Veri Nesneleri

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Bağlantılar ve Bağlantı Yönetimi
  • Hareketler ve özdevinimli işlemler
  • Hazır deyimler ve Saklı Yordamlar
  • Hatalar ve Ele Alınışları
  • Büyük Veri Nesneleri (LOB'lar)
  • PDO — PDO sınıfı
    • PDO::beginTransaction — Bir toplu hareketi ilklendirir
    • PDO::commit — Bir toplu hareketi veritabanına gönderir
    • PDO::__construct — Bir veritabanı bağlantısını temsil eden bir PDO nesnesi oluşturur
    • PDO::errorCode — Veritabanındaki son işlemle ilgili SQLSTATE kodunu döndürür
    • PDO::errorInfo — Veritabanındaki son işlemle ilgili hata bilgisini döndürür
    • PDO::exec — Belirtilen SQL deyimini çalıştırır ve etkilenen satır sayısını döndürür
    • PDO::getAttribute — Bir veritabanı bağlantı özniteliğinin değerini döndürür
    • PDO::getAvailableDrivers — Kullanılabilen PDO sürücülerini içeren bir dizi döndürür
    • PDO::inTransaction — Checks if inside a transaction
    • PDO::lastInsertId — Son yerleştirilen satırın veya sıradaki değerin kimliğini döndürür
    • PDO::prepare — Çalıştırılmak üzere bir deyimi hazırlar ve bir deyim nesnesi olarak döndürür
    • PDO::query — Bir SQL deyimini çalıştırıp sonucu bir PDOStatement nesnesi olarak döndürür
    • PDO::quote — Bir sorguda kullanılmak üzere bir dizgeyi önceler
    • PDO::rollBack — Bir toplu hareketi geri alır
    • PDO::setAttribute — Bir öznitelik tanımlar
  • PDOStatement — PDOStatement sınıfı
    • PDOStatement->bindColumn — Bir sütunu bir PHP değişkeni ile ilişkilendirir
    • PDOStatement->bindParam — Bir değiştirgeyi belirtilen değişkenle ilişkilendirir
    • PDOStatement->bindValue — Bir değeri bir değiştirge ile ilişkilendirir
    • PDOStatement->closeCursor — Göstericiyi kapatarak deyimin tekrar çalıştırılabilmesini sağlar
    • PDOStatement->columnCount — Sonuç kümesindeki sütun sayısını döndürür
    • PDOStatement->debugDumpParams — Bir SQL hazır komutunu dökümler
    • PDOStatement->errorCode — Deyim üzerindeki son işlemle ilgili SQLSTATE hata kodunu döndürür
    • PDOStatement->errorInfo — Deyim üzerindeki son işlemle ilgili hata bilgisini döndürür
    • PDOStatement->execute — Bir hazır deyimi çalıştırır
    • PDOStatement->fetch — Sonuç kümesindeki sonraki satırı döndürür
    • PDOStatement->fetchAll — Sonuç kümesinin tüm satırlarını içeren bir dizi döndürür
    • PDOStatement->fetchColumn — Sonuç kümesindeki sonraki satırdan tek bir sütun döndürür
    • PDOStatement->fetchObject — Sonraki satırı bir nesne olarak döndürür
    • PDOStatement->getAttribute — Bir deyim özniteliğinin değerini döndürür
    • PDOStatement->getColumnMeta — Sonuç kümesindeki bir sütunla ilgili temel veriyi döndürür
    • PDOStatement->nextRowset — Çok satır kümeli bir sonuçtaki sonraki satır kümesini geçerli satır kümesi yapar
    • PDOStatement->rowCount — Son SQL deyiminden etkilenen satır sayısını döndürür
    • PDOStatement->setAttribute — Bir deyim özniteliğini tanımlar
    • PDOStatement->setFetchMode — Deyim için öntanımlı veri alım kipini belirler
  • PDOException — PDOException sınıfı
  • PDO Sürücüleri
    • CUBRID (PDO) — CUBRID Functions (PDO_CUBRID)
    • MS SQL Sunucusu (PDO) — Microsoft SQL Sunucusu ve Sybase (PDO_DBLIB) İşlevleri
    • Firebird/Interbase (PDO) — Firebird/Interbase (PDO_FIREBIRD) İşlevleri
    • IBM (PDO) — IBM (PDO_IBM) İşlevleri
    • Informix (PDO) — Informix (PDO_INFORMIX) İşlevleri
    • MySQL (PDO) — MySQL (PDO_MYSQL) İşlevleri
    • MS SQL Server (PDO) — Microsoft SQL Server Functions (PDO_SQLSRV)
    • Oracle (PDO) — Oracle (PDO_OCI) İşlevleri
    • ODBC ve DB2 (PDO) — ODBC ve DB2 (PDO_ODBC) İşlevleri
    • PostgreSQL (PDO) — PostgreSQL (PDO_PGSQL) İşlevleri
    • SQLite (PDO) — SQLite (PDO_SQLITE) İşlevleri
    • PDO_4D sürücüsü — PDO için 4D sürücüsü (PDO_4D)
odbc_tables
Giriş
Soyutlama Katmanları


Giriş

PHP Veri Nesneleri (PDO) eklentisi, PHP'deki veritabanlarına erişmek için hafif ve tutarlı bir arayüz tanımlar. PDO arayüzü tanımı bulunan her veritabanı sürücüsü, veritabanına özgü özellikleri sıradan eklenti işlevleri olarak ifade edebilir. Yalnız dikkat edin, PDO eklentisinin kendisini her veritabanı işlevi için kullanamazsınız; bir veritabanı sunucusuna erişmek için veritabanına özgü PDO sürücüsünü kullanmalısınız.

PDO bir veri erişimli soyutlama katmanı sağlar, yani, kullandığınız veritabanından bağımsız olarak sorguları çalıştırmak ve sonuçları döndürmek için aynı işlevleri kullanabilirsiniz. PDO bir veritabanı soyutlaması yapmaz; SQL deyimini yeniden yazmaz ya da olmayan özellikleri taklit etmez. Bu özellikleri istiyorsanız tam gelişmiş soyutlama katmanını kullanmalısınız.

PDO, PHP 5.1'den itibaren PHP ile birlikte gelir ve PHP 5.0'dan beri bir PECL eklentisi olarak da mevcuttur. PDO, PHP 5'teki yeni nesne yönelimli özelliklere ihtiyaç duyar; bu bakımdan PHP'nin daha önceki sürümleri ile çalışmaz.

PDO
Yapılandırma/Kurulum
PDO


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
PDO


Kurulum

Unix sistemlere PDO Kurulumu

  1. PDO ve PDO_SQLITE sürücüsü PHP 5.1.0'dan itibaren öntanımlı olarak etkindir. Başka bir veritabanının PDO sürücüsünü etkinleştirmek isterseniz bunun nasıl yapılacağını veritabanlarına özgü PDO sürücüleri sayfasından öğrenebilirsiniz. Yalnız dikkat: PDO eklentisini bir paylaşımlı eklenti olarak (bu önerilmez) derliyorsanız tüm PDO sürücülerinin PDO'nun kendisinden sonra yüklenmesine dikkat etmelisiniz.

  2. PDO eklentisini bir paylaşımlı eklenti olarak kuruyorsanız, PHP çalıştığı zaman PDO eklentisinin özdevinimli olarak yüklenmesi için php.ini dosyasını buna göre düzenlemeniz gerekir. Ayrıca kullanacağınız veritabanına özgü sürücülerinde dosyada etkin kılınması gerekir. Bunu yaparken bunların pdo.so satırından sonra listelenmesine dikkat etmelisiniz. Çünkü, PDO eklentisinin veritabanlarına özgü eklentiler yüklenmeden önce ilklendirilmesi gerekir. PDO'yu ve veritabanlarına özgü eklentileri duruk olarak derliyorsanız php.ini adımını atlayabilirsiniz.

    extension=pdo.so

Windows kullanıcıları

  1. PDO ve belli başlı sürücülerin tamamı, birer paylaşımlı eklenti olarak PHP ile birlikte gelir ve php.ini dosyasında etkin kılınmaları gerekir:

    extension=php_pdo.dll

  2. Bu satırın ardına veritabanlarına özgü eklentilerin DLL dosyalarını aşağıdaki gibi ekleyebilir veya dl() ile çalışma anında da yükleyebilirsiniz.

    extension=php_pdo.dll
extension=php_pdo_firebird.dll
extension=php_pdo_informix.dll
extension=php_pdo_mssql.dll
extension=php_pdo_mysql.dll
extension=php_pdo_oci.dll
extension=php_pdo_oci8.dll
extension=php_pdo_odbc.dll
extension=php_pdo_pgsql.dll
extension=php_pdo_sqlite.dll

    Bu DLL'lerin hepsinin extension_dir yönergesinde belirtilen dizinde bulunması gerektiğini unutmayın.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

PDO Yapılandırma Yönergeleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
pdo.dsn.* |  | sadece php.ini dosyasında |
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

pdo.dsn.* string

DSN için rumuz tanımları. Ayrıntılar için PDO::__construct() yönteminin açıklamasına bakınız.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

Uyarı

PDO eklentisi, PHP 5.1'den bu yana sınıf sabitlerini kullanmaktadır. Daha önceki sürümlerinde PDO_PARAM_BOOL biçiminde küresel sabitler kullanılır.

PDO::PARAM_BOOL (integer)
Mantıksal veri türünü ifade eder.
PDO::PARAM_NULL (integer)
SQL NULL veri türünü ifade eder.
PDO::PARAM_INT (integer)
SQL INTEGER veri türünü ifade eder.
PDO::PARAM_STR (integer)
SQL CHAR, VARCHAR ve benzeri dizge veri türlerini ifade eder.
PDO::PARAM_LOB (integer)
SQL büyük nesne veri türünü ifade eder.
PDO::PARAM_STMT (integer)
Kayıt kümesi (recordset) türünü ifade eder. Her sürücü desteklemez.
PDO::PARAM_INPUT_OUTPUT (integer)
Değiştirgenin bir saklı yordam için bir girdi/çıktı değiştirgesi olduğunu gösterir. Bu değeri bir PDO::PARAM_* veri türü ile bit seviyesinde VEYAlamanız gerekir.
PDO::FETCH_LAZY (integer)
Yöntemin, sonuç kümesindeki her satırı, değişken isimlerinin sütun isimlerine karşılık geldiği bir nesne olarak döndüreceğini belirtir. PDO::FETCH_LAZY sütun isimlerine nesnenin değişkenleri olarak erişilebilmesini sağlar. PDOStatement::fetchAll() içinde geçersizdir.
PDO::FETCH_ASSOC (integer)
Yöntemin, sonuç kümesindeki her satırının, sütun isimleriyle indislenmiş bir dizi olarak döndürüleceğini belirtir. Eğer sonuç kümesi aynı isimde birden fazla sütun içeriyorsa her sütun için tek bir değer döner.
PDO::FETCH_NAMED (integer)
Yöntemin, sonuç kümesindeki her satırının, sütun isimleriyle indislenmiş bir dizi olarak olarak döndüreleceğini belirtir. Eğer sonuç kümesi aynı isimde birden fazla sütun içeriyorsa her sütun için bir değerler dizisi döner.
PDO::FETCH_NUM (integer)
Yöntemin, sonuç kümesindeki her satırının, sütun numaralarıyla indislenmiş bir dizi olarak olarak döndüreleceğini belirtir. İlk sütunun indisi 0'dır.
PDO::FETCH_BOTH (integer)
Yöntemin, sonuç kümesindeki her satırının, hem sütun isimleriyle hem de sütun numaralarıyla indislenmiş bir dizi olarak olarak döndürüleceğini belirtir. İlk sütunun indisi 0'dır.
PDO::FETCH_OBJ (integer)
Yöntemin, sonuç kümesindeki her satırının, özellik isimlerinin sütun isimlerine karşılık geldiği bir nesne olarak döndüreceğini belirtir.
PDO::FETCH_BOUND (integer)
Yöntemin, sonuç kümesindeki sütun değerlerini PDOStatement::bindParam() veya PDOStatement::bindColumn() yönteminde SQL değiştirgeleri ile ilişkilendirilip PHP değişkenlerine atanacağını ve TRUE döndürüleceğini belirtir.
PDO::FETCH_COLUMN (integer)
Yöntemin, sonuç kümesindeki sonraki satırdan istenen tek bir sütunu döndüreceğini belirtir.
PDO::FETCH_CLASS (integer)
Yöntemin, sınıf özellikleri sütun isimleriyle eşlenerek elde edilen sınıfın yeni bir örneğini döndüreceğini belirtir.

Bilginize: İstenen sınıf içinde özellik mevcut değilse sihirli __set() yöntemi çağrılır.

PDO::FETCH_INTO (integer)
Yöntemin, sınıf özellikleri sütun isimleriyle eşlenerek elde edilen sınıfın mevcut bir örneğini güncelleyeceğini belirtir.
PDO::FETCH_FUNC (integer)
Verinin anında işlenmesi yoluyla tamamen özelleştirmeye izin verir (sadece PDOStatement::fetchAll() içinde geçerlidir).
PDO::FETCH_GROUP (integer)
Grup değer olarak döner. Normal olarak PDO::FETCH_COLUMN veya PDO::FETCH_KEY_PAIR ile birlikte.
PDO::FETCH_UNIQUE (integer)
Sadece eşsiz değerleri getirir.
PDO::FETCH_KEY_PAIR (integer)
İlk sütunun anahtar diğer sütunların ise birer değer olduğu bir dizi döner. PHP 5.2.3'ten beri kullanılabilmektedir.
PDO::FETCH_CLASSTYPE (integer)
Sütun ismini ilk sütunun değerinden belirler.
PDO::FETCH_SERIALIZE (integer)
Nesnenin dizgeleştirilmiş olark döndürülmesi dışında PDO::FETCH_INTO gibidir. PHP 5.1.0'dan beri kullanılabilmektedir. PHP 5.3.0'dan beri bu seçenek etkinken sınıf kurucusu asla çağrılmamaktadır.
PDO::FETCH_PROPS_LATE (integer)
Özellikler değiştirilmeden önce kurucuyu çağırır. PHP 5.2.0'dan beri kullanılabilmektedir.
PDO::ATTR_AUTOCOMMIT (integer)
FALSE olduğu takdirde, PDO özdevinimli veri gönderimini iptal eder, böylece bağlantı bir veri hareketi (transaction) başlatır.
PDO::ATTR_PREFETCH (integer)
Önalım boyutunun ayarlanması uygulamanızın bellek kullanım hızını dengeleyebilmenizi sağlar. Her veritabanı/sürücü önalım boyutunun ayarlanmasına izin vermez. Önalım boyutu ne kadar büyük seçilirse yüksek bellek kullanımı pahasına başarım o kadar artar.
PDO::ATTR_TIMEOUT (integer)
Veritabanıyla iletişim zaman aşımını belirlemek için kullanılır.
PDO::ATTR_ERRMODE (integer)
Bu sabit ile ilgili bilgi için Hatalar ve Ele Alınışları bölümüne bakınız.
PDO::ATTR_SERVER_VERSION (integer)
Bu salt okunur bir özelliktir. PDO'nun bağlı olduğu veritabanı sunucusunun sürüm bilgisini döndürür.
PDO::ATTR_CLIENT_VERSION (integer)
Bu salt okunur bir özelliktir. PDO sürücüsünün kullandığı istemci kütüphanesinin sürüm bilgisini döndürür.
PDO::ATTR_SERVER_INFO (integer)
Bu salt okunur bir özelliktir. PDO'nun bağlı olduğu veritabanı sunucusu hakkında bazı temel bilgileri döndürür.
PDO::ATTR_CONNECTION_STATUS (integer)
PDO::ATTR_CASE (integer)
Sütun isimlerindeki harflerin PDO::CASE_* sabitlerine göre belirtilmesini sağlar.
PDO::ATTR_CURSOR_NAME (integer)
Bir gösterici için kullanılacak ismi tanımlar veya döndürür. Kaydırılabilir göstericiler ve konum belirterek yapılan güncelemeler için çok kullanışlıdır.
PDO::ATTR_CURSOR (integer)
Gösterici türünü seçer. Desteklenen gösterici türleri: PDO::CURSOR_FWDONLY ve PDO::CURSOR_SCROLL. İhtiyacınızın kaydırılabilir bir gösterici olup olmadığına dair bir fikriniz yoksa seçiminizi PDO::CURSOR_FWDONLY sabitinden yana kullanın.
PDO::ATTR_DRIVER_NAME (string)
Sürücü ismini döndürür.

Örnek 1 - PDO::ATTR_DRIVER_NAME kullanımı

<?php
if ($db->getAttribute(PDO::ATTR_DRIVER_NAME) == 'mysql') {
  echo "Burada mysql üzerinde mysql'e özgü bir şeyler yapılıyor\n";
}
?>

PDO::ATTR_ORACLE_NULLS (integer)
Veri alınırken SQL NULL değerleri boş dizgelere dönüştürür.
PDO::ATTR_PERSISTENT (integer)
Yeni bir bağlantı oluşturmak yerine kalıcı bir bağlantı ister. Ayrıntılı bilgi için Bağlantılar ve Bağlantı Yönetimi sayfasına bakınız.
PDO::ATTR_STATEMENT_CLASS (integer)
PDO::ATTR_FETCH_CATALOG_NAMES (integer)
Sonuç kümesinde döndürülen her sütun isminin başına katalog ismini yerleştirir. Katalog ismi ile sütun ismi arasına bir nokta konur. Bu özellik sürücü seviyesinde desteklenir; kullandığınız sürücü bu özelliği desteklemeyebilir.
PDO::ATTR_FETCH_TABLE_NAMES (integer)
Sonuç kümesinde döndürülen her sütun isminin başına tablo ismini yerleştirir.Tablo ismi ile sütun ismi arasına bir nokta konur. Bu özellik sürücü seviyesinde desteklenir; kullandığınız sürücü bu özelliği desteklemeyebilir.
PDO::ATTR_STRINGIFY_FETCHES (integer)
PDO::ATTR_MAX_COLUMN_LEN (integer)
PDO::ATTR_DEFAULT_FETCH_MODE (integer)
PHP 5.2.0'dan beri kullanılabilmektedir.
PDO::ATTR_EMULATE_PREPARES (integer)
PHP 5.1.3'ten beri kullanılabilmektedir.
PDO::ERRMODE_SILENT (integer)
Bir hata oluştuğunda bir istisna veya bir hata döndürülmez. Geliştiricinin hataları yakalayıp gereğini yapacağı varsayılır. Bu öntanımlı kiptir. Bu özellik ile ilgili ayrıntılı bilgi için Hatalar ve Ele Alınışları sayfasına bakınız.
PDO::ERRMODE_WARNING (integer)
Bir hata oluştuğunda bir PHP E_WARNING iletisi çıktılanır. Bu özellik ile ilgili ayrıntılı bilgi için Hatalar ve Ele Alınışları sayfasına bakınız.
PDO::ERRMODE_EXCEPTION (integer)
Bir hatanın oluşması bir PDOException istisnası ile sonuçlanır. Bu özellik ile ilgili ayrıntılı bilgi için Hatalar ve Ele Alınışları sayfasına bakınız.
PDO::CASE_NATURAL (integer)
Sütun isimleri veritabanı sürücüsünün döndürdüğü haliyle bırakılır.
PDO::CASE_LOWER (integer)
Sütun isimlerinin küçük harflerle yazılmasına sebep olur.
PDO::CASE_UPPER (integer)
Sütun isimlerinin büyük harflerle yazılmasına sebep olur.
PDO::NULL_NATURAL (integer)
PDO::NULL_EMPTY_STRING (integer)
PDO::NULL_TO_STRING (integer)
PDO::FETCH_ORI_NEXT (integer)
Sonuç kümesindeki sonraki satırı döndürür. Sadece kaydırılabilir göstericiler için geçerlidir.
PDO::FETCH_ORI_PRIOR (integer)
Sonuç kümesindeki önceki satırı döndürür. Sadece kaydırılabilir göstericiler için geçerlidir.
PDO::FETCH_ORI_FIRST (integer)
Sonuç kümesindeki ilk satırı döndürür. Sadece kaydırılabilir göstericiler için geçerlidir.
PDO::FETCH_ORI_LAST (integer)
Sonuç kümesindeki son satırı döndürür. Sadece kaydırılabilir göstericiler için geçerlidir.
PDO::FETCH_ORI_ABS (integer)
İstenen satırı sonuç kümesindeki satır numarasına göre döndürür. Sadece kaydırılabilir göstericiler için geçerlidir.
PDO::FETCH_ORI_REL (integer)
İstenen satırı, göstericinin sonuç kümesindeki konumuna göreli olarak döndürür. Sadece kaydırılabilir göstericiler için geçerlidir.
PDO::CURSOR_FWDONLY (integer)
Sadece ileri yönde hareket eden bir göstericiye sahip bir PDOStatement nesnesi oluşturur. PHP'deki en hızlı ve en çok kullanılan veriye erişim yöntemi olarak bu gösterici öntanımlı göstericidir.
PDO::CURSOR_SCROLL (integer)
Kaydırılabilir göstericili bir PDOStatement nesnesi oluşturur. Satırların sonuç kümesinden nasıl döndürüleceğini belirtmek için PDO::FETCH_ORI_* sabitlerini kullanın.
PDO::ERR_NONE (string)
SQL deyiminin hatasız ve uyarısız başarıyla çalıştırıldığı anlamına gelen SQLSTATE '00000' karşılığıdır. Bir hata oluştuğunda hatayı PDO::errorCode() veya PDOStatement::errorCode() ile saptarken kolaylık olsun diye bu sabit vardır. Bunu normal olarak yöntemden dönen kodu inceleyerek saptayabilirsiniz.
PDO::PARAM_EVT_ALLOC (integer)
Kaynak ayırma olayı.
PDO::PARAM_EVT_FREE (integer)
Ayrılan kaynağı serbest bırakma olayı.
PDO::PARAM_EVT_EXEC_PRE (integer)
Bir hazır deyimi çalıştırmadan önce tetiklenen olay.
PDO::PARAM_EVT_EXEC_POST (integer)
Bir hazır deyimi çalıştırıldıktan hemen sonra tetiklenen olay.
PDO::PARAM_EVT_FETCH_PRE (integer)
Bir sonuç kümesinden bir sonucun alınmasından önce tetiklenen olay.
PDO::PARAM_EVT_FETCH_POST (integer)
Bir sonuç kümesinden bir sonucun alınmasının ardından tetiklenen olay.
PDO::PARAM_EVT_NORMALIZE (integer)
Sürücünün değiştirge isminin normalleştirilmesini sağlamak için ilişkili değiştirgenin kayda geçirilmesi sırasında tetiklenen olay.
Özkaynak Türleri
Bağlantılar ve Bağlantı Yönetimi
PDO


Bağlantılar ve Bağlantı Yönetimi

Bağlantılar temel PDO sınıfının örneklenmesiyle kurulur. Hangi sürücüyü kullanacağınızın bir önemi yoktur; daima PDO sınıf ismini kullanmanız gerekir. Veritabanı kaynağını (diğer bir deyişle DSN' i) ve isteğe bağlı olarak kullanıcı ismini ve parolasını belirtmek için kurucuyu kullanabilirsiniz.

Örnek 1 - MySQL'e bağlanma

<?php
$dbh = new PDO('mysql:host=localhost;dbname=test', $user, $pass);
?>

Bir hata oluşursa bu bir PDOException istisnasına sebep olur. Hatayı ele almak için istisnayı yakalayabilir veya işi set_exception_handler() üzerinden ayarladığınız bir küresel hata işleme uygulamasına bırakabilirsiniz.

Örnek 2 - Bağlantı hatalarının ele alınışı

<?php
try {
    $dbh = new PDO('mysql:host=localhost;dbname=test', $user, $pass);
    foreach($dbh->query('SELECT * from FOO') as $row) {
        print_r($row);
    }
    $dbh = null;
} catch (PDOException $e) {
    print "Hata!: " . $e->getMessage() . "<br/>";
    die();
}
?>

Uyarı

Uygulamanız, PDO kurucusu tarafından tetiklenen istisnayı yakalamazsa betiği sonlandırıp bir hata geri izlemesi oluşturmak için denetim öntanımlı olarak zend motoruna geçer. Bu geri izleme, kullanıcı ismi ve parola dahil veritabanı bağlantısıyla ilgili tüm ayrıntıları ortaya döker. Bu istisnayı yakalamak sizin sorumluluğunuzdadır. Bunu ya doğrudan catch deyimiyle ya da örtük olarak set_exception_handler() üzerinden yaparsınız.

Veritabanı bağlantısının başarıyla kurulmasıyla betiğinize PDO sınıfının bir örneği döner. PDO nesnesinin ömrü boyunca bağlantı etkin kalır. Bağlantıyı kapatmak için, nesneye gönderimli herşeyin silindiğinden emin olarak nesneyi yok etmeniz gerekir; bunu nesneyi tutan değişkene NULL atayarak yapabilirsiniz. Bunu siz yapmazsanız, PHP betiğiniz sonlandığında bunu sizin yerinize yapacaktır.

Örnek 3 - Bir bağlantının kapatılışı

<?php
$dbh = new PDO('mysql:host=localhost;dbname=test', $user, $pass);
// burada bağlantıyı kullanıyoruz

// İşimiz bittiğine göre bağlantıyı kapatabiliriz.
$dbh = null;
?>

Çoğu HTTP uygulaması veritabanı sunucularına kalıcı bağlantılardan medet umar. Kalıcı bağlantılar betiğin işi bittiğinde kapatılmaz, önbelleğe alınıp aynı kimlik kanıtlarıyla bağlantı kurmak isteyen başka betiklerce kullanılır. Kalıcı bağlantı önbelleği, bir betiğin bir veritabanı ile her iletişime geçme isteğinde yeni bir bağlantı kurma maliyetini ortadan kaldırır ve uygulamanın daha hızlı çalışmasını sağlar.

Örnek 4 - Kalıcı bağlantılar

<?php
$dbh = new PDO('mysql:host=localhost;dbname=test', $user, $pass, array(
    PDO::ATTR_PERSISTENT => true
));
?>

Bilginize:

Kalıcı bağlantı kullanmak için PDO kurucusuna aktarılan sürücü seçenekleri dizisinde PDO::ATTR_PERSISTENT sabitine TRUE atamalısınız. Nesneyi ilklendirdikten sonra bu özelliği etkin kılmak isterseniz sürücü kalıcı bağlantıları kullanmayacaktır.

Bilginize:

PDO ODBC sürücüsünü kullanıyorsanız ve ODBC küüphaneleriniz ODBC Bağlantı Havuzlarını destekliyorsa (hem unixODBC hem de Windows bunu yapar; başkaları da olabilir) kalıcı PDO bağlantılarını kullanmanız önerilmez; bağlantı önbelleklemesini ODBC Bağlantı Havuzlama katmanına bırakmak daha iyidir. ODBC Bağlantı Havuzu bağlantıyı süreçteki diğer modüllerle paylaşır; eğer PDO bağlantıyı önbelleklemeye çalışırsa bu bağlantı asla ODBC bağlantı havuzuna dönmez ve sonuçta diğer modüllere hizmet vermek için ek bağlantılar oluşur.

Öntanımlı Sabitler
Hareketler ve özdevinimli işlemler
PDO


Hareketler ve özdevinimli işlemler

Bir veritabanına PDO üzerinden bağlantı kuracaksanız, sorgulara başlamadan PDO'nun toplu hareketleri nasıl yönettiğini bilmek zorundasınız. Daha önce toplu hareketler (İngilizce'de transactions denen şey) ile çalışmadıysanız şu dört ana özelliği bilmenizde yarar var: Dayanıklılık, Atomsallık, Yalıtım ve Tutarlılık (DAYT). Layman kuralları gereğince, bir toplu hareket olarak yürütülen bir işleme başlanıldığı takdirde, aşamalar halinde bile yürütülse, diğer bağlantılarla etkileşime girmeksizin veritabanına güvenle uygulanacağı garanti edilir. Ayrıca, toplu hareketler, istediğiniz taktirde (sanki işleme hiç başlamamışsınız gibi) özdevinimli olarak geri alınır ve betiğinizin hatalarla daha kolay başa çıkmasını sağlar.

Toplu hareketler genellikle bir defada uygulanacak işlemlerin bir betik (bir SQL deyimleri betiği) haline getirilmesiyle oluşur. Bunun bu güncellemelerin verimliliğini esaslı bir şekilde arttırmak gibi bir yan etkisi de vardır. Başka bir deyişle, toplu hareketler betiğinizin daha hızlı ve daha tutarlı çalışmasını sağlar (ancak, bunu sağlamak için toplu hareketleri doğru yerde kullanmanız gerekir).

Talihsizliğe bakın ki, her veritabanı toplu hareketleri desteklemez, bu yüzden PDO, önce bağlantı açımasını gerektiren ve özdevinimli işlem kipi denen kipte çalışmak zorunda kalır. Özdevinimli işlem kipinde, çalıştırdığınız her sorgu veritabanı hareketleri destekliyorsa dolaylı olarak bir harekettir, desteklemiyorsa değildir. İhtiyacınız toplu hareketleri kullanmaksa hareketleri ilklendirmek için PDO::beginTransaction() yöntemini kullanmalısınız. Eğer kullanmaya çalıştığınız veritabanı toplu hareketleri desteklemiyorsa bir PDOException istisnası oluşur (hata işleme ayarlarınızdan bağımsız olarak: bu daima bir dizi hata durumundan oluşur). Bir toplu hareketi ilklendirdikten sonra hareketi başlatmak için PDO::commit(), hareketler yerine getirilirken çalıştırdığınız kodun başarı durumuna bağlı olarak hareketleri geri almak için PDO::rollBack() yöntemini kullanabilirsiniz.

Bir toplu hareket veritabanına gönderilmişken bir nedenle betiğiniz sonlanırsa veya bağlantı kapatılmaya çalışılırsa PDO özdevinimli olarak hareketleri geri alır. Bu, betiğin beklenmedik durumlarda sonlanmasına karşı veritabanındaki verilerin tutarsız hale gelmesini önleyecek bir güvenlik önlemidir. Ancak toplu hareketleri doğrudan siz başlatmadıysanız bir şeyler zaten yolunda gitmemiş demektir, dolayısıyla verilerinizin güvenliği için hareketlere başa sarma işlemi uygulanır.

Uyarı

Özdevinimli başa sarma işlemi sadece toplu hareketler PDO::beginTransaction() üzerinden ilklendirildiğinde uygulanır. Bir toplu hareket PDO'sunu başlatan bir sorguyu el yordamıyla kendiniz başlatırsanız, neler olacağı bilinemez ve yanlış giden bir şeyler olursa bunlar geri alınamaz.

Örnek 1 - Bir toplu hareket betiğinin çalıştırılması

Aşağıdaki örnekte, yeni bir çalışan için 23 numaralı bir girdi kümesi oluşturduğumuzu varsayıyoruz. Şahıs için girilen temel bilgilere ilaveten ücretini de kaydedeceğiz. Bu basit işlemi iki ayrı güncelleme ile yapmak mümkünse de bu iki deyimi PDO::beginTransaction() ve PDO::commit() çağrılarının arasına alıp bir sebeple işlem tamamlanamazsa yapılanların geri alınmasını garantilemiş olacağız. Eğer bir şeyler yolunda gitmezse catch kümesi haraket başladığından beri yapılan işlemleri geri alır ve bir hata iletisi basar.

<?php
try {
  $dbh = new PDO('odbc:SAMPLE', 'db2inst1', 'ibmdb2',
      array(PDO::ATTR_PERSISTENT => true));
  echo "Bağlantı kuruldu\n";
  $dbh->setAttribute(PDO::ATTR_ERRMODE, PDO::ERRMODE_EXCEPTION);

  $dbh->beginTransaction();
  $dbh->exec("insert into staff (id, first, last) values (23, 'Joe', 'Bloggs')");
  $dbh->exec("insert into salarychange (id, amount, changedate)
      values (23, 50000, NOW())");
  $dbh->commit();

} catch (Exception $e) {
  $dbh->rollBack();
  echo "İşlem başarısız oldu: " . $e->getMessage();
}
?>

Güncellemeleri birer toplu hareket olarak yapmak zorunda değilsiniz. Almak istediğiniz veriler için karmaşık sorgular yapabileceğiniz gibi elde ettiğiniz verilerle başka sorgular ve güncellemeler yapmanızda da mümkündür. Ancak, bu arada bir toplu hareket işlemi yürütülüyorsa, bu çalışmanın ortasında kimsenin hiçbir veriyi değiştiremeyeceği garanti altındadır. Toplu hareketlerle ilgili daha ayrıntılı bilgi için veritabanı sunucunuzun belgelerine bakınız.

Bağlantılar ve Bağlantı Yönetimi
Hazır deyimler ve Saklı Yordamlar
PDO


Hazır deyimler ve Saklı Yordamlar

Genellikle gelişkin veritabanlarınca desteklenen, hazır deyimler diye bilinen bir kavram vardır. Bunlar nedir? Bunları bir takım değiştirgelerle özelleştirilebilen, SQL için derlenmiş şablonlar olarak düşünebilirsiniz. Hazır deyimlerin başlıca iki yararı vardır:

  • Sorgunun tek bir defa çözümlenmesi (veya hazırlanması) gerekir fakat aynı veya farklı değiştirgelerle defalarca çalıştırılabilir. Sorgu hazır olduğunda veritabanınca incelenir, derlenip sorgunun amacına uygun olarak en iyilenir. Karmaşık sorgularda aynı sorguyu farklı değiştirgelerle defalarca yineleyecekseniz işlemler, uygulamanızı farkedilir şekilde yavaşlatacak kadar uzun sürebilir. Hazır deyimleri kullanarak her yinelemede tekrarlanan inceleme/derleme/eniyileme döngüsünden kurtulabilirsiniz. Özetle, hazır deyimler daha az özkaynak kullandığından daha hızlı çalışır.
  • Hazır deyim değiştirgelerinin öncelenmesi gerekmez. Bu işlemi sürücüler sizin yerinize yapar. Uygulamanız özellikle hazır deyimleri kullanıyorsa hiçbir SQL zerkinin olmayacağından emin olabilirsiniz. (Ancak, sorgunun diğer parçaları öncelenmemiş girdiler içeriyorsa hala risk altındasınız demektir.)

Hazır deyimleri kullanmanın bir başka yararı da bunları desteklemeyen sürücüler için PDO'nun bu özelliği taklit etmesidir (PDO'nun taklit ettiği tek özellik budur). Böylece aynı veri erişim uygulamasını veritabanınızın yeteneklerinden bağımsız olarak kullanabilirsiniz.

Örnek 1 - Hazır deyimlerle değiştirge ismine göre veri girişi

Bu örnekte isim ve deger alanlarına değiştirgelerin isimlerine göre bir INSERT sorgusu ile defalarca veri girilmektedir.

<?php
$deyim = $dbh->prepare(
          "INSERT INTO KUTUK (isim, deger) VALUES (:isim, :deger)");
$deyim->bindParam(':isim', $isim);
$deyim->bindParam(':değer', $değer);

// bir satıra veri girelim
$isim = 'bir';
$değer = 1;
$deyim->execute();

// farklı değerlerle bir satır daha girelim
$isim = 'iki';
$değer = 2;
$deyim->execute();
?>

Örnek 2 - Hazır deyimlerle değiştirge indisine göre veri girişi

Bu örnekte isim ve deger alanlarına değiştirgelerin indislerine göre bir INSERT sorgusu ile defalarca veri girilmektedir.

<?php
$deyim = $dbh->prepare("INSERT INTO KUTUK (isim, değer) VALUES (?, ?)");
$deyim->bindParam(1, $isim);
$deyim->bindParam(2, $değer);

// bir satıra veri girelim
$isim = 'bir';
$değer = 1;
$deyim->execute();

// farklı değerlerle bir satır daha girelim
$isim = 'iki';
$değer = 2;
$deyim->execute();
?>

Örnek 3 - Hazır deyimle veri almak

Bu örnekte bir formdan sağlanan bir anahtar değere dayanarak veritabanından veri alınmaktadır. Kullanıcı girdisi özdevinimli olarak öncelenmekte, dolayısıya bir SQL zerki riski ortaya çıkmamaktadır.

<?php
$deyim = $dbh->prepare("SELECT * FROM KUTUK where isim = ?");
if ($deyim->execute(array($_GET['isim']))) {
  while ($satır = $deyim->fetch()) {
    print_r($satır);
  }
}
?>

Eğer veritabanı sürücüsü değiştirge ilişkilendirmeyi destekiyorsa değiştirgeleri sadece girdide değil çıktıda da değiştirgelerle ilişkilendirebilirsiniz. Çıktı değiştirgelerinin kullanımı girdi değiştirgelerine göre daha karmaşıktır. Böyle bir durumda ilişkilendirdiğiniz değiştirge sayısını bilmeniz gerekir. Eğer dönen değer önerdiğinizden daha büyükse bir hata oluşur.

Örnek 4 - Bir saklı yordamın çıktı değiştirgesi ile kullanımı

<?php
$deyim = $dbh->prepare("CALL sy_dizge_döndürür(?)");
$deyim->bindParam(1, $dönen_değer, PDO::PARAM_STR, 4000);

// call the stored procedure
$deyim->execute();

print "dönen değer: $dönen_değer\n";
?>

Ayrıca, değerleri tutan değiştirgeleri hem girdi hem de çıktı için kullanabilirsiniz. Sonraki örnekte, saklı yordama 'merhaba' dizgesi aktarılmakta, yordam döndüğünde 'merhaba' yerine yordamın dönüş değeri yerleştirilmektedir.

Örnek 5 - Bir saklı yordamın girdi/çıktı değiştirgesi ile kullanımı

<?php
$deyim = $dbh->prepare("CALL sy_dizge_alır_dizge_döndürür(?)");
$değer = 'merhaba';
$deyim->bindParam(1, $değer, PDO::PARAM_STR|PDO::PARAM_INPUT_OUTPUT, 4000);

// saklı yordamı çağıralım
$deyim->execute();

print "dönen değer: $değer\n";
?>

Örnek 6 - Geçersiz değiştirge kullanımı

<?php
$deyim = $dbh->prepare("SELECT * FROM KUTUK where isim LIKE '%?%'");
$deyim->execute(array($_GET['isim']));

// değiştirge değerin yerinde kullanılmalı
$deyim = $dbh->prepare("SELECT * FROM KUTUK where isim LIKE ?");
$deyim->execute(array("%$_GET[isim]%"));
?>

Hareketler ve özdevinimli işlemler
Hatalar ve Ele Alınışları
PDO


Hatalar ve Ele Alınışları

PDO eklentisi uygulama geliştirme tarzınıza uygun olarak üç farklı hata işleme yönteminden birini seçmenize olanak verir.

  • PDO::ERRMODE_SILENT

    Bu öntanımlı kiptir. PDO, gerek veritabanı gerekse deyim nesneleri üzerinde PDO::errorCode() ve PDO::errorInfo() işlevlerini kullanarak hata kodunu sizin için hazır hale getirir. Eğer hata bir deyim nesnesiyle ilgili bir işlev veya yöntem çağrısından kaynaklanmışsa bu nesne üzerinde PDOStatement::errorCode() veya PDOStatement::errorInfo() işlevini kendiniz çağırmalısınız. Eğer hata bir veritabanı nesnesiyle ilgili bir işlev veya yöntem çağrısından kaynaklanmışsa bu işlevleri bu kez veritabanı nesnesi üzerinde çağırmalısınız.

  • PDO::ERRMODE_WARNING

    Hata kodu ayarlarına ek olarak, PDO geleneksel bir E_WARNING uyarısı da verir. Bu kip, hata ayıklama ve denemeler sırasında uygulama akışının kesilmeden oluşan sorunları görmek için kullanışlıdır.

  • PDO::ERRMODE_EXCEPTION

    Hata kodu ayarlarına ek olarak, PDO bir PDOException istisnası oluşturup hata kodunu ve iletisini nesnenin özelliklerine yerleştirir. Bu kip de hata ayıklama sırasında uygulama akışının kesilmeden oluşan sorunları çabucak görüp müdahale etmek için kullanışlıdır. (Dikkat: Eğer istisna betiğin sonlanmasına sebep olursa veri hareketleri (transactions) özdevinimli olarak başa sarılır.)

    Bu kip bir istisna nesnesi ile çalıştığından, hataların, her veritabanı çağrısında dönen değere bakmaktan, sessiz kipi kullanmaktan ve geleneksel PHP tarzı uyarılardan daha iyi ve daha kolay işleme sokulmasını sağlar.

    PHP'deki istisna nesneleri hakkında bilgi edinmek için İstisnalar bölümüne bakınız.

PDO SQL-92 SQLSTATE hata kodu dizgelerinin kulanımını standartlaştırmıştır; her PDO sürücüsü kendi kodunu SQLSTATE kodlarına uydurmakla yükümlüdür. PDO::errorCode() yöntemi tek bir SQLSTATE kodu döndürür. Bir hata ile ilgili daha özel bilgiye gerek duyulursa, SQLSTATE kodundan başka sürücüye özgü hata kodunu ve iletisini içeren bir dizi döndüren PDO::errorInfo() yöntemi kullanılabilir.

Hazır deyimler ve Saklı Yordamlar
Büyük Veri Nesneleri (LOB'lar)
PDO


Büyük Veri Nesneleri (LOB'lar)

Uygulamanızın bir yerinde veritabanınızda büyük müktarda veri saklamanız gerekebilir. Burada büyük veriden kasıt 4kB civarı olsa da bazı veritabanları için büyük veri 32kB'tan başlar. Büyük veriler ikil veya dizgesel olabilir. PDOStatement::bindParam() ve PDOStatement::bindColumn() çağrılarında büyük verilerlerle çalışmak için PDO::PARAM_LOB veri türünü kullanabilirsiniz. PDO::PARAM_LOB, verinin bir akım olarak eşleneceği anlamına gelir. Dolayısıyla, bu veriler üzerinde PHP Akım işlevleri ile işlem yapabilirsiniz.

Örnek 1 - Veritabanındaki bir resmin gösterilmesi

Bu örnekte bir LOB, $lob değişkeni ile ilişkilendirilmekte ve
fpassthru() üzerinden tarayıcıya gönderilmektedir. LOB
bir akımla temsil edildiğinden fgets(),
fread() ve stream_get_contents()
gibi işlevlerle üzerinde işlem yapabilirsiniz.

<?php
$db = new PDO('odbc:SAMPLE', 'db2inst1', 'ibmdb2');
$stmt = $db->prepare("select contenttype, imagedata from images where id=?");
$stmt->execute(array($_GET['id']));
$stmt->bindColumn(1, $type, PDO::PARAM_STR, 256);
$stmt->bindColumn(2, $lob, PDO::PARAM_LOB);
$stmt->fetch(PDO::FETCH_BOUND);

header("Content-Type: $type");
fpassthru($lob);
?>

Örnek 2 - Bir resmin veritabanına yerleştirilmesi

Bu örnekte bir dosya açılıp, bir LOB olarak veritabanına yerleştirilmek üzere, dosya tanıtıcısı PDO'ya aktarılmaktadır. PDO, dosya içeriğini veritabanına yerleştirme işlemini en verimli şekilde yapacaktır.

<?php
$db = new PDO('odbc:SAMPLE', 'db2inst1', 'ibmdb2');
$stmt = $db->prepare("insert into images (id, contenttype, imagedata) values (?, ?, ?)");
$id = get_new_id(); // Yeni bir kimlik ayıran bir işlev

// Resmin bir dosya yükleme formundan geldiğini varsayıyoruz
// PHP belgelerinde  bu konuda ayrıntılı bilgi bulabilirsiniz

$fp = fopen($_FILES['file']['tmp_name'], 'rb');

$stmt->bindParam(1, $id);
$stmt->bindParam(2, $_FILES['file']['type']);
$stmt->bindParam(3, $fp, PDO::PARAM_LOB);

$db->beginTransaction();
$stmt->execute();
$db->commit();
?>

Örnek 3 - Oracle'da bir resmi veritabanına yerleştirmek

Oracle, bir LOB'u bir dosyadan alıp veritabanına yerleştirirken farklı bir sözdizimi kullanımını gerektirir. Esas olarak, yerleştirme işlemi bir toplu hareket olarak gerçekleştirilir. Böyle yapılmazsa oluşturulan LOB, sorgu çalıştırıldığında örtük olarak sıfır uzunluklu bir veri girişinin parçası haline gelir.

<?php
$db = new PDO('oci:', 'scott', 'tiger');
$stmt = $db->prepare("insert into images (id, contenttype, imagedata) " .
"VALUES (?, ?, EMPTY_BLOB()) RETURNING imagedata INTO ?");

$id = get_new_id(); // Yeni bir kimlik ayıran bir işlev

// Resmin bir dosya yükleme formundan geldiğini varsayıyoruz
// PHP belgelerinde  bu konuda ayrıntılı bilgi bulabilirsiniz
$fp = fopen($_FILES['file']['tmp_name'], 'rb');

$stmt->bindParam(1, $id);
$stmt->bindParam(2, $_FILES['file']['type']);
$stmt->bindParam(3, $fp, PDO::PARAM_LOB);

$stmt->beginTransaction();
$stmt->execute();
$stmt->commit();
?>

Hatalar ve Ele Alınışları
PDO
PDO


PDO sınıfı

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

Giriş

PHP ile bir veritabanı sunucusu arasındaki bağlantıyı temsil eder.

Sınıf Sözdizimi

PDO {
__construct ( string $dsn [, string $kullanıcı [, string $parola [, array $seçenekler ]]] )
bool beginTransaction ( void )
bool commit ( void )
mixed errorCode ( void )
array errorInfo ( void )
int exec ( string $deyim )
mixed getAttribute ( int $öznitelik )
array getAvailableDrivers ( void )
public bool inTransaction ( void )
string lastInsertId ([ string $isim = NULL ] )
PDOStatement prepare ( string $deyim [, array $seçenekler = array() ] )
PDOStatement query ( string $deyim )
string quote ( string $dizge [, int $değiştirge_türü = PDO::PARAM_STR ] )
bool rollBack ( void )
bool setAttribute ( int $öznitelik , mixed $değer )
}

İçindekiler

  • PDO::beginTransaction — Bir toplu hareketi ilklendirir
  • PDO::commit — Bir toplu hareketi veritabanına gönderir
  • PDO::__construct — Bir veritabanı bağlantısını temsil eden bir PDO nesnesi oluşturur
  • PDO::errorCode — Veritabanındaki son işlemle ilgili SQLSTATE kodunu döndürür
  • PDO::errorInfo — Veritabanındaki son işlemle ilgili hata bilgisini döndürür
  • PDO::exec — Belirtilen SQL deyimini çalıştırır ve etkilenen satır sayısını döndürür
  • PDO::getAttribute — Bir veritabanı bağlantı özniteliğinin değerini döndürür
  • PDO::getAvailableDrivers — Kullanılabilen PDO sürücülerini içeren bir dizi döndürür
  • PDO::inTransaction — Checks if inside a transaction
  • PDO::lastInsertId — Son yerleştirilen satırın veya sıradaki değerin kimliğini döndürür
  • PDO::prepare — Çalıştırılmak üzere bir deyimi hazırlar ve bir deyim nesnesi olarak döndürür
  • PDO::query — Bir SQL deyimini çalıştırıp sonucu bir PDOStatement nesnesi olarak döndürür
  • PDO::quote — Bir sorguda kullanılmak üzere bir dizgeyi önceler
  • PDO::rollBack — Bir toplu hareketi geri alır
  • PDO::setAttribute — Bir öznitelik tanımlar
Büyük Veri Nesneleri (LOB'lar)
PDO::beginTransaction
PDO


Bir toplu hareketi ilklendirir

PDO
PDO::commit
PDO
PHP Manual

PDO::beginTransaction

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDO::beginTransaction — Bir toplu hareketi ilklendirir

Açıklama

bool PDO::beginTransaction ( void )

Özdevinimli gönderim kipini kapatır. Özdevinimli kip kapalıyken PDO nesne örneği üzerinden veritabanında yapılan değişiklikler PDO::commit() çağrısı ile toplu hareket tamamlanmadan veritabanında bir değişikliğe yol açmaz. Toplu hareketlerle yapılan değişiklikleri geri almak ve tekrar özdevinimli kipe dönmek için PDO::rollBack() yöntemini kullanabilirsiniz.

MySQL dahil bazı veritabanları, bir toplu hareketin içinde DROP TABLE veya CREATE TABLE gibi bir veritabanı tanımlama dili deyimi kullanıldığında özdevinimli olarak örtük bir PDO::commit() yaparlar. Örtük PDO::commit(), toplu hareket içindeki diğer değişikliklerin de geri alınmasına engeller.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - ir toplu hareketi geri almak

Aşağıdaki örnekte bir toplu hareket başlatılmakta, değişiklikler geri alınmadan önce iki deyim çalıştırılmaktadır. Ancak, MySQL'de DROP TABLE deyimi özdevinimli bir PDO::commit() çağrısına sebep olduğundan bu deyimden önce toplu hareket dahilinde yapılan hiçbir hareket geri alınamaz.

<?php
/* Özdevinimli gönderim kipini kapatıp bir toplu hareket başlatalım */
$dbh->beginTransaction();

/* Veritabanı şemasını ve verisini değiştirgelim */
$sth = $dbh->exec("DROP TABLE fruit");
$sth = $dbh->exec("UPDATE dessert
    SET name = 'hamburger'");

/* Yanlışı farkedip hareketleri geri alıyoruz */
$dbh->rollBack();

/* Veritabanı bağlantısı tekrar özdevinimli gönderim kipinde. */
?>

Ayrıca Bakınız

  • PDO::commit() - Bir toplu hareketi veritabanına gönderir
  • PDO::rollBack() - Bir toplu hareketi geri alır

PDO
PDO::commit
PDO


Bir toplu hareketi veritabanına gönderir

PDO::beginTransaction
PDO::__construct
PDO
PHP Manual

PDO::commit

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDO::commit — Bir toplu hareketi veritabanına gönderir

Açıklama

bool PDO::commit ( void )

Bir toplu hareketi veritabanına gönderir ve bir PDO::beginTransaction() çağrısı ile yeni bir toplu hareket başlatılıncaya kadar geçerli olmak üzere bağlantıyı özdevinimli gönderim kipine sokar.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Bir toplu hareketin teslim edilmesi

<?php
/* Özdevinimli gönderim kipini kapatıp bir toplu hareket başlatalım */
$dbh->beginTransaction();

/* Veritabanı şemasını değiştirgelim */
$sth = $dbh->exec("DROP TABLE fruit");

/* Değişiklikleri etkin kılalım */
$dbh->commit();

/* Veritabanı bağlantısı tekrar özdevinimli gönderim kipinde. */
?>

Ayrıca Bakınız

  • PDO::beginTransaction() - Bir toplu hareketi ilklendirir
  • PDO::rollBack() - Bir toplu hareketi geri alır

PDO::beginTransaction
PDO::__construct
PDO


Bir veritabanı bağlantısını temsil eden bir PDO nesnesi oluşturur

PDO::commit
PDO::errorCode
PDO
PHP Manual

PDO::__construct

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDO::__construct — Bir veritabanı bağlantısını temsil eden bir PDO nesnesi oluşturur

Açıklama

PDO::__construct ( string $dsn [, string $kullanıcı [, string $parola [, array $seçenekler ]]] )

Belirtilen veritabanına kurulan bağlantıyı temsil eden bir PDO nesnesi oluşturur.

Değiştirgeler

dsn

Veritabanına bağlantı için gerekli bilgiyi içeren veri kaynağının ismi.

Genellikle bir veri kaynağı ismi, aralarında bir noktalı virgül bulunan sürücü ismi ile PDO sürücüsüne özgü bağlantı sözdiziminden oluşur. Bu konuda daha ayrıntılı bilgiyi PDO Sürücüleri sayfasında bulabilirsiniz.

dsn değiştirgesi, bir veritabanı bağlantısı oluşturmak için gereken üç farklı yöntemi destekler:

Sürücü isteği

dsn değiştirgesi, veri kaynağı ismi için gereken herşeyi içerir.

URI isteği

dsn değiştirgesi, uri: sözcüğünü takibeden, veri kaynağı isim dizgesini içeren bir dosyanın yerini belirten bir özkaynak betimleyicisi içerir.

uri:file:///bir/yol/dsndosyası

Takma ad kullanımı

dsndeğiştirgesi, php.ini içinde DSN dizgesini tanımlayan pdo.dsn.isim ile eşleşen isim adını içerir.

Bilginize:

Takma ad, .htaccess veya httpd.conf dosyasında değil php.ini dosyasında tanımlanmış olmalıdır.

kullanıcı

DSN dizgesi için kullanıcı ismi. Bu değiştirgenin belirtilmesi bazı PDO sürücüleri için isteğe bağlıdır.

parola

DSN dizgesi için parola. Bu değiştirgenin belirtilmesi bazı PDO sürücüleri için isteğe bağlıdır.

seçenekler

Sürücüye özgü bağlantı seçeneklerini içeren bir isim=>değer çiftleri dizisi.

Dönen Değerler

Başarı durumunda bir PDO nesnesi döner.

Hatalar/İstisnalar

PDO::__construct(), istenen veritabanına bağlantı sağlanamazsa bir PDOException istisnası oluşturur.

Örnekler

Örnek 1 - Sürücü isteğiyle PDO örneğinin oluşturulması

<?php
/* Sürücü isteğiyle bir ODBC veritabanına bağlanalım */
$dsn = 'mysql:dbname=testdb;host=127.0.0.1';
$user = 'dbuser';
$password = 'dbpass';

try {
    $dbh = new PDO($dsn, $user, $password);
} catch (PDOException $e) {
    echo 'Bağlantı kurulamadı: ' . $e->getMessage();
}

?>

Örnek 2 - URI isteğiyle PDO örneğinin oluşturulması

Aşağıdaki örnekte PHP'nin /usr/local/dbconnect dosyasını okuma iznine sahip olduğu varsayılmıştır. Dosya, PDO_ODBC sürücüsü üzerinden bir DB2 veritabanına bağlanmak için gereken şu bilgiyi içermektedir:

odbc:DSN=SAMPLE;UID=birey;PWD=parola

Bu dosyanın yerini içeren bir uri: dizgesi ile veritabanı bağlantısı oluşturulabilir:

<?php
/* URI isteğiyle bir ODBC veritabanına bağlanalım  */
$dsn = 'uri:file:///usr/local/dbconnect';
$user = '';
$password = '';

try {
    $dbh = new PDO($dsn, $user, $password);
} catch (PDOException $e) {
    echo 'Bağlantı kurulamadı: ' . $e->getMessage();
}

?>

Örnek 3 - Bir takma ad kullanarak PDO örneğinin oluşturulması

Aşağıdaki örnekte, php.ini dosyasının bir MySQL veritabanına bağlantı kurmak için mydb adını takma ad olarak kullamayı mümkün kılan şöyle bir girdi içerdiği varsayılmıştır:

[PDO]
pdo.dsn.mydb="mysql:dbname=testdb;host=localhost"
<?php
/* Bir takma ad kullanarak bir ODBC veritabanına bağlanalım */
$dsn = 'mydb';
$user = '';
$password = '';

try {
    $dbh = new PDO($dsn, $user, $password);
} catch (PDOException $e) {
    echo 'Bağlantı kurulamadı: ' . $e->getMessage();
}

?>

PDO::commit
PDO::errorCode
PDO


Veritabanındaki son işlemle ilgili SQLSTATE kodunu döndürür

PDO::__construct
PDO::errorInfo
PDO
PHP Manual

PDO::errorCode

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDO::errorCode — Veritabanındaki son işlemle ilgili SQLSTATE kodunu döndürür

Açıklama

mixed PDO::errorCode ( void )

Dönen Değerler

ANSI SQL-92 standardında tanımlanan beş karakterlik abecesayısal bir hata tanıtıcısı (SQLSTATE) döndürür. Bir SQLSTATE iki karakterlik ana hata sınıfı değerinin ardına eklenmiş üç karakterlik alt sınıf değerinden oluşur. 01 ana sınıf değeri bir uyarı belirtir ve SQL_SUCCESS_WITH_INFO dönüş kodu ile birlikte bulunur. '01' ve 'IM' sınıfları dışındaki tüm sınıf değerleri bir hata belirtir. 'IM' sınıfı PDO gerçekleniminden (ve ODBC sürücüsünü kullanıyorsanız ODBC'den) türetilen uyarılar ve hatalar ile ilgilidir. Herhangi bir sınıfın '000' alt sınıf değeri o SQLSTATE için bir alt sınıfın olmadığını belirtir.

PDO::errorCode() sadece doğrudan veritabanı tanıtıcısında yürütülen işlemlerin hata kodlarını döndürür. PDO::prepare() veya PDO::query() ile bir PDOStatement nesnesi oluşturup deyim tanıtıcısı üzerinde oluşan bir hatayla ilgili bilgi alacaksanız PDOStatement::errorInfo() yöntemini kullanmalısınız.

Veritabanı tanıtıcısında yürütülmüş bir işlem yoksa NULL döner.

Örnekler

Örnek 1 - Bir SQLSTATE kodunun döndürülmesi

<?php
/* Bir hata oluşturalım --BONES diye bir tablo olmasın */
$dbh->exec("INSERT INTO bones(skull) VALUES ('lucy')");

echo "\nPDO::errorCode(): ";
print $dbh->errorCode();
?>

Yukarıdaki örneğin çıktısı:

PDO::errorCode(): 42S02

Ayrıca Bakınız

  • PDO::errorInfo() - Veritabanındaki son işlemle ilgili hata bilgisini döndürür
  • PDOStatement::errorCode() - Deyim üzerindeki son işlemle ilgili SQLSTATE hata kodunu döndürür
  • PDOStatement::errorInfo() - Deyim üzerindeki son işlemle ilgili hata bilgisini döndürür

PDO::__construct
PDO::errorInfo
PDO


Veritabanındaki son işlemle ilgili hata bilgisini döndürür

PDO::errorCode
PDO::exec
PDO
PHP Manual

PDO::errorInfo

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDO::errorInfo — Veritabanındaki son işlemle ilgili hata bilgisini döndürür

Açıklama

array PDO::errorInfo ( void )

Veritabanındaki son işlemle ilgili hata bilgisini döndürür.

Dönen Değerler

Veritabanındaki son işlemle ilgili hata bilgisini içeren bir dizi döndürür. Dizi şu alanları içerir:

Eleman | Bilgi
0 | SQLSTATE hata kodu (ANSI SQL standardında tanımlanmış beş karakterlik abecesayısal bir tanıtıcı).
1 | Sürücüye özgü hatanın kodu.
2 | Sürücüye özgü hatanın iletisi.

Bilginize:

SQLSTATE hata kodu atanmamışsa veya sürücüye özgü hata kodu yoksa 0. eleman hariç bütün elemanlar NULL içerir.

PDO::errorInfo() yöntemi sadece veritabanına doğrudan uygulanan işlemlerin hata bilgisini döndürür. PDO::prepare() veya PDO::query() ile bir PDOStatement nesnesi oluşturup deyim tanıtıcısı üzerinde oluşan bir hatayla ilgili bilgi alacaksanız PDOStatement::errorInfo() yöntemini kullanmalısınız.

Örnekler

Örnek 1 - Bir DB2 veiitabanına kurulan bir PDO_ODBC bağlantısıyla ilgili hata bilgisinin gösterilmesi

<?php
/* Bir hata oluşturalım -- hatalı bir SQL sözdizimi  */
$stmt = $dbh->prepare('bozuk sql');
if (!$stmt) {
    echo "\nPDO::errorInfo():\n";
    print_r($dbh->errorInfo());
}
?>

Yukarıdaki örneğin çıktısı:

PDO::errorInfo():
Array
(
    [0] => HY000
    [1] => 1
    [2] => near "bozuk": syntax error
)

Ayrıca Bakınız

  • PDO::errorCode() - Veritabanındaki son işlemle ilgili SQLSTATE kodunu döndürür
  • PDOStatement::errorCode() - Deyim üzerindeki son işlemle ilgili SQLSTATE hata kodunu döndürür
  • PDOStatement::errorInfo() - Deyim üzerindeki son işlemle ilgili hata bilgisini döndürür

PDO::errorCode
PDO::exec
PDO


Belirtilen SQL deyimini çalıştırır ve etkilenen satır sayısını döndürür

PDO::errorInfo
PDO::getAttribute
PDO
PHP Manual

PDO::exec

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDO::exec — Belirtilen SQL deyimini çalıştırır ve etkilenen satır sayısını döndürür

Açıklama

int PDO::exec ( string $deyim )

PDO::exec() belirtilen SQL deyimini tek bir işlev çağrısıyla çalıştırır ve deyimden etkilenen satırların sayısını döndürür.

PDO::exec() yöntemi bir SELECT deyiminin sonucunu döndürmez. Bir SELECT deyimini uygulamanız boyunca sadece bir defa çalıştıracaksanız PDO::query() yöntemini kullanabilirsiniz. Defalarca çalıştıracaksanız PDO::prepare() ile bir PDOStatement nesnesi hazırlayıp bunu PDOStatement::execute() ile çalıştırabilirsiniz.

Değiştirgeler

deyim

Hazırlanıp çalıştırılacak SQL deyimi.

Sorgunun içindeki verinin geretiği gibi öncelenmesi gerekir.

Dönen Değerler

PDO::exec() işlevi çalıştırılan SQL deyimiyle silinen veya değiştirilen satırların sayısını döndürür. Etkilenen satır yoksa PDO::exec() 0 döndürür.

Uyarı

Bu işlev mantıksal FALSE değeriyle dönebileceği gibi FALSE olarak değerlendirilebilecek mantıksal olmayan bir değerle de dönebilir. Bu konuda daha fazla bilgi edinmek için Mantıksal Değerler bölümüne bakabilirsiniz. Bu işlevden dönen değeri sınamak için === işlecini kullanınız.

Aşağıda, dönüş değerinin yanlış ele alındığı bir örneğe yer verilmiştir. Etkilenen satır sayısı 0 olduğu halde die() işlevi çağrılmaktadır:

<?php
$db->exec() or die(print_r($db->errorInfo(), true));
?>

Örnekler

Örnek 1 - Bir DELETE deyiminin çalıştırılması

Bir DELETE deyimiyle silinen satır sayısının öğrenilmesi.

<?php
$dbh = new PDO('odbc:sample', 'db2inst1', 'ibmdb2');

/* FRUIT tablosundaki tüm satırları silelim */
$count = $dbh->exec("DELETE FROM fruit WHERE colour = 'red'");

/* Silinen satır sayısını döndürelim */
print("$count satır silindi.\n");
?>

Yukarıdaki örneğin çıktısı:

1 satır silindi.

Ayrıca Bakınız

  • PDO::prepare() - Çalıştırılmak üzere bir deyimi hazırlar ve bir deyim nesnesi olarak döndürür
  • PDO::query() - Bir SQL deyimini çalıştırıp sonucu bir PDOStatement nesnesi olarak döndürür
  • PDOStatement::execute() - Bir hazır deyimi çalıştırır

PDO::errorInfo
PDO::getAttribute
PDO


Bir veritabanı bağlantı özniteliğinin değerini döndürür

PDO::exec
PDO::getAvailableDrivers
PDO
PHP Manual

PDO::getAttribute

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.2.0)

PDO::getAttribute — Bir veritabanı bağlantı özniteliğinin değerini döndürür

Açıklama

mixed PDO::getAttribute ( int $öznitelik )

Bir veritabanı bağlantı özniteliğinin değerini döndürür.

Bazı veritabanı/sürücü çiftlerinin veritabanı bağlantı özniteliklerinin tamamını desteklemeyebileceğini unutmayınız.

Değiştirgeler

öznitelik

PDO::ATTR_* sabitlerinden biri. Sabitlerin açıklamaları için Öntanımlı Sabitler sayfasına bakınız. Veritabanı bağlantılarına uygulanabilecek sabitler:

  • PDO::ATTR_AUTOCOMMIT
  • PDO::ATTR_CASE
  • PDO::ATTR_CLIENT_VERSION
  • PDO::ATTR_CONNECTION_STATUS
  • PDO::ATTR_DRIVER_NAME
  • PDO::ATTR_ERRMODE
  • PDO::ATTR_ORACLE_NULLS
  • PDO::ATTR_PERSISTENT
  • PDO::ATTR_PREFETCH
  • PDO::ATTR_SERVER_INFO
  • PDO::ATTR_SERVER_VERSION
  • PDO::ATTR_TIMEOUT

Dönen Değerler

Başarısızlık durumunda NULL yoksa istenen PDO özniteliğinin değerini döndürür.

Örnekler

Örnek 1 - Veritabanı bağlantı özniteliklerinin öğrenilmesi

<?php
$conn = new PDO('odbc:sample', 'db2inst1', 'ibmdb2');
$attributes = array(
    "AUTOCOMMIT", "ERRMODE", "CASE", "CLIENT_VERSION", "CONNECTION_STATUS",
    "ORACLE_NULLS", "PERSISTENT", "PREFETCH", "SERVER_INFO", "SERVER_VERSION",
    "TIMEOUT"
);

foreach ($attributes as $val) {
    echo "PDO::ATTR_$val: ";
    echo $conn->getAttribute(constant("PDO::ATTR_$val")) . "\n";
}
?>

Ayrıca Bakınız

  • PDO::setAttribute() - Bir öznitelik tanımlar
  • PDOStatement::getAttribute() - Bir deyim özniteliğinin değerini döndürür
  • PDOStatement::setAttribute() - Bir deyim özniteliğini tanımlar

PDO::exec
PDO::getAvailableDrivers
PDO


Kullanılabilen PDO sürücülerini içeren bir dizi döndürür

PDO::getAttribute
PDO::inTransaction
PDO
PHP Manual

PDO::getAvailableDrivers

(PHP 5 >= 5.1.3, PHP 7, PECL pdo >= 1.0.3)

PDO::getAvailableDrivers — Kullanılabilen PDO sürücülerini içeren bir dizi döndürür

Açıklama

array PDO::getAvailableDrivers ( void )
array pdo_drivers ( void )

PDO::__construct() yönteminin DSN değiştirgesinde kullanılabilen PDO sürücülerinin listesini döndürür. Bu, duruk bir yöntemdir.

Dönen Değerler

PDO::getAvailableDrivers() yöntemi PDO sürücü isimlerini içeren bir dizi döndürür. Hiç sürücü yoksa boş bir dizi döner.

Örnekler

Örnek 1 - PDO::getAvailableDrivers() örneği

<?php
print_r(PDO::getAvailableDrivers());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [0] => mysql
    [1] => sqlite
)

PDO::getAttribute
PDO::inTransaction
PDO


Checks if inside a transaction

PDO::getAvailableDrivers
PDO::lastInsertId
PDO
PHP Manual

PDO::inTransaction

(PHP 5 >= 5.3.3, Bundled pdo_pgsql, PHP 7)

PDO::inTransaction — Checks if inside a transaction

Açıklama

public bool PDO::inTransaction ( void )

Checks if a transaction is currently active within the driver. This method only works for database drivers that support transactions.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if a transaction is currently active, and FALSE if not.

PDO::getAvailableDrivers
PDO::lastInsertId
PDO


Son yerleştirilen satırın veya sıradaki değerin kimliğini döndürür

PDO::inTransaction
PDO::prepare
PDO
PHP Manual

PDO::lastInsertId

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDO::lastInsertId — Son yerleştirilen satırın veya sıradaki değerin kimliğini döndürür

Açıklama

string PDO::lastInsertId ([ string $isim = NULL ] )

Sürücüye bağlı olarak, yerleştirilen son satırın veya bir sıralama nesnesindeki son değerin kimliğini döndürür. Örneğin, PDO_PGSQL isim değiştirgesinde bir sıralama nesnesi ismi belirtilmesini gerektirir.

Bilginize:

Bu yöntem, sıralı veya özdevinimli artan alanlarla ilgili desteğin bulunmadığı veritabanları için anlamlı veya tutarlı bir sonuç döndüremeyebilir.

Değiştirgeler

isim

Kimliği döndürülecek sırama nesnesinin ismi.

Dönen Değerler

isim değiştirgesinde bir sıralama nesnesi ismi belirtilmezse PDO::lastInsertId(), veritabanına son yerleştirilen satırın satır kimliğini bir dizge olarak döndürür.

isim değiştirgesinde bir sıralama nesnesi ismi belirtilmişse PDO::lastInsertId(), sıralama nesnesinden alınan son değeri ifade eden bir dizge döndürür.

PDO sürücüsü bu özelliği desteklemiyorsa PDO::lastInsertId() bir IM001 durumu (SQLSTATE) tetikler.

PDO::inTransaction
PDO::prepare
PDO


Çalıştırılmak üzere bir deyimi hazırlar ve bir deyim nesnesi olarak döndürür

PDO::lastInsertId
PDO::query
PDO
PHP Manual

PDO::prepare

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDO::prepare — Çalıştırılmak üzere bir deyimi hazırlar ve bir deyim nesnesi olarak döndürür

Açıklama

PDOStatement PDO::prepare ( string $deyim [, array $seçenekler = array() ] )

PDOStatement::execute() yöntemi ile çalıştırılmak üzere bir SQL deyimi hazırlar. SQL deyimi sıfır veya daha fazla sayıda birer isimle (:isim) veya birer soru imi (?) ile ifade edilen değiştirge içerebilir. Deyimin çalıştırılması sırasında bu değiştirgelere farklı değerler atanarak aynı deyim defalarca kullanılabilir. Aynı SQL deyiminde hem isimli hem de soru imli değiştirgeleri kullanamazsınız. İkisinden birini seçmek zorundasınız.

PDOStatement::execute() işlevinde aktaracağınız her değer için eşsiz bir değiştirge imleyici belirtmelisiniz. İsimli değiştirgeler eşsiz olmak zorundadır, aynı ismi birden fazla değiştirgede kullanamazsınız. Çok sayıda değeri, örneğin bir SQL deyiminin IN cümleciğinde tek bir isimli değiştirgeyle ilişkilendiremezsiniz.

Bir SQL deyiminin farklı değerlerle defalarca çalıştırılmak üzere PDO::prepare() ve PDOStatement::execute() yöntemlerine aktarılması, bu SQL deyimiyle ilgili sorgu planının ve temel verilerin müzakere edilmek üzere sürücü tarafından istemci ve/veya sunucu tarafında önbelleklemesiyle uygulamanızın başarımını yükseltecek en iyilemelerin yapılması mümkün olur ve değiştirgelerin elle öncelenmesi gereğini ortadan kaldırarak SQL zerk saldırılarını engellemeye yardımcı olur.

Değiştirgeli hazır deyimlerin değerlerle ilişkilendirilmesi işlemini desteklemeyen sürücüler için PDO bu işlemi taklit eder. Ayrıca sürücü isimli ve soru imli değiştirge aktarım tarzlarından yalnız birini destekliyorsa PDO diğer tarzı da taklit eder.

Değiştirgeler

deyim

Hedef veritabanı sunucusu için geçerli bir SQL deyimi olmalıdır.

seçenekler

Bu yöntemden döndürülen PDOStatement nesnesi için atanacak öznitelik değerlerini isim=>değer çiftleri halinde içeren bir dizi. Çoğunlukla kaydırılabilen bir gösterici isteği için PDO::CURSOR_SCROLL özniteliğine PDO::ATTR_CURSOR değerini atamakta kullanılır. Bazı sürücülerin deyimin hazırlanması aşamasında atanabilen sürücüye özgü öznitelikleri vardır.

Dönen Değerler

Veritabanı sunucusu deyimi başarıyla hazırlayabilmişse PDO::prepare() bir PDOStatement nesnesi döndürür; aksi takdirde bir PDOException istisnası oluşur.

Bilginize:

Taklit hazır deyimler için veritabanı sunucusuyla müzakere yapılmadığından PDO::prepare() deyim üzerinde bir sınama yapmaz.

Örnekler

Örnek 1 - İsimli değiştirgelerle bir SQL deyiminin hazırlanması

<?php
/* Değerleri bir dizi olarak aktaracağımız bir deyim hazırlayalım */
$sql = 'SELECT name, colour, calories
    FROM fruit
    WHERE calories < :calories AND colour = :colour';
$sth = $dbh->prepare($sql, array(PDO::ATTR_CURSOR => PDO::CURSOR_FWDONLY));
$sth->execute(array(':calories' => 150, ':colour' => 'red'));
$red = $sth->fetchAll();
$sth->execute(array('calories' => 175, 'colour' => 'yellow'));
$yellow = $sth->fetchAll();
?>

Örnek 2 - Soru imli değiştirgelerle bir SQL deyiminin hazırlanması

<?php
/* Değerleri bir dizi olarak aktaracağımız bir deyim hazırlayalım */
$sth = $dbh->prepare('SELECT name, colour, calories
    FROM fruit
    WHERE calories < ? AND colour = ?');
$sth->execute(array(150, 'red'));
$red = $sth->fetchAll();
$sth->execute(array(175, 'yellow'));
$yellow = $sth->fetchAll();
?>

Ayrıca Bakınız

  • PDO::exec() - Belirtilen SQL deyimini çalıştırır ve etkilenen satır sayısını döndürür
  • PDO::query() - Bir SQL deyimini çalıştırıp sonucu bir PDOStatement nesnesi olarak döndürür
  • PDOStatement::execute() - Bir hazır deyimi çalıştırır

PDO::lastInsertId
PDO::query
PDO


Bir SQL deyimini çalıştırıp sonucu bir PDOStatement nesnesi olarak döndürür

PDO::prepare
PDO::quote
PDO
PHP Manual

PDO::query

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.2.0)

PDO::query — Bir SQL deyimini çalıştırıp sonucu bir PDOStatement nesnesi olarak döndürür

Açıklama

PDOStatement PDO::query ( string $deyim )
PDOStatement PDO::query ( string $deyim , int $PDO::FETCH_COLUMN , int $sütunnum )
PDOStatement PDO::query ( string $deyim , int $PDO::FETCH_CLASS , string $sınıfadı , array $kurucu_değiştirgeleri )
PDOStatement PDO::query ( string $deyim , int $PDO::FETCH_INTO , object $nesne )

Bir SQL deyimini tek bir işlev çağrısında çalıştırır ve sorgu sonucunu (bir sonuç varsa) bir PDOStatement nesnesi olarak döndürür.

Defalarca yineleyeceğiniz bir sorguyu PDO::prepare() yöntemini kullanarak bir PDOStatement nesnesi haline getirip bunu PDOStatement::execute() ile defalarca çalıştırmak başarımı arttıracaktır.

Tekrar bir PDO::query() çağrısı yapmadan önce sonuç kümesindeki veriyi almazsanız çağrınız başarısızlıkla sonuçlanabilir. Yeni bir PDO::query() çağrısını yapmadan önce PDOStatement nesnesi ile ilişkilendirilmiş kaynakları serbest bırakmak için PDOStatement::closeCursor() çağrısı yapmalısınız.

Bilginize:

Bu işlev, tek bir değiştirgeye sahipmiş gibi belgelendirilmesine rağmen işleve başka değiştirgeler de aktarabilirsiniz. Bunlar, sonuç nesnesi üzerinde PDOStatement::setFetchMode() çağrısı yapılmış gibi ele alınırlar.

Değiştirgeler

deyim

Hazırlanacak ve çalıştırılacak SQL deyimi.

Sorguda kullanılacak verilerin düzgün olarak öncelenmesi gerekir.

Dönen Değerler

Başarısızlık durumunda FALSE, aksi takdirde bir PDOStatement nesnesi.

Örnekler

Örnek 1 - PDO::query() örneği

PDO::query() yönteminin tek özelliği başarıyla çalıştırılmış bir SELECT deyiminden dönen sonuç kümesi üzerinde satır satır verilere erişilebilmesini mümkün kılmasıdır.

<?php
function getFruit($conn) {
    $sql = 'SELECT name, colour, calories FROM fruit ORDER BY name';
    foreach ($conn->query($sql) as $row) {
        print $row['NAME'] . "\t";
        print $row['COLOUR'] . "\t";
        print $row['CALORIES'] . "\n";
    }
}
?>

Yukarıdaki örneğin çıktısı:

apple   red     150
banana  yellow  250
kiwi    brown   75
lemon   yellow  25
orange  orange  300
pear    green   150
watermelon      pink    90

Ayrıca Bakınız

  • PDO::exec() - Belirtilen SQL deyimini çalıştırır ve etkilenen satır sayısını döndürür
  • PDO::prepare() - Çalıştırılmak üzere bir deyimi hazırlar ve bir deyim nesnesi olarak döndürür
  • PDOStatement::execute() - Bir hazır deyimi çalıştırır

PDO::prepare
PDO::quote
PDO


Bir sorguda kullanılmak üzere bir dizgeyi önceler

PDO::query
PDO::rollBack
PDO
PHP Manual

PDO::quote

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.2.1)

PDO::quote — Bir sorguda kullanılmak üzere bir dizgeyi önceler

Açıklama

string PDO::quote ( string $dizge [, int $değiştirge_türü = PDO::PARAM_STR ] )

Girdi dizgesine gerekiyorsa ilgili veritabanı sürücüsüne uygun bir önceleme uygular.

Bu işlevi SQL deyimlerini oluştururken kullanıyorsanız, kullanıcı girdisini bir SQL deyimi haline getirmek için PDO::quote() yerine PDO::prepare() ile değiştirgeleri ilişkilendirilmiş SQL deyimleri hazırlamanızı hararetle öneririz. Değiştirgelerle ilişkilendirimiş hazır deyimler taşınabilir olmaktan başka daha kullanışlı ve SQL zerkine bağışık olmanın yanında sorgunun derlenmiş hali hem sunucuda hem de istemcide bulunduğundan yorumlanan sorgulardan çok daha hızlıdır.

PDO sürücülerinin hepsi bu yöntemi gerçeklemez. (özellikle PDO_ODBC) Bu bakımdan hazır deyimleri kullanmaya hazır olmalısınız.

Değiştirgeler

dizge

Öncelenecek dizge.

değiştirge_türü

İkincil bir önceleme tarzına sahip sürücüler için ipucu olarak bir veri türü belirtilir. PDO::PARAM_STR öntanımlıdır.

Dönen Değerler

Bir SQL deyiminde aktarılmak üzere teorik olarak güvenli kabul edilen bir öncelenmiş dizge döndürür. Eğer sürücü bu tarz öncelemeyi desteklemiyorsa FALSE döner.

Örnekler

Örnek 1 - Normal bir dizgeyi öncelemek

<?php
$conn = new PDO('sqlite:/home/lynn/music.sql3');

/*Basit dizge */
$string = 'Basit';
print "Öncelenmemiş dizge: $string\n";
print "Öncelenmiş dizge: " . $conn->quote($string) . "\n";
?>

Yukarıdaki örneğin çıktısı:

Öncelenmemiş dizge: Basit
Öncelenmiş dizge: 'Basit'

Örnek 2 - Tehlikeli bir dizgeyi öncelemek

<?php
$conn = new PDO('sqlite:/home/lynn/music.sql3');

/* Tehlikeli dizge */
$string = 'Münasebetsiz \' dizge';
print "Öncelenmemiş dizge: $string\n";
print "Öncelenmiş dizge:" . $conn->quote($string) . "\n";
?>

Yukarıdaki örneğin çıktısı:

Öncelenmemiş dizge: Münasebetsiz ' dizge
Öncelenmiş dizge: 'Münasebetsiz '' dizge'

Örnek 3 - Karmaşık bir dizgeyi öncelemek

<?php
$conn = new PDO('sqlite:/home/lynn/music.sql3');

/* Karmaşık dizge */
$string = "Co'mpl''ex \"st'\"ring";
print "Öncelenmemiş dizge: $string\n";
print "Öncelenmiş dizge:" . $conn->quote($string) . "\n";
?>

Yukarıdaki örneğin çıktısı:

Öncelenmemiş dizge: Co'mpl''ex "st'"ring
Öncelenmiş dizge: 'Co''mpl''''ex "st''"ring'

Ayrıca Bakınız

  • PDO::prepare() - Çalıştırılmak üzere bir deyimi hazırlar ve bir deyim nesnesi olarak döndürür
  • PDOStatement::execute() - Bir hazır deyimi çalıştırır

PDO::query
PDO::rollBack
PDO


Bir toplu hareketi geri alır

PDO::quote
PDO::setAttribute
PDO
PHP Manual

PDO::rollBack

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDO::rollBack — Bir toplu hareketi geri alır

Açıklama

bool PDO::rollBack ( void )

PDO::beginTransaction() ile başlatılan toplu hareketi geri alır. Bir toplu hareket etkin değilken bu yöntemin çağrılması bir hataya sebep olur.

Eğer veritabanı özdevinimli gönderim kipindeyse, toplu hareket geri alındıktan sonra tekrar özdevinimli gönderim kipine dönülür.

MySQL dahil bazı veritabanları, bir toplu hareketin içinde DROP TABLE veya CREATE TABLE gibi bir veritabanı tanımlama dili deyimi kullanıldığında özdevinimli olarak örtük bir PDO::commit() yaparlar. Örtük PDO::commit(), toplu hareket içindeki diğer değişikliklerin de geri alınmasına engeller.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Bir toplu hareketin geri alınması

Aşağıdaki örnekte bir toplu hareket başlatılmakta, değişiklikleri geri almadan önce veritabanında değişiklik yapan iki deyim gönderilmektedir. Bununla birlikte MySQL'de, DROP TABLE deyimi hareketi özdevinimli olarak COMMIT ettiğinden toplu harekete dahil hiçbir değişiklik artık geri alınamaz.

<?php
/* Özdevinimli gönderimi kapatıp bir hareket başlatalım */
$dbh->beginTransaction();

/* Veritabanı şemasını ve verisini değiştirelim */
$sth = $dbh->exec("DROP TABLE fruit");
$sth = $dbh->exec("UPDATE dessert
    SET name = 'hamburger'");

/* Yanlışı farkedip değişiklikleri geri alıyoruz */
$dbh->rollBack();

/* Veritabanı bağlantısı şimdi özdevinimli gönderim kipinde */
?>

Ayrıca Bakınız

  • PDO::beginTransaction() - Bir toplu hareketi ilklendirir
  • PDO::commit() - Bir toplu hareketi veritabanına gönderir

PDO::quote
PDO::setAttribute
PDO


Bir öznitelik tanımlar

PDO::rollBack
PDOStatement
PDO
PHP Manual

PDO::setAttribute

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDO::setAttribute — Bir öznitelik tanımlar

Açıklama

bool PDO::setAttribute ( int $öznitelik , mixed $değer )

Veritabanı için bir öznitelik tanımlar. Bazı temel öznitelikler aşağıda listelenmiştir. Bazı sürücülerin kendilerine özgü öznitelikleri olabilir.

  • PDO::ATTR_CASE: Sütun isimlerinin harflerini belli bir büyüklüğe zorlar.

    • PDO::CASE_LOWER: Sütun isimlerinin harflerini küçük harfe zorlar.

    • PDO::CASE_NATURAL: Sütun isimlerinin harfleri veritabanı sürücüsünden döndüğü haliyle kullanılır.

    • PDO::CASE_UPPER: Sütun isimlerinin harflerini büyük harfe zorlar.

  • PDO::ATTR_ERRMODE: Hata raporlama.

    • PDO::ERRMODE_SILENT: Sadece hata kodlarını atar.

    • PDO::ERRMODE_WARNING: Bir E_WARNING çıktılanır.

    • PDO::ERRMODE_EXCEPTION: Bir istisna oluşur.

  • PDO::ATTR_ORACLE_NULLS (Sadece Oracle için değil, bütün sürücüler için kullanılabilir): NULL'a ve boş dizgelere dönüşüm.

    • PDO::NULL_NATURAL: Dönüşüm yok.

    • PDO::NULL_EMPTY_STRING: Boş dizge NULL'a dönüştürülür.

    • PDO::NULL_TO_STRING: NULL boş dizgeye dönüştürülür.

  • PDO::ATTR_STRINGIFY_FETCHES: Döndürülürken sayısal değerler dizgeye dönüştürülür. Mantıksal bir değer gerekir.

  • PDO::ATTR_STATEMENT_CLASS: PDOStatement sınıfından türetilmiş kullanıcı tanımlı bir deyim sınıfı tanımlar. Kalıcı PDO bağlantılarıyla kullanılamaz. array(string sınıfadı, array(mixed kurucu_değiştirgeler)) gerekir.

  • PDO::ATTR_AUTOCOMMIT (OCI, Firebird ve MySQL'de kullanılır): Her tek deyimin özdevinimli gönderilip gönderilmeyeceği belirtilir.

  • PDO::MYSQL_ATTR_USE_BUFFERED_QUERY (MySQL'de kullanılır): Tamponlu sorgular kullanılır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDO::rollBack
PDOStatement
PDO


PDOStatement sınıfı

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 1.0.0)

Giriş

Bir hazır deyimi ve hazır deyim çalıştırıldıktan sonra sonuç kümesini temsil eder.

Sınıf Sözdizimi

PDOStatement implements Traversable {
bool bindColumn ( mixed $sütun , mixed &$değişken [, int $veri_türü [, int $uzunluk [, mixed $seçenekler ]]] )
bool bindParam ( mixed $değiştirge , mixed &$değişken [, int $veri_türü [, int $uzunluk [, mixed $seçenekler ]]] )
bool bindValue ( mixed $değiştirge , mixed $değer [, int $veri_türü ] )
bool closeCursor ( void )
int columnCount ( void )
bool debugDumpParams ( void )
string errorCode ( void )
array errorInfo ( void )
bool execute ([ array $girdiler = array() ] )
mixed fetch ([ int $alım_tarzı = PDO::FETCH_BOTH [, int $göst_yönü = PDO::FETCH_ORI_NEXT [, int $göst_başlangıcı = 0 ]]] )
array fetchAll ([ int $alım_tarzı = PDO::FETCH_BOTH [, int $sütunnum [, array $değiştirgeler = array() ]]] )
string fetchColumn ([ int $sütunnum = 0 ] )
mixed fetchObject ([ string $sınıfadı [, array $değiştirgeler ]] )
mixed getAttribute ( int $öznitelik )
array getColumnMeta ( int $sütun )
bool nextRowset ( void )
int rowCount ( void )
bool setAttribute ( int $öznitelik , mixed $değer )
bool setFetchMode ( int $kip )
}

İçindekiler

  • PDOStatement->bindColumn — Bir sütunu bir PHP değişkeni ile ilişkilendirir
  • PDOStatement->bindParam — Bir değiştirgeyi belirtilen değişkenle ilişkilendirir
  • PDOStatement->bindValue — Bir değeri bir değiştirge ile ilişkilendirir
  • PDOStatement->closeCursor — Göstericiyi kapatarak deyimin tekrar çalıştırılabilmesini sağlar
  • PDOStatement->columnCount — Sonuç kümesindeki sütun sayısını döndürür
  • PDOStatement->debugDumpParams — Bir SQL hazır komutunu dökümler
  • PDOStatement->errorCode — Deyim üzerindeki son işlemle ilgili SQLSTATE hata kodunu döndürür
  • PDOStatement->errorInfo — Deyim üzerindeki son işlemle ilgili hata bilgisini döndürür
  • PDOStatement->execute — Bir hazır deyimi çalıştırır
  • PDOStatement->fetch — Sonuç kümesindeki sonraki satırı döndürür
  • PDOStatement->fetchAll — Sonuç kümesinin tüm satırlarını içeren bir dizi döndürür
  • PDOStatement->fetchColumn — Sonuç kümesindeki sonraki satırdan tek bir sütun döndürür
  • PDOStatement->fetchObject — Sonraki satırı bir nesne olarak döndürür
  • PDOStatement->getAttribute — Bir deyim özniteliğinin değerini döndürür
  • PDOStatement->getColumnMeta — Sonuç kümesindeki bir sütunla ilgili temel veriyi döndürür
  • PDOStatement->nextRowset — Çok satır kümeli bir sonuçtaki sonraki satır kümesini geçerli satır kümesi yapar
  • PDOStatement->rowCount — Son SQL deyiminden etkilenen satır sayısını döndürür
  • PDOStatement->setAttribute — Bir deyim özniteliğini tanımlar
  • PDOStatement->setFetchMode — Deyim için öntanımlı veri alım kipini belirler
PDO::setAttribute
PDOStatement->bindColumn
PDO


Bir sütunu bir PHP değişkeni ile ilişkilendirir

PDOStatement
PDOStatement->bindParam
PDOStatement
PHP Manual

PDOStatement->bindColumn

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDOStatement->bindColumn — Bir sütunu bir PHP değişkeni ile ilişkilendirir

Açıklama

bool PDOStatement::bindColumn ( mixed $sütun , mixed &$değişken [, int $veri_türü [, int $uzunluk [, mixed $seçenekler ]]] )

Bir sorgunun sonuç kümesindeki belli bir sütunu bir değişken ile ilişkilendirir. Her PDOStatement::fetch() veya PDOStatement::fetchAll() çağrısında sütunlarla ilişkili değişkenler güncellenir.

Bilginize:

Deyim çalıştırılana kadar sütun bilgisi PDO'ya görünür olmadığından taşınabilir uygulamaların bu yöntemi bir PDOStatement::execute() çağrısından sonra kullanmaları gerekir.

Ancak, PgSQL sürücüsü kullanılırken bir LOB sütununu bir akımla ilişkilendirmek için bu yöntemin PDOStatement::execute() çağrısından önce kullanılması gerekir. Aksi takdirde büyük nesnenin nesne kimliği (oid) bir tamsayı olarak döner.

Değiştirgeler

sütun

Sütunun numarası veya ismi; sütun numaraları 1'den başlar. Sütun isminin sürücüden dönen isimle aynı harf büyüklüklerine sahip olmasına dikkat edin.

değişken

Sütun ile ilişkilendirilecek PHP değişkeninin ismi.

veri_türü

PDO::PARAM_* sabitlerinden biri olarak veri türü.

uzunluk

Yer ayırmak için ipucu olarak kullanılır.

seçenekler

Sürücü için isteğe bağlı değiştirgeler.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Sonuç kümesi çıktısının PHP değişkenleri ile ilişkilendirilmesi

Sütunları birer PHP değişkeni ile ilişkilendirmek, sonuç kümesinin her satırının anında kullanıma hazır olmasını sağlamanın en kolay ve en verimli yoludur. Aşağıdaki örnekte, sütunların alınması ve değişkenlerle ilişkilendirilirken akıllı öntanımlılarla bazı seçeneklerin kullanılışı gösterilmiştir.

<?php
function readData($dbh) {
  $sql = 'SELECT name, colour, calories FROM fruit';
  try {
    $stmt = $dbh->prepare($sql);
    $stmt->execute();

    /* Bind by column number */
    $stmt->bindColumn(1, $name);
    $stmt->bindColumn(2, $colour);

    /* Bind by column name */
    $stmt->bindColumn('calories', $cals);

    while ($row = $stmt->fetch(PDO::FETCH_BOUND)) {
      $data = $name . "\t" . $colour . "\t" . $cals . "\n";
      print $data;
    }
  }
  catch (PDOException $e) {
    print $e->getMessage();
  }
}
readData($dbh);
?>

Yukarıdaki örneğin çıktısı:

apple   red     150
banana  yellow  175
kiwi    green   75
orange  orange  150
mango   red     200
strawberry      red     25

Ayrıca Bakınız

  • PDOStatement::execute() - Bir hazır deyimi çalıştırır
  • PDOStatement::fetch() - Sonuç kümesindeki sonraki satırı döndürür
  • PDOStatement::fetchAll() - Sonuç kümesinin tüm satırlarını içeren bir dizi döndürür
  • PDOStatement::fetchColumn() - Sonuç kümesindeki sonraki satırdan tek bir sütun döndürür

PDOStatement
PDOStatement->bindParam
PDOStatement


Bir değiştirgeyi belirtilen değişkenle ilişkilendirir

PDOStatement->bindColumn
PDOStatement->bindValue
PDOStatement
PHP Manual

PDOStatement->bindParam

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDOStatement->bindParam — Bir değiştirgeyi belirtilen değişkenle ilişkilendirir

Açıklama

bool PDOStatement::bindParam ( mixed $değiştirge , mixed &$değişken [, int $veri_türü [, int $uzunluk [, mixed $seçenekler ]]] )

Bir PHP değişkenini hazır SQL deyimindeki bir isimli veya soru imli değiştirgeyle ilişkilendirir. PDOStatement::bindValue() yönteminin tersine değişken gönderimli olarak ilişkilendirilir ve sadece PDOStatement::execute() çağrısı sırasında değerlendirmeye alınır.

Değiştirgeler çoğunlukla girdi değiştirgesidir, yani değiştirgeler sadece sorguda salt okunur olarak ele alınır. Bazı sürücüler, veriyi çıktı değiştirgelerinde döndüren kayıtlı yordamların kullanımını mümkün kılar. Bazıları ise aynı değiştirgelerin hem girdi hem de çıktı için kullanımını mümkün kılar.

Değiştirgeler

değiştirge

Değiştirge betimleyicisi. İsimli değiştirgeler için :isim biçemindedir. Soru imli değiştirgeler için ise soru iminin konumudur. Konumlar 1'den başlar.

değişken

SQL deyimindeki değiştirge ile ilişkilendirilecek PHP değişkeni.

veri_türü

PDO::PARAM_* sabitlerinden biri olarak veri türü. PDO::PARAM_STR öntanımlıdır. Değiştirgeden değer de döndürmek istiyorsanız PDO::PARAM_INPUT_OUTPUT sabitini burada, bit seviyesinde VEYAlayın.

uzunluk

Veri türünün uzunluğu. Değiştirge çıktı almak amacıyla kullanılacaksa veri türü uzunluğu mutlaka belirtilmelidir.

seçenekler

Sürücü seçenekleri.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - İsimli değiştirgelerle PDOStatement::bindParam() örneği

<?php
/* PHP değişkenleriyle ilişkili bir hazır deyim çalıştıralım */
$calories = 150;
$colour = 'red';
$sth = $dbh->prepare('SELECT name, colour, calories
    FROM fruit
    WHERE calories < :calories AND colour = :colour');
$sth->bindParam(':calories', $calories, PDO::PARAM_INT);
$sth->bindParam(':colour', $colour, PDO::PARAM_STR, 12);
$sth->execute();
?>

Örnek 2 - Soru imli değiştirgelerle PDOStatement::bindParam() örneği

<?php
/* PHP değişkenleriyle ilişkili bir hazır deyim çalıştıralım */
$calories = 150;
$colour = 'red';
$sth = $dbh->prepare('SELECT name, colour, calories
    FROM fruit
    WHERE calories < ? AND colour = ?');
$sth->bindParam(1, $calories, PDO::PARAM_INT);
$sth->bindParam(2, $colour, PDO::PARAM_STR, 12);
$sth->execute();
?>

Örnek 3 - Girdi/Çıktı değiştirgesi kullanımı

<?php
/* Girdi/Çıktı değiştirgeli bir kayıtlı yordam çağrısı yapalım */
$colour = 'red';
$sth = $dbh->prepare('CALL puree_fruit(?)');
$sth->bindParam(1, $colour, PDO::PARAM_STR|PDO::PARAM_INPUT_OUTPUT, 12);
$sth->execute();
print("Meyvenin posa rengi: $colour");
?>

Ayrıca Bakınız

  • PDO::prepare() - Çalıştırılmak üzere bir deyimi hazırlar ve bir deyim nesnesi olarak döndürür
  • PDOStatement::execute() - Bir hazır deyimi çalıştırır
  • PDOStatement::bindValue() - Bir değeri bir değiştirge ile ilişkilendirir

PDOStatement->bindColumn
PDOStatement->bindValue
PDOStatement


Bir değeri bir değiştirge ile ilişkilendirir

PDOStatement->bindParam
PDOStatement->closeCursor
PDOStatement
PHP Manual

PDOStatement->bindValue

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 1.0.0)

PDOStatement->bindValue — Bir değeri bir değiştirge ile ilişkilendirir

Açıklama

bool PDOStatement::bindValue ( mixed $değiştirge , mixed $değer [, int $veri_türü ] )

Hazır SQL deyimindeki bir isimli veya soru imli değiştirgeyle bir değeri ilişkilendirir.

Değiştirgeler

değiştirge

Değiştirge betimleyicisi. İsimli değiştirgeler için :isim biçemindedir. Soru imli değiştirgeler için ise soru iminin konumudur. Konumlar 1'den başlar.

değer

Değiştirge ile ilişkilendirilecek değer.

veri_türü

PDO::PARAM_* sabitlerinden biri olarak veri türü. PDO::PARAM_STR öntanımlıdır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - İsimli değiştirgelerle PDOStatement::bindValue() örneği

<?php
/* PHP değişkenleriyle ilişkili bir hazır deyim çalıştıralım */
$calories = 150;
$colour = 'red';
$sth = $dbh->prepare('SELECT name, colour, calories
    FROM fruit
    WHERE calories < :calories AND colour = :colour');
$sth->bindValue(':calories', $calories, PDO::PARAM_INT);
$sth->bindValue(':colour', $colour, PDO::PARAM_STR);
$sth->execute();
?>

Örnek 2 - Soru imli değiştirgelerle PDOStatement::bindValue() örneği

<?php
/* PHP değişkenleriyle ilişkili bir hazır deyim çalıştıralım */
$calories = 150;
$colour = 'red';
$sth = $dbh->prepare('SELECT name, colour, calories
    FROM fruit
    WHERE calories < ? AND colour = ?');
$sth->bindValue(1, $calories, PDO::PARAM_INT);
$sth->bindValue(2, $colour, PDO::PARAM_STR);
$sth->execute();
?>

Ayrıca Bakınız

  • PDO::prepare() - Çalıştırılmak üzere bir deyimi hazırlar ve bir deyim nesnesi olarak döndürür
  • PDOStatement::execute() - Bir hazır deyimi çalıştırır
  • PDOStatement::bindParam() - Bir değiştirgeyi belirtilen değişkenle ilişkilendirir

PDOStatement->bindParam
PDOStatement->closeCursor
PDOStatement


Göstericiyi kapatarak deyimin tekrar çalıştırılabilmesini sağlar

PDOStatement->bindValue
PDOStatement->columnCount
PDOStatement
PHP Manual

PDOStatement->closeCursor

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.9.0)

PDOStatement->closeCursor — Göstericiyi kapatarak deyimin tekrar çalıştırılabilmesini sağlar

Açıklama

bool PDOStatement::closeCursor ( void )

PDOStatement::closeCursor() yöntemi sunucu bağlantısını serbest bırakarak, mevcut deyimin durumunu değiştirmeden tekrar çalıştırılabilmesinin yanında başka SQL deyimlerinin çalıştırılabilmesini de mümkün kılar.

Evvelce çalıştırılmış bir PDOStatement nesnesinden henüz alınmamış satırların olduğu durumda bazı sürücüler bir PDOStatement nesnesinin daha çalıştırılmasına izin vermezler. Bu yöntem bu tür sürücülerde yararlıdır. Sürücünüz böyle bir sürücü ise sorun sıra dışı bir hata olarak kendini gösterir.

PDOStatement::closeCursor() yöntemi ya sürücüye özel isteğe bağlı (azami verimlilikte) bir yöntemdir ya da genel amaçlı bir PDO son çare yöntemidir. Genel amaçlı yöntem aşağıdaki PHP koduna eşdeğer bir işlem yürütür:

<?php
do {
    while ($stmt->fetch())
        ;
    if (!$stmt->nextRowset())
        break;
} while (true);
?>

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - PDOStatement::closeCursor() örneği

Aşağıdaki örnekte, $stmt PDOStatement nesnesi çok sayıda satır döndürdüğü halde uygulama sadece ilk satırı almakta ve PDOStatement nesnesini satırları henüz alınmamış durumda bırakmaktadır. Uygulamanın tüm veritabanı sürücüleri ile çalışmasını sağlamak için $stmt veya $otherStmt PDOStatement nesnesi çalıştırılmadan önce bir PDOStatement::closeCursor() çağrısı yapması gerekir.

<?php
/* Bir PDOStatement nesnesi oluşturalım */
$stmt = $dbh->prepare('SELECT foo FROM bar');

/* Bir PDOStatement nesnesi daha oluşturalım*/
$otherStmt = $dbh->prepare('SELECT foobaz FROM foobar');

/* İlkini çalıştıralım */
$stmt->execute();

/* İlk satırı alalım */
$stmt->fetch();

/* Bazı sürücüler bu çağrıyı gerektirir */
$stmt->closeCursor();

/* Artık ikinci deyimi çalıştırabiliriz */
$otherStmt->execute();
?>

Ayrıca Bakınız

  • PDOStatement::execute() - Bir hazır deyimi çalıştırır

PDOStatement->bindValue
PDOStatement->columnCount
PDOStatement


Sonuç kümesindeki sütun sayısını döndürür

PDOStatement->closeCursor
PDOStatement->debugDumpParams
PDOStatement
PHP Manual

PDOStatement->columnCount

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.2.0)

PDOStatement->columnCount — Sonuç kümesindeki sütun sayısını döndürür

Açıklama

int PDOStatement::columnCount ( void )

PDOStatement nesnesi ile temsil edilen sonuç kümesindeki sütun sayısını döndürür.

Eğer PDOStatement nesnesi PDO::query() yönteminden dönmüşse sütun sayısı hemen alınabilir.

Eğer PDOStatement nesnesi PDO::prepare() yönteminden dönmüşse sütun sayısı ancak PDOStatement::execute() çağrısından sonra alınabilir.

Dönen Değerler

Sütun sayısı bir tamsayı olarak döner. Bir sonuç kümesi yoksa işlev 0 döndürür.

Örnekler

Örnek 1 - Sütunları saymak

Bu örnekte PDOStatement::columnCount() yönteminin bir sonuç kümesi varken ve yokken kullanımı gösterilmiştir.

<?php
$dbh = new PDO('odbc:sample', 'db2inst1', 'ibmdb2');

$sth = $dbh->prepare("SELECT name, colour FROM fruit");

/* Olmayan sonuç kümesindeki sütunları sayalım */
$colcount = $sth->columnCount();
print("execute() öncesi, sonuç kümesinde $colcount sütun var.\n");

$sth->execute();

/* Count the number of columns in the result set */
$colcount = $sth->columnCount();
print("execute() sonrası, sonuç kümesinde $colcount sütun var.\n");

?>

Yukarıdaki örneğin çıktısı:

execute() öncesi, sonuç kümesinde 0 sütun var.
execute() sonrası, sonuç kümesinde 2 sütun var.

Ayrıca Bakınız

  • PDO::prepare() - Çalıştırılmak üzere bir deyimi hazırlar ve bir deyim nesnesi olarak döndürür
  • PDOStatement::execute() - Bir hazır deyimi çalıştırır
  • PDOStatement::rowCount() - Son SQL deyiminden etkilenen satır sayısını döndürür

PDOStatement->closeCursor
PDOStatement->debugDumpParams
PDOStatement


Bir SQL hazır komutunu dökümler

PDOStatement->columnCount
PDOStatement->errorCode
PDOStatement
PHP Manual

PDOStatement->debugDumpParams

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.9.0)

PDOStatement->debugDumpParams — Bir SQL hazır komutunu dökümler

Açıklama

bool PDOStatement::debugDumpParams ( void )

Bir hazır deyimin içerdiği bilgiyi doğrudan çıktıya dökümler. Bu bilgi, kullanımdaki SQL sorgusu (SQL), kullanılan değiştirge sayısı (Params), isim ve tamsayı olarak türleri (paramtype) ile değiştirge listesi, değiştirgelerin isimleri veya konumları, değerleri ve sorgudaki konumlarını (PDO sürücü destekliyorsa; yoksa -1'dir) içerir.

Bu işlev, veriyi doğrudan çıktıya basan bir hata ayıklama işlevidir.

İpucu

Sonuçlarını doğrudan tarayıcıya çıktılayan her şey gibi, çıktı denetleme işlevleri bu işlevin de çıktısını yakalamak ve (örneğin) string türünde saklamak için kullanılabilir.

İşlev, sadece deyim içindeki değiştirgeleri dökümler. Ek değiştirgeler deyimde saklanmaz ve gösterilmez.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 - İsimli değiştirgelerle PDOStatement::debugDumpParams() örneği

<?php
/* PHP değişkenleriyle ilişkili bir hazır deyim çalıştıralım */
$calories = 150;
$colour = 'red';
$sth = $dbh->prepare('SELECT name, colour, calories
    FROM fruit
    WHERE calories < :calories AND colour = :colour');
$sth->bindParam(':calories', $calories, PDO::PARAM_INT);
$sth->bindValue(':colour', $colour, PDO::PARAM_STR, 12);
$sth->execute();

$sth->debugDumpParams();

?>

Yukarıdaki örneğin çıktısı:

SQL: [96] SELECT name, colour, calories
    FROM fruit
    WHERE calories < :calories AND colour = :colour
Params:  2
Key: Name: [9] :calories
paramno=-1
name=[9] ":calories"
is_param=1
param_type=1
Key: Name: [7] :colour
paramno=-1
name=[7] ":colour"
is_param=1
param_type=2

Örnek 2 - İsimsiz değiştirgelerle PDOStatement::debugDumpParams() örneği

<?php

/* PHP değişkenleriyle ilişkili bir hazır deyim çalıştıralım */
$calories = 150;
$colour = 'red';
$name = 'apple';

$sth = $dbh->prepare('SELECT name, colour, calories
    FROM fruit
    WHERE calories < ? AND colour = ?');
$sth->bindParam(1, $calories, PDO::PARAM_INT);
$sth->bindValue(2, $colour, PDO::PARAM_STR);
$sth->execute();

$sth->debugDumpParams();

?>

Yukarıdaki örneğin çıktısı:

SQL: [82] SELECT name, colour, calories
    FROM fruit
    WHERE calories < ? AND colour = ?
Params:  2
Key: Position #0:
paramno=0
name=[0] ""
is_param=1
param_type=1
Key: Position #1:
paramno=1
name=[0] ""
is_param=1
param_type=2

Ayrıca Bakınız

  • PDO::prepare() - Çalıştırılmak üzere bir deyimi hazırlar ve bir deyim nesnesi olarak döndürür
  • PDOStatement::bindParam() - Bir değiştirgeyi belirtilen değişkenle ilişkilendirir
  • PDOStatement::bindValue() - Bir değeri bir değiştirge ile ilişkilendirir

PDOStatement->columnCount
PDOStatement->errorCode
PDOStatement


Deyim üzerindeki son işlemle ilgili SQLSTATE hata kodunu döndürür

PDOStatement->debugDumpParams
PDOStatement->errorInfo
PDOStatement
PHP Manual

PDOStatement->errorCode

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDOStatement->errorCode — Deyim üzerindeki son işlemle ilgili SQLSTATE hata kodunu döndürür

Açıklama

string PDOStatement::errorCode ( void )

Dönen Değerler

Sadece deyim üzerindeki son işlemle ilgili SQLSTATE hata kodunu döndürmesi dışında PDO::errorCode() yöntemiyle aynıdır.

Örnekler

Örnek 1 - SQLSTATE kodunun döndürülmesi

<?php
/* Bir hata oluşmasını sağlayalım -- BONES diye bir tablo olmasın */
$err = $dbh->prepare('SELECT skull FROM bones');
$err->execute();

echo "\nPDOStatement::errorCode(): ";
print $err->errorCode();
?>

Yukarıdaki örneğin çıktısı:

PDOStatement::errorCode(): 42S02

Ayrıca Bakınız

  • PDO::errorCode() - Veritabanındaki son işlemle ilgili SQLSTATE kodunu döndürür
  • PDO::errorInfo() - Veritabanındaki son işlemle ilgili hata bilgisini döndürür
  • PDOStatement::errorInfo() - Deyim üzerindeki son işlemle ilgili hata bilgisini döndürür

PDOStatement->debugDumpParams
PDOStatement->errorInfo
PDOStatement


Deyim üzerindeki son işlemle ilgili hata bilgisini döndürür

PDOStatement->errorCode
PDOStatement->execute
PDOStatement
PHP Manual

PDOStatement->errorInfo

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDOStatement->errorInfo — Deyim üzerindeki son işlemle ilgili hata bilgisini döndürür

Açıklama

array PDOStatement::errorInfo ( void )

Dönen Değerler

Deyim üzerindeki son işlemle ilgili hata bilgisini bir dizi olarak döndürür. Dizi şu alanları içerir:

Eleman | Bilgi
0 | SQLSTATE hata kodu (ANSI SQL standardında tanımlı 5 abecesayısal karakterli bir betimleyici).
1 | Sürücüye özgü hata kodu.
2 | Sürücüye özgü hata iletisi.

Örnekler

Örnek 1 - Bir DB2 veritabanına açılan bir ODBC bağlantısından hata bilgisinin alınması

<?php
/* Bir hata oluşmasını sağlayalım -- BONES diye bir tablo olmasın */
$sth = $dbh->prepare('SELECT skull FROM bones');
$sth->execute();

echo "\nPDOStatement::errorInfo():\n";
$arr = $sth->errorInfo();
print_r($arr);
?>

Yukarıdaki örneğin çıktısı:

PDOStatement::errorInfo():
Array
(
    [0] => 42S02
    [1] => -204
    [2] => [IBM][CLI Driver][DB2/LINUX] SQL0204N  "DANIELS.BONES" is an
undefined name.  SQLSTATE=42704
)

Ayrıca Bakınız

  • PDO::errorCode() - Veritabanındaki son işlemle ilgili SQLSTATE kodunu döndürür
  • PDO::errorInfo() - Veritabanındaki son işlemle ilgili hata bilgisini döndürür
  • PDOStatement::errorCode() - Deyim üzerindeki son işlemle ilgili SQLSTATE hata kodunu döndürür

PDOStatement->errorCode
PDOStatement->execute
PDOStatement


Bir hazır deyimi çalıştırır

PDOStatement->errorInfo
PDOStatement->fetch
PDOStatement
PHP Manual

PDOStatement->execute

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDOStatement->execute — Bir hazır deyimi çalıştırır

Açıklama

bool PDOStatement::execute ([ array $girdiler = array() ] )

Bir hazır deyimi çalıştırır. Hazır deyim değiştirge içeriyorsa şu ikisinden birini yapmalısınız:

  • Değiştirgeleri veya soru imlerini PHP değişkenleri ile ilişkilendirmek için PDOStatement::bindParam() yöntemini kullanın; değişkenleri, değerleriyle girdi olarak ve çıktı değerini almak için kullanabilirsiniz.
  • Ya da sadece girdi değiştirgelerinin değerlerini bir dizi içinde aktarın.

Değiştirgeler

girdiler

Çalıştırılacak SQL deyimiyle ilişkilendirilmiş değiştirge sayısı kadar değer içeren bir dizi.

Tek bir değiştirgeye birden fazla değer belirtemezsiniz. Örneğin bir IN() yan tümcesindeki tek bir isimli değiştirgeye iki değer belirtemezsiniz.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Değişkenlerle ilişkili bir hazır deyimin çalıştırılması

<?php
/* PHP değişkenleriyle ilişkilendirilmiş bir hazır deyimi çalıştıralım */
$calories = 150;
$colour = 'red';
$sth = $dbh->prepare('SELECT name, colour, calories
    FROM fruit
    WHERE calories < :calories AND colour = :colour');
$sth->bindParam(':calories', $calories, PDO::PARAM_INT);
$sth->bindParam(':colour', $colour, PDO::PARAM_STR, 12);
$sth->execute();
?>

Örnek 2 - Yerleştirilecek değerlere (isimli değiştirgelere) sahip bir hazır deyimin çalıştırılması

<?php
/* Yerleştirilecek değerleri bir dizi olarak aktarmak suretiyle
   bir hazır deyimi çalıştıralım */
$calories = 150;
$colour = 'red';
$sth = $dbh->prepare('SELECT name, colour, calories
    FROM fruit
    WHERE calories < :calories AND colour = :colour');
$sth->execute(array(':calories' => $calories, ':colour' => $colour));
?>

Örnek 3 - - Yerleştirilecek değerlere (soru imli değiştirgelere) sahip bir hazır deyimin çalıştırılması

<?php
/* Yerleştirilecek değerleri bir dizi olarak aktarmak suretiyle
   bir hazır deyimi çalıştıralım */
$calories = 150;
$colour = 'red';
$sth = $dbh->prepare('SELECT name, colour, calories
    FROM fruit
    WHERE calories < ? AND colour = ?');
$sth->execute(array($calories, $colour));
?>

Örnek 4 Soru imli bir hazır deyimin çalıştırılması

<?php
/* PHP değişkenleriyle ilişkilendirilmiş bir hazır deyimi çalıştıralım */
$calories = 150;
$colour = 'red';
$sth = $dbh->prepare('SELECT name, colour, calories
    FROM fruit
    WHERE calories < ? AND colour = ?');
$sth->bindParam(1, $calories, PDO::PARAM_INT);
$sth->bindParam(2, $colour, PDO::PARAM_STR, 12);
$sth->execute();
?>

Ayrıca Bakınız

  • PDO::prepare() - Çalıştırılmak üzere bir deyimi hazırlar ve bir deyim nesnesi olarak döndürür
  • PDOStatement::bindParam() - Bir değiştirgeyi belirtilen değişkenle ilişkilendirir
  • PDOStatement::fetch() - Sonuç kümesindeki sonraki satırı döndürür
  • PDOStatement::fetchAll() - Sonuç kümesinin tüm satırlarını içeren bir dizi döndürür
  • PDOStatement::fetchColumn() - Sonuç kümesindeki sonraki satırdan tek bir sütun döndürür

PDOStatement->errorInfo
PDOStatement->fetch
PDOStatement


Sonuç kümesindeki sonraki satırı döndürür

PDOStatement->execute
PDOStatement->fetchAll
PDOStatement
PHP Manual

PDOStatement->fetch

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDOStatement->fetch — Sonuç kümesindeki sonraki satırı döndürür

Açıklama

 mixed PDOStatement::fetch
  ([ int $alım_tarzı = PDO::FETCH_BOTH
 [, int $göst_yönü = PDO::FETCH_ORI_NEXT
 [, int $göst_başlangıcı = 0
]]] )

PDOStatement nesnesi ile ilişkili sonuç kümesinden bir sonraki satırı döndürür. alım_tarzı değiştirgesi ile PDO'nun satırı nasıl döndüreceği belirtilir.

Değiştirgeler

alım_tarzı

Sonrakı satırın nasıl döndürüleceğini belirtmek için kullanılır. PDO::FETCH_* sabitlerinden biri olmalıdır. PDO::FETCH_BOTH öntanımlı değerdir.

  • PDO::FETCH_ASSOC: Sütun isimlerine göre indisli bir dizi döner.

  • PDO::FETCH_BOTH (öntanımlı): Hem sütun isimlerine hem de sütun numaralarına göre indislenmiş bir dizi döner. İlk sütunun indisi 0'dır.

  • PDO::FETCH_BOUND: Sütun değerlerini PDOStatement::bindColumn() ile ilişkilendirilmiş PHP değişkenlerine atar ve TRUE döndürür.

  • PDO::FETCH_CLASS: İstenen sınıfın özelliklerini sütun isimlerine eşleyerek sınıfın bir örneğini döndürür. Eğer alım_tarzı değiştirgesi PDO::FETCH_CLASSTYPE sabitini içeriyorsa (örn, PDO::FETCH_CLASS | PDO::FETCH_CLASSTYPE) sınıf ismi ilk sütunun değerine göre belirlenir.

  • PDO::FETCH_INTO: İstenen sınıfın mevcut örneğini sütun isimlerini sınıf özelliklerine eşleyerek günceller.

  • PDO::FETCH_LAZY:
PDO::FETCH_BOTH ve
PDO::FETCH_OBJ sabitlerinin birleşimidir.

  • PDO::FETCH_NUM: Sütun numaralarına göre indislenmiş bir dizi döner. İlk sütunun indisi 0'dır.

  • PDO::FETCH_OBJ: Özellik isimlerinin sınıf isimlerine denk düştüğü bir anonim nesne örneği döndürür.

göst_yönü

Kaydırılabilir göstericili bir PDOStatement nesnesi
için, bu değer hangi satırın döndürüleceğini belirler.
PDO::FETCH_ORI_* sabitlerinden biri olmalıdır.
PDO::FETCH_ORI_NEXT öntanımlı değerdir.
PDOStatement nesnenize bir kaydırılabilir gösterici isteği yapmak için
SQL deyimini PDO::prepare() ile hazırlarken
PDO::CURSOR_SCROLL özelliğine
PDO::ATTR_CURSOR özniteliğini atamalısınız.

göst_başlangıcı

Kaydırılabilir göstericili bir PDOStatement nesnesi için göst_yönü değiştirgesinde PDO::FETCH_ORI_ABS belirtilirse bu değer sonuç kümesinden alınacak mutlak satır numarasını belirler.

Kaydırılabilir göstericili bir PDOStatement nesnesi için göst_yönü değiştirgesinde PDO::FETCH_ORI_REL belirtilirse bu değer alınacak satırı bir önceki PDOStatement::fetch() çağrısındaki gösterici konumuna göreli olarak belirler.

Dönen Değerler

Bu işlevin dönüş değeri alım türüne bağlıdır. Bir başarısızlık durumunda daima FALSE döner.

Örnekler

Örnek 1 - Farklı alım tarzlarıyla satırların döndürülmesi

<?php
$sth = $dbh->prepare("SELECT ad, renk FROM meyveler");
$sth->execute();

/* PDOStatement::fetch tarzlarını deneyelim */
print("PDO::FETCH_ASSOC:\n");
print("Sütun isimlerine göre indisli bir dizi olarak:\n");
$result = $sth->fetch(PDO::FETCH_ASSOC);
print_r($result);
print("\n");

print("PDO::FETCH_BOTH:\n");
print("Sütun isimlerine ve numaralarına göre indisli bir dizi olarak:\n");
$result = $sth->fetch(PDO::FETCH_BOTH);
print_r($result);
print("\n");

print("PDO::FETCH_LAZY:\n");
echo "Her özelliğin bir sütun ismine denk düştüğü bir anonim nesne olarak:\n";
$result = $sth->fetch(PDO::FETCH_LAZY);
print_r($result);
print("\n");

print("PDO::FETCH_OBJ:\n");
echo "Her özelliğin bir sütun ismine denk düştüğü bir anonim nesne olarak:\n";
$result = $sth->fetch(PDO::FETCH_OBJ);
print $result->NAME;
print("\n");
?>

Yukarıdaki örneğin çıktısı:

PDO::FETCH_ASSOC:
Sütun isimlerine göre indisli bir dizi olarak:
Array
(
    [AD] => elma
    [RENK] => kırmızı
)

PDO::FETCH_BOTH:
Sütun isimlerine ve numaralarına göre indisli bir dizi olarak:
Array
(
    [AD] => muz
    [0] => muz
    [RENK] => sarı
    [1] => sarı
)

PDO::FETCH_LAZY:
Her özelliğin bir sütun ismine denk düştüğü bir anonim nesne olarak:
PDORow Object
(
    [AD] => portakal
    [RENK] => turuncu
)

PDO::FETCH_OBJ:
Her özelliğin bir sütun ismine denk düştüğü bir anonim nesne olarak:
kivi

Örnek 2 - Satırları bir kaydırılabilir gösterici ile döndürmek

<?php
function readDataForwards($dbh) {
  $sql = 'SELECT hand, won, bet FROM mynumbers ORDER BY BET';
  try {
    $stmt = $dbh->prepare($sql,
              array(PDO::ATTR_CURSOR => PDO::CURSOR_SCROLL));
    $stmt->execute();
    while ($row = $stmt->fetch(PDO::FETCH_NUM, PDO::FETCH_ORI_NEXT)) {
      $data = $row[0] . "\t" . $row[1] . "\t" . $row[2] . "\n";
      print $data;
    }
    $stmt = null;
  }
  catch (PDOException $e) {
    print $e->getMessage();
  }
}
function readDataBackwards($dbh) {
  $sql = 'SELECT hand, won, bet FROM mynumbers ORDER BY bet';
  try {
    $stmt = $dbh->prepare($sql,
              array(PDO::ATTR_CURSOR => PDO::CURSOR_SCROLL));
    $stmt->execute();
    $row = $stmt->fetch(PDO::FETCH_NUM, PDO::FETCH_ORI_LAST);
    do {
      $data = $row[0] . "\t" . $row[1] . "\t" . $row[2] . "\n";
      print $data;
    } while ($row = $stmt->fetch(PDO::FETCH_NUM, PDO::FETCH_ORI_PRIOR));
    $stmt = null;
  }
  catch (PDOException $e) {
    print $e->getMessage();
  }
}

print "İleriye doğru okuma:\n";
readDataForwards($conn);

print "Geriye doğru okuma:\n";
readDataBackwards($conn);
?>

Yukarıdaki örneğin çıktısı:

İleriye doğru okuma:
21    10    5
16    0     5
19    20    10

Geriye doğru okuma:
19    20    10
16    0     5
21    10    5

Ayrıca Bakınız

  • PDO::prepare() - Çalıştırılmak üzere bir deyimi hazırlar ve bir deyim nesnesi olarak döndürür
  • PDOStatement::execute() - Bir hazır deyimi çalıştırır
  • PDOStatement::fetchAll() - Sonuç kümesinin tüm satırlarını içeren bir dizi döndürür
  • PDOStatement::fetchColumn() - Sonuç kümesindeki sonraki satırdan tek bir sütun döndürür
  • PDOStatement::fetchObject() - Sonraki satırı bir nesne olarak döndürür
  • PDOStatement::setFetchMode() - Deyim için öntanımlı veri alım kipini belirler

PDOStatement->execute
PDOStatement->fetchAll
PDOStatement


Sonuç kümesinin tüm satırlarını içeren bir dizi döndürür

PDOStatement->fetch
PDOStatement->fetchColumn
PDOStatement
PHP Manual

PDOStatement->fetchAll

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDOStatement->fetchAll — Sonuç kümesinin tüm satırlarını içeren bir dizi döndürür

Açıklama

array PDOStatement::fetchAll ([ int $alım_tarzı = PDO::FETCH_BOTH [, int $sütunnum [, array $değiştirgeler = array() ]]] )

Değiştirgeler

alım_tarzı

PDOStatement::fetch() yönteminde açıklandığı gibi döndürülen dizinin içeriğini belirleyen sabit. PDO::FETCH_BOTH öntanımlıdır.

Sonuç kümesindeki tek bir sütunun tüm değerleri içeren bir dizi döndürmek için PDO::FETCH_COLUMN belirtin. Bu durumda hangi sütunun içeriğinin alınacağını sütunnum ile belirtin.

Sonuç kümesindeki tek bir sütunun eşsiz değerleri içeren bir dizi döndürmek için PDO::FETCH_COLUMN ile PDO::FETCH_UNIQUE sabitini bit seviyesinde VEYAlayın.

Belirtilen sütunun değerlerine göre gruplanmış bir ilişkisel dizi döndürmek için PDO::FETCH_COLUMN ile PDO::FETCH_GROUP sabitini bit seviyesinde VEYAlayın.

sütunnum

alım_tarzı değiştirgesinde PDO::FETCH_COLUMN belirtildiği takdirde alınacak sütun numarası burada belirtilir. İlk sütunun indisi 0 olup öntanımlı değerdir.

değiştirgeler

Bu dizinin elemanları kurucuya değiştirge olarak aktarılır..

Dönen Değerler

Sonuç kümesinde kalan satırların tümünü bir dizi olarak döndürür. Dizinin her elemanı birer satır içerir ve bu satır elemanları sütun değerlerini içeren bir dizi ya da sütun isimlerinin özelliklere karşı düştüğü bir nesne içerir.

Büyük sonuç kümelerini almak için bu yöntemi kullanmak sistem ve muhtemelen ağ kaynaklarından aşırı taleplere yol açar. Tüm veriyi alıp PHP ile işleme tabi tutmak yerine sonuç kümeleri üzerinde işlem yapmak için veritabanı sunucusunu kullanmak daha iyi olabilir. Örneğin, SQL'de WHERE ve SORT BY yan tümcelerini kullanarak, PHP'de işleme sokmadan önce sonuç kümesini küçültebilirsiniz.

Örnekler

Örnek 1 - Bir sonuç kümesinde kalan tüm satırları almak

<?php
$sth = $dbh->prepare("SELECT ad, renk FROM meyveler");
$sth->execute();

/* Sonuç kümesindeki tüm satırları alalım */
print("Sonuç kümesindeki tüm satırlar:\n");
$result = $sth->fetchAll();
print_r($result);
?>

Yukarıdaki örneğin çıktısı:

Sonuç kümesindeki tüm satırlar:
Array
(
    [0] => Array
        (
            [AD] => armut
            [0] => armut
            [RENK] => yeşil
            [1] => yeşil
        )

    [1] => Array
        (
            [AD] => ahududu
            [0] => ahududu
            [RENK] => mor
            [1] => mor
        )

)

Örnek 2 - Sonuç kümesinden tek bir sütunun tüm değerlerini almak

Aşağıdaki örnekte, SQL deyimi her satırda çok sayıda sütun döndürse bile bu sonuç kümesinden tek bir sütunun tüm değerlerinin nasıl alınacağı gösterilmiştir.

<?php
$sth = $dbh->prepare("SELECT isim, renk FROM meyveler");
$sth->execute();

/* İlk sütunun tüm değerlerini alalım */
$result = $sth->fetchAll(PDO::FETCH_COLUMN, 0);
var_dump($result);
?>

Yukarıdaki örneğin çıktısı:

Array(3)
(
    [0] =>
    string(5) => elma
    [1] =>
    string(4) => armut
    [2] =>
    string(10) => ahududu
)

Örnek 3 - Tüm değerleri tek bir sütuna göre gruplamak

Aşağıdaki örnekte, sonuç kümesindeki belli bir sütunun değerlerine göre gruplanmış bir ilişkisel dizini nasıl döndürüleceği gösterilmiştir. Dizi üç anahtar içerir: Elma ve armut iki farklı renk içeren iki dizi olarak ahududu ise tek renk içeren bir dizi olarak döndürülür.

<?php
$insert = $dbh->prepare("INSERT INTO fruit(isim, renk) VALUES (?, ?)");
$insert->execute(array('elma', 'yeşil'));
$insert->execute(array('armut', 'sarı'));

$sth = $dbh->prepare("SELECT isim, renk FROM meyveler");
$sth->execute();

/* Değerleri ilk sütuna göre gruplayalım */
var_dump($sth->fetchAll(PDO::FETCH_COLUMN|PDO::FETCH_GROUP));
?>

Yukarıdaki örneğin çıktısı:

array(3) {
  ["elma"]=>
  array(2) {
    [0]=>
    string(5) "yeşil"
    [1]=>
    string(3) "kırmızı"
  }
  ["armut"]=>
  array(2) {
    [0]=>
    string(5) "yeşil"
    [1]=>
    string(6) "sarı"
  }
  ["ahududu"]=>
  array(1) {
    [0]=>
    string(5) "mor"
  }
}

Ayrıca Bakınız

  • PDO::query() - Bir SQL deyimini çalıştırıp sonucu bir PDOStatement nesnesi olarak döndürür
  • PDOStatement::fetch() - Sonuç kümesindeki sonraki satırı döndürür
  • PDOStatement::fetchColumn() - Sonuç kümesindeki sonraki satırdan tek bir sütun döndürür
  • PDO::prepare() - Çalıştırılmak üzere bir deyimi hazırlar ve bir deyim nesnesi olarak döndürür
  • PDOStatement::setFetchMode() - Deyim için öntanımlı veri alım kipini belirler

PDOStatement->fetch
PDOStatement->fetchColumn
PDOStatement


Sonuç kümesindeki sonraki satırdan tek bir sütun döndürür

PDOStatement->fetchAll
PDOStatement->fetchObject
PDOStatement
PHP Manual

PDOStatement->fetchColumn

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.9.0)

PDOStatement->fetchColumn — Sonuç kümesindeki sonraki satırdan tek bir sütun döndürür

Açıklama

string PDOStatement::fetchColumn ([ int $sütunnum = 0 ] )

Sonuç kümesindeki sonraki satırdan tek bir sütun döndürür; ortada satır kalmamışsa FALSE döner.

Değiştirgeler

sütunnum

Sütunun numarası. İlk sütunun indisi 0'dır. Değiştirgede hiçbir değer belirtilmemişse ilk sütunun değeri döner.

Dönen Değerler

Sütun değerini bir dizge olarak döndürür.

Uyarı

Veriyi almak için PDOStatement::fetchColumn() yöntemini kullanırsanız aynı satırdan artık başka bir sütun döndüremezsiniz.

Örnekler

Örnek 1 - Sonraki satırın ilk sütununu döndürmek

<?php
$sth = $dbh->prepare("SELECT isim, renk FROM meyveler");
$sth->execute();

/* Sonraki satırın ilk sütununu döndürelim */
print("Sonuç kümesindeki sonraki satırın ilk sütunu:\n");
$result = $sth->fetchColumn();
print("name = $result\n");

print("Sonuç kümesindeki sonraki satırın ikinci sütunu:\n");
$result = $sth->fetchColumn(1);
print("colour = $result\n");
?>

Yukarıdaki örneğin çıktısı:

Sonuç kümesindeki sonraki satırın ilk sütunu:
isim = limon
Sonuç kümesindeki sonraki satırın ikinci sütunu:
renk = kırmızı

Ayrıca Bakınız

  • PDO::query() - Bir SQL deyimini çalıştırıp sonucu bir PDOStatement nesnesi olarak döndürür
  • PDOStatement::fetch() - Sonuç kümesindeki sonraki satırı döndürür
  • PDOStatement::fetchAll() - Sonuç kümesinin tüm satırlarını içeren bir dizi döndürür
  • PDO::prepare() - Çalıştırılmak üzere bir deyimi hazırlar ve bir deyim nesnesi olarak döndürür
  • PDOStatement::setFetchMode() - Deyim için öntanımlı veri alım kipini belirler

PDOStatement->fetchAll
PDOStatement->fetchObject
PDOStatement


Sonraki satırı bir nesne olarak döndürür

PDOStatement->fetchColumn
PDOStatement->getAttribute
PDOStatement
PHP Manual

PDOStatement->fetchObject

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.2.4)

PDOStatement->fetchObject — Sonraki satırı bir nesne olarak döndürür

Açıklama

mixed PDOStatement::fetchObject ([ string $sınıfadı [, array $değiştirgeler ]] )

Sonraki satırı bir nesne olarak döndürür. Bu yöntem
PDOStatement::fetch() yönteminin
PDO::FETCH_CLASS veya
PDO::FETCH_OBJ tarzıyla kullanımına denktir.

Değiştirgeler

sınıfadı

Oluşturulan sınıfın ismi; stdClass öntanımlı değerdir.

değiştirgeler

Bu dizinin elemanları kurucuya değiştirge olarak aktarılır.

Dönen Değerler

Sütun isimlerinin özellik isimlerine denk düştüğü sınıfın bir örneğini döndürür. İşlem sırasında bir hata oluşursa FALSE döner.

Ayrıca Bakınız

  • PDOStatement::fetch() - Sonuç kümesindeki sonraki satırı döndürür

PDOStatement->fetchColumn
PDOStatement->getAttribute
PDOStatement


Bir deyim özniteliğinin değerini döndürür

PDOStatement->fetchObject
PDOStatement->getColumnMeta
PDOStatement
PHP Manual

PDOStatement->getAttribute

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.2.0)

PDOStatement->getAttribute — Bir deyim özniteliğinin değerini döndürür

Açıklama

mixed PDOStatement::getAttribute ( int $öznitelik )

Bir deyim özniteliğinin değerini döndürür. Henüz tek bir sürücüye özel özniteliğin dışında öznitelik yoktur:

  • PDO::ATTR_CURSOR_NAME (Firebird ve ODBC'ye özgüdür): UPDATE ... WHERE CURRENT OF için gösterici ismini içerir.

Dönen Değerler

Özniteliğin değeri.

Ayrıca Bakınız

  • PDO::getAttribute() - Bir veritabanı bağlantı özniteliğinin değerini döndürür
  • PDO::setAttribute() - Bir öznitelik tanımlar
  • PDOStatement::setAttribute() - Bir deyim özniteliğini tanımlar

PDOStatement->fetchObject
PDOStatement->getColumnMeta
PDOStatement


Sonuç kümesindeki bir sütunla ilgili temel veriyi döndürür

PDOStatement->getAttribute
PDOStatement->nextRowset
PDOStatement
PHP Manual

PDOStatement->getColumnMeta

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.2.0)

PDOStatement->getColumnMeta — Sonuç kümesindeki bir sütunla ilgili temel veriyi döndürür

Açıklama

array PDOStatement::getColumnMeta ( int $sütun )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Sütun numarası belirtilen sütunla ilgili temel verileri içeren bir ilişkisel dizi döndürür.

Uyarı

PDOStatement::getColumnMeta() yöntemini her veritabanı sürücüsü desteklemez.

Değiştirgeler

sütun

Sütun numarası; ilk sütunun numarası 0'dır.

Dönen Değerler

Aşağıdaki alanlara sahip bir ilişkisel dizi döner:

Sütun temel verisi
İsim | Değerin açıklaması
native_type | Sütun değerinin PHP veri türü.
driver:decl_type | Veritabanındaki sütun değerinin SQL veri türü. Eğer sonuç kümesindeki sütun bir işlevin sonucu ise bu değer PDOStatement::getColumnMeta() tarafından döndürülmez.
flags | Bu sütun için tanımlı seçenek kümesi.
isim | Sütunun ismi.
table | Sütunu içeren tablonun ismi.
len | Sütunun genişliği. Onluk gerçek sayılar dışındaki türler için normalde -1'dir.
precision | Sütunun sayısal hassasiyeti. Onluk gerçek sayılar dışındaki türler için normalde 0'dır.
pdo_type | Sütun türünü gösteren PDO::PARAM_* sabitlerinden biri.

İstenen sütun sonuç kümesinde yoksa veya hiç sonuç kümesi yoksa FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.2.3 | Dönen diziye table alanı eklendi.

Örnekler

Örnek 1 - Sütun temel verilerinin alınması

Aşağıdaki örnekte bir PDO_SQLITE sürücüsünde bir işlev (COUNT) tarafından üretilen sonuç kümesindeki tek sütunla ilgili temel verilerin elde edilmesi gösterilmiştir.

<?php
$select = $DB->query('SELECT COUNT(*) FROM fruit');
$meta = $select->getColumnMeta(0);
var_dump($meta);
?>

Yukarıdaki örneğin çıktısı:

array(6) {
  ["native_type"]=>
  string(7) "integer"
  ["flags"]=>
  array(0) {
  }
  ["name"]=>
  string(8) "COUNT(*)"
  ["len"]=>
  int(-1)
  ["precision"]=>
  int(0)
  ["pdo_type"]=>
  int(2)
}

Ayrıca Bakınız

  • PDOStatement::columnCount() - Sonuç kümesindeki sütun sayısını döndürür
  • PDOStatement::rowCount() - Son SQL deyiminden etkilenen satır sayısını döndürür

PDOStatement->getAttribute
PDOStatement->nextRowset
PDOStatement


Çok satır kümeli bir sonuçtaki sonraki satır kümesini geçerli satır kümesi yapar

PDOStatement->getColumnMeta
PDOStatement->rowCount
PDOStatement
PHP Manual

PDOStatement->nextRowset

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.2.0)

PDOStatement->nextRowset — Çok satır kümeli bir sonuçtaki sonraki satır kümesini geçerli satır kümesi yapar

Açıklama

bool PDOStatement::nextRowset ( void )

Bazı veritabanları birden fazla satır kümesi (sonuç kümesi diye de bilinir) döndüren kayıtlı yordamları destekler. PDOStatement::nextRowset() yordamını kullaranak bir PDOStatement nesnesi ile ilişkili satır kümelerinin ikincisine ve sırayla sonraki satır kümelerine erişebilirsiniz. Her satır kümesi diğerlerinden farklı sütunlardan oluşabilir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Bir kayıtlı yordamdan dönen çok sayıda satır kümesine erişim

Aşağıdaki örnekte üç satır kümesi döndüren bir kayıtlı yordam çağrısının yapılışı gösterilmiştir. Döndürülecek satır kümesi kalmayınca FALSE döndüren PDOStatement::nextRowset() yönteminin bu özelliğini bir do / while döngüsünde kullanabiliriz.

<?php
$sql = 'CALL multiple_rowsets()';
$stmt = $conn->query($sql);
$i = 1;
do {
    $rowset = $stmt->fetch(PDO::FETCH_NUM);
    if ($rowset) {
        printResultSet($rowset, $i);
    }
    $i++;
} while ($stmt->nextRowset());

function printResultSet(&$rowset, $i) {
    print "$i. sonuç kümesi:\n";
    foreach ($rowset as $row) {
        foreach ($row as $col) {
            print $col . "\t";
        }
        print "\n";
    }
    print "\n";
}
?>

Yukarıdaki örneğin çıktısı:

1. sonuç kümesi:
apple    red
banana   yellow

2. sonuç kümesi:
orange   orange    150
banana   yellow    175

3. sonuç kümesi:
lime     green
apple    red
banana   yellow

Ayrıca Bakınız

  • PDOStatement::columnCount() - Sonuç kümesindeki sütun sayısını döndürür
  • PDOStatement::execute() - Bir hazır deyimi çalıştırır
  • PDOStatement::getColumnMeta() - Sonuç kümesindeki bir sütunla ilgili temel veriyi döndürür
  • PDO::query() - Bir SQL deyimini çalıştırıp sonucu bir PDOStatement nesnesi olarak döndürür

PDOStatement->getColumnMeta
PDOStatement->rowCount
PDOStatement


Son SQL deyiminden etkilenen satır sayısını döndürür

PDOStatement->nextRowset
PDOStatement->setAttribute
PDOStatement
PHP Manual

PDOStatement->rowCount

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.1.0)

PDOStatement->rowCount — Son SQL deyiminden etkilenen satır sayısını döndürür

Açıklama

int PDOStatement::rowCount ( void )

PDOStatement nesnesi tarafından çalıştırılan son DELETE, INSERT veya UPDATE deyiminden etkilenen satır sayısını döndürür.

Eğer PDOStatement nesnesi ile ilişkili deyim bir SELECT deyimi ise bazı veritabanları bu deyimden etkilenen satır sayısını da döndürebilmektedir. Ancak bu davranış tüm veritabanları için garanti edilmediğinden taşınıbilir bir uygulamada bu davranışa itibar edilmemelidir.

Dönen Değerler

Etkilenen satır sayısı.

Örnekler

Örnek 1 - Silinen satır sayısının döndürülmesi

PDOStatement::rowCount() bir DELETE, INSERT veya UPDATE deyiminden etkilenen satır sayısını döndürür.

<?php
/* FRUIT tablosundaki tüm satırları silelim */
$del = $dbh->prepare('DELETE FROM fruit');
$del->execute();

/* Silinen satır sayısını döndürelim */
$count = $del->rowCount();
print("$count satır silindi.\n");
?>

Yukarıdaki örneğin çıktısı:

9 satır silindi.

Örnek 2 - Bir SELECT deyiminden etkilenen satırların sayılması

Çoğu veritabanında PDOStatement::rowCount() bir SELECT deyiminden etkilenen satır sayısını döndürmez. Bu bakımdan, SELECT deyiminde kullandığınız yüklemlerin kullanıldığı bir SELECT COUNT(*) deyimi ile yapacağınız bir PDO::query() çağrısından sonra bir PDOStatement::fetchColumn() çağrısı ile etkilenen satır sayısını elde edebilirsiniz.

<?php
$sql = "SELECT COUNT(*) FROM fruit WHERE calories > 100";
if ($res = $conn->query($sql)) {

    /* Bu deyimden etkilenen satır sayısına bakalım */
  if ($res->fetchColumn() > 0) {

        /* Gerçek SELECT deyimini kullanarak sonuçları alabiliriz */
         $sql = "SELECT name FROM fruit WHERE calories > 100";
       foreach ($conn->query($sql) as $row) {
           print "Meyve: " .  $row['NAME'] . "\n";
         }
    }
    /* Etkilenen satır yokmuş; gereğini yapalım */
  else {
      print "Sorguyla eşleşen satır yok.";
    }
}

$res = null;
$conn = null;
?>

Yukarıdaki örneğin çıktısı:

apple
banana
orange
pear

Ayrıca Bakınız

  • PDOStatement::columnCount() - Sonuç kümesindeki sütun sayısını döndürür
  • PDOStatement::fetchColumn() - Sonuç kümesindeki sonraki satırdan tek bir sütun döndürür
  • PDO::query() - Bir SQL deyimini çalıştırıp sonucu bir PDOStatement nesnesi olarak döndürür

PDOStatement->nextRowset
PDOStatement->setAttribute
PDOStatement


Bir deyim özniteliğini tanımlar

PDOStatement->rowCount
PDOStatement->setFetchMode
PDOStatement
PHP Manual

PDOStatement->setAttribute

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.2.0)

PDOStatement->setAttribute — Bir deyim özniteliğini tanımlar

Açıklama

bool PDOStatement::setAttribute ( int $öznitelik , mixed $değer )

Belirtilen deyim özniteliğine bir değer atar. Şimdilik genele yönelik hiç öznitelik yoktur. Sürücüye özel tek bir öznitelik vardır:

  • PDO::ATTR_CURSOR_NAME (Firebird ve ODBC'ye özel): UPDATE ... WHERE CURRENT OF deyimi için gösterici ismini belirler.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • PDO::getAttribute() - Bir veritabanı bağlantı özniteliğinin değerini döndürür
  • PDO::setAttribute() - Bir öznitelik tanımlar
  • PDOStatement::getAttribute() - Bir deyim özniteliğinin değerini döndürür

PDOStatement->rowCount
PDOStatement->setFetchMode
PDOStatement


Deyim için öntanımlı veri alım kipini belirler

PDOStatement->setAttribute
PDOException
PDOStatement
PHP Manual

PDOStatement->setFetchMode

(PHP 5 >= 5.1.0, PHP 7, PECL pdo >= 0.2.0)

PDOStatement->setFetchMode — Deyim için öntanımlı veri alım kipini belirler

Açıklama

bool PDOStatement::setFetchMode ( int $kip )
bool PDOStatement::setFetchMode ( int $PDO::FETCH_COLUMN , int $sütunnum )
bool PDOStatement::setFetchMode ( int $PDO::FETCH_CLASS , string $sınıfadı , array $değiştirgeler )
bool PDOStatement::setFetchMode ( int $PDO::FETCH_INTO , object $nesne )

Değiştirgeler

kip

PDO::FETCH_* sabitlerinden biri olarak veri alım kipi.

sütunnum

Sütun numarası.

sınıfadı

Sınıf adı.

değiştirgeler

Kurucu değiştirgeleri.

nesne

Nesne.

Dönen Değerler

Başarı durumunda 1 aksi takdirde FALSE.

Örnekler

Örnek 1 - Veri alım kipinin belirlenmesi

Aşağıdaki örnekte bir PDOStatement nesnesinin veri alım kipinin PDOStatement::setFetchMode() ile nasıl değiştirileceği gösterilmiştir.

<?php
$sql = 'SELECT isim, renk, kalori FROM meyveler';
try {
  $stmt = $dbh->query($sql);
  $result = $stmt->setFetchMode(PDO::FETCH_NUM);
  while ($col = $stmt->fetch()) {
    print $col[0] . "\t" . $col[1] . "\t" . $col[2] . "\n";
  }
}
catch (PDOException $e) {
  print $e->getMessage();
}
?>

Yukarıdaki örneğin çıktısı:

elma      kırmızı     150
muz       sarı        250
portakal  turuncu     300
kivi      kahverengi  75
limon     sarı        25
armut     yeşil       150
ahududu   mor         90

PDOStatement->setAttribute
PDOException
PDOStatement


PDOException sınıfı

(PHP 5 >= 5.1.0, PHP 7)

Giriş

PDO tarafından oluşturulan bir hatayı temsil eder. Kendi kodunuzda bir PDOException oluşturmamalısınız. PHP'deki istisnalar hakkında bilgi edinmek için İstisnalar bölümüne bakınız.

Sınıf Sözdizimi

PDOException extends RuntimeException {
/* Özellikler */
public array $errorInfo ;
protected string $message ;
protected string $code ;
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}

Özellikler

errorInfo

PDO::errorInfo() veya PDOStatement::errorInfo() yöntemine karşılıktır.

message

Hatanın iletisi. Erişmek için Exception::getMessage() yöntemini kullanın.

code

SQLSTATE hata kodu. Erişmek için Exception::getCode() yöntemini kullanın.

PDOStatement->setFetchMode
PDO Sürücüleri
PDO


PDO Sürücüleri

İçindekiler

  • CUBRID (PDO)
  • MS SQL Sunucusu (PDO)
  • Firebird/Interbase (PDO)
  • IBM (PDO)
  • Informix (PDO)
  • MySQL (PDO)
  • MS SQL Server (PDO)
  • Oracle (PDO)
  • ODBC ve DB2 (PDO)
  • PostgreSQL (PDO)
  • SQLite (PDO)
  • PDO_4D sürücüsü

PDO arayüzü tarafından gerçeklenmiş sürücüler:

Sürücü ismi | Desteklenen veritabanları
PDO_CUBRID | Cubrid
PDO_DBLIB | FreeTDS / Microsoft SQL Sunucusu / Sybase
PDO_FIREBIRD | Firebird/Interbase 6
PDO_IBM | IBM DB2
PDO_INFORMIX | IBM Informix Devingen Sunucusu
PDO_MYSQL | MySQL 3.x/4.x/5.x
PDO_OCI | Oracle Çağrı Arayüzü
PDO_ODBC | ODBC v3 (IBM DB2, unixODBC ve win32 ODBC)
PDO_PGSQL | PostgreSQL
PDO_SQLITE | SQLite 3 ve SQLite 2
PDO_SQLSRV | Microsoft SQL Server / SQL Azure
PDO_4D | 4D

PDOException
CUBRID (PDO)
PDO


CUBRID Functions (PDO_CUBRID)

Giriş

PDO_CUBRID is a driver that implements the PHP Data Objects (PDO) interface to enable access from PHP to CUBRID databases.

Bilginize:

Current version of PDO_CUBRID doesn't support persistent connection now.

Kurulum

To build the PDO_CUBRID extension, the CUBRID DBMS must be installed on the same system as PHP. PDO_CUBRID is a » PECL extension, so follow the instructions in PECL eklentilerinin kurulması to install the PDO_CUBRID extension. Issue the configure command to point to the location of your CUBRID base dir as follows:

   $ ./configure --with-pdo-cubrid=/path/to/CUBRID[,shared]
The configure command defaults to the value of the CUBRID environment variable.

Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız. Detailed information about installation on Linux and Windows manually, please read build-guide.html in PECL package CUBRID for reference.

Features

PDO_CUBRID Features
Feature | Description
Scrollable cursors | PDO_CUBRID supports scrollable cursors. The default cursor type is forward only, and you can use parameter driver_options in PDO::prepare() to change cursor type.
Timeout | PDO_CUBRID supports sql statement execution timeout setting; You can use PDO::setAttribute() to set timeout value.
Autocommit_mode and Transaction PDO_CUBRID supports both autocommit_mode and transaction, and autocommit_mode is enabled by default. You can use PDO::setAttribute() to change its state.

If you use PDO::beginTransaction() to begin a transaction, it will disable autocommit_mode automatically and restore it after PDO::commit() or PDO::rollBack(). Note that before disabling the autocommit_mode, any pending work is automatically committed.

Multiple SQL Statements | PDO_CUBRID supports Multiple SQL statements. Multiple SQL statements are separated by semicolons (;)
Schema Information | PDO_CUBRID implements a function PDO::cubrid_schema() to get schema information.
LOBs PDO_CUBRID supports BLOB/CLOB data type. The LOB in PDO is represented as a stream, so you can insert LOBs by binding a stream, and get LOBs by reading a stream returned by CUBRID PDO. For example:

Örnek 1 Insert LOBs in CUBRID PDO

<?php
$fp = fopen('lob_test.png', 'rb');

$sql_stmt = "INSERT INTO lob_test(name, content) VALUES('lob_test.png', ?)";

$stmt = $dbh->prepare($sql_stmt);
$ret = $stmt->bindParam(1, $fp, PDO::PARAM_LOB);
$ret = $stmt->execute();
?>

Örnek 2 Fetch LOBs in CUBRID PDO

<?php
$sql_stmt = "SELECT content FROM lob_test WHERE name='lob_test.png'";

$stmt = $dbh->prepare($sql_stmt);
$stmt->execute();
$result = $stmt->fetch(PDO::FETCH_NUM);

header("Content-Type: image/png");
fpassthru($result[0]);
?>

Column meta The PDOStatement::getColumnMeta() in CUBRID PDO will return an associative array containing the following values:
  • type
  • name
  • table
  • def
  • precision
  • scale
  • not_null
  • auto_increment
  • unique_key
  • multiple_key
  • primary_key
  • foreign_key
  • reverse_index
  • reverse_unique
Collection Data Type PDO_CUBRID supports SET/MULTISET/SEQUENCE data type. If you don't specify data type, the default data type is char,for example:

Örnek 3 Insert set in CUBRID PDO with default data type.

<?php
$conn_str ="cubrid:dbname=demodb;host=localhost;port=33000";
$cubrid_pdo = new PDO($conn_str, 'dba', '');

$cubrid_pdo->exec("DROP TABLE if exists test_tbl");
$cubrid_pdo->exec("CREATE TABLE test_tbl (col_1 SET(VARCHAR))");

$sql_stmt_insert = "INSERT INTO test_tbl VALUES (?);";
$stmt = $cubrid_pdo->prepare($sql_stmt_insert);
$data = array("abc","def","ghi");
$ret = $stmt->bindParam(1, $data, PDO::PARAM_NULL);
$ret = $stmt->execute();
var_Dump($ret);
?>

Örnek 4 Specify data type when insert set in CUBRID PDO

<?php
$conn_str ="cubrid:dbname=demodb;host=localhost;port=33000";
$cubrid_pdo = new PDO($conn_str, 'dba', '');

$cubrid_pdo->exec("DROP TABLE if exists test_tbl");
$cubrid_pdo->exec("CREATE TABLE test_tbl (col_1 SET(int))");

$sql_stmt_insert = "INSERT INTO test_tbl VALUES (?);";
$stmt = $cubrid_pdo->prepare($sql_stmt_insert);
$data = array(1,2,3,4);
$ret = $stmt->bindParam(1, $data, 0,0,"int");
$ret = $stmt->execute();
var_Dump($ret);
?>

CUBRID Bind Data Types:(The fifth parameter of PDOStatement::bindParam):
  • CHAR
  • STRING
  • NCHAR
  • VARNCHAR
  • BIT
  • VARBIT
  • NUMERIC
  • NUMBER
  • INT
  • SHORT
  • BIGINT
  • MONETARY
  • FLOAT
  • DOUBLE
  • DATE
  • TIME
  • DATETIME
  • TIMESTAMP

Öntanımlı Sabitler

Bu sabitler bu sürücü tarafından tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir. Ek olarak, bu sürücüye özgü sabitler sadece bu sürücüyü kullanıyorsanız kullanılmalıdır. Sürücüye özgü özniteliklerin postgres sürücüsü ile kullanılması beklenmedik davranışlara yol açabilir. Eğer kodunuz çok sayıda sürücüye karşı çalışıyorsa sürücüyü sınayacak PDO_ATTR_DRIVER_NAME özniteliğini sağlamak için PDO::getAttribute() kullanılabilir.

The following constants can be used when setting the database attribute. They can be passed to PDO::getAttribute() or PDO::setAttribute().

PDO::CUBRID attribute flags
Constant | Description
PDO::CUBRID_ATTR_ISOLATION_LEVEL | Transaction isolation level for the database connection.
PDO::CUBRID_ATTR_LOCK_TIMEOUT | Transaction timeout in seconds.
PDO::CUBRID_ATTR_MAX_STRING_LENGTH | Read only. The maximum string length for bit, varbit, char, varchar, nchar, nchar varying data types when using CUBRID PDO API.

The following constants can be used when setting the transaction isolation level. They can be passed to PDO::getAttribute() or returned by PDO::setAttribute().

PDO::CUBRID isolation level flags
Constant | Description
PDO::TRAN_COMMIT_CLASS_UNCOMMIT_INSTANCE | The lowest isolation level (1). A dirty, non-repeatable or phantom read may occur for the tuple and a non-repeatable read may occur for the table as well.
PDO::TRAN_COMMIT_CLASS_COMMIT_INSTANCE | A relatively low isolation level (2). A dirty read does not occur, but non-repeatable or phantom read may occur.
PDO::TRAN_REP_CLASS_UNCOMMIT_INSTANCE | The default isolation of CUBRID (3). A dirty, non-repeatable or phantom read may occur for the tuple, but repeatable read is ensured for the table.
PDO::TRAN_REP_CLASS_COMMIT_INSTANCE | A relatively low isolation level (4). A dirty read does not occur, but non-repeatable or phantom read may.
PDO::TRAN_REP_CLASS_REP_INSTANCE | A relatively high isolation level (5). A dirty or non-repeatable read does not occur, but a phantom read may.
PDO::TRAN_SERIALIZABLE | The highest isolation level (6). Problems concerning concurrency (e.g. dirty read, non-repeatable read, phantom read, etc.) do not occur.

The following constants can be used when getting schema information. They can be passed to PDO::cubrid_schema().

PDO::CUBRID schema flags
Constant | Description
PDO::CUBRID_SCH_TABLE | Get name and type of table in CUBRID.
PDO::CUBRID_SCH_VIEW | Get name and type of view in CUBRID.
PDO::CUBRID_SCH_QUERY_SPEC | Get the query definition of view.
PDO::CUBRID_SCH_ATTRIBUTE | Get the attributes of table column.
PDO::CUBRID_SCH_TABLE_ATTRIBUTE | Get the attributes of table.
PDO::CUBRID_SCH_METHOD | Get the instance method. The instance method is a method called by a class instance. It is used more often than the class method because most operations are executed in the instance.
PDO::CUBRID_SCH_TABLE_METHOD | Get the class method. The class method is a method called by a class object. It is usually used to create a new class instance or to initialize it. It is also used to access or update class attributes.
PDO::CUBRID_SCH_METHOD_FILE | Get the information of the file where the method of the table is defined.
PDO::CUBRID_SCH_SUPER_TABLE | Get the name and type of table which table inherites attributes from.
PDO::CUBRID_SCH_SUB_TABLE | Get the name and type of table which inherites attributes from this table.
PDO::CUBRID_SCH_CONSTRAINT | Get the table constraints.
PDO::CUBRID_SCH_TRIGGER | Get the table triggers.
PDO::CUBRID_SCH_TABLE_PRIVILEGE | Get the privilege information of table.
PDO::CUBRID_SCH_COL_PRIVILEGE | Get the privilege information of column.
PDO::CUBRID_SCH_DIRECT_SUPER_TABLE | Get the direct super table of table.
PDO::CUBRID_SCH_PRIMARY_KEY | Get the table primary key.
PDO::CUBRID_SCH_IMPORTED_KEYS | Get imported keys of table.
PDO::CUBRID_SCH_EXPORTED_KEYS | Get exported keys of table.
PDO::CUBRID_SCH_CROSS_REFERENCE | Get reference relationship of tow tables.

İçindekiler

  • PDO_CUBRID DSN — Connecting to CUBRID databases
  • PDO::cubrid_schema — Get the requested schema information
PDO Sürücüleri
PDO_CUBRID DSN
PDO Sürücüleri


Connecting to CUBRID databases

CUBRID (PDO)
PDO::cubrid_schema
CUBRID (PDO)
PHP Manual

PDO_CUBRID DSN

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

PDO_CUBRID DSN — Connecting to CUBRID databases

Açıklama

The PDO_CUBRID Data Source Name (DSN) is composed of the following elements, delimited by semicolons:

DSN prefix

The DSN prefix is cubrid:.

host

The hostname on which the database server resides.

port

The port on which the database server is running.

dbname

The name of the database.

Notlar

Bilginize:

When you estalish the connection to CUBRID, you should give username and password except DSN.

Örnekler

Örnek 1 PDO_CUBRID DSN examples

The following example shows a PDO_CUBRID DSN for connecting to a CUBRID database:

cubrid:host=localhost;port=33000;dbname=demodb

CUBRID (PDO)
PDO::cubrid_schema
CUBRID (PDO)


Get the requested schema information

PDO_CUBRID DSN
MS SQL Sunucusu (PDO)
CUBRID (PDO)
PHP Manual

PDO::cubrid_schema

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

PDO::cubrid_schema — Get the requested schema information

Açıklama

public array PDO::cubrid_schema ( int $schema_type [, string $table_name [, string $col_name ]] )

This function is used to get the requested schema information from database. You have to designate table_name, if you want to get information on certain table, col_name, if you want to get information on certain column (can be used only with PDO::CUBRID_SCH_COL_PRIVILEGE).

The result of this function is returned as a two-dimensional array (column (associative array) * row (numeric array)). The following tables shows types of schema and the column structure of the result array to be returned based on the schema type.

Result Composition of Each Type
Schema | Column Number | Column Name | Value
PDO::CUBRID_SCH_TABLE | 1 | NAME |
 | 2 | TYPE | 0:system table 1:view 2:table
PDO::CUBRID_SCH_VIEW | 1 | NAME |
 | 2 | TYPE | 1:view
PDO::CUBRID_SCH_QUERY_SPEC | 1 | QUERY_SPEC |
PDO::CUBRID_SCH_ATTRIBUTE / PDO::CUBRID_SCH_TABLE_ATTRIBUTE | 1 | ATTR_NAME |
 | 2 | DOMAIN |
 | 3 | SCALE |
 | 4 | PRECISION |
 | 5 | INDEXED | 1:indexed
 | 6 | NOT NULL | 1:not null
 | 7 | SHARED | 1:shared
 | 8 | UNIQUE | 1:unique
 | 9 | DEFAULT |
 | 10 | ATTR_ORDER | base:1
 | 11 | CLASS_NAME |
 | 12 | SOURCE_CLASS |
 | 13 | IS_KEY | 1:key
PDO::CUBRID_SCH_METHOD / PDO::CUBRID_SCH_TABLE_METHOD | 1 | NAME |
 | 2 | RET_DOMAIN |
 | 3 | ARG_DOMAIN |
PDO::CUBRID_SCH_METHOD_FILE | 1 | METHOD_FILE |
PDO::CUBRID_SCH_SUPER_TABLE / PDO::CUBRID_SCH_DIRECT_SUPER_TABLE / PDO::CUBRID_SCH_SUB_TABLE | 1 | CLASS_NAME |
 | 2 | TYPE | 0:system table 1:view 2:table
PDO::CUBRID_SCH_CONSTRAINT | 1 | TYPE | 0:unique 1:index 2:reverse unique 3:reverse index
 | 2 | NAME |
 | 3 | ATTR_NAME |
 | 4 | NUM_PAGES |
 | 5 | NUM_KEYS |
 | 6 | PRIMARY_KEY | 1:primary key
 | 7 | KEY_ORDER | base:1
PDO::CUBRID_SCH_TRIGGER | 1 | NAME |
 | 2 | STATUS |
 | 3 | EVENT |
 | 4 | TARGET_CLASS |
 | 5 | TARGET_ATTR |
 | 6 | ACTION_TIME |
 | 7 | ACTION |
 | 8 | PRIORITY |
 | 9 | CONDITION_TIME |
 | 10 | CONDITION |
PDO::CUBRID_SCH_TABLE_PRIVILEGE / PDO::CUBRID_SCH_COL_PRIVILEGE | 1 | CLASS_NAME / ATTR_NAME |
 | 2 | PRIVILEGE |
 | 3 | GRANTABLE |
PDO::CUBRID_SCH_PRIMARY_KEY | 1 | CLASS_NAME |
 | 2 | ATTR_NAME |
 | 3 | KEY_SEQ | base:1
 | 4 | KEY_NAME |
PDO::CUBRID_SCH_IMPORTED_KEYS / PDO::CUBRID_SCH_EXPORTED_KEYS / PDO::CUBRID_SCH_CROSS_REFERENCE | 1 | PKTABLE_NAME |
 | 2 | PKCOLUMN_NAME |
 | 3 | FKTABLE_NAME | base:1
 | 4 | FKCOLUMN_NAME |
 | 5 | KEY_SEQ | base:1
 | 6 | UPDATE_ACTION | 0:cascade 1:restrict 2:no action 3:set null
 | 7 | DELETE_ACTION | 0:cascade 1:restrict 2:no action 3:set null
 | 8 | FK_NAME |
 | 9 | PK_NAME |

Değiştirgeler

schema_type

Schema type that you want to know.

table_name

Table you want to know the schema of.

col_name

Column you want to know the schema of.

Dönen Değerler

Array containing the schema information, when process is successful;

FALSE, when process is unsuccessful

Örnekler

Örnek 1 A PDO::cubrid_schema() example

This example shows how to get primary key and foreign keys of table game.

<?php
$pk_list = $dbh->cubrid_schema(PDO::CUBRID_SCH_PRIMARY_KEY, "game");
print_r($pk_list);

$fk_list = $dbh->cubrid_schema(PDO::CUBRID_SCH_IMPORTED_KEYS, "game");
print_r($fk_list);
?>

Yukarıdaki örneğin çıktısı:

Result:
Array
(
    [0] => Array
        (
            [CLASS_NAME] => game
            [ATTR_NAME] => athlete_code
            [KEY_SEQ] => 3
            [KEY_NAME] => pk_game_host_year_event_code_athlete_code
        )

    [1] => Array
        (
            [CLASS_NAME] => game
            [ATTR_NAME] => event_code
            [KEY_SEQ] => 2
            [KEY_NAME] => pk_game_host_year_event_code_athlete_code
        )

    [2] => Array
        (
            [CLASS_NAME] => game
            [ATTR_NAME] => host_year
            [KEY_SEQ] => 1
            [KEY_NAME] => pk_game_host_year_event_code_athlete_code
        )

)
Array
(
    [0] => Array
        (
            [PKTABLE_NAME] => athlete
            [PKCOLUMN_NAME] => code
            [FKTABLE_NAME] => game
            [FKCOLUMN_NAME] => athlete_code
            [KEY_SEQ] => 1
            [UPDATE_RULE] => 1
            [DELETE_RULE] => 1
            [FK_NAME] => fk_game_athlete_code
            [PK_NAME] => pk_athlete_code
        )

    [1] => Array
        (
            [PKTABLE_NAME] => event
            [PKCOLUMN_NAME] => code
            [FKTABLE_NAME] => game
            [FKCOLUMN_NAME] => event_code
            [KEY_SEQ] => 1
            [UPDATE_RULE] => 1
            [DELETE_RULE] => 1
            [FK_NAME] => fk_game_event_code
            [PK_NAME] => pk_event_code
        )

)

PDO_CUBRID DSN
MS SQL Sunucusu (PDO)
CUBRID (PDO)


Microsoft SQL Sunucusu ve Sybase (PDO_DBLIB) İşlevleri

Giriş

Uyarı

Bu eklenti DENEYSELDİR. Bu eklentinin davranışı, işlev isimleri ve tüm belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu eklentiyi kullanmayın.

PDO_DBLIB, PHP Veri Nesneleri Arayüzünün (PDO) FreeTDS kütüphanesi üzerinden Microsoft SQL Sunucusu ve Sybase veritabanlarına erişimini mümkün kılmak için gerçeklenmiş bir sürücüdür.

Windows üzerinde Microsoft SQL Sunucusu ve Sybase veritabanlarına bağlanmak için PDO_ODBC sürücüsünü kullanmalısınız. Windows'un yerleşik DB-LIB'i eskimiş, evreler bakımından güvenilmezdir ve Microsoft tarafından artık desteklenmemektedir.

İçindekiler

  • PDO_DBLIB DSN — Microsoft SQL Sunucusu ve Sybase veritabanlarına bağlantı
PDO::cubrid_schema
PDO_DBLIB DSN
PDO Sürücüleri


Microsoft SQL Sunucusu ve Sybase veritabanlarına bağlantı

MS SQL Sunucusu (PDO)
Firebird/Interbase (PDO)
MS SQL Sunucusu (PDO)
PHP Manual

PDO_DBLIB DSN

(PECL PDO_DBLIB >= 0.9.0)

PDO_DBLIB DSN — Microsoft SQL Sunucusu ve Sybase veritabanlarına bağlantı

Açıklama

PDO_DBLIB DSN'si şu bileşenlerden oluşur:

DSN öneki

DSN öneki, PDO_DBLIB, FreeTDS kütüphaneleri kullanılmak üzere derlenmişse sybase: dizgesidir, Microsoft SQL Sunucusunu kullanmak üzere derlenmişse mssql: dizgesidir. DB-lib'in başka bir sürümünü kullanmak üzere derlenmişse dblib: dizgesidir.

host

Veritabanını barındıran konağın adı veya IP adresi; 127.0.0.1 öntanımlıdır.

dbname

Veritabanının ismi.

charset

İstemcinin karakter kümesi.

appname

Uygulama ismi (sistem süreçlerinde kullanılır). "PHP Generic DB-lib" veya "PHP freetds" öntanımlıdır.

secure

Şimdilik kullanılmamaktadır.

Örnekler

Örnek 1 - PDO_DBLIB DSN örnekleri

Aşağıdaki örnekte, Microsoft SQL Sunucusu ve Sybase veritabanlarına bağlanmak için kullanılan PDO_DBLIB DSN'leri gösterilmiştir:

mssql:host=localhost;dbname=testdb
sybase:host=localhost;dbname=testdb
dblib:host=localhost;dbname=testdb

MS SQL Sunucusu (PDO)
Firebird/Interbase (PDO)
MS SQL Sunucusu (PDO)


Firebird/Interbase (PDO_FIREBIRD) İşlevleri

Giriş

Uyarı

Bu eklenti DENEYSELDİR. Bu eklentinin davranışı, işlev isimleri ve tüm belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu eklentiyi kullanmayın.

PDO_FIREBIRD, PHP Veri Nesneleri Arayüzünün (PDO) Firebird ve Interbase veritabanlarına erişimini mümkün kılmak için gerçeklenmiş bir sürücüdür.

Öntanımlı Sabitler

Bu sabitler bu sürücü tarafından tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir. Ek olarak, bu sürücüye özgü sabitler sadece bu sürücüyü kullanıyorsanız kullanılmalıdır. Sürücüye özgü özniteliklerin postgres sürücüsü ile kullanılması beklenmedik davranışlara yol açabilir. Eğer kodunuz çok sayıda sürücüye karşı çalışıyorsa sürücüyü sınayacak PDO_ATTR_DRIVER_NAME özniteliğini sağlamak için PDO::getAttribute() kullanılabilir.

PDO::FB_ATTR_DATE_FORMAT (integer)

PHP 5.3.0'dan beri kullanılabilmektedir.

Tarih biçemini tanımlar.

PDO::FB_ATTR_TIME_FORMAT (integer)

Tarih biçemini tanımlar.

PHP 5.3.0'dan beri kullanılabilmektedir.

PDO::FB_ATTR_TIMESTAMP_FORMAT (integer)

Zaman damgası biçemini tanımlar.

PHP 5.3.0'dan beri kullanılabilmektedir.

İçindekiler

  • PDO_FIREBIRD DSN — Firebird ve Interbase veritabanı bağlantısı
PDO_DBLIB DSN
PDO_FIREBIRD DSN
PDO Sürücüleri


Firebird ve Interbase veritabanı bağlantısı

Firebird/Interbase (PDO)
IBM (PDO)
Firebird/Interbase (PDO)
PHP Manual

PDO_FIREBIRD DSN

(PECL PDO_FIREBIRD >= 0.1.0)

PDO_FIREBIRD DSN — Firebird ve Interbase veritabanı bağlantısı

Açıklama

PDO_FIREBIRD DSN'sinin ana bileşenleri şunlardır:

DSN öneki

DSN öneki firebird: dizgesidir.

dbname

Veritabanının ismi.

charset

Karakter kümesi.

role

SQL rol adı.

Örnekler

Örnek 1 - PDO_FIREBIRD DSN örneği

Aşağıdaki örnekte, bir Firebird veritabanına bağlanmak için kullanılan PDO_FIREBIRD DSN'si gösterilmiştir.

firebird:dbname=DATABASE.GDE

Firebird/Interbase (PDO)
IBM (PDO)
Firebird/Interbase (PDO)


IBM (PDO_IBM) İşlevleri

Giriş

PDO_IBM, PHP Veri Nesneleri Arayüzünün (PDO) IBM veritabanlarına PHP'den erişimi mümkün kılmak için gerçeklenmiş bir sürücüdür.

Kurulum

PDO_IBM eklentisini kurmak için PHP'yi derlediğiniz makineye DB2 Client v9.1 veya üstünü kurmuş olmalısınız. DB2 Client,» IBM Uygulama Geliştirme sitesinden temin edilebilir.

Bilginize: Bilginize

The DB2 Client v9.1 ve üstü Linux, UNIX, ve Windows v8 and v9.1 için DB2'ye doğrudan erişimi destekler.

DB2 Client v9.1 ayrıca satın alacağınız » DB2 Bağlantı ürününü üzerinden z/OS sunuculardaki i5 ve DB2 UDB için DB2 UDB'ye erişimi de destekler.

PDO_IBM bir » PECL eklentisi olup eklentiyi kurmak için PECL eklentilerinin kurulması sayfasındaki talimatları izleyebilirsiniz. DB2 istemcisi başlık dosyalarını ve kütüphanelerinin bulunduğu yeri configure betiğine göstermek için şu komut satırını kullanabilirsiniz:

bash$ ./configure --with-pdo-ibm=/bir/yol/sqllib[,shared]
configure betiği öntanımlı olarak DB2DIR ortam değişkenindeki değeri kullanır.

İçindekiler

  • PDO_IBM DSN — IBM veritabanı bağlantısı
PDO_FIREBIRD DSN
PDO_IBM DSN
PDO Sürücüleri


IBM veritabanı bağlantısı

IBM (PDO)
Informix (PDO)
IBM (PDO)
PHP Manual

PDO_IBM DSN

(PECL PDO_IBM >= 0.9.0)

PDO_IBM DSN — IBM veritabanı bağlantısı

Açıklama

PDO_IBM Veri Kaynağı Adı (DSN), IBM CLI DSN'sine dayanır. PDO_IBM Veri Kaynağı Adı (DSN) şu öğelerden oluşur:

DSN öneki

DSN öneki ibm: dizgesidir.

DSN

Şunlardan biri olabilir:

  • Veri kaynağı db2cli.ini veya odbc.ini kullanılarak ayarlanır.

  • Kataloglu veritabanı adı; yani veritabanının DB2 istemci kataloğundaki takma adı.

  • Eksiksiz bağlantı dizgesi; sözdizimi şöyledir:
DRIVER={IBM DB2 ODBC DRIVER};
DATABASE=veritabanı;
HOSTNAME=konakadı;
PORT=port;PROTOCOL=TCPIP;
UID=kullanıcı;
PWD=parola;

    veritabanı

    Veritabanının adı.

    konakadı

    Veritabanı sunucusunun IP adresi veya konak adı.

    port

    Veritabanı sunucusunun dinlediği port.

    kullanıcı

    Veritabanına bağlantı için kullanıcı adı.

    password

    Veritabanına bağlantı için parola.

Örnekler

Örnek 1 - db2cli.ini kullanarak PDO_IBM DSN örneği

Aşağıdaki örnekte, db2cli.ini dosyasında DB2_9 adıyla kataloglanmış bir DB2 veritabanına bağlanmak için kullanılan bir PDO_IBM DSN'si gösterilmiştir:

$db = new PDO("ibm:DSN=DB2_9", "", "");

[DB2_9]
Database=testdb
Protocol=tcpip
Hostname=11.22.33.444
Servicename=56789

Örnek 2 - Bağlantı dizgeli PDO_IBM DSN'si örneği

Aşağıdaki örnekte, testdb adında bir DB2 veritabanına bağlanmak için bir DB2 CLI bağlantı dizgesini kullanan bir PDO_IBM DSN'si gösterilmiştir:

$db = new PDO("ibm:DRIVER={IBM DB2 ODBC DRIVER};DATABASE=testdb;" .
  "HOSTNAME=11.22.33.444;PORT=56789;PROTOCOL=TCPIP;", "testuser", "tespass");

IBM (PDO)
Informix (PDO)
IBM (PDO)


Informix (PDO_INFORMIX) İşlevleri

Giriş

PDO_INFORMIX, PHP Veri Nesneleri Arayüzünün (PDO) Informix veritabanlarına erişimini mümkün kılmak için gerçeklenmiş bir sürücüdür.

Kurulum

PDO_INFORMIX eklentisini kurmak için PDO_INFORMIX'i derlediğiniz makineye Informix Client SDK 2.81 UC1 veya üstünü kurmuş olmalısınız. Informix Client SDK » IBM Informix destek sitesinden temin edilebilir.

PDO_INFORMIX bir » PECL eklentisi olduğundan kurulum için PECL eklentilerinin kurulması bölümüne bakınız. Informix Client SDK başlık dosyalarının bulunduğu yeri belirtmek için configure komutunu şöyle kullanabilirsiniz:

   bash$ ./configure --with-pdo-informix=/bir/yol/SDK[,shared]
configure komutu öntanımlı değer olarak INFORMIXDIR ortam değişkenindeki değeri kullanır.

Kaydırılabilir göstericiler

PDO_INFORMIX kaydırılabilir göstericileri desteklemekle birlikte öntanımlı olarak etkin değildir. Kaydırılabilir gösterici desteğini etkin kılmak için odbc.ini dosyasındaki ilgili ODBC bağlantı ayarlarına ENABLESCROLLABLECURSORS=1 atamalı ya da DSN bağlantı dizgesinde EnableScrollableCursors=1 yan tümcesini belirtmelisiniz.

İçindekiler

  • PDO_INFORMIX DSN — Informix veritabanı bağlantısı
PDO_IBM DSN
PDO_INFORMIX DSN
PDO Sürücüleri


Informix veritabanı bağlantısı

Informix (PDO)
MySQL (PDO)
Informix (PDO)
PHP Manual

PDO_INFORMIX DSN

(PECL PDO_INFORMIX >= 0.1.0)

PDO_INFORMIX DSN — Informix veritabanı bağlantısı

Açıklama

PDO_INFORMIX Veri Kaynağı Adı (DSN), Informix ODBC DSN dizgesine dayanır. Bir Informix ODBC DSN'sini yapılandırmak için gereken ayrıntılı bilgiyi » Informix devingen sunucu bilgi merkezinden edinebilirsiniz. PDO_INFORMIX DSN'sinin ana bileşenleri şunlardır:

DSN örneki

DSN öneki informix: dizgesidir.

DSN

DSN ya odbc.ini kullanarak ayarlanan bir veri kaynağı veya eksiksiz bir » bağlantı dizgesi olmalıdır.

Örnekler

Örnek 1 - odbc.ini kullanan PDO_INFORMIX DSN örneği

Aşağıdaki örnekte, odbc.ini dosyasında Infdrv33 olarak kataloglanmış bir Informix veritabanına bağlanmak için kullanılan bir PDO_INFORMIX DSN'si gösterilmiştir:

$db = new PDO("informix:DSN=Infdrv33", "", "");

[ODBC Data Sources]
Infdrv33=INFORMIX 3.3 32-BIT

[Infdrv33]
Driver=/opt/informix/csdk_2.81.UC1G2/lib/cli/iclis09b.so
Description=INFORMIX 3.3 32-BIT
Database=common_db
LogonID=testuser
pwd=testpass
Servername=ids_server
DB_LOCALE=en_US.819
OPTIMIZEAUTOCOMMIT=1
ENABLESCROLLABLECURSORS=1

Örnek 2 - Bağlantı dizgeli PDO_INFORMIX DSN örneği

Aşağıdaki örnekte, common_db adındaki bir Informix veritabanına bağlanmak için kullanılan bir bağlantı dizgesi sözdizimi gösterilmiştir:

$db = new PDO("informix:host=host.domain.com; service=9800;
    database=common_db; server=ids_server; protocol=onsoctcp;
    EnableScrollableCursors=1", "testuser", "tespass");

Informix (PDO)
MySQL (PDO)
Informix (PDO)


MySQL (PDO_MYSQL) İşlevleri

Giriş

PDO_MYSQL, PHP Veri Nesneleri Arayüzünün (PDO) MySQL 3.x, 4.x ve 5.x veritabanlarına erişimini mümkün kılmak için gerçeklenmiş bir sürücüdür.

PDO_MYSQL eklentisi, MySQL'in 4.1 ve üstü sürümlerinde bulunan yerleşik hazır deyim desteğinden de yararlanır. MySQL'in daha eski istemci kütüphanelerini kullanıyorsanız PDO bu desteği sizin için kendisi sağlayacaktır.

Uyarı

Dikkat: Bazı MySQL tablo türleri (saklama motorları) toplu hareketleri desteklemez. Bir veritabanını kodlarken toplu hareketleri desteklemeyen bir tablo türünü kullanıyorsanız MySQL toplu hareketi başarıyla ilklendirmiş gibi yapar. Ayrıca, DDL sorguları, bekleyen toplu hareketlerin örtük olarak yerine getirilmesine de sebep olur.

Öntanımlı Sabitler

Bu sabitler bu sürücü tarafından tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir. Ek olarak, bu sürücüye özgü sabitler sadece bu sürücüyü kullanıyorsanız kullanılmalıdır. Sürücüye özgü özniteliklerin postgres sürücüsü ile kullanılması beklenmedik davranışlara yol açabilir. Eğer kodunuz çok sayıda sürücüye karşı çalışıyorsa sürücüyü sınayacak PDO_ATTR_DRIVER_NAME özniteliğini sağlamak için PDO::getAttribute() kullanılabilir.

PDO::MYSQL_ATTR_USE_BUFFERED_QUERY (integer)
Bu özniteliğe bir PDOStatement nesnesinde TRUE atanırsa MySQL sürücüsü MySQL arayüzünün tamponlu sürümlerini kullanır. Taşınabilir bir kod yazıyorsanız bunu yapmak yerine PDOStatement::fetchAll() yöntemini kullanın.

Örnek 1 - Sorguların tamponlanmasına zorlamak

<?php
if ($db->getAttribute(PDO::ATTR_DRIVER_NAME) == 'mysql') {
    $stmt = $db->prepare('select * from foo',
        array(PDO::MYSQL_ATTR_USE_BUFFERED_QUERY => true));
} else {
    die("Bu uygulama sadece MySQL ile çalışır; " .
        "yerine \$stmt->fetchAll() kullanılmalıydı");
}
?>

PDO::MYSQL_ATTR_LOCAL_INFILE (integer)

LOAD LOCAL INFILE etkin olur.

PDO::MYSQL_ATTR_INIT_COMMAND (integer)

MySQL sunucusuna bağlanırken çalıştırılacak komut. Yeniden bağlantı sırasında özdevinimli olarak bu komut çalıştırılır.

PDO::MYSQL_ATTR_READ_DEFAULT_FILE (integer)

Seçenekler my.cnf yerine burada belirtilen dosyadan okunur.

PDO::MYSQL_ATTR_READ_DEFAULT_GROUP (integer)

Seçenekler my.cnf dosyasında belirtilen gruptan veya MYSQL_READ_DEFAULT_FILE ile belirtilen dosyadan okunur.

PDO::MYSQL_ATTR_MAX_BUFFER_SIZE (integer)

Azami tampon büyüklüğü; 1 MiB öntanımlıdır.

PDO::MYSQL_ATTR_DIRECT_QUERY (integer)

Hazır deyimler kullanılmaz, sorgular doğrudan çalıştırılır.

İçindekiler

  • PDO_MYSQL DSN — MySQL veritabanı bağlantısı
PDO_INFORMIX DSN
PDO_MYSQL DSN
PDO Sürücüleri


MySQL veritabanı bağlantısı

MySQL (PDO)
MS SQL Server (PDO)
MySQL (PDO)
PHP Manual

PDO_MYSQL DSN

(PECL PDO_MYSQL >= 0.1.0)

PDO_MYSQL DSN — MySQL veritabanı bağlantısı

Açıklama

PDO_MYSQL Veri Kaynağı Adı (DSN) şu öğelerden oluşur:

DSN öneki

DSN öneki mysql: dizgesidir.

host

Veritabanı sunucusunu barındıran konağın ismi.

port

Veritabanı sunucusunun dinlediği portun numarası.

dbname

Veritabanının ismi.

unix_socket

MySQL Unix soketi (host veya port ile kullanılmamalıdır).

Örnekler

Örnek 1 - PDO_MYSQL DSN örnekleri

Aşağıdaki örnekte MySQL veritabanlarına bağlanmak için PDO_MYSQL DSN kullanımı gösterilmiştir:

mysql:host=localhost;dbname=testdb
Daha ayrıntılı bir örnek:
mysql:host=localhost;port=3307;dbname=testdb
mysql:unix_socket=/tmp/mysql.sock;dbname=testdb

MySQL (PDO)
MS SQL Server (PDO)
MySQL (PDO)


Microsoft SQL Server Functions (PDO_SQLSRV)

Giriş

PDO_SQLSRV is a driver that implements the PHP Data Objects (PDO) interface to enable access from PHP to MS SQL Server (starting with SQL Server 2005) and SQL Azure databases.

Kurulum

The PDO_SQLSRV extension is enabled by adding appropriate DLL file to your PHP extension directory and the corresponding entry to the php.ini file. The PDO_SQLSRV download comes 8 driver files, four of which are for PDO support. If you are running non-thread-safe PHP (PHP 5.3), use the php_pdo_sqlsrv_53_nts.dll file. (You should use a non-thread-safe version if you are using IIS as your web server). If you are running thread-safe PHP, use the php_pdo_sqlsrv_53_ts.dll file. Similarly for PHP 5.4, use the php_pdo_sqlsrv_54_nts.dll or php_pdo_sqlsrv_54_ts.dll depending on whether your PHP installation is non-thread-safe or thread-safe.

The most recent version of the driver is available for download here: » SQLSRV 3.0 download. If you need support for PHP 5.2 and/or PHP compiled with VC6, use the 2.0 release of the driver: » SQLSRV 2.0 download.

For more information about system requirements, see » SQLSRV System Requirements.

The PDO_SQLSRV extension is only compatible with PHP running on Windows. For Linux, see ODBC and » Microsoft's SQL Server ODBC Driver for Linux.

Öntanımlı Sabitler

Bu sabitler bu sürücü tarafından tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir. Ek olarak, bu sürücüye özgü sabitler sadece bu sürücüyü kullanıyorsanız kullanılmalıdır. Sürücüye özgü özniteliklerin postgres sürücüsü ile kullanılması beklenmedik davranışlara yol açabilir. Eğer kodunuz çok sayıda sürücüye karşı çalışıyorsa sürücüyü sınayacak PDO_ATTR_DRIVER_NAME özniteliğini sağlamak için PDO::getAttribute() kullanılabilir.

PDO::SQLSRV_TXN_READ_UNCOMMITTED (integer)
This constant is an acceptable value for the SQLSRV DSN key TransactionIsolation. This constant sets the transaction isolation level for the connection to Read Uncommitted.
PDO::SQLSRV_TXN_READ_COMMITTED (integer)
This constant is an acceptable value for the SQLSRV DSN key TransactionIsolation. This constant sets the transaction isolation level for the connection to Read Committed.
PDO::SQLSRV_TXN_REPEATABLE_READ (integer)
This constant is an acceptable value for the SQLSRV DSN key TransactionIsolation. This constant sets the transaction isolation level for the connection to Repeateable Read.
PDO::SQLSRV_TXN_SNAPSHOT (integer)
This constant is an acceptable value for the SQLSRV DSN key TransactionIsolation. This constant sets the transaction isolation level for the connection to Snapshot.
PDO::SQLSRV_TXN_SERIALIZABLE (integer)
This constant is an acceptable value for the SQLSRV DSN key TransactionIsolation. This constant sets the transaction isolation level for the connection to Serializable.
PDO::SQLSRV_ENCODING_BINARY (integer)
Specifies that data is sent/retrieved as a raw byte stream to/from the server without performing encoding or translation. This constant can be passed to PDOStatement::setAttribute, PDO::prepare, PDOStatement::bindColumn, and PDOStatement::bindParam.
PDO::SQLSRV_ENCODING_SYSTEM (integer)
Specifies that data is sent/retrieved to/from the server as 8-bit characters as specified in the code page of the Windows locale that is set on the system. Any multi-byte characters or characters that do not map into this code page are substituted with a single byte question mark (?) character. This constant can be passed to PDOStatement::setAttribute, PDO::setAttribute, PDO::prepare, PDOStatement::bindColumn, and PDOStatement::bindParam.
PDO::SQLSRV_ENCODING_UTF8 (integer)
Specifies that data is sent/retrieved to/from the server in UTF-8 encoding. This is the default encoding. This constant can be passed to PDOStatement::setAttribute, PDO::setAttribute, PDO::prepare, PDOStatement::bindColumn, and PDOStatement::bindParam.
PDO::SQLSRV_ENCODING_DEFAULT (integer)
Specifies that data is sent/retrieved to/from the server according to PDO::SQLSRV_ENCODING_SYSTEM if specified during connection. The connection's encoding is used if specified in a prepare statement. This constant can be passed to PDOStatement::setAttribute, PDO::setAttribute, PDO::prepare, PDOStatement::bindColumn, and PDOStatement::bindParam.
PDO::SQLSRV_ATTR_QUERY_TIMEOUT (integer)
A non-negative integer representing the timeout period, in seconds. Zero (0) is the default and means no timeout. This constant can be passed to PDOStatement::setAttribute, PDO::setAttribute, and PDO::prepare.
PDO::SQLSRV_ATTR_DIRECT_QUERY (integer)
Indicates that a query should be executed directly, without being prepared. This constant can be passed to PDO::setAttribute, and PDO::prepare. For more information, see » Direct and Prepared Statement Execution.

İçindekiler

  • PDO_SQLSRV DSN — Connecting to MS SQL Server and SQL Azure databases
PDO_MYSQL DSN
PDO_SQLSRV DSN
PDO Sürücüleri


Connecting to MS SQL Server and SQL Azure databases

MS SQL Server (PDO)
Oracle (PDO)
MS SQL Server (PDO)
PHP Manual

PDO_SQLSRV DSN

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

PDO_SQLSRV DSN — Connecting to MS SQL Server and SQL Azure databases

Açıklama

The PDO_SQLSRV Data Source Name (DSN) is composed of the following elements:

DSN prefix

The DSN prefix is sqlsrv:.

APP

The application name used in tracing.

ConnectionPooling

Specifies whether the connection is assigned from a connection pool (1 or TRUE) or not (0 or FALSE).

Database

The name of the database.

Encrypt

Specifies whether the communication with SQL Server is encrypted (1 or TRUE) or unencrypted (0 or FALSE).

Failover_Partner

Specifies the server and instance of the database's mirror (if enabled and configured) to use when the primary server is unavailable.

LoginTimeout

Specifies the number of seconds to wait before failing the connection attempt.

MultipleActiveResultSets

Disables or explicitly enables support for multiple active Result sets (MARS).

QuotedId

Specifies whether to use SQL-92 rules for quoted identifiers (1 or TRUE) or to use legacy Transact-SQL rules (0 or FALSE).

Server

The name of the database server.

TraceFile

Specifies the path for the file used for trace data.

TraceOn

Specifies whether ODBC tracing is enabled (1 or TRUE) or disabled (0 or FALSE) for the connection being established.

TransactionIsolation

Specifies the transaction isolation level. The accepted values for this
option are PDO::SQLSRV_TXN_READ_UNCOMMITTED, PDO::SQLSRV_TXN_READ_COMMITTED,
PDO::SQLSRV_TXN_REPEATABLE_READ, PDO::SQLSRV_TXN_SNAPSHOT, and
PDO::SQLSRV_TXN_SERIALIZABLE.

TrustServerCertificate

Specifies whether the client should trust (1 or TRUE) or reject (0 or FALSE) a self-signed server certificate.

WSID

Specifies the name of the computer for tracing.

Örnekler

Örnek 1 PDO_SQLSRV DSN examples

The following example shows how to connecto to a specified MS SQL Server database:

$c = new PDO("sqlsrv:Server=localhost;Database=testdb", "UserName", "Password");

The following example shows how to connect to a MS SQL Server database on a specified port:

$c = new PDO("sqlsrv:Server=localhost,1521;Database=testdb", "UserName", "Password");

The following example shows how to connecto to a SQL Azure database with server ID 12345abcde. Note that when you connect to SQL Azure with PDO, your username will be UserName@12345abcde (UserName@ServerId).

$c = new PDO("sqlsrv:Server=12345abcde.database.windows.net;Database=testdb", "UserName@12345abcde", "Password");

MS SQL Server (PDO)
Oracle (PDO)
MS SQL Server (PDO)


Oracle (PDO_OCI) İşlevleri

Giriş

Uyarı

Bu eklenti DENEYSELDİR. Bu eklentinin davranışı, işlev isimleri ve tüm belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu eklentiyi kullanmayın.

PDO_OCI eklentisi, PHP'nin OCI kütüphanesi üzerinden Oracle veritabanlarına erişimini sağlamak için PHP Veri Nesneleri Arayüzünü (PDO) gerçekleyen bir sürücüdür.

İçindekiler

  • PDO_OCI DSN — Oracle veritabanlarına bağlantı
PDO_SQLSRV DSN
PDO_OCI DSN
PDO Sürücüleri


Oracle veritabanlarına bağlantı

Oracle (PDO)
ODBC ve DB2 (PDO)
Oracle (PDO)
PHP Manual

PDO_OCI DSN

(PECL PDO_OCI >= 0.1.0)

PDO_OCI DSN — Oracle veritabanlarına bağlantı

Açıklama

PDO_OCI Veri Kaynağı Adı (DSN) şu öğelerden oluşur:

DSN öneki

DSN öneki oci: dizgesidir.

dbname (Oracle Instant Client)

Oracle Instant Client bağlantı adresi şu sözdizimini kullanır: dbname=//konakadı:portnum /veritabanı. tnsnames.ora içinde tanımlı bir veritabanına bağlanırken sadece veritabanının ismini kullanabilirsiniz: dbname=veritabanı.

charset

Geçerli ortam için istemci tarafı karakter kümesi.

Örnekler

Örnek 1 - PDO_OCI DSN örnekleri

Aşağıdaki örneklerde, Oracle veritabanlarına bağlanmak için PDO_OCI DSN'si kullanımları gösterilmiştir.

// tnsnames.ora içinde tanımlı bir veritabanına bağlanalım
oci:dbname=mydb

// Oracle Instant Client kullanarak bağlanalım
oci:dbname=//localhost:1521/mydb

Oracle (PDO)
ODBC ve DB2 (PDO)
Oracle (PDO)


ODBC ve DB2 (PDO_ODBC) İşlevleri

Giriş

PDO_ODBC, PHP Veri Nesneleri Arayüzünün (PDO) veritabanlarına ODBC sürücüleri üzerinden veya IBM DB2 Çağrı Seviyesi Arayüzü (DB2 CLI) kütüphanesi üzerinden erişimi mümkün kılmak için gerçeklenmiş bir sürücüdür. PDO_ODBC şimdilik üç farklı lezzette veritabanı sürücüsünü desteklemektedir:

ibm-db2

IBM DB2 Evrensel Veritabanına, Cloudscape ve Apache Derby sunucularına özgür DB2 istemcisi üzerinden erişimi destekler.

unixODBC

Veritabanı sunucularına unixODBC sürücüsü yöneticisi ve veritabanının kendi ODBC sürücüleri üzerinden erişimi destekler.

soysal

PDO_ODBC tarafından açıkça desteklenmemiş ODBC sürücüsü yöneticileri için bir derleme seçeneği sağlar.

Windows'ta, PDO_ODBC eklentisi PHP içinde yerleşiktir. Windows ODBC Sürücüsü Yöneticisi ile ilintili olduğundan PHP, Sistem DSN üzerinden kataloglanan veritabanlarına erişebilir ve bu Microsoft SQL Server veritabanlarına bağlanmak için önerilen sürücüdür.

Kurulum

UNIX sistemlerinde PDO_ODBC

  1. PHP 5.1'den itibaren, PDO_ODBC, PHP kaynak paketiyle gelmektedir. PDO_ODBC eklentisini duruk veya paylaşımlı bir modül olarak derlemek için kullanacağınız configure komutları:

    ibm_db2

    ./configure --with-pdo-odbc=ibm-db2,/opt/IBM/db2/V8.1/
    PDO_ODBC eklentisini ibm-db2 desteğiyle derlemek için DB2 uygulama geliştirme başlık dosyalarını, PDO_ODBC'yi derlediğiniz makineye kurmuş olmalısınız. DB2 uygulama geliştirme başlık dosyaları DB2 sunucularında kurulabilir bir seçenek olup ayrıca, DB2 Uygulama geliştirme istemcisinin bir parçası olarak » IBM DB2 evrensel veritabanı destek sitesinden özgürce indirilebilmektedir.

    configure komutuna DB2 kütüphaneleri ve başlıkları için bir konum belirtmezseniz /home/db2inst1/sqllib dizini öntanımlıdır.

    unixODBC

    ./configure --with-pdo-odbc=unixODBC,/usr/local
    configure komutuna unixODBC kütüphaneleri ve başlıkları için bir konum belirtmezseniz /usr/local dizini öntanımlıdır.

    soysal
    ./configure --with-pdo-odbc=generic,/usr/local,libname,ldflags,cflags

Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

PDO_ODBC Yapılandırma Yönergeleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
pdo_odbc.connection_pooling | "strict" | PHP_INI_ALL | PHP 5.1.0'dan beri kullanılabilmektedir.
pdo_odbc.db2_instance_name | NULL | PHP_INI_SYSTEM | PHP 5.1.1'den beri kullanılabilmektedir. PHP 6.0.0'da kaldırılmıştır.
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

pdo_odbc.connection_pooling string

ODBC bağlantılarının havuzlanıp havuzlanmayacağı. Şu değerlerden biri belirtilebilir: "strict" (katı), "relaxed" (esnek), "off" (kapalı; "" ile aynı). Değer, bağlantı yöneticisinin bağlantı değiştirgelerini mevcut havuzlu bağlantılarla nasıl eşleştireceğini belirler. strict önerilen öntanımlı değer olup, önbellekli bağlantıların sadece tüm bağlantı değiştirgeleri eşleştiğinde kullanılacağı anlamına gelir. relaxed ise benzer bağlantı değiştirgelerine sahip bağlantıların kullanılabileceğini belirtir. Bunun olumsuz tarafı, örneğin sanal konaklar arasında bağlantı bilgisi kaçağı riski nedeniyle önbellek kullanımında bir artışla sonuçlanabilmesidir.

Bu ayar sadece php.ini dosyasında değiştirilebilir ve tüm süreci etkiler; ayrıca, aynı ODBC kütüphanelerini kullanan süreçlere yüklü diğer modüller de (Tektip ODBC eklentisi dahil) etkilenir.

Uyarı

relaxed eşleştirmesi güvenlik sebebiyle bir paylaşımlı sunucuda kullanılmamalıdır.

İpucu

Bu ayarı değiştirmek için iyi bir sebebiniz yoksa öntanımlı strict ayarına dokunmamanız önerilir.

pdo_odbc.db2_instance_name string

PDO_ODBC eklentisini db2 desteğiyle kullanıyorsanız, Linux ve UNIX işletim sistemlerinde DB2INSTANCE ortam değişkenine DB2 örneğinin burada belirtilen ismini atar. Böylece, PDO_ODBC eklentisinin DB2 veritabanlarına kataloglu bağlantılar kurması ve DB2 kütüphanelerinin yerlerini bulması sağlanmış olur.

Bu ayar sadece php.ini dosyasında değiştirilebilir ve tüm süreci etkiler; ayrıca, aynı ODBC kütüphanelerini kullanan süreçlere yüklü diğer modüller de (Tektip ODBC eklentisi dahil) etkilenir.

Bu ayarın Windows üzerinde bir etkisi yoktur.

İçindekiler

  • PDO_ODBC DSN — ODBC veya DB2 veritabanlarına bağlantı
PDO_OCI DSN
PDO_ODBC DSN
PDO Sürücüleri


ODBC veya DB2 veritabanlarına bağlantı

ODBC ve DB2 (PDO)
PostgreSQL (PDO)
ODBC ve DB2 (PDO)
PHP Manual

PDO_ODBC DSN

(PECL PDO_ODBC >= 0.1.0)

PDO_ODBC DSN — ODBC veya DB2 veritabanlarına bağlantı

Açıklama

PDO_ODBC Veri Kaynağı Adı (DSN) şu öğelerden oluşur:

DSN öneki

DSN öneki odbc: dizgesidir. DB2 kataloğunda veya ODBC sürücüsü yöneticisinde kataloglanmış bir veritabanına erişirken veritabanının kataloglanmış ismini DSN'ye ekleyebilirsiniz.

DSN

DB2 kataloğunda veya ODBC sürücüsü yöneticisinde kataloglanmış veritabanının ismi. Ayrıca, » http://www.connectionstrings.com/ adresinde açıklandığı gibi bir veritabanına bağlanmak için tam bir ODBC bağlantı dizgesi de belirtebilirsiniz.

UID

Bağlantı için kullanıcı ismi. DSN'de bir kullanıcı ismi belirtirseniz PDO, kurucudaki kullanıcı adı değiştirgesini yok sayar.

PWD

Bağlantı için kullanıcı parolası. DSN'de bir kullanıcı ismi belirtirseniz PDO, kurucudaki kullanıcı adı değiştirgesini yok sayar.

Örnekler

Örnek 1 - PDO_ODBC DSN örneği (ODBC sürücüsünün yöneticisi)

Aşağıdaki örnekte, ODBC sürücüsünün yöneticisinde testdb olarak kataloglanmış bir ODBC veritabanına bağlantı için kullanılan bir PDO_ODBC DSN'si gösterilmiştir.

odbc:testdb

Örnek 2 - PDO_ODBC DSN örneği (IBM DB2 katalogsuz bağlantısı)

Aşağıdaki örnekte, tam ODBC DSN sözdizimi kullanılarak SAMPLE adında bir IBM DB2 veritabanına erişim için kullanılan bir PDO_ODBC DSN'si gösterilmiştir.

odbc:DRIVER={IBM DB2 ODBC DRIVER};HOSTNAME=localhost;PORT=50000;
DATABASE=SAMPLE;PROTOCOL=TCPIP;UID=db2inst1;PWD=ibmdb2;

Örnek 3 - PDO_ODBC DSN örneği (Microsoft Access katalogsuz bağlantısı)

Aşağıdaki örnekte, tam ODBC DSN sözdizimi kullanılarak C:\db.mdb dosyasında saklanan bir Microsoft Access veritabanına erişim için kullanılan bir PDO_ODBC DSN'si gösterilmiştir.

odbc:Driver={Microsoft Access Driver (*.mdb)};Dbq=C:\\db.mdb;Uid=Admin

ODBC ve DB2 (PDO)
PostgreSQL (PDO)
ODBC ve DB2 (PDO)


PostgreSQL (PDO_PGSQL) İşlevleri

Giriş

PDO_PGSQL, PHP Veri Nesneleri Arayüzünün (PDO) PostgreSQL veritabanlarına PHP'den erişimi mümkün kılmak için gerçeklenmiş bir sürücüdür.

Özkaynak Türleri

Bu eklentinin PDO::pgsqlLOBOpen() tarafından döndürülen bir akım özkaynağı vardır.

Kurulum

Use --with-pdo-pgsql[=DIR] to install the PDO PostgreSQL extension, where the optional [=DIR] is the PostgreSQL base install directory, or the path to pg_config.

$ ./configure --with-pdo-pgsql

İçindekiler

  • PDO_PGSQL DSN — PostgreSQL veritabanı bağlantısı
  • PDO::pgsqlCopyFromArray — Copy data from PHP array into table
  • PDO::pgsqlCopyFromFile — Copy data from file into table
  • PDO::pgsqlCopyToArray — Copy data from database table into PHP array
  • PDO::pgsqlCopyToFile — Copy data from table into file
  • PDO::pgsqlGetNotify — Get asynchronous notification
  • PDO::pgsqlGetPid — Get the server PID
  • PDO::pgsqlLOBCreate — Creates a new large object
  • PDO::pgsqlLOBOpen — Opens an existing large object stream
  • PDO::pgsqlLOBUnlink — Deletes the large object
PDO_ODBC DSN
PDO_PGSQL DSN
PDO Sürücüleri


PostgreSQL veritabanı bağlantısı

PostgreSQL (PDO)
PDO::pgsqlCopyFromArray
PostgreSQL (PDO)
PHP Manual

PDO_PGSQL DSN

(PECL PDO_PGSQL >= 0.1.0)

PDO_PGSQL DSN — PostgreSQL veritabanı bağlantısı

Açıklama

Veri Kaynağı Adı (DSN) birbirlerinden boşluklarla veya noktalı virgüllerle ayrılmış şu öğelerden oluşur:

DSN öneki

DSN öneki pgsql: dizgesidir.

host

Veritabanı sunucusunu barındıran konağın ismi.

port

Veritabanı sunucusunun çalıştığı port.

dbname

Veritabanının ismi.

user

Bağlantı için kullanıcı ismi. DSN'de bir kullanıcı ismi belirtirseniz PDO, kurucudaki kullanıcı adı değiştirgesini yok sayar.

password

Bağlantı için kullanıcı parolası. DSN'de bir kullanıcı parolası belirtirseniz PDO, kurucudaki kullanıcı parolası değiştirgesini yok sayar.

Bilginize:

bytea alanları akım olarak döndürülür.

Örnekler

Örnek 1 - PDO_PGSQL DSN örneği

Aşağıdaki örnekte bir PostgreSQL veritabanına bağlanmak için PDO_PGSQL DSN kullanımı gösterilmiştir:

pgsql:host=localhost;port=5432;dbname=testdb;user=bruce;password=mypass

PostgreSQL (PDO)
PDO::pgsqlCopyFromArray
PostgreSQL (PDO)


Copy data from PHP array into table

PDO_PGSQL DSN
PDO::pgsqlCopyFromFile
PostgreSQL (PDO)
PHP Manual

PDO::pgsqlCopyFromArray

(PHP 5 >= 5.3.3, PHP 7)

PDO::pgsqlCopyFromArray — Copy data from PHP array into table

Açıklama

public bool PDO::pgsqlCopyFromArray ( string $table_name , array $rows [, string $delimiter = '\t' [, string $null_as = "\\\\N" [, string $fields ]]] )

Copies data from rows array to table table_name using delimiter as fields delimiter and fields list

Değiştirgeler

table_name

String containing table name

rows

Array of strings with fields separated by delimiter

delimiter

Delimiter used in rows array

null_as

How to interpret null values

fields

List of fields to insert

Dönen Değerler

Returns TRUE on success, başarısızlık durumunda FALSE döner.

PDO_PGSQL DSN
PDO::pgsqlCopyFromFile
PostgreSQL (PDO)


Copy data from file into table

PDO::pgsqlCopyFromArray
PDO::pgsqlCopyToArray
PostgreSQL (PDO)
PHP Manual

PDO::pgsqlCopyFromFile

(PHP 5 >= 5.3.3, PHP 7)

PDO::pgsqlCopyFromFile — Copy data from file into table

Açıklama

public bool PDO::pgsqlCopyFromFile ( string $table_name , string $filename [, string $delimiter = '\t' [, string $null_as = "\\\\N" [, string $fields ]]] )

Copies data from file specified by filename into table table_name using delimiter as fields delimiter and fields list

Değiştirgeler

table_name

String containing table name

filename

Filename containing data to import

delimiter

Delimiter used in file specified by filename

null_as

How to interpret null values

fields

List of fields to insert

Dönen Değerler

Returns TRUE on success, başarısızlık durumunda FALSE döner.

PDO::pgsqlCopyFromArray
PDO::pgsqlCopyToArray
PostgreSQL (PDO)


Copy data from database table into PHP array

PDO::pgsqlCopyFromFile
PDO::pgsqlCopyToFile
PostgreSQL (PDO)
PHP Manual

PDO::pgsqlCopyToArray

(PHP 5 >= 5.3.3, PHP 7)

PDO::pgsqlCopyToArray — Copy data from database table into PHP array

Açıklama

public array PDO::pgsqlCopyToArray ( string $table_name , array $rows [, string $delimiter = '\t' [, string $null_as = "\\\\N" [, string $fields ]]] )

Copies data from table into array using delimiter as fields delimiter and fields list

Değiştirgeler

table_name

String containing table name

delimiter

Delimiter used in rows array

null_as

How to interpret null values

fields

List of fields to export

Dönen Değerler

Returns an array of rows, başarısızlık durumunda FALSE döner.

PDO::pgsqlCopyFromFile
PDO::pgsqlCopyToFile
PostgreSQL (PDO)


Copy data from table into file

PDO::pgsqlCopyToArray
PDO::pgsqlGetNotify
PostgreSQL (PDO)
PHP Manual

PDO::pgsqlCopyToFile

(PHP 5 >= 5.3.3, PHP 7)

PDO::pgsqlCopyToFile — Copy data from table into file

Açıklama

public bool PDO::pgsqlCopyToFile ( string $table_name , string $filename [, string $delimiter = '\t' [, string $null_as = "\\\\N" [, string $fields ]]] )

Copies data from table into file specified by filename using delimiter as fields delimiter and fields list

Değiştirgeler

table_name

String containing table name

filename

Filename to export data

delimiter

Delimiter used in file specified by filename

null_as

How to interpret null values

fields

List of fields to insert

Dönen Değerler

Returns TRUE on success, başarısızlık durumunda FALSE döner.

PDO::pgsqlCopyToArray
PDO::pgsqlGetNotify
PostgreSQL (PDO)


Get asynchronous notification

PDO::pgsqlCopyToFile
PDO::pgsqlGetPid
PostgreSQL (PDO)
PHP Manual

PDO::pgsqlGetNotify

(PHP 5 >= 5.6.0, PHP 7)

PDO::pgsqlGetNotify — Get asynchronous notification

Açıklama

public array PDO::pgsqlGetNotify ([ int $result_type = PDO::FETCH_USE_DEFAULT [, int $ms_timeout = 0 ]] )

Returns a result set representing a pending asynchronous notification.

Değiştirgeler

result_type

The format the result set should be returned as, represented as a PDO::FETCH_* constant.

ms_timeout

The length of time to wait for a response, in milliseconds.

Dönen Değerler

If one or more notifications is pending, returns a single row, with fields message and pid, otherwise returns FALSE.

PDO::pgsqlCopyToFile
PDO::pgsqlGetPid
PostgreSQL (PDO)


Get the server PID

PDO::pgsqlGetNotify
PDO::pgsqlLOBCreate
PostgreSQL (PDO)
PHP Manual

PDO::pgsqlGetPid

(PHP 5 >= 5.6.0, PHP 7)

PDO::pgsqlGetPid — Get the server PID

Açıklama

public int PDO::pgsqlGetPid ( void )

Returns the server's PID.

Dönen Değerler

The server's PID.

PDO::pgsqlGetNotify
PDO::pgsqlLOBCreate
PostgreSQL (PDO)


Creates a new large object

PDO::pgsqlGetPid
PDO::pgsqlLOBOpen
PostgreSQL (PDO)
PHP Manual

PDO::pgsqlLOBCreate

(PHP 5 >= 5.1.2, PHP 7, PECL pdo_pgsql >= 1.0.2)

PDO::pgsqlLOBCreate — Creates a new large object

Açıklama

public string PDO::pgsqlLOBCreate ( void )

PDO::pgsqlLOBCreate() creates a large object and returns the OID of that object. You may then open a stream on the object using PDO::pgsqlLOBOpen() to read or write data to it. The OID can be stored in columns of type OID and be used to reference the large object, without causing the row to grow arbitrarily large. The large object will continue to live in the database until it is removed by calling PDO::pgsqlLOBUnlink().

Large objects can be up to 2GB in size, but are cumbersome to use; you need to ensure that PDO::pgsqlLOBUnlink() is called prior to deleting the last row that references its OID from your database. In addition, large objects have no access controls. As an alternative, try the bytea column type; recent versions of PostgreSQL allow bytea columns of up to 1GB in size and transparently manage the storage for optimal row size.

Bilginize: This function must be called within a transaction.

Değiştirgeler

PDO::pgsqlLOBCreate() takes no parameters.

Dönen Değerler

Returns the OID of the newly created large object on success, or FALSE on failure.

Örnekler

Örnek 1 A PDO::pgsqlLOBCreate() example

This example creates a new large object and copies the contents of a file into it. The OID is then stored into a table.

<?php
$db = new PDO('pgsql:dbname=test host=localhost', $user, $pass);
$db->setAttribute(PDO::ATTR_ERRMODE, PDO::ERRMODE_EXCEPTION);
$db->beginTransaction();
$oid = $db->pgsqlLOBCreate();
$stream = $db->pgsqlLOBOpen($oid, 'w');
$local = fopen($filename, 'rb');
stream_copy_to_stream($local, $stream);
$local = null;
$stream = null;
$stmt = $db->prepare("INSERT INTO BLOBS (ident, oid) VALUES (?, ?)");
$stmt->execute(array($some_id, $oid));
$db->commit();
?>

Ayrıca Bakınız

  • PDO::pgsqlLOBOpen() - Opens an existing large object stream
  • PDO::pgsqlLOBUnlink() - Deletes the large object
  • pg_lo_create() - Create a large object

PDO::pgsqlGetPid
PDO::pgsqlLOBOpen
PostgreSQL (PDO)


Opens an existing large object stream

PDO::pgsqlLOBCreate
PDO::pgsqlLOBUnlink
PostgreSQL (PDO)
PHP Manual

PDO::pgsqlLOBOpen

(PHP 5 >= 5.1.2, PHP 7, PECL pdo_pgsql >= 1.0.2)

PDO::pgsqlLOBOpen — Opens an existing large object stream

Açıklama

public resource PDO::pgsqlLOBOpen ( string $oid [, string $mode = "rb" ] )

PDO::pgsqlLOBOpen() opens a stream to access the data referenced by oid. If mode is r, the stream is opened for reading, if mode is w, then the stream will be opened for writing. You can use all the usual filesystem functions, such as fread(), fwrite() and fgets() to manipulate the contents of the stream.

Bilginize: This function, and all manipulations of the large object, must be called and carried out within a transaction.

Değiştirgeler

oid

A large object identifier.

mode

If mode is r, open the stream for reading. If mode is w, open the stream for writing.

Dönen Değerler

Returns a stream resource on success başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 A PDO::pgsqlLOBOpen() example

Following on from the PDO::pgsqlLOBCreate() example, this code snippet retrieves the large object from the database and outputs it to the browser.

<?php
$db = new PDO('pgsql:dbname=test host=localhost', $user, $pass);
$db->setAttribute(PDO::ATTR_ERRMODE, PDO::ERRMODE_EXCEPTION);
$db->beginTransaction();
$stmt = $db->prepare("select oid from BLOBS where ident = ?");
$stmt->execute(array($some_id));
$stmt->bindColumn('oid', $oid, PDO::PARAM_STR);
$stmt->fetch(PDO::FETCH_BOUND);
$stream = $db->pgsqlLOBOpen($oid, 'r');
header("Content-type: application/octet-stream");
fpassthru($stream);
?>

Ayrıca Bakınız

  • PDO::pgsqlLOBCreate() - Creates a new large object
  • PDO::pgsqlLOBUnlink() - Deletes the large object
  • pg_lo_open() - Open a large object

PDO::pgsqlLOBCreate
PDO::pgsqlLOBUnlink
PostgreSQL (PDO)


Deletes the large object

PDO::pgsqlLOBOpen
SQLite (PDO)
PostgreSQL (PDO)
PHP Manual

PDO::pgsqlLOBUnlink

(PHP 5 >= 5.1.2, PHP 7, PECL pdo_pgsql >= 1.0.2)

PDO::pgsqlLOBUnlink — Deletes the large object

Açıklama

public bool PDO::pgsqlLOBUnlink ( string $oid )

Deletes a large object from the database identified by OID.

Bilginize: This function must be called within a transaction.

Değiştirgeler

oid

A large object identifier

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 A PDO::pgsqlLOBUnlink() example

This example unlinks a large object from the database prior to deleting the row that references it from the blobs table we've been using in our PDO::pgsqlLOBCreate() and PDO::pgsqlLOBOpen() examples.

<?php
$db = new PDO('pgsql:dbname=test host=localhost', $user, $pass);
$db->setAttribute(PDO::ATTR_ERRMODE, PDO::ERRMODE_EXCEPTION);
$db->beginTransaction();
$db->pgsqlLOBUnlink($oid);
$stmt = $db->prepare("DELETE FROM BLOBS where ident = ?");
$stmt->execute(array($some_id));
$db->commit();
?>

Ayrıca Bakınız

  • PDO::pgsqlLOBOpen() - Opens an existing large object stream
  • PDO::pgsqlLOBCreate() - Creates a new large object

PDO::pgsqlLOBOpen
SQLite (PDO)
PostgreSQL (PDO)


SQLite (PDO_SQLITE) İşlevleri

Giriş

PDO_SQLITE, PHP Veri Nesneleri Arayüzünün (PDO) SQLite 3 veritabanlarına erişimini mümkün kılmak için gerçeklenmiş bir sürücüdür.

PHP 5.1'de, SQLite eklentisi teknik olarak PDO_SQLITE sürücüsünün bir parçası olmamakla beraber benzer bir davranışla SQLite 2 veritabanlarına da bir sürücü sağlar. SQLite 2'nin PDO sürücüsü öncelikle, eski SQLite 2 veritabanı dosyalarını SQLite 3 sürücüyü daha hızlı ve daha verimli kullanan bir uygulamaya aktarmayı kolaşlaştırır. Neticede, SQLite 2 sürücüsü SQLite 3 sürücüsü kadar özellik zengini değildir.

Bilginize:

PDO_SQLITE dizgelerin akımlardan ayrı olarak PDO::PARAM_LOB ile birlikte kullanımını mümkün kılar.

Kurulum

The PDO_SQLITE PDO driver is enabled by default. To disable, --without-pdo-sqlite[=DIR] may be used, where the optional [=DIR] is the sqlite base install directory.

İçindekiler

  • PDO_SQLITE DSN — SQLite veritabanı bağlantısı
  • PDO::sqliteCreateAggregate — Registers an aggregating User Defined Function for use in SQL statements
  • PDO::sqliteCreateCollation — Registers a User Defined Function for use as a collating function in SQL statements
  • PDO::sqliteCreateFunction — Registers a User Defined Function for use in SQL statements
PDO::pgsqlLOBUnlink
PDO_SQLITE DSN
PDO Sürücüleri


SQLite veritabanı bağlantısı

SQLite (PDO)
PDO::sqliteCreateAggregate
SQLite (PDO)
PHP Manual

PDO_SQLITE DSN

(PECL PDO_SQLITE >= 0.2.0)

PDO_SQLITE DSN — SQLite veritabanı bağlantısı

Açıklama

PDO_SQLITE Veri Kaynağı Adı (DSN) şu öğelerden oluşur:

DSN öneki (SQLite 3)

DSN öneki sqlite: dizgesidir.

  • Disk üzerindeki bir veritabanına erişmek için DSN önekinin ardına mutlak dosya yolunu ekleyin.

  • Bellekte bir veritabanı oluşturmak için DSN önekinin ardına :memory: dizgesini ekleyin.

DSN öneki (SQLite 2)

PHP 5.1'deki SQLite eklentisi SQLite 2 veribanlarını oluşturmak ve erişmek için bir PDO sürücüsü desteği de sağlar. Böylece daha önceki PHP sürümlerinin SQLite eklentisi ile oluşturduğunuz veritabanlarına da erişebilirsiniz.

Bilginize:

Sqlite2 PDO sürücüsünü PHP 5.1.x sürümlerinde sadece PDO'yu ve ext/sqlite'ı birlikte etkin kıldığınızda kullanabilirsiniz. PECL üzerinden kurulum mümkün değildir.

SQLite 2 veritabanlarına bağlanmak için DSN öneki sqlite2: dizgesidir.

  • Disk üzerindeki bir veritabanına erişmek için DSN önekinin ardına mutlak dosya yolunu ekleyin.

  • Bellekte bir veritabanı oluşturmak için DSN önekinin ardına :memory: dizgesini ekleyin.

Örnekler

Örnek 1 - PDO_SQLITE DSN örnekleri

Aşağıdaki örneklerde SQLite veritabanlarına bağlanmak için PDO_SQLITE DSN kullanımları gösterilmiştir:

sqlite:/opt/databases/mydb.sq3
sqlite::memory:
sqlite2:/opt/databases/mydb.sq2
sqlite2::memory:

SQLite (PDO)
PDO::sqliteCreateAggregate
SQLite (PDO)


Registers an aggregating User Defined Function for use in SQL statements

PDO_SQLITE DSN
PDO::sqliteCreateCollation
SQLite (PDO)
PHP Manual

PDO::sqliteCreateAggregate

(PHP 5 >= 5.1.0, PHP 7, PECL pdo_sqlite >= 1.0.0)

PDO::sqliteCreateAggregate — Registers an aggregating User Defined Function for use in SQL statements

Açıklama

public bool PDO::sqliteCreateAggregate ( string $function_name , callable $step_func , callable $finalize_func [, int $num_args ] )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

This method is similar to PDO::sqliteCreateFunction except that it registers functions that can be used to calculate a result aggregated across all the rows of a query.

The key difference between this method and PDO::sqliteCreateFunction is that two functions are required to manage the aggregate.

Değiştirgeler

function_name

The name of the function used in SQL statements.

step_func

Callback function called for each row of the result set. Your PHP function should accumulate the result and store it in the aggregation context.

This function need to be defined as:

mixed step ( mixed $context , int $rownumber , mixed $value1 [, mixed $value2 [, mixed $.. ]] )

context will be NULL for the first row; on subsequent rows it will have the value that was previously returned from the step function; you should use this to maintain the aggregate state.

rownumber will hold the current row number.

The return value of this function will be used as the context argument in the next call of the step or finalize functions.

finalize_func

Callback function to aggregate the "stepped" data from each row. Once all the rows have been processed, this function will be called and it should then take the data from the aggregation context and return the result. Callback functions should return a type understood by SQLite (i.e. scalar type).

This function need to be defined as:

mixed fini ( mixed $context , int $rownumber )

context will hold the return value from the very last call to the step function.

rownumber will hold the number of rows over which the aggregate was performed.

The return value of this function will be used as the return value for the aggregate.

num_args

Hint to the SQLite parser if the callback function accepts a predetermined number of arguments.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 max_length aggregation function example

<?php
$data = array(
   'one',
   'two',
   'three',
   'four',
   'five',
   'six',
   'seven',
   'eight',
   'nine',
   'ten',
   );
$db = new PDO('sqlite::memory:');
$db->exec("CREATE TABLE strings(a)");
$insert = $db->prepare('INSERT INTO strings VALUES (?)');
foreach ($data as $str) {
    $insert->execute(array($str));
}
$insert = null;

function max_len_step(&$context, $rownumber, $string)
{
    if (strlen($string) > $context) {
        $context = strlen($string);
    }
    return $context;
}

function max_len_finalize(&$context, $rownumber)
{
    return $context;
}

$db->sqliteCreateAggregate('max_len', 'max_len_step', 'max_len_finalize');

var_dump($db->query('SELECT max_len(a) from strings')->fetchAll());

?>

In this example, we are creating an aggregating function that will calculate the length of the longest string in one of the columns of the table. For each row, the max_len_step function is called and passed a context parameter. The context parameter is just like any other PHP variable and be set to hold an array or even an object value. In this example, we are simply using it to hold the maximum length we have seen so far; if the string has a length longer than the current maximum, we update the context to hold this new maximum length.

After all of the rows have been processed, SQLite calls the max_len_finalize function to determine the aggregate result. Here, we could perform some kind of calculation based on the data found in the context. In our simple example though, we have been calculating the result as the query progressed, so we simply need to return the context value.

İpucu

It is NOT recommended for you to store a copy of the values in the context and then process them at the end, as you would cause SQLite to use a lot of memory to process the query - just think of how much memory you would need if a million rows were stored in memory, each containing a string 32 bytes in length.

İpucu

You can use PDO::sqliteCreateFunction and PDO::sqliteCreateAggregate to override SQLite native SQL functions.

Bilginize:

This method is not available with the SQLite2 driver. Use the old style sqlite API for that instead.

Ayrıca Bakınız

  • PDO::sqliteCreateFunction
  • sqlite_create_function() - SQL deyimlerinde kullanmak üzere bir kullanıcı tanımlı işlevi kayda geçirir
  • sqlite_create_aggregate() - SQL deyimlerinde kullanmak üzere toparlayıcı bir kullanıcı tanımlı işlevi kayda geçirir

PDO_SQLITE DSN
PDO::sqliteCreateCollation
SQLite (PDO)


Registers a User Defined Function for use as a collating function in SQL statements

PDO::sqliteCreateAggregate
PDO::sqliteCreateFunction
SQLite (PDO)
PHP Manual

PDO::sqliteCreateCollation

(PHP 5 >= 5.3.11, PHP 7)

PDO::sqliteCreateCollation — Registers a User Defined Function for use as a collating function in SQL statements

Açıklama

public bool PDO::sqliteCreateCollation ( string $name , callable $callback )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Değiştirgeler

name

Name of the SQL collating function to be created or redefined.

callback

The name of a PHP function or user-defined function to apply as a callback, defining the behavior of the collation. It should accept two strings and return as strcmp() does, i.e. it should return -1, 1, or 0 if the first string sorts before, sorts after, or is equal to the second.

This function need to be defined as:

int collation ( string $string1 , string $string2 )

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 PDO::sqliteCreateCollation() example

<?php
$db = new PDO('sqlite::memory:');
$db->exec("CREATE TABLE test (col1 string)");
$db->exec("INSERT INTO test VALUES ('a1')");
$db->exec("INSERT INTO test VALUES ('a10')");
$db->exec("INSERT INTO test VALUES ('a2')");

$db->sqliteCreateCollation('NATURAL_CMP', 'strnatcmp');
foreach ($db->query("SELECT col1 FROM test ORDER BY col1") as $row) {
  echo $row['col1'] . "\n";
}
echo "\n";
foreach ($db->query("SELECT col1 FROM test ORDER BY col1 COLLATE NATURAL_CMP") as $row) {
  echo $row['col1'] . "\n";
}
?>

Yukarıdaki örneğin çıktısı:

a1
a10
a2

a1
a2
a10

Notlar

Bilginize:

This method is not available with the SQLite2 driver. Use the old style sqlite API for that instead.

PDO::sqliteCreateAggregate
PDO::sqliteCreateFunction
SQLite (PDO)


Registers a User Defined Function for use in SQL statements

PDO::sqliteCreateCollation
PDO_4D sürücüsü
SQLite (PDO)
PHP Manual

PDO::sqliteCreateFunction

(PHP 5 >= 5.1.0, PHP 7, PECL pdo_sqlite >= 1.0.0)

PDO::sqliteCreateFunction — Registers a User Defined Function for use in SQL statements

Açıklama

public bool PDO::sqliteCreateFunction ( string $function_name , callable $callback [, int $num_args ] )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

This method allows you to register a PHP function with SQLite as an UDF (User Defined Function), so that it can be called from within your SQL statements.

The UDF can be used in any SQL statement that can call functions, such as SELECT and UPDATE statements and also in triggers.

Değiştirgeler

function_name

The name of the function used in SQL statements.

callback

Callback function to handle the defined SQL function.

Bilginize: Callback functions should return a type understood by SQLite (i.e. scalar type).

num_args

Hint to the SQLite parser if the callback function accepts a predetermined number of arguments.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 PDO::sqliteCreateFunction() example

<?php
function md5_and_reverse($string)
{
    return strrev(md5($string));
}

$db = new PDO('sqlite:sqlitedb');
$db->sqliteCreateFunction('md5rev', 'md5_and_reverse', 1);
$rows = $db->query('SELECT md5rev(filename) FROM files')->fetchAll();
?>

In this example, we have a function that calculates the md5 sum of a string, and then reverses it. When the SQL statement executes, it returns the value of the filename transformed by our function. The data returned in $rows contains the processed result.

The beauty of this technique is that you do not need to process the result using a foreach loop after you have queried for the data.

İpucu

You can use PDO::sqliteCreateFunction and PDO::sqliteCreateAggregate to override SQLite native SQL functions.

Bilginize:

This method is not available with the SQLite2 driver. Use the old style sqlite API for that instead.

Ayrıca Bakınız

  • PDO::sqliteCreateAggregate
  • sqlite_create_function() - SQL deyimlerinde kullanmak üzere bir kullanıcı tanımlı işlevi kayda geçirir
  • sqlite_create_aggregate() - SQL deyimlerinde kullanmak üzere toparlayıcı bir kullanıcı tanımlı işlevi kayda geçirir

PDO::sqliteCreateCollation
PDO_4D sürücüsü
SQLite (PDO)


PDO için 4D sürücüsü (PDO_4D)

Giriş

Uyarı

Bu eklenti DENEYSELDİR. Bu eklentinin davranışı, işlev isimleri ve tüm belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu eklentiyi kullanmayın.

PDO_4D, PHP Veri Nesneleri Arayüzünün (PDO) 4D veritabanlarına erişimini mümkün kılmak için gerçeklenmiş bir sürücüdür.

4D, 70 ülkede milyonlarca (yankı) son kullanıcı tarafından kullanılan, binlerce (yankı) geliştiricisi olan ve iş uygulamalarını geliştirilmesini kolaylaştıran ve hızlandıran bütünleşik bir platformdur.

ANSI SQL ilişkisel veritabanlarını ve toplu hareketleri destekleyen bütünleşik araçlar ile birlikte gelen, 100 yüksek seviyeden komut, yerleşik bir HTTP sunucusu, uygulama sunucusu ve benzerlerini içerin 4. nesil bir dildir. Windows, Mac veya diğer HTTP sunucuları dahil aynı andra yüzlerce kullanıcıya yönelik uygulamaların oluşturulmasını ve geliştirilmesini sağlar.

4D ayrıca bir açık platformdur. Çeşitli ortamları (OCI üzerinden Oracle, SOAP istemci ve sunucusu, Flex veri kaynağı, tüm ODBC veritabanları, HTTP üzerinden XML, vb.) için ön ve art alan uygulaması olarak davranan bağlayıcılar dahil, eklenti oluşturmak için eksiksiz bir arayüz ile gelir.

HTTP hizmetleri ve 4D veritabanlarına PDO_4D süarücüsünü kullanarak doğrudan erişebilen 4D uygulamaları ile etkileşim yeteneği de vardır.

4D geliştirme ortamı hakkında ayrıntılı bilgiyi » http://www.4d.com/ adresinden edinebilirsiniz.

PDO_4D sürcüsü Windows (Vista), Mac OS X (10.5) ve Linux (Debian'da denenmiştir) üzerinde çalışmak için geliştirilmiştir. Daha eski platformlarda da çalışabiril, ancak bnlar desteklenmemektedir.

İçindekiler

  • PDO_4D DSN — 4D SQL sunucusuna bağlantı
  • PDO_4D Sabitleri — PDO_4D Sabitleri
  • PDO_4D ve PHP ile SQL türleri — PDO_4D ve PHP ile SQL türleri
  • 4D tarafından kabul edilebilen SQL — PDO ve SQL 4D
  • PDO_4D örnekleri — PDO_4D Örnekleri
PDO::sqliteCreateFunction
PDO_4D DSN
PDO Sürücüleri


4D SQL sunucusuna bağlantı

PDO_4D sürücüsü
PDO_4D Sabitleri
PDO_4D sürücüsü
PHP Manual

PDO_4D DSN

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

PDO_4D DSN — 4D SQL sunucusuna bağlantı

Açıklama

PDO_4D DSN'si şu bileşenlerden oluşur:

DSN öneki

DSN öneki 4D: dizgesidir.

host

4D SQL sunucusunu barındıran konak.

port

Sunucunun dinlediği port; belirtilmesi isteğe bağlıdır.

user

Veritabanına bağlanırken kullanılan kullanıcı ismi.

password

Veritabanına bağlanırken kullanılan kullanıcı parolası.

dbname

Veritabanının ismi. Kullanımı isteğe bağlı olup genelde kullanılmamaktadır.

charsset

4D karakter kümesi.

Örnekler

Örnek 1 - PDO_4D için DSN örnekleri

Aşağıdaki örneklerde 4D veritabanlarına bağlanmak için kullanılan iki PDO_4D DSN'si gösterilmiştir.

4D:host=localhost;CHARSET=Windows-1254
Başka bir olası değer:
4D:host=localhost

PDO_4D sürücüsü
PDO_4D Sabitleri
PDO_4D sürücüsü


PDO_4D Sabitleri

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

PDO_4D Sabitleri — PDO_4D Sabitleri

Öntanımlı Sabitler

Bu sabitler bu sürücü tarafından tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir. Ek olarak, bu sürücüye özgü sabitler sadece bu sürücüyü kullanıyorsanız kullanılmalıdır. Sürücüye özgü özniteliklerin postgres sürücüsü ile kullanılması beklenmedik davranışlara yol açabilir. Eğer kodunuz çok sayıda sürücüye karşı çalışıyorsa sürücüyü sınayacak PDO_ATTR_DRIVER_NAME özniteliğini sağlamak için PDO::getAttribute() kullanılabilir.

PDO::FOURD_ATTR_CHARSET (integer)

Dönen verinin karakter kümesi; UTF-8 öntanımlıdır.

PDO::FOURD_ATTR_PREFERRED_IMAGE_TYPES (integer)

PICTURE sütun türlü bir satırı seçerken istenen ikil biçem. 4D tarafından desteklenen herhangi bir biçem olabilir.

PDO_4D DSN
PDO_4D ve PHP ile SQL türleri
PDO_4D sürücüsü


PDO_4D ve PHP ile SQL türleri

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

PDO_4D ve PHP ile SQL türleri — PDO_4D ve PHP ile SQL türleri

Desteklenen SQL veri türleri
SQL 4D veri türü | 4D eşdeğeri | >Bilgi
ALPHA_NUMERIC | TEXT |
VARCHAR | TEXT |
TEXT | TEXT |
TIMESTAMP | DATE |
INTERVAL | HOUR |
DURATION | HOUR |
BOOLEAN | BOOLEAN |
BIT | BOOLEAN |
BYTE | INT32 |
INT16 | SMALLINT |
SMALLINT | SMALLINT |
INT32 | INT32 |
INT | INT32 |
INT64 | INT64 |
NUMERIC | INT64 |
REAL | REAL | Desteklenmiyor (VARCHAR kullanın).
FLOAT | FLOAT | Desteklenmiyor (VARCHAR kullanın).
DOUBLE PRECISION | FLOAT |
BLOB | BLOB | Bir hazır deyim ve PDO::PARAM_LOB kullanılmalı.
BIT VARYING | BLOB | Bir hazır deyim ve PDO::PARAM_LOB kullanılmalı.
CLOB | TEXT |
PICTURE | PICTURE | Bir hazır deyim ve PDO::PARAM_LOB kullanılmalı.

PDO_4D Sabitleri
4D tarafından kabul edilebilen SQL
PDO_4D sürücüsü


PDO ve SQL 4D

PDO_4D ve PHP ile SQL türleri
PDO_4D örnekleri
PDO_4D sürücüsü
PHP Manual

4D tarafından kabul edilebilen SQL

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

4D tarafından kabul edilebilen SQL — PDO ve SQL 4D

Açıklama

4D, ANSI 89 standardıyla tam uyumludur. Kullanılabilecek komutlarla ilgili ayrıntılar için 4D SQL belgelerini okuyun. Kılavuz » http://doc.4d.com/ adresinden edinilebilir. Aşağıda 4D karakteristikleri listelenmiştir (ayrıntılı olmamakla birlikte amaca hizmet etmektedir):

4D SQL'in başlıca özellikleri
Özellik | Açıklaması | Ek bilgi
INTEGER | INT desteklenen tamsayı türüdür. SQL'i INT kullanacak şekilde değiştirir. |
UNION | Desteklenmemektedi. Ayrık sorgular yapar. |
LEFT JOIN | SQL 89 gösterimi kullanılır (PDO_4D, 3. örneğine bakınız) |
SELECT 1 + 1; | SELECT 1 + 1 FROM _USER_SCHEMAS; |
FLOAT | Bir SQL 4D işlevi (ROUND, TRUNC veya TRUNCATE) ile FLOAT değere dönüşüm. | PDO_4D v1.0'da desteklenmemektedir.
Desteklenen türler: 4D tarafından desteklenen veri türlerinden biri. Bir INTEGER sütuna dizge olarak '1' yerleştirilebilir. | Türe uyum sağlamak için ZQL sorgunuzda veya PHP kodunuzda değişiklik yapın | Desteklenmiyor.
PDO::execute($satır)() sadece TEXT türündeki tablo sütunları ile çalışır. | Doğru türleri ve hazır deyimleri kullanın | PDO eklentisi tüm değerlere execute() üzerinden dizgeye dönüşüm uygular ve SQL veritabanının bu değerleri çözümleyeceğini umar.
SELECT NULL FROM TABLE | Seçim listesinde NULL sabitinin kullanımına izin verilmez. | NULL sabitini kullanmayın. Tablodan çıkarın.
SELECT * FROM TABLE WHERE 1 | WHERE yan tümcesinde bir sabit kullanılamaz. | 1 = 1 kullanın.
SHOW TABLES | Tablolar, şemalar, indisler vs. 7 tane 4D tablosu olarak listelenir. | _USER_TABLES, _USER_COLUMNS, _USER_INDEXES, _USER_CONSTRAINTS, _USER_IND_COLUMNS, _USER_CONS_COLUMNS, ve _USER_SCHEMAS kullanın.
SQL yapısal ayracı | SQL elemanlarını (tablolar, alanlar, kullanıcılar, gruplar, şema, birincil anahtar, vb.) öncelemek için, kapatan köşeli ayraçlar yinelenmeli ve betimleyicinin tamamı köşeli ayraçlar arasına alınmalıdır. | SQL nesnelerini korumak için şu işlevi kullanın ve ardından köşeli ayraçlar arasına yerleştirin: str_replace(']',']]', $table).

Bilginize:

11.3 ve öncesi sürümlerde bir tablonun oluşturulması sırasında id INT PRIMARY KEY SQL sözdizimini kullanmak mümkün değildi. 11.4 sürümünden itibaren bu yetersizlik düzeltilmiştir. PDO_4D ile en az 11.4 sürümünün kullanımını öneririz.

PDO_4D ve PHP ile SQL türleri
PDO_4D örnekleri
PDO_4D sürücüsü


PDO_4D örnekleri

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

PDO_4D örnekleri — PDO_4D Örnekleri

Bu temel örnekte, bir 4D SQL sunucusuna nasıl bağlanılacağı, bir sorgunun nasıl çalıştırılacağı ve bağlantının nasıl kapatılacağı gösterilmiştir.

Örnek 1 - PDO_4D için bir temel örnek

<?php
$dsn = '4D:host=localhost;CHARSET=Windows-1254';
$user = 'test';
$pass = 'test';

// 4D SQL sunucusuna bağlanalım
$db = new PDO_4D($dsn, $user, $pass);

try {
    $db->exec('CREATE TABLE test(id varCHAR(1) NOT NULL, val VARCHAR(10))');
} catch (PDOException $e) {
    die("4D hatası: " . $e->getMessage());
}

$db->exec("INSERT INTO test VALUES('A', 'A')");
$db->exec("INSERT INTO test VALUES('B', 'A')");
$db->exec("INSERT INTO test VALUES('C', 'C')");

$stmt = $db->prepare('SELECT id, val from test');

$stmt->execute();
print_r($stmt->fetchAll());

unset($stmt);
unset($db);
?>

Yukarıdaki örneğin çıktısı:

    Array
(
    [0] => Array
        (
            [ID] => A
            [0] => A
            [VAL] => B
            [1] => B
        )

    [1] => Array
        (
            [ID] => C
            [0] => C
            [VAL] => D
            [1] => D
        )

    [2] => Array
        (
            [ID] => E
            [0] => E
            [VAL] => F
            [1] => F
        )

)

Bu örnekte PDO_4D üzerinden bir 4D veritabanında bir sorgunun çalıştırılışı ve sonuçların okunuşu gösterilmiştir.

Örnek 2 PDO_4D üzerinden bir 4D veritabanına bağlanmak

Örnekte method adında bir 4D yöntemi çağrılmaktadır. Yöntemin özellikleri arasında Available via SQL seçeneğinin bulunduğundan emin olun. 4D yönteminin kodu:

C_TEXTE($0)
$0:=Version application(*);

Bu 4D yöntemini kullanan PHP kodu:

<?php
$dsn = '4D:host=localhost;CHARSET=Windows-1254';
$user = 'test';
$pass = 'test';

// 4D sunucusuna bağlanalım
$db = new pdo($dsn, $user, $pass);

$stmt = $db->prepare('SELECT {FN method() AS VARCHAR } FROM _USER_SCHEMAS LIMIT 1');

$stmt->execute();
print_r($stmt->fetchAll());

unset($stmt);
unset($db);
?>

Yukarıdaki örneğin çıktısı:

(
    [0] => Array
        (
            [<expression>] => F0011140
            [0] => F0011140
        )

)

Örnek 3 - 4D'de bir LEFT JOIN çalıştırmak

Bu örnekte, 4D ile bir LEFT JOIN SQL sorgusunun çalıştırılışı gösterilmiştir.

<?php
$dsn = '4D:host=localhost;CHARSET=Windows-1254';
$user = 'test';
$pass = 'test';

// 4D SQL sunucusuna bağlanalım
$db = new PDO_4D($dsn, $user, $pass);

/* Bu SQL sorgusu aşağıdaki LEFT JOIN sorgusuna eşdeğerdir
SELECT
  classtypes.name,
  test.id AS id,
  test.val AS val
FROM
  test
LEFT JOIN
  classtypes
ON
  test.classtype=classtypes.id
*/

// SQL-89  Gösterimi kullanılıyor
$query = <<<SQL
SELECT
  classtypes.name,
  test.id AS id,
  test.val AS val
FROM
  test,
  classtypes
WHERE
  test.classtype=classtypes.id
  OR test.classtype IS NULL
SQL;

$stmt = $db->prepare($query);
$stmt->execute();

print_r($stmt->fetchAll());

$stmt = null;
$db = null;
?>

Örnek 4 - 4D tablo isimlerinin öncelenmesi

Bu örnekte bir 4D SQL sorgusunun öncelenişi gösterilmiştir:

<?php
$dsn = '4D:host=localhost;CHARSET=Windows-1254';
$user = 'test';
$pass = 'test';

// 4D sunucusuna bağlanalım
$db = new PDO_4D($dsn, $user, $pass);

$objects = array('[',']','[]','][','[[',']]','[[[',']]]','TBL ]]32[23');

foreach($objects as $id => $object) {
    $object = str_replace(']',']]', $object);
    print "$object\n";

    $db->exec('CREATE TABLE IF NOT EXISTS ['.$object.'](['.$object.'] FLOAT)');

    $req = "INSERT INTO [$object] ([$object]) VALUES ($id);";
    $db->query($req);

    $q = $db->prepare("SELECT [$object] FROM [$object]");
    $q->execute();
    $x[] = $q->fetch(PDO::FETCH_NUM);

    $db->exec('DROP TABLE ['.$object.'];');
}

?>

Yukarıdaki örneğin çıktısı:

[
]]
[]]
]][
[[
]]]]
[[[
]]]]]]
TBL ]]]]32[23

4D tarafından kabul edilebilen SQL
Sağlayıcıya Göre Veritabanı Eklentileri
PDO_4D sürücüsü


Sağlayıcıya Göre Veritabanı Eklentileri

  • CUBRID
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • CUBRID İşlevleri
    • CUBRID MySQL Compatibility Functions
    • CUBRID Obsolete Aliases and Functions
  • DB++
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • DB++ İşlevleri
  • dBase
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • dBase İşlevleri
  • filePro
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • filePro İşlevleri
  • Firebird/InterBase
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Firebird/InterBase İşlevleri
  • FrontBase
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • FrontBase İşlevleri
  • IBM DB2 — IBM DB2, Cloudscape and Apache Derby
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • IBM DB2 İşlevleri
  • Informix
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Informix İşlevleri
  • Ingres — Ingres DBMS, EDBC, and Enterprise Access Gateways
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • Ingres İşlevleri
  • MaxDB
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • MaxDB İşlevleri
  • Mongo — MongoDB driver (legacy)
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Manual
    • Core Classes
    • Types
    • GridFS Classes
    • Batch Classes
    • Miscellaneous
    • Mongo İşlevleri
    • Exceptions
    • Changelog
  • MongoDB — MongoDB driver
    • Yapılandırma/Kurulum
    • Tutorials
    • Driver Architecture and Internals — Explains the driver architecure, and special features
    • Security
    • MongoDB\Driver — MongoDB driver classes
    • MongoDB\BSON — BSON type classes and serialization functions
    • MongoDB\Driver\Exception — Exception classes
  • mSQL
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • mSQL İşlevleri
  • Mssql — Microsoft SQL Server
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Mssql İşlevleri
  • MySQL — MySQL Drivers and Plugins
    • Overview of the MySQL PHP drivers
    • MySQLi — MySQL Improved Extension
    • MySQL
    • Mysqlnd — MySQL Native Driver
    • mysqlnd_ms — Mysqlnd replication and load balancing plugin
    • mysqlnd_qc — Mysqlnd query result cache plugin
    • mysqlnd_uh — Mysqlnd user handler plugin
    • mysqlnd_mux — Mysqlnd connection multiplexing plugin
    • mysqlnd_memcache — Mysqlnd Memcache plugin
  • OCI8 — Oracle OCI8
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • OCI8 Connection Handling and Connection Pooling
    • OCI8 Fast Application Notification (FAN) Support
    • OCI8 and DTrace Dynamic Tracing
    • Supported Datatypes
    • OCI8 İşlevleri
    • OCI-Collection — The OCI-Collection class
    • OCI-Lob — The OCI-Lob class
    • OCI8 Obsolete Aliases and Functions
  • Paradox — Paradox File Access
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Paradox İşlevleri
  • PostgreSQL
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • PostgreSQL İşlevleri
  • SQLite
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • SQLite İşlevleri
  • SQLite3
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • SQLite3 — SQLite3 sınıfı
    • SQLite3Stmt — SQLite3Stmt sınıfı
    • SQLite3Result — SQLite3Result sınıfı
  • SQLSRV — Microsoft SQL Server Driver for PHP
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • SQLSRV İşlevleri
  • Sybase
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Sybase İşlevleri
  • tokyo_tyrant
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • TokyoTyrant — The TokyoTyrant class
    • TokyoTyrantTable — The TokyoTyrantTable class
    • TokyoTyrantQuery — The TokyoTyrantQuery class
    • TokyoTyrantIterator — The TokyoTyrantIterator class
    • TokyoTyrantException — The TokyoTyrantException class
PDO_4D örnekleri
CUBRID
Veritabanı Eklentileri


CUBRID

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
  • CUBRID İşlevleri
    • cubrid_bind — Bind variables to a prepared statement as parameters
    • cubrid_close_prepare — Close the request handle
    • cubrid_close_request — Close the request handle
    • cubrid_col_get — Get contents of collection type column using OID
    • cubrid_col_size — Get the number of elements in collection type column using OID
    • cubrid_column_names — Get the column names in result
    • cubrid_column_types — Get column types in result
    • cubrid_commit — Commit a transaction
    • cubrid_connect_with_url — Establish the environment for connecting to CUBRID server
    • cubrid_connect — Open a connection to a CUBRID Server
    • cubrid_current_oid — Get OID of the current cursor location
    • cubrid_disconnect — Close a database connection
    • cubrid_drop — Delete an instance using OID
    • cubrid_error_code_facility — Get the facility code of error
    • cubrid_error_code — Get error code for the most recent function call
    • cubrid_error_msg — Get last error message for the most recent function call
    • cubrid_execute — Execute a prepared SQL statement
    • cubrid_fetch — Fetch the next row from a result set
    • cubrid_free_result — Free the memory occupied by the result data
    • cubrid_get_autocommit — Get auto-commit mode of the connection
    • cubrid_get_charset — Return the current CUBRID connection charset
    • cubrid_get_class_name — Get the class name using OID
    • cubrid_get_client_info — Return the client library version
    • cubrid_get_db_parameter — Returns the CUBRID database parameters
    • cubrid_get_query_timeout — Get the query timeout value of the request
    • cubrid_get_server_info — Return the CUBRID server version
    • cubrid_get — Get a column using OID
    • cubrid_insert_id — Return the ID generated for the last updated AUTO_INCREMENT column
    • cubrid_is_instance — Check whether the instance pointed by OID exists
    • cubrid_lob_close — Close BLOB/CLOB data
    • cubrid_lob_export — Export BLOB/CLOB data to file
    • cubrid_lob_get — Get BLOB/CLOB data
    • cubrid_lob_send — Read BLOB/CLOB data and send straight to browser
    • cubrid_lob_size — Get BLOB/CLOB data size
    • cubrid_lob2_bind — Bind a lob object or a string as a lob object to a prepared statement as parameters.
    • cubrid_lob2_close — Close LOB object.
    • cubrid_lob2_export — Export the lob object to a file.
    • cubrid_lob2_import — Import BLOB/CLOB data from a file.
    • cubrid_lob2_new — Create a lob object.
    • cubrid_lob2_read — Read from BLOB/CLOB data.
    • cubrid_lob2_seek64 — Move the cursor of a lob object.
    • cubrid_lob2_seek — Move the cursor of a lob object.
    • cubrid_lob2_size64 — Get a lob object's size.
    • cubrid_lob2_size — Get a lob object's size.
    • cubrid_lob2_tell64 — Tell the cursor position of the LOB object.
    • cubrid_lob2_tell — Tell the cursor position of the LOB object.
    • cubrid_lob2_write — Write to a lob object.
    • cubrid_lock_read — Set a read lock on the given OID
    • cubrid_lock_write — Set a write lock on the given OID
    • cubrid_move_cursor — Move the cursor in the result
    • cubrid_next_result — Get result of next query when executing multiple SQL statements
    • cubrid_num_cols — Return the number of columns in the result set
    • cubrid_num_rows — Get the number of rows in the result set
    • cubrid_pconnect_with_url — Open a persistent connection to CUBRID server
    • cubrid_pconnect — Open a persistent connection to a CUBRID server
    • cubrid_prepare — Prepare a SQL statement for execution
    • cubrid_put — Update a column using OID
    • cubrid_rollback — Roll back a transaction
    • cubrid_schema — Get the requested schema information
    • cubrid_seq_drop — Delete an element from sequence type column using OID
    • cubrid_seq_insert — Insert an element to a sequence type column using OID
    • cubrid_seq_put — Update the element value of sequence type column using OID
    • cubrid_set_add — Insert a single element to set type column using OID
    • cubrid_set_autocommit — Set autocommit mode of the connection
    • cubrid_set_db_parameter — Sets the CUBRID database parameters
    • cubrid_set_drop — Delete an element from set type column using OID
    • cubrid_set_query_timeout — Set the timeout time of query execution
    • cubrid_version — Get the CUBRID PHP module's version
  • CUBRID MySQL Compatibility Functions
    • cubrid_affected_rows — Return the number of rows affected by the last SQL statement
    • cubrid_client_encoding — Return the current CUBRID connection charset
    • cubrid_close — Close CUBRID connection
    • cubrid_data_seek — Move the internal row pointer of the CUBRID result
    • cubrid_db_name — Get db name from results of cubrid_list_dbs
    • cubrid_errno — Return the numerical value of the error message from previous CUBRID operation
    • cubrid_error — Get the error message
    • cubrid_fetch_array — Fetch a result row as an associative array, a numeric array, or both
    • cubrid_fetch_assoc — Return the associative array that corresponds to the fetched row
    • cubrid_fetch_field — Get column information from a result and return as an object
    • cubrid_fetch_lengths — Return an array with the lengths of the values of each field from the current row
    • cubrid_fetch_object — Fetch the next row and return it as an object
    • cubrid_fetch_row — Return a numerical array with the values of the current row
    • cubrid_field_flags — Return a string with the flags of the given field offset
    • cubrid_field_len — Get the maximum length of the specified field
    • cubrid_field_name — Return the name of the specified field index
    • cubrid_field_seek — Move the result set cursor to the specified field offset
    • cubrid_field_table — Return the name of the table of the specified field
    • cubrid_field_type — Return the type of the column corresponding to the given field offset
    • cubrid_list_dbs — Return an array with the list of all existing CUBRID databases
    • cubrid_num_fields — Return the number of columns in the result set
    • cubrid_ping — Ping a server connection or reconnect if there is no connection
    • cubrid_query — Send a CUBRID query
    • cubrid_real_escape_string — Escape special characters in a string for use in an SQL statement
    • cubrid_result — Return the value of a specific field in a specific row
    • cubrid_unbuffered_query — Perform a query without fetching the results into memory
  • CUBRID Obsolete Aliases and Functions
    • cubrid_load_from_glo — Read data from a GLO instance and save it in a file
    • cubrid_new_glo — Create a glo instance
    • cubrid_save_to_glo — Save requested file in a GLO instance
    • cubrid_send_glo — Read data from glo and send it to std output
Sağlayıcıya Göre Veritabanı Eklentileri
Giriş
Sağlayıcıya Göre Veritabanı Eklentileri


Giriş

These functions allow you to access CUBRID database servers. More information about CUBRID can be found at » CUBRID.

Documentation for CUBRID can be found at » CUBRID Documentation.

CUBRID
Yapılandırma/Kurulum
CUBRID


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
CUBRID


Gereksinimler

In order to have these functions available, you must install CUBRID, and compile CUBRID PHP Library with CUBRID support.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/cubrid.

Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız.

For information about manual installation on Linux and Windows systems, please read the file build-guide.html included in the package.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

There is no runtime configuration now.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Özkaynak Türleri

There are four resource types used in CUBRID. The first one is the link identifier for a database connection, the second is the a resource which holds the result of a query, and the last two a resource which holds the query results of BLOB/CLOB data types.

connection identifier

A connection identifier returned by cubrid_connect(),
cubrid_connect_with_url(),
cubrid_pconnect() and
cubrid_pconnect_with_url().

request identifier

A request identifier returned by cubrid_prepare() and cubrid_execute().

LOB identifier

A LOB identifier returned by cubrid_lob_get().

LOB2 identifier

A LOB identifier returned by cubrid_lob2_new() or get from the result set.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

The following constants can be used when executing SQL statement. They can be passed to cubrid_prepare() and cubrid_execute().

CUBRID SQL execution flags
Constant | Description
CUBRID_INCLUDE_OID | Determine whether to get OID during query execution.
CUBRID_ASYNC | Execute the query in asynchronous mode.
CUBRID_EXEC_QUERY_ALL | Execute the query in synchronous mode. This flag must be set when executing multiple SQL statements.

The following constants can be used when fetching the results to specify fetch behaviour. They can be passed to cubrid_fetch() and cubrid_fetch_array().

CUBRID fetch flags
Constant | Description
CUBRID_NUM | Get query result as a numeric array (0-default).
CUBRID_ASSOC | Get query result as an associative array.
CUBRID_BOTH | Get query result as both numeric and associative arrays (default value).
CUBRID_OBJECT | Get query result an object.
CUBRID_LOB | The constant CUBRID_LOB can be used when you want to operate the lob object. It can be passed to cubrid_fetch(), cubrid_fetch_row(), cubrid_fetch_array(), cubrid_fetch_assoc() and cubrid_fetch_object().

The following constants can be used when positioning the cursor in query results. They can be passed to or returned by cubrid_move_cursor().

CUBRID cursor position flags
Constant | Description
CUBRID_CURSOR_FIRST | Move current cursor to the first position in the result.
CUBRID_CURSOR_CURRENT | Move current cursor as a default value if the origin is not specified.
CUBRID_CURSOR_LAST | Move current cursor to the last position in the result.
CUBRID_CURSOR_SUCCESS | Returned value of cubrid_move_cursor() function in case of success. This flag has been removed from 8.4.1.
CUBRID_NO_MORE_DATA | Returned value of cubrid_move_cursor() function in case of failure. This flag has been removed from 8.4.1.
CUBRID_CURSOR_ERROR | Returned value of cubrid_move_cursor() function in case of failure. This flag has been removed from 8.4.1.

The following constants can be used when setting the auto-commit mode for the database connection. They can be passed to cubrid_set_autocommit() or returned by cubrid_get_autocommit().

CUBRID auto-commit mode flags
Constant | Description
CUBRID_AUTOCOMMIT_TRUE | Enable the auto-commit mode.
CUBRID_AUTOCOMMIT_FALSE | Disable the auto-commit mode.

The following constants can be used when setting the database parameter. They can be passed to cubrid_set_db_parameter().

CUBRID parameter flags
Constant | Description
CUBRID_PARAM_ISOLATION_LEVEL | Transaction isolation level for the database connection.
CUBRID_PARAM_LOCK_TIMEOUT | Transaction timeout in seconds.

The following constants can be used when setting the transaction isolation level. They can be passed to cubrid_set_db_parameter() or returned by cubrid_get_db_parameter().

CUBRID isolation level flags
Constant | Description
TRAN_COMMIT_CLASS_UNCOMMIT_INSTANCE | The lowest isolation level (1). A dirty, non-repeatable or phantom read may occur for the tuple and a non-repeatable read may occur for the table as well.
TRAN_COMMIT_CLASS_COMMIT_INSTANCE | A relatively low isolation level (2). A dirty read does not occur, but non-repeatable or phantom read may occur.
TRAN_REP_CLASS_UNCOMMIT_INSTANCE | The default isolation of CUBRID (3). A dirty, non-repeatable or phantom read may occur for the tuple, but repeatable read is ensured for the table.
TRAN_REP_CLASS_COMMIT_INSTANCE | A relatively low isolation level (4). A dirty read does not occur, but non-repeatable or phantom read may.
TRAN_REP_CLASS_REP_INSTANCE | A relatively high isolation level (5). A dirty or non-repeatable read does not occur, but a phantom read may.
TRAN_SERIALIZABLE | The highest isolation level (6). Problems concerning concurrency (e.g. dirty read, non-repeatable read, phantom read, etc.) do not occur.

The following constants can be used when getting schema information. They can be passed to cubrid_schema().

CUBRID schema flags
Constant | Description
CUBRID_SCH_CLASS | Get name and type of table in CUBRID.
CUBRID_SCH_VCLASS | Get name and type of view in CUBRID.
CUBRID_SCH_QUERY_SPEC | Get the query definition of view.
CUBRID_SCH_ATTRIBUTE | Get the attributes of table column.
CUBRID_SCH_CLASS_ATTRIBUTE | Get the attributes of table.
CUBRID_SCH_METHOD | Get the instance method. The instance method is a method called by a class instance. It is used more often than the class method because most operations are executed in the instance.
CUBRID_SCH_CLASS_METHOD | Get the class method. The class method is a method called by a class object. It is usually used to create a new class instance or to initialize it. It is also used to access or update class attributes.
CUBRID_SCH_METHOD_FILE | Get the information of the file where the method of the table is defined.
CUBRID_SCH_SUPERCLASS | Get the name and type of table which table inherites attributes from.
CUBRID_SCH_SUBCLASS | Get the name and type of table which inherites attributes from this table.
CUBRID_SCH_CONSTRAINT | Get the table constraints.
CUBRID_SCH_TRIGGER | Get the table triggers.
CUBRID_SCH_CLASS_PRIVILEGE | Get the privilege information of table.
CUBRID_SCH_ATTR_PRIVILEGE | Get the privilege information of column.
CUBRID_SCH_DIRECT_SUPER_CLASS | Get the direct super table of table.
CUBRID_SCH_PRIMARY_KEY | Get the table primary key.
CUBRID_SCH_IMPORTED_KEYS | Get imported keys of table.
CUBRID_SCH_EXPORTED_KEYS | Get exported keys of table.
CUBRID_SCH_CROSS_REFERENCE | Get reference relationship of tow tables.

The following constants can be used when reporting errors. They can be returned from cubrid_error_code_facility().

CUBRID error facility code
Constant | Description
CUBRID_FACILITY_DBMS | The error occurred in CUBRID dbms.
CUBRID_FACILITY_CAS | The error occurred in CUBRID broker cas.
CUBRID_FACILITY_CCI | The error occurred in CUBRID cci.
CUBRID_FACILITY_CLIENT | The error occurred in CUBRID PHP client.

Özkaynak Türleri
Örnekler
CUBRID


Örnekler

The following is a simple example that establishes a connection between PHP and CUBRID. This section will cover the most basic and notable features. The following code required to connect to CUBRID database, which means CUBRID Server and CUBRID Broker have to be running.

The example below uses the demodb database as an examples. By default it is created during the installation. Make sure it has been created.

Örnek 1 Example of Data Retrieval

<html>
    <head>
    <meta http-equiv="content-type" content="text/html; charset=euc-kr">
    </head>
    <body>
    <center>
    <table border=2>
    <?php
        /**
         * Set server information for CUBRID connection. host_ip is the IP
         * address where the CUBRID Broker is installed (localhost in this
         * example), and host_port is the port number of the CUBRID Broker.
         * The port number is the default given during the installation.
         * For details, see "Administrator's Guide."
         */
        $host_ip = "localhost";
        $host_port = 33000;
        $db_name = "demodb";
        /**
         * Connect to CUBRID Server. Do not make the actual connection, but
         * only retain the connection information. The reason for not making
         * the actual connection is to handle transaction more efficiently
         * in the 3-tier architecture.
         */
        $cubrid_con = @cubrid_connect($host_ip, $host_port, $db_name);

        if (!$cubrid_con) {
            echo "Database Connection Error";
            exit;
        }
    ?>
    <?php
        $sql = "select sports, count(players) as players from event group by sports";
        /**
         * Request the CUBRID Server for the results of the SQL statement.
         * Now make the actual connection to the CUBRID Server.
         */
        $result = cubrid_execute($cubrid_con, $sql);

        if ($result) {
            /**
             * Get the column names from the result set created by the SQL query.
             */
            $columns = cubrid_column_names($result);
            /**
             * Get the number of columns in the result set created by the SQL query.
             */
            $num_fields = cubrid_num_cols($result);
            /**
             * List the column names of the result set on the screen.
             */
            echo("<tr>");

            while (list($key, $colname) = each($columns)) {
                echo("<td align=center>$colname</td>");
            }

            echo("</tr>");

            /**
             * Get the results from the result set.
             */
            while ($row = cubrid_fetch($result)) {
                echo("<tr>");

                for ($i = 0; $i < $num_fields; $i++) {
                    echo("<td align=center>");
                    echo($row[$i]);
                    echo("</td>");
                }

                echo("</tr>");
            }
        }
        /**
         * The PHP module in the CUBRID runs in a 3-tier architecture. Even when
         * calling SELECT for transaction processing, it is processed as a part
         * of the transaction. Therefore, the transaction needs to be rolled back
         * by calling commit or rollback even though SELECT was called for smooth
         * performance.
         */
        cubrid_commit($cubrid_con);
        cubrid_disconnect($cubrid_con);
    ?>
    </body>
    </html>

Örnek 2 Example of Data Insertion

<html>
    <head>
    <meta http-equiv="content-type" content="text/html; charset=euc- kr">
    </head>
    <body>
    <center>
    <table border=2>
    <?php
        /**
         * host_ip is the IP address where the CUBRID Broker is installed
         * host_port is the port number of the CUBRID Broker
         * db_name is the name of CUBRID Database
         */
        $host_ip = "localhost";
        $host_port = 33000;
        $db_name = "demodb";
        $cubrid_con = @cubrid_connect($host_ip, $host_port, $db_name);

        if (!$cubrid_con) {
            echo "Database Connection Error";
            exit;
        }
    ?>
    <?php
        $sql = "insert into olympic (host_year,host_nation,host_city,"
            . "opening_date,closing_date) values (2008, 'China', 'Beijing',"
            . "to_date('08-08-2008','mm-dd- yyyy'),to_date('08-24-2008','mm-dd-yyyy')) ;"
        $result = cubrid_execute($cubrid_con, $sql);
        if ($result) {
            /**
             * Handled successfully, so commit.
             */
            cubrid_commit($cubrid_con);
            echo("Inserted successfully ");
        } else {
            /**
             * Error occurred, so the error message is output and rollback is called.
             */
            echo(cubrid_error_msg());
            cubrid_rollback($cubrid_con);
        }
        cubrid_disconnect($cubrid_con);
    ?>
    </body>
    </html>
Öntanımlı Sabitler
CUBRID İşlevleri
CUBRID


CUBRID İşlevleri

İçindekiler

  • cubrid_bind — Bind variables to a prepared statement as parameters
  • cubrid_close_prepare — Close the request handle
  • cubrid_close_request — Close the request handle
  • cubrid_col_get — Get contents of collection type column using OID
  • cubrid_col_size — Get the number of elements in collection type column using OID
  • cubrid_column_names — Get the column names in result
  • cubrid_column_types — Get column types in result
  • cubrid_commit — Commit a transaction
  • cubrid_connect_with_url — Establish the environment for connecting to CUBRID server
  • cubrid_connect — Open a connection to a CUBRID Server
  • cubrid_current_oid — Get OID of the current cursor location
  • cubrid_disconnect — Close a database connection
  • cubrid_drop — Delete an instance using OID
  • cubrid_error_code_facility — Get the facility code of error
  • cubrid_error_code — Get error code for the most recent function call
  • cubrid_error_msg — Get last error message for the most recent function call
  • cubrid_execute — Execute a prepared SQL statement
  • cubrid_fetch — Fetch the next row from a result set
  • cubrid_free_result — Free the memory occupied by the result data
  • cubrid_get_autocommit — Get auto-commit mode of the connection
  • cubrid_get_charset — Return the current CUBRID connection charset
  • cubrid_get_class_name — Get the class name using OID
  • cubrid_get_client_info — Return the client library version
  • cubrid_get_db_parameter — Returns the CUBRID database parameters
  • cubrid_get_query_timeout — Get the query timeout value of the request
  • cubrid_get_server_info — Return the CUBRID server version
  • cubrid_get — Get a column using OID
  • cubrid_insert_id — Return the ID generated for the last updated AUTO_INCREMENT column
  • cubrid_is_instance — Check whether the instance pointed by OID exists
  • cubrid_lob_close — Close BLOB/CLOB data
  • cubrid_lob_export — Export BLOB/CLOB data to file
  • cubrid_lob_get — Get BLOB/CLOB data
  • cubrid_lob_send — Read BLOB/CLOB data and send straight to browser
  • cubrid_lob_size — Get BLOB/CLOB data size
  • cubrid_lob2_bind — Bind a lob object or a string as a lob object to a prepared statement as parameters.
  • cubrid_lob2_close — Close LOB object.
  • cubrid_lob2_export — Export the lob object to a file.
  • cubrid_lob2_import — Import BLOB/CLOB data from a file.
  • cubrid_lob2_new — Create a lob object.
  • cubrid_lob2_read — Read from BLOB/CLOB data.
  • cubrid_lob2_seek64 — Move the cursor of a lob object.
  • cubrid_lob2_seek — Move the cursor of a lob object.
  • cubrid_lob2_size64 — Get a lob object's size.
  • cubrid_lob2_size — Get a lob object's size.
  • cubrid_lob2_tell64 — Tell the cursor position of the LOB object.
  • cubrid_lob2_tell — Tell the cursor position of the LOB object.
  • cubrid_lob2_write — Write to a lob object.
  • cubrid_lock_read — Set a read lock on the given OID
  • cubrid_lock_write — Set a write lock on the given OID
  • cubrid_move_cursor — Move the cursor in the result
  • cubrid_next_result — Get result of next query when executing multiple SQL statements
  • cubrid_num_cols — Return the number of columns in the result set
  • cubrid_num_rows — Get the number of rows in the result set
  • cubrid_pconnect_with_url — Open a persistent connection to CUBRID server
  • cubrid_pconnect — Open a persistent connection to a CUBRID server
  • cubrid_prepare — Prepare a SQL statement for execution
  • cubrid_put — Update a column using OID
  • cubrid_rollback — Roll back a transaction
  • cubrid_schema — Get the requested schema information
  • cubrid_seq_drop — Delete an element from sequence type column using OID
  • cubrid_seq_insert — Insert an element to a sequence type column using OID
  • cubrid_seq_put — Update the element value of sequence type column using OID
  • cubrid_set_add — Insert a single element to set type column using OID
  • cubrid_set_autocommit — Set autocommit mode of the connection
  • cubrid_set_db_parameter — Sets the CUBRID database parameters
  • cubrid_set_drop — Delete an element from set type column using OID
  • cubrid_set_query_timeout — Set the timeout time of query execution
  • cubrid_version — Get the CUBRID PHP module's version
Örnekler
cubrid_bind
CUBRID


Bind variables to a prepared statement as parameters

CUBRID İşlevleri
cubrid_close_prepare
CUBRID İşlevleri
PHP Manual

cubrid_bind

(PECL CUBRID >= 8.3.0)

cubrid_bind — Bind variables to a prepared statement as parameters

Açıklama

bool cubrid_bind ( resource $req_identifier , int $bind_index , mixed $bind_value [, string $bind_value_type ] )

The cubrid_bind() function is used to bind values to a corresponding named or question mark placeholder in the SQL statement that was passed to cubrid_prepare(). If bind_value_type is not given, string will be the default.

Bilginize:

If the type of data to be bound is BLOB/CLOB, CUBRID will try to map the data as a PHP stream. If the actually bind value type is not stream, CUBRID will convert it to string, and use it as the full path and file name of a file on the client filesystem.

If the type of data to be bound explicitly is ENUM, the $bind_value argument should be the enum element which is in string format.

In CUBRID shard envrioment, the $bind_value_type must be included in the cubrid_bind function.

The following table shows the types of substitute values.

CUBRID Bind Date Types
Support | Bind Type | Corresponding SQL Type
Supported | STRING | CHAR, VARCHAR
 | NCHAR | NCHAR, NVARCHAR
 | BIT | BIT, VARBIT
 | NUMERIC or NUMBER | SHORT, INT, NUMERIC
 | FLOAT | FLOAT
 | DOUBLE | DOUBLE
 | TIME | TIME
 | DATE | DATE
 | TIMESTAMP | TIMESTAMP
 | OBJECT | OBJECT
 | ENUM | ENUM
 | BLOB | BLOB
 | CLOB | CLOB
 | NULL | NULL
Not supported | SET | SET
 | MULTISET | MULTISET
 | SEQUENCE | SEQUENCE

Değiştirgeler

req_identifier

Request identifier as a result of cubrid_prepare().

bind_index

Location of binding parameters. It starts with 1.

bind_value

Actual value for binding.

bind_value_type

A type of the value to bind. (It is omitted by default. Thus, the system internally uses string by default. However, you need to specify the exact type of the value as an argument when they are NCHAR, BIT, or BLOB/CLOB).

Dönen Değerler

TRUE, when process is successful.

FALSE, when process is unsuccessful.

Sürüm Bilgisi

Sürüm: | Açıklama
8.3.1 | Added BLOB/CLOB data types support.

Örnekler

Örnek 1 cubrid_bind() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

$result = cubrid_execute($conn, "SELECT code FROM event WHERE sports='Basketball' and gender='M'");
$row = cubrid_fetch_array($result, CUBRID_ASSOC);
$event_code = $row["code"];

cubrid_close_request($result);

$game_req = cubrid_prepare($conn, "SELECT athlete_code FROM game WHERE host_year=1992 and event_code=? and nation_code='USA'");
cubrid_bind($game_req, 1, $event_code, "number");
cubrid_execute($game_req);

printf("--- Dream Team (1992 United States men's Olympic basketball team) ---\n");
while ($athlete_code = cubrid_fetch_array($game_req, CUBRID_NUM)) {
    $athlete_req = cubrid_prepare($conn, "SELECT name FROM athlete WHERE code=? AND nation_code='USA' AND event='Basketball' AND gender='M'");
    cubrid_bind($athlete_req, 1, $athlete_code[0], "number");
    cubrid_execute($athlete_req);
    $row = cubrid_fetch_assoc($athlete_req);
    printf("%s\n", $row["name"]);
}

cubrid_close_request($game_req);
cubrid_close_request($athlete_req);

cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

--- Dream Team (1992 United States men's Olympic basketball team) ---
Stockton John
Robinson David
Pippen Scottie
Mullin C.
Malone Karl
Laettner C.
Jordan Michael
Johnson Earvin
Ewing Patrick
Drexler Clyde
Bird Larry
Barkley Charles

Örnek 2 cubrid_bind() BLOB/CLOB example

<?php
$con = cubrid_connect("localhost", 33000, "demodb", "dba", "");
if ($con) {
    cubrid_execute($con,"DROP TABLE if exists php_cubrid_lob_test");
    cubrid_execute($con,"CREATE TABLE php_cubrid_lob_test (doc_content CLOB)");
    $sql = "INSERT INTO php_cubrid_lob_test(doc_content) VALUES(?)";
    $req = cubrid_prepare($con, $sql);

    $fp = fopen("book.txt", "rb");

    cubrid_bind($req, 1, $fp, "clob");
    cubrid_execute($req);
}
?>

Örnek 3 cubrid_bind() BLOB/CLOB example

<?php
$con = cubrid_connect("localhost", 33000, "demodb", "dba", "");
if ($con) {
    cubrid_execute($con,"DROP TABLE if exists php_cubrid_lob_test");
    cubrid_execute($con,"CREATE TABLE php_cubrid_lob_test (image BLOB)");
    $sql = "INSERT INTO php_cubrid_lob_test(image) VALUES(?)";
    $req = cubrid_prepare($con, $sql);

    cubrid_bind($req, 1, "cubrid_logo.png", "blob");
    cubrid_execute($req);
}
?>

Ayrıca Bakınız

  • cubrid_execute() - Execute a prepared SQL statement
  • cubrid_prepare() - Prepare a SQL statement for execution

CUBRID İşlevleri
cubrid_close_prepare
CUBRID İşlevleri


Close the request handle

cubrid_bind
cubrid_close_request
CUBRID İşlevleri
PHP Manual

cubrid_close_prepare

(PECL CUBRID >= 8.3.0)

cubrid_close_prepare — Close the request handle

Açıklama

bool cubrid_close_prepare ( resource $req_identifier )

The cubrid_close_prepare() function closes the request handle given by the req_identifier argument, and releases the memory region related to the handle. It is an alias of cubrid_close_request().

Değiştirgeler

req_identifier

Request identifier.

Dönen Değerler

Return TRUE on success.

Örnekler

Örnek 1 cubrid_close_prepare() example

<?php
$con = cubrid_connect ("localhost", 33000, "demodb", "dba", "");
if ($con) {
   echo "connected successfully";
   $req = cubrid_execute ( $con, "select * from members",
                           CUBRID_INCLUDE_OID | CUBRID_ASYNC);
   if ($req) {
      while ( list ($id, $name) = cubrid_fetch ($req) ){
         echo $id;
         echo $name;
      }
      cubrid_close_prepare($req); // or you can use cubrid_close_request($req)
   }
   cubrid_disconnect($con);
}
?>

Ayrıca Bakınız

  • cubrid_close_request() - Close the request handle

cubrid_bind
cubrid_close_request
CUBRID İşlevleri


Close the request handle

cubrid_close_prepare
cubrid_col_get
CUBRID İşlevleri
PHP Manual

cubrid_close_request

(PECL CUBRID >= 8.3.0)

cubrid_close_request — Close the request handle

Açıklama

bool cubrid_close_request ( resource $req_identifier )

The cubrid_close_request() function closes the request handle given by the req_identifier argument, and releases the memory region related to the handle. It is an alias of cubrid_close_prepare().

Değiştirgeler

req_identifier

Request identifier.

Dönen Değerler

Return TRUE on success.

Örnekler

Örnek 1 cubrid_close_request() example

<?php
$con = cubrid_connect ("localhost", 33000, "demodb", "dba", "");
if ($con) {
   echo "connected successfully";
   $req = cubrid_execute ( $con, "select * from members",
                           CUBRID_INCLUDE_OID | CUBRID_ASYNC);
   if ($req) {
      while ( list ($id, $name) = cubrid_fetch ($req) ){
         echo $id;
         echo $name;
      }
      cubrid_close_request($req); // or you can use cubrid_close_prepare($req)
   }
   cubrid_disconnect($con);
}
?>

Ayrıca Bakınız

  • cubrid_close_prepare() - Close the request handle

cubrid_close_prepare
cubrid_col_get
CUBRID İşlevleri


Get contents of collection type column using OID

cubrid_close_request
cubrid_col_size
CUBRID İşlevleri
PHP Manual

cubrid_col_get

(PECL CUBRID >= 8.3.0)

cubrid_col_get — Get contents of collection type column using OID

Açıklama

array cubrid_col_get ( resource $conn_identifier , string $oid , string $attr_name )

The cubrid_col_get() function is used to get contents of the elements of the collection type (set, multiset, sequence) attribute you requested as an array.

Değiştirgeler

conn_identifier

Connection identifier.

oid

OID of the instance that you want to read.

attr_name

Attribute name that you want to read from the instance.

Dönen Değerler

Array (0-based numerical array) containing the elements you requested, when process is successful;

FALSE (to distinguish the error from the situation of attribute having empty collection or NULL, in case of error, a warning message is shown; in such case you can check the error by using cubrid_error_code()), when process is unsuccessful.

Örnekler

Örnek 1 cubrid_col_get() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

@cubrid_execute($conn, "DROP TABLE foo");
cubrid_execute($conn, "CREATE TABLE foo(a int AUTO_INCREMENT, b set(int), c list(int), d char(10))");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(1, {1,2,3}, {11,22,33,333}, 'a')");

$req = cubrid_execute($conn, "SELECT * FROM foo", CUBRID_INCLUDE_OID);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);
$oid = cubrid_current_oid($req);

$attr = cubrid_col_get($conn, $oid, "b");
var_dump($attr);

$size = cubrid_col_size($conn, $oid, "b");
var_dump($size);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

array(3) {
  [0]=>
  string(1) "1"
  [1]=>
  string(1) "2"
  [2]=>
  string(1) "3"
}
int(3)
cubrid_close_request
cubrid_col_size
CUBRID İşlevleri


Get the number of elements in collection type column using OID

cubrid_col_get
cubrid_column_names
CUBRID İşlevleri
PHP Manual

cubrid_col_size

(PECL CUBRID >= 8.3.0)

cubrid_col_size — Get the number of elements in collection type column using OID

Açıklama

int cubrid_col_size ( resource $conn_identifier , string $oid , string $attr_name )

The cubrid_col_size() function is used to get the number of elements in a collection type (set, multiset, sequence) attribute.

Değiştirgeler

conn_identifier

Connection identifier.

oid

OID the instance that you want to work with.

attr_name

Name of the attribute that you want to work with.

Dönen Değerler

Number of elements, when process is successful.

FALSE, when process is unsuccessful.

Sürüm Bilgisi

Sürüm: | Açıklama
8.3.1 | Change return value: when process is unsuccessful, return false, not -1.

Örnekler

Örnek 1 cubrid_col_size() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

@cubrid_execute($conn, "DROP TABLE foo");
cubrid_execute($conn, "CREATE TABLE foo(a int AUTO_INCREMENT, b set(int), c list(int), d char(10))");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(1, {1,2,3}, {11,22,33,333}, 'a')");

$req = cubrid_execute($conn, "SELECT * FROM foo", CUBRID_INCLUDE_OID);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);
$oid = cubrid_current_oid($req);

$attr = cubrid_col_get($conn, $oid, "b");
var_dump($attr);

$size = cubrid_col_size($conn, $oid, "b");
var_dump($size);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

array(3) {
  [0]=>
  string(1) "1"
  [1]=>
  string(1) "2"
  [2]=>
  string(1) "3"
}
int(3)
cubrid_col_get
cubrid_column_names
CUBRID İşlevleri


Get the column names in result

cubrid_col_size
cubrid_column_types
CUBRID İşlevleri
PHP Manual

cubrid_column_names

(PECL CUBRID >= 8.3.0)

cubrid_column_names — Get the column names in result

Açıklama

array cubrid_column_names ( resource $req_identifier )

The cubrid_column_names() function is used to get the column names of the query result by using req_identifier.

Değiştirgeler

req_identifier

Request identifier.

Dönen Değerler

Array of string values containing the column names, when process is successful.

FALSE, when process is unsuccessful.

Örnekler

Örnek 1 cubrid_column_names() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");
$result = cubrid_execute($conn, "SELECT * FROM game WHERE host_year=2004 AND nation_code='AUS' AND medal='G'");

$column_names = cubrid_column_names($result);
$column_types = cubrid_column_types($result);

printf("%-30s %-30s %-15s\n", "Column Names", "Column Types", "Column Maxlen");
for($i = 0, $size = count($column_names); $i < $size; $i++) {
    $column_len = cubrid_field_len($result, $i);
    printf("%-30s %-30s %-15s\n", $column_names[$i], $column_types[$i], $column_len);
}

cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

Column Names                   Column Types                   Column Maxlen
host_year                      integer                        11
event_code                     integer                        11
athlete_code                   integer                        11
stadium_code                   integer                        11
nation_code                    char                           3
medal                          char                           1
game_date                      date                           10

Ayrıca Bakınız

  • cubrid_prepare() - Prepare a SQL statement for execution
  • cubrid_execute() - Execute a prepared SQL statement
  • cubrid_column_types() - Get column types in result

cubrid_col_size
cubrid_column_types
CUBRID İşlevleri


Get column types in result

cubrid_column_names
cubrid_commit
CUBRID İşlevleri
PHP Manual

cubrid_column_types

(PECL CUBRID >= 8.3.0)

cubrid_column_types — Get column types in result

Açıklama

array cubrid_column_types ( resource $req_identifier )

The cubrid_column_types() function gets column types of query results by using req_identifier.

Değiştirgeler

req_identifier

Request identifier.

Dönen Değerler

Array of string values containing the column types, when process is successful.

FALSE, when process is unsuccessful.

Örnekler

Örnek 1 cubrid_column_types() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");
$result = cubrid_execute($conn, "SELECT * FROM game WHERE host_year=2004 AND nation_code='AUS' AND medal='G'");

$column_names = cubrid_column_names($result);
$column_types = cubrid_column_types($result);

printf("%-30s %-30s %-15s\n", "Column Names", "Column Types", "Column Maxlen");
for($i = 0, $size = count($column_names); $i < $size; $i++) {
    $column_len = cubrid_field_len($result, $i);
    printf("%-30s %-30s %-15s\n", $column_names[$i], $column_types[$i], $column_len);
}

cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

Column Names                   Column Types                   Column Maxlen
host_year                      integer                        11
event_code                     integer                        11
athlete_code                   integer                        11
stadium_code                   integer                        11
nation_code                    char                           3
medal                          char                           1
game_date                      date                           10

Ayrıca Bakınız

  • cubrid_column_names() - Get the column names in result
  • cubrid_prepare() - Prepare a SQL statement for execution
  • cubrid_execute() - Execute a prepared SQL statement

cubrid_column_names
cubrid_commit
CUBRID İşlevleri


Commit a transaction

cubrid_column_types
cubrid_connect_with_url
CUBRID İşlevleri
PHP Manual

cubrid_commit

(PECL CUBRID >= 8.3.0)

cubrid_commit — Commit a transaction

Açıklama

bool cubrid_commit ( resource $conn_identifier )

The cubrid_commit() function is used to execute commit on the transaction pointed by conn_identifier, currently in progress. Connection to the server is closed after the cubrid_commit() function is called; However, the connection handle is still valid.

In CUBRID PHP, auto-commit mode is disabled by default for transaction management. You can set it by using cubrid_set_autocommit(). You can get its status by using cubrid_get_autocommit(). Before you start a transaction, remember to disable the auto-commit mode.

Değiştirgeler

conn_identifier

Connection identifier.

Dönen Değerler

TRUE, when process is successful.

FALSE, when process is unsuccessful.

Örnekler

Örnek 1 cubrid_commit() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

@cubrid_execute($conn, "DROP TABLE publishers");

$sql = <<<EOD
CREATE TABLE publishers(
pub_id CHAR(3),
pub_name VARCHAR(20),
city VARCHAR(15),
state CHAR(2),
country VARCHAR(15)
)
EOD;
cubrid_set_autocommit($conn,false);
if (!cubrid_execute($conn, $sql)) {
    printf("Error facility: %d\nError code: %d\nError msg: %s\n", cubrid_error_code_facility(), cubrid_error_code(), cubrid_error_msg());

    cubrid_disconnect($conn);
    exit;
}

$req = cubrid_prepare($conn, "INSERT INTO publishers VALUES(?, ?, ?, ?, ?)");

$id_list = array("P01", "P02", "P03", "P04");
$name_list = array("Abatis Publishers", "Core Dump Books", "Schadenfreude Press", "Tenterhooks Press");
$city_list = array("New York", "San Francisco", "Hamburg", "Berkeley");
$state_list = array("NY", "CA", NULL, "CA");
$country_list = array("USA", "USA", "Germany", "USA");

for ($i = 0, $size = count($id_list); $i < $size; $i++) {
    cubrid_bind($req, 1, $id_list[$i]);
    cubrid_bind($req, 2, $name_list[$i]);
    cubrid_bind($req, 3, $city_list[$i]);
    cubrid_bind($req, 4, $state_list[$i]);
    cubrid_bind($req, 5, $country_list[$i]);

    if (!($ret = cubrid_execute($req))) {
        break;
    }
}

if (!$ret) {
    cubrid_rollback($conn);
} else {
    cubrid_commit($conn);

    $req = cubrid_execute($conn, "SELECT * FROM publishers");
    while ($result = cubrid_fetch_assoc($req)) {
        printf("%-3s %-20s %-15s %-3s %-15s\n",
            $result["pub_id"], $result["pub_name"], $result["city"], $result["state"], $result["country"]);
    }
}

cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

P01 Abatis Publishers    New York        NY  USA
P02 Core Dump Books      San Francisco   CA  USA
P03 Schadenfreude Press  Hamburg             Germany
P04 Tenterhooks Press    Berkeley        CA  USA

Ayrıca Bakınız

  • cubrid_rollback() - Roll back a transaction
  • cubrid_get_autocommit() - Get auto-commit mode of the connection
  • cubrid_set_autocommit() - Set autocommit mode of the connection

cubrid_column_types
cubrid_connect_with_url
CUBRID İşlevleri


Establish the environment for connecting to CUBRID server

cubrid_commit
cubrid_connect
CUBRID İşlevleri
PHP Manual

cubrid_connect_with_url

(PECL CUBRID >= 8.3.1)

cubrid_connect_with_url — Establish the environment for connecting to CUBRID server

Açıklama

resource cubrid_connect_with_url ( string $conn_url [, string $userid [, string $passwd [, bool $new_link = false ]]] )

The cubrid_connect_with_url() function is used to establish the environment for connecting to your server by using connection information passed with an url string argument. If the HA feature is enabled in CUBRID, you must specify the connection information of the standby server, which is used for failover when failure occurs, in the url string argument of this function. If the user name and password is not given, then the "PUBLIC" connection will be made by default.

<url> ::= CUBRID:<host>:<db_name>:<db_user>:<db_password>:[?<properties>]

<properties> ::= <property> [&<property>]

<properties> ::= alhosts=<alternative_hosts>[ &rctime=<time>]

<properties> ::= login_timeout=<milli_sec>

<properties> ::= query_timeout=<milli_sec>

<properties> ::= disconnect_on_query_timeout=true|false

<alternative_hosts> ::= <standby_broker1_host>:<port> [,<standby_broker2_host>:<port>]

<host> := HOSTNAME | IP_ADDR

<time> := SECOND

<milli_sec> := MILLI SECOND

  • host : A host name or IP address of the master database
  • db_name : A name of the database
  • db_user : A name of the database user
  • db_password : A database user password
  • alhosts : Specifies the broker information of the standby server, which is used for failover when it is impossible to connect to the active server. You can specify multiple brokers for failover, and the connection to the brokers is attempted in the order listed in alhosts
  • rctime : An interval between the attempts to connect to the active broker in which failure occurred. After a failure occurs, the system connects to the broker specified by althosts (failover), terminates the transaction, and then attempts to connect to the active broker of the master database at every rctime. The default value is 600 seconds.
  • login_timeout : Timeout value (unit: msec.) for database login. The default value is 0, which means infinite postponement.
  • query_timeout : Timeout value (unit: msec.) for query request. Upon timeout, a message to cancel requesting a query transferred to server is sent. The return value can depend on the disconnect_on_query_timeout configuration; even though the message to cancel a request is sent to server, that request may succeed.
  • disconnect_on_query_timeout : Configures a value whether to immediately return an error of function being executed upon timeout. The default value is false.

Bilginize:

? and : that are used as identifiers in PHP connection URL can't be included in the password. The following is an example of a password that is invalid to use as connection URL because it contains "?:".

$url = "CUBRID:localhost:33000:tdb:dba:12?:?login_timeout=100";

Passwords that contain ? or : may be passed as a separate parameter.

$url = "CUBRID:localhost:33000:tbd:::?login_timeout=100";

$conn = cubrid_connect_with_url($url, "dba", "12?");

If user or password is empty,you can't delete ":",the following is an example.

$url = "CUBRID:localhost:33000:demodb:::";

Değiştirgeler

conn_url

A character string that contains server connection information.

userid

User name for the database.

passwd

User password.

new_link

If a second call is made to cubrid_connect_with_url() with the same arguments, no new connection will be established, but instead, the connection identifier of the already opened connection will be returned. The new_link parameter modifies this behavior and makes cubrid_connect_with_url() always open a new connection, even if cubrid_connect_with_url() was called before with the same parameters.

Dönen Değerler

Connection identifier, when process is successful.

FALSE, when process is unsuccessful.

Örnekler

Örnek 1 cubrid_connect_with_url() url without properties example

<?php
$conn_url = "CUBRID:localhost:33000:demodb:dba::";
$con = cubrid_connect_with_url($conn_url);

if ($con) {
   echo "connected successfully";
   cubrid_execute($con, "create table person(id int,name char(16))");
   $req =cubrid_execute($con, "insert into person values(1,'James')");

   if ($req) {
      cubrid_close_request($req);
      cubrid_commit($con);
   } else {
      cubrid_rollback($con);
   }
   cubrid_disconnect($con);
}
?>

Örnek 2 cubrid_connect_with_url() url with properties example

<?php
$conn_url = "CUBRID:127.0.0.1:33000:demodb:dba::?login_timeout=100"
$con = cubrid_connect_with_url ($conn_url);

if ($con) {
   echo "connected successfully";
   cubrid_execute($con, "create table person(id int,name char(16))");
   $req =cubrid_execute($con, "insert into person values(1,'James')");

   if ($req) {
      cubrid_close_request($req);
      cubrid_commit($con);
   } else {
      cubrid_rollback($con);
   }
   cubrid_disconnect($con);
}
?>

Ayrıca Bakınız

  • cubrid_connect() - Open a connection to a CUBRID Server
  • cubrid_pconnect() - Open a persistent connection to a CUBRID server
  • cubrid_pconnect_with_url() - Open a persistent connection to CUBRID server
  • cubrid_disconnect() - Close a database connection
  • cubrid_close() - Close CUBRID connection

cubrid_commit
cubrid_connect
CUBRID İşlevleri


Open a connection to a CUBRID Server

cubrid_connect_with_url
cubrid_current_oid
CUBRID İşlevleri
PHP Manual

cubrid_connect

(PECL CUBRID >= 8.3.1)

cubrid_connect — Open a connection to a CUBRID Server

Açıklama

resource cubrid_connect ( string $host , int $port , string $dbname [, string $userid [, string $passwd [, bool $new_link = false ]]] )

The cubrid_connect() function is used to establish the environment for connecting to your server by using your server address, port number, database name, user name, and password. If the user name and password is not given, then the "PUBLIC" connection will be made by default.

Değiştirgeler

host

Host name or IP address of CUBRID CAS server.

port

Port number of CUBRID CAS server (BROKER_PORT configured in $CUBRID/conf/cubrid_broker.conf).

dbname

Name of database.

userid

User name for the database. If not given, the default value is "public".

passwd

User password. If not given, the default value is "".

new_link

If a second call is made to cubrid_connect() with the same arguments, no new connection will be established, but instead, the connection identifier of the already opened connection will be returned. The new_link parameter modifies this behavior and makes cubrid_connect() always open a new connection, even if cubrid_connect() was called before with the same parameters.

Dönen Değerler

Connection identifier, when process is successful.

FALSE, when process is unsuccessful.

Örnekler

Örnek 1 cubrid_connect() example

<?php
printf("%-30s %s\n", "CUBRID PHP Version:", cubrid_version());

printf("\n");

$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

if (!$conn) {
    die('Connect Error ('. cubrid_error_code() .')' . cubrid_error_msg());
}

$db_params = cubrid_get_db_parameter($conn);

while (list($param_name, $param_value) = each($db_params)) {
    printf("%-30s %s\n", $param_name, $param_value);
}

printf("\n");

$server_info = cubrid_get_server_info($conn);
$client_info = cubrid_get_client_info();

printf("%-30s %s\n", "Server Info:", $server_info);
printf("%-30s %s\n", "Client Info:", $client_info);

printf("\n");

$charset = cubrid_get_charset($conn);

printf("%-30s %s\n", "CUBRID Charset:", $charset);

cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

CUBRID PHP Version:            9.1.0.0001

PARAM_ISOLATION_LEVEL          3
LOCK_TIMEOUT                   -1
MAX_STRING_LENGTH              1073741823
PARAM_AUTO_COMMIT              1

Server Info:                   9.1.0.0212
Client Info:                   9.1.0

CUBRID Charset:                iso8859-1

Ayrıca Bakınız

  • cubrid_pconnect() - Open a persistent connection to a CUBRID server
  • cubrid_connect_with_url() - Establish the environment for connecting to CUBRID server
  • cubrid_pconnect_with_url() - Open a persistent connection to CUBRID server
  • cubrid_disconnect() - Close a database connection
  • cubrid_close() - Close CUBRID connection

cubrid_connect_with_url
cubrid_current_oid
CUBRID İşlevleri


Get OID of the current cursor location

cubrid_connect
cubrid_disconnect
CUBRID İşlevleri
PHP Manual

cubrid_current_oid

(PECL CUBRID >= 8.3.0)

cubrid_current_oid — Get OID of the current cursor location

Açıklama

string cubrid_current_oid ( resource $req_identifier )

The cubrid_current_oid() function is used to get the oid of the current cursor location from the query result. To use cubrid_current_oid(), the query executed must be a updatable query, and the CUBRID_INCLUDE_OID option must be included during the query execution.

Değiştirgeler

req_identifier

Request identifier.

Dönen Değerler

Oid of current cursor location, when process is successful

FALSE, when process is unsuccessful.

Örnekler

Örnek 1 cubrid_current_oid() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

$req = cubrid_execute($conn, "SELECT * FROM code", CUBRID_INCLUDE_OID);
$oid = cubrid_current_oid($req);
$res = cubrid_get($conn, $oid);

print_r($res);

cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [s_name] => X
    [f_name] => Mixed
)

Ayrıca Bakınız

  • cubrid_execute() - Execute a prepared SQL statement

cubrid_connect
cubrid_disconnect
CUBRID İşlevleri


Close a database connection

cubrid_current_oid
cubrid_drop
CUBRID İşlevleri
PHP Manual

cubrid_disconnect

(PECL CUBRID >= 8.3.0)

cubrid_disconnect — Close a database connection

Açıklama

bool cubrid_disconnect ([ resource $conn_identifier ] )

The cubrid_disconnect() function closes the connection handle and disconnects from server. If any request handle is not closed at this point, it will be closed. It is similar to the CUBRID MySQL compatible function cubrid_close().

Değiştirgeler

conn_identifier

Connection identifier.

Dönen Değerler

TRUE, when process is successful.

FALSE, when process is unsuccessful.

Örnekler

Örnek 1 cubrid_disconnect() example

<?php
$con = cubrid_connect ("localhost", 33000, "demodb");
if ($con) {
   echo "connected successfully";

   $req = cubrid_execute( $con, "create table person(id int,name char(10))");
   if ($req) {
      cubrid_close_request($req);
      cubrid_commit($con);
   } else {
      cubrid_rollback($con);
   }

   $req = cubrid_execute( $con, "insert into person values(1,'James')");
   if ($req) {
      cubrid_close_request($req);
      cubrid_commit($con);
   } else {
      cubrid_rollback($con);
   }
   cubrid_disconnect($con);
}
?>

Ayrıca Bakınız

  • cubrid_close() - Close CUBRID connection
  • cubrid_connect() - Open a connection to a CUBRID Server
  • cubrid_connect_with_url() - Establish the environment for connecting to CUBRID server

cubrid_current_oid
cubrid_drop
CUBRID İşlevleri


Delete an instance using OID

cubrid_disconnect
cubrid_error_code_facility
CUBRID İşlevleri
PHP Manual

cubrid_drop

(PECL CUBRID >= 8.3.0)

cubrid_drop — Delete an instance using OID

Açıklama

bool cubrid_drop ( resource $conn_identifier , string $oid )

The cubrid_drop() function is used to delete an instance from database by using the oid of the instance.

Değiştirgeler

conn_identifier

Connection identifier.

oid

Oid of the instance that you want to delete.

Dönen Değerler

TRUE, when process is successful.

FALSE, when process is unsuccessful.

Örnekler

Örnek 1 cubrid_drop() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");

@cubrid_execute($conn, "DROP TABLE foo");
cubrid_execute($conn, "CREATE TABLE foo(a int AUTO_INCREMENT, b set(int), c list(int), d char(10))");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(1, {1,2,3}, {11,22,33,333}, 'a')");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(2, {4,5,7}, {44,55,66,666}, 'b')");

$req = cubrid_execute($conn, "SELECT * FROM foo", CUBRID_INCLUDE_OID);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);
$oid = cubrid_current_oid($req);

printf("--- Before Drop: ---\n");
$attr = cubrid_get($conn, $oid);
var_dump($attr);

if (cubrid_drop($conn, $oid)) {
    cubrid_commit($conn);
} else {
    cubrid_rollback($conn);
}

cubrid_close_request($req);

$req = cubrid_execute($conn, "SELECT * FROM foo", CUBRID_INCLUDE_OID);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);
$oid = cubrid_current_oid($req);

printf("\n--- After Drop: ---\n");
$attr = cubrid_get($conn, $oid);
var_dump($attr);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

--- Before Drop: ---
array(4) {
  ["a"]=>
  string(1) "1"
  ["b"]=>
  array(3) {
    [0]=>
    string(1) "1"
    [1]=>
    string(1) "2"
    [2]=>
    string(1) "3"
  }
  ["c"]=>
  array(4) {
    [0]=>
    string(2) "11"
    [1]=>
    string(2) "22"
    [2]=>
    string(2) "33"
    [3]=>
    string(3) "333"
  }
  ["d"]=>
  string(10) "a         "
}

--- After Drop: ---
array(4) {
  ["a"]=>
  string(1) "2"
  ["b"]=>
  array(3) {
    [0]=>
    string(1) "4"
    [1]=>
    string(1) "5"
    [2]=>
    string(1) "7"
  }
  ["c"]=>
  array(4) {
    [0]=>
    string(2) "44"
    [1]=>
    string(2) "55"
    [2]=>
    string(2) "66"
    [3]=>
    string(3) "666"
  }
  ["d"]=>
  string(10) "b         "
}

Ayrıca Bakınız

  • cubrid_is_instance() - Check whether the instance pointed by OID exists

cubrid_disconnect
cubrid_error_code_facility
CUBRID İşlevleri


Get the facility code of error

cubrid_drop
cubrid_error_code
CUBRID İşlevleri
PHP Manual

cubrid_error_code_facility

(PECL CUBRID >= 8.3.0)

cubrid_error_code_facility — Get the facility code of error

Açıklama

int cubrid_error_code_facility ( void )

The cubrid_error_code_facility() function is used to get the facility code (level in which the error occurred) from the error code of the error that occurred during the API execution. Usually, you can get the error code when API returns false as its return value.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Facility code of the error code that occurred: CUBRID_FACILITY_DBMS, CUBRID_FACILITY_CAS, CUBRID_FACILITY_CCI, CUBRID_FACILITY_CLIENT

Örnekler

Örnek 1 cubrid_error_code_facility() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");
$req = @cubrid_execute($conn, "SELECT * FROM unknown");
if (!$req) {
    printf("Error facility: %d\nError code: %d\nError msg: %s\n",
        cubrid_error_code_facility(), cubrid_error_code(), cubrid_error_msg());

    cubrid_disconnect($conn);
    exit;
}
?>

Yukarıdaki örneğin çıktısı:

Error facility: 1
Error code: -493
Error msg: Syntax: In line 1, column 15 before END OF STATEMENT
Syntax error: unexpected 'unknown'

Ayrıca Bakınız

  • cubrid_error_code() - Get error code for the most recent function call
  • cubrid_error_msg() - Get last error message for the most recent function call

cubrid_drop
cubrid_error_code
CUBRID İşlevleri


Get error code for the most recent function call

cubrid_error_code_facility
cubrid_error_msg
CUBRID İşlevleri
PHP Manual

cubrid_error_code

(PECL CUBRID >= 8.3.0)

cubrid_error_code — Get error code for the most recent function call

Açıklama

int cubrid_error_code ( void )

The cubrid_error_code() function is used to get the error code of the error that occurred during the API execution. Usually, it gets the error code when API returns false as its return value.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Error code of the error that occurred, or 0 (zero) if no error occurred.

Örnekler

Örnek 1 cubrid_error_code() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");
$req = cubrid_prepare($conn , "SELECT * FROM code WHERE s_name=?");

$req = @cubrid_execute($req);
if (!$req) {
    printf("Error facility: %d\nError code: %d\nError msg: %s\n",
        cubrid_error_code_facility(), cubrid_error_code(), cubrid_error_msg());

    cubrid_disconnect($conn);
    exit;
}
?>

Yukarıdaki örneğin çıktısı:

Error facility: 4
Error code: -30015
Error msg: Some parameter not binded

Ayrıca Bakınız

  • cubrid_error_code_facility() - Get the facility code of error
  • cubrid_error_msg() - Get last error message for the most recent function call

cubrid_error_code_facility
cubrid_error_msg
CUBRID İşlevleri


Get last error message for the most recent function call

cubrid_error_code
cubrid_execute
CUBRID İşlevleri
PHP Manual

cubrid_error_msg

(PECL CUBRID >= 8.3.0)

cubrid_error_msg — Get last error message for the most recent function call

Açıklama

string cubrid_error_msg ( void )

The cubrid_error_msg() function is used to get the error message that occurred during the use of CUBRID API. Usually, it gets error message when API returns false as its return value.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Error message that occurred.

Örnekler

Örnek 1 cubrid_error_msg() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");

if (!@cubrid_schema($conn, 100000)) {
    printf("Error facility: %d\nError code: %d\nError msg: %s\n",
        cubrid_error_code_facility(), cubrid_error_code(), cubrid_error_msg());

    cubrid_disconnect($conn);
    exit;
}
?>

Yukarıdaki örneğin çıktısı:

Error facility: 2
Error code: -10015
Error msg: Invalid T_CCI_SCH_TYPE value

Ayrıca Bakınız

  • cubrid_error_code() - Get error code for the most recent function call
  • cubrid_error_code_facility() - Get the facility code of error

cubrid_error_code
cubrid_execute
CUBRID İşlevleri


Execute a prepared SQL statement

cubrid_error_msg
cubrid_fetch
CUBRID İşlevleri
PHP Manual

cubrid_execute

(PECL CUBRID >= 8.3.0)

cubrid_execute — Execute a prepared SQL statement

Açıklama

resource cubrid_execute ( resource $conn_identifier , string $sql [, int $option ] )
bool cubrid_execute ( resource $request_identifier [, int $option ] )

The cubrid_execute() function is used to execute the given SQL statement. It executes the query by using conn_identifier and SQL, and then returns the request identifier created. It is used for simple execution of query, where the parameter binding is not needed. In addition, the cubrid_execute() function is used to execute the prepared statement by means of cubrid_prepare() and cubrid_bind(). At this time, you need to specify arguments of request_identifier and option.

The option is used to determine whether to get OID after query execution and whether to execute the query in synchronous or asynchronous mode. CUBRID_INCLUDE_OID and CUBRID_ASYNC (or CUBRID_EXEC_QUERY_ALL if you want to execute multiple SQL statements) can be specified by using a bitwise OR operator. If not specified, neither of them isselected. If the flag CUBRID_EXEC_QUERY_ALL is set, a synchronous mode (sync_mode) is used to retrieve query results, and in such cases the following rules are applied:

  • The return value is the result of the first query.
  • If an error occurs in any query, the execution is processed as a failure.
  • In a query composed of q1 q2 q3, if an error occurs in q2 after q1 succeeds the execution, the result of q1 remains valid. That is, the previous successful query executions are not rolled back when an error occurs.
  • If a query is executed successfully, the result of the second query can be obtained using cubrid_next_result().

If the first argument is request_identifier to execute the cubrid_prepare() function, you can specify an option, CUBRID_ASYNC only.

Değiştirgeler

conn_identifier

Connection identifier.

sql

SQL to be executed.

option

Query execution option CUBRID_INCLUDE_OID, CUBRID_ASYNC, CUBRID_EXEC_QUERY_ALL.

request_identifier

cubrid_prepare() identifier.

Dönen Değerler

Request identifier, when process is successful and first param is conn_identifier; TRUE, when process is successful and first argument is request_identifier.

FALSE, when process is unsuccessful.

Sürüm Bilgisi

Sürüm: | Açıklama
8.4.0 | Add new option CUBRID_EXEC_QUERY_ALL.

Örnekler

Örnek 1 cubrid_execute() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");

$result = cubrid_execute($conn, "SELECT code FROM event WHERE name='100m Butterfly' and gender='M'", CUBRID_ASYNC);
$row = cubrid_fetch_array($result, CUBRID_ASSOC);
$event_code = $row["code"];

cubrid_close_request($result);

$history_req = cubrid_prepare($conn, "SELECT * FROM history WHERE event_code=?");
cubrid_bind($history_req, 1, $event_code, "number");
cubrid_execute($history_req);

printf("%-20s %-9s %-10s %-5s\n", "athlete", "host_year", "score", "unit");
while ($row = cubrid_fetch_array($history_req, CUBRID_ASSOC)) {
    printf("%-20s %-9s %-10s %-5s\n",
        $row["athlete"], $row["host_year"], $row["score"], $row["unit"]);
}

cubrid_close_request($history_req);

cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

athlete              host_year score      unit
Phelps Michael       2004      51.25      time

Ayrıca Bakınız

  • cubrid_prepare() - Prepare a SQL statement for execution
  • cubrid_bind() - Bind variables to a prepared statement as parameters
  • cubrid_next_result() - Get result of next query when executing multiple SQL statements
  • cubrid_close_request() - Close the request handle
  • cubrid_commit() - Commit a transaction
  • cubrid_rollback() - Roll back a transaction

cubrid_error_msg
cubrid_fetch
CUBRID İşlevleri


Fetch the next row from a result set

cubrid_execute
cubrid_free_result
CUBRID İşlevleri
PHP Manual

cubrid_fetch

(PECL CUBRID >= 8.3.0)

cubrid_fetch — Fetch the next row from a result set

Açıklama

mixed cubrid_fetch ( resource $result [, int $type = CUBRID_BOTH ] )

The cubrid_fetch() function is used to get a single row from the query result. The cursor automatically moves to the next row after getting the result.

Değiştirgeler

result

result comes from a call to cubrid_execute()

type

Array type of the fetched result CUBRID_NUM, CUBRID_ASSOC, CUBRID_BOTH, CUBRID_OBJECT. If you want to operate the lob object, you can use CUBRID_LOB.

Dönen Değerler

Result array or object, when process is successful.

FALSE, when there are no more rows; NULL, when process is unsuccessful.

The result can be received either as an array or as an object, and you can decide which data type to use by setting the type argument. The type variable can be set to one of the following values:

  • CUBRID_NUM : Numerical array (0-based)
  • CUBRID_ASSOC : Associative array
  • CUBRID_BOTH : Numerical & Associative array (default)
  • CUBRID_OBJECT : object that has the attribute name as the column name of query result

When type argument is omitted, the result will be received using CUBRID_BOTH option as default. When you want to receive query result in object data type, the column name of the result must obey the naming rules for identifiers in PHP. For example, column name such as "count(*)" cannot be received in object type.

Örnekler

Örnek 1 cubrid_fetch() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");
$req = cubrid_execute($conn, "SELECT * FROM stadium WHERE nation_code='GRE' AND seats > 10000");

printf("%-40s %-10s %-6s %-20s\n", "name", "area", "seats", "address");
while ($row = cubrid_fetch($req)) {
    printf("%-40s %-10s %-6s %-20s\n",
        $row["name"], $row["area"], $row["seats"], $row["address"]);
}

// if you want to operate lob object, you can use cubrid_fetch($req, CUBRID_LOB)

cubrid_close_request($req);

cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

name                                     area       seats  address
Panathinaiko Stadium                     86300.00   50000  Athens, Greece
Olympic Stadium                          54700.00   13000  Athens, Greece
Olympic Indoor Hall                      34100.00   18800  Athens, Greece
Olympic Hall                             52400.00   21000  Athens, Greece
Olympic Aquatic Centre                   42500.00   11500  Athens, Greece
Markopoulo Olympic Equestrian Centre     64000.00   15000  Markopoulo, Athens, Greece
Faliro Coastal Zone Olympic Complex      34650.00   12171  Faliro, Athens, Greece
Athens Olympic Stadium                   120400.00  71030  Maroussi, Athens, Greece
Ano Liossia                              34000.00   12000  Ano Liosia, Athens, Greece

Ayrıca Bakınız

  • cubrid_execute() - Execute a prepared SQL statement
  • cubrid_fetch_array() - Fetch a result row as an associative array, a numeric array, or both
  • cubrid_fetch_row() - Return a numerical array with the values of the current row
  • cubrid_fetch_assoc() - Return the associative array that corresponds to the fetched row
  • cubrid_fetch_object() - Fetch the next row and return it as an object

cubrid_execute
cubrid_free_result
CUBRID İşlevleri


Free the memory occupied by the result data

cubrid_fetch
cubrid_get_autocommit
CUBRID İşlevleri
PHP Manual

cubrid_free_result

(PECL CUBRID >= 8.3.0)

cubrid_free_result — Free the memory occupied by the result data

Açıklama

bool cubrid_free_result ( resource $req_identifier )

This function frees the memory occupied by the result data. It returns TRUE on success or FALSE on failure. Note that it can only frees the client fetch buffer now, and if you want free all memory, use function cubrid_close_request().

Değiştirgeler

req_identifier

This is the request identifier.

Dönen Değerler

TRUE on success.

FALSE on failure.

Örnekler

Örnek 1 cubrid_free_result() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");

$req = cubrid_execute($conn, "SELECT * FROM history WHERE host_year=2004 ORDER BY event_code");
$row = cubrid_fetch_assoc($req);
var_dump($row);

cubrid_free_result($req);
cubrid_close_request($req);
cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

array(5) {
  ["event_code"]=>
  string(5) "20005"
  ["athlete"]=>
  string(12) "Hayes Joanna"
  ["host_year"]=>
  string(4) "2004"
  ["score"]=>
  string(5) "12.37"
  ["unit"]=>
  string(4) "time"
}
cubrid_fetch
cubrid_get_autocommit
CUBRID İşlevleri


Get auto-commit mode of the connection

cubrid_free_result
cubrid_get_charset
CUBRID İşlevleri
PHP Manual

cubrid_get_autocommit

(PECL CUBRID >= 8.4.0)

cubrid_get_autocommit — Get auto-commit mode of the connection

Açıklama

bool cubrid_get_autocommit ( resource $conn_identifier )

The cubrid_get_autocommit() function is used to get the status of CUBRID database connection auto-commit mode.

For CUBRID 8.4.0, auto-commit mode is disabled by default for transaction management.

For CUBRID 8.4.1, auto-commit mode is enabled by default for transaction management.

Değiştirgeler

conn_identifier

Connection identifier.

Dönen Değerler

TRUE, when auto-commit is on.

FALSE, when auto-commit is off.

NULL on error.

Ayrıca Bakınız

  • cubrid_set_autocommit() - Set autocommit mode of the connection
  • cubrid_commit() - Commit a transaction

cubrid_free_result
cubrid_get_charset
CUBRID İşlevleri


Return the current CUBRID connection charset

cubrid_get_autocommit
cubrid_get_class_name
CUBRID İşlevleri
PHP Manual

cubrid_get_charset

(PECL CUBRID >= 8.3.0)

cubrid_get_charset — Return the current CUBRID connection charset

Açıklama

string cubrid_get_charset ( resource $conn_identifier )

This function returns the current CUBRID connection charset and is similar to the CUBRID MySQL compatible function cubrid_client_encoding().

Değiştirgeler

conn_identifier

The CUBRID connection.

Dönen Değerler

A string that represents the CUBRID connection charset; on success.

FALSE on failure.

Örnekler

Örnek 1 cubrid_get_charset() example

<?php

$con = cubrid_connect("localhost", 33000, "demodb");
if (!$con)
{
    die('Could not connect.');
}

printf("CUBRID current charset: %s\n", cubrid_get_charset($con));

?>

Yukarıdaki örneğin çıktısı:

CUBRID current charset: iso8859-1

Ayrıca Bakınız

  • cubrid_client_encoding() - Return the current CUBRID connection charset

cubrid_get_autocommit
cubrid_get_class_name
CUBRID İşlevleri


Get the class name using OID

cubrid_get_charset
cubrid_get_client_info
CUBRID İşlevleri
PHP Manual

cubrid_get_class_name

(PECL CUBRID >= 8.3.0)

cubrid_get_class_name — Get the class name using OID

Açıklama

string cubrid_get_class_name ( resource $conn_identifier , string $oid )

The cubrid_get_class_name() function is used to get the class name from oid. It doesn't work when selecting data from the system tables, for example db_class.

Değiştirgeler

conn_identifier

Connection identifier.

oid

OID of the instance that you want to check the existence.

Dönen Değerler

Class name when process is successful.

FALSE, when process is unsuccessful.

Örnekler

Örnek 1 cubrid_get_class_name() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

$req = cubrid_execute($conn, "SELECT * FROM code", CUBRID_INCLUDE_OID);
$oid = cubrid_current_oid($req);
$class_name = cubrid_get_class_name($conn, $oid);

print_r($class_name);

cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

code

Ayrıca Bakınız

  • cubrid_is_instance() - Check whether the instance pointed by OID exists
  • cubrid_drop() - Delete an instance using OID

cubrid_get_charset
cubrid_get_client_info
CUBRID İşlevleri


Return the client library version

cubrid_get_class_name
cubrid_get_db_parameter
CUBRID İşlevleri
PHP Manual

cubrid_get_client_info

(PECL CUBRID >= 8.3.0)

cubrid_get_client_info — Return the client library version

Açıklama

string cubrid_get_client_info ( void )

This function returns a string that represents the client library version.

Değiştirgeler

Dönen Değerler

A string that represents the client library version; on success.

FALSE on failure.

Örnekler

Örnek 1 cubrid_get_client_info() example

<?php
printf("%-30s %s\n", "CUBRID PHP Version:", cubrid_version());

printf("\n");

$conn = cubrid_connect("localhost", 33088, "demodb");

if (!$conn) {
    die('Connect Error ('. cubrid_error_code() .')' . cubrid_error_msg());
}

$db_params = cubrid_get_db_parameter($conn);

while (list($param_name, $param_value) = each($db_params)) {
    printf("%-30s %s\n", $param_name, $param_value);
}

printf("\n");

$server_info = cubrid_get_server_info($conn);
$client_info = cubrid_get_client_info();

printf("%-30s %s\n", "Server Info:", $server_info);
printf("%-30s %s\n", "Client Info:", $client_info);

printf("\n");

$charset = cubrid_get_charset($conn);

printf("%-30s %s\n", "CUBRID Charset:", $charset);

cubrid_disconnect($conn);

?>

Yukarıdaki örneğin çıktısı:

CUBRID PHP Version:            9.1.0.0001

PARAM_ISOLATION_LEVEL          3
LOCK_TIMEOUT                   -1
MAX_STRING_LENGTH              1073741823
PARAM_AUTO_COMMIT              1

Server Info:                   9.1.0.0212
Client Info:                   9.1.0

CUBRID Charset:                iso8859-1
cubrid_get_class_name
cubrid_get_db_parameter
CUBRID İşlevleri


Returns the CUBRID database parameters

cubrid_get_client_info
cubrid_get_query_timeout
CUBRID İşlevleri
PHP Manual

cubrid_get_db_parameter

(PECL CUBRID >= 8.3.0)

cubrid_get_db_parameter — Returns the CUBRID database parameters

Açıklama

array cubrid_get_db_parameter ( resource $conn_identifier )

This function returns the CUBRID database parameters or it returns FALSE on failure. It returns an associative array with the values for the following parameters:

  • PARAM_ISOLATION_LEVEL
  • PARAM_LOCK_TIMEOUT
  • PARAM_MAX_STRING_LENGTH
  • PARAM_AUTO_COMMIT

Database parameters
Parameter | Description
PARAM_ISOLATION_LEVEL | The transaction isolation level.
LOCK_TIMEOUT | CUBRID provides the lock timeout feature, which sets the waiting time (in seconds) for the lock until the transaction lock setting is allowed. The default value of the lock_timeout_in_secs parameter is -1, which means the application client will wait indefinitely until the transaction lock is allowed.
PARAM_AUTO_COMMIT | In CUBRID PHP, auto-commit mode is disabled by default for transaction management. It can be set by using cubrid_set_autocommit().

The following table shows the isolation levels from 1 to 6. It consists of table schema (row) and isolation level:

Levels of Isolation Supported by CUBRID
Name | Description
SERIALIZABLE (6) | In this isolation level, problems concerning concurrency (e.g. dirty read, non-repeatable read, phantom read, etc.) do not occur.
REPEATABLE READ CLASS with REPEATABLE READ INSTANCES (5) | Another transaction T2 cannot update the schema of table A while transaction T1 is viewing table A. Transaction T1 may experience phantom read for the record R that was inserted by another transaction T2 when it is repeatedly retrieving a specific record.
REPEATABLE READ CLASS with READ COMMITTED INSTANCES (or CURSOR STABILITY) (4) | Another transaction T2 cannot update the schema of table A while transaction T1 is viewing table A. Transaction T1 may experience R read (non-repeatable read) that was updated and committed by another transaction T2 when it is repeatedly retrieving the record R.
REPEATABLE READ CLASS with READ UNCOMMITTED INSTANCES (3) | Default isolation level. Another transaction T2 cannot update the schema of table A while transaction T1 is viewing table A. Transaction T1 may experience R' read (dirty read) for the record that was updated but not committed by another transaction T2.
READ COMMITTED CLASS with READ COMMITTED INSTANCES (2) | Transaction T1 may experience A' read (non-repeatable read) for the table that was updated and committed by another transaction T2 while it is viewing table A repeatedly. Transaction T1 may experience R' read (non-repeatable read) for the record that was updated and committed by another transaction T2 while it is retrieving the record R repeatedly.
READ COMMITTED CLASS with READ UNCOMMITTED INSTANCES (1) | Transaction T1 may experience A' read (non-repeatable read) for the table that was updated and committed by another transaction T2 while it is repeatedly viewing table A. Transaction T1 may experience R' read (dirty read) for the record that was updated but not committed by another transaction T2.

Değiştirgeler

conn_identifier

The CUBRID connection. If the connection identifier is not specified, the last link opened by cubrid_connect() is assumed.

Dönen Değerler

An associative array with CUBRID database parameters; on success.

FALSE on failure.

Sürüm Bilgisi

Sürüm: | Açıklama
8.4.0 | Change LOCK_TIMEOUT to PARAM_LOCK_TIMEOUT, and MAX_STRING_LENGTH to PARAM_MAX_STRING_LENGTH in result.

Örnekler

Örnek 1 cubrid_get_db_parameter() example

<?php
printf("%-30s %s\n", "CUBRID PHP Version:", cubrid_version());

printf("\n");

$conn = cubrid_connect("localhost", 33088, "demodb");

if (!$conn) {
    die('Connect Error ('. cubrid_error_code() .')' . cubrid_error_msg());
}

$db_params = cubrid_get_db_parameter($conn);

while (list($param_name, $param_value) = each($db_params)) {
    printf("%-30s %s\n", $param_name, $param_value);
}

printf("\n");

$server_info = cubrid_get_server_info($conn);
$client_info = cubrid_get_client_info();

printf("%-30s %s\n", "Server Info:", $server_info);
printf("%-30s %s\n", "Client Info:", $client_info);

printf("\n");

$charset = cubrid_get_charset($conn);

printf("%-30s %s\n", "CUBRID Charset:", $charset);

cubrid_disconnect($conn);

?>

Yukarıdaki örneğin çıktısı:

CUBRID PHP Version:            9.1.0.0001

PARAM_ISOLATION_LEVEL          3
LOCK_TIMEOUT                   -1
MAX_STRING_LENGTH              1073741823
PARAM_AUTO_COMMIT              1

Server Info:                   9.1.0.0212
Client Info:                   9.1.0

CUBRID Charset:                iso8859-1

Ayrıca Bakınız

  • cubrid_set_db_parameter() - Sets the CUBRID database parameters
  • cubrid_get_autocommit() - Get auto-commit mode of the connection

cubrid_get_client_info
cubrid_get_query_timeout
CUBRID İşlevleri


Get the query timeout value of the request

cubrid_get_db_parameter
cubrid_get_server_info
CUBRID İşlevleri
PHP Manual

cubrid_get_query_timeout

(PECL CUBRID >= 8.4.1)

cubrid_get_query_timeout — Get the query timeout value of the request

Açıklama

int cubrid_get_query_timeout ( resource $req_identifier )

The cubrid_get_query_timeout() function is used to get the query timeout of the request.

Değiştirgeler

req_identifier

Request identifier.

Dönen Değerler

Success: the query timeout value of the current request. Units of msec.

Failure: FALSE

Örnekler

Örnek 1 cubrid_get_query_timeout() example

<?php

$host = "localhost";
$port = 33000;
$db = "demodb";

$conn =
cubrid_connect_with_url("CUBRID:$host:$port:$db:::?login_timeout=50000&query_timeout=5000&disconnect_on_query_timeout=yes");

$req = cubrid_prepare($conn, "SELECT * FROM code");

$timeout = cubrid_get_query_timeout($req);
var_dump($timeout);

cubrid_set_query_timeout($req, 1000);
$timeout = cubrid_get_query_timeout($req);
var_dump($timeout);

cubrid_close($conn);
?>

Yukarıdaki örneğin çıktısı:

int(5000)
int(1000)

Ayrıca Bakınız

  • cubrid_set_query_timeout() - Set the timeout time of query execution

cubrid_get_db_parameter
cubrid_get_server_info
CUBRID İşlevleri


Return the CUBRID server version

cubrid_get_query_timeout
cubrid_get
CUBRID İşlevleri
PHP Manual

cubrid_get_server_info

(PECL CUBRID >= 8.3.0)

cubrid_get_server_info — Return the CUBRID server version

Açıklama

string cubrid_get_server_info ( resource $conn_identifier )

This function returns a string that represents the CUBRID server version.

Değiştirgeler

conn_identifier

The CUBRID connection.

Dönen Değerler

A string that represents the CUBRID server version; on success.

FALSE on failure.

Örnekler

Örnek 1 cubrid_get_server_info() example

<?php
printf("%-30s %s\n", "CUBRID PHP Version:", cubrid_version());

printf("\n");

$conn = cubrid_connect("localhost", 33088, "demodb");

if (!$conn) {
    die('Connect Error ('. cubrid_error_code() .')' . cubrid_error_msg());
}

$db_params = cubrid_get_db_parameter($conn);

while (list($param_name, $param_value) = each($db_params)) {
    printf("%-30s %s\n", $param_name, $param_value);
}

printf("\n");

$server_info = cubrid_get_server_info($conn);
$client_info = cubrid_get_client_info();

printf("%-30s %s\n", "Server Info:", $server_info);
printf("%-30s %s\n", "Client Info:", $client_info);

printf("\n");

$charset = cubrid_get_charset($conn);

printf("%-30s %s\n", "CUBRID Charset:", $charset);

cubrid_disconnect($conn);

?>

Yukarıdaki örneğin çıktısı:

CUBRID PHP Version:            9.1.0.0001

PARAM_ISOLATION_LEVEL          3
LOCK_TIMEOUT                   -1
MAX_STRING_LENGTH              1073741823
PARAM_AUTO_COMMIT              1

Server Info:                   9.1.0.0212
Client Info:                   9.1.0

CUBRID Charset:                iso8859-1
cubrid_get_query_timeout
cubrid_get
CUBRID İşlevleri


Get a column using OID

cubrid_get_server_info
cubrid_insert_id
CUBRID İşlevleri
PHP Manual

cubrid_get

(PECL CUBRID >= 8.3.0)

cubrid_get — Get a column using OID

Açıklama

mixed cubrid_get ( resource $conn_identifier , string $oid [, mixed $attr ] )

The cubrid_get() function is used to get the attribute of the instance of the given oid. You can get single attribute by using string data type for the attr argument, or many attributes by using array data type for the attr argument.

Değiştirgeler

conn_identifier

Connection identifier.

oid

OID of the instance that you want to read.

attr

Name of the attribute that you want to read.

Dönen Değerler

Content of the requested attribute, when process is successful; When attr is set with string data type, the result is returned as a string; when attr is set with array data type (0-based numerical array), then the result is returned in associative array. When attr is omitted, then all attributes are received in array form.

FALSE when process is unsuccessful or result is NULL (If error occurs to distinguish empty string from NULL, then it prints the warning message. You can check the error by using cubrid_error_code())

Örnekler

Örnek 1 cubrid_get() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");

@cubrid_execute($conn, "DROP TABLE foo");
cubrid_execute($conn, "CREATE TABLE foo(a int AUTO_INCREMENT, b set(int), c list(int), d char(10))");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(1, {1,2,3}, {11,22,33,333}, 'a')");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(2, {4,5,7}, {44,55,66,666}, 'b')");

$req = cubrid_execute($conn, "SELECT * FROM foo", CUBRID_INCLUDE_OID);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);
$oid = cubrid_current_oid($req);

$attr = cubrid_get($conn, $oid, "b");
var_dump($attr);

$attr = cubrid_get($conn, $oid);
var_dump($attr);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

string(9) "{1, 2, 3}"
array(4) {
  ["a"]=>
  string(1) "1"
  ["b"]=>
  array(3) {
    [0]=>
    string(1) "1"
    [1]=>
    string(1) "2"
    [2]=>
    string(1) "3"
  }
  ["c"]=>
  array(4) {
    [0]=>
    string(2) "11"
    [1]=>
    string(2) "22"
    [2]=>
    string(2) "33"
    [3]=>
    string(3) "333"
  }
  ["d"]=>
  string(10) "a         "
}

Ayrıca Bakınız

  • cubrid_put() - Update a column using OID

cubrid_get_server_info
cubrid_insert_id
CUBRID İşlevleri


Return the ID generated for the last updated AUTO_INCREMENT column

cubrid_get
cubrid_is_instance
CUBRID İşlevleri
PHP Manual

cubrid_insert_id

(PECL CUBRID >= 8.3.0)

cubrid_insert_id — Return the ID generated for the last updated AUTO_INCREMENT column

Açıklama

string cubrid_insert_id ([ resource $conn_identifier ] )

The cubrid_insert_id() function retrieves the ID generated for the AUTO_INCREMENT column which is updated by the previous INSERT query. It returns 0 if the previous query does not generate new rows, or FALSE on failure.

Bilginize:

CUBRID supports AUTO_INCREMENT for more than one columns in a table. In most cases, there will be a single AUTO_INCREMENT column in a table. If there are multiple AUTO_INCREMENT columns, this function should not be used even if it will return a value.

Değiştirgeler

conn_identifier

The connection identifier previously obtained by a call to cubrid_connect().

Dönen Değerler

A string representing the ID generated for an AUTO_INCREMENT column by the previous query, on success.

0, if the previous query does not generate new rows.

FALSE on failure.

Sürüm Bilgisi

Sürüm: | Açıklama
8.4.0 | Change the return value from an array to string; Remove the first parameter class_name.

Örnekler

Örnek 1 cubrid_insert_id() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");

@cubrid_execute($conn, "DROP TABLE cubrid_test");
cubrid_execute($conn, "CREATE TABLE cubrid_test (d int AUTO_INCREMENT(1, 2), t varchar)");

for ($i = 0; $i < 10; $i++) {
    cubrid_execute($conn, "INSERT INTO cubrid_test(t) VALUES('cubrid_test')");
}

$id = cubrid_insert_id();
var_dump($id);

cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

string(2) "19"
cubrid_get
cubrid_is_instance
CUBRID İşlevleri


Check whether the instance pointed by OID exists

cubrid_insert_id
cubrid_lob_close
CUBRID İşlevleri
PHP Manual

cubrid_is_instance

(PECL CUBRID >= 8.3.0)

cubrid_is_instance — Check whether the instance pointed by OID exists

Açıklama

int cubrid_is_instance ( resource $conn_identifier , string $oid )

The cubrid_is_instance() function is used to check whether the instance pointed by the given oid exists or not.

Değiştirgeler

conn_identifier

Connection identifier.

oid

OID of the instance that you want to check the existence.

Dönen Değerler

1, if such instance exists;

0, if such instance does not exist;

-1, in case of error

Örnekler

Örnek 1 cubrid_is_instance() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");

$sql = <<<EOD
SELECT host_year, medal, game_date
FROM game
WHERE athlete_code IN
    (SELECT code FROM athlete WHERE name='Thorpe Ian');
EOD;

$req = cubrid_execute($conn, $sql, CUBRID_INCLUDE_OID);
$oid = cubrid_current_oid($req);

$res = cubrid_is_instance ($conn, $oid);
if ($res == 1) {
    echo "Instance pointed by $oid exists.\n";
} else if ($res == 0){
    echo "Instance pointed by $oid doesn't exist.\n";
} else {
    echo "error\n";
}

cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

Instance pointed by @0|0|0 doesn't exist.

Ayrıca Bakınız

  • cubrid_drop() - Delete an instance using OID
  • cubrid_get_class_name() - Get the class name using OID

cubrid_insert_id
cubrid_lob_close
CUBRID İşlevleri


Close BLOB/CLOB data

cubrid_is_instance
cubrid_lob_export
CUBRID İşlevleri
PHP Manual

cubrid_lob_close

(PECL CUBRID >= 8.3.1)

cubrid_lob_close — Close BLOB/CLOB data

Açıklama

bool cubrid_lob_close ( array $lob_identifier_array )

cubrid_lob_close() is used to close all BLOB/CLOB returned from cubrid_lob_get().

Değiştirgeler

lob_identifier_array

LOB identifier array return from cubrid_lob_get.

Dönen Değerler

TRUE, when process is successful.

FALSE, when process is unsuccessful.

Örnekler

Örnek 1 cubrid_lob_close() example

<?php
$conn = cubrid_connect ("localhost", 33000, "demodb", "dba");

cubrid_execute($conn,"DROP TABLE if exists doc");
cubrid_execute($conn,"CREATE TABLE doc (id INT, doc_content CLOB)");
cubrid_execute($conn,"INSERT INTO doc VALUES (5,'hello,cubrid')");

$lobs = cubrid_lob_get($conn, "SELECT doc_content FROM doc WHERE id=5");
echo "Doc size: ".cubrid_lob_size($lobs[0])." bytes";
cubrid_lob_export($conn, $lobs[0], "doc_5.txt");
cubrid_lob_close($lobs);
cubrid_disconnect($conn);
?>

Ayrıca Bakınız

  • cubrid_lob_get() - Get BLOB/CLOB data
  • cubrid_lob_size() - Get BLOB/CLOB data size
  • cubrid_lob_export() - Export BLOB/CLOB data to file
  • cubrid_lob_send() - Read BLOB/CLOB data and send straight to browser

cubrid_is_instance
cubrid_lob_export
CUBRID İşlevleri


Export BLOB/CLOB data to file

cubrid_lob_close
cubrid_lob_get
CUBRID İşlevleri
PHP Manual

cubrid_lob_export

(PECL CUBRID >= 8.3.1)

cubrid_lob_export — Export BLOB/CLOB data to file

Açıklama

bool cubrid_lob_export ( resource $conn_identifier , resource $lob_identifier , string $path_name )

cubrid_lob_export() is used to get BLOB/CLOB data from CUBRID database, and saves its contents to a file. To use this function, you must use cubrid_lob_get() first to get BLOB/CLOB info from CUBRID.

Değiştirgeler

conn_identifier

Connection identifier.

lob_identifier

LOB identifier.

path_name

Path name of the file.

Dönen Değerler

TRUE, when process is successful.

FALSE, when process is unsuccessful.

Örnekler

Örnek 1 cubrid_lob_export() example

<?php
$conn = cubrid_connect ("localhost", 33000, "demodb", "dba");

cubrid_execute($conn,"DROP TABLE if exists doc");
cubrid_execute($conn,"CREATE TABLE doc (id INT, doc_content CLOB)");
cubrid_execute($conn,"INSERT INTO doc VALUES (5,'hello,cubrid')");

$lobs = cubrid_lob_get($conn, "SELECT doc_content FROM doc WHERE id=5");
echo "Doc size: ".cubrid_lob_size($lobs[0])." bytes";
cubrid_lob_export($conn, $lobs[0], "doc_5.txt");
cubrid_lob_close($lobs);
cubrid_disconnect($conn);
?>

Ayrıca Bakınız

  • cubrid_lob_get() - Get BLOB/CLOB data
  • cubrid_lob_close() - Close BLOB/CLOB data
  • cubrid_lob_size() - Get BLOB/CLOB data size
  • cubrid_lob_send() - Read BLOB/CLOB data and send straight to browser

cubrid_lob_close
cubrid_lob_get
CUBRID İşlevleri


Get BLOB/CLOB data

cubrid_lob_export
cubrid_lob_send
CUBRID İşlevleri
PHP Manual

cubrid_lob_get

(PECL CUBRID >= 8.3.1)

cubrid_lob_get — Get BLOB/CLOB data

Açıklama

array cubrid_lob_get ( resource $conn_identifier , string $sql )

cubrid_lob_get() is used to get BLOB/CLOB meta info from CUBRID database, CUBRID gets BLOB/CLOB by executing the SQL statement, and returns all LOBs as a resource array. Be sure that the SQL retrieves only one column and its data type is BLOB or CLOB.

Remember to use cubrid_lob_close() to release the LOBs if you don't need it any more.

Değiştirgeler

conn_identifier

Connection identifier.

sql

SQL statement to be executed.

Dönen Değerler

Return an array of LOB resources, when process is successful.

FALSE, when process is unsuccessful.

Örnekler

Örnek 1 cubrid_lob_get() example

<?php
$conn = cubrid_connect ("localhost", 33000, "demodb", "dba");

cubrid_execute($conn,"DROP TABLE if exists doc");
cubrid_execute($conn,"CREATE TABLE doc (id INT, doc_content CLOB)");
cubrid_execute($conn,"INSERT INTO doc VALUES (5,'hello,cubrid')");

$lobs = cubrid_lob_get($conn, "SELECT doc_content FROM doc WHERE id=5");
echo "Doc size: ".cubrid_lob_size($lobs[0])." bytes";
cubrid_lob_export($conn, $lobs[0], "doc_5.txt");
cubrid_lob_close($lobs);
cubrid_disconnect($conn);
?>

Ayrıca Bakınız

  • cubrid_lob_close() - Close BLOB/CLOB data
  • cubrid_lob_size() - Get BLOB/CLOB data size
  • cubrid_lob_export() - Export BLOB/CLOB data to file
  • cubrid_lob_send() - Read BLOB/CLOB data and send straight to browser

cubrid_lob_export
cubrid_lob_send
CUBRID İşlevleri


Read BLOB/CLOB data and send straight to browser

cubrid_lob_get
cubrid_lob_size
CUBRID İşlevleri
PHP Manual

cubrid_lob_send

(PECL CUBRID >= 8.3.1)

cubrid_lob_send — Read BLOB/CLOB data and send straight to browser

Açıklama

bool cubrid_lob_send ( resource $conn_identifier , resource $lob_identifier )

cubrid_lob_send() reads BLOB/CLOB data and passes it straight through to the browser. To use this function, you must use cubrid_lob_get() first to get BLOB/CLOB info from CUBRID.

Değiştirgeler

conn_identifier

Connection identifier.

lob_identifier

LOB identifier.

Dönen Değerler

TRUE, when process is successful.

FALSE, when process is unsuccessful.

Örnekler

Örnek 1 cubrid_lob_send() example

<?php
$conn = cubrid_connect ("localhost", 33000, "demodb", "dba");

cubrid_execute($conn,"DROP TABLE if exists doc");
cubrid_execute($conn,"CREATE TABLE doc (id INT, doc_content CLOB)");
cubrid_execute($conn,"INSERT INTO doc VALUES (5,'hello,cubrid')");

$lobs = cubrid_lob_get($conn, "SELECT doc_content FROM doc WHERE id=5");

cubrid_lob_send($conn, $lobs[0]);
cubrid_lob_close($lobs);
cubrid_disconnect($conn);
?>

Ayrıca Bakınız

  • cubrid_lob_get() - Get BLOB/CLOB data
  • cubrid_lob_close() - Close BLOB/CLOB data
  • cubrid_lob_size() - Get BLOB/CLOB data size
  • cubrid_lob_export() - Export BLOB/CLOB data to file

cubrid_lob_get
cubrid_lob_size
CUBRID İşlevleri


Get BLOB/CLOB data size

cubrid_lob_send
cubrid_lob2_bind
CUBRID İşlevleri
PHP Manual

cubrid_lob_size

(PECL CUBRID >= 8.3.1)

cubrid_lob_size — Get BLOB/CLOB data size

Açıklama

string cubrid_lob_size ( resource $lob_identifier )

cubrid_lob_size() is used to get BLOB/CLOB data size.

Değiştirgeler

lob_identifier

LOB identifier.

Dönen Değerler

A string representing LOB data size, when process is successful.

FALSE, when process is unsuccessful.

Sürüm Bilgisi

Sürüm: | Açıklama
8.4.0 | Change return value type from int to string.

Örnekler

Örnek 1 cubrid_lob_size() example

<?php
$lobs = cubrid_lob_get($con, "SELECT doc_content FROM doc WHERE doc_id=5");
echo "Doc size:".cubrid_lob_size($lobs[0]);
cubrid_lob_export($conn, $lobs[0], "doc_5.txt");
cubrid_lob_close($lobs);
?>

Ayrıca Bakınız

  • cubrid_lob_get() - Get BLOB/CLOB data
  • cubrid_lob_close() - Close BLOB/CLOB data
  • cubrid_lob_export() - Export BLOB/CLOB data to file
  • cubrid_lob_send() - Read BLOB/CLOB data and send straight to browser

cubrid_lob_send
cubrid_lob2_bind
CUBRID İşlevleri


Bind a lob object or a string as a lob object to a prepared statement as parameters.

cubrid_lob_size
cubrid_lob2_close
CUBRID İşlevleri
PHP Manual

cubrid_lob2_bind

(PECL CUBRID >= 8.4.1)

cubrid_lob2_bind — Bind a lob object or a string as a lob object to a prepared statement as parameters.

Açıklama

bool cubrid_lob2_bind ( resource $req_identifier , int $bind_index , mixed $bind_value [, string $bind_value_type ] )

The cubrid_lob2_bind() function is used to bind BLOB/CLOB datas to a corresponding question mark placeholder in the SQL statement that was passed to cubrid_prepare(). If bind_value_type is not given, string will be "BLOB" as the default. But if you use cubrid_lob2_new() before, bind_value_type will be consistent with type in cubrid_lob2_new() as the default.

Değiştirgeler

req_identifier

Request identifier as a result of cubrid_prepare().

bind_index

Location of binding parameters. It starts with 1.

bind_value

Actual value for binding.

bind_value_type

It must be "BLOB" or "CLOB" and it won't be case-sensitive. If it not be given, the default value is "BLOB".

Dönen Değerler

TRUE, when process is successful.

FALSE, when process is unsuccessful.

Örnekler

Örnek 1 cubrid_lob2_bind() example

<?php
// Table: test_lob (id INT, contents CLOB)

$conn = cubrid_connect("localhost", 33000, "demodb", "dba", "");

cubrid_execute($conn,"DROP TABLE if exists test_lob");
cubrid_execute($conn,"CREATE TABLE test_lob (id INT, contents CLOB)");

$req = cubrid_prepare($conn, "INSERT INTO test_lob VALUES (?, ?)");

cubrid_bind($req,1, 3);

$lob = cubrid_lob2_new($conn, 'CLOB');
cubrid_lob2_bind($req, 2, $lob);

cubrid_execute($req);

cubrid_bind($req, 1, 4);

cubrid_lob2_bind($req, 2, 'CUBRID LOB2 TEST', 'CLOB');

cubrid_execute($req);

cubrid_disconnect($conn);
?>

Ayrıca Bakınız

  • cubrid_lob2_new() - Create a lob object.
  • cubrid_lob2_close() - Close LOB object.

cubrid_lob_size
cubrid_lob2_close
CUBRID İşlevleri


Close LOB object.

cubrid_lob2_bind
cubrid_lob2_export
CUBRID İşlevleri
PHP Manual

cubrid_lob2_close

(PECL CUBRID >= 8.4.1)

cubrid_lob2_close — Close LOB object.

Açıklama

bool cubrid_lob2_close ( resource $lob_identifier )

The cubrid_lob2_close() function is used to close LOB object returned from cubrid_lob2_new() or got from the result set.

Değiştirgeler

lob_identifier

Lob identifier as a result of cubrid_lob2_new() or get from the result set.

Dönen Değerler

TRUE, on success.

FALSE, on failure.

Ayrıca Bakınız

  • cubrid_lob2_new() - Create a lob object.

cubrid_lob2_bind
cubrid_lob2_export
CUBRID İşlevleri


Export the lob object to a file.

cubrid_lob2_close
cubrid_lob2_import
CUBRID İşlevleri
PHP Manual

cubrid_lob2_export

(PECL CUBRID >= 8.4.1)

cubrid_lob2_export — Export the lob object to a file.

Açıklama

bool cubrid_lob2_export ( resource $lob_identifier , string $file_name )

The cubrid_lob2_export() function is used to save the contents of BLOB/CLOB data to a file. To use this function, you must use cubrid_lob2_new() or fetch a lob object from CUBRID database first. If the file already exists, the operation will fail. This function will not influence the cursor position of the lob object. It operates the entire lob object.

Değiştirgeler

lob_identifier

Lob identifier as a result of cubrid_lob2_new() or get from the result set.

filename

File name you want to store BLOB/CLOB data. It also supports the path of the file.

Dönen Değerler

TRUE if the process is successful and FALSE for failure.

Örnekler

Örnek 1 cubrid_lob2_export() example

<?php
// Table: test_lob (id INT, contents CLOB)

$conn = cubrid_connect("localhost", 33000, "demodb", "dba", "");

cubrid_execute($conn,"DROP TABLE if exists doc");
cubrid_execute($conn,"CREATE TABLE doc (id INT, doc_content CLOB)");
cubrid_execute($conn,"INSERT INTO doc VALUES (5,'hello,cubrid')");

$req = cubrid_prepare($conn, "select * from doc");

cubrid_execute($req);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);

$row = cubrid_fetch($req, CUBRID_NUM | CUBRID_LOB);

cubrid_lob2_export($row[1], "doc_3.txt");

cubrid_lob2_close($row[1]);
cubrid_disconnect($conn);
?>

Ayrıca Bakınız

  • cubrid_lob2_new() - Create a lob object.
  • cubrid_lob2_close() - Close LOB object.
  • cubrid_lob2_import() - Import BLOB/CLOB data from a file.
  • cubrid_lob2_bind() - Bind a lob object or a string as a lob object to a prepared statement as parameters.

cubrid_lob2_close
cubrid_lob2_import
CUBRID İşlevleri


Import BLOB/CLOB data from a file.

cubrid_lob2_export
cubrid_lob2_new
CUBRID İşlevleri
PHP Manual

cubrid_lob2_import

(PECL CUBRID >= 8.4.1)

cubrid_lob2_import — Import BLOB/CLOB data from a file.

Açıklama

bool cubrid_lob2_import ( resource $lob_identifier , string $file_name )

The cubrid_lob2_import() function is used to save the contents of BLOB/CLOB data from a file. To use this function, you must use cubrid_lob2_new() or fetch a lob object from CUBRID database first. If the file already exists, the operation will fail. This function will not influence the cursor position of the lob object. It operates the entire lob object.

Değiştirgeler

lob_identifier

Lob identifier as a result of cubrid_lob2_new() or get from the result set.

filename

File name you want to import BLOB/CLOB data. It also supports the path of the file.

Dönen Değerler

TRUE if the process is successful and FALSE for failure.

Örnekler

Örnek 1 cubrid_lob2_export() example

<?php

$conn = cubrid_connect("localhost", 33000, "demodb", "dba", "");

cubrid_execute($conn,"DROP TABLE if exists test_lob");
cubrid_execute($conn,"CREATE TABLE test_lob (id INT, contents CLOB)");

$req = cubrid_prepare($conn, "INSERT INTO test_lob VALUES (?, ?)");
cubrid_bind($req, 1, 1);

$lob = cubrid_lob2_new($conn, "clob");
cubrid_lob2_import($lob, "doc_1.txt");
cubrid_lob2_bind($req, 2, $lob, 'CLOB'); // or cubrid_lob2_bind($req, 2, $lob);

cubrid_execute($req);

cubrid_lob2_close($lob);
cubrid_disconnect($conn);
?>

Ayrıca Bakınız

  • cubrid_lob2_new() - Create a lob object.
  • cubrid_lob2_close() - Close LOB object.
  • cubrid_lob2_export() - Export the lob object to a file.
  • cubrid_lob2_bind() - Bind a lob object or a string as a lob object to a prepared statement as parameters.

cubrid_lob2_export
cubrid_lob2_new
CUBRID İşlevleri


Create a lob object.

cubrid_lob2_import
cubrid_lob2_read
CUBRID İşlevleri
PHP Manual

cubrid_lob2_new

(PECL CUBRID >= 8.4.1)

cubrid_lob2_new — Create a lob object.

Açıklama

resource cubrid_lob2_new ([ resource $conn_identifier [, string $type = "BLOB" ]] )

The cubrid_lob2_new() function is used to create a lob object (both BLOB and CLOB). This function should be used before you bind a lob object.

Değiştirgeler

conn_identifier

Connection identifier. If the connection identifier is not specified, the last connection opened by cubrid_connect() or cubrid_connect_with_url() is assumed.

type

It may be "BLOB" or "CLOB", it won't be case-sensitive. The default value is "BLOB".

Dönen Değerler

Lob identifier when it is successful.

FALSE on failure.

Ayrıca Bakınız

  • cubrid_lob2_close() - Close LOB object.

cubrid_lob2_import
cubrid_lob2_read
CUBRID İşlevleri


Read from BLOB/CLOB data.

cubrid_lob2_new
cubrid_lob2_seek64
CUBRID İşlevleri
PHP Manual

cubrid_lob2_read

(PECL CUBRID >= 8.4.1)

cubrid_lob2_read — Read from BLOB/CLOB data.

Açıklama

string cubrid_lob2_read ( resource $lob_identifier , int $len )

The cubrid_lob2_read() function reads len bytes from the LOB data and returns the bytes read.

Değiştirgeler

lob_identifier

Lob identifier as a result of cubrid_lob2_new() or get from the result set.

len

Length from buffer you want to read from the lob data.

Dönen Değerler

Returns the contents as a string.

FALSE when there is no more data.

NULL on failure.

Örnekler

Örnek 1 cubrid_lob2_read() example 1

<?php
// test_lob (id INT, contents CLOB)

$conn = cubrid_connect("localhost", 33000, "demodb", "public", "");

$req = cubrid_execute($conn, "select * from test_lob");

$row = cubrid_fetch_row($req, CUBRID_LOB);

print "position now is " . cubrid_lob2_tell($row[1]) . "\n";

cubrid_lob2_seek($row[1], 10, CUBRID_CURSOR_FIRST);

print "\nposition after moving farword is " . cubrid_lob2_tell($row[1]) . "\n";

$data = cubrid_lob2_read($row[1], 12);

print "\nposition after reading is " . cubrid_lob2_tell($row[1]) . "\n";

print $data . "\n";

cubrid_lob2_seek($row[1], 5, CUBRID_CURSOR_CURRENT);

print "\nposition after moving again is " . cubrid_lob2_tell($row[1]) . "\n";

$data = cubrid_lob2_read($row[1], 20);
print $data . "\n";

cubrid_disconnect($conn);
?>

Örnek 2 cubrid_lob2_read() example 2

<?php
// test_lob (id INT, contents CLOB)

$conn = cubrid_connect("localhost", 33000, "demodb", "dba", "");

$req = cubrid_execute($conn, "select * from test_lob");

$row = cubrid_fetch_row($req, CUBRID_LOB);

while (true) {
    if ($data = cubrid_lob2_read($row[1], 1024)) {
        print $data . "\n";
    }
    elseif ($data === false) {
        print "There is no more data\n";
        break;
    }
    else {
        print "There must some errors\n";
        break;
    }
}

cubrid_disconnect($conn);
?>

Ayrıca Bakınız

  • cubrid_lob2_write() - Write to a lob object.
  • cubrid_lob2_seek() - Move the cursor of a lob object.
  • cubrid_lob2_seek64() - Move the cursor of a lob object.
  • cubrid_lob2_tell() - Tell the cursor position of the LOB object.
  • cubrid_lob2_tell64() - Tell the cursor position of the LOB object.
  • cubrid_lob2_size() - Get a lob object's size.
  • cubrid_lob2_size64() - Get a lob object's size.

cubrid_lob2_new
cubrid_lob2_seek64
CUBRID İşlevleri


Move the cursor of a lob object.

cubrid_lob2_read
cubrid_lob2_seek
CUBRID İşlevleri
PHP Manual

cubrid_lob2_seek64

(PECL CUBRID >= 8.4.1)

cubrid_lob2_seek64 — Move the cursor of a lob object.

Açıklama

bool cubrid_lob2_seek64 ( resource $lob_identifier , string $offset [, int $origin = CUBRID_CURSOR_CURRENT ] )

The cubrid_lob2_seek64() function is used to move the cursor position of a lob object by the value set in the offset argument, to the direction set in the origin argument. If the offset you want to move is larger than an integer data can be stored, you can use this function.

To set the origin argument, you can use CUBRID_CURSOR_FIRST to set the cursor position moving forward offset units from the first beginning. In this case, offset must be a positive value.

If you use CUBRID_CURSOR_CURRENT for origin, you can move forward or backward. and offset can be positive or negative.

If you use CUBRID_CURSOR_LAST for origin, you can move backward offset units from the end of LOB object and offset only can be positive.

Bilginize:

If you use this function to move the cursor position of the lob object, you should pass offset as a string.

Değiştirgeler

lob_identifier

Lob identifier as a result of cubrid_lob2_new() or get from the result set.

offset

Number of units you want to move the cursor.

origin

This parameter can be the following values:

CUBRID_CURSOR_FIRST: move forward from the first beginning.

CUBRID_CURSOR_CURRENT: move forward or backward from the current position.

CUBRID_CURSOR_LAST: move backward at the end of LOB object.

Dönen Değerler

TRUE if the process is successful and FALSE for failure.

Örnekler

Örnek 1 cubrid_lob2_seek64() example

<?php
// test_lob (id INT, contents CLOB)
// Data length of doc_1.txt should be greater than 20101029056306120215.

$conn = cubrid_connect("localhost", 33000, "demodb", "dba", "");

cubrid_execute($conn,"DROP TABLE if exists test_lob");
cubrid_execute($conn,"CREATE TABLE test_lob (id INT, contents CLOB)");

$req = cubrid_prepare($conn, "INSERT INTO test_lob VALUES (?, ?)");
cubrid_bind($req, 1, 1);

$lob = cubrid_lob2_new($conn, "clob");
cubrid_lob2_import($lob, "doc_1.txt");
cubrid_lob2_bind($req, 2, $lob, 'CLOB'); // or cubrid_lob2_bind($req, 2, $lob);

cubrid_execute($req);

cubrid_lob2_close($lob);

$req = cubrid_execute($conn, "select * from test_lob");
$row = cubrid_fetch_row($req, CUBRID_LOB);
$lob = $row[1];

cubrid_lob2_seek64($lob, "20101029056306120215", CUBRID_CURSOR_FIRST);
$data = cubrid_lob2_read($lob, 20);
echo $data."\n";
cubrid_disconnect($conn);
?>

Ayrıca Bakınız

  • cubrid_lob2_read() - Read from BLOB/CLOB data.
  • cubrid_lob2_write() - Write to a lob object.
  • cubrid_lob2_seek() - Move the cursor of a lob object.
  • cubrid_lob2_tell() - Tell the cursor position of the LOB object.
  • cubrid_lob2_tell64() - Tell the cursor position of the LOB object.
  • cubrid_lob2_size() - Get a lob object's size.
  • cubrid_lob2_size64() - Get a lob object's size.

cubrid_lob2_read
cubrid_lob2_seek
CUBRID İşlevleri


Move the cursor of a lob object.

cubrid_lob2_seek64
cubrid_lob2_size64
CUBRID İşlevleri
PHP Manual

cubrid_lob2_seek

(PECL CUBRID >= 8.4.1)

cubrid_lob2_seek — Move the cursor of a lob object.

Açıklama

bool cubrid_lob2_seek ( resource $lob_identifier , int $offset [, int $origin = CUBRID_CURSOR_CURRENT ] )

The cubrid_lob2_seek() function is used to move the cursor position of a lob object by the value set in the offset argument, to the direction set in the origin argument.

To set the origin argument, you can use CUBRID_CURSOR_FIRST to set the cursor position moving forward offset units from the first beginning. In this case, offset must be a positive value.

If you use CUBRID_CURSOR_CURRENT for origin, you can move forward or backward. and offset can be positive or negative.

If you use CUBRID_CURSOR_LAST for origin, you can move backward offset units from the end of LOB object and offset only can be positive.

Değiştirgeler

lob_identifier

Lob identifier as a result of cubrid_lob2_new() or get from the result set.

offset

Number of units you want to move the cursor.

origin

This parameter can be the following values:

CUBRID_CURSOR_FIRST: move forward from the first beginning.

CUBRID_CURSOR_CURRENT: move forward or backward from the current position.

CUBRID_CURSOR_LAST: move backward at the end of LOB object.

Dönen Değerler

TRUE if the process is successful and FALSE for failure.

Örnekler

Örnek 1 cubrid_lob2_seek() example

<?php
// test_lob (id INT, contents CLOB)
$conn = cubrid_connect("localhost", 33000, "demodb", "dba", "");

cubrid_execute($conn,"DROP TABLE if exists test_lob");
cubrid_execute($conn,"CREATE TABLE test_lob (id INT, contents CLOB)");
$req = cubrid_prepare($conn, "INSERT INTO test_lob VALUES(2, ?)");

$lob = cubrid_lob2_new($conn, 'CLOB');
$len = cubrid_lob2_write($lob, "Hello world");

cubrid_lob2_seek($lob, 0, CUBRID_CURSOR_LAST);
cubrid_lob2_write($lob, "beautiful");

cubrid_lob2_seek($lob, 15, CUBRID_CURSOR_FIRST);
$data = cubrid_lob2_read($lob, 5);

echo $data."\n";

cubrid_lob2_bind($req, 1, $lob);
cubrid_execute($req);

cubrid_disconnect($conn);
?>

Ayrıca Bakınız

  • cubrid_lob2_read() - Read from BLOB/CLOB data.
  • cubrid_lob2_write() - Write to a lob object.
  • cubrid_lob2_seek64() - Move the cursor of a lob object.
  • cubrid_lob2_tell() - Tell the cursor position of the LOB object.
  • cubrid_lob2_tell64() - Tell the cursor position of the LOB object.
  • cubrid_lob2_size() - Get a lob object's size.
  • cubrid_lob2_size64() - Get a lob object's size.

cubrid_lob2_seek64
cubrid_lob2_size64
CUBRID İşlevleri


Get a lob object's size.

cubrid_lob2_seek
cubrid_lob2_size
CUBRID İşlevleri
PHP Manual

cubrid_lob2_size64

(PECL CUBRID >= 8.4.1)

cubrid_lob2_size64 — Get a lob object's size.

Açıklama

string cubrid_lob2_size64 ( resource $lob_identifier )

The cubrid_lob2_size64() function is used to get the size of a lob object. If the size of a lob object is larger than an integer data can be stored, you can use this function and it will return the size as a string.

Değiştirgeler

lob_identifier

Lob identifier as a result of cubrid_lob2_new() or get from the result set.

Dönen Değerler

It will return the size of the LOB object as a string when it processes successfully.

FALSE on failure.

Ayrıca Bakınız

  • cubrid_lob2_read() - Read from BLOB/CLOB data.
  • cubrid_lob2_write() - Write to a lob object.
  • cubrid_lob2_seek() - Move the cursor of a lob object.
  • cubrid_lob2_seek64() - Move the cursor of a lob object.
  • cubrid_lob2_tell() - Tell the cursor position of the LOB object.
  • cubrid_lob2_tell64() - Tell the cursor position of the LOB object.
  • cubrid_lob2_size() - Get a lob object's size.

cubrid_lob2_seek
cubrid_lob2_size
CUBRID İşlevleri


Get a lob object's size.

cubrid_lob2_size64
cubrid_lob2_tell64
CUBRID İşlevleri
PHP Manual

cubrid_lob2_size

(PECL CUBRID >= 8.4.1)

cubrid_lob2_size — Get a lob object's size.

Açıklama

int cubrid_lob2_size ( resource $lob_identifier )

The cubrid_lob2_size() function is used to get the size of a lob object.

Değiştirgeler

lob_identifier

Lob identifier as a result of cubrid_lob2_new() or get from the result set.

Dönen Değerler

It will return the size of the LOB object when it processes successfully.

FALSE on failure.

Ayrıca Bakınız

  • cubrid_lob2_read() - Read from BLOB/CLOB data.
  • cubrid_lob2_write() - Write to a lob object.
  • cubrid_lob2_seek() - Move the cursor of a lob object.
  • cubrid_lob2_seek64() - Move the cursor of a lob object.
  • cubrid_lob2_tell() - Tell the cursor position of the LOB object.
  • cubrid_lob2_tell64() - Tell the cursor position of the LOB object.
  • cubrid_lob2_size64() - Get a lob object's size.

cubrid_lob2_size64
cubrid_lob2_tell64
CUBRID İşlevleri


Tell the cursor position of the LOB object.

cubrid_lob2_size
cubrid_lob2_tell
CUBRID İşlevleri
PHP Manual

cubrid_lob2_tell64

(PECL CUBRID >= 8.4.1)

cubrid_lob2_tell64 — Tell the cursor position of the LOB object.

Açıklama

string cubrid_lob2_tell64 ( resource $lob_identifier )

The cubrid_lob2_tell64() function is used to tell the cursor position of the LOB object. If the size of a lob object is larger than an integer data can be stored, you can use this function and it will return the position information as a string.

Değiştirgeler

lob_identifier

Lob identifier as a result of cubrid_lob2_new() or get from the result set.

Dönen Değerler

It will return the cursor position on the LOB object as a string when it processes successfully.

FALSE on failure.

Ayrıca Bakınız

  • cubrid_lob2_read() - Read from BLOB/CLOB data.
  • cubrid_lob2_write() - Write to a lob object.
  • cubrid_lob2_seek() - Move the cursor of a lob object.
  • cubrid_lob2_seek64() - Move the cursor of a lob object.
  • cubrid_lob2_tell() - Tell the cursor position of the LOB object.
  • cubrid_lob2_size() - Get a lob object's size.
  • cubrid_lob2_size64() - Get a lob object's size.

cubrid_lob2_size
cubrid_lob2_tell
CUBRID İşlevleri


Tell the cursor position of the LOB object.

cubrid_lob2_tell64
cubrid_lob2_write
CUBRID İşlevleri
PHP Manual

cubrid_lob2_tell

(PECL CUBRID >= 8.4.1)

cubrid_lob2_tell — Tell the cursor position of the LOB object.

Açıklama

int cubrid_lob2_tell ( resource $lob_identifier )

The cubrid_lob2_tell() function is used to tell the cursor position of the LOB object.

Değiştirgeler

lob_identifier

Lob identifier as a result of cubrid_lob2_new() or get from the result set.

Dönen Değerler

It will return the cursor position on the LOB object when it processes successfully.

FALSE on failure.

Ayrıca Bakınız

  • cubrid_lob2_read() - Read from BLOB/CLOB data.
  • cubrid_lob2_write() - Write to a lob object.
  • cubrid_lob2_seek() - Move the cursor of a lob object.
  • cubrid_lob2_seek64() - Move the cursor of a lob object.
  • cubrid_lob2_tell64() - Tell the cursor position of the LOB object.
  • cubrid_lob2_size() - Get a lob object's size.
  • cubrid_lob2_size64() - Get a lob object's size.

cubrid_lob2_tell64
cubrid_lob2_write
CUBRID İşlevleri


Write to a lob object.

cubrid_lob2_tell
cubrid_lock_read
CUBRID İşlevleri
PHP Manual

cubrid_lob2_write

(PECL CUBRID >= 8.4.1)

cubrid_lob2_write — Write to a lob object.

Açıklama

bool cubrid_lob2_write ( resource $lob_identifier , string $buf )

The cubrid_lob2_write() function reads as much as data from buf and stores it to the LOB object. Note that this function can only append characters now.

Değiştirgeler

lob_identifier

Lob identifier as a result of cubrid_lob2_new() or get from the result set.

buf

Data that need to be written to the lob object.

Dönen Değerler

TRUE if the process is successful and FALSE for failure.

Örnekler

Örnek 1 cubrid_lob2_write() example 1

<?php
// test_lob (id INT, contents CLOB)

$conn = cubrid_connect("localhost", 33000, "demodb", "dba", "");

cubrid_execute($conn,"DROP TABLE if exists test_lob");
cubrid_execute($conn,"CREATE TABLE test_lob (id INT, contents CLOB)");

$req = cubrid_prepare($conn, "INSERT INTO test_lob VALUES(2, ?)");

$lob = cubrid_lob2_new($conn, 'CLOB');
$len = cubrid_lob2_write($lob, "Hello world");

cubrid_lob2_bind($req, 1, $lob);
cubrid_execute($req);

cubrid_disconnect($conn);
?>

Örnek 2 cubrid_lob2_write() example 2

<?php
// test_lob (id INT, contents CLOB)

$conn = cubrid_connect("localhost", 33000, "demodb", "dba", "");

cubrid_execute($conn,"DROP TABLE if exists test_lob");
cubrid_execute($conn,"CREATE TABLE test_lob (id INT, contents CLOB)");

$req = cubrid_prepare($conn, "INSERT INTO test_lob VALUES(1, ?)");
$lob1 = cubrid_lob2_new($conn, 'CLOB');
$len = cubrid_lob2_write($lob1, "cubrid php driver");
cubrid_lob2_bind($req, 1, $lob1);
cubrid_execute($req);

$req = cubrid_execute($conn, "select * from test_lob");

$row = cubrid_fetch_row($req, CUBRID_LOB);
$lob2 = $row[1];
cubrid_lob2_seek($lob2, 0, CUBRID_CURSOR_LAST);

$pos = cubrid_lob2_tell($lob2);
print "pos before write: $pos\n";

cubrid_lob2_write($lob2, "Hello world");

$pos = cubrid_lob2_tell($lob2);
print "pos after write: $pos\n";

cubrid_disconnect($conn);
?>

Ayrıca Bakınız

  • cubrid_lob2_read() - Read from BLOB/CLOB data.
  • cubrid_lob2_seek() - Move the cursor of a lob object.
  • cubrid_lob2_seek64() - Move the cursor of a lob object.
  • cubrid_lob2_tell() - Tell the cursor position of the LOB object.
  • cubrid_lob2_tell64() - Tell the cursor position of the LOB object.
  • cubrid_lob2_size() - Get a lob object's size.
  • cubrid_lob2_size64() - Get a lob object's size.

cubrid_lob2_tell
cubrid_lock_read
CUBRID İşlevleri


Set a read lock on the given OID

cubrid_lob2_write
cubrid_lock_write
CUBRID İşlevleri
PHP Manual

cubrid_lock_read

(PECL CUBRID >= 8.3.0)

cubrid_lock_read — Set a read lock on the given OID

Açıklama

bool cubrid_lock_read ( resource $conn_identifier , string $oid )

The cubrid_lock_read() function is used to put read lock on the instance pointed by given oid.

Değiştirgeler

conn_identifier

Connection identifier.

oid

OID of the instance that you want to put read lock on.

Dönen Değerler

TRUE, when process is successful.

FALSE, when process is unsuccessful.

Örnekler

Örnek 1 cubrid_lock_read() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

@cubrid_execute($conn, "DROP TABLE foo");
cubrid_execute($conn, "CREATE TABLE foo(a int AUTO_INCREMENT, b set(int), c list(int), d char(10))");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(1, {1,2,3}, {11,22,33,333}, 'a')");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(2, {4,5,7}, {44,55,66,666}, 'b')");

$req = cubrid_execute($conn, "SELECT * FROM foo", CUBRID_INCLUDE_OID);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);
$oid = cubrid_current_oid($req);

cubrid_lock_read($conn, $oid);

$attr = cubrid_get($conn, $oid, "b");
var_dump($attr);

$attr = cubrid_get($conn, $oid);
var_dump($attr);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

string(9) "{1, 2, 3}"
array(4) {
  ["a"]=>
  string(1) "1"
  ["b"]=>
  array(3) {
    [0]=>
    string(1) "1"
    [1]=>
    string(1) "2"
    [2]=>
    string(1) "3"
  }
  ["c"]=>
  array(4) {
    [0]=>
    string(2) "11"
    [1]=>
    string(2) "22"
    [2]=>
    string(2) "33"
    [3]=>
    string(3) "333"
  }
  ["d"]=>
  string(10) "a         "
}

Ayrıca Bakınız

  • cubrid_lock_write() - Set a write lock on the given OID

cubrid_lob2_write
cubrid_lock_write
CUBRID İşlevleri


Set a write lock on the given OID

cubrid_lock_read
cubrid_move_cursor
CUBRID İşlevleri
PHP Manual

cubrid_lock_write

(PECL CUBRID >= 8.3.0)

cubrid_lock_write — Set a write lock on the given OID

Açıklama

bool cubrid_lock_write ( resource $conn_identifier , string $oid )

The cubrid_lock_write() function is used to put write lock on the instance pointed by the given oid.

Değiştirgeler

conn_identifier

Connection identifier.

oid

OID of the instance that you want to put write lock on.

Dönen Değerler

TRUE, when process is successful.

FALSE, when process is unsuccessful.

Örnekler

Örnek 1 cubrid_lock_write() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

@cubrid_execute($conn, "DROP TABLE foo");
cubrid_execute($conn, "CREATE TABLE foo(a int AUTO_INCREMENT, b set(int), c list(int), d char(10))");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(1, {1,2,3}, {11,22,33,333}, 'a')");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(2, {4,5,7}, {44,55,66,666}, 'b')");

$req = cubrid_execute($conn, "SELECT * FROM foo", CUBRID_INCLUDE_OID);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);
$oid = cubrid_current_oid($req);

cubrid_lock_write($conn, $oid);

$attr = cubrid_col_get($conn, $oid, "b");
var_dump($attr);

cubrid_put($conn, $oid, "b", array(2, 4, 8));

$attr = cubrid_col_get($conn, $oid, "b");
var_dump($attr);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

array(3) {
  [0]=>
  string(1) "1"
  [1]=>
  string(1) "2"
  [2]=>
  string(1) "3"
}
array(3) {
  [0]=>
  string(1) "2"
  [1]=>
  string(1) "4"
  [2]=>
  string(1) "8"
}

Ayrıca Bakınız

  • cubrid_lock_read() - Set a read lock on the given OID

cubrid_lock_read
cubrid_move_cursor
CUBRID İşlevleri


Move the cursor in the result

cubrid_lock_write
cubrid_next_result
CUBRID İşlevleri
PHP Manual

cubrid_move_cursor

(PECL CUBRID >= 8.3.0)

cubrid_move_cursor — Move the cursor in the result

Açıklama

int cubrid_move_cursor ( resource $req_identifier , int $offset [, int $origin = CUBRID_CURSOR_CURRENT ] )

The cubrid_move_cursor() function is used to move the current cursor location of req_identifier by the value set in the offset argument, to the direction set in the origin argument. To set the origin argument, you can use CUBRID_CURSOR_FIRST for the first part of the result, CUBRID_CURSOR_CURRENT for the current location of the result, or CUBRID_CURSOR_LAST for the last part of the result. If origin argument is not explicitly designated, then the function uses CUBRID_CURSOR_CURRENT as its default value.

If the value of cursor movement range goes over the valid limit, then the cursor moves to the next location after the valid range for the cursor. For example, if you move 20 units in the result with the size of 10, then the cursor will move to 11th place and return CUBRID_NO_MORE_DATA.

Değiştirgeler

req_identifier

Request identifier.

offset

Number of units you want to move the cursor.

origin

Location where you want to move the cursor from CUBRID_CURSOR_FIRST, CUBRID_CURSOR_CURRENT, CUBRID_CURSOR_LAST.

Dönen Değerler

TRUE, when process is successful.

FALSE, when process is unsucceful.

Örnekler

Örnek 1 cubrid_move_cursor() example

<?php
$conn = cubrid_connect("127.0.0.1", 33000, "demodb", "dba");

$req = cubrid_execute($conn, "SELECT * FROM code");
cubrid_move_cursor($req, 1, CUBRID_CURSOR_LAST);

$result = cubrid_fetch_row($req);
var_dump($result);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);
$result = cubrid_fetch_row($req);
var_dump($result);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_CURRENT);
$result = cubrid_fetch_row($req);
var_dump($result);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

array(2) {
  [0]=>
  string(1) "G"
  [1]=>
  string(4) "Gold"
}
array(2) {
  [0]=>
  string(1) "X"
  [1]=>
  string(5) "Mixed"
}
array(2) {
  [0]=>
  string(1) "M"
  [1]=>
  string(3) "Man"
}

Ayrıca Bakınız

  • cubrid_execute() - Execute a prepared SQL statement

cubrid_lock_write
cubrid_next_result
CUBRID İşlevleri


Get result of next query when executing multiple SQL statements

cubrid_move_cursor
cubrid_num_cols
CUBRID İşlevleri
PHP Manual

cubrid_next_result

(PECL CUBRID >= 8.4.0)

cubrid_next_result — Get result of next query when executing multiple SQL statements

Açıklama

bool cubrid_next_result ( resource $result )

The cubrid_next_result() function is used to get results of next query if multiple SQL statements are executed and CUBRID_EXEC_QUERY_ALL flag is set upon cubrid_execute().

Değiştirgeler

result

result comes from a call to cubrid_execute()

Dönen Değerler

TRUE, when process is successful.

FALSE, when process is unsuccessful.

Örnekler

Örnek 1 cubrid_next_result() example

<?php
$conn = cubrid_connect("127.0.0.1", 33000, "demodb", "dba");

$sql_stmt = "SELECT * FROM code; SELECT * FROM history WHERE host_year=2004 AND event_code=20281";
$res = cubrid_execute($conn, $sql_stmt, CUBRID_EXEC_QUERY_ALL);

get_result_info($res);
cubrid_next_result($res);
get_result_info($res);

function get_result_info($req)
{
    printf("\n------------ get_result_info --------------------\n");

    $row_num = cubrid_num_rows($req);
    $col_num = cubrid_num_cols($req);

    $column_name_list = cubrid_column_names($req);
    $column_type_list = cubrid_column_types($req);

    $column_last_name = cubrid_field_name($req, $col_num - 1);
    $column_last_table = cubrid_field_table($req, $col_num - 1);

    $column_last_type = cubrid_field_type($req, $col_num - 1);
    $column_last_len = cubrid_field_len($req, $col_num - 1);

    $column_1_flags = cubrid_field_flags($req, 1);

    printf("%-30s %d\n", "Row count:", $row_num);
    printf("%-30s %d\n", "Column count:", $col_num);
    printf("\n");

    printf("%-30s %-30s %-15s\n", "Column Names", "Column Types", "Column Len");
    printf("------------------------------------------------------------------------------\n");

    $size = count($column_name_list);
    for($i = 0; $i < $size; $i++) {
        $column_len = cubrid_field_len($req, $i);
        printf("%-30s %-30s %-15s\n", $column_name_list[$i], $column_type_list[$i], $column_len);
    }
    printf("\n\n");

    printf("%-30s %s\n", "Last Column Name:", $column_last_name);
    printf("%-30s %s\n", "Last Column Table:", $column_last_table);
    printf("%-30s %s\n", "Last Column Type:", $column_last_type);
    printf("%-30s %d\n", "Last Column Len:", $column_last_len);
    printf("%-30s %s\n", "Second Column Flags:", $column_1_flags);

    printf("\n\n");
}
?>

Yukarıdaki örneğin çıktısı:

------------ get_result_info --------------------
Row count:                     6
Column count:                  2

Column Names                   Column Types                   Column Len
------------------------------------------------------------------------------
s_name                         char                           1
f_name                         varchar                        6

Last Column Name:              f_name
Last Column Table:             code
Last Column Type:              varchar
Last Column Len:               6
Second Column Flags:

------------ get_result_info --------------------
Row count:                     4
Column count:                  5

Column Names                   Column Types                   Column Len
------------------------------------------------------------------------------
event_code                     integer                        11
athlete                        varchar                        40
host_year                      integer                        11
score                          varchar                        10
unit                           varchar                        5

Last Column Name:              unit
Last Column Table:             history
Last Column Type:              varchar
Last Column Len:               5
Second Column Flags:           not_null primary_key unique_key

Ayrıca Bakınız

  • cubrid_execute() - Execute a prepared SQL statement

cubrid_move_cursor
cubrid_num_cols
CUBRID İşlevleri


Return the number of columns in the result set

cubrid_next_result
cubrid_num_rows
CUBRID İşlevleri
PHP Manual

cubrid_num_cols

(PECL CUBRID >= 8.3.0)

cubrid_num_cols — Return the number of columns in the result set

Açıklama

int cubrid_num_cols ( resource $result )

The cubrid_num_cols() function is used to get the number of columns from the query result. It can only be used when the query executed is a select statement.

Değiştirgeler

result

Result.

Dönen Değerler

Number of columns, when process is successful.

FALSE, if SQL statement is not SELECT.

Örnekler

Örnek 1 cubrid_num_cols() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

$req = cubrid_execute($conn, "SELECT * FROM code");

$row_num = cubrid_num_rows($req);
$col_num = cubrid_num_cols($req);

printf("Row Num: %d\nColumn Num: %d\n", $row_num, $col_num);

cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

Row Num: 6
Column Num: 2

Ayrıca Bakınız

  • cubrid_execute() - Execute a prepared SQL statement
  • cubrid_num_rows() - Get the number of rows in the result set

cubrid_next_result
cubrid_num_rows
CUBRID İşlevleri


Get the number of rows in the result set

cubrid_num_cols
cubrid_pconnect_with_url
CUBRID İşlevleri
PHP Manual

cubrid_num_rows

(PECL CUBRID >= 8.3.0)

cubrid_num_rows — Get the number of rows in the result set

Açıklama

int cubrid_num_rows ( resource $result )

The cubrid_num_rows() function is used to get the number of rows from the query result. You can use it only when the query executed is a select statement. When you want to know such value for INSERT, UPDATE, or DELETE query, you have to use the cubrid_affected_rows() function.

Note: The cubrid_num_rows() function can only be used for synchronous query; it returns 0 when it is used for asynchronous query.

Değiştirgeler

result

result comes from a call to cubrid_execute(), cubrid_query() and cubrid_prepare()

Dönen Değerler

Number of rows, when process is successful.

0 when the query was done in async mode.

-1, if SQL statement is not SELECT.

FALSE when process is unsuccessful.

Örnekler

Örnek 1 cubrid_num_rows() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

$req = cubrid_execute($conn, "SELECT * FROM code");

$row_num = cubrid_num_rows($req);
$col_num = cubrid_num_cols($req);

printf("Row Num: %d\nColumn Num: %d\n", $row_num, $col_num);

cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

Row Num: 6
Column Num: 2

Ayrıca Bakınız

  • cubrid_execute() - Execute a prepared SQL statement
  • cubrid_num_cols() - Return the number of columns in the result set
  • cubrid_affected_rows() - Return the number of rows affected by the last SQL statement

cubrid_num_cols
cubrid_pconnect_with_url
CUBRID İşlevleri


Open a persistent connection to CUBRID server

cubrid_num_rows
cubrid_pconnect
CUBRID İşlevleri
PHP Manual

cubrid_pconnect_with_url

(PECL CUBRID >= 8.3.1)

cubrid_pconnect_with_url — Open a persistent connection to CUBRID server

Açıklama

resource cubrid_pconnect_with_url ( string $conn_url [, string $userid [, string $passwd ]] )

Establishes a persistent connection to a CUBRID server.

cubrid_pconnect_with_url() acts very much like cubrid_connect_with_url() with two major differences.

First, when connecting, the function would first try to find a (persistent) link that's already open with the same host, port, dbname and userid. If one is found, an identifier for it will be returned instead of opening a new connection.

Second, the connection to the SQL server will not be closed when the execution of the script ends. Instead, the link will remain open for future use (cubrid_close() or cubrid_disconnect() will not close links established by cubrid_pconnect_with_url()).

This type of link is therefore called 'persistent'.

<url> ::= CUBRID:<host>:<db_name>:<db_user>:<db_password>:[?<properties>]

<properties> ::= <property> [&<property>]

<properties> ::= alhosts=<alternative_hosts>[ &rctime=<time>]

<properties> ::= login_timeout=<milli_sec>

<properties> ::= query_timeout=<milli_sec>

<properties> ::= disconnect_on_query_timeout=true|false

<alternative_hosts> ::= <standby_broker1_host>:<port> [,<standby_broker2_host>:<port>]

<host> := HOSTNAME | IP_ADDR

<time> := SECOND

<milli_sec> := MILLI SECOND

  • host : A host name or IP address of the master database
  • db_name : A name of the database
  • db_user : A name of the database user
  • db_password : A database user password
  • alhosts : Specifies the broker information of the standby server, which is used for failover when it is impossible to connect to the active server. You can specify multiple brokers for failover, and the connection to the brokers is attempted in the order listed in alhosts
  • rctime : An interval between the attempts to connect to the active broker in which failure occurred. After a failure occurs, the system connects to the broker specified by althosts (failover), terminates the transaction, and then attempts to connect to the active broker of the master database at every rctime. The default value is 600 seconds.
  • login_timeout : Timeout value (unit: msec.) for database login. The default value is 0, which means infinite postponement.
  • query_timeout : Timeout value (unit: msec.) for query request. Upon timeout, a message to cancel requesting a query transferred to server is sent. The return value can depend on the disconnect_on_query_timeout configuration; even though the message to cancel a request is sent to server, that request may succeed.
  • disconnect_on_query_timeout : Configures a value whether to immediately return an error of function being executed upon timeout. The default value is false.

Bilginize:

? and : that are used as identifiers in PHP connection URL can't be included in the password. The following is an example of a password that is invalid to use as connection URL because it contains "?:".

$url = "CUBRID:localhost:33000:tdb:dba:12?:?login_timeout=100";

Passwords that contain ? or : may be passed as a separate parameter.

$url = "CUBRID:localhost:33000:tbd:::?login_timeout=100";

$conn = cubrid_pconnect_with_url ($url, "dba", "12?");

If user or password is empty,you can't delete ":",the following is an example.

$url = "CUBRID:localhost:33000:demodb:::";

Değiştirgeler

conn_url

A character string that contains server connection information.

userid

User name for the database.

passwd

User password.

Dönen Değerler

Connection identifier, when process is successful.

FALSE, when process is unsuccessful.

Örnekler

Örnek 1 cubrid_pconnect_with_url() url without properties example

<?php
$conn_url = "CUBRID:127.0.0.1:33000:demodb:dba::"
$con = cubrid_pconnect_with_url ($conn_url);

if ($con) {
   echo "connected successfully";
   cubrid_execute($con, "create table person(id int,name char(16))");
   $req =cubrid_execute($con, "insert into person values(1,'James')");

   if ($req) {
      cubrid_close_request ($req);
      cubrid_commit ($con);
   } else {
      cubrid_rollback ($con);
   }
   cubrid_disconnect ($con);
}
?>

Örnek 2 cubrid_pconnect_with_url() url with properties example

<?php
$conn_url = "CUBRID:127.0.0.1:33000:demodb:dba::?althost=10.34.63.132:33088&rctime=100"
$con = cubrid_pconnect_with_url ($conn_url);

if ($con) {
   echo "connected successfully";
   $req =cubrid_execute($con, "insert into person values(1,'James')");

   if ($req) {
      cubrid_close_request ($req);
      cubrid_commit ($con);
   } else {
      cubrid_rollback ($con);
   }
   cubrid_disconnect ($con);
}
?>

Ayrıca Bakınız

  • cubrid_connect() - Open a connection to a CUBRID Server
  • cubrid_pconnect() - Open a persistent connection to a CUBRID server
  • cubrid_pconnect_with_url()
  • cubrid_disconnect() - Close a database connection
  • cubrid_close() - Close CUBRID connection

cubrid_num_rows
cubrid_pconnect
CUBRID İşlevleri


Open a persistent connection to a CUBRID server

cubrid_pconnect_with_url
cubrid_prepare
CUBRID İşlevleri
PHP Manual

cubrid_pconnect

(PECL CUBRID >= 8.3.1)

cubrid_pconnect — Open a persistent connection to a CUBRID server

Açıklama

resource cubrid_pconnect ( string $host , int $port , string $dbname [, string $userid [, string $passwd ]] )

Establishes a persistent connection to a CUBRID server.

cubrid_pconnect() acts very much like cubrid_connect() with two major differences.

First, when connecting, the function would first try to find a (persistent) link that's already open with the same host, port, dbname and userid. If one is found, an identifier for it will be returned instead of opening a new connection.

Second, the connection to the SQL server will not be closed when the execution of the script ends. Instead, the link will remain open for future use (cubrid_close() or cubrid_disconnect() will not close links established by cubrid_pconnect()).

This type of link is therefore called 'persistent'.

Değiştirgeler

host

Host name or IP address of CUBRID CAS server.

port

Port number of CUBRID CAS server (BROKER_PORT configured in $CUBRID/conf/cubrid_broker.conf).

dbname

Name of database.

userid

User name for the database.

passwd

User password.

Dönen Değerler

Connection identifier, when process is successful.

FALSE, when process is unsuccessful.

Örnekler

Örnek 1 cubrid_connect() example

<?php
printf("%-30s %s\n", "CUBRID PHP Version:", cubrid_version());

printf("\n");

$conn = cubrid_pconnect("localhost", 33000, "demodb", "dba");

if (!$conn) {
    die('Connect Error ('. cubrid_error_code() .')' . cubrid_error_msg());
}

$db_params = cubrid_get_db_parameter($conn);

while (list($param_name, $param_value) = each($db_params)) {
    printf("%-30s %s\n", $param_name, $param_value);
}

printf("\n");

$server_info = cubrid_get_server_info($conn);
$client_info = cubrid_get_client_info();

printf("%-30s %s\n", "Server Info:", $server_info);
printf("%-30s %s\n", "Client Info:", $client_info);

printf("\n");

$charset = cubrid_get_charset($conn);

printf("%-30s %s\n", "CUBRID Charset:", $charset);

cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

CUBRID PHP Version:            9.1.0.0001

PARAM_ISOLATION_LEVEL          3
LOCK_TIMEOUT                   -1
MAX_STRING_LENGTH              1073741823
PARAM_AUTO_COMMIT              1

Server Info:                   9.1.0.0212
Client Info:                   9.1.0

CUBRID Charset:                iso8859-1

Ayrıca Bakınız

  • cubrid_connect() - Open a connection to a CUBRID Server
  • cubrid_connect_with_url() - Establish the environment for connecting to CUBRID server
  • cubrid_pconnect_with_url() - Open a persistent connection to CUBRID server
  • cubrid_disconnect() - Close a database connection
  • cubrid_close() - Close CUBRID connection

cubrid_pconnect_with_url
cubrid_prepare
CUBRID İşlevleri


Prepare a SQL statement for execution

cubrid_pconnect
cubrid_put
CUBRID İşlevleri
PHP Manual

cubrid_prepare

(PECL CUBRID >= 8.3.0)

cubrid_prepare — Prepare a SQL statement for execution

Açıklama

resource cubrid_prepare ( resource $conn_identifier , string $prepare_stmt [, int $option = 0 ] )

The cubrid_prepare() function is a sort of API which represents SQL statements compiled previously to a given connection handle. This pre-compiled SQL statement will be included in the cubrid_prepare().

Accordingly, you can use this statement effectively to execute several times repeatedly or to process long data. Only a single statement can be used and a parameter may put a question mark (?) to appropriate area in the SQL statement. Add a parameter when you bind a value in the VALUES clause of INSERT statement or in the WHERE clause. Note that it is allowed to bind a value to a MARK(?) by using the cubrid_bind() function only.

Değiştirgeler

conn_identifier

Connection identifier.

prepare_stmt

Prepare query.

option

OID return option CUBRID_INCLUDE_OID.

Dönen Değerler

Request identifier, if process is successful;

FALSE, if process is unsuccessful.

Örnekler

Örnek 1 cubrid_prepare() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");

$sql = <<<EOD
SELECT g.event_code, e.name
FROM game g
JOIN event e ON g.event_code=e.code
WHERE host_year = ? AND event_code NOT IN (SELECT event_code FROM game WHERE host_year=?) GROUP BY event_code;
EOD;

$req = cubrid_prepare($conn, $sql);

cubrid_bind($req, 1, 2004);
cubrid_bind($req, 2, 2000);
cubrid_execute($req);

$row_num = cubrid_num_rows($req);
printf("There are %d event that exits in 2004 olympic but not in 2000. For example:\n\n", $row_num);

printf("%-15s %s\n", "Event_code", "Event_name");
printf("----------------------------\n");

$row = cubrid_fetch_assoc($req);
printf("%-15d %s\n", $row["event_code"], $row["name"]);
$row = cubrid_fetch_assoc($req);
printf("%-15d %s\n", $row["event_code"], $row["name"]);

cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

There are 27 event that exits in 2004 olympic but not in 2000. For example:

Event_code      Event_name
----------------------------
20063           +91kg
20070           64kg

Ayrıca Bakınız

  • cubrid_execute() - Execute a prepared SQL statement
  • cubrid_bind() - Bind variables to a prepared statement as parameters

cubrid_pconnect
cubrid_put
CUBRID İşlevleri


Update a column using OID

cubrid_prepare
cubrid_rollback
CUBRID İşlevleri
PHP Manual

cubrid_put

(PECL CUBRID >= 8.3.0)

cubrid_put — Update a column using OID

Açıklama

int cubrid_put ( resource $conn_identifier , string $oid [, string $attr ], mixed $value )

The cubrid_put() function is used to update an attribute of the instance of the given oid.

You can update single attribute by using string data type to set attr. In such case, you can use integer, floating point or string type data for the value argument. To update multiple number of attributes, you can disregard the attr argument, and set value argument with associative array data type.

Değiştirgeler

conn_identifier

Connection identifier.

oid

OID of the instance that you want to update.

attr

Name of the attribute that you want to update.

value

New value that you want to assign to the attribute.

Dönen Değerler

TRUE, when process is successful.

FALSE, when process is unsuccessful.

Örnekler

Örnek 1 cubrid_put() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

@cubrid_execute($conn, "DROP TABLE foo");
cubrid_execute($conn, "CREATE TABLE foo(a int AUTO_INCREMENT, b set(int), c list(int), d char(10))");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(1, {1,2,3}, {11,22,33,333}, 'a')");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(2, {4,5,7}, {44,55,66,666}, 'b')");

$req = cubrid_execute($conn, "SELECT * FROM foo", CUBRID_INCLUDE_OID);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);
$oid = cubrid_current_oid($req);

$attr = cubrid_col_get($conn, $oid, "b");
var_dump($attr);

cubrid_put($conn, $oid, "b", array(2, 4, 8));

$attr = cubrid_col_get($conn, $oid, "b");
var_dump($attr);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

array(3) {
  [0]=>
  string(1) "1"
  [1]=>
  string(1) "2"
  [2]=>
  string(1) "3"
}
array(3) {
  [0]=>
  string(1) "2"
  [1]=>
  string(1) "4"
  [2]=>
  string(1) "8"
}

Ayrıca Bakınız

  • cubrid_get() - Get a column using OID
  • cubrid_set_add() - Insert a single element to set type column using OID
  • cubrid_set_drop() - Delete an element from set type column using OID
  • cubrid_seq_insert() - Insert an element to a sequence type column using OID
  • cubrid_seq_drop() - Delete an element from sequence type column using OID
  • cubrid_seq_put() - Update the element value of sequence type column using OID

cubrid_prepare
cubrid_rollback
CUBRID İşlevleri


Roll back a transaction

cubrid_put
cubrid_schema
CUBRID İşlevleri
PHP Manual

cubrid_rollback

(PECL CUBRID >= 8.3.0)

cubrid_rollback — Roll back a transaction

Açıklama

bool cubrid_rollback ( resource $conn_identifier )

The cubrid_rollback() function executes rollback on the transaction pointed by conn_identifier, currently in progress.

Connection to server is closed after calling cubrid_rollback(). Connection handle, however, is still valid.

Değiştirgeler

conn_identifier

Connection identifier.

Dönen Değerler

TRUE, when process is successful.

FALSE, when process is unsuccessful.

Örnekler

Örnek 1 cubrid_rollback() example

<?php
$conn = cubrid_connect("127.0.0.1", 33000, "demodb", "dba");
cubrid_set_autocommit($conn,false);

@cubrid_execute($conn, "DROP TABLE publishers");

$sql = <<<EOD
CREATE TABLE publishers(
pub_id CHAR(3),
pub_name VARCHAR(20),
city VARCHAR(15),
state CHAR(2),
country VARCHAR(15)
)
EOD;

if (!cubrid_execute($conn, $sql)) {
    printf("Error facility: %d\nError code: %d\nError msg: %s\n", cubrid_error_code_facility(), cubrid_error_code(), cubrid_error_msg());

    cubrid_disconnect($conn);
    exit;
}

$req = cubrid_prepare($conn, "INSERT INTO publishers VALUES(?, ?, ?, ?, ?)");

$id_list = array("P01", "P02", "P03", "P04");
$name_list = array("Abatis Publishers", "Core Dump Books", "Schadenfreude Press", "Tenterhooks Press");
$city_list = array("New York", "San Francisco", "Hamburg", "Berkeley");
$state_list = array("NY", "CA", NULL, "CA");
$country_list = array("USA", "USA", "Germany", "USA");

for ($i = 0, $size = count($id_list); $i < $size; $i++) {
    cubrid_bind($req, 1, $id_list[$i]);
    cubrid_bind($req, 2, $name_list[$i]);
    cubrid_bind($req, 3, $city_list[$i]);
    cubrid_bind($req, 4, $state_list[$i]);
    cubrid_bind($req, 5, $country_list[$i]);

    if (!($ret = cubrid_execute($req))) {
        break;
    }
}

if (!$ret) {
    cubrid_rollback($conn);
} else {
    cubrid_commit($conn);

    $req = cubrid_execute($conn, "SELECT * FROM publishers");
    while ($result = cubrid_fetch_assoc($req)) {
        printf("%-3s %-20s %-15s %-3s %-15s\n",
            $result["pub_id"], $result["pub_name"], $result["city"], $result["state"], $result["country"]);
    }
}

cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

P01 Abatis Publishers    New York        NY  USA
P02 Core Dump Books      San Francisco   CA  USA
P03 Schadenfreude Press  Hamburg             Germany
P04 Tenterhooks Press    Berkeley        CA  USA

Ayrıca Bakınız

  • cubrid_commit() - Commit a transaction
  • cubrid_disconnect() - Close a database connection

cubrid_put
cubrid_schema
CUBRID İşlevleri


Get the requested schema information

cubrid_rollback
cubrid_seq_drop
CUBRID İşlevleri
PHP Manual

cubrid_schema

(PECL CUBRID >= 8.3.0)

cubrid_schema — Get the requested schema information

Açıklama

array cubrid_schema ( resource $conn_identifier , int $schema_type [, string $class_name [, string $attr_name ]] )

The cubrid_schema() function is used to get the requested schema information from database. You have to designate class_name, if you want to get information on certain class, attr_name, if you want to get information on certain attribute (can be used only with CUBRID_ SCH_ATTR_PRIVILEGE).

The result of the cubrid_schema function is returned as a two-dimensional array (column (associative array) * row (numeric array)). The following tables shows types of schema and the column structure of the result array to be returned based on the schema type.

Result Composition of Each Type
Schema | Column Number | Column Name | Value
CUBRID_SCH_CLASS | 1 | NAME |
 | 2 | TYPE | 0:system class 1:vclass 2:class
CUBRID_SCH_VCLASS | 1 | NAME |
 | 2 | TYPE | 1:vclass
CUBRID_SCH_QUERY_SPEC | 1 | QUERY_SPEC |
CUBRID_SCH_ATTRIBUTE / CUBRID_SCH_CLASS_ATTRIBUTE | 1 | ATTR_NAME |
 | 2 | DOMAIN |
 | 3 | SCALE |
 | 4 | PRECISION |
 | 5 | INDEXED | 1:indexed
 | 6 | NOT NULL | 1:not null
 | 7 | SHARED | 1:shared
 | 8 | UNIQUE | 1:unique
 | 9 | DEFAULT |
 | 10 | ATTR_ORDER | base:1
 | 11 | CLASS_NAME |
 | 12 | SOURCE_CLASS |
 | 13 | IS_KEY | 1:key
CUBRID_SCH_METHOD / CUBRID_SCH_CLASS_METHOD | 1 | NAME |
 | 2 | RET_DOMAIN |
 | 3 | ARG_DOMAIN |
CUBRID_SCH_METHOD_FILE | 1 | METHOD_FILE |
CUBRID_SCH_SUPERCLASS / CUBRID_SCH_DIRECT_SUPER_CLASS / CUBRID_SCH_SUBCLASS | 1 | CLASS_NAME |
 | 2 | TYPE | 0:system class 1:vclass 2:class
CUBRID_SCH_CONSTRAINT | 1 | TYPE | 0:unique 1:index 2:reverse unique 3:reverse index
 | 2 | NAME |
 | 3 | ATTR_NAME |
 | 4 | NUM_PAGES |
 | 5 | NUM_KEYS |
 | 6 | PRIMARY_KEY | 1:primary key
 | 7 | KEY_ORDER | base:1
CUBRID_SCH_TRIGGER | 1 | NAME |
 | 2 | STATUS |
 | 3 | EVENT |
 | 4 | TARGET_CLASS |
 | 5 | TARGET_ATTR |
 | 6 | ACTION_TIME |
 | 7 | ACTION |
 | 8 | PRIORITY |
 | 9 | CONDITION_TIME |
 | 10 | CONDITION |
CUBRID_SCH_CLASS_PRIVILEGE / CUBRID_SCH_ATTR_PRIVILEGE | 1 | CLASS_NAME / ATTR_NAME |
 | 2 | PRIVILEGE |
 | 3 | GRANTABLE |
CUBRID_SCH_PRIMARY_KEY | 1 | CLASS_NAME |
 | 2 | ATTR_NAME |
 | 3 | KEY_SEQ | base:1
 | 4 | KEY_NAME |
CUBRID_SCH_IMPORTED_KEYS / CUBRID_SCH_EXPORTED_KEYS / CUBRID_SCH_CROSS_REFERENCE | 1 | PKTABLE_NAME |
 | 2 | PKCOLUMN_NAME |
 | 3 | FKTABLE_NAME | base:1
 | 4 | FKCOLUMN_NAME |
 | 5 | KEY_SEQ | base:1
 | 6 | UPDATE_ACTION | 0:cascade 1:restrict 2:no action 3:set null
 | 7 | DELETE_ACTION | 0:cascade 1:restrict 2:no action 3:set null
 | 8 | FK_NAME |
 | 9 | PK_NAME |

Değiştirgeler

conn_identifier

Connection identifier.

schema_type

Schema data that you want to know.

class_name

Class you want to know the schema of.

attr_name

Attribute you want to know the schema of.

Dönen Değerler

Array containing the schema information, when process is successful;

FALSE, when process is unsuccessful

Sürüm Bilgisi

Sürüm: | Açıklama
8.3.1 | Change return value: when process is unsuccessful, return false, not -1.

Örnekler

Örnek 1 cubrid_schema() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

printf("\n--- Primary Key ---\n");
$pk = cubrid_schema($conn, CUBRID_SCH_PRIMARY_KEY, "game");
var_dump($pk);

printf("\n--- Foreign Keys ---\n");
$fk = cubrid_schema($conn, CUBRID_SCH_IMPORTED_KEYS, "game");
var_dump($fk);

printf("\n--- Column Attribute ---\n");
$attr = cubrid_schema($conn, CUBRID_SCH_ATTRIBUTE, "stadium", "area");
var_dump($attr);

cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

--- Primary Key ---
array(3) {
  [0]=>
  array(4) {
    ["CLASS_NAME"]=>
    string(4) "game"
    ["ATTR_NAME"]=>
    string(12) "athlete_code"
    ["KEY_SEQ"]=>
    string(1) "3"
    ["KEY_NAME"]=>
    string(41) "pk_game_host_year_event_code_athlete_code"
  }
  [1]=>
  array(4) {
    ["CLASS_NAME"]=>
    string(4) "game"
    ["ATTR_NAME"]=>
    string(10) "event_code"
    ["KEY_SEQ"]=>
    string(1) "2"
    ["KEY_NAME"]=>
    string(41) "pk_game_host_year_event_code_athlete_code"
  }
  [2]=>
  array(4) {
    ["CLASS_NAME"]=>
    string(4) "game"
    ["ATTR_NAME"]=>
    string(9) "host_year"
    ["KEY_SEQ"]=>
    string(1) "1"
    ["KEY_NAME"]=>
    string(41) "pk_game_host_year_event_code_athlete_code"
  }
}

--- Foreign Keys ---
array(2) {
  [0]=>
  array(9) {
    ["PKTABLE_NAME"]=>
    string(7) "athlete"
    ["PKCOLUMN_NAME"]=>
    string(4) "code"
    ["FKTABLE_NAME"]=>
    string(4) "game"
    ["FKCOLUMN_NAME"]=>
    string(12) "athlete_code"
    ["KEY_SEQ"]=>
    string(1) "1"
    ["UPDATE_RULE"]=>
    string(1) "1"
    ["DELETE_RULE"]=>
    string(1) "1"
    ["FK_NAME"]=>
    string(20) "fk_game_athlete_code"
    ["PK_NAME"]=>
    string(15) "pk_athlete_code"
  }
  [1]=>
  array(9) {
    ["PKTABLE_NAME"]=>
    string(5) "event"
    ["PKCOLUMN_NAME"]=>
    string(4) "code"
    ["FKTABLE_NAME"]=>
    string(4) "game"
    ["FKCOLUMN_NAME"]=>
    string(10) "event_code"
    ["KEY_SEQ"]=>
    string(1) "1"
    ["UPDATE_RULE"]=>
    string(1) "1"
    ["DELETE_RULE"]=>
    string(1) "1"
    ["FK_NAME"]=>
    string(18) "fk_game_event_code"
    ["PK_NAME"]=>
    string(13) "pk_event_code"
  }
}

--- Column Attribute ---
array(1) {
  [0]=>
  array(13) {
    ["ATTR_NAME"]=>
    string(4) "area"
    ["DOMAIN"]=>
    string(1) "7"
    ["SCALE"]=>
    string(1) "2"
    ["PRECISION"]=>
    string(2) "10"
    ["INDEXED"]=>
    string(1) "0"
    ["NON_NULL"]=>
    string(1) "0"
    ["SHARED"]=>
    string(1) "0"
    ["UNIQUE"]=>
    string(1) "0"
    ["DEFAULT"]=>
    NULL
    ["ATTR_ORDER"]=>
    string(1) "4"
    ["CLASS_NAME"]=>
    string(7) "stadium"
    ["SOURCE_CLASS"]=>
    string(7) "stadium"
    ["IS_KEY"]=>
    string(1) "0"
  }
}
cubrid_rollback
cubrid_seq_drop
CUBRID İşlevleri


Delete an element from sequence type column using OID

cubrid_schema
cubrid_seq_insert
CUBRID İşlevleri
PHP Manual

cubrid_seq_drop

(PECL CUBRID >= 8.3.0)

cubrid_seq_drop — Delete an element from sequence type column using OID

Açıklama

bool cubrid_seq_drop ( resource $conn_identifier , string $oid , string $attr_name , int $index )

The cubrid_seq_drop() function is used to delete an element you request from the given sequence type attribute in the database.

Değiştirgeler

conn_identifier

Connection identifier.

oid

OID of the instance you want to work with.

attr_name

Name of the attribute that you want to delete an element from.

index

Index of the element that you want to delete (1-based).

Dönen Değerler

TRUE, when process is successful.

FALSE, when process is unsuccessful.

Örnekler

Örnek 1 cubrid_seq_drop() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

@cubrid_execute($conn, "DROP TABLE foo");
cubrid_execute($conn, "CREATE TABLE foo(a int AUTO_INCREMENT, b set(int), c sequence(int), d char(10))");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(1, {1,2,3}, {11,22,33,333}, 'a')");

$req = cubrid_execute($conn, "SELECT * FROM foo", CUBRID_INCLUDE_OID);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);
$oid = cubrid_current_oid($req);

$attr = cubrid_col_get($conn, $oid, "c");
var_dump($attr);

cubrid_seq_drop($conn, $oid, "c", 4);

$attr = cubrid_col_get($conn, $oid, "c");
var_dump($attr);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

array(4) {
  [0]=>
  string(2) "11"
  [1]=>
  string(2) "22"
  [2]=>
  string(2) "33"
  [3]=>
  string(3) "333"
}
array(3) {
  [0]=>
  string(2) "11"
  [1]=>
  string(2) "22"
  [2]=>
  string(2) "33"
}

Ayrıca Bakınız

  • cubrid_seq_insert() - Insert an element to a sequence type column using OID
  • cubrid_seq_put() - Update the element value of sequence type column using OID

cubrid_schema
cubrid_seq_insert
CUBRID İşlevleri


Insert an element to a sequence type column using OID

cubrid_seq_drop
cubrid_seq_put
CUBRID İşlevleri
PHP Manual

cubrid_seq_insert

(PECL CUBRID >= 8.3.0)

cubrid_seq_insert — Insert an element to a sequence type column using OID

Açıklama

bool cubrid_seq_insert ( resource $conn_identifier , string $oid , string $attr_name , int $index , string $seq_element )

The cubrid_col_insert() function is used to insert an element to a sequence type attribute in a requested location.

Değiştirgeler

conn_identifier

Connection identifier.

oid

OID of the instance you want to work with.

attr_name

Name of the attribute you want to insert an instance to.

index

Location of the element, you want to insert the element to (1-based).

seq_element

Content of the element that you want to insert.

Dönen Değerler

TRUE, when process is successful.

FALSE, when process is unsuccessful.

Örnekler

Örnek 1 cubrid_seq_insert() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

@cubrid_execute($conn, "DROP TABLE foo");
cubrid_execute($conn, "CREATE TABLE foo(a int AUTO_INCREMENT, b set(int), c sequence(int), d char(10))");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(1, {1,2,3}, {11,22,33,333}, 'a')");

$req = cubrid_execute($conn, "SELECT * FROM foo", CUBRID_INCLUDE_OID);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);
$oid = cubrid_current_oid($req);

$attr = cubrid_col_get($conn, $oid, "c");
var_dump($attr);

cubrid_seq_insert($conn, $oid, "c", 5, "44");

$attr = cubrid_col_get($conn, $oid, "c");
var_dump($attr);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

array(4) {
  [0]=>
  string(2) "11"
  [1]=>
  string(2) "22"
  [2]=>
  string(2) "33"
  [3]=>
  string(3) "333"
}
array(5) {
  [0]=>
  string(2) "11"
  [1]=>
  string(2) "22"
  [2]=>
  string(2) "33"
  [3]=>
  string(3) "333"
  [4]=>
  string(2) "44"
}

Ayrıca Bakınız

  • cubrid_seq_drop() - Delete an element from sequence type column using OID
  • cubrid_seq_put() - Update the element value of sequence type column using OID

cubrid_seq_drop
cubrid_seq_put
CUBRID İşlevleri


Update the element value of sequence type column using OID

cubrid_seq_insert
cubrid_set_add
CUBRID İşlevleri
PHP Manual

cubrid_seq_put

(PECL CUBRID >= 8.3.0)

cubrid_seq_put — Update the element value of sequence type column using OID

Açıklama

bool cubrid_seq_put ( resource $conn_identifier , string $oid , string $attr_name , int $index , string $seq_element )

The cubrid_seq_put() function is used to update the content of the requested element in a sequent type attribute using OID.

Değiştirgeler

conn_identifier

Connection identifier.

oid

OID of the instance you want to work with.

attr_name

Name of the attribute that you want to update an element.

index

Index (1-based) of the element that you want to update.

seq_element

New content that you want to use for the update.

Dönen Değerler

TRUE, when process is successful.

FALSE, when process is unsuccessful.

Örnekler

Örnek 1 cubrid_seq_put() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

@cubrid_execute($conn, "DROP TABLE foo");
cubrid_execute($conn, "CREATE TABLE foo(a int AUTO_INCREMENT, b set(int), c sequence(int), d char(10))");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(1, {1,2,3}, {11,22,33,333}, 'a')");

$req = cubrid_execute($conn, "SELECT * FROM foo", CUBRID_INCLUDE_OID);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);
$oid = cubrid_current_oid($req);

$attr = cubrid_col_get($conn, $oid, "c");
var_dump($attr);

cubrid_seq_put($conn, $oid, "c", 1, "111");

$attr = cubrid_col_get($conn, $oid, "c");
var_dump($attr);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

array(4) {
  [0]=>
  string(2) "11"
  [1]=>
  string(2) "22"
  [2]=>
  string(2) "33"
  [3]=>
  string(3) "333"
}
array(4) {
  [0]=>
  string(3) "111"
  [1]=>
  string(2) "22"
  [2]=>
  string(2) "33"
  [3]=>
  string(3) "333"
}

Ayrıca Bakınız

  • cubrid_seq_drop() - Delete an element from sequence type column using OID
  • cubrid_seq_insert() - Insert an element to a sequence type column using OID

cubrid_seq_insert
cubrid_set_add
CUBRID İşlevleri


Insert a single element to set type column using OID

cubrid_seq_put
cubrid_set_autocommit
CUBRID İşlevleri
PHP Manual

cubrid_set_add

(PECL CUBRID >= 8.3.0)

cubrid_set_add — Insert a single element to set type column using OID

Açıklama

bool cubrid_set_add ( resource $conn_identifier , string $oid , string $attr_name , string $set_element )

The cubrid_set_add() function is used to insert a single element to a set type attribute (set, multiset, sequence) you requested.

Değiştirgeler

conn_identifier

Connection identifier.

oid

OID of the instance you want to work with.

attr_name

Name of the attribute you want to insert an element.

set_element

Content of the element you want to insert.

Dönen Değerler

TRUE, when process is successful.

FALSE, when process is unsuccessful.

Örnekler

Örnek 1 cubrid_set_add() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

@cubrid_execute($conn, "DROP TABLE foo");
cubrid_execute($conn, "CREATE TABLE foo(a int AUTO_INCREMENT, b set(int), c list(int), d char(10))");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(1, {1,2,3}, {11,22,33,333}, 'a')");

$req = cubrid_execute($conn, "SELECT * FROM foo", CUBRID_INCLUDE_OID);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);
$oid = cubrid_current_oid($req);

$attr = cubrid_col_get($conn, $oid, "b");
var_dump($attr);

cubrid_set_add($conn, $oid, "b", "4");

$attr = cubrid_col_get($conn, $oid, "b");
var_dump($attr);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

array(3) {
  [0]=>
  string(1) "1"
  [1]=>
  string(1) "2"
  [2]=>
  string(1) "3"
}
array(4) {
  [0]=>
  string(1) "1"
  [1]=>
  string(1) "2"
  [2]=>
  string(1) "3"
  [3]=>
  string(1) "4"
}

Ayrıca Bakınız

  • cubrid_seq_drop() - Delete an element from sequence type column using OID

cubrid_seq_put
cubrid_set_autocommit
CUBRID İşlevleri


Set autocommit mode of the connection

cubrid_set_add
cubrid_set_db_parameter
CUBRID İşlevleri
PHP Manual

cubrid_set_autocommit

(PECL CUBRID >= 8.4.0)

cubrid_set_autocommit — Set autocommit mode of the connection

Açıklama

bool cubrid_set_autocommit ( resource $conn_identifier , bool $mode )

The cubrid_set_autocommit() function is used to set the CUBRID database auto-commit mode of the current database connection.

In CUBRID PHP, auto-commit mode is disabled by default for transaction management. When auto-commit mode is truned from off to on, any pending work is automatically committed.

Değiştirgeler

conn_identifier

Connection identifier.

mode

Auto-commit mode. The following constants can be used:

  • CUBRID_AUTOCOMMIT_FALSE
  • CUBRID_AUTOCOMMIT_TRUE

Dönen Değerler

TRUE, when process is successful.

FALSE, when process is unsuccessful.

Ayrıca Bakınız

  • cubrid_get_autocommit() - Get auto-commit mode of the connection
  • cubrid_commit() - Commit a transaction

cubrid_set_add
cubrid_set_db_parameter
CUBRID İşlevleri


Sets the CUBRID database parameters

cubrid_set_autocommit
cubrid_set_drop
CUBRID İşlevleri
PHP Manual

cubrid_set_db_parameter

(PECL CUBRID >= 8.4.0)

cubrid_set_db_parameter — Sets the CUBRID database parameters

Açıklama

bool cubrid_set_db_parameter ( resource $conn_identifier , int $param_type , int $param_value )

The cubrid_set_db_parameter() function is used to set the CUBRID database parameters. It can set the following CUBRID database parameters:

  • PARAM_ISOLATION_LEVEL
  • PARAM_LOCK_TIMEOUT

Bilginize:

The auto-commit mode can be set by using cubrid_set_autocommit().

Değiştirgeler

conn_identifier

The CUBRID connection. If the connection identifier is not specified, the last link opened by cubrid_connect() is assumed.

param_type

Database parameter type.

param_value

Isolation level value (1-6) or lock timeout (in seconds) value.

Dönen Değerler

TRUE on success.

FALSE on failure.

Örnekler

Örnek 1 cubrid_get_db_parameter() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

$params = cubrid_get_db_parameter($conn);
var_dump($params);

cubrid_set_autocommit($conn, CUBRID_AUTOCOMMIT_TRUE);
cubrid_set_db_parameter($conn, CUBRID_PARAM_ISOLATION_LEVEL, 2);

$params_new = cubrid_get_db_parameter($conn);
var_dump($params_new);

cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

array(4) {
  ["PARAM_ISOLATION_LEVEL"]=>
  int(3)
  ["PARAM_LOCK_TIMEOUT"]=>
  int(-1)
  ["PARAM_MAX_STRING_LENGTH"]=>
  int(1073741823)
  ["PARAM_AUTO_COMMIT"]=>
  int(0)
}
array(4) {
  ["PARAM_ISOLATION_LEVEL"]=>
  int(2)
  ["PARAM_LOCK_TIMEOUT"]=>
  int(-1)
  ["PARAM_MAX_STRING_LENGTH"]=>
  int(1073741823)
  ["PARAM_AUTO_COMMIT"]=>
  int(1)
}

Ayrıca Bakınız

  • cubrid_get_db_parameter() - Returns the CUBRID database parameters
  • cubrid_set_autocommit() - Set autocommit mode of the connection

cubrid_set_autocommit
cubrid_set_drop
CUBRID İşlevleri


Delete an element from set type column using OID

cubrid_set_db_parameter
cubrid_set_query_timeout
CUBRID İşlevleri
PHP Manual

cubrid_set_drop

(PECL CUBRID >= 8.3.0)

cubrid_set_drop — Delete an element from set type column using OID

Açıklama

bool cubrid_set_drop ( resource $conn_identifier , string $oid , string $attr_name , string $set_element )

The cubrid_set_drop() function is used to delete an element that you request from the given set type (set, multiset) attribute of the database.

Değiştirgeler

conn_identifier

Connection identifier.

oid

OID of the instance you want to work with.

attr_name

Name of the attribute you want to delete an element from.

set_element

Content of the element you want to delete.

Dönen Değerler

TRUE, when process is successful.

FALSE, when process is unsuccessful.

Örnekler

Örnek 1 cubrid_set_drop() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb", "dba");

@cubrid_execute($conn, "DROP TABLE foo");
cubrid_execute($conn, "CREATE TABLE foo(a int AUTO_INCREMENT, b set(int), c list(int), d char(10))");
cubrid_execute($conn, "INSERT INTO foo(a, b, c, d) VALUES(1, {1,2,3}, {11,22,33,333}, 'a')");

$req = cubrid_execute($conn, "SELECT * FROM foo", CUBRID_INCLUDE_OID);

cubrid_move_cursor($req, 1, CUBRID_CURSOR_FIRST);
$oid = cubrid_current_oid($req);

$attr = cubrid_col_get($conn, $oid, "b");
var_dump($attr);

cubrid_set_drop($conn, $oid, "b", "1");

$attr = cubrid_col_get($conn, $oid, "b");
var_dump($attr);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

array(3) {
  [0]=>
  string(1) "1"
  [1]=>
  string(1) "2"
  [2]=>
  string(1) "3"
}
array(2) {
  [0]=>
  string(1) "2"
  [1]=>
  string(1) "3"
}

Ayrıca Bakınız

  • cubrid_set_add() - Insert a single element to set type column using OID

cubrid_set_db_parameter
cubrid_set_query_timeout
CUBRID İşlevleri


Set the timeout time of query execution

cubrid_set_drop
cubrid_version
CUBRID İşlevleri
PHP Manual

cubrid_set_query_timeout

(PECL CUBRID >= 8.4.1)

cubrid_set_query_timeout — Set the timeout time of query execution

Açıklama

bool cubrid_set_query_timeout ( resource $req_identifier , int $timeout )

The cubrid_set_query_timeout() function is used to set the timeout time of query execution.

Değiştirgeler

req_identifier

Request identifier.

timeout

Timeout time, unit of msec.

Dönen Değerler

TRUE, when process is successful.

FALSE, when process is unsuccessful.

Ayrıca Bakınız

  • cubrid_get_query_timeout() - Get the query timeout value of the request

cubrid_set_drop
cubrid_version
CUBRID İşlevleri


Get the CUBRID PHP module's version

cubrid_set_query_timeout
CUBRID MySQL Compatibility Functions
CUBRID İşlevleri
PHP Manual

cubrid_version

(PECL CUBRID >= 8.3.0)

cubrid_version — Get the CUBRID PHP module's version

Açıklama

string cubrid_version ( void )

The cubrid_version() function is used to get the CUBRID PHP module's version.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Version information (eg. "8.3.1.0001").

Örnekler

Örnek 1 cubrid_version() example

<?php
printf("%-30s %s\n", "CUBRID PHP Version:", cubrid_version());

printf("\n");

$conn = cubrid_connect("localhost", 33088, "demodb", "dba");

if (!$conn) {
    die('Connect Error ('. cubrid_error_code() .')' . cubrid_error_msg());
}

$db_params = cubrid_get_db_parameter($conn);

while (list($param_name, $param_value) = each($db_params)) {
    printf("%-30s %s\n", $param_name, $param_value);
}

printf("\n");

$server_info = cubrid_get_server_info($conn);
$client_info = cubrid_get_client_info();

printf("%-30s %s\n", "Server Info:", $server_info);
printf("%-30s %s\n", "Client Info:", $client_info);

printf("\n");

$charset = cubrid_get_charset($conn);

printf("%-30s %s\n", "CUBRID Charset:", $charset);

cubrid_disconnect($conn);

?>

Yukarıdaki örneğin çıktısı:

CUBRID PHP Version:            9.1.0.0001

PARAM_ISOLATION_LEVEL          3
LOCK_TIMEOUT                   -1
MAX_STRING_LENGTH              1073741823
PARAM_AUTO_COMMIT              1

Server Info:                   9.1.0.0212
Client Info:                   9.1.0

CUBRID Charset:                iso8859-1

Ayrıca Bakınız

  • cubrid_error_code() - Get error code for the most recent function call
  • cubrid_error_code_facility() - Get the facility code of error

cubrid_set_query_timeout
CUBRID MySQL Compatibility Functions
CUBRID İşlevleri


CUBRID MySQL Compatibility Functions

İçindekiler

  • cubrid_affected_rows — Return the number of rows affected by the last SQL statement
  • cubrid_client_encoding — Return the current CUBRID connection charset
  • cubrid_close — Close CUBRID connection
  • cubrid_data_seek — Move the internal row pointer of the CUBRID result
  • cubrid_db_name — Get db name from results of cubrid_list_dbs
  • cubrid_errno — Return the numerical value of the error message from previous CUBRID operation
  • cubrid_error — Get the error message
  • cubrid_fetch_array — Fetch a result row as an associative array, a numeric array, or both
  • cubrid_fetch_assoc — Return the associative array that corresponds to the fetched row
  • cubrid_fetch_field — Get column information from a result and return as an object
  • cubrid_fetch_lengths — Return an array with the lengths of the values of each field from the current row
  • cubrid_fetch_object — Fetch the next row and return it as an object
  • cubrid_fetch_row — Return a numerical array with the values of the current row
  • cubrid_field_flags — Return a string with the flags of the given field offset
  • cubrid_field_len — Get the maximum length of the specified field
  • cubrid_field_name — Return the name of the specified field index
  • cubrid_field_seek — Move the result set cursor to the specified field offset
  • cubrid_field_table — Return the name of the table of the specified field
  • cubrid_field_type — Return the type of the column corresponding to the given field offset
  • cubrid_list_dbs — Return an array with the list of all existing CUBRID databases
  • cubrid_num_fields — Return the number of columns in the result set
  • cubrid_ping — Ping a server connection or reconnect if there is no connection
  • cubrid_query — Send a CUBRID query
  • cubrid_real_escape_string — Escape special characters in a string for use in an SQL statement
  • cubrid_result — Return the value of a specific field in a specific row
  • cubrid_unbuffered_query — Perform a query without fetching the results into memory
cubrid_version
cubrid_affected_rows
CUBRID


Return the number of rows affected by the last SQL statement

CUBRID MySQL Compatibility Functions
cubrid_client_encoding
CUBRID MySQL Compatibility Functions
PHP Manual

cubrid_affected_rows

(PECL CUBRID >= 8.3.0)

cubrid_affected_rows — Return the number of rows affected by the last SQL statement

Açıklama

int cubrid_affected_rows ([ resource $conn_identifier ] )
int cubrid_affected_rows ([ resource $req_identifier ] )

The cubrid_affected_rows() function is used to get the number of rows affected by the SQL statement (INSERT, DELETE, UPDATE).

Değiştirgeler

conn_identifier

The CUBRID connection. If the connection identifier is not specified, the last link opend by cubrid_connect() is assumed.

req_identifier

Request Identifier, could be returned from either cubrid_prepare() or cubrid_execute(). If the request identifier is not specified, the last identifier requested by cubrid_prepare() or cubrid_execute() is assumed.

Dönen Değerler

Number of rows affected by the SQL statement, when process is successful.

-1, when SQL statement is not INSERT, DELETE or UPDATE.

FALSE, when the request identifier is not specified, and there is no last request.

Örnekler

Örnek 1 cubrid_affected_rows() example

<?php
$conn = cubrid_connect('localhost', 33000, 'demodb', 'dba', '');
cubrid_execute($conn, "DROP TABLE IF EXISTS cubrid_test");
cubrid_execute($conn, "CREATE TABLE cubrid_test (d varchar)");
$sql_stmt = "INSERT INTO cubrid_test(d) VALUES('php-test')";
$req = cubrid_prepare($conn, $sql_stmt);

for ($i = 0; $i < 10; $i++) {
    cubrid_execute($req);
}
cubrid_commit($conn);

$req = cubrid_execute($conn, "DELETE FROM cubrid_test WHERE d='php-test'", CUBRID_ASYNC);
var_dump(cubrid_affected_rows());
var_dump(cubrid_affected_rows($conn));
var_dump(cubrid_affected_rows($req));

cubrid_disconnect($conn);

print "done!";
?>

Yukarıdaki örneğin çıktısı:

Rows deleted: 5

Ayrıca Bakınız

  • cubrid_execute() - Execute a prepared SQL statement

CUBRID MySQL Compatibility Functions
cubrid_client_encoding
CUBRID MySQL Compatibility Functions


Return the current CUBRID connection charset

cubrid_affected_rows
cubrid_close
CUBRID MySQL Compatibility Functions
PHP Manual

cubrid_client_encoding

(PECL CUBRID >= 8.3.1)

cubrid_client_encoding — Return the current CUBRID connection charset

Açıklama

string cubrid_client_encoding ([ resource $conn_identifier ] )

This function returns the current CUBRID connection charset and is similar to the CUBRID function cubrid_get_charset().

Değiştirgeler

conn_identifier

The CUBRID connection. If the connection identifier is not specified, the last link opened by cubrid_connect() is assumed.

Dönen Değerler

A string that represents the CUBRID connection charset; on success.

FALSE on failure.

Örnekler

Örnek 1 cubrid_client_encoding() example

<?php

$con = cubrid_connect("localhost", 33000, "demodb");
if (!$con)
{
    die('Could not connect.');
}

printf("CUBRID current charset: %s\n", cubrid_client_encoding($con));

?>

Yukarıdaki örneğin çıktısı:

CUBRID current charset: iso8859-1

Ayrıca Bakınız

  • cubrid_get_charset() - Return the current CUBRID connection charset

cubrid_affected_rows
cubrid_close
CUBRID MySQL Compatibility Functions


Close CUBRID connection

cubrid_client_encoding
cubrid_data_seek
CUBRID MySQL Compatibility Functions
PHP Manual

cubrid_close

(PECL CUBRID >= 8.3.1)

cubrid_close — Close CUBRID connection

Açıklama

bool cubrid_close ([ resource $conn_identifier ] )

The cubrid_close() function ends the transaction currently in process, closes the connection handle and disconnects from server. If there is any request handles not closed yet at this point, they will be closed. It is similar to the CUBRID function cubrid_disconnect().

Değiştirgeler

conn_identifier

The CUBRID connection identifier. If the connection identifier is not specified, the last connection opened by cubrid_connect() is assumed.

Dönen Değerler

TRUE, when process is successful.

FALSE, when process is unsuccessful.

Örnekler

Örnek 1 cubrid_close() example

<?php
$con = cubrid_connect ("localhost", 33000, "demodb");
if ($con) {
   echo "connected successfully";
   $req = cubrid_execute ( $con, "insert into person values(1,'James')");
   if ($req) {
      cubrid_close_request ($req);
      cubrid_commit ($con);
   } else {
      cubrid_rollback ($con);
   }
   cubrid_close ($con);
}
?>

Ayrıca Bakınız

  • cubrid_disconnect() - Close a database connection
  • cubrid_connect() - Open a connection to a CUBRID Server
  • cubrid_connect_with_url() - Establish the environment for connecting to CUBRID server

cubrid_client_encoding
cubrid_data_seek
CUBRID MySQL Compatibility Functions


Move the internal row pointer of the CUBRID result

cubrid_close
cubrid_db_name
CUBRID MySQL Compatibility Functions
PHP Manual

cubrid_data_seek

(PECL CUBRID >= 8.3.0)

cubrid_data_seek — Move the internal row pointer of the CUBRID result

Açıklama

bool cubrid_data_seek ( resource $result , int $row_number )

This function performs the moving of the internal row pointer of the CUBRID result (associated with the specified result identifier) to point to a specific row number. There are functions, such as cubrid_fetch_assoc(), which use the current stored value of row number.

Değiştirgeler

result

The result.

row_number

This is the desired row number of the new result pointer.

Dönen Değerler

Returns TRUE on success or FALSE on failure.

Örnekler

Örnek 1 cubrid_data_seek() example

<?php
$conn = cubrid_connect("127.0.0.1", 33000, "demodb");

$req = cubrid_execute($conn, "SELECT * FROM code");
cubrid_data_seek($req, 0);

$result = cubrid_fetch_row($req);
var_dump($result);

cubrid_data_seek($req, 2);
$result = cubrid_fetch_row($req);
var_dump($result);

cubrid_data_seek($req, 4);
$result = cubrid_fetch_row($req);
var_dump($result);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

array(2) {
  [0]=>
  string(1) "X"
  [1]=>
  string(5) "Mixed"
}
array(2) {
  [0]=>
  string(1) "M"
  [1]=>
  string(3) "Man"
}
array(2) {
  [0]=>
  string(1) "S"
  [1]=>
  string(6) "Silver"
}
cubrid_close
cubrid_db_name
CUBRID MySQL Compatibility Functions


Get db name from results of cubrid_list_dbs

cubrid_data_seek
cubrid_errno
CUBRID MySQL Compatibility Functions
PHP Manual

cubrid_db_name

(PECL CUBRID >= 8.3.1)

cubrid_db_name — Get db name from results of cubrid_list_dbs

Açıklama

string cubrid_db_name ( array $result , int $index )

Retrieve the database name from a call to cubrid_list_dbs().

Değiştirgeler

result

The result pointer from a call to cubrid_list_dbs().

index

The index into the result set.

Dönen Değerler

Returns the database name on success, and FALSE on failure. If FALSE is returned, use cubrid_error() to determine the nature of the error.

Örnekler

Örnek 1 cubrid_db_name() example

<?php
error_reporting(E_ALL);

$conn = cubrid_connect('localhost', 33000, 'demodb', 'dba', '');
$db_list = cubrid_list_dbs($conn);

$i = 0;
$cnt = count($db_list);
while ($i < $cnt) {
    echo cubrid_db_name($db_list, $i) . "\n";
    $i++;
}
?>

Yukarıdaki örneğin çıktısı:

demodb

Ayrıca Bakınız

  • cubrid_list_dbs() - Return an array with the list of all existing CUBRID databases

cubrid_data_seek
cubrid_errno
CUBRID MySQL Compatibility Functions


Return the numerical value of the error message from previous CUBRID operation

cubrid_db_name
cubrid_error
CUBRID MySQL Compatibility Functions
PHP Manual

cubrid_errno

(PECL CUBRID >= 8.3.1)

cubrid_errno — Return the numerical value of the error message from previous CUBRID operation

Açıklama

int cubrid_errno ([ resource $conn_identifier ] )

Returns the error number from the last CUBRID function.

The cubrid_errno() function is used to get the error code of the error that occurred during the API execution. Usually, it gets the error code when API returns false as its return value.

Değiştirgeler

conn_identifier

The CUBRID connection identifier. If the connection identifier is not specified, the last connection opened by cubrid_connect() is assumed.

Dönen Değerler

Returns the error number from the last CUBRID function, or 0 (zero) if no error occurred.

Örnekler

Örnek 1 cubrid_errno() example

<?php
$con = cubrid_connect('localhost', 33000, 'demodb', 'dba', '');
$req = cubrid_execute($con, "select id, name from person");
if ($req) {
    while (list ($id, $name) = cubrid_fetch($req))
    echo $id, $name;
} else {
    echo "Error Code: ", cubrid_errno($con);
    echo "Error Message: ", cubrid_error($con);
}
?>

Yukarıdaki örneğin çıktısı:

Error Code: -493 Error Message: Syntax: Unknown class "person". select id, [name] from person

Ayrıca Bakınız

  • cubrid_error() - Get the error message
  • cubrid_error_code() - Get error code for the most recent function call
  • cubrid_error_msg() - Get last error message for the most recent function call

cubrid_db_name
cubrid_error
CUBRID MySQL Compatibility Functions


Get the error message

cubrid_errno
cubrid_fetch_array
CUBRID MySQL Compatibility Functions
PHP Manual

cubrid_error

(PECL CUBRID >= 8.3.1)

cubrid_error — Get the error message

Açıklama

string cubrid_error ([ resource $connection ] )

The cubrid_error() function is used to get the error message that occurred during the use of CUBRID API. Usually, it gets error message when API returns false as its return value.

Değiştirgeler

connection

The CUBRID connection.

Dönen Değerler

Error message that occurred.

Örnekler

Örnek 1 cubrid_error() example

<?php
$con = cubrid_connect('localhost', 33000, 'demodb', 'dba', '');
$req = cubrid_execute($con, "select id, name from person");
if ($req) {
    while (list ($id, $name) = cubrid_fetch($req))
    echo $id, $name;
} else {
    echo "Error Code: ", cubrid_errno($con);
    echo "Error Message: ", cubrid_error($con);
}
?>

Yukarıdaki örneğin çıktısı:

Error Code: -493 Error Message: Syntax: Unknown class "person". select id, [name] from person

Ayrıca Bakınız

  • cubrid_errno() - Return the numerical value of the error message from previous CUBRID operation
  • cubrid_error_code() - Get error code for the most recent function call
  • cubrid_error_msg() - Get last error message for the most recent function call

cubrid_errno
cubrid_fetch_array
CUBRID MySQL Compatibility Functions


Fetch a result row as an associative array, a numeric array, or both

cubrid_error
cubrid_fetch_assoc
CUBRID MySQL Compatibility Functions
PHP Manual

cubrid_fetch_array

(PECL CUBRID >=8.3.0)

cubrid_fetch_array — Fetch a result row as an associative array, a numeric array, or both

Açıklama

array cubrid_fetch_array ( resource $result [, int $type = CUBRID_BOTH ] )

The cubrid_fetch_array() function is used to get a single row from the query result and returns an array. The cursor automatically moves to the next row after getting the result.

Değiştirgeler

result

Result comes from a call to cubrid_execute()

type

Array type of the fetched result CUBRID_NUM, CUBRID_ASSOC, CUBRID_BOTH. If you need to operate the lob object, you can use CUBRID_LOB.

Dönen Değerler

Returns an array of strings that corresponds to the fetched row, when process is successful.

FALSE, when there are no more rows; NULL, when process is unsuccessful.

The type of returned array depends on how type is defined. By using CUBRID_BOTH (default), you'll get an array with both associative and number indices, and you can decide which data type to use by setting the type argument. The type variable can be set to one of the following values:

  • CUBRID_NUM : Numerical array (0-based)
  • CUBRID_ASSOC : Associative array
  • CUBRID_BOTH : Numerical & Associative array (default)

Örnekler

Örnek 1 cubrid_fetch_array() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");
$req = cubrid_execute($conn, "SELECT name,area,seats,address FROM stadium WHERE nation_code='GRE' AND seats > 10000");

printf("%-40s %-10s %-6s %-20s\n", "name", "area", "seats", "address");
while ($row = cubrid_fetch_array($req, CUBRID_NUM)) {
    printf("%-40s %-10s %-6s %-20s\n", $row[0], $row[1], $row[2], $row[3]);
}

// if you want to operate LOB object, you can use cubrid_fetch_array($req, CUBRID_NUM | CUBRID_LOB)

cubrid_close_request($req);

cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

name                                     area       seats  address
Panathinaiko Stadium                     86300.00   50000  Athens, Greece
Olympic Stadium                          54700.00   13000  Athens, Greece
Olympic Indoor Hall                      34100.00   18800  Athens, Greece
Olympic Hall                             52400.00   21000  Athens, Greece
Olympic Aquatic Centre                   42500.00   11500  Athens, Greece
Markopoulo Olympic Equestrian Centre     64000.00   15000  Markopoulo, Athens, Greece
Faliro Coastal Zone Olympic Complex      34650.00   12171  Faliro, Athens, Greece
Athens Olympic Stadium                   120400.00  71030  Maroussi, Athens, Greece
Ano Liossia                              34000.00   12000  Ano Liosia, Athens, Greece

Ayrıca Bakınız

  • cubrid_execute() - Execute a prepared SQL statement
  • cubrid_fetch() - Fetch the next row from a result set
  • cubrid_fetch_row() - Return a numerical array with the values of the current row
  • cubrid_fetch_assoc() - Return the associative array that corresponds to the fetched row
  • cubrid_fetch_object() - Fetch the next row and return it as an object

cubrid_error
cubrid_fetch_assoc
CUBRID MySQL Compatibility Functions


Return the associative array that corresponds to the fetched row

cubrid_fetch_array
cubrid_fetch_field
CUBRID MySQL Compatibility Functions
PHP Manual

cubrid_fetch_assoc

(PECL CUBRID >= 8.3.0)

cubrid_fetch_assoc — Return the associative array that corresponds to the fetched row

Açıklama

array cubrid_fetch_assoc ( resource $result [, int $type ] )

This function returns the associative array, that corresponds to the fetched row, and then moves the internal data pointer ahead, or returns FALSE when the end is reached.

Değiştirgeler

result

result comes from a call to cubrid_execute()

type

Type can only be CUBRID_LOB, this parameter will be used only when you need to operate the lob object.

Dönen Değerler

Associative array, when process is successful.

FALSE, when there are no more rows; NULL, when process is unsuccessful.

Örnekler

Örnek 1 cubrid_fetch_assoc() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");
$req = cubrid_execute($conn, "SELECT name,area,seats,address FROM stadium WHERE nation_code='GRE' AND seats > 10000");

printf("%-40s %-10s %-6s %-20s\n", "name", "area", "seats", "address");
while ($row = cubrid_fetch_assoc($req)) {
    printf("%-40s %-10s %-6s %-20s\n",
        $row["name"], $row["area"], $row["seats"], $row["address"]);
}

// if you want to operate LOB object, you can use cubrid_fetch_assoc($req, CUBRID_LOB)

cubrid_close_request($req);

cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

name                                     area       seats  address
Panathinaiko Stadium                     86300.00   50000  Athens, Greece
Olympic Stadium                          54700.00   13000  Athens, Greece
Olympic Indoor Hall                      34100.00   18800  Athens, Greece
Olympic Hall                             52400.00   21000  Athens, Greece
Olympic Aquatic Centre                   42500.00   11500  Athens, Greece
Markopoulo Olympic Equestrian Centre     64000.00   15000  Markopoulo, Athens, Greece
Faliro Coastal Zone Olympic Complex      34650.00   12171  Faliro, Athens, Greece
Athens Olympic Stadium                   120400.00  71030  Maroussi, Athens, Greece
Ano Liossia                              34000.00   12000  Ano Liosia, Athens, Greece

Ayrıca Bakınız

  • cubrid_execute() - Execute a prepared SQL statement
  • cubrid_fetch() - Fetch the next row from a result set
  • cubrid_fetch_row() - Return a numerical array with the values of the current row
  • cubrid_fetch_array() - Fetch a result row as an associative array, a numeric array, or both
  • cubrid_fetch_object() - Fetch the next row and return it as an object

cubrid_fetch_array
cubrid_fetch_field
CUBRID MySQL Compatibility Functions


Get column information from a result and return as an object

cubrid_fetch_assoc
cubrid_fetch_lengths
CUBRID MySQL Compatibility Functions
PHP Manual

cubrid_fetch_field

(PECL CUBRID >= 8.3.1)

cubrid_fetch_field — Get column information from a result and return as an object

Açıklama

object cubrid_fetch_field ( resource $result [, int $field_offset = 0 ] )

This function returns an object with certain properties of the specific column. The properties of the object are:

name

column name

table

name of the table that the column belongs to

def

default value of the column

max_length

maximum length of the column

not_null

1 if the column cannot be NULL

primary_key

1 if the column is a primary key

unique_key

1 if the column is an unique key

multiple_key

1 if the column is a non-unique key

numeric

1 if the column is numeric

blob

1 if the column is a BLOB

type

the type of the column

unsigned

1 if the column is unsigned

zerofill

1 if the column is zero-filled

Değiştirgeler

result

result comes from a call to cubrid_execute()

field_offset

The numerical field offset. If the field offset is not specified, the next field (that was not yet retrieved by this function) is retrieved. The field_offset starts at 0.

Dönen Değerler

Object with certain properties of the specific column, when process is successful.

FALSE on failure.

Örnekler

Örnek 1 cubrid_fetch_field() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");
$req = cubrid_execute($conn, "SELECT event_code,athlete_code,nation_code,game_date FROM game WHERE host_year=1988 and event_code=20001;");

var_dump(cubrid_fetch_row($req));

cubrid_field_seek($req, 1);
$field = cubrid_fetch_field($req);

printf("\n--- Field Properties ---\n");
printf("%-30s %s\n", "name:", $field->name);
printf("%-30s %s\n", "table:", $field->table);
printf("%-30s \"%s\"\n", "default value:", $field->def);
printf("%-30s %d\n", "max length:", $field->max_length);
printf("%-30s %d\n", "not null:", $field->not_null);
printf("%-30s %d\n", "primary key:", $field->primary_key);
printf("%-30s %d\n", "unique key:", $field->unique_key);
printf("%-30s %d\n", "multiple key:", $field->multiple_key);
printf("%-30s %d\n", "numeric:", $field->numeric);
printf("%-30s %d\n", "blob:", $field->blob);
printf("%-30s %s\n", "type:", $field->type);
printf("%-30s %d\n", "unsigned:", $field->unsigned);
printf("%-30s %d\n", "zerofill:", $field->zerofill);

cubrid_close_request($req);

cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

array(4) {
  [0]=>
  string(5) "20001"
  [1]=>
  string(5) "16681"
  [2]=>
  string(3) "KOR"
  [3]=>
  string(9) "1988-9-30"
}

--- Field Properties ---
name:                          athlete_code
table:                         game
default value:                 ""
max length:                    0
not null:                      1
primary key:                   1
unique key:                    1
multiple key:                  0
numeric:                       1
blob:                          0
type:                          integer
unsigned:                      0
zerofill:                      0
cubrid_fetch_assoc
cubrid_fetch_lengths
CUBRID MySQL Compatibility Functions


Return an array with the lengths of the values of each field from the current row

cubrid_fetch_field
cubrid_fetch_object
CUBRID MySQL Compatibility Functions
PHP Manual

cubrid_fetch_lengths

(PECL CUBRID >= 8.3.0)

cubrid_fetch_lengths — Return an array with the lengths of the values of each field from the current row

Açıklama

array cubrid_fetch_lengths ( resource $result )

This function returns an numeric array with the lengths of the values of each field from the current row of the result set or it returns FALSE on failure.

Bilginize:

If field data type is BLOB/CLOB, you should get its length by using cubrid_lob_size().

Değiştirgeler

result

result comes from a call to cubrid_execute()

Dönen Değerler

An numeric array, when process is successful.

FALSE on failure.

Örnekler

Örnek 1 cubrid_fetch_lengths() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");
$result = cubrid_execute($conn, "SELECT * FROM game WHERE host_year=2004 AND nation_code='AUS' AND medal='G'");

$row = cubrid_fetch_row($result);
print_r($row);

$lens = cubrid_fetch_lengths($result);
print_r($lens);

cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [0] => 2004
    [1] => 20085
    [2] => 15118
    [3] => 30134
    [4] => AUS
    [5] => G
    [6] => 2004-8-20
)
Array
(
    [0] => 4
    [1] => 5
    [2] => 5
    [3] => 5
    [4] => 3
    [5] => 1
    [6] => 10
)
cubrid_fetch_field
cubrid_fetch_object
CUBRID MySQL Compatibility Functions


Fetch the next row and return it as an object

cubrid_fetch_lengths
cubrid_fetch_row
CUBRID MySQL Compatibility Functions
PHP Manual

cubrid_fetch_object

(PECL CUBRID >= 8.3.0)

cubrid_fetch_object — Fetch the next row and return it as an object

Açıklama

object cubrid_fetch_object ( resource $result [, string $class_name [, array $params [, int $type ]]] )

This function returns an object with the column names of the result set as properties. The values of these properties are extracted from the current row of the result.

Değiştirgeler

result

result comes from a call to cubrid_execute()

class_name

The name of the class to instantiate. If not specified, a stdClass (stdClass is PHP's generic empty class that's used when casting other types to objects) object is returned.

params

An optional array of parameters to pass to the constructor for class_name objects.

type

Type can only be CUBRID_LOB, this parameter will be used only when you need to operate the lob object.

Dönen Değerler

An object, when process is successful.

FALSE, when there are no more rows; NULL, when process is unsuccessful.

Örnekler

Örnek 1 cubrid_fetch_object() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");
$res = cubrid_execute($conn, "SELECT * FROM code");

var_dump(cubrid_fetch_object($res));

// if you want to operate LOB object, you can use cubrid_fetch_object($res, CUBRID_LOB)

class demodb_code {
    public $s_name = null;
    public $f_name = null;

    public function toString() {
        var_dump($this);
    }
}

var_dump(cubrid_fetch_object($res, "demodb_code"));

// if you want to operate LOB object, you can use cubrid_fetch_object($res, "demodb_code", CUBRID_LOB)

class demodb_code_construct extends demodb_code {
    public function __construct($s, $f) {
        $this->s_name = $s;
        $this->f_name = $f;
    }
}

var_dump(cubrid_fetch_object($res, 'demodb_code_construct', array('s_name', 'f_name')));

// if you want to operate LOB object, you can use cubrid_fetch_object($res, 'demodb_code_construct', array('s_name', 'f_name'), CUBRID_LOB)

var_dump(cubrid_fetch_object($res));

cubrid_close_request($res);
cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

object(stdClass)#1 (2) {
  ["s_name"]=>
  string(1) "X"
  ["f_name"]=>
  string(5) "Mixed"
}
object(demodb_code)#1 (2) {
  ["s_name"]=>
  string(1) "W"
  ["f_name"]=>
  string(5) "Woman"
}
object(demodb_code_construct)#1 (2) {
  ["s_name"]=>
  string(6) "s_name"
  ["f_name"]=>
  string(6) "f_name"
}
object(stdClass)#1 (2) {
  ["s_name"]=>
  string(1) "B"
  ["f_name"]=>
  string(6) "Bronze"
}

Ayrıca Bakınız

  • cubrid_execute() - Execute a prepared SQL statement
  • cubrid_fetch() - Fetch the next row from a result set
  • cubrid_fetch_array() - Fetch a result row as an associative array, a numeric array, or both
  • cubrid_fetch_assoc() - Return the associative array that corresponds to the fetched row
  • cubrid_fetch_row() - Return a numerical array with the values of the current row

cubrid_fetch_lengths
cubrid_fetch_row
CUBRID MySQL Compatibility Functions


Return a numerical array with the values of the current row

cubrid_fetch_object
cubrid_field_flags
CUBRID MySQL Compatibility Functions
PHP Manual

cubrid_fetch_row

(PECL CUBRID >= 8.3.0)

cubrid_fetch_row — Return a numerical array with the values of the current row

Açıklama

array cubrid_fetch_row ( resource $result [, int $type ] )

This function returns a numerical array with the values of the current row from the result set, starting from 0, and moves the internal data pointer ahead.

Değiştirgeler

result

result comes from a call to cubrid_execute()

type

Type can only be CUBRID_LOB, this parameter will be used only when you need to operate the lob object.

Dönen Değerler

A numerical array, when process is successful.

FALSE, when there are no more rows; NULL, when process is unsuccessful.

Örnekler

Örnek 1 cubrid_fetch_row() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");
$req = cubrid_execute($conn, "SELECT name,area,seats,address FROM stadium WHERE nation_code='GRE' AND seats > 10000");

printf("%-40s %-10s %-6s %-20s\n", "name", "area", "seats", "address");
while ($row = cubrid_fetch_row($req)) {
    printf("%-40s %-10s %-6s %-20s\n", $row[0], $row[1], $row[2], $row[3]);
}

// if you want to operate LOB object, you can use cubrid_fetch_row($req, CUBRID_LOB)

cubrid_close_request($req);

cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

name                                     area       seats  address
Panathinaiko Stadium                     86300.00   50000  Athens, Greece
Olympic Stadium                          54700.00   13000  Athens, Greece
Olympic Indoor Hall                      34100.00   18800  Athens, Greece
Olympic Hall                             52400.00   21000  Athens, Greece
Olympic Aquatic Centre                   42500.00   11500  Athens, Greece
Markopoulo Olympic Equestrian Centre     64000.00   15000  Markopoulo, Athens, Greece
Faliro Coastal Zone Olympic Complex      34650.00   12171  Faliro, Athens, Greece
Athens Olympic Stadium                   120400.00  71030  Maroussi, Athens, Greece
Ano Liossia                              34000.00   12000  Ano Liosia, Athens, Greece

Ayrıca Bakınız

  • cubrid_execute() - Execute a prepared SQL statement
  • cubrid_fetch() - Fetch the next row from a result set
  • cubrid_fetch_array() - Fetch a result row as an associative array, a numeric array, or both
  • cubrid_fetch_assoc() - Return the associative array that corresponds to the fetched row
  • cubrid_fetch_object() - Fetch the next row and return it as an object

cubrid_fetch_object
cubrid_field_flags
CUBRID MySQL Compatibility Functions


Return a string with the flags of the given field offset

cubrid_fetch_row
cubrid_field_len
CUBRID MySQL Compatibility Functions
PHP Manual

cubrid_field_flags

(PECL CUBRID >= 8.3.0)

cubrid_field_flags — Return a string with the flags of the given field offset

Açıklama

string cubrid_field_flags ( resource $result , int $field_offset )

This function returns a string with the flags of the given field offset separated by space. You can split the returned value using explode. The possible flags could be: not_null, primary_key, unique_key, foreign_key, auto_increment, shared, reverse_index, reverse_unique and timestamp.

Değiştirgeler

result

result comes from a call to cubrid_execute()

field_offset

The numerical field offset. The field_offset starts at 0. If field_offset does not exist, an error of level E_WARNING is also issued.

Dönen Değerler

A string with flags, when process is successful.

FALSE when invalid field_offset value.

-1 if SQL sentence is not SELECT.

Örnekler

Örnek 1 cubrid_field_flags() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");
$result = cubrid_execute($conn, "SELECT * FROM game WHERE host_year=2004 AND nation_code='AUS' AND medal='G'");

$col_num = cubrid_num_cols($result);

printf("%-30s %s\n", "Field Name", "Field Flags");
for($i = 0; $i < $col_num; $i++) {
    printf("%-30s %s\n", cubrid_field_name($result, $i), cubrid_field_flags($result, $i));
}

cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

Field Name                     Field Flags
host_year                      not_null primary_key unique_key
event_code                     not_null primary_key unique_key foreign_key
athlete_code                   not_null primary_key unique_key foreign_key
stadium_code                   not_null
nation_code
medal
game_date
cubrid_fetch_row
cubrid_field_len
CUBRID MySQL Compatibility Functions


Get the maximum length of the specified field

cubrid_field_flags
cubrid_field_name
CUBRID MySQL Compatibility Functions
PHP Manual

cubrid_field_len

(PECL CUBRID >= 8.3.0)

cubrid_field_len — Get the maximum length of the specified field

Açıklama

int cubrid_field_len ( resource $result , int $field_offset )

This function returns the maximum length of the specified field on success, or it returns FALSE on failure.

Değiştirgeler

result

result comes from a call to cubrid_execute()

field_offset

The numerical field offset. The field_offset starts at 0. If field_offset does not exist, an error of level E_WARNING is also issued.

Dönen Değerler

Maximum length, when process is successful.

FALSE on failure.

Örnekler

Örnek 1 cubrid_field_len() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");
$result = cubrid_execute($conn, "SELECT * FROM game WHERE host_year=2004 AND nation_code='AUS' AND medal='G'");

$column_names = cubrid_column_names($result);
$column_types = cubrid_column_types($result);

printf("%-30s %-30s %-15s\n", "Column Names", "Column Types", "Column Maxlen");
for($i = 0, $size = count($column_names); $i < $size; $i++) {
    $column_len = cubrid_field_len($result, $i);
    printf("%-30s %-30s %-15s\n", $column_names[$i], $column_types[$i], $column_len);
}

cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

Column Names                   Column Types                   Column Maxlen
host_year                      integer                        11
event_code                     integer                        11
athlete_code                   integer                        11
stadium_code                   integer                        11
nation_code                    char                           3
medal                          char                           1
game_date                      date                           10
cubrid_field_flags
cubrid_field_name
CUBRID MySQL Compatibility Functions


Return the name of the specified field index

cubrid_field_len
cubrid_field_seek
CUBRID MySQL Compatibility Functions
PHP Manual

cubrid_field_name

(PECL CUBRID >= 8.3.0)

cubrid_field_name — Return the name of the specified field index

Açıklama

string cubrid_field_name ( resource $result , int $field_offset )

This function returns the name of the specified field index on success or it returns FALSE on failure.

Değiştirgeler

result

result comes from a call to cubrid_execute()

field_offset

The numerical field offset. The field_offset starts at 0. If field_offset does not exist, an error of level E_WARNING is also issued.

Dönen Değerler

Name of specified field index, on success.

FALSE on failure.

Örnekler

Örnek 1 cubrid_field_name() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");
$result = cubrid_execute($conn, "SELECT * FROM game WHERE host_year=2004 AND nation_code='AUS' AND medal='G'");

$col_num = cubrid_num_cols($result);

printf("%-30s %s\n", "Field Name", "Field Flags");
for($i = 0; $i < $col_num; $i++) {
    printf("%-30s %s\n", cubrid_field_name($result, $i), cubrid_field_flags($result, $i));
}

cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

Field Name                     Field Flags
host_year                      not_null primary_key unique_key
event_code                     not_null primary_key unique_key foreign_key
athlete_code                   not_null primary_key unique_key foreign_key
stadium_code                   not_null
nation_code
medal
game_date
cubrid_field_len
cubrid_field_seek
CUBRID MySQL Compatibility Functions


Move the result set cursor to the specified field offset

cubrid_field_name
cubrid_field_table
CUBRID MySQL Compatibility Functions
PHP Manual

cubrid_field_seek

(PECL CUBRID >= 8.3.0)

cubrid_field_seek — Move the result set cursor to the specified field offset

Açıklama

bool cubrid_field_seek ( resource $result [, int $field_offset = 0 ] )

This function moves the result set cursor to the specified field offset. This offset is used by cubrid_fetch_field() if it doesn't include a field offset. It returns TRUE on success or FALSE on failure.

Değiştirgeler

result

result comes from a call to cubrid_execute()

field_offset

The numerical field offset. The field_offset starts at 0. If field_offset does not exist, an error of level E_WARNING is also issued.

Dönen Değerler

TRUE on success.

FALSE on failure.

Örnekler

Örnek 1 cubrid_field_seek() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");
$req = cubrid_execute($conn, "SELECT event_code,athlete_code,nation_code,game_date FROM game WHERE host_year=1988 and event_code=20001;");

var_dump(cubrid_fetch_row($req));

cubrid_field_seek($req, 1);
$field = cubrid_fetch_field($req);

printf("\n--- Field Properties ---\n");
printf("%-30s %s\n", "name:", $field->name);
printf("%-30s %s\n", "table:", $field->table);
printf("%-30s \"%s\"\n", "default value:", $field->def);
printf("%-30s %d\n", "max length:", $field->max_length);
printf("%-30s %d\n", "not null:", $field->not_null);
printf("%-30s %d\n", "unique key:", $field->unique_key);
printf("%-30s %d\n", "multiple key:", $field->multiple_key);
printf("%-30s %d\n", "numeric:", $field->numeric);
printf("%-30s %s\n", "type:", $field->type);

cubrid_close_request($req);

cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

array(4) {
  [0]=>
  string(5) "20001"
  [1]=>
  string(5) "16132"
  [2]=>
  string(3) "KOR"
  [3]=>
  string(9) "1988-09-30"
}

--- Field Properties ---
name:                          athlete_code
table:                         game
default value:                 ""
max length:                    0
not null:                      1
unique key:                    1
multiple key:                  0
numeric:                       1
type:                          integer
cubrid_field_name
cubrid_field_table
CUBRID MySQL Compatibility Functions


Return the name of the table of the specified field

cubrid_field_seek
cubrid_field_type
CUBRID MySQL Compatibility Functions
PHP Manual

cubrid_field_table

(PECL CUBRID >= 8.3.0)

cubrid_field_table — Return the name of the table of the specified field

Açıklama

string cubrid_field_table ( resource $result , int $field_offset )

This function returns the name of the table of the specified field. This is useful when using large select queries with JOINS.

Değiştirgeler

result

result comes from a call to cubrid_execute()

field_offset

The numerical field offset. The field_offset starts at 0. If field_offset does not exist, an error of level E_WARNING is also issued.

Dönen Değerler

Name of the table of the specified field, on success.

FALSE when invalid field_offset value.

-1 if SQL sentence is not SELECT.

Örnekler

Örnek 1 cubrid_field_table() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");
$result = cubrid_execute($conn, "SELECT * FROM code");

$col_num = cubrid_num_cols($result);

printf("%-15s %-15s %s\n", "Field Table", "Field Name", "Field Type");
for($i = 0; $i < $col_num; $i++) {
    printf("%-15s %-15s %s\n",
        cubrid_field_table($result, $i), cubrid_field_name($result, $i), cubrid_field_type($result, $i));
}

cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

Field Table     Field Name      Field Type
code            s_name          char
code            f_name          varchar
cubrid_field_seek
cubrid_field_type
CUBRID MySQL Compatibility Functions


Return the type of the column corresponding to the given field offset

cubrid_field_table
cubrid_list_dbs
CUBRID MySQL Compatibility Functions
PHP Manual

cubrid_field_type

(PECL CUBRID >= 8.3.0)

cubrid_field_type — Return the type of the column corresponding to the given field offset

Açıklama

string cubrid_field_type ( resource $result , int $field_offset )

This function returns the type of the column corresponding to the given field offset. The returned field type could be one of the following: "int", "real", "string", etc.

Değiştirgeler

result

result comes from a call to cubrid_execute()

field_offset

The numerical field offset. The field_offset starts at 0. If field_offset does not exist, an error of level E_WARNING is also issued.

Dönen Değerler

Type of the column, on success.

FALSE when invalid field_offset value.

-1 if SQL sentence is not SELECT.

Örnekler

Örnek 1 cubrid_field_type() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");
$result = cubrid_execute($conn, "SELECT * FROM code");

$col_num = cubrid_num_cols($result);

printf("%-15s %-15s %s\n", "Field Table", "Field Name", "Field Type");
for($i = 0; $i < $col_num; $i++) {
    printf("%-15s %-15s %s\n",
        cubrid_field_table($result, $i), cubrid_field_name($result, $i), cubrid_field_type($result, $i));
}

cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

Field Table     Field Name      Field Type
code            s_name          char
code            f_name          varchar
cubrid_field_table
cubrid_list_dbs
CUBRID MySQL Compatibility Functions


Return an array with the list of all existing CUBRID databases

cubrid_field_type
cubrid_num_fields
CUBRID MySQL Compatibility Functions
PHP Manual

cubrid_list_dbs

(PECL CUBRID >= 8.3.0)

cubrid_list_dbs — Return an array with the list of all existing CUBRID databases

Açıklama

array cubrid_list_dbs ([ resource $conn_identifier ] )

This function returns an array with the list of all existing Cubrid databases.

Değiştirgeler

conn_identifier

The CUBRID connection.

Dönen Değerler

An numeric array with all existing Cubrid databases; on success.

FALSE on failure.

Örnekler

Örnek 1 cubrid_list_dbs() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");

$db_list = cubrid_list_dbs($conn);
var_dump($db_list);

cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

array(1) {
  [0]=>
  string(6) "demodb"
}
cubrid_field_type
cubrid_num_fields
CUBRID MySQL Compatibility Functions


Return the number of columns in the result set

cubrid_list_dbs
cubrid_ping
CUBRID MySQL Compatibility Functions
PHP Manual

cubrid_num_fields

(PECL CUBRID >= 8.3.0)

cubrid_num_fields — Return the number of columns in the result set

Açıklama

int cubrid_num_fields ( resource $result )

This function returns the number of columns in the result set, on success, or it returns FALSE on failure.

Değiştirgeler

result

result comes from a call to cubrid_execute(), cubrid_query() and cubrid_prepare()

Dönen Değerler

Number of columns, on success.

-1 if SQL sentence is not SELECT.

FALSE when process is unsuccessful.

Örnekler

Örnek 1 cubrid_num_fields() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");

$req = cubrid_execute($conn, "SELECT * FROM code");

$row_num = cubrid_num_rows($req);
$col_num = cubrid_num_fields($req);

printf("Row Num: %d\nColumn Num: %d\n", $row_num, $col_num);

cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

Row Num: 6
Column Num: 2
cubrid_list_dbs
cubrid_ping
CUBRID MySQL Compatibility Functions


Ping a server connection or reconnect if there is no connection

cubrid_num_fields
cubrid_query
CUBRID MySQL Compatibility Functions
PHP Manual

cubrid_ping

(PECL CUBRID >= 8.3.1)

cubrid_ping — Ping a server connection or reconnect if there is no connection

Açıklama

bool cubrid_ping ([ resource $conn_identifier ] )

Checks whether or not the connection to the server is working.

Değiştirgeler

conn_identifier

The CUBRID connection identifier. If the connection identifier is not specified, the last connection opened by cubrid_connect() is assumed.

Dönen Değerler

Returns TRUE if the connection to the server CUBRID server is working, otherwise FALSE.

Örnekler

Örnek 1 cubrid_ping() example

<?php
set_time_limit(0);

$conn = cubrid_connect('localhost', 33000, 'demodb');

/* Assuming this query will take a long time */
$sql = "select * from athlete";
$result = cubrid_query($sql);
if (!$result) {
    echo 'Query #1 failed, exiting.';
    exit;
}

/* Make sure the connection is still alive, if not, try to reconnect */
if (!cubrid_ping($conn)) {
    echo 'Lost connection, exiting after query #1';
    exit;
}
cubrid_free_result($result);

/* So the connection is still alive, let's run another query */
$sql2 = "select * from code";
$result2 = cubrid_query($sql2);
?>

cubrid_num_fields
cubrid_query
CUBRID MySQL Compatibility Functions


Send a CUBRID query

cubrid_ping
cubrid_real_escape_string
CUBRID MySQL Compatibility Functions
PHP Manual

cubrid_query

(PECL CUBRID >= 8.3.1)

cubrid_query — Send a CUBRID query

Açıklama

resource cubrid_query ( string $query [, resource $conn_identifier ] )

cubrid_query() sends a unique query (multiple queries are not supported) to the currently active database on the server that's associated with the specified conn_identifier.

Değiştirgeler

query

An SQL query

Data inside the query should be properly escaped.

conn_identifier

The CUBRID connection. If the connection identifier is not specified, the last connection opened by cubrid_connect() is assumed.

Dönen Değerler

For SELECT, SHOW, DESCRIBE, EXPLAIN and other statements returning resultset, cubrid_query() returns a resource on success, or FALSE on error.

For other type of SQL statements, INSERT, UPDATE, DELETE, DROP, etc, cubrid_query() returns TRUE on success or FALSE on error.

The returned result resource should be passed to cubrid_fetch_array(), and other functions for dealing with result tables, to access the returned data.

Use cubrid_num_rows() to find out how many rows were returned for a SELECT statement or cubrid_affected_rows() to find out how many rows were affected by a DELETE, INSERT, REPLACE, or UPDATE statement.

cubrid_query() will also fail and return FALSE if the user does not have permission to access the table(s) referenced by the query.

Örnekler

Örnek 1 Invalid Query

The following query is syntactically invalid, so cubrid_query() fails and returns FALSE.

<?php
$conn = cubrid_connect('localhost', 33000, 'demodb');

$result = cubrid_query('SELECT * WHERE 1=1');
if (!$result) {
    die('Invalid query: ' . cubrid_error());
}

?>

Örnek 2 Valid Query

The following query is valid, so cubrid_query() returns a resource.

<?php
// This could be supplied by a user, for example
$firstname = 'fred';
$lastname  = 'fox';

$conn = cubrid_connect('localhost', 33000, 'demodb');

cubrid_execute($conn,"DROP TABLE if exists friends");
cubrid_execute($conn,"create table friends(firstname varchar,lastname varchar,address char(24),age int)");
cubrid_execute($conn,"insert into friends values('fred','fox','home-1','20')");
cubrid_execute($conn,"insert into friends values('blue','cat','home-2','21')");
// Formulate Query
// This is the best way to perform an SQL query
// For more examples, see cubrid_real_escape_string()
$query = sprintf("SELECT firstname, lastname, address, age FROM friends WHERE firstname='%s' AND lastname='%s'",
cubrid_real_escape_string($firstname),
cubrid_real_escape_string($lastname));

// Perform Query
$result = cubrid_query($query);

// Check result
// This shows the actual query sent to CUBRID, and the error. Useful for debugging.
if (!$result) {
    $message  = 'Invalid query: ' . cubrid_error() . "\n";
    $message .= 'Whole query: ' . $query;
    die($message);
}

// Use result
// Attempting to print $result won't allow access to information in the resource
// One of the cubrid result functions must be used
// See also cubrid_result(), cubrid_fetch_array(), cubrid_fetch_row(), etc.
while ($row = cubrid_fetch_assoc($result)) {
    echo $row['firstname'];
    echo $row['lastname'];
    echo $row['address'];
    echo $row['age'];
}

// Free the resources associated with the result set
// This is done automatically at the end of the script
cubrid_free_result($result);
?>

Ayrıca Bakınız

  • cubrid_connect() - Open a connection to a CUBRID Server
  • cubrid_error() - Get the error message
  • cubrid_real_escape_string() - Escape special characters in a string for use in an SQL statement
  • cubrid_result() - Return the value of a specific field in a specific row
  • cubrid_fetch_assoc() - Return the associative array that corresponds to the fetched row
  • cubrid_unbuffered_query() - Perform a query without fetching the results into memory

cubrid_ping
cubrid_real_escape_string
CUBRID MySQL Compatibility Functions


Escape special characters in a string for use in an SQL statement

cubrid_query
cubrid_result
CUBRID MySQL Compatibility Functions
PHP Manual

cubrid_real_escape_string

(PECL CUBRID >= 8.3.0)

cubrid_real_escape_string — Escape special characters in a string for use in an SQL statement

Açıklama

string cubrid_real_escape_string ( string $unescaped_string [, resource $conn_identifier ] )

This function returns the escaped string version of the given string. It will escape the following characters: '. In general, single quotations are used to enclose character string. Double quotations may be used as well depending on the value of ansi_quotes, which is a parameter related to SQL statement. If the ansi_quotes value is set to no, character string enclosed by double quotations is handled as character string, not as an identifier. The default value is yes. If you want to include a single quote as part of a character string, enter two single quotes in a row.

Değiştirgeler

unescaped_string

The string that is to be escaped.

conn_identifier

The CUBRID connection. If the connection identifier is not specified, the last connection opened by cubrid_connect() is assumed.

Dönen Değerler

Escaped string version of the given string, on success.

FALSE on failure.

Örnekler

Örnek 1 cubrid_real_escape_string() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");

$unescaped_str = ' !"#$%&\'()*+,-./0123456789:;<=>?@ABCDEFGHIJKLMNOPQRSTUVWXYZ[\]^_`abcdefghijklmnopqrstuvwxyz{|}~';
$escaped_str = cubrid_real_escape_string($unescaped_str);

$len = strlen($unescaped_str);

@cubrid_execute($conn, "DROP TABLE cubrid_test");
cubrid_execute($conn, "CREATE TABLE cubrid_test (t char($len))");
cubrid_execute($conn, "INSERT INTO cubrid_test (t) VALUES('$escaped_str')");

$req = cubrid_execute($conn, "SELECT * FROM cubrid_test");
$row = cubrid_fetch_assoc($req);

var_dump($row);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

array(1) {
  ["t"]=>
  string(95) " !"#$%&'()*+,-./0123456789:;<=>?@ABCDEFGHIJKLMNOPQRSTUVWXYZ[\]^_`abcdefghijklmnopqrstuvwxyz{|}~"
}
cubrid_query
cubrid_result
CUBRID MySQL Compatibility Functions


Return the value of a specific field in a specific row

cubrid_real_escape_string
cubrid_unbuffered_query
CUBRID MySQL Compatibility Functions
PHP Manual

cubrid_result

(PECL CUBRID >= 8.3.0)

cubrid_result — Return the value of a specific field in a specific row

Açıklama

string cubrid_result ( resource $result , int $row [, mixed $field = 0 ] )

This function returns the value of a specific field in a specific row from a result set.

Değiştirgeler

result

result comes from a call to cubrid_execute()

row

The row number from the result that is being retrieved. Row numbers start at 0.

field

The name or offset of the field being retrieved. It can be the field's offset, the field's name, or the field's table dot field name (tablename.fieldname). If the column name has been aliased ('select foo as bar from...'), use the alias instead of the column name. If undefined, the first field is retrieved.

Dönen Değerler

Value of a specific field, on success (NULL if value if null).

FALSE on failure.

Örnekler

Örnek 1 cubrid_result() example

<?php
$conn = cubrid_connect("localhost", 33000, "demodb");

$req = cubrid_execute($conn, "SELECT * FROM code");

$result = cubrid_result($req, 0);
var_dump($result);

$result = cubrid_result($req, 0, 1);
var_dump($result);

$result = cubrid_result($req, 5, "f_name");
var_dump($result);

cubrid_close_request($req);
cubrid_disconnect($conn);
?>

Yukarıdaki örneğin çıktısı:

string(1) "X"
string(5) "Mixed"
string(4) "Gold"
cubrid_real_escape_string
cubrid_unbuffered_query
CUBRID MySQL Compatibility Functions


Perform a query without fetching the results into memory

cubrid_result
CUBRID Obsolete Aliases and Functions
CUBRID MySQL Compatibility Functions
PHP Manual

cubrid_unbuffered_query

(PECL CUBRID >= 8.3.0)

cubrid_unbuffered_query — Perform a query without fetching the results into memory

Açıklama

resource cubrid_unbuffered_query ( string $query [, resource $conn_identifier ] )

This function performs a query without waiting for that all query results have been complete. It will return when the results are being generated.

Değiştirgeler

query

A SQL query.

conn_identifier

The CUBRID connection. If the connection identifier is not specified, the last connection opened by cubrid_connect() is assumed.

Dönen Değerler

For SELECT, SHOW, DESCRIBE or EXPLAIN statements returns a request identifier resource on success.

For other type of SQL statements, UPDATE, DELETE, DROP, etc, returns TRUE on success.

FALSE on failure.

Notlar

Bilginize:

The benefits of cubrid_unbuffered_query() come at a cost: you cannot use cubrid_num_rows() and cubrid_data_seek() on a result set returned from cubrid_unbuffered_query().

Örnekler

Örnek 1 cubrid_unbuffered_query() example

<?php
    $link = cubrid_connect("localhost", 30000, "demodb", "dba", "");
    if (!$link)
    {
        die('Could not connect.');
    }
    $query = "select * from code";
    $result = cubrid_unbuffered_query($query, $link);

    while ($row = cubrid_fetch($result))
    {
        var_dump($row);
    }

    cubrid_close_request($result);
    cubrid_disconnect($link);
?>
cubrid_result
CUBRID Obsolete Aliases and Functions
CUBRID MySQL Compatibility Functions


CUBRID Obsolete Aliases and Functions

İçindekiler

  • cubrid_load_from_glo — Read data from a GLO instance and save it in a file
  • cubrid_new_glo — Create a glo instance
  • cubrid_save_to_glo — Save requested file in a GLO instance
  • cubrid_send_glo — Read data from glo and send it to std output
cubrid_unbuffered_query
cubrid_load_from_glo
CUBRID


Read data from a GLO instance and save it in a file

CUBRID Obsolete Aliases and Functions
cubrid_new_glo
CUBRID Obsolete Aliases and Functions
PHP Manual

cubrid_load_from_glo

(PECL CUBRID >= 8.3.0)

cubrid_load_from_glo — Read data from a GLO instance and save it in a file

Açıklama

int cubrid_load_from_glo ( resource $conn_identifier , string $oid , string $file_name )

The cubrid_load_from_glo() function is used to read a data from a glo instance, and saves it in a designated file.

Değiştirgeler

conn_identifier

Connection identifier.

oid

Oid of the glo instance that you want to read the data from.

file_name

Name of the file where you want to save the data in.

Dönen Değerler

TRUE, when process is successful.

FALSE, when process is unsuccessful.

Örnekler

Örnek 1 cubrid_load_from_glo() example

<?php
$req = cubrid_execute ($con, "select image from person where id=1");
if ($req) {
   list ($oid) = cubrid_fetch($req);
   cubrid_close_request($req);
   $res = cubrid_load_from_glo ($con, $oid, "output.jpg");
   if ($res) {
      echo "image changed successfully";
   }
}
?>

Notlar

Bilginize:

Geriye uyumluluk adına, kullanımı önerilmese de şu takma adı kullanabilirsiniz: cubrid_load_from_glo()

Bilginize:

This function is removed from CUBRID 3.1.

Ayrıca Bakınız

  • cubrid_new_glo() - Create a glo instance
  • cubrid_save_to_glo() - Save requested file in a GLO instance
  • cubrid_send_glo() - Read data from glo and send it to std output

CUBRID Obsolete Aliases and Functions
cubrid_new_glo
CUBRID Obsolete Aliases and Functions


Create a glo instance

cubrid_load_from_glo
cubrid_save_to_glo
CUBRID Obsolete Aliases and Functions
PHP Manual

cubrid_new_glo

(PECL CUBRID >= 8.3.0)

cubrid_new_glo — Create a glo instance

Açıklama

string cubrid_new_glo ( resource $conn_identifier , string $class_name , string $file_name )

The cubrid_new_glo() function is used to create a glo instance in the requested class (glo class). The glo created is a LO type, and is stored in the file_name file.

Değiştirgeler

conn_identifier

Connection identifier.

class_name

Name of the class that you want to create a glo in.

file_name

The file name that you want to save in the newly created glo.

Dönen Değerler

Oid of the instance created, when process is successful.

FALSE, when process is unsuccessful.

Örnekler

Örnek 1 cubrid_new_glo() example

<?php
$oid = cubrid_new_glo ($con, "glo", "input.jpg");
if ($oid){
   // the type of column "image" is "object"
   $req = cubrid_execute ($con, "insert into person(image) values($oid)");
   if ($req) {
      echo "image inserted successfully";
      cubrid_close_request ($req);
      cubrid_commit($con);
   }
}
?>

Notlar

Bilginize:

Geriye uyumluluk adına, kullanımı önerilmese de şu takma adı kullanabilirsiniz: cubrid_new_glo()

Bilginize:

This function is removed from CUBRID 3.1.

Ayrıca Bakınız

  • cubrid_save_to_glo() - Save requested file in a GLO instance
  • cubrid_load_from_glo() - Read data from a GLO instance and save it in a file
  • cubrid_send_glo() - Read data from glo and send it to std output

cubrid_load_from_glo
cubrid_save_to_glo
CUBRID Obsolete Aliases and Functions


Save requested file in a GLO instance

cubrid_new_glo
cubrid_send_glo
CUBRID Obsolete Aliases and Functions
PHP Manual

cubrid_save_to_glo

(PECL CUBRID >= 8.3.0)

cubrid_save_to_glo — Save requested file in a GLO instance

Açıklama

int cubrid_save_to_glo ( resource $conn_identifier , string $oid , string $file_name )

The cubrid_save_to_glo() function is used to save requested file in a glo instance.

Değiştirgeler

conn_identifier

Connection identifier.

oid

Oid of the glo instance that you want to save a file in.

file_name

The name of the file that you want to save.

Dönen Değerler

TRUE, when process is successful.

FALSE, when process is unsuccessful.

Örnekler

Örnek 1 cubrid_save_to_glo() example

<?php
$req = cubrid_execute ($con, "select image from person where id=1");
if ($req) {
   list ($oid) = cubrid_fetch($req);
   cubrid_close_request($req);
   $res = cubrid_save_to_glo ($con, $oid, "input.jpg");
   if ($res) {
      echo "image changed successfully";
   }
}
?>

Notlar

Bilginize:

Geriye uyumluluk adına, kullanımı önerilmese de şu takma adı kullanabilirsiniz: cubrid_save_to_glo()

Bilginize:

This function is removed from CUBRID 3.1.

Ayrıca Bakınız

  • cubrid_new_glo() - Create a glo instance
  • cubrid_load_from_glo() - Read data from a GLO instance and save it in a file
  • cubrid_send_glo() - Read data from glo and send it to std output

cubrid_new_glo
cubrid_send_glo
CUBRID Obsolete Aliases and Functions


Read data from glo and send it to std output

cubrid_save_to_glo
DB++
CUBRID Obsolete Aliases and Functions
PHP Manual

cubrid_send_glo

(PECL CUBRID >= 8.3.0)

cubrid_send_glo — Read data from glo and send it to std output

Açıklama

int cubrid_send_glo ( resource $conn_identifier , string $oid )

The cubrid_send_glo() function is used to read data from glo instance and sends it to the PHP standard output.

Değiştirgeler

conn_identifier

Connection identifier.

oid

Oid of the glo instance that you want to read data from.

Dönen Değerler

TRUE, when process is successful.

FALSE, when process is unsuccessful.

Örnekler

Örnek 1 cubrid_send_glo() example

<?php
$req = cubrid_execute ($con, "select image from person where id =1");
if ($req) {
  list ($oid) = cubrid_fetch($req);
  cubrid_close_request($req);
  Header ("Content-type: image/jpeg");
  cubrid_send_glo ($con, $oid);
}
?>

Notlar

Bilginize:

Geriye uyumluluk adına, kullanımı önerilmese de şu takma adı kullanabilirsiniz: cubrid_send_glo()

Bilginize:

This function is removed from CUBRID 3.1.

Ayrıca Bakınız

  • cubrid_new_glo() - Create a glo instance
  • cubrid_save_to_glo() - Save requested file in a GLO instance
  • cubrid_load_from_glo() - Read data from a GLO instance and save it in a file

cubrid_save_to_glo
DB++
CUBRID Obsolete Aliases and Functions


DB++

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
    • db++ error codes
  • DB++ İşlevleri
    • dbplus_add — Add a tuple to a relation
    • dbplus_aql — Perform AQL query
    • dbplus_chdir — Get/Set database virtual current directory
    • dbplus_close — Close a relation
    • dbplus_curr — Get current tuple from relation
    • dbplus_errcode — Get error string for given errorcode or last error
    • dbplus_errno — Get error code for last operation
    • dbplus_find — Set a constraint on a relation
    • dbplus_first — Get first tuple from relation
    • dbplus_flush — Flush all changes made on a relation
    • dbplus_freealllocks — Free all locks held by this client
    • dbplus_freelock — Release write lock on tuple
    • dbplus_freerlocks — Free all tuple locks on given relation
    • dbplus_getlock — Get a write lock on a tuple
    • dbplus_getunique — Get an id number unique to a relation
    • dbplus_info — Get information about a relation
    • dbplus_last — Get last tuple from relation
    • dbplus_lockrel — Request write lock on relation
    • dbplus_next — Get next tuple from relation
    • dbplus_open — Open relation file
    • dbplus_prev — Get previous tuple from relation
    • dbplus_rchperm — Change relation permissions
    • dbplus_rcreate — Creates a new DB++ relation
    • dbplus_rcrtexact — Creates an exact but empty copy of a relation including indices
    • dbplus_rcrtlike — Creates an empty copy of a relation with default indices
    • dbplus_resolve — Resolve host information for relation
    • dbplus_restorepos — Restore position
    • dbplus_rkeys — Specify new primary key for a relation
    • dbplus_ropen — Open relation file local
    • dbplus_rquery — Perform local (raw) AQL query
    • dbplus_rrename — Rename a relation
    • dbplus_rsecindex — Create a new secondary index for a relation
    • dbplus_runlink — Remove relation from filesystem
    • dbplus_rzap — Remove all tuples from relation
    • dbplus_savepos — Save position
    • dbplus_setindex — Set index
    • dbplus_setindexbynumber — Set index by number
    • dbplus_sql — Perform SQL query
    • dbplus_tcl — Execute TCL code on server side
    • dbplus_tremove — Remove tuple and return new current tuple
    • dbplus_undo — Undo
    • dbplus_undoprepare — Prepare undo
    • dbplus_unlockrel — Give up write lock on relation
    • dbplus_unselect — Remove a constraint from relation
    • dbplus_update — Update specified tuple in relation
    • dbplus_xlockrel — Request exclusive lock on relation
    • dbplus_xunlockrel — Free exclusive lock on relation
cubrid_send_glo
Giriş
Sağlayıcıya Göre Veritabanı Eklentileri


Giriş

db++, made by the German company » Concept asa, is a relational database system with high performance and low memory and disk usage in mind. While providing SQL as an additional language interface, it is not really an SQL database in the first place but provides its own AQL query language which is much more influenced by the relational algebra than SQL is.

Concept asa always had an interest in supporting open source languages, db++ has had Perl and Tcl call interfaces for years now and uses Tcl as its internal stored procedure language.

Uyarı

Bu eklenti DENEYSELDİR. Bu eklentinin davranışı, işlev isimleri ve tüm belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu eklentiyi kullanmayın.

DB++
Yapılandırma/Kurulum
DB++


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
DB++


Gereksinimler

This extension relies on external client libraries so you have to have a db++ client installed on the system you want to use this extension on.

» Concept asa provides » db++ Demo versions and » documentation for Linux, some other Unix versions. There is also a Windows version of db++, but this extension doesn't support it (yet).

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

In order to build this extension yourself you need the db++ client libraries and header files to be installed on your system (these are included in the db++ installation archives by default). You have to run configure with option --with-dbplus to build this extension.

configure looks for the client libraries and header files under the default paths /usr/dbplus, /usr/local/dbplus and /opt/dblus. If you have installed db++ in a different place you have add the installation path to the configure option like this: --with-dbplus=/your/installation/path .

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Özkaynak Türleri

dbplus_relation

Most db++ functions operate on or return dbplus_relation resources. A dbplus_relation is a handle to a stored relation or a relation generated as the result of a query.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

İçindekiler

  • db++ error codes

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

Özkaynak Türleri
db++ error codes
DB++


db++ error codes

DB++ Error Codes
PHP Constant | db++ constant | meaning
DBPLUS_ERR_NOERR (integer) | ERR_NOERR | Null error condition
DBPLUS_ERR_DUPLICATE (integer) | ERR_DUPLICATE | Tried to insert a duplicate tuple
DBPLUS_ERR_EOSCAN (integer) | ERR_EOSCAN | End of scan from rget()
DBPLUS_ERR_EMPTY (integer) | ERR_EMPTY | Relation is empty (server)
DBPLUS_ERR_CLOSE (integer) | ERR_CLOSE | The server can't close
DBPLUS_ERR_WLOCKED (integer) | ERR_WLOCKED | The record is write locked
DBPLUS_ERR_LOCKED (integer) | ERR_LOCKED | Relation was already locked
DBPLUS_ERR_NOLOCK (integer) | ERR_NOLOCK | Relation cannot be locked
DBPLUS_ERR_READ (integer) | ERR_READ | Read error on relation
DBPLUS_ERR_WRITE (integer) | ERR_WRITE | Write error on relation
DBPLUS_ERR_CREATE (integer) | ERR_CREATE | Create() system call failed
DBPLUS_ERR_LSEEK (integer) | ERR_LSEEK | Lseek() system call failed
DBPLUS_ERR_LENGTH (integer) | ERR_LENGTH | Tuple exceeds maximum length
DBPLUS_ERR_OPEN (integer) | ERR_OPEN | Open() system call failed
DBPLUS_ERR_WOPEN (integer) | ERR_WOPEN | Relation already opened for writing
DBPLUS_ERR_MAGIC (integer) | ERR_MAGIC | File is not a relation
DBPLUS_ERR_VERSION (integer) | ERR_VERSION | File is a very old relation
DBPLUS_ERR_PGSIZE (integer) | ERR_PGSIZE | Relation uses a different page size
DBPLUS_ERR_CRC (integer) | ERR_CRC | Invalid crc in the superpage
DBPLUS_ERR_PIPE (integer) | ERR_PIPE | Piped relation requires lseek()
DBPLUS_ERR_NIDX (integer) | ERR_NIDX | Too many secondary indices
DBPLUS_ERR_MALLOC (integer) | ERR_MALLOC | Malloc() call failed
DBPLUS_ERR_NUSERS (integer) | ERR_NUSERS | Error use of max users
DBPLUS_ERR_PREEXIT (integer) | ERR_PREEXIT | Caused by invalid usage
DBPLUS_ERR_ONTRAP (integer) | ERR_ONTRAP | Caused by a signal
DBPLUS_ERR_PREPROC (integer) | ERR_PREPROC | Error in the preprocessor
DBPLUS_ERR_DBPARSE (integer) | ERR_DBPARSE | Error in the parser
DBPLUS_ERR_DBRUNERR (integer) | ERR_DBRUNERR | Run error in db
DBPLUS_ERR_DBPREEXIT (integer) | ERR_DBPREEXIT | Exit condition caused by prexit() * procedure
DBPLUS_ERR_WAIT (integer) | ERR_WAIT | Wait a little (Simple only)
DBPLUS_ERR_CORRUPT_TUPLE (integer) | ERR_CORRUPT_TUPLE | A client sent a corrupt tuple
DBPLUS_ERR_WARNING0 (integer) | ERR_WARNING0 | The Simple routines encountered a non fatal error which was corrected
DBPLUS_ERR_PANIC (integer) | ERR_PANIC | The server should not really die but after a disaster send ERR_PANIC to all its clients
DBPLUS_ERR_FIFO (integer) | ERR_FIFO | Can't create a fifo
DBPLUS_ERR_PERM (integer) | ERR_PERM | Permission denied
DBPLUS_ERR_TCL (integer) | ERR_TCL | TCL_error
DBPLUS_ERR_RESTRICTED (integer) | ERR_RESTRICTED | Only two users
DBPLUS_ERR_USER (integer) | ERR_USER | An error in the use of the library by an application programmer
DBPLUS_ERR_UNKNOWN (integer) | ERR_UNKNOWN |

Öntanımlı Sabitler
DB++ İşlevleri
Öntanımlı Sabitler


DB++ İşlevleri

İçindekiler

  • dbplus_add — Add a tuple to a relation
  • dbplus_aql — Perform AQL query
  • dbplus_chdir — Get/Set database virtual current directory
  • dbplus_close — Close a relation
  • dbplus_curr — Get current tuple from relation
  • dbplus_errcode — Get error string for given errorcode or last error
  • dbplus_errno — Get error code for last operation
  • dbplus_find — Set a constraint on a relation
  • dbplus_first — Get first tuple from relation
  • dbplus_flush — Flush all changes made on a relation
  • dbplus_freealllocks — Free all locks held by this client
  • dbplus_freelock — Release write lock on tuple
  • dbplus_freerlocks — Free all tuple locks on given relation
  • dbplus_getlock — Get a write lock on a tuple
  • dbplus_getunique — Get an id number unique to a relation
  • dbplus_info — Get information about a relation
  • dbplus_last — Get last tuple from relation
  • dbplus_lockrel — Request write lock on relation
  • dbplus_next — Get next tuple from relation
  • dbplus_open — Open relation file
  • dbplus_prev — Get previous tuple from relation
  • dbplus_rchperm — Change relation permissions
  • dbplus_rcreate — Creates a new DB++ relation
  • dbplus_rcrtexact — Creates an exact but empty copy of a relation including indices
  • dbplus_rcrtlike — Creates an empty copy of a relation with default indices
  • dbplus_resolve — Resolve host information for relation
  • dbplus_restorepos — Restore position
  • dbplus_rkeys — Specify new primary key for a relation
  • dbplus_ropen — Open relation file local
  • dbplus_rquery — Perform local (raw) AQL query
  • dbplus_rrename — Rename a relation
  • dbplus_rsecindex — Create a new secondary index for a relation
  • dbplus_runlink — Remove relation from filesystem
  • dbplus_rzap — Remove all tuples from relation
  • dbplus_savepos — Save position
  • dbplus_setindex — Set index
  • dbplus_setindexbynumber — Set index by number
  • dbplus_sql — Perform SQL query
  • dbplus_tcl — Execute TCL code on server side
  • dbplus_tremove — Remove tuple and return new current tuple
  • dbplus_undo — Undo
  • dbplus_undoprepare — Prepare undo
  • dbplus_unlockrel — Give up write lock on relation
  • dbplus_unselect — Remove a constraint from relation
  • dbplus_update — Update specified tuple in relation
  • dbplus_xlockrel — Request exclusive lock on relation
  • dbplus_xunlockrel — Free exclusive lock on relation
db++ error codes
dbplus_add
DB++


Add a tuple to a relation

DB++ İşlevleri
dbplus_aql
DB++ İşlevleri
PHP Manual

dbplus_add

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_add — Add a tuple to a relation

Açıklama

int dbplus_add ( resource $relation , array $tuple )

Adds a tuple to a relation.

Değiştirgeler

relation

tuple

An array of attribute/value pairs to be inserted into the given relation.

After successful execution this array will contain the complete data of the newly created tuple, including all implicitly set domain fields like sequences.

Dönen Değerler

The function will return DBPLUS_ERR_NOERR on success or a db++ error code on failure.

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Ayrıca Bakınız

  • dbplus_errcode() - Get error string for given errorcode or last error

DB++ İşlevleri
dbplus_aql
DB++ İşlevleri


Perform AQL query

dbplus_add
dbplus_chdir
DB++ İşlevleri
PHP Manual

dbplus_aql

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_aql — Perform AQL query

Açıklama

resource dbplus_aql ( string $query [, string $server [, string $dbpath ]] )

Executes an AQL query on the given server and dbpath.

Değiştirgeler

query

The AQL query to be executed. Further information on the AQL (Algebraic Query Language) is provided in the original db++ manual.

server

dbpath

Dönen Değerler

Returns a relation handle on success. The result data may be fetched from this relation by calling dbplus_next() and dbplus_curr(). Other relation access functions will not work on a result relation.

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

dbplus_add
dbplus_chdir
DB++ İşlevleri


Get/Set database virtual current directory

dbplus_aql
dbplus_close
DB++ İşlevleri
PHP Manual

dbplus_chdir

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_chdir — Get/Set database virtual current directory

Açıklama

string dbplus_chdir ([ string $newdir ] )

Changes the virtual current directory where relation files will be looked for by dbplus_open().

Değiştirgeler

newdir

The new directory for relation files. You can omit this parameter to query the current working directory.

Dönen Değerler

Returns the absolute path of the current directory.

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

dbplus_aql
dbplus_close
DB++ İşlevleri


Close a relation

dbplus_chdir
dbplus_curr
DB++ İşlevleri
PHP Manual

dbplus_close

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_close — Close a relation

Açıklama

mixed dbplus_close ( resource $relation )

Closes a relation previously opened by dbplus_open().

Değiştirgeler

relation

A relation opened by dbplus_open().

Dönen Değerler

Returns TRUE on success or DBPLUS_ERR_UNKNOWN on failure.

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

dbplus_chdir
dbplus_curr
DB++ İşlevleri


Get current tuple from relation

dbplus_close
dbplus_errcode
DB++ İşlevleri
PHP Manual

dbplus_curr

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_curr — Get current tuple from relation

Açıklama

int dbplus_curr ( resource $relation , array &$tuple )

Reads the data for the current tuple for the given relation.

Değiştirgeler

relation

A relation opened by dbplus_open().

tuple

The data will be passed back in this parameter, as an associative array.

Dönen Değerler

The function will return zero (aka. DBPLUS_ERR_NOERR) on success or a db++ error code on failure.

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Ayrıca Bakınız

  • dbplus_first() - Get first tuple from relation
  • dbplus_prev() - Get previous tuple from relation
  • dbplus_next() - Get next tuple from relation
  • dbplus_last() - Get last tuple from relation
  • dbplus_errcode() - Get error string for given errorcode or last error

dbplus_close
dbplus_errcode
DB++ İşlevleri


Get error string for given errorcode or last error

dbplus_curr
dbplus_errno
DB++ İşlevleri
PHP Manual

dbplus_errcode

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_errcode — Get error string for given errorcode or last error

Açıklama

string dbplus_errcode ([ int $errno ] )

Returns a clear error string for the given error code.

Değiştirgeler

errno

The error code. If not provided, the result code of the last db++ operation is assumed.

Dönen Değerler

Returns the error message.

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

dbplus_curr
dbplus_errno
DB++ İşlevleri


Get error code for last operation

dbplus_errcode
dbplus_find
DB++ İşlevleri
PHP Manual

dbplus_errno

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_errno — Get error code for last operation

Açıklama

int dbplus_errno ( void )

Returns the error code returned by the last db++ operation.

Dönen Değerler

Returns the error code, as an integer.

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Ayrıca Bakınız

  • dbplus_errcode() - Get error string for given errorcode or last error

dbplus_errcode
dbplus_find
DB++ İşlevleri


Set a constraint on a relation

dbplus_errno
dbplus_first
DB++ İşlevleri
PHP Manual

dbplus_find

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_find — Set a constraint on a relation

Açıklama

int dbplus_find ( resource $relation , array $constraints , mixed $tuple )

Places a constraint on the given relation.

Further calls to functions like dbplus_curr() or dbplus_next() will only return tuples matching the given constraints.

Değiştirgeler

relation

A relation opened by dbplus_open().

constraints

Constraints are triplets of strings containing of a domain name, a comparison operator and a comparison value. The constraints parameter array may consist of a collection of string arrays, each of which contains a domain, an operator and a value, or of a single string array containing a multiple of three elements.

The comparison operator may be one of the following strings: '==', '>', '>=', '<', '<=', '!=', '~' for a regular expression match and 'BAND' or 'BOR' for bitwise operations.

tuple

Dönen Değerler

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Ayrıca Bakınız

  • dbplus_unselect() - Remove a constraint from relation

dbplus_errno
dbplus_first
DB++ İşlevleri


Get first tuple from relation

dbplus_find
dbplus_flush
DB++ İşlevleri
PHP Manual

dbplus_first

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_first — Get first tuple from relation

Açıklama

int dbplus_first ( resource $relation , array &$tuple )

Reads the data for the first tuple for the given relation, makes it the current tuple and pass it back as an associative array in tuple.

Değiştirgeler

relation

A relation opened by dbplus_open().

tuple

Dönen Değerler

Returns DBPLUS_ERR_NOERR on success or a db++ error code on failure.

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Ayrıca Bakınız

  • dbplus_curr() - Get current tuple from relation
  • dbplus_prev() - Get previous tuple from relation
  • dbplus_next() - Get next tuple from relation
  • dbplus_last() - Get last tuple from relation
  • dbplus_errcode() - Get error string for given errorcode or last error

dbplus_find
dbplus_flush
DB++ İşlevleri


Flush all changes made on a relation

dbplus_first
dbplus_freealllocks
DB++ İşlevleri
PHP Manual

dbplus_flush

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_flush — Flush all changes made on a relation

Açıklama

int dbplus_flush ( resource $relation )

Writes all changes applied to relation since the last flush to disk.

Değiştirgeler

relation

A relation opened by dbplus_open().

Dönen Değerler

Returns DBPLUS_ERR_NOERR on success or a db++ error code on failure.

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Ayrıca Bakınız

  • dbplus_errcode() - Get error string for given errorcode or last error

dbplus_first
dbplus_freealllocks
DB++ İşlevleri


Free all locks held by this client

dbplus_flush
dbplus_freelock
DB++ İşlevleri
PHP Manual

dbplus_freealllocks

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_freealllocks — Free all locks held by this client

Açıklama

int dbplus_freealllocks ( void )

Frees all tuple locks held by this client.

Dönen Değerler

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Ayrıca Bakınız

  • dbplus_getlock() - Get a write lock on a tuple
  • dbplus_freelock() - Release write lock on tuple
  • dbplus_freerlocks() - Free all tuple locks on given relation

dbplus_flush
dbplus_freelock
DB++ İşlevleri


Release write lock on tuple

dbplus_freealllocks
dbplus_freerlocks
DB++ İşlevleri
PHP Manual

dbplus_freelock

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_freelock — Release write lock on tuple

Açıklama

int dbplus_freelock ( resource $relation , string $tuple )

Releases a write lock on the given tuple previously obtained by dbplus_getlock().

Değiştirgeler

relation

A relation opened by dbplus_open().

tuple

Dönen Değerler

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Ayrıca Bakınız

  • dbplus_getlock() - Get a write lock on a tuple
  • dbplus_freerlocks() - Free all tuple locks on given relation
  • dbplus_freealllocks() - Free all locks held by this client

dbplus_freealllocks
dbplus_freerlocks
DB++ İşlevleri


Free all tuple locks on given relation

dbplus_freelock
dbplus_getlock
DB++ İşlevleri
PHP Manual

dbplus_freerlocks

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_freerlocks — Free all tuple locks on given relation

Açıklama

int dbplus_freerlocks ( resource $relation )

Frees all tuple locks held on the given relation.

Değiştirgeler

relation

A relation opened by dbplus_open().

Dönen Değerler

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Ayrıca Bakınız

  • dbplus_getlock() - Get a write lock on a tuple
  • dbplus_freelock() - Release write lock on tuple
  • dbplus_freealllocks() - Free all locks held by this client

dbplus_freelock
dbplus_getlock
DB++ İşlevleri


Get a write lock on a tuple

dbplus_freerlocks
dbplus_getunique
DB++ İşlevleri
PHP Manual

dbplus_getlock

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_getlock — Get a write lock on a tuple

Açıklama

int dbplus_getlock ( resource $relation , string $tuple )

Requests a write lock on the specified tuple.

Değiştirgeler

relation

A relation opened by dbplus_open().

tuple

Dönen Değerler

Returns zero on success or a non-zero error code, especially DBPLUS_ERR_WLOCKED on failure.

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Ayrıca Bakınız

  • dbplus_freelock() - Release write lock on tuple
  • dbplus_freerlocks() - Free all tuple locks on given relation
  • dbplus_freealllocks() - Free all locks held by this client

dbplus_freerlocks
dbplus_getunique
DB++ İşlevleri


Get an id number unique to a relation

dbplus_getlock
dbplus_info
DB++ İşlevleri
PHP Manual

dbplus_getunique

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_getunique — Get an id number unique to a relation

Açıklama

int dbplus_getunique ( resource $relation , int $uniqueid )

Obtains a number guaranteed to be unique for the given relation and will pass it back in the variable given as uniqueid.

Değiştirgeler

relation

A relation opened by dbplus_open().

uniqueid

Dönen Değerler

Returns DBPLUS_ERR_NOERR on success or a db++ error code on failure.

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

dbplus_getlock
dbplus_info
DB++ İşlevleri


Get information about a relation

dbplus_getunique
dbplus_last
DB++ İşlevleri
PHP Manual

dbplus_info

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_info — Get information about a relation

Açıklama

int dbplus_info ( resource $relation , string $key , array &$result )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

relation

A relation opened by dbplus_open().

key

result

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

dbplus_getunique
dbplus_last
DB++ İşlevleri


Get last tuple from relation

dbplus_info
dbplus_lockrel
DB++ İşlevleri
PHP Manual

dbplus_last

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_last — Get last tuple from relation

Açıklama

int dbplus_last ( resource $relation , array &$tuple )

Reads the data for the last tuple for the given relation, makes it the current tuple and pass it back as an associative array in tuple.

Değiştirgeler

relation

A relation opened by dbplus_open().

tuple

Dönen Değerler

Returns DBPLUS_ERR_NOERR on success or a db++ error code on failure.

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Ayrıca Bakınız

  • dbplus_first() - Get first tuple from relation
  • dbplus_curr() - Get current tuple from relation
  • dbplus_prev() - Get previous tuple from relation
  • dbplus_next() - Get next tuple from relation

dbplus_info
dbplus_lockrel
DB++ İşlevleri


Request write lock on relation

dbplus_last
dbplus_next
DB++ İşlevleri
PHP Manual

dbplus_lockrel

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_lockrel — Request write lock on relation

Açıklama

int dbplus_lockrel ( resource $relation )

Requests a write lock on the given relation.

Other clients may still query the relation, but can't alter it while it is locked.

Değiştirgeler

relation

A relation opened by dbplus_open().

Dönen Değerler

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

dbplus_last
dbplus_next
DB++ İşlevleri


Get next tuple from relation

dbplus_lockrel
dbplus_open
DB++ İşlevleri
PHP Manual

dbplus_next

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_next — Get next tuple from relation

Açıklama

int dbplus_next ( resource $relation , array &$tuple )

Reads the data for the next tuple for the given relation, makes it the current tuple and will pass it back as an associative array in tuple.

Değiştirgeler

relation

A relation opened by dbplus_open().

tuple

Dönen Değerler

Returns DBPLUS_ERR_NOERR on success or a db++ error code on failure.

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Ayrıca Bakınız

  • dbplus_first() - Get first tuple from relation
  • dbplus_curr() - Get current tuple from relation
  • dbplus_prev() - Get previous tuple from relation
  • dbplus_last() - Get last tuple from relation

dbplus_lockrel
dbplus_open
DB++ İşlevleri


Open relation file

dbplus_next
dbplus_prev
DB++ İşlevleri
PHP Manual

dbplus_open

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_open — Open relation file

Açıklama

resource dbplus_open ( string $name )

Opens the given relation file.

Değiştirgeler

name

Can be either a file name or a relative or absolute path name. This will be mapped in any case to an absolute relation file path on a specific host machine and server.

Dönen Değerler

On success a relation file resource (cursor) is returned which must be used in any subsequent commands referencing the relation. Failure leads to a zero return value, the actual error code may be asked for by calling dbplus_errno().

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

dbplus_next
dbplus_prev
DB++ İşlevleri


Get previous tuple from relation

dbplus_open
dbplus_rchperm
DB++ İşlevleri
PHP Manual

dbplus_prev

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_prev — Get previous tuple from relation

Açıklama

int dbplus_prev ( resource $relation , array &$tuple )

Reads the data for the previous tuple for the given relation, makes it the current tuple and will pass it back as an associative array in tuple.

Değiştirgeler

relation

A relation opened by dbplus_open().

tuple

Dönen Değerler

Returns DBPLUS_ERR_NOERR on success or a db++ error code on failure.

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Ayrıca Bakınız

  • dbplus_first() - Get first tuple from relation
  • dbplus_curr() - Get current tuple from relation
  • dbplus_next() - Get next tuple from relation
  • dbplus_last() - Get last tuple from relation

dbplus_open
dbplus_rchperm
DB++ İşlevleri


Change relation permissions

dbplus_prev
dbplus_rcreate
DB++ İşlevleri
PHP Manual

dbplus_rchperm

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_rchperm — Change relation permissions

Açıklama

int dbplus_rchperm ( resource $relation , int $mask , string $user , string $group )

Changes access permissions as specified by mask, user and group. The values for these are operating system specific.

Değiştirgeler

relation

A relation opened by dbplus_open().

mask

user

group

Dönen Değerler

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

dbplus_prev
dbplus_rcreate
DB++ İşlevleri


Creates a new DB++ relation

dbplus_rchperm
dbplus_rcrtexact
DB++ İşlevleri
PHP Manual

dbplus_rcreate

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_rcreate — Creates a new DB++ relation

Açıklama

resource dbplus_rcreate ( string $name , mixed $domlist [, bool $overwrite ] )

Creates a new relation. Any existing relation sharing the same name will be overwritten if the relation is currently not in use and overwrite is set to TRUE.

Değiştirgeler

name

domlist

A combination of domains. May be passed as a single domain name string or as an array of domain names.

This parameter should contain the domain specification for the new relation within an array of domain description strings. A domain description string consists of a domain name unique to this relation, a slash and a type specification character. See the db++ documentation, especially the dbcreate(1) manpage, for a description of available type specifiers and their meanings.

Bilginize:

This function will also accept a string with space delimited domain description strings, but it is recommended to use an array

overwrite

Dönen Değerler

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

dbplus_rchperm
dbplus_rcrtexact
DB++ İşlevleri


Creates an exact but empty copy of a relation including indices

dbplus_rcreate
dbplus_rcrtlike
DB++ İşlevleri
PHP Manual

dbplus_rcrtexact

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_rcrtexact — Creates an exact but empty copy of a relation including indices

Açıklama

mixed dbplus_rcrtexact ( string $name , resource $relation [, bool $overwrite ] )

dbplus_rcrtexact() will create an exact but empty copy of the given relation under a new name.

Değiştirgeler

name

relation

The copied relation, opened by dbplus_open().

overwrite

An existing relation by the same name will only be overwritten if this parameter is set to TRUE and no other process is currently using the relation.

Dönen Değerler

Returns resource on success or DBPLUS_ERR_UNKNOWN on failure.

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

dbplus_rcreate
dbplus_rcrtlike
DB++ İşlevleri


Creates an empty copy of a relation with default indices

dbplus_rcrtexact
dbplus_resolve
DB++ İşlevleri
PHP Manual

dbplus_rcrtlike

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_rcrtlike — Creates an empty copy of a relation with default indices

Açıklama

mixed dbplus_rcrtlike ( string $name , resource $relation [, int $overwrite ] )

dbplus_rcrtexact() will create an empty copy of the given relation under a new name, but with default indices.

Değiştirgeler

name

relation

The copied relation, opened by dbplus_open().

overwrite

An existing relation by the same name will only be overwritten if this parameter is set to TRUE and no other process is currently using the relation.

Dönen Değerler

Returns resource on success or DBPLUS_ERR_UNKNOWN on failure.

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

dbplus_rcrtexact
dbplus_resolve
DB++ İşlevleri


Resolve host information for relation

dbplus_rcrtlike
dbplus_restorepos
DB++ İşlevleri
PHP Manual

dbplus_resolve

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_resolve — Resolve host information for relation

Açıklama

array dbplus_resolve ( string $relation_name )

dbplus_resolve() will try to resolve the given relation_name and find out internal server id, real hostname and the database path on this host.

Değiştirgeler

relation_name

The relation name.

Dönen Değerler

Returns an array containing these values under the keys sid, host and host_path or FALSE on error.

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Ayrıca Bakınız

  • dbplus_tcl() - Execute TCL code on server side

dbplus_rcrtlike
dbplus_restorepos
DB++ İşlevleri


Restore position

dbplus_resolve
dbplus_rkeys
DB++ İşlevleri
PHP Manual

dbplus_restorepos

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_restorepos — Restore position

Açıklama

int dbplus_restorepos ( resource $relation , array $tuple )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

relation

A relation opened by dbplus_open().

tuple

Dönen Değerler

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

dbplus_resolve
dbplus_rkeys
DB++ İşlevleri


Specify new primary key for a relation

dbplus_restorepos
dbplus_ropen
DB++ İşlevleri
PHP Manual

dbplus_rkeys

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_rkeys — Specify new primary key for a relation

Açıklama

mixed dbplus_rkeys ( resource $relation , mixed $domlist )

dbplus_rkeys() will replace the current primary key for relation with the combination of domains specified by domlist.

Değiştirgeler

relation

A relation opened by dbplus_open().

domlist

A combination of domains. May be passed as a single domain name string or as an array of domain names.

Dönen Değerler

Returns resource on success or DBPLUS_ERR_UNKNOWN on failure.

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

dbplus_restorepos
dbplus_ropen
DB++ İşlevleri


Open relation file local

dbplus_rkeys
dbplus_rquery
DB++ İşlevleri
PHP Manual

dbplus_ropen

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_ropen — Open relation file local

Açıklama

resource dbplus_ropen ( string $name )

dbplus_ropen() will open the relation file locally for quick access without any client/server overhead. Access is read only and only dbplus_curr() and dbplus_next() may be applied to the returned relation.

Değiştirgeler

name

Dönen Değerler

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

dbplus_rkeys
dbplus_rquery
DB++ İşlevleri


Perform local (raw) AQL query

dbplus_ropen
dbplus_rrename
DB++ İşlevleri
PHP Manual

dbplus_rquery

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_rquery — Perform local (raw) AQL query

Açıklama

resource dbplus_rquery ( string $query [, string $dbpath ] )

dbplus_rquery() performs a local (raw) AQL query using an AQL interpreter embedded into the db++ client library. dbplus_rquery() is faster than dbplus_aql() but will work on local data only.

Değiştirgeler

query

dbpath

Dönen Değerler

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

dbplus_ropen
dbplus_rrename
DB++ İşlevleri


Rename a relation

dbplus_rquery
dbplus_rsecindex
DB++ İşlevleri
PHP Manual

dbplus_rrename

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_rrename — Rename a relation

Açıklama

int dbplus_rrename ( resource $relation , string $name )

dbplus_rrename() will change the name of relation to name.

Değiştirgeler

relation

A relation opened by dbplus_open().

name

Dönen Değerler

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

dbplus_rquery
dbplus_rsecindex
DB++ İşlevleri


Create a new secondary index for a relation

dbplus_rrename
dbplus_runlink
DB++ İşlevleri
PHP Manual

dbplus_rsecindex

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_rsecindex — Create a new secondary index for a relation

Açıklama

mixed dbplus_rsecindex ( resource $relation , mixed $domlist , int $type )

dbplus_rsecindex() will create a new secondary index for relation with consists of the domains specified by domlist and is of type type

Değiştirgeler

relation

A relation opened by dbplus_open().

domlist

A combination of domains. May be passed as a single domain name string or as an array of domain names.

type

Dönen Değerler

Returns resource on success or DBPLUS_ERR_UNKNOWN on failure.

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

dbplus_rrename
dbplus_runlink
DB++ İşlevleri


Remove relation from filesystem

dbplus_rsecindex
dbplus_rzap
DB++ İşlevleri
PHP Manual

dbplus_runlink

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_runlink — Remove relation from filesystem

Açıklama

int dbplus_runlink ( resource $relation )

dbplus_runlink() will close and remove the relation.

Değiştirgeler

relation

A relation opened by dbplus_open().

Dönen Değerler

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

dbplus_rsecindex
dbplus_rzap
DB++ İşlevleri


Remove all tuples from relation

dbplus_runlink
dbplus_savepos
DB++ İşlevleri
PHP Manual

dbplus_rzap

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_rzap — Remove all tuples from relation

Açıklama

int dbplus_rzap ( resource $relation )

dbplus_rzap() will remove all tuples from relation.

Değiştirgeler

relation

A relation opened by dbplus_open().

Dönen Değerler

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

dbplus_runlink
dbplus_savepos
DB++ İşlevleri


Save position

dbplus_rzap
dbplus_setindex
DB++ İşlevleri
PHP Manual

dbplus_savepos

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_savepos — Save position

Açıklama

int dbplus_savepos ( resource $relation )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

relation

A relation opened by dbplus_open().

Dönen Değerler

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

dbplus_rzap
dbplus_setindex
DB++ İşlevleri


Set index

dbplus_savepos
dbplus_setindexbynumber
DB++ İşlevleri
PHP Manual

dbplus_setindex

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_setindex — Set index

Açıklama

int dbplus_setindex ( resource $relation , string $idx_name )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

relation

A relation opened by dbplus_open().

idx_name

Dönen Değerler

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

dbplus_savepos
dbplus_setindexbynumber
DB++ İşlevleri


Set index by number

dbplus_setindex
dbplus_sql
DB++ İşlevleri
PHP Manual

dbplus_setindexbynumber

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_setindexbynumber — Set index by number

Açıklama

int dbplus_setindexbynumber ( resource $relation , int $idx_number )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

relation

A relation opened by dbplus_open().

idx_number

Dönen Değerler

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

dbplus_setindex
dbplus_sql
DB++ İşlevleri


Perform SQL query

dbplus_setindexbynumber
dbplus_tcl
DB++ İşlevleri
PHP Manual

dbplus_sql

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_sql — Perform SQL query

Açıklama

resource dbplus_sql ( string $query [, string $server [, string $dbpath ]] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

query

server

dbpath

Dönen Değerler

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

dbplus_setindexbynumber
dbplus_tcl
DB++ İşlevleri


Execute TCL code on server side

dbplus_sql
dbplus_tremove
DB++ İşlevleri
PHP Manual

dbplus_tcl

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_tcl — Execute TCL code on server side

Açıklama

string dbplus_tcl ( int $sid , string $script )

A db++ server will prepare a TCL interpreter for each client connection. This interpreter will enable the server to execute TCL code provided by the client as a sort of stored procedures to improve the performance of database operations by avoiding client/server data transfers and context switches.

dbplus_tcl() needs to pass the client connection id the TCL script code should be executed by. dbplus_resolve() will provide this connection id. The function will return whatever the TCL code returns or a TCL error message if the TCL code fails.

Değiştirgeler

sid

script

Dönen Değerler

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Ayrıca Bakınız

  • dbplus_resolve() - Resolve host information for relation

dbplus_sql
dbplus_tremove
DB++ İşlevleri


Remove tuple and return new current tuple

dbplus_tcl
dbplus_undo
DB++ İşlevleri
PHP Manual

dbplus_tremove

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_tremove — Remove tuple and return new current tuple

Açıklama

int dbplus_tremove ( resource $relation , array $tuple [, array &$current ] )

dbplus_tremove() removes tuple from relation if it perfectly matches a tuple within the relation. current, if given, will contain the data of the new current tuple after calling dbplus_tremove().

Değiştirgeler

relation

A relation opened by dbplus_open().

tuple

current

Dönen Değerler

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

dbplus_tcl
dbplus_undo
DB++ İşlevleri


Undo

dbplus_tremove
dbplus_undoprepare
DB++ İşlevleri
PHP Manual

dbplus_undo

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_undo — Undo

Açıklama

int dbplus_undo ( resource $relation )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

relation

A relation opened by dbplus_open().

Dönen Değerler

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

dbplus_tremove
dbplus_undoprepare
DB++ İşlevleri


Prepare undo

dbplus_undo
dbplus_unlockrel
DB++ İşlevleri
PHP Manual

dbplus_undoprepare

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_undoprepare — Prepare undo

Açıklama

int dbplus_undoprepare ( resource $relation )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

relation

A relation opened by dbplus_open().

Dönen Değerler

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

dbplus_undo
dbplus_unlockrel
DB++ İşlevleri


Give up write lock on relation

dbplus_undoprepare
dbplus_unselect
DB++ İşlevleri
PHP Manual

dbplus_unlockrel

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_unlockrel — Give up write lock on relation

Açıklama

int dbplus_unlockrel ( resource $relation )

Release a write lock previously obtained by dbplus_lockrel().

Değiştirgeler

relation

A relation opened by dbplus_open().

Dönen Değerler

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

dbplus_undoprepare
dbplus_unselect
DB++ İşlevleri


Remove a constraint from relation

dbplus_unlockrel
dbplus_update
DB++ İşlevleri
PHP Manual

dbplus_unselect

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_unselect — Remove a constraint from relation

Açıklama

int dbplus_unselect ( resource $relation )

Calling dbplus_unselect() will remove a constraint previously set by dbplus_find() on relation.

Değiştirgeler

relation

A relation opened by dbplus_open().

Dönen Değerler

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

dbplus_unlockrel
dbplus_update
DB++ İşlevleri


Update specified tuple in relation

dbplus_unselect
dbplus_xlockrel
DB++ İşlevleri
PHP Manual

dbplus_update

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_update — Update specified tuple in relation

Açıklama

int dbplus_update ( resource $relation , array $old , array $new )

dbplus_update() replaces the old tuple with the data from the new one, only if the old completely matches a tuple within relation.

Değiştirgeler

relation

A relation opened by dbplus_open().

old

The old tuple.

new

The new tuple.

Dönen Değerler

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

dbplus_unselect
dbplus_xlockrel
DB++ İşlevleri


Request exclusive lock on relation

dbplus_update
dbplus_xunlockrel
DB++ İşlevleri
PHP Manual

dbplus_xlockrel

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_xlockrel — Request exclusive lock on relation

Açıklama

int dbplus_xlockrel ( resource $relation )

Request an exclusive lock on relation preventing even read access from other clients.

Değiştirgeler

relation

A relation opened by dbplus_open().

Dönen Değerler

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Ayrıca Bakınız

  • dbplus_xunlockrel() - Free exclusive lock on relation

dbplus_update
dbplus_xunlockrel
DB++ İşlevleri


Free exclusive lock on relation

dbplus_xlockrel
dBase
DB++ İşlevleri
PHP Manual

dbplus_xunlockrel

(PHP 4 <= 4.1.0, PECL dbplus >= 0.9)

dbplus_xunlockrel — Free exclusive lock on relation

Açıklama

int dbplus_xunlockrel ( resource $relation )

Releases an exclusive lock previously obtained by dbplus_xlockrel().

Değiştirgeler

relation

A relation opened by dbplus_open().

Dönen Değerler

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

dbplus_xlockrel
dBase
DB++ İşlevleri


dBase

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • dBase İşlevleri
    • dbase_add_record — Adds a record to a database
    • dbase_close — Closes a database
    • dbase_create — Creates a database
    • dbase_delete_record — Deletes a record from a database
    • dbase_get_header_info — Gets the header info of a database
    • dbase_get_record_with_names — Gets a record from a database as an associative array
    • dbase_get_record — Gets a record from a database as an indexed array
    • dbase_numfields — Gets the number of fields of a database
    • dbase_numrecords — Gets the number of records in a database
    • dbase_open — Opens a database
    • dbase_pack — Packs a database
    • dbase_replace_record — Replaces a record in a database
dbplus_xunlockrel
Giriş
Sağlayıcıya Göre Veritabanı Eklentileri


Giriş

Bilginize:

Bu eklenti » PECL deposuna taşınmış olup şu sürümden itibaren PHP kaynak paketinde dağıtılmamaktatır: PHP 5.3.0.

These functions allow you to access records stored in dBase-format (dbf) databases.

Uyarı

We recommend against using dBase files as your production database. Use » SQLite or choose any real SQL server instead; » MySQL or » Postgres are common choices with PHP. dBase support is here to allow you to import and export data to and from your web database, because the file format is commonly understood by Windows spreadsheets and organizers.

Dikkat

As of dbase 7.0.0 the databases are automatically locked via flock(). There has been no support for locking earlier, so two concurrent web server processes modifying the same dBase file would have very likely ruined your database. This can happen even with dbase 7.0.0+ on systems which implement the locks at the process level with multithreaded SAPIs such as ISAPI.

dBase files are simple sequential files of fixed length records. Records are appended to the end of the file and deleted records are kept until you call dbase_pack().

Only dbf file levels 3 (dBASE III+) - 5 (dBASE V) are supported. The types of dBase fields available are:

Available types of fields
Field | dBase Type | Format | Additional information
M | Memo | n/a | This type is not supported by PHP, such field will be ignored
D | Date | YYYYMMDD | The field length is limited to 8
T | DateTime | YYYYMMDDhhmmss.uuu | (FoxPro) No validity checks are done. Available as of dbase 7.0.0.
N | Number | A number | You must declare a length and a precision (the number of digits after the decimal point).
F | Float | A float number | Same as N. Available as of PHP 5.2.0
C | String | A string | You must declare a length. When retrieving data, the string will be right-padded with spaces to fit the declared length. Overlong strings will be silently truncated when storing data.
L | Boolean | T or Y for TRUE, F or N for FALSE, ? for uninitialized. | As of dbase 7.0.0, returned as a bool (TRUE or FALSE), or NULL for uninitialized fields. Formerly, returned as an int (1 or 0).

Bilginize:

As of dbase 7.0.0 nullable fields are supported for DBASE_TYPE_FOXPRO databases. If a field is nullable, passing NULL will set the respective flag, and on later retrieval the field value will be NULL.

Bilginize:

There is no support for indexes or memo fields.

dBase
Yapılandırma/Kurulum
dBase


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
dBase


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/dbase.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Özkaynak Türleri

As of dbase 7.0.0, the resource type dbase is defined, which is returned by dbase_open() and dbase_create().

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

DBASE_VERSION (string)
The extension version. (Available as of dbase 7.0.0)
DBASE_RDONLY (int)
Open database for reading only. Used with dbase_open(). (Available as of dbase 7.0.0)
DBASE_RDWR (int)
Open database for reading and writing. Used with dbase_open(). (Available as of dbase 7.0.0)
DBASE_TYPE_DBASE (int)
Create dBASE style database. Used with dbase_create(). (Available as of dbase 7.0.0)
DBASE_TYPE_FOXPRO (int)
Create FoxPro style database. Used with dbase_create(). (Available as of dbase 7.0.0)
Özkaynak Türleri
dBase İşlevleri
dBase


dBase İşlevleri

Örnekler

Many examples in this reference require a dBase database. We will use /tmp/test.dbf that will be created in the example of dbase_create().

İçindekiler

  • dbase_add_record — Adds a record to a database
  • dbase_close — Closes a database
  • dbase_create — Creates a database
  • dbase_delete_record — Deletes a record from a database
  • dbase_get_header_info — Gets the header info of a database
  • dbase_get_record_with_names — Gets a record from a database as an associative array
  • dbase_get_record — Gets a record from a database as an indexed array
  • dbase_numfields — Gets the number of fields of a database
  • dbase_numrecords — Gets the number of records in a database
  • dbase_open — Opens a database
  • dbase_pack — Packs a database
  • dbase_replace_record — Replaces a record in a database
Öntanımlı Sabitler
dbase_add_record
dBase


Adds a record to a database

dBase İşlevleri
dbase_close
dBase İşlevleri
PHP Manual

dbase_add_record

(PHP 5 < 5.3.0, dbase 5, dbase 7)

dbase_add_record — Adds a record to a database

Açıklama

bool dbase_add_record ( resource $dbase_identifier , array $record )

Adds the given data to the database.

Değiştirgeler

dbase_identifier

The database link identifier, returned by dbase_open() or dbase_create().

record

An indexed array of data. The number of items must be equal to the number of fields in the database, otherwise dbase_add_record() will fail.

Bilginize:

If you're using dbase_get_record() return value for this parameter, remember to reset the key named deleted.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
dbase 7.0.0 | dbase_identifier is now a resource instead of an int.

Örnekler

Örnek 1 Inserting a record in a dBase database

<?php

// open in read-write mode
$db = dbase_open('/tmp/test.dbf', 2);

if ($db) {
  dbase_add_record($db, array(
      date('Ymd'),
      'Maxim Topolov',
      '23',
      'max@example.com',
      'T'));
  dbase_close($db);
}

?>

Ayrıca Bakınız

  • dbase_delete_record() - Deletes a record from a database
  • dbase_replace_record() - Replaces a record in a database

dBase İşlevleri
dbase_close
dBase İşlevleri


Closes a database

dbase_add_record
dbase_create
dBase İşlevleri
PHP Manual

dbase_close

(PHP 5 < 5.3.0, dbase 5, dbase 7)

dbase_close — Closes a database

Açıklama

bool dbase_close ( resource $dbase_identifier )

Closes the given database link identifier.

Değiştirgeler

dbase_identifier

The database link identifier, returned by dbase_open() or dbase_create().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
dbase 7.0.0 | dbase_identifier is now a resource instead of an int.

Örnekler

Örnek 1 Closing a dBase database file

<?php

// open in read-only mode
$db = dbase_open('/tmp/test.dbf', 0);

if ($db) {
  // read some data ..

  dbase_close($db);
}

?>

Ayrıca Bakınız

  • dbase_open() - Opens a database
  • dbase_create() - Creates a database

dbase_add_record
dbase_create
dBase İşlevleri


Creates a database

dbase_close
dbase_delete_record
dBase İşlevleri
PHP Manual

dbase_create

(PHP 5 < 5.3.0, dbase 5, dbase 7)

dbase_create — Creates a database

Açıklama

resource dbase_create ( string $filename , array $fields , int $type = DBASE_TYPE_DBASE )

dbase_create() creates a dBase database with the given definition. If the file already exists, it is not truncated. dbase_pack() can be called to force truncation.

Bilginize: Güvenli kip etkinken, PHP, dosya ve dizinlerin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığını sınar.

Bilginize:

Bu işlev open_basedir'dan etkilenir.

Değiştirgeler

filename

The name of the database. It can be a relative or absolute path to the file where dBase will store your data.

fields

An array of arrays, each array describing the format of one field of the database. Each field consists of a name, a character indicating the field type, and optionally, a length, a precision and a nullable flag. The supported field types are listed in the introduction section.

Bilginize:

The fieldnames are limited in length and must not exceed 10 chars.

type

The type of database to be created. Either DBASE_TYPE_DBASE or DBASE_TYPE_FOXPRO.

Bilginize:

The fieldnames are limited in length and must not exceed 10 chars.

Dönen Değerler

Returns a database link identifier if the database is successfully created, or FALSE if an error occurred.

Sürüm Bilgisi

Sürüm: | Açıklama
dbase 7.0.0 | The return value is now a resource instead of an int.

Örnekler

Örnek 1 Creating a dBase database file

<?php

// database "definition"
$def = array(
  array("date",     "D"),
  array("name",     "C",  50),
  array("age",      "N",   3, 0),
  array("email",    "C", 128),
  array("ismember", "L")
);

// creation
if (!dbase_create('/tmp/test.dbf', $def)) {
  echo "Error, can't create the database\n";
}

?>

Ayrıca Bakınız

  • dbase_open() - Opens a database
  • dbase_close() - Closes a database

dbase_close
dbase_delete_record
dBase İşlevleri


Deletes a record from a database

dbase_create
dbase_get_header_info
dBase İşlevleri
PHP Manual

dbase_delete_record

(PHP 5 < 5.3.0, dbase 5, dbase 7)

dbase_delete_record — Deletes a record from a database

Açıklama

bool dbase_delete_record ( resource $dbase_identifier , int $record_number )

Marks the given record to be deleted from the database.

Bilginize:

To actually remove the record from the database, you must also call dbase_pack().

Değiştirgeler

dbase_identifier

The database link identifier, returned by dbase_open() or dbase_create().

record_number

An integer which spans from 1 to the number of records in the database (as returned by dbase_numrecords()).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
dbase 7.0.0 | dbase_identifier is now a resource instead of an int.

Ayrıca Bakınız

  • dbase_add_record() - Adds a record to a database
  • dbase_replace_record() - Replaces a record in a database

dbase_create
dbase_get_header_info
dBase İşlevleri


Gets the header info of a database

dbase_delete_record
dbase_get_record_with_names
dBase İşlevleri
PHP Manual

dbase_get_header_info

(PHP 5 < 5.3.0, dbase 5, dbase 7)

dbase_get_header_info — Gets the header info of a database

Açıklama

array dbase_get_header_info ( resource $dbase_identifier )

Returns information on the column structure of the given database link identifier.

Değiştirgeler

dbase_identifier

The database link identifier, returned by dbase_open() or dbase_create().

Dönen Değerler

An indexed array with an entry for each column in the database. The array index starts at 0.

Each array element contains an associative array of column information, as described here:

name
The name of the column
type
The human-readable name for the dbase type of the column (i.e. date, boolean, etc.) The supported field types are listed in the introduction section.
length
The number of bytes this column can hold
precision
The number of digits of decimal precision for the column
format
A suggested printf() format specifier for the column
offset
The byte offset of the column from the start of the row

If the database header information cannot be read, FALSE is returned.

Sürüm Bilgisi

Sürüm: | Açıklama
dbase 7.0.0 | dbase_identifier is now a resource instead of an int.

Örnekler

Örnek 1 Showing header information for a dBase database file

<?php
// Path to dbase file
$db_path = "/tmp/test.dbf";

// Open dbase file
$dbh = dbase_open($db_path, 0)
  or die("Error! Could not open dbase database file '$db_path'.");

// Get column information
$column_info = dbase_get_header_info($dbh);

// Display information
print_r($column_info);
?>

dbase_delete_record
dbase_get_record_with_names
dBase İşlevleri


Gets a record from a database as an associative array

dbase_get_header_info
dbase_get_record
dBase İşlevleri
PHP Manual

dbase_get_record_with_names

(PHP 5 < 5.3.0, dbase 5, dbase 7)

dbase_get_record_with_names — Gets a record from a database as an associative array

Açıklama

array dbase_get_record_with_names ( resource $dbase_identifier , int $record_number )

Gets a record from a dBase database as an associative array.

Değiştirgeler

dbase_identifier

The database link identifier, returned by dbase_open() or dbase_create().

record_number

The index of the record between 1 and dbase_numrecords($dbase_identifier).

Dönen Değerler

An associative array with the record. This will also include a key named deleted which is set to 1 if the record has been marked for deletion (see dbase_delete_record()). Therefore it is not possible to retrieve the value of a field named deleted with this function.

Each field is converted to the appropriate PHP type, except:

  • Dates are left as strings.
  • DateTime values are converted to strings.
  • Integers outside the range PHP_INT_MIN..PHP_INT_MAX are returned as strings.
  • Before dbase 7.0.0, booleans (L) were converted to 1 or 0.

On error, dbase_get_record_with_names() will return FALSE.

Sürüm Bilgisi

Sürüm: | Açıklama
dbase 7.0.0 | dbase_identifier is now a resource instead of an int.

Örnekler

Örnek 1 Listing all the registered members in the database

<?php
// open in read-only mode
$db = dbase_open('/tmp/test.dbf', 0);

if ($db) {
  $record_numbers = dbase_numrecords($db);
  for ($i = 1; $i <= $record_numbers; $i++) {
      $row = dbase_get_record_with_names($db, $i);
      if ($row['ismember'] == 1) {
          echo "Member #$i: " . trim($row['name']) . "\n";
      }
  }
}
?>

Ayrıca Bakınız

  • dbase_get_record() - Gets a record from a database as an indexed array

dbase_get_header_info
dbase_get_record
dBase İşlevleri


Gets a record from a database as an indexed array

dbase_get_record_with_names
dbase_numfields
dBase İşlevleri
PHP Manual

dbase_get_record

(PHP 5 < 5.3.0, dbase 5, dbase 7)

dbase_get_record — Gets a record from a database as an indexed array

Açıklama

array dbase_get_record ( resource $dbase_identifier , int $record_number )

Gets a record from a database as an indexed array.

Değiştirgeler

dbase_identifier

The database link identifier, returned by dbase_open() or dbase_create().

record_number

The index of the record between 1 and dbase_numrecords($dbase_identifier).

Dönen Değerler

An indexed array with the record. This array will also include an associative key named deleted which is set to 1 if the record has been marked for deletion (see dbase_delete_record()).

Each field is converted to the appropriate PHP type, except:

  • Dates are left as strings.
  • DateTime values are converted to strings.
  • Integers outside the range PHP_INT_MIN..PHP_INT_MAX are returned as strings.
  • Before dbase 7.0.0, booleans (L) were converted to 1 or 0.

On error, dbase_get_record() will return FALSE.

Sürüm Bilgisi

Sürüm: | Açıklama
dbase 7.0.0 | dbase_identifier is now a resource instead of an int.

Ayrıca Bakınız

  • dbase_get_record_with_names() - Gets a record from a database as an associative array

dbase_get_record_with_names
dbase_numfields
dBase İşlevleri


Gets the number of fields of a database

dbase_get_record
dbase_numrecords
dBase İşlevleri
PHP Manual

dbase_numfields

(PHP 5 < 5.3.0, dbase 5, dbase 7)

dbase_numfields — Gets the number of fields of a database

Açıklama

int dbase_numfields ( resource $dbase_identifier )

Gets the number of fields (columns) in the specified database.

Bilginize:

Field numbers are between 0 and dbase_numfields($db)-1, while record numbers are between 1 and dbase_numrecords($db).

Değiştirgeler

dbase_identifier

The database link identifier, returned by dbase_open() or dbase_create().

Dönen Değerler

The number of fields in the database, or FALSE if an error occurs.

Sürüm Bilgisi

Sürüm: | Açıklama
dbase 7.0.0 | dbase_identifier is now a resource instead of an int.

Örnekler

Örnek 1 dbase_numfields() Example

<?php

$rec = dbase_get_record($db, $recno);
$nf  = dbase_numfields($db);
for ($i = 0; $i < $nf; $i++) {
  echo $rec[$i], "\n";
}

?>

Ayrıca Bakınız

  • dbase_numrecords() - Gets the number of records in a database

dbase_get_record
dbase_numrecords
dBase İşlevleri


Gets the number of records in a database

dbase_numfields
dbase_open
dBase İşlevleri
PHP Manual

dbase_numrecords

(PHP 5 < 5.3.0, dbase 5, dbase 7)

dbase_numrecords — Gets the number of records in a database

Açıklama

int dbase_numrecords ( resource $dbase_identifier )

Gets the number of records (rows) in the specified database.

Bilginize:

Record numbers are between 1 and dbase_numrecords($db), while field numbers are between 0 and dbase_numfields($db)-1.

Değiştirgeler

dbase_identifier

The database link identifier, returned by dbase_open() or dbase_create().

Dönen Değerler

The number of records in the database, or FALSE if an error occurs.

Sürüm Bilgisi

Sürüm: | Açıklama
dbase 7.0.0 | dbase_identifier is now a resource instead of an int.

Örnekler

Örnek 1 Looping over all the records of the database

<?php

// open in read-only mode
$db = dbase_open('/tmp/test.dbf', 0);

if ($db) {
  $record_numbers = dbase_numrecords($db);
  for ($i = 1; $i <= $record_numbers; $i++) {
      // do something here, for each record
  }
}

?>

Ayrıca Bakınız

  • dbase_numfields() - Gets the number of fields of a database

dbase_numfields
dbase_open
dBase İşlevleri


Opens a database

dbase_numrecords
dbase_pack
dBase İşlevleri
PHP Manual

dbase_open

(PHP 5 < 5.3.0, dbase 5, dbase 7)

dbase_open — Opens a database

Açıklama

resource dbase_open ( string $filename , int $mode )

dbase_open() opens a dBase database with the given access mode.

Bilginize: Güvenli kip etkinken, PHP, dosya ve dizinlerin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığını sınar.

Bilginize:

Bu işlev open_basedir'dan etkilenir.

Değiştirgeler

filename

The name of the database. It can be a relative or absolute path to the file where dBase will store your data.

mode

An integer which correspond to those for the open() system call (Typically 0 means read-only, 1 means write-only, and 2 means read and write).

Bilginize:

You can't open a dBase file in write-only mode as the function will fail to read the headers information and thus you can't use 1 as mode.

As of dbase 7.0.0 you can use DBASE_RDONLY and DBASE_RDWR, respectively, to specify the mode.

Sürüm Bilgisi

Sürüm: | Açıklama
dbase 7.0.0 | The return value is now a resource instead of an int.

Örnekler

Örnek 1 Opening a dBase database file

<?php

// open in read-only mode
$db = dbase_open('/tmp/test.dbf', 0);

if ($db) {
  // read some data ..

  dbase_close($db);
}

?>

Dönen Değerler

Returns a database link identifier if the database is successfully opened, or FALSE if an error occurred.

Ayrıca Bakınız

  • dbase_create() - Creates a database
  • dbase_close() - Closes a database

dbase_numrecords
dbase_pack
dBase İşlevleri


Packs a database

dbase_open
dbase_replace_record
dBase İşlevleri
PHP Manual

dbase_pack

(PHP 5 < 5.3.0, dbase 5, dbase 7)

dbase_pack — Packs a database

Açıklama

bool dbase_pack ( resource $dbase_identifier )

Packs the specified database by permanently deleting all records marked for deletion using dbase_delete_record(). Note that the file will be truncated after successful packing (contrary to dBASE III's PACK command).

Değiştirgeler

dbase_identifier

The database link identifier, returned by dbase_open() or dbase_create().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
dbase 7.0.0 | dbase_identifier is now a resource instead of an int.

Örnekler

Örnek 1 Emptying a dBase database

<?php

// open in read-write mode
$db = dbase_open('/tmp/test.dbf', 2);

if ($db) {
  $record_numbers = dbase_numrecords($db);
  for ($i = 1; $i <= $record_numbers; $i++) {
      dbase_delete_record($db, $i);
  }
  // expunge the database
  dbase_pack($db);
}

?>

Ayrıca Bakınız

  • dbase_delete_record() - Deletes a record from a database

dbase_open
dbase_replace_record
dBase İşlevleri


Replaces a record in a database

dbase_pack
filePro
dBase İşlevleri
PHP Manual

dbase_replace_record

(PHP 5 < 5.3.0, dbase 5, dbase 7)

dbase_replace_record — Replaces a record in a database

Açıklama

bool dbase_replace_record ( resource $dbase_identifier , array $record , int $record_number )

Replaces the given record in the database with the given data.

Değiştirgeler

dbase_identifier

The database link identifier, returned by dbase_open() or dbase_create().

record

An indexed array of data. The number of items must be equal to the number of fields in the database, otherwise dbase_replace_record() will fail.

Bilginize:

If you're using dbase_get_record() return value for this parameter, remember to reset the key named deleted.

record_number

An integer which spans from 1 to the number of records in the database (as returned by dbase_numrecords()).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
dbase 7.0.0 | dbase_identifier is now a resource instead of an int.

Örnekler

Örnek 1 Updating a record in the database

<?php

// open in read-write mode
$db = dbase_open('/tmp/test.dbf', 2);

if ($db) {
  // gets the old row
  $row = dbase_get_record_with_names($db, 1);

  // remove the 'deleted' entry
  unset($row['deleted']);

  // Update the date field with the current timestamp
  $row['date'] = date('Ymd');

  // convert the row to an indexed array
  $row = array_values($row);

  // Replace the record
  dbase_replace_record($db, $row, 1);
  dbase_close($db);
}

?>

Notlar

Bilginize:

Boolean fields result in an integer element value (0 or 1) when retrieved via dbase_get_record() or dbase_get_record_with_names(). If they are written back, this results in the value becoming 0, so care has to be taken to properly adjust the values.

Ayrıca Bakınız

  • dbase_add_record() - Adds a record to a database
  • dbase_delete_record() - Deletes a record from a database

dbase_pack
filePro
dBase İşlevleri


filePro

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • filePro İşlevleri
    • filepro_fieldcount — Find out how many fields are in a filePro database
    • filepro_fieldname — Gets the name of a field
    • filepro_fieldtype — Gets the type of a field
    • filepro_fieldwidth — Gets the width of a field
    • filepro_retrieve — Retrieves data from a filePro database
    • filepro_rowcount — Find out how many rows are in a filePro database
    • filepro — Read and verify the map file
dbase_replace_record
Giriş
Sağlayıcıya Göre Veritabanı Eklentileri


Giriş

These functions allow read-only access to data stored in filePro databases.

filePro is a registered trademark of fP Technologies, Inc. You can find more information about filePro at » http://www.fptech.com/.

Bilginize:

Bu eklenti » PECL deposuna taşınmış olup şu sürümden itibaren PHP kaynak paketinde dağıtılmamaktatır: PHP 5.2.0.

filePro
Yapılandırma/Kurulum
filePro


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
filePro


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/filepro.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
filePro İşlevleri
filePro


filePro İşlevleri

İçindekiler

  • filepro_fieldcount — Find out how many fields are in a filePro database
  • filepro_fieldname — Gets the name of a field
  • filepro_fieldtype — Gets the type of a field
  • filepro_fieldwidth — Gets the width of a field
  • filepro_retrieve — Retrieves data from a filePro database
  • filepro_rowcount — Find out how many rows are in a filePro database
  • filepro — Read and verify the map file
Öntanımlı Sabitler
filepro_fieldcount
filePro


Find out how many fields are in a filePro database

filePro İşlevleri
filepro_fieldname
filePro İşlevleri
PHP Manual

filepro_fieldcount

(PHP 4, PHP 5 <= 5.1.6, PHP 7)

filepro_fieldcount — Find out how many fields are in a filePro database

Açıklama

int filepro_fieldcount ( void )

Returns the number of fields (columns) in the opened filePro database.

Dönen Değerler

Returns the number of fields in the opened filePro database, or FALSE on errors.

Ayrıca Bakınız

  • filepro() - Read and verify the map file

filePro İşlevleri
filepro_fieldname
filePro İşlevleri


Gets the name of a field

filepro_fieldcount
filepro_fieldtype
filePro İşlevleri
PHP Manual

filepro_fieldname

(PHP 4, PHP 5 <= 5.1.6, PHP 7)

filepro_fieldname — Gets the name of a field

Açıklama

string filepro_fieldname ( int $field_number )

Returns the name of the field corresponding to field_number.

Değiştirgeler

field_number

The field number.

Dönen Değerler

Returns the name of the field as a string, or FALSE on errors.

filepro_fieldcount
filepro_fieldtype
filePro İşlevleri


Gets the type of a field

filepro_fieldname
filepro_fieldwidth
filePro İşlevleri
PHP Manual

filepro_fieldtype

(PHP 4, PHP 5 <= 5.1.6, PHP 7)

filepro_fieldtype — Gets the type of a field

Açıklama

string filepro_fieldtype ( int $field_number )

Returns the edit type of the field corresponding to field_number.

Değiştirgeler

field_number

The field number.

Dönen Değerler

Returns the edit type of the field as a string, or FALSE on errors.

filepro_fieldname
filepro_fieldwidth
filePro İşlevleri


Gets the width of a field

filepro_fieldtype
filepro_retrieve
filePro İşlevleri
PHP Manual

filepro_fieldwidth

(PHP 4, PHP 5 <= 5.1.6, PHP 7)

filepro_fieldwidth — Gets the width of a field

Açıklama

int filepro_fieldwidth ( int $field_number )

Returns the width of the field corresponding to field_number.

Değiştirgeler

field_number

The field number.

Dönen Değerler

Returns the width of the field as a integer, or FALSE on errors.

filepro_fieldtype
filepro_retrieve
filePro İşlevleri


Retrieves data from a filePro database

filepro_fieldwidth
filepro_rowcount
filePro İşlevleri
PHP Manual

filepro_retrieve

(PHP 4, PHP 5 <= 5.1.6, PHP 7)

filepro_retrieve — Retrieves data from a filePro database

Açıklama

string filepro_retrieve ( int $row_number , int $field_number )

Returns the data from the specified location in the database.

Bilginize: Güvenli kip etkinken, PHP, dosya ve dizinlerin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığını sınar.

Değiştirgeler

row_number

The row number. Must be between zero and the total number of rows minus one (0..filepro_rowcount() - 1)

field_number

The field number. Accepts values between zero and the total number of fields minus one (0..filepro_fieldcount() - 1)

Dönen Değerler

Returns the specified data, or FALSE on errors.

filepro_fieldwidth
filepro_rowcount
filePro İşlevleri


Find out how many rows are in a filePro database

filepro_retrieve
filepro
filePro İşlevleri
PHP Manual

filepro_rowcount

(PHP 4, PHP 5 <= 5.1.6, PHP 7)

filepro_rowcount — Find out how many rows are in a filePro database

Açıklama

int filepro_rowcount ( void )

Returns the number of rows in the opened filePro database.

Bilginize: Güvenli kip etkinken, PHP, dosya ve dizinlerin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığını sınar.

Dönen Değerler

Returns the number of rows in the opened filePro database, or FALSE on errors.

Ayrıca Bakınız

  • filepro() - Read and verify the map file

filepro_retrieve
filepro
filePro İşlevleri


Read and verify the map file

filepro_rowcount
Firebird/InterBase
filePro İşlevleri
PHP Manual

filepro

(PHP 4, PHP 5 <= 5.1.6, PHP 7)

filepro — Read and verify the map file

Açıklama

bool filepro ( string $directory )

This reads and verifies the map file, storing the field count and info.

No locking is done, so you should avoid modifying your filePro database while it may be opened in PHP.

Bilginize: Güvenli kip etkinken, PHP, dosya ve dizinlerin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığını sınar.

Değiştirgeler

directory

The map directory.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

filepro_rowcount
Firebird/InterBase
filePro İşlevleri


Firebird/InterBase

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Firebird/InterBase İşlevleri
    • ibase_add_user — Add a user to a security database
    • ibase_affected_rows — Return the number of rows that were affected by the previous query
    • ibase_backup — Initiates a backup task in the service manager and returns immediately
    • ibase_blob_add — Add data into a newly created blob
    • ibase_blob_cancel — Cancel creating blob
    • ibase_blob_close — Close blob
    • ibase_blob_create — Create a new blob for adding data
    • ibase_blob_echo — Output blob contents to browser
    • ibase_blob_get — Get len bytes data from open blob
    • ibase_blob_import — Create blob, copy file in it, and close it
    • ibase_blob_info — Return blob length and other useful info
    • ibase_blob_open — Open blob for retrieving data parts
    • ibase_close — Close a connection to an InterBase database
    • ibase_commit_ret — Commit a transaction without closing it
    • ibase_commit — Commit a transaction
    • ibase_connect — Open a connection to a database
    • ibase_db_info — Request statistics about a database
    • ibase_delete_user — Delete a user from a security database
    • ibase_drop_db — Drops a database
    • ibase_errcode — Return an error code
    • ibase_errmsg — Return error messages
    • ibase_execute — Execute a previously prepared query
    • ibase_fetch_assoc — Fetch a result row from a query as an associative array
    • ibase_fetch_object — Get an object from a InterBase database
    • ibase_fetch_row — Fetch a row from an InterBase database
    • ibase_field_info — Get information about a field
    • ibase_free_event_handler — Cancels a registered event handler
    • ibase_free_query — Free memory allocated by a prepared query
    • ibase_free_result — Free a result set
    • ibase_gen_id — Increments the named generator and returns its new value
    • ibase_maintain_db — Execute a maintenance command on the database server
    • ibase_modify_user — Modify a user to a security database
    • ibase_name_result — Assigns a name to a result set
    • ibase_num_fields — Get the number of fields in a result set
    • ibase_num_params — Return the number of parameters in a prepared query
    • ibase_param_info — Return information about a parameter in a prepared query
    • ibase_pconnect — Open a persistent connection to an InterBase database
    • ibase_prepare — Prepare a query for later binding of parameter placeholders and execution
    • ibase_query — Execute a query on an InterBase database
    • ibase_restore — Initiates a restore task in the service manager and returns immediately
    • ibase_rollback_ret — Roll back a transaction without closing it
    • ibase_rollback — Roll back a transaction
    • ibase_server_info — Request information about a database server
    • ibase_service_attach — Connect to the service manager
    • ibase_service_detach — Disconnect from the service manager
    • ibase_set_event_handler — Register a callback function to be called when events are posted
    • ibase_trans — Begin a transaction
    • ibase_wait_event — Wait for an event to be posted by the database
filepro
Giriş
Sağlayıcıya Göre Veritabanı Eklentileri


Giriş

Firebird is a relational database offering many ISO SQL-2003 features that runs on Linux, Windows, and a variety of Unix platforms. Firebird offers excellent concurrency, high performance, and powerful language support for stored procedures and triggers. It has been used in production systems, under a variety of names since 1981.

InterBase is the name of the closed-source variant of this RDBMS that was developed by Embarcadero/Inprise. More information about InterBase is available at » http://www.embarcadero.com/products/interbase.

Firebird is a commercially independent project (fundation) of C++ programmers, technical advisors and supporters developing and enhancing a multi-platform relational database management system based on the source code released by Inprise Corp (now known as Embarcadero) under the InterBase Public License v.1.0 on 25 July, 2000. More information about Firebird is available at » http://www.firebirdsql.org/.

Bilginize:

This extension supports InterBase versions 6 and up and Firebird version 2.0 and up.

This database uses a single quote (') character for escaping add to your php.ini the following directive(Deprecated in PHP 5.3.0. Removed in PHP 5.4.0):

magic_quotes_sybase = On

Firebird/InterBase
Yapılandırma/Kurulum
Firebird/InterBase


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Firebird/InterBase


Kurulum

To enable Firebird/InterBase support configure PHP --with-interbase[=DIR] , where DIR is the Firebird/InterBase base install directory, which defaults to /usr.

Bilginize: Note to Win32/Win64 Users

Bu eklentinin çalışabilmesi için bazı DLL dosyalarının bulunduğu yerlerin Windows sistem PATH'ında tanımlı olması gerekir. Bunun nasıl yapılacağı SSS altında "PHP dizinimi Windows'ta PATH'a nasıl eklerim" başlığı altında açıklanmıştır. Eklenti, DLL dosyaları PHP dizininden Windows system dizinine taşındığında da çalışırsa da (çünkü system dizini sistem PATH'ında zaten vardır) bu önerilmez. Bu eklentinin çalışabilmesi için bulunduğu dizine PATH üzerinden erişilebilinmesi gereken dosyanın ismi: fbclient.dll,gds32.dll

If you installed the Firebird/InterBase database server on the same machine PHP is running on, you will have this DLL already and fbclient.dll,gds32.dll (gds32.dll is generated from the installer for legacy applications) will already be in the PATH.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

InterBase configuration options
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
ibase.allow_persistent | "1" | PHP_INI_SYSTEM |
ibase.max_persistent | "-1" | PHP_INI_SYSTEM |
ibase.max_links | "-1" | PHP_INI_SYSTEM |
ibase.default_db | NULL | PHP_INI_SYSTEM | Available since PHP 5.0.0.
ibase.default_user | NULL | PHP_INI_ALL |
ibase.default_password | NULL | PHP_INI_ALL |
ibase.default_charset | NULL | PHP_INI_ALL | Available since PHP 5.0.0.
ibase.timestampformat | "%Y-%m-%d %H:%M:%S" | PHP_INI_ALL |
ibase.dateformat | "%Y-%m-%d" | PHP_INI_ALL |
ibase.timeformat | "%H:%M:%S" | PHP_INI_ALL |
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

ibase.allow_persistent boolean

Whether to allow persistent connections to Firebird/InterBase.

ibase.max_persistent integer

The maximum number of persistent Firebird/InterBase connections per process. New connections created with ibase_pconnect() will be non-persistent if this number would be exceeded.

ibase.max_links integer

The maximum number of Firebird/InterBase connections per process, including persistent connections.

ibase.default_db string

The default database to connect to when ibase_[p]connect() is called without specifying a database name. If this value is set and SQL safe mode is enabled, no other connections than to this database will be allowed.

ibase.default_user string

The user name to use when connecting to a database if no user name is specified.

ibase.default_password string

The password to use when connecting to a database if no password is specified.

ibase.default_charset string

The character set to use when connecting to a database if no character set is specified.

ibase.timestampformat string

ibase.dateformat string

ibase.timeformat string

These directives are used to set the date and time formats that are used when returning dates and times from a result set, or when binding arguments to date and time parameters.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

The following constants can be passed to ibase_trans() to specify transaction behaviour.

Firebird/InterBase transaction flags
Constant | Description
IBASE_DEFAULT | The default transaction settings are to be used. This default is determined by the client library, which defines it as IBASE_WRITE|IBASE_CONCURRENCY|IBASE_WAIT in most cases.
IBASE_READ | Starts a read-only transaction.
IBASE_WRITE | Starts a read-write transaction.
IBASE_CONSISTENCY | Starts a transaction with the isolation level set to 'consistency', which means the transaction cannot read from tables that are being modified by other concurrent transactions.
IBASE_CONCURRENCY | Starts a transaction with the isolation level set to 'concurrency' (or 'snapshot'), which means the transaction has access to all tables, but cannot see changes that were committed by other transactions after the transaction was started.
IBASE_COMMITTED | Starts a transaction with the isolation level set to 'read committed'. This flag should be combined with either IBASE_REC_VERSION or IBASE_REC_NO_VERSION. This isolation level allows access to changes that were committed after the transaction was started. If IBASE_REC_NO_VERSION was specified, only the latest version of a row can be read. If IBASE_REC_VERSION was specified, a row can even be read when a modification to it is pending in a concurrent transaction.
IBASE_WAIT | Indicated that a transaction should wait and retry when a conflict occurs.
IBASE_NOWAIT | Indicated that a transaction should fail immediately when a conflict occurs.

The following constants can be passed to ibase_fetch_row(), ibase_fetch_assoc() or ibase_fetch_object() to specify fetch behaviour.

Firebird/InterBase fetch flags
Constant | Description
IBASE_FETCH_BLOBS | Also available as IBASE_TEXTfor backward compatibility. Causes BLOB contents to be fetched inline, instead of being fetched as BLOB identifiers.
IBASE_FETCH_ARRAYS | Causes arrays to be fetched inline. Otherwise, array identifiers are returned. Array identifiers can only be used as arguments to INSERT operations, as no functions to handle array identifiers are currently available.
IBASE_UNIXTIME | Causes date and time fields not to be returned as strings, but as UNIX timestamps (the number of seconds since the epoch, which is 1-Jan-1970 0:00 UTC). Might be problematic if used with dates before 1970 on some systems.

The following constants are used to pass requests and options to the service
API functions (ibase_server_info(), ibase_db_info(),
ibase_backup(), ibase_restore()
and ibase_maintain_db()). Please refer to
the Firebird/InterBase manuals for the meaning of these options.

IBASE_BKP_IGNORE_CHECKSUMS
IBASE_BKP_IGNORE_LIMBO
IBASE_BKP_METADATA_ONLY
IBASE_BKP_NO_GARBAGE_COLLECT
IBASE_BKP_OLD_DESCRIPTIONS
IBASE_BKP_NON_TRANSPORTABLE
IBASE_BKP_CONVERT
Options to ibase_backup()
IBASE_RES_DEACTIVATE_IDX
IBASE_RES_NO_SHADOW
IBASE_RES_NO_VALIDITY
IBASE_RES_ONE_AT_A_TIME
IBASE_RES_REPLACE
IBASE_RES_CREATE
IBASE_RES_USE_ALL_SPACE
Options to ibase_restore()
IBASE_PRP_PAGE_BUFFERS
IBASE_PRP_SWEEP_INTERVAL
IBASE_PRP_SHUTDOWN_DB
IBASE_PRP_DENY_NEW_TRANSACTIONS
IBASE_PRP_DENY_NEW_ATTACHMENTS
IBASE_PRP_RESERVE_SPACE
IBASE_PRP_RES_USE_FULL
IBASE_PRP_RES
IBASE_PRP_WRITE_MODE
IBASE_PRP_WM_ASYNC
IBASE_PRP_WM_SYNC
IBASE_PRP_ACCESS_MODE
IBASE_PRP_AM_READONLY
IBASE_PRP_AM_READWRITE
IBASE_PRP_SET_SQL_DIALECT
IBASE_PRP_ACTIVATE
IBASE_PRP_DB_ONLINE
IBASE_RPR_CHECK_DB
IBASE_RPR_IGNORE_CHECKSUM
IBASE_RPR_KILL_SHADOWS
IBASE_RPR_MEND_DB
IBASE_RPR_VALIDATE_DB
IBASE_RPR_FULL
IBASE_RPR_SWEEP_DB
Options to ibase_maintain_db()
IBASE_STS_DATA_PAGES
IBASE_STS_DB_LOG
IBASE_STS_HDR_PAGES
IBASE_STS_IDX_PAGES
IBASE_STS_SYS_RELATIONS
Options to ibase_db_info()
IBASE_SVC_SERVER_VERSION
IBASE_SVC_IMPLEMENTATION
IBASE_SVC_GET_ENV
IBASE_SVC_GET_ENV_LOCK
IBASE_SVC_GET_ENV_MSG
IBASE_SVC_USER_DBPATH
IBASE_SVC_SVR_DB_INFO
IBASE_SVC_GET_USERS
Options to ibase_server_info()

Özkaynak Türleri
Firebird/InterBase İşlevleri
Firebird/InterBase


Firebird/InterBase İşlevleri

İçindekiler

  • ibase_add_user — Add a user to a security database
  • ibase_affected_rows — Return the number of rows that were affected by the previous query
  • ibase_backup — Initiates a backup task in the service manager and returns immediately
  • ibase_blob_add — Add data into a newly created blob
  • ibase_blob_cancel — Cancel creating blob
  • ibase_blob_close — Close blob
  • ibase_blob_create — Create a new blob for adding data
  • ibase_blob_echo — Output blob contents to browser
  • ibase_blob_get — Get len bytes data from open blob
  • ibase_blob_import — Create blob, copy file in it, and close it
  • ibase_blob_info — Return blob length and other useful info
  • ibase_blob_open — Open blob for retrieving data parts
  • ibase_close — Close a connection to an InterBase database
  • ibase_commit_ret — Commit a transaction without closing it
  • ibase_commit — Commit a transaction
  • ibase_connect — Open a connection to a database
  • ibase_db_info — Request statistics about a database
  • ibase_delete_user — Delete a user from a security database
  • ibase_drop_db — Drops a database
  • ibase_errcode — Return an error code
  • ibase_errmsg — Return error messages
  • ibase_execute — Execute a previously prepared query
  • ibase_fetch_assoc — Fetch a result row from a query as an associative array
  • ibase_fetch_object — Get an object from a InterBase database
  • ibase_fetch_row — Fetch a row from an InterBase database
  • ibase_field_info — Get information about a field
  • ibase_free_event_handler — Cancels a registered event handler
  • ibase_free_query — Free memory allocated by a prepared query
  • ibase_free_result — Free a result set
  • ibase_gen_id — Increments the named generator and returns its new value
  • ibase_maintain_db — Execute a maintenance command on the database server
  • ibase_modify_user — Modify a user to a security database
  • ibase_name_result — Assigns a name to a result set
  • ibase_num_fields — Get the number of fields in a result set
  • ibase_num_params — Return the number of parameters in a prepared query
  • ibase_param_info — Return information about a parameter in a prepared query
  • ibase_pconnect — Open a persistent connection to an InterBase database
  • ibase_prepare — Prepare a query for later binding of parameter placeholders and execution
  • ibase_query — Execute a query on an InterBase database
  • ibase_restore — Initiates a restore task in the service manager and returns immediately
  • ibase_rollback_ret — Roll back a transaction without closing it
  • ibase_rollback — Roll back a transaction
  • ibase_server_info — Request information about a database server
  • ibase_service_attach — Connect to the service manager
  • ibase_service_detach — Disconnect from the service manager
  • ibase_set_event_handler — Register a callback function to be called when events are posted
  • ibase_trans — Begin a transaction
  • ibase_wait_event — Wait for an event to be posted by the database
Öntanımlı Sabitler
ibase_add_user
Firebird/InterBase


Add a user to a security database

Firebird/InterBase İşlevleri
ibase_affected_rows
Firebird/InterBase İşlevleri
PHP Manual

ibase_add_user

(PHP 5, PHP 7)

ibase_add_user — Add a user to a security database

Açıklama

bool ibase_add_user ( resource $service_handle , string $user_name , string $password [, string $first_name [, string $middle_name [, string $last_name ]]] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ibase_modify_user() - Modify a user to a security database
  • ibase_delete_user() - Delete a user from a security database

Firebird/InterBase İşlevleri
ibase_affected_rows
Firebird/InterBase İşlevleri


Return the number of rows that were affected by the previous query

ibase_add_user
ibase_backup
Firebird/InterBase İşlevleri
PHP Manual

ibase_affected_rows

(PHP 5, PHP 7)

ibase_affected_rows — Return the number of rows that were affected by the previous query

Açıklama

int ibase_affected_rows ([ resource $link_identifier ] )

This function returns the number of rows that were affected by the previous query (INSERT, UPDATE or DELETE) that was executed from within the specified transaction context.

Değiştirgeler

link_identifier

A transaction context. If link_identifier is a connection resource, its default transaction is used.

Dönen Değerler

Returns the number of rows as an integer.

Ayrıca Bakınız

  • ibase_query() - Execute a query on an InterBase database
  • ibase_execute() - Execute a previously prepared query

ibase_add_user
ibase_backup
Firebird/InterBase İşlevleri


Initiates a backup task in the service manager and returns immediately

ibase_affected_rows
ibase_blob_add
Firebird/InterBase İşlevleri
PHP Manual

ibase_backup

(PHP 5, PHP 7)

ibase_backup — Initiates a backup task in the service manager and returns immediately

Açıklama

mixed ibase_backup ( resource $service_handle , string $source_db , string $dest_file [, int $options = 0 [, bool $verbose = false ]] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ibase_affected_rows
ibase_blob_add
Firebird/InterBase İşlevleri


Add data into a newly created blob

ibase_backup
ibase_blob_cancel
Firebird/InterBase İşlevleri
PHP Manual

ibase_blob_add

(PHP 5, PHP 7)

ibase_blob_add — Add data into a newly created blob

Açıklama

void ibase_blob_add ( resource $blob_handle , string $data )

ibase_blob_add() adds data into a blob created with ibase_blob_create().

Değiştirgeler

blob_handle

A blob handle opened with ibase_blob_create().

data

The data to be added.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • ibase_blob_cancel() - Cancel creating blob
  • ibase_blob_close() - Close blob
  • ibase_blob_create() - Create a new blob for adding data
  • ibase_blob_import() - Create blob, copy file in it, and close it

ibase_backup
ibase_blob_cancel
Firebird/InterBase İşlevleri


Cancel creating blob

ibase_blob_add
ibase_blob_close
Firebird/InterBase İşlevleri
PHP Manual

ibase_blob_cancel

(PHP 5, PHP 7)

ibase_blob_cancel — Cancel creating blob

Açıklama

bool ibase_blob_cancel ( resource $blob_handle )

This function will discard a BLOB if it has not yet been closed by ibase_blob_close().

Değiştirgeler

blob_handle

A BLOB handle opened with ibase_blob_create().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ibase_blob_close() - Close blob
  • ibase_blob_create() - Create a new blob for adding data
  • ibase_blob_import() - Create blob, copy file in it, and close it

ibase_blob_add
ibase_blob_close
Firebird/InterBase İşlevleri


Close blob

ibase_blob_cancel
ibase_blob_create
Firebird/InterBase İşlevleri
PHP Manual

ibase_blob_close

(PHP 5, PHP 7)

ibase_blob_close — Close blob

Açıklama

mixed ibase_blob_close ( resource $blob_handle )

This function closes a BLOB that has either been opened for reading by ibase_blob_open() or has been opened for writing by ibase_blob_create().

Değiştirgeler

blob_handle

A BLOB handle opened with ibase_blob_create() or ibase_blob_open().

Dönen Değerler

If the BLOB was being read, this function returns TRUE on success, if the BLOB was being written to, this function returns a string containing the BLOB id that has been assigned to it by the database. On failure, this function returns FALSE.

Ayrıca Bakınız

  • ibase_blob_cancel() - Cancel creating blob
  • ibase_blob_open() - Open blob for retrieving data parts

ibase_blob_cancel
ibase_blob_create
Firebird/InterBase İşlevleri


Create a new blob for adding data

ibase_blob_close
ibase_blob_echo
Firebird/InterBase İşlevleri
PHP Manual

ibase_blob_create

(PHP 5, PHP 7)

ibase_blob_create — Create a new blob for adding data

Açıklama

resource ibase_blob_create ([ resource $link_identifier = NULL ] )

ibase_blob_create() creates a new BLOB for filling with data.

Değiştirgeler

link_identifier

An InterBase link identifier. If omitted, the last opened link is assumed.

Dönen Değerler

Returns a BLOB handle for later use with ibase_blob_add() başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ibase_blob_add() - Add data into a newly created blob
  • ibase_blob_cancel() - Cancel creating blob
  • ibase_blob_close() - Close blob
  • ibase_blob_import() - Create blob, copy file in it, and close it

ibase_blob_close
ibase_blob_echo
Firebird/InterBase İşlevleri


Output blob contents to browser

ibase_blob_create
ibase_blob_get
Firebird/InterBase İşlevleri
PHP Manual

ibase_blob_echo

(PHP 5, PHP 7)

ibase_blob_echo — Output blob contents to browser

Açıklama

bool ibase_blob_echo ( string $blob_id )
bool ibase_blob_echo ( resource $link_identifier , string $blob_id )

This function opens a BLOB for reading and sends its contents directly to standard output (the browser, in most cases).

Değiştirgeler

link_identifier

An InterBase link identifier. If omitted, the last opened link is assumed.

blob_id

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ibase_blob_open() - Open blob for retrieving data parts
  • ibase_blob_close() - Close blob
  • ibase_blob_get() - Get len bytes data from open blob

ibase_blob_create
ibase_blob_get
Firebird/InterBase İşlevleri


Get len bytes data from open blob

ibase_blob_echo
ibase_blob_import
Firebird/InterBase İşlevleri
PHP Manual

ibase_blob_get

(PHP 5, PHP 7)

ibase_blob_get — Get len bytes data from open blob

Açıklama

string ibase_blob_get ( resource $blob_handle , int $len )

This function returns at most len bytes from a BLOB that has been opened for reading by ibase_blob_open().

Bilginize:

It is not possible to read from a BLOB that has been opened for writing by ibase_blob_create().

Değiştirgeler

blob_handle

A BLOB handle opened with ibase_blob_open().

len

Size of returned data.

Dönen Değerler

Returns at most len bytes from the BLOB, or FALSE on failure.

Örnekler

Örnek 1 ibase_blob_get() example

<?php
$result    = ibase_query("SELECT blob_value FROM table");
$data      = ibase_fetch_object($result);
$blob_data = ibase_blob_info($data->BLOB_VALUE);
$blob_hndl = ibase_blob_open($data->BLOB_VALUE);
echo         ibase_blob_get($blob_hndl, $blob_data[0]);
?>
Whilst this example doesn't do much more than a 'ibase_blob_echo($data->BLOB_VALUE)' would do, it does show you how to get information into a $variable to manipulate as you please.

Ayrıca Bakınız

  • ibase_blob_open() - Open blob for retrieving data parts
  • ibase_blob_close() - Close blob
  • ibase_blob_echo() - Output blob contents to browser

ibase_blob_echo
ibase_blob_import
Firebird/InterBase İşlevleri


Create blob, copy file in it, and close it

ibase_blob_get
ibase_blob_info
Firebird/InterBase İşlevleri
PHP Manual

ibase_blob_import

(PHP 5, PHP 7)

ibase_blob_import — Create blob, copy file in it, and close it

Açıklama

string ibase_blob_import ( resource $link_identifier , resource $file_handle )
string ibase_blob_import ( resource $file_handle )

This function creates a BLOB, reads an entire file into it, closes it and returns the assigned BLOB id.

Değiştirgeler

link_identifier

An InterBase link identifier. If omitted, the last opened link is assumed.

file_handle

The file handle is a handle returned by fopen().

Dönen Değerler

Returns the BLOB id on success, or FALSE on error.

Örnekler

Örnek 1 ibase_blob_import() example

<?php
$dbh = ibase_connect($host, $username, $password);
$filename = '/tmp/bar';

$fd = fopen($filename, 'r');
if ($fd) {

    $blob = ibase_blob_import($dbh, $fd);
    fclose($fd);

    if (!is_string($blob)) {
        // import failed
    } else {
        $query = "INSERT INTO foo (name, data) VALUES ('$filename', ?)";
        $prepared = ibase_prepare($dbh, $query);
        if (!ibase_execute($prepared, $blob)) {
            // record insertion failed
        }
    }
} else {
    // unable to open the data file
}
?>

Ayrıca Bakınız

  • ibase_blob_add() - Add data into a newly created blob
  • ibase_blob_cancel() - Cancel creating blob
  • ibase_blob_close() - Close blob
  • ibase_blob_create() - Create a new blob for adding data

ibase_blob_get
ibase_blob_info
Firebird/InterBase İşlevleri


Return blob length and other useful info

ibase_blob_import
ibase_blob_open
Firebird/InterBase İşlevleri
PHP Manual

ibase_blob_info

(PHP 5, PHP 7)

ibase_blob_info — Return blob length and other useful info

Açıklama

array ibase_blob_info ( resource $link_identifier , string $blob_id )
array ibase_blob_info ( string $blob_id )

Returns the BLOB length and other useful information.

Değiştirgeler

link_identifier

An InterBase link identifier. If omitted, the last opened link is assumed.

blob_id

A BLOB id.

Dönen Değerler

Returns an array containing information about a BLOB. The information returned consists of the length of the BLOB, the number of segments it contains, the size of the largest segment, and whether it is a stream BLOB or a segmented BLOB.

ibase_blob_import
ibase_blob_open
Firebird/InterBase İşlevleri


Open blob for retrieving data parts

ibase_blob_info
ibase_close
Firebird/InterBase İşlevleri
PHP Manual

ibase_blob_open

(PHP 5, PHP 7)

ibase_blob_open — Open blob for retrieving data parts

Açıklama

resource ibase_blob_open ( resource $link_identifier , string $blob_id )
resource ibase_blob_open ( string $blob_id )

Opens an existing BLOB for reading.

Değiştirgeler

link_identifier

An InterBase link identifier. If omitted, the last opened link is assumed.

blob_id

A BLOB id.

Dönen Değerler

Returns a BLOB handle for later use with ibase_blob_get() başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ibase_blob_close() - Close blob
  • ibase_blob_echo() - Output blob contents to browser
  • ibase_blob_get() - Get len bytes data from open blob

ibase_blob_info
ibase_close
Firebird/InterBase İşlevleri


Close a connection to an InterBase database

ibase_blob_open
ibase_commit_ret
Firebird/InterBase İşlevleri
PHP Manual

ibase_close

(PHP 5, PHP 7)

ibase_close — Close a connection to an InterBase database

Açıklama

bool ibase_close ([ resource $connection_id = NULL ] )

Closes the link to an InterBase database that's associated with a connection id returned from ibase_connect(). Default transaction on link is committed, other transactions are rolled back.

Değiştirgeler

connection_id

An InterBase link identifier returned from ibase_connect(). If omitted, the last opened link is assumed.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ibase_connect() - Open a connection to a database
  • ibase_pconnect() - Open a persistent connection to an InterBase database

ibase_blob_open
ibase_commit_ret
Firebird/InterBase İşlevleri


Commit a transaction without closing it

ibase_close
ibase_commit
Firebird/InterBase İşlevleri
PHP Manual

ibase_commit_ret

(PHP 5, PHP 7)

ibase_commit_ret — Commit a transaction without closing it

Açıklama

bool ibase_commit_ret ([ resource $link_or_trans_identifier = NULL ] )

Commits a transaction without closing it.

Değiştirgeler

link_or_trans_identifier

If called without an argument, this function commits the default transaction of the default link. If the argument is a connection identifier, the default transaction of the corresponding connection will be committed. If the argument is a transaction identifier, the corresponding transaction will be committed. The transaction context will be retained, so statements executed from within this transaction will not be invalidated.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

ibase_close
ibase_commit
Firebird/InterBase İşlevleri


Commit a transaction

ibase_commit_ret
ibase_connect
Firebird/InterBase İşlevleri
PHP Manual

ibase_commit

(PHP 5, PHP 7)

ibase_commit — Commit a transaction

Açıklama

bool ibase_commit ([ resource $link_or_trans_identifier = NULL ] )

Commits a transaction.

Değiştirgeler

link_or_trans_identifier

If called without an argument, this function commits the default transaction of the default link. If the argument is a connection identifier, the default transaction of the corresponding connection will be committed. If the argument is a transaction identifier, the corresponding transaction will be committed.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

ibase_commit_ret
ibase_connect
Firebird/InterBase İşlevleri


Open a connection to a database

ibase_commit
ibase_db_info
Firebird/InterBase İşlevleri
PHP Manual

ibase_connect

(PHP 5, PHP 7)

ibase_connect — Open a connection to a database

Açıklama

resource ibase_connect ([ string $database [, string $username [, string $password [, string $charset [, int $buffers [, int $dialect [, string $role [, int $sync ]]]]]]]] )

Establishes a connection to an Firebird/InterBase server.

In case a second call is made to ibase_connect() with the same arguments, no new link will be established, but instead, the link identifier of the already opened link will be returned. The link to the server will be closed as soon as the execution of the script ends, unless it's closed earlier by explicitly calling ibase_close().

Değiştirgeler

database

The database argument has to be a valid path to database file on the server it resides on. If the server is not local, it must be prefixed with either 'hostname:' (TCP/IP), 'hostname/port:' (TCP/IP with interbase server on custom TCP port), '//hostname/' (NetBEUI), depending on the connection protocol used.

username

The user name. Can be set with the ibase.default_user php.ini directive.

password

The password for username. Can be set with the ibase.default_password php.ini directive.

charset

charset is the default character set for a database.

buffers

buffers is the number of database buffers to allocate for the server-side cache. If 0 or omitted, server chooses its own default.

dialect

dialect selects the default SQL dialect for any statement executed within a connection, and it defaults to the highest one supported by client libraries.

role

Functional only with InterBase 5 and up.

sync

Dönen Değerler

Returns an Firebird/InterBase link identifier on success, or FALSE on error.

Hatalar/İstisnalar

If you get some error like "arithmetic exception, numeric overflow, or string truncation. Cannot transliterate character between character sets" (this occurs when you try use some character with accents) when using this and after ibase_query() you must set the character set (i.e. ISO8859_1 or your current character set).

Örnekler

Örnek 1 ibase_connect() example

<?php
$host = 'localhost:/path/to/your.gdb';

$dbh = ibase_connect($host, $username, $password);
$stmt = 'SELECT * FROM tblname';
$sth = ibase_query($dbh, $stmt);
while ($row = ibase_fetch_object($sth)) {
    echo $row->email, "\n";
}
ibase_free_result($sth);
ibase_close($dbh);
?>

Ayrıca Bakınız

  • ibase_pconnect() - Open a persistent connection to an InterBase database
  • ibase_close() - Close a connection to an InterBase database

ibase_commit
ibase_db_info
Firebird/InterBase İşlevleri


Request statistics about a database

ibase_connect
ibase_delete_user
Firebird/InterBase İşlevleri
PHP Manual

ibase_db_info

(PHP 5, PHP 7)

ibase_db_info — Request statistics about a database

Açıklama

string ibase_db_info ( resource $service_handle , string $db , int $action [, int $argument = 0 ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ibase_connect
ibase_delete_user
Firebird/InterBase İşlevleri


Delete a user from a security database

ibase_db_info
ibase_drop_db
Firebird/InterBase İşlevleri
PHP Manual

ibase_delete_user

(PHP 5, PHP 7)

ibase_delete_user — Delete a user from a security database

Açıklama

bool ibase_delete_user ( resource $service_handle , string $user_name )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ibase_add_user() - Add a user to a security database
  • ibase_modify_user() - Modify a user to a security database

ibase_db_info
ibase_drop_db
Firebird/InterBase İşlevleri


Drops a database

ibase_delete_user
ibase_errcode
Firebird/InterBase İşlevleri
PHP Manual

ibase_drop_db

(PHP 5, PHP 7)

ibase_drop_db — Drops a database

Açıklama

bool ibase_drop_db ([ resource $connection = NULL ] )

This functions drops a database that was opened by either ibase_connect() or ibase_pconnect(). The database is closed and deleted from the server.

Değiştirgeler

connection

An InterBase link identifier. If omitted, the last opened link is assumed.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ibase_connect() - Open a connection to a database
  • ibase_pconnect() - Open a persistent connection to an InterBase database

ibase_delete_user
ibase_errcode
Firebird/InterBase İşlevleri


Return an error code

ibase_drop_db
ibase_errmsg
Firebird/InterBase İşlevleri
PHP Manual

ibase_errcode

(PHP 5, PHP 7)

ibase_errcode — Return an error code

Açıklama

int ibase_errcode ( void )

Returns the error code that resulted from the most recent InterBase function call.

Dönen Değerler

Returns the error code as an integer, or FALSE if no error occurred.

Ayrıca Bakınız

  • ibase_errmsg() - Return error messages

ibase_drop_db
ibase_errmsg
Firebird/InterBase İşlevleri


Return error messages

ibase_errcode
ibase_execute
Firebird/InterBase İşlevleri
PHP Manual

ibase_errmsg

(PHP 5, PHP 7)

ibase_errmsg — Return error messages

Açıklama

string ibase_errmsg ( void )

Returns the error message that resulted from the most recent InterBase function call.

Dönen Değerler

Returns the error message as a string, or FALSE if no error occurred.

Ayrıca Bakınız

  • ibase_errcode() - Return an error code

ibase_errcode
ibase_execute
Firebird/InterBase İşlevleri


Execute a previously prepared query

ibase_errmsg
ibase_fetch_assoc
Firebird/InterBase İşlevleri
PHP Manual

ibase_execute

(PHP 5, PHP 7)

ibase_execute — Execute a previously prepared query

Açıklama

resource ibase_execute ( resource $query [, mixed $bind_arg [, mixed $... ]] )

Execute a query prepared by ibase_prepare().

This is a lot more effective than using ibase_query() if you are repeating a same kind of query several times with only some parameters changing.

Değiştirgeler

query

An InterBase query prepared by ibase_prepare().

bind_arg

...

Dönen Değerler

If the query raises an error, returns FALSE. If it is successful and there is a (possibly empty) result set (such as with a SELECT query), returns a result identifier. If the query was successful and there were no results, returns TRUE.

Bilginize:

This function returns the number of rows affected by the query (if > 0 and applicable to the statement type). A query that succeeded, but did not affect any rows (e.g. an UPDATE of a non-existent record) will return TRUE.

Örnekler

Örnek 1 ibase_execute() example

<?php

$dbh = ibase_connect($host, $username, $password);

$updates = array(
    1 => 'Eric',
    5 => 'Filip',
    7 => 'Larry'
);

$query = ibase_prepare($dbh, "UPDATE FOO SET BAR = ? WHERE BAZ = ?");

foreach ($updates as $baz => $bar) {
    ibase_execute($query, $bar, $baz);
}

?>

Ayrıca Bakınız

  • ibase_query() - Execute a query on an InterBase database

ibase_errmsg
ibase_fetch_assoc
Firebird/InterBase İşlevleri


Fetch a result row from a query as an associative array

ibase_execute
ibase_fetch_object
Firebird/InterBase İşlevleri
PHP Manual

ibase_fetch_assoc

(PHP 5, PHP 7)

ibase_fetch_assoc — Fetch a result row from a query as an associative array

Açıklama

array ibase_fetch_assoc ( resource $result [, int $fetch_flag = 0 ] )

Fetch a result row from a query as an associative array.

ibase_fetch_assoc() fetches one row of data from the result. If two or more columns of the result have the same field names, the last column will take precedence. To access the other column(s) of the same name, you either need to access the result with numeric indices by using ibase_fetch_row() or use alias names in your query.

Değiştirgeler

result

The result handle.

fetch_flag

fetch_flag is a combination of the constants IBASE_TEXT and IBASE_UNIXTIME ORed together. Passing IBASE_TEXT will cause this function to return BLOB contents instead of BLOB ids. Passing IBASE_UNIXTIME will cause this function to return date/time values as Unix timestamps instead of as formatted strings.

Dönen Değerler

Returns an associative array that corresponds to the fetched row. Subsequent calls will return the next row in the result set, or FALSE if there are no more rows.

Ayrıca Bakınız

  • ibase_fetch_row() - Fetch a row from an InterBase database
  • ibase_fetch_object() - Get an object from a InterBase database

ibase_execute
ibase_fetch_object
Firebird/InterBase İşlevleri


Get an object from a InterBase database

ibase_fetch_assoc
ibase_fetch_row
Firebird/InterBase İşlevleri
PHP Manual

ibase_fetch_object

(PHP 5, PHP 7)

ibase_fetch_object — Get an object from a InterBase database

Açıklama

object ibase_fetch_object ( resource $result_id [, int $fetch_flag = 0 ] )

Fetches a row as a pseudo-object from a given result identifier.

Subsequent calls to ibase_fetch_object() return the next row in the result set.

Değiştirgeler

result_id

An InterBase result identifier obtained either by ibase_query() or ibase_execute().

fetch_flag

fetch_flag is a combination of the constants IBASE_TEXT and IBASE_UNIXTIME ORed together. Passing IBASE_TEXT will cause this function to return BLOB contents instead of BLOB ids. Passing IBASE_UNIXTIME will cause this function to return date/time values as Unix timestamps instead of as formatted strings.

Dönen Değerler

Returns an object with the next row information, or FALSE if there are no more rows.

Örnekler

Örnek 1 ibase_fetch_object() example

<?php
$dbh = ibase_connect($host, $username, $password);
$stmt = 'SELECT * FROM tblname';
$sth = ibase_query($dbh, $stmt);
while ($row = ibase_fetch_object($sth)) {
    echo $row->email . "\n";
}
ibase_close($dbh);
?>

Ayrıca Bakınız

  • ibase_fetch_row() - Fetch a row from an InterBase database
  • ibase_fetch_assoc() - Fetch a result row from a query as an associative array

ibase_fetch_assoc
ibase_fetch_row
Firebird/InterBase İşlevleri


Fetch a row from an InterBase database

ibase_fetch_object
ibase_field_info
Firebird/InterBase İşlevleri
PHP Manual

ibase_fetch_row

(PHP 5, PHP 7)

ibase_fetch_row — Fetch a row from an InterBase database

Açıklama

array ibase_fetch_row ( resource $result_identifier [, int $fetch_flag = 0 ] )

ibase_fetch_row() fetches one row of data from the given result set.

Subsequent calls to ibase_fetch_row() return the next row in the result set, or FALSE if there are no more rows.

Değiştirgeler

result_identifier

An InterBase result identifier.

fetch_flag

fetch_flag is a combination of the constants IBASE_TEXT and IBASE_UNIXTIME ORed together. Passing IBASE_TEXT will cause this function to return BLOB contents instead of BLOB ids. Passing IBASE_UNIXTIME will cause this function to return date/time values as Unix timestamps instead of as formatted strings.

Dönen Değerler

Returns an array that corresponds to the fetched row, or FALSE if there are no more rows. Each result column is stored in an array offset, starting at offset 0.

Ayrıca Bakınız

  • ibase_fetch_assoc() - Fetch a result row from a query as an associative array
  • ibase_fetch_object() - Get an object from a InterBase database

ibase_fetch_object
ibase_field_info
Firebird/InterBase İşlevleri


Get information about a field

ibase_fetch_row
ibase_free_event_handler
Firebird/InterBase İşlevleri
PHP Manual

ibase_field_info

(PHP 5, PHP 7)

ibase_field_info — Get information about a field

Açıklama

array ibase_field_info ( resource $result , int $field_number )

Returns an array with information about a field after a select query has been run.

Değiştirgeler

result

An InterBase result identifier.

field_number

Field offset.

Dönen Değerler

Returns an array with the following keys: name, alias, relation, length and type.

Örnekler

Örnek 1 ibase_field_info() example

<?php
$rs = ibase_query("SELECT * FROM tablename");
$coln = ibase_num_fields($rs);
for ($i = 0; $i < $coln; $i++) {
    $col_info = ibase_field_info($rs, $i);
    echo "name: ". $col_info['name']. "\n";
    echo "alias: ". $col_info['alias']. "\n";
    echo "relation: ". $col_info['relation']. "\n";
    echo "length: ". $col_info['length']. "\n";
    echo "type: ". $col_info['type']. "\n";
}
?>

Ayrıca Bakınız

  • ibase_num_fields() - Get the number of fields in a result set

ibase_fetch_row
ibase_free_event_handler
Firebird/InterBase İşlevleri


Cancels a registered event handler

ibase_field_info
ibase_free_query
Firebird/InterBase İşlevleri
PHP Manual

ibase_free_event_handler

(PHP 5, PHP 7)

ibase_free_event_handler — Cancels a registered event handler

Açıklama

bool ibase_free_event_handler ( resource $event )

This function causes the registered event handler specified by event to be cancelled. The callback function will no longer be called for the events it was registered to handle.

Değiştirgeler

event

An event resource, created by ibase_set_event_handler().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ibase_set_event_handler() - Register a callback function to be called when events are posted

ibase_field_info
ibase_free_query
Firebird/InterBase İşlevleri


Free memory allocated by a prepared query

ibase_free_event_handler
ibase_free_result
Firebird/InterBase İşlevleri
PHP Manual

ibase_free_query

(PHP 5, PHP 7)

ibase_free_query — Free memory allocated by a prepared query

Açıklama

bool ibase_free_query ( resource $query )

Frees a prepared query.

Değiştirgeler

query

A query prepared with ibase_prepare().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

ibase_free_event_handler
ibase_free_result
Firebird/InterBase İşlevleri


Free a result set

ibase_free_query
ibase_gen_id
Firebird/InterBase İşlevleri
PHP Manual

ibase_free_result

(PHP 5, PHP 7)

ibase_free_result — Free a result set

Açıklama

bool ibase_free_result ( resource $result_identifier )

Frees a result set.

Değiştirgeler

result_identifier

A result set created by ibase_query() or ibase_execute().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

ibase_free_query
ibase_gen_id
Firebird/InterBase İşlevleri


Increments the named generator and returns its new value

ibase_free_result
ibase_maintain_db
Firebird/InterBase İşlevleri
PHP Manual

ibase_gen_id

(PHP 5, PHP 7)

ibase_gen_id — Increments the named generator and returns its new value

Açıklama

mixed ibase_gen_id ( string $generator [, int $increment = 1 [, resource $link_identifier = NULL ]] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Dönen Değerler

Returns new generator value as integer, or as string if the value is too big.

ibase_free_result
ibase_maintain_db
Firebird/InterBase İşlevleri


Execute a maintenance command on the database server

ibase_gen_id
ibase_modify_user
Firebird/InterBase İşlevleri
PHP Manual

ibase_maintain_db

(PHP 5, PHP 7)

ibase_maintain_db — Execute a maintenance command on the database server

Açıklama

bool ibase_maintain_db ( resource $service_handle , string $db , int $action [, int $argument = 0 ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

ibase_gen_id
ibase_modify_user
Firebird/InterBase İşlevleri


Modify a user to a security database

ibase_maintain_db
ibase_name_result
Firebird/InterBase İşlevleri
PHP Manual

ibase_modify_user

(PHP 5, PHP 7)

ibase_modify_user — Modify a user to a security database

Açıklama

bool ibase_modify_user ( resource $service_handle , string $user_name , string $password [, string $first_name [, string $middle_name [, string $last_name ]]] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ibase_add_user() - Add a user to a security database
  • ibase_delete_user() - Delete a user from a security database

ibase_maintain_db
ibase_name_result
Firebird/InterBase İşlevleri


Assigns a name to a result set

ibase_modify_user
ibase_num_fields
Firebird/InterBase İşlevleri
PHP Manual

ibase_name_result

(PHP 5, PHP 7)

ibase_name_result — Assigns a name to a result set

Açıklama

bool ibase_name_result ( resource $result , string $name )

This function assigns a name to a result set. This name can be used later in UPDATE|DELETE ... WHERE CURRENT OF name statements.

Değiştirgeler

result

An InterBase result set.

name

The name to be assigned.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 ibase_name_result() example

<?php
$result = ibase_query("SELECT field1,field2 FROM table FOR UPDATE");
ibase_name_result($result, "my_cursor");

$updateqry = ibase_prepare("UPDATE table SET field2 = ? WHERE CURRENT OF my_cursor");

for ($i = 0; ibase_fetch_row($result); ++$i) {
    ibase_execute($updateqry, $i);
}
?>

Ayrıca Bakınız

  • ibase_prepare() - Prepare a query for later binding of parameter placeholders and execution
  • ibase_execute() - Execute a previously prepared query

ibase_modify_user
ibase_num_fields
Firebird/InterBase İşlevleri


Get the number of fields in a result set

ibase_name_result
ibase_num_params
Firebird/InterBase İşlevleri
PHP Manual

ibase_num_fields

(PHP 5, PHP 7)

ibase_num_fields — Get the number of fields in a result set

Açıklama

int ibase_num_fields ( resource $result_id )

Get the number of fields in a result set.

Değiştirgeler

result_id

An InterBase result identifier.

Dönen Değerler

Returns the number of fields as an integer.

Örnekler

Örnek 1 ibase_num_fields() example

<?php
$rs = ibase_query("SELECT * FROM tablename");
$coln = ibase_num_fields($rs);
for ($i = 0; $i < $coln; $i++) {
    $col_info = ibase_field_info($rs, $i);
    echo "name: " . $col_info['name'] . "\n";
    echo "alias: " . $col_info['alias'] . "\n";
    echo "relation: " . $col_info['relation'] . "\n";
    echo "length: " . $col_info['length'] . "\n";
    echo "type: " . $col_info['type'] . "\n";
}
?>

Ayrıca Bakınız

  • ibase_field_info() - Get information about a field

ibase_name_result
ibase_num_params
Firebird/InterBase İşlevleri


Return the number of parameters in a prepared query

ibase_num_fields
ibase_param_info
Firebird/InterBase İşlevleri
PHP Manual

ibase_num_params

(PHP 5, PHP 7)

ibase_num_params — Return the number of parameters in a prepared query

Açıklama

int ibase_num_params ( resource $query )

This function returns the number of parameters in the prepared query specified by query. This is the number of binding arguments that must be present when calling ibase_execute().

Değiştirgeler

query

The prepared query handle.

Dönen Değerler

Returns the number of parameters as an integer.

Ayrıca Bakınız

  • ibase_prepare() - Prepare a query for later binding of parameter placeholders and execution
  • ibase_param_info() - Return information about a parameter in a prepared query

ibase_num_fields
ibase_param_info
Firebird/InterBase İşlevleri


Return information about a parameter in a prepared query

ibase_num_params
ibase_pconnect
Firebird/InterBase İşlevleri
PHP Manual

ibase_param_info

(PHP 5, PHP 7)

ibase_param_info — Return information about a parameter in a prepared query

Açıklama

array ibase_param_info ( resource $query , int $param_number )

Returns an array with information about a parameter after a query has been prepared.

Değiştirgeler

query

An InterBase prepared query handle.

param_number

Parameter offset.

Dönen Değerler

Returns an array with the following keys: name, alias, relation, length and type.

Ayrıca Bakınız

  • ibase_field_info() - Get information about a field
  • ibase_num_params() - Return the number of parameters in a prepared query

ibase_num_params
ibase_pconnect
Firebird/InterBase İşlevleri


Open a persistent connection to an InterBase database

ibase_param_info
ibase_prepare
Firebird/InterBase İşlevleri
PHP Manual

ibase_pconnect

(PHP 5, PHP 7)

ibase_pconnect — Open a persistent connection to an InterBase database

Açıklama

resource ibase_pconnect ([ string $database [, string $username [, string $password [, string $charset [, int $buffers [, int $dialect [, string $role [, int $sync ]]]]]]]] )

Opens a persistent connection to an InterBase database.

ibase_pconnect() acts very much like ibase_connect() with two major differences.

First, when connecting, the function will first try to find a (persistent) link that's already opened with the same parameters. If one is found, an identifier for it will be returned instead of opening a new connection.

Second, the connection to the InterBase server will not be closed when the execution of the script ends. Instead, the link will remain open for future use (ibase_close() will not close links established by ibase_pconnect()). This type of link is therefore called 'persistent'.

Değiştirgeler

database

The database argument has to be a valid path to database file on the server it resides on. If the server is not local, it must be prefixed with either 'hostname:' (TCP/IP), '//hostname/' (NetBEUI) or 'hostname@' (IPX/SPX), depending on the connection protocol used.

username

The user name. Can be set with the ibase.default_user php.ini directive.

password

The password for username. Can be set with the ibase.default_password php.ini directive.

charset

charset is the default character set for a database.

buffers

buffers is the number of database buffers to allocate for the server-side cache. If 0 or omitted, server chooses its own default.

dialect

dialect selects the default SQL dialect for any statement executed within a connection, and it defaults to the highest one supported by client libraries. Functional only with InterBase 6 and up.

role

Functional only with InterBase 5 and up.

sync

Dönen Değerler

Returns an InterBase link identifier on success, or FALSE on error.

Ayrıca Bakınız

  • ibase_close() - Close a connection to an InterBase database
  • ibase_connect() - Open a connection to a database

ibase_param_info
ibase_prepare
Firebird/InterBase İşlevleri


Prepare a query for later binding of parameter placeholders and execution

ibase_pconnect
ibase_query
Firebird/InterBase İşlevleri
PHP Manual

ibase_prepare

(PHP 5, PHP 7)

ibase_prepare — Prepare a query for later binding of parameter placeholders and execution

Açıklama

resource ibase_prepare ( string $query )
resource ibase_prepare ( resource $link_identifier , string $query )
resource ibase_prepare ( resource $link_identifier , string $trans , string $query )

Prepare a query for later binding of parameter placeholders and execution (via ibase_execute()).

Değiştirgeler

query

An InterBase query.

link_identifier

An InterBase link identifier returned from ibase_connect(). If omitted, the last opened link is assumed.

trans

An InterBase transaction handle the query should be associated with. If omitted, the default transaction of the connection is assumed.

Dönen Değerler

Returns a prepared query handle, or FALSE on error.

ibase_pconnect
ibase_query
Firebird/InterBase İşlevleri


Execute a query on an InterBase database

ibase_prepare
ibase_restore
Firebird/InterBase İşlevleri
PHP Manual

ibase_query

(PHP 5, PHP 7)

ibase_query — Execute a query on an InterBase database

Açıklama

resource ibase_query ([ resource $link_identifier ], string $query [, int $bind_args ] )

Performs a query on an InterBase database.

Değiştirgeler

link_identifier

An InterBase link identifier. If omitted, the last opened link is assumed.

query

An InterBase query.

bind_args

Dönen Değerler

If the query raises an error, returns FALSE. If it is successful and there is a (possibly empty) result set (such as with a SELECT query), returns a result identifier. If the query was successful and there were no results, returns TRUE.

Bilginize:

In PHP 5.0.0 and up, this function will return the number of rows affected by the query for INSERT, UPDATE and DELETE statements. In order to retain backward compatibility, it will return TRUE for these statements if the query succeeded without affecting any rows.

Hatalar/İstisnalar

If you get some error like "arithmetic exception, numeric overflow, or string truncation. Cannot transliterate character between character sets" (this occurs when you try use some character with accents) when using this and after ibase_query() you must set the character set (i.e. ISO8859_1 or your current character set).

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.1 | On success the function now returns TRUE if there were no affected rows, where it previously returned 0 (a zero followed by an empty space).

Örnekler

Örnek 1 ibase_query() example

<?php

$host = 'localhost:/path/to/your.gdb';

$dbh = ibase_connect($host, $username, $password);
$stmt = 'SELECT * FROM tblname';

$sth = ibase_query($dbh, $stmt) or die(ibase_errmsg());

?>

Ayrıca Bakınız

  • ibase_errmsg() - Return error messages
  • ibase_fetch_row() - Fetch a row from an InterBase database
  • ibase_fetch_object() - Get an object from a InterBase database
  • ibase_free_result() - Free a result set

ibase_prepare
ibase_restore
Firebird/InterBase İşlevleri


Initiates a restore task in the service manager and returns immediately

ibase_query
ibase_rollback_ret
Firebird/InterBase İşlevleri
PHP Manual

ibase_restore

(PHP 5, PHP 7)

ibase_restore — Initiates a restore task in the service manager and returns immediately

Açıklama

mixed ibase_restore ( resource $service_handle , string $source_file , string $dest_db [, int $options = 0 [, bool $verbose = false ]] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ibase_query
ibase_rollback_ret
Firebird/InterBase İşlevleri


Roll back a transaction without closing it

ibase_restore
ibase_rollback
Firebird/InterBase İşlevleri
PHP Manual

ibase_rollback_ret

(PHP 5, PHP 7)

ibase_rollback_ret — Roll back a transaction without closing it

Açıklama

bool ibase_rollback_ret ([ resource $link_or_trans_identifier = NULL ] )

Rolls back a transaction without closing it.

Değiştirgeler

link_or_trans_identifier

If called without an argument, this function rolls back the default transaction of the default link. If the argument is a connection identifier, the default transaction of the corresponding connection will be rolled back. If the argument is a transaction identifier, the corresponding transaction will be rolled back. The transaction context will be retained, so statements executed from within this transaction will not be invalidated.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

ibase_restore
ibase_rollback
Firebird/InterBase İşlevleri


Roll back a transaction

ibase_rollback_ret
ibase_server_info
Firebird/InterBase İşlevleri
PHP Manual

ibase_rollback

(PHP 5, PHP 7)

ibase_rollback — Roll back a transaction

Açıklama

bool ibase_rollback ([ resource $link_or_trans_identifier = NULL ] )

Rolls back a transaction.

Değiştirgeler

link_or_trans_identifier

If called without an argument, this function rolls back the default transaction of the default link. If the argument is a connection identifier, the default transaction of the corresponding connection will be rolled back. If the argument is a transaction identifier, the corresponding transaction will be rolled back.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

ibase_rollback_ret
ibase_server_info
Firebird/InterBase İşlevleri


Request information about a database server

ibase_rollback
ibase_service_attach
Firebird/InterBase İşlevleri
PHP Manual

ibase_server_info

(PHP 5, PHP 7)

ibase_server_info — Request information about a database server

Açıklama

string ibase_server_info ( resource $service_handle , int $action )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ibase_rollback
ibase_service_attach
Firebird/InterBase İşlevleri


Connect to the service manager

ibase_server_info
ibase_service_detach
Firebird/InterBase İşlevleri
PHP Manual

ibase_service_attach

(PHP 5, PHP 7)

ibase_service_attach — Connect to the service manager

Açıklama

resource ibase_service_attach ( string $host , string $dba_username , string $dba_password )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ibase_server_info
ibase_service_detach
Firebird/InterBase İşlevleri


Disconnect from the service manager

ibase_service_attach
ibase_set_event_handler
Firebird/InterBase İşlevleri
PHP Manual

ibase_service_detach

(PHP 5, PHP 7)

ibase_service_detach — Disconnect from the service manager

Açıklama

bool ibase_service_detach ( resource $service_handle )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

ibase_service_attach
ibase_set_event_handler
Firebird/InterBase İşlevleri


Register a callback function to be called when events are posted

ibase_service_detach
ibase_trans
Firebird/InterBase İşlevleri
PHP Manual

ibase_set_event_handler

(PHP 5, PHP 7)

ibase_set_event_handler — Register a callback function to be called when events are posted

Açıklama

resource ibase_set_event_handler ( callable $event_handler , string $event_name1 [, string $event_name2 [, string $... ]] )
resource ibase_set_event_handler ( resource $connection , callable $event_handler , string $event_name1 [, string $event_name2 [, string $... ]] )

This function registers a PHP user function as event handler for the specified events.

Değiştirgeler

event_handler

The callback is called with the event name and the link resource as arguments whenever one of the specified events is posted by the database.

The callback must return FALSE if the event handler should be canceled. Any other return value is ignored. This function accepts up to 15 event arguments.

event_name1

An event name.

event_name2

At most 15 events allowed.

Dönen Değerler

The return value is an event resource. This resource can be used to free the event handler using ibase_free_event_handler().

Örnekler

Örnek 1 ibase_set_event_handler() example

<?php

function event_handler($event_name, $link)
{
    if ($event_name == "NEW ORDER") {
        // process new order
        ibase_query($link, "UPDATE orders SET status='handled'");
    } else if ($event_name == "DB_SHUTDOWN") {
        // free event handler
        return false;
    }
}

ibase_set_event_handler($link, "event_handler", "NEW_ORDER", "DB_SHUTDOWN");
?>

Ayrıca Bakınız

  • ibase_free_event_handler() - Cancels a registered event handler
  • ibase_wait_event() - Wait for an event to be posted by the database

ibase_service_detach
ibase_trans
Firebird/InterBase İşlevleri


Begin a transaction

ibase_set_event_handler
ibase_wait_event
Firebird/InterBase İşlevleri
PHP Manual

ibase_trans

(PHP 5, PHP 7)

ibase_trans — Begin a transaction

Açıklama

resource ibase_trans ([ int $trans_args [, resource $link_identifier ]] )
resource ibase_trans ([ resource $link_identifier [, int $trans_args ]] )

Begins a transaction.

Bilginize:

The first call to ibase_trans() will not return the default transaction of a connection. All transactions started by ibase_trans() will be rolled back at the end of the script if they were not committed or rolled back by either ibase_commit() or ibase_rollback().

Bilginize:

This function will accept multiple trans_args and link_identifier arguments. This allows transactions over multiple database connections, which are committed using a 2-phase commit algorithm. This means you can rely on the updates to either succeed in every database, or fail in every database. It does NOT mean you can use tables from different databases in the same query!

If you use transactions over multiple databases, you will have to specify both the link_id and transaction_id in calls to ibase_query() and ibase_prepare().

Değiştirgeler

trans_args

trans_args can be a combination of IBASE_READ, IBASE_WRITE, IBASE_COMMITTED, IBASE_CONSISTENCY, IBASE_CONCURRENCY, IBASE_REC_VERSION, IBASE_REC_NO_VERSION, IBASE_WAIT and IBASE_NOWAIT.

link_identifier

An InterBase link identifier. If omitted, the last opened link is assumed.

Dönen Değerler

Returns a transaction handle, or FALSE on error.

ibase_set_event_handler
ibase_wait_event
Firebird/InterBase İşlevleri


Wait for an event to be posted by the database

ibase_trans
FrontBase
Firebird/InterBase İşlevleri
PHP Manual

ibase_wait_event

(PHP 5, PHP 7)

ibase_wait_event — Wait for an event to be posted by the database

Açıklama

string ibase_wait_event ( string $event_name1 [, string $event_name2 [, string $... ]] )
string ibase_wait_event ( resource $connection , string $event_name1 [, string $event_name2 [, string $... ]] )

This function suspends execution of the script until one of the specified events is posted by the database. The name of the event that was posted is returned. This function accepts up to 15 event arguments.

Değiştirgeler

event_name1

The event name.

event_name2

...

Dönen Değerler

Returns the name of the event that was posted.

Ayrıca Bakınız

  • ibase_set_event_handler() - Register a callback function to be called when events are posted
  • ibase_free_event_handler() - Cancels a registered event handler

ibase_trans
FrontBase
Firebird/InterBase İşlevleri


FrontBase

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • FrontBase İşlevleri
    • fbsql_affected_rows — Get number of affected rows in previous FrontBase operation
    • fbsql_autocommit — Enable or disable autocommit
    • fbsql_blob_size — Get the size of a BLOB
    • fbsql_change_user — Change logged in user of the active connection
    • fbsql_clob_size — Get the size of a CLOB
    • fbsql_close — Close FrontBase connection
    • fbsql_commit — Commits a transaction to the database
    • fbsql_connect — Open a connection to a FrontBase Server
    • fbsql_create_blob — Create a BLOB
    • fbsql_create_clob — Create a CLOB
    • fbsql_create_db — Create a FrontBase database
    • fbsql_data_seek — Move internal result pointer
    • fbsql_database_password — Sets or retrieves the password for a FrontBase database
    • fbsql_database — Get or set the database name used with a connection
    • fbsql_db_query — Send a FrontBase query
    • fbsql_db_status — Get the status for a given database
    • fbsql_drop_db — Drop (delete) a FrontBase database
    • fbsql_errno — Returns the error number from previous operation
    • fbsql_error — Returns the error message from previous operation
    • fbsql_fetch_array — Fetch a result row as an associative array, a numeric array, or both
    • fbsql_fetch_assoc — Fetch a result row as an associative array
    • fbsql_fetch_field — Get column information from a result and return as an object
    • fbsql_fetch_lengths — Get the length of each output in a result
    • fbsql_fetch_object — Fetch a result row as an object
    • fbsql_fetch_row — Get a result row as an enumerated array
    • fbsql_field_flags — Get the flags associated with the specified field in a result
    • fbsql_field_len — Returns the length of the specified field
    • fbsql_field_name — Get the name of the specified field in a result
    • fbsql_field_seek — Set result pointer to a specified field offset
    • fbsql_field_table — Get name of the table the specified field is in
    • fbsql_field_type — Get the type of the specified field in a result
    • fbsql_free_result — Free result memory
    • fbsql_get_autostart_info — Açıklama
    • fbsql_hostname — Get or set the host name used with a connection
    • fbsql_insert_id — Get the id generated from the previous INSERT operation
    • fbsql_list_dbs — List databases available on a FrontBase server
    • fbsql_list_fields — List FrontBase result fields
    • fbsql_list_tables — List tables in a FrontBase database
    • fbsql_next_result — Move the internal result pointer to the next result
    • fbsql_num_fields — Get number of fields in result
    • fbsql_num_rows — Get number of rows in result
    • fbsql_password — Get or set the user password used with a connection
    • fbsql_pconnect — Open a persistent connection to a FrontBase Server
    • fbsql_query — Send a FrontBase query
    • fbsql_read_blob — Read a BLOB from the database
    • fbsql_read_clob — Read a CLOB from the database
    • fbsql_result — Get result data
    • fbsql_rollback — Rollback a transaction to the database
    • fbsql_rows_fetched — Get the number of rows affected by the last statement
    • fbsql_select_db — Select a FrontBase database
    • fbsql_set_characterset — Change input/output character set
    • fbsql_set_lob_mode — Set the LOB retrieve mode for a FrontBase result set
    • fbsql_set_password — Change the password for a given user
    • fbsql_set_transaction — Set the transaction locking and isolation
    • fbsql_start_db — Start a database on local or remote server
    • fbsql_stop_db — Stop a database on local or remote server
    • fbsql_table_name — Get table name of field
    • fbsql_tablename — Takma Adı: fbsql_table_name
    • fbsql_username — Get or set the username for the connection
    • fbsql_warnings — Enable or disable FrontBase warnings
ibase_wait_event
Giriş
Sağlayıcıya Göre Veritabanı Eklentileri


Giriş

These functions allow you to access FrontBase database servers. More information about FrontBase can be found at » http://www.frontbase.com/.

Documentation for FrontBase can be found at » http://www.frontbase.com/cgi-bin/WebObjects/FBWebSite.woa.

Frontbase support has been added to PHP 4.0.6.

Bilginize:

Bu eklenti » PECL deposuna taşınmış olup şu sürümden itibaren PHP kaynak paketinde dağıtılmamaktatır: PHP 5.3.0.

FrontBase
Yapılandırma/Kurulum
FrontBase


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
FrontBase


Gereksinimler

You must install the FrontBase database server or at least the fbsql client libraries to use this functions. You can get FrontBase from » http://www.frontbase.com/.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

In order to have these functions available, you must compile PHP with fbsql support by using the --with-fbsql[=DIR] option. If you use this option without specifying the path to fbsql, PHP will search for the fbsql client libraries in the default installation location for the platform. Users who installed FrontBase in a non standard directory should always specify the path to fbsql: --with-fbsql=/path/to/fbsql . This will force PHP to use the client libraries installed by FrontBase, avoiding any conflicts.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

FrontBase configuration options
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
fbsql.allow_persistent | "1" | PHP_INI_SYSTEM | Available since PHP 4.0.6.
fbsql.generate_warnings | "0" | PHP_INI_SYSTEM | Available since PHP 4.0.6.
fbsql.autocommit | "1" | PHP_INI_SYSTEM | Available since PHP 4.0.6.
fbsql.max_persistent | "-1" | PHP_INI_SYSTEM | Available since PHP 4.0.6.
fbsql.max_links | "128" | PHP_INI_SYSTEM | Available since PHP 4.0.6.
fbsql.max_connections | "128" | PHP_INI_SYSTEM | Available since PHP 4.0.6.
fbsql.max_results | "128" | PHP_INI_SYSTEM | Available since PHP 4.0.6.
fbsql.batchSize | "1000" | PHP_INI_SYSTEM | Available since PHP 4.2.0. Removed in PHP 5.1.0.
fbsql.default_host | NULL | PHP_INI_SYSTEM | Available since PHP 4.0.6.
fbsql.default_user | "_SYSTEM" | PHP_INI_SYSTEM | Available since PHP 4.0.6.
fbsql.default_password | "" | PHP_INI_SYSTEM | Available since PHP 4.0.6.
fbsql.default_database | "" | PHP_INI_SYSTEM | Available since PHP 4.0.6.
fbsql.default_database_password | "" | PHP_INI_SYSTEM | Available since PHP 4.0.6.
fbsql.mbatchSize | "1000" | PHP_INI_SYSTEM | Available since PHP 4.0.6. Removed in PHP 4.2.0.
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

FBSQL_ASSOC (integer)
FBSQL_NUM (integer)
FBSQL_BOTH (integer)
FBSQL_LOCK_DEFERRED (integer)
FBSQL_LOCK_OPTIMISTIC (integer)
FBSQL_LOCK_PESSIMISTIC (integer)
FBSQL_ISO_READ_UNCOMMITTED (integer)
FBSQL_ISO_READ_COMMITTED (integer)
FBSQL_ISO_REPEATABLE_READ (integer)
FBSQL_ISO_SERIALIZABLE (integer)
FBSQL_ISO_VERSIONED (integer)
FBSQL_UNKNOWN (integer)
FBSQL_STOPPED (integer)
FBSQL_STARTING (integer)
FBSQL_RUNNING (integer)
FBSQL_STOPPING (integer)
FBSQL_NOEXEC (integer)
FBSQL_LOB_DIRECT (integer)
FBSQL_LOB_HANDLE (integer)
Özkaynak Türleri
FrontBase İşlevleri
FrontBase


FrontBase İşlevleri

İçindekiler

  • fbsql_affected_rows — Get number of affected rows in previous FrontBase operation
  • fbsql_autocommit — Enable or disable autocommit
  • fbsql_blob_size — Get the size of a BLOB
  • fbsql_change_user — Change logged in user of the active connection
  • fbsql_clob_size — Get the size of a CLOB
  • fbsql_close — Close FrontBase connection
  • fbsql_commit — Commits a transaction to the database
  • fbsql_connect — Open a connection to a FrontBase Server
  • fbsql_create_blob — Create a BLOB
  • fbsql_create_clob — Create a CLOB
  • fbsql_create_db — Create a FrontBase database
  • fbsql_data_seek — Move internal result pointer
  • fbsql_database_password — Sets or retrieves the password for a FrontBase database
  • fbsql_database — Get or set the database name used with a connection
  • fbsql_db_query — Send a FrontBase query
  • fbsql_db_status — Get the status for a given database
  • fbsql_drop_db — Drop (delete) a FrontBase database
  • fbsql_errno — Returns the error number from previous operation
  • fbsql_error — Returns the error message from previous operation
  • fbsql_fetch_array — Fetch a result row as an associative array, a numeric array, or both
  • fbsql_fetch_assoc — Fetch a result row as an associative array
  • fbsql_fetch_field — Get column information from a result and return as an object
  • fbsql_fetch_lengths — Get the length of each output in a result
  • fbsql_fetch_object — Fetch a result row as an object
  • fbsql_fetch_row — Get a result row as an enumerated array
  • fbsql_field_flags — Get the flags associated with the specified field in a result
  • fbsql_field_len — Returns the length of the specified field
  • fbsql_field_name — Get the name of the specified field in a result
  • fbsql_field_seek — Set result pointer to a specified field offset
  • fbsql_field_table — Get name of the table the specified field is in
  • fbsql_field_type — Get the type of the specified field in a result
  • fbsql_free_result — Free result memory
  • fbsql_get_autostart_info — Açıklama
  • fbsql_hostname — Get or set the host name used with a connection
  • fbsql_insert_id — Get the id generated from the previous INSERT operation
  • fbsql_list_dbs — List databases available on a FrontBase server
  • fbsql_list_fields — List FrontBase result fields
  • fbsql_list_tables — List tables in a FrontBase database
  • fbsql_next_result — Move the internal result pointer to the next result
  • fbsql_num_fields — Get number of fields in result
  • fbsql_num_rows — Get number of rows in result
  • fbsql_password — Get or set the user password used with a connection
  • fbsql_pconnect — Open a persistent connection to a FrontBase Server
  • fbsql_query — Send a FrontBase query
  • fbsql_read_blob — Read a BLOB from the database
  • fbsql_read_clob — Read a CLOB from the database
  • fbsql_result — Get result data
  • fbsql_rollback — Rollback a transaction to the database
  • fbsql_rows_fetched — Get the number of rows affected by the last statement
  • fbsql_select_db — Select a FrontBase database
  • fbsql_set_characterset — Change input/output character set
  • fbsql_set_lob_mode — Set the LOB retrieve mode for a FrontBase result set
  • fbsql_set_password — Change the password for a given user
  • fbsql_set_transaction — Set the transaction locking and isolation
  • fbsql_start_db — Start a database on local or remote server
  • fbsql_stop_db — Stop a database on local or remote server
  • fbsql_table_name — Get table name of field
  • fbsql_tablename — Takma Adı: fbsql_table_name
  • fbsql_username — Get or set the username for the connection
  • fbsql_warnings — Enable or disable FrontBase warnings
Öntanımlı Sabitler
fbsql_affected_rows
FrontBase


Get number of affected rows in previous FrontBase operation

FrontBase İşlevleri
fbsql_autocommit
FrontBase İşlevleri
PHP Manual

fbsql_affected_rows

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_affected_rows — Get number of affected rows in previous FrontBase operation

Açıklama

int fbsql_affected_rows ([ resource $link_identifier ] )

fbsql_affected_rows() returns the number of rows affected by the last INSERT, UPDATE or DELETE query associated with link_identifier.

Bilginize:

If you are using transactions, you need to call fbsql_affected_rows() after your INSERT, UPDATE, or DELETE query, not after the commit.

If the last query was a DELETE query with no WHERE clause, all of the records will have been deleted from the table but this function will return zero.

Bilginize:

When using UPDATE, FrontBase will not update columns where the new value is the same as the old value. This creates the possibility that fbsql_affected_rows() may not actually equal the number of rows matched, only the number of rows that were literally affected by the query.

Değiştirgeler

bağlantı_tanıtıcısı

fbsql_connect() veya fbsql_pconnect() işlevinden dönen bir FrontBase bağlantı tanıtıcısı.

İsteğe bağlıysa ve belirtilmemişse işlev, FrontBase sunucusuna açılmış bir bağlantı olup olmadığına bakar, bir bağlantı yoksa fbsql_connect() işlevi değiştirgesiz çağrılmışçasına bir bağlantı oluşturmaya çalışır.

Dönen Değerler

If the last query failed, this function will return -1.

Ayrıca Bakınız

  • fbsql_num_rows() - Get number of rows in result

FrontBase İşlevleri
fbsql_autocommit
FrontBase İşlevleri


Enable or disable autocommit

fbsql_affected_rows
fbsql_blob_size
FrontBase İşlevleri
PHP Manual

fbsql_autocommit

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_autocommit — Enable or disable autocommit

Açıklama

bool fbsql_autocommit ( resource $link_identifier [, bool $OnOff ] )

Returns the current autocommit status.

Değiştirgeler

bağlantı_tanıtıcısı

fbsql_connect() veya fbsql_pconnect() işlevinden dönen bir FrontBase bağlantı tanıtıcısı.

İsteğe bağlıysa ve belirtilmemişse işlev, FrontBase sunucusuna açılmış bir bağlantı olup olmadığına bakar, bir bağlantı yoksa fbsql_connect() işlevi değiştirgesiz çağrılmışçasına bir bağlantı oluşturmaya çalışır.

OnOff

If this optional parameter is given the auto commit status will be changed.

With OnOff set to TRUE each statement will be committed automatically, if no errors was found.

With OnOff set to FALSE the user must commit or rollback the transaction using either fbsql_commit() or fbsql_rollback().

Dönen Değerler

Returns the current autocommit status, as a boolean.

Ayrıca Bakınız

  • fbsql_commit() - Commits a transaction to the database
  • fbsql_rollback() - Rollback a transaction to the database

fbsql_affected_rows
fbsql_blob_size
FrontBase İşlevleri


Get the size of a BLOB

fbsql_autocommit
fbsql_change_user
FrontBase İşlevleri
PHP Manual

fbsql_blob_size

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

fbsql_blob_size — Get the size of a BLOB

Açıklama

int fbsql_blob_size ( string $blob_handle [, resource $link_identifier ] )

Returns the size of the given BLOB.

Değiştirgeler

blob_handle

A BLOB handle, returned by fbsql_create_blob().

bağlantı_tanıtıcısı

fbsql_connect() veya fbsql_pconnect() işlevinden dönen bir FrontBase bağlantı tanıtıcısı.

İsteğe bağlıysa ve belirtilmemişse işlev, FrontBase sunucusuna açılmış bir bağlantı olup olmadığına bakar, bir bağlantı yoksa fbsql_connect() işlevi değiştirgesiz çağrılmışçasına bir bağlantı oluşturmaya çalışır.

Dönen Değerler

Returns the BLOB size as an integer, or FALSE on error.

Ayrıca Bakınız

  • fbsql_clob_size() - Get the size of a CLOB

fbsql_autocommit
fbsql_change_user
FrontBase İşlevleri


Change logged in user of the active connection

fbsql_blob_size
fbsql_clob_size
FrontBase İşlevleri
PHP Manual

fbsql_change_user

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_change_user — Change logged in user of the active connection

Açıklama

bool fbsql_change_user ( string $user , string $password [, string $database [, resource $link_identifier ]] )

fbsql_change_user() changes the logged in user of the specified connection. If the new user and password authorization fails, the current connected user stays active.

Değiştirgeler

user

The new user name.

password

The new user password.

database

If specified, this will be the default or current database after the user has been changed.

bağlantı_tanıtıcısı

fbsql_connect() veya fbsql_pconnect() işlevinden dönen bir FrontBase bağlantı tanıtıcısı.

İsteğe bağlıysa ve belirtilmemişse işlev, FrontBase sunucusuna açılmış bir bağlantı olup olmadığına bakar, bir bağlantı yoksa fbsql_connect() işlevi değiştirgesiz çağrılmışçasına bir bağlantı oluşturmaya çalışır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

fbsql_blob_size
fbsql_clob_size
FrontBase İşlevleri


Get the size of a CLOB

fbsql_change_user
fbsql_close
FrontBase İşlevleri
PHP Manual

fbsql_clob_size

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

fbsql_clob_size — Get the size of a CLOB

Açıklama

int fbsql_clob_size ( string $clob_handle [, resource $link_identifier ] )

Returns the size of the given CLOB.

Değiştirgeler

clob_handle

A CLOB handle, returned by fbsql_create_clob().

bağlantı_tanıtıcısı

fbsql_connect() veya fbsql_pconnect() işlevinden dönen bir FrontBase bağlantı tanıtıcısı.

İsteğe bağlıysa ve belirtilmemişse işlev, FrontBase sunucusuna açılmış bir bağlantı olup olmadığına bakar, bir bağlantı yoksa fbsql_connect() işlevi değiştirgesiz çağrılmışçasına bir bağlantı oluşturmaya çalışır.

Dönen Değerler

Returns the CLOB size as an integer, or FALSE on error.

Ayrıca Bakınız

  • fbsql_blob_size() - Get the size of a BLOB

fbsql_change_user
fbsql_close
FrontBase İşlevleri


Close FrontBase connection

fbsql_clob_size
fbsql_commit
FrontBase İşlevleri
PHP Manual

fbsql_close

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_close — Close FrontBase connection

Açıklama

bool fbsql_close ([ resource $link_identifier ] )

Closes the connection to the FrontBase server that's associated with the specified link identifier.

Using fbsql_close() isn't usually necessary, as non-persistent open links are automatically closed at the end of the script's execution.

Değiştirgeler

bağlantı_tanıtıcısı

fbsql_connect() veya fbsql_pconnect() işlevinden dönen bir FrontBase bağlantı tanıtıcısı.

İsteğe bağlıysa ve belirtilmemişse işlev, FrontBase sunucusuna açılmış bir bağlantı olup olmadığına bakar, bir bağlantı yoksa fbsql_connect() işlevi değiştirgesiz çağrılmışçasına bir bağlantı oluşturmaya çalışır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 fbsql_close() example

<?php
$link = fbsql_connect("localhost", "_SYSTEM", "secret")
    or die("Could not connect");
echo "Connected successfully";
fbsql_close($link);
?>

Ayrıca Bakınız

  • fbsql_connect() - Open a connection to a FrontBase Server
  • fbsql_pconnect() - Open a persistent connection to a FrontBase Server

fbsql_clob_size
fbsql_commit
FrontBase İşlevleri


Commits a transaction to the database

fbsql_close
fbsql_connect
FrontBase İşlevleri
PHP Manual

fbsql_commit

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_commit — Commits a transaction to the database

Açıklama

bool fbsql_commit ([ resource $link_identifier ] )

Ends the current transaction by writing all inserts, updates and deletes to the disk and unlocking all row and table locks held by the transaction. This command is only needed if autocommit is set to false.

Değiştirgeler

bağlantı_tanıtıcısı

fbsql_connect() veya fbsql_pconnect() işlevinden dönen bir FrontBase bağlantı tanıtıcısı.

İsteğe bağlıysa ve belirtilmemişse işlev, FrontBase sunucusuna açılmış bir bağlantı olup olmadığına bakar, bir bağlantı yoksa fbsql_connect() işlevi değiştirgesiz çağrılmışçasına bir bağlantı oluşturmaya çalışır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • fbsql_autocommit() - Enable or disable autocommit
  • fbsql_rollback() - Rollback a transaction to the database

fbsql_close
fbsql_connect
FrontBase İşlevleri


Open a connection to a FrontBase Server

fbsql_commit
fbsql_create_blob
FrontBase İşlevleri
PHP Manual

fbsql_connect

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_connect — Open a connection to a FrontBase Server

Açıklama

 resource fbsql_connect
  ([ string $hostname = ini_get("fbsql.default_host")
 [, string $username = ini_get("fbsql.default_user")
 [, string $password = ini_get("fbsql.default_password")
]]] )

fbsql_connect() establishes a connection to a FrontBase server.

If a second call is made to fbsql_connect() with the same arguments, no new link will be established, but instead, the link identifier of the already opened link will be returned.

The link to the server will be closed as soon as the execution of the script ends, unless it's closed earlier by explicitly calling fbsql_close().

Değiştirgeler

hostname

The server host name.

username

The user name for the connection.

password

The password for the connection.

Dönen Değerler

Returns a positive FrontBase link identifier on success, or FALSE on errors.

Örnekler

Örnek 1 fbsql_connect() example

<?php

$link = fbsql_connect("localhost", "_SYSTEM", "secret")
    or die("Could not connect");
echo "Connected successfully";
fbsql_close($link);

?>

Ayrıca Bakınız

  • fbsql_pconnect() - Open a persistent connection to a FrontBase Server
  • fbsql_close() - Close FrontBase connection

fbsql_commit
fbsql_create_blob
FrontBase İşlevleri


Create a BLOB

fbsql_connect
fbsql_create_clob
FrontBase İşlevleri
PHP Manual

fbsql_create_blob

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

fbsql_create_blob — Create a BLOB

Açıklama

string fbsql_create_blob ( string $blob_data [, resource $link_identifier ] )

Creates a BLOB from the given data.

Değiştirgeler

blob_data

The BLOB data.

bağlantı_tanıtıcısı

fbsql_connect() veya fbsql_pconnect() işlevinden dönen bir FrontBase bağlantı tanıtıcısı.

İsteğe bağlıysa ve belirtilmemişse işlev, FrontBase sunucusuna açılmış bir bağlantı olup olmadığına bakar, bir bağlantı yoksa fbsql_connect() işlevi değiştirgesiz çağrılmışçasına bir bağlantı oluşturmaya çalışır.

Dönen Değerler

Returns a resource handle to the newly created BLOB, which can be used with insert and update commands to store the BLOB in the database.

Örnekler

Örnek 1 fbsql_create_blob() example

<?php
$link = fbsql_pconnect("localhost", "_SYSTEM", "secret")
    or die("Could not connect");
$filename = "blobfile.bin";
$fp = fopen($filename, "rb");
$blobdata = fread($fp, filesize($filename));
fclose($fp);

$blobHandle = fbsql_create_blob($blobdata, $link);

$sql = "INSERT INTO BLOB_TABLE (BLOB_COLUMN) VALUES ($blobHandle);";
$rs = fbsql_query($sql, $link);
?>

Ayrıca Bakınız

  • fbsql_create_clob() - Create a CLOB
  • fbsql_read_blob() - Read a BLOB from the database
  • fbsql_read_clob() - Read a CLOB from the database
  • fbsql_set_lob_mode() - Set the LOB retrieve mode for a FrontBase result set

fbsql_connect
fbsql_create_clob
FrontBase İşlevleri


Create a CLOB

fbsql_create_blob
fbsql_create_db
FrontBase İşlevleri
PHP Manual

fbsql_create_clob

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

fbsql_create_clob — Create a CLOB

Açıklama

string fbsql_create_clob ( string $clob_data [, resource $link_identifier ] )

Creates a CLOB from the given data.

Değiştirgeler

clob_data

The CLOB data.

bağlantı_tanıtıcısı

fbsql_connect() veya fbsql_pconnect() işlevinden dönen bir FrontBase bağlantı tanıtıcısı.

İsteğe bağlıysa ve belirtilmemişse işlev, FrontBase sunucusuna açılmış bir bağlantı olup olmadığına bakar, bir bağlantı yoksa fbsql_connect() işlevi değiştirgesiz çağrılmışçasına bir bağlantı oluşturmaya çalışır.

Dönen Değerler

Returns a resource handle to the newly created CLOB, which can be used with insert and update commands to store the CLOB in the database.

Örnekler

Örnek 1 fbsql_create_clob() example

<?php
$link = fbsql_pconnect("localhost", "_SYSTEM", "secret")
    or die("Could not connect");
$filename = "clob_file.txt";
$fp = fopen($filename, "rb");
$clobdata = fread($fp, filesize($filename));
fclose($fp);

$clobHandle = fbsql_create_clob($clobdata, $link);

$sql = "INSERT INTO CLOB_TABLE (CLOB_COLUMN) VALUES ($clobHandle);";
$rs = fbsql_query($sql, $link);
?>

Ayrıca Bakınız

  • fbsql_create_blob() - Create a BLOB
  • fbsql_read_blob() - Read a BLOB from the database
  • fbsql_read_clob() - Read a CLOB from the database
  • fbsql_set_lob_mode() - Set the LOB retrieve mode for a FrontBase result set

fbsql_create_blob
fbsql_create_db
FrontBase İşlevleri


Create a FrontBase database

fbsql_create_clob
fbsql_data_seek
FrontBase İşlevleri
PHP Manual

fbsql_create_db

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_create_db — Create a FrontBase database

Açıklama

bool fbsql_create_db ( string $database_name [, resource $link_identifier [, string $database_options ]] )

Attempts to create a new database on the specified server.

Değiştirgeler

database_name

The database name, as a string.

bağlantı_tanıtıcısı

fbsql_connect() veya fbsql_pconnect() işlevinden dönen bir FrontBase bağlantı tanıtıcısı.

İsteğe bağlıysa ve belirtilmemişse işlev, FrontBase sunucusuna açılmış bir bağlantı olup olmadığına bakar, bir bağlantı yoksa fbsql_connect() işlevi değiştirgesiz çağrılmışçasına bir bağlantı oluşturmaya çalışır.

database_options

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 fbsql_create_db() example

<?php
$link = fbsql_pconnect("localhost", "_SYSTEM", "secret")
    or die("Could not connect");
if (fbsql_create_db("my_db")) {
    echo "Database created successfully\n";
} else {
    printf("Error creating database: %s\n", fbsql_error());
}
?>

Ayrıca Bakınız

  • fbsql_drop_db() - Drop (delete) a FrontBase database

fbsql_create_clob
fbsql_data_seek
FrontBase İşlevleri


Move internal result pointer

fbsql_create_db
fbsql_database_password
FrontBase İşlevleri
PHP Manual

fbsql_data_seek

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_data_seek — Move internal result pointer

Açıklama

bool fbsql_data_seek ( resource $result , int $row_number )

Moves the internal row pointer of the FrontBase result associated with the specified result identifier to point to the specified row number.

The next call to fbsql_fetch_row() would return that row.

Değiştirgeler

sonuç

fbsql_query() veya fbsql_db_query() işlevinden dönen bir sonuç tanıtıcısı.

row_number

The row number. Starts at 0.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 fbsql_data_seek() example

<?php
$link = fbsql_pconnect("localhost", "_SYSTEM", "secret")
    or die("Could not connect");

fbsql_select_db("samp_db")
    or die("Could not select database");

$query = "SELECT last_name, first_name FROM friends;";
$result = fbsql_query($query)
    or die("Query failed");

// fetch rows in reverse order

for ($i = fbsql_num_rows($result) - 1; $i >=0; $i--) {
    if (!fbsql_data_seek($result, $i)) {
        printf("Cannot seek to row %d\n", $i);
        continue;
    }

    if (!($row = fbsql_fetch_object($result)))
        continue;

    echo $row->last_name . $row->first_name . "<br />\n";
}

fbsql_free_result($result);
?>

fbsql_create_db
fbsql_database_password
FrontBase İşlevleri


Sets or retrieves the password for a FrontBase database

fbsql_data_seek
fbsql_database
FrontBase İşlevleri
PHP Manual

fbsql_database_password

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_database_password — Sets or retrieves the password for a FrontBase database

Açıklama

string fbsql_database_password ( resource $link_identifier [, string $database_password ] )

Sets and retrieves the database password used by the connection. If a database is protected by a database password, the user must call this function before calling fbsql_select_db().

If no link is open, the function will try to establish a link as if fbsql_connect() was called, and use it.

This function does not change the database password in the database nor can it be used to retrieve the database password for a database.

Değiştirgeler

bağlantı_tanıtıcısı

fbsql_connect() veya fbsql_pconnect() işlevinden dönen bir FrontBase bağlantı tanıtıcısı.

İsteğe bağlıysa ve belirtilmemişse işlev, FrontBase sunucusuna açılmış bir bağlantı olup olmadığına bakar, bir bağlantı yoksa fbsql_connect() işlevi değiştirgesiz çağrılmışçasına bir bağlantı oluşturmaya çalışır.

database_password

The database password, as a string. If given, the function sets the database password for the specified link identifier.

Dönen Değerler

Returns the database password associated with the link identifier.

Örnekler

Örnek 1 fbsql_create_clob() example

<?php
$link = fbsql_pconnect("localhost", "_SYSTEM", "secret")
    or die("Could not connect");
fbsql_database_password($link, "secret db password");
fbsql_select_db($database, $link);
?>

Ayrıca Bakınız

  • fbsql_connect() - Open a connection to a FrontBase Server
  • fbsql_pconnect() - Open a persistent connection to a FrontBase Server
  • fbsql_select_db() - Select a FrontBase database

fbsql_data_seek
fbsql_database
FrontBase İşlevleri


Get or set the database name used with a connection

fbsql_database_password
fbsql_db_query
FrontBase İşlevleri
PHP Manual

fbsql_database

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_database — Get or set the database name used with a connection

Açıklama

string fbsql_database ( resource $link_identifier [, string $database ] )

Get or set the database name used with the connection.

Değiştirgeler

bağlantı_tanıtıcısı

fbsql_connect() veya fbsql_pconnect() işlevinden dönen bir FrontBase bağlantı tanıtıcısı.

İsteğe bağlıysa ve belirtilmemişse işlev, FrontBase sunucusuna açılmış bir bağlantı olup olmadığına bakar, bir bağlantı yoksa fbsql_connect() işlevi değiştirgesiz çağrılmışçasına bir bağlantı oluşturmaya çalışır.

database

The database name. If given, the default database of the connexion will be changed to database.

Dönen Değerler

Returns the name of the database used with this connection.

fbsql_database_password
fbsql_db_query
FrontBase İşlevleri


Send a FrontBase query

fbsql_database
fbsql_db_status
FrontBase İşlevleri
PHP Manual

fbsql_db_query

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_db_query — Send a FrontBase query

Açıklama

resource fbsql_db_query ( string $database , string $query [, resource $link_identifier ] )

Selects a database and executes a query on it.

Değiştirgeler

database

The database to be selected.

query

The SQL query to be executed.

Bilginize:

The query string shall always end with a semicolon.

bağlantı_tanıtıcısı

fbsql_connect() veya fbsql_pconnect() işlevinden dönen bir FrontBase bağlantı tanıtıcısı.

İsteğe bağlıysa ve belirtilmemişse işlev, FrontBase sunucusuna açılmış bir bağlantı olup olmadığına bakar, bir bağlantı yoksa fbsql_connect() işlevi değiştirgesiz çağrılmışçasına bir bağlantı oluşturmaya çalışır.

Dönen Değerler

Returns a positive FrontBase result identifier to the query result, or FALSE on error.

Ayrıca Bakınız

  • fbsql_query() - Send a FrontBase query
  • fbsql_connect() - Open a connection to a FrontBase Server

fbsql_database
fbsql_db_status
FrontBase İşlevleri


Get the status for a given database

fbsql_db_query
fbsql_drop_db
FrontBase İşlevleri
PHP Manual

fbsql_db_status

(PHP 4 >= 4.0.7, PHP 5, PHP 7)

fbsql_db_status — Get the status for a given database

Açıklama

int fbsql_db_status ( string $database_name [, resource $link_identifier ] )

Gets the current status of the specified database.

Değiştirgeler

database_name

The database name.

bağlantı_tanıtıcısı

fbsql_connect() veya fbsql_pconnect() işlevinden dönen bir FrontBase bağlantı tanıtıcısı.

İsteğe bağlıysa ve belirtilmemişse işlev, FrontBase sunucusuna açılmış bir bağlantı olup olmadığına bakar, bir bağlantı yoksa fbsql_connect() işlevi değiştirgesiz çağrılmışçasına bir bağlantı oluşturmaya çalışır.

Dönen Değerler

Returns an integer value with the current status. This can be one of the following constants:

  • FALSE - The exec handler for the host was invalid. This error will occur when the link_identifier connects directly to a database by using a port number. FBExec can be available on the server but no connection has been made for it.
  • FBSQL_UNKNOWN - The Status is unknown.
  • FBSQL_STOPPED - The database is not running. Use fbsql_start_db() to start the database.
  • FBSQL_STARTING - The database is starting.
  • FBSQL_RUNNING - The database is running and can be used to perform SQL operations.
  • FBSQL_STOPPING - The database is stopping.
  • FBSQL_NOEXEC - FBExec is not running on the server and it is not possible to get the status of the database.

Ayrıca Bakınız

  • fbsql_start_db() - Start a database on local or remote server
  • fbsql_stop_db() - Stop a database on local or remote server

fbsql_db_query
fbsql_drop_db
FrontBase İşlevleri


Drop (delete) a FrontBase database

fbsql_db_status
fbsql_errno
FrontBase İşlevleri
PHP Manual

fbsql_drop_db

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_drop_db — Drop (delete) a FrontBase database

Açıklama

bool fbsql_drop_db ( string $database_name [, resource $link_identifier ] )

fbsql_drop_db() attempts to drop (remove) an entire database from the server associated with the specified link identifier.

Değiştirgeler

database_name

The database name, as a string.

bağlantı_tanıtıcısı

fbsql_connect() veya fbsql_pconnect() işlevinden dönen bir FrontBase bağlantı tanıtıcısı.

İsteğe bağlıysa ve belirtilmemişse işlev, FrontBase sunucusuna açılmış bir bağlantı olup olmadığına bakar, bir bağlantı yoksa fbsql_connect() işlevi değiştirgesiz çağrılmışçasına bir bağlantı oluşturmaya çalışır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • fbsql_create_db() - Create a FrontBase database

fbsql_db_status
fbsql_errno
FrontBase İşlevleri


Returns the error number from previous operation

fbsql_drop_db
fbsql_error
FrontBase İşlevleri
PHP Manual

fbsql_errno

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_errno — Returns the error number from previous operation

Açıklama

int fbsql_errno ([ resource $link_identifier ] )

Returns the numerical value of the error message from previous FrontBase operation.

Errors coming back from the fbsql database backend don't issue warnings. Instead, use fbsql_errno() to retrieve the error code. Note that this function only returns the error code from the most recently executed fbsql function (not including fbsql_error() and fbsql_errno()), so if you want to use it, make sure you check the value before calling another fbsql function.

Değiştirgeler

bağlantı_tanıtıcısı

fbsql_connect() veya fbsql_pconnect() işlevinden dönen bir FrontBase bağlantı tanıtıcısı.

İsteğe bağlıysa ve belirtilmemişse işlev, FrontBase sunucusuna açılmış bir bağlantı olup olmadığına bakar, bir bağlantı yoksa fbsql_connect() işlevi değiştirgesiz çağrılmışçasına bir bağlantı oluşturmaya çalışır.

Dönen Değerler

Returns the error number from the last fbsql function, or 0 (zero) if no error occurred.

Örnekler

Örnek 1 fbsql_errno() Example

<?php
fbsql_connect("marliesle");
echo fbsql_errno() . ": " . fbsql_error() . "<br />";
fbsql_select_db("nonexistentdb");
echo fbsql_errno() . ": " . fbsql_error() . "<br />";
$conn = fbsql_query("SELECT * FROM nonexistenttable;");
echo fbsql_errno() . ": " . fbsql_error() . "<br />";
?>

Ayrıca Bakınız

  • fbsql_error() - Returns the error message from previous operation
  • fbsql_warnings() - Enable or disable FrontBase warnings

fbsql_drop_db
fbsql_error
FrontBase İşlevleri


Returns the error message from previous operation

fbsql_errno
fbsql_fetch_array
FrontBase İşlevleri
PHP Manual

fbsql_error

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_error — Returns the error message from previous operation

Açıklama

string fbsql_error ([ resource $link_identifier ] )

Returns the error message from previous FrontBase operation.

Errors coming back from the fbsql database backend don't issue warnings. Instead, use fbsql_error() to retrieve the error text. Note that this function only returns the error code from the most recently executed fbsql function (not including fbsql_error() and fbsql_errno()), so if you want to use it, make sure you check the value before calling another fbsql function.

Değiştirgeler

bağlantı_tanıtıcısı

fbsql_connect() veya fbsql_pconnect() işlevinden dönen bir FrontBase bağlantı tanıtıcısı.

İsteğe bağlıysa ve belirtilmemişse işlev, FrontBase sunucusuna açılmış bir bağlantı olup olmadığına bakar, bir bağlantı yoksa fbsql_connect() işlevi değiştirgesiz çağrılmışçasına bir bağlantı oluşturmaya çalışır.

Dönen Değerler

Returns the error text from the last fbsql function, or '' (the empty string) if no error occurred.

Örnekler

Örnek 1 fbsql_error() Example

<?php
fbsql_connect("marliesle");
echo fbsql_errno() . ": " . fbsql_error() . "<br />";
fbsql_select_db("nonexistentdb");
echo fbsql_errno() . ": " . fbsql_error() . "<br />";
$conn = fbsql_query("SELECT * FROM nonexistenttable;");
echo fbsql_errno() . ": " . fbsql_error() . "<br />";
?>

Ayrıca Bakınız

  • fbsql_errno() - Returns the error number from previous operation
  • fbsql_warnings() - Enable or disable FrontBase warnings

fbsql_errno
fbsql_fetch_array
FrontBase İşlevleri


Fetch a result row as an associative array, a numeric array, or both

fbsql_error
fbsql_fetch_assoc
FrontBase İşlevleri
PHP Manual

fbsql_fetch_array

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_fetch_array — Fetch a result row as an associative array, a numeric array, or both

Açıklama

array fbsql_fetch_array ( resource $result [, int $result_type ] )

fbsql_fetch_array() is a combination of
fbsql_fetch_row() and
fbsql_fetch_assoc().

An important thing to note is that using fbsql_fetch_array() is NOT significantly slower than using fbsql_fetch_row(), while it provides a significant added value.

Değiştirgeler

sonuç

fbsql_query() veya fbsql_db_query() işlevinden dönen bir sonuç tanıtıcısı.

result_type

A constant and can take the following values: FBSQL_ASSOC, FBSQL_NUM, or FBSQL_BOTH.

When using FBSQL_BOTH, in addition to storing the data in the numeric indices of the result array, it also stores the data in associative indices, using the field names as keys.

Dönen Değerler

Returns an array that corresponds to the fetched row, or FALSE if there are no more rows.

If two or more columns of the result have the same field names, the last column will take precedence. To access the other column(s) of the same name, you must the numeric index of the column or make an alias for the column.

select t1.f1 as foo t2.f1 as bar from t1, t2

Örnekler

Örnek 1 fbsql_fetch_array() example

<?php
fbsql_connect($host, $user, $password);
$result = fbsql_db_query("database", "select user_id, fullname from table");
while ($row = fbsql_fetch_array($result)) {
    echo "user_id: " . $row["user_id"] . "<br />\n";
    echo "user_id: " . $row[0] . "<br />\n";
    echo "fullname: " . $row["fullname"] . "<br />\n";
    echo "fullname: " . $row[1] . "<br />\n";
}
fbsql_free_result($result);
?>

Ayrıca Bakınız

  • fbsql_fetch_row() - Get a result row as an enumerated array
  • fbsql_fetch_assoc() - Fetch a result row as an associative array
  • fbsql_fetch_object() - Fetch a result row as an object

fbsql_error
fbsql_fetch_assoc
FrontBase İşlevleri


Fetch a result row as an associative array

fbsql_fetch_array
fbsql_fetch_field
FrontBase İşlevleri
PHP Manual

fbsql_fetch_assoc

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_fetch_assoc — Fetch a result row as an associative array

Açıklama

array fbsql_fetch_assoc ( resource $result )

Calling fbsql_fetch_assoc() is equivalent to calling fbsql_fetch_array() with FBSQL_ASSOC as second parameter. It only returns an associative array.

This is the way fbsql_fetch_array() originally worked. If you need the numeric indices as well as the associative, use fbsql_fetch_array().

An important thing to note is that using fbsql_fetch_assoc() is NOT significantly slower than using fbsql_fetch_row(), while it provides a significant added value.

Değiştirgeler

sonuç

fbsql_query() veya fbsql_db_query() işlevinden dönen bir sonuç tanıtıcısı.

Dönen Değerler

Returns an associative array that corresponds to the fetched row, or FALSE if there are no more rows.

If two or more columns of the result have the same field names, the last column will take precedence. To access the other column(s) of the same name, you must use fbsql_fetch_array() and have it return the numeric indices as well.

Örnekler

Örnek 1 fbsql_fetch_assoc() example

<?php
fbsql_connect($host, $user, $password);
$result = fbsql_db_query("database", "select * from table");
while ($row = fbsql_fetch_assoc($result)) {
    echo $row["user_id"];
    echo $row["fullname"];
}
fbsql_free_result($result);
?>

Ayrıca Bakınız

  • fbsql_fetch_row() - Get a result row as an enumerated array
  • fbsql_fetch_array() - Fetch a result row as an associative array, a numeric array, or both
  • fbsql_fetch_object() - Fetch a result row as an object

fbsql_fetch_array
fbsql_fetch_field
FrontBase İşlevleri


Get column information from a result and return as an object

fbsql_fetch_assoc
fbsql_fetch_lengths
FrontBase İşlevleri
PHP Manual

fbsql_fetch_field

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_fetch_field — Get column information from a result and return as an object

Açıklama

object fbsql_fetch_field ( resource $result [, int $field_offset ] )

Used in order to obtain information about fields in a certain query result.

Değiştirgeler

sonuç

fbsql_query() veya fbsql_db_query() işlevinden dönen bir sonuç tanıtıcısı.

field_offset

The numerical offset of the field. The field index starts at 0. If not specified, the next field that wasn't yet retrieved by fbsql_fetch_field() is retrieved.

Dönen Değerler

Returns an object containing field information, or FALSE on errors.

The properties of the object are:

  • name - column name
  • table - name of the table the column belongs to
  • max_length - maximum length of the column
  • not_null - 1 if the column cannot be NULL
  • type - the type of the column

Örnekler

Örnek 1 fbsql_fetch_field() example

<?php
fbsql_connect($host, $user, $password)
    or die("Could not connect");
$result = fbsql_db_query("database", "select * from table")
    or die("Query failed");
# get column metadata
$i = 0;
while ($i < fbsql_num_fields($result)) {
    echo "Information for column $i:<br />\n";
    $meta = fbsql_fetch_field($result);
    if (!$meta) {
        echo "No information available<br />\n";
    }
    echo "<pre>
max_length:   $meta->max_length
name:         $meta->name
not_null:     $meta->not_null
table:        $meta->table
type:         $meta->type
</pre>";
    $i++;
}
fbsql_free_result($result);
?>

Ayrıca Bakınız

  • fbsql_field_seek() - Set result pointer to a specified field offset

fbsql_fetch_assoc
fbsql_fetch_lengths
FrontBase İşlevleri


Get the length of each output in a result

fbsql_fetch_field
fbsql_fetch_object
FrontBase İşlevleri
PHP Manual

fbsql_fetch_lengths

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_fetch_lengths — Get the length of each output in a result

Açıklama

array fbsql_fetch_lengths ( resource $result )

Stores the lengths of each result column in the last row returned by
fbsql_fetch_row(),
fbsql_fetch_array() and
fbsql_fetch_object() in an array.

Değiştirgeler

sonuç

fbsql_query() veya fbsql_db_query() işlevinden dönen bir sonuç tanıtıcısı.

Dönen Değerler

Returns an array, starting at offset 0, that corresponds to the lengths of each field in the last row fetched by fbsql_fetch_row(), or FALSE on error.

Ayrıca Bakınız

  • fbsql_fetch_row() - Get a result row as an enumerated array

fbsql_fetch_field
fbsql_fetch_object
FrontBase İşlevleri


Fetch a result row as an object

fbsql_fetch_lengths
fbsql_fetch_row
FrontBase İşlevleri
PHP Manual

fbsql_fetch_object

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_fetch_object — Fetch a result row as an object

Açıklama

object fbsql_fetch_object ( resource $result )

fbsql_fetch_object() is similar to fbsql_fetch_array(), with one difference - an object is returned, instead of an array. Indirectly, that means that you can only access the data by the field names, and not by their offsets (numbers are illegal property names).

Speed-wise, the function is identical to fbsql_fetch_array(), and almost as quick as fbsql_fetch_row() (the difference is insignificant).

Değiştirgeler

sonuç

fbsql_query() veya fbsql_db_query() işlevinden dönen bir sonuç tanıtıcısı.

Dönen Değerler

Returns an object with properties that correspond to the fetched row, or FALSE if there are no more rows.

Örnekler

Örnek 1 fbsql_fetch_object() example

<?php
fbsql_connect($host, $user, $password);
$result = fbsql_db_query("database", "select * from table");
while ($row = fbsql_fetch_object($result)) {
    echo $row->user_id;
    echo $row->fullname;
}
fbsql_free_result($result);
?>

Ayrıca Bakınız

  • fbsql_fetch_array() - Fetch a result row as an associative array, a numeric array, or both
  • fbsql_fetch_row() - Get a result row as an enumerated array
  • fbsql_fetch_assoc() - Fetch a result row as an associative array

fbsql_fetch_lengths
fbsql_fetch_row
FrontBase İşlevleri


Get a result row as an enumerated array

fbsql_fetch_object
fbsql_field_flags
FrontBase İşlevleri
PHP Manual

fbsql_fetch_row

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_fetch_row — Get a result row as an enumerated array

Açıklama

array fbsql_fetch_row ( resource $result )

fbsql_fetch_row() fetches one row of data from the result associated with the specified result identifier.

Subsequent call to fbsql_fetch_row() would return the next row in the result set, or FALSE if there are no more rows.

Değiştirgeler

sonuç

fbsql_query() veya fbsql_db_query() işlevinden dönen bir sonuç tanıtıcısı.

Dönen Değerler

Returns an array that corresponds to the fetched row where each result column is stored in an offset, starting at offset 0, or FALSE if there are no more rows.

Ayrıca Bakınız

  • fbsql_fetch_array() - Fetch a result row as an associative array, a numeric array, or both
  • fbsql_fetch_assoc() - Fetch a result row as an associative array
  • fbsql_fetch_object() - Fetch a result row as an object
  • fbsql_data_seek() - Move internal result pointer
  • fbsql_fetch_lengths() - Get the length of each output in a result
  • fbsql_result() - Get result data

fbsql_fetch_object
fbsql_field_flags
FrontBase İşlevleri


Get the flags associated with the specified field in a result

fbsql_fetch_row
fbsql_field_len
FrontBase İşlevleri
PHP Manual

fbsql_field_flags

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_field_flags — Get the flags associated with the specified field in a result

Açıklama

string fbsql_field_flags ( resource $result [, int $field_offset ] )

Gets the flags associated with the specified field in a result.

Değiştirgeler

result

A result pointer returned by fbsql_list_fields().

field_offset

The numerical offset of the field. The field index starts at 0.

Dönen Değerler

Returns the field flags of the specified field as a single word per flag separated by a single space, so that you can split the returned value using explode().

fbsql_fetch_row
fbsql_field_len
FrontBase İşlevleri


Returns the length of the specified field

fbsql_field_flags
fbsql_field_name
FrontBase İşlevleri
PHP Manual

fbsql_field_len

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_field_len — Returns the length of the specified field

Açıklama

int fbsql_field_len ( resource $result [, int $field_offset ] )

Returns the length of the specified field.

Değiştirgeler

result

A result pointer returned by fbsql_list_fields().

field_offset

The numerical offset of the field. The field index starts at 0.

Dönen Değerler

Returns the length of the specified field.

fbsql_field_flags
fbsql_field_name
FrontBase İşlevleri


Get the name of the specified field in a result

fbsql_field_len
fbsql_field_seek
FrontBase İşlevleri
PHP Manual

fbsql_field_name

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_field_name — Get the name of the specified field in a result

Açıklama

string fbsql_field_name ( resource $result [, int $field_index ] )

Returns the name of the specified field index.

Değiştirgeler

result

A result pointer returned by fbsql_list_fields().

field_index

The numerical offset of the field. The field index starts at 0.

Dönen Değerler

Returns the name as a string, or FALSE if the field doesn't exist.

Örnekler

Örnek 1 fbsql_field_name() example

<?php
// The users table consists of three fields:
//   user_id
//   username
//   password.

$res = fbsql_db_query("users", "select * from users", $link);

echo fbsql_field_name($res, 0) . "\n";
echo fbsql_field_name($res, 2);
?>

Yukarıdaki örneğin çıktısı:

user_id
password

Ayrıca Bakınız

  • fbsql_field_type() - Get the type of the specified field in a result

fbsql_field_len
fbsql_field_seek
FrontBase İşlevleri


Set result pointer to a specified field offset

fbsql_field_name
fbsql_field_table
FrontBase İşlevleri
PHP Manual

fbsql_field_seek

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_field_seek — Set result pointer to a specified field offset

Açıklama

bool fbsql_field_seek ( resource $result [, int $field_offset ] )

Seeks to the specified field offset. If the next call to fbsql_fetch_field() doesn't include a field offset, the field offset specified in fbsql_field_seek() will be returned.

Değiştirgeler

sonuç

fbsql_query() veya fbsql_db_query() işlevinden dönen bir sonuç tanıtıcısı.

field_offset

The numerical offset of the field. The field index starts at 0.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • fbsql_fetch_field() - Get column information from a result and return as an object

fbsql_field_name
fbsql_field_table
FrontBase İşlevleri


Get name of the table the specified field is in

fbsql_field_seek
fbsql_field_type
FrontBase İşlevleri
PHP Manual

fbsql_field_table

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_field_table — Get name of the table the specified field is in

Açıklama

string fbsql_field_table ( resource $result [, int $field_offset ] )

Returns the name of the table that the specified field is in.

Değiştirgeler

sonuç

fbsql_query() veya fbsql_db_query() işlevinden dönen bir sonuç tanıtıcısı.

field_offset

The numerical offset of the field. The field index starts at 0.

Dönen Değerler

Returns the name of the table, as a string.

fbsql_field_seek
fbsql_field_type
FrontBase İşlevleri


Get the type of the specified field in a result

fbsql_field_table
fbsql_free_result
FrontBase İşlevleri
PHP Manual

fbsql_field_type

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_field_type — Get the type of the specified field in a result

Açıklama

string fbsql_field_type ( resource $result [, int $field_offset ] )

fbsql_field_type() is similar to the fbsql_field_name() function, but the field type is returned instead.

Değiştirgeler

sonuç

fbsql_query() veya fbsql_db_query() işlevinden dönen bir sonuç tanıtıcısı.

field_offset

The numerical offset of the field. The field index starts at 0.

Dönen Değerler

Returns the field type, as a string.

This can be one of int, real, string, blob, and others as detailed in the » FrontBase documentation.

Örnekler

Örnek 1 fbsql_field_type() example

<?php

fbsql_connect("localhost", "_SYSTEM", "");
fbsql_select_db("wisconsin");
$result = fbsql_query("SELECT * FROM onek;");
$fields = fbsql_num_fields($result);
$rows   = fbsql_num_rows($result);
$i = 0;
$table = fbsql_field_table($result, $i);
echo "Your '" . $table . "' table has " . $fields . " fields and " . $rows . " records <br />";
echo "The table has the following fields <br />";
while ($i < $fields) {
    $type  = fbsql_field_type($result, $i);
    $name  = fbsql_field_name($result, $i);
    $len   = fbsql_field_len($result, $i);
    $flags = fbsql_field_flags($result, $i);
    echo $type . " " . $name . " " . $len . " " . $flags . "<br />";
    $i++;
}
fbsql_close();

?>

Ayrıca Bakınız

  • fbsql_field_name() - Get the name of the specified field in a result

fbsql_field_table
fbsql_free_result
FrontBase İşlevleri


Free result memory

fbsql_field_type
fbsql_get_autostart_info
FrontBase İşlevleri
PHP Manual

fbsql_free_result

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_free_result — Free result memory

Açıklama

bool fbsql_free_result ( resource $result )

Frees all memory associated with the given result identifier.

fbsql_free_result() only needs to be called if you are concerned about how much memory is being used for queries that return large result sets. All associated result memory is automatically freed at the end of the script's execution.

Değiştirgeler

sonuç

fbsql_query() veya fbsql_db_query() işlevinden dönen bir sonuç tanıtıcısı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

fbsql_field_type
fbsql_get_autostart_info
FrontBase İşlevleri


fbsql_free_result
fbsql_hostname
FrontBase İşlevleri
PHP Manual

fbsql_get_autostart_info

(PHP 4 >= 4.0.7, PHP 5, PHP 7)

fbsql_get_autostart_info —

Açıklama

array fbsql_get_autostart_info ([ resource $link_identifier ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

bağlantı_tanıtıcısı

fbsql_connect() veya fbsql_pconnect() işlevinden dönen bir FrontBase bağlantı tanıtıcısı.

İsteğe bağlıysa ve belirtilmemişse işlev, FrontBase sunucusuna açılmış bir bağlantı olup olmadığına bakar, bir bağlantı yoksa fbsql_connect() işlevi değiştirgesiz çağrılmışçasına bir bağlantı oluşturmaya çalışır.

fbsql_free_result
fbsql_hostname
FrontBase İşlevleri


Get or set the host name used with a connection

fbsql_get_autostart_info
fbsql_insert_id
FrontBase İşlevleri
PHP Manual

fbsql_hostname

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_hostname — Get or set the host name used with a connection

Açıklama

string fbsql_hostname ( resource $link_identifier [, string $host_name ] )

Gets or sets the host name used with a connection.

Değiştirgeler

bağlantı_tanıtıcısı

fbsql_connect() veya fbsql_pconnect() işlevinden dönen bir FrontBase bağlantı tanıtıcısı.

İsteğe bağlıysa ve belirtilmemişse işlev, FrontBase sunucusuna açılmış bir bağlantı olup olmadığına bakar, bir bağlantı yoksa fbsql_connect() işlevi değiştirgesiz çağrılmışçasına bir bağlantı oluşturmaya çalışır.

host_name

If provided, this will be the new connection host name.

Dönen Değerler

Returns the current host name used for the connection.

Ayrıca Bakınız

  • fbsql_username() - Get or set the username for the connection
  • fbsql_password() - Get or set the user password used with a connection

fbsql_get_autostart_info
fbsql_insert_id
FrontBase İşlevleri


Get the id generated from the previous INSERT operation

fbsql_hostname
fbsql_list_dbs
FrontBase İşlevleri
PHP Manual

fbsql_insert_id

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_insert_id — Get the id generated from the previous INSERT operation

Açıklama

int fbsql_insert_id ([ resource $link_identifier ] )

Gets the id generated from the previous INSERT operation which created a DEFAULT UNIQUE value.

Bilginize:

The value of the FrontBase SQL function fbsql_insert_id() always contains the most recently generated DEFAULT UNIQUE value, and is not reset between queries.

Değiştirgeler

bağlantı_tanıtıcısı

fbsql_connect() veya fbsql_pconnect() işlevinden dönen bir FrontBase bağlantı tanıtıcısı.

İsteğe bağlıysa ve belirtilmemişse işlev, FrontBase sunucusuna açılmış bir bağlantı olup olmadığına bakar, bir bağlantı yoksa fbsql_connect() işlevi değiştirgesiz çağrılmışçasına bir bağlantı oluşturmaya çalışır.

Dönen Değerler

Returns the ID generated from the previous INSERT query, or 0 if the previous query does not generate an DEFAULT UNIQUE value.

If you need to save the value for later, be sure to call this function immediately after the query that generates the value.

Ayrıca Bakınız

  • fbsql_affected_rows() - Get number of affected rows in previous FrontBase operation

fbsql_hostname
fbsql_list_dbs
FrontBase İşlevleri


List databases available on a FrontBase server

fbsql_insert_id
fbsql_list_fields
FrontBase İşlevleri
PHP Manual

fbsql_list_dbs

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_list_dbs — List databases available on a FrontBase server

Açıklama

resource fbsql_list_dbs ([ resource $link_identifier ] )

Return a result pointer containing the databases available from the current fbsql daemon. Use the fbsql_tablename() to traverse this result pointer.

Değiştirgeler

bağlantı_tanıtıcısı

fbsql_connect() veya fbsql_pconnect() işlevinden dönen bir FrontBase bağlantı tanıtıcısı.

İsteğe bağlıysa ve belirtilmemişse işlev, FrontBase sunucusuna açılmış bir bağlantı olup olmadığına bakar, bir bağlantı yoksa fbsql_connect() işlevi değiştirgesiz çağrılmışçasına bir bağlantı oluşturmaya çalışır.

Dönen Değerler

Returns a result pointer or FALSE on error.

Örnekler

Örnek 1 fbsql_list_dbs() example

<?php
$link = fbsql_connect('localhost', 'myname', 'secret');
$db_list = fbsql_list_dbs($link);

while ($row = fbsql_fetch_object($db_list)) {
    echo $row->Database . "\n";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

database1
database2
database3
...

Bilginize:

The above code would just as easily work with fbsql_fetch_row() or other similar functions.

Ayrıca Bakınız

  • fbsql_list_fields() - List FrontBase result fields
  • fbsql_list_tables() - List tables in a FrontBase database

fbsql_insert_id
fbsql_list_fields
FrontBase İşlevleri


List FrontBase result fields

fbsql_list_dbs
fbsql_list_tables
FrontBase İşlevleri
PHP Manual

fbsql_list_fields

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_list_fields — List FrontBase result fields

Açıklama

resource fbsql_list_fields ( string $database_name , string $table_name [, resource $link_identifier ] )

Retrieves information about the given table.

Değiştirgeler

database_name

The database name.

table_name

The table name.

bağlantı_tanıtıcısı

fbsql_connect() veya fbsql_pconnect() işlevinden dönen bir FrontBase bağlantı tanıtıcısı.

İsteğe bağlıysa ve belirtilmemişse işlev, FrontBase sunucusuna açılmış bir bağlantı olup olmadığına bakar, bir bağlantı yoksa fbsql_connect() işlevi değiştirgesiz çağrılmışçasına bir bağlantı oluşturmaya çalışır.

Dönen Değerler

Returns a result pointer which can be used with the fbsql_field_xxx functions, or FALSE on error.

Hatalar/İstisnalar

A string describing the error will be placed in $phperrmsg, and unless the function was called as @fbsql() then this error string will also be printed out.

Örnekler

Örnek 1 fbsql_list_fields() example

<?php
$link = fbsql_connect('localhost', 'myname', 'secret');

$fields = fbsql_list_fields("database1", "table1", $link);
$columns = fbsql_num_fields($fields);

for ($i = 0; $i < $columns; $i++) {
    echo fbsql_field_name($fields, $i) . "\n";;
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

field1
field2
field3
...

Ayrıca Bakınız

  • fbsql_field_len() - Returns the length of the specified field
  • fbsql_field_name() - Get the name of the specified field in a result
  • fbsql_field_type() - Get the type of the specified field in a result
  • fbsql_field_flags() - Get the flags associated with the specified field in a result

fbsql_list_dbs
fbsql_list_tables
FrontBase İşlevleri


List tables in a FrontBase database

fbsql_list_fields
fbsql_next_result
FrontBase İşlevleri
PHP Manual

fbsql_list_tables

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_list_tables — List tables in a FrontBase database

Açıklama

resource fbsql_list_tables ( string $database [, resource $link_identifier ] )

Returns a result pointer describing the database.

Değiştirgeler

database

The database name.

bağlantı_tanıtıcısı

fbsql_connect() veya fbsql_pconnect() işlevinden dönen bir FrontBase bağlantı tanıtıcısı.

İsteğe bağlıysa ve belirtilmemişse işlev, FrontBase sunucusuna açılmış bir bağlantı olup olmadığına bakar, bir bağlantı yoksa fbsql_connect() işlevi değiştirgesiz çağrılmışçasına bir bağlantı oluşturmaya çalışır.

Dönen Değerler

Returns a result pointer which can be used with the fbsql_tablename() function to read the actual table names, or FALSE on error.

Ayrıca Bakınız

  • fbsql_list_fields() - List FrontBase result fields
  • fbsql_list_dbs() - List databases available on a FrontBase server

fbsql_list_fields
fbsql_next_result
FrontBase İşlevleri


Move the internal result pointer to the next result

fbsql_list_tables
fbsql_num_fields
FrontBase İşlevleri
PHP Manual

fbsql_next_result

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_next_result — Move the internal result pointer to the next result

Açıklama

bool fbsql_next_result ( resource $result )

When sending more than one SQL statement to the server or executing a stored procedure with multiple results will cause the server to return multiple result sets. This function will test for additional results available form the server. If an additional result set exists it will free the existing result set and prepare to fetch the words from the new result set.

Değiştirgeler

sonuç

fbsql_query() veya fbsql_db_query() işlevinden dönen bir sonuç tanıtıcısı.

Dönen Değerler

Returns TRUE if an additional result set was available or FALSE otherwise.

Örnekler

Örnek 1 fbsql_next_result() example

<?php
$link = fbsql_connect("localhost", "_SYSTEM", "secret");
fbsql_select_db("MyDB", $link);
$SQL = "Select * from table1; select * from table2;";
$rs = fbsql_query($SQL, $link);
do {
    while ($row = fbsql_fetch_row($rs)) {
    }
} while (fbsql_next_result($rs));
fbsql_free_result($rs);
fbsql_close($link);
?>

fbsql_list_tables
fbsql_num_fields
FrontBase İşlevleri


Get number of fields in result

fbsql_next_result
fbsql_num_rows
FrontBase İşlevleri
PHP Manual

fbsql_num_fields

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_num_fields — Get number of fields in result

Açıklama

int fbsql_num_fields ( resource $result )

Returns the number of fields in the given result set.

Değiştirgeler

sonuç

fbsql_query() veya fbsql_db_query() işlevinden dönen bir sonuç tanıtıcısı.

Dönen Değerler

Returns the number of fields, as an integer.

Ayrıca Bakınız

  • fbsql_db_query() - Send a FrontBase query
  • fbsql_query() - Send a FrontBase query
  • fbsql_fetch_field() - Get column information from a result and return as an object
  • fbsql_num_rows() - Get number of rows in result

fbsql_next_result
fbsql_num_rows
FrontBase İşlevleri


Get number of rows in result

fbsql_num_fields
fbsql_password
FrontBase İşlevleri
PHP Manual

fbsql_num_rows

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_num_rows — Get number of rows in result

Açıklama

int fbsql_num_rows ( resource $result )

Gets the number of rows in the given result set.

This function is only valid for SELECT statements. To retrieve the number of rows returned from a INSERT, UPDATE or DELETE query, use fbsql_affected_rows().

Değiştirgeler

sonuç

fbsql_query() veya fbsql_db_query() işlevinden dönen bir sonuç tanıtıcısı.

Dönen Değerler

Returns the number of rows returned by the last SELECT statement.

Örnekler

Örnek 1 fbsql_num_rows() example

<?php

$link = fbsql_connect("localhost", "username", "password");
fbsql_select_db("database", $link);

$result = fbsql_query("SELECT * FROM table1;", $link);
$num_rows = fbsql_num_rows($result);

echo "$num_rows Rows\n";

?>

Ayrıca Bakınız

  • fbsql_affected_rows() - Get number of affected rows in previous FrontBase operation
  • fbsql_connect() - Open a connection to a FrontBase Server
  • fbsql_select_db() - Select a FrontBase database
  • fbsql_query() - Send a FrontBase query

fbsql_num_fields
fbsql_password
FrontBase İşlevleri


Get or set the user password used with a connection

fbsql_num_rows
fbsql_pconnect
FrontBase İşlevleri
PHP Manual

fbsql_password

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_password — Get or set the user password used with a connection

Açıklama

string fbsql_password ( resource $link_identifier [, string $password ] )

Get or set the user password used with a connection.

Değiştirgeler

bağlantı_tanıtıcısı

fbsql_connect() veya fbsql_pconnect() işlevinden dönen bir FrontBase bağlantı tanıtıcısı.

İsteğe bağlıysa ve belirtilmemişse işlev, FrontBase sunucusuna açılmış bir bağlantı olup olmadığına bakar, bir bağlantı yoksa fbsql_connect() işlevi değiştirgesiz çağrılmışçasına bir bağlantı oluşturmaya çalışır.

password

If provided, this will be the new connection password.

Dönen Değerler

Returns the current password used for the connection.

Ayrıca Bakınız

  • fbsql_username() - Get or set the username for the connection
  • fbsql_hostname() - Get or set the host name used with a connection

fbsql_num_rows
fbsql_pconnect
FrontBase İşlevleri


Open a persistent connection to a FrontBase Server

fbsql_password
fbsql_query
FrontBase İşlevleri
PHP Manual

fbsql_pconnect

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_pconnect — Open a persistent connection to a FrontBase Server

Açıklama

 resource fbsql_pconnect
  ([ string $hostname = ini_get("fbsql.default_host")
 [, string $username = ini_get("fbsql.default_user")
 [, string $password = ini_get("fbsql.default_password")
]]] )

Establishes a persistent connection to a FrontBase server.

To set the server port number, use fbsql_select_db().

fbsql_pconnect() acts very much like fbsql_connect() with two major differences:

First, when connecting, the function would first try to find a (persistent) link that's already open with the same host, username and password. If one is found, an identifier for it will be returned instead of opening a new connection.

Second, the connection to the SQL server will not be closed when the execution of the script ends. Instead, the link will remain open for future use.

This type of links is therefore called 'persistent'.

Değiştirgeler

hostname

The server host name.

username

The user name for the connection.

password

The password for the connection.

Dönen Değerler

Returns a positive FrontBase persistent link identifier on success, or FALSE on error.

Ayrıca Bakınız

  • fbsql_connect() - Open a connection to a FrontBase Server

fbsql_password
fbsql_query
FrontBase İşlevleri


Send a FrontBase query

fbsql_pconnect
fbsql_read_blob
FrontBase İşlevleri
PHP Manual

fbsql_query

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_query — Send a FrontBase query

Açıklama

resource fbsql_query ( string $query [, resource $link_identifier [, int $batch_size ]] )

Sends a query to the currently active database on the server.

If the query succeeds, you can call fbsql_num_rows() to find out how many rows were returned for a SELECT statement or fbsql_affected_rows() to find out how many rows were affected by a DELETE, INSERT, REPLACE, or UPDATE statement.

Değiştirgeler

query

The SQL query to be executed.

Bilginize:

The query string shall always end with a semicolon.

bağlantı_tanıtıcısı

fbsql_connect() veya fbsql_pconnect() işlevinden dönen bir FrontBase bağlantı tanıtıcısı.

İsteğe bağlıysa ve belirtilmemişse işlev, FrontBase sunucusuna açılmış bir bağlantı olup olmadığına bakar, bir bağlantı yoksa fbsql_connect() işlevi değiştirgesiz çağrılmışçasına bir bağlantı oluşturmaya çalışır.

batch_size

Dönen Değerler

fbsql_query() returns TRUE (non-zero) or FALSE to indicate whether or not the query succeeded. A return value of TRUE means that the query was legal and could be executed by the server. It does not indicate anything about the number of rows affected or returned. It is perfectly possible for a query to succeed but affect no rows or return no rows.

For SELECT statements, fbsql_query() returns a new result identifier that you can pass to fbsql_result().

fbsql_query() will also fail and return FALSE if you don't have permission to access the table(s) referenced by the query.

Örnekler

The following query is syntactically invalid, so fbsql_query() fails and returns FALSE:

Örnek 1 fbsql_query() example

<?php
$result = fbsql_query("SELECT * WHERE 1=1")
    or die ("Invalid query");
?>

The following query is semantically invalid if my_col is not a column in the table my_tbl, so fbsql_query() fails and returns FALSE:

Örnek 2 fbsql_query() example

<?php
$result = fbsql_query ("SELECT my_col FROM my_tbl;")
    or die ("Invalid query");
?>

Ayrıca Bakınız

  • fbsql_affected_rows() - Get number of affected rows in previous FrontBase operation
  • fbsql_db_query() - Send a FrontBase query
  • fbsql_free_result() - Free result memory
  • fbsql_result() - Get result data
  • fbsql_select_db() - Select a FrontBase database
  • fbsql_connect() - Open a connection to a FrontBase Server

fbsql_pconnect
fbsql_read_blob
FrontBase İşlevleri


Read a BLOB from the database

fbsql_query
fbsql_read_clob
FrontBase İşlevleri
PHP Manual

fbsql_read_blob

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

fbsql_read_blob — Read a BLOB from the database

Açıklama

string fbsql_read_blob ( string $blob_handle [, resource $link_identifier ] )

Reads BLOB data from the database.

If a select statement contains BLOB and/or CLOB columns FrontBase will return the data directly when data is fetched. This default behavior can be changed with fbsql_set_lob_mode() so the fetch functions will return handles to BLOB and CLOB data. If a handle is fetched a user must call fbsql_read_blob() to get the actual BLOB data from the database.

Değiştirgeler

blob_handle

A BLOB handle, returned by fbsql_create_blob().

bağlantı_tanıtıcısı

fbsql_connect() veya fbsql_pconnect() işlevinden dönen bir FrontBase bağlantı tanıtıcısı.

İsteğe bağlıysa ve belirtilmemişse işlev, FrontBase sunucusuna açılmış bir bağlantı olup olmadığına bakar, bir bağlantı yoksa fbsql_connect() işlevi değiştirgesiz çağrılmışçasına bir bağlantı oluşturmaya çalışır.

Dönen Değerler

Returns a string containing the specified BLOB data.

Örnekler

Örnek 1 fbsql_read_blob() example

<?php
$link = fbsql_pconnect("localhost", "_SYSTEM", "secret")
    or die("Could not connect");
$sql = "SELECT BLOB_COLUMN FROM BLOB_TABLE;";
$rs = fbsql_query($sql, $link);
$row_data = fbsql_fetch_row($rs);
// $row_data[0] will now contain the blob data for the first row
fbsql_free_result($rs);

$rs = fbsql_query($sql, $link);
fbsql_set_lob_mode($rs, FBSQL_LOB_HANDLE);
$row_data = fbsql_fetch_row($rs);
// $row_data[0] will now contain a handle to the BLOB data in the first row
$blob_data = fbsql_read_blob($row_data[0]);
fbsql_free_result($rs);

?>

Ayrıca Bakınız

  • fbsql_create_blob() - Create a BLOB
  • fbsql_read_clob() - Read a CLOB from the database
  • fbsql_set_lob_mode() - Set the LOB retrieve mode for a FrontBase result set

fbsql_query
fbsql_read_clob
FrontBase İşlevleri


Read a CLOB from the database

fbsql_read_blob
fbsql_result
FrontBase İşlevleri
PHP Manual

fbsql_read_clob

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

fbsql_read_clob — Read a CLOB from the database

Açıklama

string fbsql_read_clob ( string $clob_handle [, resource $link_identifier ] )

Reads CLOB data from the database.

If a select statement contains BLOB and/or CLOB columns FrontBase will return the data directly when data is fetched. This default behavior can be changed with fbsql_set_lob_mode() so the fetch functions will return handles to BLOB and CLOB data. If a handle is fetched a user must call fbsql_read_clob() to get the actual CLOB data from the database.

Değiştirgeler

clob_handle

A CLOB handle, returned by fbsql_create_clob().

bağlantı_tanıtıcısı

fbsql_connect() veya fbsql_pconnect() işlevinden dönen bir FrontBase bağlantı tanıtıcısı.

İsteğe bağlıysa ve belirtilmemişse işlev, FrontBase sunucusuna açılmış bir bağlantı olup olmadığına bakar, bir bağlantı yoksa fbsql_connect() işlevi değiştirgesiz çağrılmışçasına bir bağlantı oluşturmaya çalışır.

Dönen Değerler

Returns a string containing the specified CLOB data.

Örnekler

Örnek 1 fbsql_read_clob() example

<?php
$link = fbsql_pconnect("localhost", "_SYSTEM", "secret")
    or die("Could not connect");
$sql = "SELECT CLOB_COLUMN FROM CLOB_TABLE;";
$rs = fbsql_query($sql, $link);
$row_data = fbsql_fetch_row($rs);
// $row_data[0] will now contain the clob data for the first row
fbsql_free_result($rs);

$rs = fbsql_query($sql, $link);
fbsql_set_lob_mode($rs, FBSQL_LOB_HANDLE);
$row_data = fbsql_fetch_row($rs);
// $row_data[0] will now contain a handle to the CLOB data in the first row
$clob_data = fbsql_read_clob($row_data[0]);
fbsql_free_result($rs);

?>

Ayrıca Bakınız

  • fbsql_create_clob() - Create a CLOB
  • fbsql_read_blob() - Read a BLOB from the database
  • fbsql_set_lob_mode() - Set the LOB retrieve mode for a FrontBase result set

fbsql_read_blob
fbsql_result
FrontBase İşlevleri


Get result data

fbsql_read_clob
fbsql_rollback
FrontBase İşlevleri
PHP Manual

fbsql_result

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_result — Get result data

Açıklama

mixed fbsql_result ( resource $result [, int $row [, mixed $field ]] )

Returns the contents of one cell from a FrontBase result set.

When working on large result sets, you should consider using one of the functions that fetch an entire row (specified below). As these functions return the contents of multiple cells in one function call, they're MUCH quicker than fbsql_result().

Calls to fbsql_result() should not be mixed with calls to other functions that deal with the result set.

Değiştirgeler

sonuç

fbsql_query() veya fbsql_db_query() işlevinden dönen bir sonuç tanıtıcısı.

row

field

Can be the field's offset, or the field's name, or the field's table dot field's name (tablename.fieldname).

If the column name has been aliased ('select foo as bar from...'), use the alias instead of the column name.

Bilginize:

Specifying a numeric offset for the field argument is much quicker than specifying a fieldname or tablename.fieldname argument.

Dönen Değerler

Ayrıca Bakınız

Recommended high-performance alternatives:

  • fbsql_fetch_row() - Get a result row as an enumerated array
  • fbsql_fetch_array() - Fetch a result row as an associative array, a numeric array, or both
  • fbsql_fetch_assoc() - Fetch a result row as an associative array
  • fbsql_fetch_object() - Fetch a result row as an object

fbsql_read_clob
fbsql_rollback
FrontBase İşlevleri


Rollback a transaction to the database

fbsql_result
fbsql_rows_fetched
FrontBase İşlevleri
PHP Manual

fbsql_rollback

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_rollback — Rollback a transaction to the database

Açıklama

bool fbsql_rollback ([ resource $link_identifier ] )

Ends the current transaction by rolling back all statements issued since last commit.

This command is only needed if autocommit is set to false.

Değiştirgeler

bağlantı_tanıtıcısı

fbsql_connect() veya fbsql_pconnect() işlevinden dönen bir FrontBase bağlantı tanıtıcısı.

İsteğe bağlıysa ve belirtilmemişse işlev, FrontBase sunucusuna açılmış bir bağlantı olup olmadığına bakar, bir bağlantı yoksa fbsql_connect() işlevi değiştirgesiz çağrılmışçasına bir bağlantı oluşturmaya çalışır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • fbsql_autocommit() - Enable or disable autocommit
  • fbsql_commit() - Commits a transaction to the database

fbsql_result
fbsql_rows_fetched
FrontBase İşlevleri


Get the number of rows affected by the last statement

fbsql_rollback
fbsql_select_db
FrontBase İşlevleri
PHP Manual

fbsql_rows_fetched

(PHP 5 >= 5.1.0, PHP 7)

fbsql_rows_fetched — Get the number of rows affected by the last statement

Açıklama

int fbsql_rows_fetched ( resource $result )

Gets the number of rows affected by the last statement.

Değiştirgeler

sonuç

fbsql_query() veya fbsql_db_query() işlevinden dönen bir sonuç tanıtıcısı.

Dönen Değerler

Returns the number of rows, as an integer.

fbsql_rollback
fbsql_select_db
FrontBase İşlevleri


Select a FrontBase database

fbsql_rows_fetched
fbsql_set_characterset
FrontBase İşlevleri
PHP Manual

fbsql_select_db

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_select_db — Select a FrontBase database

Açıklama

bool fbsql_select_db ([ string $database_name [, resource $link_identifier ]] )

Sets the current active database on the given link identifier.

The client contacts FBExec to obtain the port number to use for the connection to the database. If the database name is a number the system will use that as a port number and it will not ask FBExec for the port number. The FrontBase server can be stared as FRontBase -FBExec=No -port=<port number> <database name>.

Every subsequent call to fbsql_query() will be made on the active database.

Değiştirgeler

database_name

The name of the database to be selected.

If the database is protected with a database password, the you must call fbsql_database_password() before selecting the database.

bağlantı_tanıtıcısı

fbsql_connect() veya fbsql_pconnect() işlevinden dönen bir FrontBase bağlantı tanıtıcısı.

İsteğe bağlıysa ve belirtilmemişse işlev, FrontBase sunucusuna açılmış bir bağlantı olup olmadığına bakar, bir bağlantı yoksa fbsql_connect() işlevi değiştirgesiz çağrılmışçasına bir bağlantı oluşturmaya çalışır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • fbsql_connect() - Open a connection to a FrontBase Server
  • fbsql_pconnect() - Open a persistent connection to a FrontBase Server
  • fbsql_database_password() - Sets or retrieves the password for a FrontBase database
  • fbsql_query() - Send a FrontBase query

fbsql_rows_fetched
fbsql_set_characterset
FrontBase İşlevleri


Change input/output character set

fbsql_select_db
fbsql_set_lob_mode
FrontBase İşlevleri
PHP Manual

fbsql_set_characterset

(PHP 5 >= 5.1.0, PHP 7)

fbsql_set_characterset — Change input/output character set

Açıklama

void fbsql_set_characterset ( resource $link_identifier , int $characterset [, int $in_out_both ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Dönen Değerler

Hiçbir değer dönmez.

fbsql_select_db
fbsql_set_lob_mode
FrontBase İşlevleri


Set the LOB retrieve mode for a FrontBase result set

fbsql_set_characterset
fbsql_set_password
FrontBase İşlevleri
PHP Manual

fbsql_set_lob_mode

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

fbsql_set_lob_mode — Set the LOB retrieve mode for a FrontBase result set

Açıklama

bool fbsql_set_lob_mode ( resource $result , int $lob_mode )

Sets the mode for retrieving LOB data from the database.

When BLOB and CLOB data is retrieved in FrontBase it can be retrieved direct or indirect. Direct retrieved LOB data will always be fetched no matter the setting of the lob mode. If the LOB data is less than 512 bytes it will always be retrieved directly.

Değiştirgeler

sonuç

fbsql_query() veya fbsql_db_query() işlevinden dönen bir sonuç tanıtıcısı.

lob_mode

Can be one of:

  • FBSQL_LOB_DIRECT - LOB data is retrieved directly. When data is fetched from the database with fbsql_fetch_row(), and other fetch functions, all CLOB and BLOB columns will be returned as ordinary columns. This is the default value on a new FrontBase result.
  • FBSQL_LOB_HANDLE - LOB data is retrieved as handles to the data. When data is fetched from the database with fbsql_fetch_row(), and other fetch functions, LOB data will be returned as a handle to the data if the data is stored indirect or the data if it is stored direct. If a handle is returned it will be a 27 byte string formatted as @'000000000000000000000000'.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • fbsql_create_blob() - Create a BLOB
  • fbsql_create_clob() - Create a CLOB
  • fbsql_read_blob() - Read a BLOB from the database
  • fbsql_read_clob() - Read a CLOB from the database

fbsql_set_characterset
fbsql_set_password
FrontBase İşlevleri


Change the password for a given user

fbsql_set_lob_mode
fbsql_set_transaction
FrontBase İşlevleri
PHP Manual

fbsql_set_password

(PHP 5, PHP 7)

fbsql_set_password — Change the password for a given user

Açıklama

bool fbsql_set_password ( resource $link_identifier , string $user , string $password , string $old_password )

Changes the password for the given user.

Değiştirgeler

bağlantı_tanıtıcısı

fbsql_connect() veya fbsql_pconnect() işlevinden dönen bir FrontBase bağlantı tanıtıcısı.

İsteğe bağlıysa ve belirtilmemişse işlev, FrontBase sunucusuna açılmış bir bağlantı olup olmadığına bakar, bir bağlantı yoksa fbsql_connect() işlevi değiştirgesiz çağrılmışçasına bir bağlantı oluşturmaya çalışır.

user

The user name.

password

The new password to be set.

old_password

The old password to be replaced.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

fbsql_set_lob_mode
fbsql_set_transaction
FrontBase İşlevleri


Set the transaction locking and isolation

fbsql_set_password
fbsql_start_db
FrontBase İşlevleri
PHP Manual

fbsql_set_transaction

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

fbsql_set_transaction — Set the transaction locking and isolation

Açıklama

void fbsql_set_transaction ( resource $link_identifier , int $locking , int $isolation )

Sets the transaction locking and isolation.

Değiştirgeler

bağlantı_tanıtıcısı

fbsql_connect() veya fbsql_pconnect() işlevinden dönen bir FrontBase bağlantı tanıtıcısı.

İsteğe bağlıysa ve belirtilmemişse işlev, FrontBase sunucusuna açılmış bir bağlantı olup olmadığına bakar, bir bağlantı yoksa fbsql_connect() işlevi değiştirgesiz çağrılmışçasına bir bağlantı oluşturmaya çalışır.

locking

The type of locking to be set. It can be one of the following constants: FBSQL_LOCK_DEFERRED, FBSQL_LOCK_OPTIMISTIC, or FBSQL_LOCK_PESSIMISTIC.

isolation

The type of isolation to be set. It can be one of the following constants: FBSQL_ISO_READ_UNCOMMITTED, FBSQL_ISO_READ_COMMITTED, FBSQL_ISO_REPEATABLE_READ, FBSQL_ISO_SERIALIZABLE, or FBSQL_ISO_VERSIONED.

Dönen Değerler

Hiçbir değer dönmez.

fbsql_set_password
fbsql_start_db
FrontBase İşlevleri


Start a database on local or remote server

fbsql_set_transaction
fbsql_stop_db
FrontBase İşlevleri
PHP Manual

fbsql_start_db

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_start_db — Start a database on local or remote server

Açıklama

bool fbsql_start_db ( string $database_name [, resource $link_identifier [, string $database_options ]] )

Start a database on local or remote server.

Değiştirgeler

database_name

The database name.

bağlantı_tanıtıcısı

fbsql_connect() veya fbsql_pconnect() işlevinden dönen bir FrontBase bağlantı tanıtıcısı.

İsteğe bağlıysa ve belirtilmemişse işlev, FrontBase sunucusuna açılmış bir bağlantı olup olmadığına bakar, bir bağlantı yoksa fbsql_connect() işlevi değiştirgesiz çağrılmışçasına bir bağlantı oluşturmaya çalışır.

database_options

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • fbsql_db_status() - Get the status for a given database
  • fbsql_stop_db() - Stop a database on local or remote server

fbsql_set_transaction
fbsql_stop_db
FrontBase İşlevleri


Stop a database on local or remote server

fbsql_start_db
fbsql_table_name
FrontBase İşlevleri
PHP Manual

fbsql_stop_db

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_stop_db — Stop a database on local or remote server

Açıklama

bool fbsql_stop_db ( string $database_name [, resource $link_identifier ] )

Stops a database on local or remote server.

Değiştirgeler

database_name

The database name.

bağlantı_tanıtıcısı

fbsql_connect() veya fbsql_pconnect() işlevinden dönen bir FrontBase bağlantı tanıtıcısı.

İsteğe bağlıysa ve belirtilmemişse işlev, FrontBase sunucusuna açılmış bir bağlantı olup olmadığına bakar, bir bağlantı yoksa fbsql_connect() işlevi değiştirgesiz çağrılmışçasına bir bağlantı oluşturmaya çalışır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • fbsql_db_status() - Get the status for a given database
  • fbsql_start_db() - Start a database on local or remote server

fbsql_start_db
fbsql_table_name
FrontBase İşlevleri


Get table name of field

fbsql_stop_db
fbsql_tablename
FrontBase İşlevleri
PHP Manual

fbsql_table_name

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

fbsql_table_name — Get table name of field

Açıklama

string fbsql_table_name ( resource $result , int $index )

fbsql_table_name() gets the name of the current table in the given result set.

The fbsql_num_rows() function may be used to determine the number of tables in the result pointer.

Değiştirgeler

result

A result pointer returned by fbsql_list_tables().

index

Integer index for the current table.

Dönen Değerler

Returns the name of the table, as a string.

Örnekler

Örnek 1 fbsql_table_name() example

<?php
fbsql_connect("localhost", "_SYSTEM", "");
$result = fbsql_list_tables("wisconsin");
$i = 0;
while ($i < fbsql_num_rows($result)) {
    $tb_names[$i] = fbsql_table_name($result, $i);
    echo $tb_names[$i] . "<br />";
    $i++;
}
?>

fbsql_stop_db
fbsql_tablename
FrontBase İşlevleri


Takma Adı: fbsql_table_name

fbsql_table_name
fbsql_username
FrontBase İşlevleri
PHP Manual

fbsql_tablename

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

fbsql_tablename — Takma Adı: fbsql_table_name()

Açıklama

Bu işlev şu işlevin takma adıdır: fbsql_table_name().

fbsql_table_name
fbsql_username
FrontBase İşlevleri


Get or set the username for the connection

fbsql_tablename
fbsql_warnings
FrontBase İşlevleri
PHP Manual

fbsql_username

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_username — Get or set the username for the connection

Açıklama

string fbsql_username ( resource $link_identifier [, string $username ] )

Get or set the username used for the connection.

Değiştirgeler

bağlantı_tanıtıcısı

fbsql_connect() veya fbsql_pconnect() işlevinden dönen bir FrontBase bağlantı tanıtıcısı.

İsteğe bağlıysa ve belirtilmemişse işlev, FrontBase sunucusuna açılmış bir bağlantı olup olmadığına bakar, bir bağlantı yoksa fbsql_connect() işlevi değiştirgesiz çağrılmışçasına bir bağlantı oluşturmaya çalışır.

username

If provided, this is the new username to set.

Dönen Değerler

Returns the current username used with the connection, as a string.

Ayrıca Bakınız

  • fbsql_password() - Get or set the user password used with a connection
  • fbsql_hostname() - Get or set the host name used with a connection

fbsql_tablename
fbsql_warnings
FrontBase İşlevleri


Enable or disable FrontBase warnings

fbsql_username
IBM DB2
FrontBase İşlevleri
PHP Manual

fbsql_warnings

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

fbsql_warnings — Enable or disable FrontBase warnings

Açıklama

bool fbsql_warnings ([ bool $OnOff ] )

Enables or disables FrontBase warnings.

Değiştirgeler

OnOff

Whether to enable warnings or no.

Dönen Değerler

Returns TRUE if warnings is turned on, FALSE otherwise.

Ayrıca Bakınız

  • fbsql_errno() - Returns the error number from previous operation
  • fbsql_error() - Returns the error message from previous operation

fbsql_username
IBM DB2
FrontBase İşlevleri


IBM DB2, Cloudscape and Apache Derby

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • IBM DB2 İşlevleri
    • db2_autocommit — Returns or sets the AUTOCOMMIT state for a database connection
    • db2_bind_param — Binds a PHP variable to an SQL statement parameter
    • db2_client_info — Returns an object with properties that describe the DB2 database client
    • db2_close — Closes a database connection
    • db2_column_privileges — Returns a result set listing the columns and associated privileges for a table
    • db2_columns — Returns a result set listing the columns and associated metadata for a table
    • db2_commit — Commits a transaction
    • db2_conn_error — Returns a string containing the SQLSTATE returned by the last connection attempt
    • db2_conn_errormsg — Returns the last connection error message and SQLCODE value
    • db2_connect — Returns a connection to a database
    • db2_cursor_type — Returns the cursor type used by a statement resource
    • db2_escape_string — Used to escape certain characters
    • db2_exec — Executes an SQL statement directly
    • db2_execute — Executes a prepared SQL statement
    • db2_fetch_array — Returns an array, indexed by column position, representing a row in a result set
    • db2_fetch_assoc — Returns an array, indexed by column name, representing a row in a result set
    • db2_fetch_both — Returns an array, indexed by both column name and position, representing a row in a result set
    • db2_fetch_object — Returns an object with properties representing columns in the fetched row
    • db2_fetch_row — Sets the result set pointer to the next row or requested row
    • db2_field_display_size — Returns the maximum number of bytes required to display a column
    • db2_field_name — Returns the name of the column in the result set
    • db2_field_num — Returns the position of the named column in a result set
    • db2_field_precision — Returns the precision of the indicated column in a result set
    • db2_field_scale — Returns the scale of the indicated column in a result set
    • db2_field_type — Returns the data type of the indicated column in a result set
    • db2_field_width — Returns the width of the current value of the indicated column in a result set
    • db2_foreign_keys — Returns a result set listing the foreign keys for a table
    • db2_free_result — Frees resources associated with a result set
    • db2_free_stmt — Frees resources associated with the indicated statement resource
    • db2_get_option — Retrieves an option value for a statement resource or a connection resource
    • db2_last_insert_id — Returns the auto generated ID of the last insert query that successfully executed on this connection
    • db2_lob_read — Gets a user defined size of LOB files with each invocation
    • db2_next_result — Requests the next result set from a stored procedure
    • db2_num_fields — Returns the number of fields contained in a result set
    • db2_num_rows — Returns the number of rows affected by an SQL statement
    • db2_pclose — Closes a persistent database connection
    • db2_pconnect — Returns a persistent connection to a database
    • db2_prepare — Prepares an SQL statement to be executed
    • db2_primary_keys — Returns a result set listing primary keys for a table
    • db2_procedure_columns — Returns a result set listing stored procedure parameters
    • db2_procedures — Returns a result set listing the stored procedures registered in a database
    • db2_result — Returns a single column from a row in the result set
    • db2_rollback — Rolls back a transaction
    • db2_server_info — Returns an object with properties that describe the DB2 database server
    • db2_set_option — Set options for connection or statement resources
    • db2_special_columns — Returns a result set listing the unique row identifier columns for a table
    • db2_statistics — Returns a result set listing the index and statistics for a table
    • db2_stmt_error — Returns a string containing the SQLSTATE returned by an SQL statement
    • db2_stmt_errormsg — Returns a string containing the last SQL statement error message
    • db2_table_privileges — Returns a result set listing the tables and associated privileges in a database
    • db2_tables — Returns a result set listing the tables and associated metadata in a database
fbsql_warnings
Giriş
Sağlayıcıya Göre Veritabanı Eklentileri


Giriş

These functions enable you to access IBM DB2 Universal Database, IBM Cloudscape, and Apache Derby databases using the DB2 Call Level Interface (DB2 CLI).

IBM DB2
Yapılandırma/Kurulum
IBM DB2


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
IBM DB2


Gereksinimler

To connect to IBM DB2 Universal Database for Linux, UNIX, and Windows, or IBM Cloudscape, or Apache Derby, you must install an IBM DB2 Universal Database client on the same computer on which you are running PHP. The extension has been developed and tested with DB2 Version 8.2.

To connect to IBM DB2 Universal Database for z/OS or iSeries, you also require IBM DB2 Connect or the equivalent DRDA gateway software.

Requirements on Linux or Unix

The user invoking the PHP executable or SAPI must specify the DB2 instance before accessing these functions. You can set the name of the DB2 instance in php.ini using the ibm_db2.instance_name configuration option, or you can source the DB2 instance profile before invoking the PHP executable.

If you created a DB2 instance named db2inst1 in /home/db2inst1/, for example, you can add the following line to php.ini:

ibm_db2.instance_name=db2inst1
If you do not set this option in php.ini, you must issue the following command to modify your environment variables to enable access to DB2:
bash$ source /home/db2inst1/sqllib/db2profile
To enable your PHP-enabled Web server to access these functions, you must either set the ibm_db2.instance_name configuration option in php.ini, or source the DB2 instance environment in your Web server start script (typically /etc/init.d/httpd or /etc/init.d/apache).

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

To build the ibm_db2 extension, the DB2 application development header files and libraries must be installed on your system. DB2 does not install these by default, so you may have to return to your DB2 installer and add this option. The header files are included with the DB2 Application Development Client freely available for download from the IBM DB2 Universal Database » support site.

If you add the DB2 application development header files and libraries to a Linux or Unix operating system on which DB2 was already installed, you must issue the command db2iupdt -e to update the symbolic links to the header files and libraries in your DB2 instances.

ibm_db2 is a » PECL extension, so follow the instructions in PECL eklentilerinin kurulması to install the ibm_db2 extension for PHP. Issue the configure command to point to the location of your DB2 header files and libraries as follows:

bash$ ./configure --with-IBM_DB2=/path/to/DB2
The configure command defaults to /opt/IBM/db2/V8.1.

Bilginize: Note for IIS users

If you are using the ibm_db2 driver with Microsoft Internet Information Server (IIS) you may have to do the following:

  • Install DB2 with extended operating system security.
  • Add the PHP binary path to the PATH system environment variable (default C:\php\).
  • Create another system environment variable equal to the path where the PHP.INI file is located (eg: PHPRC = C:\php\).
  • Add the IUSR_COMPUTERNAME to the DB2USERS group.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

ibm_db2 Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Changelog
ibm_db2.binmode | "1" | PHP_INI_ALL |
ibm_db2.i5_all_pconnect | "0" | PHP_INI_SYSTEM | Available since ibm_db2 1.6.5.
ibm_db2.i5_allow_commit | "0" | PHP_INI_SYSTEM | Available since ibm_db2 1.4.9.
ibm_db2.i5_dbcs_alloc | "0" | PHP_INI_SYSTEM | Available since ibm_db2 1.5.0.
ibm_db2.instance_name | NULL | PHP_INI_SYSTEM | Available since ibm_db2 1.0.2.
ibm_db2.i5_ignore_userid | "0" | PHP_INI_SYSTEM | Available since ibm_db2 1.8.0.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

ibm_db2.binmode integer

This option controls the mode used for converting to and from binary data in the PHP application.

  • 1 (DB2_BINARY)

  • 2 (DB2_CONVERT)

  • 3 (DB2_PASSTHRU)

ibm_db2.i5_all_pconnect integer

This option overrides i5 db2_connect() full open and close in the PHP application. When ibm_db2.i5_all_pconnect = 1, all db2 connections become persistent (db2_pconnect()). On i5/OS, db2_pconnect() performs dramatically better with lower machine stress over db2_connect(). This is a convenience override of db2_connect() to evoke db2_pconnect() without PHP source code changes.

  • 0 db2_connect() default full open and close

  • 1 db2_connect() override to db2_pconnect() for persistent connection only

ibm_db2.i5_allow_commit integer

This option controls the isolation mode used for i5 schema collections in the PHP application (see i5_commit for override).

  • 0 - commitment control is not used

  • 1 - read uncommitted, dirty reads possible.

  • 2 - read committed, dirty reads are not possible.

  • 3 - repeatable read, dirty reads and non-repeatable reads are not possible

  • 4 - serializeable, dirty reads, non-repeatable reads, and phantoms are not possible

ibm_db2.i5_dbcs_alloc integer

This option controls the internal ibm_db2 allocation scheme for large DBCS column buffers.

  • 0 no expanded allocations (see i5_dbcs_alloc for override)

  • 1 use expanded allocations (see i5_dbcs_alloc for override)

ibm_db2.instance_name string

On Linux and UNIX operating systems, this option defines the name of the instance to use for cataloged database connections. If this option is set, its value overrides the DB2INSTANCE environment variable setting.

This option is ignored on Windows operating systems.

ibm_db2.i5_ignore_userid integer

This option overrides i5 db2_(p)connect userid and password in the PHP application. When ibm_db2.i5_ignore_userid = 1, all db2 (p)connections become null userid and null password. Therefore Apache jobs connect with the current profile (NOBODY). Use of this override is only for simple DB2 based websites that never require profile switching and therefore can avoid all overhead of server mode additional QSQSRVR jobs. This is a convenience override of db2_(p)connect to set the userid and password values to null without PHP source code changes. This override can be used in combination with ibm_db2.i5_all_pconnect = 1.

  • 0 db2_(p)connect with specified userid and password

  • 1 db2_(p)connect override connect with null userid and null password

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Özkaynak Türleri

The ibm_db2 extension returns connection resources, statement resources, and result set resources.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

DB2_BINARY (integer)
Specifies that binary data shall be returned as is. This is the default mode.
DB2_CONVERT (integer)
Specifies that binary data shall be converted to a hexadecimal encoding and returned as an ASCII string.
DB2_PASSTHRU (integer)
Specifies that binary data shall be converted to a NULL value.
DB2_SCROLLABLE (integer)
Specifies a scrollable cursor for a statement resource. This mode enables random access to rows in a result set, but currently is supported only by IBM DB2 Universal Database.
DB2_FORWARD_ONLY (integer)
Specifies a forward-only cursor for a statement resource. This is the default cursor type and is supported on all database servers.
DB2_PARAM_IN (integer)
Specifies the PHP variable should be bound as an IN parameter for a stored procedure.
DB2_PARAM_OUT (integer)
Specifies the PHP variable should be bound as an OUT parameter for a stored procedure.
DB2_PARAM_INOUT (integer)
Specifies the PHP variable should be bound as an INOUT parameter for a stored procedure.
DB2_PARAM_FILE (integer)
Specifies that the column should be bound directly to a file for input.
DB2_AUTOCOMMIT_ON (integer)
Specifies that autocommit should be turned on.
DB2_AUTOCOMMIT_OFF (integer)
Specifies that autocommit should be turned off.
DB2_DOUBLE (integer)
Specifies that the variable should be bound as a DOUBLE, FLOAT, or REAL data type.
DB2_LONG (integer)
Specifies that the variable should be bound as a SMALLINT, INTEGER, or BIGINT data type.
DB2_CHAR (integer)
Specifies that the variable should be bound as a CHAR or VARCHAR data type.
DB2_CASE_NATURAL (integer)
Specifies that column names will be returned in their natural case.
DB2_CASE_LOWER (integer)
Specifies that column names will be returned in lower case.
DB2_CASE_UPPER (integer)
Specifies that column names will be returned in upper case.
DB2_DEFERRED_PREPARE_ON (integer)
Specifies that deferred prepare should be turned on for the specified statement resource.
DB2_DEFERRED_PREPARE_OFF (integer)
Specifies that deferred prepare should be turned off for the specified statement resource.
Özkaynak Türleri
IBM DB2 İşlevleri
IBM DB2


IBM DB2 İşlevleri

İçindekiler

  • db2_autocommit — Returns or sets the AUTOCOMMIT state for a database connection
  • db2_bind_param — Binds a PHP variable to an SQL statement parameter
  • db2_client_info — Returns an object with properties that describe the DB2 database client
  • db2_close — Closes a database connection
  • db2_column_privileges — Returns a result set listing the columns and associated privileges for a table
  • db2_columns — Returns a result set listing the columns and associated metadata for a table
  • db2_commit — Commits a transaction
  • db2_conn_error — Returns a string containing the SQLSTATE returned by the last connection attempt
  • db2_conn_errormsg — Returns the last connection error message and SQLCODE value
  • db2_connect — Returns a connection to a database
  • db2_cursor_type — Returns the cursor type used by a statement resource
  • db2_escape_string — Used to escape certain characters
  • db2_exec — Executes an SQL statement directly
  • db2_execute — Executes a prepared SQL statement
  • db2_fetch_array — Returns an array, indexed by column position, representing a row in a result set
  • db2_fetch_assoc — Returns an array, indexed by column name, representing a row in a result set
  • db2_fetch_both — Returns an array, indexed by both column name and position, representing a row in a result set
  • db2_fetch_object — Returns an object with properties representing columns in the fetched row
  • db2_fetch_row — Sets the result set pointer to the next row or requested row
  • db2_field_display_size — Returns the maximum number of bytes required to display a column
  • db2_field_name — Returns the name of the column in the result set
  • db2_field_num — Returns the position of the named column in a result set
  • db2_field_precision — Returns the precision of the indicated column in a result set
  • db2_field_scale — Returns the scale of the indicated column in a result set
  • db2_field_type — Returns the data type of the indicated column in a result set
  • db2_field_width — Returns the width of the current value of the indicated column in a result set
  • db2_foreign_keys — Returns a result set listing the foreign keys for a table
  • db2_free_result — Frees resources associated with a result set
  • db2_free_stmt — Frees resources associated with the indicated statement resource
  • db2_get_option — Retrieves an option value for a statement resource or a connection resource
  • db2_last_insert_id — Returns the auto generated ID of the last insert query that successfully executed on this connection
  • db2_lob_read — Gets a user defined size of LOB files with each invocation
  • db2_next_result — Requests the next result set from a stored procedure
  • db2_num_fields — Returns the number of fields contained in a result set
  • db2_num_rows — Returns the number of rows affected by an SQL statement
  • db2_pclose — Closes a persistent database connection
  • db2_pconnect — Returns a persistent connection to a database
  • db2_prepare — Prepares an SQL statement to be executed
  • db2_primary_keys — Returns a result set listing primary keys for a table
  • db2_procedure_columns — Returns a result set listing stored procedure parameters
  • db2_procedures — Returns a result set listing the stored procedures registered in a database
  • db2_result — Returns a single column from a row in the result set
  • db2_rollback — Rolls back a transaction
  • db2_server_info — Returns an object with properties that describe the DB2 database server
  • db2_set_option — Set options for connection or statement resources
  • db2_special_columns — Returns a result set listing the unique row identifier columns for a table
  • db2_statistics — Returns a result set listing the index and statistics for a table
  • db2_stmt_error — Returns a string containing the SQLSTATE returned by an SQL statement
  • db2_stmt_errormsg — Returns a string containing the last SQL statement error message
  • db2_table_privileges — Returns a result set listing the tables and associated privileges in a database
  • db2_tables — Returns a result set listing the tables and associated metadata in a database
Öntanımlı Sabitler
db2_autocommit
IBM DB2


Returns or sets the AUTOCOMMIT state for a database connection

IBM DB2 İşlevleri
db2_bind_param
IBM DB2 İşlevleri
PHP Manual

db2_autocommit

(PECL ibm_db2 >= 1.0.0)

db2_autocommit — Returns or sets the AUTOCOMMIT state for a database connection

Açıklama

mixed db2_autocommit ( resource $connection [, bool $value ] )

Sets or gets the AUTOCOMMIT behavior of the specified connection resource.

Değiştirgeler

connection

A valid database connection resource variable as returned from db2_connect() or db2_pconnect().

value

One of the following constants:

DB2_AUTOCOMMIT_OFF

Turns AUTOCOMMIT off.

DB2_AUTOCOMMIT_ON

Turns AUTOCOMMIT on.

Dönen Değerler

When db2_autocommit() receives only the connection parameter, it returns the current state of AUTOCOMMIT for the requested connection as an integer value. A value of 0 indicates that AUTOCOMMIT is off, while a value of 1 indicates that AUTOCOMMIT is on.

When db2_autocommit() receives both the connection parameter and autocommit parameter, it attempts to set the AUTOCOMMIT state of the requested connection to the corresponding state. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Retrieving the AUTOCOMMIT value for a connection

In the following example, a connection which has been created with AUTOCOMMIT turned off is tested with the db2_autocommit() function.

<?php
$options = array('autocommit' => DB2_AUTOCOMMIT_OFF);
$conn = db2_connect($database, $user, $password, $options);
$ac = db2_autocommit($conn);
if ($ac == 0) {
    print "$ac -- AUTOCOMMIT is off.";
} else {
    print "$ac -- AUTOCOMMIT is on.";
}
?>

Yukarıdaki örneğin çıktısı:

0 -- AUTOCOMMIT is off.

Örnek 2 Setting the AUTOCOMMIT value for a connection

In the following example, a connection which was initially created with AUTOCOMMIT turned off has its behavior changed to turn AUTOCOMMIT on.

<?php
$options = array('autocommit' => DB2_AUTOCOMMIT_OFF);
$conn = db2_connect($database, $user, $password, $options);

// Turn AUTOCOMMIT on
$rc = db2_autocommit($conn, DB2_AUTOCOMMIT_ON);
if ($rc) {
    print "Turning AUTOCOMMIT on succeeded.\n";
}

// Check AUTOCOMMIT state
$ac = db2_autocommit($conn);
if ($ac == 0) {
    print "$ac -- AUTOCOMMIT is off.";
} else {
    print "$ac -- AUTOCOMMIT is on.";
}
?>

Yukarıdaki örneğin çıktısı:

Turning AUTOCOMMIT on succeeded.
1 -- AUTOCOMMIT is on.

Ayrıca Bakınız

  • db2_connect() - Returns a connection to a database
  • db2_pconnect() - Returns a persistent connection to a database

IBM DB2 İşlevleri
db2_bind_param
IBM DB2 İşlevleri


Binds a PHP variable to an SQL statement parameter

db2_autocommit
db2_client_info
IBM DB2 İşlevleri
PHP Manual

db2_bind_param

(PECL ibm_db2 >= 1.0.0)

db2_bind_param — Binds a PHP variable to an SQL statement parameter

Açıklama

bool db2_bind_param ( resource $stmt , int $parameter-number , string $variable-name [, int $parameter-type [, int $data-type = 0 [, int $precision = -1 [, int $scale = 0 ]]]] )

Binds a PHP variable to an SQL statement parameter in a statement resource returned by db2_prepare(). This function gives you more control over the parameter type, data type, precision, and scale for the parameter than simply passing the variable as part of the optional input array to db2_execute().

Değiştirgeler

stmt

A prepared statement returned from db2_prepare().

parameter-number

Specifies the 1-indexed position of the parameter in the prepared statement.

variable-name

A string specifying the name of the PHP variable to bind to the parameter specified by parameter-number.

parameter-type

A constant specifying whether the PHP variable should be bound to the SQL parameter as an input parameter (DB2_PARAM_IN), an output parameter (DB2_PARAM_OUT), or as a parameter that accepts input and returns output (DB2_PARAM_INOUT). To avoid memory overhead, you can also specify DB2_PARAM_FILE to bind the PHP variable to the name of a file that contains large object (BLOB, CLOB, or DBCLOB) data.

data-type

A constant specifying the SQL data type that the PHP variable should be bound as: one of DB2_BINARY, DB2_CHAR, DB2_DOUBLE, or DB2_LONG .

precision

Specifies the precision with which the variable should be bound to the database. This parameter can also be used for retrieving XML output values from stored procedures. A non-negative value specifies the maximum size of the XML data that will be retrieved from the database. If this parameter is not used, a default of 1MB will be assumed for retrieving the XML output value from the stored procedure.

scale

Specifies the scale with which the variable should be bound to the database.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Binding PHP variables to a prepared statement

The SQL statement in the following example uses two input parameters in the WHERE clause. We call db2_bind_param() to bind two PHP variables to the corresponding SQL parameters. Notice that the PHP variables do not have to be declared or assigned before the call to db2_bind_param(); in the example, $lower_limit is assigned a value before the call to db2_bind_param(), but $upper_limit is assigned a value after the call to db2_bind_param(). The variables must be bound and, for parameters that accept input, must have any value assigned, before calling db2_execute().

<?php

$sql = 'SELECT name, breed, weight FROM animals
    WHERE weight > ? AND weight < ?';
$conn = db2_connect($database, $user, $password);
$stmt = db2_prepare($conn, $sql);

// We can declare the variable before calling db2_bind_param()
$lower_limit = 1;

db2_bind_param($stmt, 1, "lower_limit", DB2_PARAM_IN);
db2_bind_param($stmt, 2, "upper_limit", DB2_PARAM_IN);

// We can also declare the variable after calling db2_bind_param()
$upper_limit = 15.0;

if (db2_execute($stmt)) {
    while ($row = db2_fetch_array($stmt)) {
        print "{$row[0]}, {$row[1]}, {$row[2]}\n";
    }
}
?>

Yukarıdaki örneğin çıktısı:

Pook, cat, 3.2
Rickety Ride, goat, 9.7
Peaches, dog, 12.3

Örnek 2 Calling stored procedures with IN and OUT parameters

The stored procedure match_animal in the following example accepts three different parameters:

  1. an input (IN) parameter that accepts the name of the first animal as input

  2. an input-output (INOUT) parameter that accepts the name of the second animal as input and returns the string TRUE if an animal in the database matches that name

  3. an output (OUT) parameter that returns the sum of the weight of the two identified animals

In addition, the stored procedure returns a result set consisting of the animals listed in alphabetic order starting at the animal corresponding to the input value of the first parameter and ending at the animal corresponding to the input value of the second parameter.

<?php

$sql = 'CALL match_animal(?, ?, ?)';
$conn = db2_connect($database, $user, $password);
$stmt = db2_prepare($conn, $sql);

$name = "Peaches";
$second_name = "Rickety Ride";
$weight = 0;

db2_bind_param($stmt, 1, "name", DB2_PARAM_IN);
db2_bind_param($stmt, 2, "second_name", DB2_PARAM_INOUT);
db2_bind_param($stmt, 3, "weight", DB2_PARAM_OUT);

print "Values of bound parameters _before_ CALL:\n";
print "  1: {$name} 2: {$second_name} 3: {$weight}\n\n";

if (db2_execute($stmt)) {
    print "Values of bound parameters _after_ CALL:\n";
    print "  1: {$name} 2: {$second_name} 3: {$weight}\n\n";

    print "Results:\n";
    while ($row = db2_fetch_array($stmt)) {
        print "  {$row[0]}, {$row[1]}, {$row[2]}\n";
    }
}
?>

Yukarıdaki örneğin çıktısı:

Values of bound parameters _before_ CALL:
  1: Peaches 2: Rickety Ride 3: 0

Values of bound parameters _after_ CALL:
  1: Peaches 2: TRUE 3: 22

Results:
  Peaches, dog, 12.3
  Pook, cat, 3.2
  Rickety Ride, goat, 9.7

Örnek 3 Inserting a binary large object (BLOB) directly from a file

The data for large objects are typically stored in files, such as XML documents or audio files. Rather than reading an entire file into a PHP variable, and then binding that PHP variable into an SQL statement, you can avoid some memory overhead by binding the file directly to the input parameter of your SQL statement. The following example demonstrates how to bind a file directly into a BLOB column.

<?php
$stmt = db2_prepare($conn, "INSERT INTO animal_pictures(picture) VALUES (?)");

$picture = "/opt/albums/spook/grooming.jpg";
$rc = db2_bind_param($stmt, 1, "picture", DB2_PARAM_FILE);
$rc = db2_execute($stmt);
?>

Ayrıca Bakınız

  • db2_execute() - Executes a prepared SQL statement
  • db2_prepare() - Prepares an SQL statement to be executed

db2_autocommit
db2_client_info
IBM DB2 İşlevleri


Returns an object with properties that describe the DB2 database client

db2_bind_param
db2_close
IBM DB2 İşlevleri
PHP Manual

db2_client_info

(PECL ibm_db2 >= 1.1.1)

db2_client_info — Returns an object with properties that describe the DB2 database client

Açıklama

object db2_client_info ( resource $connection )

This function returns an object with read-only properties that return information about the DB2 database client. The following table lists the DB2 client properties:

DB2 client properties
Property name | Return type | Description
APPL_CODEPAGE | int | The application code page.
CONN_CODEPAGE | int | The code page for the current connection.
DATA_SOURCE_NAME | string | The data source name (DSN) used to create the current connection to the database.
DRIVER_NAME | string | The name of the library that implements the DB2 Call Level Interface (CLI) specification.
DRIVER_ODBC_VER | string | The version of ODBC that the DB2 client supports. This returns a string "MM.mm" where MM is the major version and mm is the minor version. The DB2 client always returns "03.51".
DRIVER_VER | string | The version of the client, in the form of a string "MM.mm.uuuu" where MM is the major version, mm is the minor version, and uuuu is the update. For example, "08.02.0001" represents major version 8, minor version 2, update 1.
ODBC_SQL_CONFORMANCE string

The level of ODBC SQL grammar supported by the client:

MINIMUM

Supports the minimum ODBC SQL grammar.

CORE

Supports the core ODBC SQL grammar.

EXTENDED

Supports extended ODBC SQL grammar.

ODBC_VER | string | The version of ODBC that the ODBC driver manager supports. This returns a string "MM.mm.rrrr" where MM is the major version, mm is the minor version, and rrrr is the release. The DB2 client always returns "03.01.0000".

Değiştirgeler

connection

Specifies an active DB2 client connection.

Dönen Değerler

Returns an object on a successful call. Returns FALSE on failure.

Örnekler

Örnek 1 A db2_client_info() example

To retrieve information about the client, you must pass a valid database connection resource to db2_client_info().

<?php
$conn = db2_connect( 'SAMPLE', 'db2inst1', 'ibmdb2' );
$client = db2_client_info( $conn );

if ($client) {
    echo "DRIVER_NAME: ";           var_dump( $client->DRIVER_NAME );
    echo "DRIVER_VER: ";            var_dump( $client->DRIVER_VER );
    echo "DATA_SOURCE_NAME: ";      var_dump( $client->DATA_SOURCE_NAME );
    echo "DRIVER_ODBC_VER: ";       var_dump( $client->DRIVER_ODBC_VER );
    echo "ODBC_VER: ";              var_dump( $client->ODBC_VER );
    echo "ODBC_SQL_CONFORMANCE: ";  var_dump( $client->ODBC_SQL_CONFORMANCE );
    echo "APPL_CODEPAGE: ";         var_dump( $client->APPL_CODEPAGE );
    echo "CONN_CODEPAGE: ";         var_dump( $client->CONN_CODEPAGE );
}
else {
    echo "Error retrieving client information.
     Perhaps your database connection was invalid.";
}
db2_close($conn);

?>

Yukarıdaki örneğin çıktısı:

DRIVER_NAME: string(8) "libdb2.a"
DRIVER_VER: string(10) "08.02.0001"
DATA_SOURCE_NAME: string(6) "SAMPLE"
DRIVER_ODBC_VER: string(5) "03.51"
ODBC_VER: string(10) "03.01.0000"
ODBC_SQL_CONFORMANCE: string(8) "EXTENDED"
APPL_CODEPAGE: int(819)
CONN_CODEPAGE: int(819)

Ayrıca Bakınız

  • db2_server_info() - Returns an object with properties that describe the DB2 database server

db2_bind_param
db2_close
IBM DB2 İşlevleri


Closes a database connection

db2_client_info
db2_column_privileges
IBM DB2 İşlevleri
PHP Manual

db2_close

(PECL ibm_db2 >= 1.0.0)

db2_close — Closes a database connection

Açıklama

bool db2_close ( resource $connection )

This function closes a DB2 client connection created with db2_connect() and returns the corresponding resources to the database server.

If you attempt to close a persistent DB2 client connection created with db2_pconnect(), the close request is ignored and the persistent DB2 client connection remains available for the next caller.

Değiştirgeler

connection

Specifies an active DB2 client connection.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Closing a connection

The following example demonstrates a successful attempt to close a connection to an IBM DB2, Cloudscape, or Apache Derby database.

<?php
$conn = db2_connect('SAMPLE', 'db2inst1', 'ibmdb2');
$rc = db2_close($conn);
if ($rc) {
    echo "Connection was successfully closed.";
}
?>

Yukarıdaki örneğin çıktısı:

Connection was successfully closed.

Ayrıca Bakınız

  • db2_connect() - Returns a connection to a database
  • db2_pclose() - Closes a persistent database connection
  • db2_pconnect() - Returns a persistent connection to a database

db2_client_info
db2_column_privileges
IBM DB2 İşlevleri


Returns a result set listing the columns and associated privileges for a table

db2_close
db2_columns
IBM DB2 İşlevleri
PHP Manual

db2_column_privileges

(PECL ibm_db2 >= 1.0.0)

db2_column_privileges — Returns a result set listing the columns and associated privileges for a table

Açıklama

resource db2_column_privileges ( resource $connection [, string $qualifier [, string $schema [, string $table-name [, string $column-name ]]]] )

Returns a result set listing the columns and associated privileges for a table.

Değiştirgeler

connection

A valid connection to an IBM DB2, Cloudscape, or Apache Derby database.

qualifier

A qualifier for DB2 databases running on OS/390 or z/OS servers. For other databases, pass NULL or an empty string.

schema

The schema which contains the tables. To match all schemas, pass NULL or an empty string.

table-name

The name of the table or view. To match all tables in the database, pass NULL or an empty string.

column-name

The name of the column. To match all columns in the table, pass NULL or an empty string.

Dönen Değerler

Returns a statement resource with a result set containing rows describing the column privileges for columns matching the specified parameters. The rows are composed of the following columns:

Column name | Description
TABLE_CAT | Name of the catalog. The value is NULL if this table does not have catalogs.
TABLE_SCHEM | Name of the schema.
TABLE_NAME | Name of the table or view.
COLUMN_NAME | Name of the column.
GRANTOR | Authorization ID of the user who granted the privilege.
GRANTEE | Authorization ID of the user to whom the privilege was granted.
PRIVILEGE | The privilege for the column.
IS_GRANTABLE | Whether the GRANTEE is permitted to grant this privilege to other users.

Ayrıca Bakınız

  • db2_columns() - Returns a result set listing the columns and associated metadata for a table
  • db2_foreign_keys() - Returns a result set listing the foreign keys for a table
  • db2_primary_keys() - Returns a result set listing primary keys for a table
  • db2_procedure_columns() - Returns a result set listing stored procedure parameters
  • db2_procedures() - Returns a result set listing the stored procedures registered in a database
  • db2_special_columns() - Returns a result set listing the unique row identifier columns for a table
  • db2_statistics() - Returns a result set listing the index and statistics for a table
  • db2_table_privileges() - Returns a result set listing the tables and associated privileges in a database
  • db2_tables() - Returns a result set listing the tables and associated metadata in a database

db2_close
db2_columns
IBM DB2 İşlevleri


Returns a result set listing the columns and associated metadata for a table

db2_column_privileges
db2_commit
IBM DB2 İşlevleri
PHP Manual

db2_columns

(PECL ibm_db2 >= 1.0.0)

db2_columns — Returns a result set listing the columns and associated metadata for a table

Açıklama

resource db2_columns ( resource $connection [, string $qualifier [, string $schema [, string $table-name [, string $column-name ]]]] )

Returns a result set listing the columns and associated metadata for a table.

Değiştirgeler

connection

A valid connection to an IBM DB2, Cloudscape, or Apache Derby database.

qualifier

A qualifier for DB2 databases running on OS/390 or z/OS servers. For other databases, pass NULL or an empty string.

schema

The schema which contains the tables. To match all schemas, pass '%'.

table-name

The name of the table or view. To match all tables in the database, pass NULL or an empty string.

column-name

The name of the column. To match all columns in the table, pass NULL or an empty string.

Dönen Değerler

Returns a statement resource with a result set containing rows describing the columns matching the specified parameters. The rows are composed of the following columns:

Column name | Description
TABLE_CAT | Name of the catalog. The value is NULL if this table does not have catalogs.
TABLE_SCHEM | Name of the schema.
TABLE_NAME | Name of the table or view.
COLUMN_NAME | Name of the column.
DATA_TYPE | The SQL data type for the column represented as an integer value.
TYPE_NAME | A string representing the data type for the column.
COLUMN_SIZE | An integer value representing the size of the column.
BUFFER_LENGTH | Maximum number of bytes necessary to store data from this column.
DECIMAL_DIGITS | The scale of the column, or NULL where scale is not applicable.
NUM_PREC_RADIX | An integer value of either 10 (representing an exact numeric data type), 2 (representing an approximate numeric data type), or NULL (representing a data type for which radix is not applicable).
NULLABLE | An integer value representing whether the column is nullable or not.
REMARKS | Description of the column.
COLUMN_DEF | Default value for the column.
SQL_DATA_TYPE | An integer value representing the size of the column.
SQL_DATETIME_SUB | Returns an integer value representing a datetime subtype code, or NULL for SQL data types to which this does not apply.
CHAR_OCTET_LENGTH | Maximum length in octets for a character data type column, which matches COLUMN_SIZE for single-byte character set data, or NULL for non-character data types.
ORDINAL_POSITION | The 1-indexed position of the column in the table.
IS_NULLABLE | A string value where 'YES' means that the column is nullable and 'NO' means that the column is not nullable.

Ayrıca Bakınız

  • db2_column_privileges() - Returns a result set listing the columns and associated privileges for a table
  • db2_foreign_keys() - Returns a result set listing the foreign keys for a table
  • db2_primary_keys() - Returns a result set listing primary keys for a table
  • db2_procedure_columns() - Returns a result set listing stored procedure parameters
  • db2_procedures() - Returns a result set listing the stored procedures registered in a database
  • db2_special_columns() - Returns a result set listing the unique row identifier columns for a table
  • db2_statistics() - Returns a result set listing the index and statistics for a table
  • db2_table_privileges() - Returns a result set listing the tables and associated privileges in a database
  • db2_tables() - Returns a result set listing the tables and associated metadata in a database

db2_column_privileges
db2_commit
IBM DB2 İşlevleri


Commits a transaction

db2_columns
db2_conn_error
IBM DB2 İşlevleri
PHP Manual

db2_commit

(PECL ibm_db2 >= 1.0.0)

db2_commit — Commits a transaction

Açıklama

bool db2_commit ( resource $connection )

Commits an in-progress transaction on the specified connection resource and begins a new transaction. PHP applications normally default to AUTOCOMMIT mode, so db2_commit() is not necessary unless AUTOCOMMIT has been turned off for the connection resource.

Değiştirgeler

connection

A valid database connection resource variable as returned from db2_connect() or db2_pconnect().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • db2_autocommit() - Returns or sets the AUTOCOMMIT state for a database connection
  • db2_rollback() - Rolls back a transaction

db2_columns
db2_conn_error
IBM DB2 İşlevleri


Returns a string containing the SQLSTATE returned by the last connection attempt

db2_commit
db2_conn_errormsg
IBM DB2 İşlevleri
PHP Manual

db2_conn_error

(PECL ibm_db2 >= 1.0.0)

db2_conn_error — Returns a string containing the SQLSTATE returned by the last connection attempt

Açıklama

string db2_conn_error ([ resource $connection ] )

db2_conn_error() returns an SQLSTATE value representing the reason the last attempt to connect to a database failed. As db2_connect() returns FALSE in the event of a failed connection attempt, you do not pass any parameters to db2_conn_error() to retrieve the SQLSTATE value.

If, however, the connection was successful but becomes invalid over time, you can pass the connection parameter to retrieve the SQLSTATE value for a specific connection.

To learn what the SQLSTATE value means, you can issue the following command at a DB2 Command Line Processor prompt: db2 '? sqlstate-value'. You can also call db2_conn_errormsg() to retrieve an explicit error message and the associated SQLCODE value.

Değiştirgeler

connection

A connection resource associated with a connection that initially succeeded, but which over time became invalid.

Dönen Değerler

Returns the SQLSTATE value resulting from a failed connection attempt. Returns an empty string if there is no error associated with the last connection attempt.

Örnekler

Örnek 1 Retrieving an SQLSTATE value for a failed connection attempt

The following example demonstrates how to return an SQLSTATE value after deliberately passing invalid parameters to db2_connect().

<?php
$conn = db2_connect('badname', 'baduser', 'badpassword');
if (!$conn) {
    print "SQLSTATE value: " . db2_conn_error();
}
?>

Yukarıdaki örneğin çıktısı:

SQLSTATE value: 08001

Ayrıca Bakınız

  • db2_conn_errormsg() - Returns the last connection error message and SQLCODE value
  • db2_connect() - Returns a connection to a database
  • db2_stmt_error() - Returns a string containing the SQLSTATE returned by an SQL statement
  • db2_stmt_errormsg() - Returns a string containing the last SQL statement error message

db2_commit
db2_conn_errormsg
IBM DB2 İşlevleri


Returns the last connection error message and SQLCODE value

db2_conn_error
db2_connect
IBM DB2 İşlevleri
PHP Manual

db2_conn_errormsg

(PECL ibm_db2 >= 1.0.0)

db2_conn_errormsg — Returns the last connection error message and SQLCODE value

Açıklama

string db2_conn_errormsg ([ resource $connection ] )

db2_conn_errormsg() returns an error message and SQLCODE value representing the reason the last database connection attempt failed. As db2_connect() returns FALSE in the event of a failed connection attempt, do not pass any parameters to db2_conn_errormsg() to retrieve the associated error message and SQLCODE value.

If, however, the connection was successful but becomes invalid over time, you can pass the connection parameter to retrieve the associated error message and SQLCODE value for a specific connection.

Değiştirgeler

connection

A connection resource associated with a connection that initially succeeded, but which over time became invalid.

Dönen Değerler

Returns a string containing the error message and SQLCODE value resulting from a failed connection attempt. If there is no error associated with the last connection attempt, db2_conn_errormsg() returns an empty string.

Örnekler

Örnek 1 Retrieving the error message returned by a failed connection attempt

The following example demonstrates how to return an error message and SQLCODE value after deliberately passing invalid parameters to db2_connect().

<?php
$conn = db2_connect('badname', 'baduser', 'badpassword');
if (!$conn) {
    print db2_conn_errormsg();
}
?>

Yukarıdaki örneğin çıktısı:

[IBM][CLI Driver] SQL1013N  The database alias name
or database name "BADNAME" could not be found.  SQLSTATE=42705
 SQLCODE=-1013

Ayrıca Bakınız

  • db2_conn_error() - Returns a string containing the SQLSTATE returned by the last connection attempt
  • db2_connect() - Returns a connection to a database
  • db2_stmt_error() - Returns a string containing the SQLSTATE returned by an SQL statement
  • db2_stmt_errormsg() - Returns a string containing the last SQL statement error message

db2_conn_error
db2_connect
IBM DB2 İşlevleri


Returns a connection to a database

db2_conn_errormsg
db2_cursor_type
IBM DB2 İşlevleri
PHP Manual

db2_connect

(PECL ibm_db2 >= 1.0.0)

db2_connect — Returns a connection to a database

Açıklama

resource db2_connect ( string $database , string $username , string $password [, array $options ] )

Creates a new connection to an IBM DB2 Universal Database, IBM Cloudscape, or Apache Derby database.

Değiştirgeler

database

For a cataloged connection to a database, database represents the database alias in the DB2 client catalog.

For an uncataloged connection to a database, database represents a complete connection string in the following format:

DATABASE=database;HOSTNAME=hostname;PORT=port;PROTOCOL=TCPIP;UID=username;PWD=password;
where the parameters represent the following values:
database

The name of the database.

hostname

The hostname or IP address of the database server.

port

The TCP/IP port on which the database is listening for requests.

username

The username with which you are connecting to the database.

password

The password with which you are connecting to the database.

username

The username with which you are connecting to the database.

For uncataloged connections, you must pass a NULL value or empty string.

password

The password with which you are connecting to the database.

For uncataloged connections, you must pass a NULL value or empty string.

options

An associative array of connection options that affect the behavior of the connection, where valid array keys include:

autocommit

Passing the DB2_AUTOCOMMIT_ON value turns autocommit on for this connection handle.

Passing the DB2_AUTOCOMMIT_OFF value turns autocommit off for this connection handle.

DB2_ATTR_CASE

Passing the DB2_CASE_NATURAL value specifies that column names are returned in natural case.

Passing the DB2_CASE_LOWER value specifies that column names are returned in lower case.

Passing the DB2_CASE_UPPER value specifies that column names are returned in upper case.

CURSOR

Passing the DB2_FORWARD_ONLY value specifies a forward-only cursor for a statement resource. This is the default cursor type and is supported on all database servers.

Passing the DB2_SCROLLABLE value specifies a scrollable cursor for a statement resource. This mode enables random access to rows in a result set, but currently is supported only by IBM DB2 Universal Database.

The following new option is available in ibm_db2 version 1.7.0 and later.

trustedcontext

Passing the DB2_TRUSTED_CONTEXT_ENABLE value turns trusted context on for this connection handle. This parameter cannot be set using db2_set_option().

This key works only if the database is cataloged (even if the database is local), or if you specify the full DSN when you create the connection.

To catalog the database, use following commands:

db2 catalog tcpip node loopback remote <SERVERNAME> server <SERVICENAME>
db2 catalog database <LOCALDBNAME> as <REMOTEDBNAME> at node loopback
db2 "update dbm cfg using svcename <SERVICENAME>"
db2set DB2COMM=TCPIP

The following new i5/OS options are available in ibm_db2 version 1.5.1 and later.

i5_lib

A character value that indicates the default library that will be used for resolving unqualified file references. This is not valid if the connection is using system naming mode.

i5_naming

DB2_I5_NAMING_ON value turns on DB2 UDB CLI iSeries system naming mode. Files are qualified using the slash (/) delimiter. Unqualified files are resolved using the library list for the job.

DB2_I5_NAMING_OFF value turns off DB2 UDB CLI default naming mode, which is SQL naming. Files are qualified using the period (.) delimiter. Unqualified files are resolved using either the default library or the current user ID.

i5_commit

The i5_commit attribute should be set before the db2_connect(). If the value is changed after the connection has been established, and the connection is to a remote data source, the change does not take effect until the next successful db2_connect() for the connection handle.

Bilginize:

The php.ini setting ibm_db2.i5_allow_commit==0 or DB2_I5_TXN_NO_COMMIT is the default, but may be overridden with the i5_commit option.

DB2_I5_TXN_NO_COMMIT - Commitment control is not used.

DB2_I5_TXN_READ_UNCOMMITTED - Dirty reads, nonrepeatable reads, and phantoms are possible.

DB2_I5_TXN_READ_COMMITTED - Dirty reads are not possible. Nonrepeatable reads, and phantoms are possible.

DB2_I5_TXN_REPEATABLE_READ - Dirty reads and nonrepeatable reads are not possible. Phantoms are possible.

DB2_I5_TXN_SERIALIZABLE - Transactions are serializable. Dirty reads, non-repeatable reads, and phantoms are not possible

i5_query_optimize

DB2_FIRST_IO All queries are optimized with the goal of returning the first page of output as fast as possible. This goal works well when the output is controlled by a user who is most likely to cancel the query after viewing the first page of output data. Queries coded with an OPTIMIZE FOR nnn ROWS clause honor the goal specified by the clause.

DB2_ALL_IO All queries are optimized with the goal of running the entire query to completion in the shortest amount of elapsed time. This is a good option when the output of a query is being written to a file or report, or the interface is queuing the output data. Queries coded with an OPTIMIZE FOR nnn ROWS clause honor the goal specified by the clause. This is the default.

i5_dbcs_alloc

DB2_I5_DBCS_ALLOC_ON value turns on DB2 6X allocation scheme for DBCS translation column size growth.

DB2_I5_DBCS_ALLOC_OFF value turns off DB2 6X allocation scheme for DBCS translation column size growth.

Note: php.ini setting ibm_db2.i5_dbcs_alloc==0 or DB2_I5_DBCS_ALLOC_OFF is the default, but may be overridden with the i5_dbcs_alloc option.

i5_date_fmt

DB2_I5_FMT_ISO - The International Organization for Standardization (ISO) date format yyyy-mm-dd is used. This is the default.

DB2_I5_FMT_USA - The United States date format mm/dd/yyyy is used.

DB2_I5_FMT_EUR - The European date format dd.mm.yyyy is used.

DB2_I5_FMT_JIS - The Japanese Industrial Standard date format yyyy-mm-dd is used.

DB2_I5_FMT_MDY - The date format mm/dd/yyyy is used.

DB2_I5_FMT_DMY - The date format dd/mm/yyyy is used.

DB2_I5_FMT_YMD - The date format yy/mm/dd is used.

DB2_I5_FMT_JUL - The Julian date format yy/ddd is used.

DB2_I5_FMT_JOB - The job default is used.

i5_date_sep

DB2_I5_SEP_SLASH - A slash ( / ) is used as the date separator. This is the default.

DB2_I5_SEP_DASH - A dash ( - ) is used as the date separator.

DB2_I5_SEP_PERIOD - A period ( . ) is used as the date separator.

DB2_I5_SEP_COMMA - A comma ( , ) is used as the date separator.

DB2_I5_SEP_BLANK - A blank is used as the date separator.

DB2_I5_SEP_JOB - The job default is used

i5_time_fmt

DB2_I5_FMT_ISO - The International Organization for Standardization (ISO) time format hh.mm.ss is used. This is the default.

DB2_I5_FMT_USA - The United States time format hh:mmxx is used, where xx is AM or PM.

DB2_I5_FMT_EUR - The European time format hh.mm.ss is used.

DB2_I5_FMT_JIS - The Japanese Industrial Standard time format hh:mm:ss is used.

DB2_I5_FMT_HMS - The hh:mm:ss format is used.

i5_time_sep

DB2_I5_SEP_COLON - A colon ( : ) is used as the time separator. This is the default.

DB2_I5_SEP_PERIOD - A period ( . ) is used as the time separator.

DB2_I5_SEP_COMMA - A comma ( , ) is used as the time separator.

DB2_I5_SEP_BLANK - A blank is used as the time separator.

DB2_I5_SEP_JOB - The job default is used.

i5_decimal_sep

DB2_I5_SEP_PERIOD - A period ( . ) is used as the decimal separator. This is the default.

DB2_I5_SEP_COMMA - A comma ( , ) is used as the decimal separator.

DB2_I5_SEP_JOB - The job default is used.

The following new i5/OS option is available in ibm_db2 version 1.8.0 and later.

i5_libl

A character value that indicates the library list that will be used for resolving unqualified file references. Specify the library list elements separated by blanks 'i5_libl'=>"MYLIB YOURLIB ANYLIB".

Bilginize:

i5_libl calls qsys2/qcmdexc('cmd',cmdlen), which is only available in i5/OS V5R4 and later.

Dönen Değerler

Returns a connection handle resource if the connection attempt is successful. If the connection attempt fails, db2_connect() returns FALSE.

Örnekler

Örnek 1 Creating a cataloged connection

Cataloged connections require you to have previously cataloged the target database through the DB2 Command Line Processor (CLP) or DB2 Configuration Assistant.

<?php
$database = 'SAMPLE';
$user = 'db2inst1';
$password = 'ibmdb2';

$conn = db2_connect($database, $user, $password);

if ($conn) {
    echo "Connection succeeded.";
    db2_close($conn);
}
else {
    echo "Connection failed.";
}
?>

Yukarıdaki örneğin çıktısı:

Connection succeeded.

Örnek 2 Creating an uncataloged connection

An uncataloged connection enables you to dynamically connect to a database.

<?php
$database = 'SAMPLE';
$user = 'db2inst1';
$password = 'ibmdb2';
$hostname = 'localhost';
$port = 50000;

$conn_string = "DRIVER={IBM DB2 ODBC DRIVER};DATABASE=$database;" .
  "HOSTNAME=$hostname;PORT=$port;PROTOCOL=TCPIP;UID=$user;PWD=$password;";
$conn = db2_connect($conn_string, '', '');

if ($conn) {
    echo "Connection succeeded.";
    db2_close($conn);
}
else {
    echo "Connection failed.";
}
?>

Yukarıdaki örneğin çıktısı:

Connection succeeded.

Örnek 3 Creating a connection with autocommit off by default

Passing an array of options to db2_connect() enables you to modify the default behavior of the connection handle.

<?php
$database = 'SAMPLE';
$user = 'db2inst1';
$password = 'ibmdb2';
$options = array('autocommit' => DB2_AUTOCOMMIT_OFF);

$conn = db2_connect($database, $user, $password, $options);

if ($conn) {
    echo "Connection succeeded.\n";
    if (db2_autocommit($conn)) {
         echo "Autocommit is on.\n";
    }
    else {
         echo "Autocommit is off.\n";
    }
    db2_close($conn);
}
else {
    echo "Connection failed.";
}
?>

Yukarıdaki örneğin çıktısı:

Connection succeeded.
Autocommit is off.

Örnek 4 i5/OS best performance

To achieve best performance for your i5/OS ibm_db2 1.5.1 PHP application use the default host, userid, and password for your db2_connect().

<?php
  $library = "ADC";
  $i5 = db2_connect("", "", "", array("i5_lib"=>"qsys2"));
  $result = db2_exec($i5,
       "select * from systables where table_schema = '$library'");
  while ($row = db2_fetch_both($result)) {
     echo $row['TABLE_NAME']."</br>";
  }
  db2_close($i5);
?>

Yukarıdaki örneğin çıktısı:

ANIMALS
NAMES
PICTURES

Örnek 5 Using trusted context

The following example shows how to enable trusted context, switch users, and get the current user ID.

<?php

$database = "SAMPLE";
$hostname = "localhost";
$port = 50000;
$authID = "db2inst1";
$auth_pass = "ibmdb2";

$tc_user = "tcuser";
$tc_pass = "tcpassword";

$dsn = "DATABASE=$database;HOSTNAME=$hostname;PORT=$port;
  PROTOCOL=TCPIP;UID=$authID;PWD=$auth_pass;";
$options = array ("trustedcontext" => DB2_TRUSTED_CONTEXT_ENABLE);

$tc_conn = db2_connect($dsn, "", "", $options);
if($tc_conn) {
    echo "Explicit trusted connection succeeded.\n";

    if(db2_get_option($tc_conn, "trustedcontext")) {
        $userBefore = db2_get_option($tc_conn, "trusted_user");

        //Do some work as user 1.

        //Switching to trusted user.
        $parameters = array("trusted_user" => $tc_user,
          "trusted_password" => $tcuser_pass);
        $res = db2_set_option ($tc_conn, $parameters, 1);

        $userAfter = db2_get_option($tc_conn, "trusted_user");
        //Do more work as trusted user.

        if($userBefore != $userAfter) {
            echo "User has been switched." . "\n";
        }
    }

    db2_close($tc_conn);
}
else {
    echo "Explicit trusted connection failed.\n";
}
?>

Yukarıdaki örneğin çıktısı:

Explicit trusted connection succeeded.
User has been switched.

Ayrıca Bakınız

  • db2_close() - Closes a database connection
  • db2_pconnect() - Returns a persistent connection to a database

db2_conn_errormsg
db2_cursor_type
IBM DB2 İşlevleri


Returns the cursor type used by a statement resource

db2_connect
db2_escape_string
IBM DB2 İşlevleri
PHP Manual

db2_cursor_type

(PECL ibm_db2 >= 1.0.0)

db2_cursor_type — Returns the cursor type used by a statement resource

Açıklama

int db2_cursor_type ( resource $stmt )

Returns the cursor type used by a statement resource. Use this to determine if you are working with a forward-only cursor or scrollable cursor.

Değiştirgeler

stmt

A valid statement resource.

Dönen Değerler

Returns either DB2_FORWARD_ONLY if the statement resource uses a forward-only cursor or DB2_SCROLLABLE if the statement resource uses a scrollable cursor.

Ayrıca Bakınız

  • db2_prepare() - Prepares an SQL statement to be executed

db2_connect
db2_escape_string
IBM DB2 İşlevleri


Used to escape certain characters

db2_cursor_type
db2_exec
IBM DB2 İşlevleri
PHP Manual

db2_escape_string

(PECL ibm_db2 >= 1.6.0)

db2_escape_string — Used to escape certain characters

Açıklama

string db2_escape_string ( string $string_literal )

Prepends backslashes to special characters in the string argument.

Değiştirgeler

string_literal

The string that contains special characters that need to be modified. Characters that are prepended with a backslash are \x00, \n, \r, \, ', " and \x1a.

Dönen Değerler

Returns string_literal with the special characters noted above prepended with backslashes.

Örnekler

Örnek 1 A db2_escape_string() example

Result of using the db2_escape_string() function

<?php

$conn = db2_connect($database, $user, $password);

if ($conn) {
    $str[0] = "All characters: \x00 , \n , \r , \ , ' , \" , \x1a .";
    $str[1] = "Backslash (\). Single quote ('). Double quote (\")";
    $str[2] = "The NULL character \0 must be quoted as well";
    $str[3] = "Intersting characters: \x1a , \x00 .";
    $str[4] = "Nothing to quote";
    $str[5] = 200676;
    $str[6] = "";

    foreach( $str as $string ) {
        echo "db2_escape_string: " . db2_escape_string($string). "\n";
    }
}
?>

Yukarıdaki örneğin çıktısı:

db2_escape_string: All characters: \0 , \n , \r , \\ , \' , \" , \Z .
db2_escape_string: Backslash (\\). Single quote (\'). Double quote (\")
db2_escape_string: The NULL character \0 must be quoted as well
db2_escape_string: Intersting characters: \Z , \0 .
db2_escape_string: Nothing to quote
db2_escape_string: 200676
db2_escape_string:

Ayrıca Bakınız

  • db2_prepare() - Prepares an SQL statement to be executed

db2_cursor_type
db2_exec
IBM DB2 İşlevleri


Executes an SQL statement directly

db2_escape_string
db2_execute
IBM DB2 İşlevleri
PHP Manual

db2_exec

(PECL ibm_db2 >= 1.0.0)

db2_exec — Executes an SQL statement directly

Açıklama

resource db2_exec ( resource $connection , string $statement [, array $options ] )

Executes an SQL statement directly.

If you plan to interpolate PHP variables into the SQL statement, understand that this is one of the more common security exposures. Consider calling db2_prepare() to prepare an SQL statement with parameter markers for input values. Then you can call db2_execute() to pass in the input values and avoid SQL injection attacks.

If you plan to repeatedly issue the same SQL statement with different parameters, consider calling db2_prepare() and db2_execute() to enable the database server to reuse its access plan and increase the efficiency of your database access.

Değiştirgeler

connection

A valid database connection resource variable as returned from db2_connect() or db2_pconnect().

statement

An SQL statement. The statement cannot contain any parameter markers.

options

An associative array containing statement options. You can use this parameter to request a scrollable cursor on database servers that support this functionality.

For a description of valid statement options, see db2_set_option().

Dönen Değerler

Returns a statement resource if the SQL statement was issued successfully, or FALSE if the database failed to execute the SQL statement.

Örnekler

Örnek 1 Creating a table with db2_exec()

The following example uses db2_exec() to issue a set of DDL statements in the process of creating a table.

<?php
$conn = db2_connect($database, $user, $password);

// Create the test table
$create = 'CREATE TABLE animals (id INTEGER, breed VARCHAR(32),
    name CHAR(16), weight DECIMAL(7,2))';
$result = db2_exec($conn, $create);
if ($result) {
    print "Successfully created the table.\n";
}

// Populate the test table
$animals = array(
    array(0, 'cat', 'Pook', 3.2),
    array(1, 'dog', 'Peaches', 12.3),
    array(2, 'horse', 'Smarty', 350.0),
    array(3, 'gold fish', 'Bubbles', 0.1),
    array(4, 'budgerigar', 'Gizmo', 0.2),
    array(5, 'goat', 'Rickety Ride', 9.7),
    array(6, 'llama', 'Sweater', 150)
);

foreach ($animals as $animal) {
    $rc = db2_exec($conn, "INSERT INTO animals (id, breed, name, weight)
      VALUES ({$animal[0]}, '{$animal[1]}', '{$animal[2]}', {$animal[3]})");
    if ($rc) {
        print "Insert... ";
    }
}
?>

Yukarıdaki örneğin çıktısı:

Successfully created the table.
Insert... Insert... Insert... Insert... Insert... Insert... Insert...

Örnek 2 Executing a SELECT statement with a scrollable cursor

The following example demonstrates how to request a scrollable cursor for an SQL statement issued by db2_exec().

<?php
$conn = db2_connect($database, $user, $password);
$sql = "SELECT name FROM animals
    WHERE weight < 10.0
    ORDER BY name";
if ($conn) {
    require_once('prepare.inc');
    $stmt = db2_exec($conn, $sql, array('cursor' => DB2_SCROLLABLE));
    while ($row = db2_fetch_array($stmt)) {
        print "$row[0]\n";
    }
}
?>

Yukarıdaki örneğin çıktısı:

Bubbles
Gizmo
Pook
Rickety Ride

Örnek 3 Returning XML data as an SQL ResultSet

The following example demonstrates how to work with documents stored in a XML column using the SAMPLE database. Using some pretty simple SQL/XML, this example returns some of the nodes in a XML document in an SQL ResultSet format that most users are familiar with.

<?php

$conn = db2_connect("SAMPLE", "db2inst1", "ibmdb2");

$query = 'SELECT * FROM XMLTABLE(
    XMLNAMESPACES (DEFAULT \'http://posample.org\'),
    \'db2-fn:xmlcolumn("CUSTOMER.INFO")/customerinfo\'
    COLUMNS
    "CID" VARCHAR (50) PATH \'@Cid\',
    "NAME" VARCHAR (50) PATH \'name\',
    "PHONE" VARCHAR (50) PATH \'phone [ @type = "work"]\'
    ) AS T
    WHERE NAME = \'Kathy Smith\'
    ';
$stmt = db2_exec($conn, $query);

while($row = db2_fetch_object($stmt)){
    printf("$row->CID     $row->NAME     $row->PHONE\n");
}
db2_close($conn);

?>

Yukarıdaki örneğin çıktısı:

1000     Kathy Smith     416-555-1358
1001     Kathy Smith     905-555-7258

Örnek 4 Performing a "JOIN" with XML data

The following example works with documents stored in 2 different XML columns in the SAMPLE database. It creates 2 temporary tables from the XML documents from 2 different columns and returns an SQL ResultSet with information regarding shipping status for the customer.

<?php

$conn = db2_connect("SAMPLE", "db2inst1", "ibmdb2");

$query = '
    SELECT A.CID, A.NAME, A.PHONE, C.PONUM, C.STATUS
    FROM
    XMLTABLE(
    XMLNAMESPACES (DEFAULT \'http://posample.org\'),
    \'db2-fn:xmlcolumn("CUSTOMER.INFO")/customerinfo\'
    COLUMNS
    "CID" BIGINT PATH \'@Cid\',
    "NAME" VARCHAR (50) PATH \'name\',
    "PHONE" VARCHAR (50) PATH \'phone [ @type = "work"]\'
    ) as A,
    PURCHASEORDER AS B,
    XMLTABLE (
    XMLNAMESPACES (DEFAULT \'http://posample.org\'),
    \'db2-fn:xmlcolumn("PURCHASEORDER.PORDER")/PurchaseOrder\'
    COLUMNS
    "PONUM"  BIGINT PATH \'@PoNum\',
    "STATUS" VARCHAR (50) PATH \'@Status\'
    ) as C
    WHERE A.CID = B.CUSTID AND
    B.POID = C.PONUM AND
    A.NAME = \'Kathy Smith\'
';

$stmt = db2_exec($conn, $query);

while($row = db2_fetch_object($stmt)){
    printf("$row->CID     $row->NAME     $row->PHONE     $row->PONUM     $row->STATUS\n");
}

db2_close($conn);

?>

Yukarıdaki örneğin çıktısı:

1001     Kathy Smith     905-555-7258     5002     Shipped

Örnek 5 Returning SQL data as part of a larger XML document

The following example works with a portion of the PRODUCT.DESCRIPTION documents in the SAMPLE database. It creates a XML document containing product description (XML data) and pricing info (SQL data).

<?php

$conn = db2_connect("SAMPLE", "db2inst1", "ibmdb2");

$query = '
SELECT
XMLSERIALIZE(
XMLQUERY(\'
    declare boundary-space strip;
    declare default element namespace "http://posample.org";
    <promoList> {
    for $prod in $doc/product
    where $prod/description/price < 10.00
    order by $prod/description/price ascending
    return(
        <promoitem> {
        $prod,
        <startdate> {$start} </startdate>,
        <enddate> {$end} </enddate>,
        <promoprice> {$promo} </promoprice>
        } </promoitem>
    )
    } </promoList>
\' passing by ref DESCRIPTION AS "doc",
PROMOSTART as "start",
PROMOEND as "end",
PROMOPRICE as "promo"
RETURNING SEQUENCE)
AS CLOB (32000))
AS NEW_PRODUCT_INFO
FROM PRODUCT
WHERE PID = \'100-100-01\'
';

$stmt = db2_exec($conn, $query);

while($row = db2_fetch_array($stmt)){
    printf("$row[0]\n");
}
db2_close($conn);

?>

Yukarıdaki örneğin çıktısı:

<promoList xmlns="http://posample.org">
    <promoitem>
    <product pid="100-100-01">
        <description>
            <name>Snow Shovel, Basic 22 inch</name>
            <details>Basic Snow Shovel, 22 inches wide, straight handle with D-Grip</details>
            <price>9.99</price>
            <weight>1 kg</weight>
        </description>
    </product>
    <startdate>2004-11-19</startdate>
    <enddate>2004-12-19</enddate>
    <promoprice>7.25</promoprice>
    </promoitem>
</promoList>

Ayrıca Bakınız

  • db2_execute() - Executes a prepared SQL statement
  • db2_prepare() - Prepares an SQL statement to be executed

db2_escape_string
db2_execute
IBM DB2 İşlevleri


Executes a prepared SQL statement

db2_exec
db2_fetch_array
IBM DB2 İşlevleri
PHP Manual

db2_execute

(PECL ibm_db2 >= 1.0.0)

db2_execute — Executes a prepared SQL statement

Açıklama

bool db2_execute ( resource $stmt [, array $parameters ] )

db2_execute() executes an SQL statement that was prepared by db2_prepare().

If the SQL statement returns a result set, for example, a SELECT statement or a CALL to a stored procedure that returns one or more result sets, you can retrieve a row as an array from the stmt resource using db2_fetch_assoc(), db2_fetch_both(), or db2_fetch_array(). Alternatively, you can use db2_fetch_row() to move the result set pointer to the next row and fetch a column at a time from that row with db2_result().

Refer to db2_prepare() for a brief discussion of the advantages of using db2_prepare() and db2_execute() rather than db2_exec().

Değiştirgeler

stmt

A prepared statement returned from db2_prepare().

parameters

An array of input parameters matching any parameter markers contained in the prepared statement.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Preparing and executing an SQL statement with parameter markers

The following example prepares an INSERT statement that accepts four parameter markers, then iterates over an array of arrays containing the input values to be passed to db2_execute().

<?php
$pet = array(0, 'cat', 'Pook', 3.2);

$insert = 'INSERT INTO animals (id, breed, name, weight)
    VALUES (?, ?, ?, ?)';

$stmt = db2_prepare($conn, $insert);
if ($stmt) {
    $result = db2_execute($stmt, $pet);
    if ($result) {
        print "Successfully added new pet.";
    }
}
?>

Yukarıdaki örneğin çıktısı:

Successfully added new pet.

Örnek 2 Calling a stored procedure with an OUT parameter

The following example prepares a CALL statement that accepts one parameter marker representing an OUT parameter, binds the PHP variable $my_pets to the parameter using db2_bind_param(), then issues db2_execute() to execute the CALL statement. After the CALL to the stored procedure has been made, the value of $num_pets changes to reflect the value returned by the stored procedure for that OUT parameter.

<?php
$num_pets = 0;
$res = db2_prepare($conn, "CALL count_my_pets(?)");
$rc = db2_bind_param($res, 1, "num_pets", DB2_PARAM_OUT);
$rc = db2_execute($res);
print "I have $num_pets pets!";
?>

Yukarıdaki örneğin çıktısı:

I have 7 pets!

Örnek 3 Returning XML data as an SQL ResultSet

The following example demonstrates how to work with documents stored in a XML column using the SAMPLE database. Using some pretty simple SQL/XML, this example returns some of the nodes in a XML document in an SQL ResultSet format that most users are familiar with.

<?php

$conn = db2_connect("SAMPLE", "db2inst1", "ibmdb2");

$query = 'SELECT * FROM XMLTABLE(
    XMLNAMESPACES (DEFAULT \'http://posample.org\'),
    \'db2-fn:xmlcolumn("CUSTOMER.INFO")/customerinfo\'
    COLUMNS
    "CID" VARCHAR (50) PATH \'@Cid\',
    "NAME" VARCHAR (50) PATH \'name\',
    "PHONE" VARCHAR (50) PATH \'phone [ @type = "work"]\'
    ) AS T
    WHERE NAME = ?
    ';

$stmt = db2_prepare($conn, $query);

$name = 'Kathy Smith';

if ($stmt) {
    db2_bind_param($stmt, 1, "name", DB2_PARAM_IN);
    db2_execute($stmt);

    while($row = db2_fetch_object($stmt)){
    printf("$row->CID     $row->NAME     $row->PHONE\n");
    }
}
db2_close($conn);

?>

Yukarıdaki örneğin çıktısı:

1000     Kathy Smith     416-555-1358
1001     Kathy Smith     905-555-7258

Örnek 4 Performing a "JOIN" with XML data

The following example works with documents stored in 2 different XML columns in the SAMPLE database. It creates 2 temporary tables from the XML documents from 2 different columns and returns an SQL ResultSet with information regarding shipping status for the customer.

<?php

$conn = db2_connect("SAMPLE", "db2inst1", "ibmdb2");

$query = '
SELECT A.CID, A.NAME, A.PHONE, C.PONUM, C.STATUS
FROM
XMLTABLE(
XMLNAMESPACES (DEFAULT \'http://posample.org\'),
\'db2-fn:xmlcolumn("CUSTOMER.INFO")/customerinfo\'
COLUMNS
"CID" BIGINT PATH \'@Cid\',
"NAME" VARCHAR (50) PATH \'name\',
"PHONE" VARCHAR (50) PATH \'phone [ @type = "work"]\'
) as A,
PURCHASEORDER AS B,
XMLTABLE (
XMLNAMESPACES (DEFAULT \'http://posample.org\'),
\'db2-fn:xmlcolumn("PURCHASEORDER.PORDER")/PurchaseOrder\'
COLUMNS
"PONUM"  BIGINT PATH \'@PoNum\',
"STATUS" VARCHAR (50) PATH \'@Status\'
) as C
WHERE A.CID = B.CUSTID AND
    B.POID = C.PONUM AND
    A.NAME = ?
';

$stmt = db2_prepare($conn, $query);

$name = 'Kathy Smith';

if ($stmt) {
    db2_bind_param($stmt, 1, "name", DB2_PARAM_IN);
    db2_execute($stmt);

    while($row = db2_fetch_object($stmt)){
    printf("$row->CID     $row->NAME     $row->PHONE     $row->PONUM     $row->STATUS\n");
    }
}

db2_close($conn);

?>

Yukarıdaki örneğin çıktısı:

1001     Kathy Smith     905-555-7258     5002     Shipped

Örnek 5 Returning SQL data as part of a larger XML document

The following example works with a portion of the PRODUCT.DESCRIPTION documents in the SAMPLE database. It creates a XML document containing product description (XML data) and pricing info (SQL data).

<?php

$conn = db2_connect("SAMPLE", "db2inst1", "ibmdb2");

$query = '
SELECT
XMLSERIALIZE(
XMLQUERY(\'
    declare boundary-space strip;
    declare default element namespace "http://posample.org";
    <promoList> {
    for $prod in $doc/product
    where $prod/description/price < 10.00
    order by $prod/description/price ascending
    return(
        <promoitem> {
        $prod,
        <startdate> {$start} </startdate>,
        <enddate> {$end} </enddate>,
        <promoprice> {$promo} </promoprice>
            } </promoitem>
    )
    } </promoList>
\' passing by ref DESCRIPTION AS "doc",
PROMOSTART as "start",
PROMOEND as "end",
PROMOPRICE as "promo"
RETURNING SEQUENCE)
AS CLOB (32000))
AS NEW_PRODUCT_INFO
FROM PRODUCT
WHERE PID = ?
';

$stmt = db2_prepare($conn, $query);

$pid = "100-100-01";

if ($stmt) {
    db2_bind_param($stmt, 1, "pid", DB2_PARAM_IN);
    db2_execute($stmt);

    while($row = db2_fetch_array($stmt)){
    printf("$row[0]\n");
    }
}

db2_close($conn);

?>

Yukarıdaki örneğin çıktısı:

<promoList xmlns="http://posample.org">
    <promoitem>
    <product pid="100-100-01">
        <description>
            <name>Snow Shovel, Basic 22 inch</name>
            <details>Basic Snow Shovel, 22 inches wide, straight handle with D-Grip</details>
            <price>9.99</price>
            <weight>1 kg</weight>
        </description>
    </product>
    <startdate>2004-11-19</startdate>
    <enddate>2004-12-19</enddate>
    <promoprice>7.25</promoprice>
    </promoitem>
</promoList>

Ayrıca Bakınız

  • db2_exec() - Executes an SQL statement directly
  • db2_fetch_array() - Returns an array, indexed by column position, representing a row in a result set
  • db2_fetch_assoc() - Returns an array, indexed by column name, representing a row in a result set
  • db2_fetch_both() - Returns an array, indexed by both column name and position, representing a row in a result set
  • db2_fetch_row() - Sets the result set pointer to the next row or requested row
  • db2_prepare() - Prepares an SQL statement to be executed
  • db2_result() - Returns a single column from a row in the result set

db2_exec
db2_fetch_array
IBM DB2 İşlevleri


Returns an array, indexed by column position, representing a row in a result set

db2_execute
db2_fetch_assoc
IBM DB2 İşlevleri
PHP Manual

db2_fetch_array

(PECL ibm_db2 >= 1.0.1)

db2_fetch_array — Returns an array, indexed by column position, representing a row in a result set

Açıklama

array db2_fetch_array ( resource $stmt [, int $row_number = -1 ] )

Returns an array, indexed by column position, representing a row in a result set. The columns are 0-indexed.

Değiştirgeler

stmt

A valid stmt resource containing a result set.

row_number

Requests a specific 1-indexed row from the result set. Passing this parameter results in a PHP warning if the result set uses a forward-only cursor.

Dönen Değerler

Returns a 0-indexed array with column values indexed by the column position representing the next or requested row in the result set. Returns FALSE if there are no rows left in the result set, or if the row requested by row_number does not exist in the result set.

Örnekler

Örnek 1 Iterating through a forward-only cursor

If you call db2_fetch_array() without a specific row number, it automatically retrieves the next row in the result set.

<?php

$sql = "SELECT id, name, breed, weight FROM animals ORDER BY breed";
$stmt = db2_prepare($conn, $sql);
$result = db2_execute($stmt);

while ($row = db2_fetch_array($stmt)) {
    printf ("%-5d %-16s %-32s %10s\n",
        $row[0], $row[1], $row[2], $row[3]);
}
?>

Yukarıdaki örneğin çıktısı:

0     Pook             cat                                    3.20
5     Rickety Ride     goat                                   9.70
2     Smarty           horse                                350.00

Örnek 2 Retrieving specific rows with db2_fetch_array() from a scrollable cursor

If your result set uses a scrollable cursor, you can call db2_fetch_array() with a specific row number. The following example retrieves every other row in the result set, starting with the second row.

<?php

$sql = "SELECT id, name, breed, weight FROM animals ORDER BY breed";
$result = db2_exec($stmt, $sql, array('cursor' => DB2_SCROLLABLE));

$i=2;
while ($row = db2_fetch_array($result, $i)) {
    printf ("%-5d %-16s %-32s %10s\n",
        $row[0], $row[1], $row[2], $row[3]);
    $i = $i + 2;
}
?>

Yukarıdaki örneğin çıktısı:

0     Pook             cat                                    3.20
5     Rickety Ride     goat                                   9.70
2     Smarty           horse                                350.00

Ayrıca Bakınız

  • db2_fetch_assoc() - Returns an array, indexed by column name, representing a row in a result set
  • db2_fetch_both() - Returns an array, indexed by both column name and position, representing a row in a result set
  • db2_fetch_object() - Returns an object with properties representing columns in the fetched row
  • db2_fetch_row() - Sets the result set pointer to the next row or requested row
  • db2_result() - Returns a single column from a row in the result set

db2_execute
db2_fetch_assoc
IBM DB2 İşlevleri


Returns an array, indexed by column name, representing a row in a result set

db2_fetch_array
db2_fetch_both
IBM DB2 İşlevleri
PHP Manual

db2_fetch_assoc

(PECL ibm_db2 >= 1.0.0)

db2_fetch_assoc — Returns an array, indexed by column name, representing a row in a result set

Açıklama

array db2_fetch_assoc ( resource $stmt [, int $row_number = -1 ] )

Returns an array, indexed by column name, representing a row in a result set.

Değiştirgeler

stmt

A valid stmt resource containing a result set.

row_number

Requests a specific 1-indexed row from the result set. Passing this parameter results in a PHP warning if the result set uses a forward-only cursor.

Dönen Değerler

Returns an associative array with column values indexed by the column name representing the next or requested row in the result set. Returns FALSE if there are no rows left in the result set, or if the row requested by row_number does not exist in the result set.

Örnekler

Örnek 1 Iterating through a forward-only cursor

If you call db2_fetch_assoc() without a specific row number, it automatically retrieves the next row in the result set.

<?php

$sql = "SELECT id, name, breed, weight FROM animals ORDER BY breed";
$stmt = db2_prepare($conn, $sql);
$result = db2_execute($stmt);

while ($row = db2_fetch_assoc($stmt)) {
    printf ("%-5d %-16s %-32s %10s\n",
        $row['ID'], $row['NAME'], $row['BREED'], $row['WEIGHT']);
}
?>

Yukarıdaki örneğin çıktısı:

0     Pook             cat                                    3.20
5     Rickety Ride     goat                                   9.70
2     Smarty           horse                                350.00

Örnek 2 Retrieving specific rows with db2_fetch_assoc() from a scrollable cursor

If your result set uses a scrollable cursor, you can call db2_fetch_assoc() with a specific row number. The following example retrieves every other row in the result set, starting with the second row.

<?php

$sql = "SELECT id, name, breed, weight FROM animals ORDER BY breed";
$result = db2_exec($stmt, $sql, array('cursor' => DB2_SCROLLABLE));

$i=2;
while ($row = db2_fetch_assoc($result, $i)) {
    printf ("%-5d %-16s %-32s %10s\n",
        $row['ID'], $row['NAME'], $row['BREED'], $row['WEIGHT']);
    $i = $i + 2;
}
?>

Yukarıdaki örneğin çıktısı:

0     Pook             cat                                    3.20
5     Rickety Ride     goat                                   9.70
2     Smarty           horse                                350.00

Ayrıca Bakınız

  • db2_fetch_array() - Returns an array, indexed by column position, representing a row in a result set
  • db2_fetch_both() - Returns an array, indexed by both column name and position, representing a row in a result set
  • db2_fetch_object() - Returns an object with properties representing columns in the fetched row
  • db2_fetch_row() - Sets the result set pointer to the next row or requested row
  • db2_result() - Returns a single column from a row in the result set

db2_fetch_array
db2_fetch_both
IBM DB2 İşlevleri


Returns an array, indexed by both column name and position, representing a row in a result set

db2_fetch_assoc
db2_fetch_object
IBM DB2 İşlevleri
PHP Manual

db2_fetch_both

(PECL ibm_db2 >= 1.0.0)

db2_fetch_both — Returns an array, indexed by both column name and position, representing a row in a result set

Açıklama

array db2_fetch_both ( resource $stmt [, int $row_number = -1 ] )

Returns an array, indexed by both column name and position, representing a
row in a result set. Note that the row returned by
db2_fetch_both() requires more memory than the
single-indexed arrays returned by db2_fetch_assoc() or
db2_fetch_array().

Değiştirgeler

stmt

A valid stmt resource containing a result set.

row_number

Requests a specific 1-indexed row from the result set. Passing this parameter results in a PHP warning if the result set uses a forward-only cursor.

Dönen Değerler

Returns an associative array with column values indexed by both the column name and 0-indexed column number. The array represents the next or requested row in the result set. Returns FALSE if there are no rows left in the result set, or if the row requested by row_number does not exist in the result set.

Örnekler

Örnek 1 Iterating through a forward-only cursor

If you call db2_fetch_both() without a specific row number, it automatically retrieves the next row in the result set. The following example accesses columns in the returned array by both column name and by numeric index.

<?php

$sql = "SELECT id, name, breed, weight FROM animals ORDER BY breed";
$stmt = db2_prepare($conn, $sql);
$result = db2_execute($stmt);

while ($row = db2_fetch_both($stmt)) {
    printf ("%-5d %-16s %-32s %10s\n",
        $row['ID'], $row[0], $row['BREED'], $row[3]);
}
?>

Yukarıdaki örneğin çıktısı:

0     Pook             cat                                    3.20
5     Rickety Ride     goat                                   9.70
2     Smarty           horse                                350.00

Örnek 2 Retrieving specific rows with db2_fetch_both() from a scrollable cursor

If your result set uses a scrollable cursor, you can call db2_fetch_both() with a specific row number. The following example retrieves every other row in the result set, starting with the second row.

<?php

$sql = "SELECT id, name, breed, weight FROM animals ORDER BY breed";
$result = db2_exec($stmt, $sql, array('cursor' => DB2_SCROLLABLE));

$i=2;
while ($row = db2_fetch_both($result, $i)) {
    printf ("%-5d %-16s %-32s %10s\n",
        $row[0], $row['NAME'], $row[2], $row['WEIGHT']);
    $i = $i + 2;
}
?>

Yukarıdaki örneğin çıktısı:

0     Pook             cat                                    3.20
5     Rickety Ride     goat                                   9.70
2     Smarty           horse                                350.00

Ayrıca Bakınız

  • db2_fetch_array() - Returns an array, indexed by column position, representing a row in a result set
  • db2_fetch_assoc() - Returns an array, indexed by column name, representing a row in a result set
  • db2_fetch_object() - Returns an object with properties representing columns in the fetched row
  • db2_fetch_row() - Sets the result set pointer to the next row or requested row
  • db2_result() - Returns a single column from a row in the result set

db2_fetch_assoc
db2_fetch_object
IBM DB2 İşlevleri


Returns an object with properties representing columns in the fetched row

db2_fetch_both
db2_fetch_row
IBM DB2 İşlevleri
PHP Manual

db2_fetch_object

(PECL ibm_db2 >= 1.0.0)

db2_fetch_object — Returns an object with properties representing columns in the fetched row

Açıklama

object db2_fetch_object ( resource $stmt [, int $row_number = -1 ] )

Returns an object in which each property represents a column returned in the row fetched from a result set.

Değiştirgeler

stmt

A valid stmt resource containing a result set.

row_number

Requests a specific 1-indexed row from the result set. Passing this parameter results in a PHP warning if the result set uses a forward-only cursor.

Dönen Değerler

Returns an object representing a single row in the result set. The properties of the object map to the names of the columns in the result set.

The IBM DB2, Cloudscape, and Apache Derby database servers typically fold column names to upper-case, so the object properties will reflect that case.

If your SELECT statement calls a scalar function to modify the value of a column, the database servers return the column number as the name of the column in the result set. If you prefer a more descriptive column name and object property, you can use the AS clause to assign a name to the column in the result set.

Returns FALSE if no row was retrieved.

Örnekler

Örnek 1 A db2_fetch_object() example

The following example issues a SELECT statement with a scalar function, RTRIM, that removes whitespace from the end of the column. Rather than creating an object with the properties "BREED" and "2", we use the AS clause in the SELECT statement to assign the name "name" to the modified column. The database server folds the column names to upper-case, resulting in an object with the properties "BREED" and "NAME".

<?php
$conn = db2_connect($database, $user, $password);

$sql = "SELECT breed, RTRIM(name) AS name
    FROM animals
    WHERE id = ?";

if ($conn) {
    $stmt = db2_prepare($conn, $sql);
    db2_execute($stmt, array(0));

    while ($pet = db2_fetch_object($stmt)) {
        echo "Come here, {$pet->NAME}, my little {$pet->BREED}!";
    }
    db2_close($conn);
}
?>

Yukarıdaki örneğin çıktısı:

Come here, Pook, my little cat!

Ayrıca Bakınız

  • db2_fetch_array() - Returns an array, indexed by column position, representing a row in a result set
  • db2_fetch_assoc() - Returns an array, indexed by column name, representing a row in a result set
  • db2_fetch_both() - Returns an array, indexed by both column name and position, representing a row in a result set
  • db2_fetch_row() - Sets the result set pointer to the next row or requested row
  • db2_result() - Returns a single column from a row in the result set

db2_fetch_both
db2_fetch_row
IBM DB2 İşlevleri


Sets the result set pointer to the next row or requested row

db2_fetch_object
db2_field_display_size
IBM DB2 İşlevleri
PHP Manual

db2_fetch_row

(PECL ibm_db2 >= 1.0.0)

db2_fetch_row — Sets the result set pointer to the next row or requested row

Açıklama

bool db2_fetch_row ( resource $stmt [, int $row_number ] )

Use db2_fetch_row() to iterate through a result set, or to point to a specific row in a result set if you requested a scrollable cursor.

To retrieve individual fields from the result set, call the db2_result() function.

Rather than calling db2_fetch_row() and db2_result(), most applications will call one of db2_fetch_assoc(), db2_fetch_both(), or db2_fetch_array() to advance the result set pointer and return a complete row as an array.

Değiştirgeler

stmt

A valid stmt resource.

row_number

With scrollable cursors, you can request a specific row number in the result set. Row numbering is 1-indexed.

Dönen Değerler

Returns TRUE if the requested row exists in the result set. Returns FALSE if the requested row does not exist in the result set.

Örnekler

Örnek 1 Iterating through a result set

The following example demonstrates how to iterate through a result set with db2_fetch_row() and retrieve columns from the result set with db2_result().

<?php
$sql = 'SELECT name, breed FROM animals WHERE weight < ?';
$stmt = db2_prepare($conn, $sql);
db2_execute($stmt, array(10));
while (db2_fetch_row($stmt)) {
    $name = db2_result($stmt, 0);
    $breed = db2_result($stmt, 1);
    print "$name $breed";
}
?>

Yukarıdaki örneğin çıktısı:

cat Pook
gold fish Bubbles
budgerigar Gizmo
goat Rickety Ride

Örnek 2 i5/OS recommended alternatives to db2_fetch_row/db2_result

On i5/OS it is recommended that you use db2_fetch_both(), db2_fetch_array(), or db2_fetch_object() over db2_fetch_row()/db2_result(). In general db2_fetch_row()/db2_result() have more issues with various column types in EBCIDIC to ASCII translation, including possible truncation in DBCS applications. You may also find the performance of db2_fetch_both(), db2_fetch_array(), and db2_fetch_object() to be superior to db2_fetch_row()/db2_result().

<?php
  $conn = db2_connect("","","");
  $sql = 'SELECT SPECIFIC_SCHEMA, SPECIFIC_NAME, ROUTINE_SCHEMA, ROUTINE_NAME, ROUTINE_TYPE, ROUTINE_CREATED, ROUTINE_BODY, IN_PARMS, OUT_PARMS, INOUT_PARMS, PARAMETER_STYLE, EXTERNAL_NAME, EXTERNAL_LANGUAGE FROM QSYS2.SYSROUTINES FETCH FIRST 2 ROWS ONLY';
  $stmt = db2_exec($conn, $sql, array('cursor' => DB2_SCROLLABLE));
  while ($row = db2_fetch_both($stmt)){
    echo "<br>db2_fetch_both {$row['SPECIFIC_NAME']} {$row['ROUTINE_CREATED']} {$row[5]}";
  }
  $stmt = db2_exec($conn, $sql, array('cursor' => DB2_SCROLLABLE));
  while ($row = db2_fetch_array($stmt)){
    echo "<br>db2_fetch_array {$row[1]}  {$row[5]}";
  }
  $stmt = db2_exec($conn, $sql, array('cursor' => DB2_SCROLLABLE));
  while ($row = db2_fetch_object($stmt)){
    echo "<br>db2_fetch_object {$row->SPECIFIC_NAME} {$row->ROUTINE_CREATED}";
  }
  db2_close($conn);
?>

Yukarıdaki örneğin çıktısı:

db2_fetch_both MATCH_ANIMAL 2006-08-25-17.10.23.775000 2006-08-25-17.10.23.775000
db2_fetch_both MULTIRESULTS 2006-10-17-10.11.05.308000 2006-10-17-10.11.05.308000
db2_fetch_array MATCH_ANIMAL 2006-08-25-17.10.23.775000
db2_fetch_array MULTIRESULTS 2006-10-17-10.11.05.308000
db2_fetch_object MATCH_ANIMAL 2006-08-25-17.10.23.775000
db2_fetch_object MULTIRESULTS 2006-10-17-10.11.05.308000

Ayrıca Bakınız

  • db2_fetch_array() - Returns an array, indexed by column position, representing a row in a result set
  • db2_fetch_assoc() - Returns an array, indexed by column name, representing a row in a result set
  • db2_fetch_both() - Returns an array, indexed by both column name and position, representing a row in a result set
  • db2_fetch_object() - Returns an object with properties representing columns in the fetched row
  • db2_result() - Returns a single column from a row in the result set

db2_fetch_object
db2_field_display_size
IBM DB2 İşlevleri


Returns the maximum number of bytes required to display a column

db2_fetch_row
db2_field_name
IBM DB2 İşlevleri
PHP Manual

db2_field_display_size

(PECL ibm_db2 >= 1.0.0)

db2_field_display_size — Returns the maximum number of bytes required to display a column

Açıklama

int db2_field_display_size ( resource $stmt , mixed $column )

Returns the maximum number of bytes required to display a column in a result set.

Değiştirgeler

stmt

Specifies a statement resource containing a result set.

column

Specifies the column in the result set. This can either be an integer representing the 0-indexed position of the column, or a string containing the name of the column.

Dönen Değerler

Returns an integer value with the maximum number of bytes required to display the specified column. If the column does not exist in the result set, db2_field_display_size() returns FALSE.

Ayrıca Bakınız

  • db2_field_name() - Returns the name of the column in the result set
  • db2_field_num() - Returns the position of the named column in a result set
  • db2_field_precision() - Returns the precision of the indicated column in a result set
  • db2_field_scale() - Returns the scale of the indicated column in a result set
  • db2_field_type() - Returns the data type of the indicated column in a result set
  • db2_field_width() - Returns the width of the current value of the indicated column in a result set

db2_fetch_row
db2_field_name
IBM DB2 İşlevleri


Returns the name of the column in the result set

db2_field_display_size
db2_field_num
IBM DB2 İşlevleri
PHP Manual

db2_field_name

(PECL ibm_db2 >= 1.0.0)

db2_field_name — Returns the name of the column in the result set

Açıklama

string db2_field_name ( resource $stmt , mixed $column )

Returns the name of the specified column in the result set.

Değiştirgeler

stmt

Specifies a statement resource containing a result set.

column

Specifies the column in the result set. This can either be an integer representing the 0-indexed position of the column, or a string containing the name of the column.

Dönen Değerler

Returns a string containing the name of the specified column. If the specified column does not exist in the result set, db2_field_name() returns FALSE.

Ayrıca Bakınız

  • db2_field_display_size() - Returns the maximum number of bytes required to display a column
  • db2_field_num() - Returns the position of the named column in a result set
  • db2_field_precision() - Returns the precision of the indicated column in a result set
  • db2_field_scale() - Returns the scale of the indicated column in a result set
  • db2_field_type() - Returns the data type of the indicated column in a result set
  • db2_field_width() - Returns the width of the current value of the indicated column in a result set

db2_field_display_size
db2_field_num
IBM DB2 İşlevleri


Returns the position of the named column in a result set

db2_field_name
db2_field_precision
IBM DB2 İşlevleri
PHP Manual

db2_field_num

(PECL ibm_db2 >= 1.0.0)

db2_field_num — Returns the position of the named column in a result set

Açıklama

int db2_field_num ( resource $stmt , mixed $column )

Returns the position of the named column in a result set.

Değiştirgeler

stmt

Specifies a statement resource containing a result set.

column

Specifies the column in the result set. This can either be an integer representing the 0-indexed position of the column, or a string containing the name of the column.

Dönen Değerler

Returns an integer containing the 0-indexed position of the named column in the result set. If the specified column does not exist in the result set, db2_field_num() returns FALSE.

Ayrıca Bakınız

  • db2_field_display_size() - Returns the maximum number of bytes required to display a column
  • db2_field_name() - Returns the name of the column in the result set
  • db2_field_precision() - Returns the precision of the indicated column in a result set
  • db2_field_scale() - Returns the scale of the indicated column in a result set
  • db2_field_type() - Returns the data type of the indicated column in a result set
  • db2_field_width() - Returns the width of the current value of the indicated column in a result set

db2_field_name
db2_field_precision
IBM DB2 İşlevleri


Returns the precision of the indicated column in a result set

db2_field_num
db2_field_scale
IBM DB2 İşlevleri
PHP Manual

db2_field_precision

(PECL ibm_db2 >= 1.0.0)

db2_field_precision — Returns the precision of the indicated column in a result set

Açıklama

int db2_field_precision ( resource $stmt , mixed $column )

Returns the precision of the indicated column in a result set.

Değiştirgeler

stmt

Specifies a statement resource containing a result set.

column

Specifies the column in the result set. This can either be an integer representing the 0-indexed position of the column, or a string containing the name of the column.

Dönen Değerler

Returns an integer containing the precision of the specified column. If the specified column does not exist in the result set, db2_field_precision() returns FALSE.

Ayrıca Bakınız

  • db2_field_display_size() - Returns the maximum number of bytes required to display a column
  • db2_field_name() - Returns the name of the column in the result set
  • db2_field_num() - Returns the position of the named column in a result set
  • db2_field_scale() - Returns the scale of the indicated column in a result set
  • db2_field_type() - Returns the data type of the indicated column in a result set
  • db2_field_width() - Returns the width of the current value of the indicated column in a result set

db2_field_num
db2_field_scale
IBM DB2 İşlevleri


Returns the scale of the indicated column in a result set

db2_field_precision
db2_field_type
IBM DB2 İşlevleri
PHP Manual

db2_field_scale

(PECL ibm_db2 >= 1.0.0)

db2_field_scale — Returns the scale of the indicated column in a result set

Açıklama

int db2_field_scale ( resource $stmt , mixed $column )

Returns the scale of the indicated column in a result set.

Değiştirgeler

stmt

Specifies a statement resource containing a result set.

column

Specifies the column in the result set. This can either be an integer representing the 0-indexed position of the column, or a string containing the name of the column.

Dönen Değerler

Returns an integer containing the scale of the specified column. If the specified column does not exist in the result set, db2_field_scale() returns FALSE.

Ayrıca Bakınız

  • db2_field_display_size() - Returns the maximum number of bytes required to display a column
  • db2_field_name() - Returns the name of the column in the result set
  • db2_field_num() - Returns the position of the named column in a result set
  • db2_field_precision() - Returns the precision of the indicated column in a result set
  • db2_field_type() - Returns the data type of the indicated column in a result set
  • db2_field_width() - Returns the width of the current value of the indicated column in a result set

db2_field_precision
db2_field_type
IBM DB2 İşlevleri


Returns the data type of the indicated column in a result set

db2_field_scale
db2_field_width
IBM DB2 İşlevleri
PHP Manual

db2_field_type

(PECL ibm_db2 >= 1.0.0)

db2_field_type — Returns the data type of the indicated column in a result set

Açıklama

string db2_field_type ( resource $stmt , mixed $column )

Returns the data type of the indicated column in a result set.

Değiştirgeler

stmt

Specifies a statement resource containing a result set.

column

Specifies the column in the result set. This can either be an integer representing the 0-indexed position of the column, or a string containing the name of the column.

Dönen Değerler

Returns a string containing the defined data type of the specified column. If the specified column does not exist in the result set, db2_field_type() returns FALSE.

Ayrıca Bakınız

  • db2_field_display_size() - Returns the maximum number of bytes required to display a column
  • db2_field_name() - Returns the name of the column in the result set
  • db2_field_num() - Returns the position of the named column in a result set
  • db2_field_precision() - Returns the precision of the indicated column in a result set
  • db2_field_scale() - Returns the scale of the indicated column in a result set
  • db2_field_width() - Returns the width of the current value of the indicated column in a result set

db2_field_scale
db2_field_width
IBM DB2 İşlevleri


Returns the width of the current value of the indicated column in a result set

db2_field_type
db2_foreign_keys
IBM DB2 İşlevleri
PHP Manual

db2_field_width

(PECL ibm_db2 >= 1.0.0)

db2_field_width — Returns the width of the current value of the indicated column in a result set

Açıklama

int db2_field_width ( resource $stmt , mixed $column )

Returns the width of the current value of the indicated column in a result set. This is the maximum width of the column for a fixed-length data type, or the actual width of the column for a variable-length data type.

Değiştirgeler

stmt

Specifies a statement resource containing a result set.

column

Specifies the column in the result set. This can either be an integer representing the 0-indexed position of the column, or a string containing the name of the column.

Dönen Değerler

Returns an integer containing the width of the specified character or binary data type column in a result set. If the specified column does not exist in the result set, db2_field_width() returns FALSE.

Ayrıca Bakınız

  • db2_field_display_size() - Returns the maximum number of bytes required to display a column
  • db2_field_name() - Returns the name of the column in the result set
  • db2_field_num() - Returns the position of the named column in a result set
  • db2_field_precision() - Returns the precision of the indicated column in a result set
  • db2_field_scale() - Returns the scale of the indicated column in a result set
  • db2_field_type() - Returns the data type of the indicated column in a result set

db2_field_type
db2_foreign_keys
IBM DB2 İşlevleri


Returns a result set listing the foreign keys for a table

db2_field_width
db2_free_result
IBM DB2 İşlevleri
PHP Manual

db2_foreign_keys

(PECL ibm_db2 >= 1.0.0)

db2_foreign_keys — Returns a result set listing the foreign keys for a table

Açıklama

resource db2_foreign_keys ( resource $connection , string $qualifier , string $schema , string $table-name )

Returns a result set listing the foreign keys for a table.

Değiştirgeler

connection

A valid connection to an IBM DB2, Cloudscape, or Apache Derby database.

qualifier

A qualifier for DB2 databases running on OS/390 or z/OS servers. For other databases, pass NULL or an empty string.

schema

The schema which contains the tables. If schema is NULL, db2_foreign_keys() matches the schema for the current connection.

table-name

The name of the table.

Dönen Değerler

Returns a statement resource with a result set containing rows describing the foreign keys for the specified table. The result set is composed of the following columns:

Column name | Description
PKTABLE_CAT | Name of the catalog for the table containing the primary key. The value is NULL if this table does not have catalogs.
PKTABLE_SCHEM | Name of the schema for the table containing the primary key.
PKTABLE_NAME | Name of the table containing the primary key.
PKCOLUMN_NAME | Name of the column containing the primary key.
FKTABLE_CAT | Name of the catalog for the table containing the foreign key. The value is NULL if this table does not have catalogs.
FKTABLE_SCHEM | Name of the schema for the table containing the foreign key.
FKTABLE_NAME | Name of the table containing the foreign key.
FKCOLUMN_NAME | Name of the column containing the foreign key.
KEY_SEQ | 1-indexed position of the column in the key.
UPDATE_RULE | Integer value representing the action applied to the foreign key when the SQL operation is UPDATE.
DELETE_RULE | Integer value representing the action applied to the foreign key when the SQL operation is DELETE.
FK_NAME | The name of the foreign key.
PK_NAME | The name of the primary key.
DEFERRABILITY | An integer value representing whether the foreign key deferrability is SQL_INITIALLY_DEFERRED, SQL_INITIALLY_IMMEDIATE, or SQL_NOT_DEFERRABLE.

Ayrıca Bakınız

  • db2_column_privileges() - Returns a result set listing the columns and associated privileges for a table
  • db2_columns() - Returns a result set listing the columns and associated metadata for a table
  • db2_primary_keys() - Returns a result set listing primary keys for a table
  • db2_procedure_columns() - Returns a result set listing stored procedure parameters
  • db2_procedures() - Returns a result set listing the stored procedures registered in a database
  • db2_special_columns() - Returns a result set listing the unique row identifier columns for a table
  • db2_statistics() - Returns a result set listing the index and statistics for a table
  • db2_table_privileges() - Returns a result set listing the tables and associated privileges in a database
  • db2_tables() - Returns a result set listing the tables and associated metadata in a database

db2_field_width
db2_free_result
IBM DB2 İşlevleri


Frees resources associated with a result set

db2_foreign_keys
db2_free_stmt
IBM DB2 İşlevleri
PHP Manual

db2_free_result

(PECL ibm_db2 >= 1.0.0)

db2_free_result — Frees resources associated with a result set

Açıklama

bool db2_free_result ( resource $stmt )

Frees the system and database resources that are associated with a result set. These resources are freed implicitly when a script finishes, but you can call db2_free_result() to explicitly free the result set resources before the end of the script.

Değiştirgeler

stmt

A valid statement resource.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • db2_free_stmt() - Frees resources associated with the indicated statement resource

db2_foreign_keys
db2_free_stmt
IBM DB2 İşlevleri


Frees resources associated with the indicated statement resource

db2_free_result
db2_get_option
IBM DB2 İşlevleri
PHP Manual

db2_free_stmt

(PECL ibm_db2 >= 1.0.0)

db2_free_stmt — Frees resources associated with the indicated statement resource

Açıklama

bool db2_free_stmt ( resource $stmt )

Frees the system and database resources that are associated with a statement resource. These resources are freed implicitly when a script finishes, but you can call db2_free_stmt() to explicitly free the statement resources before the end of the script.

Değiştirgeler

stmt

A valid statement resource.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • db2_free_result() - Frees resources associated with a result set

db2_free_result
db2_get_option
IBM DB2 İşlevleri


Retrieves an option value for a statement resource or a connection resource

db2_free_stmt
db2_last_insert_id
IBM DB2 İşlevleri
PHP Manual

db2_get_option

(PECL ibm_db2 >= 1.6.0)

db2_get_option — Retrieves an option value for a statement resource or a connection resource

Açıklama

string db2_get_option ( resource $resource , string $option )

Retrieves the value of a specified option value for a statement resource or a connection resource.

Değiştirgeler

resource

A valid statement resource as returned from db2_prepare() or a valid connection resource as returned from db2_connect() or db2_pconnect().

option

A valid statement or connection options. The following new options are available as of ibm_db2 version 1.6.0. They provide useful tracking information that can be set during execution with db2_get_option().

Bilginize:

Prior versions of ibm_db2 do not support these new options.

When the value in each option is being set, some servers might not handle the entire length provided and might truncate the value.

To ensure that the data specified in each option is converted correctly when transmitted to a host system, use only the characters A through Z, 0 through 9, and the underscore (_) or period (.).

userid

SQL_ATTR_INFO_USERID - A pointer to a null-terminated character string used to identify the client user ID sent to the host database server when using DB2 Connect.

Bilginize:

DB2 for z/OS and OS/390 servers support up to a length of 16 characters. This user-id is not to be confused with the authentication user-id, it is for identification purposes only and is not used for any authorization.

acctstr

SQL_ATTR_INFO_ACCTSTR - A pointer to a null-terminated character string used to identify the client accounting string sent to the host database server when using DB2 Connect.

Bilginize:

DB2 for z/OS and OS/390 servers support up to a length of 200 characters.

applname

SQL_ATTR_INFO_APPLNAME - A pointer to a null-terminated character string used to identify the client application name sent to the host database server when using DB2 Connect.

Bilginize:

DB2 for z/OS and OS/390 servers support up to a length of 32 characters.

wrkstnname

SQL_ATTR_INFO_WRKSTNNAME - A pointer to a null-terminated character string used to identify the client workstation name sent to the host database server when using DB2 Connect.

Bilginize:

DB2 for z/OS and OS/390 servers support up to a length of 18 characters.

The following table specifies which options are compatible with the available resource types:

Resource-Parameter Matrix
Key | Value | Resource Type
 |  | Connection | Statement | Result Set
userid | SQL_ATTR_INFO_USERID | X | X | -
acctstr | SQL_ATTR_INFO_ACCTSTR | X | X | -
applname | SQL_ATTR_INFO_APPLNAME | X | X | -
wrkstnname | SQL_ATTR_INFO_WRKSTNNAME | X | X | -

Dönen Değerler

Returns the current setting of the connection attribute provided on success başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Setting and retrieving parameters through a connection resource

<?php
/* Database Connection Parameters */
$database = 'SAMPLE';
$user     = 'db2inst1';
$password = 'ibmdb2';

/* Obtain Connection Resource */
$conn = db2_connect($database, $user, $password);

echo "Client attributes passed through connection string:\n";

/* Create the associative options array with valid key-value pairs */
/* Assign the attributes through connection string */
/* Access the options specified */
$options1 = array('userid' => 'db2inst1');
$conn1 = db2_connect($database, $user, $password, $options1);
$val = db2_get_option($conn1, 'userid');
echo $val . "\n";

$options2 = array('acctstr' => 'account');
$conn2 = db2_connect($database, $user, $password, $options2);
$val = db2_get_option($conn2, 'acctstr');
echo $val . "\n";

$options3 = array('applname' => 'myapp');
$conn3 = db2_connect($database, $user, $password, $options3);
$val = db2_get_option($conn3, 'applname');
echo $val . "\n";

$options4 = array('wrkstnname' => 'workstation');
$conn4 = db2_connect($database, $user, $password, $options4);
$val = db2_get_option($conn4, 'wrkstnname');
echo $val . "\n";

echo "Client attributes passed post-connection:\n";

/* Create the associative options array with valid key-value pairs */
/* Assign the attributes after a connection is made */
/* Access the options specified */
$options5 = array('userid' => 'db2inst1');
$conn5 = db2_connect($database, $user, $password);
$rc = db2_set_option($conn5, $options5, 1);
$val = db2_get_option($conn5, 'userid');
echo $val . "\n";

$options6 = array('acctstr' => 'account');
$conn6 = db2_connect($database, $user, $password);
$rc = db2_set_option($conn6, $options6, 1);
$val = db2_get_option($conn6, 'acctstr');
echo $val . "\n";

$options7 = array('applname' => 'myapp');
$conn7 = db2_connect($database, $user, $password);
$rc = db2_set_option($conn7, $options7, 1);
$val = db2_get_option($conn7, 'applname');
echo $val . "\n";

$options8 = array('wrkstnname' => 'workstation');
$conn8 = db2_connect($database, $user, $password);
$rc = db2_set_option($conn8, $options8, 1);
$val = db2_get_option($conn8, 'wrkstnname');
echo $val . "\n";
?>

Yukarıdaki örneğin çıktısı:

Client attributes passed through connection string:
db2inst1
account
myapp
workstation
Client attributes passed post-connection:
db2inst1
account
myapp
workstation

Ayrıca Bakınız

  • db2_connect() - Returns a connection to a database
  • db2_cursor_type() - Returns the cursor type used by a statement resource
  • db2_exec() - Executes an SQL statement directly
  • db2_set_option() - Set options for connection or statement resources
  • db2_pconnect() - Returns a persistent connection to a database
  • db2_prepare() - Prepares an SQL statement to be executed

db2_free_stmt
db2_last_insert_id
IBM DB2 İşlevleri


Returns the auto generated ID of the last insert query that successfully executed on this connection

db2_get_option
db2_lob_read
IBM DB2 İşlevleri
PHP Manual

db2_last_insert_id

(PECL ibm_db2 >= 1.7.1)

db2_last_insert_id — Returns the auto generated ID of the last insert query that successfully executed on this connection

Açıklama

string db2_last_insert_id ( resource $resource )

Returns the auto generated ID of the last insert query that successfully executed on this connection.

The result of this function is not affected by any of the following:

  • A single row INSERT statement with a VALUES clause for a table without an identity column.

  • A multiple row INSERT statement with a VALUES clause.

  • An INSERT statement with a fullselect.

  • A ROLLBACK TO SAVEPOINT statement.

Değiştirgeler

resource

A valid connection resource as returned from db2_connect() or db2_pconnect(). The value of this parameter cannot be a statement resource or result set resource.

Dönen Değerler

Returns the auto generated ID of last insert query that successfully executed on this connection.

Örnekler

Örnek 1 A db2_last_insert_id() example

The following example shows how to return the auto generated ID of last insert query that successfully executed on this connection.

<?php

$database = "SAMPLE";
$user = "db2inst1";
$password = "ibmdb2";

$conn = db2_connect($database, $user, $password);
if($conn) {
    $createTable = "CREATE TABLE lastInsertID
      (id integer GENERATED BY DEFAULT AS IDENTITY, name varchar(20))";
    $insertTable = "INSERT INTO lastInsertID (name) VALUES ('Temp Name')";

    $stmt = @db2_exec($conn, $createTable);

    /* Checking for single row inserted. */
    $stmt = db2_exec($conn, $insertTable);
    $ret =  db2_last_insert_id($conn);
    if($ret) {
        echo "Last Insert ID is : " . $ret . "\n";
    } else {
        echo "No Last insert ID.\n";
    }

    db2_close($conn);
}
else {
    echo "Connection failed.";
}
?>

Yukarıdaki örneğin çıktısı:

Last Insert ID is : 1

db2_get_option
db2_lob_read
IBM DB2 İşlevleri


Gets a user defined size of LOB files with each invocation

db2_last_insert_id
db2_next_result
IBM DB2 İşlevleri
PHP Manual

db2_lob_read

(PECL ibm_db2 >= 1.6.0)

db2_lob_read — Gets a user defined size of LOB files with each invocation

Açıklama

string db2_lob_read ( resource $stmt , int $colnum , int $length )

Use db2_lob_read() to iterate through a specified column of a result set and retrieve a user defined size of LOB data.

Değiştirgeler

stmt

A valid stmt resource containing LOB data.

colnum

A valid column number in the result set of the stmt resource.

length

The size of the LOB data to be retrieved from the stmt resource.

Dönen Değerler

Returns the amount of data the user specifies. Returns FALSE if the data cannot be retrieved.

Örnekler

Örnek 1 Iterating through different types of data

<?php

/* Database Connection Parameters */
$db = 'SAMPLE';
$username = 'db2inst1';
$password = 'ibmdb2';

/* Obtain Connection Resource */
$conn = db2_connect($db,$username,$password);

if ($conn) {
    $drop = 'DROP TABLE clob_stream';
    $result = @db2_exec( $conn, $drop );

    $create = 'CREATE TABLE clob_stream (id INTEGER, my_clob CLOB)';
    $result = db2_exec( $conn, $create );

    $variable = "";
    $stmt = db2_prepare($conn, "INSERT INTO clob_stream (id,my_clob) VALUES (1, ?)");
    $variable = "THIS IS A CLOB TEST. THIS IS A CLOB TEST.";
    db2_bind_param($stmt, 1, "variable", DB2_PARAM_IN);
    db2_execute($stmt);

    $sql = "SELECT id,my_clob FROM clob_stream";
    $result = db2_prepare($conn, $sql);
    db2_execute($result);
    db2_fetch_row($result);
    $i = 0;
    /* Read LOB data */
    while ($data = db2_lob_read($result, 2, 6)) {
        echo "Loop $i: $data\n";
        $i = $i + 1;
    }

    $drop = 'DROP TABLE blob_stream';
    $result = @db2_exec( $conn, $drop );

    $create = 'CREATE TABLE blob_stream (id INTEGER, my_blob CLOB)';
    $result = db2_exec( $conn, $create );

    $variable = "";
    $stmt = db2_prepare($conn, "INSERT INTO blob_stream (id,my_blob) VALUES (1, ?)");
    $variable = "THIS IS A BLOB TEST. THIS IS A BLOB TEST.";
    db2_bind_param($stmt, 1, "variable", DB2_PARAM_IN);
    db2_execute($stmt);

    $sql = "SELECT id,my_blob FROM blob_stream";
    $result = db2_prepare($conn, $sql);
    db2_execute($result);
    db2_fetch_row($result);
    $i = 0;
    /* Read LOB data */
    while ($data = db2_lob_read($result, 2, 6)) {
        echo "Loop $i: $data\n";
        $i = $i + 1;
    }
} else {
    echo 'no connection: ' . db2_conn_errormsg();
}

?>

Yukarıdaki örneğin çıktısı:

Loop 0: THIS I
Loop 1: S A CL
Loop 2: OB TES
Loop 3: T. THI
Loop 4: S IS A
Loop 5:  CLOB
Loop 6: TEST.
Loop 0: THIS I
Loop 1: S A BL
Loop 2: OB TES
Loop 3: T. THI
Loop 4: S IS A
Loop 5:  BLOB
Loop 6: TEST.

Ayrıca Bakınız

  • db2_bind_param() - Binds a PHP variable to an SQL statement parameter
  • db2_exec() - Executes an SQL statement directly
  • db2_execute() - Executes a prepared SQL statement
  • db2_fetch_row() - Sets the result set pointer to the next row or requested row
  • db2_prepare() - Prepares an SQL statement to be executed
  • db2_result() - Returns a single column from a row in the result set

db2_last_insert_id
db2_next_result
IBM DB2 İşlevleri


Requests the next result set from a stored procedure

db2_lob_read
db2_num_fields
IBM DB2 İşlevleri
PHP Manual

db2_next_result

(PECL ibm_db2 >= 1.0.0)

db2_next_result — Requests the next result set from a stored procedure

Açıklama

resource db2_next_result ( resource $stmt )

A stored procedure can return zero or more result sets. While you handle the first result set in exactly the same way you would handle the results returned by a simple SELECT statement, to fetch the second and subsequent result sets from a stored procedure you must call the db2_next_result() function and return the result to a uniquely named PHP variable.

Değiştirgeler

stmt

A prepared statement returned from db2_exec() or db2_execute().

Dönen Değerler

Returns a new statement resource containing the next result set if the stored procedure returned another result set. Returns FALSE if the stored procedure did not return another result set.

Örnekler

Örnek 1 Calling a stored procedure that returns multiple result sets

In the following example, we call a stored procedure that returns three result sets. The first result set is fetched directly from the same statement resource on which we invoked the CALL statement, while the second and third result sets are fetched from statement resources returned from our calls to the db2_next_result() function.

<?php
$conn = db2_connect($database, $user, $password);

if ($conn) {
  $stmt = db2_exec($conn, 'CALL multiResults()');

  print "Fetching first result set\n";
  while ($row = db2_fetch_array($stmt)) {
    var_dump($row);
  }

  print "\nFetching second result set\n";
  $res = db2_next_result($stmt);
  if ($res) {
    while ($row = db2_fetch_array($res)) {
      var_dump($row);
    }
  }

  print "\nFetching third result set\n";
  $res2 = db2_next_result($stmt);
  if ($res2) {
    while ($row = db2_fetch_array($res2)) {
      var_dump($row);
    }
  }

  db2_close($conn);
}
?>

Yukarıdaki örneğin çıktısı:

Fetching first result set
array(2) {
  [0]=>
  string(16) "Bubbles         "
  [1]=>
  int(3)
}
array(2) {
  [0]=>
  string(16) "Gizmo           "
  [1]=>
  int(4)
}

Fetching second result set
array(4) {
  [0]=>
  string(16) "Sweater         "
  [1]=>
  int(6)
  [2]=>
  string(5) "llama"
  [3]=>
  string(6) "150.00"
}
array(4) {
  [0]=>
  string(16) "Smarty          "
  [1]=>
  int(2)
  [2]=>
  string(5) "horse"
  [3]=>
  string(6) "350.00"
}

Fetching third result set
array(1) {
  [0]=>
  string(16) "Bubbles         "
}
array(1) {
  [0]=>
  string(16) "Gizmo           "
}

db2_lob_read
db2_num_fields
IBM DB2 İşlevleri


Returns the number of fields contained in a result set

db2_next_result
db2_num_rows
IBM DB2 İşlevleri
PHP Manual

db2_num_fields

(PECL ibm_db2 >= 1.0.0)

db2_num_fields — Returns the number of fields contained in a result set

Açıklama

int db2_num_fields ( resource $stmt )

Returns the number of fields contained in a result set. This is most useful for handling the result sets returned by dynamically generated queries, or for result sets returned by stored procedures, where your application cannot otherwise know how to retrieve and use the results.

Değiştirgeler

stmt

A valid statement resource containing a result set.

Dönen Değerler

Returns an integer value representing the number of fields in the result set associated with the specified statement resource. Returns FALSE if the statement resource is not a valid input value.

Örnekler

Örnek 1 Retrieving the number of fields in a result set

The following example demonstrates how to retrieve the number of fields returned in a result set.

<?php

$sql = "SELECT id, name, breed, weight FROM animals ORDER BY breed";
$stmt = db2_prepare($conn, $sql);
db2_execute($stmt, $sql);
$columns = db2_num_fields($stmt);

echo "There are {$columns} columns in the result set.";
?>

Yukarıdaki örneğin çıktısı:

There are 4 columns in the result set.

Ayrıca Bakınız

  • db2_execute() - Executes a prepared SQL statement
  • db2_field_display_size() - Returns the maximum number of bytes required to display a column
  • db2_field_name() - Returns the name of the column in the result set
  • db2_field_num() - Returns the position of the named column in a result set
  • db2_field_precision() - Returns the precision of the indicated column in a result set
  • db2_field_scale() - Returns the scale of the indicated column in a result set
  • db2_field_type() - Returns the data type of the indicated column in a result set
  • db2_field_width() - Returns the width of the current value of the indicated column in a result set

db2_next_result
db2_num_rows
IBM DB2 İşlevleri


Returns the number of rows affected by an SQL statement

db2_num_fields
db2_pclose
IBM DB2 İşlevleri
PHP Manual

db2_num_rows

(PECL ibm_db2 >= 1.0.0)

db2_num_rows — Returns the number of rows affected by an SQL statement

Açıklama

int db2_num_rows ( resource $stmt )

Returns the number of rows deleted, inserted, or updated by an SQL statement.

To determine the number of rows that will be returned by a SELECT statement, issue SELECT COUNT(*) with the same predicates as your intended SELECT statement and retrieve the value.

If your application logic checks the number of rows returned by a SELECT statement and branches if the number of rows is 0, consider modifying your application to attempt to return the first row with one of db2_fetch_assoc(), db2_fetch_both(), db2_fetch_array(), or db2_fetch_row(), and branch if the fetch function returns FALSE.

Bilginize:

If you issue a SELECT statement using a scrollable cursor, db2_num_rows() returns the number of rows returned by the SELECT statement. However, the overhead associated with scrollable cursors significantly degrades the performance of your application, so if this is the only reason you are considering using scrollable cursors, you should use a forward-only cursor and either call SELECT COUNT(*) or rely on the boolean return value of the fetch functions to achieve the equivalent functionality with much better performance.

Değiştirgeler

stmt

A valid stmt resource containing a result set.

Dönen Değerler

Returns the number of rows affected by the last SQL statement issued by the specified statement handle.

db2_num_fields
db2_pclose
IBM DB2 İşlevleri


Closes a persistent database connection

db2_num_rows
db2_pconnect
IBM DB2 İşlevleri
PHP Manual

db2_pclose

(PECL ibm_db2 >= 1.8.0)

db2_pclose — Closes a persistent database connection

Açıklama

bool db2_pclose ( resource $resource )

This function closes a DB2 client connection created with db2_pconnect() and returns the corresponding resources to the database server.

Bilginize:

This function is only available on i5/OS in response to i5/OS system administration requests.

If you have a persistent DB2 client connection created with db2_pconnect(), you may use this function to close the connection. To avoid substantial connection performance penalties, this function should only be used in rare cases when the persistent connection has become unresponsive or the persistent connection will not be needed for a long period of time.

Değiştirgeler

connection

Specifies an active DB2 client connection.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Closing a persistent connection

The following example demonstrates a successful attempt to close a connection to an IBM DB2 i5/OS database.

<?php
$conn = db2_pconnect('', '', '');
$rc = db2_pclose($conn);
if ($rc) {
    echo "Connection was successfully closed.";
}
?>

Yukarıdaki örneğin çıktısı:

Connection was successfully closed.

Ayrıca Bakınız

  • db2_close() - Closes a database connection
  • db2_pconnect() - Returns a persistent connection to a database

db2_num_rows
db2_pconnect
IBM DB2 İşlevleri


Returns a persistent connection to a database

db2_pclose
db2_prepare
IBM DB2 İşlevleri
PHP Manual

db2_pconnect

(PECL ibm_db2 >= 1.0.0)

db2_pconnect — Returns a persistent connection to a database

Açıklama

resource db2_pconnect ( string $database , string $username , string $password [, array $options ] )

Returns a persistent connection to an IBM DB2 Universal Database, IBM Cloudscape, or Apache Derby database.

For more information on persistent connections, refer to Kalıcı Bağlantılı Veritabanı Bağlantıları.

Calling db2_close() on a persistent connection always returns TRUE, but the underlying DB2 client connection remains open and waiting to serve the next matching db2_pconnect() request.

Users running version 1.9.0 or later of ibm_db2 should be aware that the extension will perform a transaction rollback on persistent connections at the end of a request, thus ending the transaction. This prevents the transaction block from carrying over to the next request which uses that connection if script execution ends before the transaction block does.

Değiştirgeler

database

The database alias in the DB2 client catalog.

username

The username with which you are connecting to the database.

password

The password with which you are connecting to the database.

options

An associative array of connection options that affect the behavior of the connection, where valid array keys include:

autocommit

Passing the DB2_AUTOCOMMIT_ON value turns autocommit on for this connection handle.

Passing the DB2_AUTOCOMMIT_OFF value turns autocommit off for this connection handle.

DB2_ATTR_CASE

Passing the DB2_CASE_NATURAL value specifies that column names are returned in natural case.

Passing the DB2_CASE_LOWER value specifies that column names are returned in lower case.

Passing the DB2_CASE_UPPER value specifies that column names are returned in upper case.

CURSOR

Passing the DB2_FORWARD_ONLY value specifies a forward-only cursor for a statement resource. This is the default cursor type and is supported on all database servers.

Passing the DB2_SCROLLABLE value specifies a scrollable cursor for a statement resource. This mode enables random access to rows in a result set, but currently is supported only by IBM DB2 Universal Database.

The following new option is available in ibm_db2 version 1.7.0 and later.

trustedcontext

Passing the DB2_TRUSTED_CONTEXT_ENABLE value turns trusted context on for this connection handle. This parameter cannot be set using db2_set_option().

This key works only if the database is cataloged (even if the database is local), or if you specify the full DSN when you create the connection.

To catalog the database, use following commands:

db2 catalog tcpip node loopback remote <SERVERNAME> server <SERVICENAME>
db2 catalog database <LOCALDBNAME> as <REMOTEDBNAME> at node loopback
db2 "update dbm cfg using svcename <SERVICENAME>"
db2set DB2COMM=TCPIP

The following new i5/OS options are available in ibm_db2 version 1.5.1 and later.

İpucu

Conflicting connection attributes used in conjunction with persistent connections can produce indeterminate results on i5/OS. Site policies should be establish for all applications using each persistent connection user profile. The default DB2_AUTOCOMMIT_ON is suggested when using persistent connections.

i5_lib

A character value that indicates the default library that will be used for resolving unqualified file references. This is not valid if the connection is using system naming mode.

i5_naming

DB2_I5_NAMING_ON value turns on DB2 UDB CLI iSeries system naming mode. Files are qualified using the slash (/) delimiter. Unqualified files are resolved using the library list for the job.

DB2_I5_NAMING_OFF value turns off DB2 UDB CLI default naming mode, which is SQL naming. Files are qualified using the period (.) delimiter. Unqualified files are resolved using either the default library or the current user ID.

i5_commit

The i5_commit attribute should be set before the db2_pconnect(). If the value is changed after the connection has been established, and the connection is to a remote data source, the change does not take effect until the next successful db2_pconnect() for the connection handle.

Bilginize:

The php.ini setting ibm_db2.i5_allow_commit==0 or DB2_I5_TXN_NO_COMMIT is the default, but may be overridden with the i5_commit option.

DB2_I5_TXN_NO_COMMIT - Commitment control is not used.

DB2_I5_TXN_READ_UNCOMMITTED - Dirty reads, nonrepeatable reads, and phantoms are possible.

DB2_I5_TXN_READ_COMMITTED - Dirty reads are not possible. Nonrepeatable reads, and phantoms are possible.

DB2_I5_TXN_REPEATABLE_READ - Dirty reads and nonrepeatable reads are not possible. Phantoms are possible.

DB2_I5_TXN_SERIALIZABLE - Transactions are serializable. Dirty reads, non-repeatable reads, and phantoms are not possible

i5_query_optimize

DB2_FIRST_IO All queries are optimized with the goal of returning the first page of output as fast as possible. This goal works well when the output is controlled by a user who is most likely to cancel the query after viewing the first page of output data. Queries coded with an OPTIMIZE FOR nnn ROWS clause honor the goal specified by the clause.

DB2_ALL_IO All queries are optimized with the goal of running the entire query to completion in the shortest amount of elapsed time. This is a good option when the output of a query is being written to a file or report, or the interface is queuing the output data. Queries coded with an OPTIMIZE FOR nnn ROWS clause honor the goal specified by the clause. This is the default.

i5_dbcs_alloc

DB2_I5_DBCS_ALLOC_ON value turns on DB2 6X allocation scheme for DBCS translation column size growth.

DB2_I5_DBCS_ALLOC_OFF value turns off DB2 6X allocation scheme for DBCS translation column size growth.

Bilginize:

The php.ini setting ibm_db2.i5_dbcs_alloc==0 or DB2_I5_DBCS_ALLOC_OFF is the default, but may be overridden with the i5_dbcs_alloc option.

i5_date_fmt

DB2_I5_FMT_ISO - The International Organization for Standardization (ISO) date format yyyy-mm-dd is used. This is the default.

DB2_I5_FMT_USA - The United States date format mm/dd/yyyy is used.

DB2_I5_FMT_EUR - The European date format dd.mm.yyyy is used.

DB2_I5_FMT_JIS - The Japanese Industrial Standard date format yyyy-mm-dd is used.

DB2_I5_FMT_MDY - The date format mm/dd/yyyy is used.

DB2_I5_FMT_DMY - The date format dd/mm/yyyy is used.

DB2_I5_FMT_YMD - The date format yy/mm/dd is used.

DB2_I5_FMT_JUL - The Julian date format yy/ddd is used.

DB2_I5_FMT_JOB - The job default is used.

i5_date_sep

DB2_I5_SEP_SLASH - A slash ( / ) is used as the date separator. This is the default.

DB2_I5_SEP_DASH - A dash ( - ) is used as the date separator.

DB2_I5_SEP_PERIOD - A period ( . ) is used as the date separator.

DB2_I5_SEP_COMMA - A comma ( , ) is used as the date separator.

DB2_I5_SEP_BLANK - A blank is used as the date separator.

DB2_I5_SEP_JOB - The job default is used

i5_time_fmt

DB2_I5_FMT_ISO - The International Organization for Standardization (ISO) time format hh.mm.ss is used. This is the default.

DB2_I5_FMT_USA - The United States time format hh:mmxx is used, where xx is AM or PM.

DB2_I5_FMT_EUR - The European time format hh.mm.ss is used.

DB2_I5_FMT_JIS - The Japanese Industrial Standard time format hh:mm:ss is used.

DB2_I5_FMT_HMS - The hh:mm:ss format is used.

i5_time_sep

DB2_I5_SEP_COLON - A colon ( : ) is used as the time separator. This is the default.

DB2_I5_SEP_PERIOD - A period ( . ) is used as the time separator.

DB2_I5_SEP_COMMA - A comma ( , ) is used as the time separator.

DB2_I5_SEP_BLANK - A blank is used as the time separator.

DB2_I5_SEP_JOB - The job default is used.

i5_decimal_sep

DB2_I5_SEP_PERIOD - A period ( . ) is used as the decimal separator. This is the default.

DB2_I5_SEP_COMMA - A comma ( , ) is used as the decimal separator.

DB2_I5_SEP_JOB - The job default is used.

The following new i5/OS option is available in ibm_db2 version 1.8.0 and later.

i5_libl

A character value that indicates the library list that will be used for resolving unqualified file references. Specify the library list elements separated by blanks 'i5_libl'=>"MYLIB YOURLIB ANYLIB".

Bilginize:

i5_libl calls qsys2/qcmdexc('cmd',cmdlen), which is only available in i5/OS V5R4 and later.

Dönen Değerler

Returns a connection handle resource if the connection attempt is successful. db2_pconnect() tries to reuse an existing connection resource that exactly matches the database, username, and password parameters. If the connection attempt fails, db2_pconnect() returns FALSE.

Sürüm Bilgisi

Sürüm: | Açıklama
ibm_db2 1.9.0 | Active transactions within a persistent connection will be rolled back at the end of each request.
ibm_db2 1.8.0 | The i5_libl option is available for i5/OS users.
ibm_db2 1.7.0 | The trustedcontext option is available.
ibm_db2 1.5.1 | The i5_lib, i5_naming, i5_commit, i5_query_optimize, i5_dbcs_alloc, i5_date_fmt, i5_date_sep, i5_time_fmt, i5_time_sep and i5_decimal_sep options are available for i5/OS users.

Örnekler

Örnek 1 A db2_pconnect() example

In the following example, the first call to db2_pconnect() returns a new persistent connection resource. The second call to db2_pconnect() returns a persistent connection resource that simply reuses the first persistent connection resource.

<?php
$database = 'SAMPLE';
$user = 'db2inst1';
$password = 'ibmdb2';

$pconn = db2_pconnect($database, $user, $password);

if ($pconn) {
    echo "Persistent connection succeeded.";
}
else {
    echo "Persistent connection failed.";
}

$pconn2 = db2_pconnect($database, $user, $password);
if ($pconn) {
    echo "Second persistent connection succeeded.";
}
else {
    echo "Second persistent connection failed.";
}
?>

Yukarıdaki örneğin çıktısı:

Persistent connection succeeded.
Second persistent connection succeeded.

Örnek 2 Using trusted context

The following example shows how to enable trusted context, switch users, and get the current user ID.

<?php

$database = "SAMPLE";
$hostname = "localhost";
$port = 50000;
$authID = "db2inst1";
$auth_pass = "ibmdb2";

$tc_user = "tcuser";
$tc_pass = "tcpassword";

$dsn = "DATABASE=$database;HOSTNAME=$hostname;PORT=$port;
  PROTOCOL=TCPIP;UID=$authID;PWD=$auth_pass;";
$options = array ("trustedcontext" => DB2_TRUSTED_CONTEXT_ENABLE);

$tc_conn = db2_pconnect($dsn, "", "", $options);
if($tc_conn) {
    echo "Explicit trusted connection succeeded.\n";

    if(db2_get_option($tc_conn, "trustedcontext")) {
        $userBefore = db2_get_option($tc_conn, "trusted_user");

        //Do some work as user 1.

        //Switching to trusted user.
        $parameters = array("trusted_user" => $tc_user,
          "trusted_password" => $tcuser_pass);
        $res = db2_set_option ($tc_conn, $parameters, 1);

        $userAfter = db2_get_option($tc_conn, "trusted_user");
        //Do more work as trusted user.

        if($userBefore != $userAfter) {
            echo "User has been switched." . "\n";
        }
    }

    db2_close($tc_conn);
}
else {
    echo "Explicit trusted connection failed.\n";
}
?>

Yukarıdaki örneğin çıktısı:

Explicit trusted connection succeeded.
User has been switched.

Ayrıca Bakınız

  • db2_connect() - Returns a connection to a database

db2_pclose
db2_prepare
IBM DB2 İşlevleri


Prepares an SQL statement to be executed

db2_pconnect
db2_primary_keys
IBM DB2 İşlevleri
PHP Manual

db2_prepare

(PECL ibm_db2 >= 1.0.0)

db2_prepare — Prepares an SQL statement to be executed

Açıklama

resource db2_prepare ( resource $connection , string $statement [, array $options ] )

db2_prepare() creates a prepared SQL statement which can include 0 or more parameter markers (? characters) representing parameters for input, output, or input/output. You can pass parameters to the prepared statement using db2_bind_param(), or for input values only, as an array passed to db2_execute().

There are three main advantages to using prepared statements in your application:

  • Performance: when you prepare a statement, the database server creates an optimized access plan for retrieving data with that statement. Subsequently issuing the prepared statement with db2_execute() enables the statements to reuse that access plan and avoids the overhead of dynamically creating a new access plan for every statement you issue.

  • Security: when you prepare a statement, you can include parameter markers for input values. When you execute a prepared statement with input values for placeholders, the database server checks each input value to ensure that the type matches the column definition or parameter definition.

  • Advanced functionality: Parameter markers not only enable you to pass input values to prepared SQL statements, they also enable you to retrieve OUT and INOUT parameters from stored procedures using db2_bind_param().

Değiştirgeler

connection

A valid database connection resource variable as returned from db2_connect() or db2_pconnect().

statement

An SQL statement, optionally containing one or more parameter markers..

options

An associative array containing statement options. You can use this parameter to request a scrollable cursor on database servers that support this functionality.

For a description of valid statement options, see db2_set_option().

Dönen Değerler

Returns a statement resource if the SQL statement was successfully parsed and prepared by the database server. Returns FALSE if the database server returned an error. You can determine which error was returned by calling db2_stmt_error() or db2_stmt_errormsg().

Örnekler

Örnek 1 Preparing and executing an SQL statement with parameter markers

The following example prepares an INSERT statement that accepts four parameter markers, then iterates over an array of arrays containing the input values to be passed to db2_execute().

<?php
$animals = array(
    array(0, 'cat', 'Pook', 3.2),
    array(1, 'dog', 'Peaches', 12.3),
    array(2, 'horse', 'Smarty', 350.0),
);

$insert = 'INSERT INTO animals (id, breed, name, weight)
    VALUES (?, ?, ?, ?)';
$stmt = db2_prepare($conn, $insert);
if ($stmt) {
    foreach ($animals as $animal) {
        $result = db2_execute($stmt, $animal);
    }
}
?>

Ayrıca Bakınız

  • db2_bind_param() - Binds a PHP variable to an SQL statement parameter
  • db2_execute() - Executes a prepared SQL statement
  • db2_stmt_error() - Returns a string containing the SQLSTATE returned by an SQL statement
  • db2_stmt_errormsg() - Returns a string containing the last SQL statement error message

db2_pconnect
db2_primary_keys
IBM DB2 İşlevleri


Returns a result set listing primary keys for a table

db2_prepare
db2_procedure_columns
IBM DB2 İşlevleri
PHP Manual

db2_primary_keys

(PECL ibm_db2 >= 1.0.0)

db2_primary_keys — Returns a result set listing primary keys for a table

Açıklama

resource db2_primary_keys ( resource $connection , string $qualifier , string $schema , string $table-name )

Returns a result set listing the primary keys for a table.

Değiştirgeler

connection

A valid connection to an IBM DB2, Cloudscape, or Apache Derby database.

qualifier

A qualifier for DB2 databases running on OS/390 or z/OS servers. For other databases, pass NULL or an empty string.

schema

The schema which contains the tables. If schema is NULL, db2_primary_keys() matches the schema for the current connection.

table-name

The name of the table.

Dönen Değerler

Returns a statement resource with a result set containing rows describing the primary keys for the specified table. The result set is composed of the following columns:

Column name | Description
TABLE_CAT | Name of the catalog for the table containing the primary key. The value is NULL if this table does not have catalogs.
TABLE_SCHEM | Name of the schema for the table containing the primary key.
TABLE_NAME | Name of the table containing the primary key.
COLUMN_NAME | Name of the column containing the primary key.
KEY_SEQ | 1-indexed position of the column in the key.
PK_NAME | The name of the primary key.

Ayrıca Bakınız

  • db2_column_privileges() - Returns a result set listing the columns and associated privileges for a table
  • db2_columns() - Returns a result set listing the columns and associated metadata for a table
  • db2_foreign_keys() - Returns a result set listing the foreign keys for a table
  • db2_procedure_columns() - Returns a result set listing stored procedure parameters
  • db2_procedures() - Returns a result set listing the stored procedures registered in a database
  • db2_special_columns() - Returns a result set listing the unique row identifier columns for a table
  • db2_statistics() - Returns a result set listing the index and statistics for a table
  • db2_table_privileges() - Returns a result set listing the tables and associated privileges in a database
  • db2_tables() - Returns a result set listing the tables and associated metadata in a database

db2_prepare
db2_procedure_columns
IBM DB2 İşlevleri


Returns a result set listing stored procedure parameters

db2_primary_keys
db2_procedures
IBM DB2 İşlevleri
PHP Manual

db2_procedure_columns

(PECL ibm_db2 >= 1.0.0)

db2_procedure_columns — Returns a result set listing stored procedure parameters

Açıklama

resource db2_procedure_columns ( resource $connection , string $qualifier , string $schema , string $procedure , string $parameter )

Returns a result set listing the parameters for one or more stored procedures.

Değiştirgeler

connection

A valid connection to an IBM DB2, Cloudscape, or Apache Derby database.

qualifier

A qualifier for DB2 databases running on OS/390 or z/OS servers. For other databases, pass NULL or an empty string.

schema

The schema which contains the procedures. This parameter accepts a search pattern containing _ and % as wildcards.

procedure

The name of the procedure. This parameter accepts a search pattern containing _ and % as wildcards.

parameter

The name of the parameter. This parameter accepts a search pattern containing _ and % as wildcards. If this parameter is NULL, all parameters for the specified stored procedures are returned.

Dönen Değerler

Returns a statement resource with a result set containing rows describing the parameters for the stored procedures matching the specified parameters. The rows are composed of the following columns:

Column name | Description
PROCEDURE_CAT | The catalog that contains the procedure. The value is NULL if this table does not have catalogs.
PROCEDURE_SCHEM | Name of the schema that contains the stored procedure.
PROCEDURE_NAME | Name of the procedure.
COLUMN_NAME | Name of the parameter.
COLUMN_TYPE

An integer value representing the type of the parameter:

Return value | Parameter type
1 (SQL_PARAM_INPUT) | Input (IN) parameter.
2 (SQL_PARAM_INPUT_OUTPUT) | Input/output (INOUT) parameter.
3 (SQL_PARAM_OUTPUT) | Output (OUT) parameter.
DATA_TYPE | The SQL data type for the parameter represented as an integer value.
TYPE_NAME | A string representing the data type for the parameter.
COLUMN_SIZE | An integer value representing the size of the parameter.
BUFFER_LENGTH | Maximum number of bytes necessary to store data for this parameter.
DECIMAL_DIGITS | The scale of the parameter, or NULL where scale is not applicable.
NUM_PREC_RADIX | An integer value of either 10 (representing an exact numeric data type), 2 (representing an approximate numeric data type), or NULL (representing a data type for which radix is not applicable).
NULLABLE | An integer value representing whether the parameter is nullable or not.
REMARKS | Description of the parameter.
COLUMN_DEF | Default value for the parameter.
SQL_DATA_TYPE | An integer value representing the size of the parameter.
SQL_DATETIME_SUB | Returns an integer value representing a datetime subtype code, or NULL for SQL data types to which this does not apply.
CHAR_OCTET_LENGTH | Maximum length in octets for a character data type parameter, which matches COLUMN_SIZE for single-byte character set data, or NULL for non-character data types.
ORDINAL_POSITION | The 1-indexed position of the parameter in the CALL statement.
IS_NULLABLE | A string value where 'YES' means that the parameter accepts or returns NULL values and 'NO' means that the parameter does not accept or return NULL values.

Ayrıca Bakınız

  • db2_column_privileges() - Returns a result set listing the columns and associated privileges for a table
  • db2_columns() - Returns a result set listing the columns and associated metadata for a table
  • db2_foreign_keys() - Returns a result set listing the foreign keys for a table
  • db2_primary_keys() - Returns a result set listing primary keys for a table
  • db2_procedures() - Returns a result set listing the stored procedures registered in a database
  • db2_special_columns() - Returns a result set listing the unique row identifier columns for a table
  • db2_statistics() - Returns a result set listing the index and statistics for a table
  • db2_table_privileges() - Returns a result set listing the tables and associated privileges in a database
  • db2_tables() - Returns a result set listing the tables and associated metadata in a database

db2_primary_keys
db2_procedures
IBM DB2 İşlevleri


Returns a result set listing the stored procedures registered in a database

db2_procedure_columns
db2_result
IBM DB2 İşlevleri
PHP Manual

db2_procedures

(PECL ibm_db2 >= 1.0.0)

db2_procedures — Returns a result set listing the stored procedures registered in a database

Açıklama

resource db2_procedures ( resource $connection , string $qualifier , string $schema , string $procedure )

Returns a result set listing the stored procedures registered in a database.

Değiştirgeler

connection

A valid connection to an IBM DB2, Cloudscape, or Apache Derby database.

qualifier

A qualifier for DB2 databases running on OS/390 or z/OS servers. For other databases, pass NULL or an empty string.

schema

The schema which contains the procedures. This parameter accepts a search pattern containing _ and % as wildcards.

procedure

The name of the procedure. This parameter accepts a search pattern containing _ and % as wildcards.

Dönen Değerler

Returns a statement resource with a result set containing rows describing the stored procedures matching the specified parameters. The rows are composed of the following columns:

Column name | Description
PROCEDURE_CAT | The catalog that contains the procedure. The value is NULL if this table does not have catalogs.
PROCEDURE_SCHEM | Name of the schema that contains the stored procedure.
PROCEDURE_NAME | Name of the procedure.
NUM_INPUT_PARAMS | Number of input (IN) parameters for the stored procedure.
NUM_OUTPUT_PARAMS | Number of output (OUT) parameters for the stored procedure.
NUM_RESULT_SETS | Number of result sets returned by the stored procedure.
REMARKS | Any comments about the stored procedure.
PROCEDURE_TYPE | Always returns 1, indicating that the stored procedure does not return a return value.

Ayrıca Bakınız

  • db2_column_privileges() - Returns a result set listing the columns and associated privileges for a table
  • db2_columns() - Returns a result set listing the columns and associated metadata for a table
  • db2_foreign_keys() - Returns a result set listing the foreign keys for a table
  • db2_primary_keys() - Returns a result set listing primary keys for a table
  • db2_procedure_columns() - Returns a result set listing stored procedure parameters
  • db2_special_columns() - Returns a result set listing the unique row identifier columns for a table
  • db2_statistics() - Returns a result set listing the index and statistics for a table
  • db2_table_privileges() - Returns a result set listing the tables and associated privileges in a database
  • db2_tables() - Returns a result set listing the tables and associated metadata in a database

db2_procedure_columns
db2_result
IBM DB2 İşlevleri


Returns a single column from a row in the result set

db2_procedures
db2_rollback
IBM DB2 İşlevleri
PHP Manual

db2_result

(PECL ibm_db2 >= 1.0.0)

db2_result — Returns a single column from a row in the result set

Açıklama

mixed db2_result ( resource $stmt , mixed $column )

Use db2_result() to return the value of a specified column in the current row of a result set. You must call db2_fetch_row() before calling db2_result() to set the location of the result set pointer.

Değiştirgeler

stmt

A valid stmt resource.

column

Either an integer mapping to the 0-indexed field in the result set, or a string matching the name of the column.

Dönen Değerler

Returns the value of the requested field if the field exists in the result set. Returns NULL if the field does not exist, and issues a warning.

Örnekler

Örnek 1 A db2_result() example

The following example demonstrates how to iterate through a result set with db2_fetch_row() and retrieve columns from the result set with db2_result().

<?php
$sql = 'SELECT name, breed FROM animals WHERE weight < ?';
$stmt = db2_prepare($conn, $sql);
db2_execute($stmt, array(10));
while (db2_fetch_row($stmt)) {
    $name = db2_result($stmt, 0);
    $breed = db2_result($stmt, 'BREED');
    print "$name $breed";
}
?>

Yukarıdaki örneğin çıktısı:

cat Pook
gold fish Bubbles
budgerigar Gizmo
goat Rickety Ride

Ayrıca Bakınız

  • db2_fetch_array() - Returns an array, indexed by column position, representing a row in a result set
  • db2_fetch_assoc() - Returns an array, indexed by column name, representing a row in a result set
  • db2_fetch_both() - Returns an array, indexed by both column name and position, representing a row in a result set
  • db2_fetch_object() - Returns an object with properties representing columns in the fetched row
  • db2_fetch_row() - Sets the result set pointer to the next row or requested row

db2_procedures
db2_rollback
IBM DB2 İşlevleri


Rolls back a transaction

db2_result
db2_server_info
IBM DB2 İşlevleri
PHP Manual

db2_rollback

(PECL ibm_db2 >= 1.0.0)

db2_rollback — Rolls back a transaction

Açıklama

bool db2_rollback ( resource $connection )

Rolls back an in-progress transaction on the specified connection resource and begins a new transaction. PHP applications normally default to AUTOCOMMIT mode, so db2_rollback() normally has no effect unless AUTOCOMMIT has been turned off for the connection resource.

Değiştirgeler

connection

A valid database connection resource variable as returned from db2_connect() or db2_pconnect().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Rolling back a DELETE statement

In the following example, we count the number of rows in a table, turn off AUTOCOMMIT mode on a database connection, delete all of the rows in the table and return the count of 0 to prove that the rows have been removed. We then issue db2_rollback() and return the updated count of rows in the table to show that the number is the same as before we issued the DELETE statement. The return to the original state of the table demonstrates that the roll back of the transaction succeeded.

<?php
$conn = db2_connect($database, $user, $password);

if ($conn) {
    $stmt = db2_exec($conn, "SELECT count(*) FROM animals");
    $res = db2_fetch_array( $stmt );
    echo $res[0] . "\n";

    // Turn AUTOCOMMIT off
    db2_autocommit($conn, DB2_AUTOCOMMIT_OFF);

    // Delete all rows from ANIMALS
    db2_exec($conn, "DELETE FROM animals");

    $stmt = db2_exec($conn, "SELECT count(*) FROM animals");
    $res = db2_fetch_array( $stmt );
    echo $res[0] . "\n";

    // Roll back the DELETE statement
    db2_rollback( $conn );

    $stmt = db2_exec( $conn, "SELECT count(*) FROM animals" );
    $res = db2_fetch_array( $stmt );
    echo $res[0] . "\n";
    db2_close($conn);
}
?>

Yukarıdaki örneğin çıktısı:

7
0
7

Ayrıca Bakınız

  • db2_autocommit() - Returns or sets the AUTOCOMMIT state for a database connection
  • db2_commit() - Commits a transaction

db2_result
db2_server_info
IBM DB2 İşlevleri


Returns an object with properties that describe the DB2 database server

db2_rollback
db2_set_option
IBM DB2 İşlevleri
PHP Manual

db2_server_info

(PECL ibm_db2 >= 1.1.1)

db2_server_info — Returns an object with properties that describe the DB2 database server

Açıklama

object db2_server_info ( resource $connection )

This function returns an object with read-only properties that return information about the IBM DB2, Cloudscape, or Apache Derby database server. The following table lists the database server properties:

Database server properties
Property name | Return type | Description
DBMS_NAME | string | The name of the database server to which you are connected. For DB2 servers this is a combination of DB2 followed by the operating system on which the database server is running.
DBMS_VER | string | The version of the database server, in the form of a string "MM.mm.uuuu" where MM is the major version, mm is the minor version, and uuuu is the update. For example, "08.02.0001" represents major version 8, minor version 2, update 1.
DB_CODEPAGE | int | The code page of the database to which you are connected.
DB_NAME | string | The name of the database to which you are connected.
DFT_ISOLATION string

The default transaction isolation level supported by the server:

UR

Uncommitted read: changes are immediately visible by all concurrent transactions.

CS

Cursor stability: a row read by one transaction can be altered and committed by a second concurrent transaction.

RS

Read stability: a transaction can add or remove rows matching a search condition or a pending transaction.

RR

Repeatable read: data affected by pending transaction is not available to other transactions.

NC

No commit: any changes are visible at the end of a successful operation. Explicit commits and rollbacks are not allowed.

IDENTIFIER_QUOTE_CHAR | string | The character used to delimit an identifier.
INST_NAME | string | The instance on the database server that contains the database.
ISOLATION_OPTION | array | An array of the isolation options supported by the database server. The isolation options are described in the DFT_ISOLATION property.
KEYWORDS | array | An array of the keywords reserved by the database server.
LIKE_ESCAPE_CLAUSE | bool | TRUE if the database server supports the use of % and _ wildcard characters. FALSE if the database server does not support these wildcard characters.
MAX_COL_NAME_LEN | int | Maximum length of a column name supported by the database server, expressed in bytes.
MAX_IDENTIFIER_LEN | int | Maximum length of an SQL identifier supported by the database server, expressed in characters.
MAX_INDEX_SIZE | int | Maximum size of columns combined in an index supported by the database server, expressed in bytes.
MAX_PROC_NAME_LEN | int | Maximum length of a procedure name supported by the database server, expressed in bytes.
MAX_ROW_SIZE | int | Maximum length of a row in a base table supported by the database server, expressed in bytes.
MAX_SCHEMA_NAME_LEN | int | Maximum length of a schema name supported by the database server, expressed in bytes.
MAX_STATEMENT_LEN | int | Maximum length of an SQL statement supported by the database server, expressed in bytes.
MAX_TABLE_NAME_LEN | int | Maximum length of a table name supported by the database server, expressed in bytes.
NON_NULLABLE_COLUMNS | bool | TRUE if the database server supports columns that can be defined as NOT NULL, FALSE if the database server does not support columns defined as NOT NULL.
PROCEDURES | bool | TRUE if the database server supports the use of the CALL statement to call stored procedures, FALSE if the database server does not support the CALL statement.
SPECIAL_CHARS | string | A string containing all of the characters other than a-Z, 0-9, and underscore that can be used in an identifier name.
SQL_CONFORMANCE string

The level of conformance to the ANSI/ISO SQL-92 specification offered by the database server:

ENTRY

Entry-level SQL-92 compliance.

FIPS127

FIPS-127-2 transitional compliance.

FULL

Full level SQL-92 compliance.

INTERMEDIATE

Intermediate level SQL-92 compliance.

Değiştirgeler

connection

Specifies an active DB2 client connection.

Dönen Değerler

Returns an object on a successful call. Returns FALSE on failure.

Örnekler

Örnek 1 A db2_server_info() example

To retrieve information about the server, you must pass a valid database connection resource to db2_server_info().

<?php

$conn = db2_connect('sample', 'db2inst1', 'ibmdb2');

$server = db2_server_info( $conn );

if ($server) {
    echo "DBMS_NAME: ";                 var_dump( $server->DBMS_NAME );
    echo "DBMS_VER: ";                  var_dump( $server->DBMS_VER );
    echo "DB_CODEPAGE: ";               var_dump( $server->DB_CODEPAGE );
    echo "DB_NAME: ";                   var_dump( $server->DB_NAME );
    echo "INST_NAME: ";                 var_dump( $server->INST_NAME );
    echo "SPECIAL_CHARS: ";             var_dump( $server->SPECIAL_CHARS );
    echo "KEYWORDS: ";                  var_dump( sizeof($server->KEYWORDS) );
    echo "DFT_ISOLATION: ";             var_dump( $server->DFT_ISOLATION );
    echo "ISOLATION_OPTION: ";
    $il = '';
    foreach( $server->ISOLATION_OPTION as $opt )
    {
       $il .= $opt." ";
    }
    var_dump( $il );
    echo "SQL_CONFORMANCE: ";           var_dump( $server->SQL_CONFORMANCE );
    echo "PROCEDURES: ";                var_dump( $server->PROCEDURES );
    echo "IDENTIFIER_QUOTE_CHAR: ";     var_dump( $server->IDENTIFIER_QUOTE_CHAR );
    echo "LIKE_ESCAPE_CLAUSE: ";        var_dump( $server->LIKE_ESCAPE_CLAUSE );
    echo "MAX_COL_NAME_LEN: ";          var_dump( $server->MAX_COL_NAME_LEN );
    echo "MAX_ROW_SIZE: ";              var_dump( $server->MAX_ROW_SIZE );
    echo "MAX_IDENTIFIER_LEN: ";        var_dump( $server->MAX_IDENTIFIER_LEN );
    echo "MAX_INDEX_SIZE: ";            var_dump( $server->MAX_INDEX_SIZE );
    echo "MAX_PROC_NAME_LEN: ";         var_dump( $server->MAX_PROC_NAME_LEN );
    echo "MAX_SCHEMA_NAME_LEN: ";       var_dump( $server->MAX_SCHEMA_NAME_LEN );
    echo "MAX_STATEMENT_LEN: ";         var_dump( $server->MAX_STATEMENT_LEN );
    echo "MAX_TABLE_NAME_LEN: ";        var_dump( $server->MAX_TABLE_NAME_LEN );
    echo "NON_NULLABLE_COLUMNS: ";      var_dump( $server->NON_NULLABLE_COLUMNS );

    db2_close($conn);
}
?>

Yukarıdaki örneğin çıktısı:

DBMS_NAME: string(9) "DB2/LINUX"
DBMS_VER: string(10) "08.02.0000"
DB_CODEPAGE: int(1208)
DB_NAME: string(6) "SAMPLE"
INST_NAME: string(8) "db2inst1"
SPECIAL_CHARS: string(2) "@#"
KEYWORDS: int(179)
DFT_ISOLATION: string(2) "CS"
ISOLATION_OPTION: string(12) "UR CS RS RR "
SQL_CONFORMANCE: string(7) "FIPS127"
PROCEDURES: bool(true)
IDENTIFIER_QUOTE_CHAR: string(1) """
LIKE_ESCAPE_CLAUSE: bool(true)
MAX_COL_NAME_LEN: int(30)
MAX_ROW_SIZE: int(32677)
MAX_IDENTIFIER_LEN: int(18)
MAX_INDEX_SIZE: int(1024)
MAX_PROC_NAME_LEN: int(128)
MAX_SCHEMA_NAME_LEN: int(30)
MAX_STATEMENT_LEN: int(2097152)
MAX_TABLE_NAME_LEN: int(128)
NON_NULLABLE_COLUMNS: bool(true)

Ayrıca Bakınız

  • db2_client_info() - Returns an object with properties that describe the DB2 database client

db2_rollback
db2_set_option
IBM DB2 İşlevleri


Set options for connection or statement resources

db2_server_info
db2_special_columns
IBM DB2 İşlevleri
PHP Manual

db2_set_option

(PECL ibm_db2 >= 1.0.0)

db2_set_option — Set options for connection or statement resources

Açıklama

bool db2_set_option ( resource $resource , array $options , int $type )

Sets options for a statement resource or a connection resource. You cannot set options for result set resources.

Değiştirgeler

resource

A valid statement resource as returned from db2_prepare() or a valid connection resource as returned from db2_connect() or db2_pconnect().

options

An associative array containing valid statement or connection options. This parameter can be used to change autocommit values, cursor types (scrollable or forward), and to specify the case of the column names (lower, upper, or natural) that will appear in a result set.

autocommit

Passing DB2_AUTOCOMMIT_ON turns autocommit on for the specified connection resource.

Passing DB2_AUTOCOMMIT_OFF turns autocommit off for the specified connection resource.

cursor

Passing DB2_FORWARD_ONLY specifies a forward-only cursor for a statement resource. This is the default cursor type, and is supported by all database servers.

Passing DB2_SCROLLABLE specifies a scrollable cursor for a statement resource. Scrollable cursors enable result set rows to be accessed in non-sequential order, but are only supported by IBM DB2 Universal Database databases.

binmode

Passing DB2_BINARY specifies that binary data will be returned as is. This is the default mode. This is the equivalent of setting ibm_db2.binmode=1 in php.ini.

Passing DB2_CONVERT specifies that binary data will be converted to hexadecimal encoding, and will be returned as such. This is the equivalent of setting ibm_db2.binmode=2 in php.ini.

Passing DB2_PASSTHRU specifies that binary data will be converted to NULL. This is the equivalent of setting ibm_db2.binmode=3 in php.ini.

db2_attr_case

Passing DB2_CASE_LOWER specifies that column names of the result set are returned in lower case.

Passing DB2_CASE_UPPER specifies that column names of the result set are returned in upper case.

Passing DB2_CASE_NATURAL specifies that column names of the result set are returned in natural case.

deferred_prepare

Passing DB2_DEFERRED_PREPARE_ON turns deferred prepare on for the specified statement resource.

Passing DB2_DEFERRED_PREPARE_OFF turns deferred prepare off for the specified statement resource.

The following new i5/OS options are available in ibm_db2 version 1.5.1 and later. These options apply only when running PHP and ibm_db2 natively on i5 systems.

i5_fetch_only

DB2_I5_FETCH_ON - Cursors are read-only and cannot be used for positioned updates or deletes. This is the default unless SQL_ATTR_FOR_FETCH_ONLY environment has been set to SQL_FALSE.

DB2_I5_FETCH_OFF - Cursors can be used for positioned updates and deletes.

The following new option is available in ibm_db2 version 1.8.0 and later.

rowcount

DB2_ROWCOUNT_PREFETCH_ON - Client can request the full row count prior to fetching, which means that db2_num_rows() returns the number of rows selected even when a ROLLFORWARD_ONLY cursor is used.

DB2_ROWCOUNT_PREFETCH_OFF - Client cannot request the full row count prior to fetching.

The following new options are available in ibm_db2 version 1.7.0 and later.

trusted_user

To switch the user to a trusted user, pass the User ID (String) of the trusted user as the value of this key. This option can be set on a connection resource only. To use this option, trusted context must be enabled on the connection resource.

trusted_password

The password (String) that corresponds to the user specified by the trusted_user key.

The following new options are available in ibm_db2 version 1.6.0 and later. These options provide useful tracking information that can be accessed during execution with db2_get_option().

Bilginize:

When the value in each option is being set, some servers might not handle the entire length provided and might truncate the value.

To ensure that the data specified in each option is converted correctly when transmitted to a host system, use only the characters A through Z, 0 through 9, and the underscore (_) or period (.).

userid

SQL_ATTR_INFO_USERID - A pointer to a null-terminated character string used to identify the client user ID sent to the host database server when using DB2 Connect.

Bilginize:

DB2 for z/OS and OS/390 servers support up to a length of 16 characters. This user-id is not to be confused with the authentication user-id, it is for identification purposes only and is not used for any authorization.

acctstr

SQL_ATTR_INFO_ACCTSTR - A pointer to a null-terminated character string used to identify the client accounting string sent to the host database server when using DB2 Connect.

Bilginize:

DB2 for z/OS and OS/390 servers support up to a length of 200 characters.

applname

SQL_ATTR_INFO_APPLNAME - A pointer to a null-terminated character string used to identify the client application name sent to the host database server when using DB2 Connect.

Bilginize:

DB2 for z/OS and OS/390 servers support up to a length of 32 characters.

wrkstnname

SQL_ATTR_INFO_WRKSTNNAME - A pointer to a null-terminated character string used to identify the client workstation name sent to the host database server when using DB2 Connect.

Bilginize:

DB2 for z/OS and OS/390 servers support up to a length of 18 characters.

type

An integer value that specifies the type of resource that was passed into the function. The type of resource and this value must correspond.

Passing 1 as the value specifies that a connection resource has been passed into the function.

Passing any integer not equal to 1 as the value specifies that a statement resource has been passed into the function.

The following table specifies which options are compatible with the available resource types:

Resource-Parameter Matrix
Key | Value | Resource Type
 |  | Connection | Statement | Result Set
autocommit | DB2_AUTOCOMMIT_ON | X | - | -
autocommit | DB2_AUTOCOMMIT_OFF | X | - | -
cursor | DB2_SCROLLABLE | - | X | -
cursor | DB2_FORWARD_ONLY | - | X | -
binmode | DB2_BINARY | X | X | -
binmode | DB2_CONVERT | X | X | -
binmode | DB2_PASSTHRU | X | X | -
db2_attr_case | DB2_CASE_LOWER | X | X | -
db2_attr_case | DB2_CASE_UPPER | X | X | -
db2_attr_case | DB2_CASE_NATURAL | X | X | -
deferred_prepare | DB2_DEFERRED_PREPARE_ON | - | X | -
deferred_prepare | DB2_DEFERRED_PREPARE_OFF | - | X | -
i5_fetch_only | DB2_I5_FETCH_ON | - | X | -
i5_fetch_only | DB2_I5_FETCH_OFF | - | X | -
rowcount | DB2_ROWCOUNT_PREFETCH_ON | - | X | -
rowcount | DB2_ROWCOUNT_PREFETCH_OFF | - | X | -
trusted_user | <USER NAME> (String) | X | - | -
trusted_password | <PASSWORD> (String) | X | - | -
userid | SQL_ATTR_INFO_USERID | X | X | -
acctstr | SQL_ATTR_INFO_ACCTSTR | X | X | -
applname | SQL_ATTR_INFO_APPLNAME | X | X | -
wrkstnname | SQL_ATTR_INFO_WRKSTNNAME | X | X | -

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Setting one parameter with a connection resource

<?php
/* Database Connection Parameters */
$database = 'SAMPLE';
$hostname = 'localhost';
$port = 50000;
$protocol = 'TCPIP';
$username = 'db2inst1';
$password = 'ibmdb2';

/* Connection String */
$conn_string = "DRIVER={IBM DB2 ODBC DRIVER};DATABASE=$database;";
$conn_string .= "HOSTNAME=$hostname;PORT=$port;PROTOCOL=$protocol;";
$conn_string .= "UID=$username;PWD=$password;";

/* Obtain Connection Resource */
$conn = db2_connect($conn_string, '', '');

/* Create the associative options array with valid key-value pairs */
$options = array('autocommit' => DB2_AUTOCOMMIT_ON);

/* Call the function using the correct resource, options array, and type values */
$result = db2_set_option($conn, $options, 1);

/* Check if all options could be set correctly */
if($result)
{
  echo 'Options Set Successfully';
}
else
{
  echo 'Could Not Set Options';
}
?>

Yukarıdaki örneğin çıktısı:

Options Set Successfully

Örnek 2 Setting multiple parameters with a connection resource

<?php
/* Database Connection Parameters */
$database = 'SAMPLE';
$hostname = 'localhost';
$port = 50000;
$protocol = 'TCPIP';
$username = 'db2inst1';
$password = 'ibmdb2';

/* Connection String */
$conn_string = "DRIVER={IBM DB2 ODBC DRIVER};DATABASE=$database;";
$conn_string .= "HOSTNAME=$hostname;PORT=$port;PROTOCOL=$protocol;";
$conn_string .= "UID=$username;PWD=$password;";

/* Obtain Connection Resource */
$conn = db2_connect($conn_string, '', '');

/* Create the associative options array with valid key-value pairs */
$options = array('autocommit' => DB2_AUTOCOMMIT_OFF,
                    'binmode' => DB2_PASSTHRU,
              'db2_attr_case' => DB2_CASE_UPPER,
                     'cursor' => DB2_SCROLLABLE);

/* Call the function using the correct resource, options array, and type values */
$result = db2_set_option($conn, $options, 1);

/* Check if all options could be set correctly */
if($result)
{
  echo 'Options Set Successfully';
}
else
{
  echo 'Could Not Set Options';
}
?>

Yukarıdaki örneğin çıktısı:

Options Set Successfully

Örnek 3 Setting multiple parameters with an invalid key

<?php
/* Database Connection Parameters */
$database = 'SAMPLE';
$hostname = 'localhost';
$port = 50000;
$protocol = 'TCPIP';
$username = 'db2inst1';
$password = 'ibmdb2';

/* Connection String */
$conn_string = "DRIVER={IBM DB2 ODBC DRIVER};DATABASE=$database;";
$conn_string .= "HOSTNAME=$hostname;PORT=$port;PROTOCOL=$protocol;";
$conn_string .= "UID=$username;PWD=$password;";

/* Obtain Connection Resource */
$conn = db2_connect($conn_string, '', '');

/* Create the associative options array with valid key-value pairs */
$options = array('autocommit' => DB2_AUTOCOMMIT_OFF,
             'MY_INVALID_KEY' => DB2_PASSTHRU,
              'db2_attr_case' => DB2_CASE_UPPER,
                     'cursor' => DB2_SCROLLABLE);

/* Call the function using the correct resource, options array, and type values */
$result = db2_set_option($conn, $options, 1);

/* Check if all options could be set correctly */
if($result)
{
  echo 'Options Set Successfully';
}
else
{
  echo 'Could Not Set Options';
}
?>

Yukarıdaki örneğin çıktısı:

Could Not Set Options

Örnek 4 Setting multiple parameters with an invalid value

<?php
/* Database Connection Parameters */
$database = 'SAMPLE';
$hostname = 'localhost';
$port = 50000;
$protocol = 'TCPIP';
$username = 'db2inst1';
$password = 'ibmdb2';

/* Connection String */
$conn_string = "DRIVER={IBM DB2 ODBC DRIVER};DATABASE=$database;";
$conn_string .= "HOSTNAME=$hostname;PORT=$port;PROTOCOL=$protocol;";
$conn_string .= "UID=$username;PWD=$password;";

/* Obtain Connection Resource */
$conn = db2_connect($conn_string, '', '');

/* Create the associative options array with valid key-value pairs */
$options = array('autocommit' => DB2_AUTOCOMMIT_OFF,
                    'binmode' => 'INVALID_VALUE',
              'db2_attr_case' => DB2_CASE_UPPER,
                     'cursor' => DB2_SCROLLABLE);

/* Call the function using the correct resource, options array, and type values */
$result = db2_set_option($conn, $options, 1);

/* Check if all options could be set correctly */
if($result)
{
  echo 'Options Set Successfully';
}
else
{
  echo 'Could Not Set Options';
}
?>

Yukarıdaki örneğin çıktısı:

Could Not Set Options

Örnek 5 Setting multiple parameters with a connection resource and the wrong type

<?php
/* Database Connection Parameters */
$database = 'SAMPLE';
$hostname = 'localhost';
$port = 50000;
$protocol = 'TCPIP';
$username = 'db2inst1';
$password = 'ibmdb2';

/* Connection String */
$conn_string = "DRIVER={IBM DB2 ODBC DRIVER};DATABASE=$database;";
$conn_string .= "HOSTNAME=$hostname;PORT=$port;PROTOCOL=$protocol;";
$conn_string .= "UID=$username;PWD=$password;";

/* Obtain Connection Resource */
$conn = db2_connect($conn_string, '', '');

/* Create the associative options array with valid key-value pairs */
$options = array('autocommit' => DB2_AUTOCOMMIT_OFF,
                    'binmode' => DB2_PASSTHRU,
              'db2_attr_case' => DB2_CASE_UPPER,
                     'cursor' => DB2_SCROLLABLE);

/* Call the function using the correct resource, options array, and the wrong type value */
$result = db2_set_option($conn, $options, 2);

/* Check if all options could be set correctly */
if($result)
{
  echo 'Options Set Successfully';
}
else
{
  echo 'Could Not Set Options';
}
?>

Yukarıdaki örneğin çıktısı:

Could Not Set Options

Örnek 6 Setting multiple parameters with the wrong resource

<?php
/* Database Connection Parameters */
$database = 'SAMPLE';
$hostname = 'localhost';
$port = 50000;
$protocol = 'TCPIP';
$username = 'db2inst1';
$password = 'ibmdb2';

/* Connection String */
$conn_string = "DRIVER={IBM DB2 ODBC DRIVER};DATABASE=$database;";
$conn_string .= "HOSTNAME=$hostname;PORT=$port;PROTOCOL=$protocol;";
$conn_string .= "UID=$username;PWD=$password;";

/* Obtain Connection Resource */
$conn = db2_connect($conn_string, '', '');

/* Create the associative options array with valid key-value pairs */
$options = array('autocommit' => DB2_AUTOCOMMIT_OFF,
                    'binmode' => DB2_PASSTHRU,
              'db2_attr_case' => DB2_CASE_UPPER,
                     'cursor' => DB2_SCROLLABLE);

$stmt = db2_prepare($conn, 'SELECT * FROM EMPLOYEE');

/* Call the function using the wrong resource, and the correct options array, and type values */
$result = db2_set_option($stmt, $options, 1);

/* Check if all options could be set correctly */
if($result)
{
  echo 'Options Set Successfully';
}
else
{
  echo 'Could Not Set Options';
}
?>

Yukarıdaki örneğin çıktısı:

Could Not Set Options

Örnek 7 Putting it all together

<?php
/* Database Connection Parameters */
$database = 'SAMPLE';
$hostname = 'localhost';
$port = 50000;
$protocol = 'TCPIP';
$username = 'db2inst1';
$password = 'ibmdb2';

/* Connection String */
$conn_string = "DRIVER={IBM DB2 ODBC DRIVER};DATABASE=$database;";
$conn_string .= "HOSTNAME=$hostname;PORT=$port;PROTOCOL=$protocol;";
$conn_string .= "UID=$username;PWD=$password;";

/* Obtain Connection Resource */
$conn = db2_connect($conn_string, '', '');

/* Create the associative options array with valid key-value pairs */
$options = array('db2_attr_case' => DB2_CASE_LOWER,
                        'cursor' => DB2_SCROLLABLE);

$stmt = db2_prepare($conn, 'SELECT * FROM EMPLOYEE WHERE EMPNO = ? OR EMPNO = ?');

/* Call the function using the correct resource, options array, and type values */
$option_result = db2_set_option($stmt, $options, 2);
$result = db2_execute($stmt, array('000130', '000140'));

/* Get Row 2 before Row 1 since Scrollable Cursor */
print_r(db2_fetch_assoc($stmt, 2));
print '<br /><br />';
print_r(db2_fetch_assoc($stmt, 1));

?>

Yukarıdaki örneğin çıktısı:

Array
(
    [empno] => 000140
    [firstnme] => HEATHER
    [midinit] => A
    [lastname] => NICHOLLS
    [workdept] => C01
    [phoneno] => 1793
    [hiredate] => 1976-12-15
    [job] => ANALYST
    [edlevel] => 18
    [sex] => F
    [birthdate] => 1946-01-19
    [salary] => 28420.00
    [bonus] => 600.00
    [comm] => 2274.00
)

Array
(
    [empno] => 000130
    [firstnme] => DELORES
    [midinit] => M
    [lastname] => QUINTANA
    [workdept] => C01
    [phoneno] => 4578
    [hiredate] => 1971-07-28
    [job] => ANALYST
    [edlevel] => 16
    [sex] => F
    [birthdate] => 1925-09-15
    [salary] => 23800.00
    [bonus] => 500.00
    [comm] => 1904.00
)

Örnek 8 i5/OS cursors are read-only

<?php
  $conn = db2_connect("", "", "", array("i5_lib"=>"nobody"));
  $stmt = db2_prepare($conn, 'select * from names where first = ?');
  $name = "first2";
  db2_bind_param($stmt, 1, "name", DB2_PARAM_IN);
  $options = array("i5_fetch_only"=>DB2_I5_FETCH_ON);
  db2_set_option($stmt,$options,0);
  if (db2_execute($stmt)) {
    while ($row = db2_fetch_array($stmt)) {
      echo "{$row[0]} {$row[1]}";
    }
  }
?>

Yukarıdaki örneğin çıktısı:

first2 last2

Ayrıca Bakınız

  • db2_connect() - Returns a connection to a database
  • db2_pconnect() - Returns a persistent connection to a database
  • db2_exec() - Executes an SQL statement directly
  • db2_prepare() - Prepares an SQL statement to be executed
  • db2_cursor_type() - Returns the cursor type used by a statement resource

db2_server_info
db2_special_columns
IBM DB2 İşlevleri


Returns a result set listing the unique row identifier columns for a table

db2_set_option
db2_statistics
IBM DB2 İşlevleri
PHP Manual

db2_special_columns

(PECL ibm_db2 >= 1.0.0)

db2_special_columns — Returns a result set listing the unique row identifier columns for a table

Açıklama

resource db2_special_columns ( resource $connection , string $qualifier , string $schema , string $table_name , int $scope )

Returns a result set listing the unique row identifier columns for a table.

Değiştirgeler

connection

A valid connection to an IBM DB2, Cloudscape, or Apache Derby database.

qualifier

A qualifier for DB2 databases running on OS/390 or z/OS servers. For other databases, pass NULL or an empty string.

schema

The schema which contains the tables.

table_name

The name of the table.

scope

Integer value representing the minimum duration for which the unique row identifier is valid. This can be one of the following values:

Integer value | SQL constant | Description
0 | SQL_SCOPE_CURROW | Row identifier is valid only while the cursor is positioned on the row.
1 | SQL_SCOPE_TRANSACTION | Row identifier is valid for the duration of the transaction.
2 | SQL_SCOPE_SESSION | Row identifier is valid for the duration of the connection.

Dönen Değerler

Returns a statement resource with a result set containing rows with unique row identifier information for a table. The rows are composed of the following columns:

Column name | Description
SCOPE

Integer value | SQL constant | Description
0 | SQL_SCOPE_CURROW | Row identifier is valid only while the cursor is positioned on the row.
1 | SQL_SCOPE_TRANSACTION | Row identifier is valid for the duration of the transaction.
2 | SQL_SCOPE_SESSION | Row identifier is valid for the duration of the connection.
COLUMN_NAME | Name of the unique column.
DATA_TYPE | SQL data type for the column.
TYPE_NAME | Character string representation of the SQL data type for the column.
COLUMN_SIZE | An integer value representing the size of the column.
BUFFER_LENGTH | Maximum number of bytes necessary to store data from this column.
DECIMAL_DIGITS | The scale of the column, or NULL where scale is not applicable.
NUM_PREC_RADIX | An integer value of either 10 (representing an exact numeric data type), 2 (representing an approximate numeric data type), or NULL (representing a data type for which radix is not applicable).
PSEUDO_COLUMN | Always returns 1.

Ayrıca Bakınız

  • db2_column_privileges() - Returns a result set listing the columns and associated privileges for a table
  • db2_columns() - Returns a result set listing the columns and associated metadata for a table
  • db2_foreign_keys() - Returns a result set listing the foreign keys for a table
  • db2_primary_keys() - Returns a result set listing primary keys for a table
  • db2_procedure_columns() - Returns a result set listing stored procedure parameters
  • db2_procedures() - Returns a result set listing the stored procedures registered in a database
  • db2_statistics() - Returns a result set listing the index and statistics for a table
  • db2_table_privileges() - Returns a result set listing the tables and associated privileges in a database
  • db2_tables() - Returns a result set listing the tables and associated metadata in a database

db2_set_option
db2_statistics
IBM DB2 İşlevleri


Returns a result set listing the index and statistics for a table

db2_special_columns
db2_stmt_error
IBM DB2 İşlevleri
PHP Manual

db2_statistics

(PECL ibm_db2 >= 1.0.0)

db2_statistics — Returns a result set listing the index and statistics for a table

Açıklama

resource db2_statistics ( resource $connection , string $qualifier , string $schema , string $table-name , bool $unique )

Returns a result set listing the index and statistics for a table.

Değiştirgeler

connection

A valid connection to an IBM DB2, Cloudscape, or Apache Derby database.

qualifier

A qualifier for DB2 databases running on OS/390 or z/OS servers. For other databases, pass NULL or an empty string.

schema

The schema that contains the targeted table. If this parameter is NULL, the statistics and indexes are returned for the schema of the current user.

table_name

The name of the table.

unique

An integer value representing the type of index information to return.

0

Return only the information for unique indexes on the table.

1

Return the information for all indexes on the table.

Dönen Değerler

Returns a statement resource with a result set containing rows describing the statistics and indexes for the base tables matching the specified parameters. The rows are composed of the following columns:

Column name | Description
TABLE_CAT | The catalog that contains the table. The value is NULL if this table does not have catalogs.
TABLE_SCHEM | Name of the schema that contains the table.
TABLE_NAME | Name of the table.
NON_UNIQUE

An integer value representing whether the index prohibits unique values, or whether the row represents statistics on the table itself:

Return value | Parameter type
0 (SQL_FALSE) | The index allows duplicate values.
1 (SQL_TRUE) | The index values must be unique.
NULL | This row is statistics information for the table itself.
INDEX_QUALIFIER | A string value representing the qualifier that would have to be prepended to INDEX_NAME to fully qualify the index.
INDEX_NAME | A string representing the name of the index.
TYPE

An integer value representing the type of information contained in this row of the result set:

Return value | Parameter type
0 (SQL_TABLE_STAT) | The row contains statistics about the table itself.
1 (SQL_INDEX_CLUSTERED) | The row contains information about a clustered index.
2 (SQL_INDEX_HASH) | The row contains information about a hashed index.
3 (SQL_INDEX_OTHER) | The row contains information about a type of index that is neither clustered nor hashed.
ORDINAL_POSITION | The 1-indexed position of the column in the index. NULL if the row contains statistics information about the table itself.
COLUMN_NAME | The name of the column in the index. NULL if the row contains statistics information about the table itself.
ASC_OR_DESC | A if the column is sorted in ascending order, D if the column is sorted in descending order, NULL if the row contains statistics information about the table itself.
CARDINALITY

If the row contains information about an index, this column contains an integer value representing the number of unique values in the index.

If the row contains information about the table itself, this column contains an integer value representing the number of rows in the table.

PAGES

If the row contains information about an index, this column contains an integer value representing the number of pages used to store the index.

If the row contains information about the table itself, this column contains an integer value representing the number of pages used to store the table.

FILTER_CONDITION | Always returns NULL.

Ayrıca Bakınız

  • db2_column_privileges() - Returns a result set listing the columns and associated privileges for a table
  • db2_columns() - Returns a result set listing the columns and associated metadata for a table
  • db2_foreign_keys() - Returns a result set listing the foreign keys for a table
  • db2_primary_keys() - Returns a result set listing primary keys for a table
  • db2_procedure_columns() - Returns a result set listing stored procedure parameters
  • db2_procedures() - Returns a result set listing the stored procedures registered in a database
  • db2_special_columns() - Returns a result set listing the unique row identifier columns for a table
  • db2_table_privileges() - Returns a result set listing the tables and associated privileges in a database
  • db2_tables() - Returns a result set listing the tables and associated metadata in a database

db2_special_columns
db2_stmt_error
IBM DB2 İşlevleri


Returns a string containing the SQLSTATE returned by an SQL statement

db2_statistics
db2_stmt_errormsg
IBM DB2 İşlevleri
PHP Manual

db2_stmt_error

(PECL ibm_db2 >= 1.0.0)

db2_stmt_error — Returns a string containing the SQLSTATE returned by an SQL statement

Açıklama

string db2_stmt_error ([ resource $stmt ] )

Returns a string containing the SQLSTATE value returned by an SQL statement.

If you do not pass a statement resource as an argument to db2_stmt_error(), the driver returns the SQLSTATE value associated with the last attempt to return a statement resource, for example, from db2_prepare() or db2_exec().

To learn what the SQLSTATE value means, you can issue the following command at a DB2 Command Line Processor prompt: db2 '? sqlstate-value'. You can also call db2_stmt_errormsg() to retrieve an explicit error message and the associated SQLCODE value.

Değiştirgeler

stmt

A valid statement resource.

Dönen Değerler

Returns a string containing an SQLSTATE value.

Ayrıca Bakınız

  • db2_conn_error() - Returns a string containing the SQLSTATE returned by the last connection attempt
  • db2_conn_errormsg() - Returns the last connection error message and SQLCODE value
  • db2_stmt_errormsg() - Returns a string containing the last SQL statement error message

db2_statistics
db2_stmt_errormsg
IBM DB2 İşlevleri


Returns a string containing the last SQL statement error message

db2_stmt_error
db2_table_privileges
IBM DB2 İşlevleri
PHP Manual

db2_stmt_errormsg

(PECL ibm_db2 >= 1.0.0)

db2_stmt_errormsg — Returns a string containing the last SQL statement error message

Açıklama

string db2_stmt_errormsg ([ resource $stmt ] )

Returns a string containing the last SQL statement error message.

If you do not pass a statement resource as an argument to db2_stmt_errormsg(), the driver returns the error message associated with the last attempt to return a statement resource, for example, from db2_prepare() or db2_exec().

Değiştirgeler

stmt

A valid statement resource.

Dönen Değerler

Returns a string containing the error message and SQLCODE value for the last error that occurred issuing an SQL statement.

Ayrıca Bakınız

  • db2_conn_error() - Returns a string containing the SQLSTATE returned by the last connection attempt
  • db2_conn_errormsg() - Returns the last connection error message and SQLCODE value
  • db2_stmt_error() - Returns a string containing the SQLSTATE returned by an SQL statement

db2_stmt_error
db2_table_privileges
IBM DB2 İşlevleri


Returns a result set listing the tables and associated privileges in a database

db2_stmt_errormsg
db2_tables
IBM DB2 İşlevleri
PHP Manual

db2_table_privileges

(PECL ibm_db2 >= 1.0.0)

db2_table_privileges — Returns a result set listing the tables and associated privileges in a database

Açıklama

resource db2_table_privileges ( resource $connection [, string $qualifier [, string $schema [, string $table_name ]]] )

Returns a result set listing the tables and associated privileges in a database.

Değiştirgeler

connection

A valid connection to an IBM DB2, Cloudscape, or Apache Derby database.

qualifier

A qualifier for DB2 databases running on OS/390 or z/OS servers. For other databases, pass NULL or an empty string.

schema

The schema which contains the tables. This parameter accepts a search pattern containing _ and % as wildcards.

table_name

The name of the table. This parameter accepts a search pattern containing _ and % as wildcards.

Dönen Değerler

Returns a statement resource with a result set containing rows describing the privileges for the tables that match the specified parameters. The rows are composed of the following columns:

Column name | Description
TABLE_CAT | The catalog that contains the table. The value is NULL if this table does not have catalogs.
TABLE_SCHEM | Name of the schema that contains the table.
TABLE_NAME | Name of the table.
GRANTOR | Authorization ID of the user who granted the privilege.
GRANTEE | Authorization ID of the user to whom the privilege was granted.
PRIVILEGE | The privilege that has been granted. This can be one of ALTER, CONTROL, DELETE, INDEX, INSERT, REFERENCES, SELECT, or UPDATE.
IS_GRANTABLE | A string value of "YES" or "NO" indicating whether the grantee can grant the privilege to other users.

Ayrıca Bakınız

  • db2_column_privileges() - Returns a result set listing the columns and associated privileges for a table
  • db2_columns() - Returns a result set listing the columns and associated metadata for a table
  • db2_foreign_keys() - Returns a result set listing the foreign keys for a table
  • db2_primary_keys() - Returns a result set listing primary keys for a table
  • db2_procedure_columns() - Returns a result set listing stored procedure parameters
  • db2_procedures() - Returns a result set listing the stored procedures registered in a database
  • db2_special_columns() - Returns a result set listing the unique row identifier columns for a table
  • db2_statistics() - Returns a result set listing the index and statistics for a table
  • db2_tables() - Returns a result set listing the tables and associated metadata in a database

db2_stmt_errormsg
db2_tables
IBM DB2 İşlevleri


Returns a result set listing the tables and associated metadata in a database

db2_table_privileges
Informix
IBM DB2 İşlevleri
PHP Manual

db2_tables

(PECL ibm_db2 >= 1.0.0)

db2_tables — Returns a result set listing the tables and associated metadata in a database

Açıklama

resource db2_tables ( resource $connection [, string $qualifier [, string $schema [, string $table-name [, string $table-type ]]]] )

Returns a result set listing the tables and associated metadata in a database.

Değiştirgeler

connection

A valid connection to an IBM DB2, Cloudscape, or Apache Derby database.

qualifier

A qualifier for DB2 databases running on OS/390 or z/OS servers. For other databases, pass NULL or an empty string.

schema

The schema which contains the tables. This parameter accepts a search pattern containing _ and % as wildcards.

table-name

The name of the table. This parameter accepts a search pattern containing _ and % as wildcards.

table-type

A list of comma-delimited table type identifiers. To match all table types, pass NULL or an empty string. Valid table type identifiers include: ALIAS, HIERARCHY TABLE, INOPERATIVE VIEW, NICKNAME, MATERIALIZED QUERY TABLE, SYSTEM TABLE, TABLE, TYPED TABLE, TYPED VIEW, and VIEW.

Dönen Değerler

Returns a statement resource with a result set containing rows describing the tables that match the specified parameters. The rows are composed of the following columns:

Column name | Description
TABLE_CAT | The catalog that contains the table. The value is NULL if this table does not have catalogs.
TABLE_SCHEM | Name of the schema that contains the table.
TABLE_NAME | Name of the table.
TABLE_TYPE | Table type identifier for the table.
REMARKS | Description of the table.

Ayrıca Bakınız

  • db2_column_privileges() - Returns a result set listing the columns and associated privileges for a table
  • db2_columns() - Returns a result set listing the columns and associated metadata for a table
  • db2_foreign_keys() - Returns a result set listing the foreign keys for a table
  • db2_primary_keys() - Returns a result set listing primary keys for a table
  • db2_procedure_columns() - Returns a result set listing stored procedure parameters
  • db2_procedures() - Returns a result set listing the stored procedures registered in a database
  • db2_special_columns() - Returns a result set listing the unique row identifier columns for a table
  • db2_statistics() - Returns a result set listing the index and statistics for a table
  • db2_table_privileges() - Returns a result set listing the tables and associated privileges in a database

db2_table_privileges
Informix
IBM DB2 İşlevleri


Informix

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Informix İşlevleri
    • ifx_affected_rows — Get number of rows affected by a query
    • ifx_blobinfile_mode — Set the default blob mode for all select queries
    • ifx_byteasvarchar — Set the default byte mode
    • ifx_close — Close Informix connection
    • ifx_connect — Open Informix server connection
    • ifx_copy_blob — Duplicates the given blob object
    • ifx_create_blob — Creates an blob object
    • ifx_create_char — Creates an char object
    • ifx_do — Execute a previously prepared SQL-statement
    • ifx_error — Returns error code of last Informix call
    • ifx_errormsg — Returns error message of last Informix call
    • ifx_fetch_row — Get row as an associative array
    • ifx_fieldproperties — List of SQL fieldproperties
    • ifx_fieldtypes — List of Informix SQL fields
    • ifx_free_blob — Deletes the blob object
    • ifx_free_char — Deletes the char object
    • ifx_free_result — Releases resources for the query
    • ifx_get_blob — Return the content of a blob object
    • ifx_get_char — Return the content of the char object
    • ifx_getsqlca — Get the contents of sqlca.sqlerrd[0..5] after a query
    • ifx_htmltbl_result — Formats all rows of a query into a HTML table
    • ifx_nullformat — Sets the default return value on a fetch row
    • ifx_num_fields — Returns the number of columns in the query
    • ifx_num_rows — Count the rows already fetched from a query
    • ifx_pconnect — Open persistent Informix connection
    • ifx_prepare — Prepare an SQL-statement for execution
    • ifx_query — Send Informix query
    • ifx_textasvarchar — Set the default text mode
    • ifx_update_blob — Updates the content of the blob object
    • ifx_update_char — Updates the content of the char object
    • ifxus_close_slob — Deletes the slob object
    • ifxus_create_slob — Creates an slob object and opens it
    • ifxus_free_slob — Deletes the slob object
    • ifxus_open_slob — Opens an slob object
    • ifxus_read_slob — Reads nbytes of the slob object
    • ifxus_seek_slob — Sets the current file or seek position
    • ifxus_tell_slob — Returns the current file or seek position
    • ifxus_write_slob — Writes a string into the slob object
db2_tables
Giriş
Sağlayıcıya Göre Veritabanı Eklentileri


Giriş

The Informix driver for Informix (IDS) 7.x, SE 7.x, Universal Server (IUS) 9.x and IDS 2000 is implemented in "ifx.ec" and "php_informix.h" in the informix extension directory. IDS 7.x support is fairly complete, with full support for BYTE and TEXT columns. IUS 9.x support is partly finished: the new data types are there, but SLOB and CLOB support is still under construction.

Bilginize:

Bu eklenti » PECL deposuna taşınmış olup şu sürümden itibaren PHP kaynak paketinde dağıtılmamaktatır: PHP 5.2.1.

Informix
Yapılandırma/Kurulum
Informix


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Informix


Gereksinimler

Bilginize: Configuration notes

You need a version of ESQL/C to compile the PHP Informix driver. ESQL/C versions from 7.2x on should be OK. ESQL/C is now part of the Informix Client SDK.

Make sure that the "INFORMIXDIR" variable has been set, and that $INFORMIXDIR/bin is in your PATH before you run the "configure" script.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

To be able to use the functions defined in this module you must compile your PHP interpreter using the configure line --with-informix[=DIR] , where DIR is the Informix base install directory, defaults to nothing.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Bilginize:

Make sure that the Informix environment variables INFORMIXDIR and INFORMIXSERVER are available to the PHP ifx driver, and that the INFORMIX bin directory is in the PATH. Check this by running a script that contains a call to phpinfo() before you start testing. The phpinfo() output should list these environment variables. This is true for both CGI php and Apache mod_php. You may have to set these environment variables in your Apache startup script.

The Informix shared libraries should also be available to the loader (check LD_LIBRARY_PATH or ld.so.conf/ldconfig).

Bilginize: Some notes on the use of BLOBs (TEXT and BYTE columns)

BLOBs are normally addressed by BLOB identifiers. Select queries return a "blob id" for every BYTE and TEXT column. You can get at the contents with "string_var = ifx_get_blob($blob_id);" if you choose to get the BLOBs in memory (with: "ifx_blobinfile(0);"). If you prefer to receive the content of BLOB columns in a file, use "ifx_blobinfile(1);", and "ifx_get_blob($blob_id);" will get you the filename. Use normal file I/O to get at the blob contents.

For insert/update queries you must create these "blob id's" yourself with "ifx_create_blob();". You then plug the blob id's into an array, and replace the blob columns with a question mark (?) in the query string. For updates/inserts, you are responsible for setting the blob contents with ifx_update_blob().

The behaviour of BLOB columns can be altered by configuration variables that also can be set at runtime:

configuration variable: ifx.textasvarchar

configuration variable: ifx.byteasvarchar

runtime functions:

ifx_textasvarchar(0): use blob id's for select queries with TEXT columns

ifx_byteasvarchar(0): use blob id's for select queries with BYTE columns

ifx_textasvarchar(1): return TEXT columns as if they were VARCHAR columns, so that you don't need to use blob id's for select queries.

ifx_byteasvarchar(1): return BYTE columns as if they were VARCHAR columns, so that you don't need to use blob id's for select queries.

configuration variable: ifx.blobinfile

runtime function:

ifx_blobinfile_mode(0): return BYTE columns in memory, the blob id lets you get at the contents.

ifx_blobinfile_mode(1): return BYTE columns in a file, the blob id lets you get at the file name.

If you set ifx_text/byteasvarchar to 1, you can use TEXT and BYTE columns in select queries just like normal (but rather long) VARCHAR fields. Since all strings are "counted" in PHP, this remains "binary safe". It is up to you to handle this correctly. The returned data can contain anything, you are responsible for the contents.

If you set ifx_blobinfile to 1, use the file name returned by ifx_get_blob(..) to get at the blob contents. Note that in this case YOU ARE RESPONSIBLE FOR DELETING THE TEMPORARY FILES CREATED BY INFORMIX when fetching the row. Every new row fetched will create new temporary files for every BYTE column.

The location of the temporary files can be influenced by the environment variable "blobdir", default is "." (the current directory). Something like: putenv(blobdir=tmpblob"); will ease the cleaning up of temp files accidentally left behind (their names all start with "blb").

Bilginize: Automatically trimming "char" (SQLCHAR and SQLNCHAR) data

This can be set with the configuration variable

ifx.charasvarchar: if set to 1 trailing spaces will be automatically trimmed, to save you some "chopping".

Bilginize: NULL values

The configuration variable ifx.nullformat (and the runtime function ifx_nullformat()) when set to TRUE will return NULL columns as the string "NULL", when set to FALSE they return the empty string. This allows you to discriminate between NULL columns and empty columns.

Informix configuration options
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
ifx.allow_persistent | "1" | PHP_INI_SYSTEM | Removed in PHP 5.2.1.
ifx.max_persistent | "-1" | PHP_INI_SYSTEM | Removed in PHP 5.2.1.
ifx.max_links | "-1" | PHP_INI_SYSTEM | Removed in PHP 5.2.1.
ifx.default_host | NULL | PHP_INI_SYSTEM | Removed in PHP 5.2.1.
ifx.default_user | NULL | PHP_INI_SYSTEM | Removed in PHP 5.2.1.
ifx.default_password | NULL | PHP_INI_SYSTEM | Removed in PHP 5.2.1.
ifx.blobinfile | "1" | PHP_INI_ALL | Removed in PHP 5.2.1.
ifx.textasvarchar | "0" | PHP_INI_ALL | Removed in PHP 5.2.1.
ifx.byteasvarchar | "0" | PHP_INI_ALL | Removed in PHP 5.2.1.
ifx.charasvarchar | "0" | PHP_INI_ALL | Removed in PHP 5.2.1.
ifx.nullformat | "0" | PHP_INI_ALL | Removed in PHP 5.2.1.
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

ifx.allow_persistent boolean

Whether to allow persistent Informix connections.

ifx.max_persistent integer

The maximum number of persistent Informix connections per process.

ifx.max_links integer

The maximum number of Informix connections per process, including persistent connections.

ifx.default_host string

The default host to connect to when no host is specified in ifx_connect() or ifx_pconnect(). Doesn't apply in safe_mode.

ifx.default_user string

The default user id to use when none is specified in ifx_connect() or ifx_pconnect(). Doesn't apply in safe_mode.

ifx.default_password string

The default password to use when none is specified in ifx_connect() or ifx_pconnect(). Doesn't apply in safe_mode.

ifx.blobinfile boolean

Set to TRUE if you want to return blob columns in a file, FALSE if you want them in memory. You can override the setting at runtime with ifx_blobinfile_mode().

ifx.textasvarchar boolean

Set to TRUE if you want to return TEXT columns as normal strings in select statements, FALSE if you want to use blob id parameters. You can override the setting at runtime with ifx_textasvarchar().

ifx.byteasvarchar boolean

Set to TRUE if you want to return BYTE columns as normal strings in select queries, FALSE if you want to use blob id parameters. You can override the setting at runtime with ifx_textasvarchar().

ifx.charasvarchar boolean

Set to TRUE if you want to trim trailing spaces from CHAR columns when fetching them.

ifx.nullformat boolean

Set to TRUE if you want to return NULL columns as the literal string "NULL", FALSE if you want them returned as the empty string "". You can override this setting at runtime with ifx_nullformat().

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

IFX_SCROLL (integer)
IFX_HOLD (integer)
IFX_LO_RDONLY (integer)
IFX_LO_WRONLY (integer)
IFX_LO_APPEND (integer)
IFX_LO_RDWR (integer)
IFX_LO_BUFFER (integer)
IFX_LO_NOBUFFER (integer)
Özkaynak Türleri
Informix İşlevleri
Informix


Informix İşlevleri

İçindekiler

  • ifx_affected_rows — Get number of rows affected by a query
  • ifx_blobinfile_mode — Set the default blob mode for all select queries
  • ifx_byteasvarchar — Set the default byte mode
  • ifx_close — Close Informix connection
  • ifx_connect — Open Informix server connection
  • ifx_copy_blob — Duplicates the given blob object
  • ifx_create_blob — Creates an blob object
  • ifx_create_char — Creates an char object
  • ifx_do — Execute a previously prepared SQL-statement
  • ifx_error — Returns error code of last Informix call
  • ifx_errormsg — Returns error message of last Informix call
  • ifx_fetch_row — Get row as an associative array
  • ifx_fieldproperties — List of SQL fieldproperties
  • ifx_fieldtypes — List of Informix SQL fields
  • ifx_free_blob — Deletes the blob object
  • ifx_free_char — Deletes the char object
  • ifx_free_result — Releases resources for the query
  • ifx_get_blob — Return the content of a blob object
  • ifx_get_char — Return the content of the char object
  • ifx_getsqlca — Get the contents of sqlca.sqlerrd[0..5] after a query
  • ifx_htmltbl_result — Formats all rows of a query into a HTML table
  • ifx_nullformat — Sets the default return value on a fetch row
  • ifx_num_fields — Returns the number of columns in the query
  • ifx_num_rows — Count the rows already fetched from a query
  • ifx_pconnect — Open persistent Informix connection
  • ifx_prepare — Prepare an SQL-statement for execution
  • ifx_query — Send Informix query
  • ifx_textasvarchar — Set the default text mode
  • ifx_update_blob — Updates the content of the blob object
  • ifx_update_char — Updates the content of the char object
  • ifxus_close_slob — Deletes the slob object
  • ifxus_create_slob — Creates an slob object and opens it
  • ifxus_free_slob — Deletes the slob object
  • ifxus_open_slob — Opens an slob object
  • ifxus_read_slob — Reads nbytes of the slob object
  • ifxus_seek_slob — Sets the current file or seek position
  • ifxus_tell_slob — Returns the current file or seek position
  • ifxus_write_slob — Writes a string into the slob object
Öntanımlı Sabitler
ifx_affected_rows
Informix


Get number of rows affected by a query

Informix İşlevleri
ifx_blobinfile_mode
Informix İşlevleri
PHP Manual

ifx_affected_rows

(PHP 4, PHP <=5.2.0)

ifx_affected_rows — Get number of rows affected by a query

Açıklama

int ifx_affected_rows ( resource $result_id )

Returns the number of rows affected by a query associated with result_id.

For inserts, updates and deletes the number is the real number (sqlerrd[2]) of affected rows. For selects it is an estimate (sqlerrd[0]). Don't rely on it. The database server can never return the actual number of rows that will be returned by a SELECT because it has not even begun fetching them at this stage (just after the "PREPARE" when the optimizer has determined the query plan).

Useful after ifx_prepare() to limit queries to reasonable result sets.

Değiştirgeler

result_id

A valid result id returned by ifx_query() or ifx_prepare().

Dönen Değerler

Returns the number of rows as an integer.

Örnekler

Örnek 1 Informix affected rows

<?php
$rid = ifx_prepare("select * from emp
                     where name like " . $name, $connid);
if (! $rid) {
    /* ... error ... */
}
$rowcount = ifx_affected_rows($rid);
if ($rowcount > 1000) {
    printf ("Too many rows in result set (%d)\n<br />", $rowcount);
    die ("Please restrict your query<br />\n");
}
?>

Ayrıca Bakınız

  • ifx_num_rows() - Count the rows already fetched from a query

Informix İşlevleri
ifx_blobinfile_mode
Informix İşlevleri


Set the default blob mode for all select queries

ifx_affected_rows
ifx_byteasvarchar
Informix İşlevleri
PHP Manual

ifx_blobinfile_mode

(PHP 4, PHP <=5.2.0)

ifx_blobinfile_mode — Set the default blob mode for all select queries

Açıklama

bool ifx_blobinfile_mode ( int $mode )

Set the default blob mode for all select queries.

Değiştirgeler

mode

Mode "0" means save Byte-Blobs in memory, and mode "1" means save Byte-Blobs in a file.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

ifx_affected_rows
ifx_byteasvarchar
Informix İşlevleri


Set the default byte mode

ifx_blobinfile_mode
ifx_close
Informix İşlevleri
PHP Manual

ifx_byteasvarchar

(PHP 4, PHP <=5.2.0)

ifx_byteasvarchar — Set the default byte mode

Açıklama

bool ifx_byteasvarchar ( int $mode )

Sets the default byte mode for all select-queries.

Değiştirgeler

mode

Mode "0" will return a blob id, and mode "1" will return a varchar with text content.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ifx_textasvarchar() - Set the default text mode

ifx_blobinfile_mode
ifx_close
Informix İşlevleri


Close Informix connection

ifx_byteasvarchar
ifx_connect
Informix İşlevleri
PHP Manual

ifx_close

(PHP 4, PHP <=5.2.0)

ifx_close — Close Informix connection

Açıklama

bool ifx_close ([ resource $link_identifier ] )

ifx_close() closes the link to an Informix database that's associated with the specified link identifier.

Note that this isn't usually necessary, as non-persistent open links are automatically closed at the end of the script's execution.

ifx_close() will not close persistent links generated by ifx_pconnect().

Değiştirgeler

link_identifier

The link identifier. If not specified, the last opened link is assumed.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Closing a Informix connection

<?php
$conn_id = ifx_connect ("mydb@ol_srv", "itsme", "mypassword");
/* ... some queries and stuff ... */
ifx_close($conn_id);
?>

Ayrıca Bakınız

  • ifx_connect() - Open Informix server connection
  • ifx_pconnect() - Open persistent Informix connection

ifx_byteasvarchar
ifx_connect
Informix İşlevleri


Open Informix server connection

ifx_close
ifx_copy_blob
Informix İşlevleri
PHP Manual

ifx_connect

(PHP 4, PHP <=5.2.0)

ifx_connect — Open Informix server connection

Açıklama

resource ifx_connect ([ string $database [, string $userid [, string $password ]]] )

ifx_connect() establishes a connection to an Informix server.

In case a second call is made to ifx_connect() with the same arguments, no new link will be established, but instead, the link identifier of the already opened link will be returned.

The link to the server will be closed as soon as the execution of the script ends, unless it's closed earlier by explicitly calling ifx_close().

Değiştirgeler

All of the arguments are optional, and if they're missing, defaults are taken from values supplied in php.ini (ifx.default_host for the host (Informix libraries will use INFORMIXSERVER environment value if not defined), ifx.default_user for user, ifx.default_password for the password (none if not defined).

database

The database name, as a string.

userid

The username, as a string.

password

The password, as a string.

Dönen Değerler

Returns a connection identifier on success, or FALSE on error.

Örnekler

Örnek 1 Connect to a Informix database

<?php
$conn_id = ifx_connect ("mydb@ol_srv1", "imyself", "mypassword");
?>

Ayrıca Bakınız

  • ifx_pconnect() - Open persistent Informix connection
  • ifx_close() - Close Informix connection

ifx_close
ifx_copy_blob
Informix İşlevleri


Duplicates the given blob object

ifx_connect
ifx_create_blob
Informix İşlevleri
PHP Manual

ifx_copy_blob

(PHP 4, PHP <=5.2.0)

ifx_copy_blob — Duplicates the given blob object

Açıklama

int ifx_copy_blob ( int $bid )

Duplicates the given blob object.

Değiştirgeler

bid

A BLOB identifier.

Dönen Değerler

Returns the new blob object-id, or FALSE on errors.

Ayrıca Bakınız

  • ifx_create_blob() - Creates an blob object
  • ifx_free_blob() - Deletes the blob object

ifx_connect
ifx_create_blob
Informix İşlevleri


Creates an blob object

ifx_copy_blob
ifx_create_char
Informix İşlevleri
PHP Manual

ifx_create_blob

(PHP 4, PHP <=5.2.0)

ifx_create_blob — Creates an blob object

Açıklama

int ifx_create_blob ( int $type , int $mode , string $param )

Creates a blob object.

Değiştirgeler

type

1 = TEXT, 0 = BYTE

mode

0 = blob-object holds the content in memory, 1 = blob-object holds the content in file.

param

if mode = 0: pointer to the content, if mode = 1: pointer to the filestring.

Dönen Değerler

Returns the new BLOB object-id, or FALSE on errors.

Ayrıca Bakınız

  • ifx_copy_blob() - Duplicates the given blob object
  • ifx_free_blob() - Deletes the blob object

ifx_copy_blob
ifx_create_char
Informix İşlevleri


Creates an char object

ifx_create_blob
ifx_do
Informix İşlevleri
PHP Manual

ifx_create_char

(PHP 4, PHP <=5.2.0)

ifx_create_char — Creates an char object

Açıklama

int ifx_create_char ( string $param )

Creates an char object.

Değiştirgeler

param

The char content.

Dönen Değerler

Returns the new char object id, or FALSE on errors.

Ayrıca Bakınız

  • ifx_free_char() - Deletes the char object

ifx_create_blob
ifx_do
Informix İşlevleri


Execute a previously prepared SQL-statement

ifx_create_char
ifx_error
Informix İşlevleri
PHP Manual

ifx_do

(PHP 4, PHP <=5.2.0)

ifx_do — Execute a previously prepared SQL-statement

Açıklama

bool ifx_do ( resource $result_id )

Executes a previously prepared query or opens a cursor for it.

Does NOT free result_id on error.

Also sets the real number of ifx_affected_rows() for non-select statements for retrieval by ifx_affected_rows().

Değiştirgeler

result_id

result_id is a valid resultid returned by ifx_query() or ifx_prepare() (select type queries only!).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

Örnek 1 ifx_do() Example

<?php
$conn = fx_connect( "db", "user", "password" );
$result = ifx_prepare("SELECT customer_num, company FROM customer", $conn);
ifx_do($result);
?>

Ayrıca Bakınız

  • ifx_prepare() - Prepare an SQL-statement for execution

ifx_create_char
ifx_error
Informix İşlevleri


Returns error code of last Informix call

ifx_do
ifx_errormsg
Informix İşlevleri
PHP Manual

ifx_error

(PHP 4, PHP <=5.2.0)

ifx_error — Returns error code of last Informix call

Açıklama

string ifx_error ([ resource $link_identifier ] )

Returns in a string one character describing the general results of a statement and both SQLSTATE and SQLCODE associated with the most recent SQL statement executed.

Değiştirgeler

link_identifier

The link identifier.

Dönen Değerler

The Informix error codes (SQLSTATE & SQLCODE) formatted as x [SQLSTATE = aa bbb SQLCODE=cccc].

where x = space : no error

E : error

N : no more data

W : warning

? : undefined

If the "x" character is anything other than space, SQLSTATE and SQLCODE describe the error in more detail.

See the Informix manual for the description of SQLSTATE and SQLCODE

Ayrıca Bakınız

  • ifx_errormsg() - Returns error message of last Informix call

ifx_do
ifx_errormsg
Informix İşlevleri


Returns error message of last Informix call

ifx_error
ifx_fetch_row
Informix İşlevleri
PHP Manual

ifx_errormsg

(PHP 4, PHP <=5.2.0)

ifx_errormsg — Returns error message of last Informix call

Açıklama

string ifx_errormsg ([ int $errorcode ] )

Returns the Informix error message associated with the most recent Informix error.

Değiştirgeler

errorcode

If specified, the function will return the message corresponding to the specified code.

Dönen Değerler

Return the error message, as a string.

Örnekler

Örnek 1 ifx_errormsg() example

<?php
printf("%s\n<br>", ifx_errormsg(-201));
?>

Ayrıca Bakınız

  • ifx_error() - Returns error code of last Informix call

ifx_error
ifx_fetch_row
Informix İşlevleri


Get row as an associative array

ifx_errormsg
ifx_fieldproperties
Informix İşlevleri
PHP Manual

ifx_fetch_row

(PHP 4, PHP <=5.2.0)

ifx_fetch_row — Get row as an associative array

Açıklama

array ifx_fetch_row ( resource $result_id [, mixed $position ] )

Fetches one row of data from the result associated with the specified result identifier.

Subsequent calls to ifx_fetch_row() would return the next row in the result set, or FALSE if there are no more rows.

Değiştirgeler

result_id

result_id is a valid resultid returned by ifx_query() or ifx_prepare() (select type queries only!).

position

An optional parameter for a "fetch" operation on "scroll" cursors: NEXT, PREVIOUS, CURRENT, FIRST, LAST or a number. If you specify a number, an "absolute" row fetch is executed. This parameter is optional, and only valid for SCROLL cursors.

Dönen Değerler

Returns an associative array that corresponds to the fetched row, or FALSE if there are no more rows.

Blob columns are returned as integer blob id values for use in ifx_get_blob() unless you have used ifx_textasvarchar(1) or ifx_byteasvarchar(1), in which case blobs are returned as string values.

Örnekler

Örnek 1 Informix fetch rows

<?php
$rid = ifx_prepare ("select * from emp where name like " . $name,
                     $connid, IFX_SCROLL);
if (! $rid) {
    /* ... error ... */
}
$rowcount = ifx_affected_rows($rid);
if ($rowcount > 1000) {
    printf ("Too many rows in result set (%d)\n<br />", $rowcount);
    die ("Please restrict your query<br />\n");
}
if (! ifx_do ($rid)) {
   /* ... error ... */
}
$row = ifx_fetch_row ($rid, "NEXT");
while (is_array($row)) {
    for (reset($row); $fieldname=key($row); next($row)) {
        $fieldvalue = $row[$fieldname];
        printf ("%s = %s,", $fieldname, $fieldvalue);
    }
    printf("\n<br />");
    $row = ifx_fetch_row($rid, "NEXT");
}
ifx_free_result ($rid);
?>

ifx_errormsg
ifx_fieldproperties
Informix İşlevleri


List of SQL fieldproperties

ifx_fetch_row
ifx_fieldtypes
Informix İşlevleri
PHP Manual

ifx_fieldproperties

(PHP 4, PHP <=5.2.0)

ifx_fieldproperties — List of SQL fieldproperties

Açıklama

array ifx_fieldproperties ( resource $result_id )

Returns the Informix SQL fieldproperties of every field in the query as an associative array. Properties are encoded as: "SQLTYPE;length;precision;scale;ISNULLABLE" where SQLTYPE = the Informix type like "SQLVCHAR" etc. and ISNULLABLE = "Y" or "N".

Değiştirgeler

result_id

result_id is a valid resultid returned by ifx_query() or ifx_prepare() (select type queries only!).

Dönen Değerler

Returns an associative array with fieldnames as key and the SQL fieldproperties as data for a query with result_id. Returns FALSE on errors.

Örnekler

Örnek 1 Informix SQL fieldproperties

<?php
$properties = ifx_fieldproperties($resultid);
if (!isset($properties)) {
    /* ... error ... */
}
foreach ($properties as $fname => $val) {
    echo "$fname:\t property = $val\n";
}
?>

Ayrıca Bakınız

  • ifx_fieldtypes() - List of Informix SQL fields

ifx_fetch_row
ifx_fieldtypes
Informix İşlevleri


List of Informix SQL fields

ifx_fieldproperties
ifx_free_blob
Informix İşlevleri
PHP Manual

ifx_fieldtypes

(PHP 4, PHP <=5.2.0)

ifx_fieldtypes — List of Informix SQL fields

Açıklama

array ifx_fieldtypes ( resource $result_id )

Returns an associative array with fieldnames as key and the SQL fieldtypes as data for the query associated with result_id.

Değiştirgeler

result_id

result_id is a valid resultid returned by ifx_query() or ifx_prepare() (select type queries only!).

Dönen Değerler

Returns an associative array with fieldnames as key and the SQL fieldtypes as data for query with result_id. Returns FALSE on error.

Örnekler

Örnek 1 Fieldnames and SQL fieldtypes

<?php
$types = ifx_fieldtypes($resultid);
if (is_array($types)) {
    foreach ($types as $fname => $val) {
        echo "$fname:\t type = $val\n";
    }
}
?>

Ayrıca Bakınız

  • ifx_fieldproperties() - List of SQL fieldproperties

ifx_fieldproperties
ifx_free_blob
Informix İşlevleri


Deletes the blob object

ifx_fieldtypes
ifx_free_char
Informix İşlevleri
PHP Manual

ifx_free_blob

(PHP 4, PHP <=5.2.0)

ifx_free_blob — Deletes the blob object

Açıklama

bool ifx_free_blob ( int $bid )

Deletes the blobobject for the given blob object-id.

Değiştirgeler

bid

The BLOB object id.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ifx_create_blob() - Creates an blob object

ifx_fieldtypes
ifx_free_char
Informix İşlevleri


Deletes the char object

ifx_free_blob
ifx_free_result
Informix İşlevleri
PHP Manual

ifx_free_char

(PHP 4, PHP <=5.2.0)

ifx_free_char — Deletes the char object

Açıklama

bool ifx_free_char ( int $bid )

Deletes the charobject for the given char object-id.

Değiştirgeler

bid

The char object id.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ifx_create_char() - Creates an char object

ifx_free_blob
ifx_free_result
Informix İşlevleri


Releases resources for the query

ifx_free_char
ifx_get_blob
Informix İşlevleri
PHP Manual

ifx_free_result

(PHP 4, PHP <=5.2.0)

ifx_free_result — Releases resources for the query

Açıklama

bool ifx_free_result ( resource $result_id )

Releases resources for the query associated with result_id.

Değiştirgeler

result_id

result_id is a valid resultid returned by ifx_query() or ifx_prepare() (select type queries only!).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ifx_do() - Execute a previously prepared SQL-statement

ifx_free_char
ifx_get_blob
Informix İşlevleri


Return the content of a blob object

ifx_free_result
ifx_get_char
Informix İşlevleri
PHP Manual

ifx_get_blob

(PHP 4, PHP <=5.2.0)

ifx_get_blob — Return the content of a blob object

Açıklama

string ifx_get_blob ( int $bid )

Returns the content of the blob object.

Değiştirgeler

bid

The BLOB object id.

Dönen Değerler

The contents of the BLOB as a string, or FALSE on errors.

Ayrıca Bakınız

  • ifx_get_char() - Return the content of the char object

ifx_free_result
ifx_get_char
Informix İşlevleri


Return the content of the char object

ifx_get_blob
ifx_getsqlca
Informix İşlevleri
PHP Manual

ifx_get_char

(PHP 4, PHP <=5.2.0)

ifx_get_char — Return the content of the char object

Açıklama

string ifx_get_char ( int $bid )

Returns the content of the char object.

Değiştirgeler

bid

The char object-id.

Dönen Değerler

Returns the contents as a string, or FALSE on errors.

Ayrıca Bakınız

  • ifx_get_blob() - Return the content of a blob object

ifx_get_blob
ifx_getsqlca
Informix İşlevleri


Get the contents of sqlca.sqlerrd[0..5] after a query

ifx_get_char
ifx_htmltbl_result
Informix İşlevleri
PHP Manual

ifx_getsqlca

(PHP 4, PHP <=5.2.0)

ifx_getsqlca — Get the contents of sqlca.sqlerrd[0..5] after a query

Açıklama

array ifx_getsqlca ( resource $result_id )

Returns a pseudo-row with sqlca.sqlerrd[0] ... sqlca.sqlerrd[5] after the query associated with result_id.

For inserts, updates and deletes the values returned are those as set by the server after executing the query. This gives access to the number of affected rows and the serial insert value. For SELECTs the values are those saved after the PREPARE statement. This gives access to the *estimated* number of affected rows. The use of this function saves the overhead of executing a SELECT dbinfo('sqlca.sqlerrdx') query, as it retrieves the values that were saved by the ifx driver at the appropriate moment.

Değiştirgeler

result_id

result_id is a valid result id returned by ifx_query() or ifx_prepare() (select type queries only!).

Dönen Değerler

Returns an associative array with the following entries: sqlerrd0, sqlerrd1, sqlerrd2, sqlerrd3, sqlerrd4 and sqlerrd5.

Örnekler

Örnek 1 Retrieve Informix sqlca.sqlerrd[x] values

<?php
/* assume the first column of 'sometable' is a serial */
$qid = ifx_query("insert into sometable
                  values (0, '2nd column', 'another column') ", $connid);
if (!$qid) {
    /* ... error ... */
}
$sqlca = ifx_getsqlca($qid);
$serial_value = $sqlca["sqlerrd1"];
echo "The serial value of the inserted row is : $serial_value<br />\n";
?>

ifx_get_char
ifx_htmltbl_result
Informix İşlevleri


Formats all rows of a query into a HTML table

ifx_getsqlca
ifx_nullformat
Informix İşlevleri
PHP Manual

ifx_htmltbl_result

(PHP 4, PHP <=5.2.0)

ifx_htmltbl_result — Formats all rows of a query into a HTML table

Açıklama

int ifx_htmltbl_result ( resource $result_id [, string $html_table_options ] )

Formats and prints all rows of the result_id query into a HTML table.

Değiştirgeler

result_id

result_id is a valid resultid returned by ifx_query() or ifx_prepare() (select type queries only!).

html_table_options

This optional argument is a string of <table> tag options.

Dönen Değerler

Returns the number of fetched rows, or FALSE on errors.

Örnekler

Örnek 1 Informix results as HTML table

<?php
$rid = ifx_prepare ("select * from emp where name like " . $name,
                     $connid, IFX_SCROLL);
if (! $rid) {
    /* ... error ... */
}
$rowcount = ifx_affected_rows ($rid);
if ($rowcount > 1000) {
    printf ("Too many rows in result set (%d)\n<br />", $rowcount);
    die ("Please restrict your query<br />\n");
}
if (! ifx_do($rid)) {
    /* ... error ... */
}

ifx_htmltbl_result ($rid, "border=\"2\"");

ifx_free_result($rid);
?>

ifx_getsqlca
ifx_nullformat
Informix İşlevleri


Sets the default return value on a fetch row

ifx_htmltbl_result
ifx_num_fields
Informix İşlevleri
PHP Manual

ifx_nullformat

(PHP 4, PHP <=5.2.0)

ifx_nullformat — Sets the default return value on a fetch row

Açıklama

bool ifx_nullformat ( int $mode )

Sets the default return value of a NULL-value on a fetch row.

Değiştirgeler

mode

Mode "0" returns "", and mode "1" returns "NULL".

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

ifx_htmltbl_result
ifx_num_fields
Informix İşlevleri


Returns the number of columns in the query

ifx_nullformat
ifx_num_rows
Informix İşlevleri
PHP Manual

ifx_num_fields

(PHP 4, PHP <=5.2.0)

ifx_num_fields — Returns the number of columns in the query

Açıklama

int ifx_num_fields ( resource $result_id )

After preparing or executing a query, this call gives you the number of columns in the query.

Değiştirgeler

result_id

result_id is a valid resultid returned by ifx_query() or ifx_prepare() (select type queries only!).

Dönen Değerler

Returns the number of columns in query for result_id, or FALSE on errors.

Örnekler

Örnek 1 ifx_num_fields() Example

<?php
$conn_id = ifx_connect("db", "user", "password");
$res_id = ifx_query("select * from systables", $conn_id);
echo ifx_num_fields($res_id);
?>

Ayrıca Bakınız

  • ifx_num_rows() - Count the rows already fetched from a query

ifx_nullformat
ifx_num_rows
Informix İşlevleri


Count the rows already fetched from a query

ifx_num_fields
ifx_pconnect
Informix İşlevleri
PHP Manual

ifx_num_rows

(PHP 4, PHP <=5.2.0)

ifx_num_rows — Count the rows already fetched from a query

Açıklama

int ifx_num_rows ( resource $result_id )

Gives the number of rows fetched so far for a query with result_id after a ifx_query() or ifx_do() query.

Değiştirgeler

result_id

result_id is a valid resultid returned by ifx_query() or ifx_prepare() (select type queries only!).

Dönen Değerler

Returns the number of fetched rows or FALSE on errors.

Ayrıca Bakınız

  • ifx_num_fields() - Returns the number of columns in the query

ifx_num_fields
ifx_pconnect
Informix İşlevleri


Open persistent Informix connection

ifx_num_rows
ifx_prepare
Informix İşlevleri
PHP Manual

ifx_pconnect

(PHP 4, PHP <=5.2.0)

ifx_pconnect — Open persistent Informix connection

Açıklama

resource ifx_pconnect ([ string $database [, string $userid [, string $password ]]] )

ifx_pconnect() acts very much like ifx_connect() with two major differences.

First, when connecting, the function would first try to find a (persistent) link that's already open with the same host, username and password. If one is found, an identifier for it will be returned instead of opening a new connection.

Second, the connection to the SQL server will not be closed when the execution of the script ends. Instead, the link will remain open for future use (ifx_close() will not close links established by ifx_pconnect()).

This type of links is therefore called 'persistent'.

Değiştirgeler

All of the arguments are optional, and if they're missing, defaults are taken from values supplied in php.ini (ifx.default_host for the host (Informix libraries will use INFORMIXSERVER environment value if not defined), ifx.default_user for user, ifx.default_password for the password (none if not defined).

database

The database name, as a string.

userid

The username, as a string.

password

The password, as a string.

Dönen Değerler

Returns: valid Informix persistent link identifier on success, or FALSE on errors.

Ayrıca Bakınız

  • ifx_connect() - Open Informix server connection

ifx_num_rows
ifx_prepare
Informix İşlevleri


Prepare an SQL-statement for execution

ifx_pconnect
ifx_query
Informix İşlevleri
PHP Manual

ifx_prepare

(PHP 4, PHP <=5.2.0)

ifx_prepare — Prepare an SQL-statement for execution

Açıklama

resource ifx_prepare ( string $query , resource $link_identifier [, int $cursor_def ], mixed $blobidarray )

Prepares a query for later use with ifx_do().

For "select-type" queries a cursor is declared and opened. Non-select queries are "execute immediate".

For either query type the number of (estimated or real) affected rows is saved for retrieval by ifx_affected_rows().

If the contents of the TEXT (or BYTE) column allow it, you can also use ifx_textasvarchar(1) and ifx_byteasvarchar(1). This allows you to treat TEXT (or BYTE) columns just as if they were ordinary (but long) VARCHAR columns for select queries, and you don't need to bother with blob id's.

With ifx_textasvarchar(0) or ifx_byteasvarchar(0) (the default situation), select queries will return BLOB columns as blob id's (integer value). You can get the value of the blob as a string or file with the blob functions (see below).

Değiştirgeler

query

The query string.

link_identifier

The link identifier.

cursor_def

This optional parameter allows you to make this a scroll and/or hold cursor. It's a bitmask and can be either IFX_SCROLL, IFX_HOLD, or both or'ed together.

blobidarray

If you have BLOB (BYTE or TEXT) columns in the query, you can add a blobidarray parameter containing the corresponding "blob ids", and you should replace those columns with a "?" in the query text.

Dönen Değerler

Returns a valid result identifier for use by ifx_do(), or FALSE on errors.

Ayrıca Bakınız

  • ifx_do() - Execute a previously prepared SQL-statement

ifx_pconnect
ifx_query
Informix İşlevleri


Send Informix query

ifx_prepare
ifx_textasvarchar
Informix İşlevleri
PHP Manual

ifx_query

(PHP 4, PHP <=5.2.0)

ifx_query — Send Informix query

Açıklama

resource ifx_query ( string $query , resource $link_identifier [, int $cursor_type [, mixed $blobidarray ]] )

Sends a query to the currently active database on the server that's associated with the specified link identifier.

For "select-type" queries a cursor is declared and opened. Non-select queries are "execute immediate".

For either query type the number of (estimated or real) affected rows is saved for retrieval by ifx_affected_rows().

If the contents of the TEXT (or BYTE) column allow it, you can also use ifx_textasvarchar(1) and ifx_byteasvarchar(1). This allows you to treat TEXT (or BYTE) columns just as if they were ordinary (but long) VARCHAR columns for select queries, and you don't need to bother with blob id's.

With ifx_textasvarchar(0) or ifx_byteasvarchar(0) (the default situation), select queries will return BLOB columns as blob id's (integer value). You can get the value of the blob as a string or file with the blob functions (see below).

Değiştirgeler

query

The query string.

link_identifier

The link identifier.

cursor_def

This optional parameter allows you to make this a scroll and/or hold cursor. It's a bitmask and can be either IFX_SCROLL, IFX_HOLD, or both or'ed together. I you omit this parameter the cursor is a normal sequential cursor.

blobidarray

If you have BLOB (BYTE or TEXT) columns in the query, you can add a blobidarray parameter containing the corresponding "blob ids", and you should replace those columns with a "?" in the query text.

Dönen Değerler

Returns valid Informix result identifier on success, or FALSE on errors.

Örnekler

Örnek 1 Show all rows of the "orders" table as a HTML table

<?php
ifx_textasvarchar(1);      // use "text mode" for blobs
$res_id = ifx_query("select * from orders", $conn_id);
if (! $res_id) {
    printf("Can't select orders : %s\n<br />%s<br />\n", ifx_error(), ifx_errormsg());
    die;
}
ifx_htmltbl_result($res_id, "border=\"1\"");
ifx_free_result($res_id);
?>

Örnek 2 Insert some values into the "catalog" table

<?php

// create blob id's for a byte and text column
$textid = ifx_create_blob(0, 0, "Text column in memory");
$byteid = ifx_create_blob(1, 0, "Byte column in memory");

// store blob id's in a blobid array
$blobidarray[] = $textid;
$blobidarray[] = $byteid;

// launch query
$query = "insert into catalog (stock_num, manu_code, " .
         "cat_descr,cat_picture) values(1,'HRO',?,?)";
$res_id = ifx_query($query, $conn_id, $blobidarray);
if (! $res_id) {
    /* ... error ... */
}

// free result id
ifx_free_result($res_id);
?>

Ayrıca Bakınız

  • ifx_connect() - Open Informix server connection

ifx_prepare
ifx_textasvarchar
Informix İşlevleri


Set the default text mode

ifx_query
ifx_update_blob
Informix İşlevleri
PHP Manual

ifx_textasvarchar

(PHP 4, PHP <=5.2.0)

ifx_textasvarchar — Set the default text mode

Açıklama

bool ifx_textasvarchar ( int $mode )

Sets the default text mode for all select-queries.

Değiştirgeler

mode

Mode "0" will return a blob id, and mode "1" will return a varchar with text content.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ifx_byteasvarchar() - Set the default byte mode

ifx_query
ifx_update_blob
Informix İşlevleri


Updates the content of the blob object

ifx_textasvarchar
ifx_update_char
Informix İşlevleri
PHP Manual

ifx_update_blob

(PHP 4, PHP <=5.2.0)

ifx_update_blob — Updates the content of the blob object

Açıklama

bool ifx_update_blob ( int $bid , string $content )

Updates the content of the blob object for the given blob object bid.

Değiştirgeler

bid

A BLOB object identifier.

content

The new data, as a string.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ifx_update_char() - Updates the content of the char object

ifx_textasvarchar
ifx_update_char
Informix İşlevleri


Updates the content of the char object

ifx_update_blob
ifxus_close_slob
Informix İşlevleri
PHP Manual

ifx_update_char

(PHP 4, PHP <=5.2.0)

ifx_update_char — Updates the content of the char object

Açıklama

bool ifx_update_char ( int $bid , string $content )

Updates the content of the char object for the given char object bid.

Değiştirgeler

bid

A char object identifier.

content

The new data, as a string.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ifx_update_blob() - Updates the content of the blob object

ifx_update_blob
ifxus_close_slob
Informix İşlevleri


Deletes the slob object

ifx_update_char
ifxus_create_slob
Informix İşlevleri
PHP Manual

ifxus_close_slob

(PHP 4, PHP <=5.2.0)

ifxus_close_slob — Deletes the slob object

Açıklama

bool ifxus_close_slob ( int $bid )

Deletes the slob object on the given slob object-id bid.

Değiştirgeler

bid

An existing slob id.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ifxus_open_slob() - Opens an slob object

ifx_update_char
ifxus_create_slob
Informix İşlevleri


Creates an slob object and opens it

ifxus_close_slob
ifxus_free_slob
Informix İşlevleri
PHP Manual

ifxus_create_slob

(PHP 4, PHP <=5.2.0)

ifxus_create_slob — Creates an slob object and opens it

Açıklama

int ifxus_create_slob ( int $mode )

Creates an slob object and opens it.

Değiştirgeler

mode

A combination of IFX_LO_RDONLY, IFX_LO_WRONLY, IFX_LO_APPEND IFX_LO_RDWR, IFX_LO_BUFFER, IFX_LO_NOBUFFER.

Dönen Değerler

Return the new slob object-id, or FALSE on errors.

Ayrıca Bakınız

  • ifxus_close_slob() - Deletes the slob object
  • ifxus_free_slob() - Deletes the slob object

ifxus_close_slob
ifxus_free_slob
Informix İşlevleri


Deletes the slob object

ifxus_create_slob
ifxus_open_slob
Informix İşlevleri
PHP Manual

ifxus_free_slob

(PHP 4, PHP <=5.2.0)

ifxus_free_slob — Deletes the slob object

Açıklama

bool ifxus_free_slob ( int $bid )

Deletes the slob object.

Değiştirgeler

bid

An existing slob id.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ifxus_close_slob() - Deletes the slob object

ifxus_create_slob
ifxus_open_slob
Informix İşlevleri


Opens an slob object

ifxus_free_slob
ifxus_read_slob
Informix İşlevleri
PHP Manual

ifxus_open_slob

(PHP 4, PHP <=5.2.0)

ifxus_open_slob — Opens an slob object

Açıklama

int ifxus_open_slob ( int $bid , int $mode )

Opens an slob object. bid should be an existing slob id.

Değiştirgeler

bid

An existing slob id.

mode

A combination of IFX_LO_RDONLY, IFX_LO_WRONLY, IFX_LO_APPEND IFX_LO_RDWR, IFX_LO_BUFFER, IFX_LO_NOBUFFER.

Dönen Değerler

Returns the new slob object-id, or FALSE on errors.

Ayrıca Bakınız

  • ifxus_close_slob() - Deletes the slob object
  • ifxus_free_slob() - Deletes the slob object

ifxus_free_slob
ifxus_read_slob
Informix İşlevleri


Reads nbytes of the slob object

ifxus_open_slob
ifxus_seek_slob
Informix İşlevleri
PHP Manual

ifxus_read_slob

(PHP 4, PHP <=5.2.0)

ifxus_read_slob — Reads nbytes of the slob object

Açıklama

string ifxus_read_slob ( int $bid , int $nbytes )

Reads nbytes of the slob object.

Değiştirgeler

bid

An existing slob id.

nbytes

The number of bytes to read.

Dönen Değerler

Returns the slob contents as a string, or FALSE on errors.

Ayrıca Bakınız

  • ifxus_write_slob() - Writes a string into the slob object

ifxus_open_slob
ifxus_seek_slob
Informix İşlevleri


Sets the current file or seek position

ifxus_read_slob
ifxus_tell_slob
Informix İşlevleri
PHP Manual

ifxus_seek_slob

(PHP 4, PHP <=5.2.0)

ifxus_seek_slob — Sets the current file or seek position

Açıklama

int ifxus_seek_slob ( int $bid , int $mode , int $offset )

Sets the current file or seek position of an open slob object.

Değiştirgeler

bid

An existing slob id.

mode

0 = LO_SEEK_SET, 1 = LO_SEEK_CUR, 2 = LO_SEEK_END.

offset

A byte offset.

Dönen Değerler

Returns the seek position as an integer, or FALSE on errors.

Ayrıca Bakınız

  • ifxus_tell_slob() - Returns the current file or seek position

ifxus_read_slob
ifxus_tell_slob
Informix İşlevleri


Returns the current file or seek position

ifxus_seek_slob
ifxus_write_slob
Informix İşlevleri
PHP Manual

ifxus_tell_slob

(PHP 4, PHP <=5.2.0)

ifxus_tell_slob — Returns the current file or seek position

Açıklama

int ifxus_tell_slob ( int $bid )

Returns the current file or seek position of an open slob object

Değiştirgeler

bid

An existing slob id.

Dönen Değerler

Returns the seek position as an integer, or FALSE on errors.

Ayrıca Bakınız

  • ifxus_seek_slob() - Sets the current file or seek position

ifxus_seek_slob
ifxus_write_slob
Informix İşlevleri


Writes a string into the slob object

ifxus_tell_slob
Ingres
Informix İşlevleri
PHP Manual

ifxus_write_slob

(PHP 4, PHP <=5.2.0)

ifxus_write_slob — Writes a string into the slob object

Açıklama

int ifxus_write_slob ( int $bid , string $content )

Writes a string into the slob object.

Değiştirgeler

bid

An existing slob id.

content

The content to write, as a string.

Dönen Değerler

Returns the bytes written as an integer, or FALSE on errors.

Ayrıca Bakınız

  • ifxus_read_slob() - Reads nbytes of the slob object

ifxus_tell_slob
Ingres
Informix İşlevleri


Ingres DBMS, EDBC, and Enterprise Access Gateways

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
    • Basic usage
  • Ingres İşlevleri
    • ingres_autocommit_state — Test if the connection is using autocommit
    • ingres_autocommit — Switch autocommit on or off
    • ingres_charset — Returns the installation character set
    • ingres_close — Close an Ingres database connection
    • ingres_commit — Commit a transaction
    • ingres_connect — Open a connection to an Ingres database
    • ingres_cursor — Get a cursor name for a given result resource
    • ingres_errno — Get the last Ingres error number generated
    • ingres_error — Get a meaningful error message for the last error generated
    • ingres_errsqlstate — Get the last SQLSTATE error code generated
    • ingres_escape_string — Escape special characters for use in a query
    • ingres_execute — Execute a prepared query
    • ingres_fetch_array — Fetch a row of result into an array
    • ingres_fetch_assoc — Fetch a row of result into an associative array
    • ingres_fetch_object — Fetch a row of result into an object
    • ingres_fetch_proc_return — Get the return value from a procedure call
    • ingres_fetch_row — Fetch a row of result into an enumerated array
    • ingres_field_length — Get the length of a field
    • ingres_field_name — Get the name of a field in a query result
    • ingres_field_nullable — Test if a field is nullable
    • ingres_field_precision — Get the precision of a field
    • ingres_field_scale — Get the scale of a field
    • ingres_field_type — Get the type of a field in a query result
    • ingres_free_result — Free the resources associated with a result identifier
    • ingres_next_error — Get the next Ingres error
    • ingres_num_fields — Get the number of fields returned by the last query
    • ingres_num_rows — Get the number of rows affected or returned by a query
    • ingres_pconnect — Open a persistent connection to an Ingres database
    • ingres_prepare — Prepare a query for later execution
    • ingres_query — Send an SQL query to Ingres
    • ingres_result_seek — Set the row position before fetching data
    • ingres_rollback — Roll back a transaction
    • ingres_set_environment — Set environment features controlling output options
    • ingres_unbuffered_query — Send an unbuffered SQL query to Ingres
ifxus_write_slob
Giriş
Sağlayıcıya Göre Veritabanı Eklentileri


Giriş

The Ingres driver for PHP enables you to connect to and query the Ingres DBMS, EDBC, and Enterprise Access Gateways.

Bilginize:

Bu eklenti » PECL deposuna taşınmış olup şu sürümden itibaren PHP kaynak paketinde dağıtılmamaktatır: PHP 5.1.0.

Ingres
Yapılandırma/Kurulum
Ingres


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Ingres


Gereksinimler

To use or build the PHP extension for Ingres you must have a working Ingres client environment. You can download the client software for Ingres from » http://esd.ingres.com/.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu » PECL eklentisi PHP ile gelmez. Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/ingres.

You can download the DLL for this PECL extension from » http://esd.ingres.com/product/drivers/PHP/.

To have these functions available, you must » download and compile this extension, enabling Ingres support using the --with-ingres[=DIR] option, where DIR is the Ingres base directory. If the II_SYSTEM environment variable is not set correctly you may need to use --with-ingres=DIR to specify your Ingres installation directory.

PHP code written for version 2.x and later is not backward-compatible with earlier versions of this PHP extension. However, it is possible to run two incompatible releases within the same PHP environment using the --enable-ingres2 option. This configuration option renames the extension to ingres2, changing function names, configuration settings, and constants. For example, with this option enabled, ingres_connect() becomes ingres2_connect().

To use this extension the system environment variable II_SYSTEM must be defined. Linux and UNIX users will also need to define the shared library search path, for example, LD_LIBRARY_PATH. When used with the Apache web server these variables must be set explicitly in the startup script for Apache. In addition, the PassEnv directive is required for the Ingres extension to load the correct shared libraries. For example:

Örnek 1 Example usage of PassEnv for Ingres

<IfModule mod_env.c>
    PassEnv II_SYSTEM
    PassEnv LD_LIBRARY_PATH
</IfModule>

Bilginize:

For example configurations for different web servers and operating systems see » http://community.ingres.com/wiki/Ingres_Articles#Ingres_and_Web_Servers.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Ingres configuration options
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
ingres.allow_persistent | "1" | PHP_INI_SYSTEM | Available since ingres 1.0.0
ingres.array_index_start | "1" | PHP_INI_ALL | Available since ingres 1.4.0.
ingres.auto | "1" | PHP_INI_ALL | Available since ingres 2.0.0.
ingres.blob_segment_length | "4096" | PHP_INI_ALL | Available since ingres 1.2.0.
ingres.cursor_mode | "0" | PHP_INI_ALL | Available since ingres 1.1.0.
ingres.default_database | NULL | PHP_INI_ALL | Available since ingres 1.0.0
ingres.default_password | NULL | PHP_INI_ALL | Available since ingres 1.0.0
ingres.default_user | NULL | PHP_INI_ALL | Available since ingres 1.0.0
ingres.describe | 1 | PHP_INI_ALL | Available since ingres 2.1.0
ingres.fetch_buffer_size | 100 | PHP_INI_ALL | Available since ingres 2.1.0
ingres.max_links | "-1" | PHP_INI_SYSTEM | Available since ingres 1.0.0
ingres.max_persistent | "-1" | PHP_INI_SYSTEM | Available since ingres 1.0.0
ingres.reuse_connection | "1" | PHP_INI_ALL | Available since ingres 2.0.0
ingres.scrollable | "1" | PHP_INI_ALL | Available since ingres 2.0.0.
ingres.trace | "0" | PHP_INI_ALL | Available since ingres 2.0.0.
ingres.trace_connect | "0" | PHP_INI_ALL | Available since ingres 1.2.1.
ingres.utf8 | "1" | PHP_INI_ALL | Available since ingres 2.0.0.
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

ingres.allow_persistent boolean

Specifies whether to allow persistent connections to Ingres

ingres.array_index_start integer

Specifies the start value for an integer key for arrays generated by ingres_fetch_row() or ingres_fetch_array(). By default ingres.array_index_start is set to 1. If you wish to make the ingres extension behave like other database extensions set this configuration option to 0.

ingres.auto boolean

Enables or disables autocommit emulation. Ingres cannot have multiple cursors open with autocommit enabled. When enabled, the driver emulates autocommit.

ingres.blob_segment_length integer

Specifies the amount of memory to use when reading BLOB data, in bytes

ingres.cursor_mode integer

Specifies the default mode for cursors opened with ingres_prepare(). Valid values are INGRES_CURSOR_UPDATE or INGRES_CURSOR_READONLY.

ingres.default_database string

Specifies the default database name to use when connecting to the database server if no other name is specified. Does not apply in sql.safe_mode.

ingres.default_password string

Specifies the default password to use when connecting to the database server if no other name is specified. Does not apply in sql.safe_mode.

ingres.default_user string

Specifies the default user name to use when connecting to the database server if no other name is specified. Does not apply in sql.safe_mode.

ingres.describe boolean

Enables the use of DESCRIBE INPUT to determine the expected data types for queries that use parameters. Available with Ingres 9.1.0 and later. When disabled, queries that have parameters passed may need to manually describe the types of those parameters using the types parameter in ingres_query().

Bilginize:

Enabling this feature with ingres_query() will cause additional communications traffic between this extension and the server. To minimize this additional traffic, use ingres_prepare() and ingres_execute().

ingres.fetch_buffer_size integer

Specifies the number of pre-fetch rows that ingres_fetch_array(), ingres_fetch_object() and ingres_fetch_row() will try and fetch in one fetch operation.

ingres.max_links integer

Specifies the maximum number of Ingres sessions allowed per process or thread. The number of sessions should not exceed the total number of connected sessions configured within Ingres.

ingres.max_persistent integer

Specifies the maximum number of persistent Ingres sessions allowed per process or thread. The number of sessions should not exceed the total number of connected sessions configured within Ingres.

ingres.reuse_connection boolean

Reuses an existing active connection if connecting to the same database with the same user name

ingres.scrollable boolean

Enables support for scrollable cursors. When fetching CLOB or BLOB data, this should be set to FALSE. Available with Ingres 9.2.0 or later.

ingres.trace boolean

Enables simple tracing using E_NOTICE messages

ingres.trace_connect boolean

Prints E_NOTICE messages during ingres_connect() or ingres_pconnect() calls

ingres.utf8 boolean

Assumes that strings being passed to National Character column types (NVARCHAR or NCHAR) are using UTF8 encoding and converts them to UTF16 for the server

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Özkaynak Türleri

ingres_connect() and ingres_pconnect() return an Ingres link identifier.

ingres_query() and ingres_unbuffered_query() return an Ingres result identifier.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

INGRES_ASSOC (integer)
Columns are returned into the array having the fieldname as the array index. Used with ingres_fetch_array().
INGRES_NUM (integer)
Columns are returned into the array having a numerical index to the fields. By default this index starts at 1, the first field in the result. To change this value, see ingres.array_index_start. Used with ingres_fetch_array().
INGRES_BOTH (integer)
Columns are returned into the array having both a numerical index and the fieldname as the array index. Used with ingres_fetch_array().
INGRES_EXT_VERSION (string)
Specifies the version of the Ingres Extension. Available since version 1.2.0 of the PECL extension.
INGRES_API_VERSION (integer)
Specifies the version of Ingres OpenAPI that the extension was built against. Available since version 1.2.0 of the PECL extension.
INGRES_CURSOR_READONLY (integer)
Specifies that Ingres cursors should be opened in "readonly" mode. Available since version 1.2.0 of the PECL extension. Used with ingres.cursor_mode.
INGRES_CURSOR_UPDATE (integer)
Specifies that Ingres cursors should be opened "for update." Available since version 1.2.0 of the PECL extension. Used with ingres.cursor_mode.
INGRES_DATE_MULTINATIONAL (integer)
Equivalent to the II_DATE_FORMAT setting of MULTINATIONAL. Available since version 1.2.0 of the PECL extension. Used with ingres_connect(), ingres_pconnect() and ingres_set_environment(). See options in ingres_set_environment().
INGRES_DATE_MULTINATIONAL4 (integer)
Equivalent to the II_DATE_FORMAT setting of MULTINATIONAL4. Available since version 1.2.0 of the PECL extension.
Used with
ingres_connect(), ingres_pconnect()
and ingres_set_environment(). See options
in ingres_set_environment().
INGRES_DATE_FINNISH (integer)
Equivalent to the II_DATE_FORMAT setting of FINNISH. Available since version 1.2.0 of the PECL extension.
Used with
ingres_connect(), ingres_pconnect()
and ingres_set_environment(). See options
in ingres_set_environment().
INGRES_DATE_ISO (integer)
Equivalent to the II_DATE_FORMAT setting of ISO. Available since version 1.2.0 of the PECL extension.
Used with
ingres_connect(), ingres_pconnect()
and ingres_set_environment(). See options
in ingres_set_environment().
INGRES_DATE_ISO4 (integer)
Equivalent to the II_DATE_FORMAT setting of ISO4. Available since version 1.2.0 of the PECL extension.
Used with
ingres_connect(), ingres_pconnect()
and ingres_set_environment(). See options
in ingres_set_environment().
INGRES_DATE_GERMAN (integer)
Equivalent to the II_DATE_FORMAT setting of GERMAN. Available since version 1.2.0 of the PECL extension.
Used with
ingres_connect(), ingres_pconnect()
and ingres_set_environment(). See options
in ingres_set_environment().
INGRES_DATE_MDY (integer)
Equivalent to the II_DATE_FORMAT setting of MDY. Available since version 1.2.0 of the PECL extension.
Used with
ingres_connect(), ingres_pconnect()
and ingres_set_environment(). See options
in ingres_set_environment().
INGRES_DATE_DMY (integer)
Equivalent to the II_DATE_FORMAT setting of DMY. Available since version 1.2.0 of the PECL extension.
Used with
ingres_connect(), ingres_pconnect()
and ingres_set_environment(). See options
in ingres_set_environment().
INGRES_DATE_YMD (integer)
Equivalent to the II_DATE_FORMAT setting of YMD. Available since version 1.2.0 of the PECL extension.
Used with
ingres_connect(), ingres_pconnect()
and ingres_set_environment(). See options
in ingres_set_environment().
INGRES_MONEY_LEADING (integer)
Specifies the currency character that should be placed at the start of a money value. Equivalent to setting II_MONEY_FORMAT to "L:". Available since version 1.2.0 of the PECL extension. Used with ingres_connect(), ingres_pconnect() and ingres_set_environment(). See options in ingres_set_environment().
INGRES_MONEY_TRAILING (integer)
Specifies the currency character that should be placed at the end of a money value. Equivalent to setting II_MONEY_FORMAT to "T:". Available since version 1.2.0 of the PECL extension. Used with ingres_connect(), ingres_pconnect() and ingres_set_environment(). See options in ingres_set_environment().
INGRES_STRUCTURE_BTREE (integer)
Specifies the default table or index structure to BTREE when used in combination with the
options or index_structure option when connecting. Available since version 1.4.0 of the PECL extension.
Used with ingres_connect() and
ingres_pconnect(). See options
in ingres_connect().
INGRES_STRUCTURE_CBTREE (integer)
Specifies the default table or index structure to COMPRESSED BTREE when used in combination with the
options or index_structure option when connecting. Available since version 1.4.0 of the PECL extension.
Used with ingres_connect() and
ingres_pconnect(). See options
in ingres_connect().
INGRES_STRUCTURE_HASH (integer)
Specifies the default table or index structure to HASH when used in combination with the
options or index_structure option when connecting. Available since version 1.4.0 of the PECL extension.
Used with ingres_connect() and
ingres_pconnect(). See options
in ingres_connect().
INGRES_STRUCTURE_CHASH (integer)
Specifies the default table or index structure to COMPRESSED HASH when used in combination with the
options or index_structure option when connecting. Available since version 1.4.0 of the PECL extension.
Used with ingres_connect() and
ingres_pconnect(). See options
in ingres_connect().
INGRES_STRUCTURE_HEAP (integer)
Specifies the default table structure to HEAP when used in combination with the
options option when connecting. Available since version 1.4.0 of the PECL extension.
Used with ingres_connect() and
ingres_pconnect(). See options
in ingres_connect().
INGRES_STRUCTURE_CHEAP (integer)
Specifies the default table structure to COMPRESSED HEAP when used in combination with the
options option when connecting. Available since version 1.4.0 of the PECL extension.
Used with ingres_connect() and
ingres_pconnect(). See options
in ingres_connect().
INGRES_STRUCTURE_ISAM (integer)
Specifies the default table or index structure to ISAM when used in combination with the
options or index_structure option when connecting. Available since version 1.4.0 of the PECL extension.
Used with ingres_connect() and
ingres_pconnect(). See options
in ingres_connect().
INGRES_STRUCTURE_CISAM (integer)
Specifies the default table or index structure to COMPRESSED ISAM when used in combination with the
options or index_structure option when connecting. Available since version 1.4.0 of the PECL extension.
Used with ingres_connect() and
ingres_pconnect(). See options
in ingres_connect().
Özkaynak Türleri
Örnekler
Ingres


Örnekler

İçindekiler

  • Basic usage
Öntanımlı Sabitler
Basic usage
Ingres


Basic usage

The following simple example shows how to connect to an Ingres database, execute a query, print resulting rows and disconnect from the database.

Örnek 1 Simple Ingres Example

<?php
// Connecting, selecting database
$link = ingres_connect("database", "user", "password")
    or die("Could not connect: " . ingres_error($link));
echo "Connected successfully";

// Select from a table that exists in all Ingres databases
$query = "SELECT * FROM iitables";
$result = ingres_query($link,$query) or die("Query failed: " .
ingres_error($link));

// Print results in HTML
// relid - table name
// relowner - table owner
echo "<table>\n";
while ($iitables = ingres_fetch_object($result)) {
    echo "\t<tr>\n";
    echo "\t\t<td>" . $iitables->relid . "</td>\n";
    echo "\t\t<td>" . $iitables->relowner . "</td>\n";
    echo "\t</tr>\n";
}
echo "</table>\n";

// Free results
ingres_free_result($result);

// Commit transaction
ingres_commit($link);

// Closing connection
ingres_close($link);
?>

Örnekler
Ingres İşlevleri
Örnekler


Ingres İşlevleri

İçindekiler

  • ingres_autocommit_state — Test if the connection is using autocommit
  • ingres_autocommit — Switch autocommit on or off
  • ingres_charset — Returns the installation character set
  • ingres_close — Close an Ingres database connection
  • ingres_commit — Commit a transaction
  • ingres_connect — Open a connection to an Ingres database
  • ingres_cursor — Get a cursor name for a given result resource
  • ingres_errno — Get the last Ingres error number generated
  • ingres_error — Get a meaningful error message for the last error generated
  • ingres_errsqlstate — Get the last SQLSTATE error code generated
  • ingres_escape_string — Escape special characters for use in a query
  • ingres_execute — Execute a prepared query
  • ingres_fetch_array — Fetch a row of result into an array
  • ingres_fetch_assoc — Fetch a row of result into an associative array
  • ingres_fetch_object — Fetch a row of result into an object
  • ingres_fetch_proc_return — Get the return value from a procedure call
  • ingres_fetch_row — Fetch a row of result into an enumerated array
  • ingres_field_length — Get the length of a field
  • ingres_field_name — Get the name of a field in a query result
  • ingres_field_nullable — Test if a field is nullable
  • ingres_field_precision — Get the precision of a field
  • ingres_field_scale — Get the scale of a field
  • ingres_field_type — Get the type of a field in a query result
  • ingres_free_result — Free the resources associated with a result identifier
  • ingres_next_error — Get the next Ingres error
  • ingres_num_fields — Get the number of fields returned by the last query
  • ingres_num_rows — Get the number of rows affected or returned by a query
  • ingres_pconnect — Open a persistent connection to an Ingres database
  • ingres_prepare — Prepare a query for later execution
  • ingres_query — Send an SQL query to Ingres
  • ingres_result_seek — Set the row position before fetching data
  • ingres_rollback — Roll back a transaction
  • ingres_set_environment — Set environment features controlling output options
  • ingres_unbuffered_query — Send an unbuffered SQL query to Ingres
Basic usage
ingres_autocommit_state
Ingres


Test if the connection is using autocommit

Ingres İşlevleri
ingres_autocommit
Ingres İşlevleri
PHP Manual

ingres_autocommit_state

(PECL ingres >= 2.0.0)

ingres_autocommit_state — Test if the connection is using autocommit

Açıklama

bool ingres_autocommit_state ( resource $link )

ingres_autocommit_state() is called to determine whether the current link has autocommit enabled or not.

Değiştirgeler

link

The connection link identifier

Dönen Değerler

Returns TRUE if autocommit is enabled or FALSE when autocommit is disabled

Ayrıca Bakınız

  • ingres_autocommit() - Switch autocommit on or off
  • ingres_query() - Send an SQL query to Ingres

Ingres İşlevleri
ingres_autocommit
Ingres İşlevleri


Switch autocommit on or off

ingres_autocommit_state
ingres_charset
Ingres İşlevleri
PHP Manual

ingres_autocommit

(PHP 4 >= 4.0.2, PHP 5 <= 5.0.5, PECL ingres >= 1.0.0)

ingres_autocommit — Switch autocommit on or off

Açıklama

bool ingres_autocommit ( resource $link )

ingres_autocommit() is called before opening a transaction (before the first call to ingres_query() or just after a call to ingres_rollback() or ingres_commit()) to switch the autocommit mode of the server on or off (when the script begins the autocommit mode is off).

When autocommit mode is on, every query is automatically committed by the server, as if ingres_commit() was called after every call to ingres_query(). To see if autocommit is enabled use, ingres_autocommit_state().

By default Ingres will rollback any uncommitted transactions at the end of a request. Use this function or ingres_commit() to ensure your data is committed to the database.

Değiştirgeler

link

The connection link identifier

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ingres_autocommit_state() - Test if the connection is using autocommit
  • ingres_query() - Send an SQL query to Ingres
  • ingres_rollback() - Roll back a transaction
  • ingres_commit() - Commit a transaction

ingres_autocommit_state
ingres_charset
Ingres İşlevleri


Returns the installation character set

ingres_autocommit
ingres_close
Ingres İşlevleri
PHP Manual

ingres_charset

(PECL ingres >= 2.1.0)

ingres_charset — Returns the installation character set

Açıklama

string ingres_charset ( resource $link )

ingres_charset() is called to determine the character set being used by the Ingres client, from II_CHARSETxx (where xx is the installation code).

Bilginize:

You can override the value returned by using the function putenv(). Changing the value of II_CHARSETxx in a running Ingres installation can cause data corruption.

Değiştirgeler

link

The connection link identifier

Dönen Değerler

Returns a string with the value for II_CHARSETxx or returns NULL if the value could not be determined.

Örnekler

Örnek 1 ingres_charset() - Get the installation character set

<?php
$link = ingres_connect($database, $user, $password);

echo ingres_charset($link) . "\n";

ingres_close($link);
?>

Ayrıca Bakınız

  • ingres_connect() - Open a connection to an Ingres database
  • ingres_query() - Send an SQL query to Ingres

ingres_autocommit
ingres_close
Ingres İşlevleri


Close an Ingres database connection

ingres_charset
ingres_commit
Ingres İşlevleri
PHP Manual

ingres_close

(PHP 4 >= 4.0.2, PHP 5 <= 5.0.5, PECL ingres >= 1.0.0)

ingres_close — Close an Ingres database connection

Açıklama

bool ingres_close ( resource $link )

ingres_close() closes the connection to the Ingres server that is associated with the specified link.

ingres_close() is usually unnecessary, as it will not close persistent connections and all non-persistent connections are automatically closed at the end of the script.

Değiştirgeler

link

The connection link identifier

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ingres_connect() - Open a connection to an Ingres database
  • ingres_pconnect() - Open a persistent connection to an Ingres database

ingres_charset
ingres_commit
Ingres İşlevleri


Commit a transaction

ingres_close
ingres_connect
Ingres İşlevleri
PHP Manual

ingres_commit

(PHP 4 >= 4.0.2, PHP 5 <= 5.0.5, PECL ingres >= 1.0.0)

ingres_commit — Commit a transaction

Açıklama

bool ingres_commit ( resource $link )

ingres_commit() commits the currently open transaction, making all changes made to the database permanent.

This closes the transaction. A new transaction can be opened by sending a query with ingres_query().

You can also have the server commit automatically after every query by calling ingres_autocommit() before opening the transaction.

By default Ingres will roll back any uncommitted transactions at the end of a request. Use this function or ingres_autocommit() to ensure your that data is committed to the database.

Değiştirgeler

link

The connection link identifier

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ingres_query() - Send an SQL query to Ingres
  • ingres_rollback() - Roll back a transaction
  • ingres_autocommit() - Switch autocommit on or off

ingres_close
ingres_connect
Ingres İşlevleri


Open a connection to an Ingres database

ingres_commit
ingres_cursor
Ingres İşlevleri
PHP Manual

ingres_connect

(PHP 4 >= 4.0.2, PHP 5 <= 5.0.5, PECL ingres >= 1.0.0)

ingres_connect — Open a connection to an Ingres database

Açıklama

resource ingres_connect ([ string $database [, string $username [, string $password [, array $options ]]]] )

ingres_connect() opens a connection with the given Ingres database.

The connection is closed when the script ends or when ingres_close() is called on this link.

Değiştirgeler

If some parameters are missing, ingres_connect() uses the values in php.ini for ingres.default_database, ingres.default_user and ingres.default_password.

database

The database name. Must follow the syntax:

[vnode::]dbname[/svr_class]

username

The Ingres user name

password

The password associated with username

options

ingres_connect() options

Option name | Option type | Description | Example
date_century_boundary | integer | The threshold by which a 2-digit year is determined to be in the current century or in the next century. Equivalent to II_DATE_CENTURY_BOUNDARY. | 50
group | string | Specifies the group ID of the user, equivalent to the "-G" flag | payroll
role | string | The role ID of the application. If a role password is required, the parameter value should be specified as "role/password"
effective_user | string | The ingres user account being impersonated, equivalent to the "-u" flag | another_user
dbms_password | string | The internal database password for the user connecting to Ingres | s3cr3t
table_structure string

The default structure for new tables. Valid values for table_structure are:

  • INGRES_STRUCTURE_BTREE
  • INGRES_STRUCTURE_HASH
  • INGRES_STRUCTURE_HEAP
  • INGRES_STRUCTURE_ISAM
  • INGRES_STRUCTURE_CBTREE
  • INGRES_STRUCTURE_CISAM
  • INGRES_STRUCTURE_CHASH
  • INGRES_STRUCTURE_CHEAP

 INGRES_STRUCTURE_BTREE
index_structure string

The default structure for new secondary indexes. Valid values for index_structure are:

  • INGRES_STRUCTURE_CBTREE
  • INGRES_STRUCTURE_CISAM
  • INGRES_STRUCTURE_CHASH
  • INGRES_STRUCTURE_BTREE
  • INGRES_STRUCTURE_HASH
  • INGRES_STRUCTURE_ISAM

 INGRES_STRUCTURE_HASH
login_local | boolean | Determines how the connection user ID and password are used when a VNODE is included in the target database string. If set to TRUE, the user ID and password are used to locally access the VNODE, and the VNODE login information is used to establish the DBMS connection. If set to FALSE, the process user ID is used to access the VNODE, and the connection user ID and password are used in place of the VNODE login information to establish the DBMS connection. This parameter is ignored if no VNODE is included in the target database string. The default is FALSE. | TRUE
timezone | string | Controls the timezone of the session. If not set it will default to the value defined by II_TIMEZONE_NAME. If II_TIMEZONE_NAME is not defined, NA-PACIFIC (GMT-8 with Daylight Savings) is used.
date_format integer

Sets the allowable input and output format for Ingres dates. Defaults to the value defined by II_DATE_FORMAT. If II_DATE_FORMAT is not set the default date format is US, e.g. mm/dd/yy. Valid values for date_format are:

  • INGRES_DATE_DMY
  • INGRES_DATE_FINISH
  • INGRES_DATE_GERMAN
  • INGRES_DATE_ISO
  • INGRES_DATE_ISO4
  • INGRES_DATE_MDY
  • INGRES_DATE_MULTINATIONAL
  • INGRES_DATE_MULTINATIONAL4
  • INGRES_DATE_YMD
  • INGRES_DATE_US

 INGRES_DATE_MULTINATIONAL4
decimal_separator string The character identifier for decimal data ","
money_lort integer

Leading or trailing currency sign. Valid values for money_lort are:

  • INGRES_MONEY_LEADING
  • INGRES_MONEY_TRAILING

 INGRES_MONEY_TRAILING
money_sign string The currency symbol to be used with the MONEY datatype €
money_precision | integer | The precision of the MONEY datatype | 3
float4_precision | integer | Precision of the FLOAT4 datatype | 10
float8_precision | integer | Precision of the FLOAT8 data | 10
blob_segment_length | integer | The amount of data in bytes to fetch at a time when retrieving BLOB or CLOB data, defaults to 4096 bytes when not explicitly set | 8192

Dönen Değerler

Returns a Ingres link resource on success başarısızlık durumunda FALSE döner

Örnekler

Örnek 1 Open a connection to an Ingres database

<?php
$link = ingres_connect("mydb", "user", "pass")
    or die("Could not connect");
echo "Connected successfully";
ingres_close($link);
?>

Ayrıca Bakınız

  • ingres_pconnect() - Open a persistent connection to an Ingres database
  • ingres_close() - Close an Ingres database connection

ingres_commit
ingres_cursor
Ingres İşlevleri


Get a cursor name for a given result resource

ingres_connect
ingres_errno
Ingres İşlevleri
PHP Manual

ingres_cursor

(PECL ingres >= 1.1.0)

ingres_cursor — Get a cursor name for a given result resource

Açıklama

string ingres_cursor ( resource $result )

Returns a string with the active cursor name. If no cursor is active then NULL is returned.

Değiştirgeler

result

The query result identifier

Dönen Değerler

Returns a string containing the active cursor name. If no cursor is active then NULL is returned.

Örnekler

Örnek 1 Get cursor name for a query resource

<?php
$link = ingres_connect($database, $user, $password);

$result = ingres_prepare($link, "select * from table");

$cursor_name = ingres_cursor($result);

echo $cursor_name;

?>

Ayrıca Bakınız

  • ingres_prepare() - Prepare a query for later execution
  • ingres_execute() - Execute a prepared query

ingres_connect
ingres_errno
Ingres İşlevleri


Get the last Ingres error number generated

ingres_cursor
ingres_error
Ingres İşlevleri
PHP Manual

ingres_errno

(PECL ingres >= 1.1.0)

ingres_errno — Get the last Ingres error number generated

Açıklama

int ingres_errno ([ resource $link ] )

Returns an integer containing the last error number. If no error was reported 0 is returned.

If a link resource is passed to ingres_errno() it returns the last error recorded for the link. If no link is passed, then ingres_errno() returns the last error reported using the default link.

The function, ingres_errno(), should always be called after executing a database query. Calling another function before ingres_errno() is called will reset or change any error code from the last Ingres function call.

Değiştirgeler

link

The connection link identifier

Dönen Değerler

Returns an integer containing the last error number. If no error was reported, 0 is returned.

Örnekler

Örnek 1 Get the last Ingres error number generated

<?php
$link = ingres_connect($database, $user, $password);

$result = ingres_query($link, "select * from table");

$error_code = ingres_errno($link);

if ( $error_code != 0 ) {
   echo "An error occurred - " . $error_code;
}
?>

Ayrıca Bakınız

  • ingres_error() - Get a meaningful error message for the last error generated
  • ingres_errsqlstate() - Get the last SQLSTATE error code generated
  • ingres_next_error() - Get the next Ingres error

ingres_cursor
ingres_error
Ingres İşlevleri


Get a meaningful error message for the last error generated

ingres_errno
ingres_errsqlstate
Ingres İşlevleri
PHP Manual

ingres_error

(PECL ingres >= 1.1.0)

ingres_error — Get a meaningful error message for the last error generated

Açıklama

string ingres_error ([ resource $link ] )

Returns a string containing the last error, or NULL if no error has occurred.

If a link resource is passed to ingres_error(), it returns the last error recorded for the link. If no link is passed then ingres_error() returns the last error reported using the default link.

The function, ingres_error(), should always be called after executing any database query. Calling another function before ingres_error() is called will reset or change any error message from the last Ingres function call.

Değiştirgeler

link

The connection link identifier

Dönen Değerler

Returns a string containing the last error, or NULL if no error has occurred.

Örnekler

Örnek 1 Get a message for the last error generated

<?php
$link = ingres_connect($database, $user, $password);

$result = ingres_query($link, "select * from table");

$error_text = ingres_error();

if (!is_null($error_text)) {
   echo "An error occurred - " . $error_text;
}
?>

Ayrıca Bakınız

  • ingres_errno() - Get the last Ingres error number generated
  • ingres_errsqlstate() - Get the last SQLSTATE error code generated
  • ingres_next_error() - Get the next Ingres error

ingres_errno
ingres_errsqlstate
Ingres İşlevleri


Get the last SQLSTATE error code generated

ingres_error
ingres_escape_string
Ingres İşlevleri
PHP Manual

ingres_errsqlstate

(PECL ingres >= 1.1.0)

ingres_errsqlstate — Get the last SQLSTATE error code generated

Açıklama

string ingres_errsqlstate ([ resource $link ] )

Returns a string containing the last SQLSTATE, or NULL if no error has occurred.

If a link resource is passed to ingres_errsqlstate(), it returns the last error recorded for the link. If no link is passed, then ingres_errsqlstate() returns the last error reported using the default link.

The function, ingres_errsqlstate(), should always be called after executing any database query. Calling another function before ingres_errsqlstate() is called will reset or change any error message from the last Ingres function call.

Değiştirgeler

link

The connection link identifier

Dönen Değerler

Returns a string containing the last SQLSTATE, or NULL if no error has occurred.

Örnekler

Örnek 1 Get the last SQLSTATE error code generated

<?php
$link = ingres_connect($database, $user, $password);

$result = ingres_query($link, "select * from table");

$error_sqlstate = ingres_errsqlstate($link);

if (!is_null($error_sqlstate)) {
   echo "An error occurred - " . $error_sqlstate;
}
?>

Ayrıca Bakınız

  • ingres_errno() - Get the last Ingres error number generated
  • ingres_error() - Get a meaningful error message for the last error generated
  • ingres_next_error() - Get the next Ingres error

ingres_error
ingres_escape_string
Ingres İşlevleri


Escape special characters for use in a query

ingres_errsqlstate
ingres_execute
Ingres İşlevleri
PHP Manual

ingres_escape_string

(PECL ingres >= 2.1.0)

ingres_escape_string — Escape special characters for use in a query

Açıklama

string ingres_escape_string ( resource $link , string $source_string )

ingres_escape_string() is used to escape certain characters within a string before it is sent to the database server.

Değiştirgeler

link

The connection link identifier

source_string

The source string to be parsed

Dönen Değerler

Returns a string containing the escaped data.

Örnekler

Örnek 1 Escape special characters for use in a query

<?php
$link = ingres_connect($database, $user, $password);

$last_name = "O'Connor";

$sql = sprintf("select * from user_profile where up_last = '%s'", ingres_escape_string( $link, $last_name));

$result = ingres_query($link, $sql);

while ($user = ingres_fetch_object($result))
{
  echo $user->up_first . '<BR/>';
}

ingres_commit($link);

ingres_close($link);

?>

Ayrıca Bakınız

  • ingres_query() - Send an SQL query to Ingres

ingres_errsqlstate
ingres_execute
Ingres İşlevleri


Execute a prepared query

ingres_escape_string
ingres_fetch_array
Ingres İşlevleri
PHP Manual

ingres_execute

(PECL ingres >= 1.1.0)

ingres_execute — Execute a prepared query

Açıklama

bool ingres_execute ( resource $result [, array $params [, string $types ]] )

Execute a query prepared using ingres_prepare().

Bilginize: Related Configurations

See also the ingres.describe, ingres.scrollable and ingres.utf8 directives in Runtime Configuration.

Değiştirgeler

result

The result query identifier

params

An array of parameter values to be used with the query

types

A string containing a sequence of types for the parameter values passed. See the types parameter in ingres_query() for the list of type codes.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ingres_unbuffered_query() - Send an unbuffered SQL query to Ingres
  • ingres_fetch_array() - Fetch a row of result into an array
  • ingres_fetch_assoc() - Fetch a row of result into an associative array
  • ingres_fetch_object() - Fetch a row of result into an object
  • ingres_fetch_row() - Fetch a row of result into an enumerated array
  • ingres_commit() - Commit a transaction
  • ingres_rollback() - Roll back a transaction
  • ingres_autocommit() - Switch autocommit on or off
  • ingres_set_environment() - Set environment features controlling output options
  • ingres_errno() - Get the last Ingres error number generated
  • ingres_error() - Get a meaningful error message for the last error generated

ingres_escape_string
ingres_fetch_array
Ingres İşlevleri


Fetch a row of result into an array

ingres_execute
ingres_fetch_assoc
Ingres İşlevleri
PHP Manual

ingres_fetch_array

( PHP 5 <= 5.0.5, PECL ingres >= 1.0.0)

ingres_fetch_array — Fetch a row of result into an array

Açıklama

array ingres_fetch_array ( resource $result [, int $result_type ] )

This function is an extended version of ingres_fetch_row(). In addition to storing the data in the numeric indices of the result array, it also stores the data in associative indices, using the field names as keys.

If two or more columns of the result have the same field names, the last column will take precedence. To access the another column or columns of the same name, you must use the numeric index of the column or make an alias for the column. For example:

<?php

$result = ingres_query($link, "select ap_place as city, ap_ccode as country from airport where ap_iatacode = 'VLL'");
$result = ingres_fetch_array($result);
$foo = $result["city"];
$bar = $result["country"];

?>

With regard to speed, the function is identical to ingres_fetch_object(), and almost as quick as ingres_fetch_row() (the difference is insignificant).

By default, arrays created by ingres_fetch_array() start from position 1 and not 0 as with other DBMS extensions. The starting position can be adjusted to 0 using the configuration parameter ingres.array_index_start.

Bilginize: Related Configurations

See also the ingres.array_index_start, ingres.fetch_buffer_size and ingres.utf8 directives in Runtime Configuration.

Değiştirgeler

result

The query result identifier

result_type

The result type. This result_type can be INGRES_NUM for enumerated array, INGRES_ASSOC for associative array, or INGRES_BOTH (default).

Dönen Değerler

Returns an array that corresponds to the fetched row, or FALSE if there are no more rows

Örnekler

Örnek 1 Fetch a row of result into an array

<?php
$link = ingres_connect($database, $user, $password);

$result = ingres_query($link,"select * from table");
while ($row = ingres_fetch_array($result)) {
    echo $row["user_id"];  // using associative array
    echo $row["fullname"];
    echo $row[1];          // using enumerated array
    echo $row[2];
}
?>

Ayrıca Bakınız

  • ingres_query() - Send an SQL query to Ingres
  • ingres_num_fields() - Get the number of fields returned by the last query
  • ingres_field_name() - Get the name of a field in a query result
  • ingres_fetch_assoc() - Fetch a row of result into an associative array
  • ingres_fetch_object() - Fetch a row of result into an object
  • ingres_fetch_row() - Fetch a row of result into an enumerated array

ingres_execute
ingres_fetch_assoc
Ingres İşlevleri


Fetch a row of result into an associative array

ingres_fetch_array
ingres_fetch_object
Ingres İşlevleri
PHP Manual

ingres_fetch_assoc

(PECL ingres >= 2.2.2)

ingres_fetch_assoc — Fetch a row of result into an associative array

Açıklama

array ingres_fetch_assoc ( resource $result )

This function is stores the data fetched from a query executed using ingres_query() in an associative array, using the field names as keys.

With regard to speed, the function is identical to ingres_fetch_object(), and almost as quick as ingres_fetch_row() (the difference is insignificant).

By default, arrays created by ingres_fetch_assoc() start from position 1 and not 0 as with other DBMS extensions. The starting position can be adjusted to 0 using the configuration parameter ingres.array_index_start.

Bilginize: Related Configurations

See also the ingres.array_index_start, ingres.fetch_buffer_size and ingres.utf8 directives in Runtime Configuration.

Değiştirgeler

result

The query result identifier

Dönen Değerler

Returns an associative array that corresponds to the fetched row, or FALSE if there are no more rows

Örnekler

Örnek 1 Fetch a row into an associative array

<?php
$link = ingres_connect($database, $user, $password);

$result = ingres_query($link,"select * from table");
while ($row = ingres_fetch_assoc($result)) {
    echo $row["user_id"];  // using associative array
    echo $row["fullname"];
}
?>

Ayrıca Bakınız

  • ingres_query() - Send an SQL query to Ingres
  • ingres_num_fields() - Get the number of fields returned by the last query
  • ingres_field_name() - Get the name of a field in a query result
  • ingres_fetch_array() - Fetch a row of result into an array
  • ingres_fetch_object() - Fetch a row of result into an object
  • ingres_fetch_row() - Fetch a row of result into an enumerated array

ingres_fetch_array
ingres_fetch_object
Ingres İşlevleri


Fetch a row of result into an object

ingres_fetch_assoc
ingres_fetch_proc_return
Ingres İşlevleri
PHP Manual

ingres_fetch_object

(PHP 4 >= 4.0.2, PHP 5 <= 5.0.5, PECL ingres >= 1.0.0)

ingres_fetch_object — Fetch a row of result into an object

Açıklama

object ingres_fetch_object ( resource $result [, int $result_type ] )

This function is similar to ingres_fetch_array(), with one difference - an object is returned instead of an array. Indirectly, this means that you can access the data only by the field names and not by their offsets (numbers are illegal property names).

With regard to speed, the function is identical to ingres_fetch_array(), and almost as quick as ingres_fetch_row() (the difference is insignificant).

Bilginize: Related Configurations

See also the ingres.fetch_buffer_size and ingres.utf8 directives in Runtime Configuration.

Değiştirgeler

link

The query result identifier

result_type

(Optional argument.) result_type is a constant and can take the following values: INGRES_ASSOC, INGRES_NUM, and INGRES_BOTH.

Dönen Değerler

Returns an object that corresponds to the fetched row, or FALSE if there are no more rows

Örnekler

Örnek 1 Fetch a row into an object

<?php
$link = ingres_connect($database, $user, $password);
$result = ingres_query($link, "select * from table");
while ($row = ingres_fetch_object($result)) {
    echo $row->user_id;
    echo $row->fullname;
}
?>

Ayrıca Bakınız

  • ingres_query() - Send an SQL query to Ingres
  • ingres_num_fields() - Get the number of fields returned by the last query
  • ingres_field_name() - Get the name of a field in a query result
  • ingres_fetch_array() - Fetch a row of result into an array
  • ingres_fetch_assoc() - Fetch a row of result into an associative array
  • ingres_fetch_row() - Fetch a row of result into an enumerated array

ingres_fetch_assoc
ingres_fetch_proc_return
Ingres İşlevleri


Get the return value from a procedure call

ingres_fetch_object
ingres_fetch_row
Ingres İşlevleri
PHP Manual

ingres_fetch_proc_return

(PECL ingres >= 1.4.0)

ingres_fetch_proc_return — Get the return value from a procedure call

Açıklama

int ingres_fetch_proc_return ( resource $result )

This function is used to retrieve the return value following the execution of an Ingres database procedure (stored procedure).

Bilginize:

If used with a row-producing procedure, this function should be called after all the rows from the procedure have been fetched using ingres_fetch_array(), ingres_fetch_object() or ingres_fetch_row(). This function will eliminate any rows yet to be fetched should there be any left over.

Değiştirgeler

result

The result identifier for a query

Dönen Değerler

Returns an integer if there is a return value otherwise it will return NULL.

Örnekler

Örnek 1 Get the return value from a procedure call

<?php

$link = ingres_connect($database);

if ( ingres_errno() != 0 ) {
    $error_text = ingres_error();
    die($error_text);
}

$result = ingres_query($link, "execute procedure php_proc (value = 1000)");

if ( ingres_errno() != 0 ) {
    $error_text = ingres_error();
    die($error_text);
}

echo "return value - " . ingres_fetch_proc_return($result) . "\n";

ingres_close($link);

?>

Ayrıca Bakınız

  • ingres_query() - Send an SQL query to Ingres
  • ingres_fetch_array() - Fetch a row of result into an array
  • ingres_fetch_object() - Fetch a row of result into an object
  • ingres_fetch_row() - Fetch a row of result into an enumerated array

ingres_fetch_object
ingres_fetch_row
Ingres İşlevleri


Fetch a row of result into an enumerated array

ingres_fetch_proc_return
ingres_field_length
Ingres İşlevleri
PHP Manual

ingres_fetch_row

(PHP 4 >= 4.0.2, PHP 5 <= 5.0.5, PECL ingres >= 1.0.0)

ingres_fetch_row — Fetch a row of result into an enumerated array

Açıklama

array ingres_fetch_row ( resource $result )

ingres_fetch_row() returns an array that corresponds to the fetched row, or FALSE if there are no more rows. Each result column is stored in an array offset, starting at offset 1.

Subsequent calls to ingres_fetch_row() return the next row in the result set, or FALSE if there are no more rows.

By default, arrays created by ingres_fetch_row() start from position 1 and not 0 as with other DBMS extensions. The starting position can be adjusted to 0 using the configuration parameter ingres.array_index_start.

Bilginize: Related Configurations

See also the ingres.array_index_start, ingres.fetch_buffer_size and ingres.utf8 directives in Runtime Configuration.

Değiştirgeler

result

The query result identifier

Dönen Değerler

Returns an array that corresponds to the fetched row, or FALSE if there are no more rows

Örnekler

Örnek 1 Fetch a row of result into an enumerated array

<?php
$link = ingres_connect($database, $user, $password);

$result = ingres_query($link, "select * from table");
while ($row = ingres_fetch_row($result)) {
    echo $row[1];
    echo $row[2];
}
?>

Ayrıca Bakınız

  • ingres_num_fields() - Get the number of fields returned by the last query
  • ingres_query() - Send an SQL query to Ingres
  • ingres_fetch_array() - Fetch a row of result into an array
  • ingres_fetch_assoc() - Fetch a row of result into an associative array
  • ingres_fetch_object() - Fetch a row of result into an object

ingres_fetch_proc_return
ingres_field_length
Ingres İşlevleri


Get the length of a field

ingres_fetch_row
ingres_field_name
Ingres İşlevleri
PHP Manual

ingres_field_length

(PHP 4 >= 4.0.2, PHP 5 <= 5.0.5, PECL ingres >= 1.0.0)

ingres_field_length — Get the length of a field

Açıklama

int ingres_field_length ( resource $result , int $index )

ingres_field_length() returns the length of a field. This is the number of bytes the server uses to store the field. For detailed information, see the Ingres OpenAPI User Guide, Appendix "Data Types" in the Ingres documentation.

Bilginize: Related Configurations

See ingres.array_index_start in Runtime Configuration

Değiştirgeler

result

The query result identifier

index

index is the column number whose length will be retrieved.

The possible values of index depend upon the value of ingres.array_index_start. If ingres.array_index_start is 1 (the default) then index must be between 1 and the value returned by ingres_num_fields(). If ingres.array_index_start is 0 then index must be between 0 and ingres_num_fields() - 1.

Dönen Değerler

Returns the length of a field.

Ayrıca Bakınız

  • ingres_query() - Send an SQL query to Ingres
  • ingres_fetch_array() - Fetch a row of result into an array
  • ingres_fetch_assoc() - Fetch a row of result into an associative array
  • ingres_fetch_object() - Fetch a row of result into an object
  • ingres_fetch_row() - Fetch a row of result into an enumerated array

ingres_fetch_row
ingres_field_name
Ingres İşlevleri


Get the name of a field in a query result

ingres_field_length
ingres_field_nullable
Ingres İşlevleri
PHP Manual

ingres_field_name

(PHP 4 >= 4.0.2, PHP 5 <= 5.0.5, PECL ingres >= 1.0.0)

ingres_field_name — Get the name of a field in a query result

Açıklama

string ingres_field_name ( resource $result , int $index )

ingres_field_name() returns the name of a field in a query result.

Bilginize: Related Configurations

See ingres.array_index_start in Runtime Configuration

Değiştirgeler

result

The query result identifier

index

index is the field whose name will be retrieved.

The possible values of index depend upon the value of ingres.array_index_start. If ingres.array_index_start is 1 (the default) then index must be between 1 and the value returned by ingres_num_fields(). If ingres.array_index_start is 0 then index must be between 0 and ingres_num_fields() - 1.

Dönen Değerler

Returns the name of a field in a query result başarısızlık durumunda FALSE döner

Ayrıca Bakınız

  • ingres_query() - Send an SQL query to Ingres
  • ingres_fetch_array() - Fetch a row of result into an array
  • ingres_fetch_assoc() - Fetch a row of result into an associative array
  • ingres_fetch_object() - Fetch a row of result into an object
  • ingres_fetch_row() - Fetch a row of result into an enumerated array

ingres_field_length
ingres_field_nullable
Ingres İşlevleri


Test if a field is nullable

ingres_field_name
ingres_field_precision
Ingres İşlevleri
PHP Manual

ingres_field_nullable

(PHP 4 >= 4.0.2, PHP 5 <= 5.0.5, PECL ingres >= 1.0.0)

ingres_field_nullable — Test if a field is nullable

Açıklama

bool ingres_field_nullable ( resource $result , int $index )

Test if a field is nullable.

Bilginize: Related Configurations

See ingres.array_index_start in Runtime Configuration

Değiştirgeler

result

The query result identifier

index

index is the field whose nullability will be retrieved.

The possible values of index depend upon the value of ingres.array_index_start. If ingres.array_index_start is 1 (the default) then index must be between 1 and the value returned by ingres_num_fields(). If ingres.array_index_start is 0 then index must be between 0 and ingres_num_fields() - 1.

Dönen Değerler

ingres_field_nullable() returns TRUE if the field can be set to the NULL value and FALSE if it cannot

Ayrıca Bakınız

  • ingres_query() - Send an SQL query to Ingres
  • ingres_fetch_array() - Fetch a row of result into an array
  • ingres_fetch_assoc() - Fetch a row of result into an associative array
  • ingres_fetch_object() - Fetch a row of result into an object
  • ingres_fetch_row() - Fetch a row of result into an enumerated array

ingres_field_name
ingres_field_precision
Ingres İşlevleri


Get the precision of a field

ingres_field_nullable
ingres_field_scale
Ingres İşlevleri
PHP Manual

ingres_field_precision

(PHP 4 >= 4.0.2, PHP 5 <= 5.0.5, PECL ingres >= 1.0.0)

ingres_field_precision — Get the precision of a field

Açıklama

int ingres_field_precision ( resource $result , int $index )

ingres_field_precision() returns the precision of a field. This value is used only for decimal, float, and money SQL data types. For detailed information, see the Ingres OpenAPI User Guide, Appendix "Data Types" in the Ingres documentation.

Bilginize: Related Configurations

See ingres.array_index_start in Runtime Configuration

Değiştirgeler

result

The query result identifier

index

index is the field whose precision will be retrieved.

The possible values of index depend upon the value of ingres.array_index_start. If ingres.array_index_start is 1 (the default) then index must be between 1 and the value returned by ingres_num_fields(). If ingres.array_index_start is 0 then index must be between 0 and ingres_num_fields() - 1.

Dönen Değerler

Returns the field precision as an integer

Ayrıca Bakınız

  • ingres_query() - Send an SQL query to Ingres
  • ingres_fetch_array() - Fetch a row of result into an array
  • ingres_fetch_assoc() - Fetch a row of result into an associative array
  • ingres_fetch_object() - Fetch a row of result into an object
  • ingres_fetch_row() - Fetch a row of result into an enumerated array

ingres_field_nullable
ingres_field_scale
Ingres İşlevleri


Get the scale of a field

ingres_field_precision
ingres_field_type
Ingres İşlevleri
PHP Manual

ingres_field_scale

(PHP 4 >= 4.0.2, PHP 5 <= 5.0.5, PECL ingres >= 1.0.0)

ingres_field_scale — Get the scale of a field

Açıklama

int ingres_field_scale ( resource $result , int $index )

ingres_field_scale() returns the scale of a field. This value is used only for the decimal SQL data type. For detailed information, see the Ingres OpenAPI User Guide, Appendix "Data Types" in the Ingres documentation.

Bilginize: Related Configurations

See ingres.array_index_start in Runtime Configuration

Değiştirgeler

result

The query result identifier

index

index is the field whose scale will be retrieved.

The possible values of index depend upon the value of ingres.array_index_start. If ingres.array_index_start is 1 (the default) then index must be between 1 and the value returned by ingres_num_fields(). If ingres.array_index_start is 0 then index must be between 0 and ingres_num_fields() - 1.

Dönen Değerler

Returns the scale of the field, as an integer

Ayrıca Bakınız

  • ingres_query() - Send an SQL query to Ingres
  • ingres_fetch_array() - Fetch a row of result into an array
  • ingres_fetch_assoc() - Fetch a row of result into an associative array
  • ingres_fetch_object() - Fetch a row of result into an object
  • ingres_fetch_row() - Fetch a row of result into an enumerated array

ingres_field_precision
ingres_field_type
Ingres İşlevleri


Get the type of a field in a query result

ingres_field_scale
ingres_free_result
Ingres İşlevleri
PHP Manual

ingres_field_type

(PHP 4 >= 4.0.2, PHP 5 <= 5.0.5, PECL ingres >= 1.0.0)

ingres_field_type — Get the type of a field in a query result

Açıklama

string ingres_field_type ( resource $result , int $index )

Get the type of a field in a query result.

Bilginize: Related Configurations

See ingres.array_index_start in Runtime Configuration

Değiştirgeler

result

The query result identifier

index

index is the field whose type will be retrieved.

The possible values of index depend upon the value of ingres.array_index_start. If ingres.array_index_start is 1 (the default) then index must be between 1 and the value returned by ingres_num_fields(). If ingres.array_index_start is 0 then index must be between 0 and ingres_num_fields() - 1.

Dönen Değerler

ingres_field_type() returns the type of a field in a query result başarısızlık durumunda FALSE döner. Examples of types returned are IIAPI_BYTE_TYPE, IIAPI_CHA_TYPE, IIAPI_DTE_TYPE, IIAPI_FLT_TYPE, IIAPI_INT_TYPE, IIAPI_VCH_TYPE. Some of these types can map to more than one SQL type depending on the length of the field (see ingres_field_length()). For example IIAPI_FLT_TYPE can be a float4 or a float8. For detailed information, see the Ingres OpenAPI User Guide, Appendix "Data Types" in the Ingres documentation.

Ayrıca Bakınız

  • ingres_query() - Send an SQL query to Ingres
  • ingres_fetch_array() - Fetch a row of result into an array
  • ingres_fetch_assoc() - Fetch a row of result into an associative array
  • ingres_fetch_object() - Fetch a row of result into an object
  • ingres_fetch_row() - Fetch a row of result into an enumerated array

ingres_field_scale
ingres_free_result
Ingres İşlevleri


Free the resources associated with a result identifier

ingres_field_type
ingres_next_error
Ingres İşlevleri
PHP Manual

ingres_free_result

(PECL ingres >= 2.0.0)

ingres_free_result — Free the resources associated with a result identifier

Açıklama

bool ingres_free_result ( resource $result )

Değiştirgeler

result

The query result identifier

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Free a result resource

<?php
$link = ingres_connect($database, $user, $password);

$result = ingres_query($link, "select * from table");

while ($row = ingres_fetch_row($result)) {
    echo $row[1];
    echo $row[2];
}
ingres_free_result($result);

ingres_close($link)

?>

Ayrıca Bakınız

  • ingres_query() - Send an SQL query to Ingres

ingres_field_type
ingres_next_error
Ingres İşlevleri


Get the next Ingres error

ingres_free_result
ingres_num_fields
Ingres İşlevleri
PHP Manual

ingres_next_error

(PECL ingres >= 2.0.0)

ingres_next_error — Get the next Ingres error

Açıklama

bool ingres_next_error ([ resource $link ] )

Get the next Ingres error for the last executed query. Each call to ingres_next_error() can be followed by a call to ingres_errno(), ingres_error() or ingres_errsqlstate() to get the respective error number, error text, or SQL STATE. While ingres_next_error() returns TRUE, there are more errors to fetch.

Değiştirgeler

link

The connection link identifier

Dönen Değerler

ingres_next_error() returns TRUE if there is another error to retrieve or FALSE when there are no more errors

Ayrıca Bakınız

  • ingres_errno() - Get the last Ingres error number generated
  • ingres_error() - Get a meaningful error message for the last error generated
  • ingres_errsqlstate() - Get the last SQLSTATE error code generated

ingres_free_result
ingres_num_fields
Ingres İşlevleri


Get the number of fields returned by the last query

ingres_next_error
ingres_num_rows
Ingres İşlevleri
PHP Manual

ingres_num_fields

(PHP 4 >= 4.0.2, PHP 5 <= 5.0.5, PECL ingres >= 1.0.0)

ingres_num_fields — Get the number of fields returned by the last query

Açıklama

int ingres_num_fields ( resource $result )

ingres_num_fields() returns the number of fields in the results returned by the Ingres server after a call to ingres_query().

Değiştirgeler

result

The query result identifier

Dönen Değerler

Returns the number of fields

Ayrıca Bakınız

  • ingres_query() - Send an SQL query to Ingres
  • ingres_fetch_array() - Fetch a row of result into an array
  • ingres_fetch_assoc() - Fetch a row of result into an associative array
  • ingres_fetch_object() - Fetch a row of result into an object
  • ingres_fetch_row() - Fetch a row of result into an enumerated array

ingres_next_error
ingres_num_rows
Ingres İşlevleri


Get the number of rows affected or returned by a query

ingres_num_fields
ingres_pconnect
Ingres İşlevleri
PHP Manual

ingres_num_rows

(PHP 4 >= 4.0.2, PHP 5 <= 5.0.5, PECL ingres >= 1.0.0)

ingres_num_rows — Get the number of rows affected or returned by a query

Açıklama

int ingres_num_rows ( resource $result )

This function primarily is meant to get the number of rows modified in the database. However, it can be used to retrieve the number of rows to fetch for a SELECT statement.

Bilginize:

If scrollable cursors are disabled and this function is called before using ingres_fetch_array(), ingres_fetch_object(), or ingres_fetch_row(), the server will delete the result's data and the script will be unable to get them.

Instead, you should retrieve the result's data using one of these fetch functions in a loop until it returns FALSE, indicating that no more results are available.

Değiştirgeler

result

The result identifier for a query

Dönen Değerler

For delete, insert, or update queries, ingres_num_rows() returns the number of rows affected by the query. For other queries, ingres_num_rows() returns the number of rows in the query's result.

Ayrıca Bakınız

  • ingres_query() - Send an SQL query to Ingres
  • ingres_fetch_array() - Fetch a row of result into an array
  • ingres_fetch_assoc() - Fetch a row of result into an associative array
  • ingres_fetch_object() - Fetch a row of result into an object
  • ingres_fetch_row() - Fetch a row of result into an enumerated array

ingres_num_fields
ingres_pconnect
Ingres İşlevleri


Open a persistent connection to an Ingres database

ingres_num_rows
ingres_prepare
Ingres İşlevleri
PHP Manual

ingres_pconnect

(PHP 4 >= 4.0.2, PHP 5 <= 5.0.5, PECL ingres >= 1.0.0)

ingres_pconnect — Open a persistent connection to an Ingres database

Açıklama

resource ingres_pconnect ([ string $database [, string $username [, string $password [, array $options ]]]] )

Open a persistent connection to an Ingres database.

There are only two differences between this function and ingres_connect(): First, when connecting, the function will initially try to find a (persistent) link that is already opened with the same parameters. If one is found, an identifier for it will be returned instead of opening a new connection. Second, the connection to the Ingres server will not be closed when the execution of the script ends. Instead, the link will remain open for future use (ingres_close() will not close links established by ingres_pconnect()). This type of link is therefore called "persistent".

Değiştirgeler

database

The database name. Must follow the syntax:

[vnode::]dbname[/svr_class]

username

The Ingres user name

password

The password associated with username

options

See ingres_connect() for the list of options that can be passed

Dönen Değerler

Returns an Ingres link resource on success başarısızlık durumunda FALSE döner

Ayrıca Bakınız

  • ingres_connect() - Open a connection to an Ingres database
  • ingres_close() - Close an Ingres database connection

ingres_num_rows
ingres_prepare
Ingres İşlevleri


Prepare a query for later execution

ingres_pconnect
ingres_query
Ingres İşlevleri
PHP Manual

ingres_prepare

(PECL ingres >= 1.1.0)

ingres_prepare — Prepare a query for later execution

Açıklama

mixed ingres_prepare ( resource $link , string $query )

Prepares a query for execution by ingres_execute().

The query becomes part of the currently open transaction. If there is no open transaction, ingres_query() opens a new transaction. To close the transaction, you can call either ingres_commit() to commit the changes made to the database or ingres_rollback() to cancel these changes. When the script ends, any open transaction is rolled back (by calling ingres_rollback()). You can also use ingres_autocommit() before opening a new transaction to have every SQL query immediately committed.

Bilginize: Related Configurations

See also the ingres.describe, ingres.scrollable and ingres.utf8 directives in Runtime Configuration.

Değiştirgeler

link

The connection link identifier

query

A valid SQL query (see the Ingres SQL reference guide) in the Ingres documentation. See the query parameter in ingres_query() for a list of SQL statements which cannot be executed using ingres_prepare()

Dönen Değerler

ingres_prepare() returns a query result identifier that
is used with ingres_execute() to execute the query. To see
if an error occurred, use ingres_errno(),
ingres_error(), or
ingres_errsqlstate().

Ayrıca Bakınız

  • ingres_unbuffered_query() - Send an unbuffered SQL query to Ingres
  • ingres_fetch_array() - Fetch a row of result into an array
  • ingres_fetch_assoc() - Fetch a row of result into an associative array
  • ingres_fetch_object() - Fetch a row of result into an object
  • ingres_fetch_row() - Fetch a row of result into an enumerated array
  • ingres_commit() - Commit a transaction
  • ingres_rollback() - Roll back a transaction
  • ingres_autocommit() - Switch autocommit on or off
  • ingres_set_environment() - Set environment features controlling output options
  • ingres_errno() - Get the last Ingres error number generated
  • ingres_error() - Get a meaningful error message for the last error generated

ingres_pconnect
ingres_query
Ingres İşlevleri


Send an SQL query to Ingres

ingres_prepare
ingres_result_seek
Ingres İşlevleri
PHP Manual

ingres_query

(PHP 4 >= 4.0.2, PHP 5 <= 5.0.5, PECL ingres >= 1.0.0)

ingres_query — Send an SQL query to Ingres

Açıklama

mixed ingres_query ( resource $link , string $query [, array $params [, string $types ]] )

ingres_query() sends the given query to the Ingres server.

The query becomes part of the currently open transaction. If there is no open transaction, ingres_query() opens a new transaction. To close the transaction, you can call either ingres_commit() to commit the changes made to the database or ingres_rollback() to cancel these changes. When the script ends, any open transaction is rolled back (by calling ingres_rollback()). You can also use ingres_autocommit() before opening a new transaction to have every SQL query immediately committed.

Bilginize: Related Configurations

See also the ingres.describe, ingres.scrollable and ingres.utf8 directives in Runtime Configuration

Değiştirgeler

link

The connection link identifier.

query

A valid SQL query (see the Ingres SQL reference guide) in the Ingres documentation.

Data inside the query should be properly escaped.

The following types of SQL queries cannot be sent with this function:

  • close (see ingres_close())
  • commit (see ingres_commit())
  • connect (see ingres_connect())
  • disconnect (see ingres_close())
  • get dbevent
  • prepare to commit
  • rollback (see ingres_rollback())
  • savepoint
  • set autocommit (see ingres_autocommit())
  • all cursor-related queries are unsupported

params

An array of parameter values to be used with the query

types

A string containing a sequence of types for the parameter values passed. When ingres.describe is enabled, this parameter can be ignored as the driver automatically fetches the expected parameter types from the server.

Type code | Ingres type
a | BOOLEAN
b | BYTE
B | LONG BYTE/BLOB
c | CHAR
d | DATE/ANSIDATE/TIMESTAMP/TIME
f | FLOAT
i | INTEGER
L | LONG TEXT
m | MONEY
M | LONG NVARCHAR
n | NCHAR
N | NVARCHAR
t | TEXT
v | VARCHAR
V | LONG VARCHAR

Dönen Değerler

ingres_query() returns a query result identifier on
success else it returns FALSE. To see if an error
occurred use ingres_errno(),
ingres_error() or
ingres_errsqlstate().

Örnekler

Örnek 1 Send a simple select

<?php
$link = ingres_connect("demodb");

$result = ingres_query($link, "select * from user_profile");
while ($row = ingres_fetch_row($result)) {
    echo $row[1];
    echo $row[2];
}
?>

Örnek 2 Passing query parameters to ingres_query()

<?php
$link = ingres_connect("demodb");

$params[] = "Emma";
$query = "select * from user_profile where up_first = ?";
$result = ingres_query($link, $query, $params);
while ($row = ingres_fetch_row($result)) {
    echo $row[1];
    echo $row[2];
}
?>

Örnek 3 Inserting a BLOB with parameter types

<?php
$link = ingres_connect("demodb");

//Open a photo
$fh = fopen("photo.jpg","r");
$blob_data = stream_get_contents($fh);
fclose($fh);

//Prepare parameters
$params[] = $blob_data;
$params[] = 1201;

//Define parameter types
$param_types = "Bi";

$query = "update user_profile set up_image = ? where up_id = ?";
$result = ingres_query($link, $query , $params, $param_types);

if (ingres_errno())
{
    echo ingres_errno() . "-" . ingres_error() . "\n";
}

ingres_commit($link);

ingres_close($link);
?>

Ayrıca Bakınız

  • ingres_unbuffered_query() - Send an unbuffered SQL query to Ingres
  • ingres_fetch_array() - Fetch a row of result into an array
  • ingres_fetch_assoc() - Fetch a row of result into an associative array
  • ingres_fetch_object() - Fetch a row of result into an object
  • ingres_fetch_row() - Fetch a row of result into an enumerated array
  • ingres_commit() - Commit a transaction
  • ingres_rollback() - Roll back a transaction
  • ingres_autocommit() - Switch autocommit on or off
  • ingres_set_environment() - Set environment features controlling output options
  • ingres_errno() - Get the last Ingres error number generated
  • ingres_error() - Get a meaningful error message for the last error generated

ingres_prepare
ingres_result_seek
Ingres İşlevleri


Set the row position before fetching data

ingres_query
ingres_rollback
Ingres İşlevleri
PHP Manual

ingres_result_seek

(PECL ingres >= 2.1.0)

ingres_result_seek — Set the row position before fetching data

Açıklama

bool ingres_result_seek ( resource $result , int $position )

This function is used to position the cursor associated with the result resource before issuing a fetch. If ingres.array_index_start is set to 0 then the first row is 0 else it is 1. ingres_result_seek() can be used only with queries that make use of scrollable cursors. It cannot be used with ingres_unbuffered_query().

Bilginize: Related Configurations

See also the ingres.scrollable and ingres.array_index_start directives in Runtime Configuration.

Değiştirgeler

result

The result identifier for a query

position

The row to position the cursor on. If ingres.array_index_start is set to 0, then the first row is 0, else it is 1

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Position the cursor on the 3rd row

<?php

$result=ingres_query($link, "select * from airport where ap_ccode = 'ES' order by ap_place asc");

/* goto row 3 */
if (!ingres_result_seek($result, 3))
{
    echo ingres_errno() . " - " . ingres_error . "\n";
    die("i died");
}
else
{
    $airport = ingres_fetch_object ($result);
    {
        echo $airport->ap_iatacode . " - " .  $airport->ap_name . "\n";
    }
}

ingres_commit($link);

?>

Ayrıca Bakınız

  • ingres_query() - Send an SQL query to Ingres
  • ingres_fetch_array() - Fetch a row of result into an array
  • ingres_fetch_assoc() - Fetch a row of result into an associative array
  • ingres_fetch_object() - Fetch a row of result into an object
  • ingres_fetch_row() - Fetch a row of result into an enumerated array

ingres_query
ingres_rollback
Ingres İşlevleri


Roll back a transaction

ingres_result_seek
ingres_set_environment
Ingres İşlevleri
PHP Manual

ingres_rollback

(PHP 4 >= 4.0.2, PHP 5 <= 5.0.5, PECL ingres >= 1.0.0)

ingres_rollback — Roll back a transaction

Açıklama

bool ingres_rollback ( resource $link )

ingres_rollback() rolls back the currently open transaction, actually cancelling all changes made to the database during the transaction.

This closes the transaction. A new transaction can be opened by sending a query with ingres_query().

Değiştirgeler

link

The connection link identifier

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ingres_query() - Send an SQL query to Ingres
  • ingres_commit() - Commit a transaction
  • ingres_autocommit() - Switch autocommit on or off

ingres_result_seek
ingres_set_environment
Ingres İşlevleri


Set environment features controlling output options

ingres_rollback
ingres_unbuffered_query
Ingres İşlevleri
PHP Manual

ingres_set_environment

(PECL ingres >= 1.2.0)

ingres_set_environment — Set environment features controlling output options

Açıklama

bool ingres_set_environment ( resource $link , array $options )

ingres_set_environment() is called to set environmental options that affect the output of certain values from Ingres, such as the timezone, date format, decimal character separator, and float precision.

Değiştirgeler

link

The connection link identifier

options

An enumerated array of option name/value pairs. The following table lists the option name and the expected type

Option name | Option type | Description | Example
date_century_boundary | integer | The threshold by which a 2-digit year is determined to be in the current century or in the next century. Equivalent to II_DATE_CENTURY_BOUNDARY | 50
timezone | string | Controls the timezone of the session. If not set, it will default the value defined by II_TIMEZONE_NAME. If II_TIMEZONE_NAME is not defined, NA-PACIFIC (GMT-8 with Daylight Savings) is used. | UNITED-KINGDOM
date_format integer

Sets the allowable input and output format for Ingres dates. Defaults to the value defined by II_DATE_FORMAT. If II_DATE_FORMAT is not set, the default date format is US, for example mm/dd/yy. Valid values for date_format are:

  • INGRES_DATE_DMY
  • INGRES_DATE_FINISH
  • INGRES_DATE_GERMAN
  • INGRES_DATE_ISO
  • INGRES_DATE_ISO4
  • INGRES_DATE_MDY
  • INGRES_DATE_MULTINATIONAL
  • INGRES_DATE_MULTINATIONAL4
  • INGRES_DATE_YMD
  • INGRES_DATE_US

 INGRES_DATE_ISO4
decimal_separator string The character identifier for decimal data ","
money_lort integer

Leading or trailing currency sign. Valid values for money_lort are:

  • INGRES_MONEY_LEADING
  • INGRES_MONEY_TRAILING

 INGRES_MONEY_LEADING
money_sign string The currency symbol to be used with the MONEY datatype €
money_precision | integer | The precision of the MONEY datatype | 2
float4_precision | integer | Precision of the FLOAT4 datatype | 10
float8_precision | integer | Precision of the FLOAT8 data | 10
blob_segment_length | integer | The amount of data in bytes to fetch at a time when retrieving BLOB or CLOB data. Defaults to 4096 bytes when not set explicitly | 8192

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Set date_format to ISO4

<?php
$options = array( "date_format" => INGRES_DATE_ISO4 );

if (ingres_set_environment($link, $options))
{
    $result=ingres_query($link,"select date('now') as date");

    while ( $object = ingres_fetch_object ($result) ) {
        echo $object->date."\n";
    }
}
?>

Örnek 2 Set timezone to HONG-KONG

<?php

$options = array( "timezone" => "HONG-KONG");

if (ingres_set_environment($link, $options))
{
    $result=ingres_query($link,"select date('now') as date");

    while ( $object = ingres_fetch_object ($result) ) {
        echo $object->date."\n";
    }
}
?>

Ayrıca Bakınız

  • ingres_connect() - Open a connection to an Ingres database
  • ingres_query() - Send an SQL query to Ingres

ingres_rollback
ingres_unbuffered_query
Ingres İşlevleri


Send an unbuffered SQL query to Ingres

ingres_set_environment
MaxDB
Ingres İşlevleri
PHP Manual

ingres_unbuffered_query

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

ingres_unbuffered_query — Send an unbuffered SQL query to Ingres

Açıklama

mixed ingres_unbuffered_query ( resource $link , string $query [, array $params [, string $types ]] )

ingres_unbuffered_query() sends the given query to the Ingres server.

The query becomes part of the currently open transaction. If there is no open transaction, ingres_unbuffered_query() opens a new transaction. To close the transaction, you can call either ingres_commit() to commit the changes made to the database or ingres_rollback() to cancel these changes. When the script ends, any open transaction is rolled back (by calling ingres_rollback()). You can also use ingres_autocommit() before opening a new transaction to have every SQL query immediately committed. Ingres allows only a single unbuffered statement to be active at any one time. The extension will close any active unbuffered statements before executing any SQL. In addition you cannot use ingres_result_seek() to position the row before fetching.

Bilginize: Related Configurations

See also the ingres.describe and ingres.utf8 directives in Runtime Configuration.

Değiştirgeler

link

The connection link identifier

query

A valid SQL query (see the Ingres SQL reference guide) in the Ingres documentation. See the query parameter in ingres_query() for a list of SQL statements that cannot be executed via ingres_unbuffered_query().

Data inside the query should be properly escaped.

params

An array of parameter values to be used with the query

types

A string containing a sequence of types for the parameter values passed. See the types parameter in ingres_query() for the list of type codes.

Dönen Değerler

ingres_unbuffered_query() returns a query result identifier when there are rows to fetch; else it returns FALSE when there are no rows, as is the case of an INSERT, UPDATE, or DELETE statement. To see if an error occurred, use ingres_errno(), ingres_error(), or ingres_errsqlstate().

Örnekler

Örnek 1 Issue a simple un-buffered select

<?php
$link = ingres_connect("demodb");

$result = ingres_unbuffered_query($link, "select * from user_profile");
while ($row = ingres_fetch_row($result)) {
    echo $row[1];
    echo $row[2];
}
?>

Örnek 2 Passing query parameters to ingres_unbuffered_query()

<?php
$link = ingres_connect("demodb");

$params[] = "Emma";
$query = "select * from user_profile where up_first = ?";
$result = ingres_unbuffered_query($link, $query, $params);
while ($row = ingres_fetch_row($result)) {
    echo $row[1];
    echo $row[2];
}
?>

Örnek 3 Inserting a BLOB with parameter types

<?php
$link = ingres_connect("demodb");

//Open a photo
$fh = fopen("photo.jpg","r");
$blob_data = stream_get_contents($fh);
fclose($fh);

//Prepare parameters
$params[] = $blob_data;
$params[] = 1201;

//Define parameter types
$param_types = "Bi";

$query = "update user_profile set up_image = ? where up_id = ?";
$result = ingres_unbuffered_query($link, $query , $params, $param_types);

if (ingres_errno())
{
    echo ingres_errno() . "-" . ingres_error() . "\n";
}
?>

Ayrıca Bakınız

  • ingres_query() - Send an SQL query to Ingres
  • ingres_fetch_array() - Fetch a row of result into an array
  • ingres_fetch_assoc() - Fetch a row of result into an associative array
  • ingres_fetch_object() - Fetch a row of result into an object
  • ingres_fetch_row() - Fetch a row of result into an enumerated array
  • ingres_commit() - Commit a transaction
  • ingres_rollback() - Roll back a transaction
  • ingres_autocommit() - Switch autocommit on or off
  • ingres_set_environment() - Set environment features controlling output options
  • ingres_errno() - Get the last Ingres error number generated
  • ingres_error() - Get a meaningful error message for the last error generated

ingres_set_environment
MaxDB
Ingres İşlevleri


MaxDB

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
    • Basic usage
  • MaxDB İşlevleri
    • maxdb_affected_rows — Gets the number of affected rows in a previous MaxDB operation
    • maxdb_autocommit — Turns on or off auto-commiting database modifications
    • maxdb_bind_param — Takma Adı: maxdb_stmt_bind_param
    • maxdb_bind_result — Takma Adı: maxdb_stmt_bind_result
    • maxdb_change_user — Changes the user of the specified database connection
    • maxdb_character_set_name — Returns the default character set for the database connection
    • maxdb_client_encoding — Takma Adı: maxdb_character_set_name
    • maxdb_close_long_data — Takma Adı: maxdb_stmt_close_long_data
    • maxdb_close — Closes a previously opened database connection
    • maxdb_commit — Commits the current transaction
    • maxdb_connect_errno — Returns the error code from last connect call
    • maxdb_connect_error — Returns a string description of the last connect error
    • maxdb_connect — Open a new connection to the MaxDB server
    • maxdb_data_seek — Adjusts the result pointer to an arbitary row in the result
    • maxdb_debug — Performs debugging operations
    • maxdb_disable_reads_from_master — Disable reads from master
    • maxdb_disable_rpl_parse — Disable RPL parse
    • maxdb_dump_debug_info — Dump debugging information into the log
    • maxdb_embedded_connect — Open a connection to an embedded MaxDB server
    • maxdb_enable_reads_from_master — Enable reads from master
    • maxdb_enable_rpl_parse — Enable RPL parse
    • maxdb_errno — Returns the error code for the most recent function call
    • maxdb_error — Returns a string description of the last error
    • maxdb_escape_string — Takma Adı: maxdb_real_escape_string
    • maxdb_execute — Takma Adı: maxdb_stmt_execute
    • maxdb_fetch_array — Fetch a result row as an associative, a numeric array, or both
    • maxdb_fetch_assoc — Fetch a result row as an associative array
    • maxdb_fetch_field_direct — Fetch meta-data for a single field
    • maxdb_fetch_field — Returns the next field in the result set
    • maxdb_fetch_fields — Returns an array of resources representing the fields in a result set
    • maxdb_fetch_lengths — Returns the lengths of the columns of the current row in the result set
    • maxdb_fetch_object — Returns the current row of a result set as an object
    • maxdb_fetch_row — Get a result row as an enumerated array
    • maxdb_fetch — Takma Adı: maxdb_stmt_fetch
    • maxdb_field_count — Returns the number of columns for the most recent query
    • maxdb_field_seek — Set result pointer to a specified field offset
    • maxdb_field_tell — Get current field offset of a result pointer
    • maxdb_free_result — Frees the memory associated with a result
    • maxdb_get_client_info — Returns the MaxDB client version as a string
    • maxdb_get_client_version — Get MaxDB client info
    • maxdb_get_host_info — Returns a string representing the type of connection used
    • maxdb_get_metadata — Takma Adı: maxdb_stmt_result_metadata
    • maxdb_get_proto_info — Returns the version of the MaxDB protocol used
    • maxdb_get_server_info — Returns the version of the MaxDB server
    • maxdb_get_server_version — Returns the version of the MaxDB server as an integer
    • maxdb_info — Retrieves information about the most recently executed query
    • maxdb_init — Initializes MaxDB and returns an resource for use with maxdb_real_connect
    • maxdb_insert_id — Returns the auto generated id used in the last query
    • maxdb_kill — Disconnects from a MaxDB server
    • maxdb_master_query — Enforce execution of a query on the master in a master/slave setup
    • maxdb_more_results — Check if there any more query results from a multi query
    • maxdb_multi_query — Performs a query on the database
    • maxdb_next_result — Prepare next result from multi_query
    • maxdb_num_fields — Get the number of fields in a result
    • maxdb_num_rows — Gets the number of rows in a result
    • maxdb_options — Set options
    • maxdb_param_count — Takma Adı: maxdb_stmt_param_count
    • maxdb_ping — Pings a server connection, or tries to reconnect if the connection has gone down
    • maxdb_prepare — Prepare an SQL statement for execution
    • maxdb_query — Performs a query on the database
    • maxdb_real_connect — Opens a connection to a MaxDB server
    • maxdb_real_escape_string — Escapes special characters in a string for use in an SQL statement, taking into account the current charset of the connection
    • maxdb_real_query — Execute an SQL query
    • maxdb_report — Enables or disables internal report functions
    • maxdb_rollback — Rolls back current transaction
    • maxdb_rpl_parse_enabled — Check if RPL parse is enabled
    • maxdb_rpl_probe — RPL probe
    • maxdb_rpl_query_type — Returns RPL query type
    • maxdb_select_db — Selects the default database for database queries
    • maxdb_send_long_data — Takma Adı: maxdb_stmt_send_long_data
    • maxdb_send_query — Send the query and return
    • maxdb_server_end — Shut down the embedded server
    • maxdb_server_init — Initialize embedded server
    • maxdb_set_opt — Takma Adı: maxdb_options
    • maxdb_sqlstate — Returns the SQLSTATE error from previous MaxDB operation
    • maxdb_ssl_set — Used for establishing secure connections using SSL
    • maxdb_stat — Gets the current system status
    • maxdb_stmt_affected_rows — Returns the total number of rows changed, deleted, or inserted by the last executed statement
    • maxdb_stmt_bind_param — Binds variables to a prepared statement as parameters
    • maxdb_stmt_bind_result — Binds variables to a prepared statement for result storage
    • maxdb_stmt_close_long_data — Ends a sequence of maxdb_stmt_send_long_data
    • maxdb_stmt_close — Closes a prepared statement
    • maxdb_stmt_data_seek — Seeks to an arbitray row in statement result set
    • maxdb_stmt_errno — Returns the error code for the most recent statement call
    • maxdb_stmt_error — Returns a string description for last statement error
    • maxdb_stmt_execute — Executes a prepared Query
    • maxdb_stmt_fetch — Fetch results from a prepared statement into the bound variables
    • maxdb_stmt_free_result — Frees stored result memory for the given statement handle
    • maxdb_stmt_init — Initializes a statement and returns an resource for use with maxdb_stmt_prepare
    • maxdb_stmt_num_rows — Return the number of rows in statements result set
    • maxdb_stmt_param_count — Returns the number of parameter for the given statement
    • maxdb_stmt_prepare — Prepare an SQL statement for execution
    • maxdb_stmt_reset — Resets a prepared statement
    • maxdb_stmt_result_metadata — Returns result set metadata from a prepared statement
    • maxdb_stmt_send_long_data — Send data in blocks
    • maxdb_stmt_sqlstate — Returns SQLSTATE error from previous statement operation
    • maxdb_stmt_store_result — Transfers a result set from a prepared statement
    • maxdb_store_result — Transfers a result set from the last query
    • maxdb_thread_id — Returns the thread ID for the current connection
    • maxdb_thread_safe — Returns whether thread safety is given or not
    • maxdb_use_result — Initiate a result set retrieval
    • maxdb_warning_count — Returns the number of warnings from the last query for the given link
ingres_unbuffered_query
Giriş
Sağlayıcıya Göre Veritabanı Eklentileri


Giriş

The MaxDB PHP extension allows you to access the functionality provided by MaxDB 7.5.0 and above. More information about the MaxDB Database server can be found at » http://www.sdn.sap.com/irj/sdn/maxdb.

The MaxDB PHP extension is compatible to the MySQL mysqli extension. There are only minor differences in the behaviour of some functions due to the differences of the underlying database servers, MaxDB and MySQL.

The main differences to mysqli are in the following functions:

  • maxdb_character_set_name() - Returns only ascii or unicode.
  • maxdb_get_client_info() - Returns a different version string.
  • maxdb_get_client_version() - Returns a different version string.
  • maxdb_get_host_info() - Returns localhost or hostname.
  • maxdb_get_server_info() - Returns a different version string.
  • maxdb_get_server_version() - Returns a different version string.
  • maxdb_kill() - Only disconnects the session.
  • maxdb_multi_query() - Can not handle multiple SQL statements.
  • maxdb_next_result() - Function returns always false.
  • maxdb_options() - Supports a different set of options.
  • maxdb_report() - Supports a different report mode.
  • maxdb_stat() - Returns a different system status string.
  • maxdb_stmt_store_result() - Is not necessary for MaxDB.
  • maxdb_store_result() - Is not necessary for MaxDB.

Documentation for MaxDB can be found at » http://maxdb.sap.com/documentation/.

MaxDB
Yapılandırma/Kurulum
MaxDB


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
MaxDB


Gereksinimler

In order to have these functions available, you must compile PHP with MaxDB support. Additionally, you must have the MaxDB SQLDBC runtime library available to access the MaxDB server.

Documentation for MaxDB SQLDBC can be found at » http://maxdb.sap.com/documentation/.

Download the MaxDB SQLDBC package from » http://www.sdn.sap.com/irj/sdn/maxdb-downloads.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

By using the --with-maxdb[=DIR] configuration option you enable PHP to access MaxDB databases. [DIR] points to the directory that contains the installed MaxDB SQLDBC package.

Windows users will need to enable php_maxdb.dll inside of php.ini.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

MaxDB Configuration Options
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
maxdb.default_host | NULL | PHP_INI_ALL |
maxdb.default_db | NULL | PHP_INI_ALL |
maxdb.default_user | NULL | PHP_INI_ALL |
maxdb.default_pw | NULL | PHP_INI_ALL |
maxdb.long_readlen | "200" | PHP_INI_ALL |
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

maxdb.default_host string

The default server host to use when connecting to the database server if no other host is specified.

maxdb.default_db string

The default server database to use when connecting if no other database is specified.

maxdb.default_user string

The default user name to use when connecting to the database server if no other name is specified.

maxdb.default_pw string

The default password to use when connecting to the database server if no other password is specified.

maxdb.long_readlen integer

The default maximum length of bytes that is transferred to the client if long data is retrieved from the MaxDB database server.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Özkaynak Türleri

This extension defines resources.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

The following constants to use with maxdb_options() are defined. For further description of these constants see » http://maxdb.sap.com/documentation/.

MaxDB PHP client constants
Constant | Description
MAXDB_COMPNAME | The component name used to initialise the SQLDBC runtime environment.
MAXDB_APPLICATION | The application to be connected to the database.
MAXDB_APPVERSION | The version of the application.
MAXDB_SQLMODE | The SQL mode.
MAXDB_UNICODE | TRUE, if the connection is an unicode (UCS2) client or FALSE, if not.
MAXDB_TIMEOUT | The maximum allowed time of inactivity after which the connection to the database is closed by the system.
MAXDB_ISOLATIONLEVEL | Specifies whether and how shared locks and exclusive locks are implicitly requested or released.
MAXDB_PACKETCOUNT | The number of different request packets used for the connection.
MAXDB_STATEMENTCACHESIZE | The number of prepared statements to be cached for the connection for re-use.
MAXDB_CURSORPREFIX | The prefix to use for result tables that are automatically named.

The function maxdb_fetch_array() uses a constant for the different types of result arrays. The following constants are defined:

MaxDB fetch constants
Constant | Description
MAXDB_ASSOC | Columns are returned into the array having the fieldname as the array index.
MAXDB_ASSOC_UPPER | Columns are returned into the array having the upper case fieldname as the array index.
MAXDB_ASSOC_LOWER | Columns are returned into the array having the lower case fieldname as the array index.
MAXDB_BOTH | Columns are returned into the array having both a numerical index and the fieldname as the array index.
MAXDB_NUM | Columns are returned into the array having a numerical index to the fields. This index starts with 0, the first field in the result.

Özkaynak Türleri
Örnekler
MaxDB


Örnekler

İçindekiler

  • Basic usage
Öntanımlı Sabitler
Basic usage
MaxDB


Basic usage

All examples in the MaxDB PHP documentation use the HOTELDB demo database from MaxDB. More about this database can be found at » http://maxdb.sap.com/doc/7_7/44/d8c25164bb38d0e10000000a1553f7/content.htm.

To use the examples in the MaxDB PHP documentation, you have to load the tutorial data into your database. Then you have to set maxdb.default_db in php.ini to the database that contains the tutorial data.

This simple example shows how to connect, execute a query, print resulting rows and disconnect from a MaxDB database.

Örnek 1 MaxDB extension overview example

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* Performing SQL query */
$query = "SELECT * FROM hotel.city";
$result = maxdb_query($link, $query) or die("Query failed : " . maxdb_error());

/* Printing results in HTML */
echo "<table>\n";
while ($line = maxdb_fetch_array($result, MAXDB_ASSOC)) {
    echo "  <tr>\n";
    foreach ($line as $col_value) {
        echo "    <td>$col_value</td>\n";
    }
    echo "  </tr>\n";
}
echo "</table>\n";

/* Free resultset */
maxdb_free_result($result);

/* Closing connection */
maxdb_close($link);
?>

The following example shows how to bind variables to a SELECT INTO statement.

Örnek 2 Example for use of SELECT INTO statements

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (!$link) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* Performing SQL query */
$stmt = maxdb_prepare ($link, "SELECT percentage INTO ? FROM hotel.countrylanguage where language = ?");
if (!$stmt) {
  printf ("Prepare failed: %s\n", maxdb_error($link));
}

$name = "Mbundu";

maxdb_stmt_bind_param($stmt, 'ds', $percentage, $name);
maxdb_stmt_execute($stmt);

printf ("%f\n", $percentage);

maxdb_stmt_close ($stmt);
?>

The following example shows how to use MaxDB database procedures.

Örnek 3 Example fore using database procedures

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (!$link) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

maxdb_report (MAXDB_REPORT_OFF);
maxdb_query($link,"DROP DBPROC test_proc");
maxdb_report (MAXDB_REPORT_ERROR);

$query = "create dbproc test_proc (INOUT e_text char(72)) AS select * from SYSDBA.DUAL; fetch into :e_text;";

maxdb_query($link, $query);

/* Performing SQL query */
$stmt = maxdb_prepare ($link, "CALL test_proc (?)");
if (!$stmt) {
  printf ("Prepare failed: %s\n", maxdb_error($link));
}

maxdb_stmt_bind_param($stmt, 's', $result);
maxdb_stmt_execute($stmt);

printf ("%s\n", $result);

maxdb_stmt_close ($stmt);
?>

Örnekler
MaxDB İşlevleri
Örnekler


Basic usage
maxdb_affected_rows
MaxDB
PHP Manual

MaxDB İşlevleri

Öntanımlı Sınıflar

maxdb

Represents a connection between PHP and a MaxDB database.

Nesne Kurucu

  • maxdb - construct a new maxdb object

Yöntemler

  • autocommit - turns on or off auto-commiting database modifications

  • change_user - changes the user of the specified database connection

  • character_set_name - returns the default character set for the database connection

  • close - closes a previously opened connection

  • commit - commits the current transaction

  • connect - opens a new connection to MaxDB database server

  • debug - performs debugging operations

  • dump_debug_info - dumps debug information

  • get_client_info - returns client version

  • get_host_info - returns type of connection used

  • get_server_info - returns version of the MaxDB server

  • get_server_version - returns version of the MaxDB server

  • init - initializes maxdb object

  • info - retrieves information about the most recently executed query

  • kill - asks the server to kill a MaxDB thread

  • multi_query - performs multiple queries

  • more_results - check if more results exist from currently executed multi-query

  • next_result - reads next result from currently executed multi-query

  • options - set options

  • ping - pings a server connection or reconnects if there is no connection

  • prepare - prepares an SQL query

  • query - performs a query

  • real_connect - attempts to open a connection to MaxDB database server

  • escape_string - escapes special characters in a string for use in an SQL statement, taking into account the current charset of the connection

  • rollback - rolls back the current transaction

  • select_db - selects the default database

  • ssl_set - sets ssl parameters

  • stat - gets the current system status

  • stmt_init- initializes a statement for use with maxdb_stmt_prepare

  • store_result - transfers a resultset from last query

  • use_result - transfers an unbuffered resultset from last query

  • thread-safe - returns whether thread safety is given or not

Özellikler

  • affected_rows - gets the number of affected rows in a previous MaxDB operation

  • client_info - returns the MaxDB client version as a string

  • client_version - returns the MaxDB client version as an integer

  • errno - returns the error code for the most recent function call

  • error - returns the error string for the most recent function call

  • field_count - returns the number of columns for the most recent query

  • host_info - returns a string representing the type of connection used

  • info - retrieves information about the most recently executed query

  • insert_id - returns the auto generated id used in the last query

  • protocol_version - returns the version of the MaxDB protocol used

  • sqlstate - returns a string containing the SQLSTATE error code for the last error

  • thread_id - returns the thread ID for the current connection

  • warning_count - returns the number of warnings generated during execution of the previous SQL statement

maxdb_stmt

Represents a prepared statement.

Yöntemler

  • bind_param - binds variables to a prepared statement

  • bind_result - binds variables to a prepared statement for result storage

  • close - closes a prepared statement

  • data-seek - seeks to an arbitrary row in a statement result set

  • execute - executes a prepared statement

  • fetch - fetches result from a prepared statement into bound variables

  • free_result - frees stored result memory for the given statement handle

  • result_metadata - retrieves a resultset from a prepared statement for metadata information

  • prepare - prepares an SQL query

  • send_long_data - sends data in chunks

  • close_long_data - end sending long data

  • reset - resets a prepared statement

  • store_result - buffers complete resultset from a prepared statement

Özellikler

  • affected_rows - returns affected rows from last statement execution

  • errno - returns errorcode for last statement function

  • errno - returns errormessage for last statement function

  • param_count - returns number of parameter for a given prepare statement

  • sqlstate - returns a string containing the SQLSTATE error code for the last statement function

maxdb_result

Represents the result set obtained from a query against the database.

Yöntemler

  • close - closes resultset

  • data_seek - moves internal result pointer

  • fetch_field - gets column information from a resultset

  • fetch_fields - gets information for all columns from a resulset

  • fetch_field_direct - gets column information for specified column

  • fetch_array - fetches a result row as an associative array, a numeric array, or both.

  • fetch_assoc - fetches a result row as an associative array

  • fetch_object - fetches a result row as an object

  • fetch_row - gets a result row as an enumerated array

  • close - frees result memory

  • field_seek - set result pointer to a specified field offset

Özellikler

  • current_field - returns offset of current fieldpointer

  • field_count - returns number of fields in resultset

  • lengths - returns an array of columnlengths

  • num_rows - returns number of rows in resultset

İçindekiler

  • maxdb_affected_rows — Gets the number of affected rows in a previous MaxDB operation
  • maxdb_autocommit — Turns on or off auto-commiting database modifications
  • maxdb_bind_param — Takma Adı: maxdb_stmt_bind_param
  • maxdb_bind_result — Takma Adı: maxdb_stmt_bind_result
  • maxdb_change_user — Changes the user of the specified database connection
  • maxdb_character_set_name — Returns the default character set for the database connection
  • maxdb_client_encoding — Takma Adı: maxdb_character_set_name
  • maxdb_close_long_data — Takma Adı: maxdb_stmt_close_long_data
  • maxdb_close — Closes a previously opened database connection
  • maxdb_commit — Commits the current transaction
  • maxdb_connect_errno — Returns the error code from last connect call
  • maxdb_connect_error — Returns a string description of the last connect error
  • maxdb_connect — Open a new connection to the MaxDB server
  • maxdb_data_seek — Adjusts the result pointer to an arbitary row in the result
  • maxdb_debug — Performs debugging operations
  • maxdb_disable_reads_from_master — Disable reads from master
  • maxdb_disable_rpl_parse — Disable RPL parse
  • maxdb_dump_debug_info — Dump debugging information into the log
  • maxdb_embedded_connect — Open a connection to an embedded MaxDB server
  • maxdb_enable_reads_from_master — Enable reads from master
  • maxdb_enable_rpl_parse — Enable RPL parse
  • maxdb_errno — Returns the error code for the most recent function call
  • maxdb_error — Returns a string description of the last error
  • maxdb_escape_string — Takma Adı: maxdb_real_escape_string
  • maxdb_execute — Takma Adı: maxdb_stmt_execute
  • maxdb_fetch_array — Fetch a result row as an associative, a numeric array, or both
  • maxdb_fetch_assoc — Fetch a result row as an associative array
  • maxdb_fetch_field_direct — Fetch meta-data for a single field
  • maxdb_fetch_field — Returns the next field in the result set
  • maxdb_fetch_fields — Returns an array of resources representing the fields in a result set
  • maxdb_fetch_lengths — Returns the lengths of the columns of the current row in the result set
  • maxdb_fetch_object — Returns the current row of a result set as an object
  • maxdb_fetch_row — Get a result row as an enumerated array
  • maxdb_fetch — Takma Adı: maxdb_stmt_fetch
  • maxdb_field_count — Returns the number of columns for the most recent query
  • maxdb_field_seek — Set result pointer to a specified field offset
  • maxdb_field_tell — Get current field offset of a result pointer
  • maxdb_free_result — Frees the memory associated with a result
  • maxdb_get_client_info — Returns the MaxDB client version as a string
  • maxdb_get_client_version — Get MaxDB client info
  • maxdb_get_host_info — Returns a string representing the type of connection used
  • maxdb_get_metadata — Takma Adı: maxdb_stmt_result_metadata
  • maxdb_get_proto_info — Returns the version of the MaxDB protocol used
  • maxdb_get_server_info — Returns the version of the MaxDB server
  • maxdb_get_server_version — Returns the version of the MaxDB server as an integer
  • maxdb_info — Retrieves information about the most recently executed query
  • maxdb_init — Initializes MaxDB and returns an resource for use with maxdb_real_connect
  • maxdb_insert_id — Returns the auto generated id used in the last query
  • maxdb_kill — Disconnects from a MaxDB server
  • maxdb_master_query — Enforce execution of a query on the master in a master/slave setup
  • maxdb_more_results — Check if there any more query results from a multi query
  • maxdb_multi_query — Performs a query on the database
  • maxdb_next_result — Prepare next result from multi_query
  • maxdb_num_fields — Get the number of fields in a result
  • maxdb_num_rows — Gets the number of rows in a result
  • maxdb_options — Set options
  • maxdb_param_count — Takma Adı: maxdb_stmt_param_count
  • maxdb_ping — Pings a server connection, or tries to reconnect if the connection has gone down
  • maxdb_prepare — Prepare an SQL statement for execution
  • maxdb_query — Performs a query on the database
  • maxdb_real_connect — Opens a connection to a MaxDB server
  • maxdb_real_escape_string — Escapes special characters in a string for use in an SQL statement, taking into account the current charset of the connection
  • maxdb_real_query — Execute an SQL query
  • maxdb_report — Enables or disables internal report functions
  • maxdb_rollback — Rolls back current transaction
  • maxdb_rpl_parse_enabled — Check if RPL parse is enabled
  • maxdb_rpl_probe — RPL probe
  • maxdb_rpl_query_type — Returns RPL query type
  • maxdb_select_db — Selects the default database for database queries
  • maxdb_send_long_data — Takma Adı: maxdb_stmt_send_long_data
  • maxdb_send_query — Send the query and return
  • maxdb_server_end — Shut down the embedded server
  • maxdb_server_init — Initialize embedded server
  • maxdb_set_opt — Takma Adı: maxdb_options
  • maxdb_sqlstate — Returns the SQLSTATE error from previous MaxDB operation
  • maxdb_ssl_set — Used for establishing secure connections using SSL
  • maxdb_stat — Gets the current system status
  • maxdb_stmt_affected_rows — Returns the total number of rows changed, deleted, or inserted by the last executed statement
  • maxdb_stmt_bind_param — Binds variables to a prepared statement as parameters
  • maxdb_stmt_bind_result — Binds variables to a prepared statement for result storage
  • maxdb_stmt_close_long_data — Ends a sequence of maxdb_stmt_send_long_data
  • maxdb_stmt_close — Closes a prepared statement
  • maxdb_stmt_data_seek — Seeks to an arbitray row in statement result set
  • maxdb_stmt_errno — Returns the error code for the most recent statement call
  • maxdb_stmt_error — Returns a string description for last statement error
  • maxdb_stmt_execute — Executes a prepared Query
  • maxdb_stmt_fetch — Fetch results from a prepared statement into the bound variables
  • maxdb_stmt_free_result — Frees stored result memory for the given statement handle
  • maxdb_stmt_init — Initializes a statement and returns an resource for use with maxdb_stmt_prepare
  • maxdb_stmt_num_rows — Return the number of rows in statements result set
  • maxdb_stmt_param_count — Returns the number of parameter for the given statement
  • maxdb_stmt_prepare — Prepare an SQL statement for execution
  • maxdb_stmt_reset — Resets a prepared statement
  • maxdb_stmt_result_metadata — Returns result set metadata from a prepared statement
  • maxdb_stmt_send_long_data — Send data in blocks
  • maxdb_stmt_sqlstate — Returns SQLSTATE error from previous statement operation
  • maxdb_stmt_store_result — Transfers a result set from a prepared statement
  • maxdb_store_result — Transfers a result set from the last query
  • maxdb_thread_id — Returns the thread ID for the current connection
  • maxdb_thread_safe — Returns whether thread safety is given or not
  • maxdb_use_result — Initiate a result set retrieval
  • maxdb_warning_count — Returns the number of warnings from the last query for the given link
Basic usage
maxdb_affected_rows
MaxDB
PHP Manual


Gets the number of affected rows in a previous MaxDB operation

MaxDB İşlevleri
maxdb_autocommit
MaxDB İşlevleri
PHP Manual

maxdb_affected_rows

maxdb::affected_rows

(PECL maxdb >= 1.0)

maxdb_affected_rows -- maxdb::affected_rows — Gets the number of affected rows in a previous MaxDB operation

Açıklama

Yordamsal kullanım

int maxdb_affected_rows ( resource $link )

Nesne yönelimli kullanım

int $maxdb->affected_rows;

maxdb_affected_rows() returns the number of rows affected by the last INSERT, UPDATE, or DELETE query associated with the provided link parameter. If this number cannot be determined, this function will return -1.

Bilginize:

For SELECT statements maxdb_affected_rows() works like maxdb_num_rows().

The maxdb_affected_rows() function only works with queries which modify a table. In order to return the number of rows from a SELECT query, use the maxdb_num_rows() function instead.

Dönen Değerler

An integer greater than zero indicates the number of rows affected or retrieved. Zero indicates that no records where updated for an UPDATE statement, no rows matched the WHERE clause in the query or that no query has yet been executed. -1 indicates that the number of rows affected can not be determined.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

maxdb_report (MAXDB_REPORT_OFF);
$maxdb->query("DROP TABLE mycustomer");
maxdb_report (MAXDB_REPORT_ERROR);

/* Insert rows */
$maxdb->query("CREATE TABLE mycustomer AS SELECT * from hotel.customer");
printf("Affected rows (INSERT): %d\n", $maxdb->affected_rows);

$maxdb->query("ALTER TABLE mycustomer ADD Status int default 0");

/* update rows */
$maxdb->query("UPDATE mycustomer SET Status=1 WHERE cno > 50");
printf("Affected rows (UPDATE): %d\n", $maxdb->affected_rows);

/* delete rows */
$maxdb->query("DELETE FROM mycustomer WHERE cno < 50");
printf("Affected rows (DELETE): %d\n", $maxdb->affected_rows);

/* select all rows */
$result = $maxdb->query("SELECT title FROM mycustomer");
printf("Affected rows (SELECT): %d\n", $maxdb->affected_rows);

$result->close();

/* Delete table Language */
$maxdb->query("DROP TABLE mycustomer");

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

if (!$link) {
   printf("Can't connect to localhost. Error: %s\n", maxdb_connect_error());
   exit();
}

maxdb_report (MAXDB_REPORT_OFF);
maxdb_query($link,"DROP TABLE mycustomer");
maxdb_report (MAXDB_REPORT_ERROR);

/* Insert rows */
maxdb_query($link, "CREATE TABLE mycustomer AS SELECT * from hotel.customer");
printf("Affected rows (INSERT): %d\n", maxdb_affected_rows($link));

maxdb_query($link, "ALTER TABLE mycustomer ADD Status int default 0");

/* update rows */
maxdb_query($link, "UPDATE mycustomer SET Status=1 WHERE cno > 50");
printf("Affected rows (UPDATE): %d\n", maxdb_affected_rows($link));

/* delete rows */
maxdb_query($link, "DELETE FROM mycustomer WHERE cno < 50");
printf("Affected rows (DELETE): %d\n", maxdb_affected_rows($link));

/* select all rows */
$result = maxdb_query($link, "SELECT title FROM mycustomer");
printf("Affected rows (SELECT): %d\n", maxdb_affected_rows($link));

maxdb_free_result($result);

/* Delete table Language */
maxdb_query($link, "DROP TABLE mycustomer");

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Affected rows (INSERT): 15
Affected rows (UPDATE): 15
Affected rows (DELETE): 0
Affected rows (SELECT): 15

Ayrıca Bakınız

  • maxdb_num_rows() - Gets the number of rows in a result
  • maxdb_info() - Retrieves information about the most recently executed query

MaxDB İşlevleri
maxdb_autocommit
MaxDB İşlevleri


Turns on or off auto-commiting database modifications

maxdb_affected_rows
maxdb_bind_param
MaxDB İşlevleri
PHP Manual

maxdb_autocommit

maxdb::auto_commit

(PECL maxdb >= 1.0)

maxdb_autocommit -- maxdb::auto_commit — Turns on or off auto-commiting database modifications

Açıklama

Yordamsal kullanım

bool maxdb_autocommit ( resource $link , bool $mode )

Nesne yönelimli kullanım

bool maxdb::auto_commit ( bool $mode )

maxdb_autocommit() is used to turn on or off auto-commit mode on queries for the database connection represented by the link resource.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* turn autocommit on */
$maxdb->autocommit(TRUE);

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

if (!$link) {
   printf("Can't connect to localhost. Error: %s\n", maxdb_connect_error());
   exit();
}

/* turn autocommit on */
maxdb_autocommit($link, TRUE);

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ayrıca Bakınız

  • maxdb_commit() - Commits the current transaction
  • maxdb_rollback() - Rolls back current transaction

maxdb_affected_rows
maxdb_bind_param
MaxDB İşlevleri


Takma Adı: maxdb_stmt_bind_param

maxdb_autocommit
maxdb_bind_result
MaxDB İşlevleri
PHP Manual

maxdb_bind_param

(PECL maxdb 1.0)

maxdb_bind_param — Takma Adı: maxdb_stmt_bind_param()

Açıklama

Bu işlev şu işlevin takma adıdır: maxdb_stmt_bind_param()

Bu takma ad, PHP'nin ileri sürümlerinde kaldırılabileceğinden kullanılması önerilmemektedir ve şimdilik sadece geriye uyumluluk adına mevcuttur.

maxdb_autocommit
maxdb_bind_result
MaxDB İşlevleri


Takma Adı: maxdb_stmt_bind_result

maxdb_bind_param
maxdb_change_user
MaxDB İşlevleri
PHP Manual

maxdb_bind_result

(PECL maxdb 1.0)

maxdb_bind_result — Takma Adı: maxdb_stmt_bind_result()

Açıklama

Bu işlev şu işlevin takma adıdır: maxdb_stmt_bind_result().

Bu takma ad, PHP'nin ileri sürümlerinde kaldırılabileceğinden kullanılması önerilmemektedir ve şimdilik sadece geriye uyumluluk adına mevcuttur.

maxdb_bind_param
maxdb_change_user
MaxDB İşlevleri


Changes the user of the specified database connection

maxdb_bind_result
maxdb_character_set_name
MaxDB İşlevleri
PHP Manual

maxdb_change_user

maxdb::change_user

(PECL maxdb >= 1.0)

maxdb_change_user -- maxdb::change_user — Changes the user of the specified database connection

Açıklama

Yordamsal kullanım

bool maxdb_change_user ( resource $link , string $user , string $password , string $database )

Nesne yönelimli kullanım

bool maxdb::change_user ( string $user , string $password , string $database )

maxdb_change_user() is used to change the user of the specified database connection as given by the link parameter and to set the current database to that specified by the database parameter.

In order to successfully change users a valid username and password parameters must be provided and that user must have sufficient permissions to access the desired database. If for any reason authorization fails, the current user authentication will remain.

Bilginize:

Using this command will always cause the current database connection to behave as if was a completely new database connection, regardless of if the operation was completed successfully. This reset includes performing a rollback on any active transactions, closing all temporary tables, and unlocking all locked tables.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php

/* connect database test */
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

if ($result = $maxdb->query("SELECT * FROM dual")) {
   $row = $result->fetch_row();
   printf("Result: %s\n", $row[0]);
   $result->free();
}

/* reset all and select a new database */
if (!$maxdb->change_user("DBADMIN", "SECRET", "DEMODB")) {
  printf("Database not running\n");
} else {
  printf("Database running\n");
}

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (!$link) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

if ($result = maxdb_query($link, "SELECT * FROM dual")) {
   $row = maxdb_fetch_row($result);
   printf("Result: %s\n", $row[0]);
   maxdb_free_result($result);
}

/* reset all and select a new database */
if (!maxdb_change_user($link, "DBADMIN", "SECRET", "DEMODB")) {
  printf("Database not running\n");
} else {
  printf("Database running\n");
}

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Result: a
Database running

Ayrıca Bakınız

  • maxdb_connect() - Open a new connection to the MaxDB server
  • maxdb_select_db() - Selects the default database for database queries

maxdb_bind_result
maxdb_character_set_name
MaxDB İşlevleri


Returns the default character set for the database connection

maxdb_change_user
maxdb_client_encoding
MaxDB İşlevleri
PHP Manual

maxdb_character_set_name

maxdb::character_set_name

(PECL maxdb >= 1.0)

maxdb_character_set_name -- maxdb::character_set_name — Returns the default character set for the database connection

Açıklama

Yordamsal kullanım

string maxdb_character_set_name ( resource $link )

Nesne yönelimli kullanım

string maxdb::character_set_name ( void )

Returns the current character set for the database connection specified by the link parameter.

Dönen Değerler

The default character set for the current connection, either ascii or unicode.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* Open a connection */
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* Print current character set */
$charset = $maxdb->character_set_name();
printf ("Current character set is %s\n", $charset);

$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (!$link) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* Print current character set */
$charset = maxdb_character_set_name($link);
printf ("Current character set is %s\n",$charset);

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Current character set is ascii

Ayrıca Bakınız

  • maxdb_client_encoding() - Takma Adı: maxdb_character_set_name
  • maxdb_real_escape_string() - Escapes special characters in a string for use in an SQL statement, taking into account the current charset of the connection

maxdb_change_user
maxdb_client_encoding
MaxDB İşlevleri


Takma Adı: maxdb_character_set_name

maxdb_character_set_name
maxdb_close_long_data
MaxDB İşlevleri
PHP Manual

maxdb_client_encoding

(PECL maxdb 1.0)

maxdb_client_encoding — Takma Adı: maxdb_character_set_name()

Açıklama

Bu işlev şu işlevin takma adıdır: maxdb_character_set_name().

Bu takma ad, PHP'nin ileri sürümlerinde kaldırılabileceğinden kullanılması önerilmemektedir ve şimdilik sadece geriye uyumluluk adına mevcuttur.

maxdb_character_set_name
maxdb_close_long_data
MaxDB İşlevleri


Takma Adı: maxdb_stmt_close_long_data

maxdb_client_encoding
maxdb_close
MaxDB İşlevleri
PHP Manual

maxdb_close_long_data

maxdb::close_long_data

(PECL maxdb >= 1.0)

maxdb_close_long_data -- maxdb::close_long_data — Takma Adı: maxdb_stmt_close_long_data()

Açıklama

Bu işlev şu işlevin takma adıdır: maxdb_stmt_close_long_data().

Bu takma ad, PHP'nin ileri sürümlerinde kaldırılabileceğinden kullanılması önerilmemektedir ve şimdilik sadece geriye uyumluluk adına mevcuttur.

maxdb_client_encoding
maxdb_close
MaxDB İşlevleri


Closes a previously opened database connection

maxdb_close_long_data
maxdb_commit
MaxDB İşlevleri
PHP Manual

maxdb_close

maxdb::close

(PECL maxdb >= 1.0)

maxdb_close -- maxdb::close — Closes a previously opened database connection

Açıklama

Yordamsal kullanım

bool maxdb_close ( resource $link )

Nesne yönelimli kullanım

bool maxdb::close ( void )

The maxdb_close() function closes a previously opened database connection specified by the link parameter.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • maxdb_connect() - Open a new connection to the MaxDB server
  • maxdb_init() - Initializes MaxDB and returns an resource for use with maxdb_real_connect
  • maxdb_real_connect() - Opens a connection to a MaxDB server

maxdb_close_long_data
maxdb_commit
MaxDB İşlevleri


Commits the current transaction

maxdb_close
maxdb_connect_errno
MaxDB İşlevleri
PHP Manual

maxdb_commit

maxdb::commit

(PECL maxdb >= 1.0)

maxdb_commit -- maxdb::commit — Commits the current transaction

Açıklama

Yordamsal kullanım

bool maxdb_commit ( resource $link )

Nesne yönelimli kullanım

bool maxdb::commit ( void )

Commits the current transaction for the database connection specified by the link parameter.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* set autocommit to off */
$maxdb->autocommit(FALSE);

maxdb_report (MAXDB_REPORT_OFF);
$maxdb->query("DROP TABLE mycustomer");
maxdb_report (MAXDB_REPORT_ERROR);

$maxdb->query("CREATE TABLE mycustomer LIKE hotel.customer");

/* Insert some values */
$maxdb->query("INSERT INTO mycustomer VALUES (3000,'Mrs','Jenny','Porter','10580','1340 N.Ash Street, #3')");
$maxdb->query("INSERT INTO mycustomer VALUES (3100,'Mr','Peter','Brown','48226','1001 34th Str., APT.3')");

/* commit transaction */
$maxdb->commit();

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (!$link) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* set autocommit to off */
maxdb_autocommit($link, FALSE);

maxdb_report (MAXDB_REPORT_OFF);
maxdb_query($link,"DROP TABLE mycustomer");
maxdb_report (MAXDB_REPORT_ERROR);

maxdb_query($link, "CREATE TABLE mycustomer LIKE hotel.customer");

/* Insert some values */
maxdb_query($link, "INSERT INTO mycustomer VALUES (3000,'Mrs','Jenny','Porter','10580','1340 N.Ash Street, #3')");
maxdb_query($link, "INSERT INTO mycustomer VALUES (3100,'Mr','Peter','Brown','48226','1001 34th Str., APT.3')");

/* commit transaction */
maxdb_commit($link);

/* close connection */
maxdb_close($link);
?>

The above examples produces no output.

Ayrıca Bakınız

  • maxdb_autocommit() - Turns on or off auto-commiting database modifications
  • maxdb_rollback() - Rolls back current transaction

maxdb_close
maxdb_connect_errno
MaxDB İşlevleri


Returns the error code from last connect call

maxdb_commit
maxdb_connect_error
MaxDB İşlevleri
PHP Manual

maxdb_connect_errno

(PECL maxdb >= 1.0)

maxdb_connect_errno — Returns the error code from last connect call

Açıklama

int maxdb_connect_errno ( void )

The maxdb_connect_errno() function will return the last error code number for last call to maxdb_connect(). If no errors have occurred, this function will return zero.

Dönen Değerler

An error code value for the last call to maxdb_connect(), if it failed. zero means no error occurred.

Örnekler

Örnek 1 maxdb_connect_errno sample

<?php
$link = maxdb_connect("localhost", "XXXXXXXX", "YYYYYYYYY");

if (!$link) {
   printf("Can't connect to localhost. Errorcode: %d\n", maxdb_connect_errno());
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

PHP Warning:  maxdb_connect(): -4008 POS(1) Unknown user name/password combination [08004] <...>
Can't connect to localhost. Errorcode: -4008

Ayrıca Bakınız

  • maxdb_connect() - Open a new connection to the MaxDB server
  • maxdb_connect_error() - Returns a string description of the last connect error
  • maxdb_errno() - Returns the error code for the most recent function call
  • maxdb_error() - Returns a string description of the last error
  • maxdb_sqlstate() - Returns the SQLSTATE error from previous MaxDB operation

maxdb_commit
maxdb_connect_error
MaxDB İşlevleri


Returns a string description of the last connect error

maxdb_connect_errno
maxdb_connect
MaxDB İşlevleri
PHP Manual

maxdb_connect_error

(PECL maxdb >= 1.0)

maxdb_connect_error — Returns a string description of the last connect error

Açıklama

string maxdb_connect_error ( void )

The maxdb_connect_error() function is identical to the corresponding maxdb_connect_errno() function in every way, except instead of returning an integer error code the maxdb_connect_error() function will return a string representation of the last error to occur for the last maxdb_connect() call. If no error has occurred, this function will return an empty string.

Dönen Değerler

A string that describes the error. An empty string if no error occurred.

Örnekler

Örnek 1 maxdb_connect_error sample

<?php

$link = maxdb_connect("localhost", "nonexisting_user", "");

if (!$link) {
   printf("Can't connect to localhost. Error: %s\n", maxdb_connect_error());
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

PHP Warning:  maxdb_connect(): -4008 POS(1) Unknown user name/password combination <...>
Can't connect to localhost. Error: POS(1) Unknown user name/password combination

Ayrıca Bakınız

  • maxdb_connect() - Open a new connection to the MaxDB server
  • maxdb_connect_errno() - Returns the error code from last connect call
  • maxdb_errno() - Returns the error code for the most recent function call
  • maxdb_error() - Returns a string description of the last error
  • maxdb_sqlstate() - Returns the SQLSTATE error from previous MaxDB operation

maxdb_connect_errno
maxdb_connect
MaxDB İşlevleri


Open a new connection to the MaxDB server

maxdb_connect_error
maxdb_data_seek
MaxDB İşlevleri
PHP Manual

maxdb_connect

maxdb::__construct

(PECL maxdb >= 1.0)

maxdb_connect -- maxdb::__construct — Open a new connection to the MaxDB server

Açıklama

Yordamsal kullanım

resource maxdb_connect ([ string $host [, string $username [, string $passwd [, string $dbname [, int $port = 0 [, string $socket ]]]]]] )

Nesne yönelimli kullanım

maxdb::__construct ([ string $host [, string $username [, string $passwd [, string $dbname [, int $port = 0 [, string $socket ]]]]]] )

The maxdb_connect() function attempts to open a connection to the MaxDB Server running on host which can be either a host name or an IP address. Passing the string "localhost" to this parameter, the local host is assumed. If successful, the maxdb_connect() will return an resource representing the connection to the database başarısızlık durumunda FALSE döner.

The username and password parameters specify the username and password under which to connect to the MaxDB server. If the password is not provided (the NULL value is passed), the MaxDB server will attempt to authenticate the user against the maxdb.default_pw in php.ini.

The dbname parameter if provided will specify the default database to be used when performing queries. If not provied, the entry maxdb.default_db in php.ini is used.

The port and socket parameters are ignored for the MaxDB server.

Dönen Değerler

Returns a resource which represents the connection to a MaxDB Server or FALSE if the connection failed.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

printf("Host information: %s\n", $maxdb->host_info);

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (!$link) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

printf("Host information: %s\n", maxdb_get_host_info($link));

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Host information: localhost
maxdb_connect_error
maxdb_data_seek
MaxDB İşlevleri


Adjusts the result pointer to an arbitary row in the result

maxdb_connect
maxdb_debug
MaxDB İşlevleri
PHP Manual

maxdb_data_seek

maxdb_result::data_seek

(PECL maxdb >= 1.0)

maxdb_data_seek -- maxdb_result::data_seek — Adjusts the result pointer to an arbitary row in the result

Açıklama

Yordamsal kullanım

bool maxdb_data_seek ( resource $result , int $offset )

Nesne yönelimli kullanım

bool maxdb_result::data_seek ( int $offset )

The maxdb_data_seek() function seeks to an arbitrary result pointer specified by the offset in the result set represented by result. The offset parameter must be between zero and the total number of rows minus one (0..maxdb_num_rows() - 1).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* Open a connection */
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, state FROM hotel.city ORDER BY name";
if ($result = $maxdb->query( $query)) {

   /* seek to row no. 10 */
   $result->data_seek(10);

   /* fetch row */
   $row = $result->fetch_row();

   printf ("City: %s  State: %s\n", $row[0], $row[1]);

   /* free result set*/
   $result->close();
}

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (!$link) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, state FROM hotel.city ORDER BY name";

if ($result = maxdb_query($link, $query)) {

   /* seek to row no. 400 */
   maxdb_data_seek($result, 10);

   /* fetch row */
   $row = maxdb_fetch_row($result);

   printf ("City: %s  State: %s\n", $row[0], $row[1]);

   /* free result set*/
   maxdb_free_result($result);
}

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

City: Irvine  State: CA

Ayrıca Bakınız

  • maxdb_store_result() - Transfers a result set from the last query
  • maxdb_fetch_row() - Get a result row as an enumerated array
  • maxdb_num_rows() - Gets the number of rows in a result

maxdb_connect
maxdb_debug
MaxDB İşlevleri


Performs debugging operations

maxdb_data_seek
maxdb_disable_reads_from_master
MaxDB İşlevleri
PHP Manual

maxdb_debug

(PECL maxdb >= 1.0)

maxdb_debug — Performs debugging operations

Açıklama

void maxdb_debug ( string $debug )

The maxdb_debug() can be used to trace the SQLDBC communication. The following strings can be used as a parameter to maxdb_debug():

  • TRACE SHORT ON|OFF - Enables/disables method call trace.
  • TRACE LONG ON|OFF - Enables/disables method argument and detail debug trace.
  • TRACE PACKET ON|OFF|<size> - Enables/disables packet trace, limiting the size of the traced object to the specified number of bytes, or 1000 if no size is specified.
  • TRACE SQL ON|OFF - Enables/disables high level api trace.
  • TRACE TIMESTAMP ON|OFF - Enables/disables a timestamp prefix on each line that is traced.
  • TRACE SIZE <size> - Limits the size of the trace file to <size> bytes, at least 8192 bytes are required.

Dönen Değerler

maxdb_debug() doesn't return any value.

Örnekler

Örnek 1 Yordamsal kullanım

<?php

maxdb_debug("trace packet 200");

$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (!$link) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* close connection */
maxdb_close($link);
?>

The above example produces no output.

maxdb_data_seek
maxdb_disable_reads_from_master
MaxDB İşlevleri


Disable reads from master

maxdb_debug
maxdb_disable_rpl_parse
MaxDB İşlevleri
PHP Manual

maxdb_disable_reads_from_master

maxdb::disable_reads_from_master

(PECL maxdb >= 1.0)

maxdb_disable_reads_from_master -- maxdb::disable_reads_from_master — Disable reads from master

Açıklama

Yordamsal kullanım

bool maxdb_disable_reads_from_master ( resource $link )

Nesne yönelimli kullanım

void maxdb::disable_reads_from_master ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

maxdb_debug
maxdb_disable_rpl_parse
MaxDB İşlevleri


Disable RPL parse

maxdb_disable_reads_from_master
maxdb_dump_debug_info
MaxDB İşlevleri
PHP Manual

maxdb_disable_rpl_parse

(PECL maxdb >= 1.0)

maxdb_disable_rpl_parse — Disable RPL parse

Açıklama

bool maxdb_disable_rpl_parse ( resource $link )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

maxdb_disable_reads_from_master
maxdb_dump_debug_info
MaxDB İşlevleri


Dump debugging information into the log

maxdb_disable_rpl_parse
maxdb_embedded_connect
MaxDB İşlevleri
PHP Manual

maxdb_dump_debug_info

(PECL maxdb >= 1.0)

maxdb_dump_debug_info — Dump debugging information into the log

Açıklama

bool maxdb_dump_debug_info ( resource $link )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

maxdb_disable_rpl_parse
maxdb_embedded_connect
MaxDB İşlevleri


Open a connection to an embedded MaxDB server

maxdb_dump_debug_info
maxdb_enable_reads_from_master
MaxDB İşlevleri
PHP Manual

maxdb_embedded_connect

(PECL maxdb >= 1.0)

maxdb_embedded_connect — Open a connection to an embedded MaxDB server

Açıklama

resource maxdb_embedded_connect ([ string $dbname ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

maxdb_dump_debug_info
maxdb_enable_reads_from_master
MaxDB İşlevleri


Enable reads from master

maxdb_embedded_connect
maxdb_enable_rpl_parse
MaxDB İşlevleri
PHP Manual

maxdb_enable_reads_from_master

(PECL maxdb >= 1.0)

maxdb_enable_reads_from_master — Enable reads from master

Açıklama

bool maxdb_enable_reads_from_master ( resource $link )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

maxdb_embedded_connect
maxdb_enable_rpl_parse
MaxDB İşlevleri


Enable RPL parse

maxdb_enable_reads_from_master
maxdb_errno
MaxDB İşlevleri
PHP Manual

maxdb_enable_rpl_parse

(PECL maxdb >= 1.0)

maxdb_enable_rpl_parse — Enable RPL parse

Açıklama

bool maxdb_enable_rpl_parse ( resource $link )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

maxdb_enable_reads_from_master
maxdb_errno
MaxDB İşlevleri


Returns the error code for the most recent function call

maxdb_enable_rpl_parse
maxdb_error
MaxDB İşlevleri
PHP Manual

maxdb_errno

maxdb::errno

(PECL maxdb >= 1.0)

maxdb_errno -- maxdb::errno — Returns the error code for the most recent function call

Açıklama

Yordamsal kullanım

int maxdb_errno ( resource $link )

Nesne yönelimli kullanım

int $maxdb->errno;

The maxdb_errno() function will return the last error code for the most recent MaxDB function call that can succeed or fail with respect to the database link defined by the link parameter. If no errors have occurred, this function will return zero.

Dönen Değerler

An error code value for the last call, if it failed. zero means no error occurred.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

if (!$maxdb->query("SELECT xxx FROM hotel.city")) {
   printf("Errorcode: %d\n", $maxdb->errno);
}

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

if (!maxdb_query($link, "SELECT xxx FROM hotel.city")) {
   printf("Errorcode: %d\n", maxdb_errno($link));
}

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

PHP Warning:  maxdb_query(): -4005 POS(8) Unknown column name:XXX [42000] <...>
Errorcode: -4005

Ayrıca Bakınız

  • maxdb_connect_errno() - Returns the error code from last connect call
  • maxdb_connect_error() - Returns a string description of the last connect error
  • maxdb_error() - Returns a string description of the last error
  • maxdb_sqlstate() - Returns the SQLSTATE error from previous MaxDB operation

maxdb_enable_rpl_parse
maxdb_error
MaxDB İşlevleri


Returns a string description of the last error

maxdb_errno
maxdb_escape_string
MaxDB İşlevleri
PHP Manual

maxdb_error

maxdb::error

(PECL maxdb >= 1.0)

maxdb_error -- maxdb::error — Returns a string description of the last error

Açıklama

Yordamsal kullanım

string maxdb_error ( resource $link )

Nesne yönelimli kullanım

string $maxdb->error;

The maxdb_error() function is identical to the corresponding maxdb_errno() function in every way, except instead of returning an integer error code the maxdb_error() function will return a string representation of the last error to occur for the database connection represented by the link parameter. If no error has occurred, this function will return an empty string.

Dönen Değerler

A string that describes the error. An empty string if no error occurred.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

if (!$maxdb->query("SELECT xxx FROM hotel.city")) {
   printf("Errormessage: %s\n", $maxdb->error);
}

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

if (!maxdb_query($link, "SELECT xxx FROM hotel.city")) {
   printf("Errormessgae: %s\n", maxdb_error($link));
}

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

PHP Warning:  maxdb_query(): -4005 POS(8) Unknown column name:XXX [42000]
Errormessgae: POS(8) Unknown column name:XXX

Ayrıca Bakınız

  • maxdb_connect_errno() - Returns the error code from last connect call
  • maxdb_connect_error() - Returns a string description of the last connect error
  • maxdb_errno() - Returns the error code for the most recent function call
  • maxdb_sqlstate() - Returns the SQLSTATE error from previous MaxDB operation

maxdb_errno
maxdb_escape_string
MaxDB İşlevleri


Takma Adı: maxdb_real_escape_string

maxdb_error
maxdb_execute
MaxDB İşlevleri
PHP Manual

maxdb_escape_string

(PECL maxdb 1.0)

maxdb_escape_string — Takma Adı: maxdb_real_escape_string()

Açıklama

Bu işlev şu işlevin takma adıdır: maxdb_real_escape_string().

maxdb_error
maxdb_execute
MaxDB İşlevleri


Takma Adı: maxdb_stmt_execute

maxdb_escape_string
maxdb_fetch_array
MaxDB İşlevleri
PHP Manual

maxdb_execute

(PECL maxdb 1.0)

maxdb_execute — Takma Adı: maxdb_stmt_execute()

Açıklama

Bu işlev şu işlevin takma adıdır: maxdb_stmt_execute().

Bu takma ad, PHP'nin ileri sürümlerinde kaldırılabileceğinden kullanılması önerilmemektedir ve şimdilik sadece geriye uyumluluk adına mevcuttur.

maxdb_escape_string
maxdb_fetch_array
MaxDB İşlevleri


Fetch a result row as an associative, a numeric array, or both

maxdb_execute
maxdb_fetch_assoc
MaxDB İşlevleri
PHP Manual

maxdb_fetch_array

maxdb_result::fetch_array

(PECL maxdb >= 1.0)

maxdb_fetch_array -- maxdb_result::fetch_array — Fetch a result row as an associative, a numeric array, or both

Açıklama

Yordamsal kullanım

mixed maxdb_fetch_array ( resource $result [, int $resulttype ] )

Nesne yönelimli kullanım

mixed maxdb_result::fetch_array ([ int $resulttype ] )

Returns an array that corresponds to the fetched row or NULL if there are no more rows for the resultset represented by the result parameter.

maxdb_fetch_array() is an extended version of the maxdb_fetch_row() function. In addition to storing the data in the numeric indices of the result array, the maxdb_fetch_array() function can also store the data in associative indices, using the field names of the result set as keys.

Bilginize: Bu işlevden dönen alan isimlerinin harf büyüklüklerinde değişiklik yapılmaz.

Bilginize: Bu işlev NULL alanlara PHP NULL değerini atar.

If two or more columns of the result have the same field names, the last column will take precedence and overwrite the earlier data. In order to access multiple columns with the same name, the numerically indexed version of the row must be used.

The optional second argument resulttype is a constant indicating what type of array should be produced from the current row data. The possible values for this parameter are the constants MAXDB_ASSOC, MAXDB_ASSOC_UPPER, MAXDB_ASSOC_LOWER, MAXDB_NUM, or MAXDB_BOTH. By default the maxdb_fetch_array() function will assume MAXDB_BOTH, which is a combination of MAXDB_NUM and MAXDB_ASSOC for this parameter.

By using the MAXDB_ASSOC constant this function will behave identically to the maxdb_fetch_assoc(), while MAXDB_NUM will behave identically to the maxdb_fetch_row() function. The final option MAXDB_BOTH will create a single array with the attributes of both.

By using the MAXDB_ASSOC_UPPER constant, the behaviour of this function is identical to the use of MAXDB_ASSOC except the array index of a column is the fieldname in upper case.

By using the MAXDB_ASSOC_LOWER constant, the behaviour of this function is identical to the use of MAXDB_ASSOC except the array index of a column is the fieldname in lower case.

Dönen Değerler

Returns an array that corresponds to the fetched row or NULL if there are no more rows in resultset.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, state FROM hotel.city ORDER by zip";
$result = $maxdb->query($query);

/* numeric array */
$row = $result->fetch_array(MAXDB_NUM);
printf ("%s (%s)\n", $row[0], $row[1]);

/* associative array */
$row = $result->fetch_array(MAXDB_ASSOC);
printf ("%s (%s)\n", $row["NAME"], $row["STATE"]);

/* associative and numeric array */
$row = $result->fetch_array(MAXDB_BOTH);
printf ("%s (%s)\n", $row[0], $row["STATE"]);

/* free result set */
$result->close();

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, state FROM hotel.city ORDER by zip";
$result = maxdb_query($link, $query);

/* numeric array */
$row = maxdb_fetch_array($result, MAXDB_NUM);
printf ("%s (%s)\n", $row[0], $row[1]);

/* associative array */
$row = maxdb_fetch_array($result, MAXDB_ASSOC);
printf ("%s (%s)\n", $row["NAME"], $row["STATE"]);

/* associative and numeric array */
$row = maxdb_fetch_array($result, MAXDB_BOTH);
printf ("%s (%s)\n", $row[0], $row["STATE"]);

/* free result set */
maxdb_free_result($result);

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

New York (NY)
New York (NY)
Long Island (NY)

Ayrıca Bakınız

  • maxdb_fetch_assoc() - Fetch a result row as an associative array
  • maxdb_fetch_row() - Get a result row as an enumerated array
  • maxdb_fetch_resource()

maxdb_execute
maxdb_fetch_assoc
MaxDB İşlevleri


Fetch a result row as an associative array

maxdb_fetch_array
maxdb_fetch_field_direct
MaxDB İşlevleri
PHP Manual

maxdb_fetch_assoc

maxdb_result::fetch_assoc

(PECL maxdb >= 1.0)

maxdb_fetch_assoc -- maxdb_result::fetch_assoc — Fetch a result row as an associative array

Açıklama

Yordamsal kullanım

array maxdb_fetch_assoc ( resource $result )

Nesne yönelimli kullanım

array maxdb_result::fetch_assoc ( void )

Returns an associative array that corresponds to the fetched row or NULL if there are no more rows.

The maxdb_fetch_assoc() function is used to return an associative array representing the next row in the result set for the result represented by the result parameter, where each key in the array represents the name of one of the result set's columns.

If two or more columns of the result have the same field names, the last column will take precedence. To access the other column(s) of the same name, you either need to access the result with numeric indices by using maxdb_fetch_row() or add alias names.

Bilginize: Bu işlevden dönen alan isimlerinin harf büyüklüklerinde değişiklik yapılmaz.

Bilginize: Bu işlev NULL alanlara PHP NULL değerini atar.

Dönen Değerler

Returns an array that corresponds to the fetched row or NULL if there are no more rows in resultset.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, state FROM hotel.city ORDER by zip";

if ($result = $maxdb->query($query)) {

   /* fetch associative array */
   while ($row = $result->fetch_assoc()) {
       printf ("%s (%s)\n", $row["NAME"], $row["STATE"]);
   }

   /* free result set */
   $result->close();
}

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, state FROM hotel.city ORDER by zip";

if ($result = maxdb_query($link, $query)) {

   /* fetch associative array */
   while ($row = maxdb_fetch_assoc($result)) {
       printf ("%s (%s)\n", $row["NAME"], $row["STATE"]);
   }

   /* free result set */
   maxdb_free_result($result);
}

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

New York (NY)
New York (NY)
Long Island (NY)
Albany (NY)
Washington (DC)
Washington (DC)
Washington (DC)
Silver Spring (MD)
Daytona Beach (FL)
Deerfield Beach (FL)
Clearwater (FL)
Cincinnati (OH)
Detroit (MI)
Rosemont (IL)
Chicago (IL)
Chicago (IL)
New Orleans (LA)
Dallas (TX)
Los Angeles (CA)
Hollywood (CA)
Long Beach (CA)
Palm Springs (CA)
Irvine (CA)
Santa Clara (CA)
Portland (OR)

Ayrıca Bakınız

  • maxdb_fetch_array() - Fetch a result row as an associative, a numeric array, or both
  • maxdb_fetch_row() - Get a result row as an enumerated array
  • maxdb_fetch_resource()

maxdb_fetch_array
maxdb_fetch_field_direct
MaxDB İşlevleri


Fetch meta-data for a single field

maxdb_fetch_assoc
maxdb_fetch_field
MaxDB İşlevleri
PHP Manual

maxdb_fetch_field_direct

maxdb_result::fetch_field_direct

(PECL maxdb >= 1.0)

maxdb_fetch_field_direct -- maxdb_result::fetch_field_direct — Fetch meta-data for a single field

Açıklama

Yordamsal kullanım

mixed maxdb_fetch_field_direct ( resource $result , int $fieldnr )

Nesne yönelimli kullanım

mixed maxdb_result::fetch_field_direct ( int $fieldnr )

maxdb_fetch_field_direct() returns an resource which contains field definition information from specified resultset. The value of fieldnr must be in the range from 0 to number of fields - 1.

Dönen Değerler

Returns an resource which contains field definition information or FALSE if no field information for specified fieldnr is available.

Object attributes
Attribute | Description
name | The name of the column
max_length | The maximum width of the field for the result set.
type | The data type used for this field
decimals | The number of decimals used (for integer fields)

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, cno from hotel.customer ORDER BY name";

if ($result = $maxdb->query($query)) {

   /* Get field information for column 'SurfaceArea' */
   $finfo = $result->fetch_field_direct(1);

   printf("Name:     %s\n", $finfo->name);
   printf("Table:    %s\n", $finfo->table);
   printf("max. Len: %d\n", $finfo->max_length);
   printf("Flags:    %d\n", $finfo->flags);
   printf("Type:     %d\n", $finfo->type);

   $result->close();
}

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, cno from hotel.customer ORDER BY name";

if ($result = maxdb_query($link, $query)) {

   /* Get field information for column 'cno' */
   $finfo = maxdb_fetch_field_direct($result, 1);

   printf("Name:     %s\n", $finfo->name);
   printf("Table:    %s\n", $finfo->table);
   printf("max. Len: %d\n", $finfo->max_length);
   printf("Flags:    %d\n", $finfo->flags);
   printf("Type:     %d\n", $finfo->type);

   maxdb_free_result($result);
}

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Name:     CNO
Table:
max. Len: 4
Flags:    -1
Type:     0

Ayrıca Bakınız

  • maxdb_num_fields() - Get the number of fields in a result
  • maxdb_fetch_field() - Returns the next field in the result set
  • maxdb_fetch_fields() - Returns an array of resources representing the fields in a result set

maxdb_fetch_assoc
maxdb_fetch_field
MaxDB İşlevleri


Returns the next field in the result set

maxdb_fetch_field_direct
maxdb_fetch_fields
MaxDB İşlevleri
PHP Manual

maxdb_fetch_field

maxdb_result::fetch_field

(PECL maxdb >= 1.0)

maxdb_fetch_field -- maxdb_result::fetch_field — Returns the next field in the result set

Açıklama

Yordamsal kullanım

mixed maxdb_fetch_field ( resource $result )

Nesne yönelimli kullanım

mixed maxdb_result::fetch_field ( void )

The maxdb_fetch_field() returns the definition of one column of a result set as an resource. Call this function repeatedly to retrieve information about all columns in the result set. maxdb_fetch_field() returns FALSE when no more fields are left.

Dönen Değerler

Returns an resource which contains field definition information or FALSE if no field information is available.

Object properties
Property | Description
name | The name of the column
max_length | The maximum width of the field for the result set.
type | The data type used for this field
decimals | The number of decimals used (for integer fields)

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, cno from hotel.customer ORDER BY cno";

if ($result = $maxdb->query($query)) {

   /* Get field information for all columns */
   while ($finfo = $result->fetch_field()) {

       printf("Name:     %s\n", $finfo->name);
       printf("Table:    %s\n", $finfo->table);
       printf("max. Len: %d\n", $finfo->max_length);
       printf("Flags:    %d\n", $finfo->flags);
       printf("Type:     %d\n\n", $finfo->type);
   }
   $result->close();
}

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, cno from hotel.customer ORDER BY cno";

if ($result = maxdb_query($link, $query)) {

   /* Get field information for all fields */
   while ($finfo = maxdb_fetch_field($result)) {

       printf("Name:     %s\n", $finfo->name);
       printf("Table:    %s\n", $finfo->table);
       printf("max. Len: %d\n", $finfo->max_length);
       printf("Flags:    %d\n", $finfo->flags);
       printf("Type:     %d\n\n", $finfo->type);
   }
   maxdb_free_result($result);
}

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Name:     NAME
Table:
max. Len: 10
Flags:    -1
Type:     2

Name:     CNO
Table:
max. Len: 4
Flags:    -1
Type:     0

Ayrıca Bakınız

  • maxdb_num_fields() - Get the number of fields in a result
  • maxdb_fetch_field_direct() - Fetch meta-data for a single field
  • maxdb_fetch_fields() - Returns an array of resources representing the fields in a result set
  • maxdb_field_seek() - Set result pointer to a specified field offset

maxdb_fetch_field_direct
maxdb_fetch_fields
MaxDB İşlevleri


Returns an array of resources representing the fields in a result set

maxdb_fetch_field
maxdb_fetch_lengths
MaxDB İşlevleri
PHP Manual

maxdb_fetch_fields

maxdb_result::fetch_fields

(PECL maxdb >= 1.0)

maxdb_fetch_fields -- maxdb_result::fetch_fields — Returns an array of resources representing the fields in a result set

Açıklama

Yordamsal kullanım

mixed maxdb_fetch_fields ( resource $result )

Nesne yönelimli kullanım

mixed maxdb_result::fetch_fields ( void )

This function serves an identical purpose to the maxdb_fetch_field() function with the single difference that, instead of returning one resource at a time for each field, the columns are returned as an array of resources.

Dönen Değerler

Returns an array of resources which contains field definition information or FALSE if no field information is available.

Object properties
Property | Description
name | The name of the column
max_length | The maximum width of the field for the result set.
type | The data type used for this field
decimals | The number of decimals used (for integer fields)

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, cno from hotel.customer ORDER BY cno";

if ($result = $maxdb->query($query)) {

   /* Get field information for all columns */
   $finfo = $result->fetch_fields();

   foreach ($finfo as $val) {
       printf("Name:     %s\n", $val->name);
       printf("Table:    %s\n", $val->table);
       printf("max. Len: %d\n", $val->max_length);
       printf("Flags:    %d\n", $val->flags);
       printf("Type:     %d\n\n", $val->type);
   }
   $result->close();
}

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, cno from hotel.customer ORDER BY cno";

if ($result = maxdb_query($link, $query)) {

   /* Get field information for all columns */
   $finfo = maxdb_fetch_fields($result);

   foreach ($finfo as $val) {
       printf("Name:     %s\n", $val->name);
       printf("Table:    %s\n", $val->table);
       printf("max. Len: %d\n", $val->max_length);
       printf("Flags:    %d\n", $val->flags);
       printf("Type:     %d\n\n", $val->type);
   }
   maxdb_free_result($result);
}

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Name:     NAME
Table:
max. Len: 10
Flags:    -1
Type:     2

Name:     CNO
Table:
max. Len: 4
Flags:    -1
Type:     0

Ayrıca Bakınız

  • maxdb_num_fields() - Get the number of fields in a result
  • maxdb_fetch_field() - Returns the next field in the result set
  • maxdb_fetch_field_direct() - Fetch meta-data for a single field

maxdb_fetch_field
maxdb_fetch_lengths
MaxDB İşlevleri


Returns the lengths of the columns of the current row in the result set

maxdb_fetch_fields
maxdb_fetch_object
MaxDB İşlevleri
PHP Manual

maxdb_fetch_lengths

maxdb_result::lengths

(PECL maxdb >= 1.0)

maxdb_fetch_lengths -- maxdb_result::lengths — Returns the lengths of the columns of the current row in the result set

Açıklama

Yordamsal kullanım

array maxdb_fetch_lengths ( resource $result )

Nesne yönelimli kullanım

array $maxdb_result->lengths;

The maxdb_fetch_lengths() function returns an array containing the lengths of every column of the current row within the result set represented by the result parameter. If successful, a numerically indexed array representing the lengths of each column is returned başarısızlık durumunda FALSE döner.

Dönen Değerler

An array of integers representing the size of each column (not including any terminating null characters). FALSE if an error occurred.

maxdb_fetch_lengths() is valid only for the current row of the result set. It returns FALSE if you call it before calling maxdb_fetch_row/array/resource or after retrieving all rows in the result.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT * from hotel.customer WHERE cno = 3000";

if ($result = $maxdb->query($query)) {

   $row = $result->fetch_row();

   /* display column lengths */
   foreach ($result->lengths as $i => $val) {
       printf("Field %2d has Length %2d\n", $i+1, $val);
   }
   $result->close();
}

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT * from hotel.customer WHERE cno = 3000";

if ($result = maxdb_query($link, $query)) {

   $row = maxdb_fetch_row($result);

   /* display column lengths */
   foreach (maxdb_fetch_lengths($result) as $i => $val) {
       printf("Field %2d has Length %2d\n", $i+1, $val);
   }
   maxdb_free_result($result);
}

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Field  1 has Length  4
Field  2 has Length  3
Field  3 has Length  5
Field  4 has Length  6
Field  5 has Length  5
Field  6 has Length 21
maxdb_fetch_fields
maxdb_fetch_object
MaxDB İşlevleri


Returns the current row of a result set as an object

maxdb_fetch_lengths
maxdb_fetch_row
MaxDB İşlevleri
PHP Manual

maxdb_fetch_object

maxdb_result::fetch_object

(PECL maxdb >= 1.0)

maxdb_fetch_object -- maxdb_result::fetch_object — Returns the current row of a result set as an object

Açıklama

Yordamsal kullanım

object maxdb_fetch_object ( object $result )

Nesne yönelimli kullanım

object maxdb_result::fetch_object ( void )

The maxdb_fetch_object() will return the current row result set as an object where the attributes of the object represent the names of the fields found within the result set. If no more rows exist in the current result set, NULL is returned.

Dönen Değerler

Returns an object that corresponds to the fetched row or NULL if there are no more rows in resultset.

Bilginize: Bu işlevden dönen alan isimlerinin harf büyüklüklerinde değişiklik yapılmaz.

Bilginize: Bu işlev NULL alanlara PHP NULL değerini atar.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, state FROM hotel.city ORDER by zip";

if ($result = $maxdb->query($query)) {

   /* fetch object array */
   while ($obj = $result->fetch_object()) {
       printf ("%s (%s)\n", $obj->NAME, $obj->STATE);
   }

   /* free result set */
   $result->close();
}

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, state FROM hotel.city ORDER by zip";

if ($result = maxdb_query($link, $query)) {

   /* fetch object array */
   while ($obj = maxdb_fetch_object($result)) {
       printf ("%s (%s)\n", $obj->NAME, $obj->STATE);
   }

   /* free result set */
   maxdb_free_result($result);
}

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

New York (NY)
New York (NY)
Long Island (NY)
Albany (NY)
Washington (DC)
Washington (DC)
Washington (DC)
Silver Spring (MD)
Daytona Beach (FL)
Deerfield Beach (FL)
Clearwater (FL)
Cincinnati (OH)
Detroit (MI)
Rosemont (IL)
Chicago (IL)
Chicago (IL)
New Orleans (LA)
Dallas (TX)
Los Angeles (CA)
Hollywood (CA)
Long Beach (CA)
Palm Springs (CA)
Irvine (CA)
Santa Clara (CA)
Portland (OR)

Ayrıca Bakınız

  • maxdb_fetch_array() - Fetch a result row as an associative, a numeric array, or both
  • maxdb_fetch_assoc() - Fetch a result row as an associative array
  • maxdb_fetch_row() - Get a result row as an enumerated array

maxdb_fetch_lengths
maxdb_fetch_row
MaxDB İşlevleri


Get a result row as an enumerated array

maxdb_fetch_object
maxdb_fetch
MaxDB İşlevleri
PHP Manual

maxdb_fetch_row

maxdb_result::fetch_row

(PECL maxdb >= 1.0)

maxdb_fetch_row -- maxdb_result::fetch_row — Get a result row as an enumerated array

Açıklama

Yordamsal kullanım

mixed maxdb_fetch_row ( resource $result )

Nesne yönelimli kullanım

mixed maxdb_result::fetch_row ( void )

Returns an array that corresponds to the fetched row, or NULL if there are no more rows.

maxdb_fetch_row() fetches one row of data from the result set represented by result and returns it as an enumerated array, where each column is stored in an array offset starting from 0 (zero). Each subsequent call to the maxdb_fetch_row() function will return the next row within the result set, or FALSE if there are no more rows.

Dönen Değerler

maxdb_fetch_row() returns an array that corresponds to the fetched row or NULL if there are no more rows in result set.

Bilginize: Bu işlev NULL alanlara PHP NULL değerini atar.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, state FROM hotel.city ORDER by zip";

if ($result = $maxdb->query($query)) {

   /* fetch enumerated array */
   while ($row = $result->fetch_row()) {
       printf ("%s (%s)\n", $row[0], $row[1]);
   }

   /* free result set */
   $result->close();
}

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, state FROM hotel.city ORDER by zip";

if ($result = maxdb_query($link, $query)) {

   /* fetch enumerated array */
   while ($row = maxdb_fetch_row($result)) {
       printf ("%s (%s)\n", $row[0], $row[1]);
   }

   /* free result set */
   maxdb_free_result($result);
}

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

New York (NY)
New York (NY)
Long Island (NY)
Albany (NY)
Washington (DC)
Washington (DC)
Washington (DC)
Silver Spring (MD)
Daytona Beach (FL)
Deerfield Beach (FL)
Clearwater (FL)
Cincinnati (OH)
Detroit (MI)
Rosemont (IL)
Chicago (IL)
Chicago (IL)
New Orleans (LA)
Dallas (TX)
Los Angeles (CA)
Hollywood (CA)
Long Beach (CA)
Palm Springs (CA)
Irvine (CA)
Santa Clara (CA)
Portland (OR)

Ayrıca Bakınız

  • maxdb_fetch_array() - Fetch a result row as an associative, a numeric array, or both
  • maxdb_fetch_assoc() - Fetch a result row as an associative array
  • maxdb_fetch_resource()

maxdb_fetch_object
maxdb_fetch
MaxDB İşlevleri


Takma Adı: maxdb_stmt_fetch

maxdb_fetch_row
maxdb_field_count
MaxDB İşlevleri
PHP Manual

maxdb_fetch

(PECL maxdb 1.0)

maxdb_fetch — Takma Adı: maxdb_stmt_fetch()

Açıklama

Bu işlev şu işlevin takma adıdır: maxdb_stmt_fetch().

Bu takma ad, PHP'nin ileri sürümlerinde kaldırılabileceğinden kullanılması önerilmemektedir ve şimdilik sadece geriye uyumluluk adına mevcuttur.

maxdb_fetch_row
maxdb_field_count
MaxDB İşlevleri


Returns the number of columns for the most recent query

maxdb_fetch
maxdb_field_seek
MaxDB İşlevleri
PHP Manual

maxdb_field_count

maxdb::field_count

(PECL maxdb >= 1.0)

maxdb_field_count -- maxdb::field_count — Returns the number of columns for the most recent query

Açıklama

Yordamsal kullanım

int maxdb_field_count ( resource $link )

Nesne yönelimli kullanım

int maxdb::field_count ( void )

Returns the number of columns for the most recent query on the connection represented by the link parameter. This function can be useful when using the maxdb_store_result() function to determine if the query should have produced a non-empty result set or not without knowing the nature of the query.

Dönen Değerler

An integer representing the number of fields in a result set.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

maxdb_report (MAXDB_REPORT_OFF);
$maxdb->query("DROP TABLE friends");
maxdb_report (MAXDB_REPORT_ERROR);

$maxdb->query( "CREATE TABLE friends (id int, name varchar(20))");

$maxdb->query( "INSERT INTO friends VALUES (1,'Hartmut')");
$maxdb->query( "INSERT INTO friends VALUES (2, 'Ulf')");

if ($maxdb->field_count()) {
   /* this was a select/show or describe query */
   $result = $maxdb->store_result();

   /* process resultset */
   $row = $result->fetch_row();

   /* free resultset */
   $result->close();
}

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

maxdb_report (MAXDB_REPORT_OFF);
maxdb_query($link,"DROP TABLE friends");
maxdb_report (MAXDB_REPORT_ERROR);

maxdb_query($link, "CREATE TABLE friends (id int, name varchar(20))");

maxdb_query($link, "INSERT INTO friends VALUES (1,'Hartmut')");
maxdb_query($link, "INSERT INTO friends VALUES (2, 'Ulf')");

if (maxdb_field_count($link)) {
   /* this was a select/show or describe query */
   $result = maxdb_store_result($link);

   /* process resultset */
   $row = maxdb_fetch_row($result);

   /* free resultset */
   maxdb_free_result($result);
}

/* close connection */
maxdb_close($link);
?>

The above example produces no output.

maxdb_fetch
maxdb_field_seek
MaxDB İşlevleri


Set result pointer to a specified field offset

maxdb_field_count
maxdb_field_tell
MaxDB İşlevleri
PHP Manual

maxdb_field_seek

maxdb_result::field_seek

(PECL maxdb >= 1.0)

maxdb_field_seek -- maxdb_result::field_seek — Set result pointer to a specified field offset

Açıklama

Yordamsal kullanım

bool maxdb_field_seek ( resource $result , int $fieldnr )

Nesne yönelimli kullanım

bool maxdb_result::field_seek ( int $fieldnr )

Sets the field cursor to the given offset. The next call to maxdb_fetch_field() will retrieve the field definition of the column associated with that offset.

Bilginize:

To seek to the beginning of a row, pass an offset value of zero.

Dönen Değerler

maxdb_field_seek() returns previuos value of field cursor.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, cno from hotel.customer ORDER BY cno";

if ($result = $maxdb->query($query)) {

   /* Get field information for 2nd column */
   $result->field_seek(1);
   $finfo = $result->fetch_field();

   printf("Name:     %s\n", $finfo->name);
   printf("Table:    %s\n", $finfo->table);
   printf("max. Len: %d\n", $finfo->max_length);
   printf("Flags:    %d\n", $finfo->flags);
   printf("Type:     %d\n\n", $finfo->type);

   $result->close();
}

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, cno from hotel.customer ORDER BY cno";

if ($result = maxdb_query($link, $query)) {

   /* Get field information for 2nd column */
   maxdb_field_seek($result, 1);
   $finfo = maxdb_fetch_field($result);

   printf("Name:     %s\n", $finfo->name);
   printf("Table:    %s\n", $finfo->table);
   printf("max. Len: %d\n", $finfo->max_length);
   printf("Flags:    %d\n", $finfo->flags);
   printf("Type:     %d\n\n", $finfo->type);

   maxdb_free_result($result);
}

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Name:     NAME
Table:
max. Len: 10
Flags:    -1
Type:     2

Ayrıca Bakınız

  • maxdb_fetch_field() - Returns the next field in the result set

maxdb_field_count
maxdb_field_tell
MaxDB İşlevleri


Get current field offset of a result pointer

maxdb_field_seek
maxdb_free_result
MaxDB İşlevleri
PHP Manual

maxdb_field_tell

maxdb_result::current_field

(PECL maxdb >= 1.0)

maxdb_field_tell -- maxdb_result::current_field — Get current field offset of a result pointer

Açıklama

Yordamsal kullanım

int maxdb_field_tell ( resource $result )

Nesne yönelimli kullanım

int $maxdb_result->current_field;

Returns the position of the field cursor used for the last maxdb_fetch_field() call. This value can be used as an argument to maxdb_field_seek().

Dönen Değerler

Returns current offset of field cursor.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, cno from hotel.customer ORDER BY cno";

if ($result = $maxdb->query($query)) {

   /* Get field information for all columns */
   while ($finfo = $result->fetch_field()) {

       /* get fieldpointer offset */
       $currentfield = $result->current_field;

       printf("Column    %d:\n", $currentfield);
       printf("Name:     %s\n", $finfo->name);
       printf("Table:    %s\n", $finfo->table);
       printf("max. Len: %d\n", $finfo->max_length);
       printf("Flags:    %d\n", $finfo->flags);
       printf("Type:     %d\n\n", $finfo->type);
   }
   $result->close();
}

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, cno from hotel.customer ORDER BY cno";

if ($result = maxdb_query($link, $query)) {

   /* Get field information for all fields */
   while ($finfo = maxdb_fetch_field($result)) {

       /* get fieldpointer offset */
       $currentfield = maxdb_field_tell($result);

       printf("Column    %d:\n", $currentfield);
       printf("Name:     %s\n", $finfo->name);
       printf("Table:    %s\n", $finfo->table);
       printf("max. Len: %d\n", $finfo->max_length);
       printf("Flags:    %d\n", $finfo->flags);
       printf("Type:     %d\n\n", $finfo->type);
   }
   maxdb_free_result($result);
}

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Column    1:
Name:     NAME
Table:
max. Len: 10
Flags:    -1
Type:     2

Column    2:
Name:     CNO
Table:
max. Len: 4
Flags:    -1
Type:     0

Ayrıca Bakınız

  • maxdb_fetch_field() - Returns the next field in the result set
  • maxdb_field_seek() - Set result pointer to a specified field offset

maxdb_field_seek
maxdb_free_result
MaxDB İşlevleri


Frees the memory associated with a result

maxdb_field_tell
maxdb_get_client_info
MaxDB İşlevleri
PHP Manual

maxdb_free_result

maxdb_result::free

(PECL maxdb >= 1.0)

maxdb_free_result -- maxdb_result::free — Frees the memory associated with a result

Açıklama

Yordamsal kullanım

void maxdb_free_result ( resource $result )

Nesne yönelimli kullanım

void maxdb_result::free ( void )

The maxdb_free_result() function frees the memory associated with the result represented by the result parameter, which was allocated by maxdb_query(), maxdb_store_result() or maxdb_use_result().

Bilginize:

You should always free your result with maxdb_free_result(), when your result resource is not needed anymore.

Dönen Değerler

This function doesn't return any value.

Ayrıca Bakınız

  • maxdb_query() - Performs a query on the database
  • maxdb_stmt_store_result() - Transfers a result set from a prepared statement
  • maxdb_store_result() - Transfers a result set from the last query
  • maxdb_use_result() - Initiate a result set retrieval

maxdb_field_tell
maxdb_get_client_info
MaxDB İşlevleri


Returns the MaxDB client version as a string

maxdb_free_result
maxdb_get_client_version
MaxDB İşlevleri
PHP Manual

maxdb_get_client_info

(PECL maxdb >= 1.0)

maxdb_get_client_info — Returns the MaxDB client version as a string

Açıklama

string maxdb_get_client_info ( void )

The maxdb_get_client_info() function is used to return a string representing the client version being used in the MaxDB extension.

Dönen Değerler

A string that represents the MaxDB client library version

Örnekler

Örnek 1 maxdb_get_client_info

<?php

/* We don't need a connection to determine
   the version of MaxDB client library */

printf("Client library version: %s\n", maxdb_get_client_info());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Client library version: libSQLDBC <...>

Ayrıca Bakınız

  • maxdb_get_client_version() - Get MaxDB client info
  • maxdb_get_server_info() - Returns the version of the MaxDB server
  • maxdb_get_server_version() - Returns the version of the MaxDB server as an integer

maxdb_free_result
maxdb_get_client_version
MaxDB İşlevleri


Get MaxDB client info

maxdb_get_client_info
maxdb_get_host_info
MaxDB İşlevleri
PHP Manual

maxdb_get_client_version

(PECL maxdb >= 1.0)

maxdb_get_client_version — Get MaxDB client info

Açıklama

int maxdb_get_client_version ( void )

Returns client version number as an integer.

Dönen Değerler

A number that represents the MaxDB client library version in format: main_version*10000 + minor_version *100 + sub_version. For example, 7.5.0 is returned as 70500.

This is useful to quickly determine the version of the client library to know if some capability exists.

Örnekler

Örnek 1 maxdb_get_client_version

<?php

/* We don't need a connection to determine
   the version of MaxDB client library */

printf("Client library version: %d\n", maxdb_get_client_version());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Client library version: 7.<...>

Ayrıca Bakınız

  • maxdb_get_client_info() - Returns the MaxDB client version as a string
  • maxdb_get_server_info() - Returns the version of the MaxDB server
  • maxdb_get_server_version() - Returns the version of the MaxDB server as an integer

maxdb_get_client_info
maxdb_get_host_info
MaxDB İşlevleri


Returns a string representing the type of connection used

maxdb_get_client_version
maxdb_get_metadata
MaxDB İşlevleri
PHP Manual

maxdb_get_host_info

maxdb::get_host_info

(PECL maxdb >= 1.0)

maxdb_get_host_info -- maxdb::get_host_info — Returns a string representing the type of connection used

Açıklama

Yordamsal kullanım

string maxdb_get_host_info ( resource $link )

Nesne yönelimli kullanım

string $maxdb->host_info;

The maxdb_get_host_info() function returns a string describing the connection represented by the link parameter is using.

Dönen Değerler

A character string representing the server hostname and the connection type.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* print host information */
printf("Host info: %s\n", $maxdb->host_info);

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* print host information */
printf("Host info: %s\n", maxdb_get_host_info($link));

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Host info: localhost

Ayrıca Bakınız

  • maxdb_get_proto_info() - Returns the version of the MaxDB protocol used

maxdb_get_client_version
maxdb_get_metadata
MaxDB İşlevleri


Takma Adı: maxdb_stmt_result_metadata

maxdb_get_host_info
maxdb_get_proto_info
MaxDB İşlevleri
PHP Manual

maxdb_get_metadata

(PECL maxdb 1.0)

maxdb_get_metadata — Takma Adı: maxdb_stmt_result_metadata()

Açıklama

Bu işlev şu işlevin takma adıdır: maxdb_stmt_result_metadata().

Bu takma ad, PHP'nin ileri sürümlerinde kaldırılabileceğinden kullanılması önerilmemektedir ve şimdilik sadece geriye uyumluluk adına mevcuttur.

maxdb_get_host_info
maxdb_get_proto_info
MaxDB İşlevleri


Returns the version of the MaxDB protocol used

maxdb_get_metadata
maxdb_get_server_info
MaxDB İşlevleri
PHP Manual

maxdb_get_proto_info

maxdb::protocol_version

(PECL maxdb >= 1.0)

maxdb_get_proto_info -- maxdb::protocol_version — Returns the version of the MaxDB protocol used

Açıklama

Yordamsal kullanım

int maxdb_get_proto_info ( resource $link )

Nesne yönelimli kullanım

string $maxdb->protocol_version;

Returns an integer representing the MaxDB protocol version used by the connection represented by the link parameter.

Dönen Değerler

Returns an integer representing the protocol version (constant 10).

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* print protocol version */
printf("Protocol version: %d\n", $maxdb->protocol_version);

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* print protocol version */
printf("Protocol version: %d\n", maxdb_get_proto_info($link));

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Protocol version: 10

Ayrıca Bakınız

  • maxdb_get_host_info() - Returns a string representing the type of connection used

maxdb_get_metadata
maxdb_get_server_info
MaxDB İşlevleri


Returns the version of the MaxDB server

maxdb_get_proto_info
maxdb_get_server_version
MaxDB İşlevleri
PHP Manual

maxdb_get_server_info

maxdb::server_info

(PECL maxdb >= 1.0)

maxdb_get_server_info -- maxdb::server_info — Returns the version of the MaxDB server

Açıklama

Yordamsal kullanım

string maxdb_get_server_info ( resource $link )

Nesne yönelimli kullanım

string $maxdb->server_info;

Returns a string representing the version of the MaxDB server that the MaxDB extension is connected to (represented by the link parameter).

Dönen Değerler

A character string representing the server version.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* print server version */
printf("Server version: %s\n", $maxdb->server_info);

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* print server version */
printf("Server version: %s\n", maxdb_get_server_info($link));

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Server version: Kernel    7<...>

Ayrıca Bakınız

  • maxdb_get_client_info() - Returns the MaxDB client version as a string
  • maxdb_get_client_version() - Get MaxDB client info
  • maxdb_get_server_version() - Returns the version of the MaxDB server as an integer

maxdb_get_proto_info
maxdb_get_server_version
MaxDB İşlevleri


Returns the version of the MaxDB server as an integer

maxdb_get_server_info
maxdb_info
MaxDB İşlevleri
PHP Manual

maxdb_get_server_version

maxdb::server_version

(PECL maxdb >= 1.0)

maxdb_get_server_version -- maxdb::server_version — Returns the version of the MaxDB server as an integer

Açıklama

Yordamsal kullanım

int maxdb_get_server_version ( resource $link )

Nesne yönelimli kullanım

int $maxdb->server_version;

The maxdb_get_server_version() function returns the version of the server connected to (represented by the link parameter) as an integer.

The form of this version number is main_version * 10000 + minor_version * 100 + sub_version (i.e. version 7.5.0 is 70500).

Dönen Değerler

An integer representing the server version.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* print server version */
printf("Server version: %d\n", $maxdb->server_version);

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* print server version */
printf("Server version: %d\n", maxdb_get_server_version($link));

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Server version: 7<...>

Ayrıca Bakınız

  • maxdb_get_client_info() - Returns the MaxDB client version as a string
  • maxdb_get_client_version() - Get MaxDB client info
  • maxdb_get_server_info() - Returns the version of the MaxDB server

maxdb_get_server_info
maxdb_info
MaxDB İşlevleri


Retrieves information about the most recently executed query

maxdb_get_server_version
maxdb_init
MaxDB İşlevleri
PHP Manual

maxdb_info

maxdb::info

(PECL maxdb >= 1.0)

maxdb_info -- maxdb::info — Retrieves information about the most recently executed query

Açıklama

Yordamsal kullanım

string maxdb_info ( resource $link )

Nesne yönelimli kullanım

string $maxdb->info;

The maxdb_info() function returns a string providing information about the last query executed. The nature of this string is provided below:

Possible maxdb_info return values
Query type | Example result string
INSERT INTO...SELECT... | Records: 100 Duplicates: 0 Warnings: 0
INSERT INTO...VALUES (...),(...),(...) | Records: 3 Duplicates: 0 Warnings: 0
LOAD DATA INFILE ... | Records: 1 Deleted: 0 Skipped: 0 Warnings: 0
ALTER TABLE ... | Records: 3 Duplicates: 0 Warnings: 0
UPDATE ... | Rows matched: 40 Changed: 40 Warnings: 0

Bilginize:

Queries which do not fall into one of the above formats are not supported. In these situations, maxdb_info() will return an empty string.

Dönen Değerler

A character string representing additional information about the most recently executed query.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$maxdb->query("CREATE TABLE temp.t1 LIKE hotel.city");

/* INSERT INTO .. SELECT */
$maxdb->query("INSERT INTO temp.t1 SELECT * FROM hotel.city");
printf("%s\n", $maxdb->info);

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

maxdb_query($link, "CREATE TABLE temp.t1 LIKE hotel.city");

/* INSERT INTO .. SELECT */
maxdb_query($link, "INSERT INTO temp.t1 SELECT * FROM hotel.city");
printf("%s\n", maxdb_info($link));

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Records: 25 Duplicates: 0 Warnings: 0

Ayrıca Bakınız

  • maxdb_affected_rows() - Gets the number of affected rows in a previous MaxDB operation
  • maxdb_warning_count() - Returns the number of warnings from the last query for the given link
  • maxdb_num_rows() - Gets the number of rows in a result

maxdb_get_server_version
maxdb_init
MaxDB İşlevleri


Initializes MaxDB and returns an resource for use with maxdb_real_connect

maxdb_info
maxdb_insert_id
MaxDB İşlevleri
PHP Manual

maxdb_init

(PECL maxdb >= 1.0)

maxdb_init — Initializes MaxDB and returns an resource for use with maxdb_real_connect

Açıklama

resource maxdb_init ( void )

Allocates or initializes a MaxDB resource suitable for maxdb_options() and maxdb_real_connect().

Bilginize:

Any subsequent calls to any maxdb function (except maxdb_options()) will fail until maxdb_real_connect() was called.

Dönen Değerler

Returns an resource.

Ayrıca Bakınız

  • maxdb_options() - Set options
  • maxdb_close() - Closes a previously opened database connection
  • maxdb_real_connect() - Opens a connection to a MaxDB server
  • maxdb_connect() - Open a new connection to the MaxDB server

maxdb_info
maxdb_insert_id
MaxDB İşlevleri


Returns the auto generated id used in the last query

maxdb_init
maxdb_kill
MaxDB İşlevleri
PHP Manual

maxdb_insert_id

maxdb::insert_id

(PECL maxdb >= 1.0)

maxdb_insert_id -- maxdb::insert_id — Returns the auto generated id used in the last query

Açıklama

Yordamsal kullanım

mixed maxdb_insert_id ( resource $link )

Nesne yönelimli kullanım

mixed $maxdb->insert_id;

The maxdb_insert_id() function returns the ID generated by a query on a table with a column having the DEFAULT SERIAL attribute. If the last query wasn't an INSERT or UPDATE statement or if the modified table does not have a column with the DEFAULT SERIAL attribute, this function will return zero.

Dönen Değerler

The value of the DEFAULT SERIAL field that was updated by the previous query. Returns zero if there was no previous query on the connection or if the query did not update an DEFAULT_SERIAL value.

Bilginize:

If the number is greater than maximal int value, maxdb_insert_id() will return a string.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

maxdb_report (MAXDB_REPORT_OFF);
$maxdb->query("DROP TABLE mycity");
maxdb_report (MAXDB_REPORT_ERROR);

$maxdb->query("CREATE TABLE mycity LIKE hotel.city");
$maxdb->query("ALTER TABLE mycity ADD id FIXED(11) DEFAULT SERIAL");

$query = "INSERT INTO mycity (zip,name,state) VALUES ('12203','Albany' ,'NY')";
$maxdb->query($query);

printf ("New Record has id %d.\n", $maxdb->insert_id);

/* drop table */
$maxdb->query("DROP TABLE mycity");

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

maxdb_report (MAXDB_REPORT_OFF);
maxdb_query($link,"DROP TABLE mycity");
maxdb_report (MAXDB_REPORT_ERROR);

maxdb_query($link, "CREATE TABLE mycity LIKE hotel.city");
maxdb_query($link, "ALTER TABLE mycity ADD id FIXED(11) DEFAULT SERIAL");

$query = "INSERT INTO mycity (zip,name,state) VALUES ('12203','Albany' ,'NY')";
maxdb_query($link, $query);

printf ("New Record has id %d.\n", maxdb_insert_id($link));

/* drop table */
maxdb_query($link, "DROP TABLE mycity");

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

New Record has id 1.
maxdb_init
maxdb_kill
MaxDB İşlevleri


Disconnects from a MaxDB server

maxdb_insert_id
maxdb_master_query
MaxDB İşlevleri
PHP Manual

maxdb_kill

maxdb::kill

(PECL maxdb >= 1.0)

maxdb_kill -- maxdb::kill — Disconnects from a MaxDB server

Açıklama

Yordamsal kullanım

bool maxdb_kill ( resource $link , int $processid )

Nesne yönelimli kullanım

bool maxdb::kill ( int $processid )

This function is used to disconnect from a MaxDB server specified by the processid parameter.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* determine our thread id */
$thread_id = $maxdb->thread_id;

/* Kill connection */
$maxdb->kill($thread_id);

/* This should produce an error */
if (!$maxdb->query("CREATE TABLE myCity LIKE City")) {
   printf("Error: %s\n", $maxdb->error);
   exit;
}

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* determine our thread id */
$thread_id = maxdb_thread_id($link);

/* Kill connection */
maxdb_kill($link, $thread_id);

/* This should produce an error */
if (!maxdb_query($link, "CREATE TABLE myCity LIKE City")) {
   printf("Error: %s\n", maxdb_error($link));
   exit;
}

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Error: Session not connected

Ayrıca Bakınız

  • maxdb_thread_id() - Returns the thread ID for the current connection

maxdb_insert_id
maxdb_master_query
MaxDB İşlevleri


Enforce execution of a query on the master in a master/slave setup

maxdb_kill
maxdb_more_results
MaxDB İşlevleri
PHP Manual

maxdb_master_query

(PECL maxdb >= 1.0)

maxdb_master_query — Enforce execution of a query on the master in a master/slave setup

Açıklama

bool maxdb_master_query ( resource $link , string $query )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

maxdb_kill
maxdb_more_results
MaxDB İşlevleri


Check if there any more query results from a multi query

maxdb_master_query
maxdb_multi_query
MaxDB İşlevleri
PHP Manual

maxdb_more_results

maxdb::more_results

(PECL maxdb >= 1.0)

maxdb_more_results -- maxdb::more_results — Check if there any more query results from a multi query

Açıklama

bool maxdb_more_results ( resource $link )

maxdb_more_results() indicates if one or more result sets are available from a previous call to maxdb_multi_query().

Dönen Değerler

Always FALSE.

Örnekler

See maxdb_multi_query().

Ayrıca Bakınız

  • maxdb_multi_query() - Performs a query on the database
  • maxdb_next_result() - Prepare next result from multi_query
  • maxdb_store_result() - Transfers a result set from the last query
  • maxdb_use_result() - Initiate a result set retrieval

maxdb_master_query
maxdb_multi_query
MaxDB İşlevleri


Performs a query on the database

maxdb_more_results
maxdb_next_result
MaxDB İşlevleri
PHP Manual

maxdb_multi_query

maxdb::multi_query

(PECL maxdb >= 1.0)

maxdb_multi_query -- maxdb::multi_query — Performs a query on the database

Açıklama

Yordamsal kullanım

bool maxdb_multi_query ( resource $link , string $query )

Nesne yönelimli kullanım

bool maxdb::multi_query ( string $query )

The maxdb_multi_query() works like the function maxdb_query(). Multiple queries are not yet supported.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query  = "SELECT * FROM dual";

/* execute multi query */
if ($maxdb->multi_query($query)) {
   do {
       /* store first result set */
       if ($result = $maxdb->store_result()) {
           while ($row = $result->fetch_row()) {
               printf("%s\n", $row[0]);
           }
           $result->close();
       }
       /* print divider */
       if ($maxdb->more_results()) {
           printf("-----------------\n");
       }
   } while ($maxdb->next_result());
}

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT * FROM dual";

/* execute multi query */
if (maxdb_multi_query($link, $query)) {
   do {
       /* store first result set */
       if ($result = maxdb_store_result($link)) {
           while ($row = maxdb_fetch_row($result)) {
               printf("%s\n", $row[0]);
           }
           maxdb_free_result($result);
       }
       /* print divider */
       if (maxdb_more_results($link)) {
           printf("-----------------\n");
       }
   } while (maxdb_next_result($link));
}

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

a

Ayrıca Bakınız

  • maxdb_use_result() - Initiate a result set retrieval
  • maxdb_store_result() - Transfers a result set from the last query
  • maxdb_next_result() - Prepare next result from multi_query
  • maxdb_more_results() - Check if there any more query results from a multi query

maxdb_more_results
maxdb_next_result
MaxDB İşlevleri


Prepare next result from multi_query

maxdb_multi_query
maxdb_num_fields
MaxDB İşlevleri
PHP Manual

maxdb_next_result

maxdb::next_result

(PECL maxdb >= 1.0)

maxdb_next_result -- maxdb::next_result — Prepare next result from multi_query

Açıklama

bool maxdb_next_result ( resource $link )

Since multiple queries are not yet supported, maxdb_next_result() returns always FALSE.

Dönen Değerler

Returns FALSE.

Ayrıca Bakınız

  • maxdb_multi_query() - Performs a query on the database
  • maxdb_more_results() - Check if there any more query results from a multi query
  • maxdb_store_result() - Transfers a result set from the last query
  • maxdb_use_result() - Initiate a result set retrieval

maxdb_multi_query
maxdb_num_fields
MaxDB İşlevleri


Get the number of fields in a result

maxdb_next_result
maxdb_num_rows
MaxDB İşlevleri
PHP Manual

maxdb_num_fields

maxdb_result::field_count

(PECL maxdb >= 1.0)

maxdb_num_fields -- maxdb_result::field_count — Get the number of fields in a result

Açıklama

Yordamsal kullanım

int maxdb_num_fields ( resource $result )

Nesne yönelimli kullanım

int $maxdb_result->field_count;

maxdb_num_fields() returns the number of fields from specified result set.

Dönen Değerler

The number of fields from a result set

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

if ($result = $maxdb->query("SELECT * FROM hotel.city ORDER BY zip")) {

   /* determine number of fields in result set */
   $field_cnt = $result->field_count;

   printf("Result set has %d fields.\n", $field_cnt);

   /* close result set */
   $result->close();
}

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

if ($result = maxdb_query($link, "SELECT * FROM hotel.city ORDER BY zip")) {

   /* determine number of fields in result set */
   $field_cnt = maxdb_num_fields($result);

   printf("Result set has %d fields.\n", $field_cnt);

   /* close result set */
   maxdb_free_result($result);
}

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Result set has 3 fields.

Ayrıca Bakınız

  • maxdb_fetch_field() - Returns the next field in the result set

maxdb_next_result
maxdb_num_rows
MaxDB İşlevleri


Gets the number of rows in a result

maxdb_num_fields
maxdb_options
MaxDB İşlevleri
PHP Manual

maxdb_num_rows

maxdb::num_rows

(PECL maxdb >= 1.0)

maxdb_num_rows -- maxdb::num_rows — Gets the number of rows in a result

Açıklama

Yordamsal kullanım

int maxdb_num_rows ( resource $result )

Nesne yönelimli kullanım

int $maxdb->num_rows;

Returns the number of rows in the result set.

The use of maxdb_num_rows() depends on whether you use buffered or unbuffered result sets. In case you use unbuffered resultsets maxdb_num_rows() will not correct the correct number of rows until all the rows in the result have been retrieved.

Dönen Değerler

Returns number of rows in the result set.

Bilginize:

If the number of rows is greater than maximal int value, the number will be returned as a string.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

if ($result = $maxdb->query("SELECT cno, name FROM hotel.customer ORDER BY name")) {

   /* determine number of rows result set */
   $row_cnt = $result->num_rows;

   printf("Result set has %d rows.\n", $row_cnt);

   /* close result set */
   $result->close();
}

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

if ($result = maxdb_query($link, "SELECT cno, name FROM hotel.customer ORDER BY name")) {

   /* determine number of rows result set */
   $row_cnt = maxdb_num_rows($result);

   printf("Result set has %d rows.\n", $row_cnt);

   /* close result set */
   maxdb_free_result($result);
}

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Result set has 15 rows.

Ayrıca Bakınız

  • maxdb_affected_rows() - Gets the number of affected rows in a previous MaxDB operation
  • maxdb_store_result() - Transfers a result set from the last query
  • maxdb_use_result() - Initiate a result set retrieval
  • maxdb_query() - Performs a query on the database

maxdb_num_fields
maxdb_options
MaxDB İşlevleri


Set options

maxdb_num_rows
maxdb_param_count
MaxDB İşlevleri
PHP Manual

maxdb_options

maxdb::options

(PECL maxdb >= 1.0)

maxdb_options -- maxdb::options — Set options

Açıklama

Yordamsal kullanım

bool maxdb_options ( resource $link , int $option , mixed $value )

Nesne yönelimli kullanım

bool maxdb::options ( int $option , mixed $value )

maxdb_options() can be used to set extra connect options and affect behavior for a connection.

This function may be called multiple times to set several options.

maxdb_options() should be called after maxdb_init() and before maxdb_real_connect().

The parameter option is the option that you want to set, the value is the value for the option. For detailed description of the options see » http://maxdb.sap.com/documentation/ The parameter option can be one of the following values:

Valid options
Name | Description
MAXDB_COMPNAME | The component name used to initialise the SQLDBC runtime environment.
MAXDB_APPLICATION | The application to be connected to the database.
MAXDB_APPVERSION | The version of the application.
MAXDB_SQLMODE | The SQL mode.
MAXDB_UNICODE | TRUE, if the connection is an unicode (UCS2) client or FALSE, if not.
MAXDB_TIMEOUT | The maximum allowed time of inactivity after which the connection to the database is closed by the system.
MAXDB_ISOLATIONLEVEL | Specifies whether and how shared locks and exclusive locks are implicitly requested or released.
MAXDB_PACKETCOUNT | The number of different request packets used for the connection.
MAXDB_STATEMENTCACHESIZE | The number of prepared statements to be cached for the connection for re-use.
MAXDB_CURSORPREFIX | The prefix to use for result tables that are automatically named.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

See maxdb_real_connect().

Ayrıca Bakınız

  • maxdb_init() - Initializes MaxDB and returns an resource for use with maxdb_real_connect
  • maxdb_real_connect() - Opens a connection to a MaxDB server

maxdb_num_rows
maxdb_param_count
MaxDB İşlevleri


Takma Adı: maxdb_stmt_param_count

maxdb_options
maxdb_ping
MaxDB İşlevleri
PHP Manual

maxdb_param_count

(PECL maxdb 1.0)

maxdb_param_count — Takma Adı: maxdb_stmt_param_count()

Açıklama

Bu işlev şu işlevin takma adıdır: maxdb_stmt_param_count().

Bu takma ad, PHP'nin ileri sürümlerinde kaldırılabileceğinden kullanılması önerilmemektedir ve şimdilik sadece geriye uyumluluk adına mevcuttur.

maxdb_options
maxdb_ping
MaxDB İşlevleri


Pings a server connection, or tries to reconnect if the connection has gone down

maxdb_param_count
maxdb_prepare
MaxDB İşlevleri
PHP Manual

maxdb_ping

maxdb::ping

(PECL maxdb >= 1.0)

maxdb_ping -- maxdb::ping — Pings a server connection, or tries to reconnect if the connection has gone down

Açıklama

Yordamsal kullanım

bool maxdb_ping ( resource $link )

Nesne yönelimli kullanım

bool maxdb::ping ( void )

Checks whether the connection to the server is working. If it has gone down, and global option maxdb.reconnect is enabled an automatic reconnection is attempted.

This function can be used by clients that remain idle for a long while, to check whether the server has closed the connection and reconnect if necessary.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* check if server is alive */
if ($maxdb->ping()) {
   printf ("Our connection is ok!\n");
} else {
   printf ("Error: %s\n", $maxdb->error);
}

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* check if server is alive */
if (maxdb_ping($link)) {
   printf ("Our connection is ok!\n");
} else {
   printf ("Error: %s\n", maxdb_error($link));
}

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Our connection is ok!
maxdb_param_count
maxdb_prepare
MaxDB İşlevleri


Prepare an SQL statement for execution

maxdb_ping
maxdb_query
MaxDB İşlevleri
PHP Manual

maxdb_prepare

maxdb::prepare

(PECL maxdb >= 1.0)

maxdb_prepare -- maxdb::prepare — Prepare an SQL statement for execution

Açıklama

Yordamsal kullanım

resource maxdb_prepare ( resource $link , string $query )

Nesne yönelimli kullanım

maxdb_stmt maxdb::prepare ( string $query )

maxdb_prepare() prepares the SQL query pointed to by the null-terminated string query, and returns a statement handle to be used for further operations on the statement. The query must consist of a single SQL statement.

Bilginize:

You should not add a terminating semicolon or \g to the statement.

The parameter query can include one or more parameter markers in the SQL statement by embedding question mark (?) characters at the appropriate positions.

Bilginize:

The markers are legal only in certain places in SQL statements. For example, they are allowed in the VALUES() list of an INSERT statement (to specify column values for a row), or in a comparison with a column in a WHERE clause to specify a comparison value.

However, they are not allowed for identifiers (such as table or column names), in the select list that names the columns to be returned by a SELECT statement), or to specify both operands of a binary operator such as the = equal sign. The latter restriction is necessary because it would be impossible to determine the parameter type. In general, parameters are legal only in Data Manipulation Languange (DML) statements, and not in Data Defination Language (DDL) statements.

The parameter markers must be bound to application variables using maxdb_stmt_bind_param() and/or maxdb_stmt_bind_result() before executing the statement or fetching rows.

Dönen Değerler

maxdb_prepare() returns a statement resource or FALSE if an error occurred.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$city = "Rosemont";

/* create a prepared statement */
if ($stmt = $maxdb->prepare("SELECT state FROM hotel.city WHERE name=?")) {

   /* bind parameters for markers */
   $stmt->bind_param("s", $city);

   /* execute query */
   $stmt->execute();

   /* bind result variables */
   $stmt->bind_result($district);

   /* fetch value */
   $stmt->fetch();

   printf("%s is in district %s\n", $city, $district);

   /* close statement */
   $stmt->close();
}

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$city = "Rosemont";

/* create a prepared statement */
if ($stmt = maxdb_prepare($link, "SELECT state FROM hotel.city WHERE name=?")) {

   /* bind parameters for markers */
   maxdb_stmt_bind_param($stmt, "s", $city);

   /* execute query */
   maxdb_stmt_execute($stmt);

  /* bind result variables */
   maxdb_stmt_bind_result($stmt, $district);

   /* fetch value */
   maxdb_stmt_fetch($stmt);

   printf("%s is in district %s\n", $city, $district);

   /* close statement */
   maxdb_stmt_close($stmt);
}

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Rosemont is in district IL

Ayrıca Bakınız

  • maxdb_stmt_execute() - Executes a prepared Query
  • maxdb_stmt_fetch() - Fetch results from a prepared statement into the bound variables
  • maxdb_stmt_bind_param() - Binds variables to a prepared statement as parameters
  • maxdb_stmt_bind_result() - Binds variables to a prepared statement for result storage
  • maxdb_stmt_close() - Closes a prepared statement

maxdb_ping
maxdb_query
MaxDB İşlevleri


Performs a query on the database

maxdb_prepare
maxdb_real_connect
MaxDB İşlevleri
PHP Manual

maxdb_query

maxdb::query

(PECL maxdb >= 1.0)

maxdb_query -- maxdb::query — Performs a query on the database

Açıklama

Yordamsal kullanım

mixed maxdb_query ( resource $link , string $query [, int $resultmode ] )

Nesne yönelimli kullanım

mixed maxdb::query ( string $query )

The maxdb_query() function is used to simplify the act of performing a query against the database represented by the link parameter.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. For SELECT, SHOW, DESCRIBE or EXPLAIN maxdb_query() will return a result resource.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* Create table doesn't return a resultset */
if ($maxdb->query("CREATE TABLE temp.mycity LIKE hotel.city") === TRUE) {
   printf("Table mycity successfully created.\n");
}

/* Select queries return a resultset */
if ($result = $maxdb->query("SELECT name FROM hotel.city")) {
   printf("Select returned %d rows.\n", $result->num_rows);

   /* free result set */
   $result->close();
}

/* If we have to retrieve large amount of data we use MAXDB_USE_RESULT */
if ($result = $maxdb->query("SELECT * FROM hotel.city", MAXDB_USE_RESULT)) {
   $result->close();
}

$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* Create table doesn't return a resultset */
if (maxdb_query($link, "CREATE TABLE temp.mycity LIKE hotel.city") === TRUE) {
   printf("Table mycity successfully created.\n");
}

/* Select queries return a resultset */
if ($result = maxdb_query($link, "SELECT name FROM hotel.city")) {
   printf("Select returned %d rows.\n", maxdb_num_rows($result));

   /* free result set */
   maxdb_free_result($result);
}

/* If we have to retrieve large amount of data we use MAXDB_USE_RESULT */
if ($result = maxdb_query($link, "SELECT * FROM hotel.city", MAXDB_USE_RESULT)) {
   maxdb_free_result($result);
}

maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Table mycity successfully created.
Select returned 25 rows.

Ayrıca Bakınız

  • maxdb_real_query() - Execute an SQL query
  • maxdb_multi_query() - Performs a query on the database
  • maxdb_free_result() - Frees the memory associated with a result

maxdb_prepare
maxdb_real_connect
MaxDB İşlevleri


Opens a connection to a MaxDB server

maxdb_query
maxdb_real_escape_string
MaxDB İşlevleri
PHP Manual

maxdb_real_connect

maxdb::real_connect

(PECL maxdb >= 1.0)

maxdb_real_connect -- maxdb::real_connect — Opens a connection to a MaxDB server

Açıklama

Yordamsal kullanım

bool maxdb_real_connect ( resource $link [, string $hostname [, string $username [, string $passwd [, string $dbname [, int $port = 0 [, string $socket ]]]]]] )

Nesne yönelimli kullanım

bool maxdb::real_connect ([ string $hostname [, string $username [, string $passwd [, string $dbname [, int $port = 0 [, string $socket ]]]]]] )

maxdb_real_connect() attempts to establish a connection to a MaxDB database engine running on hostname.

This function differs from maxdb_connect():

  • maxdb_real_connect() needs a valid resource which has to be created by function maxdb_init()

  • With function maxdb_options() you can set various options for connection.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php

/* create a connection object which is not connected */
$maxdb = maxdb_init();

/* set connection options */
$maxdb->options(MAXDB_UNICODE, "FALSE");
$maxdb->options(MAXDB_TIMEOUT, 5);

/* connect to server */
$maxdb->real_connect('localhost', 'MONA', 'RED', 'DEMODB');

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

printf ("Connection: %s\n.", $maxdb->host_info);

$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php

/* create a connection object which is not connected */
$link = maxdb_init();

/* set connection options */
maxdb_options($link, MAXDB_UNICODE, "FALSE");
maxdb_options($link, MAXDB_TIMEOUT, 5);

/* connect to server */
maxdb_real_connect($link, 'localhost', 'MONA', 'RED', 'DEMODB');

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

printf ("Connection: %s\n.", maxdb_get_host_info($link));

maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Connection: localhost <...>

Ayrıca Bakınız

  • maxdb_connect() - Open a new connection to the MaxDB server
  • maxdb_init() - Initializes MaxDB and returns an resource for use with maxdb_real_connect
  • maxdb_options() - Set options
  • maxdb_ssl_set() - Used for establishing secure connections using SSL
  • maxdb_close() - Closes a previously opened database connection

maxdb_query
maxdb_real_escape_string
MaxDB İşlevleri


Escapes special characters in a string for use in an SQL statement, taking into account the current charset of the connection

maxdb_real_connect
maxdb_real_query
MaxDB İşlevleri
PHP Manual

maxdb_real_escape_string

maxdb::real_escape_string

(PECL maxdb >= 1.0)

maxdb_real_escape_string -- maxdb::real_escape_string — Escapes special characters in a string for use in an SQL statement, taking into account the current charset of the connection

Açıklama

Yordamsal kullanım

string maxdb_real_escape_string ( resource $link , string $escapestr )

Nesne yönelimli kullanım

string maxdb::real_escape_string ( string $escapestr )

This function is used to create a legal SQL string that you can use in an SQL statement. The string escapestr is encoded to an escaped SQL string, taking into account the current character set of the connection.

Characters encoded are ', ".

Dönen Değerler

Returns an escaped string.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$maxdb->query("CREATE TABLE temp.mycity LIKE hotel.city");

$city = "'s Hertogenbosch";

/* this query will fail, cause we didn't escape $city */
if (!$maxdb->query("INSERT into temp.mycity VALUES ('11111','$city','NY')")) {
   printf("Error: %s\n", $maxdb->sqlstate);
}

$city = $maxdb->real_escape_string($city);

/* this query with escaped $city will work */
if ($maxdb->query("INSERT into temp.mycity VALUES ('22222','$city','NY')")) {
   printf("%d Row inserted.\n", $maxdb->affected_rows);
}

$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

maxdb_query($link, "CREATE TABLE temp.mycity LIKE hotel.city");

$city = "'s Hertogenbosch";

/* this query will fail, cause we didn't escape $city */
if (!maxdb_query($link, "INSERT into temp.mycity VALUES ('11111','$city','NY')")) {
   printf("Error: %s\n", maxdb_sqlstate($link));
}

$city = maxdb_real_escape_string($link, $city);

/* this query with escaped $city will work */
if (maxdb_query($link, "INSERT into temp.mycity VALUES ('22222','$city','NY')")) {
   printf("%d Row inserted.\n", maxdb_affected_rows($link));
}

maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Warning: maxdb_query(): -5016 POS(43) Missing delimiter: ) <...>
Error: 42000
1 Row inserted.

Ayrıca Bakınız

  • maxdb_character_set_name() - Returns the default character set for the database connection

maxdb_real_connect
maxdb_real_query
MaxDB İşlevleri


Execute an SQL query

maxdb_real_escape_string
maxdb_report
MaxDB İşlevleri
PHP Manual

maxdb_real_query

maxdb::real_query

(PECL maxdb >= 1.0)

maxdb_real_query -- maxdb::real_query — Execute an SQL query

Açıklama

Yordamsal kullanım

bool maxdb_real_query ( resource $link , string $query )

Nesne yönelimli kullanım

bool maxdb::real_query ( string $query )

The maxdb_real_query() is functionally identical with the maxdb_query().

Bilginize:

In order to determine if a given query should return a result set or not, see maxdb_field_count().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • maxdb_query() - Performs a query on the database
  • maxdb_store_result() - Transfers a result set from the last query
  • maxdb_use_result() - Initiate a result set retrieval

maxdb_real_escape_string
maxdb_report
MaxDB İşlevleri


Enables or disables internal report functions

maxdb_real_query
maxdb_rollback
MaxDB İşlevleri
PHP Manual

maxdb_report

(PECL maxdb 1.0)

maxdb_report — Enables or disables internal report functions

Açıklama

bool maxdb_report ( int $flags )

Değiştirgeler

flags

One of the MAXDB_REPORT_XXX constants.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Yordamsal kullanım

<?php
/* activate reporting */
maxdb_report(MAXDB_REPORT_ERROR);

$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* this query should report an error */
$result = maxdb_query($link,"SELECT Name FROM Nonexistingtable WHERE population > 50000");

maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Warning: maxdb_query(): -4004 POS(18) Unknown table name:NONEXISTINGTABLE <...>
maxdb_real_query
maxdb_rollback
MaxDB İşlevleri


Rolls back current transaction

maxdb_report
maxdb_rpl_parse_enabled
MaxDB İşlevleri
PHP Manual

maxdb_rollback

maxdb::rollback

(PECL maxdb >= 1.0)

maxdb_rollback -- maxdb::rollback — Rolls back current transaction

Açıklama

Yordamsal kullanım

bool maxdb_rollback ( resource $link )

Nesne yönelimli kullanım

bool maxdb::rollback ( void )

Rollbacks the current transaction for the database specified by the link parameter.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* disable autocommit */
$maxdb->autocommit(FALSE);

$maxdb->query("CREATE TABLE temp.mycity LIKE hotel.city");
$maxdb->query("INSERT INTO temp.mycity SELECT * FROM hotel.city");

/* commit insert */
$maxdb->commit();

/* delete all rows */
$maxdb->query("DELETE FROM temp.mycity");

if ($result = $maxdb->query("SELECT COUNT(*) FROM temp.mycity")) {
   $row = $result->fetch_row();
   printf("%d rows in table mycity.\n", $row[0]);
   /* Free result */
   $result->close();
}

/* Rollback */
$maxdb->rollback();

if ($result = $maxdb->query("SELECT COUNT(*) FROM temp.mycity")) {
   $row = $result->fetch_row();
   printf("%d rows in table mycity (after rollback).\n", $row[0]);
   /* Free result */
   $result->close();
}

/* Drop table myCity */
$maxdb->query("DROP TABLE temp.mycity");

$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* disable autocommit */
maxdb_autocommit($link, FALSE);

maxdb_query($link, "CREATE TABLE temp.mycity LIKE hotel.city");
maxdb_query($link, "INSERT INTO temp.mycity SELECT * FROM hotel.city");

/* commit insert */
maxdb_commit($link);

/* delete all rows */
maxdb_query($link, "DELETE FROM temp.mycity");

if ($result = maxdb_query($link, "SELECT COUNT(*) FROM temp.mycity")) {
   $row = maxdb_fetch_row($result);
   printf("%d rows in table mycity.\n", $row[0]);
   /* Free result */
   maxdb_free_result($result);
}

/* Rollback */
maxdb_rollback($link);

if ($result = maxdb_query($link, "SELECT COUNT(*) FROM temp.mycity")) {
   $row = maxdb_fetch_row($result);
   printf("%d rows in table mycity (after rollback).\n", $row[0]);
   /* Free result */
   maxdb_free_result($result);
}

/* Drop table myCity */
maxdb_query($link, "DROP TABLE temp.mycity");

maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

0 rows in table mycity.
25 rows in table mycity (after rollback).

Ayrıca Bakınız

  • maxdb_commit() - Commits the current transaction
  • maxdb_autocommit() - Turns on or off auto-commiting database modifications

maxdb_report
maxdb_rpl_parse_enabled
MaxDB İşlevleri


Check if RPL parse is enabled

maxdb_rollback
maxdb_rpl_probe
MaxDB İşlevleri
PHP Manual

maxdb_rpl_parse_enabled

(PECL maxdb >= 1.0)

maxdb_rpl_parse_enabled — Check if RPL parse is enabled

Açıklama

int maxdb_rpl_parse_enabled ( resource $link )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

maxdb_rollback
maxdb_rpl_probe
MaxDB İşlevleri


RPL probe

maxdb_rpl_parse_enabled
maxdb_rpl_query_type
MaxDB İşlevleri
PHP Manual

maxdb_rpl_probe

(PECL maxdb >= 1.0)

maxdb_rpl_probe — RPL probe

Açıklama

bool maxdb_rpl_probe ( resource $link )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

maxdb_rpl_parse_enabled
maxdb_rpl_query_type
MaxDB İşlevleri


Returns RPL query type

maxdb_rpl_probe
maxdb_select_db
MaxDB İşlevleri
PHP Manual

maxdb_rpl_query_type

maxdb::rpl_query_type

(PECL maxdb >= 1.0)

maxdb_rpl_query_type -- maxdb::rpl_query_type — Returns RPL query type

Açıklama

Yordamsal kullanım

int maxdb_rpl_query_type ( resource $link )

Nesne yönelimli kullanım

int maxdb::rpl_query_type ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

maxdb_rpl_probe
maxdb_select_db
MaxDB İşlevleri


Selects the default database for database queries

maxdb_rpl_query_type
maxdb_send_long_data
MaxDB İşlevleri
PHP Manual

maxdb_select_db

maxdb::select_db

(PECL maxdb >= 1.0)

maxdb_select_db -- maxdb::select_db — Selects the default database for database queries

Açıklama

bool maxdb_select_db ( resource $link , string $dbname )

The maxdb_select_db() function selects the default database (specified by the dbname parameter) to be used when performing queries against the database connection represented by the link parameter.

Bilginize:

This function should only be used to change the default database for the connection. You can select the default database with 4th parameter in maxdb_connect().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* return name of current default database */
if ($result = $maxdb->query("SELECT SERVERDB FROM USERS WHERE USERNAME='MONA'")) {
   $row = $result->fetch_row();
   printf("Default database is %s.\n", $row[0]);
   $result->close();
}

/* change db to non existing db */
$maxdb->select_db("XXXXXXXX");

/* return name of current default database */
if ($result = $maxdb->query("SELECT SERVERDB FROM USERS WHERE USERNAME='MONA'")) {
   $row = $result->fetch_row();
   printf("Default database is %s.\n", $row[0]);
   $result->close();
}

$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* return name of current default database */
if ($result = maxdb_query($link, "SELECT SERVERDB FROM USERS WHERE USERNAME='MONA'")) {
   $row = maxdb_fetch_row($result);
   printf("Default database is %s.\n", $row[0]);
   maxdb_free_result($result);
}

/* change db to non existing db */
maxdb_select_db($link, "XXXXXXXX");

/* return name of current default database */
if ($result = maxdb_query($link, "SELECT SERVERDB FROM USERS WHERE USERNAME='MONA'")) {
   $row = maxdb_fetch_row($result);
   printf("Default database is %s.\n", $row[0]);
   maxdb_free_result($result);
}

maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Default database is <...>.

Warning: maxdb_select_db(): -10709 Connection failed (RTE:database not running) <...>

Warning: maxdb_query(): -10821 Session not connected [] <...>

Warning: maxdb_close(): -10821 Session not connected [] <...>

Ayrıca Bakınız

  • maxdb_connect() - Open a new connection to the MaxDB server
  • maxdb_real_connect() - Opens a connection to a MaxDB server

maxdb_rpl_query_type
maxdb_send_long_data
MaxDB İşlevleri


Takma Adı: maxdb_stmt_send_long_data

maxdb_select_db
maxdb_send_query
MaxDB İşlevleri
PHP Manual

maxdb_send_long_data

(PECL maxdb >= 1.0)

maxdb_send_long_data — Takma Adı: maxdb_stmt_send_long_data()

Açıklama

Bu işlev şu işlevin takma adıdır: maxdb_stmt_send_long_data().

Bu takma ad, PHP'nin ileri sürümlerinde kaldırılabileceğinden kullanılması önerilmemektedir ve şimdilik sadece geriye uyumluluk adına mevcuttur.

maxdb_select_db
maxdb_send_query
MaxDB İşlevleri


Send the query and return

maxdb_send_long_data
maxdb_server_end
MaxDB İşlevleri
PHP Manual

maxdb_send_query

maxdb::send_query

(PECL maxdb >= 1.0)

maxdb_send_query -- maxdb::send_query — Send the query and return

Açıklama

Yordamsal kullanım

bool maxdb_send_query ( resource $link , string $query )

Nesne yönelimli kullanım

bool maxdb::send_query ( string $query )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

maxdb_send_long_data
maxdb_server_end
MaxDB İşlevleri


Shut down the embedded server

maxdb_send_query
maxdb_server_init
MaxDB İşlevleri
PHP Manual

maxdb_server_end

(PECL maxdb >= 1.0)

maxdb_server_end — Shut down the embedded server

Açıklama

void maxdb_server_end ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

maxdb_send_query
maxdb_server_init
MaxDB İşlevleri


Initialize embedded server

maxdb_server_end
maxdb_set_opt
MaxDB İşlevleri
PHP Manual

maxdb_server_init

(PECL maxdb >= 1.0)

maxdb_server_init — Initialize embedded server

Açıklama

bool maxdb_server_init ([ array $server [, array $groups ]] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

maxdb_server_end
maxdb_set_opt
MaxDB İşlevleri


Takma Adı: maxdb_options

maxdb_server_init
maxdb_sqlstate
MaxDB İşlevleri
PHP Manual

maxdb_set_opt

(PECL maxdb 1.0)

maxdb_set_opt — Takma Adı: maxdb_options()

Açıklama

Bu işlev şu işlevin takma adıdır: maxdb_options().

maxdb_server_init
maxdb_sqlstate
MaxDB İşlevleri


Returns the SQLSTATE error from previous MaxDB operation

maxdb_set_opt
maxdb_ssl_set
MaxDB İşlevleri
PHP Manual

maxdb_sqlstate

maxdb::sqlstate

(PECL maxdb >= 1.0)

maxdb_sqlstate -- maxdb::sqlstate — Returns the SQLSTATE error from previous MaxDB operation

Açıklama

Yordamsal kullanım

string maxdb_sqlstate ( resource $link )

Nesne yönelimli kullanım

string $maxdb->sqlstate;

Returns a string containing the SQLSTATE error code for the last error. The error code consists of five characters. '00000' means no error. The values are specified by ANSI SQL and ODBC.

Bilginize:

Note that not all MaxDB errors are yet mapped to SQLSTATE's. The value HY000 (general error) is used for unmapped errors.

Dönen Değerler

Returns a string containing the SQLSTATE error code for the last error. The error code consists of five characters. '00000' means no error.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* Table City already exists, so we should get an error */
if (!$maxdb->query("CREATE TABLE hotel.city (ID INT, Name VARCHAR(30))")) {
   printf("Error - SQLSTATE %s.\n", $maxdb->sqlstate);
}

$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* Table City already exists, so we should get an error */
if (!maxdb_query($link, "CREATE TABLE hotel.city (ID INT, Name VARCHAR(30))")) {
   printf("Error - SQLSTATE %s.\n", maxdb_sqlstate($link));
}

maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Warning: maxdb_query(): -6000 POS(20) Duplicate table name:CITY [I6000] <...>
Error - SQLSTATE I6000.

Ayrıca Bakınız

  • maxdb_errno() - Returns the error code for the most recent function call
  • maxdb_error() - Returns a string description of the last error

maxdb_set_opt
maxdb_ssl_set
MaxDB İşlevleri


Used for establishing secure connections using SSL

maxdb_sqlstate
maxdb_stat
MaxDB İşlevleri
PHP Manual

maxdb_ssl_set

maxdb::ssl_set

(PECL maxdb >= 1.0)

maxdb_ssl_set -- maxdb::ssl_set — Used for establishing secure connections using SSL

Açıklama

Yordamsal kullanım

bool maxdb_ssl_set ( resource $link , string $key , string $cert , string $ca , string $capath , string $cipher )

Nesne yönelimli kullanım

bool maxdb::ssl_set ( string $key , string $cert , string $ca , string $capath , string $cipher )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

maxdb_sqlstate
maxdb_stat
MaxDB İşlevleri


Gets the current system status

maxdb_ssl_set
maxdb_stmt_affected_rows
MaxDB İşlevleri
PHP Manual

maxdb_stat

maxdb::stat

(PECL maxdb >= 1.0)

maxdb_stat -- maxdb::stat — Gets the current system status

Açıklama

Yordamsal kullanım

string maxdb_stat ( resource $link )

Nesne yönelimli kullanım

string maxdb::stat ( void )

maxdb_stat() returns a string containing several information about the MaxDB server running.

Dönen Değerler

A string describing the server status. FALSE if an error occurred.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

printf ("System status: %s\n", $maxdb->stat());

$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

printf("System status: %s\n", maxdb_stat($link));

maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

System status: Kernel    7<...>

Ayrıca Bakınız

  • maxdb_get_server_info() - Returns the version of the MaxDB server

maxdb_ssl_set
maxdb_stmt_affected_rows
MaxDB İşlevleri


Returns the total number of rows changed, deleted, or inserted by the last executed statement

maxdb_stat
maxdb_stmt_bind_param
MaxDB İşlevleri
PHP Manual

maxdb_stmt_affected_rows

maxdb_stmt::affected_rows

(PECL maxdb >= 1.0)

maxdb_stmt_affected_rows -- maxdb_stmt::affected_rows — Returns the total number of rows changed, deleted, or inserted by the last executed statement

Açıklama

Yordamsal kullanım

int maxdb_stmt_affected_rows ( resource $stmt )

Nesne yönelimli kullanım

int $maxdb_stmt->affected_rows;

maxdb_stmt_affected_rows() returns the number of rows affected by INSERT, UPDATE, or DELETE query. If the last query was invalid or the number of rows can not determined, this function will return -1.

Dönen Değerler

An integer greater than zero indicates the number of rows affected or retrieved. Zero indicates that no records where updated for an UPDATE/DELETE statement, no rows matched the WHERE clause in the query or that no query has yet been executed. -1 indicates that the query has returned an error or the number of rows can not determined.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* create temp table */
$maxdb->query("CREATE TABLE temp.mycity LIKE hotel.city");

$query = "INSERT INTO temp.mycity SELECT * FROM hotel.city WHERE state LIKE ?";

/* prepare statement */
if ($stmt = $maxdb->prepare($query)) {

   /* Bind variable for placeholder */
   $code = 'N%';
   $stmt->bind_param("s", $code);

   /* execute statement */
   $stmt->execute();

   printf("rows inserted: %d\n", $stmt->affected_rows);

   /* close statement */
   $stmt->close();
}

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* create temp table */
maxdb_query($link, "CREATE TABLE temp.mycity LIKE hotel.city");

$query = "INSERT INTO temp.mycity SELECT * FROM hotel.city WHERE state LIKE ?";

/* prepare statement */
if ($stmt = maxdb_prepare($link, $query)) {

   /* Bind variable for placeholder */
   $code = 'N%';
   maxdb_stmt_bind_param($stmt, "s", $code);

   /* execute statement */
   maxdb_stmt_execute($stmt);

   printf("rows inserted: %d\n", maxdb_stmt_affected_rows($stmt));

   /* close statement */
   maxdb_stmt_close($stmt);
}

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

rows inserted: 4

Ayrıca Bakınız

  • maxdb_stmt_num_rows() - Return the number of rows in statements result set
  • maxdb_prepare() - Prepare an SQL statement for execution

maxdb_stat
maxdb_stmt_bind_param
MaxDB İşlevleri


Binds variables to a prepared statement as parameters

maxdb_stmt_affected_rows
maxdb_stmt_bind_result
MaxDB İşlevleri
PHP Manual

maxdb_stmt_bind_param

maxdb_stmt::bind_param

(PECL maxdb >= 1.0)

maxdb_stmt_bind_param -- maxdb_stmt::bind_param — Binds variables to a prepared statement as parameters

Açıklama

Yordamsal kullanım

bool maxdb_stmt_bind_param ( resource $stmt , string $types , mixed &$var1 [, mixed &$... ] )

Nesne yönelimli kullanım

bool maxdb_stmt::bind_param ( string $types , mixed &$var1 [, mixed &$... ] )

Yordamsal kullanım (extended syntax):

bool maxdb_stmt_bind_param ( resource $stmt , string $types , array &$var )

Nesne yönelimli kullanım (extended syntax):

bool maxdb_stmt::bind_param ( string $types , array &$var )

maxdb_stmt_bind_param() is used to bind variables for the parameter markers in the SQL statement that was passed to maxdb_prepare(). The string types contains one or more characters which specify the types for the corresponding bind variables.

The extended syntax of maxdb_stmt_bind_param() allows to give the parameters as an array instead of a variable list of PHP variables to the function. If the array variable has not been used before calling maxdb_stmt_bind_param(), it has to be initialized as an emtpy array. See the examples how to use maxdb_stmt_bind_param() with extended syntax.

Variables for SELECT INTO SQL statements can also be bound using maxdb_stmt_bind_param(). Parameters for database procedures can be bound using maxdb_stmt_bind_param(). See the examples how to use maxdb_stmt_bind_param() in this cases.

If a variable bound as INTO variable to an SQL statement was used before, the content of this variable is overwritten by the data of the SELECT INTO statement. A reference to this variable will be invalid after a call to maxdb_stmt_bind_param().

For INOUT parameters of database procedures the content of the bound INOUT variable is overwritten by the output value of the database procedure. A reference to this variable will be invalid after a call to maxdb_stmt_bind_param().

Type specification chars
Character | Description
i | corresponding variable has type integer
d | corresponding variable has type double
s | corresponding variable has type string
b | corresponding variable is a blob and will be sent in packages

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb('localhost', 'MONA', 'RED', 'DEMODB');

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$maxdb->query ("CREATE TABLE temp.mycity LIKE hotel.city");
$maxdb->query ("INSERT INTO temp.mycity SELECT * FROM hotel.city");

$stmt = $maxdb->prepare("INSERT INTO temp.mycity VALUES (?, ?, ?)");
$stmt->bind_param('sss', $zip, $name, $state);

$zip = '11111';
$name = 'Georgetown';
$state = 'NY';

/* execute prepared statement */
$stmt->execute();

printf("%d Row inserted.\n", $stmt->affected_rows);

/* close statement and connection */
$stmt->close();

/* Clean up table CountryLanguage */
$maxdb->query("DELETE FROM temp.mycity WHERE name='Georgetown'");
printf("%d Row deleted.\n", $maxdb->affected_rows);

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (!$link) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

maxdb_query ($link, "CREATE TABLE temp.mycity LIKE hotel.city");
maxdb_query ($link, "INSERT INTO temp.mycity SELECT * FROM hotel.city");

$stmt = maxdb_prepare($link, "INSERT INTO temp.mycity VALUES (?, ?, ?)");
maxdb_stmt_bind_param($stmt, 'sss', $zip, $name, $state);

$zip = '11111';
$name = 'Georgetown';
$state = 'NY';

/* execute prepared statement */
maxdb_stmt_execute($stmt);

printf("%d Row inserted.\n", maxdb_stmt_affected_rows($stmt));

/* close statement and connection */
maxdb_stmt_close($stmt);

/* Clean up table CountryLanguage */
maxdb_query($link, "DELETE FROM temp.mycity WHERE name='Georgetown'");
printf("%d Row deleted.\n", maxdb_affected_rows($link));

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

1 Row inserted.
1 Row deleted.

Örnek 3 Yordamsal kullanım (SELECT INTO)

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (!$link) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* Performing SQL query */
$stmt = maxdb_prepare ($link, "SELECT price INTO ? FROM hotel.room where hno = ? and type = ?");
if (!$stmt) {
  printf ("Prepare failed: %s\n", maxdb_error($link));
}

$hno = "50";
$rtype = "suite";

maxdb_stmt_bind_param($stmt, 'dss', $price, $hno, $rtype);
maxdb_stmt_execute($stmt);

printf ("%f\n", $price);

maxdb_stmt_close ($stmt);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

21.600000

Örnek 4 Yordamsal kullanım (DB procedure)

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (!$link) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

maxdb_report (MAXDB_REPORT_OFF);
maxdb_query($link,"DROP DBPROC test_proc");
maxdb_report (MAXDB_REPORT_ERROR);

$query = "create dbproc test_proc (INOUT e_text char(72)) AS select * from SYSDBA.DUAL; fetch into :e_text;";

maxdb_query($link, $query);

/* Performing SQL query */
$stmt = maxdb_prepare ($link, "CALL test_proc (?)");
if (!$stmt) {
  printf ("Prepare failed: %s\n", maxdb_error($link));
}

maxdb_stmt_bind_param($stmt, 's', $result);
maxdb_stmt_execute($stmt);

printf ("%s\n", $result);

maxdb_stmt_close ($stmt);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

a

Örnek 5 Nesne yönelimli kullanım (extended syntax)

<?php
$maxdb = new maxdb('localhost', 'MONA', 'RED', 'DEMODB');

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$maxdb->query ("CREATE TABLE temp.mycity LIKE hotel.city");
$maxdb->query ("INSERT INTO temp.mycity SELECT * FROM hotel.city");

$stmt = $maxdb->prepare("INSERT INTO temp.mycity VALUES (?, ?, ?)");

$arr = array();

$stmt->bind_param('iss', $arr);

$arr[0] = 11111;
$arr[1] = 'Georgetown';
$arr[2] = 'NY';

/* execute prepared statement */
$stmt->execute();

printf("%d Row inserted.\n", maxdb_stmt_affected_rows($stmt));

$arr[0] = 22222;
$arr[1] = 'New Orleans';
$arr[2] = 'LA';

/* execute prepared statement */
$stmt->execute();

printf("%d Row inserted.\n", $stmt->affected_rows);

/* close statement and connection */
$stmt->close();

$result = $maxdb->query("SELECT * from temp.mycity WHERE zip = '11111' OR zip = '22222'");
if ($result) {
  while ($row = $result->fetch_row()) {
    printf ("%s %s %s\n", $row[0], $row[1], $row[2]);
  }
}

/* Clean up table CountryLanguage */
$maxdb->query("DELETE FROM temp.mycity WHERE name='Georgetown'");
$maxdb->query("DELETE FROM temp.mycity WHERE name='New Orleans'");
printf("%d Rows deleted.\n", $maxdb->affected_rows);

/* close connection */
$maxdb->close();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

1 Row inserted.
1 Row inserted.
11111 Georgetown NY
22222 New Orleans LA
2 Rows deleted.

Ayrıca Bakınız

  • maxdb_stmt_bind_result() - Binds variables to a prepared statement for result storage
  • maxdb_stmt_execute() - Executes a prepared Query
  • maxdb_stmt_fetch() - Fetch results from a prepared statement into the bound variables
  • maxdb_prepare() - Prepare an SQL statement for execution
  • maxdb_stmt_send_long_data() - Send data in blocks
  • maxdb_stmt_errno() - Returns the error code for the most recent statement call
  • maxdb_stmt_error() - Returns a string description for last statement error

maxdb_stmt_affected_rows
maxdb_stmt_bind_result
MaxDB İşlevleri


Binds variables to a prepared statement for result storage

maxdb_stmt_bind_param
maxdb_stmt_close_long_data
MaxDB İşlevleri
PHP Manual

maxdb_stmt_bind_result

maxdb_stmt::bind_result

(PECL maxdb >= 1.0)

maxdb_stmt_bind_result -- maxdb_stmt::bind_result — Binds variables to a prepared statement for result storage

Açıklama

Yordamsal kullanım

bool maxdb_stmt_bind_result ( resource $stmt , mixed &$var1 [, mixed &$... ] )

Nesne yönelimli kullanım

bool maxdb_stmt::bind_result ( mixed &$var1 [, mixed &$... ] )

maxdb_stmt_bind_result() is used to associate (bind) columns in the result set to variables. When maxdb_stmt_fetch() is called to fetch data, the MaxDB client/server protocol places the data for the bound columns into the specified variables var1, ....

Bilginize:

Note that all columns must be bound prior to calling maxdb_stmt_fetch(). Depending on column types bound variables can silently change to the corresponding PHP type.

A column can be bound or rebound at any time, even after a result set has been partially retrieved. The new binding takes effect the next time maxdb_stmt_fetch() is called.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* prepare statement */
if ($stmt = $maxdb->prepare("SELECT zip, name FROM hotel.city ORDER BY name")) {
   $stmt->execute();

   /* bind variables to prepared statement */
   $stmt->bind_result($col1, $col2);

   /* fetch values */
   while ($stmt->fetch()) {
       printf("%s %s\n", $col1, $col2);
   }

   /* close statement */
   $stmt->close();
}
/* close connection */
$maxdb->close();

?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (!$link) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* prepare statement */
if ($stmt = maxdb_prepare($link, "SELECT zip, name FROM hotel.city ORDER BY name")) {
   maxdb_stmt_execute($stmt);

   /* bind variables to prepared statement */
   maxdb_stmt_bind_result($stmt, $col1, $col2);

   /* fetch values */
   while (maxdb_stmt_fetch($stmt)) {
       printf("%s %s\n", $col1, $col2);
   }

   /* close statement */
   maxdb_stmt_close($stmt);
}

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

12203 Albany
60601 Chicago
60615 Chicago
45211 Cincinnati
33575 Clearwater
75243 Dallas
32018 Daytona Beach
33441 Deerfield Beach
48226 Detroit
90029 Hollywood
92714 Irvine
90804 Long Beach
11788 Long Island
90018 Los Angeles
70112 New Orleans
10019 New York
10580 New York
92262 Palm Springs
97213 Portland
60018 Rosemont
95054 Santa Clara
20903 Silver Spring
20005 Washington
20019 Washington
20037 Washington

Ayrıca Bakınız

  • maxdb_stmt_bind_param() - Binds variables to a prepared statement as parameters
  • maxdb_stmt_execute() - Executes a prepared Query
  • maxdb_stmt_fetch() - Fetch results from a prepared statement into the bound variables
  • maxdb_prepare() - Prepare an SQL statement for execution
  • maxdb_stmt_prepare() - Prepare an SQL statement for execution
  • maxdb_stmt_init() - Initializes a statement and returns an resource for use with maxdb_stmt_prepare
  • maxdb_stmt_errno() - Returns the error code for the most recent statement call
  • maxdb_stmt_error() - Returns a string description for last statement error

maxdb_stmt_bind_param
maxdb_stmt_close_long_data
MaxDB İşlevleri


Ends a sequence of maxdb_stmt_send_long_data

maxdb_stmt_bind_result
maxdb_stmt_close
MaxDB İşlevleri
PHP Manual

maxdb_stmt_close_long_data

maxdb_stmt::close_long_data

(PECL maxdb 1.0)

maxdb_stmt_close_long_data -- maxdb_stmt::close_long_data — Ends a sequence of maxdb_stmt_send_long_data()

Açıklama

Yordamsal kullanım

bool maxdb_stmt_close_long_data ( resource $stmt , int $param_nr )

Nesne yönelimli kullanım

bool maxdb_stmt::close_long_data ( void )

This function has to be called after a sequence of maxdb_stmt_send_long_data(), that was started after maxdb_execute().

param_nr indicates which parameter to associate the end of data with. Parameters are numbered beginning with 0.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • maxdb_prepare() - Prepare an SQL statement for execution
  • maxdb_stmt_bind_param() - Binds variables to a prepared statement as parameters

maxdb_stmt_bind_result
maxdb_stmt_close
MaxDB İşlevleri


Closes a prepared statement

maxdb_stmt_close_long_data
maxdb_stmt_data_seek
MaxDB İşlevleri
PHP Manual

maxdb_stmt_close

maxdb_stmt::close

(PECL maxdb >= 1.0)

maxdb_stmt_close -- maxdb_stmt::close — Closes a prepared statement

Açıklama

Yordamsal kullanım

bool maxdb_stmt_close ( resource $stmt )

Nesne yönelimli kullanım

bool maxdb_stmt::close ( void )

Closes a prepared statement. maxdb_stmt_close() also deallocates the statement handle pointed to by stmt. If the current statement has pending or unread results, this function cancels them so that the next query can be executed.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • maxdb_prepare() - Prepare an SQL statement for execution

maxdb_stmt_close_long_data
maxdb_stmt_data_seek
MaxDB İşlevleri


Seeks to an arbitray row in statement result set

maxdb_stmt_close
maxdb_stmt_errno
MaxDB İşlevleri
PHP Manual

maxdb_stmt_data_seek

maxdb_stmt::data_seek

(PECL maxdb >= 1.0)

maxdb_stmt_data_seek -- maxdb_stmt::data_seek — Seeks to an arbitray row in statement result set

Açıklama

Yordamsal kullanım

bool maxdb_stmt_data_seek ( resource $statement , int $offset )

Nesne yönelimli kullanım

bool maxdb_stmt::data_seek ( int $offset )

The maxdb_stmt_data_seek() function seeks to an arbitrary result pointer specified by the offset in the statement result set represented by statement. The offset parameter must be between zero and the total number of rows minus one (0..maxdb_stmt_num_rows() - 1).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* Open a connection */
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, zip FROM hotel.city ORDER BY name";
if ($stmt = $maxdb->prepare($query)) {

   /* execute query */
   $stmt->execute();

   /* bind result variables */
   $stmt->bind_result($name, $code);

   /* store result */
   $stmt->store_result();

   /* seek to row no. 5 */
   $stmt->data_seek(5);

   /* fetch values */
   $stmt->fetch();

   printf ("City: %s  Zip: %s\n", $name, $code);

   /* close statement */
   $stmt->close();
}

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
/* Open a connection */
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, zip FROM hotel.city ORDER BY name";
if ($stmt = maxdb_prepare($link, $query)) {

   /* execute query */
   maxdb_stmt_execute($stmt);

   /* bind result variables */
   maxdb_stmt_bind_result($stmt, $name, $code);

   /* store result */
   maxdb_stmt_store_result($stmt);

   /* seek to row no. 5 */
   maxdb_stmt_data_seek($stmt, 5);

   /* fetch values */
   maxdb_stmt_fetch($stmt);

   printf ("City: %s  Zip: %s\n", $name, $code);

   /* close statement */
   maxdb_stmt_close($stmt);
}

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

City: Dallas  Zip: 75243

Ayrıca Bakınız

  • maxdb_prepare() - Prepare an SQL statement for execution

maxdb_stmt_close
maxdb_stmt_errno
MaxDB İşlevleri


Returns the error code for the most recent statement call

maxdb_stmt_data_seek
maxdb_stmt_error
MaxDB İşlevleri
PHP Manual

maxdb_stmt_errno

maxdb_stmt::errno

(PECL maxdb >= 1.0)

maxdb_stmt_errno -- maxdb_stmt::errno — Returns the error code for the most recent statement call

Açıklama

Yordamsal kullanım

int maxdb_stmt_errno ( resource $stmt )

Nesne yönelimli kullanım

int $maxdb_stmt->errno;

For the statement specified by stmt, maxdb_stmt_errno() returns the error code for the most recently invoked statement function that can succeed or fail.

Bilginize:

For possible error codes see documentation of SQLDBC: » http://maxdb.sap.com/documentation/.

Dönen Değerler

An error code value. Zero means no error occurred.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* Open a connection */
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$maxdb->query("CREATE TABLE temp.mycity LIKE hotel.city");
$maxdb->query("INSERT INTO temp.mycity SELECT * FROM hotel.city");

$query = "SELECT name, zip FROM temp.mycity ORDER BY name";
if ($stmt = $maxdb->prepare($query)) {

   /* drop table */
   $maxdb->query("DROP TABLE temp.mycity");

   /* execute query */
   $stmt->execute();

   printf("Error: %d.\n", $stmt->errno);

   /* close statement */
   $stmt->close();
}

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
/* Open a connection */
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

maxdb_query($link, "CREATE TABLE temp.mycity LIKE hotel.city");
maxdb_query($link, "INSERT INTO temp.mycity SELECT * FROM hotel.city");

$query = "SELECT name, zip FROM temp.mycity ORDER BY name";
if ($stmt = maxdb_prepare($link, $query)) {

   /* drop table */
   maxdb_query($link, "DROP TABLE temp.mycity");

   /* execute query */
   maxdb_stmt_execute($stmt);

   printf("Error: %d.\n", maxdb_stmt_errno($stmt));

   /* close statement */
   maxdb_stmt_close($stmt);
}

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Warning: maxdb_stmt_execute(): -4004 POS(23) Unknown table name:MYCITY [42000] <...>
Error: -4004.

Ayrıca Bakınız

  • maxdb_stmt_error() - Returns a string description for last statement error
  • maxdb_stmt_sqlstate() - Returns SQLSTATE error from previous statement operation

maxdb_stmt_data_seek
maxdb_stmt_error
MaxDB İşlevleri


Returns a string description for last statement error

maxdb_stmt_errno
maxdb_stmt_execute
MaxDB İşlevleri
PHP Manual

maxdb_stmt_error

maxdb_stmt::error

(PECL maxdb >= 1.0)

maxdb_stmt_error -- maxdb_stmt::error — Returns a string description for last statement error

Açıklama

Yordamsal kullanım

string maxdb_stmt_error ( resource $stmt )

Nesne yönelimli kullanım

string $maxdb_stmt->error;

For the statement specified by stmt, maxdb_stmt_error() returns a containing the error message for the most recently invoked statement function that can succeed or fail.

Dönen Değerler

A string that describes the error. An empty string if no error occurred.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* Open a connection */
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$maxdb->query("CREATE TABLE temp.mycity LIKE hotel.city");
$maxdb->query("INSERT INTO temp.mycity SELECT * FROM hotel.city");

$query = "SELECT name, zip FROM temp.mycity ORDER BY name";
if ($stmt = $maxdb->prepare($query)) {

   /* drop table */
   $maxdb->query("DROP TABLE temp.mycity");

   /* execute query */
   $stmt->execute();

   printf("Error: %s.\n", $stmt->error);

   /* close statement */
   $stmt->close();
}

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
/* Open a connection */
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

maxdb_query($link, "CREATE TABLE temp.mycity LIKE hotel.city");
maxdb_query($link, "INSERT INTO temp.mycity SELECT * FROM hotel.city");

$query = "SELECT name, zip FROM temp.mycity ORDER BY name";
if ($stmt = maxdb_prepare($link, $query)) {

   /* drop table */
   maxdb_query($link, "DROP TABLE temp.mycity");

   /* execute query */
   maxdb_stmt_execute($stmt);

   printf("Error: %s.\n", maxdb_stmt_error($stmt));

   /* close statement */
   maxdb_stmt_close($stmt);
}

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Warning: maxdb_stmt_execute(): -4004 POS(23) Unknown table name:MYCITY [42000] <...>
Error: POS(23) Unknown table name:MYCITY.

Ayrıca Bakınız

  • maxdb_stmt_errno() - Returns the error code for the most recent statement call
  • maxdb_stmt_sqlstate() - Returns SQLSTATE error from previous statement operation

maxdb_stmt_errno
maxdb_stmt_execute
MaxDB İşlevleri


Executes a prepared Query

maxdb_stmt_error
maxdb_stmt_fetch
MaxDB İşlevleri
PHP Manual

maxdb_stmt_execute

maxdb_stmt::execute

(PECL maxdb >= 1.0)

maxdb_stmt_execute -- maxdb_stmt::execute — Executes a prepared Query

Açıklama

Yordamsal kullanım

bool maxdb_stmt_execute ( resource $stmt )

Nesne yönelimli kullanım

bool maxdb_stmt::execute ( void )

The maxdb_stmt_execute() function executes a query that has been previously prepared using the maxdb_prepare() function represented by the stmt resource. When executed any parameter markers which exist will automatically be replaced with the appropiate data.

If the statement is UPDATE, DELETE, or INSERT, the total number of affected rows can be determined by using the maxdb_stmt_affected_rows() function. Likewise, if the query yields a result set the maxdb_fetch() function is used.

Bilginize:

When using maxdb_stmt_execute(), the maxdb_fetch() function must be used to fetch the data prior to preforming any additional queries.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$maxdb->query("CREATE TABLE temp.mycity LIKE hotel.city");

/* Prepare an insert statement */
$query = "INSERT INTO temp.mycity (zip, name, state) VALUES (?,?,?)";
$stmt = $maxdb->prepare($query);

$stmt->bind_param("sss", $val1, $val2, $val3);

$val1 = '11111';
$val2 = 'Georgetown';
$val3 = 'NY';

/* Execute the statement */
$stmt->execute();

$val1 = '22222';
$val2 = 'Hubbatown';
$val3 = 'CA';

/* Execute the statement */
$stmt->execute();

/* close statement */
$stmt->close();

/* retrieve all rows from myCity */
$query = "SELECT zip, name, state FROM temp.mycity";
if ($result = $maxdb->query($query)) {
   while ($row = $result->fetch_row()) {
       printf("%s (%s,%s)\n", $row[0], $row[1], $row[2]);
   }
   /* free result set */
   $result->close();
}

/* remove table */
$maxdb->query("DROP TABLE temp.mycity");

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

maxdb_query($link, "CREATE TABLE temp.mycity LIKE hotel.city");

/* Prepare an insert statement */
$query = "INSERT INTO temp.mycity (zip, name, state) VALUES (?,?,?)";
$stmt = maxdb_prepare($link, $query);

maxdb_stmt_bind_param($stmt, "sss", $val1, $val2, $val3);

$val1 = '11111';
$val2 = 'Georgetown';
$val3 = 'NY';

/* Execute the statement */
maxdb_stmt_execute($stmt);

$val1 = '22222';
$val2 = 'Hubbatown';
$val3 = 'CA';

/* Execute the statement */
maxdb_stmt_execute($stmt);

/* close statement */
maxdb_stmt_close($stmt);

/* retrieve all rows from myCity */
$query = "SELECT zip, name, state FROM temp.mycity";
if ($result = maxdb_query($link, $query)) {
   while ($row = maxdb_fetch_row($result)) {
       printf("%s (%s,%s)\n", $row[0], $row[1], $row[2]);
   }
   /* free result set */
   maxdb_free_result($result);
}

/* remove table */
maxdb_query($link, "DROP TABLE temp.mycity");

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

11111 (Georgetown,NY)
22222 (Hubbatown,CA)

Ayrıca Bakınız

  • maxdb_prepare() - Prepare an SQL statement for execution
  • maxdb_stmt_bind_param() - Binds variables to a prepared statement as parameters

maxdb_stmt_error
maxdb_stmt_fetch
MaxDB İşlevleri


Fetch results from a prepared statement into the bound variables

maxdb_stmt_execute
maxdb_stmt_free_result
MaxDB İşlevleri
PHP Manual

maxdb_stmt_fetch

maxdb_stmt::fetch

(PECL maxdb >= 1.0)

maxdb_stmt_fetch -- maxdb_stmt::fetch — Fetch results from a prepared statement into the bound variables

Açıklama

Yordamsal kullanım

bool maxdb_stmt_fetch ( resource $stmt )

Nesne yönelimli kullanım

bool maxdb_stmt::fetch ( void )

maxdb_stmt_fetch() returns row data using the variables bound by maxdb_stmt_bind_result().

Bilginize:

Note that all columns must be bound by the application before calling maxdb_stmt_fetch().

Dönen Değerler

Return values
Value | Description
TRUE | Success. Data has been fetched
FALSE | Error occurred
NULL | No more rows/data exists

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT zip, name FROM hotel.city ORDER by name";

if ($stmt = $maxdb->prepare($query)) {

   /* execute statement */
   $stmt->execute();

   /* bind result variables */
   $stmt->bind_result($name, $code);

   /* fetch values */
   while ($stmt->fetch()) {
       printf ("%s (%s)\n", $name, $code);
   }

   /* close statement */
   $stmt->close();
}

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT zip, name FROM hotel.city ORDER by name";

if ($stmt = maxdb_prepare($link, $query)) {

   /* execute statement */
   maxdb_stmt_execute($stmt);

   /* bind result variables */
   maxdb_stmt_bind_result($stmt, $name, $code);

   /* fetch values */
   while (maxdb_stmt_fetch($stmt)) {
       printf ("%s (%s)\n", $name, $code);
   }

   /* close statement */
   maxdb_stmt_close($stmt);
}

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

12203 (Albany)
60601 (Chicago)
60615 (Chicago)
45211 (Cincinnati)
33575 (Clearwater)
75243 (Dallas)
32018 (Daytona Beach)
33441 (Deerfield Beach)
48226 (Detroit)
90029 (Hollywood)
92714 (Irvine)
90804 (Long Beach)
11788 (Long Island)
90018 (Los Angeles)
70112 (New Orleans)
10019 (New York)
10580 (New York)
92262 (Palm Springs)
97213 (Portland)
60018 (Rosemont)
95054 (Santa Clara)
20903 (Silver Spring)
20005 (Washington)
20019 (Washington)
20037 (Washington)

Ayrıca Bakınız

  • maxdb_prepare() - Prepare an SQL statement for execution
  • maxdb_stmt_errno() - Returns the error code for the most recent statement call
  • maxdb_stmt_error() - Returns a string description for last statement error
  • maxdb_stmt_bind_result() - Binds variables to a prepared statement for result storage

maxdb_stmt_execute
maxdb_stmt_free_result
MaxDB İşlevleri


Frees stored result memory for the given statement handle

maxdb_stmt_fetch
maxdb_stmt_init
MaxDB İşlevleri
PHP Manual

maxdb_stmt_free_result

maxdb_stmt::free_result

(PECL maxdb >= 1.0)

maxdb_stmt_free_result -- maxdb_stmt::free_result — Frees stored result memory for the given statement handle

Açıklama

Yordamsal kullanım

void maxdb_stmt_free_result ( resource $stmt )

Nesne yönelimli kullanım

void maxdb_stmt::free_result ( void )

The maxdb_stmt_free_result() function frees the result memory associated with the statement represented by the stmt parameter, which was allocated by maxdb_stmt_store_result().

Dönen Değerler

This function doesn't return any value.

Ayrıca Bakınız

  • maxdb_stmt_store_result() - Transfers a result set from a prepared statement

maxdb_stmt_fetch
maxdb_stmt_init
MaxDB İşlevleri


Initializes a statement and returns an resource for use with maxdb_stmt_prepare

maxdb_stmt_free_result
maxdb_stmt_num_rows
MaxDB İşlevleri
PHP Manual

maxdb_stmt_init

maxdb::stmt_init

(PECL maxdb >= 1.0)

maxdb_stmt_init -- maxdb::stmt_init — Initializes a statement and returns an resource for use with maxdb_stmt_prepare

Açıklama

Yordamsal kullanım

resource maxdb_stmt_init ( resource $link )

Nesne yönelimli kullanım

object maxdb::stmt_init ( void )

Allocates and initializes a statement resource suitable for maxdb_stmt_prepare().

Bilginize:

Any subsequent calls to any maxdb_stmt function will fail until maxdb_stmt_prepare() was called.

Dönen Değerler

Returns an resource.

Ayrıca Bakınız

  • maxdb_stmt_prepare() - Prepare an SQL statement for execution

maxdb_stmt_free_result
maxdb_stmt_num_rows
MaxDB İşlevleri


Return the number of rows in statements result set

maxdb_stmt_init
maxdb_stmt_param_count
MaxDB İşlevleri
PHP Manual

maxdb_stmt_num_rows

maxdb_stmt::num_rows

(PECL maxdb >= 1.0)

maxdb_stmt_num_rows -- maxdb_stmt::num_rows — Return the number of rows in statements result set

Açıklama

Yordamsal kullanım

int maxdb_stmt_num_rows ( resource $stmt )

Nesne yönelimli kullanım

int $maxdb_stmt->num_rows;

Returns the number of rows in the result set.

Dönen Değerler

An integer representing the number of rows in result set.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* Open a connection */
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT zip, name FROM hotel.city ORDER BY name";
if ($stmt = $maxdb->prepare($query)) {

   /* execute query */
   $stmt->execute();

   /* store result */
   $stmt->store_result();

   printf("Number of rows: %d.\n", $stmt->num_rows);

   /* close statement */
   $stmt->close();
}

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
/* Open a connection */
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT zip, name FROM hotel.city ORDER BY name";
if ($stmt = maxdb_prepare($link, $query)) {

   /* execute query */
   maxdb_stmt_execute($stmt);

   /* store result */
   maxdb_stmt_store_result($stmt);

   printf("Number of rows: %d.\n", maxdb_stmt_num_rows($stmt));

   /* close statement */
   maxdb_stmt_close($stmt);
}

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Number of rows: 25.

Ayrıca Bakınız

  • maxdb_stmt_affected_rows() - Returns the total number of rows changed, deleted, or inserted by the last executed statement
  • maxdb_prepare() - Prepare an SQL statement for execution
  • maxdb_stmt_store_result() - Transfers a result set from a prepared statement

maxdb_stmt_init
maxdb_stmt_param_count
MaxDB İşlevleri


Returns the number of parameter for the given statement

maxdb_stmt_num_rows
maxdb_stmt_prepare
MaxDB İşlevleri
PHP Manual

maxdb_stmt_param_count

maxdb_stmt::param_count

(PECL maxdb >= 1.0)

maxdb_stmt_param_count -- maxdb_stmt::param_count — Returns the number of parameter for the given statement

Açıklama

Yordamsal kullanım

int maxdb_stmt_param_count ( resource $stmt )

Nesne yönelimli kullanım

int $maxdb_stmt->param_count;

maxdb_stmt_param_count() returns the number of parameter markers present in the prepared statement.

Dönen Değerler

returns an integer representing the number of parameters.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

if ($stmt = $maxdb->prepare("SELECT name FROM hotel.city WHERE name=? OR state=?")) {

   $marker = $stmt->param_count;
   printf("Statement has %d markers.\n", $marker);

   /* close statement */
   $stmt->close();
}

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

if ($stmt = maxdb_prepare($link, "SELECT name FROM hotel.city WHERE name=? OR state=?")) {

   $marker = maxdb_stmt_param_count($stmt);
   printf("Statement has %d markers.\n", $marker);

   /* close statement */
   maxdb_stmt_close($stmt);
}

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Statement has 2 markers.

Ayrıca Bakınız

  • maxdb_prepare() - Prepare an SQL statement for execution

maxdb_stmt_num_rows
maxdb_stmt_prepare
MaxDB İşlevleri


Prepare an SQL statement for execution

maxdb_stmt_param_count
maxdb_stmt_reset
MaxDB İşlevleri
PHP Manual

maxdb_stmt_prepare

maxdb_stmt::prepare

(PECL maxdb >= 1.0)

maxdb_stmt_prepare -- maxdb_stmt::prepare — Prepare an SQL statement for execution

Açıklama

Yordamsal kullanım

bool maxdb_stmt_prepare ( resource $stmt , string $query )

Nesne yönelimli kullanım

mixed maxdb_stmt::prepare ( string $query )

maxdb_stmt_prepare() prepares the SQL query pointed to by the null-terminated string query. The statement resource has to be allocated by maxdb_stmt_init(). The query must consist of a single SQL statement.

Bilginize:

You should not add a terminating semicolon or \g to the statement.

The parameter query can include one or more parameter markers in the SQL statement by embedding question mark (?) characters at the appropriate positions.

Bilginize:

The markers are legal only in certain places in SQL statements. For example, they are allowed in the VALUES() list of an INSERT statement (to specify column values for a row), or in a comparison with a column in a WHERE clause to specify a comparison value.

However, they are not allowed for identifiers (such as table or column names), in the select list that names the columns to be returned by a SELECT statement), or to specify both operands of a binary operator such as the = equal sign. The latter restriction is necessary because it would be impossible to determine the parameter type. In general, parameters are legal only in Data Manipulation Languange (DML) statements, and not in Data Defination Language (DDL) statements.

The parameter markers must be bound to application variables using maxdb_stmt_bind_param() and/or maxdb_stmt_bind_result() before executing the statement or fetching rows.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$city = "Portland";

/* create a prepared statement */
$stmt =  $maxdb->stmt_init();
if ($stmt->prepare("SELECT state FROM hotel.city WHERE name=?")) {

   /* bind parameters for markers */
   $stmt->bind_param("s", $city);

   /* execute query */
   $stmt->execute();

   /* bind result variables */
   $stmt->bind_result($district);

   /* fetch value */
   $stmt->fetch();

   printf("%s is in district %s\n", $city, $district);

   /* close statement */
   $stmt->close();
}

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$city = "Portland";

/* create a prepared statement */
$stmt = maxdb_stmt_init($link);
if (maxdb_stmt_prepare($stmt, "SELECT state FROM hotel.city WHERE name=?")) {

   /* bind parameters for markers */
   maxdb_stmt_bind_param($stmt, "s", $city);

   /* execute query */
   maxdb_stmt_execute($stmt);

   /* bind result variables */
   maxdb_stmt_bind_result($stmt, $district);

   /* fetch value */
   maxdb_stmt_fetch($stmt);

   printf("%s is in district %s\n", $city, $district);

   /* close statement */
   maxdb_stmt_close($stmt);
}

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Portland is in district OR

Ayrıca Bakınız

  • maxdb_stmt_init() - Initializes a statement and returns an resource for use with maxdb_stmt_prepare
  • maxdb_stmt_execute() - Executes a prepared Query
  • maxdb_stmt_fetch() - Fetch results from a prepared statement into the bound variables
  • maxdb_stmt_bind_param() - Binds variables to a prepared statement as parameters
  • maxdb_stmt_bind_result() - Binds variables to a prepared statement for result storage
  • maxdb_stmt_close() - Closes a prepared statement

maxdb_stmt_param_count
maxdb_stmt_reset
MaxDB İşlevleri


Resets a prepared statement

maxdb_stmt_prepare
maxdb_stmt_result_metadata
MaxDB İşlevleri
PHP Manual

maxdb_stmt_reset

maxdb_stmt::reset

(PECL maxdb >= 1.0)

maxdb_stmt_reset -- maxdb_stmt::reset — Resets a prepared statement

Açıklama

Yordamsal kullanım

bool maxdb_stmt_reset ( resource $stmt )

Nesne yönelimli kullanım

bool maxdb_stmt::reset ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

maxdb_stmt_prepare
maxdb_stmt_result_metadata
MaxDB İşlevleri


Returns result set metadata from a prepared statement

maxdb_stmt_reset
maxdb_stmt_send_long_data
MaxDB İşlevleri
PHP Manual

maxdb_stmt_result_metadata

maxdb_stmt::result_metadata

(PECL maxdb >= 1.0)

maxdb_stmt_result_metadata -- maxdb_stmt::result_metadata — Returns result set metadata from a prepared statement

Açıklama

Yordamsal kullanım

resource maxdb_stmt_result_metadata ( resource $stmt )

Nesne yönelimli kullanım

resource maxdb_stmt::result_metadata ( void )

If a statement passed to maxdb_prepare() is one that produces a result set, maxdb_stmt_result_metadata() returns the result resource that can be used to process the meta information such as total number of fields and individual field information.

Bilginize:

This result set pointer can be passed as an argument to any of the field-based functions that process result set metadata, such as:

  • maxdb_num_fields()

  • maxdb_fetch_field()

  • maxdb_fetch_field_direct()

  • maxdb_fetch_fields()

  • maxdb_field_count()

  • maxdb_field_seek()

  • maxdb_field_tell()

  • maxdb_free_result()

The result set structure should be freed when you are done with it, which you can do by passing it to maxdb_free_result()

Bilginize:

The result set returned by maxdb_stmt_result_metadata() contains only metadata. It does not contain any row results. The rows are obtained by using the statement handle with maxdb_fetch().

Dönen Değerler

maxdb_stmt_result_metadata() returns a result resource or FALSE if an error occurred.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

$maxdb->query("CREATE TABLE temp.friends (id int, name varchar(20))");

$maxdb->query("INSERT INTO temp.friends VALUES (1,'Hartmut')");
$maxdb->query("INSERT INTO temp.friends VALUES (2, 'Ulf')");

$stmt = $maxdb->prepare("SELECT id, name FROM temp.friends");
$stmt->execute();

/* get resultset for metadata */
$result = $stmt->result_metadata();

/* retrieve field information from metadata result set */
$field = $result->fetch_field();

printf("Fieldname: %s\n", $field->name);

/* close resultset */
$result->close();

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

maxdb_query($link, "CREATE TABLE temp.friends (id int, name varchar(20))");

maxdb_query($link, "INSERT INTO temp.friends VALUES (1,'Hartmut')");
maxdb_query($link, "INSERT INTO temp.friends VALUES (2, 'Ulf')");

$stmt = maxdb_prepare($link, "SELECT id, name FROM temp.friends");
maxdb_stmt_execute($stmt);

/* get resultset for metadata */
$result = maxdb_stmt_result_metadata($stmt);

/* retrieve field information from metadata result set */
$field = maxdb_fetch_field($result);

printf("Fieldname: %s\n", $field->name);

/* close resultset */
maxdb_free_result($result);

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Fieldname: ID

Ayrıca Bakınız

  • maxdb_prepare() - Prepare an SQL statement for execution
  • maxdb_free_result() - Frees the memory associated with a result

maxdb_stmt_reset
maxdb_stmt_send_long_data
MaxDB İşlevleri


Send data in blocks

maxdb_stmt_result_metadata
maxdb_stmt_sqlstate
MaxDB İşlevleri
PHP Manual

maxdb_stmt_send_long_data

maxdb_stmt::send_long_data

(PECL maxdb 1.0)

maxdb_stmt_send_long_data -- maxdb_stmt::send_long_data — Send data in blocks

Açıklama

Yordamsal kullanım

bool maxdb_stmt_send_long_data ( resource $stmt , int $param_nr , string $data )

Nesne yönelimli kullanım

bool maxdb_stmt::stmt_send_long_data ( int $param_nr , string $data )

Allows to send parameter data to the server in pieces (or chunks). This function can be called multiple times to send the parts of a character or binary data value for a column, which must be one of the TEXT or BLOB datatypes.

param_nr indicates which parameter to associate the data with. Parameters are numbered beginning with 0. data is a string containing data to be sent.

Bilginize:

For efficiency reasons, this function should be used after calling maxdb_execute(). In this case, the data is not stored on the client side. The end of the sequence must end with a call to maxdb_stmt_close_long_data().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • maxdb_prepare() - Prepare an SQL statement for execution
  • maxdb_stmt_bind_param() - Binds variables to a prepared statement as parameters

maxdb_stmt_result_metadata
maxdb_stmt_sqlstate
MaxDB İşlevleri


Returns SQLSTATE error from previous statement operation

maxdb_stmt_send_long_data
maxdb_stmt_store_result
MaxDB İşlevleri
PHP Manual

maxdb_stmt_sqlstate

(PECL maxdb >= 1.0)

maxdb_stmt_sqlstate — Returns SQLSTATE error from previous statement operation

Açıklama

string maxdb_stmt_sqlstate ( resource $stmt )

Returns a string containing the SQLSTATE error code for the most recently invoked prepared statement function that can succeed or fail. The error code consists of five characters. '00000' means no error. The values are specified by ANSI SQL and ODBC.

Bilginize:

Note that not all MaxDB errors are yet mapped to SQLSTATE's. The value HY000 (general error) is used for unmapped errors.

Dönen Değerler

Returns a string containing the SQLSTATE error code for the last error. The error code consists of five characters. '00000' means no error.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* Open a connection */
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$maxdb->query("CREATE TABLE temp.mycity LIKE hotel.city");
$maxdb->query("INSERT INTO temp.mycity SELECT * FROM hotel.city");

$query = "SELECT name, zip FROM temp.mycity ORDER BY name";
if ($stmt = $maxdb->prepare($query)) {

   /* drop table */
   $maxdb->query("DROP TABLE temp.mycity");

   /* execute query */
   $stmt->execute();

   printf("Error: %s.\n", $stmt->sqlstate);

   /* close statement */
   $stmt->close();
}

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
/* Open a connection */
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

maxdb_query($link, "CREATE TABLE temp.mycity LIKE hotel.city");
maxdb_query($link, "INSERT INTO temp.mycity SELECT * FROM hotel.city");

$query = "SELECT name, zip FROM temp.mycity ORDER BY name";
if ($stmt = maxdb_prepare($link, $query)) {

   /* drop table */
   maxdb_query($link, "DROP TABLE temp.mycity");

   /* execute query */
   maxdb_stmt_execute($stmt);

   printf("Error: %s.\n", maxdb_stmt_sqlstate($stmt));

   /* close statement */
   maxdb_stmt_close($stmt);
}

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Warning: maxdb_stmt_execute(): -4004 POS(23) Unknown table name:MYCITY [42000] <...>
Error: 42000.

Ayrıca Bakınız

  • maxdb_stmt_errno() - Returns the error code for the most recent statement call
  • maxdb_stmt_error() - Returns a string description for last statement error

maxdb_stmt_send_long_data
maxdb_stmt_store_result
MaxDB İşlevleri


Transfers a result set from a prepared statement

maxdb_stmt_sqlstate
maxdb_store_result
MaxDB İşlevleri
PHP Manual

maxdb_stmt_store_result

maxdb_stmt::store_result

(PECL maxdb >= 1.0)

maxdb_stmt_store_result -- maxdb_stmt::store_result — Transfers a result set from a prepared statement

Açıklama

Yordamsal kullanım

bool maxdb_stmt_store_result ( resource $stmt )

Nesne yönelimli kullanım

object maxdb_stmt::store_result ( void )

maxdb_stmt_store_result() has no functionally effect and should not be used for retrieving data from MaxDB server.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* Open a connection */
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, zip FROM hotel.city ORDER BY name";
if ($stmt = $maxdb->prepare($query)) {

   /* execute query */
   $stmt->execute();

   /* store result */
   $stmt->store_result();

   printf("Number of rows: %d.\n", $stmt->num_rows);

   /* free result */
   $stmt->free_result();

   /* close statement */
   $stmt->close();
}

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
/* Open a connection */
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, zip FROM hotel.city ORDER BY name";
if ($stmt = maxdb_prepare($link, $query)) {

   /* execute query */
   maxdb_stmt_execute($stmt);

   /* store result */
   maxdb_stmt_store_result($stmt);

   printf("Number of rows: %d.\n", maxdb_stmt_num_rows($stmt));

   /* free result */
   maxdb_stmt_free_result($stmt);

   /* close statement */
   maxdb_stmt_close($stmt);
}

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Number of rows: 25.

Ayrıca Bakınız

  • maxdb_prepare() - Prepare an SQL statement for execution
  • maxdb_stmt_result_metadata() - Returns result set metadata from a prepared statement
  • maxdb_fetch() - Takma Adı: maxdb_stmt_fetch

maxdb_stmt_sqlstate
maxdb_store_result
MaxDB İşlevleri


Transfers a result set from the last query

maxdb_stmt_store_result
maxdb_thread_id
MaxDB İşlevleri
PHP Manual

maxdb_store_result

maxdb::store_result

(PECL maxdb >= 1.0)

maxdb_store_result -- maxdb::store_result — Transfers a result set from the last query

Açıklama

Yordamsal kullanım

resource maxdb_store_result ( resource $link )

Nesne yönelimli kullanım

object maxdb::store_result ( void )

This function has no functionally effect.

Dönen Değerler

Returns a result resource or FALSE if an error occurred.

Örnekler

See maxdb_multi_query().

Ayrıca Bakınız

  • maxdb_real_query() - Execute an SQL query
  • maxdb_use_result() - Initiate a result set retrieval

maxdb_stmt_store_result
maxdb_thread_id
MaxDB İşlevleri


Returns the thread ID for the current connection

maxdb_store_result
maxdb_thread_safe
MaxDB İşlevleri
PHP Manual

maxdb_thread_id

maxdb::thread_id

(PECL maxdb >= 1.0)

maxdb_thread_id -- maxdb::thread_id — Returns the thread ID for the current connection

Açıklama

Yordamsal kullanım

int maxdb_thread_id ( resource $link )

Nesne yönelimli kullanım

int $maxdb->thread_id;

The maxdb_thread_id() function returns the thread ID for the current connection which can then be killed using the maxdb_kill() function. If the connection is lost and you reconnect with maxdb_ping(), the thread ID will be other. Therefore you should get the thread ID only when you need it.

Bilginize:

The thread ID is assigned on a connection-by-connection basis. Hence, if the connection is broken and then re-established a new thread ID will be assigned.

Dönen Değerler

maxdb_thread_id() returns the Thread ID for the current connection.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* determine our thread id */
$thread_id = $maxdb->thread_id;

/* Kill connection */
$maxdb->kill($thread_id);

/* This should produce an error */
if (!$maxdb->query("CREATE TABLE mycity LIKE hotel.city")) {
   printf("Error: %s\n", $maxdb->error);
   exit;
}

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* determine our thread id */
$thread_id = maxdb_thread_id($link);

/* Kill connection */
maxdb_kill($link, $thread_id);

/* This should produce an error */
if (!maxdb_query($link, "CREATE TABLE mycity LIKE hotel.city")) {
   printf("Error: %s\n", maxdb_error($link));
   exit;
}

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Warning: maxdb_query(): -10821 Session not connected <...>
Error: Session not connected

Ayrıca Bakınız

  • maxdb_kill() - Disconnects from a MaxDB server

maxdb_store_result
maxdb_thread_safe
MaxDB İşlevleri


Returns whether thread safety is given or not

maxdb_thread_id
maxdb_use_result
MaxDB İşlevleri
PHP Manual

maxdb_thread_safe

(PECL maxdb >= 7.6.06.04)

maxdb_thread_safe — Returns whether thread safety is given or not

Açıklama

bool maxdb_thread_safe ( void )

maxdb_thread_safe() indicates whether the client library is compiled as thread-safe.

Dönen Değerler

TRUE if the client library is thread-safe, otherwise FALSE.

maxdb_thread_id
maxdb_use_result
MaxDB İşlevleri


Initiate a result set retrieval

maxdb_thread_safe
maxdb_warning_count
MaxDB İşlevleri
PHP Manual

maxdb_use_result

maxdb::use_result

(PECL maxdb >= 1.0)

maxdb_use_result -- maxdb::use_result — Initiate a result set retrieval

Açıklama

Yordamsal kullanım

resource maxdb_use_result ( resource $link )

Nesne yönelimli kullanım

resource maxdb::use_result ( void )

maxdb_use_result() has no effect.

Dönen Değerler

Returns result başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query  = "SELECT * FROM DUAL";

/* execute multi query */
if ($maxdb->multi_query($query)) {
   do {
       /* store first result set */
       if ($result = $maxdb->use_result()) {
           while ($row = $result->fetch_row()) {
               printf("%s\n", $row[0]);
           }
           $result->close();
       }
       /* print divider */
       if ($maxdb->more_results()) {
           printf("-----------------\n");
       }
   } while ($maxdb->next_result());
}

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query  = "SELECT * FROM DUAL";

/* execute multi query */
if (maxdb_multi_query($link, $query)) {
   do {
       /* store first result set */
       if ($result = maxdb_use_result($link)) {
           while ($row = maxdb_fetch_row($result)) {
               printf("%s\n", $row[0]);
           }
           maxdb_free_result($result);
       }
       /* print divider */
       if (maxdb_more_results($link)) {
           printf("-----------------\n");
       }
   } while (maxdb_next_result($link));
}

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

a

Ayrıca Bakınız

  • maxdb_real_query() - Execute an SQL query
  • maxdb_store_result() - Transfers a result set from the last query

maxdb_thread_safe
maxdb_warning_count
MaxDB İşlevleri


Returns the number of warnings from the last query for the given link

maxdb_use_result
Mongo
MaxDB İşlevleri
PHP Manual

maxdb_warning_count

maxdb::warning_count

(PECL maxdb >= 1.0)

maxdb_warning_count -- maxdb::warning_count — Returns the number of warnings from the last query for the given link

Açıklama

Yordamsal kullanım

int maxdb_warning_count ( resource $link )

Nesne yönelimli kullanım

int $maxdb->warning_count;

maxdb_warning_count() returns the number of warnings from the last query in the connection represented by the link parameter.

Dönen Değerler

Number of warnings or zero if there are no warnings.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$maxdb->query("CREATE TABLE temp.mycity LIKE hotel.city");

/* a remarkable city in Wales */
$query = "INSERT INTO temp.mycity (zip, name) VALUES('11111',
       'Llanfairpwllgwyngyllgogerychwyrndrobwllllantysiliogogogoch')";

$maxdb->query($query);

printf ("Number of warning: %d\n", $maxdb->warning_count);

/* close connection */
$maxdb->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

maxdb_query($link, "CREATE TABLE temp.mycity LIKE hotel.city");

/* a remarkable long city name in Wales */
$query = "INSERT INTO temp.mycity (zip, name) VALUES('11111',
       'Llanfairpwllgwyngyllgogerychwyrndrobwllllantysiliogogogoch')";

maxdb_query($link, $query);

printf ("Number of warning: %d\n", maxdb_warning_count($link));

/* close connection */
maxdb_close($link);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Warning: maxdb_query(): -8004 POS(62) Constant must be compatible with column type and length <...>
Number of warning: 0

Ayrıca Bakınız

  • maxdb_errno() - Returns the error code for the most recent function call
  • maxdb_error() - Returns a string description of the last error
  • maxdb_sqlstate() - Returns the SQLSTATE error from previous MaxDB operation

maxdb_use_result
Mongo
MaxDB İşlevleri


MongoDB driver (legacy)

  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
  • Öntanımlı Sabitler
  • Manual
    • Tutorial
    • Read Preferences
    • Write Concerns
    • SQL to Mongo Mapping Chart
    • Connecting
    • Stream Context Options
    • Writes
    • Querying
    • Updates
    • Security
    • Troubleshooting
    • Running the Driver's Tests
  • Core Classes
    • MongoClient — The MongoClient class
    • MongoDB — The MongoDB class
    • MongoCollection — The MongoCollection class
    • MongoCursor — The MongoCursor class
    • MongoCursorInterface — The MongoCursorInterface interface
    • MongoCommandCursor — The MongoCommandCursor class
  • Types
    • MongoId — The MongoId class
    • MongoCode — The MongoCode class
    • MongoDate — The MongoDate class
    • MongoRegex — The MongoRegex class
    • MongoBinData — The MongoBinData class
    • MongoInt32 — The MongoInt32 class
    • MongoInt64 — The MongoInt64 class
    • MongoDBRef — The MongoDBRef class
    • MongoMinKey — The MongoMinKey class
    • MongoMaxKey — The MongoMaxKey class
    • MongoTimestamp — The MongoTimestamp class
  • GridFS Classes
    • MongoGridFS — The MongoGridFS class
    • MongoGridFSFile — The MongoGridFSFile class
    • MongoGridFSCursor — The MongoGridFSCursor class
  • Batch Classes
    • MongoWriteBatch — The MongoWriteBatch class
    • MongoInsertBatch — The MongoInsertBatch class
    • MongoUpdateBatch — The MongoUpdateBatch class
    • MongoDeleteBatch — The MongoDeleteBatch class
  • Miscellaneous
    • MongoLog — The MongoLog class
    • MongoPool — The MongoPool class
    • Mongo — The Mongo class [deprecated]
  • Mongo İşlevleri
    • bson_decode — Deserializes a BSON object into a PHP array
    • bson_encode — Serializes a PHP variable into a BSON string
  • Exceptions
    • MongoException — The MongoException class
    • MongoResultException — The MongoResultException class
    • MongoCursorException — The MongoCursorException class
    • MongoCursorTimeoutException — The MongoCursorTimeoutException class
    • MongoConnectionException — The MongoConnectionException class
    • MongoGridFSException — The MongoGridFSException class
    • MongoDuplicateKeyException — The MongoDuplicateKeyException class
    • MongoProtocolException — The MongoProtocolException class
    • MongoExecutionTimeoutException — The MongoExecutionTimeoutException class
    • MongoWriteConcernException — The MongoWriteConcernException class
  • Changelog
maxdb_warning_count
Yapılandırma/Kurulum
Sağlayıcıya Göre Veritabanı Eklentileri


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
Uyarı

This extension is deprecated. Instead, the MongoDB extension should be used.

Mongo
Gereksinimler
Mongo


Kurulum

Uyarı

This extension is deprecated. Instead, the MongoDB extension should be used.

The MongoDB PHP driver should work on nearly any system: Windows, Mac OS X, Unix, and Linux; little- and big-endian machines; 32- and 64-bit machines; PHP 5.3 through 5.6 (versions prior to 1.6 also support PHP 5.2).

Bu » PECL eklentisi PHP ile gelmez.

  • Manual Installation
  • Installing on *NIX
  • Installing on Windows
  • OS X
  • Gentoo
  • Red Hat
  • Third-Party Installation Instructions

Manual Installation

For driver developers and people interested in the latest bugfixes, you can compile the driver from the latest source code on » Github. Go to Github and click the "download" button. Then run:

$ tar zxvf mongodb-mongodb-php-driver-<commit_id>.tar.gz
$ cd mongodb-mongodb-php-driver-<commit_id>
$ phpize
$ ./configure
$ make all
$ sudo make install

Make the following changes to php.ini:

  • Make sure the extension_dir variable is pointing to the directory containing mongo.so. The build will display where it is installing the PHP driver with output that looks something like:

    Installing '/usr/lib/php/extensions/no-debug-non-zts-20060613/mongo.so'
    Make sure that it is the same as the PHP extension directory by running:
    $ php -i | grep extension_dir
  extension_dir => /usr/lib/php/extensions/no-debug-non-zts-20060613 =>
                   /usr/lib/php/extensions/no-debug-non-zts-20060613
    If it's not, change the extension_dir in php.ini or move mongo.so.

  • To load the extension on PHP startup, add a line:

    extension=mongo.so

Installing on *NIX

Run:

$ sudo pecl install mongo

Add the following line to your php.ini file:

extension=mongo.so

If pecl runs out of memory while installing, make sure memory_limit in php.ini is set to at least 128MB.

Installing on Windows

Precompiled binaries for each release are available from » PECL for a variety of combinations of versions, thread safety, and VC libraries. Unzip the archive and put php_mongo.dll in your PHP extension directory ("ext" by default).

Add the following line to your php.ini file:

extension=php_mongo.dll

Bilginize: Additional DLL dependencies for Windows Users

Bu eklentinin çalışabilmesi için bazı DLL dosyalarının bulunduğu yerlerin Windows sistem PATH'ında tanımlı olması gerekir. Bunun nasıl yapılacağı SSS altında "PHP dizinimi Windows'ta PATH'a nasıl eklerim" başlığı altında açıklanmıştır. Eklenti, DLL dosyaları PHP dizininden Windows system dizinine taşındığında da çalışırsa da (çünkü system dizini sistem PATH'ında zaten vardır) bu önerilmez. Bu eklentinin çalışabilmesi için bulunduğu dizine PATH üzerinden erişilebilinmesi gereken dosyanın ismi: libsasl.dll

OS X

In most cases installing from pecl is the easiest way:

$ sudo pecl install mongo

If you are using » Homebrew, the PHP tap includes formulae for the driver. For example, you might install the driver for PHP 5.6 using the following command:

$ brew install php56-mongo

If you are using » XAMPP, note that it has its own pecl binary and php.ini configuration. You should be able to install the driver with the following command:

$ sudo /Applications/XAMPP/xamppfiles/bin/pecl install mongo

Bilginize: Xcode dependency for compiling on OS X

Compiling the driver on OS X will require Xcode developer tools, which may be installed with xcode-select --install. If that command is not available, you may first need to install the » Command Line Tools package.

Gentoo

Gentoo has a package for the PHP PECL driver called dev-php/pecl-mongo, which can be installed with:

$ sudo emerge -va dev-php/pecl-mongo

If you use PECL, you may get an error that libtool is the wrong version. Compiling from source you'll need to run aclocal and autoconf.

$ phpize
$ aclocal
$ autoconf
$ ./configure
$ make
$ sudo make install

Red Hat

This includes Fedora and CentOS.

The default Apache settings on these systems do not let requests make network connections, meaning that the driver will get "Permission denied" errors when it tries to connect to the database. If you run into this, try running:

$ /usr/sbin/setsebool -P httpd_can_network_connect 1
Then restart Apache. (This issue has also occurred with SELinux.)

Third-Party Installation Instructions

A number of people have created excellent tutorials on installing the PHP driver.

  • » (Re)installing PHP on Mac OS X

    This article by Justin Hileman details the process of installing PHP and additional extensions with Homebrew on OS X. This complements the earlier instructions on this page for installing the driver with Homebrew.

  • » PHP 5.3.1 with Xdebug, MongoDB and Lithium on Ubuntu 9.10 / Apache 2.2

    This screencast by Jon Adams demonstrates how to quickly get up and running with PHP 5.3.1, Xdebug, and MongoDB on Ubuntu 9.10 with Apache.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Mongo Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
mongo.allow_empty_keys | 0 | PHP_INI_ALL |
mongo.allow_persistent | 1 | PHP_INI_ALL | Removed in 1.2.0
mongo.chunk_size | 262144 | PHP_INI_ALL |
mongo.cmd | "$" | PHP_INI_ALL |
mongo.default_host | "localhost" | PHP_INI_ALL |
mongo.default_port | 27017 | PHP_INI_ALL |
mongo.is_master_interval | 15 | PHP_INI_ALL | Added in 1.2.10, before 1.3.0 the default value was 60.
mongo.long_as_object | 0 | PHP_INI_ALL |
mongo.native_long | 1 | PHP_INI_ALL | Before 1.5.0, the default value was 0.
mongo.ping_interval | 5 | PHP_INI_ALL | Added in 1.2.10
mongo.utf8 | 1 | PHP_INI_ALL |
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

mongo.allow_empty_keys int

Added in version 1.0.11.

If empty strings ("") should be allowed as key names. By default, the driver will throw an exception if you attempt to pass the empty string as a key to the database. It is extremely easy to do this inavertently by using double quotes with $-operators, so it is recommended that you leave this setting as default. However, if you need to save keys that are empty strings, you can set this option to true and the driver will allow you to pass empty strings to the database.

mongo.allow_persistent int

If persistent connections are allowed. (Removed in 1.2.0 - all connections are now persistent).

mongo.chunk_size int

The number of bytes-per-chunk. Used in divvying up GridFS files. This number must be at least 100 less than 4 megabytes (max: 4194204) and it is recommended that it be less than that.

mongo.cmd string

A character to be used in place of $ in modifiers and comparisons.

As it is easy to forget to escape the "$", you can also choose your own special character to use instead of '$'. Choose a character that will not occur in your key names, e.g. ":":

mongo.cmd = ":"

Then, to do a comparison, for example:

<?php

$query = array( "i" => array( ":gt" => 20, ":lte" => 30 ) );

?>

You can also change it in your code using ini_set("mongo.cmd", ":"). Of course, you can also just use single quotes or backslash-escape the $.

mongo.default_host string

Default hostname when nothing is passed to the constructor.

mongo.default_port string

The default TCP port number to use when connecting to the database server if no other port is specified. The database's default is 27017.

mongo.is_master_interval int

Added in version 1.2.10.

For replicaset connections: The minimum interval with which the driver will send "isMaster" requests to the MongoDB server. If the value is lower, there will be more requests, but the driver finds faster whether the topology of the replicaset has been changed.

mongo.long_as_object int

Return a BSON_LONG as an instance of MongoInt64 (instead of a primitive type).

mongo.native_long int

The default behavior for this has been changed to TRUE in 1.5.0, so make sure to set this variable to the value you want (probably TRUE) so that the driver's behavior doesn't suddenly change when you upgrade.

On 64-bit platforms, the mongo.native_long setting allows for 64-bit integers to be stored in MongoDB. If it is not set, only 32-bits of the integer will be saved. The MongoDB data type that is used in this case is the BSON LONG, instead of the BSON INT that is used if this setting is turned off.

The setting also changes the way how BSON LONGs behave when they are read back from MongoDB. Without mongo.native_long enabled, the driver would convert every BSON LONG to a PHP double which can result in a loss of precision.

On 32-bit platforms, the mongo.native_long setting changes nothing for storing integers in MongoDB: the integer is stored as a BSON INT as before. However, when the setting is enabled and a BSON LONG is read from MongoDB a MongoCursorException is thrown alerting you that the data could not be read back without losing precision.

On 32-bit systems especially, it is recommended that you combine this with enabling mongo.long_as_object.

mongo.ping_interval int

Added in version 1.2.10.

For replicaset connections: The minimum interval with which the driver will send "ping" requests to the MongoDB server. If the value is lower, there will be more pings, but the driver finds faster whether a node is no longer reachable from the replicaset.

mongo.utf8 int

If an exception should be thrown for non-UTF8 strings. Until version 1.0.4, the PHP driver would ignore non-UTF8 strings, even though you're not supposed to insert them. As of 1.0.4, the driver throws a MongoException. To ease the transition for applications that insert non-UTF8 strings, you can turn this option off to emulate the old, non-exception-throwning behavior. This option will be eliminated and exceptions always thrown for non-UTF8 strings starting with version 1.1.0.

Kurulum
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

MONGO_STREAMS (integer)
Alias of MONGO_SUPPORTS_STREAMS
MONGO_SUPPORTS_STREAMS (integer)
1 when compiled against PHP Streams (default since 1.4.0).
MONGO_SUPPORTS_SSL (integer)
1 when OpenSSL is enabled and available.
MONGO_SUPPORTS_AUTH_MECHANISM_MONGODB_CR (integer)
1 when MongoDB-Challenge/Reponse authentication is compiled in.
MONGO_SUPPORTS_AUTH_MECHANISM_MONGODB_X509 (integer)
1 when x.509 authentication is compiled in.
MONGO_SUPPORTS_AUTH_MECHANISM_GSSAPI (integer)
1 when GSSAPI authentication is compiled in.
MONGO_SUPPORTS_AUTH_MECHANISM_PLAIN (integer)
1 when PLAIN authentication is compiled in.
MONGO_STREAM_NOTIFY_TYPE_IO_INIT (integer)
MONGO_STREAM_NOTIFY_TYPE_LOG (integer)
MONGO_STREAM_NOTIFY_IO_READ (integer)
MONGO_STREAM_NOTIFY_IO_WRITE (integer)
MONGO_STREAM_NOTIFY_IO_PROGRESS (integer)
MONGO_STREAM_NOTIFY_IO_COMPLETED (integer)
MONGO_STREAM_NOTIFY_LOG_INSERT (integer)
MONGO_STREAM_NOTIFY_LOG_QUERY (integer)
MONGO_STREAM_NOTIFY_LOG_UPDATE (integer)
MONGO_STREAM_NOTIFY_LOG_DELETE (integer)
MONGO_STREAM_NOTIFY_LOG_GETMORE (integer)
MONGO_STREAM_NOTIFY_LOG_KILLCURSOR (integer)
MONGO_STREAM_NOTIFY_LOG_BATCHINSERT (integer)
MONGO_STREAM_NOTIFY_LOG_RESPONSE_HEADER (integer)
MONGO_STREAM_NOTIFY_LOG_WRITE_REPLY (integer)
MONGO_STREAM_NOTIFY_LOG_CMD_INSERT (integer)
MONGO_STREAM_NOTIFY_LOG_CMD_UPDATE (integer)
MONGO_STREAM_NOTIFY_LOG_CMD_DELETE (integer)
MONGO_STREAM_NOTIFY_LOG_WRITE_BATCH (integer)

Çalışma Anı Yapılandırması
Manual
Mongo


Manual

İçindekiler

  • Tutorial
  • Read Preferences
  • Write Concerns
  • SQL to Mongo Mapping Chart
  • Connecting
  • Stream Context Options
  • Writes
  • Querying
  • Updates
  • Security
  • Troubleshooting
  • Running the Driver's Tests
Uyarı

This extension is deprecated. Instead, the MongoDB extension should be used.

This manual goes into some detail about how to use MongoDB, but it mostly covers using the PHP driver. For information about how to design a schema, what terms means, and setting up the database server, check out the » MongoDB documentation.

Öntanımlı Sabitler
Tutorial
Mongo


Tutorial

İçindekiler

  • Making a Connection
  • Getting a Database
  • Getting A Collection
  • Inserting a Document
  • Finding Documents using MongoCollection::findOne
  • Adding Multiple Documents
  • Counting Documents in A Collection
  • Using a Cursor to Get All of the Documents
  • Setting Criteria for a Query
  • Getting A Set of Documents With a Query
  • Creating An Index
Uyarı

This extension is deprecated. Instead, the MongoDB extension should be used.

This is the official MongoDB driver for PHP.

Here's a quick code sample that connects, inserts documents, queries for documents, iterates through query results, and disconnects from MongoDB. There are more details on each step in the tutorial below.

<?php

// connect
$m = new MongoClient();

// select a database
$db = $m->comedy;

// select a collection (analogous to a relational database's table)
$collection = $db->cartoons;

// add a record
$document = array( "title" => "Calvin and Hobbes", "author" => "Bill Watterson" );
$collection->insert($document);

// add another record, with a different "shape"
$document = array( "title" => "XKCD", "online" => true );
$collection->insert($document);

// find everything in the collection
$cursor = $collection->find();

// iterate through the results
foreach ($cursor as $document) {
    echo $document["title"] . "\n";
}

?>

Yukarıdaki örneğin çıktısı:

Calvin and Hobbes
XKCD
Manual
Making a Connection
Manual


Making a Connection

To connect to the database server, use one of the following:

<?php
$connection = new MongoClient(); // connects to localhost:27017
$connection = new MongoClient( "mongodb://example.com" ); // connect to a remote host (default port: 27017)
$connection = new MongoClient( "mongodb://example.com:65432" ); // connect to a remote host at a given port
?>

You do not have to explicitly disconnect from the database. The driver uses persistent connections and will re-use already established connections.

See Also

The chapter on connecting covers different types of connections.

The API documentation on the MongoClient class and MongoClient::__construct() give a comprehensive look at all possible options with a number of examples.

Tutorial
Getting a Database
Tutorial


Getting a Database

To select a database, use:

<?php
$connection = new MongoClient();
$db = $connection->dbname;
?>

The database does not need to be created in advance, you can create new databases by selecting them.

Be careful of typos! You can inadvertently create a new database, which can cause confusing errors (here name is misspelled as anme in the second selection:

<?php
$connection = new MongoClient();

$db = $connection->mybiglongdbname;
// do some stuff

$db = $connection->mybiglongdbanme;
// now connected to a different database!
?>

See Also

The API documentation on the MongoDB class contains more information about database objects.

Making a Connection
Getting A Collection
Tutorial


Getting A Collection

Getting a collection has the same syntax as getting a database:

<?php
$connection = new MongoClient();
$db = $connection->baz;

// select a collection:
$collection = $db->foobar;

// or, directly selecting a database and collection:
$collection = $connection->baz->foobar;
?>

A collection is analogous to a table (if you are familiar with relational databases).

See Also

The API documentation on the MongoCollection class contains more information about collection objects.

Getting a Database
Inserting a Document
Tutorial


Inserting a Document

Associative arrays are the basic object that can be saved to a collection in the database. A somewhat random "document" might be:

<?php
$doc = array(
    "name" => "MongoDB",
    "type" => "database",
    "count" => 1,
    "info" => (object)array( "x" => 203, "y" => 102),
    "versions" => array("0.9.7", "0.9.8", "0.9.9")
);
?>

Note that you can have nested arrays and objects. The driver will always store an associative array as an object in the database. A numerically indexed array is stored as an array in case the keys start at 0 and are not interrupted, and as an object if the array keys don't start at 0 or have gaps (ie: 0, 1, 4, 5).

To insert this document, use MongoCollection::insert():

<?php
$connection = new MongoClient();
$collection = $connection->database->collectionName;

$collection->insert( $doc );
?>

See Also

The API documentation on MongoCollection::insert() contains more information about inserting data.

Getting A Collection
Finding Documents using MongoCollection::findOne
Tutorial


Finding Documents using MongoCollection::findOne

Inserting a Document
Adding Multiple Documents
Tutorial
PHP Manual

Finding Documents using MongoCollection::findOne()

To show that the document we inserted in the previous step is stored in the database, we can do a simple MongoCollection::findOne() operation to get a single document from the collection. This method is useful when there is only one document matching the query or you are only interested in one result.

<?php
$connection = new MongoClient();
$collection = $connection->database->collectionName;

$document = $collection->findOne();
var_dump( $document );
?>

Yukarıdaki örneğin çıktısı:

array(6) {
  ["_id"]=>
  object(MongoId)#8 (1) {
    ["$id"]=>
    string(24) "4e2995576803fab768000000"
  }
  ["name"]=>
  string(7) "MongoDB"
  ["type"]=>
  string(8) "database"
  ["count"]=>
  int(1)
  ["info"]=>
  array(2) {
    ["x"]=>
    int(203)
    ["y"]=>
    int(102)
  }
  ["versions"]=>
  array(3) {
    [0]=>
    string(5) "0.9.7"
    [1]=>
    string(5) "0.9.8"
    [2]=>
    string(5) "0.9.9"
  }
}

Note that there is an _id field that has been added automatically to your document. _id is the "primary key" field. If your document does not specify one, the driver will add one automatically.

If you specify your own _id field, it must be unique to the collection. See the example here:

<?php
$connection = new MongoClient();
$db = $connection->database;

$db->foo->insert(array("_id" => 1));
// this will throw an exception
$db->foo->insert(array("_id" => 1));

// this is fine, as it is a different collection
$db->bar->insert(array("_id" => 1));
?>

By default the driver will ensure the server has acknowledged the write before returning. You can optionally turn this behaviour off by passing array("w" => 0) as the second argument. This means that the driver should not wait for the database to acknowledge the write and would not throw the duplicate _id exception.

See Also

MongoCollection::findOne() for more information about finding data.

MongoId goes into more detail on unique ids.

The writes section covers writes in more depth, and the Write Concerns chapter goes into details of the various Write Concern options.

Inserting a Document
Adding Multiple Documents
Tutorial


Adding Multiple Documents

In order to do more interesting things with queries, let's add multiple simple documents to the collection. These documents will just be of the form array( "i" => value ); and we can do this fairly efficiently in a loop:

<?php
$connection = new MongoClient();
$collection = $connection->database->collectionName;

for ( $i = 0; $i < 100; $i++ )
{
    $collection->insert( array( 'i' => $i, "field{$i}" => $i * 2 ) );
}
?>

Notice that we can insert arrays with different keys into the same collection. This aspect is what we mean when we say that MongoDB is "schema-free". In the example above each document has an i field, but also a field name in the form of field + $i.

Finding Documents using MongoCollection::findOne
Counting Documents in A Collection
Tutorial


Counting Documents in A Collection

Now that we've inserted 101 documents (the 100 we did in the loop, plus the first one), we can check to see if we have them all using the MongoCollection::count() method.

<?php
$connection = new MongoClient();
$collection = $connection->database->collectionName;

echo $collection->count();
?>
and it should print 101.

Adding Multiple Documents
Using a Cursor to Get All of the Documents
Tutorial


Using a Cursor to Get All of the Documents

In order to get all the documents in the collection, we will use MongoCollection::find(). The find() method returns a MongoCursor object which allows us to iterate over the set of documents that matched our query. So to query all of the documents and print them out:

<?php
$connection = new MongoClient();
$collection = $connection->database->collectionName;

$cursor = $collection->find();
foreach ( $cursor as $id => $value )
{
    echo "$id: ";
    var_dump( $value );
}
?>
and that should print all 101 documents in the collection. $id is the _id field of a document (cast to a string) and $value is the document itself.

See Also

The API documentation on MongoCollection::find() contains more information about finding data.

Counting Documents in A Collection
Setting Criteria for a Query
Tutorial


Setting Criteria for a Query

We can create a query to pass to the MongoCollection::find() method to get a subset of the documents in our collection. For example, if we wanted to find the document for which the value of the "i" field is 71, we would do the following:

<?php
$connection = new MongoClient();
$collection = $connection->database->collectionName;

$query = array( 'i' => 71 );
$cursor = $collection->find( $query );

while ( $cursor->hasNext() )
{
    var_dump( $cursor->getNext() );
}
?>

Yukarıdaki örneğin çıktısı:

array(2) {
  ["_id"]=>
  object(MongoId)#6 (0) {
  }
  ["i"]=>
  int(71)
  ["_ns"]=>
  "testCollection"
}
Using a Cursor to Get All of the Documents
Getting A Set of Documents With a Query
Tutorial


Getting A Set of Documents With a Query

We can use the query to get a set of documents from our collection. For example, if we wanted to get all documents where "i" > 50, we could write:

<?php
$connection = new MongoClient();
$collection = $connection->database->collectionName;

$query = array( "i" => array( '$gt' => 50 ) ); //note the single quotes around '$gt'
$cursor = $collection->find( $query );

while ( $cursor->hasNext() )
{
    var_dump( $cursor->getNext() );
}
?>

which should print the documents where "i" > 50. We could also get a range, say 20 < i <= 30:

<?php
$connection = new MongoClient();
$collection = $connection->database->collectionName;

$query = array( 'i' => array( '$gt' => 20, "\$lte" => 30 ) );
$cursor = $collection->find( $query );

while ( $cursor->hasNext() )
{
    var_dump( $cursor->getNext() );
}
?>

Remember to always escape the $-symbol or use single quotes. Otherwise PHP will interpret it to be the variable $gt.

Setting Criteria for a Query
Creating An Index
Tutorial


Creating An Index

MongoDB supports indexes, and they are very easy to add on a collection. To create an index, you specify the field name and direction: ascending (1) or descending (-1). The following creates an ascending index on the "i" field:

<?php
$connection = new MongoClient();
$collection = $connection->database->collectionName;

$collection->ensureIndex( array( "i" => 1 ) );  // create index on "i"
$collection->ensureIndex( array( "i" => -1, "j" => 1 ) );  // index on "i" descending, "j" ascending
?>

Indexing is critical for good read performance as your data grows. If you are not familiar with indexing, check out the MongoCollection::ensureIndex() documentation and the core » MongoDB indexing documentation.

Getting A Set of Documents With a Query
Read Preferences
Tutorial


Read Preferences

MongoDB 2.2 and version 1.3.0 of the driver add support for » read preferences, which allow control over how queries are directed to mongod instances in a replica set environment. Read preferences may be specified on either a per-connection, per-database, or per-collection basis. Preferences defined at a higher level will be inherited by default (e.g. MongoCollection will inherit read preferences defined on the corresponding MongoDB instance).

Read preferences are specified with a combination of modes and tag sets. Modes determine how mongod instances are prioritized, while » tag sets specify criteria for eligible mongod instances. Mongod instances are only eligible if they are within a 15ms difference in ping time from the nearest mongod instance.

Read Preference Modes

Uyarı

All read preference modes except MongoClient::RP_PRIMARY may return stale data as secondaries replicate operations from the primary with some delay. Ensure that your application can tolerate stale data if you choose to use a mode other than MongoClient::RP_PRIMARY.

  • MongoClient::RP_PRIMARY

    All read operations use only the current replica set primary. This is the default. If the primary is unavailable, read operations will produce an exception.

    This mode is incompatible with use of tag sets. Specifying a tag set with MongoClient::RP_PRIMARY will result in an exception.

  • MongoClient::RP_PRIMARY_PREFERRED

    In most situations, operations read from the primary member of the set. However, if the primary is unavailable, as is the case during failover situations, operations read from secondary members.

    When the read preference includes a tag set, the client reads first from the primary, if available, and then from secondaries that match the specified tags. If no secondaries have matching tags, the read operation will produce an exception.

    Uyarı

    Version 2.2 of mongos added full support for read preferences. When connecting to older mongos instances, MongoClient::RP_PRIMARY_PREFERRED will send queries to secondaries.

  • MongoClient::RP_SECONDARY

    Operations read only from the secondary members of the set. If no secondaries are available, read operations will produce an exception.

    Most sets have at least one secondary, but there are situations where there may be no available secondary. For example, a set with a primary, a secondary, and an arbiter may not have any secondaries if a member is in recovering state or unavailable.

    When the read preference includes a tag set, the client attempts to find secondary members that match the specified tag set and directs reads to a random secondary from among the nearest group. If no secondaries have matching tags, the read operation will produce an exception.

  • MongoClient::RP_SECONDARY_PREFERRED

    In most situations, operations read from secondary members, but in situations where the set consists of a single primary with no other members, the read operation will use the set's primary.

    When the read preference includes a tag set, the client attempts to find a secondary member that matches the specified tag set and directs reads to a random secondary from among the nearest group. If no secondaries have matching tags, the read operation will produce an exception.

  • MongoClient::RP_NEAREST

    The driver reads from a random member of the set that has a ping time that is less than 15ms slower than the member with the lowest ping time. Reads in the MongoClient::RP_NEAREST mode do not consider the member's type and may read from both primaries and secondaries.

    Set this mode to minimize the effect of network latency on read operations without preference for current or stale data.

    If you specify a tag set, the client attempts to find a member that matches the specified tag set and directs reads to a random node from among the nearest group.

    Bilginize:

    All operations read from the nearest member of the replica set that matches the specified read preference mode. The MongoClient::RP_NEAREST mode prefers low latency reads over a member's primary or secondary status.

Tag Sets

» Tag sets allow you to specify criteria so that your application can target read operations to specific members, based on custom parameters. Tag sets make it possible to ensure that read operations target members in a particular data center or target mongod instances designated for a particular class of operations, such as reporting or analytics.

You can specify tag sets with the following read preference modes:

  • MongoClient::RP_PRIMARY_PREFERRED

  • MongoClient::RP_SECONDARY

  • MongoClient::RP_SECONDARY_PREFERRED

  • MongoClient::RP_NEAREST

You cannot specify tag sets with the MongoClient::RP_PRIMARY read preference mode. Tags apply only when selecting a secondary member of a set, except for the when in the nearest mode.

Specifying Read Preferences

Read preferences may be specified in either the connection URI provided to MongoClient::__construct(), which uses a query string syntax, or via setter methods on the core classes, which use an array syntax for tag sets.

When specifying read preference modes in a query string, the tag sets for the readPreferenceTags value should be a comma-delimited sequence of colon-delimited key/value pairs.

Bilginize:

Each tag set defined in the query string will use the readPreferenceTags name. Unlike how PHP might handle URL query strings, successive values for readPreferenceTags will not overwrite each other. The driver will collect tag sets in the order they appear in the query string.

Uyarı

If the driver cannot find a matching tag set the read will fail! It is your responsibility of providing suitable fallback, such as an empty readPreferenceTags value to fallback to "no tag set preference".

Örnek 1 Connection URI read preferences with query string syntax

<?php
// Prefer the nearest server with no tag preference
$uri  = 'mongodb://rs1.example.com,rs2.example.com/';
$uri .= '?readPreference=nearest';
$m = new MongoClient($uri, array('replicaSet' => 'rs'));

// Pick the nearest server in the "east" data center
$uri  = 'mongodb://rs1.example.com,rs2.example.com/';
$uri .= '?readPreference=nearest';
$uri .= '&readPreferenceTags=dc:east';
$m = new MongoClient($uri, array('replicaSet' => 'rs'));

// Prefer the nearest server in the "east" data center also used for reporting,
// but fall back to a server in the "west" data center
$uri  = 'mongodb://rs1.example.com,rs2.example.com/';
$uri .= '?readPreference=nearest';
$uri .= '&readPreferenceTags=dc:east,use:reporting';
$uri .= '&readPreferenceTags=dc:west';
$m = new MongoClient($uri, array('replicaSet' => 'rs'));

// Prefer the nearest server in the "east" data center, then a server in the
// "west" data center, and finally fall back to no tag set preference
$uri  = 'mongodb://rs1.example.com,rs2.example.com/';
$uri .= '?readPreference=nearest';
$uri .= '&readPreferenceTags=dc:east';
$uri .= '&readPreferenceTags=dc:west';
$uri .= '&readPreferenceTags=';
$m = new MongoClient($uri, array('replicaSet' => 'rs'));
?>

Örnek 2 Setting read preferences with array syntax for tag sets

<?php

$m = new MongoClient('mongodb://rs1.example.com,rs2.example.com', array(
    'replicaSet' => 'rs',
));

// Prefer the nearest server with no tag preference
$m->setReadPreference(MongoClient::RP_NEAREST, array());

// Pick the nearest server in the "east" data center
$m->setReadPreference(MongoClient::RP_NEAREST, array(
    array('dc' => 'east'),
));

// Prefer the nearest server in the "east" data center also used for reporting,
// but fall back to a server in the "west" data center
$m->setReadPreference(MongoClient::RP_NEAREST, array(
    array('dc' => 'east', 'use' => 'reporting'),
    array('dc' => 'west'),
));

// Prefer the nearest server in the "east" data center, then a server in the
// "west" data center, and finally fall back to no tag set preference
$m->setReadPreference(MongoClient::RP_NEAREST, array(
    array('dc' => 'east'),
    array('dc' => 'west'),
    array(),
));
?>

Creating An Index
Write Concerns
Manual


Write Concerns

MongoDB provides several different ways of selecting how durable a write to the database should be. These ways are called Write Concerns and span everything from completely ignoring all errors, to specifically targetting which servers are required to confirm the write before returning the operation.

When a write (such as with MongoCollection::insert(), MongoCollection::update(), and MongoCollection::remove()) is given a Write Concern option ("w") the driver will send the query to MongoDB and piggy back a getLastError command (GLE) with the Write Concern option at the same time. The server only returns when the Write Concern condition is verified to be fullfilled, or the query times out (controlled with the "wtimeout" option, 10000 milliseconds is the default).

Uyarı

Even though a getLastError command times out the data will most likely have been written to the primary server and will be replicated to all the secondaries once they have cought up.

The typical reasons for a timeout to happen is if you specify a Write Concern which requires confirmation from more servers then you currently have available.

When using acknowledged writes and the replica set has failed over, the driver will automatically disconnect from the primary, throw an exception, and attempt to find a new primary on the next operation (your application must decide whether or not to retry the operation on the new primary).

When using unacknowledged writes (w=0) and the replica set has failed over, there will be no way for the driver to know about the change so it will continue and silently fail to write.

The default Write Concern for the MongoClient is 1: acknowledge write operations.

Available Write Concerns
Write Concern | Meaning | Description
w=0 | Unacknowledged | A write will not be followed up with a GLE call, and therefore not checked ("fire and forget")
w=1 | Acknowledged | The write will be acknowledged by the server (the primary on replica set configuration)
w=N | Replica Set Acknowledged | The write will be acknowledged by the primary server, and replicated to N-1 secondaries.
w=majority | Majority Acknowledged | The write will be acknowledged by the majority of the replica set (including the primary). This is a special reserved string.
w=<tag set> | Replica Set Tag Set Acknowledged | The write will be acknowledged by members of the entire tag set
j=true | Journaled | The write will be acknowledged by primary and the journal flushed to disk

Using WriteConcerns

Each of the methods that causes writes (MongoCollection::insert(), MongoCollection::update(), MongoCollection::remove(), and MongoCollection::batchInsert()) allow an optional argument to send a set of options to the MongoDB server. With this option array you can set the WriteConcern as the following example illustrates:

Örnek 1 Passing a WriteConcern to a write operation

<?php
// Setting w=0 for insert:
$collection->insert($someDoc, array("w" => 0));

// Setting w=majority for update:
$collection->update($someDoc, $someUpdates, array("w" => "majority"));

// Setting w=5 and j=true for remove:
$collection->update($someDoc, array("w" => 5, "j" => true));

// Setting w="AllDCs" for batchInsert:
$collection->update(array($someDoc1, $someDoc2), array("w" => "AllDCs"));
?>

Besides setting WriteConcerns per operation as an option argument, it is also possible to set a default WriteConcern in different ways.

The first way is through the connection string. The connection string accepts the journal, w, and wTimeoutMS options:

Örnek 2 Connection string WriteConcerns

<?php
$m = new MongoClient("mongodb://localhost/?journal=true&w=majority&wTimeoutMS=20000");
?>

Since driver version 1.5 it is also possible to call MongoDB::setWriteConcern() and MongoCollection::setWriteConcern() to set a default WriteConcern for all operations created from that specific MongoDB or MongoCollection object:

Örnek 3 MongoDB::setWriteConcern and MongoCollection::setWriteConcern

<?php
$m = new MongoClient("mongodb://localhost/");
$d = $m->demoDb;
$c = $d->demoCollection;

// Set w=3 on the database object with a timeout of 25000ms
$d->setWriteConcern(3, 25000);

// Set w=majority on the collection object without changing the timeout
$c->setWriteConcern("majority");
?>

Unacknowledged Writes

By not requiring the server to acknowledge writes the writes can be performed extremely quickly, but you don't know whether or not they actually succeeded. Writes can fail for a number of reasons: if there are network problems, if a database server goes down, or if the write was simply invalid (e.g., writing to a system collection; or duplicate key errors).

While developing, you should always use acknowledged writes (to protect against inadvertent mistakes, such as syntax errors, invalid operators, duplicate key errors and so on). In production, unacknowledged writes can be used for "unimportant" data. Unimportant data varies on application, but it's generally automatically (instead of user generated) data, such as click tracking or GPS locations, where you can get thousands of records per second.

It is strongly recommended that you do an acknowledged write at the end of series of unacknowledged writes. Doing so will not incur in a too large performance penalty, but still allow you to catch any errors that may have occurred.

Örnek 4 Unacknowledged WriteConcern, followed with Acknowledged Write

<?php
$collection->insert($someDoc, array("w" => 0));
$collection->update($criteria, $newObj, array("w" => 0));
$collection->insert($somethingElse, array("w" => 0));
try {
    $collection->remove($something, array("w" => 1));
} catch(MongoCursorException $e) {
    /* Handle the exception.. */
    /* Here we should issue find() queries on the IDs generated for
    $somethingElse and $someDoc to verify they got written to the database and
    attempt to figureout where in the chain something happened. */
}
?>

If the last write throws an exception, you know that there's a problem with your database.

Acknowledged Writes

These type of write operations will make sure that the database has accepted the write operation before returning success. If the write failed, it will throw a MongoCursorException with an explanation of the failure. The MongoClient default behaviour is to acknowledge the write (w=1).

It is possible to specify how many members of an replica set have to acknowledge the write (i.e. have it replicated) before the write is deemed acknowledged and the operation returns.

Örnek 5 Acknowledged Writes

<?php
// Force acknowledgement from the primary only
$collection->insert($doc, array("w" => 1));

// Force acknowledgement from the primary, and one other member of the
// replica set
$collection->insert($doc, array("w" => 2));

// Force acknowledgement from the primary, and six other members of the
// replica set (you probably never should do this):
$collection->insert($doc, array("w" => 7));
?>

Keep in mind to select your Write Concern carefully. If you have a replica set with 5 members, and you select Write Concern of 4 you will risk the write blocking forever when one member of the replica set goes down for maintenance or a temporary network outage happens.

Uyarı

Passing in a string value for Write Concern has a specific meaning (Replica Set Tag Set Acknowledged). Please be careful of NOT using string values for numbers (i.e. array("w" => "1")) as it will be treated as a tag set name.

Majority Acknowledged Writes

Using the special majority Write Concern option is the recommended way for writes that are required to survive the apocalypse, as it will ensure the majority of your replica set will have the write and will therefore be guaranteed to survive all usual suspect outage scenarios.

Örnek 6 Majority Acknowledged Write

<?php
$collection->insert($someDoc, array("w" => "majority"));
?>

Journaled Writes

When connecting to a replica set the default Write Concern is only to have the primary server acknowledge the write. There is however a 100ms window until the write gets journaled and flushed to disk. It is possible to force the write to be journaled before acknowledging the write by setting the j option:

Örnek 7 Acknowledged and Journaled Write

Forcing journal flush

<?php
$options = array(
    "w" => 1,
    "j" => true,
);
try {
    $collection->insert($document, $options);
} catch(MongoCursorException $e) {
    /* handle the exception */
}
?>

Ayrıca Bakınız

  • » MongoDB WriteConcern docs

Sürüm Bilgisi

Sürüm: | Açıklama
1.3.0 | MongoClient was introduced and defaults to acknowledged writes. The deprecated Mongo defaults to unacknowledged writes.
1.3.0 | The "safe" write option has been deprecated and is not available with the new MongoClient class. Use the "w" option instead.
Read Preferences
SQL to Mongo Mapping Chart
Manual


SQL to Mongo Mapping Chart

This is a PHP-specific version of the » SQL to Mongo mapping chart in the main docs.

SQL Statement | Mongo Query Language Statement
CREATE TABLE USERS (a Number, b Number) | Implicit or use MongoDB::createCollection().
INSERT INTO USERS VALUES(1,1) | $db->users->insert(array("a" => 1, "b" => 1));
SELECT a,b FROM users | $db->users->find(array(), array("a" => 1, "b" => 1));
SELECT * FROM users WHERE age=33 | $db->users->find(array("age" => 33));
SELECT a,b FROM users WHERE age=33 | $db->users->find(array("age" => 33), array("a" => 1, "b" => 1));
SELECT a,b FROM users WHERE age=33 ORDER BY name | $db->users->find(array("age" => 33), array("a" => 1, "b" => 1))->sort(array("name" => 1));
SELECT * FROM users WHERE age>33 | $db->users->find(array("age" => array('$gt' => 33)));
SELECT * FROM users WHERE age<33 | $db->users->find(array("age" => array('$lt' => 33)));
SELECT * FROM users WHERE name LIKE "%Joe%" | $db->users->find(array("name" => new MongoRegex("/Joe/")));
SELECT * FROM users WHERE name LIKE "Joe%" | $db->users->find(array("name" => new MongoRegex("/^Joe/")));
SELECT * FROM users WHERE age>33 AND age<=40 | $db->users->find(array("age" => array('$gt' => 33, '$lte' => 40)));
SELECT * FROM users ORDER BY name DESC | $db->users->find()->sort(array("name" => -1));
CREATE INDEX myindexname ON users(name) | $db->users->ensureIndex(array("name" => 1));
CREATE INDEX myindexname ON users(name,ts DESC) | $db->users->ensureIndex(array("name" => 1, "ts" => -1));
SELECT * FROM users WHERE a=1 and b='q' | $db->users->find(array("a" => 1, "b" => "q"));
SELECT * FROM users LIMIT 20, 10 | $db->users->find()->limit(10)->skip(20);
SELECT * FROM users WHERE a=1 or b=2 | $db->users->find(array('$or' => array(array("a" => 1), array("b" => 2))));
SELECT * FROM users LIMIT 1 | $db->users->find()->limit(1);
EXPLAIN SELECT * FROM users WHERE z=3 | $db->users->find(array("z" => 3))->explain()
SELECT DISTINCT last_name FROM users | $db->command(array("distinct" => "users", "key" => "last_name"));
SELECT COUNT(*y) FROM users | $db->users->count();
SELECT COUNT(*y) FROM users where AGE > 30 | $db->users->find(array("age" => array('$gt' => 30)))->count();
SELECT COUNT(AGE) from users | $db->users->find(array("age" => array('$exists' => true)))->count();
UPDATE users SET a=1 WHERE b='q' | $db->users->update(array("b" => "q"), array('$set' => array("a" => 1)));
UPDATE users SET a=a+2 WHERE b='q' | $db->users->update(array("b" => "q"), array('$inc' => array("a" => 2)));
DELETE FROM users WHERE z="abc" | $db->users->remove(array("z" => "abc"));

Write Concerns
Connecting
Manual


Connecting

İçindekiler

  • Connecting over SSL
  • Authentication
  • Replica Sets
  • Sharding
  • Domain Socket Support
  • Persistent Connections (version 1.3.0+)
  • Connection Pooling (version 1.2.0-1.2.12 *only*)
  • Manually Persistent Connections (version up to 1.1.4 *only*)

Connecting to MongoDB can be as easy as new MongoClient, but there are many additional options and configurations. The documentation for MongoClient::__construct() covers all of the API options, but this page gives some more details and advice for practical use cases.

SQL to Mongo Mapping Chart
Connecting over SSL
Manual


Connecting over SSL

The driver supports connecting to » MongoDB over SSL and can optionally use SSL Stream Context options to provide more details, such as verifying certificates against specific certificate chain, or authenticate to » MongoDB using X509 certificates.

Örnek 1 Connect to MongoDB Instance with SSL Encryption

<?php
$mc = new MongoClient("mongodb://server1", array("ssl" => true));
?>

Örnek 2 Connect to MongoDB Instance with SSL Encryption, verifying it is who we think it is

<?php
$SSL_DIR = "/vagrant/certs";
$SSL_FILE = "CA_Root_Certificate.pem";

$ctx = stream_context_create(array(
    "ssl" => array(
        /* Certificate Authority the remote server certificate must be signed by */
        "cafile"            => $SSL_DIR . "/" . $SSL_FILE,

        /* Disable self signed certificates */
        "allow_self_signed" => false,

        /* Verify the peer certificate against our provided Certificate Authority root certificate */
        "verify_peer"       => true, /* Default to false pre PHP 5.6 */

        /* Verify the peer name (e.g. hostname validation) */
        /* Will use the hostname used to connec to the node */
        "verify_peer_name"  => true,

        /* Verify the server certificate has not expired */
        "verify_expiry"     => true, /* Only available in the MongoDB PHP Driver */
    ),
);

$mc = new MongoClient(
    "mongodb://server1",
    array("ssl" => true),
    array("context" => $ctx)
);
?>

Bilginize:

The "verify_peer_name" is new in PHP 5.6.0. The MongoDB driver as of 1.6.5 however has backported this feature into the driver itself, so it works with PHP 5.3 and 5.4 too

Örnek 3 Connect to MongoDB Instance that Requires Client Certificates

<?php
$SSL_DIR  = "/vagrant/certs";
$SSL_FILE = "CA_Root_Certificate.pem";

$MYCERT   = "/vagrant/certs/ca-signed-client.pem";

$ctx = stream_context_create(array(
    "ssl" => array(
        "local_cert"        => $MYCERT,
        /* If the certificate we are providing was passphrase encoded, we need to set it here */
        "passphrase"        => "My Passphrase for the local_cert",

        /* Optionally verify the server is who he says he is */
        "cafile"            => $SSL_DIR . "/" . $SSL_FILE,
        "allow_self_signed" => false,
        "verify_peer"       => true,
        "verify_peer_name"  => true,
        "verify_expiry"     => true,
    ),
));

$mc = new MongoClient(
    "mongodb://server1/?ssl=true",
    array(),
    array("context" => $ctx)
);
?>

Örnek 4 Authenticating with X.509 certificates

The username is the certificate subject from the X509, which can be extracted like this:

openssl x509 -in /vagrant/certs/ca-signed-client.pem -inform PEM -subject -nameopt RFC2253
<?php
$ctx = stream_context_create( array(
    "ssl" => array(
        "local_cert" => "/vagrant/certs/ca-signed-client.pem",
    )
) );

$mc = new MongoClient(
    'mongodb://username@server1/?authSource=$external&authMechanism=MONGODB-X509&ssl=true',
    array(),
    array("context" => $ctx)
);
?>

Where username is the certificate subject.

Sürüm Bilgisi

Sürüm: | Açıklama
1.5.0 | Added support for X509 authentication.
1.4.0 | Added support for connecting to SSL enabled MongoDB.
Connecting
Authentication
Connecting


Authentication

If MongoDB is started with the --auth or --keyFile options, you must authenticate before you can do any operations with the driver. You may authenticate a connection by specifying the username and password in either the connection URI or the "username" and "password" options for MongoClient::__construct().

Örnek 1 Authenticating against the "admin" database

<?php
// Specifying the username and password in the connection URI (preferred)
$m = new MongoClient("mongodb://${username}:${password}@localhost");

// Specifying the username and password via the options array (alternative)
$m = new MongoClient("mongodb://localhost", array("username" => $username, "password" => $password));
?>

By default, the driver will authenticate against the admin database. You may authenticate against a different database by specifying it in either the connection URI or the "db" option for MongoClient::__construct().

Örnek 2 Authenticating against normal databases

<?php
// Specifying the authentication database in the connection URI (preferred)
$m = new MongoClient("mongodb://${username}:${password}@localhost/myDatabase");

// Specifying the authentication database via the options array (alternative)
$m = new MongoClient("mongodb://${username}:${password}@localhost", array("db" => "myDatabase"));
?>

If your connection is dropped, the driver will automatically attempt to reconnect and reauthenticate you.

Connecting over SSL
Replica Sets
Connecting


Replica Sets

To connect to a replica set, specify one or more members of the set and use the "replicaSet" option. Multiple servers may be delimited by a comma.

Örnek 1 ReplicaSet seed list

<?php
// Using multiple servers as the seed list (prefered)
$m = new MongoClient("mongodb://rs1.example.com:27017,rs2.example.com:27017/?replicaSet=myReplSetName");

// Using one server as the seed list
$m = new MongoClient("mongodb://rs1.example.com:27017", array("replicaSet" => "myReplSetName"));

// Using multiple servers as the seed list
$m = new MongoClient("mongodb://rs1.example.com:27017,rs2.example.com:27017", array("replicaSet" => "myReplSetName"));
?>

The PHP driver will query the database server(s) listed to determine the primary. So long as it can connect to at least one host listed and find a primary, the connection will succeed. If it cannot make a connection to any servers listed or cannot find a primary, a MongoConnectionException will be thrown.

İpucu

You should always provide a seed list with more than one member of the ReplicaSet. For highest availability you should seed with at least one server from each of your datacenters.

Uyarı

The host names that you specify in the seed list must match the host names in the replica set configuration. This is because the driver only uses the host names in the replica set configuration to create the hash for its persistent connections.

For example, if an IP address is used in the seed list and the replica set is configured with host names, the driver will discard any seed list connection(s) that differ from the canonical host names reported by the replica set. Effectively, these non-canonical seed list connections will be recreated on each request, greatly reducing the benefit of using persistent connections.

Uyarı

The driver does not support connecting to different replica sets with the same name. This extends beyond one script so make sure to have separate names for each of your replica sets. That also means that you can not do this:

Örnek 2 Wrong replica set name duplication

<?php
$m = new MongoClient("mongodb://devserver1,devserver2,devserver3/?replicaSet=repset");
$m = new MongoClient("mongodb://prodserver1,prodserver2,prodserver3/?replicaSet=repset");
?>

Instead, you need to have two different names for your replica sets:

Örnek 3 Correct use of two replica set names

<?php
$m = new MongoClient("mongodb://devserver1,devserver2,devserver3/?replicaSet=devset");
$m = new MongoClient("mongodb://prodserver1,prodserver2,prodserver3/?replicaSet=prodset");
?>

If the primary becomes unavailable, an election will take place and a secondary will be promoted to the role of primary (unless a majority vote cannot be established). During this time (» 20-60 seconds), the connection will not be able to perform any write operations and attempts to do so will result in an exception. Connections to secondaries will still be able to perform reads.

Bilginize:

The default Read Preference is to only read from the primary. During the election process there is no primary, and all read will therefore fail.

It is recommended to use MongoClient::RP_PRIMARY_PREFERRED Read Preference for applications that require high availability for reads, as reads will only be executed on the secondaries when there simply isn't a primary available.

Once a primary is elected, attempting to perform a read or write will allow the driver to detect the new primary. The driver will make this its primary database connection and continue operating normally.

The health and state of a secondary is checked every 5 seconds (configurable with mongo.ping_interval) or when the next operation occurs after 5 seconds. It will also recheck the configuration when the driver has a problem reaching a server.

Replica set failovers are checked every 60 seconds (configurable with mongo.is_master_interval), and whenever a write operation fails when using acknowledged writes.

Dikkat

Secondaries may be behind the primary in operations, so your application must be able to handle out-of-date data when using Read Preferences other then MongoClient::RP_PRIMARY.

For more information on replica sets, see the » core documentation.

Ayrıca Bakınız

  • Read Preferences
  • Write Concerns

Sürüm Bilgisi

Sürüm: | Açıklama
1.0.9 | Added support for connecting to ReplicaSet and automatic failover.
Authentication
Sharding
Connecting


Sharding

To connect to a shard cluster, specify the address of one or more mongos instances in the connection string. Multiple servers may be delimited by a comma.

<?php
// Using one server as the seed list
$m = new MongoClient("mongodb://mongos1.example.com:27017");

// Using multiple servers as the seed list
$m = new MongoClient("mongodb://mongos1.example.com:27017,mongos2.example.com:27017");
?>

Regardless of whether each shard is a stand-alone mongod server or a full replica set, the driver's connection process is the same. All database communication will be routed through mongos.

For more information on sharding with MongoDB, see the » sharding documentation.

Replica Sets
Domain Socket Support
Connecting


Domain Socket Support

MongoDB has built-in support for connecting via Unix Domain Sockets and will open the socket on startup. By default, the socket is located in /tmp/mongodb-<port>.sock.

To connect to the socket file, specify the path in your MongoDB connection string:

<?php
$m = new MongoClient("mongodb:///tmp/mongo-27017.sock");
?>

If you would like to authenticate against a database (as described above) with a socket file, you must specify a port of 0 so that the connection string parser can detect the end of the socket path. Alternatively, you can use the constructor options.

<?php
$m = new MongoClient("mongodb://username:password@/tmp/mongo-27017.sock:0/foo");
?>

Sürüm Bilgisi

Sürüm: | Açıklama
1.0.9 | Added support for Unix Domain Sockets.
Sharding
Persistent Connections (version 1.3.0+)
Connecting


Persistent Connections (version 1.3.0+)

All versions of the driver since 1.3.0 utilize persistent connections to minimize the number of connections made to each database server. These connections are saved by the PHP worker process and may be reused between multiple requests.

Before connecting to a database server, the driver will create a hash for the connection based on its host, port, replica set name (if any), any authentication credentials (e.g. username, password, database), and the process ID. If a connection already exists for that hash, it will be used in lieu of creating a new connection associated with that hash. MongoClient::getConnections() may be used to retrieve info about each persistent connection. Consider the following program:

<?php

$m1 = new MongoClient('mongodb://localhost');
$m2 = new MongoClient('mongodb://localhost');
$m3 = new MongoClient('mongodb://user:pw@localhost');
$m4 = new MongoClient('mongodb://127.0.0.1');
$m5 = new MongoClient('mongodb://rs1.local:30017,rs2.local:30018/?replicaSet=rs');
$m6 = new MongoClient('mongodb://sharding.local:40017');

foreach (MongoClient::getConnections() as $conn) {
    echo $conn['hash'], "\n";
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

localhost:27017;-;X;15487
localhost:27017;-;admin/user/c56c...8bbc;15487
127.0.0.1:27017;-;X;15487
rs1.local:30017;rs;X;15487
rs2.local:30018;rs;X;15487
sharding.local:40017;-;X;15487

In this example $m1 and $m2 have the same hash and share a persistent connection. Connections for each other MongoClient instance hash to unique values and use their own sockets. Note that "localhost" and "127.0.0.1" do not share the same hash; DNS resolution is not taken into account.

Domain Socket Support
Connection Pooling (version 1.2.0-1.2.12 *only*)
Connecting


Connection Pooling (version 1.2.0-1.2.12 *only*)

Bilginize:

This section is no longer relevant as of the 1.3.0 release of the driver and only serves as a historical information on how the pooling used to work.

The latest versions of the driver have no concept of pooling anymore and will maintain only one connection per process, for each connection type (ReplicaSet/standalone/mongos), for each credentials combination.

Creating connections is one of the most heavyweight things that the driver does. It can take hundreds of milliseconds to set up a connection correctly, even on a fast network. Thus, the driver tries to minimize the number of new connections created by reusing connections from a pool.

When a user creates a new instance of MongoClient, all necessary connections will be taken from their pools (replica sets may require multiple connections, one for each member of the set). When the MongoClient instance goes out of scope, the connections will be returned to the pool. When the PHP process exits, all connections in the pools will be closed.

"Why do I have so many open connections?"

Connection pools can generate a large number of connections. This is expected and, using a little arithmetic, you can figure out how many connections will be created. There are three factors in determining the total number of connections:

  • connections_per_pool

    Each connection pool will create, by default, an unlimited number of connections. One might assume that this is a problem: if it can create an unlimited number of connections, couldn't it create thousands and the server would run out of file descriptors? In practice, this is unlikely, as unused connections are returned to the pool to be used later, so future connections will use the same connection instead of creating a new one. Unless you create thousands of connections at once without letting any go out of scope, the number of connections open should stay at a reasonable number.

    You can see how many connections you have in a pool using the MongoPool::info() function. Add up the "in use" and "in pool" fields for a given server. That is the total number of connections for that pool.

  • pools_per_process

    Each MongoDB server address you're connecting to gets its own connection pool. For example, if your local hostname is "example.net", connecting to "example.net:27017", "localhost:27017", and "/tmp/mongodb-27017.sock" will create three connection pools. You can see how many connection pools you have open using MongoPool::info().

  • processes

    Each PHP process has a separate set of pools. PHP-FPM and Apache generally create between 6 and a couple of dozen PHP worker children. Check your settings to see what the max number of PHP processes is that can be spawned.

    If you are using PHP-FPM, estimating the number of connections can be tricky because it will spawn more PHP-FPM workers under heavy load. To be on the safe side, look at the max_children parameter or add up spare_servers + start_servers (choose whichever number is higher). That will indicate how many PHP processes (i.e. sets of pools) you should plan for.

The three variables above can be multiplied together to give the max number of connections expected: connections_per_pool * pools_per_process * processes. Note that connections_per_pool can be different for different pools, so connections_per_pool should be the max.

For example, suppose we're getting 30 connections per pool, 10 pools per PHP process, and 128 PHP processes. Then we can expect 38400 connections from this machine. Thus, we should set this machine's file descriptor limit to be high enough to handle all of these connections or it may run out of file descriptors.

See MongoPool for more information on connection pooling.

Persistent Connections (version 1.3.0+)
Manually Persistent Connections (version up to 1.1.4 *only*)
Connecting


Manually Persistent Connections (version up to 1.1.4 *only*)

Bilginize:

This section is not relevant for 1.2.0+. In 1.2.0+, connections are always persistent and managed automatically by the driver. If you are using a 1.2.x release (but not 1.3.x or later), see MongoPool for more information on pooling.

Creating new connection to the database is very slow. To minimize the number of connections that you need to make, you can use persistent connections. A persistent connection is saved by PHP, so you can use the same connection for multiple requests.

For example, this simple program connects to the database 1000 times:

<?php

for ($i=0; $i<1000; $i++) {
  $m = new MongoClient();
}

?>

It takes approximately 18 seconds to execute. If we change it to use a persistent connection:

<?php

for ($i=0; $i<1000; $i++) {
  $m = new MongoClient("localhost:27017", array("persist" => "x"));
}

?>

...it takes less than .02 seconds to execute, as it only makes one database connection.

Persistent connections need an identifier string (which is "x" in the above example) to uniquely identify them. For a persistent connection to be used, the hostname, port, persist string, and authentication credentials (username, password and database, if given) must match an existing persistent connection. Otherwise, a new connection will be created with this identifying information.

Persistent connections are highly recommended and should always be used in production unless there is a compelling reason not to. Most of the reasons that they are not recommended for relational databases are irrelevant to MongoDB.

Connection Pooling (version 1.2.0-1.2.12 *only*)
Stream Context Options
Connecting


Stream Context Options

The PHP MongoDB extension provides Stream Context Support using the mongodb context.

A stream context must be created with stream_context_create() and passed to the MongoClient::__construct() before the actual connection to MongoDB is made. It is not possible to apply a stream context to already created streams.

Additional context options and parameters, such as ssl and notification parameters, are also supported.

The MongoDB context options provide a rich interface to log network traffic between the driver and the MongoDB servers. This interface can be used to provide query logging, profiler, debuggers, or anything that would need to inspect the underlaying commands and protocol options.

Ayrıca Bakınız

  • SSL bağlamı seçenekleri
  • Soket bağlamı seçenekleri
  • Bağlam değiştirgeleri

İçindekiler

  • log_cmd_delete — Callback When Deleting Documents
  • log_cmd_insert — Callback When Inserting Documents
  • log_cmd_update — Callback When Updating Documents
  • log_getmore — Callback When Retrieving Next Cursor Batch
  • log_killcursor — Callback When Executing KILLCURSOR operations
  • log_reply — Callback When Reading the MongoDB reply
  • log_write_batch — Callback When Writing Batches
Manually Persistent Connections (version up to 1.1.4 *only*)
log_cmd_delete
Manual


Callback When Deleting Documents

Stream Context Options
log_cmd_insert
Stream Context Options
PHP Manual

log_cmd_delete

(PECL mongo >= 1.5.0)

log_cmd_delete — Callback When Deleting Documents

Açıklama

log_cmd_delete ( array $server , array $writeOptions , array $deleteOptions , array $protocolOptions )

A callable function, used by the log_cmd_delete context option, when deleteing a document

Bilginize:

This is not a real function, only a prototype of how the function should be.

Değiştirgeler

server

An array containing the basic information about the server that was picked.

key | value
hash | server hash, example: localhost:27017;-;X;56052
type | Node type (primary/secondary/mongos/arbiter): 2
max_bson_size | The maximum BSON Size over the wire this node accepts: 16777216
max_message_size | The maximum Message Size over the wire this node accepts: 48000000
request_id | The request identifier for this message: 42

writeOptions

key | value
ordered | boolean, if the operation (in case of batch operation) must be executed sequentually (ordered=true)
writeConcern | An array of writeConcern options (see below)
writeConcern array values
key | value
fsync | boolean, force flushing to disk before returning
j | boolean, force journal write before returning
wtimeout | integer, milliseconds, maximum time the primary is allowed to wait to verify replication
w | integer=server count, or string=replication-tag

deleteOptions

key | value
limit | integer, 1 or 0. If 0, delete all matching documents.
q | Array, the search criteria

protocolOptions

key | value
message_length | The total size (in bytes) of the encoded message being sent over the wire
request_id | The request identifier for this message: 42
namespace | The MongoDB namespace used for the protocol message dbname.collectionname

Sürüm Bilgisi

Sürüm: | Açıklama
1.5.0 | Only available when connected to MongoDB 2.6.0+
Stream Context Options
log_cmd_insert
Stream Context Options


Callback When Inserting Documents

log_cmd_delete
log_cmd_update
Stream Context Options
PHP Manual

log_cmd_insert

(PECL mongo >= 1.5.0)

log_cmd_insert — Callback When Inserting Documents

Açıklama

log_cmd_insert ( array $server , array $document , array $writeOptions , array $protocolOptions )

A callable function, used by the log_cmd_insert context option, when inserting a document

Bilginize:

This is not a real function, only a prototype of how the function should be.

Değiştirgeler

server

An array containing the basic information about the server that was picked.

key | value
hash | server hash, example: localhost:27017;-;X;56052
type | Node type (primary/secondary/mongos/arbiter): 2
max_bson_size | The maximum BSON Size over the wire this node accepts: 16777216
max_message_size | The maximum Message Size over the wire this node accepts: 48000000
request_id | The request identifier for this message: 42

document

The document that has been prepared to be inserted

writeOptions

key | value
ordered | boolean, if the operation (in case of batch operation) must be executed sequentually (ordered=true)
writeConcern | An array of writeConcern options (see below)
writeConcern array values
key | value
fsync | boolean, force flushing to disk before returning
j | boolean, force journal write before returning
wtimeout | integer, milliseconds, maximum time the primary is allowed to wait to verify replication
w | integer=server count, or string=replication-tag

protocolOptions

key | value
message_length | The total size (in bytes) of the encoded message being sent over the wire
request_id | The request identifier for this message: 42
namespace | The MongoDB namespace used for the protocol message dbname.collectionname

Sürüm Bilgisi

Sürüm: | Açıklama
1.5.0 | Only available when connected to MongoDB 2.6.0+
log_cmd_delete
log_cmd_update
Stream Context Options


Callback When Updating Documents

log_cmd_insert
log_getmore
Stream Context Options
PHP Manual

log_cmd_update

(PECL mongo >= 1.5.0)

log_cmd_update — Callback When Updating Documents

Açıklama

log_cmd_update ( array $server , array $writeOptions , array $updateOptions , array $protocolOptions )

A callable function, used by the log_cmd_update context option, when updateing a document

Bilginize:

This is not a real function, only a prototype of how the function should be.

Değiştirgeler

server

An array containing the basic information about the server that was picked.

key | value
hash | server hash, example: localhost:27017;-;X;56052
type | Node type (primary/secondary/mongos/arbiter): 2
max_bson_size | The maximum BSON Size over the wire this node accepts: 16777216
max_message_size | The maximum Message Size over the wire this node accepts: 48000000
request_id | The request identifier for this message: 42

writeOptions

key | value
ordered | boolean, if the operation (in case of batch operation) must be executed sequentually (ordered=true)
writeConcern | An array of writeConcern options (see below)
writeConcern array values
key | value
fsync | boolean, force flushing to disk before returning
j | boolean, force journal write before returning
wtimeout | integer, milliseconds, maximum time the primary is allowed to wait to verify replication
w | integer=server count, or string=replication-tag

updateOptions

key | value
multi | Boolean, true if this update is allowed to update all matched criteria
upsert | Boolean, true if the document should be created if criteria does not match
q | Array, the search criteria
u | Array, the new object/modifications

protocolOptions

key | value
message_length | The total size (in bytes) of the encoded message being sent over the wire
request_id | The request identifier for this message: 42
namespace | The MongoDB namespace used for the protocol message dbname.collectionname

Sürüm Bilgisi

Sürüm: | Açıklama
1.5.0 | Only available when connected to MongoDB 2.6.0+
log_cmd_insert
log_getmore
Stream Context Options


Callback When Retrieving Next Cursor Batch

log_cmd_update
log_killcursor
Stream Context Options
PHP Manual

log_getmore

(PECL mongo >= 1.5.0)

log_getmore — Callback When Retrieving Next Cursor Batch

Açıklama

log_getmore ( array $server , array $info )

A callable function, used by the log_getmore context option, when executing a GET_MORE operation.

Bilginize:

This is not a real function, only a prototype of how the function should be.

Değiştirgeler

server

An array containing the basic information about the server that was picked.

key | value
hash | server hash, example: localhost:27017;-;X;56052
type | Node type (primary/secondary/mongos/arbiter): 2
max_bson_size | The maximum BSON Size over the wire this node accepts: 16777216
max_message_size | The maximum Message Size over the wire this node accepts: 48000000
request_id | The request identifier for this message: 42

info

key | value
request_id | integer, the driver request identifier
cursor_id | integer, the cursor identifier being used to fetch more data
batch_size | integer, maximum number of documents being requested

log_cmd_update
log_killcursor
Stream Context Options


Callback When Executing KILLCURSOR operations

log_getmore
log_reply
Stream Context Options
PHP Manual

log_killcursor

(PECL mongo >= 1.5.0)

log_killcursor — Callback When Executing KILLCURSOR operations

Açıklama

log_killcursor ( array $server , array $info )

A callable function, used by the log_killcursor context option, when reading a killcursor from MongoDB.

Bilginize:

This is not a real function, only a prototype of how the function should be.

Değiştirgeler

server

An array containing the basic information about the server that was picked.

key | value
hash | server hash, example: localhost:27017;-;X;56052
type | Node type (primary/secondary/mongos/arbiter): 2
max_bson_size | The maximum BSON Size over the wire this node accepts: 16777216
max_message_size | The maximum Message Size over the wire this node accepts: 48000000
request_id | The request identifier for this message: 42

info

key | value
cursor_id | integer, the cursor identifier to kill

log_getmore
log_reply
Stream Context Options


Callback When Reading the MongoDB reply

log_killcursor
log_write_batch
Stream Context Options
PHP Manual

log_reply

(PECL mongo >= 1.5.0)

log_reply — Callback When Reading the MongoDB reply

Açıklama

log_reply ( array $server , array $messageHeaders , array $operationHeaders )

A callable function, used by the log_reply context option, when reading a reply from MongoDB.

Bilginize:

This is not a real function, only a prototype of how the function should be.

Değiştirgeler

server

An array containing the basic information about the server that was picked.

key | value
hash | server hash, example: localhost:27017;-;X;56052
type | Node type (primary/secondary/mongos/arbiter): 2
max_bson_size | The maximum BSON Size over the wire this node accepts: 16777216
max_message_size | The maximum Message Size over the wire this node accepts: 48000000
request_id | The request identifier for this message: 42

messageHeaders

key | value
length | integer, bytes, message reply length
request_id | integer, the server request identifier
response_id | integer, the driver request identifier this message is a response of
opcode | integer, the opcode id

operationHeaders

key | value
flags | integer, bitmask of protocol flags
cursor_id | integer, ID of the cursor created on the server (0 if none created, or its been exhausted)
start | The starting offset of this cursor
returned | integer, how many documents are returned in this trip

Ayrıca Bakınız

  • The » OP_REPLY definition in the Wire Protocol
log_killcursor
log_write_batch
Stream Context Options


Callback When Writing Batches

log_reply
Writes
Stream Context Options
PHP Manual

log_write_batch

(PECL mongo >= 1.5.0)

log_write_batch — Callback When Writing Batches

Açıklama

log_write_batch ( array $server , array $writeOptions , array $batch , array $protocolOptions )

A callable function, used by the log_write_batch context option, when executing a batch operation.

Bilginize:

This is not a real function, only a prototype of how the function should be.

Değiştirgeler

server

An array containing the basic information about the server that was picked.

key | value
hash | server hash, example: localhost:27017;-;X;56052
type | Node type (primary/secondary/mongos/arbiter): 2
max_bson_size | The maximum BSON Size over the wire this node accepts: 16777216
max_message_size | The maximum Message Size over the wire this node accepts: 48000000
request_id | The request identifier for this message: 42

writeOptions

key | value
ordered | boolean, if the operation (in case of batch operation) must be executed sequentually (ordered=true)
writeConcern | An array of writeConcern options (see below)
writeConcern array values
key | value
fsync | boolean, force flushing to disk before returning
j | boolean, force journal write before returning
wtimeout | integer, milliseconds, maximum time the primary is allowed to wait to verify replication
w | integer=server count, or string=replication-tag

batch

Array, the actual batch operation.

protocolOptions

key | value
message_length | The total size (in bytes) of the encoded message being sent over the wire
request_id | The request identifier for this message: 42
namespace | The MongoDB namespace used for the protocol message dbname.collectionname

Sürüm Bilgisi

Sürüm: | Açıklama
1.5.0 | Only available when connected to MongoDB 2.6.0+
log_reply
Writes
Stream Context Options


Writes

Updating Nested Objects

Suppose we wish to change the name of a comment's author in this document:

{
    "_id" : ObjectId("4b06c282edb87a281e09dad9"),
    "content" : "this is a blog post.",
    "comments" :
    [
        {
            "author" : "Mike",
            "comment" : "I think that blah blah blah...",
        },
        {
            "author" : "John",
            "comment" : "I disagree."
        }
    ]
}
In order to change an inner field, we use $set (so that all of the other fields are not removed!) with the index of comment to change:
<?php

$blog->update($criteria, array('$set' => array("comments.1" => array("author" => "Jim"))));

?>

The Positional Operator

The positional operator $ is useful for updating objects that are in arrays. In the example above, for instance, suppose that we did not know the index of the comment that we needed to change, merely that we needed to change "John" to "Jim". We can use $ to do so.

<?php

$blog->update(
    array('comments.author' => 'John'),
    array('$set' => array('comments.$.author' => 'Jim')));

?>
log_write_batch
Querying
Manual


Querying

Distributing queries to secondaries

All queries (reads and writes) are only sent to the primary member of a replica set by default. This is however easily configurable by using the Read Preferences which allow you to set some generic read preferences (such as allowing secondary reads of the nearest server), and also provide ways to specifically target a server in a specific country, datacenter, or even hardware, by the use of replica set tag sets.

Read preferences can be configured at every level of the driver:

  • As a query parameter or option to MongoClient::__construct()
  • Specifically by calling MongoClient::setReadPreference()
  • At the database level with MongoDB::setReadPreference()
  • At the collection level with MongoCollection::setReadPreference()
  • At the cursor level with MongoCursor::setReadPreference() or MongoCommandCursor::setReadPreference()
Each class inherits its read preference setting from the "parent" context.

Örnek 1 Inheriting read preferences from the database level down to the cursor

<?php
$db->setReadPreference(MongoClient::RP_SECONDARY_PREFERRED);
$c = $db->myCollection;

$cursor = $c->find();
?>

In this example, the the query will be executed against a secondary. The collection inherits MongoClient::RP_SECONDARY_PREFERRED from the database and the cursor inherits it from the collection.

How secondaries are chosen

Each instance of MongoClient chooses its own secondary using the available secondary with the lowest ping time. So, if we had a PHP client in Europe and one in Australia and we had one secondary in each of these data centers, we could do:

<?php
$options = array("replicaSet" => "setName", "readPreference" => MongoClient::RP_SECONDARY_PREFERRED);

// on the Australian client
$m = new MongoClient("mongodb://primary,australianhost.secondary,europeanhost.secondary", $options);
$cursor = $m->foo->bar->find();
$cursor->getNext();
echo "Reading from: ", $cursor->info()["server"], "\n";

// on the European client
$m = new MongoClient("mongodb://primary,australianhost.secondary,europeanhost.secondary", $options);
$cursor = $m->foo->bar->find();
$cursor->getNext();
echo "Reading from: ", $cursor->info()["server"], "\n";
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Reading from: australianHost
Reading from: europeanHost

Note that we have to do a query before a secondary is chosen: secondaries are chosen lazily by the driver, and for each query separately.

You can see what the driver thinks is the current status of the set members by running MongoClient::getHosts() or MongoClient::getConnections().

If no secondary is readable, the driver will send reads to the primary as we specified MongoClient::RP_SECONDARY_PREFERRED which will fallback to execute a query on a primary if no secondaries are available. A server is considered readable if its state is 2 (SECONDARY) and its health is 1. You can check this with MongoClient::getHosts() and MongoClient::getConnections().

Random notes

Writes are always sent to the primary—and by default all reads are sent to the primary too.

Querying by _id

Every object inserted is automatically assigned a unique _id field, which is often a useful field to use in queries. This works similarly to "get last insert ID" functionality, except that the _id is chosen by the client.

Suppose that we wish to find the document we just inserted. Inserting adds an _id field to the document, so we can query by that:

<?php
$person = array("name" => "joe");

$people->insert($person);

// now $joe has an _id field
$joe = $people->findOne(array("_id" => $person['_id']));
?>

Unless the user has specified otherwise, the _id field is a MongoId. The most common mistake is attempting to use a string to match a MongoId. Keep in mind that these are two different datatypes, and will not match each other in the same way that the string "array()" is not the same as an empty array. For example:

<?php
$person = array("name" => "joe");

$people->insert($person);

// convert the _id to a string
$pid = $person['_id'] . "";

// FAILS - $pid is a string, not a MongoId
$joe = $people->findOne(array("_id" => $pid));
?>

Arrays

Arrays are special in a couple ways. First, there are two types that MongoDB uses: "normal" arrays and associative arrays. Associative arrays can have any mix of key types and values. "Normal" arrays are defined as arrays with ascending numeric indexes starting at 0 and increasing by one for each element. These are, typically, just your usual PHP array.

For instance, if you want to save a list of awards in a document, you could say:

<?php

$collection->save(array("awards" => array("gold", "silver", "bronze")));

?>

Queries can reach into arrays to search for elements. Suppose that we wish to find all documents with an array element of a given value. For example, documents with a "gold" award, such as:

{ "_id" : ObjectId("4b06c282edb87a281e09dad9"), "awards" : ["gold", "silver", "bronze"]}

This can be done with a simple query, ignoring the fact that "awards" is an array:

<?php

  $cursor = $collection->find(array("awards" => "gold"));

?>

Suppose we are querying for a more complex object, if each element of the array were an object itself, such as:

{
     "_id" : ObjectId("4b06c282edb87a281e09dad9"),
     "awards" :
     [
        {
            "first place" : "gold"
        },
        {
            "second place" : "silver"
        },
        {
            "third place" :  "bronze"
        }
     ]
}

Still ignoring that this is an array, we can use dot notation to query the subobject:

<?php

$cursor = $collection->find(array("awards.first place" => "gold"));

?>

Notice that it doesn't matter that there is a space in the field name (although it may be best not to use spaces, just to make things more readable).

You can also use an array to query for a number of possible values. For instance, if we were looking for documents "gold" or "copper", we could do:

<?php

$cursor = $collection->find(array("awards" => array('$in' => array("gold", "copper"))));

?>

Sürüm Bilgisi

Sürüm: | Açıklama
1.3.0 | Introduced the Read Preferences framework to allow more fine grained control over secondary reads.
1.3.0 | Deprecated slaveOkay usage, the alternative is Read Preferences.
1.1.0 | Introduced the possiblity of routing reads to secondaries of replica set members using Mongo::setSlaveOkay()
Writes
Updates
Manual


Updates

Updates can be one of the most complicated operation available with MongoDB. They combine a query with an action, modifying documents that match the criteria. They are also extremely powerful, allowing you to change documents quickly and replace them altogether. They are done in-place (when possible) with little overhead.

Modifying vs. replacing documents

There are two types of updates you can use: modifying updates and replacing updates. Modifying updates contain $-operators and change fields in a document: they might increment counters, push new elements onto an array, or change the type of a field.

For example, a modifying update could add a new field to a document.

<?php
/** suppose documents look like:
 * {"username" : "...", "password" : "...", "email" : "..."}
 */
$coll->update(array("username" => "joe"), array('$set' => array("twitter" => "@joe4153")));

/** now the document will look like:
 * {"username" : "joe", "password" : "...", "email" : "...", "twitter" : "@joe4153"}
 */
?>

Replacing updates replace the entire matching document with a new document. They are generally not as efficient as using $-modifiers, but can be very usefully for complex operations or updates that can't be expressed in terms of $-operators.

For example, a replacing update can completely change the structure of a document.

<?php
/** suppose documents look like:
 * {"username" : "...", "password" : "...", "email" : "..."}
 */
$coll->update(array("username" => "joe"), array("userId" => 12345, "info" => array(
    "name" => "joe", "twitter" => "@joe4153", "email" => "..."), "likes" => array()));

/** now the document will look like:
 * {
 *     "userId" : 12345,
 *     "info" : {
 *         "name" : "joe",
 *         "twitter" : "@joe4153",
 *         "email" : "..."
 *     },
 *     "likes" : []
 * }
 */
?>

Updating Nested Objects

Suppose we wish to change the name of a comment's author in this document:

{
    "_id" : ObjectId("4b06c282edb87a281e09dad9"),
    "content" : "this is a blog post.",
    "comments" :
    [
        {
            "author" : "Mike",
            "comment" : "I think that blah blah blah...",
        },
        {
            "author" : "John",
            "comment" : "I disagree."
        }
    ]
}
In order to change an inner field, we use $set (so that all of the other fields are not removed!) with the index of comment to change:
<?php

$blog->update($criteria, array('$set' => array("comments.1" => array("author" => "Jim"))));

?>

The Positional Operator

The positional operator $ is useful for updating objects that are in arrays. In the example above, for instance, suppose that we did not know the index of the comment that we needed to change, merely that we needed to change "John" to "Jim". We can use $ to do so.

<?php

$blog->update(
    array("comments.author" => "John"),
    array('$set' => array('comments.$.author' => "Jim")));

?>
Querying
Security
Manual


Security

Request Injection Attacks

If you are passing $_GET (or $_POST) parameters to your queries, make sure that they are cast to strings first. Users can insert associative arrays in GET and POST requests, which could then become unwanted $-queries.

A fairly innocuous example: suppose you are looking up a user's information with the request http://www.example.com?username=bob. Your application does the query $collection->find(array("username" => $_GET['username'])).

Someone could subvert this by getting http://www.example.com?username[$ne]=foo, which PHP will magically turn into an associative array, turning your query into $collection->find(array("username" => array('$ne' => "foo"))), which will return all users not named "foo" (all of your users, probably).

This is a fairly easy attack to defend against: make sure $_GET and $_POST parameters are the type you expect before you send them to the database (cast them to strings, in this case).

Note that this type of attack can be used with any databases interation that locates a document, including updates, upserts, find-and-modifies, and removes.

Thanks to » Phil for pointing this out.

See » the main documentation for more information about SQL-injection-like issues with MongoDB.

Script Injection Attacks

If you are using JavaScript, make sure that any variables that cross the PHP- to-JavaScript boundry are passed in the scope field of MongoCode, not interpolated into the JavaScript string. This can come up when using MongoDB::execute(), $where clauses, MapReduces, group-bys, and any other time you may pass JavaScript into the database.

Bilginize:

MapReduce ignore the scope field of MongoCode, but there is a scope option on the command that can be used instead.

For example, suppose we have some JavaScript to greet a user in the database logs. We could do:

<?php

// don't do this!

$username = $_POST['username'];
$db->execute("print('Hello, $username!');");

?>

However, what if a malicious user passes in some JavaScript?

<?php

// don't do this!

// $username is set to "'); db.users.drop(); print('"
$db->execute("print('Hello, $username!');");

?>

Now MongoDB executes the JavaScript string "print('Hello, '); db.users.drop(); print('!');". This attack is easy to avoid: use scope to pass variables from PHP to JavaScript:

<?php

$scope = array("user" => $username);
$db->execute(new MongoCode("print('Hello, '+user+'!');", $scope));

?>

This adds a variable user to the JavaScript scope. Now if someone tries to send malicious code, MongoDB will harmlessly print Hello, '); db.dropDatabase(); print('!.

Using scope helps prevent malicious input from being executed by the database. However, you must make sure that your code does not turn around and execute the input anyway! For example, never use the JavaScript eval function on user input:

<?php

// don't do this!

// $jsShellInput is "db.users.drop();"
$scope = array("input" => $jsShellInput);
$db->execute(new MongoCode("eval(input);", $scope));

?>

Always use scope and never allow the database to execute user input as code.

Updates
Troubleshooting
Manual


Troubleshooting

If you're having trouble, there are lots of resources you can turn to.

  • IRC

    The official MongoDB IRC room is irc.freenode.net/#mongodb. This is the fastest way to get help.

  • Mailing List

    » MongoDB's mailing list is a good (and usually very fast) way to get answers to questions.

  • Bug Tracker

    Found a bug? Want a feature? Have a question? File it in the » PHP driver's bug tracker.

You can make the driver log all kinds of error messages as E_NOTICE level PHP error messages. Have a look at the MongoLog for an example.

Security
Running the Driver's Tests
Manual


Running the Driver's Tests

The PECL package does not come with the tests, but they are available at » Github.

.phpt Tests

.phpt tests are the standard way of testing PHP extensions. After compiling the MongoDB driver with "make" you can then issue "make test" to run the tests. These tests require MongoDB to be working, and hence, you need to configure the test suite itself.

There is more information on running the tests in the contributing guidelines on » GitHub.

Reporting Errors

Please report any failures or errors in the » bugtracker. There may be skipped tests, these are normal and can be ignored.

New tests are always welcome! Please feel free to contribute new tests of any type testing any functionality.

Troubleshooting
Core Classes
Manual


Core Classes

İçindekiler

  • MongoClient
  • MongoDB
  • MongoCollection
  • MongoCursor
  • MongoCursorInterface
  • MongoCommandCursor
Uyarı

This extension is deprecated. Instead, the MongoDB extension should be used.

The core classes are the most important part of the driver.

Running the Driver's Tests
MongoClient
Mongo


The MongoClient class

(PECL mongo >=1.3.0)

Uyarı

This extension that defines this class is deprecated. Instead, the MongoDB extension should be used. Alternatives to this class include:

  • MongoDB\Driver\Manager

Giriş

A connection manager for PHP and MongoDB.

This class is used to create and manage connections. A typical use is:

Örnek 1 MongoClient basic usage

<?php

$m = new MongoClient(); // connect
$db = $m->foo; // get the database named "foo"

?>

See MongoClient::__construct() and the section on connecting for more information about creating connections.

Sınıf Sözdizimi

MongoClient {
/* Sabitler */
const string VERSION ;
const string DEFAULT_HOST = "localhost" ;
const int DEFAULT_PORT = 27017 ;
const string RP_PRIMARY = "primary" ;
const string RP_PRIMARY_PREFERRED = "primaryPreferred" ;
const string RP_SECONDARY = "secondary" ;
const string RP_SECONDARY_PREFERRED = "secondaryPreferred" ;
const string RP_NEAREST = "nearest" ;
/* Özellikler */
public boolean $connected = FALSE ;
public string $status = NULL ;
protected string $server = NULL ;
protected boolean $persistent = NULL ;
/* Yöntemler */
public __construct ([ string $server = "mongodb://localhost:27017" [, array $options = array("connect" => TRUE) [, array $driver_options ]]] )
public bool close ([ boolean|string $connection ] )
public bool connect ( void )
public array dropDB ( mixed $db )
public MongoDB __get ( string $dbname )
public static array getConnections ( void )
public array getHosts ( void )
public array getReadPreference ( void )
public array getWriteConcern ( void )
public bool killCursor ( string $server_hash , int|MongoInt64 $id )
public array listDBs ( void )
public MongoCollection selectCollection ( string $db , string $collection )
public MongoDB selectDB ( string $name )
public bool setReadPreference ( string $read_preference [, array $tags ] )
public bool setWriteConcern ( mixed $w [, int $wtimeout ] )
public string __toString ( void )
}

Öntanımlı Sabitler

MongoClient Constants

MongoClient::VERSION
PHP driver version. May be suffixed with "dev", "+" or "-" if it is in-between versions.
MongoClient::DEFAULT_HOST
"localhost"
Host to connect to if no host is given.
MongoClient::DEFAULT_PORT
27017
Port to connect to if no port is given.
MongoClient::RP_PRIMARY
"primary"
Read preference for the primary replica set member.
MongoClient::RP_PRIMARY_PREFERRED
"primaryPreferred"
Read preference for preferring the primary replica set member.
MongoClient::RP_SECONDARY
"secondary"
Read preference for a secondary replica set member.
MongoClient::RP_SECONDARY_PREFERRED
"secondaryPreferred"
Read preference for preferring a secondary replica set member.
MongoClient::RP_NEAREST
"nearest"
Read preference for the nearest replica set member.

Fields

connected

This property will be set to TRUE if we have a open connection to the database, FALSE otherwise. If the connection is to a replica set, this property will only be TRUE if the driver has a connection to a node matching the current read preference. This property does not take authentication into account.

This property is deprecated since version 1.5.0.

status

This property is no longer used and will be set to NULL In driver versions 1.1.x and earlier, this may be set to a string value (e.g. "recycled", "new") when persistent connections are used.

This property is deprecated since version 1.5.0.

Ayrıca Bakınız

  • Read Preferences
  • Write Concerns
  • Connecting
  • MongoDB core docs on » connecting

İçindekiler

  • MongoClient::close — Closes this connection
  • MongoClient::connect — Connects to a database server
  • MongoClient::__construct — Creates a new database connection object
  • MongoClient::dropDB — Drops a database [deprecated]
  • MongoClient::__get — Gets a database
  • MongoClient::getConnections — Return info about all open connections
  • MongoClient::getHosts — Updates status for all associated hosts
  • MongoClient::getReadPreference — Get the read preference for this connection
  • MongoClient::getWriteConcern — Get the write concern for this connection
  • MongoClient::killCursor — Kills a specific cursor on the server
  • MongoClient::listDBs — Lists all of the databases available.
  • MongoClient::selectCollection — Gets a database collection
  • MongoClient::selectDB — Gets a database
  • MongoClient::setReadPreference — Set the read preference for this connection
  • MongoClient::setWriteConcern — Set the write concern for this connection
  • MongoClient::__toString — String representation of this connection
Core Classes
MongoClient::close
Core Classes


Closes this connection

MongoClient
MongoClient::connect
MongoClient
PHP Manual

MongoClient::close

(PECL mongo >=1.3.0)

MongoClient::close — Closes this connection

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension.

Açıklama

public bool MongoClient::close ([ boolean|string $connection ] )

The MongoClient::close() method forcefully closes a connection to the database, even if persistent connections are being used. You should never have to do this under normal circumstances.

Değiştirgeler

connection

If connection is not given, or FALSE then connection that would be selected for writes would be closed. In a single-node configuration, that is then the whole connection, but if you are connected to a replica set, close() will only close the connection to the primary server.

If connection is TRUE then all connections as known by the connection manager will be closed. This can include connections that are not referenced in the connection string used to create the object that you are calling close on.

If connection is a string argument, then it will only close the connection identified by this hash. Hashes are identifiers for a connection and can be obtained by calling MongoClient::getConnections().

Dönen Değerler

Returns if the connection was successfully closed.

Örnekler

Örnek 1 MongoClient::close() example

This example demonstrates how to selectively close all connections for secondaries only.

<?php
// Connect to a replicaset
$a = new MongoClient("mongodb://whisky:13000/?replicaset=seta");

$connections = $a->getConnections();

foreach ( $connections as $con )
{
    // Loop over all the connections, and when the type is "SECONDARY"
    // we close the connection
    if ( $con['connection']['connection_type_desc'] == "SECONDARY" )
    {
        echo "Closing '{$con['hash']}': ";
        $closed = $a->close( $con['hash'] );
        echo $closed ? "ok" : "failed", "\n";
    }
}
?>

Yukarıdaki örneğin çıktısı:

Closing 'whisky:13001;X;4948': ok

Sürüm Bilgisi

Sürüm: | Açıklama
1.3.0 | The connection parameter to this function was added in 1.3.0. Before that, only the write connection would be closed by this method.
1.2.0 | Before version 1.2.0 the driver would not use persistent connections by default, and all connections would be closed as soon as a MongoDB connection went out if scope. Since version 1.2.0 this is no longer the case and it is a bad idea to call close as you might end up overloading the server with connections under high load.

Ayrıca Bakınız

  • MongoClient::getConnections() - Return info about all open connections
MongoClient
MongoClient::connect
MongoClient


Connects to a database server

MongoClient::close
MongoClient::__construct
MongoClient
PHP Manual

MongoClient::connect

(PECL mongo >=1.3.0)

MongoClient::connect — Connects to a database server

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension.

Açıklama

public bool MongoClient::connect ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

If the connection was successful.

Hatalar/İstisnalar

Throws MongoConnectionException if it fails to connect to the database.

MongoClient::close
MongoClient::__construct
MongoClient


Creates a new database connection object

MongoClient::connect
MongoClient::dropDB
MongoClient
PHP Manual

MongoClient::__construct

(PECL mongo >=1.3.0)

MongoClient::__construct — Creates a new database connection object

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. Alternatives to this method include:

  • MongoDB\Driver\Manager::__construct()

Açıklama

 public MongoClient::__construct
  ([ string $server = "mongodb://localhost:27017"
 [, array $options = array("connect" => TRUE)
 [, array $driver_options
]]] )

If no parameters are passed, this connects to "localhost:27017" (or whatever was specified in php.ini for mongo.default_host and mongo.default_port).

server should have the form:

mongodb://[username:password@]host1[:port1][,host2[:port2:],...]/db

The connection string always starts with mongodb://, to indicate it is a connection string in this form.

If username and password are specified, the constructor will attempt to authenticate the connection with the database before returning. Username and password are optional and must be followed by an @, if specified.

At least one host must be given (port optional, always defaulting to 27017) and as many hosts as desired may be connected to. Host names are comma-separated and the constructor will return successfully if it connected to at least one host. If it could not connect to any of the hosts, it will throw a MongoConnectionException. Please see the Replica Sets section for information on how to connect to Replica Sets.

If you specified a username and password, you may specify a database to authenticate with. If db is not specified, "admin" will be used.

An optional query string may be used to specify extra options. The same options are supported through the options array as well, and are therefore redescribed there. See the examples below on how to set those options.

One part of the options governs how the driver reads from secondary nodes in a replica set environment. Extra information on how these read preferences work is available as well through the read preferences documentation page.

Değiştirgeler

server

The server name.

options

An array of options for the connection. Currently available options include:

  • "authMechanism"

    Available mechanisms are:

    authMechanism | Description | Availability
    MONGODB-CR | Authenticate using Challenge Response mechanism. This is the default value. | All MongoDB versions
    X509 | Authenticates using X509 certificates | MongoDB 2.6. Only available when OpenSSL is enabled
    PLAIN | Authenticates using unencrypted plain username+password. Must be used over SSL connections. Generally used by MongoDB to login via 3rd party LDAP server | MongoDB Enterprise 2.4. The Driver must be compiled against CyrusSASL2
    GSSAPI | Authenticates via kerberos systems | MongoDB Enterprise 2.4. The Driver must be compiled against CyrusSASL2

  • "authSource"

    Should be set to the database name where the user is defined it.

  • "connect"

    If the constructor should connect before returning. Default is TRUE. When set to FALSE the driver will automatically connect to the server whenever it is necessary to do a query. Alternatively, you can run MongoClient::connect() manually.

    Uyarı

    This option is not supported through the connection string.

  • "connectTimeoutMS"

    How long a connection can take to be opened before timing out in milliseconds. Defaults to 60000 (60 seconds).

    If -1 is specified, no connection timeout will be applied and PHP will use default_socket_timeout.

  • "db"

    The database to authenticate against can be specified here, instead of including it in the host list. This overrides a database given in the host list.

  • "fsync"

    When "fsync" is set, all write operations will block until the database has flushed the changes to disk. This makes the write operations slower, but it guarantees that writes have succeeded and that the operations can be recovered in case of total system failure.

    If the MongoDB server has journaling enabled, this option is identical to "journal". If journaling is not enabled, this option ensures that write operations will be synced to database files on disk.

    Bilginize: If journaling is enabled, users are strongly encouraged to use the "journal" option instead of "fsync". Do not use "fsync" and "journal" simultaneously, as that will result in an error.

  • "journal"

    When "journal" is set, all write operations will block until the database has flushed the changes to the journal on disk. This makes the write operations slower, but it guarantees that writes have succeeded and that the operations can be recovered in case of total system failure.

    Bilginize: If this option is used and journaling is disabled, MongoDB 2.6+ will raise an error and the write will fail; older server versions will simply ignore the option.

  • "gssapiServiceName"

    Sets the » Kerberos service principal. Only applicable when authMechanism=GSSAPI. Defaults to "mongodb".

  • "password"

    The password can be specified here, instead of including it in the host list. This is especially useful if a password has a "@" in it. This overrides a password set in the host list.

  • "readPreference"

    Specifies the read preference type. Read preferences provide you with control from which secondaries data can be read from.

    Allowed values are: MongoClient::RP_PRIMARY,
MongoClient::RP_PRIMARY_PREFERRED,
MongoClient::RP_SECONDARY,
MongoClient::RP_SECONDARY_PREFERRED and
MongoClient::RP_NEAREST.

    See the documentation on read preferences for more information.

  • "readPreferenceTags"

    Specifies the read preference tags as an array of strings. Tags can be used in combination with the readPreference option to further control which secondaries data might be read from.

    See the documentation on read preferences for more information.

  • "replicaSet"

    The name of the replica set to connect to. If this is given, the primary will be automatically be determined. This means that the driver may end up connecting to a server that was not even listed. See the replica set example below for details.

  • "secondaryAcceptableLatencyMS"

    When reading from a secondary (using ReadPreferences), do not read from secondaries known to be more then secondaryAcceptableLatencyMS away from us. Defaults to 15

  • "socketTimeoutMS"

    How long a socket operation (read or write) can take before timing out in milliseconds. Defaults to 30000 (30 seconds).

    If -1 is specified, socket operations may block indefinitely. This option may also be set on a per-operation basis using MongoCursor::timeout() for queries or the "socketTimeoutMS" option for write methods.

    Bilginize: This is a client-side timeout. If a write operation times out, there is no way to know if the server actually handled the write or not, as a MongoCursorTimeoutException will be thrown in lieu of returning a write result.

  • "ssl"

    A boolean to specify whether you want to enable SSL for the connections to MongoDB. Extra options such as certificates can be set with SSL bağlamı seçenekleri.

  • "username"

    The username can be specified here, instead of including it in the host list. This is especially useful if a username has a ":" in it. This overrides a username set in the host list.

  • "w"

    The w option specifies the Write Concern for the driver, which determines how long the driver blocks when writing. The default value is 1.

    This option is applicable when connecting to both single servers and replica sets. A positive value controls how many nodes must acknowledge the write instruction before the driver continues. A value of 1 would require the single server or primary (in a replica set) to acknowledge the write operation. A value of 3 would cause the driver to block until the write has been applied to the primary as well as two secondary servers (in a replica set).

    A string value is used to control which tag sets are taken into account for write concerns. "majority" is special and ensures that the write operation has been applied to the majority (more than 50%) of the participating nodes.

  • "wTimeoutMS"

    This option specifies the time limit, in milliseconds, for write concern acknowledgement. It is only applicable for write operations where "w" is greater than 1, as the timeout pertains to replication. If the write concern is not satisfied within the time limit, a MongoCursorException will be thrown. A value of 0 may be specified to block indefinitely. The default value is 10000 (ten seconds).

The following options are deprecated and should no longer be used:

  • "slaveOkay"

    Deprecated. Please use the read preference options.

  • "timeout"

    Deprecated alias for "connectTimeoutMS".

  • "wTimeout"

    Deprecated alias for "wTimeoutMS".

driver_options

An array of options for the MongoDB driver. Options include setting connection context options for SSL or logging callbacks.

  • "context"

    The Stream Context to attach to all new connections. This allows you for example to configure SSL certificates and are described at SSL context options. See the Connecting over SSL tutorial.

Dönen Değerler

Returns a new database connection object.

Hatalar/İstisnalar

Throws MongoConnectionException if it tries and fails to connect to the database for all hostnames given. It will also throw a MongoConnnectionException if an invalid username or password is given. See MongoConnectionException documentation for common exceptions and their causes.

Örnekler

Örnek 1 MongoClient::__construct() replica set example

This example shows how to connect the driver to a replica set. It assumes that there is a set of three servers: sf1.example.com, sf2.example.com, and ny1.example.com. The primary could be any one of these servers.

<?php

// pass a comma-separated list of server names to the constructor
// Note that we don't need to pass in all the members of the replicaset, the driver
// will derive the full list.
$m1 = new MongoClient("mongodb://sf2.example.com,ny1.example.com", array("replicaSet" => "myReplSet"));

?>

If the current primary fails, the driver will figure out which secondary server became the new primary and automatically start using that connection. Automatic failover will not work correctly if replicaSet is not specified.

At least one seed in the seed list must be up for the driver to connect to the replica set.

If you include seeds from two separate replica sets, behavior is undefined.

See the » core documentation on replica sets for more information.

Örnek 2 Connecting to a domain socket

In version 1.0.9+, you can use a UNIX domain socket to connect to an instance of MongoDB running locally. This should be slightly faster than using a network connection.

In version 1.5.0, the MongoDB server automatically opens a socket at /tmp/mongodb-<port>.sock. You can connect to this by specifying the path in your connection string:

<?php

// MongoDB server running locally on port 20000
$m = new MongoClient("mongodb:///tmp/mongodb-20000.sock");

?>

You can combine this with any other connections you'd like:

<?php

// try to connect to the domain socket, fall back to localhost connection
$m = new MongoClient("mongodb:///tmp/mongodb-27017.sock,localhost:27017");

?>

Örnek 3 MongoClient::__construct() authentication example

A user must exist in the admin database before attempting to use authentication. You can create one with the Mongo shell by running:

> use admin
switched to db admin
> db.addUser("testUser", "testPass");
{
        "_id" : ObjectId("4b21272fd9ab21611d19095c"),
        "user" : "testUser",
        "pwd" : "03b9b27e0abf1865e2f6fcbd9845dd59"
}
>

After creating a user with, in this case, username "testUser" and password "testPass", you can create an authenticated connection:

<?php

$m = new MongoClient("mongodb://testUser:testPass@localhost");

?>

Örnek 4 MongoClient::__construct() read preference example

<?php

// Prefer the nearest server in the "east" data center
$uri  = 'mongodb://rs1.example.com,rs2.example.com/';
$uri .= '?readPreference=nearest';
$uri .= '&readPreferenceTags=dc:east';
$m = new MongoClient($uri, array('replicaSet' => 'rs'));
?>

See the read preferences section of this manual for further information.

Örnek 5 MongoClient::__construct() options example

Options can be passed both through the query string in the connection string, or as an array passed as second argument to the constructor.

Here we set the journal option to true and readPreference to secondary preferred as default for all write operations:

<?php
$m = new MongoClient("mongodb://localhost/?journal=true&readPreference=secondary");
?>

And now we do the same, but as an options array:

<?php
$options = array(
    'journal' => true,
    'readPreference' => 'secondary',
);
$m = new MongoClient("mongodb://localhost/", $options);
?>

Örnek 6 MongoClient::__construct() read preference example

<?php

// Prefer the nearest server in the "east" data center
$uri  = 'mongodb://rs1.example.com,rs2.example.com/';
$uri .= '?readPreference=nearest';
$uri .= '&readPreferenceTags=dc:east';
$m = new MongoClient($uri, array('replicaSet' => 'rs'));
?>

See the read preferences section of this manual for further information.

Sürüm Bilgisi

Sürüm: Açıklama
1.5.0

Added "authMechanism", "gssapiServiceName", and "secondaryAcceptableLatencyMS".

1.4.0

Added "ssl" option and support for connecting over SSL.

Added "wTimeoutMS" option, which replaces "wTimeout".

Emits E_DEPRECATED when "slaveOkay" or "timeout" is used.

1.5.0

Added "authSource".

1.3.4

Added "connectTimeoutMS" and "socketTimeoutMS" options.

1.3.0

Added "readPreference", "readPreferenceTags", "w", and "wTimeout" options.

1.2.0

Added "username" and "password" options.

Removed "persist" option, as all connections are now persistent. It can still be used, but it doesn't affect anything.

"persist"

If the connection should be persistent. If set, the connection will be persistent. The string representation of the value is used as an ID for the connection, so two instances of MongoClient that are initialized with array("persist" => "foobar") will share the same database connection, whereas an instance initialized with array("persist" => "barbaz") will use a different database connection.

The "replicaSet" option now takes a string, not a boolean.

1.0.9 Added "replicaSet" option.
1.0.2

Changed constructor to take an array of options. Pre-1.0.2, the constructor took the following parameters:

server

The server name.

connect

Optional boolean parameter specifying if the constructor should connect to the database before returning. Defaults to TRUE.

persistent

If the connection should be persistent.

paired

If the connection should be paired.

MongoClient::connect
MongoClient::dropDB
MongoClient


Drops a database [deprecated]

MongoClient::__construct
MongoClient::__get
MongoClient
PHP Manual

MongoClient::dropDB

(PECL mongo >=1.3.0)

MongoClient::dropDB — Drops a database [deprecated]

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension, but there is an alternative in the PHP library:

  • » MongoDB\Client::dropDatabase()

Açıklama

public array MongoClient::dropDB ( mixed $db )
Uyarı

Deprecated

Use MongoDB::drop() instead.

Değiştirgeler

db

The database to drop. Can be a MongoDB object or the name of the database.

Dönen Değerler

Returns the database response.

MongoClient::__construct
MongoClient::__get
MongoClient


Gets a database

MongoClient::dropDB
MongoClient::getConnections
MongoClient
PHP Manual

MongoClient::__get

(PECL mongo >=1.3.0)

MongoClient::__get — Gets a database

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension, but there is an alternative in the PHP library:

  • » MongoDB\Client::__get()

Açıklama

public MongoDB MongoClient::__get ( string $dbname )

This is the cleanest way of getting a database. If the database name has any special characters, MongoClient::selectDB() will need to be used; however, this should be sufficient for most cases.

<?php

$mongo = new MongoClient();

// the following two lines are equivalent
$db = $mongo->selectDB("foo");
$db = $mongo->foo;

?>

Değiştirgeler

dbname

The database name.

Dönen Değerler

Returns a new db object.

Hatalar/İstisnalar

Throws a generic exception if the database name is invalid.

MongoClient::dropDB
MongoClient::getConnections
MongoClient


Return info about all open connections

MongoClient::__get
MongoClient::getHosts
MongoClient
PHP Manual

MongoClient::getConnections

(PECL mongo >=1.3.0)

MongoClient::getConnections — Return info about all open connections

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension.

Açıklama

public static array MongoClient::getConnections ( void )

Returns an array of all open connections, and information about each of the servers

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

An array of open connections.

Örnekler

Örnek 1 MongoClient::getConnections() example

<?php
$m = new MongoClient;
var_dump($m->getConnections());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(1) {
  [0]=>
  array(3) {
    ["hash"]=>
    string(26) "localhost:27017;-;X;56052"
    ["server"]=>
    array(3) {
      ["host"]=>
      string(10) "localhost"
      ["port"]=>
      int(27017)
      ["pid"]=>
      int(56052)
    }
    ["connection"]=>
    array(8) {
      ["last_ping"]=>
      int(1354076401)
      ["last_ismaster"]=>
      int(0)
      ["ping_ms"]=>
      int(0)
      ["connection_type"]=>
      int(1)
      ["connection_type_desc"]=>
      string(10) "STANDALONE"
      ["max_bson_size"]=>
      int(16777216)
      ["tag_count"]=>
      int(0)
      ["tags"]=>
      array(0) {
      }
    }
  }
}
MongoClient::__get
MongoClient::getHosts
MongoClient


Updates status for all associated hosts

MongoClient::getConnections
MongoClient::getReadPreference
MongoClient
PHP Manual

MongoClient::getHosts

(PECL mongo >=1.3.0)

MongoClient::getHosts — Updates status for all associated hosts

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. Alternatives to this method include:

  • MongoDB\Driver\Manager::getServers()

Açıklama

public array MongoClient::getHosts ( void )

This method is only useful with a connection to a replica set. It returns the status of all of the hosts in the set. Without a replica set, it will just return an array with one element containing the host that you are connected to.

See the query section of this manual for information on distributing reads to secondaries.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array of information about the hosts in the set. Includes each host's hostname, its health (1 is healthy), its state (1 is primary, 2 is secondary, 0 is anything else), the amount of time it took to ping the server, and when the last ping occurred. For example, on a three-member replica set, it might look something like:

array(3) {
  ["A:27017"]=>
  array(4) {
    ["host"]=>
    "A"
    ["port"]=>
    27017
    ["health"]=>
    int(1)
    ["state"]=>
    int(2)
    ["ping"]=>
    int(369)
    ["lastPing"]=>
    int(1309470644)
  }
  ["B:27017"]=>
  array(4) {
    ["host"]=>
    "B"
    ["port"]=>
    27017
    ["health"]=>
    int(1)
    ["state"]=>
    int(1)
    ["ping"]=>
    int(139)
    ["lastPing"]=>
    int(1309470644)
  }
  ["C:27017"]=>
  array(4) {
    ["host"]=>
    "C"
    ["port"]=>
    27017
    ["health"]=>
    int(1)
    ["state"]=>
    int(2)
    ["ping"]=>
    int(1012)
    ["lastPing"]=>
    int(1309470644)
  }
}

Sürüm Bilgisi

Sürüm: | Açıklama
1.2.10 | Support for non-replicasets was added. The returned array elements now also include the hostname and port.

Ayrıca Bakınız

  • MongoClient::getConnections() - Return info about all open connections
MongoClient::getConnections
MongoClient::getReadPreference
MongoClient


Get the read preference for this connection

MongoClient::getHosts
MongoClient::getWriteConcern
MongoClient
PHP Manual

MongoClient::getReadPreference

(PECL mongo >=1.3.0)

MongoClient::getReadPreference — Get the read preference for this connection

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension.

Açıklama

public array MongoClient::getReadPreference ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

This function returns an array describing the read preference. The array contains the values type for the string read preference mode (corresponding to the MongoClient constants), and tagsets containing a list of all tag set criteria. If no tag sets were specified, tagsets will not be present in the array.

Sürüm Bilgisi

Sürüm: | Açıklama
1.3.3 | The return value has changed to be consistent with MongoClient::setReadPreference(). The type value was changed from a number to a string, type_string was removed, and tagsets now expresses tags as key/value pairs instead of colon-delimited strings.

Örnekler

Örnek 1 MongoClient::getReadPreference() return value example

<?php

$m = new MongoClient();
$m->setReadPreference(MongoClient::RP_SECONDARY, array(
    array('dc' => 'east', 'use' => 'reporting'),
    array('dc' => 'west'),
    array(),
));
var_dump($m->getReadPreference());
?>

Yukarıdaki örneğin çıktısı:

array(2) {
  ["type"]=>
  string(9) "secondary"
  ["tagsets"]=>
  array(3) {
    [0]=>
    array(2) {
      ["dc"]=>
      string(4) "east"
      ["use"]=>
      string(9) "reporting"
    }
    [1]=>
    array(1) {
      ["dc"]=>
      string(7) "west"
    }
    [2]=>
    array(0) {
    }
  }
}

Ayrıca Bakınız

  • The read preferences documentation.
  • MongoClient::setReadPreference() - Set the read preference for this connection
MongoClient::getHosts
MongoClient::getWriteConcern
MongoClient


Get the write concern for this connection

MongoClient::getReadPreference
MongoClient::killCursor
MongoClient
PHP Manual

MongoClient::getWriteConcern

(PECL mongo >=1.5.0)

MongoClient::getWriteConcern — Get the write concern for this connection

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension.

Açıklama

public array MongoClient::getWriteConcern ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

This function returns an array describing the write concern. The array contains the values w for an integer acknowledgement level or string mode, and wtimeout denoting the maximum number of milliseconds to wait for the server to satisfy the write concern.

Örnekler

Örnek 1 MongoClient::getWriteConcern() return value example

<?php

$mc = new MongoClient('mongodb://localhost:27017', array('wTimeoutMS' => 500));
var_dump($mc->getWriteConcern());

$mc->setWriteConcern(1, 1000);
var_dump($mc->getWriteConcern());
?>

Yukarıdaki örneğin çıktısı:

array(2) {
  ["w"]=>
  int(1)
  ["wtimeout"]=>
  int(500)
}
array(2) {
  ["w"]=>
  int(1)
  ["wtimeout"]=>
  int(1000)
}

Ayrıca Bakınız

  • The write concern documentation.
  • MongoClient::setWriteConcern() - Set the write concern for this connection
MongoClient::getReadPreference
MongoClient::killCursor
MongoClient


Kills a specific cursor on the server

MongoClient::getWriteConcern
MongoClient::listDBs
MongoClient
PHP Manual

MongoClient::killCursor

(PECL mongo >=1.5.0)

MongoClient::killCursor — Kills a specific cursor on the server

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension.

Açıklama

public bool MongoClient::killCursor ( string $server_hash , int|MongoInt64 $id )

In certain situations it might be needed to kill a cursor on the server. Usually cursors time out after 10 minutes of inactivity, but it is possible to create an immortal cursor with MongoCursor::immortal() that never times out. In order to be able to kill such an immortal cursor, you can call this method with the information supplied by MongoCursor::info().

Değiştirgeler

server_hash

The server hash that has the cursor. This can be obtained through MongoCursor::info().

id

The ID of the cursor to kill. You can either supply an int containing the 64 bit cursor ID, or an object of the MongoInt64 class. The latter is necessary on 32 bit platforms (and Windows).

Dönen Değerler

Returns TRUE if the method attempted to kill a cursor, and FALSE if there was something wrong with the arguments (such as a wrong server_hash). The return status does not reflect where the cursor was actually killed as the server does not provide that information.

Hatalar/İstisnalar

This method displays a warning if the supplied server_hash does not match up with an existing connection. No attempt to kill a cursor is attempted in that case either.

Örnekler

Örnek 1 MongoClient::killCursor() example

This example shows how to connect, do a query, obtain the cursor information and then kill the cursor.

<?php
$m = new MongoClient();
$c = $m->testdb->collection;
$cursor = $c->find();
$result = $cursor->next();

// Now the cursor is valid, so we can get the hash and ID out:
$info = $cursor->info();

// Kill the cursor
MongoClient::killCursor( $info['server'], $info['id'] );
?>
MongoClient::getWriteConcern
MongoClient::listDBs
MongoClient


Lists all of the databases available.

MongoClient::killCursor
MongoClient::selectCollection
MongoClient
PHP Manual

MongoClient::listDBs

(PECL mongo >=1.3.0)

MongoClient::listDBs — Lists all of the databases available.

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension, but there is an alternative in the PHP library:

  • » MongoDB\Client::listDatabases()

Açıklama

public array MongoClient::listDBs ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an associative array containing three fields. The first field is databases, which in turn contains an array. Each element of the array is an associative array corresponding to a database, giving th database's name, size, and if it's empty. The other two fields are totalSize (in bytes) and ok, which is 1 if this method ran successfully.

Örnekler

Örnek 1 MongoClient::listDBs() example

Example demonstrating how to use listDBs and the returned data structure.

<?php

$mongo = new MongoClient();
$dbs = $mongo->listDBs();
print_r($dbs);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [databases] => Array
        (
            [0] => Array
                (
                    [name] => doctrine
                    [sizeOnDisk] => 218103808
                    [empty] =>
                )
        )

    [totalSize] => 218103808
    [ok] => 1
)
MongoClient::killCursor
MongoClient::selectCollection
MongoClient


Gets a database collection

MongoClient::listDBs
MongoClient::selectDB
MongoClient
PHP Manual

MongoClient::selectCollection

(PECL mongo >=1.3.0)

MongoClient::selectCollection — Gets a database collection

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension, but there is an alternative in the PHP library:

  • » MongoDB\Client::selectCollection()

Açıklama

public MongoCollection MongoClient::selectCollection ( string $db , string $collection )

Değiştirgeler

db

The database name.

collection

The collection name.

Dönen Değerler

Returns a new collection object.

Hatalar/İstisnalar

Throws Exception if the database or collection name is invalid.

Örnekler

Örnek 1 MongoClient::selectCollection() example

<?php
$m = new MongoClient();

$c1 = $m->selectCollection("foo", "bar.baz");
// which is equivalent to
$c2 = $m->selectDB("foo")->selectCollection("bar.baz");

// $c1 and $c2 now represent the same collection
?>
MongoClient::listDBs
MongoClient::selectDB
MongoClient


Gets a database

MongoClient::selectCollection
MongoClient::setReadPreference
MongoClient
PHP Manual

MongoClient::selectDB

(PECL mongo >=1.3.0)

MongoClient::selectDB — Gets a database

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension, but there is an alternative in the PHP library:

  • » MongoDB\Client::selectDatabase()

Açıklama

public MongoDB MongoClient::selectDB ( string $name )

Değiştirgeler

name

The database name.

Dönen Değerler

Returns a new database object.

Hatalar/İstisnalar

Throws Exception if the database name is invalid.

MongoClient::selectCollection
MongoClient::setReadPreference
MongoClient


Set the read preference for this connection

MongoClient::selectDB
MongoClient::setWriteConcern
MongoClient
PHP Manual

MongoClient::setReadPreference

(PECL mongo >=1.3.0)

MongoClient::setReadPreference — Set the read preference for this connection

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension.

Açıklama

public bool MongoClient::setReadPreference ( string $read_preference [, array $tags ] )

Değiştirgeler

read_preference

The read preference mode: MongoClient::RP_PRIMARY, MongoClient::RP_PRIMARY_PREFERRED, MongoClient::RP_SECONDARY, MongoClient::RP_SECONDARY_PREFERRED, or MongoClient::RP_NEAREST.

tags

An array of zero or more tag sets, where each tag set is itself an array of criteria used to match tags on replica set members.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Hatalar/İstisnalar

Emits E_WARNING if either parameter is invalid, or if one or more tag sets are provided with the MongoClient::RP_PRIMARY read preference mode.

Örnekler

Örnek 1 MongoClient::setReadPreference() tag set array syntax example

<?php

$m = new MongoClient();

// Prefer the nearest server in the "east" data center also used for reporting,
// but fall back to a server in the "west" data center
$m->setReadPreference(MongoClient::RP_NEAREST, array(
    array('dc' => 'east', 'use' => 'reporting'),
    array('dc' => 'west'),
));
?>

Ayrıca Bakınız

  • The read preferences documentation.
  • MongoClient::getReadPreference() - Get the read preference for this connection
MongoClient::selectDB
MongoClient::setWriteConcern
MongoClient


Set the write concern for this connection

MongoClient::setReadPreference
MongoClient::__toString
MongoClient
PHP Manual

MongoClient::setWriteConcern

(PECL mongo >=1.5.0)

MongoClient::setWriteConcern — Set the write concern for this connection

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension.

Açıklama

public bool MongoClient::setWriteConcern ( mixed $w [, int $wtimeout ] )

Değiştirgeler

w

The write concern. This may be an integer denoting the number of servers required to acknowledge the write, or a string mode (e.g. "majority").

wtimeout

The maximum number of milliseconds to wait for the server to satisfy the write concern.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Hatalar/İstisnalar

Emits E_WARNING if the w parameter is not an integer or string value.

Örnekler

Örnek 1 MongoClient::setWriteConcern() example

<?php

$mc = new MongoClient('mongodb://rs1.example.com,rs2.example.com');

// Require that the majority of servers in the replica set acknowledge writes
// within three seconds.
$mc->setWriteConcern('majority', 3000);
?>

Ayrıca Bakınız

  • The write concern documentation.
  • MongoClient::getWriteConcern() - Get the write concern for this connection
MongoClient::setReadPreference
MongoClient::__toString
MongoClient


String representation of this connection

MongoClient::setWriteConcern
MongoDB
MongoClient
PHP Manual

MongoClient::__toString

(PECL mongo >=1.3.0)

MongoClient::__toString — String representation of this connection

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension.

Açıklama

public string MongoClient::__toString ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns hostname and port for this connection.

MongoClient::setWriteConcern
MongoDB
MongoClient


The MongoDB class

(PECL mongo >=0.9.0)

Giriş

Instances of this class are used to interact with a database. To get a database:

Örnek 1 Selecting a database

<?php

$m = new MongoClient(); // connect
$db = $m->selectDB("example");

?>
Database names can use almost any character in the ASCII range. However, they cannot contain " ", "." or be the empty string. The name "system" is also reserved.

A few unusual, but valid, database names: "null", "[x,y]", "3", "\"", "/".

Unlike collection names, database names may contain "$".

Sınıf Sözdizimi

MongoDB {
/* Sabitler */
const int PROFILING_OFF = 0 ;
const int PROFILING_SLOW = 1 ;
const int PROFILING_ON = 2 ;
/* Fields */
public integer $w = 1 ;
public integer $wtimeout = 10000 ;
/* Yöntemler */
public array authenticate ( string $username , string $password )
public array command ( array $command [, array $options = array() [, string &$hash ]] )
public __construct ( MongoClient $conn , string $name )
public MongoCollection createCollection ( string $name [, array $options ] )
public array createDBRef ( string $collection , mixed $document_or_id )
public array drop ( void )
public array dropCollection ( mixed $coll )
public array execute ( mixed $code [, array $args = array() ] )
public bool forceError ( void )
public MongoCollection __get ( string $name )
public array getCollectionInfo ([ array $options = array() ] )
public array getCollectionNames ([ array $options = array() ] )
public array getDBRef ( array $ref )
public MongoGridFS getGridFS ([ string $prefix = "fs" ] )
public int getProfilingLevel ( void )
public array getReadPreference ( void )
public bool getSlaveOkay ( void )
public array getWriteConcern ( void )
public array lastError ( void )
public array listCollections ([ array $options = array() ] )
public array prevError ( void )
public array repair ([ bool $preserve_cloned_files = FALSE [, bool $backup_original_files = FALSE ]] )
public array resetError ( void )
public MongoCollection selectCollection ( string $name )
public int setProfilingLevel ( int $level )
public bool setReadPreference ( string $read_preference [, array $tags ] )
public bool setSlaveOkay ([ bool $ok = true ] )
public bool setWriteConcern ( mixed $w [, int $wtimeout ] )
public string __toString ( void )
}

Öntanımlı Sabitler

MongoDB Log Levels

MongoDB::PROFILING_OFF
0
Profiling is off.
MongoDB::PROFILING_SLOW
1
Profiling is on for slow operations (>100 ms).
MongoDB::PROFILING_ON
2
Profiling is on for all operations.

Fields

w
1

The number of servers to replicate a change to before returning success. Inherited by instances of MongoCollection derived from this. w functionality is only available in version 1.5.1+ of the MongoDB server and 1.0.8+ of the driver.

w is used whenever you need to adjust the acknowledgement level (MongoCollection::insert(), MongoCollection::update(), MongoCollection::remove(), MongoCollection::save(), and MongoCollection::ensureIndex() all support this option). With the default value (1), an acknowledged operation will return once the database server has the operation. If the server goes down before the operation has been replicated to a secondary, it is possible to lose the operation forever. Thus, you can specify w to be higher than one and guarantee that at least one secondary has the operation before it is considered successful.

For example, if w is 2, the primary and one secondary must have a record of the operation or the driver will throw a MongoCursorException. It is tempting to set w to the total number of secondaries + primary, but then if one secondary is down the operation will fail and an exception will be thrown, so usually w=2 is safest (primary and one secondary).

wtimeout
10000

The number of milliseconds to wait for MongoDB::$w replications to take place. Inherited by instances of MongoCollection derived from this. w functionality is only available in version 1.5.1+ of the MongoDB server and 1.0.8+ of the driver.

Unless wtimeout is set, the server waits forever for replicating to w servers to finish. The driver defaults to waiting for 10 seconds, you can change this value to alter its behavior.

Ayrıca Bakınız

MongoDB core docs on » databases.

İçindekiler

  • MongoDB::authenticate — Log in to this database
  • MongoDB::command — Execute a database command
  • MongoDB::__construct — Creates a new database
  • MongoDB::createCollection — Creates a collection
  • MongoDB::createDBRef — Creates a database reference
  • MongoDB::drop — Drops this database
  • MongoDB::dropCollection — Drops a collection [deprecated]
  • MongoDB::execute — Runs JavaScript code on the database server [deprecated]
  • MongoDB::forceError — Creates a database error
  • MongoDB::__get — Gets a collection
  • MongoDB::getCollectionInfo — Returns information about collections in this database
  • MongoDB::getCollectionNames — Gets an array of names for all collections in this database
  • MongoDB::getDBRef — Fetches the document pointed to by a database reference
  • MongoDB::getGridFS — Fetches toolkit for dealing with files stored in this database
  • MongoDB::getProfilingLevel — Gets this database's profiling level
  • MongoDB::getReadPreference — Get the read preference for this database
  • MongoDB::getSlaveOkay — Get slaveOkay setting for this database
  • MongoDB::getWriteConcern — Get the write concern for this database
  • MongoDB::lastError — Check if there was an error on the most recent db operation performed
  • MongoDB::listCollections — Gets an array of MongoCollection objects for all collections in this database
  • MongoDB::prevError — Checks for the last error thrown during a database operation
  • MongoDB::repair — Repairs and compacts this database
  • MongoDB::resetError — Clears any flagged errors on the database
  • MongoDB::selectCollection — Gets a collection
  • MongoDB::setProfilingLevel — Sets this database's profiling level
  • MongoDB::setReadPreference — Set the read preference for this database
  • MongoDB::setSlaveOkay — Change slaveOkay setting for this database
  • MongoDB::setWriteConcern — Set the write concern for this database
  • MongoDB::__toString — The name of this database
MongoClient::__toString
MongoDB::authenticate
Core Classes


Log in to this database

MongoDB
MongoDB::command
MongoDB
PHP Manual

MongoDB::authenticate

(PECL mongo >=1.0.1)

MongoDB::authenticate — Log in to this database

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension.

Instead, you need to provide credentials through the connection string.

Açıklama

public array MongoDB::authenticate ( string $username , string $password )

This method causes its connection to be authenticated. If authentication is enabled for the database server (it's not, by default), you need to log in before the database will allow you to do anything.

In general, you should use the authenticate built into MongoClient::__construct() in preference to this method. If you authenticate on connection and the connection drops and reconnects during your session, you'll be reauthenticated. If you manually authenticated using this method and the connection drops, you'll have to call this method again once you're reconnected.

This method is identical to running:

<?php

$salted = "${username}:mongo:${password}";
$hash = md5($salted);

$nonce = $db->command(array("getnonce" => 1));

$saltedHash = md5($nonce["nonce"]."${username}${hash}");

$result = $db->command(array("authenticate" => 1,
    "user" => $username,
    "nonce" => $nonce["nonce"],
    "key" => $saltedHash
));

?>

Once a connection has been authenticated, it can only be un-authenticated by using the "logout" database command:

<?php

$db->command(array("logout" => 1));

?>

Değiştirgeler

username

The username.

password

The password (in plaintext).

Dönen Değerler

Returns database response. If the login was successful, it will return

<?php
array("ok" => 1);
?>
If something went wrong, it will return
<?php
array("ok" => 0, "errmsg" => "auth fails");
?>
("auth fails" could be another message, depending on database version and what when wrong).

Ayrıca Bakınız

MongoDB core docs on » authenticate.

Sürüm Bilgisi

Sürüm: | Açıklama
1.2.11 | Emits E_DEPRECATED when used. Please pass in the authentication details to the constructor.

MongoDB
MongoDB::command
MongoDB


Execute a database command

MongoDB::authenticate
MongoDB::__construct
MongoDB
PHP Manual

MongoDB::command

(PECL mongo >=0.9.2)

MongoDB::command — Execute a database command

Açıklama

public array MongoDB::command ( array $command [, array $options = array() [, string &$hash ]] )

Almost everything that is not a CRUD operation can be done with a database command. Need to know the database version? There's a command for that. Need to do aggregation? There's a command for that. Need to turn up logging? You get the idea.

This method is identical to:

<?php

public function command($data) {
    return $this->selectCollection('$cmd')->findOne($data);
}

?>

Değiştirgeler

command

The query to send.

options

An array of options for the index creation. Currently available options include:

  • "socketTimeoutMS"

    This option specifies the time limit, in milliseconds, for socket communication. If the server does not respond within the timeout period, a MongoCursorTimeoutException will be thrown and there will be no way to determine if the server actually handled the write or not. A value of -1 may be specified to block indefinitely. The default value for MongoClient is 30000 (30 seconds).

The following options are deprecated and should no longer be used:

  • "timeout"

    Deprecated alias for "socketTimeoutMS".

hash

Set to the connection hash of the server that executed the command. When the command result is suitable for creating a MongoCommandCursor, the hash is intended to be passed to MongoCommandCursor::createFromDocument().

The hash will also correspond to a connection returned from MongoClient::getConnections().

Sürüm Bilgisi

Sürüm: | Açıklama
1.5.0 | Renamed the "timeout" option to "socketTimeoutMS". Emits E_DEPRECATED when "timeout" is used. Added hash by-reference parameter.
1.2.0 | Added options parameter with a single option: "timeout".

Dönen Değerler

Returns database response. Every database response is always maximum one document, which means that the result of a database command can never exceed 16MB. The resulting document's structure depends on the command, but most results will have the ok field to indicate success or failure and results containing an array of each of the resulting documents.

Örnekler

Örnek 1 MongoDB::command() "distinct" example

Finding all of the distinct values for a key.

<?php

$people = $db->people;

$people->insert(array("name" => "Joe", "age" => 4));
$people->insert(array("name" => "Sally", "age" => 22));
$people->insert(array("name" => "Dave", "age" => 22));
$people->insert(array("name" => "Molly", "age" => 87));

$ages = $db->command(array("distinct" => "people", "key" => "age"));

foreach ($ages['values'] as $age) {
    echo "$age\n";
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

4
22
87

Örnek 2 MongoDB::command() "distinct" example

Finding all of the distinct values for a key, where the value is larger than or equal to 18.

<?php

$people = $db->people;

$people->insert(array("name" => "Joe", "age" => 4));
$people->insert(array("name" => "Sally", "age" => 22));
$people->insert(array("name" => "Dave", "age" => 22));
$people->insert(array("name" => "Molly", "age" => 87));

$ages = $db->command(
    array(
        "distinct" => "people",
        "key" => "age",
        "query" => array("age" => array('$gte' => 18))
    )
);

foreach ($ages['values'] as $age) {
    echo "$age\n";
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

22
87

Örnek 3 MongoDB::command() MapReduce example

Get all users with at least on "sale" event, and how many times each of these users has had a sale.

<?php

// sample event document
$events->insert(array("user_id" => $id,
    "type" => $type,
    "time" => new MongoDate(),
    "desc" => $description));

// construct map and reduce functions
$map = new MongoCode("function() { emit(this.user_id,1); }");
$reduce = new MongoCode("function(k, vals) { ".
    "var sum = 0;".
    "for (var i in vals) {".
        "sum += vals[i];".
    "}".
    "return sum; }");

$sales = $db->command(array(
    "mapreduce" => "events",
    "map" => $map,
    "reduce" => $reduce,
    "query" => array("type" => "sale"),
    "out" => array("merge" => "eventCounts")));

$users = $db->selectCollection($sales['result'])->find();

foreach ($users as $user) {
    echo "{$user['_id']} had {$user['value']} sale(s).\n";
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

User 47cc67093475061e3d9536d2 had 3 sale(s).
User 49902cde5162504500b45c2c had 14 sale(s).
User 4af467e4fd543cce7b0ea8e2 had 1 sale(s).

Bilginize: Using MongoCode

This example uses MongoCode, which can also take a scope argument. However, at the moment, MongoDB does not support using scopes in MapReduce. If you would like to use client-side variables in the MapReduce functions, you can add them to the global scope by using the optional scope field with the database command. See the » MapReduce documentation for more information.

Bilginize: The out argument

Before 1.8.0, the out argument was optional. If you did not use it, MapReduce results would be written to a temporary collection, which would be deleted when your connection was closed. In 1.8.0+, the out argument is required. See the » MapReduce documentation for more information.

Örnek 4 MongoDB::command() "geoNear" example

This example shows how to use the geoNear command.

<?php
$m = new MongoClient();
$d = $m->demo;
$c = $d->poiConcat;

$r = $d->command(array(
    'geoNear' => "poiConcat",      // Search in the poiConcat collection
    'near' => array(-0.08, 51.48), // Search near 51.48°N, 0.08°E
    'spherical' => true,           // Enable spherical search
    'num' => 5,                    // Maximum 5 returned documents
));
print_r($r);
?>

Ayrıca Bakınız

  • MongoCollection::aggregate() - Perform an aggregation using the aggregation framework
  • MongoCollection::findAndModify() - Update a document and return it
  • MongoCollection::group() - Performs an operation similar to SQL's GROUP BY command

MongoDB core docs on » database commands.

MongoDB::authenticate
MongoDB::__construct
MongoDB


Creates a new database

MongoDB::command
MongoDB::createCollection
MongoDB
PHP Manual

MongoDB::__construct

(PECL mongo >=0.9.0)

MongoDB::__construct — Creates a new database

Açıklama

public MongoDB::__construct ( MongoClient $conn , string $name )

This method is not meant to be called directly. The preferred way to create an instance of MongoDB is through MongoClient::__get() or MongoClient::selectDB().

If you're ignoring the previous paragraph and want to call it directly you can do so:

<?php

$m = new MongoClient();
$db = new MongoDB($m, 'mydbname');

?>

But don't. Isn't this much nicer:

<?php

$m = new MongoClient();
$db = $m->mydbname;

// or, if the name contains weird characters:

$db = $m->selectDB('my,db:name');

?>

Değiştirgeler

MongoClient conn

Database connection.

name

Database name.

Dönen Değerler

Returns the database.

Hatalar/İstisnalar

Throws default exception if the database name is invalid.

MongoDB::command
MongoDB::createCollection
MongoDB


Creates a collection

MongoDB::__construct
MongoDB::createDBRef
MongoDB
PHP Manual

MongoDB::createCollection

(PECL mongo >=0.9.0)

MongoDB::createCollection — Creates a collection

Açıklama

public MongoCollection MongoDB::createCollection ( string $name [, array $options ] )

This method is used to create capped collections and other collections requiring special options. It is identical to running:

<?php

$collection = $db->command(array(
    "create" => $name,
    "capped" => $options["capped"],
    "size" => $options["size"],
    "max" => $options["max"],
    "autoIndexId" => $options["autoIndexId"],
));

?>
See MongoDB::command() for more information about database commands.

Değiştirgeler

name

The name of the collection.

options

An array containing options for the collections. Each option is its own element in the options array, with the option name listed below being the key of the element. The supported options depend on the MongoDB server version and storage engine, and the driver passes any option that you give it straight to the server. A few of the supported options are, but you can find a full list in the MongoDB core docs on » createCollection:

capped

If the collection should be a fixed size.

size

If the collection is fixed size, its size in bytes.

max

If the collection is fixed size, the maximum number of elements to store in the collection.

autoIndexId

If capped is TRUE you can specify FALSE to disable the automatic index created on the _id field. Before MongoDB 2.2, the default value for autoIndexId was FALSE.

Dönen Değerler

Returns a collection object representing the new collection.

Örnekler

Örnek 1 MongoDB::createCollection() capped collection example

A capped collection is a special type of collection that has either a fixed or a fixed number of elements. Once the collection is "full," the oldest elements will be removed when new elements are added. Capped collections can be very useful for applications like logging, where you may want to reserve a certain amount of space for logs and not worry about them getting too big.

This example creates a very tiny log collection that will keep a maximum of 10 documents.

<?php

$log = $db->createCollection(
    "logger",
    array(
        'capped' => true,
        'size' => 10*1024,
        'max' => 10
    )
);

for ($i = 0; $i < 100; $i++) {
    $log->insert(array("level" => WARN, "msg" => "sample log message #$i", "ts" => new MongoDate()));
}

$msgs = $log->find();

foreach ($msgs as $msg) {
    echo $msg['msg']."\n";
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

sample log message #90
sample log message #91
sample log message #92
sample log message #93
sample log message #94
sample log message #95
sample log message #96
sample log message #97
sample log message #98
sample log message #99

Sürüm Bilgisi

Sürüm: Açıklama
1.4.0

In versions before 1.4.0, the options were all arguments to the method. The function synopsis in those older versions is:

public MongoCollection MongoDB::createCollection ( string $name [, bool $capped = FALSE [, int $size = 0 [, int $max = 0 ]]] )

The meaning of the options is the same as described under the options argument above.

MongoDB::__construct
MongoDB::createDBRef
MongoDB


Creates a database reference

MongoDB::createCollection
MongoDB::drop
MongoDB
PHP Manual

MongoDB::createDBRef

(PECL mongo >=0.9.0)

MongoDB::createDBRef — Creates a database reference

Açıklama

public array MongoDB::createDBRef ( string $collection , mixed $document_or_id )

This method is a flexible interface for creating database refrences (see MongoDBRef).

Değiştirgeler

collection

The collection to which the database reference will point.

document_or_id

If an array or object is given, its _id field will be used as the reference ID. If a MongoId or scalar is given, it will be used as the reference ID.

Dönen Değerler

Returns a database reference array.

If an array without an _id field was provided as the document_or_id parameter, NULL will be returned.

Örnekler

Örnek 1 MongoDB::createDBRef() example

Example demonstrating how to programatically create a DB reference array from a document.

<?php

$articles = $db->articles;

$article = array(
 'title' => 'Test article',
 'description' => 'Test article description'
);

$articles->insert($article);
$ref = $db->createDBRef('articles', $article);

print_r($article);
print_r($ref);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

     Array
     (
         [title] => Test article
         [description] => Test article description
         [_id] => MongoId Object
             (
             )

     )
     Array
     (
         [$ref] => articles
         [$id] => MongoId Object
             (
             )

     )

Now the $ref can be stored on another document and retrieved later with MongoDB::getDBRef() or MongoCollection::getDBRef().

Örnek 2 MongoDB::createDBRef() example

Example demonstrating how to programatically create a DB reference from just an id.

<?php

$id = new MongoId('47cc67093475061e3d9536d2');
$ref = $db->createDBRef('articles', $id);
?>
MongoDB::createCollection
MongoDB::drop
MongoDB


Drops this database

MongoDB::createDBRef
MongoDB::dropCollection
MongoDB
PHP Manual

MongoDB::drop

(PECL mongo >=0.9.0)

MongoDB::drop — Drops this database

Açıklama

public array MongoDB::drop ( void )

This drops the database currently being used.

This is identical to running:

<?php

public function drop() {
    $this->command(array("dropDatabase" => 1));
}

?>

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the database response.

Örnekler

Örnek 1 MongoDB::drop() example

This example demonstrates how to drop a mongo database and the response to expect.

<?php

$db = $mongo->foo;
$response = $db->drop();
print_r($response);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [dropped] => foo.$cmd
    [ok] => 1
)
MongoDB::createDBRef
MongoDB::dropCollection
MongoDB


Drops a collection [deprecated]

MongoDB::drop
MongoDB::execute
MongoDB
PHP Manual

MongoDB::dropCollection

(PECL mongo >=0.9.0)

MongoDB::dropCollection — Drops a collection [deprecated]

Açıklama

public array MongoDB::dropCollection ( mixed $coll )
Uyarı

Deprecated

Use MongoCollection::drop() instead.

This function leaks memory in version 1.0.7 and earlier!

Değiştirgeler

coll

MongoCollection or name of collection to drop.

Dönen Değerler

Returns the database response.

MongoDB::drop
MongoDB::execute
MongoDB


Runs JavaScript code on the database server [deprecated]

MongoDB::dropCollection
MongoDB::forceError
MongoDB
PHP Manual

MongoDB::execute

(PECL mongo >=0.9.3)

MongoDB::execute — Runs JavaScript code on the database server [deprecated]

Açıklama

public array MongoDB::execute ( mixed $code [, array $args = array() ] )
Uyarı

The » eval command, which this method invokes, is deprecated in MongoDB 3.0+.

The Mongo database server runs a JavaScript engine. This method allows you to run arbitary JavaScript on the database. This can be useful if you want touch a number of collections lightly, or process some results on the database side to reduce the amount that has to be sent to the client.

Running JavaScript in the database takes a write lock, meaning it blocks other operations. Make sure you consider this before running a long script.

This is a wrapper for the » eval database command. This method is basically:

<?php

public function execute($code, $args) {
    return $this->command(array('eval' => $code, 'args' => $args));
}

?>

MongoDB implies a return statement if you have a single statement on a single line. This can cause some unintuitive behavior. For example, this returns "foo":

<?php

$db->execute('"foo";');

?>

However, these return NULL:

<?php

$db->execute('"bar"; "foo";'); // more than one statement

$db->execute('db.foo.count(
);'); // more than one line

?>

To avoid surprising behavior, it is best not to depend on MongoDB to decide what to return, but to explicitly state a return value. In the examples above, we can change them to:

<?php

$db->execute('"bar"; return "foo";');

$db->execute('return db.foo.count(
);');

?>

Now the first statement will return "foo" and the second statement will return a count of the "foo" collection.

Değiştirgeler

code

MongoCode or string to execute.

args

Arguments to be passed to code.

Dönen Değerler

Returns the result of the evaluation.

Örnekler

Örnek 1 Simple MongoDB::execute() example

<?php

$response = $db->execute("function() { return 'Hello, world!'; }");
echo $response['retval'];

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Hello, world!

Örnek 2 Parameter MongoDB::execute() example

The optional array of parameters will be passed to the JavaScript function.

<?php

$response = $db->execute("function(greeting, name) { return greeting+', '+name+'!'; }", array("Good bye", "Joe"));
echo $response['retval'];

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Good bye, Joe!

Örnek 3 Scope example

If a MongoCode object is used instead of a string for the first parameter, a scope can be passed in which the JavaScript will be executed.

<?php

$func =
    "function(greeting, name) { ".
        "return greeting+', '+name+', says '+greeter;".
    "}";
$scope = array("greeter" => "Fred");

$code = new MongoCode($func, $scope);

$response = $db->execute($code, array("Goodbye", "Joe"));
echo $response['retval'];

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Goodbye, Joe, says Fred

Ayrıca Bakınız

  • The MongoDB » eval command docs

Sürüm Bilgisi

Sürüm: | Açıklama
1.7.0 | This method has been deprecated as a result of the underlaying » eval command being deprecated in MongoDB 3.0+.

MongoDB::dropCollection
MongoDB::forceError
MongoDB


Creates a database error

MongoDB::execute
MongoDB::__get
MongoDB
PHP Manual

MongoDB::forceError

(PECL mongo >=0.9.5)

MongoDB::forceError — Creates a database error

Açıklama

public bool MongoDB::forceError ( void )

This method is not very useful for normal MongoDB use. It forces a database error to occur. This means that MongoDB::lastError() will return a generic database error after running this command.

This command is identical to running:

<?php

public function forceError() {
    return $this->command(array('forceerror' => 1));
}

?>

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the database response.

Sürüm Bilgisi

Sürüm: | Açıklama
1.2.11 | Emits E_DEPRECATED when used.

MongoDB::execute
MongoDB::__get
MongoDB


Gets a collection

MongoDB::forceError
MongoDB::getCollectionInfo
MongoDB
PHP Manual

MongoDB::__get

(PECL mongo >=1.0.2)

MongoDB::__get — Gets a collection

Açıklama

public MongoCollection MongoDB::__get ( string $name )

This is the easiest way of getting a collection from a database object. If a collection name contains strange characters, you may have to use MongoDB::selectCollection() instead.

<?php

$mongo = new MongoClient();

// the following two lines are equivalent
$collection = $mongo->selectDB("foo")->selectCollection("bar");
$collection = $mongo->foo->bar;

?>

Değiştirgeler

name

The name of the collection.

Dönen Değerler

Returns the collection.

MongoDB::forceError
MongoDB::getCollectionInfo
MongoDB


Returns information about collections in this database

MongoDB::__get
MongoDB::getCollectionNames
MongoDB
PHP Manual

MongoDB::getCollectionInfo

(PECL mongo >=1.6.0)

MongoDB::getCollectionInfo — Returns information about collections in this database

Açıklama

public array MongoDB::getCollectionInfo ([ array $options = array() ] )

Gets a list of all collections in the database and returns them as an array of documents, which contain their names and options.

Bilginize: This method will use the » listCollections database command when communicating with MongoDB 2.8+. For previous database versions, the method will query the special system.namespaces collection.

Değiştirgeler

options

An array of options for listing the collections. Currently available options include:

  • "filter"

    Optional query criteria. If provided, this criteria will be used to filter the collections included in the result.

    Relevant fields that may be queried include "name" (collection name as a string, without the database name prefix) and "options" (object containing options used to create the collection)..

    Bilginize: MongoDB 2.6 and earlier versions require the "name" criteria, if specified, to be a string value (i.e. equality match). This is because the driver must prefix the value with the database name in order to query the system.namespaces collection. Later versions of MongoDB do not have this limitation, as the driver will use the listCollections command.

  • "includeSystemCollections"

    Boolean, defaults to FALSE. Determines whether system collections should be included in the result.

The following option may be used with MongoDB 2.8+:

  • "maxTimeMS"

    Specifies a cumulative time limit in milliseconds for processing the operation (does not include idle time). If the operation is not completed within the timeout period, a MongoExecutionTimeoutException will be thrown.

Dönen Değerler

This function returns an array where each element is an array describing a collection. Elements will contain a name key denoting the name of the collection, and optionally contain an options key denoting an array of objects used to create the collection. For example, capped collections will include capped and size options.

Hatalar/İstisnalar

For MongoDB 2.6 and earlier, MongoException will be thrown if a non-string value was specified for the "filter" option's "name" criteria.

Örnekler

Örnek 1 MongoDB::getCollectionInfo() example

<?php
$m = new MongoClient();
$db = $m->selectDB("demo");
var_dump($db->getCollectionInfo());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(2) {
  [0]=>
  array(2) {
    ["name"]=>
    string(4) "logs"
    ["options"]=>
    array(2) {
      ["capped"]=>
      bool(true)
      ["size"]=>
      int(10240)
    }
  }
  [1]=>
  array(2) {
    ["name"]=>
    string(5) "users"
    ["options"]=>
    array(1) {
      ["flags"]=>
      int(1)
    }
  }
}

Ayrıca Bakınız

  • MongoDB::getCollectionNames() - Gets an array of names for all collections in this database
  • MongoDB::listCollections() - Gets an array of MongoCollection objects for all collections in this database

MongoDB::__get
MongoDB::getCollectionNames
MongoDB


Gets an array of names for all collections in this database

MongoDB::getCollectionInfo
MongoDB::getDBRef
MongoDB
PHP Manual

MongoDB::getCollectionNames

(PECL mongo >=1.3.0)

MongoDB::getCollectionNames — Gets an array of names for all collections in this database

Açıklama

public array MongoDB::getCollectionNames ([ array $options = array() ] )

Gets a list of all collections in the database and returns their names as an array of strings.

Bilginize: This method will use the » listCollections database command when communicating with MongoDB 2.8+. For previous database versions, the method will query the special system.namespaces collection.

Değiştirgeler

options

An array of options for listing the collections. Currently available options include:

  • "filter"

    Optional query criteria. If provided, this criteria will be used to filter the collections included in the result.

    Relevant fields that may be queried include "name" (collection name as a string, without the database name prefix) and "options" (object containing options used to create the collection)..

    Bilginize: MongoDB 2.6 and earlier versions require the "name" criteria, if specified, to be a string value (i.e. equality match). This is because the driver must prefix the value with the database name in order to query the system.namespaces collection. Later versions of MongoDB do not have this limitation, as the driver will use the listCollections command.

  • "includeSystemCollections"

    Boolean, defaults to FALSE. Determines whether system collections should be included in the result.

The following option may be used with MongoDB 2.8+:

  • "maxTimeMS"

    Specifies a cumulative time limit in milliseconds for processing the operation (does not include idle time). If the operation is not completed within the timeout period, a MongoExecutionTimeoutException will be thrown.

Dönen Değerler

Returns the collection names as an array of strings.

Hatalar/İstisnalar

For MongoDB 2.6 and earlier, MongoException will be thrown if a non-string value was specified for the "filter" option's "name" criteria.

Sürüm Bilgisi

Sürüm: | Açıklama
1.6.0 | Changed first parameter to be an array of options. Pre-1.6.0, the first parameter was a boolean indicating the "includeSystemCollections" option.

Örnekler

Örnek 1 MongoDB::getCollectionNames() example

<?php
$m = new MongoClient();
$db = $m->selectDB("demo");
$collections = $db->getCollectionNames();

foreach ($collections as $collectionName) {
    echo "Found collection: ", $collectionName, "\n";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...
Found collection: img
Found collection: beer
Found collection: collation
...

Ayrıca Bakınız

  • MongoDB::listCollections() - Gets an array of MongoCollection objects for all collections in this database
  • MongoDB::getCollectionInfo() - Returns information about collections in this database

MongoDB::getCollectionInfo
MongoDB::getDBRef
MongoDB


Fetches the document pointed to by a database reference

MongoDB::getCollectionNames
MongoDB::getGridFS
MongoDB
PHP Manual

MongoDB::getDBRef

(PECL mongo >=0.9.0)

MongoDB::getDBRef — Fetches the document pointed to by a database reference

Açıklama

public array MongoDB::getDBRef ( array $ref )

Değiştirgeler

ref

A database reference.

Dönen Değerler

Returns the document pointed to by the reference.

Örnekler

Örnek 1 MongoDB::getDBRef() example

Example demonstrating how to get a database reference and what the expected input is.

<?php

 $ref = array(
   '$ref' => 'profiles',
   '$id' => new MongoId('47cc67093475061e3d9536d2')
 );

 $profile = $db->getDBRef($ref);
 ?>

See MongoDB::createDBRef() for more information about how to programatically create DB references.

MongoDB::getCollectionNames
MongoDB::getGridFS
MongoDB


Fetches toolkit for dealing with files stored in this database

MongoDB::getDBRef
MongoDB::getProfilingLevel
MongoDB
PHP Manual

MongoDB::getGridFS

(PECL mongo >=0.9.0)

MongoDB::getGridFS — Fetches toolkit for dealing with files stored in this database

Açıklama

public MongoGridFS MongoDB::getGridFS ([ string $prefix = "fs" ] )

Değiştirgeler

prefix

The prefix for the files and chunks collections.

Dönen Değerler

Returns a new gridfs object for this database.

Örnekler

Örnek 1 MongoDB::getGridFS() example

This example demonstrates how get a MongoGridFS instance.

<?php

$db = $mongo->my_db;

$prefix = 'files';
$collection = $db->getGridFS($prefix);

?>

Read more about the MongoGridFS to learn how to store files with MongoDB.

MongoDB::getDBRef
MongoDB::getProfilingLevel
MongoDB


Gets this database's profiling level

MongoDB::getGridFS
MongoDB::getReadPreference
MongoDB
PHP Manual

MongoDB::getProfilingLevel

(PECL mongo >=0.9.0)

MongoDB::getProfilingLevel — Gets this database's profiling level

Açıklama

public int MongoDB::getProfilingLevel ( void )

This returns the current database profiling level.

The database profiler tracks query execution times. If you turn it on (say, using MongoDB::setProfilingLevel() or the shell), you can see how many queries took longer than a given number of milliseconds or the timing for all queries.

Note that profiling slows down queries, so it is better to use in development or testing than in a time-sensitive application.

This function is equivalent to running:

<?php

public function getProfilingLevel() {
    return $this->command(array('profile' => -1));
}

?>

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the profiling level.

Ayrıca Bakınız

  • MongoDB core docs on » profiling
  • MongoDB::setProfilingLevel() - Sets this database's profiling level
MongoDB::getGridFS
MongoDB::getReadPreference
MongoDB


Get the read preference for this database

MongoDB::getProfilingLevel
MongoDB::getSlaveOkay
MongoDB
PHP Manual

MongoDB::getReadPreference

(PECL mongo >=1.3.0)

MongoDB::getReadPreference — Get the read preference for this database

Açıklama

public array MongoDB::getReadPreference ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

This function returns an array describing the read preference. The array contains the values type for the string read preference mode (corresponding to the MongoClient constants), and tagsets containing a list of all tag set criteria. If no tag sets were specified, tagsets will not be present in the array.

Sürüm Bilgisi

Sürüm: | Açıklama
1.3.3 | The return value has changed to be consistent with MongoDB::setReadPreference(). The type value was changed from a number to a string, type_string was removed, and tagsets now expresses tags as key/value pairs instead of colon-delimited strings.

Örnekler

Örnek 1 MongoDB::getReadPreference() return value example

<?php

$m = new MongoClient();
$db = $m->test;
$db->setReadPreference(MongoClient::RP_SECONDARY, array(
    array('dc' => 'east', 'use' => 'reporting'),
    array('dc' => 'west'),
    array(),
));
var_dump($db->getReadPreference());
?>

Yukarıdaki örneğin çıktısı:

array(2) {
  ["type"]=>
  string(9) "secondary"
  ["tagsets"]=>
  array(3) {
    [0]=>
    array(2) {
      ["dc"]=>
      string(4) "east"
      ["use"]=>
      string(9) "reporting"
    }
    [1]=>
    array(1) {
      ["dc"]=>
      string(7) "west"
    }
    [2]=>
    array(0) {
    }
  }
}

Ayrıca Bakınız

  • The read preferences documentation.
  • MongoDB::setReadPreference() - Set the read preference for this database
MongoDB::getProfilingLevel
MongoDB::getSlaveOkay
MongoDB


Get slaveOkay setting for this database

MongoDB::getReadPreference
MongoDB::getWriteConcern
MongoDB
PHP Manual

MongoDB::getSlaveOkay

(PECL mongo >=1.1.0)

MongoDB::getSlaveOkay — Get slaveOkay setting for this database

Açıklama

public bool MongoDB::getSlaveOkay ( void )

See the query section of this manual for information on distributing reads to secondaries.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the value of slaveOkay for this instance.

Sürüm Bilgisi

Sürüm: | Açıklama
1.2.11 | Emits E_DEPRECATED when used.

Ayrıca Bakınız

  • Read Preferences
  • MongoDB::getReadPreference() - Get the read preference for this database
  • MongoDB::setReadPreference() - Set the read preference for this database
MongoDB::getReadPreference
MongoDB::getWriteConcern
MongoDB


Get the write concern for this database

MongoDB::getSlaveOkay
MongoDB::lastError
MongoDB
PHP Manual

MongoDB::getWriteConcern

(PECL mongo >=1.5.0)

MongoDB::getWriteConcern — Get the write concern for this database

Açıklama

public array MongoDB::getWriteConcern ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

This function returns an array describing the write concern. The array contains the values w for an integer acknowledgement level or string mode, and wtimeout denoting the maximum number of milliseconds to wait for the server to satisfy the write concern.

Örnekler

Örnek 1 MongoDB::getWriteConcern() return value example

<?php

$mc = new MongoClient('mongodb://localhost:27017', array('wTimeoutMS' => 500));
$db = $mc->selectDB('test');
var_dump($db->getWriteConcern());

$db->setWriteConcern(1, 1000);
var_dump($db->getWriteConcern());
?>

Yukarıdaki örneğin çıktısı:

array(2) {
  ["w"]=>
  int(1)
  ["wtimeout"]=>
  int(500)
}
array(2) {
  ["w"]=>
  int(1)
  ["wtimeout"]=>
  int(1000)
}

Ayrıca Bakınız

  • The write concern documentation.
  • MongoDB::setWriteConcern() - Set the write concern for this database
MongoDB::getSlaveOkay
MongoDB::lastError
MongoDB


Check if there was an error on the most recent db operation performed

MongoDB::getWriteConcern
MongoDB::listCollections
MongoDB
PHP Manual

MongoDB::lastError

(PECL mongo >=0.9.5)

MongoDB::lastError — Check if there was an error on the most recent db operation performed

Açıklama

public array MongoDB::lastError ( void )

This method is equivalent to:

<?php

public function lastError() {
    return $this->command(array('getlasterror' => 1));
}

?>

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the error, if there was one.

Örnekler

Örnek 1 MongoDB::lastError() NULL error example

<?php
$db->resetError();
var_dump($db->lastError());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(3) {
  ["err"]=>
  NULL
  ["n"]=>
  int(0)
  ["ok"]=>
  float(1)
}

Örnek 2 MongoDB::lastError() duplicate key example

<?php
$c = $db->selectCollection("foo");

// insert two documents with the same _id
$c->insert(array("_id" => 1));
$c->insert(array("_id" => 1));

var_dump($db->lastError());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(3) {
  ["err"]=>
  string(64) "E11000 duplicate key errorindex: foo.foo.$_id_  dup key: { : 1 }"
  ["n"]=>
  int(0)
  ["ok"]=>
  float(1)
}
MongoDB::getWriteConcern
MongoDB::listCollections
MongoDB


Gets an array of MongoCollection objects for all collections in this database

MongoDB::lastError
MongoDB::prevError
MongoDB
PHP Manual

MongoDB::listCollections

(PECL mongo >=0.9.0)

MongoDB::listCollections — Gets an array of MongoCollection objects for all collections in this database

Açıklama

public array MongoDB::listCollections ([ array $options = array() ] )

Gets a list of all collections in the database and returns them as an array of MongoCollection objects.

Bilginize: This method will use the » listCollections database command when communicating with MongoDB 2.8+. For previous database versions, the method will query the special system.namespaces collection.

Değiştirgeler

options

An array of options for listing the collections. Currently available options include:

  • "filter"

    Optional query criteria. If provided, this criteria will be used to filter the collections included in the result.

    Relevant fields that may be queried include "name" (collection name as a string, without the database name prefix) and "options" (object containing options used to create the collection)..

    Bilginize: MongoDB 2.6 and earlier versions require the "name" criteria, if specified, to be a string value (i.e. equality match). This is because the driver must prefix the value with the database name in order to query the system.namespaces collection. Later versions of MongoDB do not have this limitation, as the driver will use the listCollections command.

  • "includeSystemCollections"

    Boolean, defaults to FALSE. Determines whether system collections should be included in the result.

The following option may be used with MongoDB 2.8+:

  • "maxTimeMS"

    Specifies a cumulative time limit in milliseconds for processing the operation (does not include idle time). If the operation is not completed within the timeout period, a MongoExecutionTimeoutException will be thrown.

Dönen Değerler

Returns an array of MongoCollection objects.

Hatalar/İstisnalar

For MongoDB 2.6 and earlier, MongoException will be thrown if a non-string value was specified for the "filter" option's "name" criteria.

Sürüm Bilgisi

Sürüm: | Açıklama
1.6.0 | Changed first parameter to be an array of options. Pre-1.6.0, the first parameter was a boolean indicating the "includeSystemCollections" option.
1.3.0 | Added the includeSystemCollections parameter.

Örnekler

Örnek 1 MongoDB::listCollections() example

The following example demonstrates running count on each collection in a database.

<?php

$m = new MongoClient();
$db = $m->selectDB("demo");
$collections = $db->listCollections();

foreach ($collections as $collection) {
    echo "amount of documents in $collection: ";
    echo $collection->count(), "\n";
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...
amount of documents in demo.pubs: 4
amount of documents in demo.elephpants: 3
amount of documents in demo.cities: 22840
...

Ayrıca Bakınız

  • MongoDB::getCollectionNames() - Gets an array of names for all collections in this database
  • MongoDB::getCollectionInfo() - Returns information about collections in this database

MongoDB::lastError
MongoDB::prevError
MongoDB


Checks for the last error thrown during a database operation

MongoDB::listCollections
MongoDB::repair
MongoDB
PHP Manual

MongoDB::prevError

(PECL mongo >=0.9.5)

MongoDB::prevError — Checks for the last error thrown during a database operation

Açıklama

public array MongoDB::prevError ( void )

MongoDB::lastError() is usually preferred to this. This method returns the last database error that occurred and how many operations ago it occurred. It is mostly deprecated.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the error and the number of operations ago it occurred.

Sürüm Bilgisi

Sürüm: | Açıklama
1.2.11 | Emits E_DEPRECATED when used.

MongoDB::listCollections
MongoDB::repair
MongoDB


Repairs and compacts this database

MongoDB::prevError
MongoDB::resetError
MongoDB
PHP Manual

MongoDB::repair

(PECL mongo >=0.9.0)

MongoDB::repair — Repairs and compacts this database

Açıklama

public array MongoDB::repair ([ bool $preserve_cloned_files = FALSE [, bool $backup_original_files = FALSE ]] )

This creates a fresh copy of all database data. It will remove any corrupt data and compact and large stretches of free space it finds. This is a very slow operation on a large database.

This is usually run from the shell or the command line, not the driver.

It is equivalent to the function:

<?php

public function repair() {
    return $this->command(array('repairDatabase' => 1));
}

?>

Değiştirgeler

preserve_cloned_files

If cloned files should be kept if the repair fails.

backup_original_files

If original files should be backed up.

Dönen Değerler

Returns db response.

Ayrıca Bakınız

MongoDB core docs on » repairDatabase.

Örnekler

Örnek 1 MongoDB::repair() example

This example demonstrates how to repare and compact a database.

<?php

$db = $mongo->foo;

$response = $db->repair();
print_r($response);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [ok] => 1
)
MongoDB::prevError
MongoDB::resetError
MongoDB


Clears any flagged errors on the database

MongoDB::repair
MongoDB::selectCollection
MongoDB
PHP Manual

MongoDB::resetError

(PECL mongo >=0.9.5)

MongoDB::resetError — Clears any flagged errors on the database

Açıklama

public array MongoDB::resetError ( void )

This method is not used in normal operations. It resets the database error tracker (which can be incremented with MongoDB::forceError(), also not normally used).

It is equivalent to running:

<?php

public function resetError() {
    return $this->command(array('reseterror' => 1));
}

?>

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the database response.

Sürüm Bilgisi

Sürüm: | Açıklama
1.2.11 | Emits E_DEPRECATED when used.

MongoDB::repair
MongoDB::selectCollection
MongoDB


Gets a collection

MongoDB::resetError
MongoDB::setProfilingLevel
MongoDB
PHP Manual

MongoDB::selectCollection

(PECL mongo >=0.9.0)

MongoDB::selectCollection — Gets a collection

Açıklama

public MongoCollection MongoDB::selectCollection ( string $name )

Değiştirgeler

name

The collection name.

Dönen Değerler

Returns a new collection object.

Hatalar/İstisnalar

Throws Exception if the collection name is invalid.

MongoDB::resetError
MongoDB::setProfilingLevel
MongoDB


Sets this database's profiling level

MongoDB::selectCollection
MongoDB::setReadPreference
MongoDB
PHP Manual

MongoDB::setProfilingLevel

(PECL mongo >=0.9.0)

MongoDB::setProfilingLevel — Sets this database's profiling level

Açıklama

public int MongoDB::setProfilingLevel ( int $level )

This changes the current database profiling level.

This function is equivalent to running:

<?php

public function setProfilingLevel($level) {
    return $this->command(array('profile' => $level));
}

?>

The options for level are 0 (off), 1 (queries > 100ms), and 2 (all queries). If you would like to profile queries that take longer than another time period, use the database command and pass it a second option, the number of milliseconds. For example, to profile all queries that take longer than one second, run:

<?php

$result = $this->command(array('profile' => 1, 'slowms' => 1000));

?>

Profiled queries will appear in the system.profile collection of this database.

Değiştirgeler

level

Profiling level.

Dönen Değerler

Returns the previous profiling level.

Ayrıca Bakınız

  • MongoDB core docs on » profiling
  • MongoDB::getProfilingLevel() - Gets this database's profiling level
MongoDB::selectCollection
MongoDB::setReadPreference
MongoDB


Set the read preference for this database

MongoDB::setProfilingLevel
MongoDB::setSlaveOkay
MongoDB
PHP Manual

MongoDB::setReadPreference

(PECL mongo >=1.3.0)

MongoDB::setReadPreference — Set the read preference for this database

Açıklama

public bool MongoDB::setReadPreference ( string $read_preference [, array $tags ] )

Değiştirgeler

read_preference

The read preference mode: MongoClient::RP_PRIMARY, MongoClient::RP_PRIMARY_PREFERRED, MongoClient::RP_SECONDARY, MongoClient::RP_SECONDARY_PREFERRED, or MongoClient::RP_NEAREST.

tags

An array of zero or more tag sets, where each tag set is itself an array of criteria used to match tags on replica set members.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Hatalar/İstisnalar

Emits E_WARNING if either parameter is invalid, or if one or more tag sets are provided with the MongoClient::RP_PRIMARY read preference mode.

Örnekler

Örnek 1 MongoDB::setReadPreference() tag set array syntax example

<?php

$m = new MongoClient();
$db = $m->test;

// Prefer the nearest server in the "east" data center also used for reporting,
// but fall back to a server in the "west" data center
$db->setReadPreference(MongoClient::RP_NEAREST, array(
    array('dc' => 'east', 'use' => 'reporting'),
    array('dc' => 'west'),
));
?>

Ayrıca Bakınız

  • The read preferences documentation.
  • MongoDB::getReadPreference() - Get the read preference for this database
MongoDB::setProfilingLevel
MongoDB::setSlaveOkay
MongoDB


Change slaveOkay setting for this database

MongoDB::setReadPreference
MongoDB::setWriteConcern
MongoDB
PHP Manual

MongoDB::setSlaveOkay

(PECL mongo >=1.1.0)

MongoDB::setSlaveOkay — Change slaveOkay setting for this database

Açıklama

public bool MongoDB::setSlaveOkay ([ bool $ok = true ] )

See the query section of this manual for information on distributing reads to secondaries.

Değiştirgeler

ok

If reads should be sent to secondary members of a replica set for all possible queries using this MongoDB instance.

Dönen Değerler

Returns the former value of slaveOkay for this instance.

Sürüm Bilgisi

Sürüm: | Açıklama
1.2.11 | Emits E_DEPRECATED when used.

Ayrıca Bakınız

  • Read Preferences
  • MongoDB::setReadPreference() - Set the read preference for this database
  • MongoDB::getReadPreference() - Get the read preference for this database
MongoDB::setReadPreference
MongoDB::setWriteConcern
MongoDB


Set the write concern for this database

MongoDB::setSlaveOkay
MongoDB::__toString
MongoDB
PHP Manual

MongoDB::setWriteConcern

(PECL mongo >=1.5.0)

MongoDB::setWriteConcern — Set the write concern for this database

Açıklama

public bool MongoDB::setWriteConcern ( mixed $w [, int $wtimeout ] )

Değiştirgeler

w

The write concern. This may be an integer denoting the number of servers required to acknowledge the write, or a string mode (e.g. "majority").

wtimeout

The maximum number of milliseconds to wait for the server to satisfy the write concern.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Hatalar/İstisnalar

Emits E_WARNING if the w parameter is not an integer or string value.

Örnekler

Örnek 1 MongoDB::setWriteConcern() example

<?php

$mc = new MongoClient('mongodb://rs1.example.com,rs2.example.com');
$db = $mc->selectDB('test');

// Require that the majority of servers in the replica set acknowledge writes
// within three seconds.
$db->setWriteConcern('majority', 3000);
?>

Ayrıca Bakınız

  • The write concern documentation.
  • MongoDB::getWriteConcern() - Get the write concern for this database
MongoDB::setSlaveOkay
MongoDB::__toString
MongoDB


The name of this database

MongoDB::setWriteConcern
MongoCollection
MongoDB
PHP Manual

MongoDB::__toString

(PECL mongo >=0.9.0)

MongoDB::__toString — The name of this database

Açıklama

public string MongoDB::__toString ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns this database's name.

MongoDB::setWriteConcern
MongoCollection
MongoDB


The MongoCollection class

(PECL mongo >=0.9.0)

Giriş

Represents a MongoDB collection.

Collection names can use any character in the ASCII set. Some valid collection names are "", "...", "my collection", and "*&#@".

User-defined collection names cannot contain the $ symbol. There are certain system collections which use a $ in their names (e.g., local.oplog.$main), but it is a reserved character. If you attempt to create and use a collection with a $ in the name, MongoDB will assert.

Sınıf Sözdizimi

MongoCollection {
/* Sabitler */
const int ASCENDING = 1 ;
const int DESCENDING = -1 ;
/* Fields */
public MongoDB $db = NULL ;
public integer $w ;
public integer $wtimeout ;
/* Yöntemler */
public array aggregate ( array $pipeline [, array $options ] )
public MongoCommandCursor aggregateCursor ( array $command [, array $options ] )
public mixed batchInsert ( array $a [, array $options = array() ] )
public __construct ( MongoDB $db , string $name )
public int count ([ array $query = array() [, array $options = array() ]] )
public array createDBRef ( mixed $document_or_id )
public bool createIndex ( array $keys [, array $options = array() ] )
public array deleteIndex ( string|array $keys )
public array deleteIndexes ( void )
public array distinct ( string $key [, array $query ] )
public array drop ( void )
public bool ensureIndex ( string|array $key|keys [, array $options = array() ] )
public MongoCursor find ([ array $query = array() [, array $fields = array() ]] )
public array findAndModify ( array $query [, array $update [, array $fields [, array $options ]]] )
 public array findOne
  ([ array $query = array()
 [, array $fields = array()
 [, array $options = array()
]]] )
public MongoCollection __get ( string $name )
public array getDBRef ( array $ref )
public array getIndexInfo ( void )
public string getName ( void )
public array getReadPreference ( void )
public bool getSlaveOkay ( void )
public array getWriteConcern ( void )
public array group ( mixed $keys , array $initial , MongoCode $reduce [, array $options = array() ] )
public bool|array insert ( array|object $document [, array $options = array() ] )
public array[MongoCommandCursor] parallelCollectionScan ( int $num_cursors )
public bool|array remove ([ array $criteria = array() [, array $options = array() ]] )
public mixed save ( array|object $document [, array $options = array() ] )
public bool setReadPreference ( string $read_preference [, array $tags ] )
public bool setSlaveOkay ([ bool $ok = true ] )
public bool setWriteConcern ( mixed $w [, int $wtimeout ] )
static protected string toIndexString ( mixed $keys )
public string __toString ( void )
public bool|array update ( array $criteria , array $new_object [, array $options = array() ] )
public array validate ([ bool $scan_data = FALSE ] )
}

Öntanımlı Sabitler

MongoCollection::ASCENDING
1
Ascending direction for sorts and index creation.
MongoCollection::DESCENDING
-1
Descending direction for sorts and index creation.

Fields

db

The "parent" database for this collection.

w

The number of servers to replicate a change to before returning success. Value is inherited from the parent database. The MongoDB class has a more detailed description of how w works.

wtimeout

The number of milliseconds to wait for $this->w replications to take place. Value is inherited from the parent database. The MongoDB class has a more detailed description of how wtimeout works.

Ayrıca Bakınız

MongoDB core docs on » collections.

İçindekiler

  • MongoCollection::aggregate — Perform an aggregation using the aggregation framework
  • MongoCollection::aggregateCursor — Execute an aggregation pipeline command and retrieve results through a cursor
  • MongoCollection::batchInsert — Inserts multiple documents into this collection
  • MongoCollection::__construct — Creates a new collection
  • MongoCollection::count — Counts the number of documents in this collection
  • MongoCollection::createDBRef — Creates a database reference
  • MongoCollection::createIndex — Creates an index on the specified field(s) if it does not already exist.
  • MongoCollection::deleteIndex — Deletes an index from this collection
  • MongoCollection::deleteIndexes — Delete all indices for this collection
  • MongoCollection::distinct — Retrieve a list of distinct values for the given key across a collection.
  • MongoCollection::drop — Drops this collection
  • MongoCollection::ensureIndex — Creates an index on the specified field(s) if it does not already exist.
  • MongoCollection::find — Queries this collection, returning a MongoCursor for the result set
  • MongoCollection::findAndModify — Update a document and return it
  • MongoCollection::findOne — Queries this collection, returning a single element
  • MongoCollection::__get — Gets a collection
  • MongoCollection::getDBRef — Fetches the document pointed to by a database reference
  • MongoCollection::getIndexInfo — Returns information about indexes on this collection
  • MongoCollection::getName — Returns this collection's name
  • MongoCollection::getReadPreference — Get the read preference for this collection
  • MongoCollection::getSlaveOkay — Get slaveOkay setting for this collection
  • MongoCollection::getWriteConcern — Get the write concern for this collection
  • MongoCollection::group — Performs an operation similar to SQL's GROUP BY command
  • MongoCollection::insert — Inserts a document into the collection
  • MongoCollection::parallelCollectionScan — Returns an array of cursors to iterator over a full collection in parallel
  • MongoCollection::remove — Remove records from this collection
  • MongoCollection::save — Saves a document to this collection
  • MongoCollection::setReadPreference — Set the read preference for this collection
  • MongoCollection::setSlaveOkay — Change slaveOkay setting for this collection
  • MongoCollection::setWriteConcern — Set the write concern for this database
  • MongoCollection::toIndexString — Converts keys specifying an index to its identifying string
  • MongoCollection::__toString — String representation of this collection
  • MongoCollection::update — Update records based on a given criteria
  • MongoCollection::validate — Validates this collection
MongoDB::__toString
MongoCollection::aggregate
Core Classes


Perform an aggregation using the aggregation framework

MongoCollection
MongoCollection::aggregateCursor
MongoCollection
PHP Manual

MongoCollection::aggregate

(PECL mongo >=1.3.0)

MongoCollection::aggregate — Perform an aggregation using the aggregation framework

Açıklama

public array MongoCollection::aggregate ( array $pipeline [, array $options ] )
public array MongoCollection::aggregate ( array $op [, array $op [, array $... ]] )

The MongoDB » aggregation framework provides a means to calculate aggregated values without having to use MapReduce. While MapReduce is powerful, it is often more difficult than necessary for many simple aggregation tasks, such as totaling or averaging field values.

This method accepts either a variable amount of pipeline operators, or a single array of operators constituting the pipeline.

Değiştirgeler

pipeline

An array of pipeline operators.

options

Options for the aggregation command. Valid options include:

  • "allowDiskUse"

    Allow aggregation stages to write to temporary files

  • "cursor"

    Options controlling the creation of the cursor object. This option causes the command to return a result document suitable for constructing a MongoCommandCursor. If you need to use this option, you should consider using MongoCollection::aggregateCursor().

  • "explain"

    Return information on the processing of the pipeline.

  • "maxTimeMS"

    Specifies a cumulative time limit in milliseconds for processing the operation (does not include idle time). If the operation is not completed within the timeout period, a MongoExecutionTimeoutException will be thrown.

Or

op

First pipeline operator.

op

The second pipeline operator.

...

Additional pipeline operators.

Dönen Değerler

The result of the aggregation as an array. The ok will be set to 1 on success, 0 on failure.

Hatalar/İstisnalar

When an error occurs an array with the following keys will be returned:

  • errmsg - containing the reason for the failure
  • code - the errorcode of the failure
  • ok - will be set to 0.

Sürüm Bilgisi

Sürüm: | Açıklama
1.5.0 | Added optional options argument

Örnekler

Örnek 1 MongoCollection::aggregate() example

The following example aggregation operation pivots data to create a set of author names grouped by tags applied to an article. Call the aggregation framework by issuing the following command:

<?php
$m = new MongoClient("localhost");
$c = $m->selectDB("examples")->selectCollection("article");
$data = array (
    'title' => 'this is my title',
    'author' => 'bob',
    'posted' => new MongoDate,
    'pageViews' => 5,
    'tags' => array ( 'fun', 'good', 'fun' ),
    'comments' => array (
      array (
        'author' => 'joe',
        'text' => 'this is cool',
      ),
      array (
        'author' => 'sam',
        'text' => 'this is bad',
      ),
    ),
    'other' =>array (
      'foo' => 5,
    ),
);
$d = $c->insert($data, array("w" => 1));

$ops = array(
    array(
        '$project' => array(
            "author" => 1,
            "tags"   => 1,
        )
    ),
    array('$unwind' => '$tags'),
    array(
        '$group' => array(
            "_id" => array("tags" => '$tags'),
            "authors" => array('$addToSet' => '$author'),
        ),
    ),
);
$results = $c->aggregate($ops);
var_dump($results);
?>

Yukarıdaki örneğin çıktısı:

array(2) {
  ["result"]=>
  array(2) {
    [0]=>
    array(2) {
      ["_id"]=>
      array(1) {
        ["tags"]=>
        string(4) "good"
      }
      ["authors"]=>
      array(1) {
        [0]=>
        string(3) "bob"
      }
    }
    [1]=>
    array(2) {
      ["_id"]=>
      array(1) {
        ["tags"]=>
        string(3) "fun"
      }
      ["authors"]=>
      array(1) {
        [0]=>
        string(3) "bob"
      }
    }
  }
  ["ok"]=>
  float(1)
}

The following examples use the » zipcode data set. Use mongoimport to load this data set into your mongod instance.

Örnek 2 MongoCollection::aggregate() example

To return all states with a population greater than 10 million, use the following aggregation operation:

<?php
$m = new MongoClient("localhost");
$c = $m->selectDB("test")->selectCollection("zips");

$pipeline = array(
    array(
        '$group' => array(
            '_id' => array('state' => '$state'),
            'totalPop' => array('$sum' => '$pop')
        )
    ),
    array(
        '$match' => array(
            'totalPop' => array('$gte' => 10 * 1000 * 1000)
        )
    ),
);
$out = $c->aggregate($pipeline);
var_dump($out);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(2) {
  ["result"]=>
  array(7) {
    [0]=>
    array(2) {
      ["_id"]=>
      string(2) "TX"
      ["totalPop"]=>
      int(16986510)
    }
    [1]=>
    array(2) {
      ["_id"]=>
      string(2) "PA"
      ["totalPop"]=>
      int(11881643)
    }
    [2]=>
    array(2) {
      ["_id"]=>
      string(2) "NY"
      ["totalPop"]=>
      int(17990455)
    }
    [3]=>
    array(2) {
      ["_id"]=>
      string(2) "IL"
      ["totalPop"]=>
      int(11430602)
    }
    [4]=>
    array(2) {
      ["_id"]=>
      string(2) "CA"
      ["totalPop"]=>
      int(29760021)
    }
    [5]=>
    array(2) {
      ["_id"]=>
      string(2) "OH"
      ["totalPop"]=>
      int(10847115)
    }
    [6]=>
    array(2) {
      ["_id"]=>
      string(2) "FL"
      ["totalPop"]=>
      int(12937926)
    }
  }
  ["ok"]=>
  float(1)
}

Örnek 3 MongoCollection::aggregate() example

To return the average populations for cities in each state, use the following aggregation operation:

<?php
$m = new MongoClient;
$c = $m->selectDB("test")->selectCollection("zips");

$out = $c->aggregate(
    array(
        '$group' => array(
            '_id' => array('state' => '$state', 'city' => '$city' ),
            'pop' => array('$sum' => '$pop' )
        )
    ),
    array(
        '$group' => array(
            '_id' => '$_id.state',
            'avgCityPop' => array('$avg' => '$pop')
        )
    )
);

var_dump($out);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(2) {
  ["result"]=>
  array(51) {
    [0]=>
    array(2) {
      ["_id"]=>
      string(2) "DC"
      ["avgCityPop"]=>
      float(303450)
    }
    [1]=>
    array(2) {
      ["_id"]=>
      string(2) "DE"
      ["avgCityPop"]=>
      float(14481.913043478)
    }
...
    [49]=>
    array(2) {
      ["_id"]=>
      string(2) "WI"
      ["avgCityPop"]=>
      float(7323.0074850299)
    }
    [50]=>
    array(2) {
      ["_id"]=>
      string(2) "WV"
      ["avgCityPop"]=>
      float(2759.1953846154)
    }
  }
  ["ok"]=>
  float(1)
}

Örnek 4 MongoCollection::aggregate() with command options

To return information on how the pipeline will be processed we use the explain command option:

<?php
$m = new MongoClient;
$c = $m->selectDB("test")->selectCollection("zips");

$pipeline = array(
    array(
        '$group' => array(
            '_id' => '$state',
           'totalPop' => array('$sum' => '$pop'),
        ),
    ),
    array(
        '$match' => array(
            'totalPop' => array('$gte' => 10 * 1000 * 1000)
        )
    ),
    array(
        '$sort' => array("totalPop" => -1),
    ),
);

$options = array("explain" => true);
$out = $c->aggregate($pipeline, $options);
var_dump($out);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(2) {
  ["stages"]=>
  array(4) {
    [0]=>
    array(1) {
      ["$cursor"]=>
      array(3) {
        ["query"]=>
        array(0) {
        }
        ["fields"]=>
        array(3) {
          ["pop"]=>
          int(1)
          ["state"]=>
          int(1)
          ["_id"]=>
          int(0)
        }
        ["plan"]=>
        array(4) {
          ["cursor"]=>
          string(11) "BasicCursor"
          ["isMultiKey"]=>
          bool(false)
          ["scanAndOrder"]=>
          bool(false)
          ["allPlans"]=>
          array(1) {
            [0]=>
            array(3) {
              ["cursor"]=>
              string(11) "BasicCursor"
              ["isMultiKey"]=>
              bool(false)
              ["scanAndOrder"]=>
              bool(false)
            }
          }
        }
      }
    }
    [1]=>
    array(1) {
      ["$group"]=>
      array(2) {
        ["_id"]=>
        string(6) "$state"
        ["totalPop"]=>
        array(1) {
          ["$sum"]=>
          string(4) "$pop"
        }
      }
    }
    [2]=>
    array(1) {
      ["$match"]=>
      array(1) {
        ["totalPop"]=>
        array(1) {
          ["$gte"]=>
          int(10000000)
        }
      }
    }
    [3]=>
    array(1) {
      ["$sort"]=>
      array(1) {
        ["sortKey"]=>
        array(1) {
          ["totalPop"]=>
          int(-1)
        }
      }
    }
  }
  ["ok"]=>
  float(1)
}

Ayrıca Bakınız

  • MongoCollection::aggregateCursor() - Execute an aggregation pipeline command and retrieve results through a cursor
  • The MongoDB » aggregation framework
MongoCollection
MongoCollection::aggregateCursor
MongoCollection


Execute an aggregation pipeline command and retrieve results through a cursor

MongoCollection::aggregate
MongoCollection::batchInsert
MongoCollection
PHP Manual

MongoCollection::aggregateCursor

(PECL mongo >=1.5.0)

MongoCollection::aggregateCursor — Execute an aggregation pipeline command and retrieve results through a cursor

Açıklama

public MongoCommandCursor MongoCollection::aggregateCursor ( array $command [, array $options ] )

With this method you can execute Aggregation Framework pipelines and retrieve the results through a cursor, instead of getting just one document back as you would with MongoCollection::aggregate(). This method returns a MongoCommandCursor object. This cursor object implements the Iterator interface just like the MongoCursor objects that are returned by the MongoCollection::find() method.

Bilginize: The resulting MongoCommandCursor will inherit this collection's read preference. MongoCommandCursor::setReadPreference() may be used to change the read preference before iterating on the cursor.

Değiştirgeler

pipeline

The Aggregation Framework pipeline to execute.

options

Options for the aggregation command. Valid options include:

  • "allowDiskUse"

    Allow aggregation stages to write to temporary files

  • "cursor"

    It is possible to configure how many initial documents the server should return with the first result set. The default initial batch size is 101. You can change it by adding the batchSize option:

    <?php
    $collection    ->aggregateCursor(
            $pipeline,
        [     "cursor" => [ "batchSize" => 4 ] ]
    );

    This option only configures the size of the first batch. To configure the size of future batches, please use the MongoCommandCursor::batchSize() method on the returned MongoCommandCursor object.

  • "explain"

    Return information on the processing of the pipeline. This option may cause the command to return a result document that is unsuitable for constructing a MongoCommandCursor. If you need to use this option, you should consider using MongoCollection::aggregate().

  • "maxTimeMS"

    Specifies a cumulative time limit in milliseconds for processing the operation (does not include idle time). If the operation is not completed within the timeout period, a MongoExecutionTimeoutException will be thrown.

Dönen Değerler

Returns a MongoCommandCursor object. Because this implements the Iterator interface you can iterate over each of the results as returned by the command query. The MongoCommandCursor also implements the MongoCursorInterface interface which adds the MongoCommandCursor::batchSize(), MongoCommandCursor::dead(), MongoCommandCursor::info() methods.

Örnekler

Örnek 1 MongoCollection::aggregateCursor() example

Finding all of the distinct values for a key.

<?php
$m = new MongoClient;
$db = $m->test;
$people = $db->people;
$people->drop();

$people->insert(array("name" => "Joe", "points" => 4));
$people->insert(array("name" => "Molly", "points" => 43));
$people->insert(array("name" => "Sally", "points" => 22));
$people->insert(array("name" => "Joe", "points" => 22));
$people->insert(array("name" => "Molly", "points" => 87));

$ages = $people->aggregateCursor( [
        [ '$group' => [ '_id' => '$name', 'points' => [ '$sum' => '$points' ] ] ],
        [ '$sort' => [ 'points' => -1 ] ],
] );

foreach ($ages as $person) {
    echo "{$person['_id']}: {$person['points']}\n";
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Molly: 130
Joe: 26
Sally: 22

Örnek 2 MongoCollection::aggregateCursor() example with different initial batch size

Finding all of the distinct values for a key.

<?php
$m = new MongoClient;
$db = $m->test;
$people = $db->people;
$people->drop();

/* Insert some sample data */
$people->insert(array("name" => "Joe", "points" => 4));
$people->insert(array("name" => "Molly", "points" => 43));
$people->insert(array("name" => "Sally", "points" => 22));
$people->insert(array("name" => "Joe", "points" => 22));
$people->insert(array("name" => "Molly", "points" => 87));

/* Run the command cursor */
$ages = $people->aggregateCursor(
    [
        [ '$group' => [ '_id' => '$name', 'points' => [ '$sum' => '$points' ] ] ],
        [ '$sort' => [ 'points' => -1 ] ],
    ],
    [ "cursor" => [ "batchSize" => 4 ] ]
);

foreach ($ages as $person) {
    echo "{$person['_id']}: {$person['points']}\n";
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Molly: 130
Joe: 26
Sally: 22

Ayrıca Bakınız

  • MongoDB::command() - Execute a database command
  • MongoCommandCursor
  • MongoCommandCursor::batchSize() - Limits the number of elements returned in one batch.
  • MongoCollection::aggregate() - Perform an aggregation using the aggregation framework
  • The MongoDB » aggregation framework

MongoCollection::aggregate
MongoCollection::batchInsert
MongoCollection


Inserts multiple documents into this collection

MongoCollection::aggregateCursor
MongoCollection::__construct
MongoCollection
PHP Manual

MongoCollection::batchInsert

(PECL mongo >=0.9.0)

MongoCollection::batchInsert — Inserts multiple documents into this collection

Açıklama

public mixed MongoCollection::batchInsert ( array $a [, array $options = array() ] )

Değiştirgeler

a

An array of arrays or objects. If any objects are used, they may not have protected or private properties.

Bilginize:

If the documents to insert do not have an _id key or property, a new MongoId instance will be created and assigned to it. See MongoCollection::insert() for additional information on this behavior.

options

An array of options for the batch of insert operations. Currently available options include:

  • "continueOnError"

    Boolean, defaults to FALSE. If set, the database will not stop processing a bulk insert if one fails (eg due to duplicate IDs). This makes bulk insert behave similarly to a series of single inserts, except that calling MongoDB::lastError() will have an error set if any insert fails, not just the last one. If multiple errors occur, only the most recent will be reported by MongoDB::lastError().

    Bilginize:

    Please note that continueOnError affects errors on the database side only. If you try to insert a document that has errors (for example it contains a key with an empty name), then the document is not even transferred to the database as the driver detects this error and bails out. continueOnError has no effect on errors detected in the documents by the driver.

  • "fsync"

    Boolean, defaults to FALSE. If journaling is enabled, it works exactly like "j". If journaling is not enabled, the write operation blocks until it is synced to database files on disk. If TRUE, an acknowledged insert is implied and this option will override setting "w" to 0.

    Bilginize: If journaling is enabled, users are strongly encouraged to use the "j" option instead of "fsync". Do not use "fsync" and "j" simultaneously, as that will result in an error.

  • "j"

    Boolean, defaults to FALSE. Forces the write operation to block until it is synced to the journal on disk. If TRUE, an acknowledged write is implied and this option will override setting "w" to 0.

    Bilginize: If this option is used and journaling is disabled, MongoDB 2.6+ will raise an error and the write will fail; older server versions will simply ignore the option.

  • "socketTimeoutMS"

    This option specifies the time limit, in milliseconds, for socket communication. If the server does not respond within the timeout period, a MongoCursorTimeoutException will be thrown and there will be no way to determine if the server actually handled the write or not. A value of -1 may be specified to block indefinitely. The default value for MongoClient is 30000 (30 seconds).

  • "w"

    See Write Concerns. The default value for MongoClient is 1.

  • "wTimeoutMS"

    This option specifies the time limit, in milliseconds, for write concern acknowledgement. It is only applicable when "w" is greater than 1, as the timeout pertains to replication. If the write concern is not satisfied within the time limit, a MongoCursorException will be thrown. A value of 0 may be specified to block indefinitely. The default value for MongoClient is 10000 (ten seconds).

The following options are deprecated and should no longer be used:

  • "safe"

    Deprecated. Please use the write concern "w" option.

  • "timeout"

    Deprecated alias for "socketTimeoutMS".

  • "wtimeout"

    Deprecated alias for "wTimeoutMS".

Dönen Değerler

If the w parameter is set to acknowledge the write, returns an associative array with the status of the inserts ("ok") and any error that may have occurred ("err"). Otherwise, returns TRUE if the batch insert was successfully sent, FALSE otherwise.

Hatalar/İstisnalar

Throws MongoException if any inserted documents are empty or if they contains zero-length keys. Attempting to insert an object with protected and private properties will cause a zero-length key error.

Throws MongoCursorException if the "w" option is set and the write fails.

Throws MongoCursorTimeoutException if the "w" option is set to a value greater than one and the operation takes longer than MongoCursor::$timeout milliseconds to complete. This does not kill the operation on the server, it is a client-side timeout. The operation in MongoCollection::$wtimeout is milliseconds.

Sürüm Bilgisi

Sürüm: | Açıklama
1.5.0 | Added the "wTimeoutMS" option, which replaces "wtimeout". Emits E_DEPRECATED when "wtimeout" is used. Added the "socketTimeoutMS" option, which replaces "timeout". Emits E_DEPRECATED when "timeout" is used. Emits E_DEPRECATED when "safe" is used.
1.3.4 | Added "wtimeout" option.
1.3.0 | Added "w" option.
1.2.7 | Added "continueOnError" option.
1.0.9 | Added ability to pass integers to the "safe" option, which previously only accepted booleans. Added "fsync" option.
1.0.5 | Added options parameter.

Örnekler

Örnek 1 MongoCollection::batchInsert() example

Batch insertion is a quick way to add many elements to the database at once

<?php

$users = array();
for ($i = 0; $i<100; $i++) {
  $users[] = array('username' => 'user'.$i, 'i' => $i);
}

$mongo = new MongoClient();
$collection = $mongo->my_db->users;
$collection->drop();

$collection->batchInsert($users);

foreach ($users as $user) {
  echo $user['_id']."\n"; // populated with instanceof MongoId
}

$users = $collection->find()->sort(array('i' => 1));
foreach ($users as $user) {
    var_dump($user['username']);
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

4bf43ac68ead0e1971000000
4bf43ac68ead0e1971010000
4bf43ac68ead0e1971020000
...
string(5) "user1"
string(5) "user2"
string(5) "user3"
...

Örnek 2 MongoCollection::batchInsert() example with ignoring errors

<?php

$con = new Mongo;
$db = $con->demo;

$doc1 = array(
        '_id' => new MongoId('4cb4ab6d7addf98506010001'),
        'id' => 1,
        'desc' => "ONE",
);
$doc2 = array(
        '_id' => new MongoId('4cb4ab6d7addf98506010002'),
        'id' => 2,
        'desc' => "TWO",
);
$doc3 = array(
        '_id' => new MongoId('4cb4ab6d7addf98506010002'), // same _id as above
        'id' => 3,
        'desc' => "THREE",
);
$doc4 = array(
        '_id' => new MongoId('4cb4ab6d7addf98506010004'),
        'id' => 4,
        'desc' => "FOUR",
);

$c = $db->selectCollection('c');
$c->batchInsert(
    array($doc1, $doc2, $doc3, $doc4),
    array('continueOnError' => true)
);

$docs = $c->find();
foreach ($docs as $doc) {
    var_dump($doc['desc']);
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(3) "ONE"
string(3) "TWO"
string(4) "FOUR"

Ayrıca Bakınız

  • MongoCollection::insert() - Inserts a document into the collection
  • MongoCollection::update() - Update records based on a given criteria
  • MongoCollection::find() - Queries this collection, returning a MongoCursor for the result set
  • MongoCollection::remove() - Remove records from this collection
  • MongoDB core docs on » insert.
MongoCollection::aggregateCursor
MongoCollection::__construct
MongoCollection


Creates a new collection

MongoCollection::batchInsert
MongoCollection::count
MongoCollection
PHP Manual

MongoCollection::__construct

(PECL mongo >=0.9.0)

MongoCollection::__construct — Creates a new collection

Açıklama

public MongoCollection::__construct ( MongoDB $db , string $name )

Değiştirgeler

MongoDB db

Parent database.

name

Name for this collection.

Dönen Değerler

Returns a new collection object.

Hatalar/İstisnalar

Throws default exception if the collection name is invalid.

MongoCollection::batchInsert
MongoCollection::count
MongoCollection


Counts the number of documents in this collection

MongoCollection::__construct
MongoCollection::createDBRef
MongoCollection
PHP Manual

MongoCollection::count

(PECL mongo >=0.9.0)

MongoCollection::count — Counts the number of documents in this collection

Açıklama

 public int MongoCollection::count
  ([ array $query = array()
 [, array $options = array()
]] )

Değiştirgeler

query

Associative array or object with fields to match.

options

An array of options for the index creation. Currently available options include:

İsim | Tür | Açıklama
hint mixed

Index to use for the query. If a string is passed, it should correspond to an index name. If an array or object is passed, it should correspond to the specification used to create the index (i.e. the first argument to MongoCollection::createIndex()).

This option is only supported in MongoDB 2.6+.
limit | integer | The maximum number of matching documents to return.
maxTimeMS integer

Specifies a cumulative time limit in milliseconds for processing the operation (does not include idle time). If the operation is not completed within the timeout period, a MongoExecutionTimeoutException will be thrown.

This option is only supported in MongoDB 2.6+.
skip | integer | The number of matching documents to skip before returning results.

Dönen Değerler

Returns the number of documents matching the query.

Hatalar/İstisnalar

Throws MongoResultException if the server could not execute the command due to an error.

Throws MongoExecutionTimeoutException if command execution was terminated due to maxTimeMS.

Sürüm Bilgisi

Sürüm: | Açıklama
1.6.0 | The second parameter is now an options array. Passing limit and skip as the second and third parameters, respectively, is deprecated.
1.0.7 | Added limit and skip as second and third parameters, respectively.

Örnekler

Örnek 1 MongoCollection::count() example

<?php

$collection->insert(array('x'=>1));
$collection->insert(array('x'=>2));
$collection->insert(array('x'=>3));

var_dump($collection->count());
var_dump($collection->count(array('x'=>1)));

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(3)
int(1)
MongoCollection::__construct
MongoCollection::createDBRef
MongoCollection


Creates a database reference

MongoCollection::count
MongoCollection::createIndex
MongoCollection
PHP Manual

MongoCollection::createDBRef

(PECL mongo >=0.9.0)

MongoCollection::createDBRef — Creates a database reference

Açıklama

public array MongoCollection::createDBRef ( mixed $document_or_id )

Değiştirgeler

document_or_id

If an array or object is given, its _id field will be used as the reference ID. If a MongoId or scalar is given, it will be used as the reference ID.

Dönen Değerler

Returns a database reference array.

If an array without an _id field was provided as the document_or_id parameter, NULL will be returned.

Örnekler

Örnek 1 MongoCollection::createDBRef() example

<?php

$songs = $db->songs;
$playlists = $db->playlists;

// create a reference to a song
$manamana = $songs->findOne(array('title' => 'Ma na ma na'));
$refToSong = $songs->createDBRef($manamana);

// add the reference to my playlist
$playlists->update(array('username' => 'me'), array('$push' => array('songlist' => $refToSong)));

?>

Ayrıca Bakınız

  • MongoCollection::getDBRef() - Fetches the document pointed to by a database reference

MongoCollection::count
MongoCollection::createIndex
MongoCollection


Creates an index on the specified field(s) if it does not already exist.

MongoCollection::createDBRef
MongoCollection::deleteIndex
MongoCollection
PHP Manual

MongoCollection::createIndex

(PECL mongo >=1.5.0)

MongoCollection::createIndex — Creates an index on the specified field(s) if it does not already exist.

Açıklama

public bool MongoCollection::createIndex ( array $keys [, array $options = array() ] )

Creates an index on the specified field(s) if it does not already exist. Fields may be indexed with a direction (e.g. ascending or descending) or a special type (e.g. text, geospatial, hashed).

Bilginize:

This method will use the » createIndexes database command when communicating with MongoDB 2.6+. For previous database versions, the method will perform an insert operation on the special system.indexes collection.

Değiştirgeler

keys

An array specifying the index's fields as its keys. For each field, the value is either the index direction or » index type. If specifying direction, specify 1 for ascending or -1 for descending.

options

An array of options for the index creation. We pass all given options straight to the server, but a non-exhaustive list of currently available options include:

  • "unique"

    Specify TRUE to create a unique index. The default value is FALSE. This option applies only to ascending/descending indexes.

    Bilginize:

    When MongoDB indexes a field, if a document does not have a value for the field, a NULL value is indexed. If multiple documents do not contain a field, a unique index will reject all but the first of those documents. The "sparse" option may be used to overcome this, since it will prevent documents without the field from being indexed.

  • "sparse"

    Specify TRUE to create a sparse index, which only indexes documents containing a specified field. The default value is FALSE.

  • "expireAfterSeconds"

    The value of this option should specify the number of seconds after which a document should be considered expired and automatically removed from the collection. This option is only compatible with single-field indexes where the field will contain MongoDate values.

    Bilginize:

    This feature is available in MongoDB 2.2+. See » Expire Data from Collections by Setting TTL for more information.

  • "name"

    A optional name that uniquely identifies the index.

    Bilginize:

    By default, the driver will generate an index name based on the index's field(s) and ordering or type. For example, a compound index array("x" => 1, "y" => -1) would be named "x_1_y_-1" and a geospatial index array("loc" => "2dsphere") would be named "loc_2dsphere". For indexes with many fields, it is possible that the generated name might exceed MongoDB's » limit for index names. The "name" option may be used in that case to supply a shorter name.

  • "background"

    Builds the index in the background so that building an index does not block other database activities. Specify TRUE to build in the background. The default value is FALSE.

    Uyarı

    Prior to MongoDB 2.6.0, index builds on secondaries were executed as foreground operations, irrespective of this option. See » Building Indexes with Replica Sets for more information.

  • "socketTimeoutMS"

    This option specifies the time limit, in milliseconds, for socket communication. If the server does not respond within the timeout period, a MongoCursorTimeoutException will be thrown and there will be no way to determine if the server actually handled the write or not. A value of -1 may be specified to block indefinitely. The default value for MongoClient is 30000 (30 seconds).

The following option may be used with MongoDB 2.6+:

  • "maxTimeMS"

    Specifies a cumulative time limit in milliseconds for processing the operation (does not include idle time). If the operation is not completed within the timeout period, a MongoExecutionTimeoutException will be thrown.

The following options may be used with MongoDB versions before 2.8:

  • "dropDups"

    Specify TRUE to force creation of a unique index where the collection may contain duplicate values for a key. MongoDB will index the first occurrence of a key and delete all subsequent documents from the collection that contain a duplicate value for that key. The default value is FALSE.

    Uyarı

    "dropDups" may delete data from your database. Use with extreme caution.

    Bilginize:

    This option is not supported on MongoDB 2.8+. Index creation will fail if the collection contains duplicate values.

The following options may be used with MongoDB versions before 2.6:

  • "w"

    See Write Concerns. The default value for MongoClient is 1.

  • "wTimeoutMS"

    This option specifies the time limit, in milliseconds, for write concern acknowledgement. It is only applicable when "w" is greater than 1, as the timeout pertains to replication. If the write concern is not satisfied within the time limit, a MongoCursorException will be thrown. A value of 0 may be specified to block indefinitely. The default value for MongoClient is 10000 (ten seconds).

The following options are deprecated and should no longer be used:

  • "safe"

    Deprecated. Please use the write concern "w" option.

  • "timeout"

    Deprecated alias for "socketTimeoutMS".

  • "wtimeout"

    Deprecated alias for "wTimeoutMS".

Dönen Değerler

Returns an array containing the status of the index creation. The array contains whether the operation succeeded ("ok"), the number of indexes before and after the operation ("numIndexesBefore" and "numIndexesAfter"), and whether the collection that the index belongs to has been created ("createdCollectionAutomatically"). If the index already existed and did not need to be created, a "note" field may be present in lieu of "numIndexesAfter".

With MongoDB 2.4 and earlier, a status document is only returned if the write concern is at least 1. Otherwise, TRUE is returned. The fields in the status document are different, except for the "ok" field, which signals whether the index creation was successful. Additional fields are described in the documentation for MongoCollection::insert().

Hatalar/İstisnalar

Throws MongoException if the index name is longer than 128 bytes, or if the index specification is not an array.

Throws MongoDuplicateKeyException if the server could not create the unique index due to conflicting documents.

Throws MongoResultException if the server could not create the index due to an error.

Throws MongoCursorException if the "w" option is set and the write fails.

Throws MongoCursorTimeoutException if the "w" option is set to a value greater than one and the operation takes longer than MongoCursor::$timeout milliseconds to complete. This does not kill the operation on the server, it is a client-side timeout. The operation in MongoCollection::$wtimeout is milliseconds.

Örnekler

Örnek 1 MongoCollection::createIndex() example

<?php

$c = new MongoCollection($db, 'foo');

// create an index on 'x' ascending
$c->createIndex(array('x' => 1));

// create a unique index on 'y'
$c->createIndex(array('y' => 1), array('unique' => true));

// create a compound index on 'za' ascending and 'zb' descending
$c->createIndex(array('za' => 1, 'zb' => -1));

?>

Örnek 2 Geospatial Indexing

Mongo supports geospatial indexes, which allow you to search for documents near a given location or within a shape. The following example creates a geospatial index on the "loc" field:

<?php

$collection->createIndex(array('loc' => '2dsphere'));

?>

Örnek 3 Drop duplicates example

<?php

$collection->insert(array('username' => 'joeschmoe'));
$collection->insert(array('username' => 'joeschmoe'));

/* Index creation fails, since you cannot create a unique index on a field when
 * duplicates exist.
 */
$collection->createIndex(array('username' => 1), array('unique' => 1));

/* MongoDB will one of the conflicting documents and allow the unique index to
 * be created.
 */
$collection->createIndex(array('username' => 1), array('unique' => 1, 'dropDups' => 1));

/* We now have a unique index and subsequent inserts with the same username will
 * fail.
 */
$collection->insert(array('username' => 'joeschmoe'));

?>

Ayrıca Bakınız

  • MongoCollection::deleteIndex() - Deletes an index from this collection
  • MongoCollection::deleteIndexes() - Delete all indices for this collection
  • The MongoDB » index and » index type documentation.
MongoCollection::createDBRef
MongoCollection::deleteIndex
MongoCollection


Deletes an index from this collection

MongoCollection::createIndex
MongoCollection::deleteIndexes
MongoCollection
PHP Manual

MongoCollection::deleteIndex

(PECL mongo >=0.9.0)

MongoCollection::deleteIndex — Deletes an index from this collection

Açıklama

public array MongoCollection::deleteIndex ( string|array $keys )

This method is identical to:

<?php

public function deleteIndexes($keys) {
  $indexName = $this->toIndexString($keys);

  return $this->db->command(array(
    "deleteIndexes" => $this->getName(),
    "index" => $indexName,
  ));
}

?>

Each index is given a unique name when it is created. This is often generated by the driver based on the index key(s) and order/type, but custom names may also be specified with MongoCollection::createIndex()'s "name" option).

Unfortunately, MongoCollection::deleteIndex() cannot delete custom-named indexes due to a backwards compatibility issue. When a string argument is provided, it is assumed to be the single field name in an ascending index (e.g. the name "x_1" would be used for the argument "x"). If an array or object is provided, an index name is generated just as if that argument was passed to MongoCollection::createIndex().

In order to delete a custom-named index with the PHP driver, the deleteIndexes database command must be used. For instance, an index named "myIndex" could be deleted with the PHP driver by running:

<?php

$db->command(array(
  "deleteIndexes" => $collection->getName(),
  "index" => "myIndex",
));

?>

To determine the name of an index with the PHP driver, you can query the system.indexes collection of a database and look for the "name" field of each result. The "ns" field will indicate the collection to which each index belongs.

Değiştirgeler

keys

An array specifying the index's fields as its keys. For each field, the value is either the index direction or » index type. If specifying direction, specify 1 for ascending or -1 for descending.

If a string is provided, it is assumed to be the single field name in an ascending index.

Dönen Değerler

Returns the database response.

Örnekler

Örnek 1 MongoCollection::deleteIndex() example

This example passes the function string and array parameters.

<?php

$m = new MongoClient();
$c = $m->example->indices;

// create and remove a simple index
$c->createIndex(array("i"=>1));
$c->deleteIndex("i");

// create and remove a multi-key index
$c->ensureIndex(array("j" => 1, "k" => 1));
$c->deleteIndex(array("j" => 1, "k" => 1));

?>

Ayrıca Bakınız

  • MongoCollection::createIndex() - Creates an index on the specified field(s) if it does not already exist.
  • MongoCollection::deleteIndexes() - Delete all indices for this collection
  • MongoCollection::toIndexString() - Converts keys specifying an index to its identifying string
  • The MongoDB » index and » index type documentation.
MongoCollection::createIndex
MongoCollection::deleteIndexes
MongoCollection


Delete all indices for this collection

MongoCollection::deleteIndex
MongoCollection::distinct
MongoCollection
PHP Manual

MongoCollection::deleteIndexes

(PECL mongo >=0.9.0)

MongoCollection::deleteIndexes — Delete all indices for this collection

Açıklama

public array MongoCollection::deleteIndexes ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the database response.

Örnekler

Örnek 1 MongoCollection::deleteIndexes() example

This example demonstrates how to delete all indexes from a collection and the response to expect.

<?php

$collection = $mongo->my_db->articles;
$response = $collection->deleteIndexes();
print_r($response);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [nIndexesWas] => 1
    [msg] => all indexes deleted for collection
    [ok] => 1
)

Ayrıca Bakınız

  • MongoCollection::createIndex() - Creates an index on the specified field(s) if it does not already exist.
  • MongoCollection::deleteIndex() - Deletes an index from this collection
MongoCollection::deleteIndex
MongoCollection::distinct
MongoCollection


Retrieve a list of distinct values for the given key across a collection.

MongoCollection::deleteIndexes
MongoCollection::drop
MongoCollection
PHP Manual

MongoCollection::distinct

(PECL mongo >=1.2.11)

MongoCollection::distinct — Retrieve a list of distinct values for the given key across a collection.

Açıklama

public array MongoCollection::distinct ( string $key [, array $query ] )

The distinct command returns a list of distinct values for the given key across a collection.

Değiştirgeler

key

The key to use.

query

An optional query parameters

Dönen Değerler

Returns an array of distinct values, başarısızlık durumunda FALSE döner

Örnekler

Örnek 1 MongoCollection::distinct() example

<?php
$m = new Mongo;
$db = $m->selectDB("test");
$db->dropCollection("distinct");
$c = $db->distinct;

$c->insert(array("stuff" => "bar", "zip-code" => 10010));
$c->insert(array("stuff" => "foo", "zip-code" => 10010));
$c->insert(array("stuff" => "bar", "zip-code" => 99701), array("w" => 1));

$retval = $c->distinct("zip-code");
var_dump($retval);

$retval = $c->distinct("zip-code", array("stuff" => "foo"));
var_dump($retval);

$retval = $c->distinct("zip-code", array("stuff" => "bar"));
var_dump($retval);

?>

Yukarıdaki örneğin çıktısı:

array(2) {
  [0]=>
  int(10010)
  [1]=>
  int(99701)
}
array(1) {
  [0]=>
  int(10010)
}
array(2) {
  [0]=>
  int(10010)
  [1]=>
  int(99701)
}

Örnek 2 MongoCollection::distinct() example on a embedded document

<?php
$c->insert(array("user" => array("points" => 25)));
$c->insert(array("user" => array("points" => 31)));
$c->insert(array("user" => array("points" => 25)));

$retval = $c->distinct("user.points");
var_dump($retval);

$retval = $c->distinct("user.nonexisting");
var_dump($retval);
?>

Yukarıdaki örneğin çıktısı:

array(2) {
  [0]=>
  int(25)
  [1]=>
  int(31)
}
array(0) {
}
MongoCollection::deleteIndexes
MongoCollection::drop
MongoCollection


Drops this collection

MongoCollection::distinct
MongoCollection::ensureIndex
MongoCollection
PHP Manual

MongoCollection::drop

(PECL mongo >=0.9.0)

MongoCollection::drop — Drops this collection

Açıklama

public array MongoCollection::drop ( void )

Drops this collection and deletes its indices.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the database response.

Örnekler

Örnek 1 MongoCollection::drop() example

This example demonstrates how to drop a collection and the response to expect.

<?php

$collection = $mongo->my_db->articles;
$response = $collection->drop();
print_r($response);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [nIndexesWas] => 1
    [msg] => all indexes deleted for collection
    [ns] => my_db.articles
    [ok] => 1
)
MongoCollection::distinct
MongoCollection::ensureIndex
MongoCollection


Creates an index on the specified field(s) if it does not already exist.

MongoCollection::drop
MongoCollection::find
MongoCollection
PHP Manual

MongoCollection::ensureIndex

(PECL mongo >=0.9.0)

MongoCollection::ensureIndex — Creates an index on the specified field(s) if it does not already exist.

Açıklama

public bool MongoCollection::ensureIndex ( string|array $key|keys [, array $options = array() ] )
Uyarı

This method is deprecated since version 1.5.0. Please use MongoCollection::createIndex() instead.

Creates an index on the specified field(s) if it does not already exist. Fields may be indexed with a direction (e.g. ascending or descending) or a special type (e.g. text, geospatial, hashed).

Bilginize:

This method will use the » createIndexes database command when communicating with MongoDB 2.6+. For previous database versions, the method will perform an insert operation on the special system.indexes collection.

Değiştirgeler

keys

An array specifying the index's fields as its keys. For each field, the value is either the index direction or » index type. If specifying direction, specify 1 for ascending or -1 for descending.

options

An array of options for the index creation. Currently available options include:

  • "unique"

    Specify TRUE to create a unique index. The default value is FALSE. This option applies only to ascending/descending indexes.

    Bilginize:

    When MongoDB indexes a field, if a document does not have a value for the field, a NULL value is indexed. If multiple documents do not contain a field, a unique index will reject all but the first of those documents. The "sparse" option may be used to overcome this, since it will prevent documents without the field from being indexed.

  • "sparse"

    Specify TRUE to create a sparse index, which only indexes documents containing a specified field. The default value is FALSE.

  • "expireAfterSeconds"

    The value of this option should specify the number of seconds after which a document should be considered expired and automatically removed from the collection. This option is only compatible with single-field indexes where the field will contain MongoDate values.

    Bilginize:

    This feature is available in MongoDB 2.2+. See » Expire Data from Collections by Setting TTL for more information.

  • "name"

    A optional name that uniquely identifies the index.

    Bilginize:

    By default, the driver will generate an index name based on the index's field(s) and ordering or type. For example, a compound index array("x" => 1, "y" => -1) would be named "x_1_y_-1" and a geospatial index array("loc" => "2dsphere") would be named "loc_2dsphere". For indexes with many fields, it is possible that the generated name might exceed MongoDB's » limit for index names. The "name" option may be used in that case to supply a shorter name.

  • "background"

    Builds the index in the background so that building an index does not block other database activities. Specify TRUE to build in the background. The default value is FALSE.

    Uyarı

    Prior to MongoDB 2.6.0, index builds on secondaries were executed as foreground operations, irrespective of this option. See » Building Indexes with Replica Sets for more information.

  • "socketTimeoutMS"

    This option specifies the time limit, in milliseconds, for socket communication. If the server does not respond within the timeout period, a MongoCursorTimeoutException will be thrown and there will be no way to determine if the server actually handled the write or not. A value of -1 may be specified to block indefinitely. The default value for MongoClient is 30000 (30 seconds).

The following option may be used with MongoDB 2.6+:

  • "maxTimeMS"

    Specifies a cumulative time limit in milliseconds for processing the operation (does not include idle time). If the operation is not completed within the timeout period, a MongoExecutionTimeoutException will be thrown.

The following options may be used with MongoDB versions before 2.8:

  • "dropDups"

    Specify TRUE to force creation of a unique index where the collection may contain duplicate values for a key. MongoDB will index the first occurrence of a key and delete all subsequent documents from the collection that contain a duplicate value for that key. The default value is FALSE.

    Uyarı

    "dropDups" may delete data from your database. Use with extreme caution.

    Bilginize:

    This option is not supported on MongoDB 2.8+. Index creation will fail if the collection contains duplicate values.

The following options may be used with MongoDB versions before 2.6:

  • "w"

    See Write Concerns. The default value for MongoClient is 1.

  • "wTimeoutMS"

    This option specifies the time limit, in milliseconds, for write concern acknowledgement. It is only applicable when "w" is greater than 1, as the timeout pertains to replication. If the write concern is not satisfied within the time limit, a MongoCursorException will be thrown. A value of 0 may be specified to block indefinitely. The default value for MongoClient is 10000 (ten seconds).

The following options are deprecated and should no longer be used:

  • "safe"

    Deprecated. Please use the write concern "w" option.

  • "timeout"

    Deprecated alias for "socketTimeoutMS".

  • "wtimeout"

    Deprecated alias for "wTimeoutMS".

Dönen Değerler

Returns an array containing the status of the index creation. The array contains whether the operation succeeded ("ok"), the number of indexes before and after the operation ("numIndexesBefore" and "numIndexesAfter"), and whether the collection that the index belongs to has been created ("createdCollectionAutomatically"). If the index already existed and did not need to be created, a "note" field may be present in lieu of "numIndexesAfter".

With MongoDB 2.4 and earlier, a status document is only returned if the write concern is at least 1. Otherwise, TRUE is returned. The fields in the status document are different, except for the "ok" field, which signals whether the index creation was successful. Additional fields are described in the documentation for MongoCollection::insert().

Sürüm Bilgisi

Sürüm: | Açıklama
1.5.0 | Renamed the "wtimeout" option to "wTimeoutMS". Emits E_DEPRECATED when "wtimeout" is used. Renamed the "timeout" option to "socketTimeoutMS". Emits E_DEPRECATED when "timeout" is used. Emits E_DEPRECATED when "safe" is used.
1.3.4 | Added "wtimeout" option.
1.3.0 | Added "w" option. The options parameter no longer accepts a boolean to signify a unique index. Instead, this now has to be done with array('unique' => true).
1.2.11 | Emits E_DEPRECATED when options is scalar.
1.2.0 | Added "timeout" option.
1.0.11 | The "safe" option will trigger a primary failover, if necessary. MongoException will be thrown if the index name (either generated or set) is longer than 128 bytes.
1.0.5 | Added the "name" option to override index name creation.
1.0.2 | Changed options parameter from boolean to array. Pre-1.0.2, the second parameter was an optional boolean value specifying a unique index.

Hatalar/İstisnalar

Throws MongoException if the index name is longer than 128 bytes, or if the index specification is not an array.

Throws MongoDuplicateKeyException if the server could not create the unique index due to conflicting documents.

Throws MongoResultException if the server could not create the index due to an error.

Throws MongoCursorException if the "w" option is set and the write fails.

Throws MongoCursorTimeoutException if the "w" option is set to a value greater than one and the operation takes longer than MongoCursor::$timeout milliseconds to complete. This does not kill the operation on the server, it is a client-side timeout. The operation in MongoCollection::$wtimeout is milliseconds.

Örnekler

Örnek 1 MongoCollection::ensureIndex() example

<?php

$c = new MongoCollection($db, 'foo');

// create an index on 'x' ascending
$c->ensureIndex(array('x' => 1));

// create a unique index on 'y'
$c->ensureIndex(array('y' => 1), array('unique' => true));

// create a compound index on 'za' ascending and 'zb' descending
$c->ensureIndex(array('za' => 1, 'zb' => -1));

?>

Örnek 2 Geospatial Indexing

Mongo supports geospatial indexes, which allow you to search for documents near a given location or within a shape. The following example creates a geospatial index on the "loc" field:

<?php

$collection->ensureIndex(array('loc' => '2dsphere'));

?>

Örnek 3 Drop duplicates example

<?php

$collection->insert(array('username' => 'joeschmoe'));
$collection->insert(array('username' => 'joeschmoe'));

/* Index creation fails, since you cannot create a unique index on a field when
 * duplicates exist.
 */
$collection->ensureIndex(array('username' => 1), array('unique' => 1));

/* MongoDB will one of the conflicting documents and allow the unique index to
 * be created.
 */
$collection->ensureIndex(array('username' => 1), array('unique' => 1, 'dropDups' => 1));

/* We now have a unique index and subsequent inserts with the same username will
 * fail.
 */
$collection->insert(array('username' => 'joeschmoe'));

?>

Ayrıca Bakınız

  • MongoCollection::createIndex() - Creates an index on the specified field(s) if it does not already exist.
  • MongoCollection::deleteIndex() - Deletes an index from this collection
  • MongoCollection::deleteIndexes() - Delete all indices for this collection
  • The MongoDB » index and » index type documentation.
MongoCollection::drop
MongoCollection::find
MongoCollection


Queries this collection, returning a MongoCursor for the result set

MongoCollection::ensureIndex
MongoCollection::findAndModify
MongoCollection
PHP Manual

MongoCollection::find

(PECL mongo >=0.9.0)

MongoCollection::find — Queries this collection, returning a MongoCursor for the result set

Açıklama

 public MongoCursor MongoCollection::find
  ([ array $query = array()
 [, array $fields = array()
]] )

Değiştirgeler

query

The fields for which to search. MongoDB's query language is quite extensive. The PHP driver will in almost all cases pass the query straight through to the server, so reading the MongoDB core docs on » find is a good idea.

Uyarı

Please make sure that for all special query operators (starting with $) you use single quotes so that PHP doesn't try to replace "$exists" with the value of the variable $exists.

fields

Fields of the results to return. The array is in the format array('fieldname' => true, 'fieldname2' => true). The _id field is always returned.

Dönen Değerler

Returns a cursor for the search results.

Örnekler

Örnek 1 MongoCollection::find() example

This example demonstrates basic search options.

<?php

$m = new MongoClient();
$db = $m->selectDB('test');
$collection = new MongoCollection($db, 'produce');

// search for fruits
$fruitQuery = array('Type' => 'Fruit');

$cursor = $collection->find($fruitQuery);
foreach ($cursor as $doc) {
    var_dump($doc);
}

// search for produce that is sweet. Taste is a child of Details.
$sweetQuery = array('Details.Taste' => 'Sweet');
echo "Sweet\n";
$cursor = $collection->find($sweetQuery);
foreach ($cursor as $doc) {
    var_dump($doc);
}

?>

Yukarıdaki örneğin çıktısı:

array(4) {
  ["_id"]=>
  object(MongoId)#7 (1) {
    ["$id"]=>
    string(24) "50a87dd084f045a19b220dd6"
  }
  ["Name"]=>
  string(5) "Apple"
  ["Type"]=>
  string(5) "Fruit"
  ["Details"]=>
  array(2) {
    ["Taste"]=>
    string(5) "Sweet"
    ["Colour"]=>
    string(3) "Red"
  }
}
array(4) {
  ["_id"]=>
  object(MongoId)#8 (1) {
    ["$id"]=>
    string(24) "50a87de084f045a19b220dd7"
  }
  ["Name"]=>
  string(5) "Lemon"
  ["Type"]=>
  string(5) "Fruit"
  ["Details"]=>
  array(2) {
    ["Taste"]=>
    string(4) "Sour"
    ["Colour"]=>
    string(5) "Green"
  }
}

Sweet:
array(4) {
  ["_id"]=>
  object(MongoId)#7 (1) {
    ["$id"]=>
    string(24) "50a87dd084f045a19b220dd6"
  }
  ["Name"]=>
  string(5) "Apple"
  ["Type"]=>
  string(5) "Fruit"
  ["Details"]=>
  array(2) {
    ["Taste"]=>
    string(5) "Sweet"
    ["Colour"]=>
    string(3) "Red"
  }
}

See MongoCursor for more information how to work with cursors.

Örnek 2 MongoCollection::find() example

This example demonstrates how to search for a range.

<?php

$m = new MongoClient();
$db = $m->selectDB('test');
$collection = new MongoCollection($db, 'phpmanual');

// search for documents where 5 < x < 20
$rangeQuery = array('x' => array( '$gt' => 5, '$lt' => 20 ));

$cursor = $collection->find($rangeQuery);
foreach ($cursor as $doc) {
    var_dump($doc);
}

?>

Yukarıdaki örneğin çıktısı:

array(2) {
  ["_id"]=>
  object(MongoId)#10 (1) {
    ["$id"]=>
    string(24) "4ebc3e3710b89f2349000000"
  }
  ["x"]=>
  int(12)
}
array(2) {
  ["_id"]=>
  object(MongoId)#11 (1) {
    ["$id"]=>
    string(24) "4ebc3e3710b89f2349000001"
  }
  ["x"]=>
  int(12)
}

See MongoCursor for more information how to work with cursors.

Örnek 3 MongoCollection::find() example using $where

This example demonstrates how to search a collection using javascript code to reduce the resultset.

<?php

$m = new MongoClient();
$db = $m->selectDB('test');
$collection = new MongoCollection($db, 'phpmanual');

$js = "function() {
    return this.name == 'Joe' || this.age == 50;
}";
$cursor = $collection->find(array('$where' => $js));
foreach ($cursor as $doc) {
    var_dump($doc);
}

?>

Yukarıdaki örneğin çıktısı:

array(3) {
  ["_id"]=>
  object(MongoId)#7 (1) {
    ["$id"]=>
    string(24) "4ebc3e3710b89f2349000002"
  }
  ["name"]=>
  string(3) "Joe"
  ["age"]=>
  int(20)
}

Örnek 4 MongoCollection::find() example using $in

This example demonstrates how to search a collection using the $in operator.

<?php

$m = new MongoClient();
$db = $m->selectDB('test');
$collection = new MongoCollection($db, 'phpmanual');

$cursor = $collection->find(array(
    'name' => array('$in' => array('Joe', 'Wendy'))
));

?>

Yukarıdaki örneğin çıktısı:

array(3) {
  ["_id"]=>
  object(MongoId)#7 (1) {
    ["$id"]=>
    string(24) "4ebc3e3710b89f2349000002"
  }
  ["name"]=>
  string(3) "Joe"
  ["age"]=>
  int(20)
}

Örnek 5 Getting results as an array

This returns a MongoCursor. Often, when people are starting out, they are more comfortable using an array. To turn a cursor into an array, use the iterator_to_array() function.

<?php

$m = new MongoClient();
$db = $m->selectDB('test');
$collection = new MongoCollection($db, 'phpmanual');

$cursor = $collection->find();
$array = iterator_to_array($cursor);

?>

Yukarıdaki örneğin çıktısı:

array(3) {
  ["4ebc40af10b89f5149000000"]=>
  array(2) {
    ["_id"]=>
    object(MongoId)#6 (1) {
      ["$id"]=>
      string(24) "4ebc40af10b89f5149000000"
    }
    ["x"]=>
    int(12)
  }
  ["4ebc40af10b89f5149000001"]=>
  array(2) {
    ["_id"]=>
    object(MongoId)#11 (1) {
      ["$id"]=>
      string(24) "4ebc40af10b89f5149000001"
    }
    ["x"]=>
    int(12)
  }
  ["4ebc40af10b89f5149000002"]=>
  array(3) {
    ["_id"]=>
    object(MongoId)#12 (1) {
      ["$id"]=>
      string(24) "4ebc40af10b89f5149000002"
    }
    ["name"]=>
    string(3) "Joe"
    ["age"]=>
    int(20)
  }
}

Using iterator_to_array() forces the driver to load all of the results into memory, so do not do this for result sets that are larger than memory!

Also, certain system collections do not have an _id field. If you are dealing with a collection that might have documents without _ids, pass FALSE as the second argument to iterator_to_array() (so that it will not try to use the non-existent _id values as keys).

Ayrıca Bakınız

  • MongoCollection::findOne() - Queries this collection, returning a single element
  • MongoCollection::insert() - Inserts a document into the collection
  • MongoDB core docs on » find.
MongoCollection::ensureIndex
MongoCollection::findAndModify
MongoCollection


Update a document and return it

MongoCollection::find
MongoCollection::findOne
MongoCollection
PHP Manual

MongoCollection::findAndModify

(PECL mongo >=1.3.0)

MongoCollection::findAndModify — Update a document and return it

Açıklama

public array MongoCollection::findAndModify ( array $query [, array $update [, array $fields [, array $options ]]] )

The findAndModify command atomically modifies and returns a single document. By default, the returned document does not include the modifications made on the update. To return the document with the modifications made on the update, use the new option.

Değiştirgeler

query

The query criteria to search for.

update

The update criteria.

fields

Optionally only return these fields.

options

An array of options to apply, such as remove the match document from the DB and return it.

Option | Açıklama
sort array | Determines which document the operation will modify if the query selects multiple documents. findAndModify will modify the first document in the sort order specified by this argument.
remove boolean | Optional if update field exists. When TRUE, removes the selected document. The default is FALSE.
update array | Optional if remove field exists. Performs an update of the selected document.
new boolean | Optional. When TRUE, returns the modified document rather than the original. The findAndModify method ignores the new option for remove operations. The default is FALSE.
upsert boolean | Optional. Used in conjunction with the update field. When TRUE, the findAndModify command creates a new document if the query returns no documents. The default is false. In MongoDB 2.2, the findAndModify command returns NULL when upsert is TRUE.

Dönen Değerler

Returns the original document, or the modified document when new is set.

Hatalar/İstisnalar

Throws MongoResultException on failure.

Örnekler

Örnek 1 MongoCollection::findAndModify() example

<?php
$m = new Mongo;
$col = $m->selectDB("test")->jobs;

$col->insert(array(
     "name" => "Next promo",
     "inprogress" => false,
     "priority" => 0,
     "tasks" => array( "select product", "add inventory", "do placement"),
) );

$col->insert(array(
     "name" => "Biz report",
     "inprogress" => false,
     "priority" => 1,
     "tasks" => array( "run sales report", "email report" )
) );

$col->insert(array(
     "name" => "Biz report",
     "inprogress" => false,
     "priority" => 2,
     "tasks" => array( "run marketing report", "email report" )
    ),
    array("w" => 1)
);

$retval = $col->findAndModify(
     array("inprogress" => false, "name" => "Biz report"),
     array('$set' => array('inprogress' => true, "started" => new MongoDate())),
     null,
     array(
        "sort" => array("priority" => -1),
        "new" => true,
    )
);

var_dump($retval);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(6) {
  ["_id"]=>
  object(MongoId)#7 (1) {
    ["$id"]=>
    string(24) "5091b5b244415e8cc3000002"
  }
  ["inprogress"]=>
  bool(true)
  ["name"]=>
  string(10) "Biz report"
  ["priority"]=>
  int(2)
  ["started"]=>
  object(MongoDate)#8 (2) {
    ["sec"]=>
    int(1351726514)
    ["usec"]=>
    int(925000)
  }
  ["tasks"]=>
  array(2) {
    [0]=>
    string(20) "run marketing report"
    [1]=>
    string(12) "email report"
  }
}

Örnek 2 MongoCollection::findAndModify() error handling

<?php
$m = new Mongo;
$col = $m->selectDB("test")->jobs;
try {
    $retval = $col->findAndModify(
         array("inprogress" => false, "name" => "Next promo"),
         array('$pop' => array("tasks" => -1)),
         array("tasks" => array('$pop' => array("stuff"))),
         array("new" => true)
    );
} catch(MongoResultException $e) {
    echo $e->getCode(), " : ", $e->getMessage(), "\n";
    var_dump($e->getDocument());
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

13097 : exception: Unsupported projection option: $pop
array(3) {
  ["errmsg"]=>
  string(46) "exception: Unsupported projection option: $pop"
  ["code"]=>
  int(13097)
  ["ok"]=>
  float(0)
}

Ayrıca Bakınız

  • The MongoDB » findAndModify command docs
MongoCollection::find
MongoCollection::findOne
MongoCollection


Queries this collection, returning a single element

MongoCollection::findAndModify
MongoCollection::__get
MongoCollection
PHP Manual

MongoCollection::findOne

(PECL mongo >=0.9.0)

MongoCollection::findOne — Queries this collection, returning a single element

Açıklama

 public array MongoCollection::findOne
  ([ array $query = array()
 [, array $fields = array()
 [, array $options = array()
]]] )

As opposed to MongoCollection::find(), this method will return only the first result from the result set, and not a MongoCursor that can be iterated over.

Değiştirgeler

query

The fields for which to search. MongoDB's query language is quite extensive. The PHP driver will in almost all cases pass the query straight through to the server, so reading the MongoDB core docs on » find is a good idea.

Uyarı

Please make sure that for all special query operaters (starting with $) you use single quotes so that PHP doesn't try to replace "$exists" with the value of the variable $exists.

fields

Fields of the results to return. The array is in the format array('fieldname' => true, 'fieldname2' => true). The _id field is always returned.

options

This parameter is an associative array of the form array("name" => <value>, ...). Currently supported options are:

  • "maxTimeMS"

    Specifies a cumulative time limit in milliseconds for processing the operation (does not include idle time). If the operation is not completed within the timeout period, a MongoExecutionTimeoutException will be thrown.

Dönen Değerler

Returns record matching the search or NULL.

Hatalar/İstisnalar

Throws MongoConnectionException if it cannot reach the database.

Sürüm Bilgisi

Sürüm: | Açıklama
1.5.0 | Added optional options argument.

Örnekler

Örnek 1 MongoCollection::findOne() document by its id.

This example demonstrates how to find a single document in a collection by its id.

<?php

$articles = $mongo->my_db->articles;

$article = $articles->findOne(array('_id' => new MongoId('47cc67093475061e3d9536d2')));

?>

Örnek 2 MongoCollection::findOne() document by some condition.

This example demonstrates how to find a single document in a collection by some condition and limiting the returned fields.

<?php

$users = $mongo->my_db->users;
$user = $users->findOne(array('username' => 'jwage'), array('password'));
print_r($user);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [_id] => MongoId Object
        (
        )

    [password] => test
)

Notice how even though the document does have a username field, we limited the results to only contain the password field.

Ayrıca Bakınız

  • MongoCollection::find() - Queries this collection, returning a MongoCursor for the result set
  • MongoCollection::insert() - Inserts a document into the collection
  • MongoDB core docs on » find.
MongoCollection::findAndModify
MongoCollection::__get
MongoCollection


Gets a collection

MongoCollection::findOne
MongoCollection::getDBRef
MongoCollection
PHP Manual

MongoCollection::__get

(PECL mongo >=1.0.2)

MongoCollection::__get — Gets a collection

Açıklama

public MongoCollection MongoCollection::__get ( string $name )

A concise syntax for getting a collection with a dot-separated name. If a collection name contains strange characters, you may have to use MongoDB::selectCollection() instead.

<?php

$mongo = new MongoClient();

// the following two lines are equivalent
$collection = $mongo->selectDB("foo")->selectCollection("bar.baz");
$collection = $mongo->foo->bar->baz;

?>

Değiştirgeler

name

The next string in the collection name.

Dönen Değerler

Returns the collection.

MongoCollection::findOne
MongoCollection::getDBRef
MongoCollection


Fetches the document pointed to by a database reference

MongoCollection::__get
MongoCollection::getIndexInfo
MongoCollection
PHP Manual

MongoCollection::getDBRef

(PECL mongo >=0.9.0)

MongoCollection::getDBRef — Fetches the document pointed to by a database reference

Açıklama

public array MongoCollection::getDBRef ( array $ref )

Değiştirgeler

ref

A database reference.

Dönen Değerler

Returns the database document pointed to by the reference.

Örnekler

Örnek 1 MongoCollection::getDBRef() example

<?php

$playlists = $db->playlists;

$myList = $playlists->findOne(array('username' => 'me'));

// fetch each song in the playlist
foreach ($myList['songlist'] as $songRef) {
    $song = $playlists->getDBRef($songRef);
    echo $song['title'] . "\n";
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Dazed and Confused
Ma na ma na
Bohemian Rhapsody

In the above example each $songRef looks something like the following:
    Array
    (
        [$ref] => songs
        [$id] => 49902cde5162504500b45c2c
    )

Ayrıca Bakınız

  • MongoCollection::createDBRef() - Creates a database reference

MongoCollection::__get
MongoCollection::getIndexInfo
MongoCollection


Returns information about indexes on this collection

MongoCollection::getDBRef
MongoCollection::getName
MongoCollection
PHP Manual

MongoCollection::getIndexInfo

(PECL mongo >=0.9.0)

MongoCollection::getIndexInfo — Returns information about indexes on this collection

Açıklama

public array MongoCollection::getIndexInfo ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

This function returns an array in which each element describes an index. Elements will contain the values name for the name of the index, ns for the namespace (a combination of the database and collection name), and key for a list of all fields in the index and their ordering. Additional values may be present for special indexes, such as unique or sparse.

Örnekler

Örnek 1 MongoCollection::getIndexInfo() example

<?php

$m = new MongoClient();
$c = $m->selectCollection('test', 'venues');
var_dump($c->getIndexInfo());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(4) {
  [0]=>
  array(4) {
    ["v"]=>
    int(1)
    ["key"]=>
    array(1) {
      ["_id"]=>
      int(1)
    }
    ["name"]=>
    string(4) "_id_"
    ["ns"]=>
    string(11) "test.venues"
  }
  [1]=>
  array(4) {
    ["v"]=>
    int(1)
    ["key"]=>
    array(1) {
      ["name"]=>
      float(1)
    }
    ["name"]=>
    string(6) "name_1"
    ["ns"]=>
    string(11) "test.venues"
  }
  [2]=>
  array(4) {
    ["v"]=>
    int(1)
    ["key"]=>
    array(2) {
      ["type"]=>
      float(1)
      ["createdAt"]=>
      float(-1)
    }
    ["name"]=>
    string(19) "type_1_createdAt_-1"
    ["ns"]=>
    string(11) "test.venues"
  }
  [3]=>
  array(5) {
    ["v"]=>
    int(1)
    ["key"]=>
    array(1) {
      ["location"]=>
      string(8) "2dsphere"
    }
    ["name"]=>
    string(17) "location_2dsphere"
    ["ns"]=>
    string(11) "test.venues"
    ["2dsphereIndexVersion"]=>
    int(2)
  }
}

Ayrıca Bakınız

MongoDB core docs on » vanilla indexes and » geospatial indexes.

MongoCollection::getDBRef
MongoCollection::getName
MongoCollection


Returns this collection's name

MongoCollection::getIndexInfo
MongoCollection::getReadPreference
MongoCollection
PHP Manual

MongoCollection::getName

(PECL mongo >=0.9.0)

MongoCollection::getName — Returns this collection's name

Açıklama

public string MongoCollection::getName ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the name of this collection.

Örnekler

Örnek 1 MongoCollection::getName() example

<?php

$m = new MongoClient();
$c = $m->foo->bar->baz;

echo "Working with collection " . $c->getName() . ".\n";

// the full namespace is given by the MongoCollection::__toString() method
echo "Working in namespace $c.\n";

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Working with collection bar.baz.
Working in namespace foo.bar.baz.

MongoCollection::getIndexInfo
MongoCollection::getReadPreference
MongoCollection


Get the read preference for this collection

MongoCollection::getName
MongoCollection::getSlaveOkay
MongoCollection
PHP Manual

MongoCollection::getReadPreference

(PECL mongo >=1.3.0)

MongoCollection::getReadPreference — Get the read preference for this collection

Açıklama

public array MongoCollection::getReadPreference ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

This function returns an array describing the read preference. The array contains the values type for the string read preference mode (corresponding to the MongoClient constants), and tagsets containing a list of all tag set criteria. If no tag sets were specified, tagsets will not be present in the array.

Sürüm Bilgisi

Sürüm: | Açıklama
1.3.3 | The return value has changed to be consistent with MongoCollection::setReadPreference(). The type value was changed from a number to a string, type_string was removed, and tagsets now expresses tags as key/value pairs instead of colon-delimited strings.

Örnekler

Örnek 1 MongoCollection::getReadPreference() return value example

<?php

$m = new MongoClient();
$c = $m->test->users;
$c->setReadPreference(MongoClient::RP_SECONDARY, array(
    array('dc' => 'east', 'use' => 'reporting'),
    array('dc' => 'west'),
    array(),
));
var_dump($c->getReadPreference());
?>

Yukarıdaki örneğin çıktısı:

array(2) {
  ["type"]=>
  string(9) "secondary"
  ["tagsets"]=>
  array(3) {
    [0]=>
    array(2) {
      ["dc"]=>
      string(4) "east"
      ["use"]=>
      string(9) "reporting"
    }
    [1]=>
    array(1) {
      ["dc"]=>
      string(7) "west"
    }
    [2]=>
    array(0) {
    }
  }
}

Ayrıca Bakınız

  • The read preferences documentation.
  • MongoCollection::setReadPreference() - Set the read preference for this collection
MongoCollection::getName
MongoCollection::getSlaveOkay
MongoCollection


Get slaveOkay setting for this collection

MongoCollection::getReadPreference
MongoCollection::getWriteConcern
MongoCollection
PHP Manual

MongoCollection::getSlaveOkay

(PECL mongo >=1.1.0)

MongoCollection::getSlaveOkay — Get slaveOkay setting for this collection

Açıklama

public bool MongoCollection::getSlaveOkay ( void )

See the query section of this manual for information on distributing reads to secondaries.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the value of slaveOkay for this instance.

Sürüm Bilgisi

Sürüm: | Açıklama
1.2.11 | Emits E_DEPRECATED when used.

Ayrıca Bakınız

  • Read Preferences
  • MongoCollection::getReadPreference() - Get the read preference for this collection
MongoCollection::getReadPreference
MongoCollection::getWriteConcern
MongoCollection


Get the write concern for this collection

MongoCollection::getSlaveOkay
MongoCollection::group
MongoCollection
PHP Manual

MongoCollection::getWriteConcern

(PECL mongo >=1.5.0)

MongoCollection::getWriteConcern — Get the write concern for this collection

Açıklama

public array MongoCollection::getWriteConcern ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

This function returns an array describing the write concern. The array contains the values w for an integer acknowledgement level or string mode, and wtimeout denoting the maximum number of milliseconds to wait for the server to satisfy the write concern.

Örnekler

Örnek 1 MongoCollection::getWriteConcern() return value example

<?php

$mc = new MongoClient('mongodb://localhost:27017', array('wTimeoutMS' => 500));
$coll = $mc->selectCollection('test', 'foo');
var_dump($coll->getWriteConcern());

$coll->setWriteConcern(1, 1000);
var_dump($coll->getWriteConcern());
?>

Yukarıdaki örneğin çıktısı:

array(2) {
  ["w"]=>
  int(1)
  ["wtimeout"]=>
  int(500)
}
array(2) {
  ["w"]=>
  int(1)
  ["wtimeout"]=>
  int(1000)
}

Ayrıca Bakınız

  • The write concern documentation.
  • MongoCollection::setWriteConcern() - Set the write concern for this database
MongoCollection::getSlaveOkay
MongoCollection::group
MongoCollection


Performs an operation similar to SQL's GROUP BY command

MongoCollection::getWriteConcern
MongoCollection::insert
MongoCollection
PHP Manual

MongoCollection::group

(PECL mongo >=0.9.2)

MongoCollection::group — Performs an operation similar to SQL's GROUP BY command

Açıklama

public array MongoCollection::group ( mixed $keys , array $initial , MongoCode $reduce [, array $options = array() ] )

Değiştirgeler

keys

Fields to group by. If an array or non-code object is passed, it will be the key used to group results.

1.0.4+: If keys is an instance of MongoCode, keys will be treated as a function that returns the key to group by (see the "Passing a keys function" example below).

initial

Initial value of the aggregation counter object.

reduce

A function that takes two arguments (the current document and the aggregation to this point) and does the aggregation.

options

Optional parameters to the group command. Valid options include:

  • "condition"

    Criteria for including a document in the aggregation.

  • "finalize"

    Function called once per unique key that takes the final output of the reduce function.

  • "maxTimeMS"

    Specifies a cumulative time limit in milliseconds for processing the operation (does not include idle time). If the operation is not completed within the timeout period, a MongoExecutionTimeoutException will be thrown.

Dönen Değerler

Returns an array containing the result.

Sürüm Bilgisi

Sürüm: | Açıklama
1.5.0 | Added "maxTimeMS" option.
1.2.11 | Emits E_DEPRECATED when options is scalar.

Örnekler

Örnek 1 MongoCollection::group() example

This groups documents by category and creates a list of names within that category.

<?php

$collection->insert(array("category" => "fruit", "name" => "apple"));
$collection->insert(array("category" => "fruit", "name" => "peach"));
$collection->insert(array("category" => "fruit", "name" => "banana"));
$collection->insert(array("category" => "veggie", "name" => "corn"));
$collection->insert(array("category" => "veggie", "name" => "broccoli"));

$keys = array("category" => 1);

$initial = array("items" => array());

$reduce = "function (obj, prev) { prev.items.push(obj.name); }";

$g = $collection->group($keys, $initial, $reduce);

echo json_encode($g['retval']);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

[{"category":"fruit","items":["apple","peach","banana"]},{"category":"veggie","items":["corn","broccoli"]}]

Örnek 2 MongoCollection::group() example

This example doesn't use any key, so every document will be its own group. It also uses a condition: only documents that match this condition will be processed by the grouping function.

<?php

$collection->save(array("a" => 2));
$collection->save(array("b" => 5));
$collection->save(array("a" => 1));

// use all fields
$keys = array();

// set intial values
$initial = array("count" => 0);

// JavaScript function to perform
$reduce = "function (obj, prev) { prev.count++; }";

// only use documents where the "a" field is greater than 1
$condition = array('condition' => array("a" => array( '$gt' => 1)));

$g = $collection->group($keys, $initial, $reduce, $condition);

var_dump($g);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(4) {
  ["retval"]=>
  array(1) {
    [0]=>
    array(1) {
      ["count"]=>
      float(1)
    }
  }
  ["count"]=>
  float(1)
  ["keys"]=>
  int(1)
  ["ok"]=>
  float(1)
}

Örnek 3 Passing a keys function

If you want to group by something other than a field name, you can pass a function as the first parameter of MongoCollection::group() and it will be run against each document. The return value of the function will be used as its grouping value.

This example demonstrates grouping by the num field modulo 4.

<?php

$c->group(new MongoCode('function(doc) { return {mod : doc.num % 4}; }'),
     array("count" => 0),
     new MongoCode('function(current, total) { total.count++; }'));

?>
MongoCollection::getWriteConcern
MongoCollection::insert
MongoCollection


Inserts a document into the collection

MongoCollection::group
MongoCollection::parallelCollectionScan
MongoCollection
PHP Manual

MongoCollection::insert

(PECL mongo >=0.9.0)

MongoCollection::insert — Inserts a document into the collection

Açıklama

public bool|array MongoCollection::insert ( array|object $document [, array $options = array() ] )

All strings sent to the database must be UTF-8. If a string is not UTF-8, a MongoException will be thrown. To insert (or query for) a non-UTF-8 string, use MongoBinData.

Değiştirgeler

document

An array or object. If an object is used, it may not have protected or private properties.

Bilginize:

If the parameter does not have an _id key or property, a new MongoId instance will be created and assigned to it. This special behavior does not mean that the parameter is passed by reference.

options

An array of options for the insert operation. Currently available options include:

  • "fsync"

    Boolean, defaults to FALSE. If journaling is enabled, it works exactly like "j". If journaling is not enabled, the write operation blocks until it is synced to database files on disk. If TRUE, an acknowledged insert is implied and this option will override setting "w" to 0.

    Bilginize: If journaling is enabled, users are strongly encouraged to use the "j" option instead of "fsync". Do not use "fsync" and "j" simultaneously, as that will result in an error.

  • "j"

    Boolean, defaults to FALSE. Forces the write operation to block until it is synced to the journal on disk. If TRUE, an acknowledged write is implied and this option will override setting "w" to 0.

    Bilginize: If this option is used and journaling is disabled, MongoDB 2.6+ will raise an error and the write will fail; older server versions will simply ignore the option.

  • "socketTimeoutMS"

    This option specifies the time limit, in milliseconds, for socket communication. If the server does not respond within the timeout period, a MongoCursorTimeoutException will be thrown and there will be no way to determine if the server actually handled the write or not. A value of -1 may be specified to block indefinitely. The default value for MongoClient is 30000 (30 seconds).

  • "w"

    See Write Concerns. The default value for MongoClient is 1.

  • "wTimeoutMS"

    This option specifies the time limit, in milliseconds, for write concern acknowledgement. It is only applicable when "w" is greater than 1, as the timeout pertains to replication. If the write concern is not satisfied within the time limit, a MongoCursorException will be thrown. A value of 0 may be specified to block indefinitely. The default value for MongoClient is 10000 (ten seconds).

The following options are deprecated and should no longer be used:

  • "safe"

    Deprecated. Please use the write concern "w" option.

  • "timeout"

    Deprecated alias for "socketTimeoutMS".

  • "wtimeout"

    Deprecated alias for "wTimeoutMS".

Dönen Değerler

Returns an array containing the status of the insertion if the "w" option is set. Otherwise, returns TRUE if the inserted array is not empty (a MongoException will be thrown if the inserted array is empty).

If an array is returned, the following keys may be present:

ok

This should almost always be 1 (unless last_error itself failed).

err

If this field is non-null, an error occurred on the previous operation. If this field is set, it will be a string describing the error that occurred.

code

If a database error occurred, the relevant error code will be passed back to the client.

errmsg

This field is set if something goes wrong with a database command. It is coupled with ok being 0. For example, if w is set and times out, errmsg will be set to "timed out waiting for slaves" and ok will be 0. If this field is set, it will be a string describing the error that occurred.

n

If the last operation was an update, upsert, or a remove, the number of documents affected will be returned. For insert operations, this value is always 0.

wtimeout

If the previous option timed out waiting for replication.

waited

How long the operation waited before timing out.

wtime

If w was set and the operation succeeded, how long it took to replicate to w servers.

upserted

If an upsert occurred, this field will contain the new record's _id field. For upserts, either this field or updatedExisting will be present (unless an error occurred).

updatedExisting

If an upsert updated an existing element, this field will be true. For upserts, either this field or upserted will be present (unless an error occurred).

Hatalar/İstisnalar

Throws MongoException if the inserted document is empty or if it contains zero-length keys. Attempting to insert an object with protected and private properties will cause a zero-length key error.

Throws MongoCursorException if the "w" option is set and the write fails.

Throws MongoCursorTimeoutException if the "w" option is set to a value greater than one and the operation takes longer than MongoCursor::$timeout milliseconds to complete. This does not kill the operation on the server, it is a client-side timeout. The operation in MongoCollection::$wtimeout is milliseconds.

Sürüm Bilgisi

Sürüm: | Açıklama
1.5.0 | Added the "wTimeoutMS" option, which replaces "wtimeout". Emits E_DEPRECATED when "wtimeout" is used. Added the "socketTimeoutMS" option, which replaces "timeout". Emits E_DEPRECATED when "timeout" is used. Emits E_DEPRECATED when "safe" is used.
1.3.4 | Added "wtimeout" option.
1.3.0 | Added "w" option. The options parameter no longer accepts a boolean to signify an acknowledged write. Instead, this now has to be done with array('w' => 1) (the default behaviour of MongoClient).
1.2.0 | Added "timeout" option.
1.0.11 | Disconnects on "not master" errors if "safe" is set.
1.0.9 | Added ability to pass integers to the "safe" option, which previously only accepted booleans. Added "fsync" option. The return type was changed to be an array containing error information if the "safe" option is used. Otherwise, a boolean is returned as before.
1.0.2 | Changed second parameter to be an array of options. Pre-1.0.2, the second parameter was a boolean indicating the "safe" option.
1.0.1 | Throw a MongoCursorException if the "safe" option is set and the insert fails.

Örnekler

Örnek 1 MongoCollection::insert() _id example

An _id field will be added to the inserted document if not already present. Depending on how the parameter is passed, a generated _id may or may not be available to calling code.

<?php

$m = new MongoClient();
$collection = $m->selectCollection('test', 'phpmanual');

// If an array literal is used, there is no way to access the generated _id
$collection->insert(array('x' => 1));

// The _id is available on an array passed by value
$a = array('x' => 2);
$collection->insert($a);
var_dump($a);

// The _id is not available on an array passed by reference
$b = array('x' => 3);
$ref = &$b;
$collection->insert($ref);
var_dump($ref);

// The _id is available if a wrapping function does not trigger copy-on-write
function insert_no_cow($collection, $document)
{
    $collection->insert($document);
}

$c = array('x' => 4);
insert_no_cow($collection, $c);
var_dump($c);

// The _id is not available if a wrapping function triggers copy-on-write
function insert_cow($collection, $document)
{
    $document['y'] = 1;
    $collection->insert($document);
}

$d = array('x' => 5);
insert_cow($collection, $d);
var_dump($d);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(2) {
  ["x"]=>
  int(2)
  ["_id"]=>
  object(MongoId)#4 (0) {
  }
}
array(1) {
  ["x"]=>
  int(3)
}
array(2) {
  ["x"]=>
  int(4)
  ["_id"]=>
  object(MongoId)#5 (0) {
  }
}
array(1) {
  ["x"]=>
  int(5)
}

Örnek 2 MongoCollection::insert() acknowledged write example

This example shows inserting two elements with the same _id, which causes a MongoCursorException to be thrown, as w was set.

<?php

$person = array("name" => "Joe", "age" => 20);
$collection->insert($person);

// now $person has an _id field, so if we save it
// again, we will get an exception
try {
    $collection->insert($person, array("w" => 1));
} catch(MongoCursorException $e) {
    echo "Can't save the same person twice!\n";
}

?>

Ayrıca Bakınız

  • MongoCollection::batchInsert() - Inserts multiple documents into this collection
  • MongoCollection::update() - Update records based on a given criteria
  • MongoCollection::find() - Queries this collection, returning a MongoCursor for the result set
  • MongoCollection::remove() - Remove records from this collection
  • MongoDB core docs on » insert.
MongoCollection::group
MongoCollection::parallelCollectionScan
MongoCollection


Returns an array of cursors to iterator over a full collection in parallel

MongoCollection::insert
MongoCollection::remove
MongoCollection
PHP Manual

MongoCollection::parallelCollectionScan

(PECL mongo >=1.5.0)

MongoCollection::parallelCollectionScan — Returns an array of cursors to iterator over a full collection in parallel

Açıklama

public array[MongoCommandCursor] MongoCollection::parallelCollectionScan ( int $num_cursors )

This method returns an array of a maximum of num_cursors cursors. An iteration over one of the returned cursors results in a partial set of documents for a collection. Iteration over all the returned cursors results in getting every document back from the collection.

This method is a wrapper for the parallelCollectionScan MongoDB command.

Değiştirgeler

num_cursors

The number of cursors to request from the server. Please note, that the server can return less cursors than you requested.

Dönen Değerler

Returns an array of MongoCommandCursor objects.

Örnekler

Örnek 1 MongoCollection::parallelCollectionScan() example

Returning all documents in a collection by using multiple cursors.

<?php
$m = new MongoClient;
$c = $m->demo->cities;

/* Request three cursors */
$cursors = $c->parallelCollectionScan( 3 );

/* Add all the cursors to the MultipleIterator */
$mi = new MultipleIterator( MultipleIterator::MIT_NEED_ANY );
foreach ( $cursors as $cursor )
{
    $mi->attachIterator( $cursor );
}

/* Iterate over all the associated cursors */
foreach ( $mi as $items )
{
    foreach ( $items as $item )
    {
        if ( $item !== NULL )
        {
            echo $item['name'], "\n";
        }
    }
}
?>

Ayrıca Bakınız

  • MultipleIterator
  • MongoCommandCursor
  • MongoDB::command() - Execute a database command

MongoCollection::insert
MongoCollection::remove
MongoCollection


Remove records from this collection

MongoCollection::parallelCollectionScan
MongoCollection::save
MongoCollection
PHP Manual

MongoCollection::remove

(PECL mongo >=0.9.0)

MongoCollection::remove — Remove records from this collection

Açıklama

 public bool|array MongoCollection::remove
  ([ array $criteria = array()
 [, array $options = array()
]] )

Değiştirgeler

criteria

Query criteria for the documents to delete.

options

An array of options for the remove operation. Currently available options include:

  • "w"

    See Write Concerns. The default value for MongoClient is 1.

  • "justOne"

    Specify TRUE to limit deletion to just one document. If FALSE or omitted, all documents matching the criteria will be deleted.

  • "fsync"

    Boolean, defaults to FALSE. If journaling is enabled, it works exactly like "j". If journaling is not enabled, the write operation blocks until it is synced to database files on disk. If TRUE, an acknowledged insert is implied and this option will override setting "w" to 0.

    Bilginize: If journaling is enabled, users are strongly encouraged to use the "j" option instead of "fsync". Do not use "fsync" and "j" simultaneously, as that will result in an error.

  • "j"

    Boolean, defaults to FALSE. Forces the write operation to block until it is synced to the journal on disk. If TRUE, an acknowledged write is implied and this option will override setting "w" to 0.

    Bilginize: If this option is used and journaling is disabled, MongoDB 2.6+ will raise an error and the write will fail; older server versions will simply ignore the option.

  • "socketTimeoutMS"

    This option specifies the time limit, in milliseconds, for socket communication. If the server does not respond within the timeout period, a MongoCursorTimeoutException will be thrown and there will be no way to determine if the server actually handled the write or not. A value of -1 may be specified to block indefinitely. The default value for MongoClient is 30000 (30 seconds).

  • "w"

    See Write Concerns. The default value for MongoClient is 1.

  • "wTimeoutMS"

    This option specifies the time limit, in milliseconds, for write concern acknowledgement. It is only applicable when "w" is greater than 1, as the timeout pertains to replication. If the write concern is not satisfied within the time limit, a MongoCursorException will be thrown. A value of 0 may be specified to block indefinitely. The default value for MongoClient is 10000 (ten seconds).

The following options are deprecated and should no longer be used:

  • "safe"

    Deprecated. Please use the write concern "w" option.

  • "timeout"

    Deprecated alias for "socketTimeoutMS".

  • "wtimeout"

    Deprecated alias for "wTimeoutMS".

Dönen Değerler

Returns an array containing the status of the removal if the "w" option is set. Otherwise, returns TRUE.

Fields in the status array are described in the documentation for MongoCollection::insert().

Hatalar/İstisnalar

Throws MongoCursorException if the "w" option is set and the write fails.

Throws MongoCursorTimeoutException if the "w" option is set to a value greater than one and the operation takes longer than MongoCursor::$timeout milliseconds to complete. This does not kill the operation on the server, it is a client-side timeout. The operation in MongoCollection::$wtimeout is milliseconds.

Sürüm Bilgisi

Sürüm: | Açıklama
1.5.0 | Added "wTimeoutMS" option, which replaces "wtimeout". Emits E_DEPRECATED when "wtimeout" is used. Added "socketTimeoutMS" option, which replaces "timeout". Emits E_DEPRECATED when "timeout" is used. Emits E_DEPRECATED when "safe" is used.
1.3.4 | Added "wtimeout" option.
1.3.0 | Added "w" option. The options parameter no longer accepts a boolean to signify "justOne". Instead, this now has to be done with array('justOne' => true).
1.2.11 | Emits E_DEPRECATED when options is scalar.
1.2.0 | Added "timeout" option.
1.0.11 | Disconnects on "not master" errors if "safe" is set.
1.0.9 | Added ability to pass integers to the "safe" option, which previously only accepted booleans. Added "fsync" option. The return type was changed to be an array containing error information if the "safe" option is used. Otherwise, a boolean is returned as before.
1.0.5 | Changed second parameter to be an array of options. Pre-1.0.5, the second parameter was a boolean indicating the "safe" option.

Örnekler

Örnek 1 MongoCollection::remove() with justOne example

<?php

$radioactive = $db->radioactive;

// count how much more plutonium there is
$remaining = $radioactive->count(array('type' => 94));

$halflife = $remaining/2;

// remove half of it
while ($halflife > 0) {
    $radioactive->remove(array('type' => 94), array("justOne" => true));
    $halflife--;
}

?>

Ayrıca Bakınız

  • MongoCollection::insert() - Inserts a document into the collection
  • MongoCollection::update() - Update records based on a given criteria
  • MongoDB core docs on » remove.
MongoCollection::parallelCollectionScan
MongoCollection::save
MongoCollection


Saves a document to this collection

MongoCollection::remove
MongoCollection::setReadPreference
MongoCollection
PHP Manual

MongoCollection::save

(PECL mongo >=0.9.0)

MongoCollection::save — Saves a document to this collection

Açıklama

public mixed MongoCollection::save ( array|object $document [, array $options = array() ] )

If the object is from the database, update the existing database object, otherwise insert this object.

Değiştirgeler

document

Array or object to save. If an object is used, it may not have protected or private properties.

Bilginize:

If the parameter does not have an _id key or property, a new MongoId instance will be created and assigned to it. See MongoCollection::insert() for additional information on this behavior.

options

Options for the save.

  • "fsync"

    Boolean, defaults to FALSE. If journaling is enabled, it works exactly like "j". If journaling is not enabled, the write operation blocks until it is synced to database files on disk. If TRUE, an acknowledged insert is implied and this option will override setting "w" to 0.

    Bilginize: If journaling is enabled, users are strongly encouraged to use the "j" option instead of "fsync". Do not use "fsync" and "j" simultaneously, as that will result in an error.

  • "j"

    Boolean, defaults to FALSE. Forces the write operation to block until it is synced to the journal on disk. If TRUE, an acknowledged write is implied and this option will override setting "w" to 0.

    Bilginize: If this option is used and journaling is disabled, MongoDB 2.6+ will raise an error and the write will fail; older server versions will simply ignore the option.

  • "socketTimeoutMS"

    This option specifies the time limit, in milliseconds, for socket communication. If the server does not respond within the timeout period, a MongoCursorTimeoutException will be thrown and there will be no way to determine if the server actually handled the write or not. A value of -1 may be specified to block indefinitely. The default value for MongoClient is 30000 (30 seconds).

  • "w"

    See Write Concerns. The default value for MongoClient is 1.

  • "wtimeout"

    Deprecated alias for "wTimeoutMS".

  • "wTimeoutMS"

    This option specifies the time limit, in milliseconds, for write concern acknowledgement. It is only applicable when "w" is greater than 1, as the timeout pertains to replication. If the write concern is not satisfied within the time limit, a MongoCursorException will be thrown. A value of 0 may be specified to block indefinitely. The default value for MongoClient is 10000 (ten seconds).

  • "safe"

    Deprecated. Please use the write concern "w" option.

  • "timeout"

    Deprecated alias for "socketTimeoutMS".

Dönen Değerler

If w was set, returns an array containing the status of the save. Otherwise, returns a boolean representing if the array was not empty (an empty array will not be inserted).

Hatalar/İstisnalar

Throws MongoException if the inserted document is empty or if it contains zero-length keys. Attempting to insert an object with protected and private properties will cause a zero-length key error.

Throws MongoCursorException if the "w" option is set and the write fails.

Throws MongoCursorTimeoutException if the "w" option is set to a value greater than one and the operation takes longer than MongoCursor::$timeout milliseconds to complete. This does not kill the operation on the server, it is a client-side timeout. The operation in MongoCollection::$wtimeout is milliseconds.

Sürüm Bilgisi

Sürüm: | Açıklama
1.5.0 | Added "wTimeoutMS" option, which replaces "wtimeout". Emits E_DEPRECATED when "wtimeout" is used. Added "socketTimeoutMS" option, which replaces "timeout". Emits E_DEPRECATED when "timeout" is used. Emits E_DEPRECATED when "safe" is used.
1.2.0 | Added "timeout" option.
1.0.11 | Disconnects on "not master" errors if "safe" is set.
1.0.9 | Added "fsync" option.
1.0.5 | Added options parameter.

Örnekler

Örnek 1 MongoCollection::save() example

<?php

$obj = array('x' => 1);

// insert $obj into the db
$collection->save($obj);
var_dump($obj);

// add another field
$obj['foo'] = 'bar';

// $obj cannot be inserted again, causes duplicate _id error
$collection->insert($obj);

// save updates $obj with the new field
$collection->save($obj);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(2) {
  ["x"]=>
  int(1)
  ["_id"]=>
  object(MongoId)#4 (1) {
    ["$id"]=>
    string(24) "50b6afe544415ed606000000"
  }
}
MongoCollection::remove
MongoCollection::setReadPreference
MongoCollection


Set the read preference for this collection

MongoCollection::save
MongoCollection::setSlaveOkay
MongoCollection
PHP Manual

MongoCollection::setReadPreference

(PECL mongo >=1.3.0)

MongoCollection::setReadPreference — Set the read preference for this collection

Açıklama

public bool MongoCollection::setReadPreference ( string $read_preference [, array $tags ] )

Değiştirgeler

read_preference

The read preference mode: MongoClient::RP_PRIMARY, MongoClient::RP_PRIMARY_PREFERRED, MongoClient::RP_SECONDARY, MongoClient::RP_SECONDARY_PREFERRED, or MongoClient::RP_NEAREST.

tags

An array of zero or more tag sets, where each tag set is itself an array of criteria used to match tags on replica set members.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Hatalar/İstisnalar

Emits E_WARNING if either parameter is invalid, or if one or more tag sets are provided with the MongoClient::RP_PRIMARY read preference mode.

Örnekler

Örnek 1 MongoCollection::setReadPreference() tag set array syntax example

<?php

$m = new MongoClient();
$c = $m->test->users;

// Prefer the nearest server in the "east" data center also used for reporting,
// but fall back to a server in the "west" data center
$c->setReadPreference(MongoClient::RP_NEAREST, array(
    array('dc' => 'east', 'use' => 'reporting'),
    array('dc' => 'west'),
));
?>

Ayrıca Bakınız

  • The read preferences documentation.
  • MongoCollection::getReadPreference() - Get the read preference for this collection
MongoCollection::save
MongoCollection::setSlaveOkay
MongoCollection


Change slaveOkay setting for this collection

MongoCollection::setReadPreference
MongoCollection::setWriteConcern
MongoCollection
PHP Manual

MongoCollection::setSlaveOkay

(PECL mongo >=1.1.0)

MongoCollection::setSlaveOkay — Change slaveOkay setting for this collection

Açıklama

public bool MongoCollection::setSlaveOkay ([ bool $ok = true ] )

See the query section of this manual for information on distributing reads to secondaries.

Değiştirgeler

ok

If reads should be sent to secondary members of a replica set for all possible queries using this MongoCollection instance.

Dönen Değerler

Returns the former value of slaveOkay for this instance.

Sürüm Bilgisi

Sürüm: | Açıklama
1.2.11 | Emits E_DEPRECATED when used.

Ayrıca Bakınız

  • Read Preferences
  • MongoCollection::setReadPreference() - Set the read preference for this collection
MongoCollection::setReadPreference
MongoCollection::setWriteConcern
MongoCollection


Set the write concern for this database

MongoCollection::setSlaveOkay
MongoCollection::toIndexString
MongoCollection
PHP Manual

MongoCollection::setWriteConcern

(PECL mongo >=1.5.0)

MongoCollection::setWriteConcern — Set the write concern for this database

Açıklama

public bool MongoCollection::setWriteConcern ( mixed $w [, int $wtimeout ] )

Değiştirgeler

w

The write concern. This may be an integer denoting the number of servers required to acknowledge the write, or a string mode (e.g. "majority").

wtimeout

The maximum number of milliseconds to wait for the server to satisfy the write concern.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Hatalar/İstisnalar

Emits E_WARNING if the w parameter is not an integer or string value.

Örnekler

Örnek 1 MongoDB::setWriteConcern() example

<?php

$mc = new MongoClient('mongodb://rs1.example.com,rs2.example.com');
$coll = $mc->selectCollection('test', 'foo');

// Require that the majority of servers in the replica set acknowledge writes
// within three seconds.
$coll->setWriteConcern('majority', 3000);
?>

Ayrıca Bakınız

  • The write concern documentation.
  • MongoCollection::getWriteConcern() - Get the write concern for this collection
MongoCollection::setSlaveOkay
MongoCollection::toIndexString
MongoCollection


Converts keys specifying an index to its identifying string

MongoCollection::setWriteConcern
MongoCollection::__toString
MongoCollection
PHP Manual

MongoCollection::toIndexString

(PECL mongo >=0.9.0)

MongoCollection::toIndexString — Converts keys specifying an index to its identifying string

Açıklama

static protected string MongoCollection::toIndexString ( mixed $keys )
Uyarı

This method is deprecated since version 1.5.0.

Değiştirgeler

keys

Field or fields to convert to the identifying string

Dönen Değerler

Returns a string that describes the index.

Örnekler

Örnek 1 MongoCollection::toIndexString() example

This example shows how you can create an index name out of keys. Because this is a protected (static) method, you need to overload it in a child class first.

<?php
// Create inherited class to make the method "public".
class MyCollection extends MongoCollection
{
    static public function toIndexString($a)
    {
        return parent::toIndexString($a);
    }
}

echo MyCollection::toIndexString("foo"), "\n";
// Outputs: foo_1

echo MyCollection::toIndexString(array('name' => 1, 'age' => -1)), "\n";
// Outputs: name_1_age_-1
?>

Ayrıca Bakınız

MongoDB core docs on » indexes.

Sürüm Bilgisi

Sürüm: | Açıklama
1.5.0 | This method has been deprecated.

MongoCollection::setWriteConcern
MongoCollection::__toString
MongoCollection


String representation of this collection

MongoCollection::toIndexString
MongoCollection::update
MongoCollection
PHP Manual

MongoCollection::__toString

(PECL mongo >=0.9.0)

MongoCollection::__toString — String representation of this collection

Açıklama

public string MongoCollection::__toString ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the full name of this collection.

Örnekler

Örnek 1 MongoCollection::__toString() example

<?php

$m = new MongoClient();

$c1 = $m->foo->bar->baz;
echo "Working with collection $c1.";

$c2 = $m->selectCollection('[]', '&');
echo "Working with collection $c2.";

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Working with collection foo.bar.baz.
Working with collection [].&.

MongoCollection::toIndexString
MongoCollection::update
MongoCollection


Update records based on a given criteria

MongoCollection::__toString
MongoCollection::validate
MongoCollection
PHP Manual

MongoCollection::update

(PECL mongo >=0.9.0)

MongoCollection::update — Update records based on a given criteria

Açıklama

public bool|array MongoCollection::update ( array $criteria , array $new_object [, array $options = array() ] )

Değiştirgeler

criteria

Query criteria for the documents to update.

new_object

The object used to update the matched documents. This may either contain update operators (for modifying specific fields) or be a replacement document.

options

An array of options for the update operation. Currently available options include:

  • "upsert"

    If no document matches $criteria, a new document will be inserted.

    If a new document would be inserted and $new_object contains atomic modifiers (i.e. $ operators), those operations will be applied to the $criteria parameter to create the new document. If $new_object does not contain atomic modifiers, it will be used as-is for the inserted document. See the upsert examples below for more information.

  • "multiple"

    All documents matching $criteria will be updated. MongoCollection::update() has exactly the opposite behavior of MongoCollection::remove(): it updates one document by default, not all matching documents. It is recommended that you always specify whether you want to update multiple documents or a single document, as the database may change its default behavior at some point in the future.

  • "fsync"

    Boolean, defaults to FALSE. If journaling is enabled, it works exactly like "j". If journaling is not enabled, the write operation blocks until it is synced to database files on disk. If TRUE, an acknowledged insert is implied and this option will override setting "w" to 0.

    Bilginize: If journaling is enabled, users are strongly encouraged to use the "j" option instead of "fsync". Do not use "fsync" and "j" simultaneously, as that will result in an error.

  • "j"

    Boolean, defaults to FALSE. Forces the write operation to block until it is synced to the journal on disk. If TRUE, an acknowledged write is implied and this option will override setting "w" to 0.

    Bilginize: If this option is used and journaling is disabled, MongoDB 2.6+ will raise an error and the write will fail; older server versions will simply ignore the option.

  • "socketTimeoutMS"

    This option specifies the time limit, in milliseconds, for socket communication. If the server does not respond within the timeout period, a MongoCursorTimeoutException will be thrown and there will be no way to determine if the server actually handled the write or not. A value of -1 may be specified to block indefinitely. The default value for MongoClient is 30000 (30 seconds).

  • "w"

    See Write Concerns. The default value for MongoClient is 1.

  • "wTimeoutMS"

    This option specifies the time limit, in milliseconds, for write concern acknowledgement. It is only applicable when "w" is greater than 1, as the timeout pertains to replication. If the write concern is not satisfied within the time limit, a MongoCursorException will be thrown. A value of 0 may be specified to block indefinitely. The default value for MongoClient is 10000 (ten seconds).

The following options are deprecated and should no longer be used:

  • "safe"

    Deprecated. Please use the write concern "w" option.

  • "timeout"

    Deprecated alias for "socketTimeoutMS".

  • "wtimeout"

    Deprecated alias for "wTimeoutMS".

Dönen Değerler

Returns an array containing the status of the update if the "w" option is set. Otherwise, returns TRUE.

Fields in the status array are described in the documentation for MongoCollection::insert().

Hatalar/İstisnalar

Throws MongoCursorException if the "w" option is set and the write fails.

Throws MongoCursorTimeoutException if the "w" option is set to a value greater than one and the operation takes longer than MongoCursor::$timeout milliseconds to complete. This does not kill the operation on the server, it is a client-side timeout. The operation in MongoCollection::$wtimeout is milliseconds.

Sürüm Bilgisi

Sürüm: | Açıklama
1.5.0 | Added the "wTimeoutMS" option, which replaces "wtimeout". Emits E_DEPRECATED when "wtimeout" is used. Added the "socketTimeoutMS" option, which replaces "timeout". Emits E_DEPRECATED when "timeout" is used. Emits E_DEPRECATED when "safe" is used.
1.3.4 | Added "wtimeout" option.
1.3.0 | Added "w" option. The options parameter no longer accepts a boolean to signify an upsert. Instead, this now has to be done with array('upsert' => true).
1.2.11 | Emits E_DEPRECATED when options is scalar.
1.2.0 | Added "timeout" option.
1.0.11 | Disconnects on "not master" errors if "safe" is set.
1.0.9 | Added ability to pass integers to the "safe" option, which previously only accepted booleans. Added "fsync" option. The return type was changed to be an array containing error information if the "safe" option is used. Otherwise, a boolean is returned as before.
1.0.5 | Added "safe" option.
1.0.1 | Changed options parameter from boolean to array. Pre-1.0.1, the second parameter was an optional boolean value specifying an upsert.

Örnekler

Örnek 1 MongoCollection::update()

Adding an address field to a document.

<?php

$c->insert(array("firstname" => "Bob", "lastname" => "Jones" ));
$newdata = array('$set' => array("address" => "1 Smith Lane"));
$c->update(array("firstname" => "Bob"), $newdata);

var_dump($c->findOne(array("firstname" => "Bob")));

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(4) {
  ["_id"]=>
  object(MongoId)#6 (0) {
  }
  ["firstname"]=>
  string(3) "Bob"
  ["lastname"]=>
  string(5) "Jones"
  ["address"]=>
  string(12) "1 Smith Lane"
}

Örnek 2 MongoCollection::update() upsert examples

Upserts can simplify code, as a single line can create the document if it does not exist (based on $criteria), or update an existing document if it matches.

In the following example, $new_object contains an atomic modifier. Since the collection is empty and upsert must insert a new document, it will apply those operations to the $criteria parameter in order to create the document.

<?php

$c->drop();
$c->update(
    array("uri" => "/summer_pics"),
    array('$inc' => array("page hits" => 1)),
    array("upsert" => true)
);
var_dump($c->findOne());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(3) {
  ["_id"]=>
  object(MongoId)#9 (0) {
  }
  ["uri"]=>
  string(12) "/summer_pics"
  ["page hits"]=>
  int(1)
}

If $new_object does not contain atomic modifiers (i.e. $ operators), upsert will use $new_object as-is for the new document. This matches the behavior of a normal update, where not using atomic modifiers causes the document to be overwritten.

<?php

$c->drop();
$c->update(
    array("name" => "joe"),
    array("username" => "joe312", "createdAt" => new MongoDate()),
    array("upsert" => true)
);
var_dump($c->findOne());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(3) {
  ["_id"]=>
  object(MongoId)#10 (0) {
  }
  ["username"]=>
  string(6) "joe312"
  ["createdAt"]=>
  object(MongoDate)#4 (0) {
  }
}

Örnek 3 MongoCollection::update() multiple example

By default, MongoCollection::update() will only update the first document matching $criteria that it finds. Using the "multiple" option can override this behavior, if needed.

This example adds a "gift" field to every person whose birthday is in the next day.

<?php

$today = array('$gt' => new MongoDate(), '$lt' => new MongoDate(strtotime("+1 day")));
$people->update(
    array("birthday" => $today),
    array('$set' => array('gift' => $surprise)),
    array("multiple" => true)
);

?>

Ayrıca Bakınız

The PHP documentation on updates and the » MongoDB core docs.

MongoCollection::__toString
MongoCollection::validate
MongoCollection


Validates this collection

MongoCollection::update
MongoCursor
MongoCollection
PHP Manual

MongoCollection::validate

(PECL mongo >=0.9.0)

MongoCollection::validate — Validates this collection

Açıklama

public array MongoCollection::validate ([ bool $scan_data = FALSE ] )

Değiştirgeler

scan_data

Only validate indices, not the base collection.

Dönen Değerler

Returns the database's evaluation of this object.

MongoCollection::update
MongoCursor
MongoCollection


The MongoCursor class

(PECL mongo >=0.9.0)

Giriş

A cursor is used to iterate through the results of a database query. For example, to query the database and see all results, you could do:

Örnek 1 MongoCursor basic usage

<?php

$cursor = $collection->find();
var_dump(iterator_to_array($cursor));

?>

You don't generally create cursors using the MongoCursor constructor, you get a new cursor by calling MongoCollection::find() (as shown above).

Suppose that, in the example above, $collection was a 50GB collection. We certainly wouldn't want to load that into memory all at once, which is what a cursor is for: allowing the client to access the collection in dribs and drabs.

If we have a large result set, we can iterate through it, loading a few megabytes of results into memory at a time. For example, we could do:

Örnek 2 Iterating over MongoCursor

<?php

$cursor = $collection->find();

foreach ($cursor as $doc) {
    // do something to each document
}

?>
This will go through each document in the collection, loading and garbage collecting documents as needed.

Note that this means that a cursor does not "contain" the database results, it just manages them. Thus, if you print a cursor (with, say, var_dump() or print_r()), you'll just get the cursor object, not your documents. To get the documents themselves, you can use one of the methods shown above.

Cursor Stages

A MongoCursor has two "life stages": pre- and post- query. When a cursor is created, it has not yet contacted the database, so it is in its pre-query state. In this state, the client can further specify what they want the query to do, including adding limits, skips, sorts, and more advanced options.

When the client attempts to get a result (by calling MongoCursor::next(), directly or indirectly), the cursor moves into the post-query stage. At this point, the query has been executed by the database and cannot be modified anymore.

Örnek 3 Adding options to MongoCursor

<?php

$cursor = $collection->find()->limit(10);

// database has not yet been queried, so more search options can be added
$cursor = $cursor->sort(array("a" => 1));

var_dump($cursor->getNext());
// now database has been queried and more options cannot be added

// so this will throw an exception:
$cursor->skip(4);
?>

Sınıf Sözdizimi

MongoCursor implements MongoCursorInterface , Iterator {
/* Static Fields */
static boolean $slaveOkay = FALSE ;
static integer $timeout = 30000 ;
/* Yöntemler */
public MongoCursor addOption ( string $key , mixed $value )
public MongoCursor awaitData ([ bool $wait = true ] )
public MongoCursor batchSize ( int $batchSize )
public __construct ( MongoClient $connection , string $ns [, array $query = array() [, array $fields = array() ]] )
public int count ([ bool $foundOnly = FALSE ] )
public array current ( void )
public bool dead ( void )
protected void doQuery ( void )
public array explain ( void )
public MongoCursor fields ( array $f )
public array getNext ( void )
public array getReadPreference ( void )
public bool hasNext ( void )
public MongoCursor hint ( mixed $index )
public MongoCursor immortal ([ bool $liveForever = true ] )
public array info ( void )
public string|int key ( void )
public MongoCursor limit ( int $num )
public MongoCursor maxTimeMS ( int $ms )
public array next ( void )
public MongoCursor partial ([ bool $okay = true ] )
public void reset ( void )
public void rewind ( void )
public MongoCursor setFlag ( int $flag [, bool $set = true ] )
public MongoCursor setReadPreference ( string $read_preference [, array $tags ] )
public MongoCursor skip ( int $num )
public MongoCursor slaveOkay ([ bool $okay = true ] )
public MongoCursor snapshot ( void )
public MongoCursor sort ( array $fields )
public MongoCursor tailable ([ bool $tail = true ] )
public MongoCursor timeout ( int $ms )
public bool valid ( void )
}

Static Variables

slaveOkay

If the query should have the "slaveOkay" flag set, which allows reads on the secondary (secondaries are, by default, just for backup and not queried). Can be overridden with MongoCursor::slaveOkay().

This functionality is deprecated. Please use Read Preferences instead.

timeout

Set timeout in milliseconds for all database responses. Use -1 to wait forever. Can be overridden with MongoCursor::timeout(). This does not cause the MongoDB server to cancel the operation; it only instructs the driver to stop waiting for a response and throw a MongoCursorTimeoutException after a set time.

Ayrıca Bakınız

MongoDB core docs on » cursors.

İçindekiler

  • MongoCursor::addOption — Adds a top-level key/value pair to a query
  • MongoCursor::awaitData — Sets whether this cursor will wait for a while for a tailable cursor to return more data
  • MongoCursor::batchSize — Limits the number of elements returned in one batch.
  • MongoCursor::__construct — Create a new cursor
  • MongoCursor::count — Counts the number of results for this query
  • MongoCursor::current — Returns the current element
  • MongoCursor::dead — Checks if there are results that have not yet been sent from the database
  • MongoCursor::doQuery — Execute the query.
  • MongoCursor::explain — Return an explanation of the query, often useful for optimization and debugging
  • MongoCursor::fields — Sets the fields for a query
  • MongoCursor::getNext — Advances the cursor to the next result, and returns that result
  • MongoCursor::getReadPreference — Get the read preference for this query
  • MongoCursor::hasNext — Checks if there are any more elements in this cursor
  • MongoCursor::hint — Gives the database a hint about the query
  • MongoCursor::immortal — Sets whether this cursor will timeout
  • MongoCursor::info — Gets information about the cursor's creation and iteration
  • MongoCursor::key — Returns the current result's _id, or its index within the result set
  • MongoCursor::limit — Limits the number of results returned
  • MongoCursor::maxTimeMS — Sets a server-side timeout for this query
  • MongoCursor::next — Advances the cursor to the next result, and returns that result
  • MongoCursor::partial — If this query should fetch partial results from mongos if a shard is down
  • MongoCursor::reset — Clears the cursor
  • MongoCursor::rewind — Returns the cursor to the beginning of the result set
  • MongoCursor::setFlag — Sets arbitrary flags in case there is no method available the specific flag
  • MongoCursor::setReadPreference — Set the read preference for this query
  • MongoCursor::skip — Skips a number of results
  • MongoCursor::slaveOkay — Sets whether this query can be done on a secondary [deprecated]
  • MongoCursor::snapshot — Use snapshot mode for the query
  • MongoCursor::sort — Sorts the results by given fields
  • MongoCursor::tailable — Sets whether this cursor will be left open after fetching the last results
  • MongoCursor::timeout — Sets a client-side timeout for this query
  • MongoCursor::valid — Checks if the cursor is reading a valid result.
MongoCollection::validate
MongoCursor::addOption
Core Classes


Adds a top-level key/value pair to a query

MongoCursor
MongoCursor::awaitData
MongoCursor
PHP Manual

MongoCursor::addOption

(PECL mongo >=1.0.4)

MongoCursor::addOption — Adds a top-level key/value pair to a query

Açıklama

public MongoCursor MongoCursor::addOption ( string $key , mixed $value )

This is an advanced function and should not be used unless you know what you're doing.

A query can optionally be nested in a "query" field if other options, such as a sort or hint, are given. For instance, adding a sort causes the query to become a subfield of a bigger query object, like:

<?php

$query = array("query" => $query, "orderby" => $sort);

?>

This method is for adding a top-level field to a query. It makes the query a subobject (if it isn't already) and adds the key/value pair of your chosing to the top level.

Uyarı

It cannot be used to add extra criteria to a query on the fly. For instance, this will not work:

<?php

// NOT CORRECT
$cursor = $users->find()->addOption("name", "joe")->addOption("age", 20);

?>
This does not query for a user named "joe" with an age of 20.

Değiştirgeler

key

Fieldname to add.

value

Value to add.

Dönen Değerler

Returns this cursor.

Hatalar/İstisnalar

Throws MongoCursorException if this cursor has started iterating.

Örnekler

Örnek 1 Adding a comment with MongoCursor::addOption() example

MongoDB supports special options to be send to the server. The shell uses the _addSpecial option to send a $comment to the server. This comment will show up in the profiling log (for slow queries f.e.). In the PHP driver, you use the MongoCursor::addOption() method.

<?php
$m = new MongoClient;
$c = $m->demo->demo;
$cursor = $c->find();
$cursor->addOption('$comment', "This comment will show up in the profiling log");

foreach ($cursor as $document) { /* empty */ }
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

{
    "op" : "query",
    "ns" : "demo.demo",
    "query" : {
        "$query" : {

        },
        "$comment" : "This comment will show up in the profiling log"
    },
    "cursorid" : 168463566447,
    "ntoreturn" : 0,
    "ntoskip" : 0,
    "nscanned" : 101,
    "nscannedObjects" : 101,
    "keyUpdates" : 0,
    "numYield" : 0,
...

Örnek 2 MongoCursor::addOption() example

Using MongoCursor::skip() to skip over millions of results can become slow. One way around this is to use $min or $max options for the query. These can be handy, but they require an index on exactly the fields being searched for. This is an example of how to use $min as an alternative to MongoCursor::skip().

<?php

// make sure we have an index
$c->ensureIndex(array("ts" => 1));

// you may have to modify this to run in a reasonable amount of time on slow
// machines (should take about 30 seconds on a good machine)
for ($i = 0; $i < 30000000; $i++) {
    $c->insert(array("ts" => new MongoDate(), "i" => $i));
}

$now = strtotime("now");

// find documents inserted in the last 2 seconds
$cursor = $c->find()->addOption('$min', array("ts" => $now-2));

?>
MongoCursor
MongoCursor::awaitData
MongoCursor


Sets whether this cursor will wait for a while for a tailable cursor to return more data

MongoCursor::addOption
MongoCursor::batchSize
MongoCursor
PHP Manual

MongoCursor::awaitData

(PECL mongo >=1.2.11)

MongoCursor::awaitData — Sets whether this cursor will wait for a while for a tailable cursor to return more data

Açıklama

public MongoCursor MongoCursor::awaitData ([ bool $wait = true ] )

This method is to be used with tailable cursors. If we are at the end of the data, block for a while rather than returning no data. After a timeout period, we do return as normal.

Değiştirgeler

wait

If the cursor should wait for more data to become available.

Dönen Değerler

Returns this cursor.

Hatalar/İstisnalar

Throws MongoCursorException if this cursor has started iterating.

Örnekler

Örnek 1 MongoCursor::awaitData() example

In this example we tail the "oplog" and instead of sleeping during every iteration, we set the MongoCursor::awaitData() option. MongoCursor::hasNext() will now block until there is more data available.

<?php
$m = new MongoClient( 'mongodb://localhost:13000', array( 'replSet' => 'seta' ) );
$c = $m->local->selectCollection( 'oplog.rs' );
$cursor = $c->find( array( 'ns' => 'demo.article', 'op' => 'i' ) );
$cursor->tailable( true );
$cursor->awaitData( true );

while (true) {
    if (!$cursor->hasNext()) {
        // we've read all the results, exit
        if ($cursor->dead()) {
            break;
        }
    } else {
        var_dump( $cursor->getNext() );
    }
}
?>

Ayrıca Bakınız

MongoDB core docs on » tailable cursors.

  • MongoCursor::tailable() - Sets whether this cursor will be left open after fetching the last results

MongoCursor::addOption
MongoCursor::batchSize
MongoCursor


Limits the number of elements returned in one batch.

MongoCursor::awaitData
MongoCursor::__construct
MongoCursor
PHP Manual

MongoCursor::batchSize

(PECL mongo >=1.0.11)

MongoCursor::batchSize — Limits the number of elements returned in one batch.

Açıklama

public MongoCursor MongoCursor::batchSize ( int $batchSize )

A cursor typically fetches a batch of result objects and store them locally. This method sets the batchSize value to configure the amount of documents retrieved from the server in one round trip. However, it will never return more documents than fit in the max batch size limit (usually 4MB).

Değiştirgeler

batchSize

The number of results to return per batch. Each batch requires a round-trip to the server.

If batchSize is 2 or more, it represents the size of each batch of objects retrieved. It can be adjusted to optimize performance and limit data transfer.

If batchSize is 1 or negative, it will limit of number returned documents to the absolute value of batchSize, and the cursor will be closed. For example if batchSize is -10, then the server will return a maximum of 10 documents and as many as can fit in 4MB, then close the cursor.

Uyarı

A batchSize of 1 is special, and means the same as -1, i.e. a value of 1 makes the cursor only capable of returning one document.

Note that this feature is different from MongoCursor::limit() in that documents must fit within a maximum size, and it removes the need to send a request to close the cursor server-side. The batch size can be changed even after a cursor is iterated, in which case the setting will apply on the next batch retrieval.

This cannot override MongoDB's limit on the amount of data it will return to the client (i.e., if you set batch size to 1,000,000,000, MongoDB will still only return 4-16MB of results per batch).

To ensure consistent behavior, the rules of MongoCursor::batchSize() and MongoCursor::limit() behave a little complex but work "as expected". The rules are: hard limits override soft limits with preference given to MongoCursor::limit() over MongoCursor::batchSize(). After that, whichever is set and lower than the other will take precedence. See below. section for some examples.

Dönen Değerler

Returns this cursor.

Örnekler

Örnek 1 MongoCursor::batchSize() and combinations with MongoCursor::limit()

<?php

// one batch, at most 10 items. The -10 makes the server to return 10 items,
// and then remove the cursor.
$cursor->limit(20)->batchSize(-10);

// first batch: at most 10 items
$cursor->limit(10);

// first batch: at most 10 items
$cursor->limit(10)->batchSize(20);

// results are fetched in batches of 10 each, with a maximum of 20 items
// returned (that means two batches of 10).
$cursor->limit(20)->batchSize(10);

// results are fetched in batches of 7 each, with a maximum of 30 items
// returned (that means that the driver requests 4 batches of 7, and one batch
// of 2).
$cursor->limit(30)->batchSize(7)
?>

Ayrıca Bakınız

MongoDB core docs on » batchSize.

  • MongoCursor::limit() - Limits the number of results returned
  • MongoCursorInterface::batchSize() - Limits the number of elements returned in one batch.

Sürüm Bilgisi

Sürüm: | Açıklama
1.4.5 | Before 1.4.5, this method would throw an MongoCursorException if the cursor had already started iterating.

MongoCursor::awaitData
MongoCursor::__construct
MongoCursor


Create a new cursor

MongoCursor::batchSize
MongoCursor::count
MongoCursor
PHP Manual

MongoCursor::__construct

(PECL mongo >=0.9.0)

MongoCursor::__construct — Create a new cursor

Açıklama

public MongoCursor::__construct ( MongoClient $connection , string $ns [, array $query = array() [, array $fields = array() ]] )

Değiştirgeler

connection

Database connection.

ns

Full name of database and collection.

query

Database query.

fields

Fields to return.

Dönen Değerler

Returns the new cursor.

MongoCursor::batchSize
MongoCursor::count
MongoCursor


Counts the number of results for this query

MongoCursor::__construct
MongoCursor::current
MongoCursor
PHP Manual

MongoCursor::count

(PECL mongo >=0.9.2)

MongoCursor::count — Counts the number of results for this query

Açıklama

public int MongoCursor::count ([ bool $foundOnly = FALSE ] )

This method does not affect the state of the cursor: if you haven't queried yet, you can still apply limits, skips, etc. If you have started iterating through results, it will not move the current position of the cursor. If you have exhasted the cursor, it will not reset it.

Değiştirgeler

foundOnly

Send cursor limit and skip information to the count function, if applicable.

Dönen Değerler

The number of documents returned by this cursor's query.

Örnekler

Örnek 1 MongoCursor::count() example

<?php

$collection->insert(array('x'=>1));
$collection->insert(array('x'=>2));
$collection->insert(array('x'=>3));

$cursor = $collection->find();

var_dump($cursor->count());
var_dump($cursor->count(true));

$cursor->limit(2);

var_dump($cursor->count());
var_dump($cursor->count(true));

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(3)
int(3)
int(3)
int(2)

Hatalar/İstisnalar

Throws MongoConnectionException if it cannot reach the database.

MongoCursor::__construct
MongoCursor::current
MongoCursor


Returns the current element

MongoCursor::count
MongoCursor::dead
MongoCursor
PHP Manual

MongoCursor::current

(PECL mongo >=0.9.0)

MongoCursor::current — Returns the current element

Açıklama

public array MongoCursor::current ( void )

This returns NULL until MongoCursor::next() is called.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current result document as an associative array. NULL will be returned if there is no result.

Ayrıca Bakınız

  • Iterator::current() - O anki elemanı döndürür
MongoCursor::count
MongoCursor::dead
MongoCursor


Checks if there are results that have not yet been sent from the database

MongoCursor::current
MongoCursor::doQuery
MongoCursor
PHP Manual

MongoCursor::dead

(PECL mongo >=0.9.6)

MongoCursor::dead — Checks if there are results that have not yet been sent from the database

Açıklama

public bool MongoCursor::dead ( void )

The database sends responses in batches of documents, up to 4MB of documents per response. This method checks if the database has more batches or if the result set has been exhausted.

A cursor being "dead" does not mean that MongoCursor::hasNext() will return FALSE, it only means that the database is done sending results to the client. The client should continue iterating through results until MongoCursor::hasNext() is FALSE.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if there are more results that have not yet been sent to the client, and FALSE otherwise.

Ayrıca Bakınız

  • MongoCursorInterface::dead() - Checks if there are results that have not yet been sent from the database
MongoCursor::current
MongoCursor::doQuery
MongoCursor


Execute the query.

MongoCursor::dead
MongoCursor::explain
MongoCursor
PHP Manual

MongoCursor::doQuery

(PECL mongo >=0.9.0 <1.6.0)

MongoCursor::doQuery — Execute the query.

Açıklama

protected void MongoCursor::doQuery ( void )
Uyarı

Please do not use me.

This function actually queries the database. All queries and commands go through this function. Thus, this function can be overridden to provide custom query handling.

This handles serializing your query, sending it to the database, receiving a response, and deserializing it. Thus, if you are planning to override this, your code should probably call out to the original to use the existing functionality (see the example below).

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

NULL.

Hatalar/İstisnalar

Throws MongoConnectionException if it cannot reach the database.

Sürüm Bilgisi

Sürüm: | Açıklama
1.2.11 | Emits E_DEPRECATED when used.

Örnekler

Örnek 1 MongoCursor::doQuery() example

You could override this function to attempt a query on a secondary and, if that fails, try it again on the primary.

<?php

class MyCursor extends MongoCursor {

    protected function doQuery() {

        $this->slaveOkay();

        try {
            MongoCursor::doQuery();
        }
        catch(MongoCursorException $e) {
            $this->slaveOkay(false);
            MongoCursor::doQuery();
        }
    }
}

?>

MongoCursor::dead
MongoCursor::explain
MongoCursor


Return an explanation of the query, often useful for optimization and debugging

MongoCursor::doQuery
MongoCursor::fields
MongoCursor
PHP Manual

MongoCursor::explain

(PECL mongo >=0.9.2)

MongoCursor::explain — Return an explanation of the query, often useful for optimization and debugging

Açıklama

public array MongoCursor::explain ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an explanation of the query.

Örnekler

Örnek 1 MongoCursor::explain() example

<?php

$cursor = $collection->find(array("x"=>1), array("y"));
$cursor->sort(array("z" => 1))->limit(4)->skip(5);

var_dump($cursor->explain());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(8) {
  ["cursor"]=>
  string(15) "BtreeCursor x_1"
  ["startKey"]=>
  array(1) {
    ["x"]=>
    int(1)
  }
  ["endKey"]=>
  array(1) {
    ["x"]=>
    int(1)
  }
  ["nscanned"]=>
  float(4)
  ["n"]=>
  int(4)
  ["scanAndOrder"]=>
  int(1)
  ["millis"]=>
  int(3)
  ["allPlans"]=>
  array(2) {
    [0]=>
    array(3) {
      ["cursor"]=>
      string(15) "BtreeCursor x_1"
      ["startKey"]=>
      array(1) {
        ["x"]=>
        int(1)
      }
      ["endKey"]=>
      array(1) {
        ["x"]=>
        int(1)
      }
    }
    [1]=>
    array(3) {
      ["cursor"]=>
      string(11) "BasicCursor"
      ["startKey"]=>
      array(0) {
      }
      ["endKey"]=>
      array(0) {
      }
    }
  }
}

Hatalar/İstisnalar

Throws MongoConnectionException if it cannot reach the database.

Ayrıca Bakınız

MongoDB core docs on » explain.

MongoCursor::doQuery
MongoCursor::fields
MongoCursor


Sets the fields for a query

MongoCursor::explain
MongoCursor::getNext
MongoCursor
PHP Manual

MongoCursor::fields

(PECL mongo >=1.0.6)

MongoCursor::fields — Sets the fields for a query

Açıklama

public MongoCursor MongoCursor::fields ( array $f )

Fields are specified by "fieldname" : bool. TRUE indicates that a field should be returned, FALSE indicates that it should not be returned. You can also use 1 and 0 instead of TRUE and FALSE.

Thus, to return only the "summary" field, one could say:

<?php

$cursor->fields(array("summary" => true));

?>

To return all fields except the "hidden" field:

<?php

$cursor->fields(array("hidden" => false));

?>

Değiştirgeler

f

Fields to return (or not return).

Dönen Değerler

Returns this cursor.

Hatalar/İstisnalar

Throws MongoCursorException if this cursor has started iterating or a scalar argument is given.

MongoCursor::explain
MongoCursor::getNext
MongoCursor


Advances the cursor to the next result, and returns that result

MongoCursor::fields
MongoCursor::getReadPreference
MongoCursor
PHP Manual

MongoCursor::getNext

(PECL mongo >=0.9.0)

MongoCursor::getNext — Advances the cursor to the next result, and returns that result

Açıklama

public array MongoCursor::getNext ( void )

Bilginize:

MongoCursor::getNext() is an alias of MongoCursor::next().

MongoCursor::fields
MongoCursor::getReadPreference
MongoCursor


Get the read preference for this query

MongoCursor::getNext
MongoCursor::hasNext
MongoCursor
PHP Manual

MongoCursor::getReadPreference

(PECL mongo >=1.3.3)

MongoCursor::getReadPreference — Get the read preference for this query

Açıklama

public array MongoCursor::getReadPreference ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

This function returns an array describing the read preference. The array contains the values type for the string read preference mode (corresponding to the MongoClient constants), and tagsets containing a list of all tag set criteria. If no tag sets were specified, tagsets will not be present in the array.

Örnekler

Örnek 1 MongoCursor::getReadPreference() return value example

<?php

$m = new MongoClient();
$cursor = $m->test->users->find();
$cursor->setReadPreference(MongoClient::RP_SECONDARY, array(
    array('dc' => 'east', 'use' => 'reporting'),
    array('dc' => 'west'),
    array(),
));
var_dump($cursor->getReadPreference());
?>

Yukarıdaki örneğin çıktısı:

array(2) {
  ["type"]=>
  string(9) "secondary"
  ["tagsets"]=>
  array(3) {
    [0]=>
    array(2) {
      ["dc"]=>
      string(4) "east"
      ["use"]=>
      string(9) "reporting"
    }
    [1]=>
    array(1) {
      ["dc"]=>
      string(7) "west"
    }
    [2]=>
    array(0) {
    }
  }
}

Ayrıca Bakınız

  • The read preferences documentation.
  • MongoCursor::setReadPreference() - Set the read preference for this query
  • MongoCursorInterface::getReadPreference() - Get the read preference for this query
MongoCursor::getNext
MongoCursor::hasNext
MongoCursor


Checks if there are any more elements in this cursor

MongoCursor::getReadPreference
MongoCursor::hint
MongoCursor
PHP Manual

MongoCursor::hasNext

(PECL mongo >=0.9.0)

MongoCursor::hasNext — Checks if there are any more elements in this cursor

Açıklama

public bool MongoCursor::hasNext ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns if there is another element.

Hatalar/İstisnalar

Throws MongoConnectionException if it cannot reach the database and MongoCursorTimeoutException if the timeout is exceeded.

MongoCursor::getReadPreference
MongoCursor::hint
MongoCursor


Gives the database a hint about the query

MongoCursor::hasNext
MongoCursor::immortal
MongoCursor
PHP Manual

MongoCursor::hint

(PECL mongo >=0.9.0)

MongoCursor::hint — Gives the database a hint about the query

Açıklama

public MongoCursor MongoCursor::hint ( mixed $index )

Değiştirgeler

index

Index to use for the query. If a string is passed, it should correspond to an index name. If an array or object is passed, it should correspond to the specification used to create the index (i.e. the first argument to MongoCollection::ensureIndex()).

Dönen Değerler

Returns this cursor.

Hatalar/İstisnalar

Throws MongoCursorException if this cursor has started iterating.

Sürüm Bilgisi

Sürüm: | Açıklama
1.4.0 | The index argument now supports index names as string values. In versions before 1.4.0, only array or object values were accepted.

MongoCursor::hasNext
MongoCursor::immortal
MongoCursor


Sets whether this cursor will timeout

MongoCursor::hint
MongoCursor::info
MongoCursor
PHP Manual

MongoCursor::immortal

(PECL mongo >=1.0.1)

MongoCursor::immortal — Sets whether this cursor will timeout

Açıklama

public MongoCursor MongoCursor::immortal ([ bool $liveForever = true ] )

After remaining idle on the server for some amount of time, cursors, by default, "die." This is generally the behavior one wants. The database cleans up a cursor once all of its results have been sent to the client, but if the client doesn't request all of the results, the cursor will languish there, taking up resources. Thus, after a few minutes, the cursor "times out" and the database assumes the client has gotten everything it needs and cleans up its the cursor's resources.

If, for some reason, you need a cursor to hang around for a long time, you can prevent the database from cleaning it up by using this method. However, if you make a cursor immortal, you need to iterate through all of its results (or at least until MongoCursor::dead() returns TRUE) or the cursor will hang around the database forever, taking up resources.

Değiştirgeler

liveForever

If the cursor should be immortal.

Dönen Değerler

Returns this cursor.

Hatalar/İstisnalar

Throws MongoCursorException if this cursor has started iterating.

MongoCursor::hint
MongoCursor::info
MongoCursor


Gets information about the cursor's creation and iteration

MongoCursor::immortal
MongoCursor::key
MongoCursor
PHP Manual

MongoCursor::info

(PECL mongo >=1.0.5)

MongoCursor::info — Gets information about the cursor's creation and iteration

Açıklama

public array MongoCursor::info ( void )

This can be called before or after the cursor has started iterating.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the namespace, batch size, limit, skip, flags, query, and projected fields for this cursor. If the cursor has started iterating, additional information about iteration and the connection will be included.

Sürüm Bilgisi

Sürüm: | Açıklama
1.1.0 | Added a number of other fields, including id (the cursor id), at (the driver's counter of which document is current), numReturned (the number returned by the server in the current batch), and server (which server the query was sent to—useful in conjunction with Read Preferences.
1.0.10 | Added started_iterating field, a boolean indicating if cursor is pre- or post-query.

Örnekler

Örnek 1 MongoCursor::info() example

<?php
$m = new MongoClient();

$cursor = $m->test->foo->find(array("x" => 4), array("y" => 0));

echo "Before iteration started:\n";
var_dump($cursor->info());

echo "\nAfter iteration started:\n";
$cursor->rewind();
var_dump($cursor->info());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Before iteration started:
array(8) {
  ["ns"]=>
  string(8) "test.foo"
  ["limit"]=>
  int(0)
  ["batchSize"]=>
  int(0)
  ["skip"]=>
  int(0)
  ["flags"]=>
  int(0)
  ["query"]=>
  array(1) {
    ["x"]=>
    int(4)
  }
  ["fields"]=>
  array(1) {
    ["y"]=>
    int(0)
  }
  ["started_iterating"]=>
  bool(false)
}

After iteration started:
array(15) {
  ["ns"]=>
  string(8) "test.foo"
  ["limit"]=>
  int(0)
  ["batchSize"]=>
  int(0)
  ["skip"]=>
  int(0)
  ["flags"]=>
  int(0)
  ["query"]=>
  array(1) {
    ["x"]=>
    int(4)
  }
  ["fields"]=>
  array(1) {
    ["y"]=>
    int(0)
  }
  ["started_iterating"]=>
  bool(true)
  ["id"]=>
  int(0)
  ["at"]=>
  int(0)
  ["numReturned"]=>
  int(1)
  ["server"]=>
  string(25) "localhost:27017;-;.;26450"
  ["host"]=>
  string(9) "localhost"
  ["port"]=>
  int(27017)
  ["connection_type_desc"]=>
  string(10) "STANDALONE"
}

Ayrıca Bakınız

  • MongoCursorInterface::info() - Gets information about the cursor's creation and iteration
MongoCursor::immortal
MongoCursor::key
MongoCursor


Returns the current result's _id, or its index within the result set

MongoCursor::info
MongoCursor::limit
MongoCursor
PHP Manual

MongoCursor::key

(PECL mongo >=0.9.0)

MongoCursor::key — Returns the current result's _id, or its index within the result set

Açıklama

public string|int MongoCursor::key ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current result's _id as a string. If the result has no _id, its numeric index within the result set will be returned as an integer.

Ayrıca Bakınız

  • Iterator::key() - O anki elemanın anahtarını döndürür
MongoCursor::info
MongoCursor::limit
MongoCursor


Limits the number of results returned

MongoCursor::key
MongoCursor::maxTimeMS
MongoCursor
PHP Manual

MongoCursor::limit

(PECL mongo >=0.9.0)

MongoCursor::limit — Limits the number of results returned

Açıklama

public MongoCursor MongoCursor::limit ( int $num )

Değiştirgeler

num

The number of results to return.

Dönen Değerler

Returns this cursor.

Hatalar/İstisnalar

Throws MongoCursorException if this cursor has started iterating.

Ayrıca Bakınız

  • MongoDB core docs on » limit.
  • MongoCursor::batchSize() - Limits the number of elements returned in one batch.
  • MongoCursor::skip() - Skips a number of results

MongoCursor::key
MongoCursor::maxTimeMS
MongoCursor


Sets a server-side timeout for this query

MongoCursor::limit
MongoCursor::next
MongoCursor
PHP Manual

MongoCursor::maxTimeMS

(PECL mongo >=1.5.0)

MongoCursor::maxTimeMS — Sets a server-side timeout for this query

Açıklama

public MongoCursor MongoCursor::maxTimeMS ( int $ms )

Specifies a cumulative time limit in milliseconds to be allowed by the server for processing operations on the cursor.

Değiştirgeler

ms

Specifies a cumulative time limit in milliseconds to be allowed by the server for processing operations on the cursor.

Dönen Değerler

This cursor.

Hatalar/İstisnalar

Throws MongoCursorException if this cursor has started iterating.

Causes methods that fetch results to throw a MongoExecutionTimeoutException if the query takes longer than the specified number of milliseconds in processing time.

Örnekler

Örnek 1 MongoCursor::maxTimeMS() example

In the following example, the server will abort the query if the cursor requires more than two seconds in processing time to return its results.

<?php

$cursor = $collection->find();
$cursor->maxTimeMS(2000);

try {
    $results = iterator_to_array($cursor);
} catch (MongoExecutionTimeoutException $e) {
    echo "query took too long!";
}

?>

Notlar

Uyarı

Unlike MongoCursor::timeout(), which specifies a client-side timeout, MongoCursor::maxTimeMS() can be used to cause the MongoDB server to abort long-running queries. This timeout is cumulative for the lifetime of the cursor (i.e. each batch will contribute to this time limit). The timeout only considers processing time; idle time is not considered.

MongoCursor::limit
MongoCursor::next
MongoCursor


Advances the cursor to the next result, and returns that result

MongoCursor::maxTimeMS
MongoCursor::partial
MongoCursor
PHP Manual

MongoCursor::next

(PECL mongo >=0.9.0)

MongoCursor::next — Advances the cursor to the next result, and returns that result

Açıklama

public array MongoCursor::next ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the next document.

Hatalar/İstisnalar

Throws MongoConnectionException if it cannot reach the database and MongoCursorTimeoutException if the timeout is exceeded.

Ayrıca Bakınız

  • Iterator::next() - Konumu sonraki elemana ilerletir
MongoCursor::maxTimeMS
MongoCursor::partial
MongoCursor


If this query should fetch partial results from mongos if a shard is down

MongoCursor::next
MongoCursor::reset
MongoCursor
PHP Manual

MongoCursor::partial

(PECL mongo >=1.2.0)

MongoCursor::partial — If this query should fetch partial results from mongos if a shard is down

Açıklama

public MongoCursor MongoCursor::partial ([ bool $okay = true ] )

This option allows mongos to send partial query results if a shard is unreachable. This is only applicable when running a sharded MongoDB cluster and connecting to a mongos.

If a shard goes down and a query needs to be sent to that shard, mongos will return the results (if any) from shards it already contacted, then an error message that it could not reach the shard (a MongoCursorException in PHP). If you would like to get whatever results mongos can provide and no exception, you can use this method. Note that this means that you won't have an indication that a shard is down in your query response.

This has no effect on the query if all shards are reachable. This flag was implemented in MongoDB version 1.7.5, so will only work with that version and higher.

Değiştirgeler

okay

If receiving partial results is okay.

Dönen Değerler

Returns this cursor.

Hatalar/İstisnalar

Throws MongoCursorException if this cursor has started iterating.

MongoCursor::next
MongoCursor::reset
MongoCursor


Clears the cursor

MongoCursor::partial
MongoCursor::rewind
MongoCursor
PHP Manual

MongoCursor::reset

(PECL mongo >=0.9.0)

MongoCursor::reset — Clears the cursor

Açıklama

public void MongoCursor::reset ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

NULL.

MongoCursor::partial
MongoCursor::rewind
MongoCursor


Returns the cursor to the beginning of the result set

MongoCursor::reset
MongoCursor::setFlag
MongoCursor
PHP Manual

MongoCursor::rewind

(PECL mongo >=0.9.0)

MongoCursor::rewind — Returns the cursor to the beginning of the result set

Açıklama

public void MongoCursor::rewind ( void )

This is identical to the function:

<?php

public function rewind() {
    $this->reset();
    $this->next();
}

?>

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

NULL.

Hatalar/İstisnalar

Throws MongoConnectionException if it cannot reach the database and MongoCursorTimeoutException if the timeout is exceeded.

Ayrıca Bakınız

  • Iterator::rewind() - Yineleyiciyi ilk elemana konumlandırır
MongoCursor::reset
MongoCursor::setFlag
MongoCursor


Sets arbitrary flags in case there is no method available the specific flag

MongoCursor::rewind
MongoCursor::setReadPreference
MongoCursor
PHP Manual

MongoCursor::setFlag

(PECL mongo >=1.2.11)

MongoCursor::setFlag — Sets arbitrary flags in case there is no method available the specific flag

Açıklama

public MongoCursor MongoCursor::setFlag ( int $flag [, bool $set = true ] )

The MongoCursor class has several methods for setting flags on the query object. This method is available in case the MongoDB wire protocol has acquired a new flag, and the driver has not been updated with a method for this new flag. In all other cases, the method should be used. See the "See also" section for available methods.

Değiştirgeler

flag

Which flag to set. You can not set flag 6 (EXHAUST) as the driver does not know how to handle them. You will get a warning if you try to use this flag. For available flags, please refer to the wire protocol » documentation.

set

Whether the flag should be set (TRUE) or unset (FALSE).

Dönen Değerler

Returns this cursor.

Hatalar/İstisnalar

Shows a warning when an unsupport flag is attempted to be set.

Sürüm Bilgisi

Sürüm: | Açıklama
1.4.0 | Support for flag 3 (OPLOG_REPLAY) is added. Versions before 1.4.0 would throw a warning saying that the flag is unsupported.

Örnekler

Örnek 1 MongoCursor::setFlag() example

<?php
$m = new MongoClient( 'mongodb://localhost:13000', array( 'replSet' => 'seta' ) );
$c = $m->local->selectCollection( 'oplog.rs' );
$cursor = $c->find( array( 'ns' => 'demo.article', 'op' => 'i' ) );
$cursor->setFlag( 1, true ); // sets the tailable flag
$cursor->setFlag( 5, true ); // sets the await data flag
?>

Ayrıca Bakınız

  • MongoCursor::tailable() - Sets whether this cursor will be left open after fetching the last results
  • MongoCursor::immortal() - Sets whether this cursor will timeout
  • MongoCursor::awaitData() - Sets whether this cursor will wait for a while for a tailable cursor to return more data
  • MongoCursor::partial() - If this query should fetch partial results from mongos if a shard is down
  • MongoDB core docs on» wire protocol query flags

MongoCursor::rewind
MongoCursor::setReadPreference
MongoCursor


Set the read preference for this query

MongoCursor::setFlag
MongoCursor::skip
MongoCursor
PHP Manual

MongoCursor::setReadPreference

(PECL mongo >=1.3.3)

MongoCursor::setReadPreference — Set the read preference for this query

Açıklama

public MongoCursor MongoCursor::setReadPreference ( string $read_preference [, array $tags ] )

Değiştirgeler

read_preference

The read preference mode: MongoClient::RP_PRIMARY, MongoClient::RP_PRIMARY_PREFERRED, MongoClient::RP_SECONDARY, MongoClient::RP_SECONDARY_PREFERRED, or MongoClient::RP_NEAREST.

tags

An array of zero or more tag sets, where each tag set is itself an array of criteria used to match tags on replica set members.

Dönen Değerler

Returns this cursor.

Hatalar/İstisnalar

Emits E_WARNING if either parameter is invalid, or if one or more tag sets are provided with the MongoClient::RP_PRIMARY read preference mode.

Örnekler

Örnek 1 MongoCursor::setReadPreference() tag set array syntax example

<?php

$m = new MongoClient();
$cursor = $m->test->users->find();

// Prefer the nearest server in the "east" data center also used for reporting,
// but fall back to a server in the "west" data center
$cursor->setReadPreference(MongoClient::RP_NEAREST, array(
    array('dc' => 'east', 'use' => 'reporting'),
    array('dc' => 'west'),
));
?>

Ayrıca Bakınız

  • The read preferences documentation.
  • MongoCursor::getReadPreference() - Get the read preference for this query
  • MongoCursorInterface::setReadPreference() - Set the read preference for this query
MongoCursor::setFlag
MongoCursor::skip
MongoCursor


Skips a number of results

MongoCursor::setReadPreference
MongoCursor::slaveOkay
MongoCursor
PHP Manual

MongoCursor::skip

(PECL mongo >=0.9.0)

MongoCursor::skip — Skips a number of results

Açıklama

public MongoCursor MongoCursor::skip ( int $num )

Değiştirgeler

num

The number of results to skip.

Dönen Değerler

Returns this cursor.

Hatalar/İstisnalar

Throws MongoCursorException if this cursor has started iterating.

Ayrıca Bakınız

  • MongoCursor::limit() - Limits the number of results returned

MongoCursor::setReadPreference
MongoCursor::slaveOkay
MongoCursor


Sets whether this query can be done on a secondary [deprecated]

MongoCursor::skip
MongoCursor::snapshot
MongoCursor
PHP Manual

MongoCursor::slaveOkay

(PECL mongo >=0.9.4)

MongoCursor::slaveOkay — Sets whether this query can be done on a secondary [deprecated]

Açıklama

public MongoCursor MongoCursor::slaveOkay ([ bool $okay = true ] )
Uyarı

This method is deprecated since version 1.5.0. Instead, please use MongoCursor::setReadPreference() and Read Preferences.

Calling this will make the driver route reads to secondaries if:

  • You are using a replica set, and
  • You created a MongoClient instance using the option "replicaSet" => "setName", and
  • There is a healthy secondary that can be reached by the driver.
You can check which server was used for this query by calling MongoCursor::info() after running the query. It's server field will show which server the query was sent to.

Note that you should use this function even if you do not use the automatic routing to secondaries. If you connect directly to a secondary in a replica set, you still need to call this function, which basically tells the database that you are aware that you might be getting older data and you're okay with that. If you do not call this, you'll get "not master" errors when you try to query.

This method will override the static class variable
MongoCursor::$slaveOkay.  It will also override
Mongo::setSlaveOkay(),
MongoDB::setSlaveOkay() and
MongoCollection::setSlaveOkay().

Değiştirgeler

okay

If it is okay to query the secondary.

Dönen Değerler

Returns this cursor.

Hatalar/İstisnalar

Throws MongoCursorException if this cursor has started iterating.

Örnekler

Örnek 1 MongoCursor::slaveOkay() example

<?php

MongoCursor::$slaveOkay = false;

// cannot query secondary
$cursor = $collection->find();

// can query secondary
$cursor = $collection->find()->slaveOkay();

MongoCursor::$slaveOkay = true;

// can query secondary
$cursor = $collection->find();

// cannot query secondary
$cursor = $collection->find()->slaveOkay(false);

?>

Ayrıca Bakınız

  • Read Preferences
  • MongoCursor::setReadPreference() - Set the read preference for this query
  • MongoCursor::getReadPreference() - Get the read preference for this query

Sürüm Bilgisi

Sürüm: | Açıklama
1.5.0 | This method has been deprecated in favour of MongoCursor::setReadPreference() and Read Preferences.

MongoCursor::skip
MongoCursor::snapshot
MongoCursor


Use snapshot mode for the query

MongoCursor::slaveOkay
MongoCursor::sort
MongoCursor
PHP Manual

MongoCursor::snapshot

(PECL mongo >=0.9.4)

MongoCursor::snapshot — Use snapshot mode for the query

Açıklama

public MongoCursor MongoCursor::snapshot ( void )

Use snapshot mode for the query. Snapshot mode ensures that a document will not be returned more than once because an intervening write operation results in a move of the document. Documents inserted or deleted during the lifetime of the cursor may or may not be returned, irrespective of snapshot mode.

Queries with short responses (less than 1MB) are always effectively snapshotted.

Snapshot mode may not be used with sorting, explicit hints, or queries on sharded collections.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns this cursor.

Hatalar/İstisnalar

Throws MongoCursorException if this cursor has started iterating.

Ayrıca Bakınız

MongoDB core docs on » $snapshot operator.

MongoCursor::slaveOkay
MongoCursor::sort
MongoCursor


Sorts the results by given fields

MongoCursor::snapshot
MongoCursor::tailable
MongoCursor
PHP Manual

MongoCursor::sort

(PECL mongo >=0.9.0)

MongoCursor::sort — Sorts the results by given fields

Açıklama

public MongoCursor MongoCursor::sort ( array $fields )

Değiştirgeler

fields

An array of fields by which to sort. Each element in the array has as key the field name, and as value either 1 for ascending sort, or -1 for descending sort.

Each result is first sorted on the first field in the array, then (if it exists) on the second field in the array, etc. This means that the order of the fields in the fields array is important. See also the examples section.

Dönen Değerler

Returns the same cursor that this method was called on.

Hatalar/İstisnalar

Throws MongoCursorException if this cursor has started iterating.

Örnekler

Örnek 1 MongoCursor::sort() example

<?php
// Sort on field x, ascending
$cursor->sort(array('x' => 1));

// The order in the associative array is important. For instance, these two
// examples will yield different results:

// Sort on date ascending and age descending
$cursor->sort(array('date' => 1, 'age' => -1));

// Sort on age descending and date ascending
$cursor->sort(array('age' => -1, 'date' => 1));
?>
MongoCursor::snapshot
MongoCursor::tailable
MongoCursor


Sets whether this cursor will be left open after fetching the last results

MongoCursor::sort
MongoCursor::timeout
MongoCursor
PHP Manual

MongoCursor::tailable

(PECL mongo >=0.9.4)

MongoCursor::tailable — Sets whether this cursor will be left open after fetching the last results

Açıklama

public MongoCursor MongoCursor::tailable ([ bool $tail = true ] )

Mongo has a feature known as tailable cursors which are similar to the Unix "tail -f" command.

Tailable means cursor is not closed when the last data is retrieved. Rather, the cursor marks the final object's position. you can resume using the cursor later, from where it was located, if more data were received.

Like any "latent cursor", the cursor may become invalid at some point -- for example if that final object it references were deleted. Thus, you should be prepared to requery if the cursor is MongoCursor::dead().

Değiştirgeler

tail

If the cursor should be tailable.

Dönen Değerler

Returns this cursor.

Hatalar/İstisnalar

Throws MongoCursorException if this cursor has started iterating.

Örnekler

Örnek 1 MongoCursor::tailable() example

<?php

$cursor = $collection->find()->tailable();

$results = array();

while (1) {
    if (!$cursor->hasNext()) {
        // we've read all the results, exit
        if ($cursor->dead()) {
            break;
        }
        // read all results so far, wait for more
        sleep(10);
    }
    else {
        $results[] = $cursor->getNext();
    }
}

?>

Ayrıca Bakınız

MongoDB core docs on » tailable cursors.

  • MongoCursor::awaitData() - Sets whether this cursor will wait for a while for a tailable cursor to return more data

MongoCursor::sort
MongoCursor::timeout
MongoCursor


Sets a client-side timeout for this query

MongoCursor::tailable
MongoCursor::valid
MongoCursor
PHP Manual

MongoCursor::timeout

(PECL mongo >=1.0.3)

MongoCursor::timeout — Sets a client-side timeout for this query

Açıklama

public MongoCursor MongoCursor::timeout ( int $ms )

A timeout can be set at any time and will affect subsequent queries on the cursor, including fetching more results from the database.

Değiştirgeler

ms

The number of milliseconds for the cursor to wait for a response. Use -1 to wait forever. By default, the cursor will wait 30000 milliseconds (30 seconds).

Dönen Değerler

This cursor.

Hatalar/İstisnalar

Causes methods that fetch results to throw a MongoCursorTimeoutException if the query takes longer than the specified number of milliseconds.

Örnekler

Örnek 1 MongoCursor::timeout() example

In the following example, the driver will wait forever for the initial database response, and then wait 100ms for subsequent responses.

<?php

$cursor = $collection->find();
$cursor->timeout(-1);

/* $cursor->hasNext() executes the query. An infinite timeout has been set, so
 * the driver will wait as long as necessary for a response.
 */
while ($cursor->hasNext()) {
    $cursor->timeout(100);

    /* A timeout has now been set, so if the cursor needs to get more results
     * from the database, it will only wait 100ms for a response.
     */
    try {
        print_r($cursor->getNext());
    } catch (MongoCursorTimeoutException $e) {
        echo "query took too long!";
    }
}

?>

Notlar

Uyarı

This does not cause the MongoDB server to cancel long-running operations; it only instructs the driver to stop waiting for a response and throw a MongoCursorTimeoutException after a set time. If you need to specify a server-side timeout for a query, consider using MongoCursor::maxTimeMS().

Ayrıca Bakınız

  • MongoCursorInterface::timeout() - Sets a client-side timeout for this query
  • The socketTimeoutMS option for MongoClient::__construct()
MongoCursor::tailable
MongoCursor::valid
MongoCursor


Checks if the cursor is reading a valid result.

MongoCursor::timeout
MongoCursorInterface
MongoCursor
PHP Manual

MongoCursor::valid

(PECL mongo >=0.9.0)

MongoCursor::valid — Checks if the cursor is reading a valid result.

Açıklama

public bool MongoCursor::valid ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

TRUE if the current result is not null, and FALSE otherwise.

Ayrıca Bakınız

  • Iterator::valid() - O anki konum geçerli mi diye bakar
MongoCursor::timeout
MongoCursorInterface
MongoCursor


The MongoCursorInterface interface

(PECL mongo >=1.5.0)

Giriş

Interface for cursors, which can be used to iterate through results of a database query or command. This interface is implemented by the MongoCursor and MongoCommandCursor classes.

Bilginize: Similar to Traversable, this interface cannot be implemented in PHP scripts.

Sınıf Sözdizimi

MongoCursorInterface extends Iterator {
/* Yöntemler */
abstract public MongoCursorInterface batchSize ( int $batchSize )
abstract public bool dead ( void )
abstract public array getReadPreference ( void )
abstract public array info ( void )
abstract public MongoCursorInterface setReadPreference ( string $read_preference [, array $tags ] )
abstract public MongoCursorInterface timeout ( int $ms )
/* Miras alınan yöntemler */
abstract public mixed Iterator::current ( void )
abstract public scalar Iterator::key ( void )
abstract public void Iterator::next ( void )
abstract public void Iterator::rewind ( void )
abstract public boolean Iterator::valid ( void )
}

İçindekiler

  • MongoCursorInterface::batchSize — Limits the number of elements returned in one batch.
  • MongoCursorInterface::dead — Checks if there are results that have not yet been sent from the database
  • MongoCursorInterface::getReadPreference — Get the read preference for this query
  • MongoCursorInterface::info — Gets information about the cursor's creation and iteration
  • MongoCursorInterface::setReadPreference — Set the read preference for this query
  • MongoCursorInterface::timeout — Sets a client-side timeout for this query
MongoCursor::valid
MongoCursorInterface::batchSize
Core Classes


Limits the number of elements returned in one batch.

MongoCursorInterface
MongoCursorInterface::dead
MongoCursorInterface
PHP Manual

MongoCursorInterface::batchSize

(PECL mongo >=1.5.0)

MongoCursorInterface::batchSize — Limits the number of elements returned in one batch.

Açıklama

abstract public MongoCursorInterface MongoCursorInterface::batchSize ( int $batchSize )

A cursor typically fetches a batch of result objects and stores them locally. This method sets the batch size value to configure the amount of documents retrieved from the server in one round trip.

Değiştirgeler

batchSize

The number of results to return per batch.

Dönen Değerler

Returns this cursor.

MongoCursorInterface
MongoCursorInterface::dead
MongoCursorInterface


Checks if there are results that have not yet been sent from the database

MongoCursorInterface::batchSize
MongoCursorInterface::getReadPreference
MongoCursorInterface
PHP Manual

MongoCursorInterface::dead

(PECL mongo >=1.5.0)

MongoCursorInterface::dead — Checks if there are results that have not yet been sent from the database

Açıklama

abstract public bool MongoCursorInterface::dead ( void )

This method checks whether the cursor has been exhausted and the database has no more results to send to the client. A cursor being "dead" does not necessarily mean that there are no more results available for iteration.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if there are more results that have not yet been sent to the client, and FALSE otherwise.

MongoCursorInterface::batchSize
MongoCursorInterface::getReadPreference
MongoCursorInterface


Get the read preference for this query

MongoCursorInterface::dead
MongoCursorInterface::info
MongoCursorInterface
PHP Manual

MongoCursorInterface::getReadPreference

(PECL mongo >=1.6.0)

MongoCursorInterface::getReadPreference — Get the read preference for this query

Açıklama

abstract public array MongoCursorInterface::getReadPreference ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

This function returns an array describing the read preference. The array contains the values type for the string read preference mode (corresponding to the MongoClient constants), and tagsets containing a list of all tag set criteria. If no tag sets were specified, tagsets will not be present in the array.

Ayrıca Bakınız

  • The read preferences documentation.
  • MongoCursorInterface::setReadPreference() - Set the read preference for this query
MongoCursorInterface::dead
MongoCursorInterface::info
MongoCursorInterface


Gets information about the cursor's creation and iteration

MongoCursorInterface::getReadPreference
MongoCursorInterface::setReadPreference
MongoCursorInterface
PHP Manual

MongoCursorInterface::info

(PECL mongo >=1.5.0)

MongoCursorInterface::info — Gets information about the cursor's creation and iteration

Açıklama

abstract public array MongoCursorInterface::info ( void )

Returns information about the cursor's creation and iteration. This can be called before or after the cursor has started iterating.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the namespace, batch size, limit, skip, flags, query, and projected fields for this cursor. If the cursor has started iterating, additional information about iteration and the connection will be included.

MongoCursorInterface::getReadPreference
MongoCursorInterface::setReadPreference
MongoCursorInterface


Set the read preference for this query

MongoCursorInterface::info
MongoCursorInterface::timeout
MongoCursorInterface
PHP Manual

MongoCursorInterface::setReadPreference

(PECL mongo >=1.6.0)

MongoCursorInterface::setReadPreference — Set the read preference for this query

Açıklama

abstract public MongoCursorInterface MongoCursorInterface::setReadPreference ( string $read_preference [, array $tags ] )

Değiştirgeler

read_preference

The read preference mode: MongoClient::RP_PRIMARY, MongoClient::RP_PRIMARY_PREFERRED, MongoClient::RP_SECONDARY, MongoClient::RP_SECONDARY_PREFERRED, or MongoClient::RP_NEAREST.

tags

An array of zero or more tag sets, where each tag set is itself an array of criteria used to match tags on replica set members.

Dönen Değerler

Returns this cursor.

Hatalar/İstisnalar

Emits E_WARNING if either parameter is invalid, or if one or more tag sets are provided with the MongoClient::RP_PRIMARY read preference mode.

Ayrıca Bakınız

  • The read preferences documentation.
  • MongoCursorInterface::getReadPreference() - Get the read preference for this query
MongoCursorInterface::info
MongoCursorInterface::timeout
MongoCursorInterface


Sets a client-side timeout for this query

MongoCursorInterface::setReadPreference
MongoCommandCursor
MongoCursorInterface
PHP Manual

MongoCursorInterface::timeout

(PECL mongo >=1.5.0)

MongoCursorInterface::timeout — Sets a client-side timeout for this query

Açıklama

abstract public MongoCursorInterface MongoCursorInterface::timeout ( int $ms )

A timeout can be set at any time and will affect subsequent data retrieval associated with this cursor, including fetching more results from the database.

Değiştirgeler

ms

The number of milliseconds for the cursor to wait for a response. Use -1 to wait forever. By default, the cursor will wait 30000 milliseconds (30 seconds).

Dönen Değerler

Returns this cursor.

Hatalar/İstisnalar

Causes methods that fetch results to throw a MongoCursorTimeoutException if the data fetch takes longer than the specified number of milliseconds.

Ayrıca Bakınız

  • The socketTimeoutMS option for MongoClient::__construct()
MongoCursorInterface::setReadPreference
MongoCommandCursor
MongoCursorInterface


The MongoCommandCursor class

(PECL mongo >=1.5.0)

Giriş

A command cursor is similar to a MongoCursor except that you use it for iterating through the results of a database command instead of a normal query. Command cursors are useful for iterating over large result sets that might exceed the document size limit (currently 16MB) of a single MongoDB::command() response.

While you can create command cursors using MongoCommandCursor::__construct() or the MongoCommandCursor::createFromDocument() factory method, you will generally want to use command-specific helpers such as MongoCollection::aggregateCursor().

Note that the cursor does not "contain" the database command's results; it just manages iteration through them. Thus, if you print a cursor (f.e. with var_dump() or print_r()), you will see the cursor object but not the result documents.

Cursor Stages

A MongoCommandCursor has two "life stages": pre- and post- command. When a cursor is created, it has not yet contacted the database, so it is in its pre-command state. When the client first attempts to get a result (by calling MongoCommandCursor::rewind(), directly or indirectly), the cursor moves into the post-command state.

The command cursor's batch size and socket timeout may be configured in both the pre- and post- command states.

Örnek 1 Adding options to MongoCommandCursor

<?php

$cursor = new MongoCommandCursor(...);

$cursor = $cursor->batchSize( 4 );

foreach ($cursor as $result) {
    var_dump($result);
}
?>

Sınıf Sözdizimi

MongoCommandCursor implements MongoCursorInterface , Iterator {
/* Yöntemler */
public MongoCommandCursor batchSize ( int $batchSize )
public __construct ( MongoClient $connection , string $ns , array $command = array() )
public static MongoCommandCursor createFromDocument ( MongoClient $connection , string $hash , array $document )
public array current ( void )
public bool dead ( void )
public array getReadPreference ( void )
public array info ( void )
public int key ( void )
public void next ( void )
public array rewind ( void )
public MongoCommandCursor setReadPreference ( string $read_preference [, array $tags ] )
public MongoCommandCursor timeout ( int $ms )
public bool valid ( void )
}

Ayrıca Bakınız

  • MongoDB::command()
  • MongoCollection::aggregateCursor()

İçindekiler

  • MongoCommandCursor::batchSize — Limits the number of elements returned in one batch.
  • MongoCommandCursor::__construct — Create a new command cursor
  • MongoCommandCursor::createFromDocument — Create a new command cursor from an existing command response document
  • MongoCommandCursor::current — Returns the current element
  • MongoCommandCursor::dead — Checks if there are results that have not yet been sent from the database
  • MongoCommandCursor::getReadPreference — Get the read preference for this command
  • MongoCommandCursor::info — Gets information about the cursor's creation and iteration
  • MongoCommandCursor::key — Returns the current result's index within the result set
  • MongoCommandCursor::next — Advances the cursor to the next result
  • MongoCommandCursor::rewind — Executes the command and resets the cursor to the start of the result set
  • MongoCommandCursor::setReadPreference — Set the read preference for this command
  • MongoCommandCursor::timeout — Sets a client-side timeout for this command
  • MongoCommandCursor::valid — Checks if the cursor is reading a valid result.
MongoCursorInterface::timeout
MongoCommandCursor::batchSize
Core Classes


Limits the number of elements returned in one batch.

MongoCommandCursor
MongoCommandCursor::__construct
MongoCommandCursor
PHP Manual

MongoCommandCursor::batchSize

(PECL mongo >=1.5.0)

MongoCommandCursor::batchSize — Limits the number of elements returned in one batch.

Açıklama

public MongoCommandCursor MongoCommandCursor::batchSize ( int $batchSize )

A cursor typically fetches a batch of result objects and store them locally. This method sets the batchSize value to configure the amount of documents retrieved from the server in one round trip.

Değiştirgeler

batchSize

The number of results to return per batch. Each batch requires a round-trip to the server.

This cannot override MongoDB's limit on the amount of data it will return to the client (i.e., if you set batch size to 1,000,000,000, MongoDB will still only return 4-16MB of results per batch).

Dönen Değerler

Returns this cursor.

Örnekler

Örnek 1 MongoCommandCursor::batchSize()

<?php
$commandCursor->batchSize(20);
?>

Ayrıca Bakınız

  • MongoCursorInterface::batchSize() - Limits the number of elements returned in one batch.
MongoCommandCursor
MongoCommandCursor::__construct
MongoCommandCursor


Create a new command cursor

MongoCommandCursor::batchSize
MongoCommandCursor::createFromDocument
MongoCommandCursor
PHP Manual

MongoCommandCursor::__construct

(PECL mongo >=1.5.0)

MongoCommandCursor::__construct — Create a new command cursor

Açıklama

public MongoCommandCursor::__construct ( MongoClient $connection , string $ns , array $command = array() )

Generally, you should not have to construct a MongoCommandCursor manually, as there are helper functions such as MongoCollection::aggregateCursor() and MongoCollection::parallelCollectionScan(); however, if the server introduces new commands that can return cursors, this constructor will be useful in the absence of specific helper methods. You may also consider using MongoCommandCursor::createFromDocument().

Değiştirgeler

connection

Database connection.

ns

Full name of the database and collection (e.g. "test.foo")

command

Database command.

Dönen Değerler

Returns the new cursor.

Örnekler

Örnek 1 MongoCommandCursor example

<?php
$m = new MongoClient;

// Define the aggregation pipeline
$pipeline = [
    [ '$group' => [
        '_id' => '$country_code',
        'timezones' => [ '$addToSet' => '$timezone' ]
    ] ],
    [ '$sort' => [ '_id' => 1 ] ],
];

// Construct a MongoCommandCursor object
$cursor = new MongoCommandCursor(
    $m, // MongoClient object
    'demo.cities', // namespace
    [
        'aggregate' => 'cities',
        'pipeline' => $pipeline,
        'cursor' => [ 'batchSize' => 0 ],
    ]
);

foreach($cursor as $result) {
   ...
}
?>

Ayrıca Bakınız

  • MongoCommandCursor::createFromDocument() - Create a new command cursor from an existing command response document
  • MongoCollection::aggregateCursor() - Execute an aggregation pipeline command and retrieve results through a cursor
  • MongoCollection::parallelCollectionScan() - Returns an array of cursors to iterator over a full collection in parallel
MongoCommandCursor::batchSize
MongoCommandCursor::createFromDocument
MongoCommandCursor


Create a new command cursor from an existing command response document

MongoCommandCursor::__construct
MongoCommandCursor::current
MongoCommandCursor
PHP Manual

MongoCommandCursor::createFromDocument

(PECL mongo >=1.5.0)

MongoCommandCursor::createFromDocument — Create a new command cursor from an existing command response document

Açıklama

public static MongoCommandCursor MongoCommandCursor::createFromDocument ( MongoClient $connection , string $hash , array $document )

Use this method if you have a raw command result with cursor information in it. Note that cursors created with this method cannot be iterated multiple times, as they will lack the original command necessary for re-execution.

Değiştirgeler

connection

Database connection.

hash

The connection hash, as obtained through the third by-reference argument to MongoDB::command().

document

Document with cursor information in it. This document needs to contain the id, ns and firstBatch fields. Such a document is obtained by calling the MongoDB::command() with appropriate arguments to return a cursor, and not just an inline result. See the example below.

Dönen Değerler

Returns the new cursor.

Örnekler

Örnek 1 MongoCommandCursor::createFromDocument()

<?php
$m = new MongoClient;
$d = $m->demo;

// Define the aggregation pipeline
$pipeline = [
    [ '$group' => [
        '_id' => '$country_code',
        'timezones' => [ '$addToSet' => '$timezone' ]
    ] ],
    [ '$sort' => [ '_id' => 1 ] ],
];

// Execute the command. The "cursor" option instructs the server to return
// cursor information in the response instead of inline results.
$r = $d->command(
    [
        'aggregate' => 'cities',
        'pipeline' => $pipeline,
        'cursor' => [ 'batchSize' => 1 ],
    ],
    null,
    $hash
);

// Show result and hash
var_dump( $r, $hash );

// Construct the command cursor
$cursor = MongoCommandCursor::createFromDocument( $m, $hash, $r );
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(2) {
  ["cursor"]=>
  array(3) {
    ["id"]=>
    object(MongoInt64)#5 (1) {
      ["value"]=>
      string(12) "392143983421"
    }
    ["ns"]=>
    string(11) "demo.cities"
    ["firstBatch"]=>
    array(1) {
      [0]=>
      array(2) {
        ["_id"]=>
        string(2) "AD"
        ["timezones"]=>
        array(1) {
          [0]=>
          string(14) "Europe/Andorra"
        }
      }
    }
  }
  ["ok"]=>
  float(1)
}
string(25) "localhost:27017;-;.;17617"

As you can see, the returned cursor information has the id, ns and firstBatch fields.

Ayrıca Bakınız

  • MongoCommandCursor::__construct() - Create a new command cursor
MongoCommandCursor::__construct
MongoCommandCursor::current
MongoCommandCursor


Returns the current element

MongoCommandCursor::createFromDocument
MongoCommandCursor::dead
MongoCommandCursor
PHP Manual

MongoCommandCursor::current

(PECL mongo >=1.5.0)

MongoCommandCursor::current — Returns the current element

Açıklama

public array MongoCommandCursor::current ( void )

This returns NULL until MongoCommandCursor::rewind() is called.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current result document as an associative array. NULL will be returned if there is no result.

Ayrıca Bakınız

  • Iterator::current() - O anki elemanı döndürür
MongoCommandCursor::createFromDocument
MongoCommandCursor::dead
MongoCommandCursor


Checks if there are results that have not yet been sent from the database

MongoCommandCursor::current
MongoCommandCursor::getReadPreference
MongoCommandCursor
PHP Manual

MongoCommandCursor::dead

(PECL mongo >=1.5.0)

MongoCommandCursor::dead — Checks if there are results that have not yet been sent from the database

Açıklama

public bool MongoCommandCursor::dead ( void )

This method checks whether the MongoCommandCursor cursor has been exhausted and the database has no more results to send to the client. A cursor being "dead" does not necessarily mean that there are no more results available for iteration.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if there are more results that have not yet been sent to the client, and FALSE otherwise.

Ayrıca Bakınız

  • MongoCursorInterface::dead() - Checks if there are results that have not yet been sent from the database
MongoCommandCursor::current
MongoCommandCursor::getReadPreference
MongoCommandCursor


Get the read preference for this command

MongoCommandCursor::dead
MongoCommandCursor::info
MongoCommandCursor
PHP Manual

MongoCommandCursor::getReadPreference

(PECL mongo >=1.6.0)

MongoCommandCursor::getReadPreference — Get the read preference for this command

Açıklama

public array MongoCommandCursor::getReadPreference ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

This function returns an array describing the read preference. The array contains the values type for the string read preference mode (corresponding to the MongoClient constants), and tagsets containing a list of all tag set criteria. If no tag sets were specified, tagsets will not be present in the array.

Örnekler

Örnek 1 MongoCommandCursor::getReadPreference() return value example

<?php

$m = new MongoClient('mongodb://rs1.example.com:27017', array('replicaSet' => 'myReplSetName'));
$collection = $m->selectCollection('test', 'people');

// If a MongoCommandCursor is constructed directly, it will inherit the read
// preference of the MongoClient instance passed to its constructor; however,
// MongoCollection::aggregateCursor() will have the MongoCommandCursor inherit
// the collection's read preference.
$collection->setReadPreference(MongoClient::RP_SECONDARY);

$cursor = $collection->aggregateCursor( [
    [ '$group' => [ '_id' => '$name', 'points' => [ '$sum' => '$points' ] ] ],
    [ '$sort' => [ 'points' => -1 ] ],
] );

var_dump($cursor->getReadPreference());

?>

Yukarıdaki örneğin çıktısı:

array(1) {
  ["type"]=>
  string(9) "secondary"
}

Ayrıca Bakınız

  • The read preferences documentation.
  • MongoCommandCursor::setReadPreference() - Set the read preference for this command
  • MongoCursorInterface::getReadPreference() - Get the read preference for this query
MongoCommandCursor::dead
MongoCommandCursor::info
MongoCommandCursor


Gets information about the cursor's creation and iteration

MongoCommandCursor::getReadPreference
MongoCommandCursor::key
MongoCommandCursor
PHP Manual

MongoCommandCursor::info

(PECL mongo >=1.5.0)

MongoCommandCursor::info — Gets information about the cursor's creation and iteration

Açıklama

public array MongoCommandCursor::info ( void )

This can be called before or after the cursor has started iterating.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the namespace, batch size, limit, skip, flags, query, and projected fields for this cursor. If the cursor has started iterating, additional information about iteration and the connection will be included.

Örnekler

Örnek 1 MongoCommandCursor::info() example

<?php
$m = new MongoClient();

$cursor = new MongoCommandCursor(
    $m, // MongoClient object
    'demo.cities', // namespace
    [
        'aggregate' => 'cities',
        'pipeline' => [ [ '$match' => [ '_id' => [ '$exists' => true ] ] ] ],
        'cursor' => [ 'batchSize' => 1 ],
    ]
);

echo "Before iteration started:\n";
var_dump($cursor->info());

echo "\nAfter iteration started:\n";
$cursor->rewind();
var_dump($cursor->info());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Before iteration started:
array(8) {
  ["ns"]=>
  string(11) "demo.cities"
  ["limit"]=>
  int(0)
  ["batchSize"]=>
  int(0)
  ["skip"]=>
  int(0)
  ["flags"]=>
  int(0)
  ["query"]=>
  array(3) {
    ["aggregate"]=>
    string(6) "cities"
    ["pipeline"]=>
    array(1) {
      [0]=>
      array(1) {
        ["$match"]=>
        array(1) {
          ["_id"]=>
          array(1) {
            ["$exists"]=>
            bool(true)
          }
        }
      }
    }
    ["cursor"]=>
    array(1) {
      ["batchSize"]=>
      int(1)
    }
  }
  ["fields"]=>
  NULL
  ["started_iterating"]=>
  bool(false)
}

After iteration started:
array(17) {
  ["ns"]=>
  string(11) "demo.cities"
  ["limit"]=>
  int(0)
  ["batchSize"]=>
  int(0)
  ["skip"]=>
  int(0)
  ["flags"]=>
  int(0)
  ["query"]=>
  array(3) {
    ["aggregate"]=>
    string(6) "cities"
    ["pipeline"]=>
    array(1) {
      [0]=>
      array(1) {
        ["$match"]=>
        array(1) {
          ["_id"]=>
          array(1) {
            ["$exists"]=>
            bool(true)
          }
        }
      }
    }
    ["cursor"]=>
    array(1) {
      ["batchSize"]=>
      int(1)
    }
  }
  ["fields"]=>
  NULL
  ["started_iterating"]=>
  bool(true)
  ["id"]=>
  int(185840310129)
  ["at"]=>
  int(0)
  ["numReturned"]=>
  int(0)
  ["server"]=>
  string(25) "localhost:27017;-;.;23991"
  ["host"]=>
  string(9) "localhost"
  ["port"]=>
  int(27017)
  ["connection_type_desc"]=>
  string(10) "STANDALONE"
  ["firstBatchAt"]=>
  int(0)
  ["firstBatchNumReturned"]=>
  int(1)
}

Ayrıca Bakınız

  • MongoCursorInterface::info() - Gets information about the cursor's creation and iteration
MongoCommandCursor::getReadPreference
MongoCommandCursor::key
MongoCommandCursor


Returns the current result's index within the result set

MongoCommandCursor::info
MongoCommandCursor::next
MongoCommandCursor
PHP Manual

MongoCommandCursor::key

(PECL mongo >=1.5.0)

MongoCommandCursor::key — Returns the current result's index within the result set

Açıklama

public int MongoCommandCursor::key ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current result's index within the result set.

Ayrıca Bakınız

  • Iterator::key() - O anki elemanın anahtarını döndürür
MongoCommandCursor::info
MongoCommandCursor::next
MongoCommandCursor


Advances the cursor to the next result

MongoCommandCursor::key
MongoCommandCursor::rewind
MongoCommandCursor
PHP Manual

MongoCommandCursor::next

(PECL mongo >=1.5.0)

MongoCommandCursor::next — Advances the cursor to the next result

Açıklama

public void MongoCommandCursor::next ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

NULL.

Hatalar/İstisnalar

Throws MongoConnectionException if it cannot reach the database and MongoCursorTimeoutException if the timeout is exceeded.

Ayrıca Bakınız

  • Iterator::next() - Konumu sonraki elemana ilerletir
MongoCommandCursor::key
MongoCommandCursor::rewind
MongoCommandCursor


Executes the command and resets the cursor to the start of the result set

MongoCommandCursor::next
MongoCommandCursor::setReadPreference
MongoCommandCursor
PHP Manual

MongoCommandCursor::rewind

(PECL mongo >=1.5.0)

MongoCommandCursor::rewind — Executes the command and resets the cursor to the start of the result set

Açıklama

public array MongoCommandCursor::rewind ( void )

If the cursor has already started iteration, the command will be re-executed.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The raw server result document.

Hatalar/İstisnalar

Throws MongoConnectionException if it cannot reach the database and MongoCursorTimeoutException if the timeout is exceeded.

Throws MongoCursorException if the cursor was created with MongoCommandCursor::createFromDocument() and has already started iteration. Such cursors cannot be iterated multiple times, as they lack the original command necessary for re-execution.

Örnekler

Örnek 1 MongoCommandCursor::rewind()

<?php
$rawResult = $commandCursor->rewind();

// Command cursor is now reset to the start of the result set

var_dump($rawResult);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(2) {
  ["cursor"]=>
  array(3) {
    ["id"]=>
    object(MongoInt64)#5 (1) {
      ["value"]=>
      string(12) "310050110216"
    }
    ["ns"]=>
    string(9) "demo.test"
    ["firstBatch"]=>
    array(1) {
      [0]=>
      array(2) {
        ["_id"]=>
        object(MongoId)#6 (1) {
          ["$id"]=>
          string(24) "52f5691544670a8077b0dc51"
        }
        ["value"]=>
        string(2) "42"
      }
    }
  }
  ["ok"]=>
  float(1)
}

Ayrıca Bakınız

  • Iterator::rewind() - Yineleyiciyi ilk elemana konumlandırır
MongoCommandCursor::next
MongoCommandCursor::setReadPreference
MongoCommandCursor


Set the read preference for this command

MongoCommandCursor::rewind
MongoCommandCursor::timeout
MongoCommandCursor
PHP Manual

MongoCommandCursor::setReadPreference

(PECL mongo >=1.6.0)

MongoCommandCursor::setReadPreference — Set the read preference for this command

Açıklama

public MongoCommandCursor MongoCommandCursor::setReadPreference ( string $read_preference [, array $tags ] )

Değiştirgeler

read_preference

The read preference mode: MongoClient::RP_PRIMARY, MongoClient::RP_PRIMARY_PREFERRED, MongoClient::RP_SECONDARY, MongoClient::RP_SECONDARY_PREFERRED, or MongoClient::RP_NEAREST.

tags

An array of zero or more tag sets, where each tag set is itself an array of criteria used to match tags on replica set members.

Dönen Değerler

Returns this cursor.

Hatalar/İstisnalar

Emits E_WARNING if either parameter is invalid, or if one or more tag sets are provided with the MongoClient::RP_PRIMARY read preference mode.

Örnekler

Örnek 1 MongoCommandCursor::setReadPreference() tag set array syntax example

<?php

$m = new MongoClient('mongodb://rs1.example.com:27017', array('replicaSet' => 'myReplSetName'));
$collection = $m->selectCollection('test', 'people');

$cursor = $collection->aggregateCursor( [
    [ '$group' => [ '_id' => '$name', 'points' => [ '$sum' => '$points' ] ] ],
    [ '$sort' => [ 'points' => -1 ] ],
] );

// Prefer the nearest server in the "east" data center also used for reporting,
// but fall back to a server in the "west" data center
$cursor->setReadPreference(MongoClient::RP_NEAREST, [
    [ 'dc' => 'east', 'use' => 'reporting' ],
    [ 'dc' => 'west' ],
] );

foreach ($cursor as $person) {
    // ...
}

// If the read preference is changed, it will be used the next time the cursor
// is rewound and the command is re-executed.
$cursor->setReadPreference(MongoClient::RP_PRIMARY);

foreach ($cursor as $person) {
    // ...
}

?>

Ayrıca Bakınız

  • The read preferences documentation.
  • MongoCommandCursor::getReadPreference() - Get the read preference for this command
  • MongoCursorInterface::setReadPreference() - Set the read preference for this query
MongoCommandCursor::rewind
MongoCommandCursor::timeout
MongoCommandCursor


Sets a client-side timeout for this command

MongoCommandCursor::setReadPreference
MongoCommandCursor::valid
MongoCommandCursor
PHP Manual

MongoCommandCursor::timeout

(PECL mongo >=1.6.0)

MongoCommandCursor::timeout — Sets a client-side timeout for this command

Açıklama

public MongoCommandCursor MongoCommandCursor::timeout ( int $ms )

A timeout can be set at any time and will affect subsequent data retrieval associated with this cursor, including fetching more results from the database.

Değiştirgeler

ms

The number of milliseconds for the cursor to wait for a response. Use -1 to wait forever. By default, the cursor will wait 30000 milliseconds (30 seconds).

Dönen Değerler

This cursor.

Hatalar/İstisnalar

Causes methods that fetch results to throw a MongoCursorTimeoutException if the data fetch takes longer than the specified number of milliseconds.

Örnekler

Örnek 1 MongoCommandCursor::timeout() example

In the following example, the driver will wait for 60 seconds for the first response from the aggregate command. It will also wait for 60 seconds each time the server needs to be polled for more information.

<?php

$m = new MongoClient;
$col = $m->database->collection;

$pipeline = [ ... ];

$cursor = $col->aggregateCursor( $pipeline );
$cursor->timeout( 60000 ); // for 60 seconds

foreach ( $cursor as $result ) {
   ...
}

?>

Notlar

Uyarı

This does not cause the MongoDB server to cancel long-running operations; it only instructs the driver to stop waiting for a response and throw a MongoCursorTimeoutException after a set time. If you need to specify a server-side timeout for a command, considering passing the maxTimeMS option to MongoCollection::aggregateCursor().

Ayrıca Bakınız

  • MongoCollection::aggregateCursor() - Execute an aggregation pipeline command and retrieve results through a cursor
  • MongoCursorInterface::timeout() - Sets a client-side timeout for this query
  • The socketTimeoutMS option for MongoClient::__construct()
MongoCommandCursor::setReadPreference
MongoCommandCursor::valid
MongoCommandCursor


Checks if the cursor is reading a valid result.

MongoCommandCursor::timeout
Types
MongoCommandCursor
PHP Manual

MongoCommandCursor::valid

(PECL mongo >=1.5.0)

MongoCommandCursor::valid — Checks if the cursor is reading a valid result.

Açıklama

public bool MongoCommandCursor::valid ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

TRUE if the current result is not null, and FALSE otherwise.

Ayrıca Bakınız

  • Iterator::valid() - O anki konum geçerli mi diye bakar
MongoCommandCursor::timeout
Types
MongoCommandCursor


Types

İçindekiler

  • MongoId
  • MongoCode
  • MongoDate
  • MongoRegex
  • MongoBinData
  • MongoInt32
  • MongoInt64
  • MongoDBRef
  • MongoMinKey
  • MongoMaxKey
  • MongoTimestamp

MongoDB allows programmers to save and query for data expressed in all of the basic PHP types, compound types (arrays, associative arrays, and objects), and a half-dozen classes provided by the MongoDB PHP driver (for regular expressions, dates, and other specialized applications).

Booleans and NULL

TRUE, FALSE, and NULL can be used as-is.

Numbers

Numbers are distinct from strings in MongoDB: "123" does not match 123. Thus, if you want to make sure numbers are sorted and matched correctly, you must make sure that they are actually saved as numbers.

<?php

$doc = array("a" => 123, "b" => "123");
$collection->insert($doc);

$doc->find(array("a" => 123));   // matches
$doc->find(array("a" => "123")); // doesn't match
$doc->find(array("a" => 123.0)); // matches
$doc->find(array("b" => 123));   // doesn't match
$doc->find(array("b" => "123")); // matches

?>

As noted above, floating point numbers do compare with/match integer numbers as one would expect.

Large Numbers

By default, on a 32-bit system, numbers are sent to the database as 32-bit integers. On a 64-bit system, they are sent as 64-bit integers. For backwards compatibility, all systems deserialize 64-bit integers as floating point numbers. Floating point numbers are not exact. If you need exact values, you must tweak your php.ini settings.

On a 32-bit system, if mongo.long_as_object is set, 64-bit integers will be returns as MongoInt64 objects. The integer will be stored in the value field with perfect precision (as a string). You can also use MongoInt64 to save 64-bit integers on 32-bit machines.

On 64-bit systems, you can either set mongo.long_as_object or set mongo.native_long. mongo.native_long will return 64-bit integers and "normal" PHP integers. You can use MongoInt32 to save 32-bit integers on 64-bit machines.

You should set the mongo.long_as_object and mongo.native_long behavior that you plan to use, even if it is the default behavior (to protect against future changes to the defaults).

See also: php.ini Options, MongoInt32, MongoInt64.

Strings

Strings must be UTF-8. Non-UTF-8 strings must either be converted to UTF-8 before being sent to the database or saved as binary data.

Regular expressions can be used to match strings, and are expressed using the MongoRegex class.

Binary Data

Non-UTF-8 strings, images, and any other binary data should be sent to the database using the MongoBinData type.

Dates

Dates can be created using the MongoDate class. They are stored as milliseconds since the epoch.

MongoTimestamp is not for saving dates or timestamps, it is used internally by MongoDB. Unless you are creating a tool that interacts with the internals of replication or sharding, you should use MongoDate, not MongoTimestamp.

Unique Ids

The driver will automatically create an _id field before inserting a document (unless one is specified by the user). This field is an instance of MongoId (called "ObjectId" in most other languages).

These ids are 12 bytes long and composed of:

  • 4 bytes of timestamp

    No two records can have the same id if they were inserted at different times.

  • 3 bytes machine id

    No two records can have the same id if they were inserted on different machines

  • 2 bytes thread id

    No two records can have the same id if they were inserted by different threads running on the same machine.

  • 3 bytes incrementing value

    Each time an id is created, a global counter is incremented and used as the increment value of the next id.

Thus, no two records can have the same id unless a single process on a single machine managed to insert 256^3 (over 16 million) documents in one second, overflowing the increment field.

JavaScript

MongoDB comes with a JavaScript engine, so you can embed JavaScript in queries (using a $where clause), send it directly to the database to be executed, and use it to perform aggregations.

For security, use MongoCode's scope field to use PHP variables in JavaScript. Code that does not require external values can either use MongoCode or just be a string. See the section on security for more information about sending JavaScript to the database.

Arrays and Objects

Arrays and objects can also be saved to the database. An array with ascending numeric keys will be saved as a an array, anything else will be saved as an object.

<?php

// $scores will be saved as an array
$scores = array(98, 100, 73, 85);
$collection->insert(array("scores" => $scores));

// $scores will be saved as an object
$scores = array("quiz1" => 98, "midterm" => 100, "quiz2" => 73, "final" => 85);
$collection->insert(array("scores" => $scores));

?>

If you query for these objects using the database shell, they will look like:

> db.students.find()
{ "_id" : ObjectId("4b06beada9ad6390dab17c43"), "scores" : [ 98, 100, 73, 85 ] }
{ "_id" : ObjectId("4b06bebea9ad6390dab17c44"), "scores" : { "quiz1" : 98, "midterm" : 100, "quiz2" : 73, "final" : 85 } }

The database can also save arbitrary PHP objects (although they will be returned as associative arrays). The fields are used for the key/value pairs. For example, a blog post might look like:

<?php

  // the blog post class
  class Post {

  var $author;
  var $content;
  var $comments = array();
  var $date;

  public function __construct($author, $content) {
  $this->author = $author;
$this->content = $content;
    $this->date = new MongoDate();
  }

  public function setTitle($title) {
    $this->title = $title;
  }
}

// create a simple blog post and insert it into the database
$post1 = new Post("Adam", "This is a blog post");

$blog->insert($post1);

// there is nothing restricting the type of the "author" field, so we can make
// it a nested object
$author = array("name" => "Fred", "karma" => 42);
$post2 = new Post($author, "This is another blog post.");

// we create an extra field by setting the title
$post2->setTitle("Second Post");

$blog->insert($post2);

?>

From the database shell, this will look something like:

> db.blog.find()
{ "_id" : ObjectId("4b06c263edb87a281e09dad8"), "author" : "Adam", "content" : "This is a blog post", "comments" : [ ], "date" : "Fri Nov 20 2009 11:22:59 GMT-0500 (EST)" }
{ "_id" : ObjectId("4b06c282edb87a281e09dad9"), "author" : { "name" : "Fred", "karma" : 42 }, "content" : "This is a blog post", "comments" : [ ], "date" : "Fri Nov 20 2009 11:23:30 GMT-0500 (EST)", "title" : "Second Post" }

The driver will not detect reference loops in arrays and objects. For example, this will give a fatal error:

<?php

$collection->insert($GLOBALS);

?>
Fatal error: Nesting level too deep - recursive dependency?
If you need to insert documents that may have recursive dependency, you have to check for it yourself before passing it to the driver.

MongoCommandCursor::valid
MongoId
Mongo


The MongoId class

(PECL mongo >=0.8.0)

Uyarı

This extension that defines this class is deprecated. Instead, the MongoDB extension should be used. Alternatives to this class include:

  • MongoDB\BSON\ObjectID

Giriş

A unique identifier created for database objects. If an object is inserted into the database without an _id field, an _id field will be added to it with a MongoId instance as its value. If the data has a naturally occuring unique field (e.g. username or timestamp) it is fine to use this as the _id field instead, and it will not be replaced with a MongoId.

Instances of the MongoId class fulfill the role that autoincrementing does in a relational database: to provide a unique key if the data does not naturally have one. Autoincrementing does not work well with a sharded database, as it is difficult to determine the next number in the sequence. This class fulfills the constraints of quickly generating a value that is unique across shards.

Each MongoId is 12 bytes (making its string form 24 hexadecimal characters). The first four bytes are a timestamp, the next three are a hash of the client machine's hostname, the next two are the two least significant bytes of the process id running the script, and the last three bytes are an incrementing value.

MongoIds are serializable/unserializable. Their serialized form is similar to their string form:

C:7:"MongoId":24:{4af9f23d8ead0e1d32000000}

Sınıf Sözdizimi

MongoId {
public string $$id = NULL ;
/* Yöntemler */
public __construct ([ string|MongoId $id = NULL ] )
public static string getHostname ( void )
public int getInc ( void )
public int getPID ( void )
public int getTimestamp ( void )
public static bool isValid ( mixed $value )
public static MongoId __set_state ( array $props )
public string __toString ( void )
}

Fields

$id
This field contains the string representation of this object.

Bilginize: The property name begins with a $ character. It may be accessed using complex variable parsed syntax (e.g. $mongoId->{'$id'}).

Ayrıca Bakınız

MongoDB core docs on » ObjectIds.

İçindekiler

  • MongoId::__construct — Creates a new id
  • MongoId::getHostname — Gets the hostname being used for this machine's ids
  • MongoId::getInc — Gets the incremented value to create this id
  • MongoId::getPID — Gets the process ID
  • MongoId::getTimestamp — Gets the number of seconds since the epoch that this id was created
  • MongoId::isValid — Check if a value is a valid ObjectId
  • MongoId::__set_state — Create a dummy MongoId
  • MongoId::__toString — Returns a hexidecimal representation of this id
Types
MongoId::__construct
Types


Creates a new id

MongoId
MongoId::getHostname
MongoId
PHP Manual

MongoId::__construct

(PECL mongo >= 0.8.0)

MongoId::__construct — Creates a new id

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. Alternatives to this method include:

  • MongoDB\BSON\ObjectID::__construct()

Açıklama

public MongoId::__construct ([ string|MongoId $id = NULL ] )

Değiştirgeler

id

A string (must be 24 hexadecimal characters) or a MongoId instance.

Dönen Değerler

Returns a new id.

Sürüm Bilgisi

Sürüm: | Açıklama
1.4.0 | An exception is thrown when passed invalid string

Örnekler

Örnek 1 MongoId::__construct() example

This example shows how to create a new id. This is seldom necessary, as the driver adds an id to arrays automatically before storing them in the database.

<?php

  $id1 = new MongoId();
  echo "$id1\n";

  $id2 = new MongoId();
  echo "$id2\n";

  ?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

49a7011a05c677b9a916612a
49a702d5450046d3d515d10d

Örnek 2 Parameter example

This example shows how to use a string parameter to initialize a MongoId with a given value.

<?php
  $id1 = new MongoId();

  // create a new id from $id1
  $id2 = new MongoId("$id1");

  // show that $id1 and $id2 have the same hexidecimal value
  var_dump($id1 == $id2);
  ?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(true)

Ayrıca Bakınız

  • MongoId::__toString() - Returns a hexidecimal representation of this id
  • MongoId::isvalid() - Check if a value is a valid ObjectId

MongoId
MongoId::getHostname
MongoId


Gets the hostname being used for this machine's ids

MongoId::__construct
MongoId::getInc
MongoId
PHP Manual

MongoId::getHostname

(PECL mongo >= 1.0.8)

MongoId::getHostname — Gets the hostname being used for this machine's ids

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension.

Açıklama

public static string MongoId::getHostname ( void )

This returns the hostname MongoId is using to generate unique ids. This should be the same value gethostname() returns.

It is identical to the function:

<?php

public static function getHostname() {
    return gethostname();
}

?>

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the hostname.

MongoId::__construct
MongoId::getInc
MongoId


Gets the incremented value to create this id

MongoId::getHostname
MongoId::getPID
MongoId
PHP Manual

MongoId::getInc

(PECL mongo >= 1.0.11)

MongoId::getInc — Gets the incremented value to create this id

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension.

Açıklama

public int MongoId::getInc ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the incremented value used to create this MongoId.

MongoId::getHostname
MongoId::getPID
MongoId


Gets the process ID

MongoId::getInc
MongoId::getTimestamp
MongoId
PHP Manual

MongoId::getPID

(PECL mongo >= 1.0.11)

MongoId::getPID — Gets the process ID

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension.

Açıklama

public int MongoId::getPID ( void )

Extracts the pid from the Mongo ID

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the PID of the MongoId.

MongoId::getInc
MongoId::getTimestamp
MongoId


Gets the number of seconds since the epoch that this id was created

MongoId::getPID
MongoId::isValid
MongoId
PHP Manual

MongoId::getTimestamp

(PECL mongo >= 1.0.1)

MongoId::getTimestamp — Gets the number of seconds since the epoch that this id was created

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension.

Açıklama

public int MongoId::getTimestamp ( void )

This returns the same thing as running time() when the id is created.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the number of seconds since the epoch that this id was created. There are only four bytes of timestamp stored, so MongoDate is a better choice for storing exact or wide-ranging times.

MongoId::getPID
MongoId::isValid
MongoId


Check if a value is a valid ObjectId

MongoId::getTimestamp
MongoId::__set_state
MongoId
PHP Manual

MongoId::isValid

(PECL mongo >= 1.5.0)

MongoId::isValid — Check if a value is a valid ObjectId

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension.

Açıklama

public static bool MongoId::isValid ( mixed $value )

This method may be used to check a variable before passing it as an argument to MongoId::__construct().

Değiştirgeler

value

The value to check for validity.

Dönen Değerler

Returns TRUE if value is a MongoId instance or a string consisting of exactly 24 hexadecimal characters; otherwise, FALSE is returned.

MongoId::getTimestamp
MongoId::__set_state
MongoId


Create a dummy MongoId

MongoId::isValid
MongoId::__toString
MongoId
PHP Manual

MongoId::__set_state

(PECL mongo >= 1.0.8)

MongoId::__set_state — Create a dummy MongoId

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension.

Açıklama

public static MongoId MongoId::__set_state ( array $props )

This function is only used by PHP internally, it shouldn't need to ever be called by the user.

It is identical to the function:

<?php

public static function __set_state($props) {
    return new MongoId("000000000000000000000000");
}

?>

Değiştirgeler

props

Theoretically, an array of properties used to create the new id. However, as MongoId instances have no properties, this is not used.

Dönen Değerler

A new id with the value "000000000000000000000000".

MongoId::isValid
MongoId::__toString
MongoId


Returns a hexidecimal representation of this id

MongoId::__set_state
MongoCode
MongoId
PHP Manual

MongoId::__toString

(PECL mongo >= 0.8.0)

MongoId::__toString — Returns a hexidecimal representation of this id

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. Alternatives to this method include:

  • MongoDB\BSON\ObjectID::__toString()

Açıklama

public string MongoId::__toString ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

This id.

Örnekler

Örnek 1 MongoId::__toString() example

<?php

$m = new MongoClient();
$collection = $m->selectDB("foo")->selectCollection("bar");

$collection->insert(array( "x" => "y" ));
$collection->insert(array( "x" => "y" ));

$cursor = $collection->find();
$r1 = $cursor->next();
$r2 = $cursor->next();

echo $r1["_id"] . "\n";
echo $r2["_id"] . "\n";

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

49a7011a05c677b9a916612a
49a702d5450046d3d515d10d
MongoId::__set_state
MongoCode
MongoId


The MongoCode class

(PECL mongo >=0.8.3)

Uyarı

This extension that defines this class is deprecated. Instead, the MongoDB extension should be used. Alternatives to this class include:

  • MongoDB\BSON\JavaScript

Giriş

Represents JavaScript code for the database.

MongoCode objects are composed of two parts: a string of code and an optional scope. The string of code must be valid JavaScript. The scope is a associative array of variable name/value pairs.

Sınıf Sözdizimi

MongoCode {
/* Yöntemler */
public __construct ( string $code [, array $scope = array() ] )
public string __toString ( void )
}

İçindekiler

  • MongoCode::__construct — Creates a new code object
  • MongoCode::__toString — Returns this code as a string
MongoId::__toString
MongoCode::__construct
Types


Creates a new code object

MongoCode
MongoCode::__toString
MongoCode
PHP Manual

MongoCode::__construct

(PECL mongo >= 0.8.3)

MongoCode::__construct — Creates a new code object

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. Alternatives to this method include:

  • MongoDB\BSON\JavaScript::__construct()

Açıklama

public MongoCode::__construct ( string $code [, array $scope = array() ] )

Değiştirgeler

code

A string of code.

scope

The scope to use for the code.

Dönen Değerler

Returns a new code object.

Örnekler

Örnek 1 MongoCode::__construct() example

<?php

$code = new MongoCode('function() { '.
    'for(i=0;i<10;i++) {'.
        'db.foo.update({z : i}, {z : x});'.
    '}'.
    'return x-1;'.
 '}', array("x" => 4));
var_dump($code);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(MongoCode)#1 (2) {
  ["scope"]=>
  array(1) {
    ["x"]=>
    int(4)
  }
  ["code"]=>
  string(80) "function() { for(i=0;i<10;i++) { db.foo.update({z : i}, {z : x}); } return x-1; }"
}

Örnek 2 Using MongoCode with $where

This example queries a collection for elements where the 'x' fields is less than $y. Notice that PHP objects can be passed into the JavaScript scope and that the JavaScript function returns a boolean.

<?php

$cursor = $collection->find(array('$where' => new MongoCode('function() { return this.x < y; }', array('y'=>$y))));

?>
MongoCode
MongoCode::__toString
MongoCode


Returns this code as a string

MongoCode::__construct
MongoDate
MongoCode
PHP Manual

MongoCode::__toString

(PECL mongo >= 0.8.3)

MongoCode::__toString — Returns this code as a string

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this method in the new extension.

Açıklama

public string MongoCode::__toString ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

This code, the scope is not returned.

Örnekler

Örnek 1 MongoCode::__toString() example

<?php

$code = new MongoCode('return x;', array("x"=>"hi"));
echo "$code\n";

$code = new MongoCode('function() { for(i=0;i<10;i++) { db.foo.update({x:i}, {x:i+1}); } }');
echo "$code\n";

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

return x;
function() { for(i=0;i<10;i++) { db.foo.update({x:i}, {x:i+1}); } }
MongoCode::__construct
MongoDate
MongoCode


The MongoDate class

(PECL mongo >=0.8.1)

Uyarı

This extension that defines this class is deprecated. Instead, the MongoDB extension should be used. Alternatives to this class include:

  • MongoDB\BSON\UTCDateTime

Giriş

Represent date objects for the database. This class should be used to save dates to the database and to query for dates. For example:

Örnek 1 Storing dates with MongoDate

<?php

// save a date to the database
$collection->save(array("ts" => new MongoDate()));

$start = new MongoDate(strtotime("2010-01-15 00:00:00"));
$end = new MongoDate(strtotime("2010-01-30 00:00:00"));

// find dates between 1/15/2010 and 1/30/2010
$collection->find(array("ts" => array('$gt' => $start, '$lte' => $end)));

?>

MongoDB stores dates as milliseconds past the epoch. This means that dates do not contain timezone information. Timezones must be stored in a separate field if needed. Second, this means that any precision beyond milliseconds will be lost when the document is sent to/from the database.

Sınıf Sözdizimi

MongoDate {
/* Fields */
public int $sec ;
public int $usec ;
/* Yöntemler */
public __construct ([ int $sec = time() [, int $usec = 0 ]] )
public DateTime toDateTime ( void )
public string __toString ( void )
}

İçindekiler

  • MongoDate::__construct — Creates a new date.
  • MongoDate::toDateTime — Returns a DateTime object representing this date
  • MongoDate::__toString — Returns a string representation of this date
MongoCode::__toString
MongoDate::__construct
Types


Creates a new date.

MongoDate
MongoDate::toDateTime
MongoDate
PHP Manual

MongoDate::__construct

(PECL mongo >= 0.8.1)

MongoDate::__construct — Creates a new date.

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. Alternatives to this method include:

  • MongoDB\BSON\UTCDateTime::__construct()

Açıklama

public MongoDate::__construct ([ int $sec = time() [, int $usec = 0 ]] )

Creates a new date. If no parameters are given, the current time is used.

Değiştirgeler

sec

Number of seconds since the epoch (i.e. 1 Jan 1970 00:00:00.000 UTC).

usec

Microseconds. Please be aware though that MongoDB's resolution is milliseconds and not microseconds, which means this value will be truncated to millisecond resolution.

Dönen Değerler

Returns this new date.

Örnekler

Örnek 1 MongoDate::__construct() example

This example demonstrates creating a new date with the current time and a new date with a given time.

<?php

$d = new MongoDate();
echo "$d\n";
$d = new MongoDate(1234567890);
echo "$d\n";
$d = new MongoDate(strtotime("2009-05-01 00:00:01"));
echo "$d\n";

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

0.23660600 1235685067
0.00000000 1234567890
0.00000000 1241150401

Ayrıca Bakınız

  • MongoDate::__toString() - Returns a string representation of this date

MongoDate
MongoDate::toDateTime
MongoDate


Returns a DateTime object representing this date

MongoDate::__construct
MongoDate::__toString
MongoDate
PHP Manual

MongoDate::toDateTime

(PECL mongo >= 1.6.0; PHP > 5.3.4)

MongoDate::toDateTime — Returns a DateTime object representing this date

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. Alternatives to this method include:

  • MongoDB\BSON\UTCDateTime::toDateTime()

Açıklama

public DateTime MongoDate::toDateTime ( void )

Returns a DateTime object representation of this date.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

This date as a DateTime object.

Örnekler

Örnek 1 MongoDate::toDateTime() example

This example demonstrates creating a DateTime object from a MongoDate object.

<?php
$d = new MongoDate(strtotime("2014-11-18 11:01:25"));
var_dump( $d->toDateTime() );
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

class DateTime#2 (3) {
  public $date =>
  string(26) "2014-11-18 11:01:25.000000"
  public $timezone_type =>
  int(1)
  public $timezone =>
  string(6) "+00:00"
}
MongoDate::__construct
MongoDate::__toString
MongoDate


Returns a string representation of this date

MongoDate::toDateTime
MongoRegex
MongoDate
PHP Manual

MongoDate::__toString

(PECL mongo >= 0.8.1)

MongoDate::__toString — Returns a string representation of this date

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. Alternatives to this method include:

  • MongoDB\BSON\UTCDateTime::__toString()

Açıklama

public string MongoDate::__toString ( void )

Returns a string representation of this date, similar to the representation returned by microtime().

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

This date.

MongoDate::toDateTime
MongoRegex
MongoDate


The MongoRegex class

(PECL mongo >=0.8.1)

Uyarı

This extension that defines this class is deprecated. Instead, the MongoDB extension should be used. Alternatives to this class include:

  • MongoDB\BSON\Regex

Giriş

This class can be used to create regular expressions. Typically, these expressions will be used to query the database and find matching strings. More unusually, they can be saved to the database and retrieved.

Regular expressions consist of four parts. First a / as starting delimiter, then the pattern, another / and finally a string containing flags.

Örnek 1 Regular expression pattern

/pattern/flags

MongoDB recognizes six regular expression flags:

  • i: Case insensitive

  • m: Multiline

  • x: Can contain comments

  • l: locale

  • s: dotall, "." matches everything, including newlines

  • u: match unicode

Sınıf Sözdizimi

MongoRegex {
/* Fields */
public string $regex ;
public string $flags ;
/* Yöntemler */
public __construct ( string $regex )
public string __toString ( void )
}

İçindekiler

  • MongoRegex::__construct — Creates a new regular expression
  • MongoRegex::__toString — A string representation of this regular expression
MongoDate::__toString
MongoRegex::__construct
Types


Creates a new regular expression

MongoRegex
MongoRegex::__toString
MongoRegex
PHP Manual

MongoRegex::__construct

(PECL mongo >= 0.8.1)

MongoRegex::__construct — Creates a new regular expression

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. Alternatives to this method include:

  • MongoDB\BSON\Regex::__construct()

Açıklama

public MongoRegex::__construct ( string $regex )

Creates a new regular expression.

Değiştirgeler

regex

Regular expression string of the form /expr/flags.

Dönen Değerler

Returns a new regular expression.

Örnekler

Örnek 1 MongoRegex::__construct() example

This example uses a regular expression to query for all documents with a username field starting (^) with an l and a vowel ([aeiouy]), case-insensitive (/i).

<?php
$luke_search = new MongoRegex("/^l[aeiouy]/i");
$cursor = $collection->find(array("username" => $luke_search));
?>

Ayrıca Bakınız

  • MongoRegex::__toString() - A string representation of this regular expression

MongoRegex
MongoRegex::__toString
MongoRegex


A string representation of this regular expression

MongoRegex::__construct
MongoBinData
MongoRegex
PHP Manual

MongoRegex::__toString

(PECL mongo >= 0.8.1)

MongoRegex::__toString — A string representation of this regular expression

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. Alternatives to this method include:

  • MongoDB\BSON\Regex::__toString()

Açıklama

public string MongoRegex::__toString ( void )

Returns a string representation of this regular expression.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

This regular expression in the form "/expr/flags".

Örnekler

Örnek 1 MongoRegex::__toString() example

<?php

$r = new MongoRegex( "/[a-fA-F0-9]{16}/g" );
echo $r->regex . "\n";
echo $r->flags . "\n";
echo "$r\n";

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

[a-fA-F0-9]{16}
g
/[a-fA-F0-9]{16}/g

MongoRegex::__construct
MongoBinData
MongoRegex


The MongoBinData class

(PECL mongo >= 0.8.1)

Uyarı

This extension that defines this class is deprecated. Instead, the MongoDB extension should be used. Alternatives to this class include:

  • MongoDB\BSON\Binary

Giriş

An object that can be used to store or retrieve binary data from the database.

The maximum size of a single object that can be inserted into the database is 16MB. For data that is larger than this (movies, music, Henry Kissinger's autobiography), use MongoGridFS. For data that is smaller than 16MB, you may find it easier to embed it within the document using MongoBinData.

For example, to embed an image in a document, one could write:

<?php

$profile = array(
    "username" => "foobity",
    "pic" => new MongoBinData(file_get_contents("gravatar.jpg"), MongoBinData::GENERIC),
);

$users->save($profile);

?>

This class contains a type field, which currently gives no additional functionality in the PHP driver or the database. There are seven predefined types, which are defined as class constants below. For backwards compatibility, the PHP driver uses MongoBinData::BYTE_ARRAY as the default; however, this may change to MongoBinData::GENERIC in the future. Users are encouraged to specify a type in MongoBinData::__construct().

Sınıf Sözdizimi

MongoBinData {
/* Sabitler */
const int GENERIC = 0 ;
const int FUNC = 1 ;
const int BYTE_ARRAY = 2 ;
const int UUID = 3 ;
const int UUID_RFC4122 = 4 ;
const int MD5 = 5 ;
const int CUSTOM = 128 ;
/* Fields */
public string $bin ;
public int $type = 2 ;
/* Yöntemler */
public __construct ( string $data [, int $type = 0 ] )
public string __toString ( void )
}

Öntanımlı Sabitler

Binary Data Types

MongoBinData::GENERIC
0x00
Generic binary data.
MongoBinData::FUNC
0x01
Function.
MongoBinData::BYTE_ARRAY
0x02
Generic binary data (deprecated in favor of MongoBinData::GENERIC).
MongoBinData::UUID
0x03
Universally unique identifier (deprecated in favor of MongoBinData::UUID_RFC4122).
MongoBinData::UUID_RFC4122
0x04
Universally unique identifier (according to » RFC 4122).
MongoBinData::MD5
0x05
MD5.
MongoBinData::CUSTOM
0x80
User-defined type.

Sürüm Bilgisi

Sürüm: | Açıklama
1.5.0 | Added MongoBinData::GENERIC and MongoBinData::UUID_RFC4122 constants.

İçindekiler

  • MongoBinData::__construct — Creates a new binary data object.
  • MongoBinData::__toString — The string representation of this binary data object.
MongoRegex::__toString
MongoBinData::__construct
Types


Creates a new binary data object.

MongoBinData
MongoBinData::__toString
MongoBinData
PHP Manual

MongoBinData::__construct

(PECL mongo >= 0.8.1)

MongoBinData::__construct — Creates a new binary data object.

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. Alternatives to this method include:

  • MongoDB\BSON\Binary::__construct()

Açıklama

public MongoBinData::__construct ( string $data [, int $type = 0 ] )

Creates a new binary data object.

There are seven types of binary data currently recognized by the BSON spec, which are defined as class constants. For backwards compatibility, the PHP driver uses MongoBinData::BYTE_ARRAY as the default; however, this may change to MongoBinData::GENERIC in the future. Users are encouraged to specify a type instead of relying on the default.

Değiştirgeler

data

Binary data.

type

Data type.

Dönen Değerler

Returns a new binary data object.

Sürüm Bilgisi

Sürüm: | Açıklama
1.5.0 | The default changed from 2 (MongoBinData::BYTE_ARRAY) to 0 (MongoBinData::GENERIC).
1.2.11 | Emits E_DEPRECATED when the second argument is not used. The default value for type may change in the near future.

MongoBinData
MongoBinData::__toString
MongoBinData


The string representation of this binary data object.

MongoBinData::__construct
MongoInt32
MongoBinData
PHP Manual

MongoBinData::__toString

(PECL mongo >= 0.8.1)

MongoBinData::__toString — The string representation of this binary data object.

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. Alternatives to this method include:

  • MongoDB\BSON\Binary::getData()

Açıklama

public string MongoBinData::__toString ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the string "<Mongo Binary Data>". To access the contents of a MongoBinData, use the bin field.

MongoBinData::__construct
MongoInt32
MongoBinData


The MongoInt32 class

(PECL mongo >=1.0.9)

Uyarı

This extension that defines this class is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this class in the new extension.

Instead, the new extension chooses the appropriate database type depending on the integer's value.

Giriş

The class can be used to save 32-bit integers to the database on a 64-bit system.

Sınıf Sözdizimi

MongoInt32 {
/* Fields */
public string $value ;
/* Yöntemler */
public __construct ( string $value )
public string __toString ( void )
}

Fields

value
This is the string value of the 32-bit number. For instance, 123's value would be "123".

İçindekiler

  • MongoInt32::__construct — Creates a new 32-bit integer.
  • MongoInt32::__toString — Returns the string representation of this 32-bit integer.
MongoBinData::__toString
MongoInt32::__construct
Types


Creates a new 32-bit integer.

MongoInt32
MongoInt32::__toString
MongoInt32
PHP Manual

MongoInt32::__construct

(PECL mongo >= 1.0.9)

MongoInt32::__construct — Creates a new 32-bit integer.

This extension that defines this class is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this class in the new extension.

Instead, the new extension chooses the appropriate database type depending on the integer's value.

Açıklama

public MongoInt32::__construct ( string $value )

Creates a new 32-bit number with the given value.

Değiştirgeler

value

A number.

Dönen Değerler

Returns a new integer.

MongoInt32
MongoInt32::__toString
MongoInt32


Returns the string representation of this 32-bit integer.

MongoInt32::__construct
MongoInt64
MongoInt32
PHP Manual

MongoInt32::__toString

(PECL mongo >= 1.0.9)

MongoInt32::__toString — Returns the string representation of this 32-bit integer.

This extension that defines this class is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this class in the new extension.

Instead, the new extension chooses the appropriate database type depending on the integer's value.

Açıklama

public string MongoInt32::__toString ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the string representation of this integer.

MongoInt32::__construct
MongoInt64
MongoInt32


The MongoInt64 class

(PECL mongo >=1.0.9)

Uyarı

This extension that defines this class is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this class in the new extension.

Instead, the new extension chooses the appropriate database type depending on the integer's value.

Giriş

The class can be used to save 64-bit integers to the database on a 32-bit system.

Sınıf Sözdizimi

MongoInt64 {
/* Fields */
public string $value ;
/* Yöntemler */
public __construct ( string $value )
public string __toString ( void )
}

Fields

value
This is the string value of the 64-bit number. For instance, 123's value would be "123".

İçindekiler

  • MongoInt64::__construct — Creates a new 64-bit integer.
  • MongoInt64::__toString — Returns the string representation of this 64-bit integer.
MongoInt32::__toString
MongoInt64::__construct
Types


Creates a new 64-bit integer.

MongoInt64
MongoInt64::__toString
MongoInt64
PHP Manual

MongoInt64::__construct

(PECL mongo >= 1.0.9)

MongoInt64::__construct — Creates a new 64-bit integer.

This extension that defines this class is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this class in the new extension.

Instead, the new extension chooses the appropriate database type depending on the integer's value.

Açıklama

public MongoInt64::__construct ( string $value )

Creates a new 64-bit number with the given value.

Değiştirgeler

value

A number.

Dönen Değerler

Returns a new integer.

MongoInt64
MongoInt64::__toString
MongoInt64


Returns the string representation of this 64-bit integer.

MongoInt64::__construct
MongoDBRef
MongoInt64
PHP Manual

MongoInt64::__toString

(PECL mongo >= 1.0.9)

MongoInt64::__toString — Returns the string representation of this 64-bit integer.

This extension that defines this class is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this class in the new extension.

Instead, the new extension chooses the appropriate database type depending on the integer's value.

Açıklama

public string MongoInt64::__toString ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the string representation of this integer.

MongoInt64::__construct
MongoDBRef
MongoInt64


The MongoDBRef class

(PECL mongo >=0.9.0)

Uyarı

This extension that defines this class is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this class in the new extension.

The concept of database references, and hence this class, has been deprecated in the database.

Giriş

This class can be used to create lightweight links between objects in different collections.

Motivation: Suppose we need to refer to a document in another collection. The easiest way is to create a field in the current document. For example, if we had a "people" collection and an "addresses" collection, we might want to create a link between each person document and an address document:

Örnek 1 Linking documents

<?php

$people = $db->people;
$addresses = $db->addresses;

$myAddress = array("line 1" => "123 Main Street",
    "line 2" => null,
    "city" => "Springfield",
    "state" => "Vermont",
    "country" => "USA");

// save the address
$addresses->insert($myAddress);

// save a person with a reference to the address
$me = array("name" => "Fred", "address" => $myAddress['_id']);
$people->insert($me);

?>

Then, later on, we can find the person's address by querying the "addresses" collection with the MongoId we saved in the "people" collection.

Suppose now that we have a more general case, where we don't know which collection (or even which database) contains the referenced document. MongoDBRef is a good choice for this case, as it is a common format that all of the drivers and the database understand.

If each person had a list of things they liked which could come from multiple collections, such as "hobbies", "sports", "books", etc., we could use MongoDBRefs to keep track of what "like" went with what collection:

Örnek 2 Creating MongoDBRef links

<?php

$people = $db->selectCollection("people");

// model trains are in the "hobbies" collection
$trainRef = MongoDBRef::create("hobbies", $modelTrains['_id']);
// soccer is in the "sports" collection
$soccerRef = MongoDBRef::create("sports", $soccer['_id']);

// now we'll know what collections the items in the "likes" array came from when
// we retrieve this document
$people->insert(array("name" => "Fred", "likes" => array($trainRef, $soccerRef)));

?>

Database references can be thought of as hyperlinks: they give the unique address of another document, but they do not load it or automatically follow the link/reference.

A database reference is just a normal associative array, not an instance of MongoDBRef, so this class is a little different than the other data type classes. This class contains exclusively static methods for manipulating database references.

Sınıf Sözdizimi

MongoDBRef {
/* Yöntemler */
public static array create ( string $collection , mixed $id [, string $database ] )
public static array get ( MongoDB $db , array $ref )
public static bool isRef ( mixed $ref )
}

Ayrıca Bakınız

MongoDB core docs on » databases references.

İçindekiler

  • MongoDBRef::create — Creates a new database reference
  • MongoDBRef::get — Fetches the object pointed to by a reference
  • MongoDBRef::isRef — Checks if an array is a database reference
MongoInt64::__toString
MongoDBRef::create
Types


Creates a new database reference

MongoDBRef
MongoDBRef::get
MongoDBRef
PHP Manual

MongoDBRef::create

(PECL mongo >= 0.9.0)

MongoDBRef::create — Creates a new database reference

This extension that defines this class is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this class in the new extension.

The concept of database references, and hence this class, has been deprecated.

Açıklama

public static array MongoDBRef::create ( string $collection , mixed $id [, string $database ] )

If no database is given, the current database is used.

Değiştirgeler

collection

Collection name (without the database name).

id

The _id field of the object to which to link.

database

Database name.

Dönen Değerler

Returns the reference.

Örnekler

Örnek 1 MongoDBRef::create() example

This creates a database reference to a document in the addresses collection. The MongoCollection::getName() function returns the name of the collection (not including the database name).

<?php
$addresses = $db->addresses;
$people = $db->people;

// save $address so it has an _id
$addresses->insert($address);

// create a reference
$ref = MongoDBRef::create($addresses->getName(), $address['_id']);

// set the field in $person
$person['address'] = $ref;
$people->save($person);
?>

Ayrıca Bakınız

  • MongoDB::createDBRef() - Creates a database reference
  • MongoCollection::createDBRef() - Creates a database reference

MongoDBRef
MongoDBRef::get
MongoDBRef


Fetches the object pointed to by a reference

MongoDBRef::create
MongoDBRef::isRef
MongoDBRef
PHP Manual

MongoDBRef::get

(PECL mongo >= 0.9.0)

MongoDBRef::get — Fetches the object pointed to by a reference

This extension that defines this class is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this class in the new extension.

The concept of database references, and hence this class, has been deprecated.

Açıklama

public static array MongoDBRef::get ( MongoDB $db , array $ref )

Değiştirgeler

db

Database to use.

ref

Reference to fetch.

Dönen Değerler

Returns the document to which the reference refers or NULL if the document does not exist (the reference is broken).

Örnekler

Örnek 1 MongoCollection::createDBRef() example

<?php

// get $person out of the db
$person = $people->findOne();

// dereference the address
$address = MongoDBRef::get($people->db, $person['address']);

?>

Ayrıca Bakınız

  • MongoDB::getDBRef() - Fetches the document pointed to by a database reference
  • MongoCollection::getDBRef() - Fetches the document pointed to by a database reference

MongoDBRef::create
MongoDBRef::isRef
MongoDBRef


Checks if an array is a database reference

MongoDBRef::get
MongoMinKey
MongoDBRef
PHP Manual

MongoDBRef::isRef

(PECL mongo >= 0.9.0)

MongoDBRef::isRef — Checks if an array is a database reference

This extension that defines this class is deprecated. Instead, the MongoDB extension should be used. There is no equivalent for this class in the new extension.

The concept of database references, and hence this class, has been deprecated.

Açıklama

public static bool MongoDBRef::isRef ( mixed $ref )

This method does not actually follow the reference, so it does not determine if it is broken or not. It merely checks that ref is in valid database reference format (in that it is an object or array with $ref and $id fields).

Değiştirgeler

ref

Array or object to check.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

MongoDBRef::get
MongoMinKey
MongoDBRef


The MongoMinKey class

(PECL mongo >= 1.0.2)

Uyarı

This extension that defines this class is deprecated. Instead, the MongoDB extension should be used. Alternatives to this class include:

  • MongoDB\BSON\MinKey

Giriş

MongoMinKey is an special type used by the database that compares less than all other possible BSON values. Thus, if a query is sorted by a given field in ascending order, any document with a MongoMinKey as its value will be returned first.

MongoMinKey has no associated fields, methods, or constants. It is merely the "smallest" value that can be represented in the database.

Bilginize: MongoMinKey is used internally by MongoDB for indexing and sharding. There is generally no reason to use this class in an application.

Sınıf Sözdizimi

MongoMinKey {
}

Using MongoMinKey as a value

<?php

$collection->insert(array("task" => "lunch", "doBy" => new MongoMinKey));
$collection->insert(array("task" => "staff meeting", "doBy" => new MongoDate(strtotime("+4 days"))));

$cursor = $collection->find()->sort(array("doBy" => 1));

?>

The cursor will return the lunch document followed by the staff meeting document. The lunch document will always be returned first, regardless of what else is added to the collection (unless other documents are added with MongoMinKey in their "doBy" field).

Ayrıca Bakınız

  • MongoMaxKey
MongoDBRef::isRef
MongoMaxKey
Types


The MongoMaxKey class

(PECL mongo >= 1.0.2)

Uyarı

This extension that defines this class is deprecated. Instead, the MongoDB extension should be used. Alternatives to this class include:

  • MongoDB\BSON\MaxKey

Giriş

MongoMaxKey is an special type used by the database that compares greater than all other possible BSON values. Thus, if a query is sorted by a given field in ascending order, any document with a MongoMaxKey as its value will be returned last.

MongoMaxKey has no associated fields, methods, or constants. It is merely the "greatest" value that can be represented in the database.

Bilginize: MongoMaxKey is used internally by MongoDB for indexing and sharding. There is generally no reason to use this class in an application.

Sınıf Sözdizimi

MongoMaxKey {
}

Using MongoMaxKey as a value

<?php

$collection->insert(array("task" => "dishes", "doBy" => new MongoMaxKey));
$collection->insert(array("task" => "staff meeting", "doBy" => new MongoDate(strtotime("+4 days"))));

$cursor = $collection->find()->sort(array("doBy" => 1));

?>

The cursor will return the staff meeting document followed by the dishes document. The dishes document will always be returned last, regardless of what else is added to the collection (unless other documents are added with MongoMaxKey in their "doBy" field).

Ayrıca Bakınız

  • MongoMinKey
MongoMinKey
MongoTimestamp
Types


The MongoTimestamp class

(PECL mongo >=1.0.1)

Uyarı

This extension that defines this class is deprecated. Instead, the MongoDB extension should be used. Alternatives to this class include:

  • MongoDB\BSON\Timestamp

Giriş

MongoTimestamp is an internal type used by MongoDB for replication and sharding. It consists of a 4-byte timestamp (i.e. seconds since the epoch) and a 4-byte increment. This type is not intended for storing time or date values (e.g. a "createdAt" field on a document).

Bilginize: Unless you are writing an application that interacts with MongoDB's replication oplog or sharding internals: stop, go directly to MongoDate, do not pass go, and do not collect 200 dollars. This is not the class you are looking for.

Sınıf Sözdizimi

MongoTimestamp {
/* Fields */
public int $sec = 0 ;
public int $inc = 0 ;
/* Yöntemler */
public __construct ([ int $sec = time() [, int $inc ]] )
public string __toString ( void )
}

İçindekiler

  • MongoTimestamp::__construct — Creates a new timestamp.
  • MongoTimestamp::__toString — Returns a string representation of this timestamp
MongoMaxKey
MongoTimestamp::__construct
Types


Creates a new timestamp.

MongoTimestamp
MongoTimestamp::__toString
MongoTimestamp
PHP Manual

MongoTimestamp::__construct

(PECL mongo >= 1.0.1)

MongoTimestamp::__construct — Creates a new timestamp.

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. Alternatives to this method include:

  • MongoDB\BSON\Timestamp::__construct()

Açıklama

public MongoTimestamp::__construct ([ int $sec = time() [, int $inc ]] )

Creates a new timestamp. If no parameters are given, the current time is used and the increment is automatically provided. The increment is set to 0 when the module is loaded and is incremented every time this constructor is called (without the $inc parameter passed in).

Değiştirgeler

sec

Number of seconds since the epoch (i.e. 1 Jan 1970 00:00:00.000 UTC).

inc

Increment.

Dönen Değerler

Returns this new timestamp.

Ayrıca Bakınız

  • MongoTimestamp::__toString() - Returns a string representation of this timestamp

MongoTimestamp
MongoTimestamp::__toString
MongoTimestamp


Returns a string representation of this timestamp

MongoTimestamp::__construct
GridFS Classes
MongoTimestamp
PHP Manual

MongoTimestamp::__toString

(PECL mongo >= 1.0.1)

MongoTimestamp::__toString — Returns a string representation of this timestamp

This extension that defines this method is deprecated. Instead, the MongoDB extension should be used. Alternatives to this method include:

  • MongoDB\BSON\Timestamp::__toString()

Açıklama

public string MongoTimestamp::__toString ( void )

Returns the "sec" field of this timestamp.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The seconds since epoch represented by this timestamp.

MongoTimestamp::__construct
GridFS Classes
MongoTimestamp


GridFS Classes

İçindekiler

  • MongoGridFS
  • MongoGridFSFile
  • MongoGridFSCursor
MongoTimestamp::__toString
MongoGridFS
Mongo


The MongoGridFS class

(PECL mongo >=0.9.0)

Giriş

Utilities for storing and retrieving files from the database.

GridFS is a storage specification all supported drivers implement. Basically, it defines two collections: files, for file metadata, and chunks, for file content. If the file is large, it will automatically be split into smaller chunks and each chunk will be saved as a document in the chunks collection.

Each document in the files collection contains the filename, upload date, and md5 hash. It also contains a unique _id field, which can be used to query the chunks collection for the file's content. Each document in the chunks collection contains a chunk of binary data, a files_id field that matches its file's _id, and the position of this chunk in the overall file.

For example, the files document is something like:

<?php
array("_id" => 123456789, "filename" => "foo.txt", "chunkSize" => 3, "length" => 12);
?>
and the chunks documents look like:
<?php
array("files_id" => 123456789, "n" => 0, "data" => new MongoBinData("abc"));
array("files_id" => 123456789, "n" => 1, "data" => new MongoBinData("def"));
array("files_id" => 123456789, "n" => 2, "data" => new MongoBinData("ghi"));
array("files_id" => 123456789, "n" => 3, "data" => new MongoBinData("jkl"));
?>
Of course, the default chunk size is thousands of bytes, but that makes an unwieldy example.

Inter-Language Compatibility

You should be able to use any files created by MongoGridFS with any other drivers, and vice versa. However, some drivers expect that all metadata associated with a file be in a "metadata" field. If you're going to be using other languages, it's a good idea to wrap info you might want them to see in a "metadata" field. For example, instead of:

<?php

$grid->storeFile("somefile.txt", array("date" => new MongoDate()));

?>

use something like:

<?php

$grid->storeFile("somefile.txt", array("metadata" => array("date" => new MongoDate())));

?>

The MongoGridFS Family

MongoGridFS represents the files and chunks collections. MongoGridFS extends MongoCollection, and an instance of MongoGridFS has access to all of MongoCollection methods, which act on the files collection:

<?php

$grid = $db->getGridFS();
$grid->update(array("filename" => "foo"), $newObj); // update on the files collection

?>

Another example of manipulating metadata:

<?php

// save a file
$id = $grid->storeFile("game.tgz");
$game = $grid->findOne();

// add a downloads counter
$game->file['downloads'] = 0;
$grid->save($game->file);

// increment the counter
$grid->update(array("_id" => $id), array('$inc' => array("downloads" => 1)));

?>

You can also access the chunks collection from an instance of MongoGridFS:

<?php

  $chunks = $grid->chunks; // $chunks is a normal MongoCollection
$chunks->insert(array("x" => 4));

?>

There are some methods for MongoGridFS with the same name as MongoCollection methods, that behave slightly differently. For example, MongoGridFS::remove() will remove any objects that match the criteria from the files collection and their content from the chunks collection.

To store something new in GridFS, there are a couple options. If you have a filename, you can say:

<?php

$grid->storeFile($filename, array("whatever" => "metadata", "you" => "want"));

?>

If you have a string of bytes that isn't a file, you can also store that using MongoGridFS::storeBytes():

<?php

$grid->storeBytes($bytes, array("whatever" => "metadata", "you" => "want"));

?>

Querying a MongoGridFS collection returns a MongoGridFSCursor, which behaves like a normal MongoCursor except that it returns MongoGridFSFiles instead of associative arrays.

MongoGridFSFiles can be written back to disc using MongoGridFSFile::write() or retrieved in memory using MongoGridFSFile::getBytes(). There is currently no method that automatically streams chunks, but it would be fairly easy to write by querying the $grid->chunks collection.

MongoGridFSFile objects contain a field file which contains any file metadata.

Sınıf Sözdizimi

extends MongoCollection {
/* Fields */
public MongoCollection $chunks = NULL ;
protected string $filesName = NULL ;
protected string $chunksName = NULL ;
/* Yöntemler */
public __construct ( MongoDB $db [, string $prefix = "fs" [, mixed $chunks = "fs" ]] )
public bool|array delete ( mixed $id )
public array drop ( void )
public MongoGridFSCursor find ([ array $query = array() [, array $fields = array() ]] )
public MongoGridFSFile findOne ([ mixed $query = array() [, mixed $fields = array() ]] )
public MongoGridFSFile get ( mixed $id )
public mixed put ( string $filename [, array $metadata = array() [, array $options = array() ]] )
public bool|array remove ([ array $criteria = array() [, array $options = array() ]] )
public mixed storeBytes ( string $bytes [, array $metadata = array() [, array $options = array() ]] )
public mixed storeFile ( string|resource $filename [, array $metadata = array() [, array $options = array() ]] )
public mixed storeUpload ( string $name [, array $metadata ] )
}

Ayrıca Bakınız

  • MongoDB core docs on » GridFS
  • LightCube Solutions blog post on » saving user uploads
  • LightCube Solutions blog post on » adding metadata to files

İçindekiler

  • MongoGridFS::__construct — Creates new file collections
  • MongoGridFS::delete — Remove a file and its chunks from the database
  • MongoGridFS::drop — Drops the files and chunks collections
  • MongoGridFS::find — Queries for files
  • MongoGridFS::findOne — Returns a single file matching the criteria
  • MongoGridFS::get — Retrieve a file from the database
  • MongoGridFS::put — Stores a file in the database
  • MongoGridFS::remove — Remove files and their chunks from the database
  • MongoGridFS::storeBytes — Stores a string of bytes in the database
  • MongoGridFS::storeFile — Stores a file in the database
  • MongoGridFS::storeUpload — Stores an uploaded file in the database
GridFS Classes
MongoGridFS::__construct
GridFS Classes


Creates new file collections

MongoGridFS
MongoGridFS::delete
MongoGridFS
PHP Manual

MongoGridFS::__construct

(PECL mongo >=0.9.0)

MongoGridFS::__construct — Creates new file collections

Açıklama

public MongoGridFS::__construct ( MongoDB $db [, string $prefix = "fs" [, mixed $chunks = "fs" ]] )

Files as stored across two collections, the first containing file meta information, the second containing chunks of the actual file. By default, fs.files and fs.chunks are the collection names used.

Use one argument to specify a prefix other than "fs":

$fs = new MongoGridFS($db, "myfiles");
uses myfiles.files and myfiles.chunks collections.

Değiştirgeler

db

Database.

files

Optional collection name prefix.

MongoGridFS
MongoGridFS::delete
MongoGridFS


Remove a file and its chunks from the database

MongoGridFS::__construct
MongoGridFS::drop
MongoGridFS
PHP Manual

MongoGridFS::delete

(PECL mongo >=1.0.8)

MongoGridFS::delete — Remove a file and its chunks from the database

Açıklama

public bool|array MongoGridFS::delete ( mixed $id )

Bilginize:

MongoGridFS::delete() is a convenience method for calling MongoGridFS::remove() with specific criteria and default options parameters.

Değiştirgeler

id

_id of the file to remove.

Dönen Değerler

Returns an array containing the status of the removal (with respect to the files collection) if a write concern is applied. Otherwise, returns TRUE.

Fields in the status array are described in the documentation for MongoCollection::insert().

Hatalar/İstisnalar

Throws MongoCursorException if the "w" option is set and the write fails.

Throws MongoCursorTimeoutException if the "w" option is set to a value greater than one and the operation takes longer than MongoCursor::$timeout milliseconds to complete. This does not kill the operation on the server, it is a client-side timeout. The operation in MongoCollection::$wtimeout is milliseconds.

MongoGridFS::__construct
MongoGridFS::drop
MongoGridFS


Drops the files and chunks collections

MongoGridFS::delete
MongoGridFS::find
MongoGridFS
PHP Manual

MongoGridFS::drop

(PECL mongo >=0.9.0)

MongoGridFS::drop — Drops the files and chunks collections

Açıklama

public array MongoGridFS::drop ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The database response.

MongoGridFS::delete
MongoGridFS::find
MongoGridFS


Queries for files

MongoGridFS::drop
MongoGridFS::findOne
MongoGridFS
PHP Manual

MongoGridFS::find

(PECL mongo >=0.9.0)

MongoGridFS::find — Queries for files

Açıklama

 public MongoGridFSCursor MongoGridFS::find
  ([ array $query = array()
 [, array $fields = array()
]] )

Değiştirgeler

query

The query.

fields

Fields to return.

Dönen Değerler

A MongoGridFSCursor.

MongoGridFS::drop
MongoGridFS::findOne
MongoGridFS


Returns a single file matching the criteria

MongoGridFS::find
MongoGridFS::get
MongoGridFS
PHP Manual

MongoGridFS::findOne

(PECL mongo >=0.9.0)

MongoGridFS::findOne — Returns a single file matching the criteria

Açıklama

 public MongoGridFSFile MongoGridFS::findOne
  ([ mixed $query = array()
 [, mixed $fields = array()
]] )

Değiştirgeler

query

The filename or criteria for which to search.

Dönen Değerler

Returns a MongoGridFSFile or NULL.

Örnekler

Örnek 1 MongoGridFS::findOne() example

Example demonstrating how to find a single file from the MongoGridFS.

<?php

$downloads = $mongo->my_db->getGridFS('downloads');

$downloads->storeFile('filename.tgz');

$download = $downloads->findOne('filename.tgz'); // instance of MongoGridFSFile

print_r($download);
?>

See MongoGridFSFile for more information about how to work with files.

Yukarıdaki örnek şuna benzer bir çıktı üretir:

MongoGridFSFile Object
(
    [file] => Array
        (
            [_id] => MongoId Object
                (
                )

            [filename] => filename.tgz
            [uploadDate] => MongoDate Object
                (
                    [sec] => 1274288014
                    [usec] => 467000
                )

            [chunkSize] => 262144
            [md5] => d41d8cd98f00b204e9800998ecf8427e
        )

    [gridfs:protected] => MongoGridFS Object
        (
            [chunks] => MongoCollection Object
                (
                )

            [filesName:protected] => downloads.files
            [chunksName:protected] => downloads.chunks
        )

)
MongoGridFS::find
MongoGridFS::get
MongoGridFS


Retrieve a file from the database

MongoGridFS::findOne
MongoGridFS::put
MongoGridFS
PHP Manual

MongoGridFS::get

(PECL mongo >=1.0.8)

MongoGridFS::get — Retrieve a file from the database

Açıklama

public MongoGridFSFile MongoGridFS::get ( mixed $id )

Değiştirgeler

id

_id of the file to find.

Dönen Değerler

Returns the file, if found, or NULL.

MongoGridFS::findOne
MongoGridFS::put
MongoGridFS


Stores a file in the database

MongoGridFS::get
MongoGridFS::remove
MongoGridFS
PHP Manual

MongoGridFS::put

(PECL mongo >=1.0.8)

MongoGridFS::put — Stores a file in the database

Açıklama

public mixed MongoGridFS::put ( string $filename [, array $metadata = array() [, array $options = array() ]] )

Bilginize:

MongoGridFS::put() is an alias of MongoGridFS::storeFile().

Değiştirgeler

filename

Name of the file to store.

metadata

Other metadata fields to include in the file document.

Bilginize:

These fields may also overwrite those that would be created automatically by the driver, as described in the MongoDB core documentation for the » files collection. Some practical use cases for this behavior would be to specify a custom chunkSize or _id for the file.

options

An array of options for the insert operations executed against the chunks and files collections. See MongoCollection::insert() for documentation on these these options.

Dönen Değerler

Returns the _id of the saved file document. This will be a generated MongoId unless an _id was explicitly specified in the metadata parameter.

Hatalar/İstisnalar

Throws MongoGridFSException if there is an error reading filename or inserting into the chunks or files collections.

Ayrıca Bakınız

  • MongoGridFS::storeBytes() - Stores a string of bytes in the database
  • MongoGridFS::storeFile() - Stores a file in the database
  • MongoGridFS::storeUpload() - Stores an uploaded file in the database
  • MongoDB core docs on » GridFS
MongoGridFS::get
MongoGridFS::remove
MongoGridFS


Remove files and their chunks from the database

MongoGridFS::put
MongoGridFS::storeBytes
MongoGridFS
PHP Manual

MongoGridFS::remove

(PECL mongo >=0.9.0)

MongoGridFS::remove — Remove files and their chunks from the database

Açıklama

 public bool|array MongoGridFS::remove
  ([ array $criteria = array()
 [, array $options = array()
]] )

Değiştirgeler

criteria

The filename or criteria for which to search.

options

An array of options for the remove operations executed against the chunks and files collections. See MongoCollection::remove() for documentation on these options.

Dönen Değerler

Returns an array containing the status of the removal (with respect to the files collection) if the "w" option is set. Otherwise, returns TRUE.

Fields in the status array are described in the documentation for MongoCollection::insert().

Hatalar/İstisnalar

Throws MongoCursorException if the "w" option is set and the write fails.

Throws MongoCursorTimeoutException if the "w" option is set to a value greater than one and the operation takes longer than MongoCursor::$timeout milliseconds to complete. This does not kill the operation on the server, it is a client-side timeout. The operation in MongoCollection::$wtimeout is milliseconds.

MongoGridFS::put
MongoGridFS::storeBytes
MongoGridFS


Stores a string of bytes in the database

MongoGridFS::remove
MongoGridFS::storeFile
MongoGridFS
PHP Manual

MongoGridFS::storeBytes

(PECL mongo >=0.9.2)

MongoGridFS::storeBytes — Stores a string of bytes in the database

Açıklama

public mixed MongoGridFS::storeBytes ( string $bytes [, array $metadata = array() [, array $options = array() ]] )

Değiştirgeler

bytes

String of bytes to store.

metadata

Other metadata fields to include in the file document.

Bilginize:

These fields may also overwrite those that would be created automatically by the driver, as described in the MongoDB core documentation for the » files collection. Some practical use cases for this behavior would be to specify a custom chunkSize or _id for the file.

options

An array of options for the insert operations executed against the chunks and files collections. See MongoCollection::insert() for documentation on these these options.

Dönen Değerler

Returns the _id of the saved file document. This will be a generated MongoId unless an _id was explicitly specified in the metadata parameter.

Hatalar/İstisnalar

Throws MongoGridFSException if there is an error inserting into the chunks or files collections.

Örnekler

Örnek 1 MongoGridFS::storeBytes() with additional metadata

<?php
$m = new MongoClient();
$gridfs = $m->selectDB('test')->getGridFS();

$bytes = 'abcdefghijklmnopqrstuvwxyz';
$id = $gridfs->storeBytes($bytes, array('_id' => 'alphabet'));
$gridfsFile = $gridfs->get($id);

var_dump($gridfsFile->file);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(7) {
  ["_id"]=>
  string(8) "alphabet"
  ["uploadDate"]=>
  object(MongoDate)#7 (0) {
  }
  ["length"]=>
  int(26)
  ["chunkSize"]=>
  int(262144)
  ["md5"]=>
  string(32) "c3fcd3d76192e4007dfb496cca67e13b"
}

Ayrıca Bakınız

  • MongoGridFS::put() - Stores a file in the database
  • MongoGridFS::storeFile() - Stores a file in the database
  • MongoGridFS::storeUpload() - Stores an uploaded file in the database
  • MongoDB core docs on » GridFS
MongoGridFS::remove
MongoGridFS::storeFile
MongoGridFS


Stores a file in the database

MongoGridFS::storeBytes
MongoGridFS::storeUpload
MongoGridFS
PHP Manual

MongoGridFS::storeFile

(PECL mongo >=0.9.0)

MongoGridFS::storeFile — Stores a file in the database

Açıklama

public mixed MongoGridFS::storeFile ( string|resource $filename [, array $metadata = array() [, array $options = array() ]] )

Değiştirgeler

filename

Name of the file or a readable stream to store.

metadata

Other metadata fields to include in the file document.

Bilginize:

These fields may also overwrite those that would be created automatically by the driver, as described in the MongoDB core documentation for the » files collection. Some practical use cases for this behavior would be to specify a custom chunkSize or _id for the file.

options

An array of options for the insert operations executed against the chunks and files collections. See MongoCollection::insert() for documentation on these these options.

Dönen Değerler

Returns the _id of the saved file document. This will be a generated MongoId unless an _id was explicitly specified in the metadata parameter.

Hatalar/İstisnalar

Throws MongoGridFSException if there is an error reading filename or inserting into the chunks or files collections.

Örnekler

Örnek 1 MongoGridFS::storeFile() with additional metadata

<?php
$m = new MongoClient();
$gridfs = $m->selectDB('test')->getGridFS();

$id = $gridfs->storeFile('example.txt', array('contentType' => 'plain/text'));
$gridfsFile = $gridfs->get($id);

var_dump($gridfsFile->file);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(7) {
  ["_id"]=>
  object(MongoId)#6 (0) {
  }
  ["contentType"]=>
  string(10) "plain/text"
  ["filename"]=>
  string(11) "example.txt"
  ["uploadDate"]=>
  object(MongoDate)#7 (0) {
  }
  ["length"]=>
  int(26)
  ["chunkSize"]=>
  int(262144)
  ["md5"]=>
  string(32) "c3fcd3d76192e4007dfb496cca67e13b"
}

Ayrıca Bakınız

  • MongoGridFS::put() - Stores a file in the database
  • MongoGridFS::storeBytes() - Stores a string of bytes in the database
  • MongoGridFS::storeUpload() - Stores an uploaded file in the database
  • MongoDB core docs on » GridFS
MongoGridFS::storeBytes
MongoGridFS::storeUpload
MongoGridFS


Stores an uploaded file in the database

MongoGridFS::storeFile
MongoGridFSFile
MongoGridFS
PHP Manual

MongoGridFS::storeUpload

(PECL mongo >=0.9.0)

MongoGridFS::storeUpload — Stores an uploaded file in the database

Açıklama

public mixed MongoGridFS::storeUpload ( string $name [, array $metadata ] )

Değiştirgeler

name

The name of the uploaded file(s) to store. This should correspond to the file field's name attribute in the HTML form.

metadata

Other metadata fields to include in the file document.

Bilginize:

These fields may also overwrite those that would be created automatically by the driver, as described in the MongoDB core documentation for the » files collection. Some practical use cases for this behavior would be to specify a custom chunkSize or _id for the file.

Bilginize:

The filename field will be populated with the client's filename (e.g. $_FILES['foo']['name']).

Dönen Değerler

Returns the _id of the saved file document. This will be a generated MongoId unless an _id was explicitly specified in the metadata parameter.

Bilginize:

If multiple files are uploaded using the same field name, this method will not return anything; however, the files themselves will still be processed.

Hatalar/İstisnalar

Throws MongoGridFSException if there is an error reading the uploaded file(s) or inserting into the chunks or files collections.

Sürüm Bilgisi

Sürüm: | Açıklama
1.2.5 | Changed second parameter to an array of metadata. Pre-1.2.5, the second parameter was an optional string overriding the filename.

Örnekler

Örnek 1 MongoGridFS::storeUpload() HTML form example

Suppose you have the following HTML form:

<form method="POST" enctype="multipart/form-data">
    <label for="username">Username:</label>
    <input type="text" name="username" id="username" />

    <label for="pic">Please upload a profile picture:</label>
    <input type="file" name="pic" id="pic" />

    <input type="submit" />
</form>

If you wanted to store the uploaded image in MongoDB, you could do the following in the script handling the form submission:

<?php
$m = new MongoClient();
$gridfs = $m->selectDB('test')->getGridFS();

$gridfs->storeUpload('pic', array('username' => $_POST['username']));
?>

Ayrıca Bakınız

  • MongoGridFS::put() - Stores a file in the database
  • MongoGridFS::storeBytes() - Stores a string of bytes in the database
  • MongoGridFS::storeFile() - Stores a file in the database
  • MongoDB core docs on » GridFS
MongoGridFS::storeFile
MongoGridFSFile
MongoGridFS


The MongoGridFSFile class

(PECL mongo >=0.9.0)

Giriş

A database file object.

Sınıf Sözdizimi

MongoGridFSFile {
/* Fields */
public array $file = NULL ;
protected MongoGridFS $gridfs = NULL ;
/* Yöntemler */
public MongoGridfsFile::__construct ( MongoGridFS $gridfs , array $file )
public string getBytes ( void )
public string getFilename ( void )
public resource getResource ( void )
public int getSize ( void )
public int write ([ string $filename = NULL ] )
}

İçindekiler

  • MongoGridfsFile::__construct — Create a new GridFS file
  • MongoGridFSFile::getBytes — Returns this file's contents as a string of bytes
  • MongoGridFSFile::getFilename — Returns this file's filename
  • MongoGridFSFile::getResource — Returns a resource that can be used to read the stored file
  • MongoGridFSFile::getSize — Returns this file's size
  • MongoGridFSFile::write — Writes this file to the filesystem
MongoGridFS::storeUpload
MongoGridfsFile::__construct
GridFS Classes


Create a new GridFS file

MongoGridFSFile
MongoGridFSFile::getBytes
MongoGridFSFile
PHP Manual

MongoGridfsFile::__construct

(PECL mongo >=0.9.0)

MongoGridfsFile::__construct — Create a new GridFS file

Açıklama

public MongoGridfsFile::__construct ( MongoGridFS $gridfs , array $file )

Değiştirgeler

gridfs

The parent MongoGridFS instance.

file

A file from the database.

Dönen Değerler

Returns a new MongoGridFSFile.

MongoGridFSFile
MongoGridFSFile::getBytes
MongoGridFSFile


Returns this file's contents as a string of bytes

MongoGridfsFile::__construct
MongoGridFSFile::getFilename
MongoGridFSFile
PHP Manual

MongoGridFSFile::getBytes

(PECL mongo >=0.9.0)

MongoGridFSFile::getBytes — Returns this file's contents as a string of bytes

Açıklama

public string MongoGridFSFile::getBytes ( void )

Warning: this will load the file into memory. If the file is bigger than your memory, this will cause problems!

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a string of the bytes in the file.

Örnekler

Örnek 1 MongoGridFSFile::getBytes() example

<?php

$images = $db->my_db->getGridFS('images');

$image = $images->findOne('jwage.png');

header('Content-type: image/png;');
echo $image->getBytes();
?>
MongoGridfsFile::__construct
MongoGridFSFile::getFilename
MongoGridFSFile


Returns this file's filename

MongoGridFSFile::getBytes
MongoGridFSFile::getResource
MongoGridFSFile
PHP Manual

MongoGridFSFile::getFilename

(PECL mongo >=0.9.0)

MongoGridFSFile::getFilename — Returns this file's filename

Açıklama

public string MongoGridFSFile::getFilename ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the filename.

MongoGridFSFile::getBytes
MongoGridFSFile::getResource
MongoGridFSFile


Returns a resource that can be used to read the stored file

MongoGridFSFile::getFilename
MongoGridFSFile::getSize
MongoGridFSFile
PHP Manual

MongoGridFSFile::getResource

(PECL mongo >=1.3.0)

MongoGridFSFile::getResource — Returns a resource that can be used to read the stored file

Açıklama

public resource MongoGridFSFile::getResource ( void )

This method returns a stream resource that can be used with all file functions in PHP that deal with reading files. The contents of the file are pulled out of MongoDB on the fly, so that the whole file does not have to be loaded into memory first.

At most two GridFSFile chunks will be loaded in memory.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a resource that can be used to read the file with

Örnekler

Örnek 1 MongoGridFSFile::getResource() example

<?php
$m = new Mongo;
$images = $m->my_db->getGridFS('images');

$image = $images->findOne('mongo.png');

header('Content-type: image/png;');
$stream = $image->getResource();

while (!feof($stream)) {
    echo fread($stream, 8192);
}
?>
MongoGridFSFile::getFilename
MongoGridFSFile::getSize
MongoGridFSFile


Returns this file's size

MongoGridFSFile::getResource
MongoGridFSFile::write
MongoGridFSFile
PHP Manual

MongoGridFSFile::getSize

(PECL mongo >=0.9.0)

MongoGridFSFile::getSize — Returns this file's size

Açıklama

public int MongoGridFSFile::getSize ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns this file's size

MongoGridFSFile::getResource
MongoGridFSFile::write
MongoGridFSFile


Writes this file to the filesystem

MongoGridFSFile::getSize
MongoGridFSCursor
MongoGridFSFile
PHP Manual

MongoGridFSFile::write

(PECL mongo >=0.9.0)

MongoGridFSFile::write — Writes this file to the filesystem

Açıklama

public int MongoGridFSFile::write ([ string $filename = NULL ] )

Değiştirgeler

filename

The location to which to write the file. If none is given, the stored filename will be used.

Dönen Değerler

Returns the number of bytes written.

Örnekler

Örnek 1 MongoGridFSFile::write() example

<?php

$images = $db->my_db->getGridFS('images');

$image = $images->findOne('jwage.png');
$image->write('/path/to/write/jwage.png');
?>
MongoGridFSFile::getSize
MongoGridFSCursor
MongoGridFSFile


The MongoGridFSCursor class

(PECL mongo >=0.9.0)

Giriş

Cursor for database file results.

Sınıf Sözdizimi

extends MongoCursor {
/* Fields */
protected MongoGridFS $gridfs = NULL ;
/* Yöntemler */
public __construct ( MongoGridFS $gridfs , resource $connection , string $ns , array $query , array $fields )
public MongoGridFSFile current ( void )
public MongoGridFSFile getNext ( void )
public string key ( void )
}

İçindekiler

  • MongoGridFSCursor::__construct — Create a new cursor
  • MongoGridFSCursor::current — Returns the current file
  • MongoGridFSCursor::getNext — Return the next file to which this cursor points, and advance the cursor
  • MongoGridFSCursor::key — Returns the current result's filename
MongoGridFSFile::write
MongoGridFSCursor::__construct
GridFS Classes


Create a new cursor

MongoGridFSCursor
MongoGridFSCursor::current
MongoGridFSCursor
PHP Manual

MongoGridFSCursor::__construct

(PECL mongo >=0.9.0)

MongoGridFSCursor::__construct — Create a new cursor

Açıklama

public MongoGridFSCursor::__construct ( MongoGridFS $gridfs , resource $connection , string $ns , array $query , array $fields )

Değiştirgeler

gridfs

Related GridFS collection.

connection

Database connection.

ns

Full name of database and collection.

query

Database query.

fields

Fields to return.

Dönen Değerler

Returns the new cursor.

MongoGridFSCursor
MongoGridFSCursor::current
MongoGridFSCursor


Returns the current file

MongoGridFSCursor::__construct
MongoGridFSCursor::getNext
MongoGridFSCursor
PHP Manual

MongoGridFSCursor::current

(PECL mongo >=0.9.0)

MongoGridFSCursor::current — Returns the current file

Açıklama

public MongoGridFSFile MongoGridFSCursor::current ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current file.

MongoGridFSCursor::__construct
MongoGridFSCursor::getNext
MongoGridFSCursor


Return the next file to which this cursor points, and advance the cursor

MongoGridFSCursor::current
MongoGridFSCursor::key
MongoGridFSCursor
PHP Manual

MongoGridFSCursor::getNext

(PECL mongo >=0.9.0)

MongoGridFSCursor::getNext — Return the next file to which this cursor points, and advance the cursor

Açıklama

public MongoGridFSFile MongoGridFSCursor::getNext ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the next file.

MongoGridFSCursor::current
MongoGridFSCursor::key
MongoGridFSCursor


Returns the current result's filename

MongoGridFSCursor::getNext
Batch Classes
MongoGridFSCursor
PHP Manual

MongoGridFSCursor::key

(PECL mongo >=0.9.0)

MongoGridFSCursor::key — Returns the current result's filename

Açıklama

public string MongoGridFSCursor::key ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current result's _id as a string.

Sürüm Bilgisi

Sürüm: | Açıklama
1.3.0 | The document's _id is returned as a string value, since the key should be unique. Pre-1.3.0, filename was returned.

MongoGridFSCursor::getNext
Batch Classes
MongoGridFSCursor


Batch Classes

İçindekiler

  • MongoWriteBatch
  • MongoInsertBatch
  • MongoUpdateBatch
  • MongoDeleteBatch
MongoGridFSCursor::key
MongoWriteBatch
Mongo


The MongoWriteBatch class

(PECL mongo >=1.5.0)

Giriş

MongoWriteBatch is the base class for the MongoInsertBatch, MongoUpdateBatch and MongoDeleteBatch classes.

MongoWriteBatch allows you to "batch up" multiple operations (of same type) and shipping them all to MongoDB at the same time. This can be especially useful when operating on many documents at the same time to reduce roundtrips.

Prior to version 1.5.0 of the driver it was possible to use MongoCollection::batchInsert(), however, as of 1.5.0 that method is now discouraged.

Note: This class is only available when talking to MongoDB 2.6.0 (and later) servers. It will throw MongoProtocolException if attempting to use it on older MongoDB servers.

Sınıf Sözdizimi

MongoWriteBatch {
/* Sabitler */
const int COMMAND_INSERT = 1 ;
const int COMMAND_UPDATE = 2 ;
const int COMMAND_DELETE = 3 ;
/* Yöntemler */
protected __construct ( MongoCollection $collection [, string $batch_type [, array $write_options ]] )
public bool add ( array $item )
final public array execute ( array $write_options )
}

MongoWriteBatch types

MongoWriteBatch::COMMAND_INSERT

Create an Insert Write Batch

MongoWriteBatch::COMMAND_UPDATE

Create an Update Write Batch

MongoWriteBatch::COMMAND_DELETE

Create an Delete Write Batch

Açıklama

When executing a batch by calling MongoWriteBatch::execute(), MongoWriteBatch will send up to maxWriteBatchSize (defaults to 1000) documents or maxBsonObjectSize (defaults to 16777216 bytes), whichever comes first.

Bilginize:

Documents will never be partially transferred. When adding documents to the batch, that overflows the limit, a new batch will be created and the document put into the new batch.

Hatalar/İstisnalar

  • Exception on parameter parsing failures
  • Exception on argument validation errors (e.g. missing keys)
  • MongoProtocolException when talking to MongoDB server older then 2.6.0.
  • MongoProtocolException on socket errors.
  • MongoWriteConcernException when a write fails due to WriteConcerns

Örnekler

Örnek 1 MongoWriteBatch example

Adding documents to a Insert batch and then execute it

<?php
$mc = new MongoClient("localhost");

$collection = $mc->selectCollection("test", "test");

$docs = array();
$docs[] = array("my" => "demo");
$docs[] = array("is" => "working");
$docs[] = array("pretty" => "well");

$batch = new MongoInsertBatch($collection);
foreach($docs as $document) {
    $batch->add($document);
}
$retval = $batch->execute(array("w" => 1));
var_dump($retval);
?>

Yukarıdaki örneğin çıktısı:

array(2) {
  ["nInserted"]=>
  int(3)
  ["ok"]=>
  bool(true)
}

İçindekiler

  • MongoWriteBatch::add — Adds a write operation to a batch
  • MongoWriteBatch::__construct — Creates a new batch of write operations
  • MongoWriteBatch::execute — Executes a batch of write operations
Batch Classes
MongoWriteBatch::add
Batch Classes


Adds a write operation to a batch

MongoWriteBatch
MongoWriteBatch::__construct
MongoWriteBatch
PHP Manual

MongoWriteBatch::add

(PECL mongo >= 1.5.0)

MongoWriteBatch::add — Adds a write operation to a batch

Açıklama

public bool MongoWriteBatch::add ( array $item )

Adds a write operation to the batch.

If $item causes the batch to exceed the maxWriteBatchSize or maxBsonObjectSize limits, the driver will internally split the batches into multiple write commands upon calling MongoWriteBatch::execute().

Değiştirgeler

item

An array that describes a write operation. The structure of this value depends on the batch's operation type.

Batch type | Argument expectation
MongoWriteBatch::COMMAND_INSERT | The document to add.
MongoWriteBatch::COMMAND_UPDATE

Raw update operation.

Required keys are "q" and "u", which correspond to the $criteria and $new_object parameters of MongoCollection::update(), respectively.

Optional keys are "multi" and "upsert", which correspond to the "multiple" and "upsert" options for MongoCollection::update(), respectively. If unspecified, both options default to FALSE.
MongoWriteBatch::COMMAND_DELETE

Raw delete operation.

Required keys are: "q" and "limit", which correspond to the $criteria parameter and "justOne" option of MongoCollection::remove(), respectively.

The "limit" option is an integer; however, MongoDB only supports 0 (i.e. remove all matching documents) and 1 (i.e. remove at most one matching document) at this time.

Dönen Değerler

Returns TRUE on success and throws an exception on failure.

Hatalar/İstisnalar

  • Exception on parameter parsing failures
  • Exception on argument validation errors (e.g. missing keys)

Örnekler

Örnek 1 MongoWriteBatch::add() example

Batching up multiple insert operations

<?php
$mc = new MongoClient("localhost");
$collection = $mc->selectCollection("test", "test");

$docs = array();
$docs[] = array("my" => "demo");
$docs[] = array("is" => "working");
$docs[] = array("pretty" => "well");

$batch = new MongoInsertBatch($collection);
foreach($docs as $document) {
    $batch->add($document);
}
$batch->execute(array("w" => 1));
?>

Örnek 2 MongoWriteBatch::add() example

Batching up multiple update operations

<?php
$mc = new MongoClient("localhost");
$collection = $mc->selectCollection("test", "test");

$item1 = array(
    "q" => array("my" => "demo"),
    "u" => array('$set' => array("try" => 1)),
    "multi"  => false, /* default value */
    "upsert" => false, /* default value */
);
$item2 = array(
    "q" => array("is" => "working"),
    "u" => array('$set' => array("try" => 2)),
    "multi" => true,
);
$item3 = array(
    "q" => array("created" => "new-document"),
    "u" => array('$set' => array("try" => 3)),
    "upsert" => true,
);

$batch = new MongoUpdateBatch($collection);
$batch->add($item1);
$batch->add($item2);
$batch->add($item3);
$batch->execute(array("w" => 1));

?>

Örnek 3 MongoWriteBatch::add() example

Batching up multiple delete operations

<?php
$mc = new MongoClient("localhost");
$collection = $mc->selectCollection("test", "test");

$item1 = array(
    "q" => array("my" => "demo"),
    "limit" => 1,
);
$item2 = array(
    "q" => array("try" => 3),
    "limit" => 1,
);

$batch = new MongoDeleteBatch($collection);
$batch->add($item1);
$batch->add($item2);
$batch->execute(array("w" => 1));
?>
MongoWriteBatch
MongoWriteBatch::__construct
MongoWriteBatch


Creates a new batch of write operations

MongoWriteBatch::add
MongoWriteBatch::execute
MongoWriteBatch
PHP Manual

MongoWriteBatch::__construct

(PECL mongo >= 1.5.0)

MongoWriteBatch::__construct — Creates a new batch of write operations

Açıklama

protected MongoWriteBatch::__construct ( MongoCollection $collection [, string $batch_type [, array $write_options ]] )

Constructs a new MongoWriteBatch.

Bilginize:

This is a protected constructor. Please use one of the classes inheriting MongoWriteBatch.

Değiştirgeler

collection

The MongoCollection to execute the batch on. Its write concern will be copied and used as the default write concern if none is given as $write_options or during MongoWriteBatch::execute().

batch_type

One of:

  • 0 - make an MongoWriteBatch::COMMAND_INSERT batch
  • 1 - make an MongoWriteBatch::COMMAND_UPDATE batch
  • 2 - make a MongoWriteBatch::COMMAND_DELETE batch

write_options

An array of Write Options.

key | value meaning
w (int|string) | Write concern value
wtimeout (int) | Maximum time to wait for replication
ordered | Determins if MongoDB must apply this batch in order (sequentally, one item at a time) or can rearrange it. Defaults to TRUE
j (bool) | Wait for journaling on the primary. This value is discouraged, use WriteConcern instead
fsync (bool) | Wait for fsync on the primary. This value is discouraged, use WriteConcern instead

Dönen Değerler

A new MongoWriteBatch of type batch_type.

Ayrıca Bakınız

  • MongoInsertBatch
  • MongoUpdateBatch
  • MongoDeleteBatch
MongoWriteBatch::add
MongoWriteBatch::execute
MongoWriteBatch


Executes a batch of write operations

MongoWriteBatch::__construct
MongoInsertBatch
MongoWriteBatch
PHP Manual

MongoWriteBatch::execute

(PECL mongo >= 1.5.0)

MongoWriteBatch::execute — Executes a batch of write operations

Açıklama

final public array MongoWriteBatch::execute ( array $write_options )

Executes the batch of write operations.

Değiştirgeler

write_options

See MongoWriteBatch::__construct.

Dönen Değerler

Returns an array containing statistical information for the full batch. If the batch had to be split into multiple batches, the return value will aggregate the values from individual batches and return only the totals.

If the batch was empty, an array containing only the 'ok' field is returned (as TRUE) although nothing will be shipped over the wire (NOOP).

Array key | Value meaning | Returned for batch type
nInserted | Number of inserted documents | MongoWriteBatch::COMMAND_INSERT batch
nMatched | Number of documents matching the query criteria | MongoWriteBatch::COMMAND_UPDATE batch
nModified | Number of documents actually needed to be modied | MongoWriteBatch::COMMAND_UPDATE batch
nUpserted | Number of upserted documents | MongoWriteBatch::COMMAND_UPDATE batch
nRemoved | Number of documents removed | MongoWriteBatch::COMMAND_DELETE batch
ok | Command success indicator | All

Hatalar/İstisnalar

A MongoWriteConcernException exception is thrown on failure.

Örnekler

Örnek 1 MongoWriteBatch::add() example

Batching up multiple insert operations

<?php
$mc = new MongoClient("localhost");
$collection = $mc->selectCollection("test", "test");

$docs = array();
$docs[] = array("my" => "demo");
$docs[] = array("is" => "working");
$docs[] = array("pretty" => "well");

$batch = new MongoInsertBatch($collection);
foreach($docs as $document) {
    $batch->add($document);
}
$retval = $batch->execute(array("w" => 1));
var_dump($retval);
?>

Yukarıdaki örneğin çıktısı:

array(2) {
  ["nInserted"]=>
  int(3)
  ["ok"]=>
  bool(true)
}

Örnek 2 MongoWriteBatch::add() example

Batching up multiple update operations

<?php
$mc = new MongoClient("localhost");
$collection = $mc->selectCollection("test", "test");

$item1 = array(
    "q" => array("my" => "demo"),
    "u" => array('$set' => array("try" => 1)),
    "multi"  => false, /* default value */
    "upsert" => false, /* default value */
);
$item2 = array(
    "q" => array("is" => "working"),
    "u" => array('$set' => array("try" => 2)),
    "multi" => true,
);
$item3 = array(
    "q" => array("created" => "new-document"),
    "u" => array('$set' => array("try" => 3)),
    "upsert" => true,
);

$batch = new MongoUpdateBatch($collection);
$batch->add($item1);
$batch->add($item2);
$batch->add($item3);
$retval = $batch->execute(array("w" => 1));
var_dump($retval);

?>

Yukarıdaki örneğin çıktısı:

array(4) {
  ["nMatched"]=>
  int(18)
  ["nModified"]=>
  int(2)
  ["nUpserted"]=>
  int(0)
  ["ok"]=>
  bool(true)
}

Örnek 3 MongoWriteBatch::add() example

Batching up multiple delete operations

<?php
$mc = new MongoClient("localhost");
$collection = $mc->selectCollection("test", "test");

$item1 = array(
    "q" => array("my" => "demo"),
    "limit" => 1,
);
$item2 = array(
    "q" => array("try" => 3),
    "limit" => 1,
);

$batch = new MongoDeleteBatch($collection);
$batch->add($item1);
$batch->add($item2);
$retval = $batch->execute(array("w" => 1));
var_dump($retval);
?>

Yukarıdaki örneğin çıktısı:

array(2) {
  ["nRemoved"]=>
  int(1)
  ["ok"]=>
  bool(true)
}
MongoWriteBatch::__construct
MongoInsertBatch
MongoWriteBatch


The MongoInsertBatch class

(PECL mongo >=1.5.0)

Giriş

Constructs a batch of INSERT operations. See MongoWriteBatch.

Sınıf Sözdizimi

MongoInsertBatch extends MongoWriteBatch {
/* Yöntemler */
public __construct ( MongoCollection $collection [, array $write_options ] )
/* Miras alınan yöntemler */
public bool MongoWriteBatch::add ( array $item )
final public array MongoWriteBatch::execute ( array $write_options )
}

İçindekiler

  • MongoInsertBatch::__construct — Description
MongoWriteBatch::execute
MongoInsertBatch::__construct
Batch Classes


Description

MongoInsertBatch
MongoUpdateBatch
MongoInsertBatch
PHP Manual

MongoInsertBatch::__construct

(PECL mongo >= 1.5.0)

MongoInsertBatch::__construct — Description

Açıklama

public MongoInsertBatch::__construct ( MongoCollection $collection [, array $write_options ] )

Constructs a batch of INSERT operations. See MongoWriteBatch.

Değiştirgeler

collection

The MongoCollection to execute the batch on. Its write concern will be copied and used as the default write concern if none is given as $write_options or during MongoWriteBatch::execute().

write_options

An array of Write Options.

key | value meaning
w (int|string) | Write concern value
wtimeout (int) | Maximum time to wait for replication
ordered | Determins if MongoDB must apply this batch in order (sequentally, one item at a time) or can rearrange it. Defaults to TRUE
j (bool) | Wait for journaling on the primary. This value is discouraged, use WriteConcern instead
fsync (bool) | Wait for fsync on the primary. This value is discouraged, use WriteConcern instead

Dönen Değerler

A new MongoInsertBatch.

MongoInsertBatch
MongoUpdateBatch
MongoInsertBatch


The MongoUpdateBatch class

(PECL mongo >=1.5.0)

Giriş

Constructs a batch of UPDATE operations. See MongoWriteBatch.

Sınıf Sözdizimi

MongoUpdateBatch extends MongoWriteBatch {
/* Yöntemler */
public __construct ( MongoCollection $collection [, array $write_options ] )
/* Miras alınan yöntemler */
public bool MongoWriteBatch::add ( array $item )
final public array MongoWriteBatch::execute ( array $write_options )
}

İçindekiler

  • MongoUpdateBatch::__construct — Description
MongoInsertBatch::__construct
MongoUpdateBatch::__construct
Batch Classes


Description

MongoUpdateBatch
MongoDeleteBatch
MongoUpdateBatch
PHP Manual

MongoUpdateBatch::__construct

(PECL mongo >= 1.5.0)

MongoUpdateBatch::__construct — Description

Açıklama

public MongoUpdateBatch::__construct ( MongoCollection $collection [, array $write_options ] )

Constructs a batch of UPDATE operations. See MongoWriteBatch.

Değiştirgeler

collection

The MongoCollection to execute the batch on. Its write concern will be copied and used as the default write concern if none is given as $write_options or during MongoWriteBatch::execute().

write_options

An array of Write Options.

key | value meaning
w (int|string) | Write concern value
wtimeout (int) | Maximum time to wait for replication
ordered | Determins if MongoDB must apply this batch in order (sequentally, one item at a time) or can rearrange it. Defaults to TRUE
j (bool) | Wait for journaling on the primary. This value is discouraged, use WriteConcern instead
fsync (bool) | Wait for fsync on the primary. This value is discouraged, use WriteConcern instead

Dönen Değerler

A new MongoUpdateBatch.

MongoUpdateBatch
MongoDeleteBatch
MongoUpdateBatch


The MongoDeleteBatch class

(PECL mongo >=1.5.0)

Giriş

Constructs a batch of DELETE operations. See MongoWriteBatch.

Sınıf Sözdizimi

MongoDeleteBatch extends MongoWriteBatch {
/* Yöntemler */
public __construct ( MongoCollection $collection [, array $write_options ] )
/* Miras alınan yöntemler */
public bool MongoWriteBatch::add ( array $item )
final public array MongoWriteBatch::execute ( array $write_options )
}

İçindekiler

  • MongoDeleteBatch::__construct — Description
MongoUpdateBatch::__construct
MongoDeleteBatch::__construct
Batch Classes


Description

MongoDeleteBatch
Miscellaneous
MongoDeleteBatch
PHP Manual

MongoDeleteBatch::__construct

(PECL mongo >= 1.5.0)

MongoDeleteBatch::__construct — Description

Açıklama

public MongoDeleteBatch::__construct ( MongoCollection $collection [, array $write_options ] )

Constructs a batch of DELETE operations. See MongoWriteBatch.

Değiştirgeler

collection

The MongoCollection to execute the batch on. Its write concern will be copied and used as the default write concern if none is given as $write_options or during MongoWriteBatch::execute().

write_options

An array of Write Options.

key | value meaning
w (int|string) | Write concern value
wtimeout (int) | Maximum time to wait for replication
ordered | Determins if MongoDB must apply this batch in order (sequentally, one item at a time) or can rearrange it. Defaults to TRUE
j (bool) | Wait for journaling on the primary. This value is discouraged, use WriteConcern instead
fsync (bool) | Wait for fsync on the primary. This value is discouraged, use WriteConcern instead

Dönen Değerler

A new MongoDeleteBatch.

MongoDeleteBatch
Miscellaneous
MongoDeleteBatch


Miscellaneous

İçindekiler

  • MongoLog
  • MongoPool
  • Mongo
MongoDeleteBatch::__construct
MongoLog
Mongo


The MongoLog class

(PECL mongo >=1.2.3)

Giriş

Logging can be used to get detailed information about what the driver is doing. Logging is disabled by default, but this class allows you to activate specific levels of logging for various parts of the driver. Some examples:

<?php

// print every log message possible
MongoLog::setLevel(MongoLog::ALL); // all log levels
MongoLog::setModule(MongoLog::ALL); // all parts of the driver

// print significant events about replica set failover
MongoLog::setLevel(MongoLog::INFO);
MongoLog::setModule(MongoLog::RS);

// print info- and diagnostic-level events for replica sets and connections
MongoLog::setLevel(MongoLog::INFO|MongoLog::FINE);
MongoLog::setModule(MongoLog::RS|MongoLog::CON);

?>

Bilginize:

By default, MongoLog emits all log messages as PHP notices. Depending on the SAPI you use, messages may be sent to stderr (for CLI) or the web server's error log. If, after configuring MongoLog, log messages are not appearing as expected, ensure that the E_NOTICE bit is included in error_reporting and that display_errors is on.

Sınıf Sözdizimi

MongoLog {
/* Sabitler */
const int NONE = 0 ;
const int ALL = 31 ;
level constants {
const int WARNING = 1 ;
const int INFO = 2 ;
const int FINE = 4 ;
module constants {
const int RS = 1 ;
const int POOL = 1 ;
const int CON = 2 ;
const int IO = 4 ;
const int SERVER = 8 ;
const int PARSE = 16 ;
/* Fields */
private static int $callback ;
private static int $level ;
private static int $module ;
/* Yöntemler */
public static callable getCallback ( void )
public static int getLevel ( void )
public static int getModule ( void )
public static void setCallback ( callable $log_function )
public static void setLevel ( int $level )
public static void setModule ( int $module )
}

Öntanımlı Sabitler

MongoLog Constants

These constants can be used by both MongoLog::setLevel() and MongoLog::setModule().

MongoLog::NONE
Log nothing.
MongoLog::ALL
Log everything.

MongoLog Level Constants

These constants can be used by MongoLog::setLevel().

MongoLog::WARNING
Log events that are somewhat exceptional, but not quite worthy of an actual exception (e.g. recoverable connection errors).
MongoLog::INFO
Log events that may be of interest to administrators, but are not particularly noteworthy (e.g. option parsing, authentication steps).
MongoLog::FINE
Log most events that the driver performs (e.g. server selection, socket communication). Depending on the module being logged, this can be extremely noisy and is primarily useful for debugging.

MongoLog Module Constants

These constants can be used by MongoLog::setModule().

MongoLog::CON
Log connection activity. Creating new connections, authentication, pinging, timeouts, etc.
MongoLog::IO
Log traffic to/from the database. Unless your program is trivial, this will create an enormous number of log messages.
MongoLog::PARSE
Log parsing of the connection string and options when constructing MongoClient.
MongoLog::POOL
Previously used to log connection pool activity. This option is now a deprecated alias of MongoLog::RS.
MongoLog::RS
Log replica set activity. Failovers, read preference selection, etc.
MongoLog::SERVER
Previously used to log server status changes. This option is deprecated in favor of MongoLog::RS.

Sürüm Bilgisi

Sürüm: | Açıklama
1.3.0 | Added MongoLog::CON and deprecated MongoLog::POOL and MongoLog::SERVER.

İçindekiler

  • MongoLog::getCallback — Gets the previously set callback function
  • MongoLog::getLevel — Gets the level(s) currently being logged
  • MongoLog::getModule — Gets the module(s) currently being logged
  • MongoLog::setCallback — Sets a callback function to be invoked for events
  • MongoLog::setLevel — Sets the level(s) to be logged
  • MongoLog::setModule — Sets the module(s) to be logged
Miscellaneous
MongoLog::getCallback
Miscellaneous


Gets the previously set callback function

MongoLog
MongoLog::getLevel
MongoLog
PHP Manual

MongoLog::getCallback

(PECL mongo >= 1.3.0)

MongoLog::getCallback — Gets the previously set callback function

Açıklama

public static callable MongoLog::getCallback ( void )

Retrieves the callback function.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the callback function, or FALSE if not set yet.

Notlar

Dikkat

This function is only available with PHP 5.3.0 and later.

MongoLog
MongoLog::getLevel
MongoLog


Gets the level(s) currently being logged

MongoLog::getCallback
MongoLog::getModule
MongoLog
PHP Manual

MongoLog::getLevel

(PECL mongo >= 1.2.3)

MongoLog::getLevel — Gets the level(s) currently being logged

Açıklama

public static int MongoLog::getLevel ( void )

This function can be used to see which log levels are currently enabled. The returned integer may be compared with the MongoLog level constants using bitwise operators to check for specific log levels.

<?php

if (MongoLog::getLevel() & MongoLog::FINE) {
    echo "lots of logs\n";
}

if (MongoLog::getLevel() ^ MongoLog::NONE) {
    echo "logging, at least a little\n";
}

if (MongoLog::getLevel() == MongoLog::ALL) {
    echo "logging at the highest levels\n";
}

?>

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the level(s) currently being logged.

MongoLog::getCallback
MongoLog::getModule
MongoLog


Gets the module(s) currently being logged

MongoLog::getLevel
MongoLog::setCallback
MongoLog
PHP Manual

MongoLog::getModule

(PECL mongo >= 1.2.3)

MongoLog::getModule — Gets the module(s) currently being logged

Açıklama

public static int MongoLog::getModule ( void )

This function can be used to see which driver modules are currently being logged. The returned integer may be compared with the MongoLog module constants using bitwise operators to check if specific modules are being logged.

<?php

if (MongoLog::getModule() & MongoLog::RS) {
    echo "logging replica sets\n";
}

if (MongoLog::getModule() ^ MongoLog::NONE) {
    echo "logging something\n";
}

if ((MongoLog::getModule() & MongoLog::IO) == 0) {
    echo "not logging io\n";
}

?>

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the module(s) currently being logged.

MongoLog::getLevel
MongoLog::setCallback
MongoLog


Sets a callback function to be invoked for events

MongoLog::getModule
MongoLog::setLevel
MongoLog
PHP Manual

MongoLog::setCallback

(PECL mongo >= 1.3.0)

MongoLog::setCallback — Sets a callback function to be invoked for events

Açıklama

public static void MongoLog::setCallback ( callable $log_function )

This function will set a callback function to be invoked for events in lieu of emitting of PHP notice.

Değiştirgeler

log_function

The callback function to be invoked on events. It should have the following prototype:

log_function ( int $module , int $level , string $message )
module
One of the MongoLog module constants.
level
One of the MongoLog level constants.
message
The log message itself.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 MongoLog::setCallback() example

<?php

function module2string($module)
{
    switch ($module) {
        case MongoLog::RS: return "REPLSET";
        case MongoLog::CON: return "CON";
        case MongoLog::IO: return "IO";
        case MongoLog::SERVER: return "SERVER";
        case MongoLog::PARSE: return "PARSE";
        default: return "UNKNOWN";
    }
}

function level2string($level)
{
    switch ($level) {
        case MongoLog::WARNING: return "WARN";
        case MongoLog::INFO: return "INFO";
        case MongoLog::FINE: return "FINE";
        default: return "UNKNOWN";
    }
}

function callback($module, $level, $message)
{
    echo date("Y-m-d H:i:s - ");
    printf("%s (%s): %s\n", module2string($module), level2string($level), $message);
}

MongoLog::setLevel(MongoLog::ALL);
MongoLog::setModule(MongoLog::ALL);

// We specify the function name here, but any callable (e.g. anonymous function) will work
MongoLog::setCallback("callback");

new MongoClient();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

2013-07-09 09:41:42 - PARSE (INFO): Parsing localhost:27017
2013-07-09 09:41:42 - PARSE (INFO): - Found node: localhost:27017
2013-07-09 09:41:42 - PARSE (INFO): - Connection type: STANDALONE
2013-07-09 09:41:42 - CON (INFO): mongo_get_read_write_connection: finding a STANDALONE connection
2013-07-09 09:41:42 - CON (INFO): connection_create: creating new connection for localhost:27017
2013-07-09 09:41:42 - CON (INFO): stream_connect: Not establishing SSL for localhost:27017
2013-07-09 09:41:42 - CON (INFO): get_server_flags: start
2013-07-09 09:41:42 - CON (FINE): send_packet: read from header: 36
2013-07-09 09:41:42 - CON (FINE): send_packet: data_size: 95
2013-07-09 09:41:42 - CON (FINE): get_server_flags: setting maxBsonObjectSize to 16777216
2013-07-09 09:41:42 - CON (FINE): get_server_flags: setting maxMessageSizeBytes to 48000000
2013-07-09 09:41:42 - CON (INFO): is_ping: pinging localhost:27017;-;.;1543
2013-07-09 09:41:42 - CON (FINE): send_packet: read from header: 36
2013-07-09 09:41:42 - CON (FINE): send_packet: data_size: 17
2013-07-09 09:41:42 - CON (INFO): is_ping: last pinged at 1373359302; time: 0ms
2013-07-09 09:41:42 - REPLSET (FINE): finding candidate servers
2013-07-09 09:41:42 - REPLSET (FINE): - all servers
2013-07-09 09:41:42 - REPLSET (FINE): filter_connections: adding connections:
2013-07-09 09:41:42 - REPLSET (FINE): - connection: type: STANDALONE, socket: 42, ping: 0, hash: localhost:27017;-;.;1543
2013-07-09 09:41:42 - REPLSET (FINE): filter_connections: done
2013-07-09 09:41:42 - REPLSET (FINE): limiting by seeded/discovered servers
2013-07-09 09:41:42 - REPLSET (FINE): - connection: type: STANDALONE, socket: 42, ping: 0, hash: localhost:27017;-;.;1543
2013-07-09 09:41:42 - REPLSET (FINE): limiting by seeded/discovered servers: done
2013-07-09 09:41:42 - REPLSET (FINE): limiting by credentials
2013-07-09 09:41:42 - REPLSET (FINE): - connection: type: STANDALONE, socket: 42, ping: 0, hash: localhost:27017;-;.;1543
2013-07-09 09:41:42 - REPLSET (FINE): limiting by credentials: done
2013-07-09 09:41:42 - REPLSET (FINE): sorting servers by priority and ping time
2013-07-09 09:41:42 - REPLSET (FINE): - connection: type: STANDALONE, socket: 42, ping: 0, hash: localhost:27017;-;.;1543
2013-07-09 09:41:42 - REPLSET (FINE): sorting servers: done
2013-07-09 09:41:42 - REPLSET (FINE): selecting near servers
2013-07-09 09:41:42 - REPLSET (FINE): selecting near servers: nearest is 0ms
2013-07-09 09:41:42 - REPLSET (FINE): - connection: type: STANDALONE, socket: 42, ping: 0, hash: localhost:27017;-;.;1543
2013-07-09 09:41:42 - REPLSET (FINE): selecting near server: done
2013-07-09 09:41:42 - REPLSET (INFO): pick server: random element 0
2013-07-09 09:41:42 - REPLSET (INFO): - connection: type: STANDALONE, socket: 42, ping: 0, hash: localhost:27017;-;.;1543

Notlar

Dikkat

This function is only available with PHP 5.3.0 and later.

MongoLog::getModule
MongoLog::setLevel
MongoLog


Sets the level(s) to be logged

MongoLog::setCallback
MongoLog::setModule
MongoLog
PHP Manual

MongoLog::setLevel

(PECL mongo >= 1.2.3)

MongoLog::setLevel — Sets the level(s) to be logged

Açıklama

public static void MongoLog::setLevel ( int $level )

This function can be used to control logging verbosity and the types of activities that should be logged. The MongoLog level constants may be used with bitwise operators to specify multiple levels.

<?php

// first, specify a logging module
MongoLog::setModule(MongoLog::CON);

// log messages for every level
MongoLog::setLevel(MongoLog::ALL);

// log warning and info messages only
MongoLog::setLevel(MongoLog::WARNING|MongoLog::INFO);

// log everything except fine activity
MongoLog::setLevel(MongoLog::ALL & (~MongoLog::FINE));

?>

Note that you must also call MongoLog::setModule() to specify which modules(s) of the driver should log.

Değiştirgeler

level

The level(s) you would like to log.

MongoLog::setCallback
MongoLog::setModule
MongoLog


Sets the module(s) to be logged

MongoLog::setLevel
MongoPool
MongoLog
PHP Manual

MongoLog::setModule

(PECL mongo >= 1.2.3)

MongoLog::setModule — Sets the module(s) to be logged

Açıklama

public static void MongoLog::setModule ( int $module )

This function can be used to set which driver modules should be logged. The MongoLog module constants may be used with bitwise operators to specify multiple modules.

<?php

// first, specify a logging level
MongoLog::setLevel(MongoLog::ALL);

// log replica set activity
MongoLog::setModule(MongoLog::RS);

// log replica sets and connection activity
MongoLog::setModule(MongoLog::RS|MongoLog::CON);

// log everything except IO activity
MongoLog::setModule(MongoLog::ALL & (~MongoLog::IO));

?>

Note that you must also call MongoLog::setLevel() to enable logging.

Değiştirgeler

module

The module(s) you would like to log.

MongoLog::setLevel
MongoPool
MongoLog


The MongoPool class

(PECL mongo >= 1.2.3)

Giriş

Uyarı

The current (1.3.0+) releases of the driver no longer implements pooling. This class and its methods are therefore deprecated and should not be used.

Sınıf Sözdizimi

MongoPool {
/* Yöntemler */
public static int getSize ( void )
public array info ( void )
public static bool setSize ( int $size )
}

Sürüm Bilgisi

Sürüm: | Açıklama
1.3.0 | This functionality has been removed and no longer does anything other than emit deprecation warnings. This class is only kept around for backwards compatability and will be removed in the near future.
1.2.11 | Emits E_DEPRECATED when used.

İçindekiler

  • MongoPool::getSize — Get pool size for connection pools
  • MongoPool::info — Returns information about all connection pools.
  • MongoPool::setSize — Set the size for future connection pools.
MongoLog::setModule
MongoPool::getSize
Miscellaneous


Get pool size for connection pools

MongoPool
MongoPool::info
MongoPool
PHP Manual

MongoPool::getSize

(PECL mongo >= 1.2.3)

MongoPool::getSize — Get pool size for connection pools

Açıklama

public static int MongoPool::getSize ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the current pool size.

Sürüm Bilgisi

Sürüm: | Açıklama
1.2.11 | Emits E_DEPRECATED when used.

Örnekler

Örnek 1 Changing pool size

This returns the default pool size, sets a new pool size, then prints the new pool size and the pool debugging information. Note that changing the pool size only affects new connection pools, it does not change old ones.

<?php

$connection = new Mongo("host1");

// pool size is -1
echo "pool size is: ".MongoPool::getSize()."\n";

echo "setting pool size to 200\n";

MongoPool::setSize(200);

// pool size is 200
echo "pool size is: ".MongoPool::getSize()."\n";

$conn2 = new Mongo("host2");

// remaining for host1 is -2
// remaining for host2 is 199
var_dump(Mongo::poolDebug());

?>

Ayrıca Bakınız

  • MongoPool::setSize() - Set the size for future connection pools.
  • MongoPool::info() - Returns information about all connection pools.
  • The connection documentation.

MongoPool
MongoPool::info
MongoPool


Returns information about all connection pools.

MongoPool::getSize
MongoPool::setSize
MongoPool
PHP Manual

MongoPool::info

(PECL mongo >= 1.2.3)

MongoPool::info — Returns information about all connection pools.

Açıklama

public array MongoPool::info ( void )

Returns an array of information about all connection pools.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Each connection pool has an identifier, which starts with the host. For each pool, this function shows the following fields:

in use

The number of connections currently being used by Mongo instances.

in pool

The number of connections currently in the pool (not being used).

remaining

The number of connections that could be created by this pool. For example, suppose a pool had 5 connections remaining and 3 connections in the pool. We could create 8 new instances of MongoClient before we exhausted this pool (assuming no instances of MongoClient went out of scope, returning their connections to the pool).

A negative number means that this pool will spawn unlimited connections.

Before a pool is created, you can change the max number of connections by calling Mongo::setPoolSize(). Once a pool is showing up in the output of this function, its size cannot be changed.

total

The total number of connections allowed for this pool. This should be greater than or equal to "in use" + "in pool" (or -1).

timeout

The socket timeout for connections in this pool. This is how long connections in this pool will attempt to connect to a server before giving up.

waiting

If you have capped the pool size, workers requesting connections from the pool may block until other workers return their connections. This field shows how many milliseconds workers have blocked for connections to be released. If this number keeps increasing, you may want to use MongoPool::setSize() to add more connections to your pool.

Sürüm Bilgisi

Sürüm: | Açıklama
1.2.11 | Emits E_DEPRECATED when used.

MongoPool::getSize
MongoPool::setSize
MongoPool


Set the size for future connection pools.

MongoPool::info
Mongo
MongoPool
PHP Manual

MongoPool::setSize

(PECL mongo >= 1.2.3)

MongoPool::setSize — Set the size for future connection pools.

Açıklama

public static bool MongoPool::setSize ( int $size )

Sets the max number of connections new pools will be able to create.

Değiştirgeler

size

The max number of connections future pools will be able to create. Negative numbers mean that the pool will spawn an infinite number of connections.

Dönen Değerler

Returns the former value of pool size.

Sürüm Bilgisi

Sürüm: | Açıklama
1.2.11 | Emits E_DEPRECATED when used.

Örnekler

Örnek 1 Mongo::setPoolSize() example

If you set the pool size to n and then create n connections, attempting to create an n+1st connection will throw a MongoConnectionException.

<?php

// only allow one connection to a server
MongoPool::setSize(1);

// creates one connection to localhost:27017
$m1 = new Mongo();

// attempt to create a second connection to localhost:27017
// only one connection is allowed, so this will throw an exception
$m2 = new Mongo();

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Fatal error: Uncaught exception 'MongoConnectionException' with message 'no more connections in pool' in /path/to/php/script.php:10
Stack trace:
#0 /path/to/php/script.php(10): Mongo->__construct()
#1 {main}
  thrown in /path/to/php/script.php on line 10

Ayrıca Bakınız

  • MongoPool::getSize() - Get pool size for connection pools
  • MongoPool::info() - Returns information about all connection pools.
  • The connection documentation.

MongoPool::info
Mongo
MongoPool


The Mongo class [deprecated]

(PECL mongo >=0.9.0)

Giriş

A connection between PHP and MongoDB.

This class extends MongoClient and provides access to several deprecated methods.

For backwards compatibility, it also defaults the "w" option of its constructor argument to 0, which does not require write operations to be acknowledged by the server. See MongoClient::__construct() for more information.

Uyarı

This class has been DEPRECATED as of version 1.3.0. Relying on this feature is highly discouraged. Please use MongoClient instead.

Sınıf Sözdizimi

Mongo extends MongoClient {
/* Yöntemler */
protected bool connectUtil ( void )
public static int getPoolSize ( void )
public string getSlave ( void )
public bool getSlaveOkay ( void )
public array poolDebug ( void )
public static bool setPoolSize ( int $size )
public bool setSlaveOkay ([ bool $ok = true ] )
public string switchSlave ( void )
/* Miras alınan yöntemler */
public bool MongoClient::close ([ boolean|string $connection ] )
public bool MongoClient::connect ( void )
public array MongoClient::dropDB ( mixed $db )
public MongoDB MongoClient::__get ( string $dbname )
public static array MongoClient::getConnections ( void )
public array MongoClient::getHosts ( void )
public array MongoClient::getReadPreference ( void )
public array MongoClient::getWriteConcern ( void )
public bool MongoClient::killCursor ( string $server_hash , int|MongoInt64 $id )
public array MongoClient::listDBs ( void )
public MongoCollection MongoClient::selectCollection ( string $db , string $collection )
public MongoDB MongoClient::selectDB ( string $name )
public bool MongoClient::setReadPreference ( string $read_preference [, array $tags ] )
public bool MongoClient::setWriteConcern ( mixed $w [, int $wtimeout ] )
public string MongoClient::__toString ( void )
}

İçindekiler

  • Mongo::connectUtil — Connects with a database server
  • Mongo::__construct — The __construct purpose
  • Mongo::getPoolSize — Get pool size for connection pools
  • Mongo::getSlave — Returns the address being used by this for slaveOkay reads
  • Mongo::getSlaveOkay — Get slaveOkay setting for this connection
  • Mongo::poolDebug — Returns information about all connection pools.
  • Mongo::setPoolSize — Set the size for future connection pools.
  • Mongo::setSlaveOkay — Change slaveOkay setting for this connection
  • Mongo::switchSlave — Choose a new secondary for slaveOkay reads
MongoPool::setSize
Mongo::connectUtil
Miscellaneous


Connects with a database server

Mongo
Mongo::__construct
Mongo
PHP Manual

Mongo::connectUtil

(PECL mongo >=0.9.0)

Mongo::connectUtil — Connects with a database server

Açıklama

protected bool Mongo::connectUtil ( void )
Uyarı

This is an internal function that you should never call yourself.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

If the connection was successful.

Hatalar/İstisnalar

Throws MongoConnectionException if it fails to connect to the databases.

Mongo
Mongo::__construct
Mongo


The __construct purpose

Mongo::connectUtil
Mongo::getPoolSize
Mongo
PHP Manual

Mongo::__construct

(PECL mongo >=0.9.0)

Mongo::__construct — The __construct purpose

Açıklama

public Mongo::__construct ([ string $server [, array $options ]] )

This method overwrites the MongoClient constructor and turns off acknowledged writes.

Please see MongoClient::__construct() for description of the parameters.

Dönen Değerler

Uyarı

Instanciating this class will emit E_DEPRECATED warning, and turn off acknowledged writes.

Please use the MongoClient instead.

Mongo::connectUtil
Mongo::getPoolSize
Mongo


Get pool size for connection pools

Mongo::__construct
Mongo::getSlave
Mongo
PHP Manual

Mongo::getPoolSize

(PECL mongo >=1.2.0)

Mongo::getPoolSize — Get pool size for connection pools

Açıklama

public static int Mongo::getPoolSize ( void )
Uyarı

This feature has been DEPRECATED as of version 1.2.3. Relying on this feature is highly discouraged. Please use MongoPool::getSize() instead.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the current pool size.

Sürüm Bilgisi

Sürüm: | Açıklama
1.2.11 | Emits E_DEPRECATED when used.

Örnekler

Örnek 1 Changing pool size

This returns the default pool size, sets a new pool size, then prints the new pool size and the pool debugging information. Note that changing the pool size only affects new connection pools, it does not change old ones.

<?php

$connection = new Mongo("host1");

// pool size is -1
echo "pool size is: ".Mongo::getPoolSize()."\n";

echo "setting pool size to 200\n";

Mongo::setPoolSize(200);

// pool size is 200
echo "pool size is: ".Mongo::getPoolSize()."\n";

$conn2 = new Mongo("host2");

// remaining for host1 is -2
// remaining for host2 is 199
var_dump(Mongo::poolDebug());

?>

Ayrıca Bakınız

  • Mongo::setPoolSize() - Set the size for future connection pools.
  • Mongo::poolDebug() - Returns information about all connection pools.
  • The connection documentation.

Mongo::__construct
Mongo::getSlave
Mongo


Returns the address being used by this for slaveOkay reads

Mongo::getPoolSize
Mongo::getSlaveOkay
Mongo
PHP Manual

Mongo::getSlave

(PECL mongo >=1.1.0)

Mongo::getSlave — Returns the address being used by this for slaveOkay reads

Açıklama

public string Mongo::getSlave ( void )

This finds the address of the secondary currently being used for reads. It is a read-only method: it does not change anything about the internal state of the object.

When you create a connection to the database, the driver will not immediately decide on a secondary to use. Thus, after you connect, this function will return NULL even if there are secondaries available. When you first do a query with slaveOkay set, at that point the driver will choose a secondary for this connection. At that point, this function will return the chosen secondary.

See the query section of this manual for information on distributing reads to secondaries.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The address of the secondary this connection is using for reads.

This returns NULL if this is not connected to a replica set or not yet initialized.

Hatalar/İstisnalar

Issues E_DEPRECATED warning

The returned results aren't really useful as the secondary selection process is done on each query and database command execution.

Sürüm Bilgisi

Sürüm: | Açıklama
1.2.11 | Emits E_DEPRECATED when used.

Ayrıca Bakınız

  • MongoCursor::info() - Gets information about the cursor's creation and iteration
Mongo::getPoolSize
Mongo::getSlaveOkay
Mongo


Get slaveOkay setting for this connection

Mongo::getSlave
Mongo::poolDebug
Mongo
PHP Manual

Mongo::getSlaveOkay

(PECL mongo >=1.1.0)

Mongo::getSlaveOkay — Get slaveOkay setting for this connection

Açıklama

public bool Mongo::getSlaveOkay ( void )

See the query section of this manual for information on distributing reads to secondaries.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the value of slaveOkay for this instance.

Hatalar/İstisnalar

Issues E_DEPRECATED warning

Sürüm Bilgisi

Sürüm: | Açıklama
1.2.11 | Emits E_DEPRECATED when used.

Ayrıca Bakınız

  • Read Preferences
  • MongoClient::getReadPreference() - Get the read preference for this connection
Mongo::getSlave
Mongo::poolDebug
Mongo


Returns information about all connection pools.

Mongo::getSlaveOkay
Mongo::setPoolSize
Mongo
PHP Manual

Mongo::poolDebug

(PECL mongo >=1.2.0)

Mongo::poolDebug — Returns information about all connection pools.

Açıklama

public array Mongo::poolDebug ( void )
Uyarı

This feature has been DEPRECATED as of version 1.2.3. Relying on this feature is highly discouraged. Please use MongoPool::info() instead.

Returns an array of information about all connection pools.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Each connection pool has an identifier, which starts with the host. For each pool, this function shows the following fields:

in use

The number of connections currently being used by MongoClient instances.

in pool

The number of connections currently in the pool (not being used).

remaining

The number of connections that could be created by this pool. For example, suppose a pool had 5 connections remaining and 3 connections in the pool. We could create 8 new instances of MongoClient before we exhausted this pool (assuming no instances of MongoClient went out of scope, returning their connections to the pool).

A negative number means that this pool will spawn unlimited connections.

Before a pool is created, you can change the max number of connections by calling Mongo::setPoolSize(). Once a pool is showing up in the output of this function, its size cannot be changed.

timeout

The socket timeout for connections in this pool. This is how long connections in this pool will attempt to connect to a server before giving up.

Sürüm Bilgisi

Sürüm: | Açıklama
1.2.11 | Emits E_DEPRECATED when used.

Mongo::getSlaveOkay
Mongo::setPoolSize
Mongo


Set the size for future connection pools.

Mongo::poolDebug
Mongo::setSlaveOkay
Mongo
PHP Manual

Mongo::setPoolSize

(PECL mongo >=1.2.0)

Mongo::setPoolSize — Set the size for future connection pools.

Açıklama

public static bool Mongo::setPoolSize ( int $size )
Uyarı

This method has been DEPRECATED as of version 1.2.3. Relying on this feature is highly discouraged. Please use MongoPool::setSize() instead.

Sets the max number of connections new pools will be able to create.

Değiştirgeler

size

The max number of connections future pools will be able to create. Negative numbers mean that the pool will spawn an infinite number of connections.

Dönen Değerler

Returns the former value of pool size.

Örnekler

Örnek 1 Mongo::setPoolSize() example

If you set the pool size to n and then create n connections, attempting to create an n+1st connection will throw a MongoConnectionException.

<?php

// only allow one connection to a server
Mongo::setPoolSize(1);

// creates one connection to localhost:27017
$m1 = new Mongo();

// attempt to create a second connection to localhost:27017
// only one connection is allowed, so this will throw an exception
$m2 = new Mongo();

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Fatal error: Uncaught exception 'MongoConnectionException' with message 'no more connections in pool' in /path/to/php/script.php:10
Stack trace:
#0 /path/to/php/script.php(10): Mongo->__construct()
#1 {main}
  thrown in /path/to/php/script.php on line 10

Ayrıca Bakınız

  • Mongo::getPoolSize() - Get pool size for connection pools
  • Mongo::poolDebug() - Returns information about all connection pools.
  • The connection documentation.

Mongo::poolDebug
Mongo::setSlaveOkay
Mongo


Change slaveOkay setting for this connection

Mongo::setPoolSize
Mongo::switchSlave
Mongo
PHP Manual

Mongo::setSlaveOkay

(PECL mongo >=1.1.0)

Mongo::setSlaveOkay — Change slaveOkay setting for this connection

Açıklama

public bool Mongo::setSlaveOkay ([ bool $ok = true ] )

See the query section of this manual for information on distributing reads to secondaries.

Değiştirgeler

ok

If reads should be sent to secondary members of a replica set for all possible queries using this MongoClient instance.

Dönen Değerler

Returns the former value of slaveOkay for this instance.

Sürüm Bilgisi

Sürüm: | Açıklama
1.2.11 | Emits E_DEPRECATED when used.

Ayrıca Bakınız

  • Read Preferences
  • MongoClient::setReadPreference() - Set the read preference for this connection
Mongo::setPoolSize
Mongo::switchSlave
Mongo


Choose a new secondary for slaveOkay reads

Mongo::setSlaveOkay
Mongo İşlevleri
Mongo
PHP Manual

Mongo::switchSlave

(PECL mongo >=1.1.0)

Mongo::switchSlave — Choose a new secondary for slaveOkay reads

Açıklama

public string Mongo::switchSlave ( void )

This choses a random secondary for a connection to read from. It is called automatically by the driver and should not need to be used. It calls MongoClient::getHosts() (to refresh the status of hosts) and Mongo::getSlave() (to get the return value).

See the query section of this manual for information on distributing reads to secondaries.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The address of the secondary this connection is using for reads. This may be the same as the previous address as addresses are randomly chosen. It may return only one address if only one secondary (or only the primary) is available.

For example, if we had a three member replica set with a primary, secondary, and arbiter this method would always return the address of the secondary. If the secondary became unavailable, this method would always return the address of the primary. If the primary also became unavailable, this method would throw an exception, as an arbiter cannot handle reads.

Hatalar/İstisnalar

Throws a MongoException (error code 15) if it is called on a non-replica-set connection. It will also throw MongoExceptions if it cannot find anyone (primary or secondary) to read from (error code 16).

Sürüm Bilgisi

Sürüm: | Açıklama
1.2.11 | Emits E_DEPRECATED when used.

Ayrıca Bakınız

  • Read Preferences
Mongo::setSlaveOkay
Mongo İşlevleri
Mongo


Mongo İşlevleri

İçindekiler

  • bson_decode — Deserializes a BSON object into a PHP array
  • bson_encode — Serializes a PHP variable into a BSON string
Mongo::switchSlave
bson_decode
Mongo


Deserializes a BSON object into a PHP array

Mongo İşlevleri
bson_encode
Mongo İşlevleri
PHP Manual

bson_decode

(PECL mongo >=1.0.1)

bson_decode — Deserializes a BSON object into a PHP array

Açıklama

array bson_decode ( string $bson )

This function is very beta and entirely useless for 99% of users. It is only useful if you're doing something weird, such as writing your own driver on top of the PHP driver.

Değiştirgeler

bson

The BSON to be deserialized.

Dönen Değerler

Returns the deserialized BSON object.

Mongo İşlevleri
bson_encode
Mongo İşlevleri


Serializes a PHP variable into a BSON string

bson_decode
Exceptions
Mongo İşlevleri
PHP Manual

bson_encode

(PECL mongo >=1.0.1)

bson_encode — Serializes a PHP variable into a BSON string

Açıklama

string bson_encode ( mixed $anything )

This function is very beta and entirely useless for 99% of users. It is only useful if you're doing something weird, such as writing your own driver on top of the PHP driver.

Değiştirgeler

anything

The variable to be serialized.

Dönen Değerler

Returns the serialized string.

bson_decode
Exceptions
Mongo İşlevleri


Exceptions

İçindekiler

  • MongoException
  • MongoResultException
  • MongoCursorException
  • MongoCursorTimeoutException
  • MongoConnectionException
  • MongoGridFSException
  • MongoDuplicateKeyException
  • MongoProtocolException
  • MongoExecutionTimeoutException
  • MongoWriteConcernException

VMWare Oddities

If you are running VMWare on Windows and are using CIFS, pausing the VM will cause CIFS to go out of sync and cause weird errors on un-pausing it ("The Mongo object has not been correctly initialized by its constructor"). Permanently mounting the Windows shares will fix this and you'll be able to pause and unpause at will.

To permanently mount the Windows shares, run:

$ sudo update-rc.d -f umountnfs.sh remove
$ sudo update-rc.d umountnfs.sh stop 15 0 6 .

See » the Ubuntu docs for the most up-to-date instructions.

bson_encode
MongoException
Mongo


The MongoException class

(PECL mongo >= 1.0.0)

Giriş

Default Mongo exception.

This covers a bunch of different error conditions that may eventually be moved to more specific exceptions, but will always extend MongoException.

  • The MongoSomething object has not been correctly initialized by its constructor

    Code: 0

    Probably your Mongo object is not connected to a database server.

  • zero-length keys are not allowed, did you use $ with double quotes?

    Code: 1

    You tried to save "" as a key. You generally should not do this. "" can mess up subobject access and is used by MongoDB internally. However, if you really want, you can set mongo.allow_empty_keys to true in your php.ini file to override this sanity check. If you override this, it is highly recommended that you set error checking to strict to avoid string interpolation errors.

  • '.' not allowed in key: <key>

    Code: 2

    You attempted to write a key with '.' in it, which is prohibited.

  • insert too large: <size>, max: <max>

    Code: 3

    You're attempting to send too much data to the database at once: the database will only accept inserts up to a certain size (currently 16 MB).

  • no elements in doc

    Code: 4

    You're attempting to save a document with no fields.

  • size of BSON doc is <size> bytes, max <max>MB

    Code: 5

    You're attempting to save a document that is larger than MongoDB can save.

  • no documents given

    Code: 6

    You're attempting to batch insert an empty array of documents.

  • MongoCollection::group takes an array, object, or MongoCode key

    Code: 7

    Wrong type parameter send to MongoCollection::group().

  • field names must be strings

    Code: 8

    You should format field selectors as array("field1" => 1, "field2" => 1, ..., "fieldN" => 1).

  • invalid regex

    Code: 9

    The regex passed to MongoRegex is not of the correct form.

  • MongoDBRef::get: $ref field must be a string

    Code: 10

  • MongoDBRef::get: $db field must be a string

    Code: 11

  • non-utf8 string: <str>

    Code: 12

    This error occurs if you attempt to send a non-utf8 string to the database. All strings going into the database should be UTF8. See php.ini options for the transition option of quieting this exception.

  • mutex error: <err>

    Code: 13

    The driver uses mutexes for synchronizing requests and responses in multithreaded environments. This is a fairly serious error and may not have a stack trace. It's unusual and should be reported to maintainers with any system information and steps to reproduce that you can provide.

  • index name too long: <len>, max <max> characters

    Code: 14

    Indexes with names longer than 128 characters cannot be created. If you get this error, you should use MongoCollection::ensureIndex()'s "name" option to create a shorter name for your index.

Sınıf Sözdizimi

MongoException extends Exception {
}
Exceptions
MongoResultException
Exceptions


The MongoResultException class

(PECL mongo >=1.3.0)

Giriş

The MongoResultException is thrown by several command helpers (such as MongoCollection::findAndModify()) in the event of failure. The original result document is available through MongoResultException::getDocument().

Sınıf Sözdizimi

MongoResultException extends MongoException {
/* Özellikler */
public $document ;
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Yöntemler */
public array getDocument ( void )
}

Özellikler

document

The raw result document as an array.

İçindekiler

  • MongoResultException::getDocument — Retrieve the full result document
MongoException
MongoResultException::getDocument
Exceptions


Retrieve the full result document

MongoResultException
MongoCursorException
MongoResultException
PHP Manual

MongoResultException::getDocument

(PECL mongo >=1.3.0)

MongoResultException::getDocument — Retrieve the full result document

Açıklama

public array MongoResultException::getDocument ( void )

Retrieves the full error result document.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The full result document as an array, including partial data if available and additional keys.

Örnekler

Örnek 1 MongoResultException::getDocument() example

<?php
$mc = new MongoClient("localhost");
$c = $mc->selectCollection("test", "test");

$c->insert(array(
     "name" => "Next promo",
     "inprogress" => false,
     "priority" => 0,
     "tasks" => array( "select product", "add inventory", "do placement"),
) );

$c->insert(array(
     "name" => "Biz report",
     "inprogress" => false,
     "priority" => 1,
     "tasks" => array( "run sales report", "email report" )
) );

$c->insert(array(
     "name" => "Biz report",
     "inprogress" => false,
     "priority" => 2,
     "tasks" => array( "run marketing report", "email report" )
    ),
    array("w" => true)
);

try {
    $retval = $c->findAndModify(
         array("inprogress" => false, "name" => "Biz report"),
         array('$set' => array('$set' => array('inprogress' => true, "started" => new MongoDate()))),
         null,
         array(
            "sort" => array("priority" => -1),
            "new" => true,
        )
    );
} catch(MongoResultException $e) {
    echo $e->getMessage(), "\n";
    $res = $e->getDocument();
    var_dump($res);
}
?>

The above examples will output something similar to:

$set is not valid for storage.
array(3) {
  ["lastErrorObject"]=>
  array(5) {
    ["connectionId"]=>
    int(6)
    ["err"]=>
    string(30) "$set is not valid for storage."
    ["code"]=>
    int(52)
    ["n"]=>
    int(0)
    ["ok"]=>
    float(1)
  }
  ["ok"]=>
  float(0)
  ["errmsg"]=>
  string(30) "$set is not valid for storage."
}
MongoResultException
MongoCursorException
MongoResultException


The MongoCursorException class

(PECL mongo >= 1.0.0)

Giriş

Caused by accessing a cursor incorrectly or a error receiving a reply. Note that this can be thrown by any database request that receives a reply, not just queries. Writes, commands, and any other operation that sends information to the database and waits for a response can throw a MongoCursorException. The only exception is new MongoClient() (creating a new connection), which will only throw MongoConnectionExceptions.

This returns a specific error message to help diagnose the problem and a numeric error code associated with the cause of the exception.

For example, suppose you tried to insert two documents with the same _id:

<?php

try {
    $collection->insert(array("_id" => 1), array("w" => 1));
    $collection->insert(array("_id" => 1), array("w" => 1));
}
catch (MongoCursorException $e) {
    echo "error message: ".$e->getMessage()."\n";
    echo "error code: ".$e->getCode()."\n";
}

?>
This would produce output like:
error message: E11000 duplicate key error index: foo.bar.$_id_  dup key: { : 1 }
error code: 11000
Note that the MongoDB error code (11000) is used for the PHP error code. The PHP driver uses the "native" error code wherever possible.

The following is a list of common errors, codes, and causes. Exact errors are in italics, errors where the message can vary are described in obliques.

  • cannot modify cursor after beginning iteration

    Code: 0

    You are calling a method that sets up the query after executing the query. Reset the cursor and try again.

    An example:

    <?php

    try {
            $cursor = $collection->find();
            var_dump($cursor->getNext());

            // getNext() queried the database, it's too late to set a limit
            $cursor->limit(1);
    }
    catch (    MongoCursorException $e) {
        echo     "error message: ".$e->getMessage()."\n";
        echo     "error code: ".$e->getCode()."\n";
    }

    // this will work, though:
    $cursor->getNext();
    $cursor->reset();
    $cursor->limit(1);

    ?>

  • Get next batch send errors

    Code: 1

    Could not send the query to the database. Make sure the database is still up and the network is okay.

  • cursor not found

    Code: 2

    The driver was trying to fetch more results from the database, but the database did not have a record of the query. This usually means that the cursor timed out on the server side: after a few minutes of inactivity, the database will kill a cursor (see MongoCursor::immortal() for information on preventing this).

    An example:

    <?php

    try {
            $cursor = $collection->find();
            $cursor->getNext();

            // sleep for 15 minutes
            sleep(60*15);

        while (    $cursor->hasNext()) {
                $cursor->getNext();
        }
    }
    catch (    MongoCursorException $e) {
        echo     "error message: ".$e->getMessage()."\n";
        echo     "error code: ".$e->getCode()."\n";
    }

    ?>

  • cursor->buf.pos is null

    Code: 3

    This may indicate you are out of RAM or some other extraordinary circumstance.

  • couldn't get response header

    Code: 4

    A common error if the database or network goes down. This means that the driver couldn't get a response from the connection.

  • no db response

    Code: 5

    This may not even be an error, for example, the database command "shutdown" returns no response. However, if you were expecting a response, this means the database didn't give one.

  • bad response length: %d, did the db assert?

    Code: 6

    This means that the database said that its response was less than 0. This error probably indicates a network error or database corruption.

  • incomplete header

    Code: 7

    Highly unusual. Occurs if the database response started out correctly, but broke off in the middle. Probably indicates a network problem.

  • incomplete response

    Code: 8

    Highly unusual. Occurs if the database response started out correctly, but broke off in the middle. Probably indicates a network problem.

  • couldn't find a response

    Code: 9

    If the response was cached and now cannot be located.

  • error getting socket

    Code: 10

    The socket was closed or encountered an error. The driver should automatically reconnect (if possible) on the next operation.

  • couldn't find reply, please try again

    Code: 11

    The driver saves any database responses it cannot immediately match with a request. This exception occurs if the driver has already passed your request's response and cannot find your response in its cache.

  • error getting database response: errstr

    WSA error getting database response: errstr

    "errstr" is an io error reported directly from the C socket subsystem. On Windows, the error message is prefixed with "WSA".

  • Timeout error

    Code: 13

    If there was an error while waiting for a query to complete.

  • couldn't send query: <various>

    Code: 14

    C socket error on send.

  • max number of retries exhausted, couldn't send query

    Code: 19

    The driver will automatically retry "plain" queries (not commands) a couple of times if the first attempt failed for certain reasons. This is to cause fewer exceptions during replica set failover (although you will probably still have to deal with some) and gloss over transient network issues.

    This can also be caused by the driver not being able to reconnect at all to the database (if, for example, the database is unreachable).

    Version 1.2.2+.

Errors passed through by the database

Database errors should always trigger MongoCursorExceptions on queries. Error messages and codes are sent directly from the database and you should be able to see matching errors in the database log.

A few common database errors are listed below:

  • E11000 duplicate key error index: foo.bar.$X dup key: { /* ... */ }

    Code: 11000

    Database error for duplicate keys.

  • not master

    Codes: 10107, 13435, and 10058

    Not master errors, piped through by the database. ach of these will cause the driver to disconnect and attempt to find a new primary. The actual error you get on failover may not be a "not master" error, depending on when the change in primary occurs.

Sınıf Sözdizimi

MongoCursorException extends MongoException {
}

İçindekiler

  • MongoCursorException::getHost — The hostname of the server that encountered the error
MongoResultException::getDocument
MongoCursorException::getHost
Exceptions


The hostname of the server that encountered the error

MongoCursorException
MongoCursorTimeoutException
MongoCursorException
PHP Manual

MongoCursorException::getHost

(PECL mongo >= 1.0.0)

MongoCursorException::getHost — The hostname of the server that encountered the error

Açıklama

public string MongoCursorException::getHost ( void )

Returns the hostname of the server the query was sent too.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the hostname, or NULL if the hostname is unknown.

MongoCursorException
MongoCursorTimeoutException
MongoCursorException


The MongoCursorTimeoutException class

(PECL mongo >= 1.0.0)

Giriş

Caused by a query timing out. You can set the length of time to wait before this exception is thrown by calling MongoCursor::timeout() on the cursor or setting MongoCursor::$timeout. The static variable is useful for queries such as database commands and MongoCollection::findOne(), both of which implicitly use cursors.

Sınıf Sözdizimi

MongoCursorTimeoutException extends MongoCursorException {
}
MongoCursorException::getHost
MongoConnectionException
Exceptions


The MongoConnectionException class

(PECL mongo >= 1.0.0)

Giriş

Thrown when the driver fails to connect to the database.

There are a number of possible error messages to help you diagnose the connection problem. These are:

  • No candidate servers found

    Thrown when the driver cannot establish a connection to MongoDB (fulfilling the ReadPreferences, if specified).

  • No server name given.

    This error occurs if you pass in "" as the server name, probably because of an typo with string interpolation, e.g., "$servr" instead of "$server".

  • failed to get host [hostname] or port [portnum] from [server].

    This indicated that the server string was malformed. "[hostname]" and "[portnum]" will be as much as the driver could dicipher of it.

  • Operation in progress

    Connecting to the database timed out.

  • Transport endpoint is not connected

    Generally means that the connection string isn't correct, the driver couldn't even find the database server.

  • couldn't determine master

    No server in a replica set connection was identified as the primary.

  • couldn't get host info for [server]

    This indicated that DNS could not resolve the server address you gave. This could easily be caused by a typo, for example, "server" instead of "$server".

  • Invalid Argument

    This can be caused by attempting to connect to a machine that is up but that the database isn't actually running on. Make sure that you've started the database server before connecting.

  • Permission denied

    This means that the socket could not be opened due to permissions issues. On Red Hat variants, this can be caused by a default setting that does not allow Apache to create network connections. You can override this setting by running:

    $ /usr/sbin/setsebool -P httpd_can_network_connect 1
    then restarting Apache.

If the error message is not listed above, it is probably an error from the C socket, and you can search the web for its usual cause.

Sınıf Sözdizimi

MongoConnectionException extends MongoException {
}
MongoCursorTimeoutException
MongoGridFSException
Exceptions


The MongoGridFSException class

(PECL mongo >= 1.0.0)

Giriş

Thrown when there are errors reading or writing files to or from the database.

Sınıf Sözdizimi

MongoGridFSException extends MongoException {
}

Error codes

MongoGridFSException error codes
Code | Message | Reason
3 | Could not open file $filename | Attempting to store an invalid file, such as directory
4 | File $filename is too large: $filesize bytes | Maximum filesize in GridFS is 4GB
5 | could not find filehandle | Resource doesn't have a filehandle
6 | no file is associate with this filehandle | Resource isn't a file resource
7 | error setting up file: $filenames | Could not open file for reading
9 | error reading file $filenames | Failed reading file
10 | error reading filehandle | Failed reading from a resource
11 | could not find uploaded file %s | Filename doesn't seem to be uploaded file
12 | Couldn't find tmp_name in the $_FILES array. Are you sure the upload worked? | Uploaded filename probably failed
13 | tmp_name was not a string or an array | Invalid filename given
14 | couldn't find file size | The length property is missing
15 | Cannot find filename | No filename provided, and no filename property set
16 | could not open destination file %s | Destination filename not writable
17 | error reading chunk of file | Chunk corruption
18 | couldn't create a php_stream | Couldn't create a stream resource
19 | couldn't find property | Chunk corruption
20 | chunk number has wrong size (size) when the max is maxchunksize | Chunk larger then expected
21 | chunk has wrong format | Chunk corruption

MongoConnectionException
MongoDuplicateKeyException
Exceptions


The MongoDuplicateKeyException class

(PECL mongo >= 1.5.0)

Giriş

Thrown when attempting to insert a document into a collection which already contains the same values for the unique keys.

Sınıf Sözdizimi

MongoDuplicateKeyException extends MongoWriteConcernException {
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Miras alınan yöntemler */
public array MongoWriteConcernException::getDocument ( void )
}

Örnekler

Örnek 1 Catching MongoDuplicateKeyException

<?php
$mc = new MongoClient("localhost");

$c = $mc->selectCollection("test", "test");

$c->insert(array('_id' => 1));
try {
    $c->insert(array('_id' => 1));
} catch (MongoWriteConcernException $e) {
    echo $e->getMessage(), "\n";
}
?>

The above examples will output something similar to:

localhost:27017: insertDocument :: caused by :: 11000 E11000 duplicate key error index: test.test.$_id_  dup key: { : 1 }
MongoGridFSException
MongoProtocolException
Exceptions


The MongoProtocolException class

(PECL mongo >= 1.5.0)

Giriş

When talking to MongoDB 2.6.0, and later, certain operations (such as writes) may throw MongoProtocolException when the response from the server did not make sense - for example during network failure (we could read the entire response) or data corruption.

This exception is also thrown when attempting to talk newer protocols then the server supports, for example using the MongoWriteBatch when talking to a MongoDB server prior to 2.6.0.

Sınıf Sözdizimi

MongoProtocolException extends MongoException {
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
}

Örnekler

Örnek 1 Catching MongoProtocolException

Running the following example against MongoDB prior to 2.6.0 will throw an MongoProtocolException

<?php
$mc = new MongoClient("localhost");
$c = $mc->selectCollection("test", "test");

try {
    $batch = new MongoInsertBatch($c);
} catch(MongoProtocolException $e) {
    echo $e->getMessage();
}
?>

The above examples will output something similar to:

Current primary does not have a Write API
MongoDuplicateKeyException
MongoExecutionTimeoutException
Exceptions


The MongoExecutionTimeoutException class

(PECL mongo >= 1.5.0)

Giriş

Thrown when a operation times out server side (i.e. in MongoDB).

To configure the operation timeout threshold, use MongoCursor::maxTimeMS() or the "maxTimeMS" command option.

Sınıf Sözdizimi

MongoExecutionTimeoutException extends MongoException {
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
}
MongoProtocolException
MongoWriteConcernException
Exceptions


The MongoWriteConcernException class

(PECL mongo >= 1.5.0)

Giriş

MongoWriteConcernException is thrown when a write fails. See Write Concerns for how to set failure thresholds.

Prior to MongoDB 2.6.0, the » getLastError command would determine whether a write failed.

Sınıf Sözdizimi

MongoWriteConcernException extends MongoCursorException {
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Yöntemler */
public array getDocument ( void )
/* Miras alınan yöntemler */
public string MongoCursorException::getHost ( void )
}

İçindekiler

  • MongoWriteConcernException::getDocument — Get the error document
MongoExecutionTimeoutException
MongoWriteConcernException::getDocument
Exceptions


Get the error document

MongoWriteConcernException
Changelog
MongoWriteConcernException
PHP Manual

MongoWriteConcernException::getDocument

(PECL mongo >= 1.5.0)

MongoWriteConcernException::getDocument — Get the error document

Açıklama

public array MongoWriteConcernException::getDocument ( void )

Returns the actual response from the server that was interperated as an error.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A MongoDB document, if available, as an array.

MongoWriteConcernException
Changelog
MongoWriteConcernException


Changelog

The following changes have been made to classes/functions/methods of this extension.

MongoDB PHP Driver 1.5.0

It supports all new features for MongoDB 2.6, including:

  • Aggregate can now return a cursor
  • Aggregation pipelines can now be explained
  • Possible to set maxTimeMS for commands and queries
  • Transparent support for the new command-based MongoDB write API
  • New MongoWriteBatch classes (using the new MongoDB write API)
  • Support for MongoDB Enterprise features (e.g. Kerberos, LDAP, X509)
  • Option to tune acceptable server latency for secondary reads (secondaryAcceptableLatencyMS)

With this release, some driver functionality which was previously documented as deprecated will now formally raise deprecation notices. This includes:

  • Instantiating the Mongo class
  • Calling MongoCursor::slaveOkay()
  • "wtimeout" and "safe" options for MongoCollection write operations
  • Manipulating public properties on core classes (such as $collection->w)

Bilginize:

No previously deprecated features have been removed.

Changes in behaviour:

  • Setting the mongo.native_long INI setting now raises an error on 32-bit platforms, and now defaults to true for 64-bit platforms.

MongoDB PHP Driver 1.4.0

The 1.4 series introduced fundemental changes in how connections are created to the MongoDB servers. The driver now utilizes PHP native streams, so all normal PHP stream options apply. Furthermore, an experimental Stream Context Support was added.

The 1.4.x series also added support for MongoDB 2.4.x.

The most important improvements however deal with the handling of replica sets, especially nodes that timeout and nodes that are unreachable for various reasons. Besides the improvements to replica set handling, this release addresses issues with read preferences through mongos nodes. It also adds support for SSL enabled connections as well as journal and fsync connection string options.

MongoDB PHP Driver 1.3.0

The 1.3 series introduced several major changes to the extension such as completely rewritten connection handling (and removal of the pooling mechanism), support for ReadPreferences and change the default WriteConcerns to be acknowledged by introducing a new class MongoClient which serves as a replacement class for the now deprecated Mongo class.

The driver now also supports connecting to multiple mongos instances (the Mongo Shard router) for loadbalancing.

Other enhancements include improved logging for easier connection handling debugging with MongoLog and support for the » Aggregation Framework via the MongoCollection::aggregate() method.

Changes to existing methods

Following is a list of all improvements to existing methods since their inception.

Version | Function | Description
1.7.0 | MongoDB::execute | This method has been deprecated as a result of the underlaying eval command being deprecated in MongoDB 3.0+.
1.6.0 | MongoCollection::count | The second parameter is now an options array. Passing limit and skip as the second and third parameters, respectively, is deprecated.
 | MongoDB::getCollectionNames | Changed first parameter to be an array of options. Pre-1.6.0, the first parameter was a boolean indicating the "includeSystemCollections" option.
 | MongoDB::listCollections | Changed first parameter to be an array of options. Pre-1.6.0, the first parameter was a boolean indicating the "includeSystemCollections" option.
1.5.0 | log_cmd_delete | Only available when connected to MongoDB 2.6.0+
 | log_cmd_insert | Only available when connected to MongoDB 2.6.0+
 | log_cmd_update | Only available when connected to MongoDB 2.6.0+
 | log_write_batch | Only available when connected to MongoDB 2.6.0+
 | MongoBinData::__construct | The default changed from 2 (MongoBinData::BYTE_ARRAY) to 0 (MongoBinData::GENERIC).
 | MongoClient::__construct | Added "authSource".
 | MongoClient::__construct | Added "authMechanism", "gssapiServiceName", and "secondaryAcceptableLatencyMS".
 | MongoCollection::aggregate | Added optional options argument
 | MongoCollection::batchInsert | Added the "wTimeoutMS" option, which replaces "wtimeout". Emits E_DEPRECATED when "wtimeout" is used. Added the "socketTimeoutMS" option, which replaces "timeout". Emits E_DEPRECATED when "timeout" is used. Emits E_DEPRECATED when "safe" is used.
 | MongoCollection::ensureIndex | Renamed the "wtimeout" option to "wTimeoutMS". Emits E_DEPRECATED when "wtimeout" is used. Renamed the "timeout" option to "socketTimeoutMS". Emits E_DEPRECATED when "timeout" is used. Emits E_DEPRECATED when "safe" is used.
 | MongoCollection::findOne | Added optional options argument.
 | MongoCollection::group | Added "maxTimeMS" option.
 | MongoCollection::insert | Added the "wTimeoutMS" option, which replaces "wtimeout". Emits E_DEPRECATED when "wtimeout" is used. Added the "socketTimeoutMS" option, which replaces "timeout". Emits E_DEPRECATED when "timeout" is used. Emits E_DEPRECATED when "safe" is used.
 | MongoCollection::remove | Added "wTimeoutMS" option, which replaces "wtimeout". Emits E_DEPRECATED when "wtimeout" is used. Added "socketTimeoutMS" option, which replaces "timeout". Emits E_DEPRECATED when "timeout" is used. Emits E_DEPRECATED when "safe" is used.
 | MongoCollection::save | Added "wTimeoutMS" option, which replaces "wtimeout". Emits E_DEPRECATED when "wtimeout" is used. Added "socketTimeoutMS" option, which replaces "timeout". Emits E_DEPRECATED when "timeout" is used. Emits E_DEPRECATED when "safe" is used.
 | MongoCollection::toIndexString | This method has been deprecated.
 | MongoCollection::update | Added the "wTimeoutMS" option, which replaces "wtimeout". Emits E_DEPRECATED when "wtimeout" is used. Added the "socketTimeoutMS" option, which replaces "timeout". Emits E_DEPRECATED when "timeout" is used. Emits E_DEPRECATED when "safe" is used.
 | MongoCursor::slaveOkay | This method has been deprecated in favour of MongoCursor::setReadPreference and .
 | MongoDB::command | Renamed the "timeout" option to "socketTimeoutMS". Emits E_DEPRECATED when "timeout" is used. Added hash by-reference parameter.
1.4.5 | MongoCursor::batchSize | Before 1.4.5, this method would throw an MongoCursorException if the cursor had already started iterating.
1.4.0 | MongoClient::__construct | Added "ssl" option and support for connecting over SSL. Added "wTimeoutMS" option, which replaces "wTimeout". Emits E_DEPRECATED when "slaveOkay" or "timeout" is used.
 | MongoCursor::hint | The index argument now supports index names as string values. In versions before 1.4.0, only array or object values were accepted.
 | MongoCursor::setFlag | Support for flag 3 (OPLOG_REPLAY) is added. Versions before 1.4.0 would throw a warning saying that the flag is unsupported.
 | MongoDB::createCollection | In versions before 1.4.0, the options were all arguments to the method. The function synopsis in those older versions is: public MongoCollectionMongoDB::createCollection stringname boolcappedFALSE intsize0 intmax0 The meaning of the options is the same as described under the options argument above.
 | MongoId::__construct | An exception is thrown when passed invalid string
1.3.4 | MongoClient::__construct | Added "connectTimeoutMS" and "socketTimeoutMS" options.
 | MongoCollection::batchInsert | Added "wtimeout" option.
 | MongoCollection::ensureIndex | Added "wtimeout" option.
 | MongoCollection::insert | Added "wtimeout" option.
 | MongoCollection::remove | Added "wtimeout" option.
 | MongoCollection::update | Added "wtimeout" option.
1.3.3 | MongoClient::getReadPreference | The return value has changed to be consistent with MongoClient::setReadPreference. The type value was changed from a number to a string, type_string was removed, and tagsets now expresses tags as key/value pairs instead of colon-delimited strings.
 | MongoCollection::getReadPreference | The return value has changed to be consistent with MongoCollection::setReadPreference. The type value was changed from a number to a string, type_string was removed, and tagsets now expresses tags as key/value pairs instead of colon-delimited strings.
 | MongoDB::getReadPreference | The return value has changed to be consistent with MongoDB::setReadPreference. The type value was changed from a number to a string, type_string was removed, and tagsets now expresses tags as key/value pairs instead of colon-delimited strings.
1.3.0 | MongoClient::close | The connection parameter to this function was added in 1.3.0. Before that, only the write connection would be closed by this method.
 | MongoClient::__construct | Added "readPreference", "readPreferenceTags", "w", and "wTimeout" options.
 | MongoCollection::batchInsert | Added "w" option.
 | MongoCollection::ensureIndex | Added "w" option. The options parameter no longer accepts a boolean to signify a unique index. Instead, this now has to be done with array('unique' => true).
 | MongoCollection::insert | Added "w" option. The options parameter no longer accepts a boolean to signify an acknowledged write. Instead, this now has to be done with array('w' => 1) (the default behaviour of MongoClient).
 | MongoCollection::remove | Added "w" option. The options parameter no longer accepts a boolean to signify "justOne". Instead, this now has to be done with array('justOne' => true).
 | MongoCollection::update | Added "w" option. The options parameter no longer accepts a boolean to signify an upsert. Instead, this now has to be done with array('upsert' => true).
 | MongoDB::listCollections | Added the includeSystemCollections parameter.
 | MongoGridFSCursor::key | The document's _id is returned as a string value, since the key should be unique. Pre-1.3.0, filename was returned.
1.2.11 | Mongo::getPoolSize | Emits E_DEPRECATED when used.
 | Mongo::getSlave | Emits E_DEPRECATED when used.
 | Mongo::getSlaveOkay | Emits E_DEPRECATED when used.
 | Mongo::poolDebug | Emits E_DEPRECATED when used.
 | Mongo::setSlaveOkay | Emits E_DEPRECATED when used.
 | Mongo::switchSlave | Emits E_DEPRECATED when used.
 | MongoBinData::__construct | Emits E_DEPRECATED when the second argument is not used. The default value for type may change in the near future.
 | MongoCollection::ensureIndex | Emits E_DEPRECATED when options is scalar.
 | MongoCollection::getSlaveOkay | Emits E_DEPRECATED when used.
 | MongoCollection::group | Emits E_DEPRECATED when options is scalar.
 | MongoCollection::remove | Emits E_DEPRECATED when options is scalar.
 | MongoCollection::setSlaveOkay | Emits E_DEPRECATED when used.
 | MongoCollection::update | Emits E_DEPRECATED when options is scalar.
 | MongoCursor::doQuery | Emits E_DEPRECATED when used.
 | MongoDB::authenticate | Emits E_DEPRECATED when used. Please pass in the authentication details to the constructor.
 | MongoDB::forceError | Emits E_DEPRECATED when used.
 | MongoDB::getSlaveOkay | Emits E_DEPRECATED when used.
 | MongoDB::prevError | Emits E_DEPRECATED when used.
 | MongoDB::resetError | Emits E_DEPRECATED when used.
 | MongoDB::setSlaveOkay | Emits E_DEPRECATED when used.
 | MongoPool::getSize | Emits E_DEPRECATED when used.
 | MongoPool::info | Emits E_DEPRECATED when used.
 | MongoPool::setSize | Emits E_DEPRECATED when used.
1.2.10 | MongoClient::getHosts | Support for non-replicasets was added. The returned array elements now also include the hostname and port.
1.2.7 | MongoCollection::batchInsert | Added "continueOnError" option.
1.2.5 | MongoGridFS::storeUpload | Changed second parameter to an array of metadata. Pre-1.2.5, the second parameter was an optional string overriding the filename.
1.2.0 | MongoClient::close | Before version 1.2.0 the driver would not use persistent connections by default, and all connections would be closed as soon as a MongoDB connection went out if scope. Since version 1.2.0 this is no longer the case and it is a bad idea to call close as you might end up overloading the server with connections under high load.
 | MongoClient::__construct | Added "username" and "password" options. Removed "persist" option, as all connections are now persistent. It can still be used, but it doesn't affect anything. "persist" If the connection should be persistent. If set, the connection will be persistent. The string representation of the value is used as an ID for the connection, so two instances of MongoClient that are initialized with array("persist" => "foobar") will share the same database connection, whereas an instance initialized with array("persist" => "barbaz") will use a different database connection. The "replicaSet" option now takes a string, not a boolean.
 | MongoCollection::ensureIndex | Added "timeout" option.
 | MongoCollection::insert | Added "timeout" option.
 | MongoCollection::remove | Added "timeout" option.
 | MongoCollection::save | Added "timeout" option.
 | MongoCollection::update | Added "timeout" option.
 | MongoDB::command | Added options parameter with a single option: "timeout".
1.1.0 | MongoCursor::info | Added a number of other fields, including id (the cursor id), at (the driver's counter of which document is current), numReturned (the number returned by the server in the current batch), and server (which server the query was sent to—useful in conjunction with .
1.0.11 | MongoCollection::ensureIndex | The "safe" option will trigger a primary failover, if necessary. MongoException will be thrown if the index name (either generated or set) is longer than 128 bytes.
 | MongoCollection::insert | Disconnects on "not master" errors if "safe" is set.
 | MongoCollection::remove | Disconnects on "not master" errors if "safe" is set.
 | MongoCollection::save | Disconnects on "not master" errors if "safe" is set.
 | MongoCollection::update | Disconnects on "not master" errors if "safe" is set.
1.0.10 | MongoCursor::info | Added started_iterating field, a boolean indicating if cursor is pre- or post-query.
1.0.9 | MongoClient::__construct | Added "replicaSet" option.
 | MongoCollection::batchInsert | Added ability to pass integers to the "safe" option, which previously only accepted booleans. Added "fsync" option.
 | MongoCollection::insert | Added ability to pass integers to the "safe" option, which previously only accepted booleans. Added "fsync" option. The return type was changed to be an array containing error information if the "safe" option is used. Otherwise, a boolean is returned as before.
 | MongoCollection::remove | Added ability to pass integers to the "safe" option, which previously only accepted booleans. Added "fsync" option. The return type was changed to be an array containing error information if the "safe" option is used. Otherwise, a boolean is returned as before.
 | MongoCollection::save | Added "fsync" option.
 | MongoCollection::update | Added ability to pass integers to the "safe" option, which previously only accepted booleans. Added "fsync" option. The return type was changed to be an array containing error information if the "safe" option is used. Otherwise, a boolean is returned as before.
1.0.7 | MongoCollection::count | Added limit and skip as second and third parameters, respectively.
1.0.5 | MongoCollection::batchInsert | Added options parameter.
 | MongoCollection::ensureIndex | Added the "name" option to override index name creation.
 | MongoCollection::remove | Changed second parameter to be an array of options. Pre-1.0.5, the second parameter was a boolean indicating the "safe" option.
 | MongoCollection::save | Added options parameter.
 | MongoCollection::update | Added "safe" option.
1.0.2 | MongoClient::__construct | Changed constructor to take an array of options. Pre-1.0.2, the constructor took the following parameters: server The server name. connect Optional boolean parameter specifying if the constructor should connect to the database before returning. Defaults to TRUE. persistent If the connection should be persistent. paired If the connection should be paired.
 | MongoCollection::ensureIndex | Changed options parameter from boolean to array. Pre-1.0.2, the second parameter was an optional boolean value specifying a unique index.
 | MongoCollection::insert | Changed second parameter to be an array of options. Pre-1.0.2, the second parameter was a boolean indicating the "safe" option.
1.0.1 | MongoCollection::insert | Throw a MongoCursorException if the "safe" option is set and the insert fails.
 | MongoCollection::update | Changed options parameter from boolean to array. Pre-1.0.1, the second parameter was an optional boolean value specifying an upsert.
MongoWriteConcernException::getDocument
MongoDB
Mongo


MongoDB driver

Unlike the mongo extension, this extension supports both PHP and HHVM and is developed atop the » libmongoc and » libbson libraries. It provides a minimal API for core driver functionality: commands, queries, writes, connection management, and BSON serialization.

Userland PHP libraries that depend on this extension may provide higher level APIs, such as query builders, individual command helper methods, and GridFS. Application developers should consider using this extension in conjunction with the » MongoDB PHP library, which implements the same higher level APIs found in MongoDB drivers for other languages. This separation of concerns allows the driver to focus on essential features for which an extension implementation is paramount for performance.

  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Öntanımlı Sabitler
  • Tutorials
    • Getting Started with HHVM
    • Using the PHP Library for MongoDB (PHPLIB)
  • Driver Architecture and Internals — Explains the driver architecure, and special features
    • Architecture — Architecture Overview
    • Connections — Connection handling and persistence
    • Persisting Data — Serialization and deserialization of PHP variables into MongoDB
  • Security
    • Request Injection Attacks
    • Script Injection Attacks
  • MongoDB\Driver — MongoDB driver classes
    • MongoDB\Driver\Manager — The MongoDB\Driver\Manager class
    • MongoDB\Driver\Command — The MongoDB\Driver\Command class
    • MongoDB\Driver\Query — The MongoDB\Driver\Query class
    • MongoDB\Driver\BulkWrite — The MongoDB\Driver\BulkWrite class
    • MongoDB\Driver\WriteConcern — The MongoDB\Driver\WriteConcern class
    • MongoDB\Driver\ReadPreference — The MongoDB\Driver\ReadPreference class
    • MongoDB\Driver\ReadConcern — The MongoDB\Driver\ReadConcern class
    • MongoDB\Driver\Cursor — The MongoDB\Driver\Cursor class
    • MongoDB\Driver\CursorId — The MongoDB\Driver\CursorId class
    • MongoDB\Driver\Server — The MongoDB\Driver\Server class
    • MongoDB\Driver\WriteConcernError — The MongoDB\Driver\WriteConcernError class
    • MongoDB\Driver\WriteError — The MongoDB\Driver\WriteError class
    • MongoDB\Driver\WriteResult — The MongoDB\Driver\WriteResult class
  • MongoDB\BSON — BSON type classes and serialization functions
    • İşlevleri
    • MongoDB\BSON\Binary — The MongoDB\BSON\Binary class
    • MongoDB\BSON\Decimal128 — The MongoDB\BSON\Decimal128 class
    • MongoDB\BSON\Javascript — The MongoDB\BSON\Javascript class
    • MongoDB\BSON\MaxKey — The MongoDB\BSON\MaxKey class
    • MongoDB\BSON\MinKey — The MongoDB\BSON\MinKey class
    • MongoDB\BSON\ObjectID — The MongoDB\BSON\ObjectID class
    • MongoDB\BSON\Regex — The MongoDB\BSON\Regex class
    • MongoDB\BSON\Timestamp — The MongoDB\BSON\Timestamp class
    • MongoDB\BSON\UTCDateTime — The MongoDB\BSON\UTCDateTime class
    • MongoDB\BSON\Type — The MongoDB\BSON\Type interface
    • MongoDB\BSON\Persistable — The MongoDB\BSON\Persistable interface
    • MongoDB\BSON\Serializable — The MongoDB\BSON\Serializable interface
    • MongoDB\BSON\Unserializable — The MongoDB\BSON\Unserializable interface
  • MongoDB\Driver\Exception — Exception classes
    • MongoDB\Driver\Exception\AuthenticationException — The MongoDB\Driver\Exception\AuthenticationException class
    • MongoDB\Driver\Exception\BulkWriteException — The MongoDB\Driver\Exception\BulkWriteException class
    • MongoDB\Driver\Exception\ConnectionException — The MongoDB\Driver\Exception\ConnectionException class
    • MongoDB\Driver\Exception\ConnectionTimeoutException — The MongoDB\Driver\Exception\ConnectionTimeoutException class
    • MongoDB\Driver\Exception\Exception — The MongoDB\Driver\Exception\Exception interface
    • MongoDB\Driver\Exception\ExecutionTimeoutException — The MongoDB\Driver\Exception\ExecutionTimeoutException class
    • MongoDB\Driver\Exception\InvalidArgumentException — The MongoDB\Driver\Exception\InvalidArgumentException class
    • MongoDB\Driver\Exception\LogicException — The MongoDB\Driver\Exception\LogicException class
    • MongoDB\Driver\Exception\RuntimeException — The MongoDB\Driver\Exception\RuntimeException class
    • MongoDB\Driver\Exception\SSLConnectionException — The MongoDB\Driver\Exception\SSLConnectionException class
    • MongoDB\Driver\Exception\UnexpectedValueException — The MongoDB\Driver\Exception\UnexpectedValueException class
    • MongoDB\Driver\Exception\WriteException — The MongoDB\Driver\Exception\WriteException class
Changelog
Yapılandırma/Kurulum
Sağlayıcıya Göre Veritabanı Eklentileri


Yapılandırma/Kurulum

  • Gereksinimler
  • Kurulum
    • Installing the MongoDB PHP Driver with PECL
    • Installing the MongoDB PHP Driver on OSX with Homebrew
    • Installing the MongoDB PHP Driver on Windows
    • Manually Installing the MongoDB PHP Driver
    • Manually Installing the MongoDB HHVM Driver
  • Çalışma Anı Yapılandırması
  • Öntanımlı Sabitler
MongoDB
Gereksinimler
MongoDB


Gereksinimler

The PHP variant of the driver requires PHP 5.4 or higher.

The HHVM variant of the driver requires HHVM 3.9 or higher.

The driver requires » libbson and » libmongoc, and will use bundled versions of both libraries by default.

The driver requires » OpenSSL and will rely on PHP to find its headers (i.e. PHP_SETUP_OPENSSL). If the build process fails to find OpenSSL, check that the OpenSSL development package (e.g. libssl-dev) and » pkg-config are both installed.

» Cyrus SASL is an optional dependency and will be used if available.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

İçindekiler

  • Installing the MongoDB PHP Driver with PECL
  • Installing the MongoDB PHP Driver on OSX with Homebrew
  • Installing the MongoDB PHP Driver on Windows
  • Manually Installing the MongoDB PHP Driver
  • Manually Installing the MongoDB HHVM Driver
Gereksinimler
Installing the MongoDB PHP Driver with PECL
Yapılandırma/Kurulum


Installing the MongoDB PHP Driver with PECL

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/mongodb

Linux, Unix, and OS X users may run the following command to install the driver:

$ sudo pecl install mongodb

Bilginize: Installing the driver via PECL will use bundled versions of » libbson and » libmongoc and rely on PHP to find OpenSSL (i.e. PHP_SETUP_OPENSSL). If the build process fails to find OpenSSL, check that the OpenSSL development package (e.g. libssl-dev) and » pkg-config are both installed.

Add the following line to your php.ini file:

extension=mongodb.so

Kurulum
Installing the MongoDB PHP Driver on OSX with Homebrew
Kurulum


Installing the MongoDB PHP Driver on OSX with Homebrew

If you are using » Homebrew, the PHP tap includes formulae for installing the driver on various PHP versions.

  • php54-mongodb
  • php55-mongodb
  • php56-mongodb
  • php70-mongodb

For example, you might install the driver for PHP 7.0 using the following command:

$ brew install php70-mongodb

Installing the MongoDB PHP Driver with PECL
Installing the MongoDB PHP Driver on Windows
Kurulum


Installing the MongoDB PHP Driver on Windows

Precompiled binaries for each release are available from » PECL for a variety of combinations of versions, thread safety, and VC libraries. Extract the archive and put php_mongodb.dll in your PHP extension directory ("ext" by default).

Add the following line to your php.ini file:

extension=php_mongodb.dll

Installing the MongoDB PHP Driver on OSX with Homebrew
Manually Installing the MongoDB PHP Driver
Kurulum


Manually Installing the MongoDB PHP Driver

For driver developers and people interested in the latest bugfixes, you can compile the driver from the latest source code on » Github. Run the following commands to clone and build the project:

$ git clone https://github.com/mongodb/mongo-php-driver.git
$ cd mongo-php-driver
$ git submodule sync && git submodule update --init
$ phpize
$ ./configure
$ make all -j 5
$ sudo make install

Bilginize: By default, the driver will use bundled versions of » libbson and » libmongoc and rely on PHP to find OpenSSL (i.e. PHP_SETUP_OPENSSL). If the build process fails to find OpenSSL, check that the OpenSSL development package (e.g. libssl-dev) and » pkg-config are both installed.

The last step will report where mongodb.so has been installed, similar to:

Installing shared extensions:     /usr/lib/php/extensions/debug-non-zts-20151012/

Ensure that the extension_dir option in php.ini points to the directory where mongodb.so was installed. You can query the option by running:

$ php -i | grep extension_dir
  extension_dir => /usr/lib/php/extensions/debug-non-zts-20151012 =>
                   /usr/lib/php/extensions/debug-non-zts-20151012

If the directories differ, either change extension_dir in php.ini or manually move mongodb.so to the correct directory.

Add the following line to your php.ini file:

extension=mongodb.so

Installing the MongoDB PHP Driver on Windows
Manually Installing the MongoDB HHVM Driver
Kurulum


Manually Installing the MongoDB HHVM Driver

At the time of this writing, HHVM does not have a package manager for extensions. Download the latest driver from » GitHub. Alternatively, you may clone the repository to build the latest source code:

$ git clone https://github.com/mongodb/mongo-hhvm-driver.git
$ cd mongo-hhvm-driver
$ git submodule sync && git submodule update --init --recursive

Set up the make files by running:

$ hphpize
$ cmake .

Generate the configure files for the bundled libraries. For this this to work, you need to have the automake, autoconf, and libtool packages installed (e.g. through apt-get).

$ make configlib

Build and install the driver by running:

$ make -j 5
$ sudo make install

Bilginize:

If the hphpize command is not available, you will need to either compile HHVM from source or install the hhvm-dev package (e.g. through apt-get).

The last step will report where mongodb.so has been installed, similar to:

Installing:     /usr/local/hhvm/3.9.1/lib/hhvm/extensions/20150212/mongodb.so

Add the following line to your php.ini file (usually found in "/etc/hhvm"):

hhvm.dynamic_extension_path=/usr/local/hhvm/3.9.1/lib/hhvm/extensions/20150212
hhvm.dynamic_extensions[mongodb]=mongodb.so

Manually Installing the MongoDB PHP Driver
Çalışma Anı Yapılandırması
Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

mongodb Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi | Comments
mongodb.debug | "" | PHP_INI_ALL |  | Only available for the PHP driver, and not the HHVM one

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

mongodb.debug string

Store full activity debug log in this directory or stream. The special value "stderr" can be provided to write to STDERR.

Bilginize:

Not available for HHVM

Manually Installing the MongoDB HHVM Driver
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

MONGODB_VERSION (string)
x.y.z style version number of the extension
MONGODB_STABILITY (string)
Current stability (alpha/beta/stable)

Çalışma Anı Yapılandırması
Tutorials
Yapılandırma/Kurulum


Tutorials

In this section you will find several tutorials on how to use the MongoDB driver for PHP and HHVM. Because the drivers work exactly the same, they share common usage tutorials, but have a separate installation sections.

  • Getting Started with HHVM
  • Using the PHP Library for MongoDB (PHPLIB)
Öntanımlı Sabitler
Getting Started with HHVM
MongoDB


Getting Started with HHVM

In this section you will learn how to set-up NGINX with HHVM and MongoDB. However, this tutorial is not meant to be an all inclusive guide on how to run NGINX and HHVM in a production environment.

In this tutorial, we will be using a Debian system with NGINX installed through apt-get and HHVM installed from source or pre-built packages into /usr/local/hhvm/3.9.1 (with the binary located at /usr/local/hhvm/3.9.1/bin/hhvm).

Installing NGINX

We simply install NGINX by running apt-get install nginx-full. If NGINX fails to start after installation, it is likely that you already have another web server (e.g. Apache) running on the same port. In that case, you will see the following lines in /var/log/nginx/error.log:

2015/09/29 10:19:27 [emerg] 22445#22445: bind() to 0.0.0.0:80 failed (98:Address already in use)
2015/09/29 10:19:27 [emerg] 22445#22445: bind() to [::]:80 failed (98: Address already in use)

To resolve this, you can either change the default port for NGINX or Apache, stop the Apache process with service apache2 stop, or remove Apache entirely with apt-get remove apache2.

Installing HHVM

This tutorial is written from the perspective of an extension developer, so we've installed HHVM from source to faciliate patch development and ensure that debug symbols are available. That said, the folks at Facebook also provide pre-built packages, which is probably what you will want to use in production and development. You can find installation instructions for these packages on the » HHVM Wiki.

You will need to install both the the hhvm and hhvm-dev packages. The latter is needed so that we can compile the MongoDB HHVM extension later on.

If you are compiling HHVM from source, you will need to create /var/run/hhvm:

sudo mkdir -p /var/run/hhvm
sudo chown www-data.www-data /var/run/hhvm
sudo mkdir /etc/hhvm
sudo touch /etc/hhvm/php.ini
# So that you don't have to ``sudo`` to edit the file
sudo chown derick /etc/hhvm/php.ini
# To see whether it actually works
echo "date.timezone=Europe/London" >> /etc/hhvm/php.ini

HHVM should be started as the www-data user. For the purposes of this tutorial, we can run it in the foreground in server mode as follows:

sudo -u www-data -s /usr/local/hhvm/3.9.1/bin/hhvm \
 --mode server \
 -vServer.Type=fastcgi \
 -vServer.FileSocket=/var/run/hhvm/sock

Making NGINX Talk to HHVM

Once HHVM runs, we need to tell NGINX how to talk to HHVM for executing .php files. Although this is perhaps not the cleanest approach, you can add the following snippet to /etc/nginx/sites-enabled/default, just after the location / { ... } section:

location ~ \.php$ {
   fastcgi_pass unix:/var/run/hhvm/sock;
   fastcgi_index index.php;
   fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
   include fastcgi_params;
}

After adding that snippet, you should restart NGINX:

sudo service nginx restart

To confirm that everything works so far, we will create a project directory with an index.php file that calls phpinfo():

  • Create the project directory: sudo mkdir -p /var/www/html/my-first-project

  • Change permissions to your user and the www-data group: sudo chown derick.www-data /var/www/html/my-first-project

  • Create the file /var/www/html/my-first-project/index.php. From now on, I will not include the full path /var/www/html/my-first-project/ when I mention file names. Put the following content in this file:

    <?php
    phpinfo    ();
    ?>

Now, in your browser, request the page http://gargleblaster/my-first-project/index.php (but adjust the hostname). This should then show a page starting with "HHVM Version 3.9.1" followed by several tables with information.

Installing the MongoDB Driver for HHVM

The MongoDB driver is the part that links up the PHP in HHVM with the database server. To install and register the driver with HHVM, you need to follow the steps in Manually Installing the MongoDB HHVM Driver.

After you have installed and enabled the extension, HHVM will need to be restarted. If you have HHVM running in the shell from earlier, stop it with Ctrl-C and restart it again as above:

sudo -u www-data -s /usr/local/hhvm/3.9.1/bin/hhvm \
   --mode server \
   -vServer.Type=fastcgi \
   -vServer.FileSocket=/var/run/hhvm/sock

In order to test that the driver is loaded, edit the index.php file and replace its contents with:

<?php
var_dump(phpversion("mongodb"));
?>

This should output something similar to:

string(5) "x.y.z"

Further Reading

Continue this tutorial by jumping to Using the PHP Library for MongoDB (PHPLIB).

Tutorials
Using the PHP Library for MongoDB (PHPLIB)
Tutorials


Using the PHP Library for MongoDB (PHPLIB)

After the initial driver set-up, we will continue explaining how to get started with the MongoDB driver and corresponding userland library to write our first project.

Installing the PHP Library with Composer

The last thing we still need to install to get started on the application itself, is the PHP library.

The library needs to be installed with » Composer, a package manager for PHP. Instructions for installing Composer on various platforms may be found on its website.

Install the library by running:

$ composer require mongodb/mongodb

It will output something akin to:

./composer.json has been created
Loading composer repositories with package information
Updating dependencies (including require-dev)
  - Installing mongodb/mongodb (1.0.0)
    Downloading: 100%

Writing lock file
Generating autoload files

Composer will create several files: composer.json, composer.lock, and a vendor directory that will contain the library and any other dependencies your project might require.

Using the PHP Library

In addition to managing your dependencies, Composer will also provide you with an autoloader (for those dependencies' classes). Ensure that it is included at the start of your script or in your application's bootstrap code:

<?php
// This path should point to Composer's autoloader
require 'vendor/autoload.php';

With this done, you can now use any of the functionality as described in the » library documentation.

If you have previously used the old driver (i.e. mongo extension), the library's API should look familiar. It contains a » Client class for connecting to MongoDB, and » Database class for database-level operations (e.g. commands, collection management) and a » Collection class for collection-level operations (e.g. » CRUD methods, index management). Various Collection methods have been renamed for clarity, and to be in accordance with a new language-agnostic » specification.

As an example, this is how you insert a document into the beers collection of the demo database:

<?php
require 'vendor/autoload.php'; // include Composer's autoloader

$client = new MongoDB\Client("mongodb://localhost:27017");
$collection = $client->demo->beers;

$result = $collection->insertOne( [ 'name' => 'Hinterland', 'brewery' => 'BrewDog' ] );

echo "Inserted with Object ID '{$result->getInsertedId()}'";
?>

Instead of injecting the generated _id field into the input document (as was done in the old driver), it is now made available through the result object returned by the insertOne method.

After insertion, you can of course also query the data that you have just inserted. For that, you use the find method, which returns an iterable cursor:

<?php
require 'vendor/autoload.php'; // include Composer's autoloader

$client = new MongoDB\Client("mongodb://localhost:27017");
$collection = $client->demo->beers;

$result = $collection->find( [ 'name' => 'Hinterland', 'brewery' => 'BrewDog' ] );

foreach ($result as $entry) {
    echo $entry['_id'], ': ', $entry['name'], "\n";
}
?>

While it may not be apparent in the examples, BSON documents and arrays are unserialized as type classes in the library by default. These classes ensure that values preserve their type when being serialized back into BSON, which avoids a caveat in the old driver where arrays might turn into documents, and vice versa. Additionally, the classes extend ArrayObject for enhanced usability. You can find more information on how serialization and deserialization between PHP variables and BSON is handled by the driver and library by reading the Persisting Data specification.

Getting Started with HHVM
Driver Architecture and Internals
Tutorials


Explains the driver architecure, and special features

  • Architecture — Architecture Overview
  • Connections — Connection handling and persistence
  • Persisting Data — Serialization and deserialization of PHP variables into MongoDB
    • Serialization to BSON
    • Deserialization from BSON
Using the PHP Library for MongoDB (PHPLIB)
Architecture
MongoDB


Architecture Overview

This section explains how all the different parts of the driver fit together. From the different language runtimes, through the extensions and to the PHP libraries on top. This new architecture has replaced the old mongo extension. We refer to the new one as the mongodb extension.

At the top of this stack sits a pure » PHP library, which we will distribute as a Composer package. This library will provide an API similar to what users have come to expect from the old mongo driver (e.g. CRUD methods, database and collection objects, command helpers) and we expect it to be a common dependency for most applications built with MongoDB. This library will also implement common » specifications, in the interest of improving API consistency across all of the » drivers maintained by MongoDB (and hopefully some community drivers, too).

Sitting below that library we have the lower level drivers—one per platform. These extensions will effectively form the glue between PHP and HHVM and our system libraries (» libmongoc and » libbson). These extensions will expose an identical public API for the most essential and performance-sensitive functionality:

  • Connection management
  • BSON encoding and decoding
  • Object document serialization (to support ODM libraries)
  • Executing commands and write operations
  • Handling queries and cursors

By decoupling the driver internals and a high-level API into extensions and PHP libraries, respectively, we hope to reduce our maintainence burden and allow for faster iteration on new features. As a welcome side effect, this also makes it easier for anyone to contribute to the driver. Additionally, an identical public API for these extensions will make it that much easier to port an application across PHP runtimes, whether the application uses the low-level driver directly or a higher-level PHP library.

» GridFS is a great example of why we chose this direction. Although we implemented GridFS in C for our old mongo driver, it is actually quite a high-level specification. Its API is just an abstraction for accessing two collections: files (i.e. metadata) and chunks (i.e. blocks of data). Likewise, all of the syntactic sugar found in the old mongo driver, such as processing uploaded files or exposing GridFS files as PHP streams, can be implemented in pure PHP. Provided we have performant methods for reading from and writing to GridFS' collections - and thanks to our low level extensions, we will - shifting this API to PHP is win-win.

Earlier I mentioned that we expect the PHP library to be a common dependency for most applications, but not all. Some users may prefer to stick to the no-frills API offered by the extensions, or create their own high-level abstraction (akin to » Doctrine MongoDB for the old mongo driver). Future libraries could include a PHP library geared for MongoDB administration, which provides an API for various user management and ops commands. The next major version of » Doctrine MongoDB ODM will likely also sit directly atop the extensions.

While we will continue to maintain and support the old mongo driver and its users for the foreseeable future, we invite everyone to use the next-generation driver and consider it for any new projects going forward. You can find all of the essential components across GitHub and JIRA:

Driver Source Code and JIRA Locations
Project | GitHub | JIRA
PHP Library | » mongodb/mongo-php-library | » PHPLIB
PHP 5 and PHP 7 Driver (phongo) | » mongodb/mongo-php-driver | » PHPC
HHVM Driver (hippo) | » mongodb/mongo-hhvm-driver | » HHVM

The existing » PHP project in JIRA will remain open for reporting bugs against the old mongo driver, but we would ask that you use the new projects above for anything pertaining to our next-generation drivers.

Driver Architecture and Internals
Connections
Driver Architecture and Internals


Connection handling and persistence

İpucu

On Unix platforms, the MongoDB driver is sensitive to scripts that use the fork() system call without also calling exec(). Users are advised not to re-use MongoDB\Driver\Manager instances in a forked child process.

Connection and topology persistence (PHP and HHVM versions since 1.2.0)

All versions of the driver since 1.2.0 persist the » libmongoc client object in the PHP worker process, which allows it to re-use database connections, authentication states, and topology information across multiple requests.

When MongoDB\Driver\Manager::__construct() is invoked, a hash is created from its arguments (i.e. URI string and array options). The driver will attempt to find a previously persisted » libmongoc client object for that hash. If an existing client cannot be found for the hash, a new client will be created (and persisted for future use).

Each client contains its own database connections and a view of the server topology (e.g. standalone, replica set, shard cluster). By persisting the client between PHP requests, the driver is able to re-use established database connections and remove the need for » discovering the server topology on each request.

Consider the following example:

<?php

$managers = [
    new MongoDB\Driver\Manager('mongodb://127.0.0.1'),
    new MongoDB\Driver\Manager('mongodb://127.0.0.1'),
    new MongoDB\Driver\Manager('mongodb://127.0.0.1:27017'),
    new MongoDB\Driver\Manager('mongodb://rs1.example.com,rs2.example.com/', ['replicaSet' => 'myReplicaSet']),
];

foreach ($managers as $manager) {
    $manager->executeCommand('test', new MongoDB\Driver\Command(['ping' => 1]));
}

?>

The first two Manager objects will share the same » libmongoc client since their constructor arguments are identical. The third and fourth objects will each use their own client. In total, three clients will be created and the PHP worker executing this script will open two connections to 127.0.0.1 and one connection to each of rs1.example.com and rs2.example.com. If the driver discovers additional members of the replica set after issuing isMaster commands, it will open additional connections to those servers as well.

If the same worker executes the script again in a second request, the three clients will be re-used and no new connections should be made. Depending on how long ago the previous request was served, the driver may need to issue additional isMaster commands to update its view of the topologies.

Socket persistence (PHP versions before 1.2.0)

Versions of the PHP driver before 1.2.0 utilize PHP's Streams API for database connections, using an API within » libmongoc to designate custom handlers for socket communication; however, a new libmongoc client is created for each MongoDB\Driver\Manager. As a result, the driver persists individual database connections but not authentication state or topology information. This means that the driver needs to issue commands at the start of each request to authenticate and » discover the server topology.

Database connections are persisted by a hash derived from the server's host, port, and the URI string used to construct the MongoDB\Driver\Manager. The constructor's array options are not included in this hash.

Bilginize: Versions of the driver >= 1.1.8 and < 1.2.0 do not persist sockets for SSL connections. See » PHPC-720 for additional information.

Despite its shortcomings with persisting SSL connections when and topology information, this version of the driver supports all SSL context options since it uses PHP's Streams API.

No persistence (HHVM versions before 1.2.0)

Versions of the HHVM driver before 1.2.0 do not persist sockets, authentication state, or topology information. Socket communication uses » libmongoc entirely.

Architecture
Persisting Data
Driver Architecture and Internals


Serialization and deserialization of PHP variables into MongoDB

İçindekiler

  • Serialization to BSON
  • Deserialization from BSON

This document discusses the methods how compound structures (documents, arrays, objects) are persisted through the drivers. And how they are brought back into PHP land.

Connections
Serialization to BSON
Driver Architecture and Internals


Serialization to BSON

Arrays

If an array is a packed array — i.e. the keys start at 0 and are sequential without gaps: BSON array.

If the array is not packed — i.e. having associative (string) keys, the keys don't start at 0, or when there are gaps:: BSON object

A top-level (root) document, always serializes as a BSON document.

Examples

These serialize as a BSON array:

[ 8, 5, 2, 3 ] => [ 8, 5, 2, 3 ]
[ 0 => 4, 1 => 9 ] => [ 4, 9 ]

These serialize as a BSON document:

[ 0 => 1, 2 => 8, 3 => 12 ] => { "0" : 1, "2" : 8, "3" : 12 }
[ "foo" => 42 ] => { "foo" : 42 }
[ 1 => 9, 0 => 10 ] => { "1" : 9, "0" : 10 }

Note that the five examples are extracts of a full document, and represent only one value inside a document.

Objects

If an object is of the stdClass class, serialize as a BSON document.

If an object is a supported class that implements MongoDB\BSON\Type, then use the BSON serialization logic for that specific type. MongoDB\BSON\Type instances (excluding MongoDB\BSON\Serializable may only be serialized as a document field value. Attempting to serialize such an object as a root document will throw a MongoDB\Driver\Exception\UnexpectedValueException

If an object is of an unknown class implementing the MongoDB\BSON\Type interface, then throw a MongoDB\Driver\Exception\UnexpectedValueException

If an object is of any other class, without implementing any special interface, serialize as a BSON document. Keep only public properties, and ignore protected and private properties.

If an object is of a class that implements the MongoDB\BSON\Serializable interface, call MongoDB\BSON\Serializable::bsonSerialize() and use the returned array or stdClass to serialize as a BSON document or array. The BSON type will be determined by the following:

  1. Root documents must be serialized as a BSON document.

  2. MongoDB\BSON\Persistable objects must be serialized as a BSON document.

  3. If MongoDB\BSON\Serializable::bsonSerialize() returns a packed array, serialize as a BSON array.

  4. If MongoDB\BSON\Serializable::bsonSerialize() returns a non-packed array or stdClass, serialize as a BSON document.

  5. If MongoDB\BSON\Serializable::bsonSerialize() did not return an array or stdClass, throw an MongoDB\Driver\Exception\UnexpectedValueException exception.

If an object is of a class that implements the MongoDB\BSON\Persistable interface (which implies MongoDB\BSON\Serializable obtain the properties in a similar way as in the previous paragraphs, but also add an additional property __pclass as a Binary value, with subtype 0x80 and data bearing the fully qualified class name of the object that is being serialized.

The __pclass property is added to the array or object returned by MongoDB\BSON\Serializable::bsonSerialize(), which means it will overwrite any __pclass key/property in the MongoDB\BSON\Serializable::bsonSerialize() return value. If you want to avoid this behaviour and set your own __pclass value, you must not implement MongoDB\BSON\Persistable and should instead implement MongoDB\BSON\Serializable directly.

Examples

<?php

class stdClass {
  public $foo = 42;
} // => { "foo" : 42 }

class MyClass {
  public $foo = 42;
  protected $prot = "wine";
  private $fpr = "cheese";
} // => { "foo" : 42 }

class AnotherClass1 implements MongoDB\BSON\Serializable {
  public $foo = 42;
  protected $prot = "wine";
  private $fpr = "cheese";
  function bsonSerialize() {
      return [ 'foo' => $this->foo, 'prot' => $this->prot ];
  }
} // => { "foo" : 42, "prot" : "wine" }

class AnotherClass2 implements MongoDB\BSON\Serializable {
  public $foo = 42;
  function bsonSerialize() {
      return $this;
  }
} // => MongoDB\Driver\Exception\UnexpectedValueException("bsonSerialize() did not return an array or stdClass")

class AnotherClass3 implements MongoDB\BSON\Serializable {
  private $elements = [ 'foo', 'bar' ];
  function bsonSerialize() {
      return $this->elements;
  }
} // => { "0" : "foo", "1" : "bar" }

class ContainerClass implements MongoDB\BSON\Serializable {
  public $things = AnotherClass4 implements MongoDB\BSON\Serializable {
    private $elements = [ 0 => 'foo', 2 => 'bar' ];
    function bsonSerialize() {
      return $this->elements;
    }
  }
  function bsonSerialize() {
      return [ 'things' => $this->things ];
  }
} // => { "things" : { "0" : "foo", "2" : "bar" } }

class ContainerClass implements MongoDB\BSON\Serializable {
  public $things = AnotherClass5 implements MongoDB\BSON\Serializable {
    private $elements = [ 0 => 'foo', 2 => 'bar' ];
    function bsonSerialize() {
      return array_values($this->elements);
    }
  }
  function bsonSerialize() {
      return [ 'things' => $this->things ];
  }
} // => { "things" : [ "foo", "bar" ] }

class ContainerClass implements MongoDB\BSON\Serializable {
  public $things = AnotherClass6 implements MongoDB\BSON\Serializable {
    private $elements = [ 'foo', 'bar' ];
    function bsonSerialize() {
      return (object) $this->elements;
    }
  }
  function bsonSerialize() {
      return [ 'things' => $this->things ];
  }
} // => { "things" : { "0" : "foo", "1" : "bar" } }

class UpperClass implements MongoDB\BSON\Persistable {
  public $foo = 42;
  protected $prot = "wine";
  private $fpr = "cheese";
  function bsonSerialize() {
      return [ 'foo' => $this->foo, 'prot' => $this->prot ];
  }
} // => { "foo" : 42, "prot" : "wine", "__pclass" : { "$type" : "80", "$binary" : "VXBwZXJDbGFzcw==" } }
Persisting Data
Deserialization from BSON
Persisting Data


Deserialization from BSON

For compound types, there are three data types:

root

refers to the top-level BSON document only

document

refers to embedded BSON documents only

array

refers to a BSON array

Each of those three data types can be mapped against different PHP types. The possible mapping values are:

not set or NULL (the is the default)

  • A BSON array will be deserialized as a PHP array.

  • A BSON document (root or embedded) without a __pclass property [1] becomes a PHP stdClass object, with each BSON document key set as a public stdClass property.

  • A BSON document (root or embedded) with a __pclass property [1] becomes a PHP object of the class name as defined by the __pclass property.

    If the named class implements the MongoDB\BSON\Persistable interface, then the properties of the BSON document, including the __pclass property, are sent as an associative array to the MongoDB\BSON\Unserializable::bsonUnserialize() function to initialise the object's properties.

    If the named class does not exist or does not implement the MongoDB\BSON\Persistable interface, stdClass will be used and each BSON document key (including __pclass) will be set as a public stdClass property.

"array"

Turns a BSON array or BSON document into a PHP array. There will be no special treatment of a __pclass property [1], but it may be set as an element in the returned array if it was present in the BSON document.

"object" or "stdClass"

Turns a BSON array or BSON document into a stdClass object. There will be no special treatment of a __pclass property [1], but it may be set as a public property in the returned object if it was present in the BSON document.

any other string

Defines the class name that the BSON array or BSON object should be deserialized as. For BSON objects that include __pclass properties, that class will take priority.

If the named class does not exist, is not concrete (i.e. it is abstract or an interface), or does not implement MongoDB\BSON\Unserializable then an MongoDB\Driver\Exception\InvalidArgumentException exception is thrown.

If the BSON object has a __pclass property and that class exists and implements MongoDB\BSON\Persistable it will supersede the class provided in the type map.

The properties of the BSON document, including the __pclass property if it exists, will be sent as an associative array to the MongoDB\BSON\Unserializable::bsonUnserialize() function to initialise the object's properties.

TypeMaps

TypeMaps can be set through the MongoDB\Driver\Cursor::setTypeMap() method on a MongoDB\Driver\Cursor object, or the $typeMap argument of MongoDB\BSON\toPHP(). Each of the three classes (root, document and array) can be individually set.

If the value in the map is NULL, it means the same as the default value for that item.

Examples

These examples use the following classes:

MyClass

which does not implement any interface

YourClass

which implements MongoDB\BSON\Unserializable

OurClass

which implements MongoDB\BSON\Persistable

TheirClass

which extends OurClass

The MongoDB\BSON\Unserializable::bsonUnserialize() method of YourClass, OurClass, TheirClass iterate over the array and set the properties without modifications. It also sets the $unserialized property to true:

<?php

function bsonUnserialize( array $map )
{
    foreach ( $map as $k => $value )
    {
        $this->$k = $value;
    }
    $this->unserialized = true;
}

/* typemap: [] (all defaults) */
{ "foo": "yes", "bar" : false }
  -> stdClass { $foo => 'yes', $bar => false }

{ "foo": "no", "array" : [ 5, 6 ] }
  -> stdClass { $foo => 'no', $array => [ 5, 6 ] }

{ "foo": "no", "obj" : { "embedded" : 3.14 } }
  -> stdClass { $foo => 'no', $obj => stdClass { $embedded => 3.14 } }

{ "foo": "yes", "__pclass": "MyClass" }
  -> stdClass { $foo => 'yes', $__pclass => 'MyClass' }

{ "foo": "yes", "__pclass": { "$type" : "80", "$binary" : "MyClass" } }
  -> stdClass { $foo => 'yes', $__pclass => Binary(0x80, 'MyClass') }

{ "foo": "yes", "__pclass": { "$type" : "80", "$binary" : "YourClass") }
  -> stdClass { $foo => 'yes', $__pclass => Binary(0x80, 'YourClass') }

{ "foo": "yes", "__pclass": { "$type" : "80", "$binary" : "OurClass") }
  -> OurClass { $foo => 'yes', $__pclass => Binary(0x80, 'OurClass'), $unserialized => true }

{ "foo": "yes", "__pclass": { "$type" : "44", "$binary" : "YourClass") }
  -> stdClass { $foo => 'yes', $__pclass => Binary(0x44, 'YourClass') }

/* typemap: [ "root" => "MissingClass" ] */
{ "foo": "yes" }
  -> MongoDB\Driver\Exception\InvalidArgumentException("MissingClass does not exist")

/* typemap: [ "root" => "MyClass" ] */
{ "foo": "yes", "__pclass" : { "$type": "80", "$binary": "MyClass" } }
  -> MongoDB\Driver\Exception\InvalidArgumentException("MyClass does not implement Unserializable interface")

/* typemap: [ "root" => "MongoDB\BSON\Unserializable" ] */
{ "foo": "yes" }
  -> MongoDB\Driver\Exception\InvalidArgumentException("Unserializable is not a concrete class")

/* typemap: [ "root" => "YourClass" ] */
{ "foo": "yes", "__pclass" : { "$type": "80", "$binary": "MongoDB\BSON\Unserializable" } }
  -> YourClass { $foo => "yes", $__pclass => Binary(0x80, "MongoDB\BSON\Unserializable"), $unserialized => true }

/* typemap: [ "root" => "YourClass" ] */
{ "foo": "yes", "__pclass" : { "$type": "80", "$binary": "MyClass" } }
  -> YourClass { $foo => "yes", $__pclass => Binary(0x80, "MyClass"), $unserialized => true }

/* typemap: [ "root" => "YourClass" ] */
{ "foo": "yes", "__pclass" : { "$type": "80", "$binary": "OurClass" } }
  -> OurClass { $foo => "yes", $__pclass => Binary(0x80, "OurClass"), $unserialized => true }

/* typemap: [ "root" => "YourClass" ] */
{ "foo": "yes", "__pclass" : { "$type": "80", "$binary": "TheirClass" } }
  -> TheirClass { $foo => "yes", $__pclass => Binary(0x80, "TheirClass"), $unserialized => true }

/* typemap: [ "root" => "OurClass" ] */
{ foo: "yes", "__pclass" : { "$type": "80", "$binary": "TheirClass" } }
  -> TheirClass { $foo => "yes", $__pclass => Binary(0x80, "TheirClass"), $unserialized => true }

/* typemap: [ 'root' => 'YourClass' ] */
{ foo: "yes", "__pclass" : { "$type": "80", "$binary": "YourClass" } }
  -> YourClass { $foo => 'yes', $__pclass => Binary(0x80, 'YourClass'), $unserialized => true }

/* typemap: [ 'root' => 'array', 'document' => 'array' ] */
{ "foo": "yes", "bar" : false }
  -> [ "foo" => "yes", "bar" => false ]

{ "foo": "no", "array" : [ 5, 6 ] }
  -> [ "foo" => "no", "array" => [ 5, 6 ] ]

{ "foo": "no", "obj" : { "embedded" : 3.14 } }
  -> [ "foo" => "no", "obj" => [ "embedded => 3.14 ] ]

{ "foo": "yes", "__pclass": "MyClass" }
  -> [ "foo" => "yes", "__pclass" => "MyClass" ]

{ "foo": "yes", "__pclass" : { "$type": "80", "$binary": "MyClass" } }
  -> [ "foo" => "yes", "__pclass" => Binary(0x80, "MyClass") ]

{ "foo": "yes", "__pclass" : { "$type": "80", "$binary": "OurClass" } }
  -> [ "foo" => "yes", "__pclass" => Binary(0x80, "OurClass") ]

/* typemap: [ 'root' => 'object', 'document' => 'object' ] */
{ "foo": "yes", "__pclass": { "$type": "80", "$binary": "MyClass" } }
  -> stdClass { $foo => "yes", "__pclass" => Binary(0x80, "MyClass") }

Serialization to BSON
Security
Persisting Data


Security

  • Request Injection Attacks
  • Script Injection Attacks
Deserialization from BSON
Request Injection Attacks
MongoDB


Request Injection Attacks

If you are passing $_GET (or $_POST) parameters to your queries, make sure that they are cast to strings first. Users can insert associative arrays in GET and POST requests, which could then become unwanted $-queries.

A fairly innocuous example: suppose you are looking up a user's information with the request http://www.example.com?username=bob. Your application creates the query $q = new \MongoDB\Driver\Query( [ 'username' => $_GET['username'] ]).

Someone could subvert this by getting http://www.example.com?username[$ne]=foo, which PHP will magically turn into an associative array, turning your query into $q = new \MongoDB\Driver\Query( [ 'username' => [ '$ne' => 'foo' ] ] ), which will return all users not named "foo" (all of your users, probably).

This is a fairly easy attack to defend against: make sure $_GET and $_POST parameters are the type you expect before you send them to the database. PHP has the filter_var() function to assist with this.

Note that this type of attack can be used with any database interaction that locates a document, including updates, upserts, deletes, and findAndModify commands.

See » the main documentation for more information about SQL-injection-like issues with MongoDB.

Security
Script Injection Attacks
Security


Script Injection Attacks

If you are using JavaScript, make sure that any variables that cross the PHP- to-JavaScript boundry are passed in the scope field of MongoDB\BSON\Javascript, not interpolated into the JavaScript string. This can come up when using $where clauses in queries, mapReduce and group commands, and any other time you may pass JavaScript into the database.

For example, suppose we have some JavaScript to greet a user in the database logs. We could do:

<?php
$m = new MongoDB\Driver\Manager;

// Don't do this!!!
$username = $_GET['field'];

$cmd = new \MongoDB\Driver\Command( [
    'eval' => "print('Hello, $username!');"
] );

$r = $m->executeCommand( 'dramio', $cmd );
?>

However, what if a malicious user passes in some JavaScript?

<?php
$m = new MongoDB\Driver\Manager;

// Don't do this!!!
$username = $_GET['field'];
// $username is set to "'); db.users.drop(); print('"

$cmd = new \MongoDB\Driver\Command( [
    'eval' => "print('Hello, $username!');"
] );

$r = $m->executeCommand( 'dramio', $cmd );
?>

Now MongoDB executes the JavaScript string "print('Hello, '); db.users.drop(); print('!');". This attack is easy to avoid: use args to pass variables from PHP to JavaScript:

<?php
$m = new MongoDB\Driver\Manager;

$_GET['field'] = 'derick';
$args = [ $_GET['field'] ];

$cmd = new \MongoDB\Driver\Command( [
    'eval' => "function greet(username) { print('Hello, ' + username + '!'); }",
    'args' => $args,
] );

$r = $m->executeCommand( 'dramio', $cmd );
?>

This adds an argument to the JavaScript scope, which gets used as argument for the greet function. Now if someone tries to send malicious code, MongoDB will harmlessly print Hello, '); db.dropDatabase(); print('!.

Using arguments helps to prevent malicious input from being executed by the database. However, you must make sure that your code does not turn around and execute the input anyway! It is best to avoid executing any JavaScript on the server in the first place.

You are strongly recommended to stay clear of the » $where clause with queries, as it impacts performance significantly. Where possible, use either normal query operators, or the » Aggregation Framework.

As alternative to » MapReduce, which uses JavaScript, consider using the » Aggregation Framework. Unlike Map/Reduce, it uses an idiomatic language to construct queries, without having to write, and use, the slower JavaScript approach that Map/Reduce requires.

The » eval command has been deprecated since MongoDB 3.0, and should also be avoided.

Request Injection Attacks
MongoDB\Driver
Security


MongoDB driver classes

  • MongoDB\Driver\Manager — The MongoDB\Driver\Manager class
    • MongoDB\Driver\Manager::__construct — Create new MongoDB Manager
    • MongoDB\Driver\Manager::executeBulkWrite — Execute one or more write operations
    • MongoDB\Driver\Manager::executeCommand — Execute a database command
    • MongoDB\Driver\Manager::executeQuery — Execute a database query
    • MongoDB\Driver\Manager::getReadConcern — Return the ReadConcern for the Manager
    • MongoDB\Driver\Manager::getReadPreference — Return the ReadPreference for the Manager
    • MongoDB\Driver\Manager::getServers — Return the servers to which this manager is connected
    • MongoDB\Driver\Manager::getWriteConcern — Return the WriteConcern for the Manager
    • MongoDB\Driver\Manager::selectServer — Select a server matching a read preference
  • MongoDB\Driver\Command — The MongoDB\Driver\Command class
    • MongoDB\Driver\Command::__construct — Create a new Command
  • MongoDB\Driver\Query — The MongoDB\Driver\Query class
    • MongoDB\Driver\Query::__construct — Construct new Query
  • MongoDB\Driver\BulkWrite — The MongoDB\Driver\BulkWrite class
    • MongoDB\Driver\BulkWrite::__construct — Create a new BulkWrite
    • MongoDB\Driver\BulkWrite::count — Count number of write operations in the bulk
    • MongoDB\Driver\BulkWrite::delete — Add a delete operation to the bulk
    • MongoDB\Driver\BulkWrite::insert — Add an insert operation to the bulk
    • MongoDB\Driver\BulkWrite::update — Add an update operation to the bulk
  • MongoDB\Driver\WriteConcern — The MongoDB\Driver\WriteConcern class
    • MongoDB\Driver\WriteConcern::bsonSerialize — Returns an object for BSON serialization
    • MongoDB\Driver\WriteConcern::__construct — Construct immutable WriteConcern
    • MongoDB\Driver\WriteConcern::getJournal — Returns the WriteConcern's "journal" option
    • MongoDB\Driver\WriteConcern::getW — Returns the WriteConcern's "w" option
    • MongoDB\Driver\WriteConcern::getWtimeout — Returns the WriteConcern's "wtimeout" option
  • MongoDB\Driver\ReadPreference — The MongoDB\Driver\ReadPreference class
    • MongoDB\Driver\ReadPreference::bsonSerialize — Returns an object for BSON serialization
    • MongoDB\Driver\ReadPreference::__construct — Construct immutable ReadPreference
    • MongoDB\Driver\ReadPreference::getMaxStalenessSeconds — Returns the ReadPreference's "maxStalenessSeconds" option
    • MongoDB\Driver\ReadPreference::getMode — Returns the ReadPreference's "mode" option
    • MongoDB\Driver\ReadPreference::getTagSets — Returns the ReadPreference's "tagSets" option
  • MongoDB\Driver\ReadConcern — The MongoDB\Driver\ReadConcern class
    • MongoDB\Driver\ReadConcern::bsonSerialize — Returns an object for BSON serialization
    • MongoDB\Driver\ReadConcern::__construct — Construct immutable ReadConcern
    • MongoDB\Driver\ReadConcern::getLevel — Returns the ReadConcern's "level" option
  • MongoDB\Driver\Cursor — The MongoDB\Driver\Cursor class
    • MongoDB\Driver\Cursor::__construct — Create a new Cursor (not used)
    • MongoDB\Driver\Cursor::getId — Returns the ID for this cursor
    • MongoDB\Driver\Cursor::getServer — Returns the server associated with this cursor
    • MongoDB\Driver\Cursor::isDead — Checks if the cursor is still open on the server
    • MongoDB\Driver\Cursor::setTypeMap — Sets a type map to use for BSON unserialization
    • MongoDB\Driver\Cursor::toArray — Returns an array containing all results for this cursor
  • MongoDB\Driver\CursorId — The MongoDB\Driver\CursorId class
    • MongoDB\Driver\CursorId::__construct — Create a new CursorId (not used)
    • MongoDB\Driver\CursorId::__toString — String representation of the cursor ID
  • MongoDB\Driver\Server — The MongoDB\Driver\Server class
    • MongoDB\Driver\Server::__construct — Create a new Server (not used)
    • MongoDB\Driver\Server::executeBulkWrite — Execute one or more write operations on this server
    • MongoDB\Driver\Server::executeCommand — Execute a database command on this server
    • MongoDB\Driver\Server::executeQuery — Execute a database query on this server
    • MongoDB\Driver\Server::getHost — Returns the hostname of this server
    • MongoDB\Driver\Server::getInfo — Returns an array of information about this server
    • MongoDB\Driver\Server::getLatency — Returns the latency of this server
    • MongoDB\Driver\Server::getPort — Returns the port on which this server is listening
    • MongoDB\Driver\Server::getTags — Returns an array of tags describing this server in a replica set
    • MongoDB\Driver\Server::getType — Returns an integer denoting the type of this server
    • MongoDB\Driver\Server::isArbiter — Checks if this server is an arbiter member of a replica set
    • MongoDB\Driver\Server::isHidden — Checks if this server is a hidden member of a replica set
    • MongoDB\Driver\Server::isPassive — Checks if this server is a passive member of a replica set
    • MongoDB\Driver\Server::isPrimary — Checks if this server is a primary member of a replica set
    • MongoDB\Driver\Server::isSecondary — Checks if this server is a secondary member of a replica set
  • MongoDB\Driver\WriteConcernError — The MongoDB\Driver\WriteConcernError class
    • MongoDB\Driver\WriteConcernError::getCode — Returns the WriteConcernError's error code
    • MongoDB\Driver\WriteConcernError::getInfo — Returns additional metadata for the WriteConcernError
    • MongoDB\Driver\WriteConcernError::getMessage — Returns the WriteConcernError's error message
  • MongoDB\Driver\WriteError — The MongoDB\Driver\WriteError class
    • MongoDB\Driver\WriteError::getCode — Returns the WriteError's error code
    • MongoDB\Driver\WriteError::getIndex — Returns the index of the write operation corresponding to this WriteError
    • MongoDB\Driver\WriteError::getInfo — Returns additional metadata for the WriteError
    • MongoDB\Driver\WriteError::getMessage — Returns the WriteError's error message
  • MongoDB\Driver\WriteResult — The MongoDB\Driver\WriteResult class
    • MongoDB\Driver\WriteResult::getDeletedCount — Returns the number of documents deleted
    • MongoDB\Driver\WriteResult::getInsertedCount — Returns the number of documents inserted (excluding upserts)
    • MongoDB\Driver\WriteResult::getMatchedCount — Returns the number of documents selected for update
    • MongoDB\Driver\WriteResult::getModifiedCount — Returns the number of existing documents updated
    • MongoDB\Driver\WriteResult::getServer — Returns the server associated with this write result
    • MongoDB\Driver\WriteResult::getUpsertedCount — Returns the number of documents inserted by an upsert
    • MongoDB\Driver\WriteResult::getUpsertedIds — Returns an array of identifiers for upserted documents
    • MongoDB\Driver\WriteResult::getWriteConcernError — Returns any write concern error that occurred
    • MongoDB\Driver\WriteResult::getWriteErrors — Returns any write errors that occurred
    • MongoDB\Driver\WriteResult::isAcknowledged — Returns whether the write was acknowledged
Script Injection Attacks
MongoDB\Driver\Manager
MongoDB


The MongoDB\Driver\Manager class

(mongodb >=1.0.0)

Giriş

The MongoDB\Driver\Manager is the main entry point to the extension. It is responsible for maintaining connections to MongoDB (be it standalone server, replica set, or sharded cluster).

No connection to MongoDB is made upon instantiating the Manager. This means the MongoDB\Driver\Manager can always be constructed, even though one or more MongoDB servers are down.

Any write or query can throw connection exceptions as connections are created lazily. A MongoDB server may also become unavailable during the life time of the script. It is therefore important that all actions on the Manager to be wrapped in try/catch statements.

Sınıf Sözdizimi

final MongoDB\Driver\Manager {
/* Yöntemler */
 final public __construct
  ([ string $uri = "mongodb://127.0.0.1/
 [, array $uriOptions = []
 [, array $driverOptions = []
]]] )
final public MongoDB\Driver\WriteResult executeBulkWrite ( string $namespace , MongoDB\Driver\BulkWrite $bulk [, MongoDB\Driver\WriteConcern $writeConcern ] )
final public MongoDB\Driver\Cursor executeCommand ( string $db , MongoDB\Driver\Command $command [, MongoDB\Driver\ReadPreference $readPreference ] )
final public MongoDB\Driver\Cursor executeQuery ( string $namespace , MongoDB\Driver\Query $query [, MongoDB\Driver\ReadPreference $readPreference ] )
final public MongoDB\Driver\ReadConcern getReadConcern ( void )
final public MongoDB\Driver\ReadPreference getReadPreference ( void )
final public array getServers ( void )
final public MongoDB\Driver\WriteConcern getWriteConcern ( void )
final public MongoDB\Driver\Server selectServer ( MongoDB\Driver\ReadPreference $readPreference )
}

Örnekler

Örnek 1 MongoDB\Driver\Manager::__construct() basic example

var_dump()ing a MongoDB\Driver\Manager will print out various details about the manager that are otherwise not normally exposed. This can be useful to debug how the driver views your MongoDB setup, and which options are used.

<?php

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017");
var_dump($manager);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(MongoDB\Driver\Manager)#1 (3) {
  ["request_id"]=>
  int(1714636915)
  ["uri"]=>
  string(25) "mongodb://localhost:27017"
  ["cluster"]=>
  array(13) {
    ["mode"]=>
    string(6) "direct"
    ["state"]=>
    string(4) "born"
    ["request_id"]=>
    int(0)
    ["sockettimeoutms"]=>
    int(300000)
    ["last_reconnect"]=>
    int(0)
    ["uri"]=>
    string(25) "mongodb://localhost:27017"
    ["requires_auth"]=>
    int(0)
    ["nodes"]=>
    array(...)
    ["max_bson_size"]=>
    int(16777216)
    ["max_msg_size"]=>
    int(50331648)
    ["sec_latency_ms"]=>
    int(15)
    ["peers"]=>
    array(0) {
    }
    ["replSet"]=>
    NULL
  }
}

İçindekiler

  • MongoDB\Driver\Manager::__construct — Create new MongoDB Manager
  • MongoDB\Driver\Manager::executeBulkWrite — Execute one or more write operations
  • MongoDB\Driver\Manager::executeCommand — Execute a database command
  • MongoDB\Driver\Manager::executeQuery — Execute a database query
  • MongoDB\Driver\Manager::getReadConcern — Return the ReadConcern for the Manager
  • MongoDB\Driver\Manager::getReadPreference — Return the ReadPreference for the Manager
  • MongoDB\Driver\Manager::getServers — Return the servers to which this manager is connected
  • MongoDB\Driver\Manager::getWriteConcern — Return the WriteConcern for the Manager
  • MongoDB\Driver\Manager::selectServer — Select a server matching a read preference
MongoDB\Driver
MongoDB\Driver\Manager::__construct
MongoDB\Driver


Create new MongoDB Manager

MongoDB\Driver\Manager
MongoDB\Driver\Manager::executeBulkWrite
MongoDB\Driver\Manager
PHP Manual

MongoDB\Driver\Manager::__construct

(mongodb >=1.0.0)

MongoDB\Driver\Manager::__construct — Create new MongoDB Manager

Açıklama

 final public MongoDB\Driver\Manager::__construct
  ([ string $uri = "mongodb://127.0.0.1/
 [, array $uriOptions = []
 [, array $driverOptions = []
]]] )

Constructs a new MongoDB\Driver\Manager object with the specified options.

Bilginize: Per the » Server Discovery and Monitoring Specification, this constructor performs no I/O. Connections will be initialized on demand, when the first operation is executed.

İpucu

On Unix platforms, the MongoDB driver is sensitive to scripts that use the fork() system call without also calling exec(). Users are advised not to re-use MongoDB\Driver\Manager instances in a forked child process.

Değiştirgeler

uri

A » mongodb:// connection URI:

mongodb://[username:password@]host1[:port1][,host2[:port2],...[,hostN[:portN]]][/[database][?options]]

For details on supported options, see » Connection String Options in the MongoDB manual. » Connection pool options are not supported, as the PHP driver does not implement connection pools.

The uri is a URL, hence any special characters in its components need to be URL encoded according to » RFC 3986. This is particularly relevant to the username and password, which can often include special characters such as @, :, or %. When connecting via a Unix domain socket, the socket path may contain special characters such as slashes and must be encoded. The rawurlencode() function may be used to encode constituent parts of the URI.

uriOptions

Additional » connection string options, which will overwrite any options with the same name in the uri parameter.

Bilginize: The "authMechanism" and "authMechanismProperties" options are not supported in uriOptions and must be specified in the uri parameter. For additional details, see » Authentication Options in the MongoDB manual and the » Driver Authentication Specification.

uriOptions
Option | Type | Description
appname string

MongoDB 3.4+ has the ability to annotate connections with metadata provided by the connecting client. This metadata is included in the server's logs upon establishing a connection and also recorded in slow query logs when database profiling is enabled.

This option may be used to specify an application name, which will be included in the metadata. The value cannot exceed 128 characters in length.

authSource string

The database name associated with the user's credentials. Defaults to the database component of the connection URI.

For authentication mechanisms that delegate credential storage to other services (e.g. GSSAPI), this should be "$external".

canonicalizeHostname boolean

If TRUE, the driver will resolve the real hostname for the server IP address before authenticating via SASL. Some underlying GSSAPI layers already do this, but the functionality may be disabled in their config (e.g. krb.conf). Defaults to FALSE.

connectTimeoutMS integer

The time in milliseconds to attempt a connection before timing out. Defaults to 10,000 milliseconds.

gssapiServiceName string

Set the Kerberos service name when connecting to Kerberized MongoDB instances. This value must match the service name set on MongoDB instances (i.e. » saslServiceName server parameter). Defaults to "mongodb".

heartbeatFrequencyMS integer

Specifies the interval in milliseconds between the driver's checks of the MongoDB topology, counted from the end of the previous check until the beginning of the next one. Defaults to 60,000 milliseconds.

Per the » Server Discovery and Monitoring Specification, this value cannot be less than 500 milliseconds.

journal boolean

Corresponds to the write concern's journal parameter. If TRUE, writes will require acknowledgement from MongoDB that the operation has been written to the journal. For details, see MongoDB\Driver\WriteConcern.

localThresholdMS integer

The size in milliseconds of the latency window for selecting among multiple suitable MongoDB instances while resolving a read preference. Defaults to 15 milliseconds.

maxStalenessSeconds integer

Corresponds to the read preference's "maxStalenessSeconds". Specifies, in seconds, how stale a secondary can be before the client stops using it for read operations. By default, there is no maximum staleness and clients will not consider a secondary's lag when choosing where to direct a read operation. For details, see MongoDB\Driver\ReadPreference.

If specified, the max staleness must be a signed 32-bit integer greater than or equal to MongoDB\Driver\ReadPreference::SMALLEST_MAX_STALENESS_SECONDS (i.e. 90 seconds).

password | string | The password for the user being authenticated. This option is useful if the password contains special characters, which would otherwise need to be URL encoded for the connection URI.
readConcernLevel | string | Corresponds to the read concern's level parameter. Specifies the level of read isolation. For details, see MongoDB\Driver\ReadConcern.
readPreference string

Corresponds to the read preferences's mode parameter. Defaults to "primary". For details, see MongoDB\Driver\ReadPreference.

Bilginize: This accepts a string value (e.g. "primary", "secondaryPreferred"), unlike MongoDB\Driver\ReadPreference::__construct(), which takes an integer.

readPreferenceTags array

Corresponds to the read preferences's tagSets parameter. Tag sets allow you to target read operations to specific members of a replica set. For details, see MongoDB\Driver\ReadPreference.

Bilginize: When not specified in the URI string, this option is expressed as an array consistent with the format expected by MongoDB\Driver\ReadPreference::__construct().

replicaSet string

Specifies the name of the replica set.

safe boolean

Specifies 1 for the write concern if TRUE, or 0 if FALSE For details, see MongoDB\Driver\WriteConcern.

This option is deprecated and should not be used.

serverSelectionTimeoutMS integer

Specifies how long in milliseconds to block for server selection before throwing an exception. Defaults to 30,000 milliseconds.

serverSelectionTryOnce boolean

When TRUE, instructs the driver to scan the MongoDB deployment exactly once after server selection fails and then either select a server or raise an error. When FALSE, the driver blocks and searches for a server up to the "serverSelectionTimeoutMS" value. Defaults to TRUE.

slaveOk boolean

Specifies "secondaryPreferred" for the read preference mode if TRUE. For details, see MongoDB\Driver\ReadPreference.

This option is deprecated and should not be used.

socketCheckIntervalMS integer

If a socket has not been used recently, the driver must check it via an isMaster command before using it for any operation. Defaults to 5,000 milliseconds.

socketTimeoutMS integer

The time in milliseconds to attempt a send or receive on a socket before timing out. Defaults to 300,000 milliseconds (i.e. five minutes).

ssl boolean

Initiates the connection with TLS/SSL if TRUE. Defaults to FALSE.

username | string | The username for the user being authenticated. This option is useful if the username contains special characters, which would otherwise need to be URL encoded for the connection URI.
w integer|string

Corresponds to the write concern's w parameter. For details, see MongoDB\Driver\WriteConcern.

wTimeoutMS integer|string

Corresponds to the write concern's wtimeout parameter. Specifies a time limit, in milliseconds, for the write concern. For details, see MongoDB\Driver\WriteConcern.

driverOptions

driverOptions
Option | Type | Description
allow_invalid_hostname bool

Disables hostname validation if TRUE. Defaults to FALSE.

Allowing invalid hostnames may expose the driver to a » man-in-the-middle attack.

ca_dir string

Path to a correctly hashed certificate directory. The system certificate store will be used by default.

Falls back to the deprecated "capath" SSL context option if not specified.

ca_file string

Path to a certificate authority file. The system certificate store will be used by default.

Falls back to the deprecated "cafile" SSL context option if not specified.

crl_file | string | Path to a certificate revocation list file.
pem_file string

Path to a PEM encoded certificate to use for client authentication.

Falls back to the deprecated "local_cert" SSL context option if not specified.

pem_pwd string

Passphrase for the PEM encoded certificate (if applicable).

Falls back to the deprecated "passphrase" SSL context option if not specified.

context resource

SSL context options to be used as fallbacks for other driver options (as specified). Note that the driver does not consult the default stream context.

This option is supported for backwards compatibility, but should be considered deprecated.

weak_cert_validation bool

Disables certificate validation if TRUE. Defaults to FALSE

Falls back to the deprecated "allow_self_signed" SSL context option if not specified.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\RuntimeException if the uri format is invalid

Sürüm Bilgisi

Sürüm: Açıklama
1.2.0

The uri argument defaults to "mongodb://127.0.0.1/". The default port remains 27017.

Added the "appname" URI option.

Added the "allow_invalid_hostname", "ca_file", "ca_dir", "clr_file", "pem_file", "pem_pwd", and "weak_cert_validation" driver options.

The PHP Streams API is no longer used for socket communication. The "connectTimeoutMS" URI option now defaults to 10 seconds instead of default_socket_timeout in previous versions. Additionally, the driver no longer supports all SSL context options via the "context" driver option.

1.1.0

The uri argument is optional and defaults to "mongodb://localhost:27017/".

Örnekler

Örnek 1 MongoDB\Driver\Manager::__construct() basic examples

Connecting to standalone MongoDB node:

<?php

$manager = new MongoDB\Driver\Manager("mongodb://example.com:27017");

?>

Connecting to standalone MongoDB node via a Unix domain socket. The socket path may include special characters such as slashes and should be encoded with rawurlencode().

<?php

$manager = new MongoDB\Driver\Manager("mongodb://" . rawurlencode("/tmp/mongodb-27017.sock"));

?>

Connecting to a replica set:

<?php

$manager = new MongoDB\Driver\Manager("mongodb://rs1.example.com,rs2.example.com/?replicaSet=myReplicaSet");

?>

Connecting to a sharded cluster (i.e. one or more mongos instances):

<?php

$manager = new MongoDB\Driver\Manager("mongodb://mongos1.example.com,mongos2.example.com/");

?>

Connecting to MongoDB with authentication credentials for a particular user and database:

<?php

$manager = new MongoDB\Driver\Manager("mongodb://myusername:mypassword@example.com/mydatabase");

?>

Connecting to MongoDB with authentication credentials for a particular user and database, where the username or password includes special characters (e.g. @, :, %). In the following example, the password string myp@ss:w%rd has been manually escaped; however, rawurlencode() may also be used to escape URI components that may contain special characters.

<?php

$manager = new MongoDB\Driver\Manager("mongodb://myusername:myp%40ss%3Aw%25rd@example.com/mydatabase");

?>

Connecting to MongoDB with X509 authentication:

<?php

$manager = new MongoDB\Driver\Manager(
    "mongodb://example.com/?ssl=true&authMechanism=MONGODB-X509",
    [],
    [
        "pem_file" => "/path/to/client.pem",
    ]
);
?>

Ayrıca Bakınız

  • Connection handling and persistence
  • » MongoDB Connection String Format
MongoDB\Driver\Manager
MongoDB\Driver\Manager::executeBulkWrite
MongoDB\Driver\Manager


Execute one or more write operations

MongoDB\Driver\Manager::__construct
MongoDB\Driver\Manager::executeCommand
MongoDB\Driver\Manager
PHP Manual

MongoDB\Driver\Manager::executeBulkWrite

(mongodb >=1.0.0)

MongoDB\Driver\Manager::executeBulkWrite — Execute one or more write operations

Açıklama

final public MongoDB\Driver\WriteResult MongoDB\Driver\Manager::executeBulkWrite ( string $namespace , MongoDB\Driver\BulkWrite $bulk [, MongoDB\Driver\WriteConcern $writeConcern ] )

Executes one or more write operations on the primary server.

A MongoDB\Driver\BulkWrite can be constructed with one or more write operations of varying types (e.g. updates, deletes, and inserts). The driver will attempt to send operations of the same type to the server in as few requests as possible to optimize round trips.

Değiştirgeler

namespace

A fully qualified namespace (databaseName.collectionName)

bulk (MongoDB\Driver\BulkWrite)

The MongoDB\Driver\BulkWrite to execute.

writeConcern

Optionally, a MongoDB\Driver\WriteConcern. If none given, default to the Write Concern set by the MongoDB Connection URI.

Dönen Değerler

Returns MongoDB\Driver\WriteResult on success.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\BulkWriteException on any write failure (WriteError and WriteConcern failures)
  • Throws MongoDB\Driver\AuthenticationException if authentication is needed and fails
  • Throws MongoDB\Driver\ConnectionException if connection to the server fails for other then authentication reasons
  • Throws MongoDB\Driver\Exception\RuntimeException on other errors.

Örnekler

Örnek 1 MongoDB\Driver\Manager::executeBulkWrite() example

<?php

$bulk = new MongoDB\Driver\BulkWrite();

$bulk->insert(['_id' => 1, 'x' => 1]);
$bulk->insert(['_id' => 2, 'x' => 2]);

$bulk->update(['x' => 2], ['$set' => ['x' => 1]], ['multi' => false, 'upsert' => false]);
$bulk->update(['x' => 3], ['$set' => ['x' => 3]], ['multi' => false, 'upsert' => true]);
$bulk->update(['_id' => 3], ['$set' => ['x' => 3]], ['multi' => false, 'upsert' => true]);

$bulk->insert(['_id' => 4, 'x' => 2]);

$bulk->delete(['x' => 1], ['limit' => 1]);

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017');
$writeConcern = new MongoDB\Driver\WriteConcern(MongoDB\Driver\WriteConcern::MAJORITY, 100);
$result = $manager->executeBulkWrite('db.collection', $bulk, $writeConcern);

printf("Inserted %d document(s)\n", $result->getInsertedCount());
printf("Matched  %d document(s)\n", $result->getMatchedCount());
printf("Updated  %d document(s)\n", $result->getModifiedCount());
printf("Upserted %d document(s)\n", $result->getUpsertedCount());
printf("Deleted  %d document(s)\n", $result->getDeletedCount());

foreach ($result->getUpsertedIds() as $index => $id) {
    printf('upsertedId[%d]: ', $index);
    var_dump($id);
}

/* If the WriteConcern could not be fulfilled */
if ($writeConcernError = $result->getWriteConcernError()) {
    printf("%s (%d): %s\n", $writeConcernError->getMessage(), $writeConcernError->getCode(), var_export($writeConcernError->getInfo(), true));
}

/* If a write could not happen at all */
foreach ($result->getWriteErrors() as $writeError) {
    printf("Operation#%d: %s (%d)\n", $writeError->getIndex(), $writeError->getMessage(), $writeError->getCode());
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Inserted 3 document(s)
Matched  1 document(s)
Updated  1 document(s)
Upserted 2 document(s)
Deleted  1 document(s)
upsertedId[3]: object(MongoDB\BSON\ObjectID)#5 (1) {
  ["oid"]=>
  string(24) "54d3adc3ce7a792f4d703756"
}
upsertedId[4]: int(3)

Ayrıca Bakınız

  • MongoDB\Driver\BulkWrite
  • MongoDB\Driver\WriteResult
  • MongoDB\Driver\WriteConcern
  • MongoDB\Driver\Server::executeBulkWrite() - Execute one or more write operations on this server
MongoDB\Driver\Manager::__construct
MongoDB\Driver\Manager::executeCommand
MongoDB\Driver\Manager


Execute a database command

MongoDB\Driver\Manager::executeBulkWrite
MongoDB\Driver\Manager::executeQuery
MongoDB\Driver\Manager
PHP Manual

MongoDB\Driver\Manager::executeCommand

(mongodb >=1.0.0)

MongoDB\Driver\Manager::executeCommand — Execute a database command

Açıklama

final public MongoDB\Driver\Cursor MongoDB\Driver\Manager::executeCommand ( string $db , MongoDB\Driver\Command $command [, MongoDB\Driver\ReadPreference $readPreference ] )

Executes command on a server If readPreference is provided, it will be used for server selection; otherwise, the default read preference will be used.

Değiştirgeler

db (string)

The name of the database on which to execute the command.

command (MongoDB\Driver\Command)

The MongoDB\Driver\Command to execute.

readPreference

Optionally, a MongoDB\Driver\ReadPreference to route the command to. If none given, defaults to the Read Preferences set by the MongoDB Connection URI.

Dönen Değerler

Returns MongoDB\Driver\Cursor on success.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\AuthenticationException if authentication is needed and fails
  • Throws MongoDB\Driver\ConnectionException if connection to the server fails for other then authentication reasons
  • Throws MongoDB\Driver\Exception\RuntimeException on other errors (e.g. invalid command, issuing a write command to a secondary).

Örnekler

Örnek 1 MongoDB\Driver\Manager::executeCommand() with a command returning a single result document

<?php

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017');
$command = new MongoDB\Driver\Command(['ping' => 1]);

try {
    $cursor = $manager->executeCommand('admin', $command);
} catch(MongoDB\Driver\Exception $e) {
    echo $e->getMessage(), "\n";
    exit;
}

/* The ping command returns a single result document, so we need to access the
 * first result in the cursor. */
$response = $cursor->toArray()[0];

var_dump($response);

?>

Yukarıdaki örneğin çıktısı:

array(1) {
  ["ok"]=>
  float(1)
}

Örnek 2 MongoDB\Driver\Manager::executeCommand() with a command returning a cursor

<?php

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017");

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1, 'y' => 'foo']);
$bulk->insert(['x' => 2, 'y' => 'bar']);
$bulk->insert(['x' => 3, 'y' => 'bar']);
$manager->executeBulkWrite('db.collection', $bulk);

$command = new MongoDB\Driver\Command([
    'aggregate' => 'collection',
    'pipeline' => [
        ['$group' => ['_id' => '$y', 'sum' => ['$sum' => '$x']]],
    ],
    'cursor' => new stdClass,
]);
$cursor = $manager->executeCommand('db', $command);

/* The aggregate command can optionally return its results in a cursor instead
 * of a single result document. In this case, we can iterate on the cursor
 * directly to access those results. */
foreach ($cursor as $document) {
    var_dump($document);
}

?>

Yukarıdaki örneğin çıktısı:

object(stdClass)#6 (2) {
  ["_id"]=>
  string(3) "bar"
  ["sum"]=>
  int(10)
}
object(stdClass)#7 (2) {
  ["_id"]=>
  string(3) "foo"
  ["sum"]=>
  int(2)
}

Notlar

Bilginize:

This method does not take a MongoDB\Driver\WriteConcern parameter. For write commands (e.g. » findAndModify in MongoDB 3.2+), the write concern should be included in the command document itself.

If a secondary readPreference is used, it is the caller's responsibility to ensure that the command can be executed on a secondary. No validation is done by the driver.

Ayrıca Bakınız

  • MongoDB\Driver\Command
  • MongoDB\Driver\Cursor
  • MongoDB\Driver\ReadPreference
  • MongoDB\Driver\Server::executeCommand() - Execute a database command on this server
MongoDB\Driver\Manager::executeBulkWrite
MongoDB\Driver\Manager::executeQuery
MongoDB\Driver\Manager


Execute a database query

MongoDB\Driver\Manager::executeCommand
MongoDB\Driver\Manager::getReadConcern
MongoDB\Driver\Manager
PHP Manual

MongoDB\Driver\Manager::executeQuery

(mongodb >=1.0.0)

MongoDB\Driver\Manager::executeQuery — Execute a database query

Açıklama

final public MongoDB\Driver\Cursor MongoDB\Driver\Manager::executeQuery ( string $namespace , MongoDB\Driver\Query $query [, MongoDB\Driver\ReadPreference $readPreference ] )

Executes query on a server. If readPreference is provided, it will be used for server selection; otherwise, the default read preference will be used.

Değiştirgeler

namespace

A fully qualified namespace (databaseName.collectionName)

query (MongoDB\Driver\Query)

The MongoDB\Driver\Query to execute.

readPreference

Optionally, a MongoDB\Driver\ReadPreference to route the command to. If none given, defaults to the Read Preferences set by the MongoDB Connection URI.

Dönen Değerler

Returns MongoDB\Driver\Cursor on success.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\AuthenticationException if authentication is needed and fails
  • Throws MongoDB\Driver\ConnectionException if connection to the server fails for other then authentication reasons
  • Throws MongoDB\Driver\Exception\RuntimeException on other errors (e.g. invalid query operators).

Örnekler

Örnek 1 MongoDB\Driver\Manager::executeQuery() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017");

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);
$bulk->insert(['x' => 2]);
$bulk->insert(['x' => 3]);
$manager->executeBulkWrite('db.collection', $bulk);

$filter = ['x' => ['$gt' => 1]];
$options = [
    'projection' => ['_id' => 0],
    'sort' => ['x' => -1],
];

$query = new MongoDB\Driver\Query($filter, $options);
$cursor = $manager->executeQuery('db.collection', $query);

foreach ($cursor as $document) {
    var_dump($document);
}

?>

Yukarıdaki örneğin çıktısı:

object(stdClass)#6 (1) {
  ["x"]=>
  int(3)
}
object(stdClass)#7 (1) {
  ["x"]=>
  int(2)
}

Ayrıca Bakınız

  • MongoDB\Driver\Cursor
  • MongoDB\Driver\Query
  • MongoDB\Driver\ReadPreference
  • MongoDB\Driver\Server::executeQuery() - Execute a database query on this server
MongoDB\Driver\Manager::executeCommand
MongoDB\Driver\Manager::getReadConcern
MongoDB\Driver\Manager


Return the ReadConcern for the Manager

MongoDB\Driver\Manager::executeQuery
MongoDB\Driver\Manager::getReadPreference
MongoDB\Driver\Manager
PHP Manual

MongoDB\Driver\Manager::getReadConcern

(mongodb >=1.1.0)

MongoDB\Driver\Manager::getReadConcern — Return the ReadConcern for the Manager

Açıklama

final public MongoDB\Driver\ReadConcern MongoDB\Driver\Manager::getReadConcern ( void )

Returns the MongoDB\Driver\ReadConcern for the Manager, which is derived from its URI options. This is the default read concern for queries and commands executed on the Manager.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The MongoDB\Driver\ReadConcern for the Manager.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\Manager::getReadConcern() example

<?php

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017');
var_dump($manager->getReadConcern());

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017/?readConcernLevel=local');
var_dump($manager->getReadConcern());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(MongoDB\Driver\ReadConcern)#2 (0) {
}
object(MongoDB\Driver\ReadConcern)#1 (1) {
  ["level"]=>
  string(5) "local"
}

Ayrıca Bakınız

  • MongoDB\Driver\ReadConcern
  • MongoDB\Driver\Manager::__construct() - Create new MongoDB Manager
MongoDB\Driver\Manager::executeQuery
MongoDB\Driver\Manager::getReadPreference
MongoDB\Driver\Manager


Return the ReadPreference for the Manager

MongoDB\Driver\Manager::getReadConcern
MongoDB\Driver\Manager::getServers
MongoDB\Driver\Manager
PHP Manual

MongoDB\Driver\Manager::getReadPreference

(mongodb >=1.0.0)

MongoDB\Driver\Manager::getReadPreference — Return the ReadPreference for the Manager

Açıklama

final public MongoDB\Driver\ReadPreference MongoDB\Driver\Manager::getReadPreference ( void )

Returns the MongoDB\Driver\ReadPreference for the Manager, which is derived from its URI options. This is the default read preference for queries and commands executed on the Manager.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The MongoDB\Driver\ReadPreference for the Manager.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\Manager::getReadPreference() example

<?php

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017');
var_dump($manager->getReadPreference());

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017/?readPreference=secondaryPreferred&readPreferenceTags=dc:ny,rack:1&readPreferenceTags=dc:ny&readPreferenceTags=');
var_dump($manager->getReadPreference());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(MongoDB\Driver\ReadPreference)#2 (1) {
  ["mode"]=>
  string(7) "primary"
}
object(MongoDB\Driver\ReadPreference)#1 (2) {
  ["mode"]=>
  string(18) "secondaryPreferred"
  ["tags"]=>
  array(3) {
    [0]=>
    object(stdClass)#3 (2) {
      ["dc"]=>
      string(2) "ny"
      ["rack"]=>
      string(1) "1"
    }
    [1]=>
    object(stdClass)#4 (1) {
      ["dc"]=>
      string(2) "ny"
    }
    [2]=>
    object(stdClass)#5 (0) {
    }
  }
}

Ayrıca Bakınız

  • MongoDB\Driver\ReadPreference
  • MongoDB\Driver\Manager::__construct() - Create new MongoDB Manager
MongoDB\Driver\Manager::getReadConcern
MongoDB\Driver\Manager::getServers
MongoDB\Driver\Manager


Return the servers to which this manager is connected

MongoDB\Driver\Manager::getReadPreference
MongoDB\Driver\Manager::getWriteConcern
MongoDB\Driver\Manager
PHP Manual

MongoDB\Driver\Manager::getServers

(mongodb >=1.0.0)

MongoDB\Driver\Manager::getServers — Return the servers to which this manager is connected

Açıklama

final public array MongoDB\Driver\Manager::getServers ( void )

Returns an array of MongoDB\Driver\Server instances to which this manager is connected.

Bilginize:

Since the driver connects to the database lazily, this method may return an empty array if called before executing an operation on the MongoDB\Driver\Manager.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array of MongoDB\Driver\Server instances to which this manager is connected.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\Manager::getServers() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017");

/* The driver connects to the database server lazily, so Manager::getServers()
 * may initially return an empty array. */
var_dump($manager->getServers());

$command = new MongoDB\Driver\Command(['ping' => 1]);
$manager->executeCommand('db', $command);

var_dump($manager->getServers());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(0) {
}
array(1) {
  [0]=>
  object(MongoDB\Driver\Server)#3 (10) {
    ["host"]=>
    string(9) "localhost"
    ["port"]=>
    int(27017)
    ["type"]=>
    int(1)
    ["is_primary"]=>
    bool(false)
    ["is_secondary"]=>
    bool(false)
    ["is_arbiter"]=>
    bool(false)
    ["is_hidden"]=>
    bool(false)
    ["is_passive"]=>
    bool(false)
    ["last_is_master"]=>
    array(8) {
      ["ismaster"]=>
      bool(true)
      ["maxBsonObjectSize"]=>
      int(16777216)
      ["maxMessageSizeBytes"]=>
      int(48000000)
      ["maxWriteBatchSize"]=>
      int(1000)
      ["localTime"]=>
      object(MongoDB\BSON\UTCDateTime)#4 (1) {
        ["milliseconds"]=>
        int(1447267964517)
      }
      ["maxWireVersion"]=>
      int(3)
      ["minWireVersion"]=>
      int(0)
      ["ok"]=>
      float(1)
    }
    ["round_trip_time"]=>
    int(554)
  }
}

Ayrıca Bakınız

  • MongoDB\Driver\Server
  • MongoDB\Driver\Manager::selectServer() - Select a server matching a read preference
MongoDB\Driver\Manager::getReadPreference
MongoDB\Driver\Manager::getWriteConcern
MongoDB\Driver\Manager


Return the WriteConcern for the Manager

MongoDB\Driver\Manager::getServers
MongoDB\Driver\Manager::selectServer
MongoDB\Driver\Manager
PHP Manual

MongoDB\Driver\Manager::getWriteConcern

(mongodb >=1.0.0)

MongoDB\Driver\Manager::getWriteConcern — Return the WriteConcern for the Manager

Açıklama

final public MongoDB\Driver\WriteConcern MongoDB\Driver\Manager::getWriteConcern ( void )

Returns the MongoDB\Driver\WriteConcern for the Manager, which is derived from its URI options. This is the default write concern for writes and commands executed on the Manager.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The MongoDB\Driver\WriteConcern for the Manager.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\Manager::getWriteConcern() example

<?php

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017');
var_dump($manager->getWriteConcern());

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017/?w=majority&wtimeoutMS=2000');
var_dump($manager->getWriteConcern());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(MongoDB\Driver\WriteConcern)#2 (0) {
}
object(MongoDB\Driver\WriteConcern)#1 (2) {
  ["w"]=>
  string(8) "majority"
  ["wtimeout"]=>
  int(2000)
}

Ayrıca Bakınız

  • MongoDB\Driver\WriteConcern
  • MongoDB\Driver\Manager::__construct() - Create new MongoDB Manager
MongoDB\Driver\Manager::getServers
MongoDB\Driver\Manager::selectServer
MongoDB\Driver\Manager


Select a server matching a read preference

MongoDB\Driver\Manager::getWriteConcern
MongoDB\Driver\Command
MongoDB\Driver\Manager
PHP Manual

MongoDB\Driver\Manager::selectServer

(mongodb >=1.0.0)

MongoDB\Driver\Manager::selectServer — Select a server matching a read preference

Açıklama

final public MongoDB\Driver\Server MongoDB\Driver\Manager::selectServer ( MongoDB\Driver\ReadPreference $readPreference )

Selects a MongoDB\Driver\Server matching readPreference. This may be used to preselect a server in order to perform version checking before executing an operation.

Bilginize:

Unlike MongoDB\Driver\Manager::getServers(), this method will initialize database connections and perform server discovery if necessary. See the » Server Selection Specification for additional information.

Değiştirgeler

readPreference

Optionally, a MongoDB\Driver\ReadPreference to route the command to. If none given, defaults to the Read Preferences set by the MongoDB Connection URI.

Dönen Değerler

Returns an MongoDB\Driver\Server matching the read preference.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\AuthenticationException if authentication is needed and fails
  • Throws MongoDB\Driver\ConnectionException if connection to the server fails for other then authentication reasons
  • Throws MongoDB\Driver\Exception\RuntimeException if a server matching the read preference could not be found.

Ayrıca Bakınız

  • MongoDB\Driver\Server
  • MongoDB\Driver\Manager::getServers() - Return the servers to which this manager is connected
  • » Server Selection Specification
MongoDB\Driver\Manager::getWriteConcern
MongoDB\Driver\Command
MongoDB\Driver\Manager


The MongoDB\Driver\Command class

(mongodb >=1.0.0)

Giriş

The MongoDB\Driver\Command class is a value object that represents a database command.

To provide "Command Helpers" the MongoDB\Driver\Command object should be composed.

Sınıf Sözdizimi

final MongoDB\Driver\Command {
/* Yöntemler */
final public __construct ( array|object $document )
}

Örnekler

Örnek 1 Composing MongoDB\Driver\Command to provide a helper to create collections

<?php
class CreateCollection {
    protected $cmd = array();

    function __construct($collectionName) {
        $this->cmd["create"] = (string)$collectionName;
    }
    function setAutoIndexId($bool) {
        $this->cmd["autoIndexId"] = (bool)$bool;
    }
    function setCappedCollection($maxBytes, $maxDocuments = false) {
        $this->cmd["capped"] = true;
        $this->cmd["size"]   = (int)$maxBytes;

        if ($maxDocuments) {
            $this->cmd["max"] = (int)$maxDocuments;
        }
    }
    function usePowerOf2Sizes($bool) {
        if ($bool) {
            $this->cmd["flags"] = 1;
        } else {
            $this->cmd["flags"] = 0;
        }
    }
    function setFlags($flags) {
        $this->cmd["flags"] = (int)$flags;
    }
    function getCommand() {
        return new MongoDB\Driver\Command($this->cmd);
    }
    function getCollectionName() {
        return $this->cmd["create"];
    }
}

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017");

$createCollection = new CreateCollection("cappedCollection");
$createCollection->setCappedCollection(64 * 1024);

try {
    $command = $createCollection->getCommand();
    $cursor = $manager->executeCommand("databaseName", $command);
    $response = $cursor->toArray()[0];
    var_dump($response);

    $collstats = ["collstats" => $createCollection->getCollectionName()];
    $cursor = $manager->executeCommand("databaseName", new MongoDB\Driver\Command($collstats));
    $response = $cursor->toArray()[0];
    var_dump($response);
} catch(MongoDB\Driver\Exception $e) {
    echo $e->getMessage(), "\n";
    exit;
}

?>

Yukarıdaki örneğin çıktısı:

object(MongoDB\Driver\Command)#3 (1) {
  ["command"]=>
  array(3) {
    ["create"]=>
    string(16) "cappedCollection"
    ["capped"]=>
    bool(true)
    ["size"]=>
    int(65536)
  }
}
array(1) {
  ["ok"]=>
  float(1)
}
array(16) {
  ["ns"]=>
  string(29) "databaseName.cappedCollection"
  ["count"]=>
  int(0)
  ["size"]=>
  int(0)
  ["numExtents"]=>
  int(1)
  ["storageSize"]=>
  int(65536)
  ["nindexes"]=>
  int(1)
  ["lastExtentSize"]=>
  float(65536)
  ["paddingFactor"]=>
  float(1)
  ["paddingFactorNote"]=>
  string(101) "paddingFactor is unused and unmaintained in 2.8. It remains hard coded to 1.0 for compatibility only."
  ["userFlags"]=>
  int(0)
  ["capped"]=>
  bool(true)
  ["max"]=>
  int(9223372036854775807)
  ["maxSize"]=>
  int(65536)
  ["totalIndexSize"]=>
  int(8176)
  ["indexSizes"]=>
  object(stdClass)#4 (1) {
    ["_id_"]=>
    int(8176)
  }
  ["ok"]=>
  float(1)
}

İçindekiler

  • MongoDB\Driver\Command::__construct — Create a new Command
MongoDB\Driver\Manager::selectServer
MongoDB\Driver\Command::__construct
MongoDB\Driver


Create a new Command

MongoDB\Driver\Command
MongoDB\Driver\Query
MongoDB\Driver\Command
PHP Manual

MongoDB\Driver\Command::__construct

(mongodb >=1.0.0)

MongoDB\Driver\Command::__construct — Create a new Command

Açıklama

final public MongoDB\Driver\Command::__construct ( array|object $document )

Değiştirgeler

document

The complete command to construct

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\Command::__construct() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017");
$command = new MongoDB\Driver\Command(array("buildinfo" => 1));

try {
    $cursor = $manager->executeCommand("admin", $command);
    $response = $cursor->toArray()[0];
} catch(MongoDB\Driver\Exception $e) {
    echo $e->getMessage(), "\n";
    exit;
}
var_dump($response);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(13) {
  ["version"]=>
  string(14) "2.8.0-rc2-pre-"
  ["gitVersion"]=>
  string(62) "b743d7158f7642f4da6b7eac8320374b3b88dc2e modules: subscription"
  ["OpenSSLVersion"]=>
  string(25) "OpenSSL 1.0.1f 6 Jan 2014"
  ["sysInfo"]=>
  string(104) "Linux infant 3.16.0-24-generic #32-Ubuntu SMP Tue Oct 28 13:07:32 UTC 2014 x86_64 BOOST_LIB_VERSION=1_49"
  ["loaderFlags"]=>
  string(91) "-fPIC -pthread -Wl,-z,now -rdynamic -Wl,-Bsymbolic-functions -Wl,-z,relro -Wl,-z,now -Wl,-E"
  ["compilerFlags"]=>
  string(301) "-Wnon-virtual-dtor -Woverloaded-virtual -std=c++11 -fPIC -fno-strict-aliasing -ggdb -pthread -Wall -Wsign-compare -Wno-unknown-pragmas -Winvalid-pch -pipe -Werror -O3 -Wno-unused-local-typedefs -Wno-unused-function -Wno-deprecated-declarations -Wno-unused-but-set-variable -fno-builtin-memcmp -std=c99"
  ["allocator"]=>
  string(8) "tcmalloc"
  ["versionArray"]=>
  array(4) {
    [0]=>
    int(2)
    [1]=>
    int(8)
    [2]=>
    int(0)
    [3]=>
    int(-8)
  }
  ["javascriptEngine"]=>
  string(2) "V8"
  ["bits"]=>
  int(64)
  ["debug"]=>
  bool(false)
  ["maxBsonObjectSize"]=>
  int(16777216)
  ["ok"]=>
  float(1)
}

Ayrıca Bakınız

  • MongoDB\Driver\Manager::executeCommand() - Execute a database command
  • MongoDB\Driver\Cursor
MongoDB\Driver\Command
MongoDB\Driver\Query
MongoDB\Driver\Command


The MongoDB\Driver\Query class

(mongodb >=1.0.0)

Giriş

The MongoDB\Driver\Query class is a value object that represents a database query.

Sınıf Sözdizimi

final MongoDB\Driver\Query {
/* Yöntemler */
final public __construct ( array|object $filter [, array $queryOptions ] )
}

İçindekiler

  • MongoDB\Driver\Query::__construct — Construct new Query
MongoDB\Driver\Command::__construct
MongoDB\Driver\Query::__construct
MongoDB\Driver


Construct new Query

MongoDB\Driver\Query
MongoDB\Driver\BulkWrite
MongoDB\Driver\Query
PHP Manual

MongoDB\Driver\Query::__construct

(mongodb >=1.0.0)

MongoDB\Driver\Query::__construct — Construct new Query

Açıklama

final public MongoDB\Driver\Query::__construct ( array|object $filter [, array $queryOptions ] )

Değiştirgeler

filter (array|object)

The search filter.

queryOptions

queryOptions
Option | Type | Description
allowPartialResults bool

For queries against a sharded collection, returns partial results from the mongos if some shards are unavailable instead of throwing an error.

Falls back to the deprecated "partial" option if not specified.

awaitData | bool | Use in conjunction with the "tailable" option to block a getMore operation on the cursor temporarily if at the end of data rather than returning no data. After a timeout period, the query returns as normal.
batchSize integer

The number of documents to return in the first batch. Defaults to 101. A batch size of 0 means that the cursor will be established, but no documents will be returned in the first batch.

In versions of MongoDB before 3.2, where queries use the legacy wire protocol OP_QUERY, a batch size of 1 will close the cursor irrespective of the number of matched documents.

collation array|object

» Collation allows users to specify language-specific rules for string comparison, such as rules for lettercase and accent marks. When specifying collation, the "locale" field is mandatory; all other collation fields are optional. For descriptions of the fields, see » Collation Document.

If the collation is unspecified but the collection has a default collation, the operation uses the collation specified for the collection. If no collation is specified for the collection or for the operation, MongoDB uses the simple binary comparison used in prior versions for string comparisons.

This option is available in MongoDB 3.4+ and will result in an exception at execution time if specified for an older server version.

comment string

A comment to attach to the query to help interpret and trace query profile data.

Falls back to the deprecated "$comment" modifier if not specified.

exhaust bool

Stream the data down full blast in multiple "more" packages, on the assumption that the client will fully read all data queried. Faster when you are pulling a lot of data and know you want to pull it all down. Note: the client is not allowed to not read all the data unless it closes the connection.

This option is not supported by the find command in MongoDB 3.2+ and will force the driver to use the legacy wire protocol version (i.e. OP_QUERY).

explain bool

If TRUE, the returned MongoDB\Driver\Cursor will contain a single document that describes the process and indexes used to return the query.

Falls back to the deprecated "$explain" modifier if not specified.

This option is not supported by the find command in MongoDB 3.2+ and will only be respected when using the legacy wire protocol version (i.e. OP_QUERY). The » explain command should be used on MongoDB 3.0+.

hint string|array|object

Index specification. Specify either the index name as a string or the index key pattern. If specified, then the query system will only consider plans using the hinted index.

Falls back to the deprecated "hint" option if not specified.

limit integer

The maximum number of documents to return. If unspecified, then defaults to no limit. A limit of 0 is equivalent to setting no limit.

A negative limit is will be interpreted as a positive limit with the "singleBatch" option set to TRUE. This behavior is supported for backwards compatibility, but should be considered deprecated.

max array|object

The exclusive upper bound for a specific index.

Falls back to the deprecated "$max" modifier if not specified.

maxScan integer

Positive integer denoting the maximum number of documents or index keys to scan when executing the query.

Falls back to the deprecated "$maxScan" modifier if not specified.

maxTimeMS integer

The cumulative time limit in milliseconds for processing operations on the cursor. MongoDB aborts the operation at the earliest following interrupt point.

Falls back to the deprecated "$maxTimeMS" modifier if not specified.

min array|object

The inclusive lower bound for a specific index.

Falls back to the deprecated "$min" modifier if not specified.

modifiers | array | » Meta operators modifying the output or behavior of a query. Use of these operators is deprecated in favor of named options.
noCursorTimeout | bool | Prevents the server from timing out idle cursors after an inactivity period (10 minutes).
oplogReplay bool

Internal use for replica sets. To use oplogReplay, you must include the following condition in the filter:

[ 'ts' => [ '$gte' => <timestamp> ] ]
projection | array|object | The » projection specification to determine which fields to include in the returned documents.
returnKey bool

If TRUE, returns only the index keys in the resulting documents. Default value is FALSE. If TRUE and the find command does not use an index, the returned documents will be empty.

Falls back to the deprecated "$returnKey" modifier if not specified.

showRecordId bool

Determines whether to return the record identifier for each document. If TRUE, adds a top-level "$recordId" field to the returned documents.

Falls back to the deprecated "$showDiskLoc" modifier if not specified.

singleBatch | bool | Determines whether to close the cursor after the first batch. Defaults to FALSE.
readConcern MongoDB\Driver\ReadConcern

Specifies the » read concern. The default level is "local".

To use a read concern level of "majority", you must use the WiredTiger storage engine with MongoDB 3.2+ and enable the feature in the server configuration.

skip | integer | Number of documents to skip. Defaults to 0.
slaveOk | bool | Allow query of replica set secondaries
sort array|object

The sort specification for the ordering of the results.

Falls back to the deprecated "$orderby" modifier if not specified.

snapshot bool

Prevents the cursor from returning a document more than once because of an intervening write operation.

Falls back to the deprecated "$snapshot" modifier if not specified.

tailable | bool | Returns a tailable cursor for a capped collection.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Sürüm Bilgisi

Sürüm: Açıklama
1.2.0

Added the "allowPartialResults", "collation", "comment", "hint", "max", "maxScan", "maxTimeMS", "min", "returnKey", "showRecordId", and "snapshot" options.

Renamed the "partial" option to "allowPartialResults". For backwards compatibility, "partial" will still be read if "allowPartialResults" is not specified.

Removed the "slaveOk" option, which is obsolete. For queries using the legacy wire protocol OP_QUERY, the driver will set the slaveOk bit as needed in accordance with the » Server Selection Specification.

1.1.0 Added the "readConcern" option.

Örnekler

Örnek 1 MongoDB\Driver\Query::__construct() example

<?php
/* Select only documents authord by "bjori" with at least 100 views */
$filter = [
    'author' => 'bjori',
    'views' => [
        '$gte' => 100,
    ],
];

$options = [
    /* Only return the following fields in the matching documents */
    'projection' => [
        'title' => 1,
        'article' => 1,
    ],
    /* Return the documents in descending order of views */
    'sort' => [
        'views' => -1
    ],
);

$query = new MongoDB\Driver\Query($filter, $options);

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017');
$readPreference = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_PRIMARY);
$cursor = $manager->executeQuery('databaseName.collectionName', $query, $readPreference);

foreach($cursor as $document) {
    var_dump($document);
}

?>

Ayrıca Bakınız

  • MongoDB\Driver\Manager::executeQuery() - Execute a database query
  • MongoDB\Driver\Cursor
MongoDB\Driver\Query
MongoDB\Driver\BulkWrite
MongoDB\Driver\Query


The MongoDB\Driver\BulkWrite class

(mongodb >=1.0.0)

Giriş

The MongoDB\Driver\BulkWrite collects one or more write operations that should be sent to the server. After adding any number of insert, update, and delete operations, the collection may be executed via MongoDB\Driver\Manager::executeBulkWrite().

Write operations may either be ordered (default) or unordered. Ordered write operations are sent to the server, in the order provided, for serial execution. If a write fails, any remaining operations will be aborted. Unordered operations are sent to the server in an arbitrary order where they may be executed in parallel. Any errors that occur are reported after all operations have been attempted.

Sınıf Sözdizimi

final MongoDB\Driver\BulkWrite implements Countable {
/* Yöntemler */
public __construct ([ array $options ] )
public int count ( void )
public void delete ( array|object $filter [, array $deleteOptions ] )
public mixed insert ( array|object $document )
public void update ( array|object $filter , array|object $newObj [, array $updateOptions ] )
}

Örnekler

Örnek 1 Mixed write operations are grouped by type

Mixed write operations (i.e. inserts, updates, and deletes) will be assembled into typed write commands to be sent sequentially to the server.

<?php

$bulk = new MongoDB\Driver\BulkWrite(['ordered' => true]);
$bulk->insert(['_id' => 1, 'x' => 1]);
$bulk->insert(['_id' => 2, 'x' => 2]);
$bulk->update(['x' => 2], ['$set' => ['x' => 1]]);
$bulk->insert(['_id' => 3, 'x' => 3]);
$bulk->delete(['x' => 1]);

?>

Will result in four write commands (i.e. roundtrips) being executed. Since the operations are ordered, the third insertion cannot be sent until the preceding update is executed.

Örnek 2 Ordered write operations causing an error

<?php

$bulk = new MongoDB\Driver\BulkWrite(['ordered' => true]);
$bulk->delete([]);
$bulk->insert(['_id' => 1]);
$bulk->insert(['_id' => 2]);
$bulk->insert(['_id' => 3, 'hello' => 'world']);
$bulk->update(['_id' => 3], ['$set' => ['hello' => 'earth']]);
$bulk->insert(['_id' => 4, 'hello' => 'pluto']);
$bulk->update(['_id' => 4], ['$set' => ['hello' => 'moon']]);
$bulk->insert(['_id' => 3]);
$bulk->insert(['_id' => 4]);
$bulk->insert(['_id' => 5]);

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017');
$writeConcern = new MongoDB\Driver\WriteConcern(MongoDB\Driver\WriteConcern::MAJORITY, 1000);

try {
    $result = $manager->executeBulkWrite('db.collection', $bulk, $writeConcern);
} catch (MongoDB\Driver\Exception\BulkWriteException $e) {
    $result = $e->getWriteResult();

    // Check if the write concern could not be fulfilled
    if ($writeConcernError = $result->getWriteConcernError()) {
        printf("%s (%d): %s\n",
            $writeConcernError->getMessage(),
            $writeConcernError->getCode(),
            var_export($writeConcernError->getInfo(), true)
        );
    }

    // Check if any write operations did not complete at all
    foreach ($result->getWriteErrors() as $writeError) {
        printf("Operation#%d: %s (%d)\n",
            $writeError->getIndex(),
            $writeError->getMessage(),
            $writeError->getCode()
        );
    }
} catch (MongoDB\Driver\Exception\Exception $e) {
    printf("Other error: %s\n", $e->getMessage());
    exit;
}

printf("Inserted %d document(s)\n", $result->getInsertedCount());
printf("Updated  %d document(s)\n", $result->getModifiedCount());

?>

Yukarıdaki örneğin çıktısı:

Operation#7: E11000 duplicate key error index: db.collection.$_id_ dup key: { : 3 } (11000)
Inserted 4 document(s)
Updated  2 document(s)

If the write concern could not be fullfilled, the example above would output something like:

waiting for replication timed out (64): array (
  'wtimeout' => true,
)
Operation#7: E11000 duplicate key error index: databaseName.collectionName.$_id_ dup key: { : 3 } (11000)
Inserted 4 document(s)
Updated  2 document(s)

If we execute the example above, but allow for unordered writes:

<?php

$bulk = new MongoDB\Driver\BulkWrite(['ordered' => false]);
/* ... */

?>

Yukarıdaki örneğin çıktısı:

Operation#7: E11000 duplicate key error index: db.collection.$_id_ dup key: { : 3 } (11000)
Operation#8: E11000 duplicate key error index: db.collection.$_id_ dup key: { : 4 } (11000)
Inserted 5 document(s)
Updated  2 document(s)

Ayrıca Bakınız

  • MongoDB\Driver\Manager::executeBulkWrite()
  • MongoDB\Driver\WriteResult
  • MongoDB\Driver\WriteConcern
  • MongoDB\Driver\WriteConcernError
  • MongoDB\Driver\WriteError

İçindekiler

  • MongoDB\Driver\BulkWrite::__construct — Create a new BulkWrite
  • MongoDB\Driver\BulkWrite::count — Count number of write operations in the bulk
  • MongoDB\Driver\BulkWrite::delete — Add a delete operation to the bulk
  • MongoDB\Driver\BulkWrite::insert — Add an insert operation to the bulk
  • MongoDB\Driver\BulkWrite::update — Add an update operation to the bulk
MongoDB\Driver\Query::__construct
MongoDB\Driver\BulkWrite::__construct
MongoDB\Driver


Create a new BulkWrite

MongoDB\Driver\BulkWrite
MongoDB\Driver\BulkWrite::count
MongoDB\Driver\BulkWrite
PHP Manual

MongoDB\Driver\BulkWrite::__construct

(mongodb >=1.0.0)

MongoDB\Driver\BulkWrite::__construct — Create a new BulkWrite

Açıklama

public MongoDB\Driver\BulkWrite::__construct ([ array $options ] )

Constructs a new ordered (default) or unordered MongoDB\Driver\BulkWrite.

Değiştirgeler

options (array)

options
Option | Type | Description | Default
ordered | bool | Ordered operations (TRUE) are executed serially on the MongoDB server, while unordered operations (FALSE) are sent to the server in an arbitrary order and may be executed in parallel. | TRUE

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\BulkWrite::__construct() example

<?php

$bulk = new MongoDB\Driver\BulkWrite(['ordered' => true]);
$bulk->delete([]);
$bulk->insert(['_id' => 1, 'x' => 1]);
$bulk->insert(['_id' => 2, 'x' => 2]);
$bulk->update(
    ['x' => 2],
    ['$set' => ['x' => 1]],
    ['limit' => 1, 'upsert' => false]
);
$bulk->delete(['x' => 1], ['limit' => 1]);
$bulk->update(
    ['_id' => 3],
    ['$set' => ['x' => 3]],
    ['limit' => 1, 'upsert' => true]
);

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017');
$writeConcern = new MongoDB\Driver\WriteConcern(MongoDB\Driver\WriteConcern::MAJORITY, 1000);

try {
    $result = $manager->executeBulkWrite('db.collection', $bulk, $writeConcern);
} catch (MongoDB\Driver\Exception\BulkWriteException $e) {
    $result = $e->getWriteResult();

    // Check if the write concern could not be fulfilled
    if ($writeConcernError = $result->getWriteConcernError()) {
        printf("%s (%d): %s\n",
            $writeConcernError->getMessage(),
            $writeConcernError->getCode(),
            var_export($writeConcernError->getInfo(), true)
        );
    }

    // Check if any write operations did not complete at all
    foreach ($result->getWriteErrors() as $writeError) {
        printf("Operation#%d: %s (%d)\n",
            $writeError->getIndex(),
            $writeError->getMessage(),
            $writeError->getCode()
        );
    }
} catch (MongoDB\Driver\Exception\Exception $e) {
    printf("Other error: %s\n", $e->getMessage());
    exit;
}

printf("Inserted %d document(s)\n", $result->getInsertedCount());
printf("Updated  %d document(s)\n", $result->getModifiedCount());
printf("Upserted %d document(s)\n", $result->getUpsertedCount());
printf("Deleted  %d document(s)\n", $result->getDeletedCount());

?>

Yukarıdaki örneğin çıktısı:

Inserted 2 document(s)
Updated  1 document(s)
Upserted 1 document(s)
Deleted  1 document(s)

Ayrıca Bakınız

  • MongoDB\Driver\Manager::executeBulkWrite() - Execute one or more write operations
  • MongoDB\Driver\WriteResult
MongoDB\Driver\BulkWrite
MongoDB\Driver\BulkWrite::count
MongoDB\Driver\BulkWrite


Count number of write operations in the bulk

MongoDB\Driver\BulkWrite::__construct
MongoDB\Driver\BulkWrite::delete
MongoDB\Driver\BulkWrite
PHP Manual

MongoDB\Driver\BulkWrite::count

(mongodb >=1.0.0)

MongoDB\Driver\BulkWrite::count — Count number of write operations in the bulk

Açıklama

public int MongoDB\Driver\BulkWrite::count ( void )

Returns the number of write operations added to the MongoDB\Driver\BulkWrite object.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns number of write operations added to the MongoDB\Driver\BulkWrite object.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Sürüm Bilgisi

Sürüm: | Açıklama
1.2.0 | Returns the number of write operations added to the MongoDB\Driver\BulkWrite object. Earlier versions returned the expected number of client-to-server roundtrips required to execute all write operations.

Örnekler

Örnek 1 MongoDB\Driver\BulkWrite::count() example

<?php

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['_id' => 1, 'x' => 1]);
$bulk->insert(['_id' => 2, 'x' => 2]);
$bulk->update(['x' => 2], ['$set' => ['x' => 1]]);
$bulk->delete(['x' => 1]);

var_dump(count($bulk));

?>

Yukarıdaki örneğin çıktısı:

int(4)
MongoDB\Driver\BulkWrite::__construct
MongoDB\Driver\BulkWrite::delete
MongoDB\Driver\BulkWrite


Add a delete operation to the bulk

MongoDB\Driver\BulkWrite::count
MongoDB\Driver\BulkWrite::insert
MongoDB\Driver\BulkWrite
PHP Manual

MongoDB\Driver\BulkWrite::delete

(mongodb >=1.0.0)

MongoDB\Driver\BulkWrite::delete — Add a delete operation to the bulk

Açıklama

public void MongoDB\Driver\BulkWrite::delete ( array|object $filter [, array $deleteOptions ] )

Adds a delete operation to the MongoDB\Driver\BulkWrite.

Değiştirgeler

filter (array|object)

The search filter.

deleteOptions

deleteOptions
Option | Type | Description | Default
collation array|object

» Collation allows users to specify language-specific rules for string comparison, such as rules for lettercase and accent marks. When specifying collation, the "locale" field is mandatory; all other collation fields are optional. For descriptions of the fields, see » Collation Document.

If the collation is unspecified but the collection has a default collation, the operation uses the collation specified for the collection. If no collation is specified for the collection or for the operation, MongoDB uses the simple binary comparison used in prior versions for string comparisons.

This option is available in MongoDB 3.4+ and will result in an exception at execution time if specified for an older server version.

limit | bool | Delete all matching documents (FALSE), or only the first matching document (TRUE) | FALSE

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Sürüm Bilgisi

Sürüm: | Açıklama
1.2.0 | Added the "collation" option.

Örnekler

Örnek 1 MongoDB\Driver\BulkWrite::delete() example

<?php

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->delete(['x' => 1], ['limit' => 1]);
$bulk->delete(['x' => 2], ['limit' => 0]);

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017');
$writeConcern = new MongoDB\Driver\WriteConcern(MongoDB\Driver\WriteConcern::MAJORITY, 1000);
$result = $manager->executeBulkWrite('db.collection', $bulk, $writeConcern);

?>

Ayrıca Bakınız

  • MongoDB\Driver\Manager::executeBulkWrite() - Execute one or more write operations
  • MongoDB\Driver\WriteResult
MongoDB\Driver\BulkWrite::count
MongoDB\Driver\BulkWrite::insert
MongoDB\Driver\BulkWrite


Add an insert operation to the bulk

MongoDB\Driver\BulkWrite::delete
MongoDB\Driver\BulkWrite::update
MongoDB\Driver\BulkWrite
PHP Manual

MongoDB\Driver\BulkWrite::insert

(mongodb >=1.0.0)

MongoDB\Driver\BulkWrite::insert — Add an insert operation to the bulk

Açıklama

public mixed MongoDB\Driver\BulkWrite::insert ( array|object $document )

Adds an insert operation to the MongoDB\Driver\BulkWrite.

Değiştirgeler

document (array|object)

A document to insert.

Dönen Değerler

If the document did not have an _id, a MongoDB\BSON\ObjectID will be generated and returned; otherwise, no value is returned.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\BulkWrite::insert() example

<?php

$bulk = new MongoDB\Driver\BulkWrite;

$document1 = ['title' => 'one'];
$document2 = ['_id' => 'custom ID', 'title' => 'two'];
$document3 = ['_id' => new MongoDB\BSON\ObjectID, 'title' => 'three'];

$_id1 = $bulk->insert($document1);
$_id2 = $bulk->insert($document2);
$_id3 = $bulk->insert($document3);

var_dump($_id1, $_id2, $_id3);

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017');
$writeConcern = new MongoDB\Driver\WriteConcern(MongoDB\Driver\WriteConcern::MAJORITY, 1000);
$result = $manager->executeBulkWrite('db.collection', $bulk, $writeConcern);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(MongoDB\BSON\ObjectID)#3 (1) {
  ["oid"]=>
  string(24) "54d51146bd21b91405401d92"
}
NULL
NULL

Ayrıca Bakınız

  • MongoDB\Driver\Manager::executeBulkWrite() - Execute one or more write operations
  • MongoDB\Driver\WriteResult
  • MongoDB\BSON\ObjectID
  • MongoDB\BSON\Persistable
MongoDB\Driver\BulkWrite::delete
MongoDB\Driver\BulkWrite::update
MongoDB\Driver\BulkWrite


Add an update operation to the bulk

MongoDB\Driver\BulkWrite::insert
MongoDB\Driver\WriteConcern
MongoDB\Driver\BulkWrite
PHP Manual

MongoDB\Driver\BulkWrite::update

(mongodb >=1.0.0)

MongoDB\Driver\BulkWrite::update — Add an update operation to the bulk

Açıklama

public void MongoDB\Driver\BulkWrite::update ( array|object $filter , array|object $newObj [, array $updateOptions ] )

Adds an update operation to the MongoDB\Driver\BulkWrite.

Değiştirgeler

filter (array|object)

The search filter.

newObj (array|object)

A document containing either update operators (e.g. $set) or a replacement document (i.e. only field:value expressions).

updateOptions

updateOptions
Option | Type | Description | Default
collation array|object

» Collation allows users to specify language-specific rules for string comparison, such as rules for lettercase and accent marks. When specifying collation, the "locale" field is mandatory; all other collation fields are optional. For descriptions of the fields, see » Collation Document.

If the collation is unspecified but the collection has a default collation, the operation uses the collation specified for the collection. If no collation is specified for the collection or for the operation, MongoDB uses the simple binary comparison used in prior versions for string comparisons.

This option is available in MongoDB 3.4+ and will result in an exception at execution time if specified for an older server version.

multi | bool | Update only the first matching document (multi=false), or all matching documents (multi=true). | FALSE
upsert | bool | If filter does not match an existing document, insert a single document. The document will be created from newObj if it is a replacement document (i.e. no update operators); otherwise, the operators in newObj will be applied to filter to create the new document. | FALSE

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Sürüm Bilgisi

Sürüm: | Açıklama
1.2.0 | Added the "collation" option.

Örnekler

Örnek 1 MongoDB\Driver\BulkWrite::update() example

<?php

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->update(
    ['x' => 2],
    ['$set' => ['y' => 3]],
    ['multi' => false, 'upsert' => false]
);

$manager = new MongoDB\Driver\Manager('mongodb://localhost:27017');
$writeConcern = new MongoDB\Driver\WriteConcern(MongoDB\Driver\WriteConcern::MAJORITY, 1000);
$result = $manager->executeBulkWrite('db.collection', $bulk, $writeConcern);

?>

Ayrıca Bakınız

  • MongoDB\Driver\Manager::executeBulkWrite() - Execute one or more write operations
  • MongoDB\Driver\WriteResult
MongoDB\Driver\BulkWrite::insert
MongoDB\Driver\WriteConcern
MongoDB\Driver\BulkWrite


The MongoDB\Driver\WriteConcern class

(mongodb >=1.0.0)

Giriş

MongoDB\Driver\WriteConcern describes the level of acknowledgement requested from MongoDB for write operations to a standalone mongod or to replica sets or to sharded clusters. In sharded clusters, mongos instances will pass the write concern on to the shards.

Sınıf Sözdizimi

final MongoDB\Driver\WriteConcern implements MongoDB\BSON\Serializable {
/* Constants */
const string MAJORITY = majority ;
/* Yöntemler */
final public object bsonSerialize ( void )
final public __construct ( string|int $w [, integer $wtimeout [, boolean $journal ]] )
final public bool|null getJournal ( void )
final public string|int|null getW ( void )
final public int getWtimeout ( void )
}

Öntanımlı Sabitler

MongoDB\Driver\WriteConcern::MAJORITY

Majority of all the members in the set; arbiters, non-voting members, passive members, hidden members and delayed members are all included in the definition of majority write concern.

İçindekiler

  • MongoDB\Driver\WriteConcern::bsonSerialize — Returns an object for BSON serialization
  • MongoDB\Driver\WriteConcern::__construct — Construct immutable WriteConcern
  • MongoDB\Driver\WriteConcern::getJournal — Returns the WriteConcern's "journal" option
  • MongoDB\Driver\WriteConcern::getW — Returns the WriteConcern's "w" option
  • MongoDB\Driver\WriteConcern::getWtimeout — Returns the WriteConcern's "wtimeout" option
MongoDB\Driver\BulkWrite::update
MongoDB\Driver\WriteConcern::bsonSerialize
MongoDB\Driver


Returns an object for BSON serialization

MongoDB\Driver\WriteConcern
MongoDB\Driver\WriteConcern::__construct
MongoDB\Driver\WriteConcern
PHP Manual

MongoDB\Driver\WriteConcern::bsonSerialize

(mongodb >=1.2.0)

MongoDB\Driver\WriteConcern::bsonSerialize — Returns an object for BSON serialization

Açıklama

final public object MongoDB\Driver\WriteConcern::bsonSerialize ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an object for serializing the WriteConcern as BSON.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\WriteConcern::bsonSerialize() with majority write concern

<?php

$wc = new MongoDB\Driver\WriteConcern(MongoDB\Driver\WriteConcern::MAJORITY);
var_dump($wc->bsonSerialize());

echo "\n", MongoDB\BSON\toJSON(MongoDB\BSON\fromPHP($wc));

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(stdClass)#2 (1) {
  ["w"]=>
  string(8) "majority"
}

{ "w" : "majority" }

Örnek 2 MongoDB\Driver\WriteConcern::bsonSerialize() with wtimeout and journal

<?php

$wc = new MongoDB\Driver\WriteConcern(2, 1000, true);
var_dump($wc->bsonSerialize());

echo "\n", MongoDB\BSON\toJSON(MongoDB\BSON\fromPHP($wc));

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(stdClass)#2 (3) {
  ["w"]=>
  int(2)
  ["j"]=>
  bool(true)
  ["wtimeout"]=>
  int(1000)
}

{ "w" : 2, "j" : true, "wtimeout" : 1000 }

Ayrıca Bakınız

  • MongoDB\BSON\Serializable::bsonSerialize() - Provides an array or document to serialize as BSON
  • » Write Concern reference
MongoDB\Driver\WriteConcern
MongoDB\Driver\WriteConcern::__construct
MongoDB\Driver\WriteConcern


Construct immutable WriteConcern

MongoDB\Driver\WriteConcern::bsonSerialize
MongoDB\Driver\WriteConcern::getJournal
MongoDB\Driver\WriteConcern
PHP Manual

MongoDB\Driver\WriteConcern::__construct

(mongodb >=1.0.0)

MongoDB\Driver\WriteConcern::__construct — Construct immutable WriteConcern

Açıklama

final public MongoDB\Driver\WriteConcern::__construct ( string|int $w [, integer $wtimeout [, boolean $journal ]] )

Creates a new WriteConcern.

Değiştirgeler

w

Write concern
Value | Description
1 | Requests acknowledgement that the write operation has propagated to the standalone mongod or the primary in a replica set. This is the default write concern for MongoDB.
0 | Requests no acknowledgment of the write operation. However, this may return information about socket exceptions and networking errors to the application.
<integer greater than 1> | Numbers greater than 1 are valid only for replica sets to request acknowledgement from specified number of members, including the primary.
MongoDB\Driver\WriteConcern::MAJORITY

Requests acknowledgment that write operations have propagated to the majority of voting nodes, including the primary, and have been written to the on-disk journal for these nodes.

Prior to MongoDB 3.0, this refers to the majority of replica set members (not just voting nodes).

string | A string value is interpereted as a tag set. Requests acknowledgement that the write operations have propagated to a replica set member with the specified tag.

wtimeout

How long to wait (in milliseconds) for secondaries before failing.

wtimeout causes write operations to return with an error (WriteConcernError) after the specified limit, even if the required write concern will eventually succeed. When these write operations return, MongoDB does not undo successful data modifications performed before the write concern exceeded the wtimeout time limit.

Write concern timeout
Value | Description
0 | Block indefinitely. This is the default.
<integer greater than 0> | Milliseconds to wait until returning.

journal

Wait until mongod has applied the write to the journal.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if w is invalid or wtimeout is negative.

Örnekler

Örnek 1 MongoDB\Driver\WriteConcern::__construct() example

<?php

/* Request write acknowledgement from the majority of the replica set nodes */
$wc = new MongoDB\Driver\WriteConcern(MongoDB\Driver\WriteConcern::MAJORITY, 500);

/* Request write acknowledgement from a node configured with the "MultipleDC" tag */
$wc = new MongoDB\Driver\WriteConcern("MultipleDC", 500);

?>

Ayrıca Bakınız

  • » Write Concern reference
MongoDB\Driver\WriteConcern::bsonSerialize
MongoDB\Driver\WriteConcern::getJournal
MongoDB\Driver\WriteConcern


Returns the WriteConcern's "journal" option

MongoDB\Driver\WriteConcern::__construct
MongoDB\Driver\WriteConcern::getW
MongoDB\Driver\WriteConcern
PHP Manual

MongoDB\Driver\WriteConcern::getJournal

(mongodb >=1.0.0)

MongoDB\Driver\WriteConcern::getJournal — Returns the WriteConcern's "journal" option

Açıklama

final public bool|null MongoDB\Driver\WriteConcern::getJournal ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the WriteConcern's "journal" option.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\WriteConcern::getJournal() example

<?php

$wc = new MongoDB\Driver\WriteConcern(1);
var_dump($wc->getJournal());

$wc = new MongoDB\Driver\WriteConcern(1, 0, true);
var_dump($wc->getJournal());

$wc = new MongoDB\Driver\WriteConcern(1, 0, false);
var_dump($wc->getJournal());

?>

Yukarıdaki örneğin çıktısı:

NULL
bool(true)
bool(false)

Ayrıca Bakınız

  • » Write Concern reference
MongoDB\Driver\WriteConcern::__construct
MongoDB\Driver\WriteConcern::getW
MongoDB\Driver\WriteConcern


Returns the WriteConcern's "w" option

MongoDB\Driver\WriteConcern::getJournal
MongoDB\Driver\WriteConcern::getWtimeout
MongoDB\Driver\WriteConcern
PHP Manual

MongoDB\Driver\WriteConcern::getW

(mongodb >=1.0.0)

MongoDB\Driver\WriteConcern::getW — Returns the WriteConcern's "w" option

Açıklama

final public string|int|null MongoDB\Driver\WriteConcern::getW ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the WriteConcern's "w" option.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\WriteConcern::getW() example

<?php

$wc = new MongoDB\Driver\WriteConcern(1);
var_dump($wc->getW());

$wc = new MongoDB\Driver\WriteConcern(MongoDB\Driver\WriteConcern::MAJORITY);
var_dump($wc->getW());

?>

Yukarıdaki örneğin çıktısı:

int(1)
string(8) "majority"

Ayrıca Bakınız

  • » Write Concern reference
MongoDB\Driver\WriteConcern::getJournal
MongoDB\Driver\WriteConcern::getWtimeout
MongoDB\Driver\WriteConcern


Returns the WriteConcern's "wtimeout" option

MongoDB\Driver\WriteConcern::getW
MongoDB\Driver\ReadPreference
MongoDB\Driver\WriteConcern
PHP Manual

MongoDB\Driver\WriteConcern::getWtimeout

(mongodb >=1.0.0)

MongoDB\Driver\WriteConcern::getWtimeout — Returns the WriteConcern's "wtimeout" option

Açıklama

final public int MongoDB\Driver\WriteConcern::getWtimeout ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the WriteConcern's "wtimeout" option.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\WriteConcern::getWtimeout() example

<?php

$wc = new MongoDB\Driver\WriteConcern(1);
var_dump($wc->getWtimeout());

$wc = new MongoDB\Driver\WriteConcern(MongoDB\Driver\WriteConcern::MAJORITY, 3000);
var_dump($wc->getWtimeout());

?>

Yukarıdaki örneğin çıktısı:

int(0)
int(3000)

Ayrıca Bakınız

  • » Write Concern reference
MongoDB\Driver\WriteConcern::getW
MongoDB\Driver\ReadPreference
MongoDB\Driver\WriteConcern


The MongoDB\Driver\ReadPreference class

(mongodb >=1.0.0)

Giriş

Sınıf Sözdizimi

final MongoDB\Driver\ReadPreference implements MongoDB\BSON\Serializable {
/* Constants */
const integer RP_PRIMARY = 1 ;
const integer RP_PRIMARY_PREFERRED = 5 ;
const integer RP_SECONDARY = 2 ;
const integer RP_SECONDARY_PREFERRED = 6 ;
const integer RP_NEAREST = 10 ;
const integer NO_MAX_STALENESS = -1 ;
const integer SMALLEST_MAX_STALENESS_SECONDS = 90 ;
/* Yöntemler */
final public object bsonSerialize ( void )
final public __construct ( int $mode [, array $tagSets = NULL [, array $options = [] ]] )
final public integer getMaxStalenessSeconds ( void )
final public integer getMode ( void )
final public array getTagSets ( void )
}

Öntanımlı Sabitler

MongoDB\Driver\ReadPreference::RP_PRIMARY

All operations read from the current replica set primary. This is the default read preference for MongoDB.

MongoDB\Driver\ReadPreference::RP_PRIMARY_PREFERRED

In most situations, operations read from the primary but if it is unavailable, operations read from secondary members.

MongoDB\Driver\ReadPreference::RP_SECONDARY

All operations read from the secondary members of the replica set.

MongoDB\Driver\ReadPreference::RP_SECONDARY_PREFERRED

In most situations, operations read from secondary members but if no secondary members are available, operations read from the primary.

MongoDB\Driver\ReadPreference::RP_NEAREST

Operations read from member of the replica set with the least network latency, irrespective of the member's type.

MongoDB\Driver\ReadPreference::NO_MAX_STALENESS

The default value for the "maxStalenessSeconds" option is to specify no limit on maximum staleness, which means that the driver will not consider a secondary's lag when choosing where to direct a read operation.

MongoDB\Driver\ReadPreference::SMALLEST_MAX_STALENESS_SECONDS

The minimum value for the "maxStalenessSeconds" option is 90 seconds. The driver estimates secondaries' staleness by periodically checking the latest write date of each replica set member. Since these checks are infrequent, the staleness estimate is coarse. Thus, the driver cannot enforce a max staleness value of less than 90 seconds.

Sürüm Bilgisi

Sürüm: | Açıklama
1.2.0 | Added the MongoDB\Driver\ReadPreference::NO_MAX_STALENESS and MongoDB\Driver\ReadPreference::SMALLEST_MAX_STALENESS_SECONDS constants.

İçindekiler

  • MongoDB\Driver\ReadPreference::bsonSerialize — Returns an object for BSON serialization
  • MongoDB\Driver\ReadPreference::__construct — Construct immutable ReadPreference
  • MongoDB\Driver\ReadPreference::getMaxStalenessSeconds — Returns the ReadPreference's "maxStalenessSeconds" option
  • MongoDB\Driver\ReadPreference::getMode — Returns the ReadPreference's "mode" option
  • MongoDB\Driver\ReadPreference::getTagSets — Returns the ReadPreference's "tagSets" option
MongoDB\Driver\WriteConcern::getWtimeout
MongoDB\Driver\ReadPreference::bsonSerialize
MongoDB\Driver


Returns an object for BSON serialization

MongoDB\Driver\ReadPreference
MongoDB\Driver\ReadPreference::__construct
MongoDB\Driver\ReadPreference
PHP Manual

MongoDB\Driver\ReadPreference::bsonSerialize

(mongodb >=1.2.0)

MongoDB\Driver\ReadPreference::bsonSerialize — Returns an object for BSON serialization

Açıklama

final public object MongoDB\Driver\ReadPreference::bsonSerialize ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an object for serializing the ReadPreference as BSON.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\ReadPreference::bsonSerialize() with primary read preference

<?php

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_PRIMARY);
var_dump($rp->bsonSerialize());

echo "\n", MongoDB\BSON\toJSON(MongoDB\BSON\fromPHP($rp));

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(stdClass)#2 (1) {
  ["mode"]=>
  string(7) "primary"
}

{ "mode" : "primary" }

Örnek 2 MongoDB\Driver\ReadPreference::bsonSerialize() with secondary read preference and tag sets

<?php

$rp = new MongoDB\Driver\ReadPreference(
    MongoDB\Driver\ReadPreference::RP_SECONDARY,
    [
        ['dc' => 'ny'],
        ['dc' => 'sf', 'use' => 'reporting'],
        []
    ]
);
var_dump($rp->bsonSerialize());

echo "\n", MongoDB\BSON\toJSON(MongoDB\BSON\fromPHP($rp));

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(stdClass)#2 (2) {
  ["mode"]=>
  string(9) "secondary"
  ["tags"]=>
  array(3) {
    [0]=>
    object(stdClass)#1 (1) {
      ["dc"]=>
      string(2) "ny"
    }
    [1]=>
    object(stdClass)#5 (2) {
      ["dc"]=>
      string(2) "sf"
      ["use"]=>
      string(9) "reporting"
    }
    [2]=>
    object(stdClass)#4 (0) {
    }
  }
}

{ "mode" : "secondary", "tags" : [ { "dc" : "ny" }, { "dc" : "sf", "use" : "reporting" }, {  } ] }

Örnek 3 MongoDB\Driver\ReadPreference::bsonSerialize() with secondary read preference and max staleness

<?php

$rp = new MongoDB\Driver\ReadPreference(
    MongoDB\Driver\ReadPreference::RP_SECONDARY,
    null,
    ['maxStalenessSeconds' => 120]
);
var_dump($rp->bsonSerialize());

echo "\n", MongoDB\BSON\toJSON(MongoDB\BSON\fromPHP($rp));

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(stdClass)#2 (2) {
  ["mode"]=>
  string(9) "secondary"
  ["maxStalenessSeconds"]=>
  int(120)
}

{ "mode" : "secondary", "maxStalenessSeconds" : 120 }

Ayrıca Bakınız

  • MongoDB\BSON\Serializable::bsonSerialize() - Provides an array or document to serialize as BSON
  • » Read Preference reference
MongoDB\Driver\ReadPreference
MongoDB\Driver\ReadPreference::__construct
MongoDB\Driver\ReadPreference


Construct immutable ReadPreference

MongoDB\Driver\ReadPreference::bsonSerialize
MongoDB\Driver\ReadPreference::getMaxStalenessSeconds
MongoDB\Driver\ReadPreference
PHP Manual

MongoDB\Driver\ReadPreference::__construct

(mongodb >=1.0.0)

MongoDB\Driver\ReadPreference::__construct — Construct immutable ReadPreference

Açıklama

final public MongoDB\Driver\ReadPreference::__construct ( int $mode [, array $tagSets = NULL [, array $options = [] ]] )

Creates a new ReadPreference.

Değiştirgeler

mode

Read preference mode
Value Description
MongoDB\Driver\ReadPreference::RP_PRIMARY

All operations read from the current replica set primary. This is the default read preference for MongoDB.

MongoDB\Driver\ReadPreference::RP_PRIMARY_PREFERRED

In most situations, operations read from the primary but if it is unavailable, operations read from secondary members.

MongoDB\Driver\ReadPreference::RP_SECONDARY

All operations read from the secondary members of the replica set.

MongoDB\Driver\ReadPreference::RP_SECONDARY_PREFERRED

In most situations, operations read from secondary members but if no secondary members are available, operations read from the primary.

MongoDB\Driver\ReadPreference::RP_NEAREST

Operations read from member of the replica set with the least network latency, irrespective of the member's type.

tagSets

Tag sets allow you to target read operations to specific members of a replica set. This parameter should be an array of associative arrays, each of which contain zero or more key/value pairs. When selecting a server for a read operation, the driver attempt to select a node having all tags in a set (i.e. the associative array of key/value pairs). If selection fails, the driver will attempt subsequent sets. An empty tag set (array()) will match any node and may be used as a fallback.

Tags are not compatible with the MongoDB\Driver\ReadPreference::RP_PRIMARY mode and, in general, only apply when selecting a secondary member of a set for a read operation. However, the MongoDB\Driver\ReadPreference::RP_NEAREST mode, when combined with a tag set, selects the matching member with the lowest network latency. This member may be a primary or secondary.

options

options
Option Type Description
maxStalenessSeconds integer

Specifies a maximum replication lag, or "staleness", for reads from secondaries. When a secondary's estimated staleness exceeds this value, the driver stops using it for read operations.

If specified, the max staleness must be a signed 32-bit integer greater than or equal to MongoDB\Driver\ReadPreference::SMALLEST_MAX_STALENESS_SECONDS.

Defaults to MongoDB\Driver\ReadPreference::NO_MAX_STALENESS, which means that the driver will not consider a secondary's lag when choosing where to direct a read operation.

This option is not compatible with the MongoDB\Driver\ReadPreference::RP_PRIMARY mode. Specifying a max staleness also requires all MongoDB instances in the deployment to be using MongoDB 3.4+. An exception will be thrown at execution time if any MongoDB instances in the deployment are of an older server version.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if mode is invalid.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if tagSets is provided for a primary read preference or is malformed (i.e. not an array of zero or more documents).
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the "maxStalenessSeconds" option is provided for a primary read preference or is out of range.

Sürüm Bilgisi

Sürüm: | Açıklama
1.2.0 | Added a third options argument, which supports the "maxStalenessSeconds" option.

Örnekler

Örnek 1 MongoDB\Driver\ReadPreference::__construct() example

<?php

/* Prefer a secondary node but fall back to a primary. */
var_dump(new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_SECONDARY_PREFERRED));

/* Prefer a node in the New York data center with lowest latency. */
var_dump(new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_NEAREST, [['dc' => 'ny']]));

/* Require a secondary node whose replication lag is within two minutes of the primary */
var_dump(new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_SECONDARY, null, ['maxStalenessSeconds' => 120]));

?>

Yukarıdaki örneğin çıktısı:

object(MongoDB\Driver\ReadPreference)#1 (1) {
  ["mode"]=>
  string(18) "secondaryPreferred"
}
object(MongoDB\Driver\ReadPreference)#1 (2) {
  ["mode"]=>
  string(7) "nearest"
  ["tags"]=>
  array(1) {
    [0]=>
    object(stdClass)#2 (1) {
      ["dc"]=>
      string(2) "ny"
    }
  }
}
object(MongoDB\Driver\ReadPreference)#1 (2) {
  ["mode"]=>
  string(9) "secondary"
  ["maxStalenessSeconds"]=>
  int(120)
}

Ayrıca Bakınız

  • » Read Preference reference
MongoDB\Driver\ReadPreference::bsonSerialize
MongoDB\Driver\ReadPreference::getMaxStalenessSeconds
MongoDB\Driver\ReadPreference


Returns the ReadPreference's "maxStalenessSeconds" option

MongoDB\Driver\ReadPreference::__construct
MongoDB\Driver\ReadPreference::getMode
MongoDB\Driver\ReadPreference
PHP Manual

MongoDB\Driver\ReadPreference::getMaxStalenessSeconds

(mongodb >=1.2.0)

MongoDB\Driver\ReadPreference::getMaxStalenessSeconds — Returns the ReadPreference's "maxStalenessSeconds" option

Açıklama

final public integer MongoDB\Driver\ReadPreference::getMaxStalenessSeconds ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the ReadPreference's "maxStalenessSeconds" option. If no max staleness has been specified, MongoDB\Driver\ReadPreference::NO_MAX_STALENESS will be returned.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\ReadPreference::getMaxStalenessSeconds() example

<?php

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_SECONDARY);
var_dump($rp->getMaxStalenessSeconds());

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_SECONDARY, null, [
    'maxStalenessSeconds' => MongoDB\Driver\ReadPreference::NO_MAX_STALENESS,
]);
var_dump($rp->getMaxStalenessSeconds());

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_SECONDARY, null, [
    'maxStalenessSeconds' => MongoDB\Driver\ReadPreference::SMALLEST_MAX_STALENESS_SECONDS,
]);
var_dump($rp->getMaxStalenessSeconds());

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_SECONDARY, null, [
    'maxStalenessSeconds' => 1000,
]);
var_dump($rp->getMaxStalenessSeconds());

?>

Yukarıdaki örneğin çıktısı:

int(-1)
int(-1)
int(90)
int(1000)

Ayrıca Bakınız

  • » Read Preference reference
MongoDB\Driver\ReadPreference::__construct
MongoDB\Driver\ReadPreference::getMode
MongoDB\Driver\ReadPreference


Returns the ReadPreference's "mode" option

MongoDB\Driver\ReadPreference::getMaxStalenessSeconds
MongoDB\Driver\ReadPreference::getTagSets
MongoDB\Driver\ReadPreference
PHP Manual

MongoDB\Driver\ReadPreference::getMode

(mongodb >=1.0.0)

MongoDB\Driver\ReadPreference::getMode — Returns the ReadPreference's "mode" option

Açıklama

final public integer MongoDB\Driver\ReadPreference::getMode ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the ReadPreference's "mode" option.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\ReadPreference::getMode() example

<?php

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_PRIMARY);
var_dump($rp->getMode());

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_PRIMARY_PREFERRED);
var_dump($rp->getMode());

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_SECONDARY);
var_dump($rp->getMode());

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_SECONDARY_PREFERRED);
var_dump($rp->getMode());

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_NEAREST);
var_dump($rp->getMode());

?>

Yukarıdaki örneğin çıktısı:

int(1)
int(5)
int(2)
int(6)
int(10)

Ayrıca Bakınız

  • » Read Preference reference
MongoDB\Driver\ReadPreference::getMaxStalenessSeconds
MongoDB\Driver\ReadPreference::getTagSets
MongoDB\Driver\ReadPreference


Returns the ReadPreference's "tagSets" option

MongoDB\Driver\ReadPreference::getMode
MongoDB\Driver\ReadConcern
MongoDB\Driver\ReadPreference
PHP Manual

MongoDB\Driver\ReadPreference::getTagSets

(mongodb >=1.0.0)

MongoDB\Driver\ReadPreference::getTagSets — Returns the ReadPreference's "tagSets" option

Açıklama

final public array MongoDB\Driver\ReadPreference::getTagSets ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the ReadPreference's "tagSets" option.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\ReadPreference::getTagSets() example

<?php

$mode = MongoDB\Driver\ReadPreference::RP_SECONDARY_PREFERRED);

/* Null and an empty array both denote no tag set preference. */
$rp = new MongoDB\Driver\ReadPreference($mode, null);
var_dump($rp->getTagSets());

$rp = new MongoDB\Driver\ReadPreference($mode, []);
var_dump($rp->getTagSets());

/* Prefer a node in New York, but fall back to any available node. */
$rp = new MongoDB\Driver\ReadPreference($mode, [['dc' => 'ny']]);
var_dump($rp->getTagSets());

/* Prefer a node in the New York, followed by a node in San Francisco that is
   labeled for reporting usage, and finally fall back to any available node. */
$rp = new MongoDB\Driver\ReadPreference($mode, [
  ['dc' => 'ny'],
  ['dc' => 'sf', 'use' => 'reporting'],
  [],
]);
var_dump($rp->getTagSets());

?>

Yukarıdaki örneğin çıktısı:

array(0) {
}
array(0) {
}
array(2) {
  [0]=>
  array(1) {
    ["dc"]=>
    string(2) "ny"
  }
  [1]=>
  array(0) {
  }
}
array(3) {
  [0]=>
  array(1) {
    ["dc"]=>
    string(2) "ny"
  }
  [1]=>
  array(2) {
    ["dc"]=>
    string(2) "sf"
    ["use"]=>
    string(9) "reporting"
  }
  [2]=>
  array(0) {
  }
}

Ayrıca Bakınız

  • » Read Preference reference
MongoDB\Driver\ReadPreference::getMode
MongoDB\Driver\ReadConcern
MongoDB\Driver\ReadPreference


The MongoDB\Driver\ReadConcern class

(mongodb >=1.1.0)

Giriş

MongoDB\Driver\ReadConcern controls the level of isolation for read operations for replica sets and replica set shards. This option requires the WiredTiger storage engine and MongoDB 3.2 or later.

Sınıf Sözdizimi

final MongoDB\Driver\ReadConcern implements MongoDB\BSON\Serializable {
/* Constants */
const string LINEARIZABLE = linearizable ;
const string LOCAL = local ;
const string MAJORITY = majority ;
/* Yöntemler */
final public object bsonSerialize ( void )
final public __construct ([ string $level ] )
final public string|null getLevel ( void )
}

Öntanımlı Sabitler

MongoDB\Driver\ReadConcern::LINEARIZABLE

A linearizable read avoids returning reads from a stale primary (one that has already been superseded by a new primary but doesn't know it yet). It is important to note that this read concern level does not by itself produce linearizable reads; they must be issued in conjunction with MongoDB\Driver\WriteConcern::MAJORITY writes to the same document(s) in order to be linearizable.

MongoDB\Driver\ReadConcern::LOCAL

Queries using this read concern will return the node's most recent copy of the data. This provides no guarantee that the data has been written to a majority of the nodes (i.e. it may be rolled back).

This is the default read concern level.

MongoDB\Driver\ReadConcern::MAJORITY

Queries using this read concern will return the node's most recent copy of the data confirmed as having been written to a majority of the nodes (i.e. the data cannot be rolled back).

Sürüm Bilgisi

Sürüm: | Açıklama
1.2.0 | Added the MongoDB\Driver\ReadConcern::LINEARIZABLE constant.

İçindekiler

  • MongoDB\Driver\ReadConcern::bsonSerialize — Returns an object for BSON serialization
  • MongoDB\Driver\ReadConcern::__construct — Construct immutable ReadConcern
  • MongoDB\Driver\ReadConcern::getLevel — Returns the ReadConcern's "level" option
MongoDB\Driver\ReadPreference::getTagSets
MongoDB\Driver\ReadConcern::bsonSerialize
MongoDB\Driver


Returns an object for BSON serialization

MongoDB\Driver\ReadConcern
MongoDB\Driver\ReadConcern::__construct
MongoDB\Driver\ReadConcern
PHP Manual

MongoDB\Driver\ReadConcern::bsonSerialize

(mongodb >=1.2.0)

MongoDB\Driver\ReadConcern::bsonSerialize — Returns an object for BSON serialization

Açıklama

final public object MongoDB\Driver\ReadConcern::bsonSerialize ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an object for serializing the ReadConcern as BSON.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\ReadConcern::bsonSerialize() with empty read concern

<?php

$rc = new MongoDB\Driver\ReadConcern;
var_dump($rc->bsonSerialize());

echo "\n", MongoDB\BSON\toJSON(MongoDB\BSON\fromPHP($rc));

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(stdClass)#2 (0) {
}

{ }

Örnek 2 MongoDB\Driver\ReadConcern::bsonSerialize() with local read concern

<?php

$rc = new MongoDB\Driver\ReadConcern(MongoDB\Driver\ReadConcern::LOCAL);
var_dump($rc->bsonSerialize());

echo "\n", MongoDB\BSON\toJSON(MongoDB\BSON\fromPHP($rc));

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(stdClass)#2 (1) {
  ["level"]=>
  string(5) "local"
}

{ "level" : "local" }

Ayrıca Bakınız

  • MongoDB\BSON\Serializable::bsonSerialize() - Provides an array or document to serialize as BSON
  • » Read Concern reference
MongoDB\Driver\ReadConcern
MongoDB\Driver\ReadConcern::__construct
MongoDB\Driver\ReadConcern


Construct immutable ReadConcern

MongoDB\Driver\ReadConcern::bsonSerialize
MongoDB\Driver\ReadConcern::getLevel
MongoDB\Driver\ReadConcern
PHP Manual

MongoDB\Driver\ReadConcern::__construct

(mongodb >=1.0.0)

MongoDB\Driver\ReadConcern::__construct — Construct immutable ReadConcern

Açıklama

final public MongoDB\Driver\ReadConcern::__construct ([ string $level ] )

Creates a new ReadConcern.

Değiştirgeler

level

Read concern
Value | Description
MongoDB\Driver\ReadConcern::LOCAL | Queries using this read concern will return the node's most recent copy of the data. This provides no guarantee that the data has been written to a majority of the nodes (i.e. it may be rolled back). This is the default read concern for MongoDB.
MongoDB\Driver\ReadConcern::MAJORITY | Queries using this read concern will return the node's most recent copy of the data confirmed as having been written to a majority of the nodes (i.e. the data cannot be rolled back).

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\ReadConcern::__construct() example

<?php

/* Unspecified read isolation level (uses the server's default behavior) */
$rc = new MongoDB\Driver\ReadConcern();

/* Request read isolation from a single replica set node */
$rc = new MongoDB\Driver\ReadConcern(MongoDB\Driver\ReadConcern::LOCAL);

/* Request read isolation from a majority of the replica set nodes */
$rc = new MongoDB\Driver\ReadConcern(MongoDB\Driver\ReadConcern::MAJORITY);

?>

Ayrıca Bakınız

  • » Read Concern reference
MongoDB\Driver\ReadConcern::bsonSerialize
MongoDB\Driver\ReadConcern::getLevel
MongoDB\Driver\ReadConcern


Returns the ReadConcern's "level" option

MongoDB\Driver\ReadConcern::__construct
MongoDB\Driver\Cursor
MongoDB\Driver\ReadConcern
PHP Manual

MongoDB\Driver\ReadConcern::getLevel

(mongodb >=1.0.0)

MongoDB\Driver\ReadConcern::getLevel — Returns the ReadConcern's "level" option

Açıklama

final public string|null MongoDB\Driver\ReadConcern::getLevel ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the ReadConcern's "level" option.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\ReadConcern::getLevel() example

<?php

$rc = new MongoDB\Driver\ReadConcern();
var_dump($rc->getLevel());

$rc = new MongoDB\Driver\ReadConcern(MongoDB\Driver\ReadConcern::LOCAL);
var_dump($rc->getLevel());

$rc = new MongoDB\Driver\ReadConcern(MongoDB\Driver\ReadConcern::MAJORITY);
var_dump($rc->getLevel());

?>

Yukarıdaki örneğin çıktısı:

NULL
string(5) "local"
string(8) "majority"

Ayrıca Bakınız

  • » Read Concern reference
MongoDB\Driver\ReadConcern::__construct
MongoDB\Driver\Cursor
MongoDB\Driver\ReadConcern


The MongoDB\Driver\Cursor class

(mongodb >=1.0.0)

Giriş

The MongoDB\Driver\Cursor class encapsulates the results of a MongoDB command or query and may be returned by MongoDB\Driver\Manager::executeCommand() or MongoDB\Driver\Manager::executeQuery(), respectively.

Sınıf Sözdizimi

MongoDB\Driver\Cursor implements Traversable {
/* Yöntemler */
final private __construct ( void )
final public MongoDB\Driver\CursorId getId ( void )
final public MongoDB\Driver\Server getServer ( void )
final public bool isDead ( void )
final public void setTypeMap ( array $typemap )
final public array toArray ( void )
}

İçindekiler

  • MongoDB\Driver\Cursor::__construct — Create a new Cursor (not used)
  • MongoDB\Driver\Cursor::getId — Returns the ID for this cursor
  • MongoDB\Driver\Cursor::getServer — Returns the server associated with this cursor
  • MongoDB\Driver\Cursor::isDead — Checks if the cursor is still open on the server
  • MongoDB\Driver\Cursor::setTypeMap — Sets a type map to use for BSON unserialization
  • MongoDB\Driver\Cursor::toArray — Returns an array containing all results for this cursor
MongoDB\Driver\ReadConcern::getLevel
MongoDB\Driver\Cursor::__construct
MongoDB\Driver


Create a new Cursor (not used)

MongoDB\Driver\Cursor
MongoDB\Driver\Cursor::getId
MongoDB\Driver\Cursor
PHP Manual

MongoDB\Driver\Cursor::__construct

(mongodb >=1.0.0)

MongoDB\Driver\Cursor::__construct — Create a new Cursor (not used)

Açıklama

final private MongoDB\Driver\Cursor::__construct ( void )

MongoDB\Driver\Cursor objects are returned as the result of an executed command or query and cannot be constructed directly.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Ayrıca Bakınız

  • MongoDB\Driver\Manager::executeCommand() - Execute a database command
  • MongoDB\Driver\Manager::executeQuery() - Execute a database query
  • MongoDB\Driver\Server::executeCommand() - Execute a database command on this server
  • MongoDB\Driver\Server::executeQuery() - Execute a database query on this server
MongoDB\Driver\Cursor
MongoDB\Driver\Cursor::getId
MongoDB\Driver\Cursor


Returns the ID for this cursor

MongoDB\Driver\Cursor::__construct
MongoDB\Driver\Cursor::getServer
MongoDB\Driver\Cursor
PHP Manual

MongoDB\Driver\Cursor::getId

(mongodb >=1.0.0)

MongoDB\Driver\Cursor::getId — Returns the ID for this cursor

Açıklama

final public MongoDB\Driver\CursorId MongoDB\Driver\Cursor::getId ( void )

Returns the MongoDB\Driver\CursorId associated with this cursor. A cursor ID uniquely identifies the cursor on the server.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the MongoDB\Driver\CursorId for this cursor.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\Cursor::getId() example

<?php

/* In this example, we insert several documents into the collection and specify
 * a smaller batchSize to ensure that the first batch contains only a subset of
 * our results and the cursor remains open on the server. */
$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017");
$query = new MongoDB\Driver\Query([], ['batchSize' => 2]);

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);
$bulk->insert(['x' => 2]);
$bulk->insert(['x' => 3]);
$manager->executeBulkWrite('db.collection', $bulk);

$cursor = $manager->executeQuery('db.collection', $query);
var_dump($cursor->getId());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(MongoDB\Driver\CursorId)#5 (1) {
  ["id"]=>
  int(94810124093)
}

Ayrıca Bakınız

  • MongoDB\Driver\CursorId
  • MongoDB\Driver\CursorId::__toString() - String representation of the cursor ID
MongoDB\Driver\Cursor::__construct
MongoDB\Driver\Cursor::getServer
MongoDB\Driver\Cursor


Returns the server associated with this cursor

MongoDB\Driver\Cursor::getId
MongoDB\Driver\Cursor::isDead
MongoDB\Driver\Cursor
PHP Manual

MongoDB\Driver\Cursor::getServer

(mongodb >=1.0.0)

MongoDB\Driver\Cursor::getServer — Returns the server associated with this cursor

Açıklama

final public MongoDB\Driver\Server MongoDB\Driver\Cursor::getServer ( void )

Returns the MongoDB\Driver\Server associated with this cursor. This is the server that executed the MongoDB\Driver\Query or MongoDB\Driver\Command.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the MongoDB\Driver\Server associated with this cursor.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\Cursor::getServer() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017");
$query = new MongoDB\Driver\Query([]);

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);
$manager->executeBulkWrite('db.collection', $bulk);

$cursor = $manager->executeQuery('db.collection', $query);
var_dump($cursor->getServer());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(MongoDB\Driver\Server)#5 (10) {
  ["host"]=>
  string(9) "localhost"
  ["port"]=>
  int(27017)
  ["type"]=>
  int(1)
  ["is_primary"]=>
  bool(false)
  ["is_secondary"]=>
  bool(false)
  ["is_arbiter"]=>
  bool(false)
  ["is_hidden"]=>
  bool(false)
  ["is_passive"]=>
  bool(false)
  ["last_is_master"]=>
  array(8) {
    ["ismaster"]=>
    bool(true)
    ["maxBsonObjectSize"]=>
    int(16777216)
    ["maxMessageSizeBytes"]=>
    int(48000000)
    ["maxWriteBatchSize"]=>
    int(1000)
    ["localTime"]=>
    object(MongoDB\BSON\UTCDateTime)#6 (1) {
      ["milliseconds"]=>
      int(1446505367907)
    }
    ["maxWireVersion"]=>
    int(3)
    ["minWireVersion"]=>
    int(0)
    ["ok"]=>
    float(1)
  }
  ["round_trip_time"]=>
  int(584)
}

Ayrıca Bakınız

  • MongoDB\Driver\Server
MongoDB\Driver\Cursor::getId
MongoDB\Driver\Cursor::isDead
MongoDB\Driver\Cursor


Checks if the cursor is still open on the server

MongoDB\Driver\Cursor::getServer
MongoDB\Driver\Cursor::setTypeMap
MongoDB\Driver\Cursor
PHP Manual

MongoDB\Driver\Cursor::isDead

(mongodb >=1.0.0)

MongoDB\Driver\Cursor::isDead — Checks if the cursor is still open on the server

Açıklama

final public bool MongoDB\Driver\Cursor::isDead ( void )

Returns whether the cursor is still open on the server (i.e. the server has more results that have yet to be sent to the client).

A cursor being "dead" does not mean that it cannot be iterated further. The database sends responses in batches of documents (up to 4MB of documents per response). The client's cursor may still have results to be iterated even if the server has no more batches to send.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if there are more results that have not yet been sent to the client, and FALSE otherwise.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\Cursor::isDead() example

<?php

/* In this example, we insert several documents into the collection and specify
 * a smaller batchSize to ensure that the first batch contains only a subset of
 * our results and the cursor remains open on the server. */
$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017");
$query = new MongoDB\Driver\Query([], ['batchSize' => 2]);

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);
$bulk->insert(['x' => 2]);
$bulk->insert(['x' => 3]);
$manager->executeBulkWrite('db.collection', $bulk);

$cursor = $manager->executeQuery('db.collection', $query);

var_dump($cursor->isDead());
$cursor->toArray();
var_dump($cursor->isDead());

?>

Yukarıdaki örneğin çıktısı:

bool(false)
bool(true)
MongoDB\Driver\Cursor::getServer
MongoDB\Driver\Cursor::setTypeMap
MongoDB\Driver\Cursor


Sets a type map to use for BSON unserialization

MongoDB\Driver\Cursor::isDead
MongoDB\Driver\Cursor::toArray
MongoDB\Driver\Cursor
PHP Manual

MongoDB\Driver\Cursor::setTypeMap

(mongodb >=1.0.0)

MongoDB\Driver\Cursor::setTypeMap — Sets a type map to use for BSON unserialization

Açıklama

final public void MongoDB\Driver\Cursor::setTypeMap ( array $typemap )

Sets the type map configuration to use when unserializing the BSON results into PHP values.

Değiştirgeler

typeMap (array)

Type map configuration.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\Cursor::setTypeMap() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017");

$bulk = new MongoDB\Driver\BulkWrite;
$id = $bulk->insert(['x' => 1]);
$manager->executeBulkWrite('db.collection', $bulk);

$query = new MongoDB\Driver\Query(['_id' => $id]);
$cursor = $manager->executeQuery('db.collection', $query);
$cursor->setTypeMap(['root' => 'array']);

foreach ($cursor as $document) {
    var_dump($document);
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(2) {
  ["_id"]=>
  object(MongoDB\BSON\ObjectID)#6 (1) {
    ["oid"]=>
    string(24) "56424fb76118fd3267180741"
  }
  ["x"]=>
  int(1)
}

Ayrıca Bakınız

  • Persisting Data
MongoDB\Driver\Cursor::isDead
MongoDB\Driver\Cursor::toArray
MongoDB\Driver\Cursor


Returns an array containing all results for this cursor

MongoDB\Driver\Cursor::setTypeMap
MongoDB\Driver\CursorId
MongoDB\Driver\Cursor
PHP Manual

MongoDB\Driver\Cursor::toArray

(mongodb >=1.0.0)

MongoDB\Driver\Cursor::toArray — Returns an array containing all results for this cursor

Açıklama

final public array MongoDB\Driver\Cursor::toArray ( void )

Iterates the cursor and returns its results in an array. MongoDB\Driver\Cursor::setTypeMap() may be used to control how documents are unserialized into PHP values.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array containing all results for this cursor.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\Cursor::toArray() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017");

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);
$bulk->insert(['x' => 2]);
$bulk->insert(['x' => 3]);
$manager->executeBulkWrite('db.collection', $bulk);

$query = new MongoDB\Driver\Query([]);
$cursor = $manager->executeQuery('db.collection', $query);

var_dump($cursor->toArray());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(3) {
  [0]=>
  object(stdClass)#6 (2) {
    ["_id"]=>
    object(MongoDB\BSON\ObjectID)#5 (1) {
      ["oid"]=>
      string(24) "564259a96118fd40b41bcf61"
    }
    ["x"]=>
    int(1)
  }
  [1]=>
  object(stdClass)#8 (2) {
    ["_id"]=>
    object(MongoDB\BSON\ObjectID)#7 (1) {
      ["oid"]=>
      string(24) "564259a96118fd40b41bcf62"
    }
    ["x"]=>
    int(2)
  }
  [2]=>
  object(stdClass)#10 (2) {
    ["_id"]=>
    object(MongoDB\BSON\ObjectID)#9 (1) {
      ["oid"]=>
      string(24) "564259a96118fd40b41bcf63"
    }
    ["x"]=>
    int(3)
  }
}

Ayrıca Bakınız

  • MongoDB\Driver\Cursor::setTypeMap() - Sets a type map to use for BSON unserialization
MongoDB\Driver\Cursor::setTypeMap
MongoDB\Driver\CursorId
MongoDB\Driver\Cursor


The MongoDB\Driver\CursorId class

(mongodb >=1.0.0)

Giriş

Sınıf Sözdizimi

final MongoDB\Driver\CursorId {
/* Yöntemler */
final private __construct ( void )
final public string __toString ( void )
}

İçindekiler

  • MongoDB\Driver\CursorId::__construct — Create a new CursorId (not used)
  • MongoDB\Driver\CursorId::__toString — String representation of the cursor ID
MongoDB\Driver\Cursor::toArray
MongoDB\Driver\CursorId::__construct
MongoDB\Driver


Create a new CursorId (not used)

MongoDB\Driver\CursorId
MongoDB\Driver\CursorId::__toString
MongoDB\Driver\CursorId
PHP Manual

MongoDB\Driver\CursorId::__construct

(mongodb >=1.0.0)

MongoDB\Driver\CursorId::__construct — Create a new CursorId (not used)

Açıklama

final private MongoDB\Driver\CursorId::__construct ( void )

MongoDB\Driver\CursorId objects are returned from MongoDB\Driver\Cursor::getId() and cannot be constructed directly.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Ayrıca Bakınız

  • MongoDB\Driver\Cursor::getId() - Returns the ID for this cursor
MongoDB\Driver\CursorId
MongoDB\Driver\CursorId::__toString
MongoDB\Driver\CursorId


String representation of the cursor ID

MongoDB\Driver\CursorId::__construct
MongoDB\Driver\Server
MongoDB\Driver\CursorId
PHP Manual

MongoDB\Driver\CursorId::__toString

(mongodb >=1.0.0)

MongoDB\Driver\CursorId::__toString — String representation of the cursor ID

Açıklama

final public string MongoDB\Driver\CursorId::__toString ( void )

Returns the string representation of the cursor ID.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the string representation of the cursor ID.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\CursorId::__toString() example

<?php

/* In this example, we insert several documents into the collection and specify
 * a smaller batchSize to ensure that the first batch contains only a subset of
 * our results and the cursor remains open on the server. */
$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017");
$query = new MongoDB\Driver\Query([], ['batchSize' => 2]);

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);
$bulk->insert(['x' => 2]);
$bulk->insert(['x' => 3]);
$manager->executeBulkWrite('db.collection', $bulk);

$cursor = $manager->executeQuery('db.collection', $query);
var_dump((string) $cursor->getId());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(11) "98061641158"

Ayrıca Bakınız

  • MongoDB\Driver\Cursor::getId() - Returns the ID for this cursor
MongoDB\Driver\CursorId::__construct
MongoDB\Driver\Server
MongoDB\Driver\CursorId


The MongoDB\Driver\Server class

(mongodb >=1.0.0)

Giriş

Sınıf Sözdizimi

final MongoDB\Driver\Server {
/* Constants */
const integer TYPE_UNKNOWN = 0 ;
const integer TYPE_STANDALONE = 1 ;
const integer TYPE_MONGOS = 2 ;
const integer TYPE_POSSIBLE_PRIMARY = 3 ;
const integer TYPE_RS_PRIMARY = 4 ;
const integer TYPE_RS_SECONDARY = 5 ;
const integer TYPE_RS_ARBITER = 6 ;
const integer TYPE_RS_OTHER = 7 ;
const integer TYPE_RS_GHOST = 8 ;
/* Yöntemler */
final private __construct ( void )
final public MongoDB\Driver\WriteResult executeBulkWrite ( string $namespace , MongoDB\Driver\BulkWrite $bulk [, MongoDB\Driver\WriteConcern $writeConcern ] )
final public MongoDB\Driver\Cursor executeCommand ( string $db , MongoDB\Driver\Command $command [, MongoDB\Driver\ReadPreference $readPreference ] )
final public MongoDB\Driver\Cursor executeQuery ( string $namespace , MongoDB\Driver\Query $query [, MongoDB\Driver\ReadPreference $readPreference ] )
final public string getHost ( void )
final public array getInfo ( void )
final public string getLatency ( void )
final public int getPort ( void )
final public array getTags ( void )
final public int getType ( void )
final public bool isArbiter ( void )
final public bool isHidden ( void )
final public bool isPassive ( void )
final public bool isPrimary ( void )
final public bool isSecondary ( void )
}

Öntanımlı Sabitler

MongoDB\Driver\Server::TYPE_UNKNOWN

Unknown server type, returned by MongoDB\Driver\Server::getType().

MongoDB\Driver\Server::TYPE_STANDALONE

Standalone server type, returned by MongoDB\Driver\Server::getType().

MongoDB\Driver\Server::TYPE_MONGOS

Mongos server type, returned by MongoDB\Driver\Server::getType().

MongoDB\Driver\Server::TYPE_POSSIBLE_PRIMARY

Replica set possible primary server type, returned by MongoDB\Driver\Server::getType().

A server may be identified as a possible primary if it has not yet been checked but another memory of the replica set thinks it is the primary.

MongoDB\Driver\Server::TYPE_RS_PRIMARY

Replica set primary server type, returned by MongoDB\Driver\Server::getType().

MongoDB\Driver\Server::TYPE_RS_SECONDARY

Replica set secondary server type, returned by MongoDB\Driver\Server::getType().

MongoDB\Driver\Server::TYPE_RS_ARBITER

Replica set arbiter server type, returned by MongoDB\Driver\Server::getType().

MongoDB\Driver\Server::TYPE_RS_OTHER

Replica set other server type, returned by MongoDB\Driver\Server::getType().

Such servers may be hidden, starting up, or recovering. They cannot be queried, but their hosts lists are useful for discovering the current replica set configuration.

MongoDB\Driver\Server::TYPE_RS_GHOST

Replica set ghost server type, returned by MongoDB\Driver\Server::getType().

Servers may be identified as such in at least three situations: briefly during server startup; in an uninitialized replica set; or when the server is shunned (i.e. removed from the replica set config). They cannot be queried, nor can their host list be used to discover the current replica set configuration; however, the client may monitor this server in hope that it transitions to a more useful state.

İçindekiler

  • MongoDB\Driver\Server::__construct — Create a new Server (not used)
  • MongoDB\Driver\Server::executeBulkWrite — Execute one or more write operations on this server
  • MongoDB\Driver\Server::executeCommand — Execute a database command on this server
  • MongoDB\Driver\Server::executeQuery — Execute a database query on this server
  • MongoDB\Driver\Server::getHost — Returns the hostname of this server
  • MongoDB\Driver\Server::getInfo — Returns an array of information about this server
  • MongoDB\Driver\Server::getLatency — Returns the latency of this server
  • MongoDB\Driver\Server::getPort — Returns the port on which this server is listening
  • MongoDB\Driver\Server::getTags — Returns an array of tags describing this server in a replica set
  • MongoDB\Driver\Server::getType — Returns an integer denoting the type of this server
  • MongoDB\Driver\Server::isArbiter — Checks if this server is an arbiter member of a replica set
  • MongoDB\Driver\Server::isHidden — Checks if this server is a hidden member of a replica set
  • MongoDB\Driver\Server::isPassive — Checks if this server is a passive member of a replica set
  • MongoDB\Driver\Server::isPrimary — Checks if this server is a primary member of a replica set
  • MongoDB\Driver\Server::isSecondary — Checks if this server is a secondary member of a replica set
MongoDB\Driver\CursorId::__toString
MongoDB\Driver\Server::__construct
MongoDB\Driver


Create a new Server (not used)

MongoDB\Driver\Server
MongoDB\Driver\Server::executeBulkWrite
MongoDB\Driver\Server
PHP Manual

MongoDB\Driver\Server::__construct

(mongodb >=1.0.0)

MongoDB\Driver\Server::__construct — Create a new Server (not used)

Açıklama

final private MongoDB\Driver\Server::__construct ( void )

MongoDB\Driver\Server objects are created internally by MongoDB\Driver\Manager when a database connection is established and may be returned by MongoDB\Driver\Manager::getServers() and MongoDB\Driver\Manager::selectServer().

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Ayrıca Bakınız

  • MongoDB\Driver\Manager::getServers() - Return the servers to which this manager is connected
  • MongoDB\Driver\Manager::selectServer() - Select a server matching a read preference
MongoDB\Driver\Server
MongoDB\Driver\Server::executeBulkWrite
MongoDB\Driver\Server


Execute one or more write operations on this server

MongoDB\Driver\Server::__construct
MongoDB\Driver\Server::executeCommand
MongoDB\Driver\Server
PHP Manual

MongoDB\Driver\Server::executeBulkWrite

(mongodb >=1.0.0)

MongoDB\Driver\Server::executeBulkWrite — Execute one or more write operations on this server

Açıklama

final public MongoDB\Driver\WriteResult MongoDB\Driver\Server::executeBulkWrite ( string $namespace , MongoDB\Driver\BulkWrite $bulk [, MongoDB\Driver\WriteConcern $writeConcern ] )

Executes one or more write operations on this server.

A MongoDB\Driver\BulkWrite can be constructed with one or more write operations of varying types (e.g. updates, deletes, and inserts). The driver will attempt to send operations of the same type to the server in as few requests as possible to optimize round trips.

Değiştirgeler

namespace

A fully qualified namespace (databaseName.collectionName)

bulk (MongoDB\Driver\BulkWrite)

The MongoDB\Driver\BulkWrite to execute.

writeConcern

Optionally, a MongoDB\Driver\WriteConcern. If none given, default to the Write Concern set by the MongoDB Connection URI.

Dönen Değerler

Returns MongoDB\Driver\WriteResult on success.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\BulkWriteException on any write failure (WriteError and WriteConcern failures)
  • Throws MongoDB\Driver\AuthenticationException if authentication is needed and fails
  • Throws MongoDB\Driver\ConnectionException if connection to the server fails for other then authentication reasons
  • Throws MongoDB\Driver\Exception\RuntimeException on other errors.

Notlar

Bilginize:

It is the caller's responsibility to ensure that the server is capable of executing the write operation. For example, executing a write operation on a secondary (excluding its "local" database) will fail.

Ayrıca Bakınız

  • MongoDB\Driver\BulkWrite
  • MongoDB\Driver\WriteResult
  • MongoDB\Driver\WriteConcern
  • MongoDB\Driver\Manager::executeBulkWrite() - Execute one or more write operations
MongoDB\Driver\Server::__construct
MongoDB\Driver\Server::executeCommand
MongoDB\Driver\Server


Execute a database command on this server

MongoDB\Driver\Server::executeBulkWrite
MongoDB\Driver\Server::executeQuery
MongoDB\Driver\Server
PHP Manual

MongoDB\Driver\Server::executeCommand

(mongodb >=1.0.0)

MongoDB\Driver\Server::executeCommand — Execute a database command on this server

Açıklama

final public MongoDB\Driver\Cursor MongoDB\Driver\Server::executeCommand ( string $db , MongoDB\Driver\Command $command [, MongoDB\Driver\ReadPreference $readPreference ] )

Executes command on this server.

Bilginize:

The readPreference parameter does not control the server to which the driver issues the command; the command will always be executed on this server object. Instead, it may be used when issuing the command to a secondary (from a replica set connection, not standalone) or mongos node to ensure that the driver sets the wire protocol accordingly or adds the read preference to the command document, respectively.

Değiştirgeler

db (string)

The name of the database on which to execute the command.

command (MongoDB\Driver\Command)

The MongoDB\Driver\Command to execute.

readPreference

Optionally, a MongoDB\Driver\ReadPreference to route the command to. If none given, defaults to the Read Preferences set by the MongoDB Connection URI.

Dönen Değerler

Returns MongoDB\Driver\Cursor on success.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\AuthenticationException if authentication is needed and fails
  • Throws MongoDB\Driver\ConnectionException if connection to the server fails for other then authentication reasons
  • Throws MongoDB\Driver\Exception\RuntimeException on other errors (e.g. invalid command, issuing a write command to a secondary).

Notlar

Bilginize:

This method does not take a MongoDB\Driver\WriteConcern parameter. For write commands (e.g. » findAndModify in MongoDB 3.2+), the write concern should be included in the command document itself.

It is the caller's responsibility to ensure that the server is capable of executing the command. For example, executing a write operation on a secondary (excluding its "local" database) will fail.

Ayrıca Bakınız

  • MongoDB\Driver\Command
  • MongoDB\Driver\Cursor
  • MongoDB\Driver\ReadPreference
  • MongoDB\Driver\Manager::executeCommand() - Execute a database command
MongoDB\Driver\Server::executeBulkWrite
MongoDB\Driver\Server::executeQuery
MongoDB\Driver\Server


Execute a database query on this server

MongoDB\Driver\Server::executeCommand
MongoDB\Driver\Server::getHost
MongoDB\Driver\Server
PHP Manual

MongoDB\Driver\Server::executeQuery

(mongodb >=1.0.0)

MongoDB\Driver\Server::executeQuery — Execute a database query on this server

Açıklama

final public MongoDB\Driver\Cursor MongoDB\Driver\Server::executeQuery ( string $namespace , MongoDB\Driver\Query $query [, MongoDB\Driver\ReadPreference $readPreference ] )

Executes query on this server.

Bilginize:

The readPreference parameter does not control the server to which the driver issues the query; the query will always be executed on this server object. Instead, it may be used when issuing the command to a secondary (from a replica set connection, not standalone) or mongos node to ensure that the driver sets the wire protocol accordingly or adds the read preference to the query document, respectively.

Değiştirgeler

namespace

A fully qualified namespace (databaseName.collectionName)

query (MongoDB\Driver\Query)

The MongoDB\Driver\Query to execute.

readPreference

Optionally, a MongoDB\Driver\ReadPreference to route the command to. If none given, defaults to the Read Preferences set by the MongoDB Connection URI.

Dönen Değerler

Returns MongoDB\Driver\Cursor on success.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\AuthenticationException if authentication is needed and fails
  • Throws MongoDB\Driver\ConnectionException if connection to the server fails for other then authentication reasons
  • Throws MongoDB\Driver\Exception\RuntimeException on other errors (e.g. invalid query operators).

Ayrıca Bakınız

  • MongoDB\Driver\Cursor
  • MongoDB\Driver\Query
  • MongoDB\Driver\ReadPreference
  • MongoDB\Driver\Manager::executeQuery() - Execute a database query
MongoDB\Driver\Server::executeCommand
MongoDB\Driver\Server::getHost
MongoDB\Driver\Server


Returns the hostname of this server

MongoDB\Driver\Server::executeQuery
MongoDB\Driver\Server::getInfo
MongoDB\Driver\Server
PHP Manual

MongoDB\Driver\Server::getHost

(mongodb >=1.0.0)

MongoDB\Driver\Server::getHost — Returns the hostname of this server

Açıklama

final public string MongoDB\Driver\Server::getHost ( void )

Returns the hostname of this server.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the hostname of this server.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\Server::getHost() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017/");

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_PRIMARY);
$server = $manager->selectServer($rp);

var_dump($server->getHost());

?>

Yukarıdaki örneğin çıktısı:

string(9) "localhost"

Ayrıca Bakınız

  • MongoDB\Driver\Server::getInfo() - Returns an array of information about this server
MongoDB\Driver\Server::executeQuery
MongoDB\Driver\Server::getInfo
MongoDB\Driver\Server


Returns an array of information about this server

MongoDB\Driver\Server::getHost
MongoDB\Driver\Server::getLatency
MongoDB\Driver\Server
PHP Manual

MongoDB\Driver\Server::getInfo

(mongodb >=1.0.0)

MongoDB\Driver\Server::getInfo — Returns an array of information about this server

Açıklama

final public array MongoDB\Driver\Server::getInfo ( void )

Returns an array of information about this server.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array of information about this server.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\Server::getInfo() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017/");

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_PRIMARY);
$server = $manager->selectServer($rp);

var_dump($server->getInfo());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(8) {
  ["ismaster"]=>
  bool(true)
  ["maxBsonObjectSize"]=>
  int(16777216)
  ["maxMessageSizeBytes"]=>
  int(48000000)
  ["maxWriteBatchSize"]=>
  int(1000)
  ["localTime"]=>
  object(MongoDB\BSON\UTCDateTime)#4 (1) {
    ["milliseconds"]=>
    int(1447276242774)
  }
  ["maxWireVersion"]=>
  int(3)
  ["minWireVersion"]=>
  int(0)
  ["ok"]=>
  float(1)
}
MongoDB\Driver\Server::getHost
MongoDB\Driver\Server::getLatency
MongoDB\Driver\Server


Returns the latency of this server

MongoDB\Driver\Server::getInfo
MongoDB\Driver\Server::getPort
MongoDB\Driver\Server
PHP Manual

MongoDB\Driver\Server::getLatency

(mongodb >=1.0.0)

MongoDB\Driver\Server::getLatency — Returns the latency of this server

Açıklama

final public string MongoDB\Driver\Server::getLatency ( void )

Returns the latency of this server (i.e. the client's measured » round trip time of an ismaster command).

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the latency of this server.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\Server::getLatency() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017/");

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_PRIMARY);
$server = $manager->selectServer($rp);

var_dump($server->getLatency());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(592)

Ayrıca Bakınız

  • MongoDB\Driver\Server::getInfo() - Returns an array of information about this server
  • » Server Discovery and Monitoring Specification
MongoDB\Driver\Server::getInfo
MongoDB\Driver\Server::getPort
MongoDB\Driver\Server


Returns the port on which this server is listening

MongoDB\Driver\Server::getLatency
MongoDB\Driver\Server::getTags
MongoDB\Driver\Server
PHP Manual

MongoDB\Driver\Server::getPort

(mongodb >=1.0.0)

MongoDB\Driver\Server::getPort — Returns the port on which this server is listening

Açıklama

final public int MongoDB\Driver\Server::getPort ( void )

Returns the port on which this server is listening.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the port on which this server is listening.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\Server::getPort() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://localhost:27017/");

$rp = new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_PRIMARY);
$server = $manager->selectServer($rp);

var_dump($server->getPort());

?>

Yukarıdaki örneğin çıktısı:

int(27017)

Ayrıca Bakınız

  • MongoDB\Driver\Server::getInfo() - Returns an array of information about this server
MongoDB\Driver\Server::getLatency
MongoDB\Driver\Server::getTags
MongoDB\Driver\Server


Returns an array of tags describing this server in a replica set

MongoDB\Driver\Server::getPort
MongoDB\Driver\Server::getType
MongoDB\Driver\Server
PHP Manual

MongoDB\Driver\Server::getTags

(mongodb >=1.0.0)

MongoDB\Driver\Server::getTags — Returns an array of tags describing this server in a replica set

Açıklama

final public array MongoDB\Driver\Server::getTags ( void )

Returns an array of » tags used to describe this server in a replica set. The array will contain zero or more string key and value pairs.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array of tags used to describe this server in a replica set.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Ayrıca Bakınız

  • MongoDB\Driver\Server::getInfo() - Returns an array of information about this server
MongoDB\Driver\Server::getPort
MongoDB\Driver\Server::getType
MongoDB\Driver\Server


Returns an integer denoting the type of this server

MongoDB\Driver\Server::getTags
MongoDB\Driver\Server::isArbiter
MongoDB\Driver\Server
PHP Manual

MongoDB\Driver\Server::getType

(mongodb >=1.0.0)

MongoDB\Driver\Server::getType — Returns an integer denoting the type of this server

Açıklama

final public int MongoDB\Driver\Server::getType ( void )

Returns an integer denoting the type of this server. The value will correlate with a MongoDB\Driver\Server constant.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an integer denoting the type of this server.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Ayrıca Bakınız

  • MongoDB\Driver\Server::getInfo() - Returns an array of information about this server
MongoDB\Driver\Server::getTags
MongoDB\Driver\Server::isArbiter
MongoDB\Driver\Server


Checks if this server is an arbiter member of a replica set

MongoDB\Driver\Server::getType
MongoDB\Driver\Server::isHidden
MongoDB\Driver\Server
PHP Manual

MongoDB\Driver\Server::isArbiter

(mongodb >=1.0.0)

MongoDB\Driver\Server::isArbiter — Checks if this server is an arbiter member of a replica set

Açıklama

final public bool MongoDB\Driver\Server::isArbiter ( void )

Returns whether this server is an » arbiter member of a replica set.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if this server is an arbiter member of a replica set, and FALSE otherwise.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Ayrıca Bakınız

  • MongoDB\Driver\Server::getInfo() - Returns an array of information about this server
MongoDB\Driver\Server::getType
MongoDB\Driver\Server::isHidden
MongoDB\Driver\Server


Checks if this server is a hidden member of a replica set

MongoDB\Driver\Server::isArbiter
MongoDB\Driver\Server::isPassive
MongoDB\Driver\Server
PHP Manual

MongoDB\Driver\Server::isHidden

(mongodb >=1.0.0)

MongoDB\Driver\Server::isHidden — Checks if this server is a hidden member of a replica set

Açıklama

final public bool MongoDB\Driver\Server::isHidden ( void )

Returns whether this server is a » hidden member of a replica set.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if this server is a hidden member of a replica set, and FALSE otherwise.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Ayrıca Bakınız

  • MongoDB\Driver\Server::getInfo() - Returns an array of information about this server
MongoDB\Driver\Server::isArbiter
MongoDB\Driver\Server::isPassive
MongoDB\Driver\Server


Checks if this server is a passive member of a replica set

MongoDB\Driver\Server::isHidden
MongoDB\Driver\Server::isPrimary
MongoDB\Driver\Server
PHP Manual

MongoDB\Driver\Server::isPassive

(mongodb >=1.0.0)

MongoDB\Driver\Server::isPassive — Checks if this server is a passive member of a replica set

Açıklama

final public bool MongoDB\Driver\Server::isPassive ( void )

Returns whether this server is a » passive member of a replica set (i.e. its priority is 0).

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if this server is a passive member of a replica set, and FALSE otherwise.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Ayrıca Bakınız

  • MongoDB\Driver\Server::getInfo() - Returns an array of information about this server
MongoDB\Driver\Server::isHidden
MongoDB\Driver\Server::isPrimary
MongoDB\Driver\Server


Checks if this server is a primary member of a replica set

MongoDB\Driver\Server::isPassive
MongoDB\Driver\Server::isSecondary
MongoDB\Driver\Server
PHP Manual

MongoDB\Driver\Server::isPrimary

(mongodb >=1.0.0)

MongoDB\Driver\Server::isPrimary — Checks if this server is a primary member of a replica set

Açıklama

final public bool MongoDB\Driver\Server::isPrimary ( void )

Returns whether this server is a » primary member of a replica set.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if this server is a primary member of a replica set, and FALSE otherwise.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Ayrıca Bakınız

  • MongoDB\Driver\Server::getInfo() - Returns an array of information about this server
MongoDB\Driver\Server::isPassive
MongoDB\Driver\Server::isSecondary
MongoDB\Driver\Server


Checks if this server is a secondary member of a replica set

MongoDB\Driver\Server::isPrimary
MongoDB\Driver\WriteConcernError
MongoDB\Driver\Server
PHP Manual

MongoDB\Driver\Server::isSecondary

(mongodb >=1.0.0)

MongoDB\Driver\Server::isSecondary — Checks if this server is a secondary member of a replica set

Açıklama

final public bool MongoDB\Driver\Server::isSecondary ( void )

Returns whether this server is a » secondary member of a replica set.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if this server is a secondary member of a replica set, and FALSE otherwise.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Ayrıca Bakınız

  • MongoDB\Driver\Server::getInfo() - Returns an array of information about this server
MongoDB\Driver\Server::isPrimary
MongoDB\Driver\WriteConcernError
MongoDB\Driver\Server


The MongoDB\Driver\WriteConcernError class

(mongodb >=1.0.0)

Giriş

The MongoDB\Driver\WriteConcernError class encapsulates information about a write concern error and may be returned by MongoDB\Driver\WriteResult::getWriteConcernError().

Sınıf Sözdizimi

final MongoDB\Driver\WriteConcernError {
/* Yöntemler */
final public int getCode ( void )
final public mixed getInfo ( void )
final public string getMessage ( void )
}

İçindekiler

  • MongoDB\Driver\WriteConcernError::getCode — Returns the WriteConcernError's error code
  • MongoDB\Driver\WriteConcernError::getInfo — Returns additional metadata for the WriteConcernError
  • MongoDB\Driver\WriteConcernError::getMessage — Returns the WriteConcernError's error message
MongoDB\Driver\Server::isSecondary
MongoDB\Driver\WriteConcernError::getCode
MongoDB\Driver


Returns the WriteConcernError's error code

MongoDB\Driver\WriteConcernError
MongoDB\Driver\WriteConcernError::getInfo
MongoDB\Driver\WriteConcernError
PHP Manual

MongoDB\Driver\WriteConcernError::getCode

(mongodb >=1.0.0)

MongoDB\Driver\WriteConcernError::getCode — Returns the WriteConcernError's error code

Açıklama

final public int MongoDB\Driver\WriteConcernError::getCode ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the WriteConcernError's error code.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\WriteConcernError::getCode() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://rs1.example.com,rs2.example.com/?replicaSet=myReplicaSet");

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);

$writeConcern = new MongoDB\Driver\WriteConcern(2, 1);

try {
    $manager->executeBulkWrite('db.collection', $bulk, $writeConcern);
} catch(MongoDB\Driver\Exception\BulkWriteException $e) {
    var_dump($e->getWriteResult()->getWriteConcernError()->getCode());
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(64)

Ayrıca Bakınız

  • » Write Concern reference
MongoDB\Driver\WriteConcernError
MongoDB\Driver\WriteConcernError::getInfo
MongoDB\Driver\WriteConcernError


Returns additional metadata for the WriteConcernError

MongoDB\Driver\WriteConcernError::getCode
MongoDB\Driver\WriteConcernError::getMessage
MongoDB\Driver\WriteConcernError
PHP Manual

MongoDB\Driver\WriteConcernError::getInfo

(mongodb >=1.0.0)

MongoDB\Driver\WriteConcernError::getInfo — Returns additional metadata for the WriteConcernError

Açıklama

final public mixed MongoDB\Driver\WriteConcernError::getInfo ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns additional metadata for the WriteConcernError, or NULL if no metadata is available.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\WriteConcernError::getInfo() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://rs1.example.com,rs2.example.com/?replicaSet=myReplicaSet");

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);

$writeConcern = new MongoDB\Driver\WriteConcern(2, 1);

try {
    $manager->executeBulkWrite('db.collection', $bulk, $writeConcern);
} catch(MongoDB\Driver\Exception\BulkWriteException $e) {
    var_dump($e->getWriteResult()->getWriteConcernError()->getInfo());
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(stdClass)#1 (1) {
  ["wtimeout"]=>
  bool(true)
}

Ayrıca Bakınız

  • » Write Concern reference
MongoDB\Driver\WriteConcernError::getCode
MongoDB\Driver\WriteConcernError::getMessage
MongoDB\Driver\WriteConcernError


Returns the WriteConcernError's error message

MongoDB\Driver\WriteConcernError::getInfo
MongoDB\Driver\WriteError
MongoDB\Driver\WriteConcernError
PHP Manual

MongoDB\Driver\WriteConcernError::getMessage

(mongodb >=1.0.0)

MongoDB\Driver\WriteConcernError::getMessage — Returns the WriteConcernError's error message

Açıklama

final public string MongoDB\Driver\WriteConcernError::getMessage ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the WriteConcernError's error message.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\WriteConcernError::getMessage() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://rs1.example.com,rs2.example.com/?replicaSet=myReplicaSet");

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);

$writeConcern = new MongoDB\Driver\WriteConcern(2, 1);

try {
    $manager->executeBulkWrite('db.collection', $bulk, $writeConcern);
} catch(MongoDB\Driver\Exception\BulkWriteException $e) {
    var_dump($e->getWriteResult()->getWriteConcernError()->getMessage());
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(33) "waiting for replication timed out"

Ayrıca Bakınız

  • » Write Concern reference
MongoDB\Driver\WriteConcernError::getInfo
MongoDB\Driver\WriteError
MongoDB\Driver\WriteConcernError


The MongoDB\Driver\WriteError class

(mongodb >=1.0.0)

Giriş

The MongoDB\Driver\WriteError class encapsulates information about a write error and may be returned as an array element from MongoDB\Driver\WriteResult::getWriteErrors().

Sınıf Sözdizimi

final MongoDB\Driver\WriteError {
/* Yöntemler */
final public int getCode ( void )
final public int getIndex ( void )
final public mixed getInfo ( void )
final public string getMessage ( void )
}

İçindekiler

  • MongoDB\Driver\WriteError::getCode — Returns the WriteError's error code
  • MongoDB\Driver\WriteError::getIndex — Returns the index of the write operation corresponding to this WriteError
  • MongoDB\Driver\WriteError::getInfo — Returns additional metadata for the WriteError
  • MongoDB\Driver\WriteError::getMessage — Returns the WriteError's error message
MongoDB\Driver\WriteConcernError::getMessage
MongoDB\Driver\WriteError::getCode
MongoDB\Driver


Returns the WriteError's error code

MongoDB\Driver\WriteError
MongoDB\Driver\WriteError::getIndex
MongoDB\Driver\WriteError
PHP Manual

MongoDB\Driver\WriteError::getCode

(mongodb >=1.0.0)

MongoDB\Driver\WriteError::getCode — Returns the WriteError's error code

Açıklama

final public int MongoDB\Driver\WriteError::getCode ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the WriteError's error code.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\WriteError::getCode() example

<?php

$manager = new MongoDB\Driver\Manager;

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['_id' => 1]);
$bulk->insert(['_id' => 1]);

try {
    $manager->executeBulkWrite('db.collection', $bulk);
} catch(MongoDB\Driver\Exception\BulkWriteException $e) {
    var_dump($e->getWriteResult()->getWriteErrors()[0]->getCode());
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(11000)
MongoDB\Driver\WriteError
MongoDB\Driver\WriteError::getIndex
MongoDB\Driver\WriteError


Returns the index of the write operation corresponding to this WriteError

MongoDB\Driver\WriteError::getCode
MongoDB\Driver\WriteError::getInfo
MongoDB\Driver\WriteError
PHP Manual

MongoDB\Driver\WriteError::getIndex

(mongodb >=1.0.0)

MongoDB\Driver\WriteError::getIndex — Returns the index of the write operation corresponding to this WriteError

Açıklama

final public int MongoDB\Driver\WriteError::getIndex ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the index of the write operation (from MongoDB\Driver\BulkWrite) corresponding to this WriteError.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\WriteError::getIndex() example

<?php

$manager = new MongoDB\Driver\Manager;

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['_id' => 1]);
$bulk->insert(['_id' => 1]);

try {
    $manager->executeBulkWrite('db.collection', $bulk);
} catch(MongoDB\Driver\Exception\BulkWriteException $e) {
    var_dump($e->getWriteResult()->getWriteErrors()[0]->getIndex());
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(1)

Ayrıca Bakınız

  • MongoDB\Driver\BulkWrite
MongoDB\Driver\WriteError::getCode
MongoDB\Driver\WriteError::getInfo
MongoDB\Driver\WriteError


Returns additional metadata for the WriteError

MongoDB\Driver\WriteError::getIndex
MongoDB\Driver\WriteError::getMessage
MongoDB\Driver\WriteError
PHP Manual

MongoDB\Driver\WriteError::getInfo

(mongodb >=1.0.0)

MongoDB\Driver\WriteError::getInfo — Returns additional metadata for the WriteError

Açıklama

final public mixed MongoDB\Driver\WriteError::getInfo ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns additional metadata for the WriteError, or NULL if no metadata is available.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.
MongoDB\Driver\WriteError::getIndex
MongoDB\Driver\WriteError::getMessage
MongoDB\Driver\WriteError


Returns the WriteError's error message

MongoDB\Driver\WriteError::getInfo
MongoDB\Driver\WriteResult
MongoDB\Driver\WriteError
PHP Manual

MongoDB\Driver\WriteError::getMessage

(mongodb >=1.0.0)

MongoDB\Driver\WriteError::getMessage — Returns the WriteError's error message

Açıklama

final public string MongoDB\Driver\WriteError::getMessage ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the WriteError's error message.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\WriteError::getMessage() example

<?php

$manager = new MongoDB\Driver\Manager;

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['_id' => 1]);
$bulk->insert(['_id' => 1]);

try {
    $manager->executeBulkWrite('db.collection', $bulk);
} catch(MongoDB\Driver\Exception\BulkWriteException $e) {
    var_dump($e->getWriteResult()->getWriteErrors()[0]->getMessage());
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(70) "E11000 duplicate key error index: db.collection.$_id_ dup key: { : 1 }"
MongoDB\Driver\WriteError::getInfo
MongoDB\Driver\WriteResult
MongoDB\Driver\WriteError


The MongoDB\Driver\WriteResult class

(mongodb >=1.0.0)

Giriş

The MongoDB\Driver\WriteResult class encapsulates information about an executed MongoDB\Driver\BulkWrite and may be returned by MongoDB\Driver\Manager::executeBulkWrite().

Sınıf Sözdizimi

final MongoDB\Driver\WriteResult {
/* Yöntemler */
final public int|null getDeletedCount ( void )
final public int|null getInsertedCount ( void )
final public int|null getMatchedCount ( void )
final public int|null getModifiedCount ( void )
final public MongoDB\Driver\Server getServer ( void )
final public int|null getUpsertedCount ( void )
final public array getUpsertedIds ( void )
final public MongoDB\Driver\WriteConcernError|null getWriteConcernError ( void )
final public array getWriteErrors ( void )
final public bool isAcknowledged ( void )
}

İçindekiler

  • MongoDB\Driver\WriteResult::getDeletedCount — Returns the number of documents deleted
  • MongoDB\Driver\WriteResult::getInsertedCount — Returns the number of documents inserted (excluding upserts)
  • MongoDB\Driver\WriteResult::getMatchedCount — Returns the number of documents selected for update
  • MongoDB\Driver\WriteResult::getModifiedCount — Returns the number of existing documents updated
  • MongoDB\Driver\WriteResult::getServer — Returns the server associated with this write result
  • MongoDB\Driver\WriteResult::getUpsertedCount — Returns the number of documents inserted by an upsert
  • MongoDB\Driver\WriteResult::getUpsertedIds — Returns an array of identifiers for upserted documents
  • MongoDB\Driver\WriteResult::getWriteConcernError — Returns any write concern error that occurred
  • MongoDB\Driver\WriteResult::getWriteErrors — Returns any write errors that occurred
  • MongoDB\Driver\WriteResult::isAcknowledged — Returns whether the write was acknowledged
MongoDB\Driver\WriteError::getMessage
MongoDB\Driver\WriteResult::getDeletedCount
MongoDB\Driver


Returns the number of documents deleted

MongoDB\Driver\WriteResult
MongoDB\Driver\WriteResult::getInsertedCount
MongoDB\Driver\WriteResult
PHP Manual

MongoDB\Driver\WriteResult::getDeletedCount

(mongodb >=1.0.0)

MongoDB\Driver\WriteResult::getDeletedCount — Returns the number of documents deleted

Açıklama

final public int|null MongoDB\Driver\WriteResult::getDeletedCount ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the number of documents deleted, or NULL if the write was not acknowledged.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\WriteResult::getDeletedCount() example

<?php

$manager = new MongoDB\Driver\Manager;

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);
$bulk->update(['x' => 1], ['$set' => ['y' => 3]]);
$bulk->update(['x' => 2], ['$set' => ['y' => 1]], ['upsert' => true]);
$bulk->update(['x' => 3], ['$set' => ['y' => 2]], ['upsert' => true]);
$bulk->delete(['x' => 1]);

$result = $manager->executeBulkWrite('db.collection', $bulk);

var_dump($result->getDeletedCount());

?>

Yukarıdaki örneğin çıktısı:

int(1)

Ayrıca Bakınız

  • MongoDB\Driver\WriteResult::isAcknowledged() - Returns whether the write was acknowledged
MongoDB\Driver\WriteResult
MongoDB\Driver\WriteResult::getInsertedCount
MongoDB\Driver\WriteResult


Returns the number of documents inserted (excluding upserts)

MongoDB\Driver\WriteResult::getDeletedCount
MongoDB\Driver\WriteResult::getMatchedCount
MongoDB\Driver\WriteResult
PHP Manual

MongoDB\Driver\WriteResult::getInsertedCount

(mongodb >=1.0.0)

MongoDB\Driver\WriteResult::getInsertedCount — Returns the number of documents inserted (excluding upserts)

Açıklama

final public int|null MongoDB\Driver\WriteResult::getInsertedCount ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the number of documents inserted (excluding upserts), or NULL if the write was not acknowledged.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\WriteResult::getInsertedCount() example

<?php

$manager = new MongoDB\Driver\Manager;

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);
$bulk->update(['x' => 1], ['$set' => ['y' => 3]]);
$bulk->update(['x' => 2], ['$set' => ['y' => 1]], ['upsert' => true]);
$bulk->update(['x' => 3], ['$set' => ['y' => 2]], ['upsert' => true]);
$bulk->delete(['x' => 1]);

$result = $manager->executeBulkWrite('db.collection', $bulk);

var_dump($result->getInsertedCount());

?>

Yukarıdaki örneğin çıktısı:

int(1)

Ayrıca Bakınız

  • MongoDB\Driver\WriteResult::isAcknowledged() - Returns whether the write was acknowledged
MongoDB\Driver\WriteResult::getDeletedCount
MongoDB\Driver\WriteResult::getMatchedCount
MongoDB\Driver\WriteResult


Returns the number of documents selected for update

MongoDB\Driver\WriteResult::getInsertedCount
MongoDB\Driver\WriteResult::getModifiedCount
MongoDB\Driver\WriteResult
PHP Manual

MongoDB\Driver\WriteResult::getMatchedCount

(mongodb >=1.0.0)

MongoDB\Driver\WriteResult::getMatchedCount — Returns the number of documents selected for update

Açıklama

final public int|null MongoDB\Driver\WriteResult::getMatchedCount ( void )

If the update operation results in no change to the document (e.g. setting the value of a field to its current value), the matched count may be greater than the value returned by MongoDB\Driver\WriteResult::getModifiedCount().

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the number of documents selected for update, or NULL if the write was not acknowledged.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\WriteResult::getMatchedCount() example

<?php

$manager = new MongoDB\Driver\Manager;

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);
$bulk->update(['x' => 1], ['$set' => ['y' => 3]]);
$bulk->update(['x' => 2], ['$set' => ['y' => 1]], ['upsert' => true]);
$bulk->update(['x' => 3], ['$set' => ['y' => 2]], ['upsert' => true]);
$bulk->delete(['x' => 1]);

$result = $manager->executeBulkWrite('db.collection', $bulk);

var_dump($result->getMatchedCount());

?>

Yukarıdaki örneğin çıktısı:

int(1)

Ayrıca Bakınız

  • MongoDB\Driver\WriteResult::getModifiedCount() - Returns the number of existing documents updated
  • MongoDB\Driver\WriteResult::isAcknowledged() - Returns whether the write was acknowledged
MongoDB\Driver\WriteResult::getInsertedCount
MongoDB\Driver\WriteResult::getModifiedCount
MongoDB\Driver\WriteResult


Returns the number of existing documents updated

MongoDB\Driver\WriteResult::getMatchedCount
MongoDB\Driver\WriteResult::getServer
MongoDB\Driver\WriteResult
PHP Manual

MongoDB\Driver\WriteResult::getModifiedCount

(mongodb >=1.0.0)

MongoDB\Driver\WriteResult::getModifiedCount — Returns the number of existing documents updated

Açıklama

final public int|null MongoDB\Driver\WriteResult::getModifiedCount ( void )

If the update operation results in no change to the document (e.g. setting the value of a field to its current value), the modified count may be less than the value returned by MongoDB\Driver\WriteResult::getMatchedCount().

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the number of existing documents updated, or NULL if the write was not acknowledged.

The modified count is not available on versions of MongoDB before 2.6, which used the legacy wire protocol version (i.e. OP_UPDATE). If this is the case, the modified count will also be NULL.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\WriteResult::getModifiedCount() example

<?php

$manager = new MongoDB\Driver\Manager;

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);
$bulk->update(['x' => 1], ['$set' => ['y' => 3]]);
$bulk->update(['x' => 2], ['$set' => ['y' => 1]], ['upsert' => true]);
$bulk->update(['x' => 3], ['$set' => ['y' => 2]], ['upsert' => true]);
$bulk->delete(['x' => 1]);

$result = $manager->executeBulkWrite('db.collection', $bulk);

var_dump($result->getModifiedCount());

?>

Yukarıdaki örneğin çıktısı:

int(1)

Ayrıca Bakınız

  • MongoDB\Driver\WriteResult::getMatchedCount() - Returns the number of documents selected for update
  • MongoDB\Driver\WriteResult::isAcknowledged() - Returns whether the write was acknowledged
MongoDB\Driver\WriteResult::getMatchedCount
MongoDB\Driver\WriteResult::getServer
MongoDB\Driver\WriteResult


Returns the server associated with this write result

MongoDB\Driver\WriteResult::getModifiedCount
MongoDB\Driver\WriteResult::getUpsertedCount
MongoDB\Driver\WriteResult
PHP Manual

MongoDB\Driver\WriteResult::getServer

(mongodb >=1.0.0)

MongoDB\Driver\WriteResult::getServer — Returns the server associated with this write result

Açıklama

final public MongoDB\Driver\Server MongoDB\Driver\WriteResult::getServer ( void )

Returns the MongoDB\Driver\Server associated with this write result. This is the server that executed the MongoDB\Driver\BulkWrite.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the MongoDB\Driver\Server associated with this write result.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\WriteResult::getServer() example

<?php

$manager = new MongoDB\Driver\Manager;
$server = $manager->selectServer(new MongoDB\Driver\ReadPreference(MongoDB\Driver\ReadPreference::RP_PRIMARY));

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);

$result = $server->executeBulkWrite('db.collection', $bulk);

var_dump($result->getServer() == $server);

?>

Yukarıdaki örneğin çıktısı:

bool(true)

Ayrıca Bakınız

  • MongoDB\Driver\Server
MongoDB\Driver\WriteResult::getModifiedCount
MongoDB\Driver\WriteResult::getUpsertedCount
MongoDB\Driver\WriteResult


Returns the number of documents inserted by an upsert

MongoDB\Driver\WriteResult::getServer
MongoDB\Driver\WriteResult::getUpsertedIds
MongoDB\Driver\WriteResult
PHP Manual

MongoDB\Driver\WriteResult::getUpsertedCount

(mongodb >=1.0.0)

MongoDB\Driver\WriteResult::getUpsertedCount — Returns the number of documents inserted by an upsert

Açıklama

final public int|null MongoDB\Driver\WriteResult::getUpsertedCount ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the number of documents inserted by an upsert.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\WriteResult::getUpsertedCount() example

<?php

$manager = new MongoDB\Driver\Manager;

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);
$bulk->update(['x' => 1], ['$set' => ['y' => 3]]);
$bulk->update(['x' => 2], ['$set' => ['y' => 1]], ['upsert' => true]);
$bulk->update(['x' => 3], ['$set' => ['y' => 2]], ['upsert' => true]);
$bulk->delete(['x' => 1]);

$result = $manager->executeBulkWrite('db.collection', $bulk);

var_dump($result->getUpsertedCount());

?>

Yukarıdaki örneğin çıktısı:

int(2)

Ayrıca Bakınız

  • MongoDB\Driver\WriteResult::getUpsertedIds() - Returns an array of identifiers for upserted documents
  • MongoDB\Driver\WriteResult::isAcknowledged() - Returns whether the write was acknowledged
MongoDB\Driver\WriteResult::getServer
MongoDB\Driver\WriteResult::getUpsertedIds
MongoDB\Driver\WriteResult


Returns an array of identifiers for upserted documents

MongoDB\Driver\WriteResult::getUpsertedCount
MongoDB\Driver\WriteResult::getWriteConcernError
MongoDB\Driver\WriteResult
PHP Manual

MongoDB\Driver\WriteResult::getUpsertedIds

(mongodb >=1.0.0)

MongoDB\Driver\WriteResult::getUpsertedIds — Returns an array of identifiers for upserted documents

Açıklama

final public array MongoDB\Driver\WriteResult::getUpsertedIds ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array of identifiers (i.e. "_id" field values) for upserted documents. The array keys will correspond to the index of the write operation (from MongoDB\Driver\BulkWrite) responsible for the upsert.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\WriteResult::getUpsertedIds() example

<?php

$manager = new MongoDB\Driver\Manager;

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);
$bulk->update(['x' => 1], ['$set' => ['y' => 3]]);
$bulk->update(['x' => 2], ['$set' => ['y' => 1]], ['upsert' => true]);
$bulk->update(['x' => 3], ['$set' => ['y' => 2]], ['upsert' => true]);
$bulk->delete(['x' => 1]);

$result = $manager->executeBulkWrite('db.collection', $bulk);

var_dump($result->getUpsertedIds());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(2) {
  [2]=>
  object(MongoDB\BSON\ObjectID)#4 (1) {
    ["oid"]=>
    string(24) "580e62a224f2302f191b880b"
  }
  [3]=>
  object(MongoDB\BSON\ObjectID)#5 (1) {
    ["oid"]=>
    string(24) "580e62a224f2302f191b880c"
  }
}

Ayrıca Bakınız

  • MongoDB\Driver\WriteResult::getUpsertedCount() - Returns the number of documents inserted by an upsert
  • MongoDB\Driver\WriteResult::isAcknowledged() - Returns whether the write was acknowledged
MongoDB\Driver\WriteResult::getUpsertedCount
MongoDB\Driver\WriteResult::getWriteConcernError
MongoDB\Driver\WriteResult


Returns any write concern error that occurred

MongoDB\Driver\WriteResult::getUpsertedIds
MongoDB\Driver\WriteResult::getWriteErrors
MongoDB\Driver\WriteResult
PHP Manual

MongoDB\Driver\WriteResult::getWriteConcernError

(mongodb >=1.0.0)

MongoDB\Driver\WriteResult::getWriteConcernError — Returns any write concern error that occurred

Açıklama

final public MongoDB\Driver\WriteConcernError|null MongoDB\Driver\WriteResult::getWriteConcernError ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a MongoDB\Driver\WriteConcernError if a write concern error was encountered during the write operation, and NULL otherwise.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\WriteResult::getWriteConcernError() example

<?php

$manager = new MongoDB\Driver\Manager("mongodb://rs1.example.com,rs2.example.com/?replicaSet=myReplicaSet");

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);

$writeConcern = new MongoDB\Driver\WriteConcern(2, 1);

try {
    $manager->executeBulkWrite('db.collection', $bulk, $writeConcern);
} catch(MongoDB\Driver\Exception\BulkWriteException $e) {
    var_dump($e->getWriteResult()->getWriteConcernError());
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(MongoDB\Driver\WriteConcernError)#6 (3) {
  ["message"]=>
  string(33) "waiting for replication timed out"
  ["code"]=>
  int(64)
  ["info"]=>
  object(stdClass)#7 (1) {
    ["wtimeout"]=>
    bool(true)
  }
}

Ayrıca Bakınız

  • MongoDB\Driver\WriteConcern
  • » Write Concern reference
MongoDB\Driver\WriteResult::getUpsertedIds
MongoDB\Driver\WriteResult::getWriteErrors
MongoDB\Driver\WriteResult


Returns any write errors that occurred

MongoDB\Driver\WriteResult::getWriteConcernError
MongoDB\Driver\WriteResult::isAcknowledged
MongoDB\Driver\WriteResult
PHP Manual

MongoDB\Driver\WriteResult::getWriteErrors

(mongodb >=1.0.0)

MongoDB\Driver\WriteResult::getWriteErrors — Returns any write errors that occurred

Açıklama

final public array MongoDB\Driver\WriteResult::getWriteErrors ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array of MongoDB\Driver\WriteError objects for any write errors encountered during the write operation. The array will be empty if no write errors occurred.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\WriteResult::getWriteErrors() with a single error

<?php

$manager = new MongoDB\Driver\Manager;

/* By default, bulk write operations are executed serially in order and
 * execution will stop after the first error.
 */
$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['_id' => 1]);
$bulk->insert(['_id' => 2]);
$bulk->insert(['_id' => 2]);
$bulk->insert(['_id' => 3]);
$bulk->insert(['_id' => 4]);
$bulk->insert(['_id' => 4]);

try {
    $result = $manager->executeBulkWrite('db.collection', $bulk);
} catch (MongoDB\Driver\Exception\BulkWriteException $e) {
    var_dump($e->getWriteResult()->getWriteErrors());
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(1) {
  [0]=>
  object(MongoDB\Driver\WriteError)#5 (4) {
    ["message"]=>
    string(81) "E11000 duplicate key error collection: db.collection index: _id_ dup key: { : 2 }"
    ["code"]=>
    int(11000)
    ["index"]=>
    int(2)
    ["info"]=>
    NULL
  }
}

Örnek 2 MongoDB\Driver\WriteResult::getWriteErrors() with multiple errors

<?php

$manager = new MongoDB\Driver\Manager;

/* The "ordered" option may be used to allow bulk write operations to continue
 * executing after the first error is encountered.
 */
$bulk = new MongoDB\Driver\BulkWrite(['ordered' => false]);
$bulk->insert(['_id' => 1]);
$bulk->insert(['_id' => 2]);
$bulk->insert(['_id' => 2]);
$bulk->insert(['_id' => 3]);
$bulk->insert(['_id' => 4]);
$bulk->insert(['_id' => 4]);

try {
    $result = $manager->executeBulkWrite('db.collection', $bulk);
} catch (MongoDB\Driver\Exception\BulkWriteException $e) {
    var_dump($e->getWriteResult()->getWriteErrors());
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(2) {
  [0]=>
  object(MongoDB\Driver\WriteError)#5 (4) {
    ["message"]=>
    string(81) "E11000 duplicate key error collection: db.collection index: _id_ dup key: { : 2 }"
    ["code"]=>
    int(11000)
    ["index"]=>
    int(2)
    ["info"]=>
    NULL
  }
  [1]=>
  object(MongoDB\Driver\WriteError)#6 (4) {
    ["message"]=>
    string(81) "E11000 duplicate key error collection: db.collection index: _id_ dup key: { : 4 }"
    ["code"]=>
    int(11000)
    ["index"]=>
    int(5)
    ["info"]=>
    NULL
  }
}

Ayrıca Bakınız

  • MongoDB\Driver\WriteError
MongoDB\Driver\WriteResult::getWriteConcernError
MongoDB\Driver\WriteResult::isAcknowledged
MongoDB\Driver\WriteResult


Returns whether the write was acknowledged

MongoDB\Driver\WriteResult::getWriteErrors
MongoDB\BSON
MongoDB\Driver\WriteResult
PHP Manual

MongoDB\Driver\WriteResult::isAcknowledged

(mongodb >=1.0.0)

MongoDB\Driver\WriteResult::isAcknowledged — Returns whether the write was acknowledged

Açıklama

final public bool MongoDB\Driver\WriteResult::isAcknowledged ( void )

If the write is acknowledged, other count fields will be available on the MongoDB\Driver\WriteResult object.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the write was acknowledged, and FALSE otherwise.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\Driver\WriteResult::isAcknowledged() with acknowledged write concern

<?php

$manager = new MongoDB\Driver\Manager;

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);

$result = $manager->executeBulkWrite('db.collection', $bulk);

var_dump($result->isAcknowledged());

?>

Yukarıdaki örneğin çıktısı:

bool(true)

Örnek 2 MongoDB\Driver\WriteResult::isAcknowledged() with unacknowledged write concern

<?php

$manager = new MongoDB\Driver\Manager;

$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['x' => 1]);

$result = $manager->executeBulkWrite('db.collection', $bulk, new MongoDB\Driver\WriteConcern(0));

var_dump($result->isAcknowledged());

?>

Yukarıdaki örneğin çıktısı:

bool(false)

Ayrıca Bakınız

  • MongoDB\Driver\WriteConcern
  • » Write Concern reference
MongoDB\Driver\WriteResult::getWriteErrors
MongoDB\BSON
MongoDB\Driver\WriteResult


BSON type classes and serialization functions

  • İşlevleri
    • MongoDB\BSON\fromJSON — Returns the BSON representation of a JSON value
    • MongoDB\BSON\fromPHP — Returns the BSON representation of a PHP value
    • MongoDB\BSON\toJSON — Returns the JSON representation of a BSON value
    • MongoDB\BSON\toPHP — Returns the PHP representation of a BSON value
  • MongoDB\BSON\Binary — The MongoDB\BSON\Binary class
    • MongoDB\BSON\Binary::__construct — Construct a new Binary
    • MongoDB\BSON\Binary::getData — Returns the Binary's data
    • MongoDB\BSON\Binary::getType — Returns the Binary's type
    • MongoDB\BSON\Binary::jsonSerialize — Returns a representation that can be converted to JSON
    • MongoDB\BSON\Binary::serialize — Serialize a Binary
    • MongoDB\BSON\Binary::__toString — Returns the Binary's data
    • MongoDB\BSON\Binary::unserialize — Unserialize a Binary
  • MongoDB\BSON\Decimal128 — The MongoDB\BSON\Decimal128 class
    • MongoDB\BSON\Decimal128::__construct — Construct a new Decimal128
    • MongoDB\BSON\Decimal128::jsonSerialize — Returns a representation that can be converted to JSON
    • MongoDB\BSON\Decimal128::serialize — Serialize a Decimal128
    • MongoDB\BSON\Decimal128::__toString — Returns the string representation of this Decimal128
    • MongoDB\BSON\Decimal128::unserialize — Unserialize a Decimal128
  • MongoDB\BSON\Javascript — The MongoDB\BSON\Javascript class
    • MongoDB\BSON\Javascript::__construct — Construct a new Javascript
    • MongoDB\BSON\Javascript::getCode — Returns the Javascript's code
    • MongoDB\BSON\Javascript::getScope — Returns the Javascript's scope document
    • MongoDB\BSON\Javascript::jsonSerialize — Returns a representation that can be converted to JSON
    • MongoDB\BSON\Javascript::serialize — Serialize a Javascript
    • MongoDB\BSON\Javascript::__toString — Returns the Javascript's code
    • MongoDB\BSON\Javascript::unserialize — Unserialize a Javascript
  • MongoDB\BSON\MaxKey — The MongoDB\BSON\MaxKey class
    • MongoDB\BSON\MaxKey::__construct — Construct a new MaxKey
    • MongoDB\BSON\MaxKey::jsonSerialize — Returns a representation that can be converted to JSON
    • MongoDB\BSON\MaxKey::serialize — Serialize a MaxKey
    • MongoDB\BSON\MaxKey::unserialize — Unserialize a MaxKey
  • MongoDB\BSON\MinKey — The MongoDB\BSON\MinKey class
    • MongoDB\BSON\MinKey::__construct — Construct a new MinKey
    • MongoDB\BSON\MinKey::jsonSerialize — Returns a representation that can be converted to JSON
    • MongoDB\BSON\MinKey::serialize — Serialize a MinKey
    • MongoDB\BSON\MinKey::unserialize — Unserialize a MinKey
  • MongoDB\BSON\ObjectID — The MongoDB\BSON\ObjectID class
    • MongoDB\BSON\ObjectID::__construct — Construct a new ObjectID
    • MongoDB\BSON\ObjectID::getTimestamp — Returns the timestamp component of this ObjectID
    • MongoDB\BSON\ObjectID::jsonSerialize — Returns a representation that can be converted to JSON
    • MongoDB\BSON\ObjectID::serialize — Serialize an ObjectID
    • MongoDB\BSON\ObjectID::__toString — Returns the hexidecimal representation of this ObjectID
    • MongoDB\BSON\ObjectID::unserialize — Unserialize an ObjectID
  • MongoDB\BSON\Regex — The MongoDB\BSON\Regex class
    • MongoDB\BSON\Regex::__construct — Construct a new Regex
    • MongoDB\BSON\Regex::getFlags — Returns the Regex's flags
    • MongoDB\BSON\Regex::getPattern — Returns the Regex's pattern
    • MongoDB\BSON\Regex::jsonSerialize — Returns a representation that can be converted to JSON
    • MongoDB\BSON\Regex::serialize — Serialize a Regex
    • MongoDB\BSON\Regex::__toString — Returns the string representation of this Regex
    • MongoDB\BSON\Regex::unserialize — Unserialize a Regex
  • MongoDB\BSON\Timestamp — The MongoDB\BSON\Timestamp class
    • MongoDB\BSON\Timestamp::__construct — Construct a new Timestamp
    • MongoDB\BSON\Timestamp::jsonSerialize — Returns a representation that can be converted to JSON
    • MongoDB\BSON\Timestamp::serialize — Serialize a Timestamp
    • MongoDB\BSON\Timestamp::__toString — Returns the string representation of this Timestamp
    • MongoDB\BSON\Timestamp::unserialize — Unserialize a Timestamp
  • MongoDB\BSON\UTCDateTime — The MongoDB\BSON\UTCDateTime class
    • MongoDB\BSON\UTCDateTime::__construct — Construct a new UTCDateTime
    • MongoDB\BSON\UTCDateTime::jsonSerialize — Returns a representation that can be converted to JSON
    • MongoDB\BSON\UTCDateTime::serialize — Serialize a UTCDateTime
    • MongoDB\BSON\UTCDateTime::toDateTime — Returns the DateTime representation of this UTCDateTime
    • MongoDB\BSON\UTCDateTime::__toString — Returns the string representation of this UTCDateTime
    • MongoDB\BSON\UTCDateTime::unserialize — Unserialize a UTCDateTime
  • MongoDB\BSON\Type — The MongoDB\BSON\Type interface
  • MongoDB\BSON\Persistable — The MongoDB\BSON\Persistable interface
  • MongoDB\BSON\Serializable — The MongoDB\BSON\Serializable interface
    • MongoDB\BSON\Serializable::bsonSerialize — Provides an array or document to serialize as BSON
  • MongoDB\BSON\Unserializable — The MongoDB\BSON\Unserializable interface
    • MongoDB\BSON\Unserializable::bsonUnserialize — Constructs the object from a BSON array or document
MongoDB\Driver\WriteResult::isAcknowledged
İşlevleri
MongoDB


İşlevleri

İçindekiler

  • MongoDB\BSON\fromJSON — Returns the BSON representation of a JSON value
  • MongoDB\BSON\fromPHP — Returns the BSON representation of a PHP value
  • MongoDB\BSON\toJSON — Returns the JSON representation of a BSON value
  • MongoDB\BSON\toPHP — Returns the PHP representation of a BSON value
MongoDB\BSON
MongoDB\BSON\fromJSON
MongoDB\BSON


Returns the BSON representation of a JSON value

İşlevleri
MongoDB\BSON\fromPHP
İşlevleri
PHP Manual

MongoDB\BSON\fromJSON

(mongodb >=1.0.0)

MongoDB\BSON\fromJSON — Returns the BSON representation of a JSON value

Açıklama

string MongoDB\BSON\fromJSON ( string $json )

Converts an » extended JSON string to its BSON representation.

Değiştirgeler

json (string)

JSON value to be converted.

Dönen Değerler

The serialized BSON document as a binary string.

Hatalar/İstisnalar

Throws MongoDB\Driver\Exception\UnexpectedValueException if the JSON value cannot be converted to BSON (e.g. due to a syntax error).

Örnekler

Örnek 1 MongoDB\BSON\fromJSON() example

<?php

$json = '{ "_id": { "$oid": "563143b280d2387c91807965" } }';
$bson = MongoDB\BSON\fromJSON($json);
$value = MongoDB\BSON\toPHP($bson);
var_dump($value);

?>

Yukarıdaki örneğin çıktısı:

object(stdClass)#2 (1) {
  ["_id"]=>
  object(MongoDB\BSON\ObjectID)#1 (1) {
    ["oid"]=>
    string(24) "563143b280d2387c91807965"
  }
}

Ayrıca Bakınız

  • MongoDB\BSON\toJSON() - Returns the JSON representation of a BSON value
  • » MongoDB Extended JSON
  • » MongoDB BSON
İşlevleri
MongoDB\BSON\fromPHP
İşlevleri


Returns the BSON representation of a PHP value

MongoDB\BSON\fromJSON
MongoDB\BSON\toJSON
İşlevleri
PHP Manual

MongoDB\BSON\fromPHP

(mongodb >=1.0.0)

MongoDB\BSON\fromPHP — Returns the BSON representation of a PHP value

Açıklama

string MongoDB\BSON\fromPHP ( array|object $value )

Serializes a PHP array or object (e.g. document) to its » BSON representation. The returned binary string will describe a BSON document.

Değiştirgeler

value (array|object)

PHP value to be serialized.

Dönen Değerler

The serialized BSON document as a binary string.

Hatalar/İstisnalar

Throws MongoDB\Driver\Exception\UnexpectedValueException if the PHP value cannot be converted to BSON. Possible reasons include, but are not limited to, encountering an unexpected MongoDB\BSON\Type instance or MongoDB\BSON\Serializable::bsonSerialize() failing to return an array or stdClass.

Örnekler

Örnek 1 MongoDB\BSON\fromPHP() example

<?php

$bson = MongoDB\BSON\fromPHP(['foo' => 1]);
echo bin2hex($bson), "\n";

?>

Yukarıdaki örneğin çıktısı:

0e00000010666f6f000100000000cat

Ayrıca Bakınız

  • MongoDB\BSON\toPHP() - Returns the PHP representation of a BSON value
  • » MongoDB BSON
  • Persisting Data
MongoDB\BSON\fromJSON
MongoDB\BSON\toJSON
İşlevleri


Returns the JSON representation of a BSON value

MongoDB\BSON\fromPHP
MongoDB\BSON\toPHP
İşlevleri
PHP Manual

MongoDB\BSON\toJSON

(mongodb >=1.0.0)

MongoDB\BSON\toJSON — Returns the JSON representation of a BSON value

Açıklama

string MongoDB\BSON\toJSON ( string $bson )

Converts a BSON string to its » extended JSON representation.

Değiştirgeler

bson (string)

BSON value to be converted.

Dönen Değerler

The converted JSON value.

Hatalar/İstisnalar

Throws MongoDB\Driver\Exception\UnexpectedValueException if the input did not contain exactly one BSON document. Possible reasons include, but are not limited to, invalid BSON, extra data (after reading one BSON document), or an unexpected » libbson error.

Örnekler

Örnek 1 MongoDB\BSON\toJSON() example

<?php

$document = ['_id' => new MongoDB\BSON\ObjectId('56315a7c6118fd1b920270b1')];
$bson = MongoDB\BSON\fromPHP($document);
echo MongoDB\BSON\toJSON($bson), "\n";

?>

Yukarıdaki örneğin çıktısı:

{ "_id" : { "$oid" : "56315a7c6118fd1b920270b1" } }

Ayrıca Bakınız

  • MongoDB\BSON\fromJSON() - Returns the BSON representation of a JSON value
  • » MongoDB Extended JSON
  • » MongoDB BSON
MongoDB\BSON\fromPHP
MongoDB\BSON\toPHP
İşlevleri


Returns the PHP representation of a BSON value

MongoDB\BSON\toJSON
MongoDB\BSON\Binary
İşlevleri
PHP Manual

MongoDB\BSON\toPHP

(mongodb >=1.0.0)

MongoDB\BSON\toPHP — Returns the PHP representation of a BSON value

Açıklama

array|object MongoDB\BSON\toPHP ( string $bson [, array $typeMap = array() ] )

Unserializes a BSON document (i.e. binary string) to its PHP representation. The typeMap paramater may be used to control the PHP types used for converting BSON arrays and documents (both root and embedded).

Değiştirgeler

bson (string)

BSON value to be unserialized.

typeMap (array)

Type map configuration.

Dönen Değerler

The unserialized PHP value.

Hatalar/İstisnalar

Throws MongoDB\Driver\Exception\InvalidArgumentException if a class in the type map cannot be instantiated or does not implement MongoDB\BSON\Unserializable.

Throws MongoDB\Driver\Exception\UnexpectedValueException if the input did not contain exactly one BSON document. Possible reasons include, but are not limited to, invalid BSON, extra data (after reading one BSON document), or an unexpected » libbson error.

Örnekler

Örnek 1 MongoDB\BSON\toPHP() example

<?php

$bson = hex2bin('0e00000010666f6f000100000000');
$value = MongoDB\BSON\toPHP($bson);
var_dump($value);

?>

Yukarıdaki örneğin çıktısı:

object(stdClass)#1 (1) {
  ["foo"]=>
  int(1)
}

Ayrıca Bakınız

  • MongoDB\BSON\fromPHP() - Returns the BSON representation of a PHP value
  • » MongoDB BSON
  • Persisting Data
MongoDB\BSON\toJSON
MongoDB\BSON\Binary
İşlevleri


The MongoDB\BSON\Binary class

(mongodb >=1.0.0)

Giriş

Sınıf Sözdizimi

MongoDB\BSON\Binary implements MongoDB\BSON\Type , Serializable , JsonSerializable {
/* Constants */
const integer TYPE_GENERIC = 0 ;
const integer TYPE_FUNCTION = 1 ;
const integer TYPE_OLD_BINARY = 2 ;
const integer TYPE_OLD_UUID = 3 ;
const integer TYPE_UUID = 4 ;
const integer TYPE_MD5 = 5 ;
const integer TYPE_USER_DEFINED = 128 ;
/* Yöntemler */
final public __construct ( string $data , integer $type )
final public string getData ( void )
final public integer getType ( void )
final public mixed jsonSerialize ( void )
final public string serialize ( void )
final public string __toString ( void )
final public void unserialize ( string $serialized )
}

Öntanımlı Sabitler

MongoDB\BSON\Binary::TYPE_GENERIC

Generic binary data.

MongoDB\BSON\Binary::TYPE_FUNCTION

Function.

MongoDB\BSON\Binary::TYPE_OLD_BINARY

Generic binary data (deprecated in favor of MongoDB\BSON\Binary::TYPE_GENERIC).

MongoDB\BSON\Binary::TYPE_OLD_UUID

Universally unique identifier (deprecated in favor of MongoDB\BSON\Binary::TYPE_UUID). When using this type, the Binary's data should be 16 bytes in length.

Historically, other drivers encoded values with this type based on their language conventions (e.g. varying endianness), which makes it non-portable. The PHP driver applies no special handling for encoding or decoding data with this type.

MongoDB\BSON\Binary::TYPE_UUID

Universally unique identifier. When using this type, the Binary's data should be 16 bytes in length and encoded according to » RFC 4122.

MongoDB\BSON\Binary::TYPE_MD5

MD5 hash. When using this type, the Binary's data should be 16 bytes in length.

MongoDB\BSON\Binary::TYPE_USER_DEFINED

User-defined type. While types between 0 and 127 are predefined or reserved, types between 128 and 255 are user-defined and may be used for anything.

Sürüm Bilgisi

Sürüm: | Açıklama
1.2.0 | Implements Serializable and JsonSerializable.

İçindekiler

  • MongoDB\BSON\Binary::__construct — Construct a new Binary
  • MongoDB\BSON\Binary::getData — Returns the Binary's data
  • MongoDB\BSON\Binary::getType — Returns the Binary's type
  • MongoDB\BSON\Binary::jsonSerialize — Returns a representation that can be converted to JSON
  • MongoDB\BSON\Binary::serialize — Serialize a Binary
  • MongoDB\BSON\Binary::__toString — Returns the Binary's data
  • MongoDB\BSON\Binary::unserialize — Unserialize a Binary
MongoDB\BSON\toPHP
MongoDB\BSON\Binary::__construct
MongoDB\BSON


Construct a new Binary

MongoDB\BSON\Binary
MongoDB\BSON\Binary::getData
MongoDB\BSON\Binary
PHP Manual

MongoDB\BSON\Binary::__construct

(mongodb >=1.0.0)

MongoDB\BSON\Binary::__construct — Construct a new Binary

Açıklama

final public MongoDB\BSON\Binary::__construct ( string $data , integer $type )

Değiştirgeler

data (string)

Binary data.

type (integer)

Unsigned 8-bit integer denoting the data's type.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if type is not an unsigned 8-bit integer.

Sürüm Bilgisi

Sürüm: | Açıklama
1.1.3 | MongoDB\Driver\Exception\InvalidArgumentException is thrown if type is not an unsigned 8-bit integer.

Örnekler

Örnek 1 MongoDB\BSON\Binary::__construct() example

<?php

$binary = new MongoDB\BSON\Binary('foo', MongoDB\BSON\Binary::TYPE_GENERIC);
var_dump($binary);

?>

Yukarıdaki örneğin çıktısı:

object(MongoDB\BSON\Binary)#1 (2) {
  ["data"]=>
  string(3) "foo"
  ["type"]=>
  int(0)
}

Ayrıca Bakınız

  • » BSON Types
MongoDB\BSON\Binary
MongoDB\BSON\Binary::getData
MongoDB\BSON\Binary


Returns the Binary's data

MongoDB\BSON\Binary::__construct
MongoDB\BSON\Binary::getType
MongoDB\BSON\Binary
PHP Manual

MongoDB\BSON\Binary::getData

(mongodb >=1.0.0)

MongoDB\BSON\Binary::getData — Returns the Binary's data

Açıklama

final public string MongoDB\BSON\Binary::getData ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the Binary's data.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\BSON\Binary::getData() example

<?php

$binary = new MongoDB\BSON\Binary('foo', MongoDB\BSON\Binary::TYPE_GENERIC);
var_dump($binary->getData());

?>

Yukarıdaki örneğin çıktısı:

string(3) "foo"

Ayrıca Bakınız

  • » BSON Types
MongoDB\BSON\Binary::__construct
MongoDB\BSON\Binary::getType
MongoDB\BSON\Binary


Returns the Binary's type

MongoDB\BSON\Binary::getData
MongoDB\BSON\Binary::jsonSerialize
MongoDB\BSON\Binary
PHP Manual

MongoDB\BSON\Binary::getType

(mongodb >=1.0.0)

MongoDB\BSON\Binary::getType — Returns the Binary's type

Açıklama

final public integer MongoDB\BSON\Binary::getType ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the Binary's type.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\BSON\Binary::getType() example

<?php

$binary = new MongoDB\BSON\Binary('foo', MongoDB\BSON\Binary::TYPE_GENERIC);
var_dump($binary->getType());

?>

Yukarıdaki örneğin çıktısı:

int(0)

Ayrıca Bakınız

  • » BSON Types
MongoDB\BSON\Binary::getData
MongoDB\BSON\Binary::jsonSerialize
MongoDB\BSON\Binary


Returns a representation that can be converted to JSON

MongoDB\BSON\Binary::getType
MongoDB\BSON\Binary::serialize
MongoDB\BSON\Binary
PHP Manual

MongoDB\BSON\Binary::jsonSerialize

(mongodb >=1.2.0)

MongoDB\BSON\Binary::jsonSerialize — Returns a representation that can be converted to JSON

Açıklama

final public mixed MongoDB\BSON\Binary::jsonSerialize ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns data which can be serialized by json_encode() to produce the » extended JSON representation of the MongoDB\BSON\Binary.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Ayrıca Bakınız

  • JsonSerializable::jsonSerialize()
  • json_encode() - Değerin JSON karşılığını verir.
  • » MongoDB Extended JSON
MongoDB\BSON\Binary::getType
MongoDB\BSON\Binary::serialize
MongoDB\BSON\Binary


Serialize a Binary

MongoDB\BSON\Binary::jsonSerialize
MongoDB\BSON\Binary::__toString
MongoDB\BSON\Binary
PHP Manual

MongoDB\BSON\Binary::serialize

(mongodb >=1.2.0)

MongoDB\BSON\Binary::serialize — Serialize a Binary

Açıklama

final public string MongoDB\BSON\Binary::serialize ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the serialized representation of the MongoDB\BSON\Binary.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Ayrıca Bakınız

  • MongoDB\BSON\Binary::unserialize() - Unserialize a Binary
  • serialize() - Bir değerin saklanabilir bir gösterimini üretir
  • Serializing Objects
MongoDB\BSON\Binary::jsonSerialize
MongoDB\BSON\Binary::__toString
MongoDB\BSON\Binary


Returns the Binary's data

MongoDB\BSON\Binary::serialize
MongoDB\BSON\Binary::unserialize
MongoDB\BSON\Binary
PHP Manual

MongoDB\BSON\Binary::__toString

(mongodb >=1.2.0)

MongoDB\BSON\Binary::__toString — Returns the Binary's data

Açıklama

final public string MongoDB\BSON\Binary::__toString ( void )

Bu yöntem şu yöntemin takma adıdır: MongoDB\BSON\Binary::getData().

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the Binary's code.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\BSON\Binary::__toString() example

<?php

var_dump((string) new MongoDB\BSON\Binary('foo', MongoDB\BSON\Binary::TYPE_GENERIC));

?>

Yukarıdaki örneğin çıktısı:

string(3) "foo"

Ayrıca Bakınız

  • MongoDB\BSON\Binary::getData() - Returns the Binary's data
  • » BSON Types
MongoDB\BSON\Binary::serialize
MongoDB\BSON\Binary::unserialize
MongoDB\BSON\Binary


Unserialize a Binary

MongoDB\BSON\Binary::__toString
MongoDB\BSON\Decimal128
MongoDB\BSON\Binary
PHP Manual

MongoDB\BSON\Binary::unserialize

(mongodb >=1.2.0)

MongoDB\BSON\Binary::unserialize — Unserialize a Binary

Açıklama

final public void MongoDB\BSON\Binary::unserialize ( string $serialized )

Değiştirgeler

serialized

The serialized MongoDB\BSON\Binary.

Dönen Değerler

Returns the unserialized MongoDB\BSON\Binary.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\UnexpectedValueException if the properties cannot be unserialized (i.e. serialized was malformed).
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the properties are invalid (e.g. missing fields or invalid values).

Ayrıca Bakınız

  • MongoDB\BSON\Binary::serialize() - Serialize a Binary
  • unserialize() - Bir PHP değerini saklanmış gösteriminden oluşturur
  • Serializing Objects
MongoDB\BSON\Binary::__toString
MongoDB\BSON\Decimal128
MongoDB\BSON\Binary


The MongoDB\BSON\Decimal128 class

(mongodb >=1.2.0)

Giriş

BSON type for the » Decimal128 floating-point format, which supports numbers with up to 34 decimal digits (i.e. significant digits) and an exponent range of -6143 to +6144.

Unlike the double BSON type (i.e. float in PHP), which only stores an approximation of the decimal values, the decimal data type stores the exact value. For example, MongoDB\BSON\Decimal128('9.99') has a precise value of 9.99 where as a double 9.99 would have an approximate value of 9.9900000000000002131628....

Bilginize: MongoDB\BSON\Decimal128 is only compatible with MongoDB 3.4+. Attempting to use the BSON type with an earlier version of MongoDB will result in an error.

Sınıf Sözdizimi

MongoDB\BSON\Decimal128 implements MongoDB\BSON\Type , Serializable , JsonSerializable {
/* Yöntemler */
final public __construct ([ string $value ] )
final public mixed jsonSerialize ( void )
final public string serialize ( void )
final public string __toString ( void )
final public void unserialize ( string $serialized )
}

Sürüm Bilgisi

Sürüm: | Açıklama
1.2.0 | Implements Serializable and JsonSerializable.

İçindekiler

  • MongoDB\BSON\Decimal128::__construct — Construct a new Decimal128
  • MongoDB\BSON\Decimal128::jsonSerialize — Returns a representation that can be converted to JSON
  • MongoDB\BSON\Decimal128::serialize — Serialize a Decimal128
  • MongoDB\BSON\Decimal128::__toString — Returns the string representation of this Decimal128
  • MongoDB\BSON\Decimal128::unserialize — Unserialize a Decimal128
MongoDB\BSON\Binary::unserialize
MongoDB\BSON\Decimal128::__construct
MongoDB\BSON


Construct a new Decimal128

MongoDB\BSON\Decimal128
MongoDB\BSON\Decimal128::jsonSerialize
MongoDB\BSON\Decimal128
PHP Manual

MongoDB\BSON\Decimal128::__construct

(mongodb >=1.2.0)

MongoDB\BSON\Decimal128::__construct — Construct a new Decimal128

Açıklama

final public MongoDB\BSON\Decimal128::__construct ([ string $value ] )

Bilginize: MongoDB\BSON\Decimal128 is only compatible with MongoDB 3.4+. Attempting to use the BSON type with an earlier version of MongoDB will result in an error.

Değiştirgeler

value (string)

A decimal string.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if value is not a valid decimal string.

Örnekler

Örnek 1 MongoDB\BSON\Decimal128::__construct() example

<?php

var_dump(new MongoDB\BSON\Decimal128(1234.5678));
var_dump(new MongoDB\BSON\Decimal128(NAN));
var_dump(new MongoDB\BSON\Decimal128(INF));

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(MongoDB\BSON\Decimal128)#1 (1) {
  ["dec"]=>
  string(9) "1234.5678"
}
object(MongoDB\BSON\Decimal128)#1 (1) {
  ["dec"]=>
  string(3) "NaN"
}
object(MongoDB\BSON\Decimal128)#1 (1) {
  ["dec"]=>
  string(8) "Infinity"
}

Ayrıca Bakınız

  • » Decimal128 floating-point format
  • » BSON Types
MongoDB\BSON\Decimal128
MongoDB\BSON\Decimal128::jsonSerialize
MongoDB\BSON\Decimal128


Returns a representation that can be converted to JSON

MongoDB\BSON\Decimal128::__construct
MongoDB\BSON\Decimal128::serialize
MongoDB\BSON\Decimal128
PHP Manual

MongoDB\BSON\Decimal128::jsonSerialize

(mongodb >=1.2.0)

MongoDB\BSON\Decimal128::jsonSerialize — Returns a representation that can be converted to JSON

Açıklama

final public mixed MongoDB\BSON\Decimal128::jsonSerialize ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns data which can be serialized by json_encode() to produce the » extended JSON representation of the MongoDB\BSON\Decimal128.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Ayrıca Bakınız

  • JsonSerializable::jsonSerialize()
  • json_encode() - Değerin JSON karşılığını verir.
  • » MongoDB Extended JSON
MongoDB\BSON\Decimal128::__construct
MongoDB\BSON\Decimal128::serialize
MongoDB\BSON\Decimal128


Serialize a Decimal128

MongoDB\BSON\Decimal128::jsonSerialize
MongoDB\BSON\Decimal128::__toString
MongoDB\BSON\Decimal128
PHP Manual

MongoDB\BSON\Decimal128::serialize

(mongodb >=1.2.0)

MongoDB\BSON\Decimal128::serialize — Serialize a Decimal128

Açıklama

final public string MongoDB\BSON\Decimal128::serialize ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the serialized representation of the MongoDB\BSON\Decimal128.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Ayrıca Bakınız

  • MongoDB\BSON\Decimal128::unserialize() - Unserialize a Decimal128
  • serialize() - Bir değerin saklanabilir bir gösterimini üretir
  • Serializing Objects
MongoDB\BSON\Decimal128::jsonSerialize
MongoDB\BSON\Decimal128::__toString
MongoDB\BSON\Decimal128


Returns the string representation of this Decimal128

MongoDB\BSON\Decimal128::serialize
MongoDB\BSON\Decimal128::unserialize
MongoDB\BSON\Decimal128
PHP Manual

MongoDB\BSON\Decimal128::__toString

(mongodb >=1.2.0)

MongoDB\BSON\Decimal128::__toString — Returns the string representation of this Decimal128

Açıklama

final public string MongoDB\BSON\Decimal128::__toString ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the string representation of this Decimal128.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\BSON\Decimal128::__toString() example

<?php

var_dump((string) new MongoDB\BSON\Decimal128(1234.5678));
var_dump((string) new MongoDB\BSON\Decimal128(NAN));
var_dump((string) new MongoDB\BSON\Decimal128(INF));

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(9) "1234.5678"
string(3) "NaN"
string(8) "Infinity"

Ayrıca Bakınız

  • » Decimal128 floating-point format
  • » BSON Types
MongoDB\BSON\Decimal128::serialize
MongoDB\BSON\Decimal128::unserialize
MongoDB\BSON\Decimal128


Unserialize a Decimal128

MongoDB\BSON\Decimal128::__toString
MongoDB\BSON\Javascript
MongoDB\BSON\Decimal128
PHP Manual

MongoDB\BSON\Decimal128::unserialize

(mongodb >=1.2.0)

MongoDB\BSON\Decimal128::unserialize — Unserialize a Decimal128

Açıklama

final public void MongoDB\BSON\Decimal128::unserialize ( string $serialized )

Değiştirgeler

serialized

The serialized MongoDB\BSON\Decimal128.

Dönen Değerler

Returns the unserialized MongoDB\BSON\Decimal128.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\UnexpectedValueException if the properties cannot be unserialized (i.e. serialized was malformed).
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the properties are invalid (e.g. missing fields or invalid values).

Ayrıca Bakınız

  • MongoDB\BSON\Decimal128::serialize() - Serialize a Decimal128
  • unserialize() - Bir PHP değerini saklanmış gösteriminden oluşturur
  • Serializing Objects
MongoDB\BSON\Decimal128::__toString
MongoDB\BSON\Javascript
MongoDB\BSON\Decimal128


The MongoDB\BSON\Javascript class

(mongodb >=1.0.0)

Giriş

Sınıf Sözdizimi

MongoDB\BSON\Javascript implements MongoDB\BSON\Type , Serializable , JsonSerializable {
/* Yöntemler */
final public __construct ( string $code [, array|object $scope ] )
final public string getCode ( void )
final public object|null getScope ( void )
final public mixed jsonSerialize ( void )
final public string serialize ( void )
final public string __toString ( void )
final public void unserialize ( string $serialized )
}

Sürüm Bilgisi

Sürüm: | Açıklama
1.2.0 | Implements Serializable and JsonSerializable.

İçindekiler

  • MongoDB\BSON\Javascript::__construct — Construct a new Javascript
  • MongoDB\BSON\Javascript::getCode — Returns the Javascript's code
  • MongoDB\BSON\Javascript::getScope — Returns the Javascript's scope document
  • MongoDB\BSON\Javascript::jsonSerialize — Returns a representation that can be converted to JSON
  • MongoDB\BSON\Javascript::serialize — Serialize a Javascript
  • MongoDB\BSON\Javascript::__toString — Returns the Javascript's code
  • MongoDB\BSON\Javascript::unserialize — Unserialize a Javascript
MongoDB\BSON\Decimal128::unserialize
MongoDB\BSON\Javascript::__construct
MongoDB\BSON


Construct a new Javascript

MongoDB\BSON\Javascript
MongoDB\BSON\Javascript::getCode
MongoDB\BSON\Javascript
PHP Manual

MongoDB\BSON\Javascript::__construct

(mongodb >=1.0.0)

MongoDB\BSON\Javascript::__construct — Construct a new Javascript

Açıklama

final public MongoDB\BSON\Javascript::__construct ( string $code [, array|object $scope ] )

Değiştirgeler

code (string)

Javascript code.

scope (array|object)

Javascript scope.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if code contains null bytes.

Sürüm Bilgisi

Sürüm: | Açıklama
1.2.0 | MongoDB\Driver\Exception\InvalidArgumentException is thrown if code contains null bytes. Previously, values would be truncated at the first null byte.

Örnekler

Örnek 1 MongoDB\BSON\Javascript::__construct() example

<?php

$code = new MongoDB\BSON\Javascript('function() { return 1; }');
var_dump($code);

$codews = new MongoDB\BSON\Javascript('function() { return foo; }', ['foo' => 'bar']);
var_dump($codews);

?>

Yukarıdaki örneğin çıktısı:

object(MongoDB\BSON\Javascript)#1 (2) {
  ["javascript"]=>
  string(24) "function() { return 1; }"
  ["scope"]=>
  object(stdClass)#2 (0) {
  }
}
object(MongoDB\BSON\Javascript)#2 (2) {
  ["javascript"]=>
  string(26) "function() { return foo; }"
  ["scope"]=>
  object(stdClass)#1 (1) {
    ["foo"]=>
    string(3) "bar"
  }
}

Ayrıca Bakınız

  • » BSON Types
MongoDB\BSON\Javascript
MongoDB\BSON\Javascript::getCode
MongoDB\BSON\Javascript


Returns the Javascript's code

MongoDB\BSON\Javascript::__construct
MongoDB\BSON\Javascript::getScope
MongoDB\BSON\Javascript
PHP Manual

MongoDB\BSON\Javascript::getCode

(mongodb >=1.2.0)

MongoDB\BSON\Javascript::getCode — Returns the Javascript's code

Açıklama

final public string MongoDB\BSON\Javascript::getCode ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the Javascript's code.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\BSON\Javascript::getCode() example

<?php

$js = new MongoDB\BSON\Javascript('function foo(bar) { return bar; }');
var_dump($js->getCode());

?>

Yukarıdaki örneğin çıktısı:

string(33) "function foo(bar) { return bar; }"

Ayrıca Bakınız

  • » BSON Types
MongoDB\BSON\Javascript::__construct
MongoDB\BSON\Javascript::getScope
MongoDB\BSON\Javascript


Returns the Javascript's scope document

MongoDB\BSON\Javascript::getCode
MongoDB\BSON\Javascript::jsonSerialize
MongoDB\BSON\Javascript
PHP Manual

MongoDB\BSON\Javascript::getScope

(mongodb >=1.2.0)

MongoDB\BSON\Javascript::getScope — Returns the Javascript's scope document

Açıklama

final public object|null MongoDB\BSON\Javascript::getScope ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the Javascript's scope document.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\BSON\Javascript::getScope() example

<?php

$js = new MongoDB\BSON\Javascript('function foo(bar) { return bar; }');
var_dump($js->getScope());

$js = new MongoDB\BSON\Javascript('function foo() { return foo; }', ['foo' => 42]);
var_dump($js->getScope());

?>

Yukarıdaki örneğin çıktısı:

NULL
object(stdClass)#1 (1) {
  ["foo"]=>
  int(42)
}

Ayrıca Bakınız

  • » BSON Types
MongoDB\BSON\Javascript::getCode
MongoDB\BSON\Javascript::jsonSerialize
MongoDB\BSON\Javascript


Returns a representation that can be converted to JSON

MongoDB\BSON\Javascript::getScope
MongoDB\BSON\Javascript::serialize
MongoDB\BSON\Javascript
PHP Manual

MongoDB\BSON\Javascript::jsonSerialize

(mongodb >=1.2.0)

MongoDB\BSON\Javascript::jsonSerialize — Returns a representation that can be converted to JSON

Açıklama

final public mixed MongoDB\BSON\Javascript::jsonSerialize ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns data which can be serialized by json_encode() to produce the » extended JSON representation of the MongoDB\BSON\Javascript.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Ayrıca Bakınız

  • JsonSerializable::jsonSerialize()
  • json_encode() - Değerin JSON karşılığını verir.
  • » MongoDB Extended JSON
MongoDB\BSON\Javascript::getScope
MongoDB\BSON\Javascript::serialize
MongoDB\BSON\Javascript


Serialize a Javascript

MongoDB\BSON\Javascript::jsonSerialize
MongoDB\BSON\Javascript::__toString
MongoDB\BSON\Javascript
PHP Manual

MongoDB\BSON\Javascript::serialize

(mongodb >=1.2.0)

MongoDB\BSON\Javascript::serialize — Serialize a Javascript

Açıklama

final public string MongoDB\BSON\Javascript::serialize ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the serialized representation of the MongoDB\BSON\Javascript.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Ayrıca Bakınız

  • MongoDB\BSON\Javascript::unserialize() - Unserialize a Javascript
  • serialize() - Bir değerin saklanabilir bir gösterimini üretir
  • Serializing Objects
MongoDB\BSON\Javascript::jsonSerialize
MongoDB\BSON\Javascript::__toString
MongoDB\BSON\Javascript


Returns the Javascript's code

MongoDB\BSON\Javascript::serialize
MongoDB\BSON\Javascript::unserialize
MongoDB\BSON\Javascript
PHP Manual

MongoDB\BSON\Javascript::__toString

(mongodb >=1.2.0)

MongoDB\BSON\Javascript::__toString — Returns the Javascript's code

Açıklama

final public string MongoDB\BSON\Javascript::__toString ( void )

Bu yöntem şu yöntemin takma adıdır: MongoDB\BSON\Javascript::getCode().

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the Javascript's code.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\BSON\Javascript::__toString() example

<?php

var_dump((string) new MongoDB\BSON\Javascript('function foo(bar) { return bar; }'));

?>

Yukarıdaki örneğin çıktısı:

string(33) "function foo(bar) { return bar; }"

Ayrıca Bakınız

  • MongoDB\BSON\Javascript::getCode() - Returns the Javascript's code
  • » BSON Types
MongoDB\BSON\Javascript::serialize
MongoDB\BSON\Javascript::unserialize
MongoDB\BSON\Javascript


Unserialize a Javascript

MongoDB\BSON\Javascript::__toString
MongoDB\BSON\MaxKey
MongoDB\BSON\Javascript
PHP Manual

MongoDB\BSON\Javascript::unserialize

(mongodb >=1.2.0)

MongoDB\BSON\Javascript::unserialize — Unserialize a Javascript

Açıklama

final public void MongoDB\BSON\Javascript::unserialize ( string $serialized )

Değiştirgeler

serialized

The serialized MongoDB\BSON\Javascript.

Dönen Değerler

Returns the unserialized MongoDB\BSON\Javascript.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\UnexpectedValueException if the properties cannot be unserialized (i.e. serialized was malformed).
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the properties are invalid (e.g. missing fields or invalid values).

Ayrıca Bakınız

  • MongoDB\BSON\Javascript::serialize() - Serialize a Javascript
  • unserialize() - Bir PHP değerini saklanmış gösteriminden oluşturur
  • Serializing Objects
MongoDB\BSON\Javascript::__toString
MongoDB\BSON\MaxKey
MongoDB\BSON\Javascript


The MongoDB\BSON\MaxKey class

(mongodb >=1.0.0)

Giriş

Sınıf Sözdizimi

MongoDB\BSON\MaxKey implements MongoDB\BSON\Type , Serializable , JsonSerializable {
/* Yöntemler */
final public __construct ( void )
final public mixed jsonSerialize ( void )
final public string serialize ( void )
final public void unserialize ( string $serialized )
}

Sürüm Bilgisi

Sürüm: | Açıklama
1.2.0 | Implements Serializable and JsonSerializable.

İçindekiler

  • MongoDB\BSON\MaxKey::__construct — Construct a new MaxKey
  • MongoDB\BSON\MaxKey::jsonSerialize — Returns a representation that can be converted to JSON
  • MongoDB\BSON\MaxKey::serialize — Serialize a MaxKey
  • MongoDB\BSON\MaxKey::unserialize — Unserialize a MaxKey
MongoDB\BSON\Javascript::unserialize
MongoDB\BSON\MaxKey::__construct
MongoDB\BSON


Construct a new MaxKey

MongoDB\BSON\MaxKey
MongoDB\BSON\MaxKey::jsonSerialize
MongoDB\BSON\MaxKey
PHP Manual

MongoDB\BSON\MaxKey::__construct

(mongodb >=1.0.0)

MongoDB\BSON\MaxKey::__construct — Construct a new MaxKey

Açıklama

final public MongoDB\BSON\MaxKey::__construct ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\BSON\MaxKey::__construct() example

<?php

var_dump(new MongoDB\BSON\MaxKey());

?>

Yukarıdaki örneğin çıktısı:

object(MongoDB\BSON\MaxKey)#1 (0) {
}

Ayrıca Bakınız

  • » BSON Types
MongoDB\BSON\MaxKey
MongoDB\BSON\MaxKey::jsonSerialize
MongoDB\BSON\MaxKey


Returns a representation that can be converted to JSON

MongoDB\BSON\MaxKey::__construct
MongoDB\BSON\MaxKey::serialize
MongoDB\BSON\MaxKey
PHP Manual

MongoDB\BSON\MaxKey::jsonSerialize

(mongodb >=1.2.0)

MongoDB\BSON\MaxKey::jsonSerialize — Returns a representation that can be converted to JSON

Açıklama

final public mixed MongoDB\BSON\MaxKey::jsonSerialize ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns data which can be serialized by json_encode() to produce the » extended JSON representation of the MongoDB\BSON\MaxKey.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Ayrıca Bakınız

  • JsonSerializable::jsonSerialize()
  • json_encode() - Değerin JSON karşılığını verir.
  • » MongoDB Extended JSON
MongoDB\BSON\MaxKey::__construct
MongoDB\BSON\MaxKey::serialize
MongoDB\BSON\MaxKey


Serialize a MaxKey

MongoDB\BSON\MaxKey::jsonSerialize
MongoDB\BSON\MaxKey::unserialize
MongoDB\BSON\MaxKey
PHP Manual

MongoDB\BSON\MaxKey::serialize

(mongodb >=1.2.0)

MongoDB\BSON\MaxKey::serialize — Serialize a MaxKey

Açıklama

final public string MongoDB\BSON\MaxKey::serialize ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the serialized representation of the MongoDB\BSON\MaxKey.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Ayrıca Bakınız

  • MongoDB\BSON\MaxKey::unserialize() - Unserialize a MaxKey
  • serialize() - Bir değerin saklanabilir bir gösterimini üretir
  • Serializing Objects
MongoDB\BSON\MaxKey::jsonSerialize
MongoDB\BSON\MaxKey::unserialize
MongoDB\BSON\MaxKey


Unserialize a MaxKey

MongoDB\BSON\MaxKey::serialize
MongoDB\BSON\MinKey
MongoDB\BSON\MaxKey
PHP Manual

MongoDB\BSON\MaxKey::unserialize

(mongodb >=1.2.0)

MongoDB\BSON\MaxKey::unserialize — Unserialize a MaxKey

Açıklama

final public void MongoDB\BSON\MaxKey::unserialize ( string $serialized )

Değiştirgeler

serialized

The serialized MongoDB\BSON\MaxKey.

Dönen Değerler

Returns the unserialized MongoDB\BSON\MaxKey.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Ayrıca Bakınız

  • MongoDB\BSON\MaxKey::serialize() - Serialize a MaxKey
  • unserialize() - Bir PHP değerini saklanmış gösteriminden oluşturur
  • Serializing Objects
MongoDB\BSON\MaxKey::serialize
MongoDB\BSON\MinKey
MongoDB\BSON\MaxKey


The MongoDB\BSON\MinKey class

(mongodb >=1.0.0)

Giriş

Sınıf Sözdizimi

MongoDB\BSON\MinKey implements MongoDB\BSON\Type , Serializable , JsonSerializable {
/* Yöntemler */
final public __construct ( void )
final public mixed jsonSerialize ( void )
final public string serialize ( void )
final public void unserialize ( string $serialized )
}

Sürüm Bilgisi

Sürüm: | Açıklama
1.2.0 | Implements Serializable and JsonSerializable.

İçindekiler

  • MongoDB\BSON\MinKey::__construct — Construct a new MinKey
  • MongoDB\BSON\MinKey::jsonSerialize — Returns a representation that can be converted to JSON
  • MongoDB\BSON\MinKey::serialize — Serialize a MinKey
  • MongoDB\BSON\MinKey::unserialize — Unserialize a MinKey
MongoDB\BSON\MaxKey::unserialize
MongoDB\BSON\MinKey::__construct
MongoDB\BSON


Construct a new MinKey

MongoDB\BSON\MinKey
MongoDB\BSON\MinKey::jsonSerialize
MongoDB\BSON\MinKey
PHP Manual

MongoDB\BSON\MinKey::__construct

(mongodb >=1.0.0)

MongoDB\BSON\MinKey::__construct — Construct a new MinKey

Açıklama

final public MongoDB\BSON\MinKey::__construct ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\BSON\MinKey::__construct() example

<?php

var_dump(new MongoDB\BSON\MinKey());

?>

Yukarıdaki örneğin çıktısı:

object(MongoDB\BSON\MinKey)#1 (0) {
}

Ayrıca Bakınız

  • » BSON Types
MongoDB\BSON\MinKey
MongoDB\BSON\MinKey::jsonSerialize
MongoDB\BSON\MinKey


Returns a representation that can be converted to JSON

MongoDB\BSON\MinKey::__construct
MongoDB\BSON\MinKey::serialize
MongoDB\BSON\MinKey
PHP Manual

MongoDB\BSON\MinKey::jsonSerialize

(mongodb >=1.2.0)

MongoDB\BSON\MinKey::jsonSerialize — Returns a representation that can be converted to JSON

Açıklama

final public mixed MongoDB\BSON\MinKey::jsonSerialize ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns data which can be serialized by json_encode() to produce the » extended JSON representation of the MongoDB\BSON\MinKey.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Ayrıca Bakınız

  • JsonSerializable::jsonSerialize()
  • json_encode() - Değerin JSON karşılığını verir.
  • » MongoDB Extended JSON
MongoDB\BSON\MinKey::__construct
MongoDB\BSON\MinKey::serialize
MongoDB\BSON\MinKey


Serialize a MinKey

MongoDB\BSON\MinKey::jsonSerialize
MongoDB\BSON\MinKey::unserialize
MongoDB\BSON\MinKey
PHP Manual

MongoDB\BSON\MinKey::serialize

(mongodb >=1.2.0)

MongoDB\BSON\MinKey::serialize — Serialize a MinKey

Açıklama

final public string MongoDB\BSON\MinKey::serialize ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the serialized representation of the MongoDB\BSON\MinKey.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Ayrıca Bakınız

  • MongoDB\BSON\MinKey::unserialize() - Unserialize a MinKey
  • serialize() - Bir değerin saklanabilir bir gösterimini üretir
  • Serializing Objects
MongoDB\BSON\MinKey::jsonSerialize
MongoDB\BSON\MinKey::unserialize
MongoDB\BSON\MinKey


Unserialize a MinKey

MongoDB\BSON\MinKey::serialize
MongoDB\BSON\ObjectID
MongoDB\BSON\MinKey
PHP Manual

MongoDB\BSON\MinKey::unserialize

(mongodb >=1.2.0)

MongoDB\BSON\MinKey::unserialize — Unserialize a MinKey

Açıklama

final public void MongoDB\BSON\MinKey::unserialize ( string $serialized )

Değiştirgeler

serialized

The serialized MongoDB\BSON\MinKey.

Dönen Değerler

Returns the unserialized MongoDB\BSON\MinKey.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Ayrıca Bakınız

  • MongoDB\BSON\MinKey::serialize() - Serialize a MinKey
  • unserialize() - Bir PHP değerini saklanmış gösteriminden oluşturur
  • Serializing Objects
MongoDB\BSON\MinKey::serialize
MongoDB\BSON\ObjectID
MongoDB\BSON\MinKey


The MongoDB\BSON\ObjectID class

(mongodb >=1.0.0)

Giriş

Sınıf Sözdizimi

MongoDB\BSON\ObjectID implements MongoDB\BSON\Type , Serializable , JsonSerializable {
/* Yöntemler */
final public __construct ([ string $id ] )
final public integer getTimestamp ( void )
final public mixed jsonSerialize ( void )
final public string serialize ( void )
final public string __toString ( void )
final public void unserialize ( string $serialized )
}

Sürüm Bilgisi

Sürüm: | Açıklama
1.2.0 | Implements Serializable and JsonSerializable.

İçindekiler

  • MongoDB\BSON\ObjectID::__construct — Construct a new ObjectID
  • MongoDB\BSON\ObjectID::getTimestamp — Returns the timestamp component of this ObjectID
  • MongoDB\BSON\ObjectID::jsonSerialize — Returns a representation that can be converted to JSON
  • MongoDB\BSON\ObjectID::serialize — Serialize an ObjectID
  • MongoDB\BSON\ObjectID::__toString — Returns the hexidecimal representation of this ObjectID
  • MongoDB\BSON\ObjectID::unserialize — Unserialize an ObjectID
MongoDB\BSON\MinKey::unserialize
MongoDB\BSON\ObjectID::__construct
MongoDB\BSON


Construct a new ObjectID

MongoDB\BSON\ObjectID
MongoDB\BSON\ObjectID::getTimestamp
MongoDB\BSON\ObjectID
PHP Manual

MongoDB\BSON\ObjectID::__construct

(mongodb >=1.0.0)

MongoDB\BSON\ObjectID::__construct — Construct a new ObjectID

Açıklama

final public MongoDB\BSON\ObjectID::__construct ([ string $id ] )

Değiştirgeler

id (string)

A 24-character hexadecimal string. If not provided, the driver will generate an ObjectID.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if id is not a 24-character hexadecimal string.

Örnekler

Örnek 1 MongoDB\BSON\ObjectID::__construct() example

<?php

var_dump(new MongoDB\BSON\ObjectId());

var_dump(new MongoDB\BSON\ObjectId('000000000000000000000001'));

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(MongoDB\BSON\ObjectID)#1 (1) {
  ["oid"]=>
  string(24) "56732d3dda14d81214634921"
}
object(MongoDB\BSON\ObjectID)#1 (1) {
  ["oid"]=>
  string(24) "000000000000000000000001"
}

Ayrıca Bakınız

  • » ObjectID Reference
  • » BSON Types: ObjectID
MongoDB\BSON\ObjectID
MongoDB\BSON\ObjectID::getTimestamp
MongoDB\BSON\ObjectID


Returns the timestamp component of this ObjectID

MongoDB\BSON\ObjectID::__construct
MongoDB\BSON\ObjectID::jsonSerialize
MongoDB\BSON\ObjectID
PHP Manual

MongoDB\BSON\ObjectID::getTimestamp

(mongodb >=1.2.0)

MongoDB\BSON\ObjectID::getTimestamp — Returns the timestamp component of this ObjectID

Açıklama

final public integer MongoDB\BSON\ObjectID::getTimestamp ( void )

The timestamp component of an ObjectID is its first four bytes, which denote the number of seconds since the Unix epoch. This value is read as an unsigned 32-bit integer with big-endian byte order.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the timestamp component of this ObjectID.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\BSON\ObjectID::getTimestamp() example

<?php

var_dump((new MongoDB\BSON\ObjectId())->getTimestamp());

var_dump((new MongoDB\BSON\ObjectId('0000002a0000000000000000'))->getTimestamp());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

integer(1484854719)
integer(42)

Ayrıca Bakınız

  • » ObjectID Reference
  • » BSON Types: ObjectID
MongoDB\BSON\ObjectID::__construct
MongoDB\BSON\ObjectID::jsonSerialize
MongoDB\BSON\ObjectID


Returns a representation that can be converted to JSON

MongoDB\BSON\ObjectID::getTimestamp
MongoDB\BSON\ObjectID::serialize
MongoDB\BSON\ObjectID
PHP Manual

MongoDB\BSON\ObjectID::jsonSerialize

(mongodb >=1.2.0)

MongoDB\BSON\ObjectID::jsonSerialize — Returns a representation that can be converted to JSON

Açıklama

final public mixed MongoDB\BSON\ObjectID::jsonSerialize ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns data which can be serialized by json_encode() to produce the » extended JSON representation of the MongoDB\BSON\ObjectID.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Ayrıca Bakınız

  • JsonSerializable::jsonSerialize()
  • json_encode() - Değerin JSON karşılığını verir.
  • » MongoDB Extended JSON
MongoDB\BSON\ObjectID::getTimestamp
MongoDB\BSON\ObjectID::serialize
MongoDB\BSON\ObjectID


Serialize an ObjectID

MongoDB\BSON\ObjectID::jsonSerialize
MongoDB\BSON\ObjectID::__toString
MongoDB\BSON\ObjectID
PHP Manual

MongoDB\BSON\ObjectID::serialize

(mongodb >=1.2.0)

MongoDB\BSON\ObjectID::serialize — Serialize an ObjectID

Açıklama

final public string MongoDB\BSON\ObjectID::serialize ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the serialized representation of the MongoDB\BSON\ObjectID.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Ayrıca Bakınız

  • MongoDB\BSON\ObjectID::unserialize() - Unserialize an ObjectID
  • serialize() - Bir değerin saklanabilir bir gösterimini üretir
  • Serializing Objects
MongoDB\BSON\ObjectID::jsonSerialize
MongoDB\BSON\ObjectID::__toString
MongoDB\BSON\ObjectID


Returns the hexidecimal representation of this ObjectID

MongoDB\BSON\ObjectID::serialize
MongoDB\BSON\ObjectID::unserialize
MongoDB\BSON\ObjectID
PHP Manual

MongoDB\BSON\ObjectID::__toString

(mongodb >=1.0.0)

MongoDB\BSON\ObjectID::__toString — Returns the hexidecimal representation of this ObjectID

Açıklama

final public string MongoDB\BSON\ObjectID::__toString ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the hexidecimal representation of this ObjectID.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\BSON\ObjectID::__toString() example

<?php

var_dump((string) new MongoDB\BSON\ObjectId());
var_dump((string) new MongoDB\BSON\ObjectId('000000000000000000000001'));

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(24) "56731b49da14d8747d701211"
string(24) "000000000000000000000001"

Ayrıca Bakınız

  • » ObjectID Reference
  • » BSON Types: ObjectID
MongoDB\BSON\ObjectID::serialize
MongoDB\BSON\ObjectID::unserialize
MongoDB\BSON\ObjectID


Unserialize an ObjectID

MongoDB\BSON\ObjectID::__toString
MongoDB\BSON\Regex
MongoDB\BSON\ObjectID
PHP Manual

MongoDB\BSON\ObjectID::unserialize

(mongodb >=1.2.0)

MongoDB\BSON\ObjectID::unserialize — Unserialize an ObjectID

Açıklama

final public void MongoDB\BSON\ObjectID::unserialize ( string $serialized )

Değiştirgeler

serialized

The serialized MongoDB\BSON\ObjectID.

Dönen Değerler

Returns the unserialized MongoDB\BSON\ObjectID.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\UnexpectedValueException if the properties cannot be unserialized (i.e. serialized was malformed).
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the properties are invalid (e.g. missing fields or invalid values).

Ayrıca Bakınız

  • MongoDB\BSON\ObjectID::serialize() - Serialize an ObjectID
  • unserialize() - Bir PHP değerini saklanmış gösteriminden oluşturur
  • Serializing Objects
MongoDB\BSON\ObjectID::__toString
MongoDB\BSON\Regex
MongoDB\BSON\ObjectID


The MongoDB\BSON\Regex class

(mongodb >=1.0.0)

Giriş

Sınıf Sözdizimi

MongoDB\BSON\Regex implements MongoDB\BSON\Type , Serializable , JsonSerializable {
/* Yöntemler */
final public __construct ( string $pattern [, string $flags = "" ] )
final public string getFlags ( void )
final public string getPattern ( void )
final public mixed jsonSerialize ( void )
final public string serialize ( void )
final public string __toString ( void )
final public void unserialize ( string $serialized )
}

Sürüm Bilgisi

Sürüm: | Açıklama
1.2.0 | Implements Serializable and JsonSerializable.

İçindekiler

  • MongoDB\BSON\Regex::__construct — Construct a new Regex
  • MongoDB\BSON\Regex::getFlags — Returns the Regex's flags
  • MongoDB\BSON\Regex::getPattern — Returns the Regex's pattern
  • MongoDB\BSON\Regex::jsonSerialize — Returns a representation that can be converted to JSON
  • MongoDB\BSON\Regex::serialize — Serialize a Regex
  • MongoDB\BSON\Regex::__toString — Returns the string representation of this Regex
  • MongoDB\BSON\Regex::unserialize — Unserialize a Regex
MongoDB\BSON\ObjectID::unserialize
MongoDB\BSON\Regex::__construct
MongoDB\BSON


Construct a new Regex

MongoDB\BSON\Regex
MongoDB\BSON\Regex::getFlags
MongoDB\BSON\Regex
PHP Manual

MongoDB\BSON\Regex::__construct

(mongodb >=1.0.0)

MongoDB\BSON\Regex::__construct — Construct a new Regex

Açıklama

final public MongoDB\BSON\Regex::__construct ( string $pattern [, string $flags = "" ] )

Değiştirgeler

pattern (string)

The regular expression pattern.

Bilginize:

The pattern should not be wrapped with delimiter characters.

flags (string)

The » regular expression flags. Characters in this argument will be sorted alphabetically.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if pattern or flags contain null bytes.

Sürüm Bilgisi

Sürüm: Açıklama
1.2.0

The flags argument is optional and defaults to an empty string.

Characters in the flags argument will be sorted alphabetically when a Regex is constructed. Previously, the characters were stored in the order provided.

MongoDB\Driver\Exception\InvalidArgumentException is thrown if pattern or flags contain null bytes. Previously, values would be truncated at the first null byte.

Örnekler

Örnek 1 MongoDB\BSON\Regex::__construct() example

<?php

$regex = new MongoDB\BSON\Regex('^foo', 'i');
var_dump($regex);

?>

Yukarıdaki örneğin çıktısı:

object(MongoDB\BSON\Regex)#1 (2) {
  ["pattern"]=>
  string(4) "^foo"
  ["flags"]=>
  string(1) "i"
}

Ayrıca Bakınız

  • » BSON Types
  • » Supported regular expression flags
MongoDB\BSON\Regex
MongoDB\BSON\Regex::getFlags
MongoDB\BSON\Regex


Returns the Regex's flags

MongoDB\BSON\Regex::__construct
MongoDB\BSON\Regex::getPattern
MongoDB\BSON\Regex
PHP Manual

MongoDB\BSON\Regex::getFlags

(mongodb >=1.0.0)

MongoDB\BSON\Regex::getFlags — Returns the Regex's flags

Açıklama

final public string MongoDB\BSON\Regex::getFlags ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the Regex's flags.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\BSON\Regex::getFlags() example

<?php

$regex = new MongoDB\BSON\Regex('regex', 'i');
var_dump($regex->getFlags());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(1) "i"

Ayrıca Bakınız

  • » BSON Types
  • » Supported regular expression flags
MongoDB\BSON\Regex::__construct
MongoDB\BSON\Regex::getPattern
MongoDB\BSON\Regex


Returns the Regex's pattern

MongoDB\BSON\Regex::getFlags
MongoDB\BSON\Regex::jsonSerialize
MongoDB\BSON\Regex
PHP Manual

MongoDB\BSON\Regex::getPattern

(mongodb >=1.0.0)

MongoDB\BSON\Regex::getPattern — Returns the Regex's pattern

Açıklama

final public string MongoDB\BSON\Regex::getPattern ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the Regex's pattern.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\BSON\Regex::getPattern() example

<?php

$regex = new MongoDB\BSON\Regex('regex', 'i');
var_dump($regex->getPattern());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(5) "regex"

Ayrıca Bakınız

  • » BSON Types
MongoDB\BSON\Regex::getFlags
MongoDB\BSON\Regex::jsonSerialize
MongoDB\BSON\Regex


Returns a representation that can be converted to JSON

MongoDB\BSON\Regex::getPattern
MongoDB\BSON\Regex::serialize
MongoDB\BSON\Regex
PHP Manual

MongoDB\BSON\Regex::jsonSerialize

(mongodb >=1.2.0)

MongoDB\BSON\Regex::jsonSerialize — Returns a representation that can be converted to JSON

Açıklama

final public mixed MongoDB\BSON\Regex::jsonSerialize ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns data which can be serialized by json_encode() to produce the » extended JSON representation of the MongoDB\BSON\Regex.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Ayrıca Bakınız

  • JsonSerializable::jsonSerialize()
  • json_encode() - Değerin JSON karşılığını verir.
  • » MongoDB Extended JSON
MongoDB\BSON\Regex::getPattern
MongoDB\BSON\Regex::serialize
MongoDB\BSON\Regex


Serialize a Regex

MongoDB\BSON\Regex::jsonSerialize
MongoDB\BSON\Regex::__toString
MongoDB\BSON\Regex
PHP Manual

MongoDB\BSON\Regex::serialize

(mongodb >=1.2.0)

MongoDB\BSON\Regex::serialize — Serialize a Regex

Açıklama

final public string MongoDB\BSON\Regex::serialize ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the serialized representation of the MongoDB\BSON\Regex.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Ayrıca Bakınız

  • MongoDB\BSON\Regex::unserialize() - Unserialize a Regex
  • serialize() - Bir değerin saklanabilir bir gösterimini üretir
  • Serializing Objects
MongoDB\BSON\Regex::jsonSerialize
MongoDB\BSON\Regex::__toString
MongoDB\BSON\Regex


Returns the string representation of this Regex

MongoDB\BSON\Regex::serialize
MongoDB\BSON\Regex::unserialize
MongoDB\BSON\Regex
PHP Manual

MongoDB\BSON\Regex::__toString

(mongodb >=1.0.0)

MongoDB\BSON\Regex::__toString — Returns the string representation of this Regex

Açıklama

final public string MongoDB\BSON\Regex::__toString ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the string representation of this Regex.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\BSON\Regex::__toString() example

<?php

$regex = new MongoDB\BSON\Regex('regex', 'i');
var_dump((string) $regex);

?>

Yukarıdaki örneğin çıktısı:

string(8) "/regex/i"

Ayrıca Bakınız

  • » BSON Types
MongoDB\BSON\Regex::serialize
MongoDB\BSON\Regex::unserialize
MongoDB\BSON\Regex


Unserialize a Regex

MongoDB\BSON\Regex::__toString
MongoDB\BSON\Timestamp
MongoDB\BSON\Regex
PHP Manual

MongoDB\BSON\Regex::unserialize

(mongodb >=1.2.0)

MongoDB\BSON\Regex::unserialize — Unserialize a Regex

Açıklama

final public void MongoDB\BSON\Regex::unserialize ( string $serialized )

Değiştirgeler

serialized

The serialized MongoDB\BSON\Regex.

Dönen Değerler

Returns the unserialized MongoDB\BSON\Regex.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\UnexpectedValueException if the properties cannot be unserialized (i.e. serialized was malformed).
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the properties are invalid (e.g. missing fields or invalid values).

Ayrıca Bakınız

  • MongoDB\BSON\Regex::serialize() - Serialize a Regex
  • unserialize() - Bir PHP değerini saklanmış gösteriminden oluşturur
  • Serializing Objects
MongoDB\BSON\Regex::__toString
MongoDB\BSON\Timestamp
MongoDB\BSON\Regex


The MongoDB\BSON\Timestamp class

(mongodb >=1.0.0)

Giriş

Represents a » BSON timestamp, which is an internal MongoDB type not intended for general date storage.

Sınıf Sözdizimi

MongoDB\BSON\Timestamp implements MongoDB\BSON\Type , Serializable , JsonSerializable {
/* Yöntemler */
final public __construct ( integer $increment , integer $timestamp )
final public mixed jsonSerialize ( void )
final public string serialize ( void )
final public string __toString ( void )
final public void unserialize ( string $serialized )
}

Sürüm Bilgisi

Sürüm: | Açıklama
1.2.0 | Implements Serializable and JsonSerializable.

İçindekiler

  • MongoDB\BSON\Timestamp::__construct — Construct a new Timestamp
  • MongoDB\BSON\Timestamp::jsonSerialize — Returns a representation that can be converted to JSON
  • MongoDB\BSON\Timestamp::serialize — Serialize a Timestamp
  • MongoDB\BSON\Timestamp::__toString — Returns the string representation of this Timestamp
  • MongoDB\BSON\Timestamp::unserialize — Unserialize a Timestamp
MongoDB\BSON\Regex::unserialize
MongoDB\BSON\Timestamp::__construct
MongoDB\BSON


Construct a new Timestamp

MongoDB\BSON\Timestamp
MongoDB\BSON\Timestamp::jsonSerialize
MongoDB\BSON\Timestamp
PHP Manual

MongoDB\BSON\Timestamp::__construct

(mongodb >=1.0.0)

MongoDB\BSON\Timestamp::__construct — Construct a new Timestamp

Açıklama

final public MongoDB\BSON\Timestamp::__construct ( integer $increment , integer $timestamp )

Değiştirgeler

increment (integer)

32-bit integer denoting the incrementing ordinal for operations within a given second.

timestamp (integer)

32-bit integer denoting seconds since the Unix epoch.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\BSON\Timestamp::__construct() example

<?php

$timestamp = new MongoDB\BSON\Timestamp(1234, 5678);

?>

Yukarıdaki örneğin çıktısı:

object(MongoDB\BSON\Timestamp)#1 (2) {
  ["increment"]=>
  int(1234)
  ["timestamp"]=>
  int(5678)
}

Ayrıca Bakınız

  • » BSON Types: Timestamps
MongoDB\BSON\Timestamp
MongoDB\BSON\Timestamp::jsonSerialize
MongoDB\BSON\Timestamp


Returns a representation that can be converted to JSON

MongoDB\BSON\Timestamp::__construct
MongoDB\BSON\Timestamp::serialize
MongoDB\BSON\Timestamp
PHP Manual

MongoDB\BSON\Timestamp::jsonSerialize

(mongodb >=1.2.0)

MongoDB\BSON\Timestamp::jsonSerialize — Returns a representation that can be converted to JSON

Açıklama

final public mixed MongoDB\BSON\Timestamp::jsonSerialize ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns data which can be serialized by json_encode() to produce the » extended JSON representation of the MongoDB\BSON\Timestamp.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Ayrıca Bakınız

  • JsonSerializable::jsonSerialize()
  • json_encode() - Değerin JSON karşılığını verir.
  • » MongoDB Extended JSON
MongoDB\BSON\Timestamp::__construct
MongoDB\BSON\Timestamp::serialize
MongoDB\BSON\Timestamp


Serialize a Timestamp

MongoDB\BSON\Timestamp::jsonSerialize
MongoDB\BSON\Timestamp::__toString
MongoDB\BSON\Timestamp
PHP Manual

MongoDB\BSON\Timestamp::serialize

(mongodb >=1.2.0)

MongoDB\BSON\Timestamp::serialize — Serialize a Timestamp

Açıklama

final public string MongoDB\BSON\Timestamp::serialize ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the serialized representation of the MongoDB\BSON\Timestamp.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Ayrıca Bakınız

  • MongoDB\BSON\Timestamp::unserialize() - Unserialize a Timestamp
  • serialize() - Bir değerin saklanabilir bir gösterimini üretir
  • Serializing Objects
MongoDB\BSON\Timestamp::jsonSerialize
MongoDB\BSON\Timestamp::__toString
MongoDB\BSON\Timestamp


Returns the string representation of this Timestamp

MongoDB\BSON\Timestamp::serialize
MongoDB\BSON\Timestamp::unserialize
MongoDB\BSON\Timestamp
PHP Manual

MongoDB\BSON\Timestamp::__toString

(mongodb >=1.0.0)

MongoDB\BSON\Timestamp::__toString — Returns the string representation of this Timestamp

Açıklama

final public string MongoDB\BSON\Timestamp::__toString ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the string representation of this Timestamp.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\BSON\Timestamp::__toString() example

<?php

$timestamp = new MongoDB\BSON\Timestamp(1234, 5678);
var_dump((string) $timestamp);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(11) "[1234:5678]"

Ayrıca Bakınız

  • » BSON Types: Timestamps
MongoDB\BSON\Timestamp::serialize
MongoDB\BSON\Timestamp::unserialize
MongoDB\BSON\Timestamp


Unserialize a Timestamp

MongoDB\BSON\Timestamp::__toString
MongoDB\BSON\UTCDateTime
MongoDB\BSON\Timestamp
PHP Manual

MongoDB\BSON\Timestamp::unserialize

(mongodb >=1.2.0)

MongoDB\BSON\Timestamp::unserialize — Unserialize a Timestamp

Açıklama

final public void MongoDB\BSON\Timestamp::unserialize ( string $serialized )

Değiştirgeler

serialized

The serialized MongoDB\BSON\Timestamp.

Dönen Değerler

Returns the unserialized MongoDB\BSON\Timestamp.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\UnexpectedValueException if the properties cannot be unserialized (i.e. serialized was malformed).
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the properties are invalid (e.g. missing fields or invalid values).

Ayrıca Bakınız

  • MongoDB\BSON\Timestamp::serialize() - Serialize a Timestamp
  • unserialize() - Bir PHP değerini saklanmış gösteriminden oluşturur
  • Serializing Objects
MongoDB\BSON\Timestamp::__toString
MongoDB\BSON\UTCDateTime
MongoDB\BSON\Timestamp


The MongoDB\BSON\UTCDateTime class

(mongodb >=1.0.0)

Giriş

Represents a » BSON date.

Sınıf Sözdizimi

MongoDB\BSON\UTCDateTime implements MongoDB\BSON\Type , Serializable , JsonSerializable {
/* Yöntemler */
final public __construct ([ integer|float|string|DateTimeInterface $milliseconds = NULL ] )
final public mixed jsonSerialize ( void )
final public string serialize ( void )
final public DateTime toDateTime ( void )
final public string __toString ( void )
final public void unserialize ( string $serialized )
}

Sürüm Bilgisi

Sürüm: | Açıklama
1.2.0 | Implements Serializable and JsonSerializable.

İçindekiler

  • MongoDB\BSON\UTCDateTime::__construct — Construct a new UTCDateTime
  • MongoDB\BSON\UTCDateTime::jsonSerialize — Returns a representation that can be converted to JSON
  • MongoDB\BSON\UTCDateTime::serialize — Serialize a UTCDateTime
  • MongoDB\BSON\UTCDateTime::toDateTime — Returns the DateTime representation of this UTCDateTime
  • MongoDB\BSON\UTCDateTime::__toString — Returns the string representation of this UTCDateTime
  • MongoDB\BSON\UTCDateTime::unserialize — Unserialize a UTCDateTime
MongoDB\BSON\Timestamp::unserialize
MongoDB\BSON\UTCDateTime::__construct
MongoDB\BSON


Construct a new UTCDateTime

MongoDB\BSON\UTCDateTime
MongoDB\BSON\UTCDateTime::jsonSerialize
MongoDB\BSON\UTCDateTime
PHP Manual

MongoDB\BSON\UTCDateTime::__construct

(mongodb >=1.0.0)

MongoDB\BSON\UTCDateTime::__construct — Construct a new UTCDateTime

Açıklama

final public MongoDB\BSON\UTCDateTime::__construct ([ integer|float|string|DateTimeInterface $milliseconds = NULL ] )

Değiştirgeler

milliseconds (integer|float|string|DateTimeInterface)

Number of milliseconds since the Unix epoch (Jan 1, 1970). Negative values represent dates before 1970. This value may be provided as a 64-bit integer. For compatibility on 32-bit systems, this parameter may also be provided as a float or string.

If the argument is a DateTimeInterface, the number of milliseconds since the Unix epoch will be derived from that value. Note that in versions of PHP versions before 7.1.0, DateTime and DateTimeImmutable objects constructed from the current time did not incorporate sub-second precision.

If this argument is NULL, the current time will be used by default.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Sürüm Bilgisi

Sürüm: | Açıklama
1.2.0 | The milliseconds argument is optional and defaults to NULL (i.e. current time). The argument also accepts a DateTimeInterface, which may be used to derive the number of milliseconds since the Unix epoch.

Örnekler

Örnek 1 MongoDB\BSON\UTCDateTime::__construct() example

<?php

var_dump(new MongoDB\BSON\UTCDateTime);

var_dump(new MongoDB\BSON\UTCDateTime(new DateTime));

var_dump(new MongoDB\BSON\UTCDateTime(1416445411987));

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(MongoDB\BSON\UTCDateTime)#1 (1) {
  ["milliseconds"]=>
  string(13) "1484852905560"
}
object(MongoDB\BSON\UTCDateTime)#1 (1) {
  ["milliseconds"]=>
  string(13) "1484852905560"
}
object(MongoDB\BSON\UTCDateTime)#1 (1) {
  ["milliseconds"]=>
  string(13) "1416445411987"
}

Ayrıca Bakınız

  • » BSON Types: Date
MongoDB\BSON\UTCDateTime
MongoDB\BSON\UTCDateTime::jsonSerialize
MongoDB\BSON\UTCDateTime


Returns a representation that can be converted to JSON

MongoDB\BSON\UTCDateTime::__construct
MongoDB\BSON\UTCDateTime::serialize
MongoDB\BSON\UTCDateTime
PHP Manual

MongoDB\BSON\UTCDateTime::jsonSerialize

(mongodb >=1.2.0)

MongoDB\BSON\UTCDateTime::jsonSerialize — Returns a representation that can be converted to JSON

Açıklama

final public mixed MongoDB\BSON\UTCDateTime::jsonSerialize ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns data which can be serialized by json_encode() to produce the » extended JSON representation of the MongoDB\BSON\UTCDateTime.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Ayrıca Bakınız

  • JsonSerializable::jsonSerialize()
  • json_encode() - Değerin JSON karşılığını verir.
  • » MongoDB Extended JSON
MongoDB\BSON\UTCDateTime::__construct
MongoDB\BSON\UTCDateTime::serialize
MongoDB\BSON\UTCDateTime


Serialize a UTCDateTime

MongoDB\BSON\UTCDateTime::jsonSerialize
MongoDB\BSON\UTCDateTime::toDateTime
MongoDB\BSON\UTCDateTime
PHP Manual

MongoDB\BSON\UTCDateTime::serialize

(mongodb >=1.2.0)

MongoDB\BSON\UTCDateTime::serialize — Serialize a UTCDateTime

Açıklama

final public string MongoDB\BSON\UTCDateTime::serialize ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the serialized representation of the MongoDB\BSON\UTCDateTime.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Ayrıca Bakınız

  • MongoDB\BSON\UTCDateTime::unserialize() - Unserialize a UTCDateTime
  • serialize() - Bir değerin saklanabilir bir gösterimini üretir
  • Serializing Objects
MongoDB\BSON\UTCDateTime::jsonSerialize
MongoDB\BSON\UTCDateTime::toDateTime
MongoDB\BSON\UTCDateTime


Returns the DateTime representation of this UTCDateTime

MongoDB\BSON\UTCDateTime::serialize
MongoDB\BSON\UTCDateTime::__toString
MongoDB\BSON\UTCDateTime
PHP Manual

MongoDB\BSON\UTCDateTime::toDateTime

(mongodb >=1.0.0)

MongoDB\BSON\UTCDateTime::toDateTime — Returns the DateTime representation of this UTCDateTime

Açıklama

final public DateTime MongoDB\BSON\UTCDateTime::toDateTime ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the DateTime representation of this UTCDateTime. The returned DateTime will use the UTC time zone.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\BSON\UTCDatetime::toDateTime() example

<?php

$utcdatetime = new MongoDB\BSON\UTCDateTime(1416445411987);
$datetime = $utcdatetime->toDateTime();
var_dump($datetime->format('r'));
var_dump($datetime->format('U.u'));
var_dump($datetime->getTimezone());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(31) "Thu, 20 Nov 2014 01:03:31 +0000"
string(17) "1416445411.987000"
object(DateTimeZone)#3 (2) {
  ["timezone_type"]=>
  int(1)
  ["timezone"]=>
  string(6) "+00:00"
}

Ayrıca Bakınız

  • » BSON Types: Date
MongoDB\BSON\UTCDateTime::serialize
MongoDB\BSON\UTCDateTime::__toString
MongoDB\BSON\UTCDateTime


Returns the string representation of this UTCDateTime

MongoDB\BSON\UTCDateTime::toDateTime
MongoDB\BSON\UTCDateTime::unserialize
MongoDB\BSON\UTCDateTime
PHP Manual

MongoDB\BSON\UTCDateTime::__toString

(mongodb >=1.0.0)

MongoDB\BSON\UTCDateTime::__toString — Returns the string representation of this UTCDateTime

Açıklama

final public string MongoDB\BSON\UTCDateTime::__toString ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the string representation of this UTCDateTime.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.

Örnekler

Örnek 1 MongoDB\BSON\UTCDateTime::__toString() example

<?php

$utcdatetime = new MongoDB\BSON\UTCDateTime(1416445411987);
var_dump((string) $utcdatetime);

?>

Yukarıdaki örneğin çıktısı:

string(13) "1416445411987"

Ayrıca Bakınız

  • » BSON Types: Date
MongoDB\BSON\UTCDateTime::toDateTime
MongoDB\BSON\UTCDateTime::unserialize
MongoDB\BSON\UTCDateTime


Unserialize a UTCDateTime

MongoDB\BSON\UTCDateTime::__toString
MongoDB\BSON\Type
MongoDB\BSON\UTCDateTime
PHP Manual

MongoDB\BSON\UTCDateTime::unserialize

(mongodb >=1.2.0)

MongoDB\BSON\UTCDateTime::unserialize — Unserialize a UTCDateTime

Açıklama

final public void MongoDB\BSON\UTCDateTime::unserialize ( string $serialized )

Değiştirgeler

serialized

The serialized MongoDB\BSON\UTCDateTime.

Dönen Değerler

Returns the unserialized MongoDB\BSON\UTCDateTime.

Hatalar/İstisnalar

  • Throws MongoDB\Driver\InvalidArgumentException on argument parsing errors.
  • Throws MongoDB\Driver\Exception\UnexpectedValueException if the properties cannot be unserialized (i.e. serialized was malformed).
  • Throws MongoDB\Driver\Exception\InvalidArgumentException if the properties are invalid (e.g. missing fields or invalid values).

Ayrıca Bakınız

  • MongoDB\BSON\UTCDateTime::serialize() - Serialize a UTCDateTime
  • unserialize() - Bir PHP değerini saklanmış gösteriminden oluşturur
  • Serializing Objects
MongoDB\BSON\UTCDateTime::__toString
MongoDB\BSON\Type
MongoDB\BSON\UTCDateTime


The MongoDB\BSON\Type interface

(mongodb >=1.0.0)

Giriş

Sınıf Sözdizimi

MongoDB\BSON\Type {
}
MongoDB\BSON\UTCDateTime::unserialize
MongoDB\BSON\Persistable
MongoDB\BSON


The MongoDB\BSON\Persistable interface

(mongodb >=1.0.0)

Giriş

Classes may implement this interface to take advantage of automatic ODM (object document mapping) behavior in the driver. During serialization, the driver will inject a __pclass property containing the PHP class name into the data returned by MongoDB\BSON\Serializable::bsonSerialize(). During unserialization, the same __pclass property will then be used to infer the PHP class (independent of any type map configuration) to be constructed before MongoDB\BSON\Unserializable::bsonUnserialize() is invoked. See Persisting Data for additional information.

Bilginize:

Even if MongoDB\BSON\Serializable::bsonSerialize() would return a sequential array, injection of the __pclass property will cause the object to be serialized as a BSON document.

Sınıf Sözdizimi

MongoDB\BSON\Persistable implements MongoDB\BSON\Unserializable , MongoDB\BSON\Serializable {
/* Miras alınan yöntemler */
abstract public array|object MongoDB\BSON\Serializable::bsonSerialize ( void )
abstract public void MongoDB\BSON\Unserializable::bsonUnserialize ( array $data )
}
MongoDB\BSON\Type
MongoDB\BSON\Serializable
MongoDB\BSON


The MongoDB\BSON\Serializable interface

(mongodb >=1.0.0)

Giriş

Classes that implement this interface may return data to be serialized as a BSON array or document in lieu of the object's public properties.

Sınıf Sözdizimi

MongoDB\BSON\Serializable implements MongoDB\BSON\Type {
/* Yöntemler */
abstract public array|object bsonSerialize ( void )
}

İçindekiler

  • MongoDB\BSON\Serializable::bsonSerialize — Provides an array or document to serialize as BSON
MongoDB\BSON\Persistable
MongoDB\BSON\Serializable::bsonSerialize
MongoDB\BSON


Provides an array or document to serialize as BSON

MongoDB\BSON\Serializable
MongoDB\BSON\Unserializable
MongoDB\BSON\Serializable
PHP Manual

MongoDB\BSON\Serializable::bsonSerialize

(mongodb >=1.0.0)

MongoDB\BSON\Serializable::bsonSerialize — Provides an array or document to serialize as BSON

Açıklama

abstract public array|object MongoDB\BSON\Serializable::bsonSerialize ( void )

Called during serialization of the object to BSON. The method must return an array or stdClass.

Root documents (e.g. a MongoDB\BSON\Serializable passed to MongoDB\BSON\fromPHP()) will always be serialized as a BSON document. For field values, associative arrays and stdClass instances will be serialized as a BSON document and sequential arrays (i.e. sequential, numeric indexes starting at 0) will be serialized as a BSON array.

Users are encouraged to include an _id property (e.g. a MongoDB\BSON\ObjectID initialized in your constructor) when returning data for a BSON root document; otherwise, the driver or database will need to generate a MongoDB\BSON\ObjectID when inserting or upserting the document, respectively.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

An array or stdClass to be serialized as a BSON array or document.

Örnekler

Örnek 1 MongoDB\BSON\Serializable::bsonSerialize() returning an associative array for root document

<?php

class MyDocument implements MongoDB\BSON\Serializable
{
    private $id;

    function __construct()
    {
        $this->id = new MongoDB\BSON\ObjectID;
    }

    function bsonSerialize()
    {
        return ['_id' => $this->id, 'foo' => 'bar'];
    }
}

$bson = MongoDB\BSON\fromPHP(new MyDocument);
echo MongoDB\BSON\toJSON($bson), "\n";

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

{ "_id" : { "$oid" : "56cccdcada14d8755a58c591" }, "foo" : "bar" }

Örnek 2 MongoDB\BSON\Serializable::bsonSerialize() returning a sequential array for root document

<?php

class MyArray implements MongoDB\BSON\Serializable
{
    function bsonSerialize()
    {
        return [1, 2, 3];
    }
}

$bson = MongoDB\BSON\fromPHP(new MyArray);
echo MongoDB\BSON\toJSON($bson), "\n";

?>

Yukarıdaki örneğin çıktısı:

{ "0" : 1, "1" : 2, "2" : 3 }

Örnek 3 MongoDB\BSON\Serializable::bsonSerialize() returning an associative array for document field

<?php

class MyDocument implements MongoDB\BSON\Serializable
{
    function bsonSerialize()
    {
        return ['foo' => 'bar'];
    }
}

$value = ['document' => new MyDocument];
$bson = MongoDB\BSON\fromPHP($value);
echo MongoDB\BSON\toJSON($bson), "\n";

?>

Yukarıdaki örneğin çıktısı:

{ "document" : { "foo" : "bar" } }

Örnek 4 MongoDB\BSON\Serializable::bsonSerialize() returning a sequential array for document field

<?php

class MyArray implements MongoDB\BSON\Serializable
{
    function bsonSerialize()
    {
        return [1, 2, 3];
    }
}

$value = ['array' => new MyArray];
$bson = MongoDB\BSON\fromPHP($value);
echo MongoDB\BSON\toJSON($bson), "\n";

?>

Yukarıdaki örneğin çıktısı:

{ "array" : [ 1, 2, 3 ] }

Ayrıca Bakınız

  • MongoDB\BSON\Unserializable::bsonUnserialize() - Constructs the object from a BSON array or document
  • MongoDB\BSON\Persistable
  • Persisting Data
MongoDB\BSON\Serializable
MongoDB\BSON\Unserializable
MongoDB\BSON\Serializable


The MongoDB\BSON\Unserializable interface

(mongodb >=1.0.0)

Giriş

Classes that implement this interface may be specified in a type map for unserializing BSON arrays and documents (both root and embedded).

Sınıf Sözdizimi

MongoDB\BSON\Unserializable {
/* Yöntemler */
abstract public void bsonUnserialize ( array $data )
}

İçindekiler

  • MongoDB\BSON\Unserializable::bsonUnserialize — Constructs the object from a BSON array or document
MongoDB\BSON\Serializable::bsonSerialize
MongoDB\BSON\Unserializable::bsonUnserialize
MongoDB\BSON


Constructs the object from a BSON array or document

MongoDB\BSON\Unserializable
MongoDB\Driver\Exception
MongoDB\BSON\Unserializable
PHP Manual

MongoDB\BSON\Unserializable::bsonUnserialize

(mongodb >=1.0.0)

MongoDB\BSON\Unserializable::bsonUnserialize — Constructs the object from a BSON array or document

Açıklama

abstract public void MongoDB\BSON\Unserializable::bsonUnserialize ( array $data )

Called during unserialization of the object from BSON. The properties of the BSON array or document will be passed to the method as an array.

Remember to check for an _id property when handling data from a BSON document.

Bilginize:

This method acts as the constructor of the object. The __construct() method will not be called after this method.

Değiştirgeler

data (array)

Properties within the BSON array or document.

Dönen Değerler

The return value from this method is ignored.

Örnekler

Örnek 1 MongoDB\BSON\Unserializable::bsonUnserialize() example

<?php

class MyDocument implements MongoDB\BSON\Unserializable
{
    private $data = [];

    function bsonUnserialize(array $data)
    {
        $this->data = $data;
    }
}

$bson = MongoDB\BSON\fromJSON('{ "foo": "bar" }');
$value = MongoDB\BSON\toPHP($bson, ['root' => 'MyDocument']);
var_dump($value);

?>

Yukarıdaki örneğin çıktısı:

object(MyDocument)#1 (1) {
  ["data":"MyDocument":private]=>
  array(1) {
    ["foo"]=>
    string(3) "bar"
  }
}

Ayrıca Bakınız

  • MongoDB\BSON\Serializable::bsonSerialize() - Provides an array or document to serialize as BSON
  • MongoDB\BSON\Persistable
  • Persisting Data
MongoDB\BSON\Unserializable
MongoDB\Driver\Exception
MongoDB\BSON\Unserializable


Exception classes

  • MongoDB\Driver\Exception\AuthenticationException — The MongoDB\Driver\Exception\AuthenticationException class
  • MongoDB\Driver\Exception\BulkWriteException — The MongoDB\Driver\Exception\BulkWriteException class
  • MongoDB\Driver\Exception\ConnectionException — The MongoDB\Driver\Exception\ConnectionException class
  • MongoDB\Driver\Exception\ConnectionTimeoutException — The MongoDB\Driver\Exception\ConnectionTimeoutException class
  • MongoDB\Driver\Exception\Exception — The MongoDB\Driver\Exception\Exception interface
  • MongoDB\Driver\Exception\ExecutionTimeoutException — The MongoDB\Driver\Exception\ExecutionTimeoutException class
  • MongoDB\Driver\Exception\InvalidArgumentException — The MongoDB\Driver\Exception\InvalidArgumentException class
  • MongoDB\Driver\Exception\LogicException — The MongoDB\Driver\Exception\LogicException class
  • MongoDB\Driver\Exception\RuntimeException — The MongoDB\Driver\Exception\RuntimeException class
  • MongoDB\Driver\Exception\SSLConnectionException — The MongoDB\Driver\Exception\SSLConnectionException class
  • MongoDB\Driver\Exception\UnexpectedValueException — The MongoDB\Driver\Exception\UnexpectedValueException class
  • MongoDB\Driver\Exception\WriteException — The MongoDB\Driver\Exception\WriteException class
    • MongoDB\Driver\Exception\WriteException::getWriteResult — Returns the WriteResult for the failed write operation
MongoDB\BSON\Unserializable::bsonUnserialize
MongoDB\Driver\Exception\AuthenticationException
MongoDB


The MongoDB\Driver\Exception\AuthenticationException class

(mongodb >= 1.0.0)

Giriş

Thrown when the driver fails to authenticate with the server.

Sınıf Sözdizimi

MongoDB\Driver\Exception\AuthenticationException extends MongoDB\Driver\Exception\ConnectionException implements MongoDB\Driver\Exception\Exception {
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}
MongoDB\Driver\Exception
MongoDB\Driver\Exception\BulkWriteException
MongoDB\Driver\Exception


The MongoDB\Driver\Exception\BulkWriteException class

(mongodb >= 1.0.0)

Giriş

Thrown when a bulk write operation fails.

Sınıf Sözdizimi

MongoDB\Driver\Exception\BulkWriteException extends MongoDB\Driver\Exception\WriteException implements MongoDB\Driver\Exception\Exception {
/* Miras alınan özellikler */
protected MongoDB\Driver\WriteResult $writeResult ;
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Miras alınan yöntemler */
final public MongoDB\Driver\WriteResult MongoDB\Driver\Exception\WriteException::getWriteResult ( void )
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}
MongoDB\Driver\Exception\AuthenticationException
MongoDB\Driver\Exception\ConnectionException
MongoDB\Driver\Exception


The MongoDB\Driver\Exception\ConnectionException class

(mongodb >= 1.0.0)

Giriş

Base class for exceptions thrown when the driver fails to establish a database connection.

Sınıf Sözdizimi

MongoDB\Driver\Exception\ConnectionException extends MongoDB\Driver\Exception\RuntimeException implements MongoDB\Driver\Exception\Exception {
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}
MongoDB\Driver\Exception\BulkWriteException
MongoDB\Driver\Exception\ConnectionTimeoutException
MongoDB\Driver\Exception


The MongoDB\Driver\Exception\ConnectionTimeoutException class

(mongodb >= 1.0.0)

Giriş

Thrown when the driver fails to establish a database connection within a specified time limit (e.g. » connectTimeoutMS).

Sınıf Sözdizimi

MongoDB\Driver\Exception\ConnectionTimeoutException extends MongoDB\Driver\Exception\ConnectionException implements MongoDB\Driver\Exception\Exception {
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}
MongoDB\Driver\Exception\ConnectionException
MongoDB\Driver\Exception\Exception
MongoDB\Driver\Exception


The MongoDB\Driver\Exception\Exception interface

(mongodb >= 1.0.0)

Giriş

Common interface for all driver exceptions. This may be used to catch only exceptions originating from the driver itself.

Sınıf Sözdizimi

MongoDB\Driver\Exception\Exception {
}
MongoDB\Driver\Exception\ConnectionTimeoutException
MongoDB\Driver\Exception\ExecutionTimeoutException
MongoDB\Driver\Exception


The MongoDB\Driver\Exception\ExecutionTimeoutException class

(mongodb >= 1.0.0)

Giriş

Thrown when a query or command fails to complete within a specified time limit (e.g. » maxTimeMS).

Sınıf Sözdizimi

MongoDB\Driver\Exception\ExecutionTimeoutException extends MongoDB\Driver\Exception\RuntimeException implements MongoDB\Driver\Exception\Exception {
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}
MongoDB\Driver\Exception\Exception
MongoDB\Driver\Exception\InvalidArgumentException
MongoDB\Driver\Exception


The MongoDB\Driver\Exception\InvalidArgumentException class

(mongodb >= 1.0.0)

Giriş

Thrown when a driver method is given invalid arguments (e.g. invalid option types).

Sınıf Sözdizimi

MongoDB\Driver\Exception\InvalidArgumentException extends InvalidArgumentException implements MongoDB\Driver\Exception\Exception {
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}
MongoDB\Driver\Exception\ExecutionTimeoutException
MongoDB\Driver\Exception\LogicException
MongoDB\Driver\Exception


The MongoDB\Driver\Exception\LogicException class

(mongodb >= 1.0.0)

Giriş

Thrown when the driver is incorrectly used (e.g. rewinding a cursor).

Sınıf Sözdizimi

MongoDB\Driver\Exception\LogicException extends LogicException implements MongoDB\Driver\Exception\Exception {
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}
MongoDB\Driver\Exception\InvalidArgumentException
MongoDB\Driver\Exception\RuntimeException
MongoDB\Driver\Exception


The MongoDB\Driver\Exception\RuntimeException class

(mongodb >= 1.0.0)

Giriş

Thrown when the driver encounters a runtime error (e.g. internal error from » libmongoc).

Sınıf Sözdizimi

MongoDB\Driver\Exception\RuntimeException extends RuntimeException implements MongoDB\Driver\Exception\Exception {
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}
MongoDB\Driver\Exception\LogicException
MongoDB\Driver\Exception\SSLConnectionException
MongoDB\Driver\Exception


The MongoDB\Driver\Exception\SSLConnectionException class

(mongodb >= 1.0.0)

Giriş

Thrown when the driver fails to establish an SSL connection with the server.

Sınıf Sözdizimi

MongoDB\Driver\Exception\SSLConnectionException extends MongoDB\Driver\Exception\ConnectionException implements MongoDB\Driver\Exception\Exception {
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}
MongoDB\Driver\Exception\RuntimeException
MongoDB\Driver\Exception\UnexpectedValueException
MongoDB\Driver\Exception


The MongoDB\Driver\Exception\UnexpectedValueException class

(mongodb >= 1.0.0)

Giriş

Thrown when the driver encounters an unexpected value (e.g. during BSON serialization or deserialization).

Sınıf Sözdizimi

MongoDB\Driver\Exception\UnexpectedValueException extends UnexpectedValueException implements MongoDB\Driver\Exception\Exception {
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}
MongoDB\Driver\Exception\SSLConnectionException
MongoDB\Driver\Exception\WriteException
MongoDB\Driver\Exception


The MongoDB\Driver\Exception\WriteException class

(mongodb >= 1.0.0)

Giriş

Base class for exceptions thrown by a failed write operation. The exception encapsulates a MongoDB\Driver\WriteResult object.

Sınıf Sözdizimi

abstract MongoDB\Driver\Exception\WriteException extends MongoDB\Driver\Exception\RuntimeException implements MongoDB\Driver\Exception\Exception {
/* Özellikler */
protected MongoDB\Driver\WriteResult $writeResult ;
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Yöntemler */
final public MongoDB\Driver\WriteResult getWriteResult ( void )
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}

Özellikler

writeResult

The MongoDB\Driver\WriteResult associated with the failed write operation.

İçindekiler

  • MongoDB\Driver\Exception\WriteException::getWriteResult — Returns the WriteResult for the failed write operation
MongoDB\Driver\Exception\UnexpectedValueException
MongoDB\Driver\Exception\WriteException::getWriteResult
MongoDB\Driver\Exception


Returns the WriteResult for the failed write operation

MongoDB\Driver\Exception\WriteException
mSQL
MongoDB\Driver\Exception\WriteException
PHP Manual

MongoDB\Driver\Exception\WriteException::getWriteResult

(mongodb >= 1.0.0)

MongoDB\Driver\Exception\WriteException::getWriteResult — Returns the WriteResult for the failed write operation

Açıklama

final public MongoDB\Driver\WriteResult MongoDB\Driver\Exception\WriteException::getWriteResult ( void )

Returns the MongoDB\Driver\WriteResult for the failed write operation. The MongoDB\Driver\WriteResult::getWriteErrors() and MongoDB\Driver\WriteResult::getWriteConcernError() methods may be used to get more details about the failure.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The MongoDB\Driver\WriteResult for the failed write operation.

Örnekler

Örnek 1 MongoDB\Driver\Exception\WriteException::getWriteResult() example

<?php

$manager = new MongoDB\Driver\Manager('mongodb://localhost');
$bulk = new MongoDB\Driver\BulkWrite;
$bulk->insert(['_id' => 1]);
$bulk->insert(['_id' => 1]);

try {
    $manager->executeBulkWrite('db.collection', $bulk);
} catch (MongoDB\Driver\Exception\WriteException $e) {
    $writeResult = $e->getWriteResult();

    if ($writeConcernError = $writeResult->getWriteConcernError()) {
        var_dump($writeConcernError);
    }

    if ($writeErrors = $writeResult->getWriteErrors()) {
        var_dump($writeErrors);
    }
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(1) {
  [0]=>
  object(MongoDB\Driver\WriteError)#5 (4) {
    ["message"]=>
    string(70) "E11000 duplicate key error index: db.collection.$_id_ dup key: { : 1 }"
    ["code"]=>
    int(11000)
    ["index"]=>
    int(1)
    ["info"]=>
    NULL
  }
}

Ayrıca Bakınız

  • MongoDB\Driver\WriteResult
  • MongoDB\Driver\Manager::executeBulkWrite() - Execute one or more write operations
MongoDB\Driver\Exception\WriteException
mSQL
MongoDB\Driver\Exception\WriteException


mSQL

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
    • Basic usage
  • mSQL İşlevleri
    • msql_affected_rows — Returns number of affected rows
    • msql_close — Close mSQL connection
    • msql_connect — Open mSQL connection
    • msql_create_db — Create mSQL database
    • msql_createdb — Takma Adı: msql_create_db
    • msql_data_seek — Move internal row pointer
    • msql_db_query — Send mSQL query
    • msql_dbname — Takma Adı: msql_result
    • msql_drop_db — Drop (delete) mSQL database
    • msql_error — Returns error message of last msql call
    • msql_fetch_array — Fetch row as array
    • msql_fetch_field — Get field information
    • msql_fetch_object — Fetch row as object
    • msql_fetch_row — Get row as enumerated array
    • msql_field_flags — Get field flags
    • msql_field_len — Get field length
    • msql_field_name — Get the name of the specified field in a result
    • msql_field_seek — Set field offset
    • msql_field_table — Get table name for field
    • msql_field_type — Get field type
    • msql_fieldflags — Alias of msql_field_flags
    • msql_fieldlen — Alias of msql_field_len
    • msql_fieldname — Alias of msql_field_name
    • msql_fieldtable — Alias of msql_field_table
    • msql_fieldtype — Alias of msql_field_type
    • msql_free_result — Free result memory
    • msql_list_dbs — List mSQL databases on server
    • msql_list_fields — List result fields
    • msql_list_tables — List tables in an mSQL database
    • msql_num_fields — Get number of fields in result
    • msql_num_rows — Get number of rows in result
    • msql_numfields — Alias of msql_num_fields
    • msql_numrows — Alias of msql_num_rows
    • msql_pconnect — Open persistent mSQL connection
    • msql_query — Send mSQL query
    • msql_regcase — Alias of sql_regcase
    • msql_result — Get result data
    • msql_select_db — Select mSQL database
    • msql_tablename — Alias of msql_result
    • msql — Alias of msql_db_query
MongoDB\Driver\Exception\WriteException::getWriteResult
Giriş
Sağlayıcıya Göre Veritabanı Eklentileri


Giriş

These functions allow you to access mSQL database servers. More information about mSQL can be found at » http://www.hughes.com.au/.

mSQL
Yapılandırma/Kurulum
mSQL


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
mSQL


Kurulum

In order to have these functions available, you must compile PHP with msql support by using the --with-msql[=DIR] option. DIR is the mSQL base install directory, defaults to /usr/local/msql3.

Bilginize: Note to Win32 Users

Bu eklentinin çalışabilmesi için bazı DLL dosyalarının bulunduğu yerlerin Windows sistem PATH'ında tanımlı olması gerekir. Bunun nasıl yapılacağı SSS altında "PHP dizinimi Windows'ta PATH'a nasıl eklerim" başlığı altında açıklanmıştır. Eklenti, DLL dosyaları PHP dizininden Windows system dizinine taşındığında da çalışırsa da (çünkü system dizini sistem PATH'ında zaten vardır) bu önerilmez. Bu eklentinin çalışabilmesi için bulunduğu dizine PATH üzerinden erişilebilinmesi gereken dosyanın ismi: msql.dll

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

mSQL configuration options
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
msql.allow_persistent | "1" | PHP_INI_ALL |
msql.max_persistent | "-1" | PHP_INI_ALL |
msql.max_links | "-1" | PHP_INI_ALL |
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

msql.allow_persistent boolean

Whether to allow persistent mSQL connections.

msql.max_persistent integer

The maximum number of persistent mSQL connections per process.

msql.max_links integer

The maximum number of mSQL connections per process, including persistent connections.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Özkaynak Türleri

There are two resource types used in the mSQL module. The first one is the link identifier for a database connection, the second a resource which holds the result of a query.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

MSQL_ASSOC (integer)
MSQL_NUM (integer)
MSQL_BOTH (integer)
Özkaynak Türleri
Örnekler
mSQL


Örnekler

İçindekiler

  • Basic usage
Öntanımlı Sabitler
Basic usage
mSQL


Basic usage

This simple example shows how to connect, execute a query, print resulting rows and disconnect from a mSQL database.

Örnek 1 mSQL usage example

<?php
/* Connecting, selecting database */
$link = msql_connect('localhost', 'username', 'password')
    or die('Could not connect : ' . msql_error($link));

msql_select_db('database', $link)
    or die('Could not select database');

/* Issue SQL query */
$query = 'SELECT * FROM my_table';
$result = msql_query($query, $link) or die('Query failed : ' . msql_error());

/* Printing results in HTML */
echo "<table>\n";
while ($row = msql_fetch_array($result, MSQL_ASSOC)) {
    echo "\t<tr>\n";
    foreach ($row as $col_value) {
        echo "\t\t<td>$col_value</td>\n";
    }
    echo "\t</tr>\n";
}
echo "</table>\n";

/* Free result set */
msql_free_result($result);

/* Close connection */
msql_close($link);
?>

Örnekler
mSQL İşlevleri
Örnekler


mSQL İşlevleri

İçindekiler

  • msql_affected_rows — Returns number of affected rows
  • msql_close — Close mSQL connection
  • msql_connect — Open mSQL connection
  • msql_create_db — Create mSQL database
  • msql_createdb — Takma Adı: msql_create_db
  • msql_data_seek — Move internal row pointer
  • msql_db_query — Send mSQL query
  • msql_dbname — Takma Adı: msql_result
  • msql_drop_db — Drop (delete) mSQL database
  • msql_error — Returns error message of last msql call
  • msql_fetch_array — Fetch row as array
  • msql_fetch_field — Get field information
  • msql_fetch_object — Fetch row as object
  • msql_fetch_row — Get row as enumerated array
  • msql_field_flags — Get field flags
  • msql_field_len — Get field length
  • msql_field_name — Get the name of the specified field in a result
  • msql_field_seek — Set field offset
  • msql_field_table — Get table name for field
  • msql_field_type — Get field type
  • msql_fieldflags — Alias of msql_field_flags
  • msql_fieldlen — Alias of msql_field_len
  • msql_fieldname — Alias of msql_field_name
  • msql_fieldtable — Alias of msql_field_table
  • msql_fieldtype — Alias of msql_field_type
  • msql_free_result — Free result memory
  • msql_list_dbs — List mSQL databases on server
  • msql_list_fields — List result fields
  • msql_list_tables — List tables in an mSQL database
  • msql_num_fields — Get number of fields in result
  • msql_num_rows — Get number of rows in result
  • msql_numfields — Alias of msql_num_fields
  • msql_numrows — Alias of msql_num_rows
  • msql_pconnect — Open persistent mSQL connection
  • msql_query — Send mSQL query
  • msql_regcase — Alias of sql_regcase
  • msql_result — Get result data
  • msql_select_db — Select mSQL database
  • msql_tablename — Alias of msql_result
  • msql — Alias of msql_db_query
Basic usage
msql_affected_rows
mSQL


Returns number of affected rows

mSQL İşlevleri
msql_close
mSQL İşlevleri
PHP Manual

msql_affected_rows

(PHP 4, PHP 5, PHP 7)

msql_affected_rows — Returns number of affected rows

Açıklama

int msql_affected_rows ( resource $result )

Returns number of affected rows by the last SELECT, UPDATE or DELETE query associated with result.

Değiştirgeler

result

The result resource that is being evaluated. This result comes from a call to msql_query().

Dönen Değerler

Returns the number of affected rows on success, or FALSE on error.

Ayrıca Bakınız

  • msql_query() - Send mSQL query

mSQL İşlevleri
msql_close
mSQL İşlevleri


Close mSQL connection

msql_affected_rows
msql_connect
mSQL İşlevleri
PHP Manual

msql_close

(PHP 4, PHP 5, PHP 7)

msql_close — Close mSQL connection

Açıklama

bool msql_close ([ resource $link_identifier ] )

msql_close() closes the non-persistent connection to the mSQL server that's associated with the specified link identifier.

Using msql_close() isn't usually necessary, as non-persistent open links are automatically closed at the end of the script's execution. See also freeing resources.

Değiştirgeler

link_identifier

The mSQL connection. If not specified, the last link opened by msql_connect() is assumed. If no such link is found, the function will try to establish a link as if msql_connect() was called, and use it.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • msql_connect() - Open mSQL connection
  • msql_pconnect() - Open persistent mSQL connection

msql_affected_rows
msql_connect
mSQL İşlevleri


Open mSQL connection

msql_close
msql_create_db
mSQL İşlevleri
PHP Manual

msql_connect

(PHP 4, PHP 5, PHP 7)

msql_connect — Open mSQL connection

Açıklama

resource msql_connect ([ string $hostname ] )

msql_connect() establishes a connection to a mSQL server.

If a second call is made to msql_connect() with the same arguments, no new link will be established, but instead, the link identifier of the already opened link will be returned.

The link to the server will be closed as soon as the execution of the script ends, unless it's closed earlier by explicitly calling msql_close().

Değiştirgeler

hostname

The hostname can also include a port number. e.g. hostname,port.

If not specified, the connection is established by the means of a Unix domain socket, being then more efficient then a localhost TCP socket connection.

Bilginize:

While this function will accept a colon (:) as a host/port separator, a comma (,) is the preferred method.

Dönen Değerler

Returns a positive mSQL link identifier on success, or FALSE on error.

Ayrıca Bakınız

  • msql_pconnect() - Open persistent mSQL connection
  • msql_close() - Close mSQL connection

msql_close
msql_create_db
mSQL İşlevleri


Create mSQL database

msql_connect
msql_createdb
mSQL İşlevleri
PHP Manual

msql_create_db

(PHP 4, PHP 5, PHP 7)

msql_create_db — Create mSQL database

Açıklama

bool msql_create_db ( string $database_name [, resource $link_identifier ] )

msql_create_db() attempts to create a new database on the mSQL server.

Değiştirgeler

database_name

The name of the mSQL database.

link_identifier

The mSQL connection. If not specified, the last link opened by msql_connect() is assumed. If no such link is found, the function will try to establish a link as if msql_connect() was called, and use it.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • msql_drop_db() - Drop (delete) mSQL database

msql_connect
msql_createdb
mSQL İşlevleri


Takma Adı: msql_create_db

msql_create_db
msql_data_seek
mSQL İşlevleri
PHP Manual

msql_createdb

(PHP 4, PHP 5, PHP 7)

msql_createdb — Takma Adı: msql_create_db()

Açıklama

Bu işlev şu işlevin takma adıdır: msql_create_db().

msql_create_db
msql_data_seek
mSQL İşlevleri


Move internal row pointer

msql_createdb
msql_db_query
mSQL İşlevleri
PHP Manual

msql_data_seek

(PHP 4, PHP 5, PHP 7)

msql_data_seek — Move internal row pointer

Açıklama

bool msql_data_seek ( resource $result , int $row_number )

msql_data_seek() moves the internal row pointer of the mSQL result associated with the specified query identifier to point to the specified row number. The next call to msql_fetch_row() would return that row.

Değiştirgeler

result

The result resource that is being evaluated. This result comes from a call to msql_query().

row_number

The seeked row number.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • msql_fetch_array() - Fetch row as array
  • msql_fetch_object() - Fetch row as object
  • msql_fetch_row() - Get row as enumerated array
  • msql_result() - Get result data

msql_createdb
msql_db_query
mSQL İşlevleri


Send mSQL query

msql_data_seek
msql_dbname
mSQL İşlevleri
PHP Manual

msql_db_query

(PHP 4, PHP 5, PHP 7)

msql_db_query — Send mSQL query

Açıklama

resource msql_db_query ( string $database , string $query [, resource $link_identifier ] )

msql_db_query() selects a database and executes a query on it.

Değiştirgeler

database

The name of the mSQL database.

query

The SQL query.

link_identifier

The mSQL connection. If not specified, the last link opened by msql_connect() is assumed. If no such link is found, the function will try to establish a link as if msql_connect() was called, and use it.

Dönen Değerler

Returns a positive mSQL query identifier to the query result, or FALSE on error.

Ayrıca Bakınız

  • msql_query() - Send mSQL query

msql_data_seek
msql_dbname
mSQL İşlevleri


Takma Adı: msql_result

msql_db_query
msql_drop_db
mSQL İşlevleri
PHP Manual

msql_dbname

(PHP 4, PHP 5, PHP 7)

msql_dbname — Takma Adı: msql_result()

Açıklama

Bu işlev şu işlevin takma adıdır: msql_result().

msql_db_query
msql_drop_db
mSQL İşlevleri


Drop (delete) mSQL database

msql_dbname
msql_error
mSQL İşlevleri
PHP Manual

msql_drop_db

(PHP 4, PHP 5, PHP 7)

msql_drop_db — Drop (delete) mSQL database

Açıklama

bool msql_drop_db ( string $database_name [, resource $link_identifier ] )

msql_drop_db() attempts to drop (remove) a database from the mSQL server.

Değiştirgeler

database_name

The name of the database.

link_identifier

The mSQL connection. If not specified, the last link opened by msql_connect() is assumed. If no such link is found, the function will try to establish a link as if msql_connect() was called, and use it.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • msql_create_db() - Create mSQL database

msql_dbname
msql_error
mSQL İşlevleri


Returns error message of last msql call

msql_drop_db
msql_fetch_array
mSQL İşlevleri
PHP Manual

msql_error

(PHP 4, PHP 5, PHP 7)

msql_error — Returns error message of last msql call

Açıklama

string msql_error ( void )

msql_error() returns the last issued error by the mSQL server. Note that only the last error message is accessible with msql_error().

Dönen Değerler

The last error message or an empty string if no error was issued.

msql_drop_db
msql_fetch_array
mSQL İşlevleri


Fetch row as array

msql_error
msql_fetch_field
mSQL İşlevleri
PHP Manual

msql_fetch_array

(PHP 4, PHP 5, PHP 7)

msql_fetch_array — Fetch row as array

Açıklama

array msql_fetch_array ( resource $result [, int $result_type ] )

msql_fetch_array() is an extended version of msql_fetch_row(). In addition to storing the data in the numeric indices of the result array, it also stores the data in associative indices, using the field names as keys.

An important thing to note is that using msql_fetch_array() is NOT significantly slower than using msql_fetch_row(), while it provides a significant added value.

Değiştirgeler

result

The result resource that is being evaluated. This result comes from a call to msql_query().

result_type

A constant that can take the following values: MSQL_ASSOC, MSQL_NUM, and MSQL_BOTH with MSQL_BOTH being the default.

Dönen Değerler

Returns an array that corresponds to the fetched row, or FALSE if there are no more rows.

Örnekler

Örnek 1 msql_fetch_array() example

<?php
$con = msql_connect();
if (!$con) {
    die('Server connection problem: ' . msql_error());
}

if (!msql_select_db('test', $con)) {
    die('Database connection problem: ' . msql_error());
}

$result = msql_query('SELECT id, name FROM people', $con);
if (!$result) {
    die('Query execution problem: ' . msql_error());
}

while ($row = msql_fetch_array($result, MSQL_ASSOC)) {
    echo $row['id'] . ': ' . $row['name'] . "\n";
}

msql_free_result($result);
?>

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.4 | A bug was fixed when retrieving data from columns containing NULL values. Such columns were not placed into the resulting array.

Ayrıca Bakınız

  • msql_fetch_row() - Get row as enumerated array
  • msql_fetch_object() - Fetch row as object
  • msql_data_seek() - Move internal row pointer
  • msql_result() - Get result data

msql_error
msql_fetch_field
mSQL İşlevleri


Get field information

msql_fetch_array
msql_fetch_object
mSQL İşlevleri
PHP Manual

msql_fetch_field

(PHP 4, PHP 5, PHP 7)

msql_fetch_field — Get field information

Açıklama

object msql_fetch_field ( resource $result [, int $field_offset = 0 ] )

msql_fetch_field() can be used in order to obtain information about fields in a certain query result.

Değiştirgeler

result

The result resource that is being evaluated. This result comes from a call to msql_query().

field_offset

The field offset. If not specified, the next field that wasn't yet retrieved by msql_fetch_field() is retrieved.

Dönen Değerler

Returns an object containing field information. The properties of the object are:

  • name - column name

  • table - name of the table the column belongs to

  • not_null - 1 if the column cannot be NULL

  • unique - 1 if the column is a unique key

  • type - the type of the column

Ayrıca Bakınız

  • msql_field_seek() - Set field offset

msql_fetch_array
msql_fetch_object
mSQL İşlevleri


Fetch row as object

msql_fetch_field
msql_fetch_row
mSQL İşlevleri
PHP Manual

msql_fetch_object

(PHP 4, PHP 5, PHP 7)

msql_fetch_object — Fetch row as object

Açıklama

object msql_fetch_object ( resource $result )

msql_fetch_object() is similar to msql_fetch_array(), with one difference - an object is returned, instead of an array. Indirectly, that means that you can only access the data by the field names, and not by their offsets (numbers are illegal property names).

Speed-wise, the function is identical to msql_fetch_array(), and almost as quick as msql_fetch_row() (the difference is insignificant).

Değiştirgeler

result

The result resource that is being evaluated. This result comes from a call to msql_query().

Dönen Değerler

Returns an object with properties that correspond to the fetched row, or FALSE if there are no more rows.

Örnekler

Örnek 1 msql_fetch_object() example

<?php
$con = msql_connect();
if (!$con) {
    die('Server connection problem: ' . msql_error());
}

if (!msql_select_db('test', $con)) {
    die('Database connection problem: ' . msql_error());
}

$result = msql_query('SELECT id, name FROM people', $con);
if (!$result) {
    die('Query execution problem: ' . msql_error());
}

while ($row = msql_fetch_object($result, MSQL_ASSOC)) {
    echo $row->id . ': ' . $row->name . "\n";
}

msql_free_result($result);
?>

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.4 | A bug was fixed when retrieving data from columns containing NULL values. Such columns were not placed into the resulting array.

Ayrıca Bakınız

  • msql_fetch_array() - Fetch row as array
  • msql_fetch_row() - Get row as enumerated array
  • msql_data_seek() - Move internal row pointer
  • msql_result() - Get result data

msql_fetch_field
msql_fetch_row
mSQL İşlevleri


Get row as enumerated array

msql_fetch_object
msql_field_flags
mSQL İşlevleri
PHP Manual

msql_fetch_row

(PHP 4, PHP 5, PHP 7)

msql_fetch_row — Get row as enumerated array

Açıklama

array msql_fetch_row ( resource $result )

msql_fetch_row() fetches one row of data from the result associated with the specified query identifier. The row is returned as an array. Each result column is stored in an array offset, starting at offset 0.

Subsequent call to msql_fetch_row() would return the next row in the result set, or FALSE if there are no more rows.

Değiştirgeler

result

The result resource that is being evaluated. This result comes from a call to msql_query().

Dönen Değerler

Returns an array that corresponds to the fetched row, or FALSE if there are no more rows.

Örnekler

Örnek 1 msql_fetch_row() example

<?php
$con = msql_connect();
if (!$con) {
    die('Server connection problem: ' . msql_error());
}

if (!msql_select_db('test', $con)) {
    die('Database connection problem: ' . msql_error());
}

$result = msql_query('SELECT id, name FROM people', $con);
if (!$result) {
    die('Query execution problem: ' . msql_error());
}

while ($row = msql_fetch_row($result)) {
    echo $row[0] . ': ' . $row[1] . "\n";
}

msql_free_result($result);
?>

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.4 | A bug was fixed when retrieving data from columns containing NULL values. Such columns were not placed into the resulting array.

Ayrıca Bakınız

  • msql_fetch_array() - Fetch row as array
  • msql_fetch_object() - Fetch row as object
  • msql_data_seek() - Move internal row pointer
  • msql_result() - Get result data

msql_fetch_object
msql_field_flags
mSQL İşlevleri


Get field flags

msql_fetch_row
msql_field_len
mSQL İşlevleri
PHP Manual

msql_field_flags

(PHP 4, PHP 5, PHP 7)

msql_field_flags — Get field flags

Açıklama

string msql_field_flags ( resource $result , int $field_offset )

msql_field_flags() returns the field flags of the specified field.

Değiştirgeler

result

The result resource that is being evaluated. This result comes from a call to msql_query().

field_offset

The numerical field offset. The field_offset starts at 1.

Dönen Değerler

Returns a string containing the field flags of the specified key. This can be: primary key not null, not null, primary key, unique not null or unique.

msql_fetch_row
msql_field_len
mSQL İşlevleri


Get field length

msql_field_flags
msql_field_name
mSQL İşlevleri
PHP Manual

msql_field_len

(PHP 4, PHP 5, PHP 7)

msql_field_len — Get field length

Açıklama

int msql_field_len ( resource $result , int $field_offset )

msql_field_len() returns the length of the specified field.

Değiştirgeler

result

The result resource that is being evaluated. This result comes from a call to msql_query().

field_offset

The numerical field offset. The field_offset starts at 1.

Dönen Değerler

Returns the length of the specified field or FALSE on error.

msql_field_flags
msql_field_name
mSQL İşlevleri


Get the name of the specified field in a result

msql_field_len
msql_field_seek
mSQL İşlevleri
PHP Manual

msql_field_name

(PHP 4, PHP 5, PHP 7)

msql_field_name — Get the name of the specified field in a result

Açıklama

string msql_field_name ( resource $result , int $field_offset )

msql_field_name() gets the name of the specified field index.

Değiştirgeler

result

The result resource that is being evaluated. This result comes from a call to msql_query().

field_offset

The numerical field offset. The field_offset starts at 1.

Dönen Değerler

The name of the field başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • msql_field_len() - Get field length

msql_field_len
msql_field_seek
mSQL İşlevleri


Set field offset

msql_field_name
msql_field_table
mSQL İşlevleri
PHP Manual

msql_field_seek

(PHP 4, PHP 5, PHP 7)

msql_field_seek — Set field offset

Açıklama

bool msql_field_seek ( resource $result , int $field_offset )

Seeks to the specified field offset. If the next call to msql_fetch_field() won't include a field offset, this field would be returned.

Değiştirgeler

result

The result resource that is being evaluated. This result comes from a call to msql_query().

field_offset

The numerical field offset. The field_offset starts at 1.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • msql_fetch_field() - Get field information

msql_field_name
msql_field_table
mSQL İşlevleri


Get table name for field

msql_field_seek
msql_field_type
mSQL İşlevleri
PHP Manual

msql_field_table

(PHP 4, PHP 5, PHP 7)

msql_field_table — Get table name for field

Açıklama

int msql_field_table ( resource $result , int $field_offset )

Returns the name of the table that the specified field is in.

Değiştirgeler

result

The result resource that is being evaluated. This result comes from a call to msql_query().

field_offset

The numerical field offset. The field_offset starts at 1.

Dönen Değerler

The name of the table on success başarısızlık durumunda FALSE döner.

msql_field_seek
msql_field_type
mSQL İşlevleri


Get field type

msql_field_table
msql_fieldflags
mSQL İşlevleri
PHP Manual

msql_field_type

(PHP 4, PHP 5, PHP 7)

msql_field_type — Get field type

Açıklama

string msql_field_type ( resource $result , int $field_offset )

msql_field_type() gets the type of the specified field index.

Değiştirgeler

result

The result resource that is being evaluated. This result comes from a call to msql_query().

field_offset

The numerical field offset. The field_offset starts at 1.

Dönen Değerler

The type of the field. One of int, char, real, ident, null or unknown. This functions will return FALSE on failure.

msql_field_table
msql_fieldflags
mSQL İşlevleri


Alias of msql_field_flags

msql_field_type
msql_fieldlen
mSQL İşlevleri
PHP Manual

msql_fieldflags

(PHP 4, PHP 5, PHP 7)

msql_fieldflags — Alias of msql_field_flags()

Açıklama

This function is an alias of msql_field_flags().

msql_field_type
msql_fieldlen
mSQL İşlevleri


Alias of msql_field_len

msql_fieldflags
msql_fieldname
mSQL İşlevleri
PHP Manual

msql_fieldlen

(PHP 4, PHP 5, PHP 7)

msql_fieldlen — Alias of msql_field_len()

Açıklama

This function is an alias of msql_field_len().

msql_fieldflags
msql_fieldname
mSQL İşlevleri


Alias of msql_field_name

msql_fieldlen
msql_fieldtable
mSQL İşlevleri
PHP Manual

msql_fieldname

(PHP 4, PHP 5, PHP 7)

msql_fieldname — Alias of msql_field_name()

Açıklama

This function is an alias of msql_field_name().

msql_fieldlen
msql_fieldtable
mSQL İşlevleri


Alias of msql_field_table

msql_fieldname
msql_fieldtype
mSQL İşlevleri
PHP Manual

msql_fieldtable

(PHP 4, PHP 5, PHP 7)

msql_fieldtable — Alias of msql_field_table()

Açıklama

This function is an alias of msql_field_table().

msql_fieldname
msql_fieldtype
mSQL İşlevleri


Alias of msql_field_type

msql_fieldtable
msql_free_result
mSQL İşlevleri
PHP Manual

msql_fieldtype

(PHP 4, PHP 5, PHP 7)

msql_fieldtype — Alias of msql_field_type()

Açıklama

This function is an alias of msql_field_type().

msql_fieldtable
msql_free_result
mSQL İşlevleri


Free result memory

msql_fieldtype
msql_list_dbs
mSQL İşlevleri
PHP Manual

msql_free_result

(PHP 4, PHP 5, PHP 7)

msql_free_result — Free result memory

Açıklama

bool msql_free_result ( resource $result )

msql_free_result() frees the memory associated with query_identifier. When PHP completes a request, this memory is freed automatically, so you only need to call this function when you want to make sure you don't use too much memory while the script is running.

Değiştirgeler

result

The result resource that is being evaluated. This result comes from a call to msql_query().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

msql_fieldtype
msql_list_dbs
mSQL İşlevleri


List mSQL databases on server

msql_free_result
msql_list_fields
mSQL İşlevleri
PHP Manual

msql_list_dbs

(PHP 4, PHP 5, PHP 7)

msql_list_dbs — List mSQL databases on server

Açıklama

resource msql_list_dbs ([ resource $link_identifier ] )

msql_list_tables() lists the databases available on the specified link_identifier.

Değiştirgeler

link_identifier

The mSQL connection. If not specified, the last link opened by msql_connect() is assumed. If no such link is found, the function will try to establish a link as if msql_connect() was called, and use it.

Dönen Değerler

Returns a result set which may be traversed with any function that fetches result sets, such as msql_fetch_array(). On failure, this function will return FALSE.

Ayrıca Bakınız

  • msql_list_tables() - List tables in an mSQL database
  • msql_list_fields() - List result fields

msql_free_result
msql_list_fields
mSQL İşlevleri


List result fields

msql_list_dbs
msql_list_tables
mSQL İşlevleri
PHP Manual

msql_list_fields

(PHP 4, PHP 5, PHP 7)

msql_list_fields — List result fields

Açıklama

resource msql_list_fields ( string $database , string $tablename [, resource $link_identifier ] )

msql_list_fields() returns information about the given table.

Değiştirgeler

database

The name of the database.

tablename

The name of the table.

link_identifier

The mSQL connection. If not specified, the last link opened by msql_connect() is assumed. If no such link is found, the function will try to establish a link as if msql_connect() was called, and use it.

Dönen Değerler

Returns a result set which may be traversed with any function that fetches result sets, such as msql_fetch_array(). On failure, this function will return FALSE.

Ayrıca Bakınız

  • msql_list_tables() - List tables in an mSQL database
  • msql_list_dbs() - List mSQL databases on server

msql_list_dbs
msql_list_tables
mSQL İşlevleri


List tables in an mSQL database

msql_list_fields
msql_num_fields
mSQL İşlevleri
PHP Manual

msql_list_tables

(PHP 4, PHP 5, PHP 7)

msql_list_tables — List tables in an mSQL database

Açıklama

resource msql_list_tables ( string $database [, resource $link_identifier ] )

msql_list_tables() lists the tables on the specified database.

Değiştirgeler

database

The name of the database.

link_identifier

The mSQL connection. If not specified, the last link opened by msql_connect() is assumed. If no such link is found, the function will try to establish a link as if msql_connect() was called, and use it.

Dönen Değerler

Returns a result set which may be traversed with any function that fetches result sets, such as msql_fetch_array(). On failure, this function will return FALSE.

Ayrıca Bakınız

  • msql_list_fields() - List result fields
  • msql_list_dbs() - List mSQL databases on server

msql_list_fields
msql_num_fields
mSQL İşlevleri


Get number of fields in result

msql_list_tables
msql_num_rows
mSQL İşlevleri
PHP Manual

msql_num_fields

(PHP 4, PHP 5, PHP 7)

msql_num_fields — Get number of fields in result

Açıklama

int msql_num_fields ( resource $result )

msql_num_fields() returns the number of fields in a result set.

Değiştirgeler

result

The result resource that is being evaluated. This result comes from a call to msql_query().

Dönen Değerler

Returns the number of fields in the result set.

Ayrıca Bakınız

  • msql_query() - Send mSQL query
  • msql_fetch_field() - Get field information
  • msql_num_rows() - Get number of rows in result

msql_list_tables
msql_num_rows
mSQL İşlevleri


Get number of rows in result

msql_num_fields
msql_numfields
mSQL İşlevleri
PHP Manual

msql_num_rows

(PHP 4, PHP 5, PHP 7)

msql_num_rows — Get number of rows in result

Açıklama

int msql_num_rows ( resource $query_identifier )

msql_num_rows() returns the number of rows in a result set.

Değiştirgeler

result

The result resource that is being evaluated. This result comes from a call to msql_query().

Dönen Değerler

Returns the number of rows in the result set.

Ayrıca Bakınız

  • msql_num_fields() - Get number of fields in result

msql_num_fields
msql_numfields
mSQL İşlevleri


Alias of msql_num_fields

msql_num_rows
msql_numrows
mSQL İşlevleri
PHP Manual

msql_numfields

(PHP 4, PHP 5, PHP 7)

msql_numfields — Alias of msql_num_fields()

Açıklama

This function is an alias of msql_num_fields().

msql_num_rows
msql_numrows
mSQL İşlevleri


Alias of msql_num_rows

msql_numfields
msql_pconnect
mSQL İşlevleri
PHP Manual

msql_numrows

(PHP 4, PHP 5, PHP 7)

msql_numrows — Alias of msql_num_rows()

Açıklama

This function is an alias of msql_num_rows().

msql_numfields
msql_pconnect
mSQL İşlevleri


Open persistent mSQL connection

msql_numrows
msql_query
mSQL İşlevleri
PHP Manual

msql_pconnect

(PHP 4, PHP 5, PHP 7)

msql_pconnect — Open persistent mSQL connection

Açıklama

resource msql_pconnect ([ string $hostname ] )

msql_pconnect() acts very much like msql_connect() with two major differences.

First, when connecting, the function would first try to find a (persistent) link that's already open with the same host. If one is found, an identifier for it will be returned instead of opening a new connection.

Second, the connection to the SQL server will not be closed when the execution of the script ends. Instead, the link will remain open for future use (msql_close() will not close links established by this function).

Değiştirgeler

hostname

The hostname can also include a port number. e.g. hostname,port.

If not specified, the connection is established by the means of a Unix domain socket, being more efficient than a localhost TCP socket connection.

Bilginize: While this function will accept a colon (:) as a host/port separator, a comma (,) is the preferred method.

Dönen Değerler

Returns a positive mSQL link identifier on success, or FALSE on error.

Ayrıca Bakınız

  • msql_connect() - Open mSQL connection
  • msql_close() - Close mSQL connection

msql_numrows
msql_query
mSQL İşlevleri


Send mSQL query

msql_pconnect
msql_regcase
mSQL İşlevleri
PHP Manual

msql_query

(PHP 4, PHP 5, PHP 7)

msql_query — Send mSQL query

Açıklama

resource msql_query ( string $query [, resource $link_identifier ] )

msql_query() sends a query to the currently active database on the server that's associated with the specified link identifier.

Değiştirgeler

query

The SQL query.

link_identifier

The mSQL connection. If not specified, the last link opened by msql_connect() is assumed. If no such link is found, the function will try to establish a link as if msql_connect() was called, and use it.

Dönen Değerler

Returns a positive mSQL query identifier on success, or FALSE on error.

Örnekler

Örnek 1 msql_query() example

<?php
$link = msql_connect("dbserver")
   or die("unable to connect to msql server: " . msql_error());
msql_select_db("db", $link)
   or die("unable to select database 'db': " . msql_error());

$result = msql_query("SELECT * FROM table WHERE id=1", $link);
if (!$result) {
   die("query failed: " . msql_error());
}

while ($row = msql_fetch_array($result)) {
    echo $row["id"];
}
?>

Ayrıca Bakınız

  • msql_db_query() - Send mSQL query
  • msql_select_db() - Select mSQL database
  • msql_connect() - Open mSQL connection

msql_pconnect
msql_regcase
mSQL İşlevleri


Alias of sql_regcase

msql_query
msql_result
mSQL İşlevleri
PHP Manual

msql_regcase

(PHP 4, PHP 5, PHP 7)

msql_regcase — Alias of sql_regcase()

Açıklama

This function is an alias of sql_regcase().

msql_query
msql_result
mSQL İşlevleri


Get result data

msql_regcase
msql_select_db
mSQL İşlevleri
PHP Manual

msql_result

(PHP 4, PHP 5, PHP 7)

msql_result — Get result data

Açıklama

string msql_result ( resource $result , int $row [, mixed $field ] )

msql_result() returns the contents of one cell from a mSQL result set.

When working on large result sets, you should consider using one of the functions that fetch an entire row (specified below). As these functions return the contents of multiple cells in one function call, they are often much quicker than msql_result().

Recommended high-performance alternatives:
msql_fetch_row(),
msql_fetch_array(), and
msql_fetch_object().

Değiştirgeler

result

The result resource that is being evaluated. This result comes from a call to msql_query().

row

The row offset.

field

Can be the field's offset, or the field's name, or the field's table dot field's name (tablename.fieldname.). If the column name has been aliased ('select foo as bar from ...'), use the alias instead of the column name.

Bilginize:

Specifying a numeric field offset is much quicker than specifying a fieldname or tablename.fieldname.

Dönen Değerler

Returns the contents of the cell at the row and offset in the specified mSQL result set.

msql_regcase
msql_select_db
mSQL İşlevleri


Select mSQL database

msql_result
msql_tablename
mSQL İşlevleri
PHP Manual

msql_select_db

(PHP 4, PHP 5, PHP 7)

msql_select_db — Select mSQL database

Açıklama

bool msql_select_db ( string $database_name [, resource $link_identifier ] )

msql_select_db() sets the current active database on the server that's associated with the specified link_identifier.

Subsequent calls to msql_query() will be made on the active database.

Değiştirgeler

database_name

The database name.

link_identifier

The mSQL connection. If not specified, the last link opened by msql_connect() is assumed. If no such link is found, the function will try to establish a link as if msql_connect() was called, and use it.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • msql_connect() - Open mSQL connection
  • msql_pconnect() - Open persistent mSQL connection
  • msql_query() - Send mSQL query

msql_result
msql_tablename
mSQL İşlevleri


Alias of msql_result

msql_select_db
msql
mSQL İşlevleri
PHP Manual

msql_tablename

(PHP 4, PHP 5, PHP 7)

msql_tablename — Alias of msql_result()

Açıklama

This function is an alias of msql_result().

msql_select_db
msql
mSQL İşlevleri


Alias of msql_db_query

msql_tablename
Mssql
mSQL İşlevleri
PHP Manual

msql

(PHP 4, PHP 5, PHP 7)

msql — Alias of msql_db_query()

Açıklama

This function is an alias of msql_db_query().

msql_tablename
Mssql
mSQL İşlevleri


Microsoft SQL Server

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Mssql İşlevleri
    • mssql_bind — Adds a parameter to a stored procedure or a remote stored procedure
    • mssql_close — Close MS SQL Server connection
    • mssql_connect — Open MS SQL server connection
    • mssql_data_seek — Moves internal row pointer
    • mssql_execute — Executes a stored procedure on a MS SQL server database
    • mssql_fetch_array — Fetch a result row as an associative array, a numeric array, or both
    • mssql_fetch_assoc — Returns an associative array of the current row in the result
    • mssql_fetch_batch — Returns the next batch of records
    • mssql_fetch_field — Get field information
    • mssql_fetch_object — Fetch row as object
    • mssql_fetch_row — Get row as enumerated array
    • mssql_field_length — Get the length of a field
    • mssql_field_name — Get the name of a field
    • mssql_field_seek — Seeks to the specified field offset
    • mssql_field_type — Gets the type of a field
    • mssql_free_result — Free result memory
    • mssql_free_statement — Free statement memory
    • mssql_get_last_message — Returns the last message from the server
    • mssql_guid_string — Converts a 16 byte binary GUID to a string
    • mssql_init — Initializes a stored procedure or a remote stored procedure
    • mssql_min_error_severity — Sets the minimum error severity
    • mssql_min_message_severity — Sets the minimum message severity
    • mssql_next_result — Move the internal result pointer to the next result
    • mssql_num_fields — Gets the number of fields in result
    • mssql_num_rows — Gets the number of rows in result
    • mssql_pconnect — Open persistent MS SQL connection
    • mssql_query — Send MS SQL query
    • mssql_result — Get result data
    • mssql_rows_affected — Returns the number of records affected by the query
    • mssql_select_db — Select MS SQL database
msql
Giriş
Sağlayıcıya Göre Veritabanı Eklentileri


Giriş

Uyarı

This feature was REMOVED in PHP 7.0.0.

Alternatives to this feature include:

  • PDO_SQLSRV (Windows only)
  • PDO_ODBC
  • SQLSRV (Windows only)
  • Unified ODBC API

These functions allow you to access MS SQL Server database.

This extension is not available anymore on Windows with PHP 5.3 or later.

SQLSRV, an alternative extension for MS SQL connectivity is available from Microsoft: » http://msdn.microsoft.com/en-us/sqlserver/ff657782.aspx.

Mssql
Yapılandırma/Kurulum
Mssql


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Mssql


Gereksinimler

Requirements for Win32 platforms.

The extension requires the MS SQL Client Tools to be installed on the system where PHP is installed. The Client Tools can be installed from the MS SQL Server CD or by copying ntwdblib.dll from \winnt\system32 on the server to \winnt\system32 on the PHP box. Copying ntwdblib.dll will only provide access through named pipes. Configuration of the client will require installation of all the tools.

This extension is not available anymore on Windows with PHP 5.3 or later.

SqlSrv, an alternative driver for MS SQL is available from Microsoft: » http://msdn.microsoft.com/en-us/sqlserver/ff657782.aspx.

Requirements for Unix/Linux platforms.

To use the MSSQL extension on Unix/Linux, you first need to build and install the FreeTDS library. Source code and installation instructions are available at the FreeTDS home page: » http://www.freetds.org/

Bilginize:

On Windows, the DBLIB from Microsoft is used. Functions that return a column name are based on the dbcolname() function in DBLIB. DBLIB was developed for SQL Server 6.x where the max identifier length is 30. For this reason, the maximum column length is 30 characters. On platforms where FreeTDS is used (Linux), this is not a problem.

Bilginize:

On Windows, if you're using MSSQL 2005 or greater you must copy the ntwdblib.dll into the directory where you have installed php and overwrite the one thats already in there. This is due to the version distributed is old and outdated. Alternatively you can use the » http://msdn.microsoft.com/en-us/sqlserver/ff657782.aspx, ODBC, PDO_DBLIB or PDO_ODBC extensions, to talk to MSSQL.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

The MSSQL extension is enabled by adding extension=php_mssql.dll to php.ini.

To get these functions to work, you have to compile PHP with --with-mssql[=DIR] , where DIR is the FreeTDS install prefix. And FreeTDS should be compiled using --enable-msdblib .

Uyarı

MS SQL functions are aliases to Sybase functions if PHP is compiled with Sybase extension and without MS SQL extension.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

MS SQL Server configuration options
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
mssql.allow_persistent | "1" | PHP_INI_SYSTEM |
mssql.max_persistent | "-1" | PHP_INI_SYSTEM |
mssql.max_links | "-1" | PHP_INI_SYSTEM |
mssql.min_error_severity | "10" | PHP_INI_ALL |
mssql.min_message_severity | "10" | PHP_INI_ALL |
mssql.compatability_mode | "0" | PHP_INI_ALL |
mssql.connect_timeout | "5" | PHP_INI_ALL |
mssql.timeout | "60" | PHP_INI_ALL | Available since PHP 4.1.0.
mssql.textsize | "-1" | PHP_INI_ALL |
mssql.textlimit | "-1" | PHP_INI_ALL |
mssql.batchsize | "0" | PHP_INI_ALL | Available since PHP 4.0.4.
mssql.datetimeconvert | "1" | PHP_INI_ALL | Available since PHP 4.2.0.
mssql.secure_connection | "0" | PHP_INI_SYSTEM | Available since PHP 4.3.0.
mssql.max_procs | "-1" | PHP_INI_ALL | Available since PHP 4.3.0.
mssql.charset | "" | PHP_INI_ALL | Available since PHP 5.1.2 when built with FreeTDS 7.0 or greater.
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Özkaynak Türleri

mssql link

A connection link returned by mssql_connect() and mssql_pconnect().

mssql result

A result handle returned by mssql_query() on SELECT queries.

mssql statement

A statement handle returned by mssql_init().

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

MSSQL_ASSOC (integer)
Return an associative array. Used on mssql_fetch_array()'s result_type parameter.
MSSQL_NUM (integer)
Return an array with numeric keys. Used on mssql_fetch_array()'s result_type parameter.
MSSQL_BOTH (integer)
Return an array with both numeric keys and keys with their field name. This is the default value for mssql_fetch_array()'s result_type parameter.
SQLTEXT (integer)
Indicates the 'TEXT' type in MSSQL, used by mssql_bind()'s type parameter.
SQLVARCHAR (integer)
Indicates the 'VARCHAR' type in MSSQL, used by mssql_bind()'s type parameter.
SQLCHAR (integer)
Indicates the 'CHAR' type in MSSQL, used by mssql_bind()'s type parameter.
SQLINT1 (integer)
Represents one byte, with a range of -128 to 127.
SQLINT2 (integer)
Represents two bytes, with a range of -32768 to 32767.
SQLINT4 (integer)
Represents four bytes, with a range of -2147483648 to 2147483647.
SQLBIT (integer)
Indicates the 'BIT' type in MSSQL, used by mssql_bind()'s type parameter.
SQLFLT4 (integer)
Represents an four byte float.
SQLFLT8 (integer)
Represents an eight byte float.
Özkaynak Türleri
Mssql İşlevleri
Mssql


Mssql İşlevleri

İçindekiler

  • mssql_bind — Adds a parameter to a stored procedure or a remote stored procedure
  • mssql_close — Close MS SQL Server connection
  • mssql_connect — Open MS SQL server connection
  • mssql_data_seek — Moves internal row pointer
  • mssql_execute — Executes a stored procedure on a MS SQL server database
  • mssql_fetch_array — Fetch a result row as an associative array, a numeric array, or both
  • mssql_fetch_assoc — Returns an associative array of the current row in the result
  • mssql_fetch_batch — Returns the next batch of records
  • mssql_fetch_field — Get field information
  • mssql_fetch_object — Fetch row as object
  • mssql_fetch_row — Get row as enumerated array
  • mssql_field_length — Get the length of a field
  • mssql_field_name — Get the name of a field
  • mssql_field_seek — Seeks to the specified field offset
  • mssql_field_type — Gets the type of a field
  • mssql_free_result — Free result memory
  • mssql_free_statement — Free statement memory
  • mssql_get_last_message — Returns the last message from the server
  • mssql_guid_string — Converts a 16 byte binary GUID to a string
  • mssql_init — Initializes a stored procedure or a remote stored procedure
  • mssql_min_error_severity — Sets the minimum error severity
  • mssql_min_message_severity — Sets the minimum message severity
  • mssql_next_result — Move the internal result pointer to the next result
  • mssql_num_fields — Gets the number of fields in result
  • mssql_num_rows — Gets the number of rows in result
  • mssql_pconnect — Open persistent MS SQL connection
  • mssql_query — Send MS SQL query
  • mssql_result — Get result data
  • mssql_rows_affected — Returns the number of records affected by the query
  • mssql_select_db — Select MS SQL database
Öntanımlı Sabitler
mssql_bind
Mssql


Adds a parameter to a stored procedure or a remote stored procedure

Mssql İşlevleri
mssql_close
Mssql İşlevleri
PHP Manual

mssql_bind

(PHP 4 >= 4.0.7, PHP 5, PECL odbtp >= 1.1.1)

mssql_bind — Adds a parameter to a stored procedure or a remote stored procedure

Uyarı

This function was REMOVED in PHP 7.0.0.

Alternatives to this function include:

  • PDOStatement::bindParam()
  • PDOStatement::bindValue()
  • sqlsrv_prepare()
  • odbc_prepare()

Açıklama

bool mssql_bind ( resource $stmt , string $param_name , mixed &$var , int $type [, bool $is_output = false [, bool $is_null = false [, int $maxlen = -1 ]]] )

Binds a parameter to a stored procedure or a remote stored procedure.

Değiştirgeler

stmt

Statement resource, obtained with mssql_init().

param_name

The parameter name, as a string.

Bilginize:

You have to include the @ character, like in the T-SQL syntax. See the explanation included in mssql_execute().

var

The PHP variable you'll bind the MSSQL parameter to. It is passed by reference, to retrieve OUTPUT and RETVAL values after the procedure execution.

type

One of: SQLTEXT, SQLVARCHAR, SQLCHAR, SQLINT1, SQLINT2, SQLINT4, SQLBIT, SQLFLT4, SQLFLT8, SQLFLTN.

is_output

Whether the value is an OUTPUT parameter or not. If it's an OUTPUT parameter and you don't mention it, it will be treated as a normal input parameter and no error will be thrown.

is_null

Whether the parameter is NULL or not. Passing the NULL value as var will not do the job.

maxlen

Used with char/varchar values. You have to indicate the length of the data so if the parameter is a varchar(50), the type must be SQLVARCHAR and this value 50.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 mssql_bind() example

<?php
// Connect to MSSQL and select the database
mssql_connect('KALLESPC\SQLEXPRESS', 'sa', 'phpfi');
mssql_select_db('php');

// Create a new stored prodecure
$stmt = mssql_init('NewUserRecord');

// Bind the field names
mssql_bind($stmt, '@username',  'Kalle',  SQLVARCHAR,  false,  false,  60);
mssql_bind($stmt, '@name',      'Kalle',  SQLVARCHAR,  false,  false,  60);
mssql_bind($stmt, '@age',       19,       SQLINT1,     false,  false,   3);

// Execute
mssql_execute($stmt);

// Free statement
mssql_free_statement($stmt);
?>

Ayrıca Bakınız

  • mssql_execute() - Executes a stored procedure on a MS SQL server database
  • mssql_free_statement() - Free statement memory
  • mssql_init() - Initializes a stored procedure or a remote stored procedure

Mssql İşlevleri
mssql_close
Mssql İşlevleri


Close MS SQL Server connection

mssql_bind
mssql_connect
Mssql İşlevleri
PHP Manual

mssql_close

(PHP 4, PHP 5, PECL odbtp >= 1.1.1)

mssql_close — Close MS SQL Server connection

Uyarı

This function was REMOVED in PHP 7.0.0.

Alternatives to this function include:

  • sqlsrv_close()
  • odbc_close()
  • odbc_close_all()

Açıklama

bool mssql_close ([ resource $link_identifier ] )

Closes the link to a MS SQL Server database that's associated with the specified link identifier. If the link identifier isn't specified, the last opened link is assumed.

Note that this isn't usually necessary, as non-persistent open links are automatically closed at the end of the script's execution.

Değiştirgeler

link_identifier

A MS SQL link identifier, returned by mssql_connect().

This function will not close persistent links generated by mssql_pconnect().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 mssql_close() example

<?php
// Connect to MSSQL
$link = mssql_connect('KALLESPC\SQLEXPRESS', 'sa', 'phpfi');

// Do any related operations here

// Close the link to MSSQL
mssql_close($link);
?>

Ayrıca Bakınız

  • mssql_connect() - Open MS SQL server connection
  • mssql_pconnect() - Open persistent MS SQL connection

mssql_bind
mssql_connect
Mssql İşlevleri


Open MS SQL server connection

mssql_close
mssql_data_seek
Mssql İşlevleri
PHP Manual

mssql_connect

(PHP 4, PHP 5, PECL odbtp >= 1.1.1)

mssql_connect — Open MS SQL server connection

Uyarı

This function was REMOVED in PHP 7.0.0.

Alternatives to this function include:

  • PDO::__construct()
  • sqlsrv_connect()
  • odbc_connect()

Açıklama

resource mssql_connect ([ string $servername [, string $username [, string $password [, bool $new_link = false ]]]] )

mssql_connect() establishes a connection to a MS SQL server.

The link to the server will be closed as soon as the execution of the script ends, unless it's closed earlier by explicitly calling mssql_close().

Değiştirgeler

servername

The MS SQL server. It can also include a port number, e.g. hostname:port (Linux), or hostname,port (Windows).

username

The username.

password

The password.

new_link

If a second call is made to mssql_connect() with the same arguments, no new link will be established, but instead, the link identifier of the already opened link will be returned. This parameter modifies this behavior and makes mssql_connect() always open a new link, even if mssql_connect() was called before with the same parameters.

Dönen Değerler

Returns a MS SQL link identifier on success, or FALSE on error.

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.0 | The new_link parameter was added

Örnekler

Örnek 1 mssql_connect() example

<?php
// Server in the this format: <computer>\<instance name> or
// <server>,<port> when using a non default port number
$server = 'KALLESPC\SQLEXPRESS';

// Connect to MSSQL
$link = mssql_connect($server, 'sa', 'phpfi');

if (!$link) {
    die('Something went wrong while connecting to MSSQL');
}
?>

Ayrıca Bakınız

  • mssql_close() - Close MS SQL Server connection
  • mssql_pconnect() - Open persistent MS SQL connection

mssql_close
mssql_data_seek
Mssql İşlevleri


Moves internal row pointer

mssql_connect
mssql_execute
Mssql İşlevleri
PHP Manual

mssql_data_seek

(PHP 4, PHP 5, PECL odbtp >= 1.1.1)

mssql_data_seek — Moves internal row pointer

Uyarı

This function was REMOVED in PHP 7.0.0.

Alternatives to this function include:

  • Using an OFFSET clause with a query issued through PDO_SQLSRV, PDO_ODBC, SQLSRV, or the unified ODBC driver.

Açıklama

bool mssql_data_seek ( resource $result_identifier , int $row_number )

mssql_data_seek() moves the internal row pointer of the MS SQL result associated with the specified result identifier to point to the specified row number, first row being number 0. The next call to mssql_fetch_row() would return that row.

Değiştirgeler

result_identifier

The result resource that is being evaluated.

row_number

The desired row number of the new result pointer.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 mssql_data_seek() example

<?php
// Connect to MSSQL and select the database
$link = mssql_connect('MANGO\SQLEXPRESS', 'sa', 'phpfi');
mssql_select_db('php', $link);

// Select all people
$result = mssql_query('SELECT [name], [age] FROM [persons] WHERE [age] >= 13');

if (!$result) {
    die('Query failed.');
}

// Select every 4th student in the results
for ($i = mssql_num_rows($result) - 1; $i % 4; $i++) {
    if (!mssql_data_seek($result, $i)) {
        continue;
    }

    // Fetch the row ...
}

// Free the query result
mssql_free_result($result);
?>

mssql_connect
mssql_execute
Mssql İşlevleri


Executes a stored procedure on a MS SQL server database

mssql_data_seek
mssql_fetch_array
Mssql İşlevleri
PHP Manual

mssql_execute

(PHP 4 >= 4.0.7, PHP 5, PECL odbtp >= 1.1.1)

mssql_execute — Executes a stored procedure on a MS SQL server database

Uyarı

This function was REMOVED in PHP 7.0.0.

Alternatives to this function include:

  • Using an EXEC query issued through PDO_SQLSRV, PDO_ODBC, SQLSRV, or the unified ODBC driver.

Açıklama

mixed mssql_execute ( resource $stmt [, bool $skip_results = false ] )

Executes a stored procedure on a MS SQL server database

Değiştirgeler

stmt

Statement handle obtained with mssql_init().

skip_results

Whenever to skip the results or not.

Örnekler

Örnek 1 mssql_execute() example

<?php
// Create a new statement
$stmt = mssql_init('NewBlogEntry');

// Some data strings
$title = 'Test of blogging system';
$content = 'If you can read this, then the new system is compatible with MSSQL';

// Bind values
mssql_bind($stmt, '@author',    'Felipe Pena',  SQLVARCHAR,     false,  false,   60);
mssql_bind($stmt, '@date',      '08/10/2008',   SQLVARCHAR,     false,  false,   20);
mssql_bind($stmt, '@title',     $title,         SQLVARCHAR,     false,  false,   60);
mssql_bind($stmt, '@content',   $content,       SQLTEXT);

// Execute the statement
mssql_execute($stmt);

// And we can free it like so:
mssql_free_statement($stmt);
?>

Notlar

Bilginize:

If the stored procedure returns parameters or a return value these will be available after the call to mssql_execute() unless the stored procedure returns more than one result set. In that case use mssql_next_result() to shift through the results. When the last result has been processed the output parameters and return values will be available.

Ayrıca Bakınız

  • mssql_bind() - Adds a parameter to a stored procedure or a remote stored procedure
  • mssql_free_statement() - Free statement memory
  • mssql_init() - Initializes a stored procedure or a remote stored procedure

mssql_data_seek
mssql_fetch_array
Mssql İşlevleri


Fetch a result row as an associative array, a numeric array, or both

mssql_execute
mssql_fetch_assoc
Mssql İşlevleri
PHP Manual

mssql_fetch_array

(PHP 4, PHP 5, PECL odbtp >= 1.1.1)

mssql_fetch_array — Fetch a result row as an associative array, a numeric array, or both

Uyarı

This function was REMOVED in PHP 7.0.0.

Alternatives to this function include:

  • PDOStatement::fetch()
  • sqlsrv_fetch_array()
  • odbc_fetch_array()

Açıklama

array mssql_fetch_array ( resource $result [, int $result_type = MSSQL_BOTH ] )

mssql_fetch_array() is an extended version of mssql_fetch_row(). In addition to storing the data in the numeric indices of the result array, it also stores the data in associative indices, using the field names as keys.

An important thing to note is that using mssql_fetch_array() is NOT significantly slower than using mssql_fetch_row(), while it provides a significant added value.

Değiştirgeler

result

The result resource that is being evaluated. This result comes from a call to mssql_query().

result_type

The type of array that is to be fetched. It's a constant and can take the following values: MSSQL_ASSOC, MSSQL_NUM, and MSSQL_BOTH.

Dönen Değerler

Returns an array that corresponds to the fetched row, or FALSE if there are no more rows.

Örnekler

Örnek 1 mssql_fetch_array() example

<?php
// Send a select query to MSSQL
$query = mssql_query('SELECT [username], [name] FROM [php].[dbo].[userlist]');

// Check if there were any records
if (!mssql_num_rows($query)) {
    echo 'No records found';
} else {
    // The following is equal to the code below:
    //
    // while ($row = mssql_fetch_row($query)) {

    while ($row = mssql_fetch_array($query, MSSQL_NUM)) {
        // ...
    }
}

// Free the query result
mssql_free_result($query);
?>

Notlar

Bilginize: Bu işlevden dönen alan isimlerinin harf büyüklüklerinde değişiklik yapılmaz.

Bilginize: Bu işlev NULL alanlara PHP NULL değerini atar.

Ayrıca Bakınız

  • mssql_fetch_row() - Get row as enumerated array

mssql_execute
mssql_fetch_assoc
Mssql İşlevleri


Returns an associative array of the current row in the result

mssql_fetch_array
mssql_fetch_batch
Mssql İşlevleri
PHP Manual

mssql_fetch_assoc

(PHP 4 >= 4.2.0, PHP 5, PECL odbtp >= 1.1.1)

mssql_fetch_assoc — Returns an associative array of the current row in the result

Uyarı

This function was REMOVED in PHP 7.0.0.

Alternatives to this function include:

  • PDOStatement::fetch()
  • sqlsrv_fetch_array()
  • odbc_fetch_array()

Açıklama

array mssql_fetch_assoc ( resource $result_id )

Returns an associative array that corresponds to the fetched row and moves the internal data pointer ahead. mssql_fetch_assoc() is equivalent to calling mssql_fetch_array() with MSSQL_ASSOC for the optional second parameter.

Değiştirgeler

result_id

The result resource that is being evaluated. This result comes from a call to mssql_query().

Dönen Değerler

Returns an associative array that corresponds to the fetched row, or FALSE if there are no more rows.

Örnekler

Örnek 1 mssql_fetch_assoc() example

<?php
// Send a select query to MSSQL
$query = mssql_query('SELECT [username], [name] FROM [php].[dbo].[userlist]');

// Check if there were any records
if (!mssql_num_rows($query)) {
    echo 'No records found';
}
else
{
    // Print a nice list of users in the format of:
    // * name (username)

    echo '<ul>';

    while ($row = mssql_fetch_assoc($query)) {
        echo '<li>' . $row['name'] . ' (' . $row['username'] . ')</li>';
    }

    echo '</ul>';
}

// Free the query result
mssql_free_result($query);
?>

mssql_fetch_array
mssql_fetch_batch
Mssql İşlevleri


Returns the next batch of records

mssql_fetch_assoc
mssql_fetch_field
Mssql İşlevleri
PHP Manual

mssql_fetch_batch

(PHP 4 >= 4.0.4, PHP 5, PECL odbtp >= 1.1.1)

mssql_fetch_batch — Returns the next batch of records

Uyarı

Bu işlev PHP 7.0.0'da tamamen KALDIRILMIŞTIR.

Açıklama

int mssql_fetch_batch ( resource $result )

Returns the next batch of records.

Değiştirgeler

result

The result resource that is being evaluated. This result comes from a call to mssql_query().

Dönen Değerler

Returns the number of rows in the returned batch.

Örnekler

Örnek 1 mssql_fetch_batch() example

<?php
// Connect to MSSQL and select the database
$link = mssql_connect('MANGO\SQLEXPRESS', 'sa', 'phpfi');
mssql_select_db('php', $link);

// Send a query
$result = mssql_query('SELECT * FROM [php].[dbo].[people]', $link, 100);
$records = 10;

while ($records >= 0) {
    while ($row = mssql_fetch_assoc($result)) {
        // Do stuff ...
    }

    --$records;
}

if ($batchsize = mssql_fetch_batch($result)) {
    // $batchsize is the number of records left
    // in the result, but not shown above
}
?>

mssql_fetch_assoc
mssql_fetch_field
Mssql İşlevleri


Get field information

mssql_fetch_batch
mssql_fetch_object
Mssql İşlevleri
PHP Manual

mssql_fetch_field

(PHP 4, PHP 5, PECL odbtp >= 1.1.1)

mssql_fetch_field — Get field information

Uyarı

This function was REMOVED in PHP 7.0.0.

Alternatives to this function include:

  • PDOStatement::getColumnMeta()
  • sqlsrv_field_metadata()
  • The various odbc_field_* functions in the unified ODBC driver.

Açıklama

object mssql_fetch_field ( resource $result [, int $field_offset = -1 ] )

mssql_fetch_field() can be used in order to obtain information about fields in a certain query result.

Değiştirgeler

result

The result resource that is being evaluated. This result comes from a call to mssql_query().

field_offset

The numerical field offset. If the field offset is not specified, the next field that was not yet retrieved by this function is retrieved. The field_offset starts at 0.

Dönen Değerler

Returns an object containing field information.

The properties of the object are:

  • name - column name. if the column is a result of a function, this property is set to computed#N, where #N is a serial number.
  • column_source - the table from which the column was taken
  • max_length - maximum length of the column
  • numeric - 1 if the column is numeric
  • type - the column type.

Örnekler

Örnek 1 mssql_fetch_field() example

<?php
// Connect to MSSQL and select the database
mssql_connect('MANGO\SQLEXPRESS', 'sa', 'phpfi');
mssql_select_db('php');

// Send a select query to MSSQL
$query = mssql_query('SELECT * FROM [php].[dbo].[persons]');

// Construct table
echo '<h3>Table structure for \'persons\'</h3>';
echo '<table border="1">';

// Table header
echo '<thead>';
echo '<tr>';
echo '<td>Field name</td>';
echo '<td>Data type</td>';
echo '<td>Max length</td>';
echo '</tr>';
echo '</thead>';

// Dump all fields
echo '<tbody>';

for ($i = 0; $i < mssql_num_fields($query); ++$i) {
    // Fetch the field information
    $field = mssql_fetch_field($query, $i);

    // Print the row
    echo '<tr>';
    echo '<td>' . $field->name . '</td>';
    echo '<td>' . strtoupper($field->type) . '</td>';
    echo '<td>' . $field->max_length . '</td>';
    echo '</tr>';
}

echo '</tbody>';
echo '</table>';

// Free the query result
mssql_free_result($query);
?>

Ayrıca Bakınız

  • mssql_field_seek() - Seeks to the specified field offset

mssql_fetch_batch
mssql_fetch_object
Mssql İşlevleri


Fetch row as object

mssql_fetch_field
mssql_fetch_row
Mssql İşlevleri
PHP Manual

mssql_fetch_object

(PHP 4, PHP 5, PECL odbtp >= 1.1.1)

mssql_fetch_object — Fetch row as object

Uyarı

This function was REMOVED in PHP 7.0.0.

Alternatives to this function include:

  • PDOStatement::fetchObject()
  • sqlsrv_fetch_object()
  • odbc_fetch_object()

Açıklama

object mssql_fetch_object ( resource $result )

mssql_fetch_object() is similar to mssql_fetch_array(), with one difference - an object is returned, instead of an array. Indirectly, that means that you can only access the data by the field names, and not by their offsets (numbers are illegal property names).

Speed-wise, the function is identical to mssql_fetch_array(), and almost as quick as mssql_fetch_row() (the difference is insignificant).

Değiştirgeler

result

The result resource that is being evaluated. This result comes from a call to mssql_query().

Dönen Değerler

Returns an object with properties that correspond to the fetched row, or FALSE if there are no more rows.

Örnekler

Örnek 1 mssql_fetch_object() example

<?php
// Send a select query to MSSQL
$query = mssql_query('SELECT [username], [name] FROM [php].[dbo].[userlist]');

// Check if there were any records
if (!mssql_num_rows($query)) {
    echo 'No records found';
} else {
    // Print a nice list of users in the format of:
    // * name (username)

    echo '<ul>';

    while ($row = mssql_fetch_object($query)) {
        echo '<li>' . $row->name . ' (' . $row->username . ')</li>';
    }

    echo '</ul>';
}

// Free the query result
mssql_free_result($query);
?>

Notlar

Bilginize: Bu işlevden dönen alan isimlerinin harf büyüklüklerinde değişiklik yapılmaz.

Bilginize: Bu işlev NULL alanlara PHP NULL değerini atar.

Ayrıca Bakınız

  • mssql_fetch_array() - Fetch a result row as an associative array, a numeric array, or both
  • mssql_fetch_row() - Get row as enumerated array

mssql_fetch_field
mssql_fetch_row
Mssql İşlevleri


Get row as enumerated array

mssql_fetch_object
mssql_field_length
Mssql İşlevleri
PHP Manual

mssql_fetch_row

(PHP 4, PHP 5, PECL odbtp >= 1.1.1)

mssql_fetch_row — Get row as enumerated array

Uyarı

This function was REMOVED in PHP 7.0.0.

Alternatives to this function include:

  • PDOStatement::fetch()
  • sqlsrv_fetch_array()
  • odbc_fetch_row()

Açıklama

array mssql_fetch_row ( resource $result )

mssql_fetch_row() fetches one row of data from the result associated with the specified result identifier. The row is returned as an array. Each result column is stored in an array offset, starting at offset 0.

Subsequent call to mssql_fetch_row() would return the next row in the result set, or FALSE if there are no more rows.

Değiştirgeler

result

The result resource that is being evaluated. This result comes from a call to mssql_query().

Dönen Değerler

Returns an array that corresponds to the fetched row, or FALSE if there are no more rows.

Örnekler

Örnek 1 mssql_fetch_row() example

<?php
// Connect to MSSQL and select the database
$link = mssql_connect('MANGO\SQLEXPRESS', 'sa', 'phpfi');
mssql_select_db('php', $link);

// Query to execute
$query = mssql_query('SELECT [id], [quote] FROM [quotes] WHERE [id] = \'42\'', $link);

// Did the query fail?
if (!$query) {
    die('MSSQL error: ' . mssql_get_last_message());
}

// Fetch the row
$row = mssql_fetch_row($query);

// Print the 'quote'
echo 'Quote #' . $row[0] . ': "' . $row[1] . '"';
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Quote #42: "The answer to everything..."

Notlar

Bilginize: Bu işlev NULL alanlara PHP NULL değerini atar.

Ayrıca Bakınız

  • mssql_fetch_array() - Fetch a result row as an associative array, a numeric array, or both
  • mssql_fetch_object() - Fetch row as object
  • mssql_data_seek() - Moves internal row pointer
  • mssql_result() - Get result data

mssql_fetch_object
mssql_field_length
Mssql İşlevleri


Get the length of a field

mssql_fetch_row
mssql_field_name
Mssql İşlevleri
PHP Manual

mssql_field_length

(PHP 4, PHP 5, PECL odbtp >= 1.1.1)

mssql_field_length — Get the length of a field

Uyarı

This function was REMOVED in PHP 7.0.0.

Alternatives to this function include:

  • PDOStatement::getColumnMeta()
  • sqlsrv_field_metadata()
  • odbc_field_len()

Açıklama

int mssql_field_length ( resource $result [, int $offset = -1 ] )

Returns the length of field no. offset in result.

Değiştirgeler

result

The result resource that is being evaluated. This result comes from a call to mssql_query().

offset

The field offset, starts at 0. If omitted, the current field is used.

Dönen Değerler

The length of the specified field index on success başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 mssql_field_length() example

<?php
// Connect to MSSQL and select the database
mssql_connect('MANGO\SQLEXPRESS', 'sa', 'phpfi');
mssql_select_db('php');

// Send a select query to MSSQL
$query = mssql_query('SELECT [name], [age] FROM [php].[dbo].[persons]');

// Print the field length
echo 'The field \'age\' has a data length of ' . mssql_field_length($query, 1);

// Free the query result
mssql_free_result($query);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

The field 'age' has a data length of 4

Notlar

Bilginize: Note to Windows Users

Due to a limitation in the underlying API used by PHP (MS DBLib C API), the length of VARCHAR fields is limited to 255. If you need to store more data, use a TEXT field instead.

Ayrıca Bakınız

  • mssql_field_name() - Get the name of a field
  • mssql_field_type() - Gets the type of a field

mssql_fetch_row
mssql_field_name
Mssql İşlevleri


Get the name of a field

mssql_field_length
mssql_field_seek
Mssql İşlevleri
PHP Manual

mssql_field_name

(PHP 4, PHP 5, PECL odbtp >= 1.1.1)

mssql_field_name — Get the name of a field

Uyarı

This function was REMOVED in PHP 7.0.0.

Alternatives to this function include:

  • PDOStatement::getColumnMeta()
  • sqlsrv_field_metadata()
  • odbc_field_name()

Açıklama

string mssql_field_name ( resource $result [, int $offset = -1 ] )

Returns the name of field no. offset in result.

Değiştirgeler

result

The result resource that is being evaluated. This result comes from a call to mssql_query().

offset

The field offset, starts at 0. If omitted, the current field is used.

Dönen Değerler

The name of the specified field index on success başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 mssql_field_name() example

<?php
// Send a select query to MSSQL
$query = mssql_query('SELECT [username], [name], [email] FROM [php].[dbo].[userlist]');

echo 'Result set contains the following field(s):', PHP_EOL;

// Dump all field names in result
for ($i = 0; $i < mssql_num_fields($query); ++$i) {
    echo ' - ' . mssql_field_name($query, $i), PHP_EOL;
}

// Free the query result
mssql_free_result($query);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Result set contains the following field(s):
 - username
 - name
 - email

Ayrıca Bakınız

  • mssql_field_length() - Get the length of a field
  • mssql_field_type() - Gets the type of a field

mssql_field_length
mssql_field_seek
Mssql İşlevleri


Seeks to the specified field offset

mssql_field_name
mssql_field_type
Mssql İşlevleri
PHP Manual

mssql_field_seek

(PHP 4, PHP 5, PECL odbtp >= 1.1.1)

mssql_field_seek — Seeks to the specified field offset

Uyarı

Bu işlev PHP 7.0.0'da tamamen KALDIRILMIŞTIR.

Açıklama

bool mssql_field_seek ( resource $result , int $field_offset )

Seeks to the specified field offset. If the next call to mssql_fetch_field() won't include a field offset, this field would be returned.

Değiştirgeler

result

The result resource that is being evaluated. This result comes from a call to mssql_query().

field_offset

The field offset, starts at 0.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Using mssql_field_seek() on the example for mssql_fetch_field()

<?php
// Connect to MSSQL and select the database
mssql_connect('MANGO\SQLEXPRESS', 'sa', 'phpfi');
mssql_select_db('php');

// Send a select query to MSSQL
$query = mssql_query('SELECT * FROM [php].[dbo].[persons]');

// Construct table
echo '<h3>Table structure for \'persons\'</h3>';
echo '<table border="1">';

// Table header
echo '<thead>';
echo '<tr>';
echo '<td>Field name</td>';
echo '<td>Data type</td>';
echo '<td>Max length</td>';
echo '</tr>';
echo '</thead>';

// Dump all fields
echo '<tbody>';

for ($i = 0; $i < mssql_num_fields($query); ++$i) {
    // Fetch the field information, notice the
    // field_offset parameter is not set. See
    // the mssql_field_seek call below
    $field = mssql_fetch_field($query);

    // Print the row
    echo '<tr>';
    echo '<td>' . $field->name . '</td>';
    echo '<td>' . strtoupper($field->type) . '</td>';
    echo '<td>' . $field->max_length . '</td>';
    echo '</tr>';

    // Move the internal seek pointer to the next
    // row in the result set
    mssql_field_seek($query, $i + 1);
}

echo '</tbody>';
echo '</table>';

// Free the query result
mssql_free_result($query);
?>

Ayrıca Bakınız

  • mssql_fetch_field() - Get field information

mssql_field_name
mssql_field_type
Mssql İşlevleri


Gets the type of a field

mssql_field_seek
mssql_free_result
Mssql İşlevleri
PHP Manual

mssql_field_type

(PHP 4, PHP 5, PECL odbtp >= 1.1.1)

mssql_field_type — Gets the type of a field

Uyarı

This function was REMOVED in PHP 7.0.0.

Alternatives to this function include:

  • PDOStatement::getColumnMeta()
  • sqlsrv_field_metadata()
  • odbc_field_type()

Açıklama

string mssql_field_type ( resource $result [, int $offset = -1 ] )

Returns the type of field no. offset in result.

Değiştirgeler

result

The result resource that is being evaluated. This result comes from a call to mssql_query().

offset

The field offset, starts at 0. If omitted, the current field is used.

Dönen Değerler

The type of the specified field index on success başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 mssql_field_type() example

<?php
// Connect to MSSQL and select the database
mssql_connect('MANGO\SQLEXPRESS', 'sa', 'phpfi');
mssql_select_db('php');

// Send a select query to MSSQL
$query = mssql_query('SELECT [name] FROM [php].[dbo].[persons]');

// Print the field type and length
echo '\'' . mssql_field_name($query, 0) . '\' is a type of ' .
     strtoupper(mssql_field_type($query, 0)) .
     '(' . mssql_field_length($query, 0) . ')';

// Free the query result
mssql_free_result($query);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

'name' is a type of CHAR(50)

Ayrıca Bakınız

  • mssql_field_length() - Get the length of a field
  • mssql_field_name() - Get the name of a field

mssql_field_seek
mssql_free_result
Mssql İşlevleri


Free result memory

mssql_field_type
mssql_free_statement
Mssql İşlevleri
PHP Manual

mssql_free_result

(PHP 4, PHP 5, PECL odbtp >= 1.1.1)

mssql_free_result — Free result memory

Uyarı

This function was REMOVED in PHP 7.0.0.

Alternatives to this function include:

  • odbc_free_result()

Açıklama

bool mssql_free_result ( resource $result )

mssql_free_result() only needs to be called if you are worried about using too much memory while your script is running. All result memory will automatically be freed when the script ends. You may call mssql_free_result() with the result identifier as an argument and the associated result memory will be freed.

Değiştirgeler

result

The result resource that is being freed. This result comes from a call to mssql_query().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 mssql_free_result() example

<?php
// Select some data from a table
$query = mssql_query('SELECT * FROM [php].[dbo].[persons]', $link);

// Handle query result here

// When we're done we free the result by calling
// mssql_free_result like so:
mssql_free_result($query);
?>

Ayrıca Bakınız

  • mssql_free_statement() - Free statement memory

mssql_field_type
mssql_free_statement
Mssql İşlevleri


Free statement memory

mssql_free_result
mssql_get_last_message
Mssql İşlevleri
PHP Manual

mssql_free_statement

(PHP 4 >= 4.3.2, PHP 5, PECL odbtp >= 1.1.1)

mssql_free_statement — Free statement memory

Uyarı

This function was REMOVED in PHP 7.0.0.

Alternatives to this function include:

  • sqlsrv_free_stmt()

Açıklama

bool mssql_free_statement ( resource $stmt )

mssql_free_statement() only needs to be called if you are worried about using too much memory while your script is running. All statement memory will automatically be freed when the script ends. You may call mssql_free_statement() with the statement identifier as an argument and the associated statement memory will be freed.

Değiştirgeler

stmt

Statement resource, obtained with mssql_init().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 mssql_free_statement() example

<?php
// Create a new statement
$stmt = mssql_init('test');

// Bind values here and execute the statement

// once we're done, we clear it from the memory
// using mssql_free_statement like so:
mssql_free_statement($stmt);
?>

Ayrıca Bakınız

  • mssql_bind() - Adds a parameter to a stored procedure or a remote stored procedure
  • mssql_execute() - Executes a stored procedure on a MS SQL server database
  • mssql_init() - Initializes a stored procedure or a remote stored procedure
  • mssql_free_result() - Free result memory

mssql_free_result
mssql_get_last_message
Mssql İşlevleri


Returns the last message from the server

mssql_free_statement
mssql_guid_string
Mssql İşlevleri
PHP Manual

mssql_get_last_message

(PHP 4, PHP 5, PECL odbtp >= 1.1.1)

mssql_get_last_message — Returns the last message from the server

Uyarı

This function was REMOVED in PHP 7.0.0.

Alternatives to this function include:

  • PDOStatement::errorInfo()
  • sqlsrv_errors()
  • odbc_errormsg()

Açıklama

string mssql_get_last_message ( void )

Gets the last message from the MS-SQL server

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns last error message from server, or an empty string if no error messages are returned from MSSQL.

Örnekler

Örnek 1 mssql_get_last_message() example

<?php
// Connect to MSSQL and select the database
mssql_connect('KALLESPC\SQLEXPRESS', 'sa', 'phpfi');
mssql_select_db('php');

// Make a query that will fail
$query = @mssql_query('SELECT * FROM [php].[dbo].[not-found]');

if (!$query) {
    // The query has failed, print a nice error message
    // using mssql_get_last_message()
    die('MSSQL error: ' . mssql_get_last_message());
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

MSSQL error: Invalid object name 'php.dbo.not-found'.

Ayrıca Bakınız

  • mssql_min_error_severity() - Sets the minimum error severity
  • mssql_min_message_severity() - Sets the minimum message severity

mssql_free_statement
mssql_guid_string
Mssql İşlevleri


Converts a 16 byte binary GUID to a string

mssql_get_last_message
mssql_init
Mssql İşlevleri
PHP Manual

mssql_guid_string

(PHP 4 >= 4.0.7, PHP 5, PECL odbtp >= 1.1.1)

mssql_guid_string — Converts a 16 byte binary GUID to a string

Uyarı

Bu işlev PHP 7.0.0'da tamamen KALDIRILMIŞTIR.

Açıklama

string mssql_guid_string ( string $binary [, bool $short_format = false ] )

Converts a 16 byte binary GUID to a string.

Değiştirgeler

binary

A 16 byte binary GUID.

short_format

Whenever to use short format.

Dönen Değerler

Returns the converted string on success.

Örnekler

Örnek 1 mssql_guid_string() example

<?php
$binary = '19555081977808608437941339997619274330352755554827939936';

var_dump(mssql_guid_string($binary));
var_dump(mssql_guid_string($binary, true));
?>

Yukarıdaki örneğin çıktısı:

string(36) "35353931-3035-3138-3937-373830383630"
string(32) "31393535353038313937373830383630"

mssql_get_last_message
mssql_init
Mssql İşlevleri


Initializes a stored procedure or a remote stored procedure

mssql_guid_string
mssql_min_error_severity
Mssql İşlevleri
PHP Manual

mssql_init

(PHP 4 >= 4.0.7, PHP 5, PECL odbtp >= 1.1.1)

mssql_init — Initializes a stored procedure or a remote stored procedure

Uyarı

This function was REMOVED in PHP 7.0.0.

Alternatives to this function include:

  • Using an EXEC query issued through PDO_SQLSRV, PDO_ODBC, SQLSRV, or the unified ODBC driver.

Açıklama

resource mssql_init ( string $sp_name [, resource $link_identifier ] )

Initializes a stored procedure or a remote stored procedure.

Değiştirgeler

sp_name

Stored procedure name, like ownew.sp_name or otherdb.owner.sp_name.

link_identifier

A MS SQL link identifier, returned by mssql_connect().

Dönen Değerler

Returns a resource identifier "statement", used in subsequent calls to mssql_bind() and mssql_execute(), or FALSE on errors.

Örnekler

Örnek 1 mssql_init() example

<?php
// Connect to MSSQL and select the database
$link = mssql_connect('KALLESPC\SQLEXPRESS', 'sa', 'phpfi');
mssql_select_db('php', $link);

// Create a new statement
$stmt = mssql_init('StatementTest', $link);

// Bind values here

// Once values are binded we execute our statement
// using mssql_execute:
mssql_execute($stmt);

// And we can free it like so:
mssql_free_statement($stmt);
?>

Ayrıca Bakınız

  • mssql_bind() - Adds a parameter to a stored procedure or a remote stored procedure
  • mssql_execute() - Executes a stored procedure on a MS SQL server database
  • mssql_free_statement() - Free statement memory

mssql_guid_string
mssql_min_error_severity
Mssql İşlevleri


Sets the minimum error severity

mssql_init
mssql_min_message_severity
Mssql İşlevleri
PHP Manual

mssql_min_error_severity

(PHP 4, PHP 5, PECL odbtp >= 1.1.1)

mssql_min_error_severity — Sets the minimum error severity

Uyarı

Bu işlev PHP 7.0.0'da tamamen KALDIRILMIŞTIR.

Açıklama

void mssql_min_error_severity ( int $severity )

Sets the minimum error severity.

Değiştirgeler

severity

The new error severity.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 mssql_min_error_severity() example

<?php
// Connect to MSSQL and select the database
mssql_connect('KALLESPC\SQLEXPRESS', 'sa', 'phpfi');
mssql_select_db('php');

// Set the minimum error severity to not include SQL
// syntax errors by setting it to something greater than
// or equal to 1.
mssql_min_error_severity(1);

// Send a query we know that will cause an syntax error, in
// this case we use the MySQL quote signs instead of wrapping
// square brackets around the field and table names.
$query = mssql_query('SELECT `syntax`, `error` FROM `MSSQL`');

if (!$query) {
    // Custom error handler ...
}
?>

mssql_init
mssql_min_message_severity
Mssql İşlevleri


Sets the minimum message severity

mssql_min_error_severity
mssql_next_result
Mssql İşlevleri
PHP Manual

mssql_min_message_severity

(PHP 4, PHP 5, PECL odbtp >= 1.1.1)

mssql_min_message_severity — Sets the minimum message severity

Uyarı

Bu işlev PHP 7.0.0'da tamamen KALDIRILMIŞTIR.

Açıklama

void mssql_min_message_severity ( int $severity )

Sets the minimum message severity.

Değiştirgeler

severity

The new message severity.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 mssql_min_message_severity() example

<?php
// Connect to MSSQL
mssql_connect('KALLESPC\SQLEXPRESS', 'sa', 'phpfi');

// Set the minimum message severity to 17, this
// will not show any messages issued by the underlaying
// API when we select a non-existent database below
mssql_min_message_severity(17);

// Select a non-existent database
mssql_select_db('THIS_DATABASE_DOES_NOT_EXISTS');
?>

Yukarıdaki örneğin çıktısı:

mssql_select_db(): Unable to select database:  THIS_DATABASE_DOES_NOT_EXISTS

mssql_min_error_severity
mssql_next_result
Mssql İşlevleri


Move the internal result pointer to the next result

mssql_min_message_severity
mssql_num_fields
Mssql İşlevleri
PHP Manual

mssql_next_result

(PHP 4 >= 4.0.5, PHP 5, PECL odbtp >= 1.1.1)

mssql_next_result — Move the internal result pointer to the next result

Uyarı

This function was REMOVED in PHP 7.0.0.

Alternatives to this function include:

  • PDOStatement::nextRowset()
  • sqlsrv_next_result()
  • odbc_next_result()

Açıklama

bool mssql_next_result ( resource $result_id )

When sending more than one SQL statement to the server or executing a stored procedure with multiple results, it will cause the server to return multiple result sets. This function will test for additional results available form the server. If an additional result set exists it will free the existing result set and prepare to fetch the rows from the new result set.

Değiştirgeler

result_id

The result resource that is being evaluated. This result comes from a call to mssql_query().

Dönen Değerler

Returns TRUE if an additional result set was available or FALSE otherwise.

Örnekler

Örnek 1 mssql_next_result() example

<?php
// Connect to MSSQL and select the database
$link = mssql_connect('MANGO\SQLEXPRESS', 'sa', 'phpfi');
mssql_select_db('php', $link);

// Send a query to MSSQL
$sql = 'SELECT [name], [age] FROM [php].[dbo].[persons]';
$query = mssql_query($sql, $link);

// Iterate through returned records
do {
    while ($row = mssql_fetch_row($query)) {
        // Handle record ...
    }
} while (mssql_next_result($query));

// Clean up
mssql_free_result($query);
mssql_close($link);
?>

mssql_min_message_severity
mssql_num_fields
Mssql İşlevleri


Gets the number of fields in result

mssql_next_result
mssql_num_rows
Mssql İşlevleri
PHP Manual

mssql_num_fields

(PHP 4, PHP 5, PECL odbtp >= 1.1.1)

mssql_num_fields — Gets the number of fields in result

Uyarı

This function was REMOVED in PHP 7.0.0.

Alternatives to this function include:

  • PDOStatement::columnCount()
  • sqlsrv_num_fields()
  • odbc_num_fields()

Açıklama

int mssql_num_fields ( resource $result )

mssql_num_fields() returns the number of fields in a result set.

Değiştirgeler

result

The result resource that is being evaluated. This result comes from a call to mssql_query().

Dönen Değerler

Returns the number of fields, as an integer.

Örnekler

Örnek 1 mssql_num_fields() example

<?php
// Connect to MSSQL and select the database
$link = mssql_connect('KALLESPC\SQLEXPRESS', 'sa', 'phpfi');
mssql_select_db('php', $link);

// Select some data from our database
$data = mssql_query('SELECT [name], [age] FROM [php].[dbo].[persons]');

// Construct a table
echo '<table border="1">';

$header = false;

// Iterate through returned results
while ($row = mssql_fetch_array($data)) {
    // Build the table header
    if (!$header) {
        echo '<thead>';
        echo '<tr>';

        for ($i = 1; ($i + 1) <= mssql_num_fields($data); ++$i) {
            echo '<td>' . ucfirst($row[$i]) . '</td>';
        }

        echo '</tr>';
        echo '</thead>';
        echo '<tbody>';

        $header = true;
    }

    // Build the row
    echo '<tr>';

    foreach($row as $value) {
        echo '<td>' . $value . '</td>';
    }

    echo '</tr>';
}

// Close table
echo '</tbody>';
echo '</table>';

// Clean up
mssql_free_result($data);
mssql_close($link);
?>

Ayrıca Bakınız

  • mssql_query() - Send MS SQL query
  • mssql_fetch_field() - Get field information
  • mssql_num_rows() - Gets the number of rows in result

mssql_next_result
mssql_num_rows
Mssql İşlevleri


Gets the number of rows in result

mssql_num_fields
mssql_pconnect
Mssql İşlevleri
PHP Manual

mssql_num_rows

(PHP 4, PHP 5, PECL odbtp >= 1.1.1)

mssql_num_rows — Gets the number of rows in result

Uyarı

This function was REMOVED in PHP 7.0.0.

Alternatives to this function include:

  • PDOStatement::rowCount()
  • sqlsrv_num_rows()
  • odbc_num_rows()

Açıklama

int mssql_num_rows ( resource $result )

mssql_num_rows() returns the number of rows in a result set.

Değiştirgeler

result

The result resource that is being evaluated. This result comes from a call to mssql_query().

Dönen Değerler

Returns the number of rows, as an integer.

Örnekler

Örnek 1 mssql_num_rows() example

<?php
// Connect to MSSQL and select the database
$link = mssql_connect('KALLESPC\SQLEXPRESS', 'sa', 'phpfi');
mssql_select_db('php');

// Select all our records from a table
$query = mssql_query('SELECT * FROM [php].[dbo].[persons]');

echo 'Total records in database: ' . mssql_num_rows($query);

// Clean up
mssql_free_result($query);
?>

Ayrıca Bakınız

  • mssql_query() - Send MS SQL query
  • mssql_fetch_row() - Get row as enumerated array

mssql_num_fields
mssql_pconnect
Mssql İşlevleri


Open persistent MS SQL connection

mssql_num_rows
mssql_query
Mssql İşlevleri
PHP Manual

mssql_pconnect

(PHP 4, PHP 5, PECL odbtp >= 1.1.1)

mssql_pconnect — Open persistent MS SQL connection

Uyarı

This function was REMOVED in PHP 7.0.0.

Alternatives to this function include:

  • PDO::__construct()
  • sqlsrv_connect()
  • odbc_pconnect()

Açıklama

resource mssql_pconnect ([ string $servername [, string $username [, string $password [, bool $new_link = false ]]]] )

mssql_pconnect() acts very much like mssql_connect() with two major differences.

First, when connecting, the function would first try to find a (persistent) link that's already open with the same host, username and password. If one is found, an identifier for it will be returned instead of opening a new connection.

Second, the connection to the SQL server will not be closed when the execution of the script ends. Instead, the link will remain open for future use (mssql_close() will not close links established by mssql_pconnect()).

This type of links is therefore called 'persistent'.

Değiştirgeler

servername

The MS SQL server. It can also include a port number. e.g. hostname:port.

username

The username.

password

The password.

new_link

If a second call is made to mssql_pconnect() with the same arguments, no new link will be established, but instead, the link identifier of the already opened link will be returned. This parameter modifies this behavior and makes mssql_pconnect() always open a new link, even if mssql_pconnect() was called before with the same parameters.

Dönen Değerler

Returns a positive MS SQL persistent link identifier on success, or FALSE on error.

Örnekler

Örnek 1 mssql_pconnect() using the new_link parameter

<?php
// Connect to MSSQL and select the database
$link1 = mssql_pconnect('MANGO\SQLEXPRESS', 'sa', 'phpfi');
mssql_select_db('php', $link1);

// Create a new link
$link2 = mssql_pconnect('MANGO\SQLEXPRESS', 'sa', 'phpfi', true);
mssql_select_db('random', $link2);
?>

mssql_num_rows
mssql_query
Mssql İşlevleri


Send MS SQL query

mssql_pconnect
mssql_result
Mssql İşlevleri
PHP Manual

mssql_query

(PHP 4, PHP 5, PECL odbtp >= 1.1.1)

mssql_query — Send MS SQL query

Uyarı

This function was REMOVED in PHP 7.0.0.

Alternatives to this function include:

  • PDO::query()
  • sqlsrv_query()
  • odbc_exec()

Açıklama

mixed mssql_query ( string $query [, resource $link_identifier [, int $batch_size = 0 ]] )

mssql_query() sends a query to the currently active database on the server that's associated with the specified link identifier.

Değiştirgeler

query

An SQL query.

link_identifier

A MS SQL link identifier, returned by mssql_connect() or mssql_pconnect().

If the link identifier isn't specified, the last opened link is assumed. If no link is open, the function tries to establish a link as if mssql_connect() was called, and use it.

batch_size

The number of records to batch in the buffer.

Dönen Değerler

Returns a MS SQL result resource on success, TRUE if no rows were returned, or FALSE on error.

Örnekler

Örnek 1 mssql_query() example

<?php
// Connect to MSSQL
$link = mssql_connect('KALLESPC\SQLEXPRESS', 'sa', 'phpfi');

if (!$link || !mssql_select_db('php', $link)) {
    die('Unable to connect or select database!');
}

// Do a simple query, select the version of
// MSSQL and print it.
$version = mssql_query('SELECT @@VERSION');
$row = mssql_fetch_array($version);

echo $row[0];

// Clean up
mssql_free_result($version);
?>

Notlar

Bilginize:

If the query returns multiple results then it is necessary to fetch all results by mssql_next_result() or free the results by mssql_free_result() before executing next query.

Ayrıca Bakınız

  • mssql_select_db() - Select MS SQL database
  • mssql_connect() - Open MS SQL server connection

mssql_pconnect
mssql_result
Mssql İşlevleri


Get result data

mssql_query
mssql_rows_affected
Mssql İşlevleri
PHP Manual

mssql_result

(PHP 4, PHP 5, PECL odbtp >= 1.1.1)

mssql_result — Get result data

Uyarı

This function was REMOVED in PHP 7.0.0.

Alternatives to this function include:

  • odbc_result()

Açıklama

string mssql_result ( resource $result , int $row , mixed $field )

mssql_result() returns the contents of one cell from a MS SQL result set.

Değiştirgeler

result

The result resource that is being evaluated. This result comes from a call to mssql_query().

row

The row number.

field

Can be the field's offset, the field's name or the field's table dot field's name (tablename.fieldname). If the column name has been aliased ('select foo as bar from...'), it uses the alias instead of the column name.

Bilginize:

Specifying a numeric offset for the field argument is much quicker than specifying a fieldname or tablename.fieldname argument.

Dönen Değerler

Returns the contents of the specified cell.

Örnekler

Örnek 1 mssql_result() example

<?php
// Send a select query to MSSQL
$query = mssql_query('SELECT [username] FROM [php].[dbo].[userlist]');

// Check if there were any records
if (!mssql_num_rows($query)) {
    echo 'No records found';
} else {
    for ($i = 0; $i < mssql_num_rows($query); ++$i) {
        echo mssql_result($query, $i, 'username'), PHP_EOL;
    }
}

// Free the query result
mssql_free_result($query);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Kalle
Felipe
Emil
Ross

Örnek 2 Faster alternative to above example

<?php
// Send a select query to MSSQL
$query = mssql_query('SELECT [username] FROM [php].[dbo].[userlist]');

// Check if there were any records
if (!mssql_num_rows($query)) {
    echo 'No records found';
} else {
    while ($row = mssql_fetch_array($query)) {
        echo $row['username'], PHP_EOL;
    }
}

// Free the query result
mssql_free_result($query);
?>

Notlar

Bilginize:

When working on large result sets, you should consider using one of the functions that fetch an entire row (specified below). As these functions return the contents of multiple cells in one function call, they're MUCH quicker than mssql_result().

Ayrıca Bakınız

Recommended high-performance alternatives:

  • mssql_fetch_row() - Get row as enumerated array
  • mssql_fetch_array() - Fetch a result row as an associative array, a numeric array, or both
  • mssql_fetch_assoc() - Returns an associative array of the current row in the result
  • mssql_fetch_object() - Fetch row as object

mssql_query
mssql_rows_affected
Mssql İşlevleri


Returns the number of records affected by the query

mssql_result
mssql_select_db
Mssql İşlevleri
PHP Manual

mssql_rows_affected

(PHP 4 >= 4.0.4, PHP 5, PECL odbtp >= 1.1.1)

mssql_rows_affected — Returns the number of records affected by the query

Uyarı

This function was REMOVED in PHP 7.0.0.

Alternatives to this function include:

  • PDOStatement::rowCount()
  • sqlsrv_rows_affected()

Açıklama

int mssql_rows_affected ( resource $link_identifier )

Returns the number of records affected by the last write query.

Değiştirgeler

link_identifier

A MS SQL link identifier, returned by mssql_connect() or mssql_pconnect().

Dönen Değerler

Returns the number of records affected by last operation.

Örnekler

Örnek 1 mssql_rows_affected() example

<?php
// Delete all rows in a table
mssql_query('TRUNCATE TABLE [php].[dbo].[persons]');

echo 'Deleted ' . mssql_rows_affected($link) . ' row(s)';
?>

mssql_result
mssql_select_db
Mssql İşlevleri


Select MS SQL database

mssql_rows_affected
MySQL
Mssql İşlevleri
PHP Manual

mssql_select_db

(PHP 4, PHP 5, PECL odbtp >= 1.1.1)

mssql_select_db — Select MS SQL database

Uyarı

This function was REMOVED in PHP 7.0.0.

Alternatives to this function include:

  • PDO_SQLSRV DSN
  • PDO_ODBC DSN
  • sqlsrv_connect()
  • odbc_connect()

Açıklama

bool mssql_select_db ( string $database_name [, resource $link_identifier ] )

mssql_select_db() sets the current active database on the server that's associated with the specified link identifier.

Every subsequent call to mssql_query() will be made on the active database.

Değiştirgeler

database_name

The database name.

To escape the name of a database that contains spaces, hyphens ("-"), or any other exceptional characters, the database name must be enclosed in brackets, as is shown in the example, below. This technique must also be applied when selecting a database name that is also a reserved word (such as primary).

link_identifier

A MS SQL link identifier, returned by mssql_connect() or mssql_pconnect().

If no link identifier is specified, the last opened link is assumed. If no link is open, the function will try to establish a link as if mssql_connect() was called, and use it.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 mssql_select_db() example

<?php
// Create a link to MSSQL
$link = mssql_connect('KALLESPC\SQLEXPRESS', 'sa', 'phpfi');

// Select the database 'php'
mssql_select_db('php', $link);
?>

Örnek 2 Escaping the database name with square brackets

<?php
// Create a link to MSSQL
$link = mssql_connect('KALLESPC\SQLEXPRESS', 'sa', 'phpfi');

// Select the database 'my.database-name'
mssql_select_db('[my.database-name]', $link);
?>

Ayrıca Bakınız

  • mssql_connect() - Open MS SQL server connection
  • mssql_pconnect() - Open persistent MS SQL connection
  • mssql_query() - Send MS SQL query

mssql_rows_affected
MySQL
Mssql İşlevleri


MySQL Drivers and Plugins

PHP offers several MySQL drivers and plugins for accessing and handling MySQL.

The differences and functionality of the MySQL extensions are described within the overview of this section.

  • Overview of the MySQL PHP drivers
    • Terminology overview
    • Choosing an API
    • Choosing a library
    • Concepts
  • MySQLi — MySQL Improved Extension
    • Giriş
    • Overview
    • Quick start guide
    • Yapılandırma/Kurulum
    • The mysqli Extension and Persistent Connections
    • Öntanımlı Sabitler
    • Notes
    • The MySQLi Extension Function Summary
    • Örnekler
    • mysqli — The mysqli class
    • mysqli_stmt — The mysqli_stmt class
    • mysqli_result — The mysqli_result class
    • mysqli_driver — The mysqli_driver class
    • mysqli_warning — The mysqli_warning class
    • mysqli_sql_exception — The mysqli_sql_exception class
    • Aliases and deprecated Mysqli İşlevleri
    • Changelog
  • MySQL
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • MySQL İşlevleri
  • Mysqlnd — MySQL Native Driver
    • Giriş
    • Overview
    • Installation
    • Çalışma Anı Yapılandırması
    • Incompatibilities
    • Persistent Connections
    • Statistics
    • Notes
    • Memory management
    • MySQL Native Driver Plugin API
  • mysqlnd_ms — Mysqlnd replication and load balancing plugin
    • Giriş
    • Quickstart and Examples
    • Concepts
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Mysqlnd_ms İşlevleri
    • Change History
  • mysqlnd_qc — Mysqlnd query result cache plugin
    • Giriş
    • Quickstart and Examples
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • mysqlnd_qc İşlevleri
    • Change History
  • mysqlnd_uh — Mysqlnd user handler plugin
    • Giriş
    • Quickstart and Examples
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • MysqlndUhConnection — The MysqlndUhConnection class
    • MysqlndUhPreparedStatement — The MysqlndUhPreparedStatement class
    • Mysqlnd_uh İşlevleri
    • Change History
  • mysqlnd_mux — Mysqlnd connection multiplexing plugin
    • Giriş
    • Concepts
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Change History
  • mysqlnd_memcache — Mysqlnd Memcache plugin
    • Giriş
    • Quickstart and Examples
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Mysqlnd_memcache İşlevleri
    • Change History
mssql_select_db
Overview of the MySQL PHP drivers
Sağlayıcıya Göre Veritabanı Eklentileri


Overview of the MySQL PHP drivers

Introduction

Depending on the version of PHP, there are either two or three PHP APIs for accessing the MySQL database. PHP 5 users can choose between the deprecated mysql extension, mysqli, or PDO_MySQL. PHP 7 removes the mysql extension, leaving only the latter two options.

This guide explains the terminology used to describe each API, information about choosing which API to use, and also information to help choose which MySQL library to use with the API.

  • Terminology overview
  • Choosing an API
  • Choosing a library
  • Concepts
    • Buffered and Unbuffered queries
    • Character sets
MySQL
Terminology overview
MySQL


Terminology overview

This section provides an introduction to the options available to you when developing a PHP application that needs to interact with a MySQL database.

What is an API?

An Application Programming Interface, or API, defines the classes, methods, functions and variables that your application will need to call in order to carry out its desired task. In the case of PHP applications that need to communicate with databases the necessary APIs are usually exposed via PHP extensions.

APIs can be procedural or object-oriented. With a procedural API you call functions to carry out tasks, with the object-oriented API you instantiate classes and then call methods on the resulting objects. Of the two the latter is usually the preferred interface, as it is more modern and leads to better organized code.

When writing PHP applications that need to connect to the MySQL server there are several API options available. This document discusses what is available and how to select the best solution for your application.

What is a Connector?

In the MySQL documentation, the term connector refers to a piece of software that allows your application to connect to the MySQL database server. MySQL provides connectors for a variety of languages, including PHP.

If your PHP application needs to communicate with a database server you will need to write PHP code to perform such activities as connecting to the database server, querying the database and other database-related functions. Software is required to provide the API that your PHP application will use, and also handle the communication between your application and the database server, possibly using other intermediate libraries where necessary. This software is known generically as a connector, as it allows your application to connect to a database server.

What is a Driver?

A driver is a piece of software designed to communicate with a specific type of database server. The driver may also call a library, such as the MySQL Client Library or the MySQL Native Driver. These libraries implement the low-level protocol used to communicate with the MySQL database server.

By way of an example, the PHP Data Objects (PDO) database abstraction layer may use one of several database-specific drivers. One of the drivers it has available is the PDO MYSQL driver, which allows it to interface with the MySQL server.

Sometimes people use the terms connector and driver interchangeably, this can be confusing. In the MySQL-related documentation the term "driver" is reserved for software that provides the database-specific part of a connector package.

What is an Extension?

In the PHP documentation you will come across another term - extension. The PHP code consists of a core, with optional extensions to the core functionality. PHP's MySQL-related extensions, such as the mysqli extension, and the mysql extension, are implemented using the PHP extension framework.

An extension typically exposes an API to the PHP programmer, to allow its facilities to be used programmatically. However, some extensions which use the PHP extension framework do not expose an API to the PHP programmer.

The PDO MySQL driver extension, for example, does not expose an API to the PHP programmer, but provides an interface to the PDO layer above it.

The terms API and extension should not be taken to mean the same thing, as an extension may not necessarily expose an API to the programmer.

Overview of the MySQL PHP drivers
Choosing an API
Overview of the MySQL PHP drivers


Choosing an API

PHP offers three different APIs to connect to MySQL. Below we show the APIs provided by the mysql, mysqli, and PDO extensions. Each code snippet creates a connection to a MySQL server running on "example.com" using the username "user" and the password "password". And a query is run to greet the user.

Örnek 1 Comparing the three MySQL APIs

<?php
// mysqli
$mysqli = new mysqli("example.com", "user", "password", "database");
$result = $mysqli->query("SELECT 'Hello, dear MySQL user!' AS _message FROM DUAL");
$row = $result->fetch_assoc();
echo htmlentities($row['_message']);

// PDO
$pdo = new PDO('mysql:host=example.com;dbname=database', 'user', 'password');
$statement = $pdo->query("SELECT 'Hello, dear MySQL user!' AS _message FROM DUAL");
$row = $statement->fetch(PDO::FETCH_ASSOC);
echo htmlentities($row['_message']);

// mysql
$c = mysql_connect("example.com", "user", "password");
mysql_select_db("database");
$result = mysql_query("SELECT 'Hello, dear MySQL user!' AS _message FROM DUAL");
$row = mysql_fetch_assoc($result);
echo htmlentities($row['_message']);
?>

Recommended API

It is recommended to use either the mysqli or PDO_MySQL extensions. It is not recommended to use the old mysql extension for new development, as it was deprecated in PHP 5.5.0 and was removed in PHP 7. A detailed feature comparison matrix is provided below. The overall performance of all three extensions is considered to be about the same. Although the performance of the extension contributes only a fraction of the total run time of a PHP web request. Often, the impact is as low as 0.1%.

Feature comparison

 | ext/mysqli | PDO_MySQL | ext/mysql
PHP version introduced | 5.0 | 5.1 | 2.0
Included with PHP 5.x | Yes | Yes | Yes
Included with PHP 7.x | Yes | Yes | No
Development status | Active | Active | Maintenance only in 5.x; removed in 7.x
Lifecycle | Active | Active | Deprecated in 5.x; removed in 7.x
Recommended for new projects | Yes | Yes | No
OOP Interface | Yes | Yes | No
Procedural Interface | Yes | No | Yes
API supports non-blocking, asynchronous queries with mysqlnd | Yes | No | No
Persistent Connections | Yes | Yes | Yes
API supports Charsets | Yes | Yes | Yes
API supports server-side Prepared Statements | Yes | Yes | No
API supports client-side Prepared Statements | No | Yes | No
API supports Stored Procedures | Yes | Yes | No
API supports Multiple Statements | Yes | Most | No
API supports Transactions | Yes | Yes | No
Transactions can be controlled with SQL | Yes | Yes | Yes
Supports all MySQL 5.1+ functionality | Yes | Most | No
Terminology overview
Choosing a library
Overview of the MySQL PHP drivers


Choosing a library

The mysqli, PDO_MySQL and mysql PHP extensions are lightweight wrappers on top of a C client library. The extensions can either use the mysqlnd library or the libmysqlclient library. Choosing a library is a compile time decision.

The mysqlnd library is part of the PHP distribution since 5.3.0. It offers features like lazy connections and query caching, features that are not available with libmysqlclient, so using the built-in mysqlnd library is highly recommended. See the mysqlnd documentation for additional details, and a listing of features and functionality that it offers.

Örnek 1 Configure commands for using mysqlnd or libmysqlclient

// Recommended, compiles with mysqlnd
$ ./configure --with-mysqli=mysqlnd --with-pdo-mysql=mysqlnd --with-mysql=mysqlnd

// Alternatively recommended, compiles with mysqlnd as of PHP 5.4
$ ./configure --with-mysqli --with-pdo-mysql --with-mysql

// Not recommended, compiles with libmysqlclient
$ ./configure --with-mysqli=/path/to/mysql_config --with-pdo-mysql=/path/to/mysql_config --with-mysql=/path/to/mysql_config

Library feature comparison

It is recommended to use the mysqlnd library instead of the MySQL Client Server library (libmysqlclient). Both libraries are supported and constantly being improved.

 | MySQL native driver (mysqlnd) | MySQL client server library (libmysqlclient)
Part of the PHP distribution | Yes | No
PHP version introduced | 5.3.0 | N/A
License | PHP License 3.01 | Dual-License
Development status | Active | Active
Lifecycle | No end announced | No end announced
PHP 5.4 and above; compile default (for all MySQL extensions) | Yes | No
PHP 5.3; compile default (for all MySQL extensions) | No | Yes
Compression protocol support | Yes (5.3.1+) | Yes
SSL support | Yes (5.3.3+) | Yes
Named pipe support | Yes (5.3.4+) | Yes
Non-blocking, asynchronous queries | Yes | No
Performance statistics | Yes | No
LOAD LOCAL INFILE respects the open_basedir directive | Yes | No
Uses PHP's native memory management system (e.g., follows PHP memory limits) | Yes | No
Return numeric column as double (COM_QUERY) | Yes | No
Return numeric column as string (COM_QUERY) | Yes | Yes
Plugin API | Yes | Limited
Read/Write splitting for MySQL Replication | Yes, with plugin | No
Load Balancing | Yes, with plugin | No
Fail over | Yes, with plugin | No
Lazy connections | Yes, with plugin | No
Query caching | Yes, with plugin | No
Transparent query manipulations (E.g., auto-EXPLAIN or monitoring) | Yes, with plugin | No
Automatic reconnect | No | Optional
Choosing an API
Concepts
Overview of the MySQL PHP drivers


Concepts

İçindekiler

  • Buffered and Unbuffered queries
  • Character sets

These concepts are specific to the MySQL drivers for PHP.

Choosing a library
Buffered and Unbuffered queries
Overview of the MySQL PHP drivers


Buffered and Unbuffered queries

Queries are using the buffered mode by default. This means that query results are immediately transferred from the MySQL Server to PHP and then are kept in the memory of the PHP process. This allows additional operations like counting the number of rows, and moving (seeking) the current result pointer. It also allows issuing further queries on the same connection while working on the result set. The downside of the buffered mode is that larger result sets might require quite a lot memory. The memory will be kept occupied till all references to the result set are unset or the result set was explicitly freed, which will automatically happen during request end the latest. The terminology "store result" is also used for buffered mode, as the whole result set is stored at once.

Bilginize:

When using libmysqlclient as library PHP's memory limit won't count the memory used for result sets unless the data is fetched into PHP variables. With mysqlnd the memory accounted for will include the full result set.

Unbuffered MySQL queries execute the query and then return a resource while the data is still waiting on the MySQL server for being fetched. This uses less memory on the PHP-side, but can increase the load on the server. Unless the full result set was fetched from the server no further queries can be sent over the same connection. Unbuffered queries can also be referred to as "use result".

Following these characteristics buffered queries should be used in cases where you expect only a limited result set or need to know the amount of returned rows before reading all rows. Unbuffered mode should be used when you expect larger results.

Because buffered queries are the default, the examples below will demonstrate how to execute unbuffered queries with each API.

Örnek 1 Unbuffered query example: mysqli

<?php
$mysqli  = new mysqli("localhost", "my_user", "my_password", "world");
$uresult = $mysqli->query("SELECT Name FROM City", MYSQLI_USE_RESULT);

if ($uresult) {
   while ($row = $uresult->fetch_assoc()) {
       echo $row['Name'] . PHP_EOL;
   }
}
$uresult->close();
?>

Örnek 2 Unbuffered query example: pdo_mysql

<?php
$pdo = new PDO("mysql:host=localhost;dbname=world", 'my_user', 'my_pass');
$pdo->setAttribute(PDO::MYSQL_ATTR_USE_BUFFERED_QUERY, false);

$uresult = $pdo->query("SELECT Name FROM City");
if ($uresult) {
   while ($row = $uresult->fetch(PDO::FETCH_ASSOC)) {
       echo $row['Name'] . PHP_EOL;
   }
}
?>

Örnek 3 Unbuffered query example: mysql

<?php
$conn = mysql_connect("localhost", "my_user", "my_pass");
$db   = mysql_select_db("world");

$uresult = mysql_unbuffered_query("SELECT Name FROM City");
if ($uresult) {
   while ($row = mysql_fetch_assoc($uresult)) {
       echo $row['Name'] . PHP_EOL;
   }
}
?>
Concepts
Character sets
Concepts


Character sets

Ideally a proper character set will be set at the server level, and doing this is described within the » Character Set Configuration section of the MySQL Server manual. Alternatively, each MySQL API offers a method to set the character set at runtime.

Dikkat

The character set and character escaping

The character set should be understood and defined, as it has an affect on every action, and includes security implications. For example, the escaping mechanism (e.g., mysqli_real_escape_string() for mysqli, mysql_real_escape_string() for mysql, and PDO::quote() for PDO_MySQL) will adhere to this setting. It is important to realize that these functions will not use the character set that is defined with a query, so for example the following will not have an effect on them:

Örnek 1 Problems with setting the character set with SQL

<?php

$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

// Will NOT affect $mysqli->real_escape_string();
$mysqli->query("SET NAMES utf8");

// Will NOT affect $mysqli->real_escape_string();
$mysqli->query("SET CHARACTER SET utf8");

// But, this will affect $mysqli->real_escape_string();
$mysqli->set_charset('utf8');

// But, this will NOT affect it (utf-8 vs utf8) -- don't use dashes here
$mysqli->set_charset('utf-8');

?>

Below are examples that demonstrate how to properly alter the character set at runtime using each API.

Bilginize: Possible UTF-8 confusion

Because character set names in MySQL do not contain dashes, the string "utf8" is valid in MySQL to set the character set to UTF-8. The string "utf-8" is not valid, as using "utf-8" will fail to change the character set.

Örnek 2 Setting the character set example: mysqli

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

printf("Initial character set: %s\n", $mysqli->character_set_name());

if (!$mysqli->set_charset('utf8')) {
    printf("Error loading character set utf8: %s\n", $mysqli->error);
    exit;
}

echo "New character set information:\n";
print_r( $mysqli->get_charset() );

?>

Örnek 3 Setting the character set example: pdo_mysql

Note: This only works as of PHP 5.3.6.

<?php
$pdo = new PDO("mysql:host=localhost;dbname=world;charset=utf8", 'my_user', 'my_pass');
?>

Örnek 4 Setting the character set example: mysql

<?php
$conn = mysql_connect("localhost", "my_user", "my_pass");
$db   = mysql_select_db("world");

echo 'Initial character set: ' .  mysql_client_encoding($conn) . "\n";

if (!mysql_set_charset('utf8', $conn)) {
    echo "Error: Unable to set the character set.\n";
    exit;
}

echo 'Your current character set is: ' .  mysql_client_encoding($conn);
?>
Buffered and Unbuffered queries
MySQLi
Concepts


MySQL Improved Extension

  • Giriş
  • Overview
  • Quick start guide
    • Dual procedural and object-oriented interface
    • Connections
    • Executing statements
    • Prepared Statements
    • Stored Procedures
    • Multiple Statements
    • API support for transactions
    • Metadata
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • The mysqli Extension and Persistent Connections
  • Öntanımlı Sabitler
  • Notes
  • The MySQLi Extension Function Summary
  • Örnekler
    • MySQLi extension basic examples
  • mysqli — The mysqli class
    • mysqli::$affected_rows — Gets the number of affected rows in a previous MySQL operation
    • mysqli::autocommit — Turns on or off auto-committing database modifications
    • mysqli::begin_transaction — Starts a transaction
    • mysqli::change_user — Changes the user of the specified database connection
    • mysqli::character_set_name — Returns the default character set for the database connection
    • mysqli::$client_info — Get MySQL client info
    • mysqli::$client_version — Returns the MySQL client version as a string
    • mysqli::close — Closes a previously opened database connection
    • mysqli::commit — Commits the current transaction
    • mysqli::$connect_errno — Returns the error code from last connect call
    • mysqli::$connect_error — Returns a string description of the last connect error
    • mysqli::__construct — Open a new connection to the MySQL server
    • mysqli::debug — Performs debugging operations
    • mysqli::dump_debug_info — Dump debugging information into the log
    • mysqli::$errno — Returns the error code for the most recent function call
    • mysqli::$error_list — Returns a list of errors from the last command executed
    • mysqli::$error — Returns a string description of the last error
    • mysqli::$field_count — Returns the number of columns for the most recent query
    • mysqli::get_charset — Returns a character set object
    • mysqli::get_client_info — Get MySQL client info
    • mysqli_get_client_stats — Returns client per-process statistics
    • mysqli_get_client_version — Returns the MySQL client version as an integer
    • mysqli::get_connection_stats — Returns statistics about the client connection
    • mysqli::$host_info — Returns a string representing the type of connection used
    • mysqli::$protocol_version — Returns the version of the MySQL protocol used
    • mysqli::$server_info — Returns the version of the MySQL server
    • mysqli::$server_version — Returns the version of the MySQL server as an integer
    • mysqli::get_warnings — Get result of SHOW WARNINGS
    • mysqli::$info — Retrieves information about the most recently executed query
    • mysqli::init — Initializes MySQLi and returns a resource for use with mysqli_real_connect()
    • mysqli::$insert_id — Returns the auto generated id used in the latest query
    • mysqli::kill — Asks the server to kill a MySQL thread
    • mysqli::more_results — Check if there are any more query results from a multi query
    • mysqli::multi_query — Performs a query on the database
    • mysqli::next_result — Prepare next result from multi_query
    • mysqli::options — Set options
    • mysqli::ping — Pings a server connection, or tries to reconnect if the connection has gone down
    • mysqli::poll — Poll connections
    • mysqli::prepare — Prepare an SQL statement for execution
    • mysqli::query — Performs a query on the database
    • mysqli::real_connect — Opens a connection to a mysql server
    • mysqli::real_escape_string — Escapes special characters in a string for use in an SQL statement, taking into account the current charset of the connection
    • mysqli::real_query — Execute an SQL query
    • mysqli::reap_async_query — Get result from async query
    • mysqli::refresh — Refreshes
    • mysqli::release_savepoint — Removes the named savepoint from the set of savepoints of the current transaction
    • mysqli::rollback — Rolls back current transaction
    • mysqli::rpl_query_type — Returns RPL query type
    • mysqli::savepoint — Set a named transaction savepoint
    • mysqli::select_db — Selects the default database for database queries
    • mysqli::send_query — Send the query and return
    • mysqli::set_charset — Sets the default client character set
    • mysqli::set_local_infile_default — Unsets user defined handler for load local infile command
    • mysqli::set_local_infile_handler — Set callback function for LOAD DATA LOCAL INFILE command
    • mysqli::$sqlstate — Returns the SQLSTATE error from previous MySQL operation
    • mysqli::ssl_set — Used for establishing secure connections using SSL
    • mysqli::stat — Gets the current system status
    • mysqli::stmt_init — Initializes a statement and returns an object for use with mysqli_stmt_prepare
    • mysqli::store_result — Transfers a result set from the last query
    • mysqli::$thread_id — Returns the thread ID for the current connection
    • mysqli::thread_safe — Returns whether thread safety is given or not
    • mysqli::use_result — Initiate a result set retrieval
    • mysqli::$warning_count — Returns the number of warnings from the last query for the given link
  • mysqli_stmt — The mysqli_stmt class
    • mysqli_stmt::$affected_rows — Returns the total number of rows changed, deleted, or inserted by the last executed statement
    • mysqli_stmt::attr_get — Used to get the current value of a statement attribute
    • mysqli_stmt::attr_set — Used to modify the behavior of a prepared statement
    • mysqli_stmt::bind_param — Binds variables to a prepared statement as parameters
    • mysqli_stmt::bind_result — Binds variables to a prepared statement for result storage
    • mysqli_stmt::close — Closes a prepared statement
    • mysqli_stmt::__construct — Constructs a new mysqli_stmt object
    • mysqli_stmt::data_seek — Seeks to an arbitrary row in statement result set
    • mysqli_stmt::$errno — Returns the error code for the most recent statement call
    • mysqli_stmt::$error_list — Returns a list of errors from the last statement executed
    • mysqli_stmt::$error — Returns a string description for last statement error
    • mysqli_stmt::execute — Executes a prepared Query
    • mysqli_stmt::fetch — Fetch results from a prepared statement into the bound variables
    • mysqli_stmt::$field_count — Returns the number of field in the given statement
    • mysqli_stmt::free_result — Frees stored result memory for the given statement handle
    • mysqli_stmt::get_result — Gets a result set from a prepared statement
    • mysqli_stmt::get_warnings — Get result of SHOW WARNINGS
    • mysqli_stmt::$insert_id — Get the ID generated from the previous INSERT operation
    • mysqli_stmt::more_results — Check if there are more query results from a multiple query
    • mysqli_stmt::next_result — Reads the next result from a multiple query
    • mysqli_stmt::$num_rows — Return the number of rows in statements result set
    • mysqli_stmt::$param_count — Returns the number of parameter for the given statement
    • mysqli_stmt::prepare — Prepare an SQL statement for execution
    • mysqli_stmt::reset — Resets a prepared statement
    • mysqli_stmt::result_metadata — Returns result set metadata from a prepared statement
    • mysqli_stmt::send_long_data — Send data in blocks
    • mysqli_stmt::$sqlstate — Returns SQLSTATE error from previous statement operation
    • mysqli_stmt::store_result — Transfers a result set from a prepared statement
  • mysqli_result — The mysqli_result class
    • mysqli_result::$current_field — Get current field offset of a result pointer
    • mysqli_result::data_seek — Adjusts the result pointer to an arbitrary row in the result
    • mysqli_result::fetch_all — Fetches all result rows as an associative array, a numeric array, or both
    • mysqli_result::fetch_array — Fetch a result row as an associative, a numeric array, or both
    • mysqli_result::fetch_assoc — Fetch a result row as an associative array
    • mysqli_result::fetch_field_direct — Fetch meta-data for a single field
    • mysqli_result::fetch_field — Returns the next field in the result set
    • mysqli_result::fetch_fields — Returns an array of objects representing the fields in a result set
    • mysqli_result::fetch_object — Returns the current row of a result set as an object
    • mysqli_result::fetch_row — Get a result row as an enumerated array
    • mysqli_result::$field_count — Get the number of fields in a result
    • mysqli_result::field_seek — Set result pointer to a specified field offset
    • mysqli_result::free — Frees the memory associated with a result
    • mysqli_result::$lengths — Returns the lengths of the columns of the current row in the result set
    • mysqli_result::$num_rows — Gets the number of rows in a result
  • mysqli_driver — The mysqli_driver class
    • mysqli_driver::embedded_server_end — Stop embedded server
    • mysqli_driver::embedded_server_start — Initialize and start embedded server
    • mysqli_driver::$report_mode — Enables or disables internal report functions
  • mysqli_warning — The mysqli_warning class
    • mysqli_warning::__construct — The __construct purpose
    • mysqli_warning::next — The next purpose
  • mysqli_sql_exception — The mysqli_sql_exception class
  • Aliases and deprecated Mysqli İşlevleri
    • mysqli_bind_param — Alias for mysqli_stmt_bind_param
    • mysqli_bind_result — Alias for mysqli_stmt_bind_result
    • mysqli_client_encoding — Alias of mysqli_character_set_name
    • mysqli_connect — Takma Adı: mysqli::__construct
    • mysqli::disable_reads_from_master — Disable reads from master
    • mysqli_disable_rpl_parse — Disable RPL parse
    • mysqli_enable_reads_from_master — Enable reads from master
    • mysqli_enable_rpl_parse — Enable RPL parse
    • mysqli_escape_string — Takma Adı: mysqli_real_escape_string
    • mysqli_execute — Alias for mysqli_stmt_execute
    • mysqli_fetch — Alias for mysqli_stmt_fetch
    • mysqli_get_cache_stats — Returns client Zval cache statistics
    • mysqli_get_links_stats — Return information about open and cached links
    • mysqli_get_metadata — Alias for mysqli_stmt_result_metadata
    • mysqli_master_query — Enforce execution of a query on the master in a master/slave setup
    • mysqli_param_count — Alias for mysqli_stmt_param_count
    • mysqli_report — Takma Adı: mysqli_driver->report_mode
    • mysqli_rpl_parse_enabled — Check if RPL parse is enabled
    • mysqli_rpl_probe — RPL probe
    • mysqli_send_long_data — Alias for mysqli_stmt_send_long_data
    • mysqli::set_opt — Alias of mysqli_options
    • mysqli_slave_query — Force execution of a query on a slave in a master/slave setup
  • Changelog
Character sets
Giriş
MySQL


Giriş

The mysqli extension allows you to access the functionality provided by MySQL 4.1 and above. More information about the MySQL Database server can be found at » http://www.mysql.com/

An overview of software available for using MySQL from PHP can be found at Overview

Documentation for MySQL can be found at » http://dev.mysql.com/doc/.

Parts of this documentation included from MySQL manual with permissions of Oracle Corporation.

Examples use either the » world or » sakila database, which are freely available.

MySQLi
Overview
MySQLi


Overview

This section provides an introduction to the options available to you when developing a PHP application that needs to interact with a MySQL database.

What is an API?

An Application Programming Interface, or API, defines the classes, methods, functions and variables that your application will need to call in order to carry out its desired task. In the case of PHP applications that need to communicate with databases the necessary APIs are usually exposed via PHP extensions.

APIs can be procedural or object-oriented. With a procedural API you call functions to carry out tasks, with the object-oriented API you instantiate classes and then call methods on the resulting objects. Of the two the latter is usually the preferred interface, as it is more modern and leads to better organized code.

When writing PHP applications that need to connect to the MySQL server there are several API options available. This document discusses what is available and how to select the best solution for your application.

What is a Connector?

In the MySQL documentation, the term connector refers to a piece of software that allows your application to connect to the MySQL database server. MySQL provides connectors for a variety of languages, including PHP.

If your PHP application needs to communicate with a database server you will need to write PHP code to perform such activities as connecting to the database server, querying the database and other database-related functions. Software is required to provide the API that your PHP application will use, and also handle the communication between your application and the database server, possibly using other intermediate libraries where necessary. This software is known generically as a connector, as it allows your application to connect to a database server.

What is a Driver?

A driver is a piece of software designed to communicate with a specific type of database server. The driver may also call a library, such as the MySQL Client Library or the MySQL Native Driver. These libraries implement the low-level protocol used to communicate with the MySQL database server.

By way of an example, the PHP Data Objects (PDO) database abstraction layer may use one of several database-specific drivers. One of the drivers it has available is the PDO MYSQL driver, which allows it to interface with the MySQL server.

Sometimes people use the terms connector and driver interchangeably, this can be confusing. In the MySQL-related documentation the term "driver" is reserved for software that provides the database-specific part of a connector package.

What is an Extension?

In the PHP documentation you will come across another term - extension. The PHP code consists of a core, with optional extensions to the core functionality. PHP's MySQL-related extensions, such as the mysqli extension, and the mysql extension, are implemented using the PHP extension framework.

An extension typically exposes an API to the PHP programmer, to allow its facilities to be used programmatically. However, some extensions which use the PHP extension framework do not expose an API to the PHP programmer.

The PDO MySQL driver extension, for example, does not expose an API to the PHP programmer, but provides an interface to the PDO layer above it.

The terms API and extension should not be taken to mean the same thing, as an extension may not necessarily expose an API to the programmer.

What are the main PHP API offerings for using MySQL?

There are three main API options when considering connecting to a MySQL database server:

  • PHP's MySQL Extension

  • PHP's mysqli Extension

  • PHP Data Objects (PDO)

Each has its own advantages and disadvantages. The following discussion aims to give a brief introduction to the key aspects of each API.

What is PHP's MySQL Extension?

This is the original extension designed to allow you to develop PHP applications that interact with a MySQL database. The mysql extension provides a procedural interface and is intended for use only with MySQL versions older than 4.1.3. This extension can be used with versions of MySQL 4.1.3 or newer, but not all of the latest MySQL server features will be available.

Bilginize:

If you are using MySQL versions 4.1.3 or later it is strongly recommended that you use the mysqli extension instead.

The mysql extension source code is located in the PHP extension directory ext/mysql.

For further information on the mysql extension, see MySQL.

What is PHP's mysqli Extension?

The mysqli extension, or as it is sometimes known, the MySQL improved extension, was developed to take advantage of new features found in MySQL systems versions 4.1.3 and newer. The mysqli extension is included with PHP versions 5 and later.

The mysqli extension has a number of benefits, the key enhancements over the mysql extension being:

  • Object-oriented interface

  • Support for Prepared Statements

  • Support for Multiple Statements

  • Support for Transactions

  • Enhanced debugging capabilities

  • Embedded server support

Bilginize:

If you are using MySQL versions 4.1.3 or later it is strongly recommended that you use this extension.

As well as the object-oriented interface the extension also provides a procedural interface.

The mysqli extension is built using the PHP extension framework, its source code is located in the directory ext/mysqli.

For further information on the mysqli extension, see MySQLi.

What is PDO?

PHP Data Objects, or PDO, is a database abstraction layer specifically for PHP applications. PDO provides a consistent API for your PHP application regardless of the type of database server your application will connect to. In theory, if you are using the PDO API, you could switch the database server you used, from say Firebird to MySQL, and only need to make minor changes to your PHP code.

Other examples of database abstraction layers include JDBC for Java applications and DBI for Perl.

While PDO has its advantages, such as a clean, simple, portable API, its main disadvantage is that it doesn't allow you to use all of the advanced features that are available in the latest versions of MySQL server. For example, PDO does not allow you to use MySQL's support for Multiple Statements.

PDO is implemented using the PHP extension framework, its source code is located in the directory ext/pdo.

For further information on PDO, see the PDO.

What is the PDO MYSQL driver?

The PDO MYSQL driver is not an API as such, at least from the PHP programmer's perspective. In fact the PDO MYSQL driver sits in the layer below PDO itself and provides MySQL-specific functionality. The programmer still calls the PDO API, but PDO uses the PDO MYSQL driver to carry out communication with the MySQL server.

The PDO MYSQL driver is one of several available PDO drivers. Other PDO drivers available include those for the Firebird and PostgreSQL database servers.

The PDO MYSQL driver is implemented using the PHP extension framework. Its source code is located in the directory ext/pdo_mysql. It does not expose an API to the PHP programmer.

For further information on the PDO MYSQL driver, see MySQL (PDO).

What is PHP's MySQL Native Driver?

In order to communicate with the MySQL database server the mysql extension, mysqli and the PDO MYSQL driver each use a low-level library that implements the required protocol. In the past, the only available library was the MySQL Client Library, otherwise known as libmysqlclient.

However, the interface presented by libmysqlclient was not optimized for communication with PHP applications, as libmysqlclient was originally designed with C applications in mind. For this reason the MySQL Native Driver, mysqlnd, was developed as an alternative to libmysqlclient for PHP applications.

The mysql extension, the mysqli extension and the PDO MySQL driver can each be individually configured to use either libmysqlclient or mysqlnd. As mysqlnd is designed specifically to be utilised in the PHP system it has numerous memory and speed enhancements over libmysqlclient. You are strongly encouraged to take advantage of these improvements.

Bilginize:

The MySQL Native Driver can only be used with MySQL server versions 4.1.3 and later.

The MySQL Native Driver is implemented using the PHP extension framework. The source code is located in ext/mysqlnd. It does not expose an API to the PHP programmer.

Comparison of Features

The following table compares the functionality of the three main methods of connecting to MySQL from PHP:

Comparison of MySQL API options for PHP
 | PHP's mysqli Extension | PDO (Using PDO MySQL Driver and MySQL Native Driver) | PHP's MySQL Extension
PHP version introduced | 5.0 | 5.0 | Prior to 3.0
Included with PHP 5.x | yes | yes | Yes
MySQL development status | Active development | Active development as of PHP 5.3 | Maintenance only
Recommended by MySQL for new projects | Yes - preferred option | Yes | No
API supports Charsets | Yes | Yes | No
API supports server-side Prepared Statements | Yes | Yes | No
API supports client-side Prepared Statements | No | Yes | No
API supports Stored Procedures | Yes | Yes | No
API supports Multiple Statements | Yes | Most | No
Supports all MySQL 4.1+ functionality | Yes | Most | No
Giriş
Quick start guide
MySQLi


Quick start guide

İçindekiler

  • Dual procedural and object-oriented interface
  • Connections
  • Executing statements
  • Prepared Statements
  • Stored Procedures
  • Multiple Statements
  • API support for transactions
  • Metadata

This quick start guide will help with choosing and gaining familiarity with the PHP MySQL API.

This quick start gives an overview on the mysqli extension. Code examples are provided for all major aspects of the API. Database concepts are explained to the degree needed for presenting concepts specific to MySQL.

Required: A familiarity with the PHP programming language, the SQL language, and basic knowledge of the MySQL server.

Overview
Dual procedural and object-oriented interface
MySQLi


Dual procedural and object-oriented interface

The mysqli extension features a dual interface. It supports the procedural and object-oriented programming paradigm.

Users migrating from the old mysql extension may prefer the procedural interface. The procedural interface is similar to that of the old mysql extension. In many cases, the function names differ only by prefix. Some mysqli functions take a connection handle as their first argument, whereas matching functions in the old mysql interface take it as an optional last argument.

Örnek 1 Easy migration from the old mysql extension

<?php
$mysqli = mysqli_connect("example.com", "user", "password", "database");
$res = mysqli_query($mysqli, "SELECT 'Please, do not use ' AS _msg FROM DUAL");
$row = mysqli_fetch_assoc($res);
echo $row['_msg'];

$mysql = mysql_connect("example.com", "user", "password");
mysql_select_db("test");
$res = mysql_query("SELECT 'the mysql extension for new developments.' AS _msg FROM DUAL", $mysql);
$row = mysql_fetch_assoc($res);
echo $row['_msg'];
?>

Yukarıdaki örneğin çıktısı:

Please, do not use the mysql extension for new developments.

The object-oriented interface

In addition to the classical procedural interface, users can choose to use the object-oriented interface. The documentation is organized using the object-oriented interface. The object-oriented interface shows functions grouped by their purpose, making it easier to get started. The reference section gives examples for both syntax variants.

There are no significant performance differences between the two interfaces. Users can base their choice on personal preference.

Örnek 2 Object-oriented and procedural interface

<?php
$mysqli = mysqli_connect("example.com", "user", "password", "database");
if (mysqli_connect_errno($mysqli)) {
    echo "Failed to connect to MySQL: " . mysqli_connect_error();
}

$res = mysqli_query($mysqli, "SELECT 'A world full of ' AS _msg FROM DUAL");
$row = mysqli_fetch_assoc($res);
echo $row['_msg'];

$mysqli = new mysqli("example.com", "user", "password", "database");
if ($mysqli->connect_errno) {
    echo "Failed to connect to MySQL: " . $mysqli->connect_error;
}

$res = $mysqli->query("SELECT 'choices to please everybody.' AS _msg FROM DUAL");
$row = $res->fetch_assoc();
echo $row['_msg'];
?>

Yukarıdaki örneğin çıktısı:

A world full of choices to please everybody.

The object oriented interface is used for the quickstart because the reference section is organized that way.

Mixing styles

It is possible to switch between styles at any time. Mixing both styles is not recommended for code clarity and coding style reasons.

Örnek 3 Bad coding style

<?php
$mysqli = new mysqli("example.com", "user", "password", "database");
if ($mysqli->connect_errno) {
    echo "Failed to connect to MySQL: " . $mysqli->connect_error;
}

$res = mysqli_query($mysqli, "SELECT 'Possible but bad style.' AS _msg FROM DUAL");
if (!$res) {
    echo "Failed to run query: (" . $mysqli->errno . ") " . $mysqli->error;
}

if ($row = $res->fetch_assoc()) {
    echo $row['_msg'];
}
?>

Yukarıdaki örneğin çıktısı:

Possible but bad style.

See also

  • mysqli::__construct()
  • mysqli::query()
  • mysqli_result::fetch_assoc()
  • $mysqli::connect_errno
  • $mysqli::connect_error
  • $mysqli::errno
  • $mysqli::error
  • The MySQLi Extension Function Summary

Quick start guide
Connections
Quick start guide


Connections

The MySQL server supports the use of different transport layers for connections. Connections use TCP/IP, Unix domain sockets or Windows named pipes.

The hostname localhost has a special meaning. It is bound to the use of Unix domain sockets. It is not possible to open a TCP/IP connection using the hostname localhost you must use 127.0.0.1 instead.

Örnek 1 Special meaning of localhost

<?php
$mysqli = new mysqli("localhost", "user", "password", "database");
if ($mysqli->connect_errno) {
    echo "Failed to connect to MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}
echo $mysqli->host_info . "\n";

$mysqli = new mysqli("127.0.0.1", "user", "password", "database", 3306);
if ($mysqli->connect_errno) {
    echo "Failed to connect to MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

echo $mysqli->host_info . "\n";
?>

Yukarıdaki örneğin çıktısı:

Localhost via UNIX socket
127.0.0.1 via TCP/IP

Connection parameter defaults

Depending on the connection function used, assorted parameters can be omitted. If a parameter is not provided, then the extension attempts to use the default values that are set in the PHP configuration file.

Örnek 2 Setting defaults

mysqli.default_host=192.168.2.27
mysqli.default_user=root
mysqli.default_pw=""
mysqli.default_port=3306
mysqli.default_socket=/tmp/mysql.sock

The resulting parameter values are then passed to the client library that is used by the extension. If the client library detects empty or unset parameters, then it may default to the library built-in values.

Built-in connection library defaults

If the host value is unset or empty, then the client library will default to a Unix socket connection on localhost. If socket is unset or empty, and a Unix socket connection is requested, then a connection to the default socket on /tmp/mysql.sock is attempted.

On Windows systems, the host name . is interpreted by the client library as an attempt to open a Windows named pipe based connection. In this case the socket parameter is interpreted as the pipe name. If not given or empty, then the socket (pipe name) defaults to \\.\pipe\MySQL.

If neither a Unix domain socket based not a Windows named pipe based connection is to be established and the port parameter value is unset, the library will default to port 3306.

The mysqlnd library and the MySQL Client Library (libmysqlclient) implement the same logic for determining defaults.

Connection options

Connection options are available to, for example, set init commands which are executed upon connect, or for requesting use of a certain charset. Connection options must be set before a network connection is established.

For setting a connection option, the connect operation has to be
performed in three steps: creating a connection handle with
mysqli_init(), setting the requested options using
mysqli_options(), and establishing the network
connection with mysqli_real_connect().

Connection pooling

The mysqli extension supports persistent database connections, which are a special kind of pooled connections. By default, every database connection opened by a script is either explicitly closed by the user during runtime or released automatically at the end of the script. A persistent connection is not. Instead it is put into a pool for later reuse, if a connection to the same server using the same username, password, socket, port and default database is opened. Reuse saves connection overhead.

Every PHP process is using its own mysqli connection pool. Depending on the web server deployment model, a PHP process may serve one or multiple requests. Therefore, a pooled connection may be used by one or more scripts subsequently.

Persistent connection

If a unused persistent connection for a given combination of host, username, password, socket, port and default database can not be found in the connection pool, then mysqli opens a new connection. The use of persistent connections can be enabled and disabled using the PHP directive mysqli.allow_persistent. The total number of connections opened by a script can be limited with mysqli.max_links. The maximum number of persistent connections per PHP process can be restricted with mysqli.max_persistent. Please note, that the web server may spawn many PHP processes.

A common complain about persistent connections is that their state is not reset before reuse. For example, open and unfinished transactions are not automatically rolled back. But also, authorization changes which happened in the time between putting the connection into the pool and reusing it are not reflected. This may be seen as an unwanted side-effect. On the contrary, the name persistent may be understood as a promise that the state is persisted.

The mysqli extension supports both interpretations of a persistent connection: state persisted, and state reset before reuse. The default is reset. Before a persistent connection is reused, the mysqli extension implicitly calls mysqli_change_user() to reset the state. The persistent connection appears to the user as if it was just opened. No artifacts from previous usages are visible.

The mysqli_change_user() function is an expensive operation. For best performance, users may want to recompile the extension with the compile flag MYSQLI_NO_CHANGE_USER_ON_PCONNECT being set.

It is left to the user to choose between safe behavior and best performance. Both are valid optimization goals. For ease of use, the safe behavior has been made the default at the expense of maximum performance.

See also

  • mysqli::__construct()
  • mysqli::init()
  • mysqli::options()
  • mysqli::real_connect()
  • mysqli::change_user()
  • $mysqli::host_info
  • MySQLi Configuration Options
  • Persistent Database Connections

Dual procedural and object-oriented interface
Executing statements
Quick start guide


Executing statements

Statements can be executed with the
mysqli_query(), mysqli_real_query()
and mysqli_multi_query() functions.
The mysqli_query() function is the most
common, and combines the executing statement with a
buffered fetch of its result set, if any, in one call.
Calling mysqli_query() is identical to
calling mysqli_real_query()
followed by mysqli_store_result().

Örnek 1 Connecting to MySQL

<?php
$mysqli = new mysqli("example.com", "user", "password", "database");
if ($mysqli->connect_errno) {
    echo "Failed to connect to MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

if (!$mysqli->query("DROP TABLE IF EXISTS test") ||
    !$mysqli->query("CREATE TABLE test(id INT)") ||
    !$mysqli->query("INSERT INTO test(id) VALUES (1)")) {
    echo "Table creation failed: (" . $mysqli->errno . ") " . $mysqli->error;
}
?>

Buffered result sets

After statement execution results can be retrieved at once to be buffered by the client or by read row by row. Client-side result set buffering allows the server to free resources associated with the statement results as early as possible. Generally speaking, clients are slow consuming result sets. Therefore, it is recommended to use buffered result sets. mysqli_query() combines statement execution and result set buffering.

PHP applications can navigate freely through buffered results. Navigation is fast because the result sets are held in client memory. Please, keep in mind that it is often easier to scale by client than it is to scale the server.

Örnek 2 Navigation through buffered results

<?php
$mysqli = new mysqli("example.com", "user", "password", "database");
if ($mysqli->connect_errno) {
    echo "Failed to connect to MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

if (!$mysqli->query("DROP TABLE IF EXISTS test") ||
    !$mysqli->query("CREATE TABLE test(id INT)") ||
    !$mysqli->query("INSERT INTO test(id) VALUES (1), (2), (3)")) {
    echo "Table creation failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

$res = $mysqli->query("SELECT id FROM test ORDER BY id ASC");

echo "Reverse order...\n";
for ($row_no = $res->num_rows - 1; $row_no >= 0; $row_no--) {
    $res->data_seek($row_no);
    $row = $res->fetch_assoc();
    echo " id = " . $row['id'] . "\n";
}

echo "Result set order...\n";
$res->data_seek(0);
while ($row = $res->fetch_assoc()) {
    echo " id = " . $row['id'] . "\n";
}
?>

Yukarıdaki örneğin çıktısı:

Reverse order...
 id = 3
 id = 2
 id = 1
Result set order...
 id = 1
 id = 2
 id = 3

Unbuffered result sets

If client memory is a short resource and freeing server resources as early as possible to keep server load low is not needed, unbuffered results can be used. Scrolling through unbuffered results is not possible before all rows have been read.

Örnek 3 Navigation through unbuffered results

<?php
$mysqli->real_query("SELECT id FROM test ORDER BY id ASC");
$res = $mysqli->use_result();

echo "Result set order...\n";
while ($row = $res->fetch_assoc()) {
    echo " id = " . $row['id'] . "\n";
}
?>

Result set values data types

The mysqli_query(), mysqli_real_query() and mysqli_multi_query() functions are used to execute non-prepared statements. At the level of the MySQL Client Server Protocol, the command COM_QUERY and the text protocol are used for statement execution. With the text protocol, the MySQL server converts all data of a result sets into strings before sending. This conversion is done regardless of the SQL result set column data type. The mysql client libraries receive all column values as strings. No further client-side casting is done to convert columns back to their native types. Instead, all values are provided as PHP strings.

Örnek 4 Text protocol returns strings by default

<?php
$mysqli = new mysqli("example.com", "user", "password", "database");
if ($mysqli->connect_errno) {
    echo "Failed to connect to MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

if (!$mysqli->query("DROP TABLE IF EXISTS test") ||
    !$mysqli->query("CREATE TABLE test(id INT, label CHAR(1))") ||
    !$mysqli->query("INSERT INTO test(id, label) VALUES (1, 'a')")) {
    echo "Table creation failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

$res = $mysqli->query("SELECT id, label FROM test WHERE id = 1");
$row = $res->fetch_assoc();

printf("id = %s (%s)\n", $row['id'], gettype($row['id']));
printf("label = %s (%s)\n", $row['label'], gettype($row['label']));
?>

Yukarıdaki örneğin çıktısı:

id = 1 (string)
label = a (string)

It is possible to convert integer and float columns back to PHP numbers by setting the MYSQLI_OPT_INT_AND_FLOAT_NATIVE connection option, if using the mysqlnd library. If set, the mysqlnd library will check the result set meta data column types and convert numeric SQL columns to PHP numbers, if the PHP data type value range allows for it. This way, for example, SQL INT columns are returned as integers.

Örnek 5 Native data types with mysqlnd and connection option

<?php
$mysqli = mysqli_init();
$mysqli->options(MYSQLI_OPT_INT_AND_FLOAT_NATIVE, 1);
$mysqli->real_connect("example.com", "user", "password", "database");

if ($mysqli->connect_errno) {
    echo "Failed to connect to MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

if (!$mysqli->query("DROP TABLE IF EXISTS test") ||
    !$mysqli->query("CREATE TABLE test(id INT, label CHAR(1))") ||
    !$mysqli->query("INSERT INTO test(id, label) VALUES (1, 'a')")) {
    echo "Table creation failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

$res = $mysqli->query("SELECT id, label FROM test WHERE id = 1");
$row = $res->fetch_assoc();

printf("id = %s (%s)\n", $row['id'], gettype($row['id']));
printf("label = %s (%s)\n", $row['label'], gettype($row['label']));
?>

Yukarıdaki örneğin çıktısı:

id = 1 (integer)
label = a (string)

See also

  • mysqli::__construct()
  • mysqli::init()
  • mysqli::options()
  • mysqli::real_connect()
  • mysqli::query()
  • mysqli::multi_query()
  • mysqli::use_result()
  • mysqli::store_result()
  • mysqli_result::free()

Connections
Prepared Statements
Quick start guide


Prepared Statements

The MySQL database supports prepared statements. A prepared statement or a parameterized statement is used to execute the same statement repeatedly with high efficiency.

Basic workflow

The prepared statement execution consists of two stages: prepare and execute. At the prepare stage a statement template is sent to the database server. The server performs a syntax check and initializes server internal resources for later use.

The MySQL server supports using anonymous, positional placeholder with ?.

Örnek 1 First stage: prepare

<?php
$mysqli = new mysqli("example.com", "user", "password", "database");
if ($mysqli->connect_errno) {
    echo "Failed to connect to MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

/* Non-prepared statement */
if (!$mysqli->query("DROP TABLE IF EXISTS test") || !$mysqli->query("CREATE TABLE test(id INT)")) {
    echo "Table creation failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

/* Prepared statement, stage 1: prepare */
if (!($stmt = $mysqli->prepare("INSERT INTO test(id) VALUES (?)"))) {
    echo "Prepare failed: (" . $mysqli->errno . ") " . $mysqli->error;
}
?>

Prepare is followed by execute. During execute the client binds parameter values and sends them to the server. The server creates a statement from the statement template and the bound values to execute it using the previously created internal resources.

Örnek 2 Second stage: bind and execute

<?php
/* Prepared statement, stage 2: bind and execute */
$id = 1;
if (!$stmt->bind_param("i", $id)) {
    echo "Binding parameters failed: (" . $stmt->errno . ") " . $stmt->error;
}

if (!$stmt->execute()) {
    echo "Execute failed: (" . $stmt->errno . ") " . $stmt->error;
}
?>

Repeated execution

A prepared statement can be executed repeatedly. Upon every execution the current value of the bound variable is evaluated and sent to the server. The statement is not parsed again. The statement template is not transferred to the server again.

Örnek 3 INSERT prepared once, executed multiple times

<?php
$mysqli = new mysqli("example.com", "user", "password", "database");
if ($mysqli->connect_errno) {
    echo "Failed to connect to MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

/* Non-prepared statement */
if (!$mysqli->query("DROP TABLE IF EXISTS test") || !$mysqli->query("CREATE TABLE test(id INT)")) {
    echo "Table creation failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

/* Prepared statement, stage 1: prepare */
if (!($stmt = $mysqli->prepare("INSERT INTO test(id) VALUES (?)"))) {
     echo "Prepare failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

/* Prepared statement, stage 2: bind and execute */
$id = 1;
if (!$stmt->bind_param("i", $id)) {
    echo "Binding parameters failed: (" . $stmt->errno . ") " . $stmt->error;
}

if (!$stmt->execute()) {
    echo "Execute failed: (" . $stmt->errno . ") " . $stmt->error;
}

/* Prepared statement: repeated execution, only data transferred from client to server */
for ($id = 2; $id < 5; $id++) {
    if (!$stmt->execute()) {
        echo "Execute failed: (" . $stmt->errno . ") " . $stmt->error;
    }
}

/* explicit close recommended */
$stmt->close();

/* Non-prepared statement */
$res = $mysqli->query("SELECT id FROM test");
var_dump($res->fetch_all());
?>

Yukarıdaki örneğin çıktısı:

array(4) {
  [0]=>
  array(1) {
    [0]=>
    string(1) "1"
  }
  [1]=>
  array(1) {
    [0]=>
    string(1) "2"
  }
  [2]=>
  array(1) {
    [0]=>
    string(1) "3"
  }
  [3]=>
  array(1) {
    [0]=>
    string(1) "4"
  }
}

Every prepared statement occupies server resources. Statements should be closed explicitly immediately after use. If not done explicitly, the statement will be closed when the statement handle is freed by PHP.

Using a prepared statement is not always the most efficient way of executing a statement. A prepared statement executed only once causes more client-server round-trips than a non-prepared statement. This is why the SELECT is not run as a prepared statement above.

Also, consider the use of the MySQL multi-INSERT SQL syntax for INSERTs. For the example, multi-INSERT requires less round-trips between the server and client than the prepared statement shown above.

Örnek 4 Less round trips using multi-INSERT SQL

<?php
if (!$mysqli->query("INSERT INTO test(id) VALUES (1), (2), (3), (4)")) {
    echo "Multi-INSERT failed: (" . $mysqli->errno . ") " . $mysqli->error;
}
?>

Result set values data types

The MySQL Client Server Protocol defines a different data transfer protocol for prepared statements and non-prepared statements. Prepared statements are using the so called binary protocol. The MySQL server sends result set data "as is" in binary format. Results are not serialized into strings before sending. The client libraries do not receive strings only. Instead, they will receive binary data and try to convert the values into appropriate PHP data types. For example, results from an SQL INT column will be provided as PHP integer variables.

Örnek 5 Native datatypes

<?php
$mysqli = new mysqli("example.com", "user", "password", "database");
if ($mysqli->connect_errno) {
    echo "Failed to connect to MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

if (!$mysqli->query("DROP TABLE IF EXISTS test") ||
    !$mysqli->query("CREATE TABLE test(id INT, label CHAR(1))") ||
    !$mysqli->query("INSERT INTO test(id, label) VALUES (1, 'a')")) {
    echo "Table creation failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

$stmt = $mysqli->prepare("SELECT id, label FROM test WHERE id = 1");
$stmt->execute();
$res = $stmt->get_result();
$row = $res->fetch_assoc();

printf("id = %s (%s)\n", $row['id'], gettype($row['id']));
printf("label = %s (%s)\n", $row['label'], gettype($row['label']));
?>

Yukarıdaki örneğin çıktısı:

id = 1 (integer)
label = a (string)

This behavior differs from non-prepared statements. By default, non-prepared statements return all results as strings. This default can be changed using a connection option. If the connection option is used, there are no differences.

Fetching results using bound variables

Results from prepared statements can either be retrieved by binding output variables, or by requesting a mysqli_result object.

Output variables must be bound after statement execution. One variable must be bound for every column of the statements result set.

Örnek 6 Output variable binding

<?php
$mysqli = new mysqli("example.com", "user", "password", "database");
if ($mysqli->connect_errno) {
    echo "Failed to connect to MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

if (!$mysqli->query("DROP TABLE IF EXISTS test") ||
    !$mysqli->query("CREATE TABLE test(id INT, label CHAR(1))") ||
    !$mysqli->query("INSERT INTO test(id, label) VALUES (1, 'a')")) {
    echo "Table creation failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!($stmt = $mysqli->prepare("SELECT id, label FROM test"))) {
    echo "Prepare failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!$stmt->execute()) {
    echo "Execute failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

$out_id    = NULL;
$out_label = NULL;
if (!$stmt->bind_result($out_id, $out_label)) {
    echo "Binding output parameters failed: (" . $stmt->errno . ") " . $stmt->error;
}

while ($stmt->fetch()) {
    printf("id = %s (%s), label = %s (%s)\n", $out_id, gettype($out_id), $out_label, gettype($out_label));
}
?>

Yukarıdaki örneğin çıktısı:

id = 1 (integer), label = a (string)

Prepared statements return unbuffered result sets by default. The results of the statement are not implicitly fetched and transferred from the server to the client for client-side buffering. The result set takes server resources until all results have been fetched by the client. Thus it is recommended to consume results timely. If a client fails to fetch all results or the client closes the statement before having fetched all data, the data has to be fetched implicitly by mysqli.

It is also possible to buffer the results of a prepared statement using mysqli_stmt_store_result().

Fetching results using mysqli_result interface

Instead of using bound results, results can also be retrieved through the mysqli_result interface. mysqli_stmt_get_result() returns a buffered result set.

Örnek 7 Using mysqli_result to fetch results

<?php
$mysqli = new mysqli("example.com", "user", "password", "database");
if ($mysqli->connect_errno) {
    echo "Failed to connect to MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

if (!$mysqli->query("DROP TABLE IF EXISTS test") ||
    !$mysqli->query("CREATE TABLE test(id INT, label CHAR(1))") ||
    !$mysqli->query("INSERT INTO test(id, label) VALUES (1, 'a')")) {
    echo "Table creation failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!($stmt = $mysqli->prepare("SELECT id, label FROM test ORDER BY id ASC"))) {
    echo "Prepare failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!$stmt->execute()) {
     echo "Execute failed: (" . $stmt->errno . ") " . $stmt->error;
}

if (!($res = $stmt->get_result())) {
    echo "Getting result set failed: (" . $stmt->errno . ") " . $stmt->error;
}

var_dump($res->fetch_all());
?>

Yukarıdaki örneğin çıktısı:

array(1) {
  [0]=>
  array(2) {
    [0]=>
    int(1)
    [1]=>
    string(1) "a"
  }
}

Using the mysqli_result interface offers the additional benefit of flexible client-side result set navigation.

Örnek 8 Buffered result set for flexible read out

<?php
$mysqli = new mysqli("example.com", "user", "password", "database");
if ($mysqli->connect_errno) {
    echo "Failed to connect to MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

if (!$mysqli->query("DROP TABLE IF EXISTS test") ||
    !$mysqli->query("CREATE TABLE test(id INT, label CHAR(1))") ||
    !$mysqli->query("INSERT INTO test(id, label) VALUES (1, 'a'), (2, 'b'), (3, 'c')")) {
    echo "Table creation failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!($stmt = $mysqli->prepare("SELECT id, label FROM test"))) {
    echo "Prepare failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!$stmt->execute()) {
     echo "Execute failed: (" . $stmt->errno . ") " . $stmt->error;
}

if (!($res = $stmt->get_result())) {
    echo "Getting result set failed: (" . $stmt->errno . ") " . $stmt->error;
}

for ($row_no = ($res->num_rows - 1); $row_no >= 0; $row_no--) {
    $res->data_seek($row_no);
    var_dump($res->fetch_assoc());
}
$res->close();
?>

Yukarıdaki örneğin çıktısı:

array(2) {
  ["id"]=>
  int(3)
  ["label"]=>
  string(1) "c"
}
array(2) {
  ["id"]=>
  int(2)
  ["label"]=>
  string(1) "b"
}
array(2) {
  ["id"]=>
  int(1)
  ["label"]=>
  string(1) "a"
}

Escaping and SQL injection

Bound variables are sent to the server separately from the query and thus cannot interfere with it. The server uses these values directly at the point of execution, after the statement template is parsed. Bound parameters do not need to be escaped as they are never substituted into the query string directly. A hint must be provided to the server for the type of bound variable, to create an appropriate conversion. See the mysqli_stmt_bind_param() function for more information.

Such a separation sometimes considered as the only security feature to prevent SQL injection, but the same degree of security can be achieved with non-prepared statements, if all the values are formatted correctly. It should be noted that correct formatting is not the same as escaping and involves more logic than simple escaping. Thus, prepared statements are simply a more convenient and less error-prone approach to this element of database security.

Client-side prepared statement emulation

The API does not include emulation for client-side prepared statement emulation.

Quick prepared - non-prepared statement comparison

The table below compares server-side prepared and non-prepared statements.

Comparison of prepared and non-prepared statements
 | Prepared Statement | Non-prepared statement
Client-server round trips, SELECT, single execution | 2 | 1
Statement string transferred from client to server | 1 | 1
Client-server round trips, SELECT, repeated (n) execution | 1 + n | n
Statement string transferred from client to server | 1 template, n times bound parameter, if any | n times together with parameter, if any
Input parameter binding API | Yes, automatic input escaping | No, manual input escaping
Output variable binding API | Yes | No
Supports use of mysqli_result API | Yes, use mysqli_stmt_get_result() | Yes
Buffered result sets | Yes, use mysqli_stmt_get_result() or binding with mysqli_stmt_store_result() | Yes, default of mysqli_query()
Unbuffered result sets | Yes, use output binding API | Yes, use mysqli_real_query() with mysqli_use_result()
MySQL Client Server protocol data transfer flavor | Binary protocol | Text protocol
Result set values SQL data types | Preserved when fetching | Converted to string or preserved when fetching
Supports all SQL statements | Recent MySQL versions support most but not all | Yes

See also

  • mysqli::__construct()
  • mysqli::query()
  • mysqli::prepare()
  • mysqli_stmt::prepare()
  • mysqli_stmt::execute()
  • mysqli_stmt::bind_param()
  • mysqli_stmt::bind_result()

Executing statements
Stored Procedures
Quick start guide


Stored Procedures

The MySQL database supports stored procedures. A stored procedure is a subroutine stored in the database catalog. Applications can call and execute the stored procedure. The CALL SQL statement is used to execute a stored procedure.

Parameter

Stored procedures can have IN, INOUT and OUT parameters, depending on the MySQL version. The mysqli interface has no special notion for the different kinds of parameters.

IN parameter

Input parameters are provided with the CALL statement. Please, make sure values are escaped correctly.

Örnek 1 Calling a stored procedure

<?php
$mysqli = new mysqli("example.com", "user", "password", "database");
if ($mysqli->connect_errno) {
    echo "Failed to connect to MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

if (!$mysqli->query("DROP TABLE IF EXISTS test") || !$mysqli->query("CREATE TABLE test(id INT)")) {
    echo "Table creation failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!$mysqli->query("DROP PROCEDURE IF EXISTS p") ||
    !$mysqli->query("CREATE PROCEDURE p(IN id_val INT) BEGIN INSERT INTO test(id) VALUES(id_val); END;")) {
    echo "Stored procedure creation failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!$mysqli->query("CALL p(1)")) {
    echo "CALL failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!($res = $mysqli->query("SELECT id FROM test"))) {
    echo "SELECT failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

var_dump($res->fetch_assoc());
?>

Yukarıdaki örneğin çıktısı:

array(1) {
  ["id"]=>
  string(1) "1"
}

INOUT/OUT parameter

The values of INOUT/OUT parameters are accessed using session variables.

Örnek 2 Using session variables

<?php
$mysqli = new mysqli("example.com", "user", "password", "database");
if ($mysqli->connect_errno) {
    echo "Failed to connect to MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

if (!$mysqli->query("DROP PROCEDURE IF EXISTS p") ||
    !$mysqli->query('CREATE PROCEDURE p(OUT msg VARCHAR(50)) BEGIN SELECT "Hi!" INTO msg; END;')) {
    echo "Stored procedure creation failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!$mysqli->query("SET @msg = ''") || !$mysqli->query("CALL p(@msg)")) {
    echo "CALL failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!($res = $mysqli->query("SELECT @msg as _p_out"))) {
    echo "Fetch failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

$row = $res->fetch_assoc();
echo $row['_p_out'];
?>

Yukarıdaki örneğin çıktısı:

Hi!

Application and framework developers may be able to provide a more convenient API using a mix of session variables and databased catalog inspection. However, please note the possible performance impact of a custom solution based on catalog inspection.

Handling result sets

Stored procedures can return result sets. Result sets returned from a stored procedure cannot be fetched correctly using mysqli_query(). The mysqli_query() function combines statement execution and fetching the first result set into a buffered result set, if any. However, there are additional stored procedure result sets hidden from the user which cause mysqli_query() to fail returning the user expected result sets.

Result sets returned from a stored procedure are fetched using mysqli_real_query() or mysqli_multi_query(). Both functions allow fetching any number of result sets returned by a statement, such as CALL. Failing to fetch all result sets returned by a stored procedure causes an error.

Örnek 3 Fetching results from stored procedures

<?php
$mysqli = new mysqli("example.com", "user", "password", "database");
if ($mysqli->connect_errno) {
    echo "Failed to connect to MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

if (!$mysqli->query("DROP TABLE IF EXISTS test") ||
    !$mysqli->query("CREATE TABLE test(id INT)") ||
    !$mysqli->query("INSERT INTO test(id) VALUES (1), (2), (3)")) {
    echo "Table creation failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!$mysqli->query("DROP PROCEDURE IF EXISTS p") ||
    !$mysqli->query('CREATE PROCEDURE p() READS SQL DATA BEGIN SELECT id FROM test; SELECT id + 1 FROM test; END;')) {
    echo "Stored procedure creation failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!$mysqli->multi_query("CALL p()")) {
    echo "CALL failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

do {
    if ($res = $mysqli->store_result()) {
        printf("---\n");
        var_dump($res->fetch_all());
        $res->free();
    } else {
        if ($mysqli->errno) {
            echo "Store failed: (" . $mysqli->errno . ") " . $mysqli->error;
        }
    }
} while ($mysqli->more_results() && $mysqli->next_result());
?>

Yukarıdaki örneğin çıktısı:

---
array(3) {
  [0]=>
  array(1) {
    [0]=>
    string(1) "1"
  }
  [1]=>
  array(1) {
    [0]=>
    string(1) "2"
  }
  [2]=>
  array(1) {
    [0]=>
    string(1) "3"
  }
}
---
array(3) {
  [0]=>
  array(1) {
    [0]=>
    string(1) "2"
  }
  [1]=>
  array(1) {
    [0]=>
    string(1) "3"
  }
  [2]=>
  array(1) {
    [0]=>
    string(1) "4"
  }
}

Use of prepared statements

No special handling is required when using the prepared statement interface for fetching results from the same stored procedure as above. The prepared statement and non-prepared statement interfaces are similar. Please note, that not every MYSQL server version may support preparing the CALL SQL statement.

Örnek 4 Stored Procedures and Prepared Statements

<?php
$mysqli = new mysqli("example.com", "user", "password", "database");
if ($mysqli->connect_errno) {
    echo "Failed to connect to MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

if (!$mysqli->query("DROP TABLE IF EXISTS test") ||
    !$mysqli->query("CREATE TABLE test(id INT)") ||
    !$mysqli->query("INSERT INTO test(id) VALUES (1), (2), (3)")) {
    echo "Table creation failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!$mysqli->query("DROP PROCEDURE IF EXISTS p") ||
    !$mysqli->query('CREATE PROCEDURE p() READS SQL DATA BEGIN SELECT id FROM test; SELECT id + 1 FROM test; END;')) {
    echo "Stored procedure creation failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!($stmt = $mysqli->prepare("CALL p()"))) {
    echo "Prepare failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!$stmt->execute()) {
    echo "Execute failed: (" . $stmt->errno . ") " . $stmt->error;
}

do {
    if ($res = $stmt->get_result()) {
        printf("---\n");
        var_dump(mysqli_fetch_all($res));
        mysqli_free_result($res);
    } else {
        if ($stmt->errno) {
            echo "Store failed: (" . $stmt->errno . ") " . $stmt->error;
        }
    }
} while ($stmt->more_results() && $stmt->next_result());
?>

Of course, use of the bind API for fetching is supported as well.

Örnek 5 Stored Procedures and Prepared Statements using bind API

<?php
if (!($stmt = $mysqli->prepare("CALL p()"))) {
    echo "Prepare failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

if (!$stmt->execute()) {
    echo "Execute failed: (" . $stmt->errno . ") " . $stmt->error;
}

do {

    $id_out = NULL;
    if (!$stmt->bind_result($id_out)) {
        echo "Bind failed: (" . $stmt->errno . ") " . $stmt->error;
    }

    while ($stmt->fetch()) {
        echo "id = $id_out\n";
    }
} while ($stmt->more_results() && $stmt->next_result());
?>

See also

  • mysqli::query()
  • mysqli::multi_query()
  • mysqli_result::next-result()
  • mysqli_result::more-results()

Prepared Statements
Multiple Statements
Quick start guide


Multiple Statements

MySQL optionally allows having multiple statements in one statement string. Sending multiple statements at once reduces client-server round trips but requires special handling.

Multiple statements or multi queries must be executed with mysqli_multi_query(). The individual statements of the statement string are separated by semicolon. Then, all result sets returned by the executed statements must be fetched.

The MySQL server allows having statements that do return result sets and statements that do not return result sets in one multiple statement.

Örnek 1 Multiple Statements

<?php
$mysqli = new mysqli("example.com", "user", "password", "database");
if ($mysqli->connect_errno) {
    echo "Failed to connect to MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

if (!$mysqli->query("DROP TABLE IF EXISTS test") || !$mysqli->query("CREATE TABLE test(id INT)")) {
    echo "Table creation failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

$sql = "SELECT COUNT(*) AS _num FROM test; ";
$sql.= "INSERT INTO test(id) VALUES (1); ";
$sql.= "SELECT COUNT(*) AS _num FROM test; ";

if (!$mysqli->multi_query($sql)) {
    echo "Multi query failed: (" . $mysqli->errno . ") " . $mysqli->error;
}

do {
    if ($res = $mysqli->store_result()) {
        var_dump($res->fetch_all(MYSQLI_ASSOC));
        $res->free();
    }
} while ($mysqli->more_results() && $mysqli->next_result());
?>

Yukarıdaki örneğin çıktısı:

array(1) {
  [0]=>
  array(1) {
    ["_num"]=>
    string(1) "0"
  }
}
array(1) {
  [0]=>
  array(1) {
    ["_num"]=>
    string(1) "1"
  }
}

Security considerations

The API functions mysqli_query() and mysqli_real_query() do not set a connection flag necessary for activating multi queries in the server. An extra API call is used for multiple statements to reduce the likeliness of accidental SQL injection attacks. An attacker may try to add statements such as ; DROP DATABASE mysql or ; SELECT SLEEP(999). If the attacker succeeds in adding SQL to the statement string but mysqli_multi_query is not used, the server will not execute the second, injected and malicious SQL statement.

Örnek 2 SQL Injection

<?php
$mysqli = new mysqli("example.com", "user", "password", "database");
$res    = $mysqli->query("SELECT 1; DROP TABLE mysql.user");
if (!$res) {
    echo "Error executing query: (" . $mysqli->errno . ") " . $mysqli->error;
}
?>

Yukarıdaki örneğin çıktısı:

Error executing query: (1064) You have an error in your SQL syntax;
check the manual that corresponds to your MySQL server version for the right syntax
to use near 'DROP TABLE mysql.user' at line 1

Prepared statements

Use of the multiple statement with prepared statements is not supported.

See also

  • mysqli::query()
  • mysqli::multi_query()
  • mysqli_result::next-result()
  • mysqli_result::more-results()

Stored Procedures
API support for transactions
Quick start guide


API support for transactions

The MySQL server supports transactions depending on the storage engine used. Since MySQL 5.5, the default storage engine is InnoDB. InnoDB has full ACID transaction support.

Transactions can either be controlled using SQL or API calls. It is recommended to use API calls for enabling and disabling the auto commit mode and for committing and rolling back transactions.

Örnek 1 Setting auto commit mode with SQL and through the API

<?php
$mysqli = new mysqli("example.com", "user", "password", "database");
if ($mysqli->connect_errno) {
    echo "Failed to connect to MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

/* Recommended: using API to control transactional settings */
$mysqli->autocommit(false);

/* Won't be monitored and recognized by the replication and the load balancing plugin */
if (!$mysqli->query('SET AUTOCOMMIT = 0')) {
    echo "Query failed: (" . $mysqli->errno . ") " . $mysqli->error;
}
?>

Optional feature packages, such as the replication and load balancing plugin, can easily monitor API calls. The replication plugin offers transaction aware load balancing, if transactions are controlled with API calls. Transaction aware load balancing is not available if SQL statements are used for setting auto commit mode, committing or rolling back a transaction.

Örnek 2 Commit and rollback

<?php
$mysqli = new mysqli("example.com", "user", "password", "database");
$mysqli->autocommit(false);

$mysqli->query("INSERT INTO test(id) VALUES (1)");
$mysqli->rollback();

$mysqli->query("INSERT INTO test(id) VALUES (2)");
$mysqli->commit();
?>

Please note, that the MySQL server cannot roll back all statements. Some statements cause an implicit commit.

See also

  • mysqli::autocommit()
  • mysqli_result::commit()
  • mysqli_result::rollback()

Multiple Statements
Metadata
Quick start guide


Metadata

A MySQL result set contains metadata. The metadata describes the columns found in the result set. All metadata sent by MySQL is accessible through the mysqli interface. The extension performs no or negligible changes to the information it receives. Differences between MySQL server versions are not aligned.

Meta data is access through the mysqli_result interface.

Örnek 1 Accessing result set meta data

<?php
$mysqli = new mysqli("example.com", "user", "password", "database");
if ($mysqli->connect_errno) {
    echo "Failed to connect to MySQL: (" . $mysqli->connect_errno . ") " . $mysqli->connect_error;
}

$res = $mysqli->query("SELECT 1 AS _one, 'Hello' AS _two FROM DUAL");
var_dump($res->fetch_fields());
?>

Yukarıdaki örneğin çıktısı:

array(2) {
  [0]=>
  object(stdClass)#3 (13) {
    ["name"]=>
    string(4) "_one"
    ["orgname"]=>
    string(0) ""
    ["table"]=>
    string(0) ""
    ["orgtable"]=>
    string(0) ""
    ["def"]=>
    string(0) ""
    ["db"]=>
    string(0) ""
    ["catalog"]=>
    string(3) "def"
    ["max_length"]=>
    int(1)
    ["length"]=>
    int(1)
    ["charsetnr"]=>
    int(63)
    ["flags"]=>
    int(32897)
    ["type"]=>
    int(8)
    ["decimals"]=>
    int(0)
  }
  [1]=>
  object(stdClass)#4 (13) {
    ["name"]=>
    string(4) "_two"
    ["orgname"]=>
    string(0) ""
    ["table"]=>
    string(0) ""
    ["orgtable"]=>
    string(0) ""
    ["def"]=>
    string(0) ""
    ["db"]=>
    string(0) ""
    ["catalog"]=>
    string(3) "def"
    ["max_length"]=>
    int(5)
    ["length"]=>
    int(5)
    ["charsetnr"]=>
    int(8)
    ["flags"]=>
    int(1)
    ["type"]=>
    int(253)
    ["decimals"]=>
    int(31)
  }
}

Prepared statements

Meta data of result sets created using prepared statements are accessed the same way. A suitable mysqli_result handle is returned by mysqli_stmt_result_metadata().

Örnek 2 Prepared statements metadata

<?php
$stmt = $mysqli->prepare("SELECT 1 AS _one, 'Hello' AS _two FROM DUAL");
$stmt->execute();
$res = $stmt->result_metadata();
var_dump($res->fetch_fields());
?>

See also

  • mysqli::query()
  • mysqli_result::fetch_fields()

API support for transactions
Yapılandırma/Kurulum
Quick start guide


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Metadata
Gereksinimler
MySQLi


Gereksinimler

In order to have these functions available, you must compile PHP with support for the mysqli extension.

Bilginize:

The mysqli extension is designed to work with MySQL version 4.1.13 or newer, or 5.0.7 or newer. For previous versions, please see the MySQL extension documentation.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

The mysqli extension was introduced with PHP version 5.0.0. The MySQL Native Driver was included in PHP version 5.3.0.

Installation on Linux

The common Unix distributions include binary versions of PHP that can be installed. Although these binary versions are typically built with support for the MySQL extensions, the extension libraries themselves may need to be installed using an additional package. Check the package manager that comes with your chosen distribution for availability.

For example, on Ubuntu the php5-mysql package installs the ext/mysql, ext/mysqli, and pdo_mysql PHP extensions. On CentOS, the php-mysql package also installs these three PHP extensions.

Alternatively, you can compile this extension yourself. Building PHP from source allows you to specify the MySQL extensions you want to use, as well as your choice of client library for each extension.

The MySQL Native Driver is the recommended client library option, as it results in improved performance and gives access to features not available when using the MySQL Client Library. Refer to What is PHP's MySQL Native Driver? for a brief overview of the advantages of MySQL Native Driver.

The /path/to/mysql_config represents the location of the mysql_config program that comes with MySQL Server.

mysqli compile time support matrix
PHP Sürüm: | Öntanımlı | Yapılandırma Seçenekleri: mysqlnd | Yapılandırma Seçenekleri: libmysqlclient | Sürüm Bilgisi
5.4.x and above | mysqlnd | --with-mysqli | --with-mysqli=/path/to/mysql_config | mysqlnd is the default
5.3.x | libmysqlclient | --with-mysqli=mysqlnd | --with-mysqli=/path/to/mysql_config | mysqlnd is supported
5.0.x, 5.1.x, 5.2.x | libmysqlclient | Kullanılabilir değil | --with-mysqli=/path/to/mysql_config | mysqlnd is not supported

Note that it is possible to freely mix MySQL extensions and client libraries. For example, it is possible to enable the MySQL extension to use the MySQL Client Library (libmysqlclient), while configuring the mysqli extension to use the MySQL Native Driver. However, all permutations of extension and client library are possible.

Installation on Windows Systems

On Windows, PHP is most commonly installed using the binary installer.

PHP 5.3.0 and newer

On Windows, for PHP versions 5.3 and newer, the mysqli extension is enabled and uses the MySQL Native Driver by default. This means you don't need to worry about configuring access to libmysql.dll.

PHP 5.0, 5.1, 5.2

On these old unsupported PHP versions (PHP 5.2 reached EOL on '6 Jan 2011'), additional configuration procedures are required to enable mysqli and specify the client library you want it to use.

The mysqli extension is not enabled by default, so the php_mysqli.dll DLL must be enabled inside of php.ini. In order to do this you need to find the php.ini file (typically located in c:\php), and make sure you remove the comment (semi-colon) from the start of the line extension=php_mysqli.dll, in the section marked [PHP_MYSQLI].

Also, if you want to use the MySQL Client Library with mysqli, you need to make sure PHP can access the client library file. The MySQL Client Library is included as a file named libmysql.dll in the Windows PHP distribution. This file needs to be available in the Windows system's PATH environment variable, so that it can be successfully loaded. See the FAQ titled "How do I add my PHP directory to the PATH on Windows" for information on how to do this. Copying libmysql.dll to the Windows system directory (typically c:\Windows\system) also works, as the system directory is by default in the system's PATH. However, this practice is strongly discouraged.

As with enabling any PHP extension (such as php_mysqli.dll), the PHP directive extension_dir should be set to the directory where the PHP extensions are located. See also the Manual Windows Installation Instructions. An example extension_dir value for PHP 5 is c:\php\ext.

Bilginize:

If when starting the web server an error similar to the following occurs: "Unable to load dynamic library './php_mysqli.dll'", this is because php_mysqli.dll and/or libmysql.dll cannot be found by the system.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

MySQLi Configuration Options
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
mysqli.allow_local_infile | "1" | PHP_INI_SYSTEM | Available since PHP 5.2.4.
mysqli.allow_persistent | "1" | PHP_INI_SYSTEM | Available since PHP 5.3.0.
mysqli.max_persistent | "-1" | PHP_INI_SYSTEM | Available since PHP 5.3.0.
mysqli.max_links | "-1" | PHP_INI_SYSTEM | Available since PHP 5.0.0.
mysqli.default_port | "3306" | PHP_INI_ALL | Available since PHP 5.0.0.
mysqli.default_socket | NULL | PHP_INI_ALL | Available since PHP 5.0.0.
mysqli.default_host | NULL | PHP_INI_ALL | Available since PHP 5.0.0.
mysqli.default_user | NULL | PHP_INI_ALL | Available since PHP 5.0.0.
mysqli.default_pw | NULL | PHP_INI_ALL | Available since PHP 5.0.0.
mysqli.reconnect | "0" | PHP_INI_SYSTEM | Available since PHP 4.3.5.
mysqli.rollback_on_cached_plink | TRUE | PHP_INI_SYSTEM | Available since PHP 5.6.0.
mysqli.cache_size | "2000" | PHP_INI_SYSTEM | Available since PHP 5.3.0.

For further details and definitions of the preceding PHP_INI_* constants, see the chapter on configuration changes.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

mysqli.allow_local_infile integer

Allow accessing, from PHP's perspective, local files with LOAD DATA statements

mysqli.allow_persistent integer

Enable the ability to create persistent connections using mysqli_connect().

mysqli.max_persistent integer

Maximum of persistent connections that can be made. Set to 0 for unlimited.

mysqli.max_links integer

The maximum number of MySQL connections per process.

mysqli.default_port integer

The default TCP port number to use when connecting to the database server if no other port is specified. If no default is specified, the port will be obtained from the MYSQL_TCP_PORT environment variable, the mysql-tcp entry in /etc/services or the compile-time MYSQL_PORT constant, in that order. Win32 will only use the MYSQL_PORT constant.

mysqli.default_socket string

The default socket name to use when connecting to a local database server if no other socket name is specified.

mysqli.default_host string

The default server host to use when connecting to the database server if no other host is specified. Doesn't apply in safe mode.

mysqli.default_user string

The default user name to use when connecting to the database server if no other name is specified. Doesn't apply in safe mode.

mysqli.default_pw string

The default password to use when connecting to the database server if no other password is specified. Doesn't apply in safe mode.

mysqli.reconnect integer

Automatically reconnect if the connection was lost.

Bilginize: This php.ini setting is ignored by the mysqlnd driver.

mysqli.rollback_on_cached_plink bool

Used for rollbacking connections put back into the persistent connection pool.

mysqli.cache_size integer

Sadece mysqlnd ile kullanılabilir.

Users cannot set MYSQL_OPT_READ_TIMEOUT through an API call or runtime configuration setting. Note that if it were possible there would be differences between how libmysqlclient and streams would interpret the value of MYSQL_OPT_READ_TIMEOUT.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Özkaynak Türleri

Bu eklentinin tanımlı hiçbir özkaynak türü yoktur.

Çalışma Anı Yapılandırması
The mysqli Extension and Persistent Connections
Yapılandırma/Kurulum


The mysqli Extension and Persistent Connections

Persistent connection support was introduced in PHP 5.3 for the mysqli extension. Support was already present in PDO MYSQL and ext/mysql. The idea behind persistent connections is that a connection between a client process and a database can be reused by a client process, rather than being created and destroyed multiple times. This reduces the overhead of creating fresh connections every time one is required, as unused connections are cached and ready to be reused.

Unlike the mysql extension, mysqli does not provide a separate function for opening persistent connections. To open a persistent connection you must prepend p: to the hostname when connecting.

The problem with persistent connections is that they can be left in unpredictable states by clients. For example, a table lock might be activated before a client terminates unexpectedly. A new client process reusing this persistent connection will get the connection "as is". Any cleanup would need to be done by the new client process before it could make good use of the persistent connection, increasing the burden on the programmer.

The persistent connection of the mysqli extension however provides built-in cleanup handling code. The cleanup carried out by mysqli includes:

  • Rollback active transactions

  • Close and drop temporary tables

  • Unlock tables

  • Reset session variables

  • Close prepared statements (always happens with PHP)

  • Close handler

  • Release locks acquired with GET_LOCK()

This ensures that persistent connections are in a clean state on return from the connection pool, before the client process uses them.

The mysqli extension does this cleanup by automatically calling the C-API function mysql_change_user().

The automatic cleanup feature has advantages and disadvantages though. The advantage is that the programmer no longer needs to worry about adding cleanup code, as it is called automatically. However, the disadvantage is that the code could potentially be a little slower, as the code to perform the cleanup needs to run each time a connection is returned from the connection pool.

It is possible to switch off the automatic cleanup code, by compiling PHP with MYSQLI_NO_CHANGE_USER_ON_PCONNECT defined.

Bilginize:

The mysqli extension supports persistent connections when using either MySQL Native Driver or MySQL Client Library.

Özkaynak Türleri
Öntanımlı Sabitler
MySQLi


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

MYSQLI_READ_DEFAULT_GROUP

Read options from the named group from my.cnf or the file specified with MYSQLI_READ_DEFAULT_FILE

MYSQLI_READ_DEFAULT_FILE

Read options from the named option file instead of from my.cnf

MYSQLI_OPT_CONNECT_TIMEOUT

Connect timeout in seconds

MYSQLI_OPT_LOCAL_INFILE

Enables command LOAD LOCAL INFILE

MYSQLI_INIT_COMMAND

Command to execute when connecting to MySQL server. Will automatically be re-executed when reconnecting.

MYSQLI_CLIENT_SSL

Use SSL (encrypted protocol). This option should not be set by application programs; it is set internally in the MySQL client library

MYSQLI_CLIENT_COMPRESS

Use compression protocol

MYSQLI_CLIENT_INTERACTIVE

Allow interactive_timeout seconds (instead of wait_timeout seconds) of inactivity before closing the connection. The client's session wait_timeout variable will be set to the value of the session interactive_timeout variable.

MYSQLI_CLIENT_IGNORE_SPACE

Allow spaces after function names. Makes all functions names reserved words.

MYSQLI_CLIENT_NO_SCHEMA

Don't allow the db_name.tbl_name.col_name syntax.

MYSQLI_CLIENT_MULTI_QUERIES

Allows multiple semicolon-delimited queries in a single mysqli_query() call.

MYSQLI_STORE_RESULT

For using buffered resultsets

MYSQLI_USE_RESULT

For using unbuffered resultsets

MYSQLI_ASSOC

Columns are returned into the array having the fieldname as the array index.

MYSQLI_NUM

Columns are returned into the array having an enumerated index.

MYSQLI_BOTH

Columns are returned into the array having both a numerical index and the fieldname as the associative index.

MYSQLI_NOT_NULL_FLAG

Indicates that a field is defined as NOT NULL

MYSQLI_PRI_KEY_FLAG

Field is part of a primary index

MYSQLI_UNIQUE_KEY_FLAG

Field is part of a unique index.

MYSQLI_MULTIPLE_KEY_FLAG

Field is part of an index.

MYSQLI_BLOB_FLAG

Field is defined as BLOB

MYSQLI_UNSIGNED_FLAG

Field is defined as UNSIGNED

MYSQLI_ZEROFILL_FLAG

Field is defined as ZEROFILL

MYSQLI_AUTO_INCREMENT_FLAG

Field is defined as AUTO_INCREMENT

MYSQLI_TIMESTAMP_FLAG

Field is defined as TIMESTAMP

MYSQLI_SET_FLAG

Field is defined as SET

MYSQLI_NUM_FLAG

Field is defined as NUMERIC

MYSQLI_PART_KEY_FLAG

Field is part of an multi-index

MYSQLI_GROUP_FLAG

Field is part of GROUP BY

MYSQLI_TYPE_DECIMAL

Field is defined as DECIMAL

MYSQLI_TYPE_NEWDECIMAL

Precision math DECIMAL or NUMERIC field (MySQL 5.0.3 and up)

MYSQLI_TYPE_BIT

Field is defined as BIT (MySQL 5.0.3 and up)

MYSQLI_TYPE_TINY

Field is defined as TINYINT

MYSQLI_TYPE_SHORT

Field is defined as SMALLINT

MYSQLI_TYPE_LONG

Field is defined as INT

MYSQLI_TYPE_FLOAT

Field is defined as FLOAT

MYSQLI_TYPE_DOUBLE

Field is defined as DOUBLE

MYSQLI_TYPE_NULL

Field is defined as DEFAULT NULL

MYSQLI_TYPE_TIMESTAMP

Field is defined as TIMESTAMP

MYSQLI_TYPE_LONGLONG

Field is defined as BIGINT

MYSQLI_TYPE_INT24

Field is defined as MEDIUMINT

MYSQLI_TYPE_DATE

Field is defined as DATE

MYSQLI_TYPE_TIME

Field is defined as TIME

MYSQLI_TYPE_DATETIME

Field is defined as DATETIME

MYSQLI_TYPE_YEAR

Field is defined as YEAR

MYSQLI_TYPE_NEWDATE

Field is defined as DATE

MYSQLI_TYPE_INTERVAL

Field is defined as INTERVAL

MYSQLI_TYPE_ENUM

Field is defined as ENUM

MYSQLI_TYPE_SET

Field is defined as SET

MYSQLI_TYPE_TINY_BLOB

Field is defined as TINYBLOB

MYSQLI_TYPE_MEDIUM_BLOB

Field is defined as MEDIUMBLOB

MYSQLI_TYPE_LONG_BLOB

Field is defined as LONGBLOB

MYSQLI_TYPE_BLOB

Field is defined as BLOB

MYSQLI_TYPE_VAR_STRING

Field is defined as VARCHAR

MYSQLI_TYPE_STRING

Field is defined as CHAR or BINARY

MYSQLI_TYPE_CHAR

Field is defined as TINYINT. For CHAR, see MYSQLI_TYPE_STRING

MYSQLI_TYPE_GEOMETRY

Field is defined as GEOMETRY

MYSQLI_NEED_DATA

More data available for bind variable

MYSQLI_NO_DATA

No more data available for bind variable

MYSQLI_DATA_TRUNCATED

Data truncation occurred. Available since PHP 5.1.0 and MySQL 5.0.5.

MYSQLI_ENUM_FLAG

Field is defined as ENUM. Available since PHP 5.3.0.

MYSQLI_BINARY_FLAG

Field is defined as BINARY. Available since PHP 5.3.0.

MYSQLI_CURSOR_TYPE_FOR_UPDATE

MYSQLI_CURSOR_TYPE_NO_CURSOR

MYSQLI_CURSOR_TYPE_READ_ONLY

MYSQLI_CURSOR_TYPE_SCROLLABLE

MYSQLI_STMT_ATTR_CURSOR_TYPE

MYSQLI_STMT_ATTR_PREFETCH_ROWS

MYSQLI_STMT_ATTR_UPDATE_MAX_LENGTH

MYSQLI_SET_CHARSET_NAME

MYSQLI_REPORT_INDEX

Report if no index or bad index was used in a query.

MYSQLI_REPORT_ERROR

Report errors from mysqli function calls.

MYSQLI_REPORT_STRICT

Throw a mysqli_sql_exception for errors instead of warnings.

MYSQLI_REPORT_ALL

Set all options on (report all).

MYSQLI_REPORT_OFF

Turns reporting off.

MYSQLI_DEBUG_TRACE_ENABLED

Is set to 1 if mysqli_debug() functionality is enabled.

MYSQLI_SERVER_QUERY_NO_GOOD_INDEX_USED

MYSQLI_SERVER_QUERY_NO_INDEX_USED

MYSQLI_REFRESH_GRANT

Refreshes the grant tables.

MYSQLI_REFRESH_LOG

Flushes the logs, like executing the FLUSH LOGS SQL statement.

MYSQLI_REFRESH_TABLES

Flushes the table cache, like executing the FLUSH TABLES SQL statement.

MYSQLI_REFRESH_HOSTS

Flushes the host cache, like executing the FLUSH HOSTS SQL statement.

MYSQLI_REFRESH_STATUS

Reset the status variables, like executing the FLUSH STATUS SQL statement.

MYSQLI_REFRESH_THREADS

Flushes the thread cache.

MYSQLI_REFRESH_SLAVE

On a slave replication server: resets the master server information, and restarts the slave. Like executing the RESET SLAVE SQL statement.

MYSQLI_REFRESH_MASTER

On a master replication server: removes the binary log files listed in the binary log index, and truncates the index file. Like executing the RESET MASTER SQL statement.

MYSQLI_TRANS_COR_AND_CHAIN

Appends "AND CHAIN" to mysqli_commit() or mysqli_rollback().

MYSQLI_TRANS_COR_AND_NO_CHAIN

Appends "AND NO CHAIN" to mysqli_commit() or mysqli_rollback().

MYSQLI_TRANS_COR_RELEASE

Appends "RELEASE" to mysqli_commit() or mysqli_rollback().

MYSQLI_TRANS_COR_NO_RELEASE

Appends "NO RELEASE" to mysqli_commit() or mysqli_rollback().

MYSQLI_TRANS_START_READ_ONLY

Start the transaction as "START TRANSACTION READ ONLY" with mysqli_begin_transaction().

MYSQLI_TRANS_START_READ_WRITE

Start the transaction as "START TRANSACTION READ WRITE" with mysqli_begin_transaction().

MYSQLI_TRANS_START_CONSISTENT_SNAPSHOT

Start the transaction as "START TRANSACTION WITH CONSISTENT SNAPSHOT" with mysqli_begin_transaction().

The mysqli Extension and Persistent Connections
Notes
MySQLi


Notes

Some implementation notes:

  1. Support was added for MYSQL_TYPE_GEOMETRY to the MySQLi extension in PHP 5.3.

  2. Note there are different internal implementations within libmysqlclient and mysqlnd for handling columns of type MYSQL_TYPE_GEOMETRY. Generally speaking, mysqlnd will allocate significantly less memory. For example, if there is a POINT column in a result set, libmysqlclient may pre-allocate up to 4GB of RAM although less than 50 bytes are needed for holding a POINT column in memory. Memory allocation is much lower, less than 50 bytes, if using mysqlnd.

Öntanımlı Sabitler
The MySQLi Extension Function Summary
MySQLi


The MySQLi Extension Function Summary

Summary of mysqli methods
mysqli Class
OOP Interface | Procedural Interface | Alias (Do not use) | Description
Properties
$mysqli::affected_rows | mysqli_affected_rows() | N/A | Gets the number of affected rows in a previous MySQL operation
$mysqli::client_info | mysqli_get_client_info() | N/A | Returns the MySQL client version as a string
$mysqli::client_version | mysqli_get_client_version() | N/A | Returns MySQL client version info as an integer
$mysqli::connect_errno | mysqli_connect_errno() | N/A | Returns the error code from last connect call
$mysqli::connect_error | mysqli_connect_error() | N/A | Returns a string description of the last connect error
$mysqli::errno | mysqli_errno() | N/A | Returns the error code for the most recent function call
$mysqli::error | mysqli_error() | N/A | Returns a string description of the last error
$mysqli::field_count | mysqli_field_count() | N/A | Returns the number of columns for the most recent query
$mysqli::host_info | mysqli_get_host_info() | N/A | Returns a string representing the type of connection used
$mysqli::protocol_version | mysqli_get_proto_info() | N/A | Returns the version of the MySQL protocol used
$mysqli::server_info | mysqli_get_server_info() | N/A | Returns the version of the MySQL server
$mysqli::server_version | mysqli_get_server_version() | N/A | Returns the version of the MySQL server as an integer
$mysqli::info | mysqli_info() | N/A | Retrieves information about the most recently executed query
$mysqli::insert_id | mysqli_insert_id() | N/A | Returns the auto generated id used in the last query
$mysqli::sqlstate | mysqli_sqlstate() | N/A | Returns the SQLSTATE error from previous MySQL operation
$mysqli::warning_count | mysqli_warning_count() | N/A | Returns the number of warnings from the last query for the given link
Methods
mysqli::autocommit() | mysqli_autocommit() | N/A | Turns on or off auto-committing database modifications
mysqli::change_user() | mysqli_change_user() | N/A | Changes the user of the specified database connection
mysqli::character_set_name(), mysqli::client_encoding | mysqli_character_set_name() | mysqli_client_encoding() | Returns the default character set for the database connection
mysqli::close() | mysqli_close() | N/A | Closes a previously opened database connection
mysqli::commit() | mysqli_commit() | N/A | Commits the current transaction
mysqli::__construct() | mysqli_connect() | N/A | Open a new connection to the MySQL server [Note: static (i.e. class) method]
mysqli::debug() | mysqli_debug() | N/A | Performs debugging operations
mysqli::dump_debug_info() | mysqli_dump_debug_info() | N/A | Dump debugging information into the log
mysqli::get_charset() | mysqli_get_charset() | N/A | Returns a character set object
mysqli::get_connection_stats() | mysqli_get_connection_stats() | N/A | Returns client connection statistics. Sadece mysqlnd ile kullanılabilir.
mysqli::get_client_info() | mysqli_get_client_info() | N/A | Returns the MySQL client version as a string
mysqli::get_client_stats() | mysqli_get_client_stats() | N/A | Returns client per-process statistics. Sadece mysqlnd ile kullanılabilir.
mysqli::get_cache_stats() | mysqli_get_cache_stats() | N/A | Returns client Zval cache statistics. Sadece mysqlnd ile kullanılabilir.
mysqli::get_server_info() | mysqli_get_server_info() | N/A | Returns a string representing the version of the MySQL server that the MySQLi extension is connected to
mysqli::get_warnings() | mysqli_get_warnings() | N/A | NOT DOCUMENTED
mysqli::init() | mysqli_init() | N/A | Initializes MySQLi and returns a resource for use with mysqli_real_connect. [Not called on an object, as it returns a $mysqli object.]
mysqli::kill() | mysqli_kill() | N/A | Asks the server to kill a MySQL thread
mysqli::more_results() | mysqli_more_results() | N/A | Check if there are any more query results from a multi query
mysqli::multi_query() | mysqli_multi_query() | N/A | Performs a query on the database
mysqli::next_result() | mysqli_next_result() | N/A | Prepare next result from multi_query
mysqli::options() | mysqli_options() | mysqli_set_opt() | Set options
mysqli::ping() | mysqli_ping() | N/A | Pings a server connection, or tries to reconnect if the connection has gone down
mysqli::prepare() | mysqli_prepare() | N/A | Prepare an SQL statement for execution
mysqli::query() | mysqli_query() | N/A | Performs a query on the database
mysqli::real_connect() | mysqli_real_connect() | N/A | Opens a connection to a mysql server
mysqli::real_escape_string(), mysqli::escape_string() | mysqli_real_escape_string() | mysqli_escape_string() | Escapes special characters in a string for use in an SQL statement, taking into account the current charset of the connection
mysqli::real_query() | mysqli_real_query() | N/A | Execute an SQL query
mysqli::refresh() | mysqli_refresh() | N/A | Flushes tables or caches, or resets the replication server information
mysqli::rollback() | mysqli_rollback() | N/A | Rolls back current transaction
mysqli::select_db() | mysqli_select_db() | N/A | Selects the default database for database queries
mysqli::set_charset() | mysqli_set_charset() | N/A | Sets the default client character set
mysqli::set_local_infile_default() | mysqli_set_local_infile_default() | N/A | Unsets user defined handler for load local infile command
mysqli::set_local_infile_handler() | mysqli_set_local_infile_handler() | N/A | Set callback function for LOAD DATA LOCAL INFILE command
mysqli::ssl_set() | mysqli_ssl_set() | N/A | Used for establishing secure connections using SSL
mysqli::stat() | mysqli_stat() | N/A | Gets the current system status
mysqli::stmt_init() | mysqli_stmt_init() | N/A | Initializes a statement and returns an object for use with mysqli_stmt_prepare
mysqli::store_result() | mysqli_store_result() | N/A | Transfers a result set from the last query
mysqli::thread_id() | mysqli_thread_id() | N/A | Returns the thread ID for the current connection
mysqli::thread_safe() | mysqli_thread_safe() | N/A | Returns whether thread safety is given or not
mysqli::use_result() | mysqli_use_result() | N/A | Initiate a result set retrieval
Summary of mysqli_stmt methods
MySQL_STMT
OOP Interface | Procedural Interface | Alias (Do not use) | Description
Properties
$mysqli_stmt::affected_rows | mysqli_stmt_affected_rows() | N/A | Returns the total number of rows changed, deleted, or inserted by the last executed statement
$mysqli_stmt::errno | mysqli_stmt_errno() | N/A | Returns the error code for the most recent statement call
$mysqli_stmt::error | mysqli_stmt_error() | N/A | Returns a string description for last statement error
$mysqli_stmt::field_count | mysqli_stmt_field_count() | N/A | Returns the number of field in the given statement - not documented
$mysqli_stmt::insert_id | mysqli_stmt_insert_id() | N/A | Get the ID generated from the previous INSERT operation
$mysqli_stmt::num_rows | mysqli_stmt_num_rows() | N/A | Return the number of rows in statements result set
$mysqli_stmt::param_count | mysqli_stmt_param_count() | mysqli_param_count() | Returns the number of parameter for the given statement
$mysqli_stmt::sqlstate | mysqli_stmt_sqlstate() | N/A | Returns SQLSTATE error from previous statement operation
Methods
mysqli_stmt::attr_get() | mysqli_stmt_attr_get() | N/A | Used to get the current value of a statement attribute
mysqli_stmt::attr_set() | mysqli_stmt_attr_set() | N/A | Used to modify the behavior of a prepared statement
mysqli_stmt::bind_param() | mysqli_stmt_bind_param() | mysqli_bind_param() | Binds variables to a prepared statement as parameters
mysqli_stmt::bind_result() | mysqli_stmt_bind_result() | mysqli_bind_result() | Binds variables to a prepared statement for result storage
mysqli_stmt::close() | mysqli_stmt_close() | N/A | Closes a prepared statement
mysqli_stmt::data_seek() | mysqli_stmt_data_seek() | N/A | Seeks to an arbitrary row in statement result set
mysqli_stmt::execute() | mysqli_stmt_execute() | mysqli_execute() | Executes a prepared Query
mysqli_stmt::fetch() | mysqli_stmt_fetch() | mysqli_fetch() | Fetch results from a prepared statement into the bound variables
mysqli_stmt::free_result() | mysqli_stmt_free_result() | N/A | Frees stored result memory for the given statement handle
mysqli_stmt::get_result() | mysqli_stmt_get_result() | N/A | Gets a result set from a prepared statement. Sadece mysqlnd ile kullanılabilir.
mysqli_stmt::get_warnings() | mysqli_stmt_get_warnings() | N/A | NOT DOCUMENTED
$mysqli_stmt::more_results() | mysqli_stmt_more_results() | N/A | Checks if there are more query results from a multiple query
$mysqli_stmt::next_result() | mysqli_stmt_next_result() | N/A | Reads the next result from a multiple query
mysqli_stmt::num_rows() | mysqli_stmt_num_rows() | N/A | See also property $mysqli_stmt::num_rows
mysqli_stmt::prepare() | mysqli_stmt_prepare() | N/A | Prepare an SQL statement for execution
mysqli_stmt::reset() | mysqli_stmt_reset() | N/A | Resets a prepared statement
mysqli_stmt::result_metadata() | mysqli_stmt_result_metadata() | mysqli_get_metadata() | Returns result set metadata from a prepared statement
mysqli_stmt::send_long_data() | mysqli_stmt_send_long_data() | mysqli_send_long_data() | Send data in blocks
mysqli_stmt::store_result() | mysqli_stmt_store_result() | N/A | Transfers a result set from a prepared statement
Summary of mysqli_result methods
mysqli_result
OOP Interface | Procedural Interface | Alias (Do not use) | Description
Properties
$mysqli_result::current_field | mysqli_field_tell() | N/A | Get current field offset of a result pointer
$mysqli_result::field_count | mysqli_num_fields() | N/A | Get the number of fields in a result
$mysqli_result::lengths | mysqli_fetch_lengths() | N/A | Returns the lengths of the columns of the current row in the result set
$mysqli_result::num_rows | mysqli_num_rows() | N/A | Gets the number of rows in a result
Methods
mysqli_result::data_seek() | mysqli_data_seek() | N/A | Adjusts the result pointer to an arbitrary row in the result
mysqli_result::fetch_all() | mysqli_fetch_all() | N/A | Fetches all result rows and returns the result set as an associative array, a numeric array, or both. Sadece mysqlnd ile kullanılabilir.
mysqli_result::fetch_array() | mysqli_fetch_array() | N/A | Fetch a result row as an associative, a numeric array, or both
mysqli_result::fetch_assoc() | mysqli_fetch_assoc() | N/A | Fetch a result row as an associative array
mysqli_result::fetch_field_direct() | mysqli_fetch_field_direct() | N/A | Fetch meta-data for a single field
mysqli_result::fetch_field() | mysqli_fetch_field() | N/A | Returns the next field in the result set
mysqli_result::fetch_fields() | mysqli_fetch_fields() | N/A | Returns an array of objects representing the fields in a result set
mysqli_result::fetch_object() | mysqli_fetch_object() | N/A | Returns the current row of a result set as an object
mysqli_result::fetch_row() | mysqli_fetch_row() | N/A | Get a result row as an enumerated array
mysqli_result::field_seek() | mysqli_field_seek() | N/A | Set result pointer to a specified field offset
mysqli_result::free(), mysqli_result::close, mysqli_result::free_result | mysqli_free_result() | N/A | Frees the memory associated with a result
Summary of mysqli_driver methods
MySQL_Driver
OOP Interface | Procedural Interface | Alias (Do not use) | Description
Properties
N/A
Methods
mysqli_driver::embedded_server_end() | mysqli_embedded_server_end() | N/A | NOT DOCUMENTED
mysqli_driver::embedded_server_start() | mysqli_embedded_server_start() | N/A | NOT DOCUMENTED

Bilginize:

Alias functions are provided for backward compatibility purposes only. Do not use them in new projects.

Notes
Örnekler
MySQLi


Örnekler

İçindekiler

  • MySQLi extension basic examples
The MySQLi Extension Function Summary
MySQLi extension basic examples
MySQLi


MySQLi extension basic examples

This example shows how to connect, execute a query, use basic error handling, print resulting rows, and disconnect from a MySQL database.

This example uses the freely available Sakila database that can be downloaded from » dev.mysql.com, as described here. To get this example to work, (a) install sakila and (b) modify the connection variables (host, your_user, your_pass).

Örnek 1 MySQLi extension overview example

<?php
// Let's pass in a $_GET variable to our example, in this case
// it's aid for actor_id in our Sakila database. Let's make it
// default to 1, and cast it to an integer as to avoid SQL injection
// and/or related security problems. Handling all of this goes beyond
// the scope of this simple example. Example:
//   http://example.org/script.php?aid=42
if (isset($_GET['aid']) && is_numeric($_GET['aid'])) {
    $aid = (int) $_GET['aid'];
} else {
    $aid = 1;
}

// Connecting to and selecting a MySQL database named sakila
// Hostname: 127.0.0.1, username: your_user, password: your_pass, db: sakila
$mysqli = new mysqli('127.0.0.1', 'your_user', 'your_pass', 'sakila');

// Oh no! A connect_errno exists so the connection attempt failed!
if ($mysqli->connect_errno) {
    // The connection failed. What do you want to do?
    // You could contact yourself (email?), log the error, show a nice page, etc.
    // You do not want to reveal sensitive information

    // Let's try this:
    echo "Sorry, this website is experiencing problems.";

    // Something you should not do on a public site, but this example will show you
    // anyways, is print out MySQL error related information -- you might log this
    echo "Error: Failed to make a MySQL connection, here is why: \n";
    echo "Errno: " . $mysqli->connect_errno . "\n";
    echo "Error: " . $mysqli->connect_error . "\n";

    // You might want to show them something nice, but we will simply exit
    exit;
}

// Perform an SQL query
$sql = "SELECT actor_id, first_name, last_name FROM actor WHERE actor_id = $aid";
if (!$result = $mysqli->query($sql)) {
    // Oh no! The query failed.
    echo "Sorry, the website is experiencing problems.";

    // Again, do not do this on a public site, but we'll show you how
    // to get the error information
    echo "Error: Our query failed to execute and here is why: \n";
    echo "Query: " . $sql . "\n";
    echo "Errno: " . $mysqli->errno . "\n";
    echo "Error: " . $mysqli->error . "\n";
    exit;
}

// Phew, we made it. We know our MySQL connection and query
// succeeded, but do we have a result?
if ($result->num_rows === 0) {
    // Oh, no rows! Sometimes that's expected and okay, sometimes
    // it is not. You decide. In this case, maybe actor_id was too
    // large?
    echo "We could not find a match for ID $aid, sorry about that. Please try again.";
    exit;
}

// Now, we know only one result will exist in this example so let's
// fetch it into an associated array where the array's keys are the
// table's column names
$actor = $result->fetch_assoc();
echo "Sometimes I see " . $actor['first_name'] . " " . $actor['last_name'] . " on TV.";

// Now, let's fetch five random actors and output their names to a list.
// We'll add less error handling here as you can do that on your own now
$sql = "SELECT actor_id, first_name, last_name FROM actor ORDER BY rand() LIMIT 5";
if (!$result = $mysqli->query($sql)) {
    echo "Sorry, the website is experiencing problems.";
    exit;
}

// Print our 5 random actors in a list, and link to each actor
echo "<ul>\n";
while ($actor = $result->fetch_assoc()) {
    echo "<li><a href='" . $_SERVER['SCRIPT_FILENAME'] . "?aid=" . $actor['actor_id'] . "'>\n";
    echo $actor['first_name'] . ' ' . $actor['last_name'];
    echo "</a></li>\n";
}
echo "</ul>\n";

// The script will automatically free the result and close the MySQL
// connection when it exits, but let's just do it anyways
$result->free();
$mysqli->close();
?>
Örnekler
mysqli
Örnekler


The mysqli class

(PHP 5, PHP 7)

Giriş

Represents a connection between PHP and a MySQL database.

Sınıf Sözdizimi

mysqli {
/* Özellikler */
int $affected_rows;
string $client_info;
int $client_version;
int $connect_errno;
string $connect_error;
int $errno;
array $error_list;
string $error;
int $field_count;
int $client_version;
string $host_info;
string $protocol_version;
string $server_info;
int $server_version;
string $info;
mixed $insert_id;
string $sqlstate;
int $thread_id;
int $warning_count;
/* Yöntemler */
 __construct
  ([ string $host = ini_get("mysqli.default_host")
 [, string $username = ini_get("mysqli.default_user")
 [, string $passwd = ini_get("mysqli.default_pw")
 [, string $dbname = ""
 [, int $port = ini_get("mysqli.default_port")
 [, string $socket = ini_get("mysqli.default_socket")
]]]]]] )
bool autocommit ( bool $mode )
bool change_user ( string $user , string $password , string $database )
string character_set_name ( void )
bool close ( void )
bool commit ([ int $flags [, string $name ]] )
bool debug ( string $message )
bool dump_debug_info ( void )
object get_charset ( void )
string get_client_info ( void )
bool get_connection_stats ( void )
mysqli_warning get_warnings ( void )
mysqli init ( void )
bool kill ( int $processid )
bool more_results ( void )
bool multi_query ( string $query )
bool next_result ( void )
bool options ( int $option , mixed $value )
bool ping ( void )
public static int poll ( array &$read , array &$error , array &$reject , int $sec [, int $usec ] )
mysqli_stmt prepare ( string $query )
mixed query ( string $query [, int $resultmode = MYSQLI_STORE_RESULT ] )
bool real_connect ([ string $host [, string $username [, string $passwd [, string $dbname [, int $port [, string $socket [, int $flags ]]]]]]] )
string escape_string ( string $escapestr )
bool real_query ( string $query )
public mysqli_result reap_async_query ( void )
public bool refresh ( int $options )
bool rollback ([ int $flags [, string $name ]] )
int rpl_query_type ( string $query )
bool select_db ( string $dbname )
bool send_query ( string $query )
bool set_charset ( string $charset )
bool set_local_infile_handler ( mysqli $link , callable $read_func )
bool ssl_set ( string $key , string $cert , string $ca , string $capath , string $cipher )
string stat ( void )
mysqli_stmt stmt_init ( void )
mysqli_result store_result ([ int $option ] )
mysqli_result use_result ( void )
}

İçindekiler

  • mysqli::$affected_rows — Gets the number of affected rows in a previous MySQL operation
  • mysqli::autocommit — Turns on or off auto-committing database modifications
  • mysqli::begin_transaction — Starts a transaction
  • mysqli::change_user — Changes the user of the specified database connection
  • mysqli::character_set_name — Returns the default character set for the database connection
  • mysqli::$client_info — Get MySQL client info
  • mysqli::$client_version — Returns the MySQL client version as a string
  • mysqli::close — Closes a previously opened database connection
  • mysqli::commit — Commits the current transaction
  • mysqli::$connect_errno — Returns the error code from last connect call
  • mysqli::$connect_error — Returns a string description of the last connect error
  • mysqli::__construct — Open a new connection to the MySQL server
  • mysqli::debug — Performs debugging operations
  • mysqli::dump_debug_info — Dump debugging information into the log
  • mysqli::$errno — Returns the error code for the most recent function call
  • mysqli::$error_list — Returns a list of errors from the last command executed
  • mysqli::$error — Returns a string description of the last error
  • mysqli::$field_count — Returns the number of columns for the most recent query
  • mysqli::get_charset — Returns a character set object
  • mysqli::get_client_info — Get MySQL client info
  • mysqli_get_client_stats — Returns client per-process statistics
  • mysqli_get_client_version — Returns the MySQL client version as an integer
  • mysqli::get_connection_stats — Returns statistics about the client connection
  • mysqli::$host_info — Returns a string representing the type of connection used
  • mysqli::$protocol_version — Returns the version of the MySQL protocol used
  • mysqli::$server_info — Returns the version of the MySQL server
  • mysqli::$server_version — Returns the version of the MySQL server as an integer
  • mysqli::get_warnings — Get result of SHOW WARNINGS
  • mysqli::$info — Retrieves information about the most recently executed query
  • mysqli::init — Initializes MySQLi and returns a resource for use with mysqli_real_connect()
  • mysqli::$insert_id — Returns the auto generated id used in the latest query
  • mysqli::kill — Asks the server to kill a MySQL thread
  • mysqli::more_results — Check if there are any more query results from a multi query
  • mysqli::multi_query — Performs a query on the database
  • mysqli::next_result — Prepare next result from multi_query
  • mysqli::options — Set options
  • mysqli::ping — Pings a server connection, or tries to reconnect if the connection has gone down
  • mysqli::poll — Poll connections
  • mysqli::prepare — Prepare an SQL statement for execution
  • mysqli::query — Performs a query on the database
  • mysqli::real_connect — Opens a connection to a mysql server
  • mysqli::real_escape_string — Escapes special characters in a string for use in an SQL statement, taking into account the current charset of the connection
  • mysqli::real_query — Execute an SQL query
  • mysqli::reap_async_query — Get result from async query
  • mysqli::refresh — Refreshes
  • mysqli::release_savepoint — Removes the named savepoint from the set of savepoints of the current transaction
  • mysqli::rollback — Rolls back current transaction
  • mysqli::rpl_query_type — Returns RPL query type
  • mysqli::savepoint — Set a named transaction savepoint
  • mysqli::select_db — Selects the default database for database queries
  • mysqli::send_query — Send the query and return
  • mysqli::set_charset — Sets the default client character set
  • mysqli::set_local_infile_default — Unsets user defined handler for load local infile command
  • mysqli::set_local_infile_handler — Set callback function for LOAD DATA LOCAL INFILE command
  • mysqli::$sqlstate — Returns the SQLSTATE error from previous MySQL operation
  • mysqli::ssl_set — Used for establishing secure connections using SSL
  • mysqli::stat — Gets the current system status
  • mysqli::stmt_init — Initializes a statement and returns an object for use with mysqli_stmt_prepare
  • mysqli::store_result — Transfers a result set from the last query
  • mysqli::$thread_id — Returns the thread ID for the current connection
  • mysqli::thread_safe — Returns whether thread safety is given or not
  • mysqli::use_result — Initiate a result set retrieval
  • mysqli::$warning_count — Returns the number of warnings from the last query for the given link
MySQLi extension basic examples
mysqli::$affected_rows
MySQLi


Gets the number of affected rows in a previous MySQL operation

mysqli
mysqli::autocommit
mysqli
PHP Manual

mysqli::$affected_rows

mysqli_affected_rows

(PHP 5, PHP 7)

mysqli::$affected_rows -- mysqli_affected_rows — Gets the number of affected rows in a previous MySQL operation

Açıklama

Nesne yönelimli kullanım

int $mysqli->affected_rows;

Yordamsal kullanım

int mysqli_affected_rows ( mysqli $link )

Returns the number of rows affected by the last INSERT, UPDATE, REPLACE or DELETE query.

For SELECT statements mysqli_affected_rows() works like mysqli_num_rows().

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

Dönen Değerler

An integer greater than zero indicates the number of rows affected or retrieved. Zero indicates that no records were updated for an UPDATE statement, no rows matched the WHERE clause in the query or that no query has yet been executed. -1 indicates that the query returned an error.

Bilginize:

If the number of affected rows is greater than the maximum integer value( PHP_INT_MAX ), the number of affected rows will be returned as a string.

Örnekler

Örnek 1 $mysqli->affected_rows example

Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* Insert rows */
$mysqli->query("CREATE TABLE Language SELECT * from CountryLanguage");
printf("Affected rows (INSERT): %d\n", $mysqli->affected_rows);

$mysqli->query("ALTER TABLE Language ADD Status int default 0");

/* update rows */
$mysqli->query("UPDATE Language SET Status=1 WHERE Percentage > 50");
printf("Affected rows (UPDATE): %d\n", $mysqli->affected_rows);

/* delete rows */
$mysqli->query("DELETE FROM Language WHERE Percentage < 50");
printf("Affected rows (DELETE): %d\n", $mysqli->affected_rows);

/* select all rows */
$result = $mysqli->query("SELECT CountryCode FROM Language");
printf("Affected rows (SELECT): %d\n", $mysqli->affected_rows);

$result->close();

/* Delete table Language */
$mysqli->query("DROP TABLE Language");

/* close connection */
$mysqli->close();
?>

Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

if (!$link) {
    printf("Can't connect to localhost. Error: %s\n", mysqli_connect_error());
    exit();
}

/* Insert rows */
mysqli_query($link, "CREATE TABLE Language SELECT * from CountryLanguage");
printf("Affected rows (INSERT): %d\n", mysqli_affected_rows($link));

mysqli_query($link, "ALTER TABLE Language ADD Status int default 0");

/* update rows */
mysqli_query($link, "UPDATE Language SET Status=1 WHERE Percentage > 50");
printf("Affected rows (UPDATE): %d\n", mysqli_affected_rows($link));

/* delete rows */
mysqli_query($link, "DELETE FROM Language WHERE Percentage < 50");
printf("Affected rows (DELETE): %d\n", mysqli_affected_rows($link));

/* select all rows */
$result = mysqli_query($link, "SELECT CountryCode FROM Language");
printf("Affected rows (SELECT): %d\n", mysqli_affected_rows($link));

mysqli_free_result($result);

/* Delete table Language */
mysqli_query($link, "DROP TABLE Language");

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Affected rows (INSERT): 984
Affected rows (UPDATE): 168
Affected rows (DELETE): 815
Affected rows (SELECT): 169

Ayrıca Bakınız

  • mysqli_num_rows() - Gets the number of rows in a result
  • mysqli_info() - Retrieves information about the most recently executed query

mysqli
mysqli::autocommit
mysqli


Turns on or off auto-committing database modifications

mysqli::$affected_rows
mysqli::begin_transaction
mysqli
PHP Manual

mysqli::autocommit

mysqli_autocommit

(PHP 5, PHP 7)

mysqli::autocommit -- mysqli_autocommit — Turns on or off auto-committing database modifications

Açıklama

Nesne yönelimli kullanım

bool mysqli::autocommit ( bool $mode )

Yordamsal kullanım

bool mysqli_autocommit ( mysqli $link , bool $mode )

Turns on or off auto-commit mode on queries for the database connection.

To determine the current state of autocommit use the SQL command SELECT @@autocommit.

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

mode

Whether to turn on auto-commit or not.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

Bilginize:

This function doesn't work with non transactional table types (like MyISAM or ISAM).

Örnekler

Örnek 1 mysqli::autocommit() example

Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* turn autocommit on */
$mysqli->autocommit(TRUE);

if ($result = $mysqli->query("SELECT @@autocommit")) {
    $row = $result->fetch_row();
    printf("Autocommit is %s\n", $row[0]);
    $result->free();
}

/* close connection */
$mysqli->close();
?>

Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

if (!$link) {
    printf("Can't connect to localhost. Error: %s\n", mysqli_connect_error());
    exit();
}

/* turn autocommit on */
mysqli_autocommit($link, TRUE);

if ($result = mysqli_query($link, "SELECT @@autocommit")) {
    $row = mysqli_fetch_row($result);
    printf("Autocommit is %s\n", $row[0]);
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Autocommit is 1

Ayrıca Bakınız

  • mysqli_begin_transaction() - Starts a transaction
  • mysqli_commit() - Commits the current transaction
  • mysqli_rollback() - Rolls back current transaction

mysqli::$affected_rows
mysqli::begin_transaction
mysqli


Starts a transaction

mysqli::autocommit
mysqli::change_user
mysqli
PHP Manual

mysqli::begin_transaction

mysqli_begin_transaction

(PHP 5 >= 5.5.0, PHP 7)

mysqli::begin_transaction -- mysqli_begin_transaction — Starts a transaction

Açıklama

Nesne yönelimli kullanım (method):

public bool mysqli::begin_transaction ([ int $flags [, string $name ]] )

Yordamsal kullanım:

bool mysqli_begin_transaction ( mysqli $link [, int $flags [, string $name ]] )

Begins a transaction. Requires MySQL 5.6 and above, and the InnoDB engine (it is enabled by default). For additional details about how MySQL transactions work, see » http://dev.mysql.com/doc/mysql/en/commit.html.

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

flags

Valid flags are:

  • MYSQLI_TRANS_START_READ_ONLY: Start the transaction as "START TRANSACTION READ ONLY".

  • MYSQLI_TRANS_START_READ_WRITE: Start the transaction as "START TRANSACTION READ WRITE".

  • MYSQLI_TRANS_START_WITH_CONSISTENT_SNAPSHOT: Start the transaction as "START TRANSACTION WITH CONSISTENT SNAPSHOT".

name

Savepoint name for the transaction.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 $mysqli->begin_transaction() example

Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("127.0.0.1", "my_user", "my_password", "sakila");

if ($mysqli->connect_errno) {
    printf("Connect failed: %s\n", $mysqli->connect_error);
    exit();
}

$mysqli->begin_transaction(MYSQLI_TRANS_START_READ_ONLY);

$mysqli->query("SELECT first_name, last_name FROM actor");
$mysqli->commit();

$mysqli->close();
?>

Yordamsal kullanım

<?php
$link = mysqli_connect("127.0.0.1", "my_user", "my_password", "sakila");

if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

mysqli_begin_transaction($link, MYSQLI_TRANS_START_READ_ONLY);

mysqli_query($link, "SELECT first_name, last_name FROM actor LIMIT 1");
mysqli_commit($link);

mysqli_close($link);
?>

Ayrıca Bakınız

  • mysqli_autocommit() - Turns on or off auto-committing database modifications
  • mysqli_commit() - Commits the current transaction
  • mysqli_rollback() - Rolls back current transaction

mysqli::autocommit
mysqli::change_user
mysqli


Changes the user of the specified database connection

mysqli::begin_transaction
mysqli::character_set_name
mysqli
PHP Manual

mysqli::change_user

mysqli_change_user

(PHP 5, PHP 7)

mysqli::change_user -- mysqli_change_user — Changes the user of the specified database connection

Açıklama

Nesne yönelimli kullanım

bool mysqli::change_user ( string $user , string $password , string $database )

Yordamsal kullanım

bool mysqli_change_user ( mysqli $link , string $user , string $password , string $database )

Changes the user of the specified database connection and sets the current database.

In order to successfully change users a valid username and password parameters must be provided and that user must have sufficient permissions to access the desired database. If for any reason authorization fails, the current user authentication will remain.

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

user

The MySQL user name.

password

The MySQL password.

database

The database to change to.

If desired, the NULL value may be passed resulting in only changing the user and not selecting a database. To select a database in this case use the mysqli_select_db() function.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

Bilginize:

Using this command will always cause the current database connection to behave as if was a completely new database connection, regardless of if the operation was completed successfully. This reset includes performing a rollback on any active transactions, closing all temporary tables, and unlocking all locked tables.

Örnekler

Örnek 1 mysqli::change_user() example

Nesne yönelimli kullanım

<?php

/* connect database test */
$mysqli = new mysqli("localhost", "my_user", "my_password", "test");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* Set Variable a */
$mysqli->query("SET @a:=1");

/* reset all and select a new database */
$mysqli->change_user("my_user", "my_password", "world");

if ($result = $mysqli->query("SELECT DATABASE()")) {
    $row = $result->fetch_row();
    printf("Default database: %s\n", $row[0]);
    $result->close();
}

if ($result = $mysqli->query("SELECT @a")) {
    $row = $result->fetch_row();
    if ($row[0] === NULL) {
        printf("Value of variable a is NULL\n");
    }
    $result->close();
}

/* close connection */
$mysqli->close();
?>

Yordamsal kullanım

<?php
/* connect database test */
$link = mysqli_connect("localhost", "my_user", "my_password", "test");

/* check connection */
if (!$link) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* Set Variable a */
mysqli_query($link, "SET @a:=1");

/* reset all and select a new database */
mysqli_change_user($link, "my_user", "my_password", "world");

if ($result = mysqli_query($link, "SELECT DATABASE()")) {
    $row = mysqli_fetch_row($result);
    printf("Default database: %s\n", $row[0]);
    mysqli_free_result($result);
}

if ($result = mysqli_query($link, "SELECT @a")) {
    $row = mysqli_fetch_row($result);
    if ($row[0] === NULL) {
        printf("Value of variable a is NULL\n");
    }
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Default database: world
Value of variable a is NULL

Ayrıca Bakınız

  • mysqli_connect() - Takma Adı: mysqli::__construct
  • mysqli_select_db() - Selects the default database for database queries

mysqli::begin_transaction
mysqli::character_set_name
mysqli


Returns the default character set for the database connection

mysqli::change_user
mysqli::$client_info
mysqli
PHP Manual

mysqli::character_set_name

mysqli_character_set_name

(PHP 5, PHP 7)

mysqli::character_set_name -- mysqli_character_set_name — Returns the default character set for the database connection

Açıklama

Nesne yönelimli kullanım

string mysqli::character_set_name ( void )

Yordamsal kullanım

string mysqli_character_set_name ( mysqli $link )

Returns the current character set for the database connection.

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

Dönen Değerler

The default character set for the current connection

Örnekler

Örnek 1 mysqli::character_set_name() example

Nesne yönelimli kullanım

<?php
/* Open a connection */
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* Print current character set */
$charset = $mysqli->character_set_name();
printf ("Current character set is %s\n", $charset);

$mysqli->close();
?>

Yordamsal kullanım

<?php
/* Open a connection */
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (!$link) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* Print current character set */
$charset = mysqli_character_set_name($link);
printf ("Current character set is %s\n",$charset);

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Current character set is latin1_swedish_ci

Ayrıca Bakınız

  • mysqli_set_charset() - Sets the default client character set
  • mysqli_client_encoding() - Alias of mysqli_character_set_name
  • mysqli_real_escape_string() - Escapes special characters in a string for use in an SQL statement, taking into account the current charset of the connection

mysqli::change_user
mysqli::$client_info
mysqli


Get MySQL client info

mysqli::character_set_name
mysqli::$client_version
mysqli
PHP Manual

mysqli::$client_info

mysqli_get_client_info

(PHP 5, PHP 7)

mysqli::$client_info -- mysqli_get_client_info — Get MySQL client info

Açıklama

Nesne yönelimli kullanım

string $mysqli->client_info;

Yordamsal kullanım

string mysqli_get_client_info ( mysqli $link )

Returns a string that represents the MySQL client library version.

Dönen Değerler

A string that represents the MySQL client library version

Örnekler

Örnek 1 mysqli_get_client_info

<?php

/* We don't need a connection to determine
   the version of mysql client library */

printf("Client library version: %s\n", mysqli_get_client_info());
?>

Ayrıca Bakınız

  • mysqli_get_client_version() - Returns the MySQL client version as an integer
  • mysqli_get_server_info() - Returns the version of the MySQL server
  • mysqli_get_server_version() - Returns the version of the MySQL server as an integer

mysqli::character_set_name
mysqli::$client_version
mysqli


Returns the MySQL client version as a string

mysqli::$client_info
mysqli::close
mysqli
PHP Manual

mysqli::$client_version

mysqli_get_client_version

(PHP 5, PHP 7)

mysqli::$client_version -- mysqli_get_client_version — Returns the MySQL client version as a string

Açıklama

Nesne yönelimli kullanım

int $mysqli->client_version;

Yordamsal kullanım

int mysqli_get_client_version ( mysqli $link )

Returns client version number as an integer.

Dönen Değerler

A number that represents the MySQL client library version in format: main_version*10000 + minor_version *100 + sub_version. For example, 4.1.0 is returned as 40100.

This is useful to quickly determine the version of the client library to know if some capability exists.

Örnekler

Örnek 1 mysqli_get_client_version

<?php

/* We don't need a connection to determine
   the version of mysql client library */

printf("Client library version: %d\n", mysqli_get_client_version());
?>

Ayrıca Bakınız

  • mysqli_get_client_info() - Get MySQL client info
  • mysqli_get_server_info() - Returns the version of the MySQL server
  • mysqli_get_server_version() - Returns the version of the MySQL server as an integer

mysqli::$client_info
mysqli::close
mysqli


Closes a previously opened database connection

mysqli::$client_version
mysqli::commit
mysqli
PHP Manual

mysqli::close

mysqli_close

(PHP 5, PHP 7)

mysqli::close -- mysqli_close — Closes a previously opened database connection

Açıklama

Nesne yönelimli kullanım

bool mysqli::close ( void )

Yordamsal kullanım

bool mysqli_close ( mysqli $link )

Closes a previously opened database connection.

Open non-persistent MySQL connections and result sets are automatically destroyed when a PHP script finishes its execution. So, while explicitly closing open connections and freeing result sets is optional, doing so is recommended. This will immediately return resources to PHP and MySQL, which can improve performance. For related information, see freeing resources

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

See mysqli_connect().

Notlar

Bilginize:

mysqli_close() will not close persistent connections. For additional details, see the manual page on persistent connections.

Ayrıca Bakınız

  • mysqli::__construct() - Open a new connection to the MySQL server
  • mysqli_init() - Initializes MySQLi and returns a resource for use with mysqli_real_connect()
  • mysqli_real_connect() - Opens a connection to a mysql server
  • mysqli_free_result() - Frees the memory associated with a result

mysqli::$client_version
mysqli::commit
mysqli


Commits the current transaction

mysqli::close
mysqli::$connect_errno
mysqli
PHP Manual

mysqli::commit

mysqli_commit

(PHP 5, PHP 7)

mysqli::commit -- mysqli_commit — Commits the current transaction

Açıklama

Nesne yönelimli kullanım

bool mysqli::commit ([ int $flags [, string $name ]] )

Yordamsal kullanım

bool mysqli_commit ( mysqli $link [, int $flags [, string $name ]] )

Commits the current transaction for the database connection.

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

flags

A bitmask of MYSQLI_TRANS_COR_* constants.

name

If provided then COMMIT/*name*/ is executed.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.5.0 | Added flags and name parameters.

Örnekler

Örnek 1 mysqli::commit() example

Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TABLE Language LIKE CountryLanguage");

/* set autocommit to off */
$mysqli->autocommit(FALSE);

/* Insert some values */
$mysqli->query("INSERT INTO Language VALUES ('DEU', 'Bavarian', 'F', 11.2)");
$mysqli->query("INSERT INTO Language VALUES ('DEU', 'Swabian', 'F', 9.4)");

/* commit transaction */
if (!$mysqli->commit()) {
    print("Transaction commit failed\n");
    exit();
}

/* drop table */
$mysqli->query("DROP TABLE Language");

/* close connection */
$mysqli->close();
?>

Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "test");

/* check connection */
if (!$link) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* set autocommit to off */
mysqli_autocommit($link, FALSE);

mysqli_query($link, "CREATE TABLE Language LIKE CountryLanguage");

/* Insert some values */
mysqli_query($link, "INSERT INTO Language VALUES ('DEU', 'Bavarian', 'F', 11.2)");
mysqli_query($link, "INSERT INTO Language VALUES ('DEU', 'Swabian', 'F', 9.4)");

/* commit transaction */
if (!mysqli_commit($link)) {
    print("Transaction commit failed\n");
    exit();
}

/* close connection */
mysqli_close($link);
?>

Ayrıca Bakınız

  • mysqli_autocommit() - Turns on or off auto-committing database modifications
  • mysqli_begin_transaction() - Starts a transaction
  • mysqli_rollback() - Rolls back current transaction
  • mysqli_savepoint() - Set a named transaction savepoint

mysqli::close
mysqli::$connect_errno
mysqli


Returns the error code from last connect call

mysqli::commit
mysqli::$connect_error
mysqli
PHP Manual

mysqli::$connect_errno

mysqli_connect_errno

(PHP 5, PHP 7)

mysqli::$connect_errno -- mysqli_connect_errno — Returns the error code from last connect call

Açıklama

Nesne yönelimli kullanım

int $mysqli->connect_errno;

Yordamsal kullanım

int mysqli_connect_errno ( void )

Returns the last error code number from the last call to mysqli_connect().

Bilginize:

Client error message numbers are listed in the MySQL errmsg.h header file, server error message numbers are listed in mysqld_error.h. In the MySQL source distribution you can find a complete list of error messages and error numbers in the file Docs/mysqld_error.txt.

Dönen Değerler

An error code value for the last call to mysqli_connect(), if it failed. zero means no error occurred.

Örnekler

Örnek 1 $mysqli->connect_errno example

Nesne yönelimli kullanım

<?php
$mysqli = @new mysqli('localhost', 'fake_user', 'my_password', 'my_db');

if ($mysqli->connect_errno) {
    die('Connect Error: ' . $mysqli->connect_errno);
}
?>

Yordamsal kullanım

<?php
$link = @mysqli_connect('localhost', 'fake_user', 'my_password', 'my_db');

if (!$link) {
    die('Connect Error: ' . mysqli_connect_errno());
}
?>

Yukarıdaki örneklerin çıktısı:

Connect Error: 1045

Ayrıca Bakınız

  • mysqli_connect() - Takma Adı: mysqli::__construct
  • mysqli_connect_error() - Returns a string description of the last connect error
  • mysqli_errno() - Returns the error code for the most recent function call
  • mysqli_error() - Returns a string description of the last error
  • mysqli_sqlstate() - Returns the SQLSTATE error from previous MySQL operation

mysqli::commit
mysqli::$connect_error
mysqli


Returns a string description of the last connect error

mysqli::$connect_errno
mysqli::__construct
mysqli
PHP Manual

mysqli::$connect_error

mysqli_connect_error

(PHP 5, PHP 7)

mysqli::$connect_error -- mysqli_connect_error — Returns a string description of the last connect error

Açıklama

Nesne yönelimli kullanım

string $mysqli->connect_error;

Yordamsal kullanım

string mysqli_connect_error ( void )

Returns the last error message string from the last call to mysqli_connect().

Dönen Değerler

A string that describes the error. NULL is returned if no error occurred.

Örnekler

Örnek 1 $mysqli->connect_error example

Nesne yönelimli kullanım

<?php
$mysqli = @new mysqli('localhost', 'fake_user', 'my_password', 'my_db');

// Works as of PHP 5.2.9 and 5.3.0.
if ($mysqli->connect_error) {
    die('Connect Error: ' . $mysqli->connect_error);
}
?>

Yordamsal kullanım

<?php
$link = @mysqli_connect('localhost', 'fake_user', 'my_password', 'my_db');

if (!$link) {
    die('Connect Error: ' . mysqli_connect_error());
}
?>

Yukarıdaki örneklerin çıktısı:

Connect Error: Access denied for user 'fake_user'@'localhost' (using password: YES)

Notlar

Uyarı

The mysqli->connect_error property only works properly as of PHP versions 5.2.9 and 5.3.0. Use the mysqli_connect_error() function if compatibility with earlier PHP versions is required.

Ayrıca Bakınız

  • mysqli_connect() - Takma Adı: mysqli::__construct
  • mysqli_connect_errno() - Returns the error code from last connect call
  • mysqli_errno() - Returns the error code for the most recent function call
  • mysqli_error() - Returns a string description of the last error
  • mysqli_sqlstate() - Returns the SQLSTATE error from previous MySQL operation

mysqli::$connect_errno
mysqli::__construct
mysqli


Open a new connection to the MySQL server

mysqli::$connect_error
mysqli::debug
mysqli
PHP Manual

mysqli::__construct

mysqli_connect

(PHP 5, PHP 7)

mysqli::__construct -- mysqli_connect — Open a new connection to the MySQL server

Açıklama

Nesne yönelimli kullanım

 mysqli::__construct
  ([ string $host = ini_get("mysqli.default_host")
 [, string $username = ini_get("mysqli.default_user")
 [, string $passwd = ini_get("mysqli.default_pw")
 [, string $dbname = ""
 [, int $port = ini_get("mysqli.default_port")
 [, string $socket = ini_get("mysqli.default_socket")
]]]]]] )

Yordamsal kullanım

 mysqli mysqli_connect
  ([ string $host = ini_get("mysqli.default_host")
 [, string $username = ini_get("mysqli.default_user")
 [, string $passwd = ini_get("mysqli.default_pw")
 [, string $dbname = ""
 [, int $port = ini_get("mysqli.default_port")
 [, string $socket = ini_get("mysqli.default_socket")
]]]]]] )

Opens a connection to the MySQL Server running on.

Değiştirgeler

host

Can be either a host name or an IP address. Passing the NULL value or the string "localhost" to this parameter, the local host is assumed. When possible, pipes will be used instead of the TCP/IP protocol.

Prepending host by p: opens a persistent connection. mysqli_change_user() is automatically called on connections opened from the connection pool.

username

The MySQL user name.

passwd

If not provided or NULL, the MySQL server will attempt to authenticate the user against those user records which have no password only. This allows one username to be used with different permissions (depending on if a password as provided or not).

dbname

If provided will specify the default database to be used when performing queries.

port

Specifies the port number to attempt to connect to the MySQL server.

socket

Specifies the socket or named pipe that should be used.

Bilginize:

Specifying the socket parameter will not explicitly determine the type of connection to be used when connecting to the MySQL server. How the connection is made to the MySQL database is determined by the host parameter.

Dönen Değerler

Returns an object which represents the connection to a MySQL Server.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | Added the ability of persistent connections.

Örnekler

Örnek 1 mysqli::__construct() example

Nesne yönelimli kullanım

<?php
$mysqli = new mysqli('localhost', 'my_user', 'my_password', 'my_db');

/*
 * This is the "official" OO way to do it,
 * BUT $connect_error was broken until PHP 5.2.9 and 5.3.0.
 */
if ($mysqli->connect_error) {
    die('Connect Error (' . $mysqli->connect_errno . ') '
            . $mysqli->connect_error);
}

/*
 * Use this instead of $connect_error if you need to ensure
 * compatibility with PHP versions prior to 5.2.9 and 5.3.0.
 */
if (mysqli_connect_error()) {
    die('Connect Error (' . mysqli_connect_errno() . ') '
            . mysqli_connect_error());
}

echo 'Success... ' . $mysqli->host_info . "\n";

$mysqli->close();
?>

Nesne yönelimli kullanım when extending mysqli class

<?php

class foo_mysqli extends mysqli {
    public function __construct($host, $user, $pass, $db) {
        parent::__construct($host, $user, $pass, $db);

        if (mysqli_connect_error()) {
            die('Connect Error (' . mysqli_connect_errno() . ') '
                    . mysqli_connect_error());
        }
    }
}

$db = new foo_mysqli('localhost', 'my_user', 'my_password', 'my_db');

echo 'Success... ' . $db->host_info . "\n";

$db->close();
?>

Yordamsal kullanım

<?php
$link = mysqli_connect('localhost', 'my_user', 'my_password', 'my_db');

if (!$link) {
    die('Connect Error (' . mysqli_connect_errno() . ') '
            . mysqli_connect_error());
}

echo 'Success... ' . mysqli_get_host_info($link) . "\n";

mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Success... MySQL host info: localhost via TCP/IP

Notlar

Bilginize:

MySQLnd daima sunucunun öntanımlı bir karakter kümesi olduğunu varsayar. Bu karakter kümesi, mysqlnd'nin kullanacağı uzlaşım/kimlik doğrulama bağlantısı sırasında gönderilir.

Libmysqlclient, ya my.cnf dosyasındaki öntanımlı karakter kümesini ya da mysqli_init() çağrısından sonraki ilk mysqli_real_connect() çağrısındaan önce çağrılan mysqli_options() işlevinde belirtilen karakter kümesini kullanır.

Bilginize:

OO syntax only: If a connection fails an object is still returned. To check if the connection failed then use either the mysqli_connect_error() function or the mysqli->connect_error property as in the preceding examples.

Bilginize:

If it is necessary to set options, such as the connection timeout, mysqli_real_connect() must be used instead.

Bilginize:

Calling the constructor with no parameters is the same as calling mysqli_init().

Bilginize:

Error "Can't create TCP/IP socket (10106)" usually means that the variables_order configure directive doesn't contain character E. On Windows, if the environment is not copied the SYSTEMROOT environment variable won't be available and PHP will have problems loading Winsock.

Ayrıca Bakınız

  • mysqli_real_connect() - Opens a connection to a mysql server
  • mysqli_options() - Set options
  • mysqli_connect_errno() - Returns the error code from last connect call
  • mysqli_connect_error() - Returns a string description of the last connect error
  • mysqli_close() - Closes a previously opened database connection

mysqli::$connect_error
mysqli::debug
mysqli


Performs debugging operations

mysqli::__construct
mysqli::dump_debug_info
mysqli
PHP Manual

mysqli::debug

mysqli_debug

(PHP 5, PHP 7)

mysqli::debug -- mysqli_debug — Performs debugging operations

Açıklama

Nesne yönelimli kullanım

bool mysqli::debug ( string $message )

Yordamsal kullanım

bool mysqli_debug ( string $message )

Performs debugging operations using the Fred Fish debugging library.

Değiştirgeler

message

A string representing the debugging operation to perform

Dönen Değerler

Returns TRUE.

Notlar

Bilginize:

To use the mysqli_debug() function you must compile the MySQL client library to support debugging.

Örnekler

Örnek 1 Generating a Trace File

<?php

/* Create a trace file in '/tmp/client.trace' on the local (client) machine: */
mysqli_debug("d:t:o,/tmp/client.trace");

?>

Ayrıca Bakınız

  • mysqli_dump_debug_info() - Dump debugging information into the log
  • mysqli_report() - Takma Adı: mysqli_driver->report_mode

mysqli::__construct
mysqli::dump_debug_info
mysqli


Dump debugging information into the log

mysqli::debug
mysqli::$errno
mysqli
PHP Manual

mysqli::dump_debug_info

mysqli_dump_debug_info

(PHP 5, PHP 7)

mysqli::dump_debug_info -- mysqli_dump_debug_info — Dump debugging information into the log

Açıklama

Nesne yönelimli kullanım

bool mysqli::dump_debug_info ( void )

Yordamsal kullanım

bool mysqli_dump_debug_info ( mysqli $link )

This function is designed to be executed by an user with the SUPER privilege and is used to dump debugging information into the log for the MySQL Server relating to the connection.

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • mysqli_debug() - Performs debugging operations

mysqli::debug
mysqli::$errno
mysqli


Returns the error code for the most recent function call

mysqli::dump_debug_info
mysqli::$error_list
mysqli
PHP Manual

mysqli::$errno

mysqli_errno

(PHP 5, PHP 7)

mysqli::$errno -- mysqli_errno — Returns the error code for the most recent function call

Açıklama

Nesne yönelimli kullanım

int $mysqli->errno;

Yordamsal kullanım

int mysqli_errno ( mysqli $link )

Returns the last error code for the most recent MySQLi function call that can succeed or fail.

Client error message numbers are listed in the MySQL errmsg.h header file, server error message numbers are listed in mysqld_error.h. In the MySQL source distribution you can find a complete list of error messages and error numbers in the file Docs/mysqld_error.txt.

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

Dönen Değerler

An error code value for the last call, if it failed. zero means no error occurred.

Örnekler

Örnek 1 $mysqli->errno example

Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if ($mysqli->connect_errno) {
    printf("Connect failed: %s\n", $mysqli->connect_error);
    exit();
}

if (!$mysqli->query("SET a=1")) {
    printf("Errorcode: %d\n", $mysqli->errno);
}

/* close connection */
$mysqli->close();
?>

Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if (!mysqli_query($link, "SET a=1")) {
    printf("Errorcode: %d\n", mysqli_errno($link));
}

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Errorcode: 1193

Ayrıca Bakınız

  • mysqli_connect_errno() - Returns the error code from last connect call
  • mysqli_connect_error() - Returns a string description of the last connect error
  • mysqli_error() - Returns a string description of the last error
  • mysqli_sqlstate() - Returns the SQLSTATE error from previous MySQL operation

mysqli::dump_debug_info
mysqli::$error_list
mysqli


Returns a list of errors from the last command executed

mysqli::$errno
mysqli::$error
mysqli
PHP Manual

mysqli::$error_list

mysqli_error_list

(PHP 5 >= 5.4.0, PHP 7)

mysqli::$error_list -- mysqli_error_list — Returns a list of errors from the last command executed

Açıklama

Nesne yönelimli kullanım

array $mysqli->error_list;

Yordamsal kullanım

array mysqli_error_list ( mysqli $link )

Returns a array of errors for the most recent MySQLi function call that can succeed or fail.

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

Dönen Değerler

A list of errors, each as an associative array containing the errno, error, and sqlstate.

Örnekler

Örnek 1 $mysqli->error_list example

Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "nobody", "");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if (!$mysqli->query("SET a=1")) {
    print_r($mysqli->error_list);
}

/* close connection */
$mysqli->close();
?>

Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if (!mysqli_query($link, "SET a=1")) {
    print_r(mysqli_error_list($link));
}

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Array
(
    [0] => Array
        (
            [errno] => 1193
            [sqlstate] => HY000
            [error] => Unknown system variable 'a'
        )

)

Ayrıca Bakınız

  • mysqli_connect_errno() - Returns the error code from last connect call
  • mysqli_connect_error() - Returns a string description of the last connect error
  • mysqli_error() - Returns a string description of the last error
  • mysqli_sqlstate() - Returns the SQLSTATE error from previous MySQL operation

mysqli::$errno
mysqli::$error
mysqli


Returns a string description of the last error

mysqli::$error_list
mysqli::$field_count
mysqli
PHP Manual

mysqli::$error

mysqli_error

(PHP 5, PHP 7)

mysqli::$error -- mysqli_error — Returns a string description of the last error

Açıklama

Nesne yönelimli kullanım

string $mysqli->error;

Yordamsal kullanım

string mysqli_error ( mysqli $link )

Returns the last error message for the most recent MySQLi function call that can succeed or fail.

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

Dönen Değerler

A string that describes the error. An empty string if no error occurred.

Örnekler

Örnek 1 $mysqli->error example

Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if ($mysqli->connect_errno) {
    printf("Connect failed: %s\n", $mysqli->connect_error);
    exit();
}

if (!$mysqli->query("SET a=1")) {
    printf("Errormessage: %s\n", $mysqli->error);
}

/* close connection */
$mysqli->close();
?>

Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if (!mysqli_query($link, "SET a=1")) {
    printf("Errormessage: %s\n", mysqli_error($link));
}

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Errormessage: Unknown system variable 'a'

Ayrıca Bakınız

  • mysqli_connect_errno() - Returns the error code from last connect call
  • mysqli_connect_error() - Returns a string description of the last connect error
  • mysqli_errno() - Returns the error code for the most recent function call
  • mysqli_sqlstate() - Returns the SQLSTATE error from previous MySQL operation

mysqli::$error_list
mysqli::$field_count
mysqli


Returns the number of columns for the most recent query

mysqli::$error
mysqli::get_charset
mysqli
PHP Manual

mysqli::$field_count

mysqli_field_count

(PHP 5, PHP 7)

mysqli::$field_count -- mysqli_field_count — Returns the number of columns for the most recent query

Açıklama

Nesne yönelimli kullanım

int $mysqli->field_count;

Yordamsal kullanım

int mysqli_field_count ( mysqli $link )

Returns the number of columns for the most recent query on the connection represented by the link parameter. This function can be useful when using the mysqli_store_result() function to determine if the query should have produced a non-empty result set or not without knowing the nature of the query.

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

Dönen Değerler

An integer representing the number of fields in a result set.

Örnekler

Örnek 1 $mysqli->field_count example

Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "test");

$mysqli->query( "DROP TABLE IF EXISTS friends");
$mysqli->query( "CREATE TABLE friends (id int, name varchar(20))");

$mysqli->query( "INSERT INTO friends VALUES (1,'Hartmut'), (2, 'Ulf')");

$mysqli->real_query("SELECT * FROM friends");

if ($mysqli->field_count) {
    /* this was a select/show or describe query */
    $result = $mysqli->store_result();

    /* process resultset */
    $row = $result->fetch_row();

    /* free resultset */
    $result->close();
}

/* close connection */
$mysqli->close();
?>

Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "test");

mysqli_query($link, "DROP TABLE IF EXISTS friends");
mysqli_query($link, "CREATE TABLE friends (id int, name varchar(20))");

mysqli_query($link, "INSERT INTO friends VALUES (1,'Hartmut'), (2, 'Ulf')");

mysqli_real_query($link, "SELECT * FROM friends");

if (mysqli_field_count($link)) {
    /* this was a select/show or describe query */
    $result = mysqli_store_result($link);

    /* process resultset */
    $row = mysqli_fetch_row($result);

    /* free resultset */
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>
mysqli::$error
mysqli::get_charset
mysqli


Returns a character set object

mysqli::$field_count
mysqli::get_client_info
mysqli
PHP Manual

mysqli::get_charset

mysqli_get_charset

(PHP 5 >= 5.1.0, PHP 7)

mysqli::get_charset -- mysqli_get_charset — Returns a character set object

Açıklama

Nesne yönelimli kullanım

object mysqli::get_charset ( void )

Yordamsal kullanım

object mysqli_get_charset ( mysqli $link )

Returns a character set object providing several properties of the current active character set.

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

Dönen Değerler

The function returns a character set object with the following properties:

charset

Character set name

collation

Collation name

dir

Directory the charset description was fetched from (?) or "" for built-in character sets

min_length

Minimum character length in bytes

max_length

Maximum character length in bytes

number

Internal character set number

state

Character set status (?)

Örnekler

Örnek 1 mysqli::get_charset() example

Nesne yönelimli kullanım

<?php
  $db = mysqli_init();
  $db->real_connect("localhost","root","","test");
  var_dump($db->get_charset());
?>

Yordamsal kullanım

<?php
  $db = mysqli_init();
  mysqli_real_connect($db, "localhost","root","","test");
  var_dump(mysqli_get_charset($db));
?>

Yukarıdaki örneklerin çıktısı:

object(stdClass)#2 (7) {
  ["charset"]=>
  string(6) "latin1"
  ["collation"]=>
  string(17) "latin1_swedish_ci"
  ["dir"]=>
  string(0) ""
  ["min_length"]=>
  int(1)
  ["max_length"]=>
  int(1)
  ["number"]=>
  int(8)
  ["state"]=>
  int(801)
}

Ayrıca Bakınız

  • mysqli_character_set_name() - Returns the default character set for the database connection
  • mysqli_set_charset() - Sets the default client character set

mysqli::$field_count
mysqli::get_client_info
mysqli


Get MySQL client info

mysqli::get_charset
mysqli_get_client_stats
mysqli
PHP Manual

mysqli::get_client_info

mysqli_get_client_info

(PHP 5, PHP 7)

mysqli::get_client_info -- mysqli_get_client_info — Get MySQL client info

Açıklama

Nesne yönelimli kullanım

string mysqli::get_client_info ( void )

Yordamsal kullanım

string mysqli_get_client_info ( mysqli $link )

Returns a string that represents the MySQL client library version.

Dönen Değerler

A string that represents the MySQL client library version

Örnekler

Örnek 1 mysqli_get_client_info

<?php

/* We don't need a connection to determine
   the version of mysql client library */

printf("Client library version: %s\n", mysqli_get_client_info());
?>

Ayrıca Bakınız

  • mysqli_get_client_version() - Returns the MySQL client version as an integer
  • mysqli_get_server_info() - Returns the version of the MySQL server
  • mysqli_get_server_version() - Returns the version of the MySQL server as an integer

mysqli::get_charset
mysqli_get_client_stats
mysqli


Returns client per-process statistics

mysqli::get_client_info
mysqli_get_client_version
mysqli
PHP Manual

mysqli_get_client_stats

(PHP 5 >= 5.3.0, PHP 7)

mysqli_get_client_stats — Returns client per-process statistics

Açıklama

array mysqli_get_client_stats ( void )

Returns client per-process statistics. Sadece mysqlnd ile kullanılabilir.

Değiştirgeler

Dönen Değerler

Returns an array with client stats if success, FALSE otherwise.

Örnekler

Örnek 1 A mysqli_get_client_stats() example

<?php
$link = mysqli_connect();
print_r(mysqli_get_client_stats());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [bytes_sent] => 43
    [bytes_received] => 80
    [packets_sent] => 1
    [packets_received] => 2
    [protocol_overhead_in] => 8
    [protocol_overhead_out] => 4
    [bytes_received_ok_packet] => 11
    [bytes_received_eof_packet] => 0
    [bytes_received_rset_header_packet] => 0
    [bytes_received_rset_field_meta_packet] => 0
    [bytes_received_rset_row_packet] => 0
    [bytes_received_prepare_response_packet] => 0
    [bytes_received_change_user_packet] => 0
    [packets_sent_command] => 0
    [packets_received_ok] => 1
    [packets_received_eof] => 0
    [packets_received_rset_header] => 0
    [packets_received_rset_field_meta] => 0
    [packets_received_rset_row] => 0
    [packets_received_prepare_response] => 0
    [packets_received_change_user] => 0
    [result_set_queries] => 0
    [non_result_set_queries] => 0
    [no_index_used] => 0
    [bad_index_used] => 0
    [slow_queries] => 0
    [buffered_sets] => 0
    [unbuffered_sets] => 0
    [ps_buffered_sets] => 0
    [ps_unbuffered_sets] => 0
    [flushed_normal_sets] => 0
    [flushed_ps_sets] => 0
    [ps_prepared_never_executed] => 0
    [ps_prepared_once_executed] => 0
    [rows_fetched_from_server_normal] => 0
    [rows_fetched_from_server_ps] => 0
    [rows_buffered_from_client_normal] => 0
    [rows_buffered_from_client_ps] => 0
    [rows_fetched_from_client_normal_buffered] => 0
    [rows_fetched_from_client_normal_unbuffered] => 0
    [rows_fetched_from_client_ps_buffered] => 0
    [rows_fetched_from_client_ps_unbuffered] => 0
    [rows_fetched_from_client_ps_cursor] => 0
    [rows_skipped_normal] => 0
    [rows_skipped_ps] => 0
    [copy_on_write_saved] => 0
    [copy_on_write_performed] => 0
    [command_buffer_too_small] => 0
    [connect_success] => 1
    [connect_failure] => 0
    [connection_reused] => 0
    [reconnect] => 0
    [pconnect_success] => 0
    [active_connections] => 1
    [active_persistent_connections] => 0
    [explicit_close] => 0
    [implicit_close] => 0
    [disconnect_close] => 0
    [in_middle_of_command_close] => 0
    [explicit_free_result] => 0
    [implicit_free_result] => 0
    [explicit_stmt_close] => 0
    [implicit_stmt_close] => 0
    [mem_emalloc_count] => 0
    [mem_emalloc_ammount] => 0
    [mem_ecalloc_count] => 0
    [mem_ecalloc_ammount] => 0
    [mem_erealloc_count] => 0
    [mem_erealloc_ammount] => 0
    [mem_efree_count] => 0
    [mem_malloc_count] => 0
    [mem_malloc_ammount] => 0
    [mem_calloc_count] => 0
    [mem_calloc_ammount] => 0
    [mem_realloc_count] => 0
    [mem_realloc_ammount] => 0
    [mem_free_count] => 0
    [proto_text_fetched_null] => 0
    [proto_text_fetched_bit] => 0
    [proto_text_fetched_tinyint] => 0
    [proto_text_fetched_short] => 0
    [proto_text_fetched_int24] => 0
    [proto_text_fetched_int] => 0
    [proto_text_fetched_bigint] => 0
    [proto_text_fetched_decimal] => 0
    [proto_text_fetched_float] => 0
    [proto_text_fetched_double] => 0
    [proto_text_fetched_date] => 0
    [proto_text_fetched_year] => 0
    [proto_text_fetched_time] => 0
    [proto_text_fetched_datetime] => 0
    [proto_text_fetched_timestamp] => 0
    [proto_text_fetched_string] => 0
    [proto_text_fetched_blob] => 0
    [proto_text_fetched_enum] => 0
    [proto_text_fetched_set] => 0
    [proto_text_fetched_geometry] => 0
    [proto_text_fetched_other] => 0
    [proto_binary_fetched_null] => 0
    [proto_binary_fetched_bit] => 0
    [proto_binary_fetched_tinyint] => 0
    [proto_binary_fetched_short] => 0
    [proto_binary_fetched_int24] => 0
    [proto_binary_fetched_int] => 0
    [proto_binary_fetched_bigint] => 0
    [proto_binary_fetched_decimal] => 0
    [proto_binary_fetched_float] => 0
    [proto_binary_fetched_double] => 0
    [proto_binary_fetched_date] => 0
    [proto_binary_fetched_year] => 0
    [proto_binary_fetched_time] => 0
    [proto_binary_fetched_datetime] => 0
    [proto_binary_fetched_timestamp] => 0
    [proto_binary_fetched_string] => 0
    [proto_binary_fetched_blob] => 0
    [proto_binary_fetched_enum] => 0
    [proto_binary_fetched_set] => 0
    [proto_binary_fetched_geometry] => 0
    [proto_binary_fetched_other] => 0
)

Ayrıca Bakınız

  • Stats description

mysqli::get_client_info
mysqli_get_client_version
mysqli


Returns the MySQL client version as an integer

mysqli_get_client_stats
mysqli::get_connection_stats
mysqli
PHP Manual

mysqli_get_client_version

mysqli::$client_version

(PHP 5, PHP 7)

mysqli_get_client_version -- mysqli::$client_version — Returns the MySQL client version as an integer

Açıklama

Nesne yönelimli kullanım

int $mysqli->client_version;

Yordamsal kullanım

int mysqli_get_client_version ( mysqli $link )

Returns client version number as an integer.

Dönen Değerler

A number that represents the MySQL client library version in format: main_version*10000 + minor_version *100 + sub_version. For example, 4.1.0 is returned as 40100.

This is useful to quickly determine the version of the client library to know if some capability exits.

Örnekler

Örnek 1 mysqli_get_client_version

<?php

/* We don't need a connection to determine
   the version of mysql client library */

printf("Client library version: %d\n", mysqli_get_client_version());
?>

Ayrıca Bakınız

  • mysqli_get_client_info() - Get MySQL client info
  • mysqli_get_server_info() - Returns the version of the MySQL server
  • mysqli_get_server_version() - Returns the version of the MySQL server as an integer

mysqli_get_client_stats
mysqli::get_connection_stats
mysqli


Returns statistics about the client connection

mysqli_get_client_version
mysqli::$host_info
mysqli
PHP Manual

mysqli::get_connection_stats

mysqli_get_connection_stats

(PHP 5 >= 5.3.0, PHP 7)

mysqli::get_connection_stats -- mysqli_get_connection_stats — Returns statistics about the client connection

Açıklama

Nesne yönelimli kullanım

bool mysqli::get_connection_stats ( void )

Yordamsal kullanım

array mysqli_get_connection_stats ( mysqli $link )

Returns statistics about the client connection. Sadece mysqlnd ile kullanılabilir.

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

Dönen Değerler

Returns an array with connection stats if success, FALSE otherwise.

Örnekler

Örnek 1 A mysqli_get_connection_stats() example

<?php
$link = mysqli_connect();
print_r(mysqli_get_connection_stats($link));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [bytes_sent] => 43
    [bytes_received] => 80
    [packets_sent] => 1
    [packets_received] => 2
    [protocol_overhead_in] => 8
    [protocol_overhead_out] => 4
    [bytes_received_ok_packet] => 11
    [bytes_received_eof_packet] => 0
    [bytes_received_rset_header_packet] => 0
    [bytes_received_rset_field_meta_packet] => 0
    [bytes_received_rset_row_packet] => 0
    [bytes_received_prepare_response_packet] => 0
    [bytes_received_change_user_packet] => 0
    [packets_sent_command] => 0
    [packets_received_ok] => 1
    [packets_received_eof] => 0
    [packets_received_rset_header] => 0
    [packets_received_rset_field_meta] => 0
    [packets_received_rset_row] => 0
    [packets_received_prepare_response] => 0
    [packets_received_change_user] => 0
    [result_set_queries] => 0
    [non_result_set_queries] => 0
    [no_index_used] => 0
    [bad_index_used] => 0
    [slow_queries] => 0
    [buffered_sets] => 0
    [unbuffered_sets] => 0
    [ps_buffered_sets] => 0
    [ps_unbuffered_sets] => 0
    [flushed_normal_sets] => 0
    [flushed_ps_sets] => 0
    [ps_prepared_never_executed] => 0
    [ps_prepared_once_executed] => 0
    [rows_fetched_from_server_normal] => 0
    [rows_fetched_from_server_ps] => 0
    [rows_buffered_from_client_normal] => 0
    [rows_buffered_from_client_ps] => 0
    [rows_fetched_from_client_normal_buffered] => 0
    [rows_fetched_from_client_normal_unbuffered] => 0
    [rows_fetched_from_client_ps_buffered] => 0
    [rows_fetched_from_client_ps_unbuffered] => 0
    [rows_fetched_from_client_ps_cursor] => 0
    [rows_skipped_normal] => 0
    [rows_skipped_ps] => 0
    [copy_on_write_saved] => 0
    [copy_on_write_performed] => 0
    [command_buffer_too_small] => 0
    [connect_success] => 1
    [connect_failure] => 0
    [connection_reused] => 0
    [reconnect] => 0
    [pconnect_success] => 0
    [active_connections] => 1
    [active_persistent_connections] => 0
    [explicit_close] => 0
    [implicit_close] => 0
    [disconnect_close] => 0
    [in_middle_of_command_close] => 0
    [explicit_free_result] => 0
    [implicit_free_result] => 0
    [explicit_stmt_close] => 0
    [implicit_stmt_close] => 0
    [mem_emalloc_count] => 0
    [mem_emalloc_ammount] => 0
    [mem_ecalloc_count] => 0
    [mem_ecalloc_ammount] => 0
    [mem_erealloc_count] => 0
    [mem_erealloc_ammount] => 0
    [mem_efree_count] => 0
    [mem_malloc_count] => 0
    [mem_malloc_ammount] => 0
    [mem_calloc_count] => 0
    [mem_calloc_ammount] => 0
    [mem_realloc_count] => 0
    [mem_realloc_ammount] => 0
    [mem_free_count] => 0
    [proto_text_fetched_null] => 0
    [proto_text_fetched_bit] => 0
    [proto_text_fetched_tinyint] => 0
    [proto_text_fetched_short] => 0
    [proto_text_fetched_int24] => 0
    [proto_text_fetched_int] => 0
    [proto_text_fetched_bigint] => 0
    [proto_text_fetched_decimal] => 0
    [proto_text_fetched_float] => 0
    [proto_text_fetched_double] => 0
    [proto_text_fetched_date] => 0
    [proto_text_fetched_year] => 0
    [proto_text_fetched_time] => 0
    [proto_text_fetched_datetime] => 0
    [proto_text_fetched_timestamp] => 0
    [proto_text_fetched_string] => 0
    [proto_text_fetched_blob] => 0
    [proto_text_fetched_enum] => 0
    [proto_text_fetched_set] => 0
    [proto_text_fetched_geometry] => 0
    [proto_text_fetched_other] => 0
    [proto_binary_fetched_null] => 0
    [proto_binary_fetched_bit] => 0
    [proto_binary_fetched_tinyint] => 0
    [proto_binary_fetched_short] => 0
    [proto_binary_fetched_int24] => 0
    [proto_binary_fetched_int] => 0
    [proto_binary_fetched_bigint] => 0
    [proto_binary_fetched_decimal] => 0
    [proto_binary_fetched_float] => 0
    [proto_binary_fetched_double] => 0
    [proto_binary_fetched_date] => 0
    [proto_binary_fetched_year] => 0
    [proto_binary_fetched_time] => 0
    [proto_binary_fetched_datetime] => 0
    [proto_binary_fetched_timestamp] => 0
    [proto_binary_fetched_string] => 0
    [proto_binary_fetched_blob] => 0
    [proto_binary_fetched_enum] => 0
    [proto_binary_fetched_set] => 0
    [proto_binary_fetched_geometry] => 0
    [proto_binary_fetched_other] => 0
)

Ayrıca Bakınız

  • Stats description

mysqli_get_client_version
mysqli::$host_info
mysqli


Returns a string representing the type of connection used

mysqli::get_connection_stats
mysqli::$protocol_version
mysqli
PHP Manual

mysqli::$host_info

mysqli_get_host_info

(PHP 5, PHP 7)

mysqli::$host_info -- mysqli_get_host_info — Returns a string representing the type of connection used

Açıklama

Nesne yönelimli kullanım

string $mysqli->host_info;

Yordamsal kullanım

string mysqli_get_host_info ( mysqli $link )

Returns a string describing the connection represented by the link parameter (including the server host name).

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

Dönen Değerler

A character string representing the server hostname and the connection type.

Örnekler

Örnek 1 $mysqli->host_info example

Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* print host information */
printf("Host info: %s\n", $mysqli->host_info);

/* close connection */
$mysqli->close();
?>

Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* print host information */
printf("Host info: %s\n", mysqli_get_host_info($link));

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Host info: Localhost via UNIX socket

Ayrıca Bakınız

  • mysqli_get_proto_info() - Returns the version of the MySQL protocol used

mysqli::get_connection_stats
mysqli::$protocol_version
mysqli


Returns the version of the MySQL protocol used

mysqli::$host_info
mysqli::$server_info
mysqli
PHP Manual

mysqli::$protocol_version

mysqli_get_proto_info

(PHP 5, PHP 7)

mysqli::$protocol_version -- mysqli_get_proto_info — Returns the version of the MySQL protocol used

Açıklama

Nesne yönelimli kullanım

string $mysqli->protocol_version;

Yordamsal kullanım

int mysqli_get_proto_info ( mysqli $link )

Returns an integer representing the MySQL protocol version used by the connection represented by the link parameter.

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

Dönen Değerler

Returns an integer representing the protocol version.

Örnekler

Örnek 1 $mysqli->protocol_version example

Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* print protocol version */
printf("Protocol version: %d\n", $mysqli->protocol_version);

/* close connection */
$mysqli->close();
?>

Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* print protocol version */
printf("Protocol version: %d\n", mysqli_get_proto_info($link));

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Protocol version: 10

Ayrıca Bakınız

  • mysqli_get_host_info() - Returns a string representing the type of connection used

mysqli::$host_info
mysqli::$server_info
mysqli


Returns the version of the MySQL server

mysqli::$protocol_version
mysqli::$server_version
mysqli
PHP Manual

mysqli::$server_info

mysqli_get_server_info

(PHP 5, PHP 7)

mysqli::$server_info -- mysqli_get_server_info — Returns the version of the MySQL server

Açıklama

Nesne yönelimli kullanım

string $mysqli->server_info;

Yordamsal kullanım

string mysqli_get_server_info ( mysqli $link )

Returns a string representing the version of the MySQL server that the MySQLi extension is connected to.

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

Dönen Değerler

A character string representing the server version.

Örnekler

Örnek 1 $mysqli->server_info example

Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* print server version */
printf("Server version: %s\n", $mysqli->server_info);

/* close connection */
$mysqli->close();
?>

Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* print server version */
printf("Server version: %s\n", mysqli_get_server_info($link));

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Server version: 4.1.2-alpha-debug

Ayrıca Bakınız

  • mysqli_get_client_info() - Get MySQL client info
  • mysqli_get_client_version() - Returns the MySQL client version as an integer
  • mysqli_get_server_version() - Returns the version of the MySQL server as an integer

mysqli::$protocol_version
mysqli::$server_version
mysqli


Returns the version of the MySQL server as an integer

mysqli::$server_info
mysqli::get_warnings
mysqli
PHP Manual

mysqli::$server_version

mysqli_get_server_version

(PHP 5, PHP 7)

mysqli::$server_version -- mysqli_get_server_version — Returns the version of the MySQL server as an integer

Açıklama

Nesne yönelimli kullanım

int $mysqli->server_version;

Yordamsal kullanım

int mysqli_get_server_version ( mysqli $link )

The mysqli_get_server_version() function returns the version of the server connected to (represented by the link parameter) as an integer.

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

Dönen Değerler

An integer representing the server version.

The form of this version number is main_version * 10000 + minor_version * 100 + sub_version (i.e. version 4.1.0 is 40100).

Örnekler

Örnek 1 $mysqli->server_version example

Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* print server version */
printf("Server version: %d\n", $mysqli->server_version);

/* close connection */
$mysqli->close();
?>

Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* print server version */
printf("Server version: %d\n", mysqli_get_server_version($link));

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Server version: 40102

Ayrıca Bakınız

  • mysqli_get_client_info() - Get MySQL client info
  • mysqli_get_client_version() - Returns the MySQL client version as an integer
  • mysqli_get_server_info() - Returns the version of the MySQL server

mysqli::$server_info
mysqli::get_warnings
mysqli


Get result of SHOW WARNINGS

mysqli::$server_version
mysqli::$info
mysqli
PHP Manual

mysqli::get_warnings

mysqli_get_warnings

(PHP 5 >= 5.1.0, PHP 7)

mysqli::get_warnings -- mysqli_get_warnings — Get result of SHOW WARNINGS

Açıklama

Nesne yönelimli kullanım

mysqli_warning mysqli::get_warnings ( void )

Yordamsal kullanım

mysqli_warning mysqli_get_warnings ( mysqli $link )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

mysqli::$server_version
mysqli::$info
mysqli


Retrieves information about the most recently executed query

mysqli::get_warnings
mysqli::init
mysqli
PHP Manual

mysqli::$info

mysqli_info

(PHP 5, PHP 7)

mysqli::$info -- mysqli_info — Retrieves information about the most recently executed query

Açıklama

Nesne yönelimli kullanım

string $mysqli->info;

Yordamsal kullanım

string mysqli_info ( mysqli $link )

The mysqli_info() function returns a string providing information about the last query executed. The nature of this string is provided below:

Possible mysqli_info return values
Query type | Example result string
INSERT INTO...SELECT... | Records: 100 Duplicates: 0 Warnings: 0
INSERT INTO...VALUES (...),(...),(...) | Records: 3 Duplicates: 0 Warnings: 0
LOAD DATA INFILE ... | Records: 1 Deleted: 0 Skipped: 0 Warnings: 0
ALTER TABLE ... | Records: 3 Duplicates: 0 Warnings: 0
UPDATE ... | Rows matched: 40 Changed: 40 Warnings: 0

Bilginize:

Queries which do not fall into one of the preceding formats are not supported. In these situations, mysqli_info() will return an empty string.

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

Dönen Değerler

A character string representing additional information about the most recently executed query.

Örnekler

Örnek 1 $mysqli->info example

Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TEMPORARY TABLE t1 LIKE City");

/* INSERT INTO .. SELECT */
$mysqli->query("INSERT INTO t1 SELECT * FROM City ORDER BY ID LIMIT 150");
printf("%s\n", $mysqli->info);

/* close connection */
$mysqli->close();
?>

Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($link, "CREATE TEMPORARY TABLE t1 LIKE City");

/* INSERT INTO .. SELECT */
mysqli_query($link, "INSERT INTO t1 SELECT * FROM City ORDER BY ID LIMIT 150");
printf("%s\n", mysqli_info($link));

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Records: 150  Duplicates: 0  Warnings: 0

Ayrıca Bakınız

  • mysqli_affected_rows() - Gets the number of affected rows in a previous MySQL operation
  • mysqli_warning_count() - Returns the number of warnings from the last query for the given link
  • mysqli_num_rows() - Gets the number of rows in a result

mysqli::get_warnings
mysqli::init
mysqli


Initializes MySQLi and returns a resource for use with mysqli_real_connect()

mysqli::$info
mysqli::$insert_id
mysqli
PHP Manual

mysqli::init

mysqli_init

(PHP 5, PHP 7)

mysqli::init -- mysqli_init — Initializes MySQLi and returns a resource for use with mysqli_real_connect()

Açıklama

Nesne yönelimli kullanım

mysqli mysqli::init ( void )

Yordamsal kullanım

mysqli mysqli_init ( void )

Allocates or initializes a MYSQL object suitable for mysqli_options() and mysqli_real_connect().

Bilginize:

Any subsequent calls to any mysqli function (except mysqli_options()) will fail until mysqli_real_connect() was called.

Dönen Değerler

Returns an object.

Örnekler

See mysqli_real_connect().

Ayrıca Bakınız

  • mysqli_options() - Set options
  • mysqli_close() - Closes a previously opened database connection
  • mysqli_real_connect() - Opens a connection to a mysql server
  • mysqli_connect() - Takma Adı: mysqli::__construct

mysqli::$info
mysqli::$insert_id
mysqli


Returns the auto generated id used in the latest query

mysqli::init
mysqli::kill
mysqli
PHP Manual

mysqli::$insert_id

mysqli_insert_id

(PHP 5, PHP 7)

mysqli::$insert_id -- mysqli_insert_id — Returns the auto generated id used in the latest query

Açıklama

Nesne yönelimli kullanım

mixed $mysqli->insert_id;

Yordamsal kullanım

mixed mysqli_insert_id ( mysqli $link )

The mysqli_insert_id() function returns the ID generated by a query on a table with a column having the AUTO_INCREMENT attribute. If the last query wasn't an INSERT or UPDATE statement or if the modified table does not have a column with the AUTO_INCREMENT attribute, this function will return zero.

Bilginize:

Performing an INSERT or UPDATE statement using the LAST_INSERT_ID() function will also modify the value returned by the mysqli_insert_id() function.

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

Dönen Değerler

The value of the AUTO_INCREMENT field that was updated by the previous query. Returns zero if there was no previous query on the connection or if the query did not update an AUTO_INCREMENT value.

Bilginize:

If the number is greater than maximal int value, mysqli_insert_id() will return a string.

Örnekler

Örnek 1 $mysqli->insert_id example

Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TABLE myCity LIKE City");

$query = "INSERT INTO myCity VALUES (NULL, 'Stuttgart', 'DEU', 'Stuttgart', 617000)";
$mysqli->query($query);

printf ("New Record has id %d.\n", $mysqli->insert_id);

/* drop table */
$mysqli->query("DROP TABLE myCity");

/* close connection */
$mysqli->close();
?>

Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($link, "CREATE TABLE myCity LIKE City");

$query = "INSERT INTO myCity VALUES (NULL, 'Stuttgart', 'DEU', 'Stuttgart', 617000)";
mysqli_query($link, $query);

printf ("New Record has id %d.\n", mysqli_insert_id($link));

/* drop table */
mysqli_query($link, "DROP TABLE myCity");

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

New Record has id 1.
mysqli::init
mysqli::kill
mysqli


Asks the server to kill a MySQL thread

mysqli::$insert_id
mysqli::more_results
mysqli
PHP Manual

mysqli::kill

mysqli_kill

(PHP 5, PHP 7)

mysqli::kill -- mysqli_kill — Asks the server to kill a MySQL thread

Açıklama

Nesne yönelimli kullanım

bool mysqli::kill ( int $processid )

Yordamsal kullanım

bool mysqli_kill ( mysqli $link , int $processid )

This function is used to ask the server to kill a MySQL thread specified by the processid parameter. This value must be retrieved by calling the mysqli_thread_id() function.

To stop a running query you should use the SQL command KILL QUERY processid.

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 mysqli::kill() example

Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* determine our thread id */
$thread_id = $mysqli->thread_id;

/* Kill connection */
$mysqli->kill($thread_id);

/* This should produce an error */
if (!$mysqli->query("CREATE TABLE myCity LIKE City")) {
    printf("Error: %s\n", $mysqli->error);
    exit;
}

/* close connection */
$mysqli->close();
?>

Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* determine our thread id */
$thread_id = mysqli_thread_id($link);

/* Kill connection */
mysqli_kill($link, $thread_id);

/* This should produce an error */
if (!mysqli_query($link, "CREATE TABLE myCity LIKE City")) {
    printf("Error: %s\n", mysqli_error($link));
    exit;
}

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Error: MySQL server has gone away

Ayrıca Bakınız

  • mysqli_thread_id() - Returns the thread ID for the current connection

mysqli::$insert_id
mysqli::more_results
mysqli


Check if there are any more query results from a multi query

mysqli::kill
mysqli::multi_query
mysqli
PHP Manual

mysqli::more_results

mysqli_more_results

(PHP 5, PHP 7)

mysqli::more_results -- mysqli_more_results — Check if there are any more query results from a multi query

Açıklama

Nesne yönelimli kullanım

bool mysqli::more_results ( void )

Yordamsal kullanım

bool mysqli_more_results ( mysqli $link )

Indicates if one or more result sets are available from a previous call to mysqli_multi_query().

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

Dönen Değerler

Returns TRUE if one or more result sets are available from a previous call to mysqli_multi_query(), otherwise FALSE.

Örnekler

See mysqli_multi_query().

Ayrıca Bakınız

  • mysqli_multi_query() - Performs a query on the database
  • mysqli_next_result() - Prepare next result from multi_query
  • mysqli_store_result() - Transfers a result set from the last query
  • mysqli_use_result() - Initiate a result set retrieval

mysqli::kill
mysqli::multi_query
mysqli


Performs a query on the database

mysqli::more_results
mysqli::next_result
mysqli
PHP Manual

mysqli::multi_query

mysqli_multi_query

(PHP 5, PHP 7)

mysqli::multi_query -- mysqli_multi_query — Performs a query on the database

Açıklama

Nesne yönelimli kullanım

bool mysqli::multi_query ( string $query )

Yordamsal kullanım

bool mysqli_multi_query ( mysqli $link , string $query )

Executes one or multiple queries which are concatenated by a semicolon.

To retrieve the resultset from the first query you can use mysqli_use_result() or mysqli_store_result(). All subsequent query results can be processed using mysqli_more_results() and mysqli_next_result().

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

query

The query, as a string.

Data inside the query should be properly escaped.

Dönen Değerler

Returns FALSE if the first statement failed. To retrieve subsequent errors from other statements you have to call mysqli_next_result() first.

Örnekler

Örnek 1 mysqli::multi_query() example

Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query  = "SELECT CURRENT_USER();";
$query .= "SELECT Name FROM City ORDER BY ID LIMIT 20, 5";

/* execute multi query */
if ($mysqli->multi_query($query)) {
    do {
        /* store first result set */
        if ($result = $mysqli->store_result()) {
            while ($row = $result->fetch_row()) {
                printf("%s\n", $row[0]);
            }
            $result->free();
        }
        /* print divider */
        if ($mysqli->more_results()) {
            printf("-----------------\n");
        }
    } while ($mysqli->next_result());
}

/* close connection */
$mysqli->close();
?>

Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query  = "SELECT CURRENT_USER();";
$query .= "SELECT Name FROM City ORDER BY ID LIMIT 20, 5";

/* execute multi query */
if (mysqli_multi_query($link, $query)) {
    do {
        /* store first result set */
        if ($result = mysqli_store_result($link)) {
            while ($row = mysqli_fetch_row($result)) {
                printf("%s\n", $row[0]);
            }
            mysqli_free_result($result);
        }
        /* print divider */
        if (mysqli_more_results($link)) {
            printf("-----------------\n");
        }
    } while (mysqli_next_result($link));
}

/* close connection */
mysqli_close($link);
?>

The above examples will output something similar to:

my_user@localhost
-----------------
Amersfoort
Maastricht
Dordrecht
Leiden
Haarlemmermeer

Ayrıca Bakınız

  • mysqli_query() - Performs a query on the database
  • mysqli_use_result() - Initiate a result set retrieval
  • mysqli_store_result() - Transfers a result set from the last query
  • mysqli_next_result() - Prepare next result from multi_query
  • mysqli_more_results() - Check if there are any more query results from a multi query

mysqli::more_results
mysqli::next_result
mysqli


Prepare next result from multi_query

mysqli::multi_query
mysqli::options
mysqli
PHP Manual

mysqli::next_result

mysqli_next_result

(PHP 5, PHP 7)

mysqli::next_result -- mysqli_next_result — Prepare next result from multi_query

Açıklama

Nesne yönelimli kullanım

bool mysqli::next_result ( void )

Yordamsal kullanım

bool mysqli_next_result ( mysqli $link )

Prepares next result set from a previous call to
mysqli_multi_query() which can be retrieved by
mysqli_store_result() or
mysqli_use_result().

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

See mysqli_multi_query().

Ayrıca Bakınız

  • mysqli_multi_query() - Performs a query on the database
  • mysqli_more_results() - Check if there are any more query results from a multi query
  • mysqli_store_result() - Transfers a result set from the last query
  • mysqli_use_result() - Initiate a result set retrieval

mysqli::multi_query
mysqli::options
mysqli


Set options

mysqli::next_result
mysqli::ping
mysqli
PHP Manual

mysqli::options

mysqli_options

(PHP 5, PHP 7)

mysqli::options -- mysqli_options — Set options

Açıklama

Nesne yönelimli kullanım

bool mysqli::options ( int $option , mixed $value )

Yordamsal kullanım

bool mysqli_options ( mysqli $link , int $option , mixed $value )

Used to set extra connect options and affect behavior for a connection.

This function may be called multiple times to set several options.

mysqli_options() should be called after
mysqli_init() and before
mysqli_real_connect().

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

option

The option that you want to set. It can be one of the following values:

Valid options
Name | Description
MYSQLI_OPT_CONNECT_TIMEOUT | connection timeout in seconds (supported on Windows with TCP/IP since PHP 5.3.1)
MYSQLI_OPT_LOCAL_INFILE | enable/disable use of LOAD LOCAL INFILE
MYSQLI_INIT_COMMAND | command to execute after when connecting to MySQL server
MYSQLI_READ_DEFAULT_FILE | Read options from named option file instead of my.cnf
MYSQLI_READ_DEFAULT_GROUP | Read options from the named group from my.cnf or the file specified with MYSQL_READ_DEFAULT_FILE.
MYSQLI_SERVER_PUBLIC_KEY | RSA public key file used with the SHA-256 based authentication.
MYSQLI_OPT_NET_CMD_BUFFER_SIZE | The size of the internal command/network buffer. Only valid for mysqlnd.
MYSQLI_OPT_NET_READ_BUFFER_SIZE | Maximum read chunk size in bytes when reading the body of a MySQL command packet. Only valid for mysqlnd.
MYSQLI_OPT_INT_AND_FLOAT_NATIVE | Convert integer and float columns back to PHP numbers. Only valid for mysqlnd.
MYSQLI_OPT_SSL_VERIFY_SERVER_CERT

value

The value for the option.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.5.0 | The MYSQLI_SERVER_PUBLIC_KEY and MYSQLI_SERVER_PUBLIC_KEY options were added.
5.3.0 | The MYSQLI_OPT_INT_AND_FLOAT_NATIVE, MYSQLI_OPT_NET_CMD_BUFFER_SIZE, MYSQLI_OPT_NET_READ_BUFFER_SIZE, and MYSQLI_OPT_SSL_VERIFY_SERVER_CERT options were added.

Örnekler

See mysqli_real_connect().

Notlar

Bilginize:

MySQLnd daima sunucunun öntanımlı bir karakter kümesi olduğunu varsayar. Bu karakter kümesi, mysqlnd'nin kullanacağı uzlaşım/kimlik doğrulama bağlantısı sırasında gönderilir.

Libmysqlclient, ya my.cnf dosyasındaki öntanımlı karakter kümesini ya da mysqli_init() çağrısından sonraki ilk mysqli_real_connect() çağrısındaan önce çağrılan mysqli_options() işlevinde belirtilen karakter kümesini kullanır.

Ayrıca Bakınız

  • mysqli_init() - Initializes MySQLi and returns a resource for use with mysqli_real_connect()
  • mysqli_real_connect() - Opens a connection to a mysql server

mysqli::next_result
mysqli::ping
mysqli


Pings a server connection, or tries to reconnect if the connection has gone down

mysqli::options
mysqli::poll
mysqli
PHP Manual

mysqli::ping

mysqli_ping

(PHP 5, PHP 7)

mysqli::ping -- mysqli_ping — Pings a server connection, or tries to reconnect if the connection has gone down

Açıklama

Nesne yönelimli kullanım

bool mysqli::ping ( void )

Yordamsal kullanım

bool mysqli_ping ( mysqli $link )

Checks whether the connection to the server is working. If it has gone down and global option mysqli.reconnect is enabled, an automatic reconnection is attempted.

Bilginize: The php.ini setting mysqli.reconnect is ignored by the mysqlnd driver, so automatic reconnection is never attempted.

This function can be used by clients that remain idle for a long while, to check whether the server has closed the connection and reconnect if necessary.

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 mysqli::ping() example

Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if ($mysqli->connect_errno) {
    printf("Connect failed: %s\n", $mysqli->connect_error);
    exit();
}

/* check if server is alive */
if ($mysqli->ping()) {
    printf ("Our connection is ok!\n");
} else {
    printf ("Error: %s\n", $mysqli->error);
}

/* close connection */
$mysqli->close();
?>

Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* check if server is alive */
if (mysqli_ping($link)) {
    printf ("Our connection is ok!\n");
} else {
    printf ("Error: %s\n", mysqli_error($link));
}

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Our connection is ok!
mysqli::options
mysqli::poll
mysqli


Poll connections

mysqli::ping
mysqli::prepare
mysqli
PHP Manual

mysqli::poll

mysqli_poll

(PHP 5 >= 5.3.0, PHP 7)

mysqli::poll -- mysqli_poll — Poll connections

Açıklama

Nesne yönelimli kullanım

public static int mysqli::poll ( array &$read , array &$error , array &$reject , int $sec [, int $usec ] )

Yordamsal kullanım

int mysqli_poll ( array &$read , array &$error , array &$reject , int $sec [, int $usec ] )

Poll connections. Sadece mysqlnd ile kullanılabilir. The method can be used as static.

Değiştirgeler

read

List of connections to check for outstanding results that can be read.

error

List of connections on which an error occured, for example, query failure or lost connection.

reject

List of connections rejected because no asynchronous query has been run on for which the function could poll results.

sec

Number of seconds to wait, must be non-negative.

usec

Number of microseconds to wait, must be non-negative.

Dönen Değerler

Returns number of ready connections upon success, FALSE otherwise.

Örnekler

Örnek 1 A mysqli_poll() example

<?php
$link1 = mysqli_connect();
$link1->query("SELECT 'test'", MYSQLI_ASYNC);
$all_links = array($link1);
$processed = 0;
do {
    $links = $errors = $reject = array();
    foreach ($all_links as $link) {
        $links[] = $errors[] = $reject[] = $link;
    }
    if (!mysqli_poll($links, $errors, $reject, 1)) {
        continue;
    }
    foreach ($links as $link) {
        if ($result = $link->reap_async_query()) {
            print_r($result->fetch_row());
            if (is_object($result))
                mysqli_free_result($result);
        } else die(sprintf("MySQLi Error: %s", mysqli_error($link)));
        $processed++;
    }
} while ($processed < count($all_links));
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [0] => test
)

Ayrıca Bakınız

  • mysqli_query() - Performs a query on the database
  • mysqli_reap_async_query() - Get result from async query

mysqli::ping
mysqli::prepare
mysqli


Prepare an SQL statement for execution

mysqli::poll
mysqli::query
mysqli
PHP Manual

mysqli::prepare

mysqli_prepare

(PHP 5, PHP 7)

mysqli::prepare -- mysqli_prepare — Prepare an SQL statement for execution

Açıklama

Nesne yönelimli kullanım

mysqli_stmt mysqli::prepare ( string $query )

Yordamsal kullanım

mysqli_stmt mysqli_prepare ( mysqli $link , string $query )

Prepares the SQL query, and returns a statement handle to be used for further operations on the statement. The query must consist of a single SQL statement.

The parameter markers must be bound to application variables using mysqli_stmt_bind_param() and/or mysqli_stmt_bind_result() before executing the statement or fetching rows.

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

query

The query, as a string.

Bilginize:

You should not add a terminating semicolon or \g to the statement.

This parameter can include one or more parameter markers in the SQL statement by embedding question mark (?) characters at the appropriate positions.

Bilginize:

The markers are legal only in certain places in SQL statements. For example, they are allowed in the VALUES() list of an INSERT statement (to specify column values for a row), or in a comparison with a column in a WHERE clause to specify a comparison value.

However, they are not allowed for identifiers (such as table or column names), in the select list that names the columns to be returned by a SELECT statement, or to specify both operands of a binary operator such as the = equal sign. The latter restriction is necessary because it would be impossible to determine the parameter type. It's not allowed to compare marker with NULL by ? IS NULL too. In general, parameters are legal only in Data Manipulation Language (DML) statements, and not in Data Definition Language (DDL) statements.

Dönen Değerler

mysqli_prepare() returns a statement object or FALSE if an error occurred.

Örnekler

Örnek 1 mysqli::prepare() example

Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$city = "Amersfoort";

/* create a prepared statement */
if ($stmt = $mysqli->prepare("SELECT District FROM City WHERE Name=?")) {

    /* bind parameters for markers */
    $stmt->bind_param("s", $city);

    /* execute query */
    $stmt->execute();

    /* bind result variables */
    $stmt->bind_result($district);

    /* fetch value */
    $stmt->fetch();

    printf("%s is in district %s\n", $city, $district);

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$city = "Amersfoort";

/* create a prepared statement */
if ($stmt = mysqli_prepare($link, "SELECT District FROM City WHERE Name=?")) {

    /* bind parameters for markers */
    mysqli_stmt_bind_param($stmt, "s", $city);

    /* execute query */
    mysqli_stmt_execute($stmt);

    /* bind result variables */
    mysqli_stmt_bind_result($stmt, $district);

    /* fetch value */
    mysqli_stmt_fetch($stmt);

    printf("%s is in district %s\n", $city, $district);

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Amersfoort is in district Utrecht

Ayrıca Bakınız

  • mysqli_stmt_execute() - Executes a prepared Query
  • mysqli_stmt_fetch() - Fetch results from a prepared statement into the bound variables
  • mysqli_stmt_bind_param() - Binds variables to a prepared statement as parameters
  • mysqli_stmt_bind_result() - Binds variables to a prepared statement for result storage
  • mysqli_stmt_close() - Closes a prepared statement

mysqli::poll
mysqli::query
mysqli


Performs a query on the database

mysqli::prepare
mysqli::real_connect
mysqli
PHP Manual

mysqli::query

mysqli_query

(PHP 5, PHP 7)

mysqli::query -- mysqli_query — Performs a query on the database

Açıklama

Nesne yönelimli kullanım

mixed mysqli::query ( string $query [, int $resultmode = MYSQLI_STORE_RESULT ] )

Yordamsal kullanım

mixed mysqli_query ( mysqli $link , string $query [, int $resultmode = MYSQLI_STORE_RESULT ] )

Performs a query against the database.

For non-DML queries (not INSERT, UPDATE or DELETE),
this function is similar to calling
mysqli_real_query() followed by either
mysqli_use_result() or
mysqli_store_result().

Bilginize:

In the case where you pass a statement to mysqli_query() that is longer than max_allowed_packet of the server, the returned error codes are different depending on whether you are using MySQL Native Driver (mysqlnd) or MySQL Client Library (libmysqlclient). The behavior is as follows:

  • mysqlnd on Linux returns an error code of 1153. The error message means "got a packet bigger than max_allowed_packet bytes".

  • mysqlnd on Windows returns an error code 2006. This error message means "server has gone away".

  • libmysqlclient on all platforms returns an error code 2006. This error message means "server has gone away".

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

query

The query string.

Data inside the query should be properly escaped.

resultmode

Either the constant MYSQLI_USE_RESULT or MYSQLI_STORE_RESULT depending on the desired behavior. By default, MYSQLI_STORE_RESULT is used.

If you use MYSQLI_USE_RESULT all subsequent calls will return error Commands out of sync unless you call mysqli_free_result()

With MYSQLI_ASYNC (available with mysqlnd), it is possible to perform query asynchronously. mysqli_poll() is then used to get results from such queries.

Dönen Değerler

Returns FALSE on failure. For successful SELECT, SHOW, DESCRIBE or EXPLAIN queries mysqli_query() will return a mysqli_result object. For other successful queries mysqli_query() will return TRUE.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | Added the ability of async queries.

Örnekler

Örnek 1 mysqli::query() example

Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if ($mysqli->connect_errno) {
    printf("Connect failed: %s\n", $mysqli->connect_error);
    exit();
}

/* Create table doesn't return a resultset */
if ($mysqli->query("CREATE TEMPORARY TABLE myCity LIKE City") === TRUE) {
    printf("Table myCity successfully created.\n");
}

/* Select queries return a resultset */
if ($result = $mysqli->query("SELECT Name FROM City LIMIT 10")) {
    printf("Select returned %d rows.\n", $result->num_rows);

    /* free result set */
    $result->close();
}

/* If we have to retrieve large amount of data we use MYSQLI_USE_RESULT */
if ($result = $mysqli->query("SELECT * FROM City", MYSQLI_USE_RESULT)) {

    /* Note, that we can't execute any functions which interact with the
       server until result set was closed. All calls will return an
       'out of sync' error */
    if (!$mysqli->query("SET @a:='this will not work'")) {
        printf("Error: %s\n", $mysqli->error);
    }
    $result->close();
}

$mysqli->close();
?>

Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* Create table doesn't return a resultset */
if (mysqli_query($link, "CREATE TEMPORARY TABLE myCity LIKE City") === TRUE) {
    printf("Table myCity successfully created.\n");
}

/* Select queries return a resultset */
if ($result = mysqli_query($link, "SELECT Name FROM City LIMIT 10")) {
    printf("Select returned %d rows.\n", mysqli_num_rows($result));

    /* free result set */
    mysqli_free_result($result);
}

/* If we have to retrieve large amount of data we use MYSQLI_USE_RESULT */
if ($result = mysqli_query($link, "SELECT * FROM City", MYSQLI_USE_RESULT)) {

    /* Note, that we can't execute any functions which interact with the
       server until result set was closed. All calls will return an
       'out of sync' error */
    if (!mysqli_query($link, "SET @a:='this will not work'")) {
        printf("Error: %s\n", mysqli_error($link));
    }
    mysqli_free_result($result);
}

mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Table myCity successfully created.
Select returned 10 rows.
Error: Commands out of sync;  You can't run this command now

Ayrıca Bakınız

  • mysqli_real_query() - Execute an SQL query
  • mysqli_multi_query() - Performs a query on the database
  • mysqli_free_result() - Frees the memory associated with a result

mysqli::prepare
mysqli::real_connect
mysqli


Opens a connection to a mysql server

mysqli::query
mysqli::real_escape_string
mysqli
PHP Manual

mysqli::real_connect

mysqli_real_connect

(PHP 5, PHP 7)

mysqli::real_connect -- mysqli_real_connect — Opens a connection to a mysql server

Açıklama

Nesne yönelimli kullanım

bool mysqli::real_connect ([ string $host [, string $username [, string $passwd [, string $dbname [, int $port [, string $socket [, int $flags ]]]]]]] )

Yordamsal kullanım

bool mysqli_real_connect ( mysqli $link [, string $host [, string $username [, string $passwd [, string $dbname [, int $port [, string $socket [, int $flags ]]]]]]] )

Establish a connection to a MySQL database engine.

This function differs from mysqli_connect():

  • mysqli_real_connect() needs a valid object which has to be created by function mysqli_init().

  • With the mysqli_options() function you can set various options for connection.

  • There is a flags parameter.

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

host

Can be either a host name or an IP address. Passing the NULL value or the string "localhost" to this parameter, the local host is assumed. When possible, pipes will be used instead of the TCP/IP protocol.

username

The MySQL user name.

passwd

If provided or NULL, the MySQL server will attempt to authenticate the user against those user records which have no password only. This allows one username to be used with different permissions (depending on if a password as provided or not).

dbname

If provided will specify the default database to be used when performing queries.

port

Specifies the port number to attempt to connect to the MySQL server.

socket

Specifies the socket or named pipe that should be used.

Bilginize:

Specifying the socket parameter will not explicitly determine the type of connection to be used when connecting to the MySQL server. How the connection is made to the MySQL database is determined by the host parameter.

flags

With the parameter flags you can set different connection options:

Supported flags
Name | Description
MYSQLI_CLIENT_COMPRESS | Use compression protocol
MYSQLI_CLIENT_FOUND_ROWS | return number of matched rows, not the number of affected rows
MYSQLI_CLIENT_IGNORE_SPACE | Allow spaces after function names. Makes all function names reserved words.
MYSQLI_CLIENT_INTERACTIVE | Allow interactive_timeout seconds (instead of wait_timeout seconds) of inactivity before closing the connection
MYSQLI_CLIENT_SSL | Use SSL (encryption)
MYSQLI_CLIENT_SSL_DONT_VERIFY_SERVER_CERT | Like MYSQLI_CLIENT_SSL, but disables validation of the provided SSL certificate. This is only for installations using MySQL Native Driver and MySQL 5.6 or later.

Bilginize:

For security reasons the MULTI_STATEMENT flag is not supported in PHP. If you want to execute multiple queries use the mysqli_multi_query() function.

Sürüm Bilgisi

Sürüm: | Açıklama
5.6.16 | Added the MYSQLI_CLIENT_SSL_DONT_VERIFY_SERVER_CERT flag for MySQL Native Driver

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 mysqli::real_connect() example

Nesne yönelimli kullanım

<?php

$mysqli = mysqli_init();
if (!$mysqli) {
    die('mysqli_init failed');
}

if (!$mysqli->options(MYSQLI_INIT_COMMAND, 'SET AUTOCOMMIT = 0')) {
    die('Setting MYSQLI_INIT_COMMAND failed');
}

if (!$mysqli->options(MYSQLI_OPT_CONNECT_TIMEOUT, 5)) {
    die('Setting MYSQLI_OPT_CONNECT_TIMEOUT failed');
}

if (!$mysqli->real_connect('localhost', 'my_user', 'my_password', 'my_db')) {
    die('Connect Error (' . mysqli_connect_errno() . ') '
            . mysqli_connect_error());
}

echo 'Success... ' . $mysqli->host_info . "\n";

$mysqli->close();
?>

Nesne yönelimli kullanım when extending mysqli class

<?php

class foo_mysqli extends mysqli {
    public function __construct($host, $user, $pass, $db) {
        parent::init();

        if (!parent::options(MYSQLI_INIT_COMMAND, 'SET AUTOCOMMIT = 0')) {
            die('Setting MYSQLI_INIT_COMMAND failed');
        }

        if (!parent::options(MYSQLI_OPT_CONNECT_TIMEOUT, 5)) {
            die('Setting MYSQLI_OPT_CONNECT_TIMEOUT failed');
        }

        if (!parent::real_connect($host, $user, $pass, $db)) {
            die('Connect Error (' . mysqli_connect_errno() . ') '
                    . mysqli_connect_error());
        }
    }
}

$db = new foo_mysqli('localhost', 'my_user', 'my_password', 'my_db');

echo 'Success... ' . $db->host_info . "\n";

$db->close();
?>

Yordamsal kullanım

<?php

$link = mysqli_init();
if (!$link) {
    die('mysqli_init failed');
}

if (!mysqli_options($link, MYSQLI_INIT_COMMAND, 'SET AUTOCOMMIT = 0')) {
    die('Setting MYSQLI_INIT_COMMAND failed');
}

if (!mysqli_options($link, MYSQLI_OPT_CONNECT_TIMEOUT, 5)) {
    die('Setting MYSQLI_OPT_CONNECT_TIMEOUT failed');
}

if (!mysqli_real_connect($link, 'localhost', 'my_user', 'my_password', 'my_db')) {
    die('Connect Error (' . mysqli_connect_errno() . ') '
            . mysqli_connect_error());
}

echo 'Success... ' . mysqli_get_host_info($link) . "\n";

mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Success... MySQL host info: localhost via TCP/IP

Notlar

Bilginize:

MySQLnd daima sunucunun öntanımlı bir karakter kümesi olduğunu varsayar. Bu karakter kümesi, mysqlnd'nin kullanacağı uzlaşım/kimlik doğrulama bağlantısı sırasında gönderilir.

Libmysqlclient, ya my.cnf dosyasındaki öntanımlı karakter kümesini ya da mysqli_init() çağrısından sonraki ilk mysqli_real_connect() çağrısındaan önce çağrılan mysqli_options() işlevinde belirtilen karakter kümesini kullanır.

Ayrıca Bakınız

  • mysqli_connect() - Takma Adı: mysqli::__construct
  • mysqli_init() - Initializes MySQLi and returns a resource for use with mysqli_real_connect()
  • mysqli_options() - Set options
  • mysqli_ssl_set() - Used for establishing secure connections using SSL
  • mysqli_close() - Closes a previously opened database connection

mysqli::query
mysqli::real_escape_string
mysqli


Escapes special characters in a string for use in an SQL statement, taking into account the current charset of the connection

mysqli::real_connect
mysqli::real_query
mysqli
PHP Manual

mysqli::real_escape_string

mysqli_real_escape_string

(PHP 5, PHP 7)

mysqli::real_escape_string -- mysqli_real_escape_string — Escapes special characters in a string for use in an SQL statement, taking into account the current charset of the connection

Açıklama

Nesne yönelimli kullanım

string mysqli::escape_string ( string $escapestr )
string mysqli::real_escape_string ( string $escapestr )

Yordamsal kullanım

string mysqli_real_escape_string ( mysqli $link , string $escapestr )

This function is used to create a legal SQL string that you can use in an SQL statement. The given string is encoded to an escaped SQL string, taking into account the current character set of the connection.

Dikkat

Security: the default character set

The character set must be set either at the server level, or with the API function mysqli_set_charset() for it to affect mysqli_real_escape_string(). See the concepts section on character sets for more information.

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

escapestr

The string to be escaped.

Characters encoded are NUL (ASCII 0), \n, \r, \, ', ", and Control-Z.

Dönen Değerler

Returns an escaped string.

Örnekler

Örnek 1 mysqli::real_escape_string() example

Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TEMPORARY TABLE myCity LIKE City");

$city = "'s Hertogenbosch";

/* this query will fail, cause we didn't escape $city */
if (!$mysqli->query("INSERT into myCity (Name) VALUES ('$city')")) {
    printf("Error: %s\n", $mysqli->sqlstate);
}

$city = $mysqli->real_escape_string($city);

/* this query with escaped $city will work */
if ($mysqli->query("INSERT into myCity (Name) VALUES ('$city')")) {
    printf("%d Row inserted.\n", $mysqli->affected_rows);
}

$mysqli->close();
?>

Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($link, "CREATE TEMPORARY TABLE myCity LIKE City");

$city = "'s Hertogenbosch";

/* this query will fail, cause we didn't escape $city */
if (!mysqli_query($link, "INSERT into myCity (Name) VALUES ('$city')")) {
    printf("Error: %s\n", mysqli_sqlstate($link));
}

$city = mysqli_real_escape_string($link, $city);

/* this query with escaped $city will work */
if (mysqli_query($link, "INSERT into myCity (Name) VALUES ('$city')")) {
    printf("%d Row inserted.\n", mysqli_affected_rows($link));
}

mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Error: 42000
1 Row inserted.

Notlar

Bilginize:

For those accustomed to using mysql_real_escape_string(),
note that the arguments of mysqli_real_escape_string()
differ from what mysql_real_escape_string() expects.
The link identifier comes first in
mysqli_real_escape_string(), whereas the string to be escaped
comes first in mysql_real_escape_string().

Ayrıca Bakınız

  • mysqli_set_charset() - Sets the default client character set
  • mysqli_character_set_name() - Returns the default character set for the database connection

mysqli::real_connect
mysqli::real_query
mysqli


Execute an SQL query

mysqli::real_escape_string
mysqli::reap_async_query
mysqli
PHP Manual

mysqli::real_query

mysqli_real_query

(PHP 5, PHP 7)

mysqli::real_query -- mysqli_real_query — Execute an SQL query

Açıklama

Nesne yönelimli kullanım

bool mysqli::real_query ( string $query )

Yordamsal kullanım

bool mysqli_real_query ( mysqli $link , string $query )

Executes a single query against the database whose result can then be retrieved or stored using the mysqli_store_result() or mysqli_use_result() functions.

In order to determine if a given query should return a result set or not, see mysqli_field_count().

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

query

The query, as a string.

Data inside the query should be properly escaped.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • mysqli_query() - Performs a query on the database
  • mysqli_store_result() - Transfers a result set from the last query
  • mysqli_use_result() - Initiate a result set retrieval

mysqli::real_escape_string
mysqli::reap_async_query
mysqli


Get result from async query

mysqli::real_query
mysqli::refresh
mysqli
PHP Manual

mysqli::reap_async_query

mysqli_reap_async_query

(PHP 5 >= 5.3.0, PHP 7)

mysqli::reap_async_query -- mysqli_reap_async_query — Get result from async query

Açıklama

Nesne yönelimli kullanım

public mysqli_result mysqli::reap_async_query ( void )

Yordamsal kullanım

mysqli_result mysqli_reap_async_query ( mysqli $link )

Get result from async query. Sadece mysqlnd ile kullanılabilir.

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

Dönen Değerler

Returns mysqli_result in success, FALSE otherwise.

Ayrıca Bakınız

  • mysqli_poll() - Poll connections

mysqli::real_query
mysqli::refresh
mysqli


Refreshes

mysqli::reap_async_query
mysqli::release_savepoint
mysqli
PHP Manual

mysqli::refresh

mysqli_refresh

(PHP 5 <= 5.3.0)

mysqli::refresh -- mysqli_refresh — Refreshes

Açıklama

Nesne yönelimli kullanım

public bool mysqli::refresh ( int $options )

Yordamsal kullanım

int mysqli_refresh ( resource $link , int $options )

Flushes tables or caches, or resets the replication server information.

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

options

The options to refresh, using the MYSQLI_REFRESH_* constants as documented within the MySQLi constants documentation.

See also the official » MySQL Refresh documentation.

Dönen Değerler

TRUE if the refresh was a success, otherwise FALSE

Ayrıca Bakınız

  • mysqli_poll() - Poll connections

mysqli::reap_async_query
mysqli::release_savepoint
mysqli


Removes the named savepoint from the set of savepoints of the current transaction

mysqli::refresh
mysqli::rollback
mysqli
PHP Manual

mysqli::release_savepoint

mysqli_release_savepoint

(PHP 5 >= 5.5.0, PHP 7)

mysqli::release_savepoint -- mysqli_release_savepoint — Removes the named savepoint from the set of savepoints of the current transaction

Açıklama

Nesne yönelimli kullanım (method):

public bool mysqli::release_savepoint ( string $name )

Yordamsal kullanım:

bool mysqli_release_savepoint ( mysqli $link , string $name )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

name

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • mysqli_rollback() - Rolls back current transaction

mysqli::refresh
mysqli::rollback
mysqli


Rolls back current transaction

mysqli::release_savepoint
mysqli::rpl_query_type
mysqli
PHP Manual

mysqli::rollback

mysqli_rollback

(PHP 5, PHP 7)

mysqli::rollback -- mysqli_rollback — Rolls back current transaction

Açıklama

Nesne yönelimli kullanım

bool mysqli::rollback ([ int $flags [, string $name ]] )

Yordamsal kullanım

bool mysqli_rollback ( mysqli $link [, int $flags [, string $name ]] )

Rollbacks the current transaction for the database.

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

flags

A bitmask of MYSQLI_TRANS_COR_* constants.

name

If provided then ROLLBACK/*name*/ is executed.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.5.0 | Added flags and name parameters.

Örnekler

Örnek 1 mysqli::rollback() example

Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* disable autocommit */
$mysqli->autocommit(FALSE);

$mysqli->query("CREATE TABLE myCity LIKE City");
$mysqli->query("ALTER TABLE myCity Type=InnoDB");
$mysqli->query("INSERT INTO myCity SELECT * FROM City LIMIT 50");

/* commit insert */
$mysqli->commit();

/* delete all rows */
$mysqli->query("DELETE FROM myCity");

if ($result = $mysqli->query("SELECT COUNT(*) FROM myCity")) {
    $row = $result->fetch_row();
    printf("%d rows in table myCity.\n", $row[0]);
    /* Free result */
    $result->close();
}

/* Rollback */
$mysqli->rollback();

if ($result = $mysqli->query("SELECT COUNT(*) FROM myCity")) {
    $row = $result->fetch_row();
    printf("%d rows in table myCity (after rollback).\n", $row[0]);
    /* Free result */
    $result->close();
}

/* Drop table myCity */
$mysqli->query("DROP TABLE myCity");

$mysqli->close();
?>

Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* disable autocommit */
mysqli_autocommit($link, FALSE);

mysqli_query($link, "CREATE TABLE myCity LIKE City");
mysqli_query($link, "ALTER TABLE myCity Type=InnoDB");
mysqli_query($link, "INSERT INTO myCity SELECT * FROM City LIMIT 50");

/* commit insert */
mysqli_commit($link);

/* delete all rows */
mysqli_query($link, "DELETE FROM myCity");

if ($result = mysqli_query($link, "SELECT COUNT(*) FROM myCity")) {
    $row = mysqli_fetch_row($result);
    printf("%d rows in table myCity.\n", $row[0]);
    /* Free result */
    mysqli_free_result($result);
}

/* Rollback */
mysqli_rollback($link);

if ($result = mysqli_query($link, "SELECT COUNT(*) FROM myCity")) {
    $row = mysqli_fetch_row($result);
    printf("%d rows in table myCity (after rollback).\n", $row[0]);
    /* Free result */
    mysqli_free_result($result);
}

/* Drop table myCity */
mysqli_query($link, "DROP TABLE myCity");

mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

0 rows in table myCity.
50 rows in table myCity (after rollback).

Ayrıca Bakınız

  • mysqli_begin_transaction() - Starts a transaction
  • mysqli_commit() - Commits the current transaction
  • mysqli_autocommit() - Turns on or off auto-committing database modifications
  • mysqli_release_savepoint() - Removes the named savepoint from the set of savepoints of the current transaction

mysqli::release_savepoint
mysqli::rpl_query_type
mysqli


Returns RPL query type

mysqli::rollback
mysqli::savepoint
mysqli
PHP Manual

mysqli::rpl_query_type

mysqli_rpl_query_type

(PHP 5, PHP 7)

mysqli::rpl_query_type -- mysqli_rpl_query_type — Returns RPL query type

Açıklama

Nesne yönelimli kullanım

int mysqli::rpl_query_type ( string $query )

Yordamsal kullanım

int mysqli_rpl_query_type ( mysqli $link , string $query )

Returns MYSQLI_RPL_MASTER, MYSQLI_RPL_SLAVE or MYSQLI_RPL_ADMIN depending on a query type. INSERT, UPDATE and similar are master queries, SELECT is slave, and FLUSH, REPAIR and similar are admin.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Uyarı

Bu işlevin kullanımı artık ÖNERİLMEMEKTEDİR ve PHP 5.3.0'da tamamen KALDIRILACAKTIR.

mysqli::rollback
mysqli::savepoint
mysqli


Set a named transaction savepoint

mysqli::rpl_query_type
mysqli::select_db
mysqli
PHP Manual

mysqli::savepoint

mysqli_savepoint

(PHP 5 >= 5.5.0, PHP 7)

mysqli::savepoint -- mysqli_savepoint — Set a named transaction savepoint

Açıklama

Nesne yönelimli kullanım (method):

public bool mysqli::savepoint ( string $name )

Yordamsal kullanım:

bool mysqli_savepoint ( mysqli $link , string $name )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

name

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • mysqli_commit() - Commits the current transaction

mysqli::rpl_query_type
mysqli::select_db
mysqli


Selects the default database for database queries

mysqli::savepoint
mysqli::send_query
mysqli
PHP Manual

mysqli::select_db

mysqli_select_db

(PHP 5, PHP 7)

mysqli::select_db -- mysqli_select_db — Selects the default database for database queries

Açıklama

Nesne yönelimli kullanım

bool mysqli::select_db ( string $dbname )

Yordamsal kullanım

bool mysqli_select_db ( mysqli $link , string $dbname )

Selects the default database to be used when performing queries against the database connection.

Bilginize:

This function should only be used to change the default database for the connection. You can select the default database with 4th parameter in mysqli_connect().

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

dbname

The database name.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 mysqli::select_db() example

Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "test");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* return name of current default database */
if ($result = $mysqli->query("SELECT DATABASE()")) {
    $row = $result->fetch_row();
    printf("Default database is %s.\n", $row[0]);
    $result->close();
}

/* change db to world db */
$mysqli->select_db("world");

/* return name of current default database */
if ($result = $mysqli->query("SELECT DATABASE()")) {
    $row = $result->fetch_row();
    printf("Default database is %s.\n", $row[0]);
    $result->close();
}

$mysqli->close();
?>

Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "test");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* return name of current default database */
if ($result = mysqli_query($link, "SELECT DATABASE()")) {
    $row = mysqli_fetch_row($result);
    printf("Default database is %s.\n", $row[0]);
    mysqli_free_result($result);
}

/* change db to world db */
mysqli_select_db($link, "world");

/* return name of current default database */
if ($result = mysqli_query($link, "SELECT DATABASE()")) {
    $row = mysqli_fetch_row($result);
    printf("Default database is %s.\n", $row[0]);
    mysqli_free_result($result);
}

mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Default database is test.
Default database is world.

Ayrıca Bakınız

  • mysqli_connect() - Takma Adı: mysqli::__construct
  • mysqli_real_connect() - Opens a connection to a mysql server

mysqli::savepoint
mysqli::send_query
mysqli


Send the query and return

mysqli::select_db
mysqli::set_charset
mysqli
PHP Manual

mysqli::send_query

mysqli_send_query

(PHP 5, PHP 7)

mysqli::send_query -- mysqli_send_query — Send the query and return

Açıklama

Nesne yönelimli kullanım

bool mysqli::send_query ( string $query )

Yordamsal kullanım

bool mysqli_send_query ( mysqli $link , string $query )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Uyarı

Bu işlevin kullanımı artık ÖNERİLMEMEKTEDİR ve PHP 5.3.0'da tamamen KALDIRILACAKTIR.

mysqli::select_db
mysqli::set_charset
mysqli


Sets the default client character set

mysqli::send_query
mysqli::set_local_infile_default
mysqli
PHP Manual

mysqli::set_charset

mysqli_set_charset

(PHP 5 >= 5.0.5, PHP 7)

mysqli::set_charset -- mysqli_set_charset — Sets the default client character set

Açıklama

Nesne yönelimli kullanım

bool mysqli::set_charset ( string $charset )

Yordamsal kullanım

bool mysqli_set_charset ( mysqli $link , string $charset )

Sets the default character set to be used when sending data from and to the database server.

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

charset

The charset to be set as default.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

Bilginize:

To use this function on a Windows platform you need MySQL client library version 4.1.11 or above (for MySQL 5.0 you need 5.0.6 or above).

Bilginize:

This is the preferred way to change the charset. Using mysqli_query() to set it (such as SET NAMES utf8) is not recommended. See the MySQL character set concepts section for more information.

Örnekler

Örnek 1 mysqli::set_charset() example

Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "test");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

printf("Initial character set: %s\n", $mysqli->character_set_name());

/* change character set to utf8 */
if (!$mysqli->set_charset("utf8")) {
    printf("Error loading character set utf8: %s\n", $mysqli->error);
    exit();
} else {
    printf("Current character set: %s\n", $mysqli->character_set_name());
}

$mysqli->close();
?>

Yordamsal kullanım

<?php
$link = mysqli_connect('localhost', 'my_user', 'my_password', 'test');

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

printf("Initial character set: %s\n", mysqli_character_set_name($link));

/* change character set to utf8 */
if (!mysqli_set_charset($link, "utf8")) {
    printf("Error loading character set utf8: %s\n", mysqli_error($link));
    exit();
} else {
    printf("Current character set: %s\n", mysqli_character_set_name($link));
}

mysqli_close($link);
?>

The above examples will output something similar to:

Initial character set: latin1
Current character set: utf8

Ayrıca Bakınız

  • mysqli_character_set_name() - Returns the default character set for the database connection
  • mysqli_real_escape_string() - Escapes special characters in a string for use in an SQL statement, taking into account the current charset of the connection
  • MySQL character set concepts
  • » List of character sets that MySQL supports

mysqli::send_query
mysqli::set_local_infile_default
mysqli


Unsets user defined handler for load local infile command

mysqli::set_charset
mysqli::set_local_infile_handler
mysqli
PHP Manual

mysqli::set_local_infile_default

mysqli_set_local_infile_default

(PHP 5, PHP 7)

mysqli::set_local_infile_default -- mysqli_set_local_infile_default — Unsets user defined handler for load local infile command

Açıklama

void mysqli_set_local_infile_default ( mysqli $link )

Deactivates a LOAD DATA INFILE LOCAL handler previously set with mysqli_set_local_infile_handler().

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

See mysqli_set_local_infile_handler() examples

Ayrıca Bakınız

  • mysqli_set_local_infile_handler() - Set callback function for LOAD DATA LOCAL INFILE command

mysqli::set_charset
mysqli::set_local_infile_handler
mysqli


Set callback function for LOAD DATA LOCAL INFILE command

mysqli::set_local_infile_default
mysqli::$sqlstate
mysqli
PHP Manual

mysqli::set_local_infile_handler

mysqli_set_local_infile_handler

(PHP 5, PHP 7)

mysqli::set_local_infile_handler -- mysqli_set_local_infile_handler — Set callback function for LOAD DATA LOCAL INFILE command

Açıklama

Nesne yönelimli kullanım

bool mysqli::set_local_infile_handler ( mysqli $link , callable $read_func )

Yordamsal kullanım

bool mysqli_set_local_infile_handler ( mysqli $link , callable $read_func )

Set callback function for LOAD DATA LOCAL INFILE command

The callbacks task is to read input from the file specified in the LOAD DATA LOCAL INFILE and to reformat it into the format understood by LOAD DATA INFILE.

The returned data needs to match the format specified in the LOAD DATA

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

read_func

A callback function or object method taking the following parameters:

stream

A PHP stream associated with the SQL commands INFILE

&buffer

A string buffer to store the rewritten input into

buflen

The maximum number of characters to be stored in the buffer

&errormsg

If an error occurs you can store an error message in here

The callback function should return the number of characters stored in the buffer or a negative value if an error occurred.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 mysqli::set_local_infile_handler() example

Nesne yönelimli kullanım

<?php
  $db = mysqli_init();
  $db->real_connect("localhost","root","","test");

  function callme($stream, &$buffer, $buflen, &$errmsg)
  {
    $buffer = fgets($stream);

    echo $buffer;

    // convert to upper case and replace "," delimiter with [TAB]
    $buffer = strtoupper(str_replace(",", "\t", $buffer));

    return strlen($buffer);
  }

  echo "Input:\n";

  $db->set_local_infile_handler("callme");
  $db->query("LOAD DATA LOCAL INFILE 'input.txt' INTO TABLE t1");
  $db->set_local_infile_default();

  $res = $db->query("SELECT * FROM t1");

  echo "\nResult:\n";
  while ($row = $res->fetch_assoc()) {
    echo join(",", $row)."\n";
  }
?>

Yordamsal kullanım

<?php
  $db = mysqli_init();
  mysqli_real_connect($db, "localhost","root","","test");

  function callme($stream, &$buffer, $buflen, &$errmsg)
  {
    $buffer = fgets($stream);

    echo $buffer;

    // convert to upper case and replace "," delimiter with [TAB]
    $buffer = strtoupper(str_replace(",", "\t", $buffer));

    return strlen($buffer);
  }

  echo "Input:\n";

  mysqli_set_local_infile_handler($db, "callme");
  mysqli_query($db, "LOAD DATA LOCAL INFILE 'input.txt' INTO TABLE t1");
  mysqli_set_local_infile_default($db);

  $res = mysqli_query($db, "SELECT * FROM t1");

  echo "\nResult:\n";
  while ($row = mysqli_fetch_assoc($res)) {
    echo join(",", $row)."\n";
  }
?>

Yukarıdaki örneklerin çıktısı:

Input:
23,foo
42,bar

Output:
23,FOO
42,BAR

Ayrıca Bakınız

  • mysqli_set_local_infile_default() - Unsets user defined handler for load local infile command

mysqli::set_local_infile_default
mysqli::$sqlstate
mysqli


Returns the SQLSTATE error from previous MySQL operation

mysqli::set_local_infile_handler
mysqli::ssl_set
mysqli
PHP Manual

mysqli::$sqlstate

mysqli_sqlstate

(PHP 5, PHP 7)

mysqli::$sqlstate -- mysqli_sqlstate — Returns the SQLSTATE error from previous MySQL operation

Açıklama

Nesne yönelimli kullanım

string $mysqli->sqlstate;

Yordamsal kullanım

string mysqli_sqlstate ( mysqli $link )

Returns a string containing the SQLSTATE error code for the last error. The error code consists of five characters. '00000' means no error. The values are specified by ANSI SQL and ODBC. For a list of possible values, see » http://dev.mysql.com/doc/mysql/en/error-handling.html.

Bilginize:

Note that not all MySQL errors are yet mapped to SQLSTATE's. The value HY000 (general error) is used for unmapped errors.

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

Dönen Değerler

Returns a string containing the SQLSTATE error code for the last error. The error code consists of five characters. '00000' means no error.

Örnekler

Örnek 1 $mysqli->sqlstate example

Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* Table City already exists, so we should get an error */
if (!$mysqli->query("CREATE TABLE City (ID INT, Name VARCHAR(30))")) {
    printf("Error - SQLSTATE %s.\n", $mysqli->sqlstate);
}

$mysqli->close();
?>

Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* Table City already exists, so we should get an error */
if (!mysqli_query($link, "CREATE TABLE City (ID INT, Name VARCHAR(30))")) {
    printf("Error - SQLSTATE %s.\n", mysqli_sqlstate($link));
}

mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Error - SQLSTATE 42S01.

Ayrıca Bakınız

  • mysqli_errno() - Returns the error code for the most recent function call
  • mysqli_error() - Returns a string description of the last error

mysqli::set_local_infile_handler
mysqli::ssl_set
mysqli


Used for establishing secure connections using SSL

mysqli::$sqlstate
mysqli::stat
mysqli
PHP Manual

mysqli::ssl_set

mysqli_ssl_set

(PHP 5, PHP 7)

mysqli::ssl_set -- mysqli_ssl_set — Used for establishing secure connections using SSL

Açıklama

Nesne yönelimli kullanım

bool mysqli::ssl_set ( string $key , string $cert , string $ca , string $capath , string $cipher )

Yordamsal kullanım

bool mysqli_ssl_set ( mysqli $link , string $key , string $cert , string $ca , string $capath , string $cipher )

Used for establishing secure connections using SSL. It must be called before mysqli_real_connect(). This function does nothing unless OpenSSL support is enabled.

Note that MySQL Native Driver does not support SSL before PHP 5.3.3, so calling this function when using MySQL Native Driver will result in an error. MySQL Native Driver is enabled by default on Microsoft Windows from PHP version 5.3 onwards.

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

key

The path name to the key file.

cert

The path name to the certificate file.

ca

The path name to the certificate authority file.

capath

The pathname to a directory that contains trusted SSL CA certificates in PEM format.

cipher

A list of allowable ciphers to use for SSL encryption.

Any unused SSL parameters may be given as NULL

Dönen Değerler

This function always returns TRUE value. If SSL setup is incorrect mysqli_real_connect() will return an error when you attempt to connect.

Ayrıca Bakınız

  • mysqli_options() - Set options
  • mysqli_real_connect() - Opens a connection to a mysql server

mysqli::$sqlstate
mysqli::stat
mysqli


Gets the current system status

mysqli::ssl_set
mysqli::stmt_init
mysqli
PHP Manual

mysqli::stat

mysqli_stat

(PHP 5, PHP 7)

mysqli::stat -- mysqli_stat — Gets the current system status

Açıklama

Nesne yönelimli kullanım

string mysqli::stat ( void )

Yordamsal kullanım

string mysqli_stat ( mysqli $link )

mysqli_stat() returns a string containing information similar to that provided by the 'mysqladmin status' command. This includes uptime in seconds and the number of running threads, questions, reloads, and open tables.

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

Dönen Değerler

A string describing the server status. FALSE if an error occurred.

Örnekler

Örnek 1 mysqli::stat() example

Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

printf ("System status: %s\n", $mysqli->stat());

$mysqli->close();
?>

Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

printf("System status: %s\n", mysqli_stat($link));

mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

System status: Uptime: 272  Threads: 1  Questions: 5340  Slow queries: 0
Opens: 13  Flush tables: 1  Open tables: 0  Queries per second avg: 19.632
Memory in use: 8496K  Max memory used: 8560K

Ayrıca Bakınız

  • mysqli_get_server_info() - Returns the version of the MySQL server

mysqli::ssl_set
mysqli::stmt_init
mysqli


Initializes a statement and returns an object for use with mysqli_stmt_prepare

mysqli::stat
mysqli::store_result
mysqli
PHP Manual

mysqli::stmt_init

mysqli_stmt_init

(PHP 5, PHP 7)

mysqli::stmt_init -- mysqli_stmt_init — Initializes a statement and returns an object for use with mysqli_stmt_prepare

Açıklama

Nesne yönelimli kullanım

mysqli_stmt mysqli::stmt_init ( void )

Yordamsal kullanım

mysqli_stmt mysqli_stmt_init ( mysqli $link )

Allocates and initializes a statement object suitable for mysqli_stmt_prepare().

Bilginize:

Any subsequent calls to any mysqli_stmt function will fail until mysqli_stmt_prepare() was called.

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

Dönen Değerler

Returns an object.

Ayrıca Bakınız

  • mysqli_stmt_prepare() - Prepare an SQL statement for execution

mysqli::stat
mysqli::store_result
mysqli


Transfers a result set from the last query

mysqli::stmt_init
mysqli::$thread_id
mysqli
PHP Manual

mysqli::store_result

mysqli_store_result

(PHP 5, PHP 7)

mysqli::store_result -- mysqli_store_result — Transfers a result set from the last query

Açıklama

Nesne yönelimli kullanım

mysqli_result mysqli::store_result ([ int $option ] )

Yordamsal kullanım

mysqli_result mysqli_store_result ( mysqli $link [, int $option ] )

Transfers the result set from the last query on the database connection represented by the link parameter to be used with the mysqli_data_seek() function.

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

option

The option that you want to set. It can be one of the following values:

Valid options
Name | Description
MYSQLI_STORE_RESULT_COPY_DATA | Copy results from the internal mysqlnd buffer into the PHP variables fetched. By default, mysqlnd will use a reference logic to avoid copying and duplicating results held in memory. For certain result sets, for example, result sets with many small rows, the copy approach can reduce the overall memory usage because PHP variables holding results may be released earlier (available with mysqlnd only, since PHP 5.6.0)

Dönen Değerler

Returns a buffered result object or FALSE if an error occurred.

Bilginize:

mysqli_store_result() returns FALSE in case the query didn't return a result set (if the query was, for example an INSERT statement). This function also returns FALSE if the reading of the result set failed. You can check if you have got an error by checking if mysqli_error() doesn't return an empty string, if mysqli_errno() returns a non zero value, or if mysqli_field_count() returns a non zero value. Also possible reason for this function returning FALSE after successful call to mysqli_query() can be too large result set (memory for it cannot be allocated). If mysqli_field_count() returns a non-zero value, the statement should have produced a non-empty result set.

Notlar

Bilginize:

Although it is always good practice to free the memory used by the result of a query using the mysqli_free_result() function, when transferring large result sets using the mysqli_store_result() this becomes particularly important.

Örnekler

See mysqli_multi_query().

Ayrıca Bakınız

  • mysqli_real_query() - Execute an SQL query
  • mysqli_use_result() - Initiate a result set retrieval

mysqli::stmt_init
mysqli::$thread_id
mysqli


Returns the thread ID for the current connection

mysqli::store_result
mysqli::thread_safe
mysqli
PHP Manual

mysqli::$thread_id

mysqli_thread_id

(PHP 5, PHP 7)

mysqli::$thread_id -- mysqli_thread_id — Returns the thread ID for the current connection

Açıklama

Nesne yönelimli kullanım

int $mysqli->thread_id;

Yordamsal kullanım

int mysqli_thread_id ( mysqli $link )

The mysqli_thread_id() function returns the thread ID for the current connection which can then be killed using the mysqli_kill() function. If the connection is lost and you reconnect with mysqli_ping(), the thread ID will be other. Therefore you should get the thread ID only when you need it.

Bilginize:

The thread ID is assigned on a connection-by-connection basis. Hence, if the connection is broken and then re-established a new thread ID will be assigned.

To kill a running query you can use the SQL command KILL QUERY processid.

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

Dönen Değerler

Returns the Thread ID for the current connection.

Örnekler

Örnek 1 $mysqli->thread_id example

Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* determine our thread id */
$thread_id = $mysqli->thread_id;

/* Kill connection */
$mysqli->kill($thread_id);

/* This should produce an error */
if (!$mysqli->query("CREATE TABLE myCity LIKE City")) {
    printf("Error: %s\n", $mysqli->error);
    exit;
}

/* close connection */
$mysqli->close();
?>

Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* determine our thread id */
$thread_id = mysqli_thread_id($link);

/* Kill connection */
mysqli_kill($link, $thread_id);

/* This should produce an error */
if (!mysqli_query($link, "CREATE TABLE myCity LIKE City")) {
    printf("Error: %s\n", mysqli_error($link));
    exit;
}

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Error: MySQL server has gone away

Ayrıca Bakınız

  • mysqli_kill() - Asks the server to kill a MySQL thread

mysqli::store_result
mysqli::thread_safe
mysqli


Returns whether thread safety is given or not

mysqli::$thread_id
mysqli::use_result
mysqli
PHP Manual

mysqli::thread_safe

mysqli_thread_safe

(PHP 5, PHP 7)

mysqli::thread_safe -- mysqli_thread_safe — Returns whether thread safety is given or not

Açıklama

Yordamsal kullanım

bool mysqli_thread_safe ( void )

Tells whether the client library is compiled as thread-safe.

Dönen Değerler

TRUE if the client library is thread-safe, otherwise FALSE.

mysqli::$thread_id
mysqli::use_result
mysqli


Initiate a result set retrieval

mysqli::thread_safe
mysqli::$warning_count
mysqli
PHP Manual

mysqli::use_result

mysqli_use_result

(PHP 5, PHP 7)

mysqli::use_result -- mysqli_use_result — Initiate a result set retrieval

Açıklama

Nesne yönelimli kullanım

mysqli_result mysqli::use_result ( void )

Yordamsal kullanım

mysqli_result mysqli_use_result ( mysqli $link )

Used to initiate the retrieval of a result set from the last query executed using the mysqli_real_query() function on the database connection.

Either this or the mysqli_store_result() function must be called before the results of a query can be retrieved, and one or the other must be called to prevent the next query on that database connection from failing.

Bilginize:

The mysqli_use_result() function does not transfer the entire result set from the database and hence cannot be used functions such as mysqli_data_seek() to move to a particular row within the set. To use this functionality, the result set must be stored using mysqli_store_result(). One should not use mysqli_use_result() if a lot of processing on the client side is performed, since this will tie up the server and prevent other threads from updating any tables from which the data is being fetched.

Dönen Değerler

Returns an unbuffered result object or FALSE if an error occurred.

Örnekler

Örnek 1 mysqli::use_result() example

Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query  = "SELECT CURRENT_USER();";
$query .= "SELECT Name FROM City ORDER BY ID LIMIT 20, 5";

/* execute multi query */
if ($mysqli->multi_query($query)) {
    do {
        /* store first result set */
        if ($result = $mysqli->use_result()) {
            while ($row = $result->fetch_row()) {
                printf("%s\n", $row[0]);
            }
            $result->close();
        }
        /* print divider */
        if ($mysqli->more_results()) {
            printf("-----------------\n");
        }
    } while ($mysqli->next_result());
}

/* close connection */
$mysqli->close();
?>

Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query  = "SELECT CURRENT_USER();";
$query .= "SELECT Name FROM City ORDER BY ID LIMIT 20, 5";

/* execute multi query */
if (mysqli_multi_query($link, $query)) {
    do {
        /* store first result set */
        if ($result = mysqli_use_result($link)) {
            while ($row = mysqli_fetch_row($result)) {
                printf("%s\n", $row[0]);
            }
            mysqli_free_result($result);
        }
        /* print divider */
        if (mysqli_more_results($link)) {
            printf("-----------------\n");
        }
    } while (mysqli_next_result($link));
}

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

my_user@localhost
-----------------
Amersfoort
Maastricht
Dordrecht
Leiden
Haarlemmermeer

Ayrıca Bakınız

  • mysqli_real_query() - Execute an SQL query
  • mysqli_store_result() - Transfers a result set from the last query

mysqli::thread_safe
mysqli::$warning_count
mysqli


Returns the number of warnings from the last query for the given link

mysqli::use_result
mysqli_stmt
mysqli
PHP Manual

mysqli::$warning_count

mysqli_warning_count

(PHP 5, PHP 7)

mysqli::$warning_count -- mysqli_warning_count — Returns the number of warnings from the last query for the given link

Açıklama

Nesne yönelimli kullanım

int $mysqli->warning_count;

Yordamsal kullanım

int mysqli_warning_count ( mysqli $link )

Returns the number of warnings from the last query in the connection.

Bilginize:

For retrieving warning messages you can use the SQL command SHOW WARNINGS [limit row_count].

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

Dönen Değerler

Number of warnings or zero if there are no warnings.

Örnekler

Örnek 1 $mysqli->warning_count example

Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TABLE myCity LIKE City");

/* a remarkable city in Wales */
$query = "INSERT INTO myCity (CountryCode, Name) VALUES('GBR',
        'Llanfairpwllgwyngyllgogerychwyrndrobwllllantysiliogogogoch')";

$mysqli->query($query);

if ($mysqli->warning_count) {
    if ($result = $mysqli->query("SHOW WARNINGS")) {
        $row = $result->fetch_row();
        printf("%s (%d): %s\n", $row[0], $row[1], $row[2]);
        $result->close();
    }
}

/* close connection */
$mysqli->close();
?>

Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($link, "CREATE TABLE myCity LIKE City");

/* a remarkable long city name in Wales */
$query = "INSERT INTO myCity (CountryCode, Name) VALUES('GBR',
        'Llanfairpwllgwyngyllgogerychwyrndrobwllllantysiliogogogoch')";

mysqli_query($link, $query);

if (mysqli_warning_count($link)) {
    if ($result = mysqli_query($link, "SHOW WARNINGS")) {
        $row = mysqli_fetch_row($result);
        printf("%s (%d): %s\n", $row[0], $row[1], $row[2]);
        mysqli_free_result($result);
    }
}

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Warning (1264): Data truncated for column 'Name' at row 1

Ayrıca Bakınız

  • mysqli_errno() - Returns the error code for the most recent function call
  • mysqli_error() - Returns a string description of the last error
  • mysqli_sqlstate() - Returns the SQLSTATE error from previous MySQL operation

mysqli::use_result
mysqli_stmt
mysqli


The mysqli_stmt class

(PHP 5, PHP 7)

Giriş

Represents a prepared statement.

Sınıf Sözdizimi

mysqli_stmt {
/* Özellikler */
int $affected_rows;
int $errno;
array $error_list;
string $error;
int $field_count;
int $insert_id;
int $num_rows;
int $param_count;
string $sqlstate;
/* Yöntemler */
__construct ( mysqli $link [, string $query ] )
int attr_get ( int $attr )
bool attr_set ( int $attr , int $mode )
bool bind_param ( string $types , mixed &$var1 [, mixed &$... ] )
bool bind_result ( mixed &$var1 [, mixed &$... ] )
bool close ( void )
void data_seek ( int $offset )
bool execute ( void )
bool fetch ( void )
void free_result ( void )
mysqli_result get_result ( void )
object get_warnings ( mysqli_stmt $stmt )
mixed prepare ( string $query )
bool reset ( void )
mysqli_result result_metadata ( void )
bool send_long_data ( int $param_nr , string $data )
bool store_result ( void )
}

İçindekiler

  • mysqli_stmt::$affected_rows — Returns the total number of rows changed, deleted, or inserted by the last executed statement
  • mysqli_stmt::attr_get — Used to get the current value of a statement attribute
  • mysqli_stmt::attr_set — Used to modify the behavior of a prepared statement
  • mysqli_stmt::bind_param — Binds variables to a prepared statement as parameters
  • mysqli_stmt::bind_result — Binds variables to a prepared statement for result storage
  • mysqli_stmt::close — Closes a prepared statement
  • mysqli_stmt::__construct — Constructs a new mysqli_stmt object
  • mysqli_stmt::data_seek — Seeks to an arbitrary row in statement result set
  • mysqli_stmt::$errno — Returns the error code for the most recent statement call
  • mysqli_stmt::$error_list — Returns a list of errors from the last statement executed
  • mysqli_stmt::$error — Returns a string description for last statement error
  • mysqli_stmt::execute — Executes a prepared Query
  • mysqli_stmt::fetch — Fetch results from a prepared statement into the bound variables
  • mysqli_stmt::$field_count — Returns the number of field in the given statement
  • mysqli_stmt::free_result — Frees stored result memory for the given statement handle
  • mysqli_stmt::get_result — Gets a result set from a prepared statement
  • mysqli_stmt::get_warnings — Get result of SHOW WARNINGS
  • mysqli_stmt::$insert_id — Get the ID generated from the previous INSERT operation
  • mysqli_stmt::more_results — Check if there are more query results from a multiple query
  • mysqli_stmt::next_result — Reads the next result from a multiple query
  • mysqli_stmt::$num_rows — Return the number of rows in statements result set
  • mysqli_stmt::$param_count — Returns the number of parameter for the given statement
  • mysqli_stmt::prepare — Prepare an SQL statement for execution
  • mysqli_stmt::reset — Resets a prepared statement
  • mysqli_stmt::result_metadata — Returns result set metadata from a prepared statement
  • mysqli_stmt::send_long_data — Send data in blocks
  • mysqli_stmt::$sqlstate — Returns SQLSTATE error from previous statement operation
  • mysqli_stmt::store_result — Transfers a result set from a prepared statement
mysqli::$warning_count
mysqli_stmt::$affected_rows
MySQLi


Returns the total number of rows changed, deleted, or inserted by the last executed statement

mysqli_stmt
mysqli_stmt::attr_get
mysqli_stmt
PHP Manual

mysqli_stmt::$affected_rows

mysqli_stmt_affected_rows

(PHP 5, PHP 7)

mysqli_stmt::$affected_rows -- mysqli_stmt_affected_rows — Returns the total number of rows changed, deleted, or inserted by the last executed statement

Açıklama

Nesne yönelimli kullanım

int $mysqli_stmt->affected_rows;

Yordamsal kullanım

int mysqli_stmt_affected_rows ( mysqli_stmt $stmt )

Returns the number of rows affected by INSERT, UPDATE, or DELETE query.

This function only works with queries which update a table. In order to get the number of rows from a SELECT query, use mysqli_stmt_num_rows() instead.

Değiştirgeler

deyimt

Sadece yordamsal tarz: mysqli_stmt_init() işlevinden dönen bir deyim tanıtıcısı.

Dönen Değerler

An integer greater than zero indicates the number of rows affected or retrieved. Zero indicates that no records where updated for an UPDATE/DELETE statement, no rows matched the WHERE clause in the query or that no query has yet been executed. -1 indicates that the query has returned an error. NULL indicates an invalid argument was supplied to the function.

Bilginize:

If the number of affected rows is greater than maximal PHP int value, the number of affected rows will be returned as a string value.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* create temp table */
$mysqli->query("CREATE TEMPORARY TABLE myCountry LIKE Country");

$query = "INSERT INTO myCountry SELECT * FROM Country WHERE Code LIKE ?";

/* prepare statement */
if ($stmt = $mysqli->prepare($query)) {

    /* Bind variable for placeholder */
    $code = 'A%';
    $stmt->bind_param("s", $code);

    /* execute statement */
    $stmt->execute();

    printf("rows inserted: %d\n", $stmt->affected_rows);

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* create temp table */
mysqli_query($link, "CREATE TEMPORARY TABLE myCountry LIKE Country");

$query = "INSERT INTO myCountry SELECT * FROM Country WHERE Code LIKE ?";

/* prepare statement */
if ($stmt = mysqli_prepare($link, $query)) {

    /* Bind variable for placeholder */
    $code = 'A%';
    mysqli_stmt_bind_param($stmt, "s", $code);

    /* execute statement */
    mysqli_stmt_execute($stmt);

    printf("rows inserted: %d\n", mysqli_stmt_affected_rows($stmt));

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

rows inserted: 17

Ayrıca Bakınız

  • mysqli_stmt_num_rows() - Return the number of rows in statements result set
  • mysqli_prepare() - Prepare an SQL statement for execution

mysqli_stmt
mysqli_stmt::attr_get
mysqli_stmt


Used to get the current value of a statement attribute

mysqli_stmt::$affected_rows
mysqli_stmt::attr_set
mysqli_stmt
PHP Manual

mysqli_stmt::attr_get

mysqli_stmt_attr_get

(PHP 5, PHP 7)

mysqli_stmt::attr_get -- mysqli_stmt_attr_get — Used to get the current value of a statement attribute

Açıklama

Nesne yönelimli kullanım

int mysqli_stmt::attr_get ( int $attr )

Yordamsal kullanım

int mysqli_stmt_attr_get ( mysqli_stmt $stmt , int $attr )

Gets the current value of a statement attribute.

Değiştirgeler

deyimt

Sadece yordamsal tarz: mysqli_stmt_init() işlevinden dönen bir deyim tanıtıcısı.

attr

The attribute that you want to get.

Dönen Değerler

Returns FALSE if the attribute is not found, otherwise returns the value of the attribute.

mysqli_stmt::$affected_rows
mysqli_stmt::attr_set
mysqli_stmt


Used to modify the behavior of a prepared statement

mysqli_stmt::attr_get
mysqli_stmt::bind_param
mysqli_stmt
PHP Manual

mysqli_stmt::attr_set

mysqli_stmt_attr_set

(PHP 5, PHP 7)

mysqli_stmt::attr_set -- mysqli_stmt_attr_set — Used to modify the behavior of a prepared statement

Açıklama

Nesne yönelimli kullanım

bool mysqli_stmt::attr_set ( int $attr , int $mode )

Yordamsal kullanım

bool mysqli_stmt_attr_set ( mysqli_stmt $stmt , int $attr , int $mode )

Used to modify the behavior of a prepared statement. This function may be called multiple times to set several attributes.

Değiştirgeler

deyimt

Sadece yordamsal tarz: mysqli_stmt_init() işlevinden dönen bir deyim tanıtıcısı.

attr

The attribute that you want to set. It can have one of the following values:

Attribute values
Character | Description
MYSQLI_STMT_ATTR_UPDATE_MAX_LENGTH | Setting to TRUE causes mysqli_stmt_store_result() to update the metadata MYSQL_FIELD->max_length value.
MYSQLI_STMT_ATTR_CURSOR_TYPE | Type of cursor to open for statement when mysqli_stmt_execute() is invoked. mode can be MYSQLI_CURSOR_TYPE_NO_CURSOR (the default) or MYSQLI_CURSOR_TYPE_READ_ONLY.
MYSQLI_STMT_ATTR_PREFETCH_ROWS | Number of rows to fetch from server at a time when using a cursor. mode can be in the range from 1 to the maximum value of unsigned long. The default is 1.

If you use the MYSQLI_STMT_ATTR_CURSOR_TYPE option with MYSQLI_CURSOR_TYPE_READ_ONLY, a cursor is opened for the statement when you invoke mysqli_stmt_execute(). If there is already an open cursor from a previous mysqli_stmt_execute() call, it closes the cursor before opening a new one. mysqli_stmt_reset() also closes any open cursor before preparing the statement for re-execution. mysqli_stmt_free_result() closes any open cursor.

If you open a cursor for a prepared statement, mysqli_stmt_store_result() is unnecessary.

mode

The value to assign to the attribute.

Ayrıca Bakınız

  • » Connector/MySQL mysql_stmt_attr_set()

mysqli_stmt::attr_get
mysqli_stmt::bind_param
mysqli_stmt


Binds variables to a prepared statement as parameters

mysqli_stmt::attr_set
mysqli_stmt::bind_result
mysqli_stmt
PHP Manual

mysqli_stmt::bind_param

mysqli_stmt_bind_param

(PHP 5, PHP 7)

mysqli_stmt::bind_param -- mysqli_stmt_bind_param — Binds variables to a prepared statement as parameters

Açıklama

Nesne yönelimli kullanım

bool mysqli_stmt::bind_param ( string $types , mixed &$var1 [, mixed &$... ] )

Yordamsal kullanım

bool mysqli_stmt_bind_param ( mysqli_stmt $stmt , string $types , mixed &$var1 [, mixed &$... ] )

Bind variables for the parameter markers in the SQL statement that was passed to mysqli_prepare().

Bilginize:

If data size of a variable exceeds max. allowed packet size (max_allowed_packet), you have to specify b in types and use mysqli_stmt_send_long_data() to send the data in packets.

Bilginize:

Care must be taken when using mysqli_stmt_bind_param() in conjunction with call_user_func_array(). Note that mysqli_stmt_bind_param() requires parameters to be passed by reference, whereas call_user_func_array() can accept as a parameter a list of variables that can represent references or values.

Değiştirgeler

deyimt

Sadece yordamsal tarz: mysqli_stmt_init() işlevinden dönen bir deyim tanıtıcısı.

types

A string that contains one or more characters which specify the types for the corresponding bind variables:

Type specification chars
Character | Description
i | corresponding variable has type integer
d | corresponding variable has type double
s | corresponding variable has type string
b | corresponding variable is a blob and will be sent in packets

var1

The number of variables and length of string types must match the parameters in the statement.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$mysqli = new mysqli('localhost', 'my_user', 'my_password', 'world');

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$stmt = $mysqli->prepare("INSERT INTO CountryLanguage VALUES (?, ?, ?, ?)");
$stmt->bind_param('sssd', $code, $language, $official, $percent);

$code = 'DEU';
$language = 'Bavarian';
$official = "F";
$percent = 11.2;

/* execute prepared statement */
$stmt->execute();

printf("%d Row inserted.\n", $stmt->affected_rows);

/* close statement and connection */
$stmt->close();

/* Clean up table CountryLanguage */
$mysqli->query("DELETE FROM CountryLanguage WHERE Language='Bavarian'");
printf("%d Row deleted.\n", $mysqli->affected_rows);

/* close connection */
$mysqli->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = mysqli_connect('localhost', 'my_user', 'my_password', 'world');

/* check connection */
if (!$link) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$stmt = mysqli_prepare($link, "INSERT INTO CountryLanguage VALUES (?, ?, ?, ?)");
mysqli_stmt_bind_param($stmt, 'sssd', $code, $language, $official, $percent);

$code = 'DEU';
$language = 'Bavarian';
$official = "F";
$percent = 11.2;

/* execute prepared statement */
mysqli_stmt_execute($stmt);

printf("%d Row inserted.\n", mysqli_stmt_affected_rows($stmt));

/* close statement and connection */
mysqli_stmt_close($stmt);

/* Clean up table CountryLanguage */
mysqli_query($link, "DELETE FROM CountryLanguage WHERE Language='Bavarian'");
printf("%d Row deleted.\n", mysqli_affected_rows($link));

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

1 Row inserted.
1 Row deleted.

Ayrıca Bakınız

  • mysqli_stmt_bind_result() - Binds variables to a prepared statement for result storage
  • mysqli_stmt_execute() - Executes a prepared Query
  • mysqli_stmt_fetch() - Fetch results from a prepared statement into the bound variables
  • mysqli_prepare() - Prepare an SQL statement for execution
  • mysqli_stmt_send_long_data() - Send data in blocks
  • mysqli_stmt_errno() - Returns the error code for the most recent statement call
  • mysqli_stmt_error() - Returns a string description for last statement error

mysqli_stmt::attr_set
mysqli_stmt::bind_result
mysqli_stmt


Binds variables to a prepared statement for result storage

mysqli_stmt::bind_param
mysqli_stmt::close
mysqli_stmt
PHP Manual

mysqli_stmt::bind_result

mysqli_stmt_bind_result

(PHP 5, PHP 7)

mysqli_stmt::bind_result -- mysqli_stmt_bind_result — Binds variables to a prepared statement for result storage

Açıklama

Nesne yönelimli kullanım

bool mysqli_stmt::bind_result ( mixed &$var1 [, mixed &$... ] )

Yordamsal kullanım

bool mysqli_stmt_bind_result ( mysqli_stmt $stmt , mixed &$var1 [, mixed &$... ] )

Binds columns in the result set to variables.

When mysqli_stmt_fetch() is called to fetch data, the MySQL client/server protocol places the data for the bound columns into the specified variables var1, ....

Bilginize:

Note that all columns must be bound after mysqli_stmt_execute() and prior to calling mysqli_stmt_fetch(). Depending on column types bound variables can silently change to the corresponding PHP type.

A column can be bound or rebound at any time, even after a result set has been partially retrieved. The new binding takes effect the next time mysqli_stmt_fetch() is called.

Değiştirgeler

deyimt

Sadece yordamsal tarz: mysqli_stmt_init() işlevinden dönen bir deyim tanıtıcısı.

var1

The variable to be bound.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* prepare statement */
if ($stmt = $mysqli->prepare("SELECT Code, Name FROM Country ORDER BY Name LIMIT 5")) {
    $stmt->execute();

    /* bind variables to prepared statement */
    $stmt->bind_result($col1, $col2);

    /* fetch values */
    while ($stmt->fetch()) {
        printf("%s %s\n", $col1, $col2);
    }

    /* close statement */
    $stmt->close();
}
/* close connection */
$mysqli->close();

?>

Örnek 2 Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (!$link) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* prepare statement */
if ($stmt = mysqli_prepare($link, "SELECT Code, Name FROM Country ORDER BY Name LIMIT 5")) {
    mysqli_stmt_execute($stmt);

    /* bind variables to prepared statement */
    mysqli_stmt_bind_result($stmt, $col1, $col2);

    /* fetch values */
    while (mysqli_stmt_fetch($stmt)) {
        printf("%s %s\n", $col1, $col2);
    }

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

AFG Afghanistan
ALB Albania
DZA Algeria
ASM American Samoa
AND Andorra

Ayrıca Bakınız

  • mysqli_stmt_get_result() - Gets a result set from a prepared statement
  • mysqli_stmt_bind_param() - Binds variables to a prepared statement as parameters
  • mysqli_stmt_execute() - Executes a prepared Query
  • mysqli_stmt_fetch() - Fetch results from a prepared statement into the bound variables
  • mysqli_prepare() - Prepare an SQL statement for execution
  • mysqli_stmt_prepare() - Prepare an SQL statement for execution
  • mysqli_stmt_init() - Initializes a statement and returns an object for use with mysqli_stmt_prepare
  • mysqli_stmt_errno() - Returns the error code for the most recent statement call
  • mysqli_stmt_error() - Returns a string description for last statement error

mysqli_stmt::bind_param
mysqli_stmt::close
mysqli_stmt


Closes a prepared statement

mysqli_stmt::bind_result
mysqli_stmt::__construct
mysqli_stmt
PHP Manual

mysqli_stmt::close

mysqli_stmt_close

(PHP 5, PHP 7)

mysqli_stmt::close -- mysqli_stmt_close — Closes a prepared statement

Açıklama

Nesne yönelimli kullanım

bool mysqli_stmt::close ( void )

Yordamsal kullanım

bool mysqli_stmt_close ( mysqli_stmt $stmt )

Closes a prepared statement. mysqli_stmt_close() also deallocates the statement handle. If the current statement has pending or unread results, this function cancels them so that the next query can be executed.

Değiştirgeler

deyimt

Sadece yordamsal tarz: mysqli_stmt_init() işlevinden dönen bir deyim tanıtıcısı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • mysqli_prepare() - Prepare an SQL statement for execution

mysqli_stmt::bind_result
mysqli_stmt::__construct
mysqli_stmt


Constructs a new mysqli_stmt object

mysqli_stmt::close
mysqli_stmt::data_seek
mysqli_stmt
PHP Manual

mysqli_stmt::__construct

(PHP 5, PHP 7)

mysqli_stmt::__construct — Constructs a new mysqli_stmt object

Açıklama

mysqli_stmt::__construct ( mysqli $link [, string $query ] )

This method constructs a new mysqli_stmt object.

Bilginize:

In general, you should use either mysqli_prepare() or mysqli_stmt_init() to create a mysqli_stmt object, rather than directly instantiating the object with new mysqli_stmt. This method (and the ability to directly instantiate mysqli_stmt objects) may be deprecated and removed in the future.

Değiştirgeler

bağlantı

Sadece yordamsal tarz: mysqli_connect() veya mysqli_init() işlevinden dönen bir bağlantı tanıtıcısı.

query

The query, as a string. If this parameter is omitted, then the constructor behaves identically to mysqli_stmt_init(), if provided, then it behaves as per mysqli_prepare().

Ayrıca Bakınız

  • mysqli_prepare() - Prepare an SQL statement for execution
  • mysqli_stmt_init() - Initializes a statement and returns an object for use with mysqli_stmt_prepare

mysqli_stmt::close
mysqli_stmt::data_seek
mysqli_stmt


Seeks to an arbitrary row in statement result set

mysqli_stmt::__construct
mysqli_stmt::$errno
mysqli_stmt
PHP Manual

mysqli_stmt::data_seek

mysqli_stmt_data_seek

(PHP 5, PHP 7)

mysqli_stmt::data_seek -- mysqli_stmt_data_seek — Seeks to an arbitrary row in statement result set

Açıklama

Nesne yönelimli kullanım

void mysqli_stmt::data_seek ( int $offset )

Yordamsal kullanım

void mysqli_stmt_data_seek ( mysqli_stmt $stmt , int $offset )

Seeks to an arbitrary result pointer in the statement result set.

mysqli_stmt_store_result() must be called prior to mysqli_stmt_data_seek().

Değiştirgeler

deyimt

Sadece yordamsal tarz: mysqli_stmt_init() işlevinden dönen bir deyim tanıtıcısı.

offset

Must be between zero and the total number of rows minus one (0.. mysqli_stmt_num_rows() - 1).

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* Open a connection */
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER BY Name";
if ($stmt = $mysqli->prepare($query)) {

    /* execute query */
    $stmt->execute();

    /* bind result variables */
    $stmt->bind_result($name, $code);

    /* store result */
    $stmt->store_result();

    /* seek to row no. 400 */
    $stmt->data_seek(399);

    /* fetch values */
    $stmt->fetch();

    printf ("City: %s  Countrycode: %s\n", $name, $code);

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

Örnek 2 Yordamsal kullanım

<?php
/* Open a connection */
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER BY Name";
if ($stmt = mysqli_prepare($link, $query)) {

    /* execute query */
    mysqli_stmt_execute($stmt);

    /* bind result variables */
    mysqli_stmt_bind_result($stmt, $name, $code);

    /* store result */
    mysqli_stmt_store_result($stmt);

    /* seek to row no. 400 */
    mysqli_stmt_data_seek($stmt, 399);

    /* fetch values */
    mysqli_stmt_fetch($stmt);

    printf ("City: %s  Countrycode: %s\n", $name, $code);

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

City: Benin City  Countrycode: NGA

Ayrıca Bakınız

  • mysqli_prepare() - Prepare an SQL statement for execution

mysqli_stmt::__construct
mysqli_stmt::$errno
mysqli_stmt


Returns the error code for the most recent statement call

mysqli_stmt::data_seek
mysqli_stmt::$error_list
mysqli_stmt
PHP Manual

mysqli_stmt::$errno

mysqli_stmt_errno

(PHP 5, PHP 7)

mysqli_stmt::$errno -- mysqli_stmt_errno — Returns the error code for the most recent statement call

Açıklama

Nesne yönelimli kullanım

int $mysqli_stmt->errno;

Yordamsal kullanım

int mysqli_stmt_errno ( mysqli_stmt $stmt )

Returns the error code for the most recently invoked statement function that can succeed or fail.

Client error message numbers are listed in the MySQL errmsg.h header file, server error message numbers are listed in mysqld_error.h. In the MySQL source distribution you can find a complete list of error messages and error numbers in the file Docs/mysqld_error.txt.

Değiştirgeler

deyimt

Sadece yordamsal tarz: mysqli_stmt_init() işlevinden dönen bir deyim tanıtıcısı.

Dönen Değerler

An error code value. Zero means no error occurred.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* Open a connection */
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TABLE myCountry LIKE Country");
$mysqli->query("INSERT INTO myCountry SELECT * FROM Country");

$query = "SELECT Name, Code FROM myCountry ORDER BY Name";
if ($stmt = $mysqli->prepare($query)) {

    /* drop table */
    $mysqli->query("DROP TABLE myCountry");

    /* execute query */
    $stmt->execute();

    printf("Error: %d.\n", $stmt->errno);

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

Örnek 2 Yordamsal kullanım

<?php
/* Open a connection */
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($link, "CREATE TABLE myCountry LIKE Country");
mysqli_query($link, "INSERT INTO myCountry SELECT * FROM Country");

$query = "SELECT Name, Code FROM myCountry ORDER BY Name";
if ($stmt = mysqli_prepare($link, $query)) {

    /* drop table */
    mysqli_query($link, "DROP TABLE myCountry");

    /* execute query */
    mysqli_stmt_execute($stmt);

    printf("Error: %d.\n", mysqli_stmt_errno($stmt));

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Error: 1146.

Ayrıca Bakınız

  • mysqli_stmt_error() - Returns a string description for last statement error
  • mysqli_stmt_sqlstate() - Returns SQLSTATE error from previous statement operation

mysqli_stmt::data_seek
mysqli_stmt::$error_list
mysqli_stmt


Returns a list of errors from the last statement executed

mysqli_stmt::$errno
mysqli_stmt::$error
mysqli_stmt
PHP Manual

mysqli_stmt::$error_list

mysqli_stmt_error_list

(PHP 5 >= 5.4.0, PHP 7)

mysqli_stmt::$error_list -- mysqli_stmt_error_list — Returns a list of errors from the last statement executed

Açıklama

Nesne yönelimli kullanım

array $mysqli_stmt->error_list;

Yordamsal kullanım

array mysqli_stmt_error_list ( mysqli_stmt $stmt )

Returns an array of errors for the most recently invoked statement function that can succeed or fail.

Değiştirgeler

deyimt

Sadece yordamsal tarz: mysqli_stmt_init() işlevinden dönen bir deyim tanıtıcısı.

Dönen Değerler

A list of errors, each as an associative array containing the errno, error, and sqlstate.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* Open a connection */
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TABLE myCountry LIKE Country");
$mysqli->query("INSERT INTO myCountry SELECT * FROM Country");

$query = "SELECT Name, Code FROM myCountry ORDER BY Name";
if ($stmt = $mysqli->prepare($query)) {

    /* drop table */
    $mysqli->query("DROP TABLE myCountry");

    /* execute query */
    $stmt->execute();

    echo "Error:\n";
    print_r($stmt->error_list);

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

Örnek 2 Yordamsal kullanım

<?php
/* Open a connection */
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($link, "CREATE TABLE myCountry LIKE Country");
mysqli_query($link, "INSERT INTO myCountry SELECT * FROM Country");

$query = "SELECT Name, Code FROM myCountry ORDER BY Name";
if ($stmt = mysqli_prepare($link, $query)) {

    /* drop table */
    mysqli_query($link, "DROP TABLE myCountry");

    /* execute query */
    mysqli_stmt_execute($stmt);

    echo "Error:\n";
    print_r(mysql_stmt_error_list($stmt));

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Array
(
    [0] => Array
        (
            [errno] => 1146
            [sqlstate] => 42S02
            [error] => Table 'world.myCountry' doesn't exist
        )

)

Ayrıca Bakınız

  • mysqli_stmt_error() - Returns a string description for last statement error
  • mysqli_stmt_errno() - Returns the error code for the most recent statement call
  • mysqli_stmt_sqlstate() - Returns SQLSTATE error from previous statement operation

mysqli_stmt::$errno
mysqli_stmt::$error
mysqli_stmt


Returns a string description for last statement error

mysqli_stmt::$error_list
mysqli_stmt::execute
mysqli_stmt
PHP Manual

mysqli_stmt::$error

mysqli_stmt_error

(PHP 5, PHP 7)

mysqli_stmt::$error -- mysqli_stmt_error — Returns a string description for last statement error

Açıklama

Nesne yönelimli kullanım

string $mysqli_stmt->error;

Yordamsal kullanım

string mysqli_stmt_error ( mysqli_stmt $stmt )

Returns a string containing the error message for the most recently invoked statement function that can succeed or fail.

Değiştirgeler

deyimt

Sadece yordamsal tarz: mysqli_stmt_init() işlevinden dönen bir deyim tanıtıcısı.

Dönen Değerler

A string that describes the error. An empty string if no error occurred.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* Open a connection */
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TABLE myCountry LIKE Country");
$mysqli->query("INSERT INTO myCountry SELECT * FROM Country");

$query = "SELECT Name, Code FROM myCountry ORDER BY Name";
if ($stmt = $mysqli->prepare($query)) {

    /* drop table */
    $mysqli->query("DROP TABLE myCountry");

    /* execute query */
    $stmt->execute();

    printf("Error: %s.\n", $stmt->error);

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

Örnek 2 Yordamsal kullanım

<?php
/* Open a connection */
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($link, "CREATE TABLE myCountry LIKE Country");
mysqli_query($link, "INSERT INTO myCountry SELECT * FROM Country");

$query = "SELECT Name, Code FROM myCountry ORDER BY Name";
if ($stmt = mysqli_prepare($link, $query)) {

    /* drop table */
    mysqli_query($link, "DROP TABLE myCountry");

    /* execute query */
    mysqli_stmt_execute($stmt);

    printf("Error: %s.\n", mysqli_stmt_error($stmt));

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Error: Table 'world.myCountry' doesn't exist.

Ayrıca Bakınız

  • mysqli_stmt_errno() - Returns the error code for the most recent statement call
  • mysqli_stmt_sqlstate() - Returns SQLSTATE error from previous statement operation

mysqli_stmt::$error_list
mysqli_stmt::execute
mysqli_stmt


Executes a prepared Query

mysqli_stmt::$error
mysqli_stmt::fetch
mysqli_stmt
PHP Manual

mysqli_stmt::execute

mysqli_stmt_execute

(PHP 5, PHP 7)

mysqli_stmt::execute -- mysqli_stmt_execute — Executes a prepared Query

Açıklama

Nesne yönelimli kullanım

bool mysqli_stmt::execute ( void )

Yordamsal kullanım

bool mysqli_stmt_execute ( mysqli_stmt $stmt )

Executes a query that has been previously prepared using the mysqli_prepare() function. When executed any parameter markers which exist will automatically be replaced with the appropriate data.

If the statement is UPDATE, DELETE, or INSERT, the total number of affected rows can be determined by using the mysqli_stmt_affected_rows() function. Likewise, if the query yields a result set the mysqli_stmt_fetch() function is used.

Bilginize:

When using mysqli_stmt_execute(), the mysqli_stmt_fetch() function must be used to fetch the data prior to performing any additional queries.

Değiştirgeler

deyimt

Sadece yordamsal tarz: mysqli_stmt_init() işlevinden dönen bir deyim tanıtıcısı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TABLE myCity LIKE City");

/* Prepare an insert statement */
$query = "INSERT INTO myCity (Name, CountryCode, District) VALUES (?,?,?)";
$stmt = $mysqli->prepare($query);

$stmt->bind_param("sss", $val1, $val2, $val3);

$val1 = 'Stuttgart';
$val2 = 'DEU';
$val3 = 'Baden-Wuerttemberg';

/* Execute the statement */
$stmt->execute();

$val1 = 'Bordeaux';
$val2 = 'FRA';
$val3 = 'Aquitaine';

/* Execute the statement */
$stmt->execute();

/* close statement */
$stmt->close();

/* retrieve all rows from myCity */
$query = "SELECT Name, CountryCode, District FROM myCity";
if ($result = $mysqli->query($query)) {
    while ($row = $result->fetch_row()) {
        printf("%s (%s,%s)\n", $row[0], $row[1], $row[2]);
    }
    /* free result set */
    $result->close();
}

/* remove table */
$mysqli->query("DROP TABLE myCity");

/* close connection */
$mysqli->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($link, "CREATE TABLE myCity LIKE City");

/* Prepare an insert statement */
$query = "INSERT INTO myCity (Name, CountryCode, District) VALUES (?,?,?)";
$stmt = mysqli_prepare($link, $query);

mysqli_stmt_bind_param($stmt, "sss", $val1, $val2, $val3);

$val1 = 'Stuttgart';
$val2 = 'DEU';
$val3 = 'Baden-Wuerttemberg';

/* Execute the statement */
mysqli_stmt_execute($stmt);

$val1 = 'Bordeaux';
$val2 = 'FRA';
$val3 = 'Aquitaine';

/* Execute the statement */
mysqli_stmt_execute($stmt);

/* close statement */
mysqli_stmt_close($stmt);

/* retrieve all rows from myCity */
$query = "SELECT Name, CountryCode, District FROM myCity";
if ($result = mysqli_query($link, $query)) {
    while ($row = mysqli_fetch_row($result)) {
        printf("%s (%s,%s)\n", $row[0], $row[1], $row[2]);
    }
    /* free result set */
    mysqli_free_result($result);
}

/* remove table */
mysqli_query($link, "DROP TABLE myCity");

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Stuttgart (DEU,Baden-Wuerttemberg)
Bordeaux (FRA,Aquitaine)

Ayrıca Bakınız

  • mysqli_prepare() - Prepare an SQL statement for execution
  • mysqli_stmt_bind_param() - Binds variables to a prepared statement as parameters
  • mysqli_stmt_get_result() - Gets a result set from a prepared statement

mysqli_stmt::$error
mysqli_stmt::fetch
mysqli_stmt


Fetch results from a prepared statement into the bound variables

mysqli_stmt::execute
mysqli_stmt::$field_count
mysqli_stmt
PHP Manual

mysqli_stmt::fetch

mysqli_stmt_fetch

(PHP 5, PHP 7)

mysqli_stmt::fetch -- mysqli_stmt_fetch — Fetch results from a prepared statement into the bound variables

Açıklama

Nesne yönelimli kullanım

bool mysqli_stmt::fetch ( void )

Yordamsal kullanım

bool mysqli_stmt_fetch ( mysqli_stmt $stmt )

Fetch the result from a prepared statement into the variables bound by mysqli_stmt_bind_result().

Bilginize:

Note that all columns must be bound by the application before calling mysqli_stmt_fetch().

Bilginize:

Data are transferred unbuffered without calling mysqli_stmt_store_result() which can decrease performance (but reduces memory cost).

Değiştirgeler

deyimt

Sadece yordamsal tarz: mysqli_stmt_init() işlevinden dönen bir deyim tanıtıcısı.

Dönen Değerler

Dönen Değerler
Value | Description
TRUE | Success. Data has been fetched
FALSE | Error occurred
NULL | No more rows/data exists or data truncation occurred

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER by ID DESC LIMIT 150,5";

if ($stmt = $mysqli->prepare($query)) {

    /* execute statement */
    $stmt->execute();

    /* bind result variables */
    $stmt->bind_result($name, $code);

    /* fetch values */
    while ($stmt->fetch()) {
        printf ("%s (%s)\n", $name, $code);
    }

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER by ID DESC LIMIT 150,5";

if ($stmt = mysqli_prepare($link, $query)) {

    /* execute statement */
    mysqli_stmt_execute($stmt);

    /* bind result variables */
    mysqli_stmt_bind_result($stmt, $name, $code);

    /* fetch values */
    while (mysqli_stmt_fetch($stmt)) {
        printf ("%s (%s)\n", $name, $code);
    }

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Rockford (USA)
Tallahassee (USA)
Salinas (USA)
Santa Clarita (USA)
Springfield (USA)

Ayrıca Bakınız

  • mysqli_prepare() - Prepare an SQL statement for execution
  • mysqli_stmt_errno() - Returns the error code for the most recent statement call
  • mysqli_stmt_error() - Returns a string description for last statement error
  • mysqli_stmt_bind_result() - Binds variables to a prepared statement for result storage

mysqli_stmt::execute
mysqli_stmt::$field_count
mysqli_stmt


Returns the number of field in the given statement

mysqli_stmt::fetch
mysqli_stmt::free_result
mysqli_stmt
PHP Manual

mysqli_stmt::$field_count

mysqli_stmt_field_count

(PHP 5, PHP 7)

mysqli_stmt::$field_count -- mysqli_stmt_field_count — Returns the number of field in the given statement

Açıklama

Nesne yönelimli kullanım

int $mysqli_stmt->field_count;

Yordamsal kullanım

int mysqli_stmt_field_count ( mysqli_stmt $stmt )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

mysqli_stmt::fetch
mysqli_stmt::free_result
mysqli_stmt


Frees stored result memory for the given statement handle

mysqli_stmt::$field_count
mysqli_stmt::get_result
mysqli_stmt
PHP Manual

mysqli_stmt::free_result

mysqli_stmt_free_result

(PHP 5, PHP 7)

mysqli_stmt::free_result -- mysqli_stmt_free_result — Frees stored result memory for the given statement handle

Açıklama

Nesne yönelimli kullanım

void mysqli_stmt::free_result ( void )

Yordamsal kullanım

void mysqli_stmt_free_result ( mysqli_stmt $stmt )

Frees the result memory associated with the statement, which was allocated by mysqli_stmt_store_result().

Değiştirgeler

deyimt

Sadece yordamsal tarz: mysqli_stmt_init() işlevinden dönen bir deyim tanıtıcısı.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • mysqli_stmt_store_result() - Transfers a result set from a prepared statement

mysqli_stmt::$field_count
mysqli_stmt::get_result
mysqli_stmt


Gets a result set from a prepared statement

mysqli_stmt::free_result
mysqli_stmt::get_warnings
mysqli_stmt
PHP Manual

mysqli_stmt::get_result

mysqli_stmt_get_result

(PHP 5 >= 5.3.0, PHP 7)

mysqli_stmt::get_result -- mysqli_stmt_get_result — Gets a result set from a prepared statement

Açıklama

Nesne yönelimli kullanım

mysqli_result mysqli_stmt::get_result ( void )

Yordamsal kullanım

mysqli_result mysqli_stmt_get_result ( mysqli_stmt $stmt )

Call to return a result set from a prepared statement query.

Değiştirgeler

deyimt

Sadece yordamsal tarz: mysqli_stmt_init() işlevinden dönen bir deyim tanıtıcısı.

Dönen Değerler

Returns a resultset for successful SELECT queries, or FALSE for other DML queries or on failure. The mysqli_errno() function can be used to distinguish between the two types of failure.

Sadece MySQL Doğal Sürücüsü

Sadece mysqlnd ile kullanılabilir.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php

$mysqli = new mysqli("127.0.0.1", "user", "password", "world");

if($mysqli->connect_error)
{
    die("$mysqli->connect_errno: $mysqli->connect_error");
}

$query = "SELECT Name, Population, Continent FROM Country WHERE Continent=? ORDER BY Name LIMIT 1";

$stmt = $mysqli->stmt_init();
if(!$stmt->prepare($query))
{
    print "Failed to prepare statement\n";
}
else
{
    $stmt->bind_param("s", $continent);

    $continent_array = array('Europe','Africa','Asia','North America');

    foreach($continent_array as $continent)
    {
        $stmt->execute();
        $result = $stmt->get_result();
        while ($row = $result->fetch_array(MYSQLI_NUM))
        {
            foreach ($row as $r)
            {
                print "$r ";
            }
            print "\n";
        }
    }
}

$stmt->close();
$mysqli->close();
?>

Örnek 2 Yordamsal kullanım

<?php

$link = mysqli_connect("127.0.0.1", "user", "password", "world");

if (!$link)
{
    $error = mysqli_connect_error();
    $errno = mysqli_connect_errno();
    print "$errno: $error\n";
    exit();
}

$query = "SELECT Name, Population, Continent FROM Country WHERE Continent=? ORDER BY Name LIMIT 1";

$stmt = mysqli_stmt_init($link);
if(!mysqli_stmt_prepare($stmt, $query))
{
    print "Failed to prepare statement\n";
}
else
{
    mysqli_stmt_bind_param($stmt, "s", $continent);

    $continent_array = array('Europe','Africa','Asia','North America');

    foreach($continent_array as $continent)
    {
        mysqli_stmt_execute($stmt);
        $result = mysqli_stmt_get_result($stmt);
        while ($row = mysqli_fetch_array($result, MYSQLI_NUM))
        {
            foreach ($row as $r)
            {
                print "$r ";
            }
            print "\n";
        }
    }
}
mysqli_stmt_close($stmt);
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Albania 3401200 Europe
Algeria 31471000 Africa
Afghanistan 22720000 Asia
Anguilla 8000 North America

Ayrıca Bakınız

  • mysqli_prepare() - Prepare an SQL statement for execution
  • mysqli_stmt_result_metadata() - Returns result set metadata from a prepared statement
  • mysqli_stmt_fetch() - Fetch results from a prepared statement into the bound variables
  • mysqli_fetch_array() - Fetch a result row as an associative, a numeric array, or both
  • mysqli_stmt_store_result() - Transfers a result set from a prepared statement
  • mysqli_errno() - Returns the error code for the most recent function call

mysqli_stmt::free_result
mysqli_stmt::get_warnings
mysqli_stmt


Get result of SHOW WARNINGS

mysqli_stmt::get_result
mysqli_stmt::$insert_id
mysqli_stmt
PHP Manual

mysqli_stmt::get_warnings

mysqli_stmt_get_warnings

(PHP 5 >= 5.1.0, PHP 7)

mysqli_stmt::get_warnings -- mysqli_stmt_get_warnings — Get result of SHOW WARNINGS

Açıklama

Nesne yönelimli kullanım

object mysqli_stmt::get_warnings ( mysqli_stmt $stmt )

Yordamsal kullanım

object mysqli_stmt_get_warnings ( mysqli_stmt $stmt )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

mysqli_stmt::get_result
mysqli_stmt::$insert_id
mysqli_stmt


Get the ID generated from the previous INSERT operation

mysqli_stmt::get_warnings
mysqli_stmt::more_results
mysqli_stmt
PHP Manual

mysqli_stmt::$insert_id

mysqli_stmt_insert_id

(PHP 5, PHP 7)

mysqli_stmt::$insert_id -- mysqli_stmt_insert_id — Get the ID generated from the previous INSERT operation

Açıklama

Nesne yönelimli kullanım

int $mysqli_stmt->insert_id;

Yordamsal kullanım

mixed mysqli_stmt_insert_id ( mysqli_stmt $stmt )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

mysqli_stmt::get_warnings
mysqli_stmt::more_results
mysqli_stmt


Check if there are more query results from a multiple query

mysqli_stmt::$insert_id
mysqli_stmt::next_result
mysqli_stmt
PHP Manual

mysqli_stmt::more_results

mysqli_stmt_more_results

(PHP 5 >= 5.3.0, PHP 7)

mysqli_stmt::more_results -- mysqli_stmt_more_results — Check if there are more query results from a multiple query

Açıklama

Nesne yönelimli kullanım (method):

public bool mysqli_stmt::more_results ( void )

Yordamsal kullanım:

bool mysqli_stmt_more_results ( mysql_stmt $stmt )

Checks if there are more query results from a multiple query.

Değiştirgeler

deyimt

Sadece yordamsal tarz: mysqli_stmt_init() işlevinden dönen bir deyim tanıtıcısı.

Dönen Değerler

Returns TRUE if more results exist, otherwise FALSE.

Sadece MySQL Doğal Sürücüsü

Sadece mysqlnd ile kullanılabilir.

Ayrıca Bakınız

  • mysqli_stmt::next_result() - Reads the next result from a multiple query
  • mysqli::multi_query() - Performs a query on the database

mysqli_stmt::$insert_id
mysqli_stmt::next_result
mysqli_stmt


Reads the next result from a multiple query

mysqli_stmt::more_results
mysqli_stmt::$num_rows
mysqli_stmt
PHP Manual

mysqli_stmt::next_result

mysqli_stmt_next_result

(PHP 5 >= 5.3.0, PHP 7)

mysqli_stmt::next_result -- mysqli_stmt_next_result — Reads the next result from a multiple query

Açıklama

Nesne yönelimli kullanım (method):

public bool mysqli_stmt::next_result ( void )

Yordamsal kullanım:

bool mysqli_stmt_next_result ( mysql_stmt $stmt )

Reads the next result from a multiple query.

Değiştirgeler

deyimt

Sadece yordamsal tarz: mysqli_stmt_init() işlevinden dönen bir deyim tanıtıcısı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

Emits an E_STRICT level error if a result set does not exist, and suggests using mysqli_stmt::more_results() in these cases, before calling mysqli_stmt::next_result().

Sadece MySQL Doğal Sürücüsü

Sadece mysqlnd ile kullanılabilir.

Ayrıca Bakınız

  • mysqli_stmt::more_results() - Check if there are more query results from a multiple query
  • mysqli::multi_query() - Performs a query on the database

mysqli_stmt::more_results
mysqli_stmt::$num_rows
mysqli_stmt


Return the number of rows in statements result set

mysqli_stmt::next_result
mysqli_stmt::$param_count
mysqli_stmt
PHP Manual

mysqli_stmt::$num_rows

mysqli_stmt_num_rows

(PHP 5, PHP 7)

mysqli_stmt::$num_rows -- mysqli_stmt_num_rows — Return the number of rows in statements result set

Açıklama

Nesne yönelimli kullanım

int $mysqli_stmt->num_rows;

Yordamsal kullanım

int mysqli_stmt_num_rows ( mysqli_stmt $stmt )

Returns the number of rows in the result set. The use of mysqli_stmt_num_rows() depends on whether or not you used mysqli_stmt_store_result() to buffer the entire result set in the statement handle.

If you use mysqli_stmt_store_result(), mysqli_stmt_num_rows() may be called immediately.

Değiştirgeler

deyimt

Sadece yordamsal tarz: mysqli_stmt_init() işlevinden dönen bir deyim tanıtıcısı.

Dönen Değerler

An integer representing the number of rows in result set.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* Open a connection */
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER BY Name LIMIT 20";
if ($stmt = $mysqli->prepare($query)) {

    /* execute query */
    $stmt->execute();

    /* store result */
    $stmt->store_result();

    printf("Number of rows: %d.\n", $stmt->num_rows);

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

Örnek 2 Yordamsal kullanım

<?php
/* Open a connection */
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER BY Name LIMIT 20";
if ($stmt = mysqli_prepare($link, $query)) {

    /* execute query */
    mysqli_stmt_execute($stmt);

    /* store result */
    mysqli_stmt_store_result($stmt);

    printf("Number of rows: %d.\n", mysqli_stmt_num_rows($stmt));

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Number of rows: 20.

Ayrıca Bakınız

  • mysqli_stmt_affected_rows() - Returns the total number of rows changed, deleted, or inserted by the last executed statement
  • mysqli_prepare() - Prepare an SQL statement for execution
  • mysqli_stmt_store_result() - Transfers a result set from a prepared statement

mysqli_stmt::next_result
mysqli_stmt::$param_count
mysqli_stmt


Returns the number of parameter for the given statement

mysqli_stmt::$num_rows
mysqli_stmt::prepare
mysqli_stmt
PHP Manual

mysqli_stmt::$param_count

mysqli_stmt_param_count

(PHP 5, PHP 7)

mysqli_stmt::$param_count -- mysqli_stmt_param_count — Returns the number of parameter for the given statement

Açıklama

Nesne yönelimli kullanım

int $mysqli_stmt->param_count;

Yordamsal kullanım

int mysqli_stmt_param_count ( mysqli_stmt $stmt )

Returns the number of parameter markers present in the prepared statement.

Değiştirgeler

deyimt

Sadece yordamsal tarz: mysqli_stmt_init() işlevinden dönen bir deyim tanıtıcısı.

Dönen Değerler

Returns an integer representing the number of parameters.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if ($stmt = $mysqli->prepare("SELECT Name FROM Country WHERE Name=? OR Code=?")) {

    $marker = $stmt->param_count;
    printf("Statement has %d markers.\n", $marker);

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if ($stmt = mysqli_prepare($link, "SELECT Name FROM Country WHERE Name=? OR Code=?")) {

    $marker = mysqli_stmt_param_count($stmt);
    printf("Statement has %d markers.\n", $marker);

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Statement has 2 markers.

Ayrıca Bakınız

  • mysqli_prepare() - Prepare an SQL statement for execution

mysqli_stmt::$num_rows
mysqli_stmt::prepare
mysqli_stmt


Prepare an SQL statement for execution

mysqli_stmt::$param_count
mysqli_stmt::reset
mysqli_stmt
PHP Manual

mysqli_stmt::prepare

mysqli_stmt_prepare

(PHP 5, PHP 7)

mysqli_stmt::prepare -- mysqli_stmt_prepare — Prepare an SQL statement for execution

Açıklama

Nesne yönelimli kullanım

mixed mysqli_stmt::prepare ( string $query )

Yordamsal kullanım

bool mysqli_stmt_prepare ( mysqli_stmt $stmt , string $query )

Prepares the SQL query pointed to by the null-terminated string query.

The parameter markers must be bound to application variables using mysqli_stmt_bind_param() and/or mysqli_stmt_bind_result() before executing the statement or fetching rows.

Bilginize:

In the case where you pass a statement to mysqli_stmt_prepare() that is longer than max_allowed_packet of the server, the returned error codes are different depending on whether you are using MySQL Native Driver (mysqlnd) or MySQL Client Library (libmysqlclient). The behavior is as follows:

  • mysqlnd on Linux returns an error code of 1153. The error message means "got a packet bigger than max_allowed_packet bytes".

  • mysqlnd on Windows returns an error code 2006. This error message means "server has gone away".

  • libmysqlclient on all platforms returns an error code 2006. This error message means "server has gone away".

Değiştirgeler

deyimt

Sadece yordamsal tarz: mysqli_stmt_init() işlevinden dönen bir deyim tanıtıcısı.

query

The query, as a string. It must consist of a single SQL statement.

You can include one or more parameter markers in the SQL statement by embedding question mark (?) characters at the appropriate positions.

Bilginize:

You should not add a terminating semicolon or \g to the statement.

Bilginize:

The markers are legal only in certain places in SQL statements. For example, they are allowed in the VALUES() list of an INSERT statement (to specify column values for a row), or in a comparison with a column in a WHERE clause to specify a comparison value.

However, they are not allowed for identifiers (such as table or column names), in the select list that names the columns to be returned by a SELECT statement), or to specify both operands of a binary operator such as the = equal sign. The latter restriction is necessary because it would be impossible to determine the parameter type. In general, parameters are legal only in Data Manipulation Language (DML) statements, and not in Data Definition Language (DDL) statements.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$city = "Amersfoort";

/* create a prepared statement */
$stmt =  $mysqli->stmt_init();
if ($stmt->prepare("SELECT District FROM City WHERE Name=?")) {

    /* bind parameters for markers */
    $stmt->bind_param("s", $city);

    /* execute query */
    $stmt->execute();

    /* bind result variables */
    $stmt->bind_result($district);

    /* fetch value */
    $stmt->fetch();

    printf("%s is in district %s\n", $city, $district);

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$city = "Amersfoort";

/* create a prepared statement */
$stmt = mysqli_stmt_init($link);
if (mysqli_stmt_prepare($stmt, 'SELECT District FROM City WHERE Name=?')) {

    /* bind parameters for markers */
    mysqli_stmt_bind_param($stmt, "s", $city);

    /* execute query */
    mysqli_stmt_execute($stmt);

    /* bind result variables */
    mysqli_stmt_bind_result($stmt, $district);

    /* fetch value */
    mysqli_stmt_fetch($stmt);

    printf("%s is in district %s\n", $city, $district);

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Amersfoort is in district Utrecht

Ayrıca Bakınız

  • mysqli_stmt_init() - Initializes a statement and returns an object for use with mysqli_stmt_prepare
  • mysqli_stmt_execute() - Executes a prepared Query
  • mysqli_stmt_fetch() - Fetch results from a prepared statement into the bound variables
  • mysqli_stmt_bind_param() - Binds variables to a prepared statement as parameters
  • mysqli_stmt_bind_result() - Binds variables to a prepared statement for result storage
  • mysqli_stmt_get_result() - Gets a result set from a prepared statement
  • mysqli_stmt_close() - Closes a prepared statement

mysqli_stmt::$param_count
mysqli_stmt::reset
mysqli_stmt


Resets a prepared statement

mysqli_stmt::prepare
mysqli_stmt::result_metadata
mysqli_stmt
PHP Manual

mysqli_stmt::reset

mysqli_stmt_reset

(PHP 5, PHP 7)

mysqli_stmt::reset -- mysqli_stmt_reset — Resets a prepared statement

Açıklama

Nesne yönelimli kullanım

bool mysqli_stmt::reset ( void )

Yordamsal kullanım

bool mysqli_stmt_reset ( mysqli_stmt $stmt )

Resets a prepared statement on client and server to state after prepare.

It resets the statement on the server, data sent using mysqli_stmt_send_long_data(), unbuffered result sets and current errors. It does not clear bindings or stored result sets. Stored result sets will be cleared when executing the prepared statement (or closing it).

To prepare a statement with another query use function mysqli_stmt_prepare().

Değiştirgeler

deyimt

Sadece yordamsal tarz: mysqli_stmt_init() işlevinden dönen bir deyim tanıtıcısı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • mysqli_prepare() - Prepare an SQL statement for execution

mysqli_stmt::prepare
mysqli_stmt::result_metadata
mysqli_stmt


Returns result set metadata from a prepared statement

mysqli_stmt::reset
mysqli_stmt::send_long_data
mysqli_stmt
PHP Manual

mysqli_stmt::result_metadata

mysqli_stmt_result_metadata

(PHP 5, PHP 7)

mysqli_stmt::result_metadata -- mysqli_stmt_result_metadata — Returns result set metadata from a prepared statement

Açıklama

Nesne yönelimli kullanım

mysqli_result mysqli_stmt::result_metadata ( void )

Yordamsal kullanım

mysqli_result mysqli_stmt_result_metadata ( mysqli_stmt $stmt )

If a statement passed to mysqli_prepare() is one that produces a result set, mysqli_stmt_result_metadata() returns the result object that can be used to process the meta information such as total number of fields and individual field information.

Bilginize:

This result set pointer can be passed as an argument to any of the field-based functions that process result set metadata, such as:

  • mysqli_num_fields()

  • mysqli_fetch_field()

  • mysqli_fetch_field_direct()

  • mysqli_fetch_fields()

  • mysqli_field_count()

  • mysqli_field_seek()

  • mysqli_field_tell()

  • mysqli_free_result()

The result set structure should be freed when you are done with it, which you can do by passing it to mysqli_free_result()

Bilginize:

The result set returned by mysqli_stmt_result_metadata() contains only metadata. It does not contain any row results. The rows are obtained by using the statement handle with mysqli_stmt_fetch().

Değiştirgeler

deyimt

Sadece yordamsal tarz: mysqli_stmt_init() işlevinden dönen bir deyim tanıtıcısı.

Dönen Değerler

Returns a result object or FALSE if an error occurred.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "test");

$mysqli->query("DROP TABLE IF EXISTS friends");
$mysqli->query("CREATE TABLE friends (id int, name varchar(20))");

$mysqli->query("INSERT INTO friends VALUES (1,'Hartmut'), (2, 'Ulf')");

$stmt = $mysqli->prepare("SELECT id, name FROM friends");
$stmt->execute();

/* get resultset for metadata */
$result = $stmt->result_metadata();

/* retrieve field information from metadata result set */
$field = $result->fetch_field();

printf("Fieldname: %s\n", $field->name);

/* close resultset */
$result->close();

/* close connection */
$mysqli->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "test");

mysqli_query($link, "DROP TABLE IF EXISTS friends");
mysqli_query($link, "CREATE TABLE friends (id int, name varchar(20))");

mysqli_query($link, "INSERT INTO friends VALUES (1,'Hartmut'), (2, 'Ulf')");

$stmt = mysqli_prepare($link, "SELECT id, name FROM friends");
mysqli_stmt_execute($stmt);

/* get resultset for metadata */
$result = mysqli_stmt_result_metadata($stmt);

/* retrieve field information from metadata result set */
$field = mysqli_fetch_field($result);

printf("Fieldname: %s\n", $field->name);

/* close resultset */
mysqli_free_result($result);

/* close connection */
mysqli_close($link);
?>

Ayrıca Bakınız

  • mysqli_prepare() - Prepare an SQL statement for execution
  • mysqli_free_result() - Frees the memory associated with a result

mysqli_stmt::reset
mysqli_stmt::send_long_data
mysqli_stmt


Send data in blocks

mysqli_stmt::result_metadata
mysqli_stmt::$sqlstate
mysqli_stmt
PHP Manual

mysqli_stmt::send_long_data

mysqli_stmt_send_long_data

(PHP 5, PHP 7)

mysqli_stmt::send_long_data -- mysqli_stmt_send_long_data — Send data in blocks

Açıklama

Nesne yönelimli kullanım

bool mysqli_stmt::send_long_data ( int $param_nr , string $data )

Yordamsal kullanım

bool mysqli_stmt_send_long_data ( mysqli_stmt $stmt , int $param_nr , string $data )

Allows to send parameter data to the server in pieces (or chunks), e.g. if the size of a blob exceeds the size of max_allowed_packet. This function can be called multiple times to send the parts of a character or binary data value for a column, which must be one of the TEXT or BLOB datatypes.

Değiştirgeler

deyimt

Sadece yordamsal tarz: mysqli_stmt_init() işlevinden dönen bir deyim tanıtıcısı.

param_nr

Indicates which parameter to associate the data with. Parameters are numbered beginning with 0.

data

A string containing data to be sent.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$stmt = $mysqli->prepare("INSERT INTO messages (message) VALUES (?)");
$null = NULL;
$stmt->bind_param("b", $null);
$fp = fopen("messages.txt", "r");
while (!feof($fp)) {
    $stmt->send_long_data(0, fread($fp, 8192));
}
fclose($fp);
$stmt->execute();
?>

Ayrıca Bakınız

  • mysqli_prepare() - Prepare an SQL statement for execution
  • mysqli_stmt_bind_param() - Binds variables to a prepared statement as parameters

mysqli_stmt::result_metadata
mysqli_stmt::$sqlstate
mysqli_stmt


Returns SQLSTATE error from previous statement operation

mysqli_stmt::send_long_data
mysqli_stmt::store_result
mysqli_stmt
PHP Manual

mysqli_stmt::$sqlstate

mysqli_stmt_sqlstate

(PHP 5, PHP 7)

mysqli_stmt::$sqlstate -- mysqli_stmt_sqlstate — Returns SQLSTATE error from previous statement operation

Açıklama

Nesne yönelimli kullanım

string $mysqli_stmt->sqlstate;

Yordamsal kullanım

string mysqli_stmt_sqlstate ( mysqli_stmt $stmt )

Returns a string containing the SQLSTATE error code for the most recently invoked prepared statement function that can succeed or fail. The error code consists of five characters. '00000' means no error. The values are specified by ANSI SQL and ODBC. For a list of possible values, see » http://dev.mysql.com/doc/mysql/en/error-handling.html.

Değiştirgeler

deyimt

Sadece yordamsal tarz: mysqli_stmt_init() işlevinden dönen bir deyim tanıtıcısı.

Dönen Değerler

Returns a string containing the SQLSTATE error code for the last error. The error code consists of five characters. '00000' means no error.

Notlar

Bilginize:

Note that not all MySQL errors are yet mapped to SQLSTATE's. The value HY000 (general error) is used for unmapped errors.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* Open a connection */
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TABLE myCountry LIKE Country");
$mysqli->query("INSERT INTO myCountry SELECT * FROM Country");

$query = "SELECT Name, Code FROM myCountry ORDER BY Name";
if ($stmt = $mysqli->prepare($query)) {

    /* drop table */
    $mysqli->query("DROP TABLE myCountry");

    /* execute query */
    $stmt->execute();

    printf("Error: %s.\n", $stmt->sqlstate);

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

Örnek 2 Yordamsal kullanım

<?php
/* Open a connection */
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($link, "CREATE TABLE myCountry LIKE Country");
mysqli_query($link, "INSERT INTO myCountry SELECT * FROM Country");

$query = "SELECT Name, Code FROM myCountry ORDER BY Name";
if ($stmt = mysqli_prepare($link, $query)) {

    /* drop table */
    mysqli_query($link, "DROP TABLE myCountry");

    /* execute query */
    mysqli_stmt_execute($stmt);

    printf("Error: %s.\n", mysqli_stmt_sqlstate($stmt));

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Error: 42S02.

Ayrıca Bakınız

  • mysqli_stmt_errno() - Returns the error code for the most recent statement call
  • mysqli_stmt_error() - Returns a string description for last statement error

mysqli_stmt::send_long_data
mysqli_stmt::store_result
mysqli_stmt


Transfers a result set from a prepared statement

mysqli_stmt::$sqlstate
mysqli_result
mysqli_stmt
PHP Manual

mysqli_stmt::store_result

mysqli_stmt_store_result

(PHP 5, PHP 7)

mysqli_stmt::store_result -- mysqli_stmt_store_result — Transfers a result set from a prepared statement

Açıklama

Nesne yönelimli kullanım

bool mysqli_stmt::store_result ( void )

Yordamsal kullanım

bool mysqli_stmt_store_result ( mysqli_stmt $stmt )

You must call mysqli_stmt_store_result() for every query that successfully produces a result set (SELECT, SHOW, DESCRIBE, EXPLAIN), if and only if you want to buffer the complete result set by the client, so that the subsequent mysqli_stmt_fetch() call returns buffered data.

Bilginize:

It is unnecessary to call mysqli_stmt_store_result() for other queries, but if you do, it will not harm or cause any notable performance loss in all cases. You can detect whether the query produced a result set by checking if mysqli_stmt_result_metadata() returns NULL.

Değiştirgeler

deyimt

Sadece yordamsal tarz: mysqli_stmt_init() işlevinden dönen bir deyim tanıtıcısı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* Open a connection */
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER BY Name LIMIT 20";
if ($stmt = $mysqli->prepare($query)) {

    /* execute query */
    $stmt->execute();

    /* store result */
    $stmt->store_result();

    printf("Number of rows: %d.\n", $stmt->num_rows);

    /* free result */
    $stmt->free_result();

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

Örnek 2 Yordamsal kullanım

<?php
/* Open a connection */
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER BY Name LIMIT 20";
if ($stmt = mysqli_prepare($link, $query)) {

    /* execute query */
    mysqli_stmt_execute($stmt);

    /* store result */
    mysqli_stmt_store_result($stmt);

    printf("Number of rows: %d.\n", mysqli_stmt_num_rows($stmt));

    /* free result */
    mysqli_stmt_free_result($stmt);

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Number of rows: 20.

Ayrıca Bakınız

  • mysqli_prepare() - Prepare an SQL statement for execution
  • mysqli_stmt_result_metadata() - Returns result set metadata from a prepared statement
  • mysqli_stmt_fetch() - Fetch results from a prepared statement into the bound variables

mysqli_stmt::$sqlstate
mysqli_result
mysqli_stmt


The mysqli_result class

(PHP 5, PHP 7)

Giriş

Represents the result set obtained from a query against the database.

Sürüm Bilgisi

Sürüm Bilgisi
Sürüm: | Açıklama
5.4.0 | Iterator support was added, as mysqli_result now implements Traversable.

Sınıf Sözdizimi

mysqli_result implements Traversable {
/* Özellikler */
int $current_field ;
int $field_count;
array $lengths;
int $num_rows;
/* Yöntemler */
bool data_seek ( int $offset )
mixed fetch_all ([ int $resulttype = MYSQLI_NUM ] )
mixed fetch_array ([ int $resulttype = MYSQLI_BOTH ] )
array fetch_assoc ( void )
object fetch_field_direct ( int $fieldnr )
object fetch_field ( void )
array fetch_fields ( void )
object fetch_object ([ string $class_name = "stdClass" [, array $params ]] )
mixed fetch_row ( void )
bool field_seek ( int $fieldnr )
void free ( void )
}

İçindekiler

  • mysqli_result::$current_field — Get current field offset of a result pointer
  • mysqli_result::data_seek — Adjusts the result pointer to an arbitrary row in the result
  • mysqli_result::fetch_all — Fetches all result rows as an associative array, a numeric array, or both
  • mysqli_result::fetch_array — Fetch a result row as an associative, a numeric array, or both
  • mysqli_result::fetch_assoc — Fetch a result row as an associative array
  • mysqli_result::fetch_field_direct — Fetch meta-data for a single field
  • mysqli_result::fetch_field — Returns the next field in the result set
  • mysqli_result::fetch_fields — Returns an array of objects representing the fields in a result set
  • mysqli_result::fetch_object — Returns the current row of a result set as an object
  • mysqli_result::fetch_row — Get a result row as an enumerated array
  • mysqli_result::$field_count — Get the number of fields in a result
  • mysqli_result::field_seek — Set result pointer to a specified field offset
  • mysqli_result::free — Frees the memory associated with a result
  • mysqli_result::$lengths — Returns the lengths of the columns of the current row in the result set
  • mysqli_result::$num_rows — Gets the number of rows in a result
mysqli_stmt::store_result
mysqli_result::$current_field
MySQLi


Get current field offset of a result pointer

mysqli_result
mysqli_result::data_seek
mysqli_result
PHP Manual

mysqli_result::$current_field

mysqli_field_tell

(PHP 5, PHP 7)

mysqli_result::$current_field -- mysqli_field_tell — Get current field offset of a result pointer

Açıklama

Nesne yönelimli kullanım

int $mysqli_result->current_field ;

Yordamsal kullanım

int mysqli_field_tell ( mysqli_result $result )

Returns the position of the field cursor used for the last mysqli_fetch_field() call. This value can be used as an argument to mysqli_field_seek().

Değiştirgeler

sonuç

Sadece yordamsal tarz: mysqli_query(),
mysqli_store_result() veya
mysqli_use_result() işlevinden dönen bir sonuç kümesi
tanıtıcısı.

Dönen Değerler

Returns current offset of field cursor.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, SurfaceArea from Country ORDER BY Code LIMIT 5";

if ($result = $mysqli->query($query)) {

    /* Get field information for all columns */
    while ($finfo = $result->fetch_field()) {

        /* get fieldpointer offset */
        $currentfield = $result->current_field;

        printf("Column %d:\n", $currentfield);
        printf("Name:     %s\n", $finfo->name);
        printf("Table:    %s\n", $finfo->table);
        printf("max. Len: %d\n", $finfo->max_length);
        printf("Flags:    %d\n", $finfo->flags);
        printf("Type:     %d\n\n", $finfo->type);
    }
    $result->close();
}

/* close connection */
$mysqli->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, SurfaceArea from Country ORDER BY Code LIMIT 5";

if ($result = mysqli_query($link, $query)) {

    /* Get field information for all fields */
    while ($finfo = mysqli_fetch_field($result)) {

        /* get fieldpointer offset */
        $currentfield = mysqli_field_tell($result);

        printf("Column %d:\n", $currentfield);
        printf("Name:     %s\n", $finfo->name);
        printf("Table:    %s\n", $finfo->table);
        printf("max. Len: %d\n", $finfo->max_length);
        printf("Flags:    %d\n", $finfo->flags);
        printf("Type:     %d\n\n", $finfo->type);
    }
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Column 1:
Name:     Name
Table:    Country
max. Len: 11
Flags:    1
Type:     254

Column 2:
Name:     SurfaceArea
Table:    Country
max. Len: 10
Flags:    32769
Type:     4

Ayrıca Bakınız

  • mysqli_fetch_field() - Returns the next field in the result set
  • mysqli_field_seek() - Set result pointer to a specified field offset

mysqli_result
mysqli_result::data_seek
mysqli_result


Adjusts the result pointer to an arbitrary row in the result

mysqli_result::$current_field
mysqli_result::fetch_all
mysqli_result
PHP Manual

mysqli_result::data_seek

mysqli_data_seek

(PHP 5, PHP 7)

mysqli_result::data_seek -- mysqli_data_seek — Adjusts the result pointer to an arbitrary row in the result

Açıklama

Nesne yönelimli kullanım

bool mysqli_result::data_seek ( int $offset )

Yordamsal kullanım

bool mysqli_data_seek ( mysqli_result $result , int $offset )

The mysqli_data_seek() function seeks to an arbitrary result pointer specified by the offset in the result set.

Değiştirgeler

sonuç

Sadece yordamsal tarz: mysqli_query(),
mysqli_store_result() veya
mysqli_use_result() işlevinden dönen bir sonuç kümesi
tanıtıcısı.

offset

The field offset. Must be between zero and the total number of rows minus one (0..mysqli_num_rows() - 1).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

Bilginize:

This function can only be used with buffered results attained from the use of the mysqli_store_result() or mysqli_query() functions.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* Open a connection */
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER BY Name";
if ($result = $mysqli->query($query)) {

    /* seek to row no. 400 */
    $result->data_seek(399);

    /* fetch row */
    $row = $result->fetch_row();

    printf ("City: %s  Countrycode: %s\n", $row[0], $row[1]);

    /* free result set*/
    $result->close();
}

/* close connection */
$mysqli->close();
?>

Örnek 2 Yordamsal kullanım

<?php
/* Open a connection */
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (!$link) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER BY Name";

if ($result = mysqli_query($link, $query)) {

    /* seek to row no. 400 */
    mysqli_data_seek($result, 399);

    /* fetch row */
    $row = mysqli_fetch_row($result);

    printf ("City: %s  Countrycode: %s\n", $row[0], $row[1]);

    /* free result set*/
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

City: Benin City  Countrycode: NGA

Ayrıca Bakınız

  • mysqli_store_result() - Transfers a result set from the last query
  • mysqli_fetch_row() - Get a result row as an enumerated array
  • mysqli_fetch_array() - Fetch a result row as an associative, a numeric array, or both
  • mysqli_fetch_assoc() - Fetch a result row as an associative array
  • mysqli_fetch_object() - Returns the current row of a result set as an object
  • mysqli_query() - Performs a query on the database
  • mysqli_num_rows() - Gets the number of rows in a result

mysqli_result::$current_field
mysqli_result::fetch_all
mysqli_result


Fetches all result rows as an associative array, a numeric array, or both

mysqli_result::data_seek
mysqli_result::fetch_array
mysqli_result
PHP Manual

mysqli_result::fetch_all

mysqli_fetch_all

(PHP 5 >= 5.3.0, PHP 7)

mysqli_result::fetch_all -- mysqli_fetch_all — Fetches all result rows as an associative array, a numeric array, or both

Açıklama

Nesne yönelimli kullanım

mixed mysqli_result::fetch_all ([ int $resulttype = MYSQLI_NUM ] )

Yordamsal kullanım

mixed mysqli_fetch_all ( mysqli_result $result [, int $resulttype = MYSQLI_NUM ] )

mysqli_fetch_all() fetches all result rows and returns the result set as an associative array, a numeric array, or both.

Değiştirgeler

sonuç

Sadece yordamsal tarz: mysqli_query(),
mysqli_store_result() veya
mysqli_use_result() işlevinden dönen bir sonuç kümesi
tanıtıcısı.

resulttype

This optional parameter is a constant indicating what type of array should be produced from the current row data. The possible values for this parameter are the constants MYSQLI_ASSOC, MYSQLI_NUM, or MYSQLI_BOTH.

Dönen Değerler

Returns an array of associative or numeric arrays holding result rows.

Sadece MySQL Doğal Sürücüsü

Sadece mysqlnd ile kullanılabilir.

As mysqli_fetch_all() returns all the rows as an array in a single step, it may consume more memory than some similar functions such as mysqli_fetch_array(), which only returns one row at a time from the result set. Further, if you need to iterate over the result set, you will need a looping construct that will further impact performance. For these reasons mysqli_fetch_all() should only be used in those situations where the fetched result set will be sent to another layer for processing.

Ayrıca Bakınız

  • mysqli_fetch_array() - Fetch a result row as an associative, a numeric array, or both
  • mysqli_query() - Performs a query on the database

mysqli_result::data_seek
mysqli_result::fetch_array
mysqli_result


Fetch a result row as an associative, a numeric array, or both

mysqli_result::fetch_all
mysqli_result::fetch_assoc
mysqli_result
PHP Manual

mysqli_result::fetch_array

mysqli_fetch_array

(PHP 5, PHP 7)

mysqli_result::fetch_array -- mysqli_fetch_array — Fetch a result row as an associative, a numeric array, or both

Açıklama

Nesne yönelimli kullanım

mixed mysqli_result::fetch_array ([ int $resulttype = MYSQLI_BOTH ] )

Yordamsal kullanım

mixed mysqli_fetch_array ( mysqli_result $result [, int $resulttype = MYSQLI_BOTH ] )

Returns an array that corresponds to the fetched row or NULL if there are no more rows for the resultset represented by the result parameter.

mysqli_fetch_array() is an extended version of the mysqli_fetch_row() function. In addition to storing the data in the numeric indices of the result array, the mysqli_fetch_array() function can also store the data in associative indices, using the field names of the result set as keys.

Bilginize: Bu işlevden dönen alan isimlerinin harf büyüklüklerinde değişiklik yapılmaz.

Bilginize: Bu işlev NULL alanlara PHP NULL değerini atar.

If two or more columns of the result have the same field names, the last column will take precedence and overwrite the earlier data. In order to access multiple columns with the same name, the numerically indexed version of the row must be used.

Değiştirgeler

sonuç

Sadece yordamsal tarz: mysqli_query(),
mysqli_store_result() veya
mysqli_use_result() işlevinden dönen bir sonuç kümesi
tanıtıcısı.

resulttype

This optional parameter is a constant indicating what type of array should be produced from the current row data. The possible values for this parameter are the constants MYSQLI_ASSOC, MYSQLI_NUM, or MYSQLI_BOTH.

By using the MYSQLI_ASSOC constant this function will behave identically to the mysqli_fetch_assoc(), while MYSQLI_NUM will behave identically to the mysqli_fetch_row() function. The final option MYSQLI_BOTH will create a single array with the attributes of both.

Dönen Değerler

Returns an array of strings that corresponds to the fetched row or NULL if there are no more rows in resultset.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if ($mysqli->connect_errno) {
    printf("Connect failed: %s\n", $mysqli->connect_error);
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER by ID LIMIT 3";
$result = $mysqli->query($query);

/* numeric array */
$row = $result->fetch_array(MYSQLI_NUM);
printf ("%s (%s)\n", $row[0], $row[1]);

/* associative array */
$row = $result->fetch_array(MYSQLI_ASSOC);
printf ("%s (%s)\n", $row["Name"], $row["CountryCode"]);

/* associative and numeric array */
$row = $result->fetch_array(MYSQLI_BOTH);
printf ("%s (%s)\n", $row[0], $row["CountryCode"]);

/* free result set */
$result->free();

/* close connection */
$mysqli->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER by ID LIMIT 3";
$result = mysqli_query($link, $query);

/* numeric array */
$row = mysqli_fetch_array($result, MYSQLI_NUM);
printf ("%s (%s)\n", $row[0], $row[1]);

/* associative array */
$row = mysqli_fetch_array($result, MYSQLI_ASSOC);
printf ("%s (%s)\n", $row["Name"], $row["CountryCode"]);

/* associative and numeric array */
$row = mysqli_fetch_array($result, MYSQLI_BOTH);
printf ("%s (%s)\n", $row[0], $row["CountryCode"]);

/* free result set */
mysqli_free_result($result);

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Kabul (AFG)
Qandahar (AFG)
Herat (AFG)

Ayrıca Bakınız

  • mysqli_fetch_assoc() - Fetch a result row as an associative array
  • mysqli_fetch_row() - Get a result row as an enumerated array
  • mysqli_fetch_object() - Returns the current row of a result set as an object
  • mysqli_query() - Performs a query on the database
  • mysqli_data_seek() - Adjusts the result pointer to an arbitrary row in the result

mysqli_result::fetch_all
mysqli_result::fetch_assoc
mysqli_result


Fetch a result row as an associative array

mysqli_result::fetch_array
mysqli_result::fetch_field_direct
mysqli_result
PHP Manual

mysqli_result::fetch_assoc

mysqli_fetch_assoc

(PHP 5, PHP 7)

mysqli_result::fetch_assoc -- mysqli_fetch_assoc — Fetch a result row as an associative array

Açıklama

Nesne yönelimli kullanım

array mysqli_result::fetch_assoc ( void )

Yordamsal kullanım

array mysqli_fetch_assoc ( mysqli_result $result )

Returns an associative array that corresponds to the fetched row or NULL if there are no more rows.

Bilginize: Bu işlevden dönen alan isimlerinin harf büyüklüklerinde değişiklik yapılmaz.

Bilginize: Bu işlev NULL alanlara PHP NULL değerini atar.

Değiştirgeler

sonuç

Sadece yordamsal tarz: mysqli_query(),
mysqli_store_result() veya
mysqli_use_result() işlevinden dönen bir sonuç kümesi
tanıtıcısı.

Dönen Değerler

Returns an associative array of strings representing the fetched row in the result set, where each key in the array represents the name of one of the result set's columns or NULL if there are no more rows in resultset.

If two or more columns of the result have the same field names, the last column will take precedence. To access the other column(s) of the same name, you either need to access the result with numeric indices by using mysqli_fetch_row() or add alias names.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if ($mysqli->connect_errno) {
    printf("Connect failed: %s\n", $mysqli->connect_error);
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER by ID DESC LIMIT 50,5";

if ($result = $mysqli->query($query)) {

    /* fetch associative array */
    while ($row = $result->fetch_assoc()) {
        printf ("%s (%s)\n", $row["Name"], $row["CountryCode"]);
    }

    /* free result set */
    $result->free();
}

/* close connection */
$mysqli->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER by ID DESC LIMIT 50,5";

if ($result = mysqli_query($link, $query)) {

    /* fetch associative array */
    while ($row = mysqli_fetch_assoc($result)) {
        printf ("%s (%s)\n", $row["Name"], $row["CountryCode"]);
    }

    /* free result set */
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Pueblo (USA)
Arvada (USA)
Cape Coral (USA)
Green Bay (USA)
Santa Clara (USA)

Örnek 3 A mysqli_result example comparing iterator usage

<?php
$c = mysqli_connect('127.0.0.1','user', 'pass');

// Using iterators (support was added with PHP 5.4)
foreach ( $c->query('SELECT user,host FROM mysql.user') as $row ) {
    printf("'%s'@'%s'\n", $row['user'], $row['host']);
}

echo "\n==================\n";

// Not using iterators
$result = $c->query('SELECT user,host FROM mysql.user');
while ($row = $result->fetch_assoc()) {
    printf("'%s'@'%s'\n", $row['user'], $row['host']);
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

'root'@'192.168.1.1'
'root'@'127.0.0.1'
'dude'@'localhost'
'lebowski'@'localhost'

==================

'root'@'192.168.1.1'
'root'@'127.0.0.1'
'dude'@'localhost'
'lebowski'@'localhost'

Ayrıca Bakınız

  • mysqli_fetch_array() - Fetch a result row as an associative, a numeric array, or both
  • mysqli_fetch_row() - Get a result row as an enumerated array
  • mysqli_fetch_object() - Returns the current row of a result set as an object
  • mysqli_query() - Performs a query on the database
  • mysqli_data_seek() - Adjusts the result pointer to an arbitrary row in the result

mysqli_result::fetch_array
mysqli_result::fetch_field_direct
mysqli_result


Fetch meta-data for a single field

mysqli_result::fetch_assoc
mysqli_result::fetch_field
mysqli_result
PHP Manual

mysqli_result::fetch_field_direct

mysqli_fetch_field_direct

(PHP 5, PHP 7)

mysqli_result::fetch_field_direct -- mysqli_fetch_field_direct — Fetch meta-data for a single field

Açıklama

Nesne yönelimli kullanım

object mysqli_result::fetch_field_direct ( int $fieldnr )

Yordamsal kullanım

object mysqli_fetch_field_direct ( mysqli_result $result , int $fieldnr )

Returns an object which contains field definition information from the specified result set.

Değiştirgeler

sonuç

Sadece yordamsal tarz: mysqli_query(),
mysqli_store_result() veya
mysqli_use_result() işlevinden dönen bir sonuç kümesi
tanıtıcısı.

fieldnr

The field number. This value must be in the range from 0 to number of fields - 1.

Dönen Değerler

Returns an object which contains field definition information or FALSE if no field information for specified fieldnr is available.

Object attributes
Attribute | Description
name | The name of the column
orgname | Original column name if an alias was specified
table | The name of the table this field belongs to (if not calculated)
orgtable | Original table name if an alias was specified
def | The default value for this field, represented as a string
max_length | The maximum width of the field for the result set.
length | The width of the field, as specified in the table definition.
charsetnr | The character set number for the field.
flags | An integer representing the bit-flags for the field.
type | The data type used for this field
decimals | The number of decimals used (for numeric fields)

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, SurfaceArea from Country ORDER BY Name LIMIT 5";

if ($result = $mysqli->query($query)) {

    /* Get field information for column 'SurfaceArea' */
    $finfo = $result->fetch_field_direct(1);

    printf("Name:     %s\n", $finfo->name);
    printf("Table:    %s\n", $finfo->table);
    printf("max. Len: %d\n", $finfo->max_length);
    printf("Flags:    %d\n", $finfo->flags);
    printf("Type:     %d\n", $finfo->type);

    $result->close();
}

/* close connection */
$mysqli->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, SurfaceArea from Country ORDER BY Name LIMIT 5";

if ($result = mysqli_query($link, $query)) {

    /* Get field information for column 'SurfaceArea' */
    $finfo = mysqli_fetch_field_direct($result, 1);

    printf("Name:     %s\n", $finfo->name);
    printf("Table:    %s\n", $finfo->table);
    printf("max. Len: %d\n", $finfo->max_length);
    printf("Flags:    %d\n", $finfo->flags);
    printf("Type:     %d\n", $finfo->type);

    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Name:     SurfaceArea
Table:    Country
max. Len: 10
Flags:    32769
Type:     4

Ayrıca Bakınız

  • mysqli_num_fields() - Get the number of fields in a result
  • mysqli_fetch_field() - Returns the next field in the result set
  • mysqli_fetch_fields() - Returns an array of objects representing the fields in a result set

mysqli_result::fetch_assoc
mysqli_result::fetch_field
mysqli_result


Returns the next field in the result set

mysqli_result::fetch_field_direct
mysqli_result::fetch_fields
mysqli_result
PHP Manual

mysqli_result::fetch_field

mysqli_fetch_field

(PHP 5, PHP 7)

mysqli_result::fetch_field -- mysqli_fetch_field — Returns the next field in the result set

Açıklama

Nesne yönelimli kullanım

object mysqli_result::fetch_field ( void )

Yordamsal kullanım

object mysqli_fetch_field ( mysqli_result $result )

Returns the definition of one column of a result set as an object. Call this function repeatedly to retrieve information about all columns in the result set.

Değiştirgeler

sonuç

Sadece yordamsal tarz: mysqli_query(),
mysqli_store_result() veya
mysqli_use_result() işlevinden dönen bir sonuç kümesi
tanıtıcısı.

Dönen Değerler

Returns an object which contains field definition information or FALSE if no field information is available.

Object properties
Property | Description
name | The name of the column
orgname | Original column name if an alias was specified
table | The name of the table this field belongs to (if not calculated)
orgtable | Original table name if an alias was specified
def | Reserved for default value, currently always ""
db | Database (since PHP 5.3.6)
catalog | The catalog name, always "def" (since PHP 5.3.6)
max_length | The maximum width of the field for the result set.
length | The width of the field, as specified in the table definition.
charsetnr | The character set number for the field.
flags | An integer representing the bit-flags for the field.
type | The data type used for this field
decimals | The number of decimals used (for integer fields)

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, SurfaceArea from Country ORDER BY Code LIMIT 5";

if ($result = $mysqli->query($query)) {

    /* Get field information for all columns */
    while ($finfo = $result->fetch_field()) {

        printf("Name:     %s\n", $finfo->name);
        printf("Table:    %s\n", $finfo->table);
        printf("max. Len: %d\n", $finfo->max_length);
        printf("Flags:    %d\n", $finfo->flags);
        printf("Type:     %d\n\n", $finfo->type);
    }
    $result->close();
}

/* close connection */
$mysqli->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, SurfaceArea from Country ORDER BY Code LIMIT 5";

if ($result = mysqli_query($link, $query)) {

    /* Get field information for all fields */
    while ($finfo = mysqli_fetch_field($result)) {

        printf("Name:     %s\n", $finfo->name);
        printf("Table:    %s\n", $finfo->table);
        printf("max. Len: %d\n", $finfo->max_length);
        printf("Flags:    %d\n", $finfo->flags);
        printf("Type:     %d\n\n", $finfo->type);
    }
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Name:     Name
Table:    Country
max. Len: 11
Flags:    1
Type:     254

Name:     SurfaceArea
Table:    Country
max. Len: 10
Flags:    32769
Type:     4

Ayrıca Bakınız

  • mysqli_num_fields() - Get the number of fields in a result
  • mysqli_fetch_field_direct() - Fetch meta-data for a single field
  • mysqli_fetch_fields() - Returns an array of objects representing the fields in a result set
  • mysqli_field_seek() - Set result pointer to a specified field offset

mysqli_result::fetch_field_direct
mysqli_result::fetch_fields
mysqli_result


Returns an array of objects representing the fields in a result set

mysqli_result::fetch_field
mysqli_result::fetch_object
mysqli_result
PHP Manual

mysqli_result::fetch_fields

mysqli_fetch_fields

(PHP 5, PHP 7)

mysqli_result::fetch_fields -- mysqli_fetch_fields — Returns an array of objects representing the fields in a result set

Açıklama

Nesne yönelimli kullanım

array mysqli_result::fetch_fields ( void )

Yordamsal kullanım

array mysqli_fetch_fields ( mysqli_result $result )

This function serves an identical purpose to the mysqli_fetch_field() function with the single difference that, instead of returning one object at a time for each field, the columns are returned as an array of objects.

Değiştirgeler

sonuç

Sadece yordamsal tarz: mysqli_query(),
mysqli_store_result() veya
mysqli_use_result() işlevinden dönen bir sonuç kümesi
tanıtıcısı.

Dönen Değerler

Returns an array of objects which contains field definition information or FALSE if no field information is available.

Object properties
Property | Description
name | The name of the column
orgname | Original column name if an alias was specified
table | The name of the table this field belongs to (if not calculated)
orgtable | Original table name if an alias was specified
max_length | The maximum width of the field for the result set.
length | The width of the field, in bytes, as specified in the table definition. Note that this number (bytes) might differ from your table definition value (characters), depending on the character set you use. For example, the character set utf8 has 3 bytes per character, so varchar(10) will return a length of 30 for utf8 (10*3), but return 10 for latin1 (10*1).
charsetnr | The character set number (id) for the field.
flags | An integer representing the bit-flags for the field.
type | The data type used for this field
decimals | The number of decimals used (for integer fields)

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("127.0.0.1", "root", "foofoo", "sakila");

/* check connection */
if ($mysqli->connect_errno) {
    printf("Connect failed: %s\n", $mysqli->connect_error);
    exit();
}

foreach (array('latin1', 'utf8') as $charset) {

    // Set character set, to show its impact on some values (e.g., length in bytes)
    $mysqli->set_charset($charset);

    $query = "SELECT actor_id, last_name from actor ORDER BY actor_id";

    echo "======================\n";
    echo "Character Set: $charset\n";
    echo "======================\n";

    if ($result = $mysqli->query($query)) {

        /* Get field information for all columns */
        $finfo = $result->fetch_fields();

        foreach ($finfo as $val) {
            printf("Name:      %s\n",   $val->name);
            printf("Table:     %s\n",   $val->table);
            printf("Max. Len:  %d\n",   $val->max_length);
            printf("Length:    %d\n",   $val->length);
            printf("charsetnr: %d\n",   $val->charsetnr);
            printf("Flags:     %d\n",   $val->flags);
            printf("Type:      %d\n\n", $val->type);
        }
        $result->free();
    }
}
$mysqli->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = mysqli_connect("127.0.0.1", "my_user", "my_password", "sakila");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

foreach (array('latin1', 'utf8') as $charset) {

    // Set character set, to show its impact on some values (e.g., length in bytes)
    mysqli_set_charset($link, $charset);

    $query = "SELECT actor_id, last_name from actor ORDER BY actor_id";

    echo "======================\n";
    echo "Character Set: $charset\n";
    echo "======================\n";

    if ($result = mysqli_query($link, $query)) {

        /* Get field information for all columns */
        $finfo = mysqli_fetch_fields($result);

        foreach ($finfo as $val) {
            printf("Name:      %s\n",   $val->name);
            printf("Table:     %s\n",   $val->table);
            printf("Max. Len:  %d\n",   $val->max_length);
            printf("Length:    %d\n",   $val->length);
            printf("charsetnr: %d\n",   $val->charsetnr);
            printf("Flags:     %d\n",   $val->flags);
            printf("Type:      %d\n\n", $val->type);
        }
        mysqli_free_result($result);
    }
}

mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

======================
Character Set: latin1
======================
Name:      actor_id
Table:     actor
Max. Len:  3
Length:    5
charsetnr: 63
Flags:     49699
Type:      2

Name:      last_name
Table:     actor
Max. Len:  12
Length:    45
charsetnr: 8
Flags:     20489
Type:      253

======================
Character Set: utf8
======================
Name:      actor_id
Table:     actor
Max. Len:  3
Length:    5
charsetnr: 63
Flags:     49699
Type:      2

Name:      last_name
Table:     actor
Max. Len:  12
Length:    135
charsetnr: 33
Flags:     20489

Ayrıca Bakınız

  • mysqli_num_fields() - Get the number of fields in a result
  • mysqli_fetch_field_direct() - Fetch meta-data for a single field
  • mysqli_fetch_field() - Returns the next field in the result set

mysqli_result::fetch_field
mysqli_result::fetch_object
mysqli_result


Returns the current row of a result set as an object

mysqli_result::fetch_fields
mysqli_result::fetch_row
mysqli_result
PHP Manual

mysqli_result::fetch_object

mysqli_fetch_object

(PHP 5, PHP 7)

mysqli_result::fetch_object -- mysqli_fetch_object — Returns the current row of a result set as an object

Açıklama

Nesne yönelimli kullanım

object mysqli_result::fetch_object ([ string $class_name = "stdClass" [, array $params ]] )

Yordamsal kullanım

object mysqli_fetch_object ( mysqli_result $result [, string $class_name = "stdClass" [, array $params ]] )

The mysqli_fetch_object() will return the current row result set as an object where the attributes of the object represent the names of the fields found within the result set.

Note that mysqli_fetch_object() sets the properties of the object before calling the object constructor.

Değiştirgeler

sonuç

Sadece yordamsal tarz: mysqli_query(),
mysqli_store_result() veya
mysqli_use_result() işlevinden dönen bir sonuç kümesi
tanıtıcısı.

class_name

The name of the class to instantiate, set the properties of and return. If not specified, a stdClass object is returned.

params

An optional array of parameters to pass to the constructor for class_name objects.

Dönen Değerler

Returns an object with string properties that corresponds to the fetched row or NULL if there are no more rows in resultset.

Bilginize: Bu işlevden dönen alan isimlerinin harf büyüklüklerinde değişiklik yapılmaz.

Bilginize: Bu işlev NULL alanlara PHP NULL değerini atar.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER by ID DESC LIMIT 50,5";

if ($result = $mysqli->query($query)) {

    /* fetch object array */
    while ($obj = $result->fetch_object()) {
        printf ("%s (%s)\n", $obj->Name, $obj->CountryCode);
    }

    /* free result set */
    $result->close();
}

/* close connection */
$mysqli->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER by ID DESC LIMIT 50,5";

if ($result = mysqli_query($link, $query)) {

    /* fetch associative array */
    while ($obj = mysqli_fetch_object($result)) {
        printf ("%s (%s)\n", $obj->Name, $obj->CountryCode);
    }

    /* free result set */
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Pueblo (USA)
Arvada (USA)
Cape Coral (USA)
Green Bay (USA)
Santa Clara (USA)

Ayrıca Bakınız

  • mysqli_fetch_array() - Fetch a result row as an associative, a numeric array, or both
  • mysqli_fetch_assoc() - Fetch a result row as an associative array
  • mysqli_fetch_row() - Get a result row as an enumerated array
  • mysqli_query() - Performs a query on the database
  • mysqli_data_seek() - Adjusts the result pointer to an arbitrary row in the result

mysqli_result::fetch_fields
mysqli_result::fetch_row
mysqli_result


Get a result row as an enumerated array

mysqli_result::fetch_object
mysqli_result::$field_count
mysqli_result
PHP Manual

mysqli_result::fetch_row

mysqli_fetch_row

(PHP 5, PHP 7)

mysqli_result::fetch_row -- mysqli_fetch_row — Get a result row as an enumerated array

Açıklama

Nesne yönelimli kullanım

mixed mysqli_result::fetch_row ( void )

Yordamsal kullanım

mixed mysqli_fetch_row ( mysqli_result $result )

Fetches one row of data from the result set and returns it as an enumerated array, where each column is stored in an array offset starting from 0 (zero). Each subsequent call to this function will return the next row within the result set, or NULL if there are no more rows.

Değiştirgeler

sonuç

Sadece yordamsal tarz: mysqli_query(),
mysqli_store_result() veya
mysqli_use_result() işlevinden dönen bir sonuç kümesi
tanıtıcısı.

Dönen Değerler

mysqli_fetch_row() returns an array of strings that corresponds to the fetched row or NULL if there are no more rows in result set.

Bilginize: Bu işlev NULL alanlara PHP NULL değerini atar.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER by ID DESC LIMIT 50,5";

if ($result = $mysqli->query($query)) {

    /* fetch object array */
    while ($row = $result->fetch_row()) {
        printf ("%s (%s)\n", $row[0], $row[1]);
    }

    /* free result set */
    $result->close();
}

/* close connection */
$mysqli->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER by ID DESC LIMIT 50,5";

if ($result = mysqli_query($link, $query)) {

    /* fetch associative array */
    while ($row = mysqli_fetch_row($result)) {
        printf ("%s (%s)\n", $row[0], $row[1]);
    }

    /* free result set */
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Pueblo (USA)
Arvada (USA)
Cape Coral (USA)
Green Bay (USA)
Santa Clara (USA)

Ayrıca Bakınız

  • mysqli_fetch_array() - Fetch a result row as an associative, a numeric array, or both
  • mysqli_fetch_assoc() - Fetch a result row as an associative array
  • mysqli_fetch_object() - Returns the current row of a result set as an object
  • mysqli_query() - Performs a query on the database
  • mysqli_data_seek() - Adjusts the result pointer to an arbitrary row in the result

mysqli_result::fetch_object
mysqli_result::$field_count
mysqli_result


Get the number of fields in a result

mysqli_result::fetch_row
mysqli_result::field_seek
mysqli_result
PHP Manual

mysqli_result::$field_count

mysqli_num_fields

(PHP 5, PHP 7)

mysqli_result::$field_count -- mysqli_num_fields — Get the number of fields in a result

Açıklama

Nesne yönelimli kullanım

int $mysqli_result->field_count;

Yordamsal kullanım

int mysqli_num_fields ( mysqli_result $result )

Returns the number of fields from specified result set.

Değiştirgeler

sonuç

Sadece yordamsal tarz: mysqli_query(),
mysqli_store_result() veya
mysqli_use_result() işlevinden dönen bir sonuç kümesi
tanıtıcısı.

Dönen Değerler

The number of fields from a result set.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if ($result = $mysqli->query("SELECT * FROM City ORDER BY ID LIMIT 1")) {

    /* determine number of fields in result set */
    $field_cnt = $result->field_count;

    printf("Result set has %d fields.\n", $field_cnt);

    /* close result set */
    $result->close();
}

/* close connection */
$mysqli->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if ($result = mysqli_query($link, "SELECT * FROM City ORDER BY ID LIMIT 1")) {

    /* determine number of fields in result set */
    $field_cnt = mysqli_num_fields($result);

    printf("Result set has %d fields.\n", $field_cnt);

    /* close result set */
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Result set has 5 fields.

Ayrıca Bakınız

  • mysqli_fetch_field() - Returns the next field in the result set

mysqli_result::fetch_row
mysqli_result::field_seek
mysqli_result


Set result pointer to a specified field offset

mysqli_result::$field_count
mysqli_result::free
mysqli_result
PHP Manual

mysqli_result::field_seek

mysqli_field_seek

(PHP 5, PHP 7)

mysqli_result::field_seek -- mysqli_field_seek — Set result pointer to a specified field offset

Açıklama

Nesne yönelimli kullanım

bool mysqli_result::field_seek ( int $fieldnr )

Yordamsal kullanım

bool mysqli_field_seek ( mysqli_result $result , int $fieldnr )

Sets the field cursor to the given offset. The next call to mysqli_fetch_field() will retrieve the field definition of the column associated with that offset.

Bilginize:

To seek to the beginning of a row, pass an offset value of zero.

Değiştirgeler

sonuç

Sadece yordamsal tarz: mysqli_query(),
mysqli_store_result() veya
mysqli_use_result() işlevinden dönen bir sonuç kümesi
tanıtıcısı.

fieldnr

The field number. This value must be in the range from 0 to number of fields - 1.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, SurfaceArea from Country ORDER BY Code LIMIT 5";

if ($result = $mysqli->query($query)) {

    /* Get field information for 2nd column */
    $result->field_seek(1);
    $finfo = $result->fetch_field();

    printf("Name:     %s\n", $finfo->name);
    printf("Table:    %s\n", $finfo->table);
    printf("max. Len: %d\n", $finfo->max_length);
    printf("Flags:    %d\n", $finfo->flags);
    printf("Type:     %d\n\n", $finfo->type);

    $result->close();
}

/* close connection */
$mysqli->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, SurfaceArea from Country ORDER BY Code LIMIT 5";

if ($result = mysqli_query($link, $query)) {

    /* Get field information for 2nd column */
    mysqli_field_seek($result, 1);
    $finfo = mysqli_fetch_field($result);

    printf("Name:     %s\n", $finfo->name);
    printf("Table:    %s\n", $finfo->table);
    printf("max. Len: %d\n", $finfo->max_length);
    printf("Flags:    %d\n", $finfo->flags);
    printf("Type:     %d\n\n", $finfo->type);

    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Name:     SurfaceArea
Table:    Country
max. Len: 10
Flags:    32769
Type:     4

Ayrıca Bakınız

  • mysqli_fetch_field() - Returns the next field in the result set

mysqli_result::$field_count
mysqli_result::free
mysqli_result


Frees the memory associated with a result

mysqli_result::field_seek
mysqli_result::$lengths
mysqli_result
PHP Manual

mysqli_result::free

mysqli_free_result

(PHP 5, PHP 7)

mysqli_result::free -- mysqli_free_result — Frees the memory associated with a result

Açıklama

Nesne yönelimli kullanım

void mysqli_result::free ( void )
void mysqli_result::close ( void )
void mysqli_result::free_result ( void )

Yordamsal kullanım

void mysqli_free_result ( mysqli_result $result )

Frees the memory associated with the result.

Bilginize:

You should always free your result with mysqli_free_result(), when your result object is not needed anymore.

Değiştirgeler

sonuç

Sadece yordamsal tarz: mysqli_query(),
mysqli_store_result() veya
mysqli_use_result() işlevinden dönen bir sonuç kümesi
tanıtıcısı.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • mysqli_query() - Performs a query on the database
  • mysqli_stmt_store_result() - Transfers a result set from a prepared statement
  • mysqli_store_result() - Transfers a result set from the last query
  • mysqli_use_result() - Initiate a result set retrieval

mysqli_result::field_seek
mysqli_result::$lengths
mysqli_result


Returns the lengths of the columns of the current row in the result set

mysqli_result::free
mysqli_result::$num_rows
mysqli_result
PHP Manual

mysqli_result::$lengths

mysqli_fetch_lengths

(PHP 5, PHP 7)

mysqli_result::$lengths -- mysqli_fetch_lengths — Returns the lengths of the columns of the current row in the result set

Açıklama

Nesne yönelimli kullanım

array $mysqli_result->lengths;

Yordamsal kullanım

array mysqli_fetch_lengths ( mysqli_result $result )

The mysqli_fetch_lengths() function returns an array containing the lengths of every column of the current row within the result set.

Değiştirgeler

sonuç

Sadece yordamsal tarz: mysqli_query(),
mysqli_store_result() veya
mysqli_use_result() işlevinden dönen bir sonuç kümesi
tanıtıcısı.

Dönen Değerler

An array of integers representing the size of each column (not including any terminating null characters). FALSE if an error occurred.

mysqli_fetch_lengths() is valid only for the current row of the result set. It returns FALSE if you call it before calling mysqli_fetch_row/array/object or after retrieving all rows in the result.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT * from Country ORDER BY Code LIMIT 1";

if ($result = $mysqli->query($query)) {

    $row = $result->fetch_row();

    /* display column lengths */
    foreach ($result->lengths as $i => $val) {
        printf("Field %2d has Length %2d\n", $i+1, $val);
    }
    $result->close();
}

/* close connection */
$mysqli->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT * from Country ORDER BY Code LIMIT 1";

if ($result = mysqli_query($link, $query)) {

    $row = mysqli_fetch_row($result);

    /* display column lengths */
    foreach (mysqli_fetch_lengths($result) as $i => $val) {
        printf("Field %2d has Length %2d\n", $i+1, $val);
    }
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Field  1 has Length  3
Field  2 has Length  5
Field  3 has Length 13
Field  4 has Length  9
Field  5 has Length  6
Field  6 has Length  1
Field  7 has Length  6
Field  8 has Length  4
Field  9 has Length  6
Field 10 has Length  6
Field 11 has Length  5
Field 12 has Length 44
Field 13 has Length  7
Field 14 has Length  3
Field 15 has Length  2
mysqli_result::free
mysqli_result::$num_rows
mysqli_result


Gets the number of rows in a result

mysqli_result::$lengths
mysqli_driver
mysqli_result
PHP Manual

mysqli_result::$num_rows

mysqli_num_rows

(PHP 5, PHP 7)

mysqli_result::$num_rows -- mysqli_num_rows — Gets the number of rows in a result

Açıklama

Nesne yönelimli kullanım

int $mysqli_result->num_rows;

Yordamsal kullanım

int mysqli_num_rows ( mysqli_result $result )

Returns the number of rows in the result set.

The behaviour of mysqli_num_rows() depends on whether buffered or unbuffered result sets are being used. For unbuffered result sets, mysqli_num_rows() will not return the correct number of rows until all the rows in the result have been retrieved.

Değiştirgeler

sonuç

Sadece yordamsal tarz: mysqli_query(),
mysqli_store_result() veya
mysqli_use_result() işlevinden dönen bir sonuç kümesi
tanıtıcısı.

Dönen Değerler

Returns number of rows in the result set.

Bilginize:

If the number of rows is greater than PHP_INT_MAX, the number will be returned as a string.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if ($result = $mysqli->query("SELECT Code, Name FROM Country ORDER BY Name")) {

    /* determine number of rows result set */
    $row_cnt = $result->num_rows;

    printf("Result set has %d rows.\n", $row_cnt);

    /* close result set */
    $result->close();
}

/* close connection */
$mysqli->close();
?>

Örnek 2 Yordamsal kullanım

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if ($result = mysqli_query($link, "SELECT Code, Name FROM Country ORDER BY Name")) {

    /* determine number of rows result set */
    $row_cnt = mysqli_num_rows($result);

    printf("Result set has %d rows.\n", $row_cnt);

    /* close result set */
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Result set has 239 rows.

Ayrıca Bakınız

  • mysqli_affected_rows() - Gets the number of affected rows in a previous MySQL operation
  • mysqli_store_result() - Transfers a result set from the last query
  • mysqli_use_result() - Initiate a result set retrieval
  • mysqli_query() - Performs a query on the database

mysqli_result::$lengths
mysqli_driver
mysqli_result


The mysqli_driver class

(PHP 5, PHP 7)

Giriş

MySQLi Driver.

Sınıf Sözdizimi

mysqli_driver {
/* Özellikler */
public readonly string $client_info ;
public readonly string $client_version ;
public readonly string $driver_version ;
public readonly string $embedded ;
public bool $reconnect ;
public int $report_mode ;
/* Yöntemler */
void embedded_server_end ( void )
bool embedded_server_start ( bool $start , array $arguments , array $groups )
}

Özellikler

client_info

The Client API header version

client_version

The Client version

driver_version

The MySQLi Driver version

embedded

Whether MySQLi Embedded support is enabled

reconnect

Allow or prevent reconnect (see the mysqli.reconnect INI directive)

report_mode

Set to MYSQLI_REPORT_OFF, MYSQLI_REPORT_ALL or any combination of MYSQLI_REPORT_STRICT (throw Exceptions for errors), MYSQLI_REPORT_ERROR (report errors) and MYSQLI_REPORT_INDEX (errors regarding indexes). See also mysqli_report().

İçindekiler

  • mysqli_driver::embedded_server_end — Stop embedded server
  • mysqli_driver::embedded_server_start — Initialize and start embedded server
  • mysqli_driver::$report_mode — Enables or disables internal report functions
mysqli_result::$num_rows
mysqli_driver::embedded_server_end
MySQLi


Stop embedded server

mysqli_driver
mysqli_driver::embedded_server_start
mysqli_driver
PHP Manual

mysqli_driver::embedded_server_end

mysqli_embedded_server_end

(PHP 5, PHP 7)

mysqli_driver::embedded_server_end -- mysqli_embedded_server_end — Stop embedded server

Açıklama

Nesne yönelimli kullanım

void mysqli_driver::embedded_server_end ( void )

Yordamsal kullanım

void mysqli_embedded_server_end ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

mysqli_driver
mysqli_driver::embedded_server_start
mysqli_driver


Initialize and start embedded server

mysqli_driver::embedded_server_end
mysqli_driver::$report_mode
mysqli_driver
PHP Manual

mysqli_driver::embedded_server_start

mysqli_embedded_server_start

(PHP 5, PHP 7)

mysqli_driver::embedded_server_start -- mysqli_embedded_server_start — Initialize and start embedded server

Açıklama

Nesne yönelimli kullanım

bool mysqli_driver::embedded_server_start ( bool $start , array $arguments , array $groups )

Yordamsal kullanım

bool mysqli_embedded_server_start ( bool $start , array $arguments , array $groups )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

mysqli_driver::embedded_server_end
mysqli_driver::$report_mode
mysqli_driver


Enables or disables internal report functions

mysqli_driver::embedded_server_start
mysqli_warning
mysqli_driver
PHP Manual

mysqli_driver::$report_mode

mysqli_report

(PHP 5, PHP 7)

mysqli_driver::$report_mode -- mysqli_report — Enables or disables internal report functions

Açıklama

Nesne yönelimli kullanım

int $mysqli_driver->report_mode ;

Yordamsal kullanım

bool mysqli_report ( int $flags )

A function helpful in improving queries during code development and testing. Depending on the flags, it reports errors from mysqli function calls or queries that don't use an index (or use a bad index).

Değiştirgeler

flags

Supported flags
Name | Description
MYSQLI_REPORT_OFF | Turns reporting off
MYSQLI_REPORT_ERROR | Report errors from mysqli function calls
MYSQLI_REPORT_STRICT | Throw mysqli_sql_exception for errors instead of warnings
MYSQLI_REPORT_INDEX | Report if no index or bad index was used in a query
MYSQLI_REPORT_ALL | Set all options (report all)

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.4 | Changing the reporting mode is now be per-request, rather than per-process.
5.2.15 | Changing the reporting mode is now be per-request, rather than per-process.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php

$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* activate reporting */
$driver = new mysqli_driver();
$driver->report_mode = MYSQLI_REPORT_ALL;

try {

    /* this query should report an error */
    $result = $mysqli->query("SELECT Name FROM Nonexistingtable WHERE population > 50000");

    /* this query should report a bad index */
    $result = $mysqli->query("SELECT Name FROM City WHERE population > 50000");

    $result->close();

    $mysqli->close();

} catch (mysqli_sql_exception $e) {

    echo $e->__toString();
}
?>

Örnek 2 Yordamsal kullanım

<?php
/* activate reporting */
mysqli_report(MYSQLI_REPORT_ALL);

$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* this query should report an error */
$result = mysqli_query("SELECT Name FROM Nonexistingtable WHERE population > 50000");

/* this query should report a bad index */
$result = mysqli_query("SELECT Name FROM City WHERE population > 50000");

mysqli_free_result($result);

mysqli_close($link);
?>

Ayrıca Bakınız

  • mysqli_debug() - Performs debugging operations
  • mysqli_dump_debug_info() - Dump debugging information into the log
  • mysqli_sql_exception
  • set_exception_handler() - Kullanıcı tanımlı bir istisna eylemcisi bildirir
  • error_reporting() - Hangi PHP hatalarının raporlanacağını tanımlar

mysqli_driver::embedded_server_start
mysqli_warning
mysqli_driver


The mysqli_warning class

(PHP 5, PHP 7)

Giriş

Represents a MySQL warning.

Sınıf Sözdizimi

mysqli_warning {
/* Özellikler */
public $message ;
public $sqlstate ;
public $errno ;
/* Yöntemler */
protected __construct ( void )
public void next ( void )
}

Özellikler

message

Message string

sqlstate

SQL state

errno

Error number

İçindekiler

  • mysqli_warning::__construct — The __construct purpose
  • mysqli_warning::next — The next purpose
mysqli_driver::$report_mode
mysqli_warning::__construct
MySQLi


The __construct purpose

mysqli_warning
mysqli_warning::next
mysqli_warning
PHP Manual

mysqli_warning::__construct

(PHP 5, PHP 7)

mysqli_warning::__construct — The __construct purpose

Açıklama

protected mysqli_warning::__construct ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

mysqli_warning
mysqli_warning::next
mysqli_warning


The next purpose

mysqli_warning::__construct
mysqli_sql_exception
mysqli_warning
PHP Manual

mysqli_warning::next

(PHP 5, PHP 7)

mysqli_warning::next — The next purpose

Açıklama

public void mysqli_warning::next ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

mysqli_warning::__construct
mysqli_sql_exception
mysqli_warning


The mysqli_sql_exception class

(PHP 5, PHP 7)

Giriş

The mysqli exception handling class.

Sınıf Sözdizimi

mysqli_sql_exception extends RuntimeException {
/* Özellikler */
protected string $sqlstate ;
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
}

Özellikler

sqlstate

The sql state with the error.

mysqli_warning::next
Aliases and deprecated Mysqli İşlevleri
MySQLi


Aliases and deprecated Mysqli İşlevleri

İçindekiler

  • mysqli_bind_param — Alias for mysqli_stmt_bind_param
  • mysqli_bind_result — Alias for mysqli_stmt_bind_result
  • mysqli_client_encoding — Alias of mysqli_character_set_name
  • mysqli_connect — Takma Adı: mysqli::__construct
  • mysqli::disable_reads_from_master — Disable reads from master
  • mysqli_disable_rpl_parse — Disable RPL parse
  • mysqli_enable_reads_from_master — Enable reads from master
  • mysqli_enable_rpl_parse — Enable RPL parse
  • mysqli_escape_string — Takma Adı: mysqli_real_escape_string
  • mysqli_execute — Alias for mysqli_stmt_execute
  • mysqli_fetch — Alias for mysqli_stmt_fetch
  • mysqli_get_cache_stats — Returns client Zval cache statistics
  • mysqli_get_links_stats — Return information about open and cached links
  • mysqli_get_metadata — Alias for mysqli_stmt_result_metadata
  • mysqli_master_query — Enforce execution of a query on the master in a master/slave setup
  • mysqli_param_count — Alias for mysqli_stmt_param_count
  • mysqli_report — Takma Adı: mysqli_driver->report_mode
  • mysqli_rpl_parse_enabled — Check if RPL parse is enabled
  • mysqli_rpl_probe — RPL probe
  • mysqli_send_long_data — Alias for mysqli_stmt_send_long_data
  • mysqli::set_opt — Alias of mysqli_options
  • mysqli_slave_query — Force execution of a query on a slave in a master/slave setup
mysqli_sql_exception
mysqli_bind_param
MySQLi


Alias for mysqli_stmt_bind_param

Aliases and deprecated Mysqli İşlevleri
mysqli_bind_result
Aliases and deprecated Mysqli İşlevleri
PHP Manual

mysqli_bind_param

(PHP 5 < 5.4.0)

mysqli_bind_param — Alias for mysqli_stmt_bind_param()

Açıklama

This function is an alias of mysqli_stmt_bind_param().

Uyarı

Bu işlevin kullanımı PHP 5.3.0 itibariyle ÖNERİLMEMEKTE olup PHP 5.4.0'da tamamen KALDIRILMIŞTIR.

Ayrıca Bakınız

  • mysqli_stmt_bind_param() - Binds variables to a prepared statement as parameters

Aliases and deprecated Mysqli İşlevleri
mysqli_bind_result
Aliases and deprecated Mysqli İşlevleri


Alias for mysqli_stmt_bind_result

mysqli_bind_param
mysqli_client_encoding
Aliases and deprecated Mysqli İşlevleri
PHP Manual

mysqli_bind_result

(PHP 5 < 5.4.0)

mysqli_bind_result — Alias for mysqli_stmt_bind_result()

Açıklama

This function is an alias of mysqli_stmt_bind_result().

Uyarı

Bu işlevin kullanımı PHP 5.3.0 itibariyle ÖNERİLMEMEKTE olup PHP 5.4.0'da tamamen KALDIRILMIŞTIR.

Ayrıca Bakınız

  • mysqli_stmt_bind_result() - Binds variables to a prepared statement for result storage

mysqli_bind_param
mysqli_client_encoding
Aliases and deprecated Mysqli İşlevleri


Alias of mysqli_character_set_name

mysqli_bind_result
mysqli_connect
Aliases and deprecated Mysqli İşlevleri
PHP Manual

mysqli_client_encoding

(PHP 5 < 5.4.0)

mysqli_client_encoding — Alias of mysqli_character_set_name()

Açıklama

This function is an alias of mysqli_character_set_name().

Uyarı

Bu işlevin kullanımı PHP 5.3.0 itibariyle ÖNERİLMEMEKTE olup PHP 5.4.0'da tamamen KALDIRILMIŞTIR.

Ayrıca Bakınız

  • mysqli_real_escape_string() - Escapes special characters in a string for use in an SQL statement, taking into account the current charset of the connection

mysqli_bind_result
mysqli_connect
Aliases and deprecated Mysqli İşlevleri


Takma Adı: mysqli::__construct

mysqli_client_encoding
mysqli::disable_reads_from_master
Aliases and deprecated Mysqli İşlevleri
PHP Manual

mysqli_connect

(PHP 5, PHP 7)

mysqli_connect — Takma Adı: mysqli::__construct()

Açıklama

Bu işlev şu işlevin takma adıdır: mysqli::__construct()

Although the mysqli::__construct() documentation also includes procedural examples that use the mysqli_connect() function, here is a short example:

Örnekler

Örnek 1 mysqli_connect() example

<?php
$link = mysqli_connect("127.0.0.1", "my_user", "my_password", "my_db");

if (!$link) {
    echo "Error: Unable to connect to MySQL." . PHP_EOL;
    echo "Debugging errno: " . mysqli_connect_errno() . PHP_EOL;
    echo "Debugging error: " . mysqli_connect_error() . PHP_EOL;
    exit;
}

echo "Success: A proper connection to MySQL was made! The my_db database is great." . PHP_EOL;
echo "Host information: " . mysqli_get_host_info($link) . PHP_EOL;

mysqli_close($link);
?>

Yukarıdaki örneklerin çıktısı:

Success: A proper connection to MySQL was made! The my_db database is great.
Host information: localhost via TCP/IP
mysqli_client_encoding
mysqli::disable_reads_from_master
Aliases and deprecated Mysqli İşlevleri


Disable reads from master

mysqli_connect
mysqli_disable_rpl_parse
Aliases and deprecated Mysqli İşlevleri
PHP Manual

mysqli::disable_reads_from_master

mysqli_disable_reads_from_master

(PHP 5 < 5.3.0)

mysqli::disable_reads_from_master -- mysqli_disable_reads_from_master — Disable reads from master

Açıklama

Nesne yönelimli kullanım

void mysqli::disable_reads_from_master ( void )

Yordamsal kullanım

bool mysqli_disable_reads_from_master ( mysqli $link )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Uyarı

Bu işlevin kullanımı artık ÖNERİLMEMEKTEDİR ve PHP 5.3.0'da tamamen KALDIRILACAKTIR.

mysqli_connect
mysqli_disable_rpl_parse
Aliases and deprecated Mysqli İşlevleri


Disable RPL parse

mysqli::disable_reads_from_master
mysqli_enable_reads_from_master
Aliases and deprecated Mysqli İşlevleri
PHP Manual

mysqli_disable_rpl_parse

(PHP 5 < 5.3.0)

mysqli_disable_rpl_parse — Disable RPL parse

Açıklama

bool mysqli_disable_rpl_parse ( mysqli $link )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Uyarı

Bu işlevin kullanımı artık ÖNERİLMEMEKTEDİR ve PHP 5.3.0'da tamamen KALDIRILACAKTIR.

mysqli::disable_reads_from_master
mysqli_enable_reads_from_master
Aliases and deprecated Mysqli İşlevleri


Enable reads from master

mysqli_disable_rpl_parse
mysqli_enable_rpl_parse
Aliases and deprecated Mysqli İşlevleri
PHP Manual

mysqli_enable_reads_from_master

(PHP 5 < 5.3.0)

mysqli_enable_reads_from_master — Enable reads from master

Açıklama

bool mysqli_enable_reads_from_master ( mysqli $link )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Uyarı

Bu işlevin kullanımı artık ÖNERİLMEMEKTEDİR ve PHP 5.3.0'da tamamen KALDIRILACAKTIR.

mysqli_disable_rpl_parse
mysqli_enable_rpl_parse
Aliases and deprecated Mysqli İşlevleri


Enable RPL parse

mysqli_enable_reads_from_master
mysqli_escape_string
Aliases and deprecated Mysqli İşlevleri
PHP Manual

mysqli_enable_rpl_parse

(PHP 5 < 5.3.0)

mysqli_enable_rpl_parse — Enable RPL parse

Açıklama

bool mysqli_enable_rpl_parse ( mysqli $link )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Uyarı

Bu işlevin kullanımı artık ÖNERİLMEMEKTEDİR ve PHP 5.3.0'da tamamen KALDIRILACAKTIR.

mysqli_enable_reads_from_master
mysqli_escape_string
Aliases and deprecated Mysqli İşlevleri


Takma Adı: mysqli_real_escape_string

mysqli_enable_rpl_parse
mysqli_execute
Aliases and deprecated Mysqli İşlevleri
PHP Manual

mysqli_escape_string

(PHP 5, PHP 7)

mysqli_escape_string — Takma Adı: mysqli_real_escape_string()

Açıklama

Bu işlev şu işlevin takma adıdır: mysqli_real_escape_string().

mysqli_enable_rpl_parse
mysqli_execute
Aliases and deprecated Mysqli İşlevleri


Alias for mysqli_stmt_execute

mysqli_escape_string
mysqli_fetch
Aliases and deprecated Mysqli İşlevleri
PHP Manual

mysqli_execute

(PHP 5, PHP 7)

mysqli_execute — Alias for mysqli_stmt_execute()

Açıklama

This function is an alias of mysqli_stmt_execute().

Notlar

Bilginize:

mysqli_execute() is deprecated and will be removed.

Ayrıca Bakınız

  • mysqli_stmt_execute() - Executes a prepared Query

mysqli_escape_string
mysqli_fetch
Aliases and deprecated Mysqli İşlevleri


Alias for mysqli_stmt_fetch

mysqli_execute
mysqli_get_cache_stats
Aliases and deprecated Mysqli İşlevleri
PHP Manual

mysqli_fetch

(PHP 5 < 5.4.0)

mysqli_fetch — Alias for mysqli_stmt_fetch()

Açıklama

This function is an alias of mysqli_stmt_fetch().

Uyarı

Bu işlevin kullanımı PHP 5.3.0 itibariyle ÖNERİLMEMEKTE olup PHP 5.4.0'da tamamen KALDIRILMIŞTIR.

Ayrıca Bakınız

  • mysqli_stmt_fetch() - Fetch results from a prepared statement into the bound variables

mysqli_execute
mysqli_get_cache_stats
Aliases and deprecated Mysqli İşlevleri


Returns client Zval cache statistics

mysqli_fetch
mysqli_get_links_stats
Aliases and deprecated Mysqli İşlevleri
PHP Manual

mysqli_get_cache_stats

(PHP 5 >= 5.3.0 and < 5.4.0)

mysqli_get_cache_stats — Returns client Zval cache statistics

Uyarı

This function has been REMOVED as of PHP 5.4.0.

Açıklama

array mysqli_get_cache_stats ( void )

Returns an empty array. Sadece mysqlnd ile kullanılabilir.

Değiştirgeler

Dönen Değerler

Returns an empty array on success, FALSE otherwise.

Sürüm Bilgisi

Sürüm: | Açıklama
5.4.0 | The mysqli_get_cache_stats() was removed.
5.3.0 | The mysqli_get_cache_stats() was added as stub.

mysqli_fetch
mysqli_get_links_stats
Aliases and deprecated Mysqli İşlevleri


Return information about open and cached links

mysqli_get_cache_stats
mysqli_get_metadata
Aliases and deprecated Mysqli İşlevleri
PHP Manual

mysqli_get_links_stats

(PHP 5 >= 5.6.0, PHP 7)

mysqli_get_links_stats — Return information about open and cached links

Açıklama

array mysqli_get_links_stats ( void )

mysqli_get_links_stats() returns information about open and cached MySQL links.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

mysqli_get_links_stats() returns an associative array with three elements, keyed as follows:

total

An integer indicating the total number of open links in any state.

active_plinks

An integer representing the number of active persistent connections.

cached_plinks

An integer representing the number of inactive persistent connections.

mysqli_get_cache_stats
mysqli_get_metadata
Aliases and deprecated Mysqli İşlevleri


Alias for mysqli_stmt_result_metadata

mysqli_get_links_stats
mysqli_master_query
Aliases and deprecated Mysqli İşlevleri
PHP Manual

mysqli_get_metadata

(PHP 5 < 5.4.0)

mysqli_get_metadata — Alias for mysqli_stmt_result_metadata()

Açıklama

This function is an alias of mysqli_stmt_result_metadata().

Uyarı

Bu işlevin kullanımı PHP 5.3.0 itibariyle ÖNERİLMEMEKTE olup PHP 5.4.0'da tamamen KALDIRILMIŞTIR.

Ayrıca Bakınız

  • mysqli_stmt_result_metadata() - Returns result set metadata from a prepared statement

mysqli_get_links_stats
mysqli_master_query
Aliases and deprecated Mysqli İşlevleri


Enforce execution of a query on the master in a master/slave setup

mysqli_get_metadata
mysqli_param_count
Aliases and deprecated Mysqli İşlevleri
PHP Manual

mysqli_master_query

(PHP 5 < 5.3.0)

mysqli_master_query — Enforce execution of a query on the master in a master/slave setup

Açıklama

bool mysqli_master_query ( mysqli $link , string $query )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Uyarı

Bu işlevin kullanımı artık ÖNERİLMEMEKTEDİR ve PHP 5.3.0'da tamamen KALDIRILACAKTIR.

mysqli_get_metadata
mysqli_param_count
Aliases and deprecated Mysqli İşlevleri


Alias for mysqli_stmt_param_count

mysqli_master_query
mysqli_report
Aliases and deprecated Mysqli İşlevleri
PHP Manual

mysqli_param_count

(PHP 5 < 5.4.0)

mysqli_param_count — Alias for mysqli_stmt_param_count()

Açıklama

This function is an alias of mysqli_stmt_param_count().

Uyarı

Bu işlevin kullanımı PHP 5.3.0 itibariyle ÖNERİLMEMEKTE olup PHP 5.4.0'da tamamen KALDIRILMIŞTIR.

Ayrıca Bakınız

  • mysqli_stmt_param_count() - Returns the number of parameter for the given statement

mysqli_master_query
mysqli_report
Aliases and deprecated Mysqli İşlevleri


Takma Adı: mysqli_driver->report_mode

mysqli_param_count
mysqli_rpl_parse_enabled
Aliases and deprecated Mysqli İşlevleri
PHP Manual

mysqli_report

(PHP 5, PHP 7)

mysqli_report — Takma Adı: mysqli_driver->report_mode

Açıklama

Bu işlev şu işlevin takma adıdır: mysqli_driver->report_mode

mysqli_param_count
mysqli_rpl_parse_enabled
Aliases and deprecated Mysqli İşlevleri


Check if RPL parse is enabled

mysqli_report
mysqli_rpl_probe
Aliases and deprecated Mysqli İşlevleri
PHP Manual

mysqli_rpl_parse_enabled

(PHP 5 < 5.3.0)

mysqli_rpl_parse_enabled — Check if RPL parse is enabled

Açıklama

int mysqli_rpl_parse_enabled ( mysqli $link )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Uyarı

Bu işlevin kullanımı artık ÖNERİLMEMEKTEDİR ve PHP 5.3.0'da tamamen KALDIRILACAKTIR.

mysqli_report
mysqli_rpl_probe
Aliases and deprecated Mysqli İşlevleri


RPL probe

mysqli_rpl_parse_enabled
mysqli_send_long_data
Aliases and deprecated Mysqli İşlevleri
PHP Manual

mysqli_rpl_probe

(PHP 5 < 5.3.0)

mysqli_rpl_probe — RPL probe

Açıklama

bool mysqli_rpl_probe ( mysqli $link )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Uyarı

Bu işlevin kullanımı artık ÖNERİLMEMEKTEDİR ve PHP 5.3.0'da tamamen KALDIRILACAKTIR.

mysqli_rpl_parse_enabled
mysqli_send_long_data
Aliases and deprecated Mysqli İşlevleri


Alias for mysqli_stmt_send_long_data

mysqli_rpl_probe
mysqli::set_opt
Aliases and deprecated Mysqli İşlevleri
PHP Manual

mysqli_send_long_data

(PHP 5 < 5.4.0)

mysqli_send_long_data — Alias for mysqli_stmt_send_long_data()

Açıklama

This function is an alias of mysqli_stmt_send_long_data().

Uyarı

Bu işlevin kullanımı PHP 5.3.0 itibariyle ÖNERİLMEMEKTE olup PHP 5.4.0'da tamamen KALDIRILMIŞTIR.

Ayrıca Bakınız

  • mysqli_stmt_send_long_data() - Send data in blocks

mysqli_rpl_probe
mysqli::set_opt
Aliases and deprecated Mysqli İşlevleri


Alias of mysqli_options

mysqli_send_long_data
mysqli_slave_query
Aliases and deprecated Mysqli İşlevleri
PHP Manual

mysqli::set_opt

mysqli_set_opt

(PHP 5, PHP 7)

mysqli::set_opt -- mysqli_set_opt — Alias of mysqli_options()

Açıklama

This function is an alias of mysqli_options().

mysqli_send_long_data
mysqli_slave_query
Aliases and deprecated Mysqli İşlevleri


Force execution of a query on a slave in a master/slave setup

mysqli::set_opt
Changelog
Aliases and deprecated Mysqli İşlevleri
PHP Manual

mysqli_slave_query

(PHP 5 < 5.3.0)

mysqli_slave_query — Force execution of a query on a slave in a master/slave setup

Açıklama

bool mysqli_slave_query ( mysqli $link , string $query )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Uyarı

Bu işlevin kullanımı artık ÖNERİLMEMEKTEDİR ve PHP 5.3.0'da tamamen KALDIRILACAKTIR.

mysqli::set_opt
Changelog
Aliases and deprecated Mysqli İşlevleri


Changelog

The following changes have been made to classes/functions/methods of this extension.

Version | Function | Description
5.6.16 | mysqli::real_connect | Added the MYSQLI_CLIENT_SSL_DONT_VERIFY_SERVER_CERT flag for MySQL Native Driver
5.5.0 | mysqli::commit | Added flags and name parameters.
 | mysqli::options | The MYSQLI_SERVER_PUBLIC_KEY and MYSQLI_SERVER_PUBLIC_KEY options were added.
 | mysqli::rollback | Added flags and name parameters.
5.4.0 | mysqli_get_cache_stats | The mysqli_get_cache_stats was removed.
5.3.4 | mysqli_driver::$report_mode | Changing the reporting mode is now be per-request, rather than per-process.
5.3.0 | mysqli_get_cache_stats | The mysqli_get_cache_stats was added as stub.
 | mysqli::__construct | Added the ability of persistent connections.
 | mysqli::options | The MYSQLI_OPT_INT_AND_FLOAT_NATIVE, MYSQLI_OPT_NET_CMD_BUFFER_SIZE, MYSQLI_OPT_NET_READ_BUFFER_SIZE, and MYSQLI_OPT_SSL_VERIFY_SERVER_CERT options were added.
 | mysqli::query | Added the ability of async queries.
5.2.15 | mysqli_driver::$report_mode | Changing the reporting mode is now be per-request, rather than per-process.
mysqli_slave_query
MySQL
MySQLi


MySQL
PHP Manual

MySQL

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
  • MySQL İşlevleri
    • mysql_affected_rows — Önceki MySQL işleminde etkilenen satırların sayısını al
    • mysql_client_encoding — Karakter kümesinin adını döndürür
    • mysql_close — MySQL bağlantısını kapatır
    • mysql_connect — MySQL Sunucusuna bir bağlantı açar
    • mysql_create_db — Bir MySQL veritabanı oluşturur
    • mysql_data_seek — Move internal result pointer
    • mysql_db_name — Sonuç verisini al
    • mysql_db_query — Bir MySQL sorgusu gönderir
    • mysql_drop_db — Drop (delete) a MySQL database
    • mysql_errno — Returns the numerical value of the error message from previous MySQL operation
    • mysql_error — Returns the text of the error message from previous MySQL operation
    • mysql_escape_string — Escapes a string for use in a mysql_query
    • mysql_fetch_array — Fetch a result row as an associative array, a numeric array, or both
    • mysql_fetch_assoc — Fetch a result row as an associative array
    • mysql_fetch_field — Get column information from a result and return as an object
    • mysql_fetch_lengths — Bir sonuçtaki her bir çıktının uzunluğunu al
    • mysql_fetch_object — Fetch a result row as an object
    • mysql_fetch_row — Get a result row as an enumerated array
    • mysql_field_flags — Get the flags associated with the specified field in a result
    • mysql_field_len — Belirtilen alanın uzunluğunu döndürür
    • mysql_field_name — Get the name of the specified field in a result
    • mysql_field_seek — Sonuç göstericisini belirtilen alan konumuna ayarla
    • mysql_field_table — Belirtilen alanı içeren tablonun adını al
    • mysql_field_type — Get the type of the specified field in a result
    • mysql_free_result — Sonuç belleğini serbest bırakır
    • mysql_get_client_info — MySQL istemci sürüm bilgisini al
    • mysql_get_host_info — MySQL konak bilgisini al
    • mysql_get_proto_info — MySQL protokol sürüm bilgisini al
    • mysql_get_server_info — MySQL sunucu bilgisini al
    • mysql_info — En son sorgu hakkında bilgi al
    • mysql_insert_id — Get the ID generated in the last query
    • mysql_list_dbs — Bir MySQL sunucusundaki kullanılabilir veritabanlarını listeler
    • mysql_list_fields — MySQL tablosunun alanlarını listeler
    • mysql_list_processes — MySQL süreçlerini listeler
    • mysql_list_tables — Bir MySQL veritabanındaki tabloları listele
    • mysql_num_fields — Sonuçtaki alan sayısını al
    • mysql_num_rows — Sonuçtaki satır sayısını al
    • mysql_pconnect — Open a persistent connection to a MySQL server
    • mysql_ping — Bir sunucu bağlantısına ping at, bağlantı yoksa tekrar bağlan
    • mysql_query — Send a MySQL query
    • mysql_real_escape_string — Escapes special characters in a string for use in an SQL statement
    • mysql_result — Get result data
    • mysql_select_db — Bir MySQL veritabanı seçer
    • mysql_set_charset — Sets the client character set
    • mysql_stat — Geçerli sunucu durumunu döndürür
    • mysql_tablename — Alanın tablo adını al
    • mysql_thread_id — Geçerli evre numarasını döndür
    • mysql_unbuffered_query — Sonuç kümesi tamponlanmayan ve alınmayan bir SQL sorgusu gönderir
Changelog
Giriş
MySQL
PHP Manual


Giriş

Bu işlevler MySQL veritabanı sunucularına erişmenizi sağlar. MySQL hakkında daha fazla bilgi » http://www.mysql.com/ adresinde bulunabilir.

MySQL belgeleri » http://dev.mysql.com/doc/ adresinde bulunabilir.

MySQL veritabanı ürünleri ve bağlanabilirlik kuralları hakkında Overview bölümünde bilgi bulabilirsiniz.

MySQL
Yapılandırma/Kurulum
MySQL


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
MySQL


Gereksinimler

Bu işlevleri kullanabilmek için, PHP'yi MySQL desteği ile derlemelisiniz.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Uyarı

This extension was deprecated in PHP 5.5.0, and it was removed in PHP 7.0.0. Instead, the MySQLi or PDO_MySQL extension should be used. See also MySQL: choosing an API guide and related FAQ for more information. Alternatives to this function include:

Derlemek için, tercihe bağlı [DIR] MySQL kurulum dizinine işaret edecek şekilde, --with-mysql[=DIR] ayar seçeneğini kullanın.

Bu MySQL eklentisi MySQL 4.1.0 ve üzeri ile uyumlu olduğu halde, bu sürümlerin sağladığı fazladan özellikleri desteklemez. Bunun için, MySQLi eklentisini kullanın.

Eğer mysqli eklentisinin yanısıra mysql eklentisini de kurmak isterseniz uyuşmazlıkları önlemek için aynı istemci kütüphanesini kullanmanız gerekmektedir.

Linux Sistemlerde Kurulum

[DIR] MySQL istemci kütüphanesi (başlık ve kütüphane dosyaları) dosyalarının yolu olup bunlar » MySQL ile indirilebilir.

ext/mysql derleme zamanı destek matrisi
PHP Sürüm: | Öntanımlı | Yapılandırma Seçenekleri: mysqlnd | Yapılandırma Seçenekleri: libmysqlclient | Sürüm Bilgisi
4.x.x | libmysqlclient | Kullanılabilir değil | etkisizleştirmek için --without-mysql | MySQL öntanımlı olarak etkindir. MySQL istemci kütüphaneleri dahil edilir.
5.0.x, 5.1.x, 5.2.x | libmysqlclient | Kullanılabilir değil | --with-mysql=[DIR] | MySQL artık öntanımlı olarak etkin değildir ve MySQL istemci kütüphaneleri dahil edilmez.
5.3.x | libmysqlclient | --with-mysql=mysqlnd | --with-mysql=[DIR] | mysqlnd kullanılabilir oldu
5.4.x | mysqlnd | --with-mysql | --with-mysql=[DIR] | mysqlnd öntanımlı oldu

Windows Sistemlerde Kurulum

PHP 5.0.x, 5.1.x, 5.2.x

MySQL artık öntanımlı olarak etkin değildir, bu yüzden php_mysql.dll DLL'i php.ini içinde seçilmelidir. Ayrıca PHP, MySQL istemci kütüphanelerine de erişmeye gereksinim duyar. Windows PHP dağıtımında libmysql.dll isimli bir dosya bulunur ve PHP'nin MySQL ile konuşabilmesi için bu dosya Windows sistem PATH'inden erişilebilir olmalıdır. Bunu nasıl yapabileceğinizi öğrenmek için "PHP dizinimi Windows'ta PATH değişkenine nasıl eklerim" başlıklı soruyu inceleyiniz. libmysql.dll'i Windows sistem dizinine kopyalamak işe yarasa da (çünkü sistem dizini öntanımlı olarak sistemin PATH'indedir), tavsiye edilmez.

Herhangi bir PHP eklentisinin (php_mysql.dll gibi) etkin kılınması sırasında, extension_dir PHP yönergesi de PHP eklentilerinin bulunduğu konumu gösterecek şekilde ayarlanmalıdır. Elle Windows Kurulumu Komutları'nı da inceleyiniz. PHP5 için örnek bir extension_dir değeri c:\php\ext'dir.

Bilginize:

Eğer HTTP sunucusunu başlatırken "Unable to load dynamic library './php_mysql.dll'" benzeri bir hata oluşuyorsa, bunun nedeni php_mysql.dll ve/veya libmysql.dll'in sistem tarafından bulunamamasıdır.

PHP 5.3.0+

MySQL Yerli Sürücü öntanımlı olarak etkindir. php_mysql.dll buna dahildir, fakat libmysql.dll artık ne gerekmekte ne de kullanılmaktadır.

MySQL Kurulum Notları

Uyarı

Bu eklenti recode eklentisiyle birlikte yüklendiğinde PHP'nin çakılması veya başlama sorunları ile karşılaşabilirsiniz. Daha fazla bilgi için recode eklentisine bakınız.

Bilginize:

Eğer (öntanımlı) latin karakter seti dışında karakter kümelerine ihtiyaç duyarsanız, karakter kümesi desteği ile derlenmiş olan harici bir libmysqlclient kurmalısınız.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

MySQL Ayar Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
mysql.allow_local_infile | "1" | PHP_INI_SYSTEM |
mysql.allow_persistent | "1" | PHP_INI_SYSTEM |
mysql.max_persistent | "-1" | PHP_INI_SYSTEM |
mysql.max_links | "-1" | PHP_INI_SYSTEM |
mysql.trace_mode | "0" | PHP_INI_ALL | PHP 4.3.0'den itibaren kullanılabilir.
mysql.default_port | NULL | PHP_INI_ALL |
mysql.default_socket | NULL | PHP_INI_ALL | PHP 4.0.1'den itibaren kullanılabilir.
mysql.default_host | NULL | PHP_INI_ALL |
mysql.default_user | NULL | PHP_INI_ALL |
mysql.default_password | NULL | PHP_INI_ALL |
mysql.connect_timeout | "60" | PHP_INI_ALL | PHP <= 4.3.2'te PHP_INI_SYSTEM. PHP 4.3.0'den itibaren kullanılabilir.
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

mysql.allow_local_infile integer

PHP'nin bakış açısından LOAD DATA deyimleriyle yerel dosyalara erişime izin verir.

mysql.allow_persistent boolean

MySQL'e Kalıcı bağlantı yapılmasına izin verilip verilmeyeceğini belirler.

mysql.max_persistent integer

Süreç başına azami kalıcı MySQL bağlantı sayısı.

mysql.max_links integer

Kalıcı bağlantılar da dahil, süreç başına en yüksek MySQL bağlantı sayısı.

mysql.trace_mode boolean

İz sürme kipi. mysql.trace_mode seçildiği zaman, tablo/indis taramaları, boş olmayan sonuç kümeleri ve SQL hataları için uyarı gösterilir. (PHP 4.3.0'dan itibaren)

mysql.default_port string

Eğer başka bir port numarası belirtilmediyse, veritabanı sunucusuna bağlanırken kullanılacak öntanımlı port numarası. Eğer öntanımlı bir değer tanımlanmadıysa, port sırasıyla MYSQL_TCP_PORT ortam değişkeninden, /etc/services dosyasındaki mysql-tcp girdisinden veya MYSQL_PORT sabitinden alınır. Win32 sadece MYSQL_PORT sabitini kullanacaktır.

mysql.default_socket string

Yereldeki bir veritabanı sunucusuna bağlanırken başka bir soket adı belirtilmediyse kullanılacak olan öntanımlı soket adı.

mysql.default_host string

Veritabanı sunucusuna bağlanırken eğer başka bir konak belirtilmediyse kullanılacak olan öntanımlı konak. sql.safe_mode'da geçerli değildir.

mysql.default_user string

Veritabanı sunucusuna bağlanırken eğer başka bir kullanıcı adı belirtilmediyse kullanılacak olan öntanımlı kullanıcı adı. sql.safe_mode'da geçerli değildir.

mysql.default_password string

Veritabanı sunucusuna bağlanırken eğer başka bir parola belirtilmediyse kullanılacak olan öntanımlı parola. sql.safe_mode'da geçerli değildir.

mysql.connect_timeout integer

Saniye cinsinden bağlantı zaman aşımı süresi. Linux'ta, bu zaman aşımı süresi sunucudan ilk cevabı beklemek için de kullanılır.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Özkaynak Türleri

MySQL modülünde iki kaynak türü vardır. Birincisi veritabanı bağlantısı belirteci, ikincisi de sorgu sonuçlarını tutan kaynaktır.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

PHP 4.3.0 sürümünden itibaren mysql_connect() ve mysql_pconnect() işlevleri için fazladan istemci seçenekleri tanımlanabilmektedir. Aşağıdaki sabitler tanımlanmıştır:

MySQL istemci sabitleri
Sabit | Açıklama
MYSQL_CLIENT_COMPRESS | Sıkıştırma protokolü kullan
MYSQL_CLIENT_IGNORE_SPACE | İşlev isimlerinden sonra boşluğa izin ver
MYSQL_CLIENT_INTERACTIVE | Bağlantıyı kapatmadan önce (wait_timeout yerine) interactive_timeout saniye hareketsizliğe izin ver. İstemci oturumunun wait_timeout değişkeninin değeri oturumun interactive_timeout değişkenine atanır.
MYSQL_CLIENT_SSL | SSL şifrelemesi kullan. Bu seçenek MySQL istemci kütüphanesinin sadece 4.x veya daha yeni sürümlerinde kullanılabilir. 3.23.x sürümü hem PHP 4 ile hem de PHP 5'in Windows çalıştırılabilir dosyaları ile birlikte gelir.

mysql_fetch_array() işlevi farklı türlerdeki sonuç dizileri için bir sabit kullanır. Şu sabitler tanımlanmıştır:

MySQL veri çekme sabitleri
Sabit | Açıklama
MYSQL_ASSOC | Sütunlar indisi alan adı olan bir dizi olarak döndürülür.
MYSQL_BOTH | Sütunlar, hem alan adı anahtarlı hem de sayısal indisli bir dizi olarak döndürülür.
MYSQL_NUM | Sütunlar, alanları sayısal indisli bir dizi olarak döndürülür. Bu indis 0'dan başlar.

Özkaynak Türleri
Örnekler
MySQL


Örnekler

İçindekiler

Öntanımlı Sabitler
MySQL


Örnekler
MySQL İşlevleri
Örnekler
PHP Manual

Bu basit örnek bir MySQL sunucuya nasıl bağlanılacağını, bir sorgunun nasıl çalıştırılacağını, sonuç satırlarının nasıl bastırılacağını ve bağlantının nasıl kesileceğini gösterir.

Örnek 1 - MySQL eklentisi örneği

<?php
// Bağlanıyor, veritabanı seçiliyor
$link = mysql_connect('mysql_host', 'mysql_user', 'mysql_password')
    or die('Bağlanamadı: ' . mysql_error());
echo 'Başarıyla bağlandı';
mysql_select_db('my_database') or die('Veritabanı seçilemedi');

// SQL sorgusu uygulanıyor
$query = 'SELECT * FROM my_table';
$result = mysql_query($query) or die('Sorgu başarısız: ' . mysql_error());

// Sonuçlar HTML olarak gösteriliyor
echo "<table>\n";
while ($line = mysql_fetch_array($result, MYSQL_ASSOC)) {
    echo "\t<tr>\n";
    foreach ($line as $col_value) {
        echo "\t\t<td>$col_value</td>\n";
    }
    echo "\t</tr>\n";
}
echo "</table>\n";

// Sonuç kümesi serbest bırakılıyor
mysql_free_result($result);

// Bağlantı kapatılıyor
mysql_close($link);
?>

Örnekler
MySQL İşlevleri
Örnekler


MySQL İşlevleri

Notlar

Bilginize:

Çoğu MySQL işlevi bağlantı_belirteci'ni sonuncu tercihe bağlı değiştirge olarak kabul eder. Eğer verilmemişse, son açılan bağlantı kullanılır. Eğer yoksa, php.ini'de belirlenen öntanımlı değiştirgelerle bir bağlantı kurulmaya çalışılır. Eğer başarılı olamazsa, işlev FALSE sonucunu döndürür.

İçindekiler

  • mysql_affected_rows — Önceki MySQL işleminde etkilenen satırların sayısını al
  • mysql_client_encoding — Karakter kümesinin adını döndürür
  • mysql_close — MySQL bağlantısını kapatır
  • mysql_connect — MySQL Sunucusuna bir bağlantı açar
  • mysql_create_db — Bir MySQL veritabanı oluşturur
  • mysql_data_seek — Move internal result pointer
  • mysql_db_name — Sonuç verisini al
  • mysql_db_query — Bir MySQL sorgusu gönderir
  • mysql_drop_db — Drop (delete) a MySQL database
  • mysql_errno — Returns the numerical value of the error message from previous MySQL operation
  • mysql_error — Returns the text of the error message from previous MySQL operation
  • mysql_escape_string — Escapes a string for use in a mysql_query
  • mysql_fetch_array — Fetch a result row as an associative array, a numeric array, or both
  • mysql_fetch_assoc — Fetch a result row as an associative array
  • mysql_fetch_field — Get column information from a result and return as an object
  • mysql_fetch_lengths — Bir sonuçtaki her bir çıktının uzunluğunu al
  • mysql_fetch_object — Fetch a result row as an object
  • mysql_fetch_row — Get a result row as an enumerated array
  • mysql_field_flags — Get the flags associated with the specified field in a result
  • mysql_field_len — Belirtilen alanın uzunluğunu döndürür
  • mysql_field_name — Get the name of the specified field in a result
  • mysql_field_seek — Sonuç göstericisini belirtilen alan konumuna ayarla
  • mysql_field_table — Belirtilen alanı içeren tablonun adını al
  • mysql_field_type — Get the type of the specified field in a result
  • mysql_free_result — Sonuç belleğini serbest bırakır
  • mysql_get_client_info — MySQL istemci sürüm bilgisini al
  • mysql_get_host_info — MySQL konak bilgisini al
  • mysql_get_proto_info — MySQL protokol sürüm bilgisini al
  • mysql_get_server_info — MySQL sunucu bilgisini al
  • mysql_info — En son sorgu hakkında bilgi al
  • mysql_insert_id — Get the ID generated in the last query
  • mysql_list_dbs — Bir MySQL sunucusundaki kullanılabilir veritabanlarını listeler
  • mysql_list_fields — MySQL tablosunun alanlarını listeler
  • mysql_list_processes — MySQL süreçlerini listeler
  • mysql_list_tables — Bir MySQL veritabanındaki tabloları listele
  • mysql_num_fields — Sonuçtaki alan sayısını al
  • mysql_num_rows — Sonuçtaki satır sayısını al
  • mysql_pconnect — Open a persistent connection to a MySQL server
  • mysql_ping — Bir sunucu bağlantısına ping at, bağlantı yoksa tekrar bağlan
  • mysql_query — Send a MySQL query
  • mysql_real_escape_string — Escapes special characters in a string for use in an SQL statement
  • mysql_result — Get result data
  • mysql_select_db — Bir MySQL veritabanı seçer
  • mysql_set_charset — Sets the client character set
  • mysql_stat — Geçerli sunucu durumunu döndürür
  • mysql_tablename — Alanın tablo adını al
  • mysql_thread_id — Geçerli evre numarasını döndür
  • mysql_unbuffered_query — Sonuç kümesi tamponlanmayan ve alınmayan bir SQL sorgusu gönderir
mysql_affected_rows
MySQL


Önceki MySQL işleminde etkilenen satırların sayısını al

MySQL İşlevleri
mysql_client_encoding
MySQL İşlevleri
PHP Manual

mysql_affected_rows

(PHP 4, PHP 5)

mysql_affected_rows — Önceki MySQL işleminde etkilenen satırların sayısını al

Açıklama

int mysql_affected_rows ([ resource $bağlantı_belirteci ] )

bağlantı_belirteci ile ilişkili son INSERT, UPDATE, REPLACE veya DELETE sorgusundan etkilenen satır sayısını döndürür.

Değiştirgeler

bağlantı_belirteci

MySQL bağlantısı. Eğer bağlantı belirteci belirtilmemişse mysql_connect() tarafından açılan son bağlantı kullanılmaya çalışılır. Eğer böyle bir bağlantı yoksa mysql_connect() değiştirgesiz olarak çağrılmış gibi bir bağlantı oluşturmaya çalışır. Hiçbir bağlantı yoksa ve yenisi de kurulamazsa E_WARNING seviyesinde bir hata üretilir.

Dönen Değerler

Son sorgunun başarılı olması durumunda etkilenen satırların sayısını döndürür; başarısız olması durumunda -1 döndürür.

Eğer son sorgu, WHERE şartı içermeyen bir DELETE sorgusuysa, tablodaki bütün kayıtlar silinmiş demektir, ancak bu işlev MySQL'in 4.1.2'den önceki sürümlerinde 0 döndürür.

UPDATE'i kullanırken, MySQL yeni değerleri eski değerleri ile aynı olan sütunları düzeltmez. Bu da mysql_affected_rows()'un muhtemelen uyan tüm satırların değil, sadece sorgu sonucu gerçekten düzeltilen satırların sayısını döndürmesine neden olur.

REPLACE ifadesi aynı birincil anahtara sahip olan kayıtları siler, daha sonra yeni kaydı girer. Bu işlev silinen kayıtların sayısı artı girilen kayıtların sayısını döndürür.

Örnekler

Örnek 1 - mysql_affected_rows() örneği

<?php
$link = mysql_connect('localhost', 'mysql_user', 'mysql_password');
if (!$link) {
    die('Bağlanamadı: ' . mysql_error());
}
mysql_select_db('mydb');

/* bu silinen kayıtların gerçek sayısını döndürmeli */
mysql_query('DELETE FROM mytable WHERE id < 10');
printf("Silinen kayıtlar: %d\n", mysql_affected_rows());

/* WHERE şartıyla asla true olmaz, 0 döndürmeli */
mysql_query('DELETE FROM mytable WHERE 0');
printf("Silinen kayıtlar: %d\n", mysql_affected_rows());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Silinen kayıtlar: 10
Silinen kayıtlar: 0

Örnek 2 - Hareket kullananılan mysql_affected_rows() örneği

<?php
$link = mysql_connect('localhost', 'mysql_user', 'mysql_password');
if (!$link) {
    die('Bağlanamadı: ' . mysql_error());
}
mysql_select_db('mydb');

/* Kayıtları güncelle */
mysql_query("UPDATE mytable SET used=1 WHERE id < 10");
printf ("Güncellenen kayıtlar: %d\n", mysql_affected_rows());
mysql_query("COMMIT");
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Güncellenen kayıtlar: 10

Notlar

Bilginize: Hareketler

Eğer hareketleri kullanıyorsanız mysql_affected_rows() işlevini INSERT, UPDATE veya DELETE sorgunuzdan sonra, ama COMMIT'den önce kullanmalısınız.

Bilginize: SELECT Deyimleri

Bir SELECT sorgusundan döndürülen satırların sayısını almak için, mysql_num_rows() işlevini kullanmak mümkündür.

Bilginize: Birleşik Yabancı Anahtarlar

mysql_affected_rows() yabancı anahtar kısıtlarındaki ON DELETE CASCADE ve/veya ON UPDATE CASCADE kullanımları üzerinden dolaylı olarak etkilenen satırları saymaz.

Ayrıca Bakınız

  • mysql_num_rows() - Sonuçtaki satır sayısını al
  • mysql_info() - En son sorgu hakkında bilgi al

MySQL İşlevleri
mysql_client_encoding
MySQL İşlevleri


Karakter kümesinin adını döndürür

mysql_affected_rows
mysql_close
MySQL İşlevleri
PHP Manual

mysql_client_encoding

(PHP 4 >= 4.3.0, PHP 5)

mysql_client_encoding — Karakter kümesinin adını döndürür

Açıklama

string mysql_client_encoding ([ resource $bağlantı_belirteci ] )

MySQL'den character_set değişkenini alır.

Değiştirgeler

bağlantı_belirteci

MySQL bağlantısı. Eğer bağlantı belirteci belirtilmemişse mysql_connect() tarafından açılan son bağlantı kullanılmaya çalışılır. Eğer böyle bir bağlantı yoksa mysql_connect() değiştirgesiz olarak çağrılmış gibi bir bağlantı oluşturmaya çalışır. Hiçbir bağlantı yoksa ve yenisi de kurulamazsa E_WARNING seviyesinde bir hata üretilir.

Dönen Değerler

Geçerli bağlantı için öntanımlı karakter kümesini döndürür.

Örnekler

Örnek 1 - mysql_client_encoding() örneği

<?php
$link    = mysql_connect('localhost', 'mysql_user', 'mysql_password');
$charset = mysql_client_encoding($link);

echo "Geçerli karakter kümesi: $charset\n";
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Geçerli karakter kümesi: latin5

Ayrıca Bakınız

  • mysql_set_charset() - Sets the client character set
  • mysql_real_escape_string() - Escapes special characters in a string for use in an SQL statement

mysql_affected_rows
mysql_close
MySQL İşlevleri


MySQL bağlantısını kapatır

mysql_client_encoding
mysql_connect
MySQL İşlevleri
PHP Manual

mysql_close

(PHP 4, PHP 5)

mysql_close — MySQL bağlantısını kapatır

Açıklama

bool mysql_close ([ resource $bağlantı_belirteci ] )

mysql_close() işlevi, MySQL sunucusuna, bağlantı belirteci ile belirtilen kalıcı olmayan bağlantıyı kapatır. Eğer bağlantı_belirteci belirtilmemişse, son açılan bağlantı kullanılır.

Kalıcı olmayan bağlantılar betiğin çalışmasından sonra özdevinimli olarak kapatıldığından mysql_close()'u kullanmak genellikle gerekli değildir. Ayrıca, Özkaynakları serbest bırakmak bölümüne de bakınız.

Değiştirgeler

bağlantı_belirteci

MySQL bağlantısı. Eğer bağlantı belirteci belirtilmemişse mysql_connect() tarafından açılan son bağlantı kullanılmaya çalışılır. Eğer böyle bir bağlantı yoksa mysql_connect() değiştirgesiz olarak çağrılmış gibi bir bağlantı oluşturmaya çalışır. Hiçbir bağlantı yoksa ve yenisi de kurulamazsa E_WARNING seviyesinde bir hata üretilir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - mysql_close() örneği

<?php
$link = mysql_connect('localhost', 'mysql_user', 'mysql_password');
if (!$link) {
    die('Bağlanamadı: ' . mysql_error());
}
echo 'Başarıyla bağlandı';
mysql_close($link);
?>

Yukarıdaki örneğin çıktısı:

Başarıyla bağlandı

Notlar

Bilginize:

mysql_close() mysql_pconnect() ile oluşturulmuş kalıcı bağlantıları kapatmayacaktır.

Ayrıca Bakınız

  • mysql_connect() - MySQL Sunucusuna bir bağlantı açar
  • mysql_free_result() - Sonuç belleğini serbest bırakır

mysql_client_encoding
mysql_connect
MySQL İşlevleri


MySQL Sunucusuna bir bağlantı açar

mysql_close
mysql_create_db
MySQL İşlevleri
PHP Manual

mysql_connect

(PHP 4, PHP 5)

mysql_connect — MySQL Sunucusuna bir bağlantı açar

Açıklama

resource mysql_connect ([ string $sunucu = ini_get("mysql.default_host") [, string $kullanıcı_adı = ini_get("mysql.default_user") [, string $parola = ini_get("mysql.default_password") [, bool $yeni_bağlantı = false [, int $istemci_seçenekleri = 0 ]]]]] )

Bir MySQL sunucusuna bir bağlantı açar veya var olanı tekrar kullanır.

Değiştirgeler

sunucu

MySQL sunucusu. "konak_adı:port" biçiminde ayrıca bir de port içerebileceği gibi localhost için belirtildiğinde ":/bir/yol/soket" biçiminde yerel bir sokete bir yol da belirtebilir.

Eğer mysql.default_host PHP yönergesi tanımsızsa (öntanımlı), öntanımlı değer 'localhost:3306''dır. sql.safe_mode'da bu değiştirge önemsenmez ve her zaman 'localhost:3306' değeri kullanılır.

kullanıcı_adı

Kullanıcı adı. Öntanımlı değer mysql.default_user ile tanımlanır. sql.safe_mode'da, bu değiştirge önemsenmez ve sunucu sürecinin sahibi olan kullanıcı kullanılır.

parola

Parola. Öntanımlı değer mysql.default_password ile tanımlanır. sql.safe_mode'da, bu değiştirge önemsenmez ve boş parola kullanılır.

yeni_bağlantı

Eğer mysql_connect() aynı değiştirgelerle ikinci kez çağrılırsa, yeni bir bağlantı kurulmaz, zaten açık olan bağlantının belirteci döndürülür. yeni_bağlantı değiştirgesi bu davranışı değiştirir ve mysql_connect(), daha önce aynı değiştirgelerle çağrılmış olsa bile her zaman yeni bir bağlantı açar. sql.safe_mode'da bu değiştirge önemsenmez.

istemci_seçenekleri

istemci_seçenekleri değiştirgesi şu sabitlerin bir karışımı olabilir: 128 (LOAD DATA LOCAL tutamağı etkin), MYSQL_CLIENT_SSL, MYSQL_CLIENT_COMPRESS, MYSQL_CLIENT_IGNORE_SPACE veya MYSQL_CLIENT_INTERACTIVE. Daha fazla bilgi için MySQL istemci sabitleri ile ilgili bölümü okuyun. sql.safe_mode'da bu değiştirge önemsenmez.

Dönen Değerler

Başarı durumunda bir MySQL bağlantı belirteci döndürür, hata durumunda FALSE döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.0 | istemci_seçenekleri değiştirgesi eklendi.
4.2.0 | yeni_bağlantı değiştirgesi eklendi.

Örnekler

Örnek 1 - mysql_connect() örneği

<?php
$link = mysql_connect('localhost', 'mysql_user', 'mysql_password');
if (!$link) {
    die('Bağlanamadı: ' . mysql_error());
}
echo 'Başarıyla bağlandı';
mysql_close($link);
?>

Örnek 2 - konak_adı:port sözdizimini kullanan mysql_connect() örneği

<?php
// 3307 portundan example.com'a bağlanıyoruz
$link = mysql_connect('example.com:3307', 'mysql_user', 'mysql_password');
if (!$link) {
    die('Bağlanamadı: ' . mysql_error());
}
echo 'Başarıyla bağlandı';
mysql_close($link);

// 3307 portundan localhost'a bağlanıyoruz
$link = mysql_connect('127.0.0.1:3307', 'mysql_user', 'mysql_password');
if (!$link) {
    die('Bağlanamadı: ' . mysql_error());
}
echo 'Başarıyla bağlandı';
mysql_close($link);
?>

Örnek 3 - ":/bir/yol/soket" sözdizimini kullanan mysql_connect() örneği

<?php
// localhost ve sokete, örneğin /tmp/mysql.sock, bağlanıyoruz

// 1. yol: localhost'u ihmal ederek
$link = mysql_connect(':/tmp/mysql', 'mysql_user', 'mysql_password');
if (!$link) {
    die('Bağlanamadı: ' . mysql_error());
}
echo 'Başarıyla bağlandı';
mysql_close($link);

// 2. yol: localhost ile
$link = mysql_connect('localhost:/tmp/mysql.sock', 'mysql_user', 'mysql_password');
if (!$link) {
    die('Bağlanamadı: ' . mysql_error());
}
echo 'Başarıyla bağlandı';
mysql_close($link);
?>

Notlar

Bilginize:

Sunucu olarak "localhost" veya "localhost:port" belirttiğinizde, MySQL istemci kütüphanesi bunu geçersiz kılar ve yerel bir sokete (Windows'ta boru hattı (pipe) denir) bağlanmaya çalışır. TCP/IP kullanmak istiyorsanız, "localhost" yerine "127.0.0.1" kullanın. Eğer MySQL istemci kütüphanesi yanlış bir yerel sokete bağlanmaya çalışırsa, doğru yolu PHP ayarlarınızda yönergesiyle ayarlamalı ve sunucu alanını boş bırakmalısınız.

Bilginize:

Sunucuya bağlantı, eğer daha önceden mysql_close() kullanılarak kapatılmadıysa, betiğin çalışması biter bitmez kapatılır.

Bilginize:

Hata iletisini işlev adının önüne bir @ imi koyarak önleyebilirsiniz.

Bilginize:

"Can't create TCP/IP socket (10106)" hatası genellikle variables_order yapılandırma yönergesinin E harfini içermediği anlamına gelir. Windows'ta, ortam kopyalanmadıysa SYSTEMROOT ortam değişkeni kullanılamaz ve PHP Winsock'u yüklerken sorun yaşar.

Ayrıca Bakınız

  • mysql_pconnect() - Open a persistent connection to a MySQL server
  • mysql_close() - MySQL bağlantısını kapatır

mysql_close
mysql_create_db
MySQL İşlevleri


Bir MySQL veritabanı oluşturur

mysql_connect
mysql_data_seek
MySQL İşlevleri
PHP Manual

mysql_create_db

(PHP 4, PHP 5)

mysql_create_db — Bir MySQL veritabanı oluşturur

Açıklama

bool mysql_create_db ( string $veritabanı_adı [, resource $bağlantı_belirteci ] )

mysql_create_db() verilen bağlantı belirteci ile ilişkili sunucuda yeni bir veritabanı oluşturmaya çalışır.

Değiştirgeler

veritabanı_adı

Oluşturulacak veritabanının adı.

bağlantı_belirteci

MySQL bağlantısı. Eğer bağlantı belirteci belirtilmemişse mysql_connect() tarafından açılan son bağlantı kullanılmaya çalışılır. Eğer böyle bir bağlantı yoksa mysql_connect() değiştirgesiz olarak çağrılmış gibi bir bağlantı oluşturmaya çalışır. Hiçbir bağlantı yoksa ve yenisi de kurulamazsa E_WARNING seviyesinde bir hata üretilir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - mysql_create_db() yerine kullanılacak kod örneği

mysql_create_db() işlevinin kullanımı önerilmemektedir. Bunun yerine CREATE DATABASE deyimini çalıştırmak için mysql_query() kullanmak tercih edilebilir.

<?php
$link = mysql_connect('localhost', 'mysql_user', 'mysql_password');
if (!$link) {
    die('Bağlanamadı: ' . mysql_error());
}

$sql = 'CREATE DATABASE benim_vt';
if (mysql_query($sql, $link)) {
    echo "benim_vt veritabanı başarıyla oluşturuldu\n";
} else {
    echo 'veritabanı oluşturulurken hata: ' . mysql_error() . "\n";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

benim_vt veritabanı başarıyla oluşturuldu

Notlar

Bilginize:

Geriye uyumluluk adına, kullanımı önerilmese de şu takma adı kullanabilirsiniz: mysql_createdb()

Bilginize:

Eğer MySQL eklentisi MySQL 4.x istemci kütüphanesini kullanacak şekilde derlendiyse bu işlev kullanılamaz.

Ayrıca Bakınız

  • mysql_query() - Send a MySQL query
  • mysql_select_db() - Bir MySQL veritabanı seçer

mysql_connect
mysql_data_seek
MySQL İşlevleri


Move internal result pointer

mysql_create_db
mysql_db_name
MySQL İşlevleri
PHP Manual

mysql_data_seek

(PHP 4, PHP 5)

mysql_data_seek — Move internal result pointer

Uyarı

This extension was deprecated in PHP 5.5.0, and it was removed in PHP 7.0.0. Instead, the MySQLi or PDO_MySQL extension should be used. See also MySQL: choosing an API guide and related FAQ for more information. Alternatives to this function include:

  • mysqli_data_seek()
  • PDO::FETCH_ORI_ABS

Açıklama

bool mysql_data_seek ( resource $result , int $row_number )

mysql_data_seek() moves the internal row pointer of the MySQL result associated with the specified result identifier to point to the specified row number. The next call to a MySQL fetch function, such as mysql_fetch_assoc(), would return that row.

row_number starts at 0. The row_number should be a value in the range from 0 to mysql_num_rows() - 1. However if the result set is empty (mysql_num_rows() == 0), a seek to 0 will fail with a E_WARNING and mysql_data_seek() will return FALSE.

Değiştirgeler

sonuç

resource türünde sorgu sonucu. Bu sonuç bir mysql_query() çağrısının sonucudur.

row_number

The desired row number of the new result pointer.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 mysql_data_seek() example

<?php
$link = mysql_connect('localhost', 'mysql_user', 'mysql_password');
if (!$link) {
    die('Could not connect: ' . mysql_error());
}
$db_selected = mysql_select_db('sample_db');
if (!$db_selected) {
    die('Could not select database: ' . mysql_error());
}
$query = 'SELECT last_name, first_name FROM friends';
$result = mysql_query($query);
if (!$result) {
    die('Query failed: ' . mysql_error());
}
/* fetch rows in reverse order */
for ($i = mysql_num_rows($result) - 1; $i >= 0; $i--) {
    if (!mysql_data_seek($result, $i)) {
        echo "Cannot seek to row $i: " . mysql_error() . "\n";
        continue;
    }

    if (!($row = mysql_fetch_assoc($result))) {
        continue;
    }

    echo $row['last_name'] . ' ' . $row['first_name'] . "<br />\n";
}

mysql_free_result($result);
?>

Notlar

Bilginize:

The function mysql_data_seek() can be used in conjunction only with mysql_query(), not with mysql_unbuffered_query().

Ayrıca Bakınız

  • mysql_query() - Send a MySQL query
  • mysql_num_rows() - Sonuçtaki satır sayısını al
  • mysql_fetch_row() - Get a result row as an enumerated array
  • mysql_fetch_assoc() - Fetch a result row as an associative array
  • mysql_fetch_array() - Fetch a result row as an associative array, a numeric array, or both
  • mysql_fetch_object() - Fetch a result row as an object

mysql_create_db
mysql_db_name
MySQL İşlevleri


Sonuç verisini al

mysql_data_seek
mysql_db_query
MySQL İşlevleri
PHP Manual

mysql_db_name

(PHP 4, PHP 5)

mysql_db_name — Sonuç verisini al

Açıklama

string mysql_db_name ( resource $sonuç , int $satır [, mixed $alan ] )

Bir mysql_list_dbs() çağrısından veritabanı adını alır.

Değiştirgeler

sonuç

Bir mysql_list_dbs() çağrısının sonuç göstericisi.

satır

Sonuç kümesine indis.

alan

Alan adı.

Dönen Değerler

Başarı durumunda veritabanı adını, hata durumunda FALSE döndürür. Eğer FALSE döndürüldüyse, hatanın mahiyetini anlamak için mysql_error() işlevini kullanın.

Örnekler

Örnek 1 - mysql_db_name() örneği

<?php
error_reporting(E_ALL);

$link = mysql_connect('dbhost', 'kullanıcı', 'parola');
$db_list = mysql_list_dbs($link);

$i = 0;
$bgl = mysql_num_rows($db_list);
while ($i < $bgl) {
    echo mysql_db_name($db_list, $i) . "\n";
    $i++;
}
?>

Notlar

Bilginize:

Geriye uyumluluk adına, kullanımı önerilmese de şu takma adı kullanabilirsiniz: mysql_dbname()

Ayrıca Bakınız

  • mysql_list_dbs() - Bir MySQL sunucusundaki kullanılabilir veritabanlarını listeler
  • mysql_tablename() - Alanın tablo adını al

mysql_data_seek
mysql_db_query
MySQL İşlevleri


Bir MySQL sorgusu gönderir

mysql_db_name
mysql_drop_db
MySQL İşlevleri
PHP Manual

mysql_db_query

(PHP 4, PHP 5)

mysql_db_query — Bir MySQL sorgusu gönderir

Açıklama

resource mysql_db_query ( string $veritabanı , string $sorgu [, resource $bağlantı_belirteci ] )

mysql_db_query() bir veritabanı seçip üzerinde bir sorgu çalıştırır.

Uyarı

Bu işlevin kullanımı PHP 5.3.0'dan beri ÖNERİLMEMEKTEDİR ve PHP 6.0.0'da tamamen KALDIRILMIŞTIR. Bu işleve kesinlikle güvenmemelisiniz.

Değiştirgeler

veritabanı

Seçilecek veritabanının adı.

sorgu

MySQL sorgusu.

Sorgunun içindeki verinin gerektiği gibi öncelenmesi gerekir.

bağlantı_belirteci

MySQL bağlantısı. Eğer bağlantı belirteci belirtilmemişse mysql_connect() tarafından açılan son bağlantı kullanılmaya çalışılır. Eğer böyle bir bağlantı yoksa mysql_connect() değiştirgesiz olarak çağrılmış gibi bir bağlantı oluşturmaya çalışır. Hiçbir bağlantı yoksa ve yenisi de kurulamazsa E_WARNING seviyesinde bir hata üretilir.

Dönen Değerler

Başarı durumunda sorgu sonucuna olumlu bir MySQL sonuç göstericisi, hata durumunda FALSE döndürür. Bu işlev INSERT/UPDATE/DELETE sorgularında da başarı/hata durumunu bildirmek için TRUE/FALSE döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | Bu işlev artık bir E_DEPRECATED uyarısı vermektedir.
4.0.6 | Bu işlevin kullanımı artık önerilmemektedir, bu işlevi kullanmayın. Bunun yerine, mysql_select_db() ve mysql_query() kullanın.

Örnekler

Örnek 1 - mysql_db_query() yerine kullanılabilecek kod örneği

<?php

if (!$link = mysql_connect('mysql_host', 'mysql_user', 'mysql_password')) {
    echo 'mysql\'e bağlanamadı';
    exit;
}

if (!mysql_select_db('mysql_dbname', $link)) {
    echo 'Veritabanını seçemedi';
    exit;
}

$sql    = 'SELECT foo FROM bar WHERE id = 42';
$result = mysql_query($sql, $link);

if (!$result) {
    echo "Veritabanı hatası, veritabanını sorgulayamıyor\n";
    echo 'MySQL Hatası: ' . mysql_error();
    exit;
}

while ($row = mysql_fetch_assoc($result)) {
    echo $row['foo'];
}

mysql_free_result($result);

?>

Notlar

Bilginize:

Bu işlevin daha önce bağlandığınız veritabanına kendiliğinden geri DÖNMEDİĞİNE dikkat ediniz. Başka bir deyişle, bu işlevi başka bir veritabanında geçici olarak bir sql sorgusu çalıştırmak için kullanamazsınız, önceki veritabanına kendiniz dönmeniz gerekir. Kullanıcıların sorgularında veritabanı.tablo sözdizimini veya bu işlev yerine mysql_select_db() işlevini kullanmaları şiddetle tavsiye edilir.

Ayrıca Bakınız

  • mysql_query() - Send a MySQL query
  • mysql_select_db() - Bir MySQL veritabanı seçer

mysql_db_name
mysql_drop_db
MySQL İşlevleri


Drop (delete) a MySQL database

mysql_db_query
mysql_errno
MySQL İşlevleri
PHP Manual

mysql_drop_db

(PHP 4, PHP 5)

mysql_drop_db — Drop (delete) a MySQL database

Uyarı

This function was deprecated in PHP 4.3.0, and it and the entire original MySQL extension was removed in PHP 7.0.0. Instead, use either the actively developed MySQLi or PDO_MySQL extensions. See also the MySQL: choosing an API guide and its related FAQ entry for additional information. Alternatives to this function include:

  • Execute a DROP DATABASE query

Açıklama

bool mysql_drop_db ( string $database_name [, resource $link_identifier = NULL ] )

mysql_drop_db() attempts to drop (remove) an entire database from the server associated with the specified link identifier. This function is deprecated, it is preferable to use mysql_query() to issue an sql DROP DATABASE statement instead.

Değiştirgeler

database_name

The name of the database that will be deleted.

bağlantı_belirteci

MySQL bağlantısı. Eğer bağlantı belirteci belirtilmemişse mysql_connect() tarafından açılan son bağlantı kullanılmaya çalışılır. Eğer böyle bir bağlantı yoksa mysql_connect() değiştirgesiz olarak çağrılmış gibi bir bağlantı oluşturmaya çalışır. Hiçbir bağlantı yoksa ve yenisi de kurulamazsa E_WARNING seviyesinde bir hata üretilir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 mysql_drop_db() alternative example

<?php
$link = mysql_connect('localhost', 'mysql_user', 'mysql_password');
if (!$link) {
    die('Could not connect: ' . mysql_error());
}

$sql = 'DROP DATABASE my_db';
if (mysql_query($sql, $link)) {
    echo "Database my_db was successfully dropped\n";
} else {
    echo 'Error dropping database: ' . mysql_error() . "\n";
}
?>

Notlar

Uyarı

This function will not be available if the MySQL extension was built against a MySQL 4.x client library.

Bilginize:

Geriye uyumluluk adına, kullanımı önerilmese de şu takma adı kullanabilirsiniz: mysql_dropdb()

Ayrıca Bakınız

  • mysql_query() - Send a MySQL query

mysql_db_query
mysql_errno
MySQL İşlevleri


Returns the numerical value of the error message from previous MySQL operation

mysql_drop_db
mysql_error
MySQL İşlevleri
PHP Manual

mysql_errno

(PHP 4, PHP 5)

mysql_errno — Returns the numerical value of the error message from previous MySQL operation

Uyarı

This extension was deprecated in PHP 5.5.0, and it was removed in PHP 7.0.0. Instead, the MySQLi or PDO_MySQL extension should be used. See also MySQL: choosing an API guide and related FAQ for more information. Alternatives to this function include:

  • mysqli_errno()
  • PDO::errorCode()

Açıklama

int mysql_errno ([ resource $link_identifier = NULL ] )

Returns the error number from the last MySQL function.

Errors coming back from the MySQL database backend no longer issue warnings. Instead, use mysql_errno() to retrieve the error code. Note that this function only returns the error code from the most recently executed MySQL function (not including mysql_error() and mysql_errno()), so if you want to use it, make sure you check the value before calling another MySQL function.

Değiştirgeler

bağlantı_belirteci

MySQL bağlantısı. Eğer bağlantı belirteci belirtilmemişse mysql_connect() tarafından açılan son bağlantı kullanılmaya çalışılır. Eğer böyle bir bağlantı yoksa mysql_connect() değiştirgesiz olarak çağrılmış gibi bir bağlantı oluşturmaya çalışır. Hiçbir bağlantı yoksa ve yenisi de kurulamazsa E_WARNING seviyesinde bir hata üretilir.

Dönen Değerler

Returns the error number from the last MySQL function, or 0 (zero) if no error occurred.

Örnekler

Örnek 1 mysql_errno() example

<?php
$link = mysql_connect("localhost", "mysql_user", "mysql_password");

if (!mysql_select_db("nonexistentdb", $link)) {
    echo mysql_errno($link) . ": " . mysql_error($link). "\n";
}

mysql_select_db("kossu", $link);
if (!mysql_query("SELECT * FROM nonexistenttable", $link)) {
    echo mysql_errno($link) . ": " . mysql_error($link) . "\n";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

1049: Unknown database 'nonexistentdb'
1146: Table 'kossu.nonexistenttable' doesn't exist

Ayrıca Bakınız

  • mysql_error() - Returns the text of the error message from previous MySQL operation
  • » MySQL error codes

mysql_drop_db
mysql_error
MySQL İşlevleri


Returns the text of the error message from previous MySQL operation

mysql_errno
mysql_escape_string
MySQL İşlevleri
PHP Manual

mysql_error

(PHP 4, PHP 5)

mysql_error — Returns the text of the error message from previous MySQL operation

Uyarı

This extension was deprecated in PHP 5.5.0, and it was removed in PHP 7.0.0. Instead, the MySQLi or PDO_MySQL extension should be used. See also MySQL: choosing an API guide and related FAQ for more information. Alternatives to this function include:

  • mysqli_error()
  • PDO::errorInfo()

Açıklama

string mysql_error ([ resource $link_identifier = NULL ] )

Returns the error text from the last MySQL function. Errors coming back from the MySQL database backend no longer issue warnings. Instead, use mysql_error() to retrieve the error text. Note that this function only returns the error text from the most recently executed MySQL function (not including mysql_error() and mysql_errno()), so if you want to use it, make sure you check the value before calling another MySQL function.

Değiştirgeler

bağlantı_belirteci

MySQL bağlantısı. Eğer bağlantı belirteci belirtilmemişse mysql_connect() tarafından açılan son bağlantı kullanılmaya çalışılır. Eğer böyle bir bağlantı yoksa mysql_connect() değiştirgesiz olarak çağrılmış gibi bir bağlantı oluşturmaya çalışır. Hiçbir bağlantı yoksa ve yenisi de kurulamazsa E_WARNING seviyesinde bir hata üretilir.

Dönen Değerler

Returns the error text from the last MySQL function, or '' (empty string) if no error occurred.

Örnekler

Örnek 1 mysql_error() example

<?php
$link = mysql_connect("localhost", "mysql_user", "mysql_password");

mysql_select_db("nonexistentdb", $link);
echo mysql_errno($link) . ": " . mysql_error($link). "\n";

mysql_select_db("kossu", $link);
mysql_query("SELECT * FROM nonexistenttable", $link);
echo mysql_errno($link) . ": " . mysql_error($link) . "\n";
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

1049: Unknown database 'nonexistentdb'
1146: Table 'kossu.nonexistenttable' doesn't exist

Ayrıca Bakınız

  • mysql_errno() - Returns the numerical value of the error message from previous MySQL operation
  • » MySQL error codes

mysql_errno
mysql_escape_string
MySQL İşlevleri


Escapes a string for use in a mysql_query

mysql_error
mysql_fetch_array
MySQL İşlevleri
PHP Manual

mysql_escape_string

(PHP 4 >= 4.0.3, PHP 5)

mysql_escape_string — Escapes a string for use in a mysql_query

Uyarı

This function was deprecated in PHP 4.3.0, and it and the entire original MySQL extension was removed in PHP 7.0.0. Instead, use either the actively developed MySQLi or PDO_MySQL extensions. See also the MySQL: choosing an API guide and its related FAQ entry for additional information. Alternatives to this function include:

  • mysqli_escape_string()
  • PDO::quote()

Açıklama

string mysql_escape_string ( string $unescaped_string )

This function will escape the unescaped_string, so that it is safe to place it in a mysql_query(). This function is deprecated.

This function is identical to mysql_real_escape_string() except that mysql_real_escape_string() takes a connection handler and escapes the string according to the current character set. mysql_escape_string() does not take a connection argument and does not respect the current charset setting.

Değiştirgeler

unescaped_string

The string that is to be escaped.

Dönen Değerler

Returns the escaped string.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | This function now throws an E_DEPRECATED notice.
4.3.0 | This function became deprecated, do not use this function. Instead, use mysql_real_escape_string().

Örnekler

Örnek 1 mysql_escape_string() example

<?php
$item = "Zak's Laptop";
$escaped_item = mysql_escape_string($item);
printf("Escaped string: %s\n", $escaped_item);
?>

Yukarıdaki örneğin çıktısı:

Escaped string: Zak\'s Laptop

Notlar

Bilginize:

mysql_escape_string() does not escape % and _.

Ayrıca Bakınız

  • mysql_real_escape_string() - Escapes special characters in a string for use in an SQL statement
  • addslashes() - Özel karakterlerin önüne tersbölü yerleştirir
  • The magic_quotes_gpc directive.

mysql_error
mysql_fetch_array
MySQL İşlevleri


Fetch a result row as an associative array, a numeric array, or both

mysql_escape_string
mysql_fetch_assoc
MySQL İşlevleri
PHP Manual

mysql_fetch_array

(PHP 4, PHP 5)

mysql_fetch_array — Fetch a result row as an associative array, a numeric array, or both

Uyarı

This extension was deprecated in PHP 5.5.0, and it was removed in PHP 7.0.0. Instead, the MySQLi or PDO_MySQL extension should be used. See also MySQL: choosing an API guide and related FAQ for more information. Alternatives to this function include:

  • mysqli_fetch_array()
  • PDOStatement::fetch()

Açıklama

array mysql_fetch_array ( resource $result [, int $result_type = MYSQL_BOTH ] )

Returns an array that corresponds to the fetched row and moves the internal data pointer ahead.

Değiştirgeler

sonuç

resource türünde sorgu sonucu. Bu sonuç bir mysql_query() çağrısının sonucudur.

result_type

The type of array that is to be fetched. It's a constant and can take the following values: MYSQL_ASSOC, MYSQL_NUM, and MYSQL_BOTH.

Dönen Değerler

Returns an array of strings that corresponds to the fetched row, or FALSE if there are no more rows. The type of returned array depends on how result_type is defined. By using MYSQL_BOTH (default), you'll get an array with both associative and number indices. Using MYSQL_ASSOC, you only get associative indices (as mysql_fetch_assoc() works), using MYSQL_NUM, you only get number indices (as mysql_fetch_row() works).

If two or more columns of the result have the same field names, the last column will take precedence. To access the other column(s) of the same name, you must use the numeric index of the column or make an alias for the column. For aliased columns, you cannot access the contents with the original column name.

Örnekler

Örnek 1 Query with aliased duplicate field names

SELECT table1.field AS foo, table2.field AS bar FROM table1, table2

Örnek 2 mysql_fetch_array() with MYSQL_NUM

<?php
mysql_connect("localhost", "mysql_user", "mysql_password") or
    die("Could not connect: " . mysql_error());
mysql_select_db("mydb");

$result = mysql_query("SELECT id, name FROM mytable");

while ($row = mysql_fetch_array($result, MYSQL_NUM)) {
    printf("ID: %s  Name: %s", $row[0], $row[1]);
}

mysql_free_result($result);
?>

Örnek 3 mysql_fetch_array() with MYSQL_ASSOC

<?php
mysql_connect("localhost", "mysql_user", "mysql_password") or
    die("Could not connect: " . mysql_error());
mysql_select_db("mydb");

$result = mysql_query("SELECT id, name FROM mytable");

while ($row = mysql_fetch_array($result, MYSQL_ASSOC)) {
    printf("ID: %s  Name: %s", $row["id"], $row["name"]);
}

mysql_free_result($result);
?>

Örnek 4 mysql_fetch_array() with MYSQL_BOTH

<?php
mysql_connect("localhost", "mysql_user", "mysql_password") or
    die("Could not connect: " . mysql_error());
mysql_select_db("mydb");

$result = mysql_query("SELECT id, name FROM mytable");

while ($row = mysql_fetch_array($result, MYSQL_BOTH)) {
    printf ("ID: %s  Name: %s", $row[0], $row["name"]);
}

mysql_free_result($result);
?>

Notlar

Bilginize: Performance

An important thing to note is that using mysql_fetch_array() is not significantly slower than using mysql_fetch_row(), while it provides a significant added value.

Bilginize: Bu işlevden dönen alan isimlerinin harf büyüklüklerinde değişiklik yapılmaz.

Bilginize: Bu işlev NULL alanlara PHP NULL değerini atar.

Ayrıca Bakınız

  • mysql_fetch_row() - Get a result row as an enumerated array
  • mysql_fetch_assoc() - Fetch a result row as an associative array
  • mysql_data_seek() - Move internal result pointer
  • mysql_query() - Send a MySQL query

mysql_escape_string
mysql_fetch_assoc
MySQL İşlevleri


Fetch a result row as an associative array

mysql_fetch_array
mysql_fetch_field
MySQL İşlevleri
PHP Manual

mysql_fetch_assoc

(PHP 4 >= 4.0.3, PHP 5)

mysql_fetch_assoc — Fetch a result row as an associative array

Uyarı

This extension was deprecated in PHP 5.5.0, and it was removed in PHP 7.0.0. Instead, the MySQLi or PDO_MySQL extension should be used. See also MySQL: choosing an API guide and related FAQ for more information. Alternatives to this function include:

  • mysqli_fetch_assoc()
  • PDOStatement::fetch(PDO::FETCH_ASSOC)

Açıklama

array mysql_fetch_assoc ( resource $result )

Returns an associative array that corresponds to the fetched row and moves the internal data pointer ahead. mysql_fetch_assoc() is equivalent to calling mysql_fetch_array() with MYSQL_ASSOC for the optional second parameter. It only returns an associative array.

Değiştirgeler

sonuç

resource türünde sorgu sonucu. Bu sonuç bir mysql_query() çağrısının sonucudur.

Dönen Değerler

Returns an associative array of strings that corresponds to the fetched row, or FALSE if there are no more rows.

If two or more columns of the result have the same field names, the last column will take precedence. To access the other column(s) of the same name, you either need to access the result with numeric indices by using mysql_fetch_row() or add alias names. See the example at the mysql_fetch_array() description about aliases.

Örnekler

Örnek 1 An expanded mysql_fetch_assoc() example

<?php

$conn = mysql_connect("localhost", "mysql_user", "mysql_password");

if (!$conn) {
    echo "Unable to connect to DB: " . mysql_error();
    exit;
}

if (!mysql_select_db("mydbname")) {
    echo "Unable to select mydbname: " . mysql_error();
    exit;
}

$sql = "SELECT id as userid, fullname, userstatus
        FROM   sometable
        WHERE  userstatus = 1";

$result = mysql_query($sql);

if (!$result) {
    echo "Could not successfully run query ($sql) from DB: " . mysql_error();
    exit;
}

if (mysql_num_rows($result) == 0) {
    echo "No rows found, nothing to print so am exiting";
    exit;
}

// While a row of data exists, put that row in $row as an associative array
// Note: If you're expecting just one row, no need to use a loop
// Note: If you put extract($row); inside the following loop, you'll
//       then create $userid, $fullname, and $userstatus
while ($row = mysql_fetch_assoc($result)) {
    echo $row["userid"];
    echo $row["fullname"];
    echo $row["userstatus"];
}

mysql_free_result($result);

?>

Notlar

Bilginize: Performance

An important thing to note is that using mysql_fetch_assoc() is not significantly slower than using mysql_fetch_row(), while it provides a significant added value.

Bilginize: Bu işlevden dönen alan isimlerinin harf büyüklüklerinde değişiklik yapılmaz.

Bilginize: Bu işlev NULL alanlara PHP NULL değerini atar.

Ayrıca Bakınız

  • mysql_fetch_row() - Get a result row as an enumerated array
  • mysql_fetch_array() - Fetch a result row as an associative array, a numeric array, or both
  • mysql_data_seek() - Move internal result pointer
  • mysql_query() - Send a MySQL query
  • mysql_error() - Returns the text of the error message from previous MySQL operation

mysql_fetch_array
mysql_fetch_field
MySQL İşlevleri


Get column information from a result and return as an object

mysql_fetch_assoc
mysql_fetch_lengths
MySQL İşlevleri
PHP Manual

mysql_fetch_field

(PHP 4, PHP 5)

mysql_fetch_field — Get column information from a result and return as an object

Uyarı

This extension was deprecated in PHP 5.5.0, and it was removed in PHP 7.0.0. Instead, the MySQLi or PDO_MySQL extension should be used. See also MySQL: choosing an API guide and related FAQ for more information. Alternatives to this function include:

  • mysqli_fetch_field()
  • PDOStatement::getColumnMeta()

Açıklama

object mysql_fetch_field ( resource $result [, int $field_offset = 0 ] )

Returns an object containing field information. This function can be used to obtain information about fields in the provided query result.

Değiştirgeler

sonuç

resource türünde sorgu sonucu. Bu sonuç bir mysql_query() çağrısının sonucudur.

field_offset

The numerical field offset. If the field offset is not specified, the next field that was not yet retrieved by this function is retrieved. The field_offset starts at 0.

Dönen Değerler

Returns an object containing field information. The properties of the object are:

  • name - column name
  • table - name of the table the column belongs to, which is the alias name if one is defined
  • max_length - maximum length of the column
  • not_null - 1 if the column cannot be NULL
  • primary_key - 1 if the column is a primary key
  • unique_key - 1 if the column is a unique key
  • multiple_key - 1 if the column is a non-unique key
  • numeric - 1 if the column is numeric
  • blob - 1 if the column is a BLOB
  • type - the type of the column
  • unsigned - 1 if the column is unsigned
  • zerofill - 1 if the column is zero-filled

Örnekler

Örnek 1 mysql_fetch_field() example

<?php
$conn = mysql_connect('localhost', 'mysql_user', 'mysql_password');
if (!$conn) {
    die('Could not connect: ' . mysql_error());
}
mysql_select_db('database');
$result = mysql_query('select * from table');
if (!$result) {
    die('Query failed: ' . mysql_error());
}
/* get column metadata */
$i = 0;
while ($i < mysql_num_fields($result)) {
    echo "Information for column $i:<br />\n";
    $meta = mysql_fetch_field($result, $i);
    if (!$meta) {
        echo "No information available<br />\n";
    }
    echo "<pre>
blob:         $meta->blob
max_length:   $meta->max_length
multiple_key: $meta->multiple_key
name:         $meta->name
not_null:     $meta->not_null
numeric:      $meta->numeric
primary_key:  $meta->primary_key
table:        $meta->table
type:         $meta->type
unique_key:   $meta->unique_key
unsigned:     $meta->unsigned
zerofill:     $meta->zerofill
</pre>";
    $i++;
}
mysql_free_result($result);
?>

Notlar

Bilginize: Bu işlevden dönen alan isimlerinin harf büyüklüklerinde değişiklik yapılmaz.

Bilginize:

If field or tablenames are aliased in the SQL query the aliased name will be returned. The original name can be retrieved for instance by using mysqli_result::fetch_field().

Ayrıca Bakınız

  • mysql_field_seek() - Sonuç göstericisini belirtilen alan konumuna ayarla

mysql_fetch_assoc
mysql_fetch_lengths
MySQL İşlevleri


Bir sonuçtaki her bir çıktının uzunluğunu al

mysql_fetch_field
mysql_fetch_object
MySQL İşlevleri
PHP Manual

mysql_fetch_lengths

(PHP 4, PHP 5)

mysql_fetch_lengths — Bir sonuçtaki her bir çıktının uzunluğunu al

Açıklama

array mysql_fetch_lengths ( resource $sonuç )

MySQL'den çekilen son satırdaki alanların uzunluklarını içeren bir dizi döndürür.

mysql_fetch_lengths() işlevi,
mysql_fetch_row(),
mysql_fetch_assoc(),
mysql_fetch_array() ve
mysql_fetch_object() tarafından döndürülen son satırdaki
her bir sonuç sütununun uzunluğunu ilk elemanının indisi 0 olan bir dizide
döndürür.

Değiştirgeler

sonuç

resource türünde sorgu sonucu. Bu sonuç bir mysql_query() çağrısının sonucudur.

Dönen Değerler

Başarı durumunda bir uzunluklar dizisi, hata durumunda FALSE döndürür.

Örnekler

Örnek 1 - mysql_fetch_lengths() örneği

<?php
$result = mysql_query("SELECT id,email FROM people WHERE id = '42'");
if (!$result) {
    echo 'Sorgu çalıştırılamadı: ' . mysql_error();
    exit;
}
$row     = mysql_fetch_assoc($result);
$lengths = mysql_fetch_lengths($result);

print_r($row);
print_r($lengths);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [id] => 42
    [email] => user@example.com
)
Array
(
    [0] => 2
    [1] => 16
)

Ayrıca Bakınız

  • mysql_field_len() - Belirtilen alanın uzunluğunu döndürür
  • mysql_fetch_row() - Get a result row as an enumerated array
  • strlen() - Dizge uzunluğunu döndürür

mysql_fetch_field
mysql_fetch_object
MySQL İşlevleri


Fetch a result row as an object

mysql_fetch_lengths
mysql_fetch_row
MySQL İşlevleri
PHP Manual

mysql_fetch_object

(PHP 4, PHP 5)

mysql_fetch_object — Fetch a result row as an object

Uyarı

This extension was deprecated in PHP 5.5.0, and it was removed in PHP 7.0.0. Instead, the MySQLi or PDO_MySQL extension should be used. See also MySQL: choosing an API guide and related FAQ for more information. Alternatives to this function include:

  • mysqli_fetch_object()
  • PDOStatement::fetch(PDO::FETCH_OBJ)

Açıklama

object mysql_fetch_object ( resource $result [, string $class_name [, array $params ]] )

Returns an object with properties that correspond to the fetched row and moves the internal data pointer ahead.

Değiştirgeler

sonuç

resource türünde sorgu sonucu. Bu sonuç bir mysql_query() çağrısının sonucudur.

class_name

The name of the class to instantiate, set the properties of and return. If not specified, a stdClass object is returned.

params

An optional array of parameters to pass to the constructor for class_name objects.

Dönen Değerler

Returns an object with string properties that correspond to the fetched row, or FALSE if there are no more rows.

Örnekler

Örnek 1 mysql_fetch_object() example

<?php
mysql_connect("hostname", "user", "password");
mysql_select_db("mydb");
$result = mysql_query("select * from mytable");
while ($row = mysql_fetch_object($result)) {
    echo $row->user_id;
    echo $row->fullname;
}
mysql_free_result($result);
?>

Örnek 2 mysql_fetch_object() example

<?php
class foo {
    public $name;
}

mysql_connect("hostname", "user", "password");
mysql_select_db("mydb");

$result = mysql_query("select name from mytable limit 1");
$obj = mysql_fetch_object($result, 'foo');
var_dump($obj);
?>

Notlar

Bilginize: Performance

Speed-wise, the function is identical to mysql_fetch_array(), and almost as quick as mysql_fetch_row() (the difference is insignificant).

Bilginize:

mysql_fetch_object() is similar to mysql_fetch_array(), with one difference - an object is returned, instead of an array. Indirectly, that means that you can only access the data by the field names, and not by their offsets (numbers are illegal property names).

Bilginize: Bu işlevden dönen alan isimlerinin harf büyüklüklerinde değişiklik yapılmaz.

Bilginize: Bu işlev NULL alanlara PHP NULL değerini atar.

Ayrıca Bakınız

  • mysql_fetch_array() - Fetch a result row as an associative array, a numeric array, or both
  • mysql_fetch_assoc() - Fetch a result row as an associative array
  • mysql_fetch_row() - Get a result row as an enumerated array
  • mysql_data_seek() - Move internal result pointer
  • mysql_query() - Send a MySQL query

mysql_fetch_lengths
mysql_fetch_row
MySQL İşlevleri


Get a result row as an enumerated array

mysql_fetch_object
mysql_field_flags
MySQL İşlevleri
PHP Manual

mysql_fetch_row

(PHP 4, PHP 5)

mysql_fetch_row — Get a result row as an enumerated array

Uyarı

This extension was deprecated in PHP 5.5.0, and it was removed in PHP 7.0.0. Instead, the MySQLi or PDO_MySQL extension should be used. See also MySQL: choosing an API guide and related FAQ for more information. Alternatives to this function include:

  • mysqli_fetch_row()
  • PDOStatement::fetch(PDO::FETCH_NUM)

Açıklama

array mysql_fetch_row ( resource $result )

Returns a numerical array that corresponds to the fetched row and moves the internal data pointer ahead.

Değiştirgeler

sonuç

resource türünde sorgu sonucu. Bu sonuç bir mysql_query() çağrısının sonucudur.

Dönen Değerler

Returns an numerical array of strings that corresponds to the fetched row, or FALSE if there are no more rows.

mysql_fetch_row() fetches one row of data from the result associated with the specified result identifier. The row is returned as an array. Each result column is stored in an array offset, starting at offset 0.

Örnekler

Örnek 1 Fetching one row with mysql_fetch_row()

<?php
$result = mysql_query("SELECT id,email FROM people WHERE id = '42'");
if (!$result) {
    echo 'Could not run query: ' . mysql_error();
    exit;
}
$row = mysql_fetch_row($result);

echo $row[0]; // 42
echo $row[1]; // the email value
?>

Notlar

Bilginize: Bu işlev NULL alanlara PHP NULL değerini atar.

Ayrıca Bakınız

  • mysql_fetch_array() - Fetch a result row as an associative array, a numeric array, or both
  • mysql_fetch_assoc() - Fetch a result row as an associative array
  • mysql_fetch_object() - Fetch a result row as an object
  • mysql_data_seek() - Move internal result pointer
  • mysql_fetch_lengths() - Bir sonuçtaki her bir çıktının uzunluğunu al
  • mysql_result() - Get result data

mysql_fetch_object
mysql_field_flags
MySQL İşlevleri


Get the flags associated with the specified field in a result

mysql_fetch_row
mysql_field_len
MySQL İşlevleri
PHP Manual

mysql_field_flags

(PHP 4, PHP 5)

mysql_field_flags — Get the flags associated with the specified field in a result

Uyarı

This extension was deprecated in PHP 5.5.0, and it was removed in PHP 7.0.0. Instead, the MySQLi or PDO_MySQL extension should be used. See also MySQL: choosing an API guide and related FAQ for more information. Alternatives to this function include:

  • mysqli_fetch_field_direct() [flags]
  • PDOStatement::getColumnMeta() [flags]

Açıklama

string mysql_field_flags ( resource $result , int $field_offset )

mysql_field_flags() returns the field flags of the specified field. The flags are reported as a single word per flag separated by a single space, so that you can split the returned value using explode().

Değiştirgeler

sonuç

resource türünde sorgu sonucu. Bu sonuç bir mysql_query() çağrısının sonucudur.

alan_konumu

Alanın sayısal konumu. 0'dan başlar. Eğer bir alan konumu yoksa E_WARNING seviyesinde bir hata üretilir.

Dönen Değerler

Returns a string of flags associated with the result başarısızlık durumunda FALSE döner.

The following flags are reported, if your version of MySQL is current enough to support them: "not_null", "primary_key", "unique_key", "multiple_key", "blob", "unsigned", "zerofill", "binary", "enum", "auto_increment" and "timestamp".

Örnekler

Örnek 1 A mysql_field_flags() example

<?php
$result = mysql_query("SELECT id,email FROM people WHERE id = '42'");
if (!$result) {
    echo 'Could not run query: ' . mysql_error();
    exit;
}
$flags = mysql_field_flags($result, 0);

echo $flags;
print_r(explode(' ', $flags));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

not_null primary_key auto_increment
Array
(
    [0] => not_null
    [1] => primary_key
    [2] => auto_increment
)

Notlar

Bilginize:

Geriye uyumluluk adına, kullanımı önerilmese de şu takma adı kullanabilirsiniz: mysql_fieldflags()

Ayrıca Bakınız

  • mysql_field_type() - Get the type of the specified field in a result
  • mysql_field_len() - Belirtilen alanın uzunluğunu döndürür

mysql_fetch_row
mysql_field_len
MySQL İşlevleri


Belirtilen alanın uzunluğunu döndürür

mysql_field_flags
mysql_field_name
MySQL İşlevleri
PHP Manual

mysql_field_len

(PHP 4, PHP 5)

mysql_field_len — Belirtilen alanın uzunluğunu döndürür

Açıklama

int mysql_field_len ( resource $result , int $alan_konumu )

mysql_field_len() işlevi, belirtilen alanın uzunluğunu döndürür.

Değiştirgeler

sonuç

resource türünde sorgu sonucu. Bu sonuç bir mysql_query() çağrısının sonucudur.

alan_konumu

Alanın sayısal konumu. 0'dan başlar. Eğer bir alan konumu yoksa E_WARNING seviyesinde bir hata üretilir.

Dönen Değerler

Başarı durumunda indisi belirtilen alanın uzunluğu, hata durumunda FALSE döndürür.

Örnekler

Örnek 1 - mysql_field_len() örneği

<?php
$result = mysql_query("SELECT id,email FROM people WHERE id = '42'");
if (!$result) {
    echo 'Sorgu çalıştırılamadı: ' . mysql_error();
    exit;
}

// id alanının veritabanı yapısında belirtilen uzunluğu
$uzunluk = mysql_field_len($result, 0);
echo $uzunluk;
?>

Notlar

Bilginize:

Geriye uyumluluk adına, kullanımı önerilmese de şu takma adı kullanabilirsiniz: mysql_fieldlen()

Ayrıca Bakınız

  • mysql_fetch_lengths() - Bir sonuçtaki her bir çıktının uzunluğunu al
  • strlen() - Dizge uzunluğunu döndürür

mysql_field_flags
mysql_field_name
MySQL İşlevleri


Get the name of the specified field in a result

mysql_field_len
mysql_field_seek
MySQL İşlevleri
PHP Manual

mysql_field_name

(PHP 4, PHP 5)

mysql_field_name — Get the name of the specified field in a result

Uyarı

This extension was deprecated in PHP 5.5.0, and it was removed in PHP 7.0.0. Instead, the MySQLi or PDO_MySQL extension should be used. See also MySQL: choosing an API guide and related FAQ for more information. Alternatives to this function include:

  • mysqli_fetch_field_direct() [name] or [orgname]
  • PDOStatement::getColumnMeta() [name]

Açıklama

string mysql_field_name ( resource $result , int $field_offset )

mysql_field_name() returns the name of the specified field index.

Değiştirgeler

sonuç

resource türünde sorgu sonucu. Bu sonuç bir mysql_query() çağrısının sonucudur.

alan_konumu

Alanın sayısal konumu. 0'dan başlar. Eğer bir alan konumu yoksa E_WARNING seviyesinde bir hata üretilir.

Dönen Değerler

The name of the specified field index on success başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 mysql_field_name() example

<?php
/* The users table consists of three fields:
 *   user_id
 *   username
 *   password.
 */
$link = mysql_connect('localhost', 'mysql_user', 'mysql_password');
if (!$link) {
    die('Could not connect to MySQL server: ' . mysql_error());
}
$dbname = 'mydb';
$db_selected = mysql_select_db($dbname, $link);
if (!$db_selected) {
    die("Could not set $dbname: " . mysql_error());
}
$res = mysql_query('select * from users', $link);

echo mysql_field_name($res, 0) . "\n";
echo mysql_field_name($res, 2);
?>

Yukarıdaki örneğin çıktısı:

user_id
password

Notlar

Bilginize: Bu işlevden dönen alan isimlerinin harf büyüklüklerinde değişiklik yapılmaz.

Bilginize:

Geriye uyumluluk adına, kullanımı önerilmese de şu takma adı kullanabilirsiniz: mysql_fieldname()

Ayrıca Bakınız

  • mysql_field_type() - Get the type of the specified field in a result
  • mysql_field_len() - Belirtilen alanın uzunluğunu döndürür

mysql_field_len
mysql_field_seek
MySQL İşlevleri


Sonuç göstericisini belirtilen alan konumuna ayarla

mysql_field_name
mysql_field_table
MySQL İşlevleri
PHP Manual

mysql_field_seek

(PHP 4, PHP 5)

mysql_field_seek — Sonuç göstericisini belirtilen alan konumuna ayarla

Açıklama

bool mysql_field_seek ( resource $sonuç , int $alan_konumu )

Belirtilen göreli alan konumuna gider. Eğer mysql_fetch_field() işlevinin sonraki çağrısı göreli bir alan konumu içermiyorsa, mysql_field_seek() işlevinde belirtilen göreli alan konumu döndürülür.

Değiştirgeler

sonuç

resource türünde sorgu sonucu. Bu sonuç bir mysql_query() çağrısının sonucudur.

alan_konumu

Alanın sayısal konumu. 0'dan başlar. Eğer bir alan konumu yoksa E_WARNING seviyesinde bir hata üretilir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • mysql_fetch_field() - Get column information from a result and return as an object

mysql_field_name
mysql_field_table
MySQL İşlevleri


Belirtilen alanı içeren tablonun adını al

mysql_field_seek
mysql_field_type
MySQL İşlevleri
PHP Manual

mysql_field_table

(PHP 4, PHP 5)

mysql_field_table — Belirtilen alanı içeren tablonun adını al

Açıklama

string mysql_field_table ( resource $sonuç , int $alan_konumu )

Belirtilen alanı içeren tablonun adını döndürür.

Değiştirgeler

sonuç

resource türünde sorgu sonucu. Bu sonuç bir mysql_query() çağrısının sonucudur.

alan_konumu

Alanın sayısal konumu. 0'dan başlar. Eğer bir alan konumu yoksa E_WARNING seviyesinde bir hata üretilir.

Dönen Değerler

Başarı durumunda tablonun adı.

Örnekler

Örnek 1 - mysql_field_table() örneği

<?php

$sorgu = "SELECT account.*, country.* FROM account, country " .
         "WHERE country.name = 'Portugal' AND account.country_id = country.id";

// Veritabanından sonucu al
$sonuc = mysql_query($sorgu);

// Önce tablo adını sonra alan adını listele
for ($i = 0; $i < mysql_num_fields($sonuc); ++$i) {
    $tablo = mysql_field_table($sonuc, $i);
    $alan = mysql_field_name($sonuc, $i);

    echo  "$tablo: $alan\n";
}

?>

Notlar

Bilginize:

Geriye uyumluluk adına, kullanımı önerilmese de şu takma adı kullanabilirsiniz: mysql_fieldtable()

Ayrıca Bakınız

  • mysql_list_tables() - Bir MySQL veritabanındaki tabloları listele

mysql_field_seek
mysql_field_type
MySQL İşlevleri


Get the type of the specified field in a result

mysql_field_table
mysql_free_result
MySQL İşlevleri
PHP Manual

mysql_field_type

(PHP 4, PHP 5)

mysql_field_type — Get the type of the specified field in a result

Uyarı

This extension was deprecated in PHP 5.5.0, and it was removed in PHP 7.0.0. Instead, the MySQLi or PDO_MySQL extension should be used. See also MySQL: choosing an API guide and related FAQ for more information. Alternatives to this function include:

  • mysqli_fetch_field_direct() [type]
  • PDOStatement::getColumnMeta() [driver:decl_type] or [pdo_type]

Açıklama

string mysql_field_type ( resource $result , int $field_offset )

mysql_field_type() is similar to the mysql_field_name() function. The arguments are identical, but the field type is returned instead.

Değiştirgeler

sonuç

resource türünde sorgu sonucu. Bu sonuç bir mysql_query() çağrısının sonucudur.

alan_konumu

Alanın sayısal konumu. 0'dan başlar. Eğer bir alan konumu yoksa E_WARNING seviyesinde bir hata üretilir.

Dönen Değerler

The returned field type will be one of "int", "real", "string", "blob", and others as detailed in the » MySQL documentation.

Örnekler

Örnek 1 mysql_field_type() example

<?php
mysql_connect("localhost", "mysql_username", "mysql_password");
mysql_select_db("mysql");
$result = mysql_query("SELECT * FROM func");
$fields = mysql_num_fields($result);
$rows   = mysql_num_rows($result);
$table  = mysql_field_table($result, 0);
echo "Your '" . $table . "' table has " . $fields . " fields and " . $rows . " record(s)\n";
echo "The table has the following fields:\n";
for ($i=0; $i < $fields; $i++) {
    $type  = mysql_field_type($result, $i);
    $name  = mysql_field_name($result, $i);
    $len   = mysql_field_len($result, $i);
    $flags = mysql_field_flags($result, $i);
    echo $type . " " . $name . " " . $len . " " . $flags . "\n";
}
mysql_free_result($result);
mysql_close();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Your 'func' table has 4 fields and 1 record(s)
The table has the following fields:
string name 64 not_null primary_key binary
int ret 1 not_null
string dl 128 not_null
string type 9 not_null enum

Notlar

Bilginize:

Geriye uyumluluk adına, kullanımı önerilmese de şu takma adı kullanabilirsiniz: mysql_fieldtype()

Ayrıca Bakınız

  • mysql_field_name() - Get the name of the specified field in a result
  • mysql_field_len() - Belirtilen alanın uzunluğunu döndürür

mysql_field_table
mysql_free_result
MySQL İşlevleri


Sonuç belleğini serbest bırakır

mysql_field_type
mysql_get_client_info
MySQL İşlevleri
PHP Manual

mysql_free_result

(PHP 4, PHP 5)

mysql_free_result — Sonuç belleğini serbest bırakır

Açıklama

bool mysql_free_result ( resource $sonuç )

mysql_free_result() işlevi, sonuç sonuç göstericisine ayrılan belleği serbest bırakır.

mysql_free_result()'ın sadece büyük sonuç kümeleri döndüren sorgularda kullanılan bellek miktarını önemsiyorsanız kullanılması gerekmektedir. Sonuç belleği, betiğin çalışması sona erdiğinde özdevinimli olarak serbest bırakılır.

Değiştirgeler

sonuç

resource türünde sorgu sonucu. Bu sonuç bir mysql_query() çağrısının sonucudur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Eğer belirtilen sonuç değiştirgesi resource türünde değilse, E_WARNING seviyesinde bir hata oluşacaktır. mysql_query() işlevinin SELECT, SHOW, EXPLAIN ve DESCRIBE sorguları için resource türünde tek bir sonuç döndürdüğünü bilmenizde yarar var.

Örnekler

Örnek 1 - mysql_free_result() örneği

<?php
$sonuç = mysql_query("SELECT id,email FROM people WHERE id = '42'");
if (!$sonuç) {
    echo 'Sorgu çalıştırılamadı: ' . mysql_error();
    exit;
}
/* Sonucu kullandıktan sonra onunla işimizin bittiğini varsayıyoruz */
$row = mysql_fetch_assoc($sonuç);

/* Şimdi sonucu serbest bırakıyoruz ve betiğimize devam ediyoruz */
mysql_free_result($sonuç);

echo $row['id'];
echo $row['email'];
?>

Notlar

Bilginize:

Geriye uyumluluk adına, kullanımı önerilmese de şu takma adı kullanabilirsiniz: mysql_freeresult()

Ayrıca Bakınız

  • mysql_query() - Send a MySQL query
  • is_resource() - Değişken resource türünde mi diye bakar

mysql_field_type
mysql_get_client_info
MySQL İşlevleri


MySQL istemci sürüm bilgisini al

mysql_free_result
mysql_get_host_info
MySQL İşlevleri
PHP Manual

mysql_get_client_info

(PHP 4 >= 4.0.5, PHP 5)

mysql_get_client_info — MySQL istemci sürüm bilgisini al

Açıklama

string mysql_get_client_info ( void )

mysql_get_client_info() istemci kütüphane sürümünü bildiren bir dizge döndürür.

Dönen Değerler

MySQL istemci sürümü.

Örnekler

Örnek 1 - mysql_get_client_info() örneği

<?php
printf("MySQL istemci sürümü: %s\n", mysql_get_client_info());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

MySQL istemci sürümü: 3.23.39

Ayrıca Bakınız

  • mysql_get_host_info() - MySQL konak bilgisini al
  • mysql_get_proto_info() - MySQL protokol sürüm bilgisini al
  • mysql_get_server_info() - MySQL sunucu bilgisini al

mysql_free_result
mysql_get_host_info
MySQL İşlevleri


MySQL konak bilgisini al

mysql_get_client_info
mysql_get_proto_info
MySQL İşlevleri
PHP Manual

mysql_get_host_info

(PHP 4 >= 4.0.5, PHP 5)

mysql_get_host_info — MySQL konak bilgisini al

Açıklama

string mysql_get_host_info ([ resource $bağlantı_belirteci ] )

Bağlantı için kullanılmakta olan bağlantının türünü ve sunucunun konak adını döndürür.

Değiştirgeler

bağlantı_belirteci

MySQL bağlantısı. Eğer bağlantı belirteci belirtilmemişse mysql_connect() tarafından açılan son bağlantı kullanılmaya çalışılır. Eğer böyle bir bağlantı yoksa mysql_connect() değiştirgesiz olarak çağrılmış gibi bir bağlantı oluşturmaya çalışır. Hiçbir bağlantı yoksa ve yenisi de kurulamazsa E_WARNING seviyesinde bir hata üretilir.

Dönen Değerler

Başarı durumunda bağlantı için kullanılmakta olan MySQL bağlantısının türünü içeren bir dizge, hata durumunda FALSE döndürür.

Örnekler

Örnek 1 - mysql_get_host_info() örneği

<?php
$link = mysql_connect('localhost', 'mysql_user', 'mysql_parolası');
if (!$link) {
    die('Bağlanamadı: ' . mysql_error());
}
printf("MySQL konak bilgisi: %s\n", mysql_get_host_info());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

MySQL konak bilgisi: Localhost via UNIX socket

Ayrıca Bakınız

  • mysql_get_client_info() - MySQL istemci sürüm bilgisini al
  • mysql_get_proto_info() - MySQL protokol sürüm bilgisini al
  • mysql_get_server_info() - MySQL sunucu bilgisini al

mysql_get_client_info
mysql_get_proto_info
MySQL İşlevleri


MySQL protokol sürüm bilgisini al

mysql_get_host_info
mysql_get_server_info
MySQL İşlevleri
PHP Manual

mysql_get_proto_info

(PHP 4 >= 4.0.5, PHP 5)

mysql_get_proto_info — MySQL protokol sürüm bilgisini al

Açıklama

int mysql_get_proto_info ([ resource $bağlantı_belirteci ] )

MySQL protokol sürümünü döndürür.

Değiştirgeler

bağlantı_belirteci

MySQL bağlantısı. Eğer bağlantı belirteci belirtilmemişse mysql_connect() tarafından açılan son bağlantı kullanılmaya çalışılır. Eğer böyle bir bağlantı yoksa mysql_connect() değiştirgesiz olarak çağrılmış gibi bir bağlantı oluşturmaya çalışır. Hiçbir bağlantı yoksa ve yenisi de kurulamazsa E_WARNING seviyesinde bir hata üretilir.

Dönen Değerler

Başarı durumunda MySQL protokol sürümünü, hata durumunda FALSE döndürür.

Örnekler

Örnek 1 - mysql_get_proto_info() örneği

<?php
$link = mysql_connect('localhost', 'mysql_user', 'mysql_parolası');
if (!$link) {
    die('Bağlanamadı: ' . mysql_error());
}
printf("MySQL protokol sürümü: %s\n", mysql_get_proto_info());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

MySQL protokol sürümü: 10

Ayrıca Bakınız

  • mysql_get_client_info() - MySQL istemci sürüm bilgisini al
  • mysql_get_host_info() - MySQL konak bilgisini al
  • mysql_get_server_info() - MySQL sunucu bilgisini al

mysql_get_host_info
mysql_get_server_info
MySQL İşlevleri


MySQL sunucu bilgisini al

mysql_get_proto_info
mysql_info
MySQL İşlevleri
PHP Manual

mysql_get_server_info

(PHP 4 >= 4.0.5, PHP 5)

mysql_get_server_info — MySQL sunucu bilgisini al

Açıklama

string mysql_get_server_info ([ resource $bağlantı_belirteci ] )

MySQL sunucu sürümünü döndürür.

Değiştirgeler

bağlantı_belirteci

MySQL bağlantısı. Eğer bağlantı belirteci belirtilmemişse mysql_connect() tarafından açılan son bağlantı kullanılmaya çalışılır. Eğer böyle bir bağlantı yoksa mysql_connect() değiştirgesiz olarak çağrılmış gibi bir bağlantı oluşturmaya çalışır. Hiçbir bağlantı yoksa ve yenisi de kurulamazsa E_WARNING seviyesinde bir hata üretilir.

Dönen Değerler

Başarı durumunda MySQL sunucu sürümünü, hata durumunda FALSE döndürür.

Örnekler

Örnek 1 - mysql_get_server_info() örneği

<?php
$link = mysql_connect('localhost', 'mysql_user', 'mysql_parolası');
if (!$link) {
    die('Bağlanamadı: ' . mysql_error());
}
printf("MySQL sunucu sürümü: %s\n", mysql_get_server_info());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

MySQL sunucu sürümü: 4.0.1-alpha

Ayrıca Bakınız

  • mysql_get_client_info() - MySQL istemci sürüm bilgisini al
  • mysql_get_host_info() - MySQL konak bilgisini al
  • mysql_get_proto_info() - MySQL protokol sürüm bilgisini al
  • phpversion() - Çalışan PHP'nin sürümünü döndürür

mysql_get_proto_info
mysql_info
MySQL İşlevleri


En son sorgu hakkında bilgi al

mysql_get_server_info
mysql_insert_id
MySQL İşlevleri
PHP Manual

mysql_info

(PHP 4 >= 4.3.0, PHP 5)

mysql_info — En son sorgu hakkında bilgi al

Açıklama

string mysql_info ([ resource $bağlantı_belirteci ] )

Son sorgu hakkında ayrıntılı bilgi döndürür.

Değiştirgeler

bağlantı_belirteci

MySQL bağlantısı. Eğer bağlantı belirteci belirtilmemişse mysql_connect() tarafından açılan son bağlantı kullanılmaya çalışılır. Eğer böyle bir bağlantı yoksa mysql_connect() değiştirgesiz olarak çağrılmış gibi bir bağlantı oluşturmaya çalışır. Hiçbir bağlantı yoksa ve yenisi de kurulamazsa E_WARNING seviyesinde bir hata üretilir.

Dönen Değerler

Başarı durumunda ifade ile ilgili bilgi, hata durumunda FALSE döndürür. Hangi deyimlerin ne değer döndürdüğünü görmek için aşağıdaki örneğe bakın. Burada listelenmemiş deyimler FALSE döndürecektir.

Örnekler

Örnek 1 - İlgili MySQL Deyimleri

Dizge döndüren deyimler. Sayılar sadece betimleme amaçlıdır; yani, değerleri sorguya göre olacaktır.

INSERT INTO ... SELECT ...
String format: Records: 23 Duplicates: 0 Warnings: 0
INSERT INTO ... VALUES (...),(...),(...)...
String format: Records: 37 Duplicates: 0 Warnings: 0
LOAD DATA INFILE ...
String format: Records: 42 Deleted: 0 Skipped: 0 Warnings: 0
ALTER TABLE
String format: Records: 60 Duplicates: 0 Warnings: 0
UPDATE
String format: Rows matched: 65 Changed: 65 Warnings: 0

Notlar

Bilginize:

mysql_info() işlevi, INSERT ... VALUES deyimi için sadece ve sadece deyimde birden fazla değer listesi belirtildiği takdirde FALSE dışında bir değer döndürecektir.

Ayrıca Bakınız

  • mysql_affected_rows() - Önceki MySQL işleminde etkilenen satırların sayısını al
  • mysql_insert_id() - Get the ID generated in the last query
  • mysql_stat() - Geçerli sunucu durumunu döndürür

mysql_get_server_info
mysql_insert_id
MySQL İşlevleri


Get the ID generated in the last query

mysql_info
mysql_list_dbs
MySQL İşlevleri
PHP Manual

mysql_insert_id

(PHP 4, PHP 5)

mysql_insert_id — Get the ID generated in the last query

Uyarı

This extension was deprecated in PHP 5.5.0, and it was removed in PHP 7.0.0. Instead, the MySQLi or PDO_MySQL extension should be used. See also MySQL: choosing an API guide and related FAQ for more information. Alternatives to this function include:

  • mysqli_insert_id()
  • PDO::lastInsertId()

Açıklama

int mysql_insert_id ([ resource $link_identifier = NULL ] )

Retrieves the ID generated for an AUTO_INCREMENT column by the previous query (usually INSERT).

Değiştirgeler

bağlantı_belirteci

MySQL bağlantısı. Eğer bağlantı belirteci belirtilmemişse mysql_connect() tarafından açılan son bağlantı kullanılmaya çalışılır. Eğer böyle bir bağlantı yoksa mysql_connect() değiştirgesiz olarak çağrılmış gibi bir bağlantı oluşturmaya çalışır. Hiçbir bağlantı yoksa ve yenisi de kurulamazsa E_WARNING seviyesinde bir hata üretilir.

Dönen Değerler

The ID generated for an AUTO_INCREMENT column by the previous query on success, 0 if the previous query does not generate an AUTO_INCREMENT value, or FALSE if no MySQL connection was established.

Örnekler

Örnek 1 mysql_insert_id() example

<?php
$link = mysql_connect('localhost', 'mysql_user', 'mysql_password');
if (!$link) {
    die('Could not connect: ' . mysql_error());
}
mysql_select_db('mydb');

mysql_query("INSERT INTO mytable (product) values ('kossu')");
printf("Last inserted record has id %d\n", mysql_insert_id());
?>

Notlar

Dikkat

mysql_insert_id() will convert the return type of the native MySQL C API function mysql_insert_id() to a type of long (named int in PHP). If your AUTO_INCREMENT column has a column type of BIGINT (64 bits) the conversion may result in an incorrect value. Instead, use the internal MySQL SQL function LAST_INSERT_ID() in an SQL query. For more information about PHP's maximum integer values, please see the integer documentation.

Bilginize:

Because mysql_insert_id() acts on the last performed query, be sure to call mysql_insert_id() immediately after the query that generates the value.

Bilginize:

The value of the MySQL SQL function LAST_INSERT_ID() always contains the most recently generated AUTO_INCREMENT value, and is not reset between queries.

Ayrıca Bakınız

  • mysql_query() - Send a MySQL query
  • mysql_info() - En son sorgu hakkında bilgi al

mysql_info
mysql_list_dbs
MySQL İşlevleri


Bir MySQL sunucusundaki kullanılabilir veritabanlarını listeler

mysql_insert_id
mysql_list_fields
MySQL İşlevleri
PHP Manual

mysql_list_dbs

(PHP 4, PHP 5)

mysql_list_dbs — Bir MySQL sunucusundaki kullanılabilir veritabanlarını listeler

Açıklama

resource mysql_list_dbs ([ resource $bağlantı_belirteci ] )

MySQL sunucusundaki kullanılabilir veritabanlarını içeren bir sonuç göstericisi döndürür.

Değiştirgeler

bağlantı_belirteci

MySQL bağlantısı. Eğer bağlantı belirteci belirtilmemişse mysql_connect() tarafından açılan son bağlantı kullanılmaya çalışılır. Eğer böyle bir bağlantı yoksa mysql_connect() değiştirgesiz olarak çağrılmış gibi bir bağlantı oluşturmaya çalışır. Hiçbir bağlantı yoksa ve yenisi de kurulamazsa E_WARNING seviyesinde bir hata üretilir.

Dönen Değerler

Başarı durumunda resource türünde bir sonuç göstericisi, hata durumunda FALSE döndürür. Bu sonuç göstericisinin veya mysql_fetch_array() gibi sonuç tabloları üreten bir işlevden elde edilen işlevselliğin tersini elde etmek için mysql_tablename() işlevini kullanın.

Örnekler

Örnek 1 - mysql_list_dbs() örneği

<?php
$link = mysql_connect('localhost', 'mysql_user', 'mysql_parolası');
$db_list = mysql_list_dbs($link);

while ($row = mysql_fetch_object($db_list)) {
     echo $row->Database . "\n";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

database1
database2
database3

Notlar

Bilginize:

Geriye uyumluluk adına, kullanımı önerilmese de şu takma adı kullanabilirsiniz: mysql_listdbs()

Ayrıca Bakınız

  • mysql_db_name() - Sonuç verisini al
  • mysql_select_db() - Bir MySQL veritabanı seçer

mysql_insert_id
mysql_list_fields
MySQL İşlevleri


MySQL tablosunun alanlarını listeler

mysql_list_dbs
mysql_list_processes
MySQL İşlevleri
PHP Manual

mysql_list_fields

(PHP 4, PHP 5)

mysql_list_fields — MySQL tablosunun alanlarını listeler

Açıklama

resource mysql_list_fields ( string $veritabanı_adı , string $tablo_adı [, resource $bağlantı_belirteci ] )

Verilen tablo hakkındaki bilgileri alır.

Bu işlevin kullanımı önerilmemektedir. Bunun yerine, SHOW COLUMNS FROM table [LIKE 'ad'] şeklinde bir ifade çalıştırmak için mysql_query() işlevini kullanmak tercih edilebilir.

Değiştirgeler

veritabanı_adı

Sorgulanan veritabanının adı.

tablo_adı

Sorgulanan tablonun adı.

bağlantı_belirteci

MySQL bağlantısı. Eğer bağlantı belirteci belirtilmemişse mysql_connect() tarafından açılan son bağlantı kullanılmaya çalışılır. Eğer böyle bir bağlantı yoksa mysql_connect() değiştirgesiz olarak çağrılmış gibi bir bağlantı oluşturmaya çalışır. Hiçbir bağlantı yoksa ve yenisi de kurulamazsa E_WARNING seviyesinde bir hata üretilir.

Dönen Değerler

Başarı durumunda resource türünde bir sonuç göstericisi, hata durumunda FALSE döndürür.

Döndürülen sonuç  mysql_field_flags(),
mysql_field_len(),
mysql_field_name()  ve
mysql_field_type() ile kullanılabilir.

Örnekler

Örnek 1 - mysql_list_fields() yerine kullanılabilecek kod örneği

<?php
$sonuç = mysql_query("SHOW COLUMNS FROM birtablo");
if (!$sonuç) {
    echo 'Sorguyu çalıştıramadı: ' . mysql_error();
    exit;
}
if (mysql_num_rows($sonuç) > 0) {
    while ($satır = mysql_fetch_assoc($sonuç)) {
        print_r($satır);
    }
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [Field] => id
    [Type] => int(7)
    [Null] =>
    [Key] => PRI
    [Default] =>
    [Extra] => auto_increment
)
Array
(
    [Field] => email
    [Type] => varchar(100)
    [Null] =>
    [Key] =>
    [Default] =>
    [Extra] =>
)

Notlar

Bilginize:

Geriye uyumluluk adına, kullanımı önerilmese de şu takma adı kullanabilirsiniz: mysql_listfields()

Ayrıca Bakınız

  • mysql_field_flags() - Get the flags associated with the specified field in a result
  • mysql_info() - En son sorgu hakkında bilgi al

mysql_list_dbs
mysql_list_processes
MySQL İşlevleri


MySQL süreçlerini listeler

mysql_list_fields
mysql_list_tables
MySQL İşlevleri
PHP Manual

mysql_list_processes

(PHP 4 >= 4.3.0, PHP 5)

mysql_list_processes — MySQL süreçlerini listeler

Açıklama

resource mysql_list_processes ([ resource $bağlantı_belirteci ] )

Geçerli MySQL sunucu evrelerini alır.

Değiştirgeler

bağlantı_belirteci

MySQL bağlantısı. Eğer bağlantı belirteci belirtilmemişse mysql_connect() tarafından açılan son bağlantı kullanılmaya çalışılır. Eğer böyle bir bağlantı yoksa mysql_connect() değiştirgesiz olarak çağrılmış gibi bir bağlantı oluşturmaya çalışır. Hiçbir bağlantı yoksa ve yenisi de kurulamazsa E_WARNING seviyesinde bir hata üretilir.

Dönen Değerler

Başarı durumunda resource türünde bir sonuç göstericisi, hata durumunda FALSE döner.

Örnekler

Örnek 1 - mysql_list_processes() örneği

<?php
$link = mysql_connect('localhost', 'mysql_user', 'mysql_parolası');

$result = mysql_list_processes($link);
while ($row = mysql_fetch_assoc($result)){
    printf("%s %s %s %s %s\n", $row["Id"], $row["Host"], $row["db"],
        $row["Command"], $row["Time"]);
}
mysql_free_result($result);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

1 localhost test Processlist 0
4 localhost mysql sleep 5

Ayrıca Bakınız

  • mysql_thread_id() - Geçerli evre numarasını döndür
  • mysql_stat() - Geçerli sunucu durumunu döndürür

mysql_list_fields
mysql_list_tables
MySQL İşlevleri


Bir MySQL veritabanındaki tabloları listele

mysql_list_processes
mysql_num_fields
MySQL İşlevleri
PHP Manual

mysql_list_tables

(PHP 4, PHP 5)

mysql_list_tables — Bir MySQL veritabanındaki tabloları listele

Açıklama

resource mysql_list_tables ( string $veritabanı [, resource $bağlantı_belirteci ] )

Bir MySQL veritabanından tabloların listesini alır.

Bu işlevin kullanımı önerilmemektedir. Bunun yerine, SHOW TABLES [FROM db_adı] [LIKE 'şablon'] gibi bir SQL sorgusu çalıştırmak için mysql_query() işlevinin kullanımı tercih edilebilir.

Değiştirgeler

veritabanı

Veritabanının adı.

bağlantı_belirteci

MySQL bağlantısı. Eğer bağlantı belirteci belirtilmemişse mysql_connect() tarafından açılan son bağlantı kullanılmaya çalışılır. Eğer böyle bir bağlantı yoksa mysql_connect() değiştirgesiz olarak çağrılmış gibi bir bağlantı oluşturmaya çalışır. Hiçbir bağlantı yoksa ve yenisi de kurulamazsa E_WARNING seviyesinde bir hata üretilir.

Dönen Değerler

Başarı durumunda resource türünde bir sonuç göstericisi, hata durumunda FALSE döndürür.

Bu sonuç göstericisinin veya mysql_fetch_array() gibi sonuç tabloları üreten bir işlevden elde edilen işlevselliğin tersini elde etmek için mysql_tablename() işlevini kullanın.

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.7 | Bu işlevin kullanımı artık önerilmiyor.

Örnekler

Örnek 1 - mysql_list_tables() yerine kullanılabilecek kod örneği

<?php
$dbname = 'mysql_dbname';

if (!mysql_connect('mysql_host', 'mysql_user', 'mysql_password')) {
    echo 'mysql\'e bağlanılamadı';
    exit;
}

$sql = "SHOW TABLES FROM $dbname";
$result = mysql_query($sql);

if (!$result) {
    echo "Veritabanı hatası, tablolar listelenemedi\n";
    echo 'MySQL Hatası: ' . mysql_error();
    exit;
}

while ($row = mysql_fetch_row($result)) {
    echo "Tablo: {$row[0]}\n";
}

mysql_free_result($result);
?>

Notlar

Bilginize:

Geriye uyumluluk adına, kullanımı önerilmese de şu takma adı kullanabilirsiniz: mysql_listtables()

Ayrıca Bakınız

  • mysql_list_dbs() - Bir MySQL sunucusundaki kullanılabilir veritabanlarını listeler
  • mysql_tablename() - Alanın tablo adını al

mysql_list_processes
mysql_num_fields
MySQL İşlevleri


Sonuçtaki alan sayısını al

mysql_list_tables
mysql_num_rows
MySQL İşlevleri
PHP Manual

mysql_num_fields

(PHP 4, PHP 5)

mysql_num_fields — Sonuçtaki alan sayısını al

Açıklama

int mysql_num_fields ( resource $sonuç )

Bir sorgunun döndürdüğü alanların sayısını alır.

Değiştirgeler

sonuç

resource türünde sorgu sonucu. Bu sonuç bir mysql_query() çağrısının sonucudur.

Dönen Değerler

Başarı durumunda resource türündeki sonuç kümesinde bulunan alanların sayısını, hata durumunda FALSE döndürür.

Örnekler

Örnek 1 - mysql_num_fields() örneği

<?php
$result = mysql_query("SELECT id,email FROM people WHERE id = '42'");
if (!$result) {
    echo 'Sorgu çalıştırılamadı: ' . mysql_error();
    exit;
}

/* 2 döndürür, çünkü id,email === iki alan */
echo mysql_num_fields($result);
?>

Notlar

Bilginize:

Geriye uyumluluk adına, kullanımı önerilmese de şu takma adı kullanabilirsiniz: mysql_numfields()

Ayrıca Bakınız

  • mysql_select_db() - Bir MySQL veritabanı seçer
  • mysql_query() - Send a MySQL query
  • mysql_fetch_field() - Get column information from a result and return as an object
  • mysql_num_rows() - Sonuçtaki satır sayısını al

mysql_list_tables
mysql_num_rows
MySQL İşlevleri


Sonuçtaki satır sayısını al

mysql_num_fields
mysql_pconnect
MySQL İşlevleri
PHP Manual

mysql_num_rows

(PHP 4, PHP 5)

mysql_num_rows — Sonuçtaki satır sayısını al

Açıklama

int mysql_num_rows ( resource $sonuç )

Bir sonuç kümesinden satırların sayısını alır. Bu komut sadece SELECT veya SHOW gibi gerçek bir sonuç kümesi döndüren ifadeler için geçerlidir. INSERT, UPDATE, REPLACE veya DELETE sorgusundan etkilenen satırların sayısını almak için mysql_affected_rows() işlevini kullanın.

Değiştirgeler

sonuç

resource türünde sorgu sonucu. Bu sonuç bir mysql_query() çağrısının sonucudur.

Dönen Değerler

Başarı durumunda sonuç kümesindeki satırların sayısını, hata durumunda FALSE döndürür.

Örnekler

Örnek 1 - mysql_num_rows() örneği

<?php

$link = mysql_connect("localhost", "mysql_user", "mysql_password");
mysql_select_db("database", $link);

$result = mysql_query("SELECT * FROM table1", $link);
$num_rows = mysql_num_rows($result);

echo "$num_rows Satır\n";

?>

Notlar

Bilginize:

mysql_unbuffered_query() işlevini kullanırsanız, mysql_num_rows() sonuç kümesindeki bütün satırlar alınana kadar gerçek değeri döndürmez.

Bilginize:

Geriye uyumluluk adına, kullanımı önerilmese de şu takma adı kullanabilirsiniz: mysql_numrows()

Ayrıca Bakınız

  • mysql_affected_rows() - Önceki MySQL işleminde etkilenen satırların sayısını al
  • mysql_connect() - MySQL Sunucusuna bir bağlantı açar
  • mysql_data_seek() - Move internal result pointer
  • mysql_select_db() - Bir MySQL veritabanı seçer
  • mysql_query() - Send a MySQL query

mysql_num_fields
mysql_pconnect
MySQL İşlevleri


Open a persistent connection to a MySQL server

mysql_num_rows
mysql_ping
MySQL İşlevleri
PHP Manual

mysql_pconnect

(PHP 4, PHP 5)

mysql_pconnect — Open a persistent connection to a MySQL server

Uyarı

This extension was deprecated in PHP 5.5.0, and it was removed in PHP 7.0.0. Instead, the MySQLi or PDO_MySQL extension should be used. See also MySQL: choosing an API guide and related FAQ for more information. Alternatives to this function include:

  • mysqli_connect() with p: host prefix
  • PDO::__construct() with PDO::ATTR_PERSISTENT as a driver option

Açıklama

resource mysql_pconnect ([ string $server = ini_get("mysql.default_host") [, string $username = ini_get("mysql.default_user") [, string $password = ini_get("mysql.default_password") [, int $client_flags = 0 ]]]] )

Establishes a persistent connection to a MySQL server.

mysql_pconnect() acts very much like mysql_connect() with two major differences.

First, when connecting, the function would first try to find a (persistent) link that's already open with the same host, username and password. If one is found, an identifier for it will be returned instead of opening a new connection.

Second, the connection to the SQL server will not be closed when the execution of the script ends. Instead, the link will remain open for future use (mysql_close() will not close links established by mysql_pconnect()).

This type of link is therefore called 'persistent'.

Değiştirgeler

server

The MySQL server. It can also include a port number. e.g. "hostname:port" or a path to a local socket e.g. ":/path/to/socket" for the localhost.

If the PHP directive mysql.default_host is undefined (default), then the default value is 'localhost:3306'

username

The username. Default value is the name of the user that owns the server process.

password

The password. Default value is an empty password.

client_flags

The client_flags parameter can be a combination of the following constants: 128 (enable LOAD DATA LOCAL handling), MYSQL_CLIENT_SSL, MYSQL_CLIENT_COMPRESS, MYSQL_CLIENT_IGNORE_SPACE or MYSQL_CLIENT_INTERACTIVE.

Dönen Değerler

Returns a MySQL persistent link identifier on success, or FALSE on failure.

Sürüm Bilgisi

Sürüm: | Açıklama
5.5.0 | This function will generate an E_DEPRECATED error.

Notlar

Bilginize:

Note, that these kind of links only work if you are using a module version of PHP. See the Persistent Database Connections section for more information.

Uyarı

Using persistent connections can require a bit of tuning of your Apache and MySQL configurations to ensure that you do not exceed the number of connections allowed by MySQL.

Bilginize:

You can suppress the error message on failure by prepending a @ to the function name.

Ayrıca Bakınız

  • mysql_connect() - MySQL Sunucusuna bir bağlantı açar
  • Persistent Database Connections

mysql_num_rows
mysql_ping
MySQL İşlevleri


Bir sunucu bağlantısına ping at, bağlantı yoksa tekrar bağlan

mysql_pconnect
mysql_query
MySQL İşlevleri
PHP Manual

mysql_ping

(PHP 4 >= 4.3.0, PHP 5)

mysql_ping — Bir sunucu bağlantısına ping at, bağlantı yoksa tekrar bağlan

Açıklama

bool mysql_ping ([ resource $bağlantı_belirteci ] )

Sunucuyla bağlantının çalışıp çalışmadığına bakar. Eğer bağlantı kesilmişse, özdevinimli olarak yeniden bağlanmaya çalışır. Bu işlev, uzun süre boş kalan betikler tarafından, sunucunun bağlantıyı kapatıp kapatmadığını denetlemek ve eğer kapattıysa tekrar bağlanmak için kullanılabilir.

Bilginize:

MySQL 5.0.13'ten itibaren özdevinimli olarak yeniden bağlanma özelliği devre dışı bırakılmıştır.

Değiştirgeler

bağlantı_belirteci

MySQL bağlantısı. Eğer bağlantı belirteci belirtilmemişse mysql_connect() tarafından açılan son bağlantı kullanılmaya çalışılır. Eğer böyle bir bağlantı yoksa mysql_connect() değiştirgesiz olarak çağrılmış gibi bir bağlantı oluşturmaya çalışır. Hiçbir bağlantı yoksa ve yenisi de kurulamazsa E_WARNING seviyesinde bir hata üretilir.

Dönen Değerler

MySQL sunucusuyla bağlantı çalışıyorsa TRUE, çalışmıyorsa FALSE döndürür.

Örnekler

Örnek 1 - mysql_ping() örneği

<?php
set_time_limit(0);

$conn = mysql_connect('localhost', 'mysqluser', 'mypass');
$db   = mysql_select_db('mydb');

/* Bu sorgunun uzun süre alacağını varsayarak */
$result = mysql_query($sql);
if (!$result) {
    echo 'Sorgu #1 çalışmadı, çıkıyor.';
    exit;
}

/* Bağlantının hala canlı olduğundan emin ol, değilse tekrar bağlan */
if (!mysql_ping($conn)) {
    echo 'Bağlantı kayboldu, sorgu #1\'den sonra çıkıyor';
    exit;
}
mysql_free_result($result);

/* Bağlantı hala canlı olduğuna göre, başka bir sorgu çalıştıralım */
$result2 = mysql_query($sql2);
?>

Ayrıca Bakınız

  • mysql_thread_id() - Geçerli evre numarasını döndür
  • mysql_list_processes() - MySQL süreçlerini listeler

mysql_pconnect
mysql_query
MySQL İşlevleri


Send a MySQL query

mysql_ping
mysql_real_escape_string
MySQL İşlevleri
PHP Manual

mysql_query

(PHP 4, PHP 5)

mysql_query — Send a MySQL query

Uyarı

This extension was deprecated in PHP 5.5.0, and it was removed in PHP 7.0.0. Instead, the MySQLi or PDO_MySQL extension should be used. See also MySQL: choosing an API guide and related FAQ for more information. Alternatives to this function include:

  • mysqli_query()
  • PDO::query()

Açıklama

mixed mysql_query ( string $query [, resource $link_identifier = NULL ] )

mysql_query() sends a unique query (multiple queries are not supported) to the currently active database on the server that's associated with the specified link_identifier.

Değiştirgeler

query

An SQL query

The query string should not end with a semicolon. Data inside the query should be properly escaped.

bağlantı_belirteci

MySQL bağlantısı. Eğer bağlantı belirteci belirtilmemişse mysql_connect() tarafından açılan son bağlantı kullanılmaya çalışılır. Eğer böyle bir bağlantı yoksa mysql_connect() değiştirgesiz olarak çağrılmış gibi bir bağlantı oluşturmaya çalışır. Hiçbir bağlantı yoksa ve yenisi de kurulamazsa E_WARNING seviyesinde bir hata üretilir.

Dönen Değerler

For SELECT, SHOW, DESCRIBE, EXPLAIN and other statements returning resultset, mysql_query() returns a resource on success, or FALSE on error.

For other type of SQL statements, INSERT, UPDATE, DELETE, DROP, etc, mysql_query() returns TRUE on success or FALSE on error.

The returned result resource should be passed to mysql_fetch_array(), and other functions for dealing with result tables, to access the returned data.

Use mysql_num_rows() to find out how many rows were returned for a SELECT statement or mysql_affected_rows() to find out how many rows were affected by a DELETE, INSERT, REPLACE, or UPDATE statement.

mysql_query() will also fail and return FALSE if the user does not have permission to access the table(s) referenced by the query.

Örnekler

Örnek 1 Invalid Query

The following query is syntactically invalid, so mysql_query() fails and returns FALSE.

<?php
$result = mysql_query('SELECT * WHERE 1=1');
if (!$result) {
    die('Invalid query: ' . mysql_error());
}

?>

Örnek 2 Valid Query

The following query is valid, so mysql_query() returns a resource.

<?php
// This could be supplied by a user, for example
$firstname = 'fred';
$lastname  = 'fox';

// Formulate Query
// This is the best way to perform an SQL query
// For more examples, see mysql_real_escape_string()
$query = sprintf("SELECT firstname, lastname, address, age FROM friends
    WHERE firstname='%s' AND lastname='%s'",
    mysql_real_escape_string($firstname),
    mysql_real_escape_string($lastname));

// Perform Query
$result = mysql_query($query);

// Check result
// This shows the actual query sent to MySQL, and the error. Useful for debugging.
if (!$result) {
    $message  = 'Invalid query: ' . mysql_error() . "\n";
    $message .= 'Whole query: ' . $query;
    die($message);
}

// Use result
// Attempting to print $result won't allow access to information in the resource
// One of the mysql result functions must be used
// See also mysql_result(), mysql_fetch_array(), mysql_fetch_row(), etc.
while ($row = mysql_fetch_assoc($result)) {
    echo $row['firstname'];
    echo $row['lastname'];
    echo $row['address'];
    echo $row['age'];
}

// Free the resources associated with the result set
// This is done automatically at the end of the script
mysql_free_result($result);
?>

Ayrıca Bakınız

  • mysql_connect() - MySQL Sunucusuna bir bağlantı açar
  • mysql_error() - Returns the text of the error message from previous MySQL operation
  • mysql_real_escape_string() - Escapes special characters in a string for use in an SQL statement
  • mysql_result() - Get result data
  • mysql_fetch_assoc() - Fetch a result row as an associative array
  • mysql_unbuffered_query() - Sonuç kümesi tamponlanmayan ve alınmayan bir SQL sorgusu gönderir

mysql_ping
mysql_real_escape_string
MySQL İşlevleri


Escapes special characters in a string for use in an SQL statement

mysql_query
mysql_result
MySQL İşlevleri
PHP Manual

mysql_real_escape_string

(PHP 4 >= 4.3.0, PHP 5)

mysql_real_escape_string — Escapes special characters in a string for use in an SQL statement

Uyarı

This extension was deprecated in PHP 5.5.0, and it was removed in PHP 7.0.0. Instead, the MySQLi or PDO_MySQL extension should be used. See also MySQL: choosing an API guide and related FAQ for more information. Alternatives to this function include:

  • mysqli_real_escape_string()
  • PDO::quote()

Açıklama

string mysql_real_escape_string ( string $unescaped_string [, resource $link_identifier = NULL ] )

Escapes special characters in the unescaped_string, taking into account the current character set of the connection so that it is safe to place it in a mysql_query(). If binary data is to be inserted, this function must be used.

mysql_real_escape_string() calls MySQL's library function mysql_real_escape_string, which prepends backslashes to the following characters: \x00, \n, \r, \, ', " and \x1a.

This function must always (with few exceptions) be used to make data safe before sending a query to MySQL.

Dikkat

Security: the default character set

The character set must be set either at the server level, or with the API function mysql_set_charset() for it to affect mysql_real_escape_string(). See the concepts section on character sets for more information.

Değiştirgeler

unescaped_string

The string that is to be escaped.

bağlantı_belirteci

MySQL bağlantısı. Eğer bağlantı belirteci belirtilmemişse mysql_connect() tarafından açılan son bağlantı kullanılmaya çalışılır. Eğer böyle bir bağlantı yoksa mysql_connect() değiştirgesiz olarak çağrılmış gibi bir bağlantı oluşturmaya çalışır. Hiçbir bağlantı yoksa ve yenisi de kurulamazsa E_WARNING seviyesinde bir hata üretilir.

Dönen Değerler

Returns the escaped string, or FALSE on error.

Hatalar/İstisnalar

Executing this function without a MySQL connection present will also emit E_WARNING level PHP errors. Only execute this function with a valid MySQL connection present.

Örnekler

Örnek 1 Simple mysql_real_escape_string() example

<?php
// Connect
$link = mysql_connect('mysql_host', 'mysql_user', 'mysql_password')
    OR die(mysql_error());

// Query
$query = sprintf("SELECT * FROM users WHERE user='%s' AND password='%s'",
            mysql_real_escape_string($user),
            mysql_real_escape_string($password));
?>

Örnek 2 mysql_real_escape_string() requires a connection example

This example demonstrates what happens if a MySQL connection is not present when calling this function.

<?php
// We have not connected to MySQL

$lastname  = "O'Reilly";
$_lastname = mysql_real_escape_string($lastname);

$query = "SELECT * FROM actors WHERE last_name = '$_lastname'";

var_dump($_lastname);
var_dump($query);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Warning: mysql_real_escape_string(): No such file or directory in /this/test/script.php on line 5
Warning: mysql_real_escape_string(): A link to the server could not be established in /this/test/script.php on line 5

bool(false)
string(41) "SELECT * FROM actors WHERE last_name = ''"

Örnek 3 An example SQL Injection Attack

<?php
// We didn't check $_POST['password'], it could be anything the user wanted! For example:
$_POST['username'] = 'aidan';
$_POST['password'] = "' OR ''='";

// Query database to check if there are any matching users
$query = "SELECT * FROM users WHERE user='{$_POST['username']}' AND password='{$_POST['password']}'";
mysql_query($query);

// This means the query sent to MySQL would be:
echo $query;
?>

The query sent to MySQL:

SELECT * FROM users WHERE user='aidan' AND password='' OR ''=''

This would allow anyone to log in without a valid password.

Notlar

Bilginize:

A MySQL connection is required before using mysql_real_escape_string() otherwise an error of level E_WARNING is generated, and FALSE is returned. If link_identifier isn't defined, the last MySQL connection is used.

Bilginize:

If magic_quotes_gpc is enabled, first apply stripslashes() to the data. Using this function on data which has already been escaped will escape the data twice.

Bilginize:

If this function is not used to escape data, the query is vulnerable to SQL Injection Attacks.

Bilginize: mysql_real_escape_string() does not escape % and _. These are wildcards in MySQL if combined with LIKE, GRANT, or REVOKE.

Ayrıca Bakınız

  • mysql_set_charset() - Sets the client character set
  • mysql_client_encoding() - Karakter kümesinin adını döndürür
  • addslashes() - Özel karakterlerin önüne tersbölü yerleştirir
  • stripslashes() - Bir dizgeden tersbölüleri ayıklar
  • The magic_quotes_gpc directive
  • The magic_quotes_runtime directive

mysql_query
mysql_result
MySQL İşlevleri


Get result data

mysql_real_escape_string
mysql_select_db
MySQL İşlevleri
PHP Manual

mysql_result

(PHP 4, PHP 5)

mysql_result — Get result data

Uyarı

This extension was deprecated in PHP 5.5.0, and it was removed in PHP 7.0.0. Instead, the MySQLi or PDO_MySQL extension should be used. See also MySQL: choosing an API guide and related FAQ for more information. Alternatives to this function include:

  • mysqli_data_seek() in conjunction with
mysqli_field_seek() and
mysqli_fetch_field()
  • PDOStatement::fetchColumn()

Açıklama

string mysql_result ( resource $result , int $row [, mixed $field = 0 ] )

Retrieves the contents of one cell from a MySQL result set.

When working on large result sets, you should consider using one of the functions that fetch an entire row (specified below). As these functions return the contents of multiple cells in one function call, they're MUCH quicker than mysql_result(). Also, note that specifying a numeric offset for the field argument is much quicker than specifying a fieldname or tablename.fieldname argument.

Değiştirgeler

sonuç

resource türünde sorgu sonucu. Bu sonuç bir mysql_query() çağrısının sonucudur.

row

The row number from the result that's being retrieved. Row numbers start at 0.

field

The name or offset of the field being retrieved.

It can be the field's offset, the field's name, or the field's table dot field name (tablename.fieldname). If the column name has been aliased ('select foo as bar from...'), use the alias instead of the column name. If undefined, the first field is retrieved.

Dönen Değerler

The contents of one cell from a MySQL result set on success, or FALSE on failure.

Örnekler

Örnek 1 mysql_result() example

<?php
$link = mysql_connect('localhost', 'mysql_user', 'mysql_password');
if (!$link) {
    die('Could not connect: ' . mysql_error());
}
if (!mysql_select_db('database_name')) {
    die('Could not select database: ' . mysql_error());
}
$result = mysql_query('SELECT name FROM work.employee');
if (!$result) {
    die('Could not query:' . mysql_error());
}
echo mysql_result($result, 2); // outputs third employee's name

mysql_close($link);
?>

Notlar

Bilginize:

Calls to mysql_result() should not be mixed with calls to other functions that deal with the result set.

Ayrıca Bakınız

  • mysql_fetch_row() - Get a result row as an enumerated array
  • mysql_fetch_array() - Fetch a result row as an associative array, a numeric array, or both
  • mysql_fetch_assoc() - Fetch a result row as an associative array
  • mysql_fetch_object() - Fetch a result row as an object

mysql_real_escape_string
mysql_select_db
MySQL İşlevleri


Bir MySQL veritabanı seçer

mysql_result
mysql_set_charset
MySQL İşlevleri
PHP Manual

mysql_select_db

(PHP 4, PHP 5)

mysql_select_db — Bir MySQL veritabanı seçer

Açıklama

bool mysql_select_db ( string $veritabanı_adı [, resource $bağlantı_belirteci ] )

Belirtilen bağlantı belirteci ile ilişkili sunucuda, geçerli etkin veritabanını ayarlar. Takip eden bütün mysql_query() çağrıları etkin veritabanında yapılacaktır.

Değiştirgeler

veritabanı_adı

Seçilecek veritabanının adı.

bağlantı_belirteci

MySQL bağlantısı. Eğer bağlantı belirteci belirtilmemişse mysql_connect() tarafından açılan son bağlantı kullanılmaya çalışılır. Eğer böyle bir bağlantı yoksa mysql_connect() değiştirgesiz olarak çağrılmış gibi bir bağlantı oluşturmaya çalışır. Hiçbir bağlantı yoksa ve yenisi de kurulamazsa E_WARNING seviyesinde bir hata üretilir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - mysql_select_db() örneği

<?php

$link = mysql_connect('localhost', 'mysql_user', 'mysql_password');
if (!$link) {
    die('Bağlı değil : ' . mysql_error());
}

// foo'yu geçerli veritabanı yap
$db_selected = mysql_select_db('foo', $link);
if (!$db_selected) {
    die ('foo kullanılamaz : ' . mysql_error());
}
?>

Notlar

Bilginize:

Geriye uyumluluk adına, kullanımı önerilmese de şu takma adı kullanabilirsiniz: mysql_selectdb()

Ayrıca Bakınız

  • mysql_connect() - MySQL Sunucusuna bir bağlantı açar
  • mysql_pconnect() - Open a persistent connection to a MySQL server
  • mysql_query() - Send a MySQL query

mysql_result
mysql_set_charset
MySQL İşlevleri


Sets the client character set

mysql_select_db
mysql_stat
MySQL İşlevleri
PHP Manual

mysql_set_charset

(PHP 5 >= 5.2.3)

mysql_set_charset — Sets the client character set

Uyarı

This extension was deprecated in PHP 5.5.0, and it was removed in PHP 7.0.0. Instead, the MySQLi or PDO_MySQL extension should be used. See also MySQL: choosing an API guide and related FAQ for more information. Alternatives to this function include:

  • mysqli_set_charset()
  • PDO: Add charset to the connection string, such as charset=utf8

Açıklama

bool mysql_set_charset ( string $charset [, resource $link_identifier = NULL ] )

Sets the default character set for the current connection.

Değiştirgeler

charset

A valid character set name.

bağlantı_belirteci

MySQL bağlantısı. Eğer bağlantı belirteci belirtilmemişse mysql_connect() tarafından açılan son bağlantı kullanılmaya çalışılır. Eğer böyle bir bağlantı yoksa mysql_connect() değiştirgesiz olarak çağrılmış gibi bir bağlantı oluşturmaya çalışır. Hiçbir bağlantı yoksa ve yenisi de kurulamazsa E_WARNING seviyesinde bir hata üretilir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

Bilginize:

This function requires MySQL 5.0.7 or later.

Bilginize:

This is the preferred way to change the charset. Using mysql_query() to set it (such as SET NAMES utf8) is not recommended. See the MySQL character set concepts section for more information.

Ayrıca Bakınız

  • Setting character sets in MySQL
  • » List of character sets that MySQL supports
  • mysql_client_encoding() - Karakter kümesinin adını döndürür

mysql_select_db
mysql_stat
MySQL İşlevleri


Geçerli sunucu durumunu döndürür

mysql_set_charset
mysql_tablename
MySQL İşlevleri
PHP Manual

mysql_stat

(PHP 4 >= 4.3.0, PHP 5)

mysql_stat — Geçerli sunucu durumunu döndürür

Açıklama

string mysql_stat ([ resource $bağlantı_belirteci ] )

mysql_stat() geçerli sunucu durumunu döndürür.

Değiştirgeler

bağlantı_belirteci

MySQL bağlantısı. Eğer bağlantı belirteci belirtilmemişse mysql_connect() tarafından açılan son bağlantı kullanılmaya çalışılır. Eğer böyle bir bağlantı yoksa mysql_connect() değiştirgesiz olarak çağrılmış gibi bir bağlantı oluşturmaya çalışır. Hiçbir bağlantı yoksa ve yenisi de kurulamazsa E_WARNING seviyesinde bir hata üretilir.

Dönen Değerler

Toplam çalışma süresi, evre, sorgu, açık tablo, boşaltılmış tablo ve saniyedeki sorgu sayısını bir dizge olarak döndürür. Diğer durum değişkenlerinin eksiksiz listesini almak için SHOW STATUS SQL komutunu kullanmalısınız. bağlantı_belirteci geçersizse NULL döner.

Örnekler

Örnek 1 - mysql_stat() örneği

<?php
$link   = mysql_connect('localhost', 'mysql_user', 'mysql_password');
$status = explode('  ', mysql_stat($link));
print_r($status);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [0] => Uptime: 5380
    [1] => Threads: 2
    [2] => Questions: 1321299
    [3] => Slow queries: 0
    [4] => Opens: 26
    [5] => Flush tables: 1
    [6] => Open tables: 17
    [7] => Queries per second avg: 245.595
)

Örnek 2 - Bir başka mysql_stat() örneği

<?php
$link   = mysql_connect('localhost', 'mysql_user', 'mysql_password');
$result = mysql_query('SHOW STATUS', $link);
while ($row = mysql_fetch_assoc($result)) {
    echo $row['Variable_name'] . ' = ' . $row['Value'] . "\n";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

back_log = 50
basedir = /usr/local/
bdb_cache_size = 8388600
bdb_log_buffer_size = 32768
bdb_home = /var/db/mysql/
bdb_max_lock = 10000
bdb_logdir =
bdb_shared_data = OFF
bdb_tmpdir = /var/tmp/
...

Ayrıca Bakınız

  • mysql_get_server_info() - MySQL sunucu bilgisini al
  • mysql_list_processes() - MySQL süreçlerini listeler

mysql_set_charset
mysql_tablename
MySQL İşlevleri


Alanın tablo adını al

mysql_stat
mysql_thread_id
MySQL İşlevleri
PHP Manual

mysql_tablename

(PHP 4, PHP 5)

mysql_tablename — Alanın tablo adını al

Açıklama

string mysql_tablename ( resource $sonuç , int $i )

Bir sonuç'tan tablo adını alır.

Bu işlevin kullanımı önerilmemektedir. Bunun yerine, SHOW TABLES [FROM db_adı] [LIKE 'şablon'] şeklinde bir SQL ifadesi çalıştırmak için mysql_query() kullanılması tercih edilebilir.

Değiştirgeler

sonuç

mysql_list_tables() işlevinden döndürülen resource türünde bir sonuç göstericisi.

i

Tamsayı indisi (satır/tablo numarası)

Dönen Değerler

Başarı durumunda tablo adı, hata durumunda FALSE döndürülür.

Bu sonuç göstericisini veya mysql_fetch_array() gibi sonuç tabloları üreten bir işlevden elde edilen işlevselliğin tersini elde etmek için mysql_tablename() işlevini kullanın.

Örnekler

Örnek 1 - mysql_tablename() örneği

<?php
mysql_connect("localhost", "mysql_user", "mysql_password");
$result = mysql_list_tables("mydb");
$num_rows = mysql_num_rows($result);
for ($i = 0; $i < $num_rows; $i++) {
    echo "Tablo: ", mysql_tablename($result, $i), "\n";
}

mysql_free_result($result);
?>

Notlar

Bilginize:

mysql_num_rows() işlevi sonuç göstericisindeki tablo sayısını belirlemek için kullanılabilir.

Ayrıca Bakınız

  • mysql_list_tables() - Bir MySQL veritabanındaki tabloları listele
  • mysql_field_table() - Belirtilen alanı içeren tablonun adını al
  • mysql_db_name() - Sonuç verisini al

mysql_stat
mysql_thread_id
MySQL İşlevleri


Geçerli evre numarasını döndür

mysql_tablename
mysql_unbuffered_query
MySQL İşlevleri
PHP Manual

mysql_thread_id

(PHP 4 >= 4.3.0, PHP 5)

mysql_thread_id — Geçerli evre numarasını döndür

Açıklama

int mysql_thread_id ([ resource $bağlantı_belirteci ] )

Geçerli evre numarasını alır. Eğer bağlantı kaybolursa ve mysql_ping() ile yeniden bağlanılırsa evre numarası da değişecektir. Bu nedenle, evre numarasını sadece gerektiğinde alın.

Değiştirgeler

bağlantı_belirteci

MySQL bağlantısı. Eğer bağlantı belirteci belirtilmemişse mysql_connect() tarafından açılan son bağlantı kullanılmaya çalışılır. Eğer böyle bir bağlantı yoksa mysql_connect() değiştirgesiz olarak çağrılmış gibi bir bağlantı oluşturmaya çalışır. Hiçbir bağlantı yoksa ve yenisi de kurulamazsa E_WARNING seviyesinde bir hata üretilir.

Dönen Değerler

Başarı durumunda evre numarası, hata durumunda FALSE.

Örnekler

Örnek 1 - mysql_thread_id() örneği

<?php
$link = mysql_connect('localhost', 'mysql_user', 'mysql_password');
$thread_id = mysql_thread_id($link);
if ($thread_id){
    printf("geçerli evre numarası %d\n", $thread_id);
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

geçerli evre numarası 73

Ayrıca Bakınız

  • mysql_ping() - Bir sunucu bağlantısına ping at, bağlantı yoksa tekrar bağlan
  • mysql_list_processes() - MySQL süreçlerini listeler

mysql_tablename
mysql_unbuffered_query
MySQL İşlevleri


Sonuç kümesi tamponlanmayan ve alınmayan bir SQL sorgusu gönderir

mysql_thread_id
Mysqlnd
MySQL İşlevleri
PHP Manual

mysql_unbuffered_query

(PHP 4 >= 4.0.6, PHP 5)

mysql_unbuffered_query — Sonuç kümesi tamponlanmayan ve alınmayan bir SQL sorgusu gönderir

Açıklama

resource mysql_unbuffered_query ( string $sorgu [, resource $bağlantı_belirteci ] )

mysql_unbuffered_query() işlevi mysql_query() işlevinin yaptığı gibi sonuç kümesini tamponlamadan ve içindekileri almamak üzere sorgu SQL sorgusunu MySQL'e gönderir. Başka bir deyişle, büyük sonuç kümeleri üreten SQL sorgularından kaynaklanan bellek tüketimini azaltır. Yani, ilk satırı alır almaz sonuç kümesiyle çalışmaya başlayabilirsiniz; SQL sorusunun tamamlanmasını beklemeniz gerekmez.Çok sayıda veritabanı bağlantısı kullanıyorsanız belirtilmesi isteğe bağlı olan bağlantı_belirteci değiştirgesini de belirtmeniz gerekir.

Değiştirgeler

sorgu

Bir SQL sorgusu.

Sorgunun içerdiği verinin gerektiği gibi öncelenmesi gerekir.

bağlantı_belirteci

MySQL bağlantısı. Eğer bağlantı belirteci belirtilmemişse mysql_connect() tarafından açılan son bağlantı kullanılmaya çalışılır. Eğer böyle bir bağlantı yoksa mysql_connect() değiştirgesiz olarak çağrılmış gibi bir bağlantı oluşturmaya çalışır. Hiçbir bağlantı yoksa ve yenisi de kurulamazsa E_WARNING seviyesinde bir hata üretilir.

Dönen Değerler

SELECT, SHOW, DESCRIBE ve EXPLAIN deyimleri için mysql_unbuffered_query() başarı durumunda bir özkaynak aksi takdirde FALSE döndürür.

UPDATE, DELETE, DROP gibi diğer SQL deyimi türlerinde, mysql_unbuffered_query() başarı durumunda TRUE aksi takdirde FALSE döndürür.

Notlar

Bilginize:

mysql_unbuffered_query() işlevinin getirilerinin yanında götürüleri de vardır: mysql_unbuffered_query() işlevinden dönen bir sonuç kümesi üzerinde mysql_num_rows() ve mysql_data_seek() işlevlerini kullanamazsınız. Ayrıca, MySQL'e yeni bir SQL sorgusu göndermeden önce tamponsuz bir SQL sorgusundan kaynaklanan sonuç kümesinin tamamını almanız gerekir.

Ayrıca Bakınız

  • mysql_query() - Send a MySQL query

mysql_thread_id
Mysqlnd
MySQL İşlevleri


MySQL Native Driver

  • Giriş
  • Overview
  • Installation
  • Çalışma Anı Yapılandırması
  • Incompatibilities
  • Persistent Connections
  • Statistics
  • Notes
  • Memory management
  • MySQL Native Driver Plugin API
    • A comparison of mysqlnd plugins with MySQL Proxy
    • Obtaining the mysqlnd plugin API
    • MySQL Native Driver Plugin Architecture
    • The mysqlnd plugin API
    • Getting started building a mysqlnd plugin
mysql_unbuffered_query
Giriş
MySQL


Giriş

MySQL Native Driver is a replacement for the MySQL Client Library (libmysqlclient). MySQL Native Driver is part of the official PHP sources as of PHP 5.3.0.

The MySQL database extensions MySQL extension, mysqli and PDO MYSQL all communicate with the MySQL server. In the past, this was done by the extension using the services provided by the MySQL Client Library. The extensions were compiled against the MySQL Client Library in order to use its client-server protocol.

With MySQL Native Driver there is now an alternative, as the MySQL database extensions can be compiled to use MySQL Native Driver instead of the MySQL Client Library.

MySQL Native Driver is written in C as a PHP extension.

Mysqlnd
Overview
Mysqlnd


Overview

What it is not

Although MySQL Native Driver is written as a PHP extension, it is important to note that it does not provide a new API to the PHP programmer. The programmer APIs for MySQL database connectivity are provided by the MySQL extension, mysqli and PDO MYSQL. These extensions can now use the services of MySQL Native Driver to communicate with the MySQL Server. Therefore, you should not think of MySQL Native Driver as an API.

Why use it?

Using the MySQL Native Driver offers a number of advantages over using the MySQL Client Library.

The older MySQL Client Library was written by MySQL AB (now Oracle Corporation) and so was released under the MySQL license. This ultimately led to MySQL support being disabled by default in PHP. However, the MySQL Native Driver has been developed as part of the PHP project, and is therefore released under the PHP license. This removes licensing issues that have been problematic in the past.

Also, in the past, you needed to build the MySQL database extensions against a copy of the MySQL Client Library. This typically meant you needed to have MySQL installed on a machine where you were building the PHP source code. Also, when your PHP application was running, the MySQL database extensions would call down to the MySQL Client library file at run time, so the file needed to be installed on your system. With MySQL Native Driver that is no longer the case as it is included as part of the standard distribution. So you do not need MySQL installed in order to build PHP or run PHP database applications.

Because MySQL Native Driver is written as a PHP extension, it is tightly coupled to the workings of PHP. This leads to gains in efficiency, especially when it comes to memory usage, as the driver uses the PHP memory management system. It also supports the PHP memory limit. Using MySQL Native Driver leads to comparable or better performance than using MySQL Client Library, it always ensures the most efficient use of memory. One example of the memory efficiency is the fact that when using the MySQL Client Library, each row is stored in memory twice, whereas with the MySQL Native Driver each row is only stored once in memory.

Bilginize: Reporting memory usage

Because MySQL Native Driver uses the PHP memory management system, its memory usage can be tracked with memory_get_usage(). This is not possible with libmysqlclient because it uses the C function malloc() instead.

Special features

MySQL Native Driver also provides some special features not available when the MySQL database extensions use MySQL Client Library. These special features are listed below:

  • Improved persistent connections

  • The special function mysqli_fetch_all()

  • Performance statistics calls:
mysqli_get_cache_stats(),
mysqli_get_client_stats(),
mysqli_get_connection_stats()

The performance statistics facility can prove to be very useful in identifying performance bottlenecks.

MySQL Native Driver also allows for persistent connections when used with the mysqli extension.

SSL Support

MySQL Native Driver has supported SSL since PHP version 5.3.3

Compressed Protocol Support

As of PHP 5.3.2 MySQL Native Driver supports the compressed client server protocol. MySQL Native Driver did not support this in 5.3.0 and 5.3.1. Extensions such as ext/mysql, ext/mysqli, that are configured to use MySQL Native Driver, can also take advantage of this feature. Note that PDO_MYSQL does NOT support compression when used together with mysqlnd.

Named Pipes Support

Named pipes support for Windows was added in PHP version 5.4.0.

Giriş
Installation
Mysqlnd


Installation

Sürüm Bilgisi

Sürüm Bilgisi
Sürüm: | Açıklama
5.3.0 | The MySQL Native Driver was added, with support for all MySQL extensions (i.e., mysql, mysqli and PDO_MYSQL). Passing in mysqlnd to the appropriate configure switch enables this support.
5.4.0 | The MySQL Native Driver is now the default for all MySQL extensions (i.e., mysql, mysqli and PDO_MYSQL). Passing in mysqlnd to configure is now optional.
5.5.0 | SHA-256 Authentication Plugin support was added

Installation on Unix

The MySQL database extensions must be configured to use the MySQL Client Library. In order to use the MySQL Native Driver, PHP needs to be built specifying that the MySQL database extensions are compiled with MySQL Native Driver support. This is done through configuration options prior to building the PHP source code.

For example, to build the MySQL extension, mysqli and PDO MYSQL using the MySQL Native Driver, the following command would be given:

./configure --with-mysql=mysqlnd \
--with-mysqli=mysqlnd \
--with-pdo-mysql=mysqlnd \
[other options]

Installation on Windows

In the official PHP Windows distributions from 5.3 onwards, MySQL Native Driver is enabled by default, so no additional configuration is required to use it. All MySQL database extensions will use MySQL Native Driver in this case.

SHA-256 Authentication Plugin support

The MySQL Native Driver requires the OpenSSL functionality of PHP to be loaded and enabled to connect to MySQL through accounts that use the MySQL SHA-256 Authentication Plugin. For example, PHP could be configured using:

./configure --with-mysql=mysqlnd \
--with-mysqli=mysqlnd \
--with-pdo-mysql=mysqlnd \
--with-openssl
[other options]
Overview
Çalışma Anı Yapılandırması
Mysqlnd


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

MySQL Native Driver Configuration Options
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
mysqlnd.collect_statistics | "1" | PHP_INI_SYSTEM | Available since PHP 5.3.0.
mysqlnd.collect_memory_statistics | "0" | PHP_INI_SYSTEM | Available since PHP 5.3.0.
mysqlnd.debug | "" | PHP_INI_SYSTEM | Available since PHP 5.3.0.
mysqlnd.log_mask | 0 | PHP_INI_ALL | Available since PHP 5.3.0
mysqlnd.mempool_default_size | 16000 | PHP_INI_ALL | Available since PHP 5.3.3
mysqlnd.net_read_timeout | "31536000" | PHP_INI_SYSTEM | Available since PHP 5.3.0.
mysqlnd.net_cmd_buffer_size | 5.3.0 - "2048", 5.3.1 - "4096" | PHP_INI_SYSTEM | Available since PHP 5.3.0.
mysqlnd.net_read_buffer_size | "32768" | PHP_INI_SYSTEM | Available since PHP 5.3.0.
mysqlnd.sha256_server_public_key | "" | PHP_INI_PERDIR | Available since PHP 5.5.0.
mysqlnd.fetch_data_copy | 0 | PHP_INI_ALL | Available since PHP 5.6.0.
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

mysqlnd.collect_statistics boolean

Enables the collection of various client statistics which can be
accessed through mysqli_get_client_stats(),
mysqli_get_connection_stats(),
mysqli_get_cache_stats() and are shown in
mysqlnd section of the output of the
phpinfo() function as well.

This configuration setting enables all MySQL Native Driver statistics except those relating to memory management.

mysqlnd.collect_memory_statistics boolean

Enable the collection of various memory statistics which can be
accessed through mysqli_get_client_stats(),
mysqli_get_connection_stats(),
mysqli_get_cache_stats() and are shown in
mysqlnd section of the output of the
phpinfo() function as well.

This configuration setting enables the memory management statistics within the overall set of MySQL Native Driver statistics.

mysqlnd.debug string

Records communication from all extensions using mysqlnd to the specified log file.

The format of the directive is mysqlnd.debug = "option1[,parameter_option1][:option2[,parameter_option2]]".

The options for the format string are as follows:

  • A[,file] - Appends trace output to specified file. Also ensures that data is written after each write. This is done by closing and reopening the trace file (this is slow). It helps ensure a complete log file should the application crash.

  • a[,file] - Appends trace output to the specified file.

  • d - Enables output from DBUG_<N> macros for the current state. May be followed by a list of keywords which selects output only for the DBUG macros with that keyword. An empty list of keywords implies output for all macros.

  • f[,functions] - Limits debugger actions to the specified list of functions. An empty list of functions implies that all functions are selected.

  • F - Marks each debugger output line with the name of the source file containing the macro causing the output.

  • i - Marks each debugger output line with the PID of the current process.

  • L - Marks each debugger output line with the name of the source file line number of the macro causing the output.

  • n - Marks each debugger output line with the current function nesting depth

  • o[,file] - Similar to a[,file] but overwrites old file, and does not append.

  • O[,file] - Similar to A[,file] but overwrites old file, and does not append.

  • t[,N] - Enables function control flow tracing. The maximum nesting depth is specified by N, and defaults to 200.

  • x - This option activates profiling.

  • m - Trace memory allocation and deallocation related calls.

Example:

d:t:x:O,/tmp/mysqlnd.trace

Bilginize:

This feature is only available with a debug build of PHP. Works on Microsoft Windows if using a debug build of PHP and PHP was built using Microsoft Visual C version 9 and above.

mysqlnd.log_mask integer

Defines which queries will be logged. The default 0, which disables logging. Define using an integer, and not with PHP constants. For example, a value of 48 (16 + 32) will log slow queries which either use 'no good index' (SERVER_QUERY_NO_GOOD_INDEX_USED = 16) or no index at all (SERVER_QUERY_NO_INDEX_USED = 32). A value of 2043 (1 + 2 + 8 + ... + 1024) will log all slow query types.

The types are as follows: SERVER_STATUS_IN_TRANS=1, SERVER_STATUS_AUTOCOMMIT=2,
SERVER_MORE_RESULTS_EXISTS=8, SERVER_QUERY_NO_GOOD_INDEX_USED=16, SERVER_QUERY_NO_INDEX_USED=32,
SERVER_STATUS_CURSOR_EXISTS=64, SERVER_STATUS_LAST_ROW_SENT=128, SERVER_STATUS_DB_DROPPED=256,
SERVER_STATUS_NO_BACKSLASH_ESCAPES=512, and SERVER_QUERY_WAS_SLOW=1024.

mysqlnd.mempool_default_size integer

Default size of the mysqlnd memory pool, which is used by result sets.

mysqlnd.net_read_timeout integer

mysqlnd and the MySQL Client Library, libmysqlclient use different networking APIs. mysqlnd uses PHP streams, whereas libmysqlclient uses its own wrapper around the operating level network calls. PHP, by default, sets a read timeout of 60s for streams. This is set via php.ini, default_socket_timeout. This default applies to all streams that set no other timeout value. mysqlnd does not set any other value and therefore connections of long running queries can be disconnected after default_socket_timeout seconds resulting in an error message "2006 - MySQL Server has gone away". The MySQL Client Library sets a default timeout of 365 * 24 * 3600 seconds (1 year) and waits for other timeouts to occur, such as TCP/IP timeouts. mysqlnd now uses the same very long timeout. The value is configurable through a new php.ini setting: mysqlnd.net_read_timeout. mysqlnd.net_read_timeout gets used by any extension (ext/mysql, ext/mysqli, PDO_MySQL) that uses mysqlnd. mysqlnd tells PHP Streams to use mysqlnd.net_read_timeout. Please note that there may be subtle differences between MYSQL_OPT_READ_TIMEOUT from the MySQL Client Library and PHP Streams, for example MYSQL_OPT_READ_TIMEOUT is documented to work only for TCP/IP connections and, prior to MySQL 5.1.2, only for Windows. PHP streams may not have this limitation. Please check the streams documentation, if in doubt.

mysqlnd.net_cmd_buffer_size long

mysqlnd allocates an internal command/network buffer of mysqlnd.net_cmd_buffer_size (in php.ini) bytes for every connection. If a MySQL Client Server protocol command, for example, COM_QUERY ("normal" query), does not fit into the buffer, mysqlnd will grow the buffer to the size required for sending the command. Whenever the buffer gets extended for one connection, command_buffer_too_small will be incremented by one.

If mysqlnd has to grow the buffer beyond its initial size of mysqlnd.net_cmd_buffer_size bytes for almost every connection, you should consider increasing the default size to avoid re-allocations.

The default buffer size is 2048 bytes in PHP 5.3.0. In later versions the default is 4096 bytes.

It is recommended that the buffer size be set to no less than 4096 bytes because mysqlnd also uses it when reading certain communication packet from MySQL. In PHP 5.3.0, mysqlnd will not grow the buffer if MySQL sends a packet that is larger than the current size of the buffer. As a consequence, mysqlnd is unable to decode the packet and the client application will get an error. There are only two situations when the packet can be larger than the 2048 bytes default of mysqlnd.net_cmd_buffer_size in PHP 5.3.0: the packet transports a very long error message, or the packet holds column meta data from COM_LIST_FIELD (mysql_list_fields() and the meta data come from a string column with a very long default value (>1900 bytes).

As of PHP 5.3.2 mysqlnd does not allow setting buffers smaller than 4096 bytes.

The value can also be set using mysqli_options(link, MYSQLI_OPT_NET_CMD_BUFFER_SIZE, size).

mysqlnd.net_read_buffer_size long

Maximum read chunk size in bytes when reading the body of a MySQL command packet. The MySQL client server protocol encapsulates all its commands in packets. The packets consist of a small header and a body with the actual payload. The size of the body is encoded in the header. mysqlnd reads the body in chunks of MIN(header.size, mysqlnd.net_read_buffer_size) bytes. If a packet body is larger than mysqlnd.net_read_buffer_size bytes, mysqlnd has to call read() multiple times.

The value can also be set using mysqli_options(link, MYSQLI_OPT_NET_READ_BUFFER_SIZE, size).

mysqlnd.sha256_server_public_key string

SHA-256 Authentication Plugin related. File with the MySQL server public RSA key.

Clients can either omit setting a public RSA key, specify the key through this PHP configuration setting or set the key at runtime using mysqli_options(). If not public RSA key file is given by the client, then the key will be exchanged as part of the standard SHA-256 Authentication Plugin authentication procedure.

mysqlnd.fetch_data_copy long

Enforce copying result sets from the internal result set buffers into PHP variables instead of using the default reference and copy-on-write logic. Please, see the memory management implementation notes for further details.

Copying result sets instead of having PHP variables reference them allows releasing the memory occupied for the PHP variables earlier. Depending on the user API code, the actual database quries and the size of their result sets this may reduce the memory footprint of mysqlnd.

Do not set if using PDO_MySQL. PDO_MySQL has not yet been updated to support the new fetch mode.

Installation
Incompatibilities
Mysqlnd


Incompatibilities

MySQL Native Driver is in most cases compatible with MySQL Client Library (libmysql). This section documents incompatibilities between these libraries.

  • Values of bit data type are returned as binary strings (e.g. "\0" or "\x1F") with libmysql and as decimal strings (e.g. "0" or "31") with mysqlnd. If you want the code to be compatible with both libraries then always return bit fields as numbers from MySQL with a query like this: SELECT bit + 0 FROM table.

Çalışma Anı Yapılandırması
Persistent Connections
Mysqlnd


Persistent Connections

Using Persistent Connections

If mysqli is used with mysqlnd, when a persistent connection is created it generates a COM_CHANGE_USER (mysql_change_user()) call on the server. This ensures that re-authentication of the connection takes place.

As there is some overhead associated with the COM_CHANGE_USER call, it is possible to switch this off at compile time. Reusing a persistent connection will then generate a COM_PING (mysql_ping) call to simply test the connection is reusable.

Generation of COM_CHANGE_USER can be switched off with the compile flag MYSQLI_NO_CHANGE_USER_ON_PCONNECT. For example:

shell# CFLAGS="-DMYSQLI_NO_CHANGE_USER_ON_PCONNECT" ./configure --with-mysql=/usr/local/mysql/ --with-mysqli=/usr/local/mysql/bin/mysql_config --with-pdo-mysql=/usr/local/mysql/bin/mysql_config --enable-debug && make clean && make -j6

Or alternatively:

shell# export CFLAGS="-DMYSQLI_NO_CHANGE_USER_ON_PCONNECT"
shell# configure --whatever-option
shell# make clean
shell# make

Note that only mysqli on mysqlnd uses COM_CHANGE_USER. Other extension-driver combinations use COM_PING on initial use of a persistent connection.

Incompatibilities
Statistics
Mysqlnd


Statistics

Using Statistical Data

MySQL Native Driver contains support for gathering statistics on the communication between the client and the server. The statistics gathered are of two main types:

  • Client statistics

  • Connection statistics

If you are using the mysqli extension, these statistics can be obtained through two API calls:

  • mysqli_get_client_stats()

  • mysqli_get_connection_stats()

Bilginize:

Statistics are aggregated among all extensions that use MySQL Native Driver. For example, when compiling both ext/mysql and ext/mysqli against MySQL Native Driver, both function calls of ext/mysql and ext/mysqli will change the statistics. There is no way to find out how much a certain API call of any extension that has been compiled against MySQL Native Driver has impacted a certain statistic. You can configure the PDO MySQL Driver, ext/mysql and ext/mysqli to optionally use the MySQL Native Driver. When doing so, all three extensions will change the statistics.

Accessing Client Statistics

To access client statistics, you need to call mysqli_get_client_stats(). The function call does not require any parameters.

The function returns an associative array that contains the name of the statistic as the key and the statistical data as the value.

Client statistics can also be accessed by calling the phpinfo() function.

Accessing Connection Statistics

To access connection statistics call mysqli_get_connection_stats(). This takes the database connection handle as the parameter.

The function returns an associative array that contains the name of the statistic as the key and the statistical data as the value.

Buffered and Unbuffered Result Sets

Result sets can be buffered or unbuffered. Using default settings, ext/mysql and ext/mysqli work with buffered result sets for normal (non prepared statement) queries. Buffered result sets are cached on the client. After the query execution all results are fetched from the MySQL Server and stored in a cache on the client. The big advantage of buffered result sets is that they allow the server to free all resources allocated to a result set, once the results have been fetched by the client.

Unbuffered result sets on the other hand are kept much longer on the server. If you want to reduce memory consumption on the client, but increase load on the server, use unbuffered results. If you experience a high server load and the figures for unbuffered result sets are high, you should consider moving the load to the clients. Clients typically scale better than servers. "Load" does not only refer to memory buffers - the server also needs to keep other resources open, for example file handles and threads, before a result set can be freed.

Prepared Statements use unbuffered result sets by default. However, you can use mysqli_stmt_store_result() to enable buffered result sets.

Statistics returned by MySQL Native Driver

The following tables show a list of statistics returned by the mysqli_get_client_stats() and mysqli_get_connection_stats() functions.

Returned mysqlnd statistics: Network
Statistic | Scope | Description | Notes
bytes_sent | Connection | Number of bytes sent from PHP to the MySQL server | Can be used to check the efficiency of the compression protocol
bytes_received | Connection | Number of bytes received from MySQL server | Can be used to check the efficiency of the compression protocol
packets_sent | Connection | Number of MySQL Client Server protocol packets sent | Used for debugging Client Server protocol implementation
packets_received | Connection | Number of MySQL Client Server protocol packets received | Used for debugging Client Server protocol implementation
protocol_overhead_in | Connection | MySQL Client Server protocol overhead in bytes for incoming traffic. Currently only the Packet Header (4 bytes) is considered as overhead. protocol_overhead_in = packets_received * 4 | Used for debugging Client Server protocol implementation
protocol_overhead_out | Connection | MySQL Client Server protocol overhead in bytes for outgoing traffic. Currently only the Packet Header (4 bytes) is considered as overhead. protocol_overhead_out = packets_sent * 4 | Used for debugging Client Server protocol implementation
bytes_received_ok_packet | Connection | Total size of bytes of MySQL Client Server protocol OK packets received. OK packets can contain a status message. The length of the status message can vary and thus the size of an OK packet is not fixed. | Used for debugging CS protocol implementation. Note that the total size in bytes includes the size of the header packet (4 bytes, see protocol overhead).
packets_received_ok | Connection | Number of MySQL Client Server protocol OK packets received. | Used for debugging CS protocol implementation. Note that the total size in bytes includes the size of the header packet (4 bytes, see protocol overhead).
bytes_received_eof_packet | Connection | Total size in bytes of MySQL Client Server protocol EOF packets received. EOF can vary in size depending on the server version. Also, EOF can transport an error message. | Used for debugging CS protocol implementation. Note that the total size in bytes includes the size of the header packet (4 bytes, see protocol overhead).
packets_received_eof | Connection | Number of MySQL Client Server protocol EOF packets. Like with other packet statistics the number of packets will be increased even if PHP does not receive the expected packet but, for example, an error message. | Used for debugging CS protocol implementation. Note that the total size in bytes includes the size of the header packet (4 bytes, see protocol overhead).
bytes_received_rset_header_packet | Connection | Total size in bytes of MySQL Client Server protocol result set header packets. The size of the packets varies depending on the payload (LOAD LOCAL INFILE, INSERT, UPDATE, SELECT, error message). | Used for debugging CS protocol implementation. Note that the total size in bytes includes the size of the header packet (4 bytes, see protocol overhead).
packets_received_rset_header | Connection | Number of MySQL Client Server protocol result set header packets. | Used for debugging CS protocol implementation. Note that the total size in bytes includes the size of the header packet (4 bytes, see protocol overhead).
bytes_received_rset_field_meta_packet | Connection | Total size in bytes of MySQL Client Server protocol result set meta data (field information) packets. Of course the size varies with the fields in the result set. The packet may also transport an error or an EOF packet in case of COM_LIST_FIELDS. | Only useful for debugging CS protocol implementation. Note that the total size in bytes includes the size of the header packet (4 bytes, see protocol overhead).
packets_received_rset_field_meta | Connection | Number of MySQL Client Server protocol result set meta data (field information) packets. | Only useful for debugging CS protocol implementation. Note that the total size in bytes includes the size of the header packet (4 bytes, see protocol overhead).
bytes_received_rset_row_packet | Connection | Total size in bytes of MySQL Client Server protocol result set row data packets. The packet may also transport an error or an EOF packet. You can reverse engineer the number of error and EOF packets by subtracting rows_fetched_from_server_normal and rows_fetched_from_server_ps from bytes_received_rset_row_packet. | Only useful for debugging CS protocol implementation. Note that the total size in bytes includes the size of the header packet (4 bytes, see protocol overhead).
packets_received_rset_row | Connection | Number of MySQL Client Server protocol result set row data packets and their total size in bytes. | Only useful for debugging CS protocol implementation. Note that the total size in bytes includes the size of the header packet (4 bytes, see protocol overhead).
bytes_received_prepare_response_packet | Connection | Total size in bytes of MySQL Client Server protocol OK for Prepared Statement Initialization packets (prepared statement init packets). The packet may also transport an error. The packet size depends on the MySQL version: 9 bytes with MySQL 4.1 and 12 bytes from MySQL 5.0 on. There is no safe way to know how many errors happened. You may be able to guess that an error has occurred if, for example, you always connect to MySQL 5.0 or newer and, bytes_received_prepare_response_packet != packets_received_prepare_response * 12. See also ps_prepared_never_executed, ps_prepared_once_executed. | Only useful for debugging CS protocol implementation. Note that the total size in bytes includes the size of the header packet (4 bytes, see protocol overhead).
packets_received_prepare_response | Connection | Number of MySQL Client Server protocol OK for Prepared Statement Initialization packets (prepared statement init packets). | Only useful for debugging CS protocol implementation. Note that the total size in bytes includes the size of the header packet (4 bytes, see protocol overhead).
bytes_received_change_user_packet | Connection | Total size in bytes of MySQL Client Server protocol COM_CHANGE_USER packets. The packet may also transport an error or EOF. | Only useful for debugging CS protocol implementation. Note that the total size in bytes includes the size of the header packet (4 bytes, see protocol overhead).
packets_received_change_user | Connection | Number of MySQL Client Server protocol COM_CHANGE_USER packets | Only useful for debugging CS protocol implementation. Note that the total size in bytes includes the size of the header packet (4 bytes, see protocol overhead).
packets_sent_command | Connection | Number of MySQL Client Server protocol commands sent from PHP to MySQL. There is no way to know which specific commands and how many of them have been sent. At its best you can use it to check if PHP has sent any commands to MySQL to know if you can consider to disable MySQL support in your PHP binary. There is also no way to reverse engineer the number of errors that may have occurred while sending data to MySQL. The only error that is recorded is command_buffer_too_small (see below). | Only useful for debugging CS protocol implementation.
bytes_received_real_data_normal Connection Number of bytes of payload fetched by the PHP client from mysqlnd using the text protocol. This is the size of the actual data contained in result sets that do not originate from prepared statements and which have been fetched by the PHP client. Note that although a full result set may have been pulled from MySQL by mysqlnd, this statistic only counts actual data pulled from mysqlnd by the PHP client. An example of a code sequence that will increase the value is as follows:
$mysqli = new mysqli();
$res = $mysqli->query("SELECT 'abc'");
$res->fetch_assoc();
$res->close();

Every fetch operation will increase the value.

The statistic will not be increased if the result set is only buffered on the client, but not fetched, such as in the following example:

$mysqli = new mysqli();
$res = $mysqli->query("SELECT 'abc'");
$res->close();

This statistic is available as of PHP version 5.3.4.

bytes_received_real_data_ps | Connection | Number of bytes of the payload fetched by the PHP client from mysqlnd using the prepared statement protocol. | This is the size of the actual data contained in result sets that originate from prepared statements and which has been fetched by the PHP client. The value will not be increased if the result set is not subsequently read by the PHP client. Note that although a full result set may have been pulled from MySQL by mysqlnd, this statistic only counts actual data pulled from mysqlnd by the PHP client. See also bytes_received_real_data_normal. This statistic is available as of PHP version 5.3.4.

Result Set

Returned mysqlnd statistics: Result Set
Statistic | Scope | Description | Notes
result_set_queries | Connection | Number of queries that have generated a result set. Examples of queries that generate a result set: SELECT, SHOW. The statistic will not be incremented if there is an error reading the result set header packet from the line. | You may use it as an indirect measure for the number of queries PHP has sent to MySQL, for example, to identify a client that causes a high database load.
non_result_set_queries | Connection | Number of queries that did not generate a result set. Examples of queries that do not generate a result set: INSERT, UPDATE, LOAD DATA. The statistic will not be incremented if there is an error reading the result set header packet from the line. | You may use it as an indirect measure for the number of queries PHP has sent to MySQL, for example, to identify a client that causes a high database load.
no_index_used | Connection | Number of queries that have generated a result set but did not use an index (see also mysqld start option -log-queries-not-using-indexes). If you want these queries to be reported you can use mysqli_report(MYSQLI_REPORT_INDEX) to make ext/mysqli throw an exception. If you prefer a warning instead of an exception use mysqli_report(MYSQLI_REPORT_INDEX ^ MYSQLI_REPORT_STRICT).
bad_index_used | Connection | Number of queries that have generated a result set and did not use a good index (see also mysqld start option -log-slow-queries). | If you want these queries to be reported you can use mysqli_report(MYSQLI_REPORT_INDEX) to make ext/mysqli throw an exception. If you prefer a warning instead of an exception use mysqli_report(MYSQLI_REPORT_INDEX ^ MYSQLI_REPORT_STRICT)
slow_queries | Connection | SQL statements that took more than long_query_time seconds to execute and required at least min_examined_row_limit rows to be examined. | Not reported through mysqli_report()
buffered_sets | Connection | Number of buffered result sets returned by "normal" queries. "Normal" means "not prepared statement" in the following notes. | Examples of API calls that will buffer result sets on the client: mysql_query(), mysqli_query(), mysqli_store_result(), mysqli_stmt_get_result(). Buffering result sets on the client ensures that server resources are freed as soon as possible and it makes result set scrolling easier. The downside is the additional memory consumption on the client for buffering data. Note that mysqlnd (unlike the MySQL Client Library) respects the PHP memory limit because it uses PHP internal memory management functions to allocate memory. This is also the reason why memory_get_usage() reports a higher memory consumption when using mysqlnd instead of the MySQL Client Library. memory_get_usage() does not measure the memory consumption of the MySQL Client Library at all because the MySQL Client Library does not use PHP internal memory management functions monitored by the function!
unbuffered_sets | Connection | Number of unbuffered result sets returned by normal (non prepared statement) queries. | Examples of API calls that will not buffer result sets on the client: mysqli_use_result()
ps_buffered_sets | Connection | Number of buffered result sets returned by prepared statements. By default prepared statements are unbuffered. | Examples of API calls that will buffer result sets on the client: mysqli_stmt_store_result
ps_unbuffered_sets | Connection | Number of unbuffered result sets returned by prepared statements. | By default prepared statements are unbuffered.
flushed_normal_sets Connection Number of result sets from normal (non prepared statement) queries with unread data which have been flushed silently for you. Flushing happens only with unbuffered result sets. Unbuffered result sets must be fetched completely before a new query can be run on the connection otherwise MySQL will throw an error. If the application does not fetch all rows from an unbuffered result set, mysqlnd does implicitly fetch the result set to clear the line. See also rows_skipped_normal, rows_skipped_ps. Some possible causes for an implicit flush:

  • Faulty client application

  • Client stopped reading after it found what it was looking for but has made MySQL calculate more records than needed

  • Client application has stopped unexpectedly

flushed_ps_sets Connection Number of result sets from prepared statements with unread data which have been flushed silently for you. Flushing happens only with unbuffered result sets. Unbuffered result sets must be fetched completely before a new query can be run on the connection otherwise MySQL will throw an error. If the application does not fetch all rows from an unbuffered result set, mysqlnd does implicitly fetch the result set to clear the line. See also rows_skipped_normal, rows_skipped_ps. Some possible causes for an implicit flush:

  • Faulty client application

  • Client stopped reading after it found what it was looking for but has made MySQL calculate more records than needed

  • Client application has stopped unexpectedly

ps_prepared_never_executed | Connection | Number of statements prepared but never executed. | Prepared statements occupy server resources. You should not prepare a statement if you do not plan to execute it.
ps_prepared_once_executed | Connection | Number of prepared statements executed only one. | One of the ideas behind prepared statements is that the same query gets executed over and over again (with different parameters) and some parsing and other preparation work can be saved, if statement execution is split up in separate prepare and execute stages. The idea is to prepare once and "cache" results, for example, the parse tree to be reused during multiple statement executions. If you execute a prepared statement only once the two stage processing can be inefficient compared to "normal" queries because all the caching means extra work and it takes (limited) server resources to hold the cached information. Consequently, prepared statements that are executed only once may cause performance hurts.
rows_fetched_from_server_normal, rows_fetched_from_server_ps | Connection | Total number of result set rows successfully fetched from MySQL regardless if the client application has consumed them or not. Some of the rows may not have been fetched by the client application but have been flushed implicitly. | See also packets_received_rset_row
rows_buffered_from_client_normal, rows_buffered_from_client_ps | Connection | Total number of successfully buffered rows originating from a "normal" query or a prepared statement. This is the number of rows that have been fetched from MySQL and buffered on client. Note that there are two distinct statistics on rows that have been buffered (MySQL to mysqlnd internal buffer) and buffered rows that have been fetched by the client application (mysqlnd internal buffer to client application). If the number of buffered rows is higher than the number of fetched buffered rows it can mean that the client application runs queries that cause larger result sets than needed resulting in rows not read by the client. | Examples of queries that will buffer results: mysqli_query(), mysqli_store_result()
rows_fetched_from_client_normal_buffered, rows_fetched_from_client_ps_buffered | Connection | Total number of rows fetched by the client from a buffered result set created by a normal query or a prepared statement.
rows_fetched_from_client_normal_unbuffered, rows_fetched_from_client_ps_unbuffered | Connection | Total number of rows fetched by the client from a unbuffered result set created by a "normal" query or a prepared statement.
rows_fetched_from_client_ps_cursor | Connection | Total number of rows fetch by the client from a cursor created by a prepared statement.
rows_skipped_normal, rows_skipped_ps | Connection | Reserved for future use (currently not supported)
copy_on_write_saved, copy_on_write_performed | Process | With mysqlnd, variables returned by the extensions point into mysqlnd internal network result buffers. If you do not change the variables, fetched data will be kept only once in memory. If you change the variables, mysqlnd has to perform a copy-on-write to protect the internal network result buffers from being changed. With the MySQL Client Library you always hold fetched data twice in memory. Once in the internal MySQL Client Library buffers and once in the variables returned by the extensions. In theory mysqlnd can save up to 40% memory. However, note that the memory saving cannot be measured using memory_get_usage().
explicit_free_result, implicit_free_result | Connection, Process (only during prepared statement cleanup) | Total number of freed result sets. | The free is always considered explicit but for result sets created by an init command, for example, mysqli_options(MYSQLI_INIT_COMMAND , ...)
proto_text_fetched_null, proto_text_fetched_bit, proto_text_fetched_tinyint proto_text_fetched_short, proto_text_fetched_int24, proto_text_fetched_int proto_text_fetched_bigint, proto_text_fetched_decimal, proto_text_fetched_float proto_text_fetched_double, proto_text_fetched_date, proto_text_fetched_year proto_text_fetched_time, proto_text_fetched_datetime, proto_text_fetched_timestamp proto_text_fetched_string, proto_text_fetched_blob, proto_text_fetched_enum proto_text_fetched_set, proto_text_fetched_geometry, proto_text_fetched_other Connection Total number of columns of a certain type fetched from a normal query (MySQL text protocol). Mapping from C API / MySQL meta data type to statistics name:

  • MYSQL_TYPE_NULL - proto_text_fetched_null

  • MYSQL_TYPE_BIT - proto_text_fetched_bit

  • MYSQL_TYPE_TINY - proto_text_fetched_tinyint

  • MYSQL_TYPE_SHORT - proto_text_fetched_short

  • MYSQL_TYPE_INT24 - proto_text_fetched_int24

  • MYSQL_TYPE_LONG - proto_text_fetched_int

  • MYSQL_TYPE_LONGLONG - proto_text_fetched_bigint

  • MYSQL_TYPE_DECIMAL, MYSQL_TYPE_NEWDECIMAL - proto_text_fetched_decimal

  • MYSQL_TYPE_FLOAT - proto_text_fetched_float

  • MYSQL_TYPE_DOUBLE - proto_text_fetched_double

  • MYSQL_TYPE_DATE, MYSQL_TYPE_NEWDATE - proto_text_fetched_date

  • MYSQL_TYPE_YEAR - proto_text_fetched_year

  • MYSQL_TYPE_TIME - proto_text_fetched_time

  • MYSQL_TYPE_DATETIME - proto_text_fetched_datetime

  • MYSQL_TYPE_TIMESTAMP - proto_text_fetched_timestamp

  • MYSQL_TYPE_STRING, MYSQL_TYPE_VARSTRING, MYSQL_TYPE_VARCHAR - proto_text_fetched_string

  • MYSQL_TYPE_TINY_BLOB, MYSQL_TYPE_MEDIUM_BLOB, MYSQL_TYPE_LONG_BLOB, MYSQL_TYPE_BLOB - proto_text_fetched_blob

  • MYSQL_TYPE_ENUM - proto_text_fetched_enum

  • MYSQL_TYPE_SET - proto_text_fetched_set

  • MYSQL_TYPE_GEOMETRY - proto_text_fetched_geometry

  • Any MYSQL_TYPE_* not listed before (there should be none) - proto_text_fetched_other

Note that the MYSQL_*-type constants may not be associated with the very same SQL column types in every version of MySQL.

proto_binary_fetched_null, proto_binary_fetched_bit, proto_binary_fetched_tinyint proto_binary_fetched_short, proto_binary_fetched_int24, proto_binary_fetched_int, proto_binary_fetched_bigint, proto_binary_fetched_decimal, proto_binary_fetched_float, proto_binary_fetched_double, proto_binary_fetched_date, proto_binary_fetched_year, proto_binary_fetched_time, proto_binary_fetched_datetime, proto_binary_fetched_timestamp, proto_binary_fetched_string, proto_binary_fetched_blob, proto_binary_fetched_enum, proto_binary_fetched_set, proto_binary_fetched_geometry, proto_binary_fetched_other | Connection | Total number of columns of a certain type fetched from a prepared statement (MySQL binary protocol). | For type mapping see proto_text_* described in the preceding text.
Returned mysqlnd statistics: Connection
Statistic | Scope | Description | Notes
connect_success, connect_failure | Connection | Total number of successful / failed connection attempt. | Reused connections and all other kinds of connections are included.
reconnect | Process | Total number of (real_)connect attempts made on an already opened connection handle. | The code sequence $link = new mysqli(...); $link->real_connect(...) will cause a reconnect. But $link = new mysqli(...); $link->connect(...) will not because $link->connect(...) will explicitly close the existing connection before a new connection is established.
pconnect_success | Connection | Total number of successful persistent connection attempts. | Note that connect_success holds the sum of successful persistent and non-persistent connection attempts. The number of successful non-persistent connection attempts is connect_success - pconnect_success.
active_connections | Connection | Total number of active persistent and non-persistent connections.
active_persistent_connections | Connection | Total number of active persistent connections. | The total number of active non-persistent connections is active_connections - active_persistent_connections.
explicit_close Connection Total number of explicitly closed connections (ext/mysqli only). Examples of code snippets that cause an explicit close :
$link = new mysqli(...); $link->close(...)
$link = new mysqli(...); $link->connect(...)
implicit_close Connection Total number of implicitly closed connections (ext/mysqli only). Examples of code snippets that cause an implicit close :

  • $link = new mysqli(...); $link->real_connect(...)

  • unset($link)

  • Persistent connection: pooled connection has been created with real_connect and there may be unknown options set - close implicitly to avoid returning a connection with unknown options

  • Persistent connection: ping/change_user fails and ext/mysqli closes the connection

  • end of script execution: close connections that have not been closed by the user

disconnect_close | Connection | Connection failures indicated by the C API call mysql_real_connect() during an attempt to establish a connection. | It is called disconnect_close because the connection handle passed to the C API call will be closed.
in_middle_of_command_close | Process | A connection has been closed in the middle of a command execution (outstanding result sets not fetched, after sending a query and before retrieving an answer, while fetching data, while transferring data with LOAD DATA). | Unless you use asynchronous queries this should only happen if your script stops unexpectedly and PHP shuts down the connections for you.
init_command_executed_count | Connection | Total number of init command executions, for example, mysqli_options(MYSQLI_INIT_COMMAND , ...). | The number of successful executions is init_command_executed_count - init_command_failed_count.
init_command_failed_count | Connection | Total number of failed init commands.
Returned mysqlnd statistics: COM_* Command
Statistic Scope Description Notes
com_quit, com_init_db, com_query, com_field_list, com_create_db, com_drop_db, com_refresh, com_shutdown, com_statistics, com_process_info, com_connect, com_process_kill, com_debug, com_ping, com_time, com_delayed_insert, com_change_user, com_binlog_dump, com_table_dump, com_connect_out, com_register_slave, com_stmt_prepare, com_stmt_execute, com_stmt_send_long_data, com_stmt_close, com_stmt_reset, com_stmt_set_option, com_stmt_fetch, com_daemon Connection Total number of attempts to send a certain COM_* command from PHP to MySQL.

The statistics are incremented after checking the line and immediately before sending the corresponding MySQL client server protocol packet. If mysqlnd fails to send the packet over the wire the statistics will not be decremented. In case of a failure mysqlnd emits a PHP warning "Error while sending %s packet. PID=%d."

Usage examples:

  • Check if PHP sends certain commands to MySQL, for example, check if a client sends COM_PROCESS_KILL

  • Calculate the average number of prepared statement executions by comparing COM_EXECUTE with COM_PREPARE

  • Check if PHP has run any non-prepared SQL statements by checking if COM_QUERY is zero

  • Identify PHP scripts that run an excessive number of SQL statements by checking COM_QUERY and COM_EXECUTE

Miscellaneous

Returned mysqlnd statistics: Miscellaneous
Statistic | Scope | Description | Notes
explicit_stmt_close, implicit_stmt_close | Process | Total number of close prepared statements. | A close is always considered explicit but for a failed prepare.
mem_emalloc_count, mem_emalloc_ammount, mem_ecalloc_count, mem_ecalloc_ammount, mem_erealloc_count, mem_erealloc_ammount, mem_efree_count, mem_malloc_count, mem_malloc_ammount, mem_calloc_count, mem_calloc_ammount, mem_realloc_count, mem_realloc_ammount, mem_free_count | Process | Memory management calls. | Development only.
command_buffer_too_small Connection Number of network command buffer extensions while sending commands from PHP to MySQL.

mysqlnd allocates an internal command/network buffer of mysqlnd.net_cmd_buffer_size (php.ini) bytes for every connection. If a MySQL Client Server protocol command, for example, COM_QUERY (normal query), does not fit into the buffer, mysqlnd will grow the buffer to what is needed for sending the command. Whenever the buffer gets extended for one connection command_buffer_too_small will be incremented by one.

If mysqlnd has to grow the buffer beyond its initial size of mysqlnd.net_cmd_buffer_size (php.ini) bytes for almost every connection, you should consider to increase the default size to avoid re-allocations.

The default buffer size is 2048 bytes in PHP 5.3.0. In future versions the default will be 4kB or larger. The default can changed either through the php.ini setting mysqlnd.net_cmd_buffer_size or using mysqli_options(MYSQLI_OPT_NET_CMD_BUFFER_SIZE, int size).

It is recommended to set the buffer size to no less than 4096 bytes because mysqlnd also uses it when reading certain communication packet from MySQL. In PHP 5.3.0, mysqlnd will not grow the buffer if MySQL sends a packet that is larger than the current size of the buffer. As a consequence mysqlnd is unable to decode the packet and the client application will get an error. There are only two situations when the packet can be larger than the 2048 bytes default of mysqlnd.net_cmd_buffer_size in PHP 5.3.0: the packet transports a very long error message or the packet holds column meta data from COM_LIST_FIELD (mysql_list_fields()) and the meta data comes from a string column with a very long default value (>1900 bytes). No bug report on this exists - it should happen rarely.

As of PHP 5.3.2 mysqlnd does not allow setting buffers smaller than 4096 bytes.

connection_reused
Persistent Connections
Notes
Mysqlnd


Notes

This section provides a collection of miscellaneous notes on MySQL Native Driver usage.

  • Using mysqlnd means using PHP streams for underlying connectivity. For mysqlnd, the PHP streams documentation (Akımlar) should be consulted on such details as timeout settings, not the documentation for the MySQL Client Library.

Statistics
Memory management
Mysqlnd


Memory management

Introduction

The MySQL Native Driver manages memory different than the MySQL Client Library. The libraries differ in the way memory is allocated and released, how memory is allocated in chunks while reading results from MySQL, which debug and development options exist, and how results read from MySQL are linked to PHP user variables.

The following notes are intended as an introduction and summary to users interested at understanding the MySQL Native Driver at the C code level.

Memory management functions used

All memory allocation and deallocation is done using the PHP memory management functions. Therefore, the memory consumption of mysqlnd can be tracked using PHP API calls, such as memory_get_usage(). Because memory is allocated and released using the PHP memory management, the changes may not immediately become visible at the operating system level. The PHP memory management acts as a proxy which may delay releasing memory towards the system. Due to this, comparing the memory usage of the MySQL Native Driver and the MySQL Client Library is difficult. The MySQL Client Library is using the operating system memory management calls directly, hence the effects can be observed immediately at the operating system level.

Any memory limit enforced by PHP also affects the MySQL Native Driver. This may cause out of memory errors when fetching large result sets that exceed the size of the remaining memory made available by PHP. Because the MySQL Client Library is not using PHP memory management functions, it does not comply to any PHP memory limit set. If using the MySQL Client Library, depending on the deployment model, the memory footprint of the PHP process may grow beyond the PHP memory limit. But also PHP scripts may be able to process larger result sets as parts of the memory allocated to hold the result sets are beyond the control of the PHP engine.

PHP memory management functions are invoked by the MySQL Native Driver through a lightweight wrapper. Among others, the wrapper makes debugging easier.

Handling of result sets

The various MySQL Server and the various client APIs differentiate between buffered and unbuffered result sets. Unbuffered result sets are transferred row-by-row from MySQL to the client as the client iterates over the results. Buffered results are fetched in their entirety by the client library before passing them on to the client.

The MySQL Native Driver is using PHP Streams for the network communication with the MySQL Server. Results sent by MySQL are fetched from the PHP Streams network buffers into the result buffer of mysqlnd. The result buffer is made of zvals. In a second step the results are made available to the PHP script. This final transfer from the result buffer into PHP variables impacts the memory consumption and is mostly noticible when using buffered result sets.

By default the MySQL Native Driver tries to avoid holding buffered results twice in memory. Results are kept only once in the internal result buffers and their zvals. When results are fetched into PHP variables by the PHP script, the variables will reference the internal result buffers. Database query results are not copied and kept in memory only once. Should the user modify the contents of a variable holding the database results a copy-on-write must be performed to avoid changing the referenced internal result buffer. The contents of the buffer must not be modified because the user may decide to read the result set a second time. The copy-on-write mechanism is implemented using an additional reference management list and the use of standard zval reference counters. Copy-on-write must also be done if the user reads a result set into PHP variables and frees a result set before the variables are unset.

Generally speaking, this pattern works well for scripts that read a result set once and do not modify variables holding results. Its major drawback is the memory overhead caused by the additional reference management which comes primarily from the fact that user variables holding results cannot be entirely released until the mysqlnd reference management stops referencing them. The MySQL Native driver removes the reference to the user variables when the result set is freed or a copy-on-write is performed. An observer will see the total memory consumption grow until the result set is released. Use the statistics to check whether a script does release result sets explicitly or the driver is does implicit releases and thus memory is used for a time longer than necessary. Statistics also help to see how many copy-on-write operations happened.

A PHP script reading many small rows of a buffered result set using a code snippet equal or equivalent to while ($row = $res->fetch_assoc()) { ... } may optimize memory consumption by requesting copies instead of references. Albeit requesting copies means keeping results twice in memory, it allows PHP to free the copy contained in $row as the result set is being iterated and prior to releasing the result set itself. On a loaded server optimizing peak memory usage may help improving the overall system performace although for an individual script the copy approach may be slower due to additional allocations and memory copy operations.

The copy mode can be enforced by setting mysqlnd.fetch_data_copy=1.

Monitoring and debugging

There are multiple ways of tracking the memory usage of the MySQL Native Driver. If the goal is to get a quick high level overview or to verify the memory efficiency of PHP scripts, then check the statistics collected by the library. The statistics allow you, for example, to catch SQL statements which generate more results than are processed by a PHP script.

The debug trace log can be configured to record memory management calls. This helps to see when memory is allocated or free'd. However, the size of the requested memory chunks may not be listed.

Some, recent versions of the MySQL Native Driver feature the emulation of random out of memory situations. This feature is meant to be used by the C developers of the library or mysqlnd plugin authors only. Please, search the source code for corresponding PHP configuration settings and further details. The feature is considered private and may be modified at any time without prior notice.

Notes
MySQL Native Driver Plugin API
Mysqlnd


MySQL Native Driver Plugin API

İçindekiler

  • A comparison of mysqlnd plugins with MySQL Proxy
  • Obtaining the mysqlnd plugin API
  • MySQL Native Driver Plugin Architecture
  • The mysqlnd plugin API
  • Getting started building a mysqlnd plugin

The MySQL Native Driver Plugin API is a feature of MySQL Native Driver, or mysqlnd. Mysqlnd plugins operate in the layer between PHP applications and the MySQL server. This is comparable to MySQL Proxy. MySQL Proxy operates on a layer between any MySQL client application, for example, a PHP application and, the MySQL server. Mysqlnd plugins can undertake typical MySQL Proxy tasks such as load balancing, monitoring and performance optimizations. Due to the different architecture and location, mysqlnd plugins do not have some of MySQL Proxy's disadvantages. For example, with plugins, there is no single point of failure, no dedicated proxy server to deploy, and no new programming language to learn (Lua).

A mysqlnd plugin can be thought of as an extension to mysqlnd. Plugins can intercept the majority of mysqlnd functions. The mysqlnd functions are called by the PHP MySQL extensions such as ext/mysql, ext/mysqli, and PDO_MYSQL. As a result, it is possible for a mysqlnd plugin to intercept all calls made to these extensions from the client application.

Internal mysqlnd function calls can also be intercepted, or replaced. There are no restrictions on manipulating mysqlnd internal function tables. It is possible to set things up so that when certain mysqlnd functions are called by the extensions that use mysqlnd, the call is directed to the appropriate function in the mysqlnd plugin. The ability to manipulate mysqlnd internal function tables in this way allows maximum flexibility for plugins.

Mysqlnd plugins are in fact PHP Extensions, written in C, that use the mysqlnd plugin API (which is built into MySQL Native Driver, mysqlnd). Plugins can be made 100% transparent to PHP applications. No application changes are needed because plugins operate on a different layer. The mysqlnd plugin can be thought of as operating in a layer below mysqlnd.

The following list represents some possible applications of mysqlnd plugins.

  • Load Balancing

    • Read/Write Splitting. An example of this is the PECL/mysqlnd_ms (Master Slave) extension. This extension splits read/write queries for a replication setup.

    • Failover

    • Round-Robin, least loaded

  • Monitoring

    • Query Logging

    • Query Analysis

    • Query Auditing. An example of this is the PECL/mysqlnd_sip (SQL Injection Protection) extension. This extension inspects queries and executes only those that are allowed according to a ruleset.

  • Performance

    • Caching. An example of this is the PECL/mysqlnd_qc (Query Cache) extension.

    • Throttling

    • Sharding. An example of this is the PECL/mysqlnd_mc (Multi Connect) extension. This extension will attempt to split a SELECT statement into n-parts, using SELECT ... LIMIT part_1, SELECT LIMIT part_n. It sends the queries to distinct MySQL servers and merges the result at the client.

MySQL Native Driver Plugins Available

There are a number of mysqlnd plugins already available. These include:

  • PECL/mysqlnd_mc - Multi Connect plugin.

  • PECL/mysqlnd_ms - Master Slave plugin.

  • PECL/mysqlnd_qc - Query Cache plugin.

  • PECL/mysqlnd_pscache - Prepared Statement Handle Cache plugin.

  • PECL/mysqlnd_sip - SQL Injection Protection plugin.

  • PECL/mysqlnd_uh - User Handler plugin.

Memory management
A comparison of mysqlnd plugins with MySQL Proxy
Mysqlnd


A comparison of mysqlnd plugins with MySQL Proxy

Mysqlnd plugins and MySQL Proxy are different technologies using different approaches. Both are valid tools for solving a variety of common tasks such as load balancing, monitoring, and performance enhancements. An important difference is that MySQL Proxy works with all MySQL clients, whereas mysqlnd plugins are specific to PHP applications.

As a PHP Extension, a mysqlnd plugin gets installed on the PHP application server, along with the rest of PHP. MySQL Proxy can either be run on the PHP application server or can be installed on a dedicated machine to handle multiple PHP application servers.

Deploying MySQL Proxy on the application server has two advantages:

  1. No single point of failure

  2. Easy to scale out (horizontal scale out, scale by client)

MySQL Proxy (and mysqlnd plugins) can solve problems easily which otherwise would have required changes to existing applications.

However, MySQL Proxy does have some disadvantages:

  • MySQL Proxy is a new component and technology to master and deploy.

  • MySQL Proxy requires knowledge of the Lua scripting language.

MySQL Proxy can be customized with C and Lua programming. Lua is the preferred scripting language of MySQL Proxy. For most PHP experts Lua is a new language to learn. A mysqlnd plugin can be written in C. It is also possible to write plugins in PHP using » PECL/mysqlnd_uh.

MySQL Proxy runs as a daemon - a background process. MySQL Proxy can recall earlier decisions, as all state can be retained. However, a mysqlnd plugin is bound to the request-based lifecycle of PHP. MySQL Proxy can also share one-time computed results among multiple application servers. A mysqlnd plugin would need to store data in a persistent medium to be able to do this. Another daemon would need to be used for this purpose, such as Memcache. This gives MySQL Proxy an advantage in this case.

MySQL Proxy works on top of the wire protocol. With MySQL Proxy you have to parse and reverse engineer the MySQL Client Server Protocol. Actions are limited to those that can be achieved by manipulating the communication protocol. If the wire protocol changes (which happens very rarely) MySQL Proxy scripts would need to be changed as well.

Mysqlnd plugins work on top of the C API, which mirrors the libmysqlclient client and Connector/C APIs. This C API is basically a wrapper around the MySQL Client Server protocol, or wire protocol, as it is sometimes called. You can intercept all C API calls. PHP makes use of the C API, therefore you can hook all PHP calls, without the need to program at the level of the wire protocol.

Mysqlnd implements the wire protocol. Plugins can therefore parse, reverse engineer, manipulate and even replace the communication protocol. However, this is usually not required.

As plugins allow you to create implementations that use two levels (C API and wire protocol), they have greater flexibility than MySQL Proxy. If a mysqlnd plugin is implemented using the C API, any subsequent changes to the wire protocol do not require changes to the plugin itself.

MySQL Native Driver Plugin API
Obtaining the mysqlnd plugin API
MySQL Native Driver Plugin API


Obtaining the mysqlnd plugin API

The mysqlnd plugin API is simply part of the MySQL Native Driver PHP extension, ext/mysqlnd. Development started on the mysqlnd plugin API in December 2009. It is developed as part of the PHP source repository, and as such is available to the public either via Git, or through source snapshot downloads.

The following table shows PHP versions and the corresponding mysqlnd version contained within.

The bundled mysqlnd version per PHP release
PHP Version | MySQL Native Driver version
5.3.0 | 5.0.5
5.3.1 | 5.0.5
5.3.2 | 5.0.7
5.3.3 | 5.0.7
5.3.4 | 5.0.7

Plugin developers can determine the mysqlnd version through accessing MYSQLND_VERSION, which is a string of the format "mysqlnd 5.0.7-dev - 091210 - $Revision: 300535", or through MYSQLND_VERSION_ID, which is an integer such as 50007. Developers can calculate the version number as follows:

MYSQLND_VERSION_ID calculation table
Version (part) | Example
Major*10000 | 5*10000 = 50000
Minor*100 | 0*100 = 0
Patch | 7 = 7
MYSQLND_VERSION_ID | 50007

During development, developers should refer to the mysqlnd version number for compatibility and version tests, as several iterations of mysqlnd could occur during the lifetime of a PHP development branch with a single PHP version number.

A comparison of mysqlnd plugins with MySQL Proxy
MySQL Native Driver Plugin Architecture
MySQL Native Driver Plugin API


MySQL Native Driver Plugin Architecture

This section provides an overview of the mysqlnd plugin architecture.

MySQL Native Driver Overview

Before developing mysqlnd plugins, it is useful to know a little of how mysqlnd itself is organized. Mysqlnd consists of the following modules:

The mysqlnd organization chart, per module
Modules Statistics | mysqlnd_statistics.c
Connection | mysqlnd.c
Resultset | mysqlnd_result.c
Resultset Metadata | mysqlnd_result_meta.c
Statement | mysqlnd_ps.c
Network | mysqlnd_net.c
Wire protocol | mysqlnd_wireprotocol.c

C Object Oriented Paradigm

At the code level, mysqlnd uses a C pattern for implementing object orientation.

In C you use a struct to represent an object. Members of the struct represent object properties. Struct members pointing to functions represent methods.

Unlike with other languages such as C++ or Java, there are no fixed rules on inheritance in the C object oriented paradigm. However, there are some conventions that need to be followed that will be discussed later.

The PHP Life Cycle

When considering the PHP life cycle there are two basic cycles:

  • PHP engine startup and shutdown cycle

  • Request cycle

When the PHP engine starts up it will call the module initialization (MINIT) function of each registered extension. This allows each module to setup variables and allocate resources that will exist for the lifetime of the PHP engine process. When the PHP engine shuts down it will call the module shutdown (MSHUTDOWN) function of each extension.

During the lifetime of the PHP engine it will receive a number of requests. Each request constitutes another life cycle. On each request the PHP engine will call the request initialization function of each extension. The extension can perform any variable setup and resource allocation required for request processing. As the request cycle ends the engine calls the request shutdown (RSHUTDOWN) function of each extension so the extension can perform any cleanup required.

How a plugin works

A mysqlnd plugin works by intercepting calls made to mysqlnd by extensions that use mysqlnd. This is achieved by obtaining the mysqlnd function table, backing it up, and replacing it by a custom function table, which calls the functions of the plugin as required.

The following code shows how the mysqlnd function table is replaced:

/* a place to store original function table */
struct st_mysqlnd_conn_methods org_methods;

void minit_register_hooks(TSRMLS_D) {
  /* active function table */
  struct st_mysqlnd_conn_methods * current_methods
    = mysqlnd_conn_get_methods();

  /* backup original function table */
  memcpy(&org_methods, current_methods,
    sizeof(struct st_mysqlnd_conn_methods);

  /* install new methods */
  current_methods->query = MYSQLND_METHOD(my_conn_class, query);
}

Connection function table manipulations must be done during Module Initialization (MINIT). The function table is a global shared resource. In an multi-threaded environment, with a TSRM build, the manipulation of a global shared resource during the request processing will almost certainly result in conflicts.

Bilginize:

Do not use any fixed-size logic when manipulating the mysqlnd function table: new methods may be added at the end of the function table. The function table may change at any time in the future.

Calling parent methods

If the original function table entries are backed up, it is still possible to call the original function table entries - the parent methods.

In some cases, such as for Connection::stmt_init(), it is vital to call the parent method prior to any other activity in the derived method.

MYSQLND_METHOD(my_conn_class, query)(MYSQLND *conn,
  const char *query, unsigned int query_len TSRMLS_DC) {

  php_printf("my_conn_class::query(query = %s)\n", query);

  query = "SELECT 'query rewritten' FROM DUAL";
  query_len = strlen(query);

  return org_methods.query(conn, query, query_len); /* return with call to parent */
}

Extending properties

A mysqlnd object is represented by a C struct. It is not possible to add a member to a C struct at run time. Users of mysqlnd objects cannot simply add properties to the objects.

Arbitrary data (properties) can be added to a mysqlnd objects using an appropriate function of the mysqlnd_plugin_get_plugin_<object>_data() family. When allocating an object mysqlnd reserves space at the end of the object to hold a void * pointer to arbitrary data. mysqlnd reserves space for one void * pointer per plugin.

The following table shows how to calculate the position of the pointer for a specific plugin:

Pointer calculations for mysqlnd
Memory address | Contents
0 | Beginning of the mysqlnd object C struct
n | End of the mysqlnd object C struct
n + (m x sizeof(void*)) | void* to object data of the m-th plugin

If you plan to subclass any of the mysqlnd object constructors, which is allowed, you must keep this in mind!

The following code shows extending properties:

/* any data we want to associate */
typedef struct my_conn_properties {
  unsigned long query_counter;
} MY_CONN_PROPERTIES;

/* plugin id */
unsigned int my_plugin_id;

void minit_register_hooks(TSRMLS_D) {
  /* obtain unique plugin ID */
  my_plugin_id = mysqlnd_plugin_register();
  /* snip - see Extending Connection: methods */
}

static MY_CONN_PROPERTIES** get_conn_properties(const MYSQLND *conn TSRMLS_DC) {
  MY_CONN_PROPERTIES** props;
  props = (MY_CONN_PROPERTIES**)mysqlnd_plugin_get_plugin_connection_data(
    conn, my_plugin_id);
  if (!props || !(*props)) {
    *props = mnd_pecalloc(1, sizeof(MY_CONN_PROPERTIES), conn->persistent);
    (*props)->query_counter = 0;
  }
  return props;
}

The plugin developer is responsible for the management of plugin data memory.

Use of the mysqlnd memory allocator is recommended for plugin data. These functions are named using the convention: mnd_*loc(). The mysqlnd allocator has some useful features, such as the ability to use a debug allocator in a non-debug build.

When and how to subclass
 | When to subclass? | Each instance has its own private function table? | How to subclass?
Connection (MYSQLND) | MINIT | No | mysqlnd_conn_get_methods()
Resultset (MYSQLND_RES) | MINIT or later | Yes | mysqlnd_result_get_methods() or object method function table manipulation
Resultset Meta (MYSQLND_RES_METADATA) | MINIT | No | mysqlnd_result_metadata_get_methods()
Statement (MYSQLND_STMT) | MINIT | No | mysqlnd_stmt_get_methods()
Network (MYSQLND_NET) | MINIT or later | Yes | mysqlnd_net_get_methods() or object method function table manipulation
Wire protocol (MYSQLND_PROTOCOL) | MINIT or later | Yes | mysqlnd_protocol_get_methods() or object method function table manipulation

You must not manipulate function tables at any time later than MINIT if it is not allowed according to the above table.

Some classes contain a pointer to the method function table. All instances of such a class will share the same function table. To avoid chaos, in particular in threaded environments, such function tables must only be manipulated during MINIT.

Other classes use copies of a globally shared function table. The class function table copy is created together with the object. Each object uses its own function table. This gives you two options: you can manipulate the default function table of an object at MINIT, and you can additionally refine methods of an object without impacting other instances of the same class.

The advantage of the shared function table approach is performance. There is no need to copy a function table for each and every object.

Constructor status
Allocation, construction, reset | Can be modified? | Caller
Connection (MYSQLND) | mysqlnd_init() | No | mysqlnd_connect()
Resultset(MYSQLND_RES)

Allocation:

  • Connection::result_init()

Reset and re-initialized during:

  • Result::use_result()

  • Result::store_result

Yes, but call parent!

  • Connection::list_fields()

  • Statement::get_result()

  • Statement::prepare() (Metadata only)

  • Statement::resultMetaData()

Resultset Meta (MYSQLND_RES_METADATA) | Connection::result_meta_init() | Yes, but call parent! | Result::read_result_metadata()
Statement (MYSQLND_STMT) | Connection::stmt_init() | Yes, but call parent! | Connection::stmt_init()
Network (MYSQLND_NET) | mysqlnd_net_init() | No | Connection::init()
Wire protocol (MYSQLND_PROTOCOL) | mysqlnd_protocol_init() | No | Connection::init()

It is strongly recommended that you do not entirely replace a constructor. The constructors perform memory allocations. The memory allocations are vital for the mysqlnd plugin API and the object logic of mysqlnd. If you do not care about warnings and insist on hooking the constructors, you should at least call the parent constructor before doing anything in your constructor.

Regardless of all warnings, it can be useful to subclass constructors. Constructors are the perfect place for modifying the function tables of objects with non-shared object tables, such as Resultset, Network, Wire Protocol.

Destruction status
 | Derived method must call parent? | Destructor
Connection | yes, after method execution | free_contents(), end_psession()
Resultset | yes, after method execution | free_result()
Resultset Meta | yes, after method execution | free()
Statement | yes, after method execution | dtor(), free_stmt_content()
Network | yes, after method execution | free()
Wire protocol | yes, after method execution | free()

The destructors are the appropriate place to free properties, mysqlnd_plugin_get_plugin_<object>_data().

The listed destructors may not be equivalent to the actual mysqlnd method freeing the object itself. However, they are the best possible place for you to hook in and free your plugin data. As with constructors you may replace the methods entirely but this is not recommended. If multiple methods are listed in the above table you will need to hook all of the listed methods and free your plugin data in whichever method is called first by mysqlnd.

The recommended method for plugins is to simply hook the methods, free your memory and call the parent implementation immediately following this.

Dikkat

Due to a bug in PHP versions 5.3.0 to 5.3.3, plugins do not associate plugin data with a persistent connection. This is because ext/mysql and ext/mysqli do not trigger all the necessary mysqlnd end_psession() method calls and the plugin may therefore leak memory. This has been fixed in PHP 5.3.4.

Obtaining the mysqlnd plugin API
The mysqlnd plugin API
MySQL Native Driver Plugin API


The mysqlnd plugin API

The following is a list of functions provided in the mysqlnd plugin API:

  • mysqlnd_plugin_register()

  • mysqlnd_plugin_count()

  • mysqlnd_plugin_get_plugin_connection_data()

  • mysqlnd_plugin_get_plugin_result_data()

  • mysqlnd_plugin_get_plugin_stmt_data()

  • mysqlnd_plugin_get_plugin_net_data()

  • mysqlnd_plugin_get_plugin_protocol_data()

  • mysqlnd_conn_get_methods()

  • mysqlnd_result_get_methods()

  • mysqlnd_result_meta_get_methods()

  • mysqlnd_stmt_get_methods()

  • mysqlnd_net_get_methods()

  • mysqlnd_protocol_get_methods()

There is no formal definition of what a plugin is and how a plugin mechanism works.

Components often found in plugins mechanisms are:

  • A plugin manager

  • A plugin API

  • Application services (or modules)

  • Application service APIs (or module APIs)

The mysqlnd plugin concept employs these features, and additionally enjoys an open architecture.

No Restrictions

A plugin has full access to the inner workings of mysqlnd. There are no security limits or restrictions. Everything can be overwritten to implement friendly or hostile algorithms. It is recommended you only deploy plugins from a trusted source.

As discussed previously, plugins can use pointers freely. These pointers are not restricted in any way, and can point into another plugin's data. Simple offset arithmetic can be used to read another plugin's data.

It is recommended that you write cooperative plugins, and that you always call the parent method. The plugins should always cooperate with mysqlnd itself.

Issues: an example of chaining and cooperation
Extension | mysqlnd.query() pointer | call stack if calling parent
ext/mysqlnd | mysqlnd.query() | mysqlnd.query
ext/mysqlnd_cache mysqlnd_cache.query()

  1. mysqlnd_cache.query()

  2. mysqlnd.query

ext/mysqlnd_monitor mysqlnd_monitor.query()

  1. mysqlnd_monitor.query()

  2. mysqlnd_cache.query()

  3. mysqlnd.query

In this scenario, a cache (ext/mysqlnd_cache) and a monitor (ext/mysqlnd_monitor) plugin are loaded. Both subclass Connection::query(). Plugin registration happens at MINIT using the logic shown previously. PHP calls extensions in alphabetical order by default. Plugins are not aware of each other and do not set extension dependencies.

By default the plugins call the parent implementation of the query method in their derived version of the method.

PHP Extension Recap

This is a recap of what happens when using an example plugin, ext/mysqlnd_plugin, which exposes the mysqlnd C plugin API to PHP:

  • Any PHP MySQL application tries to establish a connection to 192.168.2.29

  • The PHP application will either use ext/mysql, ext/mysqli or PDO_MYSQL. All three PHP MySQL extensions use mysqlnd to establish the connection to 192.168.2.29.

  • Mysqlnd calls its connect method, which has been subclassed by ext/mysqlnd_plugin.

  • ext/mysqlnd_plugin calls the userspace hook proxy::connect() registered by the user.

  • The userspace hook changes the connection host IP from 192.168.2.29 to 127.0.0.1 and returns the connection established by parent::connect().

  • ext/mysqlnd_plugin performs the equivalent of parent::connect(127.0.0.1) by calling the original mysqlnd method for establishing a connection.

  • ext/mysqlnd establishes a connection and returns to ext/mysqlnd_plugin. ext/mysqlnd_plugin returns as well.

  • Whatever PHP MySQL extension had been used by the application, it receives a connection to 127.0.0.1. The PHP MySQL extension itself returns to the PHP application. The circle is closed.

MySQL Native Driver Plugin Architecture
Getting started building a mysqlnd plugin
MySQL Native Driver Plugin API


Getting started building a mysqlnd plugin

It is important to remember that a mysqlnd plugin is itself a PHP extension.

The following code shows the basic structure of the MINIT function that will be used in the typical mysqlnd plugin:

/* my_php_mysqlnd_plugin.c */

 static PHP_MINIT_FUNCTION(mysqlnd_plugin) {
  /* globals, ini entries, resources, classes */

  /* register mysqlnd plugin */
  mysqlnd_plugin_id = mysqlnd_plugin_register();

  conn_m = mysqlnd_get_conn_methods();
  memcpy(org_conn_m, conn_m,
    sizeof(struct st_mysqlnd_conn_methods));

  conn_m->query = MYSQLND_METHOD(mysqlnd_plugin_conn, query);
  conn_m->connect = MYSQLND_METHOD(mysqlnd_plugin_conn, connect);
}

/* my_mysqlnd_plugin.c */

 enum_func_status MYSQLND_METHOD(mysqlnd_plugin_conn, query)(/* ... */) {
  /* ... */
}
enum_func_status MYSQLND_METHOD(mysqlnd_plugin_conn, connect)(/* ... */) {
  /* ... */
}

Task analysis: from C to userspace

 class proxy extends mysqlnd_plugin_connection {
  public function connect($host, ...) { .. }
}
mysqlnd_plugin_set_conn_proxy(new proxy());

Process:

  1. PHP: user registers plugin callback

  2. PHP: user calls any PHP MySQL API to connect to MySQL

  3. C: ext/*mysql* calls mysqlnd method

  4. C: mysqlnd ends up in ext/mysqlnd_plugin

  5. C: ext/mysqlnd_plugin

    1. Calls userspace callback

    2. Or original mysqlnd method, if userspace callback not set

You need to carry out the following:

  1. Write a class "mysqlnd_plugin_connection" in C

  2. Accept and register proxy object through "mysqlnd_plugin_set_conn_proxy()"

  3. Call userspace proxy methods from C (optimization - zend_interfaces.h)

Userspace object methods can either be called using call_user_function() or you can operate at a level closer to the Zend Engine and use zend_call_method().

Optimization: calling methods from C using zend_call_method

The following code snippet shows the prototype for the zend_call_method function, taken from zend_interfaces.h.

 ZEND_API zval* zend_call_method(
  zval **object_pp, zend_class_entry *obj_ce,
  zend_function **fn_proxy, char *function_name,
  int function_name_len, zval **retval_ptr_ptr,
  int param_count, zval* arg1, zval* arg2 TSRMLS_DC
);

Zend API supports only two arguments. You may need more, for example:

 enum_func_status (*func_mysqlnd_conn__connect)(
  MYSQLND *conn, const char *host,
  const char * user, const char * passwd,
  unsigned int passwd_len, const char * db,
  unsigned int db_len, unsigned int port,
  const char * socket, unsigned int mysql_flags TSRMLS_DC
);

To get around this problem you will need to make a copy of zend_call_method() and add a facility for additional parameters. You can do this by creating a set of MY_ZEND_CALL_METHOD_WRAPPER macros.

Calling PHP userspace

This code snippet shows the optimized method for calling a userspace function from C:

/* my_mysqlnd_plugin.c */

MYSQLND_METHOD(my_conn_class,connect)(
  MYSQLND *conn, const char *host /* ... */ TSRMLS_DC) {
  enum_func_status ret = FAIL;
  zval * global_user_conn_proxy = fetch_userspace_proxy();
  if (global_user_conn_proxy) {
    /* call userspace proxy */
    ret = MY_ZEND_CALL_METHOD_WRAPPER(global_user_conn_proxy, host, /*...*/);
  } else {
    /* or original mysqlnd method = do nothing, be transparent */
    ret = org_methods.connect(conn, host, user, passwd,
          passwd_len, db, db_len, port,
          socket, mysql_flags TSRMLS_CC);
  }
  return ret;
}

Calling userspace: simple arguments

/* my_mysqlnd_plugin.c */

 MYSQLND_METHOD(my_conn_class,connect)(
  /* ... */, const char *host, /* ...*/) {
  /* ... */
  if (global_user_conn_proxy) {
    /* ... */
    zval* zv_host;
    MAKE_STD_ZVAL(zv_host);
    ZVAL_STRING(zv_host, host, 1);
    MY_ZEND_CALL_METHOD_WRAPPER(global_user_conn_proxy, zv_retval, zv_host /*, ...*/);
    zval_ptr_dtor(&zv_host);
    /* ... */
  }
  /* ... */
}

Calling userspace: structs as arguments

/* my_mysqlnd_plugin.c */

MYSQLND_METHOD(my_conn_class, connect)(
  MYSQLND *conn, /* ...*/) {
  /* ... */
  if (global_user_conn_proxy) {
    /* ... */
    zval* zv_conn;
    ZEND_REGISTER_RESOURCE(zv_conn, (void *)conn, le_mysqlnd_plugin_conn);
    MY_ZEND_CALL_METHOD_WRAPPER(global_user_conn_proxy, zv_retval, zv_conn, zv_host /*, ...*/);
    zval_ptr_dtor(&zv_conn);
    /* ... */
  }
  /* ... */
}

The first argument of many mysqlnd methods is a C "object". For example, the first argument of the connect() method is a pointer to MYSQLND. The struct MYSQLND represents a mysqlnd connection object.

The mysqlnd connection object pointer can be compared to a standard I/O file handle. Like a standard I/O file handle a mysqlnd connection object shall be linked to the userspace using the PHP resource variable type.

From C to userspace and back

 class proxy extends mysqlnd_plugin_connection {
  public function connect($conn, $host, ...) {
    /* "pre" hook */
    printf("Connecting to host = '%s'\n", $host);
    debug_print_backtrace();
    return parent::connect($conn);
  }

  public function query($conn, $query) {
    /* "post" hook */
    $ret = parent::query($conn, $query);
    printf("Query = '%s'\n", $query);
    return $ret;
  }
}
mysqlnd_plugin_set_conn_proxy(new proxy());

PHP users must be able to call the parent implementation of an overwritten method.

As a result of subclassing it is possible to refine only selected methods and you can choose to have "pre" or "post" hooks.

Buildin class: mysqlnd_plugin_connection::connect()

/*  my_mysqlnd_plugin_classes.c */

 PHP_METHOD("mysqlnd_plugin_connection", connect) {
  /* ... simplified! ... */
  zval* mysqlnd_rsrc;
  MYSQLND* conn;
  char* host; int host_len;
  if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "rs",
    &mysqlnd_rsrc, &host, &host_len) == FAILURE) {
    RETURN_NULL();
  }
  ZEND_FETCH_RESOURCE(conn, MYSQLND* conn, &mysqlnd_rsrc, -1,
    "Mysqlnd Connection", le_mysqlnd_plugin_conn);
  if (PASS == org_methods.connect(conn, host, /* simplified! */ TSRMLS_CC))
    RETVAL_TRUE;
  else
    RETVAL_FALSE;
}
The mysqlnd plugin API
mysqlnd_ms
MySQL Native Driver Plugin API


Mysqlnd replication and load balancing plugin

  • Giriş
  • Quickstart and Examples
    • Setup
    • Running statements
    • Connection state
    • SQL Hints
    • Local transactions
    • XA/Distributed Transactions
    • Service level and consistency
    • Global transaction IDs
    • Cache integration
    • Failover
    • Partitioning and Sharding
    • MySQL Fabric
  • Concepts
    • Architecture
    • Connection pooling and switching
    • Local transaction handling
    • Error handling
    • Transient errors
    • Failover
    • Load balancing
    • Read-write splitting
    • Filter
    • Service level and consistency
    • Global transaction IDs
    • Cache integration
    • Supported clusters
    • XA/Distributed transactions
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Plugin configuration file (>=1.1.x)
  • Öntanımlı Sabitler
  • Mysqlnd_ms İşlevleri
    • mysqlnd_ms_dump_servers — Returns a list of currently configured servers
    • mysqlnd_ms_fabric_select_global — Switch to global sharding server for a given table
    • mysqlnd_ms_fabric_select_shard — Switch to shard
    • mysqlnd_ms_get_last_gtid — Returns the latest global transaction ID
    • mysqlnd_ms_get_last_used_connection — Returns an array which describes the last used connection
    • mysqlnd_ms_get_stats — Returns query distribution and connection statistics
    • mysqlnd_ms_match_wild — Finds whether a table name matches a wildcard pattern or not
    • mysqlnd_ms_query_is_select — Find whether to send the query to the master, the slave or the last used MySQL server
    • mysqlnd_ms_set_qos — Sets the quality of service needed from the cluster
    • mysqlnd_ms_set_user_pick_server — Sets a callback for user-defined read/write splitting
    • mysqlnd_ms_xa_begin — Starts a distributed/XA transaction among MySQL servers
    • mysqlnd_ms_xa_commit — Commits a distributed/XA transaction among MySQL servers
    • mysqlnd_ms_xa_gc — Garbage collects unfinished XA transactions after severe errors
    • mysqlnd_ms_xa_rollback — Rolls back a distributed/XA transaction among MySQL servers
  • Change History
    • PECL/mysqlnd_ms 1.6 series
    • PECL/mysqlnd_ms 1.5 series
    • PECL/mysqlnd_ms 1.4 series
    • PECL/mysqlnd_ms 1.3 series
    • PECL/mysqlnd_ms 1.2 series
    • PECL/mysqlnd_ms 1.1 series
    • PECL/mysqlnd_ms 1.0 series
Getting started building a mysqlnd plugin
Giriş
MySQL


Giriş

The mysqlnd replication and load balancing plugin (mysqlnd_ms) adds easy to use MySQL replication support to all PHP MySQL extensions that use mysqlnd.

As of version PHP 5.3.3 the MySQL native driver for PHP (mysqlnd) features an internal plugin C API. C plugins, such as the replication and load balancing plugin, can extend the functionality of mysqlnd.

The MySQL native driver for PHP is a C library that ships together with PHP as of PHP 5.3.0. It serves as a drop-in replacement for the MySQL Client Library (libmysqlclient). Using mysqlnd has several advantages: no extra downloads are required because it's bundled with PHP, it's under the PHP license, there is lower memory consumption in certain cases, and it contains new functionality such as asynchronous queries.

Mysqlnd plugins like mysqlnd_ms operate, for the most part, transparently from a user perspective. The replication and load balancing plugin supports all PHP applications, and all MySQL PHP extensions. It does not change existing APIs. Therefore, it can easily be used with existing PHP applications.

Key Features

The key features of PECL/mysqlnd_ms are as follows.

  • Transparent and therefore easy to use.

    • Supports all of the PHP MySQL extensions.

    • SSL support.

    • A consistent API.

    • Little to no application changes required, dependent on the required usage scenario.

    • Lazy connections: connections to master and slave servers are not opened before a SQL statement is executed.

    • Optional: automatic use of master after the first write in a web request, to lower the possible impact of replication lag.

  • Can be used with any MySQL clustering solution.

    • MySQL Replication: Read-write splitting is done by the plugin. Primary focus of the plugin.

    • MySQL Cluster: Read-write splitting can be disabled. Configuration of multiple masters possible

    • Third-party solutions: the plugin is optimized for MySQL Replication but can be used with any other kind of MySQL clustering solution.

  • Featured read-write split strategies

    • Automatic detection of SELECT.

    • Supports SQL hints to overrule automatism.

    • User-defined.

    • Can be disabled for, for example, when using synchronous clusters such as MySQL Cluster.

  • Featured load balancing strategies

    • Round Robin: choose a different slave in round-robin fashion for every slave request.

    • Random: choose a random slave for every slave request.

    • Random once (sticky): choose a random slave once to run all slave requests for the duration of a web request.

    • User-defined. The application can register callbacks with mysqlnd_ms.

    • PHP 5.4.0 or newer: transaction aware when using API calls only to control transactions.

    • Weighted load balancing: servers can be assigned different priorities, for example, to direct more requests to a powerful machine than to another less powerful machine. Or, to prefer nearby machines to reduce latency.

  • Global transaction ID

    • Client-side emulation. Makes manual master server failover and slave promotion easier with asynchronous clusters, such as MySQL Replication.

    • Support for built-in global transaction identifier feature of MySQL 5.6.5 or newer.

    • Supports using transaction ids to identify up-to-date asynchronous slaves for reading when session consistency is required. Please, note the restrictions mentioned in the manual.

    • Throttling: optionally, the plugin can wait for a slave to become "synchronous" before continuing.

  • Service and consistency levels

    • Applications can request eventual, session and strong consistency service levels for connections. Appropriate cluster nodes will be searched automatically.

    • Eventual consistent MySQL Replication slave accesses can be replaced with fast local cache accesses transparently to reduce server load.

  • Partitioning and sharding

    • Servers of a replication cluster can be organized into groups. SQL hints can be used to manually direct queries to a specific group. Grouping can be used to partition (shard) the data, or to cure the issue of hotspots with updates.

    • MySQL Replication filters are supported through the table filter.

  • MySQL Fabric

    • Experimental support for MySQL Fabric is included.

Limitations

The built-in read-write-split mechanism is very basic. Every query which starts with SELECT is considered a read request to be sent to a MySQL slave server. All other queries (such as SHOW statements) are considered as write requests that are sent to the MySQL master server. The build-in behavior can be overruled using SQL hints, or a user-defined callback function.

The read-write splitter is not aware of multi-statements. Multi-statements are considered as one statement. The decision of where to run the statement will be based on the beginning of the statement string. For example, if using mysqli_multi_query() to execute the multi-statement SELECT id FROM test ; INSERT INTO test(id) VALUES (1), the statement will be redirected to a slave server because it begins with SELECT. The INSERT statement, which is also part of the multi-statement, will not be redirected to a master server.

Bilginize:

Applications must be aware of the consequences of connection switches that are performed for load balancing purposes. Please check the documentation on connection pooling and switching, transaction handling, failover load balancing ve read-write splitting.

On the name

The shortcut mysqlnd_ms stands for mysqlnd master slave plugin. The name was chosen for a quick-and-dirty proof-of-concept. In the beginning the developers did not expect to continue using the code base.

mysqlnd_ms
Quickstart and Examples
mysqlnd_ms


Quickstart and Examples

İçindekiler

  • Setup
  • Running statements
  • Connection state
  • SQL Hints
  • Local transactions
  • XA/Distributed Transactions
  • Service level and consistency
  • Global transaction IDs
  • Cache integration
  • Failover
  • Partitioning and Sharding
  • MySQL Fabric

The mysqlnd replication load balancing plugin is easy to use. This quickstart will demo typical use-cases, and provide practical advice on getting started.

It is strongly recommended to read the reference sections in addition to the quickstart. The quickstart tries to avoid discussing theoretical concepts and limitations. Instead, it will link to the reference sections. It is safe to begin with the quickstart. However, before using the plugin in mission critical environments we urge you to read additionally the background information from the reference sections.

The focus is on using PECL mysqlnd_ms for work with an asynchronous MySQL cluster, namely MySQL replication. Generally speaking an asynchronous cluster is more difficult to use than a synchronous one. Thus, users of, for example, MySQL Cluster will find more information than needed.

Giriş
Setup
mysqlnd_ms


Setup

The plugin is implemented as a PHP extension. See also the installation instructions to install the » PECL/mysqlnd_ms extension.

Compile or configure the PHP MySQL extension (API) (mysqli, PDO_MYSQL, mysql) that you plan to use with support for the mysqlnd library. PECL/mysqlnd_ms is a plugin for the mysqlnd library. To use the plugin with any of the PHP MySQL extensions, the extension has to use the mysqlnd library.

Then, load the extension into PHP and activate the plugin in the PHP configuration file using the PHP configuration directive named mysqlnd_ms.enable.

Örnek 1 Enabling the plugin (php.ini)

mysqlnd_ms.enable=1
mysqlnd_ms.config_file=/path/to/mysqlnd_ms_plugin.ini

The plugin uses its own configuration file. Use the PHP configuration directive mysqlnd_ms.config_file to set the full file path to the plugin-specific configuration file. This file must be readable by PHP (e.g., the web server user). Please note, the configuration directive mysqlnd_ms.config_file superseeds mysqlnd_ms.ini_file since 1.4.0. It is a common pitfall to use the old, no longer available configuration directive.

Create a plugin-specific configuration file. Save the file to the path set by the PHP configuration directive mysqlnd_ms.config_file.

The plugins configuration file is JSON based. It is divided into one or more sections. Each section has a name, for example, myapp. Every section makes its own set of configuration settings.

A section must, at a minimum, list the MySQL replication master server, and set a list of slaves. The plugin supports using only one master server per section. Multi-master MySQL replication setups are not yet fully supported. Use the configuration setting master to set the hostname, and the port or socket of the MySQL master server. MySQL slave servers are configured using the slave keyword.

Örnek 2 Minimal plugin-specific configuration file (mysqlnd_ms_plugin.ini)

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": [

        ]
    }
}

Configuring a MySQL slave server list is required, although it may contain an empty list. It is recommended to always configure at least one slave server.

Server lists can use anonymous or non-anonymous syntax. Non-anonymous lists include alias names for the servers, such as master_0 for the master in the above example. The quickstart uses the more verbose non-anonymous syntax.

Örnek 3 Recommended minimal plugin-specific config (mysqlnd_ms_plugin.ini)

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.2.27",
                "port": "3306"
            }
        }
    }
}

If there are at least two servers in total, the plugin can start to load balance and switch connections. Switching connections is not always transparent and can cause issues in certain cases. The reference sections about connection pooling and switching, transaction handling, fail over load balancing and read-write splitting all provide more details. And potential pitfalls are described later in this guide.

It is the responsibility of the application to handle potential issues caused by connection switches, by configuring a master with at least one slave server, which allows switching to work therefore related problems can be found.

The MySQL master and MySQL slave servers, which you configure, do not need to be part of MySQL replication setup. For testing purpose you can use single MySQL server and make it known to the plugin as a master and slave server as shown below. This could help you to detect many potential issues with connection switches. However, such a setup will not be prone to the issues caused by replication lag.

Örnek 4 Using one server as a master and as a slave (testing only!)

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "127.0.0.1",
                "port": "3306"
            }
        }
    }
}

The plugin attempts to notify you of invalid configurations. Since 1.5.0 it will throw a warning during PHP startup if the configuration file cannot be read, is empty or parsing the JSON failed. Depending on your PHP settings those errors may appear in some log files only. Further validation is done when a connection is to be established and the configuration file is searched for valid sections. Setting mysqlnd_ms.force_config_usage may help debugging a faulty setup. Please, see also configuration file debugging notes.

Quickstart and Examples
Running statements
Quickstart and Examples


Running statements

The plugin can be used with any PHP MySQL extension (mysqli, mysql, and PDO_MYSQL) that is compiled to use the mysqlnd library. PECL/mysqlnd_ms plugs into the mysqlnd library. It does not change the API or behavior of those extensions.

Whenever a connection to MySQL is being opened, the plugin compares the host parameter value of the connect call, with the section names from the plugin specific configuration file. If, for example, the plugin specific configuration file has a section myapp then the section should be referenced by opening a MySQL connection to the host myapp

Örnek 1 Plugin specific configuration file (mysqlnd_ms_plugin.ini)

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.2.27",
                "port": "3306"
            }
        }
    }
}

Örnek 2 Opening a load balanced connection

<?php
/* Load balanced following "myapp" section rules from the plugins config file */
$mysqli = new mysqli("myapp", "username", "password", "database");
$pdo = new PDO('mysql:host=myapp;dbname=database', 'username', 'password');
$mysql = mysql_connect("myapp", "username", "password");
?>

The connection examples above will be load balanced. The plugin will send read-only statements to the MySQL slave server with the IP 192.168.2.27 and will listen on port 3306 for the MySQL client connection. All other statements will be directed to the MySQL master server running on the host localhost. If on Unix like operating systems, the master on localhost will be accepting MySQL client connections on the Unix domain socket /tmp/mysql.sock, while TCP/IP is the default port on Windows. The plugin will use the user name username and the password password to connect to any of the MySQL servers listed in the section myapp of the plugins configuration file. Upon connect, the plugin will select database as the current schemata.

The username, password and schema name are taken from the connect API calls and used for all servers. In other words: you must use the same username and password for every MySQL server listed in a plugin configuration file section. The is not a general limitation. As of PECL/mysqlnd_ms 1.1.0, it is possible to set the username and password for any server in the plugins configuration file, to be used instead of the credentials passed to the API call.

The plugin does not change the API for running statements. Read-write splitting works out of the box. The following example assumes that there is no significant replication lag between the master and the slave.

Örnek 3 Executing statements

<?php
/* Load balanced following "myapp" section rules from the plugins config file */
$mysqli = new mysqli("myapp", "username", "password", "database");
if (mysqli_connect_errno()) {
    /* Of course, your error handling is nicer... */
    die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));
}

/* Statements will be run on the master */
if (!$mysqli->query("DROP TABLE IF EXISTS test")) {
    printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
}
if (!$mysqli->query("CREATE TABLE test(id INT)")) {
    printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
}
if (!$mysqli->query("INSERT INTO test(id) VALUES (1)")) {
    printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
}

/* read-only: statement will be run on a slave */
if (!($res = $mysqli->query("SELECT id FROM test"))) {
    printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
} else {
    $row = $res->fetch_assoc();
    $res->close();
    printf("Slave returns id = '%s'\n", $row['id']);
}
$mysqli->close();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Slave returns id = '1'

Setup
Connection state
Quickstart and Examples


Connection state

The plugin changes the semantics of a PHP MySQL connection handle. A new connection handle represents a connection pool, instead of a single MySQL client-server network connection. The connection pool consists of a master connection, and optionally any number of slave connections.

Every connection from the connection pool has its own state. For example, SQL user variables, temporary tables and transactions are part of the state. For a complete list of items that belong to the state of a connection, see the connection pooling and switching concepts documentation. If the plugin decides to switch connections for load balancing, the application could be given a connection which has a different state. Applications must be made aware of this.

Örnek 1 Plugin config with one slave and one master

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.2.27",
                "port": "3306"
            }
        }
    }
}

Örnek 2 Pitfall: connection state and SQL user variables

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
if (!$mysqli) {
    /* Of course, your error handling is nicer... */
    die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));
}

/* Connection 1, connection bound SQL user variable, no SELECT thus run on master */
if (!$mysqli->query("SET @myrole='master'")) {
    printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
}

/* Connection 2, run on slave because SELECT */
if (!($res = $mysqli->query("SELECT @myrole AS _role"))) {
    printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
} else {
    $row = $res->fetch_assoc();
    $res->close();
    printf("@myrole = '%s'\n", $row['_role']);
}
$mysqli->close();
?>

Yukarıdaki örneğin çıktısı:

@myrole = ''

The example opens a load balanced connection and executes two statements. The first statement SET @myrole='master' does not begin with the string SELECT. Therefore the plugin does not recognize it as a read-only query which shall be run on a slave. The plugin runs the statement on the connection to the master. The statement sets a SQL user variable which is bound to the master connection. The state of the master connection has been changed.

The next statement is SELECT @myrole AS _role. The plugin does recognize it as a read-only query and sends it to the slave. The statement is run on a connection to the slave. This second connection does not have any SQL user variables bound to it. It has a different state than the first connection to the master. The requested SQL user variable is not set. The example script prints @myrole = ''.

It is the responsibility of the application developer to take care of the connection state. The plugin does not monitor all connection state changing activities. Monitoring all possible cases would be a very CPU intensive task, if it could be done at all.

The pitfalls can easily be worked around using SQL hints.

Running statements
SQL Hints
Quickstart and Examples


SQL Hints

SQL hints can force a query to choose a specific server from the connection pool. It gives the plugin a hint to use a designated server, which can solve issues caused by connection switches and connection state.

SQL hints are standard compliant SQL comments. Because SQL comments are supposed to be ignored by SQL processing systems, they do not interfere with other programs such as the MySQL Server, the MySQL Proxy, or a firewall.

Three SQL hints are supported by the plugin: The MYSQLND_MS_MASTER_SWITCH hint makes the plugin run a statement on the master, MYSQLND_MS_SLAVE_SWITCH enforces the use of the slave, and MYSQLND_MS_LAST_USED_SWITCH will run a statement on the same server that was used for the previous statement.

The plugin scans the beginning of a statement for the existence of an SQL hint. SQL hints are only recognized if they appear at the beginning of the statement.

Örnek 1 Plugin config with one slave and one master

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.2.27",
                "port": "3306"
            }
        }
    }
}

Örnek 2 SQL hints to prevent connection switches

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
if (mysqli_connect_errno()) {
    /* Of course, your error handling is nicer... */
    die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));
}

/* Connection 1, connection bound SQL user variable, no SELECT thus run on master */
if (!$mysqli->query("SET @myrole='master'")) {
    printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
}

/* Connection 1, run on master because of SQL hint */
if (!($res = $mysqli->query(sprintf("/*%s*/SELECT @myrole AS _role", MYSQLND_MS_LAST_USED_SWITCH)))) {
    printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
} else {
    $row = $res->fetch_assoc();
    $res->close();
    printf("@myrole = '%s'\n", $row['_role']);
}
$mysqli->close();
?>

Yukarıdaki örneğin çıktısı:

@myrole = 'master'

In the above example, using MYSQLND_MS_LAST_USED_SWITCH prevents session switching from the master to a slave when running the SELECT statement.

SQL hints can also be used to run SELECT statements on the MySQL master server. This may be desired if the MySQL slave servers are typically behind the master, but you need current data from the cluster.

In version 1.2.0 the concept of a service level has been introduced to address cases when current data is required. Using a service level requires less attention and removes the need of using SQL hints for this use case. Please, find more information below in the service level and consistency section.

Örnek 3 Fighting replication lag

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
if (!$mysqli) {
    /* Of course, your error handling is nicer... */
    die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));
}

/* Force use of master, master has always fresh and current data */
if (!$mysqli->query(sprintf("/*%s*/SELECT critical_data FROM important_table", MYSQLND_MS_MASTER_SWITCH))) {
    printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
}
?>

A use case may include the creation of tables on a slave. If an SQL hint is not given, then the plugin will send CREATE and INSERT statements to the master. Use the SQL hint MYSQLND_MS_SLAVE_SWITCH if you want to run any such statement on a slave, for example, to build temporary reporting tables.

Örnek 4 Table creation on a slave

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
if (!$mysqli) {
    /* Of course, your error handling is nicer... */
    die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));
}

/* Force use of slave */
if (!$mysqli->query(sprintf("/*%s*/CREATE TABLE slave_reporting(id INT)", MYSQLND_MS_SLAVE_SWITCH))) {
    printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
}
/* Continue using this particular slave connection */
if (!$mysqli->query(sprintf("/*%s*/INSERT INTO slave_reporting(id) VALUES (1), (2), (3)", MYSQLND_MS_LAST_USED_SWITCH))) {
    printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
}
/* Don't use MYSQLND_MS_SLAVE_SWITCH which would allow switching to another slave! */
if ($res = $mysqli->query(sprintf("/*%s*/SELECT COUNT(*) AS _num FROM slave_reporting", MYSQLND_MS_LAST_USED_SWITCH))) {
    $row = $res->fetch_assoc();
    $res->close();
    printf("There are %d rows in the table 'slave_reporting'", $row['_num']);
} else {
    printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
}
$mysqli->close();
?>

The SQL hint MYSQLND_MS_LAST_USED forbids switching a connection, and forces use of the previously used connection.

Connection state
Local transactions
Quickstart and Examples


Local transactions

The current version of the plugin is not transaction safe by default, because it is not aware of running transactions in all cases. SQL transactions are units of work to be run on a single server. The plugin does not always know when the unit of work starts and when it ends. Therefore, the plugin may decide to switch connections in the middle of a transaction.

No kind of MySQL load balancer can detect transaction boundaries without any kind of hint from the application.

You can either use SQL hints to work around this limitation. Alternatively, you can activate transaction API call monitoring. In the latter case you must use API calls only to control transactions, see below.

Örnek 1 Plugin config with one slave and one master

[myapp]
{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.2.27",
                "port": "3306"
            }
        }
    }
}

Örnek 2 Using SQL hints for transactions

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
if (!$mysqli) {
    /* Of course, your error handling is nicer... */
    die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));
}

/* Not a SELECT, will use master */
if (!$mysqli->query("START TRANSACTION")) {
    /* Please use better error handling in your code */
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* Prevent connection switch! */
if (!$mysqli->query(sprintf("/*%s*/INSERT INTO test(id) VALUES (1)", MYSQLND_MS_LAST_USED_SWITCH))) {
    /* Please do proper ROLLBACK in your code, don't just die */
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}
if ($res = $mysqli->query(sprintf("/*%s*/SELECT COUNT(*) AS _num FROM test", MYSQLND_MS_LAST_USED_SWITCH))) {
    $row = $res->fetch_assoc();
    $res->close();
    if ($row['_num'] > 1000) {
        if (!$mysqli->query(sprintf("/*%s*/INSERT INTO events(task) VALUES ('cleanup')", MYSQLND_MS_LAST_USED_SWITCH))) {
            die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
        }
    }
} else {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}
if (!$mysqli->query(sprintf("/*%s*/UPDATE log SET last_update = NOW()", MYSQLND_MS_LAST_USED_SWITCH))) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}
if (!$mysqli->query(sprintf("/*%s*/COMMIT", MYSQLND_MS_LAST_USED_SWITCH))) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

$mysqli->close();
?>

Starting with PHP 5.4.0, the mysqlnd library allows the plugin to monitor the status of the autocommit mode, if the mode is set by API calls instead of using SQL statements such as SET AUTOCOMMIT=0. This makes it possible for the plugin to become transaction aware. In this case, you do not need to use SQL hints.

If using PHP 5.4.0 or newer, API calls that enable autocommit mode, and when setting the plugin configuration option trx_stickiness=master, the plugin can automatically disable load balancing and connection switches for SQL transactions. In this configuration, the plugin stops load balancing if autocommit is disabled and directs all statements to the master. This prevents connection switches in the middle of a transaction. Once autocommit is re-enabled, the plugin starts to load balance statements again.

API based transaction boundary detection has been improved with PHP 5.5.0 and PECL/mysqlnd_ms 1.5.0 to cover not only calls to mysqli_autocommit() but also mysqli_begin(), mysqli_commit() and mysqli_rollback().

Örnek 3 Transaction aware load balancing: trx_stickiness setting

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "127.0.0.1",
                "port": "3306"
            }
        },
        "trx_stickiness": "master"
    }
}

Örnek 4 Transaction aware

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
if (!$mysqli) {
    /* Of course, your error handling is nicer... */
    die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));
}

/* Disable autocommit, plugin will run all statements on the master */
$mysqli->autocommit(false);

if (!$mysqli->query("INSERT INTO test(id) VALUES (1)")) {
    /* Please do proper ROLLBACK in your code, don't just die */
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}
if ($res = $mysqli->query("SELECT COUNT(*) AS _num FROM test")) {
    $row = $res->fetch_assoc();
    $res->close();
    if ($row['_num'] > 1000) {
        if (!$mysqli->query("INSERT INTO events(task) VALUES ('cleanup')")) {
            die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
        }
    }
} else {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}
if (!$mysqli->query("UPDATE log SET last_update = NOW()")) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}
if (!$mysqli->commit()) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* Plugin assumes that the transaction has ended and starts load balancing again */
$mysqli->autocommit(true);
$mysqli->close();
?>

Bilginize: Version requirement

The plugin configuration option trx_stickiness=master requires PHP 5.4.0 or newer.

Please note the restrictions outlined in the transaction handling concepts section.

SQL Hints
XA/Distributed Transactions
Quickstart and Examples


XA/Distributed Transactions

Bilginize: Version requirement

XA related functions have been introduced in PECL mysqlnd_ms version 1.6.0-alpha.

Bilginize: Early adaptors wanted

The feature is currently under development. There may be issues and/or feature limitations. Do not use in production environments, although early lab tests indicate reasonable quality.

Please, contact the development team if you are interested in this feature. We are looking for real life feedback to complement the feature.

XA transactions are a standardized method for executing transactions across multiple resources. Those resources can be databases or other transactional systems. The MySQL server supports XA SQL statements which allows users to carry out a distributed SQL transaction that spawns multiple database servers or any kind as long as they support the SQL statements too. In such a scenario it is in the responsibility of the user to coordinate the participating servers.

PECL/mysqlnd_ms can act as a transaction coordinator for a global (distributed, XA) transaction carried out on MySQL servers only. As a transaction coordinator, the plugin tracks all servers involved in a global transaction and transparently issues appropriate SQL statements on the participants. The global transactions are controlled with mysqlnd_ms_xa_begin(), mysqlnd_ms_xa_commit() and mysqlnd_ms_xa_rollback(). SQL details are mostly hidden from the application as is the need to track and coordinate participants.

Örnek 1 General pattern for XA transactions

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
if (!$mysqli) {
    /* Of course, your error handling is nicer... */
    die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));
}

/* start a global transaction */
$gtrid_id = "12345";
if (!mysqlnd_ms_xa_begin($mysqli, $gtrid_id)) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* run queries as usual: XA BEGIN will be injected upon running a query */
if (!$mysqli->query("INSERT INTO orders(order_id, item) VALUES (1, 'christmas tree, 1.8m')")) {
    /* Either INSERT failed or the injected XA BEGIN failed */
    if ('XA' == substr($mysqli->sqlstate, 0, 2)) {
        printf("Global transaction/XA related failure, [%d] %s\n", $mysqli->errno, $mysqli->error);
    } else {
        printf("INSERT failed, [%d] %s\n", $mysqli->errno, $mysqli->error);
    }
    /* rollback global transaction */
    mysqlnd_ms_xa_rollback($mysqli, $xid);
    die("Stopping.");
}

/* continue carrying out queries on other servers, e.g. other shards */

/* commit the global transaction */
if (!mysqlnd_ms_xa_commit($mysqli, $xa_id)) {
    printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
}
?>

Unlike with local transactions, which are carried out on a single server, XA transactions have an identifier (xid) associated with them. The XA transaction identifier is composed of a global transaction identifier (gtrid), a branch qualifier (bqual) a format identifier (formatID). Only the global transaction identifier can and must be given when calling any of the plugins XA functions.

Once a global transaction has been started, the plugin begins tracking servers until the global transaction ends. When a server is picked for query execution, the plugin injects the SQL statement XA BEGIN prior to executing the actual SQL statement on the server. XA BEGIN makes the server participate in the global transaction. If the injected SQL statement fails, the plugin will report the issue in reply to the query execution function that was used. In the above example, $mysqli->query("INSERT INTO orders(order_id, item) VALUES (1, 'christmas tree, 1.8m')") would indicate such an error. You may want to check the errors SQL state code to determine whether the actual query (here: INSERT) has failed or the error is related to the global transaction. It is up to you to ignore the failure to start the global transaction on a server and continue execution without having the server participate in the global transaction.

Örnek 2 Local and global transactions are mutually exclusive

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
if (!$mysqli) {
    /* Of course, your error handling is nicer... */
    die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));
}

/* start a local transaction */
if (!$mysqli->begin_transaction()) {
    die(sprintf("[%d/%s] %s\n", $mysqli->errno, $mysqli->sqlstate, $mysqli->error));
}

/* cannot start global transaction now - must end local transaction first */
$gtrid_id = "12345";
if (!mysqlnd_ms_xa_begin($mysqli, $gtrid_id)) {
    die(sprintf("[%d/%s] %s\n", $mysqli->errno, $mysqli->sqlstate, $mysqli->error));
}
?>

Yukarıdaki örneğin çıktısı:

Warning: mysqlnd_ms_xa_begin(): (mysqlnd_ms) Some work is done outside global transaction. You must end the active local transaction first in ... on line ...
[1400/XAE09] (mysqlnd_ms) Some work is done outside global transaction. You must end the active local transaction first

A global transaction cannot be started when a local transaction is active. The plugin tries to detect this situation as early as possible, that is when mysqlnd_ms_xa_begin() is called. If using API calls only to control transactions, the plugin will know that a local transaction is open and return an error for mysqlnd_ms_xa_begin(). However, note the plugins limitations on detecting transaction boundaries.. In the worst case, if using direct SQL for local transactions (BEGIN, COMMIT, ...), it may happen that an error is delayed until some SQL is executed on a server.

To end a global transaction invoke mysqlnd_ms_xa_commit() or mysqlnd_ms_xa_rollback(). When a global transaction is ended all participants must be informed of the end. Therefore, PECL/mysqlnd_ms transparently issues appropriate XA related SQL statements on some or all of them. Any failure during this phase will cause an implicit rollback. The XA related API is intentionally kept simple here. A more complex API that gave more control would bare few, if any, advantages over a user implementation that issues all lower level XA SQL statements itself.

XA transactions use the two-phase commit protocol. The two-phase commit protocol is a blocking protocol. There are cases when no progress can be made, not even when using timeouts. Transaction coordinators should survive their own failure, be able to detect blockades and break ties. PECL/mysqlnd_ms takes the role of a transaction coordinator and can be configured to survive its own crash to avoid issues with blocked MySQL servers. Therefore, the plugin can and should be configured to use a persistent and crash-safe state to allow garbage collection of unfinished, aborted global transactions. A global transaction can be aborted in an open state if either the plugin fails (crashes) or a connection from the plugin to a global transaction participant fails.

Örnek 3 Transaction coordinator state store

{
    "myapp": {
        "xa": {
            "state_store": {
                "participant_localhost_ip": "192.168.2.12",
                "mysql": {
                    "host": "192.168.2.13",
                    "user": "root",
                    "password": "",
                    "db": "test",
                    "port": "3312",
                    "socket": null
                }
            }
        },
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.2.14",
                "port": "3306"
            }
        }
    }
}

Currently, PECL/mysqlnd_ms supports only using MySQL database tables as a state store. The SQL definitions of the tables are given in the plugin configuration section. Please, make sure to use a transactional and crash-safe storage engine for the tables, such as InnoDB. InnoDB is the default table engine in recent versions of the MySQL server. Make also sure the database server itself is highly available.

If a state store has been configured, the plugin can perform a garbage collection. During garbage collection it may be necessary to connect to a participant of a failed global transaction. Thus, the state store holds a list of participants and, among others, their host names. If the garbage collection is run on another host but the one that has written a participant entry with the host name localhost, then localhost resolves to different machines. There are two solutions to the problem. Either you do not configure any servers with the host name localhost but configure an IP address (and port) or, you hint the garbage collection. In the above example, localhost is used for master_0, hence it may not resolve to the correct host during garbage collection. However, participant_localhost_ip is also set to hint the garbage collection that localhost stands for the IP 192.168.2.12.

Local transactions
Service level and consistency
Quickstart and Examples


Service level and consistency

Bilginize: Version requirement

Service levels have been introduced in PECL mysqlnd_ms version 1.2.0-alpha. mysqlnd_ms_set_qos() is available with PHP 5.4.0 or newer.

Different types of MySQL cluster solutions offer different service and data consistency levels to their users. An asynchronous MySQL replication cluster offers eventual consistency by default. A read executed on an asynchronous slave may return current, stale or no data at all, depending on whether the slave has replayed all changesets from the master or not.

Applications using an MySQL replication cluster need to be designed to work correctly with eventual consistent data. In some cases, however, stale data is not acceptable. In those cases only certain slaves or even only master accesses are allowed to achieve the required quality of service from the cluster.

As of PECL mysqlnd_ms 1.2.0 the plugin is capable of selecting MySQL replication nodes automatically that deliver session consistency or strong consistency. Session consistency means that one client can read its writes. Other clients may or may not see the clients' write. Strong consistency means that all clients will see all writes from the client.

Örnek 1 Session consistency: read your writes

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "127.0.0.1",
                "port": "3306"
            }
        }
    }
}

Örnek 2 Requesting session consistency

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
if (!$mysqli) {
    /* Of course, your error handling is nicer... */
    die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));
}

/* read-write splitting: master used */
if (!$mysqli->query("INSERT INTO orders(order_id, item) VALUES (1, 'christmas tree, 1.8m')")) {
    /* Please use better error handling in your code */
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* Request session consistency: read your writes */
if (!mysqlnd_ms_set_qos($mysqli, MYSQLND_MS_QOS_CONSISTENCY_SESSION)) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* Plugin picks a node which has the changes, here: master */
if (!$res = $mysqli->query("SELECT item FROM orders WHERE order_id = 1")) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

var_dump($res->fetch_assoc());

/* Back to eventual consistency: stale data allowed */
if (!mysqlnd_ms_set_qos($mysqli, MYSQLND_MS_QOS_CONSISTENCY_EVENTUAL)) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* Plugin picks any slave, stale data is allowed */
if (!$res = $mysqli->query("SELECT item, price FROM specials")) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}
?>

Service levels can be set in the plugins configuration file and at runtime using mysqlnd_ms_set_qos(). In the example the function is used to enforce session consistency (read your writes) for all future statements until further notice. The SELECT statement on the orders table is run on the master to ensure the previous write can be seen by the client. Read-write splitting logic has been adapted to fulfill the service level.

After the application has read its changes from the orders table it returns to the default service level, which is eventual consistency. Eventual consistency puts no restrictions on choosing a node for statement execution. Thus, the SELECT statement on the specials table is executed on a slave.

The new functionality supersedes the use of SQL hints and the master_on_write configuration option. In many cases mysqlnd_ms_set_qos() is easier to use, more powerful improves portability.

Örnek 3 Maximum age/slave lag

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "127.0.0.1",
                "port": "3306"
            }
        },
        "failover" : "master"
    }
}

Örnek 4 Limiting slave lag

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
if (!$mysqli) {
    /* Of course, your error handling is nicer... */
    die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));
}

/* Read from slaves lagging no more than four seconds */
$ret = mysqlnd_ms_set_qos(
    $mysqli,
    MYSQLND_MS_QOS_CONSISTENCY_EVENTUAL,
    MYSQLND_MS_QOS_OPTION_AGE,
    4
);

if (!$ret) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* Plugin picks any slave, which may or may not have the changes */
if (!$res = $mysqli->query("SELECT item, price FROM daytrade")) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* Back to default: use of all slaves and masters permitted */
if (!mysqlnd_ms_set_qos($mysqli, MYSQLND_MS_QOS_CONSISTENCY_EVENTUAL)) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}
?>

The eventual consistency service level can be used with an optional parameter to set a maximum slave lag for choosing slaves. If set, the plugin checks SHOW SLAVE STATUS for all configured slaves. In case of the example, only slaves for which Slave_IO_Running=Yes, Slave_SQL_Running=Yes and Seconds_Behind_Master <= 4 is true are considered for executing the statement SELECT item, price FROM daytrade.

Checking SHOW SLAVE STATUS is done transparently from an applications perspective. Errors, if any, are reported as warnings. No error will be set on the connection handle. Even if all SHOW SLAVE STATUS SQL statements executed by the plugin fail, the execution of the users statement is not stopped, given that master fail over is enabled. Thus, no application changes are required.

Bilginize: Expensive and slow operation

Checking SHOW SLAVE STATUS for all slaves adds overhead to the application. It is an expensive and slow background operation. Try to minimize the use of it. Unfortunately, a MySQL replication cluster does not give clients the possibility to request a list of candidates from a central instance. Thus, a more efficient way of checking the slaves lag is not available.

Please, note the limitations and properties of SHOW SLAVE STATUS as explained in the MySQL reference manual.

To prevent mysqlnd_ms from emitting a warning if no slaves can be found that lag no more than the defined number of seconds behind the master, it is necessary to enable master fail over in the plugins configuration file. If no slaves can be found and fail over is turned on, the plugin picks a master for executing the statement.

If no slave can be found and fail over is turned off, the plugin emits a warning, it does not execute the statement and it sets an error on the connection.

Örnek 5 Fail over not set

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "127.0.0.1",
                "port": "3306"
            }
        }
    }
}

Örnek 6 No slave within time limit

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
if (!$mysqli) {
    /* Of course, your error handling is nicer... */
    die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));
}

/* Read from slaves lagging no more than four seconds */
$ret = mysqlnd_ms_set_qos(
    $mysqli,
    MYSQLND_MS_QOS_CONSISTENCY_EVENTUAL,
    MYSQLND_MS_QOS_OPTION_AGE,
    4
);

if (!$ret) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* Plugin picks any slave, which may or may not have the changes */
if (!$res = $mysqli->query("SELECT item, price FROM daytrade")) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* Back to default: use of all slaves and masters permitted */
if (!mysqlnd_ms_set_qos($mysqli, MYSQLND_MS_QOS_CONSISTENCY_EVENTUAL)) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}
?>

Yukarıdaki örneğin çıktısı:

PHP Warning:  mysqli::query(): (mysqlnd_ms) Couldn't find the appropriate slave connection. 0 slaves to choose from. Something is wrong in %s on line %d
PHP Warning:  mysqli::query(): (mysqlnd_ms) No connection selected by the last filter in %s on line %d
[2000] (mysqlnd_ms) No connection selected by the last filter

XA/Distributed Transactions
Global transaction IDs
Quickstart and Examples


Global transaction IDs

Bilginize: Version requirement

A client-side global transaction ID injection has been introduced in mysqlnd_ms version 1.2.0-alpha. The feature is not required for synchronous clusters, such as MySQL Cluster. Use it with asynchronous clusters such as classical MySQL replication.

As of MySQL 5.6.5-m8 release candidate the MySQL server features built-in global transaction identifiers. The MySQL built-in global transaction ID feature is supported by PECL/mysqlnd_ms 1.3.0-alpha or later. However, the final feature set found in MySQL 5.6 production releases to date is not sufficient to support the ideas discussed below in all cases. Please, see also the concepts section.

PECL/mysqlnd_ms can either use its own global transaction ID emulation or the global transaction ID feature built-in to MySQL 5.6.5-m8 or later. From a developer perspective the client-side and server-side approach offer the same features with regards to service levels provided by PECL/mysqlnd_ms. Their differences are discussed in the concepts section.

The quickstart first demonstrates the use of the client-side global transaction ID emulation built-in to PECL/mysqlnd_ms before its show how to use the server-side counterpart. The order ensures that the underlying idea is discussed first.

Idea and client-side emulation

In its most basic form a global transaction ID (GTID) is a counter in a table on the master. The counter is incremented whenever a transaction is committed on the master. Slaves replicate the table. The counter serves two purposes. In case of a master failure, it helps the database administrator to identify the most recent slave for promoting it to the new master. The most recent slave is the one with the highest counter value. Applications can use the global transaction ID to search for slaves which have replicated a certain write (identified by a global transaction ID) already.

PECL/mysqlnd_ms can inject SQL for every committed transaction to increment a GTID counter. The so created GTID is accessible by the application to identify an applications write operation. This enables the plugin to deliver session consistency (read your writes) service level by not only querying masters but also slaves which have replicated the change already. Read load is taken away from the master.

Client-side global transaction ID emulation has some limitations. Please, read the concepts section carefully to fully understand the principles and ideas behind it, before using in production environments. The background knowledge is not required to continue with the quickstart.

First, create a counter table on your master server and insert a record into it. The plugin does not assist creating the table. Database administrators must make sure it exists. Depending on the error reporting mode, the plugin will silently ignore the lack of the table or bail out.

Örnek 1 Create counter table on master

CREATE TABLE `trx` (
  `trx_id` int(11) DEFAULT NULL,
  `last_update` timestamp NOT NULL DEFAULT CURRENT_TIMESTAMP ON UPDATE CURRENT_TIMESTAMP
) ENGINE=InnoDB DEFAULT CHARSET=latin1
INSERT INTO `trx`(`trx_id`) VALUES (1);

In the plugins configuration file set the SQL to update the global transaction ID table using on_commit from the global_transaction_id_injection section. Make sure the table name used for the UPDATE statement is fully qualified. In the example, test.trx is used to refer to table trx in the schema (database) test. Use the table that was created in the previous step. It is important to set the fully qualified table name because the connection on which the injection is done may use a different default database. Make sure the user that opens the connection is allowed to execute the UPDATE.

Enable reporting of errors that may occur when mysqlnd_ms does global transaction ID injection.

Örnek 2 Plugin config: SQL for client-side GTID injection

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "127.0.0.1",
                "port": "3306"
            }
        },
        "global_transaction_id_injection":{
            "on_commit":"UPDATE test.trx SET trx_id = trx_id + 1",
            "report_error":true
        }
    }
}

Örnek 3 Transparent global transaction ID injection

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
if (!$mysqli) {
    /* Of course, your error handling is nicer... */
    die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));
}

/* auto commit mode, transaction on master, GTID must be incremented */
if (!$mysqli->query("DROP TABLE IF EXISTS test")) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* auto commit mode, transaction on master, GTID must be incremented */
if (!$mysqli->query("CREATE TABLE test(id INT)")) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* auto commit mode, transaction on master, GTID must be incremented */
if (!$mysqli->query("INSERT INTO test(id) VALUES (1)")) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* auto commit mode, read on slave, no increment */
if (!($res = $mysqli->query("SELECT id FROM test"))) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

var_dump($res->fetch_assoc());
?>

Yukarıdaki örneğin çıktısı:

array(1) {
  ["id"]=>
  string(1) "1"
}

The example runs three statements in auto commit mode on the master, causing three transactions on the master. For every such statement, the plugin will inject the configured UPDATE transparently before executing the users SQL statement. When the script ends the global transaction ID counter on the master has been incremented by three.

The fourth SQL statement executed in the example, a SELECT, does not trigger an increment. Only transactions (writes) executed on a master shall increment the GTID counter.

Bilginize: SQL for global transaction ID: efficient solution wanted!

The SQL used for the client-side global transaction ID emulation is inefficient. It is optimized for clearity not for performance. Do not use it for production environments. Please, help finding an efficient solution for inclusion in the manual. We appreciate your input.

Örnek 4 Plugin config: SQL for fetching GTID

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "127.0.0.1",
                "port": "3306"
            }
        },
        "global_transaction_id_injection":{
            "on_commit":"UPDATE test.trx SET trx_id = trx_id + 1",
            "fetch_last_gtid" : "SELECT MAX(trx_id) FROM test.trx",
            "report_error":true
        }
    }
}

Örnek 5 Obtaining GTID after injection

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
if (!$mysqli) {
    /* Of course, your error handling is nicer... */
    die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));
}

/* auto commit mode, transaction on master, GTID must be incremented */
if (!$mysqli->query("DROP TABLE IF EXISTS test")) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

printf("GTID after transaction %s\n", mysqlnd_ms_get_last_gtid($mysqli));

/* auto commit mode, transaction on master, GTID must be incremented */
if (!$mysqli->query("CREATE TABLE test(id INT)")) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

printf("GTID after transaction %s\n", mysqlnd_ms_get_last_gtid($mysqli));
?>

Yukarıdaki örneğin çıktısı:

GTID after transaction 7
GTID after transaction 8

Applications can ask PECL mysqlnd_ms for a global transaction ID which belongs to the last write operation performed by the application. The function mysqlnd_ms_get_last_gtid() returns the GTID obtained when executing the SQL statement from the fetch_last_gtid entry of the global_transaction_id_injection section from the plugins configuration file. The function may be called after the GTID has been incremented.

Applications are adviced not to run the SQL statement themselves as this bares the risk of accidently causing an implicit GTID increment. Also, if the function is used, it is easy to migrate an application from one SQL statement for fetching a transaction ID to another, for example, if any MySQL server ever features built-in global transaction ID support.

The quickstart shows a SQL statement which will return a GTID equal or greater to that created for the previous statement. It is exactly the GTID created for the previous statement if no other clients have incremented the GTID in the time span between the statement execution and the SELECT to fetch the GTID. Otherwise, it is greater.

Örnek 6 Plugin config: Checking for a certain GTID

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "127.0.0.1",
                "port": "3306"
            }
        },
        "global_transaction_id_injection":{
            "on_commit":"UPDATE test.trx SET trx_id = trx_id + 1",
            "fetch_last_gtid" : "SELECT MAX(trx_id) FROM test.trx",
            "check_for_gtid" : "SELECT trx_id FROM test.trx WHERE trx_id >= #GTID",
            "report_error":true
        }
    }
}

Örnek 7 Session consistency service level and GTID combined

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
if (!$mysqli) {
    /* Of course, your error handling is nicer... */
    die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));
}

/* auto commit mode, transaction on master, GTID must be incremented */
if (   !$mysqli->query("DROP TABLE IF EXISTS test")
    || !$mysqli->query("CREATE TABLE test(id INT)")
    || !$mysqli->query("INSERT INTO test(id) VALUES (1)")
) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* GTID as an identifier for the last write */
$gtid = mysqlnd_ms_get_last_gtid($mysqli);

/* Session consistency (read your writes): try to read from slaves not only master */
if (false == mysqlnd_ms_set_qos($mysqli, MYSQLND_MS_QOS_CONSISTENCY_SESSION, MYSQLND_MS_QOS_OPTION_GTID, $gtid)) {
    die(sprintf("[006] [%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* Either run on master or a slave which has replicated the INSERT */
if (!($res = $mysqli->query("SELECT id FROM test"))) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

var_dump($res->fetch_assoc());
?>

A GTID returned from mysqlnd_ms_get_last_gtid() can be used as an option for the session consistency service level. Session consistency delivers read your writes. Session consistency can be requested by calling mysqlnd_ms_set_qos(). In the example, the plugin will execute the SELECT statement either on the master or on a slave which has replicated the previous INSERT already.

PECL mysqlnd_ms will transparently check every configured slave if it has replicated the INSERT by checking the slaves GTID table. The check is done running the SQL set with the check_for_gtid option from the global_transaction_id_injection section of the plugins configuration file. Please note, that this is a slow and expensive procedure. Applications should try to use it sparsely and only if read load on the master becomes to high otherwise.

Use of the server-side global transaction ID feature

Bilginize: Insufficient server support in MySQL 5.6

The plugin has been developed against a pre-production version of MySQL 5.6. It turns out that all released production versions of MySQL 5.6 do not provide clients with enough information to enforce session consistency based on GTIDs. Please, read the concepts section for details.

Starting with MySQL 5.6.5-m8 the MySQL Replication system features server-side global transaction IDs. Transaction identifiers are automatically generated and maintained by the server. Users do not need to take care of maintaining them. There is no need to setup any tables in advance, or for setting on_commit. A client-side emulation is no longer needed.

Clients can continue to use global transaction identifier to achieve session consistency when reading from MySQL Replication slaves in some cases but not all! The algorithm works as described above. Different SQL statements must be configured for fetch_last_gtid and check_for_gtid. The statements are given below. Please note, MySQL 5.6.5-m8 is a development version. Details of the server implementation may change in the future and require adoption of the SQL statements shown.

Using the following configuration any of the above described functionality can be used together with the server-side global transaction ID feature. mysqlnd_ms_get_last_gtid() and mysqlnd_ms_set_qos() continue to work as described above. The only difference is that the server does not use a simple sequence number but a string containing of a server identifier and a sequence number. Thus, users cannot easily derive an order from GTIDs returned by mysqlnd_ms_get_last_gtid().

Örnek 8 Plugin config: using MySQL 5.6.5-m8 built-in GTID feature

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "127.0.0.1",
                "port": "3306"
            }
        },
        "global_transaction_id_injection":{
            "fetch_last_gtid" : "SELECT @@GLOBAL.GTID_DONE AS trx_id FROM DUAL",
            "check_for_gtid" : "SELECT GTID_SUBSET('#GTID', @@GLOBAL.GTID_DONE) AS trx_id FROM DUAL",
            "report_error":true
        }
    }
}

Service level and consistency
Cache integration
Quickstart and Examples


Cache integration

Bilginize: Version requirement, dependencies and status

Please, find more about version requirements, extension load order dependencies and the current status in the concepts section!

Databases clusters can deliver different levels of consistency. As of PECL/mysqlnd_ms 1.2.0 it is possible to advice the plugin to consider only cluster nodes that can deliver the consistency level requested. For example, if using asynchronous MySQL Replication with its cluster-wide eventual consistency, it is possible to request session consistency (read your writes) at any time using mysqlnd_ms_set_quos(). Please, see also the service level and consistency introduction.

Örnek 1 Recap: quality of service to request read your writes

/* Request session consistency: read your writes */
if (!mysqlnd_ms_set_qos($mysqli, MYSQLND_MS_QOS_CONSISTENCY_SESSION))
  die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));

Assuming PECL/mysqlnd has been explicitly told to deliver no consistency level higher than eventual consistency, it is possible to replace a database node read access with a client-side cache using time-to-live (TTL) as its invalidation strategy. Both the database node and the cache may or may not serve current data as this is what eventual consistency defines.

Replacing a database node read access with a local cache access can improve overall performance and lower the database load. If the cache entry is every reused by other clients than the one creating the cache entry, a database access is saved and thus database load is lowered. Furthermore, system performance can become better if computation and delivery of a database query is slower than a local cache access.

Örnek 2 Plugin config: no special entries for caching

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "127.0.0.1",
                "port": "3306"
            }
        },
    }
}

Örnek 3 Caching a slave request

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
if (!$mysqli) {
    /* Of course, your error handling is nicer... */
    die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));
}

if (   !$mysqli->query("DROP TABLE IF EXISTS test")
    || !$mysqli->query("CREATE TABLE test(id INT)")
    || !$mysqli->query("INSERT INTO test(id) VALUES (1)")
) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* Explicitly allow eventual consistency and caching (TTL <= 60 seconds) */
if (false == mysqlnd_ms_set_qos($mysqli, MYSQLND_MS_QOS_CONSISTENCY_EVENTUAL, MYSQLND_MS_QOS_OPTION_CACHE, 60)) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* To make this example work, we must wait for a slave to catch up. Brute force style. */
$attempts = 0;
do {
    /* check if slave has the table */
    if ($res = $mysqli->query("SELECT id FROM test")) {
        break;
    } else if ($mysqli->errno) {
        die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
    }
    /* wait for slave to catch up */
    usleep(200000);
} while ($attempts++ < 10);

/* Query has been run on a slave, result is in the cache */
assert($res);
var_dump($res->fetch_assoc());

/* Served from cache */
$res = $mysqli->query("SELECT id FROM test");
?>

The example shows how to use the cache feature. First, you have to set the quality of service to eventual consistency and explicitly allow for caching. This is done by calling mysqlnd_ms_set_qos(). Then, the result set of every read-only statement is cached for upto that many seconds as allowed with mysqlnd_ms_set_qos().

The actual TTL is lower or equal to the value set with mysqlnd_ms_set_qos(). The value passed to the function sets the maximum age (seconds) of the data delivered. To calculate the actual TTL value the replication lag on a slave is checked and subtracted from the given value. If, for example, the maximum age is set to 60 seconds and the slave reports a lag of 10 seconds the resulting TTL is 50 seconds. The TTL is calculated individually for every cached query.

Örnek 4 Read your writes and caching combined

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
if (!$mysqli) {
    /* Of course, your error handling is nicer... */
    die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));
}

if (   !$mysqli->query("DROP TABLE IF EXISTS test")
    || !$mysqli->query("CREATE TABLE test(id INT)")
    || !$mysqli->query("INSERT INTO test(id) VALUES (1)")
) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* Explicitly allow eventual consistency and caching (TTL <= 60 seconds) */
if (false == mysqlnd_ms_set_qos($mysqli, MYSQLND_MS_QOS_CONSISTENCY_EVENTUAL, MYSQLND_MS_QOS_OPTION_CACHE, 60)) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* To make this example work, we must wait for a slave to catch up. Brute force style. */
$attempts = 0;
do {
    /* check if slave has the table */
    if ($res = $mysqli->query("SELECT id FROM test")) {
        break;
    } else if ($mysqli->errno) {
        die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
    }
    /* wait for slave to catch up */
    usleep(200000);
} while ($attempts++ < 10);

assert($res);

/* Query has been run on a slave, result is in the cache */
var_dump($res->fetch_assoc());

/* Served from cache */
if (!($res = $mysqli->query("SELECT id FROM test"))) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}
var_dump($res->fetch_assoc());

/* Update on master */
if (!$mysqli->query("UPDATE test SET id = 2")) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* Read your writes */
if (false == mysqlnd_ms_set_qos($mysqli, MYSQLND_MS_QOS_CONSISTENCY_SESSION)) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* Fetch latest data */
if (!($res = $mysqli->query("SELECT id FROM test"))) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}
var_dump($res->fetch_assoc());
?>

The quality of service can be changed at any time to avoid further cache usage. If needed, you can switch to read your writes (session consistency). In that case, the cache will not be used and fresh data is read.

Global transaction IDs
Failover
Quickstart and Examples


Failover

By default, the plugin does not attempt to fail over if connecting to a host fails. This prevents pitfalls related to connection state. It is recommended to manually handle connection errors in a way similar to a failed transaction. You should catch the error, rebuild the connection state and rerun your query as shown below.

If connection state is no issue to you, you can alternatively enable automatic and silent failover. Depending on the configuration, the automatic and silent failover will either attempt to fail over to the master before issuing and error or, try to connect to other slaves, given the query allowes for it, before attempting to connect to a master. Because automatic failover is not fool-proof, it is not discussed in the quickstart. Instead, details are given in the concepts section below.

Örnek 1 Manual failover, automatic optional

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "simulate_slave_failure",
                "port": "0"
            },
            "slave_1": {
                "host": "127.0.0.1",
                "port": 3311
            }
        },
       "filters": { "roundrobin": [] }
    }
 }

Örnek 2 Manual failover

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
if (!$mysqli) {
    /* Of course, your error handling is nicer... */
    die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));
}

$sql = "SELECT 1 FROM DUAL";

/* error handling as it should be done regardless of the plugin */
if (!($res = $link->query($sql))) {
    /* plugin specific: check for connection error */
    switch ($link->errno) {
    case 2002:
    case 2003:
    case 2005:
        printf("Connection error - trying next slave!\n");
        /* load balancer will pick next slave */
        $res = $link->query($sql);
        break;
    default:
        /* no connection error, failover is unlikely to help */
        die(sprintf("SQL error: [%d] %s", $link->errno, $link->error));
        break;
    }
}
if ($res) {
    var_dump($res->fetch_assoc());
}
?>

Cache integration
Partitioning and Sharding
Quickstart and Examples


Partitioning and Sharding

Database clustering is done for various reasons. Clusters can improve availability, fault tolerance, and increase performance by applying a divide and conquer approach as work is distributed over many machines. Clustering is sometimes combined with partitioning and sharding to further break up a large complex task into smaller, more manageable units.

The mysqlnd_ms plugin aims to support a wide variety of MySQL database clusters. Some flavors of MySQL database clusters have built-in methods for partitioning and sharding, which could be transparent to use. The plugin supports the two most common approaches: MySQL Replication table filtering, and Sharding (application based partitioning).

MySQL Replication supports partitioning as filters that allow you to create slaves that replicate all or specific databases of the master, or tables. It is then in the responsibility of the application to choose a slave according to the filter rules. You can either use the mysqlnd_ms node_groups filter to manually support this, or use the experimental table filter.

Manual partitioning or sharding is supported through the node grouping filter, and SQL hints as of 1.5.0. The node_groups filter lets you assign a symbolic name to a group of master and slave servers. In the example, the master master_0 and slave_0 form a group with the name Partition_A. It is entirely up to you to decide what makes up a group. For example, you may use node groups for sharding, and use the group names to address shards like Shard_A_Range_0_100.

Örnek 1 Cluster node groups

{
  "myapp": {
       "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "simulate_slave_failure",
                "port": "0"
            },
            "slave_1": {
                "host": "127.0.0.1",
                "port": 3311
            }
        },
        "filters": {
            "node_groups": {
                "Partition_A" : {
                    "master": ["master_0"],
                    "slave": ["slave_0"]
                }
            },
           "roundrobin": []
        }
    }
}

Örnek 2 Manual partitioning using SQL hints

<?php
function select($mysqli, $msg, $hint = '')
{
    /* Note: weak test, two connections to two servers may have the same thread id */
    $sql = sprintf("SELECT CONNECTION_ID() AS _thread, '%s' AS _hint FROM DUAL", $msg);
    if ($hint) {
        $sql = $hint . $sql;
    }
    if (!($res = $mysqli->query($sql))) {
        printf("[%d] %s", $mysqli->errno, $mysqli->error);
        return false;
    }
    $row =  $res->fetch_assoc();
    printf("%d - %s - %s\n", $row['_thread'], $row['_hint'], $sql);
    return true;
}

$mysqli = new mysqli("myapp", "user", "password", "database");
if (!$mysqli) {
    /* Of course, your error handling is nicer... */
    die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));
}

/* All slaves allowed */
select($mysqli, "slave_0");
select($mysqli, "slave_1");

/* only servers of node group "Partition_A" allowed */
select($mysqli, "slave_1", "/*Partition_A*/");
select($mysqli, "slave_1", "/*Partition_A*/");
?>
6804 - slave_0 - SELECT CONNECTION_ID() AS _thread, 'slave1' AS _hint FROM DUAL
2442 - slave_1 - SELECT CONNECTION_ID() AS _thread, 'slave2' AS _hint FROM DUAL
6804 - slave_0 - /*Partition_A*/SELECT CONNECTION_ID() AS _thread, 'slave1' AS _hint FROM DUAL
6804 - slave_0 - /*Partition_A*/SELECT CONNECTION_ID() AS _thread, 'slave1' AS _hint FROM DUAL

By default, the plugin will use all configured master and slave servers for query execution. But if a query begins with a SQL hint like /*node_group*/, the plugin will only consider the servers listed in the node_group for query execution. Thus, SELECT queries prefixed with /*Partition_A*/ will only be executed on slave_0.

Failover
MySQL Fabric
Quickstart and Examples


MySQL Fabric

Bilginize: Version requirement and status

Work on supporting MySQL Fabric started in version 1.6. Please, consider the support to be of pre-alpha quality. The manual may not list all features or feature limitations. This is work in progress.

Sharding is the only use case supported by the plugin to date.

Bilginize: MySQL Fabric concepts

Please, check the MySQL reference manual for more information about MySQL Fabric and how to set it up. The PHP manual assumes that you are familiar with the basic concepts and ideas of MySQL Fabric.

MySQL Fabric is a system for managing farms of MySQL servers to achive High Availability and optionally support sharding. Technically, it is a middleware to manage and monitor MySQL servers.

Clients query MySQL Fabric to obtain lists of MySQL servers, their state and their roles. For example, clients can request a list of slaves for a MySQL Replication group and whether they are ready to handle SQL requests. Another example is a cluster of sharded MySQL servers where the client seeks to know which shard to query for a given table and shard key. If configured to use Fabric, the plugin uses XML RCP over HTTP to obtain the list at runtime from a MySQL Fabric host. The XML remote procedure call itself is done in the background and transparent from a developers point of view.

Instead of listing MySQL servers directly in the plugins configuration file it contains a list of one or more MySQL Fabric hosts

Örnek 1 Plugin config: Fabric hosts instead of MySQL servers

{
    "myapp": {
        "fabric": {
            "hosts": [
                {
                    "host" : "127.0.0.1",
                    "port" : 8080
                }
            ]
        }
    }
}

Users utilize the new functions mysqlnd_ms_fabric_select_shard() and mysqlnd_ms_fabric_select_global() to switch to the set of servers responsible for a given shard key. Then, the plugin picks an appropriate server for running queries on. When doing so, the plugin takes care of additional load balancing rules set.

The below example assumes that MySQL Fabric has been setup to shard the table test.fabrictest using the id column of the table as a shard key.

Örnek 2 Manual partitioning using SQL hints

<?php
$mysqli = new mysqli("myapp", "user", "password", "database");
if (!$mysqli) {
    /* Of course, your error handling is nicer... */
    die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));
}

/* Create a global table - a table available on all shards */
mysqlnd_ms_fabric_select_global($mysqli, "test.fabrictest");
if (!$mysqli->query("CREATE TABLE test.fabrictest(id INT NOT NULL PRIMARY KEY)")) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* Switch connection to appropriate shard and insert record */
mysqlnd_ms_fabric_select_shard($mysqli, "test.fabrictest", 10);
if (!($res = $mysqli->query("INSERT INTO fabrictest(id) VALUES (10)"))) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}

/* Try to read newly inserted record */
mysqlnd_ms_fabric_select_shard($mysqli, "test.fabrictest", 10);
if (!($res = $mysqli->query("SELECT id FROM test WHERE id = 10"))) {
    die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
}
?>

The example creates the sharded table, inserts a record and reads the record thereafter. All SQL data definition language (DDL) operations on a sharded table must be applied to the so called global server group. Prior to creating or altering a sharded table, mysqlnd_ms_fabric_select_global() is called to switch the given connection to the corresponding servers of the global group. Data manipulation (DML) SQL statements must be sent to the shards directly. The mysqlnd_ms_fabric_select_shard() switches a connection to shards handling a certain shard key.

Partitioning and Sharding
Concepts
Quickstart and Examples


Concepts

İçindekiler

  • Architecture
  • Connection pooling and switching
  • Local transaction handling
  • Error handling
  • Transient errors
  • Failover
  • Load balancing
  • Read-write splitting
  • Filter
  • Service level and consistency
  • Global transaction IDs
  • Cache integration
  • Supported clusters
  • XA/Distributed transactions

This explains the architecture and related concepts for this plugin, and describes the impact that MySQL replication and this plugin have on developmental tasks while using a database cluster. Reading and understanding these concepts is required, in order to use this plugin with success.

MySQL Fabric
Architecture
mysqlnd_ms


Architecture

The mysqlnd replication and load balancing plugin is implemented as a PHP extension. It is written in C and operates under the hood of PHP. During the startup of the PHP interpreter, in the module init phase of the PHP engine, it gets registered as a mysqlnd plugin to replace selected mysqlnd C methods.

At PHP runtime, it inspects queries sent from mysqlnd (PHP) to the MySQL server. If a query is recognized as read-only, it will be sent to one of the configured slave servers. Statements are considered read-only if they either start with SELECT, the SQL hint /*ms=slave*/ or a slave had been chosen for running the previous query, and the query started with the SQL hint /*ms=last_used*/. In all other cases, the query will be sent to the MySQL replication master server.

For better portability, applications should use the MYSQLND_MS_MASTER_SWITCH, MYSQLND_MS_SLAVE_SWITCH, and MYSQLND_MS_LAST_USED_SWITCH predefined mysqlnd_ms constants, instead of their literal values, such as /*ms=slave*/.

The plugin handles the opening and closing of database connections to both master and slave servers. From an application point of view, there continues to be only one connection handle. However, internally, this one public connection handle represents a pool of network connections that are managed by the plugin. The plugin proxies queries to the master server, and to the slaves using multiple connections.

Database connections have a state consisting of, for example, transaction status, transaction settings, character set settings, and temporary tables. The plugin will try to maintain the same state among all internal connections, whenever this can be done in an automatic and transparent way. In cases where it is not easily possible to maintain state among all connections, such as when using BEGIN TRANSACTION, the plugin leaves it to the user to handle.

Concepts
Connection pooling and switching
Concepts


Connection pooling and switching

The replication and load balancing plugin changes the semantics of a PHP MySQL connection handle. The existing API of the PHP MySQL extensions (mysqli, mysql, and PDO_MYSQL) are not changed in a way that functions are added or removed. But their behavior changes when using the plugin. Existing applications do not need to be adapted to a new API, but they may need to be modified because of the behavior changes.

The plugin breaks the one-by-one relationship between a mysqli, mysql, and PDO_MYSQL connection handle and a MySQL network connection. And a mysqli, mysql, and PDO_MYSQL connection handle represents a local pool of connections to the configured MySQL replication master and MySQL replication slave servers. The plugin redirects queries to the master and slave servers. At some point in time one and the same PHP connection handle may point to the MySQL master server. Later on, it may point to one of the slave servers or still the master. Manipulating and replacing the network connection referenced by a PHP MySQL connection handle is not a transparent operation.

Every MySQL connection has a state. The state of the connections in the connection pool of the plugin can differ. Whenever the plugin switches from one wire connection to another, the current state of the user connection may change. The applications must be aware of this.

The following list shows what the connection state consists of. The list may not be complete.

  • Transaction status
  • Temporary tables
  • Table locks
  • Session system variables and session user variables
  • The current database set using USE and other state chaining SQL commands
  • Prepared statements
  • HANDLER variables
  • Locks acquired with GET_LOCK()

Connection switches happen right before queries are executed. The plugin does not switch the current connection until the next statement is executed.

Bilginize: Replication issues

See also the MySQL reference manual chapter about » replication features and related issues. Some restrictions may not be related to the PHP plugin, but are properties of the MySQL replication system.

Broadcasted messages

The plugins philosophy is to align the state of connections in the pool only if the state is under full control of the plugin, or if it is necessary for security reasons. Just a few actions that change the state of the connection fall into this category.

The following is a list of connection client library calls that change state, and are broadcasted to all open connections in the connection pool.

If any of the listed calls below are to be executed, the plugin loops over all open master and slave connections. The loop continues until all servers have been contacted, and the loop does not break if a server indicates a failure. If possible, the failure will propagate to the called user API function, which may be detected depending on which underlying library function was triggered.

Library call | Notes | Version
change_user() | Called by the mysqli_change_user() user API call. Also triggered upon reuse of a persistent mysqli connection. | Since 1.0.0.
select_db | Called by the following user API calls: mysql_select_db(), mysql_list_tables(), mysql_db_query(), mysql_list_fields(), mysqli_select_db(). Note, that SQL USE is not monitored. | Since 1.0.0.
set_charset() | Called by the following user API calls: mysql_set_charset(). mysqli_set_charset(). Note, that SQL SET NAMES is not monitored. | Since 1.0.0.
set_server_option() | Called by the following user API calls: mysqli_multi_query(), mysqli_real_query(), mysqli_query(), mysql_query(). | Since 1.0.0.
set_client_option() | Called by the following user API calls: mysqli_options(), mysqli_ssl_set(), mysqli_connect(), mysql_connect(), mysql_pconnect(). | Since 1.0.0.
set_autocommit() | Called by the following user API calls: mysqli_autocommit(), PDO::setAttribute(PDO::ATTR_AUTOCOMMIT). | Since 1.0.0. PHP >= 5.4.0.
ssl_set() | Called by the following user API calls: mysqli_ssl_set(). | Since 1.1.0.

Broadcasting and lazy connections

The plugin does not proxy or "remember" all settings to apply them on connections opened in the future. This is important to remember, if using lazy connections. Lazy connections are connections which are not opened before the client sends the first connection. Use of lazy connections is the default plugin action.

The following connection library calls each changed state, and their execution is recorded for later use when lazy connections are opened. This helps ensure that the connection state of all connections in the connection pool are comparable.

Library call | Notes | Version
change_user() | User, password and database recorded for future use. | Since 1.1.0.
select_db | Database recorded for future use. | Since 1.1.0.
set_charset() | Calls set_client_option(MYSQL_SET_CHARSET_NAME, charset) on lazy connection to ensure charset will be used upon opening the lazy connection. | Since 1.1.0.
set_autocommit() | Adds SET AUTOCOMMIT=0|1 to the list of init commands of a lazy connection using set_client_option(MYSQL_INIT_COMMAND, "SET AUTOCOMMIT=...%quot;). | Since 1.1.0. PHP >= 5.4.0.
Dikkat

Connection state

The connection state is not only changed by API calls. Thus, even if PECL mysqlnd_ms monitors all API calls, the application must still be aware. Ultimately, it is the applications responsibility to maintain the connection state, if needed.

Charsets and string escaping

Due to the use of lazy connections, which are a default, it can happen that an application tries to escape a string for use within SQL statements before a connection has been established. In this case string escaping is not possible. The string escape function does not know what charset to use before a connection has been established.

To overcome the problem a new configuration setting server_charset has been introduced in version 1.4.0.

Attention has to be paid on escaping strings with a certain charset but using the result on a connection that uses a different charset. Please note, that PECL/mysqlnd_ms manipulates connections and one application level connection represents a pool of multiple connections that all may have different default charsets. It is recommended to configure the servers involved to use the same default charsets. The configuration setting server_charset does help with this situation as well. If using server_charset, the plugin will set the given charset on all newly opened connections.

Architecture
Local transaction handling
Concepts


Local transaction handling

Transaction handling is fundamentally changed. An SQL transaction is a unit of work that is run on one database server. The unit of work consists of one or more SQL statements.

By default the plugin is not aware of SQL transactions. The plugin may switch connections for load balancing at any point in time. Connection switches may happen in the middle of a transaction. This is against the nature of an SQL transaction. By default, the plugin is not transaction safe.

Any kind of MySQL load balancer must be hinted about the begin and end of a transaction. Hinting can either be done implicitly by monitoring API calls or using SQL hints. Both options are supported by the plugin, depending on your PHP version. API monitoring requires PHP 5.4.0 or newer. The plugin, like any other MySQL load balancer, cannot detect transaction boundaries based on the MySQL Client Server Protocol. Thus, entirely transparent transaction aware load balancing is not possible. The least intrusive option is API monitoring, which requires little to no application changes, depending on your application.

Please, find examples of using SQL hints or the API monitoring in the examples section. The details behind the API monitoring, which makes the plugin transaction aware, are described below.

Beginning with PHP 5.4.0, the mysqlnd library allows this plugin to subclass the library C API call set_autocommit(), to detect the status of autocommit mode.

The PHP MySQL extensions either issue a query (such as SET AUTOCOMMIT=0|1), or use the mysqlnd library call set_autocommit() to control the autocommit setting. If an extension makes use of set_autocommit(), the plugin can be made transaction aware. Transaction awareness cannot be achieved if using SQL to set the autocommit mode. The library function set_autocommit() is called by the mysqli_autocommit() and PDO::setAttribute(PDO::ATTR_AUTOCOMMIT) user API calls.

The plugin configuration option trx_stickiness=master can be used to make the plugin transactional aware. In this mode, the plugin stops load balancing if autocommit becomes disabled, and directs all statements to the master until autocommit gets enabled.

An application that does not want to set SQL hints for transactions but wants to use the transparent API monitoring to avoid application changes must make sure that the autocommit settings is changed exclusively through the listed API calls.

API based transaction boundary detection has been improved with PHP 5.5.0 and PECL/mysqlnd_ms 1.5.0 to cover not only calls to mysqli_autocommit() but also mysqli_begin(), mysqli_commit() and mysqli_rollback().

Connection pooling and switching
Error handling
Concepts


Error handling

Applications using PECL/mysqlnd_ms should implement proper error handling for all user API calls. And because the plugin changes the semantics of a connection handle, API calls may return unexpected errors. If using the plugin on a connection handle that no longer represents an individual network connection, but a connection pool, an error code and error message will be set on the connection handle whenever an error occurs on any of the network connections behind.

If using lazy connections, which is the default, connections are not opened until they are needed for query execution. Therefore, an API call for a statement execution may return a connection error. In the example below, an error is provoked when trying to run a statement on a slave. Opening a slave connection fails because the plugin configuration file lists an invalid host name for the slave.

Örnek 1 Provoking a connection error

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "invalid_host_name",
            }
        },
        "lazy_connections": 1
    }
}

The explicit activation of lazy connections is for demonstration purpose only.

Örnek 2 Connection error on query execution

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
if (mysqli_connect_errno())
  /* Of course, your error handling is nicer... */
  die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));

/* Connection 1, connection bound SQL user variable, no SELECT thus run on master */
if (!$mysqli->query("SET @myrole='master'")) {
 printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
}

/* Connection 2, run on slave because SELECT, provoke connection error */
if (!($res = $mysqli->query("SELECT @myrole AS _role"))) {
 printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
} else {
 $row = $res->fetch_assoc();
 $res->close();
 printf("@myrole = '%s'\n", $row['_role']);
}
$mysqli->close();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

PHP Warning:  mysqli::query(): php_network_getaddresses: getaddrinfo failed: Name or service not known in %s on line %d
PHP Warning:  mysqli::query(): [2002] php_network_getaddresses: getaddrinfo failed: Name or service not known (trying to connect via tcp://invalid_host_name:3306) in %s on line %d
[2002] php_network_getaddresses: getaddrinfo failed: Name or service not known

Applications are expected to handle possible connection errors by implementing proper error handling.

Depending on the use case, applications may want to handle connection errors differently from other errors. Typical connection errors are 2002 (CR_CONNECTION_ERROR) - Can't connect to local MySQL server through socket '%s' (%d), 2003 (CR_CONN_HOST_ERROR) - Can't connect to MySQL server on '%s' (%d) and 2005 (CR_UNKNOWN_HOST) - Unknown MySQL server host '%s' (%d). For example, the application may test for the error codes and manually perform a fail over. The plugins philosophy is not to offer automatic fail over, beyond master fail over, because fail over is not a transparent operation.

Örnek 3 Provoking a connection error

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "invalid_host_name"
            },
            "slave_1": {
                "host": "192.168.78.136"
            }
        },
        "lazy_connections": 1,
        "filters": {
            "roundrobin": [

            ]
        }
    }
}

Explicitly activating lazy connections is done for demonstration purposes, as is round robin load balancing as opposed to the default random once type.

Örnek 4 Most basic failover

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
if (mysqli_connect_errno())
  /* Of course, your error handling is nicer... */
  die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));

/* Connection 1, connection bound SQL user variable, no SELECT thus run on master */
if (!$mysqli->query("SET @myrole='master'")) {
 printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
}

/* Connection 2, first slave */
$res = $mysqli->query("SELECT VERSION() AS _version");
/* Hackish manual fail over */
if (2002 == $mysqli->errno || 2003 == $mysqli->errno || 2004 == $mysqli->errno) {
  /* Connection 3, first slave connection failed, trying next slave */
  $res = $mysqli->query("SELECT VERSION() AS _version");
}

if (!$res) {
  printf("ERROR, [%d] '%s'\n", $mysqli->errno, $mysqli->error);
} else {
 /* Error messages are taken from connection 3, thus no error */
 printf("SUCCESS, [%d] '%s'\n", $mysqli->errno, $mysqli->error);
 $row = $res->fetch_assoc();
 $res->close();
 printf("version = %s\n", $row['_version']);
}
$mysqli->close();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

[1045] Access denied for user 'username'@'localhost' (using password: YES)
PHP Warning:  mysqli::query(): php_network_getaddresses: getaddrinfo failed: Name or service not known in %s on line %d
PHP Warning:  mysqli::query(): [2002] php_network_getaddresses: getaddrinfo failed: Name or service not known (trying to connect via tcp://invalid_host_name:3306) in %s on line %d
SUCCESS, [0] ''
version = 5.6.2-m5-log

In some cases, it may not be easily possible to retrieve all errors that occur on all network connections through a connection handle. For example, let's assume a connection handle represents a pool of three open connections. One connection to a master and two connections to the slaves. The application changes the current database using the user API call mysqli_select_db(), which then calls the mysqlnd library function to change the schemata. mysqlnd_ms monitors the function, and tries to change the current database on all connections to harmonize their state. Now, assume the master succeeds in changing the database, and both slaves fail. Upon the initial error from the first slave, the plugin will set an appropriate error on the connection handle. The same is done when the second slave fails to change the database. The error message from the first slave is lost.

Such cases can be debugged by either checking for errors of the type E_WARNING (see above) or, if no other option, investigation of the mysqlnd_ms debug and trace log.

Local transaction handling
Transient errors
Concepts


Transient errors

Some distributed database clusters make use of transient errors. A transient error is a temporary error that is likely to disappear soon. By definition it is safe for a client to ignore a transient error and retry the failed operation on the same database server. The retry is free of side effects. Clients are not forced to abort their work or to fail over to another database server immediately. They may enter a retry loop before to wait for the error to disappear before giving up on the database server. Transient errors can be seen, for example, when using MySQL Cluster. But they are not bound to any specific clustering solution per se.

PECL/mysqlnd_ms can perform an automatic retry loop in case of a transient error. This increases distribution transparency and thus makes it easier to migrate an application running on a single database server to run on a cluster of database servers without having to change the source of the application.

The automatic retry loop will repeat the requested operation up to a user configurable number of times and pause between the attempts for a configurable amount of time. If the error disappears during the loop, the application will never see it. If not, the error is forwarded to the application for handling.

In the example below a duplicate key error is provoked to make the plugin retry the failing query two times before the error is passed to the application. Between the two attempts the plugin sleeps for 100 milliseconds.

Örnek 1 Provoking a transient error

mysqlnd_ms.enable=1
mysqlnd_ms.collect_statistics=1
{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.78.136",
                "port": "3306"
            }
       },
       "transient_error": {
          "mysql_error_codes": [
            1062
          ],
          "max_retries": 2,
          "usleep_retry": 100
       }
    }
}

Örnek 2 Transient error retry loop

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
if (mysqli_connect_errno())
  /* Of course, your error handling is nicer... */
  die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));

if (!$mysqli->query("DROP TABLE IF EXISTS test") ||
    !$mysqli->query("CREATE TABLE test(id INT PRIMARY KEY)") ||
    !$mysqli->query("INSERT INTO test(id) VALUES (1))")) {
  printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
}

/* Retry loop is completely transparent. Checking statistics is
 the only way to know about implicit retries */
$stats = mysqlnd_ms_get_stats();
printf("Transient error retries before error: %d\n", $stats['transient_error_retries']);

/* Provoking duplicate key error to see statistics change */
if (!$mysqli->query("INSERT INTO test(id) VALUES (1))")) {
  printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
}

$stats = mysqlnd_ms_get_stats();
printf("Transient error retries after error: %d\n", $stats['transient_error_retries']);

$mysqli->close();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Transient error retries before error: 0
[1062] Duplicate entry '1' for key 'PRIMARY'
Transient error retries before error: 2

Because the execution of the retry loop is transparent from a users point of view, the example checks the statistics provided by the plugin to learn about it.

As the example shows, the plugin can be instructed to consider any error transient regardless of the database servers error semantics. The only error that a stock MySQL server considers temporary has the error code 1297. When configuring other error codes but 1297 make sure your configuration reflects the semantics of your clusters error codes.

The following mysqlnd C API calls are monitored by the plugin to check
for transient errors: query(),
change_user(), select_db(),
set_charset(), set_server_option()
prepare(), execute(),
set_autocommit(),
tx_begin(), tx_commit(),
tx_rollback(), tx_commit_or_rollback().
The corresponding user API calls have similar names.

The maximum time the plugin may sleep during the retry loop depends on the function in question. The a retry loop for query(), prepare() or execute() will sleep for up to max_retries * usleep_retry milliseconds.

However, functions that control connection state are dispatched to all connections. The retry loop settings are applied to every connection on which the command is to be run. Thus, such a function may interrupt program execution for longer than a function that is run on one server only. For example, set_autocommit() is dispatched to connections and may sleep up to (max_retries * usleep_retry) * number_of_open_connections) milliseconds. Please, keep this in mind when setting long sleep times and large retry numbers. Using the default settings of max_retries=1, usleep_retry=100 and lazy_connections=1 it is unlikely that you will ever see a delay of more than 1 second.

Error handling
Failover
Concepts


Failover

By default, connection failover handling is left to the user. The application is responsible for checking return values of the database functions it calls and reacting to possible errors. If, for example, the plugin recognizes a query as a read-only query to be sent to the slave servers, and the slave server selected by the plugin is not available, the plugin will raise an error after not executing the statement.

Default: manual failover

It is up to the application to handle the error and, if required, re-issue the query to trigger the selection of another slave server for statement execution. The plugin will make no attempts to failover automatically, because the plugin cannot ensure that an automatic failover will not change the state of the connection. For example, the application may have issued a query which depends on SQL user variables which are bound to a specific connection. Such a query might return incorrect results if the plugin would switch the connection implicitly as part of automatic failover. To ensure correct results, the application must take care of the failover, and rebuild the required connection state. Therefore, by default, no automatic failover is performed by the plugin.

A user that does not change the connection state after opening a connection may activate automatic failover. Please note, that automatic failover logic is limited to connection attempts. Automatic failover is not used for already established connections. There is no way to instruct the plugin to attempt failover on a connection that has been connected to MySQL already in the past.

Automatic failover

The failover policy is configured in the plugins configuration file, by using the failover configuration directive.

Automatic and silent failover can be enabled through the failover configuration directive. Automatic failover can either be configured to try exactly one master after a slave failure or, alternatively, loop over slaves and masters before returning an error to the user. The number of connection attempts can be limited and failed hosts can be excluded from future load balancing attempts. Limiting the number of retries and remembering failed hosts are considered experimental features, albeit being reasonable stable. Syntax and semantics may change in future versions.

Please note, since version 1.5.0 automatic failover is disabled for the duration of a transaction if transaction stickiness is enabled and transaction boundaries have been detected. The plugin will not switch connections for the duration of a transaction. It will also not perform automatic and silent failover. Instead an error will be thrown. It is then left to the user to handle the failure of the transaction. Please check, the trx_stickiness documentation how to do this.

A basic manual failover example is provided within the error handling section.

Standby servers

Using weighted load balancing, introduced in PECL/mysqlnd 1.4.0, it is possible to configure standby servers that are sparsely used during normal operations. A standby server that is primarily used as a worst-case standby failover target can be assigned a very low weight/priority in relation to all other servers. As long as all servers are up and running the majority of the workload is assigned to the servers which have hight weight values. Few requests will be directed to the standby system which has a very low weight value.

Upon failure of the servers with a high priority, you can still failover to the standby, which has been given a low load balancing priority by assigning a low weight to it. Failover can be some manually or automatically. If done automatically, you may want to combine it with the remember_failed option.

At this point, it is not possible to instruct the load balancer to direct no requests at all to a standby. This may not be much of a limitation given that the highest weight you can assign to a server is 65535. Given two slaves, of which one shall act as a standby and has been assigned a weight of 1, the standby will have to handle far less than one percent of the overall workload.

Failover and primary copy

Please note, if using a primary copy cluster, such as MySQL Replication, it is difficult to do connection failover in case of a master failure. At any time there is only one master in the cluster for a given dataset. The master is a single point of failure. If the master fails, clients have no target to fail over write requests. In case of a master outage the database administrator must take care of the situation and update the client configurations, if need be.

Transient errors
Load balancing
Concepts


Load balancing

Four load balancing strategies are supported to distribute statements over the configured MySQL slave servers:

random

Chooses a random server whenever a statement is executed.

random once (default)

Chooses a random server after the first statement is executed, and uses the decision for the rest of the PHP request.

It is the default, and the lowest impact on the connection state.

round robin

Iterates over the list of configured servers.

user-defined via callback

Is used to implement any other strategy.

The load balancing policy is configured in the plugins configuration file using the random, roundrobin, and user filters.

Servers can be prioritized assigning a weight. A server that has been given a weight of two will get twice as many requests as a server that has been given the default weight of one. Prioritization can be handy in heterogenous environments. For example, you may want to assign more requests to a powerful machine than to a less powerful. Or, you may have configured servers that are close or far from the client, thus expose different latencies.

Failover
Read-write splitting
Concepts


Read-write splitting

The plugin executes read-only statements on the configured MySQL slaves, and all other queries on the MySQL master. Statements are considered read-only if they either start with SELECT, the SQL hint /*ms=slave*/, or if a slave had been chosen for running the previous query and the query starts with the SQL hint /*ms=last_used*/. In all other cases, the query will be sent to the MySQL replication master server. It is recommended to use the constants MYSQLND_MS_SLAVE_SWITCH, MYSQLND_MS_MASTER_SWITCH and MYSQLND_MS_LAST_USED_SWITCH instead of /*ms=slave*/. See also the list of mysqlnd_ms constants.

SQL hints are a special kind of standard compliant SQL comments. The plugin does check every statement for certain SQL hints. The SQL hints are described within the mysqlnd_ms constants documentation, constants that are exported by the extension. Other systems involved with the statement processing, such as the MySQL server, SQL firewalls, and SQL proxies, are unaffected by the SQL hints, because those systems are designed to ignore SQL comments.

The built-in read-write splitter can be replaced by a user-defined filter, see also the user filter documentation.

A user-defined read-write splitter can request the built-in logic to send a statement to a specific location, by invoking mysqlnd_ms_is_select().

Bilginize:

The built-in read-write splitter is not aware of multi-statements. Multi-statements are seen as one statement. The splitter will check the beginning of the statement to decide where to run the statement. If, for example, a multi-statement begins with SELECT 1 FROM DUAL; INSERT INTO test(id) VALUES (1); ... the plugin will run it on a slave although the statement is not read-only.

Load balancing
Filter
Concepts


Filter

Bilginize: Version requirement

Filters exist as of mysqlnd_ms version 1.1.0-beta.

filters. PHP applications that implement a MySQL replication cluster must first identify a group of servers in the cluster which could execute a statement before the statement is executed by one of the candidates. In other words: a defined list of servers must be filtered until only one server is available.

The process of filtering may include using one or more filters, and filters can be chained. And they are executed in the order they are defined in the plugins configuration file.

Bilginize: Explanation: comparing filter chaining to pipes

The concept of chained filters can be compared to using pipes to connect command line utilities on an operating system command shell. For example, an input stream is passed to a processor, filtered, and then transferred to be output. Then, the output is passed as input to the next command, which is connected to the previous using the pipe operator.

Available filters:

  • Load balancing filters: random and roundrobin.
  • Selection filter: user, user_multi, quality_of_service.

The random filter implements the 'random' and 'random once' load balancing policies. The 'round robin' load balancing can be configured through the roundrobin filter. Setting a 'user defined callback' for server selection is possible with the user filter. The quality_of_service filter finds cluster nodes capable of delivering a certain service, for example, read-your-writes or, not lagging more seconds behind the master than allowed.

Filters can accept parameters to change their behavior. The random filter accepts an optional sticky parameter. If set to true, the filter changes load balancing from random to random once. Random picks a random server every time a statement is to be executed. Random once picks a random server when the first statement is to be executed and uses the same server for the rest of the PHP request.

One of the biggest strength of the filter concept is the possibility to chain filters. This strength does not become immediately visible because the random, roundrobin and user filters are supposed to output no more than one server. If a filter reduces the list of candidates for running a statement to only one server, it makes little sense to use that one server as input for another filter for further reduction of the list of candidates.

An example filter sequence that will fail:

  • Statement to be executed: SELECT 1 FROM DUAL. Passed to all filters.
  • All configured nodes are passed as input to the first filter. Master nodes: master_0. Slave nodes:slave_0, slave_1
  • Filter: random, argument sticky=1. Picks a random slave once to be used for the rest of the PHP request. Output: slave_0.
  • Output of slave_0 and the statement to be executed is passed as input to the next filter. Here: roundrobin, server list passed to filter is: slave_0.
  • Filter: roundrobin. Server list consists of one server only, round robin will always return the same server.
If trying to use such a filter sequence, the plugin may emit a warning like (mysqlnd_ms) Error while creating filter '%s' . Non-multi filter '%s' already created. Stopping in %s on line %d. Furthermore, an appropriate error on the connection handle may be set.

A second type of filter exists: multi filter. A multi filter emits zero, one or multiple servers after processing. The quality_of_service filter is an example. If the service quality requested sets an upper limit for the slave lag and more than one slave is lagging behind less than the allowed number of seconds, the filter returns more than one cluster node. A multi filter must be followed by other to further reduce the list of candidates for statement execution until a candidate is found.

A filter sequence with the quality_of_service multi filter followed by a load balancing filter.

  • Statement to be executed: SELECT sum(price) FROM orders WHERE order_id = 1. Passed to all filters.
  • All configured nodes are passed as input to the first filter. Master nodes: master_0. Slave nodes: slave_0, slave_1, slave_2, slave_3
  • Filter: quality_of_service, rule set: session_consistency (read-your-writes) Output: master_0
  • Output of master_0 and the statement to be executed is passed as input to the next filter, which is roundrobin.
  • Filter: roundrobin. Server list consists of one server. Round robin selects master_0.

A filter sequence must not end with a multi filter. If trying to use a filter sequence which ends with a multi filter the plugin may emit a warning like (mysqlnd_ms) Error in configuration. Last filter is multi filter. Needs to be non-multi one. Stopping in %s on line %d. Furthermore, an appropriate error on the connection handle may be set.

Bilginize: Speculation towards the future: MySQL replication filtering

In future versions, there may be additional multi filters. For example, there may be a table filter to support MySQL replication filtering. This would allow you to define rules for which database or table is to be replicated to which node of a replication cluster. Assume your replication cluster consists of four slaves (slave_0, slave_1, slave_2, slave_3) two of which replicate a database named sales (slave_0, slave_1). If the application queries the database slaves, the hypothetical table filter reduces the list of possible servers to slave_0 and slave_1. Because the output and list of candidates consists of more than one server, it is necessary and possible to add additional filters to the candidate list, for example, using a load balancing filter to identify a server for statement execution.

Read-write splitting
Service level and consistency
Concepts


Service level and consistency

Bilginize: Version requirement

Service levels have been introduced in mysqlnd_ms version 1.2.0-alpha. mysqlnd_ms_set_qos() requires PHP 5.4.0 or newer.

The plugin can be used with different kinds of MySQL database clusters. Different clusters can deliver different levels of service to applications. The service levels can be grouped by the data consistency levels that can be achieved. The plugin knows about:

  • eventual consistency
  • session consistency
  • strong consistency

Depending how a cluster is used it may be possible to achieve higher service levels than the default one. For example, a read from an asynchronous MySQL replication slave is eventual consistent. Thus, one may say the default consistency level of a MySQL replication cluster is eventual consistency. However, if the master only is used by a client for reading and writing during a session, session consistency (read your writes) is given. PECL mysqlnd 1.2.0 abstracts the details of choosing an appropriate node for any of the above service levels from the user.

Service levels can be set through the qualify-of-service filter in the plugins configuration file and at runtime using the function mysqlnd_ms_set_qos().

The plugin defines the different service levels as follows.

Eventual consistency is the default service provided by an asynchronous cluster, such as classical MySQL replication. A read operation executed on an arbitrary node may or may not return stale data. The applications view of the data is eventual consistent.

Session consistency is given if a client can always read its own writes. An asynchronous MySQL replication cluster can deliver session consistency if clients always use the master after the first write or never query a slave which has not yet replicated the clients write operation.

The plugins understanding of strong consistency is that all clients always see the committed writes of all other clients. This is the default when using MySQL Cluster or any other cluster offering synchronous data distribution.

Service level parameters

Eventual consistency and session consistency service level accept parameters.

Eventual consistency is the service provided by classical MySQL replication. By default, all nodes qualify for read requests. An optional age parameter can be given to filter out nodes which lag more than a certain number of seconds behind the master. The plugin is using SHOW SLAVE STATUS to measure the lag. Please, see the MySQL reference manual to learn about accuracy and reliability of the SHOW SLAVE STATUS command.

Session consistency (read your writes) accepts an optional GTID parameter to consider reading not only from the master but also from slaves which already have replicated a certain write described by its transaction identifier. This way, when using asynchronous MySQL replication, read requests may be load balanced over slaves while still ensuring session consistency.

The latter requires the use of client-side global transaction id injection.

Advantages of the new approach

The new approach supersedes the use of SQL hints and the configuration option master_on_write in some respects. If an application running on top of an asynchronous MySQL replication cluster cannot accept stale data for certain reads, it is easier to tell the plugin to choose appropriate nodes than prefixing all read statements in question with the SQL hint to enforce the use of the master. Furthermore, the plugin may be able to use selected slaves for reading.

The master_on_write configuration option makes the plugin use the master after the first write (session consistency, read your writes). In some cases, session consistency may not be needed for the rest of the session but only for some, few read operations. Thus, master_on_write may result in more read load on the master than necessary. In those cases it is better to request a higher than default service level only for those reads that actually need it. Once the reads are done, the application can return to default service level. Switching between service levels is only possible using mysqlnd_ms_set_qos().

Performance considerations

A MySQL replication cluster cannot tell clients which slaves are capable of delivering which level of service. Thus, in some cases, clients need to query the slaves to check their status. PECL mysqlnd_ms transparently runs the necessary SQL in the background. However, this is an expensive and slow operation. SQL statements are run if eventual consistency is combined with an age (slave lag) limit and if session consistency is combined with a global transaction ID.

If eventual consistency is combined with an maximum age (slave lag), the plugin selects candidates for statement execution and load balancing for each statement as follows. If the statement is a write all masters are considered as candidates. Slaves are not checked and not considered as candidates. If the statement is a read, the plugin transparently executes SHOW SLAVE STATUS on every slaves connection. It will loop over all connections, send the statement and then start checking for results. Usually, this is slightly faster than a loop over all connections in which for every connection a query is send and the plugin waits for its results. A slave is considered a candidate if SHOW SLAVE STATUS reports Slave_IO_Running=Yes, Slave_SQL_Running=Yes and Seconds_Behind_Master is less or equal than the allowed maximum age. In case of an SQL error, the plugin emits a warning but does not set an error on the connection. The error is not set to make it possible to use the plugin as a drop-in.

If session consistency is combined with a global transaction ID, the plugin executes the SQL statement set with the fetch_last_gtid entry of the global_transaction_id_injection section from the plugins configuration file. Further details are identical to those described above.

In version 1.2.0 no additional optimizations are done for executing background queries. Future versions may contain optimizations, depending on user demand.

If no parameters and options are set, no SQL is needed. In that case, the plugin consider all nodes of the type shown below.

  • eventual consistency, no further options set: all masters, all slaves
  • session consistency, no further options set: all masters
  • strong consistency (no options allowed): all masters

Throttling

The quality of service filter can be combined with Global transaction IDs to throttle clients. Throttling does reduce the write load on the master by slowing down clients. If session consistency is requested and global transactions identifier are used to check the status of a slave, the check can be done in two ways. By default a slave is checked and skipped immediately if it does not match the criteria for session consistency. Alternatively, the plugin can wait for a slave to catch up to the master until session consistency is possible. To enable the throttling, you have to set wait_for_gtid_timeout configuration option.

Filter
Global transaction IDs
Concepts


Global transaction IDs

Bilginize: Version requirement

Client side global transaction ID injection exists as of mysqlnd_ms version 1.2.0-alpha. Transaction boundaries are detected by monitoring API calls. This is possible as of PHP 5.4.0. Please, see also Transaction handling.

As of MySQL 5.6.5-m8 the MySQL server features built-in global transaction identifiers. The MySQL built-in global transaction ID feature is supported by PECL/mysqlnd_ms 1.3.0-alpha or later. Neither are client-side transaction boundary monitoring nor any setup activities required if using the server feature.

Please note, all MySQL 5.6 production versions do not provide clients with enough information to use GTIDs for enforcing session consistency. In the worst case, the plugin will choose the master only.

Idea and client-side emulation

PECL/mysqlnd_ms can do client-side transparent global transaction ID injection. In its most basic form, a global transaction identifier is a counter which is incremented for every transaction executed on the master. The counter is held in a table on the master. Slaves replicate the counter table.

In case of a master failure a database administrator can easily identify the most recent slave for promoting it as a new master. The most recent slave has the highest transaction identifier.

Application developers can ask the plugin for the global transaction identifier (GTID) for their last successful write operation. The plugin will return an identifier that refers to an transaction no older than that of the clients last write operation. Then, the GTID can be passed as a parameter to the quality of service (QoS) filter as an option for session consistency. Session consistency ensures read your writes. The filter ensures that all reads are either directed to a master or a slave which has replicated the write referenced by the GTID.

When injection is done

The plugin transparently maintains the GTID table on the master. In autocommit mode the plugin injects an UPDATE statement before executing the users statement for every master use. In manual transaction mode, the injection is done before the application calls commit() to close a transaction. The configuration option report_error of the GTID section in the plugins configuration file is used to control whether a failed injection shall abort the current operation or be ignored silently (default).

Please note, the PHP version requirements for transaction boundary monitoring and their limits.

Limitations

Client-side global transaction ID injection has shortcomings. The potential issues are not specific to PECL/mysqlnd_ms but are rather of general nature.

  • Global transaction ID tables must be deployed on all masters and replicas.
  • The GTID can have holes. Only PHP clients using the plugin will maintain the table. Other clients will not.
  • Client-side transaction boundary detection is based on API calls only.
  • Client-side transaction boundary detection does not take implicit commit into account. Some MySQL SQL statements cause an implicit commit and cannot be rolled back.

Using server-side global transaction identifier

Starting with PECL/mysqlnd_ms 1.3.0-alpha the MySQL 5.6.5-m8 or newer built-in global transaction identifier feature is supported. Use of the server feature lifts all of the above listed limitations. Please, see the MySQL Reference Manual for limitations and preconditions for using server built-in global transaction identifiers.

Whether to use the client-side emulation or the server built-in functionality is a question not directly related to the plugin, thus it is not discussed in depth. There are no plans to remove the client-side emulation and you can continue to use it, if the server-side solution is no option. This may be the case in heterogenous environments with old MySQL server or, if any of the server-side solution limitations is not acceptable.

From an applications perspective there is hardly a difference in using one or the other approach. The following properties differ.

  • Client-side emulation, as shown in the manual, is using an easy to compare sequence number for global transactions. Multi-master is not handled to keep the manual examples easy. Server-side built-in feature is using a combination of a server identifier and a sequence number as a global transaction identifier. Comparison cannot use numeric algebra. Instead a SQL function must be used. Please, see the MySQL Reference Manual for details. Server-side built-in feature of MySQL 5.6 cannot be used to ensure session consistency under all circumstances. Do not use it for the quality-of-service feature. Here is a simple example why it will not give reliable results. There are more edge cases that cannot be covered with limited functionality exported by the server. Currently, clients can ask a MySQL replication master for a list of all executed global transaction IDs only. If a slave is configured not to replicate all transactions, for example, because replication filters are set, then the slave will never show the same set of executed global transaction IDs. Albeit the slave may have replicated a clients writes and it may be a candidate for a consistent read, it will never be considered by the plugin. Upon write the plugin learns from the master that the servers complete transaction history consists of GTID=1..3. There is no way for the plugin to ask for the GTID of the write transaction itself, say GTID=3. Assume that a slave does not replicate the transactions GTID=1..2 but only GTID=3 because of a replication feature. Then, the slaves transaction history is GTID=3. However, the plugin tries to find a node which has a transaction history of GITD=1...3. Albeit the slave has replicated the clients write and session consistency may be achieved when reading from the slave, it will not be considered by the plugin. This is not a fault of the plugin implementation but a feature gap on the server side. Please note, this is a trivial case to illustrate the issue there are other issues. In sum you are asked not to attempt using MySQL 5.6 built-in GTIDs for enforcing session consistency. Sooner or later the load balancing will stop working properly and the plugin will direct all session consistency requests to the master.
  • Plugin global transaction ID statistics are only available with client-side emulation because they monitor the emulation.

Bilginize: Global transaction identifiers in distributed systems

Global transaction identifiers can serve multiple purposes in the context of distributed systems, such as a database cluster. Global transaction identifiers can be used for, for example, system wide identification of transactions, global ordering of transactions, heartbeat mechanism and for checking the replication status of replicas. PECL/mysqlnd_ms, a clientside driver based software, does focus on using GTIDs for tasks that can be handled at the client, such as checking the replication status of replicas for asynchronous replication setups.

Service level and consistency
Cache integration
Concepts


Cache integration

Bilginize: Version requirement

The feature requires use of PECL/mysqlnd_ms 1.3.0-beta or later, and PECL/mysqlnd_qc 1.1.0-alpha or newer. PECL/mysqlnd_ms must be compiled to support the feature. PHP 5.4.0 or newer is required.

Bilginize: Setup: extension load order

PECL/mysqlnd_ms must be loaded before PECL/mysqlnd_qc, when using shared extensions.

Bilginize: Feature stability

The cache integration is of beta quality.

Bilginize: Suitable MySQL clusters

The feature is targeted for use with MySQL Replication (primary copy). Currently, no other kinds of MySQL clusters are supported. Users of such cluster must control PECL/mysqlnd_qc manually if they are interested in client-side query caching.

Support for MySQL replication clusters (asynchronous primary copy) is the main focus of PECL/mysqlnd_ms. The slaves of a MySQL replication cluster may or may not reflect the latest updates from the master. Slaves are asynchronous and can lag behind the master. A read from a slave is eventual consistent from a cluster-wide perspective.

The same level of consistency is offered by a local cache using time-to-live (TTL) invalidation strategy. Current data or stale data may be served. Eventually, data searched for in the cache is not available and the source of the cache needs to be accessed.

Given that both a MySQL Replication slave (asynchronous secondary) and a local TTL-driven cache deliver the same level of service it is possible to transparently replace a remote database access with a local cache access to gain better possibility.

As of PECL/mysqlnd_ms 1.3.0-beta the plugin is capable of transparently controlling PECL/mysqlnd_ms 1.1.0-alpha or newer to cache a read-only query if explicitly allowed by setting an appropriate quality of service through mysqlnd_ms_set_qos(). P lease, see the quickstart for a code example. Both plugins must be installed, PECL/mysqlnd_ms must be compiled to support the cache feature and PHP 5.4.0 or newer has to be used.

Applications have full control of cache usage and can request fresh data at any time, if need be. The cache usage can be enabled and disabled time during the execution of a script. The cache will be used if mysqlnd_ms_set_qos() sets the quality of service to eventual consistency and enables cache usage. Cache usage is disabled by requesting higher consistency levels, for example, session consistency (read your writes). Once the quality of service has been relaxed to eventual consistency the cache can be used again.

If caching is enabled for a read-only statement, PECL/mysqlnd_ms may inject SQL hints to control caching by PECL/mysqlnd_qc. It may modify the SQL statement it got from the application. Subsequent SQL processors are supposed to ignore the SQL hints. A SQL hint is a SQL comment. Comments must not be ignored, for example, by the database server.

The TTL of a cache entry is computed on a per statement basis. Applications set an maximum age for the data they want to retrieve using mysqlnd_ms_set_qos(). The age sets an approximate upper limit of how many seconds the data returned may lag behind the master.

The following logic is used to compute the actual TTL if caching is enabled. The logic takes the estimated slave lag into account for choosing a TTL. If, for example, there are two slaves lagging 5 and 10 seconds behind and the maximum age allowed is 60 seconds, the TTL is set to 50 seconds. Please note, the age setting is no more than an estimated guess.

  • Check whether the statement is read-only. If not, don't cache.
  • If caching is enabled, check the slave lag of all configured slaves. Establish slave connections if none exist so far and lazy connections are used.
  • Send SHOW SLAVE STATUS to all slaves. Do not wait for the first slave to reply before sending to the second slave. Clients often wait long for replies, thus we send out all requests in a burst before fetching in a second stage.
  • Loop over all slaves. For every slave wait for its reply. Do not start checking another slave before the currently waited for slave has replied. Check for Slave_IO_Running=Yes and Slave_SQL_Running=Yes. If both conditions hold true, fetch the value of Seconds_Behind_Master. In case of any errors or if conditions fail, set an error on the slave connection. Skip any such slave connection for the rest of connection filtering.
  • Search for the maximum value of Seconds_Behind_Master from all slaves that passed the previous conditions. Subtract the value from the maximum age provided by the user with mysqlnd_ms_set_qos(). Use the result as a TTL.
  • The filtering may sort out all slaves. If so, the maximum age is used as TTL, because the maximum lag found equals zero. It is perfectly valid to sort out all slaves. In the following it is up to subsequent filter to decide what to do. The built-in load balancing filter will pick the master.
  • Inject the appropriate SQL hints to enable caching by PECL/mysqlnd_qc.
  • Proceed with the connection filtering, e.g. apply load balancing rules to pick a slave.
  • PECL/mysqlnd_qc is loaded after PECL/mysqlnd_ms by PHP. Thus, it will see all query modifications of PECL/mysqlnd_ms and cache the query if instructed to do so.

The algorithm may seem expensive. SHOW SLAVE STATUS is a very fast operation. Given a sufficient number of requests and cache hits per second the cost of checking the slaves lag can easily outweigh the costs of the cache decision.

Suggestions on a better algorithm are always welcome.

Global transaction IDs
Supported clusters
Concepts


Supported clusters

Any application using any kind of MySQL cluster is faced with the same tasks:

  • Identify nodes capable of executing a given statement with the required service level
  • Load balance requests within the list of candidates
  • Automatic fail over within candidates, if needed

The plugin is optimized for fulfilling these tasks in the context of a classical asynchronous MySQL replication cluster consisting of a single master and many slaves (primary copy). When using classical, asynchronous MySQL replication all of the above listed tasks need to be mastered at the client side.

Other types of MySQL cluster may have lower requirements on the application side. For example, if all nodes in the cluster can answer read and write requests, no read-write splitting needs to be done (multi-master, update-all). If all nodes in the cluster are synchronous, they automatically provide the highest possible quality of service which makes choosing a node easier. In this case, the plugin may serve the application after some reconfiguration to disable certain features, such as built-in read-write splitting.

Bilginize: Documentation focus

The documentation focusses describing the use of the plugin with classical asynchronous MySQL replication clusters (primary copy). Support for this kind of cluster has been the original development goal. Use of other clusters is briefly described below. Please note, that this is still work in progress.

Primary copy (MySQL Replication)

This is the primary use case of the plugin. Follow the hints given in the descriptions of each feature.

  • Configure one master and one or more slaves. Server configuration details are given in the setup section.
  • Use random load balancing policy together with the sticky flag.
  • If you do not plan to use the service level API calls, add the master on write flag.
  • Please, make yourself aware of the properties of automatic failover before adding a failover directive.
  • Consider the use of trx_stickiness to execute transactions on the primary only. Please, read carefully how it works before you rely on it.

Örnek 1 Enabling the plugin (php.ini)

mysqlnd_ms.enable=1
mysqlnd_ms.config_file=/path/to/mysqlnd_ms_plugin.ini

Örnek 2 Basic plugin configuration (mysqlnd_ms_plugin.ini) for MySQL Replication

{
  "myapp": {
    "master": {
      "master_1": {
        "host": "localhost",
        "socket": "\/tmp\/mysql57.sock"
      }
    },
    "slave": {
      "slave_0": {
        "host": "127.0.0.1",
        "port": 3308
      },
      "slave_1": {
        "host": "192.168.2.28",
        "port": 3306
      }
    },
    "filters": {
      "random": {
        "sticky": "1"
      }
    }
  }
}

Primary copy with multi primaries (MMM - MySQL Multi Master)

MySQL Replication allows you to create cluster topologies with multiple masters (primaries). Write-write conflicts are not handled by the replication system. This is no update anywhere setup. Thus, data must be partitioned manually and clients must redirected in accordance to the partitioning rules. The recommended setup is equal to the sharding setup below.

Manual sharding, possibly combined with primary copy and multiple primaries

Use SQL hints and the node group filter for clusters that use data partitioning but leave query redirection to the client. The example configuration shows a multi master setup with two shards.

Örnek 3 Multiple primaries - multi master (php.ini)

mysqlnd_ms.enable=1
mysqlnd_ms.config_file=/path/to/mysqlnd_ms_plugin.ini
mysqlnd_ms.multi_master=1

Örnek 4 Primary copy with multiple primaries and paritioning

{
  "myapp": {
    "master": {
      "master_1": {
        "host": "localhost",
        "socket": "\/tmp\/mysql57.sock"
      }
      "master_2": {
        "host": "192.168.2.27",
        "socket": "3306"
      }
    },
    "slave": {
      "slave_1": {
        "host": "127.0.0.1",
        "port": 3308
      },
      "slave_2": {
        "host": "192.168.2.28",
        "port": 3306
      }
    },
    "filters": {
      "node_groups": {
        "Partition_A" : {
          "master": ["master_1"],
          "slave": ["slave_1"]
        },
        "Partition_B" : {
          "master": ["master_2"],
          "slave": ["slave_2"]
        }
      },
      "roundrobin": []
    }
  }
}

The plugin can also be used with a loose collection of unrelated shards. For such a cluster, configure masters only and disable read write splitting. The nodes of such a cluster are called masters in the plugin configuration as they accept both reads and writes for their partition.

Using synchronous update everywhere clusters such as MySQL Cluster

MySQL Cluster is a synchronous cluster solution. All cluster nodes accept read and write requests. In the context of the plugin, all nodes shall be considered as masters.

Use the load balancing and fail over features only.

  • Disable the plugins built-in read-write splitting.
  • Configure masters only.
  • Consider random once load balancing strategy, which is the plugins default. If random once is used, only masters are configured and no SQL hints are used to force using a certain node, no connection switches will happen for the duration of a web request. Thus, no special handling is required for transactions. The plugin will pick one master at the beginning of the PHP script and use it until the script terminates.
  • Do not set the quality of service. All nodes have all the data. This automatically gives you the highest possible service quality (strong consistency).
  • Do not enable client-side global transaction injection. It is neither required to help with server-side fail over nor to assist the quality of service filter choosing an appropriate node.

Disabling built-in read-write splitting.

  • Set mysqlnd_ms.disable_rw_split=1
  • Do not use SQL hints to enforce the use of slaves

Configure masters only.

  • Set mysqlnd_ms.multi_master=1.
  • Do not configure any slaves.
  • Set failover=loop_before_master in the plugins configuration file to avoid warnings about the empty slave list and to make the failover logic loop over all configured masters before emitting an error. Please, note the warnings about automatic failover given in the previous sections.

Örnek 5 Multiple primaries - multi master (php.ini)

mysqlnd_ms.enable=1
mysqlnd_ms.config_file=/path/to/mysqlnd_ms_plugin.ini
mysqlnd_ms.multi_master=1
mysqlnd_ms.disable_rw_split=1

Örnek 6 Synchronous update anywhere cluster

"myapp": {
    "master": {
      "master_1": {
        "host": "localhost",
        "socket": "\/tmp\/mysql57.sock"
      },
      "master_2": {
        "host": "192.168.2.28",
        "port": 3306
      }
    },
    "slave": {
    },
    "filters": {
      "roundrobin": {
      }
    },
    "failover": {
      "strategy": "loop_before_master",
      "remember_failed": true
    }
  }
}

If running an update everywhere cluster that has no built-in partitioning to avoid hot spots and high collision rates, consider using the node groups filter to keep updates on a frequently accessed table on one of the nodes. This may help to reduce collision rates and thus improve performance.

Cache integration
XA/Distributed transactions
Concepts


XA/Distributed transactions

Bilginize: Version requirement

XA related functions have been introduced in PECL/mysqlnd_ms version 1.6.0-alpha.

Bilginize: Early adaptors wanted

The feature is currently under development. There may be issues and/or feature limitations. Do not use in production environments, although early lab tests indicate reasonable quality.

Please, contact the development team if you are interested in this feature. We are looking for real life feedback to complement the feature.

Below is a list of some feature restrictions.

  • The feature is not yet compatible with the MySQL Fabric support . This limitation is soon to be lifted.

    XA transaction identifier are currently restricted to numbers. This limitation will be lifted upon request, it is a simplification used during the initial implementation.

Bilginize: MySQL server restrictions

The XA support by the MySQL server has some restrictions. Most noteably, the servers binary log may lack changes made by XA transactions in case of certain errors. Please, see the MySQL manual for details.

XA/Distributed transactions can spawn multiple MySQL servers. Thus, they may seem like a perfect tool for sharded MySQL clusters, for example, clusters managed with MySQL Fabric. PECL/mysqlnd_ms hides most of the SQL commands to control XA transactions and performs automatic administrative tasks in cases of errors, to provide the user with a comprehensive API. Users should setup the plugin carefully and be well aware of server restrictions prior to using the feature.

Örnek 1 General pattern for XA transactions

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");

/* BEGIN */
mysqlnd_ms_xa_begin($mysqli, 1 /* xa id */);

/* run queries on various servers */
$mysqli->query("UPDATE some_table SET col_a = 1");
...

/* COMMIT */
mysqlnd_ms_xa_commit($link, 1);
?>

XA transactions use the two-phase commit protocol. The two-phase commit protocol is a blocking protocol. During the first phase participating servers begin a transaction and the client carries out its work. This phase is followed by a second voting phase. During voting, the servers first make a firm promise that they are ready to commit the work even in case of their possible unexpected failure. Should a server crash in this phase, it will still recall the aborted transaction after recover and wait for the client to decide on whether it shall be committed or rolled back.

Should a client that has initiated a global transaction crash after all the participating servers gave their promise to be ready to commit, then the servers must wait for a decision. The servers are not allowed to unilaterally decide on the transaction.

A client crash or disconnect from a participant, a server crash or server error during the fist phase of the protocol is uncritical. In most cases, the server will forget about the XA transaction and its work is rolled back. Additionally, the plugin tries to reach out to as many participants as it can to instruct the server to roll back the work immediately. It is not possible to disable this implicit rollback carried out by PECL/mysqlnd_ms in case of errors during the first phase of the protocol. This design decision has been made to keep the implementation simple.

An error during the second phase of the commit protocol can develop into a more severe situation. The servers will not forget about prepared but unfinished transactions in all cases. The plugin will not attempt to solve these cases immediately but waits for optional background garbage collection to ensure progress of the commit protocol. It is assumed that a solution will take significant time as it may include waiting for a participating server to recover from a crash. This time span may be longer than a developer and end user expects when trying to commit a global transaction with mysqlnd_ms_xa_commit(). Thus, the function returns with the unfinished global transaction still requiring attention. Please, be warned that at this point, it is not yet clear whether the global transaction will be committed or rolled back later on.

Errors during the second phase can be ignored, handled by yourself or solved by the build-int garbage collection logic. Ignoring them is not recommended as you may experience unfinished global transactions on your servers that block resources virtually indefinitely. Handling the errors requires knowing the participants, checking their state and issuing appropriate SQL commands on them. There are no user API calls to expose this very information. You will have to configure a state store and make the plugin record its actions in it to receive the desired facts.

Please, see the quickstart and related plugin configuration file settings for an example how to configure a state. In addition to configuring a state store, you have to setup some SQL tables. The table definitions are given in the description of the plugin configuration settings.

Setting up and configuring a state store is also a precondition for using the built-in garbage collection for XA transactions that fail during the second commit phase. Recording information about ongoing XA transactions is an unavoidable extra task. The extra task consists of updating the state store after each and every operation that changes the state of the global transaction itself (started, committed, rolled back, errors and aborts), the addition of participants (host, optionally user and password required to connect) and any changes to a participants state. Please note, depending on configuration and your security policies, these recordings may be considered sensitive. It is therefore recommended to restrict access to the state store. Unless the state store itself becomes overloaded, writing the state information may contribute noteworthy to the runtime but should overall be only a minor factor.

It is possible that the effort it takes to implement your own routines for handling XA transactions that failed during the second commit phase exceeds the benefits of using the XA feature of PECL/mysqlnd_ms in the first place. Thus, the manual focussed on using the built-on garbage collection only.

Garbage collection can be triggered manually or automatically in the background. You may want to call mysqlnd_ms_xa_gc() immediately after a commit failure to attempt to solve any failed but still open global transactions as soon as possible. You may also decide to disable the automatic background garbage collection, implement your own rule set for invoking the built-in garbage collection and trigger it when desired.

By default the plugin will start the garbage collection with a certain probability in the extensions internal RSHUTDOWN method. The request shutdown is called after your script finished. Whether the garbage collection will be triggered is determined by computing a random value between 1...1000 and comparing it with the configuration setting probability (default: 5). If the setting is greater or equal to the random value, the garbage collection will be triggered.

Once started, the garbage collection acts upon up to max_transactions_per_run (default: 100) global transactions recorded. Records include successfully finished but also unfinished XA transactions. Records for successful transactions are removed and unfinished transactions are attempted to be solved. There are no statistics that help you finding the right balance between keeping garbage collection runs short by limiting the number of transactions considered per run and preventing the garbage collection to fall behind, resulting in many records.

For each failed XA transaction the garbage collection makes max_retries (default: 5) attempts to finish it. After that PECL/mysqlnd_ms gives up. There are two possible reasons for this. Either a participating server crashed and has not become accessible again within max_retries invocations of the garbage collection, or there is a situation that the built-in garbage collection cannot cope with. Likely, the latter would be considered a bug. However, you can manually force more garbage collection runs calling mysqlnd_ms_xa_gc() with the appropriate parameter set. Should even those function runs fail to solve the situation, then the problem must be solved by an operator.

The function mysqlnd_ms_get_stats() provides some statistics on how many XA transactions have been started, committed, failed or rolled back.

Supported clusters
Yapılandırma/Kurulum
Concepts


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Plugin configuration file (>=1.1.x)
XA/Distributed transactions
Gereksinimler
mysqlnd_ms


Gereksinimler

PHP 5.3.6 or newer. Some advanced functionality requires PHP 5.4.0 or newer.

The mysqlnd_ms replication and load balancing plugin supports all PHP applications and all available PHP MySQL extensions (mysqli, mysql, PDO_MYSQL). The PHP MySQL extension must be configured to use mysqlnd in order to be able to use the mysqlnd_ms plugin for mysqlnd.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu » PECL eklentisi PHP ile gelmez.

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/mysqlnd_ms

Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Mysqlnd_ms Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
mysqlnd_ms.enable | 0 | PHP_INI_SYSTEM |
mysqlnd_ms.force_config_usage | 0 | PHP_INI_SYSTEM |
mysqlnd_ms.ini_file | "" | PHP_INI_SYSTEM |
mysqlnd_ms.config_file | "" | PHP_INI_SYSTEM |
mysqlnd_ms.collect_statistics | 0 | PHP_INI_SYSTEM |
mysqlnd_ms.multi_master | 0 | PHP_INI_SYSTEM |
mysqlnd_ms.disable_rw_split | 0 | PHP_INI_SYSTEM |

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

mysqlnd_ms.enable integer

Enables or disables the plugin. If disabled, the extension will not plug into mysqlnd to proxy internal mysqlnd C API calls.

mysqlnd_ms.force_config_usage integer

If enabled, the plugin checks if the host (server) parameters value of any MySQL connection attempt, matches a section name from the plugin configuration file. If not, the connection attempt is blocked.

This setting is not only useful to restrict PHP to certain servers but also to debug configuration file problems. The configuration file validity is checked at two different stages. The first check is performed when PHP begins to handle a web request. At this point the plugin reads and decodes the configuration file. Errors thrown at this early stage in an extensions life cycle may not be shown properly to the user. Thus, the plugin buffers the errors, if any, and additionally displays them when establishing a connection to MySQL. By default a buffered startup error will emit an error of type E_WARNING. If force_config_usage is set, the error type used is E_RECOVERABLE_ERROR.

Please, see also configuration file debugging notes.

mysqlnd_ms.ini_file string

Plugin specific configuration file. This setting has been renamed to mysqlnd_ms.config_file in version 1.4.0.

mysqlnd_ms.config_file string

Plugin specific configuration file. This setting superseeds mysqlnd_ms.ini_file since 1.4.0.

mysqlnd_ms.collect_statistics integer

Enables or disables the collection of statistics. The collection of statistics is disabled by default for performance reasons. Statistics are returned by the function mysqlnd_ms_get_stats().

mysqlnd_ms.multi_master integer

Enables or disables support of MySQL multi master replication setups. Please, see also supported clusters.

mysqlnd_ms.disable_rw_split integer

Enables or disables built-in read write splitting.

Controls whether load balancing and lazy connection functionality can be used independently of read write splitting. If read write splitting is disabled, only servers from the master list will be used for statement execution. All configured slave servers will be ignored.

The SQL hint MYSQLND_MS_USE_SLAVE will not be recognized. If found, the statement will be redirected to a master.

Disabling read write splitting impacts the return value of mysqlnd_ms_query_is_select(). The function will no longer propose query execution on slave servers.

Bilginize: Multiple master servers

Setting mysqlnd_ms.multi_master=1 allows the plugin to use multiple master servers, instead of only the first master server of the master list.

Please, see also supported clusters.

Kurulum
Plugin configuration file (>=1.1.x)
Yapılandırma/Kurulum


Plugin configuration file (>=1.1.x)

The following documentation applies to PECL/mysqlnd_ms >= 1.1.0-beta. It is not valid for prior versions. For documentation covering earlier versions, see the configuration documentation for mysqlnd_ms 1.0.x and below.

Introduction

Bilginize: Changelog: Feature was added in PECL/mysqlnd_ms 1.1.0-beta

The below description applies to PECL/mysqlnd_ms >= 1.1.0-beta. It is not valid for prior versions.

The plugin uses its own configuration file. The configuration file holds information about the MySQL replication master server, the MySQL replication slave servers, the server pick (load balancing) policy, the failover strategy, and the use of lazy connections.

The plugin loads its configuration file at the beginning of a web request. It is then cached in memory and used for the duration of the web request. This way, there is no need to restart PHP after deploying the configuration file. Configuration file changes will become active almost instantly.

The PHP configuration directive mysqlnd_ms.config_file is used to set the plugins configuration file. Please note, that the PHP configuration directive may not be evaluated for every web request. Therefore, changing the plugins configuration file name or location may require a PHP restart. However, no restart is required to read changes if an already existing plugin configuration file is updated.

Using and parsing JSON is efficient, and using JSON makes it easier to express hierarchical data structures than the standard php.ini format.

Örnek 1 Converting a PHP array (hash) into JSON format

Or alternatively, a developer may be more familiar with the PHP array syntax, and prefer it. This example demonstrates how a developer might convert a PHP array to JSON.

<?php
$config = array(
  "myapp" => array(
    "master" => array(
      "master_0" => array(
        "host"   => "localhost",
        "socket" => "/tmp/mysql.sock",
      ),
    ),
    "slave" => array(),
  ),
);

file_put_contents("mysqlnd_ms.ini", json_encode($config, JSON_PRETTY_PRINT));
printf("mysqlnd_ms.ini file created...\n");
printf("Dumping file contents...\n");
printf("%s\n", str_repeat("-", 80));
echo file_get_contents("mysqlnd_ms.ini");
printf("\n%s\n", str_repeat("-", 80));
?>

Yukarıdaki örneğin çıktısı:

mysqlnd_ms.ini file created...
Dumping file contents...
--------------------------------------------------------------------------------
{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": [

        ]
    }
}
--------------------------------------------------------------------------------

A plugin configuration file consists of one or more sections. Sections are represented by the top-level object properties of the object encoded in the JSON file. Sections could also be called configuration names.

Applications reference sections by their name. Applications use section names as the host (server) parameter to the various connect methods of the mysqli, mysql and PDO_MYSQL extensions. Upon connect, the mysqlnd plugin compares the hostname with all of the section names from the plugin configuration file. If the hostname and section name match, then the plugin will load the settings for that section.

Örnek 2 Using section names example

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.2.27"
            },
            "slave_1": {
                "host": "192.168.2.27",
                "port": 3306
            }
        }
    },
    "localhost": {
        "master": [
            {
                "host": "localhost",
                "socket": "\/path\/to\/mysql.sock"
            }
        ],
        "slave": [
            {
                "host": "192.168.3.24",
                "port": "3305"
            },
            {
                "host": "192.168.3.65",
                "port": "3309"
            }
        ]
    }
}
<?php
/* All of the following connections will be load balanced */
$mysqli = new mysqli("myapp", "username", "password", "database");
$pdo = new PDO('mysql:host=myapp;dbname=database', 'username', 'password');
$mysql = mysql_connect("myapp", "username", "password");

$mysqli = new mysqli("localhost", "username", "password", "database");
?>

Section names are strings. It is valid to use a section name such as 192.168.2.1, 127.0.0.1 or localhost. If, for example, an application connects to localhost and a plugin configuration section localhost exists, the semantics of the connect operation are changed. The application will no longer only use the MySQL server running on the host localhost, but the plugin will start to load balance MySQL queries following the rules from the localhost configuration section. This way you can load balance queries from an application without changing the applications source code. Please keep in mind, that such a configuration may not contribute to overall readability of your applications source code. Using section names that can be mixed up with host names should be seen as a last resort.

Each configuration section contains, at a minimum, a list of master servers and a list of slave servers. The master list is configured with the keyword master, while the slave list is configured with the slave keyword. Failing to provide a slave list will result in a fatal E_ERROR level error, although a slave list may be empty. It is possible to allow no slaves. However, this is only recommended with synchronous clusters, please see also supported clusters. The main part of the documentation focusses on the use of asynchronous MySQL replication clusters.

The master and slave server lists can be optionally indexed by symbolic names for the servers they describe. Alternatively, an array of descriptions for slave and master servers may be used.

Örnek 3 List of anonymous slaves

"slave": [
    {
        "host": "192.168.3.24",
        "port": "3305"
    },
    {
        "host": "192.168.3.65",
        "port": "3309"
    }
]

An anonymous server list is encoded by the JSON array type. Optionally, symbolic names may be used for indexing the slave or master servers of a server list, and done so using the JSON object type.

Örnek 4 Master list using symbolic names

"master": {
    "master_0": {
        "host": "localhost"
    }
}

It is recommended to index the server lists with symbolic server names. The alias names will be shown in error messages.

The order of servers is preserved and taken into account by mysqlnd_ms. If, for example, you configure round robin load balancing strategy, the first SELECT statement will be executed on the slave that appears first in the slave server list.

A configured server can be described with the host, port, socket, db, user, password and connect_flags. It is mandatory to set the database server host using the host keyword. All other settings are optional.

Örnek 5 Keywords to configure a server

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "db_server_host",
                "port": "db_server_port",
                "socket": "db_server_socket",
                "db": "database_resp_schema",
                "user": "user",
                "password": "password",
                "connect_flags": 0
            }
        },
        "slave": {
            "slave_0": {
                "host": "db_server_host",
                "port": "db_server_port",
                "socket": "db_server_socket"
            }
        }
    }
}

If a setting is omitted, the plugin will use the value provided by the user API call used to open a connection. Please, see the using section names example above.

The configuration file format has been changed in version 1.1.0-beta to allow for chained filters. Filters are responsible for filtering the configured list of servers to identify a server for execution of a given statement. Filters are configured with the filter keyword. Filters are executed by mysqlnd_ms in the order of their appearance. Defining filters is optional. A configuration section in the plugins configuration file does not need to have a filters entry.

Filters replace the pick[] setting from prior versions. The new random and roundrobin provide the same functionality.

Örnek 6 New roundrobin filter, old functionality

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.78.136",
                "port": "3306"
            },
            "slave_1": {
                "host": "192.168.78.137",
                "port": "3306"
            }
        },
        "filters": {
            "roundrobin": [

            ]
        }
    }
}

The function mysqlnd_ms_set_user_pick_server() has been removed. Setting a callback is now done with the user filter. Some filters accept parameters. The user filter requires and accepts a mandatory callback parameter to set the callback previously set through the function mysqlnd_ms_set_user_pick_server().

Örnek 7 The user filter replaces mysqlnd_ms_set_user_pick_server()

"filters": {
    "user": {
        "callback": "pick_server"
    }
}

The validity of the configuration file is checked both when reading the configuration file and later when establishing a connection. The configuration file is read during PHP request startup. At this early stage a PHP extension may not display error messages properly. In the worst case, no error is shown and a connection attempt fails without an adequate error message. This problem has been cured in version 1.5.0.

Örnek 8 Common error message in case of configuration file issues (upto version 1.5.0)

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
?>

Yukarıdaki örneğin çıktısı:

Warning: mysqli::mysqli(): (mysqlnd_ms) (mysqlnd_ms) Failed to parse config file [s1.json]. Please, verify the JSON in Command line code

Warning: mysqli::mysqli(): (HY000/2002): php_network_getaddresses: getaddrinfo failed: Name or service not known in Command line code on line 1

Warning: mysqli::query(): Couldn't fetch mysqli in Command line code on line 1

Fatal error: Call to a member function fetch_assoc() on a non-object in Command line code on line 1

Since version 1.5.0 startup errors are additionally buffered and emitted when a connection attempt is made. Use the configuration directive mysqlnd_ms.force_config_usage to set the error type used to display buffered errors. By default an error of type E_WARNING will be emitted.

Örnek 9 Improved configuration file validation since 1.5.0

<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
?>

Yukarıdaki örneğin çıktısı:

Warning: mysqli::mysqli(): (mysqlnd_ms) (mysqlnd_ms) Failed to parse config file [s1.json]. Please, verify the JSON in Command line code on line 1

It can be useful to set mysqlnd_ms.force_config_usage = 1 when debugging potential configuration file errors. This will not only turn the type of buffered startup errors into E_RECOVERABLE_ERROR but also help detecting misspelled section names.

Örnek 10 Possibly more precise error due to mysqlnd_ms.force_config_usage=1

mysqlnd_ms.force_config_usage=1
<?php
$mysqli = new mysqli("invalid_section", "username", "password", "database");
?>

Yukarıdaki örneğin çıktısı:

Warning: mysqli::mysqli(): (mysqlnd_ms) Exclusive usage of configuration enforced but did not find the correct INI file section (invalid_section) in Command line code on line 1 line 1

Configuration Directives

Here is a short explanation of the configuration directives that can be used.

master array or object

List of MySQL replication master servers. The list of either of the JSON type array to declare an anonymous list of servers or of the JSON type object. Please, see above for examples.

Setting at least one master server is mandatory. The plugin will issue an error of type E_ERROR if the user has failed to provide a master server list for a configuration section. The fatal error may read (mysqlnd_ms) Section [master] doesn't exist for host [name_of_a_config_section] in %s on line %d.

A server is described with the host, port, socket, db, user, password and connect_flags. It is mandatory to provide at a value for host. If any of the other values is not given, it will be taken from the user API connect call, please, see also: using section names example.

Table of server configuration keywords.

Keyword Description Version
host

Database server host. This is a mandatory setting. Failing to provide, will cause an error of type E_RECOVERABLE_ERROR when the plugin tries to connect to the server. The error message may read (mysqlnd_ms) Cannot find [host] in [%s] section in config in %s on line %d.

Since 1.1.0.
port

Database server TCP/IP port.

Since 1.1.0.
socket

Database server Unix domain socket.

Since 1.1.0.
db

Database (schemata).

Since 1.1.0.
user

MySQL database user.

Since 1.1.0.
password

MySQL database user password.

Since 1.1.0.
connect_flags

Connection flags.

Since 1.1.0.

The plugin supports using only one master server. An experimental setting exists to enable multi-master support. The details are not documented. The setting is meant for development only.

slave array or object

List of one or more MySQL replication slave servers. The syntax is identical to setting master servers, please, see master above for details.

The plugin supports using one or more slave servers.

Setting a list of slave servers is mandatory. The plugin will report an error of the type E_ERROR if slave is not given for a configuration section. The fatal error message may read (mysqlnd_ms) Section [slave] doesn't exist for host [%s] in %s on line %d. Note, that it is valid to use an empty slave server list. The error has been introduced to prevent accidently setting no slaves by forgetting about the slave setting. A master-only setup is still possible using an empty slave server list.

If an empty slave list is configured and an attempt is made to execute a statement on a slave the plugin may emit a warning like mysqlnd_ms) Couldn't find the appropriate slave connection. 0 slaves to choose from. upon statement execution. It is possible that another warning follows such as (mysqlnd_ms) No connection selected by the last filter.

global_transaction_id_injection array or object

Global transaction identifier configuration related to both the use of the server built-in global transaction ID feature and the client-side emulation.

Keyword Description Version
fetch_last_gtid

SQL statement for accessing the latest global transaction identifier. The SQL statement is run if the plugin needs to know the most recent global transaction identifier. This can be the case, for example, when checking MySQL Replication slave status. Also used with mysqlnd_ms_get_last_gtid().

Since 1.2.0.
check_for_gtid

SQL statement for checking if a replica has replicated all transactions up to and including ones searched for. The SQL statement is run when searching for replicas which can offer a higher level of consistency than eventual consistency. The statement must contain a placeholder #GTID which is to be replaced with the global transaction identifier searched for by the plugin. Please, check the quickstart for examples.

Since 1.2.0.
report_errors

Whether to emit an error of type warning if an issue occurs while executing any of the configured SQL statements.

Since 1.2.0.
on_commit

Client-side global transaction ID emulation only. SQL statement to run when a transaction finished to update the global transaction identifier sequence number on the master. Please, see the quickstart for examples.

Since 1.2.0.
wait_for_gtid_timeout

Instructs the plugin to wait up to wait_for_gtid_timeout seconds for a slave to catch up when searching for slaves that can deliver session consistency. The setting limits the time spend for polling the slave status. If polling the status takes very long, the total clock time spend waiting may exceed wait_for_gtid_timeout. The plugin calls sleep(1) to sleep one second between each two polls.

The setting can be used both with the plugins client-side emulation and the server-side global transaction identifier feature of MySQL 5.6.

Waiting for a slave to replicate a certain GTID needed for session consistency also means throttling the client. By throttling the client the write load on the master is reduced indirectly. A primary copy based replication system, such as MySQL Replication, is given more time to reach a consistent state. This can be desired, for example, to increase the number of data copies for high availability considerations or to prevent the master from being overloaded.

Since 1.4.0.
fabric object

MySQL Fabric related settings. If the plugin is used together with MySQL Fabric, then the plugins configuration file no longer contains lists of MySQL servers. Instead, the plugin will ask MySQL Fabric which list of servers to use to perform a certain task.

A minimum plugin configuration for use with MySQL Fabric contains a list of one or more MySQL Fabric hosts that the plugin can query. If more than one MySQL Fabric host is configured, the plugin will use a roundrobin strategy to choose among them. Other strategies are currently not available.

Örnek 11 Minimum pluging configuration for use with MySQL Fabric

{
    "myapp": {
        "fabric": {
            "hosts": [
                {
                    "host" : "127.0.0.1",
                    "port" : 8080
                }
            ]
        }
    }
}

Each MySQL Fabric host is described using a JSON object with the following members.

Keyword Description Version
host

Host name of the MySQL Fabric host.

Since 1.6.0.
port

The TCP/IP port on which the MySQL Fabric host listens for remote procedure calls sent by clients such as the plugin.

Since 1.6.0.

The plugin is using PHP streams to communicate with MySQL Fabric through XML RPC over HTTP. By default no timeouts are set for the network communication. Thus, the plugin defaults to PHP stream default timeouts. Those defaults are out of control of the plugin itself.

An optional timeout value can be set to overrule the PHP streams default timeout setting. Setting the timeout in the plugins configuration file has the same effect as setting a timeout for a PHP user space HTTP connection established through PHP streams.

The plugins Fabric timeout value unit is seconds. The allowed value range is from 0 to 65535. The setting exists since version 1.6.

Örnek 12 Optional timeout for communication with Fabric

{
    "myapp": {
        "fabric": {
            "hosts": [
                {
                    "host" : "127.0.0.1",
                    "port" : 8080
                }
            ],
            "timeout": 2
        }
    }
}

Transaction stickiness and MySQL Fabric logic can collide. The stickiness option disables switching between servers for the duration of a transaction. When using Fabric and sharding the user may (erroneously) start a local transaction on one share and then attempt to switch to a different shard using either mysqlnd_ms_fabric_select_shard() or mysqlnd_ms_fabric_select_global(). In this case, the plugin will not reject the request to switch servers in the middle of a transaction but allow the user to switch to another server regardless of the transaction stickiness setting used. It is clearly a user error to write such code.

If transaction stickiness is enabled and you would like to get an error of type warning when calling mysqlnd_ms_fabric_select_shard() or mysqlnd_ms_fabric_select_global(), set the boolean flag trx_warn_server_list_changes.

Örnek 13 Warnings about the violation of transaction boundaries

{
    "myapp": {
        "fabric": {
            "hosts": [
                {
                    "host" : "127.0.0.1",
                    "port" : 8080
                }
            ],
            "trx_warn_serverlist_changes": 1
        },
        "trx_stickiness": "on"
    }
}
<?php
$link = new mysqli("myapp", "root", "", "test");
/*
  For the demo the call may fail.
  Failed or not we get into the state
  needed for the example.
*/
@mysqlnd_ms_fabric_select_global($link, 1);
$link->begin_transaction();
@$link->query("DROP TABLE IF EXISTS test");
/*
  Switching servers/shards is a mistake due to open
  local transaction!
*/
mysqlnd_ms_select_global($link, 1);
?>

Yukarıdaki örneğin çıktısı:

PHP Warning: mysqlnd_ms_fabric_select_global(): (mysqlnd_ms) Fabric server exchange in the middle of a transaction in %s on line %d

Please, consider the feature experimental. Changes to syntax and semantics may happen.

filters object

List of filters. A filter is responsible to filter the list of available servers for executing a given statement. Filters can be chained. The random and roundrobin filter replace the pick[] directive used in prior version to select a load balancing policy. The user filter replaces the mysqlnd_ms_set_user_pick_server() function.

Filters may accept parameters to refine their actions.

If no load balancing policy is set, the plugin will default to random_once. The random_once policy picks a random slave server when running the first read-only statement. The slave server will be used for all read-only statements until the PHP script execution ends. No load balancing policy is set and thus, defaulting takes place, if neither the random nor the roundrobin are part of a configuration section.

If a filter chain is configured so that a filter which output no more than once server is used as input for a filter which should be given more than one server as input, the plugin may emit a warning upon opening a connection. The warning may read: (mysqlnd_ms) Error while creating filter '%s' . Non-multi filter '%s' already created. Stopping in %s on line %d. Furthermore, an error of the error code 2000, the sql state HY000 and an error message similar to the warning may be set on the connection handle.

Örnek 14 Invalid filter sequence

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.78.136",
                "port": "3306"
            }
        },
        "filters": [
            "roundrobin",
            "random"
        ]
    }
}
<?php
$link = new mysqli("myapp", "root", "", "test");
printf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error());
$link->query("SELECT 1 FROM DUAL");
?>

Yukarıdaki örneğin çıktısı:

PHP Warning:  mysqli::mysqli(): (HY000/2000): (mysqlnd_ms) Error while creating filter 'random' . Non-multi filter 'roundrobin' already created. Stopping in filter_warning.php on line 1
[2000] (mysqlnd_ms) Error while creating filter 'random' . Non-multi filter 'roundrobin' already created. Stopping
PHP Warning:  mysqli::query(): Couldn't fetch mysqli in filter_warning.php on line 3

Filter: random object

The random filter features the random and random once load balancing policies, set through the pick[] directive in older versions.

The random policy will pick a random server whenever a read-only statement is to be executed. The random once strategy picks a random slave server once and continues using the slave for the rest of the PHP web request. Random once is a default, if load balancing is not configured through a filter.

If the random filter is not given any arguments, it stands for random load balancing policy.

Örnek 15 Random load balancing with random filter

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.78.136",
                "port": "3306"
            },
            "slave_1": {
                "host": "192.168.78.137",
                "port": "3306"
            }
        },
        "filters": [
            "random"
        ]
    }
}

Optionally, the sticky argument can be passed to the filter. If the parameter sticky is set to the string 1, the filter follows the random once load balancing strategy.

Örnek 16 Random once load balancing with random filter

{
    "filters": {
        "random": {
            "sticky": "1"
        }
    }
}

Both the random and roundrobin filters support setting a priority, a weight for a server, since PECL/mysqlnd_ms 1.4.0. If the weight argument is passed to the filter, it must assign a weight for all servers. Servers must be given an alias name in the slave respectively master server lists. The alias must be used to reference servers for assigning a priority with weight.

Örnek 17 Referencing error

[E_RECOVERABLE_ERROR] mysqli_real_connect(): (mysqlnd_ms) Unknown server 'slave3' in 'random' filter configuration. Stopping in %s on line %d

Using a wrong alias name with weight may result in an error similar to the shown above.

If weight is omitted, the default weight of all servers is one.

Örnek 18 Assigning a weight for load balancing

{
   "myapp": {
       "master": {
           "master1":{
               "host":"localhost",
               "socket":"\/var\/run\/mysql\/mysql.sock"
           }
       },
       "slave": {
           "slave1": {
               "host":"192.168.2.28",
               "port":3306
           },
           "slave2": {
               "host":"192.168.2.29",
               "port":3306
           },
           "slave3": {
               "host":"192.0.43.10",
               "port":3306
           },
       },
       "filters": {
           "random": {
               "weights": {
                   "slave1":8,
                   "slave2":4,
                   "slave3":1,
                   "master1":1
               }
           }
       }
   }
}

At the average a server assigned a weight of two will be selected twice as often as a server assigned a weight of one. Different weights can be assigned to reflect differently sized machines, to prefer co-located slaves which have a low network latency or, to configure a standby failover server. In the latter case, you may want to assign the standby server a very low weight in relation to the other servers. For example, given the configuration above slave3 will get only some eight percent of the requests in the average. As long as slave1 and slave2 are running, it will be used sparsely, similar to a standby failover server. Upon failure of slave1 and slave2, the usage of slave3 increases. Please, check the notes on failover before using weight this way.

Valid weight values range from 1 to 65535.

Unknown arguments are ignored by the filter. No warning or error is given.

The filter expects one or more servers as input. Outputs one server. A filter sequence such as random, roundrobin may cause a warning and an error message to be set on the connection handle when executing a statement.

List of filter arguments.

Keyword Description Version
sticky

Enables or disabled random once load balancing policy. See above.

Since 1.2.0.
weight

Assigns a load balancing weight/priority to a server. Please, see above for a description.

Since 1.4.0.
Filter: roundrobin object

If using the roundrobin filter, the plugin iterates over the list of configured slave servers to pick a server for statement execution. If the plugin reaches the end of the list, it wraps around to the beginning of the list and picks the first configured slave server.

Örnek 19 roundrobin filter

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.78.136",
                "port": "3306"
            }
        },
        "filters": [
            "roundrobin"
        ]
    }
}

Expects one or more servers as input. Outputs one server. A filter sequence such as roundrobin, random may cause a warning and an error message to be set on the connection handle when executing a statement.

List of filter arguments.

Keyword Description Version
weight

Assigns a load balancing weight/priority to a server. Please, find a description above.

Since 1.4.0.
Filter: user object

The user replaces mysqlnd_ms_set_user_pick_server() function, which was removed in 1.1.0-beta. The filter sets a callback for user-defined read/write splitting and server selection.

The plugins built-in read/write query split mechanism decisions can be overwritten in two ways. The easiest way is to prepend a query string with the SQL hints MYSQLND_MS_MASTER_SWITCH, MYSQLND_MS_SLAVE_SWITCH or MYSQLND_MS_LAST_USED_SWITCH. Using SQL hints one can control, for example, whether a query shall be send to the MySQL replication master server or one of the slave servers. By help of SQL hints it is not possible to pick a certain slave server for query execution.

Full control on server selection can be gained using a callback function. Use of a callback is recommended to expert users only because the callback has to cover all cases otherwise handled by the plugin.

The plugin will invoke the callback function for selecting a server from the lists of configured master and slave servers. The callback function inspects the query to run and picks a server for query execution by returning the hosts URI, as found in the master and slave list.

If the lazy connections are enabled and the callback chooses a slave server for which no connection has been established so far and establishing the connection to the slave fails, the plugin will return an error upon the next action on the failed connection, for example, when running a query. It is the responsibility of the application developer to handle the error. For example, the application can re-run the query to trigger a new server selection and callback invocation. If so, the callback must make sure to select a different slave, or check slave availability, before returning to the plugin to prevent an endless loop.

Örnek 20 Setting a callback

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.78.136",
                "port": "3306"
            }
        },
        "filters": {
            "user": {
                "callback": "pick_server"
            }
        }
    }
}

The callback is supposed to return a host to run the query on. The host URI is to be taken from the master and slave connection lists passed to the callback function. If callback returns a value neither found in the master nor in the slave connection lists the plugin will emit an error of the type E_RECOVERABLE_ERROR The error may read like (mysqlnd_ms) User filter callback has returned an unknown server. The server 'server that is not in master or slave list' can neither be found in the master list nor in the slave list. If the application catches the error to ignore it, follow up errors may be set on the connection handle, for example, (mysqlnd_ms) No connection selected by the last filter with the error code 2000 and the sqlstate HY000. Furthermore a warning may be emitted.

Referencing a non-existing function as a callback will result in any error of the type E_RECOVERABLE_ERROR whenever the plugin tries to callback function. The error message may reads like: (mysqlnd_ms) Specified callback (pick_server) is not a valid callback. If the application catches the error to ignore it, follow up errors may be set on the connection handle, for example, (mysqlnd_ms) Specified callback (pick_server) is not a valid callback with the error code 2000 and the sqlstate HY000. Furthermore a warning may be emitted.

The following parameters are passed from the plugin to the callback.

Parameter Description Version
connected_host

URI of the currently connected database server.

Since 1.1.0.
query

Query string of the statement for which a server needs to be picked.

Since 1.1.0.
masters

List of master servers to choose from. Note, that the list of master servers may not be identical to the list of configured master servers if the filter is not the first in the filter chain. Previously run filters may have reduced the master list already.

Since 1.1.0.
slaves

List of slave servers to choose from. Note, that the list of master servers may not be identical to the list of configured master servers if the filter is not the first in the filter chain. Previously run filters may have reduced the master list already.

Since 1.1.0.
last_used_connection

URI of the server of the connection used to execute the previous statement on.

Since 1.1.0.
in_transaction

Boolean flag indicating whether the statement is part of an open transaction. If autocommit mode is turned off, this will be set to TRUE. Otherwise it is set to FALSE.

Transaction detection is based on monitoring the mysqlnd library call set_autocommit. Monitoring is not possible before PHP 5.4.0. Please, see connection pooling and switching concepts discussion for further details.

Since 1.1.0.

Örnek 21 Using a callback

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.2.27",
                "port": "3306"
            },
            "slave_1": {
                "host": "192.168.78.136",
                "port": "3306"
            }
        },
        "filters": {
            "user": {
                "callback": "pick_server"
            }
        }
    }
}
<?php
function pick_server($connected, $query, $masters, $slaves, $last_used_connection, $in_transaction)
{
 static $slave_idx = 0;
 static $num_slaves = NULL;
 if (is_null($num_slaves))
  $num_slaves = count($slaves);

 /* default: fallback to the plugins build-in logic */
 $ret = NULL;

 printf("User has connected to '%s'...\n", $connected);
 printf("... deciding where to run '%s'\n", $query);

 $where = mysqlnd_ms_query_is_select($query);
 switch ($where)
 {
  case MYSQLND_MS_QUERY_USE_MASTER:
   printf("... using master\n");
   $ret = $masters[0];
   break;
  case MYSQLND_MS_QUERY_USE_SLAVE:
   /* SELECT or SQL hint for using slave */
   if (stristr($query, "FROM table_on_slave_a_only"))
   {
    /* a table which is only on the first configured slave  */
    printf("... access to table available only on slave A detected\n");
    $ret = $slaves[0];
   }
   else
   {
    /* round robin */
    printf("... some read-only query for a slave\n");
    $ret = $slaves[$slave_idx++ % $num_slaves];
   }
   break;
  case MYSQLND_MS_QUERY_LAST_USED:
   printf("... using last used server\n");
   $ret = $last_used_connection;
   break;
 }

 printf("... ret = '%s'\n", $ret);
 return $ret;
}

$mysqli = new mysqli("myapp", "root", "", "test");

if (!($res = $mysqli->query("SELECT 1 FROM DUAL")))
 printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
else
 $res->close();

if (!($res = $mysqli->query("SELECT 2 FROM DUAL")))
 printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
else
 $res->close();

if (!($res = $mysqli->query("SELECT * FROM table_on_slave_a_only")))
 printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
else
 $res->close();

$mysqli->close();
?>

Yukarıdaki örneğin çıktısı:

User has connected to 'myapp'...
... deciding where to run 'SELECT 1 FROM DUAL'
... some read-only query for a slave
... ret = 'tcp://192.168.2.27:3306'
User has connected to 'myapp'...
... deciding where to run 'SELECT 2 FROM DUAL'
... some read-only query for a slave
... ret = 'tcp://192.168.78.136:3306'
User has connected to 'myapp'...
... deciding where to run 'SELECT * FROM table_on_slave_a_only'
... access to table available only on slave A detected
... ret = 'tcp://192.168.2.27:3306'

Filter: user_multi object

The user_multi differs from the user only in one aspect. Otherwise, their syntax is identical. The user filter must pick and return exactly one node for statement execution. A filter chain usually ends with a filter that emits only one node. The filter chain shall reduce the list of candidates for statement execution down to one. This, only one node left, is the case after the user filter has been run.

The user_multi filter is a multi filter. It returns a list of slave and a list of master servers. This list needs further filtering to identify exactly one node for statement execution. A multi filter is typically placed at the top of the filter chain. The quality_of_service filter is another example of a multi filter.

The return value of the callback set for user_multi must be an array with two elements. The first element holds a list of selected master servers. The second element contains a list of selected slave servers. The lists shall contain the keys of the slave and master servers as found in the slave and master lists passed to the callback. The below example returns random master and slave lists extracted from the functions input.

Örnek 22 Returning random masters and slaves

<?php
function pick_server($connected, $query, $masters, $slaves, $last_used_connection, $in_transaction)
{
  $picked_masters = array()
  foreach ($masters as $key => $value) {
    if (mt_rand(0, 2) > 1)
      $picked_masters[] = $key;
  }
  $picked_slaves = array()
  foreach ($slaves as $key => $value) {
    if (mt_rand(0, 2) > 1)
      $picked_slaves[] = $key;
  }
  return array($picked_masters, $picked_slaves);
}
?>

The plugin will issue an error of type E_RECOVERABLE if the callback fails to return a server list. The error may read (mysqlnd_ms) User multi filter callback has not returned a list of servers to use. The callback must return an array in %s on line %d. In case the server list is not empty but has invalid servers key/ids in it, an error of type E_RECOVERABLE will the thrown with an error message like (mysqlnd_ms) User multi filter callback has returned an invalid list of servers to use. Server id is negative in %s on line %d, or similar.

Whether an error is emitted in case of an empty slave or master list depends on the configuration. If an empty master list is returned for a write operation, it is likely that the plugin will emit a warning that may read (mysqlnd_ms) Couldn't find the appropriate master connection. 0 masters to choose from. Something is wrong in %s on line %d. Typically a follow up error of type E_ERROR will happen. In case of a read operation and an empty slave list the behavior depends on the fail over configuration. If fail over to master is enabled, no error should appear. If fail over to master is deactivated the plugin will emit a warning that may read (mysqlnd_ms) Couldn't find the appropriate slave connection. 0 slaves to choose from. Something is wrong in %s on line %d.

Filter: node_groups object

The node_groups filter lets you group cluster nodes and query selected groups, for example, to support data partitioning. Data partitioning can be required for manual sharding, primary copy based clusters running multiple masters, or to avoid hot spots in update everywhere clusters that have no built-in partitioning. The filter is a multi filter which returns zero, one or multiple of its input servers. Thus, it must be followed by other filters to reduce the number of candidates down to one for statement execution.

Keyword Description Version
user defined node group name

One or more node groups must be defined. A node group can have an arbitrary user defined name. The name is used in combination with a SQL hint to restrict query execution to the nodes listed for the node group. To run a query on any of the servers of a node group, the query must begin with the SQL hint /*user defined node group name*/. Please note, no white space is allowed around user defined node group name. Because user defined node group name is used as-is as part of a SQL hint, you should choose the name that is compliant with the SQL language.

Each node group entry must contain a list of master servers. Additional slave servers are allowed. Failing to provide a list of master for a node group name_of_group may cause an error of type E_RECOVERABLE_ERROR like (mysqlnd_ms) No masters configured in node group 'name_of_group' for 'node_groups' filter.

The list of master and slave servers must reference corresponding entries in the global master respectively slave server list. Referencing an unknown server in either of the both server lists may cause an E_RECOVERABLE_ERROR error like (mysqlnd_ms) Unknown master 'server_alias_name' (section 'name_of_group') in 'node_groups' filter configuration.

Örnek 23 Manual partitioning

{
  "myapp": {
       "master": {
            "master_0": {
                "host": "localhost",
                "socket": "\/tmp\/mysql.sock"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.2.28",
                "port": 3306
            },
            "slave_1": {
                "host": "127.0.0.1",
                "port": 3311
            }
        },
        "filters": {
            "node_groups": {
                "Partition_A" : {
                    "master": ["master_0"],
                    "slave": ["slave_0"]
                }
            },
           "roundrobin": []
        }
    }
}

Please note, if a filter chain generates an empty slave list and the PHP configuration directive mysqlnd_ms.multi_master=0 is used, the plugin may emit a warning.

Since 1.5.0.
Filter: quality_of_service object

The quality_of_service identifies cluster nodes capable of delivering a certain quality of service. It is a multi filter which returns zero, one or multiple of its input servers. Thus, it must be followed by other filters to reduce the number of candidates down to one for statement execution.

The quality_of_service filter has been introduced in 1.2.0-alpha. In the 1.2 series the filters focus is on the consistency aspect of service quality. Different types of clusters offer different default data consistencies. For example, an asynchronous MySQL replication slave offers eventual consistency. The slave may not be able to deliver requested data because it has not replicated the write, it may serve stale database because its lagging behind or it may serve current information. Often, this is acceptable. In some cases higher consistency levels are needed for the application to work correct. In those cases, the quality_of_service can filter out cluster nodes which cannot deliver the necessary quality of service.

The quality_of_service filter can be replaced or created at runtime. A successful call to mysqlnd_ms_set_qos() removes all existing qos filter entries from the filter list and installs a new one at the very beginning. All settings that can be made through mysqlnd_ms_set_qos() can also be in the plugins configuration file. However, use of the function is by far the most common use case. Instead of setting session consistency and strong consistency service levels in the plugins configuration file it is recommended to define only masters and no slaves. Both service levels will force the use of masters only. Using an empty slave list shortens the configuration file, thus improving readability. The only service level for which there is a case of defining in the plugins configuration file is the combination of eventual consistency and maximum slave lag.

Keyword Description Version
eventual_consistency

Request eventual consistency. Allows the use of all master and slave servers. Data returned may or may not be current.

Eventual consistency accepts an optional age parameter. If age is given the plugin considers only slaves for reading for which MySQL replication reports a slave lag less or equal to age. The replication lag is measure using SHOW SLAVE STATUS. If the plugin fails to fetch the replication lag, the slave tested is skipped. Implementation details and tips are given in the quality of service concepts section.

Please note, if a filter chain generates an empty slave list and the PHP configuration directive mysqlnd_ms.multi_master=0 is used, the plugin may emit a warning.

Örnek 24 Global limit on slave lag

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.2.27",
                "port": "3306"
            },
            "slave_1": {
                "host": "192.168.78.136",
                "port": "3306"
            }
        },
        "filters": {
            "quality_of_service": {
                "eventual_consistency": {
                    "age":123
                }
            }
        }
    }
}

 Since 1.2.0.
session_consistency

Request session consistency (read your writes). Allows use of all masters and all slaves which are in sync with the master. If no further parameters are given slaves are filtered out as there is no reliable way to test if a slave has caught up to the master or is lagging behind. Please note, if a filter chain generates an empty slave list and the PHP configuration directive mysqlnd_ms.multi_master=0 is used, the plugin may emit a warning.

Session consistency temporarily requested using mysqlnd_ms_set_qos() is a valuable alternative to using master_on_write. master_on_write is likely to send more statements to the master than needed. The application may be able to continue operation at a lower consistency level after it has done some critical reads.

Since 1.1.0.
strong_consistency

Request strong consistency. Only masters will be used.

Since 1.2.0.
failover Up to and including 1.3.x: string. Since 1.4.0: object.

Failover policy. Supported policies: disabled (default), master, loop_before_master (Since 1.4.0).

If no failover policy is set, the plugin will not do any automatic failover (failover=disabled). Whenever the plugin fails to connect a server it will emit a warning and set the connections error code and message. Thereafter it is up to the application to handle the error and, for example, resent the last statement to trigger the selection of another server.

Please note, the automatic failover logic is applied when opening connections only. Once a connection has been opened no automatic attempts are made to reopen it in case of an error. If, for example, the server a connection is connected to is shut down and the user attempts to run a statement on the connection, no automatic failover will be tried. Instead, an error will be reported.

If using failover=master the plugin will implicitly failover to a master, if available. Please check the concepts documentation to learn about potential pitfalls and risks of using failover=master.

Örnek 25 Optional master failover when failing to connect to slave (PECL/mysqlnd_ms < 1.4.0)

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.78.136",
                "port": "3306"
            }
        },
        "failover": "master"
    }
}

Since PECL/mysqlnd_ms 1.4.0 the failover configuration keyword refers to an object.

Örnek 26 New syntax since 1.4.0

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.78.136",
                "port": "3306"
            }
        },
        "failover": {"strategy": "master" }
    }
}

Keyword Description Version
strategy

Failover policy. Possible values: disabled (default), master, loop_before_master

A value of disabled disables automatic failover.

Setting master instructs the plugin to try to connect to a master in case of a slave connection error. If the master connection attempt fails, the plugin exists the failover loop and returns an error to the user.

If using loop_before_master and a slave request is made, the plugin tries to connect to other slaves before failing over to a master. If multiple master are given and multi master is enabled, the plugin also loops over the list of masters and attempts to connect before returning an error to the user.

Since 1.4.0.
remember_failed

Remember failures for the duration of a web request. Default: false.

If set to true the plugin will remember failed hosts and skip the hosts in all future load balancing made for the duration of the current web request.

Since 1.4.0. The feature is only available together with the random and roundrobin load balancing filter. Use of the setting is recommended.
max_retries

Maximum number of connection attempts before skipping host. Default: 0 (no limit).

The setting is used to prevent hosts from being dropped of the host list upon the first failure. If set to n > 0, the plugin will keep the node in the node list even after a failed connection attempt. The node will not be removed immediately from the slave respectively master lists after the first connection failure but instead be tried to connect to up to n times in future load balancing rounds before being removed.

Since 1.4.0. The feature is only available together with the random and roundrobin load balancing filter.

Setting failover to any other value but disabled, master or loop_before_master will not emit any warning or error.

lazy_connections bool

Controls the use of lazy connections. Lazy connections are connections which are not opened before the client sends the first connection. Lazy connections are a default.

It is strongly recommended to use lazy connections. Lazy connections help to keep the number of open connections low. If you disable lazy connections and, for example, configure one MySQL replication master server and two MySQL replication slaves, the plugin will open three connections upon the first call to a connect function although the application might use the master connection only.

Lazy connections bare a risk if you make heavy use of actions which change the state of a connection. The plugin does not dispatch all state changing actions to all connections from the connection pool. The few dispatched actions are applied to already opened connections only. Lazy connections opened in the future are not affected. Only some settings are "remembered" and applied when lazy connections are opened.

Örnek 27 Disabling lazy connection

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.78.136",
                "port": "3306"
            }
        },
        "lazy_connections": 0
    }
}

Please, see also server_charset to overcome potential problems with string escaping and servers using different default charsets.

server_charset string

The setting has been introduced in 1.4.0. It is recommended to set it if using lazy connections.

The server_charset setting serves two purposes. It acts as a fallback charset to be used for string escaping done before a connection has been established and it helps to avoid escaping pitfalls in heterogeneous environments which servers using different default charsets.

String escaping takes a connections charset into account. String escaping is not possible before a connection has been opened and the connections charset is known. The use of lazy connections delays the actual opening of connections until a statement is send.

An application using lazy connections may attempt to escape a string before sending a statement. In fact, this should be a common case as the statement string may contain the string that is to be escaped. However, due to the lazy connection feature no connection has been opened yet and escaping fails. The plugin may report an error of the type E_WARNING and a message like (mysqlnd_ms) string escaping doesn't work without established connection. Possible solution is to add server_charset to your configuration to inform you of the pitfall.

Setting server_charset makes the plugin use the given charset for string escaping done on lazy connection handles before establishing a network connection to MySQL. Furthermore, the plugin will enforce the use of the charset when the connection is established.

Enforcing the use of the configured charset used for escaping is done to prevent tapping into the pitfall of using a different charset for escaping than used later for the connection. This has the additional benefit of removing the need to align the charset configuration of all servers used. No matter what the default charset on any of the servers is, the plugin will set the configured one as a default.

The plugin does not stop the user from changing the charset at any time using the set_charset() call or corresponding SQL statements. Please, note that the use of SQL is not recommended as it cannot be monitored by the plugin. The user can, for example, change the charset on a lazy connection handle after escaping a string and before the actual connection is opened. The charset set by the user will be used for any subsequent escaping before the connection is established. The connection will be established using the configured charset, no matter what the server charset is or what the user has set before. Once a connection has been opened, set_charset is of no meaning anymore.

Örnek 28 String escaping on a lazy connection handle

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.78.136",
                "port": "3306"
            }
        },
        "lazy_connections": 1,
        "server_charset" : "utf8"
    }
}
<?php
$mysqli = new mysqli("myapp", "username", "password", "database");
$mysqli->real_escape("this will be escaped using the server_charset setting - utf8");
$mysqli->set_charset("latin1");
$mysqli->real_escape("this will be escaped using latin1");
/* server_charset implicitly set - utf8 connection */
$mysqli->query("SELECT 'This connection will be set to server_charset upon establishing' AS _msg FROM DUAL");
/* latin1 used from now on */
$mysqli->set_charset("latin1");
?>

master_on_write bool

If set, the plugin will use the master server only after the first statement has been executed on the master. Applications can still send statements to the slaves using SQL hints to overrule the automatic decision.

The setting may help with replication lag. If an application runs an INSERT the plugin will, by default, use the master to execute all following statements, including SELECT statements. This helps to avoid problems with reads from slaves which have not replicated the INSERT yet.

Örnek 29 Master on write for consistent reads

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.78.136",
                "port": "3306"
            }
        },
        "master_on_write": 1
    }
}

Please, note the quality_of_service filter introduced in version 1.2.0-alpha. It gives finer control, for example, for achieving read-your-writes and, it offers additional functionality introducing service levels.

All transaction stickiness settings, including trx_stickiness=on, are overruled by master_on_write=1.

trx_stickiness string

Transaction stickiness policy. Supported policies: disabled (default), master.

The setting requires 5.4.0 or newer. If used with PHP older than 5.4.0, the plugin will emit a warning like (mysqlnd_ms) trx_stickiness strategy is not supported before PHP 5.3.99.

If no transaction stickiness policy is set or, if setting trx_stickiness=disabled, the plugin is not transaction aware. Thus, the plugin may load balance connections and switch connections in the middle of a transaction. The plugin is not transaction safe. SQL hints must be used avoid connection switches during a transaction.

As of PHP 5.4.0 the mysqlnd library allows the plugin to monitor the autocommit mode set by calls to the libraries set_autocommit() function. If setting set_stickiness=master and autocommit gets disabled by a PHP MySQL extension invoking the mysqlnd library internal function call set_autocommit(), the plugin is made aware of the begin of a transaction. Then, the plugin stops load balancing and directs all statements to the master server until autocommit is enabled. Thus, no SQL hints are required.

An example of a PHP MySQL API function calling the mysqlnd library internal function call set_autocommit() is mysqli_autocommit().

Although setting trx_stickiness=master, the plugin cannot be made aware of autocommit mode changes caused by SQL statements such as SET AUTOCOMMIT=0 or BEGIN.

As of PHP 5.5.0, the mysqlnd library features additional C API calls to control transactions. The level of control matches the one offered by SQL statements. The mysqli API has been modified to use these calls. Since version 1.5.0, PECL/mysqlnd_ms can monitor not only mysqli_autocommit(), but also mysqli_begin(), mysqli_commit() and mysqli_rollback() to detect transaction boundaries and stop load balancing for the duration of a transaction.

Örnek 30 Using master to execute transactions

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.78.136",
                "port": "3306"
            }
        },
        "trx_stickiness": "master"
    }
}

Since version 1.5.0 automatic and silent failover is disabled for the duration of a transaction. If the boundaries of a transaction have been properly detected, transaction stickiness is enabled and a server fails, the plugin will not attempt to fail over to the next server, if any, regardless of the failover policy configured. The user must handle the error manually. Depending on the configuration, the plugin may emit an error of type E_WARNING reading like (mysqlnd_ms) Automatic failover is not permitted in the middle of a transaction. This error may then be overwritten by follow up errors such as (mysqlnd_ms) No connection selected by the last filter. Those errors will be generated by the failing query function.

Örnek 31 No automatic failover, error handling pitfall

<?php
/* assumption: automatic failover configured */
$mysqli = new mysqli("myapp", "username", "password", "database");

/* sets plugin internal state in_trx = 1 */
$mysqli->autocommit(false);

/* assumption: server fails */
if (!($res = $mysqli->query("SELECT 'Assume this query fails' AS _msg FROM DUAL"))) {
 /* handle failure of transaction, plugin internal state is still in_trx = 1 */
 printf("[%d] %s", $mysqli->errno, $mysqli->error);
 /*
  If using autocommit() based transaction detection it is a
  MUST to call autocommit(true). Otherwise the plugin assumes
  the current transaction continues and connection
  changes remain forbidden.
 */
 $mysqli->autocommit(true);
 /* Likewise, you'll want to start a new transaction */
 $mysqli->autocommit(false);
}
/* latin1 used from now on */
$mysqli->set_charset("latin1");
?>

If a server fails in the middle of a transaction the plugin continues to refuse to switch connections until the current transaction has been finished. Recall that the plugin monitors API calls to detect transaction boundaries. Thus, you have to, for example, enable auto commit mode to end the current transaction before the plugin continues load balancing and switches the server. Likewise, you will want to start a new transaction immediately thereafter and disable auto commit mode again.

Not handling failed queries and not ending a failed transaction using API calls may cause all following commands emit errors such as Commands out of sync; you can't run this command now. Thus, it is important to handle all errors.

transient_error object

The setting has been introduced in 1.6.0.

A database cluster node may reply a transient error to a client. The client can then repeat the operation on the same node, fail over to a different node or abort the operation. Per definition is it safe for a client to retry the same operation on the same node before giving up.

PECL/mysqlnd_ms can perform the retry loop on behalf of the application. By configuring transient_error the plugin can be instructed to repeat operations failing with a certain error code for a certain maximum number of times with a pause between the retries. If the transient error disappears during loop execution, it is hidden from the application. Otherwise, the error is forwarded to the application by the end of the loop.

Örnek 32 Retry loop for transient errors

{
    "myapp": {
        "master": {
            "master_0": {
                "host": "localhost"
            }
        },
        "slave": {
            "slave_0": {
                "host": "192.168.78.136",
                "port": "3306"
            }
       },
       "transient_error": {
          "mysql_error_codes": [
            1297
          ],
          "max_retries": 2,
          "usleep_retry": 100
       }
    }
}

Keyword Description Version
mysql_error_codes

List of transient error codes. You may add any MySQL error code to the list. It is possible to consider any error as transient not only 1297 (HY000 (ER_GET_TEMPORARY_ERRMSG), Message: Got temporary error %d '%s' from %s). Before adding other codes but 1297 to the list, make sure your cluster supports a new attempt without impacting the state of your application.

Since 1.6.0.
max_retries

How often to retry an operation which fails with a transient error before forwarding the failure to the user.

Default: 1

Since 1.6.0.
usleep_retry

Milliseconds to sleep between transient error retries. The value is passed to the C function usleep(), hence the name.

Default: 100

Since 1.6.0.
xa object

The setting has been introduced in 1.6.0.

Bilginize: Experimental

The feature is currently under development. There may be issues and/or feature limitations. Do not use in production environments.

state_store
record_participant_credentials

Whether to store the username and password of a global transaction participant in the participants table. If disabled, the garbage collection will use the default username and password when connecting to the participants. Unless you are using a different username and password for each of your MySQL servers, you can use the default and avoid storing the sensible information in state store.

Please note, username and password are stored in clear text when using the MySQL state store, which is the only one available. It is in your responsibility to protect this sensible information.

Default: false

participant_localhost_ip

During XA garbage collection the plugin may find a participant server for which the host localhost has been recorded. If the garbage collection takes place on another host but the host that has written the participant record to the state store, the host name localhost now resolves to a different host. Therefore, when recording a participant servers host name in the state store, a value of localhost must be replaced with the actual IP address of localhost.

Setting participant_localhost_ip should be considered only if using localhost cannot be avoided. From a garbage collection point of view only, it is preferrable not to configure any socket connection but to provide an IP address and port for a node.

mysql

The MySQL state store is the only state store available.

global_trx_table

Name of the MySQL table used to store the state of an ongoing or aborted global transaction. Use the below SQL statement to create the table. Make sure to edit the table name to match your configuration.

Default: mysqlnd_ms_xa_trx

Örnek 33 SQL definition for the MySQL state store transaction table

CREATE TABLE mysqlnd_ms_xa_trx (
  store_trx_id int(11) NOT NULL AUTO_INCREMENT,
  gtrid int(11) NOT NULL,
  format_id int(10) unsigned NOT NULL DEFAULT '1',
  state enum('XA_NON_EXISTING','XA_ACTIVE','XA_IDLE','XA_PREPARED','XA_COMMIT','XA_ROLLBACK') NOT NULL DEFAULT 'XA_NON_EXISTING',
  intend enum('XA_NON_EXISTING','XA_ACTIVE','XA_IDLE','XA_PREPARED','XA_COMMIT','XA_ROLLBACK') DEFAULT 'XA_NON_EXISTING',
  finished enum('NO','SUCCESS','FAILURE') NOT NULL DEFAULT 'NO',
  modified timestamp NOT NULL DEFAULT CURRENT_TIMESTAMP,
  started datetime DEFAULT NULL,
  timeout datetime DEFAULT NULL,
  PRIMARY KEY (store_trx_id),
  KEY idx_xa_id (gtrid,format_id,finished),
  KEY idx_state (state)
) ENGINE=InnoDB

participant_table

Name of the MySQL table used to store participants of an ongoing or aborted global transaction. Use the below SQL statement to create the table. Make sure to edit the table name to match your configuration.

Storing credentials can be enabled and disabled using record_participant_credentials

Default: mysqlnd_ms_xa_participants

Örnek 34 SQL definition for the MySQL state store transaction table

CREATE TABLE mysqlnd_ms_xa_participants (
  fk_store_trx_id int(11) NOT NULL,
  bqual varbinary(64) NOT NULL DEFAULT '',
  participant_id int(10) unsigned NOT NULL AUTO_INCREMENT,
  server_uuid varchar(127) DEFAULT NULL,
  scheme varchar(1024) NOT NULL,
  host varchar(127) DEFAULT NULL,
  port smallint(5) unsigned DEFAULT NULL,
  socket varchar(127) DEFAULT NULL,
  user varchar(127) DEFAULT NULL,
  password varchar(127) DEFAULT NULL,
  state enum('XA_NON_EXISTING','XA_ACTIVE','XA_IDLE','XA_PREPARED','XA_COMMIT','XA_ROLLBACK')
   NOT NULL DEFAULT 'XA_NON_EXISTING',
  health enum('OK','GC_DONE','CLIENT ERROR','SERVER ERROR') NOT NULL DEFAULT 'OK',
  connection_id int(10) unsigned DEFAULT NULL,
  client_errno smallint(5) unsigned DEFAULT NULL,
  client_error varchar(1024) DEFAULT NULL,
  modified timestamp NOT NULL DEFAULT CURRENT_TIMESTAMP,
  PRIMARY KEY (participant_id),
  KEY idx_xa_bqual (bqual),
  KEY idx_store_trx (fk_store_trx_id),
  CONSTRAINT mysqlnd_ms_xa_participants_ibfk_1 FOREIGN KEY (fk_store_trx_id)
    REFERENCES mysqlnd_ms_xa_trx (store_trx_id) ON DELETE CASCADE ON UPDATE CASCADE
) ENGINE=InnoDB
garbage_collection_table

Name of the MySQL table used to track and synchronize garbage collection runs. Use the below SQL statement to create the table. Make sure to edit the table name to match your configuration.

Default: mysqlnd_ms_xa_gc

Örnek 35 SQL definition for the MySQL state store garbage collection table

CREATE TABLE mysqlnd_ms_xa_gc (
  gc_id int(10) unsigned NOT NULL AUTO_INCREMENT,
  gtrid int(11) NOT NULL,
  format_id int(10) unsigned NOT NULL DEFAULT '1',
  fk_store_trx_id int(11) DEFAULT NULL,
  modified timestamp NOT NULL DEFAULT CURRENT_TIMESTAMP,
  attempts smallint(5) unsigned NOT NULL DEFAULT '0',
  PRIMARY KEY (gc_id),
  KEY idx_store_trx (gtrid,format_id,fk_store_trx_id)
) ENGINE=InnoDB
host

Host name of the MySQL server.

user

Name of the user used to connect to the MySQL server.

password

Password for the MySQL server user.

db

Database that holds the garbage collection tables. Please note, you have to create the garbage collection tables prior to using the plugin. The tables will not be created implicitly during runtime but garbage collection will fail if the tables to not exist.

port

Port of the MySQL server.

socket

Unix domain socket of the MySQL server. Please note, if you have multiple PHP servers each of them will try to carry out garbage collection and need to be able to connect to the state store. In this case, you may prefer configuring an IP address and a port for the MySQL state store server to ensure all PHP servers can reach it.

rollback_on_close

Whether to automatically rollback an open global transaction when a connection is closed. If enabled, it mimics the default behaviour of local transactions. Should a client disconnect, the server rolls back any open and unfinished transactions.

Default: true

garbage_collection
max_retries

Maximum number of garbage collection runs before giving up. Allowed values are from 0 to 100. A setting of 0 means no limit, unless the state store enforces a limit. Should the state store enforce a limit, it can be supposed to be significantly higher than 100. Available since 1.6.0.

Please note, it is important to end failed XA transactions within reasonable time to make participating servers free resources bound to the transaction. The built-in garbage collection is not expected to fail for a long period as long as crashed servers become available again quickly. Still, a situation may arise where a human is required to act because the built-in garbage collection stopped or failed. In this case, you may first want to check if the transaction still cannot be fixed by forcing mysqlnd_ms_xa_gc() to ignore the setting, prior to handling it manually.

Default: 5

probability

Garbage collection probability. Allowed values are from 0 to 1000. A setting of 0 disables automatic background garbage collection. Despite a setting of 0 it is still possible to trigger garbage collection by calling mysqlnd_ms_gc(). Available since 1.6.0.

The automatic garbage collection of stalled XA transaction is only available if a state store have been configured. The state store is responsible to keep track of XA transactions. Based on its recordings it can find blocked XA transactions where the client has crashed, connect to the participants and rollback the unfinished transactions.

The garbage collection is triggered as part of PHP's request shutdown procedure at the end of a web request. That is after your PHP script has finished working. Do decide whether to run the garbage collection a random value between 0 and 1000 is computed. If the probability value is higher or equal to the random value, the state stores garbage collection routines are invoked.

Default: 5

max_transactions_per_run

Maximum number of unfinished XA transactions considered by the garbage collection during one run. Allowed values are from 1 to 32768. Available since 1.6.0.

Cleaning up an unfinished XA transaction takes considerable amounts of time and resources. The garbage collection routine may have to connect to several participants of a failed global transaction to issue the SQL commands for rolling back the unfinished tranaction.

Default: 100

Plugin configuration file (<= 1.0.x)

Bilginize:

The below description applies to PECL/mysqlnd_ms < 1.1.0-beta. It is not valid for later versions.

The plugin is using its own configuration file. The configuration file holds information on the MySQL replication master server, the MySQL replication slave servers, the server pick (load balancing) policy, the failover strategy and the use of lazy connections.

The PHP configuration directive mysqlnd_ms.ini_file is used to set the plugins configuration file.

The configuration file mimics standard the php.ini format. It consists of one or more sections. Every section defines its own unit of settings. There is no global section for setting defaults.

Applications reference sections by their name. Applications use section names as the host (server) parameter to the various connect methods of the mysqli, mysql and PDO_MYSQL extensions. Upon connect the mysqlnd plugin compares the hostname with all section names from the plugin configuration file. If hostname and section name match, the plugin will load the sections settings.

Örnek 36 Using section names example

[myapp]
master[] = localhost
slave[] = 192.168.2.27
slave[] = 192.168.2.28:3306
[localhost]
master[] = localhost:/tmp/mysql/mysql.sock
slave[] = 192.168.3.24:3305
slave[] = 192.168.3.65:3309
<?php
/* All of the following connections will be load balanced */
$mysqli = new mysqli("myapp", "username", "password", "database");
$pdo = new PDO('mysql:host=myapp;dbname=database', 'username', 'password');
$mysql = mysql_connect("myapp", "username", "password");

$mysqli = new mysqli("localhost", "username", "password", "database");
?>

Section names are strings. It is valid to use a section name such as 192.168.2.1, 127.0.0.1 or localhost. If, for example, an application connects to localhost and a plugin configuration section [localhost] exists, the semantics of the connect operation are changed. The application will no longer only use the MySQL server running on the host localhost but the plugin will start to load balance MySQL queries following the rules from the [localhost] configuration section. This way you can load balance queries from an application without changing the applications source code.

The master[], slave[] and pick[] configuration directives use a list-like syntax. Configuration directives supporting list-like syntax may appear multiple times in a configuration section. The plugin maintains the order in which entries appear when interpreting them. For example, the below example shows two slave[] configuration directives in the configuration section [myapp]. If doing round-robin load balancing for read-only queries, the plugin will send the first read-only query to the MySQL server mysql_slave_1 because it is the first in the list. The second read-only query will be send to the MySQL server mysql_slave_2 because it is the second in the list. Configuration directives supporting list-like syntax result are ordered from top to bottom in accordance to their appearance within a configuration section.

Örnek 37 List-like syntax

[myapp]
master[] = mysql_master_server
slave[] = mysql_slave_1
slave[] = mysql_slave_2

Here is a short explanation of the configuration directives that can be used.

master[] string

URI of a MySQL replication master server. The URI follows the syntax hostname[:port|unix_domain_socket].

The plugin supports using only one master server.

Setting a master server is mandatory. The plugin will report a warning upon connect if the user has failed to provide a master server for a configuration section. The warning may read (mysqlnd_ms) Cannot find master section in config. Furthermore the plugin may set an error code for the connection handle such as HY000/2000 (CR_UNKNOWN_ERROR). The corresponding error message depends on your language settings.

slave[] string

URI of one or more MySQL replication slave servers. The URI follows the syntax hostname[:port|unix_domain_socket].

The plugin supports using one or more slave servers.

Setting a slave server is mandatory. The plugin will report a warning upon connect if the user has failed to provide at least one slave server for a configuration section. The warning may read (mysqlnd_ms) Cannot find slaves section in config. Furthermore the plugin may set an error code for the connection handle such as HY000/2000 (CR_UNKNOWN_ERROR). The corresponding error message depends on your language settings.

pick[] string

Load balancing (server picking) policy. Supported policies: random, random_once (default), roundrobin, user.

If no load balancing policy is set, the plugin will default to random_once. The random_once policy picks a random slave server when running the first read-only statement. The slave server will be used for all read-only statements until the PHP script execution ends.

The random policy will pick a random server whenever a read-only statement is to be executed.

If using roundrobin the plugin iterates over the list of configured slave servers to pick a server for statement execution. If the plugin reaches the end of the list, it wraps around to the beginning of the list and picks the first configured slave server.

Setting more than one load balancing policy for a configuration section makes only sense in conjunction with user and mysqlnd_ms_set_user_pick_server(). If the user defined callback fails to pick a server, the plugin falls back to the second configured load balancing policy.

failover string

Failover policy. Supported policies: disabled (default), master.

If no failover policy is set, the plugin will not do any automatic failover (failover=disabled). Whenever the plugin fails to connect a server it will emit a warning and set the connections error code and message. Thereafter it is up to the application to handle the error and, for example, resent the last statement to trigger the selection of another server.

If using failover=master the plugin will implicitly failover to a slave, if available. Please check the concepts documentation to learn about potential pitfalls and risks of using failover=master.

lazy_connections bool

Controls the use of lazy connections. Lazy connections are connections which are not opened before the client sends the first connection.

It is strongly recommended to use lazy connections. Lazy connections help to keep the number of open connections low. If you disable lazy connections and, for example, configure one MySQL replication master server and two MySQL replication slaves, the plugin will open three connections upon the first call to a connect function although the application might use the master connection only.

Lazy connections bare a risk if you make heavy use of actions which change the state of a connection. The plugin does not dispatch all state changing actions to all connections from the connection pool. The few dispatched actions are applied to already opened connections only. Lazy connections opened in the future are not affected. If, for example, the connection character set is changed using a PHP MySQL API call, the plugin will change the character set of all currently opened connection. It will not remember the character set change to apply it on lazy connections opened in the future. As a result the internal connection pool would hold connections using different character sets. This is not desired. Remember that character sets are taken into account for escaping.

master_on_write bool

If set, the plugin will use the master server only after the first statement has been executed on the master. Applications can still send statements to the slaves using SQL hints to overrule the automatic decision.

The setting may help with replication lag. If an application runs an INSERT the plugin will, by default, use the master to execute all following statements, including SELECT statements. This helps to avoid problems with reads from slaves which have not replicated the INSERT yet.

trx_stickiness string

Transaction stickiness policy. Supported policies: disabled (default), master.

Experimental feature.

The setting requires 5.4.0 or newer. If used with PHP older than 5.4.0, the plugin will emit a warning like (mysqlnd_ms) trx_stickiness strategy is not supported before PHP 5.3.99.

If no transaction stickiness policy is set or, if setting trx_stickiness=disabled, the plugin is not transaction aware. Thus, the plugin may load balance connections and switch connections in the middle of a transaction. The plugin is not transaction safe. SQL hints must be used avoid connection switches during a transaction.

As of PHP 5.4.0 the mysqlnd library allows the plugin to monitor the autocommit mode set by calls to the libraries trx_autocommit() function. If setting trx_stickiness=master and autocommit gets disabled by a PHP MySQL extension invoking the mysqlnd library internal function call trx_autocommit(), the plugin is made aware of the begin of a transaction. Then, the plugin stops load balancing and directs all statements to the master server until autocommit is enabled. Thus, no SQL hints are required.

An example of a PHP MySQL API function calling the mysqlnd library internal function call trx_autocommit() is mysqli_autocommit().

Although setting trx_stickiness=master, the plugin cannot be made aware of autocommit mode changes caused by SQL statements such as SET AUTOCOMMIT=0.

Testing

Bilginize:

The section applies to mysqlnd_ms 1.1.0 or newer, not the 1.0 series.

The PECL/mysqlnd_ms test suite is in the tests/ directory of the source distribution. The test suite consists of standard phpt tests, which are described on the PHP Quality Assurance Teams website.

Running the tests requires setting up one to four MySQL servers. Some tests don't connect to MySQL at all. Others require one server for testing. Some require two distinct servers. In some cases two servers are used to emulate a replication setup. In other cases a master and a slave of an existing MySQL replication setup are required for testing. The tests will try to detect how many servers and what kind of servers are given. If the required servers are not found, the test will be skipped automatically.

Before running the tests, edit tests/config.inc to configure the MySQL servers to be used for testing.

The most basic configuration is as follows.

 putenv("MYSQL_TEST_HOST=localhost");
 putenv("MYSQL_TEST_PORT=3306");
 putenv("MYSQL_TEST_USER=root");
 putenv("MYSQL_TEST_PASSWD=");
 putenv("MYSQL_TEST_DB=test");
 putenv("MYSQL_TEST_ENGINE=MyISAM");
 putenv("MYSQL_TEST_SOCKET=");

 putenv("MYSQL_TEST_SKIP_CONNECT_FAILURE=1");
 putenv("MYSQL_TEST_CONNECT_FLAGS=0");
 putenv("MYSQL_TEST_EXPERIMENTAL=0");

 /* replication cluster emulation */
 putenv("MYSQL_TEST_EMULATED_MASTER_HOST=". getenv("MYSQL_TEST_HOST"));
 putenv("MYSQL_TEST_EMULATED_SLAVE_HOST=". getenv("MYSQL_TEST_HOST"));

 /* real replication cluster */
 putenv("MYSQL_TEST_MASTER_HOST=". getenv("MYSQL_TEST_EMULATED_MASTER_HOST"));
 putenv("MYSQL_TEST_SLAVE_HOST=". getenv("MYSQL_TEST_EMULATED_SLAVE_HOST"));

MYSQL_TEST_HOST, MYSQL_TEST_PORT and MYSQL_TEST_SOCKET define the hostname, TCP/IP port and Unix domain socket of the default database server. MYSQL_TEST_USER and MYSQL_TEST_PASSWD contain the user and password needed to connect to the database/schema configured with MYSQL_TEST_DB. All configured servers must have the same database user configured to give access to the test database.

Using host, host:port or host:/path/to/socket syntax one can set an alternate host, host and port or host and socket for any of the servers.

putenv("MYSQL_TEST_SLAVE_HOST=192.168.78.136:3307"));
putenv("MYSQL_TEST_MASTER_HOST=myserver_hostname:/path/to/socket"));

Debugging and Tracing

The mysqlnd debug log can be used to debug and trace the actitivities of PECL/mysqlnd_ms. As a mysqlnd PECL/mysqlnd_ms adds trace information to the mysqlnd library debug file. Please, see the mysqlnd.debug PHP configuration directive documentation for a detailed description on how to configure the debug log.

Configuration setting example to activate the debug log:

mysqlnd.debug=d:t:x:O,/tmp/mysqlnd.trace

Bilginize:

This feature is only available with a debug build of PHP. Works on Microsoft Windows if using a debug build of PHP and PHP was built using Microsoft Visual C version 9 and above.

The debug log shows mysqlnd library and PECL/mysqlnd_ms plugin function calls, similar to a trace log. Mysqlnd library calls are usually prefixed with mysqlnd_. PECL/mysqlnd internal calls begin with mysqlnd_ms.

Example excerpt from the debug log (connect):

[...]
>mysqlnd_connect
| info : host=myapp user=root db=test port=3306 flags=131072
| >mysqlnd_ms::connect
| | >mysqlnd_ms_config_json_section_exists
| | | info : section=[myapp] len=[5]
| | | >mysqlnd_ms_config_json_sub_section_exists
| | | | info : section=[myapp] len=[5]
| | | | info : ret=1
| | | <mysqlnd_ms_config_json_sub_section_exists
| | | info : ret=1
| | <mysqlnd_ms_config_json_section_exists
[...]

The debug log is not only useful for plugin developers but also to find the cause of user errors. For example, if your application does not do proper error handling and fails to record error messages, checking the debug and trace log may help finding the cause. Use of the debug log to debug application issues should be considered only if no other option is available. Writing the debug log to disk is a slow operation and may have negative impact on the application performance.

Example excerpt from the debug log (connection failure):

[...]
| | | | | | | info : adding error [Access denied for user 'root'@'localhost' (using password: YES)] to the list
| | | | | | | info : PACKET_FREE(0)
| | | | | | | info : PACKET_FREE(0x7f3ef6323f50)
| | | | | | | info : PACKET_FREE(0x7f3ef6324080)
| | | | | | <mysqlnd_auth_handshake
| | | | | | info : switch_to_auth_protocol=n/a
| | | | | | info : conn->error_info.error_no = 1045
| | | | | <mysqlnd_connect_run_authentication
| | | | | info : PACKET_FREE(0x7f3ef63236d8)
| | | | | >mysqlnd_conn::free_contents
| | | | | | >mysqlnd_net::free_contents
| | | | | | <mysqlnd_net::free_contents
| | | | | | info : Freeing memory of members
| | | | | | info : scheme=unix:///tmp/mysql.sock
| | | | | | >mysqlnd_error_list_pdtor
| | | | | | <mysqlnd_error_list_pdtor
| | | | | <mysqlnd_conn::free_contents
| | | | <mysqlnd_conn::connect
[...]

The trace log can also be used to verify correct behaviour of PECL/mysqlnd_ms itself, for example, to check which server has been selected for query execution and why.

Example excerpt from the debug log (plugin decision):

[...]
>mysqlnd_ms::query
| info : query=DROP TABLE IF EXISTS test
| >_mysqlnd_plugin_get_plugin_connection_data
| | info : plugin_id=5
| <_mysqlnd_plugin_get_plugin_connection_data
| >mysqlnd_ms_pick_server_ex
| | info : conn_data=0x7fb6a7d3e5a0 *conn_data=0x7fb6a7d410d0
| | >mysqlnd_ms_select_servers_all
| | <mysqlnd_ms_select_servers_all
| | >mysqlnd_ms_choose_connection_rr
| | | >mysqlnd_ms_query_is_select
[...]
| | | <mysqlnd_ms_query_is_select
[...]
| | | info : Init the master context
| | | info : list(0x7fb6a7d3f598) has 1
| | | info : Using master connection
| | | >mysqlnd_ms_advanced_connect
| | | | >mysqlnd_conn::connect
| | | | | info : host=localhost user=root db=test port=3306 flags=131072 persistent=0 state=0

In this case the statement DROP TABLE IF EXISTS test has been executed. Note that the statement string is shown in the log file. You may want to take measures to restrict access to the log for security considerations.

The statement has been load balanced using round robin policy, as you can easily guess from the functions name >mysqlnd_ms_choose_connection_rr. It has been sent to a master server running on host=localhost user=root db=test port=3306 flags=131072 persistent=0 state=0.

Monitoring

Plugin activity can be monitored using the mysqlnd trace log, mysqlnd statistics, mysqlnd_ms plugin statistics and external PHP debugging tools. Use of the trace log should be limited to debugging. It is recommended to use the plugins statistics for monitoring.

Writing a trace log is a slow operation. If using an external PHP debugging tool, please refer to the vendors manual about its performance impact and the type of information collected. In many cases, external debugging tools will provide call stacks. Often, a call stack or a trace log is more difficult to interpret than the statistics provided by the plugin.

Plugin statistics tell how often which kind of cluster node has been used (slave or master), why the node was used, if lazy connections have been used and if global transaction ID injection has been performed. The monitoring information provided enables user to verify plugin decisions and to plan their cluster resources based on usage pattern. The function mysqlnd_ms_get_stats() is used to access the statistics. Please, see the functions description for a list of available statistics.

Statistics are collected on a per PHP process basis. Their scope is a PHP process. Depending on the PHP deployment model a process may serve one or multiple web requests. If using CGI model, a PHP process serves one web request. If using FastCGI or pre-fork web server models, a PHP process usually serves multiple web requests. The same is the case with a threaded web server. Please, note that threads running in parallel can update the statistics in parallel. Thus, if using a threaded PHP deployment model, statistics can be changed by more than one script at a time. A script cannot rely on the fact that it sees only its own changes to statistics.

Örnek 38 Verify plugin activity in a non-threaded deployment model

mysqlnd_ms.enable=1
mysqlnd_ms.collect_statistics=1
<?php
/* Load balanced following "myapp" section rules from the plugins config file (not shown) */
$mysqli = new mysqli("myapp", "username", "password", "database");
if (mysqli_connect_errno())
  /* Of course, your error handling is nicer... */
  die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));

$stats_before = mysqlnd_ms_get_stats();
if ($res = $mysqli->query("SELECT 'Read request' FROM DUAL")) {
  var_dump($res->fetch_all());
}
$stats_after = mysqlnd_ms_get_stats();
if ($stats_after['use_slave'] <= $stats_before['use_slave']) {
  echo "According to the statistics the read request has not been run on a slave!";
}
?>

Statistics are aggregated for all plugin activities and all connections handled by the plugin. It is not possible to tell how much a certain connection handle has contributed to the overall statistics.

Utilizing PHPs register_shutdown_function() function or the auto_append_file PHP configuration directive it is easily possible to dump statistics into, for example, a log file when a script finishes. Instead of using a log file it is also possible to send the statistics to an external monitoring tool for recording and display.

Örnek 39 Recording statistics during shutdown

mysqlnd_ms.enable=1
mysqlnd_ms.collect_statistics=1
error_log=/tmp/php_errors.log
<?php
function check_stats() {
  $msg = str_repeat("-", 80) . "\n";
  $msg .= var_export(mysqlnd_ms_get_stats(), true) . "\n";
  $msg .= str_repeat("-", 80) . "\n";
  error_log($msg);
}
register_shutdown_function("check_stats");
?>

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

SQL hint related

Örnek 1 Example demonstrating the usage of mysqlnd_ms constants

The mysqlnd replication and load balancing plugin (mysqlnd_ms) performs read/write splitting. This directs write queries to a MySQL master server, and read-only queries to the MySQL slave servers. The plugin has a built-in read/write split logic. All queries which start with SELECT are considered read-only queries, which are then sent to a MySQL slave server that is listed in the plugin configuration file. All other queries are directed to the MySQL master server that is also specified in the plugin configuration file.

User supplied SQL hints can be used to overrule automatic read/write splitting, to gain full control on the process. SQL hints are standards compliant SQL comments. The plugin will scan the beginning of a query string for an SQL comment for certain commands, which then control query redirection. Other systems involved in the query processing are unaffected by the SQL hints because other systems will ignore the SQL comments.

The plugin supports three SQL hints to direct queries to either the MySQL slave servers, the MySQL master server, or the last used MySQL server. SQL hints must be placed at the beginning of a query to be recognized by the plugin.

For better portability, it is recommended to use the string constants MYSQLND_MS_MASTER_SWITCH, MYSQLND_MS_SLAVE_SWITCH and MYSQLND_MS_LAST_USED_SWITCH instead of their literal values.

<?php
/* Use constants for maximum portability */
$master_query = "/*" . MYSQLND_MS_MASTER_SWITCH . "*/SELECT id FROM test";

/* Valid but less portable: using literal instead of constant */
$slave_query = "/*ms=slave*/SHOW TABLES";

printf("master_query = '%s'\n", $master_query);
printf("slave_query = '%s'\n", $slave_query);
?>

Yukarıdaki örneklerin çıktısı:

master_query = /*ms=master*/SELECT id FROM test
slave_query = /*ms=slave*/SHOW TABLES

MYSQLND_MS_MASTER_SWITCH (string)
SQL hint used to send a query to the MySQL replication master server.
MYSQLND_MS_SLAVE_SWITCH (string)
SQL hint used to send a query to one of the MySQL replication slave servers.
MYSQLND_MS_LAST_USED_SWITCH (string)
SQL hint used to send a query to the last used MySQL server. The last used MySQL server can either be a master or a slave server in a MySQL replication setup.

mysqlnd_ms_query_is_select() related

MYSQLND_MS_QUERY_USE_MASTER (integer)
If mysqlnd_ms_is_select() returns MYSQLND_MS_QUERY_USE_MASTER for a given query, the built-in read/write split mechanism recommends sending the query to a MySQL replication master server.
MYSQLND_MS_QUERY_USE_SLAVE (integer)
If mysqlnd_ms_is_select() returns MYSQLND_MS_QUERY_USE_SLAVE for a given query, the built-in read/write split mechanism recommends sending the query to a MySQL replication slave server.
MYSQLND_MS_QUERY_USE_LAST_USED (integer)
If mysqlnd_ms_is_select() returns MYSQLND_MS_QUERY_USE_LAST_USED for a given query, the built-in read/write split mechanism recommends sending the query to the last used server.

mysqlnd_ms_set_qos(), quality of service filter and service level related

MYSQLND_MS_QOS_CONSISTENCY_EVENTUAL (integer)
Use to request the service level eventual consistency from the mysqlnd_ms_set_qos(). Eventual consistency is the default quality of service when reading from an asynchronous MySQL replication slave. Data returned in this service level may or may not be stale, depending on whether the selected slaves happen to have replicated the latest changes from the MySQL replication master or not.
MYSQLND_MS_QOS_CONSISTENCY_SESSION (integer)
Use to request the service level session consistency from the mysqlnd_ms_set_qos(). Session consistency is defined as read your writes. The client is guaranteed to see his latest changes.
MYSQLND_MS_QOS_CONSISTENCY_STRONG (integer)
Use to request the service level strong consistency from the mysqlnd_ms_set_qos(). Strong consistency is used to ensure all clients see each others changes.
MYSQLND_MS_QOS_OPTION_GTID (integer)
Used as a service level option with mysqlnd_ms_set_qos() to parameterize session consistency.
MYSQLND_MS_QOS_OPTION_AGE (integer)
Used as a service level option with mysqlnd_ms_set_qos() to parameterize eventual consistency.

Other

The plugins version number can be obtained using MYSQLND_MS_VERSION or MYSQLND_MS_VERSION_ID. MYSQLND_MS_VERSION is the string representation of the numerical version number MYSQLND_MS_VERSION_ID, which is an integer such as 10000. Developers can calculate the version number as follows.

Version (part) | Example
Major*10000 | 1*10000 = 10000
Minor*100 | 0*100 = 0
Patch | 0 = 0
MYSQLND_MS_VERSION_ID | 10000

MYSQLND_MS_VERSION (string)
Plugin version string, for example, "1.0.0-prototype".
MYSQLND_MS_VERSION_ID (integer)
Plugin version number, for example, 10000.

Plugin configuration file (>=1.1.x)
Mysqlnd_ms İşlevleri
mysqlnd_ms


Mysqlnd_ms İşlevleri

İçindekiler

  • mysqlnd_ms_dump_servers — Returns a list of currently configured servers
  • mysqlnd_ms_fabric_select_global — Switch to global sharding server for a given table
  • mysqlnd_ms_fabric_select_shard — Switch to shard
  • mysqlnd_ms_get_last_gtid — Returns the latest global transaction ID
  • mysqlnd_ms_get_last_used_connection — Returns an array which describes the last used connection
  • mysqlnd_ms_get_stats — Returns query distribution and connection statistics
  • mysqlnd_ms_match_wild — Finds whether a table name matches a wildcard pattern or not
  • mysqlnd_ms_query_is_select — Find whether to send the query to the master, the slave or the last used MySQL server
  • mysqlnd_ms_set_qos — Sets the quality of service needed from the cluster
  • mysqlnd_ms_set_user_pick_server — Sets a callback for user-defined read/write splitting
  • mysqlnd_ms_xa_begin — Starts a distributed/XA transaction among MySQL servers
  • mysqlnd_ms_xa_commit — Commits a distributed/XA transaction among MySQL servers
  • mysqlnd_ms_xa_gc — Garbage collects unfinished XA transactions after severe errors
  • mysqlnd_ms_xa_rollback — Rolls back a distributed/XA transaction among MySQL servers
Öntanımlı Sabitler
mysqlnd_ms_dump_servers
mysqlnd_ms


Returns a list of currently configured servers

Mysqlnd_ms İşlevleri
mysqlnd_ms_fabric_select_global
Mysqlnd_ms İşlevleri
PHP Manual

mysqlnd_ms_dump_servers

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

mysqlnd_ms_dump_servers — Returns a list of currently configured servers

Açıklama

array mysqlnd_ms_dump_servers ( mixed $connection )

Returns a list of currently configured servers.

Değiştirgeler

connection

A MySQL connection handle obtained from any of the connect functions of the mysqli, mysql or PDO_MYSQL extensions.

Dönen Değerler

FALSE on error. Otherwise, returns an array with two entries masters and slaves each of which contains an array listing all corresponding servers.

The function can be used to check and debug the list of servers currently used by the plugin. It is mostly useful when the list of servers changes at runtime, for example, when using MySQL Fabric.

masters and slaves server entries

Key | Description | Version
name_from_config | Server entry name from config, if appliciable. NULL if no configuration name is available. | Since 1.6.0.
hostname | Host name of the server. | Since 1.6.0.
user | Database user used to authenticate against the server. | Since 1.6.0.
port | TCP/IP port of the server. | Since 1.6.0.
socket | Unix domain socket of the server. | Since 1.6.0.

Notlar

Bilginize:

mysqlnd_ms_dump_servers() requires PECL mysqlnd_ms >> 1.6.0.

Örnekler

Örnek 1 mysqlnd_ms_dump_servers() example

{
    "myapp": {
        "master": {
            "master1": {
                "host":"master1_host",
                "port":"master1_port",
                "socket":"master1_socket",
                "db":"master1_db",
                "user":"master1_user",
                "password":"master1_pw"
            }
        },
        "slave": {
             "slave_0": {
                 "host":"slave0_host",
                 "port":"slave0_port",
                 "socket":"slave0_socket",
                 "db":"slave0_db",
                 "user":"slave0_user",
                 "password":"slave0_pw"
             },
             "slave_1": {
                 "host":"slave1_host"
             }
        }
    }
}
<?php
$link = mysqli_connect("myapp", "global_user", "global_pass", "global_db", 1234, "global_socket");
var_dump(mysqlnd_ms_dump_servers($link);
?>

Yukarıdaki örneğin çıktısı:

array(2) {
  ["masters"]=>
  array(1) {
    [0]=>
    array(5) {
      ["name_from_config"]=>
      string(7) "master1"
      ["hostname"]=>
      string(12) "master1_host"
      ["user"]=>
      string(12) "master1_user"
      ["port"]=>
      int(3306)
      ["socket"]=>
      string(14) "master1_socket"
    }
  }
  ["slaves"]=>
  array(2) {
    [0]=>
    array(5) {
      ["name_from_config"]=>
      string(7) "slave_0"
      ["hostname"]=>
      string(11) "slave0_host"
      ["user"]=>
      string(11) "slave0_user"
      ["port"]=>
      int(3306)
      ["socket"]=>
      string(13) "slave0_socket"
    }
    [1]=>
    array(5) {
      ["name_from_config"]=>
      string(7) "slave_1"
      ["hostname"]=>
      string(11) "slave1_host"
      ["user"]=>
      string(12) "gloabal_user"
      ["port"]=>
      int(1234)
      ["socket"]=>
      string(13) "global_socket"
    }
  }
}

Mysqlnd_ms İşlevleri
mysqlnd_ms_fabric_select_global
Mysqlnd_ms İşlevleri


Switch to global sharding server for a given table

mysqlnd_ms_dump_servers
mysqlnd_ms_fabric_select_shard
Mysqlnd_ms İşlevleri
PHP Manual

mysqlnd_ms_fabric_select_global

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

mysqlnd_ms_fabric_select_global — Switch to global sharding server for a given table

Açıklama

array mysqlnd_ms_fabric_select_global ( mixed $connection , mixed $table_name )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

MySQL Fabric related.

Switch the connection to the nodes handling global sharding queries for the given table name.

Değiştirgeler

connection

A MySQL connection handle obtained from any of the connect functions of the mysqli, mysql or PDO_MYSQL extensions.

table_name

The table name to ask Fabric about.

Dönen Değerler

FALSE on error. Otherwise, TRUE

Notlar

Bilginize:

mysqlnd_ms_fabric_select_global() requires PECL mysqlnd_ms >> 1.6.0.

mysqlnd_ms_dump_servers
mysqlnd_ms_fabric_select_shard
Mysqlnd_ms İşlevleri


Switch to shard

mysqlnd_ms_fabric_select_global
mysqlnd_ms_get_last_gtid
Mysqlnd_ms İşlevleri
PHP Manual

mysqlnd_ms_fabric_select_shard

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

mysqlnd_ms_fabric_select_shard — Switch to shard

Açıklama

array mysqlnd_ms_fabric_select_shard ( mixed $connection , mixed $table_name , mixed $shard_key )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

MySQL Fabric related.

Switch the connection to the shards responsible for the given table name and shard key.

Değiştirgeler

connection

A MySQL connection handle obtained from any of the connect functions of the mysqli, mysql or PDO_MYSQL extensions.

table_name

The table name to ask Fabric about.

shard_key

The shard key to ask Fabric about.

Dönen Değerler

FALSE on error. Otherwise, TRUE

Notlar

Bilginize:

mysqlnd_ms_fabric_select_shard() requires PECL mysqlnd_ms >> 1.6.0.

mysqlnd_ms_fabric_select_global
mysqlnd_ms_get_last_gtid
Mysqlnd_ms İşlevleri


Returns the latest global transaction ID

mysqlnd_ms_fabric_select_shard
mysqlnd_ms_get_last_used_connection
Mysqlnd_ms İşlevleri
PHP Manual

mysqlnd_ms_get_last_gtid

(PECL mysqlnd_ms >= 1.2.0)

mysqlnd_ms_get_last_gtid — Returns the latest global transaction ID

Açıklama

string mysqlnd_ms_get_last_gtid ( mixed $connection )

Returns a global transaction identifier which belongs to a write operation no older than the last write performed by the client. It is not guaranteed that the global transaction identifier is identical to that one created for the last write transaction performed by the client.

Değiştirgeler

connection

A PECL/mysqlnd_ms connection handle to a MySQL server of the type PDO_MYSQL, mysqli> or ext/mysql. The connection handle is obtained when opening a connection with a host name that matches a mysqlnd_ms configuration file entry using any of the above three MySQL driver extensions.

Dönen Değerler

Returns a global transaction ID (GTID) on success. Otherwise, returns FALSE.

The function mysqlnd_ms_get_last_gtid() returns the GTID obtained when executing the SQL statement from the fetch_last_gtid entry of the global_transaction_id_injection section from the plugins configuration file.

The function may be called after the GTID has been incremented.

Notlar

Bilginize:

mysqlnd_ms_get_last_gtid() requires PHP >= 5.4.0 and PECL mysqlnd_ms >= 1.2.0. Internally, it is using a mysqlnd library C functionality not available with PHP 5.3.

Please note, all MySQL 5.6 production versions do not provide clients with enough information to use GTIDs for enforcing session consistency. In the worst case, the plugin will choose the master only.

Örnekler

Örnek 1 mysqlnd_ms_get_last_gtid() example

<?php
/* Open mysqlnd_ms connection using mysqli, PDO_MySQL or mysql extension */
$mysqli = new mysqli("myapp", "username", "password", "database");
if (!$mysqli)
  /* Of course, your error handling is nicer... */
  die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));

/* auto commit mode, transaction on master, GTID must be incremented */
if (!$mysqli->query("DROP TABLE IF EXISTS test"))
  die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));

printf("GTID after transaction %s\n", mysqlnd_ms_get_last_gtid($mysqli));

/* auto commit mode, transaction on master, GTID must be incremented */
if (!$mysqli->query("CREATE TABLE test(id INT)"))
  die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));

printf("GTID after transaction %s\n", mysqlnd_ms_get_last_gtid($mysqli));
?>

Ayrıca Bakınız

  • Global Transaction IDs

mysqlnd_ms_fabric_select_shard
mysqlnd_ms_get_last_used_connection
Mysqlnd_ms İşlevleri


Returns an array which describes the last used connection

mysqlnd_ms_get_last_gtid
mysqlnd_ms_get_stats
Mysqlnd_ms İşlevleri
PHP Manual

mysqlnd_ms_get_last_used_connection

(PECL mysqlnd_ms >= 1.1.0)

mysqlnd_ms_get_last_used_connection — Returns an array which describes the last used connection

Açıklama

array mysqlnd_ms_get_last_used_connection ( mixed $connection )

Returns an array which describes the last used connection from the plugins connection pool currently pointed to by the user connection handle. If using the plugin, a user connection handle represents a pool of database connections. It is not possible to tell from the user connection handles properties to which database server from the pool the user connection handle points.

The function can be used to debug or monitor PECL mysqlnd_ms.

Değiştirgeler

connection

A MySQL connection handle obtained from any of the connect functions of the mysqli, mysql or PDO_MYSQL extensions.

Dönen Değerler

FALSE on error. Otherwise, an array which describes the connection used to execute the last statement on.

Array which describes the connection.

Property | Description | Version
scheme | Connection scheme. Either tcp://host:port or unix://host:socket. If you want to distinguish connections from each other use a combination of scheme and thread_id as a unique key. Neither scheme nor thread_id alone are sufficient to distinguish two connections from each other. Two servers may assign the same thread_id to two different connections. Thus, connections in the pool may have the same thread_id. Also, do not rely on uniqueness of scheme in a pool. Your QA engineers may use the same MySQL server instance for two distinct logical roles and add it multiple times to the pool. This hack is used, for example, in the test suite. | Since 1.1.0.
host | Database server host used with the connection. The host is only set with TCP/IP connections. It is empty with Unix domain or Windows named pipe connections, | Since 1.1.0.
host_info | A character string representing the server hostname and the connection type. | Since 1.1.2.
port | Database server port used with the connection. | Since 1.1.0.
socket_or_pipe | Unix domain socket or Windows named pipe used with the connection. The value is empty for TCP/IP connections. | Since 1.1.2.
thread_id | Connection thread id. | Since 1.1.0.
last_message | Info message obtained from the MySQL C API function mysql_info(). Please, see mysqli_info() for a description. | Since 1.1.0.
errno | Error code. | Since 1.1.0.
error | Error message. | Since 1.1.0.
sqlstate | Error SQLstate code. | Since 1.1.0.

Notlar

Bilginize:

mysqlnd_ms_get_last_used_connection() requires PHP >= 5.4.0 and PECL mysqlnd_ms >> 1.1.0. Internally, it is using a mysqlnd library C call not available with PHP 5.3.

Örnekler

The example assumes that myapp refers to a plugin configuration file section and represents a connection pool.

Örnek 1 mysqlnd_ms_get_last_used_connection() example

<?php
$link = new mysqli("myapp", "user", "password", "database");
$res = $link->query("SELECT 1 FROM DUAL");
var_dump(mysqlnd_ms_get_last_used_connection($link));
?>

Yukarıdaki örneğin çıktısı:

array(10) {
  ["scheme"]=>
  string(22) "unix:///tmp/mysql.sock"
  ["host_info"]=>
  string(25) "Localhost via UNIX socket"
  ["host"]=>
  string(0) ""
  ["port"]=>
  int(3306)
  ["socket_or_pipe"]=>
  string(15) "/tmp/mysql.sock"
  ["thread_id"]=>
  int(46253)
  ["last_message"]=>
  string(0) ""
  ["errno"]=>
  int(0)
  ["error"]=>
  string(0) ""
  ["sqlstate"]=>
  string(5) "00000"
}

mysqlnd_ms_get_last_gtid
mysqlnd_ms_get_stats
Mysqlnd_ms İşlevleri


Returns query distribution and connection statistics

mysqlnd_ms_get_last_used_connection
mysqlnd_ms_match_wild
Mysqlnd_ms İşlevleri
PHP Manual

mysqlnd_ms_get_stats

(PECL mysqlnd_ms >= 1.0.0)

mysqlnd_ms_get_stats — Returns query distribution and connection statistics

Açıklama

array mysqlnd_ms_get_stats ( void )

Returns an array of statistics collected by the replication and load balancing plugin.

The PHP configuration setting mysqlnd_ms.collect_statistics controls the collection of statistics. The collection of statistics is disabled by default for performance reasons.

The scope of the statistics is the PHP process. Depending on your deployment model a PHP process may handle one or multiple requests.

Statistics are aggregated for all connections and all storage handler. It is not possible to tell how much queries originating from mysqli, PDO_MySQL or mysql API calls have contributed to the aggregated data values.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns NULL if the PHP configuration directive mysqlnd_ms.enable has disabled the plugin. Otherwise, returns array of statistics.

Array of statistics

Statistic | Description | Version
use_slave

The semantics of this statistic has changed between 1.0.1 - 1.1.0.

The meaning for version 1.0.1 is as follows. Number of statements considered as read-only by the built-in query analyzer. Neither statements which begin with a SQL hint to force use of slave nor statements directed to a slave by an user-defined callback are included. The total number of statements sent to the slaves is use_slave + use_slave_sql_hint + use_slave_callback.

PECL/mysqlnd_ms 1.1.0 introduces a new concept of chained filters. The statistics is now set by the internal load balancing filter. With version 1.1.0 the load balancing filter is always the last in the filter chain, if used. In future versions a load balancing filter may be followed by other filters causing another change in the meaning of the statistic. If, in the future, a load balancing filter is followed by another filter it is no longer guaranteed that the statement, which increments use_slave, will be executed on the slaves.

The meaning for version 1.1.0 is as follows. Number of statements sent to the slaves. Statements directed to a slave by the user filter (an user-defined callback) are not included. The latter are counted by use_slave_callback.

Since 1.0.0.
use_master

The semantics of this statistic has changed between 1.0.1 - 1.1.0.

The meaning for version 1.0.1 is as follows. Number of statements not considered as read-only by the built-in query analyzer. Neither statements which begin with a SQL hint to force use of master nor statements directed to a master by an user-defined callback are included. The total number of statements sent to the master is use_master + use_master_sql_hint + use_master_callback.

PECL/mysqlnd_ms 1.1.0 introduces a new concept of chained filters. The statictics is now set by the internal load balancing filter. With version 1.1.0 the load balancing filter is always the last in the filter chain, if used. In future versions a load balancing filter may be followed by other filters causing another change in the meaning of the statistic. If, in the future, a load balancing filter is followed by another filter it is no longer guaranteed that the statement, which increments use_master, will be executed on the slaves.

The meaning for version 1.1.0 is as follows. Number of statements sent to the masters. Statements directed to a master by the user filter (an user-defined callback) are not included. The latter are counted by use_master_callback.

Since 1.0.0.
use_slave_guess | Number of statements the built-in query analyzer recommends sending to a slave because they contain no SQL hint to force use of a certain server. The recommendation may be overruled in the following. It is not guaranteed whether the statement will be executed on a slave or not. This is how often the internal is_select function has guessed that a slave shall be used. Please, see also the user space function mysqlnd_ms_query_is_select(). | Since 1.1.0.
use_master_guess | Number of statements the built-in query analyzer recommends sending to a master because they contain no SQL hint to force use of a certain server. The recommendation may be overruled in the following. It is not guaranteed whether the statement will be executed on a slave or not. This is how often the internal is_select function has guessed that a master shall be used. Please, see also the user space function mysqlnd_ms_query_is_select(). | Since 1.1.0.
use_slave_sql_hint | Number of statements sent to a slave because statement begins with the SQL hint to force use of slave. | Since 1.0.0.
use_master_sql_hint | Number of statements sent to a master because statement begins with the SQL hint to force use of master. | Since 1.0.0.
use_last_used_sql_hint | Number of statements sent to server which has run the previous statement, because statement begins with the SQL hint to force use of previously used server. | Since 1.0.0.
use_slave_callback | Number of statements sent to a slave because an user-defined callback has chosen a slave server for statement execution. | Since 1.0.0.
use_master_callback | Number of statements sent to a master because an user-defined callback has chosen a master server for statement execution. | Since 1.0.0.
non_lazy_connections_slave_success | Number of successfully opened slave connections from configurations not using lazy connections. The total number of successfully opened slave connections is non_lazy_connections_slave_success + lazy_connections_slave_success | Since 1.0.0.
non_lazy_connections_slave_failure | Number of failed slave connection attempts from configurations not using lazy connections. The total number of failed slave connection attempts is non_lazy_connections_slave_failure + lazy_connections_slave_failure | Since 1.0.0.
non_lazy_connections_master_success | Number of successfully opened master connections from configurations not using lazy connections. The total number of successfully opened master connections is non_lazy_connections_master_success + lazy_connections_master_success | Since 1.0.0.
non_lazy_connections_master_failure | Number of failed master connection attempts from configurations not using lazy connections. The total number of failed master connection attempts is non_lazy_connections_master_failure + lazy_connections_master_failure | Since 1.0.0.
lazy_connections_slave_success | Number of successfully opened slave connections from configurations using lazy connections. | Since 1.0.0.
lazy_connections_slave_failure | Number of failed slave connection attempts from configurations using lazy connections. | Since 1.0.0.
lazy_connections_master_success | Number of successfully opened master connections from configurations using lazy connections. | Since 1.0.0.
lazy_connections_master_failure | Number of failed master connection attempts from configurations using lazy connections. | Since 1.0.0.
trx_autocommit_on | Number of autocommit mode activations via API calls. This figure may be used to monitor activity related to the plugin configuration setting trx_stickiness. If, for example, you want to know if a certain API call invokes the mysqlnd library function trx_autocommit(), which is a requirement for trx_stickiness, you may call the user API function in question and check if the statistic has changed. The statistic is modified only by the plugins internal subclassed trx_autocommit() method. | Since 1.0.0.
trx_autocommit_off | Number of autocommit mode deactivations via API calls. | Since 1.0.0.
trx_master_forced | Number of statements redirected to the master while trx_stickiness=master and autocommit mode is disabled. | Since 1.0.0.
gtid_autocommit_injections_success | Number of successful SQL injections in autocommit mode as part of the plugins client-side global transaction id emulation. | Since 1.2.0.
gtid_autocommit_injections_failure | Number of failed SQL injections in autocommit mode as part of the plugins client-side global transaction id emulation. | Since 1.2.0.
gtid_commit_injections_success | Number of successful SQL injections in commit mode as part of the plugins client-side global transaction id emulation. | Since 1.2.0.
gtid_commit_injections_failure | Number of failed SQL injections in commit mode as part of the plugins client-side global transaction id emulation. | Since 1.2.0.
gtid_implicit_commit_injections_success | Number of successful SQL injections when implicit commit is detected as part of the plugins client-side global transaction id emulation. Implicit commit happens, for example, when autocommit has been turned off, a query is executed and autocommit is enabled again. In that case, the statement will be committed by the server and SQL to maintain is injected before the autocommit is re-enabled. Another sequence causing an implicit commit is begin(), query(), begin(). The second call to begin() will implicitly commit the transaction started by the first call to begin(). begin() refers to internal library calls not actual PHP user API calls. | Since 1.2.0.
gtid_implicit_commit_injections_failure | Number of failed SQL injections when implicit commit is detected as part of the plugins client-side global transaction id emulation. Implicit commit happens, for example, when autocommit has been turned off, a query is executed and autocommit is enabled again. In that case, the statement will be committed by the server and SQL to maintain is injected before the autocommit is re-enabled. | Since 1.2.0.
transient_error_retries | How often an operation has been retried when a transient error was detected. See also, transient_error plugin configuration file setting. | Since 1.6.0.
fabric_sharding_lookup_servers_success | Number of successful sharding.lookup_servers remote procedure calls to MySQL Fabric. A call is considered successful if the plugin could reach MySQL Fabric and got any reply. The reply itself may or may not be understood by the plugin. Success refers to the network transport only. If the reply was not understood or indicates a valid error condition, fabric_sharding_lookup_servers_xml_failure gets incremented. | Since 1.6.0.
fabric_sharding_lookup_servers_failure | Number of failed sharding.lookup_servers remote procedure calls to MySQL Fabric. A remote procedure call is considered failed if there was a network error in connecting to, writing to or reading from MySQL Fabric. | Since 1.6.0.
fabric_sharding_lookup_servers_time_total | Time spent connecting to,writing to and reading from MySQL Fabrich during the sharding.lookup_servers remote procedure call. The value is aggregated for all calls. Time is measured in microseconds. | Since 1.6.0.
fabric_sharding_lookup_servers_bytes_total | Total number of bytes received from MySQL Fabric in reply to sharding.lookup_servers calls. | Since 1.6.0.
fabric_sharding_lookup_servers_xml_failure | How often a reply from MySQL Fabric to sharding.lookup_servers calls was not understood. Please note, the current experimental implementation does not distinguish between valid errors returned and malformed replies. | Since 1.6.0.
xa_begin | How many XA/distributed transactions have been started using mysqlnd_ms_xa_begin(). | Since 1.6.0.
xa_commit_success | How many XA/distributed transactions have been successfully committed using mysqlnd_ms_xa_commit(). | Since 1.6.0.
xa_commit_failure | How many XA/distributed transactions failed to commit during mysqlnd_ms_xa_commit(). | Since 1.6.0.
xa_rollback_success | How many XA/distributed transactions have been successfully rolled back using mysqlnd_ms_xa_rollback(). The figure does not include implict rollbacks performed as a result of mysqlnd_ms_xa_commit() failure. | Since 1.6.0.
xa_rollback_failure | How many XA/distributed transactions could not be rolled back. This includes failures of mysqlnd_ms_xa_rollback() but also failured during rollback when closing a connection, if rollback_on_close is set. Please, see also xa_rollback_on_close below. | Since 1.6.0.
xa_participants | Total number of participants in any XA transaction started with mysqlnd_ms_xa_begin(). | Since 1.6.0.
xa_rollback_on_close | How many XA transactions have been rolled back implicitly when a connection was close and rollback_on_close is set. Depending on your coding policies, this may hint a flaw in your code as you may prefer to explicitly clean up resources. | Since 1.6.0.
pool_masters_total | Number of master servers (connections) in the internal connection pool. | Since 1.6.0.
pool_slaves_total | Number of slave servers (connections) in the internal connection pool. | Since 1.6.0.
pool_masters_active | Number of master servers (connections) from the internal connection pool which are currently used for picking a connection. | Since 1.6.0.
pool_slaves_active | Number of slave servers (connections) from the internal connection pool which are currently used for picking a connection. | Since 1.6.0.
pool_updates | How often the active connection list has been replaced and a new set of master and slave servers had been installed. | Since 1.6.0.
pool_master_reactivated | How often a master connection has been reused after being flushed from the active list. | Since 1.6.0.
pool_slave_reactivated | How often a slave connection has been reused after being flushed from the active list. | Since 1.6.0.

Örnekler

Örnek 1 mysqlnd_ms_get_stats() example

<?php
printf("mysqlnd_ms.enable = %d\n", ini_get("mysqlnd_ms.enable"));
printf("mysqlnd_ms.collect_statistics = %d\n", ini_get("mysqlnd_ms.collect_statistics"));
var_dump(mysqlnd_ms_get_stats());
?>

Yukarıdaki örneğin çıktısı:

mysqlnd_ms.enable = 1
mysqlnd_ms.collect_statistics = 1
array(26) {
  ["use_slave"]=>
  string(1) "0"
  ["use_master"]=>
  string(1) "0"
  ["use_slave_guess"]=>
  string(1) "0"
  ["use_master_guess"]=>
  string(1) "0"
  ["use_slave_sql_hint"]=>
  string(1) "0"
  ["use_master_sql_hint"]=>
  string(1) "0"
  ["use_last_used_sql_hint"]=>
  string(1) "0"
  ["use_slave_callback"]=>
  string(1) "0"
  ["use_master_callback"]=>
  string(1) "0"
  ["non_lazy_connections_slave_success"]=>
  string(1) "0"
  ["non_lazy_connections_slave_failure"]=>
  string(1) "0"
  ["non_lazy_connections_master_success"]=>
  string(1) "0"
  ["non_lazy_connections_master_failure"]=>
  string(1) "0"
  ["lazy_connections_slave_success"]=>
  string(1) "0"
  ["lazy_connections_slave_failure"]=>
  string(1) "0"
  ["lazy_connections_master_success"]=>
  string(1) "0"
  ["lazy_connections_master_failure"]=>
  string(1) "0"
  ["trx_autocommit_on"]=>
  string(1) "0"
  ["trx_autocommit_off"]=>
  string(1) "0"
  ["trx_master_forced"]=>
  string(1) "0"
  ["gtid_autocommit_injections_success"]=>
  string(1) "0"
  ["gtid_autocommit_injections_failure"]=>
  string(1) "0"
  ["gtid_commit_injections_success"]=>
  string(1) "0"
  ["gtid_commit_injections_failure"]=>
  string(1) "0"
  ["gtid_implicit_commit_injections_success"]=>
  string(1) "0"
  ["gtid_implicit_commit_injections_failure"]=>
  string(1) "0"
  ["transient_error_retries"]=>
  string(1) "0"
}

Ayrıca Bakınız

  • Runtime configuration
  • mysqlnd_ms.collect_statistics
  • mysqlnd_ms.enable
  • Monitoring

mysqlnd_ms_get_last_used_connection
mysqlnd_ms_match_wild
Mysqlnd_ms İşlevleri


Finds whether a table name matches a wildcard pattern or not

mysqlnd_ms_get_stats
mysqlnd_ms_query_is_select
Mysqlnd_ms İşlevleri
PHP Manual

mysqlnd_ms_match_wild

(PECL mysqlnd_ms >= 1.1.0)

mysqlnd_ms_match_wild — Finds whether a table name matches a wildcard pattern or not

Açıklama

bool mysqlnd_ms_match_wild ( string $table_name , string $wildcard )

Finds whether a table name matches a wildcard pattern or not.

This function is not of much practical relevance with PECL mysqlnd_ms 1.1.0 because the plugin does not support MySQL replication table filtering yet.

Değiştirgeler

table_name

The table name to check if it is matched by the wildcard.

wildcard

The wildcard pattern to check against the table name. The wildcard pattern supports the same placeholders as MySQL replication filters do.

MySQL replication filters can be configured by using the MySQL Server configuration options --replicate-wild-do-table and --replicate-wild-do-db. Please, consult the MySQL Reference Manual to learn more about this MySQL Server feature.

The supported placeholders are:

  • % - zero or more literals
  • _ - one literal

Placeholders can be escaped using \.

Dönen Değerler

Returns TRUE table_name is matched by wildcard. Otherwise, returns FALSE

Örnekler

Örnek 1 mysqlnd_ms_match_wild() example

<?php
var_dump(mysqlnd_ms_match_wild("schema_name.table_name", "schema%"));
var_dump(mysqlnd_ms_match_wild("abc", "_"));
var_dump(mysqlnd_ms_match_wild("table1", "table_"));
var_dump(mysqlnd_ms_match_wild("asia_customers", "%customers"));
var_dump(mysqlnd_ms_match_wild("funny%table","funny\%table"));
var_dump(mysqlnd_ms_match_wild("funnytable", "funny%table"));
?>

Yukarıdaki örneğin çıktısı:

bool(true)
bool(false)
bool(true)
bool(true)
bool(true)
bool(true)

mysqlnd_ms_get_stats
mysqlnd_ms_query_is_select
Mysqlnd_ms İşlevleri


Find whether to send the query to the master, the slave or the last used MySQL server

mysqlnd_ms_match_wild
mysqlnd_ms_set_qos
Mysqlnd_ms İşlevleri
PHP Manual

mysqlnd_ms_query_is_select

(PECL mysqlnd_ms >= 1.0.0)

mysqlnd_ms_query_is_select — Find whether to send the query to the master, the slave or the last used MySQL server

Açıklama

int mysqlnd_ms_query_is_select ( string $query )

Finds whether to send the query to the master, the slave or the last used MySQL server.

The plugins built-in read/write split mechanism will be used to analyze the query string to make a recommendation where to send the query. The built-in read/write split mechanism is very basic and simple. The plugin will recommend sending all queries to the MySQL replication master server but those which begin with SELECT, or begin with a SQL hint which enforces sending the query to a slave server. Due to the basic but fast algorithm the plugin may propose to run some read-only statements such as SHOW TABLES on the replication master.

Değiştirgeler

query

Query string to test.

Dönen Değerler

A return value of MYSQLND_MS_QUERY_USE_MASTER indicates that the query should be send to the MySQL replication master server. The function returns a value of MYSQLND_MS_QUERY_USE_SLAVE if the query can be run on a slave because it is considered read-only. A value of MYSQLND_MS_QUERY_USE_LAST_USED is returned to recommend running the query on the last used server. This can either be a MySQL replication master server or a MySQL replication slave server.

If read write splitting has been disabled by setting mysqlnd_ms.disable_rw_split, the function will always return MYSQLND_MS_QUERY_USE_MASTER or MYSQLND_MS_QUERY_USE_LAST_USED.

Örnekler

Örnek 1 mysqlnd_ms_query_is_select() example

<?php
function is_select($query)
{
 switch (mysqlnd_ms_query_is_select($query))
 {
  case MYSQLND_MS_QUERY_USE_MASTER:
   printf("'%s' should be run on the master.\n", $query);
   break;
  case MYSQLND_MS_QUERY_USE_SLAVE:
   printf("'%s' should be run on a slave.\n", $query);
   break;
  case MYSQLND_MS_QUERY_USE_LAST_USED:
   printf("'%s' should be run on the server that has run the previous query\n", $query);
   break;
  default:
   printf("No suggestion where to run the '%s', fallback to master recommended\n", $query);
   break;
 }
}

is_select("INSERT INTO test(id) VALUES (1)");
is_select("SELECT 1 FROM DUAL");
is_select("/*" . MYSQLND_MS_LAST_USED_SWITCH . "*/SELECT 2 FROM DUAL");
?>

Yukarıdaki örneğin çıktısı:

INSERT INTO test(id) VALUES (1) should be run on the master.
SELECT 1 FROM DUAL should be run on a slave.
/*ms=last_used*/SELECT 2 FROM DUAL should be run on the server that has run the previous query

Ayrıca Bakınız

  • Predefined Constants
  • user filter
  • Runtime configuration
  • mysqlnd_ms.disable_rw_split
  • mysqlnd_ms.enable

mysqlnd_ms_match_wild
mysqlnd_ms_set_qos
Mysqlnd_ms İşlevleri


Sets the quality of service needed from the cluster

mysqlnd_ms_query_is_select
mysqlnd_ms_set_user_pick_server
Mysqlnd_ms İşlevleri
PHP Manual

mysqlnd_ms_set_qos

(PECL mysqlnd_ms < 1.2.0)

mysqlnd_ms_set_qos — Sets the quality of service needed from the cluster

Açıklama

bool mysqlnd_ms_set_qos ( mixed $connection , int $service_level [, int $service_level_option [, mixed $option_value ]] )

Sets the quality of service needed from the cluster. A database cluster delivers a certain quality of service to the user depending on its architecture. A major aspect of the quality of service is the consistency level the cluster can offer. An asynchronous MySQL replication cluster defaults to eventual consistency for slave reads: a slave may serve stale data, current data, or it may have not the requested data at all, because it is not synchronous to the master. In a MySQL replication cluster, only master accesses can give strong consistency, which promises that all clients see each others changes.

PECL/mysqlnd_ms hides the complexity of choosing appropriate nodes to achieve a certain level of service from the cluster. The "Quality of Service" filter implements the necessary logic. The filter can either be configured in the plugins configuration file, or at runtime using mysqlnd_ms_set_qos().

Similar results can be achieved with PECL mysqlnd_ms < 1.2.0, if using SQL hints to force the use of a certain type of node or using the master_on_write plugin configuration option. The first requires more code and causes more work on the application side. The latter is less refined than using the quality of service filter. Settings made through the function call can be reversed, as shown in the example below. The example temporarily switches to a higher service level (session consistency, read your writes) and returns back to the clusters default after it has performed all operations that require the better service. This way, read load on the master can be minimized compared to using master_on_write, which would continue using the master after the first write.

Since 1.5.0 calls will fail when done in the middle of a transaction if transaction stickiness is enabled and transaction boundaries have been detected. properly.

Değiştirgeler

connection

A PECL/mysqlnd_ms connection handle to a MySQL server of the type PDO_MYSQL, mysqli or ext/mysql for which a service level is to be set. The connection handle is obtained when opening a connection with a host name that matches a mysqlnd_ms configuration file entry using any of the above three MySQL driver extensions.

service_level

The requested service level: MYSQLND_MS_QOS_CONSISTENCY_EVENTUAL, MYSQLND_MS_QOS_CONSISTENCY_SESSION or MYSQLND_MS_QOS_CONSISTENCY_STRONG.

service_level_option

An option to parameterize the requested service level. The option can either be MYSQLND_MS_QOS_OPTION_GTID or MYSQLND_MS_QOS_OPTION_AGE.

The option MYSQLND_MS_QOS_OPTION_GTID can be used to refine the service level MYSQLND_MS_QOS_CONSISTENCY_SESSION. It must be combined with a fourth function parameter, the option_value. The option_value shall be a global transaction ID obtained from mysqlnd_ms_get_last_gtid(). If set, the plugin considers both master servers and asynchronous slaves for session consistency (read your writes). Otherwise, only masters are used to achieve session consistency. A slave is considered up-to-date and checked if it has already replicated the global transaction ID from option_value. Please note, searching appropriate slaves is an expensive and slow operation. Use the feature sparsely, if the master cannot handle the read load alone.

The MYSQLND_MS_QOS_OPTION_AGE option can be combined with the MYSQLND_MS_QOS_CONSISTENCY_EVENTUAL service level, to filter out asynchronous slaves that lag more seconds behind the master than option_value. If set, the plugin will only consider slaves for reading if SHOW SLAVE STATUS reports Slave_IO_Running=Yes, Slave_SQL_Running=Yes and Seconds_Behind_Master <= option_value. Please note, searching appropriate slaves is an expensive and slow operation. Use the feature sparsely in version 1.2.0. Future versions may improve the algorithm used to identify candidates. Please, see the MySQL reference manual about the precision, accuracy and limitations of the MySQL administrative command SHOW SLAVE STATUS.

option_value

Parameter value for the service level option. See also the service_level_option parameter.

Dönen Değerler

Returns TRUE if the connections service level has been switched to the requested. Otherwise, returns FALSE

Notlar

Bilginize:

mysqlnd_ms_set_qos() requires PHP >= 5.4.0 and PECL mysqlnd_ms >= 1.2.0. Internally, it is using a mysqlnd library C functionality not available with PHP 5.3.

Please note, all MySQL 5.6 production versions do not provide clients with enough information to use GTIDs for enforcing session consistency. In the worst case, the plugin will choose the master only.

Örnekler

Örnek 1 mysqlnd_ms_set_qos() example

<?php
/* Open mysqlnd_ms connection using mysqli, PDO_MySQL or mysql extension */
$mysqli = new mysqli("myapp", "username", "password", "database");
if (!$mysqli)
  /* Of course, your error handling is nicer... */
  die(sprintf("[%d] %s\n", mysqli_connect_errno(), mysqli_connect_error()));

/* Session consistency: read your writes */
$ret = mysqlnd_ms_set_qos($mysqli, MYSQLND_MS_QOS_CONSISTENCY_SESSION);
if (!$ret)
  die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));

/* Will use master and return fresh data, client can see his last write */
if (!$res = $mysqli->query("SELECT item, price FROM orders WHERE order_id = 1"))
  die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));

/* Back to default: use of all slaves and masters permitted, stale data can happen */
if (!mysqlnd_ms_set_qos($mysqli, MYSQLND_MS_QOS_CONSISTENCY_EVENTUAL))
  die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));
?>

Ayrıca Bakınız

  • mysqlnd_ms_get_last_gtid() - Returns the latest global transaction ID
  • Service level and consistency concept
  • Filter concept

mysqlnd_ms_query_is_select
mysqlnd_ms_set_user_pick_server
Mysqlnd_ms İşlevleri


Sets a callback for user-defined read/write splitting

mysqlnd_ms_set_qos
mysqlnd_ms_xa_begin
Mysqlnd_ms İşlevleri
PHP Manual

mysqlnd_ms_set_user_pick_server

(PECL mysqlnd_ms < 1.1.0)

mysqlnd_ms_set_user_pick_server — Sets a callback for user-defined read/write splitting

Açıklama

bool mysqlnd_ms_set_user_pick_server ( string $function )

Sets a callback for user-defined read/write splitting. The plugin will call the callback only if pick[]=user is the default rule for server picking in the relevant section of the plugins configuration file.

The plugins built-in read/write query split mechanism decisions can be overwritten in two ways. The easiest way is to prepend the query string with the SQL hints MYSQLND_MS_MASTER_SWITCH, MYSQLND_MS_SLAVE_SWITCH or MYSQLND_MS_LAST_USED_SWITCH. Using SQL hints one can control, for example, whether a query shall be send to the MySQL replication master server or one of the slave servers. By help of SQL hints it is not possible to pick a certain slave server for query execution.

Full control on server selection can be gained using a callback function. Use of a callback is recommended to expert users only because the callback has to cover all cases otherwise handled by the plugin.

The plugin will invoke the callback function for selecting a server from the lists of configured master and slave servers. The callback function inspects the query to run and picks a server for query execution by returning the hosts URI, as found in the master and slave list.

If the lazy connections are enabled and the callback chooses a slave server for which no connection has been established so far and establishing the connection to the slave fails, the plugin will return an error upon the next action on the failed connection, for example, when running a query. It is the responsibility of the application developer to handle the error. For example, the application can re-run the query to trigger a new server selection and callback invocation. If so, the callback must make sure to select a different slave, or check slave availability, before returning to the plugin to prevent an endless loop.

Değiştirgeler

function

The function to be called. Class methods may also be invoked statically using this function by passing array($classname, $methodname) to this parameter. Additionally class methods of an object instance may be called by passing array($objectinstance, $methodname) to this parameter.

Dönen Değerler

Host to run the query on. The host URI is to be taken from the master and slave connection lists passed to the callback function. If callback returns a value neither found in the master nor in the slave connection lists the plugin will fallback to the second pick method configured via the pick[] setting in the plugin configuration file. If not second pick method is given, the plugin falls back to the build-in default pick method for server selection.

Notlar

Bilginize:

mysqlnd_ms_set_user_pick_server() is available with PECL mysqlnd_ms < 1.1.0. It has been replaced by the user filter. Please, check the Change History for upgrade notes.

Örnekler

Örnek 1 mysqlnd_ms_set_user_pick_server() example

[myapp]
master[] = localhost
slave[] = 192.168.2.27:3306
slave[] = 192.168.78.136:3306
pick[] = user
<?php

function pick_server($connected, $query, $master, $slaves, $last_used)
{
 static $slave_idx = 0;
 static $num_slaves = NULL;
 if (is_null($num_slaves))
  $num_slaves = count($slaves);

 /* default: fallback to the plugins build-in logic */
 $ret = NULL;

 printf("User has connected to '%s'...\n", $connected);
 printf("... deciding where to run '%s'\n", $query);

 $where = mysqlnd_ms_query_is_select($query);
 switch ($where)
 {
  case MYSQLND_MS_QUERY_USE_MASTER:
   printf("... using master\n");
   $ret = $master[0];
   break;
  case MYSQLND_MS_QUERY_USE_SLAVE:
   /* SELECT or SQL hint for using slave */
   if (stristr($query, "FROM table_on_slave_a_only"))
   {
    /* a table which is only on the first configured slave  */
    printf("... access to table available only on slave A detected\n");
    $ret = $slaves[0];
   }
   else
   {
    /* round robin */
    printf("... some read-only query for a slave\n");
    $ret = $slaves[$slave_idx++ % $num_slaves];
   }
   break;
  case MYSQLND_MS_QUERY_LAST_USED:
   printf("... using last used server\n");
   $ret = $last_used;
   break;
 }

 printf("... ret = '%s'\n", $ret);
 return $ret;
}

mysqlnd_ms_set_user_pick_server("pick_server");

$mysqli = new mysqli("myapp", "root", "root", "test");

if (!($res = $mysqli->query("SELECT 1 FROM DUAL")))
 printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
else
 $res->close();

if (!($res = $mysqli->query("SELECT 2 FROM DUAL")))
 printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
else
 $res->close();

if (!($res = $mysqli->query("SELECT * FROM table_on_slave_a_only")))
 printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
else
 $res->close();

$mysqli->close();
?>

Yukarıdaki örneğin çıktısı:

User has connected to 'myapp'...
... deciding where to run 'SELECT 1 FROM DUAL'
... some read-only query for a slave
... ret = 'tcp://192.168.2.27:3306'
User has connected to 'myapp'...
... deciding where to run 'SELECT 2 FROM DUAL'
... some read-only query for a slave
... ret = 'tcp://192.168.78.136:3306'
User has connected to 'myapp'...
... deciding where to run 'SELECT * FROM table_on_slave_a_only'
... access to table available only on slave A detected
... ret = 'tcp://192.168.2.27:3306'

Ayrıca Bakınız

  • mysqlnd_ms_query_is_select() - Find whether to send the query to the master, the slave or the last used MySQL server
  • Filter concept
  • user filter

mysqlnd_ms_set_qos
mysqlnd_ms_xa_begin
Mysqlnd_ms İşlevleri


Starts a distributed/XA transaction among MySQL servers

mysqlnd_ms_set_user_pick_server
mysqlnd_ms_xa_commit
Mysqlnd_ms İşlevleri
PHP Manual

mysqlnd_ms_xa_begin

(PECL mysqlnd_ms < 1.6.0)

mysqlnd_ms_xa_begin — Starts a distributed/XA transaction among MySQL servers

Açıklama

int mysqlnd_ms_xa_begin ( mixed $connection , string $gtrid [, int $timeout ] )

Starts a XA transaction among MySQL servers. PECL/mysqlnd_ms acts as a transaction coordinator the distributed transaction.

Once a global transaction has been started, the plugin injects appropriate XA BEGIN SQL statements on all MySQL servers used in the following. The global transaction is either ended by calling mysqlnd_ms_xa_commit(), mysqlnd_ms_xa_rollback() or by an implicit rollback in case of an error.

During a global transaction, the plugin tracks all server switches, for example, when switching from one MySQL shard to another MySQL shard. Immediately before a query is run on a server that has not been participating in the global transaction yet, XA BEGIN is executed on the server. From a users perspective the injection happens during a call to a query execution function such as mysqli_query(). Should the injection fail an error is reported to the caller of the query execution function. The failing server does not become a participant in the global transaction. The user may retry executing a query on the server and hereby retry injecting XA BEGIN, abort the global transaction because not all required servers can participate, or ignore and continue the global without the failed server.

Reasons to fail executing XA BEGIN include but are not limited to a server being unreachable or the server having an open, concurrent XA transaction using the same xid.

Please note, global and local transactions are mutually exclusive. You cannot start a XA transaction when you have a local transaction open. The local transaction must be ended first. The plugin tries to detect this conflict as early as possible. It monitors API calls for controlling local transactions to learn about the current state. However, if using SQL statements for local transactions such as BEGIN, the plugin may not know the current state and the conflict is not detected before XA BEGIN is injected and executed.

The use of other XA resources but MySQL servers is not supported by the function. To carry out a global transaction among, for example, a MySQL server and another vendors database system, you should issue the systems SQL commands yourself.

Bilginize: Experimental

The feature is currently under development. There may be issues and/or feature limitations. Do not use in production environments.

Değiştirgeler

connection

A MySQL connection handle obtained from any of the connect functions of the mysqli, mysql or PDO_MYSQL extensions.

gtrid

Global transaction identifier (gtrid). The gtrid is a binary string up to 64 bytes long. Please note, depending on your character set settings, 64 characters may require more than 64 bytes to store.

In accordance with the MySQL SQL syntax, XA transactions use identifiers made of three parts. An xid consists of a global transaction identifier (gtrid), a branch qualifier (bqual) and a format identifier (formatID). Only the global transaction identifier can and needs to be set.

The branch qualifier and format identifier are set automatically. The details should be considered implementation dependent, which may change without prior notice. In version 1.6 the branch qualifier is consecutive number which is incremented whenever a participant joins the global transaction.

timeout

Timeout in seconds. The default value is 60 seconds.

The timeout is a hint to the garbage collection. If a transaction is recorded to take longer than expected, the garbage collection begins checking the transactions status.

Setting a low value may make the garbage collection check the progress too often. Please note, checking the status of a global transaction may involve connecting to all recorded participants and possibly issuing queries on the servers.

Dönen Değerler

Returns TRUE if there is no open local or global transaction and a new global transaction can be started. Otherwise, returns FALSE

Ayrıca Bakınız

  • Quickstart XA/Distributed transactions
  • Runtime configuration
  • mysqlnd_ms_get_stats() - Returns query distribution and connection statistics

mysqlnd_ms_set_user_pick_server
mysqlnd_ms_xa_commit
Mysqlnd_ms İşlevleri


Commits a distributed/XA transaction among MySQL servers

mysqlnd_ms_xa_begin
mysqlnd_ms_xa_gc
Mysqlnd_ms İşlevleri
PHP Manual

mysqlnd_ms_xa_commit

(PECL mysqlnd_ms < 1.6.0)

mysqlnd_ms_xa_commit — Commits a distributed/XA transaction among MySQL servers

Açıklama

int mysqlnd_ms_xa_commit ( mixed $connection , string $gtrid )

Commits a global transaction among MySQL servers started by mysqlnd_ms_xa_begin().

If any of the global transaction participants fails to commit an implicit rollback is performed. It may happen that not all cases can be handled during the rollback. For example, no attempts will be made to reconnect to a participant after the connection to the participant has been lost. Solving cases that cannot easily be rolled back is left to the garbage collection.

Bilginize: Experimental

The feature is currently under development. There may be issues and/or feature limitations. Do not use in production environments.

Değiştirgeler

connection

A MySQL connection handle obtained from any of the connect functions of the mysqli, mysql or PDO_MYSQL extensions.

gtrid

Global transaction identifier (gtrid).

Dönen Değerler

Returns TRUE if the global transaction has been committed. Otherwise, returns FALSE

Ayrıca Bakınız

  • Quickstart XA/Distributed transactions
  • Runtime configuration
  • mysqlnd_ms_get_stats() - Returns query distribution and connection statistics

mysqlnd_ms_xa_begin
mysqlnd_ms_xa_gc
Mysqlnd_ms İşlevleri


Garbage collects unfinished XA transactions after severe errors

mysqlnd_ms_xa_commit
mysqlnd_ms_xa_rollback
Mysqlnd_ms İşlevleri
PHP Manual

mysqlnd_ms_xa_gc

(PECL mysqlnd_ms < 1.6.0)

mysqlnd_ms_xa_gc — Garbage collects unfinished XA transactions after severe errors

Açıklama

int mysqlnd_ms_xa_gc ( mixed $connection [, string $gtrid [, boolean $ignore_max_retries ]] )

Garbage collects unfinished XA transactions.

The XA protocol is a blocking protocol. There exist cases when servers participating in a global transaction cannot make progress when the transaction coordinator crashes or disconnects. In such a case, the MySQL servers keep waiting for instructions to finish the XA transaction in question. Because transactions occupy resources, transactions should always be terminated properly.

Garbage collection requires configuring a state store to track global transactions. Should a PHP client crash in the middle of a transaction and a new PHP client be started, then the built-in garbage collection can learn about the aborted global transaction and terminate it. If you do not configure a state store, the garbage collection cannot perform any cleanup tasks.

The state store should be crash-safe and be highly available to survive its own crash. Currently, only MySQL is supported as a state store.

Garbage collection can also be performed automatically in the background. See the plugin configuration directive garbage_collection for details.

Bilginize: Experimental

The feature is currently under development. There may be issues and/or feature limitations. Do not use in production environments.

Değiştirgeler

connection

A MySQL connection handle obtained from any of the connect functions of the mysqli, mysql or PDO_MYSQL extensions.

gtrid

Global transaction identifier (gtrid). If given, the garbage collection considers the transaction only. Otherwise, the state store is scanned for any unfinished transaction.

ignore_max_retries

Whether to ignore the plugin configuration max_retries setting. If garbage collection continuously fails and the max_retries limit is reached prior to finishing the failed global transaction, you can attempt further runs prior to investigating the cause and solving the issue manually by issuing appropriate SQL statements on the participants. Setting the parameter has the same effect as temporarily setting max_retries = 0.

Dönen Değerler

Returns TRUE if garbage collection was successful. Otherwise, returns FALSE

Ayrıca Bakınız

  • Quickstart XA/Distributed transactions
  • Runtime configuration
  • State store configuration
  • mysqlnd_ms_get_stats() - Returns query distribution and connection statistics

mysqlnd_ms_xa_commit
mysqlnd_ms_xa_rollback
Mysqlnd_ms İşlevleri


Rolls back a distributed/XA transaction among MySQL servers

mysqlnd_ms_xa_gc
Change History
Mysqlnd_ms İşlevleri
PHP Manual

mysqlnd_ms_xa_rollback

(PECL mysqlnd_ms < 1.6.0)

mysqlnd_ms_xa_rollback — Rolls back a distributed/XA transaction among MySQL servers

Açıklama

int mysqlnd_ms_xa_rollback ( mixed $connection , string $gtrid )

Rolls back a global transaction among MySQL servers started by mysqlnd_ms_xa_begin().

If any of the global transaction participants fails to rollback the situation is left to be solved by the garbage collection.

Bilginize: Experimental

The feature is currently under development. There may be issues and/or feature limitations. Do not use in production environments.

Değiştirgeler

connection

A MySQL connection handle obtained from any of the connect functions of the mysqli, mysql or PDO_MYSQL extensions.

gtrid

Global transaction identifier (gtrid).

Dönen Değerler

Returns TRUE if the global transaction has been rolled back. Otherwise, returns FALSE

Ayrıca Bakınız

  • Quickstart XA/Distributed transactions
  • Runtime configuration
  • mysqlnd_ms_get_stats() - Returns query distribution and connection statistics

mysqlnd_ms_xa_gc
Change History
Mysqlnd_ms İşlevleri


Change History

İçindekiler

  • PECL/mysqlnd_ms 1.6 series
  • PECL/mysqlnd_ms 1.5 series
  • PECL/mysqlnd_ms 1.4 series
  • PECL/mysqlnd_ms 1.3 series
  • PECL/mysqlnd_ms 1.2 series
  • PECL/mysqlnd_ms 1.1 series
  • PECL/mysqlnd_ms 1.0 series

This change history is a high level summary of selected changes that may impact applications and/or break backwards compatibility.

See also the CHANGES file in the source distribution for a complete list of changes.

mysqlnd_ms_xa_rollback
PECL/mysqlnd_ms 1.6 series
mysqlnd_ms


PECL/mysqlnd_ms 1.6 series

1.6.0-alpha

  • Release date: TBD
  • Motto/theme: Maintenance and initial MySQL Fabric support

Bilginize:

This is the current development series. All features are at an early stage. Changes may happen at any time without prior notice. Please, do not use this version in production environments.

The documentation may not reflect all changes yet.

Bug fixes

  • Won't fix: #66616 R/W split fails: QOS with mysqlnd_get_last_gtid with built-in MySQL GTID

    This is not a bug in the plugins implementation but a server side feature limitation not considered and documented before. MySQL 5.6 built-in GTIDs cannot be used to ensure session consistency when reading from slaves in all cases. In the worst case the plugin will not consider using the slaves and fallback to using the master. There will be no wrong results but no benefit from doing GTID checks either.

  • Fixed #66064 - Random once load balancer ignoring weights

    Due to a config parsing bug random load balancing has ignored node weights if, and only if, the sticky flag was set (random once).

  • Fixed #65496 - Wrong check for slave delay

    The quality of service filter has erroneously ignored slaves that lag for zero (0) seconds if a any maximum lag had been set. Although a slave was not lagging behind, it was excluded from the load balancing list if a maximum age was set by the QoS filter. This was due to using the wrong comparison operator in the source of the filter.

  • Fixed #65408 - Compile failure with -Werror=format-security

Feature changes

  • Introduced an internal connection pool. When using Fabric and switching from shard group A to shard group B, we are replacing the entire list of masters and slaves. This troubles the connections state alignment logic and some filters. Some filters cache information on the master and slave lists. The new internal connection pool abstraction allows us to inform the filters of changes, hence they can update their caches.

    Later on, the pool can also be used to reduce connection overhead. Assume you are switching from a shard group to another and back again. Whenever the switch is done, the pool's active server (and connection) lists are replaced. However, no longer used connections are not necessarily closed immediately but can be kept in the pool for later reuse.

    Please note, the connection pool is internalat this point. There are some new statistics to monitor it. However, you cannot yet configure pool size of behaviour.

  • Added a basic distributed transaction abstraction. XA transactions can are supported ever since using standard SQL calls. This is inconvenient as XA participants must be managed manually. PECL/mysqlnd_ms introduces API calls to control XA transaction among MySQL servers. When using the new functions, PECL/mysqlnd_ms acts as a transaction coordinator. After starting a distributed transaction, the plugin tracks all servers involved until the transaction is ended and issues appropriate SQL statements on the XA participants.

    This is useful, for example, when using Fabric and sharding. When using Fabric the actual shard servers involved in a business transaction may not be known in advance. Thus, manually controlling a transaction that spawns multiple shards becomes difficult. Please, be warned about current limitations.

  • Introduced automatic retry loop for transient errors and corresponding statistic to count the number of implicit retries. Some distributed database clusters use transient errors to hint a client to retry its operation in a bit. Most often, the client is then supposed to halt execution (sleep) for a short moment before retrying the desired operation. Immediately failing over to another node is not necessary in response to the error. Instead, a retry loop can be performed. Common situation when using MySQL Cluster.

  • Introduced automatic retry loop for transient errors and corresponding statistic to count the number of implicit retries. Some distributed database clusters use transient errors to hint a client to retry its operation in a bit. Most often, the client is then supposed to halt execution (sleep) for a short moment before retrying the desired operation. Immediately failing over to another node is not necessary in response to the error. Instead, a retry loop can be performed. Common situation when using MySQL Cluster.

  • Introduced most basic support for the MySQL Fabric High Availability and sharding framework.

    Please, consider this pre-alpha quality. Both the server side framework and the client side code is supposed to work flawless considering the MySQL Fabric quickstart examples only. However, testing has not been performed to the level of prior plugin alpha releases. Either sides are moving targets, API changes may happen at any time without prior warning.

    As this is work in progress, the manual may not yet reflect allow feature limitations and known bugs.

  • New statistics to monitor the Fabric XML RPC call sharding.lookup_servers: fabric_sharding_lookup_servers_success, fabric_sharding_lookup_servers_failure, fabric_sharding_lookup_servers_time_total, fabric_sharding_lookup_servers_bytes_total, fabric_sharding_lookup_servers_xml_failure.

  • New functions related to MySQL Fabric:
mysqlnd_ms_fabric_select_shard(),
mysqlnd_ms_fabric_select_global(),
mysqlnd_ms_dump_servers().

Change History
PECL/mysqlnd_ms 1.5 series
Change History


PECL/mysqlnd_ms 1.5 series

1.5.1-stable

  • Release date: 06/2013
  • Motto/theme: Sharding support, improved transaction support

Bilginize:

This is the current stable series. Use this version in production environments.

The documentation is complete.

1.5.0-alpha

  • Release date: 03/2013
  • Motto/theme: Sharding support, improved transaction support

Bug fixes

  • Fixed #60605 PHP segmentation fault when mysqlnd_ms is enabled.

  • Setting transaction stickiness disables all load balancing, including automatic failover, for the duration of a transaction. So far connection switches could have happened in the middle of a transaction in multi-master configurations and during automatic failover although transaction monitoring had detected transaction boundaries properly.

  • BC break and bug fix. SQL hints enforcing the use of a specific kind of server (MYSQLND_MS_MASTER_SWITCH, MYSQLND_MS_SLAVE_SWITCH, MYSQLND_MS_LAST_USED_SWITCH) are ignored for the duration of a transaction of transaction stickiness is enabled and transaction boundaries have been detected properly.

    This is a change in behaviour. However, it is also a bug fix and a step to align behaviour. If, in previous versions, transaction stickiness, one of the above listed SQL hints and the quality of service filtering was combined it could happened that the SQL hints got ignored. In some case the SQL hints did work, in other cases they did not. The new behaviour is more consistent. SQL hints will always be ignore for the duration of a transaction, if transaction stickiness is enabled.

    Please note, transaction boundary detection continues to be based on API call monitoring. SQL commands controlling transactions are not monitored.

  • BC break and bug fix. Calls to mysqlnd_ms_set_qos() will fail when done in the middle of a transaction if transaction stickiness is enabled. Connection switches are not allowed for the duration of a transaction. Changing the quality of service likely results on a different set of servers qualifying for query execution, possibly making it necessary to switch connections. Thus, the call is not allowed in during an active transaction. The quality of server can, however, be changed in between transactions.

Feature changes

  • Introduced the node_group filter. The filter lets you organize servers (master and slaves) into groups. Queries can be directed to a certain group of servers by prefixing the query statement with a SQL hint/comment that contains the groups configured name. Grouping can be used for partitioning and sharding, and also to optimize for local caching. In the case of sharding, a group name can be thought of like a shard key. All queries for a given shard key will be executed on the configured shard. Note: both the client and server must support sharding for sharding to function with mysqlnd_ms.

  • Extended configuration file validation during PHP startup (RINIT). An E_WARNING level error will be thrown if the configuration file can not be read (permissions), is empty, or the file (JSON) could not be parsed. Warnings may appear in log files, which depending on how PHP is configured.

    Distributions that aim to provide a pre-configured setup, including a configuration file stub, are asked to put {} into the configuration file to prevent this warning about an invalid configuration file.

    Further configuration file validation is done when parsing sections upon opening a connection. Please, note that there may still be situations when an invalid plugin configuration file does not lead to proper error messages but a failure to connect.

  • As of PHP 5.5.0, improved support for transaction boundaries detection was added for mysqli. The mysqli extension has been modified to use the new C API calls of the mysqlnd library to begin, commit, and rollback a transaction or savepoint. If trx_stickiness is used to enable transaction aware load balancing, the mysqli_begin(), mysqli_commit() and mysqli_rollback() functions will now be monitered by the plugin, to go along with the mysqli_autocommit() function that was already supported. All SQL features to control transactions are also available through the improved mysqli transaction control related functions. This means that it is not required to issue SQL statements instead of using API calls. Applications using the appropriate API calls can be load balanced by PECL/mysqlnd_ms in a completely transaction-aware way.

    Please note, PDO_MySQL has not been updated yet to utilize the new mysqlnd API calls. Thus, transaction boundary detection with PDO_MySQL continues to be limited to the monitoring by passing in PDO::ATTR_AUTOCOMMIT to PDO::setAttribute().

  • Introduced trx_stickiness=on. This trx_stickiness option differs from trx_stickiness=master as it tries to execute a read-only transaction on a slave, if quality of service (consistency level) allows the use of a slave. Read-only transactions were introduced in MySQL 5.6, and they offer performance gains.

  • Query cache support is considered beta if used with the mysqli API. It should work fine with primary copy based clusters. For all other APIs, this feature continues to be called experimental.

  • The code examples in the mysqlnd_ms source were updated.

PECL/mysqlnd_ms 1.6 series
PECL/mysqlnd_ms 1.4 series
Change History


PECL/mysqlnd_ms 1.4 series

1.4.2-stable

  • Release date: 08/2012
  • Motto/theme: Tweaking based on user feedback

1.4.1-beta

  • Release date: 08/2012
  • Motto/theme: Tweaking based on user feedback

Bug fixes

  • Fixed build with PHP 5.5

1.4.0-alpha

  • Release date: 07/2012
  • Motto/theme: Tweaking based on user feedback

Feature changes

  • BC break: Renamed plugin configuration setting ini_file to config_file. In early versions the plugin configuration file used ini style. Back then the configuration setting was named accordingly. It has now been renamed to reflect the newer file format and to distinguish it from PHP's own ini file (configuration directives file).

  • Introduced new default charset setting server_charset to allow proper escaping before a connection is opened. This is most useful when using lazy connections, which are a default.

  • Introduced wait_for_gtid_timeout setting to throttle slave reads that need session consistency. If global transaction identifier are used and the service level is set to session consistency, the plugin tries to find up-to-date slaves. The slave status check is done by a SQL statement. If nothing else is set, the slave status is checked only one can the search for more up-to-date slaves continues immediately thereafter. Setting wait_for_gtid_timeout instructs the plugin to poll a slaves status for wait_for_gtid_timeout seconds if the first execution of the SQL statement has shown that the slave is not up-to-date yet. The poll will be done once per second. This way, the plugin will wait for slaves to catch up and throttle the client.

  • New failover strategy loop_before_master. By default the plugin does no failover. It is possible to enable automatic failover if a connection attempt fails. Upto version 1.3 only master strategy existed to failover to a master if a slave connection fails. loop_before_master is similar but tries all other slaves before attempting to connect to the master if a slave connection fails.

    The number of attempts can be limited using the max_retries option. Failed hosts can be remembered and skipped in load balancing for the rest of the web request. max_retries and remember_failed are considered experimental although decent stability is given. Syntax and semantics may change in the future without prior notice.

PECL/mysqlnd_ms 1.5 series
PECL/mysqlnd_ms 1.3 series
Change History


PECL/mysqlnd_ms 1.3 series

1.3.2-stable

  • Release date: 04/2012
  • Motto/theme: see 1.3.0-alpha

Bug fixes

  • Fixed problem with multi-master where although in a transaction the queries to the master weren't sticky and were spread all over the masters (RR). Still not sticky for Random. Random_once is not affected.

1.3.1-beta

  • Release date: 04/2012
  • Motto/theme: see 1.3.0-alpha

Bug fixes

  • Fixed problem with building together with QC.

1.3.0-alpha

  • Release date: 04/2012
  • Motto/theme: Query caching through quality-of-service concept

The 1.3 series aims to improve the performance of applications and the overall load of an asynchronous MySQL cluster, for example, a MySQL cluster using MySQL Replication. This is done by transparently replacing a slave access with a local cache access, if the application allows it by setting an appropriate quality of service flag. When using MySQL replication a slave can serve stale data. An application using MySQL replication must continue to work correctly with stale data. Given that the application is know to work correctly with stale data, the slave access can transparently be replace with a local cache access.

PECL/mysqlnd_qc serves as a cache backend. PECL/mysqlnd_qc supports use of various storage locations, among others main memory, APC and MEMCACHE.

Feature changes

  • Added cache option to quality-of-service (QoS) filter.

    • New configure option enable-mysqlnd-ms-cache-support
    • New constant MYSQLND_MS_HAVE_CACHE_SUPPORT.
    • New constant MYSQLND_MS_QOS_OPTION_CACHE to be used with mysqlnd_ms_set_qos().

  • Support for built-in global transaction identifier feature of MySQL 5.6.5-m8 or newer.

PECL/mysqlnd_ms 1.4 series
PECL/mysqlnd_ms 1.2 series
Change History


PECL/mysqlnd_ms 1.2 series

1.2.1-beta

  • Release date: 01/2012
  • Motto/theme: see 1.2.0-alpha

Minor test changes.

1.2.0-alpha

  • Release date: 11/2011
  • Motto/theme: Global Transaction ID injection and quality-of-service concept

In version 1.2 the focus continues to be on supporting MySQL database clusters with asynchronous replication. The plugin tries to make using the cluster introducing a quality-of-service filter which applications can use to define what service quality they need from the cluster. Service levels provided are eventual consistency with optional maximum age/slave slag, session consistency and strong consistency.

Additionally the plugin can do client-side global transaction id injection to make manual master failover easier.

Feature changes

  • Introduced quality-of-service (QoS) filter. Service levels provided by QoS filter:

    • eventual consistency, optional option slave lag
    • session consistency, optional option GTID
    • strong consistency

  • Added the mysqlnd_ms_set_qos() function to set the required connection quality at runtime. The new constants related to mysqlnd_ms_set_qos() are:

    • MYSQLND_MS_QOS_CONSISTENCY_STRONG
    • MYSQLND_MS_QOS_CONSISTENCY_SESSION
    • MYSQLND_MS_QOS_CONSISTENCY_EVENTUAL
    • MYSQLND_MS_QOS_OPTION_GTID
    • MYSQLND_MS_QOS_OPTION_AGE

  • Added client-side global transaction id injection (GTID).

  • New statistics related to GTID:

    • gtid_autocommit_injections_success
    • gtid_autocommit_injections_failure
    • gtid_commit_injections_success
    • gtid_commit_injections_failure
    • gtid_implicit_commit_injections_success
    • gtid_implicit_commit_injections_failure

  • Added mysqlnd_ms_get_last_gtid() to fetch the last global transaction id.

  • Enabled support for multi master without slaves.

PECL/mysqlnd_ms 1.3 series
PECL/mysqlnd_ms 1.1 series
Change History


PECL/mysqlnd_ms 1.1 series

1.1.0

  • Release date: 09/2011
  • Motto/theme: Cover replication basics with production quality

The 1.1 and 1.0 series expose a similar feature set. Internally, the 1.1 series has been refactored to plan for future feature additions. A new configuration file format has been introduced, and limitations have been lifted. And the code quality and quality assurance has been improved.

Feature changes

  • Added the (chainable) filter concept:

    • BC break: mysqlnd_ms_set_user_pick_server() has been removed. Thehttp://svn.php.net/viewvc/pecl/mysqlnd_ms/trunk/ user filter has been introduced to replace it. The filter offers similar functionality, but see below for an explanation of the differences.

  • New powerful JSON based configuration syntax.
  • Lazy connections improved: security relevant, and state changing commands are covered.
  • Support for (native) prepared statements.

  • New statistics: use_master_guess, use_slave_guess.

    • BC break: Semantics of statistics changed for use_slave, use_master. Future changes are likely. Please see, mysqlnd_ms_get_stats().

  • List of broadcasted messages extended by ssl_set.
  • Library calls now monitored to remember settings for lazy connections: change_user, select_db, set_charset, set_autocommit.
  • Introduced mysqlnd_ms.disable_rw_split. The configuration setting allows using the load balancing and lazy connection functionality independently of read write splitting.

Bug fixes

  • Fixed PECL #22724 - Server switching (mysqlnd_ms_query_is_select() case sensitive)
  • Fixed PECL #22784 - Using mysql_connect and mysql_select_db did not work
  • Fixed PECL #59982 - Unusable extension with --enable-mysqlnd-ms-table-filter. Use of the option is NOT supported. You must not used it. Added note to m4.
  • Fixed Bug #60119 - host="localhost" lost in mysqlnd_ms_get_last_used_connection()

The mysqlnd_ms_set_user_pick_server() function was removed, and replaced in favor of a new user filter. You can no longer set a callback function using mysqlnd_ms_set_user_pick_server() at runtime, but instead have to configure it in the plugins configuration file. The user filter will pass the same arguments to the callback as before. Therefore, you can continue to use the same procedural function as a callback.callback It is no longer possible to use static class methods, or class methods of an object instance, as a callback. Doing so will cause the function executing a statement handled by the plugin to emit an E_RECOVERABLE_ERROR level error, which might look like: "(mysqlnd_ms) Specified callback (picker) is not a valid callback." Note: this may halt your application.

PECL/mysqlnd_ms 1.2 series
PECL/mysqlnd_ms 1.0 series
Change History


PECL/mysqlnd_ms 1.0 series

1.0.1-alpha

  • Release date: 04/2011
  • Motto/theme: bug fix release

1.0.0-alpha

  • Release date: 04/2011
  • Motto/theme: Cover replication basics to test user feedback

The first release of practical use. It features basic automatic read-write splitting, SQL hints to overrule automatic redirection, load balancing of slave requests, lazy connections, and optional, automatic use of the master after the first write.

The public feature set is close to that of the 1.1 release.

1.0.0-pre-alpha

  • Release date: 09/2010
  • Motto/theme: Proof of concept

Initial check-in. Essentially a demo of the mysqlnd plugin API.

PECL/mysqlnd_ms 1.1 series
mysqlnd_qc
Change History


Mysqlnd query result cache plugin

  • Giriş
  • Quickstart and Examples
    • Architecture and Concepts
    • Setup
    • Caching queries
    • Setting the TTL
    • Pattern based caching
    • Slam defense
    • Finding cache candidates
    • Measuring cache efficiency
    • Beyond TTL: user-defined storage
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
  • Öntanımlı Sabitler
  • mysqlnd_qc İşlevleri
    • mysqlnd_qc_clear_cache — Flush all cache contents
    • mysqlnd_qc_get_available_handlers — Returns a list of available storage handler
    • mysqlnd_qc_get_cache_info — Returns information on the current handler, the number of cache entries and cache entries, if available
    • mysqlnd_qc_get_core_stats — Statistics collected by the core of the query cache
    • mysqlnd_qc_get_normalized_query_trace_log — Returns a normalized query trace log for each query inspected by the query cache
    • mysqlnd_qc_get_query_trace_log — Returns a backtrace for each query inspected by the query cache
    • mysqlnd_qc_set_cache_condition — Set conditions for automatic caching
    • mysqlnd_qc_set_is_select — Installs a callback which decides whether a statement is cached
    • mysqlnd_qc_set_storage_handler — Change current storage handler
    • mysqlnd_qc_set_user_handlers — Sets the callback functions for a user-defined procedural storage handler
  • Change History
    • PECL/mysqlnd_qc 1.2 series
    • PECL/mysqlnd_qc 1.1 series
    • PECL/mysqlnd_qc 1.0 series
PECL/mysqlnd_ms 1.0 series
Giriş
MySQL


Giriş

The mysqlnd query result cache plugin adds easy to use client-side query caching to all PHP MySQL extensions using mysqlnd.

As of version PHP 5.3.3 the MySQL native driver for PHP ( mysqlnd) features an internal plugin C API. C plugins, such as the query cache plugin, can extend the functionality of mysqlnd.

Mysqlnd plugins such as the query cache plugin operate transparent from a user perspective. The cache plugin supports all PHP applications and all PHP MySQL extensions ( mysqli, mysql, PDO_MYSQL). It does not change existing APIs.

No significant application changes are required to cache a query. The cache has two operation modes. It will either cache all queries (not recommended) or only those queries marked with a certain SQL hint (recommended).

Key Features

  • Transparent and therefore easy to use

    • supports all PHP MySQL extensions

    • no API changes

    • very little application changes required

  • Flexible invalidation strategy

    • Time-to-Live (TTL)

    • user-defined

  • Storage with different scope and life-span

    • Default (Hash, process memory)

    • APC

    • MEMCACHE

    • sqlite

    • user-defined

  • Built-in slam defense to prevent cache stampeding.

Limitations

The current 1.0.1 release of PECL mysqlnd_qc does not support PHP 5.4. Version 1.1.0-alpha lifts this limitation.

Prepared statements and unbuffered queries are fully supported. Thus, the plugin is capable of caching all statements issued with mysqli or PDO_MySQL, which are the only two PHP MySQL APIs to offer prepared statement support.

On the name

The shortcut mysqlnd_qc stands for mysqlnd query cache plugin. The name was chosen for a quick-and-dirty proof-of-concept. In the beginning the developers did not expect to continue using the code base. Sometimes PECL/mysqlnd_qc has also been called client-side query result set cache.

mysqlnd_qc
Quickstart and Examples
mysqlnd_qc


Quickstart and Examples

İçindekiler

  • Architecture and Concepts
  • Setup
  • Caching queries
  • Setting the TTL
  • Pattern based caching
  • Slam defense
  • Finding cache candidates
  • Measuring cache efficiency
  • Beyond TTL: user-defined storage

The mysqlnd query cache plugin is easy to use. This quickstart will demo typical use-cases, and provide practical advice on getting started.

It is strongly recommended to read the reference sections in addition to the quickstart. It is safe to begin with the quickstart. However, before using the plugin in mission critical environments we urge you to read additionally the background information from the reference sections.

Most of the examples use the mysqli extension because it is the most feature complete PHP MySQL extension. However, the plugin can be used with any PHP MySQL extension that is using the mysqlnd library.

Giriş
Architecture and Concepts
mysqlnd_qc


Architecture and Concepts

The query cache plugin is implemented as a PHP extension. It is written in C and operates under the hood of PHP. During the startup of the PHP interpreter, it gets registered as a mysqlnd plugin to replace selected mysqlnd C methods. Hereby, it can change the behaviour of any PHP MySQL extension (mysqli, PDO_MYSQL, mysql) compiled to use the mysqlnd library without changing the extensions API. This makes the plugin compatible with each and every PHP MySQL application. Because existing APIs are not changed, it is almost transparent to use. Please, see the mysqlnd plugin API description for a discussion of the advantages of the plugin architecture and a comparison with proxy based solutions.

Transparent to use

At PHP run time PECL/mysqlnd_qc can proxy queries send from PHP (mysqlnd) to the MySQL server. It then inspects the statement string to find whether it shall cache its results. If so, result set is cached using a storage handler and further executions of the statement are served from the cache for a user-defined period. The Time to Live (TTL) of the cache entry can either be set globally or on a per statement basis.

A statement is either cached if the plugin is instructed to cache all statements globally using a or, if the query string starts with the SQL hint (/*qc=on*/). The plugin is capable of caching any query issued by calling appropriate API calls of any of the existing PHP MySQL extensions.

Flexible storage: various storage handler

Various storage handler are supported to offer different scopes for cache entries. Different scopes allow for different degrees in sharing cache entries among clients.

  • default (built-in): process memory, scope: process, one or more web requests depending on PHP deployment model used

  • APC: shared memory, scope: single server, multiple web requests

  • SQLite: memory or file, scope: single server, multiple web requests

  • MEMCACHE: main memory, scope: single or multiple server, multiple web requests

  • user (built-in): user-defined - any, scope: user-defined - any

Support for the APC, SQLite and MEMCACHE storage handler has to be enabled at compile time. The default and user handler are built-in. It is possible to switch between compiled-in storage handlers on a per query basis at run time. However, it is recommended to pick one storage handler and use it for all cache entries.

Built-in slam defense to avoid overloading

To avoid overload situations the cache plugin has a built-in slam defense mechanism. If a popular cache entries expires many clients using the cache entries will try to refresh the cache entry. For the duration of the refresh many clients may access the database server concurrently. In the worst case, the database server becomes overloaded and it takes more and more time to refresh the cache entry, which in turn lets more and more clients try to refresh the cache entry. To prevent this from happening the plugin has a slam defense mechanism. If slam defense is enabled and the plugin detects an expired cache entry it extends the life time of the cache entry before it refreshes the cache entry. This way other concurrent accesses to the expired cache entry are still served from the cache for a certain time. The other concurrent accesses to not trigger a concurrent refresh. Ideally, the cache entry gets refreshed by the client which extended the cache entries lifespan before other clients try to refresh the cache and potentially cause an overload situation.

Unique approach to caching

PECL/mysqlnd_qc has a unique approach to caching result sets that is superior to application based cache solutions. Application based solutions first fetch a result set into PHP variables. Then, the PHP variables are serialized for storage in a persistent cache, and then unserialized when fetching. The mysqlnd query cache stores the raw wire protocol data sent from MySQL to PHP in its cache and replays it, if still valid, on a cache hit. This way, it saves an extra serialization step for a cache put that all application based solutions have to do. It can store the raw wire protocol data in the cache without having to serialize into a PHP variable first and deserializing the PHP variable for storing in the cache again.

Quickstart and Examples
Setup
Quickstart and Examples


Setup

The plugin is implemented as a PHP extension. See also the installation instructions to install the » PECL/mysqlnd_qc extension.

Compile or configure the PHP MySQL extension (mysqli, PDO_MYSQL, mysql) that you plan to use with support for the mysqlnd library. PECL/mysqlnd_qc is a plugin for the mysqlnd library. To use the plugin with any of the existing PHP MySQL extensions (APIs), the extension has to use the mysqlnd library.

Then, load the extension into PHP and activate the plugin in the PHP configuration file using the PHP configuration directive named mysqlnd_qc.enable_qc.

Örnek 1 Enabling the plugin (php.ini)

mysqlnd_qc.enable_qc=1

Architecture and Concepts
Caching queries
Quickstart and Examples


Caching queries

There are four ways to trigger caching of a query.

  • Use of SQL hints on a per query basis
  • User supplied callbacks to decide on a per query basis, for example, using mysqlnd_qc_is_select()
  • mysqlnd_set_cache_condition() for rule based automatic per query decisions
  • mysqlnd_qc.cache_by_default = 1 to cache all queries blindly

Use of SQL hints and mysqlnd_qc.cache_by_default = 1 are explained below. Please, refer to the function reference on mysqlnd_qc_is_select() for a description of using a callback and, mysqlnd_qc_set_cache_condition() on how to set rules for automatic caching.

A SQL hint is a SQL standards compliant comment. As a SQL comment it is ignored by the database. A statement is considered eligible for caching if it either begins with the SQL hint enabling caching or it is a SELECT statement.

An individual query which shall be cached must begin with the SQL hint /*qc=on*/. It is recommended to use the PHP constant MYSQLND_QC_ENABLE_SWITCH instead of using the string value.

  • not eligible for caching and not cached: INSERT INTO test(id) VALUES (1)

  • not eligible for caching and not cached: SHOW ENGINES

  • eligible for caching but uncached: SELECT id FROM test

  • eligible for caching and cached: /*qc=on*/SELECT id FROM test

The examples SELECT statement string is prefixed with the MYSQLND_QC_ENABLE_SWITCH SQL hint to enable caching of the statement. The SQL hint must be given at the very beginning of the statement string to enable caching.

Örnek 1 Using the MYSQLND_QC_ENABLE_SWITCH SQL hint

mysqlnd_qc.enable_qc=1
<?php
/* Connect, create and populate test table */
$mysqli = new mysqli("host", "user", "password", "schema", "port", "socket");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1), (2)");

/* Will be cached because of the SQL hint */
$start = microtime(true);
$res   = $mysqli->query("/*" . MYSQLND_QC_ENABLE_SWITCH . "*/" . "SELECT id FROM test WHERE id = 1");

var_dump($res->fetch_assoc());
$res->free();

printf("Total time uncached query: %.6fs\n", microtime(true) - $start);

/* Cache hit */
$start = microtime(true);
$res   = $mysqli->query("/*" . MYSQLND_QC_ENABLE_SWITCH . "*/" . "SELECT id FROM test WHERE id = 1");

var_dump($res->fetch_assoc());
$res->free();

printf("Total time cached query: %.6fs\n", microtime(true) - $start);
?>

The above examples will output something similar to:

array(1) {
  ["id"]=>
  string(1) "1"
}
Total time uncached query: 0.000740s
array(1) {
  ["id"]=>
  string(1) "1"
}
Total time cached query: 0.000098s

If nothing else is configured, as it is the case in the quickstart example, the plugin will use the built-in default storage handler. The default storage handler uses process memory to hold a cache entry. Depending on the PHP deployment model, a PHP process may serve one or more web requests. Please, consult the web server manual for details. Details make no difference for the examples given in the quickstart.

The query cache plugin will cache all queries regardless if the query string begins with the SQL hint which enables caching or not, if the PHP configuration directive mysqlnd_qc.cache_by_default is set to 1. The setting mysqlnd_qc.cache_by_default is evaluated by the core of the query cache plugins. Neither the built-in nor user-defined storage handler can overrule the setting.

The SQL hint /*qc=off*/ can be used to disable caching of individual queries if mysqlnd_qc.cache_by_default = 1 It is recommended to use the PHP constant MYSQLND_QC_DISABLE_SWITCH instead of using the string value.

Örnek 2 Using the MYSQLND_QC_DISABLE_SWITCH SQL hint

mysqlnd_qc.enable_qc=1
mysqlnd_qc.cache_by_default=1
<?php
/* Connect, create and populate test table */
$mysqli = new mysqli("host", "user", "password", "schema", "port", "socket");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1), (2)");

/* Will be cached although no SQL hint is present because of mysqlnd_qc.cache_by_default = 1*/
$res = $mysqli->query("SELECT id FROM test WHERE id = 1");
var_dump($res->fetch_assoc());
$res->free();

$mysqli->query("DELETE FROM test WHERE id = 1");

/* Cache hit - no automatic invalidation and still valid! */
$res = $mysqli->query("SELECT id FROM test WHERE id = 1");
var_dump($res->fetch_assoc());
$res->free();

/* Cache miss - query must not be cached because of the SQL hint */
$res = $mysqli->query("/*" . MYSQLND_QC_DISABLE_SWITCH . "*/SELECT id FROM test WHERE id = 1");
var_dump($res->fetch_assoc());
$res->free();
?>

Yukarıdaki örneklerin çıktısı:

array(1) {
  ["id"]=>
  string(1) "1"
}
array(1) {
  ["id"]=>
  string(1) "1"
}
NULL

PECL/mysqlnd_qc forbids caching of statements for which at least one column from the statements result set shows no table name in its meta data by default. This is usually the case for columns originating from SQL functions such as NOW() or LAST_INSERT_ID(). The policy aims to prevent pitfalls if caching by default is used.

Örnek 3 Example showing which type of statements are not cached

mysqlnd_qc.enable_qc=1
mysqlnd_qc.cache_by_default=1
<?php
/* Connect, create and populate test table */
$mysqli = new mysqli("host", "user", "password", "schema", "port", "socket");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1)");

for ($i = 0; $i < 3; $i++) {

    $start = microtime(true);

    /* Note: statement will not be cached because of NOW() use */
    $res = $mysqli->query("SELECT id, NOW() AS _time FROM test");
    $row = $res->fetch_assoc();

    /* dump results */
    var_dump($row);

    printf("Total time: %.6fs\n", microtime(true) - $start);

    /* pause one second */
    sleep(1);
}
?>

The above examples will output something similar to:

array(2) {
  ["id"]=>
  string(1) "1"
  ["_time"]=>
  string(19) "2012-01-11 15:43:10"
}
Total time: 0.000540s
array(2) {
  ["id"]=>
  string(1) "1"
  ["_time"]=>
  string(19) "2012-01-11 15:43:11"
}
Total time: 0.000555s
array(2) {
  ["id"]=>
  string(1) "1"
  ["_time"]=>
  string(19) "2012-01-11 15:43:12"
}
Total time: 0.000549s

It is possible to enable caching for all statements including those which has columns in their result set for which MySQL reports no table, such as the statement from the example. Set mysqlnd_qc.cache_no_table = 1 to enable caching of such statements. Please, note the difference in the measured times for the above and below examples.

Örnek 4 Enabling caching for all statements using the mysqlnd_qc.cache_no_table ini setting

mysqlnd_qc.enable_qc=1
mysqlnd_qc.cache_by_default=1
mysqlnd_qc.cache_no_table=1
<?php
/* Connect, create and populate test table */
$mysqli = new mysqli("host", "user", "password", "schema", "port", "socket");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1)");

for ($i = 0; $i < 3; $i++) {

    $start = microtime(true);

    /* Note: statement will not be cached because of NOW() use */
    $res = $mysqli->query("SELECT id, NOW() AS _time FROM test");
    $row = $res->fetch_assoc();

    /* dump results */
    var_dump($row);

    printf("Total time: %.6fs\n", microtime(true) - $start);

    /* pause one second */
    sleep(1);
}
?>

The above examples will output something similar to:

array(2) {
  ["id"]=>
  string(1) "1"
  ["_time"]=>
  string(19) "2012-01-11 15:47:45"
}
Total time: 0.000546s
array(2) {
  ["id"]=>
  string(1) "1"
  ["_time"]=>
  string(19) "2012-01-11 15:47:45"
}
Total time: 0.000187s
array(2) {
  ["id"]=>
  string(1) "1"
  ["_time"]=>
  string(19) "2012-01-11 15:47:45"
}
Total time: 0.000167s

Bilginize:

Although mysqlnd_qc.cache_no_table = 1 has been created for use with mysqlnd_qc.cache_by_default = 1 it is bound it. The plugin will evaluate the mysqlnd_qc.cache_no_table whenever a query is to be cached, no matter whether caching has been enabled using a SQL hint or any other measure.

Setup
Setting the TTL
Quickstart and Examples


Setting the TTL

The default invalidation strategy of the query cache plugin is Time to Live (TTL). The built-in storage handlers will use the default TTL defined by the PHP configuration value mysqlnd_qc.ttl unless the query string contains a hint for setting a different TTL. The TTL is specified in seconds. By default cache entries expire after 30 seconds

The example sets mysqlnd_qc.ttl=3 to cache statements for three seconds by default. Every second it updates a database table record to hold the current time and executes a SELECT statement to fetch the record from the database. The SELECT statement is cached for three seconds because it is prefixed with the SQL hint enabling caching. The output verifies that the query results are taken from the cache for the duration of three seconds before they are refreshed.

Örnek 1 Setting the TTL with the mysqlnd_qc.ttl ini setting

mysqlnd_qc.enable_qc=1
mysqlnd_qc.ttl=3
<?php
/* Connect, create and populate test table */
$mysqli = new mysqli("host", "user", "password", "schema", "port", "socket");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id VARCHAR(255))");

for ($i = 0; $i < 7; $i++) {

    /* update DB row  */
    if (!$mysqli->query("DELETE FROM test") ||
        !$mysqli->query("INSERT INTO test(id) VALUES (NOW())"))
      /* Of course, a real-life script should do better error handling */
      die(sprintf("[%d] %s\n", $mysqli->errno, $mysqli->error));

    /* select latest row but cache results */
    $query  = "/*" . MYSQLND_QC_ENABLE_SWITCH . "*/";
    $query .= "SELECT id AS _time FROM test";
    if (!($res = $mysqli->query($query)) ||
        !($row = $res->fetch_assoc()))
    {
      printf("[%d] %s\n", $mysqli->errno, $mysqli->error);
    }
    $res->free();
    printf("Wall time %s - DB row time %s\n", date("H:i:s"), $row['_time']);

    /* pause one second */
    sleep(1);
}
?>

The above examples will output something similar to:

Wall time 14:55:59 - DB row time 2012-01-11 14:55:59
Wall time 14:56:00 - DB row time 2012-01-11 14:55:59
Wall time 14:56:01 - DB row time 2012-01-11 14:55:59
Wall time 14:56:02 - DB row time 2012-01-11 14:56:02
Wall time 14:56:03 - DB row time 2012-01-11 14:56:02
Wall time 14:56:04 - DB row time 2012-01-11 14:56:02
Wall time 14:56:05 - DB row time 2012-01-11 14:56:05

As can be seen from the example, any TTL based cache can serve stale data. Cache entries are not automatically invalidated, if underlying data changes. Applications using the default TTL invalidation strategy must be able to work correctly with stale data.

A user-defined cache storage handler can implement any invalidation strategy to work around this limitation.

The default TTL can be overruled using the SQL hint /*qc_tt=seconds*/. The SQL hint must be appear immediately after the SQL hint which enables caching. It is recommended to use the PHP constant MYSQLND_QC_TTL_SWITCH instead of using the string value.

Örnek 2 Setting TTL with SQL hints

<?php
$start = microtime(true);

/* Connect, create and populate test table */
$mysqli = new mysqli("host", "user", "password", "schema", "port", "socket");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1), (2)");

printf("Default TTL\t: %d seconds\n", ini_get("mysqlnd_qc.ttl"));

/* Will be cached for 2 seconds */
$sql = sprintf("/*%s*//*%s%d*/SELECT id FROM test WHERE id = 1", MYSQLND_QC_ENABLE_SWITCH, MYSQLND_QC_TTL_SWITCH, 2);
$res = $mysqli->query($sql);

var_dump($res->fetch_assoc());
$res->free();

$mysqli->query("DELETE FROM test WHERE id = 1");
sleep(1);

/* Cache hit - no automatic invalidation and still valid! */
$res = $mysqli->query($sql);
var_dump($res->fetch_assoc());
$res->free();

sleep(2);

/* Cache miss - cache entry has expired */
$res = $mysqli->query($sql);
var_dump($res->fetch_assoc());
$res->free();

printf("Script runtime\t: %d seconds\n", microtime(true) - $start);
?>

The above examples will output something similar to:

Default TTL     : 30 seconds
array(1) {
  ["id"]=>
  string(1) "1"
}
array(1) {
  ["id"]=>
  string(1) "1"
}
NULL
Script runtime  : 3 seconds

Caching queries
Pattern based caching
Quickstart and Examples


Pattern based caching

An application has three options for telling PECL/mysqlnd_qc whether a particular statement shall be used. The most basic approach is to cache all statements by setting mysqlnd_qc.cache_by_default = 1. This approach is often of little practical value. But it enables users to make a quick estimation about the maximum performance gains from caching. An application designed to use a cache may be able to prefix selected statements with the appropriate SQL hints. However, altering an applications source code may not always be possible or desired, for example, to avoid problems with software updates. Therefore, PECL/mysqlnd_qc allows setting a callback which decides if a query is to be cached.

The callback is installed with the mysqlnd_qc_set_is_select() function. The callback is given the statement string of every statement inspected by the plugin. Then, the callback can decide whether to cache the function. The callback is supposed to return FALSE if the statement shall not be cached. A return value of TRUE makes the plugin try to add the statement into the cache. The cache entry will be given the default TTL ( mysqlnd_qc.ttl). If the callback returns a numerical value it is used as the TTL instead of the global default.

Örnek 1 Setting a callback with mysqlnd_qc_set_is_select()

mysqlnd_qc.enable_qc=1
mysqlnd_qc.collect_statistics=1
<?php
/* callback which decides if query is cached */
function is_select($query) {
    static $patterns = array(
      /* true - use default from mysqlnd_qc.ttl */
      "@SELECT\s+.*\s+FROM\s+test@ismU" => true,
      /* 3 - use TTL = 3 seconds */
      "@SELECT\s+.*\s+FROM\s+news@ismU" => 3
    );

    /* check if query does match pattern */
    foreach ($patterns as $pattern => $ttl) {
        if (preg_match($pattern, $query)) {
            printf("is_select(%45s): cache\n", $query);
            return $ttl;
        }
    }
    printf("is_select(%45s): do not cache\n", $query);
    return false;
}
/* install callback */
mysqlnd_qc_set_is_select("is_select");

/* Connect, create and populate test table */
$mysqli = new mysqli("host", "user", "password", "schema", "port", "socket");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1), (2), (3)");

/* cache put */
$mysqli->query("SELECT id FROM test WHERE id = 1");
/* cache hit */
$mysqli->query("SELECT id FROM test WHERE id = 1");
/* cache put */
$mysqli->query("SELECT * FROM test");

$stats = mysqlnd_qc_get_core_stats();
printf("Cache put: %d\n", $stats['cache_put']);
printf("Cache hit: %d\n", $stats['cache_hit']);
?>

The above examples will output something similar to:

is_select(                    DROP TABLE IF EXISTS test): do not cache
is_select(                    CREATE TABLE test(id INT)): do not cache
is_select(    INSERT INTO test(id) VALUES (1), (2), (3)): do not cache
is_select(             SELECT id FROM test WHERE id = 1): cache
is_select(             SELECT id FROM test WHERE id = 1): cache
is_select(                           SELECT * FROM test): cache
Cache put: 2
Cache hit: 1

The examples callback tests if a statement string matches a pattern. If this is the case, it either returns TRUE to cache the statement using the global default TTL or an alternative TTL.

To minimize application changes the callback can put into and registered in an auto prepend file.

Setting the TTL
Slam defense
Quickstart and Examples


Slam defense

A badly designed cache can do more harm than good. In the worst case a cache can increase database server load instead of minimizing it. An overload situation can occur if a highly shared cache entry expires (cache stampeding).

Cache entries are shared and reused to a different degree depending on the storage used. The default storage handler stores cache entries in process memory. Thus, a cache entry can be reused for the life-span of a process. Other PHP processes cannot access it. If Memcache is used, a cache entry can be shared among multiple PHP processes and even among multiple machines, depending on the set up being used.

If a highly shared cache entry stored, for example, in Memcache expires, many clients gets a cache miss. Many client requests can no longer be served from the cache but try to run the underlying query on the database server. Until the cache entry is refreshed, more and more clients contact the database server. In the worst case, a total lost of service is the result.

The overload can be avoided using a storage handler which limits the reuse of cache entries to few clients. Then, at the average, its likely that only a limited number of clients will try to refresh a cache entry concurrently.

Additionally, the built-in slam defense mechanism can and should be used. If slam defense is activated an expired cache entry is given an extended life time. The first client getting a cache miss for the expired cache entry tries to refresh the cache entry within the extended life time. All other clients requesting the cache entry are temporarily served from the cache although the original TTL of the cache entry has expired. The other clients will not experience a cache miss before the extended life time is over.

Örnek 1 Enabling the slam defense mechanism

mysqlnd_qc.slam_defense=1
mysqlnd_qc.slam_defense_ttl=1

The slam defense mechanism is enabled with the PHP configuration directive mysqlnd_qc.slam_defense. The extended life time of a cache entry is set with mysqlnd_qc.slam_defense_ttl.

The function mysqlnd_qc_get_core_stats() returns an array of statistics. The statistics slam_stale_refresh and slam_stale_hit are incremented if slam defense takes place.

It is not possible to give a one-fits-all recommendation on the slam defense configuration. Users are advised to monitor and test their setup and derive settings accordingly.

Pattern based caching
Finding cache candidates
Quickstart and Examples


Finding cache candidates

A statement should be considered for caching if it is executed often and has a long run time. Cache candidates are found by creating a list of statements sorted by the product of the number of executions multiplied by the statements run time. The function mysqlnd_qc_get_query_trace_log() returns a query log which help with the task.

Collecting a query trace is a slow operation. Thus, it is disabled by default. The PHP configuration directive mysqlnd_qc.collect_query_trace is used to enable it. The functions trace contains one entry for every query issued before the function is called.

Örnek 1 Collecting a query trace

mysqlnd_qc.enable_qc=1
mysqlnd_qc.collect_query_trace=1
<?php
/* connect to MySQL */
$mysqli = new mysqli("host", "user", "password", "schema", "port", "socket");

/* dummy queries to fill the query trace */
for ($i = 0; $i < 2; $i++) {
    $res = $mysqli->query("SELECT 1 AS _one FROM DUAL");
    $res->free();
}

/* dump trace */
var_dump(mysqlnd_qc_get_query_trace_log());
?>

Yukarıdaki örneklerin çıktısı:

array(2) {
  [0]=>
  array(8) {
    ["query"]=>
    string(26) "SELECT 1 AS _one FROM DUAL"
    ["origin"]=>
    string(102) "#0 qc.php(7): mysqli->query('SELECT 1 AS _on...')
#1 {main}"
    ["run_time"]=>
    int(0)
    ["store_time"]=>
    int(25)
    ["eligible_for_caching"]=>
    bool(false)
    ["no_table"]=>
    bool(false)
    ["was_added"]=>
    bool(false)
    ["was_already_in_cache"]=>
    bool(false)
  }
  [1]=>
  array(8) {
    ["query"]=>
    string(26) "SELECT 1 AS _one FROM DUAL"
    ["origin"]=>
    string(102) "#0 qc.php(7): mysqli->query('SELECT 1 AS _on...')
#1 {main}"
    ["run_time"]=>
    int(0)
    ["store_time"]=>
    int(8)
    ["eligible_for_caching"]=>
    bool(false)
    ["no_table"]=>
    bool(false)
    ["was_added"]=>
    bool(false)
    ["was_already_in_cache"]=>
    bool(false)
  }
}

Assorted information is given in the trace. Among them timings and the origin of the query call. The origin property holds a code backtrace to identify the source of the query. The depth of the backtrace can be limited with the PHP configuration directive mysqlnd_qc.query_trace_bt_depth. The default depth is 3.

Örnek 2 Setting the backtrace depth with the mysqlnd_qc.query_trace_bt_depth ini setting

mysqlnd_qc.enable_qc=1
mysqlnd_qc.collect_query_trace=1
<?php
/* connect to MySQL */
$mysqli = new mysqli("host", "user", "password", "schema", "port", "socket");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1), (2), (3)");

/* dummy queries to fill the query trace */
for ($i = 0; $i < 3; $i++) {
    $res = $mysqli->query("SELECT id FROM test WHERE id = " . $mysqli->real_escape_string($i));
    $res->free();
}

$trace = mysqlnd_qc_get_query_trace_log();
$summary = array();
foreach ($trace as $entry) {
    if (!isset($summary[$entry['query']])) {
        $summary[$entry['query']] = array(
            "executions" => 1,
            "time"       => $entry['run_time'] + $entry['store_time'],
        );
    } else {
        $summary[$entry['query']]['executions']++;
        $summary[$entry['query']]['time'] += $entry['run_time'] + $entry['store_time'];
    }
}

foreach ($summary as $query => $details) {
    printf("%45s: %5dms (%dx)\n",
    $query, $details['time'], $details['executions']);
}
?>

The above examples will output something similar to:

                    DROP TABLE IF EXISTS test:     0ms (1x)
                    CREATE TABLE test(id INT):     0ms (1x)
    INSERT INTO test(id) VALUES (1), (2), (3):     0ms (1x)
             SELECT id FROM test WHERE id = 0:    25ms (1x)
             SELECT id FROM test WHERE id = 1:    10ms (1x)
             SELECT id FROM test WHERE id = 2:     9ms (1x)

Slam defense
Measuring cache efficiency
Quickstart and Examples


Measuring cache efficiency

PECL/mysqlnd_qc offers three ways to measure the cache efficiency. The function mysqlnd_qc_get_normalized_query_trace_log() returns statistics aggregated by the normalized query string, mysqlnd_qc_get_cache_info() gives storage handler specific information which includes a list of all cached items, depending on the storage handler. Additionally, the core of PECL/mysqlnd_qc collects high-level summary statistics aggregated per PHP process. The high-level statistics are returned by mysqlnd_qc_get_core_stats().

The functions mysqlnd_qc_get_normalized_query_trace_log() and mysqlnd_qc_get_core_stats() will not collect data unless data collection has been enabled through their corresponding PHP configuration directives. Data collection is disabled by default for performance considerations. It is configurable with the mysqlnd_qc.time_statistics option, which determines if timing information should be collected. Collection of time statistics is enabled by default but only performed if data collection as such has been enabled. Recording time statistics causes extra system calls. In most cases, the benefit of the monitoring outweighs any potential performance penalty of the additional system calls.

Örnek 1 Collecting statistics data with the mysqlnd_qc.time_statistics ini setting

mysqlnd_qc.enable_qc=1
mysqlnd_qc.collect_statistics=1
<?php
/* connect to MySQL */
$mysqli = new mysqli("host", "user", "password", "schema", "port", "socket");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1), (2), (3)");

/* dummy queries */
for ($i = 1; $i <= 4; $i++) {
    $query = sprintf("/*%s*/SELECT id FROM test WHERE id = %d", MYSQLND_QC_ENABLE_SWITCH, $i % 2);
    $res   = $mysqli->query($query);

    $res->free();
}

var_dump(mysqlnd_qc_get_core_stats());
?>

The above examples will output something similar to:

array(26) {
  ["cache_hit"]=>
  string(1) "2"
  ["cache_miss"]=>
  string(1) "2"
  ["cache_put"]=>
  string(1) "2"
  ["query_should_cache"]=>
  string(1) "4"
  ["query_should_not_cache"]=>
  string(1) "3"
  ["query_not_cached"]=>
  string(1) "3"
  ["query_could_cache"]=>
  string(1) "4"
  ["query_found_in_cache"]=>
  string(1) "2"
  ["query_uncached_other"]=>
  string(1) "0"
  ["query_uncached_no_table"]=>
  string(1) "0"
  ["query_uncached_no_result"]=>
  string(1) "0"
  ["query_uncached_use_result"]=>
  string(1) "0"
  ["query_aggr_run_time_cache_hit"]=>
  string(2) "28"
  ["query_aggr_run_time_cache_put"]=>
  string(3) "900"
  ["query_aggr_run_time_total"]=>
  string(3) "928"
  ["query_aggr_store_time_cache_hit"]=>
  string(2) "14"
  ["query_aggr_store_time_cache_put"]=>
  string(2) "40"
  ["query_aggr_store_time_total"]=>
  string(2) "54"
  ["receive_bytes_recorded"]=>
  string(3) "136"
  ["receive_bytes_replayed"]=>
  string(3) "136"
  ["send_bytes_recorded"]=>
  string(2) "84"
  ["send_bytes_replayed"]=>
  string(2) "84"
  ["slam_stale_refresh"]=>
  string(1) "0"
  ["slam_stale_hit"]=>
  string(1) "0"
  ["request_counter"]=>
  int(1)
  ["process_hash"]=>
  int(1929695233)
}

For a quick overview, call mysqlnd_qc_get_core_stats(). It delivers cache usage, cache timing and traffic related statistics. Values are aggregated on a per process basis for all queries issued by any PHP MySQL API call.

Some storage handler, such as the default handler, can report cache entries, statistics related to the entries and meta data for the underlying query through the mysqlnd_qc_get_cache_info() function. Please note, that the information returned depends on the storage handler. Values are aggregated on a per process basis.

Örnek 2 Example mysqlnd_qc_get_cache_info() usage

mysqlnd_qc.enable_qc=1
<?php
/* connect to MySQL */
$mysqli = new mysqli("host", "user", "password", "schema", "port", "socket");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1), (2), (3)");

/* dummy queries to fill the query trace */
for ($i = 1; $i <= 4; $i++) {
    $query = sprintf("/*%s*/SELECT id FROM test WHERE id = %d", MYSQLND_QC_ENABLE_SWITCH, $i % 2);
    $res   = $mysqli->query($query);

    $res->free();
}

var_dump(mysqlnd_qc_get_cache_info());
?>

The above examples will output something similar to:

array(4) {
  ["num_entries"]=>
  int(2)
  ["handler"]=>
  string(7) "default"
  ["handler_version"]=>
  string(5) "1.0.0"
  ["data"]=>
  array(2) {
    ["Localhost via UNIX socket
3306
root
test|/*qc=on*/SELECT id FROM test WHERE id = 1"]=>
    array(2) {
      ["statistics"]=>
      array(11) {
        ["rows"]=>
        int(1)
        ["stored_size"]=>
        int(71)
        ["cache_hits"]=>
        int(1)
        ["run_time"]=>
        int(391)
        ["store_time"]=>
        int(27)
        ["min_run_time"]=>
        int(16)
        ["max_run_time"]=>
        int(16)
        ["min_store_time"]=>
        int(8)
        ["max_store_time"]=>
        int(8)
        ["avg_run_time"]=>
        int(8)
        ["avg_store_time"]=>
        int(4)
      }
      ["metadata"]=>
      array(1) {
        [0]=>
        array(8) {
          ["name"]=>
          string(2) "id"
          ["orig_name"]=>
          string(2) "id"
          ["table"]=>
          string(4) "test"
          ["orig_table"]=>
          string(4) "test"
          ["db"]=>
          string(4) "test"
          ["max_length"]=>
          int(1)
          ["length"]=>
          int(11)
          ["type"]=>
          int(3)
        }
      }
    }
    ["Localhost via UNIX socket
3306
root
test|/*qc=on*/SELECT id FROM test WHERE id = 0"]=>
    array(2) {
      ["statistics"]=>
      array(11) {
        ["rows"]=>
        int(0)
        ["stored_size"]=>
        int(65)
        ["cache_hits"]=>
        int(1)
        ["run_time"]=>
        int(299)
        ["store_time"]=>
        int(13)
        ["min_run_time"]=>
        int(11)
        ["max_run_time"]=>
        int(11)
        ["min_store_time"]=>
        int(6)
        ["max_store_time"]=>
        int(6)
        ["avg_run_time"]=>
        int(5)
        ["avg_store_time"]=>
        int(3)
      }
      ["metadata"]=>
      array(1) {
        [0]=>
        array(8) {
          ["name"]=>
          string(2) "id"
          ["orig_name"]=>
          string(2) "id"
          ["table"]=>
          string(4) "test"
          ["orig_table"]=>
          string(4) "test"
          ["db"]=>
          string(4) "test"
          ["max_length"]=>
          int(0)
          ["length"]=>
          int(11)
          ["type"]=>
          int(3)
        }
      }
    }
  }
}

It is possible to further break down the granularity of statistics to the level of the normalized statement string. The normalized statement string is the statements string with all parameters replaced with question marks. For example, the two statements SELECT id FROM test WHERE id = 0 and SELECT id FROM test WHERE id = 1 are normalized into SELECT id FROM test WHERE id = ?. Their both statistics are aggregated into one entry for SELECT id FROM test WHERE id = ?.

Örnek 3 Example mysqlnd_qc_get_normalized_query_trace_log() usage

mysqlnd_qc.enable_qc=1
mysqlnd_qc.collect_normalized_query_trace=1
<?php
/* connect to MySQL */
$mysqli = new mysqli("host", "user", "password", "schema", "port", "socket");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1), (2), (3)");

/* dummy queries to fill the query trace */
for ($i = 1; $i <= 4; $i++) {
    $query = sprintf("/*%s*/SELECT id FROM test WHERE id = %d", MYSQLND_QC_ENABLE_SWITCH, $i % 2);
    $res   = $mysqli->query($query);

    $res->free();
}

var_dump(mysqlnd_qc_get_normalized_query_trace_log());
?>

The above examples will output something similar to:

array(4) {
  [0]=>
  array(9) {
    ["query"]=>
    string(25) "DROP TABLE IF EXISTS test"
    ["occurences"]=>
    int(0)
    ["eligible_for_caching"]=>
    bool(false)
    ["avg_run_time"]=>
    int(0)
    ["min_run_time"]=>
    int(0)
    ["max_run_time"]=>
    int(0)
    ["avg_store_time"]=>
    int(0)
    ["min_store_time"]=>
    int(0)
    ["max_store_time"]=>
    int(0)
  }
  [1]=>
  array(9) {
    ["query"]=>
    string(27) "CREATE TABLE test (id INT )"
    ["occurences"]=>
    int(0)
    ["eligible_for_caching"]=>
    bool(false)
    ["avg_run_time"]=>
    int(0)
    ["min_run_time"]=>
    int(0)
    ["max_run_time"]=>
    int(0)
    ["avg_store_time"]=>
    int(0)
    ["min_store_time"]=>
    int(0)
    ["max_store_time"]=>
    int(0)
  }
  [2]=>
  array(9) {
    ["query"]=>
    string(46) "INSERT INTO test (id ) VALUES (? ), (? ), (? )"
    ["occurences"]=>
    int(0)
    ["eligible_for_caching"]=>
    bool(false)
    ["avg_run_time"]=>
    int(0)
    ["min_run_time"]=>
    int(0)
    ["max_run_time"]=>
    int(0)
    ["avg_store_time"]=>
    int(0)
    ["min_store_time"]=>
    int(0)
    ["max_store_time"]=>
    int(0)
  }
  [3]=>
  array(9) {
    ["query"]=>
    string(31) "SELECT id FROM test WHERE id =?"
    ["occurences"]=>
    int(4)
    ["eligible_for_caching"]=>
    bool(true)
    ["avg_run_time"]=>
    int(179)
    ["min_run_time"]=>
    int(11)
    ["max_run_time"]=>
    int(393)
    ["avg_store_time"]=>
    int(12)
    ["min_store_time"]=>
    int(7)
    ["max_store_time"]=>
    int(25)
  }
}

The source distribution of PECL/mysqlnd_qc contains a directory web/ in which web based monitoring scripts can be found which give an example how to write a cache monitor. Please, follow the instructions given in the source.

Since PECL/mysqlnd_qc 1.1.0 it is possible to write statistics into a log file. Please, see mysqlnd_qc.collect_statistics_log_file.

Finding cache candidates
Beyond TTL: user-defined storage
Quickstart and Examples


Beyond TTL: user-defined storage

The query cache plugin supports the use of user-defined storage handler. User-defined storage handler can use arbitrarily complex invalidation algorithms and support arbitrary storage media.

All user-defined storage handlers have to provide a certain interface. The functions of the user-defined storage handler will be called by the core of the cache plugin. The necessary interface consists of seven public functions. Both procedural and object oriented user-defined storage handler must implement the same set of functions.

Örnek 1 Using a user-defined storage handler

<?php
/* Enable default caching of all statements */
ini_set("mysqlnd_qc.cache_by_default", 1);

/* Procedural user defined storage handler functions */

$__cache = array();

function get_hash($host_info, $port, $user, $db, $query) {
    global $__cache;
    printf("\t%s(%d)\n", __FUNCTION__, func_num_args());

    return md5(sprintf("%s%s%s%s%s", $host_info, $port, $user, $db, $query));
}

function find_query_in_cache($key) {
    global $__cache;
    printf("\t%s(%d)\n", __FUNCTION__, func_num_args());

    if (isset($__cache[$key])) {
        $tmp = $__cache[$key];
        if ($tmp["valid_until"] < time()) {
            unset($__cache[$key]);
            $ret = NULL;
        } else {
            $ret = $__cache[$key]["data"];
        }
    } else {
        $ret = NULL;
    }

    return $ret;
}

function return_to_cache($key) {
    /*
     Called on cache hit after cached data has been processed,
     may be used for reference counting
    */
    printf("\t%s(%d)\n", __FUNCTION__, func_num_args());
}

function add_query_to_cache_if_not_exists($key, $data, $ttl, $run_time, $store_time, $row_count) {
    global $__cache;
    printf("\t%s(%d)\n", __FUNCTION__, func_num_args());

    $__cache[$key] = array(
        "data"               => $data,
        "row_count"          => $row_count,
        "valid_until"        => time() + $ttl,
        "hits"               => 0,
        "run_time"           => $run_time,
        "store_time"         => $store_time,
        "cached_run_times"   => array(),
        "cached_store_times" => array(),
    );

    return TRUE;
}

function query_is_select($query) {
    printf("\t%s('%s'): ", __FUNCTION__, $query);

    $ret = FALSE;
    if (stristr($query, "SELECT") !== FALSE) {
        /* cache for 5 seconds */
        $ret = 5;
    }

    printf("%s\n", (FALSE === $ret) ? "FALSE" : $ret);
    return $ret;
}

function update_query_run_time_stats($key, $run_time, $store_time) {
    global $__cache;
    printf("\t%s(%d)\n", __FUNCTION__, func_num_args());

    if (isset($__cache[$key])) {
        $__cache[$key]['hits']++;
        $__cache[$key]["cached_run_times"][] = $run_time;
        $__cache[$key]["cached_store_times"][] = $store_time;
    }
}

function get_stats($key = NULL) {
    global $__cache;
    printf("\t%s(%d)\n", __FUNCTION__, func_num_args());

    if ($key && isset($__cache[$key])) {
        $stats = $__cache[$key];
    } else {
        $stats = array();
        foreach ($__cache as $key => $details) {
            $stats[$key] = array(
               'hits'              => $details['hits'],
               'bytes'             => strlen($details['data']),
               'uncached_run_time' => $details['run_time'],
               'cached_run_time'   => (count($details['cached_run_times']))
                                      ? array_sum($details['cached_run_times']) / count($details['cached_run_times'])
                                      : 0,
            );
        }
    }

    return $stats;
}

function clear_cache() {
    global $__cache;
    printf("\t%s(%d)\n", __FUNCTION__, func_num_args());

    $__cache = array();
    return TRUE;
}

/* Install procedural user-defined storage handler */
if (!mysqlnd_qc_set_user_handlers("get_hash", "find_query_in_cache",
    "return_to_cache", "add_query_to_cache_if_not_exists",
    "query_is_select", "update_query_run_time_stats", "get_stats", "clear_cache")) {

        printf("Failed to install user-defined storage handler\n");
}

/* Connect, create and populate test table */
$mysqli = new mysqli("host", "user", "password", "schema", "port", "socket");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1), (2)");

printf("\nCache put/cache miss\n");

$res = $mysqli->query("SELECT id FROM test WHERE id = 1");
var_dump($res->fetch_assoc());
$res->free();

/* Delete record to verify we get our data from the cache */
$mysqli->query("DELETE FROM test WHERE id = 1");

printf("\nCache hit\n");

$res = $mysqli->query("SELECT id FROM test WHERE id = 1");
var_dump($res->fetch_assoc());
$res->free();

printf("\nDisplay cache statistics\n");
var_dump(mysqlnd_qc_get_cache_info());

printf("\nFlushing cache, cache put/cache miss");
var_dump(mysqlnd_qc_clear_cache());

$res = $mysqli->query("SELECT id FROM test WHERE id = 1");
var_dump($res->fetch_assoc());
$res->free();
?>

The above examples will output something similar to:

        query_is_select('DROP TABLE IF EXISTS test'): FALSE
        query_is_select('CREATE TABLE test(id INT)'): FALSE
        query_is_select('INSERT INTO test(id) VALUES (1), (2)'): FALSE

Cache put/cache miss
        query_is_select('SELECT id FROM test WHERE id = 1'): 5
        get_hash(5)
        find_query_in_cache(1)
        add_query_to_cache_if_not_exists(6)
array(1) {
  ["id"]=>
  string(1) "1"
}
        query_is_select('DELETE FROM test WHERE id = 1'): FALSE

Cache hit
        query_is_select('SELECT id FROM test WHERE id = 1'): 5
        get_hash(5)
        find_query_in_cache(1)
        return_to_cache(1)
        update_query_run_time_stats(3)
array(1) {
  ["id"]=>
  string(1) "1"
}

Display cache statistics
        get_stats(0)
array(4) {
  ["num_entries"]=>
  int(1)
  ["handler"]=>
  string(4) "user"
  ["handler_version"]=>
  string(5) "1.0.0"
  ["data"]=>
  array(1) {
    ["18683c177dc89bb352b29965d112fdaa"]=>
    array(4) {
      ["hits"]=>
      int(1)
      ["bytes"]=>
      int(71)
      ["uncached_run_time"]=>
      int(398)
      ["cached_run_time"]=>
      int(4)
    }
  }
}

Flushing cache, cache put/cache miss    clear_cache(0)
bool(true)
        query_is_select('SELECT id FROM test WHERE id = 1'): 5
        get_hash(5)
        find_query_in_cache(1)
        add_query_to_cache_if_not_exists(6)
NULL

Measuring cache efficiency
Yapılandırma/Kurulum
Quickstart and Examples


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
Beyond TTL: user-defined storage
Gereksinimler
mysqlnd_qc


Gereksinimler

PHP 5.3.3 or a newer version of PHP.

PECL/mysqlnd_qc is a mysqlnd plugin. It plugs into the mysqlnd library. To use you this plugin with a PHP MySQL extension, the extension (mysqli, mysql, or PDO_MYSQL) must enable the mysqlnd library.

For using the APC storage handler with PECL/mysqlnd_qc 1.0 APC 3.1.3p1-beta or newer. PECL/mysqlnd_qc 1.2 has been tested with APC 3.1.13-beta. The APC storage handler cannot be used with a shared build. You cannot use the PHP configuration directive extension to load the APC and PECL/mysqlnd_qc extensions if PECL/mysqlnd_qc will use APC as a storage handler. For using the APC storage handler, you have to statically compile PHP with APC and PECL/mysqlnd_qc support into PHP.

For using MEMCACHE storage handler: Use libmemcache 0.38 or newer. PECL/mysqlnd_qc 1.2 has been tested with libmemcache 1.4.0.

For using sqlite storage handler: Use the sqlite3 extension that bundled with PHP.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu » PECL eklentisi PHP ile gelmez.

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/mysqlnd_qc

Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

mysqlnd_qc Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
mysqlnd_qc.enable_qc | 1 | PHP_INI_SYSTEM |
mysqlnd_qc.ttl | 30 | PHP_INI_ALL |
mysqlnd_qc.cache_by_default | 0 | PHP_INI_ALL |
mysqlnd_qc.cache_no_table | 0 | PHP_INI_ALL |
mysqlnd_qc.use_request_time | 0 | PHP_INI_ALL |
mysqlnd_qc.time_statistics | 1 | PHP_INI_ALL |
mysqlnd_qc.collect_statistics | 0 | PHP_INI_ALL |
mysqlnd_qc.collect_statistics_log_file | /tmp/mysqlnd_qc.stats | PHP_INI_SYSTEM |
mysqlnd_qc.collect_query_trace | 0 | PHP_INI_SYSTEM |
mysqlnd_qc.query_trace_bt_depth | 3 | PHP_INI_SYSTEM |
mysqlnd_qc.collect_normalized_query_trace | 0 | PHP_INI_SYSTEM |
mysqlnd_qc.ignore_sql_comments | 1 | PHP_INI_ALL |
mysqlnd_qc.slam_defense | 0 | PHP_INI_SYSTEM |
mysqlnd_qc.slam_defense_ttl | 30 | PHP_INI_SYSTEM |
mysqlnd_qc.std_data_copy | 0 | PHP_INI_SYSTEM |
mysqlnd_qc.apc_prefix | qc_ | PHP_INI_ALL |
mysqlnd_qc.memc_server | 127.0.0.1 | PHP_INI_ALL |
mysqlnd_qc.memc_port | 11211 | PHP_INI_ALL |
mysqlnd_qc.sqlite_data_file | :memory: | PHP_INI_ALL |

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

mysqlnd_qc.enable_qc integer

Enables or disables the plugin. If disabled the extension will not plug into mysqlnd to proxy internal mysqlnd C API calls.

mysqlnd_qc.ttl integer

Default Time-to-Live (TTL) for cache entries in seconds.

mysqlnd_qc.cache_by_default integer

Cache all queries regardless if they begin with the SQL hint that enables caching of a query or not. Storage handler cannot overrule the setting. It is evaluated by the core of the plugin.

mysqlnd_qc.cache_no_table integer

Whether to cache queries with no table name in any of columns meta data of their result set, for example, SELECT SLEEP(1), SELECT NOW(), SELECT SUBSTRING().

mysqlnd_qc.use_request_time integer

Use PHP global request time to avoid gettimeofday() system calls? If using APC storage handler it should be set to the value of apc.use_request_time , if not warnings will be generated.

mysqlnd_qc.time_statistics integer

Collect run time and store time statistics using gettimeofday() system call? Data will be collected only if you also set mysqlnd_qc.collect_statistics = 1,

mysqlnd_qc.collect_statistics integer

Collect statistics for mysqlnd_qc_get_core_stats()? Does not influence storage handler statistics! Handler statistics can be an integral part of the handler internal storage format. Therefore, collection of some handler statistics cannot be disabled.

mysqlnd_qc.collect_statistics-log-file integer

If mysqlnd_qc.collect_statistics and mysqlnd_qc.collect_statistics_log_file are set, the plugin will dump statistics into the specified log file at every 10th web request during PHP request shutdown. The log file needs to be writable by the web server user.

Since 1.1.0.

mysqlnd_qc.collect_query_trace integer

Collect query back traces?

mysqlnd_qc.query_trace_bt_depth integer

Maximum depth/level of a query code backtrace.

mysqlnd_qc.ignore_sql_comments integer

Whether to remove SQL comments from a query string before hashing it to generate a cache key. Disable if you do not want two statemts such as SELECT /*my_source_ip=123*/ id FROM test and SELECT /*my_source_ip=456*/ id FROM test to refer to the same cache entry.

Since 1.1.0.

mysqlnd_qc.slam_defense integer

Activates handler based slam defense (cache stampeding protection) if available. Supported by Default and APC storage handler

mysqlnd_qc.slam_defense_ttl integer

TTL for stale cache entries which are served while another client updates the entries. Supported by APC storage handler.

mysqlnd_qc.collect_normalized_query_trace integer

Collect aggregated normalized query traces? The setting has no effect by default. You compile the extension using the define NORM_QUERY_TRACE_LOG to make use of the setting.

mysqlnd_qc.std_data_copy integer

Default storage handler: copy cached wire data? EXPERIMENTAL - use default setting!

mysqlnd_qc.apc_prefix string

The APC storage handler stores data in the APC user cache. The setting sets a prefix to be used for cache entries.

mysqlnd_qc.memc_server string

MEMCACHE storage handler: memcache server host.

mysqlnd_qc.memc_port integer

MEMCACHE storage handler: memcached server port.

mysqlnd_qc.sqlite_data_file string

sqlite storage handler: data file. Any setting but :memory: may be of little practical value.

Kurulum
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

SQL hint related

Örnek 1 Using SQL hint constants

The query cache is controlled by SQL hints. SQL hints are used to enable and disable caching. SQL hints can be used to set the TTL of a query.

The SQL hints recognized by the query cache can be manually changed at compile time. This makes it possible to use mysqlnd_qc in environments in which the default SQL hints are already taken and interpreted by other systems. Therefore it is recommended to use the SQL hint string constants instead of manually adding the default SQL hints to the query string.

<?php
/* Use constants for maximum portability */
$query = "/*" . MYSQLND_QC_ENABLE_SWITCH . "*/SELECT id FROM test";

/* Valid but less portable: default TTL */
$query = "/*qc=on*/SELECT id FROM test";

/* Valid but less portable: per statement TTL */
$query = "/*qc=on*//*qc_ttl=5*/SELECT id FROM test";

printf("MYSQLND_QC_ENABLE_SWITCH: %s\n", MYSQLND_QC_ENABLE_SWITCH);
printf("MYSQLND_QC_DISABLE_SWITCH: %s\n", MYSQLND_QC_DISABLE_SWITCH);
printf("MYSQLND_QC_TTL_SWITCH: %s\n", MYSQLND_QC_TTL_SWITCH);
?>

Yukarıdaki örneklerin çıktısı:

MYSQLND_QC_ENABLE_SWITCH: qc=on
MYSQLND_QC_DISABLE_SWITCH: qc=off
MYSQLND_QC_TTL_SWITCH: qc_ttl=

MYSQLND_QC_ENABLE_SWITCH (string)
SQL hint used to enable caching of a query.
MYSQLND_QC_DISABLE_SWITCH (string)
SQL hint used to disable caching of a query if mysqlnd_qc.cache_by_default = 1.
MYSQLND_QC_TTL_SWITCH (string)
SQL hint used to set the TTL of a result set.
MYSQLND_QC_SERVER_ID_SWITCH (string)
This SQL hint should not be used in general. It is needed by PECL/mysqlnd_ms to group cache entries for one statement but originating from different physical connections. If the hint is used connection settings such as user, hostname and charset are not considered for generating a cache key of a query. Instead the given value and the query string are used as input to the hashing function that generates the key. PECL/mysqlnd_ms may, if instructed, cache results from MySQL Replication slaves. Because it can hold many connections to the slave the cache key shall not be formed from the user, hostname or other settings that may vary for the various slave connections. Instead, PECL/mysqlnd_ms provides an identifier which refers to the group of slave connections that shall be enabled to share cache entries no matter which physical slave connection was to generate the cache entry. Use of this feature outside of PECL/mysqlnd_ms is not recommended.

mysqlnd_qc_set_cache_condition() related

Örnek 2 Example mysqlnd_qc_set_cache_condition() usage

The function mysqlnd_qc_set_cache_condition() allows setting conditions for automatic caching of statements which don't begin with the SQL hints necessary to manually enable caching.

<?php
/* Cache all accesses to tables with the name "new%" in schema/database "db_example" for 1 second */
if (!mysqlnd_qc_set_cache_condition(MYSQLND_QC_CONDITION_META_SCHEMA_PATTERN, "db_example.new%", 1)) {
  die("Failed to set cache condition!");
}

$mysqli = new mysqli("host", "user", "password", "db_example", "port");
/* cached although no SQL hint given  */
$mysqli->query("SELECT id, title FROM news");

$pdo_mysql = new PDO("mysql:host=host;dbname=db_example;port=port", "user", "password");
/* not cached: no SQL hint, no pattern match */
$pdo_mysql->query("SELECT id, title FROM latest_news");
/* cached: TTL 1 second, pattern match */
$pdo_mysql->query("SELECT id, title FROM news");
?>

MYSQLND_QC_CONDITION_META_SCHEMA_PATTERN (int)
Used as a parameter of mysqlnd_qc_set_cache_condition() to set conditions for schema based automatic caching.

Other

The plugin version number can be obtained using either MYSQLND_QC_VERSION, which is the string representation of the numerical version number, or MYSQLND_QC_VERSION_ID, which is an integer such as 10000. Developers can calculate the version number as follows.

Version (part) | Example
Major*10000 | 1*10000 = 10000
Minor*100 | 0*100 = 0
Patch | 0 = 0
MYSQLND_QC_VERSION_ID | 10000

MYSQLND_QC_VERSION (string)
Plugin version string, for example, "1.0.0-prototype".

MYSQLND_QC_VERSION_ID (int)
Plugin version number, for example, 10000.

Çalışma Anı Yapılandırması
mysqlnd_qc İşlevleri
mysqlnd_qc


mysqlnd_qc İşlevleri

İçindekiler

  • mysqlnd_qc_clear_cache — Flush all cache contents
  • mysqlnd_qc_get_available_handlers — Returns a list of available storage handler
  • mysqlnd_qc_get_cache_info — Returns information on the current handler, the number of cache entries and cache entries, if available
  • mysqlnd_qc_get_core_stats — Statistics collected by the core of the query cache
  • mysqlnd_qc_get_normalized_query_trace_log — Returns a normalized query trace log for each query inspected by the query cache
  • mysqlnd_qc_get_query_trace_log — Returns a backtrace for each query inspected by the query cache
  • mysqlnd_qc_set_cache_condition — Set conditions for automatic caching
  • mysqlnd_qc_set_is_select — Installs a callback which decides whether a statement is cached
  • mysqlnd_qc_set_storage_handler — Change current storage handler
  • mysqlnd_qc_set_user_handlers — Sets the callback functions for a user-defined procedural storage handler
Öntanımlı Sabitler
mysqlnd_qc_clear_cache
mysqlnd_qc


Flush all cache contents

mysqlnd_qc İşlevleri
mysqlnd_qc_get_available_handlers
mysqlnd_qc İşlevleri
PHP Manual

mysqlnd_qc_clear_cache

(PECL mysqlnd_qc >= 1.0.0)

mysqlnd_qc_clear_cache — Flush all cache contents

Açıklama

bool mysqlnd_qc_clear_cache ( void )

Flush all cache contents.

Flushing the cache is a storage handler responsibility. All built-in storage handler but the memcache storage handler support flushing the cache. The memcache storage handler cannot flush its cache contents.

User-defined storage handler may or may not support the operation.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

A return value of FALSE indicates that flushing all cache contents has failed or the operation is not supported by the active storage handler. Applications must not expect that calling the function will always flush the cache.

mysqlnd_qc İşlevleri
mysqlnd_qc_get_available_handlers
mysqlnd_qc İşlevleri


Returns a list of available storage handler

mysqlnd_qc_clear_cache
mysqlnd_qc_get_cache_info
mysqlnd_qc İşlevleri
PHP Manual

mysqlnd_qc_get_available_handlers

(PECL mysqlnd_qc >= 1.0.0)

mysqlnd_qc_get_available_handlers — Returns a list of available storage handler

Açıklama

array mysqlnd_qc_get_available_handlers ( void )

Which storage are available depends on the compile time configuration of the query cache plugin. The default storage handler is always available. All other storage handler must be enabled explicitly when building the extension.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array of available built-in storage handler. For each storage handler the version number and version string is given.

Örnekler

Örnek 1 mysqlnd_qc_get_available_handlers() example

<?php
var_dump(mysqlnd_qc_get_available_handlers());
?>

Yukarıdaki örneklerin çıktısı:

array(5) {
  ["default"]=>
  array(2) {
    ["version"]=>
    string(5) "1.0.0"
    ["version_number"]=>
    int(100000)
  }
  ["user"]=>
  array(2) {
    ["version"]=>
    string(5) "1.0.0"
    ["version_number"]=>
    int(100000)
  }
  ["APC"]=>
  array(2) {
    ["version"]=>
    string(5) "1.0.0"
    ["version_number"]=>
    int(100000)
  }
  ["MEMCACHE"]=>
  array(2) {
    ["version"]=>
    string(5) "1.0.0"
    ["version_number"]=>
    int(100000)
  }
  ["sqlite"]=>
  array(2) {
    ["version"]=>
    string(5) "1.0.0"
    ["version_number"]=>
    int(100000)
  }
}

Ayrıca Bakınız

  • Installation
  • mysqlnd_qc_set_storage_handler() - Change current storage handler

mysqlnd_qc_clear_cache
mysqlnd_qc_get_cache_info
mysqlnd_qc İşlevleri


Returns information on the current handler, the number of cache entries and cache entries, if available

mysqlnd_qc_get_available_handlers
mysqlnd_qc_get_core_stats
mysqlnd_qc İşlevleri
PHP Manual

mysqlnd_qc_get_cache_info

(PECL mysqlnd_qc >= 1.0.0)

mysqlnd_qc_get_cache_info — Returns information on the current handler, the number of cache entries and cache entries, if available

Açıklama

array mysqlnd_qc_get_cache_info ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns information on the current handler, the number of cache entries and cache entries, if available. If and what data will be returned for the cache entries is subject to the active storage handler. Storage handler are free to return any data. Storage handler are recommended to return at least the data provided by the default handler, if technically possible.

The scope of the information is the PHP process. Depending on the PHP deployment model a process may serve one or more web requests.

Values are aggregated for all cache activities on a per storage handler basis. It is not possible to tell how much queries originating from mysqli, PDO_MySQL or mysql.API calls have contributed to the aggregated data values. Use mysqlnd_qc_get_core_stats() to get timing data aggregated for all storage handlers.

Array of cache information

handler string

The active storage handler.

All storage handler. Since 1.0.0.

handler_version string

The version of the active storage handler.

All storage handler. Since 1.0.0.

num_entries int

The number of cache entries. The value depends on the storage handler in use.

The default, APC and SQLite storage handler provide the actual number of cache entries.

The MEMCACHE storage handler always returns 0. MEMCACHE does not support counting the number of cache entries.

If a user defined handler is used, the number of entries of the data property is reported.

Since 1.0.0.

data array

The version of the active storage handler.

Additional storage handler dependent data on the cache entries. Storage handler are requested to provide similar and comparable information. A user defined storage handler is free to return any data.

Since 1.0.0.

The following information is provided by the default storage handler for the data property.

The data property holds a hash. The hash is indexed by the internal cache entry identifier of the storage handler. The cache entry identifier is human-readable and contains the query string leading to the cache entry. Please, see also the example below. The following data is given for every cache entry.

statistics array

Statistics of the cache entry.

Since 1.0.0.

Property | Description | Version
rows | Number of rows of the cached result set. | Since 1.0.0.
stored_size | The size of the cached result set in bytes. This is the size of the payload. The value is not suited for calculating the total memory consumption of all cache entries including the administrative overhead of the cache entries. | Since 1.0.0.
cache_hits | How often the cached entry has been returned. | Since 1.0.0.
run_time | Run time of the statement to which the cache entry belongs. This is the run time of the uncached statement. It is the time between sending the statement to MySQL receiving a reply from MySQL. Run time saved by using the query cache plugin can be calculated like this: cache_hits * ((run_time - avg_run_time) + (store_time - avg_store_time)). | Since 1.0.0.
store_time | Store time of the statements result set to which the cache entry belongs. This is the time it took to fetch and store the results of the uncached statement. | Since 1.0.0.
min_run_time | Minimum run time of the cached statement. How long it took to find the statement in the cache. | Since 1.0.0.
min_store_time | Minimum store time of the cached statement. The time taken for fetching the cached result set from the storage medium and decoding | Since 1.0.0.
avg_run_time | Average run time of the cached statement. | Since 1.0.0.
avg_store_time | Average store time of the cached statement. | Since 1.0.0.
max_run_time | Average run time of the cached statement. | Since 1.0.0.
max_store_time | Average store time of the cached statement. | Since 1.0.0.
valid_until | Timestamp when the cache entry expires. | Since 1.1.0.
metadata array

Metadata of the cache entry. This is the metadata provided by MySQL together with the result set of the statement in question. Different versions of the MySQL server may return different metadata. Unlike with some of the PHP MySQL extensions no attempt is made to hide MySQL server version dependencies and version details from the caller. Please, refer to the MySQL C API documentation that belongs to the MySQL server in use for further details.

The metadata list contains one entry for every column.

Since 1.0.0.

Property | Description | Version
name | The field name. Depending on the MySQL version this may be the fields alias name. | Since 1.0.0.
org_name | The field name. | Since 1.0.0.
table | The table name. If an alias name was used for the table, this usually holds the alias name. | Since 1.0.0.
org_table | The table name. | Since 1.0.0.
db | The database/schema name. | Since 1.0.0.
max_length | The maximum width of the field. Details may vary by MySQL server version. | Since 1.0.0.
length | The width of the field. Details may vary by MySQL server version. | Since 1.0.0.
type | The data type of the field. Details may vary by the MySQL server in use. This is the MySQL C API type constants value. It is recommended to use type constants provided by the mysqli extension to test for its meaning. You should not test for certain type values by comparing with certain numbers. | Since 1.0.0.

The APC storage handler returns the same information for the data property but no metadata. The metadata of a cache entry is set to NULL.

The MEMCACHE storage handler does not fill the data property. Statistics are not available on a per cache entry basis with the MEMCACHE storage handler.

A user defined storage handler is free to provide any data.

Örnekler

Örnek 1 mysqlnd_qc_get_cache_info() example

The example shows the output from the built-in default storage handler. Other storage handler may report different data.

<?php
/* Populate the cache, e.g. using mysqli */
$mysqli = new mysqli("host", "user", "password", "schema");
$mysqli->query("/*" . MYSQLND_QC_ENABLE_SWITCH . "*/SELECT id FROM test");

/* Display cache information */
var_dump(mysqlnd_qc_get_cache_info());
?>

Yukarıdaki örneklerin çıktısı:

array(4) {
 ["num_entries"]=>
 int(1)
 ["handler"]=>
 string(7) "default"
 ["handler_version"]=>
 string(5) "1.0.0"
 ["data"]=>
 array(1) {
   ["Localhost via UNIX socket 3306 user schema|/*qc=on*/SELECT id FROM test"]=>
   array(2) {
     ["statistics"]=>
     array(11) {
       ["rows"]=>
       int(6)
       ["stored_size"]=>
       int(101)
       ["cache_hits"]=>
       int(0)
       ["run_time"]=>
       int(471)
       ["store_time"]=>
       int(27)
       ["min_run_time"]=>
       int(0)
       ["max_run_time"]=>
       int(0)
       ["min_store_time"]=>
       int(0)
       ["max_store_time"]=>
       int(0)
       ["avg_run_time"]=>
       int(0)
       ["avg_store_time"]=>
       int(0)
     }
     ["metadata"]=>
     array(1) {
       [0]=>
       array(8) {
         ["name"]=>
         string(2) "id"
         ["orig_name"]=>
         string(2) "id"
         ["table"]=>
         string(4) "test"
         ["orig_table"]=>
         string(4) "test"
         ["db"]=>
         string(4) "schema"
         ["max_length"]=>
         int(1)
         ["length"]=>
         int(11)
         ["type"]=>
         int(3)
       }
     }
   }
 }
}

Ayrıca Bakınız

  • mysqlnd_qc_get_core_stats() - Statistics collected by the core of the query cache

mysqlnd_qc_get_available_handlers
mysqlnd_qc_get_core_stats
mysqlnd_qc İşlevleri


Statistics collected by the core of the query cache

mysqlnd_qc_get_cache_info
mysqlnd_qc_get_normalized_query_trace_log
mysqlnd_qc İşlevleri
PHP Manual

mysqlnd_qc_get_core_stats

(PECL mysqlnd_qc >= 1.0.0)

mysqlnd_qc_get_core_stats — Statistics collected by the core of the query cache

Açıklama

array mysqlnd_qc_get_core_stats ( void )

Returns an array of statistics collected by the core of the cache plugin. The same data fields will be reported for any storage handler because the data is collected by the core.

The PHP configuration setting mysqlnd_qc.collect_statistics controls the collection of statistics. The collection of statistics is disabled by default for performance reasons. Disabling the collection of statistics will also disable the collection of time related statistics.

The PHP configuration setting mysqlnd_qc.collect_time_statistics controls the collection of time related statistics.

The scope of the core statistics is the PHP process. Depending on your deployment model a PHP process may handle one or multiple requests.

Statistics are aggregated for all cache entries and all storage handler. It is not possible to tell how much queries originating from mysqli, PDO_MySQL or mysql API calls have contributed to the aggregated data values.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Array of core statistics

Statistic | Description | Version
cache_hit | Statement is considered cacheable and cached data has been reused. Statement is considered cacheable and a cache miss happened but the statement got cached by someone else while we process it and thus we can fetch the result from the refreshed cache. | Since 1.0.0.
cache_miss Statement is considered cacheable...

  • ... and has been added to the cache

  • ... but the PHP configuration directive setting of mysqlnd_qc.cache_no_table = 1 has prevented caching.

  • ... but an unbuffered result set is requested.

  • ... but a buffered result set was empty.

Since 1.0.0.
cache_put | Statement is considered cacheable and has been added to the cache. Take care when calculating derived statistics. Storage handler with a storage life time beyond process scope may report cache_put = 0 together with cache_hit > 0, if another process has filled the cache. You may want to use num_entries from mysqlnd_qc_get_cache_info() if the handler supports it ( default, APC). | Since 1.0.0.
query_should_cache | Statement is considered cacheable based on query string analysis. The statement may or may not be added to the cache. See also cache_put. | Since 1.0.0.
query_should_not_cache | Statement is considered not cacheable based on query string analysis. | Since 1.0.0.
query_not_cached | Statement is considered not cacheable or it is considered cachable but the storage handler has not returned a hash key for it. | Since 1.0.0.
query_could_cache Statement is considered cacheable...

  • ... and statement has been run without errors

  • ... and meta data shows at least one column in the result set

The statement may or may not be in the cache already. It may or may not be added to the cache later on. 		Since 1.0.0.
query_found_in_cache | Statement is considered cacheable and we have found it in the cache but we have not replayed the cached data yet and we have not send the result set to the client yet. This is not considered a cache hit because the client might not fetch the result or the cached data may be faulty. | Since 1.0.0.
query_uncached_other | Statement is considered cacheable and it may or may not be in the cache already but either replaying cached data has failed, no result set is available or some other error has happened.
query_uncached_no_table | Statement has not been cached because the result set has at least one column which has no table name in its meta data. An example of such a query is SELECT SLEEP(1). To cache those statements you have to change default value of the PHP configuration directive mysqlnd_qc.cache_no_table and set mysqlnd_qc.cache_no_table = 1. Often, it is not desired to cache such statements. | Since 1.0.0.
query_uncached_use_result | Statement would have been cached if a buffered result set had been used. The situation is also considered as a cache miss and cache_miss will be incremented as well. | Since 1.0.0.
query_aggr_run_time_cache_hit | Aggregated run time (ms) of all cached queries. Cached queries are those which have incremented cache_hit. | Since 1.0.0.
query_aggr_run_time_cache_put | Aggregated run time (ms) of all uncached queries that have been put into the cache. See also cache_put. | Since 1.0.0.
query_aggr_run_time_total | Aggregated run time (ms) of all uncached and cached queries that have been inspected and executed by the query cache. | Since 1.0.0.
query_aggr_store_time_cache_hit | Aggregated store time (ms) of all cached queries. Cached queries are those which have incremented cache_hit. | Since 1.0.0.
query_aggr_store_time_cache_put | Aggregated store time ( ms) of all uncached queries that have been put into the cache. See also cache_put. | Since 1.0.0.
query_aggr_store_time_total | Aggregated store time (ms) of all uncached and cached queries that have been inspected and executed by the query cache. | Since 1.0.0.
receive_bytes_recorded | Recorded incoming network traffic ( bytes) send from MySQL to PHP. The traffic may or may not have been added to the cache. The traffic is the total for all queries regardless if cached or not. | Since 1.0.0.
receive_bytes_replayed | Network traffic replayed during cache. This is the total amount of incoming traffic saved because of the usage of the query cache plugin. | Since 1.0.0.
send_bytes_recorded | Recorded outgoing network traffic ( bytes) send from MySQL to PHP. The traffic may or may not have been added to the cache. The traffic is the total for all queries regardless if cached or not. | Since 1.0.0.
send_bytes_replayed | Network traffic replayed during cache. This is the total amount of outgoing traffic saved because of the usage of the query cache plugin. | Since 1.0.0.
slam_stale_refresh | Number of cache misses which triggered serving stale data until the client causing the cache miss has refreshed the cache entry. | Since 1.0.0.
slam_stale_hit | Number of cache hits while a stale cache entry gets refreshed. | Since 1.0.0.

Örnekler

Örnek 1 mysqlnd_qc_get_core_stats() example

<?php
/* Enable collection of statistics - default: disabled */
ini_set("mysqlnd_qc.collect_statistics", 1);

/* Enable collection of all timing related statistics -
default: enabled but overruled by mysqlnd_qc.collect_statistics = 0 */
ini_set("mysqlnd_qc.collect_time_statistics", 1);

/* Populate the cache, e.g. using mysqli */
$mysqli = new mysqli('host', 'user', 'password', 'schema');

/* Cache miss and cache put */
$mysqli->query("/*qc=on*/SELECT id FROM test");
/* Cache hit */
$mysqli->query("/*qc=on*/SELECT id FROM test");

/* Display core statistics */
var_dump(mysqlnd_qc_get_core_stats());
?>

Yukarıdaki örneklerin çıktısı:

array(26) {
  ["cache_hit"]=>
  string(1) "1"
  ["cache_miss"]=>
  string(1) "1"
  ["cache_put"]=>
  string(1) "1"
  ["query_should_cache"]=>
  string(1) "2"
  ["query_should_not_cache"]=>
  string(1) "0"
  ["query_not_cached"]=>
  string(1) "0"
  ["query_could_cache"]=>
  string(1) "2"
  ["query_found_in_cache"]=>
  string(1) "1"
  ["query_uncached_other"]=>
  string(1) "0"
  ["query_uncached_no_table"]=>
  string(1) "0"
  ["query_uncached_no_result"]=>
  string(1) "0"
  ["query_uncached_use_result"]=>
  string(1) "0"
  ["query_aggr_run_time_cache_hit"]=>
  string(1) "4"
  ["query_aggr_run_time_cache_put"]=>
  string(3) "395"
  ["query_aggr_run_time_total"]=>
  string(3) "399"
  ["query_aggr_store_time_cache_hit"]=>
  string(1) "2"
  ["query_aggr_store_time_cache_put"]=>
  string(1) "8"
  ["query_aggr_store_time_total"]=>
  string(2) "10"
  ["receive_bytes_recorded"]=>
  string(2) "65"
  ["receive_bytes_replayed"]=>
  string(2) "65"
  ["send_bytes_recorded"]=>
  string(2) "29"
  ["send_bytes_replayed"]=>
  string(2) "29"
  ["slam_stale_refresh"]=>
  string(1) "0"
  ["slam_stale_hit"]=>
  string(1) "0"
  ["request_counter"]=>
  int(1)
  ["process_hash"]=>
  int(3547549858)
}

Ayrıca Bakınız

  • Runtime configuration
  • mysqlnd_qc.collect_statistics
  • mysqlnd_qc.time_statistics
  • mysqlnd_qc_get_cache_info() - Returns information on the current handler, the number of cache entries and cache entries, if available

mysqlnd_qc_get_cache_info
mysqlnd_qc_get_normalized_query_trace_log
mysqlnd_qc İşlevleri


Returns a normalized query trace log for each query inspected by the query cache

mysqlnd_qc_get_core_stats
mysqlnd_qc_get_query_trace_log
mysqlnd_qc İşlevleri
PHP Manual

mysqlnd_qc_get_normalized_query_trace_log

(PECL mysqlnd_qc >= 1.0.0)

mysqlnd_qc_get_normalized_query_trace_log — Returns a normalized query trace log for each query inspected by the query cache

Açıklama

array mysqlnd_qc_get_normalized_query_trace_log ( void )

Returns a normalized query trace log for each query inspected by the query cache. The collection of the trace log is disabled by default. To collect the trace log you have to set the PHP configuration directive mysqlnd_qc.collect_normalized_query_trace to 1

Entries in the trace log are grouped by the normalized query statement. The normalized query statement is the query statement with all statement parameter values being replaced with a question mark. For example, the two statements SELECT id FROM test WHERE id = 1 and SELECT id FROM test WHERE id = 2 are normalized as SELECT id FROM test WHERE id = ?. Whenever a statement is inspected by the query cache which matches the normalized statement pattern, its statistics are grouped by the normalized statement string.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

An array of query log. Every list entry contains the normalized query stringand further detail information.

Key | Description
query | Normalized statement string.
occurences | How many statements have matched the normalized statement string in addition to the one which has created the log entry. The value is zero if a statement has been normalized, its normalized representation has been added to the log but no further queries inspected by PECL/mysqlnd_qc have the same normalized statement string.
eligible_for_caching | Whether the statement could be cached. An statement eligible for caching has not necessarily been cached. It not possible to tell for sure if or how many cached statement have contributed to the aggregated normalized statement log entry. However, comparing the minimum and average run time one can make an educated guess.
avg_run_time | The average run time of all queries contributing to the query log entry. The run time is the time between sending the query statement to MySQL and receiving an answer from MySQL.
avg_store_time | The average store time of all queries contributing to the query log entry. The store time is the time needed to fetch a statements result set from the server to the client and, storing it on the client.
min_run_time | The minimum run time of all queries contributing to the query log entry.
min_store_time | The minimum store time of all queries contributing to the query log entry.
max_run_time | The maximum run time of all queries contributing to the query log entry.
max_store_time | The maximum store time of all queries contributing to the query log entry.

Örnekler

Örnek 1 mysqlnd_qc_get_normalized_query_trace_log() example

mysqlnd_qc.collect_normalized_query_trace=1
<?php
/* Connect, create and populate test table */
$mysqli = new mysqli("host", "user", "password", "schema", "port", "socket");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1), (2)");

/* not cached */
$res = $mysqli->query("SELECT id FROM test WHERE id = 1");
var_dump($res->fetch_assoc());
$res->free();

/* cache put */
$res = $mysqli->query("/*" . MYSQLND_QC_ENABLE_SWITCH . "*/" . "SELECT id FROM test WHERE id = 2");
var_dump($res->fetch_assoc());
$res->free();

/* cache hit */
$res = $mysqli->query("/*" . MYSQLND_QC_ENABLE_SWITCH . "*/" . "SELECT id FROM test WHERE id = 2");
var_dump($res->fetch_assoc());
$res->free();

var_dump(mysqlnd_qc_get_normalized_query_trace_log());
?>

Yukarıdaki örneklerin çıktısı:

array(1) {
  ["id"]=>
  string(1) "1"
}
array(1) {
  ["id"]=>
  string(1) "2"
}
array(1) {
  ["id"]=>
  string(1) "2"
}
array(4) {
  [0]=>
  array(9) {
    ["query"]=>
    string(25) "DROP TABLE IF EXISTS test"
    ["occurences"]=>
    int(0)
    ["eligible_for_caching"]=>
    bool(false)
    ["avg_run_time"]=>
    int(0)
    ["min_run_time"]=>
    int(0)
    ["max_run_time"]=>
    int(0)
    ["avg_store_time"]=>
    int(0)
    ["min_store_time"]=>
    int(0)
    ["max_store_time"]=>
    int(0)
  }
  [1]=>
  array(9) {
    ["query"]=>
    string(27) "CREATE TABLE test (id INT )"
    ["occurences"]=>
    int(0)
    ["eligible_for_caching"]=>
    bool(false)
    ["avg_run_time"]=>
    int(0)
    ["min_run_time"]=>
    int(0)
    ["max_run_time"]=>
    int(0)
    ["avg_store_time"]=>
    int(0)
    ["min_store_time"]=>
    int(0)
    ["max_store_time"]=>
    int(0)
  }
  [2]=>
  array(9) {
    ["query"]=>
    string(40) "INSERT INTO test (id ) VALUES (? ), (? )"
    ["occurences"]=>
    int(0)
    ["eligible_for_caching"]=>
    bool(false)
    ["avg_run_time"]=>
    int(0)
    ["min_run_time"]=>
    int(0)
    ["max_run_time"]=>
    int(0)
    ["avg_store_time"]=>
    int(0)
    ["min_store_time"]=>
    int(0)
    ["max_store_time"]=>
    int(0)
  }
  [3]=>
  array(9) {
    ["query"]=>
    string(31) "SELECT id FROM test WHERE id =?"
    ["occurences"]=>
    int(2)
    ["eligible_for_caching"]=>
    bool(true)
    ["avg_run_time"]=>
    int(159)
    ["min_run_time"]=>
    int(12)
    ["max_run_time"]=>
    int(307)
    ["avg_store_time"]=>
    int(10)
    ["min_store_time"]=>
    int(8)
    ["max_store_time"]=>
    int(13)
  }
}

Ayrıca Bakınız

  • Runtime configuration
  • mysqlnd_qc.collect_normalized_query_trace
  • mysqlnd_qc.time_statistics
  • mysqlnd_qc_get_query_trace_log() - Returns a backtrace for each query inspected by the query cache

mysqlnd_qc_get_core_stats
mysqlnd_qc_get_query_trace_log
mysqlnd_qc İşlevleri


Returns a backtrace for each query inspected by the query cache

mysqlnd_qc_get_normalized_query_trace_log
mysqlnd_qc_set_cache_condition
mysqlnd_qc İşlevleri
PHP Manual

mysqlnd_qc_get_query_trace_log

(PECL mysqlnd_qc >= 1.0.0)

mysqlnd_qc_get_query_trace_log — Returns a backtrace for each query inspected by the query cache

Açıklama

array mysqlnd_qc_get_query_trace_log ( void )

Returns a backtrace for each query inspected by the query cache. The collection of the backtrace is disabled by default. To collect the backtrace you have to set the PHP configuration directive mysqlnd_qc.collect_query_trace to 1

The maximum depth of the backtrace is limited to the depth set with the PHP configuration directive mysqlnd_qc.query_trace_bt_depth.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

An array of query backtrace. Every list entry contains the query string, a backtrace and further detail information.

Key | Description
query | Query string.
origin | Code backtrace.
run_time | Query run time in milliseconds. The collection of all times and the necessary gettimeofday system calls can be disabled by setting the PHP configuration directive mysqlnd_qc.time_statistics to 0
store_time | Query result set store time in milliseconds. The collection of all times and the necessary gettimeofday system calls can be disabled by setting the PHP configuration directive mysqlnd_qc.time_statistics to 0
eligible_for_caching | TRUE if query is cacheable otherwise FALSE.
no_table | TRUE if the query has generated a result set and at least one column from the result set has no table name set in its metadata. This is usually the case with queries which one probably do not want to cache such as SELECT SLEEP(1). By default any such query will not be added to the cache. See also PHP configuration directive mysqlnd_qc.cache_no_table.
was_added | TRUE if the query result has been put into the cache, otherwise FALSE.
was_already_in_cache | TRUE if the query result would have been added to the cache if it was not already in the cache (cache hit). Otherwise FALSE.

Örnekler

Örnek 1 mysqlnd_qc_get_query_trace_log() example

mysqlnd_qc.collect_query_trace=1
<?php
/* Connect, create and populate test table */
$mysqli = new mysqli("host", "user", "password", "schema", "port", "socket");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1), (2)");

/* not cached */
$res = $mysqli->query("SELECT id FROM test WHERE id = 1");
var_dump($res->fetch_assoc());
$res->free();

/* cache put */
$res = $mysqli->query("/*" . MYSQLND_QC_ENABLE_SWITCH . "*/" . "SELECT id FROM test WHERE id = 2");
var_dump($res->fetch_assoc());
$res->free();

/* cache hit */
$res = $mysqli->query("/*" . MYSQLND_QC_ENABLE_SWITCH . "*/" . "SELECT id FROM test WHERE id = 2");
var_dump($res->fetch_assoc());
$res->free();

var_dump(mysqlnd_qc_get_query_trace_log());
?>

Yukarıdaki örneklerin çıktısı:

array(1) {
  ["id"]=>
  string(1) "1"
}
array(1) {
  ["id"]=>
  string(1) "2"
}
array(1) {
  ["id"]=>
  string(1) "2"
}
array(6) {
  [0]=>
  array(8) {
    ["query"]=>
    string(25) "DROP TABLE IF EXISTS test"
    ["origin"]=>
    string(102) "#0 qc.php(4): mysqli->query('DROP TABLE IF E...')
#1 {main}"
    ["run_time"]=>
    int(0)
    ["store_time"]=>
    int(0)
    ["eligible_for_caching"]=>
    bool(false)
    ["no_table"]=>
    bool(false)
    ["was_added"]=>
    bool(false)
    ["was_already_in_cache"]=>
    bool(false)
  }
  [1]=>
  array(8) {
    ["query"]=>
    string(25) "CREATE TABLE test(id INT)"
    ["origin"]=>
    string(102) "#0 qc.php(5): mysqli->query('CREATE TABLE te...')
#1 {main}"
    ["run_time"]=>
    int(0)
    ["store_time"]=>
    int(0)
    ["eligible_for_caching"]=>
    bool(false)
    ["no_table"]=>
    bool(false)
    ["was_added"]=>
    bool(false)
    ["was_already_in_cache"]=>
    bool(false)
  }
  [2]=>
  array(8) {
    ["query"]=>
    string(36) "INSERT INTO test(id) VALUES (1), (2)"
    ["origin"]=>
    string(102) "#0 qc.php(6): mysqli->query('INSERT INTO tes...')
#1 {main}"
    ["run_time"]=>
    int(0)
    ["store_time"]=>
    int(0)
    ["eligible_for_caching"]=>
    bool(false)
    ["no_table"]=>
    bool(false)
    ["was_added"]=>
    bool(false)
    ["was_already_in_cache"]=>
    bool(false)
  }
  [3]=>
  array(8) {
    ["query"]=>
    string(32) "SELECT id FROM test WHERE id = 1"
    ["origin"]=>
    string(102) "#0 qc.php(9): mysqli->query('SELECT id FROM ...')
#1 {main}"
    ["run_time"]=>
    int(0)
    ["store_time"]=>
    int(25)
    ["eligible_for_caching"]=>
    bool(false)
    ["no_table"]=>
    bool(false)
    ["was_added"]=>
    bool(false)
    ["was_already_in_cache"]=>
    bool(false)
  }
  [4]=>
  array(8) {
    ["query"]=>
    string(41) "/*qc=on*/SELECT id FROM test WHERE id = 2"
    ["origin"]=>
    string(103) "#0 qc.php(14): mysqli->query('/*qc=on*/SELECT...')
#1 {main}"
    ["run_time"]=>
    int(311)
    ["store_time"]=>
    int(13)
    ["eligible_for_caching"]=>
    bool(true)
    ["no_table"]=>
    bool(false)
    ["was_added"]=>
    bool(true)
    ["was_already_in_cache"]=>
    bool(false)
  }
  [5]=>
  array(8) {
    ["query"]=>
    string(41) "/*qc=on*/SELECT id FROM test WHERE id = 2"
    ["origin"]=>
    string(103) "#0 qc.php(19): mysqli->query('/*qc=on*/SELECT...')
#1 {main}"
    ["run_time"]=>
    int(13)
    ["store_time"]=>
    int(8)
    ["eligible_for_caching"]=>
    bool(true)
    ["no_table"]=>
    bool(false)
    ["was_added"]=>
    bool(false)
    ["was_already_in_cache"]=>
    bool(true)
  }
}

Ayrıca Bakınız

  • Runtime configuration
  • mysqlnd_qc.collect_query_trace
  • mysqlnd_qc.query_trace_bt_depth
  • mysqlnd_qc.time_statistics
  • mysqlnd_qc.cache_no_table
  • mysqlnd_qc_get_normalized_query_trace_log() - Returns a normalized query trace log for each query inspected by the query cache

mysqlnd_qc_get_normalized_query_trace_log
mysqlnd_qc_set_cache_condition
mysqlnd_qc İşlevleri


Set conditions for automatic caching

mysqlnd_qc_get_query_trace_log
mysqlnd_qc_set_is_select
mysqlnd_qc İşlevleri
PHP Manual

mysqlnd_qc_set_cache_condition

(PECL mysqlnd_qc >= 1.1.0)

mysqlnd_qc_set_cache_condition — Set conditions for automatic caching

Açıklama

bool mysqlnd_qc_set_cache_condition ( int $condition_type , mixed $condition , mixed $condition_option )

Sets a condition for automatic caching of statements which do not contain the necessary SQL hints to enable caching of them.

Değiştirgeler

condition_type

Type of the condition. The only allowed value is MYSQLND_QC_CONDITION_META_SCHEMA_PATTERN.

condition

Parameter for the condition set with condition_type. Parameter type and structure depend on condition_type

If condition_type equals MYSQLND_QC_CONDITION_META_SCHEMA_PATTERN condition must be a string. The string sets a pattern. Statements are cached if table and database meta data entry of their result sets match the pattern. The pattern is checked for a match with the db and org_table meta data entries provided by the underlying MySQL client server library. Please, check the MySQL Reference manual for details about the two entries. The db and org_table values are concatenated with a dot (.) before matched against condition. Pattern matching supports the wildcards % and _. The wildcard % will match one or many arbitrary characters. _ will match one arbitrary character. The escape symbol is backslash.

condition_option

Option for condition. Type and structure depend on condition_type.

If condition_type equals MYSQLND_QC_CONDITION_META_SCHEMA_PATTERN condition_options is the TTL to be used.

Örnekler

Örnek 1 mysqlnd_qc_set_cache_condition() example

<?php
/* Cache all accesses to tables with the name "new%" in schema/database "db_example" for 1 second */
if (!mysqlnd_qc_set_cache_condition(MYSQLND_QC_CONDITION_META_SCHEMA_PATTERN, "db_example.new%", 1)) {
  die("Failed to set cache condition!");
}

$mysqli = new mysqli("host", "user", "password", "db_example", "port");
/* cached although no SQL hint given  */
$mysqli->query("SELECT id, title FROM news");

$pdo_mysql = new PDO("mysql:host=host;dbname=db_example;port=port", "user", "password");
/* not cached: no SQL hint, no pattern match */
$pdo_mysql->query("SELECT id, title FROM latest_news");
/* cached: TTL 1 second, pattern match */
$pdo_mysql->query("SELECT id, title FROM news");
?>

Dönen Değerler

Returns TRUE on success or FALSE on FAILURE.

Ayrıca Bakınız

  • Quickstart: pattern based caching

mysqlnd_qc_get_query_trace_log
mysqlnd_qc_set_is_select
mysqlnd_qc İşlevleri


Installs a callback which decides whether a statement is cached

mysqlnd_qc_set_cache_condition
mysqlnd_qc_set_storage_handler
mysqlnd_qc İşlevleri
PHP Manual

mysqlnd_qc_set_is_select

(PECL mysqlnd_qc >= 1.0.0)

mysqlnd_qc_set_is_select — Installs a callback which decides whether a statement is cached

Açıklama

mixed mysqlnd_qc_set_is_select ( string $callback )

Installs a callback which decides whether a statement is cached.

There are several ways of hinting PELC/mysqlnd_qc to cache a query. By default, PECL/mysqlnd_qc attempts to cache a if caching of all statements is enabled or the query string begins with a certain SQL hint. The plugin internally calls a function named is_select() to find out. This internal function can be replaced with a user-defined callback. Then, the user-defined callback is responsible to decide whether the plugin attempts to cache a statement. Because the internal function is replaced with the callback, the callback gains full control. The callback is free to ignore the configuration setting mysqlnd_qc.cache_by_default and SQL hints.

The callback is invoked for every statement inspected by the plugin. It is given the statements string as a parameter. The callback returns FALSE if the statement shall not be cached. It returns TRUE to make the plugin attempt to cache the statements result set, if any. A so-created cache entry is given the default TTL set with the PHP configuration directive mysqlnd_qc.ttl. If a different TTL shall be used, the callback returns a numeric value to be used as the TTL.

The internal is_select function is part of the internal cache storage handler interface. Thus, a user-defined storage handler offers the same capabilities.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 mysqlnd_qc_set_is_select() example

<?php
/* callback which decides if query is cached */
function is_select($query) {
  static $patterns = array(
   /* true - use default from mysqlnd_qc.ttl */
   "@SELECT\s+.*\s+FROM\s+test@ismU" => true,
   /* 3 - use TTL = 3 seconds */
   "@SELECT\s+.*\s+FROM\s+news@ismU" => 3
  );
  /* check if query does match pattern */
  foreach ($patterns as $pattern => $ttl) {
    if (preg_match($pattern, $query)) {
      printf("is_select(%45s): cache\n", $query);
      return $ttl;
    }
  }
  printf("is_select(%45s): do not cache\n", $query);
  return false;
}
mysqlnd_qc_set_is_select("is_select");

/* Connect, create and populate test table */
$mysqli = new mysqli("host", "user", "password", "schema");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1), (2), (3)");

/* cache put */
$mysqli->query("SELECT id FROM test WHERE id = 1");
/* cache hit */
$mysqli->query("SELECT id FROM test WHERE id = 1");
/* cache put */
$mysqli->query("SELECT * FROM test");
?>

Yukarıdaki örneklerin çıktısı:

is_select(                    DROP TABLE IF EXISTS test): do not cache
is_select(                    CREATE TABLE test(id INT)): do not cache
is_select(    INSERT INTO test(id) VALUES (1), (2), (3)): do not cache
is_select(             SELECT id FROM test WHERE id = 1): cache
is_select(             SELECT id FROM test WHERE id = 1): cache
is_select(                           SELECT * FROM test): cache

Ayrıca Bakınız

  • Runtime configuration
  • mysqlnd_qc.ttl
  • mysqlnd_qc.cache_by_default
  • mysqlnd_qc_set_user_handlers() - Sets the callback functions for a user-defined procedural storage handler

mysqlnd_qc_set_cache_condition
mysqlnd_qc_set_storage_handler
mysqlnd_qc İşlevleri


Change current storage handler

mysqlnd_qc_set_is_select
mysqlnd_qc_set_user_handlers
mysqlnd_qc İşlevleri
PHP Manual

mysqlnd_qc_set_storage_handler

(PECL mysqlnd_qc >= 1.0.0)

mysqlnd_qc_set_storage_handler — Change current storage handler

Açıklama

bool mysqlnd_qc_set_storage_handler ( string $handler )

Sets the storage handler used by the query cache. A list of available storage handler can be obtained from mysqlnd_qc_get_available_handlers(). Which storage are available depends on the compile time configuration of the query cache plugin. The default storage handler is always available. All other storage handler must be enabled explicitly when building the extension.

Değiştirgeler

handler

Handler can be of type string representing the name of a built-in storage handler or an object of type mysqlnd_qc_handler_default. The names of the built-in storage handler are default, APC, MEMCACHE, sqlite.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

If changing the storage handler fails a catchable fatal error will be thrown. The query cache cannot operate if the previous storage handler has been shutdown but no new storage handler has been installed.

Örnekler

Örnek 1 mysqlnd_qc_set_storage_handler() example

The example shows the output from the built-in default storage handler. Other storage handler may report different data.

<?php
var_dump(mysqlnd_qc_set_storage_handler("memcache"));

if (true === mysqlnd_qc_set_storage_handler("default"))
  printf("Default storage handler activated");

/* Catchable fatal error */
var_dump(mysqlnd_qc_set_storage_handler("unknown"));
?>

Yukarıdaki örneklerin çıktısı:

bool(true)
Default storage handler activated
Catchable fatal error: mysqlnd_qc_set_storage_handler(): Unknown handler 'unknown' in (file) on line (line)

Ayrıca Bakınız

  • Installation
  • mysqlnd_qc_get_available_handlers() - Returns a list of available storage handler

mysqlnd_qc_set_is_select
mysqlnd_qc_set_user_handlers
mysqlnd_qc İşlevleri


Sets the callback functions for a user-defined procedural storage handler

mysqlnd_qc_set_storage_handler
Change History
mysqlnd_qc İşlevleri
PHP Manual

mysqlnd_qc_set_user_handlers

(PECL mysqlnd_qc >= 1.0.0)

mysqlnd_qc_set_user_handlers — Sets the callback functions for a user-defined procedural storage handler

Açıklama

bool mysqlnd_qc_set_user_handlers ( string $get_hash , string $find_query_in_cache , string $return_to_cache , string $add_query_to_cache_if_not_exists , string $query_is_select , string $update_query_run_time_stats , string $get_stats , string $clear_cache )

Sets the callback functions for a user-defined procedural storage handler.

Değiştirgeler

get_hash

Name of the user function implementing the storage handler get_hash functionality.

find_query_in_cache

Name of the user function implementing the storage handler find_in_cache functionality.

return_to_cache

Name of the user function implementing the storage handler return_to_cache functionality.

add_query_to_cache_if_not_exists

Name of the user function implementing the storage handler add_query_to_cache_if_not_exists functionality.

query_is_select

Name of the user function implementing the storage handler query_is_select functionality.

update_query_run_time_stats

Name of the user function implementing the storage handler update_query_run_time_stats functionality.

get_stats

Name of the user function implementing the storage handler get_stats functionality.

clear_cache

Name of the user function implementing the storage handler clear_cache functionality.

Dönen Değerler

Returns TRUE on success or FALSE on FAILURE.

Ayrıca Bakınız

  • Procedural user-defined storage handler example

mysqlnd_qc_set_storage_handler
Change History
mysqlnd_qc İşlevleri


Change History

İçindekiler

  • PECL/mysqlnd_qc 1.2 series
  • PECL/mysqlnd_qc 1.1 series
  • PECL/mysqlnd_qc 1.0 series

This change history is a high level summary of selected changes that may impact applications and/or break backwards compatibility.

See also the CHANGES file in the source distribution for a complete list of changes.

mysqlnd_qc_set_user_handlers
PECL/mysqlnd_qc 1.2 series
mysqlnd_qc


PECL/mysqlnd_qc 1.2 series

1.2.0 - alpha

  • Release date: 03/2013
  • Motto/theme: PHP 5.5 compatibility

Feature changes

  • Update build for PHP 5.5 (Credits: Remi Collet)

  • APC storage handler update

    • Fix build for APC 3.1.13-beta and trunk

  • Introduced MYSQLND_QC_VERSION and MYSQLND_QC_VERSION_ID.

Change History
PECL/mysqlnd_qc 1.1 series
Change History


PECL/mysqlnd_qc 1.1 series

1.1.0 - stable

  • Release date: 04/2012
  • Motto/theme: PHP 5.4 compatibility, schema pattern based caching and mysqlnd_ms support

1.1.0 - beta

  • Release date: 04/2012
  • Motto/theme: PHP 5.4 compatibility, schema pattern based caching and mysqlnd_ms support

1.1.0 - alpha

  • Release date: 04/2012
  • Motto/theme: PHP 5.4 compatibility, schema pattern based caching and mysqlnd_ms support

Feature changes

  • APC storage handler update

    • Fix build for APC 3.1.9+
    • Note: Use of the APC storage handler is currently not recommended due to stability issues of APC itself.

  • New PHP configuration directives

    • mysqlnd_qc.collect_statistics_log_file. Aggregated cache statistics log file written after every 10th request served by the PHP process.
    • mysqlnd_qc.ignore_sql_comments. Control whether SQL comments are ignored for cache key hash generation.

  • New constants and SQL hints

    • MYSQLND_QC_SERVER_ID_SWITCH allows grouping of cache entries from different physical connections. This is needed by PECL/mysqlnd_ms.
    • MYSQLND_QC_CONDITION_META_SCHEMA_PATTERN to be used with mysqlnd_qc_set_cache_condition().

  • New function mysqlnd_qc_set_cache_condition() for built-in schema pattern based caching. Likely to support a wider range of conditions in the future.

  • Report valid_until timestamp for cache entries of the default handler through mysqlnd_qc_get_cache_info().

  • Include charset number for cache entry hashing. This should prevent serving result sets which have the wrong charset.

    API change: get_hash_key expects new "charsetnr" (int) parameter after "port".

  • API change: changing is_select() signature from bool is_select() to mixed is_select(). Mixed can be either boolean or array(long ttl, string server_id). This is needed by PECL/mysqlnd_ms.

Other

  • Support acting as a cache backend for PECL/mysqlnd_ms 1.3.0-beta or later to transparently replace MySQL Replication slave reads with cache accesses, if the user explicitly allows.

Bug fixes

  • Fixed Bug #59959 (config.m4, wrong library - 64bit memcached handler builds) (Credits: Remi Collet)

PECL/mysqlnd_qc 1.2 series
PECL/mysqlnd_qc 1.0 series
Change History


PECL/mysqlnd_qc 1.0 series

1.0.1-stable

  • Release date: 12/2010
  • Motto/theme: Prepared statement support

Added support for Prepared statements and unbuffered queries.

1.0.0-beta

  • Release date: 07/2010
  • Motto/theme: TTL-based cache with various storage options (Memcache, APC, SQLite, user-defined)

Initial public release of the transparent TTL-based query result cache. Flexible storage of cached results. Various storage media supported.

PECL/mysqlnd_qc 1.1 series
mysqlnd_uh
Change History


Mysqlnd user handler plugin

  • Giriş
  • Quickstart and Examples
    • Setup
    • How it works
    • Installing a proxy
    • Basic query monitoring
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • MysqlndUhConnection — The MysqlndUhConnection class
    • MysqlndUhConnection::changeUser — Changes the user of the specified mysqlnd database connection
    • MysqlndUhConnection::charsetName — Returns the default character set for the database connection
    • MysqlndUhConnection::close — Closes a previously opened database connection
    • MysqlndUhConnection::connect — Open a new connection to the MySQL server
    • MysqlndUhConnection::__construct — The __construct purpose
    • MysqlndUhConnection::endPSession — End a persistent connection
    • MysqlndUhConnection::escapeString — Escapes special characters in a string for use in an SQL statement, taking into account the current charset of the connection
    • MysqlndUhConnection::getAffectedRows — Gets the number of affected rows in a previous MySQL operation
    • MysqlndUhConnection::getErrorNumber — Returns the error code for the most recent function call
    • MysqlndUhConnection::getErrorString — Returns a string description of the last error
    • MysqlndUhConnection::getFieldCount — Returns the number of columns for the most recent query
    • MysqlndUhConnection::getHostInformation — Returns a string representing the type of connection used
    • MysqlndUhConnection::getLastInsertId — Returns the auto generated id used in the last query.
    • MysqlndUhConnection::getLastMessage — Retrieves information about the most recently executed query
    • MysqlndUhConnection::getProtocolInformation — Returns the version of the MySQL protocol used
    • MysqlndUhConnection::getServerInformation — Returns the version of the MySQL server
    • MysqlndUhConnection::getServerStatistics — Gets the current system status
    • MysqlndUhConnection::getServerVersion — Returns the version of the MySQL server as an integer
    • MysqlndUhConnection::getSqlstate — Returns the SQLSTATE error from previous MySQL operation
    • MysqlndUhConnection::getStatistics — Returns statistics about the client connection.
    • MysqlndUhConnection::getThreadId — Returns the thread ID for the current connection
    • MysqlndUhConnection::getWarningCount — Returns the number of warnings from the last query for the given link
    • MysqlndUhConnection::init — Initialize mysqlnd connection
    • MysqlndUhConnection::killConnection — Asks the server to kill a MySQL thread
    • MysqlndUhConnection::listFields — List MySQL table fields
    • MysqlndUhConnection::listMethod — Wrapper for assorted list commands
    • MysqlndUhConnection::moreResults — Check if there are any more query results from a multi query
    • MysqlndUhConnection::nextResult — Prepare next result from multi_query
    • MysqlndUhConnection::ping — Pings a server connection, or tries to reconnect if the connection has gone down
    • MysqlndUhConnection::query — Performs a query on the database
    • MysqlndUhConnection::queryReadResultsetHeader — Read a result set header
    • MysqlndUhConnection::reapQuery — Get result from async query
    • MysqlndUhConnection::refreshServer — Flush or reset tables and caches
    • MysqlndUhConnection::restartPSession — Restart a persistent mysqlnd connection
    • MysqlndUhConnection::selectDb — Selects the default database for database queries
    • MysqlndUhConnection::sendClose — Sends a close command to MySQL
    • MysqlndUhConnection::sendQuery — Sends a query to MySQL
    • MysqlndUhConnection::serverDumpDebugInformation — Dump debugging information into the log for the MySQL server
    • MysqlndUhConnection::setAutocommit — Turns on or off auto-committing database modifications
    • MysqlndUhConnection::setCharset — Sets the default client character set
    • MysqlndUhConnection::setClientOption — Sets a client option
    • MysqlndUhConnection::setServerOption — Sets a server option
    • MysqlndUhConnection::shutdownServer — The shutdownServer purpose
    • MysqlndUhConnection::simpleCommand — Sends a basic COM_* command
    • MysqlndUhConnection::simpleCommandHandleResponse — Process a response for a basic COM_* command send to the client
    • MysqlndUhConnection::sslSet — Used for establishing secure connections using SSL
    • MysqlndUhConnection::stmtInit — Initializes a statement and returns a resource for use with mysqli_statement::prepare
    • MysqlndUhConnection::storeResult — Transfers a result set from the last query
    • MysqlndUhConnection::txCommit — Commits the current transaction
    • MysqlndUhConnection::txRollback — Rolls back current transaction
    • MysqlndUhConnection::useResult — Initiate a result set retrieval
  • MysqlndUhPreparedStatement — The MysqlndUhPreparedStatement class
    • MysqlndUhPreparedStatement::__construct — The __construct purpose
    • MysqlndUhPreparedStatement::execute — Executes a prepared Query
    • MysqlndUhPreparedStatement::prepare — Prepare an SQL statement for execution
  • Mysqlnd_uh İşlevleri
    • mysqlnd_uh_convert_to_mysqlnd — Converts a MySQL connection handle into a mysqlnd connection handle
    • mysqlnd_uh_set_connection_proxy — Installs a proxy for mysqlnd connections
    • mysqlnd_uh_set_statement_proxy — Installs a proxy for mysqlnd statements
  • Change History
    • PECL/mysqlnd_uh 1.0 series
PECL/mysqlnd_qc 1.0 series
Giriş
MySQL


Giriş

The mysqlnd user handler plugin (mysqlnd_uh) allows users to set hooks for most internal calls of the MySQL native driver for PHP (mysqlnd). Mysqlnd and its plugins, including PECL/mysqlnd_uh, operate on a layer beneath the PHP MySQL extensions. A mysqlnd plugin can be considered as a proxy between the PHP MySQL extensions and the MySQL server as part of the PHP executable on the client-side. Because the plugins operates on their own layer below the PHP MySQL extensions, they can monitor and change application actions without requiring application changes. If the PHP MySQL extensions (mysqli, mysql, PDO_MYSQL) are compiled to use mysqlnd this can be used for:

  • Monitoring

    • Queries executed by any of the PHP MySQL extensions

    • Prepared statements executing by any of the PHP MySQL extensions

  • Auditing

    • Detection of database usage

    • SQL injection protection using black and white lists

  • Assorted

    • Load Balancing connections

The MySQL native driver for PHP (mysqlnd) features an internal plugin C API. C plugins, such as the mysqlnd user handler plugin, can extend the functionality of mysqlnd. PECL/mysqlnd_uh makes parts of the internal plugin C API available to the PHP user for plugin development with PHP.

Bilginize: Status

The mysqlnd user handler plugin is in alpha status. Take appropriate care before using it in production environments.

Security considerations

PECL/mysqlnd_uh gives users access to MySQL user names, MySQL password used by any of the PHP MySQL extensions to connect to MySQL. It allows monitoring of all queries and prepared statements exposing the statement string to the user. Therefore, the extension should be installed with care. The PHP_INI_SYSTEM configuration setting mysqlnd_uh.enable can be used to prevent users from hooking mysqlnd calls.

Code obfuscators and similar technologies are not suitable to prevent monitoring of mysqlnd library activities if PECL/mysqlnd_uh is made available and the user can install a proxy, for example, using auto_prepend_file.

Documentation note

Many of the mysqlnd_uh functions are briefly described because the mysqli extension is a thin abstraction layer on top of the MySQL C API that the mysqlnd library provides. Therefore, the corresponding mysqli documentation (along with the MySQL reference manual) can be consulted to receive more information about a particular function.

On the name

The shortcut mysqlnd_uh stands for mysqlnd user handler, and has been the name since early development.

mysqlnd_uh
Quickstart and Examples
mysqlnd_uh


Quickstart and Examples

İçindekiler

  • Setup
  • How it works
  • Installing a proxy
  • Basic query monitoring

The mysqlnd user handler plugin can be understood as a client-side proxy for all PHP MySQL extensions (mysqli, mysql, PDO_MYSQL), if they are compiled to use the mysqlnd library. The extensions use the mysqlnd library internally, at the C level, to communicate with the MySQL server. PECL/mysqlnd_uh allows it to hook many mysqlnd calls. Therefore, most activities of the PHP MySQL extensions can be monitored.

Because monitoring happens at the level of the library, at a layer below the application, it is possible to monitor applications without changing them.

On the C level, the mysqlnd library is structured in modules or classes. The extension hooks almost all methods of the mysqlnd internal connection class and exposes them through the user space class MysqlndUhConnection. Some few methods of the mysqlnd internal statement class are made available to the PHP user with the class MysqlndUhPreparedStatement. By subclassing the classes MysqlndUhConnection and MysqlndUhPreparedStatement users get access to mysqlnd internal function calls.

Bilginize:

The internal mysqlnd function calls are not designed to be exposed to the PHP user. Manipulating their activities may cause PHP to crash or leak memory. Often, this is not considered a bug. Please, keep in mind that you are accessing C library functions through PHP which are expected to take certain actions, which you may not be able to emulate in user space. Therefore, it is strongly recommended to always call the parent method implementation when subclassing MysqlndUhConnection or MysqlndUhPreparedStatement. To prevent the worst case, the extension performs some sanity checks. Please, see also the Mysqlnd_uh Yapılandırma Seçenekleri.

Giriş
Setup
mysqlnd_uh


Setup

The plugin is implemented as a PHP extension. See the installation instructions to install the » PECL/mysqlnd_uh extension. Then, load the extension into PHP and activate the plugin in the PHP configuration file using the PHP configuration directive named mysqlnd_uh.enable. The below example shows the default settings of the extension.

Örnek 1 Enabling the plugin (php.ini)

mysqlnd_uh.enable=1
mysqlnd_uh.report_wrong_types=1

Quickstart and Examples
How it works
Quickstart and Examples


How it works

This describes the background and inner workings of the mysqlnd_uh extension.

Two classes are provided by the extension: MysqlndUhConnection and MysqlndUhPreparedStatement. MysqlndUhConnection lets you access almost all methods of the mysqlnd internal connection class. The latter exposes some selected methods of the mysqlnd internal statement class. For example, MysqlndUhConnection::connect() maps to the mysqlnd library C function mysqlnd_conn__connect.

As a mysqlnd plugin, the PECL/mysqlnd_uh extension replaces mysqlnd library C functions with its own functions. Whenever a PHP MySQL extension compiled to use mysqlnd calls a mysqlnd function, the functions installed by the plugin are executed instead of the original mysqlnd ones. For example, mysqli_connect() invokes mysqlnd_conn__connect, so the connect function installed by PECL/mysqlnd_uh will be called. The functions installed by PECL/mysqlnd_uh are the methods of the built-in classes.

The built-in PHP classes and their methods do nothing but call their mysqlnd C library counterparts, to behave exactly like the original mysqlnd function they replace. The code below illustrates in pseudo-code what the extension does.

Örnek 1 Pseudo-code: what a built-in class does

class MysqlndUhConnection {
  public function connect(($conn, $host, $user, $passwd, $db, $port, $socket, $mysql_flags) {
    MYSQLND* c_mysqlnd_connection = convert_from_php_to_c($conn);
    ...
    return call_c_function(mysqlnd_conn__connect(c_mysqlnd_connection, ...));
  }
}

The build-in classes behave like a transparent proxy. It is possible for you to replace the proxy with your own. This is done by subclassing MysqlndUhConnection or MysqlndUhPreparedStatement to extend the functionality of the proxy, followed by registering a new proxy object. Proxy objects are installed by mysqlnd_uh_set_connection_proxy() and mysqlnd_uh_set_statement_proxy().

Örnek 2 Installing a proxy

<?php
class proxy extends MysqlndUhConnection {
 public function connect($res, $host, $user, $passwd, $db, $port, $socket, $mysql_flags) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   $ret = parent::connect($res, $host, $user, $passwd, $db, $port, $socket, $mysql_flags);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
?>

Yukarıdaki örneğin çıktısı:

proxy::connect(array (
  0 => NULL,
  1 => 'localhost',
  2 => 'root',
  3 => '',
  4 => 'test',
  5 => 3306,
  6 => NULL,
  7 => 131072,
))
proxy::connect returns true

Setup
Installing a proxy
Quickstart and Examples


Installing a proxy

The extension provides two built-in classes: MysqlndUhConnection and MysqlndUhPreparedStatement. The classes are used for hooking mysqlnd library calls. Their methods correspond to mysqlnd internal functions. By default they act like a transparent proxy and do nothing but call their mysqlnd counterparts. By subclassing the classes you can install your own proxy to monitor mysqlnd.

See also the How it works guide to learn about the inner workings of this extension.

Connection proxies are objects of the type MysqlndUhConnection. Connection proxy objects are installed by mysqlnd_uh_set_connection_proxy(). If you install the built-in class MysqlndUhConnection as a proxy, nothing happens. It behaves like a transparent proxy.

Örnek 1 Proxy registration, mysqlnd_uh.enable=1

<?php
mysqlnd_uh_set_connection_proxy(new MysqlndUhConnection());
$mysqli = new mysqli("localhost", "root", "", "test");
?>

The PHP_INI_SYSTEM configuration setting mysqlnd_uh.enable controls whether a proxy may be set. If disabled, the extension will throw errors of type E_WARNING

Örnek 2 Proxy installation disabled

mysqlnd_uh.enable=0
<?php
mysqlnd_uh_set_connection_proxy(new MysqlndUhConnection());
$mysqli = new mysqli("localhost", "root", "", "test");
?>

Yukarıdaki örneğin çıktısı:

PHP Warning:  MysqlndUhConnection::__construct(): (Mysqlnd User Handler) The plugin has been disabled by setting the configuration parameter mysqlnd_uh.enabled = false.  You must not use any of the base classes in %s on line %d
PHP Warning:  mysqlnd_uh_set_connection_proxy(): (Mysqlnd User Handler) The plugin has been disabled by setting the configuration parameter mysqlnd_uh.enable = false. The proxy has not been installed  in %s on line %d

To monitor mysqlnd, you have to write your own proxy object subclassing MysqlndUhConnection. Please, see the function reference for a the list of methods that can be subclassed. Alternatively, you can use reflection to inspect the built-in MysqlndUhConnection.

Create a new class proxy. Derive it from the built-in class MysqlndUhConnection. Replace the MysqlndUhConnection::connect(). method. Print out the host parameter value passed to the method. Make sure that you call the parent implementation of the connect method. Failing to do so may give unexpected and undesired results, including memory leaks and crashes.

Register your proxy and open three connections using the PHP MySQL extensions mysqli, mysql, PDO_MYSQL. If the extensions have been compiled to use the mysqlnd library, the proxy::connect method will be called three times, once for each connection opened.

Örnek 3 Connection proxy

<?php
class proxy extends MysqlndUhConnection {
  public function connect($res, $host, $user, $passwd, $db, $port, $socket, $mysql_flags) {
   printf("Connection opened to '%s'\n", $host);
   /* Always call the parent implementation! */
   return parent::connect($res, $host, $user, $passwd, $db, $port, $socket, $mysql_flags);
  }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$mysql = mysql_connect("localhost", "root", "");
$pdo = new PDO("mysql:host=localhost;dbname=test", "root", "");
?>

Yukarıdaki örneğin çıktısı:

Connection opened to 'localhost'
Connection opened to 'localhost'
Connection opened to 'localhost'

The use of prepared statement proxies follows the same pattern: create a proxy object of the type MysqlndUhPreparedStatement and install the proxy using mysqlnd_uh_set_statement_proxy().

Örnek 4 Prepared statement proxy

<?php
class stmt_proxy extends MysqlndUhPreparedStatement {
 public function prepare($res, $query) {
  printf("%s(%s)\n", __METHOD__, $query);
  return parent::prepare($res, $query);
 }
}
mysqlnd_uh_set_statement_proxy(new stmt_proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$stmt = $mysqli->prepare("SELECT 'mysqlnd hacking made easy' AS _msg FROM DUAL");
?>

Yukarıdaki örneğin çıktısı:

stmt_proxy::prepare(SELECT 'mysqlnd hacking made easy' AS _msg FROM DUAL)

How it works
Basic query monitoring
Quickstart and Examples


Basic query monitoring

Basic monitoring of a query statement is easy with PECL/mysqlnd_uh. Combined with debug_print_backtrace() it can become a powerful tool, for example, to find the origin of certain statement. This may be desired when searching for slow queries but also after database refactoring to find code still accessing deprecated databases or tables. The latter may be a complicated matter to do otherwise, especially if the application uses auto-generated queries.

Örnek 1 Basic Monitoring

<?php
class conn_proxy extends MysqlndUhConnection {
 public function query($res, $query) {
  debug_print_backtrace();
  return parent::query($res, $query);
 }
}
class stmt_proxy extends MysqlndUhPreparedStatement {
 public function prepare($res, $query) {
  debug_print_backtrace();
  return parent::prepare($res, $query);
 }
}
mysqlnd_uh_set_connection_proxy(new conn_proxy());
mysqlnd_uh_set_statement_proxy(new stmt_proxy());

printf("Proxies installed...\n");
$pdo = new PDO("mysql:host=localhost;dbname=test", "root", "");
var_dump($pdo->query("SELECT 1 AS _one FROM DUAL")->fetchAll(PDO::FETCH_ASSOC));

$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->prepare("SELECT 1 AS _two FROM DUAL");
?>

Yukarıdaki örneğin çıktısı:

#0  conn_proxy->query(Resource id #19, SELECT 1 AS _one FROM DUAL)
#1  PDO->query(SELECT 1 AS _one FROM DUAL) called at [example.php:19]
array(1) {
  [0]=>
  array(1) {
    ["_one"]=>
    string(1) "1"
  }
}
#0  stmt_proxy->prepare(Resource id #753, SELECT 1 AS _two FROM DUAL)
#1  mysqli->prepare(SELECT 1 AS _two FROM DUAL) called at [example.php:22]

For basic query monitoring you should install a connection and a prepared statement proxy. The connection proxy should subclass MysqlndUhConnection::query(). All database queries not using native prepared statements will call this method. In the example the query function is invoked by a PDO call. By default, PDO_MySQL is using prepared statement emulation.

All native prepared statements are prepared with the prepare method of mysqlnd exported through MysqlndUhPreparedStatement::prepare(). Subclass MysqlndUhPreparedStatement and overwrite prepare for native prepared statement monitoring.

Installing a proxy
Yapılandırma/Kurulum
Quickstart and Examples


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Basic query monitoring
Gereksinimler
mysqlnd_uh


Gereksinimler

PHP 5.3.3 or later. It is recommended to use PHP 5.4.0 or later to get access to the latest mysqlnd features.

The mysqlnd_uh user handler plugin supports all PHP applications and all available PHP MySQL extensions (mysqli, mysql, PDO_MYSQL). The PHP MySQL extension must be configured to use mysqlnd in order to be able to use the mysqlnd_uh plugin for mysqlnd.

The alpha versions makes use of some mysqli features. You must enable mysqli to compile the plugin. This requirement may be removed in the future. Note, that this requirement does not restrict you to use the plugin only with mysqli. You can use the plugin to monitor mysql, mysqli and PDO_MYSQL.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/mysqlnd-uh

PECL/mysqlnd_uh is currently not available on Windows. The source code of the extension makes use of C99 constructs not allowed with PHP Windows builds.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Mysqlnd_uh Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
mysqlnd_uh.enable | 1 | PHP_INI_SYSTEM |
mysqlnd_uh.report_wrong_types | 1 | PHP_INI_ALL |

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

mysqlnd_uh.enable integer

Enables or disables the plugin. If set to disabled, the extension will not allow users to plug into mysqlnd to hook mysqlnd calls.

mysqlnd_uh.report_wrong_types integer

Whether to report wrong return value types of user hooks as E_WARNING level errors. This is recommended for detecting errors.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

Most of the constants refer to details of the MySQL Client Server Protocol. Please, refer to the MySQL reference manual to learn about their meaning. To avoid content duplication, only short descriptions are given.

MysqlndUhConnection::simpleCommand() related

The following constants can be used to detect what command is to be send through MysqlndUhConnection::simpleCommand().

MYSQLND_UH_MYSQLND_COM_SLEEP (integer)
MySQL Client Server protocol command: COM_SLEEP.
MYSQLND_UH_MYSQLND_COM_QUIT (integer)
MySQL Client Server protocol command: COM_QUIT.
MYSQLND_UH_MYSQLND_COM_INIT_DB (integer)
MySQL Client Server protocol command: COM_INIT_DB.
MYSQLND_UH_MYSQLND_COM_QUERY (integer)
MySQL Client Server protocol command: COM_QUERY.
MYSQLND_UH_MYSQLND_COM_FIELD_LIST (integer)
MySQL Client Server protocol command: COM_FIELD_LIST.
MYSQLND_UH_MYSQLND_COM_CREATE_DB (integer)
MySQL Client Server protocol command: COM_CREATE_DB.
MYSQLND_UH_MYSQLND_COM_DROP_DB (integer)
MySQL Client Server protocol command: COM_DROP_DB.
MYSQLND_UH_MYSQLND_COM_REFRESH (integer)
MySQL Client Server protocol command: COM_REFRESH.
MYSQLND_UH_MYSQLND_COM_SHUTDOWN (integer)
MySQL Client Server protocol command: COM_SHUTDOWN.
MYSQLND_UH_MYSQLND_COM_STATISTICS (integer)
MySQL Client Server protocol command: COM_STATISTICS.
MYSQLND_UH_MYSQLND_COM_PROCESS_INFO (integer)
MySQL Client Server protocol command: COM_PROCESS_INFO.
MYSQLND_UH_MYSQLND_COM_CONNECT (integer)
MySQL Client Server protocol command: COM_CONNECT.
MYSQLND_UH_MYSQLND_COM_PROCESS_KILL (integer)
MySQL Client Server protocol command: COM_PROCESS_KILL.
MYSQLND_UH_MYSQLND_COM_DEBUG (integer)
MySQL Client Server protocol command: COM_DEBUG.
MYSQLND_UH_MYSQLND_COM_PING (integer)
MySQL Client Server protocol command: COM_PING.
MYSQLND_UH_MYSQLND_COM_TIME (integer)
MySQL Client Server protocol command: COM_TIME.
MYSQLND_UH_MYSQLND_COM_DELAYED_INSERT (integer)
MySQL Client Server protocol command: COM_DELAYED_INSERT.
MYSQLND_UH_MYSQLND_COM_CHANGE_USER (integer)
MySQL Client Server protocol command: COM_CHANGE_USER.
MYSQLND_UH_MYSQLND_COM_BINLOG_DUMP (integer)
MySQL Client Server protocol command: COM_BINLOG_DUMP.
MYSQLND_UH_MYSQLND_COM_TABLE_DUMP (integer)
MySQL Client Server protocol command: COM_TABLE_DUMP.
MYSQLND_UH_MYSQLND_COM_CONNECT_OUT (integer)
MySQL Client Server protocol command: COM_CONNECT_OUT.
MYSQLND_UH_MYSQLND_COM_REGISTER_SLAVED (integer)
MySQL Client Server protocol command: COM_REGISTER_SLAVED.
MYSQLND_UH_MYSQLND_COM_STMT_PREPARE (integer)
MySQL Client Server protocol command: COM_STMT_PREPARE.
MYSQLND_UH_MYSQLND_COM_STMT_EXECUTE (integer)
MySQL Client Server protocol command: COM_STMT_EXECUTE.
MYSQLND_UH_MYSQLND_COM_STMT_SEND_LONG_DATA (integer)
MySQL Client Server protocol command: COM_STMT_SEND_LONG_DATA.
MYSQLND_UH_MYSQLND_COM_STMT_CLOSE (integer)
MySQL Client Server protocol command: COM_STMT_CLOSE.
MYSQLND_UH_MYSQLND_COM_STMT_RESET (integer)
MySQL Client Server protocol command: COM_STMT_RESET.
MYSQLND_UH_MYSQLND_COM_SET_OPTION (integer)
MySQL Client Server protocol command: COM_SET_OPTION.
MYSQLND_UH_MYSQLND_COM_STMT_FETCH (integer)
MySQL Client Server protocol command: COM_STMT_FETCH.
MYSQLND_UH_MYSQLND_COM_DAEMON (integer)
MySQL Client Server protocol command: COM_DAEMON.
MYSQLND_UH_MYSQLND_COM_END (integer)
MySQL Client Server protocol command: COM_END.

The following constants can be used to analyze the ok_packet argument of MysqlndUhConnection::simpleCommand().

MYSQLND_UH_MYSQLND_PROT_GREET_PACKET (integer)
MySQL Client Server protocol packet: greeting.
MYSQLND_UH_MYSQLND_PROT_AUTH_PACKET (integer)
MySQL Client Server protocol packet: authentication.
MYSQLND_UH_MYSQLND_PROT_OK_PACKET (integer)
MySQL Client Server protocol packet: OK.
MYSQLND_UH_MYSQLND_PROT_EOF_PACKET (integer)
MySQL Client Server protocol packet: EOF.
MYSQLND_UH_MYSQLND_PROT_CMD_PACKET (integer)
MySQL Client Server protocol packet: command.
MYSQLND_UH_MYSQLND_PROT_RSET_HEADER_PACKET (integer)
MySQL Client Server protocol packet: result set header.
MYSQLND_UH_MYSQLND_PROT_RSET_FLD_PACKET (integer)
MySQL Client Server protocol packet: resultset field.
MYSQLND_UH_MYSQLND_PROT_ROW_PACKET (integer)
MySQL Client Server protocol packet: row.
MYSQLND_UH_MYSQLND_PROT_STATS_PACKET (integer)
MySQL Client Server protocol packet: stats.
MYSQLND_UH_MYSQLND_PREPARE_RESP_PACKET (integer)
MySQL Client Server protocol packet: prepare response.
MYSQLND_UH_MYSQLND_CHG_USER_RESP_PACKET (integer)
MySQL Client Server protocol packet: change user response.
MYSQLND_UH_MYSQLND_PROT_LAST (integer)
No practical meaning. Last entry marker of internal C data structure list.

MysqlndUhConnection::close() related

The following constants can be used to detect why a connection has been closed through MysqlndUhConnection::close().

MYSQLND_UH_MYSQLND_CLOSE_EXPLICIT (integer)
User has called mysqlnd to close the connection.
MYSQLND_UH_MYSQLND_CLOSE_IMPLICIT (integer)
Implicitly closed, for example, during garbage connection.
MYSQLND_UH_MYSQLND_CLOSE_DISCONNECTED (integer)
Connection error.
MYSQLND_UH_MYSQLND_CLOSE_LAST (integer)
No practical meaning. Last entry marker of internal C data structure list.

MysqlndUhConnection::setServerOption() related

The following constants can be used to detect which option is set through MysqlndUhConnection::setServerOption().

MYSQLND_UH_SERVER_OPTION_MULTI_STATEMENTS_ON (integer)
Option: enables multi statement support.
MYSQLND_UH_SERVER_OPTION_MULTI_STATEMENTS_OFF (integer)
Option: disables multi statement support.

MysqlndUhConnection::setClientOption() related

The following constants can be used to detect which option is set through MysqlndUhConnection::setClientOption().

MYSQLND_UH_MYSQLND_OPTION_OPT_CONNECT_TIMEOUT (integer)
Option: connection timeout.
MYSQLND_UH_MYSQLND_OPTION_OPT_COMPRESS (integer)
Option: whether the MySQL compressed protocol is to be used.
MYSQLND_UH_MYSQLND_OPTION_OPT_NAMED_PIPE (integer)
Option: named pipe to use for connection (Windows).
MYSQLND_UH_MYSQLND_OPTION_INIT_COMMAND (integer)
Option: init command to execute upon connect.
MYSQLND_UH_MYSQLND_READ_DEFAULT_FILE (integer)
Option: MySQL server default file to read upon connect.
MYSQLND_UH_MYSQLND_READ_DEFAULT_GROUP (integer)
Option: MySQL server default file group to read upon connect.
MYSQLND_UH_MYSQLND_SET_CHARSET_DIR (integer)
Option: charset description files directory.
MYSQLND_UH_MYSQLND_SET_CHARSET_NAME (integer)
Option: charset name.
MYSQLND_UH_MYSQLND_OPT_LOCAL_INFILE (integer)
Option: Whether to allow LOAD DATA LOCAL INFILE use.
MYSQLND_UH_MYSQLND_OPT_PROTOCOL (integer)
Option: supported protocol version.
MYSQLND_UH_MYSQLND_SHARED_MEMORY_BASE_NAME (integer)
Option: shared memory base name for shared memory connections.
MYSQLND_UH_MYSQLND_OPT_READ_TIMEOUT (integer)
Option: connection read timeout.
MYSQLND_UH_MYSQLND_OPT_WRITE_TIMEOUT (integer)
Option: connection write timeout.
MYSQLND_UH_MYSQLND_OPT_USE_RESULT (integer)
Option: unbuffered result sets.
MYSQLND_UH_MYSQLND_OPT_USE_REMOTE_CONNECTION (integer)
Embedded server related.
MYSQLND_UH_MYSQLND_OPT_USE_EMBEDDED_CONNECTION (integer)
Embedded server related.
MYSQLND_UH_MYSQLND_OPT_GUESS_CONNECTION (integer)
TODO
MYSQLND_UH_MYSQLND_SET_CLIENT_IP (integer)
TODO
MYSQLND_UH_MYSQLND_SECURE_AUTH (integer)
TODO
MYSQLND_UH_MYSQLND_REPORT_DATA_TRUNCATION (integer)
Option: Whether to report data truncation.
MYSQLND_UH_MYSQLND_OPT_RECONNECT (integer)
Option: Whether to reconnect automatically.
MYSQLND_UH_MYSQLND_OPT_SSL_VERIFY_SERVER_CERT (integer)
Option: TODO
MYSQLND_UH_MYSQLND_OPT_NET_CMD_BUFFER_SIZE (integer)
Option: mysqlnd network buffer size for commands.
MYSQLND_UH_MYSQLND_OPT_NET_READ_BUFFER_SIZE (integer)
Option: mysqlnd network buffer size for reading from the server.
MYSQLND_UH_MYSQLND_OPT_SSL_KEY (integer)
Option: SSL key.
MYSQLND_UH_MYSQLND_OPT_SSL_CERT (integer)
Option: SSL certificate.
MYSQLND_UH_MYSQLND_OPT_SSL_CA (integer)
Option: SSL CA.
MYSQLND_UH_MYSQLND_OPT_SSL_CAPATH (integer)
Option: Path to SSL CA.
MYSQLND_UH_MYSQLND_OPT_SSL_CIPHER (integer)
Option: SSL cipher.
MYSQLND_UH_MYSQLND_OPT_SSL_PASSPHRASE (integer)
Option: SSL passphrase.
MYSQLND_UH_SERVER_OPTION_PLUGIN_DIR (integer)
Option: server plugin directory.
MYSQLND_UH_SERVER_OPTION_DEFAULT_AUTH (integer)
Option: default authentication method.
MYSQLND_UH_SERVER_OPTION_SET_CLIENT_IP (integer)
TODO
MYSQLND_UH_MYSQLND_OPT_MAX_ALLOWED_PACKET (integer)
Option: maximum allowed packet size. Available as of PHP 5.4.0.
MYSQLND_UH_MYSQLND_OPT_AUTH_PROTOCOL (integer)
Option: TODO. Available as of PHP 5.4.0.
MYSQLND_UH_MYSQLND_OPT_INT_AND_FLOAT_NATIVE (integer)
Option: make mysqlnd return integer and float columns as long even when using the MySQL Client Server text protocol. Only available with a custom build of mysqlnd.

Other

The plugins version number can be obtained using MYSQLND_UH_VERSION or MYSQLND_UH_VERSION_ID. MYSQLND_UH_VERSION is the string representation of the numerical version number MYSQLND_UH_VERSION_ID, which is an integer such as 10000. Developers can calculate the version number as follows.

Version (part) | Example
Major*10000 | 1*10000 = 10000
Minor*100 | 0*100 = 0
Patch | 0 = 0
MYSQLND_UH_VERSION_ID | 10000

MYSQLND_UH_VERSION (string)
Plugin version string, for example, "1.0.0-alpha".
MYSQLND_UH_VERSION_ID (integer)
Plugin version number, for example, 10000.

Özkaynak Türleri
MysqlndUhConnection
mysqlnd_uh


The MysqlndUhConnection class

(PECL mysqlnd-uh >= 1.0.0-alpha)

Giriş

Sınıf Sözdizimi

MysqlndUhConnection {
/* Yöntemler */
public bool changeUser ( mysqlnd_connection $connection , string $user , string $password , string $database , bool $silent , int $passwd_len )
public string charsetName ( mysqlnd_connection $connection )
public bool close ( mysqlnd_connection $connection , int $close_type )
public bool connect ( mysqlnd_connection $connection , string $host , string $use" , string $password , string $database , int $port , string $socket , int $mysql_flags )
public __construct ( void )
public bool endPSession ( mysqlnd_connection $connection )
public string escapeString ( mysqlnd_connection $connection , string $escape_string )
public int getAffectedRows ( mysqlnd_connection $connection )
public int getErrorNumber ( mysqlnd_connection $connection )
public string getErrorString ( mysqlnd_connection $connection )
public int getFieldCount ( mysqlnd_connection $connection )
public string getHostInformation ( mysqlnd_connection $connection )
public int getLastInsertId ( mysqlnd_connection $connection )
public void getLastMessage ( mysqlnd_connection $connection )
public string getProtocolInformation ( mysqlnd_connection $connection )
public string getServerInformation ( mysqlnd_connection $connection )
public string getServerStatistics ( mysqlnd_connection $connection )
public int getServerVersion ( mysqlnd_connection $connection )
public string getSqlstate ( mysqlnd_connection $connection )
public array getStatistics ( mysqlnd_connection $connection )
public int getThreadId ( mysqlnd_connection $connection )
public int getWarningCount ( mysqlnd_connection $connection )
public bool init ( mysqlnd_connection $connection )
public bool killConnection ( mysqlnd_connection $connection , int $pid )
public array listFields ( mysqlnd_connection $connection , string $table , string $achtung_wild )
public void listMethod ( mysqlnd_connection $connection , string $query , string $achtung_wild , string $par1 )
public bool moreResults ( mysqlnd_connection $connection )
public bool nextResult ( mysqlnd_connection $connection )
public bool ping ( mysqlnd_connection $connection )
public bool query ( mysqlnd_connection $connection , string $query )
public bool queryReadResultsetHeader ( mysqlnd_connection $connection , mysqlnd_statement $mysqlnd_stmt )
public bool reapQuery ( mysqlnd_connection $connection )
public bool refreshServer ( mysqlnd_connection $connection , int $options )
public bool restartPSession ( mysqlnd_connection $connection )
public bool selectDb ( mysqlnd_connection $connection , string $database )
public bool sendClose ( mysqlnd_connection $connection )
public bool sendQuery ( mysqlnd_connection $connection , string $query )
public bool serverDumpDebugInformation ( mysqlnd_connection $connection )
public bool setAutocommit ( mysqlnd_connection $connection , int $mode )
public bool setCharset ( mysqlnd_connection $connection , string $charset )
public bool setClientOption ( mysqlnd_connection $connection , int $option , int $value )
public void setServerOption ( mysqlnd_connection $connection , int $option )
public void shutdownServer ( string $MYSQLND_UH_RES_MYSQLND_NAME , string $"level" )
public bool simpleCommand ( mysqlnd_connection $connection , int $command , string $arg , int $ok_packet , bool $silent , bool $ignore_upsert_status )
public bool simpleCommandHandleResponse ( mysqlnd_connection $connection , int $ok_packet , bool $silent , int $command , bool $ignore_upsert_status )
public bool sslSet ( mysqlnd_connection $connection , string $key , string $cert , string $ca , string $capath , string $cipher )
public resource stmtInit ( mysqlnd_connection $connection )
public resource storeResult ( mysqlnd_connection $connection )
public bool txCommit ( mysqlnd_connection $connection )
public bool txRollback ( mysqlnd_connection $connection )
public resource useResult ( mysqlnd_connection $connection )
}

İçindekiler

  • MysqlndUhConnection::changeUser — Changes the user of the specified mysqlnd database connection
  • MysqlndUhConnection::charsetName — Returns the default character set for the database connection
  • MysqlndUhConnection::close — Closes a previously opened database connection
  • MysqlndUhConnection::connect — Open a new connection to the MySQL server
  • MysqlndUhConnection::__construct — The __construct purpose
  • MysqlndUhConnection::endPSession — End a persistent connection
  • MysqlndUhConnection::escapeString — Escapes special characters in a string for use in an SQL statement, taking into account the current charset of the connection
  • MysqlndUhConnection::getAffectedRows — Gets the number of affected rows in a previous MySQL operation
  • MysqlndUhConnection::getErrorNumber — Returns the error code for the most recent function call
  • MysqlndUhConnection::getErrorString — Returns a string description of the last error
  • MysqlndUhConnection::getFieldCount — Returns the number of columns for the most recent query
  • MysqlndUhConnection::getHostInformation — Returns a string representing the type of connection used
  • MysqlndUhConnection::getLastInsertId — Returns the auto generated id used in the last query.
  • MysqlndUhConnection::getLastMessage — Retrieves information about the most recently executed query
  • MysqlndUhConnection::getProtocolInformation — Returns the version of the MySQL protocol used
  • MysqlndUhConnection::getServerInformation — Returns the version of the MySQL server
  • MysqlndUhConnection::getServerStatistics — Gets the current system status
  • MysqlndUhConnection::getServerVersion — Returns the version of the MySQL server as an integer
  • MysqlndUhConnection::getSqlstate — Returns the SQLSTATE error from previous MySQL operation
  • MysqlndUhConnection::getStatistics — Returns statistics about the client connection.
  • MysqlndUhConnection::getThreadId — Returns the thread ID for the current connection
  • MysqlndUhConnection::getWarningCount — Returns the number of warnings from the last query for the given link
  • MysqlndUhConnection::init — Initialize mysqlnd connection
  • MysqlndUhConnection::killConnection — Asks the server to kill a MySQL thread
  • MysqlndUhConnection::listFields — List MySQL table fields
  • MysqlndUhConnection::listMethod — Wrapper for assorted list commands
  • MysqlndUhConnection::moreResults — Check if there are any more query results from a multi query
  • MysqlndUhConnection::nextResult — Prepare next result from multi_query
  • MysqlndUhConnection::ping — Pings a server connection, or tries to reconnect if the connection has gone down
  • MysqlndUhConnection::query — Performs a query on the database
  • MysqlndUhConnection::queryReadResultsetHeader — Read a result set header
  • MysqlndUhConnection::reapQuery — Get result from async query
  • MysqlndUhConnection::refreshServer — Flush or reset tables and caches
  • MysqlndUhConnection::restartPSession — Restart a persistent mysqlnd connection
  • MysqlndUhConnection::selectDb — Selects the default database for database queries
  • MysqlndUhConnection::sendClose — Sends a close command to MySQL
  • MysqlndUhConnection::sendQuery — Sends a query to MySQL
  • MysqlndUhConnection::serverDumpDebugInformation — Dump debugging information into the log for the MySQL server
  • MysqlndUhConnection::setAutocommit — Turns on or off auto-committing database modifications
  • MysqlndUhConnection::setCharset — Sets the default client character set
  • MysqlndUhConnection::setClientOption — Sets a client option
  • MysqlndUhConnection::setServerOption — Sets a server option
  • MysqlndUhConnection::shutdownServer — The shutdownServer purpose
  • MysqlndUhConnection::simpleCommand — Sends a basic COM_* command
  • MysqlndUhConnection::simpleCommandHandleResponse — Process a response for a basic COM_* command send to the client
  • MysqlndUhConnection::sslSet — Used for establishing secure connections using SSL
  • MysqlndUhConnection::stmtInit — Initializes a statement and returns a resource for use with mysqli_statement::prepare
  • MysqlndUhConnection::storeResult — Transfers a result set from the last query
  • MysqlndUhConnection::txCommit — Commits the current transaction
  • MysqlndUhConnection::txRollback — Rolls back current transaction
  • MysqlndUhConnection::useResult — Initiate a result set retrieval
Öntanımlı Sabitler
MysqlndUhConnection::changeUser
mysqlnd_uh


Changes the user of the specified mysqlnd database connection

MysqlndUhConnection
MysqlndUhConnection::charsetName
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::changeUser

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::changeUser — Changes the user of the specified mysqlnd database connection

Açıklama

public bool MysqlndUhConnection::changeUser ( mysqlnd_connection $connection , string $user , string $password , string $database , bool $silent , int $passwd_len )

Changes the user of the specified mysqlnd database connection

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

user

The MySQL user name.

password

The MySQL password.

database

The MySQL database to change to.

silent

Controls if mysqlnd is allowed to emit errors or not.

passwd_len

Length of the MySQL password.

Dönen Değerler

Returns TRUE on success. Otherwise, returns FALSE

Örnekler

Örnek 1 MysqlndUhConnection::changeUser() example

<?php
class proxy extends MysqlndUhConnection {
 /* Hook mysqlnd's connection::change_user call */
 public function changeUser($res, $user, $passwd, $db, $silent, $passwd_len) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   $ret = parent::changeUser($res, $user, $passwd, $db, $silent, $passwd_len);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
/* Install proxy/hooks to be used with all future mysqlnd connection */
mysqlnd_uh_set_connection_proxy(new proxy());

/* Create mysqli connection which is using the mysqlnd library */
$mysqli = new mysqli("localhost", "root", "", "test");

/* Example of a user API call which triggers the hooked mysqlnd call */
var_dump($mysqli->change_user("root", "bar", "test"));
?>

Yukarıdaki örneğin çıktısı:

proxy::changeUser(array (
  0 => NULL,
  1 => 'root',
  2 => 'bar',
  3 => 'test',
  4 => false,
  5 => 3,
))
proxy::changeUser returns false
bool(false)

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_change_user() - Changes the user of the specified database connection

MysqlndUhConnection
MysqlndUhConnection::charsetName
MysqlndUhConnection


Returns the default character set for the database connection

MysqlndUhConnection::changeUser
MysqlndUhConnection::close
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::charsetName

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::charsetName — Returns the default character set for the database connection

Açıklama

public string MysqlndUhConnection::charsetName ( mysqlnd_connection $connection )

Returns the default character set for the database connection.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

Dönen Değerler

The default character set.

Örnekler

Örnek 1 MysqlndUhConnection::charsetName() example

<?php
class proxy extends MysqlndUhConnection {
  public function charsetName($res) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   $ret = parent::charsetName($res);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
var_dump(mysqli_character_set_name($mysqli));
?>

Yukarıdaki örneğin çıktısı:

proxy::charsetName(array (
  0 => NULL,
))
proxy::charsetName returns 'latin1'
string(6) "latin1"

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_character_set_name() - Returns the default character set for the database connection

MysqlndUhConnection::changeUser
MysqlndUhConnection::close
MysqlndUhConnection


Closes a previously opened database connection

MysqlndUhConnection::charsetName
MysqlndUhConnection::connect
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::close

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::close — Closes a previously opened database connection

Açıklama

public bool MysqlndUhConnection::close ( mysqlnd_connection $connection , int $close_type )

Closes a previously opened database connection.

Bilginize:

Failing to call the parent implementation may cause memory leaks or crash PHP. This is not considered a bug. Please, keep in mind that the mysqlnd library functions have never been designed to be exposed to the user space.

Değiştirgeler

connection

The connection to be closed. Do not modify!

close_type

Why the connection is to be closed. The value of close_type is one of MYSQLND_UH_MYSQLND_CLOSE_EXPLICIT, MYSQLND_UH_MYSQLND_CLOSE_IMPLICIT, MYSQLND_UH_MYSQLND_CLOSE_DISCONNECTED or MYSQLND_UH_MYSQLND_CLOSE_LAST. The latter should never be seen, unless the default behaviour of the mysqlnd library has been changed by a plugin.

Dönen Değerler

Returns TRUE on success. Otherwise, returns FALSE

Örnekler

Örnek 1 MysqlndUhConnection::close() example

<?php
function close_type_to_string($close_type) {
 $mapping = array(
  MYSQLND_UH_MYSQLND_CLOSE_DISCONNECTED => "MYSQLND_UH_MYSQLND_CLOSE_DISCONNECTED",
  MYSQLND_UH_MYSQLND_CLOSE_EXPLICIT => "MYSQLND_UH_MYSQLND_CLOSE_EXPLICIT",
  MYSQLND_UH_MYSQLND_CLOSE_IMPLICIT => "MYSQLND_UH_MYSQLND_CLOSE_IMPLICIT",
  MYSQLND_UH_MYSQLND_CLOSE_LAST => "MYSQLND_UH_MYSQLND_CLOSE_IMPLICIT"
 );
 return (isset($mapping[$close_type])) ? $mapping[$close_type] : 'unknown';
}

class proxy extends MysqlndUhConnection {
  public function close($res, $close_type) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   printf("close_type = %s\n", close_type_to_string($close_type));
   /* WARNING: you must call the parent */
   $ret = parent::close($res, $close_type);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->close();
?>

Yukarıdaki örneğin çıktısı:

proxy::close(array (
  0 => NULL,
  1 => 0,
))
close_type = MYSQLND_UH_MYSQLND_CLOSE_EXPLICIT
proxy::close returns true

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_close() - Closes a previously opened database connection
  • mysql_close() - MySQL bağlantısını kapatır

MysqlndUhConnection::charsetName
MysqlndUhConnection::connect
MysqlndUhConnection


Open a new connection to the MySQL server

MysqlndUhConnection::close
MysqlndUhConnection::__construct
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::connect

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::connect — Open a new connection to the MySQL server

Açıklama

public bool MysqlndUhConnection::connect ( mysqlnd_connection $connection , string $host , string $use" , string $password , string $database , int $port , string $socket , int $mysql_flags )

Open a new connection to the MySQL server.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

host

Can be either a host name or an IP address. Passing the NULL value or the string "localhost" to this parameter, the local host is assumed. When possible, pipes will be used instead of the TCP/IP protocol.

user

The MySQL user name.

password

If not provided or NULL, the MySQL server will attempt to authenticate the user against those user records which have no password only. This allows one username to be used with different permissions (depending on if a password as provided or not).

database

If provided will specify the default database to be used when performing queries.

port

Specifies the port number to attempt to connect to the MySQL server.

socket

Specifies the socket or named pipe that should be used. If NULL, mysqlnd will default to /tmp/mysql.sock.

mysql_flags

Connection options.

Dönen Değerler

Returns TRUE on success. Otherwise, returns FALSE

Örnekler

Örnek 1 MysqlndUhConnection::connect() example

<?php
class proxy extends MysqlndUhConnection {
 public function connect($res, $host, $user, $passwd, $db, $port, $socket, $mysql_flags) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   $ret = parent::connect($res, $host, $user, $passwd, $db, $port, $socket, $mysql_flags);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
?>

Yukarıdaki örneğin çıktısı:

proxy::connect(array (
  0 => NULL,
  1 => 'localhost',
  2 => 'root',
  3 => '',
  4 => 'test',
  5 => 3306,
  6 => NULL,
  7 => 131072,
))
proxy::connect returns true

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_connect() - Takma Adı: mysqli::__construct
  • mysql_connect() - MySQL Sunucusuna bir bağlantı açar

MysqlndUhConnection::close
MysqlndUhConnection::__construct
MysqlndUhConnection


The __construct purpose

MysqlndUhConnection::connect
MysqlndUhConnection::endPSession
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::__construct

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::__construct — The __construct purpose

Açıklama

public MysqlndUhConnection::__construct ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

MysqlndUhConnection::connect
MysqlndUhConnection::endPSession
MysqlndUhConnection


End a persistent connection

MysqlndUhConnection::__construct
MysqlndUhConnection::escapeString
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::endPSession

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::endPSession — End a persistent connection

Açıklama

public bool MysqlndUhConnection::endPSession ( mysqlnd_connection $connection )

End a persistent connection

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

Dönen Değerler

Returns TRUE on success. Otherwise, returns FALSE

Örnekler

Örnek 1 MysqlndUhConnection::endPSession() example

<?php
class proxy extends MysqlndUhConnection {
 public function endPSession($conn) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   $ret = parent::endPSession($conn);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("p:localhost", "root", "", "test");
$mysqli->close();
?>

Yukarıdaki örneğin çıktısı:

proxy::endPSession(array (
  0 => NULL,
))
proxy::endPSession returns true

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections

MysqlndUhConnection::__construct
MysqlndUhConnection::escapeString
MysqlndUhConnection


Escapes special characters in a string for use in an SQL statement, taking into account the current charset of the connection

MysqlndUhConnection::endPSession
MysqlndUhConnection::getAffectedRows
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::escapeString

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::escapeString — Escapes special characters in a string for use in an SQL statement, taking into account the current charset of the connection

Açıklama

public string MysqlndUhConnection::escapeString ( mysqlnd_connection $connection , string $escape_string )

Escapes special characters in a string for use in an SQL statement, taking into account the current charset of the connection.

Değiştirgeler

MYSQLND_UH_RES_MYSQLND_NAME

Mysqlnd connection handle. Do not modify!

escape_string

The string to be escaped.

Dönen Değerler

The escaped string.

Örnekler

Örnek 1 MysqlndUhConnection::escapeString() example

<?php
class proxy extends MysqlndUhConnection {
 public function escapeString($res, $string) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   $ret = parent::escapeString($res, $string);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->set_charset("latin1");
$mysqli->real_escape_string("test0'test");
?>

Yukarıdaki örneğin çıktısı:

proxy::escapeString(array (
  0 => NULL,
  1 => 'test0\'test',
))
proxy::escapeString returns 'test0\\\'test'

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_real_escape_string() - Escapes special characters in a string for use in an SQL statement, taking into account the current charset of the connection
  • mysql_real_escape_string() - Escapes special characters in a string for use in an SQL statement

MysqlndUhConnection::endPSession
MysqlndUhConnection::getAffectedRows
MysqlndUhConnection


Gets the number of affected rows in a previous MySQL operation

MysqlndUhConnection::escapeString
MysqlndUhConnection::getErrorNumber
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::getAffectedRows

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getAffectedRows — Gets the number of affected rows in a previous MySQL operation

Açıklama

public int MysqlndUhConnection::getAffectedRows ( mysqlnd_connection $connection )

Gets the number of affected rows in a previous MySQL operation.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

Dönen Değerler

Number of affected rows.

Örnekler

Örnek 1 MysqlndUhConnection::getAffectedRows() example

<?php
class proxy extends MysqlndUhConnection {
 public function getAffectedRows($res) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   $ret = parent::getAffectedRows($res);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT)");
$mysqli->query("INSERT INTO test(id) VALUES (1)");
var_dump($mysqli->affected_rows);
?>

Yukarıdaki örneğin çıktısı:

proxy::getAffectedRows(array (
  0 => NULL,
))
proxy::getAffectedRows returns 1
int(1)

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_affected_rows() - Gets the number of affected rows in a previous MySQL operation
  • mysql_affected_rows() - Önceki MySQL işleminde etkilenen satırların sayısını al

MysqlndUhConnection::escapeString
MysqlndUhConnection::getErrorNumber
MysqlndUhConnection


Returns the error code for the most recent function call

MysqlndUhConnection::getAffectedRows
MysqlndUhConnection::getErrorString
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::getErrorNumber

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getErrorNumber — Returns the error code for the most recent function call

Açıklama

public int MysqlndUhConnection::getErrorNumber ( mysqlnd_connection $connection )

Returns the error code for the most recent function call.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

Dönen Değerler

Error code for the most recent function call.

Örnekler

MysqlndUhConnection::getErrorNumber() is not only executed after the invocation of a user space API call which maps directly to it but also called internally.

Örnek 1 MysqlndUhConnection::getErrorNumber() example

<?php
class proxy extends MysqlndUhConnection {
 public function getErrorNumber($res) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   $ret = parent::getErrorNumber($res);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

printf("connect...\n");
$mysqli = new mysqli("localhost", "root", "", "test");
printf("query...\n");
$mysqli->query("PLEASE_LET_THIS_BE_INVALID_SQL");
printf("errno...\n");
var_dump($mysqli->errno);
printf("close...\n");
$mysqli->close();
?>

Yukarıdaki örneğin çıktısı:

connect...
proxy::getErrorNumber(array (
  0 => NULL,
))
proxy::getErrorNumber returns 0
query...
errno...
proxy::getErrorNumber(array (
  0 => NULL,
))
proxy::getErrorNumber returns 1064
int(1064)
close...

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • MysqlndUhConnection::getErrorString() - Returns a string description of the last error
  • mysqli_errno() - Returns the error code for the most recent function call
  • mysql_errno() - Returns the numerical value of the error message from previous MySQL operation

MysqlndUhConnection::getAffectedRows
MysqlndUhConnection::getErrorString
MysqlndUhConnection


Returns a string description of the last error

MysqlndUhConnection::getErrorNumber
MysqlndUhConnection::getFieldCount
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::getErrorString

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getErrorString — Returns a string description of the last error

Açıklama

public string MysqlndUhConnection::getErrorString ( mysqlnd_connection $connection )

Returns a string description of the last error.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

Dönen Değerler

Error string for the most recent function call.

Örnekler

MysqlndUhConnection::getErrorString() is not only executed after the invocation of a user space API call which maps directly to it but also called internally.

Örnek 1 MysqlndUhConnection::getErrorString() example

<?php
class proxy extends MysqlndUhConnection {
 public function getErrorString($res) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   $ret = parent::getErrorString($res);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

printf("connect...\n");
$mysqli = new mysqli("localhost", "root", "", "test");
printf("query...\n");
$mysqli->query("WILL_I_EVER_LEARN_SQL?");
printf("errno...\n");
var_dump($mysqli->error);
printf("close...\n");
$mysqli->close();
?>

Yukarıdaki örneğin çıktısı:

connect...
proxy::getErrorString(array (
  0 => NULL,
))
proxy::getErrorString returns ''
query...
errno...
proxy::getErrorString(array (
  0 => NULL,
))
proxy::getErrorString returns 'You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near \'WILL_I_EVER_LEARN_SQL?\' at line 1'
string(168) "You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'WILL_I_EVER_LEARN_SQL?' at line 1"
close...

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • MysqlndUhConnection::getErrorNumber() - Returns the error code for the most recent function call
  • mysqli_error() - Returns a string description of the last error
  • mysql_error() - Returns the text of the error message from previous MySQL operation

MysqlndUhConnection::getErrorNumber
MysqlndUhConnection::getFieldCount
MysqlndUhConnection


Returns the number of columns for the most recent query

MysqlndUhConnection::getErrorString
MysqlndUhConnection::getHostInformation
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::getFieldCount

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getFieldCount — Returns the number of columns for the most recent query

Açıklama

public int MysqlndUhConnection::getFieldCount ( mysqlnd_connection $connection )

Returns the number of columns for the most recent query.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

Dönen Değerler

Number of columns.

Örnekler

MysqlndUhConnection::getFieldCount() is not only executed after the invocation of a user space API call which maps directly to it but also called internally.

Örnek 1 MysqlndUhConnection::getFieldCount() example

<?php
class proxy extends MysqlndUhConnection {
 public function getFieldCount($res) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   $ret = parent::getFieldCount($res);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->query("WILL_I_EVER_LEARN_SQL?");
var_dump($mysqli->field_count);
$mysqli->query("SELECT 1, 2, 3 FROM DUAL");
var_dump($mysqli->field_count);
?>

Yukarıdaki örneğin çıktısı:

proxy::getFieldCount(array (
  0 => NULL,
))
proxy::getFieldCount returns 0
int(0)
proxy::getFieldCount(array (
  0 => NULL,
))
proxy::getFieldCount returns 3
proxy::getFieldCount(array (
  0 => NULL,
))
proxy::getFieldCount returns 3
int(3)

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_field_count() - Returns the number of columns for the most recent query

MysqlndUhConnection::getErrorString
MysqlndUhConnection::getHostInformation
MysqlndUhConnection


Returns a string representing the type of connection used

MysqlndUhConnection::getFieldCount
MysqlndUhConnection::getLastInsertId
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::getHostInformation

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getHostInformation — Returns a string representing the type of connection used

Açıklama

public string MysqlndUhConnection::getHostInformation ( mysqlnd_connection $connection )

Returns a string representing the type of connection used.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

Dönen Değerler

Connection description.

Örnekler

Örnek 1 MysqlndUhConnection::getHostInformation() example

<?php
class proxy extends MysqlndUhConnection {
 public function getHostInformation($res) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   $ret = parent::getHostInformation($res);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
var_dump($mysqli->host_info);
?>

Yukarıdaki örneğin çıktısı:

proxy::getHostInformation(array (
  0 => NULL,
))
proxy::getHostInformation returns 'Localhost via UNIX socket'
string(25) "Localhost via UNIX socket"

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_get_host_info() - Returns a string representing the type of connection used
  • mysql_get_host_info() - MySQL konak bilgisini al

MysqlndUhConnection::getFieldCount
MysqlndUhConnection::getLastInsertId
MysqlndUhConnection


Returns the auto generated id used in the last query.

MysqlndUhConnection::getHostInformation
MysqlndUhConnection::getLastMessage
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::getLastInsertId

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getLastInsertId — Returns the auto generated id used in the last query.

Açıklama

public int MysqlndUhConnection::getLastInsertId ( mysqlnd_connection $connection )

Returns the auto generated id used in the last query.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

Dönen Değerler

Last insert id.

Örnekler

Örnek 1 MysqlndUhConnection::getLastInsertId() example

<?php
class proxy extends MysqlndUhConnection {
 public function getLastInsertId($res) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   $ret = parent::getLastInsertId($res);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->query("DROP TABLE IF EXISTS test");
$mysqli->query("CREATE TABLE test(id INT AUTO_INCREMENT PRIMARY KEY, col VARCHAR(255))");
$mysqli->query("INSERT INTO test(col) VALUES ('a')");
var_dump($mysqli->insert_id);
?>

Yukarıdaki örneğin çıktısı:

proxy::getLastInsertId(array (
  0 => NULL,
))
proxy::getLastInsertId returns 1
int(1)

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_insert_id() - Returns the auto generated id used in the latest query
  • mysql_insert_id() - Get the ID generated in the last query

MysqlndUhConnection::getHostInformation
MysqlndUhConnection::getLastMessage
MysqlndUhConnection


Retrieves information about the most recently executed query

MysqlndUhConnection::getLastInsertId
MysqlndUhConnection::getProtocolInformation
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::getLastMessage

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getLastMessage — Retrieves information about the most recently executed query

Açıklama

public void MysqlndUhConnection::getLastMessage ( mysqlnd_connection $connection )

Retrieves information about the most recently executed query.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

Dönen Değerler

Last message. Trying to return a string longer than 511 bytes will cause an error of the type E_WARNING and result in the string being truncated.

Örnekler

Örnek 1 MysqlndUhConnection::getLastMessage() example

<?php
class proxy extends MysqlndUhConnection {
 public function getLastMessage($res) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   $ret = parent::getLastMessage($res);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
var_dump($mysqli->info);
$mysqli->query("DROP TABLE IF EXISTS test");
var_dump($mysqli->info);
?>

Yukarıdaki örneğin çıktısı:

proxy::getLastMessage(array (
  0 => NULL,
))
proxy::getLastMessage returns ''
string(0) ""
proxy::getLastMessage(array (
  0 => NULL,
))
proxy::getLastMessage returns ''
string(0) ""

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_info() - Retrieves information about the most recently executed query
  • mysql_info() - En son sorgu hakkında bilgi al

MysqlndUhConnection::getLastInsertId
MysqlndUhConnection::getProtocolInformation
MysqlndUhConnection


Returns the version of the MySQL protocol used

MysqlndUhConnection::getLastMessage
MysqlndUhConnection::getServerInformation
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::getProtocolInformation

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getProtocolInformation — Returns the version of the MySQL protocol used

Açıklama

public string MysqlndUhConnection::getProtocolInformation ( mysqlnd_connection $connection )

Returns the version of the MySQL protocol used.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

Dönen Değerler

The protocol version.

Örnekler

Örnek 1 MysqlndUhConnection::getProtocolInformation() example

<?php
class proxy extends MysqlndUhConnection {
 public function getProtocolInformation($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::getProtocolInformation($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
var_dump($mysqli->protocol_version);
?>

Yukarıdaki örneğin çıktısı:

proxy::getProtocolInformation(array (
  0 => NULL,
))
proxy::getProtocolInformation returns 10
int(10)

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_get_proto_info() - Returns the version of the MySQL protocol used
  • mysql_get_proto_info() - MySQL protokol sürüm bilgisini al

MysqlndUhConnection::getLastMessage
MysqlndUhConnection::getServerInformation
MysqlndUhConnection


Returns the version of the MySQL server

MysqlndUhConnection::getProtocolInformation
MysqlndUhConnection::getServerStatistics
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::getServerInformation

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getServerInformation — Returns the version of the MySQL server

Açıklama

public string MysqlndUhConnection::getServerInformation ( mysqlnd_connection $connection )

Returns the version of the MySQL server.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

Dönen Değerler

The server version.

Örnekler

Örnek 1 MysqlndUhConnection::getServerInformation() example

<?php
class proxy extends MysqlndUhConnection {
 public function getServerInformation($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::getServerInformation($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
var_dump($mysqli->server_info);
?>

Yukarıdaki örneğin çıktısı:

proxy::getServerInformation(array (
  0 => NULL,
))
proxy::getServerInformation returns '5.1.45-debug-log'
string(16) "5.1.45-debug-log"

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_get_server_info() - Returns the version of the MySQL server
  • mysql_get_server_info() - MySQL sunucu bilgisini al

MysqlndUhConnection::getProtocolInformation
MysqlndUhConnection::getServerStatistics
MysqlndUhConnection


Gets the current system status

MysqlndUhConnection::getServerInformation
MysqlndUhConnection::getServerVersion
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::getServerStatistics

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getServerStatistics — Gets the current system status

Açıklama

public string MysqlndUhConnection::getServerStatistics ( mysqlnd_connection $connection )

Gets the current system status.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

Dönen Değerler

The system status message.

Örnekler

Örnek 1 MysqlndUhConnection::getServerStatistics() example

<?php
class proxy extends MysqlndUhConnection {
 public function getServerStatistics($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::getServerStatistics($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
var_dump(mysqli_stat($mysqli));
?>

Yukarıdaki örneğin çıktısı:

proxy::getServerStatistics(array (
  0 => NULL,
))
proxy::getServerStatistics returns 'Uptime: 2059995  Threads: 1  Questions: 126157  Slow queries: 0  Opens: 6377  Flush tables: 1  Open tables: 18  Queries per second avg: 0.61'
string(140) "Uptime: 2059995  Threads: 1  Questions: 126157  Slow queries: 0  Opens: 6377  Flush tables: 1  Open tables: 18  Queries per second avg: 0.61"

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_stat() - Gets the current system status
  • mysql_stat() - Geçerli sunucu durumunu döndürür

MysqlndUhConnection::getServerInformation
MysqlndUhConnection::getServerVersion
MysqlndUhConnection


Returns the version of the MySQL server as an integer

MysqlndUhConnection::getServerStatistics
MysqlndUhConnection::getSqlstate
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::getServerVersion

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getServerVersion — Returns the version of the MySQL server as an integer

Açıklama

public int MysqlndUhConnection::getServerVersion ( mysqlnd_connection $connection )

Returns the version of the MySQL server as an integer.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

Dönen Değerler

The MySQL version.

Örnekler

Örnek 1 MysqlndUhConnection::getServerVersion() example

<?php
class proxy extends MysqlndUhConnection {
 public function getServerVersion($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::getServerVersion($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
var_dump($mysqli->server_version);
?>

Yukarıdaki örneğin çıktısı:

proxy::getServerVersion(array (
  0 => NULL,
))
proxy::getServerVersion returns 50145
int(50145)

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_get_server_version() - Returns the version of the MySQL server as an integer
  • mysql_get_server_version()

MysqlndUhConnection::getServerStatistics
MysqlndUhConnection::getSqlstate
MysqlndUhConnection


Returns the SQLSTATE error from previous MySQL operation

MysqlndUhConnection::getServerVersion
MysqlndUhConnection::getStatistics
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::getSqlstate

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getSqlstate — Returns the SQLSTATE error from previous MySQL operation

Açıklama

public string MysqlndUhConnection::getSqlstate ( mysqlnd_connection $connection )

Returns the SQLSTATE error from previous MySQL operation.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

Dönen Değerler

The SQLSTATE code.

Örnekler

Örnek 1 MysqlndUhConnection::getSqlstate() example

<?php
class proxy extends MysqlndUhConnection {
 public function getSqlstate($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::getSqlstate($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
var_dump($mysqli->sqlstate);
$mysqli->query("AN_INVALID_REQUEST_TO_PROVOKE_AN_ERROR");
var_dump($mysqli->sqlstate);
?>

Yukarıdaki örneğin çıktısı:

proxy::getSqlstate(array (
  0 => NULL,
))
proxy::getSqlstate returns '00000'
string(5) "00000"
proxy::getSqlstate(array (
  0 => NULL,
))
proxy::getSqlstate returns '42000'
string(5) "42000"

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_sql_state()

MysqlndUhConnection::getServerVersion
MysqlndUhConnection::getStatistics
MysqlndUhConnection


Returns statistics about the client connection.

MysqlndUhConnection::getSqlstate
MysqlndUhConnection::getThreadId
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::getStatistics

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getStatistics — Returns statistics about the client connection.

Açıklama

public array MysqlndUhConnection::getStatistics ( mysqlnd_connection $connection )

Returns statistics about the client connection.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

Dönen Değerler

Connection statistics collected by mysqlnd.

Örnekler

Örnek 1 MysqlndUhConnection::getStatistics() example

<?php
class proxy extends MysqlndUhConnection {
 public function getStatistics($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::getStatistics($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
var_dump($mysqli->get_connection_stats());
?>

Yukarıdaki örneğin çıktısı:

proxy::getStatistics(array (
  0 => NULL,
))
proxy::getStatistics returns array (
  'bytes_sent' => '73',
  'bytes_received' => '77',
  'packets_sent' => '2',
  'packets_received' => '2',
  'protocol_overhead_in' => '8',
  'protocol_overhead_out' => '8',
  'bytes_received_ok_packet' => '0',
  'bytes_received_eof_packet' => '0',
  'bytes_received_rset_header_packet' => '0',
  'bytes_received_rset_field_meta_packet' => '0',
  'bytes_received_rset_row_packet' => '0',
  'bytes_received_prepare_response_packet' => '0',
  'bytes_received_change_user_packet' => '0',
  'packets_sent_command' => '0',
  'packets_received_ok' => '0',
  'packets_received_eof' => '0',
  'packets_received_rset_header' => '0',
  'packets_received_rset_field_meta' => '0',
  'packets_received_rset_row' => '0',
  'packets_received_prepare_response' => '0',
  'packets_received_change_user' => '0',
  'result_set_queries' => '0',
  'non_result_set_queries' => '0',
  'no_index_used' => '0',
  'bad_index_used' => '0',
  'slow_queries' => '0',
  'buffered_sets' => '0',
  'unbuffered_sets' => '0',
  'ps_buffered_sets' => '0',
  'ps_unbuffered_sets' => '0',
  'flushed_normal_sets' => '0',
  'flushed_ps_sets' => '0',
  'ps_prepared_never_executed' => '0',
  'ps_prepared_once_executed' => '0',
  'rows_fetched_from_server_normal' => '0',
  'rows_fetched_from_server_ps' => '0',
  'rows_buffered_from_client_normal' => '0',
  'rows_buffered_from_client_ps' => '0',
  'rows_fetched_from_client_normal_buffered' => '0',
  'rows_fetched_from_client_normal_unbuffered' => '0',
  'rows_fetched_from_client_ps_buffered' => '0',
  'rows_fetched_from_client_ps_unbuffered' => '0',
  'rows_fetched_from_client_ps_cursor' => '0',
  'rows_affected_normal' => '0',
  'rows_affected_ps' => '0',
  'rows_skipped_normal' => '0',
  'rows_skipped_ps' => '0',
  'copy_on_write_saved' => '0',
  'copy_on_write_performed' => '0',
  'command_buffer_too_small' => '0',
  'connect_success' => '1',
  'connect_failure' => '0',
  'connection_reused' => '0',
  'reconnect' => '0',
  'pconnect_success' => '0',
  'active_connections' => '1',
  'active_persistent_connections' => '0',
  'explicit_close' => '0',
  'implicit_close' => '0',
  'disconnect_close' => '0',
  'in_middle_of_command_close' => '0',
  'explicit_free_result' => '0',
  'implicit_free_result' => '0',
  'explicit_stmt_close' => '0',
  'implicit_stmt_close' => '0',
  'mem_emalloc_count' => '0',
  'mem_emalloc_amount' => '0',
  'mem_ecalloc_count' => '0',
  'mem_ecalloc_amount' => '0',
  'mem_erealloc_count' => '0',
  'mem_erealloc_amount' => '0',
  'mem_efree_count' => '0',
  'mem_efree_amount' => '0',
  'mem_malloc_count' => '0',
  'mem_malloc_amount' => '0',
  'mem_calloc_count' => '0',
  'mem_calloc_amount' => '0',
  'mem_realloc_count' => '0',
  'mem_realloc_amount' => '0',
  'mem_free_count' => '0',
  'mem_free_amount' => '0',
  'mem_estrndup_count' => '0',
  'mem_strndup_count' => '0',
  'mem_estndup_count' => '0',
  'mem_strdup_count' => '0',
  'proto_text_fetched_null' => '0',
  'proto_text_fetched_bit' => '0',
  'proto_text_fetched_tinyint' => '0',
  'proto_text_fetched_short' => '0',
  'proto_text_fetched_int24' => '0',
  'proto_text_fetched_int' => '0',
  'proto_text_fetched_bigint' => '0',
  'proto_text_fetched_decimal' => '0',
  'proto_text_fetched_float' => '0',
  'proto_text_fetched_double' => '0',
  'proto_text_fetched_date' => '0',
  'proto_text_fetched_year' => '0',
  'proto_text_fetched_time' => '0',
  'proto_text_fetched_datetime' => '0',
  'proto_text_fetched_timestamp' => '0',
  'proto_text_fetched_string' => '0',
  'proto_text_fetched_blob' => '0',
  'proto_text_fetched_enum' => '0',
  'proto_text_fetched_set' => '0',
  'proto_text_fetched_geometry' => '0',
  'proto_text_fetched_other' => '0',
  'proto_binary_fetched_null' => '0',
  'proto_binary_fetched_bit' => '0',
  'proto_binary_fetched_tinyint' => '0',
  'proto_binary_fetched_short' => '0',
  'proto_binary_fetched_int24' => '0',
  'proto_binary_fetched_int' => '0',
  'proto_binary_fetched_bigint' => '0',
  'proto_binary_fetched_decimal' => '0',
  'proto_binary_fetched_float' => '0',
  'proto_binary_fetched_double' => '0',
  'proto_binary_fetched_date' => '0',
  'proto_binary_fetched_year' => '0',
  'proto_binary_fetched_time' => '0',
  'proto_binary_fetched_datetime' => '0',
  'proto_binary_fetched_timestamp' => '0',
  'proto_binary_fetched_string' => '0',
  'proto_binary_fetched_blob' => '0',
  'proto_binary_fetched_enum' => '0',
  'proto_binary_fetched_set' => '0',
  'proto_binary_fetched_geometry' => '0',
  'proto_binary_fetched_other' => '0',
  'init_command_executed_count' => '0',
  'init_command_failed_count' => '0',
  'com_quit' => '0',
  'com_init_db' => '0',
  'com_query' => '0',
  'com_field_list' => '0',
  'com_create_db' => '0',
  'com_drop_db' => '0',
  'com_refresh' => '0',
  'com_shutdown' => '0',
  'com_statistics' => '0',
  'com_process_info' => '0',
  'com_connect' => '0',
  'com_process_kill' => '0',
  'com_debug' => '0',
  'com_ping' => '0',
  'com_time' => '0',
  'com_delayed_insert' => '0',
  'com_change_user' => '0',
  'com_binlog_dump' => '0',
  'com_table_dump' => '0',
  'com_connect_out' => '0',
  'com_register_slave' => '0',
  'com_stmt_prepare' => '0',
  'com_stmt_execute' => '0',
  'com_stmt_send_long_data' => '0',
  'com_stmt_close' => '0',
  'com_stmt_reset' => '0',
  'com_stmt_set_option' => '0',
  'com_stmt_fetch' => '0',
  'com_deamon' => '0',
  'bytes_received_real_data_normal' => '0',
  'bytes_received_real_data_ps' => '0',
)
array(160) {
  ["bytes_sent"]=>
  string(2) "73"
  ["bytes_received"]=>
  string(2) "77"
  ["packets_sent"]=>
  string(1) "2"
  ["packets_received"]=>
  string(1) "2"
  ["protocol_overhead_in"]=>
  string(1) "8"
  ["protocol_overhead_out"]=>
  string(1) "8"
  ["bytes_received_ok_packet"]=>
  string(1) "0"
  ["bytes_received_eof_packet"]=>
  string(1) "0"
  ["bytes_received_rset_header_packet"]=>
  string(1) "0"
  ["bytes_received_rset_field_meta_packet"]=>
  string(1) "0"
  ["bytes_received_rset_row_packet"]=>
  string(1) "0"
  ["bytes_received_prepare_response_packet"]=>
  string(1) "0"
  ["bytes_received_change_user_packet"]=>
  string(1) "0"
  ["packets_sent_command"]=>
  string(1) "0"
  ["packets_received_ok"]=>
  string(1) "0"
  ["packets_received_eof"]=>
  string(1) "0"
  ["packets_received_rset_header"]=>
  string(1) "0"
  ["packets_received_rset_field_meta"]=>
  string(1) "0"
  ["packets_received_rset_row"]=>
  string(1) "0"
  ["packets_received_prepare_response"]=>
  string(1) "0"
  ["packets_received_change_user"]=>
  string(1) "0"
  ["result_set_queries"]=>
  string(1) "0"
  ["non_result_set_queries"]=>
  string(1) "0"
  ["no_index_used"]=>
  string(1) "0"
  ["bad_index_used"]=>
  string(1) "0"
  ["slow_queries"]=>
  string(1) "0"
  ["buffered_sets"]=>
  string(1) "0"
  ["unbuffered_sets"]=>
  string(1) "0"
  ["ps_buffered_sets"]=>
  string(1) "0"
  ["ps_unbuffered_sets"]=>
  string(1) "0"
  ["flushed_normal_sets"]=>
  string(1) "0"
  ["flushed_ps_sets"]=>
  string(1) "0"
  ["ps_prepared_never_executed"]=>
  string(1) "0"
  ["ps_prepared_once_executed"]=>
  string(1) "0"
  ["rows_fetched_from_server_normal"]=>
  string(1) "0"
  ["rows_fetched_from_server_ps"]=>
  string(1) "0"
  ["rows_buffered_from_client_normal"]=>
  string(1) "0"
  ["rows_buffered_from_client_ps"]=>
  string(1) "0"
  ["rows_fetched_from_client_normal_buffered"]=>
  string(1) "0"
  ["rows_fetched_from_client_normal_unbuffered"]=>
  string(1) "0"
  ["rows_fetched_from_client_ps_buffered"]=>
  string(1) "0"
  ["rows_fetched_from_client_ps_unbuffered"]=>
  string(1) "0"
  ["rows_fetched_from_client_ps_cursor"]=>
  string(1) "0"
  ["rows_affected_normal"]=>
  string(1) "0"
  ["rows_affected_ps"]=>
  string(1) "0"
  ["rows_skipped_normal"]=>
  string(1) "0"
  ["rows_skipped_ps"]=>
  string(1) "0"
  ["copy_on_write_saved"]=>
  string(1) "0"
  ["copy_on_write_performed"]=>
  string(1) "0"
  ["command_buffer_too_small"]=>
  string(1) "0"
  ["connect_success"]=>
  string(1) "1"
  ["connect_failure"]=>
  string(1) "0"
  ["connection_reused"]=>
  string(1) "0"
  ["reconnect"]=>
  string(1) "0"
  ["pconnect_success"]=>
  string(1) "0"
  ["active_connections"]=>
  string(1) "1"
  ["active_persistent_connections"]=>
  string(1) "0"
  ["explicit_close"]=>
  string(1) "0"
  ["implicit_close"]=>
  string(1) "0"
  ["disconnect_close"]=>
  string(1) "0"
  ["in_middle_of_command_close"]=>
  string(1) "0"
  ["explicit_free_result"]=>
  string(1) "0"
  ["implicit_free_result"]=>
  string(1) "0"
  ["explicit_stmt_close"]=>
  string(1) "0"
  ["implicit_stmt_close"]=>
  string(1) "0"
  ["mem_emalloc_count"]=>
  string(1) "0"
  ["mem_emalloc_amount"]=>
  string(1) "0"
  ["mem_ecalloc_count"]=>
  string(1) "0"
  ["mem_ecalloc_amount"]=>
  string(1) "0"
  ["mem_erealloc_count"]=>
  string(1) "0"
  ["mem_erealloc_amount"]=>
  string(1) "0"
  ["mem_efree_count"]=>
  string(1) "0"
  ["mem_efree_amount"]=>
  string(1) "0"
  ["mem_malloc_count"]=>
  string(1) "0"
  ["mem_malloc_amount"]=>
  string(1) "0"
  ["mem_calloc_count"]=>
  string(1) "0"
  ["mem_calloc_amount"]=>
  string(1) "0"
  ["mem_realloc_count"]=>
  string(1) "0"
  ["mem_realloc_amount"]=>
  string(1) "0"
  ["mem_free_count"]=>
  string(1) "0"
  ["mem_free_amount"]=>
  string(1) "0"
  ["mem_estrndup_count"]=>
  string(1) "0"
  ["mem_strndup_count"]=>
  string(1) "0"
  ["mem_estndup_count"]=>
  string(1) "0"
  ["mem_strdup_count"]=>
  string(1) "0"
  ["proto_text_fetched_null"]=>
  string(1) "0"
  ["proto_text_fetched_bit"]=>
  string(1) "0"
  ["proto_text_fetched_tinyint"]=>
  string(1) "0"
  ["proto_text_fetched_short"]=>
  string(1) "0"
  ["proto_text_fetched_int24"]=>
  string(1) "0"
  ["proto_text_fetched_int"]=>
  string(1) "0"
  ["proto_text_fetched_bigint"]=>
  string(1) "0"
  ["proto_text_fetched_decimal"]=>
  string(1) "0"
  ["proto_text_fetched_float"]=>
  string(1) "0"
  ["proto_text_fetched_double"]=>
  string(1) "0"
  ["proto_text_fetched_date"]=>
  string(1) "0"
  ["proto_text_fetched_year"]=>
  string(1) "0"
  ["proto_text_fetched_time"]=>
  string(1) "0"
  ["proto_text_fetched_datetime"]=>
  string(1) "0"
  ["proto_text_fetched_timestamp"]=>
  string(1) "0"
  ["proto_text_fetched_string"]=>
  string(1) "0"
  ["proto_text_fetched_blob"]=>
  string(1) "0"
  ["proto_text_fetched_enum"]=>
  string(1) "0"
  ["proto_text_fetched_set"]=>
  string(1) "0"
  ["proto_text_fetched_geometry"]=>
  string(1) "0"
  ["proto_text_fetched_other"]=>
  string(1) "0"
  ["proto_binary_fetched_null"]=>
  string(1) "0"
  ["proto_binary_fetched_bit"]=>
  string(1) "0"
  ["proto_binary_fetched_tinyint"]=>
  string(1) "0"
  ["proto_binary_fetched_short"]=>
  string(1) "0"
  ["proto_binary_fetched_int24"]=>
  string(1) "0"
  ["proto_binary_fetched_int"]=>
  string(1) "0"
  ["proto_binary_fetched_bigint"]=>
  string(1) "0"
  ["proto_binary_fetched_decimal"]=>
  string(1) "0"
  ["proto_binary_fetched_float"]=>
  string(1) "0"
  ["proto_binary_fetched_double"]=>
  string(1) "0"
  ["proto_binary_fetched_date"]=>
  string(1) "0"
  ["proto_binary_fetched_year"]=>
  string(1) "0"
  ["proto_binary_fetched_time"]=>
  string(1) "0"
  ["proto_binary_fetched_datetime"]=>
  string(1) "0"
  ["proto_binary_fetched_timestamp"]=>
  string(1) "0"
  ["proto_binary_fetched_string"]=>
  string(1) "0"
  ["proto_binary_fetched_blob"]=>
  string(1) "0"
  ["proto_binary_fetched_enum"]=>
  string(1) "0"
  ["proto_binary_fetched_set"]=>
  string(1) "0"
  ["proto_binary_fetched_geometry"]=>
  string(1) "0"
  ["proto_binary_fetched_other"]=>
  string(1) "0"
  ["init_command_executed_count"]=>
  string(1) "0"
  ["init_command_failed_count"]=>
  string(1) "0"
  ["com_quit"]=>
  string(1) "0"
  ["com_init_db"]=>
  string(1) "0"
  ["com_query"]=>
  string(1) "0"
  ["com_field_list"]=>
  string(1) "0"
  ["com_create_db"]=>
  string(1) "0"
  ["com_drop_db"]=>
  string(1) "0"
  ["com_refresh"]=>
  string(1) "0"
  ["com_shutdown"]=>
  string(1) "0"
  ["com_statistics"]=>
  string(1) "0"
  ["com_process_info"]=>
  string(1) "0"
  ["com_connect"]=>
  string(1) "0"
  ["com_process_kill"]=>
  string(1) "0"
  ["com_debug"]=>
  string(1) "0"
  ["com_ping"]=>
  string(1) "0"
  ["com_time"]=>
  string(1) "0"
  ["com_delayed_insert"]=>
  string(1) "0"
  ["com_change_user"]=>
  string(1) "0"
  ["com_binlog_dump"]=>
  string(1) "0"
  ["com_table_dump"]=>
  string(1) "0"
  ["com_connect_out"]=>
  string(1) "0"
  ["com_register_slave"]=>
  string(1) "0"
  ["com_stmt_prepare"]=>
  string(1) "0"
  ["com_stmt_execute"]=>
  string(1) "0"
  ["com_stmt_send_long_data"]=>
  string(1) "0"
  ["com_stmt_close"]=>
  string(1) "0"
  ["com_stmt_reset"]=>
  string(1) "0"
  ["com_stmt_set_option"]=>
  string(1) "0"
  ["com_stmt_fetch"]=>
  string(1) "0"
  ["com_deamon"]=>
  string(1) "0"
  ["bytes_received_real_data_normal"]=>
  string(1) "0"
  ["bytes_received_real_data_ps"]=>
  string(1) "0"
}

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_get_connection_stats() - Returns statistics about the client connection

MysqlndUhConnection::getSqlstate
MysqlndUhConnection::getThreadId
MysqlndUhConnection


Returns the thread ID for the current connection

MysqlndUhConnection::getStatistics
MysqlndUhConnection::getWarningCount
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::getThreadId

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getThreadId — Returns the thread ID for the current connection

Açıklama

public int MysqlndUhConnection::getThreadId ( mysqlnd_connection $connection )

Returns the thread ID for the current connection.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

Dönen Değerler

Connection thread id.

Örnekler

Örnek 1 MysqlndUhConnection::getThreadId() example

<?php
class proxy extends MysqlndUhConnection {
 public function getThreadId($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::getThreadId($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
var_dump($mysqli->thread_id);
?>

Yukarıdaki örneğin çıktısı:

proxy::getThreadId(array (
  0 => NULL,
))
proxy::getThreadId returns 27646
int(27646)

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_thread_id() - Returns the thread ID for the current connection
  • mysql_thread_id() - Geçerli evre numarasını döndür

MysqlndUhConnection::getStatistics
MysqlndUhConnection::getWarningCount
MysqlndUhConnection


Returns the number of warnings from the last query for the given link

MysqlndUhConnection::getThreadId
MysqlndUhConnection::init
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::getWarningCount

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::getWarningCount — Returns the number of warnings from the last query for the given link

Açıklama

public int MysqlndUhConnection::getWarningCount ( mysqlnd_connection $connection )

Returns the number of warnings from the last query for the given link.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

Dönen Değerler

Number of warnings.

Örnekler

Örnek 1 MysqlndUhConnection::getWarningCount() example

<?php
class proxy extends MysqlndUhConnection {
 public function getWarningCount($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::getWarningCount($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
var_dump($mysqli->warning_count);
?>

Yukarıdaki örneğin çıktısı:

proxy::getWarningCount(array (
  0 => NULL,
))
proxy::getWarningCount returns 0
int(0)

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_warning_count() - Returns the number of warnings from the last query for the given link

MysqlndUhConnection::getThreadId
MysqlndUhConnection::init
MysqlndUhConnection


Initialize mysqlnd connection

MysqlndUhConnection::getWarningCount
MysqlndUhConnection::killConnection
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::init

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::init — Initialize mysqlnd connection

Açıklama

public bool MysqlndUhConnection::init ( mysqlnd_connection $connection )

Initialize mysqlnd connection. This is an mysqlnd internal call to initialize the connection object.

Bilginize:

Failing to call the parent implementation may cause memory leaks or crash PHP. This is not considered a bug. Please, keep in mind that the mysqlnd library functions have never been designed to be exposed to the user space.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

Dönen Değerler

Returns TRUE on success. Otherwise, returns FALSE

Örnekler

Örnek 1 MysqlndUhConnection::init() example

<?php
class proxy extends MysqlndUhConnection {
 public function init($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::init($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
?>

Yukarıdaki örneğin çıktısı:

proxy::init(array (
  0 => NULL,
))
proxy::init returns true

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections

MysqlndUhConnection::getWarningCount
MysqlndUhConnection::killConnection
MysqlndUhConnection


Asks the server to kill a MySQL thread

MysqlndUhConnection::init
MysqlndUhConnection::listFields
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::killConnection

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::killConnection — Asks the server to kill a MySQL thread

Açıklama

public bool MysqlndUhConnection::killConnection ( mysqlnd_connection $connection , int $pid )

Asks the server to kill a MySQL thread.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

pid

Thread Id of the connection to be killed.

Dönen Değerler

Returns TRUE on success. Otherwise, returns FALSE

Örnekler

Örnek 1 MysqlndUhConnection::kill() example

<?php
class proxy extends MysqlndUhConnection {
 public function killConnection($res, $pid) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::killConnection($res, $pid);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->kill($mysqli->thread_id);
?>

Yukarıdaki örneğin çıktısı:

proxy::killConnection(array (
  0 => NULL,
  1 => 27650,
))
proxy::killConnection returns true

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_kill() - Asks the server to kill a MySQL thread

MysqlndUhConnection::init
MysqlndUhConnection::listFields
MysqlndUhConnection


List MySQL table fields

MysqlndUhConnection::killConnection
MysqlndUhConnection::listMethod
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::listFields

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::listFields — List MySQL table fields

Açıklama

public array MysqlndUhConnection::listFields ( mysqlnd_connection $connection , string $table , string $achtung_wild )

List MySQL table fields.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

table

The name of the table that's being queried.

pattern

Name pattern.

Dönen Değerler

Örnekler

Örnek 1 MysqlndUhConnection::listFields() example

<?php
class proxy extends MysqlndUhConnection {
 public function listFields($res, $table, $pattern) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::listFields($res, $table, $pattern);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysql = mysql_connect("localhost", "root", "");
mysql_select_db("test", $mysql);
mysql_query("DROP TABLE IF EXISTS test_a", $mysql);
mysql_query("CREATE TABLE test_a(id INT, col1 VARCHAR(255))", $mysql);
$res = mysql_list_fields("test", "test_a", $mysql);
printf("num_rows = %d\n", mysql_num_rows($res));
while ($row = mysql_fetch_assoc($res))
 var_dump($row);
?>

Yukarıdaki örneğin çıktısı:

proxy::listFields(array (
  0 => NULL,
  1 => 'test_a',
  2 => '',
))
proxy::listFields returns NULL
num_rows = 0

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysql_list_fields() - MySQL tablosunun alanlarını listeler

MysqlndUhConnection::killConnection
MysqlndUhConnection::listMethod
MysqlndUhConnection


Wrapper for assorted list commands

MysqlndUhConnection::listFields
MysqlndUhConnection::moreResults
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::listMethod

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::listMethod — Wrapper for assorted list commands

Açıklama

public void MysqlndUhConnection::listMethod ( mysqlnd_connection $connection , string $query , string $achtung_wild , string $par1 )

Wrapper for assorted list commands.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

query

SHOW command to be executed.

achtung_wild

par1

Dönen Değerler

Dönen Değerler

TODO

Örnekler

Örnek 1 MysqlndUhConnection::listMethod() example

<?php
class proxy extends MysqlndUhConnection {
 public function listMethod($res, $query, $pattern, $par1) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::listMethod($res, $query, $pattern, $par1);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysql = mysql_connect("localhost", "root", "");
$res = mysql_list_dbs($mysql);
printf("num_rows = %d\n", mysql_num_rows($res));
while ($row = mysql_fetch_assoc($res))
 var_dump($row);
?>

Yukarıdaki örneğin çıktısı:

proxy::listMethod(array (
  0 => NULL,
  1 => 'SHOW DATABASES',
  2 => '',
  3 => '',
))
proxy::listMethod returns NULL
num_rows = 6
array(1) {
  ["Database"]=>
  string(18) "information_schema"
}
array(1) {
  ["Database"]=>
  string(5) "mysql"
}
array(1) {
  ["Database"]=>
  string(8) "oxid_new"
}
array(1) {
  ["Database"]=>
  string(7) "phptest"
}
array(1) {
  ["Database"]=>
  string(7) "pushphp"
}
array(1) {
  ["Database"]=>
  string(4) "test"
}

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysql_list_dbs() - Bir MySQL sunucusundaki kullanılabilir veritabanlarını listeler

MysqlndUhConnection::listFields
MysqlndUhConnection::moreResults
MysqlndUhConnection


Check if there are any more query results from a multi query

MysqlndUhConnection::listMethod
MysqlndUhConnection::nextResult
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::moreResults

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::moreResults — Check if there are any more query results from a multi query

Açıklama

public bool MysqlndUhConnection::moreResults ( mysqlnd_connection $connection )

Check if there are any more query results from a multi query.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

Dönen Değerler

Returns TRUE on success. Otherwise, returns FALSE

Örnekler

Örnek 1 MysqlndUhConnection::moreResults() example

<?php
class proxy extends MysqlndUhConnection {
 public function moreResults($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::moreResults($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->multi_query("SELECT 1 AS _one; SELECT 2 AS _two");
do {
  $res = $mysqli->store_result();
  var_dump($res->fetch_assoc());
  printf("%s\n", str_repeat("-", 40));
} while ($mysqli->more_results() && $mysqli->next_result());
?>

Yukarıdaki örneğin çıktısı:

array(1) {
  ["_one"]=>
  string(1) "1"
}
----------------------------------------
proxy::moreResults(array (
  0 => NULL,
))
proxy::moreResults returns true
proxy::moreResults(array (
  0 => NULL,
))
proxy::moreResults returns true
array(1) {
  ["_two"]=>
  string(1) "2"
}
----------------------------------------
proxy::moreResults(array (
  0 => NULL,
))
proxy::moreResults returns false

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_more_results() - Check if there are any more query results from a multi query

MysqlndUhConnection::listMethod
MysqlndUhConnection::nextResult
MysqlndUhConnection


Prepare next result from multi_query

MysqlndUhConnection::moreResults
MysqlndUhConnection::ping
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::nextResult

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::nextResult — Prepare next result from multi_query

Açıklama

public bool MysqlndUhConnection::nextResult ( mysqlnd_connection $connection )

Prepare next result from multi_query.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

Dönen Değerler

Returns TRUE on success. Otherwise, returns FALSE

Örnekler

Örnek 1 MysqlndUhConnection::nextResult() example

<?php
class proxy extends MysqlndUhConnection {
 public function nextResult($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::nextResult($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->multi_query("SELECT 1 AS _one; SELECT 2 AS _two");
do {
  $res = $mysqli->store_result();
  var_dump($res->fetch_assoc());
  printf("%s\n", str_repeat("-", 40));
} while ($mysqli->more_results() && $mysqli->next_result());
?>

Yukarıdaki örneğin çıktısı:

array(1) {
  ["_one"]=>
  string(1) "1"
}
----------------------------------------
proxy::nextResult(array (
  0 => NULL,
))
proxy::nextResult returns true
array(1) {
  ["_two"]=>
  string(1) "2"
}
----------------------------------------

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_next_result() - Prepare next result from multi_query

MysqlndUhConnection::moreResults
MysqlndUhConnection::ping
MysqlndUhConnection


Pings a server connection, or tries to reconnect if the connection has gone down

MysqlndUhConnection::nextResult
MysqlndUhConnection::query
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::ping

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::ping — Pings a server connection, or tries to reconnect if the connection has gone down

Açıklama

public bool MysqlndUhConnection::ping ( mysqlnd_connection $connection )

Pings a server connection, or tries to reconnect if the connection has gone down.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

Dönen Değerler

Returns TRUE on success. Otherwise, returns FALSE

Örnekler

Örnek 1 MysqlndUhConnection::ping() example

<?php
class proxy extends MysqlndUhConnection {
 public function ping($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::ping($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->ping();
?>

Yukarıdaki örneğin çıktısı:

proxy::ping(array (
  0 => NULL,
))
proxy::ping returns true

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_ping() - Pings a server connection, or tries to reconnect if the connection has gone down
  • mysql_ping() - Bir sunucu bağlantısına ping at, bağlantı yoksa tekrar bağlan

MysqlndUhConnection::nextResult
MysqlndUhConnection::query
MysqlndUhConnection


Performs a query on the database

MysqlndUhConnection::ping
MysqlndUhConnection::queryReadResultsetHeader
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::query

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::query — Performs a query on the database

Açıklama

public bool MysqlndUhConnection::query ( mysqlnd_connection $connection , string $query )

Performs a query on the database (COM_QUERY).

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

query

The query string.

Dönen Değerler

Returns TRUE on success. Otherwise, returns FALSE

Örnekler

Örnek 1 MysqlndUhConnection::query() example

<?php
class proxy extends MysqlndUhConnection {
 public function query($res, $query) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $query = "SELECT 'How about query rewriting?'";
  $ret = parent::query($res, $query);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$res = $mysqli->query("SELECT 'Welcome mysqlnd_uh!' FROM DUAL");
var_dump($res->fetch_assoc());
?>

Yukarıdaki örneğin çıktısı:

proxy::query(array (
  0 => NULL,
  1 => 'SELECT \'Welcome mysqlnd_uh!\' FROM DUAL',
))
proxy::query returns true
array(1) {
  ["How about query rewriting?"]=>
  string(26) "How about query rewriting?"
}

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_query() - Performs a query on the database
  • mysql_query() - Send a MySQL query

MysqlndUhConnection::ping
MysqlndUhConnection::queryReadResultsetHeader
MysqlndUhConnection


Read a result set header

MysqlndUhConnection::query
MysqlndUhConnection::reapQuery
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::queryReadResultsetHeader

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::queryReadResultsetHeader — Read a result set header

Açıklama

public bool MysqlndUhConnection::queryReadResultsetHeader ( mysqlnd_connection $connection , mysqlnd_statement $mysqlnd_stmt )

Read a result set header.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

mysqlnd_stmt

Mysqlnd statement handle. Do not modify! Set to NULL, if function is not used in the context of a prepared statement.

Dönen Değerler

Returns TRUE on success. Otherwise, returns FALSE

Örnekler

Örnek 1 MysqlndUhConnection::queryReadResultsetHeader() example

<?php
class proxy extends MysqlndUhConnection {
 public function queryReadResultsetHeader($res, $stmt) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::queryReadResultsetHeader($res, $stmt);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$res = $mysqli->query("SELECT 'Welcome mysqlnd_uh!' FROM DUAL");
var_dump($res->fetch_assoc());
?>

Yukarıdaki örneğin çıktısı:

proxy::queryReadResultsetHeader(array (
  0 => NULL,
  1 => NULL,
))
proxy::queryReadResultsetHeader returns true
array(1) {
  ["Welcome mysqlnd_uh!"]=>
  string(19) "Welcome mysqlnd_uh!"
}

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections

MysqlndUhConnection::query
MysqlndUhConnection::reapQuery
MysqlndUhConnection


Get result from async query

MysqlndUhConnection::queryReadResultsetHeader
MysqlndUhConnection::refreshServer
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::reapQuery

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::reapQuery — Get result from async query

Açıklama

public bool MysqlndUhConnection::reapQuery ( mysqlnd_connection $connection )

Get result from async query.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

Dönen Değerler

Returns TRUE on success. Otherwise, returns FALSE

Örnekler

Örnek 1 MysqlndUhConnection::reapQuery() example

<?php
class proxy extends MysqlndUhConnection {
 public function reapQuery($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::reapQuery($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$conn1 = new mysqli("localhost", "root", "", "test");
$conn2 = new mysqli("localhost", "root", "", "test");

$conn1->query("SELECT 1 as 'one', SLEEP(1) AS _sleep FROM DUAL", MYSQLI_ASYNC |  MYSQLI_USE_RESULT);
$conn2->query("SELECT 1.1 as 'one dot one' FROM DUAL", MYSQLI_ASYNC |  MYSQLI_USE_RESULT);

$links = array(
 $conn1->thread_id => array('link' => $conn1, 'processed' => false),
 $conn2->thread_id => array('link' => $conn2, 'processed' => false)
);

$saved_errors = array();
do {
 $poll_links = $poll_errors = $poll_reject = array();
 foreach ($links as $thread_id => $link) {
  if (!$link['processed']) {
   $poll_links[] = $link['link'];
   $poll_errors[] = $link['link'];
   $poll_reject[] = $link['link'];
  }
 }
 if (0 == count($poll_links))
  break;

 if (0 == ($num_ready = mysqli_poll($poll_links, $poll_errors, $poll_reject, 0, 200000)))
  continue;

 if (!empty($poll_errors)) {
  die(var_dump($poll_errors));
 }

 foreach ($poll_links as $link) {
  $thread_id = mysqli_thread_id($link);
  $links[$thread_id]['processed'] = true;

  if (is_object($res = mysqli_reap_async_query($link))) {
   // result set object
   while ($row = mysqli_fetch_assoc($res)) {
    // eat up all results
    var_dump($row);
   }
   mysqli_free_result($res);
  } else {
   // either there is no result (no SELECT) or there is an error
   if (mysqli_errno($link) > 0) {
    $saved_errors[$thread_id] = mysqli_errno($link);
    printf("'%s' caused %d\n", $links[$thread_id]['query'],     mysqli_errno($link));
   }
  }
 }
} while (true);
?>

Yukarıdaki örneğin çıktısı:

proxy::reapQuery(array (
  0 => NULL,
))
proxy::reapQuery returns true
array(1) {
  ["one dot one"]=>
  string(3) "1.1"
}
proxy::reapQuery(array (
  0 => NULL,
))
proxy::reapQuery returns true
array(2) {
  ["one"]=>
  string(1) "1"
  ["_sleep"]=>
  string(1) "0"
}

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_real_async_query()

MysqlndUhConnection::queryReadResultsetHeader
MysqlndUhConnection::refreshServer
MysqlndUhConnection


Flush or reset tables and caches

MysqlndUhConnection::reapQuery
MysqlndUhConnection::restartPSession
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::refreshServer

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::refreshServer — Flush or reset tables and caches

Açıklama

public bool MysqlndUhConnection::refreshServer ( mysqlnd_connection $connection , int $options )

Flush or reset tables and caches.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

options

What to refresh.

Dönen Değerler

Returns TRUE on success. Otherwise, returns FALSE

Örnekler

Örnek 1 MysqlndUhConnection::refreshServer() example

<?php
class proxy extends MysqlndUhConnection {
 public function refreshServer($res, $option) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::refreshServer($res, $option);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());
$mysqli = new mysqli("localhost", "root", "", "test");
mysqli_refresh($mysqli, 1);
?>

Yukarıdaki örneğin çıktısı:

proxy::refreshServer(array (
  0 => NULL,
  1 => 1,
))
proxy::refreshServer returns false

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections

MysqlndUhConnection::reapQuery
MysqlndUhConnection::restartPSession
MysqlndUhConnection


Restart a persistent mysqlnd connection

MysqlndUhConnection::refreshServer
MysqlndUhConnection::selectDb
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::restartPSession

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::restartPSession — Restart a persistent mysqlnd connection

Açıklama

public bool MysqlndUhConnection::restartPSession ( mysqlnd_connection $connection )

Restart a persistent mysqlnd connection.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

Dönen Değerler

Returns TRUE on success. Otherwise, returns FALSE

Örnekler

Örnek 1 MysqlndUhConnection::restartPSession() example

<?php
class proxy extends MysqlndUhConnection {
 public function ping($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::ping($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->ping();
?>

Yukarıdaki örneğin çıktısı:

proxy::restartPSession(array (
  0 => NULL,
))
proxy::restartPSession returns true

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections

MysqlndUhConnection::refreshServer
MysqlndUhConnection::selectDb
MysqlndUhConnection


Selects the default database for database queries

MysqlndUhConnection::restartPSession
MysqlndUhConnection::sendClose
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::selectDb

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::selectDb — Selects the default database for database queries

Açıklama

public bool MysqlndUhConnection::selectDb ( mysqlnd_connection $connection , string $database )

Selects the default database for database queries.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

database

The database name.

Dönen Değerler

Returns TRUE on success. Otherwise, returns FALSE

Örnekler

Örnek 1 MysqlndUhConnection::selectDb() example

<?php
class proxy extends MysqlndUhConnection {
 public function selectDb($res, $database) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::selectDb($res, $database);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());
$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->select_db("mysql");
?>

Yukarıdaki örneğin çıktısı:

proxy::selectDb(array (
  0 => NULL,
  1 => 'mysql',
))
proxy::selectDb returns true

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_select_db() - Selects the default database for database queries
  • mysql_select_db() - Bir MySQL veritabanı seçer

MysqlndUhConnection::restartPSession
MysqlndUhConnection::sendClose
MysqlndUhConnection


Sends a close command to MySQL

MysqlndUhConnection::selectDb
MysqlndUhConnection::sendQuery
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::sendClose

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::sendClose — Sends a close command to MySQL

Açıklama

public bool MysqlndUhConnection::sendClose ( mysqlnd_connection $connection )

Sends a close command to MySQL.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

Dönen Değerler

Returns TRUE on success. Otherwise, returns FALSE

Örnekler

Örnek 1 MysqlndUhConnection::sendClose() example

<?php
class proxy extends MysqlndUhConnection {
 public function sendClose($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::sendClose($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());
$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->close();
?>

Yukarıdaki örneğin çıktısı:

proxy::sendClose(array (
  0 => NULL,
))
proxy::sendClose returns true
proxy::sendClose(array (
  0 => NULL,
))
proxy::sendClose returns true

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections

MysqlndUhConnection::selectDb
MysqlndUhConnection::sendQuery
MysqlndUhConnection


Sends a query to MySQL

MysqlndUhConnection::sendClose
MysqlndUhConnection::serverDumpDebugInformation
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::sendQuery

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::sendQuery — Sends a query to MySQL

Açıklama

public bool MysqlndUhConnection::sendQuery ( mysqlnd_connection $connection , string $query )

Sends a query to MySQL.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

query

The query string.

Dönen Değerler

Returns TRUE on success. Otherwise, returns FALSE

Örnekler

Örnek 1 MysqlndUhConnection::sendQuery() example

<?php
class proxy extends MysqlndUhConnection {
 public function sendQuery($res, $query) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::sendQuery($res, $query);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());
$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->query("SELECT 1");
?>

Yukarıdaki örneğin çıktısı:

proxy::sendQuery(array (
  0 => NULL,
  1 => 'SELECT 1',
))
proxy::sendQuery returns true

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections

MysqlndUhConnection::sendClose
MysqlndUhConnection::serverDumpDebugInformation
MysqlndUhConnection


Dump debugging information into the log for the MySQL server

MysqlndUhConnection::sendQuery
MysqlndUhConnection::setAutocommit
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::serverDumpDebugInformation

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::serverDumpDebugInformation — Dump debugging information into the log for the MySQL server

Açıklama

public bool MysqlndUhConnection::serverDumpDebugInformation ( mysqlnd_connection $connection )

Dump debugging information into the log for the MySQL server.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

Dönen Değerler

Returns TRUE on success. Otherwise, returns FALSE

Örnekler

Örnek 1 MysqlndUhConnection::serverDumpDebugInformation() example

<?php
class proxy extends MysqlndUhConnection {
 public function serverDumpDebugInformation($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::serverDumpDebugInformation($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());
$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->dump_debug_info();
?>

Yukarıdaki örneğin çıktısı:

proxy::serverDumpDebugInformation(array (
  0 => NULL,
))
proxy::serverDumpDebugInformation returns true

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_dump_debug_info() - Dump debugging information into the log

MysqlndUhConnection::sendQuery
MysqlndUhConnection::setAutocommit
MysqlndUhConnection


Turns on or off auto-committing database modifications

MysqlndUhConnection::serverDumpDebugInformation
MysqlndUhConnection::setCharset
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::setAutocommit

(PECL mysqlnd-uh >= 1.0.1-alpha, PHP >= 5.4.0)

MysqlndUhConnection::setAutocommit — Turns on or off auto-committing database modifications

Açıklama

public bool MysqlndUhConnection::setAutocommit ( mysqlnd_connection $connection , int $mode )

Turns on or off auto-committing database modifications

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

mode

Whether to turn on auto-commit or not.

Dönen Değerler

Returns TRUE on success. Otherwise, returns FALSE

Örnekler

Örnek 1 MysqlndUhConnection::setAutocommit() example

<?php
class proxy extends MysqlndUhConnection {
 public function setAutocommit($res, $mode) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::setAutocommit($res, $mode);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());
$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->autocommit(false);
$mysqli->autocommit(true);
?>

Yukarıdaki örneğin çıktısı:

proxy::setAutocommit(array (
  0 => NULL,
  1 => 0,
))
proxy::setAutocommit returns true
proxy::setAutocommit(array (
  0 => NULL,
  1 => 1,
))
proxy::setAutocommit returns true

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_autocommit() - Turns on or off auto-committing database modifications

MysqlndUhConnection::serverDumpDebugInformation
MysqlndUhConnection::setCharset
MysqlndUhConnection


Sets the default client character set

MysqlndUhConnection::setAutocommit
MysqlndUhConnection::setClientOption
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::setCharset

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::setCharset — Sets the default client character set

Açıklama

public bool MysqlndUhConnection::setCharset ( mysqlnd_connection $connection , string $charset )

Sets the default client character set.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

charset

The charset to be set as default.

Dönen Değerler

Returns TRUE on success. Otherwise, returns FALSE

Örnekler

Örnek 1 MysqlndUhConnection::setCharset() example

<?php
class proxy extends MysqlndUhConnection {
 public function setCharset($res, $charset) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::setCharset($res, $charset);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());
$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->set_charset("latin1");
?>

Yukarıdaki örneğin çıktısı:

proxy::setCharset(array (
  0 => NULL,
  1 => 'latin1',
))
proxy::setCharset returns true

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_set_charset() - Sets the default client character set

MysqlndUhConnection::setAutocommit
MysqlndUhConnection::setClientOption
MysqlndUhConnection


Sets a client option

MysqlndUhConnection::setCharset
MysqlndUhConnection::setServerOption
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::setClientOption

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::setClientOption — Sets a client option

Açıklama

public bool MysqlndUhConnection::setClientOption ( mysqlnd_connection $connection , int $option , int $value )

Sets a client option.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

option

The option to be set.

value

Optional option value, if required.

Dönen Değerler

Returns TRUE on success. Otherwise, returns FALSE

Örnekler

Örnek 1 MysqlndUhConnection::setClientOption() example

<?php
function client_option_to_string($option) {
 static $mapping = array(
  MYSQLND_UH_MYSQLND_OPTION_OPT_CONNECT_TIMEOUT => "MYSQLND_UH_MYSQLND_OPTION_OPT_CONNECT_TIMEOUT",
  MYSQLND_UH_MYSQLND_OPTION_OPT_COMPRESS => "MYSQLND_UH_MYSQLND_OPTION_OPT_COMPRESS",
  MYSQLND_UH_MYSQLND_OPTION_OPT_NAMED_PIPE => "MYSQLND_UH_MYSQLND_OPTION_OPT_NAMED_PIPE",
  MYSQLND_UH_MYSQLND_OPTION_INIT_COMMAND => "MYSQLND_UH_MYSQLND_OPTION_INIT_COMMAND",
  MYSQLND_UH_MYSQLND_READ_DEFAULT_FILE => "MYSQLND_UH_MYSQLND_READ_DEFAULT_FILE",
  MYSQLND_UH_MYSQLND_READ_DEFAULT_GROUP => "MYSQLND_UH_MYSQLND_READ_DEFAULT_GROUP",
  MYSQLND_UH_MYSQLND_SET_CHARSET_DIR => "MYSQLND_UH_MYSQLND_SET_CHARSET_DIR",
  MYSQLND_UH_MYSQLND_SET_CHARSET_NAME => "MYSQLND_UH_MYSQLND_SET_CHARSET_NAME",
  MYSQLND_UH_MYSQLND_OPT_LOCAL_INFILE => "MYSQLND_UH_MYSQLND_OPT_LOCAL_INFILE",
  MYSQLND_UH_MYSQLND_OPT_PROTOCOL => "MYSQLND_UH_MYSQLND_OPT_PROTOCOL",
  MYSQLND_UH_MYSQLND_SHARED_MEMORY_BASE_NAME => "MYSQLND_UH_MYSQLND_SHARED_MEMORY_BASE_NAME",
  MYSQLND_UH_MYSQLND_OPT_READ_TIMEOUT => "MYSQLND_UH_MYSQLND_OPT_READ_TIMEOUT",
  MYSQLND_UH_MYSQLND_OPT_WRITE_TIMEOUT => "MYSQLND_UH_MYSQLND_OPT_WRITE_TIMEOUT",
  MYSQLND_UH_MYSQLND_OPT_USE_RESULT => "MYSQLND_UH_MYSQLND_OPT_USE_RESULT",
  MYSQLND_UH_MYSQLND_OPT_USE_REMOTE_CONNECTION => "MYSQLND_UH_MYSQLND_OPT_USE_REMOTE_CONNECTION",
  MYSQLND_UH_MYSQLND_OPT_USE_EMBEDDED_CONNECTION => "MYSQLND_UH_MYSQLND_OPT_USE_EMBEDDED_CONNECTION",
  MYSQLND_UH_MYSQLND_OPT_GUESS_CONNECTION => "MYSQLND_UH_MYSQLND_OPT_GUESS_CONNECTION",
  MYSQLND_UH_MYSQLND_SET_CLIENT_IP => "MYSQLND_UH_MYSQLND_SET_CLIENT_IP",
  MYSQLND_UH_MYSQLND_SECURE_AUTH => "MYSQLND_UH_MYSQLND_SECURE_AUTH",
  MYSQLND_UH_MYSQLND_REPORT_DATA_TRUNCATION => "MYSQLND_UH_MYSQLND_REPORT_DATA_TRUNCATION",
  MYSQLND_UH_MYSQLND_OPT_RECONNECT => "MYSQLND_UH_MYSQLND_OPT_RECONNECT",
  MYSQLND_UH_MYSQLND_OPT_SSL_VERIFY_SERVER_CERT => "MYSQLND_UH_MYSQLND_OPT_SSL_VERIFY_SERVER_CERT",
  MYSQLND_UH_MYSQLND_OPT_NET_CMD_BUFFER_SIZE => "MYSQLND_UH_MYSQLND_OPT_NET_CMD_BUFFER_SIZE",
  MYSQLND_UH_MYSQLND_OPT_NET_READ_BUFFER_SIZE => "MYSQLND_UH_MYSQLND_OPT_NET_READ_BUFFER_SIZE",
  MYSQLND_UH_MYSQLND_OPT_SSL_KEY => "MYSQLND_UH_MYSQLND_OPT_SSL_KEY",
  MYSQLND_UH_MYSQLND_OPT_SSL_CERT => "MYSQLND_UH_MYSQLND_OPT_SSL_CERT",
  MYSQLND_UH_MYSQLND_OPT_SSL_CA => "MYSQLND_UH_MYSQLND_OPT_SSL_CA",
  MYSQLND_UH_MYSQLND_OPT_SSL_CAPATH => "MYSQLND_UH_MYSQLND_OPT_SSL_CAPATH",
  MYSQLND_UH_MYSQLND_OPT_SSL_CIPHER => "MYSQLND_UH_MYSQLND_OPT_SSL_CIPHER",
  MYSQLND_UH_MYSQLND_OPT_SSL_PASSPHRASE => "MYSQLND_UH_MYSQLND_OPT_SSL_PASSPHRASE",
  MYSQLND_UH_SERVER_OPTION_PLUGIN_DIR => "MYSQLND_UH_SERVER_OPTION_PLUGIN_DIR",
  MYSQLND_UH_SERVER_OPTION_DEFAULT_AUTH => "MYSQLND_UH_SERVER_OPTION_DEFAULT_AUTH",
  MYSQLND_UH_SERVER_OPTION_SET_CLIENT_IP => "MYSQLND_UH_SERVER_OPTION_SET_CLIENT_IP"
 );
 if (version_compare(PHP_VERSION, '5.3.99-dev', '>')) {
  $mapping[MYSQLND_UH_MYSQLND_OPT_MAX_ALLOWED_PACKET] = "MYSQLND_UH_MYSQLND_OPT_MAX_ALLOWED_PACKET";
  $mapping[MYSQLND_UH_MYSQLND_OPT_AUTH_PROTOCOL] = "MYSQLND_UH_MYSQLND_OPT_AUTH_PROTOCOL";
 }
 if (defined("MYSQLND_UH_MYSQLND_OPT_INT_AND_FLOAT_NATIVE")) {
  /* special mysqlnd build */
  $mapping["MYSQLND_UH_MYSQLND_OPT_INT_AND_FLOAT_NATIVE"] = "MYSQLND_UH_MYSQLND_OPT_INT_AND_FLOAT_NATIVE";
 }
 return (isset($mapping[$option])) ? $mapping[$option] : 'unknown';
}

class proxy extends MysqlndUhConnection {
 public function setClientOption($res, $option, $value) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  printf("Option '%s' set to %s\n", client_option_to_string($option), var_export($value, true));
  $ret = parent::setClientOption($res, $option, $value);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());
$mysqli = new mysqli("localhost", "root", "", "test");
?>

Yukarıdaki örneğin çıktısı:

proxy::setClientOption(array (
  0 => NULL,
  1 => 210,
  2 => 3221225472,
))
Option 'MYSQLND_UH_MYSQLND_OPT_MAX_ALLOWED_PACKET' set to 3221225472
proxy::setClientOption returns true
proxy::setClientOption(array (
  0 => NULL,
  1 => 211,
  2 => 'mysql_native_password',
))
Option 'MYSQLND_UH_MYSQLND_OPT_AUTH_PROTOCOL' set to 'mysql_native_password'
proxy::setClientOption returns true
proxy::setClientOption(array (
  0 => NULL,
  1 => 8,
  2 => 1,
))
Option 'MYSQLND_UH_MYSQLND_OPT_LOCAL_INFILE' set to 1
proxy::setClientOption returns true

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_real_connect() - Opens a connection to a mysql server
  • mysqli_options() - Set options

MysqlndUhConnection::setCharset
MysqlndUhConnection::setServerOption
MysqlndUhConnection


Sets a server option

MysqlndUhConnection::setClientOption
MysqlndUhConnection::shutdownServer
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::setServerOption

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::setServerOption — Sets a server option

Açıklama

public void MysqlndUhConnection::setServerOption ( mysqlnd_connection $connection , int $option )

Sets a server option.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

option

The option to be set.

Dönen Değerler

Returns TRUE on success. Otherwise, returns FALSE

Örnekler

Örnek 1 MysqlndUhConnection::setServerOption() example

<?php
function server_option_to_string($option) {
 $ret = 'unknown';
 switch ($option) {
  case MYSQLND_UH_SERVER_OPTION_MULTI_STATEMENTS_ON:
   $ret = 'MYSQLND_UH_SERVER_OPTION_MULTI_STATEMENTS_ON';
   break;
  case MYSQLND_UH_SERVER_OPTION_MULTI_STATEMENTS_OFF:
   $ret = 'MYSQLND_UH_SERVER_OPTION_MULTI_STATEMENTS_ON';
   break;
 }
 return $ret;
}

class proxy extends MysqlndUhConnection {
 public function setServerOption($res, $option) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  printf("Option '%s' set\n", server_option_to_string($option));
  $ret = parent::setServerOption($res, $option);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());
$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->multi_query("SELECT 1; SELECT 2");
?>

Yukarıdaki örneğin çıktısı:

proxy::setServerOption(array (
  0 => NULL,
  1 => 0,
))
Option 'MYSQLND_UH_SERVER_OPTION_MULTI_STATEMENTS_ON' set
proxy::setServerOption returns true

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_real_connect() - Opens a connection to a mysql server
  • mysqli_options() - Set options
  • mysqli_multi_query() - Performs a query on the database

MysqlndUhConnection::setClientOption
MysqlndUhConnection::shutdownServer
MysqlndUhConnection


The shutdownServer purpose

MysqlndUhConnection::setServerOption
MysqlndUhConnection::simpleCommand
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::shutdownServer

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::shutdownServer — The shutdownServer purpose

Açıklama

public void MysqlndUhConnection::shutdownServer ( string $MYSQLND_UH_RES_MYSQLND_NAME , string $"level" )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

MYSQLND_UH_RES_MYSQLND_NAME

"level"

Dönen Değerler

MysqlndUhConnection::setServerOption
MysqlndUhConnection::simpleCommand
MysqlndUhConnection


Sends a basic COM_* command

MysqlndUhConnection::shutdownServer
MysqlndUhConnection::simpleCommandHandleResponse
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::simpleCommand

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::simpleCommand — Sends a basic COM_* command

Açıklama

public bool MysqlndUhConnection::simpleCommand ( mysqlnd_connection $connection , int $command , string $arg , int $ok_packet , bool $silent , bool $ignore_upsert_status )

Sends a basic COM_* command to MySQL.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

command

The COM command to be send.

arg

Optional COM command arguments.

ok_packet

The OK packet type.

silent

Whether mysqlnd may emit errors.

ignore_upsert_status

Whether to ignore UPDATE/INSERT status.

Dönen Değerler

Returns TRUE on success. Otherwise, returns FALSE

Örnekler

Örnek 1 MysqlndUhConnection::simpleCommand() example

<?php
function server_cmd_2_string($command) {
 $mapping = array(
  MYSQLND_UH_MYSQLND_COM_SLEEP => "MYSQLND_UH_MYSQLND_COM_SLEEP",
  MYSQLND_UH_MYSQLND_COM_QUIT => "MYSQLND_UH_MYSQLND_COM_QUIT",
  MYSQLND_UH_MYSQLND_COM_INIT_DB => "MYSQLND_UH_MYSQLND_COM_INIT_DB",
  MYSQLND_UH_MYSQLND_COM_QUERY => "MYSQLND_UH_MYSQLND_COM_QUERY",
  MYSQLND_UH_MYSQLND_COM_FIELD_LIST => "MYSQLND_UH_MYSQLND_COM_FIELD_LIST",
  MYSQLND_UH_MYSQLND_COM_CREATE_DB => "MYSQLND_UH_MYSQLND_COM_CREATE_DB",
  MYSQLND_UH_MYSQLND_COM_DROP_DB => "MYSQLND_UH_MYSQLND_COM_DROP_DB",
  MYSQLND_UH_MYSQLND_COM_REFRESH => "MYSQLND_UH_MYSQLND_COM_REFRESH",
  MYSQLND_UH_MYSQLND_COM_SHUTDOWN => "MYSQLND_UH_MYSQLND_COM_SHUTDOWN",
  MYSQLND_UH_MYSQLND_COM_STATISTICS => "MYSQLND_UH_MYSQLND_COM_STATISTICS",
  MYSQLND_UH_MYSQLND_COM_PROCESS_INFO => "MYSQLND_UH_MYSQLND_COM_PROCESS_INFO",
  MYSQLND_UH_MYSQLND_COM_CONNECT => "MYSQLND_UH_MYSQLND_COM_CONNECT",
  MYSQLND_UH_MYSQLND_COM_PROCESS_KILL => "MYSQLND_UH_MYSQLND_COM_PROCESS_KILL",
  MYSQLND_UH_MYSQLND_COM_DEBUG => "MYSQLND_UH_MYSQLND_COM_DEBUG",
  MYSQLND_UH_MYSQLND_COM_PING => "MYSQLND_UH_MYSQLND_COM_PING",
  MYSQLND_UH_MYSQLND_COM_TIME => "MYSQLND_UH_MYSQLND_COM_TIME",
  MYSQLND_UH_MYSQLND_COM_DELAYED_INSERT => "MYSQLND_UH_MYSQLND_COM_DELAYED_INSERT",
  MYSQLND_UH_MYSQLND_COM_CHANGE_USER => "MYSQLND_UH_MYSQLND_COM_CHANGE_USER",
  MYSQLND_UH_MYSQLND_COM_BINLOG_DUMP => "MYSQLND_UH_MYSQLND_COM_BINLOG_DUMP",
  MYSQLND_UH_MYSQLND_COM_TABLE_DUMP => "MYSQLND_UH_MYSQLND_COM_TABLE_DUMP",
  MYSQLND_UH_MYSQLND_COM_CONNECT_OUT => "MYSQLND_UH_MYSQLND_COM_CONNECT_OUT",
  MYSQLND_UH_MYSQLND_COM_REGISTER_SLAVED => "MYSQLND_UH_MYSQLND_COM_REGISTER_SLAVED",
  MYSQLND_UH_MYSQLND_COM_STMT_PREPARE => "MYSQLND_UH_MYSQLND_COM_STMT_PREPARE",
  MYSQLND_UH_MYSQLND_COM_STMT_EXECUTE => "MYSQLND_UH_MYSQLND_COM_STMT_EXECUTE",
  MYSQLND_UH_MYSQLND_COM_STMT_SEND_LONG_DATA => "MYSQLND_UH_MYSQLND_COM_STMT_SEND_LONG_DATA",
  MYSQLND_UH_MYSQLND_COM_STMT_CLOSE => "MYSQLND_UH_MYSQLND_COM_STMT_CLOSE",
  MYSQLND_UH_MYSQLND_COM_STMT_RESET => "MYSQLND_UH_MYSQLND_COM_STMT_RESET",
  MYSQLND_UH_MYSQLND_COM_SET_OPTION => "MYSQLND_UH_MYSQLND_COM_SET_OPTION",
  MYSQLND_UH_MYSQLND_COM_STMT_FETCH => "MYSQLND_UH_MYSQLND_COM_STMT_FETCH",
  MYSQLND_UH_MYSQLND_COM_DAEMON => "MYSQLND_UH_MYSQLND_COM_DAEMON",
  MYSQLND_UH_MYSQLND_COM_END => "MYSQLND_UH_MYSQLND_COM_END",
 );
 return (isset($mapping[$command])) ? $mapping[$command] : 'unknown';
}

function ok_packet_2_string($ok_packet) {
 $mapping = array(
  MYSQLND_UH_MYSQLND_PROT_GREET_PACKET => "MYSQLND_UH_MYSQLND_PROT_GREET_PACKET",
  MYSQLND_UH_MYSQLND_PROT_AUTH_PACKET => "MYSQLND_UH_MYSQLND_PROT_AUTH_PACKET",
  MYSQLND_UH_MYSQLND_PROT_OK_PACKET => "MYSQLND_UH_MYSQLND_PROT_OK_PACKET",
  MYSQLND_UH_MYSQLND_PROT_EOF_PACKET => "MYSQLND_UH_MYSQLND_PROT_EOF_PACKET",
  MYSQLND_UH_MYSQLND_PROT_CMD_PACKET => "MYSQLND_UH_MYSQLND_PROT_CMD_PACKET",
  MYSQLND_UH_MYSQLND_PROT_RSET_HEADER_PACKET => "MYSQLND_UH_MYSQLND_PROT_RSET_HEADER_PACKET",
  MYSQLND_UH_MYSQLND_PROT_RSET_FLD_PACKET => "MYSQLND_UH_MYSQLND_PROT_RSET_FLD_PACKET",
  MYSQLND_UH_MYSQLND_PROT_ROW_PACKET => "MYSQLND_UH_MYSQLND_PROT_ROW_PACKET",
  MYSQLND_UH_MYSQLND_PROT_STATS_PACKET => "MYSQLND_UH_MYSQLND_PROT_STATS_PACKET",
  MYSQLND_UH_MYSQLND_PREPARE_RESP_PACKET => "MYSQLND_UH_MYSQLND_PREPARE_RESP_PACKET",
  MYSQLND_UH_MYSQLND_CHG_USER_RESP_PACKET => "MYSQLND_UH_MYSQLND_CHG_USER_RESP_PACKET",
  MYSQLND_UH_MYSQLND_PROT_LAST => "MYSQLND_UH_MYSQLND_PROT_LAST",
 );
 return (isset($mapping[$ok_packet])) ? $mapping[$ok_packet] : 'unknown';
}

class proxy extends MysqlndUhConnection {
 public function simpleCommand($conn, $command, $arg, $ok_packet, $silent, $ignore_upsert_status) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  printf("Command '%s'\n", server_cmd_2_string($command));
  printf("OK packet '%s'\n",  ok_packet_2_string($ok_packet));
  $ret = parent::simpleCommand($conn, $command, $arg, $ok_packet, $silent, $ignore_upsert_status);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());
$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->query("SELECT 1");
?>

Yukarıdaki örneğin çıktısı:

proxy::simpleCommand(array (
  0 => NULL,
  1 => 3,
  2 => 'SELECT 1',
  3 => 13,
  4 => false,
  5 => false,
))
Command 'MYSQLND_UH_MYSQLND_COM_QUERY'
OK packet 'MYSQLND_UH_MYSQLND_PROT_LAST'
proxy::simpleCommand returns true
:)proxy::simpleCommand(array (
  0 => NULL,
  1 => 1,
  2 => '',
  3 => 13,
  4 => true,
  5 => true,
))
Command 'MYSQLND_UH_MYSQLND_COM_QUIT'
OK packet 'MYSQLND_UH_MYSQLND_PROT_LAST'
proxy::simpleCommand returns true

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections

MysqlndUhConnection::shutdownServer
MysqlndUhConnection::simpleCommandHandleResponse
MysqlndUhConnection


Process a response for a basic COM_* command send to the client

MysqlndUhConnection::simpleCommand
MysqlndUhConnection::sslSet
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::simpleCommandHandleResponse

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::simpleCommandHandleResponse — Process a response for a basic COM_* command send to the client

Açıklama

public bool MysqlndUhConnection::simpleCommandHandleResponse ( mysqlnd_connection $connection , int $ok_packet , bool $silent , int $command , bool $ignore_upsert_status )

Process a response for a basic COM_* command send to the client.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

ok_packet

The OK packet type.

silent

Whether mysqlnd may emit errors.

command

The COM command to process results from.

ignore_upsert_status

Whether to ignore UPDATE/INSERT status.

Dönen Değerler

Returns TRUE on success. Otherwise, returns FALSE

Örnekler

Örnek 1 MysqlndUhConnection::simpleCommandHandleResponse() example

<?php
function server_cmd_2_string($command) {
 $mapping = array(
  MYSQLND_UH_MYSQLND_COM_SLEEP => "MYSQLND_UH_MYSQLND_COM_SLEEP",
  MYSQLND_UH_MYSQLND_COM_QUIT => "MYSQLND_UH_MYSQLND_COM_QUIT",
  MYSQLND_UH_MYSQLND_COM_INIT_DB => "MYSQLND_UH_MYSQLND_COM_INIT_DB",
  MYSQLND_UH_MYSQLND_COM_QUERY => "MYSQLND_UH_MYSQLND_COM_QUERY",
  MYSQLND_UH_MYSQLND_COM_FIELD_LIST => "MYSQLND_UH_MYSQLND_COM_FIELD_LIST",
  MYSQLND_UH_MYSQLND_COM_CREATE_DB => "MYSQLND_UH_MYSQLND_COM_CREATE_DB",
  MYSQLND_UH_MYSQLND_COM_DROP_DB => "MYSQLND_UH_MYSQLND_COM_DROP_DB",
  MYSQLND_UH_MYSQLND_COM_REFRESH => "MYSQLND_UH_MYSQLND_COM_REFRESH",
  MYSQLND_UH_MYSQLND_COM_SHUTDOWN => "MYSQLND_UH_MYSQLND_COM_SHUTDOWN",
  MYSQLND_UH_MYSQLND_COM_STATISTICS => "MYSQLND_UH_MYSQLND_COM_STATISTICS",
  MYSQLND_UH_MYSQLND_COM_PROCESS_INFO => "MYSQLND_UH_MYSQLND_COM_PROCESS_INFO",
  MYSQLND_UH_MYSQLND_COM_CONNECT => "MYSQLND_UH_MYSQLND_COM_CONNECT",
  MYSQLND_UH_MYSQLND_COM_PROCESS_KILL => "MYSQLND_UH_MYSQLND_COM_PROCESS_KILL",
  MYSQLND_UH_MYSQLND_COM_DEBUG => "MYSQLND_UH_MYSQLND_COM_DEBUG",
  MYSQLND_UH_MYSQLND_COM_PING => "MYSQLND_UH_MYSQLND_COM_PING",
  MYSQLND_UH_MYSQLND_COM_TIME => "MYSQLND_UH_MYSQLND_COM_TIME",
  MYSQLND_UH_MYSQLND_COM_DELAYED_INSERT => "MYSQLND_UH_MYSQLND_COM_DELAYED_INSERT",
  MYSQLND_UH_MYSQLND_COM_CHANGE_USER => "MYSQLND_UH_MYSQLND_COM_CHANGE_USER",
  MYSQLND_UH_MYSQLND_COM_BINLOG_DUMP => "MYSQLND_UH_MYSQLND_COM_BINLOG_DUMP",
  MYSQLND_UH_MYSQLND_COM_TABLE_DUMP => "MYSQLND_UH_MYSQLND_COM_TABLE_DUMP",
  MYSQLND_UH_MYSQLND_COM_CONNECT_OUT => "MYSQLND_UH_MYSQLND_COM_CONNECT_OUT",
  MYSQLND_UH_MYSQLND_COM_REGISTER_SLAVED => "MYSQLND_UH_MYSQLND_COM_REGISTER_SLAVED",
  MYSQLND_UH_MYSQLND_COM_STMT_PREPARE => "MYSQLND_UH_MYSQLND_COM_STMT_PREPARE",
  MYSQLND_UH_MYSQLND_COM_STMT_EXECUTE => "MYSQLND_UH_MYSQLND_COM_STMT_EXECUTE",
  MYSQLND_UH_MYSQLND_COM_STMT_SEND_LONG_DATA => "MYSQLND_UH_MYSQLND_COM_STMT_SEND_LONG_DATA",
  MYSQLND_UH_MYSQLND_COM_STMT_CLOSE => "MYSQLND_UH_MYSQLND_COM_STMT_CLOSE",
  MYSQLND_UH_MYSQLND_COM_STMT_RESET => "MYSQLND_UH_MYSQLND_COM_STMT_RESET",
  MYSQLND_UH_MYSQLND_COM_SET_OPTION => "MYSQLND_UH_MYSQLND_COM_SET_OPTION",
  MYSQLND_UH_MYSQLND_COM_STMT_FETCH => "MYSQLND_UH_MYSQLND_COM_STMT_FETCH",
  MYSQLND_UH_MYSQLND_COM_DAEMON => "MYSQLND_UH_MYSQLND_COM_DAEMON",
  MYSQLND_UH_MYSQLND_COM_END => "MYSQLND_UH_MYSQLND_COM_END",
 );
 return (isset($mapping[$command])) ? $mapping[$command] : 'unknown';
}

function ok_packet_2_string($ok_packet) {
 $mapping = array(
  MYSQLND_UH_MYSQLND_PROT_GREET_PACKET => "MYSQLND_UH_MYSQLND_PROT_GREET_PACKET",
  MYSQLND_UH_MYSQLND_PROT_AUTH_PACKET => "MYSQLND_UH_MYSQLND_PROT_AUTH_PACKET",
  MYSQLND_UH_MYSQLND_PROT_OK_PACKET => "MYSQLND_UH_MYSQLND_PROT_OK_PACKET",
  MYSQLND_UH_MYSQLND_PROT_EOF_PACKET => "MYSQLND_UH_MYSQLND_PROT_EOF_PACKET",
  MYSQLND_UH_MYSQLND_PROT_CMD_PACKET => "MYSQLND_UH_MYSQLND_PROT_CMD_PACKET",
  MYSQLND_UH_MYSQLND_PROT_RSET_HEADER_PACKET => "MYSQLND_UH_MYSQLND_PROT_RSET_HEADER_PACKET",
  MYSQLND_UH_MYSQLND_PROT_RSET_FLD_PACKET => "MYSQLND_UH_MYSQLND_PROT_RSET_FLD_PACKET",
  MYSQLND_UH_MYSQLND_PROT_ROW_PACKET => "MYSQLND_UH_MYSQLND_PROT_ROW_PACKET",
  MYSQLND_UH_MYSQLND_PROT_STATS_PACKET => "MYSQLND_UH_MYSQLND_PROT_STATS_PACKET",
  MYSQLND_UH_MYSQLND_PREPARE_RESP_PACKET => "MYSQLND_UH_MYSQLND_PREPARE_RESP_PACKET",
  MYSQLND_UH_MYSQLND_CHG_USER_RESP_PACKET => "MYSQLND_UH_MYSQLND_CHG_USER_RESP_PACKET",
  MYSQLND_UH_MYSQLND_PROT_LAST => "MYSQLND_UH_MYSQLND_PROT_LAST",
 );
 return (isset($mapping[$ok_packet])) ? $mapping[$ok_packet] : 'unknown';
}

class proxy extends MysqlndUhConnection {
 public function simpleCommandHandleResponse($conn, $ok_packet, $silent, $command, $ignore_upsert_status) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  printf("Command '%s'\n", server_cmd_2_string($command));
  printf("OK packet '%s'\n",  ok_packet_2_string($ok_packet));
  $ret = parent::simpleCommandHandleResponse($conn, $ok_packet, $silent, $command, $ignore_upsert_status);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());
$mysql = mysql_connect("localhost", "root", "");
mysql_query("SELECT 1 FROM DUAL", $mysql);
?>

Yukarıdaki örneğin çıktısı:

proxy::simpleCommandHandleResponse(array (
  0 => NULL,
  1 => 5,
  2 => false,
  3 => 27,
  4 => true,
))
Command 'MYSQLND_UH_MYSQLND_COM_SET_OPTION'
OK packet 'MYSQLND_UH_MYSQLND_PROT_EOF_PACKET'
proxy::simpleCommandHandleResponse returns true

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections

MysqlndUhConnection::simpleCommand
MysqlndUhConnection::sslSet
MysqlndUhConnection


Used for establishing secure connections using SSL

MysqlndUhConnection::simpleCommandHandleResponse
MysqlndUhConnection::stmtInit
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::sslSet

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::sslSet — Used for establishing secure connections using SSL

Açıklama

public bool MysqlndUhConnection::sslSet ( mysqlnd_connection $connection , string $key , string $cert , string $ca , string $capath , string $cipher )

Used for establishing secure connections using SSL.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

key

The path name to the key file.

cert

The path name to the certificate file.

ca

The path name to the certificate authority file.

capath

The pathname to a directory that contains trusted SSL CA certificates in PEM format.

cipher

A list of allowable ciphers to use for SSL encryption.

Dönen Değerler

Returns TRUE on success. Otherwise, returns FALSE

Örnekler

Örnek 1 MysqlndUhConnection::sslSet() example

<?php
class proxy extends MysqlndUhConnection {
 public function sslSet($conn, $key, $cert, $ca, $capath, $cipher) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::sslSet($conn, $key, $cert, $ca, $capath, $cipher);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());
$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->ssl_set("key", "cert", "ca", "capath", "cipher");
?>

Yukarıdaki örneğin çıktısı:

proxy::sslSet(array (
  0 => NULL,
  1 => 'key',
  2 => 'cert',
  3 => 'ca',
  4 => 'capath',
  5 => 'cipher',
))
proxy::sslSet returns true

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_ssl_set() - Used for establishing secure connections using SSL

MysqlndUhConnection::simpleCommandHandleResponse
MysqlndUhConnection::stmtInit
MysqlndUhConnection


Initializes a statement and returns a resource for use with mysqli_statement::prepare

MysqlndUhConnection::sslSet
MysqlndUhConnection::storeResult
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::stmtInit

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::stmtInit — Initializes a statement and returns a resource for use with mysqli_statement::prepare

Açıklama

public resource MysqlndUhConnection::stmtInit ( mysqlnd_connection $connection )

Initializes a statement and returns a resource for use with mysqli_statement::prepare.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

Dönen Değerler

Resource of type Mysqlnd Prepared Statement (internal only - you must not modify it!). The documentation may also refer to such resources using the alias name mysqlnd_prepared_statement.

Örnekler

Örnek 1 MysqlndUhConnection::stmtInit() example

<?php
class proxy extends MysqlndUhConnection {
 public function stmtInit($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  var_dump($res);
  $ret = parent::stmtInit($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  var_dump($ret);
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());
$mysqli = new mysqli("localhost", "root", "", "test");
$stmt = $mysqli->prepare("SELECT 1 AS _one FROM DUAL");
$stmt->execute();
$one = NULL;
$stmt->bind_result($one);
$stmt->fetch();
var_dump($one);
?>

Yukarıdaki örneğin çıktısı:

proxy::stmtInit(array (
  0 => NULL,
))
resource(19) of type (Mysqlnd Connection)
proxy::stmtInit returns NULL
resource(246) of type (Mysqlnd Prepared Statement (internal only - you must not modify it!))
int(1)

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_stmt_init() - Initializes a statement and returns an object for use with mysqli_stmt_prepare

MysqlndUhConnection::sslSet
MysqlndUhConnection::storeResult
MysqlndUhConnection


Transfers a result set from the last query

MysqlndUhConnection::stmtInit
MysqlndUhConnection::txCommit
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::storeResult

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::storeResult — Transfers a result set from the last query

Açıklama

public resource MysqlndUhConnection::storeResult ( mysqlnd_connection $connection )

Transfers a result set from the last query.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

Dönen Değerler

Resource of type Mysqlnd Resultset (internal only - you must not modify it!). The documentation may also refer to such resources using the alias name mysqlnd_resultset.

Örnekler

Örnek 1 MysqlndUhConnection::storeResult() example

<?php
class proxy extends MysqlndUhConnection {
 public function storeResult($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::storeResult($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  var_dump($ret);
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$res = $mysqli->query("SELECT 'Also called buffered result' AS _msg FROM DUAL");
var_dump($res->fetch_assoc());

$mysqli->real_query("SELECT 'Good morning!' AS _msg FROM DUAL");
$res = $mysqli->store_result();
var_dump($res->fetch_assoc());
?>

Yukarıdaki örneğin çıktısı:

proxy::storeResult(array (
  0 => NULL,
))
proxy::storeResult returns NULL
resource(475) of type (Mysqlnd Resultset (internal only - you must not modify it!))
array(1) {
  ["_msg"]=>
  string(27) "Also called buffered result"
}
proxy::storeResult(array (
  0 => NULL,
))
proxy::storeResult returns NULL
resource(730) of type (Mysqlnd Resultset (internal only - you must not modify it!))
array(1) {
  ["_msg"]=>
  string(13) "Good morning!"
}

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_store_result() - Transfers a result set from the last query
  • mysqli_real_query() - Execute an SQL query

MysqlndUhConnection::stmtInit
MysqlndUhConnection::txCommit
MysqlndUhConnection


Commits the current transaction

MysqlndUhConnection::storeResult
MysqlndUhConnection::txRollback
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::txCommit

(PECL mysqlnd-uh >= 1.0.1-alpha, PHP >= 5.4.0)

MysqlndUhConnection::txCommit — Commits the current transaction

Açıklama

public bool MysqlndUhConnection::txCommit ( mysqlnd_connection $connection )

Commits the current transaction.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

Dönen Değerler

Returns TRUE on success. Otherwise, returns FALSE

Örnekler

Örnek 1 MysqlndUhConnection::txCommit() example

<?php
class proxy extends MysqlndUhConnection {
 public function txCommit($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::txCommit($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->commit();
?>

Yukarıdaki örneğin çıktısı:

proxy::txCommit(array (
  0 => NULL,
))
proxy::txCommit returns true

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_commit() - Commits the current transaction

MysqlndUhConnection::storeResult
MysqlndUhConnection::txRollback
MysqlndUhConnection


Rolls back current transaction

MysqlndUhConnection::txCommit
MysqlndUhConnection::useResult
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::txRollback

(PECL mysqlnd-uh >= 1.0.1-alpha, PHP >= 5.4.0)

MysqlndUhConnection::txRollback — Rolls back current transaction

Açıklama

public bool MysqlndUhConnection::txRollback ( mysqlnd_connection $connection )

Rolls back current transaction.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

Dönen Değerler

Returns TRUE on success. Otherwise, returns FALSE

Örnekler

Örnek 1 MysqlndUhConnection::txRollback() example

<?php
class proxy extends MysqlndUhConnection {
 public function txRollback($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::txRollback($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->rollback();
?>

Yukarıdaki örneğin çıktısı:

proxy::txRollback(array (
  0 => NULL,
))
proxy::txRollback returns true

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_commit() - Commits the current transaction

MysqlndUhConnection::txCommit
MysqlndUhConnection::useResult
MysqlndUhConnection


Initiate a result set retrieval

MysqlndUhConnection::txRollback
MysqlndUhPreparedStatement
MysqlndUhConnection
PHP Manual

MysqlndUhConnection::useResult

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhConnection::useResult — Initiate a result set retrieval

Açıklama

public resource MysqlndUhConnection::useResult ( mysqlnd_connection $connection )

Initiate a result set retrieval.

Değiştirgeler

connection

Mysqlnd connection handle. Do not modify!

Dönen Değerler

Resource of type Mysqlnd Resultset (internal only - you must not modify it!). The documentation may also refer to such resources using the alias name mysqlnd_resultset.

Örnekler

Örnek 1 MysqlndUhConnection::useResult() example

<?php
class proxy extends MysqlndUhConnection {
 public function useResult($res) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $ret = parent::useResult($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  var_dump($ret);
  return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->real_query("SELECT 'Good morning!' AS _msg FROM DUAL");
$res = $mysqli->use_result();
var_dump($res->fetch_assoc());
?>

Yukarıdaki örneğin çıktısı:

proxy::useResult(array (
  0 => NULL,
))
proxy::useResult returns NULL
resource(425) of type (Mysqlnd Resultset (internal only - you must not modify it!))
array(1) {
  ["_msg"]=>
  string(13) "Good morning!"
}

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqli_use_result() - Initiate a result set retrieval
  • mysqli_real_query() - Execute an SQL query

MysqlndUhConnection::txRollback
MysqlndUhPreparedStatement
MysqlndUhConnection


The MysqlndUhPreparedStatement class

(PECL mysqlnd-uh >= 1.0.0-alpha)

Giriş

Sınıf Sözdizimi

MysqlndUhPreparedStatement {
/* Yöntemler */
public __construct ( void )
public bool execute ( mysqlnd_prepared_statement $statement )
public bool prepare ( mysqlnd_prepared_statement $statement , string $query )
}

İçindekiler

  • MysqlndUhPreparedStatement::__construct — The __construct purpose
  • MysqlndUhPreparedStatement::execute — Executes a prepared Query
  • MysqlndUhPreparedStatement::prepare — Prepare an SQL statement for execution
MysqlndUhConnection::useResult
MysqlndUhPreparedStatement::__construct
mysqlnd_uh


The __construct purpose

MysqlndUhPreparedStatement
MysqlndUhPreparedStatement::execute
MysqlndUhPreparedStatement
PHP Manual

MysqlndUhPreparedStatement::__construct

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhPreparedStatement::__construct — The __construct purpose

Açıklama

public MysqlndUhPreparedStatement::__construct ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

MysqlndUhPreparedStatement
MysqlndUhPreparedStatement::execute
MysqlndUhPreparedStatement


Executes a prepared Query

MysqlndUhPreparedStatement::__construct
MysqlndUhPreparedStatement::prepare
MysqlndUhPreparedStatement
PHP Manual

MysqlndUhPreparedStatement::execute

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhPreparedStatement::execute — Executes a prepared Query

Açıklama

public bool MysqlndUhPreparedStatement::execute ( mysqlnd_prepared_statement $statement )

Executes a prepared Query.

Değiştirgeler

statement

Mysqlnd prepared statement handle. Do not modify! Resource of type Mysqlnd Prepared Statement (internal only - you must not modify it!).

Dönen Değerler

Returns TRUE on success. Otherwise, returns FALSE

Örnekler

Örnek 1 MysqlndUhPreparedStatement::execute() example

<?php
class stmt_proxy extends MysqlndUhPreparedStatement {
 public function execute($res) {
  printf("%s(", __METHOD__);
  var_dump($res);
  printf(")\n");
  $ret = parent::execute($res);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  var_dump($ret);
  return $ret;
 }
}
mysqlnd_uh_set_statement_proxy(new stmt_proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$stmt = $mysqli->prepare("SELECT 'Labskaus' AS _msg FROM DUAL");
$stmt->execute();
$msg = NULL;
$stmt->bind_result($msg);
$stmt->fetch();
var_dump($msg);
?>

Yukarıdaki örneğin çıktısı:

stmt_proxy::execute(resource(256) of type (Mysqlnd Prepared Statement (internal only - you must not modify it!))
)
stmt_proxy::execute returns true
bool(true)
string(8) "Labskaus"

Ayrıca Bakınız

  • mysqlnd_uh_set_statement_proxy() - Installs a proxy for mysqlnd statements
  • mysqli_stmt_execute() - Executes a prepared Query

MysqlndUhPreparedStatement::__construct
MysqlndUhPreparedStatement::prepare
MysqlndUhPreparedStatement


Prepare an SQL statement for execution

MysqlndUhPreparedStatement::execute
Mysqlnd_uh İşlevleri
MysqlndUhPreparedStatement
PHP Manual

MysqlndUhPreparedStatement::prepare

(PECL mysqlnd-uh >= 1.0.0-alpha)

MysqlndUhPreparedStatement::prepare — Prepare an SQL statement for execution

Açıklama

public bool MysqlndUhPreparedStatement::prepare ( mysqlnd_prepared_statement $statement , string $query )

Prepare an SQL statement for execution.

Değiştirgeler

statement

Mysqlnd prepared statement handle. Do not modify! Resource of type Mysqlnd Prepared Statement (internal only - you must not modify it!).

query

The query to be prepared.

Dönen Değerler

Returns TRUE on success. Otherwise, returns FALSE

Örnekler

Örnek 1 MysqlndUhPreparedStatement::prepare() example

<?php
class stmt_proxy extends MysqlndUhPreparedStatement {
 public function prepare($res, $query) {
  printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
  $query = "SELECT 'No more you-know-what-I-mean for lunch, please' AS _msg FROM DUAL";
  $ret = parent::prepare($res, $query);
  printf("%s returns %s\n", __METHOD__, var_export($ret, true));
  var_dump($ret);
  return $ret;
 }
}
mysqlnd_uh_set_statement_proxy(new stmt_proxy());

$mysqli = new mysqli("localhost", "root", "", "test");
$stmt = $mysqli->prepare("SELECT 'Labskaus' AS _msg FROM DUAL");
$stmt->execute();
$msg = NULL;
$stmt->bind_result($msg);
$stmt->fetch();
var_dump($msg);
?>

Yukarıdaki örneğin çıktısı:

stmt_proxy::prepare(array (
  0 => NULL,
  1 => 'SELECT \'Labskaus\' AS _msg FROM DUAL',
))
stmt_proxy::prepare returns true
bool(true)
string(46) "No more you-know-what-I-mean for lunch, please"

Ayrıca Bakınız

  • mysqlnd_uh_set_statement_proxy() - Installs a proxy for mysqlnd statements
  • mysqli_stmt_prepare() - Prepare an SQL statement for execution
  • mysqli_prepare() - Prepare an SQL statement for execution

MysqlndUhPreparedStatement::execute
Mysqlnd_uh İşlevleri
MysqlndUhPreparedStatement


Mysqlnd_uh İşlevleri

İçindekiler

  • mysqlnd_uh_convert_to_mysqlnd — Converts a MySQL connection handle into a mysqlnd connection handle
  • mysqlnd_uh_set_connection_proxy — Installs a proxy for mysqlnd connections
  • mysqlnd_uh_set_statement_proxy — Installs a proxy for mysqlnd statements
MysqlndUhPreparedStatement::prepare
mysqlnd_uh_convert_to_mysqlnd
mysqlnd_uh


Converts a MySQL connection handle into a mysqlnd connection handle

Mysqlnd_uh İşlevleri
mysqlnd_uh_set_connection_proxy
Mysqlnd_uh İşlevleri
PHP Manual

mysqlnd_uh_convert_to_mysqlnd

(PECL mysqlnd-uh >= 1.0.0-alpha)

mysqlnd_uh_convert_to_mysqlnd — Converts a MySQL connection handle into a mysqlnd connection handle

Açıklama

resource mysqlnd_uh_convert_to_mysqlnd ( mysqli &$mysql_connection )

Converts a MySQL connection handle into a mysqlnd connection handle. After conversion you can execute mysqlnd library calls on the connection handle. This can be used to access mysqlnd functionality not made available through user space API calls.

The function can be disabled with mysqlnd_uh.enable. If mysqlnd_uh.enable is set to FALSE the function will not install the proxy and always return TRUE. Additionally, an error of the type E_WARNING may be emitted. The error message may read like PHP Warning: mysqlnd_uh_convert_to_mysqlnd(): (Mysqlnd User Handler) The plugin has been disabled by setting the configuration parameter mysqlnd_uh.enable = false. You are not allowed to call this function [...].

Değiştirgeler

MySQL connection handle

A MySQL connection handle of type mysql, mysqli or PDO_MySQL.

Dönen Değerler

A mysqlnd connection handle.

Sürüm Bilgisi

Sürüm: | Açıklama
5.4.0 | The mysql_connection parameter can now be of type mysql, PDO_MySQL, or mysqli. Before, only the mysqli type was allowed.

Örnekler

Örnek 1 mysqlnd_uh_convert_to_mysqlnd() example

<?php
/* PDO user API gives no access to connection thread id */
$mysql_connection = new PDO("mysql:host=localhost;dbname=test", "root", "");

/* Convert PDO MySQL handle to mysqlnd handle */
$mysqlnd = mysqlnd_uh_convert_to_mysqlnd($mysql_connection);

/* Create Proxy to call mysqlnd connection class methods */
$obj = new MySQLndUHConnection();
/* Call mysqlnd_conn::get_thread_id */
var_dump($obj->getThreadId($mysqlnd));

/* Use SQL to fetch connection thread id */
var_dump($mysql_connection->query("SELECT CONNECTION_ID()")->fetchAll());
?>

Yukarıdaki örneğin çıktısı:

int(27054)
array(1) {
  [0]=>
  array(2) {
    ["CONNECTION_ID()"]=>
    string(5) "27054"
    [0]=>
    string(5) "27054"
  }
}

Ayrıca Bakınız

  • mysqlnd_uh.enable

Mysqlnd_uh İşlevleri
mysqlnd_uh_set_connection_proxy
Mysqlnd_uh İşlevleri


Installs a proxy for mysqlnd connections

mysqlnd_uh_convert_to_mysqlnd
mysqlnd_uh_set_statement_proxy
Mysqlnd_uh İşlevleri
PHP Manual

mysqlnd_uh_set_connection_proxy

(PECL mysqlnd-uh >= 1.0.0-alpha)

mysqlnd_uh_set_connection_proxy — Installs a proxy for mysqlnd connections

Açıklama

bool mysqlnd_uh_set_connection_proxy ( MysqlndUhConnection &$connection_proxy [, mysqli &$mysqli_connection ] )

Installs a proxy object to hook mysqlnd's connection objects methods. Once installed, the proxy will be used for all MySQL connections opened with mysqli, mysql or PDO_MYSQL, assuming that the listed extensions are compiled to use the mysqlnd library.

The function can be disabled with mysqlnd_uh.enable. If mysqlnd_uh.enable is set to FALSE the function will not install the proxy and always return TRUE. Additionally, an error of the type E_WARNING may be emitted. The error message may read like PHP Warning: mysqlnd_uh_set_connection_proxy(): (Mysqlnd User Handler) The plugin has been disabled by setting the configuration parameter mysqlnd_uh.enable = false. The proxy has not been installed [...].

Değiştirgeler

connection_proxy

A proxy object of type MysqlndUhConnection.

mysqli_connection

Object of type mysqli. If given, the proxy will be set for this particular connection only.

Dönen Değerler

Returns TRUE on success. Otherwise, returns FALSE

Örnekler

Örnek 1 mysqlnd_uh_set_connection_proxy() example

<?php
$mysqli = new mysqli("localhost", "root", "", "test");
$mysqli->query("SELECT 'No proxy installed, yet'");

class proxy extends MysqlndUhConnection {
 public function query($res, $query) {
   printf("%s(%s)\n", __METHOD__, var_export(func_get_args(), true));
   $ret = parent::query($res, $query);
   printf("%s returns %s\n", __METHOD__, var_export($ret, true));
   return $ret;
 }
}
mysqlnd_uh_set_connection_proxy(new proxy());

$mysqli->query("SELECT 'mysqlnd rocks!'");

$mysql = mysql_connect("localhost", "root", "", "test");
mysql_query("SELECT 'Ahoy Andrey!'", $mysql);

$pdo = new PDO("mysql:host=localhost;dbname=test", "root", "");
$pdo->query("SELECT 'Moin Johannes!'");
?>

Yukarıdaki örneğin çıktısı:

proxy::query(array (
  0 => NULL,
  1 => 'SELECT \'mysqlnd rocks!\'',
))
proxy::query returns true
proxy::query(array (
  0 => NULL,
  1 => 'SELECT \'Ahoy Andrey!\'',
))
proxy::query returns true
proxy::query(array (
  0 => NULL,
  1 => 'SELECT \'Moin Johannes!\'',
))
proxy::query returns true

Ayrıca Bakınız

  • mysqlnd_uh_set_statement_proxy() - Installs a proxy for mysqlnd statements
  • mysqlnd_uh.enable

mysqlnd_uh_convert_to_mysqlnd
mysqlnd_uh_set_statement_proxy
Mysqlnd_uh İşlevleri


Installs a proxy for mysqlnd statements

mysqlnd_uh_set_connection_proxy
Change History
Mysqlnd_uh İşlevleri
PHP Manual

mysqlnd_uh_set_statement_proxy

(PECL mysqlnd-uh >= 1.0.0-alpha)

mysqlnd_uh_set_statement_proxy — Installs a proxy for mysqlnd statements

Açıklama

bool mysqlnd_uh_set_statement_proxy ( MysqlndUhStatement &$statement_proxy )

Installs a proxy for mysqlnd statements. The proxy object will be used for all mysqlnd prepared statement objects, regardless which PHP MySQL extension (mysqli, mysql, PDO_MYSQL) has created them as long as the extension is compiled to use the mysqlnd library.

The function can be disabled with mysqlnd_uh.enable. If mysqlnd_uh.enable is set to FALSE the function will not install the proxy and always return TRUE. Additionally, an error of the type E_WARNING may be emitted. The error message may read like PHP Warning: mysqlnd_uh_set_statement_proxy(): (Mysqlnd User Handler) The plugin has been disabled by setting the configuration parameter mysqlnd_uh.enable = false. The proxy has not been installed [...].

Değiştirgeler

statement_proxy

The mysqlnd statement proxy object of type MysqlndUhStatement

Dönen Değerler

Returns TRUE on success. Otherwise, returns FALSE

Ayrıca Bakınız

  • mysqlnd_uh_set_connection_proxy() - Installs a proxy for mysqlnd connections
  • mysqlnd_uh.enable

mysqlnd_uh_set_connection_proxy
Change History
Mysqlnd_uh İşlevleri


Change History

İçindekiler

  • PECL/mysqlnd_uh 1.0 series

The Change History lists major changes users need to be aware if upgrading from one version to another. It is a high level summary of selected changes that may impact applications or might even break backwards compatibility. See also the CHANGES file contained in the source for additional changelog information. The commit history is also available.

mysqlnd_uh_set_statement_proxy
PECL/mysqlnd_uh 1.0 series
mysqlnd_uh


PECL/mysqlnd_uh 1.0 series

1.0.1-alpha

  • Release date: TBD
  • Motto/theme: bug fix release

Feature changes

  • Support of PHP 5.4.0 or later.
  • BC break: MysqlndUhConnection::changeUser() requires additional passwd_len parameter.
  • BC break: MYSQLND_UH_VERSION_STR renamed to MYSQLND_UH_VERSION. MYSQLND_UH_VERSION renamed to MYSQLND_UH_VERSION_ID.
  • BC break: mysqlnd_uh.enabled configuration setting renamed to mysqlnd_uh.enable.

1.0.0-alpha

  • Release date: 08/2010
  • Motto/theme: Initial release

Change History
mysqlnd_mux
Change History


Mysqlnd connection multiplexing plugin

  • Giriş
  • Concepts
    • Architecture
    • Connection pool
    • Sharing connections
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
  • Öntanımlı Sabitler
  • Change History
    • PECL/mysqlnd_mux 1.0 series
PECL/mysqlnd_uh 1.0 series
Giriş
MySQL


Giriş

The mysqlnd multiplexing plugin (mysqlnd_mux) multiplexes MySQL connections established by all PHP MySQL extensions that use the MySQL native driver (mysqlnd) for PHP.

The MySQL native driver for PHP features an internal C API for plugins, such as the connection multiplexing plugin, which can extend the functionality of mysqlnd. See the mysqlnd for additional details about its benefits over the MySQL Client Library libmysqlclient.

Mysqlnd plugins like mysqlnd_mux operate, for the most part, transparently from a user perspective. The connection multiplexing plugin supports all PHP applications, and all MySQL PHP extensions. It does not change existing APIs. Therefore, it can easily be used with existing PHP applications.

Bilginize:

This is a proof-of-concept. All features are at an early stage. Not all kinds of queries are handled by the plugin yet. Thus, it cannot be used in a drop-in fashion at the moment.

Please, do not use this version in production environments.

Key Features

The key features of mysqlnd_mux are as follows:

  • Transparent and therefore easy to use:

    • Supports all of the PHP MySQL extensions.

    • Little to no application changes are required, dependent on the required usage scenario.

  • Reduces server load and connection establishment latency:

    • Opens less connections to the MySQL server.

    • Less connections to MySQL mean less work for the MySQL server. In a client-server environment scaling the server is often more difficult than scaling the client. Multiplexing helps with horizontal scale-out (scale-by-client).

    • Pooling saves connection time.

    • Multiplexed connection: multiple user handles share the same network connection. Once opened, a network connection is cached and shared among multiple user handles. There is a 1:n relationship between internal network connection and user connection handles.

    • Persistent connection: a network connection is kept open at the end of the web request, if the PHP deployment model allows. Thus, subsequently web requests can reuse a previously opened connection. Like other resources, network connections are bound to the scope of a process. Thus, they can be reused for all web requests served by a process.

Limitations

The proof-of-concept does not support unbuffered queries, prepared statements, and asynchronous queries.

The connection pool is using a combination of the transport method and hostname as keys. As a consequence, two connections to the same host using the same transport method (TCP/IP, Unix socket, Windows named pipe) will be linked to the same pooled connection even if username and password differ. Be aware of the possible security implications.

The proof-of-concept is transaction agnostic. It does not know about SQL transactions.

Bilginize:

Applications must be aware of the consequences of connection sharing connections.

About the name mysqlnd_mux

The shortcut mysqlnd_mux stands for mysqlnd connection multiplexing plugin.

mysqlnd_mux
Concepts
mysqlnd_mux


Concepts

İçindekiler

  • Architecture
  • Connection pool
  • Sharing connections

This explains the architecture and related concepts for this plugin. Reading and understanding these concepts is required to successfully use this plugin.

Giriş
Architecture
mysqlnd_mux


Architecture

The mysqlnd connection multiplexing plugin is implemented as a PHP extension. It is written in C and operates under the hood of PHP. During the startup of the PHP interpreter, in the module initialization phase of the PHP engine, it gets registered as a mysqlnd plugin to replace specific mysqlnd C methods.

The mysqlnd library uses PHP streams to communicate with the MySQL server. PHP streams are accessed by the mysqlnd library through its net module. The mysqlnd connection multiplexing plugin proxies methods of the mysqlnd library net module to control opening and closing of network streams.

Upon opening a user connection to MySQL using the appropriate connection functions of either mysqli, PDO_MYSQL or ext/mysql, the plugin will search its connection pool for an open network connection. If the pool contains a network connection to the host specified by the connect function using the transport method requested (TCP/IP, Unix domain socket, Windows named pipe), the pooled connection is linked to the user handle. Otherwise, a new network connection is opened, put into the poolm and associated with the user connection handle. This way, multiple user handles can be linked to the same network connection.

Concepts
Connection pool
Concepts


Connection pool

The plugins connection pool is created when PHP initializes its modules (MINIT) and free'd when PHP shuts down the modules (MSHUTDOWN). This is the same as for persistent MySQL connections.

Depending on the deployment model, the pool is used for the duration of one or multiple web requests. Network connections are bound to the lifespan of an operating system level process. If the PHP process serves multiple web requests as it is the case for Fast-CGI or threaded web server deployments, then the pooled connections can be reused over multiple connections. Because multiplexing means sharing connections, it can even happen with a threaded deployment that two threads or two distinct web requests are linked to one pooled network connections.

A pooled connection is explicitly closed once the last reference to it is released. An implicit close happens when PHP shuts down its modules.

Architecture
Sharing connections
Concepts


Sharing connections

The PHP mysqlnd connection multiplexing plugin changes the relationship between a users connection handle and the underlying MySQL connection. Without the plugin, every MySQL connection belongs to exactly one user connection at a time. The multiplexing plugin changes. A MySQL connection is shared among multiple user handles. There no one-to-one relation if using the plugin.

Sharing pooled connections has an impact on the connection state. State changing operations from multiple user handles pointing to one MySQL connection are not isolated from each other. If, for example, a session variable is set through one user connection handle, the session variable becomes visible to all other user handles that reference the same underlying MySQL connection.

This is similar in concept to connection state related phenomens described for the PHP mysqlnd replication and load balancing plugin. Please, check the PECL/mysqlnd_ms documentation for more details on the state of a connection.

The proof-of-concept takes no measures to isolate multiplexed connections from each other.

Connection pool
Yapılandırma/Kurulum
Concepts


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
Sharing connections
Gereksinimler
mysqlnd_mux


Gereksinimler

PHP 5.5.0 or newer. Some advanced functionality requires PHP 5.5.0 or newer.

The mysqlnd_mux replication and load balancing plugin supports all PHP applications and all available PHP MySQL extensions (mysqli, mysql, PDO_MYSQL). The PHP MySQL extension must be configured to use mysqlnd in order to be able to use the mysqlnd_mux plugin for mysqlnd.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/mysqlnd_mux

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Mysqlnd_mux Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
mysqlnd_mux.enable | 0 | PHP_INI_SYSTEM |

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

mysqlnd_mux.enable integer

Enables or disables the plugin. If disabled, the extension will not plug into mysqlnd to proxy internal mysqlnd C API calls.

Kurulum
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

Other

The plugins version number can be obtained using MYSQLND_MUX_VERSION or MYSQLND_MUX_VERSION_ID. MYSQLND_MUX_VERSION is the string representation of the numerical version number MYSQLND_MUX_VERSION_ID, which is an integer such as 10000. Developers can calculate the version number as follows.

Version (part) | Example
Major*10000 | 1*10000 = 10000
Minor*100 | 0*100 = 0
Patch | 0 = 0
MYSQLND_MUX_VERSION_ID | 10000

MYSQLND_MUX_VERSION (string)
Plugin version string, for example, "1.0.0-prototype".
MYSQLND_MUX_VERSION_ID (integer)
Plugin version number, for example, 10000.

Çalışma Anı Yapılandırması
Change History
mysqlnd_mux


Change History

İçindekiler

  • PECL/mysqlnd_mux 1.0 series

This change history is a high level summary of selected changes that may impact applications and/or break backwards compatibility.

See also the CHANGES file in the source distribution for a complete list of changes.

Öntanımlı Sabitler
PECL/mysqlnd_mux 1.0 series
mysqlnd_mux


PECL/mysqlnd_mux 1.0 series

1.0.0-pre-alpha

  • Release date: no package released, initial check-in 09/2012
  • Motto/theme: Proof of concept

Initial check-in. Essentially a demo of the mysqlnd plugin API.

Bilginize:

This is the current development series. All features are at an early stage. Changes may happen at any time without prior notice. Please, do not use this version in production environments.

The documentation may not reflect all changes yet.

Change History
mysqlnd_memcache
Change History


Mysqlnd Memcache plugin

  • Giriş
  • Quickstart and Examples
    • Setup
    • Usage
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
  • Öntanımlı Sabitler
  • Mysqlnd_memcache İşlevleri
    • mysqlnd_memcache_get_config — Returns information about the plugin configuration
    • mysqlnd_memcache_set — Associate a MySQL connection with a Memcache connection
  • Change History
    • PECL/mysqlnd_memcache 1.0 series
PECL/mysqlnd_mux 1.0 series
Giriş
MySQL


Giriş

The mysqlnd memcache plugin (mysqlnd_memcache) is an PHP extension for transparently translating SQL into requests for the MySQL InnoDB Memcached Daemon Plugin (server plugin). It includes experimental support for the MySQL Cluster Memcached Daemon. The server plugin provides access to data stored inside MySQL InnoDB (respectively MySQL Cluster NDB) tables using the Memcache protocol. This PHP extension, which supports all PHP MySQL extensions that use mysqlnd, will identify tables exported in this way and will translate specific SELECT queries into Memcache requests.

mysqlnd_memcache data flow

Bilginize:

This plugin depends on the MySQL InnoDB Memcached Daemon Plugin. It is not provided to be used with a stand-alone Memcached. For a generic query cache using Memcached look at the mysqlnd query cache plugin. For direct Memcache access look at the memcache and memcached extensions.

The MySQL native driver for PHP is a C library that ships together with PHP as of PHP 5.3.0. It serves as a drop-in replacement for the MySQL Client Library (libmysqlclient). Using mysqlnd has several advantages: no extra downloads are required because it's bundled with PHP, it's under the PHP license, there is lower memory consumption in certain cases, and it contains new functionality such as asynchronous queries.

The mysqlnd_mmemcache operates, for the most part, transparently from a user perspective. The mysqlnd memcache plugin supports all PHP applications, and all MySQL PHP extensions. It does not change existing APIs. Therefore, it can easily be used with existing PHP applications.

The MySQL Memcache plugins add key-value style access method for data stored in InnoDB resp. NDB (MySQL Cluster) SQL tables through the Memcache protocol. This type of key-value access if often faster than using SQL.

Key Features

The key features of PECL/mysqlnd_memcache are as follows.

  • Possible performance benefits

    • Client-side: light-weight protocol.

    • Server-side: no SQL parsing, direct access to the storage.

    • Please, run your own benchmarks! Actual performance results are highly dependent on setup and hardware used.

Limitations

The initial version is not binary safe. Due to the way the MySQL Memcache plugins works there are restrictions related to separators.

Prepared statements and asynchronous queries are not supported. Result set meta data support is limited.

The mapping information for tables accessible via Memcache is not cached in the plugin between requests but fetched from the MySQL server each time a MySQL connection is associated with a Memcache connection. See mysqlnd_memcache_set() for details.

On the name

The shortcut mysqlnd_memcache stands for mysqlnd memcache plugin. Memcache refers to support of the MySQL Memcache plugins for InnoDB and NDB (MySQL Cluster). The plugin is not related to the Memcached cache server.

mysqlnd_memcache
Quickstart and Examples
mysqlnd_memcache


Quickstart and Examples

İçindekiler

  • Setup
  • Usage

The mysqlnd memcache plugin is easy to use. This quickstart will demo typical use-cases, and provide practical advice on getting started.

It is strongly recommended to read the reference sections in addition to the quickstart. The quickstart tries to avoid discussing theoretical concepts and limitations. Instead, it will link to the reference sections. It is safe to begin with the quickstart. However, before using the plugin in mission critical environments we urge you to read additionally the background information from the reference sections.

Giriş
Setup
mysqlnd_memcache


Setup

The plugin is implemented as a PHP extension. See also the installation instructions to install this extension.

Compile or configure the PHP MySQL extension (API) (mysqli, PDO_MYSQL, mysql). That extension must use the mysqlnd library as because mysqlnd_memcache is a plugin for the mysqlnd library. For additional information, refer to the mysqlnd_memcache installation instructions.

Then, load this extension into PHP and activate the plugin in the PHP configuration file using the PHP configuration directive named mysqlnd_memcache.enable.

Örnek 1 Enabling the plugin (php.ini)

; On Windows the filename is php_mysqnd_memcache.dll
; Load the extension
extension=mysqlnd_memcache.so
; Enable it
mysqlnd_memcache.enable=1

Follow the instructions given in the » MySQL Reference Manual on installing the Memcache plugins for the MySQL server. Activate the plugins and configure Memcache access for SQL tables.

The examples in this quickguide assume that the following table exists, and that Memcache is configured with access to it.

Örnek 2 SQL table used for the Quickstart

CREATE TABLE test(
  id CHAR(16),
  f1 VARCHAR(255),
  f2 VARCHAR(255),
  f3 VARCHAR(255),
  flags INT NOT NULL,
  cas_column INT,
  expire_time_column INT,
  PRIMARY KEY(id)
  ) ENGINE=InnoDB;

INSERT INTO test (id, f1, f2, f3) VALUES (1, 'Hello', 'World', '!');
INSERT INTO test (id, f1, f2, f3) VALUES (2, 'Lady', 'and', 'the tramp');

INSERT INTO innodb_memcache.containers(
  name, db_schema, db_table, key_columns, value_columns,
  flags, cas_column, expire_time_column, unique_idx_name_on_key)
VALUES (
  'plugin_test', 'test', 'test', 'id', 'f1,f2,f3',
  'flags', 'cas_column', 'expire_time_column', 'PRIMARY KEY');

Quickstart and Examples
Usage
Quickstart and Examples


Usage

After associating a MySQL connection with a Memcache connection using mysqnd_memcache_set() the plugin attempts to transparently replace SQL SELECT statements by a memcache access. For that purpose the plugin monitors all SQL statements executed and tries to match the statement string against MYSQLND_MEMCACHE_DEFAULT_REGEXP. In case of a match, the mysqlnd memcache plugin checks whether the SELECT is accessing only columns of a mapped table and the WHERE clause is limited to a single key lookup.

In case of the example SQL table, the plugin will use the Memcache interface of the MySQL server to fetch results for a SQL query like SELECT f1, f2, f3 WHERE id = n.

Örnek 1 Basic example.

<?php
$mysqli = new mysqli("host", "user", "passwd", "database");
$memc = new Memcached();
$memc->addServer("host", 11211);
mysqlnd_memcache_set($mysqli, $memc);

/*
   This is a query which queries table test using id as key in the WHERE part
   and is accessing fields f1, f2 and f3. Therefore, mysqlnd_memcache
   will intercept it and route it via memcache.
*/
$result = $mysqli->query("SELECT f1, f2, f3 FROM test WHERE id = 1");
while ($row = $result->fetch_row()) {
    print_r($row);
}

/*
   This is a query which queries table test but using f1 in the WHERE clause.
   Therefore, mysqlnd_memcache can't intercept it. This will be executed
   using the MySQL protocol
*/
$mysqli->query("SELECT id FROM test WHERE f1 = 'Lady'");
while ($row = $result->fetch_row()) {
    print_r($row);
}
?>

Yukarıdaki örneğin çıktısı:

array(
    [f1] => Hello
    [f2] => World
    [f3] => !
)
array(
    [id] => 2
)

Setup
Yapılandırma/Kurulum
Quickstart and Examples


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
Usage
Gereksinimler
mysqlnd_memcache


Gereksinimler

PHP: this extension requires PHP 5.4+, version PHP 5.4.4 or never. The required PHP extensions are PCRE (enabled by default), and the memcached extension version 2.0.x.

The mysqlnd_memcache Memcache plugin supports all PHP applications and all available PHP MySQL extensions (mysqli, mysql, PDO_MYSQL). The PHP MySQL extension must be configured with mysqlnd support.

For accessing InnoDB tables, this PHP extension requires MySQL Server 5.6.6 or newer with the InnoDB Memcache Daemon Plugin enabled.

For accessing MySQL Cluster NDB tables, this PHP extension requires MySQL Cluster 7.2 or newer with the NDB Memcache API nodes enabled.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu » PECL eklentisi PHP ile gelmez.

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/mysqlnd_memcache

Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Mysqlnd_memcache Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
mysqlnd_memcache.enable | 1 | PHP_INI_SYSTEM | Available since 1.0.0

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

mysqlnd_memcache.enable integer

Enables or disables the plugin. If disabled, the extension will not plug into mysqlnd to proxy internal mysqlnd C API calls.

Bilginize:

This option is mainly used by developers to build this extension statically into PHP. General users are encouraged to build this extension as a shared object, and to unload it completely when it is not needed.

Kurulum
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

MySQL Memcache Plugin related

MYSQLND_MEMCACHE_DEFAULT_REGEXP (string)
Default regular expression (PCRE style) used for matching SELECT statements that will be mapped into a MySQL Memcache Plugin access point, if possible. It is also possible to use mysqlnd_memcache_set(), but the default approach is using this regular expression for pattern matching.

Assorted

The version number of this plugin can be obtained by using MYSQLND_MEMCACHE_VERSION or MYSQLND_MEMCACHE_VERSION_ID. MYSQLND_MEMCACHE_VERSION is the string representation of the numerical version number MYSQLND_MEMCACHE_VERSION_ID, which is an integer such as 10000. Developers can calculate the version number as follows.

Version (part) | Example
Major*10000 | 1*10000 = 10000
Minor*100 | 0*100 = 0
Patch | 0 = 0
MYSQLND_MEMCACHE_VERSION_ID | 10000

MYSQLND_MEMCACHE_VERSION (string)
Plugin version string, for example, "1.0.0-alpha".
MYSQLND_MEMCACHE_VERSION_ID (integer)
Plugin version number, for example, 10000.

Çalışma Anı Yapılandırması
Mysqlnd_memcache İşlevleri
mysqlnd_memcache


Mysqlnd_memcache İşlevleri

İçindekiler

  • mysqlnd_memcache_get_config — Returns information about the plugin configuration
  • mysqlnd_memcache_set — Associate a MySQL connection with a Memcache connection
Öntanımlı Sabitler
mysqlnd_memcache_get_config
mysqlnd_memcache


Returns information about the plugin configuration

Mysqlnd_memcache İşlevleri
mysqlnd_memcache_set
Mysqlnd_memcache İşlevleri
PHP Manual

mysqlnd_memcache_get_config

(PECL mysqlnd_memcache >= 1.0.0)

mysqlnd_memcache_get_config — Returns information about the plugin configuration

Açıklama

array mysqlnd_memcache_get_config ( mixed $connection )

This function returns an array of all mysqlnd_memcache related configuration information that is attached to the MySQL connection. This includes MySQL, the Memcache object provided via mysqlnd_memcache_set(), and the table mapping configuration that was automatically collected from the MySQL Server.

Değiştirgeler

connection

A handle to a MySQL Server using one of the MySQL API extensions for PHP, which are PDO_MYSQL, mysqli or ext/mysql.

Dönen Değerler

An array of mysqlnd_memcache configuration information on success, otherwise FALSE.

The returned array has these elements:

mysqlnd_memcache_get_config() array structure
Array Key | Description
memcached | Instance of Memcached associated to this MySQL connection by mysqlnd_memcache_set(). You can use this to change settings of the memcache connection, or directly by querying the server on this connection.
pattern | The PCRE regular expression used to match the SQL query sent to the server. Queries matching this pattern will be further analyzed to decide whether the query can be intercepted and sent via the memcache interface or whether the query is sent using the general MySQL protocol to the server. The pattern is either the default pattern (MYSQLND_MEMCACHE_DEFAULT_REGEXP) or it is set via mysqlnd_memcache_set().
mappings | An associative array with a list of all configured containers as they were discovered by this plugin. The key for these elements is the name of the container in the MySQL configuration. The value is described below. The contents of this field is created by querying the MySQL Server during association to MySQL and a memcache connection using mysqlnd_memcache_set().
mapping_query | An SQL query used during mysqlnd_memcache_set() to identify the available containers and mappings. The result of that query is provided in the mappings element.
Mapping entry structure
Array Key | Description
prefix | A prefix used while accessing data via memcache. With the MySQL InnoDB Memcache Deamon plugin, this usually begins with @@ and ends with a configurable separator. This prefix is placed in front of the key value while using the memcache protocol.
schema_name | Name of the schema (database) which contains the table being accessed.
table_name | Name of the table which contains the data accessible via memcache protocol.
id_field_name | Name of the database field (column) with the id used as key when accessing the table via memcache. Often this is the database field having a primary key.
separator The separator used to split the different field values. This is needed as memcache only provides access to a single value while MySQL can map multiple columns to this value.

Bilginize:

The separator, which can be set in the MySQL Server configuration, should not be part of any value retrieved via memcache because proper mapping can't be guaranteed.

fields | An array with the name of all fields available for this mapping.

Örnekler

Örnek 1 mysqlnd_memcache_get_config() example

<?php
$mysqli = new mysqli("host", "user", "passwd", "database");
$memc = new Memcached();
$memc->addServer("host", 11211);
mysqlnd_memcache_set($mysqli, $memc);

var_dump(mysqlnd_memcache_get_config($mysqli));
?>

Yukarıdaki örneğin çıktısı:

array(4) {
  ["memcached"]=>
  object(Memcached)#2 (0) {
  }
  ["pattern"]=>
  string(125) "/^\s*SELECT\s*(.+?)\s*FROM\s*`?([a-z0-9_]+)`?\s*WHERE\s*`?([a-z0-9_]+)`?\s*=\s*(?(?=["'])["']([^"']*)["']|([0-9e\.]*))\s*$/is"
  ["mappings"]=>
  array(1) {
    ["mymem_test"]=>
    array(6) {
      ["prefix"]=>
      string(13) "@@mymem_test."
      ["schema_name"]=>
      string(4) "test"
      ["table_name"]=>
      string(10) "mymem_test"
      ["id_field_name"]=>
      string(2) "id"
      ["separator"]=>
      string(1) "|"
      ["fields"]=>
      array(3) {
        [0]=>
        string(2) "f1"
        [1]=>
        string(2) "f2"
        [2]=>
        string(2) "f3"
      }
    }
  }
  ["mapping_query"]=>
  string(209) "    SELECT c.name,
                          CONCAT('@@', c.name, (SELECT value FROM innodb_memcache.config_options WHERE name = 'table_map_delimiter')) AS key_prefix,
                          c.db_schema,
                          c.db_table,
                          c.key_columns,
                          c.value_columns,
                          (SELECT value FROM innodb_memcache.config_options WHERE name = 'separator') AS sep
                     FROM innodb_memcache.containers c"
}

Ayrıca Bakınız

  • mysqlnd_memcache_set() - Associate a MySQL connection with a Memcache connection

Mysqlnd_memcache İşlevleri
mysqlnd_memcache_set
Mysqlnd_memcache İşlevleri


Associate a MySQL connection with a Memcache connection

mysqlnd_memcache_get_config
Change History
Mysqlnd_memcache İşlevleri
PHP Manual

mysqlnd_memcache_set

(PECL mysqlnd_memcache >= 1.0.0)

mysqlnd_memcache_set — Associate a MySQL connection with a Memcache connection

Açıklama

bool mysqlnd_memcache_set ( mixed $mysql_connection [, Memcached $memcache_connection [, string $pattern [, callback $callback ]]] )

Associate mysql_connection with memcache_connection using pattern as a PCRE regular expression, and callback as a notification callback or to unset the association of mysql_connection.

While associating a MySQL connection with a Memcache connection, this function will query the MySQL Server for its configuration. It will automatically detect whether the server is configured to use the InnoDB Memcache Daemon Plugin or MySQL Cluster NDB Memcache support. It will also query the server to automatically identify exported tables and other configuration options. The results of this automatic configuration can be retrieved using mysqlnd_memcache_get_config().

Değiştirgeler

mysql_connection

A handle to a MySQL Server using one of the MySQL API extensions for PHP, which are PDO_MYSQL, mysqli or ext/mysql.

memcache_connection

A Memcached instance with a connection to the MySQL Memcache Daemon plugin. If this parameter is omitted, then mysql_connection will be unassociated from any memcache connection. And if a previous association exists, then it will be replaced.

pattern

A regular expression in Perl Compatible Regular Expression syntax used to identify potential Memcache-queries. The query should have three sub patterns. The first subpattern contains the requested field list, the second the name of the ID column from the query and the third the requested value. If this parameter is omitted or os set to NULL, then a default pattern will be used.

callback

A callback which will be used whenever a query is being sent to MySQL. The callback will receive a single boolean parameter telling if a query was sent via Memcache.

Dönen Değerler

TRUE if the association or disassociation is successful, otherwise FALSE if there is an error.

Örnekler

Örnek 1 mysqlnd_memcache_set() example with var_dump() as a simple debugging callback.

<?php
$mysqli = new mysqli("host", "user", "passwd", "database");
$memc = new Memcached();
$memc->addServer("host", 11211);
mysqlnd_memcache_set($mysqli, $memc, NULL, 'var_dump');

/* This query will be intercepted and executed via Memcache protocol */
echo "Sending query for id via Memcache: ";
$mysqli->query("SELECT f1, f2, f3 FROM test WHERE id = 1");

/* f1 is not configured as valid key field, this won't be sent via Memcache */
echo "Sending query for f1 via Memcache: ";
$mysqli->query("SELECT id FROM test WHERE f1 = 1");

mysqlnd_memcache_set($mysqli);

/* Now the regular MySQL protocol will be used */
echo "var_dump won't be invoked: ";
$mysqli->query("SELECT f1, f2, f3 WHERE id = 1");

?>

Yukarıdaki örneğin çıktısı:

Sending query for id via Memcache: bool(true)
Sending query for f1 via Memcache: bool(false)
var_dump won't be invoked:

Ayrıca Bakınız

  • mysqlnd_memcache_get_config() - Returns information about the plugin configuration

mysqlnd_memcache_get_config
Change History
Mysqlnd_memcache İşlevleri


Change History

İçindekiler

  • PECL/mysqlnd_memcache 1.0 series

This change history is a high level summary of selected changes that may impact applications and/or break backwards compatibility.

See also the CHANGES file in the source distribution for a complete list of changes.

mysqlnd_memcache_set
PECL/mysqlnd_memcache 1.0 series
mysqlnd_memcache


PECL/mysqlnd_memcache 1.0 series

1.0.0-alpha

  • Release date: TBD
  • Motto/theme: Basic mapping of SQL SELECT to a MySQL Memcache plugin access.

The initial release does map basic SQL SELECT statements to a MySQL Memcache plugin access. This bares potential performance benefits as the direct key-value access to MySQL storage using the Memcache protocol is usually faster than using SQL access.

Change History
OCI8
Change History


Oracle OCI8

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Testing
    • Çalışma Anı Yapılandırması
  • Öntanımlı Sabitler
  • Örnekler
  • OCI8 Connection Handling and Connection Pooling
  • OCI8 Fast Application Notification (FAN) Support
  • OCI8 and DTrace Dynamic Tracing
  • Supported Datatypes
  • OCI8 İşlevleri
    • oci_bind_array_by_name — Binds a PHP array to an Oracle PL/SQL array parameter
    • oci_bind_by_name — Binds a PHP variable to an Oracle placeholder
    • oci_cancel — Cancels reading from cursor
    • oci_client_version — Returns the Oracle client library version
    • oci_close — Closes an Oracle connection
    • oci_commit — Commits the outstanding database transaction
    • oci_connect — Connect to an Oracle database
    • oci_define_by_name — Associates a PHP variable with a column for query fetches
    • oci_error — Returns the last error found
    • oci_execute — Executes a statement
    • oci_fetch_all — Fetches multiple rows from a query into a two-dimensional array
    • oci_fetch_array — Returns the next row from a query as an associative or numeric array
    • oci_fetch_assoc — Returns the next row from a query as an associative array
    • oci_fetch_object — Returns the next row from a query as an object
    • oci_fetch_row — Returns the next row from a query as a numeric array
    • oci_fetch — Fetches the next row from a query into internal buffers
    • oci_field_is_null — Checks if a field in the currently fetched row is NULL
    • oci_field_name — Returns the name of a field from the statement
    • oci_field_precision — Tell the precision of a field
    • oci_field_scale — Tell the scale of the field
    • oci_field_size — Returns field's size
    • oci_field_type_raw — Tell the raw Oracle data type of the field
    • oci_field_type — Returns a field's data type name
    • oci_free_descriptor — Frees a descriptor
    • oci_free_statement — Frees all resources associated with statement or cursor
    • oci_get_implicit_resultset — Returns the next child statement resource from a parent statement resource that has Oracle Database 12c Implicit Result Sets
    • oci_internal_debug — Enables or disables internal debug output
    • oci_lob_copy — Copies large object
    • oci_lob_is_equal — Compares two LOB/FILE locators for equality
    • oci_new_collection — Allocates new collection object
    • oci_new_connect — Connect to the Oracle server using a unique connection
    • oci_new_cursor — Allocates and returns a new cursor (statement handle)
    • oci_new_descriptor — Initializes a new empty LOB or FILE descriptor
    • oci_num_fields — Returns the number of result columns in a statement
    • oci_num_rows — Returns number of rows affected during statement execution
    • oci_parse — Prepares an Oracle statement for execution
    • oci_password_change — Changes password of Oracle's user
    • oci_pconnect — Connect to an Oracle database using a persistent connection
    • oci_result — Returns field's value from the fetched row
    • oci_rollback — Rolls back the outstanding database transaction
    • oci_server_version — Returns the Oracle Database version
    • oci_set_action — Sets the action name
    • oci_set_client_identifier — Sets the client identifier
    • oci_set_client_info — Sets the client information
    • oci_set_edition — Sets the database edition
    • oci_set_module_name — Sets the module name
    • oci_set_prefetch — Sets number of rows to be prefetched by queries
    • oci_statement_type — Returns the type of a statement
  • OCI-Collection — The OCI-Collection class
    • OCI-Collection::append — Appends element to the collection
    • OCI-Collection::assign — Assigns a value to the collection from another existing collection
    • OCI-Collection::assignElem — Assigns a value to the element of the collection
    • OCI-Collection::free — Frees the resources associated with the collection object
    • OCI-Collection::getElem — Returns value of the element
    • OCI-Collection::max — Returns the maximum number of elements in the collection
    • OCI-Collection::size — Returns size of the collection
    • OCI-Collection::trim — Trims elements from the end of the collection
  • OCI-Lob — The OCI-Lob class
    • OCI-Lob::append — Appends data from the large object to another large object
    • OCI-Lob::close — Closes LOB descriptor
    • OCI-Lob::eof — Tests for end-of-file on a large object's descriptor
    • OCI-Lob::erase — Erases a specified portion of the internal LOB data
    • OCI-Lob::export — Exports LOB's contents to a file
    • OCI-Lob::flush — Flushes/writes buffer of the LOB to the server
    • OCI-Lob::free — Frees resources associated with the LOB descriptor
    • OCI-Lob::getBuffering — Returns current state of buffering for the large object
    • OCI-Lob::import — Imports file data to the LOB
    • OCI-Lob::load — Returns large object's contents
    • OCI-Lob::read — Reads part of the large object
    • OCI-Lob::rewind — Moves the internal pointer to the beginning of the large object
    • OCI-Lob::save — Saves data to the large object
    • OCI-Lob::saveFile — Takma Adı: OCI-Lob::import
    • OCI-Lob::seek — Sets the internal pointer of the large object
    • OCI-Lob::setBuffering — Changes current state of buffering for the large object
    • OCI-Lob::size — Returns size of large object
    • OCI-Lob::tell — Returns the current position of internal pointer of large object
    • OCI-Lob::truncate — Truncates large object
    • OCI-Lob::write — Writes data to the large object
    • OCI-Lob::writeTemporary — Writes a temporary large object
    • OCI-Lob::writeToFile — Takma Adı: OCI-Lob::export
  • OCI8 Obsolete Aliases and Functions
    • ocibindbyname — Takma Adı: oci_bind_by_name
    • ocicancel — Takma Adı: oci_cancel
    • ocicloselob — Takma Adı: OCI-Lob::close
    • ocicollappend — Takma Adı: OCI-Collection::append
    • ocicollassign — Takma Adı: OCI-Collection::assign
    • ocicollassignelem — Takma Adı: OCI-Collection::assignElem
    • ocicollgetelem — Takma Adı: OCI-Collection::getElem
    • ocicollmax — Takma Adı: OCI-Collection::max
    • ocicollsize — Takma Adı: OCI-Collection::size
    • ocicolltrim — Takma Adı: OCI-Collection::trim
    • ocicolumnisnull — Takma Adı: oci_field_is_null
    • ocicolumnname — Takma Adı: oci_field_name
    • ocicolumnprecision — Takma Adı: oci_field_precision
    • ocicolumnscale — Takma Adı: oci_field_scale
    • ocicolumnsize — Takma Adı: oci_field_size
    • ocicolumntype — Takma Adı: oci_field_type
    • ocicolumntyperaw — Takma Adı: oci_field_type_raw
    • ocicommit — Takma Adı: oci_commit
    • ocidefinebyname — Takma Adı: oci_define_by_name
    • ocierror — Takma Adı: oci_error
    • ociexecute — Takma Adı: oci_execute
    • ocifetch — Takma Adı: oci_fetch
    • ocifetchinto — Obsolete variant of oci_fetch_array, oci_fetch_object, oci_fetch_assoc and oci_fetch_row
    • ocifetchstatement — Takma Adı: oci_fetch_all
    • ocifreecollection — Takma Adı: OCI-Collection::free
    • ocifreecursor — Takma Adı: oci_free_statement
    • ocifreedesc — Takma Adı: OCI-Lob::free
    • ocifreestatement — Takma Adı: oci_free_statement
    • ociinternaldebug — Takma Adı: oci_internal_debug
    • ociloadlob — Takma Adı: OCI-Lob::load
    • ocilogoff — Takma Adı: oci_close
    • ocilogon — Takma Adı: oci_connect
    • ocinewcollection — Takma Adı: oci_new_collection
    • ocinewcursor — Takma Adı: oci_new_cursor
    • ocinewdescriptor — Takma Adı: oci_new_descriptor
    • ocinlogon — Takma Adı: oci_new_connect
    • ocinumcols — Takma Adı: oci_num_fields
    • ociparse — Takma Adı: oci_parse
    • ociplogon — Takma Adı: oci_pconnect
    • ociresult — Takma Adı: oci_result
    • ocirollback — Takma Adı: oci_rollback
    • ocirowcount — Takma Adı: oci_num_rows
    • ocisavelob — Takma Adı: OCI-Lob::save
    • ocisavelobfile — Takma Adı: OCI-Lob::import
    • ociserverversion — Takma Adı: oci_server_version
    • ocisetprefetch — Takma Adı: oci_set_prefetch
    • ocistatementtype — Takma Adı: oci_statement_type
    • ociwritelobtofile — Takma Adı: OCI-Lob::export
    • ociwritetemporarylob — Takma Adı: OCI-Lob::writeTemporary
PECL/mysqlnd_memcache 1.0 series
Giriş
Sağlayıcıya Göre Veritabanı Eklentileri


Giriş

These functions allow you to access Oracle Database 12c, 11g, 10g, 9i and 8i. They support SQL and PL/SQL statements. Basic features include transaction control, binding of PHP variables to Oracle placeholders, and support for large object (LOB) types and collections. Oracle's scalability features such as Database Resident Connection Pooling (DRCP) and result caching are also supported.

OCI8
Yapılandırma/Kurulum
OCI8


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Testing
  • Çalışma Anı Yapılandırması
Giriş
Gereksinimler
OCI8


Gereksinimler

The OCI8 1.4 extension is included with PHP 5.3, PHP 5.4 and PHP 5.5. It is also available from » PECL. A newer OCI8 2.0 version is available only from » PECL. OCI8 1.4 requires Oracle 12c, 11g, 10g or 9iR2 client libraries and will install on PHP 4.3.9 onwards. OCI8 2.0 requires Oracle 12c, 11g or 10g client libraries and will install on PHP 5.2 onwards.

If the Oracle Database is on the same machine as PHP, the database software already contains the necessary libraries. When PHP is on a different machine, use the free » Oracle Instant Client libraries.

To use Oracle Instant Client, install the basic or basiclite Oracle Instant Client ZIP file or RPM package. When building PHP from source code, also install the sdk ZIP file or devel RPM package.

You must run PHP with the same, or a more recent, version of the Oracle libraries that OCI8 was built with.

On Windows, the php_oci8 DLL needs Oracle client libraries from version 10gR2 or greater. In PHP 5.3 up to and including PHP 5.3.5, the php_oci8_11g DLL requires Oracle 11gR1 or greater client libraries. From PHP 5.3.6 the php_oci8_11g DLL requires Oracle 11gR2 or greater client libraries. The php_oci8_12c DLL from PECL requires Oracle 12cR1 client libraries. With some versions of Instant Client you may additionally need mfc71.dll and msvcr71.dll libraries.

Bilginize:

If OCI8 uses 9iR2 client libraries, then PHP can connect to Oracle Database 8i, 9iR2, 10g or 11g. If OCI8 uses 10gR2 client libraries, the database can be 9iR2, 10g, 11g or 12c. If OCI8 uses 11g client libraries, the database can be 9iR2, 10g, 11g or 12c. If OCI8 uses 12c client libraries, the database can be 10gR2, 11g or 12c.

Bilginize:

Full OCI8 feature support is only available when using the most recent versions of the Oracle client libraries and database.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Configuring PHP with OCI8

Review the previous Requirements section before configuring OCI8.

To enable the OCI8 extension, configure PHP with the option --with-oci8 .

Before starting the web server, OCI8 typically requires several Oracle environment variables (see below) to locate libraries, point to configuration files, and set some basic properties such as the character set used by Oracle libraries. The variables must be set before any PHP process starts.

The PHP binary must link with the same, or more recent, major version of Oracle libraries as it was configured with. For example, if you build OCI8 with Oracle 11.2 libraries, then PHP should also be deployed and run with Oracle 11.2 libraries. PHP applications can connect to other versions of Oracle Database, since Oracle has client-server cross-version compatibility.

Installing OCI8 as a Shared Extension

The configuration shared option builds OCI8 as a shared library that can be dynamically loaded into PHP. Building a shared extension allows OCI8 to be upgraded easily without impacting the rest of PHP.

Configure OCI8 using one of the following configure options.

  • If using the free » Oracle Instant Client libraries, then do:

    ./configure --with-oci8=shared,instantclient,/path/to/instant/client/lib

    If Instant Client is installed from ZIP files, make sure to create the library symbolic link first, for example ln -s libclntsh.so.12.1 libclntsh.so.

    If using an RPM-based installation of Oracle Instant Client, the configure line will look like this:

    ./configure --with-oci8=shared,instantclient,/usr/lib/oracle/<version>/client/lib

    For example, --with-oci8=shared,instantclient,/usr/lib/oracle/12.1/client/lib

    Note that Oracle Instant Client support first appeared in PHP 4.3.11 and 5.0.4 and originally used the option --with-oci8-instant-client to configure PHP.

  • If using an Oracle database or full Oracle Client installation then do:

    ./configure --with-oci8=shared,$ORACLE_HOME

    Make sure the web server user (nobody, www) has access to the libraries, initialization files and tnsnames.ora (if used) under the $ORACLE_HOME directory. With Oracle 10gR2, you may need to run the $ORACLE_HOME/install/changePerm.sh utility to give directory access.

After configuration, follow the usual PHP building procedure, e.g. make install. The OCI8 shared extension oci8.so library will be created. It may need to be manually moved to the PHP extension directory, specified by the extension_dir option in your php.ini file.

To complete installation of OCI8, edit php.ini and add the line:

extension=oci8.so

Installing OCI8 as a Statically Compiled Extension

Configure PHP to include OCI8 using one of the following configure options.

  • If using Oracle Instant Client, then do:

    ./configure --with-oci8=instantclient,/path/to/instant/client/lib

  • If using an Oracle database or full Oracle Client installation then do:

    ./configure --with-oci8=$ORACLE_HOME

After configuration, follow the usual PHP building procedure, e.g. make install. After successful compilation, you do not need to add oci8.so to php.ini. No additional build steps are required.

Installing OCI8 from PECL

The OCI8 extension can be added to an existing PHP installation either automatically or manually from » PECL.

For an automated install follow these steps:

  • If you are behind a firewall, set PEAR's proxy, for example:

    pear config-set http_proxy http://my-proxy.example.com:80/

  • Run

    pecl install oci8

    When prompted, enter either the value of $ORACLE_HOME, or instantclient,/path/to/instant/client/lib.

    Note: Do not enter the variable $ORACLE_HOME because it will not be expanded. Instead, enter the actual path of the Oracle home directory.

For a manual install when the pecl command is not available, download the PECL OCI8 package, e.g. oci8-1.4.10.tgz.

  • Extract the package:

    tar -zxf oci8-1.4.10.tgz
cd oci8-1.4.10

  • Prepare the package:

    phpize

  • Configure the package, either using $ORACLE_HOME or Instant Client

    ./configure -with-oci8=shared,$ORACLE_HOME

    or

    ./configure -with-oci8=shared,instantclient,/path/to/instant/client/lib

  • Install the package:

    make install

After either an automatic or manual install, edit your php.ini file and add the line:

extension=oci8.so

Make sure the php.ini directive extension_dir is set to the directory that oci8.so was installed in.

Installing OCI8 on Windows

When using Oracle 10gR2 client libraries on Windows, uncomment the php.ini line extension=php_oci8.dll. When using Oracle 11gR2 or later client libraries, uncomment extension=php_oci8_11g.dll or extension=php_oci8.dll. With Oracle 12c libraries use extension=php_oci8_12c.dll or extension=php_oci8_11g.dll or extension=php_oci8.dll. Only one of these DLLs may be enabled at a time. DLLs with higher versions may contain more functionality. Not all DLLs may be available for all versions of PHP. Make sure extension_dir is set to the directory containing the PHP extension DLLs.

If using Instant Client, set the system PATH environment variable to the Oracle library directory.

Setting the Oracle Environment

Before using this extension, make sure that the Oracle environment variables are properly set for the web daemon user. If your web server is automatically started at boot time then make sure that the boot-time environment is also configured correctly.

Bilginize:

Do not set Oracle environment variables using putenv() in a PHP script because Oracle libraries may be loaded and initialized before your script runs. Variables set with putenv() may then cause conflicts, crashes, or unpredictable behavior. Some functions may work but others might give subtle errors. The variables should be set up before the web server is started.

On Red Hat Linux and variants, export variables at the end of /etc/sysconfig/httpd. Other systems with Apache 2 may use an envvars script in the Apache bin directory. A third option, the Apache SetEnv directive in httpd.conf, may work in some systems but is known to be insufficient in others.

To check that environment variables are set correctly, use phpinfo() and check the Environment (not the Apache Environment) section contains the expected variables.

The variables that might be needed are included in the following table. Refer to the Oracle documentation for more information on all the available variables.

Common Oracle Environment Variables
Name | Purpose
ORACLE_HOME | Contains the directory of the full Oracle Database software. Do not set this when using Oracle Instant Client as it is unnecessary and may cause installation problems.
ORACLE_SID | Contains the name of the database on the local machine to be connected to. There is no need to set this if you using Oracle Instant Client, or always pass the connection parameter to oci_connect().
LD_LIBRARY_PATH | Set this (or its platform equivalent, such as DYLD_LIBRARY_PATH, LIBPATH, or SHLIB_PATH) to the location of the Oracle libraries, for example $ORACLE_HOME/lib or /usr/lib/oracle/11.1/client/lib. This variable is not needed if the libraries are located by a different search mechanism, such as with ldconfig or with LD_PRELOAD.
NLS_LANG | This is the primary variable for setting the character set and globalization information used by the Oracle libraries.
ORA_SDTZ | Sets the Oracle session timezone.
TNS_ADMIN | Contains the directory where the Oracle Net Services configuration files such as tnsnames.ora and sqlnet.ora are kept. Not needed if the oci_connect() connection string uses the Easy Connect naming syntax such as localhost/XE. Not needed if the network configuration files are in one of the default locations such as $ORACLE_HOME/network/admin or /etc.
Less frequently used Oracle environment variables include TWO_TASK, ORA_TZFILE, and the various Oracle globalization settings like NLS* and the ORA_NLS_* variables.

Troubleshooting

The most common problem with installing OCI8 is not having the Oracle environment correctly set. This typically appears as a problem using oci_connect() or oci_pconnect(). The error may be a PHP error such as Call to undefined function oci_connect(), an Oracle error such as ORA-12705, or even an Apache crash. Check the Apache log files for startup errors and see the sections above to resolve this problem.

While network errors like ORA-12154 or ORA-12514 indicate an Oracle network naming or configuration issue, the root cause may be because the PHP environment is incorrectly set up and Oracle libraries are unable to locate the tnsnames.ora configuration file.

On Windows, having multiple versions of Oracle on the one machine can easily cause library clashes unless care is taken to make sure PHP only uses the correct version of Oracle.

A utility to examine what libraries are being looked for and loaded can help resolve missing or clashing library issues, particularly on Windows.

Bilginize: If the web server doesn't start or crashes at startup

Check that Apache is linked with the pthread library:

# ldd /www/apache/bin/httpd
  libpthread.so.0 => /lib/libpthread.so.0 (0x4001c000)
  libm.so.6 => /lib/libm.so.6 (0x4002f000)
  libcrypt.so.1 => /lib/libcrypt.so.1 (0x4004c000)
  libdl.so.2 => /lib/libdl.so.2 (0x4007a000)
  libc.so.6 => /lib/libc.so.6 (0x4007e000)
  /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

If the libpthread is not listed, then reinstall Apache:

# cd /usr/src/apache_1.3.xx
# make clean
# LIBS=-lpthread ./config.status
# make
# make install

Please note that on some systems like UnixWare, it is libthread instead of libpthread. PHP and Apache have to be configured with EXTRA_LIBS=-lthread.

Gereksinimler
Testing
Yapılandırma/Kurulum


Testing

The OCI8 test suite is in ext/oci8/tests. After OCI8 tests are run this directory will also contain logs of any failures.

Before running PHP's tests, edit details.inc and set $user, $password and the $dbase connection string. The OCI8 test suite has been developed using the SYSTEM account. Some tests will fail if the test user does not have equivalent permissions.

If Oracle Database Resident Connection Pooling is being tested, set $test_drcp to TRUE and ensure the connection string uses an appropriate DRCP pooled server.

An alternative to editing details.inc is the set environment variables, for example:

    $ export PHP_OCI8_TEST_USER=system
    $ export PHP_OCI8_TEST_PASS=oracle
    $ export PHP_OCI8_TEST_DB=localhost/XE
    $ export PHP_OCI8_TEST_DRCP=FALSE
Note in some shells these variables are not propagated correctly to the PHP process and tests will fail to connect if this method is used.

Next, set any necessary environment for the Oracle database. With Oracle 10gR2 XE do:

    $ . /usr/lib/oracle/xe/app/oracle/product/10.2.0/server/bin/oracle_env.sh

With Oracle 11gR2 XE do:

    $ . /u01/app/oracle/product/11.2.0/xe/bin/oracle_env.sh

For other versions of the Oracle database do:

    $ . /usr/local/bin/oraenv

Some shells require that php.ini has E in the variables_order parameter, for example:

    variables_order = "EGPCS"

Run all the PHP tests with:

    $ cd your_php_src_directory
    $ make test
or run only the OCI8 tests with
    $ cd your_php_src_directory
    $ make test TESTS=ext/oci8

When the tests have completed, review any test failures. On slow systems, some tests may take longer than the default test timeout in run-tests.php. To correct this, set the environment variable TEST_TIMEOUT to a larger number of seconds.

On fast machines with a local database configured for light load (e.g. Oracle 11gR2 XE) some tests might fail with ORA-12516 or ORA-12520 errors. To prevent this, increase the database PROCESSES parameter using the following steps:

Connect as the oracle software owner:

    $ su - oracle

Set the necessary Oracle environment with oracle_env.sh or oraenv, as described above.

Start the SQL*Plus command line tool and increase PROCESSES

    $ sqlplus / as sysdba
    SQL> alter system set processes=100 scope=spfile

Restart the database:

    SQL> startup force

Kurulum
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

OCI8 Configuration Options
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
oci8.connection_class | "" | PHP_INI_ALL | Available since PHP 5.3 (PECL OCI8 1.3).
oci8.default_prefetch | "100" | PHP_INI_SYSTEM | Available since PHP 5.1.2 (PECL OCI8 1.1).
oci8.events | Off | PHP_INI_SYSTEM | Available since PHP 5.3 (PECL OCI8 1.3).
oci8.max_persistent | "-1" | PHP_INI_SYSTEM | Available since PHP 5.1.2 (PECL OCI8 1.1).
oci8.old_oci_close_semantics | Off | PHP_INI_SYSTEM | Available since PHP 5.1.2 (PECL OCI8 1.1).
oci8.persistent_timeout | "-1" | PHP_INI_SYSTEM | Available since PHP 5.1.2 (PECL OCI8 1.1).
oci8.ping_interval | "60" | PHP_INI_SYSTEM | Available since PHP 5.1.2 (PECL OCI8 1.1).
oci8.privileged_connect | Off | PHP_INI_SYSTEM | Available since PHP 5.1.2 (PECL OCI8 1.1).
oci8.statement_cache_size | "20" | PHP_INI_SYSTEM | Available since PHP 5.1.2 (PECL OCI8 1.1).

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

oci8.connection_class string

This user defined text is used by Oracle 11g Database Resident Connection Pooling (DRCP) connections to sub-partition the connection pool. It allows OCI8 persistent connections from an application to reuse database sessions from a previous PHP script, giving better scalability. When an application uses a database pooled process previously used with a different connection class, the session settings such as the default Oracle date format are reset. This prevents accidental sharing of information between different applications.

The value can be set at runtime with ini_set() prior to connecting.

To use DRCP, OCI8 must be linked with Oracle 11g libraries and the database must be Oracle 11g. The connection pool must be enabled in the database, the oci8.connection_class should be set to the same string for all web servers running the same application, and the OCI8 connection string must specify to use a pooled server.

oci8.default_prefetch int

This option sets the default number of extra rows that will be fetched and cached automatically whenever a low-level request for data from the database is made. Setting a value of 0 turns off prefetching.

The prefetch value does not alter the number of rows that functions like oci_fetch_array() return to the user; the prefetching and caching of rows is handled internally in OCI8.

The value can be set per-statement with oci_set_prefetch() prior to statement execution.

In PHP 5.3 (PECL OCI8 1.3.4) the default value was increased from 10 to 100.

In PHP 5.3.2 (PECL OCI8 1.4) the minimum value settable was reduced from 1 to 0, allowing prefetching to be turned off.

When using Oracle Database 12c, the prefetch value set by PHP can be overridden by Oracle's client oraaccess.xml configuration file. Refer to Oracle documentation for more detail.

Bilginize: A larger prefetch can result in improved performance, at the cost of some increased memory usage. For queries that return large amounts of data, the performance benefit can be significant.

oci8.events boolean

Using On allows PHP to be notified of database Fast Application Notification (FAN) events.

Without FAN, when a database instance or machine node fails unexpectedly, PHP applications may be blocked waiting for a database response until a TCP timeout expires. With FAN events, PHP applications are quickly notified of failures that affect their established database connections. The OCI8 extension will clean up unusable connections in the persistent connection cache.

When using On, the database must also be configured to post FAN events.

FAN support is available when OCI8 is linked with Oracle 10gR2 (or later) libraries and connected to Oracle Database 10gR2 (or later).

oci8.max_persistent int

The maximum number of persistent OCI8 connections per PHP process. Setting this option to -1 means that there is no limit.

oci8.old_oci_close_semantics boolean

This option controls oci_close() behaviour. Enabling it means that oci_close() will do nothing; the connection will not be closed until the end of the script. This is for backward compatibility only. If you find that you need to enable this setting, you are strongly encouraged to adjust the oci_close() calls in your application instead of enabling this option.

oci8.persistent_timeout int

The maximum number of seconds that a PHP process is allowed to keep an idle persistent connection open. Setting this option to -1 means that idle persistent connections will be retained until the PHP process terminates or the connection is explicitly closed with oci_close().

Bilginize: In PHP, the expiry of idle resources is not alarm-based. It occurs when PHP finishes processing a script and checks the last-used timestamp of resources. Hence there is a paradox that idle connections can only be closed when there is some activity (though not necessarily OCI8 related) in the PHP process. If there is more than one PHP process then each must individually be activated in order to trigger expiry of its idle resources. The introduction of Database Resident Connection Pooling (DRCP) in Oracle 11g resolves the memory and resource issues that oci8.max_persistent and oci8.persistent_timeout previously attempted to overcome.

Bilginize: In PHP 5.3 (PECL OCI8 1.3), persistent connections can be closed with oci_close().

oci8.ping_interval int

The number of seconds that must pass before issuing a ping during oci_pconnect(). A ping ensures that the database connection is valid. When set to 0, persistent connections will be pinged every time oci_pconnect() is called. To disable pings completely, set this option to -1.

Bilginize: Disabling pings allows oci_pconnect() to operate at the highest efficiency, but PHP may not be able to detect unusable connections, such as caused by network dropout, or if the Oracle database has gone down since PHP connected, until the connection is used later in the script. Consult the oci_pconnect() documentation for more information.

oci8.privileged_connect boolean

This option allows connections to use the privileged external credentials OCI_SYSOPER or OCI_SYSDBA.

Bilginize: Seting this On can allow scripts on web servers running with the appropriate OS user privileges to connect as privileged database users without requiring a database password. This can be a security risk.

oci8.statement_cache_size int

This option enables statement caching, and specifies how many statements to cache. To disable statement caching just set this option to 0.

Statement caching removes the need to transmit the statement text to the database and removes the need to transmit any meta data about the statement back to PHP. This can significantly improve overall system performance in applications which reuse statements during the lifetime of a connection. Some extra database "cursors" may be held open under the assumption that statements will be reused.

Set this value to the size of the working set of statements used by your application. Setting too small a value can cause statements to be flushed from the cache before they are reused.

This option is of most use with persistent connections.

When using Oracle Database 12c, this value can be overridden and automatically tuned by Oracle's client oraaccess.xml file. Refer to Oracle documentation for more detail.

Testing
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

OCI8 Function and Method Modes
Constant | Description
OCI_ASSOC | Used with oci_fetch_all() and oci_fetch_array() to get results as an associative array.
OCI_BOTH | Used with oci_fetch_all() and oci_fetch_array() to get results as an array with both associative and number indices.
OCI_COMMIT_ON_SUCCESS | Statement execution mode for oci_execute() call. Automatically commit changes when the statement has succeeded.
OCI_CRED_EXT | Used with oci_connect() for using Oracles' External or OS authentication. Introduced in PHP 5.3 and PECL OCI8 1.3.4.
OCI_DEFAULT | See OCI_NO_AUTO_COMMIT.
OCI_DESCRIBE_ONLY | Statement execution mode for oci_execute(). Use this mode if you want meta data such as the column names but don't want to fetch rows from the query.
OCI_EXACT_FETCH | Obsolete. Statement fetch mode. Used when the application knows in advance exactly how many rows it will be fetching. This mode turns prefetching off for Oracle release 8 or later mode. The cursor is canceled after the desired rows are fetched which may result in reduced server-side resource usage.
OCI_FETCHSTATEMENT_BY_COLUMN | Default mode of oci_fetch_all().
OCI_FETCHSTATEMENT_BY_ROW | Alternative mode of oci_fetch_all().
OCI_LOB_BUFFER_FREE | Used with OCI-Lob::flush to free buffers used.
OCI_NO_AUTO_COMMIT | Statement execution mode for oci_execute(). The transaction is not automatically committed when using this mode. For readability in new code, use this value instead of the older, equivalent OCI_DEFAULT constant. Introduced in PHP 5.3.2 (PECL OCI8 1.4).
OCI_NUM | Used with oci_fetch_all() and oci_fetch_array() to get results as an enumerated array.
OCI_RETURN_LOBS | Used with oci_fetch_array() to get the data value of the LOB instead of the descriptor.
OCI_RETURN_NULLS | Used with oci_fetch_array() to get empty array elements if the row items value is NULL.
OCI_SEEK_CUR | Used with OCI-Lob::seek to set the seek position.
OCI_SEEK_END | Used with OCI-Lob::seek to set the seek position.
OCI_SEEK_SET | Used with OCI-Lob::seek to set the seek position.
OCI_SYSDATE | Obsolete.
OCI_SYSDBA | Used with oci_connect() to connect with the SYSDBA privilege. The php.ini setting oci8.privileged_connect should be enabled to use this.
OCI_SYSOPER | Used with oci_connect() to connect with the SYSOPER privilege. The php.ini setting oci8.privileged_connect should be enabled to use this.
OCI_TEMP_BLOB | Used with OCI-Lob::writeTemporary to indicate that a temporary BLOB should be created.
OCI_TEMP_CLOB | Used with OCI-Lob::writeTemporary to indicate that a temporary CLOB should be created.
OCI8 Bind and Define Types
Constant | Description
OCI_B_BFILE | Used with oci_bind_by_name() when binding BFILEs.
OCI_B_BIN | Used with oci_bind_by_name() to bind RAW values.
OCI_B_BLOB | Used with oci_bind_by_name() when binding BLOBs.
OCI_B_BOL | Used with oci_bind_by_name() to bind a PL/SQL BOOLEAN variable.
OCI_B_CFILEE | Used with oci_bind_by_name() when binding CFILEs.
OCI_B_CLOB | Used with oci_bind_by_name() when binding CLOBs.
OCI_B_CURSOR | Used with oci_bind_by_name() when binding cursors, previously allocated with oci_new_descriptor().
OCI_B_INT | Used with oci_bind_array_by_name() to bind arrays of INTEGER.
OCI_B_NTY | Used with oci_bind_by_name() when binding named data types. Note: in PHP < 5.0 it was called OCI_B_SQLT_NTY.
OCI_B_NUM | Used with oci_bind_array_by_name() to bind arrays of NUMBER.
OCI_B_ROWID | Used with oci_bind_by_name() when binding ROWIDs.
SQLT_AFC | Used with oci_bind_array_by_name() to bind arrays of CHAR.
SQLT_AVC | Used with oci_bind_array_by_name() to bind arrays of VARCHAR2.
SQLT_BDOUBLE | Not supported.
SQLT_BFILEE | The same as OCI_B_BFILE.
SQLT_BFLOAT | Not supported.
SQLT_BIN | The same as OCI_B_BIN.
SQLT_BLOB | The same as OCI_B_BLOB.
SQLT_BOL | The same as OCI_B_BOL.
SQLT_CFILEE | The same as OCI_B_CFILEE.
SQLT_CHR | Used with oci_bind_array_by_name() to bind arrays of VARCHAR2. Also used with oci_bind_by_name().
SQLT_CLOB | The same as OCI_B_CLOB.
SQLT_FLT | Used with oci_bind_array_by_name() to bind arrays of FLOAT.
SQLT_INT | The same as OCI_B_INT.
SQLT_LBI | Used with oci_bind_by_name() to bind LONG RAW values.
SQLT_LNG | Used with oci_bind_by_name() to bind LONG values.
SQLT_LVC | Used with oci_bind_array_by_name() to bind arrays of LONG VARCHAR.
SQLT_NTY | The same as OCI_B_NTY.
SQLT_NUM | The same as OCI_B_NUM.
SQLT_ODT | Used with oci_bind_array_by_name() to bind arrays of LONG.
SQLT_RDD | The same as OCI_B_ROWID.
SQLT_RSET | The same as OCI_B_CURSOR.
SQLT_STR | Used with oci_bind_array_by_name() to bind arrays of STRING.
SQLT_UIN | Not supported.
SQLT_VCS | Used with oci_bind_array_by_name() to bind arrays of VARCHAR.
OCI8 Descriptor Types
Constant | Description
OCI_DTYPE_FILE | This flag tells oci_new_descriptor() to initialize a new FILE descriptor.
OCI_DTYPE_LOB | This flag tells oci_new_descriptor() to initialize a new LOB descriptor.
OCI_DTYPE_ROWID | This flag tells oci_new_descriptor() to initialize a new ROWID descriptor.
OCI_D_FILE | The same as OCI_DTYPE_FILE.
OCI_D_LOB | The same as OCI_DTYPE_LOB.
OCI_D_ROWID | The same as OCI_DTYPE_ROWID.
Çalışma Anı Yapılandırması
Örnekler
OCI8


Örnekler

These examples connect as the HR user, which is the sample "Human Resources" schema supplied with the Oracle database. The account may need to be unlocked and the password reset before you can use it.

The examples connect to the XE database on your machine. Change the connect string to your database before running the examples.

Örnek 1 Basic query

This shows querying and displaying results. Statements in OCI8 use a prepare-execute-fetch sequence of steps.

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

// Prepare the statement
$stid = oci_parse($conn, 'SELECT * FROM departments');
if (!$stid) {
    $e = oci_error($conn);
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

// Perform the logic of the query
$r = oci_execute($stid);
if (!$r) {
    $e = oci_error($stid);
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

// Fetch the results of the query
print "<table border='1'>\n";
while ($row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_NULLS)) {
    print "<tr>\n";
    foreach ($row as $item) {
        print "    <td>" . ($item !== null ? htmlentities($item, ENT_QUOTES) : "&nbsp;") . "</td>\n";
    }
    print "</tr>\n";
}
print "</table>\n";

oci_free_statement($stid);
oci_close($conn);

?>

Örnek 2 Inserting with bind variables

Bind variables improve performance by allowing reuse of execution contexts and caches. Bind variables improve security by preventing some kinds of SQL Injection problems.

<?php

// Before running, create the table:
//   CREATE TABLE MYTABLE (mid NUMBER, myd VARCHAR2(20));

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'INSERT INTO MYTABLE (mid, myd) VALUES(:myid, :mydata)');

$id = 60;
$data = 'Some data';

oci_bind_by_name($stid, ':myid', $id);
oci_bind_by_name($stid, ':mydata', $data);

$r = oci_execute($stid);  // executes and commits

if ($r) {
    print "One row inserted";
}

oci_free_statement($stid);
oci_close($conn);

?>

Örnek 3 Binding in the WHERE clause of a query

This shows a single scalar bind.

<?php

$conn = oci_connect("hr", "hrpwd", "localhost/XE");
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$sql = 'SELECT last_name FROM employees WHERE department_id = :didbv ORDER BY last_name';
$stid = oci_parse($conn, $sql);
$didbv = 60;
oci_bind_by_name($stid, ':didbv', $didbv);
oci_execute($stid);
while (($row = oci_fetch_array($stid, OCI_ASSOC)) != false) {
    echo $row['LAST_NAME'] ."<br>\n";
}

// Output is
//    Austin
//    Ernst
//    Hunold
//    Lorentz
//    Pataballa

oci_free_statement($stid);
oci_close($conn);

?>

Örnek 4 Inserting and fetching a CLOB

For large data use binary long object (BLOB) or character long object (CLOB) types. This example uses CLOB.

<?php

// Before running, create the table:
//     CREATE TABLE MYTABLE (mykey NUMBER, myclob CLOB);

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$mykey = 12343;  // arbitrary key for this example;

$sql = "INSERT INTO mytable (mykey, myclob)
        VALUES (:mykey, EMPTY_CLOB())
        RETURNING myclob INTO :myclob";

$stid = oci_parse($conn, $sql);
$clob = oci_new_descriptor($conn, OCI_D_LOB);
oci_bind_by_name($stid, ":mykey", $mykey, 5);
oci_bind_by_name($stid, ":myclob", $clob, -1, OCI_B_CLOB);
oci_execute($stid, OCI_NO_AUTO_COMMIT); // use OCI_DEFAULT for PHP <= 5.3.1
$clob->save("A very long string");

oci_commit($conn);

// Fetching CLOB data

$query = 'SELECT myclob FROM mytable WHERE mykey = :mykey';

$stid = oci_parse ($conn, $query);
oci_bind_by_name($stid, ":mykey", $mykey, 5);
oci_execute($stid);

print '<table border="1">';
while ($row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_LOBS)) {
    print '<tr><td>'.$row['MYCLOB'].'</td></tr>';
    // In a loop, freeing the large variable before the 2nd fetch reduces PHP's peak memory usage
    unset($row);
}
print '</table>';

?>

Örnek 5 Using a PL/SQL stored function

You must bind a variable for the return value and optionally for any PL/SQL function arguments.

<?php

/*
  Before running the PHP program, create a stored function in
  SQL*Plus or SQL Developer:

  CREATE OR REPLACE FUNCTION myfunc(p IN NUMBER) RETURN NUMBER AS
  BEGIN
      RETURN p * 3;
  END;

*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$p = 8;

$stid = oci_parse($conn, 'begin :r := myfunc(:p); end;');
oci_bind_by_name($stid, ':p', $p);
oci_bind_by_name($stid, ':r', $r, 40);

oci_execute($stid);

print "$r\n";   // prints 24

oci_free_statement($stid);
oci_close($conn);

?>

Örnek 6 Using a PL/SQL stored procedure

With stored procedures, you should bind variables for any arguments.

<?php

/*
  Before running the PHP program, create a stored procedure in
  SQL*Plus or SQL Developer:

  CREATE OR REPLACE PROCEDURE myproc(p1 IN NUMBER, p2 OUT NUMBER) AS
  BEGIN
      p2 := p1 * 2;
  END;

*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$p1 = 8;

$stid = oci_parse($conn, 'begin myproc(:p1, :p2); end;');
oci_bind_by_name($stid, ':p1', $p1);
oci_bind_by_name($stid, ':p2', $p2, 40);

oci_execute($stid);

print "$p2\n";   // prints 16

oci_free_statement($stid);
oci_close($conn);

?>

Örnek 7 Calling a PL/SQL function that returns a REF CURSOR

Each returned value from the query is a REF CURSOR that can be fetched from.

<?php
/*
  Create the PL/SQL stored function as:

  CREATE OR REPLACE FUNCTION myfunc(p1 IN NUMBER) RETURN SYS_REFCURSOR AS
      rc SYS_REFCURSOR;
  BEGIN
      OPEN rc FOR SELECT city FROM locations WHERE ROWNUM < p1;
      RETURN rc;
  END;
*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');

$stid = oci_parse($conn, 'SELECT myfunc(5) AS mfrc FROM dual');
oci_execute($stid);

echo "<table border='1'>\n";
while (($row = oci_fetch_array($stid, OCI_ASSOC))) {
    echo "<tr>\n";
    $rc = $row['MFRC'];
    oci_execute($rc);  // returned column value from the query is a ref cursor
    while (($rc_row = oci_fetch_array($rc, OCI_ASSOC))) {
        echo "    <td>" . $rc_row['CITY'] . "</td>\n";
    }
    oci_free_statement($rc);
    echo "</tr>\n";
}
echo "</table>\n";

// Output is:
//   Beijing
//   Bern
//   Bombay
//   Geneva

oci_free_statement($stid);
oci_close($conn);

?>
Öntanımlı Sabitler
OCI8 Connection Handling and Connection Pooling
OCI8


OCI8 Connection Handling and Connection Pooling

Connection Functions

The OCI8 extension provides three different functions for connecting to Oracle. The standard connection function is oci_connect(). This creates a connection to an Oracle database and returns a resource used by subsequent database calls.

Connecting to an Oracle server is a reasonably expensive operation in terms of the time that it takes to complete. The oci_pconnect() function uses a persistent cache of connections that can be re-used across different script requests. This means that the connection overhead will typically only occur once per PHP process (or Apache child).

If the application connects to Oracle using a different set of credentials for each web user, the persistent cache employed by oci_pconnect() will become less useful as the number of concurrent users increases, to the point where it may start to adversely affect the overall performance of the Oracle server due to maintaining too many idle connections. If the application is structured in this way, it is recommended to either tune the application using the oci8.max_persistent and oci8.persistent_timeout configuration settings (these will give control over the persistent connection cache size and lifetime), use Oracle Database Resident Connection Pooling (in Oracle Database 11g or later), or use oci_connect() instead.

Both oci_connect() and oci_pconnect() employ a connection cache; if multiple calls to oci_connect() use the same parameters in a given script, the second and subsequent calls return the existing connection handle. The cache used by oci_connect() is cleaned up at the end of the script run, or when the connection handle is explicitly closed. The function oci_pconnect() has similar behavior, although its cache is maintained separately and survives between HTTP requests.

This caching feature means the two handles are not transactionally isolated (they are in fact the same connection handle, so there is no isolation of any kind). If the application needs two separate, transactionally isolated connections, then use oci_new_connect().

The oci_pconnect() cache is cleared and any database connections closed when the PHP process terminates, so effective use of persistent connections requires that PHP be an Apache module or used with FCGI, or similar. Persistent connections will not have any benefits over oci_connect() when PHP is used with CGI or via the command-line.

The function oci_new_connect() always creates a new connection to the Oracle server, regardless of what other connections might already exist. High traffic web applications should avoid using oci_new_connect(), especially in the busiest sections of the application.

DRCP Connection Pooling

PHP from 5.3 (PECL OCI8 1.3) supports Oracle Database Resident Connection Pooling (DRCP). DRCP allows more efficient use of database machine memory and provides high scalability. No, or minimal, application changes are needed to use DRCP.

DRCP is suited for applications that connect using few database schemas and hold database connections open for a short period of time. Other applications should use Oracle's default Dedicated database server processes, or use Shared servers.

DRCP benefits all three connection functions, but gives the highest scalability when connections are created with oci_pconnect().

For DRCP to be available in OCI8, Oracle client libraries used by PHP and the version of the Oracle Database must both be 11g or greater.

Documentation on DRCP is found in several Oracle manuals. For example, see » Configuring Database Resident Connection Pooling in the Oracle documentation for usage information. A » DRCP white paper contains background information on DRCP.

To use DRCP, build PHP with the OCI8 1.3 (or later) extension and Oracle 11g (or later) libraries and then follow these steps:

  • As a privileged database administrator, use a program like SQL*Plus to start the connection pool in the database:

        SQL> execute dbms_connection_pool.start_pool;

  • Optionally use dbms_connection_pool.alter_param() to configure DRCP settings. The current pool settings can be queried from the DBA_CPOOL_INFO view.

  • Update the connection strings used. For PHP applications that currently connect using a Network Connect Name like MYDB:

        $c = oci_pconnect("myuser", "mypassword", "MYDB");

    modify the tnsnames.ora file and add a (SERVER=POOLED) clause, for example:

        MYDB = (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp) (HOST=myhost.dom.com)
           (PORT=1521))(CONNECT_DATA=(SERVICE_NAME=sales)
           (SERVER=POOLED)))

    Alternatively, modify the Easy Connect syntax in PHP and add :POOLED after the service name:

        $c = oci_pconnect("myuser", "mypassword", "myhost.dom.com:1521/sales:POOLED");

  • Edit php.ini and choose a connection class name. This name indicates a logical division of the connection pool and can be used to isolate pooling for separate applications. Any PHP applications with the same user name and connection class value will be able to share connections in the pool, giving greater scalability.

        oci8.connection_class = "MY_APPLICATION_NAME"

  • Run the application, connecting to the 11g (or later) database.

Bilginize:

Applications using Oracle 10g that require the performance of persistent connections can reduce the amount of database server memory needed by using Oracle Shared servers (previously known as Multi Threaded Servers). Refer to Oracle documentation for information.

DRCP Recommendations and Known Limitations

Changing a password over DRCP connections will fail with the error ORA-56609: Usage not supported with DRCP. This is a documented restriction of Oracle Database 11g.

From OCI8 1.3, persistent connections can be closed by the user, allowing greater control over connection resource usage. Persistent connections will now also be closed automatically when there is no PHP variable referencing them, such as at the end of scope of a PHP user function. This will rollback any uncommitted transaction. These changes to persistent connections make them behave similarly to non-persistent connections, simplifying the interface, allowing for greater application consistency and predictability. Use oci8.old_oci_close_semantics set to On to retain the historical behavior.

If the Oracle Database is version 11.1.0.6, then the Oracle database patch for Oracle bug 6474441 must be applied to use DRCP. Without this patch, errors such as ORA-01000: maximum open cursors exceeded, ORA-01001 invalid cursor or ORA-01002 fetch out of sequence may occur. This bug was fixed in Oracle 11.1.0.7 onwards.

If the Oracle 11.1.0.6 database patch cannot be applied, one of the following three workarounds can be used instead:

  • Connect using Oracle Dedicated or Shared servers instead of DRCP.
  • Set PHP's oci8.statement_cache_size to 0.
  • Set an event in the database initialization parameter file: event="56699 trace name context forever, level 128".

Oracle Database 11.1.0.7 and the Oracle Database 11.1.0.6 patch for Oracle bug 6474441 allow PHP applications with DRCP connection to use a database LOGON trigger to set session properties at the time of session creation. Examples of such settings are the NLS language and the date format.

If the Oracle 11.1.0.6 database patch cannot be applied, one of the following workarounds can be used instead of using LOGON triggers:

  • After logon, explicitly set the session properties using PHP application code.
  • Connect using Oracle Dedicated or Shared servers instead of DRCP.

The automatic re-establishment of PHP persistent connections after an Apache or FCGI process respawns means LOGON triggers in PHP are only recommended for setting session attributes and not for per-application user connection requests. This is even more so with DRCP due to the automatic pool sizing and with the way LOGON triggers fire with DRCP authentication.

Örnekler
OCI8 Fast Application Notification (FAN) Support
OCI8


OCI8 Fast Application Notification (FAN) Support

FAN support gives fast connection failover, an Oracle Database high availability feature. This allows PHP OCI8 scripts to be notified when a database machine or database instance becomes unavailable. Without FAN, OCI8 can hang until a TCP timeout occurs and an error is returned, which might be several minutes. Enabling FAN in OCI8 can allow applications to detect errors and re-connect to an available database instance without the web user being aware of an outage.

FAN support is available when the Oracle client libraries that PHP links with and the Oracle Database are either version 10gR2 or later.

FAN benefits users of Oracle's clustering technology (RAC) because connections to surviving database instances can be immediately made. Users of Oracle's Data Guard with a broker will see the FAN events generated when the standby database goes online. Standalone databases will send FAN events when the database restarts.

For active connections, when a machine or database instance becomes unavailable, a connection failure error will be returned by the OCI8 extension function currently being called. On a subsequent PHP script re-connect, a connection to a surviving database instance will be established. The OCI8 extension also transparently cleans up any idle connections affected by a database machine or instance failure so PHP connect calls will establish a fresh connection without the script being aware of any service disruption.

When oci8.events is On, it is suggested to set oci8.ping_interval to -1 to disable pinging, since enabling FAN events provide pro-active connection management of idle connections made invalid by a service disruption.

To enable FAN support in PHP OCI8, build PHP OCI8 with Oracle 10gR2 or later libraries and then follow these steps:

  • As a privileged database administrator, use a program like SQL*Plus to enable the database service to post FAN events, for example:

        SQL> execute dbms_service.modify_service(
                   SERVICE_NAME        => 'sales',
                   AQ_HA_NOTIFICATIONS => TRUE);

  • Edit php.ini and add

        oci8.events = On

  • If the application does not already handle OCI8 error conditions, modify it to detect failures and take appropriate action. This may include re-connecting and re-executing statements.
  • Run the application, connecting to Oracle Database 10gR2 or later.

OCI8 Connection Handling and Connection Pooling
OCI8 and DTrace Dynamic Tracing
OCI8


OCI8 and DTrace Dynamic Tracing

OCI8 2.0 introduced static DTrace probes that can be used on operating systems that support DTrace. See DTrace Dynamic Tracing for an overview of PHP and DTrace.

Installing OCI8 with DTrace Support

To enable DTrace support in PHP OCI8, build OCI8 as a shared extension after setting PHP_DTRACE.

$ export PHP_DTRACE=yes
$ pecl install oci8

Edit php.ini, set extension_dir to the directory with the created oci8.so and also enable the extension by adding:

extension=oci8.so

If you install PHP OCI8 2.0 from PECL using phpize and configure (instead of pecl), you will still need to set PHP_DTRACE=yes. This is because the --enable-dtrace option will be ignored by the limited configure script of a PECL bundle.

See Installation of PECL extensions for general PECL installation instructions.

DTrace Static Probes in PHP OCI8

The following static probes are available in PHP OCI8
Probe Name | Probe Description | Probe Arguments
oci8-connect-entry | Initiated by oci_connect(), oci_pconnect() and oci_new_connect(). Fires before database connection is established. | char *username, char *dbname, char *charset, long session_mode, int persistent, int exclusive
oci8-connect-return | Fires at the end of connection. | void *connection
oci8-check-connection | Fires if an Oracle error might have caused the connection to become invalid. | void *connection, char *client_id, int is_open, long errcode, unsigned long server_status
oci8-sqltext | Fires when oci_parse() is executed. | void *connection, char *client_id, void *statement, char *sql
oci8-connection-close | Fires when the connection to the database is completely destroyed. | void *connection
oci8-error | Fires if an Oracle error occurs. | int status, long errcode
oci8-execute-mode | Fires at oci_execute() to show the execution mode. | void *connection, char *client_id, void *statement, unsigned int mode

These probes are useful for tracing OCI8 scripts.

The connection and statement are the pointers to internal structures used for tracking PHP connections and executed statements.

The client_id is the value set by oci_set_client_identifier().

Core PHP also has static probes. See DTrace Static Probes in Core PHP.

Internal Debugging DTrace Probes in OCI8
Probe Name
oci8-connect-expiry
oci8-connect-lookup
oci8-connect-p-dtor-close
oci8-connect-p-dtor-release
oci8-connect-type
oci8-sesspool-create
oci8-sesspool-stats
oci8-sesspool-type

These probes are useful for OCI8 maintainers. Refer to the OCI8 source code for arguments and to see when the will fire.

Listing DTrace Static Probes in PHP OCI8

To list available probes, start a PHP process and then run:

# dtrace -l

The output will be similar to:

   ID   PROVIDER            MODULE                          FUNCTION NAME
   [ . . . ]
   17 phpoci22116           oci8.so   php_oci_dtrace_check_connection oci8-check-connection
   18 phpoci22116           oci8.so                php_oci_do_connect oci8-connect-entry
   19 phpoci22116           oci8.so         php_oci_persistent_helper oci8-connect-expiry
   20 phpoci22116           oci8.so             php_oci_do_connect_ex oci8-connect-lookup
   21 phpoci22116           oci8.so  php_oci_pconnection_list_np_dtor oci8-connect-p-dtor-close
   22 phpoci22116           oci8.so  php_oci_pconnection_list_np_dtor oci8-connect-p-dtor-release
   23 phpoci22116           oci8.so                php_oci_do_connect oci8-connect-return
   24 phpoci22116           oci8.so             php_oci_do_connect_ex oci8-connect-type
   25 phpoci22116           oci8.so          php_oci_connection_close oci8-connection-close
   26 phpoci22116           oci8.so                     php_oci_error oci8-error
   27 phpoci22116           oci8.so         php_oci_statement_execute oci8-execute-mode
   28 phpoci22116           oci8.so              php_oci_create_spool oci8-sesspool-create
   29 phpoci22116           oci8.so            php_oci_create_session oci8-sesspool-stats
   30 phpoci22116           oci8.so            php_oci_create_session oci8-sesspool-type
   31 phpoci22116           oci8.so          php_oci_statement_create oci8-sqltext

The Provider column values consist of phpoci and the process id of the currently running PHP process.

The Function column refers to PHP's internal C implementation function names where each provider is located.

If a PHP process is not running, then no PHP probes will be shown.

DTrace with PHP OCI8 Example

This example shows the basics of the DTrace D scripting language.

Örnek 1 user_oci8_probes.d for tracing all user-level PHP OCI8 Static Probes with DTrace

#!/usr/sbin/dtrace -Zs

#pragma D option quiet

php*:::oci8-connect-entry
{
    printf("%lld: PHP connect-entry\n", walltimestamp);
    printf("  credentials=\"%s@%s\"\n", arg0 ? copyinstr(arg0) : "", arg1 ? copyinstr(arg1) : "");
    printf("  charset=\"%s\"\n", arg2 ? copyinstr(arg2) : "");
    printf("  session_mode=%ld\n", (long)arg3);
    printf("  persistent=%d\n", (int)arg4);
    printf("  exclusive=%d\n", (int)arg5);
}

php*:::oci8-connect-return
{
    printf("%lld: PHP oci8-connect-return\n", walltimestamp);
    printf("  connection=0x%p\n", (void *)arg0);
}

php*:::oci8-connection-close
{
    printf("%lld: PHP oci8-connect-close\n", walltimestamp);
    printf("  connection=0x%p\n", (void *)arg0);
}

php*:::oci8-error
{
    printf("%lld: PHP oci8-error\n", walltimestamp);
    printf("  status=%d\n", (int)arg0);
    printf("  errcode=%ld\n", (long)arg1);
}

php*:::oci8-check-connection
{
    printf("%lld: PHP oci8-check-connection\n", walltimestamp);
    printf("  connection=0x%p\n", (void *)arg0);
    printf("  client_id=\"%s\"\n", arg1 ? copyinstr(arg1) : "");
    printf("  is_open=%d\n", arg2);
    printf("  errcode=%ld\n", (long)arg3);
    printf("  server_status=%lu\n", (unsigned long)arg4);
}

php*:::oci8-sqltext
{
    printf("%lld: PHP oci8-sqltext\n", walltimestamp);
    printf("  connection=0x%p\n", (void *)arg0);
    printf("  client_id=\"%s\"\n", arg1 ? copyinstr(arg1) : "");
    printf("  statement=0x%p\n", (void *)arg2);
    printf("  sql=\"%s\"\n", arg3 ? copyinstr(arg3) : "");
}

php*:::oci8-execute-mode
{
    printf("%lld: PHP oci8-execute-mode\n", walltimestamp);
    printf("  connection=0x%p\n", (void *)arg0);
    printf("  client_id=\"%s\"\n", arg1 ? copyinstr(arg1) : "");
    printf("  statement=0x%p\n", (void *)arg2);
    printf("  mode=0x%x\n", arg3);
}

This script uses the -Z option to dtrace, allowing it to be run when there is no PHP process executing. If this option were omitted the script would immediately terminate when no PHP executable was running because it knows none of the probes to be monitored are in existence.

On multi-CPU machines the probe ordering might not appear to be sequential. This depends on which CPU was processing the probes, and how threads migrate across CPUs. Displaying probe time stamps helps reduce confusion.

The script traces all user-level PHP OCI8 static probe points throughout the duration of a running PHP script. Run the D script:

# ./user_oci8_probes.d

Run a PHP script or application. The monitoring D script will output each probe's arguments as it fires. For example, a simple PHP script that queries a table might produce the following trace output:

1381794982092854582: PHP connect-entry
  credentials="hr@localhost/pdborcl"
  charset=""
  session_mode=0
  persistent=0
  exclusive=0
1381794982183158766: PHP oci8-connect-return
  connection=0x7f4a7907bfb8
1381794982183594576: PHP oci8-sqltext
  connection=0x7f4a7907bfb8
  client_id="Chris"
  statement=0x7f4a7907c2a0
  sql="select * from employees"
1381794982183783706: PHP oci8-execute-mode
  connection=0x7f4a7907bfb8
  client_id="Chris"
  statement=0x7f4a7907c2a0
  mode=0x20
1381794982444344390: PHP oci8-connect-close
  connection=0x7f4a7907bfb8

When monitoring is complete, the D script can be terminated with a ^C.

See Also

  • DTrace Dynamic Tracing
OCI8 Fast Application Notification (FAN) Support
Supported Datatypes
OCI8


Supported Datatypes

The driver supports the following types when binding parameters using the oci_bind_by_name() function:
Type | Mapping
SQLT_NTY | Maps a native collection type from a PHP collection object, such as those created by oci_new_collection().
SQLT_BFILEE | Maps a native descriptor, such as those created by oci_new_descriptor().
SQLT_CFILEE | Maps a native descriptor, such as those created by oci_new_descriptor().
SQLT_CLOB | Maps a native descriptor, such as those created by oci_new_descriptor().
SQLT_BLOB | Maps a native descriptor, such as those created by oci_new_descriptor().
SQLT_RDD | Maps a native descriptor, such as those created by oci_new_descriptor().
SQLT_NUM | Converts the PHP parameter to a 'C' long type, and binds to that value.
SQLT_RSET | Maps a native statement handle, such as those created by oci_parse() or those retrieved from other OCI queries.
SQLT_BOL | Bind the PHP parameter to a PL/SQL BOOLEAN
SQLT_CHR and any other type | Converts the PHP parameter to a string type and binds as a string.
The following types are supported when retrieving columns from a result set:
Type | Mapping
SQLT_RSET | Creates an oci statement resource to represent the cursor.
SQLT_RDD | Creates a ROWID object.
SQLT_BLOB | Creates a LOB object.
SQLT_CLOB | Creates a LOB object.
SQLT_BFILE | Creates a LOB object.
SQLT_LNG | Bound as SQLT_CHR, returned as a string
SQLT_LBI | Bound as SQLT_BIN, returned as a string
Any other type | Bound as SQLT_CHR, returned as a string
OCI8 and DTrace Dynamic Tracing
OCI8 İşlevleri
OCI8


OCI8 İşlevleri

İçindekiler

  • oci_bind_array_by_name — Binds a PHP array to an Oracle PL/SQL array parameter
  • oci_bind_by_name — Binds a PHP variable to an Oracle placeholder
  • oci_cancel — Cancels reading from cursor
  • oci_client_version — Returns the Oracle client library version
  • oci_close — Closes an Oracle connection
  • oci_commit — Commits the outstanding database transaction
  • oci_connect — Connect to an Oracle database
  • oci_define_by_name — Associates a PHP variable with a column for query fetches
  • oci_error — Returns the last error found
  • oci_execute — Executes a statement
  • oci_fetch_all — Fetches multiple rows from a query into a two-dimensional array
  • oci_fetch_array — Returns the next row from a query as an associative or numeric array
  • oci_fetch_assoc — Returns the next row from a query as an associative array
  • oci_fetch_object — Returns the next row from a query as an object
  • oci_fetch_row — Returns the next row from a query as a numeric array
  • oci_fetch — Fetches the next row from a query into internal buffers
  • oci_field_is_null — Checks if a field in the currently fetched row is NULL
  • oci_field_name — Returns the name of a field from the statement
  • oci_field_precision — Tell the precision of a field
  • oci_field_scale — Tell the scale of the field
  • oci_field_size — Returns field's size
  • oci_field_type_raw — Tell the raw Oracle data type of the field
  • oci_field_type — Returns a field's data type name
  • oci_free_descriptor — Frees a descriptor
  • oci_free_statement — Frees all resources associated with statement or cursor
  • oci_get_implicit_resultset — Returns the next child statement resource from a parent statement resource that has Oracle Database 12c Implicit Result Sets
  • oci_internal_debug — Enables or disables internal debug output
  • oci_lob_copy — Copies large object
  • oci_lob_is_equal — Compares two LOB/FILE locators for equality
  • oci_new_collection — Allocates new collection object
  • oci_new_connect — Connect to the Oracle server using a unique connection
  • oci_new_cursor — Allocates and returns a new cursor (statement handle)
  • oci_new_descriptor — Initializes a new empty LOB or FILE descriptor
  • oci_num_fields — Returns the number of result columns in a statement
  • oci_num_rows — Returns number of rows affected during statement execution
  • oci_parse — Prepares an Oracle statement for execution
  • oci_password_change — Changes password of Oracle's user
  • oci_pconnect — Connect to an Oracle database using a persistent connection
  • oci_result — Returns field's value from the fetched row
  • oci_rollback — Rolls back the outstanding database transaction
  • oci_server_version — Returns the Oracle Database version
  • oci_set_action — Sets the action name
  • oci_set_client_identifier — Sets the client identifier
  • oci_set_client_info — Sets the client information
  • oci_set_edition — Sets the database edition
  • oci_set_module_name — Sets the module name
  • oci_set_prefetch — Sets number of rows to be prefetched by queries
  • oci_statement_type — Returns the type of a statement
Supported Datatypes
oci_bind_array_by_name
OCI8


Binds a PHP array to an Oracle PL/SQL array parameter

OCI8 İşlevleri
oci_bind_by_name
OCI8 İşlevleri
PHP Manual

oci_bind_array_by_name

(PHP 5 >= 5.1.2, PHP 7, PECL OCI8 >= 1.2.0)

oci_bind_array_by_name — Binds a PHP array to an Oracle PL/SQL array parameter

Açıklama

bool oci_bind_array_by_name ( resource $statement , string $name , array &$var_array , int $max_table_length [, int $max_item_length = -1 [, int $type = SQLT_AFC ]] )

Binds the PHP array var_array to the Oracle placeholder name, which points to an Oracle PL/SQL array. Whether it will be used for input or output will be determined at run-time.

Değiştirgeler

statement

A valid OCI statement identifier.

name

The Oracle placeholder.

var_array

An array.

max_table_length

Sets the maximum length both for incoming and result arrays.

max_item_length

Sets maximum length for array items. If not specified or equals to -1, oci_bind_array_by_name() will find the longest element in the incoming array and will use it as the maximum length.

type

Should be used to set the type of PL/SQL array items. See list of available types below:

  • SQLT_NUM - for arrays of NUMBER.

  • SQLT_INT - for arrays of INTEGER (Note: INTEGER it is actually a synonym for NUMBER(38), but SQLT_NUM type won't work in this case even though they are synonyms).

  • SQLT_FLT - for arrays of FLOAT.

  • SQLT_AFC - for arrays of CHAR.

  • SQLT_CHR - for arrays of VARCHAR2.

  • SQLT_VCS - for arrays of VARCHAR.

  • SQLT_AVC - for arrays of CHARZ.

  • SQLT_STR - for arrays of STRING.

  • SQLT_LVC - for arrays of LONG VARCHAR.

  • SQLT_ODT - for arrays of DATE.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 oci_bind_array_by_name() example

<?php

$conn = oci_connect("hr", "hrpwd", "localhost/XE");
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$create = "CREATE TABLE bind_example(name VARCHAR(20))";
$stid = oci_parse($conn, $create);
oci_execute($stid);

$create_pkg = "
CREATE OR REPLACE PACKAGE ARRAYBINDPKG1 AS
  TYPE ARRTYPE IS TABLE OF VARCHAR(20) INDEX BY BINARY_INTEGER;
  PROCEDURE iobind(c1 IN OUT ARRTYPE);
END ARRAYBINDPKG1;";
$stid = oci_parse($conn, $create_pkg);
oci_execute($stid);

$create_pkg_body = "
CREATE OR REPLACE PACKAGE BODY ARRAYBINDPKG1 AS
  CURSOR CUR IS SELECT name FROM bind_example;
  PROCEDURE iobind(c1 IN OUT ARRTYPE) IS
    BEGIN
    -- Bulk Insert
    FORALL i IN INDICES OF c1
      INSERT INTO bind_example VALUES (c1(i));

    -- Fetch and reverse
    IF NOT CUR%ISOPEN THEN
      OPEN CUR;
    END IF;
    FOR i IN REVERSE 1..5 LOOP
      FETCH CUR INTO c1(i);
      IF CUR%NOTFOUND THEN
        CLOSE CUR;
        EXIT;
      END IF;
    END LOOP;
  END iobind;
END ARRAYBINDPKG1;";
$stid = oci_parse($conn, $create_pkg_body);
oci_execute($stid);

$stid = oci_parse($conn, "BEGIN arraybindpkg1.iobind(:c1); END;");
$array = array("one", "two", "three", "four", "five");
oci_bind_array_by_name($stid, ":c1", $array, 5, -1, SQLT_CHR);
oci_execute($stid);

var_dump($array);

?>

OCI8 İşlevleri
oci_bind_by_name
OCI8 İşlevleri


Binds a PHP variable to an Oracle placeholder

oci_bind_array_by_name
oci_cancel
OCI8 İşlevleri
PHP Manual

oci_bind_by_name

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

oci_bind_by_name — Binds a PHP variable to an Oracle placeholder

Açıklama

bool oci_bind_by_name ( resource $statement , string $bv_name , mixed &$variable [, int $maxlength = -1 [, int $type = SQLT_CHR ]] )

Binds a PHP variable variable to the Oracle bind variable placeholder bv_name. Binding is important for Oracle database performance and also as a way to avoid SQL Injection security issues.

Binding allows the database to reuse the statement context and caches from previous executions of the statement, even if another user or process originally executed it. Binding reduces SQL Injection concerns because the data associated with a bind variable is never treated as part of the SQL statement. It does not need quoting or escaping.

PHP variables that have been bound can be changed and the statement re-executed without needing to re-parse the statement or re-bind.

In Oracle, bind variables are commonly divided into IN binds for values that are passed into the database, and OUT binds for values that are returned to PHP. A bind variable may be both IN and OUT. Whether a bind variable will be used for input or output is determined at run-time.

You must specify maxlength when using an OUT bind so that PHP allocates enough memory to hold the returned value.

For IN binds it is recommended to set the maxlength length if the statement is re-executed multiple times with different values for the PHP variable. Otherwise Oracle may truncate data to the length of the initial PHP variable value. If you don't know what the maximum length will be, then re-call oci_bind_by_name() with the current data size prior to each oci_execute() call. Binding an unnecessarily large length will have an impact on process memory in the database.

A bind call tells Oracle which memory address to read data from. For IN binds that address needs to contain valid data when oci_execute() is called. This means that the variable bound must remain in scope until execution. If it doesn't, unexpected results or errors such as "ORA-01460: unimplemented or unreasonable conversion requested" may occur. For OUT binds one symptom is no value being set in the PHP variable.

For a statement that is repeatedly executed, binding values that never change may reduce the ability of the Oracle optimizer to choose the best statement execution plan. Long running statements that are rarely re-executed may not benefit from binding. However in both cases, binding might be safer than joining strings into a SQL statement, as this can be a security risk if unfiltered user text is concatenated.

Değiştirgeler

statement

A valid OCI8 statement identifer.

bv_name

The colon-prefixed bind variable placeholder used in the statement. The colon is optional in bv_name. Oracle does not use question marks for placeholders.

variable

The PHP variable to be associated with bv_name

maxlength

Sets the maximum length for the data. If you set it to -1, this function will use the current length of variable to set the maximum length. In this case the variable must exist and contain data when oci_bind_by_name() is called.

type

The datatype that Oracle will treat the data as. The default type used is SQLT_CHR. Oracle will convert the data between this type and the database column (or PL/SQL variable type), when possible.

If you need to bind an abstract datatype (LOB/ROWID/BFILE) you need to allocate it first using the oci_new_descriptor() function. The length is not used for abstract datatypes and should be set to -1.

Possible values for type are:

  • SQLT_BFILEE or OCI_B_BFILE - for BFILEs;

  • SQLT_CFILEE or OCI_B_CFILEE - for CFILEs;

  • SQLT_CLOB or OCI_B_CLOB - for CLOBs;

  • SQLT_BLOB or OCI_B_BLOB - for BLOBs;

  • SQLT_RDD or OCI_B_ROWID - for ROWIDs;

  • SQLT_NTY or OCI_B_NTY - for named datatypes;

  • SQLT_INT or OCI_B_INT - for integers;

  • SQLT_CHR - for VARCHARs;

  • SQLT_BIN or OCI_B_BIN - for RAW columns;

  • SQLT_LNG - for LONG columns;

  • SQLT_LBI - for LONG RAW columns;

  • SQLT_RSET - for cursors created with oci_new_cursor();

  • SQLT_BOL or OCI_B_BOL - for PL/SQL BOOLEANs (Requires OCI8 2.0.7 and Oracle Database 12c)

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Inserting data with oci_bind_by_name()

<?php

// Create the table with:
//   CREATE TABLE mytab (id NUMBER, text VARCHAR2(40));

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$stid = oci_parse($conn,"INSERT INTO mytab (id, text) VALUES(:id_bv, :text_bv)");

$id = 1;
$text = "Data to insert     ";
oci_bind_by_name($stid, ":id_bv", $id);
oci_bind_by_name($stid, ":text_bv", $text);
oci_execute($stid);

// Table now contains: 1, 'Data to insert     '

?>

Örnek 2 Binding once for multiple executions

<?php

// Create the table with:
//   CREATE TABLE mytab (id NUMBER);

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$a = array(1,3,5,7,11);  // data to insert

$stid = oci_parse($conn, 'INSERT INTO mytab (id) VALUES (:bv)');
oci_bind_by_name($stid, ':bv', $v, 20);
foreach ($a as $v) {
    $r = oci_execute($stid, OCI_DEFAULT);  // don't auto commit
}
oci_commit($conn); // commit everything at once

// Table contains five rows: 1, 3, 5, 7, 11

oci_free_statement($stid);
oci_close($conn);

?>

Örnek 3 Binding with a foreach() loop

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$sql = 'SELECT * FROM departments WHERE department_name = :dname AND location_id = :loc';
$stid = oci_parse($conn, $sql);

$ba = array(':dname' => 'IT Support', ':loc' => 1700);

foreach ($ba as $key => $val) {

    // oci_bind_by_name($stid, $key, $val) does not work
    // because it binds each placeholder to the same location: $val
    // instead use the actual location of the data: $ba[$key]
    oci_bind_by_name($stid, $key, $ba[$key]);
}

oci_execute($stid);
$row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_NULLS);
foreach ($row as $item) {
    print $item."<br>\n";
}

oci_free_statement($stid);
oci_close($conn);

?>

Örnek 4 Binding in a WHERE clause

<?php

$conn = oci_connect("hr", "hrpwd", "localhost/XE");
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$sql = 'SELECT last_name FROM employees WHERE department_id = :didbv ORDER BY last_name';
$stid = oci_parse($conn, $sql);
$didbv = 60;
oci_bind_by_name($stid, ':didbv', $didbv);
oci_execute($stid);
while (($row = oci_fetch_array($stid, OCI_ASSOC)) != false) {
    echo $row['LAST_NAME'] ."<br>\n";
}

// Output is
//    Austin
//    Ernst
//    Hunold
//    Lorentz
//    Pataballa

oci_free_statement($stid);
oci_close($conn);

?>

Örnek 5 Binding with a LIKE clause

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

// Find all cities that begin with 'South'
$stid = oci_parse($conn, "SELECT city FROM locations WHERE city LIKE :bv");
$city = 'South%';  // '%' is a wildcard in SQL
oci_bind_by_name($stid, ":bv", $city);
oci_execute($stid);
oci_fetch_all($stid, $res);

foreach ($res['CITY'] as $c) {
    print $c . "<br>\n";
}
// Output is
//   South Brunswick
//   South San Francisco
//   Southlake

oci_free_statement($stid);
oci_close($conn);

?>

Örnek 6 Binding with REGEXP_LIKE

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

// Find all cities that contain 'ing'
$stid = oci_parse($conn, "SELECT city FROM locations WHERE REGEXP_LIKE(city, :bv)");
$city = '.*ing.*';
oci_bind_by_name($stid, ":bv", $city);
oci_execute($stid);
oci_fetch_all($stid, $res);

foreach ($res['CITY'] as $c) {
    print $c . "<br>\n";
}
// Output is
//   Beijing
//   Singapore

oci_free_statement($stid);
oci_close($conn);

?>

For a small, fixed number of IN clause conditions, use individual bind variables. Values unknown at run time can be set to NULL. This allows a single statement to be used by all application users, maximizing Oracle DB cache efficiency.

Örnek 7 Binding Multiple Values in an IN Clause

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$sql = 'SELECT last_name FROM employees WHERE employee_id in (:e1, :e2, :e3)';
$stid = oci_parse($conn, $sql);
$mye1 = 103;
$mye2 = 104;
$mye3 = NULL; // pretend we were not given this value
oci_bind_by_name($stid, ':e1', $mye1);
oci_bind_by_name($stid, ':e2', $mye2);
oci_bind_by_name($stid, ':e3', $mye3);
oci_execute($stid);
oci_fetch_all($stid, $res);
foreach ($res['LAST_NAME'] as $name) {
    print $name ."<br>\n";
}

// Output is
//   Ernst
//   Hunold

oci_free_statement($stid);
oci_close($conn);

?>

Örnek 8 Binding a ROWID returned by a query

<?php

// Create the table with:
//   CREATE TABLE mytab (id NUMBER, salary NUMBER, name VARCHAR2(40));
//   INSERT INTO mytab (id, salary, name) VALUES (1, 100, 'Chris');
//   COMMIT;

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT ROWID, name FROM mytab WHERE id = :id_bv FOR UPDATE');
$id = 1;
oci_bind_by_name($stid, ':id_bv', $id);
oci_execute($stid);
$row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_NULLS);
$rid = $row['ROWID'];
$name = $row['NAME'];

// Change name to upper case & save the changes
$name = strtoupper($name);
$stid = oci_parse($conn, 'UPDATE mytab SET name = :n_bv WHERE ROWID = :r_bv');
oci_bind_by_name($stid, ':n_bv', $name);
oci_bind_by_name($stid, ':r_bv', $rid, -1, OCI_B_ROWID);
oci_execute($stid);

// The table now contains 1, 100, CHRIS

oci_free_statement($stid);
oci_close($conn);

?>

Örnek 9 Binding a ROWID on INSERT

<?php

// This example inserts an id & name, and then updates the salary
// Create the table with:
//   CREATE TABLE mytab (id NUMBER, salary NUMBER, name VARCHAR2(40));
//
// Based on original ROWID example by thies at thieso dot net (980221)

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$sql = "INSERT INTO mytab (id, name) VALUES(:id_bv, :name_bv)
        RETURNING ROWID INTO :rid";

$ins_stid = oci_parse($conn, $sql);

$rowid = oci_new_descriptor($conn, OCI_D_ROWID);
oci_bind_by_name($ins_stid, ":id_bv",   $id,    10);
oci_bind_by_name($ins_stid, ":name_bv", $name,  32);
oci_bind_by_name($ins_stid, ":rid",     $rowid, -1, OCI_B_ROWID);

$sql = "UPDATE mytab SET salary = :salary WHERE ROWID = :rid";
$upd_stid = oci_parse($conn, $sql);
oci_bind_by_name($upd_stid, ":rid", $rowid, -1, OCI_B_ROWID);
oci_bind_by_name($upd_stid, ":salary", $salary,   32);

// ids and names to insert
$data = array(1111 => "Larry",
              2222 => "Bill",
              3333 => "Jim");

// Salary of each person
$salary = 10000;

// Insert and immediately update each row
foreach ($data as $id => $name) {
    oci_execute($ins_stid);
    oci_execute($upd_stid);
}

$rowid->free();
oci_free_statement($upd_stid);
oci_free_statement($ins_stid);

// Show the new rows
$stid = oci_parse($conn, "SELECT * FROM mytab");
oci_execute($stid);
while ($row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_NULLS)) {
    var_dump($row);
}

oci_free_statement($stid);
oci_close($conn);

?>

Örnek 10 Binding for a PL/SQL stored function

<?php

//  Before running the PHP program, create a stored function in
//  SQL*Plus or SQL Developer:
//
//  CREATE OR REPLACE FUNCTION myfunc(p IN NUMBER) RETURN NUMBER AS
//  BEGIN
//      RETURN p * 3;
//  END;

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message']), E_USER_ERROR);
}

$p = 8;

$stid = oci_parse($conn, 'begin :r := myfunc(:p); end;');
oci_bind_by_name($stid, ':p', $p);

// The return value is an OUT bind. The default type will be a string
// type so binding a length 40 means that at most 40 digits will be
// returned.
oci_bind_by_name($stid, ':r', $r, 40);

oci_execute($stid);

print "$r\n";   // prints 24

oci_free_statement($stid);
oci_close($conn);

?>

Örnek 11 Binding parameters for a PL/SQL stored procedure

<?php

//  Before running the PHP program, create a stored procedure in
//  SQL*Plus or SQL Developer:
//
//  CREATE OR REPLACE PROCEDURE myproc(p1 IN NUMBER, p2 OUT NUMBER) AS
//  BEGIN
//      p2 := p1 * 2;
//  END;

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message']), E_USER_ERROR);
}

$p1 = 8;

$stid = oci_parse($conn, 'begin myproc(:p1, :p2); end;');
oci_bind_by_name($stid, ':p1', $p1);

// The second procedure parameter is an OUT bind. The default type
// will be a string type so binding a length 40 means that at most 40
// digits will be returned.
oci_bind_by_name($stid, ':p2', $p2, 40);

oci_execute($stid);

print "$p2\n";   // prints 16

oci_free_statement($stid);
oci_close($conn);

?>

Örnek 12 Binding a CLOB column

<?php

// Before running, create the table:
//     CREATE TABLE mytab (mykey NUMBER, myclob CLOB);

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message']), E_USER_ERROR);
}

$mykey = 12343;  // arbitrary key for this example;

$sql = "INSERT INTO mytab (mykey, myclob)
        VALUES (:mykey, EMPTY_CLOB())
        RETURNING myclob INTO :myclob";

$stid = oci_parse($conn, $sql);
$clob = oci_new_descriptor($conn, OCI_D_LOB);
oci_bind_by_name($stid, ":mykey", $mykey, 5);
oci_bind_by_name($stid, ":myclob", $clob, -1, OCI_B_CLOB);
oci_execute($stid, OCI_DEFAULT);
$clob->save("A very long string");

oci_commit($conn);

// Fetching CLOB data

$query = 'SELECT myclob FROM mytab WHERE mykey = :mykey';

$stid = oci_parse ($conn, $query);
oci_bind_by_name($stid, ":mykey", $mykey, 5);
oci_execute($stid);

print '<table border="1">';
while ($row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_LOBS)) {
    print '<tr><td>'.$row['MYCLOB'].'</td></tr>';
    // In a loop, freeing the large variable before the 2nd fetch reduces PHP's peak memory usage
    unset($row);
}
print '</table>';

?>

Örnek 13 Binding a PL/SQL BOOLEAN

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message']), E_USER_ERROR);
}

$plsql =
  "begin
    :output1 := true;
    :output2 := false;
   end;";

$s = oci_parse($c, $plsql);
oci_bind_by_name($s, ':output1', $output1, -1, OCI_B_BOL);
oci_bind_by_name($s, ':output2', $output2, -1, OCI_B_BOL);
oci_execute($s);
var_dump($output1);  // true
var_dump($output2);  // false

?>

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

Uyarı

Do not use magic_quotes_gpc or addslashes() and oci_bind_by_name() simultaneously as no quoting is needed. Any magically applied quotes will be written into your database because oci_bind_by_name() inserts data verbatim and does not remove quotes or escape characters.

Bilginize:

If you bind a string to a CHAR column in a WHERE clause, remember that Oracle uses blank-padded comparison semantics for CHAR columns. Your PHP variable should be blank padded to the same width as the column for the WHERE clause to succeed.

Bilginize:

The PHP variable argument is a reference. Some forms of loops do not work as expected:

<?php
foreach ($myarray as $key => $value)  {
    oci_bind_by_name($stid, $key, $value);
}
?>

This binds each key to the location of $value, so all bound variables end up pointing to the last loop iteration's value. Instead use the following:

<?php
foreach ($myarray as $key => $value) {
    oci_bind_by_name($stid, $key, $myarray[$key]);
}
?>

Ayrıca Bakınız

  • oci_bind_array_by_name() - Binds a PHP array to an Oracle PL/SQL array parameter
  • oci_parse() - Prepares an Oracle statement for execution

oci_bind_array_by_name
oci_cancel
OCI8 İşlevleri


Cancels reading from cursor

oci_bind_by_name
oci_client_version
OCI8 İşlevleri
PHP Manual

oci_cancel

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

oci_cancel — Cancels reading from cursor

Açıklama

bool oci_cancel ( resource $statement )

Invalidates a cursor, freeing all associated resources and cancels the ability to read from it.

Değiştirgeler

statement

An OCI statement.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

oci_bind_by_name
oci_client_version
OCI8 İşlevleri


Returns the Oracle client library version

oci_cancel
oci_close
OCI8 İşlevleri
PHP Manual

oci_client_version

(PHP 5.3.7, PHP 7, PECL OCI8 >= 1.4.6)

oci_client_version — Returns the Oracle client library version

Açıklama

string oci_client_version ( void )

Returns a string containing the version number of the Oracle C client library that PHP is linked with.

Değiştirgeler

None

Dönen Değerler

Returns the version number as a string.

Örnekler

Örnek 1 oci_client_version() example

<?php
    echo "Client Version: " . oci_client_version(); // Client version: 11.2.0.2
?>

Notlar

Bilginize:

Oracle libraries before 10gR2 do not have the underlying functionality to get the client library version number. The string "Unknown" will be returned in this case.

Ayrıca Bakınız

  • oci_server_version() - Returns the Oracle Database version

oci_cancel
oci_close
OCI8 İşlevleri


Closes an Oracle connection

oci_client_version
oci_commit
OCI8 İşlevleri
PHP Manual

oci_close

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

oci_close — Closes an Oracle connection

Açıklama

bool oci_close ( resource $connection )

Unsets connection. The underlying database connection is closed if no other resources are using it and if it was created with oci_connect() or oci_new_connect().

It is recommended to close connections that are no longer needed because this makes database resources available for other users.

Değiştirgeler

connection

An Oracle connection identifier returned by oci_connect(), oci_pconnect(), or oci_new_connect().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Closing a connection

Resources associated with a connection should be closed to ensure the underlying database connection is properly terminated and the database resources are released.

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT * FROM departments');
$r = oci_execute($stid);
oci_fetch_all($stid, $res);
var_dump($res);

// Free the statement identifier when closing the connection
oci_free_statement($stid);
oci_close($conn);

?>

Örnek 2 Database connections are not closed until all references are closed

The internal refcount of a connection identifier must be zero before the underlying connection to the database is closed.

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT * FROM departments');  // this increases the refcount on $conn
oci_execute($stid);
oci_fetch_all($stid, $res);
var_dump($res);

oci_close($conn);

// $conn is no longer usable in the script but the underlying database
// connection is still held open until $stid is freed.
var_dump($conn);  // prints NULL

// While PHP sleeps, querying the Oracle V$SESSION view in a
// terminal window will show that the database user is still connected.
sleep(10);

// When $stid is freed, the database connection is physically closed
oci_free_statement($stid);

// While PHP sleeps, querying the Oracle V$SESSION view in a
// terminal window will show that the database user has disconnected.
sleep(10);

?>

Örnek 3 Closing a connection opened more than once

When database credentials are reused, both connections must be closed before the underlying database connection is closed.

<?php

$conn1 = oci_connect('hr', 'welcome', 'localhost/XE');

// Using the same credentials reuses the same underlying database connection
// Any uncommitted changes done on $conn1 will be visible in $conn2
$conn2 = oci_connect('hr', 'welcome', 'localhost/XE');

// While PHP sleeps, querying the Oracle V$SESSION view in a
// terminal window will show that only one database user is connected.
sleep(10);

oci_close($conn1); // doesn't close the underlying database connection
var_dump($conn1);  // prints NULL because the variable $conn1 is no longer usable
var_dump($conn2);  // displays that $conn2 is still a valid connection resource

?>

Örnek 4 Connections are closed when variables go out of scope

When all variables referencing a connection go out of scope and are freed by PHP, a rollback occurs (if necessary) and the underlying connection to the database is closed.

<?php

function myfunc() {
    $conn = oci_connect('hr', 'hrpwd', 'localhost/XE');
    if (!$conn) {
        $e = oci_error();
        trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
    }

    $stid = oci_parse($conn, 'UPDATE mytab SET id = 100');
    oci_execute($stid, OCI_NO_AUTO_COMMIT);
    return "Finished";
}

$r = myfunc();
// At this point a rollback occurred and the underlying database connection was released.

print $r;  // displays the function return value "Finished"

?>

Notlar

Bilginize:

Variables that have a dependency on the connection identifier, such as statement identifiers returned by oci_parse(), must also be freed before the underlying database connection is closed.

Bilginize:

Prior to version PHP 5.1.2 (PECL OCI8 1.1) oci_close() was a no-op. In more recent versions it correctly closes the Oracle connection. Use oci8.old_oci_close_semantics option to restore old behavior of this function.

Bilginize:

The oci_close() function does not close the underlying database connections created with oci_pconnect().

Ayrıca Bakınız

  • oci_connect() - Connect to an Oracle database
  • oci_free_statement() - Frees all resources associated with statement or cursor

oci_client_version
oci_commit
OCI8 İşlevleri


Commits the outstanding database transaction

oci_close
oci_connect
OCI8 İşlevleri
PHP Manual

oci_commit

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

oci_commit — Commits the outstanding database transaction

Açıklama

bool oci_commit ( resource $connection )

Commits the outstanding transaction for the Oracle connection. A commit ends the current transaction and makes permanent all changes. It releases all locks held.

A transaction begins when the first SQL statement that changes data is executed with oci_execute() using the OCI_NO_AUTO_COMMIT flag. Further data changes made by other statements become part of the same transaction. Data changes made in a transaction are temporary until the transaction is committed or rolled back. Other users of the database will not see the changes until they are committed.

When inserting or updating data, using transactions is recommended for relational data consistency and for performance reasons.

Değiştirgeler

connection

An Oracle connection identifier, returned by oci_connect(), oci_pconnect(), or oci_new_connect().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 oci_commit() example

<?php

// Insert into several tables, rolling back the changes if an error occurs

$conn = oci_connect('hr', 'welcome', 'localhost/XE');

$stid = oci_parse($conn, "INSERT INTO mysalary (id, name) VALUES (1, 'Chris')");

// The OCI_NO_AUTO_COMMIT flag tells Oracle not to commit the INSERT immediately
// Use OCI_DEFAULT as the flag for PHP <= 5.3.1.  The two flags are equivalent
$r = oci_execute($stid, OCI_NO_AUTO_COMMIT);
if (!$r) {
    $e = oci_error($stid);
    trigger_error(htmlentities($e['message']), E_USER_ERROR);
}

$stid = oci_parse($conn, 'INSERT INTO myschedule (startday) VALUES (12)');
$r = oci_execute($stid, OCI_NO_AUTO_COMMIT);
if (!$r) {
    $e = oci_error($stid);
    oci_rollback($conn);  // rollback changes to both tables
    trigger_error(htmlentities($e['message']), E_USER_ERROR);
}

// Commit the changes to both tables
$r = oci_commit($conn);
if (!$r) {
    $e = oci_error($conn);
    trigger_error(htmlentities($e['message']), E_USER_ERROR);
}

?>

Notlar

Bilginize:

Transactions are automatically rolled back when you close the connection, or when the script ends, whichever is soonest. You need to explicitly call oci_commit() to commit the transaction.

Any call to oci_execute() that uses OCI_COMMIT_ON_SUCCESS mode explicitly or by default will commit any previous uncommitted transaction.

Any Oracle DDL statement such as CREATE or DROP will automatically commit any uncommitted transaction.

Ayrıca Bakınız

  • oci_execute() - Executes a statement
  • oci_rollback() - Rolls back the outstanding database transaction

oci_close
oci_connect
OCI8 İşlevleri


Connect to an Oracle database

oci_commit
oci_define_by_name
OCI8 İşlevleri
PHP Manual

oci_connect

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

oci_connect — Connect to an Oracle database

Açıklama

resource oci_connect ( string $username , string $password [, string $connection_string [, string $character_set [, int $session_mode ]]] )

Returns a connection identifier needed for most other OCI8 operations.

See Connection Handling for general information on connection management and connection pooling.

From PHP 5.1.2 (PECL OCI8 1.1) oci_close() can be used to close the connection.

The second and subsequent calls to oci_connect() with the same parameters will return the connection handle returned from the first call. This means that transactions in one handle are also in the other handles, because they use the same underlying database connection. If two handles need to be transactionally isolated from each other, use oci_new_connect() instead.

Değiştirgeler

username

The Oracle user name.

password

The password for username.

connection_string

Contains the Oracle instance to connect to. It can be an » Easy Connect string, or a Connect Name from the tnsnames.ora file, or the name of a local Oracle instance

If not specified, PHP uses environment variables such as TWO_TASK (on Linux) or LOCAL (on Windows) and ORACLE_SID to determine the Oracle instance to connect to.

To use the Easy Connect naming method, PHP must be linked with Oracle 10g or greater Client libraries. The Easy Connect string for Oracle 10g is of the form: 10g is of the form: [//]host_name[:port][/service_name]. With Oracle [//]host_name[:port][/service_name]. From Oracle 11g, the syntax is: 11g, the syntax is:[//]host_name[:port][/service_name][:server_type][/instance_name] . Service names can be found by running the Oracle utility lsnrctl status on the database server machine.

The tnsnames.ora file can be in the Oracle Net search path, which includes $ORACLE_HOME/network/admin and /etc. Alternatively set TNS_ADMIN so that $TNS_ADMIN/tnsnames.ora is read. Make sure the web daemon has read access to the file.

character_set

Oracle sunucusunun 9.2 ve üstü sürümlerini kullanırken, karakter_kümesi değiştirgesini yeni bağlantıda kullanılacak değiştirgeye göre belirtebilirsiniz. Eğer 9.2 sürümünden daha eski bir Oracle sunucusu kullanıyorsanız bu değiştirge yok sayılacak, yerine NLS_LANG ortam değişkeni kullanılacaktır.

If not specified, the Oracle Client libraries determine a character set from the NLS_LANG environment variable.

Passing this parameter can reduce the time taken to connect.

session_mode

This parameter is available since version PHP 5 (PECL OCI8 1.1) and accepts the following values: OCI_DEFAULT, OCI_SYSOPER and OCI_SYSDBA. If either OCI_SYSOPER or OCI_SYSDBA were specified, this function will try to establish privileged connection using external credentials. Privileged connections are disabled by default. To enable them you need to set oci8.privileged_connect to On.

PHP 5.3 (PECL OCI8 1.3.4) introduced the OCI_CRED_EXT mode value. This tells Oracle to use External or OS authentication, which must be configured in the database. The OCI_CRED_EXT flag can only be used with username of "/" and a empty password. oci8.privileged_connect may be On or Off.

OCI_CRED_EXT may be combined with the OCI_SYSOPER or OCI_SYSDBA modes.

OCI_CRED_EXT is not supported on Windows for security reasons.

Dönen Değerler

Returns a connection identifier or FALSE on error.

Örnekler

Örnek 1 Basic oci_connect() using Easy Connect syntax

<?php

// Connects to the XE service (i.e. database) on the "localhost" machine
$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT * FROM employees');
oci_execute($stid);

echo "<table border='1'>\n";
while ($row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_NULLS)) {
    echo "<tr>\n";
    foreach ($row as $item) {
        echo "    <td>" . ($item !== null ? htmlentities($item, ENT_QUOTES) : "&nbsp;") . "</td>\n";
    }
    echo "</tr>\n";
}
echo "</table>\n";

?>

Örnek 2 Basic oci_connect() using a Network Connect name

<?php

// Connects to the MYDB database described in tnsnames.ora file,
// One example tnsnames.ora entry for MYDB could be:
//   MYDB =
//     (DESCRIPTION =
//       (ADDRESS = (PROTOCOL = TCP)(HOST = mymachine.oracle.com)(PORT = 1521))
//       (CONNECT_DATA =
//         (SERVER = DEDICATED)
//         (SERVICE_NAME = XE)
//       )
//     )

$conn = oci_connect('hr', 'welcome', 'MYDB');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT * FROM employees');
oci_execute($stid);

echo "<table border='1'>\n";
while ($row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_NULLS)) {
    echo "<tr>\n";
    foreach ($row as $item) {
        echo "    <td>" . ($item !== null ? htmlentities($item, ENT_QUOTES) : "&nbsp;") . "</td>\n";
    }
    echo "</tr>\n";
}
echo "</table>\n";

?>

Örnek 3 oci_connect() with an explicit character set

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE', 'AL32UTF8');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT * FROM employees');
oci_execute($stid);

echo "<table border='1'>\n";
while ($row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_NULLS)) {
    echo "<tr>\n";
    foreach ($row as $item) {
        echo "    <td>" . ($item !== null ? htmlentities($item, ENT_QUOTES) : "&nbsp;") . "</td>\n";
    }
    echo "</tr>\n";
}
echo "</table>\n";

?>

Örnek 4 Using multiple calls to oci_connect()

<?php

$c1 = oci_connect("hr", "welcome", 'localhost/XE');
$c2 = oci_connect("hr", "welcome", 'localhost/XE');

// Both $c1 and $c2 show the same PHP resource id meaning they use the
// same underlying database connection
echo "c1 is $c1<br>\n";
echo "c2 is $c2<br>\n";

function create_table($conn)
{
    $stmt = oci_parse($conn, "create table hallo (test varchar2(64))");
    oci_execute($stmt);
    echo "Created table<br>\n";
}

function drop_table($conn)
{
    $stmt = oci_parse($conn, "drop table hallo");
    oci_execute($stmt);
    echo "Dropped table<br>\n";
}

function insert_data($connname, $conn)
{
    $stmt = oci_parse($conn, "insert into hallo
              values(to_char(sysdate,'DD-MON-YY HH24:MI:SS'))");
    oci_execute($stmt, OCI_DEFAULT);
    echo "$connname inserted row without committing<br>\n";
}

function rollback($connname, $conn)
{
    oci_rollback($conn);
    echo "$connname rollback<br>\n";
}

function select_data($connname, $conn)
{
    $stmt = oci_parse($conn, "select * from hallo");
    oci_execute($stmt, OCI_DEFAULT);
    echo "$connname ----selecting<br>\n";
    while (oci_fetch($stmt)) {
        echo "    " . oci_result($stmt, "TEST") . "<br>\n";
    }
    echo "$connname ----done<br>\n";
}

create_table($c1);

insert_data('c1', $c1);   // Insert a row using c1
sleep(2);                 // sleep to show a different timestamp for the 2nd row
insert_data('c2', $c2);   // Insert a row using c2

select_data('c1', $c1);   // Results of both inserts are returned
select_data('c2', $c2);   // Results of both inserts are returned

rollback('c1', $c1);      // Rollback using c1

select_data('c1', $c1);   // Both inserts have been rolled back
select_data('c2', $c2);

drop_table($c1);

// Closing one of the connections makes the PHP variable unusable, but
// the other could be used
oci_close($c1);
echo "c1 is $c1<br>\n";
echo "c2 is $c2<br>\n";

// Output is:
//    c1 is Resource id #5
//    c2 is Resource id #5
//    Created table
//    c1 inserted row without committing
//    c2 inserted row without committing
//    c1 ----selecting
//        09-DEC-09 12:14:43
//        09-DEC-09 12:14:45
//    c1 ----done
//    c2 ----selecting
//        09-DEC-09 12:14:43
//        09-DEC-09 12:14:45
//    c2 ----done
//    c1 rollback
//    c1 ----selecting
//    c1 ----done
//    c2 ----selecting
//    c2 ----done
//    Dropped table
//    c1 is
//    c2 is Resource id #5

?>

Notlar

Bilginize:

An incorrectly installed or configured OCI8 extension will often manifest itself as a connection problem or error. See Installing/Configuring for troubleshooting information.

Ayrıca Bakınız

  • oci_pconnect() - Connect to an Oracle database using a persistent connection
  • oci_new_connect() - Connect to the Oracle server using a unique connection
  • oci_close() - Closes an Oracle connection

oci_commit
oci_define_by_name
OCI8 İşlevleri


Associates a PHP variable with a column for query fetches

oci_connect
oci_error
OCI8 İşlevleri
PHP Manual

oci_define_by_name

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

oci_define_by_name — Associates a PHP variable with a column for query fetches

Açıklama

bool oci_define_by_name ( resource $statement , string $column_name , mixed &$variable [, int $type = SQLT_CHR ] )

Associates a PHP variable with a column for query fetches using oci_fetch().

The oci_define_by_name() call must occur before executing oci_execute().

Değiştirgeler

statement

A valid OCI8 statement identifier created by oci_parse() and executed by oci_execute(), or a REF CURSOR statement identifier.

column_name

The column name used in the query.

Use uppercase for Oracle's default, non-case sensitive column names. Use the exact column name case for case-sensitive column names.

variable

The PHP variable that will contain the returned column value.

type

The data type to be returned. Generally not needed. Note that Oracle-style data conversions are not performed. For example, SQLT_INT will be ignored and the returned data type will still be SQLT_CHR.

You can optionally use oci_new_descriptor() to allocate LOB/ROWID/BFILE descriptors.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 oci_define_by_name() example

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$sql = 'SELECT location_id, city FROM locations WHERE location_id < 1200';
$stid = oci_parse($conn, $sql);

// The defines MUST be done before executing
oci_define_by_name($stid, 'LOCATION_ID', $locid);
oci_define_by_name($stid, 'CITY', $city);

oci_execute($stid);

// Each fetch populates the previously defined variables with the next row's data
while (oci_fetch($stid)) {
    echo "Location id $locid is $city<br>\n";
}

// Displays:
//   Location id 1000 is Roma
//   Location id 1100 is Venice

oci_free_statement($stid);
oci_close($conn);

?>

Örnek 2 oci_define_by_name() with case sensitive column names

<?php

/*
  Before running, create the table with a case sensitive column name:
    CREATE TABLE mytab (id NUMBER, "MyDescription" VARCHAR2(30));
    INSERT INTO mytab (id, "MyDescription") values (1, 'Iced Coffee');
    COMMIT;
*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT * FROM mytab');

// Use uppercase for non case-sensitive column names
oci_define_by_name($stid, 'ID', $id);

// Use the exact case for case-sensitive column names
oci_define_by_name($stid, 'MyDescription', $mydesc);

oci_execute($stid);

while (oci_fetch($stid)) {
    echo "id $id is $mydesc<br>\n";
}

// Displays:
//   id 1 is Iced Coffee

oci_free_statement($stid);
oci_close($conn);

?>

Örnek 3 oci_define_by_name() with LOB columns

<?php

/*
  Before running, create the table:
    CREATE TABLE mytab (id NUMBER, fruit CLOB);
    INSERT INTO mytab (id, fruit) values (1, 'apple');
    INSERT INTO mytab (id, fruit) values (2, 'orange');
    COMMIT;
*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT * FROM mytab');

// The defines MUST be done before executing
oci_define_by_name($stid, 'ID', $id);
oci_define_by_name($stid, 'FRUIT', $fruit);  // $fruit will become a LOB descriptor

oci_execute($stid);

while (oci_fetch($stid)) {
    echo $id . " is " . $fruit->load(100) . "<br>\n";
}

// Displays:
//   1 is apple
//   2 is orange

$fruit->free();
oci_free_statement($stid);
oci_close($conn);

?>

Örnek 4 oci_define_by_name() with an explicit type

<?php

/*
  Before running, create the table:
    CREATE TABLE mytab (id NUMBER, fruit CLOB);
    INSERT INTO mytab (id, fruit) values (1, 'apple');
    INSERT INTO mytab (id, fruit) values (2, 'orange');
    COMMIT;
*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT * FROM mytab');

// The defines MUST be done before executing
oci_define_by_name($stid, 'ID', $id);

$fruit = oci_new_descriptor($conn, OCI_D_LOB);
oci_define_by_name($stid, 'FRUIT', $fruit, OCI_D_CLOB);

oci_execute($stid);

while (oci_fetch($stid)) {
    echo $id . " is " . $fruit->load(100) . "<br>\n";
}

// Displays:
//   1 is apple
//   2 is orange

$fruit->free();
oci_free_statement($stid);
oci_close($conn);

?>

Ayrıca Bakınız

  • oci_fetch() - Fetches the next row from a query into internal buffers
  • oci_new_descriptor() - Initializes a new empty LOB or FILE descriptor

oci_connect
oci_error
OCI8 İşlevleri


Returns the last error found

oci_define_by_name
oci_execute
OCI8 İşlevleri
PHP Manual

oci_error

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

oci_error — Returns the last error found

Açıklama

array oci_error ([ resource $resource ] )

Returns the last error found.

The function should be called immediately after an error occurs. Errors are cleared by a successful statement.

Değiştirgeler

resource

For most errors, resource is the
resource handle that was passed to the failing function call.
For connection errors with oci_connect(),
oci_new_connect() or
oci_pconnect() do not pass resource.

Dönen Değerler

If no error is found, oci_error() returns FALSE. Otherwise, oci_error() returns the error information as an associative array.

oci_error() Array Description
Array key | Type | Açıklama
code | integer | The Oracle error number.
message | string | The Oracle error text.
offset | integer | The byte position of an error in the SQL statement. If there was no statement, this is 0
sqltext | string | The SQL statement text. If there was no statement, this is an empty string.

Örnekler

Örnek 1 Displaying the Oracle error message after a connection error

<?php
$conn = oci_connect("hr", "welcome", "localhost/XE");
if (!$conn) {
    $e = oci_error();   // For oci_connect errors do not pass a handle
    trigger_error(htmlentities($e['message']), E_USER_ERROR);
}
?>

Örnek 2 Displaying the Oracle error message after a parsing error

<?php
$stid = oci_parse($conn, "select ' from dual");  // note mismatched quote
if (!$stid) {
    $e = oci_error($conn);  // For oci_parse errors pass the connection handle
    trigger_error(htmlentities($e['message']), E_USER_ERROR);
}
?>

Örnek 3 Displaying the Oracle error message, the problematic statement, and the position of the problem of an execution error

<?php
$stid = oci_parse($conn, "select does_not_exist from dual");
$r = oci_execute($stid);
if (!$r) {
    $e = oci_error($stid);  // For oci_execute errors pass the statement handle
    print htmlentities($e['message']);
    print "\n<pre>\n";
    print htmlentities($e['sqltext']);
    printf("\n%".($e['offset']+1)."s", "^");
    print  "\n</pre>\n";
}
?>

oci_define_by_name
oci_execute
OCI8 İşlevleri


Executes a statement

oci_error
oci_fetch_all
OCI8 İşlevleri
PHP Manual

oci_execute

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

oci_execute — Executes a statement

Açıklama

bool oci_execute ( resource $statement [, int $mode = OCI_COMMIT_ON_SUCCESS ] )

Executes a statement previously returned from oci_parse().

After execution, statements like INSERT will have data committed to the database by default. For statements like SELECT, execution performs the logic of the query. Query results can subsequently be fetched in PHP with functions like oci_fetch_array().

Each parsed statement may be executed multiple times, saving the cost of re-parsing. This is commonly used for INSERT statements when data is bound with oci_bind_by_name().

Değiştirgeler

statement

A valid OCI statement identifier.

mode

An optional second parameter can be one of the following constants:

Execution Modes
Constant | Description
OCI_COMMIT_ON_SUCCESS | Automatically commit all outstanding changes for this connection when the statement has succeeded. This is the default.
OCI_DESCRIBE_ONLY | Make query meta data available to functions like oci_field_name() but do not create a result set. Any subsequent fetch call such as oci_fetch_array() will fail.
OCI_NO_AUTO_COMMIT | Do not automatically commit changes. Prior to PHP 5.3.2 (PECL OCI8 1.4) use OCI_DEFAULT which is equivalent to OCI_NO_AUTO_COMMIT.

Using OCI_NO_AUTO_COMMIT mode starts or continues a transaction. Transactions are automatically rolled back when the connection is closed, or when the script ends. Explicitly call oci_commit() to commit a transaction, or oci_rollback() to abort it.

When inserting or updating data, using transactions is recommended for relational data consistency and for performance reasons.

If OCI_NO_AUTO_COMMIT mode is used for any statement including queries, and oci_commit() or oci_rollback() is not subsequently called, then OCI8 will perform a rollback at the end of the script even if no data was changed. To avoid an unnecessary rollback, many scripts do not use OCI_NO_AUTO_COMMIT mode for queries or PL/SQL. Be careful to ensure the appropriate transactional consistency for the application when using oci_execute() with different modes in the same script.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 oci_execute() for queries

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');

$stid = oci_parse($conn, 'SELECT * FROM employees');
oci_execute($stid);

echo "<table border='1'>\n";
while ($row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_NULLS)) {
    echo "<tr>\n";
    foreach ($row as $item) {
        echo "    <td>" . ($item !== null ? htmlentities($item, ENT_QUOTES) : "&nbsp;") . "</td>\n";
    }
    echo "</tr>\n";
}
echo "</table>\n";

?>

Örnek 2 oci_execute() without specifying a mode example

<?php

// Before running, create the table:
//   CREATE TABLE MYTABLE (col1 NUMBER);

$conn = oci_connect('hr', 'welcome', 'localhost/XE');

$stid = oci_parse($conn, 'INSERT INTO mytab (col1) VALUES (123)');

oci_execute($stid); // The row is committed and immediately visible to other users

?>

Örnek 3 oci_execute() with OCI_NO_AUTO_COMMIT example

<?php

// Before running, create the table:
//   CREATE TABLE MYTABLE (col1 NUMBER);

$conn = oci_connect('hr', 'welcome', 'localhost/XE');

$stid = oci_parse($conn, 'INSERT INTO mytab (col1) VALUES (:bv)');
oci_bind_by_name($stid, ':bv', $i, 10);
for ($i = 1; $i <= 5; ++$i) {
    oci_execute($stid, OCI_NO_AUTO_COMMIT);  // use OCI_DEFAULT for PHP <= 5.3.1
}
oci_commit($conn);  // commits all new values: 1, 2, 3, 4, 5

?>

Örnek 4 oci_execute() with different commit modes example

<?php

// Before running, create the table:
//   CREATE TABLE MYTABLE (col1 NUMBER);

$conn = oci_connect('hr', 'welcome', 'localhost/XE');

$stid = oci_parse($conn, 'INSERT INTO mytab (col1) VALUES (123)');
oci_execute($stid, OCI_NO_AUTO_COMMIT);  // data not committed

$stid = oci_parse($conn, 'INSERT INTO mytab (col1) VALUES (456)');
oci_execute($stid);  // commits both 123 and 456 values

?>

Örnek 5 oci_execute() with OCI_DESCRIBE_ONLY example

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');

$stid = oci_parse($conn, 'SELECT * FROM locations');
oci_execute($s, OCI_DESCRIBE_ONLY);
for ($i = 1; $i <= oci_num_fields($stid); ++$i) {
    echo oci_field_name($stid, $i) . "<br>\n";
}

?>

Notlar

Bilginize:

Transactions are automatically rolled back when connections are closed, or when the script ends, whichever is soonest. Explicitly call oci_commit() to commit a transaction.

Any call to oci_execute() that uses OCI_COMMIT_ON_SUCCESS mode explicitly or by default will commit any previous uncommitted transaction.

Any Oracle DDL statement such as CREATE or DROP will automatically commit any uncommitted transaction.

Bilginize:

Because the oci_execute() function generally sends the statement to the database, oci_execute() can identify some statement syntax errors that the lightweight, local oci_parse() function does not.

Ayrıca Bakınız

  • oci_parse() - Prepares an Oracle statement for execution

oci_error
oci_fetch_all
OCI8 İşlevleri


Fetches multiple rows from a query into a two-dimensional array

oci_execute
oci_fetch_array
OCI8 İşlevleri
PHP Manual

oci_fetch_all

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

oci_fetch_all — Fetches multiple rows from a query into a two-dimensional array

Açıklama

int oci_fetch_all ( resource $statement , array &$output [, int $skip = 0 [, int $maxrows = -1 [, int $flags = OCI_FETCHSTATEMENT_BY_COLUMN + OCI_ASSOC ]]] )

Fetches multiple rows from a query into a two-dimensional array. By default, all rows are returned.

This function can be called only once for each query executed with oci_execute().

Değiştirgeler

statement

A valid OCI8 statement identifier created by oci_parse() and executed by oci_execute(), or a REF CURSOR statement identifier.

output

The variable to contain the returned rows.

LOB columns are returned as strings, where Oracle supports conversion.

See oci_fetch_array() for more information on how data and types are fetched.

skip

The number of initial rows to discard when fetching the result. The default value is 0, so the first row onwards is returned.

maxrows

The number of rows to return. The default is -1 meaning return all the rows from skip + 1 onwards.

flags

Parameter flags indicates the array structure and whether associative arrays should be used.

oci_fetch_all() Array Structure Modes
Constant | Description
OCI_FETCHSTATEMENT_BY_ROW | The outer array will contain one sub-array per query row.
OCI_FETCHSTATEMENT_BY_COLUMN | The outer array will contain one sub-array per query column. This is the default.

Arrays can be indexed either by column heading or numerically. Only one index mode will be returned.

oci_fetch_all() Array Index Modes
Constant | Description
OCI_NUM | Numeric indexes are used for each column's array.
OCI_ASSOC | Associative indexes are used for each column's array. This is the default.

Use the addition operator "+" to choose a combination of array structure and index modes.

Oracle's default, non-case sensitive column names will have uppercase array keys. Case-sensitive column names will have array keys using the exact column case. Use var_dump() on output to verify the appropriate case to use for each query.

Queries that have more than one column with the same name should use column aliases. Otherwise only one of the columns will appear in an associative array.

Dönen Değerler

Returns the number of rows in output, which may be 0 or more, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 oci_fetch_all() example

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT POSTAL_CODE, CITY FROM locations WHERE ROWNUM < 3');
oci_execute($stid);

$nrows = oci_fetch_all($stid, $res);

echo "$nrows rows fetched<br>\n";
var_dump($res);

// var_dump output is:
//    2 rows fetched
//    array(2) {
//      ["POSTAL_CODE"]=>
//      array(2) {
//        [0]=>
//        string(6) "00989x"
//        [1]=>
//        string(6) "10934x"
//      }
//      ["CITY"]=>
//      array(2) {
//        [0]=>
//        string(4) "Roma"
//        [1]=>
//        string(6) "Venice"
//      }
//    }

// Pretty-print the results
echo "<table border='1'>\n";
foreach ($res as $col) {
    echo "<tr>\n";
    foreach ($col as $item) {
        echo "    <td>".($item !== null ? htmlentities($item, ENT_QUOTES) : "")."</td>\n";
    }
    echo "</tr>\n";
}
echo "</table>\n";

oci_free_statement($stid);
oci_close($conn);

?>

Örnek 2 oci_fetch_all() example with OCI_FETCHSTATEMENT_BY_ROW

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT POSTAL_CODE, CITY FROM locations WHERE ROWNUM < 3');
oci_execute($stid);

$nrows = oci_fetch_all($stid, $res, null, null, OCI_FETCHSTATEMENT_BY_ROW);

echo "$nrows rows fetched<br>\n";
var_dump($res);

// Output is:
//    2 rows fetched
//    array(2) {
//      [0]=>
//      array(2) {
//        ["POSTAL_CODE"]=>
//        string(6) "00989x"
//        ["CITY"]=>
//        string(4) "Roma"
//      }
//      [1]=>
//      array(2) {
//        ["POSTAL_CODE"]=>
//        string(6) "10934x"
//        ["CITY"]=>
//        string(6) "Venice"
//      }
//    }

oci_free_statement($stid);
oci_close($conn);

?>

Örnek 3 oci_fetch_all() with OCI_NUM

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT POSTAL_CODE, CITY FROM locations WHERE ROWNUM < 3');
oci_execute($stid);

$nrows = oci_fetch_all($stid, $res, null, null, OCI_FETCHSTATEMENT_BY_ROW + OCI_NUM);

echo "$nrows rows fetched<br>\n";
var_dump($res);

// Output is:
//    2 rows fetched
//    array(2) {
//      [0]=>
//      array(2) {
//        [0]=>
//        string(6) "00989x"
//        [1]=>
//        string(4) "Roma"
//      }
//      [1]=>
//      array(2) {
//        [0]=>
//        string(6) "10934x"
//        [1]=>
//        string(6) "Venice"
//      }
//    }

oci_free_statement($stid);
oci_close($conn);

?>

Notlar

Bilginize:

Using skip is very inefficient. All the rows to be skipped are included in the result set that is returned from the database to PHP. They are then discarded. It is more efficient to use SQL to restrict the offset and range of rows in the query. See oci_fetch_array() for an example.

Bilginize:

Queries that return a large number of rows can be more memory efficient if a single-row fetching function like oci_fetch_array() is used.

Bilginize:

For queries returning a large number of rows, performance can be significantly improved by increasing oci8.default_prefetch or using oci_set_prefetch().

Bilginize:

Will not return rows from Oracle Database 12c Implicit Result Sets. Use oci_fetch_array() instead.

Ayrıca Bakınız

  • oci_fetch() - Fetches the next row from a query into internal buffers
  • oci_fetch_array() - Returns the next row from a query as an associative or numeric array
  • oci_fetch_assoc() - Returns the next row from a query as an associative array
  • oci_fetch_object() - Returns the next row from a query as an object
  • oci_fetch_row() - Returns the next row from a query as a numeric array
  • oci_set_prefetch() - Sets number of rows to be prefetched by queries

oci_execute
oci_fetch_array
OCI8 İşlevleri


Returns the next row from a query as an associative or numeric array

oci_fetch_all
oci_fetch_assoc
OCI8 İşlevleri
PHP Manual

oci_fetch_array

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

oci_fetch_array — Returns the next row from a query as an associative or numeric array

Açıklama

array oci_fetch_array ( resource $statement [, int $mode ] )

Returns an array containing the next result-set row of a query. Each array entry corresponds to a column of the row. This function is typically called in a loop until it returns FALSE, indicating no more rows exist.

If statement corresponds to a PL/SQL block returning Oracle Database 12c Implicit Result Sets, then rows from all sets are consecutively fetched. If statement is returned by oci_get_implicit_resultset(), then only the subset of rows for one child query are returned.

OCI8 sürücüsü tarafından yapılan veri türü eşlemeyle ilgili ayrıntılar için sürücü tarafından desteklenen veri türleri bölümüne bakınız.

Değiştirgeler

statement

A valid OCI8 statement identifier created by oci_parse() and executed by oci_execute(), or a REF CURSOR statement identifier.

Can also be a statement identifier returned by oci_get_implicit_resultset().

mode

An optional second parameter can be any combination of the following constants:

oci_fetch_array() Modes
Constant | Description
OCI_BOTH | Returns an array with both associative and numeric indices. This is the same as OCI_ASSOC + OCI_NUM and is the default behavior.
OCI_ASSOC | Returns an associative array.
OCI_NUM | Returns a numeric array.
OCI_RETURN_NULLS | Creates elements for NULL fields. The element values will be a PHP NULL.
OCI_RETURN_LOBS | Returns the contents of LOBs instead of the LOB descriptors.

The default mode is OCI_BOTH.

Use the addition operator "+" to specify more than one mode at a time.

Dönen Değerler

Returns an array with associative and/or numeric indices. If there are no more rows in the statement then FALSE is returned.

By default, LOB columns are returned as LOB descriptors.

DATE columns are returned as strings formatted to the current date format. The default format can be changed with Oracle environment variables such as NLS_LANG or by a previously executed ALTER SESSION SET NLS_DATE_FORMAT command.

Oracle's default, non-case sensitive column names will have uppercase associative indices in the result array. Case-sensitive column names will have array indices using the exact column case. Use var_dump() on the result array to verify the appropriate case to use for each query.

The table name is not included in the array index. If your query contains two different columns with the same name, use OCI_NUM or add a column alias to the query to ensure name uniqueness, see example #7. Otherwise only one column will be returned via PHP.

Örnekler

Örnek 1 oci_fetch_array() with OCI_BOTH

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT department_id, department_name FROM departments');
oci_execute($stid);

while (($row = oci_fetch_array($stid, OCI_BOTH)) != false) {
    // Use the uppercase column names for the associative array indices
    echo $row[0] . " and " . $row['DEPARTMENT_ID']   . " are the same<br>\n";
    echo $row[1] . " and " . $row['DEPARTMENT_NAME'] . " are the same<br>\n";
}

oci_free_statement($stid);
oci_close($conn);

?>

Örnek 2 oci_fetch_array() with OCI_NUM

<?php

/*
  Before running, create the table:
      CREATE TABLE mytab (id NUMBER, description CLOB);
      INSERT INTO mytab (id, description) values (1, 'A very long string');
      COMMIT;
*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT id, description FROM mytab');
oci_execute($stid);

while (($row = oci_fetch_array($stid, OCI_NUM)) != false) {
    echo $row[0] . "<br>\n";
    echo $row[1]->read(11) . "<br>\n"; // this will output first 11 bytes from DESCRIPTION
}

// Output is:
//    1
//    A very long

oci_free_statement($stid);
oci_close($conn);

?>

Örnek 3 oci_fetch_array() with OCI_ASSOC

<?php

/*
  Before running, create the table:
      CREATE TABLE mytab (id NUMBER, description CLOB);
      INSERT INTO mytab (id, description) values (1, 'A very long string');
      COMMIT;
*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT id, description FROM mytab');
oci_execute($stid);

while (($row = oci_fetch_array($stid, OCI_ASSOC)) != false) {
    echo $row['ID'] . "<br>\n";
    echo $row['DESCRIPTION']->read(11) . "<br>\n"; // this will output first 11 bytes from DESCRIPTION
}

// Output is:
//    1
//    A very long

oci_free_statement($stid);
oci_close($conn);

?>

Örnek 4 oci_fetch_array() with OCI_RETURN_NULLS

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT 1, null FROM dual');
oci_execute($stid);
while (($row = oci_fetch_array ($stid, OCI_ASSOC)) != false) { // Ignore NULLs
    var_dump($row);
}

/*
The above code prints:
  array(1) {
    [1]=>
    string(1) "1"
  }
*/

$stid = oci_parse($conn, 'SELECT 1, null FROM dual');
oci_execute($stid);
while (($row = oci_fetch_array ($stid, OCI_ASSOC+OCI_RETURN_NULLS)) != false) { // Fetch NULLs
    var_dump($row);
}

/*
The above code prints:
  array(2) {
    [1]=>
    string(1) "1"
    ["NULL"]=>
    NULL
  }
*/

?>

Örnek 5 oci_fetch_array() with OCI_RETURN_LOBS

<?php

/*
  Before running, create the table:
      CREATE TABLE mytab (id NUMBER, description CLOB);
      INSERT INTO mytab (id, description) values (1, 'A very long string');
      COMMIT;
*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT id, description FROM mytab');
oci_execute($stid);

while (($row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_LOBS)) != false) {
    echo $row['ID'] . "<br>\n";
    echo $row['DESCRIPTION'] . "<br>\n"; // this contains all of DESCRIPTION
    // In a loop, freeing the large variable before the 2nd fetch reduces PHP's peak memory usage
    unset($row);
}

// Output is:
//    1
//    A very long string

oci_free_statement($stid);
oci_close($conn);

?>

Örnek 6 oci_fetch_array() with case sensitive column names

<?php

/*
   Before running, create the table:
      CREATE TABLE mytab ("Name" VARCHAR2(20), city VARCHAR2(20));
      INSERT INTO mytab ("Name", city) values ('Chris', 'Melbourne');
      COMMIT;
*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'select * from mytab');
oci_execute($stid);
$row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_NULLS);

// Because 'Name' was created as a case-sensitive column, that same
// case is used for the array index.  However uppercase 'CITY' must
// be used for the case-insensitive column index
print $row['Name'] . "<br>\n";   //  prints Chris
print $row['CITY'] . "<br>\n";   //  prints Melbourne

oci_free_statement($stid);
oci_close($conn);

?>

Örnek 7 oci_fetch_array() with columns having duplicate names

<?php

/*
  Before running, create the tables:
      CREATE TABLE mycity (id NUMBER, name VARCHAR2(20));
      INSERT INTO mycity (id, name) values (1, 'Melbourne');
      CREATE TABLE mycountry (id NUMBER, name VARCHAR2(20));
      INSERT INTO mycountry (id, name) values (1, 'Australia');
      COMMIT;
*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$sql = 'SELECT mycity.name, mycountry.name
        FROM mycity, mycountry
        WHERE mycity.id = mycountry.id';
$stid = oci_parse($conn, $sql);
oci_execute($stid);
$row = oci_fetch_array($stid, OCI_ASSOC);
var_dump($row);

// Output only contains one "NAME" entry:
//    array(1) {
//      ["NAME"]=>
//      string(9) "Australia"
//    }

// To query a repeated column name, use an SQL column alias like "AS ctnm":
$sql = 'SELECT mycity.name AS ctnm, mycountry.name
        FROM mycity, mycountry
        WHERE mycity.id = mycountry.id';
$stid = oci_parse($conn, $sql);
oci_execute($stid);
$row = oci_fetch_array($stid, OCI_ASSOC);
var_dump($row);

// Output now contains both columns selected:
//    array(2) {
//      ["CTNM"]=>
//      string(9) "Melbourne"
//      ["NAME"]=>
//      string(9) "Australia"
//    }

oci_free_statement($stid);
oci_close($conn);

?>

Örnek 8 oci_fetch_array() with DATE columns

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

// Set the date format for this connection.
// For performance reasons, consider changing the format
// in a trigger or with environment variables instead
$stid = oci_parse($conn, "ALTER SESSION SET NLS_DATE_FORMAT = 'YYYY-MM-DD'");
oci_execute($stid);

$stid = oci_parse($conn, 'SELECT hire_date FROM employees WHERE employee_id = 188');
oci_execute($stid);
$row = oci_fetch_array($stid, OCI_ASSOC);
echo $row['HIRE_DATE'] . "<br>\n";  // prints 1997-06-14

oci_free_statement($stid);
oci_close($conn);

?>

Örnek 9 oci_fetch_array() with REF CURSOR

<?php
/*
  Create the PL/SQL stored procedure as:

  CREATE OR REPLACE PROCEDURE myproc(p1 OUT SYS_REFCURSOR) AS
  BEGIN
    OPEN p1 FOR SELECT * FROM all_objects WHERE ROWNUM < 5000;
  END;
*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'BEGIN myproc(:rc); END;');
$refcur = oci_new_cursor($conn);
oci_bind_by_name($stid, ':rc', $refcur, -1, OCI_B_CURSOR);
oci_execute($stid);

// Execute the returned REF CURSOR and fetch from it like a statement identifier
oci_execute($refcur);
echo "<table border='1'>\n";
while (($row = oci_fetch_array($refcur, OCI_ASSOC+OCI_RETURN_NULLS)) != false) {
    echo "<tr>\n";
    foreach ($row as $item) {
        echo "    <td>".($item !== null ? htmlentities($item, ENT_QUOTES) : "&nbsp;")."</td>\n";
    }
    echo "</tr>\n";
}
echo "</table>\n";

oci_free_statement($refcur);
oci_free_statement($stid);
oci_close($conn);

?>

Örnek 10 Pagination with oci_fetch_array() using a LIMIT-like query

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

// Find the version of the database
preg_match('/Release ([0-9]+)\./', oci_server_version($conn), $matches);
$oracleversion = $matches[1];

// This is the query you want to "page" through
$sql = 'SELECT city, postal_code FROM locations ORDER BY city';

if ($oracleversion >= 12) {
    // Make use of Oracle 12c OFFSET / FETCH NEXT syntax
    $sql = $sql . ' OFFSET :offset ROWS FETCH NEXT :numrows ROWS ONLY';
} else {
    // Older Oracle versions need a nested query selecting a subset
    // from $sql.  Or, if the SQL statement is known at development
    // time, consider using a row_number() function instead of this
    // nested solution.  In production environments, be careful to
    // avoid SQL Injection issues with concatenation.
    $sql = "SELECT * FROM (SELECT a.*, ROWNUM AS my_rnum
                           FROM ($sql) a
                           WHERE ROWNUM <= :offset + :numrows)
            WHERE my_rnum > :offset";
}

$offset  = 0;  // skip this many rows
$numrows = 5;  // return 5 rows
$stid = oci_parse($conn, $sql);
oci_bind_by_name($stid, ':numrows', $numrows);
oci_bind_by_name($stid, ':offset', $offset);
oci_execute($stid);

while (($row = oci_fetch_array($stid, OCI_ASSOC + OCI_RETURN_NULLS)) != false) {
    echo $row['CITY'] . " " . $row['POSTAL_CODE'] . "<br>\n";
}

// Output is:
//    Beijing 190518
//    Bern 3095
//    Bombay 490231
//    Geneva 1730
//    Hiroshima 6823

oci_free_statement($stid);
oci_close($conn);

?>

Örnek 11 oci_fetch_array() with Oracle Database 12c Implicit Result Sets

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/pdborcl');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

// Requires OCI8 2.0 and Oracle Database 12c
// Also see oci_get_implicit_resultset()
$sql = 'DECLARE
           c1 SYS_REFCURSOR;
        BEGIN
           OPEN c1 FOR SELECT city, postal_code FROM locations WHERE ROWNUM < 4 ORDER BY city;
           DBMS_SQL.RETURN_RESULT(c1);
           OPEN c1 FOR SELECT country_id FROM locations WHERE ROWNUM < 4 ORDER BY city;
           DBMS_SQL.RETURN_RESULT(c1);
        END;';

$stid = oci_parse($conn, $sql);
oci_execute($stid);

// Note: oci_fetch_all and oci_fetch() cannot be used in this manner
echo "<table>\n";
while (($row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_NULLS)) != false) {
    echo "<tr>\n";
    foreach ($row as $item) {
        echo "  <td>".($item!==null?htmlentities($item, ENT_QUOTES|ENT_SUBSTITUTE):"&nbsp;")."</td>\n";
    }
    echo "</tr>\n";
}
echo "</table>\n";

// Output is:
//    Beijing 190518
//    Bern    3095
//    Bombay  490231
//    CN
//    CH
//    IN

oci_free_statement($stid);
oci_close($conn);

?>

Notlar

Bilginize:

Associative array indices need to be in uppercase for standard Oracle columns that were created with case insensitive names.

Bilginize:

For queries returning a large number of rows, performance can be significantly improved by increasing oci8.default_prefetch or using oci_set_prefetch().

Bilginize:

The function oci_fetch_array() is insignificantly slower than oci_fetch_assoc() or oci_fetch_row(), but is more flexible.

Ayrıca Bakınız

  • oci_fetch() - Fetches the next row from a query into internal buffers
  • oci_fetch_all() - Fetches multiple rows from a query into a two-dimensional array
  • oci_fetch_assoc() - Returns the next row from a query as an associative array
  • oci_fetch_object() - Returns the next row from a query as an object
  • oci_fetch_row() - Returns the next row from a query as a numeric array
  • oci_set_prefetch() - Sets number of rows to be prefetched by queries

oci_fetch_all
oci_fetch_assoc
OCI8 İşlevleri


Returns the next row from a query as an associative array

oci_fetch_array
oci_fetch_object
OCI8 İşlevleri
PHP Manual

oci_fetch_assoc

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

oci_fetch_assoc — Returns the next row from a query as an associative array

Açıklama

array oci_fetch_assoc ( resource $statement )

Returns an associative array containing the next result-set row of a query. Each array entry corresponds to a column of the row. This function is typically called in a loop until it returns FALSE, indicating no more rows exist.

Calling oci_fetch_assoc() is identical to calling oci_fetch_array() with OCI_ASSOC + OCI_RETURN_NULLS.

Değiştirgeler

statement

A valid OCI8 statement identifier created by oci_parse() and executed by oci_execute(), or a REF CURSOR statement identifier.

Dönen Değerler

Returns an associative array. If there are no more rows in the statement then FALSE is returned.

Örnekler

Örnek 1 oci_fetch_assoc() Example

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT department_id, department_name FROM departments');
oci_execute($stid);

while (($row = oci_fetch_assoc($stid)) != false) {
    echo $row['DEPARTMENT_ID'] . " " . $row['DEPARTMENT_NAME'] . "<br>\n";
}

oci_free_statement($stid);
oci_close($conn);

?>

Notlar

Bilginize:

See oci_fetch_array() for more examples of fetching rows.

Ayrıca Bakınız

  • oci_fetch() - Fetches the next row from a query into internal buffers
  • oci_fetch_all() - Fetches multiple rows from a query into a two-dimensional array
  • oci_fetch_array() - Returns the next row from a query as an associative or numeric array
  • oci_fetch_object() - Returns the next row from a query as an object
  • oci_fetch_row() - Returns the next row from a query as a numeric array

oci_fetch_array
oci_fetch_object
OCI8 İşlevleri


Returns the next row from a query as an object

oci_fetch_assoc
oci_fetch_row
OCI8 İşlevleri
PHP Manual

oci_fetch_object

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

oci_fetch_object — Returns the next row from a query as an object

Açıklama

object oci_fetch_object ( resource $statement )

Returns an object containing the next result-set row of a query. Each attribute of the object corresponds to a column of the row. This function is typically called in a loop until it returns FALSE, indicating no more rows exist.

OCI8 sürücüsü tarafından yapılan veri türü eşlemeyle ilgili ayrıntılar için sürücü tarafından desteklenen veri türleri bölümüne bakınız.

Değiştirgeler

statement

A valid OCI8 statement identifier created by oci_parse() and executed by oci_execute(), or a REF CURSOR statement identifier.

Dönen Değerler

Returns an object. Each attribute of the object corresponds to a column of the row. If there are no more rows in the statement then FALSE is returned.

Any LOB columns are returned as LOB descriptors.

DATE columns are returned as strings formatted to the current date format. The default format can be changed with Oracle environment variables such as NLS_LANG or by a previously executed ALTER SESSION SET NLS_DATE_FORMAT command.

Oracle's default, non-case sensitive column names will have uppercase attribute names. Case-sensitive column names will have attribute names using the exact column case. Use var_dump() on the result object to verify the appropriate case for attribute access.

Attribute values will be NULL for any NULL data fields.

Örnekler

Örnek 1 oci_fetch_object() example

<?php

/*
  Before running, create the table:
    CREATE TABLE mytab (id NUMBER, description VARCHAR2(30));
    INSERT INTO mytab (id, description) values (1, 'Fish and Chips');
    COMMIT;
*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT id, description FROM mytab');
oci_execute($stid);

while (($row = oci_fetch_object($stid)) != false) {
    // Use upper case attribute names for each standard Oracle column
    echo $row->ID . "<br>\n";
    echo $row->DESCRIPTION . "<br>\n";
}

// Output is:
//    1
//    Fish and Chips

oci_free_statement($stid);
oci_close($conn);

?>

Örnek 2 oci_fetch_object() with case sensitive column names

<?php

/*
  Before running, create the table with a case sensitive column name:
    CREATE TABLE mytab (id NUMBER, "MyDescription" VARCHAR2(30));
    INSERT INTO mytab (id, "MyDescription") values (1, 'Iced Coffee');
    COMMIT;
*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT id, "MyDescription" FROM mytab');
oci_execute($stid);

while (($row = oci_fetch_object($stid)) != false) {
    // Use upper case attribute names for each standard Oracle column
    echo $row->ID . "<br>\n";
    // Use the exact case for the case sensitive column name
    echo $row->MyDescription . "<br>\n";
}

// Output is:
//    1
//    Iced Coffee

oci_free_statement($stid);
oci_close($conn);

?>

Örnek 3 oci_fetch_object() with LOBs

<?php

/*
  Before running, create the table:
    CREATE TABLE mytab (id NUMBER, description CLOB);
    INSERT INTO mytab (id, description) values (1, 'A very long string');
    COMMIT;
*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT id, description FROM mytab');
oci_execute($stid);

while (($row = oci_fetch_object($stid)) != false) {
    echo $row->ID . "<br>\n";
    // The following will output the first 11 bytes from DESCRIPTION
    echo $row->DESCRIPTION->read(11) . "<br>\n";
}

// Output is:
//    1
//    A very long

oci_free_statement($stid);
oci_close($conn);

?>

Ayrıca Bakınız

  • oci_fetch() - Fetches the next row from a query into internal buffers
  • oci_fetch_all() - Fetches multiple rows from a query into a two-dimensional array
  • oci_fetch_assoc() - Returns the next row from a query as an associative array
  • oci_fetch_array() - Returns the next row from a query as an associative or numeric array
  • oci_fetch_row() - Returns the next row from a query as a numeric array

oci_fetch_assoc
oci_fetch_row
OCI8 İşlevleri


Returns the next row from a query as a numeric array

oci_fetch_object
oci_fetch
OCI8 İşlevleri
PHP Manual

oci_fetch_row

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

oci_fetch_row — Returns the next row from a query as a numeric array

Açıklama

array oci_fetch_row ( resource $statement )

Returns a numerically indexed array containing the next result-set row of a query. Each array entry corresponds to a column of the row. This function is typically called in a loop until it returns FALSE, indicating no more rows exist.

Calling oci_fetch_row() is identical to calling oci_fetch_array() with OCI_NUM + OCI_RETURN_NULLS.

Değiştirgeler

statement

A valid OCI8 statement identifier created by oci_parse() and executed by oci_execute(), or a REF CURSOR statement identifier.

Dönen Değerler

Returns a numerically indexed array. If there are no more rows in the statement then FALSE is returned.

Örnekler

Örnek 1 oci_fetch_row() Example

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT department_id, department_name FROM departments');
oci_execute($stid);

while (($row = oci_fetch_row($stid)) != false) {
    echo $row[0] . " " . $row[1] . "<br>\n";
}

oci_free_statement($stid);
oci_close($conn);

?>

Notlar

Bilginize:

See oci_fetch_array() for more examples of fetching rows.

Ayrıca Bakınız

  • oci_fetch() - Fetches the next row from a query into internal buffers
  • oci_fetch_all() - Fetches multiple rows from a query into a two-dimensional array
  • oci_fetch_array() - Returns the next row from a query as an associative or numeric array
  • oci_fetch_assoc() - Returns the next row from a query as an associative array
  • oci_fetch_object() - Returns the next row from a query as an object

oci_fetch_object
oci_fetch
OCI8 İşlevleri


Fetches the next row from a query into internal buffers

oci_fetch_row
oci_field_is_null
OCI8 İşlevleri
PHP Manual

oci_fetch

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

oci_fetch — Fetches the next row from a query into internal buffers

Açıklama

bool oci_fetch ( resource $statement )

Fetches the next row from a query into internal buffers accessible either with oci_result(), or by using variables previously defined with oci_define_by_name().

See oci_fetch_array() for general information about fetching data.

Değiştirgeler

statement

A valid OCI8 statement identifier created by oci_parse() and executed by oci_execute(), or a REF CURSOR statement identifier.

Dönen Değerler

Returns TRUE on success or FALSE if there are no more rows in the statement.

Örnekler

Örnek 1 oci_fetch() with defined variables

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$sql = 'SELECT location_id, city FROM locations WHERE location_id < 1200';
$stid = oci_parse($conn, $sql);

// The defines MUST be done before executing
oci_define_by_name($stid, 'LOCATION_ID', $locid);
oci_define_by_name($stid, 'CITY', $city);

oci_execute($stid);

// Each fetch populates the previously defined variables with the next row's data
while (oci_fetch($stid)) {
    echo "Location id $locid is $city<br>\n";
}

// Displays:
//   Location id 1000 is Roma
//   Location id 1100 is Venice

oci_free_statement($stid);
oci_close($conn);

?>

Örnek 2 oci_fetch() with oci_result()

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$sql = 'SELECT location_id, city FROM locations WHERE location_id < 1200';
$stid = oci_parse($conn, $sql);
oci_execute($stid);

while (oci_fetch($stid)) {
    echo oci_result($stid, 'LOCATION_ID') . " is ";
    echo oci_result($stid, 'CITY') . "<br>\n";
}

// Displays:
//   1000 is Roma
//   1100 is Venice

oci_free_statement($stid);
oci_close($conn);

?>

Notlar

Bilginize:

Will not return rows from Oracle Database 12c Implicit Result Sets. Use oci_fetch_array() instead.

Ayrıca Bakınız

  • oci_define_by_name() - Associates a PHP variable with a column for query fetches
  • oci_fetch_all() - Fetches multiple rows from a query into a two-dimensional array
  • oci_fetch_array() - Returns the next row from a query as an associative or numeric array
  • oci_fetch_assoc() - Returns the next row from a query as an associative array
  • oci_fetch_object() - Returns the next row from a query as an object
  • oci_fetch_row() - Returns the next row from a query as a numeric array
  • oci_result() - Returns field's value from the fetched row

oci_fetch_row
oci_field_is_null
OCI8 İşlevleri


Checks if a field in the currently fetched row is NULL

oci_fetch
oci_field_name
OCI8 İşlevleri
PHP Manual

oci_field_is_null

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

oci_field_is_null — Checks if a field in the currently fetched row is NULL

Açıklama

bool oci_field_is_null ( resource $statement , mixed $field )

Checks if the given field from the current row of statement is NULL.

Değiştirgeler

statement

A valid OCI statement identifier.

field

Can be the field's index (1-based) or name.

Dönen Değerler

Returns TRUE if field is NULL, FALSE otherwise.

Örnekler

Örnek 1 oci_field_name() example

<?php

// Create the table with:
//   CREATE TABLE mytab (c1 NUMBER);
//   INSERT INTO mytab VALUES (1);
//   INSERT INTO mytab VALUES (NULL);

$conn = oci_connect("hr", "hrpwd", "localhost/XE");
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$stid = oci_parse($conn, "SELECT * FROM mytab");
oci_execute($stid);

while (($row = oci_fetch_array($stid, OCI_RETURN_NULLS)) != false) {
    $ncols = oci_num_fields($stid);
    for ($col = 1; $col <= $ncols; $col++) {
        var_dump(oci_field_is_null($stid, $col));
    }
}

// Outputs:
//    bool(false)
//    bool(true)

oci_free_statement($stid);
oci_close($conn);

?>

Notlar

Bilginize:

In PHP versions before 5.0.0 you must use ocicolumnisnull() instead. This name still can be used, it was left as alias of oci_field_is_null() for downwards compatability. This, however, is deprecated and not recommended.

oci_fetch
oci_field_name
OCI8 İşlevleri


Returns the name of a field from the statement

oci_field_is_null
oci_field_precision
OCI8 İşlevleri
PHP Manual

oci_field_name

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

oci_field_name — Returns the name of a field from the statement

Açıklama

string oci_field_name ( resource $statement , mixed $field )

Returns the name of the field.

Değiştirgeler

statement

A valid OCI statement identifier.

field

Can be the field's index (1-based) or name.

Dönen Değerler

Returns the name as a string, or FALSE on errors.

Örnekler

Örnek 1 oci_field_name() example

<?php

// Create the table with:
//   CREATE TABLE mytab (number_col NUMBER, varchar2_col varchar2(1),
//                       clob_col CLOB, date_col DATE);

$conn = oci_connect("hr", "hrpwd", "localhost/XE");
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$stid = oci_parse($conn, "SELECT * FROM mytab");
oci_execute($stid, OCI_DESCRIBE_ONLY); // Use OCI_DESCRIBE_ONLY if not fetching rows

echo "<table border=\"1\">\n";
echo "<tr>";
echo "<th>Name</th>";
echo "<th>Type</th>";
echo "<th>Length</th>";
echo "</tr>\n";

$ncols = oci_num_fields($stid);

for ($i = 1; $i <= $ncols; $i++) {
    $column_name  = oci_field_name($stid, $i);
    $column_type  = oci_field_type($stid, $i);

    echo "<tr>";
    echo "<td>$column_name</td>";
    echo "<td>$column_type</td>";
    echo "</tr>\n";
}

echo "</table>\n";

// Outputs:
//    Name           Type
//    NUMBER_COL    NUMBER
//    VARCHAR2_COL  VARCHAR2
//    CLOB_COL      CLOB
//    DATE_COL      DATE

oci_free_statement($stid);
oci_close($conn);

?>

Notlar

Bilginize:

In PHP versions before 5.0.0 you must use ocicolumnname() instead. This name still can be used, it was left as alias of oci_field_name() for downwards compatability. This, however, is deprecated and not recommended.

Ayrıca Bakınız

  • oci_num_fields() - Returns the number of result columns in a statement
  • oci_field_type() - Returns a field's data type name
  • oci_field_size() - Returns field's size

oci_field_is_null
oci_field_precision
OCI8 İşlevleri


Tell the precision of a field

oci_field_name
oci_field_scale
OCI8 İşlevleri
PHP Manual

oci_field_precision

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

oci_field_precision — Tell the precision of a field

Açıklama

int oci_field_precision ( resource $statement , mixed $field )

Returns precision of the field.

For FLOAT columns, precision is nonzero and scale is -127. If precision is 0, then column is NUMBER. Else it's NUMBER(precision, scale).

Değiştirgeler

statement

A valid OCI statement identifier.

field

Can be the field's index (1-based) or name.

Dönen Değerler

Returns the precision as an integer, or FALSE on errors.

Örnekler

Örnek 1 oci_field_precision() Example

<?php

// Create the table with:
//   CREATE TABLE mytab (c1 NUMBER, c2 FLOAT, c3 NUMBER(4), c4 NUMBER(5,3));

$conn = oci_connect("hr", "hrpwd", "localhost/XE");
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$stid = oci_parse($conn, "SELECT * FROM mytab");
oci_execute($stid, OCI_DESCRIBE_ONLY); // Use OCI_DESCRIBE_ONLY if not fetching rows

$ncols = oci_num_fields($stid);
for ($i = 1; $i <= $ncols; $i++) {
    echo oci_field_name($stid, $i) . " "
        . oci_field_precision($stid, $i) . " "
        . oci_field_scale($stid, $i) . "<br>\n";
}

// Outputs:
//   C1    0 -127
//   C2  126 -127
//   C3    4    0
//   C4    5    3

oci_free_statement($stid);
oci_close($conn);

?>

Notlar

Bilginize:

In PHP versions before 5.0.0 you must use ocicolumnprecision() instead. This name still can be used, it was left as alias of oci_field_precision() for downwards compatability. This, however, is deprecated and not recommended.

Ayrıca Bakınız

  • oci_field_scale() - Tell the scale of the field
  • oci_field_type() - Returns a field's data type name

oci_field_name
oci_field_scale
OCI8 İşlevleri


Tell the scale of the field

oci_field_precision
oci_field_size
OCI8 İşlevleri
PHP Manual

oci_field_scale

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

oci_field_scale — Tell the scale of the field

Açıklama

int oci_field_scale ( resource $statement , mixed $field )

Returns the scale of the column with field index.

For FLOAT columns, precision is nonzero and scale is -127. If precision is 0, then column is NUMBER. Else it's NUMBER(precision, scale).

Değiştirgeler

statement

A valid OCI statement identifier.

field

Can be the field's index (1-based) or name.

Dönen Değerler

Returns the scale as an integer, or FALSE on errors.

Örnekler

Örnek 1 oci_field_scale() Example

<?php

// Create the table with:
//   CREATE TABLE mytab (c1 NUMBER, c2 FLOAT, c3 NUMBER(4), c4 NUMBER(5,3));

$conn = oci_connect("hr", "hrpwd", "localhost/XE");
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$stid = oci_parse($conn, "SELECT * FROM mytab");
oci_execute($stid, OCI_DESCRIBE_ONLY); // Use OCI_DESCRIBE_ONLY if not fetching rows

$ncols = oci_num_fields($stid);
for ($i = 1; $i <= $ncols; $i++) {
    echo oci_field_name($stid, $i) . " "
        . oci_field_precision($stid, $i) . " "
        . oci_field_scale($stid, $i) . "<br>\n";
}

// Outputs:
//   C1    0 -127
//   C2  126 -127
//   C3    4    0
//   C4    5    3

oci_free_statement($stid);
oci_close($conn);

?>

Notlar

Bilginize:

In PHP versions before 5.0.0 you must use ocicolumnscale() instead. This name still can be used, it was left as alias of oci_field_scale() for downwards compatability. This, however, is deprecated and not recommended.

Ayrıca Bakınız

  • oci_field_precision() - Tell the precision of a field
  • oci_field_type() - Returns a field's data type name

oci_field_precision
oci_field_size
OCI8 İşlevleri


Returns field's size

oci_field_scale
oci_field_type_raw
OCI8 İşlevleri
PHP Manual

oci_field_size

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

oci_field_size — Returns field's size

Açıklama

int oci_field_size ( resource $statement , mixed $field )

Returns the size of a field.

Değiştirgeler

statement

A valid OCI statement identifier.

field

Can be the field's index (1-based) or name.

Dönen Değerler

Returns the size of a field in bytes, or FALSE on errors.

Örnekler

Örnek 1 oci_field_size() example

<?php

// Create the table with:
//   CREATE TABLE mytab (number_col NUMBER, varchar2_col varchar2(1),
//                       clob_col CLOB, date_col DATE);

$conn = oci_connect("hr", "hrpwd", "localhost/XE");
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$stid = oci_parse($conn, "SELECT * FROM mytab");
oci_execute($stid, OCI_DESCRIBE_ONLY); // Use OCI_DESCRIBE_ONLY if not fetching rows

echo "<table border=\"1\">\n";
echo "<tr>";
echo "<th>Name</th>";
echo "<th>Type</th>";
echo "<th>Length</th>";
echo "</tr>\n";

$ncols = oci_num_fields($stid);

for ($i = 1; $i <= $ncols; $i++) {
    $column_name  = oci_field_name($stid, $i);
    $column_type  = oci_field_type($stid, $i);
    $column_size  = oci_field_size($stid, $i);

    echo "<tr>";
    echo "<td>$column_name</td>";
    echo "<td>$column_type</td>";
    echo "<td>$column_size</td>";
    echo "</tr>\n";
}

echo "</table>\n";

// Outputs:
//    Name           Type       Length
//    NUMBER_COL    NUMBER        22
//    VARCHAR2_COL  VARCHAR2       1
//    CLOB_COL      CLOB        4000
//    DATE_COL      DATE           7

oci_free_statement($stid);
oci_close($conn);

?>

Notlar

Bilginize:

In PHP versions before 5.0.0 you must use ocicolumnsize() instead. This name still can be used, it was left as alias of oci_field_size() for downwards compatability. This, however, is deprecated and not recommended.

Ayrıca Bakınız

  • oci_num_fields() - Returns the number of result columns in a statement
  • oci_field_name() - Returns the name of a field from the statement

oci_field_scale
oci_field_type_raw
OCI8 İşlevleri


Tell the raw Oracle data type of the field

oci_field_size
oci_field_type
OCI8 İşlevleri
PHP Manual

oci_field_type_raw

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

oci_field_type_raw — Tell the raw Oracle data type of the field

Açıklama

int oci_field_type_raw ( resource $statement , mixed $field )

Returns Oracle's raw "SQLT" data type of the field.

If you want a field's type name, then use oci_field_type() instead.

Değiştirgeler

statement

A valid OCI statement identifier.

field

Can be the field's index (1-based) or name.

Dönen Değerler

Returns Oracle's raw data type as a number, or FALSE on errors.

Örnekler

Örnek 1 oci_field_type_raw() Example

<?php

// Create the table with:
//   CREATE TABLE mytab (number_col NUMBER, varchar2_col varchar2(1), clob_col CLOB, date_col DATE);

$conn = oci_connect("hr", "hrpwd", "localhost/XE");
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$stid = oci_parse($conn, 'select * from mytab');
oci_execute($stid, OCI_DESCRIBE_ONLY);  // Use OCI_DESCRIBE_ONLY if not fetching rows
$n = oci_num_fields($stid);
for ($i = 1; $i <= $n; ++$i) {
    echo oci_field_name($stid, $i) . " is raw type: " . oci_field_type_raw($stid, $i) . "<br>\n";
}

// Output is:
//    NUMBER_COL is raw type: 2
//    VARCHAR2_COL is raw type: 1
//    CLOB_COL is raw type: 112
//    DATE_COL is raw type: 12

oci_free_statement($stid);
oci_close($conn);

?>

Notlar

Bilginize:

In PHP versions before 5.0.0 you must use ocicolumntyperaw() instead. This name still can be used, it was left as alias of oci_field_type_raw() for downwards compatability. This, however, is deprecated and not recommended.

oci_field_size
oci_field_type
OCI8 İşlevleri


Returns a field's data type name

oci_field_type_raw
oci_free_descriptor
OCI8 İşlevleri
PHP Manual

oci_field_type

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

oci_field_type — Returns a field's data type name

Açıklama

mixed oci_field_type ( resource $statement , mixed $field )

Returns a field's data type name.

Değiştirgeler

statement

A valid OCI statement identifier.

field

Can be the field's index (1-based) or name.

Dönen Değerler

Returns the field data type as a string, or FALSE on errors.

Örnekler

Örnek 1 oci_field_type() example

<?php

// Create the table with:
//   CREATE TABLE mytab (number_col NUMBER, varchar2_col varchar2(1),
//                       clob_col CLOB, date_col DATE);

$conn = oci_connect("hr", "hrpwd", "localhost/XE");
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$stid = oci_parse($conn, "SELECT * FROM mytab");
oci_execute($stid, OCI_DESCRIBE_ONLY); // Use OCI_DESCRIBE_ONLY if not fetching rows

echo "<table border=\"1\">\n";
echo "<tr>";
echo "<th>Name</th>";
echo "<th>Type</th>";
echo "<th>Length</th>";
echo "</tr>\n";

$ncols = oci_num_fields($stid);

for ($i = 1; $i <= $ncols; $i++) {
    $column_name  = oci_field_name($stid, $i);
    $column_type  = oci_field_type($stid, $i);
    $column_size  = oci_field_size($stid, $i);

    echo "<tr>";
    echo "<td>$column_name</td>";
    echo "<td>$column_type</td>";
    echo "<td>$column_size</td>";
    echo "</tr>\n";
}

echo "</table>\n";

// Outputs:
//    Name           Type       Length
//    NUMBER_COL    NUMBER        22
//    VARCHAR2_COL  VARCHAR2       1
//    CLOB_COL      CLOB        4000
//    DATE_COL      DATE           7

oci_free_statement($stid);
oci_close($conn);

?>

Notlar

Bilginize:

In PHP versions before 5.0.0 you must use ocicolumntype() instead. This name still can be used, it was left as alias of oci_field_type() for downwards compatability. This, however, is deprecated and not recommended.

Ayrıca Bakınız

  • oci_num_fields() - Returns the number of result columns in a statement
  • oci_field_name() - Returns the name of a field from the statement
  • oci_field_size() - Returns field's size

oci_field_type_raw
oci_free_descriptor
OCI8 İşlevleri


Frees a descriptor

oci_field_type
oci_free_statement
OCI8 İşlevleri
PHP Manual

oci_free_descriptor

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

oci_free_descriptor — Frees a descriptor

Açıklama

bool oci_free_descriptor ( resource $descriptor )

Frees a descriptor allocated by oci_new_descriptor().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

Bilginize:

This function is commonly used as a method OCI-LOB::free.

Ayrıca Bakınız

  • OCI-LOB::free

oci_field_type
oci_free_statement
OCI8 İşlevleri


Frees all resources associated with statement or cursor

oci_free_descriptor
oci_get_implicit_resultset
OCI8 İşlevleri
PHP Manual

oci_free_statement

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

oci_free_statement — Frees all resources associated with statement or cursor

Açıklama

bool oci_free_statement ( resource $statement )

Frees resources associated with Oracle's cursor or statement, which was received from as a result of oci_parse() or obtained from Oracle.

Değiştirgeler

statement

A valid OCI statement identifier.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

oci_free_descriptor
oci_get_implicit_resultset
OCI8 İşlevleri


Returns the next child statement resource from a parent statement resource that has Oracle Database 12c Implicit Result Sets

oci_free_statement
oci_internal_debug
OCI8 İşlevleri
PHP Manual

oci_get_implicit_resultset

(PECL OCI8 >= 2.0.0)

oci_get_implicit_resultset — Returns the next child statement resource from a parent statement resource that has Oracle Database 12c Implicit Result Sets

Açıklama

resource oci_get_implicit_resultset ( resource $statement )

Used to fetch consectutive sets of query results after the execution of a stored or anonymous Oracle PL/SQL block where that block returns query results with Oracle's DBMS_SQL.RETURN_RESULT PL/SQL function. This allows PL/SQL blocks to easily return query results.

The child statement can be used with any of the OCI8 fetching
functions: oci_fetch(), oci_fetch_all(),
oci_fetch_array(), oci_fetch_object(),
oci_fetch_assoc() or oci_fetch_row()

Child statements inherit their parent statement's prefetch value, or it can be explicitly set with oci_set_prefetch().

Değiştirgeler

statement

A valid OCI8 statement identifier created by oci_parse() and executed by oci_execute(). The statement identifier may or may not be associated with a SQL statement that returns Implicit Result Sets.

Dönen Değerler

Returns a statement handle for the next child statement available on statement. Returns FALSE when child statements do not exist, or all child statements have been returned by previous calls to oci_get_implicit_resultset().

Örnekler

Örnek 1 Fetching Implicit Result Sets in a loop

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/pdborcl');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$sql = 'DECLARE
            c1 SYS_REFCURSOR;
        BEGIN
           OPEN c1 FOR SELECT city, postal_code FROM locations WHERE ROWNUM < 4 ORDER BY city;
           DBMS_SQL.RETURN_RESULT(c1);
           OPEN c1 FOR SELECT country_id FROM locations WHERE ROWNUM < 4 ORDER BY city;
           DBMS_SQL.RETURN_RESULT(c1);
        END;';

$stid = oci_parse($conn, $sql);
oci_execute($stid);

while (($stid_c = oci_get_implicit_resultset($stid))) {
    echo "<h2>New Implicit Result Set:</h2>\n";
    echo "<table>\n";
    while (($row = oci_fetch_array($stid_c, OCI_ASSOC+OCI_RETURN_NULLS)) != false) {
        echo "<tr>\n";
        foreach ($row as $item) {
            echo "  <td>".($item!==null?htmlentities($item, ENT_QUOTES|ENT_SUBSTITUTE):"&nbsp;")."</td>\n";
        }
        echo "</tr>\n";
    }
    echo "</table>\n";
}

// Output is:
//    New Implicit Result Set:
//     Beijing 190518
//     Bern    3095
//     Bombay  490231
//    New Implicit Result Set:
//     CN
//     CH
//     IN

oci_free_statement($stid);
oci_close($conn);

?>

Örnek 2 Getting child statement handles individually

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/pdborcl');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$sql = 'DECLARE
            c1 SYS_REFCURSOR;
        BEGIN
           OPEN c1 FOR SELECT city, postal_code FROM locations WHERE ROWNUM < 4 ORDER BY city;
           DBMS_SQL.RETURN_RESULT(c1);
           OPEN c1 FOR SELECT country_id FROM locations WHERE ROWNUM < 4 ORDER BY city;
           DBMS_SQL.RETURN_RESULT(c1);
        END;';

$stid = oci_parse($conn, $sql);
oci_execute($stid);

$stid_1 = oci_get_implicit_resultset($stid);
$stid_2 = oci_get_implicit_resultset($stid);

$row = oci_fetch_array($stid_1, OCI_ASSOC+OCI_RETURN_NULLS);
var_dump($row);
$row = oci_fetch_array($stid_2, OCI_ASSOC+OCI_RETURN_NULLS);
var_dump($row);
$row = oci_fetch_array($stid_1, OCI_ASSOC+OCI_RETURN_NULLS);
var_dump($row);
$row = oci_fetch_array($stid_2, OCI_ASSOC+OCI_RETURN_NULLS);
var_dump($row);

// Output is:
//    array(2) {
//      ["CITY"]=>
//      string(7) "Beijing"
//      ["POSTAL_CODE"]=>
//      string(6) "190518"
//    }
//    array(1) {
//      ["COUNTRY_ID"]=>
//      string(2) "CN"
//    }
//    array(2) {
//      ["CITY"]=>
//      string(4) "Bern"
//      ["POSTAL_CODE"]=>
//      string(4) "3095"
//    }
//    array(1) {
//      ["COUNTRY_ID"]=>
//      string(2) "CH"
//    }

oci_free_statement($stid);
oci_close($conn);

?>

Örnek 3 Explicitly setting the Prefetch Count

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/pdborcl');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$sql = 'DECLARE
            c1 SYS_REFCURSOR;
        BEGIN
           OPEN c1 FOR SELECT city, postal_code FROM locations ORDER BY city;
           DBMS_SQL.RETURN_RESULT(c1);
        END;';

$stid = oci_parse($conn, $sql);
oci_execute($stid);

$stid_c = oci_get_implicit_resultset($stid);
oci_set_prefetch($stid_c, 200);   // Set the prefetch before fetching from the child statement
echo "<table>\n";
while (($row = oci_fetch_array($stid_c, OCI_ASSOC+OCI_RETURN_NULLS)) != false) {
    echo "<tr>\n";
    foreach ($row as $item) {
        echo "  <td>".($item!==null?htmlentities($item, ENT_QUOTES|ENT_SUBSTITUTE):"&nbsp;")."</td>\n";
    }
    echo "</tr>\n";
}
echo "</table>\n";

oci_free_statement($stid);
oci_close($conn);

?>

Örnek 4 Implicit Result Set example without using oci_get_implicit_resultset()

All results from all queries are returned consecutively.

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/pdborcl');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$sql = 'DECLARE
            c1 SYS_REFCURSOR;
        BEGIN
           OPEN c1 FOR SELECT city, postal_code FROM locations WHERE ROWNUM < 4 ORDER BY city;
           DBMS_SQL.RETURN_RESULT(c1);
           OPEN c1 FOR SELECT country_id FROM locations WHERE ROWNUM < 4 ORDER BY city;
           DBMS_SQL.RETURN_RESULT(c1);
        END;';

$stid = oci_parse($conn, $sql);
oci_execute($stid);

// Note: oci_fetch_all and oci_fetch() cannot be used in this manner
echo "<table>\n";
while (($row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_NULLS)) != false) {
    echo "<tr>\n";
    foreach ($row as $item) {
        echo "  <td>".($item!==null?htmlentities($item, ENT_QUOTES|ENT_SUBSTITUTE):"&nbsp;")."</td>\n";
    }
    echo "</tr>\n";
}
echo "</table>\n";

// Output is:
//    Beijing 190518
//    Bern 3095
//    Bombay 490231
//    CN
//    CH
//    IN

oci_free_statement($stid);
oci_close($conn);

?>

Notlar

Bilginize:

For queries returning a large number of rows, performance can be significantly improved by increasing oci8.default_prefetch or using oci_set_prefetch().

oci_free_statement
oci_internal_debug
OCI8 İşlevleri


Enables or disables internal debug output

oci_get_implicit_resultset
oci_lob_copy
OCI8 İşlevleri
PHP Manual

oci_internal_debug

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

oci_internal_debug — Enables or disables internal debug output

Açıklama

void oci_internal_debug ( bool $onoff )

Enables or disables internal debug output.

Değiştirgeler

onoff

Set this to FALSE to turn debug output off or TRUE to turn it on.

Dönen Değerler

Hiçbir değer dönmez.

Notlar

Bilginize:

In PHP versions before 5.0.0 you must use ociinternaldebug() instead. This name still can be used, it was left as alias of oci_internal_debug() for downwards compatability. This, however, is deprecated and not recommended.

oci_get_implicit_resultset
oci_lob_copy
OCI8 İşlevleri


Copies large object

oci_internal_debug
oci_lob_is_equal
OCI8 İşlevleri
PHP Manual

oci_lob_copy

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

oci_lob_copy — Copies large object

Açıklama

bool oci_lob_copy ( OCI-Lob $lob_to , OCI-Lob $lob_from [, int $length = 0 ] )

Copies a large object or a part of a large object to another large object. Old LOB-recipient data will be overwritten.

If you need to copy a particular part of a LOB to a particular position of a LOB, use OCI-Lob::seek() to move LOB internal pointers.

Değiştirgeler

lob_to

The destination LOB.

lob_from

The copied LOB.

length

Indicates the length of data to be copied.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

oci_internal_debug
oci_lob_is_equal
OCI8 İşlevleri


Compares two LOB/FILE locators for equality

oci_lob_copy
oci_new_collection
OCI8 İşlevleri
PHP Manual

oci_lob_is_equal

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

oci_lob_is_equal — Compares two LOB/FILE locators for equality

Açıklama

bool oci_lob_is_equal ( OCI-Lob $lob1 , OCI-Lob $lob2 )

Compares two LOB/FILE locators.

Değiştirgeler

lob1

A LOB identifier.

lob2

A LOB identifier.

Dönen Değerler

Returns TRUE if these objects are equal, FALSE otherwise.

oci_lob_copy
oci_new_collection
OCI8 İşlevleri


Allocates new collection object

oci_lob_is_equal
oci_new_connect
OCI8 İşlevleri
PHP Manual

oci_new_collection

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

oci_new_collection — Allocates new collection object

Açıklama

OCI-Collection oci_new_collection ( resource $connection , string $tdo [, string $schema = NULL ] )

Allocates a new collection object.

Değiştirgeler

connection

An Oracle connection identifier, returned by oci_connect() or oci_pconnect().

tdo

Should be a valid named type (uppercase).

schema

Should point to the scheme, where the named type was created. The name of the current user is the default value.

Dönen Değerler

Returns a new OCICollection object or FALSE on error.

Notlar

Bilginize:

In PHP versions before 5.0.0 you must use ocinewcollection() instead. This name still can be used, it was left as alias of oci_new_collection() for downwards compatability. This, however, is deprecated and not recommended.

oci_lob_is_equal
oci_new_connect
OCI8 İşlevleri


Connect to the Oracle server using a unique connection

oci_new_collection
oci_new_cursor
OCI8 İşlevleri
PHP Manual

oci_new_connect

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

oci_new_connect — Connect to the Oracle server using a unique connection

Açıklama

resource oci_new_connect ( string $username , string $password [, string $connection_string [, string $character_set [, int $session_mode ]]] )

Establishes a new connection to an Oracle server and logs on.

Unlike oci_connect() and oci_pconnect(), oci_new_connect() does not cache connections and will always return a brand-new freshly opened connection handle. This is useful if your application needs transactional isolation between two sets of queries.

Değiştirgeler

username

The Oracle user name.

password

The password for username.

connection_string

Contains the Oracle instance to connect to. It can be an » Easy Connect string, or a Connect Name from the tnsnames.ora file, or the name of a local Oracle instance

If not specified, PHP uses environment variables such as TWO_TASK (on Linux) or LOCAL (on Windows) and ORACLE_SID to determine the Oracle instance to connect to.

To use the Easy Connect naming method, PHP must be linked with Oracle 10g or greater Client libraries. The Easy Connect string for Oracle 10g is of the form: 10g is of the form: [//]host_name[:port][/service_name]. With Oracle [//]host_name[:port][/service_name]. From Oracle 11g, the syntax is: 11g, the syntax is:[//]host_name[:port][/service_name][:server_type][/instance_name] . Service names can be found by running the Oracle utility lsnrctl status on the database server machine.

The tnsnames.ora file can be in the Oracle Net search path, which includes $ORACLE_HOME/network/admin and /etc. Alternatively set TNS_ADMIN so that $TNS_ADMIN/tnsnames.ora is read. Make sure the web daemon has read access to the file.

character_set

Oracle sunucusunun 9.2 ve üstü sürümlerini kullanırken, karakter_kümesi değiştirgesini yeni bağlantıda kullanılacak değiştirgeye göre belirtebilirsiniz. Eğer 9.2 sürümünden daha eski bir Oracle sunucusu kullanıyorsanız bu değiştirge yok sayılacak, yerine NLS_LANG ortam değişkeni kullanılacaktır.

If not specified, the Oracle Client libraries determine a character set from the NLS_LANG environment variable.

Passing this parameter can reduce the time taken to connect.

session_mode

This parameter is available since version PHP 5 (PECL OCI8 1.1) and accepts the following values: OCI_DEFAULT, OCI_SYSOPER and OCI_SYSDBA. If either OCI_SYSOPER or OCI_SYSDBA were specified, this function will try to establish privileged connection using external credentials. Privileged connections are disabled by default. To enable them you need to set oci8.privileged_connect to On.

PHP 5.3 (PECL OCI8 1.3.4) introduced the OCI_CRED_EXT mode value. This tells Oracle to use External or OS authentication, which must be configured in the database. The OCI_CRED_EXT flag can only be used with username of "/" and a empty password. oci8.privileged_connect may be On or Off.

OCI_CRED_EXT may be combined with the OCI_SYSOPER or OCI_SYSDBA modes.

OCI_CRED_EXT is not supported on Windows for security reasons.

Dönen Değerler

Returns a connection identifier or FALSE on error.

Örnekler

The following demonstrates how you can separate connections.

Örnek 1 oci_new_connect() example

<?php

// create table mytab (mycol number);

function query($name, $c)
{
    echo "Querying $name\n";
    $s = oci_parse($c, "select * from mytab");
    oci_execute($s, OCI_NO_AUTO_COMMIT);
    $row = oci_fetch_array($s, OCI_ASSOC);
    if (!$row) {
        echo "No rows\n";
    } else {
        do {
            foreach ($row as $item)
                echo $item . " ";
            echo "\n";
        } while (($row = oci_fetch_array($s, OCI_ASSOC)) != false);
    }
}

$c1 = oci_connect("hr", "welcome", "localhost/orcl");
$c2 = oci_new_connect("hr", "welcome", "localhost/orcl");

$s = oci_parse($c1, "insert into mytab values(1234)");
oci_execute($s, OCI_NO_AUTO_COMMIT);

query("basic connection", $c1);
query("new connection", $c2);
oci_commit($c1);
query("new connection after commit", $c2);

// Output is:
//   Querying basic connection
//   1234
//   Querying new connection
//   No rows
//   Querying new connection after commit
//   1234

?>

See oci_connect() for further examples of parameter usage.

Ayrıca Bakınız

  • oci_connect() - Connect to an Oracle database
  • oci_pconnect() - Connect to an Oracle database using a persistent connection

oci_new_collection
oci_new_cursor
OCI8 İşlevleri


Allocates and returns a new cursor (statement handle)

oci_new_connect
oci_new_descriptor
OCI8 İşlevleri
PHP Manual

oci_new_cursor

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

oci_new_cursor — Allocates and returns a new cursor (statement handle)

Açıklama

resource oci_new_cursor ( resource $connection )

Allocates a new statement handle on the specified connection.

Değiştirgeler

connection

An Oracle connection identifier, returned by oci_connect() or oci_pconnect().

Dönen Değerler

Returns a new statement handle, or FALSE on error.

Örnekler

Örnek 1 Binding a REF CURSOR in an Oracle stored procedure call

<?php

// Precreate:
//   create or replace procedure myproc(myrc out sys_refcursor) as
//   begin
//     open myrc for select first_name from employees;
//   end;

$conn = oci_connect("hr", "hrpwd", "localhost/XE");
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$curs = oci_new_cursor($conn);
$stid = oci_parse($conn, "begin myproc(:cursbv); end;");
oci_bind_by_name($stid, ":cursbv", $curs, -1, OCI_B_CURSOR);
oci_execute($stid);

oci_execute($curs);  // Execute the REF CURSOR like a normal statement id
while (($row = oci_fetch_array($curs, OCI_ASSOC+OCI_RETURN_NULLS)) != false) {
    echo $row['FIRST_NAME'] . "<br />\n";
}

oci_free_statement($stid);
oci_free_statement($curs);
oci_close($conn);

?>

Notlar

Bilginize:

In PHP versions before 5.0.0 you must use ocinewcursor() instead. This name still can be used, it was left as alias of oci_new_cursor() for downwards compatability. This, however, is deprecated and not recommended.

oci_new_connect
oci_new_descriptor
OCI8 İşlevleri


Initializes a new empty LOB or FILE descriptor

oci_new_cursor
oci_num_fields
OCI8 İşlevleri
PHP Manual

oci_new_descriptor

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

oci_new_descriptor — Initializes a new empty LOB or FILE descriptor

Açıklama

OCI-Lob oci_new_descriptor ( resource $connection [, int $type = OCI_DTYPE_LOB ] )

Allocates resources to hold descriptor or LOB locator.

Değiştirgeler

connection

An Oracle connection identifier, returned by oci_connect() or oci_pconnect().

type

Valid values for type are: OCI_DTYPE_FILE, OCI_DTYPE_LOB and OCI_DTYPE_ROWID.

Dönen Değerler

Returns a new LOB or FILE descriptor on success, FALSE on error.

Örnekler

Örnek 1 oci_new_descriptor() example

<?php
/* This script is designed to be called from a HTML form.
 * It expects $user, $password, $table, $where, and $commitsize
 * to be passed in from the form.  The script then deletes
 * the selected rows using the ROWID and commits after each
 * set of $commitsize rows. (Use with care, there is no rollback)
 */
$conn = oci_connect($user, $password);
$stmt = oci_parse($conn, "select rowid from $table $where");
$rowid = oci_new_descriptor($conn, OCI_D_ROWID);
oci_define_by_name($stmt, "ROWID", $rowid);
oci_execute($stmt);
while (oci_fetch($stmt)) {
    $nrows = oci_num_rows($stmt);
    $delete = oci_parse($conn, "delete from $table where ROWID = :rid");
    oci_bind_by_name($delete, ":rid", $rowid, -1, OCI_B_ROWID);
    oci_execute($delete);
    echo "$nrows\n";
    if (($nrows % $commitsize) == 0) {
        oci_commit($conn);
    }
}
$nrows = oci_num_rows($stmt);
echo "$nrows deleted...\n";
oci_free_statement($stmt);
oci_close($conn);
?>
<?php
    /* This script demonstrates file upload to LOB columns
     * The formfield used for this example looks like this
     * <form action="upload.php" method="post" enctype="multipart/form-data">
     * <input type="file" name="lob_upload" />
     * ...
     */
  if (!isset($lob_upload) || $lob_upload == 'none'){
?>
<form action="upload.php" method="post" enctype="multipart/form-data">
Upload file: <input type="file" name="lob_upload" /><br />
<input type="submit" value="Upload" /> - <input type="reset" value="Reset" />
</form>
<?php
  } else {

     // $lob_upload contains the temporary filename of the uploaded file

     // see also the features section on file upload,
     // if you would like to use secure uploads

     $conn = oci_connect($user, $password);
     $lob = oci_new_descriptor($conn, OCI_D_LOB);
     $stmt = oci_parse($conn, "insert into $table (id, the_blob)
               values(my_seq.NEXTVAL, EMPTY_BLOB()) returning the_blob into :the_blob");
     oci_bind_by_name($stmt, ':the_blob', $lob, -1, OCI_B_BLOB);
     oci_execute($stmt, OCI_DEFAULT);
     if ($lob->savefile($lob_upload)){
        oci_commit($conn);
        echo "Blob successfully uploaded\n";
     }else{
        echo "Couldn't upload Blob\n";
     }
     $lob->free();
     oci_free_statement($stmt);
     oci_close($conn);
  }
?>

Örnek 2 oci_new_descriptor() example

<?php
/* Calling PL/SQL stored procedures which contain clobs as input
 * parameters.
 * Example PL/SQL stored procedure signature is:
 *
 * PROCEDURE save_data
 *   Argument Name                  Type                    In/Out Default?
 *   ------------------------------ ----------------------- ------ --------
 *   KEY                            NUMBER(38)              IN
 *   DATA                           CLOB                    IN
 *
 */

$conn = oci_connect($user, $password);
$stmt = oci_parse($conn, "begin save_data(:key, :data); end;");
$clob = oci_new_descriptor($conn, OCI_D_LOB);
oci_bind_by_name($stmt, ':key', $key);
oci_bind_by_name($stmt, ':data', $clob, -1, OCI_B_CLOB);
$clob->write($data);
oci_execute($stmt, OCI_DEFAULT);
oci_commit($conn);
$clob->free();
oci_free_statement($stmt);
?>

Notlar

Bilginize:

In PHP versions before 5.0.0 you must use ocinewdescriptor() instead. This name still can be used, it was left as alias of oci_new_descriptor() for downwards compatability. This, however, is deprecated and not recommended.

Ayrıca Bakınız

  • oci_bind_by_name() - Binds a PHP variable to an Oracle placeholder

oci_new_cursor
oci_num_fields
OCI8 İşlevleri


Returns the number of result columns in a statement

oci_new_descriptor
oci_num_rows
OCI8 İşlevleri
PHP Manual

oci_num_fields

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

oci_num_fields — Returns the number of result columns in a statement

Açıklama

int oci_num_fields ( resource $statement )

Gets the number of columns in the given statement.

Değiştirgeler

statement

A valid OCI statement identifier.

Dönen Değerler

Returns the number of columns as an integer, or FALSE on errors.

Örnekler

Örnek 1 oci_num_fields() example

<?php

// Create the table with:
//   CREATE TABLE mytab (id NUMBER, quantity NUMBER);

$conn = oci_connect("hr", "hrpwd", "localhost/XE");
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$stid = oci_parse($conn, "SELECT * FROM mytab");
oci_execute($stid, OCI_DESCRIBE_ONLY); // Use OCI_DESCRIBE_ONLY if not fetching rows

$ncols = oci_num_fields($stid);
for ($i = 1; $i <= $ncols; $i++) {
    echo oci_field_name($stid, $i) . " " . oci_field_type($stid, $i) . "<br>\n";
}

// Outputs:
//    ID NUMBER
//    QUANTITY NUMBER

oci_free_statement($stid);
oci_close($conn);

?>

Notlar

Bilginize:

In PHP versions before 5.0.0 you must use ocinumcols() instead. This name still can be used, it was left as alias of oci_num_fields() for downwards compatability. This, however, is deprecated and not recommended.

oci_new_descriptor
oci_num_rows
OCI8 İşlevleri


Returns number of rows affected during statement execution

oci_num_fields
oci_parse
OCI8 İşlevleri
PHP Manual

oci_num_rows

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

oci_num_rows — Returns number of rows affected during statement execution

Açıklama

int oci_num_rows ( resource $statement )

Gets the number of rows affected during statement execution.

Değiştirgeler

statement

A valid OCI statement identifier.

Dönen Değerler

Returns the number of rows affected as an integer, or FALSE on errors.

Örnekler

Örnek 1 oci_num_rows() example

<?php

$conn = oci_connect("hr", "hrpwd", "localhost/XE");
if (!$conn) {
    $m = oci_error();
    trigger_error(htmlentities($m['message']), E_USER_ERROR);
}

$stid = oci_parse($conn, "create table emp2 as select * from employees");
oci_execute($stid);
echo oci_num_rows($stid) . " rows inserted.<br />\n";
oci_free_statement($stid);

$stid = oci_parse($conn, "delete from emp2");
oci_execute($stid, OCI_DEFAULT);
echo oci_num_rows($stid) . " rows deleted.<br />\n";
oci_commit($conn);
oci_free_statement($stid);

$stid = oci_parse($conn, "drop table emp2");
oci_execute($stid);
oci_free_statement($stid);

oci_close($conn);

?>

Notlar

Bilginize:

This function does not return number of rows selected! For SELECT statements this function will return the number of rows, that were fetched to the buffer with oci_fetch*() functions.

Bilginize:

In PHP versions before 5.0.0 you must use ocirowcount() instead. This name still can be used, it was left as alias of oci_num_rows() for downwards compatability. This, however, is deprecated and not recommended.

oci_num_fields
oci_parse
OCI8 İşlevleri


Prepares an Oracle statement for execution

oci_num_rows
oci_password_change
OCI8 İşlevleri
PHP Manual

oci_parse

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

oci_parse — Prepares an Oracle statement for execution

Açıklama

resource oci_parse ( resource $connection , string $sql_text )

Prepares sql_text using connection and returns the statement identifier, which can be used with oci_bind_by_name(), oci_execute() and other functions.

Statement identifiers can be freed with oci_free_statement() or by setting the variable to NULL.

Değiştirgeler

connection

An Oracle connection identifier, returned by oci_connect(), oci_pconnect(), or oci_new_connect().

sql_text

The SQL or PL/SQL statement.

SQL statements should not end with a semi-colon (";"). PL/SQL statements should end with a semi-colon (";").

Dönen Değerler

Returns a statement handle on success, or FALSE on error.

Örnekler

Örnek 1 oci_parse() example for SQL statements

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');

// Parse the statement. Note there is no final semi-colon in the SQL statement
$stid = oci_parse($conn, 'SELECT * FROM employees');
oci_execute($stid);

echo "<table border='1'>\n";
while ($row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_NULLS)) {
    echo "<tr>\n";
    foreach ($row as $item) {
        echo "    <td>" . ($item !== null ? htmlentities($item, ENT_QUOTES) : "&nbsp;") . "</td>\n";
    }
    echo "</tr>\n";
}
echo "</table>\n";

?>

Örnek 2 oci_parse() example for PL/SQL statements

<?php

/*
  Before running the PHP program, create a stored procedure in
  SQL*Plus or SQL Developer:

  CREATE OR REPLACE PROCEDURE myproc(p1 IN NUMBER, p2 OUT NUMBER) AS
  BEGIN
      p2 := p1 * 2;
  END;

*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$p1 = 8;

// When parsing PL/SQL programs, there should be a final semi-colon in the string
$stid = oci_parse($conn, 'begin myproc(:p1, :p2); end;');
oci_bind_by_name($stid, ':p1', $p1);
oci_bind_by_name($stid, ':p2', $p2, 40);

oci_execute($stid);

print "$p2\n";   // prints 16

oci_free_statement($stid);
oci_close($conn);

?>

Notlar

Bilginize:

This function does not validate sql_text. The only way to find out if sql_text is a valid SQL or PL/SQL statement is to execute it.

Ayrıca Bakınız

  • oci_execute() - Executes a statement
  • oci_free_statement() - Frees all resources associated with statement or cursor

oci_num_rows
oci_password_change
OCI8 İşlevleri


Changes password of Oracle's user

oci_parse
oci_pconnect
OCI8 İşlevleri
PHP Manual

oci_password_change

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

oci_password_change — Changes password of Oracle's user

Açıklama

bool oci_password_change ( resource $connection , string $username , string $old_password , string $new_password )
resource oci_password_change ( string $dbname , string $username , string $old_password , string $new_password )

Changes password for user with username.

The oci_password_change() function is most useful for PHP command-line scripts, or when non-persistent connections are used throughout the PHP application.

Değiştirgeler

connection

An Oracle connection identifier, returned by oci_connect() or oci_pconnect().

username

The Oracle user name.

old_password

The old password.

new_password

The new password to be set.

dbname

The database name.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 oci_password_change() example changing the password of an already connected user

<?php

$dbase      = 'localhost/orcl';
$user       = 'cj';
$current_pw = 'welcome';
$new_pw     = 'geelong';

$c = oci_pconnect($user, $current_pw, $dbase);
oci_password_change($c, $user, $current_pw, $new_pw);
echo "New password is : " . $new_pw . "\n";

?>

Örnek 2 oci_password_change() example of connecting and changing the password in one step

<?php

$dbase      = 'localhost/orcl';
$user       = 'cj';
$current_pw = 'welcome';
$new_pw     = 'geelong';

$c = oci_pconnect($user, $current_pw, $dbase);
if (!$c) {
    $m = oci_error();
    if ($m['code'] == 28001) { // "ORA-28001: the password has expired"
        // Login and reset password at the same time
        $c = oci_password_change($dbase, $user, $current_pw, $new_pw);
        if ($c) {
            echo "New password is : " . $new_pw . "\n";
        }
    }
}

if (!$c) {  // The original error wasn't 28001, or the password change failed
    $m = oci_error();
    trigger_error('Could not connect to database: '. $m['message'], E_USER_ERROR);
}

// Use the connection $c
...

?>

Notlar

Bilginize:

Changing the password either with this function or directly in Oracle should be done carefully. This is because PHP applications may continue to successfully reuse persistent connections by authenticating with the old password. The best practice is to restart all web servers whenever the user password is changed.

Bilginize:

If upgrading the Oracle client libraries or the database from a release prior to 11.2.0.3 to version 11.2.0.3 or higher, oci_password_change() may give the error "ORA-1017: invalid username/password" unless both client and server versions are upgraded at the same time.

Bilginize:

The second oci_password_change() syntax is available since OCI8 version 1.1.

Bilginize:

In PHP versions before 5.0.0 you must use ocipasswordchange() instead. This name still can be used, it was left as alias of oci_password_change() for downwards compatability. This, however, is deprecated and not recommended.

oci_parse
oci_pconnect
OCI8 İşlevleri


Connect to an Oracle database using a persistent connection

oci_password_change
oci_result
OCI8 İşlevleri
PHP Manual

oci_pconnect

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

oci_pconnect — Connect to an Oracle database using a persistent connection

Açıklama

resource oci_pconnect ( string $username , string $password [, string $connection_string [, string $character_set [, int $session_mode ]]] )

Creates a persistent connection to an Oracle server and logs on.

Persistent connections are cached and re-used between requests, resulting in reduced overhead on each page load; a typical PHP application will have a single persistent connection open against an Oracle server per Apache child process (or PHP FastCGI/CGI process). See the Persistent Database Connections section for more information.

Değiştirgeler

username

The Oracle user name.

password

The password for username.

connection_string

Contains the Oracle instance to connect to. It can be an » Easy Connect string, or a Connect Name from the tnsnames.ora file, or the name of a local Oracle instance

If not specified, PHP uses environment variables such as TWO_TASK (on Linux) or LOCAL (on Windows) and ORACLE_SID to determine the Oracle instance to connect to.

To use the Easy Connect naming method, PHP must be linked with Oracle 10g or greater Client libraries. The Easy Connect string for Oracle 10g is of the form: 10g is of the form: [//]host_name[:port][/service_name]. With Oracle [//]host_name[:port][/service_name]. From Oracle 11g, the syntax is: 11g, the syntax is:[//]host_name[:port][/service_name][:server_type][/instance_name] . Service names can be found by running the Oracle utility lsnrctl status on the database server machine.

The tnsnames.ora file can be in the Oracle Net search path, which includes $ORACLE_HOME/network/admin and /etc. Alternatively set TNS_ADMIN so that $TNS_ADMIN/tnsnames.ora is read. Make sure the web daemon has read access to the file.

character_set

Oracle sunucusunun 9.2 ve üstü sürümlerini kullanırken, karakter_kümesi değiştirgesini yeni bağlantıda kullanılacak değiştirgeye göre belirtebilirsiniz. Eğer 9.2 sürümünden daha eski bir Oracle sunucusu kullanıyorsanız bu değiştirge yok sayılacak, yerine NLS_LANG ortam değişkeni kullanılacaktır.

If not specified, the Oracle Client libraries determine a character set from the NLS_LANG environment variable.

Passing this parameter can reduce the time taken to connect.

session_mode

This parameter is available since version PHP 5 (PECL OCI8 1.1) and accepts the following values: OCI_DEFAULT, OCI_SYSOPER and OCI_SYSDBA. If either OCI_SYSOPER or OCI_SYSDBA were specified, this function will try to establish privileged connection using external credentials. Privileged connections are disabled by default. To enable them you need to set oci8.privileged_connect to On.

PHP 5.3 (PECL OCI8 1.3.4) introduced the OCI_CRED_EXT mode value. This tells Oracle to use External or OS authentication, which must be configured in the database. The OCI_CRED_EXT flag can only be used with username of "/" and a empty password. oci8.privileged_connect may be On or Off.

OCI_CRED_EXT may be combined with the OCI_SYSOPER or OCI_SYSDBA modes.

OCI_CRED_EXT is not supported on Windows for security reasons.

Dönen Değerler

Returns a connection identifier or FALSE on error.

Örnekler

Örnek 1 Basic oci_pconnect() Example using Easy Connect syntax

<?php

// Connects to the XE service (i.e. database) on the "localhost" machine
$conn = oci_pconnect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$stid = oci_parse($conn, 'SELECT * FROM employees');
oci_execute($stid);

echo "<table border='1'>\n";
while ($row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_NULLS)) {
    echo "<tr>\n";
    foreach ($row as $item) {
        echo "    <td>" . ($item !== null ? htmlentities($item, ENT_QUOTES) : "&nbsp;") . "</td>\n";
    }
    echo "</tr>\n";
}
echo "</table>\n";

?>

See oci_connect() for further examples of parameter usage.

Notlar

Bilginize: Starting with PHP 5.1.2 and PECL OCI8 1.1, the lifetime and maximum number of persistent Oracle connections per PHP process can be tuned by setting the following configuration values: oci8.persistent_timeout, oci8.ping_interval and oci8.max_persistent.

Ayrıca Bakınız

  • oci_connect() - Connect to an Oracle database
  • oci_new_connect() - Connect to the Oracle server using a unique connection

oci_password_change
oci_result
OCI8 İşlevleri


Returns field's value from the fetched row

oci_pconnect
oci_rollback
OCI8 İşlevleri
PHP Manual

oci_result

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

oci_result — Returns field's value from the fetched row

Açıklama

mixed oci_result ( resource $statement , mixed $field )

Returns the data from field in the current row, fetched by oci_fetch().

OCI8 sürücüsü tarafından yapılan veri türü eşlemeyle ilgili ayrıntılar için sürücü tarafından desteklenen veri türleri bölümüne bakınız.

Değiştirgeler

statement

field

Can be either use the column number (1-based) or the column name. The case of the column name must be the case that Oracle meta data describes the column as, which is uppercase for columns created case insensitively.

Dönen Değerler

Returns everything as strings except for abstract types (ROWIDs, LOBs and FILEs). Returns FALSE on error.

Örnekler

Örnek 1 oci_fetch() with oci_result()

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');
if (!$conn) {
    $e = oci_error();
    trigger_error(htmlentities($e['message'], ENT_QUOTES), E_USER_ERROR);
}

$sql = 'SELECT location_id, city FROM locations WHERE location_id < 1200';
$stid = oci_parse($conn, $sql);
oci_execute($stid);

while (oci_fetch($stid)) {
    echo oci_result($stid, 'LOCATION_ID') . " is ";
    echo oci_result($stid, 'CITY') . "<br>\n";
}

// Displays:
//   1000 is Roma
//   1100 is Venice

oci_free_statement($stid);
oci_close($conn);

?>

Notlar

Bilginize:

In PHP versions before 5.0.0 you must use ociresult() instead. This name still can be used, it was left as alias of oci_result() for downwards compatability. This, however, is deprecated and not recommended.

Ayrıca Bakınız

  • oci_fetch_array() - Returns the next row from a query as an associative or numeric array
  • oci_fetch_assoc() - Returns the next row from a query as an associative array
  • oci_fetch_object() - Returns the next row from a query as an object
  • oci_fetch_row() - Returns the next row from a query as a numeric array
  • oci_fetch_all() - Fetches multiple rows from a query into a two-dimensional array

oci_pconnect
oci_rollback
OCI8 İşlevleri


Rolls back the outstanding database transaction

oci_result
oci_server_version
OCI8 İşlevleri
PHP Manual

oci_rollback

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

oci_rollback — Rolls back the outstanding database transaction

Açıklama

bool oci_rollback ( resource $connection )

Reverts all uncommitted changes for the Oracle connection and ends the transaction. It releases all locks held. All Oracle SAVEPOINTS are erased.

A transaction begins when the first SQL statement that changes data is executed with oci_execute() using the OCI_NO_AUTO_COMMIT flag. Further data changes made by other statements become part of the same transaction. Data changes made in a transaction are temporary until the transaction is committed or rolled back. Other users of the database will not see the changes until they are committed.

When inserting or updating data, using transactions is recommended for relational data consistency and for performance reasons.

Değiştirgeler

connection

An Oracle connection identifier, returned by oci_connect(), oci_pconnect() or oci_new_connect().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 oci_rollback() example

<?php

// Insert into several tables, rolling back the changes if an error occurs

$conn = oci_connect('hr', 'welcome', 'localhost/XE');

$stid = oci_parse($conn, "INSERT INTO mysalary (id, name) VALUES (1, 'Chris')");

// The OCI_NO_AUTO_COMMIT flag tells Oracle not to commit the INSERT immediately
// Use OCI_DEFAULT as the flag for PHP <= 5.3.1.  The two flags are equivalent
$r = oci_execute($stid, OCI_NO_AUTO_COMMIT);
if (!$r) {
    $e = oci_error($stid);
    trigger_error(htmlentities($e['message']), E_USER_ERROR);
}

$stid = oci_parse($conn, 'INSERT INTO myschedule (startday) VALUES (12)');
$r = oci_execute($stid, OCI_NO_AUTO_COMMIT);
if (!$r) {
    $e = oci_error($stid);
    oci_rollback($conn);  // rollback changes to both tables
    trigger_error(htmlentities($e['message']), E_USER_ERROR);
}

// Commit the changes to both tables
$r = oci_commit($conn);
if (!r) {
    $e = oci_error($conn);
    trigger_error(htmlentities($e['message']), E_USER_ERROR);
}

?>

Örnek 2 Rolling back to a SAVEPOINT example

<?php
$stid = oci_parse($conn, 'UPDATE mytab SET id = 1111');
oci_execute($stid, OCI_NO_AUTO_COMMIT);

// Create the savepoint
$stid = oci_parse($conn, 'SAVEPOINT mysavepoint');
oci_execute($stid, OCI_NO_AUTO_COMMIT);

$stid = oci_parse($conn, 'UPDATE mytab SET id = 2222');
oci_execute($stid, OCI_NO_AUTO_COMMIT);

// Use an explicit SQL statement to rollback to the savepoint
$stid = oci_parse($conn, 'ROLLBACK TO SAVEPOINT mysavepoint');
oci_execute($stid, OCI_NO_AUTO_COMMIT);

oci_commit($conn);  // mytab now has id of 1111
?>

Notlar

Bilginize:

Transactions are automatically rolled back when you close the connection, or when the script ends, whichever is soonest. You need to explicitly call oci_commit() to commit the transaction.

Any call to oci_execute() that uses OCI_COMMIT_ON_SUCCESS mode explicitly or by default will commit any previous uncommitted transaction.

Any Oracle DDL statement such as CREATE or DROP will automatically commit any uncommitted transaction.

Ayrıca Bakınız

  • oci_commit() - Commits the outstanding database transaction
  • oci_execute() - Executes a statement

oci_result
oci_server_version
OCI8 İşlevleri


Returns the Oracle Database version

oci_rollback
oci_set_action
OCI8 İşlevleri
PHP Manual

oci_server_version

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

oci_server_version — Returns the Oracle Database version

Açıklama

string oci_server_version ( resource $connection )

Returns a string with the Oracle Database version and available options

Değiştirgeler

connection

Dönen Değerler

Returns the version information as a string or FALSE on error.

Örnekler

Örnek 1 oci_server_version() example

<?php

$conn = oci_connect("hr", "hrpwd", "localhost/XE");
echo "Server Version: " . oci_server_version($conn);

// Displays:
// Server Version: Oracle Database 11g Enterprise Edition Release 11.2.0.1.0 - 64bit Production
// With the Partitioning, OLAP, Data Mining and Real Application Testing option

oci_close($conn);

?>

Notlar

Bilginize:

In PHP versions before 5.0.0 you must use ociserverversion() instead. This old name still can be used. However it is deprecated and not recommended.

Ayrıca Bakınız

  • oci_client_version() - Returns the Oracle client library version

oci_rollback
oci_set_action
OCI8 İşlevleri


Sets the action name

oci_server_version
oci_set_client_identifier
OCI8 İşlevleri
PHP Manual

oci_set_action

(PHP 5.3.2, PHP 7, PECL OCI8 >= 1.4.0)

oci_set_action — Sets the action name

Açıklama

bool oci_set_action ( resource $connection , string $action_name )

Sets the action name for Oracle tracing.

The action name is registered with the database when the next 'roundtrip' from PHP to the database occurs, typically when an SQL statement is executed.

The action name can subsequently be queried from database administration views such as V$SESSION. It can be used for tracing and monitoring such as with V$SQLAREA and DBMS_MONITOR.SERV_MOD_ACT_STAT_ENABLE.

The value may be retained across persistent connections.

Değiştirgeler

connection

An Oracle connection identifier, returned by oci_connect(), oci_pconnect(), or oci_new_connect().

action_name

User chosen string up to 32 bytes long.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Setting the action

<?php

$c = oci_connect('hr', 'welcome', 'localhost/XE');

// Record the action
oci_set_action($c, 'Friend Lookup');

// Code that causes a roundtrip, for example a query:
$s = oci_parse($c, 'select * from dual');
oci_execute($s);
oci_fetch_all($s, $res);

sleep(30);

?>
// While the script is running, the administrator can see the actions
// being performed:

sqlplus system/welcome
SQL> select action from v$session;

Notlar

Bilginize: Oracle version requirement

This function is available when PHP is linked with Oracle Database libraries from version 10g onwards.

İpucu

Performance

With older versions of OCI8 or the Oracle Database, the client information can be set using the Oracle DBMS_APPLICATION_INFO package. This is less efficient than using oci_set_client_info().

Dikkat

Roundtrip Gotcha

Some but not all OCI8 functions cause roundtrips. Roundtrips to the database may not occur with queries when result caching is enabled.

Ayrıca Bakınız

  • oci_set_module_name() - Sets the module name
  • oci_set_client_info() - Sets the client information
  • oci_set_client_identifier() - Sets the client identifier

oci_server_version
oci_set_client_identifier
OCI8 İşlevleri


Sets the client identifier

oci_set_action
oci_set_client_info
OCI8 İşlevleri
PHP Manual

oci_set_client_identifier

(PHP 5.3.2, PHP 7, PECL OCI8 >= 1.4.0)

oci_set_client_identifier — Sets the client identifier

Açıklama

bool oci_set_client_identifier ( resource $connection , string $client_identifier )

Sets the client identifier used by various database components to identify lightweight application users who authenticate as the same database user.

The client identifier is registered with the database when the next 'roundtrip' from PHP to the database occurs, typically when an SQL statement is executed.

The identifier can subsequently be queried, for example with SELECT SYS_CONTEXT('USERENV','CLIENT_IDENTIFIER') FROM DUAL. Database administration views such as V$SESSION will also contain the value. It can be used with DBMS_MONITOR.CLIENT_ID_TRACE_ENABLE for tracing and can also be used for auditing.

The value may be retained across page requests that use the same persistent connection.

Değiştirgeler

connection

An Oracle connection identifier, returned by oci_connect(), oci_pconnect(), or oci_new_connect().

client_identifier

User chosen string up to 64 bytes long.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Setting the client identifier to the application user

<?php

// Find the application user's login name
session_start();
$un = my_validate_session($_SESSION['username']);
$c = oci_connect('myschema', 'welcome', 'localhost/XE');

// Tell Oracle who that user is
oci_set_client_identifier($c, $un);

// The next roundtrip to the database will piggyback the identifier
$s = oci_parse($c, 'select mydata from mytable');
oci_execute($s);

// ...

?>

Notlar

Dikkat

Roundtrip Gotcha

Some but not all OCI8 functions cause roundtrips. Roundtrips to the database may not occur with queries when result caching is enabled.

Ayrıca Bakınız

  • oci_set_module_name() - Sets the module name
  • oci_set_action() - Sets the action name
  • oci_set_client_info() - Sets the client information

oci_set_action
oci_set_client_info
OCI8 İşlevleri


Sets the client information

oci_set_client_identifier
oci_set_edition
OCI8 İşlevleri
PHP Manual

oci_set_client_info

(PHP 5.3.2, PHP 7, PECL OCI8 >= 1.4.0)

oci_set_client_info — Sets the client information

Açıklama

bool oci_set_client_info ( resource $connection , string $client_info )

Sets the client information for Oracle tracing.

The client information is registered with the database when the next 'roundtrip' from PHP to the database occurs, typically when an SQL statement is executed.

The client information can subsequently be queried from database administration views such as V$SESSION.

The value may be retained across persistent connections.

Değiştirgeler

connection

An Oracle connection identifier, returned by oci_connect(), oci_pconnect(), or oci_new_connect().

client_info

User chosen string up to 64 bytes long.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Setting the client information

<?php

$c = oci_connect('hr', 'welcome', 'localhost/XE');

// Record the client information
oci_set_client_info($c, 'My Application Version 2');

// Code that causes a roundtrip, for example a query:
$s = oci_parse($c, 'select * from dual');
oci_execute($s);
oci_fetch_all($s, $res);

sleep(30);

?>
// While the script is running, the administrator can see the client
// information:

sqlplus system/welcome
SQL> select client_info from v$session;

Notlar

Bilginize: Oracle version requirement

This function is available when PHP is linked with Oracle Database libraries from version 10g onwards.

İpucu

Performance

With older versions of OCI8 or the Oracle Database, the client information can be set using the Oracle DBMS_APPLICATION_INFO package. This is less efficient than using oci_set_client_info().

Dikkat

Roundtrip Gotcha

Some but not all OCI8 functions cause roundtrips. Roundtrips to the database may not occur with queries when result caching is enabled.

Ayrıca Bakınız

  • oci_set_module_name() - Sets the module name
  • oci_set_action() - Sets the action name
  • oci_set_client_identifier() - Sets the client identifier

oci_set_client_identifier
oci_set_edition
OCI8 İşlevleri


Sets the database edition

oci_set_client_info
oci_set_module_name
OCI8 İşlevleri
PHP Manual

oci_set_edition

(PHP 5.3.2, PHP 7, PECL OCI8 >= 1.4.0)

oci_set_edition — Sets the database edition

Açıklama

bool oci_set_edition ( string $edition )

Sets the database "edition" of objects to be used by a subsequent connections.

Oracle Editions allow concurrent versions of applications to run using the same schema and object names. This is useful for upgrading live systems.

Call oci_set_edition() before calling
oci_connect(), oci_pconnect()
or oci_new_connect().

If an edition is set that is not valid in the database, connection will fail even if oci_set_edition() returns success.

When using persistent connections, if a connection with the requested edition setting already exists, it is reused. Otherwise, a different persistent connection is created

Değiştirgeler

edition

Oracle Database edition name previously created with the SQL "CREATE EDITION" command.

Notlar

Bilginize: Oracle version requirement

This function is available from Oracle 11gR2 onwards.

Dikkat

Persistent connections

To avoid inconsistencies and unexpected errors, do not use ALTER SESSION SET EDITION to change the edition on persistent connections.

Dikkat

DRCP Connection Pooling

To avoid inconsistencies and unexpected errors when using editions and DRCP with Oracle 11.2.0.1, keep a one-to-one correspondence between the oci8.connection_class and the edition name used by applications. Each pooled server of a given connection class should only be used with one edition. This restriction has been removed with Oracle 11.2.0.2.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Two scripts can use different versions of myfunc() at the same time

<?php

// File 1

echo "Version 1 of application\n";

oci_set_edition('ORA$BASE');
$c = oci_connect('hr', 'welcome', 'localhost/XE');

$s = oci_parse($c, "begin :r := myfunc(); end;");
oci_bind_by_name($s, ":r", $r, 20);
oci_execute($s);
echo "The result is $r\n";

?>
<?php

// File 2

echo "Version 2 of application\n";

oci_set_edition('E1');
$c = oci_connect('hr', 'welcome', 'localhost/XE');

$s = oci_parse($c, "begin :r := myfunc(); end;");
oci_bind_by_name($s, ":r", $r, 20);
oci_execute($s);
echo "The result is $r\n";

?>

oci_set_client_info
oci_set_module_name
OCI8 İşlevleri


Sets the module name

oci_set_edition
oci_set_prefetch
OCI8 İşlevleri
PHP Manual

oci_set_module_name

(PHP 5.3.2, PHP 7, PECL OCI8 >= 1.4.0)

oci_set_module_name — Sets the module name

Açıklama

bool oci_set_module_name ( resource $connection , string $module_name )

Sets the module name for Oracle tracing.

The module name is registered with the database when the next 'roundtrip' from PHP to the database occurs, typically when an SQL statement is executed.

The name can subsequently be queried from database administration views such as V$SESSION. It can be used for tracing and monitoring such as with V$SQLAREA and DBMS_MONITOR.SERV_MOD_ACT_STAT_ENABLE.

The value may be retained across persistent connections.

Değiştirgeler

connection

An Oracle connection identifier, returned by oci_connect(), oci_pconnect(), or oci_new_connect().

module_name

User chosen string up to 48 bytes long.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

Bilginize: Oracle version requirement

This function is available when PHP is linked with Oracle Database libraries from version 10g onwards.

İpucu

Performance

With older versions of OCI8 or the Oracle Database, the client information can be set using the Oracle DBMS_APPLICATION_INFO package. This is less efficient than using oci_set_client_info().

Dikkat

Roundtrip Gotcha

Some but not all OCI8 functions cause roundtrips. Roundtrips to the database may not occur with queries when result caching is enabled.

Örnekler

Örnek 1 Setting the module name

<?php

$c = oci_connect('hr', 'welcome', 'localhost/XE');

// Record the module
oci_set_module_name($c, 'Home Page');

// Code that causes a roundtrip, for example a query:
$s = oci_parse($c, 'select * from dual');
oci_execute($s);
oci_fetch_all($s, $res);

sleep(30);
?>
// While the script is running, the administrator can see the
// modules in use:

sqlplus system/welcome
SQL> select module from v$session;

Ayrıca Bakınız

  • oci_set_action() - Sets the action name
  • oci_set_client_info() - Sets the client information
  • oci_set_client_identifier() - Sets the client identifier

oci_set_edition
oci_set_prefetch
OCI8 İşlevleri


Sets number of rows to be prefetched by queries

oci_set_module_name
oci_statement_type
OCI8 İşlevleri
PHP Manual

oci_set_prefetch

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

oci_set_prefetch — Sets number of rows to be prefetched by queries

Açıklama

bool oci_set_prefetch ( resource $statement , int $rows )

Sets the number of rows to be buffered by the Oracle Client libraries after a successful query call to oci_execute() and for each subsequent internal fetch request to the database. For queries returning a large number of rows, performance can be significantly improved by increasing the prefetch count above the default oci8.default_prefetch value.

Prefetching is Oracle's efficient way of returning more than one data row from the database in each network request. This can result in better network and CPU utilization. The buffering of rows is internal to OCI8 and the behavior of OCI8 fetching functions is unchanged regardless of the prefetch count. For example, oci_fetch_row() will always return one row. The prefetch buffer is per-statement and is not used by re-executed statements or by other connections.

Call oci_set_prefetch() before calling oci_execute().

A tuning goal is to set the prefetch value to a reasonable size for the network and database to handle. For queries returning a very large number of rows, overall system efficiency might be better if rows are retrieved from the database in several chunks (i.e set the prefetch value smaller than the number of rows). This allows the database to handle other users' statements while the PHP script is processing the current set of rows.

Query prefetching was introduced in Oracle 8i. REF CURSOR prefetching was introduced in Oracle 11gR2 and occurs when PHP is linked with Oracle 11gR2 (or later) Client libraries. Nested cursor prefetching was introduced in Oracle 11gR2 and requires both the Oracle Client libraries and the database to be version 11gR2 or greater.

Prefetching is not supported when queries contain LONG or LOB columns. The prefetch value is ignored and single-row fetches will be used in all the situations when prefetching is not supported.

When using Oracle Database 12c, the prefetch value set by PHP can be overridden by Oracle's client oraaccess.xml configuration file. Refer to Oracle documentation for more detail.

Değiştirgeler

statement

A valid OCI8 statement identifier created by oci_parse() and executed by oci_execute(), or a REF CURSOR statement identifier.

rows

The number of rows to be prefetched, >= 0

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.2 (PECL OCI8 1.4) | Before this release, rows must be >= 1.
5.3.0 (PECL OCI8 1.3.4) | Before this release, prefetching was limited to the lesser of rows rows and 1024 * rows bytes. The byte size restriction has now been removed.

Örnekler

Örnek 1 Changing the default prefetch value for a query

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');

$stid = oci_parse($conn, 'SELECT * FROM myverybigtable');
oci_set_prefetch($stid, 300);  // Set before calling oci_execute()
oci_execute($stid);

echo "<table border='1'>\n";
while ($row = oci_fetch_array($stid, OCI_ASSOC+OCI_RETURN_NULLS)) {
    echo "<tr>\n";
    foreach ($row as $item) {
        echo "    <td>".($item !== null ? htmlentities($item, ENT_QUOTES) : "&nbsp;")."</td>\n";
    }
    echo "</tr>\n";
}
echo "</table>\n";

oci_free_statement($stid);
oci_close($conn);

?>

Örnek 2 Changing the default prefetch for a REF CURSOR fetch

<?php
/*
  Create the PL/SQL stored procedure as:

  CREATE OR REPLACE PROCEDURE myproc(p1 OUT SYS_REFCURSOR) AS
  BEGIN
    OPEN p1 FOR SELECT * FROM all_objects WHERE ROWNUM < 5000;
  END;
*/

$conn = oci_connect('hr', 'welcome', 'localhost/XE');

$stid = oci_parse($conn, 'BEGIN myproc(:rc); END;');
$refcur = oci_new_cursor($conn);
oci_bind_by_name($stid, ':rc', $refcur, -1, OCI_B_CURSOR);
oci_execute($stid);

// Change the prefetch before executing the cursor.
// REF CURSOR prefetching works when PHP is linked with Oracle 11gR2 or later Client libraries
oci_set_prefetch($refcur, 200);
oci_execute($refcur);

echo "<table border='1'>\n";
while ($row = oci_fetch_array($refcur, OCI_ASSOC+OCI_RETURN_NULLS)) {
    echo "<tr>\n";
    foreach ($row as $item) {
        echo "    <td>".($item !== null ? htmlentities($item, ENT_QUOTES) : "&nbsp;")."</td>\n";
    }
    echo "</tr>\n";
}
echo "</table>\n";

oci_free_statement($refcur);
oci_free_statement($stid);
oci_close($conn);

?>

If PHP OCI8 fetches from a REF CURSOR and then passes the REF CURSOR back to a second PL/SQL procedure for further processing, then set the REF CURSOR prefetch count to 0 to avoid rows being "lost" from the result set. The prefetch value is the number of extra rows fetched in each OCI8 internal request to the database, so setting it to 0 means only fetch one row at a time.

Örnek 3 Setting the prefetch value when passing a REF CURSOR back to Oracle

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/orcl');

// get the REF CURSOR
$stid = oci_parse($conn, 'BEGIN myproc(:rc_out); END;');
$refcur = oci_new_cursor($conn);
oci_bind_by_name($stid, ':rc_out', $refcur, -1, OCI_B_CURSOR);
oci_execute($stid);

// Display two rows, but don't prefetch any extra rows otherwise
// those extra rows would not be passed back to myproc_use_rc().
// A prefetch value of 0 is allowed in PHP 5.3.2 and PECL OCI8 1.4
oci_set_prefetch($refcur, 0);
oci_execute($refcur);
$row = oci_fetch_array($refcur);
var_dump($row);
$row = oci_fetch_array($refcur);
var_dump($row);

// pass the REF CURSOR to myproc_use_rc() to do more data processing
// with the result set
$stid = oci_parse($conn, 'begin myproc_use_rc(:rc_in); end;');
oci_bind_by_name($stid, ':rc_in', $refcur, -1, OCI_B_CURSOR);
oci_execute($stid);

?>

Ayrıca Bakınız

  • oci8.default_prefetch ini option

oci_set_module_name
oci_statement_type
OCI8 İşlevleri


Returns the type of a statement

oci_set_prefetch
OCI-Collection
OCI8 İşlevleri
PHP Manual

oci_statement_type

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

oci_statement_type — Returns the type of a statement

Açıklama

string oci_statement_type ( resource $statement )

Returns a keyword identifying the type of the OCI8 statement.

Değiştirgeler

statement

A valid OCI8 statement identifier from oci_parse().

Dönen Değerler

Returns the type of statement as one of the following strings.

Statement type
Return String | Notes
ALTER |
BEGIN |
CALL | Introduced in PHP 5.2.1 (PECL OCI8 1.2.3)
CREATE |
DECLARE |
DELETE |
DROP |
INSERT |
SELECT |
UPDATE |
UNKNOWN |

Returns FALSE on error.

Örnekler

Örnek 1 oci_statement_type() example

<?php

$conn = oci_connect('hr', 'welcome', 'localhost/XE');

$stid = oci_parse($conn, 'DELETE FROM departments WHERE department_id = 130;');
if (oci_statement_type($stid) == "DELETE") {
    trigger_error('You are not allowed to delete from this table', E_USER_ERROR);
}
else {
    oci_execute($stid);  // delete the row
}

oci_free_statement($stid);
oci_close($conn);

?>

oci_set_prefetch
OCI-Collection
OCI8 İşlevleri


The OCI-Collection class

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

Giriş

OCI8 Collection functionality.

Sınıf Sözdizimi

OCI-Collection {
/* Yöntemler */
bool append ( mixed $value )
bool assign ( OCI-Collection $from )
bool assignElem ( int $index , mixed $value )
bool free ( void )
mixed getElem ( int $index )
int max ( void )
int size ( void )
bool trim ( int $num )
}

İçindekiler

  • OCI-Collection::append — Appends element to the collection
  • OCI-Collection::assign — Assigns a value to the collection from another existing collection
  • OCI-Collection::assignElem — Assigns a value to the element of the collection
  • OCI-Collection::free — Frees the resources associated with the collection object
  • OCI-Collection::getElem — Returns value of the element
  • OCI-Collection::max — Returns the maximum number of elements in the collection
  • OCI-Collection::size — Returns size of the collection
  • OCI-Collection::trim — Trims elements from the end of the collection
oci_statement_type
OCI-Collection::append
OCI8


Appends element to the collection

OCI-Collection
OCI-Collection::assign
OCI-Collection
PHP Manual

OCI-Collection::append

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

OCI-Collection::append — Appends element to the collection

Açıklama

bool OCI-Collection::append ( mixed $value )

Appends element to the end of the collection.

Değiştirgeler

value

The value to be added to the collection. Can be a string or a number.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • OCI-Collection::assign

OCI-Collection
OCI-Collection::assign
OCI-Collection


Assigns a value to the collection from another existing collection

OCI-Collection::append
OCI-Collection::assignElem
OCI-Collection
PHP Manual

OCI-Collection::assign

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

OCI-Collection::assign — Assigns a value to the collection from another existing collection

Açıklama

bool OCI-Collection::assign ( OCI-Collection $from )

Assigns a value to the collection from another, previously created collection. Both collections must be created with oci_new_collection() prior to using them.

Değiştirgeler

from

An instance of OCI-Collection.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • OCI-Collection::append

OCI-Collection::append
OCI-Collection::assignElem
OCI-Collection


Assigns a value to the element of the collection

OCI-Collection::assign
OCI-Collection::free
OCI-Collection
PHP Manual

OCI-Collection::assignElem

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

OCI-Collection::assignElem — Assigns a value to the element of the collection

Açıklama

bool OCI-Collection::assignElem ( int $index , mixed $value )

Assigns a value to the element with index index.

Değiştirgeler

index

The element index. First index is 0.

value

Can be a string or a number.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • OCI-Collection::getElem

OCI-Collection::assign
OCI-Collection::free
OCI-Collection


Frees the resources associated with the collection object

OCI-Collection::assignElem
OCI-Collection::getElem
OCI-Collection
PHP Manual

OCI-Collection::free

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

OCI-Collection::free — Frees the resources associated with the collection object

Açıklama

bool OCI-Collection::free ( void )

Frees the resources associated with the collection object.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • oci_new_collection

OCI-Collection::assignElem
OCI-Collection::getElem
OCI-Collection


Returns value of the element

OCI-Collection::free
OCI-Collection::max
OCI-Collection
PHP Manual

OCI-Collection::getElem

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

OCI-Collection::getElem — Returns value of the element

Açıklama

mixed OCI-Collection::getElem ( int $index )

Returns element's value with the index index (0-based).

Değiştirgeler

index

The element index. First index is 0.

Dönen Değerler

Returns FALSE if such element doesn't exist; NULL if element is NULL; string if element is column of a string datatype or number if element is numeric field.

Ayrıca Bakınız

  • OCI-Collection::assignElem

OCI-Collection::free
OCI-Collection::max
OCI-Collection


Returns the maximum number of elements in the collection

OCI-Collection::getElem
OCI-Collection::size
OCI-Collection
PHP Manual

OCI-Collection::max

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

OCI-Collection::max — Returns the maximum number of elements in the collection

Açıklama

int OCI-Collection::max ( void )

Returns the maximum number of elements in the collection.

Dönen Değerler

Returns the maximum number as an integer, or FALSE on errors.

If the returned value is 0, then the number of elements is not limited.

Ayrıca Bakınız

  • OCI-Collection::size

OCI-Collection::getElem
OCI-Collection::size
OCI-Collection


Returns size of the collection

OCI-Collection::max
OCI-Collection::trim
OCI-Collection
PHP Manual

OCI-Collection::size

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

OCI-Collection::size — Returns size of the collection

Açıklama

int OCI-Collection::size ( void )

Returns the size of the collection.

Dönen Değerler

Returns the number of elements in the collection or FALSE on error.

Ayrıca Bakınız

  • OCI-Collection::max

OCI-Collection::max
OCI-Collection::trim
OCI-Collection


Trims elements from the end of the collection

OCI-Collection::size
OCI-Lob
OCI-Collection
PHP Manual

OCI-Collection::trim

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

OCI-Collection::trim — Trims elements from the end of the collection

Açıklama

bool OCI-Collection::trim ( int $num )

Trims num of elements from the end of the collection.

Değiştirgeler

num

The number of elements to be trimmed.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • OCI-Collection::size

OCI-Collection::size
OCI-Lob
OCI-Collection


The OCI-Lob class

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

Giriş

OCI8 LOB functionality for large binary (BLOB) and character (CLOB) objects.

Sınıf Sözdizimi

OCI-Lob {
/* Yöntemler */
bool append ( OCI-Lob $lob_from )
bool close ( void )
bool eof ( void )
int erase ([ int $offset [, int $length ]] )
bool export ( string $filename [, int $start [, int $length ]] )
bool flush ([ int $flag ] )
bool free ( void )
bool getBuffering ( void )
bool import ( string $filename )
string load ( void )
string read ( int $length )
bool rewind ( void )
bool save ( string $data [, int $offset ] )
bool seek ( int $offset [, int $whence = OCI_SEEK_SET ] )
bool setBuffering ( bool $on_off )
int size ( void )
int tell ( void )
bool truncate ([ int $length = 0 ] )
int write ( string $data [, int $length ] )
bool writeTemporary ( string $data [, int $lob_type = OCI_TEMP_CLOB ] )
}

İçindekiler

  • OCI-Lob::append — Appends data from the large object to another large object
  • OCI-Lob::close — Closes LOB descriptor
  • OCI-Lob::eof — Tests for end-of-file on a large object's descriptor
  • OCI-Lob::erase — Erases a specified portion of the internal LOB data
  • OCI-Lob::export — Exports LOB's contents to a file
  • OCI-Lob::flush — Flushes/writes buffer of the LOB to the server
  • OCI-Lob::free — Frees resources associated with the LOB descriptor
  • OCI-Lob::getBuffering — Returns current state of buffering for the large object
  • OCI-Lob::import — Imports file data to the LOB
  • OCI-Lob::load — Returns large object's contents
  • OCI-Lob::read — Reads part of the large object
  • OCI-Lob::rewind — Moves the internal pointer to the beginning of the large object
  • OCI-Lob::save — Saves data to the large object
  • OCI-Lob::saveFile — Takma Adı: OCI-Lob::import
  • OCI-Lob::seek — Sets the internal pointer of the large object
  • OCI-Lob::setBuffering — Changes current state of buffering for the large object
  • OCI-Lob::size — Returns size of large object
  • OCI-Lob::tell — Returns the current position of internal pointer of large object
  • OCI-Lob::truncate — Truncates large object
  • OCI-Lob::write — Writes data to the large object
  • OCI-Lob::writeTemporary — Writes a temporary large object
  • OCI-Lob::writeToFile — Takma Adı: OCI-Lob::export
OCI-Collection::trim
OCI-Lob::append
OCI8


Appends data from the large object to another large object

OCI-Lob
OCI-Lob::close
OCI-Lob
PHP Manual

OCI-Lob::append

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

OCI-Lob::append — Appends data from the large object to another large object

Açıklama

bool OCI-Lob::append ( OCI-Lob $lob_from )

Appends data from the large object to the end of another large object.

Writing to the large object with this method will fail if buffering was previously enabled. You must disable buffering before appending. You may need to flush buffers with OCI-Lob::flush before disabling buffering.

Değiştirgeler

lob_from

The copied LOB.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • OCI-Lob::flush
  • OCI-Lob::setBuffering
  • OCI-Lob::getBuffering

OCI-Lob
OCI-Lob::close
OCI-Lob


Closes LOB descriptor

OCI-Lob::append
OCI-Lob::eof
OCI-Lob
PHP Manual

OCI-Lob::close

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

OCI-Lob::close — Closes LOB descriptor

Açıklama

bool OCI-Lob::close ( void )

Closes descriptor of LOB or FILE. This function should be used only with OCI-Lob::writeTemporary.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • OCI-Lob::writeTemporary

OCI-Lob::append
OCI-Lob::eof
OCI-Lob


Tests for end-of-file on a large object's descriptor

OCI-Lob::close
OCI-Lob::erase
OCI-Lob
PHP Manual

OCI-Lob::eof

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

OCI-Lob::eof — Tests for end-of-file on a large object's descriptor

Açıklama

bool OCI-Lob::eof ( void )

Tells whether the internal pointer of large object is at the end of LOB.

Dönen Değerler

Returns TRUE if internal pointer of large object is at the end of LOB. Otherwise returns FALSE.

Notlar

Bilginize:

This function will return an Oracle error if OCI-Lob::setBuffering is enabled on the LOB.

Ayrıca Bakınız

  • OCI-Lob::size

OCI-Lob::close
OCI-Lob::erase
OCI-Lob


Erases a specified portion of the internal LOB data

OCI-Lob::eof
OCI-Lob::export
OCI-Lob
PHP Manual

OCI-Lob::erase

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

OCI-Lob::erase — Erases a specified portion of the internal LOB data

Açıklama

int OCI-Lob::erase ([ int $offset [, int $length ]] )

Erases a specified portion of the internal LOB data starting at a specified offset. If called without parameters, it erases all LOB data.

For BLOBs, erasing means that the existing LOB value is overwritten with zero-bytes. For CLOBs, the existing LOB value is overwritten with spaces.

Değiştirgeler

offset

length

Dönen Değerler

Returns the actual number of characters/bytes erased başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • OCI-Lob::truncate

OCI-Lob::eof
OCI-Lob::export
OCI-Lob


Exports LOB's contents to a file

OCI-Lob::erase
OCI-Lob::flush
OCI-Lob
PHP Manual

OCI-Lob::export

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

OCI-Lob::export — Exports LOB's contents to a file

Açıklama

bool OCI-Lob::export ( string $filename [, int $start [, int $length ]] )

Exports LOB contents to a file.

Değiştirgeler

filename

Path to the file.

start

Indicates from where to start exporting.

length

Indicates the length of data to be exported.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • OCI-Lob::import

OCI-Lob::erase
OCI-Lob::flush
OCI-Lob


Flushes/writes buffer of the LOB to the server

OCI-Lob::export
OCI-Lob::free
OCI-Lob
PHP Manual

OCI-Lob::flush

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

OCI-Lob::flush — Flushes/writes buffer of the LOB to the server

Açıklama

bool OCI-Lob::flush ([ int $flag ] )

OCI-Lob::flush() actually writes data to the server.

Değiştirgeler

flag

By default, resources are not freed, but using flag OCI_LOB_BUFFER_FREE you can do it explicitly. Be sure you know what you're doing - next read/write operation to the same part of LOB will involve a round-trip to the server and initialize new buffer resources. It is recommended to use OCI_LOB_BUFFER_FREE flag only when you are not going to work with the LOB anymore.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Returns FALSE if buffering was not enabled or an error occurred.

Ayrıca Bakınız

  • OCI-Lob::getBuffering
  • OCI-Lob::setBuffering

OCI-Lob::export
OCI-Lob::free
OCI-Lob


Frees resources associated with the LOB descriptor

OCI-Lob::flush
OCI-Lob::getBuffering
OCI-Lob
PHP Manual

OCI-Lob::free

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

OCI-Lob::free — Frees resources associated with the LOB descriptor

Açıklama

bool OCI-Lob::free ( void )

Frees resources associated with the descriptor, previously allocated with oci_new_descriptor().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

OCI-Lob::flush
OCI-Lob::getBuffering
OCI-Lob


Returns current state of buffering for the large object

OCI-Lob::free
OCI-Lob::import
OCI-Lob
PHP Manual

OCI-Lob::getBuffering

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

OCI-Lob::getBuffering — Returns current state of buffering for the large object

Açıklama

bool OCI-Lob::getBuffering ( void )

Tells whether the buffering for the large object is on or off.

Dönen Değerler

Returns FALSE if buffering for the large object is off and TRUE if buffering is used.

Ayrıca Bakınız

  • OCI-Lob::setBuffering

OCI-Lob::free
OCI-Lob::import
OCI-Lob


Imports file data to the LOB

OCI-Lob::getBuffering
OCI-Lob::load
OCI-Lob
PHP Manual

OCI-Lob::import

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

OCI-Lob::import — Imports file data to the LOB

Açıklama

bool OCI-Lob::import ( string $filename )

Writes data from the filename in to the current position of large object.

Değiştirgeler

filename

Path to the file.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • OCI-Lob::export
  • OCI-Lob::write

OCI-Lob::getBuffering
OCI-Lob::load
OCI-Lob


Returns large object's contents

OCI-Lob::import
OCI-Lob::read
OCI-Lob
PHP Manual

OCI-Lob::load

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

OCI-Lob::load — Returns large object's contents

Açıklama

string OCI-Lob::load ( void )

Returns large object's contents. As script execution is terminated when the memory_limit is reached, ensure that the LOB does not exceed this limit. In most cases it's recommended to use OCI-Lob::read instead.

Dönen Değerler

Returns the contents of the object, or FALSE on errors.

Ayrıca Bakınız

  • OCI-Lob::read

OCI-Lob::import
OCI-Lob::read
OCI-Lob


Reads part of the large object

OCI-Lob::load
OCI-Lob::rewind
OCI-Lob
PHP Manual

OCI-Lob::read

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

OCI-Lob::read — Reads part of the large object

Açıklama

string OCI-Lob::read ( int $length )

Reads length bytes from the current position of LOB's internal pointer.

Reading stops when length bytes have been read or end of the large object is reached. Internal pointer of the large object will be shifted on the amount of bytes read.

Değiştirgeler

length

The length of data to read, in bytes. Large values will be rounded down to 1 MB.

Dönen Değerler

Returns the contents as a string, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • OCI-Lob::load
  • OCI-Lob::write

OCI-Lob::load
OCI-Lob::rewind
OCI-Lob


Moves the internal pointer to the beginning of the large object

OCI-Lob::read
OCI-Lob::save
OCI-Lob
PHP Manual

OCI-Lob::rewind

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

OCI-Lob::rewind — Moves the internal pointer to the beginning of the large object

Açıklama

bool OCI-Lob::rewind ( void )

Sets the internal pointer to the beginning of the large object.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • OCI-Lob::seek
  • OCI-Lob::tell

OCI-Lob::read
OCI-Lob::save
OCI-Lob


Saves data to the large object

OCI-Lob::rewind
OCI-Lob::saveFile
OCI-Lob
PHP Manual

OCI-Lob::save

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

OCI-Lob::save — Saves data to the large object

Açıklama

bool OCI-Lob::save ( string $data [, int $offset ] )

Saves data to the large object.

Değiştirgeler

data

The data to be saved.

offset

Can be used to indicate offset from the beginning of the large object.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • OCI-Lob::write
  • OCI-Lob::import

OCI-Lob::rewind
OCI-Lob::saveFile
OCI-Lob


Takma Adı: OCI-Lob::import

OCI-Lob::save
OCI-Lob::seek
OCI-Lob
PHP Manual

OCI-Lob::saveFile

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

OCI-Lob::saveFile — Takma Adı: OCI-Lob::import()

Açıklama

Bu işlev şu işlevin takma adıdır: OCI-Lob::import().

OCI-Lob::save
OCI-Lob::seek
OCI-Lob


Sets the internal pointer of the large object

OCI-Lob::saveFile
OCI-Lob::setBuffering
OCI-Lob
PHP Manual

OCI-Lob::seek

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

OCI-Lob::seek — Sets the internal pointer of the large object

Açıklama

bool OCI-Lob::seek ( int $offset [, int $whence = OCI_SEEK_SET ] )

Sets the internal pointer of the large object.

Değiştirgeler

offset

Indicates the amount of bytes, on which internal pointer should be moved from the position, pointed by whence.

whence

May be one of:

  • OCI_SEEK_SET - sets the position equal to offset
  • OCI_SEEK_CUR - adds offset bytes to the current position
  • OCI_SEEK_END - adds offset bytes to the end of large object (use negative value to move to a position before the end of large object)

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • OCI-Lob::rewind
  • OCI-Lob::tell
  • OCI-Lob::eof

OCI-Lob::saveFile
OCI-Lob::setBuffering
OCI-Lob


Changes current state of buffering for the large object

OCI-Lob::seek
OCI-Lob::size
OCI-Lob
PHP Manual

OCI-Lob::setBuffering

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

OCI-Lob::setBuffering — Changes current state of buffering for the large object

Açıklama

bool OCI-Lob::setBuffering ( bool $on_off )

Sets the buffering for the large object, depending on the value of the on_off parameter.

Use of this function may provide performance improvements by buffering small reads and writes of LOBs by reducing the number of network round-trips and LOB versions. OCI-Lob::flush() should be used to flush buffers, when you have finished working with the large object.

Değiştirgeler

on_off

TRUE for on and FALSE for off.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. Repeated calls to this method with the same flag will return TRUE.

Ayrıca Bakınız

  • OCI-Lob::getBuffering

OCI-Lob::seek
OCI-Lob::size
OCI-Lob


Returns size of large object

OCI-Lob::setBuffering
OCI-Lob::tell
OCI-Lob
PHP Manual

OCI-Lob::size

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

OCI-Lob::size — Returns size of large object

Açıklama

int OCI-Lob::size ( void )

Gets the size of the large object.

Dönen Değerler

Returns length of large object value başarısızlık durumunda FALSE döner. Empty objects have zero length.

OCI-Lob::setBuffering
OCI-Lob::tell
OCI-Lob


Returns the current position of internal pointer of large object

OCI-Lob::size
OCI-Lob::truncate
OCI-Lob
PHP Manual

OCI-Lob::tell

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

OCI-Lob::tell — Returns the current position of internal pointer of large object

Açıklama

int OCI-Lob::tell ( void )

Gets the current position of a LOB's internal pointer.

Dönen Değerler

Returns current position of a LOB's internal pointer or FALSE if an error occurred.

Ayrıca Bakınız

  • OCI-Lob::rewind
  • OCI-Lob::size
  • OCI-Lob::eof

OCI-Lob::size
OCI-Lob::truncate
OCI-Lob


Truncates large object

OCI-Lob::tell
OCI-Lob::write
OCI-Lob
PHP Manual

OCI-Lob::truncate

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

OCI-Lob::truncate — Truncates large object

Açıklama

bool OCI-Lob::truncate ([ int $length = 0 ] )

Truncates the LOB.

Değiştirgeler

length

If provided, this method will truncate the LOB to length bytes. Otherwise, it will completely purge the LOB.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • OCI-Lob::erase

OCI-Lob::tell
OCI-Lob::write
OCI-Lob


Writes data to the large object

OCI-Lob::truncate
OCI-Lob::writeTemporary
OCI-Lob
PHP Manual

OCI-Lob::write

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

OCI-Lob::write — Writes data to the large object

Açıklama

int OCI-Lob::write ( string $data [, int $length ] )

Writes data from the parameter data into the current position of LOB's internal pointer.

Değiştirgeler

data

The data to write in the LOB.

length

If this parameter is given, writing will stop after length bytes have been written or the end of data is reached, whichever comes first.

Dönen Değerler

Returns the number of bytes written başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • OCI-Lob::read

OCI-Lob::truncate
OCI-Lob::writeTemporary
OCI-Lob


Writes a temporary large object

OCI-Lob::write
OCI-Lob::writeToFile
OCI-Lob
PHP Manual

OCI-Lob::writeTemporary

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

OCI-Lob::writeTemporary — Writes a temporary large object

Açıklama

bool OCI-Lob::writeTemporary ( string $data [, int $lob_type = OCI_TEMP_CLOB ] )

Creates a temporary large object and writes data to it.

You should use OCI-Lob::close when you are done with this object.

Değiştirgeler

data

The data to write.

lob_type

Can be one of the following:

  • OCI_TEMP_BLOB is used to create temporary BLOBs
  • OCI_TEMP_CLOB is used to create temporary CLOBs

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • OCI-Lob::close

OCI-Lob::write
OCI-Lob::writeToFile
OCI-Lob


Takma Adı: OCI-Lob::export

OCI-Lob::writeTemporary
OCI8 Obsolete Aliases and Functions
OCI-Lob
PHP Manual

OCI-Lob::writeToFile

(PHP 5, PHP 7, PECL OCI8 >= 1.1.0)

OCI-Lob::writeToFile — Takma Adı: OCI-Lob::export()

Açıklama

Bu işlev şu işlevin takma adıdır: OCI-Lob::export().

OCI-Lob::writeTemporary
OCI8 Obsolete Aliases and Functions
OCI-Lob


OCI8 Obsolete Aliases and Functions

İçindekiler

  • ocibindbyname — Takma Adı: oci_bind_by_name
  • ocicancel — Takma Adı: oci_cancel
  • ocicloselob — Takma Adı: OCI-Lob::close
  • ocicollappend — Takma Adı: OCI-Collection::append
  • ocicollassign — Takma Adı: OCI-Collection::assign
  • ocicollassignelem — Takma Adı: OCI-Collection::assignElem
  • ocicollgetelem — Takma Adı: OCI-Collection::getElem
  • ocicollmax — Takma Adı: OCI-Collection::max
  • ocicollsize — Takma Adı: OCI-Collection::size
  • ocicolltrim — Takma Adı: OCI-Collection::trim
  • ocicolumnisnull — Takma Adı: oci_field_is_null
  • ocicolumnname — Takma Adı: oci_field_name
  • ocicolumnprecision — Takma Adı: oci_field_precision
  • ocicolumnscale — Takma Adı: oci_field_scale
  • ocicolumnsize — Takma Adı: oci_field_size
  • ocicolumntype — Takma Adı: oci_field_type
  • ocicolumntyperaw — Takma Adı: oci_field_type_raw
  • ocicommit — Takma Adı: oci_commit
  • ocidefinebyname — Takma Adı: oci_define_by_name
  • ocierror — Takma Adı: oci_error
  • ociexecute — Takma Adı: oci_execute
  • ocifetch — Takma Adı: oci_fetch
  • ocifetchinto — Obsolete variant of oci_fetch_array, oci_fetch_object, oci_fetch_assoc and oci_fetch_row
  • ocifetchstatement — Takma Adı: oci_fetch_all
  • ocifreecollection — Takma Adı: OCI-Collection::free
  • ocifreecursor — Takma Adı: oci_free_statement
  • ocifreedesc — Takma Adı: OCI-Lob::free
  • ocifreestatement — Takma Adı: oci_free_statement
  • ociinternaldebug — Takma Adı: oci_internal_debug
  • ociloadlob — Takma Adı: OCI-Lob::load
  • ocilogoff — Takma Adı: oci_close
  • ocilogon — Takma Adı: oci_connect
  • ocinewcollection — Takma Adı: oci_new_collection
  • ocinewcursor — Takma Adı: oci_new_cursor
  • ocinewdescriptor — Takma Adı: oci_new_descriptor
  • ocinlogon — Takma Adı: oci_new_connect
  • ocinumcols — Takma Adı: oci_num_fields
  • ociparse — Takma Adı: oci_parse
  • ociplogon — Takma Adı: oci_pconnect
  • ociresult — Takma Adı: oci_result
  • ocirollback — Takma Adı: oci_rollback
  • ocirowcount — Takma Adı: oci_num_rows
  • ocisavelob — Takma Adı: OCI-Lob::save
  • ocisavelobfile — Takma Adı: OCI-Lob::import
  • ociserverversion — Takma Adı: oci_server_version
  • ocisetprefetch — Takma Adı: oci_set_prefetch
  • ocistatementtype — Takma Adı: oci_statement_type
  • ociwritelobtofile — Takma Adı: OCI-Lob::export
  • ociwritetemporarylob — Takma Adı: OCI-Lob::writeTemporary
OCI-Lob::writeToFile
ocibindbyname
OCI8


Takma Adı: oci_bind_by_name

OCI8 Obsolete Aliases and Functions
ocicancel
OCI8 Obsolete Aliases and Functions
PHP Manual

ocibindbyname

(PHP 4, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ocibindbyname — Takma Adı: oci_bind_by_name()

Açıklama

Takma Adı: oci_bind_by_name()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

OCI8 Obsolete Aliases and Functions
ocicancel
OCI8 Obsolete Aliases and Functions


Takma Adı: oci_cancel

ocibindbyname
ocicloselob
OCI8 Obsolete Aliases and Functions
PHP Manual

ocicancel

(PHP 4, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ocicancel — Takma Adı: oci_cancel()

Açıklama

Takma Adı: oci_cancel()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ocibindbyname
ocicloselob
OCI8 Obsolete Aliases and Functions


Takma Adı: OCI-Lob::close

ocicancel
ocicollappend
OCI8 Obsolete Aliases and Functions
PHP Manual

ocicloselob

(PHP 4 >= 4.0.6, PECL OCI8 1.0)

ocicloselob — Takma Adı: OCI-Lob::close()

Açıklama

Takma Adı: OCI-Lob::close()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ocicancel
ocicollappend
OCI8 Obsolete Aliases and Functions


Takma Adı: OCI-Collection::append

ocicloselob
ocicollassign
OCI8 Obsolete Aliases and Functions
PHP Manual

ocicollappend

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ocicollappend — Takma Adı: OCI-Collection::append()

Açıklama

Takma Adı: OCI-Collection::append()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ocicloselob
ocicollassign
OCI8 Obsolete Aliases and Functions


Takma Adı: OCI-Collection::assign

ocicollappend
ocicollassignelem
OCI8 Obsolete Aliases and Functions
PHP Manual

ocicollassign

(PHP 4 >= 4.0.6, PECL OCI8 1.0)

ocicollassign — Takma Adı: OCI-Collection::assign()

Açıklama

Takma Adı: OCI-Collection::assign()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ocicollappend
ocicollassignelem
OCI8 Obsolete Aliases and Functions


Takma Adı: OCI-Collection::assignElem

ocicollassign
ocicollgetelem
OCI8 Obsolete Aliases and Functions
PHP Manual

ocicollassignelem

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ocicollassignelem — Takma Adı: OCI-Collection::assignElem()

Açıklama

Takma Adı: OCI-Collection::assignElem()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ocicollassign
ocicollgetelem
OCI8 Obsolete Aliases and Functions


Takma Adı: OCI-Collection::getElem

ocicollassignelem
ocicollmax
OCI8 Obsolete Aliases and Functions
PHP Manual

ocicollgetelem

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ocicollgetelem — Takma Adı: OCI-Collection::getElem()

Açıklama

Takma Adı: OCI-Collection::getElem()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ocicollassignelem
ocicollmax
OCI8 Obsolete Aliases and Functions


Takma Adı: OCI-Collection::max

ocicollgetelem
ocicollsize
OCI8 Obsolete Aliases and Functions
PHP Manual

ocicollmax

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ocicollmax — Takma Adı: OCI-Collection::max()

Açıklama

Takma Adı: OCI-Collection::max()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ocicollgetelem
ocicollsize
OCI8 Obsolete Aliases and Functions


Takma Adı: OCI-Collection::size

ocicollmax
ocicolltrim
OCI8 Obsolete Aliases and Functions
PHP Manual

ocicollsize

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ocicollsize — Takma Adı: OCI-Collection::size()

Açıklama

Takma Adı: OCI-Collection::size()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ocicollmax
ocicolltrim
OCI8 Obsolete Aliases and Functions


Takma Adı: OCI-Collection::trim

ocicollsize
ocicolumnisnull
OCI8 Obsolete Aliases and Functions
PHP Manual

ocicolltrim

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ocicolltrim — Takma Adı: OCI-Collection::trim()

Açıklama

Takma Adı: OCI-Collection::trim()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ocicollsize
ocicolumnisnull
OCI8 Obsolete Aliases and Functions


Takma Adı: oci_field_is_null

ocicolltrim
ocicolumnname
OCI8 Obsolete Aliases and Functions
PHP Manual

ocicolumnisnull

(PHP 4, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ocicolumnisnull — Takma Adı: oci_field_is_null()

Açıklama

Takma Adı: oci_field_is_null()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ocicolltrim
ocicolumnname
OCI8 Obsolete Aliases and Functions


Takma Adı: oci_field_name

ocicolumnisnull
ocicolumnprecision
OCI8 Obsolete Aliases and Functions
PHP Manual

ocicolumnname

(PHP 4, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ocicolumnname — Takma Adı: oci_field_name()

Açıklama

Takma Adı: oci_field_name()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ocicolumnisnull
ocicolumnprecision
OCI8 Obsolete Aliases and Functions


Takma Adı: oci_field_precision

ocicolumnname
ocicolumnscale
OCI8 Obsolete Aliases and Functions
PHP Manual

ocicolumnprecision

(PHP 4, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ocicolumnprecision — Takma Adı: oci_field_precision()

Açıklama

Takma Adı: oci_field_precision()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ocicolumnname
ocicolumnscale
OCI8 Obsolete Aliases and Functions


Takma Adı: oci_field_scale

ocicolumnprecision
ocicolumnsize
OCI8 Obsolete Aliases and Functions
PHP Manual

ocicolumnscale

(PHP 4, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ocicolumnscale — Takma Adı: oci_field_scale()

Açıklama

Takma Adı: oci_field_scale()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ocicolumnprecision
ocicolumnsize
OCI8 Obsolete Aliases and Functions


Takma Adı: oci_field_size

ocicolumnscale
ocicolumntype
OCI8 Obsolete Aliases and Functions
PHP Manual

ocicolumnsize

(PHP 4, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ocicolumnsize — Takma Adı: oci_field_size()

Açıklama

Takma Adı: oci_field_size()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ocicolumnscale
ocicolumntype
OCI8 Obsolete Aliases and Functions


Takma Adı: oci_field_type

ocicolumnsize
ocicolumntyperaw
OCI8 Obsolete Aliases and Functions
PHP Manual

ocicolumntype

(PHP 4, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ocicolumntype — Takma Adı: oci_field_type()

Açıklama

Takma Adı: oci_field_type()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ocicolumnsize
ocicolumntyperaw
OCI8 Obsolete Aliases and Functions


Takma Adı: oci_field_type_raw

ocicolumntype
ocicommit
OCI8 Obsolete Aliases and Functions
PHP Manual

ocicolumntyperaw

(PHP 4, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ocicolumntyperaw — Takma Adı: oci_field_type_raw()

Açıklama

Takma Adı: oci_field_type_raw()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ocicolumntype
ocicommit
OCI8 Obsolete Aliases and Functions


Takma Adı: oci_commit

ocicolumntyperaw
ocidefinebyname
OCI8 Obsolete Aliases and Functions
PHP Manual

ocicommit

(PHP 4, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ocicommit — Takma Adı: oci_commit()

Açıklama

Takma Adı: oci_commit()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ocicolumntyperaw
ocidefinebyname
OCI8 Obsolete Aliases and Functions


Takma Adı: oci_define_by_name

ocicommit
ocierror
OCI8 Obsolete Aliases and Functions
PHP Manual

ocidefinebyname

(PHP 4, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ocidefinebyname — Takma Adı: oci_define_by_name()

Açıklama

Takma Adı: oci_define_by_name()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ocicommit
ocierror
OCI8 Obsolete Aliases and Functions


Takma Adı: oci_error

ocidefinebyname
ociexecute
OCI8 Obsolete Aliases and Functions
PHP Manual

ocierror

(PHP 4, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ocierror — Takma Adı: oci_error()

Açıklama

Takma Adı: oci_error()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ocidefinebyname
ociexecute
OCI8 Obsolete Aliases and Functions


Takma Adı: oci_execute

ocierror
ocifetch
OCI8 Obsolete Aliases and Functions
PHP Manual

ociexecute

(PHP 4, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ociexecute — Takma Adı: oci_execute()

Açıklama

Takma Adı: oci_execute()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ocierror
ocifetch
OCI8 Obsolete Aliases and Functions


Takma Adı: oci_fetch

ociexecute
ocifetchinto
OCI8 Obsolete Aliases and Functions
PHP Manual

ocifetch

(PHP 4, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ocifetch — Takma Adı: oci_fetch()

Açıklama

Takma Adı: oci_fetch()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ociexecute
ocifetchinto
OCI8 Obsolete Aliases and Functions


Obsolete variant of oci_fetch_array, oci_fetch_object, oci_fetch_assoc and oci_fetch_row

ocifetch
ocifetchstatement
OCI8 Obsolete Aliases and Functions
PHP Manual

ocifetchinto

(PHP 4, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ocifetchinto — Obsolete variant of oci_fetch_array(), oci_fetch_object(), oci_fetch_assoc() and oci_fetch_row()

Açıklama

Obsolete variant of oci_fetch_array(), oci_fetch_object(),
  oci_fetch_assoc() and
  oci_fetch_row()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ocifetch
ocifetchstatement
OCI8 Obsolete Aliases and Functions


Takma Adı: oci_fetch_all

ocifetchinto
ocifreecollection
OCI8 Obsolete Aliases and Functions
PHP Manual

ocifetchstatement

(PHP 4, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ocifetchstatement — Takma Adı: oci_fetch_all()

Açıklama

Takma Adı: oci_fetch_all()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ocifetchinto
ocifreecollection
OCI8 Obsolete Aliases and Functions


Takma Adı: OCI-Collection::free

ocifetchstatement
ocifreecursor
OCI8 Obsolete Aliases and Functions
PHP Manual

ocifreecollection

(PHP 4 >= 4.0.7, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ocifreecollection — Takma Adı: OCI-Collection::free()

Açıklama

Takma Adı: OCI-Collection::free()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ocifetchstatement
ocifreecursor
OCI8 Obsolete Aliases and Functions


Takma Adı: oci_free_statement

ocifreecollection
ocifreedesc
OCI8 Obsolete Aliases and Functions
PHP Manual

ocifreecursor

(PHP 4, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ocifreecursor — Takma Adı: oci_free_statement()

Açıklama

Takma Adı: oci_free_statement()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ocifreecollection
ocifreedesc
OCI8 Obsolete Aliases and Functions


Takma Adı: OCI-Lob::free

ocifreecursor
ocifreestatement
OCI8 Obsolete Aliases and Functions
PHP Manual

ocifreedesc

(PHP 4, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ocifreedesc — Takma Adı: OCI-Lob::free()

Açıklama

Takma Adı: OCI-Lob::free()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ocifreecursor
ocifreestatement
OCI8 Obsolete Aliases and Functions


Takma Adı: oci_free_statement

ocifreedesc
ociinternaldebug
OCI8 Obsolete Aliases and Functions
PHP Manual

ocifreestatement

(PHP 4, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ocifreestatement — Takma Adı: oci_free_statement()

Açıklama

Takma Adı: oci_free_statement()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ocifreedesc
ociinternaldebug
OCI8 Obsolete Aliases and Functions


Takma Adı: oci_internal_debug

ocifreestatement
ociloadlob
OCI8 Obsolete Aliases and Functions
PHP Manual

ociinternaldebug

(PHP 4, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ociinternaldebug — Takma Adı: oci_internal_debug()

Açıklama

Takma Adı: oci_internal_debug()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ocifreestatement
ociloadlob
OCI8 Obsolete Aliases and Functions


Takma Adı: OCI-Lob::load

ociinternaldebug
ocilogoff
OCI8 Obsolete Aliases and Functions
PHP Manual

ociloadlob

(PHP 4, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ociloadlob — Takma Adı: OCI-Lob::load()

Açıklama

Takma Adı: OCI-Lob::load()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ociinternaldebug
ocilogoff
OCI8 Obsolete Aliases and Functions


Takma Adı: oci_close

ociloadlob
ocilogon
OCI8 Obsolete Aliases and Functions
PHP Manual

ocilogoff

(PHP 4, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ocilogoff — Takma Adı: oci_close()

Açıklama

Takma Adı: oci_close()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ociloadlob
ocilogon
OCI8 Obsolete Aliases and Functions


Takma Adı: oci_connect

ocilogoff
ocinewcollection
OCI8 Obsolete Aliases and Functions
PHP Manual

ocilogon

(PHP 4, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ocilogon — Takma Adı: oci_connect()

Açıklama

Takma Adı: oci_connect()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ocilogoff
ocinewcollection
OCI8 Obsolete Aliases and Functions


Takma Adı: oci_new_collection

ocilogon
ocinewcursor
OCI8 Obsolete Aliases and Functions
PHP Manual

ocinewcollection

(PHP 4 >= 4.0.6, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ocinewcollection — Takma Adı: oci_new_collection()

Açıklama

Takma Adı: oci_new_collection()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ocilogon
ocinewcursor
OCI8 Obsolete Aliases and Functions


Takma Adı: oci_new_cursor

ocinewcollection
ocinewdescriptor
OCI8 Obsolete Aliases and Functions
PHP Manual

ocinewcursor

(PHP 4, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ocinewcursor — Takma Adı: oci_new_cursor()

Açıklama

Takma Adı: oci_new_cursor()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ocinewcollection
ocinewdescriptor
OCI8 Obsolete Aliases and Functions


Takma Adı: oci_new_descriptor

ocinewcursor
ocinlogon
OCI8 Obsolete Aliases and Functions
PHP Manual

ocinewdescriptor

(PHP 4, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ocinewdescriptor — Takma Adı: oci_new_descriptor()

Açıklama

Takma Adı: oci_new_descriptor()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ocinewcursor
ocinlogon
OCI8 Obsolete Aliases and Functions


Takma Adı: oci_new_connect

ocinewdescriptor
ocinumcols
OCI8 Obsolete Aliases and Functions
PHP Manual

ocinlogon

(PHP 4, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ocinlogon — Takma Adı: oci_new_connect()

Açıklama

Takma Adı: oci_new_connect()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ocinewdescriptor
ocinumcols
OCI8 Obsolete Aliases and Functions


Takma Adı: oci_num_fields

ocinlogon
ociparse
OCI8 Obsolete Aliases and Functions
PHP Manual

ocinumcols

(PHP 4, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ocinumcols — Takma Adı: oci_num_fields()

Açıklama

Takma Adı: oci_num_fields()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ocinlogon
ociparse
OCI8 Obsolete Aliases and Functions


Takma Adı: oci_parse

ocinumcols
ociplogon
OCI8 Obsolete Aliases and Functions
PHP Manual

ociparse

(PHP 4, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ociparse — Takma Adı: oci_parse()

Açıklama

Takma Adı: oci_parse()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ocinumcols
ociplogon
OCI8 Obsolete Aliases and Functions


Takma Adı: oci_pconnect

ociparse
ociresult
OCI8 Obsolete Aliases and Functions
PHP Manual

ociplogon

(PHP 4, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ociplogon — Takma Adı: oci_pconnect()

Açıklama

Takma Adı: oci_pconnect()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ociparse
ociresult
OCI8 Obsolete Aliases and Functions


Takma Adı: oci_result

ociplogon
ocirollback
OCI8 Obsolete Aliases and Functions
PHP Manual

ociresult

(PHP 4, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ociresult — Takma Adı: oci_result()

Açıklama

Takma Adı: oci_result()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ociplogon
ocirollback
OCI8 Obsolete Aliases and Functions


Takma Adı: oci_rollback

ociresult
ocirowcount
OCI8 Obsolete Aliases and Functions
PHP Manual

ocirollback

(PHP 4, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ocirollback — Takma Adı: oci_rollback()

Açıklama

Takma Adı: oci_rollback()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ociresult
ocirowcount
OCI8 Obsolete Aliases and Functions


Takma Adı: oci_num_rows

ocirollback
ocisavelob
OCI8 Obsolete Aliases and Functions
PHP Manual

ocirowcount

(PHP 4, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ocirowcount — Takma Adı: oci_num_rows()

Açıklama

Takma Adı: oci_num_rows()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ocirollback
ocisavelob
OCI8 Obsolete Aliases and Functions


Takma Adı: OCI-Lob::save

ocirowcount
ocisavelobfile
OCI8 Obsolete Aliases and Functions
PHP Manual

ocisavelob

(PHP 4, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ocisavelob — Takma Adı: OCI-Lob::save()

Açıklama

Takma Adı: OCI-Lob::save()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ocirowcount
ocisavelobfile
OCI8 Obsolete Aliases and Functions


Takma Adı: OCI-Lob::import

ocisavelob
ociserverversion
OCI8 Obsolete Aliases and Functions
PHP Manual

ocisavelobfile

(PHP 4, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ocisavelobfile — Takma Adı: OCI-Lob::import()

Açıklama

Takma Adı: OCI-Lob::import()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ocisavelob
ociserverversion
OCI8 Obsolete Aliases and Functions


Takma Adı: oci_server_version

ocisavelobfile
ocisetprefetch
OCI8 Obsolete Aliases and Functions
PHP Manual

ociserverversion

(PHP 4, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ociserverversion — Takma Adı: oci_server_version()

Açıklama

Takma Adı: oci_server_version()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ocisavelobfile
ocisetprefetch
OCI8 Obsolete Aliases and Functions


Takma Adı: oci_set_prefetch

ociserverversion
ocistatementtype
OCI8 Obsolete Aliases and Functions
PHP Manual

ocisetprefetch

(PHP 4, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ocisetprefetch — Takma Adı: oci_set_prefetch()

Açıklama

Takma Adı: oci_set_prefetch()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ociserverversion
ocistatementtype
OCI8 Obsolete Aliases and Functions


Takma Adı: oci_statement_type

ocisetprefetch
ociwritelobtofile
OCI8 Obsolete Aliases and Functions
PHP Manual

ocistatementtype

(PHP 4, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ocistatementtype — Takma Adı: oci_statement_type()

Açıklama

Takma Adı: oci_statement_type()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ocisetprefetch
ociwritelobtofile
OCI8 Obsolete Aliases and Functions


Takma Adı: OCI-Lob::export

ocistatementtype
ociwritetemporarylob
OCI8 Obsolete Aliases and Functions
PHP Manual

ociwritelobtofile

(PHP 4, PHP 5, PHP 7, PECL OCI8 >= 1.0.0)

ociwritelobtofile — Takma Adı: OCI-Lob::export()

Açıklama

Takma Adı: OCI-Lob::export()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ocistatementtype
ociwritetemporarylob
OCI8 Obsolete Aliases and Functions


Takma Adı: OCI-Lob::writeTemporary

ociwritelobtofile
Paradox
OCI8 Obsolete Aliases and Functions
PHP Manual

ociwritetemporarylob

(PHP 4 >= 4.0.6, PECL OCI8 1.0)

ociwritetemporarylob — Takma Adı: OCI-Lob::writeTemporary()

Açıklama

Takma Adı: OCI-Lob::writeTemporary()

Uyarı

Bu takma adın kullanımı PHP 5.4.0'dan beri ÖNERİLMEMEKTEDİR. Bu takma ada kesinlikle güvenmemelisiniz.

ociwritelobtofile
Paradox
OCI8 Obsolete Aliases and Functions


Paradox File Access

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Paradox İşlevleri
    • px_close — Closes a paradox database
    • px_create_fp — Create a new paradox database
    • px_date2string — Converts a date into a string.
    • px_delete_record — Deletes record from paradox database
    • px_delete — Deletes resource of paradox database
    • px_get_field — Returns the specification of a single field
    • px_get_info — Return lots of information about a paradox file
    • px_get_parameter — Gets a parameter
    • px_get_record — Returns record of paradox database
    • px_get_schema — Returns the database schema
    • px_get_value — Gets a value
    • px_insert_record — Inserts record into paradox database
    • px_new — Create a new paradox object
    • px_numfields — Returns number of fields in a database
    • px_numrecords — Returns number of records in a database
    • px_open_fp — Open paradox database
    • px_put_record — Stores record into paradox database
    • px_retrieve_record — Returns record of paradox database
    • px_set_blob_file — Sets the file where blobs are read from
    • px_set_parameter — Sets a parameter
    • px_set_tablename — Sets the name of a table (deprecated)
    • px_set_targetencoding — Sets the encoding for character fields (deprecated)
    • px_set_value — Sets a value
    • px_timestamp2string — Converts the timestamp into a string.
    • px_update_record — Updates record in paradox database
ociwritetemporarylob
Giriş
Sağlayıcıya Göre Veritabanı Eklentileri


Giriş

This module allows to read and write Paradox databases, primary index files and blob files. Write support has been proven to be quite reliable, though due to lack of documentation the produced files may not in any case be readable by other applications. Encrypted databases can be read without specifying a password if pxlib >= 0.5.0 is used.

Bilginize:

This module is also in development and may change, though major changes to the API are not expected.

Uyarı

Bu eklenti DENEYSELDİR. Bu eklentinin davranışı, işlev isimleri ve tüm belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu eklentiyi kullanmayın.

Paradox
Yapılandırma/Kurulum
Paradox


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Paradox


Gereksinimler

You need at least PHP 5.0.0 and pxlib >= 0.4.4 for the basic set of functions. Some newer functions are only available with pxlib >= 0.6.0. Reading and writing of encrypted databases requires at least pxlib >= 0.5.0. The paradox library (pxlib) is available at » http://pxlib.sourceforge.net.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/paradox

Make sure you have pxlib installed before. If you install pxlib from an rpm or debian package, do not forget to install the development package as well.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Özkaynak Türleri

px_new() creates a new Paradox object required by all Paradox functions.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

The following two tables lists all constants defined by the paradox extension.

Contants for field types
Name | Meaning
PX_FIELD_ALPHA | Character data with fixed length
PX_FIELD_DATE | Date, number of days since 1.1.0000
PX_FIELD_SHORT | Short integer (2 Bytes)
PX_FIELD_LONG | Long integer (4 Bytes)
PX_FIELD_CURRENCY | same as PX_FIELD_NUMBER
PX_FIELD_NUMBER | Double
PX_FIELD_LOGICAL | Boolean
PX_FIELD_MEMOBLOB | Binary large object
PX_FIELD_BLOB | Binary large object (not supported)
PX_FIELD_FMTMEMOBLOB | Binary large object
PX_FIELD_OLE | OLE object (basically a blob, not supported)
PX_FIELD_GRAPHIC | Graphic (basically a blob, not supported)
PX_FIELD_TIME | time, number of milli seconds since midnight
PX_FIELD_TIMESTAMP | timestamp, number of milli seconds since 1.1.0000
PX_FIELD_AUTOINC | Auto incrementing interger (like PX_FIELD_LONG)
PX_FIELD_BCD | Decimal number stored in bcd format (not supported)
PX_FIELD_BYTES | Array of Bytes with not more than 255 bytes (not supported)
PX_KEYTOLOWER | Turn all field names into lower case
PX_KEYTOUPPER | Turn all field names into upper case
Contants for file types
Name | Meaning
PX_FILE_INDEX_DB | Indexed database
PX_FILE_PRIM_INDEX | Primary index
PX_FILE_NON_INDEX_DB | None indexed database
PX_FILE_NON_INC_SEC_INDEX | None incremental secondary index
PX_FILE_SEC_INDEX | Secondary index
PX_FILE_INC_SEC_INDEX | Incremental secondary index
PX_FILE_NON_INC_SEC_INDEX_G | Non incremental secondary index
PX_FILE_SEC_INDEX_G | Secondary index
PX_FILE_INC_SEC_INDEX_G | Non incremental secondary index

Özkaynak Türleri
Paradox İşlevleri
Paradox


Paradox İşlevleri

Object oriented API

The paradox extension provides also an object oriented API. It consists of only one class called paradox_db. Its methods only differ from the functions in its name and of course the missing first parameter. The following table will list all methods and its equivalent functions.

Methods of class paradox_db
Name of method | Equivalent function
Constructor | px_new()
Destructor | px_delete()
open_fp() | px_open_fp()
create_fp() | px_create_fp()
close() | px_close()
numrecords() | px_numrecords()
numfields() | px_numfields()
get_record() | px_get_record()
put_record() | px_put_record()
retrieve_record() | px_retrieve_record()
delete_record() | px_delete_record()
insert_record() | px_insert_record()
update_record() | px_update_record()
get_field() | px_get_field()
get_schema() | px_get_schema()
get_info() | px_get_info()
set_parameter() | px_set_parameter()
get_parameter() | px_get_parameter()
set_value() | px_set_value()
get_value() | px_get_value()
get_info() | px_get_info()
set_targetencoding() | px_set_targetencoding()
set_tablename() | px_set_tablename()
set_blob_file() | px_set_blob_file()
date2string() | px_date2string()
timestamp2string() | px_timestamp2string()

İçindekiler

  • px_close — Closes a paradox database
  • px_create_fp — Create a new paradox database
  • px_date2string — Converts a date into a string.
  • px_delete_record — Deletes record from paradox database
  • px_delete — Deletes resource of paradox database
  • px_get_field — Returns the specification of a single field
  • px_get_info — Return lots of information about a paradox file
  • px_get_parameter — Gets a parameter
  • px_get_record — Returns record of paradox database
  • px_get_schema — Returns the database schema
  • px_get_value — Gets a value
  • px_insert_record — Inserts record into paradox database
  • px_new — Create a new paradox object
  • px_numfields — Returns number of fields in a database
  • px_numrecords — Returns number of records in a database
  • px_open_fp — Open paradox database
  • px_put_record — Stores record into paradox database
  • px_retrieve_record — Returns record of paradox database
  • px_set_blob_file — Sets the file where blobs are read from
  • px_set_parameter — Sets a parameter
  • px_set_tablename — Sets the name of a table (deprecated)
  • px_set_targetencoding — Sets the encoding for character fields (deprecated)
  • px_set_value — Sets a value
  • px_timestamp2string — Converts the timestamp into a string.
  • px_update_record — Updates record in paradox database
Öntanımlı Sabitler
px_close
Paradox


Closes a paradox database

Paradox İşlevleri
px_create_fp
Paradox İşlevleri
PHP Manual

px_close

(PECL paradox >= 1.0.0)

px_close — Closes a paradox database

Açıklama

bool px_close ( resource $pxdoc )

Closes the paradox database. This function will not close the file. You will have to call fclose() afterwards.

Değiştirgeler

pxdoc

Resource identifier of the paradox database as returned by px_new().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • px_open_fp() - Open paradox database
  • The example at px_new() - Create a new paradox object

Paradox İşlevleri
px_create_fp
Paradox İşlevleri


Create a new paradox database

px_close
px_date2string
Paradox İşlevleri
PHP Manual

px_create_fp

(PECL paradox >= 1.0.0)

px_create_fp — Create a new paradox database

Açıklama

bool px_create_fp ( resource $pxdoc , resource $file , array $fielddesc )

Create a new paradox database file. The actual file has to be opened before with fopen(). Make sure the file is writable.

Bilginize:

Calling this functions issues a warning about an empty tablename which can be safely ignored. Just set the tablename afterwards with px_set_parameter().

Bilginize:

This function is highly experimental, due to insufficient documentation of the paradox file format. Database files created with this function can be opened by px_open_fp() and has been successfully opened by the Paradox software, but your milage may vary.

Değiştirgeler

pxdoc

Resource identifier of the paradox database as returned by px_new().

file

File handle as returned by fopen().

fielddesc

fielddesc is an array containing one element for each field specification. A field specification is an array itself with either two or three elements.The first element is always a string value used as the name of the field. It may not be larger than ten characters. The second element contains the field type which is one of the constants listed in the table Constants for field types. In the case of a character field or bcd field, you will have to provide a third element specifying the length respectively the precesion of the field. If your field specification contains blob fields, you will have to make sure to either make the field large enough for all field values to fit or specify a blob file with px_set_blob_file() for storing the blobs. If this is not done the field data is truncated.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Creating a Paradox database with two fields

<?php
if(!$pxdoc = px_new()) {
  /* Error handling */
}
$fp = fopen("test.db", "w+");
$fields = array(array("col1", "S"), array("col2", "I"));
if(!px_create_fp($pxdoc, $fp, $fields)) {
  /* Error handling */
}
px_set_parameter($pxdoc, "tablename", "testtable");
for($i=-50; $i<50; $i++) {
  $rec = array($i, -$i);
  px_put_record($pxdoc, $rec);
}
px_close($pxdoc);
px_delete($pxdoc);
fclose($fp);
?>

Ayrıca Bakınız

  • px_new() - Create a new paradox object
  • px_put_record() - Stores record into paradox database
  • fopen() - Bir dosya veya URL'yi açar

px_close
px_date2string
Paradox İşlevleri


Converts a date into a string.

px_create_fp
px_delete_record
Paradox İşlevleri
PHP Manual

px_date2string

(PECL paradox >= 1.4.0)

px_date2string — Converts a date into a string.

Açıklama

string px_date2string ( resource $pxdoc , int $value , string $format )

Turns a date as it stored in the paradox file into human readable format. Paradox dates are the number of days since 1.1.0000. This function is just for convenience. It can be easily replaced by some math and the calendar functions as demonstrated in the example below.

Değiştirgeler

pxdoc

Resource identifier of the paradox database as returned by px_new().

value

Value as stored in paradox database field of type PX_FIELD_DATE.

format

String format similar to the format used by date(). The placeholders support by this function is a subset of those supported by date() (Y, y, m, n, d, j, L).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Turn a paradox date into a human readable form

<?php
$px = px_new();

/* make up a date as it could be stored in */
/* a date field of a paradox db. */
/* 700000 days since 1.1.0000. */
$days = 700000;

/* Use the calendar functions to print a */
/* human readable format of the date */
echo jdtogregorian($days+1721425)."\n";
/* px_date2string() outputs the same */
echo px_date2string($px, $days, "n/d/Y")."\n";

px_delete($px);
?>

Yukarıdaki örneğin çıktısı:

7/15/1917
7/15/1917

Ayrıca Bakınız

  • px_timestamp2string() - Converts the timestamp into a string.
  • jdtogregorian() - Jülyen Gün Sayısını, Gregoryen tarihine çevirir

px_create_fp
px_delete_record
Paradox İşlevleri


Deletes record from paradox database

px_date2string
px_delete
Paradox İşlevleri
PHP Manual

px_delete_record

(PECL paradox >= 1.4.0)

px_delete_record — Deletes record from paradox database

Açıklama

bool px_delete_record ( resource $pxdoc , int $num )

This function deletes a record from the database. It does not free the space in the database file but just marks it as deleted. Inserting a new record afterwards will reuse the space.

Bilginize:

This function is only available if pxlib >= 0.6.0 is used.

Değiştirgeler

pxdoc

Resource identifier of the paradox database as returned by px_new().

num

The record number is an artificial number counting records in the order as they are stored in the database. The first record has number 0.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

px_date2string
px_delete
Paradox İşlevleri


Deletes resource of paradox database

px_delete_record
px_get_field
Paradox İşlevleri
PHP Manual

px_delete

(PECL paradox >= 1.0.0)

px_delete — Deletes resource of paradox database

Açıklama

bool px_delete ( resource $pxdoc )

Deletes the resource of the paradox file and frees all memory.

Değiştirgeler

pxdoc

Resource identifier of the paradox database as returned by px_new().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

px_delete_record
px_get_field
Paradox İşlevleri


Returns the specification of a single field

px_delete
px_get_info
Paradox İşlevleri
PHP Manual

px_get_field

(PECL paradox >= 1.0.0)

px_get_field — Returns the specification of a single field

Açıklama

array px_get_field ( resource $pxdoc , int $fieldno )

Değiştirgeler

pxdoc

Resource identifier of the paradox database as returned by px_new().

fieldno

Number of the field. The first field has number 0. Specifying a field number less than 0 and greater or equal the number of fields will trigger an error.

Dönen Değerler

Returns the specification of the fieldno 'th database field as an associated array. The array contains three fields named name, type, and size.

px_delete
px_get_info
Paradox İşlevleri


Return lots of information about a paradox file

px_get_field
px_get_parameter
Paradox İşlevleri
PHP Manual

px_get_info

(PECL paradox >= 1.0.0)

px_get_info — Return lots of information about a paradox file

Açıklama

array px_get_info ( resource $pxdoc )

Değiştirgeler

pxdoc

Resource identifier of the paradox database as returned by px_new().

Dönen Değerler

Returns an associated array with lots of information about a paradox file. This array is likely to be extended in the future.

fileversion

Version of file multiplied by 10, e.g. 70.

tablename

Name of table as stored in the file. If the database was created by pxlib, then this will be the name of the file without the extension.

numrecords

Number of records in this table.

numfields

Number of fields in this table.

headersize

Number of bytes used for the header. This is usually 0x800.

recordsize

Number of bytes used for each record. This is the sum of all field sizes (available since version 1.4.2).

maxtablesize

This value multiplied by 0x400 is the size of a data block in bytes. The maximum number of records in a datablock is the integer part of (maxtablesize * 0x400 - 8) / recordsize.

numdatablocks

The number of data blocks in the file. Each data block contains a certain number of records which depends on the record size and the data block size (maxtablesize). Data blocks may not necessarily be completely filled.

numindexfields

Number of fields used for the primary index. The fields do always start with field number 1.

codepage

The DOS codepage which was used for encoding fields with character data. If the target encoding is not set with px_set_targetencoding() this will be the encoding for character fields when records are being accessed with px_get_record() or px_retrieve_record().

Ayrıca Bakınız

  • px_numfields() - Returns number of fields in a database
  • px_numrecords() - Returns number of records in a database

px_get_field
px_get_parameter
Paradox İşlevleri


Gets a parameter

px_get_info
px_get_record
Paradox İşlevleri
PHP Manual

px_get_parameter

(PECL paradox >= 1.1.0)

px_get_parameter — Gets a parameter

Açıklama

string px_get_parameter ( resource $pxdoc , string $name )

Gets various parameters.

Değiştirgeler

pxdoc

Resource identifier of the paradox database as returned by px_new().

name

The name can be one of the following:

tablename

The name of the table as it will be stored in the database header.

targetencoding

The encoding for the output. Data which is being read from character fields with px_get_record() or px_retrieve_record() is recoded into the targetencoding. If it is not set, then the data will be delivered as stored in the database file.

inputencoding

The encoding of the input data which is to be stored into the database. When storing data of character fields in the database, the data is expected to be delivered in this encoding.

Dönen Değerler

Returns the value of the parameter başarısızlık durumunda FALSE döner.

px_get_info
px_get_record
Paradox İşlevleri


Returns record of paradox database

px_get_parameter
px_get_schema
Paradox İşlevleri
PHP Manual

px_get_record

(PECL paradox >= 1.0.0)

px_get_record — Returns record of paradox database

Açıklama

array px_get_record ( resource $pxdoc , int $num [, int $mode = 0 ] )

Değiştirgeler

pxdoc

Resource identifier of the paradox database as returned by px_new().

num

The record number is an artificial number counting records in the order as they are stored in the database. The first record has number 0.

mode

The optional mode can be PX_KEYTOLOWER or PX_KEYTOUPPER in order to convert the keys of the returned array into lower or upper case. If mode is not passed or is 0, then the key will be exactly like the field name. The element values will contain the field values. NULL values will be retained and are different from 0.0, 0 or the empty string. Fields of type PX_FIELD_TIME will be returned as an integer counting the number of milliseconds starting at midnight. A timestamp (PX_FIELD_TIMESTAMP) and date (PX_FIELD_DATE) are floating point respectively int values counting milliseconds respectively days starting at the beginning of julian calendar. Use the functions px-timestamp2string() and px-date2string() to convert them into a character representation.

Dönen Değerler

Returns the num'th record from the paradox database. The record is returned as an associated array with its keys being the field names.

Ayrıca Bakınız

  • px_retrieve_record() - Returns record of paradox database

px_get_parameter
px_get_schema
Paradox İşlevleri


Returns the database schema

px_get_record
px_get_value
Paradox İşlevleri
PHP Manual

px_get_schema

(PECL paradox >= 1.0.0)

px_get_schema — Returns the database schema

Açıklama

array px_get_schema ( resource $pxdoc [, int $mode = 0 ] )

px_get_schema() returns the database schema.

Değiştirgeler

pxdoc

Resource identifier of the paradox database as returned by px_new().

mode

If the optional mode is PX_KEYTOLOWER or PX_KEYTOUPPER the keys of the returned array will be converted to lower or upper case. If mode is 0 or not passed at all, then the key name will be identical to the field name.

Dönen Değerler

Returns the schema of a database file as an associated array. The key name is equal to the field name. Each array element is itself an associated array containing the two fields type and size. type is one of the constants in table Constants for field types. size is the number of bytes this field consumes in the record. The total of all field sizes is equal to the record size as it can be retrieved with px-get-info().

px_get_record
px_get_value
Paradox İşlevleri


Gets a value

px_get_schema
px_insert_record
Paradox İşlevleri
PHP Manual

px_get_value

(PECL paradox >= 1.1.0)

px_get_value — Gets a value

Açıklama

float px_get_value ( resource $pxdoc , string $name )

Gets various values.

Değiştirgeler

pxdoc

Resource identifier of the paradox database as returned by px_new().

name

name can be one of the following.

numprimkeys

The number of primary keys. Paradox databases always use the first numprimkeys fields for the primary index.

Dönen Değerler

Returns the value of the parameter başarısızlık durumunda FALSE döner.

px_get_schema
px_insert_record
Paradox İşlevleri


Inserts record into paradox database

px_get_value
px_new
Paradox İşlevleri
PHP Manual

px_insert_record

(PECL paradox >= 1.4.0)

px_insert_record — Inserts record into paradox database

Açıklama

int px_insert_record ( resource $pxdoc , array $data )

Inserts a new record into the database. The record is not necessarily inserted at the end of the database, but may be inserted at any position depending on where the first free slot is found.

The record data is passed as an array of field values. The elements in the array must correspond to the fields in the database. If the array has less elements than fields in the database, the remaining fields will be set to null.

Most field values can be passed as its equivalent php type e.g. a long value is used for fields of type PX_FIELD_LONG, PX_FIELD_SHORT and PX_FIELD_AUTOINC, a double values is used for fields of type PX_FIELD_CURRENCY and PX_FIELD_NUMBER. Field values for blob and alpha fields are passed as strings.

Fields of type PX_FIELD_TIME and PX_FIELD_DATE both require a long value. In the first case this is the number of milliseconds since midnight. In the second case this is the number of days since 1.1.0000. Below there are two examples to convert the current date or timestamp into a value suitable for one of paradox's date/time fields.

Bilginize:

This function is only available if pxlib >= 0.6.0 is used.

Değiştirgeler

pxdoc

Resource identifier of the paradox database as returned by px_new().

data

Associated or indexed array containing the field values as e.g. returned by px_retrieve_record().

Dönen Değerler

Returns FALSE on failure or the record number in case of success.

Örnekler

Örnek 1 Set the date/time fields in a paradox database to the current date/time

<?php
$px = px_new();
$fp = fopen("test.db", "w+");
px_create_fp($px, $fp, array(array("timestamp", "@"), array("time", "T"), array("date", "D")));

$curdate = getdate();
$jd = gregoriantojd($curdate["mon"], $curdate["mday"], $curdate["year"]);
$days = $jd - 1721425; /* Number of days between 1.1.4714 b.c. and 1.1.0000 */
$secs = $curdate["hours"]*3600 + $curdate["minutes"]*60 + $curdate["seconds"];
px_insert_record($px, array($days*86400000.0 + $secs*1000.0, $secs*1000.0, $days));

$curtimestamp = microtime(true);
$days = (int) ($curtimestamp/86400);
$secs = $curtimestamp - ($days * 86400.0);
$days += 2440588; /* Number of days between 1.1.4714 b.c. and 1.1.1970 */
$days -= 1721425; /* Number of days between 1.1.4714 b.c. and 1.1.0000 */
px_insert_record($px, array($days*86400000.0 + $secs*1000.0, $secs*1000.0, $days));
for($i=0; $i<2; $i++) {
    $rec = px_retrieve_record($px, $i);
    echo px_timestamp2string($px, $rec["timestamp"], "n/d/Y H:i:s")."\n";
    echo px_date2string($px, $rec["date"], "n/d/Y")."\n";
}
px_close($px);
px_delete($px);
?>

Yukarıdaki örneğin çıktısı:

2/21/2006 21:42:30
2/21/2006
2/21/2006 20:42:30
2/21/2006

The Julian day count as passed to jdtogregorian() has a different base of 1.1.4714 b.c. and must therefore be calculated by adding 1721425 to the day count used in the paradox file. Turning the day count into a timestamp is easily done by multiplying with 86400000.0 to obtain milli seconds.

Ayrıca Bakınız

px_update_record() - Updates record in paradox database

px_get_value
px_new
Paradox İşlevleri


Create a new paradox object

px_insert_record
px_numfields
Paradox İşlevleri
PHP Manual

px_new

(PECL paradox >= 1.0.0)

px_new — Create a new paradox object

Açıklama

resource px_new ( void )

Create a new paradox object. You will have to call this function before any further functions. px_new() does not create any file on the disk, it just creates an instance of a paradox object. This function must not be called if the object oriented interface is used. Use new paradox_db() instead.

Dönen Değerler

Returns FALSE on failure.

Örnekler

Örnek 1 Opening a Paradox database

<?php
if(!$pxdoc = px_new()) {
  /* Error handling */
}
$fp = fopen("test.db", "r");
if(!px_open_fp($pxdoc, $fp)) {
  /* Error handling */
}
// ...
px_close($pxdoc);
px_delete($pxdoc);
fclose($fp);
?>

If you prefer the object oriented API, then the above example will look like the following.

Örnek 2 Opening a Paradox database

<?php
$fp = fopen("test.db", "r");
$pxdoc = new paradox_db();
if(!$pxdoc->open_fp($fp)) {
  /* Error handling */
}
// ...
$pxdoc->close();
fclose($fp);
?>

Ayrıca Bakınız

  • px_delete() - Deletes resource of paradox database
  • px_open_fp() - Open paradox database

px_insert_record
px_numfields
Paradox İşlevleri


Returns number of fields in a database

px_new
px_numrecords
Paradox İşlevleri
PHP Manual

px_numfields

(PECL paradox >= 1.0.0)

px_numfields — Returns number of fields in a database

Açıklama

int px_numfields ( resource $pxdoc )

Get the number of fields in a database file.

Değiştirgeler

pxdoc

Resource identifier of the paradox database as returned by px_new().

Dönen Değerler

Returns the number of fields in a database file. The return value of this function is identical to the element numfields in the array returned by px_get_info().

px_new
px_numrecords
Paradox İşlevleri


Returns number of records in a database

px_numfields
px_open_fp
Paradox İşlevleri
PHP Manual

px_numrecords

(PECL paradox >= 1.0.0)

px_numrecords — Returns number of records in a database

Açıklama

int px_numrecords ( resource $pxdoc )

Get the number of records in a database file.

Değiştirgeler

pxdoc

Resource identifier of the paradox database as returned by px_new().

Dönen Değerler

Returns the number of records in a database file. The return value of this function is identical to the element numrecords in the array returned by px_get_info().

px_numfields
px_open_fp
Paradox İşlevleri


Open paradox database

px_numrecords
px_put_record
Paradox İşlevleri
PHP Manual

px_open_fp

(PECL paradox >= 1.0.0)

px_open_fp — Open paradox database

Açıklama

bool px_open_fp ( resource $pxdoc , resource $file )

Open an existing paradox database file. The actual file has to be opened before with fopen(). This function can also be used to open primary index files and tread them like a paradox database. This is supported for those who would like to investigate a primary index. It cannot be used to accelerate access to a database file.

Değiştirgeler

pxdoc

Resource identifier of the paradox database as returned by px_new().

file

file is the return value from fopen() with the actual database file as parameter. Make sure the database is writable if you plan to update or insert records.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • fopen() - Bir dosya veya URL'yi açar
  • The example at px_new() - Create a new paradox object

px_numrecords
px_put_record
Paradox İşlevleri


Stores record into paradox database

px_open_fp
px_retrieve_record
Paradox İşlevleri
PHP Manual

px_put_record

(PECL paradox >= 1.0.0)

px_put_record — Stores record into paradox database

Açıklama

bool px_put_record ( resource $pxdoc , array $record [, int $recpos = -1 ] )

Stores a record into a paradox database. The record is always added at the end of the database, regardless of any free slots. Use px_insert_record() to add a new record into the first free slot found in the database.

Değiştirgeler

pxdoc

Resource identifier of the paradox database as returned by px_new().

record

Associated or indexed array containing the field values as e.g. returned by px_retrieve_record().

recpos

This optional parameter may be used to specify a record number greater than the current number of records in the database. The function will add as many empty records as needed. There is hardly any need for this parameter.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

px_open_fp
px_retrieve_record
Paradox İşlevleri


Returns record of paradox database

px_put_record
px_set_blob_file
Paradox İşlevleri
PHP Manual

px_retrieve_record

(PECL paradox >= 1.4.0)

px_retrieve_record — Returns record of paradox database

Açıklama

array px_retrieve_record ( resource $pxdoc , int $num [, int $mode = 0 ] )

This function is very similar to px_get_record() but uses internally a different approach to retrieve the data. It relies on pxlib for reading each single field value, which usually results in support for more field types.

Bilginize:

This function is only available if pxlib >= 0.6.0 is used.

Değiştirgeler

pxdoc

Resource identifier of the paradox database as returned by px_new().

num

The record number is an artificial number counting records in the order as they are stored in the database. The first record has number 0.

mode

The optional mode can be PX_KEYTOLOWER or PX_KEYTOUPPER in order to convert the keys into lower or upper case. If mode is not passed or is 0, then the key will be exactly like the field name. The element values will contain the field values. NULL values will be retained and are different from 0.0, 0 or the empty string. Fields of type PX_FIELD_TIME will be returned as an integer counting the number of milliseconds starting at midnight. A timestamp is a floating point value also counting milliseconds starting at the beginning of julian calendar.

Dönen Değerler

Returns the num'th record from the paradox database. The record is returned as an associated array with its keys being the field names.

Ayrıca Bakınız

  • px_get_record() - Returns record of paradox database

px_put_record
px_set_blob_file
Paradox İşlevleri


Sets the file where blobs are read from

px_retrieve_record
px_set_parameter
Paradox İşlevleri
PHP Manual

px_set_blob_file

(PECL paradox >= 1.3.0)

px_set_blob_file — Sets the file where blobs are read from

Açıklama

bool px_set_blob_file ( resource $pxdoc , string $filename )

Sets the name of the file where blobs are going to be read from or written into. Without calling this function, px_get_record() or px_retrieve_record() will only return data in blob fields if the data is part of the record and not stored in the blob file. Blob data is stored in the record if it is small enough to fit in the size of the blob field.

Calling px_put_record(),
px_insert_record(), or
px_update_record() without calling
px_set_blob_file() will result in truncated blob fields
unless the data fits into the database file.

Calling this function twice will close the first blob file and open the new one.

Değiştirgeler

pxdoc

Resource identifier of the paradox database as returned by px_new().

filename

The name of the file. Its extension should be .MB.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

px_retrieve_record
px_set_parameter
Paradox İşlevleri


Sets a parameter

px_set_blob_file
px_set_tablename
Paradox İşlevleri
PHP Manual

px_set_parameter

(PECL paradox >= 1.1.0)

px_set_parameter — Sets a parameter

Açıklama

bool px_set_parameter ( resource $pxdoc , string $name , string $value )

Sets various parameters.

Değiştirgeler

pxdoc

Resource identifier of the paradox database as returned by px_new().

name

Depending on the parameter you want to set, name can be one of the following.

tablename

The name of the table as it will be stored in the database header.

targetencoding

The encoding for the output. Data which is being read from character fields is recoded into the targetencoding.

inputencoding

The encoding of the input data which is to be stored into the database.

value

The value of parameter to set. For inputencoding and targetencoding this must be the name of the encoding as understood by iconv or recode, e.g. iso-8859-1, utf-8, cp850.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • px_get_info() - Return lots of information about a paradox file to determine the DOS code page.

px_set_blob_file
px_set_tablename
Paradox İşlevleri


Sets the name of a table (deprecated)

px_set_parameter
px_set_targetencoding
Paradox İşlevleri
PHP Manual

px_set_tablename

(PECL paradox >= 1.0.0)

px_set_tablename — Sets the name of a table (deprecated)

Açıklama

void px_set_tablename ( resource $pxdoc , string $name )

Sets the table name of a paradox database, which was created with px_create_fp(). This function is deprecated use px_set_parameter() instead.

Değiştirgeler

pxdoc

Resource identifier of the paradox database as returned by px_new().

tablename

The name of the table. If it is not set explicitly it will be set to the name of the database file.

Dönen Değerler

Returns NULL on success başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

px_set_parameter() - Sets a parameter

px_set_parameter
px_set_targetencoding
Paradox İşlevleri


Sets the encoding for character fields (deprecated)

px_set_tablename
px_set_value
Paradox İşlevleri
PHP Manual

px_set_targetencoding

(PECL paradox >= 1.0.0)

px_set_targetencoding — Sets the encoding for character fields (deprecated)

Açıklama

bool px_set_targetencoding ( resource $pxdoc , string $encoding )

Set the encoding for data retrieved from a character field. All character fields will be recoded to the encoding set by this function. If the encoding is not set, the character data will be returned in the DOS code page encoding as specified in the database file. The encoding can be any string identifier known to iconv or recode. On Unix systems run iconv -l for a list of available encodings.

This function is deprecated and should be replaced by calling px_set_parameter().

See also px_get_info() to determine the DOS code page as stored in the database file.

Değiştirgeler

pxdoc

Resource identifier of the paradox database as returned by px_new().

encoding

The encoding for the output. Data which is being read from character fields is recoded into the targetencoding.

Dönen Değerler

Returns FALSE if the encoding could not be set, e.g. the encoding is unknown, or pxlib does not support recoding at all. In the second case a warning will be issued.

Ayrıca Bakınız

px_set_parameter() - Sets a parameter

px_set_tablename
px_set_value
Paradox İşlevleri


Sets a value

px_set_targetencoding
px_timestamp2string
Paradox İşlevleri
PHP Manual

px_set_value

(PECL paradox >= 1.1.0)

px_set_value — Sets a value

Açıklama

bool px_set_value ( resource $pxdoc , string $name , float $value )

Sets various values.

Değiştirgeler

pxdoc

Resource identifier of the paradox database as returned by px_new().

name

name can be one of the following.

numprimkeys

The number of primary keys. Paradox databases always use the first numprimkeys fields for the primary index.

value

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

px_set_parameter() - Sets a parameter

px_set_targetencoding
px_timestamp2string
Paradox İşlevleri


Converts the timestamp into a string.

px_set_value
px_update_record
Paradox İşlevleri
PHP Manual

px_timestamp2string

(PECL paradox >= 1.4.0)

px_timestamp2string — Converts the timestamp into a string.

Açıklama

string px_timestamp2string ( resource $pxdoc , float $value , string $format )

Turns a timestamp as it stored in the paradox file into human readable format. Paradox timestamps are the number of miliseconds since 0001-01-02. This function is just for convenience. It can be easily replaced by some math and the calendar functions as demonstrated in the following example.

Değiştirgeler

pxdoc

Resource identifier of the paradox database.

value

Value as stored in paradox database field of type PX_FIELD_TIME, or PX_FIELD_TIMESTAMP.

format

String format similar to the format used by date(). The placeholders support by this function is a subset of those supported by date() (Y, y, m, n, d, j, H, h, G, g, i, s, A, a, L).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Turn a paradox timestamp into a human readable form

<?php
$px = px_new();

/* make up a date as it could be stored in */
/* a date field of a paradox db. */
/* 700000 days since 1.1.0000. */
$days = 700000;

/* Use the calendar functions to print a */
/* human readable format of the date */
echo jdtogregorian($days+1721425)."\n";

/* Turn it into a timestamp as it stored in a paradox database */
/* Timestamps are stored in miliseconds since 0001-01-02 */
$stamp = $days * 86400.0 * 1000.0;
/* Add one hour */
$stamp += 3600000.0;
/* The following will output '7/15/1917 01:00:00'. */
echo px_timestamp2string($px, $stamp, "n/d/Y H:i:s")."\n";

px_delete($px);
?>

Yukarıdaki örneğin çıktısı:

7/15/1917
7/15/1917 01:00:00

The Julian day count as passed to jdtogregorian() has a different base of 1.1.4714 b.c. and must therefore be calculated by adding 1721425 to the day count used in the paradox file. Turning the day count into a timestamp is easily done by multiplying with 86400000.0 to obtain miliseconds.

Ayrıca Bakınız

  • px_date2string() - Converts a date into a string.
  • jdtogregorian() - Jülyen Gün Sayısını, Gregoryen tarihine çevirir

px_set_value
px_update_record
Paradox İşlevleri


Updates record in paradox database

px_timestamp2string
PostgreSQL
Paradox İşlevleri
PHP Manual

px_update_record

(PECL paradox >= 1.4.0)

px_update_record — Updates record in paradox database

Açıklama

bool px_update_record ( resource $pxdoc , array $data , int $num )

Updates an exiting record in the database. The record starts at 0.

The record data is passed as an array of field values. The elements in the array must correspond to the fields in the database. If the array has less elements than fields in the database, the remaining fields will be set to null.

Bilginize:

This function is only available if pxlib >= 0.6.0 is used.

Değiştirgeler

pxdoc

Resource identifier of the paradox database as returned by px_new().

data

Associated array containing the field values as returned by px_retrieve_record().

num

The record number is an artificial number counting records in the order as they are stored in the database. The first record has number 0.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

px_insert_record() - Inserts record into paradox database

px_timestamp2string
PostgreSQL
Paradox İşlevleri


PostgreSQL

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
    • Basic usage
  • PostgreSQL İşlevleri
    • pg_affected_rows — Returns number of affected records (tuples)
    • pg_cancel_query — Cancel an asynchronous query
    • pg_client_encoding — Gets the client encoding
    • pg_close — Closes a PostgreSQL connection
    • pg_connect_poll — Poll the status of an in-progress asynchronous PostgreSQL connection attempt.
    • pg_connect — Open a PostgreSQL connection
    • pg_connection_busy — Get connection is busy or not
    • pg_connection_reset — Reset connection (reconnect)
    • pg_connection_status — Get connection status
    • pg_consume_input — Reads input on the connection
    • pg_convert — Convert associative array values into suitable for SQL statement
    • pg_copy_from — Insert records into a table from an array
    • pg_copy_to — Copy a table to an array
    • pg_dbname — Get the database name
    • pg_delete — Deletes records
    • pg_end_copy — Sync with PostgreSQL backend
    • pg_escape_bytea — Escape a string for insertion into a bytea field
    • pg_escape_identifier — Escape a identifier for insertion into a text field
    • pg_escape_literal — Escape a literal for insertion into a text field
    • pg_escape_string — Escape a string for query
    • pg_execute — Sends a request to execute a prepared statement with given parameters, and waits for the result.
    • pg_fetch_all_columns — Fetches all rows in a particular result column as an array
    • pg_fetch_all — Fetches all rows from a result as an array
    • pg_fetch_array — Fetch a row as an array
    • pg_fetch_assoc — Fetch a row as an associative array
    • pg_fetch_object — Fetch a row as an object
    • pg_fetch_result — Returns values from a result resource
    • pg_fetch_row — Get a row as an enumerated array
    • pg_field_is_null — Test if a field is SQL NULL
    • pg_field_name — Returns the name of a field
    • pg_field_num — Returns the field number of the named field
    • pg_field_prtlen — Returns the printed length
    • pg_field_size — Returns the internal storage size of the named field
    • pg_field_table — Returns the name or oid of the tables field
    • pg_field_type_oid — Returns the type ID (OID) for the corresponding field number
    • pg_field_type — Returns the type name for the corresponding field number
    • pg_flush — Flush outbound query data on the connection
    • pg_free_result — Free result memory
    • pg_get_notify — Gets SQL NOTIFY message
    • pg_get_pid — Gets the backend's process ID
    • pg_get_result — Get asynchronous query result
    • pg_host — Returns the host name associated with the connection
    • pg_insert — Insert array into table
    • pg_last_error — Get the last error message string of a connection
    • pg_last_notice — Returns the last notice message from PostgreSQL server
    • pg_last_oid — Returns the last row's OID
    • pg_lo_close — Close a large object
    • pg_lo_create — Create a large object
    • pg_lo_export — Export a large object to file
    • pg_lo_import — Import a large object from file
    • pg_lo_open — Open a large object
    • pg_lo_read_all — Reads an entire large object and send straight to browser
    • pg_lo_read — Read a large object
    • pg_lo_seek — Seeks position within a large object
    • pg_lo_tell — Returns current seek position a of large object
    • pg_lo_truncate — Truncates a large object
    • pg_lo_unlink — Delete a large object
    • pg_lo_write — Write to a large object
    • pg_meta_data — Get meta data for table
    • pg_num_fields — Returns the number of fields in a result
    • pg_num_rows — Returns the number of rows in a result
    • pg_options — Get the options associated with the connection
    • pg_parameter_status — Looks up a current parameter setting of the server.
    • pg_pconnect — Open a persistent PostgreSQL connection
    • pg_ping — Ping database connection
    • pg_port — Return the port number associated with the connection
    • pg_prepare — Submits a request to create a prepared statement with the given parameters, and waits for completion.
    • pg_put_line — Send a NULL-terminated string to PostgreSQL backend
    • pg_query_params — Submits a command to the server and waits for the result, with the ability to pass parameters separately from the SQL command text.
    • pg_query — Execute a query
    • pg_result_error_field — Returns an individual field of an error report.
    • pg_result_error — Get error message associated with result
    • pg_result_seek — Set internal row offset in result resource
    • pg_result_status — Get status of query result
    • pg_select — Select records
    • pg_send_execute — Sends a request to execute a prepared statement with given parameters, without waiting for the result(s).
    • pg_send_prepare — Sends a request to create a prepared statement with the given parameters, without waiting for completion.
    • pg_send_query_params — Submits a command and separate parameters to the server without waiting for the result(s).
    • pg_send_query — Sends asynchronous query
    • pg_set_client_encoding — Set the client encoding
    • pg_set_error_verbosity — Determines the verbosity of messages returned by pg_last_error and pg_result_error.
    • pg_socket — Get a read only handle to the socket underlying a PostgreSQL connection
    • pg_trace — Enable tracing a PostgreSQL connection
    • pg_transaction_status — Returns the current in-transaction status of the server.
    • pg_tty — Return the TTY name associated with the connection
    • pg_unescape_bytea — Unescape binary for bytea type
    • pg_untrace — Disable tracing of a PostgreSQL connection
    • pg_update — Update table
    • pg_version — Returns an array with client, protocol and server version (when available)
px_update_record
Giriş
Sağlayıcıya Göre Veritabanı Eklentileri


Giriş

PostgreSQL database is an Open Source product and available without cost. Postgres, developed originally in the UC Berkeley Computer Science Department, pioneered many of the object-relational concepts now becoming available in some commercial databases. It provides SQL92/SQL99 language support, transactions, referential integrity, stored procedures and type extensibility. PostgreSQL is an open source descendant of this original Berkeley code.

PostgreSQL
Yapılandırma/Kurulum
PostgreSQL


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
PostgreSQL


Gereksinimler

To use PostgreSQL support, you need PostgreSQL 6.5 or later, PostgreSQL 8.0 or later to enable all PostgreSQL module features. PostgreSQL supports many character encodings including multibyte character encoding. The current version and more information about PostgreSQL is available at » http://www.postgresql.org/ and the » PostgreSQL Documentation.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

In order to enable PostgreSQL support, --with-pgsql[=DIR] is required when you compile PHP. DIR is the PostgreSQL base install directory, defaults to /usr/local/pgsql. If shared object module is available, PostgreSQL module may be loaded using extension directive in php.ini or dl() function.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

PostgreSQL configuration options
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
pgsql.allow_persistent | "1" | PHP_INI_SYSTEM |
pgsql.max_persistent | "-1" | PHP_INI_SYSTEM |
pgsql.max_links | "-1" | PHP_INI_SYSTEM |
pgsql.auto_reset_persistent | "0" | PHP_INI_SYSTEM | Available since PHP 4.2.0.
pgsql.ignore_notice | "0" | PHP_INI_ALL | Available since PHP 4.3.0.
pgsql.log_notice | "0" | PHP_INI_ALL | Available since PHP 4.3.0.
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

pgsql.allow_persistent boolean

Whether to allow persistent Postgres connections.

pgsql.max_persistent integer

The maximum number of persistent Postgres connections per process.

pgsql.max_links integer

The maximum number of Postgres connections per process, including persistent connections.

pgsql.auto_reset_persistent integer

Detect broken persistent links with pg_pconnect(). Needs a little overhead.

pgsql.ignore_notice integer

Whether or not to ignore PostgreSQL backend notices.

pgsql.log_notice integer

Whether or not to log PostgreSQL backends notice messages. The PHP directive pgsql.ignore_notice must be off in order to log notice messages.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Özkaynak Türleri

There are two resource types used in the PostgreSQL module. The first one is the link identifier for a database connection, the second a resource which holds the result of a query.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

PGSQL_LIBPQ_VERSION (string)
Short libpq version that contains only numbers and dots.
PGSQL_LIBPQ_VERSION_STR (string)
Long libpq version that includes compiler information.
PGSQL_ASSOC (integer)
Passed to pg_fetch_array(). Return an associative array of field names and values.
PGSQL_NUM (integer)
Passed to pg_fetch_array(). Return a numerically indexed array of field numbers and values.
PGSQL_BOTH (integer)
Passed to pg_fetch_array(). Return an array of field values that is both numerically indexed (by field number) and associated (by field name).
PGSQL_CONNECT_FORCE_NEW (integer)
Passed to pg_connect() to force the creation of a new connection, rather than re-using an existing identical connection.
PGSQL_CONNECT_ASYNC (integer)
Passed to pg_connect() to create an asynchronous connection. Added in PHP 5.6.0.
PGSQL_CONNECTION_BAD (integer)
Returned by pg_connection_status() indicating that the database connection is in an invalid state.
PGSQL_CONNECTION_OK (integer)
Returned by pg_connection_status() indicating that the database connection is in a valid state.
PGSQL_SEEK_SET (integer)
Passed to pg_lo_seek(). Seek operation is to begin from the start of the object.
PGSQL_SEEK_CUR (integer)
Passed to pg_lo_seek(). Seek operation is to begin from the current position.
PGSQL_SEEK_END (integer)
Passed to pg_lo_seek(). Seek operation is to begin from the end of the object.
PGSQL_EMPTY_QUERY (integer)
Returned by pg_result_status(). The string sent to the server was empty.
PGSQL_COMMAND_OK (integer)
Returned by pg_result_status(). Successful completion of a command returning no data.
PGSQL_TUPLES_OK (integer)
Returned by pg_result_status(). Successful completion of a command returning data (such as a SELECT or SHOW).
PGSQL_COPY_OUT (integer)
Returned by pg_result_status(). Copy Out (from server) data transfer started.
PGSQL_COPY_IN (integer)
Returned by pg_result_status(). Copy In (to server) data transfer started.
PGSQL_BAD_RESPONSE (integer)
Returned by pg_result_status(). The server's response was not understood.
PGSQL_NONFATAL_ERROR (integer)
Returned by pg_result_status(). A nonfatal error (a notice or warning) occurred.
PGSQL_FATAL_ERROR (integer)
Returned by pg_result_status(). A fatal error occurred.
PGSQL_TRANSACTION_IDLE (integer)
Returned by pg_transaction_status(). Connection is currently idle, not in a transaction.
PGSQL_TRANSACTION_ACTIVE (integer)
Returned by pg_transaction_status(). A command is in progress on the connection. A query has been sent via the connection and not yet completed.
PGSQL_TRANSACTION_INTRANS (integer)
Returned by pg_transaction_status(). The connection is idle, in a transaction block.
PGSQL_TRANSACTION_INERROR (integer)
Returned by pg_transaction_status(). The connection is idle, in a failed transaction block.
PGSQL_TRANSACTION_UNKNOWN (integer)
Returned by pg_transaction_status(). The connection is bad.
PGSQL_DIAG_SEVERITY (integer)
Passed to pg_result_error_field(). The severity; the field contents are ERROR, FATAL, or PANIC (in an error message), or WARNING, NOTICE, DEBUG, INFO, or LOG (in a notice message), or a localized translation of one of these. Always present.
PGSQL_DIAG_SQLSTATE (integer)
Passed to pg_result_error_field(). The SQLSTATE code for the error. The SQLSTATE code identifies the type of error that has occurred; it can be used by front-end applications to perform specific operations (such as error handling) in response to a particular database error. This field is not localizable, and is always present.
PGSQL_DIAG_MESSAGE_PRIMARY (integer)
Passed to pg_result_error_field(). The primary human-readable error message (typically one line). Always present.
PGSQL_DIAG_MESSAGE_DETAIL (integer)
Passed to pg_result_error_field(). Detail: an optional secondary error message carrying more detail about the problem. May run to multiple lines.
PGSQL_DIAG_MESSAGE_HINT (integer)
Passed to pg_result_error_field(). Hint: an optional suggestion what to do about the problem. This is intended to differ from detail in that it offers advice (potentially inappropriate) rather than hard facts. May run to multiple lines.
PGSQL_DIAG_STATEMENT_POSITION (integer)
Passed to pg_result_error_field(). A string containing a decimal integer indicating an error cursor position as an index into the original statement string. The first character has index 1, and positions are measured in characters not bytes.
PGSQL_DIAG_INTERNAL_POSITION (integer)
Passed to pg_result_error_field(). This is defined the same as the PG_DIAG_STATEMENT_POSITION field, but it is used when the cursor position refers to an internally generated command rather than the one submitted by the client. The PG_DIAG_INTERNAL_QUERY field will always appear when this field appears.
PGSQL_DIAG_INTERNAL_QUERY (integer)
Passed to pg_result_error_field(). The text of a failed internally-generated command. This could be, for example, a SQL query issued by a PL/pgSQL function.
PGSQL_DIAG_CONTEXT (integer)
Passed to pg_result_error_field(). An indication of the context in which the error occurred. Presently this includes a call stack traceback of active procedural language functions and internally-generated queries. The trace is one entry per line, most recent first.
PGSQL_DIAG_SOURCE_FILE (integer)
Passed to pg_result_error_field(). The file name of the PostgreSQL source-code location where the error was reported.
PGSQL_DIAG_SOURCE_LINE (integer)
Passed to pg_result_error_field(). The line number of the PostgreSQL source-code location where the error was reported.
PGSQL_DIAG_SOURCE_FUNCTION (integer)
Passed to pg_result_error_field(). The name of the PostgreSQL source-code function reporting the error.
PGSQL_ERRORS_TERSE (integer)
Passed to pg_set_error_verbosity(). Specified that returned messages include severity, primary text, and position only; this will normally fit on a single line.
PGSQL_ERRORS_DEFAULT (integer)
Passed to pg_set_error_verbosity(). The default mode produces messages that include the above plus any detail, hint, or context fields (these may span multiple lines).
PGSQL_ERRORS_VERBOSE (integer)
Passed to pg_set_error_verbosity(). The verbose mode includes all available fields.
PGSQL_STATUS_LONG (integer)
Passed to pg_result_status(). Indicates that numerical result code is desired.
PGSQL_STATUS_STRING (integer)
Passed to pg_result_status(). Indicates that textual result command tag is desired.
PGSQL_CONV_IGNORE_DEFAULT (integer)
Passed to pg_convert(). Ignore default values in the table during conversion.
PGSQL_CONV_FORCE_NULL (integer)
Passed to pg_convert(). Use SQL NULL in place of an empty string.
PGSQL_CONV_IGNORE_NOT_NULL (integer)
Passed to pg_convert(). Ignore conversion of NULL into SQL NOT NULL columns.
PGSQL_DML_NO_CONV (integer)
Passed to pg_insert(), pg_select(), pg_update() and pg_delete(). All parameters passed as is. Manual escape is required if parameters contain user supplied data. Use pg_escape_string() for it.
PGSQL_DML_EXEC (integer)
Passed to pg_insert(), pg_select(), pg_update() and pg_delete(). Execute query by these functions.
PGSQL_DML_ASYNC (integer)
Passed to pg_insert(), pg_select(), pg_update() and pg_delete(). Execute asynchronous query by these functions.
PGSQL_DML_STRING (integer)
Passed to pg_insert(), pg_select(), pg_update() and pg_delete(). Return executed query string.
PGSQL_DML_ESCAPE (integer)
Passed to pg_insert(), pg_select(), pg_update() and pg_delete(). Apply escape to all parameters instead of calling pg_convert() internally. This option omits meta data look up. Query could be as fast as pg_query() and pg_send_query().
PGSQL_POLLING_FAILED (integer)
Returned by pg_connect_poll() to indicate that the connection attempt failed.
PGSQL_POLLING_READING (integer)
Returned by pg_connect_poll() to indicate that the connection is waiting for the PostgreSQL socket to be readable.
PGSQL_POLLING_WRITING (integer)
Returned by pg_connect_poll() to indicate that the connection is waiting for the PostgreSQL socket to be writable.
PGSQL_POLLING_OK (integer)
Returned by pg_connect_poll() to indicate that the connection is ready to be used.
PGSQL_POLLING_ACTIVE (integer)
Returned by pg_connect_poll() to indicate that the connection is currently active.
Özkaynak Türleri
Örnekler
PostgreSQL


Örnekler

İçindekiler

  • Basic usage
Öntanımlı Sabitler
Basic usage
PostgreSQL


Basic usage

This simple example shows how to connect, execute a query, print resulting rows and disconnect from a PostgreSQL database.

Örnek 1 PostgreSQL extension overview example

<?php
// Connecting, selecting database
$dbconn = pg_connect("host=localhost dbname=publishing user=www password=foo")
    or die('Could not connect: ' . pg_last_error());

// Performing SQL query
$query = 'SELECT * FROM authors';
$result = pg_query($query) or die('Query failed: ' . pg_last_error());

// Printing results in HTML
echo "<table>\n";
while ($line = pg_fetch_array($result, null, PGSQL_ASSOC)) {
    echo "\t<tr>\n";
    foreach ($line as $col_value) {
        echo "\t\t<td>$col_value</td>\n";
    }
    echo "\t</tr>\n";
}
echo "</table>\n";

// Free resultset
pg_free_result($result);

// Closing connection
pg_close($dbconn);
?>

Örnekler
PostgreSQL İşlevleri
Örnekler


PostgreSQL İşlevleri

Notlar

Bilginize:

Not all functions are supported by all builds. It depends on your libpq (The PostgreSQL C client library) version and how libpq is compiled. If PHP PostgreSQL extensions are missing, then it is because your libpq version does not support them.

Bilginize:

Most PostgreSQL functions accept connection as the optional first parameter. If it is not provided, the last opened connection is used. If it doesn't exist, functions return FALSE.

Bilginize:

PostgreSQL automatically folds all identifiers (e.g. table/column names) to lower-case values at object creation time and at query time. To force the use of mixed or upper case identifiers, you must escape the identifier using double quotes ("").

Bilginize:

PostgreSQL does not have special commands for fetching database schema information (eg. all the tables in the current database). Instead, there is a standard schema named information_schema in PostgreSQL 7.4 and above containing system views with all the necessary information, in an easily queryable form. See the » PostgreSQL Documentation for full details.

İçindekiler

  • pg_affected_rows — Returns number of affected records (tuples)
  • pg_cancel_query — Cancel an asynchronous query
  • pg_client_encoding — Gets the client encoding
  • pg_close — Closes a PostgreSQL connection
  • pg_connect_poll — Poll the status of an in-progress asynchronous PostgreSQL connection attempt.
  • pg_connect — Open a PostgreSQL connection
  • pg_connection_busy — Get connection is busy or not
  • pg_connection_reset — Reset connection (reconnect)
  • pg_connection_status — Get connection status
  • pg_consume_input — Reads input on the connection
  • pg_convert — Convert associative array values into suitable for SQL statement
  • pg_copy_from — Insert records into a table from an array
  • pg_copy_to — Copy a table to an array
  • pg_dbname — Get the database name
  • pg_delete — Deletes records
  • pg_end_copy — Sync with PostgreSQL backend
  • pg_escape_bytea — Escape a string for insertion into a bytea field
  • pg_escape_identifier — Escape a identifier for insertion into a text field
  • pg_escape_literal — Escape a literal for insertion into a text field
  • pg_escape_string — Escape a string for query
  • pg_execute — Sends a request to execute a prepared statement with given parameters, and waits for the result.
  • pg_fetch_all_columns — Fetches all rows in a particular result column as an array
  • pg_fetch_all — Fetches all rows from a result as an array
  • pg_fetch_array — Fetch a row as an array
  • pg_fetch_assoc — Fetch a row as an associative array
  • pg_fetch_object — Fetch a row as an object
  • pg_fetch_result — Returns values from a result resource
  • pg_fetch_row — Get a row as an enumerated array
  • pg_field_is_null — Test if a field is SQL NULL
  • pg_field_name — Returns the name of a field
  • pg_field_num — Returns the field number of the named field
  • pg_field_prtlen — Returns the printed length
  • pg_field_size — Returns the internal storage size of the named field
  • pg_field_table — Returns the name or oid of the tables field
  • pg_field_type_oid — Returns the type ID (OID) for the corresponding field number
  • pg_field_type — Returns the type name for the corresponding field number
  • pg_flush — Flush outbound query data on the connection
  • pg_free_result — Free result memory
  • pg_get_notify — Gets SQL NOTIFY message
  • pg_get_pid — Gets the backend's process ID
  • pg_get_result — Get asynchronous query result
  • pg_host — Returns the host name associated with the connection
  • pg_insert — Insert array into table
  • pg_last_error — Get the last error message string of a connection
  • pg_last_notice — Returns the last notice message from PostgreSQL server
  • pg_last_oid — Returns the last row's OID
  • pg_lo_close — Close a large object
  • pg_lo_create — Create a large object
  • pg_lo_export — Export a large object to file
  • pg_lo_import — Import a large object from file
  • pg_lo_open — Open a large object
  • pg_lo_read_all — Reads an entire large object and send straight to browser
  • pg_lo_read — Read a large object
  • pg_lo_seek — Seeks position within a large object
  • pg_lo_tell — Returns current seek position a of large object
  • pg_lo_truncate — Truncates a large object
  • pg_lo_unlink — Delete a large object
  • pg_lo_write — Write to a large object
  • pg_meta_data — Get meta data for table
  • pg_num_fields — Returns the number of fields in a result
  • pg_num_rows — Returns the number of rows in a result
  • pg_options — Get the options associated with the connection
  • pg_parameter_status — Looks up a current parameter setting of the server.
  • pg_pconnect — Open a persistent PostgreSQL connection
  • pg_ping — Ping database connection
  • pg_port — Return the port number associated with the connection
  • pg_prepare — Submits a request to create a prepared statement with the given parameters, and waits for completion.
  • pg_put_line — Send a NULL-terminated string to PostgreSQL backend
  • pg_query_params — Submits a command to the server and waits for the result, with the ability to pass parameters separately from the SQL command text.
  • pg_query — Execute a query
  • pg_result_error_field — Returns an individual field of an error report.
  • pg_result_error — Get error message associated with result
  • pg_result_seek — Set internal row offset in result resource
  • pg_result_status — Get status of query result
  • pg_select — Select records
  • pg_send_execute — Sends a request to execute a prepared statement with given parameters, without waiting for the result(s).
  • pg_send_prepare — Sends a request to create a prepared statement with the given parameters, without waiting for completion.
  • pg_send_query_params — Submits a command and separate parameters to the server without waiting for the result(s).
  • pg_send_query — Sends asynchronous query
  • pg_set_client_encoding — Set the client encoding
  • pg_set_error_verbosity — Determines the verbosity of messages returned by pg_last_error and pg_result_error.
  • pg_socket — Get a read only handle to the socket underlying a PostgreSQL connection
  • pg_trace — Enable tracing a PostgreSQL connection
  • pg_transaction_status — Returns the current in-transaction status of the server.
  • pg_tty — Return the TTY name associated with the connection
  • pg_unescape_bytea — Unescape binary for bytea type
  • pg_untrace — Disable tracing of a PostgreSQL connection
  • pg_update — Update table
  • pg_version — Returns an array with client, protocol and server version (when available)
Basic usage
pg_affected_rows
PostgreSQL


Returns number of affected records (tuples)

PostgreSQL İşlevleri
pg_cancel_query
PostgreSQL İşlevleri
PHP Manual

pg_affected_rows

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

pg_affected_rows — Returns number of affected records (tuples)

Açıklama

int pg_affected_rows ( resource $result )

pg_affected_rows() returns the number of tuples (instances/records/rows) affected by INSERT, UPDATE, and DELETE queries.

Since PostgreSQL 9.0 and above, the server returns the number of SELECTed rows. Older PostgreSQL return 0 for SELECT.

Bilginize:

This function used to be called pg_cmdtuples().

Değiştirgeler

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

Dönen Değerler

The number of rows affected by the query. If no tuple is affected, it will return 0.

Örnekler

Örnek 1 pg_affected_rows() example

<?php
$result = pg_query($conn, "INSERT INTO authors VALUES ('Orwell', 2002, 'Animal Farm')");

$cmdtuples = pg_affected_rows($result);

echo $cmdtuples . " tuples are affected.\n";
?>

Yukarıdaki örneğin çıktısı:

1 tuples are affected.

Ayrıca Bakınız

  • pg_query() - Execute a query
  • pg_query_params() - Submits a command to the server and waits for the result, with the ability to pass parameters separately from the SQL command text.
  • pg_execute() - Sends a request to execute a prepared statement with given parameters, and waits for the result.
  • pg_num_rows() - Returns the number of rows in a result

PostgreSQL İşlevleri
pg_cancel_query
PostgreSQL İşlevleri


Cancel an asynchronous query

pg_affected_rows
pg_client_encoding
PostgreSQL İşlevleri
PHP Manual

pg_cancel_query

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

pg_cancel_query — Cancel an asynchronous query

Açıklama

bool pg_cancel_query ( resource $connection )

pg_cancel_query() cancels an asynchronous query sent with pg_send_query(), pg_send_query_params() or pg_send_execute(). You cannot cancel a query executed using pg_query().

Değiştirgeler

connection

PostgreSQL database connection resource.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 pg_cancel_query() example

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  if (!pg_connection_busy($dbconn)) {
      pg_send_query($dbconn, "select * from authors; select count(*) from authors;");
  }

  $res1 = pg_get_result($dbconn);
  echo "First call to pg_get_result(): $res1\n";
  $rows1 = pg_num_rows($res1);
  echo "$res1 has $rows1 records\n\n";

  // Cancel the currently running query.  Will be the second query if it is
  // still running.
  pg_cancel_query($dbconn);
?>

Yukarıdaki örneğin çıktısı:

First call to pg_get_result(): Resource id #3
Resource id #3 has 3 records

Ayrıca Bakınız

  • pg_send_query() - Sends asynchronous query
  • pg_connection_busy() - Get connection is busy or not

pg_affected_rows
pg_client_encoding
PostgreSQL İşlevleri


Gets the client encoding

pg_cancel_query
pg_close
PostgreSQL İşlevleri
PHP Manual

pg_client_encoding

(PHP 4 >= 4.0.3, PHP 5, PHP 7)

pg_client_encoding — Gets the client encoding

Açıklama

string pg_client_encoding ([ resource $connection ] )

PostgreSQL supports automatic character set conversion between server and client for certain character sets. pg_client_encoding() returns the client encoding as a string. The returned string will be one of the standard PostgreSQL encoding identifiers.

Bilginize:

This function requires PHP 4.0.3 or higher and PostgreSQL 7.0 or higher. If libpq is compiled without multibyte encoding support, pg_client_encoding() always returns SQL_ASCII. Supported encoding depends on PostgreSQL version. Refer to the PostgreSQL Documentation supported encodings.

The function used to be called pg_clientencoding().

Değiştirgeler

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

Dönen Değerler

The client encoding, or FALSE on error.

Örnekler

Örnek 1 pg_client_encoding() example

<?php
// Assume $conn is a connection to a ISO-8859-1 database
$encoding = pg_client_encoding($conn);

echo "Client encoding is: ", $encoding, "\n";
?>

Yukarıdaki örneğin çıktısı:

Client encoding is: ISO-8859-1

Ayrıca Bakınız

  • pg_set_client_encoding() - Set the client encoding

pg_cancel_query
pg_close
PostgreSQL İşlevleri


Closes a PostgreSQL connection

pg_client_encoding
pg_connect_poll
PostgreSQL İşlevleri
PHP Manual

pg_close

(PHP 4, PHP 5, PHP 7)

pg_close — Closes a PostgreSQL connection

Açıklama

bool pg_close ([ resource $connection ] )

pg_close() closes the non-persistent connection to a PostgreSQL database associated with the given connection resource.

Bilginize:

Using pg_close() is not usually necessary, as non-persistent open connections are automatically closed at the end of the script.

If there is open large object resource on the connection, do not close the connection before closing all large object resources.

Değiştirgeler

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 pg_close() example

<?php
$dbconn = pg_connect("host=localhost port=5432 dbname=mary")
   or die("Could not connect");
echo "Connected successfully";
pg_close($dbconn);
?>

Yukarıdaki örneğin çıktısı:

Connected successfully

Ayrıca Bakınız

  • pg_connect() - Open a PostgreSQL connection

pg_client_encoding
pg_connect_poll
PostgreSQL İşlevleri


Poll the status of an in-progress asynchronous PostgreSQL connection attempt.

pg_close
pg_connect
PostgreSQL İşlevleri
PHP Manual

pg_connect_poll

(PHP 5 >= 5.6.0, PHP 7)

pg_connect_poll — Poll the status of an in-progress asynchronous PostgreSQL connection attempt.

Açıklama

int pg_connect_poll ([ resource $connection ] )

pg_connect_poll() polls the status of a PostgreSQL connection created by calling pg_connect() with the PGSQL_CONNECT_ASYNC option.

Değiştirgeler

connection

PostgreSQL database connection resource.

Dönen Değerler

Returns PGSQL_POLLING_FAILED, PGSQL_POLLING_READING, PGSQL_POLLING_WRITING, PGSQL_POLLING_OK, or PGSQL_POLLING_ACTIVE.

pg_close
pg_connect
PostgreSQL İşlevleri


Open a PostgreSQL connection

pg_connect_poll
pg_connection_busy
PostgreSQL İşlevleri
PHP Manual

pg_connect

(PHP 4, PHP 5, PHP 7)

pg_connect — Open a PostgreSQL connection

Açıklama

resource pg_connect ( string $connection_string [, int $connect_type ] )

pg_connect() opens a connection to a PostgreSQL database specified by the connection_string.

If a second call is made to pg_connect() with the same connection_string as an existing connection, the existing connection will be returned unless you pass PGSQL_CONNECT_FORCE_NEW as connect_type.

The old syntax with multiple parameters $conn = pg_connect("host", "port", "options", "tty", "dbname") has been deprecated.

Değiştirgeler

connection_string

The connection_string can be empty to use all default parameters, or it can contain one or more parameter settings separated by whitespace. Each parameter setting is in the form keyword = value. Spaces around the equal sign are optional. To write an empty value or a value containing spaces, surround it with single quotes, e.g., keyword = 'a value'. Single quotes and backslashes within the value must be escaped with a backslash, i.e., \' and \\.

The currently recognized parameter keywords are: host, hostaddr, port, dbname (defaults to value of user), user, password, connect_timeout, options, tty (ignored), sslmode, requiressl (deprecated in favor of sslmode), and service. Which of these arguments exist depends on your PostgreSQL version.

The options parameter can be used to set command line parameters to be invoked by the server.

connect_type

If PGSQL_CONNECT_FORCE_NEW is passed, then a new connection is created, even if the connection_string is identical to an existing connection.

If PGSQL_CONNECT_ASYNC is given, then the connection is established asynchronously. The state of the connection can then be checked via pg_connect_poll() or pg_connection_status().

Dönen Değerler

PostgreSQL connection resource on success, FALSE on failure.

Sürüm Bilgisi

Sürüm: | Açıklama
5.6.0 | Support for giving the PGSQL_CONNECT_ASYNC constant as the connect_type was added.

Örnekler

Örnek 1 Using pg_connect()

<?php
$dbconn = pg_connect("dbname=mary");
//connect to a database named "mary"

$dbconn2 = pg_connect("host=localhost port=5432 dbname=mary");
// connect to a database named "mary" on "localhost" at port "5432"

$dbconn3 = pg_connect("host=sheep port=5432 dbname=mary user=lamb password=foo");
//connect to a database named "mary" on the host "sheep" with a username and password

$conn_string = "host=sheep port=5432 dbname=test user=lamb password=bar";
$dbconn4 = pg_connect($conn_string);
//connect to a database named "test" on the host "sheep" with a username and password

$dbconn5 = pg_connect("host=localhost options='--client_encoding=UTF8'");
//connect to a database on "localhost" and set the command line parameter which tells the encoding is in UTF-8
?>

Ayrıca Bakınız

  • pg_pconnect() - Open a persistent PostgreSQL connection
  • pg_close() - Closes a PostgreSQL connection
  • pg_host() - Returns the host name associated with the connection
  • pg_port() - Return the port number associated with the connection
  • pg_tty() - Return the TTY name associated with the connection
  • pg_options() - Get the options associated with the connection
  • pg_dbname() - Get the database name

pg_connect_poll
pg_connection_busy
PostgreSQL İşlevleri


Get connection is busy or not

pg_connect
pg_connection_reset
PostgreSQL İşlevleri
PHP Manual

pg_connection_busy

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

pg_connection_busy — Get connection is busy or not

Açıklama

bool pg_connection_busy ( resource $connection )

pg_connection_busy() determines whether or not a connection is busy. If it is busy, a previous query is still executing. If pg_get_result() is used on the connection, it will be blocked.

Değiştirgeler

connection

PostgreSQL database connection resource.

Dönen Değerler

Returns TRUE if the connection is busy, FALSE otherwise.

Örnekler

Örnek 1 pg_connection_busy() example

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");
  $bs = pg_connection_busy($dbconn);
  if ($bs) {
      echo 'connection is busy';
  } else {
     echo 'connection is not busy';
  }
?>

Ayrıca Bakınız

  • pg_connection_status() - Get connection status
  • pg_get_result() - Get asynchronous query result

pg_connect
pg_connection_reset
PostgreSQL İşlevleri


Reset connection (reconnect)

pg_connection_busy
pg_connection_status
PostgreSQL İşlevleri
PHP Manual

pg_connection_reset

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

pg_connection_reset — Reset connection (reconnect)

Açıklama

bool pg_connection_reset ( resource $connection )

pg_connection_reset() resets the connection. It is useful for error recovery.

Değiştirgeler

connection

PostgreSQL database connection resource.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 pg_connection_reset() example

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");
  $dbconn2 = pg_connection_reset($dbconn);
  if ($dbconn2) {
      echo "reset successful\n";
  } else {
      echo "reset failed\n";
  }
?>

Ayrıca Bakınız

  • pg_connect() - Open a PostgreSQL connection
  • pg_pconnect() - Open a persistent PostgreSQL connection
  • pg_connection_status() - Get connection status

pg_connection_busy
pg_connection_status
PostgreSQL İşlevleri


Get connection status

pg_connection_reset
pg_consume_input
PostgreSQL İşlevleri
PHP Manual

pg_connection_status

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

pg_connection_status — Get connection status

Açıklama

int pg_connection_status ( resource $connection )

pg_connection_status() returns the status of the specified connection.

Değiştirgeler

connection

PostgreSQL database connection resource.

Dönen Değerler

PGSQL_CONNECTION_OK or PGSQL_CONNECTION_BAD.

Örnekler

Örnek 1 pg_connection_status() example

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");
  $stat = pg_connection_status($dbconn);
  if ($stat === PGSQL_CONNECTION_OK) {
      echo 'Connection status ok';
  } else {
      echo 'Connection status bad';
  }
?>

Ayrıca Bakınız

  • pg_connection_busy() - Get connection is busy or not

pg_connection_reset
pg_consume_input
PostgreSQL İşlevleri


Reads input on the connection

pg_connection_status
pg_convert
PostgreSQL İşlevleri
PHP Manual

pg_consume_input

(PHP 5 >= 5.6.0, PHP 7)

pg_consume_input — Reads input on the connection

Açıklama

bool pg_consume_input ( resource $connection )

pg_consume_input() consumes any input waiting to be read from the database server.

Değiştirgeler

connection

PostgreSQL database connection resource.

Dönen Değerler

TRUE if no error occurred, or FALSE if there was an error. Note that TRUE does not necessarily indicate that input was waiting to be read.

pg_connection_status
pg_convert
PostgreSQL İşlevleri


Convert associative array values into suitable for SQL statement

pg_consume_input
pg_copy_from
PostgreSQL İşlevleri
PHP Manual

pg_convert

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

pg_convert — Convert associative array values into suitable for SQL statement

Açıklama

array pg_convert ( resource $connection , string $table_name , array $assoc_array [, int $options = 0 ] )

pg_convert() checks and converts the values in assoc_array into suitable values for use in an SQL statement. Precondition for pg_convert() is the existence of a table table_name which has at least as many columns as assoc_array has elements. The fieldnames in table_name must match the indices in assoc_array and the corresponding datatypes must be compatible. Returns an array with the converted values on success, FALSE otherwise.

Bilginize:

Since PHP 5.6.0, it accepts boolean values. It converted to PostgreSQL boolean. String representations of boolean value is also supported. NULL is converted to PostgreSQL NULL.

Prior to PHP 5.6.0, if there are boolean fields in table_name don't use the constant TRUE in assoc_array. It will be converted to the string 'TRUE' which is no valid entry for boolean fields in PostgreSQL. Use one of t, true, 1, y, yes instead.

Değiştirgeler

connection

PostgreSQL database connection resource.

table_name

Name of the table against which to convert types.

assoc_array

Data to be converted.

options

Any number of PGSQL_CONV_IGNORE_DEFAULT, PGSQL_CONV_FORCE_NULL or PGSQL_CONV_IGNORE_NOT_NULL, combined.

Dönen Değerler

An array of converted values, or FALSE on error.

Örnekler

Örnek 1 pg_convert() example

<?php
  $dbconn = pg_connect('dbname=foo');

  $tmp = array(
      'author' => 'Joe Thackery',
      'year' => 2005,
      'title' => 'My Life, by Joe Thackery'
  );

  $vals = pg_convert($dbconn, 'authors', $tmp);
?>

Sürüm Bilgisi

Sürüm: | Açıklama
5.6.0 | No longer experimental. Boolean/NULL data types are supported. Unknown/unsupported data types are escaped without validation. pg_convert() could be used with any data types.

Ayrıca Bakınız

  • pg_meta_data() - Get meta data for table
  • pg_insert() - Insert array into table
  • pg_select() - Select records
  • pg_update() - Update table
  • pg_delete() - Deletes records

pg_consume_input
pg_copy_from
PostgreSQL İşlevleri


Insert records into a table from an array

pg_convert
pg_copy_to
PostgreSQL İşlevleri
PHP Manual

pg_copy_from

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

pg_copy_from — Insert records into a table from an array

Açıklama

bool pg_copy_from ( resource $connection , string $table_name , array $rows [, string $delimiter [, string $null_as ]] )

pg_copy_from() inserts records into a table from rows. It issues a COPY FROM SQL command internally to insert records.

Değiştirgeler

connection

PostgreSQL database connection resource.

table_name

Name of the table into which to copy the rows.

rows

An array of data to be copied into table_name. Each value in rows becomes a row in table_name. Each value in rows should be a delimited string of the values to insert into each field. Values should be linefeed terminated.

delimiter

The token that separates values for each field in each element of rows. Default is TAB.

null_as

How SQL NULL values are represented in the rows. Default is \N ("\\N").

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 pg_copy_from() example

<?php
   $db = pg_connect("dbname=publisher") or die("Could not connect");

   $rows = pg_copy_to($db, $table_name);

   pg_query($db, "DELETE FROM $table_name");

   pg_copy_from($db, $table_name, $rows);
?>

Ayrıca Bakınız

  • pg_copy_to() - Copy a table to an array

pg_convert
pg_copy_to
PostgreSQL İşlevleri


Copy a table to an array

pg_copy_from
pg_dbname
PostgreSQL İşlevleri
PHP Manual

pg_copy_to

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

pg_copy_to — Copy a table to an array

Açıklama

array pg_copy_to ( resource $connection , string $table_name [, string $delimiter [, string $null_as ]] )

pg_copy_to() copies a table to an array. It issues COPY TO SQL command internally to retrieve records.

Değiştirgeler

connection

PostgreSQL database connection resource.

table_name

Name of the table from which to copy the data into rows.

delimiter

The token that separates values for each field in each element of rows. Default is TAB.

null_as

How SQL NULL values are represented in the rows. Default is \N ("\\N").

Dönen Değerler

An array with one element for each line of COPY data. It returns FALSE on failure.

Örnekler

Örnek 1 pg_copy_to() example

<?php
   $db = pg_connect("dbname=publisher") or die("Could not connect");

   $rows = pg_copy_to($db, $table_name);

   pg_query($db, "DELETE FROM $table_name");

   pg_copy_from($db, $table_name, $rows);
?>

Ayrıca Bakınız

  • pg_copy_from() - Insert records into a table from an array

pg_copy_from
pg_dbname
PostgreSQL İşlevleri


Get the database name

pg_copy_to
pg_delete
PostgreSQL İşlevleri
PHP Manual

pg_dbname

(PHP 4, PHP 5, PHP 7)

pg_dbname — Get the database name

Açıklama

string pg_dbname ([ resource $connection ] )

pg_dbname() returns the name of the database that the given PostgreSQL connection resource.

Değiştirgeler

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

Dönen Değerler

A string containing the name of the database the connection is to, or FALSE on error.

Örnekler

Örnek 1 pg_dbname() example

<?php
  error_reporting(E_ALL);

  pg_connect("host=localhost port=5432 dbname=mary");
  echo pg_dbname(); // mary
?>

pg_copy_to
pg_delete
PostgreSQL İşlevleri


Deletes records

pg_dbname
pg_end_copy
PostgreSQL İşlevleri
PHP Manual

pg_delete

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

pg_delete — Deletes records

Açıklama

mixed pg_delete ( resource $connection , string $table_name , array $assoc_array [, int $options = PGSQL_DML_EXEC ] )

pg_delete() deletes records from a table specified by the keys and values in assoc_array. If options is specified, pg_convert() is applied to assoc_array with the specified options.

Değiştirgeler

connection

PostgreSQL database connection resource.

table_name

Name of the table from which to delete rows.

assoc_array

An array whose keys are field names in the table table_name, and whose values are the values of those fields that are to be deleted.

options

Any number of PGSQL_CONV_FORCE_NULL, PGSQL_DML_NO_CONV, PGSQL_DML_ESCAPE, PGSQL_DML_EXEC, PGSQL_DML_ASYNC or PGSQL_DML_STRING combined. If PGSQL_DML_STRING is part of the options then query string is returned. When PGSQL_DML_NO_CONV or PGSQL_DML_ESCAPE is set, it does not call pg_convert() internally.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. Returns string if PGSQL_DML_STRING is passed via options.

Örnekler

Örnek 1 pg_delete() example

<?php
  $db = pg_connect('dbname=foo');
  // This is safe, since $_POST is converted automatically
  $res = pg_delete($db, 'post_log', $_POST);
  if ($res) {
      echo "POST data is deleted: $res\n";
  } else {
      echo "User must have sent wrong inputs\n";
  }
?>

Sürüm Bilgisi

Sürüm: | Açıklama
5.6.0 | No longer experimental. Added PGSQL_DML_ESCAPE constant, TRUE/FALSE and NULL data type support.
5.5.3/5.4.19 | Direct SQL injection to table_name and Indirect SQL injection to identifiers are fixed.

Ayrıca Bakınız

  • pg_convert() - Convert associative array values into suitable for SQL statement

pg_dbname
pg_end_copy
PostgreSQL İşlevleri


Sync with PostgreSQL backend

pg_delete
pg_escape_bytea
PostgreSQL İşlevleri
PHP Manual

pg_end_copy

(PHP 4 >= 4.0.3, PHP 5, PHP 7)

pg_end_copy — Sync with PostgreSQL backend

Açıklama

bool pg_end_copy ([ resource $connection ] )

pg_end_copy() syncs the PostgreSQL frontend (usually a web server process) with the PostgreSQL server after doing a copy operation performed by pg_put_line(). pg_end_copy() must be issued, otherwise the PostgreSQL server may get out of sync with the frontend and will report an error.

Değiştirgeler

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 pg_end_copy() example

<?php
  $conn = pg_pconnect("dbname=foo");
  pg_query($conn, "create table bar (a int4, b char(16), d float8)");
  pg_query($conn, "copy bar from stdin");
  pg_put_line($conn, "3\thello world\t4.5\n");
  pg_put_line($conn, "4\tgoodbye world\t7.11\n");
  pg_put_line($conn, "\\.\n");
  pg_end_copy($conn);
?>

Ayrıca Bakınız

  • pg_put_line() - Send a NULL-terminated string to PostgreSQL backend

pg_delete
pg_escape_bytea
PostgreSQL İşlevleri


Escape a string for insertion into a bytea field

pg_end_copy
pg_escape_identifier
PostgreSQL İşlevleri
PHP Manual

pg_escape_bytea

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

pg_escape_bytea — Escape a string for insertion into a bytea field

Açıklama

string pg_escape_bytea ([ resource $connection ], string $data )

pg_escape_bytea() escapes string for bytea datatype. It returns escaped string.

Bilginize:

When you SELECT a bytea type, PostgreSQL returns octal byte values prefixed with '\' (e.g. \032). Users are supposed to convert back to binary format manually.

This function requires PostgreSQL 7.2 or later. With PostgreSQL 7.2.0 and 7.2.1, bytea values must be cast when you enable multi-byte support. i.e. INSERT INTO test_table (image) VALUES ('$image_escaped'::bytea); PostgreSQL 7.2.2 or later does not need a cast. The exception is when the client and backend character encoding does not match, and there may be multi-byte stream error. User must then cast to bytea to avoid this error.

Değiştirgeler

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

data

A string containing text or binary data to be inserted into a bytea column.

Dönen Değerler

A string containing the escaped data.

Sürüm Bilgisi

Sürüm: | Açıklama
5.2.0 | connection added

Örnekler

Örnek 1 pg_escape_bytea() example

<?php
  // Connect to the database
  $dbconn = pg_connect('dbname=foo');

  // Read in a binary file
  $data = file_get_contents('image1.jpg');

  // Escape the binary data
  $escaped = pg_escape_bytea($data);

  // Insert it into the database
  pg_query("INSERT INTO gallery (name, data) VALUES ('Pine trees', '{$escaped}')");
?>

Ayrıca Bakınız

  • pg_unescape_bytea() - Unescape binary for bytea type
  • pg_escape_string() - Escape a string for query

pg_end_copy
pg_escape_identifier
PostgreSQL İşlevleri


Escape a identifier for insertion into a text field

pg_escape_bytea
pg_escape_literal
PostgreSQL İşlevleri
PHP Manual

pg_escape_identifier

(PHP 5 >= 5.4.4, PHP 7)

pg_escape_identifier — Escape a identifier for insertion into a text field

Açıklama

string pg_escape_identifier ([ resource $connection ], string $data )

pg_escape_identifier() escapes a identifier (e.g. table, field names) for quering the database. It returns an escaped identifier string for PostgreSQL server. pg_escape_identifier() adds double quotes before and after data. Users should not add double quotes. Use of this function is recommended for identifier parameters in query. For SQL literals (i.e. parameters except bytea), pg_escape_literal() or pg_escape_string() must be used. For bytea type fields, pg_escape_bytea() must be used instead.

Bilginize:

This function has internal escape code and can also be used with PostgreSQL 8.4 or less.

Değiştirgeler

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

data

A string containing text to be escaped.

Dönen Değerler

A string containing the escaped data.

Örnekler

Örnek 1 pg_escape_identifier() example

<?php
  // Connect to the database
  $dbconn = pg_connect('dbname=foo');

  // Escape the table name data
  $escaped = pg_escape_identifier($table_name);

  // Select rows from $table_name
  pg_query("SELECT * FROM {$escaped};");
?>

Ayrıca Bakınız

  • pg_escape_literal() - Escape a literal for insertion into a text field
  • pg_escape_bytea() - Escape a string for insertion into a bytea field
  • pg_escape_string() - Escape a string for query

pg_escape_bytea
pg_escape_literal
PostgreSQL İşlevleri


Escape a literal for insertion into a text field

pg_escape_identifier
pg_escape_string
PostgreSQL İşlevleri
PHP Manual

pg_escape_literal

(PHP 5 >= 5.4.4, PHP 7)

pg_escape_literal — Escape a literal for insertion into a text field

Açıklama

string pg_escape_literal ([ resource $connection ], string $data )

pg_escape_literal() escapes a literal for querying the PostgreSQL database. It returns an escaped literal in the PostgreSQL format. pg_escape_literal() adds quotes before and after data. Users should not add quotes. Use of this function is recommended instead of pg_escape_string(). If the type of the column is bytea, pg_escape_bytea() must be used instead. For escaping identifiers (e.g. table, field names), pg_escape_identifier() must be used.

Bilginize:

This function has internal escape code and can also be used with PostgreSQL 8.4 or less.

Değiştirgeler

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect(). When there is no default connection, it raises E_WARNING and returns FALSE.

data

A string containing text to be escaped.

Dönen Değerler

A string containing the escaped data.

Örnekler

Örnek 1 pg_escape_literal() example

<?php
  // Connect to the database
  $dbconn = pg_connect('dbname=foo');

  // Read in a text file (containing apostrophes and backslashes)
  $data = file_get_contents('letter.txt');

  // Escape the text data
  $escaped = pg_escape_literal($data);

  // Insert it into the database. Note that no quotes around {$escaped}
  pg_query("INSERT INTO correspondence (name, data) VALUES ('My letter', {$escaped})");
?>

Ayrıca Bakınız

  • pg_escape_identifier() - Escape a identifier for insertion into a text field
  • pg_escape_bytea() - Escape a string for insertion into a bytea field
  • pg_escape_string() - Escape a string for query

pg_escape_identifier
pg_escape_string
PostgreSQL İşlevleri


Escape a string for query

pg_escape_literal
pg_execute
PostgreSQL İşlevleri
PHP Manual

pg_escape_string

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

pg_escape_string — Escape a string for query

Açıklama

string pg_escape_string ([ resource $connection ], string $data )

pg_escape_string() escapes a string for querying the database. It returns an escaped string in the PostgreSQL format without quotes. pg_escape_literal() is more preferred way to escape SQL parameters for PostgreSQL. addslashes() must not be used with PostgreSQL. If the type of the column is bytea, pg_escape_bytea() must be used instead. pg_escape_identifier() must be used to escape identifiers (e.g. table names, field names)

Bilginize:

This function requires PostgreSQL 7.2 or later.

Değiştirgeler

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

data

A string containing text to be escaped.

Dönen Değerler

A string containing the escaped data.

Sürüm Bilgisi

Sürüm: | Açıklama
5.2.0 | connection added

Örnekler

Örnek 1 pg_escape_string() example

<?php
  // Connect to the database
  $dbconn = pg_connect('dbname=foo');

  // Read in a text file (containing apostrophes and backslashes)
  $data = file_get_contents('letter.txt');

  // Escape the text data
  $escaped = pg_escape_string($data);

  // Insert it into the database
  pg_query("INSERT INTO correspondence (name, data) VALUES ('My letter', '{$escaped}')");
?>

Ayrıca Bakınız

  • pg_escape_bytea() - Escape a string for insertion into a bytea field

pg_escape_literal
pg_execute
PostgreSQL İşlevleri


Sends a request to execute a prepared statement with given parameters, and waits for the result.

pg_escape_string
pg_fetch_all_columns
PostgreSQL İşlevleri
PHP Manual

pg_execute

(PHP 5 >= 5.1.0, PHP 7)

pg_execute — Sends a request to execute a prepared statement with given parameters, and waits for the result.

Açıklama

resource pg_execute ([ resource $connection ], string $stmtname , array $params )

Sends a request to execute a prepared statement with given parameters, and waits for the result.

pg_execute() is like pg_query_params(), but the command to be executed is specified by naming a previously-prepared statement, instead of giving a query string. This feature allows commands that will be used repeatedly to be parsed and planned just once, rather than each time they are executed. The statement must have been prepared previously in the current session. pg_execute() is supported only against PostgreSQL 7.4 or higher connections; it will fail when using earlier versions.

The parameters are identical to pg_query_params(), except that the name of a prepared statement is given instead of a query string.

Değiştirgeler

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

stmtname

The name of the prepared statement to execute. if "" is specified, then the unnamed statement is executed. The name must have been previously prepared using pg_prepare(), pg_send_prepare() or a PREPARE SQL command.

params

An array of parameter values to substitute for the $1, $2, etc. placeholders in the original prepared query string. The number of elements in the array must match the number of placeholders.

Uyarı

Elements are converted to strings by calling this function.

Dönen Değerler

A query result resource on success başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Using pg_execute()

<?php
// Connect to a database named "mary"
$dbconn = pg_connect("dbname=mary");

// Prepare a query for execution
$result = pg_prepare($dbconn, "my_query", 'SELECT * FROM shops WHERE name = $1');

// Execute the prepared query.  Note that it is not necessary to escape
// the string "Joe's Widgets" in any way
$result = pg_execute($dbconn, "my_query", array("Joe's Widgets"));

// Execute the same prepared query, this time with a different parameter
$result = pg_execute($dbconn, "my_query", array("Clothes Clothes Clothes"));

?>

Ayrıca Bakınız

  • pg_prepare() - Submits a request to create a prepared statement with the given parameters, and waits for completion.
  • pg_send_prepare() - Sends a request to create a prepared statement with the given parameters, without waiting for completion.
  • pg_query_params() - Submits a command to the server and waits for the result, with the ability to pass parameters separately from the SQL command text.

pg_escape_string
pg_fetch_all_columns
PostgreSQL İşlevleri


Fetches all rows in a particular result column as an array

pg_execute
pg_fetch_all
PostgreSQL İşlevleri
PHP Manual

pg_fetch_all_columns

(PHP 5 >= 5.1.0, PHP 7)

pg_fetch_all_columns — Fetches all rows in a particular result column as an array

Açıklama

array pg_fetch_all_columns ( resource $result [, int $column = 0 ] )

pg_fetch_all_columns() returns an array that contains all rows (records) in a particular column of the result resource.

Bilginize: Bu işlev NULL alanlara PHP NULL değerini atar.

Değiştirgeler

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

column

Column number, zero-based, to be retrieved from the result resource. Defaults to the first column if not specified.

Dönen Değerler

An array with all values in the result column.

FALSE is returned if column is larger than the number of columns in the result, or on any other error.

Örnekler

Örnek 1 pg_fetch_all_columns() example

<?php
$conn = pg_pconnect("dbname=publisher");
if (!$conn) {
  echo "An error occurred.\n";
  exit;
}

$result = pg_query($conn, "SELECT title, name, address FROM authors");
if (!$result) {
  echo "An error occurred.\n";
  exit;
}

// Get an array of all author names
$arr = pg_fetch_all_columns($result, 1);

var_dump($arr);

?>

Ayrıca Bakınız

  • pg_fetch_all() - Fetches all rows from a result as an array

pg_execute
pg_fetch_all
PostgreSQL İşlevleri


Fetches all rows from a result as an array

pg_fetch_all_columns
pg_fetch_array
PostgreSQL İşlevleri
PHP Manual

pg_fetch_all

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

pg_fetch_all — Fetches all rows from a result as an array

Açıklama

array pg_fetch_all ( resource $result )

pg_fetch_all() returns an array that contains all rows (records) in the result resource.

Bilginize: Bu işlev NULL alanlara PHP NULL değerini atar.

Değiştirgeler

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

Dönen Değerler

An array with all rows in the result. Each row is an array of field values indexed by field name.

FALSE is returned if there are no rows in the result, or on any other error.

Örnekler

Örnek 1 PostgreSQL fetch all

<?php
$conn = pg_pconnect("dbname=publisher");
if (!$conn) {
    echo "An error occurred.\n";
    exit;
}

$result = pg_query($conn, "SELECT * FROM authors");
if (!$result) {
    echo "An error occurred.\n";
    exit;
}

$arr = pg_fetch_all($result);

print_r($arr);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [0] => Array
        (
            [id] => 1
            [name] => Fred
        )

    [1] => Array
        (
            [id] => 2
            [name] => Bob
        )

)

Ayrıca Bakınız

  • pg_fetch_row() - Get a row as an enumerated array
  • pg_fetch_array() - Fetch a row as an array
  • pg_fetch_object() - Fetch a row as an object
  • pg_fetch_result() - Returns values from a result resource

pg_fetch_all_columns
pg_fetch_array
PostgreSQL İşlevleri


Fetch a row as an array

pg_fetch_all
pg_fetch_assoc
PostgreSQL İşlevleri
PHP Manual

pg_fetch_array

(PHP 4, PHP 5, PHP 7)

pg_fetch_array — Fetch a row as an array

Açıklama

array pg_fetch_array ( resource $result [, int $row [, int $result_type = PGSQL_BOTH ]] )

pg_fetch_array() returns an array that corresponds to the fetched row (record).

pg_fetch_array() is an extended version of pg_fetch_row(). In addition to storing the data in the numeric indices (field number) to the result array, it can also store the data using associative indices (field name). It stores both indicies by default.

Bilginize: Bu işlev NULL alanlara PHP NULL değerini atar.

pg_fetch_array() is NOT significantly slower than using pg_fetch_row(), and is significantly easier to use.

Değiştirgeler

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

row

Row number in result to fetch. Rows are numbered from 0 upwards. If omitted or NULL, the next row is fetched.

result_type

An optional parameter that controls how the returned array is indexed. result_type is a constant and can take the following values: PGSQL_ASSOC, PGSQL_NUM and PGSQL_BOTH. Using PGSQL_NUM, pg_fetch_array() will return an array with numerical indices, using PGSQL_ASSOC it will return only associative indices while PGSQL_BOTH, the default, will return both numerical and associative indices.

Dönen Değerler

An array indexed numerically (beginning with 0) or associatively (indexed by field name), or both. Each value in the array is represented as a string. Database NULL values are returned as NULL.

FALSE is returned if row exceeds the number of rows in the set, there are no more rows, or on any other error.

Örnekler

Örnek 1 pg_fetch_array() example

<?php

$conn = pg_pconnect("dbname=publisher");
if (!$conn) {
  echo "An error occurred.\n";
  exit;
}

$result = pg_query($conn, "SELECT author, email FROM authors");
if (!$result) {
  echo "An error occurred.\n";
  exit;
}

$arr = pg_fetch_array($result, 0, PGSQL_NUM);
echo $arr[0] . " <- Row 1 Author\n";
echo $arr[1] . " <- Row 1 E-mail\n";

// The row parameter is optional; NULL can be passed instead,
// to pass a result_type.  Successive calls to pg_fetch_array
// will return the next row.
$arr = pg_fetch_array($result, NULL, PGSQL_ASSOC);
echo $arr["author"] . " <- Row 2 Author\n";
echo $arr["email"] . " <- Row 2 E-mail\n";

$arr = pg_fetch_array($result);
echo $arr["author"] . " <- Row 3 Author\n";
echo $arr[1] . " <- Row 3 E-mail\n";

?>

Ayrıca Bakınız

  • pg_fetch_row() - Get a row as an enumerated array
  • pg_fetch_object() - Fetch a row as an object
  • pg_fetch_result() - Returns values from a result resource

pg_fetch_all
pg_fetch_assoc
PostgreSQL İşlevleri


Fetch a row as an associative array

pg_fetch_array
pg_fetch_object
PostgreSQL İşlevleri
PHP Manual

pg_fetch_assoc

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

pg_fetch_assoc — Fetch a row as an associative array

Açıklama

array pg_fetch_assoc ( resource $result [, int $row ] )

pg_fetch_assoc() returns an associative array that corresponds to the fetched row (records).

pg_fetch_assoc() is equivalent to calling pg_fetch_array() with PGSQL_ASSOC as the optional third parameter. It only returns an associative array. If you need the numeric indices, use pg_fetch_row().

Bilginize: Bu işlev NULL alanlara PHP NULL değerini atar.

pg_fetch_assoc() is NOT significantly slower than using pg_fetch_row(), and is significantly easier to use.

Değiştirgeler

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

row

Row number in result to fetch. Rows are numbered from 0 upwards. If omitted or NULL, the next row is fetched.

Dönen Değerler

An array indexed associatively (by field name). Each value in the array is represented as a string. Database NULL values are returned as NULL.

FALSE is returned if row exceeds the number of rows in the set, there are no more rows, or on any other error.

Örnekler

Örnek 1 pg_fetch_assoc() example

<?php
$conn = pg_connect("dbname=publisher");
if (!$conn) {
  echo "An error occurred.\n";
  exit;
}

$result = pg_query($conn, "SELECT id, author, email FROM authors");
if (!$result) {
  echo "An error occurred.\n";
  exit;
}

while ($row = pg_fetch_assoc($result)) {
  echo $row['id'];
  echo $row['author'];
  echo $row['email'];
}
?>

Ayrıca Bakınız

  • pg_fetch_row() - Get a row as an enumerated array
  • pg_fetch_array() - Fetch a row as an array
  • pg_fetch_object() - Fetch a row as an object
  • pg_fetch_result() - Returns values from a result resource

pg_fetch_array
pg_fetch_object
PostgreSQL İşlevleri


Fetch a row as an object

pg_fetch_assoc
pg_fetch_result
PostgreSQL İşlevleri
PHP Manual

pg_fetch_object

(PHP 4, PHP 5, PHP 7)

pg_fetch_object — Fetch a row as an object

Açıklama

object pg_fetch_object ( resource $result [, int $row [, int $result_type = PGSQL_ASSOC ]] )
object pg_fetch_object ( resource $result [, int $row [, string $class_name [, array $params ]]] )

pg_fetch_object() returns an object with properties that correspond to the fetched row's field names. It can optionally instantiate an object of a specific class, and pass parameters to that class's constructor.

Bilginize: Bu işlev NULL alanlara PHP NULL değerini atar.

Speed-wise, the function is identical to pg_fetch_array(), and almost as fast as pg_fetch_row() (the difference is insignificant).

Değiştirgeler

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

row

Row number in result to fetch. Rows are numbered from 0 upwards. If omitted or NULL, the next row is fetched.

result_type

Ignored and deprecated.

class_name

The name of the class to instantiate, set the properties of and return. If not specified, a stdClass object is returned.

params

An optional array of parameters to pass to the constructor for class_name objects.

Dönen Değerler

An object with one attribute for each field name in the result. Database NULL values are returned as NULL.

FALSE is returned if row exceeds the number of rows in the set, there are no more rows, or on any other error.

Örnekler

Örnek 1 pg_fetch_object() example

<?php

$database = "store";

$db_conn = pg_connect("host=localhost port=5432 dbname=$database");
if (!$db_conn) {
  echo "Failed connecting to postgres database $database\n";
  exit;
}

$qu = pg_query($db_conn, "SELECT * FROM books ORDER BY author");

while ($data = pg_fetch_object($qu)) {
  echo $data->author . " (";
  echo $data->year . "): ";
  echo $data->title . "<br />";
}

pg_free_result($qu);
pg_close($db_conn);

?>

Ayrıca Bakınız

  • pg_query() - Execute a query
  • pg_fetch_array() - Fetch a row as an array
  • pg_fetch_assoc() - Fetch a row as an associative array
  • pg_fetch_row() - Get a row as an enumerated array
  • pg_fetch_result() - Returns values from a result resource

pg_fetch_assoc
pg_fetch_result
PostgreSQL İşlevleri


Returns values from a result resource

pg_fetch_object
pg_fetch_row
PostgreSQL İşlevleri
PHP Manual

pg_fetch_result

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

pg_fetch_result — Returns values from a result resource

Açıklama

string pg_fetch_result ( resource $result , int $row , mixed $field )
string pg_fetch_result ( resource $result , mixed $field )

pg_fetch_result() returns the value of a particular row and field (column) in a PostgreSQL result resource.

Bilginize:

This function used to be called pg_result().

Değiştirgeler

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

row

Row number in result to fetch. Rows are numbered from 0 upwards. If omitted, next row is fetched.

field

A string representing the name of the field (column) to fetch, otherwise an int representing the field number to fetch. Fields are numbered from 0 upwards.

Dönen Değerler

Boolean is returned as "t" or "f". All other types, including arrays are returned as strings formatted in the same default PostgreSQL manner that you would see in the psql program. Database NULL values are returned as NULL.

FALSE is returned if row exceeds the number of rows in the set, or on any other error.

Örnekler

Örnek 1 pg_fetch_result() example

<?php
$db = pg_connect("dbname=users user=me") || die();

$res = pg_query($db, "SELECT 1 UNION ALL SELECT 2");

$val = pg_fetch_result($res, 1, 0);

echo "First field in the second row is: ", $val, "\n";
?>

Yukarıdaki örneğin çıktısı:

First field in the second row is: 2

Ayrıca Bakınız

  • pg_query() - Execute a query
  • pg_fetch_array() - Fetch a row as an array

pg_fetch_object
pg_fetch_row
PostgreSQL İşlevleri


Get a row as an enumerated array

pg_fetch_result
pg_field_is_null
PostgreSQL İşlevleri
PHP Manual

pg_fetch_row

(PHP 4, PHP 5, PHP 7)

pg_fetch_row — Get a row as an enumerated array

Açıklama

array pg_fetch_row ( resource $result [, int $row ] )

pg_fetch_row() fetches one row of data from the result associated with the specified result resource.

Bilginize: Bu işlev NULL alanlara PHP NULL değerini atar.

Değiştirgeler

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

row

Row number in result to fetch. Rows are numbered from 0 upwards. If omitted or NULL, the next row is fetched.

Dönen Değerler

An array, indexed from 0 upwards, with each value represented as a string. Database NULL values are returned as NULL.

FALSE is returned if row exceeds the number of rows in the set, there are no more rows, or on any other error.

Örnekler

Örnek 1 pg_fetch_row() example

<?php

$conn = pg_pconnect("dbname=publisher");
if (!$conn) {
  echo "An error occurred.\n";
  exit;
}

$result = pg_query($conn, "SELECT author, email FROM authors");
if (!$result) {
  echo "An error occurred.\n";
  exit;
}

while ($row = pg_fetch_row($result)) {
  echo "Author: $row[0]  E-mail: $row[1]";
  echo "<br />\n";
}

?>

Ayrıca Bakınız

  • pg_query() - Execute a query
  • pg_fetch_array() - Fetch a row as an array
  • pg_fetch_object() - Fetch a row as an object
  • pg_fetch_result() - Returns values from a result resource

pg_fetch_result
pg_field_is_null
PostgreSQL İşlevleri


Test if a field is SQL NULL

pg_fetch_row
pg_field_name
PostgreSQL İşlevleri
PHP Manual

pg_field_is_null

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

pg_field_is_null — Test if a field is SQL NULL

Açıklama

int pg_field_is_null ( resource $result , int $row , mixed $field )
int pg_field_is_null ( resource $result , mixed $field )

pg_field_is_null() tests if a field in a PostgreSQL result resource is SQL NULL or not.

Bilginize:

This function used to be called pg_fieldisnull().

Değiştirgeler

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

row

Row number in result to fetch. Rows are numbered from 0 upwards. If omitted, current row is fetched.

field

Field number (starting from 0) as an integer or the field name as a string.

Dönen Değerler

Returns 1 if the field in the given row is SQL NULL, 0 if not. FALSE is returned if the row is out of range, or upon any other error.

Örnekler

Örnek 1 pg_field_is_null() example

<?php
  $dbconn = pg_connect("dbname=publisher") or die ("Could not connect");
  $res = pg_query($dbconn, "select * from authors where author = 'Orwell'");
  if ($res) {
      if (pg_field_is_null($res, 0, "year") == 1) {
          echo "The value of the field year is null.\n";
      }
      if (pg_field_is_null($res, 0, "year") == 0) {
          echo "The value of the field year is not null.\n";
    }
 }
?>

pg_fetch_row
pg_field_name
PostgreSQL İşlevleri


Returns the name of a field

pg_field_is_null
pg_field_num
PostgreSQL İşlevleri
PHP Manual

pg_field_name

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

pg_field_name — Returns the name of a field

Açıklama

string pg_field_name ( resource $result , int $field_number )

pg_field_name() returns the name of the field occupying the given field_number in the given PostgreSQL result resource. Field numbering starts from 0.

Bilginize:

This function used to be called pg_fieldname().

Değiştirgeler

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

field_number

Field number, starting from 0.

Dönen Değerler

The field name, or FALSE on error.

Örnekler

Örnek 1 Getting information about fields

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  $res = pg_query($dbconn, "select * from authors where author = 'Orwell'");
  $i = pg_num_fields($res);
  for ($j = 0; $j < $i; $j++) {
      echo "column $j\n";
      $fieldname = pg_field_name($res, $j);
      echo "fieldname: $fieldname\n";
      echo "printed length: " . pg_field_prtlen($res, $fieldname) . " characters\n";
      echo "storage length: " . pg_field_size($res, $j) . " bytes\n";
      echo "field type: " . pg_field_type($res, $j) . " \n\n";
  }
?>

Yukarıdaki örneğin çıktısı:

column 0
fieldname: author
printed length: 6 characters
storage length: -1 bytes
field type: varchar

column 1
fieldname: year
printed length: 4 characters
storage length: 2 bytes
field type: int2

column 2
fieldname: title
printed length: 24 characters
storage length: -1 bytes
field type: varchar

Ayrıca Bakınız

  • pg_field_num() - Returns the field number of the named field

pg_field_is_null
pg_field_num
PostgreSQL İşlevleri


Returns the field number of the named field

pg_field_name
pg_field_prtlen
PostgreSQL İşlevleri
PHP Manual

pg_field_num

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

pg_field_num — Returns the field number of the named field

Açıklama

int pg_field_num ( resource $result , string $field_name )

pg_field_num() will return the number of the field number that corresponds to the field_name in the given PostgreSQL result resource.

Bilginize:

This function used to be called pg_fieldnum().

Değiştirgeler

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

field_name

The name of the field.

Dönen Değerler

The field number (numbered from 0), or -1 on error.

Örnekler

Örnek 1 Getting information about fields

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  $res = pg_query($dbconn, "select author, year, title from authors where author = 'Orwell'");

  echo "Column 'title' is field number: ", pg_field_num($res, 'title');
?>

Yukarıdaki örneğin çıktısı:

Column 'title' is field number: 2

Ayrıca Bakınız

  • pg_field_name() - Returns the name of a field

pg_field_name
pg_field_prtlen
PostgreSQL İşlevleri


Returns the printed length

pg_field_num
pg_field_size
PostgreSQL İşlevleri
PHP Manual

pg_field_prtlen

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

pg_field_prtlen — Returns the printed length

Açıklama

int pg_field_prtlen ( resource $result , int $row_number , mixed $field_name_or_number )
int pg_field_prtlen ( resource $result , mixed $field_name_or_number )

pg_field_prtlen() returns the actual printed length (number of characters) of a specific value in a PostgreSQL result. Row numbering starts at 0. This function will return FALSE on an error.

field_name_or_number can be passed either as an integer or as a string. If it is passed as an integer, PHP recognises it as the field number, otherwise as field name.

See the example given at the pg_field_name() page.

Bilginize:

This function used to be called pg_fieldprtlen().

Değiştirgeler

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

row

Row number in result. Rows are numbered from 0 upwards. If omitted, current row is fetched.

Dönen Değerler

The field printed length, or FALSE on error.

Örnekler

Örnek 1 Getting information about fields

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  $res = pg_query($dbconn, "select * from authors where author = 'Orwell'");
  $i = pg_num_fields($res);
  for ($j = 0; $j < $i; $j++) {
      echo "column $j\n";
      $fieldname = pg_field_name($res, $j);
      echo "fieldname: $fieldname\n";
      echo "printed length: " . pg_field_prtlen($res, $fieldname) . " characters\n";
      echo "storage length: " . pg_field_size($res, $j) . " bytes\n";
      echo "field type: " . pg_field_type($res, $j) . " \n\n";
  }
?>

Yukarıdaki örneğin çıktısı:

column 0
fieldname: author
printed length: 6 characters
storage length: -1 bytes
field type: varchar

column 1
fieldname: year
printed length: 4 characters
storage length: 2 bytes
field type: int2

column 2
fieldname: title
printed length: 24 characters
storage length: -1 bytes
field type: varchar

Ayrıca Bakınız

  • pg_field_size() - Returns the internal storage size of the named field

pg_field_num
pg_field_size
PostgreSQL İşlevleri


Returns the internal storage size of the named field

pg_field_prtlen
pg_field_table
PostgreSQL İşlevleri
PHP Manual

pg_field_size

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

pg_field_size — Returns the internal storage size of the named field

Açıklama

int pg_field_size ( resource $result , int $field_number )

pg_field_size() returns the internal storage size (in bytes) of the field number in the given PostgreSQL result.

Bilginize:

This function used to be called pg_fieldsize().

Değiştirgeler

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

field_number

Field number, starting from 0.

Dönen Değerler

The internal field storage size (in bytes). -1 indicates a variable length field. FALSE is returned on error.

Örnekler

Örnek 1 Getting information about fields

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  $res = pg_query($dbconn, "select * from authors where author = 'Orwell'");
  $i = pg_num_fields($res);
  for ($j = 0; $j < $i; $j++) {
      echo "column $j\n";
      $fieldname = pg_field_name($res, $j);
      echo "fieldname: $fieldname\n";
      echo "printed length: " . pg_field_prtlen($res, $fieldname) . " characters\n";
      echo "storage length: " . pg_field_size($res, $j) . " bytes\n";
      echo "field type: " . pg_field_type($res, $j) . " \n\n";
  }
?>

Yukarıdaki örneğin çıktısı:

column 0
fieldname: author
printed length: 6 characters
storage length: -1 bytes
field type: varchar

column 1
fieldname: year
printed length: 4 characters
storage length: 2 bytes
field type: int2

column 2
fieldname: title
printed length: 24 characters
storage length: -1 bytes
field type: varchar

Ayrıca Bakınız

  • pg_field_prtlen() - Returns the printed length
  • pg_field_type() - Returns the type name for the corresponding field number

pg_field_prtlen
pg_field_table
PostgreSQL İşlevleri


Returns the name or oid of the tables field

pg_field_size
pg_field_type_oid
PostgreSQL İşlevleri
PHP Manual

pg_field_table

(PHP 5 >= 5.2.0, PHP 7)

pg_field_table — Returns the name or oid of the tables field

Açıklama

mixed pg_field_table ( resource $result , int $field_number [, bool $oid_only = false ] )

pg_field_table() returns the name of the table that field belongs to, or the table's oid if oid_only is TRUE.

Değiştirgeler

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

field_number

Field number, starting from 0.

oid_only

By default the tables name that field belongs to is returned but if oid_only is set to TRUE, then the oid will instead be returned.

Dönen Değerler

On success either the fields table name or oid. Or, FALSE on failure.

Örnekler

Örnek 1 Getting table information about a field

<?php
$dbconn = pg_connect("dbname=publisher") or die("Could not connect");

$res = pg_query($dbconn, "SELECT bar FROM foo");

echo pg_field_table($res, 0);
echo pg_field_table($res, 0, true);

$res = pg_query($dbconn, "SELECT version()");
var_dump(pg_field_table($res, 0));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

foo
14379580

bool(false)

Notlar

Bilginize:

Returning the oid is much faster than returning the table name because fetching the table name requires a query to the database system table.

Ayrıca Bakınız

  • pg_field_name() - Returns the name of a field
  • pg_field_type() - Returns the type name for the corresponding field number

pg_field_size
pg_field_type_oid
PostgreSQL İşlevleri


Returns the type ID (OID) for the corresponding field number

pg_field_table
pg_field_type
PostgreSQL İşlevleri
PHP Manual

pg_field_type_oid

(PHP 5 >= 5.1.0, PHP 7)

pg_field_type_oid — Returns the type ID (OID) for the corresponding field number

Açıklama

int pg_field_type_oid ( resource $result , int $field_number )

pg_field_type_oid() returns an integer containing the OID of the base type of the given field_number in the given PostgreSQL result resource.

You can get more information about the field type by querying PostgreSQL's pg_type system table using the OID obtained with this function. The PostgreSQL format_type() function will convert a type OID into an SQL standard type name.

Bilginize:

If the field uses a PostgreSQL domain (rather than a basic type), it is the OID of the domain's underlying type that is returned, rather than the OID of the domain itself.

Değiştirgeler

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

field_number

Field number, starting from 0.

Dönen Değerler

The OID of the field's base type. FALSE is returned on error.

Örnekler

Örnek 1 Getting information about fields

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  // Assume 'title' is a varchar type
  $res = pg_query($dbconn, "select title from authors where author = 'Orwell'");

  echo "Title field type OID: ", pg_field_type_oid($res, 0);
?>

Yukarıdaki örneğin çıktısı:

Title field type OID: 1043

Ayrıca Bakınız

  • pg_field_type() - Returns the type name for the corresponding field number
  • pg_field_prtlen() - Returns the printed length
  • pg_field_name() - Returns the name of a field

pg_field_table
pg_field_type
PostgreSQL İşlevleri


Returns the type name for the corresponding field number

pg_field_type_oid
pg_flush
PostgreSQL İşlevleri
PHP Manual

pg_field_type

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

pg_field_type — Returns the type name for the corresponding field number

Açıklama

string pg_field_type ( resource $result , int $field_number )

pg_field_type() returns a string containing the base type name of the given field_number in the given PostgreSQL result resource.

Bilginize:

If the field uses a PostgreSQL domain (rather than a basic type), it is the name of the domain's underlying type that is returned, rather than the name of the domain itself.

Bilginize:

This function used to be called pg_fieldtype().

Değiştirgeler

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

field_number

Field number, starting from 0.

Dönen Değerler

A string containing the base name of the field's type, or FALSE on error.

Örnekler

Örnek 1 Getting information about fields

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  // Assume 'title' is a varchar type
  $res = pg_query($dbconn, "select title from authors where author = 'Orwell'");

  echo "Title field type: ", pg_field_type($res, 0);
?>

Yukarıdaki örneğin çıktısı:

Title field type: varchar

Ayrıca Bakınız

  • pg_field_prtlen() - Returns the printed length
  • pg_field_name() - Returns the name of a field
  • pg_field_type_oid() - Returns the type ID (OID) for the corresponding field number

pg_field_type_oid
pg_flush
PostgreSQL İşlevleri


Flush outbound query data on the connection

pg_field_type
pg_free_result
PostgreSQL İşlevleri
PHP Manual

pg_flush

(PHP 5 >= 5.6.0, PHP 7)

pg_flush — Flush outbound query data on the connection

Açıklama

mixed pg_flush ( resource $connection )

pg_flush() flushes any outbound query data waiting to be sent on the connection.

Değiştirgeler

connection

PostgreSQL database connection resource.

Dönen Değerler

Returns TRUE if the flush was successful or no data was waiting to be flushed, 0 if part of the pending data was flushed but more remains başarısızlık durumunda FALSE döner.

pg_field_type
pg_free_result
PostgreSQL İşlevleri


Free result memory

pg_flush
pg_get_notify
PostgreSQL İşlevleri
PHP Manual

pg_free_result

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

pg_free_result — Free result memory

Açıklama

bool pg_free_result ( resource $result )

pg_free_result() frees the memory and data associated with the specified PostgreSQL query result resource.

This function need only be called if memory consumption during script execution is a problem. Otherwise, all result memory will be automatically freed when the script ends.

Bilginize:

This function used to be called pg_freeresult().

Değiştirgeler

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 pg_free_result() example

<?php
$db = pg_connect("dbname=users user=me") || die();

$res = pg_query($db, "SELECT 1 UNION ALL SELECT 2");

$val = pg_fetch_result($res, 1, 0);

echo "First field in the second row is: ", $val, "\n";

pg_free_result($res);
?>

Yukarıdaki örneğin çıktısı:

First field in the second row is: 2

Ayrıca Bakınız

  • pg_query() - Execute a query
  • pg_query_params() - Submits a command to the server and waits for the result, with the ability to pass parameters separately from the SQL command text.
  • pg_execute() - Sends a request to execute a prepared statement with given parameters, and waits for the result.

pg_flush
pg_get_notify
PostgreSQL İşlevleri


Gets SQL NOTIFY message

pg_free_result
pg_get_pid
PostgreSQL İşlevleri
PHP Manual

pg_get_notify

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

pg_get_notify — Gets SQL NOTIFY message

Açıklama

array pg_get_notify ( resource $connection [, int $result_type ] )

pg_get_notify() gets notifications generated by a NOTIFY SQL command. To receive notifications, the LISTEN SQL command must be issued.

Değiştirgeler

connection

PostgreSQL database connection resource.

result_type

An optional parameter that controls how the returned array is indexed. result_type is a constant and can take the following values: PGSQL_ASSOC, PGSQL_NUM and PGSQL_BOTH. Using PGSQL_NUM, pg_get_notify() will return an array with numerical indices, using PGSQL_ASSOC it will return only associative indices while PGSQL_BOTH, the default, will return both numerical and associative indices.

Dönen Değerler

An array containing the NOTIFY message name and backend PID. As of PHP 5.4.0 and if supported by the server, the array also contains the server version and the payload. Otherwise if no NOTIFY is waiting, then FALSE is returned.

Örnekler

Örnek 1 PostgreSQL NOTIFY message

<?php
$conn = pg_pconnect("dbname=publisher");
if (!$conn) {
  echo "An error occurred.\n";
  exit;
}

// Listen 'author_updated' message from other processes
pg_query($conn, 'LISTEN author_updated;');
$notify = pg_get_notify($conn);
if (!$notify) {
  echo "No messages\n";
} else {
  print_r($notify);
}
?>

Ayrıca Bakınız

  • pg_get_pid() - Gets the backend's process ID

pg_free_result
pg_get_pid
PostgreSQL İşlevleri


Gets the backend's process ID

pg_get_notify
pg_get_result
PostgreSQL İşlevleri
PHP Manual

pg_get_pid

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

pg_get_pid — Gets the backend's process ID

Açıklama

int pg_get_pid ( resource $connection )

pg_get_pid() gets the backend's (database server process) PID. The PID is useful to determine whether or not a NOTIFY message received via pg_get_notify() is sent from another process or not.

Değiştirgeler

connection

PostgreSQL database connection resource.

Dönen Değerler

The backend database process ID.

Örnekler

Örnek 1 PostgreSQL backend PID

<?php
$conn = pg_pconnect("dbname=publisher");
if (!$conn) {
  echo "An error occurred.\n";
  exit;
}

// Backend process PID. Use PID with pg_get_notify()
$pid = pg_get_pid($conn);
?>

Ayrıca Bakınız

  • pg_get_notify() - Gets SQL NOTIFY message

pg_get_notify
pg_get_result
PostgreSQL İşlevleri


Get asynchronous query result

pg_get_pid
pg_host
PostgreSQL İşlevleri
PHP Manual

pg_get_result

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

pg_get_result — Get asynchronous query result

Açıklama

resource pg_get_result ([ resource $connection ] )

pg_get_result() gets the result resource from an asynchronous query executed by pg_send_query(), pg_send_query_params() or pg_send_execute().

pg_send_query() and the other asynchronous query functions can send multiple queries to a PostgreSQL server and pg_get_result() is used to get each query's results, one by one.

Değiştirgeler

connection

PostgreSQL database connection resource.

Dönen Değerler

The result resource, or FALSE if no more results are available.

Örnekler

Örnek 1 pg_get_result() example

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  if (!pg_connection_busy($dbconn)) {
      pg_send_query($dbconn, "select * from authors; select count(*) from authors;");
  }

  $res1 = pg_get_result($dbconn);
  echo "First call to pg_get_result(): $res1\n";
  $rows1 = pg_num_rows($res1);
  echo "$res1 has $rows1 records\n\n";

  $res2 = pg_get_result($dbconn);
  echo "Second call to pg_get_result(): $res2\n";
  $rows2 = pg_num_rows($res2);
  echo "$res2 has $rows2 records\n";
?>

Yukarıdaki örneğin çıktısı:

First call to pg_get_result(): Resource id #3
Resource id #3 has 3 records

Second call to pg_get_result(): Resource id #4
Resource id #4 has 1 records

Ayrıca Bakınız

  • pg_send_query() - Sends asynchronous query

pg_get_pid
pg_host
PostgreSQL İşlevleri


Returns the host name associated with the connection

pg_get_result
pg_insert
PostgreSQL İşlevleri
PHP Manual

pg_host

(PHP 4, PHP 5, PHP 7)

pg_host — Returns the host name associated with the connection

Açıklama

string pg_host ([ resource $connection ] )

pg_host() returns the host name of the given PostgreSQL connection resource is connected to.

Değiştirgeler

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

Dönen Değerler

A string containing the name of the host the connection is to, or FALSE on error.

Örnekler

Örnek 1 pg_host() example

<?php
$pgsql_conn = pg_connect("dbname=mark host=localhost");

if ($pgsql_conn) {
   print "Successfully connected to: " . pg_host($pgsql_conn) . "<br/>\n";
} else {
   print pg_last_error($pgsql_conn);
   exit;
}
?>

Ayrıca Bakınız

  • pg_connect() - Open a PostgreSQL connection
  • pg_pconnect() - Open a persistent PostgreSQL connection

pg_get_result
pg_insert
PostgreSQL İşlevleri


Insert array into table

pg_host
pg_last_error
PostgreSQL İşlevleri
PHP Manual

pg_insert

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

pg_insert — Insert array into table

Açıklama

mixed pg_insert ( resource $connection , string $table_name , array $assoc_array [, int $options = PGSQL_DML_EXEC ] )

pg_insert() inserts the values of assoc_array into the table specified by table_name. If options is specified, pg_convert() is applied to assoc_array with the specified options.

Değiştirgeler

connection

PostgreSQL database connection resource.

table_name

Name of the table into which to insert rows. The table table_name must at least have as many columns as assoc_array has elements.

assoc_array

An array whose keys are field names in the table table_name, and whose values are the values of those fields that are to be inserted.

options

Any number of PGSQL_CONV_OPTS, PGSQL_DML_NO_CONV, PGSQL_DML_ESCAPE, PGSQL_DML_EXEC, PGSQL_DML_ASYNC or PGSQL_DML_STRING combined. If PGSQL_DML_STRING is part of the options then query string is returned. When PGSQL_DML_NO_CONV or PGSQL_DML_ESCAPE is set, it does not call pg_convert() internally.

Dönen Değerler

Returns the connection resource on success, başarısızlık durumunda FALSE döner. Returns string if PGSQL_DML_STRING is passed via options.

Örnekler

Örnek 1 pg_insert() example

<?php
  $dbconn = pg_connect('dbname=foo');
  // This is safe, since $_POST is converted automatically
  $res = pg_insert($dbconn, 'post_log', $_POST);
  if ($res) {
      echo "POST data is successfully logged\n";
  } else {
      echo "User must have sent wrong inputs\n";
  }
?>

Sürüm Bilgisi

Sürüm: | Açıklama
5.6.0 | Unless PGSQL_DML_STRING is passed, the function now returns the connection resource instead of TRUE on success.
5.6.0 | No longer experimental. Added PGSQL_DML_ESCAPE constant, TRUE/FALSE and NULL data type support.
5.5.3/5.4.19 | Direct SQL injection to table_name and Indirect SQL injection to identifiers are fixed.

Ayrıca Bakınız

  • pg_convert() - Convert associative array values into suitable for SQL statement

pg_host
pg_last_error
PostgreSQL İşlevleri


Get the last error message string of a connection

pg_insert
pg_last_notice
PostgreSQL İşlevleri
PHP Manual

pg_last_error

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

pg_last_error — Get the last error message string of a connection

Açıklama

string pg_last_error ([ resource $connection ] )

pg_last_error() returns the last error message for a given connection.

Error messages may be overwritten by internal PostgreSQL (libpq) function calls. It may not return an appropriate error message if multiple errors occur inside a PostgreSQL module function.

Use pg_result_error(), pg_result_error_field(),
pg_result_status() and
pg_connection_status() for better error handling.

Bilginize:

This function used to be called pg_errormessage().

Değiştirgeler

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

Dönen Değerler

A string containing the last error message on the given connection, or FALSE on error.

Örnekler

Örnek 1 pg_last_error() example

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  // Query that fails
  $res = pg_query($dbconn, "select * from doesnotexist");

  echo pg_last_error($dbconn);
?>

Ayrıca Bakınız

  • pg_result_error() - Get error message associated with result
  • pg_result_error_field() - Returns an individual field of an error report.

pg_insert
pg_last_notice
PostgreSQL İşlevleri


Returns the last notice message from PostgreSQL server

pg_last_error
pg_last_oid
PostgreSQL İşlevleri
PHP Manual

pg_last_notice

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

pg_last_notice — Returns the last notice message from PostgreSQL server

Açıklama

string pg_last_notice ( resource $connection )

pg_last_notice() returns the last notice message from the PostgreSQL server on the specified connection. The PostgreSQL server sends notice messages in several cases, for instance when creating a SERIAL column in a table.

With pg_last_notice(), you can avoid issuing useless queries by checking whether or not the notice is related to your transaction.

Notice message tracking can be set to optional by setting 1 for pgsql.ignore_notice in php.ini.

Notice message logging can be set to optional by setting 0 for pgsql.log_notice in php.ini. Unless pgsql.ignore_notice is set to 0, notice message cannot be logged.

Değiştirgeler

connection

PostgreSQL database connection resource.

Dönen Değerler

A string containing the last notice on the given connection, or FALSE on error.

Örnekler

Örnek 1 pg_last_notice() example

<?php
  $pgsql_conn = pg_connect("dbname=mark host=localhost");

  $res = pg_query("CREATE TABLE test (id SERIAL)");

  $notice = pg_last_notice($pgsql_conn);

  echo $notice;
?>

Yukarıdaki örneğin çıktısı:

CREATE TABLE will create implicit sequence "test_id_seq" for "serial" column "test.id"

Ayrıca Bakınız

  • pg_query() - Execute a query
  • pg_last_error() - Get the last error message string of a connection

pg_last_error
pg_last_oid
PostgreSQL İşlevleri


Returns the last row's OID

pg_last_notice
pg_lo_close
PostgreSQL İşlevleri
PHP Manual

pg_last_oid

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

pg_last_oid — Returns the last row's OID

Açıklama

string pg_last_oid ( resource $result )

pg_last_oid() is used to retrieve the OID assigned to an inserted row.

OID field became an optional field from PostgreSQL 7.2 and will not be present by default in PostgreSQL 8.1. When the OID field is not present in a table, the programmer must use pg_result_status() to check for successful insertion.

To get the value of a SERIAL field in an inserted row, it is necessary to use the PostgreSQL CURRVAL function, naming the sequence whose last value is required. If the name of the sequence is unknown, the pg_get_serial_sequence PostgreSQL 8.0 function is necessary.

PostgreSQL 8.1 has a function LASTVAL that returns the value of the most recently used sequence in the session. This avoids the need for naming the sequence, table or column altogether.

Bilginize:

This function used to be called pg_getlastoid().

Değiştirgeler

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

Dönen Değerler

A string containing the OID assigned to the most recently inserted row in the specified connection, or FALSE on error or no available OID.

Örnekler

Örnek 1 pg_last_oid() example

<?php
  // Connect to the database
  pg_connect("dbname=mark host=localhost");

  // Create a sample table
  pg_query("CREATE TABLE test (a INTEGER) WITH OIDS");

  // Insert some data into it
  $res = pg_query("INSERT INTO test VALUES (1)");

  $oid = pg_last_oid($res);
?>

Ayrıca Bakınız

  • pg_query() - Execute a query
  • pg_result_status() - Get status of query result

pg_last_notice
pg_lo_close
PostgreSQL İşlevleri


Close a large object

pg_last_oid
pg_lo_create
PostgreSQL İşlevleri
PHP Manual

pg_lo_close

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

pg_lo_close — Close a large object

Açıklama

bool pg_lo_close ( resource $large_object )

pg_lo_close() closes a large object. large_object is a resource for the large object from pg_lo_open().

To use the large object interface, it is necessary to enclose it within a transaction block.

Bilginize:

This function used to be called pg_loclose().

Değiştirgeler

result

PostgreSQL large object (LOB) resource, returned by pg_lo_open().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 pg_lo_close() example

<?php
   $database = pg_connect("dbname=jacarta");
   pg_query($database, "begin");
   $oid = pg_lo_create($database);
   echo "$oid\n";
   $handle = pg_lo_open($database, $oid, "w");
   echo "$handle\n";
   pg_lo_write($handle, "large object data");
   pg_lo_close($handle);
   pg_query($database, "commit");
?>

Ayrıca Bakınız

  • pg_lo_open() - Open a large object
  • pg_lo_create() - Create a large object
  • pg_lo_import() - Import a large object from file

pg_last_oid
pg_lo_create
PostgreSQL İşlevleri


Create a large object

pg_lo_close
pg_lo_export
PostgreSQL İşlevleri
PHP Manual

pg_lo_create

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

pg_lo_create — Create a large object

Açıklama

int pg_lo_create ([ resource $connection [, mixed $object_id ]] )
int pg_lo_create ( mixed $object_id )

pg_lo_create() creates a large object and returns the OID of the large object. PostgreSQL access modes INV_READ, INV_WRITE, and INV_ARCHIVE are not supported, the object is created always with both read and write access. INV_ARCHIVE has been removed from PostgreSQL itself (version 6.3 and above).

To use the large object interface, it is necessary to enclose it within a transaction block.

Instead of using the large object interface (which has no access controls and is cumbersome to use), try PostgreSQL's bytea column type and pg_escape_bytea().

Bilginize:

This function used to be called pg_locreate().

Değiştirgeler

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

object_id

If an object_id is given the function will try to create a large object with this id, else a free object id is assigned by the server. The parameter was added in PHP 5.3 and relies on functionality that first appeared in PostgreSQL 8.1.

Dönen Değerler

A large object OID or FALSE on error.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | The optional object_id was added.

Örnekler

Örnek 1 pg_lo_create() example

<?php
   $database = pg_connect("dbname=jacarta");
   pg_query($database, "begin");
   $oid = pg_lo_create($database);
   echo "$oid\n";
   $handle = pg_lo_open($database, $oid, "w");
   echo "$handle\n";
   pg_lo_write($handle, "large object data");
   pg_lo_close($handle);
   pg_query($database, "commit");
?>

pg_lo_close
pg_lo_export
PostgreSQL İşlevleri


Export a large object to file

pg_lo_create
pg_lo_import
PostgreSQL İşlevleri
PHP Manual

pg_lo_export

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

pg_lo_export — Export a large object to file

Açıklama

bool pg_lo_export ([ resource $connection ], int $oid , string $pathname )

pg_lo_export() takes a large object in a PostgreSQL database and saves its contents to a file on the local filesystem.

To use the large object interface, it is necessary to enclose it within a transaction block.

Bilginize:

This function used to be called pg_loexport().

Değiştirgeler

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

oid

The OID of the large object in the database.

pathname

The full path and file name of the file in which to write the large object on the client filesystem.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 pg_lo_export() example

<?php
   $database = pg_connect("dbname=jacarta");
   pg_query($database, "begin");
   $oid = pg_lo_create($database);
   $handle = pg_lo_open($database, $oid, "w");
   pg_lo_write($handle, "large object data");
   pg_lo_close($handle);
   pg_lo_export($database, $oid, '/tmp/lob.dat');
   pg_query($database, "commit");
?>

Ayrıca Bakınız

  • pg_lo_import() - Import a large object from file

pg_lo_create
pg_lo_import
PostgreSQL İşlevleri


Import a large object from file

pg_lo_export
pg_lo_open
PostgreSQL İşlevleri
PHP Manual

pg_lo_import

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

pg_lo_import — Import a large object from file

Açıklama

int pg_lo_import ([ resource $connection ], string $pathname [, mixed $object_id ] )

pg_lo_import() creates a new large object in the database using a file on the filesystem as its data source.

To use the large object interface, it is necessary to enclose it within a transaction block.

Bilginize: Güvenli kip etkinken, PHP, dosya ve dizinlerin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığını sınar.

Bilginize:

This function used to be called pg_loimport().

Değiştirgeler

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

pathname

The full path and file name of the file on the client filesystem from which to read the large object data.

object_id

If an object_id is given the function will try to create a large object with this id, else a free object id is assigned by the server. The parameter was added in PHP 5.3 and relies on functionality that first appeared in PostgreSQL 8.1.

Dönen Değerler

The OID of the newly created large object, or FALSE on failure.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | The optional object_id was added.

Örnekler

Örnek 1 pg_lo_import() example

<?php
   $database = pg_connect("dbname=jacarta");
   pg_query($database, "begin");
   $oid = pg_lo_import($database, '/tmp/lob.dat');
   pg_query($database, "commit");
?>

Ayrıca Bakınız

  • pg_lo_export() - Export a large object to file
  • pg_lo_open() - Open a large object

pg_lo_export
pg_lo_open
PostgreSQL İşlevleri


Open a large object

pg_lo_import
pg_lo_read_all
PostgreSQL İşlevleri
PHP Manual

pg_lo_open

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

pg_lo_open — Open a large object

Açıklama

resource pg_lo_open ( resource $connection , int $oid , string $mode )

pg_lo_open() opens a large object in the database and returns large object resource so that it can be manipulated.

Uyarı

Do not close the database connection before closing the large object resource.

To use the large object interface, it is necessary to enclose it within a transaction block.

Bilginize:

This function used to be called pg_loopen().

Değiştirgeler

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

oid

The OID of the large object in the database.

mode

Can be either "r" for read-only, "w" for write only or "rw" for read and write.

Dönen Değerler

A large object resource or FALSE on error.

Örnekler

Örnek 1 pg_lo_open() example

<?php
   $database = pg_connect("dbname=jacarta");
   pg_query($database, "begin");
   $oid = pg_lo_create($database);
   echo "$oid\n";
   $handle = pg_lo_open($database, $oid, "w");
   echo "$handle\n";
   pg_lo_write($handle, "large object data");
   pg_lo_close($handle);
   pg_query($database, "commit");
?>

Ayrıca Bakınız

  • pg_lo_close() - Close a large object
  • pg_lo_create() - Create a large object

pg_lo_import
pg_lo_read_all
PostgreSQL İşlevleri


Reads an entire large object and send straight to browser

pg_lo_open
pg_lo_read
PostgreSQL İşlevleri
PHP Manual

pg_lo_read_all

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

pg_lo_read_all — Reads an entire large object and send straight to browser

Açıklama

int pg_lo_read_all ( resource $large_object )

pg_lo_read_all() reads a large object and passes it straight through to the browser after sending all pending headers. Mainly intended for sending binary data like images or sound.

To use the large object interface, it is necessary to enclose it within a transaction block.

Bilginize:

This function used to be called pg_loreadall().

Değiştirgeler

large_object

PostgreSQL large object (LOB) resource, returned by pg_lo_open().

Dönen Değerler

Number of bytes read or FALSE on error.

Örnekler

Örnek 1 pg_lo_read_all() example

<?php
   header('Content-type: image/jpeg');
   $image_oid = 189762345;
   $database = pg_connect("dbname=jacarta");
   pg_query($database, "begin");
   $handle = pg_lo_open($database, $image_oid, "r");
   pg_lo_read_all($handle);
   pg_query($database, "commit");
?>

Ayrıca Bakınız

  • pg_lo_read() - Read a large object

pg_lo_open
pg_lo_read
PostgreSQL İşlevleri


Read a large object

pg_lo_read_all
pg_lo_seek
PostgreSQL İşlevleri
PHP Manual

pg_lo_read

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

pg_lo_read — Read a large object

Açıklama

string pg_lo_read ( resource $large_object [, int $len = 8192 ] )

pg_lo_read() reads at most len bytes from a large object and returns it as a string.

To use the large object interface, it is necessary to enclose it within a transaction block.

Bilginize:

This function used to be called pg_loread().

Değiştirgeler

large_object

PostgreSQL large object (LOB) resource, returned by pg_lo_open().

len

An optional maximum number of bytes to return.

Dönen Değerler

A string containing len bytes from the large object, or FALSE on error.

Örnekler

Örnek 1 pg_lo_read() example

<?php
   $doc_oid = 189762345;
   $database = pg_connect("dbname=jacarta");
   pg_query($database, "begin");
   $handle = pg_lo_open($database, $doc_oid, "r");
   $data = pg_lo_read($handle, 50000);
   pg_query($database, "commit");
   echo $data;
?>

Ayrıca Bakınız

  • pg_lo_read_all() - Reads an entire large object and send straight to browser

pg_lo_read_all
pg_lo_seek
PostgreSQL İşlevleri


Seeks position within a large object

pg_lo_read
pg_lo_tell
PostgreSQL İşlevleri
PHP Manual

pg_lo_seek

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

pg_lo_seek — Seeks position within a large object

Açıklama

bool pg_lo_seek ( resource $large_object , int $offset [, int $whence = PGSQL_SEEK_CUR ] )

pg_lo_seek() seeks a position within a large object resource.

To use the large object interface, it is necessary to enclose it within a transaction block.

Değiştirgeler

large_object

PostgreSQL large object (LOB) resource, returned by pg_lo_open().

offset

The number of bytes to seek.

whence

One of the constants PGSQL_SEEK_SET (seek from object start), PGSQL_SEEK_CUR (seek from current position) or PGSQL_SEEK_END (seek from object end) .

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 pg_lo_seek() example

<?php
   $doc_oid = 189762345;
   $database = pg_connect("dbname=jacarta");
   pg_query($database, "begin");
   $handle = pg_lo_open($database, $doc_oid, "r");
   // Skip first 50000 bytes
   pg_lo_seek($handle, 50000, PGSQL_SEEK_SET);
   // Read the next 10000 bytes
   $data = pg_lo_read($handle, 10000);
   pg_query($database, "commit");
   echo $data;
?>

Sürüm Bilgisi

Sürüm: | Açıklama
5.6.0 | Added PostgreSQL 9.3's 64bit large object support. Both client and server must support PostgreSQL 9.3 and PHP must be 64bit build to use 64bit large object.

Ayrıca Bakınız

  • pg_lo_tell() - Returns current seek position a of large object

pg_lo_read
pg_lo_tell
PostgreSQL İşlevleri


Returns current seek position a of large object

pg_lo_seek
pg_lo_truncate
PostgreSQL İşlevleri
PHP Manual

pg_lo_tell

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

pg_lo_tell — Returns current seek position a of large object

Açıklama

int pg_lo_tell ( resource $large_object )

pg_lo_tell() returns the current position (offset from the beginning) of a large object.

To use the large object interface, it is necessary to enclose it within a transaction block.

Değiştirgeler

large_object

PostgreSQL large object (LOB) resource, returned by pg_lo_open().

Dönen Değerler

The current seek offset (in number of bytes) from the beginning of the large object. If there is an error, the return value is negative.

Örnekler

Örnek 1 pg_lo_tell() example

<?php
   $doc_oid = 189762345;
   $database = pg_connect("dbname=jacarta");
   pg_query($database, "begin");
   $handle = pg_lo_open($database, $doc_oid, "r");
   // Skip first 50000 bytes
   pg_lo_seek($handle, 50000, PGSQL_SEEK_SET);
   // See how far we've skipped
   $offset = pg_lo_tell($handle);
   echo "Seek position is: $offset";
   pg_query($database, "commit");
?>

Yukarıdaki örneğin çıktısı:

Seek position is: 50000

Sürüm Bilgisi

Sürüm: | Açıklama
5.6.0 | Added PostgreSQL 9.3's 64bit large object support. Both client and server must support PostgreSQL 9.3 and PHP must be 64bit build to use 64bit large object.

Ayrıca Bakınız

  • pg_lo_seek() - Seeks position within a large object

pg_lo_seek
pg_lo_truncate
PostgreSQL İşlevleri


Truncates a large object

pg_lo_tell
pg_lo_unlink
PostgreSQL İşlevleri
PHP Manual

pg_lo_truncate

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

pg_lo_truncate — Truncates a large object

Açıklama

bool pg_lo_truncate ( resource $large_object , int $size )

pg_lo_truncate() truncates a large object resource.

To use the large object interface, it is necessary to enclose it within a transaction block.

Değiştirgeler

large_object

PostgreSQL large object (LOB) resource, returned by pg_lo_open().

size

The number of bytes to truncate.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 pg_lo_truncate() example

<?php
   $doc_oid = 189762345;
   $database = pg_connect("dbname=jacarta");
   pg_query($database, "begin");
   $handle = pg_lo_open($database, $doc_oid, "r");
   // Truncate to 0
   pg_lo_truncate($handle, 0);
   pg_query($database, "commit");
   echo $data;
?>

Sürüm Bilgisi

Sürüm: | Açıklama
5.6.0 | Added truncate function. It supports PostgreSQL 9.3's 64bit large object. Both client and server must support PostgreSQL 9.3 and PHP must be 64bit build to use 64bit large object.

Ayrıca Bakınız

  • pg_lo_tell() - Returns current seek position a of large object

pg_lo_tell
pg_lo_unlink
PostgreSQL İşlevleri


Delete a large object

pg_lo_truncate
pg_lo_write
PostgreSQL İşlevleri
PHP Manual

pg_lo_unlink

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

pg_lo_unlink — Delete a large object

Açıklama

bool pg_lo_unlink ( resource $connection , int $oid )

pg_lo_unlink() deletes a large object with the oid. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

To use the large object interface, it is necessary to enclose it within a transaction block.

Bilginize:

This function used to be called pg_lounlink().

Değiştirgeler

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

oid

The OID of the large object in the database.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 pg_lo_unlink() example

<?php
   // OID of the large object to delete
   $doc_oid = 189762345;
   $database = pg_connect("dbname=jacarta");
   pg_query($database, "begin");
   pg_lo_unlink($database, $doc_oid);
   pg_query($database, "commit");
?>

Ayrıca Bakınız

  • pg_lo_create() - Create a large object
  • pg_lo_import() - Import a large object from file

pg_lo_truncate
pg_lo_write
PostgreSQL İşlevleri


Write to a large object

pg_lo_unlink
pg_meta_data
PostgreSQL İşlevleri
PHP Manual

pg_lo_write

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

pg_lo_write — Write to a large object

Açıklama

int pg_lo_write ( resource $large_object , string $data [, int $len ] )

pg_lo_write() writes data into a large object at the current seek position.

To use the large object interface, it is necessary to enclose it within a transaction block.

Bilginize:

This function used to be called pg_lowrite().

Değiştirgeler

large_object

PostgreSQL large object (LOB) resource, returned by pg_lo_open().

data

The data to be written to the large object. If len is specified and is less than the length of data, only len bytes will be written.

len

An optional maximum number of bytes to write. Must be greater than zero and no greater than the length of data. Defaults to the length of data.

Dönen Değerler

The number of bytes written to the large object, or FALSE on error.

Örnekler

Örnek 1 pg_lo_write() example

<?php
   $doc_oid = 189762345;
   $data = "This will overwrite the start of the large object.";
   $database = pg_connect("dbname=jacarta");
   pg_query($database, "begin");
   $handle = pg_lo_open($database, $doc_oid, "w");
   $data = pg_lo_write($handle, $data);
   pg_query($database, "commit");
?>

Ayrıca Bakınız

  • pg_lo_create() - Create a large object
  • pg_lo_open() - Open a large object

pg_lo_unlink
pg_meta_data
PostgreSQL İşlevleri


Get meta data for table

pg_lo_write
pg_num_fields
PostgreSQL İşlevleri
PHP Manual

pg_meta_data

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

pg_meta_data — Get meta data for table

Açıklama

array pg_meta_data ( resource $connection , string $table_name [, bool $extended ] )

pg_meta_data() returns table definition for table_name as an array.

Değiştirgeler

connection

PostgreSQL database connection resource.

table_name

The name of the table.

extended

Flag for returning extended meta data. Default to FALSE.

Dönen Değerler

An array of the table definition, or FALSE on error.

Örnekler

Örnek 1 Getting table metadata

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  $meta = pg_meta_data($dbconn, 'authors');
  if (is_array($meta)) {
      echo '<pre>';
      var_dump($meta);
      echo '</pre>';
  }
?>

Yukarıdaki örneğin çıktısı:

array(3) {
["author"]=>
array(5) {
  ["num"]=>
  int(1)
  ["type"]=>
  string(7) "varchar"
  ["len"]=>
  int(-1)
  ["not null"]=>
  bool(false)
  ["has default"]=>
  bool(false)
}
["year"]=>
array(5) {
  ["num"]=>
  int(2)
  ["type"]=>
  string(4) "int2"
  ["len"]=>
  int(2)
  ["not null"]=>
  bool(false)
  ["has default"]=>
  bool(false)
}
["title"]=>
array(5) {
  ["num"]=>
  int(3)
  ["type"]=>
  string(7) "varchar"
  ["len"]=>
  int(-1)
  ["not null"]=>
  bool(false)
  ["has default"]=>
  bool(false)
}
}

Sürüm Bilgisi

Sürüm: | Açıklama
5.6.0 | No longer experimental. Added "is enum" as default attribute. extended flag is added.

Ayrıca Bakınız

  • pg_convert() - Convert associative array values into suitable for SQL statement

pg_lo_write
pg_num_fields
PostgreSQL İşlevleri


Returns the number of fields in a result

pg_meta_data
pg_num_rows
PostgreSQL İşlevleri
PHP Manual

pg_num_fields

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

pg_num_fields — Returns the number of fields in a result

Açıklama

int pg_num_fields ( resource $result )

pg_num_fields() returns the number of fields (columns) in a PostgreSQL result resource.

Bilginize:

This function used to be called pg_numfields().

Değiştirgeler

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

Dönen Değerler

The number of fields (columns) in the result. On error, -1 is returned.

Örnekler

Örnek 1 pg_num_fields() example

<?php
$result = pg_query($conn, "SELECT 1, 2");

$num = pg_num_fields($result);

echo $num . " field(s) returned.\n";
?>

Yukarıdaki örneğin çıktısı:

2 field(s) returned.

Ayrıca Bakınız

  • pg_num_rows() - Returns the number of rows in a result
  • pg_affected_rows() - Returns number of affected records (tuples)

pg_meta_data
pg_num_rows
PostgreSQL İşlevleri


Returns the number of rows in a result

pg_num_fields
pg_options
PostgreSQL İşlevleri
PHP Manual

pg_num_rows

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

pg_num_rows — Returns the number of rows in a result

Açıklama

int pg_num_rows ( resource $result )

pg_num_rows() will return the number of rows in a PostgreSQL result resource.

Bilginize:

This function used to be called pg_numrows().

Değiştirgeler

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

Dönen Değerler

The number of rows in the result. On error, -1 is returned.

Örnekler

Örnek 1 pg_num_rows() example

<?php
$result = pg_query($conn, "SELECT 1");

$rows = pg_num_rows($result);

echo $rows . " row(s) returned.\n";
?>

Yukarıdaki örneğin çıktısı:

1 row(s) returned.

Ayrıca Bakınız

  • pg_num_fields() - Returns the number of fields in a result
  • pg_affected_rows() - Returns number of affected records (tuples)

pg_num_fields
pg_options
PostgreSQL İşlevleri


Get the options associated with the connection

pg_num_rows
pg_parameter_status
PostgreSQL İşlevleri
PHP Manual

pg_options

(PHP 4, PHP 5, PHP 7)

pg_options — Get the options associated with the connection

Açıklama

string pg_options ([ resource $connection ] )

pg_options() will return a string containing the options specified on the given PostgreSQL connection resource.

Değiştirgeler

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

Dönen Değerler

A string containing the connection options, or FALSE on error.

Örnekler

Örnek 1 pg_options() example

<?php
   $pgsql_conn = pg_connect("dbname=mark host=localhost");
   echo pg_options($pgsql_conn);
?>

Ayrıca Bakınız

  • pg_connect() - Open a PostgreSQL connection

pg_num_rows
pg_parameter_status
PostgreSQL İşlevleri


Looks up a current parameter setting of the server.

pg_options
pg_pconnect
PostgreSQL İşlevleri
PHP Manual

pg_parameter_status

(PHP 5, PHP 7)

pg_parameter_status — Looks up a current parameter setting of the server.

Açıklama

string pg_parameter_status ([ resource $connection ], string $param_name )

Looks up a current parameter setting of the server.

Certain parameter values are reported by the server automatically at connection startup or whenever their values change. pg_parameter_status() can be used to interrogate these settings. It returns the current value of a parameter if known, or FALSE if the parameter is not known.

Parameters reported as of PostgreSQL 8.0 include server_version, server_encoding, client_encoding, is_superuser, session_authorization, DateStyle, TimeZone, and integer_datetimes. (server_encoding, TimeZone, and integer_datetimes were not reported by releases before 8.0.) Note that server_version, server_encoding and integer_datetimes cannot change after PostgreSQL startup.

PostgreSQL 7.3 or lower servers do not report parameter settings, pg_parameter_status() includes logic to obtain values for server_version and client_encoding anyway. Applications are encouraged to use pg_parameter_status() rather than ad hoc code to determine these values.

Dikkat

On a pre-7.4 PostgreSQL server, changing client_encoding via SET after connection startup will not be reflected by pg_parameter_status().

Değiştirgeler

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

param_name

Possible param_name values include server_version, server_encoding, client_encoding, is_superuser, session_authorization, DateStyle, TimeZone, and integer_datetimes.

Dönen Değerler

A string containing the value of the parameter, FALSE on failure or invalid param_name.

Örnekler

Örnek 1 pg_parameter_status() example

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  echo "Server encoding: ", pg_parameter_status($dbconn, "server_encoding");
?>

Yukarıdaki örneğin çıktısı:

Server encoding: SQL_ASCII

pg_options
pg_pconnect
PostgreSQL İşlevleri


Open a persistent PostgreSQL connection

pg_parameter_status
pg_ping
PostgreSQL İşlevleri
PHP Manual

pg_pconnect

(PHP 4, PHP 5, PHP 7)

pg_pconnect — Open a persistent PostgreSQL connection

Açıklama

resource pg_pconnect ( string $connection_string [, int $connect_type ] )

pg_pconnect() opens a connection to a PostgreSQL database. It returns a connection resource that is needed by other PostgreSQL functions.

If a second call is made to pg_pconnect() with the same connection_string as an existing connection, the existing connection will be returned unless you pass PGSQL_CONNECT_FORCE_NEW as connect_type.

To enable persistent connection, the pgsql.allow_persistent php.ini directive must be set to "On" (which is the default). The maximum number of persistent connection can be defined with the pgsql.max_persistent php.ini directive (defaults to -1 for no limit). The total number of connections can be set with the pgsql.max_links php.ini directive.

pg_close() will not close persistent links generated by pg_pconnect().

Değiştirgeler

connection_string

The connection_string can be empty to use all default parameters, or it can contain one or more parameter settings separated by whitespace. Each parameter setting is in the form keyword = value. Spaces around the equal sign are optional. To write an empty value or a value containing spaces, surround it with single quotes, e.g., keyword = 'a value'. Single quotes and backslashes within the value must be escaped with a backslash, i.e., \' and \\.

The currently recognized parameter keywords are: host, hostaddr, port, dbname, user, password, connect_timeout, options, tty (ignored), sslmode, requiressl (deprecated in favor of sslmode), and service. Which of these arguments exist depends on your PostgreSQL version.

connect_type

If PGSQL_CONNECT_FORCE_NEW is passed, then a new connection is created, even if the connection_string is identical to an existing connection.

Dönen Değerler

PostgreSQL connection resource on success, FALSE on failure.

Örnekler

Örnek 1 Using pg_pconnect()

<?php
$dbconn = pg_pconnect("dbname=mary");
//connect to a database named "mary"

$dbconn2 = pg_pconnect("host=localhost port=5432 dbname=mary");
// connect to a database named "mary" on "localhost" at port "5432"

$dbconn3 = pg_pconnect("host=sheep port=5432 dbname=mary user=lamb password=foo");
//connect to a database named "mary" on the host "sheep" with a username and password

$conn_string = "host=sheep port=5432 dbname=test user=lamb password=bar";
$dbconn4 = pg_pconnect($conn_string);
//connect to a database named "test" on the host "sheep" with a username and password
?>

Ayrıca Bakınız

  • pg_connect() - Open a PostgreSQL connection
  • Persistent Database Connections

pg_parameter_status
pg_ping
PostgreSQL İşlevleri


Ping database connection

pg_pconnect
pg_port
PostgreSQL İşlevleri
PHP Manual

pg_ping

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

pg_ping — Ping database connection

Açıklama

bool pg_ping ([ resource $connection ] )

pg_ping() pings a database connection and tries to reconnect it if it is broken.

Değiştirgeler

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 pg_ping() example

<?php
$conn = pg_pconnect("dbname=publisher");
if (!$conn) {
  echo "An error occurred.\n";
  exit;
}

if (!pg_ping($conn))
  die("Connection is broken\n");
?>

Ayrıca Bakınız

  • pg_connection_status() - Get connection status
  • pg_connection_reset() - Reset connection (reconnect)

pg_pconnect
pg_port
PostgreSQL İşlevleri


Return the port number associated with the connection

pg_ping
pg_prepare
PostgreSQL İşlevleri
PHP Manual

pg_port

(PHP 4, PHP 5, PHP 7)

pg_port — Return the port number associated with the connection

Açıklama

int pg_port ([ resource $connection ] )

pg_port() returns the port number that the given PostgreSQL connection resource is connected to.

Değiştirgeler

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

Dönen Değerler

An int containing the port number of the database server the connection is to, or FALSE on error.

Örnekler

Örnek 1 pg_port() example

<?php
$pgsql_conn = pg_connect("dbname=mark host=localhost");

if ($pgsql_conn) {
   print "Successfully connected to port: " . pg_port($pgsql_conn) . "<br/>\n";
} else {
   print pg_last_error($pgsql_conn);
   exit;
}
?>

pg_ping
pg_prepare
PostgreSQL İşlevleri


Submits a request to create a prepared statement with the given parameters, and waits for completion.

pg_port
pg_put_line
PostgreSQL İşlevleri
PHP Manual

pg_prepare

(PHP 5 >= 5.1.0, PHP 7)

pg_prepare — Submits a request to create a prepared statement with the given parameters, and waits for completion.

Açıklama

resource pg_prepare ([ resource $connection ], string $stmtname , string $query )

pg_prepare() creates a prepared statement for later execution with pg_execute() or pg_send_execute(). This feature allows commands that will be used repeatedly to be parsed and planned just once, rather than each time they are executed. pg_prepare() is supported only against PostgreSQL 7.4 or higher connections; it will fail when using earlier versions.

The function creates a prepared statement named stmtname from the query string, which must contain a single SQL command. stmtname may be "" to create an unnamed statement, in which case any pre-existing unnamed statement is automatically replaced; otherwise it is an error if the statement name is already defined in the current session. If any parameters are used, they are referred to in the query as $1, $2, etc.

Prepared statements for use with pg_prepare() can also be created by executing SQL PREPARE statements. (But pg_prepare() is more flexible since it does not require parameter types to be pre-specified.) Also, although there is no PHP function for deleting a prepared statement, the SQL DEALLOCATE statement can be used for that purpose.

Değiştirgeler

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

stmtname

The name to give the prepared statement. Must be unique per-connection. If "" is specified, then an unnamed statement is created, overwriting any previously defined unnamed statement.

query

The parameterized SQL statement. Must contain only a single statement. (multiple statements separated by semi-colons are not allowed.) If any parameters are used, they are referred to as $1, $2, etc.

Dönen Değerler

A query result resource on success başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Using pg_prepare()

<?php
// Connect to a database named "mary"
$dbconn = pg_connect("dbname=mary");

// Prepare a query for execution
$result = pg_prepare($dbconn, "my_query", 'SELECT * FROM shops WHERE name = $1');

// Execute the prepared query.  Note that it is not necessary to escape
// the string "Joe's Widgets" in any way
$result = pg_execute($dbconn, "my_query", array("Joe's Widgets"));

// Execute the same prepared query, this time with a different parameter
$result = pg_execute($dbconn, "my_query", array("Clothes Clothes Clothes"));

?>

Ayrıca Bakınız

  • pg_execute() - Sends a request to execute a prepared statement with given parameters, and waits for the result.
  • pg_send_execute() - Sends a request to execute a prepared statement with given parameters, without waiting for the result(s).

pg_port
pg_put_line
PostgreSQL İşlevleri


Send a NULL-terminated string to PostgreSQL backend

pg_prepare
pg_query_params
PostgreSQL İşlevleri
PHP Manual

pg_put_line

(PHP 4 >= 4.0.3, PHP 5, PHP 7)

pg_put_line — Send a NULL-terminated string to PostgreSQL backend

Açıklama

bool pg_put_line ([ resource $connection ], string $data )

pg_put_line() sends a NULL-terminated string to the PostgreSQL backend server. This is needed in conjunction with PostgreSQL's COPY FROM command.

COPY is a high-speed data loading interface supported by PostgreSQL. Data is passed in without being parsed, and in a single transaction.

An alternative to using raw pg_put_line() commands is to use pg_copy_from(). This is a far simpler interface.

Bilginize:

The application must explicitly send the two characters "\." on the last line to indicate to the backend that it has finished sending its data, before issuing pg_end_copy().

Uyarı

Use of the pg_put_line() causes most large object operations, including pg_lo_read() and pg_lo_tell(), to subsequently fail. You can use pg_copy_from() and pg_copy_to() instead.

Değiştirgeler

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

data

A line of text to be sent directly to the PostgreSQL backend. A NULL terminator is added automatically.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 pg_put_line() example

<?php
  $conn = pg_pconnect("dbname=foo");
  pg_query($conn, "create table bar (a int4, b char(16), d float8)");
  pg_query($conn, "copy bar from stdin");
  pg_put_line($conn, "3\thello world\t4.5\n");
  pg_put_line($conn, "4\tgoodbye world\t7.11\n");
  pg_put_line($conn, "\\.\n");
  pg_end_copy($conn);
?>

Ayrıca Bakınız

  • pg_end_copy() - Sync with PostgreSQL backend

pg_prepare
pg_query_params
PostgreSQL İşlevleri


Submits a command to the server and waits for the result, with the ability to pass parameters separately from the SQL command text.

pg_put_line
pg_query
PostgreSQL İşlevleri
PHP Manual

pg_query_params

(PHP 5 >= 5.1.0, PHP 7)

pg_query_params — Submits a command to the server and waits for the result, with the ability to pass parameters separately from the SQL command text.

Açıklama

resource pg_query_params ([ resource $connection ], string $query , array $params )

Submits a command to the server and waits for the result, with the ability to pass parameters separately from the SQL command text.

pg_query_params() is like pg_query(), but offers additional functionality: parameter values can be specified separately from the command string proper. pg_query_params() is supported only against PostgreSQL 7.4 or higher connections; it will fail when using earlier versions.

If parameters are used, they are referred to in the query string as $1, $2, etc. The same parameter may appear more than once in the query; the same value will be used in that case. params specifies the actual values of the parameters. A NULL value in this array means the corresponding parameter is SQL NULL.

The primary advantage of pg_query_params() over pg_query() is that parameter values may be separated from the query string, thus avoiding the need for tedious and error-prone quoting and escaping. Unlike pg_query(), pg_query_params() allows at most one SQL command in the given string. (There can be semicolons in it, but not more than one nonempty command.)

Değiştirgeler

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

query

The parameterized SQL statement. Must contain only a single statement. (multiple statements separated by semi-colons are not allowed.) If any parameters are used, they are referred to as $1, $2, etc.

User-supplied values should always be passed as parameters, not interpolated into the query string, where they form possible SQL injection attack vectors and introduce bugs when handling data containing quotes. If for some reason you cannot use a parameter, ensure that interpolated values are properly escaped.

params

An array of parameter values to substitute for the $1, $2, etc. placeholders in the original prepared query string. The number of elements in the array must match the number of placeholders.

Values intended for bytea fields are not supported as parameters. Use pg_escape_bytea() instead, or use the large object functions.

Dönen Değerler

A query result resource on success başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Using pg_query_params()

<?php
// Connect to a database named "mary"
$dbconn = pg_connect("dbname=mary");

// Find all shops named Joe's Widgets.  Note that it is not necessary to
// escape "Joe's Widgets"
$result = pg_query_params($dbconn, 'SELECT * FROM shops WHERE name = $1', array("Joe's Widgets"));

// Compare against just using pg_query
$str = pg_escape_string("Joe's Widgets");
$result = pg_query($dbconn, "SELECT * FROM shops WHERE name = '{$str}'");

?>

Ayrıca Bakınız

  • pg_query() - Execute a query

pg_put_line
pg_query
PostgreSQL İşlevleri


Execute a query

pg_query_params
pg_result_error_field
PostgreSQL İşlevleri
PHP Manual

pg_query

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

pg_query — Execute a query

Açıklama

resource pg_query ([ resource $connection ], string $query )

pg_query() executes the query on the specified database connection. pg_query_params() should be preferred in most cases.

If an error occurs, and FALSE is returned, details of the error can be retrieved using the pg_last_error() function if the connection is valid.

Bilginize: Although connection can be omitted, it is not recommended, since it can be the cause of hard to find bugs in scripts.

Bilginize:

This function used to be called pg_exec(). pg_exec() is still available for compatibility reasons, but users are encouraged to use the newer name.

Değiştirgeler

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

query

The SQL statement or statements to be executed. When multiple statements are passed to the function, they are automatically executed as one transaction, unless there are explicit BEGIN/COMMIT commands included in the query string. However, using multiple transactions in one function call is not recommended.

Uyarı

String interpolation of user-supplied data is extremely dangerous and is likely to lead to SQL injection vulnerabilities. In most cases pg_query_params() should be preferred, passing user-supplied values as parameters rather than substituting them into the query string.

Any user-supplied data substituted directly into a query string should be properly escaped.

Dönen Değerler

A query result resource on success başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 pg_query() example

<?php

$conn = pg_pconnect("dbname=publisher");
if (!$conn) {
  echo "An error occurred.\n";
  exit;
}

$result = pg_query($conn, "SELECT author, email FROM authors");
if (!$result) {
  echo "An error occurred.\n";
  exit;
}

while ($row = pg_fetch_row($result)) {
  echo "Author: $row[0]  E-mail: $row[1]";
  echo "<br />\n";
}

?>

Örnek 2 Using pg_query() with multiple statements

<?php

$conn = pg_pconnect("dbname=publisher");

// these statements will be executed as one transaction

$query = "UPDATE authors SET author=UPPER(author) WHERE id=1;";
$query .= "UPDATE authors SET author=LOWER(author) WHERE id=2;";
$query .= "UPDATE authors SET author=NULL WHERE id=3;";

pg_query($conn, $query);

?>

Ayrıca Bakınız

  • pg_connect() - Open a PostgreSQL connection
  • pg_pconnect() - Open a persistent PostgreSQL connection
  • pg_fetch_array() - Fetch a row as an array
  • pg_fetch_object() - Fetch a row as an object
  • pg_num_rows() - Returns the number of rows in a result
  • pg_affected_rows() - Returns number of affected records (tuples)

pg_query_params
pg_result_error_field
PostgreSQL İşlevleri


Returns an individual field of an error report.

pg_query
pg_result_error
PostgreSQL İşlevleri
PHP Manual

pg_result_error_field

(PHP 5 >= 5.1.0, PHP 7)

pg_result_error_field — Returns an individual field of an error report.

Açıklama

string pg_result_error_field ( resource $result , int $fieldcode )

pg_result_error_field() returns one of the detailed error message fields associated with result resource. It is only available against a PostgreSQL 7.4 or above server. The error field is specified by the fieldcode.

Because pg_query() and pg_query_params() return FALSE if the query fails, you must use pg_send_query() and pg_get_result() to get the result handle.

If you need to get additional error information from failed pg_query() queries, use pg_set_error_verbosity() and pg_last_error() and then parse the result.

Değiştirgeler

result

A PostgreSQL query result resource from a previously executed statement.

fieldcode

Possible fieldcode values are: PGSQL_DIAG_SEVERITY, PGSQL_DIAG_SQLSTATE, PGSQL_DIAG_MESSAGE_PRIMARY, PGSQL_DIAG_MESSAGE_DETAIL, PGSQL_DIAG_MESSAGE_HINT, PGSQL_DIAG_STATEMENT_POSITION, PGSQL_DIAG_INTERNAL_POSITION (PostgreSQL 8.0+ only), PGSQL_DIAG_INTERNAL_QUERY (PostgreSQL 8.0+ only), PGSQL_DIAG_CONTEXT, PGSQL_DIAG_SOURCE_FILE, PGSQL_DIAG_SOURCE_LINE or PGSQL_DIAG_SOURCE_FUNCTION.

Dönen Değerler

A string containing the contents of the error field, NULL if the field does not exist or FALSE on failure.

Örnekler

Örnek 1 pg_result_error_field() example

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  if (!pg_connection_busy($dbconn)) {
      pg_send_query($dbconn, "select * from doesnotexist;");
  }

  $res1 = pg_get_result($dbconn);
  echo pg_result_error_field($res1, PGSQL_DIAG_SQLSTATE);
?>

Ayrıca Bakınız

  • pg_result_error() - Get error message associated with result

pg_query
pg_result_error
PostgreSQL İşlevleri


Get error message associated with result

pg_result_error_field
pg_result_seek
PostgreSQL İşlevleri
PHP Manual

pg_result_error

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

pg_result_error — Get error message associated with result

Açıklama

string pg_result_error ( resource $result )

pg_result_error() returns any error message associated with the result resource. Therefore, the user has a better chance of getting the correct error message than with pg_last_error().

The function pg_result_error_field() can give much greater detail on result errors than pg_result_error().

Because pg_query() returns FALSE if the query fails, you must use pg_send_query() and pg_get_result() to get the result handle.

Değiştirgeler

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

Dönen Değerler

Returns a string. Returns empty string if there is no error. If there is an error associated with the result parameter, returns FALSE.

Örnekler

Örnek 1 pg_result_error() example

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  if (!pg_connection_busy($dbconn)) {
      pg_send_query($dbconn, "select * from doesnotexist;");
  }

  $res1 = pg_get_result($dbconn);
  echo pg_result_error($res1);
?>

Ayrıca Bakınız

  • pg_result_error_field() - Returns an individual field of an error report.
  • pg_query() - Execute a query
  • pg_send_query() - Sends asynchronous query
  • pg_get_result() - Get asynchronous query result
  • pg_last_error() - Get the last error message string of a connection
  • pg_last_notice() - Returns the last notice message from PostgreSQL server

pg_result_error_field
pg_result_seek
PostgreSQL İşlevleri


Set internal row offset in result resource

pg_result_error
pg_result_status
PostgreSQL İşlevleri
PHP Manual

pg_result_seek

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

pg_result_seek — Set internal row offset in result resource

Açıklama

bool pg_result_seek ( resource $result , int $offset )

pg_result_seek() sets the internal row offset in a result resource.

Değiştirgeler

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

offset

Row to move the internal offset to in the result resource. Rows are numbered starting from zero.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 pg_result_seek() example

<?php

// Connect to the database
$conn = pg_pconnect("dbname=publisher");

// Execute a query
$result = pg_query($conn, "SELECT author, email FROM authors");

// Seek to the 3rd row (assuming there are 3 rows)
pg_result_seek($result, 2);

// Fetch the 3rd row
$row = pg_fetch_row($result);

?>

Ayrıca Bakınız

  • pg_fetch_row() - Get a row as an enumerated array
  • pg_fetch_assoc() - Fetch a row as an associative array
  • pg_fetch_array() - Fetch a row as an array
  • pg_fetch_object() - Fetch a row as an object
  • pg_fetch_result() - Returns values from a result resource

pg_result_error
pg_result_status
PostgreSQL İşlevleri


Get status of query result

pg_result_seek
pg_select
PostgreSQL İşlevleri
PHP Manual

pg_result_status

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

pg_result_status — Get status of query result

Açıklama

mixed pg_result_status ( resource $result [, int $type = PGSQL_STATUS_LONG ] )

pg_result_status() returns the status of a result resource, or the PostgreSQL command completion tag associated with the result

Değiştirgeler

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

type

Either PGSQL_STATUS_LONG to return the numeric status of the result, or PGSQL_STATUS_STRING to return the command tag of the result. If not specified, PGSQL_STATUS_LONG is the default.

Dönen Değerler

Possible return values are PGSQL_EMPTY_QUERY, PGSQL_COMMAND_OK, PGSQL_TUPLES_OK, PGSQL_COPY_OUT, PGSQL_COPY_IN, PGSQL_BAD_RESPONSE, PGSQL_NONFATAL_ERROR and PGSQL_FATAL_ERROR if PGSQL_STATUS_LONG is specified. Otherwise, a string containing the PostgreSQL command tag is returned.

Örnekler

Örnek 1 pg_result_status() example

<?php

// Connect to the database
$conn = pg_pconnect("dbname=publisher");

// Execute a COPY
$result = pg_query($conn, "COPY authors FROM STDIN;");

// Get the result status
$status = pg_result_status($result);

// Determine status
if ($status == PGSQL_COPY_IN)
   echo "Copy began.";
else
   echo "Copy failed.";

?>

Yukarıdaki örneğin çıktısı:

Copy began.

Ayrıca Bakınız

  • pg_connection_status() - Get connection status

pg_result_seek
pg_select
PostgreSQL İşlevleri


Select records

pg_result_status
pg_send_execute
PostgreSQL İşlevleri
PHP Manual

pg_select

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

pg_select — Select records

Açıklama

mixed pg_select ( resource $connection , string $table_name , array $assoc_array [, int $options = PGSQL_DML_EXEC ] )

pg_select() selects records specified by assoc_array which has field=>value. For a successful query, it returns an array containing all records and fields that match the condition specified by assoc_array.

If options is specified, pg_convert() is applied to assoc_array with the specified flags.

Değiştirgeler

connection

PostgreSQL database connection resource.

table_name

Name of the table from which to select rows.

assoc_array

An array whose keys are field names in the table table_name, and whose values are the conditions that a row must meet to be retrieved.

options

Any number of PGSQL_CONV_FORCE_NULL, PGSQL_DML_NO_CONV, PGSQL_DML_ESCAPE, PGSQL_DML_EXEC, PGSQL_DML_ASYNC or PGSQL_DML_STRING combined. If PGSQL_DML_STRING is part of the options then query string is returned. When PGSQL_DML_NO_CONV or PGSQL_DML_ESCAPE is set, it does not call pg_convert() internally.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. Returns string if PGSQL_DML_STRING is passed via options.

Örnekler

Örnek 1 pg_select() example

<?php
  $db = pg_connect('dbname=foo');
  // This is safe, since $_POST is converted automatically
  $rec = pg_select($db, 'post_log', $_POST);
  if ($rec) {
      echo "Records selected\n";
      var_dump($rec);
  } else {
      echo "User must have sent wrong inputs\n";
  }
?>

Sürüm Bilgisi

Sürüm: | Açıklama
5.6.0 | No longer experimental. Added PGSQL_DML_ESCAPE constant, TRUE/FALSE and NULL data type support.
5.5.3/5.4.19 | Direct SQL injection to table_name and Indirect SQL injection to identifiers are fixed.

Ayrıca Bakınız

  • pg_convert() - Convert associative array values into suitable for SQL statement

pg_result_status
pg_send_execute
PostgreSQL İşlevleri


Sends a request to execute a prepared statement with given parameters, without waiting for the result(s).

pg_select
pg_send_prepare
PostgreSQL İşlevleri
PHP Manual

pg_send_execute

(PHP 5 >= 5.1.0, PHP 7)

pg_send_execute — Sends a request to execute a prepared statement with given parameters, without waiting for the result(s).

Açıklama

bool pg_send_execute ( resource $connection , string $stmtname , array $params )

Sends a request to execute a prepared statement with given parameters, without waiting for the result(s).

This is similar to pg_send_query_params(), but the command to be executed is specified by naming a previously-prepared statement, instead of giving a query string. The function's parameters are handled identically to pg_execute(). Like pg_execute(), it will not work on pre-7.4 versions of PostgreSQL.

Değiştirgeler

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

stmtname

The name of the prepared statement to execute. if "" is specified, then the unnamed statement is executed. The name must have been previously prepared using pg_prepare(), pg_send_prepare() or a PREPARE SQL command.

params

An array of parameter values to substitute for the $1, $2, etc. placeholders in the original prepared query string. The number of elements in the array must match the number of placeholders.

Dönen Değerler

Returns TRUE on success, FALSE on failure. Use pg_get_result() to determine the query result.

Örnekler

Örnek 1 Using pg_send_execute()

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  // Prepare a query for execution
  if (!pg_connection_busy($dbconn)) {
    pg_send_prepare($dbconn, "my_query", 'SELECT * FROM shops WHERE name = $1');
    $res1 = pg_get_result($dbconn);
  }

  // Execute the prepared query.  Note that it is not necessary to escape
  // the string "Joe's Widgets" in any way
  if (!pg_connection_busy($dbconn)) {
    pg_send_execute($dbconn, "my_query", array("Joe's Widgets"));
    $res2 = pg_get_result($dbconn);
  }

  // Execute the same prepared query, this time with a different parameter
  if (!pg_connection_busy($dbconn)) {
    pg_send_execute($dbconn, "my_query", array("Clothes Clothes Clothes"));
    $res3 = pg_get_result($dbconn);
  }

?>

Ayrıca Bakınız

  • pg_prepare() - Submits a request to create a prepared statement with the given parameters, and waits for completion.
  • pg_send_prepare() - Sends a request to create a prepared statement with the given parameters, without waiting for completion.
  • pg_execute() - Sends a request to execute a prepared statement with given parameters, and waits for the result.

pg_select
pg_send_prepare
PostgreSQL İşlevleri


Sends a request to create a prepared statement with the given parameters, without waiting for completion.

pg_send_execute
pg_send_query_params
PostgreSQL İşlevleri
PHP Manual

pg_send_prepare

(PHP 5 >= 5.1.0, PHP 7)

pg_send_prepare — Sends a request to create a prepared statement with the given parameters, without waiting for completion.

Açıklama

bool pg_send_prepare ( resource $connection , string $stmtname , string $query )

Sends a request to create a prepared statement with the given parameters, without waiting for completion.

This is an asynchronous version of pg_prepare(): it returns TRUE if it was able to dispatch the request, and FALSE if not. After a successful call, call pg_get_result() to determine whether the server successfully created the prepared statement. The function's parameters are handled identically to pg_prepare(). Like pg_prepare(), it will not work on pre-7.4 versions of PostgreSQL.

Değiştirgeler

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

stmtname

The name to give the prepared statement. Must be unique per-connection. If "" is specified, then an unnamed statement is created, overwriting any previously defined unnamed statement.

query

The parameterized SQL statement. Must contain only a single statement. (multiple statements separated by semi-colons are not allowed.) If any parameters are used, they are referred to as $1, $2, etc.

Dönen Değerler

Returns TRUE on success, FALSE on failure. Use pg_get_result() to determine the query result.

Örnekler

Örnek 1 Using pg_send_prepare()

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  // Prepare a query for execution
  if (!pg_connection_busy($dbconn)) {
    pg_send_prepare($dbconn, "my_query", 'SELECT * FROM shops WHERE name = $1');
    $res1 = pg_get_result($dbconn);
  }

  // Execute the prepared query.  Note that it is not necessary to escape
  // the string "Joe's Widgets" in any way
  if (!pg_connection_busy($dbconn)) {
    pg_send_execute($dbconn, "my_query", array("Joe's Widgets"));
    $res2 = pg_get_result($dbconn);
  }

  // Execute the same prepared query, this time with a different parameter
  if (!pg_connection_busy($dbconn)) {
    pg_send_execute($dbconn, "my_query", array("Clothes Clothes Clothes"));
    $res3 = pg_get_result($dbconn);
  }

?>

Ayrıca Bakınız

  • pg_connect() - Open a PostgreSQL connection
  • pg_pconnect() - Open a persistent PostgreSQL connection
  • pg_execute() - Sends a request to execute a prepared statement with given parameters, and waits for the result.
  • pg_send_execute() - Sends a request to execute a prepared statement with given parameters, without waiting for the result(s).
  • pg_send_query_params() - Submits a command and separate parameters to the server without waiting for the result(s).

pg_send_execute
pg_send_query_params
PostgreSQL İşlevleri


Submits a command and separate parameters to the server without waiting for the result(s).

pg_send_prepare
pg_send_query
PostgreSQL İşlevleri
PHP Manual

pg_send_query_params

(PHP 5 >= 5.1.0, PHP 7)

pg_send_query_params — Submits a command and separate parameters to the server without waiting for the result(s).

Açıklama

bool pg_send_query_params ( resource $connection , string $query , array $params )

Submits a command and separate parameters to the server without waiting for the result(s).

This is equivalent to pg_send_query() except that query parameters can be specified separately from the query string. The function's parameters are handled identically to pg_query_params(). Like pg_query_params(), it will not work on pre-7.4 PostgreSQL connections, and it allows only one command in the query string.

Değiştirgeler

connection

PostgreSQL database connection resource.

query

The parameterized SQL statement. Must contain only a single statement. (multiple statements separated by semi-colons are not allowed.) If any parameters are used, they are referred to as $1, $2, etc.

params

An array of parameter values to substitute for the $1, $2, etc. placeholders in the original prepared query string. The number of elements in the array must match the number of placeholders.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Use pg_get_result() to determine the query result.

Örnekler

Örnek 1 Using pg_send_query_params()

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  // Using parameters.  Note that it is not necessary to quote or escape
  // the parameter.
  pg_send_query_params($dbconn, 'select count(*) from authors where city = $1', array('Perth'));

  // Compare against basic pg_send_query usage
  $str = pg_escape_string('Perth');
  pg_send_query($dbconn, "select count(*) from authors where city = '${str}'");
?>

Ayrıca Bakınız

  • pg_send_query() - Sends asynchronous query

pg_send_prepare
pg_send_query
PostgreSQL İşlevleri


Sends asynchronous query

pg_send_query_params
pg_set_client_encoding
PostgreSQL İşlevleri
PHP Manual

pg_send_query

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

pg_send_query — Sends asynchronous query

Açıklama

bool pg_send_query ( resource $connection , string $query )

pg_send_query() sends a query or queries asynchronously to the connection. Unlike pg_query(), it can send multiple queries at once to PostgreSQL and get the results one by one using pg_get_result().

Script execution is not blocked while the queries are executing. Use pg_connection_busy() to check if the connection is busy (i.e. the query is executing). Queries may be cancelled using pg_cancel_query().

Although the user can send multiple queries at once, multiple queries cannot be sent over a busy connection. If a query is sent while the connection is busy, it waits until the last query is finished and discards all its results.

Değiştirgeler

connection

PostgreSQL database connection resource.

query

The SQL statement or statements to be executed.

Data inside the query should be properly escaped.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Use pg_get_result() to determine the query result.

Örnekler

Örnek 1 pg_send_query() example

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  if (!pg_connection_busy($dbconn)) {
      pg_send_query($dbconn, "select * from authors; select count(*) from authors;");
  }

  $res1 = pg_get_result($dbconn);
  echo "First call to pg_get_result(): $res1\n";
  $rows1 = pg_num_rows($res1);
  echo "$res1 has $rows1 records\n\n";

  $res2 = pg_get_result($dbconn);
  echo "Second call to pg_get_result(): $res2\n";
  $rows2 = pg_num_rows($res2);
  echo "$res2 has $rows2 records\n";
?>

Yukarıdaki örneğin çıktısı:

First call to pg_get_result(): Resource id #3
Resource id #3 has 3 records

Second call to pg_get_result(): Resource id #4
Resource id #4 has 1 records

Ayrıca Bakınız

  • pg_query() - Execute a query
  • pg_cancel_query() - Cancel an asynchronous query
  • pg_get_result() - Get asynchronous query result
  • pg_connection_busy() - Get connection is busy or not

pg_send_query_params
pg_set_client_encoding
PostgreSQL İşlevleri


Set the client encoding

pg_send_query
pg_set_error_verbosity
PostgreSQL İşlevleri
PHP Manual

pg_set_client_encoding

(PHP 4 >= 4.0.3, PHP 5, PHP 7)

pg_set_client_encoding — Set the client encoding

Açıklama

int pg_set_client_encoding ([ resource $connection ], string $encoding )

pg_set_client_encoding() sets the client encoding and returns 0 if success or -1 if error.

PostgreSQL will automatically convert data in the backend database encoding into the frontend encoding.

Bilginize:

The function used to be called pg_setclientencoding().

Değiştirgeler

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

encoding

The required client encoding. One of SQL_ASCII, EUC_JP, EUC_CN, EUC_KR, EUC_TW, UNICODE, MULE_INTERNAL, LATINX (X=1...9), KOI8, WIN, ALT, SJIS, BIG5 or WIN1250.

The exact list of available encodings depends on your PostgreSQL version, so check your PostgreSQL manual for a more specific list.

Dönen Değerler

Returns 0 on success or -1 on error.

Örnekler

Örnek 1 pg_set_client_encoding() example

<?php

$conn = pg_pconnect("dbname=publisher");
if (!$conn) {
  echo "An error occurred.\n";
  exit;
}

// Set the client encoding to UNICODE.  Data will be automatically
// converted from the backend encoding to the frontend.
pg_set_client_encoding($conn, "UNICODE");

$result = pg_query($conn, "SELECT author, email FROM authors");
if (!$result) {
  echo "An error occurred.\n";
  exit;
}

// Write out UTF-8 data
while ($row = pg_fetch_row($result)) {
  echo "Author: $row[0]  E-mail: $row[1]";
  echo "<br />\n";
}

?>

Ayrıca Bakınız

  • pg_client_encoding() - Gets the client encoding

pg_send_query
pg_set_error_verbosity
PostgreSQL İşlevleri


Determines the verbosity of messages returned by pg_last_error and pg_result_error.

pg_set_client_encoding
pg_socket
PostgreSQL İşlevleri
PHP Manual

pg_set_error_verbosity

(PHP 5 >= 5.1.0, PHP 7)

pg_set_error_verbosity — Determines the verbosity of messages returned by pg_last_error() and pg_result_error().

Açıklama

int pg_set_error_verbosity ([ resource $connection ], int $verbosity )

Determines the verbosity of messages returned by pg_last_error() and pg_result_error().

pg_set_error_verbosity() sets the verbosity mode, returning the connection's previous setting. In PGSQL_ERRORS_TERSE mode, returned messages include severity, primary text, and position only; this will normally fit on a single line. The default mode (PGSQL_ERRORS_DEFAULT) produces messages that include the above plus any detail, hint, or context fields (these may span multiple lines). The PGSQL_ERRORS_VERBOSE mode includes all available fields. Changing the verbosity does not affect the messages available from already-existing result objects, only subsequently-created ones.

Değiştirgeler

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

verbosity

The required verbosity: PGSQL_ERRORS_TERSE, PGSQL_ERRORS_DEFAULT or PGSQL_ERRORS_VERBOSE.

Dönen Değerler

The previous verbosity level: PGSQL_ERRORS_TERSE, PGSQL_ERRORS_DEFAULT or PGSQL_ERRORS_VERBOSE.

Örnekler

Örnek 1 pg_set_error_verbosity() example

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  if (!pg_connection_busy($dbconn)) {
      pg_send_query($dbconn, "select * from doesnotexist;");
  }

  pg_set_error_verbosity($dbconn, PGSQL_ERRORS_VERBOSE);
  $res1 = pg_get_result($dbconn);
  echo pg_result_error($res1);
?>

Ayrıca Bakınız

  • pg_last_error() - Get the last error message string of a connection
  • pg_result_error() - Get error message associated with result

pg_set_client_encoding
pg_socket
PostgreSQL İşlevleri


Get a read only handle to the socket underlying a PostgreSQL connection

pg_set_error_verbosity
pg_trace
PostgreSQL İşlevleri
PHP Manual

pg_socket

(PHP 5 >= 5.6.0, PHP 7)

pg_socket — Get a read only handle to the socket underlying a PostgreSQL connection

Açıklama

resource pg_socket ( resource $connection )

pg_socket() returns a read only resource corresponding to the socket underlying the given PostgreSQL connection.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

connection

PostgreSQL database connection resource.

Dönen Değerler

A socket resource on success başarısızlık durumunda FALSE döner.

pg_set_error_verbosity
pg_trace
PostgreSQL İşlevleri


Enable tracing a PostgreSQL connection

pg_socket
pg_transaction_status
PostgreSQL İşlevleri
PHP Manual

pg_trace

(PHP 4 >= 4.0.1, PHP 5, PHP 7)

pg_trace — Enable tracing a PostgreSQL connection

Açıklama

bool pg_trace ( string $pathname [, string $mode = "w" [, resource $connection ]] )

pg_trace() enables tracing of the PostgreSQL frontend/backend communication to a file. To fully understand the results, one needs to be familiar with the internals of PostgreSQL communication protocol.

For those who are not, it can still be useful for tracing errors in queries sent to the server, you could do for example grep '^To backend' trace.log and see what queries actually were sent to the PostgreSQL server. For more information, refer to the » PostgreSQL Documentation.

Değiştirgeler

pathname

The full path and file name of the file in which to write the trace log. Same as in fopen().

mode

An optional file access mode, same as for fopen().

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 pg_trace() example

<?php
$pgsql_conn = pg_connect("dbname=mark host=localhost");

if ($pgsql_conn) {
   pg_trace('/tmp/trace.log', 'w', $pgsql_conn);
   pg_query("SELECT 1");
   pg_untrace($pgsql_conn);
   // Now /tmp/trace.log will contain backend communication
} else {
   print pg_last_error($pgsql_conn);
   exit;
}
?>

Ayrıca Bakınız

  • fopen() - Bir dosya veya URL'yi açar
  • pg_untrace() - Disable tracing of a PostgreSQL connection

pg_socket
pg_transaction_status
PostgreSQL İşlevleri


Returns the current in-transaction status of the server.

pg_trace
pg_tty
PostgreSQL İşlevleri
PHP Manual

pg_transaction_status

(PHP 5 >= 5.1.0, PHP 7)

pg_transaction_status — Returns the current in-transaction status of the server.

Açıklama

int pg_transaction_status ( resource $connection )

Returns the current in-transaction status of the server.

Dikkat

pg_transaction_status() will give incorrect results when using a PostgreSQL 7.3 server that has the parameter autocommit set to off. The server-side autocommit feature has been deprecated and does not exist in later server versions.

Değiştirgeler

connection

PostgreSQL database connection resource.

Dönen Değerler

The status can be PGSQL_TRANSACTION_IDLE (currently idle), PGSQL_TRANSACTION_ACTIVE (a command is in progress), PGSQL_TRANSACTION_INTRANS (idle, in a valid transaction block), or PGSQL_TRANSACTION_INERROR (idle, in a failed transaction block). PGSQL_TRANSACTION_UNKNOWN is reported if the connection is bad. PGSQL_TRANSACTION_ACTIVE is reported only when a query has been sent to the server and not yet completed.

Örnekler

Örnek 1 pg_transaction_status() example

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");
  $stat = pg_transaction_status($dbconn);
  if ($stat === PGSQL_TRANSACTION_UNKNOWN) {
      echo 'Connection is bad';
  } else if ($stat === PGSQL_TRANSACTION_IDLE) {
      echo 'Connection is currently idle';
  } else {
      echo 'Connection is in a transaction state';
  }
?>

pg_trace
pg_tty
PostgreSQL İşlevleri


Return the TTY name associated with the connection

pg_transaction_status
pg_unescape_bytea
PostgreSQL İşlevleri
PHP Manual

pg_tty

(PHP 4, PHP 5, PHP 7)

pg_tty — Return the TTY name associated with the connection

Açıklama

string pg_tty ([ resource $connection ] )

pg_tty() returns the TTY name that server side debugging output is sent to on the given PostgreSQL connection resource.

Bilginize:

pg_tty() is obsolete, since the server no longer pays attention to the TTY setting, but the function remains for backwards compatibility.

Değiştirgeler

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

Dönen Değerler

A string containing the debug TTY of the connection, or FALSE on error.

Örnekler

Örnek 1 pg_tty() example

<?php
$pgsql_conn = pg_connect("dbname=mark host=localhost");

if ($pgsql_conn) {
   print "Server debug TTY is: " . pg_tty($pgsql_conn) . "<br/>\n";
} else {
   print pg_last_error($pgsql_conn);
   exit;
}
?>

pg_transaction_status
pg_unescape_bytea
PostgreSQL İşlevleri


Unescape binary for bytea type

pg_tty
pg_untrace
PostgreSQL İşlevleri
PHP Manual

pg_unescape_bytea

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

pg_unescape_bytea — Unescape binary for bytea type

Açıklama

string pg_unescape_bytea ( string $data )

pg_unescape_bytea() unescapes PostgreSQL bytea data values. It returns the unescaped string, possibly containing binary data.

Bilginize:

When you SELECT a bytea type, PostgreSQL returns octal byte values prefixed with '\' (e.g. \032). Users are supposed to convert back to binary format manually.

This function requires PostgreSQL 7.2 or later. With PostgreSQL 7.2.0 and 7.2.1, bytea values must be cast when you enable multi-byte support. i.e. INSERT INTO test_table (image) VALUES ('$image_escaped'::bytea); PostgreSQL 7.2.2 or later does not need a cast. The exception is when the client and backend character encoding does not match, and there may be multi-byte stream error. User must then cast to bytea to avoid this error.

Değiştirgeler

data

A string containing PostgreSQL bytea data to be converted into a PHP binary string.

Dönen Değerler

A string containing the unescaped data.

Örnekler

Örnek 1 pg_unescape_bytea() example

<?php
  // Connect to the database
  $dbconn = pg_connect('dbname=foo');

  // Get the bytea data
  $res = pg_query("SELECT data FROM gallery WHERE name='Pine trees'");
  $raw = pg_fetch_result($res, 'data');

  // Convert to binary and send to the browser
  header('Content-type: image/jpeg');
  echo pg_unescape_bytea($raw);
?>

Sürüm Bilgisi

Sürüm: | Açıklama
5.5.1 | A warning is thrown if the input string is invalid.

Ayrıca Bakınız

  • pg_escape_bytea() - Escape a string for insertion into a bytea field
  • pg_escape_string() - Escape a string for query

pg_tty
pg_untrace
PostgreSQL İşlevleri


Disable tracing of a PostgreSQL connection

pg_unescape_bytea
pg_update
PostgreSQL İşlevleri
PHP Manual

pg_untrace

(PHP 4 >= 4.0.1, PHP 5, PHP 7)

pg_untrace — Disable tracing of a PostgreSQL connection

Açıklama

bool pg_untrace ([ resource $connection ] )

Stop tracing started by pg_trace().

Değiştirgeler

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

Dönen Değerler

Always returns TRUE.

Örnekler

Örnek 1 pg_untrace() example

<?php
$pgsql_conn = pg_connect("dbname=mark host=localhost");

if ($pgsql_conn) {
   pg_trace('/tmp/trace.log', 'w', $pgsql_conn);
   pg_query("SELECT 1");
   pg_untrace($pgsql_conn);
   // Now tracing of backend communication is disabled
} else {
   print pg_last_error($pgsql_conn);
   exit;
}
?>

Ayrıca Bakınız

  • pg_trace() - Enable tracing a PostgreSQL connection

pg_unescape_bytea
pg_update
PostgreSQL İşlevleri


Update table

pg_untrace
pg_version
PostgreSQL İşlevleri
PHP Manual

pg_update

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

pg_update — Update table

Açıklama

mixed pg_update ( resource $connection , string $table_name , array $data , array $condition [, int $options = PGSQL_DML_EXEC ] )

pg_update() updates records that matches condition with data. If options is specified, pg_convert() is applied to data with specified options.

Değiştirgeler

connection

PostgreSQL database connection resource.

table_name

Name of the table into which to update rows.

data

An array whose keys are field names in the table table_name, and whose values are what matched rows are to be updated to.

condition

An array whose keys are field names in the table table_name, and whose values are the conditions that a row must meet to be updated.

options

Any number of PGSQL_CONV_FORCE_NULL, PGSQL_DML_NO_CONV, PGSQL_DML_ESCAPE, PGSQL_DML_EXEC, PGSQL_DML_ASYNC or PGSQL_DML_STRING combined. If PGSQL_DML_STRING is part of the options then query string is returned. When PGSQL_DML_NO_CONV or PGSQL_DML_ESCAPE is set, it does not call pg_convert() internally.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. Returns string if PGSQL_DML_STRING is passed via options.

Örnekler

Örnek 1 pg_update() example

<?php
  $db = pg_connect('dbname=foo');
  $data = array('field1'=>'AA', 'field2'=>'BB');

  // This is safe, since $_POST is converted automatically
  $res = pg_update($db, 'post_log', $_POST, $data);
  if ($res) {
      echo "Data is updated: $res\n";
  } else {
      echo "User must have sent wrong inputs\n";
  }
?>

Sürüm Bilgisi

Sürüm: | Açıklama
5.6.0 | No longer experimental. Added PGSQL_DML_ESCAPE constant, TRUE/FALSE and NULL data type support.
5.5.3/5.4.19 | Direct SQL injection to table_name and Indirect SQL injection to identifiers are fixed.

Ayrıca Bakınız

  • pg_convert() - Convert associative array values into suitable for SQL statement

pg_untrace
pg_version
PostgreSQL İşlevleri


Returns an array with client, protocol and server version (when available)

pg_update
SQLite
PostgreSQL İşlevleri
PHP Manual

pg_version

(PHP 5, PHP 7)

pg_version — Returns an array with client, protocol and server version (when available)

Açıklama

array pg_version ([ resource $connection ] )

pg_version() returns an array with the client, protocol and server version. Protocol and server versions are only available if PHP was compiled with PostgreSQL 7.4 or later.

For more detailed server information, use pg_parameter_status().

Değiştirgeler

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

Dönen Değerler

Returns an array with client, protocol and server keys and values (if available). Returns FALSE on error or invalid connection.

Örnekler

Örnek 1 pg_version() example

<?php
  $dbconn = pg_connect("host=localhost port=5432 dbname=mary")
     or die("Could not connect");

  $v = pg_version($dbconn);

  echo $v['client'];
?>

Yukarıdaki örneğin çıktısı:

7.4

Ayrıca Bakınız

  • pg_parameter_status() - Looks up a current parameter setting of the server.

pg_update
SQLite
PostgreSQL İşlevleri


SQLite

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • SQLite İşlevleri
    • sqlite_array_query — Belirtilen veritabanı üzerinde bir sorgu çalıştırıp sonucu bir dizi içinde döndürür
    • sqlite_busy_timeout — Meşgul bekleme zaman aşımını belirler
    • sqlite_changes — En son SQL deyiminin değiştirdiği satır sayısını döndürür
    • sqlite_close — Açık bir SQLite veritabanını kapatır
    • sqlite_column — Sonuç kümesindeki geçerli satırdan belirtilen sütunu döndürür
    • sqlite_create_aggregate — SQL deyimlerinde kullanmak üzere toparlayıcı bir kullanıcı tanımlı işlevi kayda geçirir
    • sqlite_create_function — SQL deyimlerinde kullanmak üzere bir kullanıcı tanımlı işlevi kayda geçirir
    • sqlite_current — Sonuç kümesindeki geçerli satırı bir dizi içinde döndürür
    • sqlite_error_string — Bir hata kodu ile ilgili açıklamayı döndürür
    • sqlite_escape_string — Bir sorgu değiştirgesi olarak kullanmak üzere bir dizgeyi önceler
    • sqlite_exec — Belirtilen veritabanı üzerinde sonuç döndürmeyen bir sorgu çalıştırır
    • sqlite_factory — Bir SQLite veritabanı açıp bir SQLiteDatabase nesnesi döndürür
    • sqlite_fetch_all — Sonuç kümesindeki tüm satırları bir satır dizileri dizisi olarak döndürür
    • sqlite_fetch_array — Sonuç kümesindeki sonraki satırı bir dizi içinde döndürür
    • sqlite_fetch_column_types — Belli bir tablodaki sütun türlerini bir dizi içinde döndürür
    • sqlite_fetch_object — Sonuç kümesindeki sonraki satırı bir nesne olarak döndürür
    • sqlite_fetch_single — Sonuç kümesindeki ilk sütunu bir dizge olarak döndürür
    • sqlite_fetch_string — sqlite_fetch_single işlevinin takma adıdır
    • sqlite_field_name — Sonuç kümesindeki belli bir alanın ismini döndürür
    • sqlite_has_more — Sonuç kümesinde başka satır kaldı mı diye bakar
    • sqlite_has_prev — Geçerli satırın öncesinde satır var mı diye bakar
    • sqlite_key — Geçerli satırın indisini döndürür
    • sqlite_last_error — Veritabanındaki son hatanın kodunu döndürür
    • sqlite_last_insert_rowid — Son yerleştirilen satırın satır kimliğini döndürür
    • sqlite_libencoding — İlintili SQLite kütüphanesinin karakter kodlamasını döndürür
    • sqlite_libversion — İlintili SQLite kütüphanesinin sürüm numarasını döndürür
    • sqlite_next — Sonraki satıra gider
    • sqlite_num_fields — Sonuç kümesindeki alan sayısını döndürür
    • sqlite_num_rows — Tamponlu bir sonuç kümesindeki satır sayısını döndürür
    • sqlite_open — Bir SQLite veritabanı için bir tanıtıcı açar, veritabanı mevcut değilse oluşturur
    • sqlite_popen — Bir SQLite veritabanı için kalıcı bir tanıtıcı açar, veritabanı mevcut değilse oluşturur
    • sqlite_prev — Sonuç kümesindeki önceki satıra gider
    • sqlite_query — Belirtilen veritabanında bir sorgu çalıştırıp bir sonuç tanıtıcısı döndürür
    • sqlite_rewind — İlk satırı geçerli satır yapar
    • sqlite_seek — Tamponlu bir sonuç kümesinde belli bir satır numarasına gider
    • sqlite_single_query — Bir sorgu çalıştırıp sonucu tek bir sütunluk veya tek bir satırlık bir dizi olarak döndürür
    • sqlite_udf_decode_binary — Kullanıcı tanımlı bir işleve değiştirge olarak aktarılacak ikil veriyi çözümler
    • sqlite_udf_encode_binary — Bir kullanıcı tanımlı işlevden dönecek ikil veriyi döndürmeden önce kodlamak için kullanılır
    • sqlite_unbuffered_query — Sonuçların alınıp bir tampona konmadığı bir sorgu çalıştırır
    • sqlite_valid — Başka satır var mı diye bakar
pg_version
Giriş
Sağlayıcıya Göre Veritabanı Eklentileri


Giriş

Bu modül SQLite Gömülebilir SQL Veritabanı Motoru için bir eklentidir. SQLite gömülebilir bir SQL veritabanı motoru gerçekleyen bir C kütüphanesidir. SQLite kütüphanesi ile ilintilenen programlar ayrı bir RDBMS süreci çalıştırmaya gerek kalmaksızın SQL veritabanına erişebilirler.

SQLite, büyük bir veritabanı sunucusuna bağlanmak için kullanılan bir istemci kütüphanesi değildir. SQLite bir sunucudur. SQLite kütüphanesi veritabanı dosyalarını doğrudan diske yazar ve doğrudan diskten okur.

Bilginize:

Daha fazla bilgi için SQLite sitesine bakın (» http://sqlite.org/).

SQLite
Yapılandırma/Kurulum
SQLite


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
SQLite


Gereksinimler

The SQLite eklentisi PHP 5'ten itibaren öntanımlı olarak etkindir. Daha önceki sürümler için SQLite kütüphanesi gerekir.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

PHP 5'ten itibaren bu eklenti öntanımlı olarak etkin ve kullanılabilir durumda olup istenirse kolayca kaldırılabilir.

Dikkat

Bu eklentinin PECL sürümünü artık bakımı yapılmadığından kullanmayın. Paylaşımlı bile derleyecek olsanız daima PHP paketiyle gelen eklentiyi kullanın. Kaynak dosyaları pakette php-src-dir/ext/sqlite dizininde olup derlemek için phpize yöntemi kullanılabilir.

Windows kullanıcılarının bu eklentiyi kullanabilmesi için php.ini içinde php_sqlite.dll'i etkin kılmaları gerekir.

Windows derlemelerinde ayrıca PDO da etkindir. Bunun sebebi PHP 5.1.0'ın bu eklentiye bağımlı olmasıdır. Dolayısıyla php.ini dosyanızda şu satırlar bulunmalıdır:

extension=php_pdo.dll
extension=php_sqlite.dll
Linux ve Unix işletim sistemlerinde, PDO'yu paylaşımlı bir eklenti olarak derleyecekseniz SQLite'ı da paylaşımlı derlemelisiniz. Bunun için derleme sırasında --with-sqlite=shared yapılandırma seçeneğini kullanmanız gerekir.

PHP 5.0.x serisi Windows derlemelerinde bu eklenti öntanımlı olarak etkin olduğundan bir DLL dosyası gerekli değildir.

SQLite 3, PDO SQLite üzerinden desteklenmektedir.

Bilginize: Yetkisiz kullanıcılar için Windows kurulumu

Windows işletim sisteminde yetkisiz hesaplar öntanımlı olarak TMP ortam değişkenine sahip değildir. Bu durum, SQLite'ın geçici dosyaları windows dizininde oluşturmasına sebep olur ve bu istenmeyen bir durumdur. Bu bakımdan TMP ortam değişkenini HTTP sunucusu için veya HTTP sunucusunu çalıştıran kullanıcı için tanımlamanız gerekir. HTTP sunucusu olarak Apache kullanıyorsanız bunu httpd.conf dosyanızda SetEnv yönergesi üzerinden yapabilirsiniz. Örnek:

SetEnv TMP c:/temp
Bu ayarı sunucu seviyesinde yapamıyorsanız bunu betiğinizde de yapabilirsiniz:
putenv('TMP=C:/temp');
Burada belirttiğiniz dizin HTTP sunucusunun oluşturulan dosyaları okuyup yazabildiği bir dizin olmalıdır. Yoksa şöyle bir hata iletisi alabilirsiniz: malformed database schema - unable to open a temporary database file for storing temporary tables

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

SQLite Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm bilgisi
sqlite.assoc_case | "0" | PHP_INI_ALL | PHP 5.0.0'dan beri kullanılabilmektedir.
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

sqlite.assoc_case int

İndisler için büyük harf mi (1), küçük harf mi (2) yoksa her ikisi karışık mı (0) kullanılacağını belirler.

Bu seçenek, esas olarak, veritabanı şemasındaki alan adlarının gerçek harf büyüklüklerine aldırmadan sütun isimlerini daima küçük harf veya büyük harf olarak döndüren diğer veritabanı sistemleriyle uyumluluk gerektiğinde işe yarar.

SQLite kütüphanesi sütun isimlerini sizin belirttiğiniz gibi döndürür, harf büyüklüklerini değiştirmez. Bu, sqlite.assoc_case seçeneğine 0 atamaya eşdeğerdir. 1 veya 2 atanırsa PHP harf büyüklüklerinde gerekli dönüşümü yapacaktır.

Bu seçenek işlem hızını büyük ölçüde düşürür, ancak yine de PHP betiğinizde sizin yaptığınız harf dönüşüm işleminden hızlıdır.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Özkaynak Türleri

SQLite Arayüzünün kullandığı iki özkaynak türü vardır: Veritabanı bağlantısı ve sonuç kümesi.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

sqlite_fetch_array() ve sqlite_current() işlevleri farklı sonuç dizilerini belirtmek için sabitleri kullanır. Aşağıdaki sabitler tanımlıdır:

SQLite sonuç türü sabitleri
SQLITE_ASSOC (int)
Sütunlar bir dizi içinde döndürülürken alan isimleri indis olarak kullanılır.
SQLITE_BOTH (int)
Sütunlar bir dizi içinde döndürülürken indis olarak hem alan isimleri hem de sayısal indisler kullanılır.
SQLITE_NUM (int)
Sütunlar bir dizi içinde döndürülürken sayısal indisler kullanılır. Sonuç kümesindeki ilk alanın indisi 0'dır.

Bazı işlevler durum kodları döndürür. Bu amaçla şu sabitler tanımlanmıştır:

SQLite durum kodu sabitleri
SQLITE_OK (int)
Sonuç başarılı.
SQLITE_ERROR (int)
SQL hatası veya bir veritabanı yok.
SQLITE_INTERNAL (int)
SQLite'ta bir dahili mantık hatası.
SQLITE_PERM (int)
Erişime izin verilmedi.
SQLITE_ABORT (int)
Geriçağırım yordamı bir terk istedi.
SQLITE_BUSY (int)
Veritabanı kilitli.
SQLITE_LOCKED (int)
Veritabanında istenen tablo kilitli.
SQLITE_NOMEM (int)
Bellek ayrılamadı.
SQLITE_READONLY (int)
Salt okunur bir veritabanına yazma denemesi.
SQLITE_INTERRUPT (int)
İşlem dahili olarak sonlandırıldı.
SQLITE_IOERR (int)
Disk G/Ç hatası oluştu.
SQLITE_NOTADB (int)
Açık dosya bir veritabanı dosyası değil.
SQLITE_CORRUPT (int)
Veritabanının diskteki yapısı bozulmuş.
SQLITE_FORMAT (int)
Yardımcı veritabanı biçem hatası.
SQLITE_NOTFOUND (int)
(Dahili) Tablo veya kayıt yok.
SQLITE_FULL (int)
Veritabanı dolu olduğundan başka veri yazılamıyor.
SQLITE_CANTOPEN (int)
Veritabanı dosyası açılamadı.
SQLITE_PROTOCOL (int)
Veritabanı kilitleme protokolü hatası.
SQLITE_EMPTY (int)
(Dahili) Veritabanı tablosu boş.
SQLITE_SCHEMA (int)
Veritabanı şeması değişti.
SQLITE_TOOBIG (int)
Veri, tablodaki satır için çok fazla.
SQLITE_CONSTRAINT (int)
Kısıtla çelişki sebebiyle çıkılıyor.
SQLITE_MISMATCH (int)
Veri türü uygun değil.
SQLITE_MISUSE (int)
Kütüphane kullanımı yanlış.
SQLITE_NOLFS (int)
Kullanılan işletim sistemi özellikleri burada desteklenmiyor.
SQLITE_AUTH (int)
Yetkilendirme başarısız.
SQLITE_ROW (int)
Dahili süreç zaten başka bir satır için hazır.
SQLITE_DONE (int)
Dahili süreç işini bitirdi.
Özkaynak Türleri
SQLite İşlevleri
SQLite


SQLite İşlevleri

Öntanımlı Sınıflar

SQLiteDatabase

Açık bir SQLite veritabanını betimler.

Nesne Kurucu

  • __construct - Yeni bir SQLiteDatabase nesnesi oluşturur.

Yöntemler

  • query - Bir sorgu çalıştırır.
  • queryExec - Sonuç kümesiz bir sorgu çalıştırır.
  • arrayQuery - Sonuç kümesini bir dizi olarak döndüren bir sorgu çalıştırır.
  • singleQuery - Sorgu sonucunu ilk satırın değeri veya tek sütunluk bir dizi olarak döndüren bir sorgu çalıştırır.
  • unbufferedQuery - Tamponsuz bir sorgu çalıştırır
  • lastInsertRowid - En son yerleştirilen satırın satır kimliğini döndürür.
  • changes - En son deyimle değiştirilen satır sayısını döndürür.
  • createAggregate - SQL deyimlerinde kullanmak üzere toparlayıcı bir kullanıcı tanımlı işlevi kayda geçirir.
  • createFunction - SQL deyimlerinde kullanmak üzere bir kullanıcı tanımlı işlevi kayda geçirir.
  • busyTimeout - Meşgul zaman aşımını tanımlar veya kaldırır.
  • lastError - En son oluşan hatanın hata kodunu döndürür.
  • fetchColumnTypes - Belli bir tablodaki sütun türlerini bir dizi içinde döndürür.

SQLiteResult

Bir tamponlu SQLite sonuç kümesini betimler.

Yöntemler

  • fetch - Sonuç kümesindeki sonraki satırı bir dizi içinde döndürür.
  • fetchObject - Sonuç kümesindeki sonraki satırı bir nesne olarak döndürür.
  • fetchSingle - Sonuç kümesindeki ilk sütunu bir dizge olarak döndürür.
  • fetchAll - Sonuç kümesindeki tüm satırları bir satır dizileri dizisi olarak döndürür.
  • column - Sonuç kümesindeki geçerli satırdan bir sütun döndürür.
  • numFields - Sonuç kümesindeki alan sayısını döndürür.
  • fieldName - Sonuç kümesindeki belli bir alanın ismini döndürür.
  • current - Sonuç kümesindeki geçerli satırı bir dizi olarak döndürür.
  • key - Geçerli satırın indisini döndürür.
  • next - Sonraki satırı geçerli satır yapar.
  • valid - Başka satır var mı diye bakar.
  • rewind - Sonuç kümesindeki ilk satırı geçerli satır yapar.
  • prev - Sonuç kümesindeki önceki satırı geçerli satır yapar.
  • hasPrev - Geçerli satırın öncesinde satır var mı diye bakar.
  • numRows - Sonuç kümesindeki satır sayısını döndürür.
  • seek - Numarası belirtilen satırı geçerli satır yapar.

SQLiteUnbuffered

Tamponsuz bir SQLite sonuç kümesini betimler. Tamponsuz sonuç kümelerinde sadece ileri yönde ilerlenebilir.

Yöntemler

  • fetch - Sonuç kümesindeki sonraki satırı bir dizi olarak döndürür.
  • fetchObject - Sonuç kümesindeki sonraki satırı bir nesne olarak döndürür.
  • fetchSingle - Sonuç kümesindeki ilk sütunu bir dizge olarak döndürür.
  • fetchAll - Sonuç kümesindeki tüm satırları bir satır dizileri dizisi olarak döndürür.
  • column - Sonuç kümesindeki geçerli satırdan bir sütun döndürür.
  • numFields - Sonuç kümesindeki alan sayısını döndürür.
  • fieldName - Sonuç kümesindeki belli bir alanın ismini döndürür.
  • current - Sonuç kümesindeki geçerli satırı bir dizi olarak döndürür.
  • next - Sonraki satırı geçerli satır yapar.
  • valid - Başka satır var mı diye bakar.

İçindekiler

  • sqlite_array_query — Belirtilen veritabanı üzerinde bir sorgu çalıştırıp sonucu bir dizi içinde döndürür
  • sqlite_busy_timeout — Meşgul bekleme zaman aşımını belirler
  • sqlite_changes — En son SQL deyiminin değiştirdiği satır sayısını döndürür
  • sqlite_close — Açık bir SQLite veritabanını kapatır
  • sqlite_column — Sonuç kümesindeki geçerli satırdan belirtilen sütunu döndürür
  • sqlite_create_aggregate — SQL deyimlerinde kullanmak üzere toparlayıcı bir kullanıcı tanımlı işlevi kayda geçirir
  • sqlite_create_function — SQL deyimlerinde kullanmak üzere bir kullanıcı tanımlı işlevi kayda geçirir
  • sqlite_current — Sonuç kümesindeki geçerli satırı bir dizi içinde döndürür
  • sqlite_error_string — Bir hata kodu ile ilgili açıklamayı döndürür
  • sqlite_escape_string — Bir sorgu değiştirgesi olarak kullanmak üzere bir dizgeyi önceler
  • sqlite_exec — Belirtilen veritabanı üzerinde sonuç döndürmeyen bir sorgu çalıştırır
  • sqlite_factory — Bir SQLite veritabanı açıp bir SQLiteDatabase nesnesi döndürür
  • sqlite_fetch_all — Sonuç kümesindeki tüm satırları bir satır dizileri dizisi olarak döndürür
  • sqlite_fetch_array — Sonuç kümesindeki sonraki satırı bir dizi içinde döndürür
  • sqlite_fetch_column_types — Belli bir tablodaki sütun türlerini bir dizi içinde döndürür
  • sqlite_fetch_object — Sonuç kümesindeki sonraki satırı bir nesne olarak döndürür
  • sqlite_fetch_single — Sonuç kümesindeki ilk sütunu bir dizge olarak döndürür
  • sqlite_fetch_string — sqlite_fetch_single işlevinin takma adıdır
  • sqlite_field_name — Sonuç kümesindeki belli bir alanın ismini döndürür
  • sqlite_has_more — Sonuç kümesinde başka satır kaldı mı diye bakar
  • sqlite_has_prev — Geçerli satırın öncesinde satır var mı diye bakar
  • sqlite_key — Geçerli satırın indisini döndürür
  • sqlite_last_error — Veritabanındaki son hatanın kodunu döndürür
  • sqlite_last_insert_rowid — Son yerleştirilen satırın satır kimliğini döndürür
  • sqlite_libencoding — İlintili SQLite kütüphanesinin karakter kodlamasını döndürür
  • sqlite_libversion — İlintili SQLite kütüphanesinin sürüm numarasını döndürür
  • sqlite_next — Sonraki satıra gider
  • sqlite_num_fields — Sonuç kümesindeki alan sayısını döndürür
  • sqlite_num_rows — Tamponlu bir sonuç kümesindeki satır sayısını döndürür
  • sqlite_open — Bir SQLite veritabanı için bir tanıtıcı açar, veritabanı mevcut değilse oluşturur
  • sqlite_popen — Bir SQLite veritabanı için kalıcı bir tanıtıcı açar, veritabanı mevcut değilse oluşturur
  • sqlite_prev — Sonuç kümesindeki önceki satıra gider
  • sqlite_query — Belirtilen veritabanında bir sorgu çalıştırıp bir sonuç tanıtıcısı döndürür
  • sqlite_rewind — İlk satırı geçerli satır yapar
  • sqlite_seek — Tamponlu bir sonuç kümesinde belli bir satır numarasına gider
  • sqlite_single_query — Bir sorgu çalıştırıp sonucu tek bir sütunluk veya tek bir satırlık bir dizi olarak döndürür
  • sqlite_udf_decode_binary — Kullanıcı tanımlı bir işleve değiştirge olarak aktarılacak ikil veriyi çözümler
  • sqlite_udf_encode_binary — Bir kullanıcı tanımlı işlevden dönecek ikil veriyi döndürmeden önce kodlamak için kullanılır
  • sqlite_unbuffered_query — Sonuçların alınıp bir tampona konmadığı bir sorgu çalıştırır
  • sqlite_valid — Başka satır var mı diye bakar
Öntanımlı Sabitler
sqlite_array_query
SQLite


Belirtilen veritabanı üzerinde bir sorgu çalıştırıp sonucu bir dizi içinde döndürür

SQLite İşlevleri
sqlite_busy_timeout
SQLite İşlevleri
PHP Manual

sqlite_array_query

SQLiteDatabase->arrayQuery

(PHP 5 < 5.4.0, PECL sqlite >= 1.0.0)

sqlite_array_query -- SQLiteDatabase->arrayQuery — Belirtilen veritabanı üzerinde bir sorgu çalıştırıp sonucu bir dizi içinde döndürür

Açıklama

array sqlite_array_query ( resource $db , string $sorgu [, int $sonuç_türü [, bool $ikil_çöz ]] )
array sqlite_array_query ( string $sorgu , resource $db [, int $sonuç_türü [, bool $ikil_çöz ]] )

Nesne yönelimli kullanım

array arrayQuery ( string $sorgu [, int $sonuç_türü [, bool $ikil_çöz ]] )

Belirtilen sorguyu çalıştırıp sonuç kümesini bir dizi olarak
döndürür. sqlite_query() işlevinin ardından sonuç
kümesindeki her satır için sqlite_fetch_array() işlevini
çağırmaya eşdeğerdir.  sqlite_array_query() bu işlemi
bunlardan belirgin şekilde daha hızlı gerçekleştirir.

İpucu

sqlite_array_query() işlevi en fazla 45 satırlık sorgular için en iyilenmiştir. Bundan daha büyük sorgularda daha iyi başarım elde etmek için sqlite_unbuffered_query() işlevini kullanarak kendi betiğinizi yazmanız önerilir.

Değiştirgeler

sorgu

Çalıştırılacak sorgu.

Sorgu içindeki verinin düzgün olarak öncelenmiş olması gerekir.

db

SQLite Veritabanı özkaynağı. Yordamsal kullanımda sqlite_open() işlevi tarafından döndürülür. Nesne yönelimli kullanımda bu değiştirgeye gerek yoktur.

sonuç_türü

İsteğe bağlı bu değiştirgede döndürülen dizinin nasıl oluşturulacağını belirleyen bir sabit belirtilir. SQLITE_ASSOC belirtilirse alanların isimleri indis olarak kullanılır. SQLITE_NUM belirtilirse alanların sıra numaraları indis olarak kullanılır. SQLITE_BOTH için ise hem isimli hem de sayısal indisli bir dizi döner. SQLITE_BOTH bu işlev için öntanımlı değerdir.

ikil_çöz

TRUE belirtildiği takdirde (öntanımlıdır), veriye sqlite_escape_string() işleviyle ikil kodlama uygulanmışsa PHP bunu çözer. SQLite ile işlem yapan başka uygulamalarca oluşturulmuş veritabanları için bir takım ara işlemler yapmıyorsanız, normal olarak bu değeri öntanımlı haliyle bırakmanız gerekir.

Bilginize: Diğer veritabanı eklentileri (MySQL gibi) ile uyumluluk için iki ayrı sözdizimi desteklenmektedir. Genelde tercih edilen sözdizimi db değiştirgesinin ilk değiştirge olarak kullanıldığı ilk sözdizimidir.

Dönen Değerler

Başarısızlık durumunda FALSE yoksa sonuç kümesinin tamamını bir dizi olarak döndürür.

SQLITE_ASSOC ve SQLITE_BOTH sabitleri kullanılarak döndürülen sütun isimlerinin harf büyüklükleri sqlite.assoc_case php.ini yapılandırma yönergesinin değerine uygun olarak döndürülür.

Örnekler

Örnek 1 - Yordamsal kullanım örneği

<?php
$dbhandle = sqlite_open('sqlitedb');
$result = sqlite_array_query($dbhandle, 'SELECT name,
            email FROM users LIMIT 25', SQLITE_ASSOC);
foreach ($result as $entry) {
    echo İsim: ' . $entry['name'] . '  Eposta: ' . $entry['email'];
}
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$dbhandle = new SQLiteDatabase('sqlitedb');
$result = $dbhandle->arrayQuery('SELECT name,
            email FROM users LIMIT 25', SQLITE_ASSOC);
foreach ($result as $entry) {
    echo 'İsim: ' . $entry['name'] . '  Eposta: ' . $entry['email'];
}
?>

Ayrıca Bakınız

  • sqlite_query() - Belirtilen veritabanında bir sorgu çalıştırıp bir sonuç tanıtıcısı döndürür
  • sqlite_fetch_array() - Sonuç kümesindeki sonraki satırı bir dizi içinde döndürür
  • sqlite_fetch_string() - sqlite_fetch_single işlevinin takma adıdır

SQLite İşlevleri
sqlite_busy_timeout
SQLite İşlevleri


Meşgul bekleme zaman aşımını belirler

sqlite_array_query
sqlite_changes
SQLite İşlevleri
PHP Manual

sqlite_busy_timeout

SQLiteDatabase->busyTimeout

(PHP 5 < 5.4.0, PECL sqlite >= 1.0.0)

sqlite_busy_timeout -- SQLiteDatabase->busyTimeout — Meşgul bekleme zaman aşımını belirler

Açıklama

void sqlite_busy_timeout ( resource $db , int $milisaniye )

Nesne yönelimli kullanım

void busyTimeout ( int $milisaniye )

db ile belirtilen veritabanı kullanıma hazır hale gelene kadar beklenecek azami süreyi milisaniye cinsinden belirler.

Değiştirgeler

db

SQLite Veritabanı özkaynağı. Yordamsal kullanımda sqlite_open() işlevi tarafından döndürülür. Nesne yönelimli kullanımda bu değiştirgeye gerek yoktur.

milisaniye

Zaman aşımının saniye cinsinden süresi. 0 belirtilirse ve veritabanını başka bir süreç veya evre güncellemek için kilitlemişse SQLite hiç beklemeden SQLITE_BUSY durum kodu ile döner.

PHP, veritabanı açıldığında bu zaman aşımı süresini 60 saniyeye ayarlar.

Bilginize:

Bir saniye 1000 milisaniyedir.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 - Yordamsal kullanım örneği

<?php
$dbhandle = sqlite_open('sqlitedb');
sqlite_busy_timeout($dbhandle, 10000); // zaman aşımını 10 saniye yapar
sqlite_busy_timeout($dbhandle, 0); // zaman aşımı 0 yapılır
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$dbhandle = new SQLiteDatabase('sqlitedb');
$dbhandle->busyTimeout(10000); // 10 saniye
$dbhandle->busyTimeout(0); // iptal
?>

Ayrıca Bakınız

  • sqlite_open() - Bir SQLite veritabanı için bir tanıtıcı açar, veritabanı mevcut değilse oluşturur

sqlite_array_query
sqlite_changes
SQLite İşlevleri


En son SQL deyiminin değiştirdiği satır sayısını döndürür

sqlite_busy_timeout
sqlite_close
SQLite İşlevleri
PHP Manual

sqlite_changes

SQLiteDatabase->changes

(PHP 5 < 5.4.0, PECL sqlite >= 1.0.0)

sqlite_changes -- SQLiteDatabase->changes — En son SQL deyiminin değiştirdiği satır sayısını döndürür

Açıklama

int sqlite_changes ( resource $db )

Nesne yönelimli kullanım

int changes ( void )

En son SQL deyiminin db veritabanında değiştirdiği satır sayısını döndürür.

Değiştirgeler

db

SQLite Veritabanı özkaynağı. Yordamsal kullanımda sqlite_open() işlevi tarafından döndürülür. Nesne yönelimli kullanımda bu değiştirgeye gerek yoktur.

Dönen Değerler

Değişen satır sayısı.

Örnekler

Örnek 1 - Yordamsal kullanım örneği

<?php
$dbhandle = sqlite_open('mysqlitedb');
$query = sqlite_query($dbhandle,
        "UPDATE users SET email='jDoe@example.com' WHERE username='jDoe'");
if (!$query) {
    exit('Sorguda hata.');
} else {
    echo 'Değişen satır sayısı: ', sqlite_changes($dbhandle);
}
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$dbhandle = new SQLiteDatabase('mysqlitedb');
$query = $dbhandle->query(
        "UPDATE users SET email='jDoe@example.com' WHERE username='jDoe'");
if (!$query) {
    exit('Sorguda hata.');
} else {
    echo 'Değişen satır sayısı: ', $dbhandle->changes();
}
?>

Ayrıca Bakınız

  • sqlite_open() - Bir SQLite veritabanı için bir tanıtıcı açar, veritabanı mevcut değilse oluşturur

sqlite_busy_timeout
sqlite_close
SQLite İşlevleri


Açık bir SQLite veritabanını kapatır

sqlite_changes
sqlite_column
SQLite İşlevleri
PHP Manual

sqlite_close

(PHP 5 < 5.4.0, PECL sqlite >= 1.0.0)

sqlite_close — Açık bir SQLite veritabanını kapatır

Açıklama

void sqlite_close ( resource $db )

db ile belirtilen veritabanını kapatır. Veritabanı kalıcı ise kapatıldıktan sonra kalıcı veritabanları listesinden silinir.

Değiştirgeler

db

SQLite Veritabanı özkaynağı. Yordamsal kullanımda sqlite_open() işlevi tarafından döndürülür. Nesne yönelimli kullanımda bu değiştirgeye gerek yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 - sqlite_close() örneği

<?php
$dbhandle = sqlite_open('sqlitedb');
sqlite_close($dbhandle);
?>

Ayrıca Bakınız

  • sqlite_open() - Bir SQLite veritabanı için bir tanıtıcı açar, veritabanı mevcut değilse oluşturur
  • sqlite_popen() - Bir SQLite veritabanı için kalıcı bir tanıtıcı açar, veritabanı mevcut değilse oluşturur

sqlite_changes
sqlite_column
SQLite İşlevleri


Sonuç kümesindeki geçerli satırdan belirtilen sütunu döndürür

sqlite_close
sqlite_create_aggregate
SQLite İşlevleri
PHP Manual

sqlite_column

SQLiteResult->column

SQLiteUnbuffered->column

(PHP 5 < 5.4.0, PECL sqlite >= 1.0.0)

sqlite_column -- SQLiteResult->column -- SQLiteUnbuffered->column — Sonuç kümesindeki geçerli satırdan belirtilen sütunu döndürür

Açıklama

mixed sqlite_column ( resource $sonuç , mixed $indis_veya_isim [, bool $ikil_çöz = true ] )
mixed column ( mixed $indis_veya_isim [, bool $ikil_çöz = true ] )
mixed column ( mixed $indis_veya_isim [, bool $ikil_çöz = true ] )

sonuç ile belirtilen sonuç kümesindeki geçerli satırdan indis_veya_isim ile numarası (bir tamsayı) veya ismi (bir dizge) belirtilen sütunu döndürür.

Değiştirgeler

sonuç

SQLite sonuç özkaynağı. Nesne yönelimli kullanımda bu değiştirgeye gerek yoktur.

indis_veya_isim

Döndürülecek sütunun ismi veya numarası.

ikil_çöz

TRUE belirtildiği takdirde (öntanımlıdır), veriye sqlite_escape_string() işleviyle ikil kodlama uygulanmışsa PHP bunu çözer. SQLite ile işlem yapan başka uygulamalarca oluşturulmuş veritabanları için bir takım ara işlemler yapmıyorsanız, normal olarak bu değeri öntanımlı haliyle bırakmanız gerekir.

Dönen Değerler

Sütunun değeri.

Notlar

Bilginize:

Büyük bir sonuç kümesinde çok sayıda sütun üzerinde yineleme yapacaksanız veya sütunlardan büyük miktarda veri döndürecekseniz bu işlevi kullanın.

Ayrıca Bakınız

  • sqlite_fetch_string() - sqlite_fetch_single işlevinin takma adıdır

sqlite_close
sqlite_create_aggregate
SQLite İşlevleri


SQL deyimlerinde kullanmak üzere toparlayıcı bir kullanıcı tanımlı işlevi kayda geçirir

sqlite_column
sqlite_create_function
SQLite İşlevleri
PHP Manual

sqlite_create_aggregate

SQLiteDatabase->createAggregate

(PHP 5 < 5.4.0, PECL sqlite >= 1.0.0)

sqlite_create_aggregate -- SQLiteDatabase->createAggregate — SQL deyimlerinde kullanmak üzere toparlayıcı bir kullanıcı tanımlı işlevi kayda geçirir

Açıklama

void sqlite_create_aggregate ( resource $db , string $işlev_ismi , callback $sekme_işlevi , callback $sonuncu_işlev [, int $değ_sayısı = -1 ] )

Nesne yönelimli kullanım

void createAggregate ( string $işlev_ismi , callback $sekme_işlevi , callback $sonuncu_işlev [, int $değ_sayısı = -1 ] )

Bir sorgudaki tüm satırlardan toparlanan bir sonucu hesaplayacak bir işlevi kayda geçirmesi dışında sqlite_create_function() işlevi gibidir.

Bu işlevin sqlite_create_function() işlevinden farkı bir değil üç işlevi kayda geçirmesidir. Betiğiniz gerekli sonuç kümesini sağlar. Sonuç kümesindeki her satır için sekme_işlevi çağrılarak elde edilen sonuçlarla toparlama bağlamı oluşturulur. Toparlama bağlamından veriyi alıp sonucu döndürmek için ise sonuncu_işlev çağrılır. Bu geriçağırım işlevlerinin SQLite'ın tanıdığı veri türlerini döndürmesi gerekir (bir sayıl tür gibi).

Değiştirgeler

db

SQLite Veritabanı özkaynağı. Yordamsal kullanımda sqlite_open() işlevi tarafından döndürülür. Nesne yönelimli kullanımda bu değiştirgeye gerek yoktur.

işlev_ismi

SQL deyimlerinde kullanılacak işlev ismi.

sekme_işlevi

Sonuç kümesindeki her satır için çağrılacak geriçağırım işlevi.

sonuncu_işlev

Satırlardan adım adım toplanan veriden sonucu hesaplayacak geriçağırım işlevi.

değ_sayısı

Geriçağırım işlevi belli sayıda değiştirge gerektiriyorsa SQLite çözümleyiciye bir ipucu vermek için kullanılır.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 - azami_uzunluk işlevi örneği

<?php
$data = array(
   'one',
   'two',
   'three',
   'four',
   'five',
   'six',
   'seven',
   'eight',
   'nine',
   'ten',
   );
$db = sqlite_open(':memory:');
sqlite_query($db, "CREATE TABLE strings(a)");
foreach ($data as $str) {
    $str = sqlite_escape_string($str);
    sqlite_query($db, "INSERT INTO strings VALUES ('$str')");
}

function azami_uzunluk_sek(&$baglam, $dizge)
{
    if (strlen($dizge) > $baglam) {
        $baglam = strlen($dizge);
    }
}

function azami_uzunluk_bitir(&$baglam)
{
    return $baglam;
}

sqlite_create_aggregate($db, 'azami_uzunluk', 'azami_uzunluk_sek',
                          'azami_uzunluk_bitir');

var_dump(sqlite_array_query($db, 'SELECT azami_uzunluk(a) from strings'));

?>

Bu örnekte, bir tablonun sütunlarında bulunan dizgelerin en uzununun boyunu hesaplayan bir veri toparlama işlevi oluşturulmaktadır. Her satır için azami_uzunluk_sek işlevi çağrılmakta ve önceki $baglam değiştirgesindekinden daha uzun olan dizge daima $baglam değiştirgesindekiyle değiştirilmektedir. $baglam değiştirgesi herhangi bir PHP değişkeni gibi bir dizi veya nesne tutabilmelidir.

Bütün satırlar işlemden geçirildikten sonra SQLite, sonucu döndürmek için azami_uzunluk_bitir işlevini çağırır. Burada $baglam değiştirgesindeki veriye dayalı her çeşit hesaplama yapabilirdik. Örneğimiz basit olsun çalıştırılan sorgudan elde edilen sonucu basit bir işleme sokup elde ettiğimiz bağlamı döndürmekle yetindik.

Bilginize:

Yukarıdaki örnek, ikil veri içeren sütunlar varsa gerektiği gibi çalışmaz. Bunun sebebini ve ikil kodlamayla nasıl çalışıldığını öğrenmek için sqlite_udf_decode_binary() işlevinin açıklamasına bakınız.

İpucu

Değerlerin kopyalarını bağlamda saklayıp sonra bunlar üzerinde işlem yapmanız önerilmez. Yoksa SQLite'ın sorguyu işlemek için çok fazla bellek kullanmasına sebep olursunuz. Her biri 32 baytlık bir dizge içeren bir milyon satır için ne kadar bellek gerektiğini bir düşünün.

İpucu

SQLite'ın dahili SQL işlevlerini geçersiz kılmak için sqlite_create_function() ve sqlite_create_aggregate() işlevlerini kullanabilirsiniz.

Ayrıca Bakınız

  • sqlite_create_function() - SQL deyimlerinde kullanmak üzere bir kullanıcı tanımlı işlevi kayda geçirir
  • sqlite_udf_encode_binary() - Bir kullanıcı tanımlı işlevden dönecek ikil veriyi döndürmeden önce kodlamak için kullanılır
  • sqlite_udf_decode_binary() - Kullanıcı tanımlı bir işleve değiştirge olarak aktarılacak ikil veriyi çözümler

sqlite_column
sqlite_create_function
SQLite İşlevleri


SQL deyimlerinde kullanmak üzere bir kullanıcı tanımlı işlevi kayda geçirir

sqlite_create_aggregate
sqlite_current
SQLite İşlevleri
PHP Manual

sqlite_create_function

SQLiteDatabase->createFunction

(PHP 5 < 5.4.0, sqlite >= 1.0.0)

sqlite_create_function -- SQLiteDatabase->createFunction — SQL deyimlerinde kullanmak üzere bir kullanıcı tanımlı işlevi kayda geçirir

Açıklama

void sqlite_create_function ( resource $db , string $işlev_adı , callback $geriçağırım [, int $değ_sayısı = -1 ] )

Nesne yönelimli kullanım

void createFunction ( string $işlev_adı , callback $geriçağırım [, int $değ_sayısı = -1 ] )

SQL deyimlerinde kullanmak üzere bir kullanıcı tanımlı işlevi kayda geçirir.

Kullanıcı tanımlı işlevler, işlev çağırabilen SQL deyimlerinde kulllanılır. SELECT ve UPDATE deyimlerinden başka tetikleyiciler de işlev çağırabilmektedir.

Değiştirgeler

db

SQLite Veritabanı özkaynağı. Yordamsal kullanımda sqlite_open() işlevi tarafından döndürülür. Nesne yönelimli kullanımda bu değiştirgeye gerek yoktur.

işlev_adı

SQL deyiminde kullanılacak işlevin adı.

geriçağırım

Tanımlanan SQL işlevini elde edecek geriçağırım işlevi.

Bilginize: Geriçağırım işlevlerinin SQLite'ın tanıdığı veri türlerini döndürmesi gerekir (bir sayıl tür gibi).

değ_sayısı

Geriçağırım işlevi belli sayıda değiştirge gerektiriyorsa SQLite çözümleyiciye bir ipucu vermek için kullanılır.

Bilginize: Diğer veritabanı eklentileri (MySQL gibi) ile uyumluluk için iki ayrı sözdizimi desteklenmektedir. Genelde tercih edilen sözdizimi db değiştirgesinin ilk değiştirge olarak kullanıldığı ilk sözdizimidir.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 - sqlite_create_function() örneği

<?php
function md5_and_reverse($string)
{
    return strrev(md5($string));
}

if ($dbhandle = sqlite_open('mysqlitedb', 0666, $sqliteerror)) {

    sqlite_create_function($dbhandle, 'md5rev', 'md5_and_reverse', 1);

    $sql  = 'SELECT md5rev(filename) FROM files';
    $rows = sqlite_array_query($dbhandle, $sql);
} else {
    echo 'sqlite veritabanı açılırken hata: ' . $sqliteerror;
    exit;
}
?>

Bu örnekte, bir dizgenin MD5 toplamını hesaplayıp bunu ters çeviren bir işlev tanımlanmaktadır. SQL deyimi çalıştırıldığında işlevimiz dosya isminin dönüştürülmüş değerini döndürmektedir. $rows sonucu içerecektir.

Bu tekniğin güzel tarafı veriyi sorguladıktan sonra sonucu işlemek için bir foreach döngüsü kullanımını gerektirmemesidir.

Veritabanı ilk açıldığında PHP, php adında bir işlevi kayda geçirir. Yeni bir isim kaydetmek zorunda kalmadan php ismini işlev_adı olarak kullanabilirsiniz.

Örnek 2 - php işlevi kullanım örneği

<?php
$rows = sqlite_array_query($dbhandle, "SELECT php('md5', dosya) from files");
?>

Bu örnek veritabanındaki her dosya sütunu için md5() işlevini çağırır ve sonucu $rows içinde döndürür.

Bilginize:

Başarımı arttırmak amacıyla PHP, kullanıcı tanımlı işleve aktarılan ve ondan dönen ikil verileri özdevinimli olarak kodlamaz veya çözümlemez. Bu yöntemde ikil veriler kullanmak istiyorsanız ikil verileri kodlama ve çözme işlemlerini kendiniz gerçeklemelisiniz. Bu konuda daha ayrıntılı bilgi edinmek için sqlite_udf_encode_binary() ve sqlite_udf_decode_binary() işlevinin açıklamasına bakınız.

İpucu

Başarımı arttırmak uygulamanız için vazgeçilmezlerdense kullanıcı tanımlı işlevlerde ikil verileri işlemeniz önerilmez.

İpucu

sqlite_create_function() ve sqlite_create_aggregate() işlevlerini SQLite'ın dahili SQL işlevlerini geçersiz kılmak için kullanabilirsiniz.

Ayrıca Bakınız

  • sqlite_create_aggregate() - SQL deyimlerinde kullanmak üzere toparlayıcı bir kullanıcı tanımlı işlevi kayda geçirir

sqlite_create_aggregate
sqlite_current
SQLite İşlevleri


Sonuç kümesindeki geçerli satırı bir dizi içinde döndürür

sqlite_create_function
sqlite_error_string
SQLite İşlevleri
PHP Manual

sqlite_current

SQLiteResult->current

SQLiteUnbuffered->current

(PHP 5 < 5.4.0, PECL sqlite >= 1.0.0)

sqlite_current -- SQLiteResult->current -- SQLiteUnbuffered->current — Sonuç kümesindeki geçerli satırı bir dizi içinde döndürür

Açıklama

array sqlite_current ( resource $sonuç [, int $sonuç_türü = SQLITE_BOTH [, bool $ikil_çöz = true ]] )

Nesne yönelimli kullanım

array current ([ int $sonuç_türü = SQLITE_BOTH [, bool $ikil_çöz = true ]] )
array current ([ int $sonuç_türü = SQLITE_BOTH [, bool $ikil_çöz = true ]] )

Veriyi döndürmeden önce bir sonraki satıra ilerlememesi dışında sqlite_fetch_array() işlevinin benzeridir. Bu işlev sadece geçerli satırdaki veriyi döndürür.

Değiştirgeler

sonuç

SQLite sonuç özkaynağı. Nesne yönelimli kullanımda bu değiştirgeye gerek yoktur.

sonuç_türü

İsteğe bağlı bu değiştirgede döndürülen dizinin nasıl oluşturulacağını belirleyen bir sabit belirtilir. SQLITE_ASSOC belirtilirse alanların isimleri indis olarak kullanılır. SQLITE_NUM belirtilirse alanların sıra numaraları indis olarak kullanılır. SQLITE_BOTH için ise hem isimli hem de sayısal indisli bir dizi döner. SQLITE_BOTH bu işlev için öntanımlı değerdir.

ikil_çöz

TRUE belirtildiği takdirde (öntanımlıdır), veriye sqlite_escape_string() işleviyle ikil kodlama uygulanmışsa PHP bunu çözer. SQLite ile işlem yapan başka uygulamalarca oluşturulmuş veritabanları için bir takım ara işlemler yapmıyorsanız, normal olarak bu değeri öntanımlı haliyle bırakmanız gerekir.

Dönen Değerler

Sonuç kümesindeki geçerli satırı içeren bir dizi döndürür. Geçerli konum son satırın sonrasındaysa FALSE döner.

SQLITE_ASSOC ve SQLITE_BOTH sabitleri kullanılarak döndürülen sütun isimlerinin harf büyüklükleri sqlite.assoc_case php.ini yapılandırma yönergesinin değerine uygun olarak döndürülür.

Ayrıca Bakınız

  • sqlite_seek() - Tamponlu bir sonuç kümesinde belli bir satır numarasına gider
  • sqlite_next() - Sonraki satıra gider
  • sqlite_fetch_array() - Sonuç kümesindeki sonraki satırı bir dizi içinde döndürür

sqlite_create_function
sqlite_error_string
SQLite İşlevleri


Bir hata kodu ile ilgili açıklamayı döndürür

sqlite_current
sqlite_escape_string
SQLite İşlevleri
PHP Manual

sqlite_error_string

(PHP 5 < 5.4.0, PECL sqlite >= 1.0.0)

sqlite_error_string — Bir hata kodu ile ilgili açıklamayı döndürür

Açıklama

string sqlite_error_string ( int $hata_kodu )

sqlite_last_error() işlevinden dönen hata_kodu'nun iletisini döndürür.

Değiştirgeler

hata_kodu

sqlite_last_error() işlevinden dönen hata numarası.

Dönen Değerler

Hata iletisini bir dizge olarak döndürür.

Ayrıca Bakınız

  • sqlite_last_error() - Veritabanındaki son hatanın kodunu döndürür

sqlite_current
sqlite_escape_string
SQLite İşlevleri


Bir sorgu değiştirgesi olarak kullanmak üzere bir dizgeyi önceler

sqlite_error_string
sqlite_exec
SQLite İşlevleri
PHP Manual

sqlite_escape_string

(PHP 5 < 5.4.0, PECL sqlite >= 1.0.0)

sqlite_escape_string — Bir sorgu değiştirgesi olarak kullanmak üzere bir dizgeyi önceler

Açıklama

string sqlite_escape_string ( string $öğe )

Bir SQLite deyiminde kullanmak için öğe ile belirtilen dizgeye önceleme uygular. Buna tek tırnakların tek tırnaklarla öncelenmesi ve ikil olarak güvenilir olmayan karakterlerin uygun şekilde öncelenmesi dahildir.

Kodlamak suretiyle verinin güvenle yerleştirilmesini sağlasa da basit metin karşılaştırmalarıyla bunu yaptığından, LIKE deyimlerinde olduğu gibi ikil veri içeren sütunlar için kullanışsızdır. Uygulamada, böyle şeyleri ikil sütunlarda saklamamanız gerektiğinden (aslında ikil verileri başka bir yerde örneğin dosyalarda saklamanız daha iyidir) bunun bir sorun olmaması gerekir.

Değiştirgeler

öğe

Öncelenecek dizge.

Belirtilen dizge bir NUL karakteri içeriyorsa veya 0x01 karakteri ile başlıyorsa PHP'nin uygulayacağı ikil kodlama şemasından dolayı böyle ikil verileri rahatça alıp saklayabilirsiniz.

Dönen Değerler

Bir SQLite deyiminde kullanmak üzere bir öncelenmiş dizge döndürür.

Notlar

Bilginize: sqlite_create_function() veya sqlite_create_aggregate() kullanılarak oluşturulmuş kullanıcı tanımlı bir işlevden dönen bir değeri kodlamak için bu işlevi değil sqlite_udf_encode_binary() işlevini kullanın.

Uyarı

SQLite sorgularında kullanacağınız dizgeler için addslashes() işlevini kullanmayın; veriyi veritabanından alırken tuhaf sonuçlar verebilir.

Ayrıca Bakınız

  • sqlite_udf_encode_binary() - Bir kullanıcı tanımlı işlevden dönecek ikil veriyi döndürmeden önce kodlamak için kullanılır

sqlite_error_string
sqlite_exec
SQLite İşlevleri


Belirtilen veritabanı üzerinde sonuç döndürmeyen bir sorgu çalıştırır

sqlite_escape_string
sqlite_factory
SQLite İşlevleri
PHP Manual

sqlite_exec

SQLiteDatabase->exec

(PHP 5 < 5.4.0, PECL sqlite >= 1.0.3)

sqlite_exec -- SQLiteDatabase->exec — Belirtilen veritabanı üzerinde sonuç döndürmeyen bir sorgu çalıştırır

Açıklama

bool sqlite_exec ( resource $db , string $sorgu [, string &$hata_iletisi ] )
bool sqlite_exec ( string $sorgu , resource $db )

Nesne yönelimli kullanım

bool queryExec ( string $sorgu [, string &$hata_iletisi ] )

db ile belirtilen veritabanı üzerinde sorgu ile belirtilen SQL deyimini çalıştırır.

Uyarı

SQLite, noktalı virgüllerle ayrılmış birden fazla sorguyu çalıştırabilir. Bu sayede, bir dosyadan yüklenen SQL betiklerini çalıştırabilirsiniz.

Değiştirgeler

db

SQLite Veritabanı özkaynağı. Yordamsal kullanımda sqlite_open() işlevi tarafından döndürülür. Nesne yönelimli kullanımda bu değiştirgeye gerek yoktur.

sorgu

Çalıştırılacak sorgu.

Sorgu içindeki verinin düzgün olarak öncelenmiş olması gerekir.

hata_iletisi

Bir hata oluştuğunda hata iletisi bu değiştirgeye konur. SQL sözdizimi hataları sqlite_last_error() işlevi ile alınamadığından bu değiştirge özellikle önemlidir.

Bilginize: Diğer veritabanı eklentileri (MySQL gibi) ile uyumluluk için iki ayrı sözdizimi desteklenmektedir. Genelde tercih edilen sözdizimi db değiştirgesinin ilk değiştirge olarak kullanıldığı ilk sözdizimidir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. Sorgu bir sonuç döndürmeliyse bu işlevi değil sqlite_query() işlevini kullanın.

SQLITE_ASSOC ve SQLITE_BOTH sabitleri kullanılarak döndürülen sütun isimlerinin harf büyüklükleri sqlite.assoc_case php.ini yapılandırma yönergesinin değerine uygun olarak döndürülür.

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.0 | hata_iletisi değiştirgesi eklendi.

Örnekler

Örnek 1 - Yordamsal kullanım örneği

<?php
$db = sqlite_open('mysqlitedb');
$query = sqlite_exec($db,
        "UPDATE users SET email='jDoe@example.com' WHERE username='jDoe'",
        $error);
if (!$query) {
    exit("Sorguda hata: '$error'");
} else {
    echo 'Değişen satır sayısı: ', sqlite_changes($db);
}
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$db = new SQLiteDatabase('mysqlitedb');
$query = $db->queryExec(
          "UPDATE users SET email='jDoe@example.com' WHERE username='jDoe'",
          $error);
if (!$query) {
    exit("Sorguda hata: '$error'");
} else {
    echo 'Değişen satır sayısı: ', $db->changes();
}
?>

Ayrıca Bakınız

  • sqlite_query() - Belirtilen veritabanında bir sorgu çalıştırıp bir sonuç tanıtıcısı döndürür
  • sqlite_unbuffered_query() - Sonuçların alınıp bir tampona konmadığı bir sorgu çalıştırır
  • sqlite_array_query() - Belirtilen veritabanı üzerinde bir sorgu çalıştırıp sonucu bir dizi içinde döndürür

sqlite_escape_string
sqlite_factory
SQLite İşlevleri


Bir SQLite veritabanı açıp bir SQLiteDatabase nesnesi döndürür

sqlite_exec
sqlite_fetch_all
SQLite İşlevleri
PHP Manual

sqlite_factory

(PHP 5 < 5.4.0)

sqlite_factory — Bir SQLite veritabanı açıp bir SQLiteDatabase nesnesi döndürür

Açıklama

SQLiteDatabase sqlite_factory ( string $dosya [, int $kip = 0666 [, string &$hata_iletisi ]] )

sqlite_open() işlevi gibi davranarak bir SQLite veritabanını açmaya, veritabanı mevcut değilse oluşturmaya çalışır. Ancak farklı olarak bir özkaynak değil bir SQLiteDatabase nesnesi döner. Ayrıntılar için sqlite_open() işlevinin açıklamasına bakınız.

Değiştirgeler

dosya

SQLite veritabanı dosyası.

kip

Dosyanın erişim kipi. Veritabanını salt okunur kipte açmak için kullanmak amacıyla tasarlanmıştır. Hali hazırda bu değiştirge SQLite kütüphanesi tarafından yok sayılmaktadır. Değiştirgenin öntanımlı değeri 0666 olup bu önerilen değerdir.

hata_iletisi

Bir hata oluştuğunda veritabanının açılamama sebebini açıklayan ileti bu değiştirgeye konur.

Dönen Değerler

Bir hata durumunda NULL yoksa bir SQLiteDatabase nesnesi döner.

Örnekler

Örnek 1 - sqlite_factory() örneği

<?php
$db = sqlite_factory('sqlitedb');
$db->query('SELECT user_id, username FROM users');

/* Buna eşdeğerdir: */

$db = new SQLiteDatabase('sqlitedb');
$db->query('SELECT user_id, username FROM users');

?>

Ayrıca Bakınız

  • sqlite_open() - Bir SQLite veritabanı için bir tanıtıcı açar, veritabanı mevcut değilse oluşturur
  • sqlite_popen() - Bir SQLite veritabanı için kalıcı bir tanıtıcı açar, veritabanı mevcut değilse oluşturur

sqlite_exec
sqlite_fetch_all
SQLite İşlevleri


Sonuç kümesindeki tüm satırları bir satır dizileri dizisi olarak döndürür

sqlite_factory
sqlite_fetch_array
SQLite İşlevleri
PHP Manual

sqlite_fetch_all

SQLiteResult->fetchAll

SQLiteUnbuffered->fetchAll

(PHP 5 < 5.4.0, PECL sqlite >= 1.0.0)

sqlite_fetch_all -- SQLiteResult->fetchAll -- SQLiteUnbuffered->fetchAll — Sonuç kümesindeki tüm satırları bir satır dizileri dizisi olarak döndürür

Açıklama

array sqlite_fetch_all ( resource $sonuç [, int $sonuç_türü = SQLITE_BOTH [, bool $ikil_çöz = true ]] )

Nesne yönelimli kullanım

array fetchAll ([ int $sonuç_türü = SQLITE_BOTH [, bool $ikil_çöz = true ]] )
array fetchAll ([ int $sonuç_türü = SQLITE_BOTH [, bool $ikil_çöz = true ]] )

sonuç tanıtıcısı ile belirtilen sonuç kümesindeki tüm satırları bir satır dizileri dizisi olarak döndürür. sqlite_query() (veya sqlite_unbuffered_query()) işlevinin ardından sonuç kümesindeki her satır için sqlite_fetch_array() işlevini çağırmaya eşdeğerdir.

Değiştirgeler

sonuç

SQLite sonuç özkaynağı. Nesne yönelimli kullanımda bu değiştirgeye gerek yoktur.

sonuç_türü

İsteğe bağlı bu değiştirgede döndürülen dizinin nasıl oluşturulacağını belirleyen bir sabit belirtilir. SQLITE_ASSOC belirtilirse alanların isimleri indis olarak kullanılır. SQLITE_NUM belirtilirse alanların sıra numaraları indis olarak kullanılır. SQLITE_BOTH için ise hem isimli hem de sayısal indisli bir dizi döner. SQLITE_BOTH bu işlev için öntanımlı değerdir.

ikil_çöz

TRUE belirtildiği takdirde (öntanımlıdır), veriye sqlite_escape_string() işleviyle ikil kodlama uygulanmışsa PHP bunu çözer. SQLite ile işlem yapan başka uygulamalarca oluşturulmuş veritabanları için bir takım ara işlemler yapmıyorsanız, normal olarak bu değeri öntanımlı haliyle bırakmanız gerekir.

Dönen Değerler

Sonuç kümesindeki tüm satırları bir satır dizileri dizisi olarak döndürür. sqlite_query() işlevinin hemen ardından çağrılırsa tüm satırları döndürür. sqlite_fetch_array(), işlevinden sonra çağrılırsa kalanları döndürür. Sonuç kümesinde hiç satır yoksa boş bir dizi döner.

SQLITE_ASSOC ve SQLITE_BOTH sabitleri kullanılarak döndürülen sütun isimlerinin harf büyüklükleri sqlite.assoc_case php.ini yapılandırma yönergesinin değerine uygun olarak döndürülür.

Örnekler

Örnek 1 - Yordamsal kullanım örneği

<?php
$dbhandle = sqlite_open('sqlitedb');
$query = sqlite_query($dbhandle, 'SELECT name, email FROM users LIMIT 25');
$result = sqlite_fetch_all($query, SQLITE_ASSOC);
foreach ($result as $entry) {
    echo 'İsim: ' . $entry['name'] . '  Eposta: ' . $entry['email'];
}
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$dbhandle = new SQLiteDatabase('sqlitedb');

//  Tamponlu sonuç kümesi
$query = $dbhandle->query('SELECT name, email FROM users LIMIT 25');

// Tamponsuz sonuç kümesi
$query = $dbhandle->unbufferedQuery('SELECT name, email FROM users LIMIT 25');

$result = $query->fetchAll(SQLITE_ASSOC);
foreach ($result as $entry) {
    echo 'İsim: ' . $entry['name'] . '  Eposta: ' . $entry['email'];
}
?>

Ayrıca Bakınız

  • sqlite_fetch_array() - Sonuç kümesindeki sonraki satırı bir dizi içinde döndürür

sqlite_factory
sqlite_fetch_array
SQLite İşlevleri


Sonuç kümesindeki sonraki satırı bir dizi içinde döndürür

sqlite_fetch_all
sqlite_fetch_column_types
SQLite İşlevleri
PHP Manual

sqlite_fetch_array

SQLiteResult->fetch

SQLiteUnbuffered->fetch

(PHP 5 < 5.4.0, PECL sqlite >= 1.0.0)

sqlite_fetch_array -- SQLiteResult->fetch -- SQLiteUnbuffered->fetch — Sonuç kümesindeki sonraki satırı bir dizi içinde döndürür

Açıklama

array sqlite_fetch_array ( resource $sonuç [, int $sonuç_türü = SQLITE_BOTH [, bool $ikil_çöz = true ]] )

Nesne yönelimli kullanım

array fetch ([ int $sonuç_türü = SQLITE_BOTH [, bool $ikil_çöz = true ]] )
array fetch ([ int $sonuç_türü = SQLITE_BOTH [, bool $ikil_çöz = true ]] )

sonuç tanıtıcısı ile belirtilen sonuç kümesindeki sonraki satırı bir dizi içinde döndürür. Sonuç kümesindeki sonraki konum geçersizse FALSE, aksi takdirde satır verisini bir ilişkisel dizi olarak döndürür.

Değiştirgeler

sonuç

SQLite sonuç özkaynağı. Nesne yönelimli kullanımda bu değiştirgeye gerek yoktur.

sonuç_türü

İsteğe bağlı bu değiştirgede döndürülen dizinin nasıl oluşturulacağını belirleyen bir sabit belirtilir. SQLITE_ASSOC belirtilirse alanların isimleri indis olarak kullanılır. SQLITE_NUM belirtilirse alanların sıra numaraları indis olarak kullanılır. SQLITE_BOTH için ise hem isimli hem de sayısal indisli bir dizi döner. SQLITE_BOTH bu işlev için öntanımlı değerdir.

ikil_çöz

TRUE belirtildiği takdirde (öntanımlıdır), veriye sqlite_escape_string() işleviyle ikil kodlama uygulanmışsa PHP bunu çözer. SQLite ile işlem yapan başka uygulamalarca oluşturulmuş veritabanları için bir takım ara işlemler yapmıyorsanız, normal olarak bu değeri öntanımlı haliyle bırakmanız gerekir.

Dönen Değerler

Sonuç kümesindeki sonraki konum sonuncu satırın sonrası ise FALSE, aksi takdirde satır verisini bir ilişkisel dizi olarak döndürür.

SQLITE_ASSOC ve SQLITE_BOTH sabitleri kullanılarak döndürülen sütun isimlerinin harf büyüklükleri sqlite.assoc_case php.ini yapılandırma yönergesinin değerine uygun olarak döndürülür.

Örnekler

Örnek 1 - Yordamsal kullanım örneği

<?php
$dbhandle = sqlite_open('sqlitedb');
$query = sqlite_query($dbhandle, 'SELECT name, email FROM users LIMIT 25');
while ($entry = sqlite_fetch_array($query, SQLITE_ASSOC)) {
    echo 'İsim: ' . $entry['name'] . '  Eposta: ' . $entry['email'];
}
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$db = new SQLiteDatabase('sqlitedb');

// Tamponlu sonuç kümesi
$sorgu = $db->query('SELECT name, email FROM users LIMIT 25');

// Tamponsuz sonuç kümesi
$sorgu = $db->unbufferedQuery('SELECT name, email FROM users LIMIT 25');

while ($entry = $sorgu->fetch(SQLITE_ASSOC)) {
    echo 'İsim: ' . $entry['name'] . '  Eposta: ' . $entry['email'];
}
?>

Ayrıca Bakınız

  • sqlite_array_query() - Belirtilen veritabanı üzerinde bir sorgu çalıştırıp sonucu bir dizi içinde döndürür
  • sqlite_fetch_string() - sqlite_fetch_single işlevinin takma adıdır

sqlite_fetch_all
sqlite_fetch_column_types
SQLite İşlevleri


Belli bir tablodaki sütun türlerini bir dizi içinde döndürür

sqlite_fetch_array
sqlite_fetch_object
SQLite İşlevleri
PHP Manual

sqlite_fetch_column_types

SQLiteDatabase->fetchColumnTypes

(PHP 5 < 5.4.0)

sqlite_fetch_column_types -- SQLiteDatabase->fetchColumnTypes — Belli bir tablodaki sütun türlerini bir dizi içinde döndürür

Açıklama

array sqlite_fetch_column_types ( string $tablo_adı , resource $db [, int $sonuç_türü ] )

Nesne yönelimli kullanım

array fetchColumnTypes ( string $tablo_adı [, int $sonuç_türü ] )

tablo_adı ile belirtilen tablodaki sütun türlerini bir dizi içinde döndürür.

Değiştirgeler

tablo_adı

Sorgulanacak tablonun ismi.

db

SQLite Veritabanı özkaynağı. Yordamsal kullanımda sqlite_open() işlevi tarafından döndürülür. Nesne yönelimli kullanımda bu değiştirgeye gerek yoktur.

sonuç_türü

İsteğe bağlı bu değiştirgede döndürülen dizinin nasıl oluşturulacağını belirleyen bir sabit belirtilir. SQLITE_ASSOC belirtilirse alanların isimleri indis olarak kullanılır. SQLITE_NUM belirtilirse alanların sıra numaraları indis olarak kullanılır. SQLITE_BOTH için ise hem isimli hem de sayısal indisli bir dizi döner. SQLITE_BOTH bu işlev için öntanımlı değerdir.

Dönen Değerler

Bir hata durumunda FALSE yoksa sütun türlerini bir dizi içinde döndürür.

SQLITE_ASSOC ve SQLITE_BOTH sabitleri kullanılarak döndürülen sütun isimlerinin harf büyüklükleri sqlite.assoc_case php.ini yapılandırma yönergesinin değerine uygun olarak döndürülür.

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.0 | sonuç_türü eklendi.

Örnekler

Örnek 1 - Yordamsal kullanım örneği

<?php
$db = sqlite_open('mysqlitedb');
sqlite_query($db, 'CREATE TABLE foo (bar varchar(10), arf text)');
$cols = sqlite_fetch_column_types('foo', $db, SQLITE_ASSOC);

foreach ($cols as $column => $type) {
    echo "Sütun ismi: $column  Türü: $type";
}
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$db = new SQLiteDatabase('mysqlitedb');
$db->query('CREATE TABLE foo (bar varchar(10), arf text)');
$cols = $db->fetchColumnTypes('foo', SQLITE_ASSOC);

foreach ($cols as $column => $type) {
    echo "Sütun ismi: $column  Türü: $type";
}
?>

Yukarıdaki örneğin çıktısı:

Sütun ismi: bar  Türü: VARCHAR
Sütun ismi: arf  Türü: TEXT

sqlite_fetch_array
sqlite_fetch_object
SQLite İşlevleri


Sonuç kümesindeki sonraki satırı bir nesne olarak döndürür

sqlite_fetch_column_types
sqlite_fetch_single
SQLite İşlevleri
PHP Manual

sqlite_fetch_object

SQLiteResult->fetchObject

SQLiteUnbuffered->fetchObject

(PHP 5 < 5.4.0)

sqlite_fetch_object -- SQLiteResult->fetchObject -- SQLiteUnbuffered->fetchObject — Sonuç kümesindeki sonraki satırı bir nesne olarak döndürür

Açıklama

object sqlite_fetch_object ( resource $sonuç [, string $sınf_adı [, array $ctor_params [, bool $ikil_çöz = true ]]] )

Nesne yönelimli kullanım

object fetchObject ([ string $sınf_adı [, array $ctor_params [, bool $ikil_çöz = true ]]] )
object fetchObject ([ string $sınf_adı [, array $ctor_params [, bool $ikil_çöz = true ]]] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

sqlite_fetch_column_types
sqlite_fetch_single
SQLite İşlevleri


Sonuç kümesindeki ilk sütunu bir dizge olarak döndürür

sqlite_fetch_object
sqlite_fetch_string
SQLite İşlevleri
PHP Manual

sqlite_fetch_single

SQLiteResult->fetchSingle

SQLiteUnbuffered->fetchSingle

(PHP 5 < 5.4.0, PECL sqlite >= 1.0.1)

sqlite_fetch_single -- SQLiteResult->fetchSingle -- SQLiteUnbuffered->fetchSingle — Sonuç kümesindeki ilk sütunu bir dizge olarak döndürür

Açıklama

string sqlite_fetch_single ( resource $sonuç [, bool $ikil_çöz = true ] )

Nesne yönelimli kullanım

string fetchSingle ([ bool $ikil_çöz = true ] )
string fetchSingle ([ bool $ikil_çöz = true ] )

Satırdaki ilk sütunun değerini bir dizge olarak döndürmesi dışında sqlite_fetch_array() işlevi gibidir.

Tek sütunluk satırlarla çalışıyorsanız veriyi almanın en verimli yolu budur.

Değiştirgeler

sonuç

SQLite sonuç özkaynağı. Nesne yönelimli kullanımda bu değiştirgeye gerek yoktur.

ikil_çöz

TRUE belirtildiği takdirde (öntanımlıdır), veriye sqlite_escape_string() işleviyle ikil kodlama uygulanmışsa PHP bunu çözer. SQLite ile işlem yapan başka uygulamalarca oluşturulmuş veritabanları için bir takım ara işlemler yapmıyorsanız, normal olarak bu değeri öntanımlı haliyle bırakmanız gerekir.

Dönen Değerler

İlk sütunun değerini bir dizge olarak döndürür.

Örnekler

Örnek 1 - sqlite_fetch_single() örneği

<?php
if ($dbhandle = sqlite_open('mysqlitedb', 0666, $sqliteerror)) {

    $sql = "SELECT id FROM sometable WHERE id = 42";
    $res = sqlite_query($dbhandle, $sql);

    if (sqlite_num_rows($res) > 0) {
        echo sqlite_fetch_single($res); // 42
    }

    sqlite_close($dbhandle);
}
?>

Ayrıca Bakınız

  • sqlite_fetch_array() - Sonuç kümesindeki sonraki satırı bir dizi içinde döndürür

sqlite_fetch_object
sqlite_fetch_string
SQLite İşlevleri


sqlite_fetch_single işlevinin takma adıdır

sqlite_fetch_single
sqlite_field_name
SQLite İşlevleri
PHP Manual

sqlite_fetch_string

(PHP 5 < 5.4.0, PECL sqlite >= 1.0.0)

sqlite_fetch_string — sqlite_fetch_single() işlevinin takma adıdır

Açıklama

Bu işlev, sqlite_fetch_single() işlevinin takma adıdır.

sqlite_fetch_single
sqlite_field_name
SQLite İşlevleri


Sonuç kümesindeki belli bir alanın ismini döndürür

sqlite_fetch_string
sqlite_has_more
SQLite İşlevleri
PHP Manual

sqlite_field_name

SQLiteResult->fieldName

SQLiteUnbuffered->fieldName

(PHP 5 < 5.4.0, PECL sqlite >= 1.0.0)

sqlite_field_name -- SQLiteResult->fieldName -- SQLiteUnbuffered->fieldName — Sonuç kümesindeki belli bir alanın ismini döndürür

Açıklama

string sqlite_field_name ( resource $sonuç , int $alan_indisi )

Nesne yönelimli kullanım

string fieldName ( int $alan_indisi )
string fieldName ( int $alan_indisi )

sonuç ile belirtilen sonuç kümesinden, sütun numarası alan_indisi ile belirtilen alanın ismini döndürür.

Değiştirgeler

sonuç

SQLite sonuç özkaynağı. Nesne yönelimli kullanımda bu değiştirgeye gerek yoktur.

alan_indisi

Sonuç kümesindeki sütunun sıra numarası.

Dönen Değerler

Bir hata oluşursa FALSE yoksa alan ismini bir dizge olarak döndürür.

SQLITE_ASSOC ve SQLITE_BOTH sabitleri kullanılarak döndürülen sütun isimlerinin harf büyüklükleri sqlite.assoc_case php.ini yapılandırma yönergesinin değerine uygun olarak döndürülür.

sqlite_fetch_string
sqlite_has_more
SQLite İşlevleri


Sonuç kümesinde başka satır kaldı mı diye bakar

sqlite_field_name
sqlite_has_prev
SQLite İşlevleri
PHP Manual

sqlite_has_more

(PHP 5 < 5.4.0, PECL sqlite >= 1.0.0)

sqlite_has_more — Sonuç kümesinde başka satır kaldı mı diye bakar

Açıklama

bool sqlite_has_more ( resource $sonuç )

Sonuç kümesinde başka satır kaldı mı diye bakar.

Değiştirgeler

sonuç

SQLite sonuç özkaynağı.

Dönen Değerler

Başka satır varsa TRUE yoksa FALSE döner.

Ayrıca Bakınız

  • sqlite_num_rows() - Tamponlu bir sonuç kümesindeki satır sayısını döndürür
  • sqlite_changes() - En son SQL deyiminin değiştirdiği satır sayısını döndürür

sqlite_field_name
sqlite_has_prev
SQLite İşlevleri


Geçerli satırın öncesinde satır var mı diye bakar

sqlite_has_more
sqlite_key
SQLite İşlevleri
PHP Manual

sqlite_has_prev

SQLiteResult->hasPrev

(PHP 5 < 5.4.0)

sqlite_has_prev -- SQLiteResult->hasPrev — Geçerli satırın öncesinde satır var mı diye bakar

Açıklama

bool sqlite_has_prev ( resource $sonuç )

Nesne yönelimli kullanım

bool hasPrev ( void )

Sonuç kümesindeki geçerli satırın öncesinde başka satır var mı diye bakar.

Değiştirgeler

sonuç

SQLite sonuç özkaynağı. Nesne yönelimli kullanımda bu değiştirgeye gerek yoktur.

Bilginize:

Bu işlev tamponsuz sonuç tanıtıcıları ile kullanılamaz.

Dönen Değerler

Geçerli satırın öncesinde bir satır varsa TRUE yoksa FALSE döner.

Ayrıca Bakınız

  • sqlite_prev() - Sonuç kümesindeki önceki satıra gider
  • sqlite_has_more() - Sonuç kümesinde başka satır kaldı mı diye bakar
  • sqlite_num_rows() - Tamponlu bir sonuç kümesindeki satır sayısını döndürür

sqlite_has_more
sqlite_key
SQLite İşlevleri


Geçerli satırın indisini döndürür

sqlite_has_prev
sqlite_last_error
SQLite İşlevleri
PHP Manual

sqlite_key

SQLiteResult->key

(PHP 5 >= 5.1.0 and < 5.4.0)

sqlite_key -- SQLiteResult->key — Geçerli satırın indisini döndürür

Açıklama

int sqlite_key ( resource $sonuç )

Nesne yönelimli kullanım

int key ( void )

Tamponlu sonuç kümesindeki geçerli satırın satır indisini döndürür.

Değiştirgeler

sonuç

SQLite sonuç özkaynağı. Nesne yönelimli kullanımda bu değiştirgeye gerek yoktur.

Bilginize:

Bu işlev tamponsuz sonuç tanıtıcıları ile kullanılamaz.

Dönen Değerler

Satır indisini bir tamsayı olarak döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.4 | PHP 5.0.4 öncesinde, bu işlev sadece bir SQLiteResult yöntemi olarak çağrılabiliyordu. Yordamsal kullanımı mevcut değildi.

Ayrıca Bakınız

  • sqlite_next() - Sonraki satıra gider
  • sqlite_current() - Sonuç kümesindeki geçerli satırı bir dizi içinde döndürür
  • sqlite_rewind() - İlk satırı geçerli satır yapar

sqlite_has_prev
sqlite_last_error
SQLite İşlevleri


Veritabanındaki son hatanın kodunu döndürür

sqlite_key
sqlite_last_insert_rowid
SQLite İşlevleri
PHP Manual

sqlite_last_error

SQLiteDatabase->lastError

(PHP 5 < 5.4.0, PECL sqlite >= 1.0.0)

sqlite_last_error -- SQLiteDatabase->lastError — Veritabanındaki son hatanın kodunu döndürür

Açıklama

int sqlite_last_error ( resource $db )

Nesne yönelimli kullanım

int lastError ( void )

db üzerinde uygulanan son işlemde oluşan hatanın numarasını döndürür. Bir hata oluşmamışsa 0 döner. Hatanın iletisini sqlite_error_string() işleviyle alabilirsiniz.

Değiştirgeler

db

SQLite Veritabanı özkaynağı. Yordamsal kullanımda sqlite_open() işlevi tarafından döndürülür. Nesne yönelimli kullanımda bu değiştirgeye gerek yoktur.

Dönen Değerler

Oluşmuş bir hata yoksa 0, varsa hatanın numarasını döndürür.

Ayrıca Bakınız

  • sqlite_error_string() - Bir hata kodu ile ilgili açıklamayı döndürür

sqlite_key
sqlite_last_insert_rowid
SQLite İşlevleri


Son yerleştirilen satırın satır kimliğini döndürür

sqlite_last_error
sqlite_libencoding
SQLite İşlevleri
PHP Manual

sqlite_last_insert_rowid

SQLiteDatabase->lastInsertRowid

(PHP 5 < 5.4.0, PECL sqlite >= 1.0.0)

sqlite_last_insert_rowid -- SQLiteDatabase->lastInsertRowid — Son yerleştirilen satırın satır kimliğini döndürür

Açıklama

int sqlite_last_insert_rowid ( resource $db )

Nesne yönelimli kullanım

int lastInsertRowid ( void )

db veritabanına son yerleştirilen satır oluşturulabilmişse ve özdevinimli artan bir alana sahipse satırın satır kimliğini döndürür.

İpucu

Özdevinimli artan alanları SQLite'da oluşturabilmek için tablo şemanızda bu alanları INTEGER PRIMARY KEY olarak bildirmeniz gerekir.

Değiştirgeler

db

SQLite Veritabanı özkaynağı. Yordamsal kullanımda sqlite_open() işlevi tarafından döndürülür. Nesne yönelimli kullanımda bu değiştirgeye gerek yoktur.

Dönen Değerler

Satır kimliğini bir tamsayı olarak döndürür.

sqlite_last_error
sqlite_libencoding
SQLite İşlevleri


İlintili SQLite kütüphanesinin karakter kodlamasını döndürür

sqlite_last_insert_rowid
sqlite_libversion
SQLite İşlevleri
PHP Manual

sqlite_libencoding

(PHP 5 < 5.4.0, PECL sqlite >= 1.0.0)

sqlite_libencoding — İlintili SQLite kütüphanesinin karakter kodlamasını döndürür

Açıklama

string sqlite_libencoding ( void )

SQLite kütüphanesi ya ISO-8859-1 ya da UTF-8 uyumlu kipte kodlanır. Bu işlev sayesinde kütüphanenize hangi kodlama şemasını kullanacağını belirtebilirsiniz.

Uyarı

Öntanımlı PHP dağıtımı libsqlite dosyasını ISO-8859-1 kodlamasını kullanacak şeklide derler. Ancak, bu yanıltıcıdır; dizge sıralama ve karşılaştırma işlevlerinde ISO-8859-1'i değil yerel ayarlarınızı kullanır. Bu bakımdan, ISO-8859-1 ayarını 8 bitlik bir kodlama olarak ele almalısınız.

UTF-8 destekli olarak derlendiğinde çok baytlı karakterlerin kodlamasında ve kod çözümünde UTF-8 kullanılsa da bu yeterince gerçeklenememiş olup bazı karşılaştırma işlemleri hala doğru olarak yapılamamaktadır.

Uyarı

UTF-8 desteği ile derlenmiş SQLite kütüphanesini kullanan PHP'li bir HTTP sunucu yapılandırmasını kullanmanız önerilmez. Yoksa, UTF-8 kodlama ile ilgili bir sorun saptandığında libsqlite süreci çıkar.

Dönen Değerler

Kütüphanenin karakter kodlamasını bir dizge olarak döndürür.

Ayrıca Bakınız

  • sqlite_libversion() - İlintili SQLite kütüphanesinin sürüm numarasını döndürür

sqlite_last_insert_rowid
sqlite_libversion
SQLite İşlevleri


İlintili SQLite kütüphanesinin sürüm numarasını döndürür

sqlite_libencoding
sqlite_next
SQLite İşlevleri
PHP Manual

sqlite_libversion

(PHP 5 < 5.4.0, PECL sqlite >= 1.0.0)

sqlite_libversion — İlintili SQLite kütüphanesinin sürüm numarasını döndürür

Açıklama

string sqlite_libversion ( void )

İlintili SQLite kütüphanesinin sürüm numarasını döndürür.

Dönen Değerler

sürüm numarasını bir dizge olarak döndürür.

Ayrıca Bakınız

  • sqlite_libencoding() - İlintili SQLite kütüphanesinin karakter kodlamasını döndürür

sqlite_libencoding
sqlite_next
SQLite İşlevleri


Sonraki satıra gider

sqlite_libversion
sqlite_num_fields
SQLite İşlevleri
PHP Manual

sqlite_next

SQLiteResult->next

SQLiteUnbuffered->next

(PHP 5 < 5.4.0, PECL sqlite >= 1.0.0)

sqlite_next -- SQLiteResult->next -- SQLiteUnbuffered->next — Sonraki satıra gider

Açıklama

bool sqlite_next ( resource $sonuç )

Nesne yönelimli kullanım

bool next ( void )
bool next ( void )

sonuç kümesindeki sonraki satırı geçerli satır haline getirir.

Değiştirgeler

sonuç

SQLite sonuç özkaynağı. Nesne yönelimli kullanımda bu değiştirgeye gerek yoktur.

Dönen Değerler

Geçerli satırın sonrasında başka satır yoksa FALSE varsa TRUE döner.

Ayrıca Bakınız

  • sqlite_seek() - Tamponlu bir sonuç kümesinde belli bir satır numarasına gider
  • sqlite_current() - Sonuç kümesindeki geçerli satırı bir dizi içinde döndürür
  • sqlite_rewind() - İlk satırı geçerli satır yapar

sqlite_libversion
sqlite_num_fields
SQLite İşlevleri


Sonuç kümesindeki alan sayısını döndürür

sqlite_next
sqlite_num_rows
SQLite İşlevleri
PHP Manual

sqlite_num_fields

SQLiteResult->numFields

SQLiteUnbuffered->numFields

(PHP 5 < 5.4.0, PECL sqlite >= 1.0.0)

sqlite_num_fields -- SQLiteResult->numFields -- SQLiteUnbuffered->numFields — Sonuç kümesindeki alan sayısını döndürür

Açıklama

int sqlite_num_fields ( resource $sonuç )

Nesne yönelimli kullanım

int numFields ( void )
int numFields ( void )

sonuç kümesindeki alan sayısını döndürür.

Değiştirgeler

sonuç

SQLite sonuç özkaynağı. Nesne yönelimli kullanımda bu değiştirgeye gerek yoktur.

Dönen Değerler

Alan sayısını bir tamsayı olarak döndürür.

Ayrıca Bakınız

  • sqlite_changes() - En son SQL deyiminin değiştirdiği satır sayısını döndürür
  • sqlite_num_rows() - Tamponlu bir sonuç kümesindeki satır sayısını döndürür

sqlite_next
sqlite_num_rows
SQLite İşlevleri


Tamponlu bir sonuç kümesindeki satır sayısını döndürür

sqlite_num_fields
sqlite_open
SQLite İşlevleri
PHP Manual

sqlite_num_rows

SQLiteResult->numRows

(PHP 5 < 5.4.0, PECL sqlite >= 1.0.0)

sqlite_num_rows -- SQLiteResult->numRows — Tamponlu bir sonuç kümesindeki satır sayısını döndürür

Açıklama

int sqlite_num_rows ( resource $sonuç )

Nesne yönelimli kullanım

int numRows ( void )

Tamponlu sonuç kümesindeki satır sayısını döndürür

Değiştirgeler

sonuç

SQLite sonuç özkaynağı. Nesne yönelimli kullanımda bu değiştirgeye gerek yoktur.

Bilginize:

Bu işlev tamponsuz sonuç tanıtıcıları ile kullanılamaz.

Dönen Değerler

Satır sayısını bir tamsayı olarak döndürür.

Örnekler

Örnek 1 - Yordamsal kullanım örneği

<?php
$db = sqlite_open('mysqlitedb');
$result = sqlite_query($db, "SELECT * FROM mytable WHERE name='John Doe'");
$rows = sqlite_num_rows($result);

echo "Satır sayısı: $rows";
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$db = new SQLiteDatabase('mysqlitedb');
$result = $db->query("SELECT * FROM mytable WHERE name='John Doe'");
$rows = $result->numRows();

echo "Satır sayısı: $rows";
?>

Ayrıca Bakınız

  • sqlite_changes() - En son SQL deyiminin değiştirdiği satır sayısını döndürür
  • sqlite_query() - Belirtilen veritabanında bir sorgu çalıştırıp bir sonuç tanıtıcısı döndürür
  • sqlite_num_fields() - Sonuç kümesindeki alan sayısını döndürür

sqlite_num_fields
sqlite_open
SQLite İşlevleri


Bir SQLite veritabanı için bir tanıtıcı açar, veritabanı mevcut değilse oluşturur

sqlite_num_rows
sqlite_popen
SQLite İşlevleri
PHP Manual

sqlite_open

(PHP 5 < 5.4.0, PECL sqlite >= 1.0.0)

sqlite_open — Bir SQLite veritabanı için bir tanıtıcı açar, veritabanı mevcut değilse oluşturur

Açıklama

resource sqlite_open ( string $dosya [, int $kip = 0666 [, string &$hata_iletisi ]] )

Nesne yönelimli kullanım (kurucu):

__construct ( string $dosya [, int $kip = 0666 [, string &$hata_iletisi ]] )

Bir SQLite veritabanı dosyası için bir tanıtıcı açar, veritabanı mevcut değilse oluşturur.

Değiştirgeler

dosya

SQLite veritabanı dosyasının ismi. Böyle bir dosya yoksa SQLite oluşturmaya çalışır. Dosyaya veri yazılacaksa, veritabanı şeması değiştirilecekse veya mevcut olmayan veritabanı oluşturulacaksa PHP'nin dosya yazma izninin olması gerekir.

kip

Dosyaya erişim kipi. Hali hazırda bu değiştirge SQLite kütüphanesi tarafından yok sayılmaktadır. 0666 sekizlik değeri öntanımlı olup önerilen değerdir.

hata_iletisi

Bir hata oluştuğunda veritabanının açılamama sebebini açıklayan ileti bu değiştirgeye konur.

Dönen Değerler

Bir hata durumunda FALSE yoksa bir özkaynak (veritabanı tanıtıcısı) döner.

Örnekler

Örnek 1 - sqlite_open() örneği

<?php
if ($db = sqlite_open('mysqlitedb', 0666, $sqliteerror)) {
    sqlite_query($db, 'CREATE TABLE foo (bar varchar(10))');
    sqlite_query($db, "INSERT INTO foo VALUES ('fnord')");
    $result = sqlite_query($db, 'select bar from foo');
    var_dump(sqlite_fetch_array($result));
} else {
    die($sqliteerror);
}
?>

Notlar

İpucu

Unix platformlarında, SQLite fork() sistem çağrısını kullanan betiklere duyarlıdır. Böyle bir betiğiniz varsa çatallama öncesi tanıtıcıyı kapatıp çocuk ve ebeveyn süreçte yeniden açmanız önerilir. bu konuda daha ayrıntılı bilgi edinmek için » SQLite kütüphanesinin C dili arayüzü belgesinin Multi-Threading And SQLite (Çok Evrelilik ve SQLite) bölümüne bakınız.

İpucu

NFS bölümlerinde bulunan SQLite veritabanları ile çalışmanız önerilmez. NFS kilitlenmesi ile ünlü olduğundan kendinizi veritabanına erişemez durumda bulabilirsiniz. Dosya erişilebilir olsa bile kilitlenme davranışının bir açıklaması olmayabilir.

Bilginize: SQLite kütüphanesinin 2.8.2 sürümünden itibaren, bilgisayarın sadece belleğinde varolabilen bir veritabanı oluşturmak için dosya değiştirgesinde :memory: dizgesini belirtebilirsiniz. Süreç sonlandığında bellekteki veritabanı yok edildiğinden geçici işlemler için oldukça yararlıdır. Ayrıca, başka veritabanlarını yüklemek ve bunlar arasında veri hareketleri ve sorguları yapmak için ATTACH DATABASE SQL deyiminin kullanıldığı durumlarda da yararlıdır.

Bilginize: SQLite safe_mode ve open_basedir'a duyarlıdır.

Ayrıca Bakınız

  • sqlite_popen() - Bir SQLite veritabanı için kalıcı bir tanıtıcı açar, veritabanı mevcut değilse oluşturur
  • sqlite_close() - Açık bir SQLite veritabanını kapatır
  • sqlite_factory() - Bir SQLite veritabanı açıp bir SQLiteDatabase nesnesi döndürür

sqlite_num_rows
sqlite_popen
SQLite İşlevleri


Bir SQLite veritabanı için kalıcı bir tanıtıcı açar, veritabanı mevcut değilse oluşturur

sqlite_open
sqlite_prev
SQLite İşlevleri
PHP Manual

sqlite_popen

(PHP 5 < 5.4.0, PECL sqlite >= 1.0.0)

sqlite_popen — Bir SQLite veritabanı için kalıcı bir tanıtıcı açar, veritabanı mevcut değilse oluşturur

Açıklama

resource sqlite_popen ( string $dosya [, int $kip = 0666 [, string &$hata_iletisi ]] )

PHP'nin kalıcı özkaynak mekanizmasını kullanması dışında sqlite_open() işlevine eşdeğerdir. Değiştirgelerin anlamları için sqlite_open() işlevinin açıklamasına bakınız.

sqlite_popen() önce belirtilen dosya için açılmış kalıcı bir tanıtıcı olup olmadığına bakar. Varsa eski tanıtıcıyı döndürür, yoksa yeni bir tanıtıcı açıp yenisini döndürür.

Bu yaklaşım sayesinde, HTTP sunucusunun SAPI'si (CGI veya CLI değil) tarafından kalıcı bağlantı üzerinden sunulan her sayfada veritabanının ve indisleme şemasının yeniden okunması maliyetinden kurtulursunuz.

Bilginize: Bir kalıcı tanıtıcı kullanırken aynı anda başka bir süreç veritabanını güncellerse (örneğin crontab üzerinden) veya başka bir süreç üzerine yazarak veritabanını yeniden oluşturursa ( bağın yerini değiştirerek, veritabanını yeniden oluşturarak veya eski sürümü yenisi ile değiştirerek) veritabanının eski sürümüne ait kalıcı tanıtıcı beklenmedik davranışlar gösterebilir. Bu gibi durumlarla karşılaşmamak için aynı veritabanı dosyasını açan artalan sürecinin güncellemelerini hareket (transaction) olarak yapmasını sağlamalısınız.

Değiştirgeler

dosya

SQLite veritabanı dosyasının ismi. Böyle bir dosya yoksa SQLite oluşturmaya çalışır. Dosyaya veri yazılacaksa, veritabanı şeması değiştirilecekse veya mevcut olmayan veritabanı oluşturulacaksa PHP'nin dosya yazma izninin olması gerekir.

kip

Dosyaya erişim kipi. Hali hazırda bu değiştirge SQLite kütüphanesi tarafından yok sayılmaktadır. 0666 sekizlik değeri öntanımlı olup önerilen değerdir.

hata_iletisi

Bir hata oluştuğunda veritabanının açılamama sebebini açıklayan ileti bu değiştirgeye konur.

Dönen Değerler

Bir hata durumunda FALSE yoksa bir özkaynak (veritabanı tanıtıcısı) döner.

Ayrıca Bakınız

  • sqlite_open() - Bir SQLite veritabanı için bir tanıtıcı açar, veritabanı mevcut değilse oluşturur
  • sqlite_close() - Açık bir SQLite veritabanını kapatır
  • sqlite_factory() - Bir SQLite veritabanı açıp bir SQLiteDatabase nesnesi döndürür

sqlite_open
sqlite_prev
SQLite İşlevleri


Sonuç kümesindeki önceki satıra gider

sqlite_popen
sqlite_query
SQLite İşlevleri
PHP Manual

sqlite_prev

SQLiteResult->prev

(PHP 5 < 5.4.0)

sqlite_prev -- SQLiteResult->prev — Sonuç kümesindeki önceki satıra gider

Açıklama

bool sqlite_prev ( resource $sonuç )

Nesne yönelimli kullanım

bool prev ( void )

sonuç kümesindeki önceki satırı geçerli satır haline getirir.

Değiştirgeler

sonuç

SQLite sonuç özkaynağı. Nesne yönelimli kullanımda bu değiştirgeye gerek yoktur.

Bilginize:

Bu işlev tamponsuz sonuç tanıtıcıları ile kullanılamaz.

Dönen Değerler

Geçerli satırın öncesinde başka satır yoksa FALSE varsa TRUE döner.

Ayrıca Bakınız

  • sqlite_has_prev() - Geçerli satırın öncesinde satır var mı diye bakar
  • sqlite_rewind() - İlk satırı geçerli satır yapar
  • sqlite_next() - Sonraki satıra gider

sqlite_popen
sqlite_query
SQLite İşlevleri


Belirtilen veritabanında bir sorgu çalıştırıp bir sonuç tanıtıcısı döndürür

sqlite_prev
sqlite_rewind
SQLite İşlevleri
PHP Manual

sqlite_query

SQLiteDatabase->sorgu

(PHP 5 < 5.4.0, PECL sqlite >= 1.0.0)

sqlite_query -- SQLiteDatabase->sorgu — Belirtilen veritabanında bir sorgu çalıştırıp bir sonuç tanıtıcısı döndürür

Açıklama

resource sqlite_query ( resource $db , string $sorgu [, int $sonuç_türü [, string &$hata_iletisi ]] )
resource sqlite_query ( string $sorgu , resource $db [, int $sonuç_türü [, string &$hata_iletisi ]] )

Nesne yönelimli kullanım

SQLiteResult sorgu ( string $sorgu [, int $sonuç_türü [, string &$hata_iletisi ]] )

Belirtilen veritabanında (db) sorgu ile belirtilen SQL deyimini çalıştırıp elde edilen sonuç kümesi için bir tanıtıcı döndürür.

Değiştirgeler

db

SQLite Veritabanı özkaynağı. Yordamsal kullanımda sqlite_open() işlevi tarafından döndürülür. Nesne yönelimli kullanımda bu değiştirgeye gerek yoktur.

sorgu

Çalıştırılacak sorgu.

Sorgu içindeki verinin düzgün olarak öncelenmiş olması gerekir.

sonuç_türü

İsteğe bağlı bu değiştirgede döndürülen dizinin nasıl oluşturulacağını belirleyen bir sabit belirtilir. SQLITE_ASSOC belirtilirse alanların isimleri indis olarak kullanılır. SQLITE_NUM belirtilirse alanların sıra numaraları indis olarak kullanılır. SQLITE_BOTH için ise hem isimli hem de sayısal indisli bir dizi döner. SQLITE_BOTH bu işlev için öntanımlı değerdir.

hata_iletisi

Bir hata oluştuğunda hata iletisi bu değiştirgeye konur. SQL sözdizimi hataları sqlite_last_error() işlevi ile alınamadığından bu değiştirge özellikle önemlidir.

Bilginize: Diğer veritabanı eklentileri (MySQL gibi) ile uyumluluk için iki ayrı sözdizimi desteklenmektedir. Genelde tercih edilen sözdizimi db değiştirgesinin ilk değiştirge olarak kullanıldığı ilk sözdizimidir.

Dönen Değerler

Hata durumunda FALSE yoksa bir sonuç tanıtıcısı döndürür. Çok sayıda satır döndüren sorgular için sonuç tanıtıcısı sqlite_fetch_array() ve sqlite_seek() gibi işlevlerde kullanılabilir.

Sorgu türünden bağımsız olarak, bir sorgu başarısız olursa bu işlev FALSE döndürür.

sqlite_query() işlevi, üzerinde arama yapılabilen, tamponlu bir sonuç tanıtıcısı döndürür. Satırlara rasgele erişimin gerekli olduğu durumlarda nispeten küçük sonuç kümeleri için oldukça elverişlidir. Tamponlu sonuç için bellekte bir yer ayrılır ve bu tampon gerekli satırlarla doldurulana kadar işlev dönmez. Veriye rasgele değil de sırayla erişmenin yeterli olduğu durumlarda sqlite_unbuffered_query() işlevi daha verimlidir.

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.0 | hata_iletisi değiştirgesi eklendi.

Notlar

Uyarı

SQLite, noktalı virgüllerle ayrılmış birden fazla sorguyu çalıştırabilir. Bu sayede, bir dosyadan yüklenen SQL betiklerini çalıştırabilirsiniz. Ancak, bu sadece işlev sonucu kullanılmayacaksa işe yarar, kullanılacaksa tek bir SQL deyimi çalıştırılmalıdır. Çok sayıda SQL deyimini çalıştırmak için daima sqlite_exec() işlevini kullanın.

Çok sayıda sorgu çalıştırıldığı durumda bir hata oluşmuşsa FALSE, başarı durumunda ise TRUE döner. Tek SQL deyimlik sorgularda ise başarı durumunda sonuç tanıtıcısı döner.

Ayrıca Bakınız

  • sqlite_unbuffered_query() - Sonuçların alınıp bir tampona konmadığı bir sorgu çalıştırır
  • sqlite_array_query() - Belirtilen veritabanı üzerinde bir sorgu çalıştırıp sonucu bir dizi içinde döndürür

sqlite_prev
sqlite_rewind
SQLite İşlevleri


İlk satırı geçerli satır yapar

sqlite_query
sqlite_seek
SQLite İşlevleri
PHP Manual

sqlite_rewind

SQLiteResult->rewind

(PHP 5 < 5.4.0, PECL sqlite >= 1.0.0)

sqlite_rewind -- SQLiteResult->rewind — İlk satırı geçerli satır yapar

Açıklama

bool sqlite_rewind ( resource $sonuç )

Nesne yönelimli kullanım

bool rewind ( void )

Sonuç kümesindeki ilk satırı tekrar geçerli satır haline getirir.

Değiştirgeler

sonuç

SQLite sonuç özkaynağı. Nesne yönelimli kullanımda bu değiştirgeye gerek yoktur.

Bilginize:

Bu işlev tamponsuz sonuç tanıtıcıları ile kullanılamaz.

Dönen Değerler

Sonuç kümesinde hiç satır yoksa FALSE aksi takdirde TRUE döner.

Ayrıca Bakınız

  • sqlite_next() - Sonraki satıra gider
  • sqlite_current() - Sonuç kümesindeki geçerli satırı bir dizi içinde döndürür
  • sqlite_seek() - Tamponlu bir sonuç kümesinde belli bir satır numarasına gider

sqlite_query
sqlite_seek
SQLite İşlevleri


Tamponlu bir sonuç kümesinde belli bir satır numarasına gider

sqlite_rewind
sqlite_single_query
SQLite İşlevleri
PHP Manual

sqlite_seek

SQLiteResult->seek

(PHP 5 < 5.4.0, PECL sqlite >= 1.0.0)

sqlite_seek -- SQLiteResult->seek — Tamponlu bir sonuç kümesinde belli bir satır numarasına gider

Açıklama

bool sqlite_seek ( resource $sonuç , int $satırnum )

Nesne yönelimli kullanım

bool seek ( int $satırnum )

sonuç kümesindeki satırnum satırını geçerli satır haline getirir.

Değiştirgeler

sonuç

SQLite sonuç özkaynağı. Nesne yönelimli kullanımda bu değiştirgeye gerek yoktur.

Bilginize:

Bu işlev tamponsuz sonuç tanıtıcıları ile kullanılamaz.

satırnum

Aranacak satır numarası. Satır numaraları 0'dan başlar.

Bilginize:

Bu işlev tamponsuz sonuç tanıtıcıları ile kullanılamaz.

Dönen Değerler

Belirtilen satır yoksa FALSE varsa TRUE döner.

Ayrıca Bakınız

  • sqlite_next() - Sonraki satıra gider
  • sqlite_current() - Sonuç kümesindeki geçerli satırı bir dizi içinde döndürür
  • sqlite_rewind() - İlk satırı geçerli satır yapar

sqlite_rewind
sqlite_single_query
SQLite İşlevleri


Bir sorgu çalıştırıp sonucu tek bir sütunluk veya tek bir satırlık bir dizi olarak döndürür

sqlite_seek
sqlite_udf_decode_binary
SQLite İşlevleri
PHP Manual

sqlite_single_query

SQLiteDatabase->singleQuery

(PHP 5 < 5.4.0, PECL sqlite >= 1.0.1)

sqlite_single_query -- SQLiteDatabase->singleQuery — Bir sorgu çalıştırıp sonucu tek bir sütunluk veya tek bir satırlık bir dizi olarak döndürür

Açıklama

array sqlite_single_query ( resource $db , string $sorgu [, bool $sadece_ilk_satır [, bool $ikil_çöz ]] )

Nesne yönelimli kullanım

array singleQuery ( string $sorgu [, bool $sadece_ilk_satır [, bool $ikil_çöz ]] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

sqlite_seek
sqlite_udf_decode_binary
SQLite İşlevleri


Kullanıcı tanımlı bir işleve değiştirge olarak aktarılacak ikil veriyi çözümler

sqlite_single_query
sqlite_udf_encode_binary
SQLite İşlevleri
PHP Manual

sqlite_udf_decode_binary

(PHP 5 < 5.4.0, PECL sqlite >= 1.0.0)

sqlite_udf_decode_binary — Kullanıcı tanımlı bir işleve değiştirge olarak aktarılacak ikil veriyi çözümler

Açıklama

string sqlite_udf_decode_binary ( string $veri )

Kullanıcı tanımlı bir işleve (UDF) değiştirge olarak aktarılacak ikil veriyi çözümler.

İkil verilerin güvenli hale getirilmesi için PHP devreye sokulmuşsa ikil içeriğin tekrar işe yarar hale gelmesi için bu veriyi kullanıcı tanımlı işlevinize aktarırken bu işlevle tekrar eski haline getirmeniz gerekir.

PHP başarımı etkilediğinden bu kodlama ve kod çözme işlemlerini özdevinimli olarak uygulamaz.

Değiştirgeler

veri

sqlite_udf_encode_binary() veya sqlite_escape_string() tarafından kodlanmış ikil veri.

Dönen Değerler

Kodu çözülmüş dizge.

Örnekler

Örnek 1 - İkil olarak güvenli azami_uzunluk işlevi örneği

<?php
$data = array(
   'one',
   'two',
   'three',
   'four',
   'five',
   'six',
   'seven',
   'eight',
   'nine',
   'ten',
   );
$db = sqlite_open(':memory:');
sqlite_query($db, "CREATE TABLE strings(a)");
foreach ($data as $str) {
    $str = sqlite_escape_string($str);
    sqlite_query($db, "INSERT INTO strings VALUES ('$str')");
}

function azami_uzunluk_sek(&$baglam, $dizge)
{
    $dizge = sqlite_udf_decode_binary($string);
    if (strlen($dizge) > $baglam) {
        $baglam = strlen($dizge);
    }
}

function azami_uzunluk_son(&$baglam)
{
    return $baglam;
}

sqlite_create_aggregate($db, 'azami_uzunluk',
        'azami_uzunluk_sek', 'azami_uzunluk_son');

var_dump(sqlite_array_query($db, 'SELECT max_len(a) from strings'));

?>

Ayrıca Bakınız

  • sqlite_udf_encode_binary() - Bir kullanıcı tanımlı işlevden dönecek ikil veriyi döndürmeden önce kodlamak için kullanılır
  • sqlite_create_function() - SQL deyimlerinde kullanmak üzere bir kullanıcı tanımlı işlevi kayda geçirir
  • sqlite_create_aggregate() - SQL deyimlerinde kullanmak üzere toparlayıcı bir kullanıcı tanımlı işlevi kayda geçirir

sqlite_single_query
sqlite_udf_encode_binary
SQLite İşlevleri


Bir kullanıcı tanımlı işlevden dönecek ikil veriyi döndürmeden önce kodlamak için kullanılır

sqlite_udf_decode_binary
sqlite_unbuffered_query
SQLite İşlevleri
PHP Manual

sqlite_udf_encode_binary

(PHP 5 < 5.4.0, PECL sqlite >= 1.0.0)

sqlite_udf_encode_binary — Bir kullanıcı tanımlı işlevden dönecek ikil veriyi döndürmeden önce kodlamak için kullanılır

Açıklama

string sqlite_udf_encode_binary ( string $veri )

Eklentinin arayüzü olduğu libsqlite kütüphanesi ikil veriler için güvenli olmadığından bir kullanıcı tanımlı işlevde (UDF) sorgulardan dönen veriyi güvenli duruma getirmek için sqlite_udf_encode_binary() işlevi veri ile belirtilen veriye ikil kodlama uygular.

Verinizin ikil olarak güvensiz olma şansı varsa (örneğin, sonunda değil de ortasında bir NUL bayt bulunma şansı varsa veya ilk karakteri 0x01 karakteri olabiliyorsa) kullanıcı tanımlı işlevinizde veriyi döndürmeden önce bu işlevi çağırmalısınız.

PHP başarımı etkilediğinden bu kodlama ve kod çözme işlemlerini özdevinimli olarak uygulamaz.

Bilginize:

Kullanıcı tanımlı işlevinizden dönen dizgeleri önceletmek için sqlite_escape_string() işlevini değil sqlite_udf_encode_binary() işlevini kullanın yoksa verinize çifte önceleme uygulanmış olur!

Değiştirgeler

veri

Kodlanacak dizge.

Dönen Değerler

Kodlanmış bir dizge döner.

Ayrıca Bakınız

  • sqlite_udf_decode_binary() - Kullanıcı tanımlı bir işleve değiştirge olarak aktarılacak ikil veriyi çözümler
  • sqlite_escape_string() - Bir sorgu değiştirgesi olarak kullanmak üzere bir dizgeyi önceler
  • sqlite_create_function() - SQL deyimlerinde kullanmak üzere bir kullanıcı tanımlı işlevi kayda geçirir
  • sqlite_create_aggregate() - SQL deyimlerinde kullanmak üzere toparlayıcı bir kullanıcı tanımlı işlevi kayda geçirir

sqlite_udf_decode_binary
sqlite_unbuffered_query
SQLite İşlevleri


Sonuçların alınıp bir tampona konmadığı bir sorgu çalıştırır

sqlite_udf_encode_binary
sqlite_valid
SQLite İşlevleri
PHP Manual

sqlite_unbuffered_query

SQLiteDatabase->unbufferedQuery

(PHP 5 < 5.4.0, PECL sqlite >= 1.0.0)

sqlite_unbuffered_query -- SQLiteDatabase->unbufferedQuery — Sonuçların alınıp bir tampona konmadığı bir sorgu çalıştırır

Açıklama

resource sqlite_unbuffered_query ( resource $db , string $sorgu [, int $sonuç_türü [, string &$hata_iletisi ]] )
resource sqlite_unbuffered_query ( string $sorgu , resource $db [, int $sonuç_türü [, string &$hata_iletisi ]] )

Nesne yönelimli kullanım

SQLiteUnbuffered unbufferedQuery ( string $sorgu [, int $sonuç_türü [, string &$hata_iletisi ]] )

Sıralı ve sadece ileri yönde ilerlenebilen, her seferinde tek bir satırın okunabildiği bir sonuç döndürmesi dışında sqlite_query() işlevi gibidir.

Her seferinde bir satırın işlenmesine gerek duyan, satır verisine rasgele erişimin gerekmediği HTML tabloları gibi şeyleri üretmek için çok kullanışlıdır.

Bilginize:

Bu işlevden dönen sonuç tanıtıcısı sqlite_seek(),
sqlite_rewind(), sqlite_next(),
sqlite_current() ve sqlite_num_rows()
işlevinde çalışmaz.

Değiştirgeler

db

SQLite Veritabanı özkaynağı. Yordamsal kullanımda sqlite_open() işlevi tarafından döndürülür. Nesne yönelimli kullanımda bu değiştirgeye gerek yoktur.

sorgu

Çalıştırılacak sorgu.

Sorgu içindeki verinin düzgün olarak öncelenmiş olması gerekir.

sonuç_türü

İsteğe bağlı bu değiştirgede döndürülen dizinin nasıl oluşturulacağını belirleyen bir sabit belirtilir. SQLITE_ASSOC belirtilirse alanların isimleri indis olarak kullanılır. SQLITE_NUM belirtilirse alanların sıra numaraları indis olarak kullanılır. SQLITE_BOTH için ise hem isimli hem de sayısal indisli bir dizi döner. SQLITE_BOTH bu işlev için öntanımlı değerdir.

hata_iletisi

Bir hata oluştuğunda hata iletisi bu değiştirgeye konur. SQL sözdizimi hataları sqlite_last_error() işlevi ile alınamadığından bu değiştirge özellikle önemlidir.

Bilginize: Diğer veritabanı eklentileri (MySQL gibi) ile uyumluluk için iki ayrı sözdizimi desteklenmektedir. Genelde tercih edilen sözdizimi db değiştirgesinin ilk değiştirge olarak kullanıldığı ilk sözdizimidir.

Dönen Değerler

Hata durumunda FALSE yoksa bir sonuç tanıtıcısı döner.

sqlite_unbuffered_query() işlevi, Sıralı ve sadece ileri yönde ilerlenebilen, her seferinde tek bir satırın okunabildiği bir sonuç döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.0 | hata_iletisi değiştirgesi eklendi.

Ayrıca Bakınız

  • sqlite_query() - Belirtilen veritabanında bir sorgu çalıştırıp bir sonuç tanıtıcısı döndürür

sqlite_udf_encode_binary
sqlite_valid
SQLite İşlevleri


Başka satır var mı diye bakar

sqlite_unbuffered_query
SQLite3
SQLite İşlevleri
PHP Manual

sqlite_valid

SQLiteResult->valid

SQLiteUnbuffered->valid

(PHP 5 < 5.4.0)

sqlite_valid -- SQLiteResult->valid -- SQLiteUnbuffered->valid — Başka satır var mı diye bakar

Açıklama

bool sqlite_valid ( resource $sonuç )

Nesne yönelimli kullanım

bool valid ( void )
bool valid ( void )

Belirtilen sonuç kümesinde başka satır var mı diye bakar.

Değiştirgeler

sonuç

SQLite sonuç özkaynağı. Nesne yönelimli kullanımda bu değiştirgeye gerek yoktur.

Bilginize:

Bu işlev tamponsuz sonuç tanıtıcıları ile kullanılamaz.

Dönen Değerler

Başka satır varsa TRUE yoksa FALSE döner.

Ayrıca Bakınız

  • sqlite_num_rows() - Tamponlu bir sonuç kümesindeki satır sayısını döndürür
  • sqlite_changes() - En son SQL deyiminin değiştirdiği satır sayısını döndürür

sqlite_unbuffered_query
SQLite3
SQLite İşlevleri


SQLite3

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • SQLite3 — SQLite3 sınıfı
    • SQLite3::busyTimeout — Sets the busy connection handler
    • SQLite3::changes — Veritabanında son SQL deyimi ile işlem gören satır sayısını döndürür
    • SQLite3::close — Veritabanı bağlantısını kapatır
    • SQLite3::__construct — Yeni bir SQLite3 nesnesini ilklendirdikten sonra bir SQLite veritabanını açar
    • SQLite3::createAggregate — Toparlayıcı bir SQL işlevi olarak kullanılmak üzere bir PHP işlevini kayda geçirir
    • SQLite3::createCollation — Registers a PHP function for use as an SQL collating function
    • SQLite3::createFunction — Sayıl bir SQL işlevi olarak kullanılmak üzere bir PHP işlevini kayda geçirir
    • SQLite3::enableExceptions — Enable throwing exceptions
    • SQLite3::escapeString — Gerektiği gibi öncelenmiş bir dizge döndürür
    • SQLite3::exec — Sonuç döndürmeyen bir SQL sorgusu çalıştırır
    • SQLite3::lastErrorCode — Başarısız olan son SQLite isteğinin sayısal sonuç kodunu döndürür
    • SQLite3::lastErrorMsg — Başarısız olan son SQLite isteği ile ilgili İngilizce iletiyi döndürür
    • SQLite3::lastInsertRowID — Veritabanına en son yerleştirilen satırın kimliğini döndürür
    • SQLite3::loadExtension — Belirtilen SQLite eklenti kütüphanesini yüklemeye çalışır
    • SQLite3::open — Bir SQLite veritabanını açar
    • SQLite3::openBlob — Opens a stream resource to read a BLOB
    • SQLite3::prepare — Çalıştırılmak üzere bir SQL sorgusu hazırlar
    • SQLite3::query — Bir SQL sorgusu çalıştırır
    • SQLite3::querySingle — Bir sorgu çalıştırıp tek bir sonuç döndürür
    • SQLite3::version — SQLite3 kütüphanesinin sürüm numarasını dizge ve sayı olarak döndürür
  • SQLite3Stmt — SQLite3Stmt sınıfı
    • SQLite3Stmt::bindParam — Bir değiştirgeyi bir deyim değişkeni ile ilişkilendirir
    • SQLite3Stmt::bindValue — Bir değiştirgenin değerini bir deyim değişkeni ile ilişkilendirir
    • SQLite3Stmt::clear — Tüm değiştirge ilişkilendirmelerini temizler
    • SQLite3Stmt::close — Hazır deyimi kapatır
    • SQLite3Stmt::execute — Hazır deyimi çalıştırır ve sonuç kümesini bir nesne olarak döndürür
    • SQLite3Stmt::paramCount — Hazır deyimdeki değişken sayısını döndürür
    • SQLite3Stmt::readOnly() — Returns whether a statement is definitely read only
    • SQLite3Stmt::reset — Hazır deyimi sıfırlar
  • SQLite3Result — SQLite3Result sınıfı
    • SQLite3Result::columnName — Numarası belirtilen sütunun ismini döndürür
    • SQLite3Result::columnType — Numarası belirtilen sütunun türünü döndürür
    • SQLite3Result::fetchArray — Sonuç satırını bir dizi olarak döndürür
    • SQLite3Result::finalize — Sonuç kümesini kapatır
    • SQLite3Result::numColumns — Sonuç kümesindeki sütun sayısını döndürür
    • SQLite3Result::reset — Sonuç kümesindeki geçerli satırı ilk satır yapar
sqlite_valid
Giriş
Sağlayıcıya Göre Veritabanı Eklentileri


Giriş

SQLite'ın 3. sürüm veritabanları için destek.

SQLite3
Yapılandırma/Kurulum
SQLite3


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
SQLite3


Kurulum

SQLite3 eklentisi PHP 5.3.0'dan beri öntanımlı olarak etkindir. Derleme sırasında --without-sqlite3 seçeneğini kullanarak iptal etmek mümkündür.

Windows kullanıcılarının bu eklentiyi kullanabilmeleri için php.ini içinde php_sqlite3.dll'i etkin kılmaları gerekmektedir. Bu DLL, PHP 5.3.0'dan itibaren PHP'nin Windows dağıtımlarına dahil edilmektedir.

Bilginize:

Bu eklenti bir PECL eklentisi olarak da mevcutsa da sadece deneysel kullanım için önerilebilir.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

SQLite3 Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm bilgisi
sqlite3.extension_dir | NULL | PHP_INI_SYSTEM |

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

sqlite3.extension_dir string

SQLite yüklenebilir eklentilerinin yeri.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

SQLITE3_ASSOC (integer)
SQLite3Result::fetchArray() yönteminin ilgili sonuç kümesinde bulunan sütun isimlerine göre indislenmiş bir dizi döndüreceğini belirtir.
SQLITE3_NUM (integer)
Sqlite3Result::fetchArray() yönteminin ilgili sonuç kümesinde bulunan sütun numaralarına göre indislenmiş bir dizi döndüreceğini belirtir. Sütun numaraları 0'dan başlar.
SQLITE3_BOTH (integer)
Sqlite3Result::fetchArray() yönteminin ilgili sonuç kümesinde bulunan sütun isimlerine ve sütün numaralarına göre indislenmiş bir dizi döndüreceğini belirtir. Sütun numaraları 0'dan başlar.
SQLITE3_INTEGER (integer)
SQLite3 INTEGER (tamsayı) saklama sınıfını temsil eder.
SQLITE3_FLOAT (integer)
SQLite3 REAL (FLOAT) (gerçek sayı) saklama sınıfını temsil eder.
SQLITE3_TEXT (integer)
SQLite3 TEXT (metin) saklama sınıfını temsil eder.
SQLITE3_BLOB (integer)
SQLite3 BLOB (ikil veri) saklama sınıfını temsil eder..
SQLITE3_NULL (integer)
SQLite3 NULL saklama sınıfını temsil eder.
SQLITE3_OPEN_READONLY (integer)
SQLite3 veritabanının salt-okunur açılacağını belirtir.
SQLITE3_OPEN_READWRITE (integer)
SQLite3 veritabanının okuma ve yazma amacıyla açılacağını belirtir.
SQLITE3_OPEN_CREATE (integer)
SQLite3 veritabanının mevcut değilse oluşturulacağını belirtir.

Özkaynak Türleri
SQLite3
SQLite3


SQLite3 sınıfı

(PHP 5 >= 5.3.0, PHP 7)

Giriş

SQLite 3 veritabanlarına arayüzlük eden sınıf.

Sınıf Sözdizimi

SQLite3 {
/* Methods */
public bool busyTimeout ( int $msecs )
public int changes ( void )
public bool close ( void )
__construct ( string $dosya [, int $seçenekler [, string $anahtar ]] )
public bool createAggregate ( string $isim , mixed $sekme_işlevi , mixed $son_işlev [, int $değ_sayısı = -1 ] )
public bool createCollation ( string $name , callable $callback )
public bool createFunction ( string $isim , mixed $işlev [, int $değ_sayısı = -1 ] )
bool enableExceptions ([ bool $enableExceptions = false ] )
public string escapeString ( string $veri )
public bool exec ( string $sorgu )
public int lastErrorCode ( void )
public string lastErrorMsg ( void )
public int lastInsertRowID ( void )
public bool loadExtension ( string $kütüphane )
public bool open ( string $dosya [, int $seçenekler = SQLITE3_OPEN_READWRITE | SQLITE3_OPEN_CREATE [, string $anahtar ]] )
public resource open ( string $table , string $column , int $rowid [, string $dbname = "main" ] )
public SQLite3Stmt prepare ( string $sorgu )
public SQLite3Result query ( string $sorgu )
public mixed querySingle ( string $sorgu [, bool $tüm_satır = false ] )
public array version ( void )
}

İçindekiler

  • SQLite3::busyTimeout — Sets the busy connection handler
  • SQLite3::changes — Veritabanında son SQL deyimi ile işlem gören satır sayısını döndürür
  • SQLite3::close — Veritabanı bağlantısını kapatır
  • SQLite3::__construct — Yeni bir SQLite3 nesnesini ilklendirdikten sonra bir SQLite veritabanını açar
  • SQLite3::createAggregate — Toparlayıcı bir SQL işlevi olarak kullanılmak üzere bir PHP işlevini kayda geçirir
  • SQLite3::createCollation — Registers a PHP function for use as an SQL collating function
  • SQLite3::createFunction — Sayıl bir SQL işlevi olarak kullanılmak üzere bir PHP işlevini kayda geçirir
  • SQLite3::enableExceptions — Enable throwing exceptions
  • SQLite3::escapeString — Gerektiği gibi öncelenmiş bir dizge döndürür
  • SQLite3::exec — Sonuç döndürmeyen bir SQL sorgusu çalıştırır
  • SQLite3::lastErrorCode — Başarısız olan son SQLite isteğinin sayısal sonuç kodunu döndürür
  • SQLite3::lastErrorMsg — Başarısız olan son SQLite isteği ile ilgili İngilizce iletiyi döndürür
  • SQLite3::lastInsertRowID — Veritabanına en son yerleştirilen satırın kimliğini döndürür
  • SQLite3::loadExtension — Belirtilen SQLite eklenti kütüphanesini yüklemeye çalışır
  • SQLite3::open — Bir SQLite veritabanını açar
  • SQLite3::openBlob — Opens a stream resource to read a BLOB
  • SQLite3::prepare — Çalıştırılmak üzere bir SQL sorgusu hazırlar
  • SQLite3::query — Bir SQL sorgusu çalıştırır
  • SQLite3::querySingle — Bir sorgu çalıştırıp tek bir sonuç döndürür
  • SQLite3::version — SQLite3 kütüphanesinin sürüm numarasını dizge ve sayı olarak döndürür
Öntanımlı Sabitler
SQLite3::busyTimeout
SQLite3


Sets the busy connection handler

SQLite3
SQLite3::changes
SQLite3
PHP Manual

SQLite3::busyTimeout

(PHP 5 >= 5.3.3, PHP 7)

SQLite3::busyTimeout — Sets the busy connection handler

Açıklama

public bool SQLite3::busyTimeout ( int $msecs )

Sets a busy handler that will sleep until the database is not locked or the timeout is reached.

Değiştirgeler

msecs

The milliseconds to sleep. Setting this value to a value less than or equal to zero, will turn off an already set timeout handler.

Dönen Değerler

Returns TRUE on success, FALSE on failure.

SQLite3
SQLite3::changes
SQLite3


Veritabanında son SQL deyimi ile işlem gören satır sayısını döndürür

SQLite3::busyTimeout
SQLite3::close
SQLite3
PHP Manual

SQLite3::changes

(PHP 5 >= 5.3.0, PHP 7)

SQLite3::changes — Veritabanında son SQL deyimi ile işlem gören satır sayısını döndürür

Açıklama

public int SQLite3::changes ( void )

Veritabanında son SQL deyimi ile değişikliğe uğrayan, silinen veya yerleştirilen satır sayısını döndürür.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

İşlem gören satır sayısını bir tamsayı olarak döndürür.

Örnekler

Örnek 1 - SQLite3::changes() örneği

<?php
$db = new SQLite3('mysqlitedb.db');

$query = $db->exec('UPDATE counter SET views=0 WHERE page="test"');
if ($query) {
    echo 'İşlem gören satır sayısı: ', $db->changes();
}
?>

SQLite3::busyTimeout
SQLite3::close
SQLite3


Veritabanı bağlantısını kapatır

SQLite3::changes
SQLite3::__construct
SQLite3
PHP Manual

SQLite3::close

(PHP 5 >= 5.3.0, PHP 7)

SQLite3::close — Veritabanı bağlantısını kapatır

Açıklama

public bool SQLite3::close ( void )

Veritabanı bağlantısını kapatır.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - SQLite3::close() örneği

<?php
$db = new SQLite3('mysqlitedb.db');
$db->close();
?>

SQLite3::changes
SQLite3::__construct
SQLite3


Yeni bir SQLite3 nesnesini ilklendirdikten sonra bir SQLite veritabanını açar

SQLite3::close
SQLite3::createAggregate
SQLite3
PHP Manual

SQLite3::__construct

(PHP 5 >= 5.3.0, PHP 7)

SQLite3::__construct — Yeni bir SQLite3 nesnesini ilklendirdikten sonra bir SQLite veritabanını açar

Açıklama

SQLite3::__construct ( string $dosya [, int $seçenekler [, string $anahtar ]] )

Yeni bir SQLite3 nesnesini ilklendirdikten sonra dosya ile belirtilen SQLite veritabanına bir bağlantı açar. Eğer veritabanı şifreliyse anahtar ile şifresini çözmeye çalışır.

Değiştirgeler

dosya

SQLite veritabanını içeren dosyanın yolu.

seçenekler

SQLite veritabanının nasıl açılacağını belirleyen seçimlik seçenekler. Öntanımlı olarak, SQLITE3_OPEN_READWRITE | SQLITE3_OPEN_CREATE kullanılır.

  • SQLITE3_OPEN_READONLY: Veritabanı okumak için açılır.

  • SQLITE3_OPEN_READWRITE: Veritabanı hem okumak hem de yazmak için açılır.

  • SQLITE3_OPEN_CREATE: Veritabanı yoksa oluşturulur.

encryption_key

SQLite veritabanını şifrelemek/şifresini çözmek için kullanılan şifreleme anahtarı.

Dönen Değerler

İşlem başarılı olursa bir SQLite3 nesnesi döner.

Örnekler

Örnek 1 - SQLite3::__construct() örneği

<?php
$db = new SQLite3('mysqlitedb.db');

$db->exec('CREATE TABLE foo (bar STRING)');
$db->exec("INSERT INTO foo (bar) VALUES ('Bu bir denemedir.')");

$result = $db->query('SELECT bar FROM foo');
var_dump($result->fetchArray());
?>

SQLite3::close
SQLite3::createAggregate
SQLite3


Toparlayıcı bir SQL işlevi olarak kullanılmak üzere bir PHP işlevini kayda geçirir

SQLite3::__construct
SQLite3::createCollation
SQLite3
PHP Manual

SQLite3::createAggregate

(PHP 5 >= 5.3.0, PHP 7)

SQLite3::createAggregate — Toparlayıcı bir SQL işlevi olarak kullanılmak üzere bir PHP işlevini kayda geçirir

Açıklama

public bool SQLite3::createAggregate ( string $isim , mixed $sekme_işlevi , mixed $son_işlev [, int $değ_sayısı = -1 ] )

SQL deyimlerinde toparlayıcı bir SQL işlevi olarak kullanılmak üzere bir PHP işlevini veya bir kullanıcı tanımlı işlevi kayda geçirir.

Değiştirgeler

isim

Oluşturulacak veya yeniden tanımlanacak toparlayıcı SQL işlevinin ismi.

sekme_işlevi

Verinin toplanacağı öğelerin her biriyle çalıştırılacak PHP işlevinin veya kullanıcı tanımlı işlevin ismi.

son_işlev

Veri toplama işlemi bittikten sonra çalıştırılacak PHP işlevinin veya kullanıcı tanımlı işlevin ismi.

değ_sayısı

SQL işlevinin alacağı değiştirge sayısı. Negatif bir sayı belirtilirse SQL işlevi herhangi bir sayıda değiştirge alabilir demektir.

Dönen Değerler

İşlev başarıyla oluşturulmuşsa TRUE yoksa FALSE döner.

SQLite3::__construct
SQLite3::createCollation
SQLite3


Registers a PHP function for use as an SQL collating function

SQLite3::createAggregate
SQLite3::createFunction
SQLite3
PHP Manual

SQLite3::createCollation

(PHP 5 >= 5.3.11, PHP 7)

SQLite3::createCollation — Registers a PHP function for use as an SQL collating function

Açıklama

public bool SQLite3::createCollation ( string $name , callable $callback )

Registers a PHP function or user-defined function for use as a collating function within SQL statements.

Değiştirgeler

name

Name of the SQL collating function to be created or redefined

callback

The name of a PHP function or user-defined function to apply as a callback, defining the behavior of the collation. It should accept two strings and return as strcmp() does, i.e. it should return -1, 1, or 0 if the first string sorts before, sorts after, or is equal to the second.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 SQLite3::createCollation() example

Register the PHP function strnatcmp() as a collating sequence in the SQLite3 database.

<?php

$db = new SQLite3(":memory:");
$db->exec("CREATE TABLE test (col1 string)");
$db->exec("INSERT INTO test VALUES ('a1')");
$db->exec("INSERT INTO test VALUES ('a10')");
$db->exec("INSERT INTO test VALUES ('a2')");

$db->createCollation('NATURAL_CMP', 'strnatcmp');

$defaultSort = $db->query("SELECT col1 FROM test ORDER BY col1");
$naturalSort = $db->query("SELECT col1 FROM test ORDER BY col1 COLLATE NATURAL_CMP");

echo "default:\n";
while ($row = $defaultSort->fetchArray()){
    echo $row['col1'], "\n";
}

echo "\nnatural:\n";
while ($row = $naturalSort->fetchArray()){
    echo $row['col1'], "\n";
}

$db->close();

?>

Yukarıdaki örneğin çıktısı:

default:
a1
a10
a2

natural:
a1
a2
a10

Ayrıca Bakınız

  • The SQLite collation documentation: » http://sqlite.org/datatype3.html#collation
SQLite3::createAggregate
SQLite3::createFunction
SQLite3


Sayıl bir SQL işlevi olarak kullanılmak üzere bir PHP işlevini kayda geçirir

SQLite3::createCollation
SQLite3::enableExceptions
SQLite3
PHP Manual

SQLite3::createFunction

(PHP 5 >= 5.3.0, PHP 7)

SQLite3::createFunction — Sayıl bir SQL işlevi olarak kullanılmak üzere bir PHP işlevini kayda geçirir

Açıklama

public bool SQLite3::createFunction ( string $isim , mixed $işlev [, int $değ_sayısı = -1 ] )

Mevcut veya yeni bir SQL işlevinin davranışını tanımlamak üzere bir geriçağırım işlevi olarak kullanılacak bir PHP işlevi veya kullanıcı tanımlı bir işlevi kayda geçirir.

Değiştirgeler

isim

Oluşturulacak veya yeniden tanımlanacak SQL işlevi.

işlev

SQL işlevinin davranışını tanımlamak üzere bir geriçağırım işlevi olarak kullanılacak bir PHP işlevi veya kullanıcı tanımlı bir işlevin ismi.

değ_sayısı

SQL işlevinin alacağı değiştirge sayısı. Negatif bir sayı belirtilirse SQL işlevi herhangi bir sayıda değiştirge alabilir demektir.

Dönen Değerler

İşlev başarıyla oluşturulmuşsa TRUE yoksa FALSE döner.

Örnekler

Örnek 1 - SQLite3::createFunction() örneği

<?php
function my_udf_md5($string) {
    return md5($string);
}

$db = new SQLite3('mysqlitedb.db');
$db->createFunction('my_udf_md5', 'my_udf_md5');

var_dump($db->querySingle('SELECT my_udf_md5("test")'));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(32) "098f6bcd4621d373cade4e832627b4f6"

SQLite3::createCollation
SQLite3::enableExceptions
SQLite3


Enable throwing exceptions

SQLite3::createFunction
SQLite3::escapeString
SQLite3
PHP Manual

SQLite3::enableExceptions

(PHP 5 >= 5.3.0, PHP 7)

SQLite3::enableExceptions — Enable throwing exceptions

Açıklama

bool SQLite3::enableExceptions ([ bool $enableExceptions = false ] )

Controls whether the SQLite3 instance will throw exceptions or warnings on error.

Değiştirgeler

enable

When TRUE, the SQLite3 instance, and SQLite3Stmt and SQLite3Result instances derived from it, will throw exceptions on error.

When FALSE, the SQLite3 instance, and SQLite3Stmt and SQLite3Result instances derived from it, will raise warnings on error.

For either mode, the error code and message, if any, will be available via SQLite3::lastErrorCode() and SQLite3::lastErrorMsg() respectively.

Dönen Değerler

Returns the old value; TRUE if exceptions were enabled, FALSE otherwise.

Örnekler

Örnek 1 SQLite3::enableExceptions() example

<?php
$sqlite = new SQLite3(':memory:');
try {
    $sqlite->exec('create table foo');
    $sqlite->enableExceptions(true);
    $sqlite->exec('create table bar');
} catch (Exception $e) {
    echo 'Caught exception: ' . $e->getMessage();
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Warning: SQLite3::exec(): near "foo": syntax error in example.php on line 4
Caught exception: near "bar": syntax error
SQLite3::createFunction
SQLite3::escapeString
SQLite3


Gerektiği gibi öncelenmiş bir dizge döndürür

SQLite3::enableExceptions
SQLite3::exec
SQLite3
PHP Manual

SQLite3::escapeString

(PHP 5 >= 5.3.0, PHP 7)

SQLite3::escapeString — Gerektiği gibi öncelenmiş bir dizge döndürür

Açıklama

public string SQLite3::escapeString ( string $veri )

Belirtilen veri gerekli öncelemlerle bir SQL deyiminde güvenle kullanılabilir hale getirilip bir dizge olarak döndürülür.

Değiştirgeler

veri

Öncelenecek dizge.

Dönen Değerler

Bir SQL deyiminde güvenle kullanılabilir hale getirilmiş dizgeyi döndürür.

Notlar

Uyarı

SQLite sorgularında kullanacığınız dizgeleri addslashes() kullanarak öncelememelisiniz. Aksi takdirde tuhaf sonuçlar alabilirsiniz.

SQLite3::enableExceptions
SQLite3::exec
SQLite3


Sonuç döndürmeyen bir SQL sorgusu çalıştırır

SQLite3::escapeString
SQLite3::lastErrorCode
SQLite3
PHP Manual

SQLite3::exec

(PHP 5 >= 5.3.0, PHP 7)

SQLite3::exec — Sonuç döndürmeyen bir SQL sorgusu çalıştırır

Açıklama

public bool SQLite3::exec ( string $sorgu )

Sonuç döndürmeyen bir SQL sorgusu çalıştırır.

Değiştirgeler

sorgu

Sonuç döndürmeyen CREATE, INSERT, UPDATE, DELETE gibi bir sorgu.

Dönen Değerler

İstek başarıyla yerine getirilirse TRUE yoksa FALSE döner.

Örnekler

Örnek 1 - SQLite3::exec() örneği

<?php
$db = new SQLite3('mysqlitedb.db');

$db->exec('CREATE TABLE bar (bar STRING)');
?>

SQLite3::escapeString
SQLite3::lastErrorCode
SQLite3


Başarısız olan son SQLite isteğinin sayısal sonuç kodunu döndürür

SQLite3::exec
SQLite3::lastErrorMsg
SQLite3
PHP Manual

SQLite3::lastErrorCode

(PHP 5 >= 5.3.0, PHP 7)

SQLite3::lastErrorCode — Başarısız olan son SQLite isteğinin sayısal sonuç kodunu döndürür

Açıklama

public int SQLite3::lastErrorCode ( void )

Başarısız olan son SQLite isteğinin sayısal sonuç kodunu döndürür.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Sonuç kodu bir tamsayı olarak döner.

SQLite3::exec
SQLite3::lastErrorMsg
SQLite3


Başarısız olan son SQLite isteği ile ilgili İngilizce iletiyi döndürür

SQLite3::lastErrorCode
SQLite3::lastInsertRowID
SQLite3
PHP Manual

SQLite3::lastErrorMsg

(PHP 5 >= 5.3.0, PHP 7)

SQLite3::lastErrorMsg — Başarısız olan son SQLite isteği ile ilgili İngilizce iletiyi döndürür

Açıklama

public string SQLite3::lastErrorMsg ( void )

Başarısız olan son SQLite isteğinin başarısızlığını açıklayan İngilizce iletiyi döndürür.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarısızlığın sebebini açıklayan iletiyi içeren bir dizge döner.

SQLite3::lastErrorCode
SQLite3::lastInsertRowID
SQLite3


Veritabanına en son yerleştirilen satırın kimliğini döndürür

SQLite3::lastErrorMsg
SQLite3::loadExtension
SQLite3
PHP Manual

SQLite3::lastInsertRowID

(PHP 5 >= 5.3.0, PHP 7)

SQLite3::lastInsertRowID — Veritabanına en son yerleştirilen satırın kimliğini döndürür

Açıklama

public int SQLite3::lastInsertRowID ( void )

Veritabanına en son yerleştirilen (INSERT) satırın kimliğini döndürür.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Satır kimliği bir tamsayı olarak döner.

SQLite3::lastErrorMsg
SQLite3::loadExtension
SQLite3


Belirtilen SQLite eklenti kütüphanesini yüklemeye çalışır

SQLite3::lastInsertRowID
SQLite3::open
SQLite3
PHP Manual

SQLite3::loadExtension

(PHP 5 >= 5.3.0, PHP 7)

SQLite3::loadExtension — Belirtilen SQLite eklenti kütüphanesini yüklemeye çalışır

Açıklama

public bool SQLite3::loadExtension ( string $kütüphane )

kütüphane ile ismi belirtilen SQLite eklenti kütüphanesini yüklemeye çalışır.

Değiştirgeler

kütüphane

Yüklenecek paylaşımlı kütüphanenin ismi. Kütüphane sqlite3.extension_dir yapılandırma yönergesinde belirtilen dizinde olmalıdır.

Dönen Değerler

Eklenti başarıyla yüklendiği takdirde TRUE yoksa FALSE döner.

Örnekler

Örnek 1 - SQLite3::loadExtension() örneği

<?php
$db = new SQLite3('mysqlitedb.db');
$db->loadExtension('libagg.so');
?>

SQLite3::lastInsertRowID
SQLite3::open
SQLite3


Bir SQLite veritabanını açar

SQLite3::loadExtension
SQLite3::openBlob
SQLite3
PHP Manual

SQLite3::open

(PHP 5 >= 5.3.0, PHP 7)

SQLite3::open — Bir SQLite veritabanını açar

Açıklama

public bool SQLite3::open ( string $dosya [, int $seçenekler = SQLITE3_OPEN_READWRITE | SQLITE3_OPEN_CREATE [, string $anahtar ]] )

dosya ile belirtilen SQLite 3 veritabanını açar. Veritabanı şifreli ise belirtilen anahtar ile şifresi çözülmeye çalışılır.

Değiştirgeler

dosya

SQLite veritabanını içeren dosyanın yolu.

seçenekler

SQLite veritabanının nasıl açılacağını belirleyen seçimlik seçenekler. Öntanımlı olarak, SQLITE3_OPEN_READWRITE | SQLITE3_OPEN_CREATE kullanılır.

  • SQLITE3_OPEN_READONLY: Veritabanı okumak için açılır.

  • SQLITE3_OPEN_READWRITE: Veritabanı hem okumak hem de yazmak için açılır.

  • SQLITE3_OPEN_CREATE: Veritabanı yoksa oluşturulur.

anahtar

SQLite veritabanını şifrelemek/şifresini çözmek için kullanılan şifreleme anahtarı.

Dönen Değerler

Veritabanı açılabilirse TRUE yoksa FALSE döner.

Örnekler

Örnek 1 - SQLite3::open() örneği

<?php
$db = new SQLite3('mysqlitedb.db');

$db->exec('CREATE TABLE foo (bar STRING)');
$db->exec("INSERT INTO foo (bar) VALUES ('Bu bir denemedir')");

$result = $db->query('SELECT bar FROM foo');
var_dump($result->fetchArray());
?>

SQLite3::loadExtension
SQLite3::openBlob
SQLite3


Opens a stream resource to read a BLOB

SQLite3::open
SQLite3::prepare
SQLite3
PHP Manual

SQLite3::openBlob

(PHP 5 >= 5.3.0, PHP 7)

SQLite3::openBlob — Opens a stream resource to read a BLOB

Açıklama

public resource SQLite3::open ( string $table , string $column , int $rowid [, string $dbname = "main" ] )

Opens a stream resource to read a BLOB, which would be selected by:

SELECT column FROM dbname.table WHERE rowid = rowid

Değiştirgeler

table

The table name.

column

The column name.

rowid

The row ID.

dbname

The symbolic name of the DB

Dönen Değerler

Returns a stream resource, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 SQLite3::openBlob() example

<?php
$conn = new SQLite3(':memory:');
$conn->exec('CREATE TABLE test (text text)');
$conn->exec("INSERT INTO test VALUES ('Lorem ipsum')");
$stream = $conn->openBlob('test', 'text', 1);
echo stream_get_contents($stream);
fclose($stream); // mandatory, otherwise the next line would fail
$conn->close();
?>

Yukarıdaki örneğin çıktısı:

Lorem ipsum

SQLite3::open
SQLite3::prepare
SQLite3


Çalıştırılmak üzere bir SQL sorgusu hazırlar

SQLite3::openBlob
SQLite3::query
SQLite3
PHP Manual

SQLite3::prepare

(PHP 5 >= 5.3.0, PHP 7)

SQLite3::prepare — Çalıştırılmak üzere bir SQL sorgusu hazırlar

Açıklama

public SQLite3Stmt SQLite3::prepare ( string $sorgu )

Çalıştırılmak üzere bir SQL sorgusu hazırlar ve bir SQLite3Stmt nesnesi olarak döndürür.

Değiştirgeler

sorgu

Hazırlanacak SQL sorgusu.

Dönen Değerler

İşlem başarılı olursa bir SQLite3Stmt nesnesi, yoksa FALSE döner.

Örnekler

Örnek 1 - SQLite3::prepare() örneği

<?php
unlink('mysqlitedb.db');
$db = new SQLite3('mysqlitedb.db');

$db->exec('CREATE TABLE foo (id INTEGER, bar STRING)');
$db->exec("INSERT INTO foo (id, bar) VALUES (1, 'Bu bir denemedir')");

$stmt = $db->prepare('SELECT bar FROM foo WHERE id=:id');
$stmt->bindValue(':id', 1, SQLITE3_INTEGER);

$result = $stmt->execute();
var_dump($result->fetchArray());
?>

SQLite3::openBlob
SQLite3::query
SQLite3


Bir SQL sorgusu çalıştırır

SQLite3::prepare
SQLite3::querySingle
SQLite3
PHP Manual

SQLite3::query

(PHP 5 >= 5.3.0, PHP 7)

SQLite3::query — Bir SQL sorgusu çalıştırır

Açıklama

public SQLite3Result SQLite3::query ( string $sorgu )

Bir SQL sorgusu çalıştırır ve sonucu bir SQLite3Result nesnesi olarak döndürür.

Değiştirgeler

sorgu

Çalıştırılacak SQL sorgusu.

Dönen Değerler

Sorgu sonuç döndürürse bir SQLite3Result nesnesi, başarılı olur ancak sonuç döndürmezse TRUE aksi takdirde FALSE döner.

Örnekler

Örnek 1 - SQLite3::query() örneği

<?php
$db = new SQLite3('mysqlitedb.db');

$results = $db->query('SELECT bar FROM foo');
while ($row = $results->fetchArray()) {
    var_dump($row);
}
?>

SQLite3::prepare
SQLite3::querySingle
SQLite3


Bir sorgu çalıştırıp tek bir sonuç döndürür

SQLite3::query
SQLite3::version
SQLite3
PHP Manual

SQLite3::querySingle

(PHP 5 >= 5.3.0, PHP 7)

SQLite3::querySingle — Bir sorgu çalıştırıp tek bir sonuç döndürür

Açıklama

public mixed SQLite3::querySingle ( string $sorgu [, bool $tüm_satır = false ] )

Bir sorgu çalıştırıp tek bir sonuç döndürür.

Değiştirgeler

sorgu

Çalıştırılacak SQL sorgusu.

tüm_satır

Öntanımlı olarak sorgudan ilk sütunun değeri döner. Bu değiştirgede TRUE belirtilirse ilk satırın tamamı bir dizi olarak döndürülür.

Dönen Değerler

Bir hata oluşmuşsa FALSE, tüm_satır değiştirgesinde TRUE belirtilmişse ilk satırı içeren bir dizi yoksa ilk sütunun değeri bir dizge olarak döner.

Örnekler

Örnek 1 - SQLite3::querySingle() örneği

<?php
$db = new SQLite3('mysqlitedb.db');

var_dump($db->querySingle('SELECT username FROM user WHERE userid=1'));
print_r($db->querySingle('SELECT username, email FROM user WHERE userid=1',
      true));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(5) "Scott"
Array
(
    [username] => Scott
    [email] => scott@example.com
)

SQLite3::query
SQLite3::version
SQLite3


SQLite3 kütüphanesinin sürüm numarasını dizge ve sayı olarak döndürür

SQLite3::querySingle
SQLite3Stmt
SQLite3
PHP Manual

SQLite3::version

(PHP 5 >= 5.3.0, PHP 7)

SQLite3::version — SQLite3 kütüphanesinin sürüm numarasını dizge ve sayı olarak döndürür

Açıklama

public array SQLite3::version ( void )

SQLite3 kütüphanesinin sürüm numarasını dizge ve sayı olarak döndürür.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

"versionString" ve "versionNumber" anahtarlarına sahip bir ilişkisel dizi döndürür.

Örnekler

Örnek 1 - SQLite3::version() örneği

<?php
print_r(SQLite3::version());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [versionString] => 3.5.9
    [versionNumber] => 3005009
)

SQLite3::querySingle
SQLite3Stmt
SQLite3


SQLite3Stmt sınıfı

(PHP 5 >= 5.3.0, PHP 7)

Giriş

SQLite 3 eklentisi için hazır deyimleri içeren sınıf.

Sınıf Sözdizimi

SQLite3Stmt {
/* Methods */
public bool bindParam ( string $değişken , mixed &$değiştirge [, int $tür ] )
public bool bindValue ( string $değişken , mixed $değer [, int $tür ] )
public bool clear ( void )
public bool close ( void )
public SQLite3Result execute ( void )
public int paramCount ( void )
public bool readOnly ( void )
public bool reset ( void )
}

İçindekiler

  • SQLite3Stmt::bindParam — Bir değiştirgeyi bir deyim değişkeni ile ilişkilendirir
  • SQLite3Stmt::bindValue — Bir değiştirgenin değerini bir deyim değişkeni ile ilişkilendirir
  • SQLite3Stmt::clear — Tüm değiştirge ilişkilendirmelerini temizler
  • SQLite3Stmt::close — Hazır deyimi kapatır
  • SQLite3Stmt::execute — Hazır deyimi çalıştırır ve sonuç kümesini bir nesne olarak döndürür
  • SQLite3Stmt::paramCount — Hazır deyimdeki değişken sayısını döndürür
  • SQLite3Stmt::readOnly() — Returns whether a statement is definitely read only
  • SQLite3Stmt::reset — Hazır deyimi sıfırlar
SQLite3::version
SQLite3Stmt::bindParam
SQLite3


Bir değiştirgeyi bir deyim değişkeni ile ilişkilendirir

SQLite3Stmt
SQLite3Stmt::bindValue
SQLite3Stmt
PHP Manual

SQLite3Stmt::bindParam

(PHP 5 >= 5.3.0, PHP 7)

SQLite3Stmt::bindParam — Bir değiştirgeyi bir deyim değişkeni ile ilişkilendirir

Açıklama

public bool SQLite3Stmt::bindParam ( string $değişken , mixed &$değiştirge [, int $tür ] )

değiştirge'yi değişken ile belirtilen deyim değişkeni ile ilişkilendirir.

Değiştirgeler

değişken

değiştirge ile ilişkilendirilecek değişkenin ismi.

değiştirge

Deyim değişkeni ile ilişkilendirilecek değiştirge.

tür

İlişkilendirilecek değiştirgenin veri türü

  • SQLITE3_INTEGER: İşaretli tamsayı. Değerin büyüklüğüne göre 1, 2, 3, 4, 6 veya 8 bayt genişlikte olabilir.

  • SQLITE3_FLOAT: Gerçek sayı. Bir 8 baytlık IEEE kayan noktalı sayı olarak saklanır.

  • SQLITE3_TEXT: Bir dizge. Veritabanının karakter kodlamasıyla kodlanır (UTF-8, UTF-16BE veya UTF-16-LE).

  • SQLITE3_BLOB: İkil veri. Veri girildiği haliyle saklanır.

  • SQLITE3_NULL: NULL değer.

Dönen Değerler

Değiştirge deyim değişkeni ile ilişkilendirilebilmişse TRUE yoksa FALSE döner.

SQLite3Stmt
SQLite3Stmt::bindValue
SQLite3Stmt


Bir değiştirgenin değerini bir deyim değişkeni ile ilişkilendirir

SQLite3Stmt::bindParam
SQLite3Stmt::clear
SQLite3Stmt
PHP Manual

SQLite3Stmt::bindValue

(PHP 5 >= 5.3.0, PHP 7)

SQLite3Stmt::bindValue — Bir değiştirgenin değerini bir deyim değişkeni ile ilişkilendirir

Açıklama

public bool SQLite3Stmt::bindValue ( string $değişken , mixed $değer [, int $tür ] )

değer'i değişken ile belirtilen deyim değişkeni ile ilişkilendirir.

Değiştirgeler

değişken

değer ile ilişkilendirilecek deyim değişkeninin ismi.

değer

Deyim değişkeni ile ilişkilendirilecek değer.

tür

İlişkilendirilecek değerin veri türü.

  • SQLITE3_INTEGER: İşaretli tamsayı. Değerin büyüklüğüne göre 1, 2, 3, 4, 6 veya 8 bayt genişlikte olabilir.

  • SQLITE3_FLOAT: Gerçek sayı. Bir 8 baytlık IEEE kayan noktalı sayı olarak saklanır.

  • SQLITE3_TEXT: Bir dizge. Veritabanının karakter kodlamasıyla kodlanır (UTF-8, UTF-16BE veya UTF-16-LE).

  • SQLITE3_BLOB: İkil veri. Veri girildiği haliyle saklanır.

  • SQLITE3_NULL: NULL değer.

Dönen Değerler

Değer, deyim değişkeni ile ilişkilendirilebilmişse TRUE yoksa FALSE döner.

Örnekler

Örnek 1 - SQLite3Stmt::bindValue() örneği

<?php
unlink('mysqlitedb.db');
$db = new SQLite3('mysqlitedb.db');

$db->exec('CREATE TABLE foo (id INTEGER, bar STRING)');
$db->exec("INSERT INTO foo (id, bar) VALUES (1, 'Bu bir denemedir')");

$stmt = $db->prepare('SELECT bar FROM foo WHERE id=:id');
$stmt->bindValue(':id', 1, SQLITE3_INTEGER);

$result = $stmt->execute();
var_dump($result->fetchArray());
?>

SQLite3Stmt::bindParam
SQLite3Stmt::clear
SQLite3Stmt


Tüm değiştirge ilişkilendirmelerini temizler

SQLite3Stmt::bindValue
SQLite3Stmt::close
SQLite3Stmt
PHP Manual

SQLite3Stmt::clear

(PHP 5 >= 5.3.0, PHP 7)

SQLite3Stmt::clear — Tüm değiştirge ilişkilendirmelerini temizler

Açıklama

public bool SQLite3Stmt::clear ( void )

Tüm değiştirge ilişkilendirmelerini temizler.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Tüm değiştirge ilişkilendirmelerini temizlenebilmişse TRUE yoksa FALSE döner.

SQLite3Stmt::bindValue
SQLite3Stmt::close
SQLite3Stmt


Hazır deyimi kapatır

SQLite3Stmt::clear
SQLite3Stmt::execute
SQLite3Stmt
PHP Manual

SQLite3Stmt::close

(PHP 5 >= 5.3.0, PHP 7)

SQLite3Stmt::close — Hazır deyimi kapatır

Açıklama

public bool SQLite3Stmt::close ( void )

Hazır deyimi kapatır.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

TRUE döner.

SQLite3Stmt::clear
SQLite3Stmt::execute
SQLite3Stmt


Hazır deyimi çalıştırır ve sonuç kümesini bir nesne olarak döndürür

SQLite3Stmt::close
SQLite3Stmt::paramCount
SQLite3Stmt
PHP Manual

SQLite3Stmt::execute

(PHP 5 >= 5.3.0, PHP 7)

SQLite3Stmt::execute — Hazır deyimi çalıştırır ve sonuç kümesini bir nesne olarak döndürür

Açıklama

public SQLite3Result SQLite3Stmt::execute ( void )

Hazır deyimi çalıştırır ve sonuç kümesini bir nesne olarak döndürür

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

İşlem başarılı olmuşsa bir SQLite3Result nesnesi yoksa FALSE döner.

SQLite3Stmt::close
SQLite3Stmt::paramCount
SQLite3Stmt


Hazır deyimdeki değişken sayısını döndürür

SQLite3Stmt::execute
SQLite3Stmt::readOnly()
SQLite3Stmt
PHP Manual

SQLite3Stmt::paramCount

(PHP 5 >= 5.3.0, PHP 7)

SQLite3Stmt::paramCount — Hazır deyimdeki değişken sayısını döndürür

Açıklama

public int SQLite3Stmt::paramCount ( void )

Hazır deyimdeki değişken sayısını döndürür.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hazır deyimdeki değişken sayısını bir tamsayı olarak döndürür.

SQLite3Stmt::execute
SQLite3Stmt::readOnly()
SQLite3Stmt


Returns whether a statement is definitely read only

SQLite3Stmt::paramCount
SQLite3Stmt::reset
SQLite3Stmt
PHP Manual

SQLite3Stmt::readOnly()

(PHP 5 >= 5.3.6, PHP 7)

SQLite3Stmt::readOnly() — Returns whether a statement is definitely read only

Açıklama

public bool SQLite3Stmt::readOnly ( void )

Returns whether a statement is definitely read only. A statement is considered read only, if it makes no direct changes to the content of the database file. Note that user defined SQL functions might change the database indirectly as a side effect.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if a statement is definitely read only, FALSE otherwise.

SQLite3Stmt::paramCount
SQLite3Stmt::reset
SQLite3Stmt


Hazır deyimi sıfırlar

SQLite3Stmt::readOnly()
SQLite3Result
SQLite3Stmt
PHP Manual

SQLite3Stmt::reset

(PHP 5 >= 5.3.0, PHP 7)

SQLite3Stmt::reset — Hazır deyimi sıfırlar

Açıklama

public bool SQLite3Stmt::reset ( void )

Hazır deyimi çalıştırılmadan önceki durumuna getirir. Sıfırlama sonrası değiştirge ilişkileri dokunulmamış olarak kalır.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Deyim başarıyla sıfırlanabilmişse TRUE yoksa FALSE döner.

SQLite3Stmt::readOnly()
SQLite3Result
SQLite3Stmt


SQLite3Result sınıfı

(PHP 5 >= 5.3.0, PHP 7)

Giriş

SQLite 3 eklentisi için sonuç kümesini temsil eden sınıf.

Sınıf Sözdizimi

SQLite3Result {
/* Methods */
public string columnName ( int $sütunnum )
public int columnType ( int $sütunnum )
public array fetchArray ([ int $kip = SQLITE3_BOTH ] )
public bool finalize ( void )
public int numColumns ( void )
public bool reset ( void )
}

İçindekiler

  • SQLite3Result::columnName — Numarası belirtilen sütunun ismini döndürür
  • SQLite3Result::columnType — Numarası belirtilen sütunun türünü döndürür
  • SQLite3Result::fetchArray — Sonuç satırını bir dizi olarak döndürür
  • SQLite3Result::finalize — Sonuç kümesini kapatır
  • SQLite3Result::numColumns — Sonuç kümesindeki sütun sayısını döndürür
  • SQLite3Result::reset — Sonuç kümesindeki geçerli satırı ilk satır yapar
SQLite3Stmt::reset
SQLite3Result::columnName
SQLite3


Numarası belirtilen sütunun ismini döndürür

SQLite3Result
SQLite3Result::columnType
SQLite3Result
PHP Manual

SQLite3Result::columnName

(PHP 5 >= 5.3.0, PHP 7)

SQLite3Result::columnName — Numarası belirtilen sütunun ismini döndürür

Açıklama

public string SQLite3Result::columnName ( int $sütunnum )

sütunnum ile numarası belirtilen sütunun ismini döndürür.

Değiştirgeler

sütunnum

Sütunun sıra numarası. İlk sütunun numarası 0'dır.

Dönen Değerler

Belirtilen sütunun ismini bir dizge olarak döndürür.

SQLite3Result
SQLite3Result::columnType
SQLite3Result


Numarası belirtilen sütunun türünü döndürür

SQLite3Result::columnName
SQLite3Result::fetchArray
SQLite3Result
PHP Manual

SQLite3Result::columnType

(PHP 5 >= 5.3.0, PHP 7)

SQLite3Result::columnType — Numarası belirtilen sütunun türünü döndürür

Açıklama

public int SQLite3Result::columnType ( int $sütunnum )

sütunnum ile numarası belirtilen sütunun türünü dönürür.

Değiştirgeler

sütunnum

Sütunun sıra numarası. İlk sütunun numarası 0'dır.

Dönen Değerler

Sütunun veri türü olarak şu sabitlerden biri döner: SQLITE3_INTEGER, SQLITE3_FLOAT, SQLITE3_TEXT, SQLITE3_BLOB, SQLITE3_NULL.

SQLite3Result::columnName
SQLite3Result::fetchArray
SQLite3Result


Sonuç satırını bir dizi olarak döndürür

SQLite3Result::columnType
SQLite3Result::finalize
SQLite3Result
PHP Manual

SQLite3Result::fetchArray

(PHP 5 >= 5.3.0, PHP 7)

SQLite3Result::fetchArray — Sonuç satırını bir dizi olarak döndürür

Açıklama

public array SQLite3Result::fetchArray ([ int $kip = SQLITE3_BOTH ] )

Sonuç satırını kip ile belirtildiği gibi satır isimleriyle veya satır numaraları ile ya da her ikisiyle de indisleyerek bir dizi olarak döndürür.

Değiştirgeler

kip

Döndürülecek dizinin nasıl düzenleneceğini belirler. Aşağıdaki sabitlerden biri olabilir. SQLITE3_BOTH öntanımlıdır.

  • SQLITE3_ASSOC: Dizi sütun isimleriyle indislenir.

  • SQLITE3_NUM: Dizi sütun numaraları ile indislenir. İlk sütunun indisi 0'dır.

  • SQLITE3_BOTH: Dizi hem sütun isimleriyle hem de sütun numaraları ile indislenir. İlk sütunun indisi 0'dır.

Dönen Değerler

Satır isimleriyle veya satır numaraları ile ya da her ikisiyle de indislenmiş bir dizi döner.

SQLite3Result::columnType
SQLite3Result::finalize
SQLite3Result


Sonuç kümesini kapatır

SQLite3Result::fetchArray
SQLite3Result::numColumns
SQLite3Result
PHP Manual

SQLite3Result::finalize

(PHP 5 >= 5.3.0, PHP 7)

SQLite3Result::finalize — Sonuç kümesini kapatır

Açıklama

public bool SQLite3Result::finalize ( void )

Sonuç kümesini kapatır.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

TRUE döner.

SQLite3Result::fetchArray
SQLite3Result::numColumns
SQLite3Result


Sonuç kümesindeki sütun sayısını döndürür

SQLite3Result::finalize
SQLite3Result::reset
SQLite3Result
PHP Manual

SQLite3Result::numColumns

(PHP 5 >= 5.3.0, PHP 7)

SQLite3Result::numColumns — Sonuç kümesindeki sütun sayısını döndürür

Açıklama

public int SQLite3Result::numColumns ( void )

Sonuç kümesindeki sütun sayısını döndürür.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Sütun sayısı bir tamsayı olarak döner.

SQLite3Result::finalize
SQLite3Result::reset
SQLite3Result


Sonuç kümesindeki geçerli satırı ilk satır yapar

SQLite3Result::numColumns
SQLSRV
SQLite3Result
PHP Manual

SQLite3Result::reset

(PHP 5 >= 5.3.0, PHP 7)

SQLite3Result::reset — Sonuç kümesindeki geçerli satırı ilk satır yapar

Açıklama

public bool SQLite3Result::reset ( void )

Sonuç kümesindeki geçerli satırı ilk satır yapar.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Sonuç kümesindeki geçerli satır, ilk satır yapılabilmişse TRUE yoksa FALSE döner.

SQLite3Result::numColumns
SQLSRV
SQLite3Result


Microsoft SQL Server Driver for PHP

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • SQLSRV İşlevleri
    • sqlsrv_begin_transaction — Begins a database transaction
    • sqlsrv_cancel — Cancels a statement
    • sqlsrv_client_info — Returns information about the client and specified connection
    • sqlsrv_close — Closes an open connection and releases resourses associated with the connection
    • sqlsrv_commit — Commits a transaction that was begun with sqlsrv_begin_transaction
    • sqlsrv_configure — Changes the driver error handling and logging configurations
    • sqlsrv_connect — Opens a connection to a Microsoft SQL Server database
    • sqlsrv_errors — Returns error and warning information about the last SQLSRV operation performed
    • sqlsrv_execute — Executes a statement prepared with sqlsrv_prepare
    • sqlsrv_fetch_array — Returns a row as an array
    • sqlsrv_fetch_object — Retrieves the next row of data in a result set as an object
    • sqlsrv_fetch — Makes the next row in a result set available for reading
    • sqlsrv_field_metadata — Retrieves metadata for the fields of a statement prepared by sqlsrv_prepare or sqlsrv_query
    • sqlsrv_free_stmt — Frees all resources for the specified statement
    • sqlsrv_get_config — Returns the value of the specified configuration setting
    • sqlsrv_get_field — Gets field data from the currently selected row
    • sqlsrv_has_rows — Indicates whether the specified statement has rows
    • sqlsrv_next_result — Makes the next result of the specified statement active
    • sqlsrv_num_fields — Retrieves the number of fields (columns) on a statement
    • sqlsrv_num_rows — Retrieves the number of rows in a result set
    • sqlsrv_prepare — Prepares a query for execution
    • sqlsrv_query — Prepares and executes a query.
    • sqlsrv_rollback — Rolls back a transaction that was begun with sqlsrv_begin_transaction
    • sqlsrv_rows_affected — Returns the number of rows modified by the last INSERT, UPDATE, or DELETE query executed
    • sqlsrv_send_stream_data — Sends data from parameter streams to the server
    • sqlsrv_server_info — Returns information about the server
SQLite3Result::reset
Giriş
Sağlayıcıya Göre Veritabanı Eklentileri


Giriş

The SQLSRV extension allows you to access Microsoft SQL Server and SQL Azure databases when running PHP on Windows. The 3.0 release of the driver supports SQL Server, beginning with SQL Server 2005, including SQL Server 2012 and SQL Server 2012 LocalDB. (For more information about LocalDB, see » PHP Driver for SQL Server Support for LocalDB and » SQL Server 2012 Express LocalDB.)

The SQLSRV extension is supported by Microsoft and available for download here: » http://msdn.microsoft.com/en-us/sqlserver/ff657782.aspx. SQL Server 2012 LocalDB can be downloaded here: » http://go.microsoft.com/fwlink/?LinkID=237665.

SQLSRV
Yapılandırma/Kurulum
SQLSRV


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
SQLSRV


Gereksinimler

The SQLSRV extension can be used on the following operating systems:

  • Windows Vista Service Pack 2 or later
  • Windows Server 2008 Service Pack 2 or later
  • Windows Server 2008 R2
  • Windows 7

The SQLSRV extension requires that the Microsoft SQL Server 2012 Native Client be installed on the same computer that is running PHP. If the Microsoft SQL Server 2012 Native Client is not already installed, click the appropriate link below to download it:

  • » Download the x86 package
  • » Download the x64 package

The SQLSRV download comes 8 driver files, four of which are for PDO support. If you are running non-thread-safe PHP (PHP 5.3), use the php_sqlsrv_53_nts.dll file. (You should use a non-thread-safe version if you are using IIS as your web server). If you are running thread-safe PHP, use the php_sqlsrv_53_ts.dll file. Similarly for PHP 5.4, use the php_sqlsrv_54_nts.dll or php_sqlsrv_54_ts.dll depending on whether your PHP installation is non-thread-safe or thread-safe.

The most recent version of the driver is available for download here: » SQLSRV 3.0 download. If you need support for PHP 5.2 and/or PHP compiled with VC6, use the 2.0 release of the driver: » SQLSRV 2.0 download.

For more information about SQLSRV requirements, see » SQLSRV System Requirements.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

The SQLSRV extension is enabled by adding appropriate DLL file to your PHP extension directory and the corresponding entry to the php.ini file. The SQLSRV download comes 8 driver files, four of which are for PDO support. If you are running non-thread-safe PHP (PHP 5.3), use the php_sqlsrv_53_nts.dll file. (You should use a non-thread-safe version if you are using IIS as your web server). If you are running thread-safe PHP, use the php_sqlsrv_53_ts.dll file. Similarly for PHP 5.4, use the php_sqlsrv_54_nts.dll or php_sqlsrv_54_ts.dll depending on whether your PHP installation is non-thread-safe or thread-safe.

The most recent version of the driver is available for download here: » SQLSRV 3.0 download. If you need support for PHP 5.2 and/or PHP compiled with VC6, use the 2.0 release of the driver: » SQLSRV 2.0 download.

For more information about SQLSRV requirements, see » SQLSRV System Requirements.

The SQLSRV extension is only compatible with PHP running on Windows.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

The following table lists the configuration options available in the SQLSRV extension. For more information about these options, see » Handling SQLSRV Warnings and Errors.

SQLSRV Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Changelog
sqlsrv.WarningsReturnAsErrors | 1 (TRUE) | PHP_INI_ALL | Available since SQLSRV 1.0
sqlsrv.LogSubsystems | 0 | PHP_INI_ALL | Available since SQLSRV 1.0
sqlsrv.LogSeverity | 1 | PHP_INI_ALL | Available since SQLSRV 1.0

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Özkaynak Türleri

Connection resource

A connection resource returned by sqlsrv_connect().

Statement resource

A statement resource returned by sqlsrv_query() or by sqlsrv_prepare().

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

SQLSRV_FETCH_ASSOC (integer)
Forces sqlsrv_fetch_array() to return an associative array when passed as a parameter.
SQLSRV_FETCH_NUMERIC (integer)
Forces sqlsrv_fetch_array() to return an array with numeric when passed as a parameter.
SQLSRV_FETCH_BOTH (integer)
Forces sqlsrv_fetch_array() to return an array with both associative and numeric keys when passed as a parameter (the default behavior).
SQLSRV_ERR_ALL (integer)
Forces sqlsrv_errors() to return both errors and warings when passed as a parameter (the default behavior).
SQLSRV_ERR_ERRORS (integer)
Forces sqlsrv_errors() to return errors only (no warnings) when passed as a parameter.
SQLSRV_ERR_WARNINGS (integer)
Forces sqlsrv_errors() to return warnings only (no errors) when passed as a parameter.
SQLSRV_LOG_SYSTEM_ALL (integer)
Turns on logging of all subsystems when passed to sqlsrv_configure() as a parameter.
SQLSRV_LOG_SYSTEM_CONN (integer)
Turns on logging of connection activity when passed to sqlsrv_configure() as a parameter.
SQLSRV_LOG_SYSTEM_INIT (integer)
Turns on logging of initialization activity when passed to sqlsrv_configure() as a parameter.
SQLSRV_LOG_SYSTEM_OFF (integer)
Turns off logging of all subsystems when passed to sqlsrv_configure() as a parameter.
SQLSRV_LOG_SYSTEM_STMT (integer)
Turns on logging of statement activity when passed to sqlsrv_configure() as a parameter.
SQLSRV_LOG_SYSTEM_UTIL (integer)
Turns on logging of error function activity when passed to sqlsrv_configure() as a parameter.
SQLSRV_LOG_SEVERITY_ALL (integer)
Specifies that errors, warnings, and notices will be logged when passed to sqlsrv_configure() as a parameter.
SQLSRV_LOG_SEVERITY_ERROR (integer)
Specifies that errors will be logged when passed to sqlsrv_configure() as a parameter.
SQLSRV_LOG_SEVERITY_NOTICE (integer)
Specifies that notices will be logged when passed to sqlsrv_configure() as a parameter.
SQLSRV_LOG_SEVERITY_WARNING (integer)
Specifies that warnings will be logged when passed to sqlsrv_configure() as a parameter.
SQLSRV_NULLABLE_YES (integer)
Indicates that a column is nullable.
SQLSRV_NULLABLE_NO (integer)
Indicates that a column is not nullable.
SQLSRV_NULLABLE_UNKNOWN (integer)
Indicates that it is not known if a column is nullable.
SQLSRV_PARAM_IN (integer)
Indicates an input parameter when passed to sqlsrv_query() or sqlsrv_prepare().
SQLSRV_PARAM_INOUT (integer)
Indicates a bidirectional parameter when passed to sqlsrv_query() or sqlsrv_prepare().
SQLSRV_PARAM_OUT (integer)
Indicates an output parameter when passed to sqlsrv_query() or sqlsrv_prepare().
SQLSRV_PHPTYPE_INT (integer)
Specifies an integer PHP data type. For usage information, see » How to: Specify PHP Types.
SQLSRV_PHPTYPE_DATETIME (integer)
Specifies a datetime PHP data type. For usage information, see » How to: Specify PHP Types.
SQLSRV_PHPTYPE_FLOAT (integer)
Specifies a float PHP data type. For usage information, see » How to: Specify PHP Types.
SQLSRV_PHPTYPE_STREAM (integer)
Specifies a PHP stream. This constant works like a function and accepts an encoding constant. See the SQLSRV_ENC_* constants. For usage information, see » How to: Specify PHP Types.
SQLSRV_PHPTYPE_STRING (integer)
Specifies a string PHP data type. This constant works like a function and accepts an encoding constant. See the SQLSRV_ENC_* constants. For usage information, see » How to: Specify PHP Types.
SQLSRV_ENC_BINARY (integer)
Specifies that data is returned as a raw byte stream from the server without performing encoding or translation. For usage information, see » How to: Specify PHP Types.
SQLSRV_ENC_CHAR (integer)
Data is returned in 8-bit characters as specified in the code page of the Windows locale that is set on the system. Any multi-byte characters or characters that do not map into this code page are substituted with a single byte question mark (?) character. This is the default encoding. For usage information, see » How to: Specify PHP Types.
UTF-8 (integer)
Specifies that data is returned with UTF-8 encoding. For usage information, see » How to: Specify PHP Types.
SQLSRV_SQLTYPE_BIGINT (integer)
Describes the bigint SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_BINARY (integer)
Describes the binary SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_BIT (integer)
Describes the bit SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_CHAR (integer)
Describes the char SQL Server data type. This constant works like a function and accepts a parameter indicating the number characters. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_DATE (integer)
Describes the date SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_DATETIME (integer)
Describes the datetime SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_DATETIME2 (integer)
Describes the datetime2 SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_DATETIMEOFFSET (integer)
Describes the datetimeoffset SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_DECIMAL (integer)
Describes the decimal SQL Server data type. This constant works like a function and accepts two parameters indicating (in order) precision and scale. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_FLOAT (integer)
Describes the float SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_IMAGE (integer)
Describes the image SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_INT (integer)
Describes the int SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_MONEY (integer)
Describes the money SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_NCHAR (integer)
Describes the nchar SQL Server data type. This constant works like a function and accepts a single parameter indicating the character count. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_NUMERIC (integer)
Describes the numeric SQL Server data type. This constant works like a function and accepts two parameter indicating (in order) precision and scale. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_NVARCHAR (integer)
Describes the nvarchar SQL Server data type. This constant works like a function and accepts a single parameter indicating the character count. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_NVARCHAR('max') (integer)
Describes the nvarchar(MAX) SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_NTEXT (integer)
Describes the ntext SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_REAL (integer)
Describes the real SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_SMALLDATETIME (integer)
Describes the smalldatetime SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_SMALLINT (integer)
Describes the smallint SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_SMALLMONEY (integer)
Describes the smallmoney SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_TEXT (integer)
Describes the text SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_TIME (integer)
Describes the time SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_TIMESTAMP (integer)
Describes the timestamp SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_TINYINT (integer)
Describes the tinyint SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_UNIQUEIDENTIFIER (integer)
Describes the uniqueidentifier SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_UDT (integer)
Describes the UDT SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_VARBINARY (integer)
Describes the varbinary SQL Server data type. This constant works like a function and accepts a single parameter indicating the byte count. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_VARBINARY('max') (integer)
Describes the varbinary(MAX) SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_VARCHAR (integer)
Describes the varchar SQL Server data type. This constant works like a function and accepts a single parameter indicating the character count. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_VARCHAR('max') (integer)
Describes the varchar(MAX) SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_SQLTYPE_XML (integer)
Describes the XML SQL Server data type. For usage information, see » How to: Specify SQL Types.
SQLSRV_TXN_READ_UNCOMMITTED (integer)
Inidicates a transaction isolation level of READ UNCOMMITTED. This value is used to set the TransactionIsolation level in the $connectionOptions arrary passed to sqlsrv_connect().
SQLSRV_TXN_READ_COMMITTED (integer)
Inidicates a transaction isolation level of READ COMMITTED. This value is used to set the TransactionIsolation level in the $connectionOptions arrary passed to sqlsrv_connect().
SQLSRV_TXN_REPEATABLE_READ (integer)
Inidicates a transaction isolation level of REPEATABLE READ. This value is used to set the TransactionIsolation level in the $connectionOptions arrary passed to sqlsrv_connect().
SQLSRV_TXN_SNAPSHOT (integer)
Inidicates a transaction isolation level of SNAPSHOT. This value is used to set the TransactionIsolation level in the $connectionOptions arrary passed to sqlsrv_connect().
SQLSRV_TXN_READ_SERIALIZABLE (integer)
Inidicates a transaction isolation level of SERIALIZABLE. This value is used to set the TransactionIsolation level in the $connectionOptions arrary passed to sqlsrv_connect().
SQLSRV_CURSOR_FORWARD (integer)
Inidicates a forward-only cursor. For usage information, see » Specifying a Cursor Type and Selecting Rows.
SQLSRV_CURSOR_STATIC (integer)
Inidicates a static cursor. For usage information, see » Specifying a Cursor Type and Selecting Rows.
SQLSRV_CURSOR_DYNAMIC (integer)
Inidicates a dynamic cursor. For usage information, see » Specifying a Cursor Type and Selecting Rows.
SQLSRV_CURSOR_KEYSET (integer)
Inidicates a keyset cursor. For usage information, see » Specifying a Cursor Type and Selecting Rows.
SQLSRV_CURSOR_BUFFERED (integer)
Creates a client-side cursor query. Lets you access rows in any order. For usage information, see » Specifying a Cursor Type and Selecting Rows.
SQLSRV_SCROLL_NEXT (integer)
Specifies which row to select in a result set. For usage information, see » Specifying a Cursor Type and Selecting Rows.
SQLSRV_SCROLL_PRIOR (integer)
Specifies which row to select in a result set. For usage information, see » Specifying a Cursor Type and Selecting Rows.
SQLSRV_SCROLL_FIRST (integer)
Specifies which row to select in a result set. For usage information, see » Specifying a Cursor Type and Selecting Rows.
SQLSRV_SCROLL_LAST (integer)
Specifies which row to select in a result set. For usage information, see » Specifying a Cursor Type and Selecting Rows.
SQLSRV_SCROLL_ABSOLUTE (integer)
Specifies which row to select in a result set. For usage information, see » Specifying a Cursor Type and Selecting Rows.
SQLSRV_SCROLL_RELATIVE (integer)
Specifies which row to select in a result set. For usage information, see » Specifying a Cursor Type and Selecting Rows.

Özkaynak Türleri
SQLSRV İşlevleri
SQLSRV


SQLSRV İşlevleri

İçindekiler

  • sqlsrv_begin_transaction — Begins a database transaction
  • sqlsrv_cancel — Cancels a statement
  • sqlsrv_client_info — Returns information about the client and specified connection
  • sqlsrv_close — Closes an open connection and releases resourses associated with the connection
  • sqlsrv_commit — Commits a transaction that was begun with sqlsrv_begin_transaction
  • sqlsrv_configure — Changes the driver error handling and logging configurations
  • sqlsrv_connect — Opens a connection to a Microsoft SQL Server database
  • sqlsrv_errors — Returns error and warning information about the last SQLSRV operation performed
  • sqlsrv_execute — Executes a statement prepared with sqlsrv_prepare
  • sqlsrv_fetch_array — Returns a row as an array
  • sqlsrv_fetch_object — Retrieves the next row of data in a result set as an object
  • sqlsrv_fetch — Makes the next row in a result set available for reading
  • sqlsrv_field_metadata — Retrieves metadata for the fields of a statement prepared by sqlsrv_prepare or sqlsrv_query
  • sqlsrv_free_stmt — Frees all resources for the specified statement
  • sqlsrv_get_config — Returns the value of the specified configuration setting
  • sqlsrv_get_field — Gets field data from the currently selected row
  • sqlsrv_has_rows — Indicates whether the specified statement has rows
  • sqlsrv_next_result — Makes the next result of the specified statement active
  • sqlsrv_num_fields — Retrieves the number of fields (columns) on a statement
  • sqlsrv_num_rows — Retrieves the number of rows in a result set
  • sqlsrv_prepare — Prepares a query for execution
  • sqlsrv_query — Prepares and executes a query.
  • sqlsrv_rollback — Rolls back a transaction that was begun with sqlsrv_begin_transaction
  • sqlsrv_rows_affected — Returns the number of rows modified by the last INSERT, UPDATE, or DELETE query executed
  • sqlsrv_send_stream_data — Sends data from parameter streams to the server
  • sqlsrv_server_info — Returns information about the server
Öntanımlı Sabitler
sqlsrv_begin_transaction
SQLSRV


Begins a database transaction

SQLSRV İşlevleri
sqlsrv_cancel
SQLSRV İşlevleri
PHP Manual

sqlsrv_begin_transaction

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

sqlsrv_begin_transaction — Begins a database transaction

Açıklama

bool sqlsrv_begin_transaction ( resource $conn )

The transaction begun by sqlsrv_begin_transaction() includes all statements that were executed after the call to sqlsrv_begin_transaction() and before calls to sqlsrv_rollback() or sqlsrv_commit(). Explicit transactions should be started and committed or rolled back using these functions instead of executing SQL statements that begin and committ/roll back transactions. For more information, see » SQLSRV Transactions.

Değiştirgeler

conn

The connection resource returned by a call to sqlsrv_connect().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 sqlsrv_begin_transaction() example

The following example demonstrates how to use sqlsrv_begin_transaction() together with sqlsrv_commit() and sqlsrv_rollback().

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"userName", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false ) {
    die( print_r( sqlsrv_errors(), true ));
}

/* Begin the transaction. */
if ( sqlsrv_begin_transaction( $conn ) === false ) {
     die( print_r( sqlsrv_errors(), true ));
}

/* Initialize parameter values. */
$orderId = 1; $qty = 10; $productId = 100;

/* Set up and execute the first query. */
$sql1 = "INSERT INTO OrdersTable (ID, Quantity, ProductID)
          VALUES (?, ?, ?)";
$params1 = array( $orderId, $qty, $productId );
$stmt1 = sqlsrv_query( $conn, $sql1, $params1 );

/* Set up and execute the second query. */
$sql2 = "UPDATE InventoryTable
          SET Quantity = (Quantity - ?)
          WHERE ProductID = ?";
$params2 = array($qty, $productId);
$stmt2 = sqlsrv_query( $conn, $sql2, $params2 );

/* If both queries were successful, commit the transaction. */
/* Otherwise, rollback the transaction. */
if( $stmt1 && $stmt2 ) {
     sqlsrv_commit( $conn );
     echo "Transaction committed.<br />";
} else {
     sqlsrv_rollback( $conn );
     echo "Transaction rolled back.<br />";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ayrıca Bakınız

  • sqlsrv_commit() - Commits a transaction that was begun with sqlsrv_begin_transaction
  • sqlsrv_rollback() - Rolls back a transaction that was begun with sqlsrv_begin_transaction

SQLSRV İşlevleri
sqlsrv_cancel
SQLSRV İşlevleri


Cancels a statement

sqlsrv_begin_transaction
sqlsrv_client_info
SQLSRV İşlevleri
PHP Manual

sqlsrv_cancel

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

sqlsrv_cancel — Cancels a statement

Açıklama

bool sqlsrv_cancel ( resource $stmt )

Cancels a statement. Any results associated with the statement that have not been consumed are deleted. After sqlsrv_cancel() has been called, the specified statement can be re-executed if it was created with sqlsrv_prepare(). Calling sqlsrv_cancel() is not necessary if all the results associated with the statement have been consumed.

Değiştirgeler

stmt

The statement resource to be cancelled.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 sqlsrv_cancel() example

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false ) {
     die( print_r( sqlsrv_errors(), true));
}

$sql = "SELECT Sales FROM Table_1";

$stmt = sqlsrv_prepare( $conn, $sql);

if( $stmt === false ) {
     die( print_r( sqlsrv_errors(), true));
}

if( sqlsrv_execute( $stmt ) === false) {
     die( print_r( sqlsrv_errors(), true));
}

$salesTotal = 0;
$count = 0;

while( ($row = sqlsrv_fetch_array( $stmt)) && $salesTotal <=100000)
{
     $qty = $row[0];
     $price = $row[1];
     $salesTotal += ( $price * $qty);
     $count++;
}

echo "$count sales accounted for the first $$salesTotal in revenue.<br />";

// Cancel the pending results. The statement can be reused.
sqlsrv_cancel( $stmt);
?>

Notlar

The main difference between sqlsrv_cancel() and sqlsrv_free_stmt() is that a statement resource cancelled with sqlsrv_cancel() can be re-executed if it was created with sqlsrv_prepare(). A statement resource cancelled with sqlsrv_free_statement() cannot be re-executed.

Ayrıca Bakınız

  • sqlsrv_free_stmt() - Frees all resources for the specified statement
  • sqlsrv_prepare() - Prepares a query for execution

sqlsrv_begin_transaction
sqlsrv_client_info
SQLSRV İşlevleri


Returns information about the client and specified connection

sqlsrv_cancel
sqlsrv_close
SQLSRV İşlevleri
PHP Manual

sqlsrv_client_info

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

sqlsrv_client_info — Returns information about the client and specified connection

Açıklama

array sqlsrv_client_info ( resource $conn )

Returns information about the client and specified connection

Değiştirgeler

conn

The connection about which information is returned.

Dönen Değerler

Returns an associative array with keys described in the table below. Returns FALSE otherwise.

Array returned by sqlsrv_client_info
Key | Description
DriverDllName | SQLNCLI10.DLL
DriverODBCVer | ODBC version (xx.yy)
DriverVer | SQL Server Native Client DLL version (10.5.xxx)
ExtensionVer | php_sqlsrv.dll version (2.0.xxx.x)

Örnekler

Örnek 1 sqlsrv_client_info() example

<?php
$serverName = "serverName\sqlexpress";
$connOptions = array("UID"=>"username", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connOptions );

if( $conn === false ) {
    die( print_r( sqlsrv_errors(), true));
}

if( $client_info = sqlsrv_client_info( $conn)) {
    foreach( $client_info as $key => $value) {
        echo $key.": ".$value."<br />";
    }
} else {
    echo "Error in retrieving client info.<br />";
}
?>

Ayrıca Bakınız

  • sqlsrv_server_info() - Returns information about the server

sqlsrv_cancel
sqlsrv_close
SQLSRV İşlevleri


Closes an open connection and releases resourses associated with the connection

sqlsrv_client_info
sqlsrv_commit
SQLSRV İşlevleri
PHP Manual

sqlsrv_close

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

sqlsrv_close — Closes an open connection and releases resourses associated with the connection

Açıklama

bool sqlsrv_close ( resource $conn )

Closes an open connection and releases resourses associated with the connection.

Değiştirgeler

conn

The connection to be closed.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 sqlsrv_close() example

<?php
$serverName = "serverName\sqlexpres";
$connOptions = array("UID"=>"username", "PWD"=>"password", "Database"=>"dbname");
$conn = sqlsrv_connect( $serverName, $connOptions );
if( $conn === false ) {
     die( print_r( sqlsrv_errors(), true));
}

//-------------------------------------
// Perform database operations here.
//-------------------------------------

// Close the connection.
sqlsrv_close( $conn );
?>

Ayrıca Bakınız

  • sqlsrv_connect() - Opens a connection to a Microsoft SQL Server database

sqlsrv_client_info
sqlsrv_commit
SQLSRV İşlevleri


Commits a transaction that was begun with sqlsrv_begin_transaction

sqlsrv_close
sqlsrv_configure
SQLSRV İşlevleri
PHP Manual

sqlsrv_commit

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

sqlsrv_commit — Commits a transaction that was begun with sqlsrv_begin_transaction()

Açıklama

bool sqlsrv_commit ( resource $conn )

Commits a transaction that was begun with sqlsrv_begin_transaction(). The connection is returned to auto-commit mode after sqlsrv_commit() is called. The transaction that is committed includes all statements that were executed after the call to sqlsrv_begin_transaction(). Explicit transactions should be started and committed or rolled back using these functions instead of executing SQL statements that begin and committ/roll back transactions. For more information, see » SQLSRV Transactions.

Değiştirgeler

conn

The connection on which the transaction is to be committed.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 sqlsrv_commit() example

The following example demonstrates how to use sqlsrv_commit() together with sqlsrv_begin_transaction() and sqlsrv_rollback().

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"userName", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false ) {
    die( print_r( sqlsrv_errors(), true ));
}

/* Begin the transaction. */
if ( sqlsrv_begin_transaction( $conn ) === false ) {
     die( print_r( sqlsrv_errors(), true ));
}

/* Initialize parameter values. */
$orderId = 1; $qty = 10; $productId = 100;

/* Set up and execute the first query. */
$sql1 = "INSERT INTO OrdersTable (ID, Quantity, ProductID)
         VALUES (?, ?, ?)";
$params1 = array( $orderId, $qty, $productId );
$stmt1 = sqlsrv_query( $conn, $sql1, $params1 );

/* Set up and execute the second query. */
$sql2 = "UPDATE InventoryTable
         SET Quantity = (Quantity - ?)
         WHERE ProductID = ?";
$params2 = array($qty, $productId);
$stmt2 = sqlsrv_query( $conn, $sql2, $params2 );

/* If both queries were successful, commit the transaction. */
/* Otherwise, rollback the transaction. */
if( $stmt1 && $stmt2 ) {
     sqlsrv_commit( $conn );
     echo "Transaction committed.<br />";
} else {
     sqlsrv_rollback( $conn );
     echo "Transaction rolled back.<br />";
}
?>

Ayrıca Bakınız

  • sqlsrv_begin_transaction() - Begins a database transaction
  • sqlsrv_rollback() - Rolls back a transaction that was begun with sqlsrv_begin_transaction

sqlsrv_close
sqlsrv_configure
SQLSRV İşlevleri


Changes the driver error handling and logging configurations

sqlsrv_commit
sqlsrv_connect
SQLSRV İşlevleri
PHP Manual

sqlsrv_configure

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

sqlsrv_configure — Changes the driver error handling and logging configurations

Açıklama

bool sqlsrv_configure ( string $setting , mixed $value )

Changes the driver error handling and logging configurations.

Değiştirgeler

setting

The name of the setting to set. The possible values are "WarningsReturnAsErrors", "LogSubsystems", and "LogSeverity".

value

The value of the specified setting. The following table shows possible values:

Error and Logging Setting Options
Setting | Options
WarningsReturnAsErrors | 1 (TRUE) or 0 (FALSE)
LogSubsystems | SQLSRV_LOG_SYSTEM_ALL (-1) SQLSRV_LOG_SYSTEM_CONN (2) SQLSRV_LOG_SYSTEM_INIT (1) SQLSRV_LOG_SYSTEM_OFF (0) SQLSRV_LOG_SYSTEM_STMT (4) SQLSRV_LOG_SYSTEM_UTIL (8)
LogSeverity | SQLSRV_LOG_SEVERITY_ALL (-1) SQLSRV_LOG_SEVERITY_ERROR (1) SQLSRV_LOG_SEVERITY_NOTICE (4) SQLSRV_LOG_SEVERITY_WARNING (2)

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • » SQLSRV Error Handling.
  • » Logging SQLSRV Activity.

sqlsrv_commit
sqlsrv_connect
SQLSRV İşlevleri


Opens a connection to a Microsoft SQL Server database

sqlsrv_configure
sqlsrv_errors
SQLSRV İşlevleri
PHP Manual

sqlsrv_connect

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

sqlsrv_connect — Opens a connection to a Microsoft SQL Server database

Açıklama

resource sqlsrv_connect ( string $serverName [, array $connectionInfo ] )

Opens a connection to a Microsoft SQL Server database. By default, the connection is attempted using Windows Authentication. To connect using SQL Server Authentication, include "UID" and "PWD" in the connection options array.

Değiştirgeler

serverName

The name of the server to which a connection is established. To connect to a specific instance, follow the server name with a backward slash and the instance name (e.g. serverName\sqlexpress).

connectionInfo

An associative array that specifies options for connecting to the server. If values for the UID and PWD keys are not specified, the connection will be attempted using Windows Authentication. For a complete list of supported keys, see » SQLSRV Connection Options.

Dönen Değerler

A connection resource. If a connection cannot be successfully opened, FALSE is returned.

Örnekler

Örnek 1 Connect using Windows Authentication.

<?php
$serverName = "serverName\sqlexpress"; //serverName\instanceName

// Since UID and PWD are not specified in the $connectionInfo array,
// The connection will be attempted using Windows Authentication.
$connectionInfo = array( "Database"=>"dbName");
$conn = sqlsrv_connect( $serverName, $connectionInfo);

if( $conn ) {
     echo "Connection established.<br />";
}else{
     echo "Connection could not be established.<br />";
     die( print_r( sqlsrv_errors(), true));
}
?>

Örnek 2 Connect by specifying a user name and password.

<?php
$serverName = "serverName\sqlexpress"; //serverName\instanceName
$connectionInfo = array( "Database"=>"dbName", "UID"=>"userName", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);

if( $conn ) {
     echo "Connection established.<br />";
}else{
     echo "Connection could not be established.<br />";
     die( print_r( sqlsrv_errors(), true));
}
?>

Örnek 3 Connect on a specifed port.

<?php
$serverName = "serverName\sqlexpress, 1542"; //serverName\instanceName, portNumber (default is 1433)
$connectionInfo = array( "Database"=>"dbName", "UID"=>"userName", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);

if( $conn ) {
     echo "Connection established.<br />";
}else{
     echo "Connection could not be established.<br />";
     die( print_r( sqlsrv_errors(), true));
}
?>

Notlar

By default, the sqlsrv_connect() uses connection pooling to improve connection performance. To turn off connection pooling (i.e. force a new connection on each call), set the "ConnectionPooling" option in the $connectionOptions array to 0 (or FALSE). For more information, see » SQLSRV Connection Pooling.

The SQLSRV extension does not have a dedicated function for changing which database is connected to. The target database is specified in the $connectionOptions array that is passed to sqlsrv_connect. To change the database on an open connection, execute the following query "USE dbName" (e.g. sqlsrv_query($conn, "USE dbName")).

Ayrıca Bakınız

  • sqlsrv_close() - Closes an open connection and releases resourses associated with the connection
  • sqlsrv_errors() - Returns error and warning information about the last SQLSRV operation performed
  • sqlsrv_query() - Prepares and executes a query.

sqlsrv_configure
sqlsrv_errors
SQLSRV İşlevleri


Returns error and warning information about the last SQLSRV operation performed

sqlsrv_connect
sqlsrv_execute
SQLSRV İşlevleri
PHP Manual

sqlsrv_errors

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

sqlsrv_errors — Returns error and warning information about the last SQLSRV operation performed

Açıklama

mixed sqlsrv_errors ([ int $errorsOrWarnings ] )

Returns error and warning information about the last SQLSRV operation performed.

Değiştirgeler

errorsOrWarnings

Determines whether error information, warning information, or both are returned. If this parameter is not supplied, both error information and warning information are returned. The following are the supported values for this parameter: SQLSRV_ERR_ALL, SQLSRV_ERR_ERRORS, SQLSRV_ERR_WARNINGS.

Dönen Değerler

If errors and/or warnings occurred on the last sqlsrv operation, an array of arrays containing error information is returned. If no errors and/or warnings occurred on the last sqlsrv operation, NULL is returned. The following table describes the structure of the returned arrays:

Array returned by sqlsrv_errors
Key | Description
SQLSTATE | For errors that originate from the ODBC driver, the SQLSTATE returned by ODBC. For errors that originate from the Microsoft Drivers for PHP for SQL Server, a SQLSTATE of IMSSP. For warnings that originate from the Microsoft Drivers for PHP for SQL Server, a SQLSTATE of 01SSP.
code | For errors that originate from SQL Server, the native SQL Server error code. For errors that originate from the ODBC driver, the error code returned by ODBC. For errors that originate from the Microsoft Drivers for PHP for SQL Server, the Microsoft Drivers for PHP for SQL Server error code.
message | A description of the error.

Örnekler

Örnek 1 functionname() example

<?php
$serverName = "serverName/sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false ) {
     die( print_r( sqlsrv_errors(), true));
}

/* Set up a query to select an invalid column name. */
$sql = "SELECT BadColumnName FROM Table_1";

/* Execution of the query will fail because of the bad column name. */
$stmt = sqlsrv_query( $conn, $sql );
if( $stmt === false ) {
    if( ($errors = sqlsrv_errors() ) != null) {
        foreach( $errors as $error ) {
            echo "SQLSTATE: ".$error[ 'SQLSTATE']."<br />";
            echo "code: ".$error[ 'code']."<br />";
            echo "message: ".$error[ 'message']."<br />";
        }
    }
}
?>

Notlar

By default, warnings generated on a call to any SQLSRV function are treated as errors. This means that if a warning occurs on a call to a SQLSRV function, the function returns FALSE. However, warnings that correspond to SQLSTATE values 01000, 01001, 01003, and 01S02 are never treated as errors. For information about changing this behavior, see sqlsrv_configure() and the WarningsReturnAsErrors setting.

Ayrıca Bakınız

  • sqlsrv_configure() - Changes the driver error handling and logging configurations

sqlsrv_connect
sqlsrv_execute
SQLSRV İşlevleri


Executes a statement prepared with sqlsrv_prepare

sqlsrv_errors
sqlsrv_fetch_array
SQLSRV İşlevleri
PHP Manual

sqlsrv_execute

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

sqlsrv_execute — Executes a statement prepared with sqlsrv_prepare()

Açıklama

bool sqlsrv_execute ( resource $stmt )

Executes a statement prepared with sqlsrv_prepare(). This function is ideal for executing a prepared statement multiple times with different parameter values.

Değiştirgeler

stmt

A statement resource returned by sqlsrv_prepare().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 sqlsrv_execute() example

This example demonstrates how to prepare a statement with sqlsrv_prepare() and re-execute it multiple times (with different parameter values) using sqlsrv_execute().

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false) {
    die( print_r( sqlsrv_errors(), true));
}

$sql = "UPDATE Table_1
        SET OrderQty = ?
        WHERE SalesOrderID = ?";

// Initialize parameters and prepare the statement.
// Variables $qty and $id are bound to the statement, $stmt.
$qty = 0; $id = 0;
$stmt = sqlsrv_prepare( $conn, $sql, array( &$qty, &$id));
if( !$stmt ) {
    die( print_r( sqlsrv_errors(), true));
}

// Set up the SalesOrderDetailID and OrderQty information.
// This array maps the order ID to order quantity in key=>value pairs.
$orders = array( 1=>10, 2=>20, 3=>30);

// Execute the statement for each order.
foreach( $orders as $id => $qty) {
    // Because $id and $qty are bound to $stmt1, their updated
    // values are used with each execution of the statement.
    if( sqlsrv_execute( $stmt ) === false ) {
          die( print_r( sqlsrv_errors(), true));
    }
}
?>

Notlar

When you prepare a statement that uses variables as parameters, the variables are bound to the statement. This means that if you update the values of the variables, the next time you execute the statement it will run with updated parameter values. For statements that you plan to execute only once, use sqlsrv_query().

Ayrıca Bakınız

  • sqlsrv_prepare() - Prepares a query for execution
  • sqlsrv_query() - Prepares and executes a query.

sqlsrv_errors
sqlsrv_fetch_array
SQLSRV İşlevleri


Returns a row as an array

sqlsrv_execute
sqlsrv_fetch_object
SQLSRV İşlevleri
PHP Manual

sqlsrv_fetch_array

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

sqlsrv_fetch_array — Returns a row as an array

Açıklama

array sqlsrv_fetch_array ( resource $stmt [, int $fetchType [, int $row [, int $offset ]]] )

Returns the next available row of data as an associative array, a numeric array, or both (the default).

Değiştirgeler

stmt

A statement resource returned by sqlsrv_query or sqlsrv_prepare.

fetchType

A predefined constant specifying the type of array to return. Possible values are SQLSRV_FETCH_ASSOC, SQLSRV_FETCH_NUMERIC, and SQLSRV_FETCH_BOTH (the default).

A fetch type of SQLSRV_FETCH_ASSOC should not be used when consuming a result set with multiple columns of the same name.

row

Specifies the row to access in a result set that uses a scrollable cursor. Possible values are SQLSRV_SCROLL_NEXT, SQLSRV_SCROLL_PRIOR, SQLSRV_SCROLL_FIRST, SQLSRV_SCROLL_LAST, SQLSRV_SCROLL_ABSOLUTE and, SQLSRV_SCROLL_RELATIVE (the default). When this parameter is specified, the fetchType must be explicitly defined.

offset

Specifies the row to be accessed if the row parameter is set to SQLSRV_SCROLL_ABSOLUTE or SQLSRV_SCROLL_RELATIVE. Note that the first row in a result set has index 0.

Dönen Değerler

Returns an array on success, NULL if there are no more rows to return, and FALSE if an error occurs.

Örnekler

Örnek 1 Retrieving an associative array.

<?php
$serverName = "serverName\instanceName";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo );
if( $conn === false ) {
    die( print_r( sqlsrv_errors(), true));
}

$sql = "SELECT FirstName, LastName FROM SomeTable";
$stmt = sqlsrv_query( $conn, $sql );
if( $stmt === false) {
    die( print_r( sqlsrv_errors(), true) );
}

while( $row = sqlsrv_fetch_array( $stmt, SQLSRV_FETCH_ASSOC) ) {
      echo $row['LastName'].", ".$row['FirstName']."<br />";
}

sqlsrv_free_stmt( $stmt);
?>

Örnek 2 Retrieving a numeric array.

<?php
$serverName = "serverName\instanceName";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo );
if( $conn === false ) {
    die( print_r( sqlsrv_errors(), true));
}

$sql = "SELECT FirstName, LastName FROM SomeTable";
$stmt = sqlsrv_query( $conn, $sql );
if( $stmt === false) {
    die( print_r( sqlsrv_errors(), true) );
}

while( $row = sqlsrv_fetch_array( $stmt, SQLSRV_FETCH_NUMERIC) ) {
      echo $row[0].", ".$row[1]."<br />";
}

sqlsrv_free_stmt( $stmt);
?>

Notlar

Not specifying the fetchType or explicity using the SQLSRV_FETCH_TYPE constant in the examples above will return an array that has both associative and numeric keys.

If more than one column is returned with the same name, the last column will take precedence. To avoid field name collisions, use aliases.

If a column with no name is returned, the associative key for the array element will be an empty string ("").

Ayrıca Bakınız

  • sqlsrv_connect() - Opens a connection to a Microsoft SQL Server database
  • sqlsrv_query() - Prepares and executes a query.
  • sqlsrv_errors() - Returns error and warning information about the last SQLSRV operation performed
  • sqlsrv_fetch() - Makes the next row in a result set available for reading

sqlsrv_execute
sqlsrv_fetch_object
SQLSRV İşlevleri


Retrieves the next row of data in a result set as an object

sqlsrv_fetch_array
sqlsrv_fetch
SQLSRV İşlevleri
PHP Manual

sqlsrv_fetch_object

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

sqlsrv_fetch_object — Retrieves the next row of data in a result set as an object

Açıklama

mixed sqlsrv_fetch_object ( resource $stmt [, string $className [, array $ctorParams [, int $row [, int $offset ]]]] )

Retrieves the next row of data in a result set as an instance of the specified class with properties that match the row field names and values that correspond to the row field values.

Değiştirgeler

stmt

A statement resource created by sqlsrv_query() or sqlsrv_execute().

className

The name of the class to instantiate. If no class name is specified, stdClass is instantiated.

ctorParams

Values passed to the constructor of the specified class. If the constructor of the specified class takes parameters, the ctorParams array must be supplied.

row

The row to be accessed. This parameter can only be used if the specified statement was prepared with a scrollable cursor. In that case, this parameter can take on one of the following values:

  • SQLSRV_SCROLL_NEXT
  • SQLSRV_SCROLL_PRIOR
  • SQLSRV_SCROLL_FIRST
  • SQLSRV_SCROLL_LAST
  • SQLSRV_SCROLL_ABSOLUTE
  • SQLSRV_SCROLL_RELATIVE

offset

Specifies the row to be accessed if the row parameter is set to SQLSRV_SCROLL_ABSOLUTE or SQLSRV_SCROLL_RELATIVE. Note that the first row in a result set has index 0.

Dönen Değerler

Returns an object on success, NULL if there are no more rows to return, and FALSE if an error occurs or if the specified class does not exist.

Örnekler

Örnek 1 sqlsrv_fetch_object() example

The following example demonstrates how to retrieve a row as a stdClass object.

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false ) {
     die( print_r( sqlsrv_errors(), true));
}

$sql = "SELECT fName, lName FROM Table_1";
$stmt = sqlsrv_query( $conn, $sql);
if( $stmt === false ) {
     die( print_r( sqlsrv_errors(), true));
}

// Retrieve each row as an object.
// Because no class is specified, each row will be retrieved as a stdClass object.
// Property names correspond to field names.
while( $obj = sqlsrv_fetch_object( $stmt)) {
      echo $obj->fName.", ".$obj->lName."<br />";
}
?>

Notlar

If a class name is specified with the optional $className parameter and the class has properties whose names match the result set field names, the corresponding result set values are applied to the properties. If a result set field name does not match a class property, a property with the result set field name is added to the object and the result set value is applied to the property. The following rules apply when using the $className parameter:

  • Field-property name matching is case-sensitive.
  • Field-property matching occurs regardless of access modifiers.
  • Class property data types are ignored when applying a field value to a property.
  • If the class does not exist, the function returns FALSE and adds an error to the error collection.
Regardless of whether the $className parameter is supplied, if a field with no name is returned, the field value will be ignored and a warning will be added to the error collection.

When consuming a result set that has multiple columns with the same name, it may be better to use sqlsrv_fetch_array() or the combination of sqlsrv_fetch() and sqlsrv_get_field().

Ayrıca Bakınız

  • sqlsrv_fetch() - Makes the next row in a result set available for reading
  • sqlsrv_fetch_array() - Returns a row as an array

sqlsrv_fetch_array
sqlsrv_fetch
SQLSRV İşlevleri


Makes the next row in a result set available for reading

sqlsrv_fetch_object
sqlsrv_field_metadata
SQLSRV İşlevleri
PHP Manual

sqlsrv_fetch

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

sqlsrv_fetch — Makes the next row in a result set available for reading

Açıklama

mixed sqlsrv_fetch ( resource $stmt [, int $row [, int $offset ]] )

Makes the next row in a result set available for reading. Use sqlsrv_get_field() to read the fields of the row.

Değiştirgeler

stmt

A statement resource created by executing sqlsrv_query() or sqlsrv_execute().

row

The row to be accessed. This parameter can only be used if the specified statement was prepared with a scrollable cursor. In that case, this parameter can take on one of the following values:

  • SQLSRV_SCROLL_NEXT
  • SQLSRV_SCROLL_PRIOR
  • SQLSRV_SCROLL_FIRST
  • SQLSRV_SCROLL_LAST
  • SQLSRV_SCROLL_ABSOLUTE
  • SQLSRV_SCROLL_RELATIVE

offset

Specifies the row to be accessed if the row parameter is set to SQLSRV_SCROLL_ABSOLUTE or SQLSRV_SCROLL_RELATIVE. Note that the first row in a result set has index 0.

Dönen Değerler

Returns TRUE if the next row of a result set was successfully retrieved, FALSE if an error occurs, and NULL if there are no more rows in the result set.

Örnekler

Örnek 1 sqlsrv_fetch() example

The following example demonstrates how to retrieve a row with sqlsrv_fetch() and get the row fields with sqlsrv_get_field().

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false ) {
     die( print_r( sqlsrv_errors(), true));
}

$sql = "SELECT Name, Comment
        FROM Table_1
        WHERE ReviewID=1";
$stmt = sqlsrv_query( $conn, $sql);
if( $stmt === false ) {
     die( print_r( sqlsrv_errors(), true));
}

// Make the first (and in this case, only) row of the result set available for reading.
if( sqlsrv_fetch( $stmt ) === false) {
     die( print_r( sqlsrv_errors(), true));
}

// Get the row fields. Field indeces start at 0 and must be retrieved in order.
// Retrieving row fields by name is not supported by sqlsrv_get_field.
$name = sqlsrv_get_field( $stmt, 0);
echo "$name: ";

$comment = sqlsrv_get_field( $stmt, 1);
echo $comment;
?>

Ayrıca Bakınız

  • sqlsrv_get_field() - Gets field data from the currently selected row
  • sqlsrv_fetch_array() - Returns a row as an array
  • sqlsrv_fetch_object() - Retrieves the next row of data in a result set as an object

sqlsrv_fetch_object
sqlsrv_field_metadata
SQLSRV İşlevleri


Retrieves metadata for the fields of a statement prepared by sqlsrv_prepare or sqlsrv_query

sqlsrv_fetch
sqlsrv_free_stmt
SQLSRV İşlevleri
PHP Manual

sqlsrv_field_metadata

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

sqlsrv_field_metadata — Retrieves metadata for the fields of a statement prepared by sqlsrv_prepare() or sqlsrv_query()

Açıklama

mixed sqlsrv_field_metadata ( resource $stmt )

Retrieves metadata for the fields of a statement prepared by sqlsrv_prepare() or sqlsrv_query(). sqlsrv_field_metadata() can be called on a statement before or after statement execution.

Değiştirgeler

stmt

The statment resource for which metadata is returned.

Dönen Değerler

Returns an array of arrays is returned on success. Otherwise, FALSE is returned. Each returned array is described by the following table:

Array returned by sqlsrv_field_metadata
Key | Description
Name | The name of the field.
Type | The numeric value for the SQL type.
Size | The number of characters for fields of character type, the number of bytes for fields of binary type, or NULL for other types.
Precision | The precision for types of variable precision, NULL for other types.
Scale | The scale for types of variable scale, NULL for other types.
Nullable | An enumeration indicating whether the column is nullable, not nullable, or if it is not known.
For more information, see » sqlsrv_field_metadata in the Microsoft SQLSRV documentation.

Örnekler

Örnek 1 sqlsrv_field_metadata() example

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"AdventureWorks", "UID"=>"username", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false ) {
   die( print_r( sqlsrv_errors(), true));
}

$sql = "SELECT * FROM Table_1";
$stmt = sqlsrv_prepare( $conn, $sql );

foreach( sqlsrv_field_metadata( $stmt ) as $fieldMetadata ) {
    foreach( $fieldMetadata as $name => $value) {
       echo "$name: $value<br />";
    }
      echo "<br />";
}
?>

Ayrıca Bakınız

  • sqlsrv_client_info() - Returns information about the client and specified connection

sqlsrv_fetch
sqlsrv_free_stmt
SQLSRV İşlevleri


Frees all resources for the specified statement

sqlsrv_field_metadata
sqlsrv_get_config
SQLSRV İşlevleri
PHP Manual

sqlsrv_free_stmt

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

sqlsrv_free_stmt — Frees all resources for the specified statement

Açıklama

bool sqlsrv_free_stmt ( resource $stmt )

Frees all resources for the specified statement. The statement cannot be used after sqlsrv_free_stmt() has been called on it. If sqlsrv_free_stmt() is called on an in-progress statement that alters server state, statement execution is terminated and the statement is rolled back.

Değiştirgeler

stmt

The statment for which resources are freed. Note that NULL is a valid parameter value. This allows the function to be called multiple times in a script.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 sqlsrv_free_stmt() example

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false ) {
     die( print_r( sqlsrv_errors(), true));
}

$stmt = sqlsrv_query( $conn, "SELECT * FROM Table_1");
if( $stmt === false ) {
     die( print_r( sqlsrv_errors(), true));
}

/*-------------------------------
     Process query results here.
-------------------------------*/

/* Free the statement resources. */
sqlsrv_free_stmt( $stmt);

?>

Notlar

The main difference between sqlsrv_free_stmt() and sqlsrv_cancel() is that a statement resource cancelled with sqlsrv_cancel() can be re-executed if it was created with sqlsrv_prepare(). A statement resource cancelled with sqlsrv_free_statement() cannot be re-executed.

Ayrıca Bakınız

  • sqlsrv_cancel() - Cancels a statement

sqlsrv_field_metadata
sqlsrv_get_config
SQLSRV İşlevleri


Returns the value of the specified configuration setting

sqlsrv_free_stmt
sqlsrv_get_field
SQLSRV İşlevleri
PHP Manual

sqlsrv_get_config

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

sqlsrv_get_config — Returns the value of the specified configuration setting

Açıklama

mixed sqlsrv_get_config ( string $setting )

Returns the value of the specified configuration setting.

Değiştirgeler

setting

The name of the setting for which the value is returned. For a list of configurable settings, see sqlsrv_configure().

Dönen Değerler

Returns the value of the specified setting. If an invalid setting is specified, FALSE is returned.

Ayrıca Bakınız

  • sqlsrv_configure() - Changes the driver error handling and logging configurations

sqlsrv_free_stmt
sqlsrv_get_field
SQLSRV İşlevleri


Gets field data from the currently selected row

sqlsrv_get_config
sqlsrv_has_rows
SQLSRV İşlevleri
PHP Manual

sqlsrv_get_field

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

sqlsrv_get_field — Gets field data from the currently selected row

Açıklama

mixed sqlsrv_get_field ( resource $stmt , int $fieldIndex [, int $getAsType ] )

Gets field data from the currently selected row. Fields must be accessed in order. Field indices start at 0.

Değiştirgeler

stmt

A statement resource returned by sqlsrv_query() or sqlsrv_execute().

fieldIndex

The index of the field to be retrieved. Field indices start at 0. Fields must be accessed in order. i.e. If you access field index 1, then field index 0 will not be available.

getAsType

The PHP data type for the returned field data. If this parameter is not set, the field data will be returned as its default PHP data type. For information about default PHP data types, see » Default PHP Data Types in the Microsoft SQLSRV documentation.

Dönen Değerler

Returns data from the specified field on success. Returns FALSE otherwise.

Örnekler

Örnek 1 sqlsrv_get_field() example

The following example demonstrates how to retrieve a row with sqlsrv_fetch() and get the row fields with sqlsrv_get_field().

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false ) {
     die( print_r( sqlsrv_errors(), true));
}

$sql = "SELECT Name, Comment
        FROM Table_1
        WHERE ReviewID=1";
$stmt = sqlsrv_query( $conn, $sql);
if( $stmt === false ) {
     die( print_r( sqlsrv_errors(), true));
}

// Make the first (and in this case, only) row of the result set available for reading.
if( sqlsrv_fetch( $stmt ) === false) {
     die( print_r( sqlsrv_errors(), true));
}

// Get the row fields. Field indeces start at 0 and must be retrieved in order.
// Retrieving row fields by name is not supported by sqlsrv_get_field.
$name = sqlsrv_get_field( $stmt, 0);
echo "$name: ";

$comment = sqlsrv_get_field( $stmt, 1);
echo $comment;
?>

Ayrıca Bakınız

  • sqlsrv_fetch() - Makes the next row in a result set available for reading
  • sqlsrv_fetch_array() - Returns a row as an array
  • sqlsrv_fetch_object() - Retrieves the next row of data in a result set as an object

sqlsrv_get_config
sqlsrv_has_rows
SQLSRV İşlevleri


Indicates whether the specified statement has rows

sqlsrv_get_field
sqlsrv_next_result
SQLSRV İşlevleri
PHP Manual

sqlsrv_has_rows

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

sqlsrv_has_rows — Indicates whether the specified statement has rows

Açıklama

bool sqlsrv_has_rows ( resource $stmt )

Indicates whether the specified statement has rows.

Değiştirgeler

stmt

A statement resource returned by sqlsrv_query() or sqlsrv_execute().

Dönen Değerler

Returns TRUE if the specified statement has rows and FALSE if the statement does not have rows or if an error occurred.

Örnekler

Örnek 1 sqlsrv_has_rows() example

<?php
$server = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password" )
$conn = sqlsrv_connect( $server, $connectionInfo );

$stmt = sqlsrv_query( $conn, "SELECT * FROM Table_1");

if ($stmt) {
   $rows = sqlsrv_has_rows( $stmt );
   if ($rows === true)
      echo "There are rows. <br />";
   else
      echo "There are no rows. <br />";
}
?>

Ayrıca Bakınız

  • sqlsrv_num_rows() - Retrieves the number of rows in a result set
  • sqlsrv_query() - Prepares and executes a query.

sqlsrv_get_field
sqlsrv_next_result
SQLSRV İşlevleri


Makes the next result of the specified statement active

sqlsrv_has_rows
sqlsrv_num_fields
SQLSRV İşlevleri
PHP Manual

sqlsrv_next_result

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

sqlsrv_next_result — Makes the next result of the specified statement active

Açıklama

mixed sqlsrv_next_result ( resource $stmt )

Makes the next result of the specified statement active. Results include result sets, row counts, and output parameters.

Değiştirgeler

stmt

The statment on which the next result is being called.

Dönen Değerler

Returns TRUE if the next result was successfully retrieved, FALSE if an error occurred, and NULL if there are no more results to retrieve.

Örnekler

Örnek 1 sqlsrv_next_result() example

The following example executes a batch query that inserts into a table and then selects from the table. This produces two results on the statement: one for the rows affected by the INSERT and one for the rows returned by the SELECT. To get to the rows returned by the SELECT, sqlsrv_next_result() must be called to move past the first result.

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array("Database"=>"dbName", "UID"=>"userName", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);

$query = "INSERT INTO Table_1 (id, data) VALUES (?,?); SELECT * FROM TABLE_1;";
$params = array(1, "some data");
$stmt = sqlsrv_query($conn, $query, $params);

// Consume the first result (rows affected by INSERT) without calling sqlsrv_next_result.
echo "Rows affected: ".sqlsrv_rows_affected($stmt)."<br />";

// Move to the next result and display results.
$next_result = sqlsrv_next_result($stmt);
if( $next_result ) {
   while( $row = sqlsrv_fetch_array( $stmt, SQLSRV_FETCH_ASSOC)){
      echo $row['id'].": ".$row['data']."<br />";
   }
} elseif( is_null($next_result)) {
     echo "No more results.<br />";
} else {
     die(print_r(sqlsrv_errors(), true));
}
?>

Ayrıca Bakınız

  • sqlsrv_query() - Prepares and executes a query.
  • sqlsrv_fetch_array() - Returns a row as an array
  • sqlsrv_rows_affected() - Returns the number of rows modified by the last INSERT, UPDATE, or DELETE query executed

sqlsrv_has_rows
sqlsrv_num_fields
SQLSRV İşlevleri


Retrieves the number of fields (columns) on a statement

sqlsrv_next_result
sqlsrv_num_rows
SQLSRV İşlevleri
PHP Manual

sqlsrv_num_fields

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

sqlsrv_num_fields — Retrieves the number of fields (columns) on a statement

Açıklama

mixed sqlsrv_num_fields ( resource $stmt )

Retrieves the number of fields (columns) on a statement.

Değiştirgeler

stmt

The statment for which the number of fields is returned. sqlsrv_num_fields() can be called on a statement before or after statement execution.

Dönen Değerler

Returns the number of fields on success. Returns FALSE otherwise.

Örnekler

Örnek 1 sqlsrv_num_fields() example

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false ) {
   die( print_r( sqlsrv_errors(), true));
}

$sql = "SELECT * FROM Table_1";
$stmt = sqlsrv_query($conn, $sql);
if( $stmt === false) {
   die( print_r( sqlsrv_errors(), true));
}

$numFields = sqlsrv_num_fields( $stmt );

while( sqlsrv_fetch( $stmt )) {
   // Iterate through the fields of each row.
   for($i = 0; $i < $numFields; $i++) {
      echo sqlsrv_get_field($stmt, $i)." ";
   }
   echo "<br />";
}
?>

Ayrıca Bakınız

  • sqlsrv_field_metadata() - Retrieves metadata for the fields of a statement prepared by sqlsrv_prepare or sqlsrv_query
  • sqlsrv_fetch() - Makes the next row in a result set available for reading
  • sqlsrv_get_field() - Gets field data from the currently selected row

sqlsrv_next_result
sqlsrv_num_rows
SQLSRV İşlevleri


Retrieves the number of rows in a result set

sqlsrv_num_fields
sqlsrv_prepare
SQLSRV İşlevleri
PHP Manual

sqlsrv_num_rows

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

sqlsrv_num_rows — Retrieves the number of rows in a result set

Açıklama

mixed sqlsrv_num_rows ( resource $stmt )

Retrieves the number of rows in a result set. This function requires that the statment resource be created with a static or keyset cursor. For more information, see sqlsrv_query(), sqlsrv_prepare(), or » Specifying a Cursor Type and Selecting Rows in the Microsoft SQLSRV documentation.

Değiştirgeler

stmt

The statement for which the row count is returned. The statment resource must be created with a static or keyset cursor. For more information, see sqlsrv_query(), sqlsrv_prepare(), or » Specifying a Cursor Type and Selecting Rows in the Microsoft SQLSRV documentation.

Dönen Değerler

Returns the number of rows retrieved on success and FALSE if an error occurred. If a forward cursor (the default) or dynamic cursor is used, FALSE is returned.

Örnekler

Örnek 1 sqlsrv_num_rows() example

<?php
$server = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password" );
$conn = sqlsrv_connect( $server, $connectionInfo );

$sql = "SELECT * FROM Table_1";
$params = array();
$options =  array( "Scrollable" => SQLSRV_CURSOR_KEYSET );
$stmt = sqlsrv_query( $conn, $sql , $params, $options );

$row_count = sqlsrv_num_rows( $stmt );

if ($row_count === false)
   echo "Error in retrieveing row count.";
else
   echo $row_count;
?>

Ayrıca Bakınız

  • sqlsrv_has_rows() - Indicates whether the specified statement has rows
  • sqlsrv_rows_affected() - Returns the number of rows modified by the last INSERT, UPDATE, or DELETE query executed

sqlsrv_num_fields
sqlsrv_prepare
SQLSRV İşlevleri


Prepares a query for execution

sqlsrv_num_rows
sqlsrv_query
SQLSRV İşlevleri
PHP Manual

sqlsrv_prepare

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

sqlsrv_prepare — Prepares a query for execution

Açıklama

mixed sqlsrv_prepare ( resource $conn , string $sql [, array $params [, array $options ]] )

Prepares a query for execution. This function is ideal for preparing a query that will be executed multiple times with different parameter values.

Değiştirgeler

conn

A connection resource returned by sqlsrv_connect().

sql

The string that defines the query to be prepared and executed.

params

An array specifying parameter information when executing a parameterized query. Array elements can be any of the following:

  • A literal value
  • A PHP variable
  • An array with this structure: array($value [, $direction [, $phpType [, $sqlType]]])
The following table describes the elements in the array structure above:

Array structure
Element | Description
$value | A literal value, a PHP variable, or a PHP by-reference variable.
$direction (optional) | One of the following SQLSRV constants used to indicate the parameter direction: SQLSRV_PARAM_IN, SQLSRV_PARAM_OUT, SQLSRV_PARAM_INOUT. The default value is SQLSRV_PARAM_IN.
$phpType (optional) | A SQLSRV_PHPTYPE_* constant that specifies PHP data type of the returned value.
$sqlType (optional) | A SQLSRV_SQLTYPE_* constant that specifies the SQL Server data type of the input value.
options

An array specifing query property options. The supported keys are described in the following table:

Query Options
Key | Values | Description
QueryTimeout | A positive integer value. | Sets the query timeout in seconds. By default, the driver will wait indefinitely for results.
SendStreamParamsAtExec | TRUE or FALSE (the default is TRUE) | Configures the driver to send all stream data at execution (TRUE), or to send stream data in chunks (FALSE). By default, the value is set to TRUE. For more information, see sqlsrv_send_stream_data().
Scrollable | SQLSRV_CURSOR_FORWARD, SQLSRV_CURSOR_STATIC, SQLSRV_CURSOR_DYNAMIC, or SQLSRV_CURSOR_KEYSET | See » Specifying a Cursor Type and Selecting Rows in the Microsoft SQLSRV documentation.

Dönen Değerler

Returns a statement resource on success and FALSE if an error occurred.

Örnekler

Örnek 1 sqlsrv_prepare() example

This example demonstrates how to prepare a statement with sqlsrv_prepare() and re-execute it multiple times (with different parameter values) using sqlsrv_execute().

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false) {
    die( print_r( sqlsrv_errors(), true));
}

$sql = "UPDATE Table_1
        SET OrderQty = ?
        WHERE SalesOrderID = ?";

// Initialize parameters and prepare the statement.
// Variables $qty and $id are bound to the statement, $stmt.
$qty = 0; $id = 0;
$stmt = sqlsrv_prepare( $conn, $sql, array( &$qty, &$id));
if( !$stmt ) {
    die( print_r( sqlsrv_errors(), true));
}

// Set up the SalesOrderDetailID and OrderQty information.
// This array maps the order ID to order quantity in key=>value pairs.
$orders = array( 1=>10, 2=>20, 3=>30);

// Execute the statement for each order.
foreach( $orders as $id => $qty) {
    // Because $id and $qty are bound to $stmt1, their updated
    // values are used with each execution of the statement.
    if( sqlsrv_execute( $stmt ) === false ) {
          die( print_r( sqlsrv_errors(), true));
    }
}
?>

Notlar

When you prepare a statement that uses variables as parameters, the variables are bound to the statement. This means that if you update the values of the variables, the next time you execute the statement it will run with updated parameter values. For statements that you plan to execute only once, use sqlsrv_query().

Ayrıca Bakınız

  • sqlsrv_execute() - Executes a statement prepared with sqlsrv_prepare
  • sqlsrv_query() - Prepares and executes a query.

sqlsrv_num_rows
sqlsrv_query
SQLSRV İşlevleri


Prepares and executes a query.

sqlsrv_prepare
sqlsrv_rollback
SQLSRV İşlevleri
PHP Manual

sqlsrv_query

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

sqlsrv_query — Prepares and executes a query.

Açıklama

mixed sqlsrv_query ( resource $conn , string $sql [, array $params [, array $options ]] )

Prepares and executes a query.

Değiştirgeler

conn

A connection resource returned by sqlsrv_connect().

sql

The string that defines the query to be prepared and executed.

params

An array specifying parameter information when executing a parameterized query. Array elements can be any of the following:

  • A literal value
  • A PHP variable
  • An array with this structure: array($value [, $direction [, $phpType [, $sqlType]]])
The following table describes the elements in the array structure above:

Array structure
Element | Description
$value | A literal value, a PHP variable, or a PHP by-reference variable.
$direction (optional) | One of the following SQLSRV constants used to indicate the parameter direction: SQLSRV_PARAM_IN, SQLSRV_PARAM_OUT, SQLSRV_PARAM_INOUT. The default value is SQLSRV_PARAM_IN.
$phpType (optional) | A SQLSRV_PHPTYPE_* constant that specifies PHP data type of the returned value.
$sqlType (optional) | A SQLSRV_SQLTYPE_* constant that specifies the SQL Server data type of the input value.
options

An array specifing query property options. The supported keys are described in the following table:

Query Options
Key | Values | Description
QueryTimeout | A positive integer value. | Sets the query timeout in seconds. By default, the driver will wait indefinitely for results.
SendStreamParamsAtExec | TRUE or FALSE (the default is TRUE) | Configures the driver to send all stream data at execution (TRUE), or to send stream data in chunks (FALSE). By default, the value is set to TRUE. For more information, see sqlsrv_send_stream_data().
Scrollable | SQLSRV_CURSOR_FORWARD, SQLSRV_CURSOR_STATIC, SQLSRV_CURSOR_DYNAMIC, or SQLSRV_CURSOR_KEYSET | See » Specifying a Cursor Type and Selecting Rows in the Microsoft SQLSRV documentation.

Dönen Değerler

Returns a statement resource on success and FALSE if an error occurred.

Örnekler

Örnek 1 sqlsrv_query() example

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password" );
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false ) {
     die( print_r( sqlsrv_errors(), true));
}

$sql = "INSERT INTO Table_1 (id, data) VALUES (?, ?)";
$params = array(1, "some data");

$stmt = sqlsrv_query( $conn, $sql, $params);
if( $stmt === false ) {
     die( print_r( sqlsrv_errors(), true));
}
?>

Notlar

For statements that you plan to execute only once, use sqlsrv_query(). If you intend to re-execute a statement with different parameter values, use the combination of sqlsrv_prepare() and sqlsrv_execute().

Ayrıca Bakınız

  • sqlsrv_prepare() - Prepares a query for execution
  • sqlsrv_execute() - Executes a statement prepared with sqlsrv_prepare

sqlsrv_prepare
sqlsrv_rollback
SQLSRV İşlevleri


Rolls back a transaction that was begun with sqlsrv_begin_transaction

sqlsrv_query
sqlsrv_rows_affected
SQLSRV İşlevleri
PHP Manual

sqlsrv_rollback

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

sqlsrv_rollback — Rolls back a transaction that was begun with sqlsrv_begin_transaction()

Açıklama

bool sqlsrv_rollback ( resource $conn )

Rolls back a transaction that was begun with sqlsrv_begin_transaction() and returns the connection to auto-commit mode.

Değiştirgeler

conn

The connection resource returned by a call to sqlsrv_connect().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 sqlsrv_rollback() example

The following example demonstrates how to use sqlsrv_begin_transaction() together with sqlsrv_commit() and sqlsrv_rollback().

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"userName", "PWD"=>"password");
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false ) {
    die( print_r( sqlsrv_errors(), true ));
}

/* Begin the transaction. */
if ( sqlsrv_begin_transaction( $conn ) === false ) {
     die( print_r( sqlsrv_errors(), true ));
}

/* Initialize parameter values. */
$orderId = 1; $qty = 10; $productId = 100;

/* Set up and execute the first query. */
$sql1 = "INSERT INTO OrdersTable (ID, Quantity, ProductID)
         VALUES (?, ?, ?)";
$params1 = array( $orderId, $qty, $productId );
$stmt1 = sqlsrv_query( $conn, $sql1, $params1 );

/* Set up and execute the second query. */
$sql2 = "UPDATE InventoryTable
         SET Quantity = (Quantity - ?)
         WHERE ProductID = ?";
$params2 = array($qty, $productId);
$stmt2 = sqlsrv_query( $conn, $sql2, $params2 );

/* If both queries were successful, commit the transaction. */
/* Otherwise, rollback the transaction. */
if( $stmt1 && $stmt2 ) {
     sqlsrv_commit( $conn );
     echo "Transaction committed.<br />";
} else {
     sqlsrv_rollback( $conn );
     echo "Transaction rolled back.<br />";
}
?>

Ayrıca Bakınız

  • sqlsrv_begin_transaction() - Begins a database transaction
  • sqlsrv_commit() - Commits a transaction that was begun with sqlsrv_begin_transaction

sqlsrv_query
sqlsrv_rows_affected
SQLSRV İşlevleri


Returns the number of rows modified by the last INSERT, UPDATE, or DELETE query executed

sqlsrv_rollback
sqlsrv_send_stream_data
SQLSRV İşlevleri
PHP Manual

sqlsrv_rows_affected

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

sqlsrv_rows_affected — Returns the number of rows modified by the last INSERT, UPDATE, or DELETE query executed

Açıklama

int sqlsrv_rows_affected ( resource $stmt )

Returns the number of rows modified by the last INSERT, UPDATE, or DELETE query executed. For information about the number of rows returned by a SELECT query, see sqlsrv_num_rows().

Değiştirgeler

stmt

The executed statement resource for which the number of affected rows is returned.

Dönen Değerler

Returns the number of rows affected by the last INSERT, UPDATE, or DELETE query. If no rows were affected, 0 is returned. If the number of affected rows cannot be determined, -1 is returned. If an error occurred, FALSE is returned.

Örnekler

Örnek 1 sqlsrv_rows_affected() example

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password" );
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false ) {
     die( print_r( sqlsrv_errors(), true));
}

$sql = "UPDATE Table_1 SET data = ? WHERE id = ?";

$params = array("updated data", 1);

$stmt = sqlsrv_query( $conn, $sql, $params);

$rows_affected = sqlsrv_rows_affected( $stmt);
if( $rows_affected === false) {
     die( print_r( sqlsrv_errors(), true));
} elseif( $rows_affected == -1) {
      echo "No information available.<br />";
} else {
      echo $rows_affected." rows were updated.<br />";
}
?>

Ayrıca Bakınız

  • sqlsrv_num_rows() - Retrieves the number of rows in a result set

sqlsrv_rollback
sqlsrv_send_stream_data
SQLSRV İşlevleri


Sends data from parameter streams to the server

sqlsrv_rows_affected
sqlsrv_server_info
SQLSRV İşlevleri
PHP Manual

sqlsrv_send_stream_data

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

sqlsrv_send_stream_data — Sends data from parameter streams to the server

Açıklama

bool sqlsrv_send_stream_data ( resource $stmt )

Send data from parameter streams to the server. Up to 8 KB of data is sent with each call.

Değiştirgeler

stmt

A statement resource returned by sqlsrv_query() or sqlsrv_execute().

Dönen Değerler

Returns TRUE if there is more data to send and FALSE if there is not.

Örnekler

Örnek 1 sqlsrv_send_stream_data() example

<?php
$serverName = "serverName\sqlexpress";
$connectionInfo = array( "Database"=>"dbName", "UID"=>"username", "PWD"=>"password" );
$conn = sqlsrv_connect( $serverName, $connectionInfo);
if( $conn === false ) {
     die( print_r( sqlsrv_errors(), true));
}

$sql = "UPDATE Table_1 SET data = ( ?) WHERE id = 100";

// Open parameter data as a stream and put it in the $params array.
$data = fopen( "data://text/plain,[ Lengthy content here. ]", "r");
$params = array( &$data);

// Prepare the statement. Use the $options array to turn off the
// default behavior, which is to send all stream data at the time of query
// execution.
$options = array("SendStreamParamsAtExec"=>0);
$stmt = sqlsrv_prepare( $conn, $sql, $params, $options);

sqlsrv_execute( $stmt);

// Send up to 8K of parameter data to the server
// with each call to sqlsrv_send_stream_data.
$i = 1;
while( sqlsrv_send_stream_data( $stmt)) {
      $i++;
}
echo "$i calls were made.";
?>

Ayrıca Bakınız

  • sqlsrv_prepare() - Prepares a query for execution
  • sqlsrv_query() - Prepares and executes a query.

sqlsrv_rows_affected
sqlsrv_server_info
SQLSRV İşlevleri


Returns information about the server

sqlsrv_send_stream_data
Sybase
SQLSRV İşlevleri
PHP Manual

sqlsrv_server_info

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

sqlsrv_server_info — Returns information about the server

Açıklama

array sqlsrv_server_info ( resource $conn )

Returns information about the server.

Değiştirgeler

conn

The connection resource that connects the client and the server.

Dönen Değerler

Returns an array as described in the following table:

Returned Array
CurrentDatabase | The connected-to database.
SQLServerVersion | The SQL Server version.
SQLServerName | The name of the server.

Örnekler

Örnek 1 sqlsrv_server_info() example

<?php
$serverName = "serverName\sqlexpress";
$conn = sqlsrv_connect( $serverName);
if( $conn === false ) {
     die( print_r( sqlsrv_errors(), true));
}

$server_info = sqlsrv_server_info( $conn);
if( $server_info )
{
    foreach( $server_info as $key => $value) {
       echo $key.": ".$value."<br />";
    }
} else {
      die( print_r( sqlsrv_errors(), true));
}
?>

Ayrıca Bakınız

  • sqlsrv_client_info() - Returns information about the client and specified connection

sqlsrv_send_stream_data
Sybase
SQLSRV İşlevleri


Sybase

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Sybase İşlevleri
    • sybase_affected_rows — Gets number of affected rows in last query
    • sybase_close — Closes a Sybase connection
    • sybase_connect — Opens a Sybase server connection
    • sybase_data_seek — Moves internal row pointer
    • sybase_deadlock_retry_count — Sets the deadlock retry count
    • sybase_fetch_array — Fetch row as array
    • sybase_fetch_assoc — Fetch a result row as an associative array
    • sybase_fetch_field — Get field information from a result
    • sybase_fetch_object — Fetch a row as an object
    • sybase_fetch_row — Get a result row as an enumerated array
    • sybase_field_seek — Sets field offset
    • sybase_free_result — Frees result memory
    • sybase_get_last_message — Returns the last message from the server
    • sybase_min_client_severity — Sets minimum client severity
    • sybase_min_error_severity — Sets minimum error severity
    • sybase_min_message_severity — Sets minimum message severity
    • sybase_min_server_severity — Sets minimum server severity
    • sybase_num_fields — Gets the number of fields in a result set
    • sybase_num_rows — Get number of rows in a result set
    • sybase_pconnect — Open persistent Sybase connection
    • sybase_query — Sends a Sybase query
    • sybase_result — Get result data
    • sybase_select_db — Selects a Sybase database
    • sybase_set_message_handler — Sets the handler called when a server message is raised
    • sybase_unbuffered_query — Send a Sybase query and do not block
sqlsrv_server_info
Giriş
Sağlayıcıya Göre Veritabanı Eklentileri


Giriş

Uyarı

As of PHP 7.0.0, the sybase_ct extension has been removed.

Sybase
Yapılandırma/Kurulum
Sybase


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Sybase


Kurulum

To enable Sybase-DB support configure PHP --with-sybase[=DIR] . DIR is the Sybase home directory, defaults to /home/sybase. To enable Sybase-CT support configure PHP --with-sybase-ct[=DIR] . DIR is the Sybase home directory, defaults to /home/sybase.

Bilginize:

As of PHP 5.3.0, the Sybase extension has been superseded by the sybase_ct extension and is no longer maintained. To continue using sybase you must use the sybase_ct extension.

As of PHP 7.0.0, the sybase_ct extension has been removed.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Sybase configuration options
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
sybase.allow_persistent | "1" | PHP_INI_ALL | PHP_INI_ALL in PHP <= 4.0.2. PHP_INI_SYSTEM in PHP <= 4.0.3.
sybase.max_persistent | "-1" | PHP_INI_ALL | PHP_INI_ALL in PHP <= 4.0.2. PHP_INI_SYSTEM in PHP <= 4.0.3.
sybase.max_links | "-1" | PHP_INI_ALL | PHP_INI_ALL in PHP <= 4.0.2. PHP_INI_SYSTEM in PHP <= 4.0.3.
sybase.interface_file | "/usr/sybase/interfaces" | PHP_INI_SYSTEM |
sybase.min_error_severity | "10" | PHP_INI_ALL |
sybase.min_message_severity | "10" | PHP_INI_ALL |
sybase.compatability_mode | "0" | PHP_INI_ALL |
magic_quotes_sybase | "0" | PHP_INI_ALL | Deprecated in PHP 5.3.0. Removed in PHP 5.4.0.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

sybase.allow_persistent boolean

Whether to allow persistent Sybase connections.

sybase.max_persistent integer

The maximum number of persistent Sybase connections per process. -1 means no limit.

sybase.max_links integer

The maximum number of Sybase connections per process, including persistent connections. -1 means no limit.

sybase.min_error_severity integer

Minimum error severity to display.

sybase.min_message_severity integer

Minimum message severity to display.

magic_quotes_sybase boolean

If magic_quotes_sybase is on, a single-quote is escaped with a single-quote instead of a backslash if magic_quotes_gpc or magic_quotes_runtime are enabled. This setting is also respected by addslashes() and stripslashes().

Bilginize:

Note that when magic_quotes_sybase is ON it completely overrides magic_quotes_gpc . In this case even when magic_quotes_gpc is enabled neither double quotes, backslashes or NUL's will be escaped.

Uyarı

Bu özelliğin kullanımı PHP 5.3.0 itibariyle ÖNERİLMEMEKTE olup PHP 5.4.0'da tamamen KALDIRILMIŞTIR.

Sybase-CT configuration options
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
sybct.deadlock_retry_count | "0" | PHP_INI_ALL | Available since PHP 4.3.0.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

sybct.login_timeout integer

The maximum time in seconds to wait for a connection attempt to succeed before returning failure. Note that if max_execution_time has been exceeded when a connection attempt times out, your script will be terminated before it can take action on failure. The default is one minute.

sybct.timeout integer

The maximum time in seconds to wait for a select_db or query operation to succeed before returning failure. Note that if max_execution_time has been exceeded when an operation times out, your script will be terminated before it can take action on failure. The default is no limit.

sybct.deadlock_retry_count int

Allows you to define how often deadlocks are to be retried. The default is 0, value -1 means "forever".

PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
Sybase İşlevleri
Sybase


Sybase İşlevleri

İçindekiler

  • sybase_affected_rows — Gets number of affected rows in last query
  • sybase_close — Closes a Sybase connection
  • sybase_connect — Opens a Sybase server connection
  • sybase_data_seek — Moves internal row pointer
  • sybase_deadlock_retry_count — Sets the deadlock retry count
  • sybase_fetch_array — Fetch row as array
  • sybase_fetch_assoc — Fetch a result row as an associative array
  • sybase_fetch_field — Get field information from a result
  • sybase_fetch_object — Fetch a row as an object
  • sybase_fetch_row — Get a result row as an enumerated array
  • sybase_field_seek — Sets field offset
  • sybase_free_result — Frees result memory
  • sybase_get_last_message — Returns the last message from the server
  • sybase_min_client_severity — Sets minimum client severity
  • sybase_min_error_severity — Sets minimum error severity
  • sybase_min_message_severity — Sets minimum message severity
  • sybase_min_server_severity — Sets minimum server severity
  • sybase_num_fields — Gets the number of fields in a result set
  • sybase_num_rows — Get number of rows in a result set
  • sybase_pconnect — Open persistent Sybase connection
  • sybase_query — Sends a Sybase query
  • sybase_result — Get result data
  • sybase_select_db — Selects a Sybase database
  • sybase_set_message_handler — Sets the handler called when a server message is raised
  • sybase_unbuffered_query — Send a Sybase query and do not block
Öntanımlı Sabitler
sybase_affected_rows
Sybase


Gets number of affected rows in last query

Sybase İşlevleri
sybase_close
Sybase İşlevleri
PHP Manual

sybase_affected_rows

(PHP 4, PHP 5)

sybase_affected_rows — Gets number of affected rows in last query

Uyarı

Bu işlev PHP 7.0.0'da tamamen KALDIRILMIŞTIR.

Açıklama

int sybase_affected_rows ([ resource $link_identifier ] )

sybase_affected_rows() returns the number of rows affected by the last INSERT, UPDATE or DELETE query on the server associated with the specified link identifier.

This command is not effective for SELECT statements, only on statements which modify records. To retrieve the number of rows returned from a SELECT, use sybase_num_rows().

Değiştirgeler

link_identifier

If the link identifier isn't specified, the last opened link is assumed.

Dönen Değerler

Returns the number of affected rows, as an integer.

Örnekler

Örnek 1 Delete-Query

<?php
/* connect to database */
sybase_connect('SYBASE', '', '') or
die("Could not connect");
sybase_select_db("db");

sybase_query("DELETE FROM sometable WHERE id < 10");
printf("Records deleted: %d\n", sybase_affected_rows());
?>

Yukarıdaki örneğin çıktısı:

Records deleted: 10

Ayrıca Bakınız

  • sybase_num_rows() - Get number of rows in a result set

Sybase İşlevleri
sybase_close
Sybase İşlevleri


Closes a Sybase connection

sybase_affected_rows
sybase_connect
Sybase İşlevleri
PHP Manual

sybase_close

(PHP 4, PHP 5)

sybase_close — Closes a Sybase connection

Uyarı

Bu işlev PHP 7.0.0'da tamamen KALDIRILMIŞTIR.

Açıklama

bool sybase_close ([ resource $link_identifier ] )

sybase_close() closes the link to a Sybase database that's associated with the specified link link_identifier.

Note that this isn't usually necessary, as non-persistent open links are automatically closed at the end of the script's execution.

sybase_close() will not close persistent links generated by sybase_pconnect().

Değiştirgeler

link_identifier

If the link identifier isn't specified, the last opened link is assumed.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • sybase_connect() - Opens a Sybase server connection
  • sybase_pconnect() - Open persistent Sybase connection

sybase_affected_rows
sybase_connect
Sybase İşlevleri


Opens a Sybase server connection

sybase_close
sybase_data_seek
Sybase İşlevleri
PHP Manual

sybase_connect

(PHP 4, PHP 5)

sybase_connect — Opens a Sybase server connection

Uyarı

Bu işlev PHP 7.0.0'da tamamen KALDIRILMIŞTIR.

Açıklama

resource sybase_connect ([ string $servername [, string $username [, string $password [, string $charset [, string $appname [, bool $new = false ]]]]]] )

sybase_connect() establishes a connection to a Sybase server.

In case a second call is made to sybase_connect() with the same arguments, no new link will be established, but instead, the link identifier of the already opened link will be returned.

The link to the server will be closed as soon as the execution of the script ends, unless it's closed earlier by explicitly calling sybase_close().

Değiştirgeler

servername

The servername argument has to be a valid servername that is defined in the 'interfaces' file.

username

Sybase user name

password

Password associated with username.

charset

Specifies the charset for the connection

appname

Specifies an appname for the Sybase connection. This allow you to make separate connections in the same script to the same database. This may come handy when you have started a transaction in your current connection, and you need to be able to do a separate query which cannot be performed inside this transaction.

new

Whether to open a new connection or use the existing one.

Dönen Değerler

Returns a positive Sybase link identifier on success, or FALSE on failure.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | The new parameter was added.

Örnekler

Örnek 1 sybase_connect() example

<?php
$link = sybase_connect('SYBASE', '', '')
        or die("Could not connect !");
echo "Connected successfully";
sybase_close($link);
?>

Ayrıca Bakınız

  • sybase_pconnect() - Open persistent Sybase connection
  • sybase_close() - Closes a Sybase connection

sybase_close
sybase_data_seek
Sybase İşlevleri


Moves internal row pointer

sybase_connect
sybase_deadlock_retry_count
Sybase İşlevleri
PHP Manual

sybase_data_seek

(PHP 4, PHP 5)

sybase_data_seek — Moves internal row pointer

Uyarı

Bu işlev PHP 7.0.0'da tamamen KALDIRILMIŞTIR.

Açıklama

bool sybase_data_seek ( resource $result_identifier , int $row_number )

sybase_data_seek() moves the internal row pointer of the Sybase result associated with the specified result identifier to pointer to the specified row number. The next call to sybase_fetch_row() would return that row.

Değiştirgeler

result_identifier

row_number

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • sybase_fetch_row() - Get a result row as an enumerated array

sybase_connect
sybase_deadlock_retry_count
Sybase İşlevleri


Sets the deadlock retry count

sybase_data_seek
sybase_fetch_array
Sybase İşlevleri
PHP Manual

sybase_deadlock_retry_count

(PHP 4 >= 4.3.0, PHP 5)

sybase_deadlock_retry_count — Sets the deadlock retry count

Uyarı

Bu işlev PHP 7.0.0'da tamamen KALDIRILMIŞTIR.

Açıklama

void sybase_deadlock_retry_count ( int $retry_count )

Using sybase_deadlock_retry_count(), the number of retries can be defined in cases of deadlocks. By default, every deadlock is retried an infinite number of times or until the process is killed by Sybase, the executing script is killed (for instance, by set_time_limit()) or the query succeeds.

Değiştirgeler

retry_count

Values for retry_count
-1 | Retry forever (default)
0 | Do not retry
n | Retry n times

Dönen Değerler

Hiçbir değer dönmez.

Notlar

Bilginize: This function is only available when using the CT library interface to Sybase, and not with the DB library.

sybase_data_seek
sybase_fetch_array
Sybase İşlevleri


Fetch row as array

sybase_deadlock_retry_count
sybase_fetch_assoc
Sybase İşlevleri
PHP Manual

sybase_fetch_array

(PHP 4, PHP 5)

sybase_fetch_array — Fetch row as array

Uyarı

Bu işlev PHP 7.0.0'da tamamen KALDIRILMIŞTIR.

Açıklama

array sybase_fetch_array ( resource $result )

sybase_fetch_array() is an extended version of sybase_fetch_row(). In addition to storing the data in the numeric indices of the result array, it also stores the data in associative indices, using the field names as keys.

An important thing to note is that using sybase_fetch_array() is NOT significantly slower than using sybase_fetch_row(), while it provides a significant added value.

Değiştirgeler

result

Dönen Değerler

Returns an array that corresponds to the fetched row, or FALSE if there are no more rows.

Bilginize:

When selecting fields with identical names (for instance, in a join), the associative indices will have a sequential number prepended. See the example for details.

Örnekler

Örnek 1 Identical fieldnames

<?php

$dbh = sybase_connect('SYBASE', '', '');
$q = sybase_query('SELECT * FROM p, a WHERE p.person_id= a.person_id');
var_dump(sybase_fetch_array($q));
sybase_close($dbh);
?>

The above example would produce the following output (assuming the two tables only have each one column called "person_id"):

array(4) {
  [0]=>
  int(1)
  ["person_id"]=>
  int(1)
  [1]=>
  int(1)
  ["person_id1"]=>
  int(1)
}

Ayrıca Bakınız

  • sybase_fetch_row() - Get a result row as an enumerated array
  • sybase_fetch_assoc() - Fetch a result row as an associative array
  • sybase_fetch_object() - Fetch a row as an object

sybase_deadlock_retry_count
sybase_fetch_assoc
Sybase İşlevleri


Fetch a result row as an associative array

sybase_fetch_array
sybase_fetch_field
Sybase İşlevleri
PHP Manual

sybase_fetch_assoc

(PHP 4 >= 4.3.0, PHP 5)

sybase_fetch_assoc — Fetch a result row as an associative array

Uyarı

Bu işlev PHP 7.0.0'da tamamen KALDIRILMIŞTIR.

Açıklama

array sybase_fetch_assoc ( resource $result )

sybase_fetch_assoc() is a version of sybase_fetch_row() that uses column names instead of integers for indices in the result array. Columns from different tables with the same names are returned as name, name1, name2, ..., nameN.

An important thing to note is that using sybase_fetch_assoc() is NOT significantly slower than using sybase_fetch_row(), while it provides a significant added value.

Değiştirgeler

result

Dönen Değerler

Returns an array that corresponds to the fetched row, or FALSE if there are no more rows.

Notlar

Bilginize: This function is only available when using the CT library interface to Sybase, and not with the DB library.

Ayrıca Bakınız

  • sybase_fetch_row() - Get a result row as an enumerated array
  • sybase_fetch_array() - Fetch row as array
  • sybase_fetch_object() - Fetch a row as an object

sybase_fetch_array
sybase_fetch_field
Sybase İşlevleri


Get field information from a result

sybase_fetch_assoc
sybase_fetch_object
Sybase İşlevleri
PHP Manual

sybase_fetch_field

(PHP 4, PHP 5)

sybase_fetch_field — Get field information from a result

Uyarı

Bu işlev PHP 7.0.0'da tamamen KALDIRILMIŞTIR.

Açıklama

object sybase_fetch_field ( resource $result [, int $field_offset = -1 ] )

sybase_fetch_field() can be used in order to obtain information about fields in a certain query result.

Değiştirgeler

result

field_offset

If the field offset isn't specified, the next field that wasn't yet retrieved by sybase_fetch_field() is retrieved.

Dönen Değerler

Returns an object containing field information.

The properties of the object are:

  • name - column name. if the column is a result of a function, this property is set to computed#N, where #N is a serial number.
  • column_source - the table from which the column was taken
  • max_length - maximum length of the column
  • numeric - 1 if the column is numeric
  • type - datatype of the column

Ayrıca Bakınız

  • sybase_field_seek() - Sets field offset

sybase_fetch_assoc
sybase_fetch_object
Sybase İşlevleri


Fetch a row as an object

sybase_fetch_field
sybase_fetch_row
Sybase İşlevleri
PHP Manual

sybase_fetch_object

(PHP 4, PHP 5)

sybase_fetch_object — Fetch a row as an object

Uyarı

Bu işlev PHP 7.0.0'da tamamen KALDIRILMIŞTIR.

Açıklama

object sybase_fetch_object ( resource $result [, mixed $object ] )

sybase_fetch_object() is similar to sybase_fetch_assoc(), with one difference - an object is returned, instead of an array.

Speed-wise, the function is identical to sybase_fetch_array(), and almost as quick as sybase_fetch_row() (the difference is insignificant).

Değiştirgeler

result

object

Use the second object to specify the type of object you want to return. If this parameter is omitted, the object will be of type stdClass.

Dönen Değerler

Returns an object with properties that correspond to the fetched row, or FALSE if there are no more rows.

Örnekler

Örnek 1 sybase_fetch_object() return as Foo

<?php
    class Foo {
        var $foo, $bar, $baz;
    }

    // {...]
    $qrh= sybase_query('SELECT foo, bar, baz FROM example');
    $foo= sybase_fetch_object($qrh, 'Foo');
    $bar= sybase_fetch_object($qrh, new Foo());
    // {...]
?>

Ayrıca Bakınız

  • sybase_fetch_array() - Fetch row as array
  • sybase_fetch_row() - Get a result row as an enumerated array

sybase_fetch_field
sybase_fetch_row
Sybase İşlevleri


Get a result row as an enumerated array

sybase_fetch_object
sybase_field_seek
Sybase İşlevleri
PHP Manual

sybase_fetch_row

(PHP 4, PHP 5)

sybase_fetch_row — Get a result row as an enumerated array

Uyarı

Bu işlev PHP 7.0.0'da tamamen KALDIRILMIŞTIR.

Açıklama

array sybase_fetch_row ( resource $result )

sybase_fetch_row() fetches one row of data from the result associated with the specified result identifier.

Subsequent call to sybase_fetch_row() would return the next row in the result set, or FALSE if there are no more rows.

Değiştirgeler

result

Dönen Değerler

Returns an array that corresponds to the fetched row, or FALSE if there are no more rows. Each result column is stored in an array offset, starting at offset 0.

Data types
PHP | Sybase
string | VARCHAR, TEXT, CHAR, IMAGE, BINARY, VARBINARY, DATETIME
int | NUMERIC (w/o precision), DECIMAL (w/o precision), INT, BIT, TINYINT, SMALLINT
float | NUMERIC (w/ precision), DECIMAL (w/ precision), REAL, FLOAT, MONEY
NULL | NULL

Ayrıca Bakınız

  • sybase_fetch_array() - Fetch row as array
  • sybase_fetch_assoc() - Fetch a result row as an associative array
  • sybase_fetch_object() - Fetch a row as an object
  • sybase_data_seek() - Moves internal row pointer
  • sybase_result() - Get result data

sybase_fetch_object
sybase_field_seek
Sybase İşlevleri


Sets field offset

sybase_fetch_row
sybase_free_result
Sybase İşlevleri
PHP Manual

sybase_field_seek

(PHP 4, PHP 5)

sybase_field_seek — Sets field offset

Uyarı

Bu işlev PHP 7.0.0'da tamamen KALDIRILMIŞTIR.

Açıklama

bool sybase_field_seek ( resource $result , int $field_offset )

Seeks to the specified field offset. If the next call to sybase_fetch_field() won't include a field offset, this field would be returned.

Değiştirgeler

result

field_offset

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • sybase_fetch_field() - Get field information from a result

sybase_fetch_row
sybase_free_result
Sybase İşlevleri


Frees result memory

sybase_field_seek
sybase_get_last_message
Sybase İşlevleri
PHP Manual

sybase_free_result

(PHP 4, PHP 5)

sybase_free_result — Frees result memory

Uyarı

Bu işlev PHP 7.0.0'da tamamen KALDIRILMIŞTIR.

Açıklama

bool sybase_free_result ( resource $result )

sybase_free_result() only needs to be called if you are worried about using too much memory while your script is running. All result memory will automatically be freed when the script ends. You may call sybase_free_result() with the result identifier as an argument and the associated result memory will be freed.

Değiştirgeler

result

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

sybase_field_seek
sybase_get_last_message
Sybase İşlevleri


Returns the last message from the server

sybase_free_result
sybase_min_client_severity
Sybase İşlevleri
PHP Manual

sybase_get_last_message

(PHP 4, PHP 5)

sybase_get_last_message — Returns the last message from the server

Uyarı

Bu işlev PHP 7.0.0'da tamamen KALDIRILMIŞTIR.

Açıklama

string sybase_get_last_message ( void )

sybase_get_last_message() returns the last message reported by the server.

Dönen Değerler

Returns the message as a string.

Ayrıca Bakınız

  • sybase_min_message_severity() - Sets minimum message severity

sybase_free_result
sybase_min_client_severity
Sybase İşlevleri


Sets minimum client severity

sybase_get_last_message
sybase_min_error_severity
Sybase İşlevleri
PHP Manual

sybase_min_client_severity

(PHP 4, PHP 5)

sybase_min_client_severity — Sets minimum client severity

Uyarı

Bu işlev PHP 7.0.0'da tamamen KALDIRILMIŞTIR.

Açıklama

void sybase_min_client_severity ( int $severity )

sybase_min_client_severity() sets the minimum client severity level.

Değiştirgeler

severity

Dönen Değerler

Hiçbir değer dönmez.

Notlar

Bilginize: This function is only available when using the CT library interface to Sybase, and not with the DB library.

Ayrıca Bakınız

  • sybase_min_server_severity() - Sets minimum server severity

sybase_get_last_message
sybase_min_error_severity
Sybase İşlevleri


Sets minimum error severity

sybase_min_client_severity
sybase_min_message_severity
Sybase İşlevleri
PHP Manual

sybase_min_error_severity

(PHP 4, PHP 5)

sybase_min_error_severity — Sets minimum error severity

Uyarı

Bu işlev PHP 7.0.0'da tamamen KALDIRILMIŞTIR.

Açıklama

void sybase_min_error_severity ( int $severity )

sybase_min_error_severity() sets the minimum error severity level.

Değiştirgeler

severity

Dönen Değerler

Hiçbir değer dönmez.

Notlar

Bilginize: This function is only available when using the CT library interface to Sybase, and not with the DB library.

Ayrıca Bakınız

  • sybase_min_message_severity() - Sets minimum message severity

sybase_min_client_severity
sybase_min_message_severity
Sybase İşlevleri


Sets minimum message severity

sybase_min_error_severity
sybase_min_server_severity
Sybase İşlevleri
PHP Manual

sybase_min_message_severity

(PHP 4, PHP 5)

sybase_min_message_severity — Sets minimum message severity

Uyarı

Bu işlev PHP 7.0.0'da tamamen KALDIRILMIŞTIR.

Açıklama

void sybase_min_message_severity ( int $severity )

sybase_min_message_severity() sets the minimum message severity level.

Değiştirgeler

severity

Dönen Değerler

Hiçbir değer dönmez.

Notlar

Bilginize: This function is only available when using the DB library interface to Sybase, and not with the CT library.

Ayrıca Bakınız

  • sybase_min_error_severity() - Sets minimum error severity

sybase_min_error_severity
sybase_min_server_severity
Sybase İşlevleri


Sets minimum server severity

sybase_min_message_severity
sybase_num_fields
Sybase İşlevleri
PHP Manual

sybase_min_server_severity

(PHP 4, PHP 5)

sybase_min_server_severity — Sets minimum server severity

Uyarı

Bu işlev PHP 7.0.0'da tamamen KALDIRILMIŞTIR.

Açıklama

void sybase_min_server_severity ( int $severity )

sybase_min_server_severity() sets the minimum server severity level.

Değiştirgeler

severity

Dönen Değerler

Hiçbir değer dönmez.

Notlar

Bilginize: This function is only available when using the CT library interface to Sybase, and not with the DB library.

Ayrıca Bakınız

  • sybase_min_client_severity() - Sets minimum client severity

sybase_min_message_severity
sybase_num_fields
Sybase İşlevleri


Gets the number of fields in a result set

sybase_min_server_severity
sybase_num_rows
Sybase İşlevleri
PHP Manual

sybase_num_fields

(PHP 4, PHP 5)

sybase_num_fields — Gets the number of fields in a result set

Uyarı

Bu işlev PHP 7.0.0'da tamamen KALDIRILMIŞTIR.

Açıklama

int sybase_num_fields ( resource $result )

sybase_num_fields() returns the number of fields in a result set.

Değiştirgeler

result

Dönen Değerler

Returns the number of fields as an integer.

Ayrıca Bakınız

  • sybase_query() - Sends a Sybase query
  • sybase_fetch_field() - Get field information from a result
  • sybase_num_rows() - Get number of rows in a result set

sybase_min_server_severity
sybase_num_rows
Sybase İşlevleri


Get number of rows in a result set

sybase_num_fields
sybase_pconnect
Sybase İşlevleri
PHP Manual

sybase_num_rows

(PHP 4, PHP 5)

sybase_num_rows — Get number of rows in a result set

Uyarı

Bu işlev PHP 7.0.0'da tamamen KALDIRILMIŞTIR.

Açıklama

int sybase_num_rows ( resource $result )

sybase_num_rows() returns the number of rows in a result set.

Değiştirgeler

result

Dönen Değerler

Returns the number of rows as an integer.

Ayrıca Bakınız

  • sybase_num_fields() - Gets the number of fields in a result set
  • sybase_query() - Sends a Sybase query
  • sybase_fetch_row() - Get a result row as an enumerated array

sybase_num_fields
sybase_pconnect
Sybase İşlevleri


Open persistent Sybase connection

sybase_num_rows
sybase_query
Sybase İşlevleri
PHP Manual

sybase_pconnect

(PHP 4, PHP 5)

sybase_pconnect — Open persistent Sybase connection

Uyarı

Bu işlev PHP 7.0.0'da tamamen KALDIRILMIŞTIR.

Açıklama

resource sybase_pconnect ([ string $servername [, string $username [, string $password [, string $charset [, string $appname ]]]]] )

sybase_pconnect() acts very much like sybase_connect() with two major differences.

First, when connecting, the function would first try to find a (persistent) link that's already open with the same host, username and password. If one is found, an identifier for it will be returned instead of opening a new connection.

Second, the connection to the SQL server will not be closed when the execution of the script ends. Instead, the link will remain open for future use (sybase_close() will not close links established by sybase_pconnect()).

This type of links is therefore called 'persistent'.

Değiştirgeler

servername

The servername argument has to be a valid servername that is defined in the 'interfaces' file.

username

Sybase user name

password

Password associated with username.

charset

Specifies the charset for the connection

appname

Specifies an appname for the Sybase connection. This allow you to make separate connections in the same script to the same database. This may come handy when you have started a transaction in your current connection, and you need to be able to do a separate query which cannot be performed inside this transaction.

Dönen Değerler

Returns a positive Sybase persistent link identifier on success, or FALSE on error.

Ayrıca Bakınız

  • sybase_connect() - Opens a Sybase server connection

sybase_num_rows
sybase_query
Sybase İşlevleri


Sends a Sybase query

sybase_pconnect
sybase_result
Sybase İşlevleri
PHP Manual

sybase_query

(PHP 4, PHP 5)

sybase_query — Sends a Sybase query

Uyarı

Bu işlev PHP 7.0.0'da tamamen KALDIRILMIŞTIR.

Açıklama

mixed sybase_query ( string $query [, resource $link_identifier ] )

sybase_query() sends a query to the currently active database on the server that's associated with the specified link identifier.

Değiştirgeler

query

link_identifier

If the link identifier isn't specified, the last opened link is assumed. If no link is open, the function tries to establish a link as if sybase_connect() was called, and use it.

Dönen Değerler

Returns a positive Sybase result identifier on success, FALSE on error, or TRUE if the query was successful but didn't return any columns.

Ayrıca Bakınız

  • sybase_select_db() - Selects a Sybase database
  • sybase_connect() - Opens a Sybase server connection

sybase_pconnect
sybase_result
Sybase İşlevleri


Get result data

sybase_query
sybase_select_db
Sybase İşlevleri
PHP Manual

sybase_result

(PHP 4, PHP 5)

sybase_result — Get result data

Uyarı

Bu işlev PHP 7.0.0'da tamamen KALDIRILMIŞTIR.

Açıklama

string sybase_result ( resource $result , int $row , mixed $field )

Returns the contents of the cell at the row and offset in the specified Sybase result set.

When working on large result sets, you should consider using one of the functions that fetch an entire row (specified below). As these functions return the contents of multiple cells in one function call, they're MUCH quicker than sybase_result(). Also, note that specifying a numeric offset for the field argument is much quicker than specifying a fieldname or tablename.fieldname argument.

Recommended high-performance alternatives:
sybase_fetch_row(),
sybase_fetch_array() and
sybase_fetch_object().

Değiştirgeler

result

row

field

The field argument can be the field's offset, or the field's name, or the field's table dot field's name (tablename.fieldname). If the column name has been aliased ('select foo as bar from...'), use the alias instead of the column name.

Dönen Değerler

sybase_result() returns the contents of one cell from a Sybase result set.

sybase_query
sybase_select_db
Sybase İşlevleri


Selects a Sybase database

sybase_result
sybase_set_message_handler
Sybase İşlevleri
PHP Manual

sybase_select_db

(PHP 4, PHP 5)

sybase_select_db — Selects a Sybase database

Uyarı

Bu işlev PHP 7.0.0'da tamamen KALDIRILMIŞTIR.

Açıklama

bool sybase_select_db ( string $database_name [, resource $link_identifier ] )

sybase_select_db() sets the current active database on the server that's associated with the specified link identifier.

Every subsequent call to sybase_query() will be made on the active database.

Değiştirgeler

database_name

link_identifier

If no link identifier is specified, the last opened link is assumed. If no link is open, the function will try to establish a link as if sybase_connect() was called, and use it.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • sybase_connect() - Opens a Sybase server connection
  • sybase_pconnect() - Open persistent Sybase connection
  • sybase_query() - Sends a Sybase query

sybase_result
sybase_set_message_handler
Sybase İşlevleri


Sets the handler called when a server message is raised

sybase_select_db
sybase_unbuffered_query
Sybase İşlevleri
PHP Manual

sybase_set_message_handler

(PHP 4 >= 4.3.0, PHP 5)

sybase_set_message_handler — Sets the handler called when a server message is raised

Uyarı

Bu işlev PHP 7.0.0'da tamamen KALDIRILMIŞTIR.

Açıklama

bool sybase_set_message_handler ( callable $handler [, resource $link_identifier ] )

sybase_set_message_handler() sets a user function to handle messages generated by the server. You may specify the name of a global function, or use an array to specify an object reference and a method name.

Değiştirgeler

handler

The handler expects five arguments in the following order: message number, severity, state, line number and description. The first four are integers. The last is a string. If the function returns FALSE, PHP generates an ordinary error message.

link_identifier

If the link identifier isn't specified, the last opened link is assumed.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 sybase_set_message_handler() callback function

<?php
    function msg_handler($msgnumber, $severity, $state, $line, $text)
    {
        var_dump($msgnumber, $severity, $state, $line, $text);
    }

    sybase_set_message_handler('msg_handler');
?>

Örnek 2 sybase_set_message_handler() callback to a class

<?php
    class Sybase {
        function handler($msgnumber, $severity, $state, $line, $text)
        {
            var_dump($msgnumber, $severity, $state, $line, $text);
        }
    }

    $sybase= new Sybase();
    sybase_set_message_handler(array($sybase, 'handler'));
?>

Örnek 3 sybase_set_message_handler() unhandled messages

<?php
    // Return FALSE from this function to indicate you can't handle
    // this. The error is printed out as a warning, the way you're used
    // to it if there is no handler installed.
    function msg_handler($msgnumber, $severity, $state, $line, $text)
    {
        if (257 == $msgnumber) {
            return false;
        }
        var_dump($msgnumber, $severity, $state, $line, $text);
    }

    sybase_set_message_handler('msg_handler');
?>

Notlar

Bilginize: This function is only available when using the CT library interface to Sybase, and not with the DB library.

sybase_select_db
sybase_unbuffered_query
Sybase İşlevleri


Send a Sybase query and do not block

sybase_set_message_handler
tokyo_tyrant
Sybase İşlevleri
PHP Manual

sybase_unbuffered_query

(PHP 4 >= 4.3.0, PHP 5)

sybase_unbuffered_query — Send a Sybase query and do not block

Uyarı

Bu işlev PHP 7.0.0'da tamamen KALDIRILMIŞTIR.

Açıklama

resource sybase_unbuffered_query ( string $query , resource $link_identifier [, bool $store_result ] )

sybase_unbuffered_query() sends a query to the currently active database on the server that's associated with the specified link identifier. If the link identifier isn't specified, the last opened link is assumed. If no link is open, the function tries to establish a link as if sybase_connect() was called, and use it.

Unlike sybase_query(), sybase_unbuffered_query() reads only the first row of the result set. sybase_fetch_array() and similar function read more rows as needed. sybase_data_seek() reads up to the target row. The behavior may produce better performance for large result sets.

sybase_num_rows() will only return the correct number of rows if all result sets have been read. To Sybase, the number of rows is not known and is therefore computed by the client implementation.

Bilginize:

If you don't read all of the resultsets prior to executing the next query, PHP will raise a warning and cancel all of the pending results. To get rid of this, use sybase_free_result() which will cancel pending results of an unbuffered query.

Değiştirgeler

query

link_identifier

store_result

The optional store_result can be FALSE to indicate the resultsets shouldn't be fetched into memory, thus minimizing memory usage which is particularly interesting with very large resultsets.

Dönen Değerler

Returns a positive Sybase result identifier on success, or FALSE on error.

Örnekler

Örnek 1 sybase_unbuffered_query() example

<?php

$dbh = sybase_connect('SYBASE', '', '');
$q = sybase_unbuffered_query('select firstname, lastname from huge_table', $dbh, false);
sybase_data_seek($q, 10000);
$i = 0;

while ($row = sybase_fetch_row($q)) {
    echo $row[0], ' ', $row[1], '<br />';
    if ($i++ > 40000) {
        break;
    }
}

sybase_free_result($q);
sybase_close($dbh);

?>

Notlar

Bilginize: This function is only available when using the CT library interface to Sybase, and not with the DB library.

Ayrıca Bakınız

  • sybase_query() - Sends a Sybase query

sybase_set_message_handler
tokyo_tyrant
Sybase İşlevleri


tokyo_tyrant

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
  • TokyoTyrant — The TokyoTyrant class
    • TokyoTyrant::add — Adds to a numeric key
    • TokyoTyrant::connect — Connect to a database
    • TokyoTyrant::connectUri — Connects to a database
    • TokyoTyrant::__construct — Construct a new TokyoTyrant object
    • TokyoTyrant::copy — Copies the database
    • TokyoTyrant::ext — Execute a remote script
    • TokyoTyrant::fwmKeys — Returns the forward matching keys
    • TokyoTyrant::get — The get purpose
    • TokyoTyrant::getIterator — Get an iterator
    • TokyoTyrant::num — Number of records in the database
    • TokyoTyrant::out — Removes records
    • TokyoTyrant::put — Puts values
    • TokyoTyrant::putCat — Concatenates to a record
    • TokyoTyrant::putKeep — Puts a record
    • TokyoTyrant::putNr — Puts value
    • TokyoTyrant::putShl — Concatenates to a record
    • TokyoTyrant::restore — Restore the database
    • TokyoTyrant::setMaster — Set the replication master
    • TokyoTyrant::size — Returns the size of the value
    • TokyoTyrant::stat — Get statistics
    • TokyoTyrant::sync — Synchronize the database
    • TokyoTyrant::tune — Tunes connection values
    • TokyoTyrant::vanish — Empties the database
  • TokyoTyrantTable — The TokyoTyrantTable class
    • TokyoTyrantTable::add — Adds a record
    • TokyoTyrantTable::genUid — Generate unique id
    • TokyoTyrantTable::get — Get a row
    • TokyoTyrantTable::getIterator — Get an iterator
    • TokyoTyrantTable::getQuery — Get a query object
    • TokyoTyrantTable::out — Remove records
    • TokyoTyrantTable::put — Store a row
    • TokyoTyrantTable::putCat — Concatenates to a row
    • TokyoTyrantTable::putKeep — Put a new record
    • TokyoTyrantTable::putNr — Puts value
    • TokyoTyrantTable::putShl — Concatenates to a record
    • TokyoTyrantTable::setIndex — Sets index
  • TokyoTyrantQuery — The TokyoTyrantQuery class
    • TokyoTyrantQuery::addCond — Adds a condition to the query
    • TokyoTyrantQuery::__construct — Construct a new query
    • TokyoTyrantQuery::count — Counts records
    • TokyoTyrantQuery::current — Returns the current element
    • TokyoTyrantQuery::hint — Get the hint string of the query
    • TokyoTyrantQuery::key — Returns the current key
    • TokyoTyrantQuery::metaSearch — Retrieve records with multiple queries
    • TokyoTyrantQuery::next — Moves the iterator to next entry
    • TokyoTyrantQuery::out — Removes records based on query
    • TokyoTyrantQuery::rewind — Rewinds the iterator
    • TokyoTyrantQuery::search — Searches records
    • TokyoTyrantQuery::setLimit — Limit results
    • TokyoTyrantQuery::setOrder — Orders results
    • TokyoTyrantQuery::valid — Checks the validity of current item
  • TokyoTyrantIterator — The TokyoTyrantIterator class
    • TokyoTyrantIterator::__construct — Construct an iterator
    • TokyoTyrantIterator::current — Get the current value
    • TokyoTyrantIterator::key — Returns the current key
    • TokyoTyrantIterator::next — Move to next key
    • TokyoTyrantIterator::rewind — Rewinds the iterator
    • TokyoTyrantIterator::valid — Rewinds the iterator
  • TokyoTyrantException — The TokyoTyrantException class
sybase_unbuffered_query
Giriş
Sağlayıcıya Göre Veritabanı Eklentileri


Giriş

tokyo_tyrant extension provides a wrapper for Tokyo Tyrant client libraries. The extension contains the normal key-value API and the table API.

"Tokyo Tyrant is a package of network interface to the DBM called Tokyo Cabinet. Though the DBM has high performance, you might bother in case that multiple processes share the same database, or remote processes access the database. Thus, Tokyo Tyrant is provided for concurrent and remote connections to Tokyo Cabinet. It is composed of the server process managing a database and its access library for client applications." --Tokyo Tyrant documentation

Tokyo Tyrant is written by Mikio Hirabayashi and is licensed under GNU Lesser General Public License.

tokyo_tyrant
Yapılandırma/Kurulum
tokyo_tyrant


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
tokyo_tyrant


Gereksinimler

Before using this extension Tokyo Cabinet and Tokyo Tyrant must be installed.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/tokyo_tyrant

Configure options

  • --with-tokyo-tyrant[=DIR] DIR is the prefix to the Tokyo Tyrant installation
  • --with-tokyo-cabinet-dir[=DIR] DIR is the prefix to the Tokyo Cabinet installation
  • --disable-tokyo-tyrant-session Disable Tokyo Tyrant session handler support

Enabling the extension

The extension can be enabled by adding extension=tokyo_tyrant.so to the INI-configuration

Running Tokyo Tyrant for the session handler

ttserver -port 2000 -ext /path/to/expire.lua -extpc expire 30.0 '/tmp/sessions.tct#idx=ts:dec'

Bilginize: expire.lua is included in the tokyo_tyrant extension source distribution

Configuring session handler

  • tokyo_tyrant.session_salt="randomlongstring"
  • session.save_handler=tokyo_tyrant
  • session.save_path="tcp://hostname1:2000,tcp://hostname2:2000"

Bilginize: It is important to make sure that tokyo_tyrant.session_salt matches on all servers.

How it works?

The session handler creates a session id like the following: 8b0e27a823fa4a6cf7246945b82c1d51-a5eadbbed1f2075952900628456bfd6830541629-0-5460

The parts from left to right:

  • Session id - Generated session id
  • Checksum - Checksum of session salt, session id, node id and primary key
  • Node id - The id of the node where the session maps to
  • Primary key - The primary key of the row where the session is stored

The checksum contains SHA1 sum of the node id, primary key, session id and the salt which is known only on the server side. This allows quick mapping of session id to node and primary key since there is no need to do an additional search. During session id regeneration only the parts 1 and 2 change but the mapping to the node and primary key stays constant.

In case some of the nodes fail tokyo_tyrant.allow_failover, tokyo_tyrant.fail_threshold and tokyo_tyrant.health_check_divisor INI-settings control the behavior during failover. If failover is allowed the session handler will map the session to a healthy node and creates a new empty session.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

tokyo_tyrant Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
tokyo_tyrant.default_timeout | 2.0 | PHP_INI_ALL |
tokyo_tyrant.session_salt | NULL | PHP_INI_ALL |
tokyo_tyrant.key_prefix | NULL | PHP_INI_ALL |
tokyo_tyrant.allow_failover | 1 | PHP_INI_ALL |
tokyo_tyrant.fail_threshold | 5 | PHP_INI_ALL |
tokyo_tyrant.health_check_divisor | 1000 | PHP_INI_ALL |
tokyo_tyrant.php_expiration | 0 | PHP_INI_ALL |

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

tokyo_tyrant.default_timeout integer

Default timeout when connecting to databases

tokyo_tyrant.session_salt string

The secret that is used to salt session id

tokyo_tyrant.key_prefix string

Prefix all keys with this string. The prefix is transparent to the developer but helps making sure that keys won't collide if multiple applications are using the same database.

tokyo_tyrant.allow_failover integer

Whether to allow session failover in case a server dies.

tokyo_tyrant.fail_threshold integer

How many read/write or connection failures is allowed before server is marked as failed.

tokyo_tyrant.health_check_divisor integer

Defines the divisor for the health check probability. If there are failed servers and the probability matches, the servers are health checked and in case the server seems healthy, it will be added back to the pool.

tokyo_tyrant.php_expiration integer

Whether to use built in session expiration mechanism or delegate the expiration to a lua-script on the server-side.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

TokyoTyrant constants

Özkaynak Türleri
Örnekler
tokyo_tyrant


Örnekler

Basic usage

Örnek 1 Putting and getting a key-value pair

<?php
$tt = new TokyoTyrant("localhost");
$tt->put("key", "value");
echo $tt->get("key");
?>

Yukarıdaki örneğin çıktısı:

value
Öntanımlı Sabitler
TokyoTyrant
tokyo_tyrant


The TokyoTyrant class

(PECL tokyo_tyrant >= 0.1.0)

Giriş

The main Tokyo Tyrant class

Sınıf Sözdizimi

TokyoTyrant {
/* Sabitler */
const integer RDBDEF_PORT = 1978 ;
const integer RDBQC_STREQ = 0 ;
const integer RDBQC_STRINC = 1 ;
const integer RDBQC_STRBW = 2 ;
const integer RDBQC_STREW = 3 ;
const integer RDBQC_STRAND = 4 ;
const integer RDBQC_STROR = 5 ;
const integer RDBQC_STROREQ = 6 ;
const integer RDBQC_STRRX = 7 ;
const integer RDBQC_NUMEQ = 8 ;
const integer RDBQC_NUMGT = 9 ;
const integer RDBQC_NUMGE = 10 ;
const integer RDBQC_NUMLT = 11 ;
const integer RDBQC_NUMLE = 12 ;
const integer RDBQC_NUMBT = 13 ;
const integer RDBQC_NUMOREQ = 14 ;
const integer RDBQC_NEGATE = 16777216 ;
const integer RDBQC_NOIDX = 33554432 ;
const integer RDBQO_STRASC = 0 ;
const integer RDBQO_STRDESC = 1 ;
const integer RDBQO_NUMASC = 2 ;
const integer RDBQO_NUMDESC = 3 ;
const integer RDBIT_LEXICAL = 0 ;
const integer RDBIT_DECIMAL = 1 ;
const integer RDBIT_TOKEN = 2 ;
const integer RDBIT_QGRAM = 3 ;
const integer RDBIT_OPT = 9998 ;
const integer RDBIT_VOID = 9999 ;
const integer RDBIT_KEEP = 16777216 ;
const integer RDBQCFTS_PH = 15 ;
const integer RDBQCFTS_AND = 16 ;
const integer RDBQCFTS_OR = 17 ;
const integer RDBQCFTS_EX = 18 ;
const integer RDBXO_LCKREC = 1 ;
const integer RDBXOLCK_GLB = 2 ;
const integer RDBREC_INT = 1 ;
const integer RDBREC_DBL = 2 ;
const integer RDBMS_UNION = 0 ;
const integer RDBMS_ISECT = 1 ;
const integer RDBMS_DIFF = 2 ;
const integer RDBT_RECON = 1 ;
/* Yöntemler */
public number add ( string $key , number $increment [, int $type = 0 ] )
public TokyoTyrant connect ( string $host [, int $port = TokyoTyrant::RDBDEF_PORT [, array $options ]] )
public TokyoTyrant connectUri ( string $uri )
public __construct ([ string $host [, int $port = TokyoTyrant::RDBDEF_PORT [, array $options ]]] )
public TokyoTyrant copy ( string $path )
public string ext ( string $name , int $options , string $key , string $value )
public array fwmKeys ( string $prefix , int $max_recs )
public mixed get ( mixed $keys )
public TokyoTyrantIterator getIterator ( void )
public int num ( void )
public TokyoTyrant out ( mixed $keys )
public TokyoTyrant put ( mixed $keys [, string $value = NULL ] )
public TokyoTyrant putCat ( mixed $keys [, string $value ] )
public TokyoTyrant putKeep ( mixed $keys [, string $value ] )
public TokyoTyrant putNr ( mixed $keys [, string $value = NULL ] )
public mixed putShl ( string $key , string $value , int $width )
public mixed restore ( string $log_dir , int $timestamp [, bool $check_consistency = true ] )
public mixed setMaster ( string $host , int $port , int $timestamp [, bool $check_consistency = true ] )
public int size ( string $key )
public array stat ( void )
public mixed sync ( void )
public TokyoTyrant tune ( float $timeout [, int $options = TokyoTyrant::RDBT_RECON ] )
public mixed vanish ( void )
}

Öntanımlı Sabitler

TokyoTyrant Constants

TokyoTyrant::RDBDEF_PORT

The default port of the Tokyo Tyrant database

TokyoTyrant::RDBQC_STREQ

string is equal to

TokyoTyrant::RDBQC_STRINC

string is included in

TokyoTyrant::RDBQC_STRBW

string begins with

TokyoTyrant::RDBQC_STREW

string ends with

TokyoTyrant::RDBQC_STRAND

string includes all tokens in

TokyoTyrant::RDBQC_STROR

string includes at least one token in

TokyoTyrant::RDBQC_STROREQ

string is equal to at least one token in

TokyoTyrant::RDBQC_STRRX

string matches regular expressions of

TokyoTyrant::RDBQC_NUMEQ

number is equal to

TokyoTyrant::RDBQC_NUMGT

number is greater than

TokyoTyrant::RDBQC_NUMGE

number is greater than or equal to

TokyoTyrant::RDBQC_NUMLT

number is less than

TokyoTyrant::RDBQC_NUMLE

number is less than or equal to

TokyoTyrant::RDBQC_NUMBT

number is between two tokens of

TokyoTyrant::RDBQC_NUMOREQ

number is equal to at least one token in

TokyoTyrant::RDBQC_NEGATE

negation flag

TokyoTyrant::RDBQC_NOIDX

no index flag

TokyoTyrant::RDBQO_STRASC

string ascending

TokyoTyrant::RDBQO_STRDESC

string descending

TokyoTyrant::RDBQO_NUMASC

number ascending

TokyoTyrant::RDBQO_NUMDESC

number descending

TokyoTyrant::RDBIT_LEXICAL

lexical string

TokyoTyrant::RDBIT_DECIMAL

decimal string

TokyoTyrant::RDBIT_TOKEN

token inverted index (Tokyo Tyrant >= 1.1.29)

TokyoTyrant::RDBIT_QGRAM

QGRAM inverted index (Tokyo Tyrant >= 1.1.29)

TokyoTyrant::RDBIT_OPT

optimize

TokyoTyrant::RDBIT_VOID

void

TokyoTyrant::RDBIT_KEEP

keep existing index

TokyoTyrant::RDBQCFTS_PH

full-text search with the phrase of (Tokyo Tyrant >= 1.1.29)

TokyoTyrant::RDBQCFTS_AND

full-text search with all tokens in (Tokyo Tyrant >= 1.1.29)

TokyoTyrant::RDBQCFTS_OR

full-text search with at least one token in (Tokyo Tyrant >= 1.1.29)

TokyoTyrant::RDBQCFTS_EX

full-text search with the compound expression of (Tokyo Tyrant >= 1.1.29)

TokyoTyrant::RDBQCFTS_AND

Metasearch union between records (Tokyo Tyrant >= 1.1.33)

TokyoTyrant::RDBQCFTS_OR

Metasearch intersection between records (Tokyo Tyrant >= 1.1.33)

TokyoTyrant::RDBQCFTS_EX

Metasearch difference between records (Tokyo Tyrant >= 1.1.33)

TokyoTyrant::RDBT_RECON

Whether to reconnect on connection failure. It is recommended to have this parameter on for persistent connections

TokyoTyrant::RDBXOLCK_REC

record locking

TokyoTyrant::RDBXOLCK_GLB

global locking

TokyoTyrant::RDBREC_INT

record type int

TokyoTyrant::RDBREC_DBL

record type float (double)

TokyoTyrant::TTE_SUCCESS

success

TokyoTyrant::TTE_INVALID

invalid operation

TokyoTyrant::TTE_NOHOST

host not found

TokyoTyrant::TTE_REFUSED

connection refused

TokyoTyrant::TTE_SEND

send error

TokyoTyrant::TTE_RECV

recv error

TokyoTyrant::TTE_KEEP

record exist

TokyoTyrant::TTE_NOREC

no record found

TokyoTyrant::TTE_MISC

miscellaneous error

İçindekiler

  • TokyoTyrant::add — Adds to a numeric key
  • TokyoTyrant::connect — Connect to a database
  • TokyoTyrant::connectUri — Connects to a database
  • TokyoTyrant::__construct — Construct a new TokyoTyrant object
  • TokyoTyrant::copy — Copies the database
  • TokyoTyrant::ext — Execute a remote script
  • TokyoTyrant::fwmKeys — Returns the forward matching keys
  • TokyoTyrant::get — The get purpose
  • TokyoTyrant::getIterator — Get an iterator
  • TokyoTyrant::num — Number of records in the database
  • TokyoTyrant::out — Removes records
  • TokyoTyrant::put — Puts values
  • TokyoTyrant::putCat — Concatenates to a record
  • TokyoTyrant::putKeep — Puts a record
  • TokyoTyrant::putNr — Puts value
  • TokyoTyrant::putShl — Concatenates to a record
  • TokyoTyrant::restore — Restore the database
  • TokyoTyrant::setMaster — Set the replication master
  • TokyoTyrant::size — Returns the size of the value
  • TokyoTyrant::stat — Get statistics
  • TokyoTyrant::sync — Synchronize the database
  • TokyoTyrant::tune — Tunes connection values
  • TokyoTyrant::vanish — Empties the database
Örnekler
TokyoTyrant::add
tokyo_tyrant


Adds to a numeric key

TokyoTyrant
TokyoTyrant::connect
TokyoTyrant
PHP Manual

TokyoTyrant::add

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::add — Adds to a numeric key

Açıklama

public number TokyoTyrant::add ( string $key , number $increment [, int $type = 0 ] )

Adds to an int or double value. This increments the value by the given amount and returns the new value. If the key does not exist a new key is created with initial value of the increment parameter.

Değiştirgeler

key

The string key

increment

The amount to increment

type

TokyoTyrant::RDBREC_INT or TokyoTyrant::RDBREC_DBL constant. If this parameter is omitted the type is guessed from the increment parameters type.

Dönen Değerler

Returns the new value on success

Örnekler

Örnek 1 TokyoTyrant::add() example

<?php
$tt = new TokyoTyrant("localhost", TokyoTyrant::RDBDEF_PORT);
/* Adds integer 3 to key and creates a new key */
$tt->add("test", 3);

/* String value is converted to double */
echo $tt->add("test", "3.5", TokyoTyrant::RDBREC_DBL);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

6.5

Ayrıca Bakınız

  • TokyoTyrant::put() - Puts values
  • TokyoTyrant::putcat() - Concatenates to a record
  • TokyoTyrant::putkeep() - Puts a record

TokyoTyrant
TokyoTyrant::connect
TokyoTyrant


Connect to a database

TokyoTyrant::add
TokyoTyrant::connectUri
TokyoTyrant
PHP Manual

TokyoTyrant::connect

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::connect — Connect to a database

Açıklama

public TokyoTyrant TokyoTyrant::connect ( string $host [, int $port = TokyoTyrant::RDBDEF_PORT [, array $options ]] )

Connects to a remote database

Değiştirgeler

host

The hostname

port

The port. Default: 1978

options

Connection options: timeout (default: 5.0), reconnect (default: TRUE) and persistent (default: TRUE)

Dönen Değerler

This method returns the current object and throws TokyoTyrantException on failure.

Örnekler

Örnek 1 TokyoTyrant::connect() example

<?php
$tt = new TokyoTyrant();
$tt->connect("localhost", TokyoTyrant::RDBDEF_PORT)->put("test", "value");
?>

Ayrıca Bakınız

  • TokyoTyrant::connectUri() - Connects to a database

TokyoTyrant::add
TokyoTyrant::connectUri
TokyoTyrant


Connects to a database

TokyoTyrant::connect
TokyoTyrant::__construct
TokyoTyrant
PHP Manual

TokyoTyrant::connectUri

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::connectUri — Connects to a database

Açıklama

public TokyoTyrant TokyoTyrant::connectUri ( string $uri )

Connects to a database using an uri

Değiştirgeler

uri

An URI to the database. For example tcp://localhost:1979/

Dönen Değerler

This method returns the current object and throws TokyoTyrantException on failure.

Örnekler

Örnek 1 TokyoTyrant::connectUri() example

<?php
$tt = new TokyoTyrant();
$tt->connectUri("tcp://localhost:1978/")->put("test", "hi");
?>

Ayrıca Bakınız

  • TokyoTyrant::connect() - Connect to a database

TokyoTyrant::connect
TokyoTyrant::__construct
TokyoTyrant


Construct a new TokyoTyrant object

TokyoTyrant::connectUri
TokyoTyrant::copy
TokyoTyrant
PHP Manual

TokyoTyrant::__construct

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::__construct — Construct a new TokyoTyrant object

Açıklama

public TokyoTyrant::__construct ([ string $host [, int $port = TokyoTyrant::RDBDEF_PORT [, array $options ]]] )

Constructs a new TokyoTyrant object and optionally connects to the database

Değiştirgeler

host

The hostname. Default: NULL

port

port number. Default: 1978

options

Connection options: timeout (default: 5.0), reconnect (default: TRUE) and persistent (default: TRUE)

Dönen Değerler

Throws TokyoTyrantException if connection to database fails

Ayrıca Bakınız

  • TokyoTyrant::connect() - Connect to a database
  • TokyoTyrant::connectUri() - Connects to a database

TokyoTyrant::connectUri
TokyoTyrant::copy
TokyoTyrant


Copies the database

TokyoTyrant::__construct
TokyoTyrant::ext
TokyoTyrant
PHP Manual

TokyoTyrant::copy

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::copy — Copies the database

Açıklama

public TokyoTyrant TokyoTyrant::copy ( string $path )

Makes a copy of the current database

Değiştirgeler

path

Path to where to copy the database. The user running the remote database must have a write access to the directory.

Dönen Değerler

This method returns the current object and throws TokyoTyrantException on failure.

Örnekler

Örnek 1 TokyoTyrant::copy() example

<?php
$tt = new TokyoTyrant("localhost", 1978);
$tt->copy("/tmp/foobar.tct");
?>

Ayrıca Bakınız

  • TokyoTyrant::restore() - Restore the database

TokyoTyrant::__construct
TokyoTyrant::ext
TokyoTyrant


Execute a remote script

TokyoTyrant::copy
TokyoTyrant::fwmKeys
TokyoTyrant
PHP Manual

TokyoTyrant::ext

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::ext — Execute a remote script

Açıklama

public string TokyoTyrant::ext ( string $name , int $options , string $key , string $value )

Executes a remote script extension.

Değiştirgeler

name

Name of the function to execute

options

Either TokyoTyrant::RDBXO_LCKREC for record locking and TokyoTyrant::RDBXO_LCKGLB for global locking.

key

The key to pass to the function

value

The value to pass to the function

Dönen Değerler

Returns the result of the script function

Örnekler

Örnek 1 TokyoTyrant::ext() example

<?php
$tt = new TokyoTyrant("localhost", 1978);
echo $tt->ext("somefunc", TokyoTyrant::RDBXO_LCKREC, "some_key", "some_value");
?>

TokyoTyrant::copy
TokyoTyrant::fwmKeys
TokyoTyrant


Returns the forward matching keys

TokyoTyrant::ext
TokyoTyrant::get
TokyoTyrant
PHP Manual

TokyoTyrant::fwmKeys

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::fwmKeys — Returns the forward matching keys

Açıklama

public array TokyoTyrant::fwmKeys ( string $prefix , int $max_recs )

Returns the forward matching keys from the database

Değiştirgeler

prefix

Prefix of the keys

max_recs

Maximum records to return

Dönen Değerler

Returns an array of matching keys. The values are not returned

Örnekler

Örnek 1 TokyoTyrant::fwmKeys() example

<?php

$tt = new TokyoTyrant("localhost");

/* Create 20 macthing keys */
for ($i = 0; $i < 20; $i++) {
    $tt->put("key_" . $i, "value_" . $i);
}

/* Create 20 non-macthing keys */
for ($i = 0; $i < 20; $i++) {
    $tt->put("something_" . $i, "data_" . $i);
}

/* Get five matching keys */
var_dump($tt->fwmKeys("key_", 5));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(5) {
  [0]=>
  string(5) "key_5"
  [1]=>
  string(6) "key_14"
  [2]=>
  string(5) "key_6"
  [3]=>
  string(6) "key_15"
  [4]=>
  string(5) "key_7"
}

TokyoTyrant::ext
TokyoTyrant::get
TokyoTyrant


The get purpose

TokyoTyrant::fwmKeys
TokyoTyrant::getIterator
TokyoTyrant
PHP Manual

TokyoTyrant::get

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::get — The get purpose

Açıklama

public mixed TokyoTyrant::get ( mixed $keys )

This method is used to return a value or multiple values. This method accepts a string or an array as a value.

Değiştirgeler

keys

A string key or an array of string keys

Dönen Değerler

Returns a string or an array based on the given parameters. Throws a TokyoTyrantException on error. If string is passed null is returned if the key is not found. In case an array is given as an parameter only existing keys will be returned. It is not an error to pass a key that does not exist.

Örnekler

Örnek 1 TokyoTyrant::get() example

<?php
$tt = new TokyoTyrant("localhost", 1978);
$tt->put("key1", "value1");
$tt->put("key2", "value2");
var_dump($tt->get(array("key1", "key2")));
var_dump($tt->get("key1"));
?>

Yukarıdaki örneğin çıktısı:

array(2) {
  ["key1"]=>
  string(6) "value1"
  ["key2"]=>
  string(6) "value2"
}
string(6) "value1"

Ayrıca Bakınız

  • TokyoTyrant::put() - Puts values

TokyoTyrant::fwmKeys
TokyoTyrant::getIterator
TokyoTyrant


Get an iterator

TokyoTyrant::get
TokyoTyrant::num
TokyoTyrant
PHP Manual

TokyoTyrant::getIterator

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

TokyoTyrant::getIterator — Get an iterator

Açıklama

public TokyoTyrantIterator TokyoTyrant::getIterator ( void )

Gets an iterator for iterating all keys / values in the database.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

This method returns TokyoTyrantIterator object and throws TokyoTyrantException on failure.

Örnekler

Örnek 1 TokyoTyrant::getIterator() example

<?php
$tt = new TokyoTyrant("localhost");
$it = $tt->getIterator();

foreach ($it as $k => $v) {

}
?>

Ayrıca Bakınız

  • TokyoTyrantTable::getQuery() - Get a query object
  • TokyoTyrantTable::getIterator() - Get an iterator

TokyoTyrant::get
TokyoTyrant::num
TokyoTyrant


Number of records in the database

TokyoTyrant::getIterator
TokyoTyrant::out
TokyoTyrant
PHP Manual

TokyoTyrant::num

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::num — Number of records in the database

Açıklama

public int TokyoTyrant::num ( void )

Returns the number of records in the database

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns number of records in the database

Örnekler

Örnek 1 TokyoTyrant::num() example

<?php
/* Connect to a database on default port */
$tt = new TokyoTyrant("localhost");

/* Echo the number of records */
echo $tt->num();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

1234

Ayrıca Bakınız

  • TokyoTyrant::stat() - Get statistics

TokyoTyrant::getIterator
TokyoTyrant::out
TokyoTyrant


Removes records

TokyoTyrant::num
TokyoTyrant::put
TokyoTyrant
PHP Manual

TokyoTyrant::out

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::out — Removes records

Açıklama

public TokyoTyrant TokyoTyrant::out ( mixed $keys )

Removes a record or multiple records. This method accepts a string for a single key or an array of keys for multiple records.

Değiştirgeler

keys

A string key or an array of string keys

Dönen Değerler

This method returns the current object and throws TokyoTyrantException on failure.

Örnekler

Örnek 1 TokyoTyrant::out() example

<?php
/* Connect to a database on default port */
$tt = new TokyoTyrant("localhost");

$tt->put("test1", "value1");
$tt->put("test2", "value2");

$tt->out(array("test1", "test2"));
?>

Ayrıca Bakınız

  • TokyoTyrant::put() - Puts values

TokyoTyrant::num
TokyoTyrant::put
TokyoTyrant


Puts values

TokyoTyrant::out
TokyoTyrant::putCat
TokyoTyrant
PHP Manual

TokyoTyrant::put

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::put — Puts values

Açıklama

public TokyoTyrant TokyoTyrant::put ( mixed $keys [, string $value = NULL ] )

Puts a key-value pair into the database or multiple key-value pairs. If keys is string then the second parameter value defines the value. The second parameter is mandatory if keys is a string. If the key exists the value will be replaced with new value.

Değiştirgeler

keys

A string key or an array of key-value pairs

value

The value in case a string key is used

Dönen Değerler

This method returns a reference to the current object and throws TokyoTyrantException on failure.

Örnekler

Örnek 1 TokyoTyrant::put() example

<?php
/* Connect to a database on default port */
$tt = new TokyoTyrant("localhost");

/* Put single key-value pair */
$tt->put("key", "value");

/* Put key-value pairs, new value overwrites the old */
$tt->put(array("key1" => "value1", "key" => "value2"));

/* Get back one key */
echo $tt->get("key");
?>

Yukarıdaki örneğin çıktısı:

value2

Ayrıca Bakınız

  • TokyoTyrant::putKeep() - Puts a record
  • TokyoTyrant::putCat() - Concatenates to a record

TokyoTyrant::out
TokyoTyrant::putCat
TokyoTyrant


Concatenates to a record

TokyoTyrant::put
TokyoTyrant::putKeep
TokyoTyrant
PHP Manual

TokyoTyrant::putCat

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::putCat — Concatenates to a record

Açıklama

public TokyoTyrant TokyoTyrant::putCat ( mixed $keys [, string $value ] )

Appends a value into existing key or multiple values if keys is an array. The second parameter is mandatory if keys is a string. If the record does not exist a new record is created.

Değiştirgeler

keys

A string key or an array of key-value pairs

value

The value in case a string key is used

Dönen Değerler

This method returns a reference to the current object and throws TokyoTyrantException on failure.

Örnekler

Örnek 1 TokyoTyrant::putCat() example

<?php
/* Connect to a database on default port */
$tt = new TokyoTyrant("localhost");

/* Create a new key */
$tt->put("key", "value");

/* Concatenate single key-value pair */
$tt->putCat("key", " has more data");

/* Echo the key */
echo $tt->get("key");
?>

Yukarıdaki örneğin çıktısı:

value has more data

Ayrıca Bakınız

  • TokyoTyrant::put() - Puts values
  • TokyoTyrant::putKeep() - Puts a record

TokyoTyrant::put
TokyoTyrant::putKeep
TokyoTyrant


Puts a record

TokyoTyrant::putCat
TokyoTyrant::putNr
TokyoTyrant
PHP Manual

TokyoTyrant::putKeep

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::putKeep — Puts a record

Açıklama

public TokyoTyrant TokyoTyrant::putKeep ( mixed $keys [, string $value ] )

Puts a key-value pair into the database or multiple key-value pairs. If keys is string then the second parameter value defines the value. The second parameter is mandatory if keys is a string. If the key already exists this method throws an exception indicating that the records exists.

Değiştirgeler

keys

A string key or an array of key-value pairs

value

The string value

Dönen Değerler

This method returns a reference to the current object and throws TokyoTyrantException on failure.

Örnekler

Örnek 1 tokyotyrant::putKeep() example

<?php
/* Connect to a database on default port */
$tt = new TokyoTyrant("localhost");

/* Create a new key */
$tt->put("key", "value");

try {
    $tt->putKeep("key", "new value");
} catch (TokyoTyrantException $e) {
    if ($e->getCode() === TokyoTyrant::TTE_KEEP) {
        echo "Existing record! Not modified\n";
    } else {
        echo "Error: " , $e->getMessage() , "\n";
    }
}
echo $tt->get("key");
?>

Yukarıdaki örneğin çıktısı:

Existing record! Not modified
value

Ayrıca Bakınız

  • TokyoTyrant::put() - Puts values
  • TokyoTyrant::putCat() - Concatenates to a record

TokyoTyrant::putCat
TokyoTyrant::putNr
TokyoTyrant


Puts value

TokyoTyrant::putKeep
TokyoTyrant::putShl
TokyoTyrant
PHP Manual

TokyoTyrant::putNr

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::putNr — Puts value

Açıklama

public TokyoTyrant TokyoTyrant::putNr ( mixed $keys [, string $value = NULL ] )

Puts a key-value pair into the database or multiple key-value pairs. If keys is string then the second parameter value defines the value. The second parameter is mandatory if keys is a string. This method does not wait for the response from the server.

Değiştirgeler

keys

A string key or an array of key-value pairs

value

The value in case a string key is used

Dönen Değerler

This method returns a reference to the current object and throws TokyoTyrantException on failure.

Örnekler

Örnek 1 TokyoTyrant::putNr() example

<?php
/* Connect to a database on default port */
$tt = new TokyoTyrant("localhost");

/* Put single key-value pair */
$tt->putNr("key", "value");

/* Put key-value pairs */
$tt->putNr(array("key1" => "value1", "key2" => "value2"));

/* Get back one key */
echo $tt->get("key1");
?>

Yukarıdaki örneğin çıktısı:

value1

Ayrıca Bakınız

  • TokyoTyrant::putNr()
  • TokyoTyrant::putKeep() - Puts a record
  • TokyoTyrant::putCat() - Concatenates to a record

TokyoTyrant::putKeep
TokyoTyrant::putShl
TokyoTyrant


Concatenates to a record

TokyoTyrant::putNr
TokyoTyrant::restore
TokyoTyrant
PHP Manual

TokyoTyrant::putShl

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::putShl — Concatenates to a record

Açıklama

public mixed TokyoTyrant::putShl ( string $key , string $value , int $width )

Concatenate to a record and shift to left.

Değiştirgeler

key

A string key

value

The value to concatenate

width

The width of the record

Dönen Değerler

This method returns a reference to the current object and throws TokyoTyrantException on failure.

Örnekler

Örnek 1 TokyoTyrant::putShl() example

<?php
/* Connect to a database on default port */
$tt = new TokyoTyrant("localhost");

/* Create a new key */
$tt->put("key", "just a long piece of data");

/* Concatenate and shift to left */
$tt->putShl("key", " and string", 15);

/* Echo the key */
echo $tt->get("key");
?>

Yukarıdaki örneğin çıktısı:

data and string

Ayrıca Bakınız

  • TokyoTyrant::put() - Puts values
  • TokyoTyrant::putKeep() - Puts a record
  • TokyoTyrant::putCat() - Concatenates to a record

TokyoTyrant::putNr
TokyoTyrant::restore
TokyoTyrant


Restore the database

TokyoTyrant::putShl
TokyoTyrant::setMaster
TokyoTyrant
PHP Manual

TokyoTyrant::restore

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::restore — Restore the database

Açıklama

public mixed TokyoTyrant::restore ( string $log_dir , int $timestamp [, bool $check_consistency = true ] )

Restore the database from the update log.

Uyarı

This method is not supported on 32bit platforms.

Değiştirgeler

log_dir

Directory where the log is

timestamp

Beginning timestamp with microseconds

check_consistency

Whether to check consistency: Default: TRUE

Dönen Değerler

This method returns the current object and throws TokyoTyrantException on failure.

TokyoTyrant::putShl
TokyoTyrant::setMaster
TokyoTyrant


Set the replication master

TokyoTyrant::restore
TokyoTyrant::size
TokyoTyrant
PHP Manual

TokyoTyrant::setMaster

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::setMaster — Set the replication master

Açıklama

public mixed TokyoTyrant::setMaster ( string $host , int $port , int $timestamp [, bool $check_consistency = true ] )

Sets the replication master of the database

Uyarı

This method is not supported on 32bit platforms.

Değiştirgeler

host

Hostname of the replication master. If NULL the replication is disabled.

port

Port of the replication master

timestamp

Beginning timestamp with microseconds

check_consistency

Whether to check consistency.

Dönen Değerler

This method returns the current object and throws TokyoTyrantException on failure.

Örnekler

Örnek 1 TokyoTyrant::setMaster() example

<?php
/* Connect to a database */
$tt = new TokyoTyrant("tokyotyrant.example.com");

/* Disable the replication */
$tt->setMaster(NULL, 0, 0);
?>

Ayrıca Bakınız

  • Classname::Method()

TokyoTyrant::restore
TokyoTyrant::size
TokyoTyrant


Returns the size of the value

TokyoTyrant::setMaster
TokyoTyrant::stat
TokyoTyrant
PHP Manual

TokyoTyrant::size

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::size — Returns the size of the value

Açıklama

public int TokyoTyrant::size ( string $key )

Returns the size of a value by key

Değiştirgeler

key

The key of which size to fetch

Dönen Değerler

Returns the size of the key or throw TokyoTyrantException on error

Örnekler

Örnek 1 TokyoTyrant::size() example

<?php
$tt = new TokyoTyrant("localhost");

$tt->put("test_key", "12345");

echo $tt->size("test_key");
?>

Yukarıdaki örneğin çıktısı:

5

TokyoTyrant::setMaster
TokyoTyrant::stat
TokyoTyrant


Get statistics

TokyoTyrant::size
TokyoTyrant::sync
TokyoTyrant
PHP Manual

TokyoTyrant::stat

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::stat — Get statistics

Açıklama

public array TokyoTyrant::stat ( void )

Returns statistics of the remote database

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array of key value pairs describing the statistics

Örnekler

Örnek 1 TokyoTyrant::stat() example

<?php
$tt = new TokyoTyrant("localhost");

var_dump($tt->stat());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(19) {
  ["version"]=>
  string(6) "1.1.28"
  ["libver"]=>
  string(3) "311"
  ["protver"]=>
  string(4) "0.91"
  ["os"]=>
  string(5) "Linux"
  ["time"]=>
  string(17) "1247358357.665630"
  ["pid"]=>
  string(5) "14348"
  ["sid"]=>
  string(8) "59025947"
  ["type"]=>
  string(9) "on-memory"
  ["path"]=>
  string(1) "*"
  ["rnum"]=>
  string(1) "4"
  ["size"]=>
  string(6) "262856"
  ["bigend"]=>
  string(1) "0"
  ["fd"]=>
  string(1) "5"
  ["loadavg"]=>
  string(8) "0.000000"
  ["memsize"]=>
  string(8) "77328384"
  ["memrss"]=>
  string(7) "1183744"
  ["ru_real"]=>
  string(13) "162776.042152"
  ["ru_user"]=>
  string(8) "0.476029"
  ["ru_sys"]=>
  string(8) "8.652540"
}

Ayrıca Bakınız

  • Classname::Method()

TokyoTyrant::size
TokyoTyrant::sync
TokyoTyrant


Synchronize the database

TokyoTyrant::stat
TokyoTyrant::tune
TokyoTyrant
PHP Manual

TokyoTyrant::sync

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::sync — Synchronize the database

Açıklama

public mixed TokyoTyrant::sync ( void )

Synchronizes the database on to the physical device

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

This method returns the current object and throws TokyoTyrantException on failure.

TokyoTyrant::stat
TokyoTyrant::tune
TokyoTyrant


Tunes connection values

TokyoTyrant::sync
TokyoTyrant::vanish
TokyoTyrant
PHP Manual

TokyoTyrant::tune

(PECL tokyo_tyrant >= 0.2.0)

TokyoTyrant::tune — Tunes connection values

Açıklama

public TokyoTyrant TokyoTyrant::tune ( float $timeout [, int $options = TokyoTyrant::RDBT_RECON ] )

Tunes database connection options.

Değiştirgeler

timeout

The objects timeout value (default: 5.0)

options

Bitmask of options to tune. This can be either 0 or TokyoTyrant::RDBT_RECON. It is recommended not to change the second parameter.

Dönen Değerler

This method returns a reference to the current object and throws TokyoTyrantException on failure.

TokyoTyrant::sync
TokyoTyrant::vanish
TokyoTyrant


Empties the database

TokyoTyrant::tune
TokyoTyrantTable
TokyoTyrant
PHP Manual

TokyoTyrant::vanish

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrant::vanish — Empties the database

Açıklama

public mixed TokyoTyrant::vanish ( void )

Empties a remote database

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

This method returns the current object and throws TokyoTyrantException on failure.

Örnekler

Örnek 1 TokyoTyrant::vanish() example

<?php
$tt = new TokyoTyrant("localhost");
$tt->vanish();
?>

Ayrıca Bakınız

  • TokyoTyrant::out() - Removes records

TokyoTyrant::tune
TokyoTyrantTable
TokyoTyrant


The TokyoTyrantTable class

(PECL tokyo_tyrant >= 0.1.0)

Giriş

Provides an API to the table databases. A table database can be create using the following command: ttserver -port 1979 /tmp/tt_table.tct. In Tokyo Tyrant the table API is a schemaless database which can store arbitrary amount of key-value pairs under a single primary key.

Sınıf Sözdizimi

TokyoTyrantTable extends TokyoTyrant {
/* Yöntemler */
public void add ( string $key , mixed $increment [, string $type ] )
public int genUid ( void )
public array get ( mixed $keys )
public TokyoTyrantIterator getIterator ( void )
public TokyoTyrantQuery getQuery ( void )
public void out ( mixed $keys )
public int put ( string $key , array $columns )
public void putCat ( string $key , array $columns )
public void putKeep ( string $key , array $columns )
public void putNr ( mixed $keys [, string $value ] )
public void putShl ( string $key , string $value , int $width )
public mixed setIndex ( string $column , int $type )
/* Miras alınan yöntemler */
public number TokyoTyrant::add ( string $key , number $increment [, int $type = 0 ] )
public TokyoTyrant TokyoTyrant::connect ( string $host [, int $port = TokyoTyrant::RDBDEF_PORT [, array $options ]] )
public TokyoTyrant TokyoTyrant::connectUri ( string $uri )
public TokyoTyrant::__construct ([ string $host [, int $port = TokyoTyrant::RDBDEF_PORT [, array $options ]]] )
public TokyoTyrant TokyoTyrant::copy ( string $path )
public string TokyoTyrant::ext ( string $name , int $options , string $key , string $value )
public array TokyoTyrant::fwmKeys ( string $prefix , int $max_recs )
public mixed TokyoTyrant::get ( mixed $keys )
public TokyoTyrantIterator TokyoTyrant::getIterator ( void )
public int TokyoTyrant::num ( void )
public TokyoTyrant TokyoTyrant::out ( mixed $keys )
public TokyoTyrant TokyoTyrant::put ( mixed $keys [, string $value = NULL ] )
public TokyoTyrant TokyoTyrant::putCat ( mixed $keys [, string $value ] )
public TokyoTyrant TokyoTyrant::putKeep ( mixed $keys [, string $value ] )
public TokyoTyrant TokyoTyrant::putNr ( mixed $keys [, string $value = NULL ] )
public mixed TokyoTyrant::putShl ( string $key , string $value , int $width )
public mixed TokyoTyrant::restore ( string $log_dir , int $timestamp [, bool $check_consistency = true ] )
public mixed TokyoTyrant::setMaster ( string $host , int $port , int $timestamp [, bool $check_consistency = true ] )
public int TokyoTyrant::size ( string $key )
public array TokyoTyrant::stat ( void )
public mixed TokyoTyrant::sync ( void )
public TokyoTyrant TokyoTyrant::tune ( float $timeout [, int $options = TokyoTyrant::RDBT_RECON ] )
public mixed TokyoTyrant::vanish ( void )
}

İçindekiler

  • TokyoTyrantTable::add — Adds a record
  • TokyoTyrantTable::genUid — Generate unique id
  • TokyoTyrantTable::get — Get a row
  • TokyoTyrantTable::getIterator — Get an iterator
  • TokyoTyrantTable::getQuery — Get a query object
  • TokyoTyrantTable::out — Remove records
  • TokyoTyrantTable::put — Store a row
  • TokyoTyrantTable::putCat — Concatenates to a row
  • TokyoTyrantTable::putKeep — Put a new record
  • TokyoTyrantTable::putNr — Puts value
  • TokyoTyrantTable::putShl — Concatenates to a record
  • TokyoTyrantTable::setIndex — Sets index
TokyoTyrant::vanish
TokyoTyrantTable::add
tokyo_tyrant


Adds a record

TokyoTyrantTable
TokyoTyrantTable::genUid
TokyoTyrantTable
PHP Manual

TokyoTyrantTable::add

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantTable::add — Adds a record

Açıklama

public void TokyoTyrantTable::add ( string $key , mixed $increment [, string $type ] )

This method is not supported with table databases.

Değiştirgeler

key

The string key

increment

The amount to increment

type

TokyoTyrant::RDB_RECINT or TokyoTyrant::RDB_RECDBL constant. If this parameter is omitted the type is guessed from the increment parameters type.

Dönen Değerler

This method throws an TokyoTyrantException if used through this class.

Ayrıca Bakınız

  • TokyoTyrant::add() - Adds to a numeric key

TokyoTyrantTable
TokyoTyrantTable::genUid
TokyoTyrantTable


Generate unique id

TokyoTyrantTable::add
TokyoTyrantTable::get
TokyoTyrantTable
PHP Manual

TokyoTyrantTable::genUid

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantTable::genUid — Generate unique id

Açıklama

public int TokyoTyrantTable::genUid ( void )

Generates an unique id inside the table database. In table databases rows are referenced using a numeric primary key.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an unique id or throws TokyoTyrantException on error

Örnekler

Örnek 1 TokyoTyrantTable::genUid() example

<?php
$tt = new TokyoTyrantTable("localhost", 1122);

echo $tt->genUid();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

4

Ayrıca Bakınız

  • TokyoTyrantTable::put() - Store a row

TokyoTyrantTable::add
TokyoTyrantTable::get
TokyoTyrantTable


Get a row

TokyoTyrantTable::genUid
TokyoTyrantTable::getIterator
TokyoTyrantTable
PHP Manual

TokyoTyrantTable::get

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantTable::get — Get a row

Açıklama

public array TokyoTyrantTable::get ( mixed $keys )

Gets a row from table database. keys is a single integer for the primary key of the row or an array of integers for multiple rows.

Değiştirgeler

keys

The primary key, can be a string or an integer

Dönen Değerler

Returns the row as an array

Örnekler

Örnek 1 TokyoTyrantTable::get() example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Passing null to put generates a new uid */
$index = $tt->put(null, array("column1" => "some data", "column2" => "more data"));

/* Get the row back */
var_dump($tt->get($index));
?>

Yukarıdaki örneğin çıktısı:

array(2) {
  ["column1"]=>
  string(9) "some data"
  ["column2"]=>
  string(9) "more data"
}

Notlar

Bilginize:

Starting from version 0.3.0 this method accepts array as parameter. Please note that multi-get on tables is not binary-safe.

Ayrıca Bakınız

  • TokyoTyrantTable::put() - Store a row

TokyoTyrantTable::genUid
TokyoTyrantTable::getIterator
TokyoTyrantTable


Get an iterator

TokyoTyrantTable::get
TokyoTyrantTable::getQuery
TokyoTyrantTable
PHP Manual

TokyoTyrantTable::getIterator

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

TokyoTyrantTable::getIterator — Get an iterator

Açıklama

public TokyoTyrantIterator TokyoTyrantTable::getIterator ( void )

Gets an iterator for iterating all keys / values in the database.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

This method returns TokyoTyrantIterator object and throws TokyoTyrantException on failure.

Örnekler

Örnek 1 TokyoTyrantTable::getIterator() example

<?php
$tt = new TokyoTyrantTable("localhost");
$it = $tt->getIterator();

foreach ($it as $k => $v) {
  var_dump($k, $v);
}
?>

Ayrıca Bakınız

  • TokyoTyrantTable::getQuery() - Get a query object
  • TokyoTyrant::getIterator() - Get an iterator

TokyoTyrantTable::get
TokyoTyrantTable::getQuery
TokyoTyrantTable


Get a query object

TokyoTyrantTable::getIterator
TokyoTyrantTable::out
TokyoTyrantTable
PHP Manual

TokyoTyrantTable::getQuery

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantTable::getQuery — Get a query object

Açıklama

public TokyoTyrantQuery TokyoTyrantTable::getQuery ( void )

Get a query object to execute searches on the database

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TokyoTyrantQuery on success and throws TokyoTyrantException on error

Örnekler

Örnek 1 TokyoTyrantTable::getQuery() example

<?php
/* Connect to a table database */
$table = new TokyoTyrantTable("localhost", 1979);

/* Put a few rows */
$table->put(null, array("column1" => "some data", "column2" => "more data"));
$table->put(null, array("something" => "value", "data" => "good data"));

/* Get query object */
$query = $table->getQuery();

/* Add condition to query */
$query->addCond('data', TokyoTyrant::RDBQC_STREQ, 'good data');

/* Get matching rows */
var_dump($query->search());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(1) {
  [11]=>
  array(2) {
    ["something"]=>
    string(5) "value"
    ["data"]=>
    string(9) "good data"
  }
}

Ayrıca Bakınız

  • TokyoTyrantQuery::search() - Searches records
  • TokyoTyrantQuery::out() - Removes records based on query

TokyoTyrantTable::getIterator
TokyoTyrantTable::out
TokyoTyrantTable


Remove records

TokyoTyrantTable::getQuery
TokyoTyrantTable::put
TokyoTyrantTable
PHP Manual

TokyoTyrantTable::out

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantTable::out — Remove records

Açıklama

public void TokyoTyrantTable::out ( mixed $keys )

Removes records from a table database.

Değiştirgeler

keys

A single integer key or an array of integers

Dönen Değerler

This method returns the current object and throws TokyoTyrantException on failure.

Örnekler

Örnek 1 TokyoTyrantTable::out() example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Passing null to put generates a new uid */
$index = $tt->put(null, array("column1" => "some data", "column2" => "more data"));

/* Delete the row */
$tt->out($index);
?>

Ayrıca Bakınız

  • TokyoTyrantTable::put() - Store a row

TokyoTyrantTable::getQuery
TokyoTyrantTable::put
TokyoTyrantTable


Store a row

TokyoTyrantTable::out
TokyoTyrantTable::putCat
TokyoTyrantTable
PHP Manual

TokyoTyrantTable::put

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantTable::put — Store a row

Açıklama

public int TokyoTyrantTable::put ( string $key , array $columns )

Puts a new row into the database. This method parameters are key which is the primary key of the row, passing NULL will generate a new unique id. value is an array containing the row contents which is usually key value pairs.

Değiştirgeler

key

The primary key of the row

columns

The row contents

Dönen Değerler

Returns the primary key on success and throws TokyoTyrantException on error

Örnekler

Örnek 1 TokyoTyrantTable::put() example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Passing null to put generates a new uid */
$index = $tt->put(null, array("column1" => "some data", "column2" => "more data"));

/* Get the row back */
var_dump($tt->get($index));

/* Modify an existing row */
$tt->put($index, array("column1" => "other data", "column2" => "better data"));

/* Get the row back */
var_dump($tt->get($index));
?>

Yukarıdaki örneğin çıktısı:

array(2) {
  ["column1"]=>
  string(9) "some data"
  ["column2"]=>
  string(9) "more data"
}
array(2) {
  ["column1"]=>
  string(10) "other data"
  ["column2"]=>
  string(11) "better data"
}

Ayrıca Bakınız

  • TokyoTyrantTable::get() - Get a row

TokyoTyrantTable::out
TokyoTyrantTable::putCat
TokyoTyrantTable


Concatenates to a row

TokyoTyrantTable::put
TokyoTyrantTable::putKeep
TokyoTyrantTable
PHP Manual

TokyoTyrantTable::putCat

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantTable::putCat — Concatenates to a row

Açıklama

public void TokyoTyrantTable::putCat ( string $key , array $columns )

This method can be used to add new columns to existing records. Existing keys will be left unmodified but any new columns will be appended to the row. Passing null as key will generate a new row.

Değiştirgeler

key

The primary key of the row or NULL

columns

Array of row contents

Dönen Değerler

Returns the primary key and throws TokyoTyrantException on error.

Örnekler

Örnek 1 TokyoTyrantTable::putCat() example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Passing null to put generates a new uid */
$index = $tt->put(null, array("column1" => "some data", "column2" => "more data"));

/* Get the row back */
var_dump($tt->get($index));

/* Modify an existing row */
$tt->putcat($index, array("column1" => "something new", "new_column" => "other data"));

/* Get the row back */
var_dump($tt->get($index));
?>

Yukarıdaki örneğin çıktısı:

array(2) {
  ["column1"]=>
  string(9) "some data"
  ["column2"]=>
  string(9) "more data"
}
array(3) {
  ["column1"]=>
  string(9) "some data"
  ["column2"]=>
  string(9) "more data"
  ["new_column"]=>
  string(10) "other data"
}

Ayrıca Bakınız

  • TokyoTyrantTable::put() - Store a row

TokyoTyrantTable::put
TokyoTyrantTable::putKeep
TokyoTyrantTable


Put a new record

TokyoTyrantTable::putCat
TokyoTyrantTable::putNr
TokyoTyrantTable
PHP Manual

TokyoTyrantTable::putKeep

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantTable::putKeep — Put a new record

Açıklama

public void TokyoTyrantTable::putKeep ( string $key , array $columns )

Puts a new record into the database. If the key already exists this method throws an exception indicating that the records exists.

Değiştirgeler

key

The primary key of the row or NULL

columns

Array of the row contents

Dönen Değerler

Returns the primary key and throws TokyoTyrantException on error.

Örnekler

Örnek 1 TokyoTyrantTable::putKeep() example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Passing null to put generates a new uid */
$index = $tt->put(null, array("column1" => "some data", "column2" => "more data"));

/* Get the row back */
var_dump($tt->get($index));

try {
    $tt->putKeep($index, array("column1" => "something new", "new_column" => "other data"));
} catch (TokyoTyrantException $e) {
    if ($e->getCode() === TokyoTyrant::TTE_KEEP) {
        echo "Existing record! Not modified\n";
    } else {
        echo "Error: " , $e->getMessage() , "\n";
    }
}

/* Get the row back */
var_dump($tt->get($index));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(2) {
  ["column1"]=>
  string(9) "some data"
  ["column2"]=>
  string(9) "more data"
}
Existing record! Not modified
array(2) {
  ["column1"]=>
  string(9) "some data"
  ["column2"]=>
  string(9) "more data"
}

Ayrıca Bakınız

  • TokyoTyrantTable::put() - Store a row

TokyoTyrantTable::putCat
TokyoTyrantTable::putNr
TokyoTyrantTable


Puts value

TokyoTyrantTable::putKeep
TokyoTyrantTable::putShl
TokyoTyrantTable
PHP Manual

TokyoTyrantTable::putNr

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantTable::putNr — Puts value

Açıklama

public void TokyoTyrantTable::putNr ( mixed $keys [, string $value ] )

This method is not supported on table databases. Calling this method through TokyoTyrantTable is considered an error and an TokyoTyrantException will be thrown.

Değiştirgeler

keys

A string key or an array of key-value pairs

value

The value in case a string key is used

Dönen Değerler

This method is not supported on table databases. Calling this method through TokyoTyrantTable is considered an error and an TokyoTyrantException will be thrown.

Ayrıca Bakınız

  • TokyoTyrant::putNr() - Puts value
  • TokyoTyrant::putKeep() - Puts a record
  • TokyoTyrant::putCat() - Concatenates to a record

TokyoTyrantTable::putKeep
TokyoTyrantTable::putShl
TokyoTyrantTable


Concatenates to a record

TokyoTyrantTable::putNr
TokyoTyrantTable::setIndex
TokyoTyrantTable
PHP Manual

TokyoTyrantTable::putShl

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantTable::putShl — Concatenates to a record

Açıklama

public void TokyoTyrantTable::putShl ( string $key , string $value , int $width )

This method is not supported on table databases. Calling this method through TokyoTyrantTable is considered an error and an TokyoTyrantException will be thrown.

Değiştirgeler

key

A string key

value

The value to concatenate

width

The width of the record

Dönen Değerler

This method is not supported on table databases.

Ayrıca Bakınız

  • TokyoTyrant::put() - Puts values
  • TokyoTyrant::putKeep() - Puts a record
  • TokyoTyrant::putCat() - Concatenates to a record
  • TokyoTyrantTable::put() - Store a row
  • TokyoTyrantTable::putKeep() - Put a new record
  • TokyoTyrantTable::putCat() - Concatenates to a row

TokyoTyrantTable::putNr
TokyoTyrantTable::setIndex
TokyoTyrantTable


Sets index

TokyoTyrantTable::putShl
TokyoTyrantQuery
TokyoTyrantTable
PHP Manual

TokyoTyrantTable::setIndex

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantTable::setIndex — Sets index

Açıklama

public mixed TokyoTyrantTable::setIndex ( string $column , int $type )

Sets an index on a specified column. The index type is one of the TokyoTyrant::RDBIT_* constants. Passing TokyoTyrant::RDBIT_VOID removes the index.

Değiştirgeler

column

The name of the column

type

The index type

Dönen Değerler

This method returns the current object and throws TokyoTyrantException on failure.

TokyoTyrantTable::putShl
TokyoTyrantQuery
TokyoTyrantTable


The TokyoTyrantQuery class

(PECL tokyo_tyrant >= 0.1.0)

Giriş

This class is used to query the table databases

Sınıf Sözdizimi

TokyoTyrantQuery implements Iterator {
/* Yöntemler */
public mixed addCond ( string $name , int $op , string $expr )
public __construct ( TokyoTyrantTable $table )
public int count ( void )
public array current ( void )
public string hint ( void )
public string key ( void )
public array metaSearch ( array $queries , int $type )
public array next ( void )
public TokyoTyrantQuery out ( void )
public bool rewind ( void )
public array search ( void )
public mixed setLimit ([ int $max [, int $skip ]] )
public mixed setOrder ( string $name , int $type )
public bool valid ( void )
}

İçindekiler

  • TokyoTyrantQuery::addCond — Adds a condition to the query
  • TokyoTyrantQuery::__construct — Construct a new query
  • TokyoTyrantQuery::count — Counts records
  • TokyoTyrantQuery::current — Returns the current element
  • TokyoTyrantQuery::hint — Get the hint string of the query
  • TokyoTyrantQuery::key — Returns the current key
  • TokyoTyrantQuery::metaSearch — Retrieve records with multiple queries
  • TokyoTyrantQuery::next — Moves the iterator to next entry
  • TokyoTyrantQuery::out — Removes records based on query
  • TokyoTyrantQuery::rewind — Rewinds the iterator
  • TokyoTyrantQuery::search — Searches records
  • TokyoTyrantQuery::setLimit — Limit results
  • TokyoTyrantQuery::setOrder — Orders results
  • TokyoTyrantQuery::valid — Checks the validity of current item
TokyoTyrantTable::setIndex
TokyoTyrantQuery::addCond
tokyo_tyrant


Adds a condition to the query

TokyoTyrantQuery
TokyoTyrantQuery::__construct
TokyoTyrantQuery
PHP Manual

TokyoTyrantQuery::addCond

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantQuery::addCond — Adds a condition to the query

Açıklama

public mixed TokyoTyrantQuery::addCond ( string $name , int $op , string $expr )

Adds a condition to the query. Condition can be something like: get all keys which value matches expr.

Değiştirgeler

name

Name of the column in the condition

op

The operator. One of the TokyoTyrant::RDBQC_* constants

expr

The expression

Dönen Değerler

This method returns the current object and throws TokyoTyrantException on failure.

Örnekler

Örnek 1 TokyoTyrantQuery::addCond() example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Add rows */
$tt->put(null, array("column1" => "some data", "column2" => "something here"));
$tt->put(null, array("column1" => "more data", "column2" => "best data this far"));
$tt->put(null, array("column1" => "again data", "column3" => "not here"));
$tt->put(null, array("column45" => "random data", "column2" => "something along the lines"));
$tt->put(null, array("column21" => "test data", "column2" => "generating.."));
$tt->put(null, array("column1" => "foobar data", "column2" => "value here"));

/* Get a new query object */
$query = $tt->getQuery();

/* Add a search condition */
$query->addCond("column2", TokyoTyrant::RDBQC_STROR, "something");

/* Dump the search results */
var_dump($query->search());
?>

Yukarıdaki örneğin çıktısı:

array(2) {
  [1]=>
  array(2) {
    ["column1"]=>
    string(9) "some data"
    ["column2"]=>
    string(14) "something here"
  }
  [4]=>
  array(2) {
    ["column45"]=>
    string(11) "random data"
    ["column2"]=>
    string(25) "something along the lines"
  }
}

Ayrıca Bakınız

  • Classname::Method()

TokyoTyrantQuery
TokyoTyrantQuery::__construct
TokyoTyrantQuery


Construct a new query

TokyoTyrantQuery::addCond
TokyoTyrantQuery::count
TokyoTyrantQuery
PHP Manual

TokyoTyrantQuery::__construct

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantQuery::__construct — Construct a new query

Açıklama

public TokyoTyrantQuery::__construct ( TokyoTyrantTable $table )

Construct a new query object

Değiştirgeler

table

TokyoTyrantTable object with active database connection

Dönen Değerler

Returns a new TokyoTyrantQuery object and throws TokyoTyrantException on error

Örnekler

Örnek 1 TokyoTyrantQuery::__construct() example

<?php
$tt = new TokyoTyrantTable("localhost", 1979);

$query = new TokyoTyrantQuery($tt);

/* Work with $query */
?>

Ayrıca Bakınız

  • TokyoTyrantTable::getQuery() - Get a query object

TokyoTyrantQuery::addCond
TokyoTyrantQuery::count
TokyoTyrantQuery


Counts records

TokyoTyrantQuery::__construct
TokyoTyrantQuery::current
TokyoTyrantQuery
PHP Manual

TokyoTyrantQuery::count

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

TokyoTyrantQuery::count — Counts records

Açıklama

public int TokyoTyrantQuery::count ( void )

Returns a count of how many records a query returns.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a count of matching rows and throws TokyoTyrantException on error

Örnekler

Örnek 1 TokyoTyrantQuery::count() example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Add rows */
$tt->put(null, array("column1" => "some data", "column2" => "something here"));
$tt->put(null, array("column1" => "more data", "column2" => "best data this far"));
$tt->put(null, array("column1" => "again data", "column3" => "not here"));
$tt->put(null, array("column45" => "random data", "column2" => "something along the lines"));
$tt->put(null, array("column21" => "test data", "column2" => "generating.."));
$tt->put(null, array("column1" => "foobar data", "column2" => "value here"));

/* Get a new query object */
$query = $tt->getQuery();

/* Add a search condition */
$query->addCond("column2", TokyoTyrant::RDBQC_STROR, "something");

/* Count the results */
var_dump($query->count());
?>

Yukarıdaki örneğin çıktısı:

int(2)

Ayrıca Bakınız

  • TokyoTyrantQuery::out() - Removes records based on query
  • TokyoTyrantQuery::search() - Searches records
  • TokyoTyrantQuery::metaSearch() - Retrieve records with multiple queries

TokyoTyrantQuery::__construct
TokyoTyrantQuery::current
TokyoTyrantQuery


Returns the current element

TokyoTyrantQuery::count
TokyoTyrantQuery::hint
TokyoTyrantQuery
PHP Manual

TokyoTyrantQuery::current

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantQuery::current — Returns the current element

Açıklama

public array TokyoTyrantQuery::current ( void )

Returns the current element. Part of Iterator interface

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the current row

Örnekler

Örnek 1 TokyoTyrantQuery iterator example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Add rows */
$tt->put(null, array("column1" => "some data", "column2" => "something here"));
$tt->put(null, array("column1" => "more data", "column2" => "best data this far"));
$tt->put(null, array("column1" => "again data", "column3" => "foobar here"));
$tt->put(null, array("column45" => "random data", "column2" => "something along the lines"));
$tt->put(null, array("column21" => "test data", "column2" => "generating.."));
$tt->put(null, array("column1" => "foobar data", "column2" => "value here"));

/* Get a new query object */
$query = $tt->getQuery();

/* Add a search condition */
$query->addCond("column2", TokyoTyrant::RDBQC_STROR, "something");

/* Iterate the results */
foreach ($query as $key => $value) {
    echo "pk: $key, columns: ", count($value) ,"\n";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

pk: 1, columns: 2
pk: 4, columns: 2

Ayrıca Bakınız

  • TokyoTyrantQuery::addCond() - Adds a condition to the query

TokyoTyrantQuery::count
TokyoTyrantQuery::hint
TokyoTyrantQuery


Get the hint string of the query

TokyoTyrantQuery::current
TokyoTyrantQuery::key
TokyoTyrantQuery
PHP Manual

TokyoTyrantQuery::hint

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

TokyoTyrantQuery::hint — Get the hint string of the query

Açıklama

public string TokyoTyrantQuery::hint ( void )

Get the hint string of the query. The hint string contains information about an executed query and it could be compared to for example MySQL EXPLAIN statement.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

This method always returns a string

Örnekler

Örnek 1 TokyoTyrantQuery::hint example

<?php
$tt = new TokyoTyrantTable("localhost", 1979);
$tt->vanish();

for ($i = 0; $i < 11; $i++) {
     $tt->put(null, array('a_col' => 'a' . $i, 'b_col' => 'b' . $i));
}

$query = $tt->getQuery();
$query->addCond('a_col', TokyoTyrant::RDBQC_STRBW, 'a');

$query->search();
var_dump($query->hint());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(72) "
scanning the whole table
result set size: 11
leaving the natural order
"

Ayrıca Bakınız

  • TokyoTyrantQuery::addCond() - Adds a condition to the query

TokyoTyrantQuery::current
TokyoTyrantQuery::key
TokyoTyrantQuery


Returns the current key

TokyoTyrantQuery::hint
TokyoTyrantQuery::metaSearch
TokyoTyrantQuery
PHP Manual

TokyoTyrantQuery::key

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantQuery::key — Returns the current key

Açıklama

public string TokyoTyrantQuery::key ( void )

Returns the current key. Part of the Iterator interface

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the current key and throws TokyoTyrantException on error

Örnekler

Örnek 1 TokyoTyrantQuery iterator example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Add rows */
$tt->put(null, array("column1" => "some data", "column2" => "something here"));
$tt->put(null, array("column1" => "more data", "column2" => "best data this far"));
$tt->put(null, array("column1" => "again data", "column3" => "foobar here"));
$tt->put(null, array("column45" => "random data", "column2" => "something along the lines"));
$tt->put(null, array("column21" => "test data", "column2" => "generating.."));
$tt->put(null, array("column1" => "foobar data", "column2" => "value here"));

/* Get a new query object */
$query = $tt->getQuery();

/* Add a search condition */
$query->addCond("column2", TokyoTyrant::RDBQC_STROR, "something");

/* Iterate the results */
foreach ($query as $key => $value) {
    echo "pk: $key, columns: ", count($value) ,"\n";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

pk: 1, columns: 2
pk: 4, columns: 2

Ayrıca Bakınız

  • TokyoTyrantQuery::addCond() - Adds a condition to the query

TokyoTyrantQuery::hint
TokyoTyrantQuery::metaSearch
TokyoTyrantQuery


Retrieve records with multiple queries

TokyoTyrantQuery::key
TokyoTyrantQuery::next
TokyoTyrantQuery
PHP Manual

TokyoTyrantQuery::metaSearch

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

TokyoTyrantQuery::metaSearch — Retrieve records with multiple queries

Açıklama

public array TokyoTyrantQuery::metaSearch ( array $queries , int $type )

Executes multiple queries on a database and returns matching records. The current object is always the left most object in the search.

Değiştirgeler

queries

Array of TokyoTyrantQuery objects

type

One of the TokyoTyrant::RDBMS_* constants

Dönen Değerler

Returns the matching rows and throws TokyoTyrantException on error

Örnekler

Örnek 1 TokyoTyrantQuery::metaSearch() example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Add test data */
$tt->put('cherry',     array('color' => 'red'));
$tt->put('strawberry', array('color' => 'red'));
$tt->put('apple',      array('color' => 'green'));
$tt->put('lemon',      array('color' => 'yellow'));

/* First query */
$query = $tt->getQuery();
$query->addCond('color', TokyoTyrant::RDBQC_STREQ, 'red')->setOrder('color', TokyoTyrant::RDBQO_STRASC);

/* Second query */
$query1 = $tt->getQuery();
$query1->addCond('color', TokyoTyrant::RDBQC_STREQ, 'yellow');

/* Get union between the queries */
var_dump($query->metaSearch(array($query1), TokyoTyrant::RDBMS_UNION));
?>

Yukarıdaki örneğin çıktısı:

array(3) {
  ["cherry"]=>
  array(1) {
    ["color"]=>
    string(3) "red"
  }
  ["strawberry"]=>
  array(1) {
    ["color"]=>
    string(3) "red"
  }
  ["lemon"]=>
  array(1) {
    ["color"]=>
    string(6) "yellow"
  }
}

Ayrıca Bakınız

  • TokyoTyrantQuery::search() - Searches records

TokyoTyrantQuery::key
TokyoTyrantQuery::next
TokyoTyrantQuery


Moves the iterator to next entry

TokyoTyrantQuery::metaSearch
TokyoTyrantQuery::out
TokyoTyrantQuery
PHP Manual

TokyoTyrantQuery::next

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantQuery::next — Moves the iterator to next entry

Açıklama

public array TokyoTyrantQuery::next ( void )

Returns the next result in the resultset. Part of the Iterator interface.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the next row and throws TokyoTyrantException on error.

Örnekler

Örnek 1 TokyoTyrantQuery iterator example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Add rows */
$tt->put(null, array("column1" => "some data", "column2" => "something here"));
$tt->put(null, array("column1" => "more data", "column2" => "best data this far"));
$tt->put(null, array("column1" => "again data", "column3" => "foobar here"));
$tt->put(null, array("column45" => "random data", "column2" => "something along the lines"));
$tt->put(null, array("column21" => "test data", "column2" => "generating.."));
$tt->put(null, array("column1" => "foobar data", "column2" => "value here"));

/* Get a new query object */
$query = $tt->getQuery();

/* Add a search condition */
$query->addCond("column2", TokyoTyrant::RDBQC_STROR, "something");

/* Iterate the results */
foreach ($query as $key => $value) {
    echo "pk: $key, columns: ", count($value) ,"\n";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

pk: 1, columns: 2
pk: 4, columns: 2

Ayrıca Bakınız

  • TokyoTyrantQuery::addCond() - Adds a condition to the query

TokyoTyrantQuery::metaSearch
TokyoTyrantQuery::out
TokyoTyrantQuery


Removes records based on query

TokyoTyrantQuery::next
TokyoTyrantQuery::rewind
TokyoTyrantQuery
PHP Manual

TokyoTyrantQuery::out

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantQuery::out — Removes records based on query

Açıklama

public TokyoTyrantQuery TokyoTyrantQuery::out ( void )

Removes all records that match the query. Works exactly like search but removes the records instead of returning them.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

This method returns the current object and throws TokyoTyrantException on failure.

Örnekler

Örnek 1 TokyoTyrantQuery::out() example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Add rows */
$tt->put(null, array("column1" => "some data", "column2" => "something here"));
$tt->put(null, array("column1" => "more data", "column2" => "best data this far"));
$tt->put(null, array("column1" => "again data", "column3" => "foobar here"));
$tt->put(null, array("column45" => "random data", "column2" => "something along the lines"));
$tt->put(null, array("column21" => "test data", "column2" => "generating.."));
$tt->put(null, array("column1" => "foobar data", "column2" => "value here"));

/* Get a new query object */
$query = $tt->getQuery();

/* Add a search condition */
$query->addCond("column2", TokyoTyrant::RDBQC_STROR, "something");

/* Remove matching records */
$query->out();
?>

Ayrıca Bakınız

  • TokyoTyrantQuery::addCond() - Adds a condition to the query

TokyoTyrantQuery::next
TokyoTyrantQuery::rewind
TokyoTyrantQuery


Rewinds the iterator

TokyoTyrantQuery::out
TokyoTyrantQuery::search
TokyoTyrantQuery
PHP Manual

TokyoTyrantQuery::rewind

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantQuery::rewind — Rewinds the iterator

Açıklama

public bool TokyoTyrantQuery::rewind ( void )

Rewind the resultset and executes the query if it has not been executed. Part of the Iterator interface.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE

Örnekler

Örnek 1 TokyoTyrantQuery iterator example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Add rows */
$tt->put(null, array("column1" => "some data", "column2" => "something here"));
$tt->put(null, array("column1" => "more data", "column2" => "best data this far"));
$tt->put(null, array("column1" => "again data", "column3" => "foobar here"));
$tt->put(null, array("column45" => "random data", "column2" => "something along the lines"));
$tt->put(null, array("column21" => "test data", "column2" => "generating.."));
$tt->put(null, array("column1" => "foobar data", "column2" => "value here"));

/* Get a new query object */
$query = $tt->getQuery();

/* Add a search condition */
$query->addCond("column2", TokyoTyrant::RDBQC_STROR, "something");

/* Iterate the results */
foreach ($query as $key => $value) {
    echo "pk: $key, columns: ", count($value) ,"\n";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

pk: 1, columns: 2
pk: 4, columns: 2

Ayrıca Bakınız

  • TokyoTyrantQuery::addCond() - Adds a condition to the query

TokyoTyrantQuery::out
TokyoTyrantQuery::search
TokyoTyrantQuery


Searches records

TokyoTyrantQuery::rewind
TokyoTyrantQuery::setLimit
TokyoTyrantQuery
PHP Manual

TokyoTyrantQuery::search

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantQuery::search — Searches records

Açıklama

public array TokyoTyrantQuery::search ( void )

Executes a search on the table database. Returns an array of arrays containing the matching records. In the returned array the first level is the primary key of the data and the second level is the row data.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the matching rows and throws TokyoTyrantException on error

Örnekler

Örnek 1 TokyoTyrantQuery::search() example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Add rows */
$tt->put(null, array("column1" => "some data", "column2" => "something here"));
$tt->put(null, array("column1" => "more data", "column2" => "best data this far"));
$tt->put(null, array("column1" => "again data", "column3" => "not here"));
$tt->put(null, array("column45" => "random data", "column2" => "something along the lines"));
$tt->put(null, array("column21" => "test data", "column2" => "generating.."));
$tt->put(null, array("column1" => "foobar data", "column2" => "value here"));

/* Get a new query object */
$query = $tt->getQuery();

/* Add a search condition */
$query->addCond("column2", TokyoTyrant::RDBQC_STROR, "something");

/* Dump the search results */
var_dump($query->search());
?>

Yukarıdaki örneğin çıktısı:

array(2) {
  [1]=>
  array(2) {
    ["column1"]=>
    string(9) "some data"
    ["column2"]=>
    string(14) "something here"
  }
  [4]=>
  array(2) {
    ["column45"]=>
    string(11) "random data"
    ["column2"]=>
    string(25) "something along the lines"
  }
}

Ayrıca Bakınız

  • TokyoTyrantQuery::out() - Removes records based on query
  • TokyoTyrantQuery::metaSearch() - Retrieve records with multiple queries

TokyoTyrantQuery::rewind
TokyoTyrantQuery::setLimit
TokyoTyrantQuery


Limit results

TokyoTyrantQuery::search
TokyoTyrantQuery::setOrder
TokyoTyrantQuery
PHP Manual

TokyoTyrantQuery::setLimit

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantQuery::setLimit — Limit results

Açıklama

public mixed TokyoTyrantQuery::setLimit ([ int $max [, int $skip ]] )

Set the maximum amount of records to return on a query.

Değiştirgeler

max

Maximum amount of records. Default: -1

skip

How many records to skip from the start. Default: -1

Dönen Değerler

This method returns the current object and throws TokyoTyrantException on failure.

TokyoTyrantQuery::search
TokyoTyrantQuery::setOrder
TokyoTyrantQuery


Orders results

TokyoTyrantQuery::setLimit
TokyoTyrantQuery::valid
TokyoTyrantQuery
PHP Manual

TokyoTyrantQuery::setOrder

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantQuery::setOrder — Orders results

Açıklama

public mixed TokyoTyrantQuery::setOrder ( string $name , int $type )

Sets the order of a query

Değiştirgeler

name

The column name to apply the ordering on.

type

The type can be one of the following constants:

  • TokyoTyrant::RDBQO_STRASC - String ascending
  • TokyoTyrant::RDBQO_STRDESC - String descending
  • TokyoTyrant::RDBQO_NUMASC - Numberic ascending
  • TokyoTyrant::RDBQO_NUMDESC - String descending

Dönen Değerler

This method returns the current object.

TokyoTyrantQuery::setLimit
TokyoTyrantQuery::valid
TokyoTyrantQuery


Checks the validity of current item

TokyoTyrantQuery::setOrder
TokyoTyrantIterator
TokyoTyrantQuery
PHP Manual

TokyoTyrantQuery::valid

(PECL tokyo_tyrant >= 0.1.0)

TokyoTyrantQuery::valid — Checks the validity of current item

Açıklama

public bool TokyoTyrantQuery::valid ( void )

Checks if the current item is valid. Part of the Iterator interface

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the current item is valid and FALSE if not.

Örnekler

Örnek 1 TokyoTyrantQuery iterator example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Add rows */
$tt->put(null, array("column1" => "some data", "column2" => "something here"));
$tt->put(null, array("column1" => "more data", "column2" => "best data this far"));
$tt->put(null, array("column1" => "again data", "column3" => "foobar here"));
$tt->put(null, array("column45" => "random data", "column2" => "something along the lines"));
$tt->put(null, array("column21" => "test data", "column2" => "generating.."));
$tt->put(null, array("column1" => "foobar data", "column2" => "value here"));

/* Get a new query object */
$query = $tt->getQuery();

/* Add a search condition */
$query->addCond("column2", TokyoTyrant::RDBQC_STROR, "something");

/* Iterate the results */
foreach ($query as $key => $value) {
    echo "pk: $key, columns: ", count($value) ,"\n";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

pk: 1, columns: 2
pk: 4, columns: 2

Ayrıca Bakınız

  • TokyoTyrantQuery::addCond() - Adds a condition to the query

TokyoTyrantQuery::setOrder
TokyoTyrantIterator
TokyoTyrantQuery


The TokyoTyrantIterator class

(PECL tokyo_tyrant >= 0.2.0)

Giriş

Provides an iterator for TokyoTyrant and TokyoTyrantTable objects. The iterator iterates over all keys and values in the database. TokyoTyrantIterator was added in version 0.2.0.

Sınıf Sözdizimi

TokyoTyrantIterator implements Iterator {
/* Methods */
public __construct ( mixed $object )
public mixed current ( void )
public mixed key ( void )
public mixed next ( void )
public void rewind ( void )
public bool valid ( void )
/* Inherited methods */
public number TokyoTyrant::add ( string $key , number $increment [, int $type = 0 ] )
public TokyoTyrant TokyoTyrant::connect ( string $host [, int $port = TokyoTyrant::RDBDEF_PORT [, array $options ]] )
public TokyoTyrant TokyoTyrant::connectUri ( string $uri )
public TokyoTyrant::__construct ([ string $host [, int $port = TokyoTyrant::RDBDEF_PORT [, array $options ]]] )
public TokyoTyrant TokyoTyrant::copy ( string $path )
public string TokyoTyrant::ext ( string $name , int $options , string $key , string $value )
public array TokyoTyrant::fwmKeys ( string $prefix , int $max_recs )
public mixed TokyoTyrant::get ( mixed $keys )
public TokyoTyrantIterator TokyoTyrant::getIterator ( void )
public int TokyoTyrant::num ( void )
public TokyoTyrant TokyoTyrant::out ( mixed $keys )
public TokyoTyrant TokyoTyrant::put ( mixed $keys [, string $value = NULL ] )
public TokyoTyrant TokyoTyrant::putCat ( mixed $keys [, string $value ] )
public TokyoTyrant TokyoTyrant::putKeep ( mixed $keys [, string $value ] )
public TokyoTyrant TokyoTyrant::putNr ( mixed $keys [, string $value = NULL ] )
public mixed TokyoTyrant::putShl ( string $key , string $value , int $width )
public mixed TokyoTyrant::restore ( string $log_dir , int $timestamp [, bool $check_consistency = true ] )
public mixed TokyoTyrant::setMaster ( string $host , int $port , int $timestamp [, bool $check_consistency = true ] )
public int TokyoTyrant::size ( string $key )
public array TokyoTyrant::stat ( void )
public mixed TokyoTyrant::sync ( void )
public TokyoTyrant TokyoTyrant::tune ( float $timeout [, int $options = TokyoTyrant::RDBT_RECON ] )
public mixed TokyoTyrant::vanish ( void )
}

İçindekiler

  • TokyoTyrantIterator::__construct — Construct an iterator
  • TokyoTyrantIterator::current — Get the current value
  • TokyoTyrantIterator::key — Returns the current key
  • TokyoTyrantIterator::next — Move to next key
  • TokyoTyrantIterator::rewind — Rewinds the iterator
  • TokyoTyrantIterator::valid — Rewinds the iterator
TokyoTyrantQuery::valid
TokyoTyrantIterator::__construct
tokyo_tyrant


Construct an iterator

TokyoTyrantIterator
TokyoTyrantIterator::current
TokyoTyrantIterator
PHP Manual

TokyoTyrantIterator::__construct

(PECL tokyo_tyrant >= 0.2.0)

TokyoTyrantIterator::__construct — Construct an iterator

Açıklama

public TokyoTyrantIterator::__construct ( mixed $object )

Construct a new TokyoTyrantIterator object. One connection can have multiple iterators but it is not quaranteed that all items are traversed in that case. object parameter can be either an of instance TokyoTyrant or TokyoTyrantTable.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Throws an exception if iterator initialization fails.

Örnekler

Örnek 1 TokyoTyrantIterator::__construct() example

<?php
/* Connect to a table database */
$tt = new TokyoTyrantTable("localhost", 1979);

/* Passing null to put generates a new uid */
$index = $tt->put(null, array("column1" => "some data", "column2" => "more data"));

/* Construct an iterator */
$it = new TokyoTyrantIterator($tt);

foreach ($it as $value) {
    var_dump($value);
}
?>

Yukarıdaki örneğin çıktısı:

array(2) {
  ["column1"]=>
  string(9) "some data"
  ["column2"]=>
  string(9) "more data"
}

Ayrıca Bakınız

  • TokyoTyrantIterator::key() - Returns the current key
  • TokyoTyrantIterator::current() - Get the current value
  • TokyoTyrantIterator::next() - Move to next key
  • TokyoTyrantIterator::rewind() - Rewinds the iterator
  • TokyoTyrantIterator::key() - Returns the current key

TokyoTyrantIterator
TokyoTyrantIterator::current
TokyoTyrantIterator


Get the current value

TokyoTyrantIterator::__construct
TokyoTyrantIterator::key
TokyoTyrantIterator
PHP Manual

TokyoTyrantIterator::current

(PECL tokyo_tyrant >= 0.2.0)

TokyoTyrantIterator::current — Get the current value

Açıklama

public mixed TokyoTyrantIterator::current ( void )

Returns the current value during iteration.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the current value on success and false on failure.

Ayrıca Bakınız

  • TokyoTyrantIterator::valid() - Rewinds the iterator
  • TokyoTyrantIterator::key() - Returns the current key
  • TokyoTyrantIterator::next() - Move to next key
  • TokyoTyrantIterator::rewind() - Rewinds the iterator

TokyoTyrantIterator::__construct
TokyoTyrantIterator::key
TokyoTyrantIterator


Returns the current key

TokyoTyrantIterator::current
TokyoTyrantIterator::next
TokyoTyrantIterator
PHP Manual

TokyoTyrantIterator::key

(PECL tokyo_tyrant >= 0.2.0)

TokyoTyrantIterator::key — Returns the current key

Açıklama

public mixed TokyoTyrantIterator::key ( void )

Returns the current key.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the current key on success and false on failure.

Ayrıca Bakınız

  • TokyoTyrantIterator::valid() - Rewinds the iterator
  • TokyoTyrantIterator::current() - Get the current value
  • TokyoTyrantIterator::next() - Move to next key
  • TokyoTyrantIterator::rewind() - Rewinds the iterator

TokyoTyrantIterator::current
TokyoTyrantIterator::next
TokyoTyrantIterator


Move to next key

TokyoTyrantIterator::key
TokyoTyrantIterator::rewind
TokyoTyrantIterator
PHP Manual

TokyoTyrantIterator::next

(PECL tokyo_tyrant >= 0.2.0)

TokyoTyrantIterator::next — Move to next key

Açıklama

public mixed TokyoTyrantIterator::next ( void )

Move to next key during iteration and return it's value.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the next value on success and false on failure.

Ayrıca Bakınız

  • TokyoTyrantIterator::valid() - Rewinds the iterator
  • TokyoTyrantIterator::key() - Returns the current key
  • TokyoTyrantIterator::current() - Get the current value
  • TokyoTyrantIterator::rewind() - Rewinds the iterator

TokyoTyrantIterator::key
TokyoTyrantIterator::rewind
TokyoTyrantIterator


Rewinds the iterator

TokyoTyrantIterator::next
TokyoTyrantIterator::valid
TokyoTyrantIterator
PHP Manual

TokyoTyrantIterator::rewind

(PECL tokyo_tyrant >= 0.2.0)

TokyoTyrantIterator::rewind — Rewinds the iterator

Açıklama

public void TokyoTyrantIterator::rewind ( void )

Rewinds the iterator for new iteration. Called automatically at the beginning of foreach.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Throws TokyoTyrantException if iterator initialization fails.

Ayrıca Bakınız

  • TokyoTyrantIterator::valid() - Rewinds the iterator
  • TokyoTyrantIterator::current() - Get the current value
  • TokyoTyrantIterator::next() - Move to next key
  • TokyoTyrantIterator::rewind()

TokyoTyrantIterator::next
TokyoTyrantIterator::valid
TokyoTyrantIterator


Rewinds the iterator

TokyoTyrantIterator::rewind
TokyoTyrantException
TokyoTyrantIterator
PHP Manual

TokyoTyrantIterator::valid

(PECL tokyo_tyrant >= 0.2.0)

TokyoTyrantIterator::valid — Rewinds the iterator

Açıklama

public bool TokyoTyrantIterator::valid ( void )

Checks whether the internal pointer points to valid element.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the current item is valid and FALSE if not.

Ayrıca Bakınız

  • TokyoTyrantIterator::key() - Returns the current key
  • TokyoTyrantIterator::current() - Get the current value
  • TokyoTyrantIterator::next() - Move to next key
  • TokyoTyrantIterator::rewind() - Rewinds the iterator

TokyoTyrantIterator::rewind
TokyoTyrantException
TokyoTyrantIterator


The TokyoTyrantException class

(PECL tokyo_tyrant >= 0.1.0)

Giriş

TokyoTyrantException

Sınıf Sözdizimi

tokyotyrantexception extends Exception {
/* Özellikler */
protected int $code ;
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}

Özellikler

code

The exception code. This can be compared to TokyoTyrant::TTE_* constants

TokyoTyrantIterator::valid
Tarih ve Saat ile İlgili Eklentiler
tokyo_tyrant


Tarih ve Saat ile İlgili Eklentiler

  • Takvim
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Takvim İşlevleri
  • Tarih ve Zaman
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Desteklenen Zaman Dilimlerinin Listesi
    • Supported Date and Time Formats
    • DateTime — DateTime sınıfı
    • DateTimeZone — DateTimeZone sınıfı
    • DateInterval — DateInterval sınıfı
    • DatePeriod — DatePeriod sınıfı
    • Tarih ve Zaman İşlevleri
  • HRTime — High resolution timing
    • Giriş
    • Yapılandırma/Kurulum
    • Örnekler
    • HRTime\PerformanceCounter — The HRTime\PerformanceCounter class
    • HRTime\StopWatch — The HRTime\StopWatch class
    • HRTime\Unit — The HRTime\Unit class
TokyoTyrantException
Takvim
İşlev Başvuru Kılavuzu


Takvim

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Takvim İşlevleri
    • cal_days_in_month — Seçilen takvime ve yıla göre istenen aydaki gün sayısını geri döndürür
    • cal_from_jd — Jülyen Gün Sayısını, istenen takvim biçimine çevirir
    • cal_info — Değiştirge olarak verilen takvim hakkında bilgi döner
    • cal_to_jd — Desteklenen bir takvimden Jülyen Gün Sayısına dönüşüm yapar
    • easter_date — Verilen yıl için paskalya gece yarısının unix zaman damgasını döner
    • easter_days — Verilen yıl için Paskalya zamanına, 21 Marttan sonraki kalan gün sayısını verir.
    • FrenchToJD — Fransız İhtilali takvim tarihini, Jülyen Gün Sayısına çevirir
    • GregorianToJD — Gregoryen tarihini, Jülyen Gün Sayısına çevirir
    • JDDayOfWeek — Haftanın gününü verir
    • JDMonthName — Ay adını geri döner
    • JDToFrench — Jülyen gün sayısını, Fransız İhtilali takvimine çevirir
    • JDToGregorian — Jülyen Gün Sayısını, Gregoryen tarihine çevirir
    • jdtojewish — Jülyen Gün Sayısını, Yahudi takvimine çevirir
    • JDToJulian — Jülyen Gün Sayısını, Jülyen takvim tarihine çevirir
    • jdtounix — Jülyen Gün Sayısını, Unix zaman damgasına çevirir
    • JewishToJD — Yahudi takvimindeki bir tarihi, Jülyen Gün Sayısına çevirir
    • JulianToJD — Jülyen takvimindeki tarihi, Jülyen Gün Sayısına çevirir
    • unixtojd — Unix zaman damgasını, Jülyen Gün Sayısına çevirir
Tarih ve Saat ile İlgili Eklentiler
Giriş
Tarih ve Saat ile İlgili Eklentiler


Giriş

Takvim eklentisi farklı takvim biçimleri arasında dönüşüm işlemlerini basitleştirmek için işlevler sunar. Ara biçim veya standart olarak Jülyen Gün Sayısını alır. Jülyen Gün Sayısı M.Ö. 1 Ocak 4713 tarihinden başlayarak geçen günlerin sayısıdır. Takvim biçimleri arasında dönüşüm yapmak için önce Jülyen Gün Sayısını bulmalı ve sonra bu bilgiyi istediğiniz takvim bilgisine dönüştürmelisiniz. Jülyen Gün Sayısı, Jülyen takviminden çok farklıdır! Jülyen Gün Sayısı hakkında daha fazla bilgi için » http://www.hermetic.ch/cal_stud/jdn.htm adresini ziyaret edebilirsiniz. Takvim biçimleri hakkında ise » http://www.fourmilab.ch/documents/calendar/ adresinden yararlanabilirsiniz. Bu adresten yapılan alıntılar tırnak işaretleri içerisinde gösterilmiştir.

Takvim
Yapılandırma/Kurulum
Takvim


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Takvim


Kurulum

İşlevlerin çalışabilmesi için, PHP'yi --enable-calendar seçeneği ile derlemelisiniz.

PHP'nin Windows sürümünde bu eklenti yerleşik olarak gelmektedir. Bu işlevleri Windows'ta kullanmak için herhangi bir eklenti kurmanıza gerek yoktur.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

CAL_GREGORIAN (integer)
CAL_JULIAN (integer)
CAL_JEWISH (integer)
CAL_FRENCH (integer)
CAL_NUM_CALS (integer)
CAL_DOW_DAYNO (integer)
CAL_DOW_SHORT (integer)
CAL_DOW_LONG (integer)
CAL_MONTH_GREGORIAN_SHORT (integer)
CAL_MONTH_GREGORIAN_LONG (integer)
CAL_MONTH_JULIAN_SHORT (integer)
CAL_MONTH_JULIAN_LONG (integer)
CAL_MONTH_JEWISH (integer)
CAL_MONTH_FRENCH (integer)

Aşağıdaki sabitler, PHP 4.3.0 ve sonraki sürümlerde geçerlidir:

CAL_EASTER_DEFAULT (integer)
CAL_EASTER_ROMAN (integer)
CAL_EASTER_ALWAYS_GREGORIAN (integer)
CAL_EASTER_ALWAYS_JULIAN (integer)

Aşağıdaki sabitler, PHP 5.0.0 ve sonraki sürümlerde geçerlidir:

CAL_JEWISH_ADD_ALAFIM_GERESH (integer)
CAL_JEWISH_ADD_ALAFIM (integer)
CAL_JEWISH_ADD_GERESHAYIM (integer)
Özkaynak Türleri
Takvim İşlevleri
Takvim


Takvim İşlevleri

İçindekiler

  • cal_days_in_month — Seçilen takvime ve yıla göre istenen aydaki gün sayısını geri döndürür
  • cal_from_jd — Jülyen Gün Sayısını, istenen takvim biçimine çevirir
  • cal_info — Değiştirge olarak verilen takvim hakkında bilgi döner
  • cal_to_jd — Desteklenen bir takvimden Jülyen Gün Sayısına dönüşüm yapar
  • easter_date — Verilen yıl için paskalya gece yarısının unix zaman damgasını döner
  • easter_days — Verilen yıl için Paskalya zamanına, 21 Marttan sonraki kalan gün sayısını verir.
  • FrenchToJD — Fransız İhtilali takvim tarihini, Jülyen Gün Sayısına çevirir
  • GregorianToJD — Gregoryen tarihini, Jülyen Gün Sayısına çevirir
  • JDDayOfWeek — Haftanın gününü verir
  • JDMonthName — Ay adını geri döner
  • JDToFrench — Jülyen gün sayısını, Fransız İhtilali takvimine çevirir
  • JDToGregorian — Jülyen Gün Sayısını, Gregoryen tarihine çevirir
  • jdtojewish — Jülyen Gün Sayısını, Yahudi takvimine çevirir
  • JDToJulian — Jülyen Gün Sayısını, Jülyen takvim tarihine çevirir
  • jdtounix — Jülyen Gün Sayısını, Unix zaman damgasına çevirir
  • JewishToJD — Yahudi takvimindeki bir tarihi, Jülyen Gün Sayısına çevirir
  • JulianToJD — Jülyen takvimindeki tarihi, Jülyen Gün Sayısına çevirir
  • unixtojd — Unix zaman damgasını, Jülyen Gün Sayısına çevirir
Öntanımlı Sabitler
cal_days_in_month
Takvim


Seçilen takvime ve yıla göre istenen aydaki gün sayısını geri döndürür

Takvim İşlevleri
cal_from_jd
Takvim İşlevleri
PHP Manual

cal_days_in_month

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

cal_days_in_month — Seçilen takvime ve yıla göre istenen aydaki gün sayısını geri döndürür

Açıklama

int cal_days_in_month ( int $takvim , int $ay , int $yil )

İşlev seçilen takvim, yil ve ay değiştirgelerine göre gün sayısını geri döndürecektir.

Değiştirgeler

takvim

Hesaplama yapılacak takvim

ay

Seçilen takvimdeki ay

yil

Seçilen takvimdeki yıl

Dönen Değerler

Değiştirge olarak verilen takvimde, seçilen aydaki gün sayısı

Örnekler

Örnek 1 cal_days_in_month() örneği

<?php
$num = cal_days_in_month(CAL_GREGORIAN, 8, 2003); // 31
echo "2003 yılı Ağustos ayında $num gün vardır";
?>

Takvim İşlevleri
cal_from_jd
Takvim İşlevleri


Jülyen Gün Sayısını, istenen takvim biçimine çevirir

cal_days_in_month
cal_info
Takvim İşlevleri
PHP Manual

cal_from_jd

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

cal_from_jd — Jülyen Gün Sayısını, istenen takvim biçimine çevirir

Açıklama

array cal_from_jd ( int $jg , int $takvim )

cal_from_jd() işlevi jg değiştirgesi ile verilen Jülyen Gün Sayısını takvim değiştirgesi ile verilen takvim gününe çevirir. Desteklenen takvim değerleri CAL_GREGORIAN, CAL_JULIAN, CAL_JEWISH ve CAL_FRENCH'dir.

Değiştirgeler

jg

Tamsayı olarak Jülyen Gün Sayısı

takvim

İstenen takvim

Dönen Değerler

Ay, gün, yıl, haftanın günü, gün ve ayın kısa ve uzun isimleri, "ay/gün/yıl" biçiminde tarih dizgesi öğelerini içeren dizi değişken döner.

Örnekler

Örnek 1 cal_from_jd() örneği

<?php
$today = unixtojd(mktime(0, 0, 0, 8, 16, 2003));
print_r(cal_from_jd($today, CAL_GREGORIAN));
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [date] => 8/16/2003
    [month] => 8
    [day] => 16
    [year] => 2003
    [dow] => 6
    [abbrevdayname] => Sat
    [dayname] => Saturday
    [abbrevmonth] => Aug
    [monthname] => August
)

Ayrıca Bakınız

  • cal_to_jd() - Desteklenen bir takvimden Jülyen Gün Sayısına dönüşüm yapar
  • jdtofrench() - Jülyen gün sayısını, Fransız İhtilali takvimine çevirir
  • jdtogregorian() - Jülyen Gün Sayısını, Gregoryen tarihine çevirir
  • jdtojewish() - Jülyen Gün Sayısını, Yahudi takvimine çevirir
  • jdtojulian() - Jülyen Gün Sayısını, Jülyen takvim tarihine çevirir
  • jdtounix() - Jülyen Gün Sayısını, Unix zaman damgasına çevirir

cal_days_in_month
cal_info
Takvim İşlevleri


Değiştirge olarak verilen takvim hakkında bilgi döner

cal_from_jd
cal_to_jd
Takvim İşlevleri
PHP Manual

cal_info

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

cal_info — Değiştirge olarak verilen takvim hakkında bilgi döner

Açıklama

array cal_info ([ int $takvim = -1 ] )

cal_info() işlevi, verilmiş takvim değiştirgesine ait bilgiler içeren dizi değişken döner.

Dizi değişken şu öğeleri içerir; calname, calsymbol, month, abbrevmonth ve maxdaysinmonth. takvim değiştirgesi olarak:

  • Gregoryen (Miladi) takvimi için 0 veya CAL_GREGORIAN
  • Jülyen (Rumi) takvimi için 1 veya CAL_JULIAN
  • Yahudi takvimi için 2 veya CAL_JEWISH
  • Fransız ihtilali takvimi için 3 veya CAL_FRENCH

Eğer takvim değeri verilmez ise, desteklenen bütün takvimler hakkında bilgi içeren dizi dönecektir.

Değiştirgeler

takvim

Bilgi verilecek takvim. Eğer belirtilmezse, bütün takvimler hakkında bilgi döner.

Dönen Değerler

Sürüm Bilgisi

Sürüm: | Açıklama
5.0'dan beri | takvim değiştirgesi seçimlik olmuştur ve ihmal edilirse, öntanımlı olarak "bütün takvimler" hakkında bilgi döner.

Örnekler

Örnek 1 cal_info() örneği

<?php
$info = cal_info(0);
print_r($info);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [months] => Array
        (
            [1] => January
            [2] => February
            [3] => March
            [4] => April
            [5] => May
            [6] => June
            [7] => July
            [8] => August
            [9] => September
            [10] => October
            [11] => November
            [12] => December
        )

    [abbrevmonths] => Array
        (
            [1] => Jan
            [2] => Feb
            [3] => Mar
            [4] => Apr
            [5] => May
            [6] => Jun
            [7] => Jul
            [8] => Aug
            [9] => Sep
            [10] => Oct
            [11] => Nov
            [12] => Dec
        )

    [maxdaysinmonth] => 31
    [calname] => Gregorian
    [calsymbol] => CAL_GREGORIAN
)

cal_from_jd
cal_to_jd
Takvim İşlevleri


Desteklenen bir takvimden Jülyen Gün Sayısına dönüşüm yapar

cal_info
easter_date
Takvim İşlevleri
PHP Manual

cal_to_jd

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

cal_to_jd — Desteklenen bir takvimden Jülyen Gün Sayısına dönüşüm yapar

Açıklama

int cal_to_jd ( int $takvim , int $ay , int $gun , int $yil )

cal_to_jd() işlevi calendar değiştirgesine göre Jülyen Gün Sayısını hesaplar. Desteklenen takvim türleri CAL_GREGORIAN, CAL_JULIAN, CAL_JEWISH ve CAL_FRENCH'dir.

Değiştirgeler

takvim

Dönüşüm yapılacak takvim CAL_GREGORIAN, CAL_JULIAN, CAL_JEWISH veya CAL_FRENCH değerlerinden biri olabilir.

ay

Sayı olarak ay değeri, geçerli olan değer aralığı takvim değiştirgesine bağlıdır

gun

Sayı olarak gün değeri, gerçerli olan değer aralığı takvim değiştirgesine bağlıdır

yil

Sayı olarak yıl değeri, geçerli olan değer aralığı takvim değiştirgesine bağlıdır

Dönen Değerler

Jülyen Gün Sayısı.

Ayrıca Bakınız

  • cal_from_jd() - Jülyen Gün Sayısını, istenen takvim biçimine çevirir
  • frenchtojd() - Fransız İhtilali takvim tarihini, Jülyen Gün Sayısına çevirir
  • gregoriantojd() - Gregoryen tarihini, Jülyen Gün Sayısına çevirir
  • jewishtojd() - Yahudi takvimindeki bir tarihi, Jülyen Gün Sayısına çevirir
  • juliantojd() - Jülyen takvimindeki tarihi, Jülyen Gün Sayısına çevirir
  • unixtojd() - Unix zaman damgasını, Jülyen Gün Sayısına çevirir

cal_info
easter_date
Takvim İşlevleri


Verilen yıl için paskalya gece yarısının unix zaman damgasını döner

cal_to_jd
easter_days
Takvim İşlevleri
PHP Manual

easter_date

(PHP 4, PHP 5, PHP 7)

easter_date — Verilen yıl için paskalya gece yarısının unix zaman damgasını döner

Açıklama

int easter_date ([ int $yil ] )

Verilen yıl için paskalya gece yarısının unix zaman damgasını döner.

Uyarı

Bu işlev, yıl unix zaman damgasının geçerli olduğu aralık dışında (1970'den önce 2037'den sonra) verilirse bir uyarı üretir.

Paskalya günü, ilk olarak M.S. 325 yılında İznik Konseyi tarafından, İlk dolunaydan veya Bahar ılımından (ekinoks) sonraki ilk pazar günü olarak tanımlanmıştır. Ilımın daima 21 Mart tarihine rastladığı varsayılır ve hesaplama dolunayın ve sonraki pazar gününün hesaplanmasına indirgenir. Kullanılan algoritma Dionysius Exiguus tarafından 532 yılında tanıtıldı. Jülyen takvimi döneminde (1753'den önceki yıllar) ayın evrelerini takip etmek için basit 19 yıllık çevrim kullanıldı. Gregoryen takvimi döneminde (1753'den sonraki yıllar - Clavius ve Lilius tarafından hazırlandı ve XIII Papa Gregory tarafından Ekim 1582'de tanıtıldı, Eylül 1752'de Britanya ve kolonilerine yayıldı) çevrimin daha doğru olması için 2 düzeltme değişkeni eklendi.

(Simon Kershaw tarafından yazılan C programı temel alınmıştır, <webmaster at ely.anglican dot org>)

Değiştirgeler

yil

1970-2037 aralığındaki değerlerden biri.

Dönen Değerler

Unix zaman damgası olarak paskalya günü.

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.0 sürümünden beri | yil değiştirgesi seçime bağlıdır, ihmal edilirse, öntanımlı olarak yerel zamanda, içinde bulunulan yıla eşittir.

Örnekler

Örnek 1 easter_date() örneği

<?php

echo date("M-d-Y", easter_date(1999));        // Apr-04-1999
echo date("M-d-Y", easter_date(2000));        // Apr-23-2000
echo date("M-d-Y", easter_date(2001));        // Apr-15-2001

?>

Ayrıca Bakınız

  • 1970'den önce veya 2037'den sonraki Paskalya günleri için easter_days() - Verilen yıl için Paskalya zamanına, 21 Marttan sonraki kalan gün sayısını verir.

cal_to_jd
easter_days
Takvim İşlevleri


Verilen yıl için Paskalya zamanına, 21 Marttan sonraki kalan gün sayısını verir.

easter_date
FrenchToJD
Takvim İşlevleri
PHP Manual

easter_days

(PHP 4, PHP 5, PHP 7)

easter_days — Verilen yıl için Paskalya zamanına, 21 Marttan sonraki kalan gün sayısını verir.

Açıklama

int easter_days ([ int $yil [, int $yontem = CAL_EASTER_DEFAULT ]] )

Verilen yıl için Paskalya zamanına, 21 Marttan sonraki kalan gün sayısını verir. Yıl belirtilmezse öntanımlı olarak içinde bulunulan yıl alınır.

Bu işlev Unix zaman damgasının dışına düşen yıllarda (1970'den önce, 2037'den sonra), Paskalya gününü hesaplamak için easter_date() işlevi yerine kullanılabilir.

Paskalya günü, ilk olarak M.S. 325 yılında İznik Konseyi tarafından, İlk dolunaydan veya Bahar ılımından (ekinoks) sonraki ilk pazar günü olarak tanımlanmıştır. Ilımın daima 21 Mart tarihine rastladığı varsayılır ve hesaplama dolunayın ve sonraki pazar gününün hesaplanmasına indirgenir. Kullanılan algoritma Dionysius Exiguus tarafından 532 yılında tanıtıldı. Jülyen takvimi döneminde (1753'den önceki yıllar) ayın evrelerini takip etmek için basit 19 yıllık çevrim kullanıldı. Gregoryen takvimi döneminde (1753'den sonraki yıllar - Clavius ve Lilius tarafından hazırlandı ve XIII Papa Gregory tarafından Ekim 1582'de tanıtıldı, Eylül 1752'de Britanya ve kolonilerine yayıldı) çevrimin daha doğru olması için 2 düzeltme değişkeni eklendi.

(Simon Kershaw tarafından yazılan C programı temel alınmıştır, <webmaster at ely.anglican dot org>)

Değiştirgeler

yil

Pozitif sayı olarak yıl

yontem

CAL_EASTER_ROMAN sabiti verildiği zaman 1582 - 1752 yılları için Gregoryen takvimi temel alınarak hesaplama yapar. Diğer sabitler için takvim sabitleri adresine bakınız.

Dönen Değerler

Verilen yil değiştirgesi için Paskalya zamanına, 21 Marttan sonraki kalan gün sayısını verir.

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.0 sürümünden beri | yil değiştirgesi seçimliktir, ihmal edilirse yerel zamana göre içinde bulunulan yıla eşittir.
4.3.0 sürümünden beri | yontem değiştirgesi eklenmiştir.

Örnekler

Örnek 1 easter_days() örneği

<?php

echo easter_days(1999);        // 14, i.e. April 4
echo easter_days(1492);        // 32, i.e. April 22
echo easter_days(1913);        //  2, i.e. March 23

?>

Ayrıca Bakınız

  • easter_date() - Verilen yıl için paskalya gece yarısının unix zaman damgasını döner

easter_date
FrenchToJD
Takvim İşlevleri


Fransız İhtilali takvim tarihini, Jülyen Gün Sayısına çevirir

easter_days
GregorianToJD
Takvim İşlevleri
PHP Manual

FrenchToJD

(PHP 4, PHP 5, PHP 7)

FrenchToJD — Fransız İhtilali takvim tarihini, Jülyen Gün Sayısına çevirir

Açıklama

int frenchtojd ( int $ay , int $gun , int $yil )

Fransız Cumhuriyet Takvim tarihini, Jülyen Gün Sayısına çevirir.

Bu işlev, sadece 1'den 14'e kadar olan yılları çevirir (Gregoryen tarihleri 22 Eylül 1792'den 22 Eylül 1806'ya kadar). Bu aralık takvimin kullanımda olduğu zamanlardan daha geniş bir dönemi kapsar.

Değiştirgeler

ay

1'den (Vendémiaire için), 13'e (her yılın sonundaki 5-6 gün için) kadar sayı olarak ay değeri

gun

1'den 30'a kadar sayı olarak gün değeri

yil

1 ile 14 arasında yıl değeri.

Dönen Değerler

Tamsayı olarak, verilmiş Fransız İhtilali Tarihine karşılık gelen Jülyen Gün Sayısı.

Ayrıca Bakınız

  • jdtofrench() - Jülyen gün sayısını, Fransız İhtilali takvimine çevirir
  • cal_to_jd() - Desteklenen bir takvimden Jülyen Gün Sayısına dönüşüm yapar

easter_days
GregorianToJD
Takvim İşlevleri


Gregoryen tarihini, Jülyen Gün Sayısına çevirir

FrenchToJD
JDDayOfWeek
Takvim İşlevleri
PHP Manual

GregorianToJD

(PHP 4, PHP 5, PHP 7)

GregorianToJD — Gregoryen tarihini, Jülyen Gün Sayısına çevirir

Açıklama

int gregoriantojd ( int $ay , int $gun , int $yil )

Gregoryen Takvimi için geçerli olan aralık M.Ö. 4714 ile M.S. 9999 arasıdır

Bu işlev M.Ö. 4714'e kadar olan tarihleri işleyebilse de, bu tip bir kullanım anlamlı değildir. Gregoryen takvimi 15 Ekim 1582'ye (Jülyen takvimine göre 5 Ekim 1582) kadar kullanılmamıştır. Hatta bazı ülkeler bu tarihten daha sonra kullanmaya başlamıştır, örneğin; İngiliz krallığı 1752, SSCB 1918 ve Yunanistan 1923'de geçmiştir. Birçok Avrupa ülkesi Gregoryen takviminden önce Jülyen takvimini kullanmıştır.

Değiştirgeler

ay

1'den (Ocak), 12'ye (Aralık) kadar ay değeri

gun

1 ile 31 arasında gün değeri

yil

-4714 ile 9999 arasında yıl değeri

Dönen Değerler

Gregoryen tarihine karşılık tamsayı olarak Jülyen Gün Sayısı.

Örnekler

Örnek 1 Takvim işlevleri örneği

<?php
$jd = GregorianToJD(10, 11, 1970);
echo "$jd\n";
$gregorian = JDToGregorian($jd);
echo "$gregorian\n";
?>

Ayrıca Bakınız

  • jdtogregorian() - Jülyen Gün Sayısını, Gregoryen tarihine çevirir
  • cal_to_jd() - Desteklenen bir takvimden Jülyen Gün Sayısına dönüşüm yapar

FrenchToJD
JDDayOfWeek
Takvim İşlevleri


Haftanın gününü verir

GregorianToJD
JDMonthName
Takvim İşlevleri
PHP Manual

JDDayOfWeek

(PHP 4, PHP 5, PHP 7)

JDDayOfWeek — Haftanın gününü verir

Açıklama

mixed jddayofweek ( int $julyengunu [, int $yontem = CAL_DOW_DAYNO ] )

Haftanın gününü verir. Değiştirge olarak verilen yöntem'e göre dizge veya tamsayı geri döner.

Değiştirgeler

julyengunu

Tamsayı olarak Jülyen Gün Sayısı

yontem
Takvim hafta yöntemleri
Yöntem | Anlamı
0 (Öntanımlı) | Tamsayı olarak gün sayısını döner (0=Pazar, 1=Pazartesi, v.b.)
1 | Haftanın gününün dizge karşılığını döner (İngilizce-Gregoryen)
2 | Günün kısaltılmış değerini döner (İngilizce-Gregoryen)

Dönen Değerler

Dizge ya da tamsayı olarak, hafta gününün gregoryen değeri.

GregorianToJD
JDMonthName
Takvim İşlevleri


Ay adını geri döner

JDDayOfWeek
JDToFrench
Takvim İşlevleri
PHP Manual

JDMonthName

(PHP 4, PHP 5, PHP 7)

JDMonthName — Ay adını geri döner

Açıklama

string jdmonthname ( int $julyengunu , int $takvim )

Ay adını dizge olarak döndürür. takvim Jülyen Gün Sayısının hangi takvim ve ay adına çevrileceğini belirler.

Takvim değerleri
Yöntem | Anlamı | Değerleri
0 | Gregoryen - kısaltılmış | Jan, Feb, Mar, Apr, May, Jun, Jul, Aug, Sep, Oct, Nov, Dec
1 | Gregoryen | January, February, March, April, May, June, July, August, September, October, November, December
2 | Jülyen - kısaltılmış | Jan, Feb, Mar, Apr, May, Jun, Jul, Aug, Sep, Oct, Nov, Dec
3 | Jülyen | January, February, March, April, May, June, July, August, September, October, November, December
4 | Yahudi | Tishri, Heshvan, Kislev, Tevet, Shevat, AdarI, AdarII, Nisan, Iyyar, Sivan, Tammuz, Av, Elul
5 | Fransız İhtilali | Vendemiaire, Brumaire, Frimaire, Nivose, Pluviose, Ventose, Germinal, Floreal, Prairial, Messidor, Thermidor, Fructidor, Extra

Değiştirgeler

julyengunu

Üzerinde işlem yapılacak Jülyen Günü

takvim

Ay adının alınacağı takvim

Dönen Değerler

Verilen Jülyen Günü ve takvim değiştirgesine göre ay adı.

JDDayOfWeek
JDToFrench
Takvim İşlevleri


Jülyen gün sayısını, Fransız İhtilali takvimine çevirir

JDMonthName
JDToGregorian
Takvim İşlevleri
PHP Manual

JDToFrench

(PHP 4, PHP 5, PHP 7)

JDToFrench — Jülyen gün sayısını, Fransız İhtilali takvimine çevirir

Açıklama

string jdtofrench ( int $julyengunu )

Jülyen gün sayısını, Fransız İhtilali takvimine çevirir.

Değiştirgeler

julyengunu

Tamsayı olarak Jülyen Gün Sayısı

Dönen Değerler

"ay/gün/yıl" biçiminde, dizge olarak Fransız İhtilal takvim tarihi

Ayrıca Bakınız

  • frenchtojd() - Fransız İhtilali takvim tarihini, Jülyen Gün Sayısına çevirir
  • cal_from_jd() - Jülyen Gün Sayısını, istenen takvim biçimine çevirir

JDMonthName
JDToGregorian
Takvim İşlevleri


Jülyen Gün Sayısını, Gregoryen tarihine çevirir

JDToFrench
jdtojewish
Takvim İşlevleri
PHP Manual

JDToGregorian

(PHP 4, PHP 5, PHP 7)

JDToGregorian — Jülyen Gün Sayısını, Gregoryen tarihine çevirir

Açıklama

string jdtogregorian ( int $julyengunu )

Jülyen Gün Sayısını, "ay/gün/yıl" biçimindeki Gregoryen tarih dizgesine çevirir.

Değiştirgeler

julyengunu

Tamsayı olarak, Jülyen Gün Sayısı

Dönen Değerler

"ay/gün/yıl" biçiminde, Gregoryen tarih dizgesi

Ayrıca Bakınız

  • gregoriantojd() - Gregoryen tarihini, Jülyen Gün Sayısına çevirir
  • cal_from_jd() - Jülyen Gün Sayısını, istenen takvim biçimine çevirir

JDToFrench
jdtojewish
Takvim İşlevleri


Jülyen Gün Sayısını, Yahudi takvimine çevirir

JDToGregorian
JDToJulian
Takvim İşlevleri
PHP Manual

jdtojewish

(PHP 4, PHP 5, PHP 7)

jdtojewish — Jülyen Gün Sayısını, Yahudi takvimine çevirir

Açıklama

string jdtojewish ( int $julyengunu [, bool $ibrani = false [, int $bicim = 0 ]] )

Jülyen Gün Sayısını, Yahudi takvimine çevirir.

Değiştirgeler

julyengunu

Tamsayı olarak Jülyen Gün Sayısı

ibrani

ibrani değiştirgesi TRUE olarak ayarlanırsa, bicim değiştirgesi, İbranice çıktıyı biçimlendirmek için kullanılır.

bicim

Geçerli sabitler şunlardır: CAL_JEWISH_ADD_ALAFIM_GERESH, CAL_JEWISH_ADD_ALAFIM, CAL_JEWISH_ADD_GERESHAYIM.

Dönen Değerler

Dizge olarak, "ay/gün/yıl" biçiminde Yahudi takvimi tarihi

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.0 | bicim değiştirgesi eklenmiştir.
4.3.0 | ibrani değiştirgesi eklenmiştir.

Örnekler

Örnek 1 jdtojewish() örneği

<?php
echo jdtojewish(gregoriantojd(10, 8, 2002), true,
       CAL_JEWISH_ADD_GERESHAYIM + CAL_JEWISH_ADD_ALAFIM +
       CAL_JEWISH_ADD_ALAFIM_GERESH);
?>

Ayrıca Bakınız

  • jewishtojd() - Yahudi takvimindeki bir tarihi, Jülyen Gün Sayısına çevirir
  • cal_from_jd() - Jülyen Gün Sayısını, istenen takvim biçimine çevirir

JDToGregorian
JDToJulian
Takvim İşlevleri


Jülyen Gün Sayısını, Jülyen takvim tarihine çevirir

jdtojewish
jdtounix
Takvim İşlevleri
PHP Manual

JDToJulian

(PHP 4, PHP 5, PHP 7)

JDToJulian — Jülyen Gün Sayısını, Jülyen takvim tarihine çevirir

Açıklama

string jdtojulian ( int $julyengunu )

Jülyen Gün Sayısını, "ay/gün/yıl" biçiminde Jülyen takvim tarihine çevirir.

Değiştirgeler

julyengunu

Tamsayı olarak Jülyen Gün Sayısı

Dönen Değerler

"ay/gün/yıl" biçiminde dizge olarak Jülyen takvimi tarihi

Ayrıca Bakınız

  • juliantojd() - Jülyen takvimindeki tarihi, Jülyen Gün Sayısına çevirir
  • cal_from_jd() - Jülyen Gün Sayısını, istenen takvim biçimine çevirir

jdtojewish
jdtounix
Takvim İşlevleri


Jülyen Gün Sayısını, Unix zaman damgasına çevirir

JDToJulian
JewishToJD
Takvim İşlevleri
PHP Manual

jdtounix

(PHP 4, PHP 5, PHP 7)

jdtounix — Jülyen Gün Sayısını, Unix zaman damgasına çevirir

Açıklama

int jdtounix ( int $julyengunu )

İşlev julyengunu'ne karşılık gelen Unix zaman damgasını ya da verilen julyengunu Unix zaman damgası aralığında (1970 ve 2037 Gregoryen yılları arası veya 2440588 <= julyengunu <= 2465342 ) değilse FALSE değerini döner. İşlevden dönen zaman damgası, GMT'ye göre değil, yerel zamana göredir.

Değiştirgeler

julyengunu

2440588 ve 2465342 aralığında Jülyen Gün Sayısı.

Dönen Değerler

Jülyen Gün Sayısına, karşılık gelen Unix zaman damgası.

Ayrıca Bakınız

  • unixtojd() - Unix zaman damgasını, Jülyen Gün Sayısına çevirir

JDToJulian
JewishToJD
Takvim İşlevleri


Yahudi takvimindeki bir tarihi, Jülyen Gün Sayısına çevirir

jdtounix
JulianToJD
Takvim İşlevleri
PHP Manual

JewishToJD

(PHP 4, PHP 5, PHP 7)

JewishToJD — Yahudi takvimindeki bir tarihi, Jülyen Gün Sayısına çevirir

Açıklama

int jewishtojd ( int $ay , int $gun , int $yil )

İşlev, 1. yıldan (M.Ö. 3761) itibaren bütün tarihleri çevirebilse de, bu tip kullanım anlamlı değildir. Yahudi takvimi birkaç bin yıldan beri kullanımdadır, bununla birlikte ilk dönemlerinde bir ayın başlangıcı belirlemek için herhangi bir yol yoktu. Yeni bir ay, ilk hilal gözlendiğinde başlıyordu.

Değiştirgeler

ay

1 ile 13 aralığında sayı olarak ay

gun

1 ile 30 aralığında sayı olarak gün

yil

1 ile 9999 aralığında sayı olarak yıl

Dönen Değerler

Yahudi tarihine karşılık gelen Jülyen Gün Sayısı.

Ayrıca Bakınız

  • jdtojewish() - Jülyen Gün Sayısını, Yahudi takvimine çevirir
  • cal_to_jd() - Desteklenen bir takvimden Jülyen Gün Sayısına dönüşüm yapar

jdtounix
JulianToJD
Takvim İşlevleri


Jülyen takvimindeki tarihi, Jülyen Gün Sayısına çevirir

JewishToJD
unixtojd
Takvim İşlevleri
PHP Manual

JulianToJD

(PHP 4, PHP 5, PHP 7)

JulianToJD — Jülyen takvimindeki tarihi, Jülyen Gün Sayısına çevirir

Açıklama

int juliantojd ( int $ay , int $gun , int $yil )

Jülyen takviminin geçerli olduğu aralık M.Ö. 4713 ile M.S. 9999'dur.

İşlev, M.Ö. 4713 yılına kadar tarihler için dönüşüm yapabilse de, böyle kullanımlar anlamlı değildir. Takvim M.Ö. 46 yılında başlamıştır fakat M.S. 8 ve belki de 4. yüzyılın sonlarına kadar yaygın hale gelmemiştir. Ayrıca, yılın başlangıcı bir kültürden diğerine değişiyordu, hepsi Ocak ayını ilk ay olarak kabul etmemişti.

Dikkat

Şimdi dünya genelinde kullanılan takvim sistemin Gregoryen olduğunu unutmayın, gregoriantojd() işlevi tarihleri Jülyen Gün Sayısına çevirmek için kullanılabilir.

Değiştirgeler

ay

1 (Ocak) ile 12 (Aralık) aralığında sayı olarak ay

gun

1 ile 31 aralığında sayı olarak gün

yil

-4713 ile 9999 aralığında sayı olarak yıl değeri

Dönen Değerler

Verilen Jülyen tarihine karşılık gelen Jülyen Gün Sayısı.

Ayrıca Bakınız

  • jdtojulian() - Jülyen Gün Sayısını, Jülyen takvim tarihine çevirir
  • cal_to_jd() - Desteklenen bir takvimden Jülyen Gün Sayısına dönüşüm yapar

JewishToJD
unixtojd
Takvim İşlevleri


Unix zaman damgasını, Jülyen Gün Sayısına çevirir

JulianToJD
Tarih ve Zaman
Takvim İşlevleri
PHP Manual

unixtojd

(PHP 4, PHP 5, PHP 7)

unixtojd — Unix zaman damgasını, Jülyen Gün Sayısına çevirir

Açıklama

int unixtojd ([ int $zamandamgasi = time() ] )

Verilen Unix zamandamgasi (1.1.1970'den başlayarak geçen saniye sayısı) için Jülyen Gün Sayısını döndürür, eğer zamandamgasi verilmez ise içinde bulunulan gün için Jülyen Gün Sayısını verir.

Değiştirgeler

zamandamgasi

Çevrilecek unix zaman damgası.

Dönen Değerler

Tamsayı olarak, Jülyen Gün Sayısı.

Ayrıca Bakınız

  • jdtounix() - Jülyen Gün Sayısını, Unix zaman damgasına çevirir

JulianToJD
Tarih ve Zaman
Takvim İşlevleri


Tarih ve Zaman

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Desteklenen Zaman Dilimlerinin Listesi
    • Afrika
    • Amerika
    • Antarktika
    • Kuzey Kutup Dairesi
    • Asya
    • Atlantik
    • Avustralya
    • Avrupa
    • Hint Denizi
    • Pasifik
    • Diğerleri
  • Supported Date and Time Formats
    • Time Formats
    • Date Formats
    • Compound Formats
    • Relative Formats
  • DateTime — DateTime sınıfı
    • DateTime::add — Adds an amount of days, months, years, hours, minutes and seconds to a DateTime object
    • DateTime::__construct — Returns new DateTime object
    • DateTime::createFromFormat — Parses a time string according to a specified format
    • DateTime::getLastErrors — Returns the warnings and errors
    • DateTime::modify — Alters the timestamp
    • DateTime::__set_state — The __set_state handler
    • DateTime::setDate — Sets the date
    • DateTime::setISODate — Sets the ISO date
    • DateTime::setTime — Sets the time
    • DateTime::setTimestamp — Sets the date and time based on an Unix timestamp
    • DateTime::setTimezone — Sets the time zone for the DateTime object
    • DateTime::sub — Subtracts an amount of days, months, years, hours, minutes and seconds from a DateTime object
  • DateTimeZone — DateTimeZone sınıfı
    • DateTimeZone::__construct — Yeni bir DateTimeZone nesnesi oluşturur
    • DateTimeZone::getLocation — Zaman dilimi konum bilgisini döndürür
    • DateTimeZone::getName — Zaman diliminin adını döndürür
    • DateTimeZone::getOffset — Returns the timezone offset from GMT
    • DateTimeZone::getTransitions — Returns all transitions for the timezone
    • DateTimeZone::listAbbreviations — Returns associative array containing dst, offset and the timezone name
    • DateTimeZone::listIdentifiers — Returns a numerically indexed array containing all defined timezone identifiers
  • DateInterval — DateInterval sınıfı
    • DateInterval::__construct — Yeni bir DateInterval nesnesi oluşturur
    • DateInterval::createFromDateString — Dizgenin göreli kısımlarından bir DateInterval nesnesi döndürür
    • DateInterval::format — Zaman aralığını biçimler
  • DatePeriod — DatePeriod sınıfı
    • DatePeriod::__construct — Yeni bir DatePeriod nesnesi oluşturur
    • DatePeriod::getDateInterval — Gets the interval
    • DatePeriod::getEndDate — Gets the end date
    • DatePeriod::getStartDate — Gets the start date
  • Tarih ve Zaman İşlevleri
    • checkdate — Miladi tarihi doğrular
    • date_add — DateTime::add işlevinin takma adıdır
    • date_create_from_format — DateTime::createFromFormat işlevinin takma adıdır
    • date_create_immutable_from_format — Takma Adı: DateTimeImmutable::createFromFormat
    • date_create_immutable — Takma Adı: DateTimeImmutable::__construct
    • date_create — DateTime::__construct için bir takma ad
    • date_date_set — DateTime::setDate işlevinin takma adıdır
    • date_default_timezone_get — Betik içerisindeki tüm tarih/zaman işlevleri tarafından kullanılan öntanımlı zaman dilimini getirir
    • date_default_timezone_set — Betik içerisindeki tüm tarih/zaman işlevleri tarafından kullanılan öntanımlı zaman dilimini ayarlar
    • date_diff — DateTime::diff işlevinin takma adıdır
    • date_format — DateTime::format işlevinin takma adıdır
    • date_get_last_errors — DateTime::getLastErrors işlevinin takma adıdır
    • date_interval_create_from_date_string — DateInterval::createFromDateString işlevinin takma adıdır
    • date_interval_format — DateInterval::format işlevinin takma adıdır
    • date_isodate_set — DateTime::setISODate işlevinin takma adıdır
    • date_modify — DateTime::modify işlevinin takma adıdır
    • date_offset_get — DateTime::getOffset işlevinin takma adıdır
    • date_parse_from_format — Get info about given date formatted according to the specified format
    • date_parse — Verilen tarih hakkındaki ayrıntılı bilgiyi ilişkisel dizi olarak döndürür
    • date_sub — DateTime::sub işlevinin takma adıdır
    • date_sun_info — Güneşin doğuşu/batışı ve alacakaranlık başlangıcı/sonu hakkında bilgi içeren bir dizi döndürür
    • date_sunrise — Belirtilen gün ve konum için şafak zamanını döndürür
    • date_sunset — Verilen gün ve konum için günbatımı zamanını döndürür
    • date_time_set — DateTime::setTime işlevinin takma adıdır
    • date_timestamp_get — DateTime::getTimestamp işlevinin takma adıdır
    • date_timestamp_set — DateTime::setTimestamp işlevinin takma adıdır
    • date_timezone_get — DateTime::getTimezone işlevinin takma adıdır
    • date_timezone_set — DateTime::setTimezone işlevinin takma adıdır
    • date — Yerel tarihi/saati biçimlendirir
    • getdate — Tarih/zaman bilgisi getirir
    • gettimeofday — Geçerli zamanı getirir
    • gmdate — Bir tarih/saati GMT/UTC tarih/saati olarak biçemler
    • gmmktime — Bir GMT tarihi için Unix zaman damgasını döndürür
    • gmstrftime — Yerel ayarlara göre tarih ve saati, GMT/UTC türüne çevirir
    • idate — Yerel zamanı/tarihi tamsayı olarak biçimlendirir
    • localtime — Yerel zamanı getirir
    • microtime — Geçerli Unix zaman damgasını mikrosaniye olarak döndürür
    • mktime — Bir tarih için Unix zaman damgasını döndürür
    • strftime — Format a local time/date according to locale settings
    • strptime — strftime işleviyle üretilen zaman ve tarihleri çözümler
    • strtotime — Parse about any English textual datetime description into a Unix timestamp
    • time — Geçerli Unix zaman damgasını döndürür
    • timezone_abbreviations_list — DateTimeZone::listAbbreviations işlevinin takma adıdır
    • timezone_identifiers_list — DateTimeZone::listIdentifiers işlevinin takma adıdır
    • timezone_location_get — DateTimeZone::getLocation işlevinin takma adıdır
    • timezone_name_from_abbr — Kısaltmasından, zaman diliminin adını döndürür
    • timezone_name_get — DateTimeZone::getName işlevinin takma adıdır
    • timezone_offset_get — DateTimeZone::getOffset işlevinin takma adıdır
    • timezone_open — DateTimeZone::__construct için takma ad
    • timezone_transitions_get — DateTimeZone::getTransitions işlevinin takma adıdır
    • timezone_version_get — Gets the version of the timezonedb
unixtojd
Giriş
Tarih ve Saat ile İlgili Eklentiler


Giriş

Bu işlevler PHP betiğinizin çalıştığı sunucunun tarih ve saati üzerinde işlem yaparlar. Tarih ve saati farklı biçemlerde göstermek için bu işlevleri kullanabilirsiniz.

Tarih ve zaman bilgisi dahili olarak 64 bitlik bir sayı olarak saklanır, dolayısıyla hayali tarihler (negatif yıllar dahil) desteklenir. Aralık, geçmişte yaklaşık 292 milyar yıldan, gelecekte yaklaşık 292 milyar yıla kadardır.

Bilginize: Bu işlevlerin sunucunuzun yerel zaman ayarlarına bağlı olarak işlem yaptığını lütfen aklınızdan çıkarmayın. Yaz saati uygulamasına dikkat edin. Örneğin, süre ekleme işlemi için $date += 7*24*60*60 değil $date = strtotime('+7 days', $date) kullanın. Ayrıca, bu işlevlerin artık yılları hesaba kattığını unutmayın.

Bilginize: Bu işlevlerde kullanılabilecek zaman dilimlerini Desteklenen Zaman Dilimlerinin Listesi bölümünde bulabilirsiniz.

Tarih ve Zaman
Yapılandırma/Kurulum
Tarih ve Zaman


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Tarih ve Zaman


Kurulum

Bu işlevleri kullanmak için hiçbir şey kurmaya gerek yoktur; PHP çekirdeğinin parçasıdırlar.

Bilginize: Güncel zaman dilimi veritabanının yüklenmesi

Zaman dilimi veritabanın güncel sürümü, PECL'nin » zaman dilimi veritabanı olarak yüklenebilir.

Bilginize: PHP 5.1.x sürümlerinde Deneysel DateTime Desteği

Her ne kadar DateTime sınıfı (ve ilgili işlevleri) PHP 5.2.0 sürümünden itibaren kullanılabilir olsalar da, PHP 5.1.x sürümlerinde deneysel desteği eklemek için yapılandırma ya da derlemede sırasında CFLAGS=-DEXPERIMENTAL_DATE_SUPPORT=1 seçeneği kullanılabilir.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Tarih/Saat Yapılandırma Seçenekleri
İsim | Varsayılan | Değişiklik yeri | Sürüm bilgisi
date.default_latitude | "31.7667" | PHP_INI_ALL | PHP 5.0.0 sürümünden beri kullanılabilir.
date.default_longitude | "35.2333" | PHP_INI_ALL | PHP 5.0.0 sürümünden beri kullanılabilir.
date.sunrise_zenith | "90.583333" | PHP_INI_ALL | PHP 5.0.0 sürümünden beri kullanılabilir.
date.sunset_zenith | "90.583333" | PHP_INI_ALL | PHP 5.0.0 sürümünden beri kullanılabilir.
date.timezone | "" | PHP_INI_ALL | PHP 5.1.0 sürümünden beri kullanılabilir.
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

date.default_latitude float

Varsayılan enlem.

date.default_longitude float

Varsayılan boylam.

date.sunrise_zenith float

Varsayılan gün doğumu başucu noktası.

date.sunset_zenith float

Varsayılan gün batımı başucu noktası.

date.timezone string

Eğer TZ ortam değişkeni ayarlanmamışsa tüm tarih/saat işlevleri için varsayılan zaman dilimi kullanılır. Öncelik sıralaması date_default_timezone_get() işlevinin sayfasında tanımlanmıştır. Desteklenen zaman dilimleri için Desteklenen Zaman Dilimlerinin Listesi sayfasına bakın.

Bilginize: İlk dört yapılandırma seçeneği halen sadece date_sunrise() ile date_sunset() işlevlerinde kullanılmaktadır.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

DATE_ sabitleri PHP 5.1.1 sürümünden itibaren tanımlanmıştır ve standart tarih gösterimi için tarih biçimlendirme işlevleriyle kullanılabilirler. (date() işlevi gibi).

Aşağıdaki sabitler PHP 5.1.2 sürümünden itibaren mevcutturlar ve date_sunrise() ile date_sunset() işlevleri tarafından biçim belirtmek için döndürülürler.

SUNFUNCS_RET_TIMESTAMP (integer)
Zaman damgası
SUNFUNCS_RET_STRING (integer)
Saat:dakika (örnek: 08:02)
SUNFUNCS_RET_DOUBLE (integer)
Gerçek sayı olarak saat (örnek: 8.75)
Özkaynak Türleri
Desteklenen Zaman Dilimlerinin Listesi
Tarih ve Zaman


Desteklenen Zaman Dilimlerinin Listesi

İçindekiler

  • Afrika
  • Amerika
  • Antarktika
  • Kuzey Kutup Dairesi
  • Asya
  • Atlantik
  • Avustralya
  • Avrupa
  • Hint Denizi
  • Pasifik
  • Diğerleri

Burada, date_default_timezone_set() gibi işlevler tarafından kullanılmak üzere PHP tarafından desteklenen zaman dilimlerinin tamamı listelenmiştir.

Bilginize: Zaman dilimi veritabanının en son sürümü PECL'nin » timezonedb paketinden kurulabilir.

Bilginize: Bu liste zaman dilimi veritabanının şu sürümüne dayanır: 2016.10.

Öntanımlı Sabitler
Afrika
Tarih ve Zaman


Afrika

Afrika
Africa/Abidjan | Africa/Accra | Africa/Addis_Ababa | Africa/Algiers
Africa/Asmara | Africa/Bamako | Africa/Bangui | Africa/Banjul
Africa/Bissau | Africa/Blantyre | Africa/Brazzaville | Africa/Bujumbura
Africa/Cairo | Africa/Casablanca | Africa/Ceuta | Africa/Conakry
Africa/Dakar | Africa/Dar_es_Salaam | Africa/Djibouti | Africa/Douala
Africa/El_Aaiun | Africa/Freetown | Africa/Gaborone | Africa/Harare
Africa/Johannesburg | Africa/Juba | Africa/Kampala | Africa/Khartoum
Africa/Kigali | Africa/Kinshasa | Africa/Lagos | Africa/Libreville
Africa/Lome | Africa/Luanda | Africa/Lubumbashi | Africa/Lusaka
Africa/Malabo | Africa/Maputo | Africa/Maseru | Africa/Mbabane
Africa/Mogadishu | Africa/Monrovia | Africa/Nairobi | Africa/Ndjamena
Africa/Niamey | Africa/Nouakchott | Africa/Ouagadougou | Africa/Porto-Novo
Africa/Sao_Tome | Africa/Tripoli | Africa/Tunis | Africa/Windhoek
Desteklenen Zaman Dilimlerinin Listesi
Amerika
Desteklenen Zaman Dilimlerinin Listesi


Amerika

Amerika
America/Adak | America/Anchorage | America/Anguilla | America/Antigua
America/Araguaina | America/Argentina/Buenos_Aires | America/Argentina/Catamarca | America/Argentina/Cordoba
America/Argentina/Jujuy | America/Argentina/La_Rioja | America/Argentina/Mendoza | America/Argentina/Rio_Gallegos
America/Argentina/Salta | America/Argentina/San_Juan | America/Argentina/San_Luis | America/Argentina/Tucuman
America/Argentina/Ushuaia | America/Aruba | America/Asuncion | America/Atikokan
America/Bahia | America/Bahia_Banderas | America/Barbados | America/Belem
America/Belize | America/Blanc-Sablon | America/Boa_Vista | America/Bogota
America/Boise | America/Cambridge_Bay | America/Campo_Grande | America/Cancun
America/Caracas | America/Cayenne | America/Cayman | America/Chicago
America/Chihuahua | America/Costa_Rica | America/Creston | America/Cuiaba
America/Curacao | America/Danmarkshavn | America/Dawson | America/Dawson_Creek
America/Denver | America/Detroit | America/Dominica | America/Edmonton
America/Eirunepe | America/El_Salvador | America/Fort_Nelson | America/Fortaleza
America/Glace_Bay | America/Godthab | America/Goose_Bay | America/Grand_Turk
America/Grenada | America/Guadeloupe | America/Guatemala | America/Guayaquil
America/Guyana | America/Halifax | America/Havana | America/Hermosillo
America/Indiana/Indianapolis | America/Indiana/Knox | America/Indiana/Marengo | America/Indiana/Petersburg
America/Indiana/Tell_City | America/Indiana/Vevay | America/Indiana/Vincennes | America/Indiana/Winamac
America/Inuvik | America/Iqaluit | America/Jamaica | America/Juneau
America/Kentucky/Louisville | America/Kentucky/Monticello | America/Kralendijk | America/La_Paz
America/Lima | America/Los_Angeles | America/Lower_Princes | America/Maceio
America/Managua | America/Manaus | America/Marigot | America/Martinique
America/Matamoros | America/Mazatlan | America/Menominee | America/Merida
America/Metlakatla | America/Mexico_City | America/Miquelon | America/Moncton
America/Monterrey | America/Montevideo | America/Montserrat | America/Nassau
America/New_York | America/Nipigon | America/Nome | America/Noronha
America/North_Dakota/Beulah | America/North_Dakota/Center | America/North_Dakota/New_Salem | America/Ojinaga
America/Panama | America/Pangnirtung | America/Paramaribo | America/Phoenix
America/Port-au-Prince | America/Port_of_Spain | America/Porto_Velho | America/Puerto_Rico
America/Rainy_River | America/Rankin_Inlet | America/Recife | America/Regina
America/Resolute | America/Rio_Branco | America/Santarem | America/Santiago
America/Santo_Domingo | America/Sao_Paulo | America/Scoresbysund | America/Sitka
America/St_Barthelemy | America/St_Johns | America/St_Kitts | America/St_Lucia
America/St_Thomas | America/St_Vincent | America/Swift_Current | America/Tegucigalpa
America/Thule | America/Thunder_Bay | America/Tijuana | America/Toronto
America/Tortola | America/Vancouver | America/Whitehorse | America/Winnipeg
America/Yakutat | America/Yellowknife |  |
Afrika
Antarktika
Desteklenen Zaman Dilimlerinin Listesi


Antarktika

Antarktika
Antarctica/Casey | Antarctica/Davis | Antarctica/DumontDUrville | Antarctica/Macquarie
Antarctica/Mawson | Antarctica/McMurdo | Antarctica/Palmer | Antarctica/Rothera
Antarctica/Syowa | Antarctica/Troll | Antarctica/Vostok |
Amerika
Kuzey Kutup Dairesi
Desteklenen Zaman Dilimlerinin Listesi


Kuzey Kutup Dairesi

Kuzey Kutup Dairesi
Arctic/Longyearbyen
Antarktika
Asya
Desteklenen Zaman Dilimlerinin Listesi


Asya

Asya
Asia/Aden | Asia/Almaty | Asia/Amman | Asia/Anadyr
Asia/Aqtau | Asia/Aqtobe | Asia/Ashgabat | Asia/Atyrau
Asia/Baghdad | Asia/Bahrain | Asia/Baku | Asia/Bangkok
Asia/Barnaul | Asia/Beirut | Asia/Bishkek | Asia/Brunei
Asia/Chita | Asia/Choibalsan | Asia/Colombo | Asia/Damascus
Asia/Dhaka | Asia/Dili | Asia/Dubai | Asia/Dushanbe
Asia/Famagusta | Asia/Gaza | Asia/Hebron | Asia/Ho_Chi_Minh
Asia/Hong_Kong | Asia/Hovd | Asia/Irkutsk | Asia/Jakarta
Asia/Jayapura | Asia/Jerusalem | Asia/Kabul | Asia/Kamchatka
Asia/Karachi | Asia/Kathmandu | Asia/Khandyga | Asia/Kolkata
Asia/Krasnoyarsk | Asia/Kuala_Lumpur | Asia/Kuching | Asia/Kuwait
Asia/Macau | Asia/Magadan | Asia/Makassar | Asia/Manila
Asia/Muscat | Asia/Nicosia | Asia/Novokuznetsk | Asia/Novosibirsk
Asia/Omsk | Asia/Oral | Asia/Phnom_Penh | Asia/Pontianak
Asia/Pyongyang | Asia/Qatar | Asia/Qyzylorda | Asia/Riyadh
Asia/Sakhalin | Asia/Samarkand | Asia/Seoul | Asia/Shanghai
Asia/Singapore | Asia/Srednekolymsk | Asia/Taipei | Asia/Tashkent
Asia/Tbilisi | Asia/Tehran | Asia/Thimphu | Asia/Tokyo
Asia/Tomsk | Asia/Ulaanbaatar | Asia/Urumqi | Asia/Ust-Nera
Asia/Vientiane | Asia/Vladivostok | Asia/Yakutsk | Asia/Yangon
Asia/Yekaterinburg | Asia/Yerevan |  |
Kuzey Kutup Dairesi
Atlantik
Desteklenen Zaman Dilimlerinin Listesi


Atlantik

Atlantik
Atlantic/Azores | Atlantic/Bermuda | Atlantic/Canary | Atlantic/Cape_Verde
Atlantic/Faroe | Atlantic/Madeira | Atlantic/Reykjavik | Atlantic/South_Georgia
Atlantic/St_Helena | Atlantic/Stanley |  |
Asya
Avustralya
Desteklenen Zaman Dilimlerinin Listesi


Avustralya

Avustralya
Australia/Adelaide | Australia/Brisbane | Australia/Broken_Hill | Australia/Currie
Australia/Darwin | Australia/Eucla | Australia/Hobart | Australia/Lindeman
Australia/Lord_Howe | Australia/Melbourne | Australia/Perth | Australia/Sydney
Atlantik
Avrupa
Desteklenen Zaman Dilimlerinin Listesi


Avrupa

Avrupa
Europe/Amsterdam | Europe/Andorra | Europe/Astrakhan | Europe/Athens
Europe/Belgrade | Europe/Berlin | Europe/Bratislava | Europe/Brussels
Europe/Bucharest | Europe/Budapest | Europe/Busingen | Europe/Chisinau
Europe/Copenhagen | Europe/Dublin | Europe/Gibraltar | Europe/Guernsey
Europe/Helsinki | Europe/Isle_of_Man | Europe/Istanbul | Europe/Jersey
Europe/Kaliningrad | Europe/Kiev | Europe/Kirov | Europe/Lisbon
Europe/Ljubljana | Europe/London | Europe/Luxembourg | Europe/Madrid
Europe/Malta | Europe/Mariehamn | Europe/Minsk | Europe/Monaco
Europe/Moscow | Europe/Oslo | Europe/Paris | Europe/Podgorica
Europe/Prague | Europe/Riga | Europe/Rome | Europe/Samara
Europe/San_Marino | Europe/Sarajevo | Europe/Saratov | Europe/Simferopol
Europe/Skopje | Europe/Sofia | Europe/Stockholm | Europe/Tallinn
Europe/Tirane | Europe/Ulyanovsk | Europe/Uzhgorod | Europe/Vaduz
Europe/Vatican | Europe/Vienna | Europe/Vilnius | Europe/Volgograd
Europe/Warsaw | Europe/Zagreb | Europe/Zaporozhye | Europe/Zurich
Avustralya
Hint Denizi
Desteklenen Zaman Dilimlerinin Listesi


Hint Denizi

Hint Denizi
Indian/Antananarivo | Indian/Chagos | Indian/Christmas | Indian/Cocos
Indian/Comoro | Indian/Kerguelen | Indian/Mahe | Indian/Maldives
Indian/Mauritius | Indian/Mayotte | Indian/Reunion |
Avrupa
Pasifik
Desteklenen Zaman Dilimlerinin Listesi


Pasifik

Pasifik
Pacific/Apia | Pacific/Auckland | Pacific/Bougainville | Pacific/Chatham
Pacific/Chuuk | Pacific/Easter | Pacific/Efate | Pacific/Enderbury
Pacific/Fakaofo | Pacific/Fiji | Pacific/Funafuti | Pacific/Galapagos
Pacific/Gambier | Pacific/Guadalcanal | Pacific/Guam | Pacific/Honolulu
Pacific/Johnston | Pacific/Kiritimati | Pacific/Kosrae | Pacific/Kwajalein
Pacific/Majuro | Pacific/Marquesas | Pacific/Midway | Pacific/Nauru
Pacific/Niue | Pacific/Norfolk | Pacific/Noumea | Pacific/Pago_Pago
Pacific/Palau | Pacific/Pitcairn | Pacific/Pohnpei | Pacific/Port_Moresby
Pacific/Rarotonga | Pacific/Saipan | Pacific/Tahiti | Pacific/Tarawa
Pacific/Tongatapu | Pacific/Wake | Pacific/Wallis |
Hint Denizi
Diğerleri
Desteklenen Zaman Dilimlerinin Listesi


Diğerleri

Uyarı

Lütfen burada listelenen zaman dilimlerini (UTC dışında) kullanmayın. Sadece geriye uyumluluk için varlar.

Uyarı

Yukarıdaki uyarıyı dikkate almazsanız, lütfen şunu dikkate alın: PHP'nin zaman dilimi desteğini sağlayan IANA zaman dilim veritabanı, ortak kullanımdan ayrılmış olarak Etc/GMT+n ve Etc/GMT-n sonuçlarını üreten POSIX tarzı kalıplar kullanır.

Örneğin Çin ve Batı Avustralya'da (ve bunların arasındaki yerlerde) kullanılan GMT'den 8 saat ileri zaman dilimi için bu veritabanı beklendiği gibi Etc/GMT+8 değil Etc/GMT-8 sonucunu verir.

Bir kere daha belirtelim: Bölgeniz için mutlaka doğru zaman dilimini kullanmanızı öneririz. Yukarıdaki örnek için Asia/Shanghai veya Australia/Perth gibi.

Diğerleri
Africa/Asmera | Africa/Timbuktu | America/Argentina/ComodRivadavia | America/Atka
America/Buenos_Aires | America/Catamarca | America/Coral_Harbour | America/Cordoba
America/Ensenada | America/Fort_Wayne | America/Indianapolis | America/Jujuy
America/Knox_IN | America/Louisville | America/Mendoza | America/Montreal
America/Porto_Acre | America/Rosario | America/Santa_Isabel | America/Shiprock
America/Virgin | Antarctica/South_Pole | Asia/Ashkhabad | Asia/Calcutta
Asia/Chongqing | Asia/Chungking | Asia/Dacca | Asia/Harbin
Asia/Istanbul | Asia/Kashgar | Asia/Katmandu | Asia/Macao
Asia/Rangoon | Asia/Saigon | Asia/Tel_Aviv | Asia/Thimbu
Asia/Ujung_Pandang | Asia/Ulan_Bator | Atlantic/Faeroe | Atlantic/Jan_Mayen
Australia/ACT | Australia/Canberra | Australia/LHI | Australia/North
Australia/NSW | Australia/Queensland | Australia/South | Australia/Tasmania
Australia/Victoria | Australia/West | Australia/Yancowinna | Brazil/Acre
Brazil/DeNoronha | Brazil/East | Brazil/West | Canada/Atlantic
Canada/Central | Canada/East-Saskatchewan | Canada/Eastern | Canada/Mountain
Canada/Newfoundland | Canada/Pacific | Canada/Saskatchewan | Canada/Yukon
CET | Chile/Continental | Chile/EasterIsland | CST6CDT
Cuba | EET | Egypt | Eire
EST | EST5EDT | Etc/GMT | Etc/GMT+0
Etc/GMT+1 | Etc/GMT+10 | Etc/GMT+11 | Etc/GMT+12
Etc/GMT+2 | Etc/GMT+3 | Etc/GMT+4 | Etc/GMT+5
Etc/GMT+6 | Etc/GMT+7 | Etc/GMT+8 | Etc/GMT+9
Etc/GMT-0 | Etc/GMT-1 | Etc/GMT-10 | Etc/GMT-11
Etc/GMT-12 | Etc/GMT-13 | Etc/GMT-14 | Etc/GMT-2
Etc/GMT-3 | Etc/GMT-4 | Etc/GMT-5 | Etc/GMT-6
Etc/GMT-7 | Etc/GMT-8 | Etc/GMT-9 | Etc/GMT0
Etc/Greenwich | Etc/UCT | Etc/Universal | Etc/UTC
Etc/Zulu | Europe/Belfast | Europe/Nicosia | Europe/Tiraspol
Factory | GB | GB-Eire | GMT
GMT+0 | GMT-0 | GMT0 | Greenwich
Hongkong | HST | Iceland | Iran
Israel | Jamaica | Japan | Kwajalein
Libya | MET | Mexico/BajaNorte | Mexico/BajaSur
Mexico/General | MST | MST7MDT | Navajo
NZ | NZ-CHAT | Pacific/Ponape | Pacific/Samoa
Pacific/Truk | Pacific/Yap | Poland | Portugal
PRC | PST8PDT | ROC | ROK
Singapore | Turkey | UCT | Universal
US/Alaska | US/Aleutian | US/Arizona | US/Central
US/East-Indiana | US/Eastern | US/Hawaii | US/Indiana-Starke
US/Michigan | US/Mountain | US/Pacific | US/Pacific-New
US/Samoa | UTC | W-SU | WET
Zulu |  |  |
Pasifik
Supported Date and Time Formats
Desteklenen Zaman Dilimlerinin Listesi


Supported Date and Time Formats

İçindekiler

  • Time Formats
  • Date Formats
  • Compound Formats
  • Relative Formats

This section describes all the different formats that the strtotime(), DateTime and date_create() parser understands. The formats are grouped by section. In most cases formats from different sections can be used in the same date/time string. For each of the supported formats, one or more examples are given, as well as a description for the format. Characters in single quotes in the formats are case-insensitive ('t' could be t or T), characters in double quotes are case-sensitive ("T" is only T).

Diğerleri
Time Formats
Tarih ve Zaman


Time Formats

This page describes the different time formats that the strtotime(), DateTime and date_create() parser understands.

Used Symbols
Description | Formats | Examples
frac | . [0-9]+ | ".21342", ".85"
hh | "0"?[1-9] | "1"[0-2] | "04", "7", "12"
HH | [01][0-9] | "2"[0-4] | "04", "07", "19"
meridian | [AaPp] .? [Mm] .? [\0\t ] | "A.m.", "pM", "am."
MM | [0-5][0-9] | "00", "12", "59"
II | [0-5][0-9] | "00", "12", "59"
space | [ \t] |
tz | "("? [A-Za-z]{1,6} ")"? | [A-Z][a-z]+([_/][A-Z][a-z]+)+ | "CEST", "Europe/Amsterdam", "America/Indiana/Knox"
tzcorrection | "GMT"? [+-] hh ":"? MM? | "+0400", "GMT-07:00", "-07:00"
12 Hour Notation
Description | Format | Examples
Hour only, with meridian | hh space? meridian | "4 am", "5PM"
Hour and minutes, with meridian | hh [.:] MM space? meridian | "4:08 am", "7:19P.M."
Hour, minutes and seconds, with meridian | hh [.:] MM [.:] II space? meridian | "4:08:37 am", "7:19:19P.M."
MS SQL (Hour, minutes, seconds and fraction with meridian), PHP 5.3 and later only | hh ":" MM ":" II [.:] [0-9]+ meridian | "4:08:39:12313am"
24 Hour Notation
Description | Format | Examples
Hour and minutes | 't'? HH [.:] MM | "04:08", "19.19", "T23:43"
Hour and minutes, no colon | 't'? HH MM | "0408", "t1919", "T2343"
Hour, minutes and seconds | 't'? HH [.:] MM [.:] II | "04.08.37", "t19:19:19"
Hour, minutes and seconds, no colon | 't'? HH MM II | "040837", "T191919"
Hour, minutes, seconds and timezone | 't'? HH [.:] MM [.:] II space? ( tzcorrection | tz ) | "040837CEST", "T191919-0700"
Hour, minutes, seconds and fraction | 't'? HH [.:] MM [.:] II frac | "04.08.37.81412", "19:19:19.532453"
Time zone information | tz | tzcorrection | "CEST", "Europe/Amsterdam", "+0430", "GMT-06:00"
Supported Date and Time Formats
Date Formats
Supported Date and Time Formats


Date Formats

This page describes the different date formats that the strtotime(), DateTime and date_create() parser understands.

Used Symbols
Description | Format | Examples
daysuf | "st" | "nd" | "rd" | "th" |
dd | ([0-2]?[0-9] | "3"[01]) daysuf? | "7th", "22nd", "31"
DD | "0" [0-9] | [1-2][0-9] | "3" [01] | "07", "31"
m | 'january' | 'february' | 'march' | 'april' | 'may' | 'june' | 'july' | 'august' | 'september' | 'october' | 'november' | 'december' | 'jan' | 'feb' | 'mar' | 'apr' | 'may' | 'jun' | 'jul' | 'aug' | 'sep' | 'sept' | 'oct' | 'nov' | 'dec' | "I" | "II" | "III" | "IV" | "V" | "VI" | "VII" | "VIII" | "IX" | "X" | "XI" | "XII" |
M | 'jan' | 'feb' | 'mar' | 'apr' | 'may' | 'jun' | 'jul' | 'aug' | 'sep' | 'sept' | 'oct' | 'nov' | 'dec' |
mm | "0"? [0-9] | "1"[0-2] | "0", "04", "7", "12"
MM | "0" [0-9] | "1"[0-2] | "00", "04", "07", "12"
y | [0-9]{1,4} | "00", "78", "08", "8", "2008"
yy | [0-9]{2} | "00", "08", "78"
YY | [0-9]{4} | "2000", "2008", "1978"
Localized Notations
Description | Format | Examples
American month and day | mm "/" dd | "5/12", "10/27"
American month, day and year | mm "/" dd "/" y | "12/22/78", "1/17/2006", "1/17/6"
Four digit year, month and day with slashes | YY "/" mm "/" dd | "2008/6/30", "1978/12/22"
Four digit year and month (GNU) | YY "-" mm | "2008-6", "2008-06", "1978-12"
Year, month and day with dashes | y "-" mm "-" dd | "2008-6-30", "78-12-22", "8-6-21"
Day, month and four digit year, with dots, tabs or dashes | dd [.\t-] mm [.-] YY | "30-6-2008", "22.12.1978"
Day, month and two digit year, with dots or tabs | dd [.\t] mm "." yy | "30.6.08", "22\t12.78"
Day, textual month and year | dd ([ \t.-])* m ([ \t.-])* y | "30-June 2008", "22DEC78", "14 III 1879"
Textual month and four digit year (Day reset to 1) | m ([ \t.-])* YY | "June 2008", "DEC1978", "March 1879"
Four digit year and textual month (Day reset to 1) | YY ([ \t.-])* m | "2008 June", "1978-XII", "1879.MArCH"
Textual month, day and year | m ([ .\t-])* dd [,.stndrh\t ]+ y | "July 1st, 2008", "April 17, 1790", "May.9,78"
Textual month and day | m ([ .\t-])* dd [,.stndrh\t ]* | "July 1st,", "Apr 17", "May.9"
Day and textual month | d ([ .\t-])* m | "1 July", "17 Apr", "9.May"
Month abbreviation, day and year | M "-" DD "-" y | "May-09-78", "Apr-17-1790"
Year, month abbreviation and day | y "-" M "-" DD | "78-Dec-22", "1814-MAY-17"
Year (and just the year) | YY | "1978", "2008"
Textual month (and just the month) | m | "March", "jun", "DEC"
ISO8601 Notations
Description | Format | Examples
Eight digit year, month and day | YY MM DD | "15810726", "19780417", "18140517"
Four digit year, month and day with slashes | YY "/" MM "/" DD | "2008/06/30", "1978/12/22"
Two digit year, month and day with dashes | yy "-" MM "-" DD | "08-06-30", "78-12-22"
Four digit year with optional sign, month and day | [+-]? YY "-" MM "-" DD | "-0002-07-26", "+1978-04-17", "1814-05-17"

Bilginize:

For the y and yy formats, years below 100 are handled in a special way when the y or yy symbol is used. If the year falls in the range 0 (inclusive) to 69 (inclusive), 2000 is added. If the year falls in the range 70 (inclusive) to 99 (inclusive) then 1900 is added. This means that "00-01-01" is interpreted as "2000-01-01".

Bilginize:

The "Day, month and two digit year, with dots or tabs" format (dd [.\t] mm "." yy) only works for the year values 61 (inclusive) to 99 (inclusive) - outside those years the time format "HH [.:] MM [.:] SS" has precedence.

Bilginize:

The "Year (and just the year)" format only works if a time string has already been found -- otherwise this format is recognised as HH MM.

Bilginize:

It is possible to over- and underflow the dd and DD format. Day 0 means the last day of previous month, whereas overflows count into the next month. This makes "2008-08-00" equivalent to "2008-07-31" and "2008-06-31" equivalent to "2008-07-01" (June only has 30 days).

Note that as of PHP 5.1.0 the day range is restricted to 0-31 as indicated by the regular expression above. Thus "2008-06-32" is not a valid date string, for instance.

It is also possible to underflow the mm and MM formats with the value 0. A month value of 0 means December of the previous year. As example "2008-00-22" is equivalent to "2007-12-22".

If you combine the previous two facts and underflow both the day and the month, the following happens: "2008-00-00" first gets converted to "2007-12-00" which then gets converted to "2007-11-30". This also happens with the string "0000-00-00", which gets transformed into "-0001-11-30" (the year -1 in the ISO 8601 calendar, which is 2 BC in the proleptic Gregorian calendar).

Time Formats
Compound Formats
Supported Date and Time Formats


Compound Formats

This page describes the different compound date/time formats that the strtotime(), DateTime and date_create() parser understands.

Used Symbols
Description | Formats | Examples
DD | "0" [0-9] | [1-2][0-9] | "3" [01] | "02", "12", "31"
doy | "00"[1-9] | "0"[1-9][0-9] | [1-2][0-9][0-9] | "3"[0-5][0-9] | "36"[0-6] | "001", "012", "180", "350", "366"
frac | . [0-9]+ | ".21342", ".85"
hh | "0"?[1-9] | "1"[0-2] | "04", "7", "12"
HH | [01][0-9] | "2"[0-4] | "04", "7", "19"
meridian | [AaPp] .? [Mm] .? [\0\t ] | "A.m.", "pM", "am."
ii | [0-5][0-9] | "04", "8", "59"
II | [0-5][0-9] | "04", "08", "59"
M | 'jan' | 'feb' | 'mar' | 'apr' | 'may' | 'jun' | 'jul' | 'aug' | 'sep' | 'sept' | 'oct' | 'nov' | 'dec' |
MM | [0-1][0-9] | "00", "12"
space | [ \t] |
ss | [0-5][0-9] | "04", "8", "59"
SS | [0-5][0-9] | "04", "08", "59"
W | "0"[1-9] | [1-4][0-9] | "5"[0-3] | "05", "17", "53"
tzcorrection | "GMT"? [+-] hh ":"? II? | "+0400", "GMT-07:00", "-07:00"
YY | [0-9]{4} | "2000", "2008", "1978"
Localized Notations
Description | Format | Examples
Common Log Format | dd "/" M "/" YY : HH ":" II ":" SS space tzcorrection | "10/Oct/2000:13:55:36 -0700"
EXIF | YY ":" MM ":" DD " " HH ":" II ":" SS | "2008:08:07 18:11:31"
ISO year with ISO week | YY "-"? "W" W | "2008W27", "2008-W28"
ISO year with ISO week and day | YY "-"? "W" W "-"? [0-7] | "2008W273", "2008-W28-3"
MySQL | YY "-" MM "-" DD " " HH ":" II ":" SS | "2008-08-07 18:11:31"
PostgreSQL: Year with day-of-year | YY "."? doy | "2008.197", "2008197"
SOAP | YY "-" MM "-" DD "T" HH ":" II ":" SS frac tzcorrection? | "2008-07-01T22:35:17.02", "2008-07-01T22:35:17.03+08:00"
Unix Timestamp | "@" "-"? [0-9]+ | "@1215282385"
XMLRPC | YY MM DD "T" hh ":" II ":" SS | "20080701T22:38:07", "20080701T9:38:07"
XMLRPC (Compact) | YY MM DD 't' hh II SS | "20080701t223807", "20080701T093807"
WDDX | YY "-" mm "-" dd "T" hh ":" ii ":" ss | "2008-7-1T9:3:37"

Bilginize:

The "W" in the "ISO year with ISO week" and "ISO year with ISO week and day" formats is case-sensitive, you can only use the upper case "W".

The "T" in the SOAP, XMRPC and WDDX formats is case-sensitive, you can only use the upper case "T".

The "Unix Timestamp" format sets the timezone to UTC.

Date Formats
Relative Formats
Supported Date and Time Formats


Relative Formats

This page describes the different relative date/time formats that the strtotime(), DateTime and date_create() parser understands.

Used Symbols
Description | Format
dayname | 'sunday' | 'monday' | 'tuesday' | 'wednesday' | 'thursday' | 'friday' | 'saturday' | 'sun' | 'mon' | 'tue' | 'wed' | 'thu' | 'fri' | 'sat'
daytext | 'weekday' | 'weekdays'
number | [+-]?[0-9]+
ordinal | 'first' | 'second' | 'third' | 'fourth' | 'fifth' | 'sixth' | 'seventh' | 'eighth' | 'ninth' | 'tenth' | 'eleventh' | 'twelfth' | 'next' | 'last' | 'previous' | 'this'
reltext | 'next' | 'last' | 'previous' | 'this'
space | [ \t]+
unit | (('sec' | 'second' | 'min' | 'minute' | 'hour' | 'day' | 'fortnight' | 'forthnight' | 'month' | 'year') 's'?) | 'weeks' | daytext
Day-based Notations
Format | Description | Examples
'yesterday' | Midnight of yesterday | "yesterday 14:00"
'midnight' | The time is set to 00:00:00 |
'today' | The time is set to 00:00:00 |
'now' | Now - this is simply ignored |
'noon' | The time is set to 12:00:00 | "yesterday noon"
'tomorrow' | Midnight of tomorrow |
'back of' hour | 15 minutes past the specified hour | "back of 7pm", "back of 15"
'front of' hour | 15 minutes before the specified hour | "front of 5am", "front of 23"
'first day of' | Sets the day of the first of the current month. This phrase is best used together with a month name following it. | "first day of January 2008"
'last day of' | Sets the day to the last day of the current month. This phrase is best used together with a month name following it. | "last day of next month"
ordinal space dayname space 'of' | Calculates the x-th week day of the current month. | "first sat of July 2008"
'last' space dayname space 'of' | Calculates the last week day of the current month. | "last sat of July 2008"
number space? (unit | 'week') | Handles relative time items where the value is a number. | "+5 weeks", "12 day", "-7 weekdays"
ordinal space unit | Handles relative time items where the value is text. | "fifth day", "second month"
'ago' | Negates all the values of previously found relative time items. | "2 days ago", "8 days ago 14:00", "2 months 5 days ago", "2 months ago 5 days", "2 days ago"
dayname | Moves to the next day of this name. | "Monday"
reltext space 'week' | Handles the special format "weekday + last/this/next week". | "Monday next week"

Bilginize:

Relative statements are always processed after non-relative statements. This makes "+1 week july 2008" and "july 2008 +1 week" equivalent.

Exceptions to this rule are: "yesterday", "midnight", "today", "noon" and "tomorrow". Note that "tomorrow 11:00" and "11:00 tomorrow" are different. Considering today's date of "July 23rd, 2008" the first one produces "2008-07-24 11:00" where as the second one produces "2008-07-24 00:00". The reason for this is that those five statements directly influence the current time.

Bilginize:

Observe the following remarks when the current day-of-week is the same as the day-of-week used in the date/time string. The current day-of-week could have been (re-)calculated by non-relative parts of the date/time string however.

  1. "dayname" does not advance to another day. (Example: "Wed July 23rd, 2008" means "2008-07-23").
  2. "number dayname" does not advance to another day. (Example: "1 wednesday july 23rd, 2008" means "2008-07-23").
  3. "number week dayname" will first add the number of weeks, but does not advance to another day. In this case "number week" and "dayname" are two distinct blocks. (Example: "+1 week wednesday july 23rd, 2008" means "2008-07-30").
  4. "ordinal dayname" does advance to another day. (Example "first wednesday july 23rd, 2008" means "2008-07-30").
  5. "number week ordinal dayname" will first add the number of weeks, and then advances to another day. In this case "number week" and "ordinal dayname" are two distinct blocks. (Example: "+1 week first wednesday july 23rd, 2008" means "2008-08-06").
  6. "ordinal dayname 'of' " does not advance to another day. (Example: "first wednesday of july 23rd, 2008" means "2008-07-02" because the specific phrase with 'of' resets the day-of-month to '1' and the '23rd' is ignored here).

Also observe that the "of" in "ordinal space dayname space 'of' " and "'last' space dayname space 'of' " does something special.

  1. It sets the day-of-month to 1.
  2. "ordinal dayname 'of' " does not advance to another day. (Example: "first tuesday of july 2008" means "2008-07-01").
  3. "ordinal dayname " does advance to another day. (Example: "first tuesday july 2008" means "2008-07-08", see also point 4 in the list above).
  4. "'last' dayname 'of' " takes the last dayname of the current month. (Example: "last wed of july 2008" means "2008-07-30")
  5. "'last' dayname" takes the last dayname from the current day. (Example: "last wed july 2008" means "2008-06-25"; "july 2008" first sets the current date to "2008-07-01" and then "last wed" moves to the previous Wednesday which is "2008-06-25").

Bilginize:

Relative month values are calculated based on the length of months that they pass through. An example would be "+2 month 2011-11-30", which would produce "2012-01-30". This is due to November being 30 days in length, and December being 31 days in length, producing a total of 61 days.

Sürüm Bilgisi

Sürüm: | Açıklama
5.6.23, 7.0.8 | Weeks always start on monday. Formerly, sunday would also be considered to start a week.
5.3.3 | "first day" and "last day" changed to behave has "+1 day" and "-1 day", respectively. Previously, the behaviour was as "first day of" and "last day of".

Compound Formats
DateTime
Supported Date and Time Formats


DateTime sınıfı

(PHP 5 >= 5.2.0, PHP 7)

Giriş

Tarih ve saat gösterimi.

Sınıf Sözdizimi

DateTime {
/* Sabitler */
const string ATOM = Y-m-d\TH:i:sP ;
const string COOKIE = l, d-M-y H:i:s T ;
const string ISO8601 = Y-m-d\TH:i:sO ;
const string RFC822 = D, d M y H:i:s O ;
const string RFC850 = l, d-M-y H:i:s T ;
const string RFC1036 = D, d M y H:i:s O ;
const string RFC1123 = D, d M Y H:i:s O ;
const string RFC2822 = D, d M Y H:i:s O ;
const string RFC3339 = Y-m-d\TH:i:sP ;
const string RSS = D, d M Y H:i:s O ;
const string W3C = Y-m-d\TH:i:sP ;
/* Yöntemler */
public __construct ([ string $time = "now" [, DateTimeZone $timezone = NULL ]] )
public DateTime add ( DateInterval $interval )
public static DateTime createFromFormat ( string $format , string $time [, DateTimeZone $timezone ] )
public static array getLastErrors ( void )
public DateTime modify ( string $modify )
public static DateTime __set_state ( array $array )
public DateTime setDate ( int $year , int $month , int $day )
public DateTime setISODate ( int $year , int $week [, int $day = 1 ] )
public DateTime setTime ( int $hour , int $minute [, int $second = 0 ] )
public DateTime setTimestamp ( int $unixtimestamp )
public DateTime setTimezone ( DateTimeZone $timezone )
public DateTime sub ( DateInterval $interval )
}

Öntanımlı Sabitler

DateTime Düğüm Türleri

DateTime::ATOM
DATE_ATOM
Atom (örnek: 2005-08-15T15:52:01+00:00)
DateTime::COOKIE
DATE_COOKIE
HTTP Çerezleri (örnek: Monday, 15-Aug-05 15:52:01 UTC)
DateTime::ISO8601
DATE_ISO8601
ISO-8601 (örnek: 2005-08-15T15:52:01+0000)
DateTime::RFC822
DATE_RFC822
RFC 822 (örnek: Mon, 15 Aug 05 15:52:01 +0000)
DateTime::RFC850
DATE_RFC850
RFC 850 (örnek: Monday, 15-Aug-05 15:52:01 UTC)
DateTime::RFC1036
DATE_RFC1036
RFC 1036 (örnek: Mon, 15 Aug 05 15:52:01 +0000)
DateTime::RFC1123
DATE_RFC1123
RFC 1123 (örnek: Mon, 15 Aug 2005 15:52:01 +0000)
DateTime::RFC2822
DATE_RFC2822
RFC 2822 (Mon, 15 Aug 2005 15:52:01 +0000)
DateTime::RFC3339
DATE_RFC3339
DATE_ATOM ile aynı (PHP 5.1.3'ten beri).
DateTime::RSS
DATE_RSS
RSS (Mon, 15 Aug 2005 15:52:01 +0000)
DateTime::W3C
DATE_W3C
World Wide Web Consortium (örnek: 2005-08-15T15:52:01+00:00)

İçindekiler

  • DateTime::add — Adds an amount of days, months, years, hours, minutes and seconds to a DateTime object
  • DateTime::__construct — Returns new DateTime object
  • DateTime::createFromFormat — Parses a time string according to a specified format
  • DateTime::getLastErrors — Returns the warnings and errors
  • DateTime::modify — Alters the timestamp
  • DateTime::__set_state — The __set_state handler
  • DateTime::setDate — Sets the date
  • DateTime::setISODate — Sets the ISO date
  • DateTime::setTime — Sets the time
  • DateTime::setTimestamp — Sets the date and time based on an Unix timestamp
  • DateTime::setTimezone — Sets the time zone for the DateTime object
  • DateTime::sub — Subtracts an amount of days, months, years, hours, minutes and seconds from a DateTime object
Relative Formats
DateTime::add
Tarih ve Zaman


Adds an amount of days, months, years, hours, minutes and seconds to a DateTime object

DateTime
DateTime::__construct
DateTime
PHP Manual

DateTime::add

date_add

(PHP 5 >= 5.3.0, PHP 7)

DateTime::add -- date_add — Adds an amount of days, months, years, hours, minutes and seconds to a DateTime object

Açıklama

Nesne yönelimli kullanım

public DateTime DateTime::add ( DateInterval $interval )

Yordamsal kullanım

DateTime date_add ( DateTime $object , DateInterval $interval )

Adds the specified DateInterval object to the specified DateTime object.

Değiştirgeler

nesne

Sadece yordamsal tarz: date_create() tarafından bir DateTime nesnesi döndürülür. İşlev bu nesnede değişiklik yapar.

interval

A DateInterval object

Dönen Değerler

Değişmiş DateTime nesnesinden başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 DateTime::add() example

Nesne yönelimli kullanım

<?php
$date = new DateTime('2000-01-01');
$date->add(new DateInterval('P10D'));
echo $date->format('Y-m-d') . "\n";
?>

Yordamsal kullanım

<?php
$date = date_create('2000-01-01');
date_add($date, date_interval_create_from_date_string('10 days'));
echo date_format($date, 'Y-m-d');
?>

Yukarıdaki örneklerin çıktısı:

2000-01-11

Örnek 2 Further DateTime::add() examples

<?php
$date = new DateTime('2000-01-01');
$date->add(new DateInterval('PT10H30S'));
echo $date->format('Y-m-d H:i:s') . "\n";

$date = new DateTime('2000-01-01');
$date->add(new DateInterval('P7Y5M4DT4H3M2S'));
echo $date->format('Y-m-d H:i:s') . "\n";
?>

Yukarıdaki örneğin çıktısı:

2000-01-01 10:00:30
2007-06-05 04:03:02

Örnek 3 Beware when adding months

<?php
$date = new DateTime('2000-12-31');
$interval = new DateInterval('P1M');

$date->add($interval);
echo $date->format('Y-m-d') . "\n";

$date->add($interval);
echo $date->format('Y-m-d') . "\n";
?>

Yukarıdaki örneğin çıktısı:

2001-01-31
2001-03-03

Notlar

DateTime::modify() is an alternative when using PHP 5.2.

Ayrıca Bakınız

  • DateTime::sub() - Subtracts an amount of days, months, years, hours, minutes and seconds from a DateTime object
  • DateTime::diff()
  • DateTime::modify() - Alters the timestamp
DateTime
DateTime::__construct
DateTime


Returns new DateTime object

DateTime::add
DateTime::createFromFormat
DateTime
PHP Manual

DateTime::__construct

date_create

(PHP 5 >= 5.2.0, PHP 7)

DateTime::__construct -- date_create — Returns new DateTime object

Açıklama

Nesne yönelimli kullanım

public DateTime::__construct ([ string $time = "now" [, DateTimeZone $timezone = NULL ]] )

Yordamsal kullanım

DateTime date_create ([ string $time = "now" [, DateTimeZone $timezone = NULL ]] )

Returns new DateTime object.

Değiştirgeler

time

Bir tarih/zaman dizgesi. Geçerli biçemler Tarih ve Zaman Biçemleri bölümünde açıklanmıştır.

Enter NULL here to obtain the current time when using the $timezone parameter.

timezone

A DateTimeZone object representing the timezone of $time.

If $timezone is omitted, the current timezone will be used.

Bilginize:

The $timezone parameter and the current timezone are ignored when the $time parameter either is a UNIX timestamp (e.g. @946684800) or specifies a timezone (e.g. 2010-01-28T15:00:00+02:00).

Dönen Değerler

Returns a new DateTime instance. Yordamsal kullanım başarısızlık durumunda FALSE döndürür.

Hatalar/İstisnalar

Emits Exception in case of an error.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | If time contains an invalid date/time format, then an exception is now thrown. Previously an error was emitted.

Örnekler

Örnek 1 DateTime::__construct() example

Nesne yönelimli kullanım

<?php
try {
    $date = new DateTime('2000-01-01');
} catch (Exception $e) {
    echo $e->getMessage();
    exit(1);
}

echo $date->format('Y-m-d');
?>

Yordamsal kullanım

<?php
$date = date_create('2000-01-01');
if (!$date) {
    $e = date_get_last_errors();
    foreach ($e['errors'] as $error) {
        echo "$error\n";
    }
    exit(1);
}

echo date_format($date, 'Y-m-d');
?>

Yukarıdaki örneklerin çıktısı:

2000-01-01

Örnek 2 Intricacies of DateTime::__construct()

<?php
// Specified date/time in your computer's time zone.
$date = new DateTime('2000-01-01');
echo $date->format('Y-m-d H:i:sP') . "\n";

// Specified date/time in the specified time zone.
$date = new DateTime('2000-01-01', new DateTimeZone('Pacific/Nauru'));
echo $date->format('Y-m-d H:i:sP') . "\n";

// Current date/time in your computer's time zone.
$date = new DateTime();
echo $date->format('Y-m-d H:i:sP') . "\n";

// Current date/time in the specified time zone.
$date = new DateTime(null, new DateTimeZone('Pacific/Nauru'));
echo $date->format('Y-m-d H:i:sP') . "\n";

// Using a UNIX timestamp.  Notice the result is in the UTC time zone.
$date = new DateTime('@946684800');
echo $date->format('Y-m-d H:i:sP') . "\n";

// Non-existent values roll over.
$date = new DateTime('2000-02-30');
echo $date->format('Y-m-d H:i:sP') . "\n";
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

2000-01-01 00:00:00-05:00
2000-01-01 00:00:00+12:00
2010-04-24 10:24:16-04:00
2010-04-25 02:24:16+12:00
2000-01-01 00:00:00+00:00
2000-03-01 00:00:00-05:00

Ayrıca Bakınız

  • DateTime::createFromFormat() - Parses a time string according to a specified format
  • DateTimeZone::__construct() - Yeni bir DateTimeZone nesnesi oluşturur
  • Date and Time Formats
  • date.timezone ini setting
  • date_default_timezone_set() - Betik içerisindeki tüm tarih/zaman işlevleri tarafından kullanılan öntanımlı zaman dilimini ayarlar
  • DateTime::getLastErrors() - Returns the warnings and errors
  • checkdate() - Miladi tarihi doğrular
DateTime::add
DateTime::createFromFormat
DateTime


Parses a time string according to a specified format

DateTime::__construct
DateTime::getLastErrors
DateTime
PHP Manual

DateTime::createFromFormat

date_create_from_format

(PHP 5 >= 5.3.0, PHP 7)

DateTime::createFromFormat -- date_create_from_format — Parses a time string according to a specified format

Açıklama

Nesne yönelimli kullanım

public static DateTime DateTime::createFromFormat ( string $format , string $time [, DateTimeZone $timezone ] )

Yordamsal kullanım

DateTime date_create_from_format ( string $format , string $time [, DateTimeZone $timezone ] )

Returns a new DateTime object representing the date and time specified by the time string, which was formatted in the given format.

Değiştirgeler

format

The format that the passed in string should be in. See the formatting options below. In most cases, the same letters as for the date() can be used.

The following characters are recognized in the format parameter string
format character | Description | Example parsable values
Day --- ---
d and j | Day of the month, 2 digits with or without leading zeros | 01 to 31 or 1 to 31
D and l | A textual representation of a day | Mon through Sun or Sunday through Saturday
S | English ordinal suffix for the day of the month, 2 characters. It's ignored while processing. | st, nd, rd or th.
z | The day of the year (starting from 0) | 0 through 365
Month --- ---
F and M | A textual representation of a month, such as January or Sept | January through December or Jan through Dec
m and n | Numeric representation of a month, with or without leading zeros | 01 through 12 or 1 through 12
Year --- ---
Y | A full numeric representation of a year, 4 digits | Examples: 1999 or 2003
y | A two digit representation of a year (which is assumed to be in the range 1970-2069, inclusive) | Examples: 99 or 03 (which will be interpreted as 1999 and 2003, respectively)
Time --- ---
a and A | Ante meridiem and Post meridiem | am or pm
g and h | 12-hour format of an hour with or without leading zero | 1 through 12 or 01 through 12
G and H | 24-hour format of an hour with or without leading zeros | 0 through 23 or 00 through 23
i | Minutes with leading zeros | 00 to 59
s | Seconds, with leading zeros | 00 through 59
u | Microseconds (up to six digits) | Example: 45, 654321
Timezone --- ---
e, O, P and T | Timezone identifier, or difference to UTC in hours, or difference to UTC with colon between hours and minutes, or timezone abbreviation | Examples: UTC, GMT, Atlantic/Azores or +0200 or +02:00 or EST, MDT
Full Date/Time --- ---
U | Seconds since the Unix Epoch (January 1 1970 00:00:00 GMT) | Example: 1292177455
Whitespace and Separators --- ---
(space) | One space or one tab | Example:
# One of the following separation symbol: ;, :, /, ., ,, -, ( or ) Example: /
;, :, /, ., ,, -, ( or ) | The specified character. | Example: -
? A random byte Example: ^ (Be aware that for UTF-8 characters you might need more than one ?. In this case, using * is probably what you want instead)
* Random bytes until the next separator or digit Example: * in Y-*-d with the string 2009-aWord-08 will match aWord
! Resets all fields (year, month, day, hour, minute, second, fraction and timzone information) to the Unix Epoch Without !, all fields will be set to the current date and time.
| Resets all fields (year, month, day, hour, minute, second, fraction and timzone information) to the Unix Epoch if they have not been parsed yet Y-m-d| will set the year, month and day to the information found in the string to parse, and sets the hour, minute and second to 0.
+ If this format specifier is present, trailing data in the string will not cause an error, but a warning instead Use DateTime::getLastErrors() to find out whether trailing data was present.

Unrecognized characters in the format string will cause the parsing to fail and an error message is appended to the returned structure. You can query error messages with DateTime::getLastErrors().

To include literal characters in format, you have to escape them with a backslash (\).

If format does not contain the character ! then portions of the generated time which are not specified in format will be set to the current system time.

If format contains the character !, then portions of the generated time not provided in format, as well as values to the left-hand side of the !, will be set to corresponding values from the Unix epoch.

The Unix epoch is 1970-01-01 00:00:00 UTC.

time

String representing the time.

timezone

A DateTimeZone object representing the desired time zone.

If timezone is omitted and time contains no timezone, the current timezone will be used.

Bilginize:

The timezone parameter and the current timezone are ignored when the time parameter either contains a UNIX timestamp (e.g. 946684800) or specifies a timezone (e.g. 2010-01-28T15:00:00+02:00).

Dönen Değerler

Returns a new DateTime instance başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.9 | The + format specifier has been added.

Örnekler

Örnek 1 DateTime::createFromFormat() example

Nesne yönelimli kullanım

<?php
$date = DateTime::createFromFormat('j-M-Y', '15-Feb-2009');
echo $date->format('Y-m-d');
?>

Yordamsal kullanım

<?php
$date = date_create_from_format('j-M-Y', '15-Feb-2009');
echo date_format($date, 'Y-m-d');
?>

Yukarıdaki örneklerin çıktısı:

2009-02-15

Örnek 2 Intricacies of DateTime::createFromFormat()

<?php
echo 'Current time: ' . date('Y-m-d H:i:s') . "\n";

$format = 'Y-m-d';
$date = DateTime::createFromFormat($format, '2009-02-15');
echo "Format: $format; " . $date->format('Y-m-d H:i:s') . "\n";

$format = 'Y-m-d H:i:s';
$date = DateTime::createFromFormat($format, '2009-02-15 15:16:17');
echo "Format: $format; " . $date->format('Y-m-d H:i:s') . "\n";

$format = 'Y-m-!d H:i:s';
$date = DateTime::createFromFormat($format, '2009-02-15 15:16:17');
echo "Format: $format; " . $date->format('Y-m-d H:i:s') . "\n";

$format = '!d';
$date = DateTime::createFromFormat($format, '15');
echo "Format: $format; " . $date->format('Y-m-d H:i:s') . "\n";
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Current time: 2010-04-23 10:29:35
Format: Y-m-d; 2009-02-15 10:29:35
Format: Y-m-d H:i:s; 2009-02-15 15:16:17
Format: Y-m-!d H:i:s; 1970-01-15 15:16:17
Format: !d; 1970-01-15 00:00:00

Örnek 3 Format string with literal characters

<?php
echo DateTime::createFromFormat('H\h i\m s\s','23h 15m 03s')->format('H:i:s');
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

23:15:03

Ayrıca Bakınız

  • DateTime::__construct() - Returns new DateTime object
  • DateTime::getLastErrors() - Returns the warnings and errors
  • checkdate() - Miladi tarihi doğrular
  • strptime() - strftime işleviyle üretilen zaman ve tarihleri çözümler
DateTime::__construct
DateTime::getLastErrors
DateTime


Returns the warnings and errors

DateTime::createFromFormat
DateTime::modify
DateTime
PHP Manual

DateTime::getLastErrors

date_get_last_errors

(PHP 5 >= 5.3.0, PHP 7)

DateTime::getLastErrors -- date_get_last_errors — Returns the warnings and errors

Açıklama

Nesne yönelimli kullanım

public static array DateTime::getLastErrors ( void )

Yordamsal kullanım

array date_get_last_errors ( void )

Returns an array of warnings and errors found while parsing a date/time string.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns array containing info about warnings and errors.

Örnekler

Örnek 1 DateTime::getLastErrors() example

Nesne yönelimli kullanım

<?php
try {
    $date = new DateTime('asdfasdf');
} catch (Exception $e) {
    // For demonstration purposes only...
    print_r(DateTime::getLastErrors());

    // The real object oriented way to do this is
    // echo $e->getMessage();
}
?>

Yordamsal kullanım

<?php
$date = date_create('asdfasdf');
print_r(date_get_last_errors());
?>

Yukarıdaki örneklerin çıktısı:

Array
(
   [warning_count] => 1
   [warnings] => Array
       (
           [6] => Double timezone specification
       )

   [error_count] => 1
   [errors] => Array
       (
           [0] => The timezone could not be found in the database
       )

)

The indexes 6, and 0 in the example output refer to the character index in the string where the error occurred.

DateTime::createFromFormat
DateTime::modify
DateTime


Alters the timestamp

DateTime::getLastErrors
DateTime::__set_state
DateTime
PHP Manual

DateTime::modify

date_modify

(PHP 5 >= 5.2.0, PHP 7)

DateTime::modify -- date_modify — Alters the timestamp

Açıklama

Nesne yönelimli kullanım

public DateTime DateTime::modify ( string $modify )

Yordamsal kullanım

DateTime date_modify ( DateTime $object , string $modify )

Alter the timestamp of a DateTime object by incrementing or decrementing in a format accepted by strtotime().

Değiştirgeler

nesne

Sadece yordamsal tarz: date_create() tarafından bir DateTime nesnesi döndürülür. İşlev bu nesnede değişiklik yapar.

modify

Bir tarih/zaman dizgesi. Geçerli biçemler Tarih ve Zaman Biçemleri bölümünde açıklanmıştır.

Dönen Değerler

Değişmiş DateTime nesnesinden başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.6 | Absolute date/time statements now take effect. Previously, only relative parts were used.
5.3.0 | Başarı durumunda dönen değer artık NULL değil, DateTime oldu.

Örnekler

Örnek 1 DateTime::modify() example

Nesne yönelimli kullanım

<?php
$date = new DateTime('2006-12-12');
$date->modify('+1 day');
echo $date->format('Y-m-d');
?>

Yordamsal kullanım

<?php
$date = date_create('2006-12-12');
date_modify($date, '+1 day');
echo date_format($date, 'Y-m-d');
?>

Yukarıdaki örneklerin çıktısı:

2006-12-13

Örnek 2 Beware when adding or subtracting months

<?php
$date = new DateTime('2000-12-31');

$date->modify('+1 month');
echo $date->format('Y-m-d') . "\n";

$date->modify('+1 month');
echo $date->format('Y-m-d') . "\n";
?>

Yukarıdaki örneğin çıktısı:

2001-01-31
2001-03-03

Ayrıca Bakınız

  • strtotime() - Parse about any English textual datetime description into a Unix timestamp
  • DateTime::add() - Adds an amount of days, months, years, hours, minutes and seconds to a DateTime object
  • DateTime::sub() - Subtracts an amount of days, months, years, hours, minutes and seconds from a DateTime object
  • DateTime::setDate() - Sets the date
  • DateTime::setISODate() - Sets the ISO date
  • DateTime::setTime() - Sets the time
  • DateTime::setTimestamp() - Sets the date and time based on an Unix timestamp
DateTime::getLastErrors
DateTime::__set_state
DateTime


The __set_state handler

DateTime::modify
DateTime::setDate
DateTime
PHP Manual

DateTime::__set_state

(PHP 5 >= 5.2.0, PHP 7)

DateTime::__set_state — The __set_state handler

Açıklama

public static DateTime DateTime::__set_state ( array $array )

The __set_state() handler.

Değiştirgeler

array

Initialization array.

Dönen Değerler

Returns a new instance of a DateTime object.

DateTime::modify
DateTime::setDate
DateTime


Sets the date

DateTime::__set_state
DateTime::setISODate
DateTime
PHP Manual

DateTime::setDate

date_date_set

(PHP 5 >= 5.2.0, PHP 7)

DateTime::setDate -- date_date_set — Sets the date

Açıklama

Nesne yönelimli kullanım

public DateTime DateTime::setDate ( int $year , int $month , int $day )

Yordamsal kullanım

DateTime date_date_set ( DateTime $object , int $year , int $month , int $day )

Resets the current date of the DateTime object to a different date.

Değiştirgeler

nesne

Sadece yordamsal tarz: date_create() tarafından bir DateTime nesnesi döndürülür. İşlev bu nesnede değişiklik yapar.

year

Year of the date.

month

Month of the date.

day

Day of the date.

Dönen Değerler

Değişmiş DateTime nesnesinden başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | Başarı durumunda dönen değer artık NULL değil, DateTime oldu.

Örnekler

Örnek 1 DateTime::setDate() example

Nesne yönelimli kullanım

<?php
$date = new DateTime();
$date->setDate(2001, 2, 3);
echo $date->format('Y-m-d');
?>

Yordamsal kullanım

<?php
$date = date_create();
date_date_set($date, 2001, 2, 3);
echo date_format($date, 'Y-m-d');
?>

Yukarıdaki örneklerin çıktısı:

2001-02-03

Örnek 2 Values exceeding ranges are added to their parent values

<?php
$date = new DateTime();

$date->setDate(2001, 2, 28);
echo $date->format('Y-m-d') . "\n";

$date->setDate(2001, 2, 29);
echo $date->format('Y-m-d') . "\n";

$date->setDate(2001, 14, 3);
echo $date->format('Y-m-d') . "\n";
?>

Yukarıdaki örneğin çıktısı:

2001-02-28
2001-03-01
2002-02-03

Ayrıca Bakınız

  • DateTime::setISODate() - Sets the ISO date
  • DateTime::setTime() - Sets the time
DateTime::__set_state
DateTime::setISODate
DateTime


Sets the ISO date

DateTime::setDate
DateTime::setTime
DateTime
PHP Manual

DateTime::setISODate

date_isodate_set

(PHP 5 >= 5.2.0, PHP 7)

DateTime::setISODate -- date_isodate_set — Sets the ISO date

Açıklama

Nesne yönelimli kullanım

public DateTime DateTime::setISODate ( int $year , int $week [, int $day = 1 ] )

Yordamsal kullanım

DateTime date_isodate_set ( DateTime $object , int $year , int $week [, int $day = 1 ] )

Set a date according to the ISO 8601 standard - using weeks and day offsets rather than specific dates.

Değiştirgeler

nesne

Sadece yordamsal tarz: date_create() tarafından bir DateTime nesnesi döndürülür. İşlev bu nesnede değişiklik yapar.

year

Year of the date.

week

Week of the date.

day

Offset from the first day of the week.

Dönen Değerler

Değişmiş DateTime nesnesinden başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | Başarı durumunda dönen değer artık NULL değil, DateTime oldu.

Örnekler

Örnek 1 DateTime::setISODate() example

Nesne yönelimli kullanım

<?php
$date = new DateTime();

$date->setISODate(2008, 2);
echo $date->format('Y-m-d') . "\n";

$date->setISODate(2008, 2, 7);
echo $date->format('Y-m-d') . "\n";
?>

Yordamsal kullanım

<?php
$date = date_create();

date_isodate_set($date, 2008, 2);
echo date_format($date, 'Y-m-d') . "\n";

date_isodate_set($date, 2008, 2, 7);
echo date_format($date, 'Y-m-d') . "\n";
?>

Yukarıdaki örneklerin çıktısı:

2008-01-07
2008-01-13

Örnek 2 Values exceeding ranges are added to their parent values

<?php
$date = new DateTime();

$date->setISODate(2008, 2, 7);
echo $date->format('Y-m-d') . "\n";

$date->setISODate(2008, 2, 8);
echo $date->format('Y-m-d') . "\n";

$date->setISODate(2008, 53, 7);
echo $date->format('Y-m-d') . "\n";
?>

Yukarıdaki örneğin çıktısı:

2008-01-13
2008-01-14
2009-01-04

Örnek 3 Finding the month a week is in

<?php
$date = new DateTime();
$date->setISODate(2008, 14);
echo $date->format('n');
?>

Yukarıdaki örneklerin çıktısı:

3

Ayrıca Bakınız

  • DateTime::setDate() - Sets the date
  • DateTime::setTime() - Sets the time
DateTime::setDate
DateTime::setTime
DateTime


Sets the time

DateTime::setISODate
DateTime::setTimestamp
DateTime
PHP Manual

DateTime::setTime

date_time_set

(PHP 5 >= 5.2.0, PHP 7)

DateTime::setTime -- date_time_set — Sets the time

Açıklama

Nesne yönelimli kullanım

public DateTime DateTime::setTime ( int $hour , int $minute [, int $second = 0 ] )

Yordamsal kullanım

DateTime date_time_set ( DateTime $object , int $hour , int $minute [, int $second = 0 ] )

Resets the current time of the DateTime object to a different time.

Değiştirgeler

nesne

Sadece yordamsal tarz: date_create() tarafından bir DateTime nesnesi döndürülür. İşlev bu nesnede değişiklik yapar.

hour

Hour of the time.

minute

Minute of the time.

second

Second of the time.

Dönen Değerler

Değişmiş DateTime nesnesinden başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | Başarı durumunda dönen değer artık NULL değil, DateTime oldu.

Örnekler

Örnek 1 DateTime::setTime() example

Nesne yönelimli kullanım

<?php
$date = new DateTime('2001-01-01');

$date->setTime(14, 55);
echo $date->format('Y-m-d H:i:s') . "\n";

$date->setTime(14, 55, 24);
echo $date->format('Y-m-d H:i:s') . "\n";
?>

Yordamsal kullanım

<?php
$date = date_create('2001-01-01');

date_time_set($date, 14, 55);
echo date_format($date, 'Y-m-d H:i:s') . "\n";

date_time_set($date, 14, 55, 24);
echo date_format($date, 'Y-m-d H:i:s') . "\n";
?>

The above examples will output something similar to:

2001-01-01 14:55:00
2001-01-01 14:55:24

Örnek 2 Values exceeding ranges are added to their parent values

<?php
$date = new DateTime('2001-01-01');

$date->setTime(14, 55, 24);
echo $date->format('Y-m-d H:i:s') . "\n";

$date->setTime(14, 55, 65);
echo $date->format('Y-m-d H:i:s') . "\n";

$date->setTime(14, 65, 24);
echo $date->format('Y-m-d H:i:s') . "\n";

$date->setTime(25, 55, 24);
echo $date->format('Y-m-d H:i:s') . "\n";
?>

Yukarıdaki örneğin çıktısı:

2001-01-01 14:55:24
2001-01-01 14:56:05
2001-01-01 15:05:24
2001-01-02 01:55:24

Ayrıca Bakınız

  • DateTime::setDate() - Sets the date
  • DateTime::setISODate() - Sets the ISO date
DateTime::setISODate
DateTime::setTimestamp
DateTime


Sets the date and time based on an Unix timestamp

DateTime::setTime
DateTime::setTimezone
DateTime
PHP Manual

DateTime::setTimestamp

date_timestamp_set

(PHP 5 >= 5.3.0, PHP 7)

DateTime::setTimestamp -- date_timestamp_set — Sets the date and time based on an Unix timestamp

Açıklama

Nesne yönelimli kullanım

public DateTime DateTime::setTimestamp ( int $unixtimestamp )

Yordamsal kullanım

DateTime date_timestamp_set ( DateTime $object , int $unixtimestamp )

Sets the date and time based on an Unix timestamp.

Değiştirgeler

nesne

Sadece yordamsal tarz: date_create() tarafından bir DateTime nesnesi döndürülür. İşlev bu nesnede değişiklik yapar.

unixtimestamp

Unix timestamp representing the date.

Dönen Değerler

Değişmiş DateTime nesnesinden başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 DateTime::setTimestamp() example

Nesne yönelimli kullanım

<?php
$date = new DateTime();
echo $date->format('U = Y-m-d H:i:s') . "\n";

$date->setTimestamp(1171502725);
echo $date->format('U = Y-m-d H:i:s') . "\n";
?>

Yordamsal kullanım

<?php
$date = date_create();
echo date_format($date, 'U = Y-m-d H:i:s') . "\n";

date_timestamp_set($date, 1171502725);
echo date_format($date, 'U = Y-m-d H:i:s') . "\n";
?>

The above examples will output something similar to:

1272508903 = 2010-04-28 22:41:43
1171502725 = 2007-02-14 20:25:25

Notlar

Using the Unix timestamp format to construct a new DateTime object is an alternative when using PHP 5.2, as shown in the example below.

Örnek 2 DateTime::setTimestamp() alternative in PHP 5.2

<?php
$ts = 1171502725;
$date = new DateTime("@$ts");
echo $date->format('U = Y-m-d H:i:s') . "\n";
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

1171502725 = 2007-02-14 20:25:25

Ayrıca Bakınız

  • DateTime::getTimestamp()
DateTime::setTime
DateTime::setTimezone
DateTime


Sets the time zone for the DateTime object

DateTime::setTimestamp
DateTime::sub
DateTime
PHP Manual

DateTime::setTimezone

date_timezone_set

(PHP 5 >= 5.2.0, PHP 7)

DateTime::setTimezone -- date_timezone_set — Sets the time zone for the DateTime object

Açıklama

Nesne yönelimli kullanım

public DateTime DateTime::setTimezone ( DateTimeZone $timezone )

Yordamsal kullanım

DateTime date_timezone_set ( DateTime $object , DateTimeZone $timezone )

Sets a new timezone for a DateTime object.

Değiştirgeler

nesne

Sadece yordamsal tarz: date_create() tarafından bir DateTime nesnesi döndürülür. İşlev bu nesnede değişiklik yapar.

timezone

A DateTimeZone object representing the desired time zone.

Dönen Değerler

Değişmiş DateTime nesnesinden başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | Başarı durumunda dönen değer artık NULL değil, DateTime oldu.

Örnekler

Örnek 1 DateTime::setTimeZone() example

Nesne yönelimli kullanım

<?php
$date = new DateTime('2000-01-01', new DateTimeZone('Pacific/Nauru'));
echo $date->format('Y-m-d H:i:sP') . "\n";

$date->setTimezone(new DateTimeZone('Pacific/Chatham'));
echo $date->format('Y-m-d H:i:sP') . "\n";
?>

Yordamsal kullanım

<?php
$date = date_create('2000-01-01', timezone_open('Pacific/Nauru'));
echo date_format($date, 'Y-m-d H:i:sP') . "\n";

date_timezone_set($date, timezone_open('Pacific/Chatham'));
echo date_format($date, 'Y-m-d H:i:sP') . "\n";
?>

Yukarıdaki örneklerin çıktısı:

2000-01-01 00:00:00+12:00
2000-01-01 01:45:00+13:45

Ayrıca Bakınız

  • DateTime::getTimezone()
  • DateTimeZone::__construct() - Yeni bir DateTimeZone nesnesi oluşturur
DateTime::setTimestamp
DateTime::sub
DateTime


Subtracts an amount of days, months, years, hours, minutes and seconds from a DateTime object

DateTime::setTimezone
DateTimeZone
DateTime
PHP Manual

DateTime::sub

date_sub

(PHP 5 >= 5.3.0, PHP 7)

DateTime::sub -- date_sub — Subtracts an amount of days, months, years, hours, minutes and seconds from a DateTime object

Açıklama

Nesne yönelimli kullanım

public DateTime DateTime::sub ( DateInterval $interval )

Yordamsal kullanım

DateTime date_sub ( DateTime $object , DateInterval $interval )

Subtracts the specified DateInterval object from the specified DateTime object.

Değiştirgeler

nesne

Sadece yordamsal tarz: date_create() tarafından bir DateTime nesnesi döndürülür. İşlev bu nesnede değişiklik yapar.

interval

A DateInterval object

Dönen Değerler

Değişmiş DateTime nesnesinden başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 DateTime::sub() example

Nesne yönelimli kullanım

<?php
$date = new DateTime('2000-01-20');
$date->sub(new DateInterval('P10D'));
echo $date->format('Y-m-d') . "\n";
?>

Yordamsal kullanım

<?php
$date = date_create('2000-01-20');
date_sub($date, date_interval_create_from_date_string('10 days'));
echo date_format($date, 'Y-m-d');
?>

Yukarıdaki örneklerin çıktısı:

2000-01-10

Örnek 2 Further DateTime::sub() examples

<?php
$date = new DateTime('2000-01-20');
$date->sub(new DateInterval('PT10H30S'));
echo $date->format('Y-m-d H:i:s') . "\n";

$date = new DateTime('2000-01-20');
$date->sub(new DateInterval('P7Y5M4DT4H3M2S'));
echo $date->format('Y-m-d H:i:s') . "\n";
?>

Yukarıdaki örneğin çıktısı:

2000-01-19 13:59:30
1992-08-15 19:56:58

Örnek 3 Beware when subtracting months

<?php
$date = new DateTime('2001-04-30');
$interval = new DateInterval('P1M');

$date->sub($interval);
echo $date->format('Y-m-d') . "\n";

$date->sub($interval);
echo $date->format('Y-m-d') . "\n";
?>

Yukarıdaki örneğin çıktısı:

2001-03-30
2001-03-02

Notlar

DateTime::modify() is an alternative when using PHP 5.2.

Ayrıca Bakınız

  • DateTime::add() - Adds an amount of days, months, years, hours, minutes and seconds to a DateTime object
  • DateTime::diff()
  • DateTime::modify() - Alters the timestamp
DateTime::setTimezone
DateTimeZone
DateTime


DateTimeZone sınıfı

(PHP 5 >= 5.2.0, PHP 7)

Giriş

Zaman dilimi gösterimi.

Sınıf Sözdizimi

DateTimeZone {
/* Sabitler */
const integer AFRICA = 1 ;
const integer AMERICA = 2 ;
const integer ANTARCTICA = 4 ;
const integer ARCTIC = 8 ;
const integer ASIA = 16 ;
const integer ATLANTIC = 32 ;
const integer AUSTRALIA = 64 ;
const integer EUROPE = 128 ;
const integer INDIAN = 256 ;
const integer PACIFIC = 512 ;
const integer UTC = 1024 ;
const integer ALL = 2047 ;
const integer ALL_WITH_BC = 4095 ;
const integer PER_COUNTRY = 4096 ;
/* Yöntemler */
public __construct ( string $zamandilimi )
public array getLocation ( void )
public string getName ( void )
public int getOffset ( DateTime $datetime )
public array getTransitions ([ int $timestamp_begin [, int $timestamp_end ]] )
public static array listAbbreviations ( void )
public static array listIdentifiers ([ int $what = DateTimeZone::ALL [, string $country = NULL ]] )
}

Öntanımlı Sabitler

DateTimeZone Düğüm Türleri

DateTimeZone::AFRICA

Afrika zaman dilimleri.

DateTimeZone::AMERICA

Amerika zaman dilimleri.

DateTimeZone::ANTARCTICA

Antarktika zaman dilimleri.

DateTimeZone::ARCTIC

Kuzey Kutup Dairesi zaman dilimleri.

DateTimeZone::ASIA

Asya zaman dilimleri.

DateTimeZone::ATLANTIC

Atlantik zaman dilimleri.

DateTimeZone::AUSTRALIA

Avustralya zaman dilimleri.

DateTimeZone::EUROPE

Avrupa zaman dilimleri.

DateTimeZone::INDIAN

Hindistan zaman dilimleri.

DateTimeZone::PACIFIC

Pasifik zaman dilimleri.

DateTimeZone::UTC

UTC zaman dilimleri.

DateTimeZone::ALL

Tüm zaman dilimleri.

DateTimeZone::ALL_WITH_BC

Geriye uyumluluk dahil tüm zaman dilimleri.

DateTimeZone::PER_COUNTRY

Ülkelere göre zaman dilimleri.

İçindekiler

  • DateTimeZone::__construct — Yeni bir DateTimeZone nesnesi oluşturur
  • DateTimeZone::getLocation — Zaman dilimi konum bilgisini döndürür
  • DateTimeZone::getName — Zaman diliminin adını döndürür
  • DateTimeZone::getOffset — Returns the timezone offset from GMT
  • DateTimeZone::getTransitions — Returns all transitions for the timezone
  • DateTimeZone::listAbbreviations — Returns associative array containing dst, offset and the timezone name
  • DateTimeZone::listIdentifiers — Returns a numerically indexed array containing all defined timezone identifiers
DateTime::sub
DateTimeZone::__construct
Tarih ve Zaman


Yeni bir DateTimeZone nesnesi oluşturur

DateTimeZone
DateTimeZone::getLocation
DateTimeZone
PHP Manual

DateTimeZone::__construct

(PHP 5 >= 5.2.0, PHP 7)

DateTimeZone::__construct — Yeni bir DateTimeZone nesnesi oluşturur

Açıklama

Nesne yönelimli kullanım

public DateTimeZone::__construct ( string $zamandilimi )

Yordamsal kullanım

DateTimeZone timezone_open ( string $zamandilimi )

Yeni bir DateTimeZone nesnesi oluşturur.

Değiştirgeler

zamandilimi

Tanımlı zaman dilimlerinden biri.

Dönen Değerler

Başarılı olduğunda yeni bir DateTimeZone nesnesi döndürür. Yordamsal kullanım başarısızlık durumunda FALSE döndürür.

Hatalar/İstisnalar

Eğer zaman dilimi geçerli bir zaman dilimi değilse bu işlev bir Exception istisnası oluşturur.

Örnekler

Örnek 1 - DateTimeZone örneklenirken hataların yakalanması

<?php
// Yakalanan istisna nesneleriyle hata işlenmesine örnek
$zamandilimleri = array('Europe/Istanbul', 'Mars/Phobos', 'Jupiter/Europa');

foreach ($zamandilimleri as $zd) {
    try {
        $mars = new DateTimeZone($zd);
    } catch(Exception $e) {
        echo $e->getMessage() . '<br />';
    }
}
?>

Yukarıdaki örneğin çıktısı:

DateTimeZone::__construct() [datetimezone.--construct]: Unknown or bad timezone (Mars/Phobos)
DateTimeZone::__construct() [datetimezone.--construct]: Unknown or bad timezone (Jupiter/Europa)

DateTimeZone
DateTimeZone::getLocation
DateTimeZone


Zaman dilimi konum bilgisini döndürür

DateTimeZone::__construct
DateTimeZone::getName
DateTimeZone
PHP Manual

DateTimeZone::getLocation

(PHP 5 >= 5.3.0, PHP 7)

DateTimeZone::getLocation — Zaman dilimi konum bilgisini döndürür

Açıklama

Nesne yönelimli kullanım

public array DateTimeZone::getLocation ( void )

Yordamsal kullanım

array timezone_location_get ( void )

Zaman dilimi için konum bilgisini; ülke kodu, enlem/boylam değerlerini ve yorumları döndürür.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Zaman dilimi hakkında konum bilgisini içeren bir dizi.

Örnekler

Örnek 1 - DateTimeZone::getLocation() örneği

<?php
$tz = new DateTimeZone("Europe/Prague");
print_r($tz->getLocation());
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [country_code] => CZ
    [latitude] => 50.08333
    [longitude] => 14.43333
    [comments] =>
)

DateTimeZone::__construct
DateTimeZone::getName
DateTimeZone


Zaman diliminin adını döndürür

DateTimeZone::getLocation
DateTimeZone::getOffset
DateTimeZone
PHP Manual

DateTimeZone::getName

(PHP 5 >= 5.2.0, PHP 7)

DateTimeZone::getName — Zaman diliminin adını döndürür

Açıklama

Nesne yönelimli kullanım

public string DateTimeZone::getName ( void )

Yordamsal kullanım

string timezone_name_get ( void )

Zaman diliminin adını döndürür.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Tanımlı zaman dilimlerinden biri.

DateTimeZone::getLocation
DateTimeZone::getOffset
DateTimeZone


Returns the timezone offset from GMT

DateTimeZone::getName
DateTimeZone::getTransitions
DateTimeZone
PHP Manual

DateTimeZone::getOffset

timezone_offset_get

(PHP 5 >= 5.2.0, PHP 7)

DateTimeZone::getOffset -- timezone_offset_get — Returns the timezone offset from GMT

Açıklama

Nesne yönelimli kullanım

public int DateTimeZone::getOffset ( DateTime $datetime )

Yordamsal kullanım

int timezone_offset_get ( DateTimeZone $object , DateTime $datetime )

This function returns the offset to GMT for the date/time specified in the datetime parameter. The GMT offset is calculated with the timezone information contained in the DateTimeZone object being used.

Değiştirgeler

nesne

Sadece yordamsal biçem: timezone_open() işlevinden dönen bir DateTimeZone nesnesi.

datetime

DateTime that contains the date/time to compute the offset from.

Dönen Değerler

Returns time zone offset in seconds on success başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 DateTimeZone::getOffset() examples

<?php
// Create two timezone objects, one for Taipei (Taiwan) and one for
// Tokyo (Japan)
$dateTimeZoneTaipei = new DateTimeZone("Asia/Taipei");
$dateTimeZoneJapan = new DateTimeZone("Asia/Tokyo");

// Create two DateTime objects that will contain the same Unix timestamp, but
// have different timezones attached to them.
$dateTimeTaipei = new DateTime("now", $dateTimeZoneTaipei);
$dateTimeJapan = new DateTime("now", $dateTimeZoneJapan);

// Calculate the GMT offset for the date/time contained in the $dateTimeTaipei
// object, but using the timezone rules as defined for Tokyo
// ($dateTimeZoneJapan).
$timeOffset = $dateTimeZoneJapan->getOffset($dateTimeTaipei);

// Should show int(32400) (for dates after Sat Sep 8 01:00:00 1951 JST).
var_dump($timeOffset);
?>

DateTimeZone::getName
DateTimeZone::getTransitions
DateTimeZone


Returns all transitions for the timezone

DateTimeZone::getOffset
DateTimeZone::listAbbreviations
DateTimeZone
PHP Manual

DateTimeZone::getTransitions

timezone_transitions_get

(PHP 5 >= 5.2.0, PHP 7)

DateTimeZone::getTransitions -- timezone_transitions_get — Returns all transitions for the timezone

Açıklama

Nesne yönelimli kullanım

public array DateTimeZone::getTransitions ([ int $timestamp_begin [, int $timestamp_end ]] )

Yordamsal kullanım

array timezone_transitions_get ( DateTimeZone $object [, int $timestamp_begin [, int $timestamp_end ]] )

Değiştirgeler

nesne

Sadece yordamsal biçem: timezone_open() işlevinden dönen bir DateTimeZone nesnesi.

timestamp_begin

Begin timestamp.

timestamp_end

End timestamp.

Dönen Değerler

Returns numerically indexed array containing associative array with all transitions on success başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | The optional timestamp_begin and timestamp_end were added.

Örnekler

Örnek 1 A timezone_transitions_get() example

<?php
$timezone = new DateTimeZone("Europe/London");
$transitions = $timezone->getTransitions();
print_r(array_slice($transitions, 0, 3));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [0] => Array
        (
            [ts] => -9223372036854775808
            [time] => -292277022657-01-27T08:29:52+0000
            [offset] => 3600
            [isdst] => 1
            [abbr] => BST
        )

    [1] => Array
        (
            [ts] => -1691964000
            [time] => 1916-05-21T02:00:00+0000
            [offset] => 3600
            [isdst] => 1
            [abbr] => BST
        )

    [2] => Array
        (
            [ts] => -1680472800
            [time] => 1916-10-01T02:00:00+0000
            [offset] => 0
            [isdst] =>
            [abbr] => GMT
        )

)

DateTimeZone::getOffset
DateTimeZone::listAbbreviations
DateTimeZone


Returns associative array containing dst, offset and the timezone name

DateTimeZone::getTransitions
DateTimeZone::listIdentifiers
DateTimeZone
PHP Manual

DateTimeZone::listAbbreviations

timezone_abbreviations_list

(PHP 5 >= 5.2.0, PHP 7)

DateTimeZone::listAbbreviations -- timezone_abbreviations_list — Returns associative array containing dst, offset and the timezone name

Açıklama

Nesne yönelimli kullanım

public static array DateTimeZone::listAbbreviations ( void )

Yordamsal kullanım

array timezone_abbreviations_list ( void )

Dönen Değerler

Returns array on success başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 A timezone_abbreviations_list() example

<?php
$timezone_abbreviations = DateTimeZone::listAbbreviations();
print_r($timezone_abbreviations["acst"]);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [0] => Array
        (
            [dst] => 1
            [offset] => -14400
            [timezone_id] => America/Porto_Acre
        )

    [1] => Array
        (
            [dst] => 1
            [offset] => -14400
            [timezone_id] => America/Eirunepe
        )

    [2] => Array
        (
            [dst] => 1
            [offset] => -14400
            [timezone_id] => America/Rio_Branco
        )

    [3] => Array
        (
            [dst] => 1
            [offset] => -14400
            [timezone_id] => Brazil/Acre
        )

)

Ayrıca Bakınız

  • timezone_identifiers_list() - DateTimeZone::listIdentifiers işlevinin takma adıdır

DateTimeZone::getTransitions
DateTimeZone::listIdentifiers
DateTimeZone


Returns a numerically indexed array containing all defined timezone identifiers

DateTimeZone::listAbbreviations
DateInterval
DateTimeZone
PHP Manual

DateTimeZone::listIdentifiers

timezone_identifiers_list

(PHP 5 >= 5.2.0, PHP 7)

DateTimeZone::listIdentifiers -- timezone_identifiers_list — Returns a numerically indexed array containing all defined timezone identifiers

Açıklama

Nesne yönelimli kullanım

public static array DateTimeZone::listIdentifiers ([ int $what = DateTimeZone::ALL [, string $country = NULL ]] )

Yordamsal kullanım

array timezone_identifiers_list ([ int $what = DateTimeZone::ALL [, string $country = NULL ]] )

Değiştirgeler

what

One of DateTimeZone class constants.

country

A two-letter ISO 3166-1 compatible country code.

Bilginize: This option is only used when what is set to DateTimeZone::PER_COUNTRY.

Dönen Değerler

Returns array on success başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | Added the optional what and country parameters.

Örnekler

Örnek 1 A timezone_identifiers_list() example

<?php
$timezone_identifiers = DateTimeZone::listIdentifiers();
for ($i=0; $i < 5; $i++) {
    echo "$timezone_identifiers[$i]\n";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Africa/Abidjan
Africa/Accra
Africa/Addis_Ababa
Africa/Algiers
Africa/Asmara

Ayrıca Bakınız

  • timezone_abbreviations_list() - DateTimeZone::listAbbreviations işlevinin takma adıdır

DateTimeZone::listAbbreviations
DateInterval
DateTimeZone


DateInterval sınıfı

(PHP 5 >= 5.3.0, PHP 7)

Giriş

Tarih aralığının gösterimi. Ya sabit bir süre (yıl, ay, gün saat sayısı gibi) ya da DateTime kurucusunun desteklediği biçemde göreli bir zaman dizgesi saklanır.

Sınıf Sözdizimi

DateInterval {
/* Yöntemler */
public __construct ( string $zaman_aralığı )
public static DateInterval createFromDateString ( string $zaman )
public string format ( string $biçem )
}

İçindekiler

  • DateInterval::__construct — Yeni bir DateInterval nesnesi oluşturur
  • DateInterval::createFromDateString — Dizgenin göreli kısımlarından bir DateInterval nesnesi döndürür
  • DateInterval::format — Zaman aralığını biçimler
DateTimeZone::listIdentifiers
DateInterval::__construct
Tarih ve Zaman


Yeni bir DateInterval nesnesi oluşturur

DateInterval
DateInterval::createFromDateString
DateInterval
PHP Manual

DateInterval::__construct

(PHP 5 >= 5.3.0, PHP 7)

DateInterval::__construct — Yeni bir DateInterval nesnesi oluşturur

Açıklama

public DateInterval::__construct ( string $zaman_aralığı )

Yeni bir DateInterval nesnesi oluşturur.

Değiştirgeler

zaman_aralığı

Dizge türünde zaman aralığı belirtimi.

Zaman aralığını ("period") belirtmek için biçem P harfiyle başlar, ardından süreyi belirten bir tamsayı değer gelir. Süre zaman bileşenleri içeriyorsa bunların önüne T harfi getirilir..

zaman_aralığı Belirteçleri
Belirteç | Açıklama
Y | Yıl
M | Ay
D | Gün
W | Hafta. Gün sayısına dönüştürmek için D harfiyle birlikte belirtilebilir.
H | Saat
M | Dakika
S | saniye

Burada bazı basit örneklere yer verilmiştir. İki gün: P2D. İki saniye: PT2S. Altı yıl, 5 dakika: P6YT5M.

Bilginize:

Birimler belirtilirken en büyük ölçekli birim solda en küçük ölçekli birim sağda kalacak şekilde veri girilir. Dolayısıyla, örneğin, aylar yıllardan sonra, günlerden önce yer alır. Bur yıl dört gün P4D1Y değil P1Y4D olarak ifade edilir.

Belirtim bir tarih saat olarak da gösterilebilir. Örneğin, bir yıl dört gün P0001-00-04T00:00:00 olarak gösterilebilir. Fakat bu biçemde belirtilen değerler birime tanınan azami değeri aşmamalıdır (örneğin 25 saat geçersizdir).

Bu biçemler » ISO 8601 süre belirtimine dayanır.

Örnekler

<?php

$interval = new DateInterval('P2Y4DT6H8M');
print_r($interval);

?>

Yukarıdaki örneğin çıktısı:

DateInterval Object
(
    [y] => 2
    [m] => 0
    [d] => 4
    [h] => 6
    [i] => 8
    [s] => 0
    [invert] => 0
    [days] => 0
)

Ayrıca Bakınız

  • DateInterval::format() - Zaman aralığını biçimler
  • DateTime::add() - Adds an amount of days, months, years, hours, minutes and seconds to a DateTime object
  • DateTime::sub() - Subtracts an amount of days, months, years, hours, minutes and seconds from a DateTime object
  • DateTime::diff()

DateInterval
DateInterval::createFromDateString
DateInterval


Dizgenin göreli kısımlarından bir DateInterval nesnesi döndürür

DateInterval::__construct
DateInterval::format
DateInterval
PHP Manual

DateInterval::createFromDateString

(PHP 5 >= 5.3.0, PHP 7)

DateInterval::createFromDateString — Dizgenin göreli kısımlarından bir DateInterval nesnesi döndürür

Açıklama

public static DateInterval DateInterval::createFromDateString ( string $zaman )

Normal tarih ayrıştırcısı kullanır ve dizgenin göreli kısımlarından bir DateInterval nesnesi oluşturur.

Değiştirgeler

zaman

Tarihe göreli kısımlar.

Dönen Değerler

Başarılıysa yeni bir DateInterval nesnesi döndürür.

DateInterval::__construct
DateInterval::format
DateInterval


Zaman aralığını biçimler

DateInterval::createFromDateString
DatePeriod
DateInterval
PHP Manual

DateInterval::format

(PHP 5 >= 5.3.0, PHP 7)

DateInterval::format — Zaman aralığını biçimler

Açıklama

public string DateInterval::format ( string $biçem )

Zaman aralığını biçimlendirir.

Değiştirgeler

biçem

biçem dizgesinde tanınan karakterler aşağıda listelenmiştir. Her biçem karakterinin başına bir yüzde (%) işareti konmalıdır.
Karakter | Açıklama | Örnek değerler
% % iminin kendisi %
Y | Başına 0 getirilerek iki haneli yıl | 01, 03
y | 0 ile öncelenmeksizin yıl | 1, 3
M | Başına 0 getirilerek iki haneli ay | 01, 03, 12
m | 0 ile öncelenmeksizin ay | 1, 3, 12
D | Başına 0 getirilerek iki haneli ayın günü | 01, 03, 31
d | 0 ile öncelenmeksizin ayın günü | 1, 3, 31
a | Toplam gün sayısı | 4, 18, 8123
H | Başına 0 getirilerek iki haneli saat | 01, 03, 23
h | 0 ile öncelenmeksizin saat | 1, 3, 23
I | Başına 0 getirilerek iki haneli dakika | 01, 03, 59
i | 0 ile öncelenmeksizin dakika | 1, 3, 59
S | Başına 0 getirilerek iki haneli saniye | 01, 03, 57
s | 0 ile öncelenmeksizin saniye | 1, 3, 57
R Negatifse "-", pozitifse "+" imi -, +
r Negatifse "-", pozitifse boş dizge -,

Dönen Değerler

Biçimlendirilmiş zaman aralığını bir dizge olarak döndürür.

Notlar

Bilginize:

DateInterval::format() yöntemi ne zaman dizgelerinde ne de tarih bölümlerinde tehir edilen kısımları yeniden hesaplar. Bunun sebebi "32 gün" gibi büyük değerlerin olanaksız oluşudur. Olanaklı olsaydı böyle bir değer "1 ay 4 gün" ile "1 ay 1 gün" arasında bir değer olarak yorumlanabilirdi.

Örnekler

Örnek 1 - DateInterval örneği

<?php

$interval = new DateInterval('P2Y4DT6H8M');
echo $interval->format('%d gün');

?>

Yukarıdaki örneğin çıktısı:

4 gün

Örnek 2 - DateInterval ve büyük değerler

<?php

$interval = new DateInterval('P32D');
echo $interval->format('%d gün');

?>

Yukarıdaki örneğin çıktısı:

32 gün

Örnek 3 - DateInterval ve DateTime::diff() ile %a ve %d değiştiricileri

<?php

$january = new DateTime('2010-01-01');
$february = new DateTime('2010-02-01');
$interval = $february->diff($january);

// %a toplam gün sayısını çıktılar.
echo $interval->format('toplam %a gün')."\n";

// %d ise aya dahil olmayan gün sayısını çıktılar.
echo $interval->format('%m ay, %d gün');

?>

Yukarıdaki örneğin çıktısı:

toplam 31 gün
1 ay, 0 gün

DateInterval::createFromDateString
DatePeriod
DateInterval


DatePeriod sınıfı

(PHP 5 >= 5.3.0, PHP 7)

Giriş

Dönemselliğin gösterimi.

Sınıf Sözdizimi

DatePeriod implements Traversable {
/* Sabitler */
const integer EXCLUDE_START_DATE = 1 ;
/* Yöntemler */
public __construct ( DateTime $başlangıç , DateInterval $aralık , int $tekrarlama [, int $seçenekler ] )
public __construct ( DateTime $başlangıç , DateInterval $aralık , DateTime $bitiş [, int $seçenekler ] )
public __construct ( string $isostr [, int $seçenekler ] )
}

Öntanımlı Sabitler

DatePeriod Düğüm Türleri

DatePeriod::EXCLUDE_START_DATE

DatePeriod::__construct() yönteminde kullanılan başlangıç tarihi dışlanır.

İçindekiler

  • DatePeriod::__construct — Yeni bir DatePeriod nesnesi oluşturur
  • DatePeriod::getDateInterval — Gets the interval
  • DatePeriod::getEndDate — Gets the end date
  • DatePeriod::getStartDate — Gets the start date
DateInterval::format
DatePeriod::__construct
Tarih ve Zaman


Yeni bir DatePeriod nesnesi oluşturur

DatePeriod
DatePeriod::getDateInterval
DatePeriod
PHP Manual

DatePeriod::__construct

(PHP 5 >= 5.3.0, PHP 7)

DatePeriod::__construct — Yeni bir DatePeriod nesnesi oluşturur

Açıklama

public DatePeriod::__construct ( DateTime $başlangıç , DateInterval $aralık , int $tekrarlama [, int $seçenekler ] )
public DatePeriod::__construct ( DateTime $başlangıç , DateInterval $aralık , DateTime $bitiş [, int $seçenekler ] )
public DatePeriod::__construct ( string $isostr [, int $seçenekler ] )

Yeni bir DatePeriod nesnesi oluşturur.

Değiştirgeler

başlangıç

Tarih başlangıcı.

aralık

Aralık.

tekrarlama

Tekrar sayısı.

bitiş

Tarih bitişi.

isostr

ISO aralığını içeren dizge.

seçenekler

DatePeriod::EXCLUDE_START_DATE sabiti olabilir.

DatePeriod
DatePeriod::getDateInterval
DatePeriod


Gets the interval

DatePeriod::__construct
DatePeriod::getEndDate
DatePeriod
PHP Manual

DatePeriod::getDateInterval

(PHP 5 >= 5.6.5, PHP 7)

DatePeriod::getDateInterval — Gets the interval

Açıklama

Nesne yönelimli kullanım

public DateInterval DatePeriod::getDateInterval ( void )

Gets a DateInterval object representing the interval used for the period.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a DateInterval object

Örnekler

Örnek 1 DatePeriod::getDateInterval() example

<?php
$period = new DatePeriod('R7/2016-05-16T00:00:00Z/P1D');
$interval = $period->getDateInterval();
echo $interval->format('%d day');
?>

Yukarıdaki örneğin çıktısı:

1 day

Ayrıca Bakınız

  • DatePeriod::getStartDate() - Gets the start date
  • DatePeriod::getEndDate() - Gets the end date
DatePeriod::__construct
DatePeriod::getEndDate
DatePeriod


Gets the end date

DatePeriod::getDateInterval
DatePeriod::getStartDate
DatePeriod
PHP Manual

DatePeriod::getEndDate

(PHP 5 >= 5.6.5, PHP 7)

DatePeriod::getEndDate — Gets the end date

Açıklama

Nesne yönelimli kullanım

public DateTimeInterface DatePeriod::getEndDate ( void )

Gets the end date of the period.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns NULL if the DatePeriod does not have an end date. For example, when initialized with the recurrences parameter, or the isostr parameter without an end date.

Returns a DateTimeImmutable object when the DatePeriod is initialized with a DateTimeImmutable object as the end parameter.

Returns a DateTime object otherwise.

Örnekler

Örnek 1 DatePeriod::getEndDate() example

<?php
$period = new DatePeriod(
    new DateTime('2016-05-16T00:00:00Z'),
    new DateInterval('P1D'),
    new DateTime('2016-05-20T00:00:00Z')
);
$start = $period->getEndDate();
echo $start->format(DateTime::ISO8601);
?>

Yukarıdaki örneklerin çıktısı:

2016-05-20T00:00:00+0000

Örnek 2 DatePeriod::getEndDate() without an end date

<?php
$period = new DatePeriod(
    new DateTime('2016-05-16T00:00:00Z'),
    new DateInterval('P1D'),
    7
);
var_dump($period->getEndDate());
?>

Yukarıdaki örneğin çıktısı:

NULL

Ayrıca Bakınız

  • DatePeriod::getStartDate() - Gets the start date
  • DatePeriod::getDateInterval() - Gets the interval
DatePeriod::getDateInterval
DatePeriod::getStartDate
DatePeriod


Gets the start date

DatePeriod::getEndDate
Tarih ve Zaman İşlevleri
DatePeriod
PHP Manual

DatePeriod::getStartDate

(PHP 5 >= 5.6.5, PHP 7)

DatePeriod::getStartDate — Gets the start date

Açıklama

Nesne yönelimli kullanım

public DateTimeInterface DatePeriod::getStartDate ( void )

Gets the start date of the period.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a DateTimeImmutable object when the DatePeriod is initialized with a DateTimeImmutable object as the start parameter.

Returns a DateTime object otherwise.

Örnekler

Örnek 1 DatePeriod::getStartDate() example

<?php
$period = new DatePeriod('R7/2016-05-16T00:00:00Z/P1D');
$start = $period->getStartDate();
echo $start->format(DateTime::ISO8601);
?>

Yukarıdaki örneğin çıktısı:

2016-05-16T00:00:00+0000

Ayrıca Bakınız

  • DatePeriod::getEndDate() - Gets the end date
  • DatePeriod::getDateInterval() - Gets the interval
DatePeriod::getEndDate
Tarih ve Zaman İşlevleri
DatePeriod


Tarih ve Zaman İşlevleri

İçindekiler

  • checkdate — Miladi tarihi doğrular
  • date_add — DateTime::add işlevinin takma adıdır
  • date_create_from_format — DateTime::createFromFormat işlevinin takma adıdır
  • date_create_immutable_from_format — Takma Adı: DateTimeImmutable::createFromFormat
  • date_create_immutable — Takma Adı: DateTimeImmutable::__construct
  • date_create — DateTime::__construct için bir takma ad
  • date_date_set — DateTime::setDate işlevinin takma adıdır
  • date_default_timezone_get — Betik içerisindeki tüm tarih/zaman işlevleri tarafından kullanılan öntanımlı zaman dilimini getirir
  • date_default_timezone_set — Betik içerisindeki tüm tarih/zaman işlevleri tarafından kullanılan öntanımlı zaman dilimini ayarlar
  • date_diff — DateTime::diff işlevinin takma adıdır
  • date_format — DateTime::format işlevinin takma adıdır
  • date_get_last_errors — DateTime::getLastErrors işlevinin takma adıdır
  • date_interval_create_from_date_string — DateInterval::createFromDateString işlevinin takma adıdır
  • date_interval_format — DateInterval::format işlevinin takma adıdır
  • date_isodate_set — DateTime::setISODate işlevinin takma adıdır
  • date_modify — DateTime::modify işlevinin takma adıdır
  • date_offset_get — DateTime::getOffset işlevinin takma adıdır
  • date_parse_from_format — Get info about given date formatted according to the specified format
  • date_parse — Verilen tarih hakkındaki ayrıntılı bilgiyi ilişkisel dizi olarak döndürür
  • date_sub — DateTime::sub işlevinin takma adıdır
  • date_sun_info — Güneşin doğuşu/batışı ve alacakaranlık başlangıcı/sonu hakkında bilgi içeren bir dizi döndürür
  • date_sunrise — Belirtilen gün ve konum için şafak zamanını döndürür
  • date_sunset — Verilen gün ve konum için günbatımı zamanını döndürür
  • date_time_set — DateTime::setTime işlevinin takma adıdır
  • date_timestamp_get — DateTime::getTimestamp işlevinin takma adıdır
  • date_timestamp_set — DateTime::setTimestamp işlevinin takma adıdır
  • date_timezone_get — DateTime::getTimezone işlevinin takma adıdır
  • date_timezone_set — DateTime::setTimezone işlevinin takma adıdır
  • date — Yerel tarihi/saati biçimlendirir
  • getdate — Tarih/zaman bilgisi getirir
  • gettimeofday — Geçerli zamanı getirir
  • gmdate — Bir tarih/saati GMT/UTC tarih/saati olarak biçemler
  • gmmktime — Bir GMT tarihi için Unix zaman damgasını döndürür
  • gmstrftime — Yerel ayarlara göre tarih ve saati, GMT/UTC türüne çevirir
  • idate — Yerel zamanı/tarihi tamsayı olarak biçimlendirir
  • localtime — Yerel zamanı getirir
  • microtime — Geçerli Unix zaman damgasını mikrosaniye olarak döndürür
  • mktime — Bir tarih için Unix zaman damgasını döndürür
  • strftime — Format a local time/date according to locale settings
  • strptime — strftime işleviyle üretilen zaman ve tarihleri çözümler
  • strtotime — Parse about any English textual datetime description into a Unix timestamp
  • time — Geçerli Unix zaman damgasını döndürür
  • timezone_abbreviations_list — DateTimeZone::listAbbreviations işlevinin takma adıdır
  • timezone_identifiers_list — DateTimeZone::listIdentifiers işlevinin takma adıdır
  • timezone_location_get — DateTimeZone::getLocation işlevinin takma adıdır
  • timezone_name_from_abbr — Kısaltmasından, zaman diliminin adını döndürür
  • timezone_name_get — DateTimeZone::getName işlevinin takma adıdır
  • timezone_offset_get — DateTimeZone::getOffset işlevinin takma adıdır
  • timezone_open — DateTimeZone::__construct için takma ad
  • timezone_transitions_get — DateTimeZone::getTransitions işlevinin takma adıdır
  • timezone_version_get — Gets the version of the timezonedb
DatePeriod::getStartDate
checkdate
Tarih ve Zaman


Miladi tarihi doğrular

Tarih ve Zaman İşlevleri
date_add
Tarih ve Zaman İşlevleri
PHP Manual

checkdate

(PHP 4, PHP 5, PHP 7)

checkdate — Miladi tarihi doğrular

Açıklama

bool checkdate ( int $ay , int $gün , int $yıl )

Verilen değiştirgelerle şekillenen tarihin geçerliliğini sınar. Her değiştirge doğru tanımlanmışsa, tarih geçerli sayılır.

Değiştirgeler

ay

Ay 1 ve 12 arasında olmalıdır.

gün

Gün, verilen ay'ın gün sayıları içerisinde olmalıdır. Artık yıllar dikkate alınacaktır.

yıl

Yıl 1 ve 32767 arasında olmalıdır.

Dönen Değerler

Verilen tarih geçerli ise TRUE değeriyle, değilse FALSE değeriyle döner.

Örnekler

Örnek 1 - checkdate() örneği

<?php
var_dump(checkdate(12, 31, 2000));
var_dump(checkdate(2, 29, 2001));
?>

Yukarıdaki örneğin çıktısı:

bool(true)
bool(false)

Ayrıca Bakınız

  • mktime() - Bir tarih için Unix zaman damgasını döndürür
  • strtotime() - Parse about any English textual datetime description into a Unix timestamp

Tarih ve Zaman İşlevleri
date_add
Tarih ve Zaman İşlevleri


DateTime::add işlevinin takma adıdır

checkdate
date_create_from_format
Tarih ve Zaman İşlevleri
PHP Manual

date_add

(PHP 5 >= 5.3.0, PHP 7)

date_add — DateTime::add() işlevinin takma adıdır

Açıklama

Bu işlev, DateTime::add() işlevinin takma adıdır.

checkdate
date_create_from_format
Tarih ve Zaman İşlevleri


DateTime::createFromFormat işlevinin takma adıdır

date_add
date_create_immutable_from_format
Tarih ve Zaman İşlevleri
PHP Manual

date_create_from_format

(PHP 5 >= 5.3.0, PHP 7)

date_create_from_format — DateTime::createFromFormat() işlevinin takma adıdır

Açıklama

Bu işlev DateTime::createFromFormat() işlevinin takma adıdır.

date_add
date_create_immutable_from_format
Tarih ve Zaman İşlevleri


Takma Adı: DateTimeImmutable::createFromFormat

date_create_from_format
date_create_immutable
Tarih ve Zaman İşlevleri
PHP Manual

date_create_immutable_from_format

(PHP 5 >= 5.5.0, PHP 7)

date_create_immutable_from_format — Takma Adı: DateTimeImmutable::createFromFormat()

Açıklama

Bu işlev şu işlevin takma adıdır: DateTimeImmutable::createFromFormat()

date_create_from_format
date_create_immutable
Tarih ve Zaman İşlevleri


Takma Adı: DateTimeImmutable::__construct

date_create_immutable_from_format
date_create
Tarih ve Zaman İşlevleri
PHP Manual

date_create_immutable

(PHP 5 >= 5.5.0, PHP 7)

date_create_immutable — Takma Adı: DateTimeImmutable::__construct()

Açıklama

Bu işlev şu işlevin takma adıdır: DateTimeImmutable::__construct()

date_create_immutable_from_format
date_create
Tarih ve Zaman İşlevleri


DateTime::__construct için bir takma ad

date_create_immutable
date_date_set
Tarih ve Zaman İşlevleri
PHP Manual

date_create

(PHP 5 >= 5.2.0, PHP 7)

date_create — DateTime::__construct() için bir takma ad

Açıklama

Bu işlev DateTime::__construct() için bir takma addır.

date_create_immutable
date_date_set
Tarih ve Zaman İşlevleri


DateTime::setDate işlevinin takma adıdır

date_create
date_default_timezone_get
Tarih ve Zaman İşlevleri
PHP Manual

date_date_set

(PHP 5 >= 5.2.0, PHP 7)

date_date_set — DateTime::setDate() işlevinin takma adıdır

Açıklama

Bu işlev, DateTime::setDate() işlevinin takma adıdır.

date_create
date_default_timezone_get
Tarih ve Zaman İşlevleri


Betik içerisindeki tüm tarih/zaman işlevleri tarafından kullanılan öntanımlı zaman dilimini getirir

date_date_set
date_default_timezone_set
Tarih ve Zaman İşlevleri
PHP Manual

date_default_timezone_get

(PHP 5 >= 5.1.0, PHP 7)

date_default_timezone_get — Betik içerisindeki tüm tarih/zaman işlevleri tarafından kullanılan öntanımlı zaman dilimini getirir

Açıklama

string date_default_timezone_get ( void )

Bu işlev tercih sırasına göre öntanımlı zaman dilimini şöyle döndürür:

  • date_default_timezone_set() işlevi kullanılarak atanan zaman dilimiyle (eğer varsa).

  • TZ ortam değişkenindeki değerle (boş değilse).

  • date.timezone ini yönergesindeki değerle (ayarlanmışsa).

  • Ev sahibi işletim sistemini sorgulayarak (işletim sistemi destekliyor ve izin veriyorsa).

Eğer yukarıdakilerin hiçbirisi başarılı değilse, date_default_timezone_get() işlevi öntanımlı UTC zaman dilimini döndürecektir.

Dönen Değerler

string türünde geri döner.

Örnekler

Örnek 1 - Öntanımlı zaman diliminin getirilmesi

<?php
date_default_timezone_set('Europe/Istanbul');

if (date_default_timezone_get()) {
    echo 'date_default_timezone_set: '. date_default_timezone_get() .'<br />';
}

if (ini_get('date.timezone')) {
    echo 'date.timezone: ' . ini_get('date.timezone');
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

date_default_timezone_set: Europe/Istanbul
date.timezone: Europe/Istanbul

Örnek 2 - Zaman diliminin kısaltmasının getirilmesi

<?php
date_default_timezone_set('Europe/Istanbul');
echo date_default_timezone_get() . ' => ' . date('e') . ' => ' . date('T');
?>

Yukarıdaki örneğin çıktısı:

Europe/Istanbul => Europe/Istanbul => EET

Ayrıca Bakınız

  • date_default_timezone_set() - Betik içerisindeki tüm tarih/zaman işlevleri tarafından kullanılan öntanımlı zaman dilimini ayarlar
  • Desteklenen Zaman Dilimlerinin Listesi

date_date_set
date_default_timezone_set
Tarih ve Zaman İşlevleri


Betik içerisindeki tüm tarih/zaman işlevleri tarafından kullanılan öntanımlı zaman dilimini ayarlar

date_default_timezone_get
date_diff
Tarih ve Zaman İşlevleri
PHP Manual

date_default_timezone_set

(PHP 5 >= 5.1.0, PHP 7)

date_default_timezone_set — Betik içerisindeki tüm tarih/zaman işlevleri tarafından kullanılan öntanımlı zaman dilimini ayarlar

Açıklama

bool date_default_timezone_set ( string $zamandilimi_belirteci )

date_default_timezone_set() işlevi, tüm tarih/zaman işlevleri tarafından kullanılan öntanımlı zaman dilimini ayarlar.

Bilginize:

PHP 5.1.0 sürümünden beri (tarih/zaman işlevleri yeniden yazıldığından beri), bir tarih/zaman işlevinin her çağrılışında, eğer zaman dilimi geçerli değilse bir E_NOTICE, eğer sistem ayarları ya da TZ ortam değişkeni kullanılıyorsa bir E_WARNING iletisi üretilmektedir.

Öntanımlı zaman dilimini ayarlamak için, bu işlevi betiğinizde kullanmak yerine, INI ayarlarındaki date.timezone yönergesini de kullanabilirsiniz.

Değiştirgeler

zamandilimi_belirteci

Zaman dilimi belirteci, UTC ya da Europe/Istanbul gibi bir değer olabilir. Geçerli belirteçlerin listesi Desteklenen Zaman Dilimlerinin Listesi bölümünde bulunmaktadır.

Dönen Değerler

Bu işlev zamandilimi_belirteci geçersizse FALSE, aksi takdirde TRUE döndürür.

Örnekler

Örnek 1 - Öntanımlı zaman dilimini almak

<?php
date_default_timezone_set('Europe/Istanbul');

$betik_zd = date_default_timezone_get();

if (strcmp($betik_zd, ini_get('date.timezone'))){
    echo 'Betik zaman dilimi ini dosyasında belirtilenden farklı.';
} else {
    echo 'Betik zaman dilimi ini dosyasında belirtilenle aynı.';
}
?>

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | Artık E_STRICT yerine E_WARNING oluşuyor.
5.1.2 | İşlev, zamandilimi_belirteci değiştirgesini kullanmaya başladı.

Ayrıca Bakınız

  • date_default_timezone_get() - Betik içerisindeki tüm tarih/zaman işlevleri tarafından kullanılan öntanımlı zaman dilimini getirir
  • Desteklenen Zaman Dilimlerinin Listesi

date_default_timezone_get
date_diff
Tarih ve Zaman İşlevleri


DateTime::diff işlevinin takma adıdır

date_default_timezone_set
date_format
Tarih ve Zaman İşlevleri
PHP Manual

date_diff

(PHP 5 >= 5.3.0, PHP 7)

date_diff — DateTime::diff() işlevinin takma adıdır

Açıklama

Bu işlev, DateTime::diff() işlevinin takma adıdır.

date_default_timezone_set
date_format
Tarih ve Zaman İşlevleri


DateTime::format işlevinin takma adıdır

date_diff
date_get_last_errors
Tarih ve Zaman İşlevleri
PHP Manual

date_format

(PHP 5 >= 5.2.0, PHP 7)

date_format — DateTime::format() işlevinin takma adıdır

Açıklama

Bu işlev, DateTime::format() işlevinin takma adıdır.

date_diff
date_get_last_errors
Tarih ve Zaman İşlevleri


DateTime::getLastErrors işlevinin takma adıdır

date_format
date_interval_create_from_date_string
Tarih ve Zaman İşlevleri
PHP Manual

date_get_last_errors

(PHP 5 >= 5.3.0, PHP 7)

date_get_last_errors — DateTime::getLastErrors() işlevinin takma adıdır

Açıklama

Bu işlev, DateTime::getLastErrors() işlevinin takma adıdır.

date_format
date_interval_create_from_date_string
Tarih ve Zaman İşlevleri


DateInterval::createFromDateString işlevinin takma adıdır

date_get_last_errors
date_interval_format
Tarih ve Zaman İşlevleri
PHP Manual

date_interval_create_from_date_string

(PHP 5 >= 5.3.0, PHP 7)

date_interval_create_from_date_string — DateInterval::createFromDateString() işlevinin takma adıdır

Açıklama

Bu işlev, DateInterval::createFromDateString() işlevinin takma adıdır.

date_get_last_errors
date_interval_format
Tarih ve Zaman İşlevleri


DateInterval::format işlevinin takma adıdır

date_interval_create_from_date_string
date_isodate_set
Tarih ve Zaman İşlevleri
PHP Manual

date_interval_format

(PHP 5 >= 5.3.0, PHP 7)

date_interval_format — DateInterval::format() işlevinin takma adıdır

Açıklama

Bu işlev, DateInterval::format() işlevinin takma adıdır.

date_interval_create_from_date_string
date_isodate_set
Tarih ve Zaman İşlevleri


DateTime::setISODate işlevinin takma adıdır

date_interval_format
date_modify
Tarih ve Zaman İşlevleri
PHP Manual

date_isodate_set

(PHP 5 >= 5.2.0, PHP 7)

date_isodate_set — DateTime::setISODate() işlevinin takma adıdır

Açıklama

Bu işlev, DateTime::setISODate() işlevinin takma adıdır.

date_interval_format
date_modify
Tarih ve Zaman İşlevleri


DateTime::modify işlevinin takma adıdır

date_isodate_set
date_offset_get
Tarih ve Zaman İşlevleri
PHP Manual

date_modify

(PHP 5 >= 5.2.0, PHP 7)

date_modify — DateTime::modify() işlevinin takma adıdır

Açıklama

Bu işlev, DateTime::modify() işlevinin takma adıdır.

date_isodate_set
date_offset_get
Tarih ve Zaman İşlevleri


DateTime::getOffset işlevinin takma adıdır

date_modify
date_parse_from_format
Tarih ve Zaman İşlevleri
PHP Manual

date_offset_get

(PHP 5 >= 5.2.0, PHP 7)

date_offset_get — DateTime::getOffset() işlevinin takma adıdır

Açıklama

Bu işlev, DateTime::getOffset() işlevinin takma adıdır.

date_modify
date_parse_from_format
Tarih ve Zaman İşlevleri


Get info about given date formatted according to the specified format

date_offset_get
date_parse
Tarih ve Zaman İşlevleri
PHP Manual

date_parse_from_format

(PHP 5 >= 5.3.0, PHP 7)

date_parse_from_format — Get info about given date formatted according to the specified format

Açıklama

array date_parse_from_format ( string $format , string $date )

Returns associative array with detailed info about given date.

Değiştirgeler

format

Format accepted by DateTime::createFromFormat().

date

String representing the date.

Dönen Değerler

Returns associative array with detailed info about given date.

Örnekler

Örnek 1 date_parse_from_format() example

<?php
$date = "6.1.2009 13:00+01:00";
print_r(date_parse_from_format("j.n.Y H:iP", $date));
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [year] => 2009
    [month] => 1
    [day] => 6
    [hour] => 13
    [minute] => 0
    [second] => 0
    [fraction] =>
    [warning_count] => 0
    [warnings] => Array
        (
        )

    [error_count] => 0
    [errors] => Array
        (
        )

    [is_localtime] => 1
    [zone_type] => 1
    [zone] => -60
    [is_dst] =>
)

Ayrıca Bakınız

  • DateTime::createFromFormat() - Parses a time string according to a specified format
  • checkdate() - Miladi tarihi doğrular

date_offset_get
date_parse
Tarih ve Zaman İşlevleri


Verilen tarih hakkındaki ayrıntılı bilgiyi ilişkisel dizi olarak döndürür

date_parse_from_format
date_sub
Tarih ve Zaman İşlevleri
PHP Manual

date_parse

(PHP 5 >= 5.2.0, PHP 7)

date_parse — Verilen tarih hakkındaki ayrıntılı bilgiyi ilişkisel dizi olarak döndürür

Açıklama

array date_parse ( string $tarih )

Değiştirgeler

tarih

strtotime() işlevi tarafından kabul edilen biçimde tarih.

Dönen Değerler

Başarılı olduğunda çözümlenen tarihin bilgilerini içeren diziyle, başarısız olduğunda FALSE değeriyle döner.

Hatalar/İstisnalar

Tarih biçimi hatalı olduğu taktirde, dizinin 'errors' elemanı hata iletilerini içerecektir.

Örnekler

Örnek 1 - date_parse() örneği

<?php
print_r(date_parse("1923-11-29 20:30:00.0"));
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [year] => 1923
    [month] => 11
    [day] => 29
    [hour] => 20
    [minute] => 30
    [second] => 0
    [fraction] => 0
    [warning_count] => 0
    [warnings] => Array ()
    [error_count] => 0
    [errors] => Array ()
    [is_localtime] =>
)

Ayrıca Bakınız

  • getdate() - Tarih/zaman bilgisi getirir

date_parse_from_format
date_sub
Tarih ve Zaman İşlevleri


DateTime::sub işlevinin takma adıdır

date_parse
date_sun_info
Tarih ve Zaman İşlevleri
PHP Manual

date_sub

(PHP 5 >= 5.3.0, PHP 7)

date_sub — DateTime::sub() işlevinin takma adıdır

Açıklama

Bu işlev, DateTime::sub() işlevinin takma adıdır.

date_parse
date_sun_info
Tarih ve Zaman İşlevleri


Güneşin doğuşu/batışı ve alacakaranlık başlangıcı/sonu hakkında bilgi içeren bir dizi döndürür

date_sub
date_sunrise
Tarih ve Zaman İşlevleri
PHP Manual

date_sun_info

(PHP 5 >= 5.1.2, PHP 7)

date_sun_info — Güneşin doğuşu/batışı ve alacakaranlık başlangıcı/sonu hakkında bilgi içeren bir dizi döndürür

Açıklama

array date_sun_info ( int $zaman , float $enlem , float $boylam )

Değiştirgeler

zaman

Zaman damgası.

enlem

Enlem derecesi.

boylam

Boylam derecesi.

Dönen Değerler

Başarılı olduğunda diziyi, başarısız olduğunda FALSE değerini döndürür.

Örnekler

Örnek 1 - date_sun_info() örneği

<?php
$sun_info = date_sun_info(strtotime("2008-12-12"), 36.55, 32.03);
foreach ($sun_info as $key => $val) {
    echo "$key: " . date("H:i:s", $val) . "\n";
}
?>

Yukarıdaki örneğin çıktısı:

sunrise: 06:54:58
sunset: 16:36:54
transit: 11:45:56
civil_twilight_begin: 06:26:20
civil_twilight_end: 17:05:32
nautical_twilight_begin: 05:54:03
nautical_twilight_end: 17:37:49
astronomical_twilight_begin: 05:22:39
astronomical_twilight_end: 18:09:14

Ayrıca Bakınız

  • date_sunrise() - Belirtilen gün ve konum için şafak zamanını döndürür
  • date_sunset() - Verilen gün ve konum için günbatımı zamanını döndürür

date_sub
date_sunrise
Tarih ve Zaman İşlevleri


Belirtilen gün ve konum için şafak zamanını döndürür

date_sun_info
date_sunset
Tarih ve Zaman İşlevleri
PHP Manual

date_sunrise

(PHP 5, PHP 7)

date_sunrise — Belirtilen gün ve konum için şafak zamanını döndürür

Açıklama

mixed date_sunrise ( int $zamandamgası [, int $biçim = SUNFUNCS_RET_STRING [, float $enlem = ini_get("date.default_latitude") [, float $boylam = ini_get("date.default_longitude") [, float $başucu = ini_get("date.sunrise_zenith") [, float $gmt_farkı = 0 ]]]]] )

date_sunrise() işlevi, verilen gün (zamandamgası) ve konum için şafak zamanını döndürür.

Değiştirgeler

zamandamgası

Şafak zamanı öğrenilecek günün zamandamgası.

biçim

biçim sabitleri
sabit | açıklama | örnek
SUNFUNCS_RET_STRING | Sonucu dizge olarak döndürür. | 16:46
SUNFUNCS_RET_DOUBLE | Sonucu gerçek sayı olarak döndürür. | 16.78243132
SUNFUNCS_RET_TIMESTAMP | Sonucu tamsayı (zaman damgası) olarak döndürür. | 1095034606

enlem

Kuzey yarımküre öntanımlıdır. Güney yarımküre için negatif değer girin. Ayrıca bakınız: date.default_latitude

boylam

Doğu yarımküre öntanımlıdır. Batı yarımküre için negatif değer girin. Ayrıca bakınız: date.default_longitude

başucu

Öntanımlı: date.sunrise_zenith

gmt_farkı

Saat cinsinden belirtilir.

Dönen Değerler

Başarılı olduğunda, biçim değiştirgesiyle belirlenen biçimde şafak zamanını, başarız olduğunda FALSE değerini döndürür.

Hatalar/İstisnalar

Bir tarih/zaman işlevine yapılan her çağrı eğer zaman dilimi ayarı geçerli değilse bir E_NOTICE üretir. Ve/veya eğer sistem ayarları veya TZ ortam değişkeni kullanılıyorsa bir E_STRICT veya bir E_WARNING iletisi üretir. Ayrıca bakınız: date_default_timezone_set()

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.0 | Zaman dilimi hatalarında artık E_STRICT ve E_NOTICE çıktılanıyor.

Örnekler

Örnek 1 - date_sunrise() örneği

<?php

/* İstanbul, Türkiye için şafak hesabı
Enlem: 41.01 Kuzey
Boylam: 28.58 Doğu
Başucu ~= 90
saat farkı: +2 GMT
*/

echo date("D M d Y"). ', şafak: ' .date_sunrise(time(), SUNFUNCS_RET_STRING, 41.01, 28.58, 90, 2);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Fri Dec 12 2008, şafak: 07:25

Ayrıca Bakınız

  • date_sunset() - Verilen gün ve konum için günbatımı zamanını döndürür

date_sun_info
date_sunset
Tarih ve Zaman İşlevleri


Verilen gün ve konum için günbatımı zamanını döndürür

date_sunrise
date_time_set
Tarih ve Zaman İşlevleri
PHP Manual

date_sunset

(PHP 5, PHP 7)

date_sunset — Verilen gün ve konum için günbatımı zamanını döndürür

Açıklama

mixed date_sunset ( int $zamandamgası [, int $biçim = SUNFUNCS_RET_STRING [, float $enlem = ini_get("date.default_latitude") [, float $boylam = ini_get("date.default_longitude") [, float $başucu = ini_get("date.sunset_zenith") [, float $gmt_farkı = 0 ]]]]] )

date_sunset() işlevi, verilen gün (zamandamgası) ve konum için günbatımı zamanını döndürür.

Değiştirgeler

zaman damgası

Günbatımı zamanı alınacak günün zamandamgası.

biçim

biçim sabitleri
sabit | açıklama | örnek
SUNFUNCS_RET_STRING | Sonucu dizge olarak döndürür. | 16:46
SUNFUNCS_RET_DOUBLE | Sonucu gerçek sayı olarak döndürür. | 16.78243132
SUNFUNCS_RET_TIMESTAMP | Sonucu tamsayı (zaman damgası) olarak döndürür. | 1095034606

enlem

Kuzey yarımküre öntanımlıdır. Güney yarımküre için negatif değer girin. Ayrıca bakınız: date.default_latitude

boylam

Doğu yarımküre öntanımlıdır. Batı yarımküre için negatif değer girin. Ayrıca bakınız: date.default_longitude

başucu

Öntanımlı: date.sunset_zenith

gmt_farkı

Saat cinsinden belirtilir.

Hatalar/İstisnalar

Bir tarih/zaman işlevine yapılan her çağrı eğer zaman dilimi ayarı geçerli değilse bir E_NOTICE üretir. Ve/veya eğer sistem ayarları veya TZ ortam değişkeni kullanılıyorsa bir E_STRICT veya bir E_WARNING iletisi üretir. Ayrıca bakınız: date_default_timezone_set()

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.0 | Zaman dilimi hatalarında artık E_STRICT ve E_NOTICE çıktılanıyor.

Dönen Değerler

Başarılı olduğunda, biçim değiştirgesiyle belirlenen biçemde gün batımı zamanını, başarız olduğunda FALSE değerini döndürür.

Örnekler

Örnek 1 - date_sunset() örneği

<?php

/* İstanbul, Türkiye için günbatımı zamanı hesabı
Enlem: 41.01 Kuzey
Boylam: 28.58 Doğu
Başucu ~= 90
saat farkı: +2 GMT
*/

echo date("D M d Y"). ', günbatımı: ' .date_sunset(time(), SUNFUNCS_RET_STRING, 41.01, 28.58, 90, 2);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Thu Dec 11 2008, günbatımı: 16:33

Ayrıca Bakınız

  • date_sunrise() - Belirtilen gün ve konum için şafak zamanını döndürür

date_sunrise
date_time_set
Tarih ve Zaman İşlevleri


DateTime::setTime işlevinin takma adıdır

date_sunset
date_timestamp_get
Tarih ve Zaman İşlevleri
PHP Manual

date_time_set

(PHP 5 >= 5.2.0, PHP 7)

date_time_set — DateTime::setTime() işlevinin takma adıdır

Açıklama

Bu işlev, DateTime::setTime() işlevinin takma adıdır.

date_sunset
date_timestamp_get
Tarih ve Zaman İşlevleri


DateTime::getTimestamp işlevinin takma adıdır

date_time_set
date_timestamp_set
Tarih ve Zaman İşlevleri
PHP Manual

date_timestamp_get

(PHP 5 >= 5.3.0, PHP 7)

date_timestamp_get — DateTime::getTimestamp() işlevinin takma adıdır

Açıklama

Bu işlev, DateTime::getTimestamp() işlevinin takma adıdır.

date_time_set
date_timestamp_set
Tarih ve Zaman İşlevleri


DateTime::setTimestamp işlevinin takma adıdır

date_timestamp_get
date_timezone_get
Tarih ve Zaman İşlevleri
PHP Manual

date_timestamp_set

(PHP 5 >= 5.3.0, PHP 7)

date_timestamp_set — DateTime::setTimestamp() işlevinin takma adıdır

Açıklama

Bu işlev, DateTime::setTimestamp() işlevinin takma adıdır.

date_timestamp_get
date_timezone_get
Tarih ve Zaman İşlevleri


DateTime::getTimezone işlevinin takma adıdır

date_timestamp_set
date_timezone_set
Tarih ve Zaman İşlevleri
PHP Manual

date_timezone_get

(PHP 5 >= 5.2.0, PHP 7)

date_timezone_get — DateTime::getTimezone() işlevinin takma adıdır

Açıklama

Bu işlev, DateTime::getTimezone() işlevinin takma adıdır.

date_timestamp_set
date_timezone_set
Tarih ve Zaman İşlevleri


DateTime::setTimezone işlevinin takma adıdır

date_timezone_get
date
Tarih ve Zaman İşlevleri
PHP Manual

date_timezone_set

(PHP 5 >= 5.2.0, PHP 7)

date_timezone_set — DateTime::setTimezone() işlevinin takma adıdır

Açıklama

Bu işlev, DateTime::setTimezone() işlevinin takma adıdır.

date_timezone_get
date
Tarih ve Zaman İşlevleri


Yerel tarihi/saati biçimlendirir

date_timezone_set
getdate
Tarih ve Zaman İşlevleri
PHP Manual

date

(PHP 4, PHP 5, PHP 7)

date — Yerel tarihi/saati biçimlendirir

Açıklama

string date ( string $biçim [, int $zaman_damgası ] )

zaman_damgası değiştirgesi ile belirtilen zamanı ya da zaman damgası değiştirgesi kullanılmamışsa yerel zamanı, belirtilen biçime göre biçimlendirerek döndürür. Başka bir deyişle, zaman_damgası değiştirgesini belirtmek isteğe bağlıdır ve varsayılan değeri time() işlevinin değeridir.

Değiştirgeler

biçim

Çıktılanan zamanın string türünden biçimi. Biçimlendirme seçenekleri için aşağıya bakınız. Ayrıca burada kullanılabilecek önceden tanımlanmış çeşitli tarih sabitleri vardır. Örneğin, DATE_RSS sabiti 'D, d M Y H:i:s' biçemini içerir.

Aşağıdaki karakterler biçim değiştirge dizgesi içinde tanınır.
biçim karakteri | Açıklama | Örnek sonuç
Gün --- ---
d | Ay günlerinin sıfır dolgulu iki haneli gösterimi | 01'den 31'e
D | Ay günlerinin üç harfli metinsel gösterimi | Pzt'den Paz'a
j | Ay günlerinin sıfır dolgusuz gösterimi | 1'den 31'e
l (küçük 'L' harfi) | Hafta günlerinin tam metinsel gösterimi | Pazar'dan Cumartesi'ye
N | Hafta günlerinin ISO-8601 standardında sayısal gösterimi (PHP 5.1.0'da eklenmiştir) | 1'den (Pazartesi için) 7'ye (Pazar için)
S | Ay günleri için 2 karakterli İngilizce sıralama ekleri | st, nd, rd ya da th. j ile uyumlu çalışmaktadır.
w | Hafta günlerinin sayısal gösterimi | 0'dan (Pazar için) 6'ya (Cumartesi için)
z | Yılın günleri (0'dan başlar) | 0'dan 365'e
Hafta --- ---
W | ISO-8601 standartına göre yılın hafta numarası, hafta başlangıcı Pazartesi'dir (PHP 4.1.0 sürümüyle eklenmiştir) | Örneğin: 42 (Yılın 42'inci haftası)
Ay --- ---
F | Ayın tam metinsel gösterimi, Ocak ya da Mart gibi | January'den December'a
m | Ayın sıfır dolgulu sayısal gösterimi | 01'den 12'ye
M | Ayın üç karakterli, metinsel kısa gösterimi | Jan'dan Dec'e kadar
n | Ayın sıfır dolgusuz sayısal gösterimi | 1'den 12'ye kadar
t | Belirtilen ayın gün sayısı | 28'den 31'e
Yıl --- ---
L | Artık yıl olduğunda | Eğer artık yılsa 1, değilse 0.
o | ISO-8601 standardı yıl numarası. ISO hafta numaralarının (W) ait olduğu yılın gösterilmesi dışında Y ile aynı değere sahiptir. (PHP 5.1.0 sürümünde eklenmiştir) | Örnekler: 1999 ya da 2003 gibi
Y | Yılın 4 haneli sayısal, tam gösterimi | Örnekler: 1999 ya da 2003 gibi
y | Yılın iki haneli gösterimi | Örnekler: 99 ya da 03 gibi
Saat --- ---
a | Küçük harfli öğleden önce ve öğleden sonra | am ya da pm
A | Büyük harfli öğleden önce ve öğleden sonra | AM ya da PM
B | Swatch İnternet saati | 000'dan 999'a
g | Saatin, 12-saatlik sıfır dolgusuz gösterimi | 1'den 12'ye
G | Saatin, 24-saatlik sıfır dolgusuz gösterimi | 0'dan 23'e
h | Saatin, 12-saatlik sıfır dolgulu gösterimi | 01'den 12'ye
H | Saatin, 24-saatlik sıfır dolgulu gösterimi | 00'dan 23'e
i | Sıfır dolgulu dakika gösterimi | 00 ile 59 arasında
s | Sıfır dolgulu saniye gösterimi | 00 ile 59 arasında
u | Mikrosaniye (PHP 5.2.2 sürümüyle eklenmiştir) | Örneğin: 654321
Zaman dilimi --- ---
e | Zaman dilimi belirteci (PHP 5.1.0 sürümüyle eklenmiştir) | Örnekler: UTC, GMT, Europe/Istanbul
I (büyük ı) | Yaz saati uygulaması var mı? | Varsa 1, yoksa 0.
O | Saat olarak Greenwich zamanı (GMT) farkı | Örneğin: +0200
P | Saat ve dakika olarak Greenwich zamanı (GMT) farkı (PHP 5.1.3 sürümüyle eklenmiştir) | Örneğin: +02:00
T | Zaman dilimi kısaltması | Örnekler: EST, EET gibi
Z | Saniye cinsinden saat farkı. UTC'nin batısı daima negatif, doğusu ise daima pozitif değerlidir. | -43200'den 50400'e
Tam Tarih/Saat --- ---
c | ISO 8601 standardı tarih (PHP 5'te' eklenmiştir) | 2004-02-12T15:19:21+00:00
r | » RFC 2822 biçiminde tarih | Örneğin: Thu, 21 Dec 2000 16:01:07 +0200
U | Unix Zaman Başlangıcından (1 Ocak 1970 00:00:00 GMT) itibaren geçen saniye sayısı | time() işlevine bakınız

Biçim dizgesinde tanınmayan karakterler olduğu gibi yazdırılacaktır. Z biçimi gmdate() işleviyle kullanıldığında daima 0 değerini döndürür.

Bilginize:

Bu işlev sadece integer türünde zaman damgalarını kabul etmektedir. u biçim karakteri sadece date_format() işlevinde, date_create() işleviyle kullanıcı tabanlı bir zaman damgası oluşturulduğunda kullanılabilir.

zaman_damgası

Seçimlik zaman_damgası değiştirgesi integer türünde bir Unix zaman damgası olup belirtilmediği takdirde yerel zaman kullanılır. Başka bir deyişle, time() işlevinden dönen değer öntanımlıdır.

Dönen Değerler

Biçimlendirilmiş tarih dizgesi döndürür. Eğer zaman_damgası değiştirgesi için sayı olmayan bir değer girilirse; FALSE döndürülür ve E_WARNING seviyesinde bir hata çıktılanır.

Hatalar/İstisnalar

Bir tarih/zaman işlevine yapılan her çağrı eğer zaman dilimi ayarı geçerli değilse bir E_NOTICE üretir. Ve/veya eğer sistem ayarları veya TZ ortam değişkeni kullanılıyorsa bir E_STRICT veya bir E_WARNING iletisi üretir. Ayrıca bakınız: date_default_timezone_set()

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.0 | Zaman damgasının geçerlilik aralığı, genellikle Cum, 13 Ara 1901 20:45:54 GMT ile Per, 19 Oca 2038 03:14:07 GMT arasındadır. (Bu tarih değerleri aynı zamanda en küçük ve en büyük 32-bit işaretli tamsayıları temsil etmektedir.) Bununla birikte, PHP 5.1.0'den önce bu aralık bazı sistemlerde 01-01-1970 ile 19-01-2038 arasıyla sınırlıydı. (ör: Windows).
5.1.0 | Zaman dilimi hatalarında artık E_STRICT ve E_NOTICE çıktılanıyor.
5.1.1 | Standart tarih/zaman biçimleri için, biçim değiştirgesinde kullanılabilecek yararlı sabitler devreye girdi.

Örnekler

Örnek 1 - date() örnekleri

<?php
// varsayılan zaman dilimini ayarla. PHP 5.1'den beri kullanılabilir.
date_default_timezone_set('UTC');

// Şöyle bir şey basar: Monday
echo date("l");

// Şöyle bir şey basar: Monday 8th of August 2005 03:12:46 PM
echo date('l jS \of F Y h:i:s A');

// Şöyle bir şey basar: July 1, 2000 is on a Saturday
echo "July 1, 2000 is on a " . date("l", mktime(0, 0, 0, 7, 1, 2000));

/* biçim değiştirgesi için sabit kullanımı*/
// Şöyle bir şey basar: Mon, 15 Aug 2005 15:12:46 UTC
echo date(DATE_RFC822);

// Şöyle bir şey basar: 2000-07-01T00:00:00+00:00
echo date(DATE_ATOM, mktime(0, 0, 0, 7, 1, 2000));
?>

Biçim dizgesinin içinde tanınan bir karakterin önüne bir tersbölü imi koyarak yorumlanmasını engelleyebilirsiniz. Eğer tersbölülü karakter zaten özel bir dizilimi ifade ediyorsa, bir tane daha tersbölü karakterine ihtiyacınız olacaktır.

Örnek 2 - date() işlevinde önceleme karakterleri

<?php
// Şöyle bir şey basar: Wednesday the 15th
echo date("l \\t\h\e jS");
?>

date() ve mktime() işlevleri birlikte, geçmiş ya da gelecek zamanın bulunmasında kullanılabilir.

Örnek 3 - date() ve mktime() örneği

<?php
$yarın  = mktime(0, 0, 0, date("m")  , date("d")+1, date("Y"));
$geçenay = mktime(0, 0, 0, date("m")-1, date("d"),   date("Y"));
$gelecekyıl = mktime(0, 0, 0, date("m"),   date("d"),   date("Y")+1);
?>

Bilginize:

Bu kullanım, yaz saati uygulamasından dolayı, bir zaman damgasına basitçe saniye, gün ve ay ekleme veya çıkartma işlemlerinden daha güvenilirdir.

Bazı date() işlevi biçimlendirme örnekleri. Diğer öncelenen karakterlerin, geçerli bir özel anlama sahip olabileceklerinden istenmeyen sonuçlara neden olacağını ve gelecekteki PHP sürümlerinde kullanılmak üzere tahsis edilebileceklerini dikkate alın. Önceleme yaparken \n gibi özel karakterlerin oluşmasını önlemek için dizgeyi tek tırnaklar arasına almayı unutmayın.

Örnek 4 - date() Biçemlemesi

<?php
// Bugünün; March 10th, 2001, 5:16:18 pm olduğunu ve
// Mountain Standard Time (MST) Zaman Diliminde olduğumuzu varsayıyoruz

$bugün = date("F j, Y, g:i a");                 // March 10, 2001, 5:16 pm
$bugün = date("m.d.y");                         // 03.10.01
$bugün = date("j, n, Y");                       // 10, 3, 2001
$bugün = date("Ymd");                           // 20010310
$bugün = date('h-i-s, j-m-y, it is w Day');     // 05-16-18, 10-03-01, 1631 1618 6 Satpm01
$bugün = date('\i\t \i\s \t\h\e jS \d\a\y.');   // it is the 10th day.
$bugün = date("D M j G:i:s T Y");               // Sat Mar 10 17:16:18 MST 2001
$bugün = date('H:m:s \m \i\s\ \m\o\n\t\h');     // 17:03:18 m is month
$bugün = date("H:i:s");                         // 17:16:18
?>

Tarihi farklı dillerde biçimlendirmek için, date()
işlevi yerine setlocale() ve
strftime() işlevini kullanmalısınız.

Notlar

Bilginize:

Tarihin dizge gösteriminden zaman damgası üretirken, strtotime() işlevini kullanabilirsiniz. Ayrıca, bazı veritabanları girilen zaman damgalarını kendi biçimine çeviren işlevlere sahiptir (MySQL'in » UNIX_TIMESTAMP işlevi gibi).

İpucu

PHP 5.1 sürümünden beri istek başlangıcının zaman damgası $_SERVER['REQUEST_TIME'] değişkeniyle tanımlanmaktadır.

Ayrıca Bakınız

  • gmdate() - Bir tarih/saati GMT/UTC tarih/saati olarak biçemler
  • idate() - Yerel zamanı/tarihi tamsayı olarak biçimlendirir
  • getdate() - Tarih/zaman bilgisi getirir
  • getlastmod() - Geçerli sayfanın son değişiklik zamanını döndürür
  • mktime() - Bir tarih için Unix zaman damgasını döndürür
  • strftime() - Format a local time/date according to locale settings
  • time() - Geçerli Unix zaman damgasını döndürür
  • Öntanımlı Tarih/Saat Sabitleri

date_timezone_set
getdate
Tarih ve Zaman İşlevleri


Tarih/zaman bilgisi getirir

date
gettimeofday
Tarih ve Zaman İşlevleri
PHP Manual

getdate

(PHP 4, PHP 5, PHP 7)

getdate — Tarih/zaman bilgisi getirir

Açıklama

array getdate ([ int $zaman_damgası = time() ] )

Değiştirgeyle çağrılmışsa zaman_damgası'na karşılık olan tarih bilgisini bir ilişkisel dizi olarak döndürür. Değiştirgesiz çağrılmışsa dönen değer o anın yerel zamanına göre olur.

Değiştirgeler

zaman_damgası

Seçimlik zaman_damgası değiştirgesi integer türünde bir Unix zaman damgası olup belirtilmediği takdirde yerel zaman kullanılır. Başka bir deyişle, time() işlevinden dönen değer öntanımlıdır.

Dönen Değerler

zaman_damgası'na karşılık olan tarih bilgisini bir ilişkisel dizi olarak döndürür. İlişkisel dizide döndürülen öğeler aşağıdaki gibidir:

İlişkisel diziyle döndürülen anahtarlar
Anahtar | Açıklama | Örnek dönüş değerleri
"seconds" | Saniyelerin sayısal gösterimi | 0'dan 59'a kadar
"minutes" | Dakikaların sayısal gösterimi | 0'dan 59'a kadar
"hours" | Saatlerin sayılsal gösterimi | 0'dan 23'e kadar
"mday" | Ayın günlerinin sayısal gösterimi | 1'den 31'e kadar
"wday" | Haftanın günlerinin sayılsal gösterimi | (Pazar için) 0'dan (Cumartesi için) 6'ya kadar
"mon" | Ayın sayısal gösterimi | 1 'den 12'ye kadar
"year" | Yılın 4 haneli sayısal tam gösterimi | Örnek: 1999 ya da 2003 gibi
"yday" | Yılın gününün sayısal gösterimi | 0'dan 365'e kadar
"weekday" | Haftanın gününün metinsel tam gösterimi | Sunday'dan Saturday'ye
"month" | Ayın metinsel tam gösterimi, Ocak ya da Mart gibi | January'dan December'a kadar
0 | Saniyeler, Unix Zaman Başlangıcından itibaren, time() işlevi tarafından döndürülen ve date() işleviyle kullanılan değerlerle benzerdir. | Sisteme Bağımlı, genellikle -2147483648 ile 2147483647 arasında.

Örnekler

Örnek 1 - getdate() örneği

<?php
$bugun = getdate();
print_r($bugun);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [seconds] => 40
    [minutes] => 58
    [hours]   => 21
    [mday]    => 17
    [wday]    => 2
    [mon]     => 6
    [year]    => 2003
    [yday]    => 167
    [weekday] => Salı
    [month]   => Haziran
    [0]       => 1055901520
)

Ayrıca Bakınız

  • date() - Yerel tarihi/saati biçimlendirir
  • idate() - Yerel zamanı/tarihi tamsayı olarak biçimlendirir
  • time() - Geçerli Unix zaman damgasını döndürür
  • setlocale() - Yereli ayarlar

date
gettimeofday
Tarih ve Zaman İşlevleri


Geçerli zamanı getirir

getdate
gmdate
Tarih ve Zaman İşlevleri
PHP Manual

gettimeofday

(PHP 4, PHP 5, PHP 7)

gettimeofday — Geçerli zamanı getirir

Açıklama

mixed gettimeofday ([ bool $sayı_döndür ] )

gettimeofday(2) işlevinin arayüzüdür. Sistem çağrısıdan döndürülmüş veriyi içeren bir ilişkisel dizi döndürür.

Değiştirgeler

sayı_döndür

TRUE olarak ayarlanmışsa, bir dizi yerine bir gerçek sayı döndürür.

Dönen Değerler

Varsayılan durumda değer array türünden döner. Eğer sayı_döndür değiştirgesi TRUE ise float türünde bir değerle döner.

Dizi anahtarları:

  • "sec" - Unix Zaman Başlangıcından itibaren geçen saniye sayısı.
  • "usec" - mikrosaniye
  • "minuteswest" - Greenwich'in batı saniyeleri
  • "dsttime" - yaz saati düzeltmesi

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.0 | sayı_döndür değiştirgesi eklendi.

Örnekler

Örnek 1 - gettimeofday() örneği

<?php
print_r(gettimeofday());

echo gettimeofday(true);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [sec] => 1073504408
    [usec] => 238215
    [minuteswest] => 0
    [dsttime] => 1
)

1073504408.23910

getdate
gmdate
Tarih ve Zaman İşlevleri


Bir tarih/saati GMT/UTC tarih/saati olarak biçemler

gettimeofday
gmmktime
Tarih ve Zaman İşlevleri
PHP Manual

gmdate

(PHP 4, PHP 5, PHP 7)

gmdate — Bir tarih/saati GMT/UTC tarih/saati olarak biçemler

Açıklama

string gmdate ( string $biçem [, int $zaman_damgası ] )

Zamanı, Greenwich Saatiyle (GMT) döndürmesi dışında tıpkı date() işlevi gibi çalışır.

Değiştirgeler

biçim

Zaman çıktısının biçimi string türündendir. Biçimlendirme seçenekleri için date() işlevine bakınız.

zaman_damgası

Seçimlik zaman_damgası değiştirgesi integer türünde bir Unix zaman damgası olup belirtilmediği takdirde yerel zaman kullanılır. Başka bir deyişle, time() işlevinden dönen değer öntanımlıdır.

Dönen Değerler

Biçimlendirilmiş tarih dizgesi döndürür. Eğer zaman_damgası değiştirgesi için sayısal değer kullanılmamışsa, FALSE döndürür ve E_WARNING seviyesinde bir hata çıktılar.

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.0 | Zaman damgasının geçerlilik aralığı, genellikle Cum, 13 Ara 1901 20:45:54 GMT ile Per, 19 Oca 2038 03:14:07 GMT arasındadır. (Bu tarih değerleri aynı zamanda en küçük ve en büyük 32 bitlik işaretli tamsayıları temsil etmektedir.) Bununla birikte, PHP 5.1.0'den önce bu aralık bazı sistemlerde (ör: Windows) 01-01-1970 ile 19-01-2038 arasıyla sınırlıdır.
5.1.1 | biçem değiştirgesinde kullanılabilecek standart tarih/zaman biçem sabitleri kullanıma girdi.

Örnekler

Örnek 1 - gmdate() örneği

Aşağıdaki betik Türkiye'de (GMT +0200) çalıştırılsaydı ilk çıktı "01 Oca 1998 00:00:00", ikinci çıktı "31 Ara 1997 22:00:00" olurdu.

<?php
echo date("d M Y H:i:s", mktime(0, 0, 0, 1, 1, 1998));
echo gmdate("d M Y H:i:s", mktime(0, 0, 0, 1, 1, 1998));
?>

Ayrıca Bakınız

  • date() - Yerel tarihi/saati biçimlendirir
  • mktime() - Bir tarih için Unix zaman damgasını döndürür
  • gmmktime() - Bir GMT tarihi için Unix zaman damgasını döndürür
  • strftime() - Format a local time/date according to locale settings

gettimeofday
gmmktime
Tarih ve Zaman İşlevleri


Bir GMT tarihi için Unix zaman damgasını döndürür

gmdate
gmstrftime
Tarih ve Zaman İşlevleri
PHP Manual

gmmktime

(PHP 4, PHP 5, PHP 7)

gmmktime — Bir GMT tarihi için Unix zaman damgasını döndürür

Açıklama

 int gmmktime
  ([ int $saat = gmdate("H")
 [, int $dakika = gmdate("i")
 [, int $saniye = gmdate("s")
 [, int $ay = gmdate("n")
 [, int $gün = gmdate("j")
 [, int $yıl = gmdate("Y")
 [, int $ysu_var = -1
]]]]]]] )

Aktarılan değiştirgelerin bir GMT tarihini belirtmesi dışında tıpkı mktime() işlevi gibidir. gmmktime() işlevi kendi içinde mktime() işlevini kullanır ve sadece türetilen yerel zamanda geçerli zamanlar kullanılabilir.

mktime() işlevindeki gibi, değiştirgeler sağdan sola sıralıdır. Böylece belirtilmeyen değiştirge için geçerli GMT zamanının kullanılabilmesi sağlanmıştır.

Değiştirgeler

saat

Saat

dakika

Dakika

saniye

Saniye-

Ay

Ay

Gün

Gün

Yıl

Yıl

ysu_var

Değiştirgeler daima GMT zamanını temsil eder. ysu_var değiştirgesinin sonuca etkisi yoktur.

Dönen Değerler

integer türünden Unix zaman damgası döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.0 | PHP 5.1.0 sürümünden beri, ysu_var değiştirgesinin kullanılması önerilmemektedir. Sonuç olarak, yerine yeni zaman dilimi özellikleri kullanılmalıdır.

Örnekler

Örnek 1 - Windows üzerinde gmmktime() işlevi

<?php
gmmktime(0, 0, 0, 1, 1, 1970); // GMT ve batıda geçerli, doğuda geçersiz
?>

Ayrıca Bakınız

  • mktime() - Bir tarih için Unix zaman damgasını döndürür
  • date() - Yerel tarihi/saati biçimlendirir
  • time() - Geçerli Unix zaman damgasını döndürür

gmdate
gmstrftime
Tarih ve Zaman İşlevleri


Yerel ayarlara göre tarih ve saati, GMT/UTC türüne çevirir

gmmktime
idate
Tarih ve Zaman İşlevleri
PHP Manual

gmstrftime

(PHP 4, PHP 5, PHP 7)

gmstrftime — Yerel ayarlara göre tarih ve saati, GMT/UTC türüne çevirir

Açıklama

string gmstrftime ( string $biçem [, int $zaman_damgası = time() ] )

Zamanı, Greenwich Saatiyle (GMT) döndürmesi dışında tıpkı strftime() işlevi gibi davranır. Örneğin, Doğu Standart Zamanınında (GMT -0500) çalıştırıldığında, aşağıdaki örneğin ilk satırı "Ara 31 1998 20:00:00" basarken ikinci satırı "Oca 01 1999 01:00:00" basar.

Değiştirgeler

biçem

Açıklama için strftime() işlevine bakınız.

zaman_damgası

Seçimlik zaman_damgası değiştirgesi integer türünde bir Unix zaman damgası olup belirtilmediği takdirde yerel zaman kullanılır. Başka bir deyişle, time() işlevinden dönen değer öntanımlıdır.

Dönen Değerler

İstenilen biçime göre verilen zaman_damgası değiştirgesini ya da zaman damgası değiştirgesi kullanılmamışsa yerel zamanı; biçimlendirilmiş dizge olarak döndürür. Ay ve hafta günlerinin isimleri ve diğer dile bağımlı dizgelerle ilgili geçerli yereller setlocale() işlevi ile ayarlanabilir.

Örnekler

Örnek 1 - gmstrftime() örneği

<?php
setlocale(LC_TIME, 'en_US');
echo strftime("%b %d %Y %H:%M:%S", mktime(20, 0, 0, 12, 31, 98)) . "\n";
echo gmstrftime("%b %d %Y %H:%M:%S", mktime(20, 0, 0, 12, 31, 98)) . "\n";
?>

Ayrıca Bakınız

  • strftime() - Format a local time/date according to locale settings

gmmktime
idate
Tarih ve Zaman İşlevleri


Yerel zamanı/tarihi tamsayı olarak biçimlendirir

gmstrftime
localtime
Tarih ve Zaman İşlevleri
PHP Manual

idate

(PHP 5, PHP 7)

idate — Yerel zamanı/tarihi tamsayı olarak biçimlendirir

Açıklama

int idate ( string $biçem [, int $zaman_damgası = time() ] )

zaman_damgası ile belirtilen zaman için biçem dizgesine göre biçemlenmiş bir sayı döndürür. zaman_damgası belirtilmemişse time() işlevinin çıktısı öntanımlıdır.

date() işlevinden farklı olarak, idate() işlevi biçem dizgesi olarak tek bir karakter kabul eder.

Değiştirgeler

biçem

biçim değiştirgesinde aşağıdaki karakterlerden biri belirtilebilir
biçem karakterleri | Açıklama
B | Swatch Ritim/İnternet Saati
d | Ayın günleri
h | Saat (12 saatlik gösterim)
H | Saat (24 saatlik gösterim)
i | Dakika
I (büyük ı) | Yaz Saati Uygulaması etkinleştirilmişse 1, diğer durumlarda 0 döndürür
L (büyük l) | artık yıl için 1, değilse 0 döndürür
m | Ayın sayısal dengi
s | Saniye
t | Şimdiki ayın günleri
U | Unix Zaman Başlangıcından (1 Ocak 1970 00:00:00 UTC) beri geçen saniye sayısı; time() işlevinin çıktısına eşdeğerdir.
w | Haftanın günü (Pazar için 0)
W | ISO-8601 standardına göre yılın hafta numarası, haftaların başlangıcı Pazartesi'dir
y | Yıl (1 yada 2 karakter - aşağıya bakınız)
Y | Yıl (4 haneli)
z | Yılın günü
Z | Sanile olarak zaman dilimi

zaman_damgası

Seçimlik zaman_damgası değiştirgesi integer türünde bir Unix zaman damgası olup belirtilmediği takdirde yerel zaman kullanılır. Başka bir deyişle, time() işlevinden dönen değer öntanımlıdır.

Dönen Değerler

integer türünde bir değer döner.

idate() işlevi daima integer türünde değer döndürse de bu değerler "0" ile başlayamaz. idate() işlevi beklediğinizden daha az karakter döndürebilir. Aşağıdaki örneğe bakınız.

Hatalar/İstisnalar

Bir tarih/zaman işlevine yapılan her çağrı eğer zaman dilimi ayarı geçerli değilse bir E_NOTICE üretir. Ve/veya eğer sistem ayarları veya TZ ortam değişkeni kullanılıyorsa bir E_STRICT veya bir E_WARNING iletisi üretir. Ayrıca bakınız: date_default_timezone_set()

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.0 | Zaman dilimi hatalarında artık E_STRICT ve E_NOTICE çıktılanıyor.

Örnekler

Örnek 1 - idate() örneği

<?php
$timestamp = strtotime('1st January 2004'); //1072915200

// Yılı iki haneli basması gerekirse de
// başında "0" olmadan sadece "4" basar
echo idate('y', $timestamp);
?>

Ayrıca Bakınız

  • date() - Yerel tarihi/saati biçimlendirir
  • getdate() - Tarih/zaman bilgisi getirir
  • time() - Geçerli Unix zaman damgasını döndürür

gmstrftime
localtime
Tarih ve Zaman İşlevleri


Yerel zamanı getirir

idate
microtime
Tarih ve Zaman İşlevleri
PHP Manual

localtime

(PHP 4, PHP 5, PHP 7)

localtime — Yerel zamanı getirir

Açıklama

array localtime ([ int $zamandamgası = time() [, bool $ilişkisel_mi = false ]] )

localtime() işlevi, standart C işlev çağrısı olan localtime tarafından döndürülen yapıya eşdeğer bir dizi döndürür.

Değiştirgeler

zaman_damgası

Seçimlik zaman_damgası değiştirgesi integer türünde bir Unix zaman damgası olup belirtilmediği takdirde yerel zaman kullanılır. Başka bir deyişle, time() işlevinden dönen değer öntanımlıdır.

ilişkisel_mi

Eğer değiştirge FALSE olarak ayarlanmış ya da kullanılmamışsa, sayısal indisli bir dizi döndürür. Eğer değiştirge TRUE olarak ayarlanmışsa localtime() işlevi standart C işlevi localtime tarafından döndürülen yapıyı farklı öğe isimleriyle indislenmiş olarak bir ilişkisel dizi olarak döndürür. İlişkisel dizinin farklı öğe isimleri aşağıdaki gibidir:

  • "tm_sec" - saniye
  • "tm_min" - dakika
  • "tm_hour" - saat
  • "tm_mday" - ayın günleri Aylar, 0'dan (Ocak) 11'e (Aralık) ve haftanın günleri 0'dan (Paz) 6'ya (Cmt).
  • "tm_mon" - yılın ayları, Ocak için 0'dan başlar
  • "tm_year" - Yıllar, başlangıç 1900 kabul edilir
  • "tm_wday" - Haftanın günleri
  • "tm_yday" - Yılın günleri
  • "tm_isdst" - Yaz saati uygulaması bilgisi

Hatalar/İstisnalar

Bir tarih/zaman işlevine yapılan her çağrı eğer zaman dilimi ayarı geçerli değilse bir E_NOTICE üretir. Ve/veya eğer sistem ayarları veya TZ ortam değişkeni kullanılıyorsa bir E_STRICT veya bir E_WARNING iletisi üretir. Ayrıca bakınız: date_default_timezone_set()

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.0 | Zaman dilimi hatalarında artık E_STRICT ve E_NOTICE çıktılanıyor.

Örnekler

Örnek 1 - localtime() örneği

<?php
$localtime = localtime();
$localtime_assoc = localtime(time(), true);
print_r($localtime);
print_r($localtime_assoc);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [0] => 24
    [1] => 3
    [2] => 19
    [3] => 3
    [4] => 3
    [5] => 105
    [6] => 0
    [7] => 92
    [8] => 1
)

Array
(
    [tm_sec] => 24
    [tm_min] => 3
    [tm_hour] => 19
    [tm_mday] => 3
    [tm_mon] => 3
    [tm_year] => 105
    [tm_wday] => 0
    [tm_yday] => 92
    [tm_isdst] => 1
)

idate
microtime
Tarih ve Zaman İşlevleri


Geçerli Unix zaman damgasını mikrosaniye olarak döndürür

localtime
mktime
Tarih ve Zaman İşlevleri
PHP Manual

microtime

(PHP 4, PHP 5, PHP 7)

microtime — Geçerli Unix zaman damgasını mikrosaniye olarak döndürür

Açıklama

mixed microtime ([ bool $gerçek_sayı ] )

microtime() işlevi geçerli Unix zaman damgasını mikrosaniye cinsinden döndürür. Bu işlev sadece gettimeofday() sistem çağrısını destekleyen işletim sistemlerinde geçerlidir.

Değiştirgeler

gerçek_sayı

İşlev, isteğe bağlı olarak değiştirgesiz çağırıldığında; "msan. san." dizgesini döndürür. 'san.' geçerli zamanın Unix Zamam Başlangıcından (1 Ocak 1970 0:00:00 GMT) itibaren hesaplanan saniyeyi ve 'msan.' ise mikrosaniye kısmını belirtir. Dizgenin iki kısmı da saniye cinsindendir.

İsteğe bağlı kullanılan bu değiştirgeyle TRUE aktarıldığında, saniyeler float türünde döndürülür.

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.0 | gerçek_sayı değiştirgesi eklendi.

Örnekler

Örnek 1 - microtime() ile zamanlama betiği

<?php
/**
 * PHP 5 davranışını taklit eden basit bir işlev
 */
function microtime_float()
{
    list($usec, $sec) = explode(" ", microtime());
    return ((float)$usec + (float)$sec);
}

$sure_baslangici = microtime_float();

// Biraz bekle
usleep(100);

$sure_bitimi = microtime_float();
$sure = $sure_bitimi - $sure_baslangici;

echo "Bekleme süresi: $sure saniye\n";
?>

Örnek 2 - PHP 5'de zamanlama betiği

<?php
$sure_baslangici = microtime(true);

// Biraz bekle
usleep(100);

$sure_bitimi = microtime(true);
$sure = $sure_bitimi - $sure_baslangici;

echo "Bekleme süresi: $sure saniye.\n";
?>

Ayrıca Bakınız

  • time() - Geçerli Unix zaman damgasını döndürür

localtime
mktime
Tarih ve Zaman İşlevleri


Bir tarih için Unix zaman damgasını döndürür

microtime
strftime
Tarih ve Zaman İşlevleri
PHP Manual

mktime

(PHP 4, PHP 5, PHP 7)

mktime — Bir tarih için Unix zaman damgasını döndürür

Açıklama

 int mktime
  ([ int $saat = date("H")
 [, int $dakika = date("i")
 [, int $saniye = date("s")
 [, int $ay = date("n")
 [, int $gün = date("j")
 [, int $yıl = date("Y")
 [, int $ysu_var = -1
]]]]]]] )

Verilen değiştirge düzenine göre Unix zaman damgasını döndürür. Bu zaman damgası, Unix Zaman Başlangıcı (1 Ocak 1970 00:00:00 GMT) ile belirtilen zaman arasında geçen süreyi uzun tamsayı türünde saniye olarak belirtir.

Değiştirgeler sağdan sola sıralıdır; böylece belirtilmeyen bir değiştirge yerine yerel tarih ve zamana göre geçerli değerin kullanılması sağlanmıştır.

Notlar

Bilginize:

PHP 5.1'den itibaren, mktime() değiştirgesiz çağrıldığına bir E_STRICT uyarısı çıktılamaktadır. Böyle durumlarda time() işlevini kullanmalısınız.

Değiştirgeler

saat

Saat sayısı.

dakika

Dakika sayısı.

saniye

Son dakikanın geçen saniye sayısı.

ay

Ay sayısı.

gün

Gün sayısı.

yıl

Yıl sayısı, iki ya da dört hane olabilir. 0-69 değerleri arasında olanlar 2000-2069 ile ve 70-100 arasındaki değerler ise 1970-2000 yıllarıyla eşleşir. Sistemlerdeki time_t türü 32 bit işaretli tamsayı türüyle belirtilmiştir ve günümüzde çok kullanılmaktadır. yıl değiştirgesi için geçerli aralık 1901 ve 2038 arasındadır. Bununla birlikte, PHP 5.1.0 sürümünden önce bu aralık bazı sistemlerde 1970 ve 2038 arasında sınırlıydı (ör. Windows).

ysu_var

Bu değiştirge, yaz saati uygulaması varsa 1'e yoksa 0'a ya da yaz saati uygulması olup olmadığının bilinmediği durumlarda varsayılan değere yani -1'e ayarlanmalıdır. Bilinmeyen durumlarda PHP bunu çözümleyecektir. Bu beklenmeyen sonuçlara (fakat yanlış olmayan) neden olur. Bazı zamanlarda, PHP çalışırken YSU etkinleştirildiğinde ya da ysu_var değiştirgesi 1'e ayarlandığında zaman geçersiz olur. Örneğin, eğer saat 2:00'de YSU etkinleştirilirse, 2:00 ve 3:00 arasındaki tüm zaman geçersiz olacak ve mktime() işlevi anlamsız (genellikle negatif) bir değerle dönecektir. Bazı sistemlerde (ör. Solaris 8) YSU gece yarısında etkinleşir. YSU etkinleştiğinde saat 0:30 ise, saat bir önceki günün 23:30'u olarak değerlendirilecektir.

Bilginize:

PHP 5.1.0 sürümünden beri, bu değiştirgenin kullanılması önerilmemektedir. Sonuç olarak, yerine yeni zaman dilimi özellikleri kullanılmalıdır.

Dönen Değerler

mktime() işlevi verilen değiştirgelerden elde edilen Unix zaman damgası döndürür. Eğer değiştirge geçersiz ise işlev FALSE değeriyle döner (PHP 5.1 sürümünden önce -1 dönerdi).

Hatalar/İstisnalar

Bir tarih/zaman işlevine yapılan her çağrı eğer zaman dilimi ayarı geçerli değilse bir E_NOTICE üretir. Ve/veya eğer sistem ayarları veya TZ ortam değişkeni kullanılıyorsa bir E_STRICT veya bir E_WARNING iletisi üretir. Ayrıca bakınız: date_default_timezone_set()

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | Artık mktime() işlevi, ysu_var değiştirgesi kullanılırsa E_DEPRECATED uyarısı vermektedir.
5.1.0 | ysu_var değiştirgesinin kullanımı artık önerilmemektedir. İşlev hata durumunda -1 yerine, FALSE değeri döndürür olmuştur. İşlev, yıl, ay ve gün değiştirgelerinde sıfır kabul edecek şekilde düzeltilmiştir.
5.1.0 | mktime() değiştirgesiz çağrıldığına bir E_STRICT uyarısı çıktılamaktadır. Böyle durumlarda time() işlevini kullanmalısınız.
5.1.0 | Zaman dilimi hatalarında artık E_STRICT ve E_NOTICE çıktılanıyor.

Örnekler

Örnek 1 - Basit bir mktime() örneği

<?php
// Öntanımlı zaman dilimini belirtelim. PHP 5.1'den beri kullanılabiliyor.
date_default_timezone_set('UTC');

echo "July 1, 2000 is on a " . date("l", mktime(0, 0, 0, 7, 1, 2000));
// Çıktısı: July 1, 2000 is on a Saturday

echo date('c', mktime(1, 2, 3, 4, 5, 2006));
// Şöyle bir şey basar: 2006-04-05T01:02:03+00:00
?>

Örnek 2 - mktime() örneği

mktime() işlevi tarih hesaplamaları ve geçerlilik denetimi için kullanışlıdır. Aralık dışına çıkan değerleri (ayın 32'si gibi) özdevinimli olarak doğru hesaplar. Örneğin, aşağıdaki satırların üreteceği dizge "Jan-01-1998" olacaktır.

<?php
echo date("M-d-Y", mktime(0, 0, 0, 12, 32, 1997));
echo date("M-d-Y", mktime(0, 0, 0, 13, 1, 1997));
echo date("M-d-Y", mktime(0, 0, 0, 1, 1, 1998));
echo date("M-d-Y", mktime(0, 0, 0, 1, 1, 98));
?>

Örnek 3 - Gelecek ayın son günü

Verilen herhangi bir ayın son günü, gelecek ayın -1'inci değil 0'ıncı günü olarak ifade edilebilir. Aşağıdaki iki örnek de "2000 Şubat'ının son günü: 29" dizgesi üretilecektir.

<?php
$songün = mktime(0, 0, 0, 3, 0, 2000);
echo strftime("2000 Şubat'ının son günü: %d", $songün);
$songün = mktime(0, 0, 0, 4, -31, 2000);
echo strftime("2000 Şubat'ının son günü: %d", $songün);
?>

Notlar

Dikkat

PHP 5.1.0 sürümünden önce, negatif zaman damgaları bilinen Windows sürümleri altında ve diğer benzer sistemlerde desteklemiyordu. Bundan dolayı, geçerli yılların aralığı 1970 ile 2038 arasında sınırlıydı.

Ayrıca Bakınız

  • gmmktime() - Bir GMT tarihi için Unix zaman damgasını döndürür
  • date() - Yerel tarihi/saati biçimlendirir
  • time() - Geçerli Unix zaman damgasını döndürür

microtime
strftime
Tarih ve Zaman İşlevleri


Format a local time/date according to locale settings

mktime
strptime
Tarih ve Zaman İşlevleri
PHP Manual

strftime

(PHP 4, PHP 5, PHP 7)

strftime — Format a local time/date according to locale settings

Açıklama

string strftime ( string $format [, int $timestamp = time() ] )

Format the time and/or date according to locale settings. Month and weekday names and other language-dependent strings respect the current locale set with setlocale().

Not all conversion specifiers may be supported by your C library, in which case they will not be supported by PHP's strftime(). Additionally, not all platforms support negative timestamps, so your date range may be limited to no earlier than the Unix epoch. This means that %e, %T, %R and, %D (and possibly others) - as well as dates prior to Jan 1, 1970 - will not work on Windows, some Linux distributions, and a few other operating systems. For Windows systems, a complete overview of supported conversion specifiers can be found at » MSDN.

Değiştirgeler

format

The following characters are recognized in the format parameter string
format | Description | Example returned values
Day --- ---
%a | An abbreviated textual representation of the day | Sun through Sat
%A | A full textual representation of the day | Sunday through Saturday
%d | Two-digit day of the month (with leading zeros) | 01 to 31
%e | Day of the month, with a space preceding single digits. Not implemented as described on Windows. See below for more information. | 1 to 31
%j | Day of the year, 3 digits with leading zeros | 001 to 366
%u | ISO-8601 numeric representation of the day of the week | 1 (for Monday) through 7 (for Sunday)
%w | Numeric representation of the day of the week | 0 (for Sunday) through 6 (for Saturday)
Week --- ---
%U | Week number of the given year, starting with the first Sunday as the first week | 13 (for the 13th full week of the year)
%V | ISO-8601:1988 week number of the given year, starting with the first week of the year with at least 4 weekdays, with Monday being the start of the week | 01 through 53 (where 53 accounts for an overlapping week)
%W | A numeric representation of the week of the year, starting with the first Monday as the first week | 46 (for the 46th week of the year beginning with a Monday)
Month --- ---
%b | Abbreviated month name, based on the locale | Jan through Dec
%B | Full month name, based on the locale | January through December
%h | Abbreviated month name, based on the locale (an alias of %b) | Jan through Dec
%m | Two digit representation of the month | 01 (for January) through 12 (for December)
Year --- ---
%C | Two digit representation of the century (year divided by 100, truncated to an integer) | 19 for the 20th Century
%g | Two digit representation of the year going by ISO-8601:1988 standards (see %V) | Example: 09 for the week of January 6, 2009
%G | The full four-digit version of %g | Example: 2008 for the week of January 3, 2009
%y | Two digit representation of the year | Example: 09 for 2009, 79 for 1979
%Y | Four digit representation for the year | Example: 2038
Time --- ---
%H | Two digit representation of the hour in 24-hour format | 00 through 23
%k | Hour in 24-hour format, with a space preceding single digits | 0 through 23
%I | Two digit representation of the hour in 12-hour format | 01 through 12
%l (lower-case 'L') | Hour in 12-hour format, with a space preceding single digits | 1 through 12
%M | Two digit representation of the minute | 00 through 59
%p | UPPER-CASE 'AM' or 'PM' based on the given time | Example: AM for 00:31, PM for 22:23
%P | lower-case 'am' or 'pm' based on the given time | Example: am for 00:31, pm for 22:23
%r | Same as "%I:%M:%S %p" | Example: 09:34:17 PM for 21:34:17
%R | Same as "%H:%M" | Example: 00:35 for 12:35 AM, 16:44 for 4:44 PM
%S | Two digit representation of the second | 00 through 59
%T | Same as "%H:%M:%S" | Example: 21:34:17 for 09:34:17 PM
%X | Preferred time representation based on locale, without the date | Example: 03:59:16 or 15:59:16
%z | The time zone offset. Not implemented as described on Windows. See below for more information. | Example: -0500 for US Eastern Time
%Z | The time zone abbreviation. Not implemented as described on Windows. See below for more information. | Example: EST for Eastern Time
Time and Date Stamps --- ---
%c | Preferred date and time stamp based on locale | Example: Tue Feb 5 00:45:10 2009 for February 5, 2009 at 12:45:10 AM
%D | Same as "%m/%d/%y" | Example: 02/05/09 for February 5, 2009
%F | Same as "%Y-%m-%d" (commonly used in database datestamps) | Example: 2009-02-05 for February 5, 2009
%s | Unix Epoch Time timestamp (same as the time() function) | Example: 305815200 for September 10, 1979 08:40:00 AM
%x | Preferred date representation based on locale, without the time | Example: 02/05/09 for February 5, 2009
Miscellaneous --- ---
%n A newline character ("\n") ---
%t A Tab character ("\t") ---
%% A literal percentage character ("%") ---

Maximum length of this parameter is 1023 characters.

Uyarı

Contrary to ISO-9899:1999, Sun Solaris starts with Sunday as 1. As a result, %u may not function as described in this manual.

Uyarı

Windows only:

The %e modifier is not supported in the Windows implementation of this function. To achieve this value, the %#d modifier can be used instead. The example below illustrates how to write a cross platform compatible function.

The %z and %Z modifiers both return the time zone name instead of the offset or abbreviation.

Uyarı

Mac OS X only: The %P modifier is not supported in the Mac OS X implementation of this function.

zaman_damgası

Seçimlik zaman_damgası değiştirgesi integer türünde bir Unix zaman damgası olup belirtilmediği takdirde yerel zaman kullanılır. Başka bir deyişle, time() işlevinden dönen değer öntanımlıdır.

Dönen Değerler

Returns a string formatted according format using the given timestamp or the current local time if no timestamp is given. Month and weekday names and other language-dependent strings respect the current locale set with setlocale().

Hatalar/İstisnalar

Bir tarih/zaman işlevine yapılan her çağrı eğer zaman dilimi ayarı geçerli değilse bir E_NOTICE üretir. Ve/veya eğer sistem ayarları veya TZ ortam değişkeni kullanılıyorsa bir E_STRICT veya bir E_WARNING iletisi üretir. Ayrıca bakınız: date_default_timezone_set()

As the output is dependent upon the underlying C library, some conversion specifiers are not supported. On Windows, supplying unknown conversion specifiers will result in 5 E_WARNING messages and return FALSE. On other operating systems you may not get any E_WARNING messages and the output may contain the conversion specifiers unconverted.

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.0 | Zaman dilimi hatalarında artık E_STRICT ve E_NOTICE çıktılanıyor.

Örnekler

This example will work if you have the respective locales installed in your system.

Örnek 1 strftime() locale examples

<?php
setlocale(LC_TIME, "C");
echo strftime("%A");
setlocale(LC_TIME, "fi_FI");
echo strftime(" in Finnish is %A,");
setlocale(LC_TIME, "fr_FR");
echo strftime(" in French %A and");
setlocale(LC_TIME, "de_DE");
echo strftime(" in German %A.\n");
?>

Örnek 2 ISO 8601:1988 week number example

<?php
/*     December 2002 / January 2003
ISOWk  M   Tu  W   Thu F   Sa  Su
----- ----------------------------
51     16  17  18  19  20  21  22
52     23  24  25  26  27  28  29
1      30  31   1   2   3   4   5
2       6   7   8   9  10  11  12
3      13  14  15  16  17  18  19   */

// Outputs: 12/28/2002 - %V,%G,%Y = 52,2002,2002
echo "12/28/2002 - %V,%G,%Y = " . strftime("%V,%G,%Y", strtotime("12/28/2002")) . "\n";

// Outputs: 12/30/2002 - %V,%G,%Y = 1,2003,2002
echo "12/30/2002 - %V,%G,%Y = " . strftime("%V,%G,%Y", strtotime("12/30/2002")) . "\n";

// Outputs: 1/3/2003 - %V,%G,%Y = 1,2003,2003
echo "1/3/2003 - %V,%G,%Y = " . strftime("%V,%G,%Y",strtotime("1/3/2003")) . "\n";

// Outputs: 1/10/2003 - %V,%G,%Y = 2,2003,2003
echo "1/10/2003 - %V,%G,%Y = " . strftime("%V,%G,%Y",strtotime("1/10/2003")) . "\n";

/*     December 2004 / January 2005
ISOWk  M   Tu  W   Thu F   Sa  Su
----- ----------------------------
51     13  14  15  16  17  18  19
52     20  21  22  23  24  25  26
53     27  28  29  30  31   1   2
1       3   4   5   6   7   8   9
2      10  11  12  13  14  15  16   */

// Outputs: 12/23/2004 - %V,%G,%Y = 52,2004,2004
echo "12/23/2004 - %V,%G,%Y = " . strftime("%V,%G,%Y",strtotime("12/23/2004")) . "\n";

// Outputs: 12/31/2004 - %V,%G,%Y = 53,2004,2004
echo "12/31/2004 - %V,%G,%Y = " . strftime("%V,%G,%Y",strtotime("12/31/2004")) . "\n";

// Outputs: 1/2/2005 - %V,%G,%Y = 53,2004,2005
echo "1/2/2005 - %V,%G,%Y = " . strftime("%V,%G,%Y",strtotime("1/2/2005")) . "\n";

// Outputs: 1/3/2005 - %V,%G,%Y = 1,2005,2005
echo "1/3/2005 - %V,%G,%Y = " . strftime("%V,%G,%Y",strtotime("1/3/2005")) . "\n";

?>

Örnek 3 Cross platform compatible example using the %e modifier

<?php

// Jan 1: results in: '%e%1%' (%%, e, %%, %e, %%)
$format = '%%e%%%e%%';

// Check for Windows to find and replace the %e
// modifier correctly
if (strtoupper(substr(PHP_OS, 0, 3)) == 'WIN') {
    $format = preg_replace('#(?<!%)((?:%%)*)%e#', '\1%#d', $format);
}

echo strftime($format);
?>

Örnek 4 Display all known and unknown formats.

<?php
// Describe the formats.
$strftimeFormats = array(
    'A' => 'A full textual representation of the day',
    'B' => 'Full month name, based on the locale',
    'C' => 'Two digit representation of the century (year divided by 100, truncated to an integer)',
    'D' => 'Same as "%m/%d/%y"',
    'E' => '',
    'F' => 'Same as "%Y-%m-%d"',
    'G' => 'The full four-digit version of %g',
    'H' => 'Two digit representation of the hour in 24-hour format',
    'I' => 'Two digit representation of the hour in 12-hour format',
    'J' => '',
    'K' => '',
    'L' => '',
    'M' => 'Two digit representation of the minute',
    'N' => '',
    'O' => '',
    'P' => 'lower-case "am" or "pm" based on the given time',
    'Q' => '',
    'R' => 'Same as "%H:%M"',
    'S' => 'Two digit representation of the second',
    'T' => 'Same as "%H:%M:%S"',
    'U' => 'Week number of the given year, starting with the first Sunday as the first week',
    'V' => 'ISO-8601:1988 week number of the given year, starting with the first week of the year with at least 4 weekdays, with Monday being the start of the week',
    'W' => 'A numeric representation of the week of the year, starting with the first Monday as the first week',
    'X' => 'Preferred time representation based on locale, without the date',
    'Y' => 'Four digit representation for the year',
    'Z' => 'The time zone offset/abbreviation option NOT given by %z (depends on operating system)',
    'a' => 'An abbreviated textual representation of the day',
    'b' => 'Abbreviated month name, based on the locale',
    'c' => 'Preferred date and time stamp based on local',
    'd' => 'Two-digit day of the month (with leading zeros)',
    'e' => 'Day of the month, with a space preceding single digits',
    'f' => '',
    'g' => 'Two digit representation of the year going by ISO-8601:1988 standards (see %V)',
    'h' => 'Abbreviated month name, based on the locale (an alias of %b)',
    'i' => '',
    'j' => 'Day of the year, 3 digits with leading zeros',
    'k' => 'Hour in 24-hour format, with a space preceding single digits',
    'l' => 'Hour in 12-hour format, with a space preceding single digits',
    'm' => 'Two digit representation of the month',
    'n' => 'A newline character ("\n")',
    'o' => '',
    'p' => 'UPPER-CASE "AM" or "PM" based on the given time',
    'q' => '',
    'r' => 'Same as "%I:%M:%S %p"',
    's' => 'Unix Epoch Time timestamp',
    't' => 'A Tab character ("\t")',
    'u' => 'ISO-8601 numeric representation of the day of the week',
    'v' => '',
    'w' => 'Numeric representation of the day of the week',
    'x' => 'Preferred date representation based on locale, without the time',
    'y' => 'Two digit representation of the year',
    'z' => 'Either the time zone offset from UTC or the abbreviation (depends on operating system)',
    '%' => 'A literal percentage character ("%")',
);

// Results.
$strftimeValues = array();

// Evaluate the formats whilst suppressing any errors.
foreach($strftimeFormats as $format => $description){
    if (False !== ($value = @strftime("%{$format}"))){
        $strftimeValues[$format] = $value;
    }
}

// Find the longest value.
$maxValueLength = 2 + max(array_map('strlen', $strftimeValues));

// Report known formats.
foreach($strftimeValues as $format => $value){
    echo "Known format   : '{$format}' = ", str_pad("'{$value}'", $maxValueLength), " ( {$strftimeFormats[$format]} )\n";
}

// Report unknown formats.
foreach(array_diff_key($strftimeFormats, $strftimeValues) as $format => $description){
    echo "Unknown format : '{$format}'   ", str_pad(' ', $maxValueLength), ($description ? " ( {$description} )" : ''), "\n";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Known format   : 'A' = 'Friday'            ( A full textual representation of the day )
Known format   : 'B' = 'December'          ( Full month name, based on the locale )
Known format   : 'H' = '11'                ( Two digit representation of the hour in 24-hour format )
Known format   : 'I' = '11'                ( Two digit representation of the hour in 12-hour format )
Known format   : 'M' = '24'                ( Two digit representation of the minute )
Known format   : 'S' = '44'                ( Two digit representation of the second )
Known format   : 'U' = '48'                ( Week number of the given year, starting with the first Sunday as the first week )
Known format   : 'W' = '48'                ( A numeric representation of the week of the year, starting with the first Monday as the first week )
Known format   : 'X' = '11:24:44'          ( Preferred time representation based on locale, without the date )
Known format   : 'Y' = '2010'              ( Four digit representation for the year )
Known format   : 'Z' = 'GMT Standard Time' ( The time zone offset/abbreviation option NOT given by %z (depends on operating system) )
Known format   : 'a' = 'Fri'               ( An abbreviated textual representation of the day )
Known format   : 'b' = 'Dec'               ( Abbreviated month name, based on the locale )
Known format   : 'c' = '12/03/10 11:24:44' ( Preferred date and time stamp based on local )
Known format   : 'd' = '03'                ( Two-digit day of the month (with leading zeros) )
Known format   : 'j' = '337'               ( Day of the year, 3 digits with leading zeros )
Known format   : 'm' = '12'                ( Two digit representation of the month )
Known format   : 'p' = 'AM'                ( UPPER-CASE "AM" or "PM" based on the given time )
Known format   : 'w' = '5'                 ( Numeric representation of the day of the week )
Known format   : 'x' = '12/03/10'          ( Preferred date representation based on locale, without the time )
Known format   : 'y' = '10'                ( Two digit representation of the year )
Known format   : 'z' = 'GMT Standard Time' ( Either the time zone offset from UTC or the abbreviation (depends on operating system) )
Known format   : '%' = '%'                 ( A literal percentage character ("%") )
Unknown format : 'C'                       ( Two digit representation of the century (year divided by 100, truncated to an integer) )
Unknown format : 'D'                       ( Same as "%m/%d/%y" )
Unknown format : 'E'
Unknown format : 'F'                       ( Same as "%Y-%m-%d" )
Unknown format : 'G'                       ( The full four-digit version of %g )
Unknown format : 'J'
Unknown format : 'K'
Unknown format : 'L'
Unknown format : 'N'
Unknown format : 'O'
Unknown format : 'P'                       ( lower-case "am" or "pm" based on the given time )
Unknown format : 'Q'
Unknown format : 'R'                       ( Same as "%H:%M" )
Unknown format : 'T'                       ( Same as "%H:%M:%S" )
Unknown format : 'V'                       ( ISO-8601:1988 week number of the given year, starting with the first week of the year with at least 4 weekdays, with Monday being the start of the week )
Unknown format : 'e'                       ( Day of the month, with a space preceding single digits )
Unknown format : 'f'
Unknown format : 'g'                       ( Two digit representation of the year going by ISO-8601:1988 standards (see %V) )
Unknown format : 'h'                       ( Abbreviated month name, based on the locale (an alias of %b) )
Unknown format : 'i'
Unknown format : 'k'                       ( Hour in 24-hour format, with a space preceding single digits )
Unknown format : 'l'                       ( Hour in 12-hour format, with a space preceding single digits )
Unknown format : 'n'                       ( A newline character ("\n") )
Unknown format : 'o'
Unknown format : 'q'
Unknown format : 'r'                       ( Same as "%I:%M:%S %p" )
Unknown format : 's'                       ( Unix Epoch Time timestamp )
Unknown format : 't'                       ( A Tab character ("\t") )
Unknown format : 'u'                       ( ISO-8601 numeric representation of the day of the week )
Unknown format : 'v'

Notlar

Bilginize: %G and %V, which are based on ISO 8601:1988 week numbers can give unexpected (albeit correct) results if the numbering system is not thoroughly understood. See %V examples in this manual page.

Ayrıca Bakınız

  • » Online strftime() format design tool
  • setlocale() - Yereli ayarlar
  • mktime() - Bir tarih için Unix zaman damgasını döndürür
  • strptime() - strftime işleviyle üretilen zaman ve tarihleri çözümler
  • gmstrftime() - Yerel ayarlara göre tarih ve saati, GMT/UTC türüne çevirir
  • » Open Group specification of strftime()

mktime
strptime
Tarih ve Zaman İşlevleri


strftime işleviyle üretilen zaman ve tarihleri çözümler

strftime
strtotime
Tarih ve Zaman İşlevleri
PHP Manual

strptime

(PHP 5 >= 5.1.0, PHP 7)

strptime — strftime() işleviyle üretilen zaman ve tarihleri çözümler

Açıklama

array strptime ( string $tarih , string $biçim )

strptime() işlevi çözümlenmiş tarih değiştirgesini bir diziyle döndürür. Hata durumlarındaysa FALSE değeriyle döner.

Ay, gün isimleri ve yerel ayarlarıyla ilgili dile bağımlı diğer dizgeler (LC_TIME), setlocale() işleviyle ayarlanır.

Değiştirgeler

tarih

Çözümlenen dizge (ör. strftime() işlevinden dönen değer)

biçim

tarih değiştirgesinde kullanılan biçim (ör. strftime() işlevinde kullanılanla aynı).

Biçimlendirme seçenekleri hakkında daha fazla bilgi için strftime() sayfasını okuyun.

Dönen Değerler

Dizi döndürür. Hata durumlarında FALSE değeriyle döner.

Diziyle dönen değerler
Değiştirge | Açıklama
"tm_sec" | Saniye (0-61)
"tm_min" | Dakika (0-59)
"tm_hour" | Saat (0-23)
"tm_mday" | Gün (1-31)
"tm_mon" | Ay (0-11)
"tm_year" | 1900'den itibaren yıllar
"tm_wday" | Pazar'dan itibaren hafta günleri (0-6)
"tm_yday" | Ocak 1'den itibaren günler (0-365)
"unparsed" | tarih değiştirgesinin bilinmeyen biçim değiştirgesi kullanımından dönen değer

Örnekler

Örnek 1 - strptime() örneği

<?php
$biçim = '%d/%m/%Y %H:%M:%S';
$strf = strftime($biçim);

echo "$strf\n";

print_r(strptime($strf, $biçim));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

03/10/2004 15:54:19

Array
(
    [tm_sec] => 19
    [tm_min] => 54
    [tm_hour] => 15
    [tm_mday] => 3
    [tm_mon] => 9
    [tm_year] => 104
    [tm_wday] => 0
    [tm_yday] => 276
    [unparsed] =>
)

Notlar

Bilginize: Bu işlev Windows sistemlerinde çalışmaz.

Bilginize:

"tm_sec" "artık saniyeleri" de içerir (yılda 2 saniyeye kadar). Artık saniyeler hakkında bilgi edinmek için » Wikipedia artık saniyeler makalesine bakınız.

Ayrıca Bakınız

  • strftime() - Format a local time/date according to locale settings

strftime
strtotime
Tarih ve Zaman İşlevleri


Parse about any English textual datetime description into a Unix timestamp

strptime
time
Tarih ve Zaman İşlevleri
PHP Manual

strtotime

(PHP 4, PHP 5, PHP 7)

strtotime — Parse about any English textual datetime description into a Unix timestamp

Açıklama

int strtotime ( string $time [, int $now = time() ] )

The function expects to be given a string containing an English date format and will try to parse that format into a Unix timestamp (the number of seconds since January 1 1970 00:00:00 UTC), relative to the timestamp given in now, or the current time if now is not supplied.

Each parameter of this function uses the default time zone unless a time zone is specified in that parameter. Be careful not to use different time zones in each parameter unless that is intended. See date_default_timezone_get() on the various ways to define the default time zone.

Değiştirgeler

time

Bir tarih/zaman dizgesi. Geçerli biçemler Tarih ve Zaman Biçemleri bölümünde açıklanmıştır.

now

The timestamp which is used as a base for the calculation of relative dates.

Dönen Değerler

Returns a timestamp on success, FALSE otherwise. Previous to PHP 5.1.0, this function would return -1 on failure.

Hatalar/İstisnalar

Bir tarih/zaman işlevine yapılan her çağrı eğer zaman dilimi ayarı geçerli değilse bir E_NOTICE üretir. Ve/veya eğer sistem ayarları veya TZ ortam değişkeni kullanılıyorsa bir E_STRICT veya bir E_WARNING iletisi üretir. Ayrıca bakınız: date_default_timezone_set()

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | Prior to PHP 5.3.0, relative time formats supplied to the time argument of strtotime() such as this week, previous week, last week, and next week were interpreted to mean a 7 day period relative to the current date/time, rather than a week period of Monday through Sunday.
5.3.0 | Prior to PHP 5.3.0, 24:00 was not a valid format and strtotime() returned FALSE.
5.2.7 | In PHP 5 prior to 5.2.7, requesting a given occurrence of a given weekday in a month where that weekday was the first day of the month would incorrectly add one week to the returned timestamp. This has been corrected in 5.2.7 and later versions.
5.1.0 | Now returns FALSE on failure, instead of -1.
5.1.0 | Zaman dilimi hatalarında artık E_STRICT ve E_NOTICE çıktılanıyor.
5.0.2 | In PHP 5 up to 5.0.2, "now" and other relative times are wrongly computed from today's midnight. This differs from other versions where it is correctly computed from current time.
5.0.0 | Microseconds began to be allowed, but they are ignored.

Örnekler

Örnek 1 A strtotime() example

<?php
echo strtotime("now"), "\n";
echo strtotime("10 September 2000"), "\n";
echo strtotime("+1 day"), "\n";
echo strtotime("+1 week"), "\n";
echo strtotime("+1 week 2 days 4 hours 2 seconds"), "\n";
echo strtotime("next Thursday"), "\n";
echo strtotime("last Monday"), "\n";
?>

Örnek 2 Checking for failure

<?php
$str = 'Not Good';

// previous to PHP 5.1.0 you would compare with -1, instead of false
if (($timestamp = strtotime($str)) === false) {
    echo "The string ($str) is bogus";
} else {
    echo "$str == " . date('l dS \o\f F Y h:i:s A', $timestamp);
}
?>

Notlar

Bilginize:

If the number of the year is specified in a two digit format, the values between 00-69 are mapped to 2000-2069 and 70-99 to 1970-1999. See the notes below for possible differences on 32bit systems (possible dates might end on 2038-01-19 03:14:07).

Bilginize:

The valid range of a timestamp is typically from Fri, 13 Dec 1901 20:45:54 UTC to Tue, 19 Jan 2038 03:14:07 UTC. (These are the dates that correspond to the minimum and maximum values for a 32-bit signed integer.)

Prior to PHP 5.1.0, not all platforms support negative timestamps, therefore your date range may be limited to no earlier than the Unix epoch. This means that e.g. dates prior to Jan 1, 1970 will not work on Windows, some Linux distributions, and a few other operating systems.

For 64-bit versions of PHP, the valid range of a timestamp is effectively infinite, as 64 bits can represent approximately 293 billion years in either direction.

Bilginize:

Dates in the m/d/y or d-m-y formats are disambiguated by looking at the separator between the various components: if the separator is a slash (/), then the American m/d/y is assumed; whereas if the separator is a dash (-) or a dot (.), then the European d-m-y format is assumed. If, however, the year is given in a two digit format and the separator is a dash (-, the date string is parsed as y-m-d.

To avoid potential ambiguity, it's best to use ISO 8601 (YYYY-MM-DD) dates or DateTime::createFromFormat() when possible.

Bilginize:

Using this function for mathematical operations is not advisable. It is better to use DateTime::add() and DateTime::sub() in PHP 5.3 and later, or DateTime::modify() in PHP 5.2.

Ayrıca Bakınız

  • Date and Time Formats
  • DateTime::createFromFormat() - Parses a time string according to a specified format
  • checkdate() - Miladi tarihi doğrular
  • strptime() - strftime işleviyle üretilen zaman ve tarihleri çözümler

strptime
time
Tarih ve Zaman İşlevleri


Geçerli Unix zaman damgasını döndürür

strtotime
timezone_abbreviations_list
Tarih ve Zaman İşlevleri
PHP Manual

time

(PHP 4, PHP 5, PHP 7)

time — Geçerli Unix zaman damgasını döndürür

Açıklama

int time ( void )

Unix Zaman Başlangıcından (1 Ocak 1970 00:00:00 GMT) itibaren geçen zamanı saniye cinsinden döndürür.

Örnekler

Örnek 1 - time() örneği

<?php
$gelecekHafta = time() + (7 * 24 * 60 * 60);
                   // 7 gün; 24 saat; 60 dakida; 60 saniye
echo 'Şimdi:         '. date('d-m-Y') ."\n";
echo 'Gelecek Hafta: '. date('d-m-Y', $gelecekHafta) ."\n";
// yada strtotime() işlevi ile kullanımı
echo 'Gelecek Hafta: '. date('d-m-Y', strtotime('+1 week')) ."\n";
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Şimdi:         25-03-2009
Gelecek Hafta: 01-04-2009
Gelecek Hafta: 01-04-2009

Notlar

İpucu

İstek başlangıç zamandamgası PHP 5.1'den beri $_SERVER['REQUEST_TIME'] değişkeniyle kullanımdadır.

Ayrıca Bakınız

  • date() - Yerel tarihi/saati biçimlendirir
  • microtime() - Geçerli Unix zaman damgasını mikrosaniye olarak döndürür

strtotime
timezone_abbreviations_list
Tarih ve Zaman İşlevleri


DateTimeZone::listAbbreviations işlevinin takma adıdır

time
timezone_identifiers_list
Tarih ve Zaman İşlevleri
PHP Manual

timezone_abbreviations_list

(PHP 5 >= 5.2.0, PHP 7)

timezone_abbreviations_list — DateTimeZone::listAbbreviations() işlevinin takma adıdır

Açıklama

Bu işlev, DateTimeZone::listAbbreviations() işlevinin takma adıdır.

time
timezone_identifiers_list
Tarih ve Zaman İşlevleri


DateTimeZone::listIdentifiers işlevinin takma adıdır

timezone_abbreviations_list
timezone_location_get
Tarih ve Zaman İşlevleri
PHP Manual

timezone_identifiers_list

(PHP 5 >= 5.2.0, PHP 7)

timezone_identifiers_list — DateTimeZone::listIdentifiers() işlevinin takma adıdır

Açıklama

Bu işlev, DateTimeZone::listIdentifiers() işlevinin takma adıdır.

timezone_abbreviations_list
timezone_location_get
Tarih ve Zaman İşlevleri


DateTimeZone::getLocation işlevinin takma adıdır

timezone_identifiers_list
timezone_name_from_abbr
Tarih ve Zaman İşlevleri
PHP Manual

timezone_location_get

(PHP 5 >= 5.3.0, PHP 7)

timezone_location_get — DateTimeZone::getLocation() işlevinin takma adıdır

Açıklama

Bu işlev, DateTimeZone::getLocation() işlevinin takma adıdır.

timezone_identifiers_list
timezone_name_from_abbr
Tarih ve Zaman İşlevleri


Kısaltmasından, zaman diliminin adını döndürür

timezone_location_get
timezone_name_get
Tarih ve Zaman İşlevleri
PHP Manual

timezone_name_from_abbr

(PHP 5 >= 5.1.3, PHP 7)

timezone_name_from_abbr — Kısaltmasından, zaman diliminin adını döndürür

Açıklama

string timezone_name_from_abbr ( string $kısaltma [, int $gmt_farkı = -1 [, int $ysu_var = -1 ]] )

Değiştirgeler

kısaltma

Zaman dilimi kısaltması.

gmt_farkı

Yerel saatin GMT'ye göre saniye cinsinden farkı. Varsayılan değer, kısaltma değiştirgesinin karşılığı olarak bulunan ilk zaman diliminin döndürüleceği anlamına gelen -1'dir. Yoksa, farka uyan zaman dilimi aranır ve bulunamadığı durumlarda fark ne olursa olsun bulunan ilk zaman dilimi döndürülür.

ysu_var

Yaz saati uygulaması belirteci. Eğer kısaltma değiştirgesi yoksa zaman dilimi yalnızca gmt_farkı ve ysu_var değiştirgelerine göre aranacaktır.

Dönen Değerler

Başarılı olduğunda zaman dilimini adını, başarısız olduğunda FALSE döndürür.

Örnekler

Örnek 1 - timezone_name_from_abbr() örneği

<?php
echo timezone_name_from_abbr("EET") . "\n";
echo timezone_name_from_abbr("", 3600, 0) . "\n";
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Europe/Helsinki
Europe/Paris

Ayrıca Bakınız

  • timezone_abbreviations_list() - DateTimeZone::listAbbreviations işlevinin takma adıdır

timezone_location_get
timezone_name_get
Tarih ve Zaman İşlevleri


DateTimeZone::getName işlevinin takma adıdır

timezone_name_from_abbr
timezone_offset_get
Tarih ve Zaman İşlevleri
PHP Manual

timezone_name_get

(PHP 5 >= 5.2.0, PHP 7)

timezone_name_get — DateTimeZone::getName() işlevinin takma adıdır

Açıklama

Bu işlev, DateTimeZone::getName() işlevinin takma adıdır.

timezone_name_from_abbr
timezone_offset_get
Tarih ve Zaman İşlevleri


DateTimeZone::getOffset işlevinin takma adıdır

timezone_name_get
timezone_open
Tarih ve Zaman İşlevleri
PHP Manual

timezone_offset_get

(PHP 5 >= 5.2.0, PHP 7)

timezone_offset_get — DateTimeZone::getOffset() işlevinin takma adıdır

Açıklama

Bu işlev, DateTimeZone::getOffset() işlevinin takma adıdır.

timezone_name_get
timezone_open
Tarih ve Zaman İşlevleri


DateTimeZone::__construct için takma ad

timezone_offset_get
timezone_transitions_get
Tarih ve Zaman İşlevleri
PHP Manual

timezone_open

(PHP 5 >= 5.2.0, PHP 7)

timezone_open — DateTimeZone::__construct() için takma ad

Açıklama

Bu işlev DateTimeZone::__construct() için bir takma addır.

timezone_offset_get
timezone_transitions_get
Tarih ve Zaman İşlevleri


DateTimeZone::getTransitions işlevinin takma adıdır

timezone_open
timezone_version_get
Tarih ve Zaman İşlevleri
PHP Manual

timezone_transitions_get

(PHP 5 >= 5.2.0, PHP 7)

timezone_transitions_get — DateTimeZone::getTransitions() işlevinin takma adıdır

Açıklama

Bu işlev, DateTimeZone::getTransitions() işlevinin takma adıdır.

timezone_open
timezone_version_get
Tarih ve Zaman İşlevleri


Gets the version of the timezonedb

timezone_transitions_get
HRTime
Tarih ve Zaman İşlevleri
PHP Manual

timezone_version_get

(PHP 5 >= 5.3.0, PHP 7)

timezone_version_get — Gets the version of the timezonedb

Açıklama

string timezone_version_get ( void )

Returns the current version of the timezonedb.

Dönen Değerler

Returns a string.

Örnekler

Örnek 1 Getting the timezonedb version

<?php
echo timezone_version_get();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

2009.7

Ayrıca Bakınız

  • List of Supported Timezones

timezone_transitions_get
HRTime
Tarih ve Zaman İşlevleri


High resolution timing

  • Giriş
  • Yapılandırma/Kurulum
    • Kurulum
  • Örnekler
    • Basic usage
  • HRTime\PerformanceCounter — The HRTime\PerformanceCounter class
    • HRTime\PerformanceCounter::getFrequency — Timer frequency in ticks per second
    • HRTime\PerformanceCounter::getTicks — Current ticks from the system
    • HRTime\PerformanceCounter::getTicksSince — Ticks elapsed since the given value
  • HRTime\StopWatch — The HRTime\StopWatch class
    • HRTime\StopWatch::getElapsedTicks — Get elapsed ticks for all intervals.
    • HRTime\StopWatch::getElapsedTime — Get elapsed time for all intervals.
    • HRTime\StopWatch::getLastElapsedTicks — Get elapsed ticks for the last interval.
    • HRTime\StopWatch::getLastElapsedTime — Get elapsed time for the last interval.
    • HRTime\StopWatch::isRunning — Whether the measurement is running.
    • HRTime\StopWatch::start — Start time measurement
    • HRTime\StopWatch::stop — Stop time measurement
  • HRTime\Unit — The HRTime\Unit class
timezone_version_get
Giriş
Tarih ve Saat ile İlgili Eklentiler


Giriş

The HRTime extension implements a high resolution StopWatch class. It uses the best possible APIs on different platforms which brings resolution up to nanoseconds. It also makes possible to implement a custom stopwatch using low level ticks delivered by the underlaying APIs.

HRTime
Yapılandırma/Kurulum
HRTime


Yapılandırma/Kurulum

İçindekiler

  • Kurulum
Giriş
Kurulum
HRTime


Kurulum

Bu » PECL eklentisi PHP ile gelmez.

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/hrtime.

A DLL for this PECL extension is available under » http://windows.php.net/downloads/pecl/releases/hrtime/.

Yapılandırma/Kurulum
Örnekler
Yapılandırma/Kurulum


Örnekler

İçindekiler

  • Basic usage
Kurulum
Basic usage
HRTime


Basic usage

The example illustrates the basic StopWatch class usage

Örnek 1 Measure several code blocks execution and get the total

<?php

$c = new HRTime\StopWatch;

$c->start();
/* measure this code block execution */
for ($i = 0; $i < 1024*1024; $i++);
$c->stop();
$elapsed0 = $c->getLastElapsedTime(HRTime\Unit::NANOSECOND);

/* measurement is not running here*/
for ($i = 0; $i < 1024*1024; $i++);

$c->start();
/* measure this code block execution */
for ($i = 0; $i < 1024*1024; $i++);
$c->stop();
$elapsed1 = $c->getLastElapsedTime(HRTime\Unit::NANOSECOND);

$elapsed_total = $c->getElapsedTime(HRTime\Unit::NANOSECOND);

?>
Örnekler
HRTime\PerformanceCounter
Örnekler


The HRTime\PerformanceCounter class

(PECL hrtime >= 0.4.3)

Giriş

Sınıf Sözdizimi

HRTime\PerformanceCounter {
/* Yöntemler */
public static int getFrequency ( void )
public static int getTicks ( void )
public static int getTicksSince ( integer $start )
}

İçindekiler

  • HRTime\PerformanceCounter::getFrequency — Timer frequency in ticks per second
  • HRTime\PerformanceCounter::getTicks — Current ticks from the system
  • HRTime\PerformanceCounter::getTicksSince — Ticks elapsed since the given value
Basic usage
HRTime\PerformanceCounter::getFrequency
HRTime


Timer frequency in ticks per second

HRTime\PerformanceCounter
HRTime\PerformanceCounter::getTicks
HRTime\PerformanceCounter
PHP Manual

HRTime\PerformanceCounter::getFrequency

(PECL hrtime >= 0.4.3)

HRTime\PerformanceCounter::getFrequency — Timer frequency in ticks per second

Açıklama

public static int HRTime\PerformanceCounter::getFrequency ( void )

Returns the timer frequency in ticks per second. This value is constant after the system start on almost any operating system.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns integer indicating the timer frequency.

HRTime\PerformanceCounter
HRTime\PerformanceCounter::getTicks
HRTime\PerformanceCounter


Current ticks from the system

HRTime\PerformanceCounter::getFrequency
HRTime\PerformanceCounter::getTicksSince
HRTime\PerformanceCounter
PHP Manual

HRTime\PerformanceCounter::getTicks

(PECL hrtime >= 0.6.0)

HRTime\PerformanceCounter::getTicks — Current ticks from the system

Açıklama

public static int HRTime\PerformanceCounter::getTicks ( void )

Returns the ticks count.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns integer indicating the ticks count.

HRTime\PerformanceCounter::getFrequency
HRTime\PerformanceCounter::getTicksSince
HRTime\PerformanceCounter


Ticks elapsed since the given value

HRTime\PerformanceCounter::getTicks
HRTime\StopWatch
HRTime\PerformanceCounter
PHP Manual

HRTime\PerformanceCounter::getTicksSince

(PECL hrtime >= 0.6.0)

HRTime\PerformanceCounter::getTicksSince — Ticks elapsed since the given value

Açıklama

public static int HRTime\PerformanceCounter::getTicksSince ( integer $start )

Returns the ticks count elapsed since the given start value.

Değiştirgeler

start

Starting ticks value.

Dönen Değerler

Returns integer indicating the ticks count.

HRTime\PerformanceCounter::getTicks
HRTime\StopWatch
HRTime\PerformanceCounter


The HRTime\StopWatch class

(PECL hrtime >= 0.4.3)

Giriş

Sınıf Sözdizimi

HRTime\StopWatch extends HRTime\PerformanceCounter {
/* Yöntemler */
public int getElapsedTicks ( void )
public float getElapsedTime ([ integer $unit ] )
public int getLastElapsedTicks ( void )
public float getLastElapsedTime ([ integer $unit ] )
public bool isRunning ( void )
public void start ( void )
public void stop ( void )
/* Miras alınan yöntemler */
public static int HRTime\PerformanceCounter::getFrequency ( void )
public static int HRTime\PerformanceCounter::getTicks ( void )
public static int HRTime\PerformanceCounter::getTicksSince ( integer $start )
}

İçindekiler

  • HRTime\StopWatch::getElapsedTicks — Get elapsed ticks for all intervals.
  • HRTime\StopWatch::getElapsedTime — Get elapsed time for all intervals.
  • HRTime\StopWatch::getLastElapsedTicks — Get elapsed ticks for the last interval.
  • HRTime\StopWatch::getLastElapsedTime — Get elapsed time for the last interval.
  • HRTime\StopWatch::isRunning — Whether the measurement is running.
  • HRTime\StopWatch::start — Start time measurement
  • HRTime\StopWatch::stop — Stop time measurement
HRTime\PerformanceCounter::getTicksSince
HRTime\StopWatch::getElapsedTicks
HRTime


Get elapsed ticks for all intervals.

HRTime\StopWatch
HRTime\StopWatch::getElapsedTime
HRTime\StopWatch
PHP Manual

HRTime\StopWatch::getElapsedTicks

(PECL hrtime >= 0.4.3)

HRTime\StopWatch::getElapsedTicks — Get elapsed ticks for all intervals.

Açıklama

public int HRTime\StopWatch::getElapsedTicks ( void )

Get elapsed ticks for all the previously closed intervals.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns integer indicating elapsed ticks.

HRTime\StopWatch
HRTime\StopWatch::getElapsedTime
HRTime\StopWatch


Get elapsed time for all intervals.

HRTime\StopWatch::getElapsedTicks
HRTime\StopWatch::getLastElapsedTicks
HRTime\StopWatch
PHP Manual

HRTime\StopWatch::getElapsedTime

(PECL hrtime >= 0.4.3)

HRTime\StopWatch::getElapsedTime — Get elapsed time for all intervals.

Açıklama

public float HRTime\StopWatch::getElapsedTime ([ integer $unit ] )

Get elapsed time for all the previously closed intervals.

Değiştirgeler

unit

Time unit represented by a HRTime\Unit constant. Default is HRTime\Unit::SECOND.

Dönen Değerler

Returns float indicating elapsed time.

HRTime\StopWatch::getElapsedTicks
HRTime\StopWatch::getLastElapsedTicks
HRTime\StopWatch


Get elapsed ticks for the last interval.

HRTime\StopWatch::getElapsedTime
HRTime\StopWatch::getLastElapsedTime
HRTime\StopWatch
PHP Manual

HRTime\StopWatch::getLastElapsedTicks

(PECL hrtime >= 0.4.3)

HRTime\StopWatch::getLastElapsedTicks — Get elapsed ticks for the last interval.

Açıklama

public int HRTime\StopWatch::getLastElapsedTicks ( void )

Get elapsed ticks for the previously closed interval.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns integer indicating elapsed ticks.

HRTime\StopWatch::getElapsedTime
HRTime\StopWatch::getLastElapsedTime
HRTime\StopWatch


Get elapsed time for the last interval.

HRTime\StopWatch::getLastElapsedTicks
HRTime\StopWatch::isRunning
HRTime\StopWatch
PHP Manual

HRTime\StopWatch::getLastElapsedTime

(PECL hrtime >= 0.4.3)

HRTime\StopWatch::getLastElapsedTime — Get elapsed time for the last interval.

Açıklama

public float HRTime\StopWatch::getLastElapsedTime ([ integer $unit ] )

Get elapsed time for the previously closed interval.

Değiştirgeler

unit

Time unit represented by a HRTime\Unit constant. Default is HRTime\Unit::SECOND.

Dönen Değerler

Returns float indicating elapsed time.

HRTime\StopWatch::getLastElapsedTicks
HRTime\StopWatch::isRunning
HRTime\StopWatch


Whether the measurement is running.

HRTime\StopWatch::getLastElapsedTime
HRTime\StopWatch::start
HRTime\StopWatch
PHP Manual

HRTime\StopWatch::isRunning

(PECL hrtime >= 0.4.3)

HRTime\StopWatch::isRunning — Whether the measurement is running.

Açıklama

public bool HRTime\StopWatch::isRunning ( void )

Reveals whether the measurement was started.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns boolean indicating whetehr the measurement is running.

HRTime\StopWatch::getLastElapsedTime
HRTime\StopWatch::start
HRTime\StopWatch


Start time measurement

HRTime\StopWatch::isRunning
HRTime\StopWatch::stop
HRTime\StopWatch
PHP Manual

HRTime\StopWatch::start

(PECL hrtime >= 0.4.3)

HRTime\StopWatch::start — Start time measurement

Açıklama

public void HRTime\StopWatch::start ( void )

Starts the time measurement. It has no effect if the measurement was already started. The measurement will be continued if it was previously stopped.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns void.

HRTime\StopWatch::isRunning
HRTime\StopWatch::stop
HRTime\StopWatch


Stop time measurement

HRTime\StopWatch::start
HRTime\Unit
HRTime\StopWatch
PHP Manual

HRTime\StopWatch::stop

(PECL hrtime >= 0.4.3)

HRTime\StopWatch::stop — Stop time measurement

Açıklama

public void HRTime\StopWatch::stop ( void )

Stop the time measurement for the previously started interval.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns void.

HRTime\StopWatch::start
HRTime\Unit
HRTime\StopWatch


The HRTime\Unit class

(PECL hrtime >= 0.4.3)

Giriş

Sınıf Sözdizimi

HRTime\Unit {
/* Constants */
const integer SECOND = 0 ;
const integer MILLISECOND = 1 ;
const integer MICROSECOND = 2 ;
const integer NANOSECOND = 3 ;
/* Yöntemler */
}

Öntanımlı Sabitler

HRTime\Unit::SECOND

HRTime\Unit::MILLISECOND

HRTime\Unit::MICROSECOND

HRTime\Unit::NANOSECOND

HRTime\StopWatch::stop
Dosya Sistemiyle İlgili Eklentiler
HRTime


Dosya Sistemiyle İlgili Eklentiler

  • Doğrudan G/Ç
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Doğrudan G/Ç İşlevleri
  • Dizinler
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Directory — The Directory class
    • Dizin İşlevleri
  • Fileinfo — Dosya Bilgileri
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Fileinfo İşlevleri
  • Dosya Sistemi
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Dosya Sistemi İşlevleri
  • Inotify
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Inotify İşlevleri
  • MIME Türü
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
  • Proctitle
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Proctitle İşlevleri
  • xattr
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • xattr İşlevleri
  • xdiff
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • xdiff İşlevleri
HRTime\Unit
Doğrudan G/Ç
İşlev Başvuru Kılavuzu


Doğrudan G/Ç

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Doğrudan G/Ç İşlevleri
    • dio_close — Belirtilen dosya tanıtıcısını kapatır
    • dio_fcntl — Belirtilen dosya tanıtıcısı üzerinde komut çalıştırır
    • dio_open — Belirtilen dosyayı açar ve bu dosya için bir dosya tanıtıcısı döndürür
    • dio_read — Bir dosya tanıtıcısından baytları okur
    • dio_seek — Dosya tanıtıcısında konumu bir yerden başka bir yere taşır
    • dio_stat — Belirtilen dosya tanıtıcısı hakkında durum bilgisi döndürür
    • dio_tcsetattr — Bir seri portun veri hızını ve uçbirim özniteliklerini tanımlar
    • dio_truncate — Dosya tanıtıcısındaki bayt sayısını sınırlar
    • dio_write — Veriyi (uzunluğunu isteğe bağlı olarak kırparak) dosya tanıtıcısına yazar
Dosya Sistemiyle İlgili Eklentiler
Giriş
Dosya Sistemiyle İlgili Eklentiler


Giriş

PHP, C dilinin akım G/Ç işlevlerinden (fopen(), fread(),..) daha düşük seviyeli doğrudan G/Ç işlevlerini POSIX standardında açıklandığı gibi destekler. Doğrudan G/Ç işlevleri sadece bir aygıta doğrudan erişim gerekli olduğunda kullanılmalıdır. Diğer tüm durumlarda standart Dosya Sistemi işlevleri fazlasıyla yeterlidir.

Bilginize:

Bu eklenti » PECL deposuna taşınmış olup şu sürümden itibaren PHP kaynak paketinde dağıtılmamaktatır: PHP 5.1.0.

Bu eklenti PHP 5.0.0'dan itibaren sadece Windows Platformlarında kullanılabilmektedir.

Doğrudan G/Ç
Yapılandırma/Kurulum
Doğrudan G/Ç


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Doğrudan G/Ç


Kurulum

Bu işlevlerle çalışmak için PHP paketini derleme sırasında --enable-dio seçeneği ile yapılandırmalısınız.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Özkaynak Türleri

Bu eklenti tarafından tanımlanan tek özkaynak türü, dio_open() işlevinden dönen dosya tanıtıcıdır.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

F_DUPFD (integer)

F_GETFD (integer)

F_GETFL (integer)

F_GETLK (integer)

F_GETOWN (integer)

F_RDLCK (integer)

F_SETFL (integer)

F_SETLK (integer)

F_SETLKW (integer)

F_SETOWN (integer)

F_UNLCK (integer)

F_WRLCK (integer)

O_APPEND (integer)

O_ASYNC (integer)

O_CREAT (integer)

O_EXCL (integer)

O_NDELAY (integer)

O_NOCTTY (integer)

O_NONBLOCK (integer)

O_RDONLY (integer)

O_RDWR (integer)

O_SYNC (integer)

O_TRUNC (integer)

O_WRONLY (integer)

S_IRGRP (integer)

S_IROTH (integer)

S_IRUSR (integer)

S_IRWXG (integer)

S_IRWXO (integer)

S_IRWXU (integer)

S_IWGRP (integer)

S_IWOTH (integer)

S_IWUSR (integer)

S_IXGRP (integer)

S_IXOTH (integer)

S_IXUSR (integer)

Özkaynak Türleri
Doğrudan G/Ç İşlevleri
Doğrudan G/Ç


Doğrudan G/Ç İşlevleri

İçindekiler

  • dio_close — Belirtilen dosya tanıtıcısını kapatır
  • dio_fcntl — Belirtilen dosya tanıtıcısı üzerinde komut çalıştırır
  • dio_open — Belirtilen dosyayı açar ve bu dosya için bir dosya tanıtıcısı döndürür
  • dio_read — Bir dosya tanıtıcısından baytları okur
  • dio_seek — Dosya tanıtıcısında konumu bir yerden başka bir yere taşır
  • dio_stat — Belirtilen dosya tanıtıcısı hakkında durum bilgisi döndürür
  • dio_tcsetattr — Bir seri portun veri hızını ve uçbirim özniteliklerini tanımlar
  • dio_truncate — Dosya tanıtıcısındaki bayt sayısını sınırlar
  • dio_write — Veriyi (uzunluğunu isteğe bağlı olarak kırparak) dosya tanıtıcısına yazar
Öntanımlı Sabitler
dio_close
Doğrudan G/Ç


Belirtilen dosya tanıtıcısını kapatır

Doğrudan G/Ç İşlevleri
dio_fcntl
Doğrudan G/Ç İşlevleri
PHP Manual

dio_close

(PHP 4 >= 4.2.0, PHP 5 <= 5.0.5, PHP 7)

dio_close — Belirtilen dosya tanıtıcısını kapatır

Açıklama

void dio_close ( resource $dt )

dio_close() işlevi, dt ile belirtilen dosya tanıtıcısını kapatır.

Değiştirgeler

dt

dio_open() işlevinden dönmüş bir dosya tanıtıcısı.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 - Açık bir dosya tanıtıcısının kapatılması

<?php
$fd = dio_open('/dev/ttyS0', O_RDWR);

dio_close($fd);
?>

Ayrıca Bakınız

  • dio_open() - Belirtilen dosyayı açar ve bu dosya için bir dosya tanıtıcısı döndürür

Doğrudan G/Ç İşlevleri
dio_fcntl
Doğrudan G/Ç İşlevleri


Belirtilen dosya tanıtıcısı üzerinde komut çalıştırır

dio_close
dio_open
Doğrudan G/Ç İşlevleri
PHP Manual

dio_fcntl

(PHP 4 >= 4.2.0, PHP 5 <= 5.0.5, PHP 7)

dio_fcntl — Belirtilen dosya tanıtıcısı üzerinde komut çalıştırır

Açıklama

mixed dio_fcntl ( resource $dt , int $komut [, mixed $değiştirgeler ] )

dio_fcntl() işlevi, dt dosya tanıtıcısı üzerinde komut ile belirtilen işlemi yapar. Bazı komutların gerektirdiği ek değiştirgeler değiştirgeler değiştirgesinde belirtilebilir.

Değiştirgeler

dt

dio_open() işlevinden dönmüş bir dosya tanıtıcısı.

komut

Aşağıdaki işlemlerden biri belirtilebilir:

  • F_SETLK - Dosya kilidi tanımlar veya siler. Kilit başka bir süreç tarafından tutulmuşsa işlev -1 ile döner.

  • F_SETLKW - F_SETLK gibidir, farklı olarak, kilit başka bir süreç tarafından tutulmuşsa kilit serbest kalıncaya kadar bekler.

  • F_GETLK - Birileri kilidin tutulmasını engelliyorsa dio_fcntl() işlevi (yukarıda açıklandığı gibi) bir ilişkisel dizi ile döner. Hiçbir engelleme anahtarı yoksa "tür" olarak F_UNLCK atanır.

  • F_DUPFD - değiştirgeler değerine eşit veya büyük dosya tanıtıcılarından en küçük numaralısını bulur ve bunu döndürür.

  • F_SETFL - Dosya tanıtıcılarının seçeneklerini değiştirgeler ile belirtilen değere ayarlar; bunlar, O_APPEND, O_NONBLOCK veya O_ASYNC olabilir. O_ASYNC kullanmak için PCNTL eklentisini kullanmanız gerekir.

değiştirgeler

değiştirgeler bir ilişkisel dizi olup, komut olarak F_SETLK veya F_SETLLW belirtildiğinde aşağıdaki anahtarlar belirtilebilir:

  • "start" - kilidin başlangıç konumu

  • "length" - kilitli alanın boyu; sıfır, dosyanın sonuna kadar demektir.

  • "wenth" - l_start'ın göreli olduğu yer: SEEK_SET, SEEK_END ve SEEK_CUR olabilir.

  • "type" - kilit türü: F_RDLCK (okuma kilidi), F_WRLCK (yazma kilidi) veya F_UNLCK (kilidi aç) olabilir.

Dönen Değerler

C çağrısının sonucu ile döner.

Örnekler

Örnek 1 - Bir kilidin atanması ve silinmesi

<?php

$fd = dio_open('/dev/ttyS0', O_RDWR);

if (dio_fcntl($fd, F_SETLK, Array("type"=>F_WRLCK)) == -1) {
   // dosya tanıtıcısı kilitli görünüyor
   echo "Kilit kaldırılamadı. Başka bir süreç tarafından tutuluyor.";
} else {
   echo "Kilit başarıyla atandı/silindi";
}

dio_close($fd);
?>

Notlar

Bilginize: Bu işlev Windows sistemlerinde çalışmaz.

dio_close
dio_open
Doğrudan G/Ç İşlevleri


Belirtilen dosyayı açar ve bu dosya için bir dosya tanıtıcısı döndürür

dio_fcntl
dio_read
Doğrudan G/Ç İşlevleri
PHP Manual

dio_open

(PHP 4 >= 4.2.0, PHP 5 <= 5.0.5, PHP 7)

dio_open — Belirtilen dosyayı açar ve bu dosya için bir dosya tanıtıcısı döndürür

Açıklama

resource dio_open ( string $dosyaismi , int $seçenekler [, int $kip = 0 ] )

dio_open() işlevi, C kütüphanesinin girdi/çıktı akımlarıyla ilgili işlevlerinde kullanılmak üzere belirtilen dosyayı düşük seviyede açar (gerekirse oluşturur) ve bu dosya için bir dosya tanıtıcısı döndürür.

Değiştirgeler

dosyaismi

Açılacak dosyanın yolu.

seçenekler

Aşağıdaki seçeneklerin bir birleşimi (bit seviyesinde VEYAlanmışı) olarak belirtilebilir. Bu değer, aşağıdaki diğer seçeneklere ek olarak O_RDONLY, O_WRONLYveya O_RDWR sabitlerinden birini mutlaka içermelidir.

  • O_RDONLY - Dosyayı okuma erişimli açar.

  • O_WRONLY - Dosyayı yazma erişimli açar.

  • O_RDWR -Dosyayı hem okuma hem de yazma erişimli açar.

  • O_CREAT - mevcut değilse dosyayı oluşturur.

  • O_EXCL - dosya mevcutsa ve O_CREAT ile O_EXCL birlikte belirtilmişse dosya mevcut demektir, bu durumda işlev başarısız olur.

  • O_TRUNC - dosya mevcutsa ve dosya yazmak için açılmışsa dosya içeriği sıfırlanır (dosya boyutu sıfır bayt olur).

  • O_APPEND - veri daima dosyanın sonuna yazılır.

  • O_NONBLOCK - engellenmeyen kip geçerli olur.

  • O_NOCTTY - Bir TTY aygıt dosyası açılırken işletim sisteminin açılmış dosyayı sürecin denetim uçbirimi olarak atamasını önler.

kip

seçenekler değiştirgesine O_CREAT atanmışsa dosya kipi (oluşturma izinleri) kip değiştirgesinde belirtildiği gibi ayarlanır. kip olarak O_CREAT belirtilmişse kip doğru işlem için gereklidir, yoksa yok sayılır.

Oluşturlacak dosyaya atanacak asıl izinler, normal olarak sürecin umask değerinden etkilenir.

Dönen Değerler

Bir hata oluşmuşsa FALSE, aksi takdirde dosya tanıtıcısı döner.

Örnekler

Örnek 1 - Bir dosya tanıtıcısının açılması

<?php

$fd = dio_open('/dev/ttyS0', O_RDWR | O_NOCTTY | O_NONBLOCK);

dio_close($fd);
?>

Ayrıca Bakınız

  • dio_close() - Belirtilen dosya tanıtıcısını kapatır

dio_fcntl
dio_read
Doğrudan G/Ç İşlevleri


Bir dosya tanıtıcısından baytları okur

dio_open
dio_seek
Doğrudan G/Ç İşlevleri
PHP Manual

dio_read

(PHP 4 >= 4.2.0, PHP 5 <= 5.0.5, PHP 7)

dio_read — Bir dosya tanıtıcısından baytları okur

Açıklama

string dio_read ( resource $dt [, int $uzunluk = 1024 ] )

dio_read() işlevi, dt dosya tanıtıcısını okur ve uzunluk baytını döndürür.

Değiştirgeler

dt

dio_open() işlevinden dönmüş bir dosya tanıtıcısı.

uzunluk

Okunacak baytların sayısı. Belirtilmezse, dio_read() işlevi veriyi 1K'lık bloklar halinde okur.

Dönen Değerler

dt'den okunan baytlarla döner.

Ayrıca Bakınız

  • dio_write() - Veriyi (uzunluğunu isteğe bağlı olarak kırparak) dosya tanıtıcısına yazar

dio_open
dio_seek
Doğrudan G/Ç İşlevleri


Dosya tanıtıcısında konumu bir yerden başka bir yere taşır

dio_read
dio_stat
Doğrudan G/Ç İşlevleri
PHP Manual

dio_seek

(PHP 4 >= 4.2.0, PHP 5 <= 5.0.5, PHP 7)

dio_seek — Dosya tanıtıcısında konumu bir yerden başka bir yere taşır

Açıklama

int dio_seek ( resource $dt , int $nereye [, int $nereden = SEEK_SET ] )

dio_seek() işlevi, belirtilen dosya tanıtıcısında dosya konumunu değiştirmek için kullanılır.

Değiştirgeler

dt

dio_open() işlevinden dönmüş bir dosya tanıtıcısı.

nereye

Yeni konum.

nereden

Mevcut konumun nasıl yorumlanacağı belirtilir:

  • SEEK_SET (öntanımlı) - nereye konumunun dosya başlangıcına göre belirtildiği varsayılır.

  • SEEK_CUR - nereye konumunun mevcut dosya konumuna göre bayt sayısı olarak belirtildiği varsayılır. Bu miktar pozitif veya negatif olabilir.

  • SEEK_END - nereye konumunun dosya sonuna göre belirtildiği varsayılır. Pozitif bir değer dosya sonundan önceki bayt sayısı olarak, negatif bir değer ise dosya sonundan sonraki bayt sayısı olarak yorumlanır. Dosya sonundan sonraki konumlara ulaşmak için bu bölgenin sıfır baytları ile doldurulması gerekir. Asıl veri ancak bundan sonra yazılır.

Dönen Değerler

Örnekler

Örnek 1 - Bir dosyada belli bir konuma gitmek

<?php

$fd = dio_open('/dev/ttyS0', O_RDWR);

dio_seek($fd, 10, SEEK_SET);
// Dosyanın başından itibaren 10. karakterdeyiz

dio_seek($fd, -2, SEEK_CUR);
// Şimdi dosyanın başından itibaren 8. karakterdeyiz

dio_seek($fd, -5, SEEK_END);
// Dosyanın sonundan itibaren başa doğru 5. karakterdeyiz

dio_seek($fd, 10, SEEK_END);
// Dosyanın sonundan itibaren 10. karakterdeyiz. Yeni dosya sonuna
// ulaşmak için eski dosya sonundan itibaren 10 tane sıfır baytı yazılır.

dio_close($fd);
?>

dio_read
dio_stat
Doğrudan G/Ç İşlevleri


Belirtilen dosya tanıtıcısı hakkında durum bilgisi döndürür

dio_seek
dio_tcsetattr
Doğrudan G/Ç İşlevleri
PHP Manual

dio_stat

(PHP 4 >= 4.2.0, PHP 5 <= 5.0.5, PHP 7)

dio_stat — Belirtilen dosya tanıtıcısı hakkında durum bilgisi döndürür

Açıklama

array dio_stat ( resource $dt )

dio_stat() işlevi, belirtilen dosya tanıtıcısı hakkında bilgi döndürür.

Değiştirgeler

dt

dio_open() işlevinden dönmüş bir dosya tanıtıcısı.

Dönen Değerler

Aşağıdaki anahtarları içeren bir dizi ile döner:

  • "device" - aygıt

  • "inode" - dosya düğümü

  • "mode" - kip

  • "nlink" - sabit bağların sayısı

  • "uid" - kullanıcı kimliği

  • "gid" - grup kimliği

  • "device_type" - aygıt türü (bir dosya düğümü aygıtıysa)

  • "size" - bayt cinsinden toplam boyut

  • "blocksize" - blok boyu

  • "blocks" - ayrılmış blok sayısı

  • "atime" - son erişim zamanı

  • "mtime" - son değişiklik zamanı

  • "ctime" - son değişim zamanı

Hata oluşursa dio_stat() işlevi NULL döndürür.

dio_seek
dio_tcsetattr
Doğrudan G/Ç İşlevleri


Bir seri portun veri hızını ve uçbirim özniteliklerini tanımlar

dio_stat
dio_truncate
Doğrudan G/Ç İşlevleri
PHP Manual

dio_tcsetattr

(PHP 4 >= 4.3.0, PHP 5 <= 5.0.5, PHP 7)

dio_tcsetattr — Bir seri portun veri hızını ve uçbirim özniteliklerini tanımlar

Açıklama

bool dio_tcsetattr ( resource $dt , array $seçenekler )

dio_tcsetattr() işleve açık bir fd'nin veri hızını ve uçbirim özniteliklerini ayarlar.

Değiştirgeler

dt

dio_open() işlevinden dönmüş bir dosya tanıtıcısı.

seçenekler

Olası seçenekler:

  • 'baud' - saniyede bit bayısı olarak veri hızı - 38400,19200,9600,4800,2400,1800,1200,600,300,200,150,134,110,75 veya 50 olabilir; 9600 öntanımlıdır.

  • 'bits' - veri bitleri - 8,7,6 veya 5 olabilir; 8 öntanımlıdır.

  • 'stop' - durdurma bitleri - 1 veya 2 olabilir; 1 öntanımlıdır.

  • 'parity' - eşik bitleri- 0,1 veya 2 olabilir; 0 öntanımlıdır.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 - Bir seri portun hızının ayarlanması

<?php

$fd = dio_open('/dev/ttyS0', O_RDWR | O_NOCTTY | O_NONBLOCK);

dio_fcntl($fd, F_SETFL, O_SYNC);

dio_tcsetattr($fd, array(
  'baud' => 9600,
  'bits' => 8,
  'stop'  => 1,
  'parity' => 0
));

while (1) {

  $data = dio_read($fd, 256);

  if ($data) {
      echo $data;
  }
}

?>

Notlar

Bilginize: Bu işlev Windows sistemlerinde çalışmaz.

dio_stat
dio_truncate
Doğrudan G/Ç İşlevleri


Dosya tanıtıcısındaki bayt sayısını sınırlar

dio_tcsetattr
dio_write
Doğrudan G/Ç İşlevleri
PHP Manual

dio_truncate

(PHP 4 >= 4.2.0, PHP 5 <= 5.0.5, PHP 7)

dio_truncate — Dosya tanıtıcısındaki bayt sayısını sınırlar

Açıklama

bool dio_truncate ( resource $dt , int $uzunluk )

dio_truncate() işlevi, bir dosyanın içeriğini uzunluk baytla sınırlar.

Dosya belirtilen uzunluktan uzunsa fazlalık kaybedilir. Kısaysa ya dosya boyu değişmeden kalır ya da boş kısımlar sıfır baytları olarak okunur.

Değiştirgeler

dt

dio_open() işlevinden dönmüş bir dosya tanıtıcısı.

uzunluk

Bayt cinsinden kırpma uzunluğu.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

Bilginize: Bu işlev Windows sistemlerinde çalışmaz.

dio_tcsetattr
dio_write
Doğrudan G/Ç İşlevleri


Veriyi (uzunluğunu isteğe bağlı olarak kırparak) dosya tanıtıcısına yazar

dio_truncate
Dizinler
Doğrudan G/Ç İşlevleri
PHP Manual

dio_write

(PHP 4 >= 4.2.0, PHP 5 <= 5.0.5, PHP 7)

dio_write — Veriyi (uzunluğunu isteğe bağlı olarak kırparak) dosya tanıtıcısına yazar

Açıklama

int dio_write ( resource $dt , string $veri [, int $uzunluk = 0 ] )

dio_write() işlevi veri'nin uzunluk bayta kadarlık bölümünü dt dosya tanıtıcısına yazar.

Değiştirgeler

dt

dio_open() işlevinden dönmüş bir dosya tanıtıcısı.

veri

Yazılacak veri.

uzunluk

Bayt cinsinden, yazılacak verinin uzunluğu. Belirtilmezse, verinin tamamı dosya tanıtıcısına yazılır.

Dönen Değerler

dt dosya tanıtıcısına yazılan baytların sayısı.

Ayrıca Bakınız

  • dio_read() - Bir dosya tanıtıcısından baytları okur

dio_truncate
Dizinler
Doğrudan G/Ç İşlevleri


Dizinler

  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Directory — The Directory class
    • Directory::close — Close directory handle
    • Directory::read — Read entry from directory handle
    • Directory::rewind — Rewind directory handle
  • Dizin İşlevleri
    • chdir — Dizin değiştirir
    • chroot — Kök dizini değiştirir
    • closedir — Dizin tanıtıcısını kapatır
    • dir — Return an instance of the Directory class
    • getcwd — Geçerli çalışma dizinini döndürür
    • opendir — Belirtilen dizin için bir tanıtıcı döndürür
    • readdir — Dizinden bir girdinin ismini okur
    • rewinddir — Dizin tanıtıcısını dizin başlangıcına konumlar
    • scandir — Belirtilen dizindeki alt dizinleri ve dosyaları listeler
dio_write
Yapılandırma/Kurulum
Dosya Sistemiyle İlgili Eklentiler


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Dizinler
Gereksinimler
Dizinler


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

DIRECTORY_SEPARATOR (string)
PATH_SEPARATOR (string)
PHP 4.3.0'dan beri kullanılabilmektedir. Windows'ta noktalı virgül, diğerlerinde iki nokta karakteridir.
SCANDIR_SORT_ASCENDING (integer)
PHP 5.4.0'dan beri kullanılabilmektedir.
SCANDIR_SORT_DESCENDING (integer)
PHP 5.4.0'dan beri kullanılabilmektedir.
SCANDIR_SORT_NONE (integer)
PHP 5.4.0'dan beri kullanılabilmektedir.
Özkaynak Türleri
Directory
Dizinler


The Directory class

(PHP 4, PHP 5, PHP 7)

Giriş

Instances of Directory are created by calling the dir() function, not by the new operator.

Sınıf Sözdizimi

Directory {
/* Özellikler */
public string $path ;
public resource $handle ;
/* Yöntemler */
public void close ([ resource $dir_handle ] )
public string read ([ resource $dir_handle ] )
public void rewind ([ resource $dir_handle ] )
}

Özellikler

path

The directory that was opened.

handle

Can be used with other directory functions such as readdir(), rewinddir() and closedir().

İçindekiler

  • Directory::close — Close directory handle
  • Directory::read — Read entry from directory handle
  • Directory::rewind — Rewind directory handle
Öntanımlı Sabitler
Directory::close
Dizinler


Close directory handle

Directory
Directory::read
Directory
PHP Manual

Directory::close

(PHP 4, PHP 5, PHP 7)

Directory::close — Close directory handle

Açıklama

public void Directory::close ([ resource $dir_handle ] )

Same as closedir(), only dir_handle defaults to $this.

Directory
Directory::read
Directory


Read entry from directory handle

Directory::close
Directory::rewind
Directory
PHP Manual

Directory::read

(PHP 4, PHP 5, PHP 7)

Directory::read — Read entry from directory handle

Açıklama

public string Directory::read ([ resource $dir_handle ] )

Same as readdir(), only dir_handle defaults to $this.

Directory::close
Directory::rewind
Directory


Rewind directory handle

Directory::read
Dizin İşlevleri
Directory
PHP Manual

Directory::rewind

(PHP 4, PHP 5, PHP 7)

Directory::rewind — Rewind directory handle

Açıklama

public void Directory::rewind ([ resource $dir_handle ] )

Same as rewinddir(), only dir_handle defaults to $this.

Directory::read
Dizin İşlevleri
Directory


Dizin İşlevleri

Ayrıca Bakınız

dirname(), is_dir(), mkdir() ve rmdir() gibi dosya sistemiyle ilgili işlevler için Dosya Sistemi bölümüne bakınız.

İçindekiler

  • chdir — Dizin değiştirir
  • chroot — Kök dizini değiştirir
  • closedir — Dizin tanıtıcısını kapatır
  • dir — Return an instance of the Directory class
  • getcwd — Geçerli çalışma dizinini döndürür
  • opendir — Belirtilen dizin için bir tanıtıcı döndürür
  • readdir — Dizinden bir girdinin ismini okur
  • rewinddir — Dizin tanıtıcısını dizin başlangıcına konumlar
  • scandir — Belirtilen dizindeki alt dizinleri ve dosyaları listeler
Directory::rewind
chdir
Dizinler


Dizin değiştirir

Dizin İşlevleri
chroot
Dizin İşlevleri
PHP Manual

chdir

(PHP 4, PHP 5, PHP 7)

chdir — Dizin değiştirir

Açıklama

bool chdir ( string $dizin )

PHP'nin geçerli dizinden belirtilen dizin'e geçmesini sağlar.

Değiştirgeler

dizin

Yeni geçerli dizin.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - chdir() örneği

<?php

// geçerli dizin
echo getcwd() . "\n";

// değiştirelim
chdir('public_html');

// geçerli dizin
echo getcwd() . "\n";

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

/home/nilgun
/home/nilgun/public_html

Notlar

Bilginize: Güvenli kip etkinken, PHP, betiğin çalıştığı dizinin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığını sınar.

Ayrıca Bakınız

  • getcwd() - Geçerli çalışma dizinini döndürür

Dizin İşlevleri
chroot
Dizin İşlevleri


Kök dizini değiştirir

chdir
closedir
Dizin İşlevleri
PHP Manual

chroot

(PHP 4 >= 4.0.5, PHP 5, PHP 7)

chroot — Kök dizini değiştirir

Açıklama

bool chroot ( string $dizin )

Geçerli sürecin kök dizinini dizin yapar.

Bu işlev sadece sisteminiz kendisini destekliyorsa ve CLI, CGI veya gömülü SAPI kullanıyorsanız kullanılabilir. Ayrıca, bu işlevin kullanılabilmesi için sürecin root aidiyetinde çalışması gerekir.

Değiştirgeler

dizin

Yeni kök dizin.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

Bilginize: Bu işlev Windows sistemlerinde çalışmaz.

chdir
closedir
Dizin İşlevleri


Dizin tanıtıcısını kapatır

chroot
dir
Dizin İşlevleri
PHP Manual

closedir

(PHP 4, PHP 5, PHP 7)

closedir — Dizin tanıtıcısını kapatır

Açıklama

void closedir ([ resource $dizin_tanıtıcısı ] )

dizin_tanıtıcısı ile belirtilen dizin akımını kapatır. Akımın evvelce opendir() tarafından açılmış olması gerekir.

Değiştirgeler

dizin_tanıtıcısı

opendir() işlevinden dönmüş bir dizin tanıtıcısı. Belirtilmezse opendir() tarafından açılan son dizin kullanılır.

Örnekler

Örnek 1 - closedir() örneği

<?php
$dizin = "/etc/apache2/";

// Dizin aç ve içeriğin oku
if (is_dir($dizin)) {
    if ($dit = opendir($dizin)) {
        while (($dosya = readdir($dit)) !== false) {
          echo "dosya adı: $dosya - dosya türü: " .
            ((filetype($dizin . $dosya) === "dir") ? "dizin" : "dosya") . "\n";
        }
        closedir($dit);
    }
}
?>

chroot
dir
Dizin İşlevleri


Return an instance of the Directory class

closedir
getcwd
Dizin İşlevleri
PHP Manual

dir

(PHP 4, PHP 5, PHP 7)

dir — Return an instance of the Directory class

Açıklama

Directory dir ( string $directory [, resource $context ] )

A pseudo-object oriented mechanism for reading a directory. The given directory is opened.

Değiştirgeler

directory

Directory to open

context

Bilginize: Bağlamsal destek PHP 5.0.0 ile eklenmiştir. Bağlamlar hakkında bilgi edinmek için Akım İşlevleri belgesine bakınız.

Dönen Değerler

Returns an instance of Directory, or NULL with wrong parameters, or FALSE in case of another error.

Örnekler

Örnek 1 dir() example

Please note the fashion in which Directory::read()'s return value is checked in the example below. We are explicitly testing whether the return value is identical to (equal to and of the same type as - see Comparison Operators for more information) FALSE since otherwise, any directory entry whose name evaluates to FALSE will stop the loop.

<?php
$d = dir("/etc/php5");
echo "Handle: " . $d->handle . "\n";
echo "Path: " . $d->path . "\n";
while (false !== ($entry = $d->read())) {
   echo $entry."\n";
}
$d->close();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Handle: Resource id #2
Path: /etc/php5
.
..
apache
cgi
cli

Notlar

Bilginize:

The order in which directory entries are returned by the read method is system-dependent.

closedir
getcwd
Dizin İşlevleri


Geçerli çalışma dizinini döndürür

dir
opendir
Dizin İşlevleri
PHP Manual

getcwd

(PHP 4, PHP 5, PHP 7)

getcwd — Geçerli çalışma dizinini döndürür

Açıklama

string getcwd ( void )

Geçerli çalışma dizinini döndürür.

Dönen Değerler

Başarılı olursa geçerli çalışma dizinini, aksi takdirde FALSE döndürür.

Bazı Unix türevlerinde, üst dizinlere erişim izni yoksa getcwd() işlevi FALSE döndürür. Erişim izinleri ve kipler hakkında daha ayrıntılı bilgi için chmod() işlevine bakınız.

Örnekler

Örnek 1 - getcwd() örneği

<?php

// geçerli dizin
echo getcwd() . "\n";

// dizin değiştirelim
chdir('cvs');

// geçerli dizin
echo getcwd() . "\n";

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

/home/nilgun
/home/nilgun/cvs

Ayrıca Bakınız

  • chdir() - Dizin değiştirir
  • chmod() - Dosya kipini değiştirir

dir
opendir
Dizin İşlevleri


Belirtilen dizin için bir tanıtıcı döndürür

getcwd
readdir
Dizin İşlevleri
PHP Manual

opendir

(PHP 4, PHP 5, PHP 7)

opendir — Belirtilen dizin için bir tanıtıcı döndürür

Açıklama

resource opendir ( string $dizin [, resource $bağlam ] )

closedir(), readdir() ve rewinddir() çağrılarında kullanılmak üzere bir dizin tanıtıcısı ile döner.

Değiştirgeler

dizin

Açılacak dizinin yolu.

bağlam

bağlam değiştirgesinin açıklaması için akımlar bölümüne bakınız.

Dönen Değerler

Başarılı olduğunda dizin tanıtıcısı ile aksi takdirde FALSE değeriyle döner.

Eğer belirtilen dizin bir dizin değilse veya erişim izinlerinin yetersizliğinden dolayı dizin açılamamışsa ya da bir dosya sistemi hatası oluşmuşsa işlev FALSE ile döner ve E_WARNING seviyesinde bir hata üretilir. Hata iletisinin çıktılanmasını işlev isminin başına bir '@' karakteri ekleyerek engelleyebilirsiniz.

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.0 | dizin değiştirgesinde ftp:// sarmalayıcısı da kabul edilmeye başlandı.
4.3.0 | dizin değiştirgesinde dizin listelemeyi destekleyen URL'ler belirtilebilir oldu. Ancak, PHP 4 sadece file:// sarmalayıcısını desteklemektedir.

Örnekler

Örnek 1 - opendir() örneği

<?php
$dizin = "/etc/apache2/";

// Dizin aç ve içeriğin oku
if (is_dir($dizin)) {
    if ($dit = opendir($dizin)) {
        while (($dosya = readdir($dit)) !== false) {
          echo "dosya adı: $dosya - dosya türü: " .
            ((filetype($dizin . $dosya) === "dir") ? "dizin" : "dosya") . "\n";
        }
        closedir($dit);
    }
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

dosya adı: httpd.conf - dosya türü: dosya
dosya adı: mods-enabled - dosya türü: dizin
dosya adı: sites-enabled - dosya türü: dizin
dosya adı: .. - dosya türü: dizin
dosya adı: apache2.conf - dosya türü: dosya
dosya adı: sites-available - dosya türü: dizin
dosya adı: envvars - dosya türü: dosya
dosya adı: ports.conf - dosya türü: dosya
dosya adı: mods-available - dosya türü: dizin
dosya adı: conf.d - dosya türü: dizin
dosya adı: . - dosya türü: dizin

Ayrıca Bakınız

  • is_dir() - Bir dosyanın bir dizin olup olmadığını söyler
  • readdir() - Dizinden bir girdinin ismini okur
  • dir() - Return an instance of the Directory class

getcwd
readdir
Dizin İşlevleri


Dizinden bir girdinin ismini okur

opendir
rewinddir
Dizin İşlevleri
PHP Manual

readdir

(PHP 4, PHP 5, PHP 7)

readdir — Dizinden bir girdinin ismini okur

Açıklama

string readdir ([ resource $dizin_tanıtıcısı ] )

Dizindeki sonraki dosyanın ismi ile döner. Dosya isimleri dosya sisteminde saklandıkları sıra ile döndürülür.

Değiştirgeler

dizin_tanıtıcısı

opendir() işlevinden dönmüş bir dizin tanıtıcısı. Belirtilmezse opendir() tarafından açılan son dizin kullanılır.

Dönen Değerler

Başarılı olduğunda dosya ismi ile aksi takdirde FALSE değeriyle döner.

Uyarı

Bu işlev mantıksal FALSE değeriyle dönebileceği gibi FALSE olarak değerlendirilebilecek mantıksal olmayan bir değerle de dönebilir. Bu konuda daha fazla bilgi edinmek için Mantıksal Değerler bölümüne bakabilirsiniz. Bu işlevden dönen değeri sınamak için === işlecini kullanınız.

Örnekler

Örnek 1 - Bir dizin içeriğinin listelenmesi

Aşağıdaki örnekte dönen değerin mantıksal FALSE olup olmadığına (bak: Karşılaştırma İşleçleri) özellikle bakılmakta oluşuna dikkat ediniz. Eğer dizgesel olarak baksaydık ismi mantıksal FALSE olarak değerlendirilebilecek bir dosya (örneğin "0") döngünün durmasına yol açardı.

<?php
// 4.0.0-RC2 sürümüne kadar !== işlecinin kullanılamadığına dikkat edin

if ($dizin = opendir('/bir/dizin/dosyalar')) {
    echo "Dizin tanıtıcısı: $dizin\n";
    echo "Dizin içeriği:\n";

    /* Dizin içeriğini taramak için doğru yöntem. */
    while (false !== ($dosya = readdir($dizin))) {
        echo "$dosya\n";
    }

    /* Dizin içeriğini taramak için YANLIŞ yöntem. */
    while ($dosya = readdir($dizin)) {
        echo "$dosya\n";
    }

    closedir($dizin);
}
?>

Örnek 2 - . ve .. girdileri ayıklanarak dizin içeriğinin listelenmesi

<?php
if ($dizin = opendir('.')) {
    while (false !== ($dosya= readdir($dizin))) {
        if ($dosya != "." && $dosya != "..") {
            echo "$dosya\n";
        }
    }
    closedir($dizin);
}
?>

Ayrıca Bakınız

  • is_dir() - Bir dosyanın bir dizin olup olmadığını söyler
  • glob() - Bir kalıpla eşleşen dosya yollarını bulur
  • opendir() - Belirtilen dizin için bir tanıtıcı döndürür
  • scandir() - Belirtilen dizindeki alt dizinleri ve dosyaları listeler

opendir
rewinddir
Dizin İşlevleri


Dizin tanıtıcısını dizin başlangıcına konumlar

readdir
scandir
Dizin İşlevleri
PHP Manual

rewinddir

(PHP 4, PHP 5, PHP 7)

rewinddir — Dizin tanıtıcısını dizin başlangıcına konumlar

Açıklama

void rewinddir ([ resource $dizin_tanıtıcısı ] )

dizin_tanıtıcısı ile belirtilen dizin akımında konumu dizinin başlangıcına taşır.

Değiştirgeler

dizin_tanıtıcıcı

opendir() işlevinden dönmüş bir dizin tanıtıcısı. Belirtilmezse opendir() tarafından açılan son dizin kullanılır.

readdir
scandir
Dizin İşlevleri


Belirtilen dizindeki alt dizinleri ve dosyaları listeler

rewinddir
Fileinfo
Dizin İşlevleri
PHP Manual

scandir

(PHP 5, PHP 7)

scandir — Belirtilen dizindeki alt dizinleri ve dosyaları listeler

Açıklama

array scandir ( string $dizin [, int $sıralama_türü = 0 [, resource $bağlam ]] )

Belirtilen dizin içindeki dosya ve dizinleri içeren dizi ile döner.

Değiştirgeler

dizin

İçeriği taranacak dizin.

sıralama_türü

Abecesel olarak küçükten büyüğe sıralama öntanımlıdır. Bu değiştirgeye sıfırdan farklı bir değer atarsanız sıralama büyükten küçüğe doğru yapılır.

bağlam

bağlam değiştirgesinin açıklaması için akımlar bölümüne bakınız.

Dönen Değerler

Başarılı olduğunda dosya ve dizin isimlerini içeren bir dizi ile aksi takdirde FALSE değeriyle döner. Eğer belirtilen dizin bir dizin değilse FALSE döner ve E_WARNING seviyesinde bir hata üretilir.

Örnekler

Örnek 1 - Basit bir scandir() örneği

<?php
$dir    = '/tmp';
$files1 = scandir($dir);
$files2 = scandir($dir, 1);

print_r($files1);
print_r($files2);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [0] => .
    [1] => ..
    [2] => bar.php
    [3] => foo.txt
    [4] => somedir
)
Array
(
    [0] => somedir
    [1] => foo.txt
    [2] => bar.php
    [3] => ..
    [4] => .
)

Örnek 2 - PHP 4 için scandir() örneği

<?php
$dir = "/tmp";
$dh  = opendir($dir);
while (false !== ($filename = readdir($dh))) {
    $files[] = $filename;
}

sort($files);

print_r($files);

rsort($files);

print_r($files);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [0] => .
    [1] => ..
    [2] => bar.php
    [3] => foo.txt
    [4] => somedir
)
Array
(
    [0] => somedir
    [1] => foo.txt
    [2] => bar.php
    [3] => ..
    [4] => .
)

Notlar

İpucu

fopen sarmalayıcıları etkin kılınmışsa bu işlevde dosya ismi olarak bir URL belirtebilirsiniz. Dosya isminin nasıl belirtilebileceği hakkında bilgi edinmek için fopen() işlevine bakınız. Sarmalayıcıların neler yapabildiği, kullanım bilgileri ve bunlar tarafından kullanılan öntanımlı değişkenler hakkında bilgi edinmek için ise Supported Protocols and Wrappers bölümüne bakınız.

Ayrıca Bakınız

  • opendir() - Belirtilen dizin için bir tanıtıcı döndürür
  • readdir() - Dizinden bir girdinin ismini okur
  • glob() - Bir kalıpla eşleşen dosya yollarını bulur
  • is_dir() - Bir dosyanın bir dizin olup olmadığını söyler
  • sort() - Bir diziyi sıralar

rewinddir
Fileinfo
Dizin İşlevleri


Dosya Bilgileri

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Fileinfo İşlevleri
    • finfo_buffer — Bir dizge tamponu hakkında bilgi döndürür
    • finfo_close — Fileinfo özkaynağını kapatır
    • finfo_file — Bir dosya hakkında bilgi döndürür
    • finfo_open — Yeni bir fileinfo özkaynağı oluşturur
    • finfo_set_flags — Libmagic yapılandırma seçeneklerini ayarlar
    • mime_content_type — Detect MIME Content-type for a file
scandir
Giriş
Dosya Sistemiyle İlgili Eklentiler


Giriş

Bu modüldeki işlevler, dosya içinde belli bir konumda bulunan sihirli baytlara bakarak dosyanın içerik türünü ve kodlamasını tahmin etmeye çalışır. Çok güçlü bir yaklaşım olmasa da kullanılan ampirik yöntem oldukça iyi iş çıkarmaktadır.

Fileinfo
Yapılandırma/Kurulum
Fileinfo


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Fileinfo


Gereksinimler

PHP 5.3.0 ve öncesinde bu eklentiyi derlemek için magic_open kütüphanesi gerekir.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu eklenti PHP 5.3.0'dan beri öntanımlı olarak etkindir. Daha önceki sürümler için bir PECL eklentisi idiyse de artık gelişimini bir PECL eklentisi olarak değil PHP içinde sürdürmektedir.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Özkaynak Türleri

Fileinfo eklentisinde kullanılan tek bir özkaynak vardır: finfo_open() işlevi tarafından döndürülen bir sihir veritabanı tanıtıcısı.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

FILEINFO_NONE (integer)
Özel bir işlem yok.
FILEINFO_SYMLINK (integer)
Sembolik bağlar izlenir.
FILEINFO_MIME_TYPE (integer)
MIME türü döndürülür. PHP 5.3.0'dan beri kullanılabilmektedir.
FILEINFO_MIME_ENCODING (integer)
Dosyanın MIME kodlaması döndürülür. PHP 5.3.0'dan beri kullanılabilmektedir.
FILEINFO_MIME (integer)
RFC 2045'te açıklandığı gibi, bir MIME türü ve bir MIME kodlaması döndürülür.
FILEINFO_COMPRESS (integer)
Sıkıştırılmış dosyaların sıkıştırmasını açar. Güvenlik kaygılarıyla PHP 5.3.0'dan itibaren kaldırılmıştır.
FILEINFO_DEVICES (integer)
Karakter veya blok aygıtlarının içeriğine bakılır.
FILEINFO_CONTINUE (integer)
Sadece ilki değil, tüm eşleşenler döndürülür.
FILEINFO_PRESERVE_ATIME (integer)
Mümkünse özgün erişim zamanı korunur.
FILEINFO_RAW (integer)
Basılamayan karakterler, \ooo biçiminde sekizlik gösterime dönüştürülmez.
Özkaynak Türleri
Fileinfo İşlevleri
Fileinfo


Fileinfo İşlevleri

İçindekiler

  • finfo_buffer — Bir dizge tamponu hakkında bilgi döndürür
  • finfo_close — Fileinfo özkaynağını kapatır
  • finfo_file — Bir dosya hakkında bilgi döndürür
  • finfo_open — Yeni bir fileinfo özkaynağı oluşturur
  • finfo_set_flags — Libmagic yapılandırma seçeneklerini ayarlar
  • mime_content_type — Detect MIME Content-type for a file
Öntanımlı Sabitler
finfo_buffer
Fileinfo


Bir dizge tamponu hakkında bilgi döndürür

Fileinfo İşlevleri
finfo_close
Fileinfo İşlevleri
PHP Manual

finfo_buffer

(PHP 5 >= 5.3.0, PHP 7, PECL fileinfo >= 0.1.0)

finfo_buffer — Bir dizge tamponu hakkında bilgi döndürür

Açıklama

string finfo_buffer ( resource $özkaynak , string $dizge = NULL [, int $seçenekler = FILEINFO_NONE [, resource $bağlam = NULL ]] )
string buffer ( string $dizge = NULL [, int $seçenekler = FILEINFO_NONE [, resource $bağlam = NULL ]] )

Bu işlev bir dizge içindeki ikil veri hakkında bilgi edinmek için kullanılır.

Değiştirgeler

özkaynak

finfo_open() işlevinden dönmüş bir Fileinfo özkaynağı.

dizge

İçeriği incelenecek dizge.

seçenekler

Fileinfo sabitlerinden biri veya bir kaçının birleşimi.

bağlam

Bağlamlar hakkında bilgi edinmek için Akım İşlevleri bölümüne bakınız.

Dönen Değerler

Bir hata oluşmuşsa FALSE, aksi takdirde belirtilen dizgenin içeriği hakkında açıklama dizgesi döner.

Örnekler

Örnek 1 - finfo_buffer() örneği

<?php
$finfo = new finfo(FILEINFO_MIME);
echo $finfo->buffer($_POST["betik"]) . "\n";
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

application/x-sh; charset=us-ascii

Ayrıca Bakınız

  • finfo_file() - Bir dosya hakkında bilgi döndürür

Fileinfo İşlevleri
finfo_close
Fileinfo İşlevleri


Fileinfo özkaynağını kapatır

finfo_buffer
finfo_file
Fileinfo İşlevleri
PHP Manual

finfo_close

(PHP >= 5.3.0, PECL fileinfo >= 0.1.0)

finfo_close — Fileinfo özkaynağını kapatır

Açıklama

bool finfo_close ( resource $özkaynak )
__destruct ( void )

Bu işlev, finfo_open() tarafından açılmış özkaynağı kapatır.

Değiştirgeler

özkaynak

finfo_open() işlevinden dönmüş bir Fileinfo özkaynağı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

finfo_buffer
finfo_file
Fileinfo İşlevleri


Bir dosya hakkında bilgi döndürür

finfo_close
finfo_open
Fileinfo İşlevleri
PHP Manual

finfo_file

(PHP >= 5.3.0, PECL fileinfo >= 0.1.0)

finfo_file — Bir dosya hakkında bilgi döndürür

Açıklama

string finfo_file ( resource $özkaynak , string $dosya_ismi = NULL [, int $seçenekler = FILEINFO_NONE [, resource $bağlam = NULL ]] )
string file ( string $dosya_ismi = NULL [, int $seçenekler = FILEINFO_NONE [, resource $bağlam = NULL ]] )

Bu işlev bir dosya hakkında bilgi edinmek için kullanılır.

Değiştirgeler

özkaynak

finfo_open() işlevinden dönmüş bir Fileinfo özkaynağı.

dosya_ismi

Hakkında bilgi istenen dosya.

seçenekler

Fileinfo sabitlerinden biri veya bir kaçının birleşimi.

bağlam

Bağlamlar hakkında bilgi edinmek için Akım İşlevleri bölümüne bakınız.

Dönen Değerler

Bir hata oluşmuşsa FALSE, aksi takdirde belirtilen dosyanın içeriği hakkında açıklama dizgesi döner.

Örnekler

Örnek 1 - finfo_file() örneği

<?php
Bir açıklama değil MIME türü dönsün
$finfo = finfo_open(FILEINFO_MIME_TYPE);

foreach (glob("*") as $dosya) {
    echo finfo_file($finfo, $dosya) . "\n";
}

finfo_close($finfo);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

text/html
image/gif
application/vnd.ms-excel

Ayrıca Bakınız

  • finfo_buffer() - Bir dizge tamponu hakkında bilgi döndürür

finfo_close
finfo_open
Fileinfo İşlevleri


Yeni bir fileinfo özkaynağı oluşturur

finfo_file
finfo_set_flags
Fileinfo İşlevleri
PHP Manual

finfo_open

finfo->__construct

(PHP >= 5.3.0, PECL fileinfo >= 0.1.0)

finfo_open -- finfo->__construct — Yeni bir fileinfo özkaynağı oluşturur

Açıklama

Yordamsal kullanım

resource finfo_open ([ int $seçenekler = FILEINFO_NONE [, string $sihir_dosyası = NULL ]] )

Nesne yönelimli kullanım (kurucu):

__construct ([ int $seçenekler = FILEINFO_NONE [, string $sihirli_dosya = NULL ]] )

Bu işlev bir sihir veritabanı açar ve özkaynağını döndürür.

Değiştirgeler

seçenekler

Fileinfo sabitlerinden biri veya bir kaçının birleşimi.

sihir_dosyası

Sihir veritabanının dosya ismi genellikle /bir/yol/magic.mime şeklindedir. Belirtilmezse MAGIC ortam değişkeninin değeri kullanılır. Bu değişken de atanmamışsa /usr/share/misc/magic dosyası öntanımlıdır. Gerek görülürse dosya uzantısı olarak .mime ve/veya .mgc kullanılabilir.

Dönen Değerler

Başarısızlık durumunda FALSE, aksi takdirde sihir veritabanı özkaynağı ile döner.

Örnekler

Örnek 1 - Nesne yönelimli kullanım örneği

<?php
// Bir açıklama değil MIME türü dönsün
$finfo = new finfo(FILEINFO_MIME, "/usr/share/misc/magic");

if (!$finfo) {
    echo "Fileinfo veritabanı açılamadı";
    exit();
}

/* Bir dosyanın MIME türünü öğrenelim */
$dosya = "/usr/local/birdosya.txt";
echo $finfo->file($dosya);
?>

Örnek 2 - Yordamsal kullanım örneği

<?php
// Bir açıklama değil MIME türü dönsün
$finfo = finfo_open(FILEINFO_MIME, "/usr/share/misc/magic");

if (!$finfo) {
    echo "Fileinfo veritabanı açılamadı";
    exit();
}

/* Bir dosyanın MIME türünü öğrenelim */
$dosya = "/usr/local/something.txt";
echo finfo_file($finfo, $dosya);

/* Bağlantıyı kapatalım */
finfo_close($finfo);
?>

Yukarıdaki örneğin çıktısı:

text/plain; charset=us-ascii

Ayrıca Bakınız

  • finfo_close() - Fileinfo özkaynağını kapatır

finfo_file
finfo_set_flags
Fileinfo İşlevleri


Libmagic yapılandırma seçeneklerini ayarlar

finfo_open
mime_content_type
Fileinfo İşlevleri
PHP Manual

finfo_set_flags

(PHP >= 5.3.0, PECL fileinfo >= 0.1.0)

finfo_set_flags — Libmagic yapılandırma seçeneklerini ayarlar

Açıklama

bool finfo_set_flags ( resource $özkaynak , int $seçenekler )
bool set_flags ( int $seçenekler )

Bu işlevle çeşitli Fileinfo seçenekleri ayarlanır. Bu seçenekler ayrıca, finfo_open() veya diğer Fileinfo işlevleriyle de doğrudan ayarlanabilir.

Değiştirgeler

özkaynak

finfo_open() işlevinden dönmüş bir Fileinfo özkaynağı.

seçenekler

Fileinfo sabitlerinden biri veya bir kaçının birleşimi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

finfo_open
mime_content_type
Fileinfo İşlevleri


Detect MIME Content-type for a file

finfo_set_flags
Dosya Sistemi
Fileinfo İşlevleri
PHP Manual

mime_content_type

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

mime_content_type — Detect MIME Content-type for a file

Açıklama

string mime_content_type ( string $filename )

Returns the MIME content type for a file as determined by using information from the magic.mime file.

Değiştirgeler

filename

Path to the tested file.

Dönen Değerler

Returns the content type in MIME format, like text/plain or application/octet-stream.

Örnekler

Örnek 1 mime_content_type() Example

<?php
echo mime_content_type('php.gif') . "\n";
echo mime_content_type('test.php');
?>

Yukarıdaki örneğin çıktısı:

image/gif
text/plain

Ayrıca Bakınız

  • finfo_file() - Bir dosya hakkında bilgi döndürür
  • finfo_buffer() - Bir dizge tamponu hakkında bilgi döndürür

finfo_set_flags
Dosya Sistemi
Fileinfo İşlevleri


Dosya Sistemi

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Dosya Sistemi İşlevleri
    • basename — Dosya yolunun dosya ismi bileşenini döndürür
    • chgrp — Dosya grubunu değiştirir
    • chmod — Dosya kipini değiştirir
    • chown — Dosyanın sahibini değiştirir
    • clearstatcache — Dosya durum önbelleğini temizler
    • copy — Dosya kopyalar
    • delete — unlink veya unset işlevine bakınız
    • dirname — Belirtilen dosya yolunun dizin bileşenini döndürür
    • disk_free_space — Dizindeki kullanılabilir bayt sayısını döndürür
    • disk_total_space — Bir dizinin toplam boyunu döndürür
    • diskfreespace — disk_free_space işlevinin takma adıdır
    • fclose — Açık bir dosya tanıtıcısını kapatır
    • feof — Bir dosya tanıtıcısı üzerinde konum dosya sonunda mı diye bakar
    • fflush — Çıktıyı bir dosyaya boşaltır
    • fgetc — Dosya tanıtıcısından bir karakter döndürür
    • fgetcsv — Dosya tanıtıcısından CSV alanlarını çözümleyerek bir satır döndürür
    • fgets — Dosya tanıtıcısından bir satır döndürür
    • fgetss — Dosya tanıtıcısından bir satırı HTML etiketlerinden arındırarak döndürür
    • file_exists — Bir dosya veya dizinin mevcut olup olmadığına bakar
    • file_get_contents — Dosya içeriğinin tamamını bir dizge olarak döndürür
    • file_put_contents — Bir dizgeyi bir dosyaya yazar
    • file — Dosya içeriğinin tamamını bir diziye okur
    • fileatime — Dosyaya son erişim zamanını döndürür
    • filectime — Dosyanın dosya düğümü değişiklik zamanını döndürür
    • filegroup — Dosyanın sahibi olan grubu döndürür
    • fileinode — Dosyanın düğüm numarasını döndürür
    • filemtime — Dosyanın değişiklik zamanını döndürür
    • fileowner — Dosya sahibini döndürür
    • fileperms — Dosya izinlerini döndürür
    • filesize — Dosya uzunluğunu döndürür
    • filetype — Dosya türünü döndürür
    • flock — Taşınabilir tavsiye niteliğinde dosya kilitleme
    • fnmatch — Dosya ismi belirtilen kalıpla eşleşiyor mu diye bakar
    • fopen — Bir dosya veya URL'yi açar
    • fpassthru — Bir dosya tanıtıcısında kalan verinin tamamını çıktılar
    • fputcsv — Satırı CSV olarak biçemler ve dosya tanıtıcısına yazar
    • fputs — fwrite işlevinin takma adıdır
    • fread — Dosyayı ikil kipte okur
    • fscanf — Bir dosyadaki girdiyi belli bir biçeme göre çözümler
    • fseek — Dosya tanıtıcısında konumu bir yerden başka bir yere taşır
    • fstat — Bir açık dosya tanıtıcısı kullanarak bir dosya hakkında bilgi döndürür
    • ftell — Dosya okuma/yazma konumlayıcının mevcut konumu ile döner
    • ftruncate — Bir dosyayı belli bir uzunlukta budar
    • fwrite — Dosyaya ikil kipte yazar
    • glob — Bir kalıpla eşleşen dosya yollarını bulur
    • is_dir — Bir dosyanın bir dizin olup olmadığını söyler
    • is_executable — Bir dosyanın çalıştırılabilir bir dosya olup olmadığını söyler
    • is_file — Bir dosyanın sıradan bir dosya olup olmadığını söyler
    • is_link — Bir dosyanın sembolik bağ olup olmadığını söyler
    • is_readable — Bir dosyanın mevcut ve okunabilir olup olmadığını söyler
    • is_uploaded_file — Bir dosya HTTP POST üzerinden karşıya yüklenebilecekse bunu söyler
    • is_writable — Bir dosyanın yazılabilir olup olmadığını söyler
    • is_writeable — is_writable işlevinin takma adıdır
    • lchgrp — Bir sembolik bağın grubunu değiştirir
    • lchown — Bir sembolik bağın sahibini değiştirir
    • link — Sabit bir bağ oluşturur
    • linkinfo — Bir bağ hakkında bilgi verir
    • lstat — Bir dosya veya sembolik bağ hakkında bilgi verir
    • mkdir — Dizin oluşturur
    • move_uploaded_file — Karşıya yüklenen bir dosyayı yeni bir yere taşır
    • parse_ini_file — Bir yapılandırma dosyasını çözümler
    • parse_ini_string — Bir yapılandırma dizgesini çözümler
    • pathinfo — Bir dosya yolu hakkında bilgi döndürür
    • pclose — Bir süreç tanıtıcısını kapatır
    • popen — Bir süreç tanıtıcısı açar
    • readfile — Bir dosyayı çıktılar
    • readlink — Bir sembolik bağın hedefi ile döner
    • realpath_cache_get — Get realpath cache entries
    • realpath_cache_size — Get realpath cache size
    • realpath — Normalleştirilmiş mutlak dosya yolunu döndürür
    • rename — Bir dosya veya dizinin ismini değiştirir
    • rewind — Bir dosya tanıtıcısında konumu başa taşır
    • rmdir — Dizin siler
    • set_file_buffer — stream_set_write_buffer işlevinin takma adıdır
    • stat — Bir dosya hakkında bilgi döndürür
    • symlink — Bir sembolik bağ oluşturur
    • tempnam — Eşsiz bir isimle dosya oluşturur
    • tmpfile — Geçici bir dosya oluşturur
    • touch — Dosyanın erişim ve değişiklik zamanını ayarlar
    • umask — Geçerli izin maskesini değiştirir
    • unlink — Bir dosyayı siler
mime_content_type
Giriş
Dosya Sistemiyle İlgili Eklentiler


Giriş

Bu eklentiyi derlemek için hiçbir ek kütüphaneye gerek yoktur fakat PHP'nin Linux'ta büyük dosyaları (>2GB) desteklemesini istiyorsanız glibc'nin son sürümüne sahip olmanız ve PHP'yi -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 seçenekleriyle derlemelisiniz.

Dosya Sistemi
Yapılandırma/Kurulum
Dosya Sistemi


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Dosya Sistemi


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Dosya sistemi ve akımlar ile ilgili yapılandırma seçenekleri
İsim | Öntanımlı | Değişiklik Yeri | Sürüm Bilgisi
allow_url_fopen | "1" | PHP_INI_ALL | PHP <= 4.3.4'te PHP_INI_ALL. PHP < 6'da PHP_INI_SYSTEM. PHP 4.0.4'ten beri kullanılabilmektedir.
allow_url_include | "0" | PHP_INI_ALL | PHP 5'te PHP_INI_SYSTEM. PHP 5.2.0'dan beri kullanılabilmektedir.
user_agent | NULL | PHP_INI_ALL | PHP 4.3.0'dan beri kullanılabilmektedir.
default_socket_timeout | "60" | PHP_INI_ALL | PHP 4.3.0'dan beri kullanılabilmektedir.
from | "" | PHP_INI_ALL |
auto_detect_line_endings | "0" | PHP_INI_ALL | PHP 4.3.0'dan beri kullanılabilmektedir.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

allow_url_fopen boolean

Bu seçenek, dosyalar gibi URL nesnelerine erişimi mümkün kılan fopen URL sarmalayıcılarını etkinleştirir. HTTP ve FTP protokollerini kullanarak uzak dosyalara erişmek için öntanımlı sarmalayıcılar mevcuttur. zlib gibi bazı eklentilerle ek sarmalayıcılar devreye sokulabilir.

Bilginize:

Bu yönergeye güvenlik sebebiyle sadece php.ini içinde atama yapılabilmektedir.

Bilginize:

Bu yönerge PHP 4.0.3 sürümünün hemen ardından devreye girmiştir. PHP 4.0.3 ve önceki sürümlerde bu özellik sadece derleme sırasında --disable-url-fopen-wrapper yapılandırma seçeneği ile iptal edilebilmekteydi.

Uyarı

PHP 4.3.0 ve öncesi Windows sürümlerinde, uzak dosyalara erişimi desteklemeyen işlevler: include, include_once, require, require_once ve GD ve Resim İşlevleri eklentisinin imagecreatefromXXX işlevleri.

allow_url_include boolean

Bu yönerge, fopen URL sarmalayıcılarını şu işlevlerde kullanabilmeyi mümkün kılar: include, include_once, require ve require_once.

Bilginize:

Bu yönerge allow_url_fopen yönergesinin 'On' olmasını gerektirir.

user_agent string

PHP için gönderilecek kullanıcı aracısını tanımlar.

default_socket_timeout integer

Soketlere dayalı akımlar için öntanımlı zaman aşımı (saniye cinsinden).

Bilginize: Bu yönerge PHP 4.3.0'dan beri kullanılabilmektedir.

from string

Anonim FTP parolasını (eposta adresi) tanımlamak için kullanılır.

auto_detect_line_endings boolean

'On' atandığı takdirde, PHP hangi tür satırsonu karakteri (Unix, MS-DOS veya Macintosh) kullanıldığını saptamak için fgets() ve file() işlevlerinde veriyi inceler.

PHP'nin Mac sistemleriyle birlikte çalışabilirliğini sağlar ama öntanımlı değeri Off'tur, çünkü ilk satıra bakarak satırsonu kuralını belirlemeye çalışmak çok az da olsa başarımı düşürücü etki yapar ve ayrıca Unix sistemlerinde öğe ayracı olarak satırbaşı karakteri kullananlar açısından geriye doğru uyumluluğu ortadan kaldırır.

Bilginize: Bu yönerge PHP 4.3.0'dan beri kullanılabilmektedir.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

GLOB_BRACE (integer)
GLOB_ONLYDIR (integer)
GLOB_MARK (integer)
GLOB_NOSORT (integer)
GLOB_NOCHECK (integer)
GLOB_NOESCAPE (integer)
GLOB_AVAILABLE_FLAGS (integer)
PATHINFO_DIRNAME (integer)
PATHINFO_BASENAME (integer)
PATHINFO_EXTENSION (integer)
PATHINFO_FILENAME (integer)
PHP 5.2.0'dan beri.
FILE_USE_INCLUDE_PATH (integer)
dosyaismi include_path içinde aranır (PHP 5'ten beri).
FILE_NO_DEFAULT_CONTEXT (integer)
FILE_APPEND (integer)
İçerik mevcut dosyanın sonuna eklenir.
FILE_IGNORE_NEW_LINES (integer)
Satırsonu karakterlerini yoksayar (PHP 5'ten beri).
FILE_SKIP_EMPTY_LINES (integer)
Boş satırları atlar (PHP 5'ten beri).
FILE_BINARY (integer)

İkil kip (PHP 5.2.7'den beri).

Bilginize:

Bu sabitin PHP öncesinde bir etkisi yoktur. Sadece ileriye uyumluluk adına mevcuttur.

FILE_TEXT (integer)

Metin kipi (PHP 5.2.7'den beri).

Bilginize:

Bu sabitin PHP öncesinde bir etkisi yoktur. Sadece ileriye uyumluluk adına mevcuttur.

INI_SCANNER_NORMAL (integer)
Normal INI tarayıcı kipi (PHP 5.3'ten beri).
INI_SCANNER_RAW (integer)
Ham INI tarayıcı kipi (PHP 5.3'ten beri).
FNM_NOESCAPE (integer)
Tersbölü öncelemesini iptal eder.
FNM_PATHNAME (integer)
Bir dizgedeki bölü çizgisi sadece belirtilen şablondaki bölü çizgisiyle eşleşir.
FNM_PERIOD (integer)
Bir dizgenen başındaki nokta iminin belirtilen şablondaki nokta imiyle tam olarak eşleşmesi gerekir.
FNM_CASEFOLD (integer)
Harf büyüklüğüne duyarsız eşleşme. Bir GNU oluşumudur.
Özkaynak Türleri
Dosya Sistemi İşlevleri
Dosya Sistemi


Dosya Sistemi İşlevleri

Ayrıca Bakınız

Dosya sistemi ile ilgili diğer işlevler için Dizinler ve Program Çalıştırma bölümlerine bakınız.

Uzak dosyalar için kullanılabilen çeşitli URL sarmalayıcıları hakkında bilgi edinmek için Supported Protocols and Wrappers bölümüne bakınız.

İçindekiler

  • basename — Dosya yolunun dosya ismi bileşenini döndürür
  • chgrp — Dosya grubunu değiştirir
  • chmod — Dosya kipini değiştirir
  • chown — Dosyanın sahibini değiştirir
  • clearstatcache — Dosya durum önbelleğini temizler
  • copy — Dosya kopyalar
  • delete — unlink veya unset işlevine bakınız
  • dirname — Belirtilen dosya yolunun dizin bileşenini döndürür
  • disk_free_space — Dizindeki kullanılabilir bayt sayısını döndürür
  • disk_total_space — Bir dizinin toplam boyunu döndürür
  • diskfreespace — disk_free_space işlevinin takma adıdır
  • fclose — Açık bir dosya tanıtıcısını kapatır
  • feof — Bir dosya tanıtıcısı üzerinde konum dosya sonunda mı diye bakar
  • fflush — Çıktıyı bir dosyaya boşaltır
  • fgetc — Dosya tanıtıcısından bir karakter döndürür
  • fgetcsv — Dosya tanıtıcısından CSV alanlarını çözümleyerek bir satır döndürür
  • fgets — Dosya tanıtıcısından bir satır döndürür
  • fgetss — Dosya tanıtıcısından bir satırı HTML etiketlerinden arındırarak döndürür
  • file_exists — Bir dosya veya dizinin mevcut olup olmadığına bakar
  • file_get_contents — Dosya içeriğinin tamamını bir dizge olarak döndürür
  • file_put_contents — Bir dizgeyi bir dosyaya yazar
  • file — Dosya içeriğinin tamamını bir diziye okur
  • fileatime — Dosyaya son erişim zamanını döndürür
  • filectime — Dosyanın dosya düğümü değişiklik zamanını döndürür
  • filegroup — Dosyanın sahibi olan grubu döndürür
  • fileinode — Dosyanın düğüm numarasını döndürür
  • filemtime — Dosyanın değişiklik zamanını döndürür
  • fileowner — Dosya sahibini döndürür
  • fileperms — Dosya izinlerini döndürür
  • filesize — Dosya uzunluğunu döndürür
  • filetype — Dosya türünü döndürür
  • flock — Taşınabilir tavsiye niteliğinde dosya kilitleme
  • fnmatch — Dosya ismi belirtilen kalıpla eşleşiyor mu diye bakar
  • fopen — Bir dosya veya URL'yi açar
  • fpassthru — Bir dosya tanıtıcısında kalan verinin tamamını çıktılar
  • fputcsv — Satırı CSV olarak biçemler ve dosya tanıtıcısına yazar
  • fputs — fwrite işlevinin takma adıdır
  • fread — Dosyayı ikil kipte okur
  • fscanf — Bir dosyadaki girdiyi belli bir biçeme göre çözümler
  • fseek — Dosya tanıtıcısında konumu bir yerden başka bir yere taşır
  • fstat — Bir açık dosya tanıtıcısı kullanarak bir dosya hakkında bilgi döndürür
  • ftell — Dosya okuma/yazma konumlayıcının mevcut konumu ile döner
  • ftruncate — Bir dosyayı belli bir uzunlukta budar
  • fwrite — Dosyaya ikil kipte yazar
  • glob — Bir kalıpla eşleşen dosya yollarını bulur
  • is_dir — Bir dosyanın bir dizin olup olmadığını söyler
  • is_executable — Bir dosyanın çalıştırılabilir bir dosya olup olmadığını söyler
  • is_file — Bir dosyanın sıradan bir dosya olup olmadığını söyler
  • is_link — Bir dosyanın sembolik bağ olup olmadığını söyler
  • is_readable — Bir dosyanın mevcut ve okunabilir olup olmadığını söyler
  • is_uploaded_file — Bir dosya HTTP POST üzerinden karşıya yüklenebilecekse bunu söyler
  • is_writable — Bir dosyanın yazılabilir olup olmadığını söyler
  • is_writeable — is_writable işlevinin takma adıdır
  • lchgrp — Bir sembolik bağın grubunu değiştirir
  • lchown — Bir sembolik bağın sahibini değiştirir
  • link — Sabit bir bağ oluşturur
  • linkinfo — Bir bağ hakkında bilgi verir
  • lstat — Bir dosya veya sembolik bağ hakkında bilgi verir
  • mkdir — Dizin oluşturur
  • move_uploaded_file — Karşıya yüklenen bir dosyayı yeni bir yere taşır
  • parse_ini_file — Bir yapılandırma dosyasını çözümler
  • parse_ini_string — Bir yapılandırma dizgesini çözümler
  • pathinfo — Bir dosya yolu hakkında bilgi döndürür
  • pclose — Bir süreç tanıtıcısını kapatır
  • popen — Bir süreç tanıtıcısı açar
  • readfile — Bir dosyayı çıktılar
  • readlink — Bir sembolik bağın hedefi ile döner
  • realpath_cache_get — Get realpath cache entries
  • realpath_cache_size — Get realpath cache size
  • realpath — Normalleştirilmiş mutlak dosya yolunu döndürür
  • rename — Bir dosya veya dizinin ismini değiştirir
  • rewind — Bir dosya tanıtıcısında konumu başa taşır
  • rmdir — Dizin siler
  • set_file_buffer — stream_set_write_buffer işlevinin takma adıdır
  • stat — Bir dosya hakkında bilgi döndürür
  • symlink — Bir sembolik bağ oluşturur
  • tempnam — Eşsiz bir isimle dosya oluşturur
  • tmpfile — Geçici bir dosya oluşturur
  • touch — Dosyanın erişim ve değişiklik zamanını ayarlar
  • umask — Geçerli izin maskesini değiştirir
  • unlink — Bir dosyayı siler
Öntanımlı Sabitler
basename
Dosya Sistemi


Dosya yolunun dosya ismi bileşenini döndürür

Dosya Sistemi İşlevleri
chgrp
Dosya Sistemi İşlevleri
PHP Manual

basename

(PHP 4, PHP 5, PHP 7)

basename — Dosya yolunun dosya ismi bileşenini döndürür

Açıklama

string basename ( string $yol [, string $uzantı ] )

Belirtilen dosya yolunun dosya ismi bileşenini döndürür.

Değiştirgeler

yol

Dosya yolu.

Dizin ayırma karakteri olarak Windows üzerinde hem bölü ( / ) hem de ters bölü ( \ ) çizgisi kullanılabilirken diğer ortamlarda sadece bölü ( / ) çizgisi kullanılabilir.

uzantı

Dönen bileşenden kaldırılacak dosya uzantısı.

Dönen Değerler

Belirtilen dosya yolunun dosya ismi bileşenini döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
4.1.0 | uzantı değiştirgesi eklendi.

Örnekler

Örnek 1 - basename() örneği

<?php
$yol = "/home/httpd/html/index.php";
$dosya = basename($yol);         // $dosya => "index.php"
$dosya = basename($yol, ".php"); // $dosya => "index"
?>

Ayrıca Bakınız

  • dirname() - Belirtilen dosya yolunun dizin bileşenini döndürür
  • pathinfo() - Bir dosya yolu hakkında bilgi döndürür

Dosya Sistemi İşlevleri
chgrp
Dosya Sistemi İşlevleri


Dosya grubunu değiştirir

basename
chmod
Dosya Sistemi İşlevleri
PHP Manual

chgrp

(PHP 4, PHP 5, PHP 7)

chgrp — Dosya grubunu değiştirir

Açıklama

bool chgrp ( string $dosyaismi , mixed $grup )

dosyaismi ile belirtilen dosyanın grubunu grup yapmaya çalışır.

Bir dosyanın grubunu keyfi olarak sadece root değiştirebilir; diğer kullanıcılar sadece sahibi oldukları bir dosyanın grubunu üyesi oldukları gruplarla değiştirebilirler.

Değiştirgeler

dosyaismi

Dosya yolu.

grup

Grup ismi veya numarası.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Bir dosyanın grubunun değiştirilmesi

<?php
$filename = 'shared_file.txt';
$format = "%s's Group ID @ %s: %d\n";
printf($format, $filename, date('r'), filegroup($filename));
chgrp($filename, 8);
printf($format, $filename, date('r'), filegroup($filename));
?>

Notlar

Bilginize: Dosyaların sunucunun dosya sistemi üzerinden erişilebilir olması gerektiğinden bu işlev uzak dosyalar üzerinde çalışmayacaktır.

Bilginize: Güvenli kip etkinken, PHP, dosya ve dizinlerin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığını sınar.

Ayrıca Bakınız

  • chown() - Dosyanın sahibini değiştirir
  • chmod() - Dosya kipini değiştirir

basename
chmod
Dosya Sistemi İşlevleri


Dosya kipini değiştirir

chgrp
chown
Dosya Sistemi İşlevleri
PHP Manual

chmod

(PHP 4, PHP 5, PHP 7)

chmod — Dosya kipini değiştirir

Açıklama

bool chmod ( string $dosyaismi , int $kip )

Belirtilen dosyanın kipini kip yapmaya çalışır.

Değiştirgeler

dosyaismi

Dosya yolu.

kip

kip ile belirtilen değerin özdevinimli olarak sekizlik bir değer olduğu varsayılmamaktadır, bu bakımdan değerin önüne 0 getirmeniz gerekir. Ayrıca, ("g+w" gibi) dizgesel kip belirtimleri çalışmayacaktır.

<?php
chmod("/somedir/somefile", 755);   // onluk tabanda; doğru sonuç vermeyebilir
chmod("/somedir/somefile", "u+rwx,go+rx"); // dizge; doğru sonuç vermeyebilir
chmod("/somedir/somefile", 0755);  // sekizlik; doğru kip değeri.
?>

kip değiştirgesi üç adet sekizlik değerden oluşur. Sırayla kullanıcı, grup ve diğerlerinin izinlerini düzenlerler. Her bileşen kullanıcıya verilen izinlerin toplamından oluşur. Çalıştırma hakkı için 1, yazma hakkı için 2 ve okuma hakkı için 4 değeri toplama dahil edilir. Unix sistemlerindeki kipler hakkında daha ayrıntılı bilgiyi 'man 1 chmod' ve 'man 2 chmod' kılavuz sayfalarında bulabilirsiniz.

<?php
//sahibinden başkası okuyup yazamasın
chmod("/birdizin/birdosya", 0600);

// Sahibi okuyup yazsın başka herkes sadece okuyabilsin
chmod("/birdizin/birdosya", 0644);

// Sahibi herşeyi yapsın, başka herkes okuyup çalıştırabilsin
chmod("/birdizin/birdosya", 0755);

// Sahibi herşeyi yapsın, grup üyeleri okuyup çalıştırabilsin,
// diğerleri hiçbir şey yapamasın
chmod("/birdizin/birdosya", 0750);
?>

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

Bilginize:

Geçerli kullanıcı PHP'yi çalıştıran kullanıcıdır. Muhtemelen normal kabuk ve FTP erişimi için kullandığınız kullanıcı değildir. Çoğu sistemde dosyanın kipini sadece dosyanın sahibi olan kullanıcı değiştirebilir.

Bilginize: Dosyaların sunucunun dosya sistemi üzerinden erişilebilir olması gerektiğinden bu işlev uzak dosyalar üzerinde çalışmayacaktır.

Bilginize:

safe_mode etkinse, PHP, üzerinde işlem yaptığınız dizin ve dosyaların sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığını sınayacaktır. Ayrıca, SUID, SGID ve yapışkan bitleri bu işlevle tanımlayamazsınız.

Ayrıca Bakınız

  • chown() - Dosyanın sahibini değiştirir
  • chgrp() - Dosya grubunu değiştirir
  • fileperms() - Dosya izinlerini döndürür
  • stat() - Bir dosya hakkında bilgi döndürür

chgrp
chown
Dosya Sistemi İşlevleri


Dosyanın sahibini değiştirir

chmod
clearstatcache
Dosya Sistemi İşlevleri
PHP Manual

chown

(PHP 4, PHP 5, PHP 7)

chown — Dosyanın sahibini değiştirir

Açıklama

bool chown ( string $dosyaismi , mixed $kullanıcı )

dosyaismi ile belirtilen dosyanın sahibini kullanıcı yapmaya çalışır. Bu değişikliği sadece root yapabilir.

Değiştirgeler

dosyaismi

Dosya yolu.

kullanıcı

Kullanıcı ismi veya numarası.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - chown() örneği

<?php

// Kullanılacak dosya ve kullanıcı ismi
$dosya_ismi= "foo.php";
$yol = "/home/sites/php.net/public_html/sandbox/" . $dosya_ismi ;
$kull_ismi = "root";

// Kullanıcıyı değiştirelim
chown($yol, $kull_ismi);

// sonucu sınayalım
$durum = stat($yol);
print_r(posix_getpwuid($stat['uid']));

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(7) {
  ["name"]=>
  string(13) "php.net"
  ["passwd"]=>
  string(1) "x"
  ["uid"]=>
  int(148864)
  ["gid"]=>
  int(148910)
  ["gecos"]=>
  string(13) "php.net"
  ["dir"]=>
  string(25) "/home/sites/php.net"
  ["shell"]=>
  string(13) "/sbin/nologin"
}

Notlar

Bilginize: Dosyaların sunucunun dosya sistemi üzerinden erişilebilir olması gerektiğinden bu işlev uzak dosyalar üzerinde çalışmayacaktır.

Bilginize: Güvenli kip etkinken, PHP, dosya ve dizinlerin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığını sınar.

Ayrıca Bakınız

  • chmod() - Dosya kipini değiştirir

chmod
clearstatcache
Dosya Sistemi İşlevleri


Dosya durum önbelleğini temizler

chown
copy
Dosya Sistemi İşlevleri
PHP Manual

clearstatcache

(PHP 4, PHP 5, PHP 7)

clearstatcache — Dosya durum önbelleğini temizler

Açıklama

void clearstatcache ([ bool $gerçek_yol_belleğini_temizle = false [, string $dosyaismi ]] )

Aşağıda verilen etkilenen işlevler listesindeki işlevlerden başka stat() veya lstat() işlevini kullanırsanız PHP işlemi hızlandırmak için bu işlevlerin döndürdüğü bilgiyi önbelleğe alır. Bununla birlikte belli durumlarda önbellekteki bilgiyi temizlemek ihtiyacını duyabilirsiniz. Örneğin hep aynı dosyanın varlığını sınayan bir betik için dosyanın işlem sırasında silinmesi veya değişmesi tehlikesi varsa durum önbelleğini temizlememeyi seçebilirsiniz. Bu gibi durumlarda, PHP'nin dosya hakkında önbelleğe aldığı bilgiyi temizlemek için clearstatcache() işlevini kullanabilirsiniz.

PHP'nin mevcut olmayan dosyalar hakkında önbellekte bilgi saklamadığına dikkat ediniz. Bu bakımdan, varolmayan bir dosya üzerinde file_exists() işlevini çağırırsanız, siz dosyayı oluşturana kadar işlev FALSE döndürecektir. Siz dosyayı oluşturduktan sonra dosyayı silseniz bile işlev TRUE döndürecektir. Bunun yanında, unlink() işlevi önbelleği özdevinimli olarak temizleyecektir.

Bilginize:

Bu işlev belli dosya isimleri hakkında bilgiyi önbelleğe alır; dolayısıyla aynı dosya üzerinde çok sayıda işlem yapıyorsanız ve bu dosya hakkındaki bilgilerin önbellekte saklanmaması gerekiyorsa tek ihtiyacınız clearstatcache() çağrısı yapmak olacaktır.

Önbelleklemeden etkilenen işlevler:
stat(),
lstat(),
file_exists(),
is_writable(),
is_readable(),
is_executable(),
is_file(),
is_dir(),
is_link(),
filectime(),
fileatime(),
filemtime(),
fileinode(),
filegroup(),
fileowner(),
filesize(),
filetype() ve
fileperms().

Değiştirgeler

gerçek_yol_belleğini_temizle

Öntanımlı olarak gerçek yol belleği temizlenmez.

dosyaismi

Belirtilen dosya için gerçek yol önbelleğini sadece gerçek_yol_belleğini_temizle değiştirgesine TRUE atandığı takdirde temizleyecektir.

Dönen Değerler

Hiçbir değer dönmez.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | İsteğe bağlı gerçek_yol_belleğini_temizle ve dosyaismi değiştirgeleri eklendi.

Örnekler

Örnek 1 - clearstatcache() örneği

<?php
$file = 'output_log.txt';

function get_owner($file)
{
    $stat = stat($file);
    $user = posix_getpwuid($stat['uid']);
    return $user['name'];
}

$format = "UID @ %s: %s\n";

printf($format, date('r'), get_owner($file));

chown($file, 'ross');
printf($format, date('r'), get_owner($file));

clearstatcache();
printf($format, date('r'), get_owner($file));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

UID @ Sun, 12 Oct 2008 20:48:28 +0100: root
UID @ Sun, 12 Oct 2008 20:48:28 +0100: root
UID @ Sun, 12 Oct 2008 20:48:28 +0100: ross

chown
copy
Dosya Sistemi İşlevleri


Dosya kopyalar

clearstatcache
delete
Dosya Sistemi İşlevleri
PHP Manual

copy

(PHP 4, PHP 5, PHP 7)

copy — Dosya kopyalar

Açıklama

bool copy ( string $kaynak , string $hedef [, resource $bağlam ] )

kaynak dosyasını hedef dosyasına kopyalar.

Dosyayı taşımak istiyorsanız rename() işlevini kullanın.

Değiştirgeler

kaynak

Kaynak dosyanın yolu.

hedef

Hedef dosyanın yolu. Bir URL olarak belirtilirse sarmalayıcı mevcut dosyaların üzerine yazılmasını desteklemiyorsa kopyalama başarısız olabilir.

Uyarı

Hedefte dosya varsa, dosyanın üzerine yazılır.

bağlam

stream_context_create() işlevi tarafından oluşturulmuş geçerli bir bağlam.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | Bağlam desteği eklendi.
4.3.0 | Eğer fopen sarmalayıcıları etkinse, hem kaynak hem de hedef artık URL olabilmektedir. Ayrıntılar için fopen() işlevine bakınız.

Örnekler

Örnek 1 - copy() örneği

<?php
$mevcut = 'example.txt';
$yeni = 'example.txt.bak';

if (!copy($mevcut, $yeni)) {
    echo "$mevcut kopyalanamadı...\n";
}
?>

Ayrıca Bakınız

  • move_uploaded_file() - Karşıya yüklenen bir dosyayı yeni bir yere taşır
  • rename() - Bir dosya veya dizinin ismini değiştirir
  • Karşıya dosya yükleme

clearstatcache
delete
Dosya Sistemi İşlevleri


unlink veya unset işlevine bakınız

copy
dirname
Dosya Sistemi İşlevleri
PHP Manual

delete

delete — unlink() veya unset() işlevine bakınız

Açıklama

void delete ( void )

unlink() veya unset() işlevlerini yanlış yerde arayanlar için yol gösterici bir sayfadır.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • unlink() - Bir dosyayı siler
  • unset() - Belirtilen değişkeni tanımsız yapar

copy
dirname
Dosya Sistemi İşlevleri


Belirtilen dosya yolunun dizin bileşenini döndürür

delete
disk_free_space
Dosya Sistemi İşlevleri
PHP Manual

dirname

(PHP 4, PHP 5, PHP 7)

dirname — Belirtilen dosya yolunun dizin bileşenini döndürür

Açıklama

string dirname ( string $yol )

Belirtilen dosya yolunun dizin bileşenini döndürür.

Değiştirgeler

yol

Dosya yolu.

Dizin ayırma karakteri olarak Windows üzerinde hem bölü ( / ) hem de ters bölü ( \ ) çizgisi kullanılabilirken diğer ortamlarda sadece bölü ( / ) çizgisi kullanılabilir.

Dönen Değerler

Dizin ismini döndürür. yol değiştirgesi hiç bölü çizgisi içermiyorsa, içinde bulunulan dizin anlamında tek bir nokta ('.') döner. Aksi takdirde yol dizgesi son /bileşeni kaldırılarak döndürülülür.

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.0 | dirname() ikil olarak güvenilirdir.
4.0.3 | dirname() POSIX uyumlu oldu.

Örnekler

Örnek 1 - dirname() örneği

<?php
$yol = "/etc/passwd";
$dizin = dirname($yol); // $dizin = "/etc"
?>

Notlar

Bilginize:

PHP 4.3.0'dan beri, eski işlevselliğin boş bir dizge döndürdüğü durumda dirname() çoğunlukla bir bölü çizgisi veya bir nokta döndürmektedir.

Şu örneği ele alalım:

<?php

// PHP 4.3.0 öncesi
dirname('c:/');       // '.' döner

// PHP 4.3.0 sonrası
dirname('c:/x');      // 'c:\' döner
dirname('c:/Temp/x'); // 'c:/Temp' döner
dirname('/x');        // '\' döner

?>

Ayrıca Bakınız

  • basename() - Dosya yolunun dosya ismi bileşenini döndürür
  • pathinfo() - Bir dosya yolu hakkında bilgi döndürür
  • realpath() - Normalleştirilmiş mutlak dosya yolunu döndürür

delete
disk_free_space
Dosya Sistemi İşlevleri


Dizindeki kullanılabilir bayt sayısını döndürür

dirname
disk_total_space
Dosya Sistemi İşlevleri
PHP Manual

disk_free_space

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

disk_free_space — Dizindeki kullanılabilir bayt sayısını döndürür

Açıklama

float disk_free_space ( string $dizin )

Belirtilen dizinin bulunduğu dosya sistemi veya disk bölümünün kullanılabilir toplam boyunu bayt cinsinden döndürür.

Değiştirgeler

dizin

Bir dosya sisteminin veya disk bölümünün bir dizini.

Bilginize:

Bir dizin yerine bir dosya verildiği takdirde işlevin davranışı belirsizdir ve kullanılan işletim sistemine ve PHP sürümüne göre farklılık gösterebilir.

Dönen Değerler

Hata oluşmuşsa FALSE, yoksa kullanılabilir toplam bayt sayısını bir gerçek sayı olarak döndürür.

Örnekler

Örnek 1 - disk_free_space() örneği

<?php
// $df kök dizin altındaki kullanılabilir toplam bayt sayısını içerir
$df = disk_free_space("/");

// Windows üzerinde:
disk_free_space("C:");
disk_free_space("D:");
?>

Notlar

Bilginize: Dosyaların sunucunun dosya sistemi üzerinden erişilebilir olması gerektiğinden bu işlev uzak dosyalar üzerinde çalışmayacaktır.

Ayrıca Bakınız

  • disk_total_space() - Bir dizinin toplam boyunu döndürür

dirname
disk_total_space
Dosya Sistemi İşlevleri


Bir dizinin toplam boyunu döndürür

disk_free_space
diskfreespace
Dosya Sistemi İşlevleri
PHP Manual

disk_total_space

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

disk_total_space — Bir dizinin toplam boyunu döndürür

Açıklama

float disk_total_space ( string $dizin )

Belirtilen dizinin bulunduğu dosya sistemi veya disk bölümünün toplam boyunu bayt cinsinden döndürür.

Değiştirgeler

dizin

Bir dosya sisteminin veya disk bölümünün bir dizini.

Dönen Değerler

Hata durumunda FALSE yoksa toplam bayt sayısını bir gerçek sayı olarak döndürür.

Örnekler

Örnek 1 - disk_total_space() örneği

<?php
// $df kök dizin altındaki toplam bayt sayısını içerir
$df = disk_total_space("/");

// Windows üzerinde:
disk_total_space("C:");
disk_total_space("D:");
?>

Notlar

Bilginize: Dosyaların sunucunun dosya sistemi üzerinden erişilebilir olması gerektiğinden bu işlev uzak dosyalar üzerinde çalışmayacaktır.

Ayrıca Bakınız

  • disk_free_space() - Dizindeki kullanılabilir bayt sayısını döndürür

disk_free_space
diskfreespace
Dosya Sistemi İşlevleri


disk_free_space işlevinin takma adıdır

disk_total_space
fclose
Dosya Sistemi İşlevleri
PHP Manual

diskfreespace

(PHP 4, PHP 5, PHP 7)

diskfreespace — disk_free_space() işlevinin takma adıdır

Açıklama

Bu işlev disk_free_space() işlevinin takma adıdır.

disk_total_space
fclose
Dosya Sistemi İşlevleri


Açık bir dosya tanıtıcısını kapatır

diskfreespace
feof
Dosya Sistemi İşlevleri
PHP Manual

fclose

(PHP 4, PHP 5, PHP 7)

fclose — Açık bir dosya tanıtıcısını kapatır

Açıklama

bool fclose ( resource $dt )

dt ile ilişkilendirilmiş dosya kapatılır.

Değiştirgeler

dt

Dosya tanıtıcısı geçerli olmalı ve fopen() veya fsockopen() tarafından başarıyla açılmış bir dosya için döndürülmüş olmalıdır (ve henüz fclose() tarafından kapatılmamış olmalıdır).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Basit bir fclose() örneği

<?php

$dt = fopen('birdosya.txt', 'r');

fclose($dt);

?>

Ayrıca Bakınız

  • fopen() - Bir dosya veya URL'yi açar
  • fsockopen() - Bir internet veya Unix alan soketi bağlantısı açar

diskfreespace
feof
Dosya Sistemi İşlevleri


Bir dosya tanıtıcısı üzerinde konum dosya sonunda mı diye bakar

fclose
fflush
Dosya Sistemi İşlevleri
PHP Manual

feof

(PHP 4, PHP 5, PHP 7)

feof — Bir dosya tanıtıcısı üzerinde konum dosya sonunda mı diye bakar

Açıklama

bool feof ( resource $dt )

Bir dosya tanıtıcısı üzerinde konum dosya sonunda mı diye bakar.

Değiştirgeler

dt

Dosya tanıtıcısı geçerli olmalı ve fopen() veya fsockopen() tarafından başarıyla açılmış bir dosya için döndürülmüş olmalıdır (ve henüz fclose() tarafından kapatılmamış olmalıdır).

Dönen Değerler

Eğer dosya sonu (EOF) saptanmışsa veya bir hata oluşmuşsa (soketin zaman aşımına uğraması gibi) TRUE, aksi takdirde FALSE döner.

Notlar

Uyarı

fsockopen() tarafından açılmış bir bağlantı sunucu tarafından kapatılmamışsa, feof() işlevi bir zaman aşımı oluşuncaya kadar bekler ve TRUE döndürür. Öntanımlı zaman aşımı süresi 60 saniyedir. Bu değeri değiştirmek için stream_set_timeout() işlevini kullanabilirsiniz.

Uyarı

Eğer belirtilen dosya tanıtıcısı geçersizse feof() başarısız olup TRUE döndürceğinden sonsuz bir döngü oluşabilir.

Örnek 1 - Geçersiz dosya tanıtıcılı feof() örneği

<?php
// Dosya okunamazsa veya yoksa fopen işlevi FALSE döndürür
$file = @fopen("olmayan_dosya", "r");

// fopen FALSE döndürdüğünden bir uyarı çıktılanır
// ve burada sonsuz döngü oluşur.
while (!feof($file)) {
}

fclose($file);
?>
fclose
fflush
Dosya Sistemi İşlevleri


Çıktıyı bir dosyaya boşaltır

feof
fgetc
Dosya Sistemi İşlevleri
PHP Manual

fflush

(PHP 4 >= 4.0.1, PHP 5, PHP 7)

fflush — Çıktıyı bir dosyaya boşaltır

Açıklama

bool fflush ( resource $dt )

Bu işlev tüm tampon çıktısının dosya tanıtıcısı dt ile belirtilen dosyaya yazılması için zorlar.

Değiştirgeler

dt

Dosya tanıtıcısı geçerli olmalı ve fopen() veya fsockopen() tarafından başarıyla açılmış bir dosya için döndürülmüş olmalıdır (ve henüz fclose() tarafından kapatılmamış olmalıdır).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - fflush() kullanarak dosyaya yazma örneği

<?php
$filename = 'bar.txt';

$file = fopen($filename, 'r+');
rewind($file);
fwrite($file, 'Foo');
fflush($file);
ftruncate($file, ftell($file));
fclose($file);
?>

Ayrıca Bakınız

  • clearstatcache() - Dosya durum önbelleğini temizler
  • fwrite() - Dosyaya ikil kipte yazar

feof
fgetc
Dosya Sistemi İşlevleri


Dosya tanıtıcısından bir karakter döndürür

fflush
fgetcsv
Dosya Sistemi İşlevleri
PHP Manual

fgetc

(PHP 4, PHP 5, PHP 7)

fgetc — Dosya tanıtıcısından bir karakter döndürür

Açıklama

string fgetc ( resource $dt )

Belirtilen dosya tanıtıcısından bir karakter döndürür.

Değiştirgeler

dt

Dosya tanıtıcısı geçerli olmalı ve fopen() veya fsockopen() tarafından başarıyla açılmış bir dosya için döndürülmüş olmalıdır (ve henüz fclose() tarafından kapatılmamış olmalıdır).

Dönen Değerler

Dosya tanıtıcısı dt ile belirtilen bir dosyadan tek bir karakter içeren bir dizge döndürür. Dosya sonuna gelindiğinde FALSE döndürür.

Uyarı

Bu işlev mantıksal FALSE değeriyle dönebileceği gibi FALSE olarak değerlendirilebilecek mantıksal olmayan bir değerle de dönebilir. Bu konuda daha fazla bilgi edinmek için Mantıksal Değerler bölümüne bakabilirsiniz. Bu işlevden dönen değeri sınamak için === işlecini kullanınız.

Örnekler

Örnek 1 - fgetc() örneği

<?php
$dt = fopen('birdosya.txt', 'r');
if (!$dt) {
    echo 'birdosya.txt dosyası açılamadı';
}
while (false !== ($kar = fgetc($dt))) {
    echo "$kar\n";
}
?>

Notlar

Bilginize: Bu işlev ikil dosyalarla çalışırken dosya içeriğini değiştirmez.

Ayrıca Bakınız

  • fread() - Dosyayı ikil kipte okur
  • fopen() - Bir dosya veya URL'yi açar
  • popen() - Bir süreç tanıtıcısı açar
  • fsockopen() - Bir internet veya Unix alan soketi bağlantısı açar
  • fgets() - Dosya tanıtıcısından bir satır döndürür

fflush
fgetcsv
Dosya Sistemi İşlevleri


Dosya tanıtıcısından CSV alanlarını çözümleyerek bir satır döndürür

fgetc
fgets
Dosya Sistemi İşlevleri
PHP Manual

fgetcsv

(PHP 4, PHP 5, PHP 7)

fgetcsv — Dosya tanıtıcısından CSV alanlarını çözümleyerek bir satır döndürür

Açıklama

array fgetcsv ( resource $dt [, int $uzunluk [, string $ayraç = ',' [, string $sınırlayıcı = '"' [, string $öncelem = '\\' ]]]] )

Satırı okuyup CSV biçemindeki alanları bir dizi içinde döndürmesi dışında fgets() işlevi gibidir.

Değiştirgeler

dt

fopen(), popen()veya fsockopen() tarafından başarıyla açılmış geçerrli bir dosyanın tanıtıcısı.

uzunluk

CSV dosyasındaki en uzun satırdan (satırsonu karakterleri dahil) daha büyük bir değer içermelidir. PHP5'te isteğe bağlı hale gelmiştir. Bu değiştirgenin belirtilmemesi (veya PHP 5.0.4 ve sonrası için 0 belirtilmesi) durumunda azami satır uzunluğu sınırlanmaz fakat işlem yavaşlar.

ayraç

İsteğe bağlı bu değiştirge ile tek karakterlik alan ayracı belirtilir.

sınırlayıcı

İsteğe bağlı bu değiştirge ile tek karakterlik alan sınırlayıcı belirtilir.

escape

Önceleme karakteri belirtilir (tek bir karakter).

Dönen Değerler

Okunan alanları içeren indisli bir dizi döner.

Bilginize:

CSV dosyasındaki boş bir satır tek bir null içeren bir dizi olarak döndürülür ve bir hata olarak ele alınmaz.

Bilginize: Eğer PHP'nin Macintosh bilgisayarlarda çalışırken veya bu bilgisayarlarda oluşturulmuş dosyalarla çalışırken satır sonlarını tanımamaması gibi bir sorunla karşılaşırsanız, auto_detect_line_endings çalışma anı seçeneğini etkin kılarak bu sorunu çözebilirsiniz.

fgetcsv() işlevi, geçersiz dt belirtilmişse NULL, dosya sonuna gelindiğinde veya bir hata oluştuğunda ise FALSE döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | öncelem değiştirgesi eklendi.
4.3.5 | fgetcsv() işlevi dosyaları ikil kipte okur oldu.
4.3.0 | sınırlayıcı değiştirgesi eklendi.

Örnekler

Örnek 1 - Bir CSV dosyasının okunup basılması

<?php
$row = 1;
if (($handle = fopen("test.csv", "r")) !== FALSE) {
    while (($data = fgetcsv($handle, 1000, ",")) !== FALSE) {
        $num = count($data);
        echo "<p> $row satırındaki $num alan: <br /></p>\n";
        $row++;
        for ($c=0; $c < $num; $c++) {
            echo $data[$c] . "<br />\n";
        }
     }
    fclose($handle);
 }
?>

Notlar

Bilginize:

Bu işlevde yerel ayarlar hesaba katılır. Eğer LANG, örneğin, tr_TR.UTF-8 ise ISO-8859-9 ile kodlanmış dosyaları bu işlev hatalı okuyacaktır.

Ayrıca Bakınız

  • str_getcsv() - Bir CSV dizgesinin girdilerini bir dizinin elemanlarına paylaştırır
  • explode() - Bir dizgeyi bir ayraca göre bölüp bir dizi haline getirir
  • file() - Dosya içeriğinin tamamını bir diziye okur
  • pack() - Veriyi bir ikil dizge halinde paketler
  • fputcsv() - Satırı CSV olarak biçemler ve dosya tanıtıcısına yazar

fgetc
fgets
Dosya Sistemi İşlevleri


Dosya tanıtıcısından bir satır döndürür

fgetcsv
fgetss
Dosya Sistemi İşlevleri
PHP Manual

fgets

(PHP 4, PHP 5, PHP 7)

fgets — Dosya tanıtıcısından bir satır döndürür

Açıklama

string fgets ( resource $dt [, int $uzunluk ] )

Belirtilen dosya tanıtıcısından bir satır döndürür.

Değiştirgeler

dt

Dosya tanıtıcısı geçerli olmalı ve fopen() veya fsockopen() tarafından başarıyla açılmış bir dosya için döndürülmüş olmalıdır (ve henüz fclose() tarafından kapatılmamış olmalıdır).

uzunluk

uzunluk - 1 bayt okununca bir satırsonu karakterinde veya dosya sonunda (hangisi önce vuku bulursa) okuma işlemi durur. Bir uzunluk belirtilmezse akımdan okuma işlemi satırın sonuna erişilinceye kadar sürdürülür.

Bilginize:

PHP 4.3.0'a kadar, uzunluk belirtilmediğinde satır uzunluğu 1024 bayt kabul edilirdi. Bir dosyadaki satırların büyük çoğunluğu 8KB'tan büyükse, azami bir uzunluk belirtmek betiğiniz için daha verimli olabilir.

Dönen Değerler

Dosya tanıtıcısı dt ile belirtilen bir dosyadan uzunluk - 1 baytlık veriyi bir dizge içinde döndürür.

Bir hata oluşursa FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.0 | fgets() dosyaları ikil kipte okumaya başladı.
4.2.0 | uzunluk değiştirgesi isteğe bağlı oldu.

Örnekler

Örnek 1 - Bir dosyanın satır satır okunması

<?php
$dt = @fopen("/tmp/inputfile.txt", "r");
if ($dt) {
    while (!feof($dt)) {
        $tampon = fgets($dt, 4096);
        echo $tampon;
    }
    fclose($dt);
}
?>

Notlar

Bilginize: Eğer PHP'nin Macintosh bilgisayarlarda çalışırken veya bu bilgisayarlarda oluşturulmuş dosyalarla çalışırken satır sonlarını tanımamaması gibi bir sorunla karşılaşırsanız, auto_detect_line_endings çalışma anı seçeneğini etkin kılarak bu sorunu çözebilirsiniz.

Bilginize:

fgets() işlevinin 'C' dilindeki anlamlandırılmasını bilenler dosya sonu karakterinin (EOF) döndürülüşü ile ilgili farka dikkat etmelidir.

Ayrıca Bakınız

  • fgetss() - Dosya tanıtıcısından bir satırı HTML etiketlerinden arındırarak döndürür
  • fread() - Dosyayı ikil kipte okur
  • fgetc() - Dosya tanıtıcısından bir karakter döndürür
  • stream_get_line() - Akımdan belirtilen ayraca kadar bir satır döndürür
  • fopen() - Bir dosya veya URL'yi açar
  • popen() - Bir süreç tanıtıcısı açar
  • fsockopen() - Bir internet veya Unix alan soketi bağlantısı açar
  • stream_set_timeout() - Akımın zaman aşımı süresini ayarlar

fgetcsv
fgetss
Dosya Sistemi İşlevleri


Dosya tanıtıcısından bir satırı HTML etiketlerinden arındırarak döndürür

fgets
file_exists
Dosya Sistemi İşlevleri
PHP Manual

fgetss

(PHP 4, PHP 5, PHP 7)

fgetss — Dosya tanıtıcısından bir satırı HTML etiketlerinden arındırarak döndürür

Açıklama

string fgetss ( resource $dt [, int $uzunluk [, string $etiketler ]] )

Okunan metinden HTML ve PHP etiketlerini temizlemesi dışında fgets() işlevi ile aynıdır.

Değiştirgeler

dt

Dosya tanıtıcısı geçerli olmalı ve fopen() veya fsockopen() tarafından başarıyla açılmış bir dosya için döndürülmüş olmalıdır (ve henüz fclose() tarafından kapatılmamış olmalıdır).

uzunluk

Döndürülecek verinin uzunluğu.

etiketler

Hangi etiketlerin ayıklanacağını bu isteğe bağlı değiştirge ile belirtebilirsiniz.

Dönen Değerler

Dosya tanıtıcısı dt ile belirtilen bir dosyadan uzunluk - 1 baytlık veriyi HTML ve PHP etiketlerinden arındırarak bir dizge içinde döndürür.

Bir hata oluşursa FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.0 | uzunluk değiştirgesi isteğe bağlı oldu.
4.0.0 | etiketler değiştirgesi eklendi.

Örnek 1 - Bir PHP dosyasının satır satır okunması

<?php
$str = <<<EOD
<html><body>
 <p>Welcome! Today is the <?php echo(date('jS')); ?> of <?= date('F'); ?>.</p>
</body></html>
Text outside of the HTML block.
EOD;
file_put_contents('sample.php', $str);

$dt = @fopen("sample.php", "r");
if ($dt) {
    while (!feof($dt)) {
        $tampon = fgetss($dt, 4096);
        echo $tampon;
    }
    fclose($dt);
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

 Welcome! Today is the  of .

Text outside of the HTML block.

Notlar

Bilginize: Eğer PHP'nin Macintosh bilgisayarlarda çalışırken veya bu bilgisayarlarda oluşturulmuş dosyalarla çalışırken satır sonlarını tanımamaması gibi bir sorunla karşılaşırsanız, auto_detect_line_endings çalışma anı seçeneğini etkin kılarak bu sorunu çözebilirsiniz.

Ayrıca Bakınız

  • fgets() - Dosya tanıtıcısından bir satır döndürür
  • fopen() - Bir dosya veya URL'yi açar
  • popen() - Bir süreç tanıtıcısı açar
  • fsockopen() - Bir internet veya Unix alan soketi bağlantısı açar
  • strip_tags() - Bir dizgeden HTML ve PHP etiketlerini ayıklar

fgets
file_exists
Dosya Sistemi İşlevleri


Bir dosya veya dizinin mevcut olup olmadığına bakar

fgetss
file_get_contents
Dosya Sistemi İşlevleri
PHP Manual

file_exists

(PHP 4, PHP 5, PHP 7)

file_exists — Bir dosya veya dizinin mevcut olup olmadığına bakar

Açıklama

bool file_exists ( string $dosyaismi )

Bir dosya veya dizinin mevcut olup olmadığına bakar.

Değiştirgeler

dosyaismi

Dosya veya dizinin yolu.

Windows üzerinde, ağ paylaşımlarındaki dosyaları sınamak için //makineadı/paylaşım/dosyaismi veya \\makineadı\paylaşım\dosyaismi sözdizimlerini kullanın.

Dönen Değerler

dosyaismi ile belirtilen dosya veya dizin mevcutsa TRUE değilse FALSE.

Bilginize:

Bu işlev var olmayan dosyaları işaret eden sembolik bağlar için FALSE döndürür.

Uyarı

Güvenli kip sınırlamalarından dolayı erişilemeyen dosyalar için bu işlev FALSE döndürür. Bununla birlikte bu dosyaları safe_mode_include_dir yönergesinde belirtilen yollarda bulunuyorsa betiğinize dahil edebilirsiniz.

Bilginize:

Sınama etkin UID/GID ile değil gerçek UID/GID kullanılarak yapılır.

Örnekler

Örnek 1 - Bir dosyanın varlığının sınanması

<?php
$dosya = '/bir/yol/dosya.txt';

if (file_exists($dosya)) {
    echo "$dosya diye bir dosya var";
} else {
    echo "$dosya diye bir dosya yok";
}
?>

Notlar

Bilginize: Bu işlevin sonuçları önbelleğe kaydedilir. Daha ayrıntılı bilgi edinmek için clearstatcache() işlevine bakınız.

İpucu

PHP 5.0.0 sürümünden itibaren bu işlev bazı URL sarmalayıcıları ile kullanılabilmektedir. stat() ailesini destekleyen sarmalayıcıların listesini Supported Protocols and Wrappers başlığı altında bulabilirsiniz.

Ayrıca Bakınız

  • is_readable() - Bir dosyanın mevcut ve okunabilir olup olmadığını söyler
  • is_writable() - Bir dosyanın yazılabilir olup olmadığını söyler
  • is_file() - Bir dosyanın sıradan bir dosya olup olmadığını söyler
  • file() - Dosya içeriğinin tamamını bir diziye okur

fgetss
file_get_contents
Dosya Sistemi İşlevleri


Dosya içeriğinin tamamını bir dizge olarak döndürür

file_exists
file_put_contents
Dosya Sistemi İşlevleri
PHP Manual

file_get_contents

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

file_get_contents — Dosya içeriğinin tamamını bir dizge olarak döndürür

Açıklama

string file_get_contents ( string $dosyaismi [, int $seçenekler = 0 [, resource $bağlam [, int $başlangıç = -1 [, int $uzunluk = -1 ]]]] )

Belirtilen dosyanın başlangıç konumundan başlayan uzunluk baytını bir dizge olarak döndürmesi dışında file() işlevi gibidir. İşlem başarılı olmazsa FALSE döner.

file_get_contents() işlevi bir dosyanın içeriğini bir dizgeye okumak için tercih edilen bir işlevdir. Başarımı arttırmak için eğer işletim sistemi tarafından destekleniyorsa bellek eşlem tekniklerini kullanılacaktır.

Bilginize:

Boşluklar gibi özel karakterler içeren bir URI'yi açmaya çalışıyorsanız URI'yi urlencode() ile kodlamalısınız.

Bilginize:

The default value of uzunluk değiştirgesinin öntanımlı değeri aslında -1 değildir; daha ziyade dahili bir PHP değeri olup, akımın tamamının dosya sonuna kadar kopyalanacağı anlamına gelir. Bu öntanımlı değeri belirtmenin tek yolu değiştirge olarak belirtmemektir (belirtilmesinin isteğe bağlı oluşuna dikkat edin).

Değiştirgeler

dosyaismi

İçeriği okunacak dosyanın ismi.

seçenekler

Bilginize:

PHP 6'dan önceki sürümlerde bu değiştirge include_path_kullan olarak adlandırılır ve bool türünde bir değer alırdı. PHP 5'ten beri, aramanın include path yönergesinde belirtilen yollarda da yapılacağını belirtmek için FILE_USE_INCLUDE_PATH sabitini kullanmanız gerekmektedir.

seçenekler değiştirgesine, bazı sınırlamalarla ve ikil VEYA (|) işleci ile birleştirilmiş olarak aşağıdaki seçenekler belirtilebilir:

Olası seçenekler
Seçenek | Açıklama
FILE_USE_INCLUDE_PATH | Dosya include_path yönergesinde belirtilen yollarda aranır.
FILE_TEXT | PHP 6'dan beri okunan verinin kodlaması UTF-8'dir. Özel bir bağlam oluşturarak veya öntanımlı kodlamayı stream_default_encoding() ile değiştirerek farklı bir kodlama belirtebilirsiniz. Su seçenek FILE_BINARY ile birlikte kullanılamaz.
FILE_BINARY | İçerik ikil veri olarak okunur. Bu öntanımlıdır ve FILE_TEXT ile birlikte kullanılamaz.
bağlam

stream_context_create() işlevi tarafından oluşturulmuş geçerli bir bağlam özkaynağı. Özel bir bağlam kullanmaya ihtiyacınız yoksa bu değiştirgeye NULL atayabilirsiniz.

başlangıç

Okumaya başlanacak konum.

uzunluk

Okunacak verinin azami uzunluğu. Öntanımlı olarak dosya sonuna kadar okunur.

Dönen Değerler

Hata durumunda FALSE aksi takdirde dosyadan okunan veriyi döndürür.

Örnekler

Örnek 1 - Site başsayfasının kaynak kodunun çıktılanması

<?php
$homepage = file_get_contents('http://www.example.com/');
echo $homepage;
?>

Örnek 2 - include_path içinde arama

<?php
// <= PHP 5
$file = file_get_contents('./people.txt', true);
// > PHP 5
$file = file_get_contents('./people.txt', FILE_USE_INCLUDE_PATH);
?>

Örnek 3 - Bir dosyanın belli bir bölümünün okunması

<?php
// 21. karakterden itibaren 14 karakter okuyalım
$section = file_get_contents('./people.txt', NULL, NULL, 20, 14);
var_dump($section);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(14) "lle Bjori Ro"

Örnek 4 - Akım bağlamı kullanımı

<?php
// Bir akım oluşturalım
$opts = array(
  'http'=>array(
    'method'=>"GET",
    'header'=>"Accept-language: en\r\n" .
              "Cookie: foo=bar\r\n"
  )
);

$context = stream_context_create($opts);

// Yukarıda atadığımız HTTP başlıklarını kullanarak dosyayı açalım
$file = file_get_contents('http://www.example.com/', false, $context);
?>

Sürüm Bilgisi

Sürüm: | Açıklama
6.0.0 | include_path_kullan değiştirgesi seçenekler değiştirgesi ile değiştirildi.
5.1.0 | başlangıç ve uzunluk değiştirgeleri eklendi.
5.0.0 | Bağlam desteği eklendi.

Notlar

Bilginize: Bu işlev ikil dosyalarla çalışırken dosya içeriğini değiştirmez.

İpucu

fopen sarmalayıcıları etkin kılınmışsa bu işlevde dosya ismi olarak bir URL belirtebilirsiniz. Dosya isminin nasıl belirtilebileceği hakkında bilgi edinmek için fopen() işlevine bakınız. Sarmalayıcıların neler yapabildiği, kullanım bilgileri ve bunlar tarafından kullanılan öntanımlı değişkenler hakkında bilgi edinmek için ise Supported Protocols and Wrappers bölümüne bakınız.

Uyarı

Microsoft IIS, SSL kullanırken bir close_notify göndermeden bağlantıyı kapatarak protokolle çelişir. Verinin sonuna ulaştığınız zaman PHP bunu "SSL: Fatal Protocol Error" (SSL: "Ölümcül Protokol Hatası") olarak raporlar. Bu sorunu bertaraf etmek için error_reporting değerini uyarıları içermeyecek bir seviyeye indirmek gerekir. PHP, akımı https:// şemasını kullanarak açarsanız hatalı IIS sunucu yazılımını saptayıp uyarıları engelleyebilir. Bir ssl:// soketi oluşturmak için fsockopen() kullanılacaksa uyarıları saptayıp engellemekten geliştirici sorumludur.

Ayrıca Bakınız

  • file() - Dosya içeriğinin tamamını bir diziye okur
  • fgets() - Dosya tanıtıcısından bir satır döndürür
  • fread() - Dosyayı ikil kipte okur
  • readfile() - Bir dosyayı çıktılar
  • file_put_contents() - Bir dizgeyi bir dosyaya yazar
  • stream_get_contents() - Akımdan kalanı bir dizgeye okur
  • stream_context_create() - Bir akım bağlamı oluşturur
file_exists
file_put_contents
Dosya Sistemi İşlevleri


Bir dizgeyi bir dosyaya yazar

file_get_contents
file
Dosya Sistemi İşlevleri
PHP Manual

file_put_contents

(PHP 5, PHP 7)

file_put_contents — Bir dizgeyi bir dosyaya yazar

Açıklama

int file_put_contents ( string $dosyaismi , mixed $veri [, int $seçenekler = 0 [, resource $bağlam ]] )

Bu işlev, veriyi bir dosyaya yazmak için sırayla fopen(), fwrite() ve fclose() işlevlerinin çağrılmasına denk bir işlem yapar.

Eğer dosyaismi mevcut değilse dosya oluşturulur. Aksi takdirde, FILE_APPEND seçeneği etkin değilse veri mevcut dosyanın üzerine yazılır.

Değiştirgeler

dosyaismi

Verinin yazılacağı dosyanın yolu.

veri

Yazılacak veri. Bir dizi, bir dizge veya bir özkaynak olabilir.

Eğer veri bir akım özkaynağı ise tamponda kalan verinin tamamı dosyaya yazılır. Bu işlem, stream_copy_to_stream() kullanımına eşdğerdir.

veri değiştirgesinde tek boyutlu bir dizi de belirtebilirsiniz. Bu takdirde yapılan işlem file_put_contents(dosyaismi, implode('', $dizi)) işlemine denktir.

seçenekler

İsteğe bağlı bu değiştirgede bazı kısıtlamalarla şu sabitlerden bir veya daha fazlasını ikil VEYA (|) ile birleştirerek belirtebilirsiniz:

Belirtilebilecek seçenekler
Seçenet | Açıklama
FILE_USE_INCLUDE_PATH | Dosya include_path yönergesinde belirtilen yollarda aranır.
FILE_APPEND | Eğer dosyaismi dosyası mevcutsa veri dosyanın üzerine yazılmaz, sonuna eklenir. Eklemeler atomik olup kilitlemeye gerek olmadığından LOCK_EX ile birlikte kullanılamaz.
LOCK_EX | Yazma işlemi için dosya üzerinde ayrıcalıklı bir kilit edinilir. FILE_APPEND ile birlikte kullanılamaz.
FILE_TEXT | veri metin kipinde yazılır. Eğer Evrenkod anlambilimsel olarak etkinse öntanımlı kodlama UTF-8'dir. Özel bir bağlam oluşturarak veya stream_default_encoding() işleviyle öntanımlı değeri değiştirerek farklı bir kodlama belirtebilirsiniz. Bu seçenek FILE_BINARY ile birlikte kullanılamaz. Bu seçenek PHP 6'dan beri kullanılabilmektedir.
FILE_BINARY | veri ikil kipte yazılır. Bu öntanımlıdır ve FILE_TEXT ile birlikte kullanılamaz.Bu seçenek PHP 6'dan beri kullanılabilmektedir.

bağlam

stream_context_create() ile oluşturulmuş geçerli bir bağlam özkaynağı.

Dönen Değerler

İşlev, başarısızlık durumunda FALSE, aksi takdirde dosyaya yazılan baytların sayısı ile döner.

Örnekler

Örnek 1 - Basit kullanım örneği

<?php
$file = 'people.txt';
// İçeriğini almak için dosyayı açalım
$içerik = file_get_contents($file);
// İçeriğe yeni bir kişi ekleyelim
$içerik .= "John Smith\n";
// İçeriği dosyaya yazalım
file_put_contents($file, $içerik);
?>

Örnek 2 - Seçenek kullanımı

<?php
$file = 'people.txt';
// Dosyaya eklenecek yeni kişi
$person = "John Smith\n";
// $person değişkeninin değerini $file dosyasının sonuna ekleyelim.
file_put_contents($file, $person, FILE_APPEND);
?>

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.0 | Bağlam desteği eklendi.
5.1.0 | Added support for LOCK_EX için destek ve data değiştirgesinde bir akım kaynağının aktarılabilmesi yeteneği eklendi.
6.0.0 | FILE_TEXT ve FILE_BINARY seçenekleri için destek eklendi.

Notlar

Bilginize: Bu işlev ikil dosyalarla çalışırken dosya içeriğini değiştirmez.

İpucu

fopen sarmalayıcıları etkin kılınmışsa bu işlevde dosya ismi olarak bir URL belirtebilirsiniz. Dosya isminin nasıl belirtilebileceği hakkında bilgi edinmek için fopen() işlevine bakınız. Sarmalayıcıların neler yapabildiği, kullanım bilgileri ve bunlar tarafından kullanılan öntanımlı değişkenler hakkında bilgi edinmek için ise Supported Protocols and Wrappers bölümüne bakınız.

Ayrıca Bakınız

  • fopen() - Bir dosya veya URL'yi açar
  • fwrite() - Dosyaya ikil kipte yazar
  • file_get_contents() - Dosya içeriğinin tamamını bir dizge olarak döndürür
  • stream_context_create() - Bir akım bağlamı oluşturur

file_get_contents
file
Dosya Sistemi İşlevleri


Dosya içeriğinin tamamını bir diziye okur

file_put_contents
fileatime
Dosya Sistemi İşlevleri
PHP Manual

file

(PHP 4, PHP 5, PHP 7)

file — Dosya içeriğinin tamamını bir diziye okur

Açıklama

array file ( string $dosyaismi [, int $seçenekler = 0 [, resource $bağlam ]] )

Dosyanın tamamını bir dizi içinde döndürür.

Bilginize:

Dosya içeğini bir dizge olarak döndürmek için file_get_contents() işlevini kullanabilirsiniz.

Değiştirgeler

dosyaismi

Dosya yolu.

İpucu

fopen sarmalayıcıları etkin kılınmışsa bu işlevde dosya ismi olarak bir URL belirtebilirsiniz. Dosya isminin nasıl belirtilebileceği hakkında bilgi edinmek için fopen() işlevine bakınız. Sarmalayıcıların neler yapabildiği, kullanım bilgileri ve bunlar tarafından kullanılan öntanımlı değişkenler hakkında bilgi edinmek için ise Supported Protocols and Wrappers bölümüne bakınız.

seçenekler

İsteğe bağlı bu değiştirgede şu sabitlerden bir veya daha fazlasını belirtebilirsiniz:

FILE_USE_INCLUDE_PATH
Dosya include_path yönergesinde belirtilen yollarda aranır.
FILE_IGNORE_NEW_LINES
Her dizi elemanının sonuna satırsonu karakteri eklenmez.
FILE_SKIP_EMPTY_LINES
Boş satırlar atlanır.
FILE_TEXT
İçerik UTF-8 kodlu döndürülür. Özel bir bağlam oluşturarark farklı bir kodlama belirtebilirsiniz. Bu seçenek FILE_BINARY ile birlikte kullanılamaz.
FILE_BINARY
İçerik ikil veri olarak okunur. Bu öntanımlıdır ve FILE_TEXT ile birlikte kullanılamaz.

bağlam

stream_context_create() işlevi ile oluşturulmuş bir bağlam özkaynağı.

Bilginize: Bağlamsal destek PHP 5.0.0 ile eklenmiştir. Bağlamlar hakkında bilgi edinmek için Akım İşlevleri belgesine bakınız.

Dönen Değerler

Dosyayı bir dizi olarak döndürür. Dizinin her elemanı dosyanın bir satırına karşılıktır ve satırsonu karakterleri ayrılmaz. Başarısızlık durumunda işlev FALSE döndürür.

Bilginize:

FILE_IGNORE_NEW_LINES sabiti kullanılmadığı sürece dizinin her elemanı bir satırsonu karakteri içerecektir. Bu satırsonu karakterlerinden kurtulmak isterseniz rtrim() işlevini kullanabilirsiniz.

Bilginize: Eğer PHP'nin Macintosh bilgisayarlarda çalışırken veya bu bilgisayarlarda oluşturulmuş dosyalarla çalışırken satır sonlarını tanımamaması gibi bir sorunla karşılaşırsanız, auto_detect_line_endings çalışma anı seçeneğini etkin kılarak bu sorunu çözebilirsiniz.

Sürüm Bilgisi

Sürüm: Açıklama
6.0.0 FILE_TEXT ve FILE_BINARY seçenekleri desteği eklendi.

Bilginize:

İleriye uyumluluk adına, bu sabitler PHP 5.2.7'den beri mevcuttur.

5.0.0 | bağlam değiştirgesi eklendi.
5.0.0 | PHP 5.0.0 öncesinde seçenekler değiştirgesi sadece include_path yönergesinde belirtilen yolları kapsardı ve daima 1 ile etkinleştirilirdi.
4.3.0 | file() işlevi veriyi ikil kipte okur oldu.

Örnekler

Örnek 1 - file() örneği

<?php
// Dosyayı bir diziye aktaralım. Bu örnekte HTTP üzerinden
// bir URL sayesinde HTML içeriği okuyacağız.
$lines = file('http://www.example.com/');

// Diziyi döngüye sokarak HTML kaynağını satır
// numaralarıyla birlikte gösterelim.
foreach ($lines as $line_num => $line) {
    echo "Satır #<b>{$line_num}</b>: " . htmlspecialchars($line) . "<br />\n";
}

// Diğer bir örnek olarak bir HTML sayfayı bir dizgeye aktaracağız.
// Bunun için file_get_contents() işlevine de bakınız.
$html = implode('', file('http://www.example.com/'));

// PHP 5'ten itibaren isteğe bağlı seçenekler
// değiştirgesini kullanabiliriz
$trimmed = file('somefile.txt', FILE_IGNORE_NEW_LINES | FILE_SKIP_EMPTY_LINES);
?>

Notlar

Uyarı

Microsoft IIS, SSL kullanırken bir close_notify göndermeden bağlantıyı kapatarak protokolle çelişir. Verinin sonuna ulaştığınız zaman PHP bunu "SSL: Fatal Protocol Error" (SSL: "Ölümcül Protokol Hatası") olarak raporlar. Bu sorunu bertaraf etmek için error_reporting değerini uyarıları içermeyecek bir seviyeye indirmek gerekir. PHP, akımı https:// şemasını kullanarak açarsanız hatalı IIS sunucu yazılımını saptayıp uyarıları engelleyebilir. Bir ssl:// soketi oluşturmak için fsockopen() kullanılacaksa uyarıları saptayıp engellemekten geliştirici sorumludur.

Ayrıca Bakınız

  • readfile() - Bir dosyayı çıktılar
  • fopen() - Bir dosya veya URL'yi açar
  • fsockopen() - Bir internet veya Unix alan soketi bağlantısı açar
  • popen() - Bir süreç tanıtıcısı açar
  • file_get_contents() - Dosya içeriğinin tamamını bir dizge olarak döndürür
  • include - include
  • stream_context_create() - Bir akım bağlamı oluşturur

file_put_contents
fileatime
Dosya Sistemi İşlevleri


Dosyaya son erişim zamanını döndürür

file
filectime
Dosya Sistemi İşlevleri
PHP Manual

fileatime

(PHP 4, PHP 5, PHP 7)

fileatime — Dosyaya son erişim zamanını döndürür

Açıklama

int fileatime ( string $dosyaismi )

Belirtilen dosyaya son erişim zamanını döndürür.

Değiştirgeler

dosyaismi

Dosya yolu.

Dönen Değerler

Hata durumunda FALSE aksi takdirde dosyaya son erişim zamanını döndürür. Zaman bir Unix zaman damgası olarak döndürülür.

Örnekler

Örnek 1 - fileatime() örneği

<?php
// Çıktı şöyle bir şey olur:
// birdosya.txt dosyasının son erişim zamanı: December 29 2008 22:16:23.

$dosya = 'birdosya.txt';
if (file_exists($dosya)) {
    echo "$dosya dosyasının son değişiklik zamanı: " .
          date ("F d Y H:i:s.", fileatime($dosya));
}
?>

Notlar

Bilginize:

Bir dosyanın erişim zamanının dosyanın veri blokları okunduğu zaman değiştiği varsayılır. Eğer bir uygulama çok büyük sayıda dosya ve dizine erişerek çalışıyorsa, bu, epeyce bir başarım kaybına sebep olur.

Bazı Unix dosya sistemlerinde böyle uygulamaların başarımını arttırabilmek için erişim zamanının güncellenmesi iptal edilebilmektedir. Böyle dosya sistemlerinde bu işlev kullanışsızdır.

Bilginize:

Zaman çözünürlüğünün dosya sistemine göre farklı olabileceğini unutmayın.

Bilginize: Bu işlevin sonuçları önbelleğe kaydedilir. Daha ayrıntılı bilgi edinmek için clearstatcache() işlevine bakınız.

İpucu

PHP 5.0.0 sürümünden itibaren bu işlev bazı URL sarmalayıcıları ile kullanılabilmektedir. stat() ailesini destekleyen sarmalayıcıların listesini Supported Protocols and Wrappers başlığı altında bulabilirsiniz.

Ayrıca Bakınız

  • filemtime() - Dosyanın değişiklik zamanını döndürür
  • fileinode() - Dosyanın düğüm numarasını döndürür
  • date() - Yerel tarihi/saati biçimlendirir

file
filectime
Dosya Sistemi İşlevleri


Dosyanın dosya düğümü değişiklik zamanını döndürür

fileatime
filegroup
Dosya Sistemi İşlevleri
PHP Manual

filectime

(PHP 4, PHP 5, PHP 7)

filectime — Dosyanın dosya düğümü değişiklik zamanını döndürür

Açıklama

int filectime ( string $dosyaismi )

Belirtilen dosyanın dosya düğümü değişiklik zamanını döndürür.

Değiştirgeler

dosyaismi

Dosya yolu.

Dönen Değerler

Belirtilen dosyanın son dosya düğümü değişiklik zamanını döndürür. Hata durumunda FALSE döner. Zaman bir Unix zaman damgası olarak döndürülür.

Örnekler

Örnek 1 - filectime() örneği

<?php
// Çıktı şöyle bir şey olur:
// birdosya.txt dosyasının son değişiklik zamanı: December 29 2008 22:16:23.

$dosya = 'birdosya.txt';
if (file_exists($dosya)) {
    echo "$dosya dosyasının son değişiklik zamanı: " .
          date ("F d Y H:i:s.", filectime($dosya));
}
?>

Notlar

Bilginize:

Çoğu Unix dosya sisteminde dosya düğümü verisi değiştiğinde, yani, dosya izinleri, dosyanın sahibi veya grubu ya da diğer temel verileri değiştiğinde dosya değişmiş sayılır. Ayrıca, (sitenizin son güncellendiği tarihi belirtmek isterseniz) filemtime() ve fileatime() işlevlerine de bakınız.

Bilginize:

Bazı Unix belgelerinde bir dosyanın dosya düğümü değişiklik zamanı dosyanın oluşturuluş zamanı olarak gösterilir. Bu yanlıştır. Çoğu Unix dosya sisteminde Unix dosyaları için bir oluşturulma zamanı mevcut değildir.

Bilginize:

Zaman çözünürlüğünün dosya sistemine göre farklı olabileceğini unutmayın.

Bilginize: Bu işlevin sonuçları önbelleğe kaydedilir. Daha ayrıntılı bilgi edinmek için clearstatcache() işlevine bakınız.

İpucu

PHP 5.0.0 sürümünden itibaren bu işlev bazı URL sarmalayıcıları ile kullanılabilmektedir. stat() ailesini destekleyen sarmalayıcıların listesini Supported Protocols and Wrappers başlığı altında bulabilirsiniz.

Ayrıca Bakınız

  • filemtime() - Dosyanın değişiklik zamanını döndürür

fileatime
filegroup
Dosya Sistemi İşlevleri


Dosyanın sahibi olan grubu döndürür

filectime
fileinode
Dosya Sistemi İşlevleri
PHP Manual

filegroup

(PHP 4, PHP 5, PHP 7)

filegroup — Dosyanın sahibi olan grubu döndürür

Açıklama

int filegroup ( string $dosyaismi )

Dosyanın sahibi olan grubu döndürür. Grup kimliği sayısal biçemde döner. Grup ismini elde etmek için posix_getgrgid() işlevini kullanabilirsiniz.

Değiştirgeler

dosyaismi

Dosya yolu.

Dönen Değerler

Hata durumunda FALSE aksi takdirde dosyanın sahibi olan grubu döndürür. Grup kimliği sayısal biçemde döner. Grup ismini elde etmek için posix_getgrgid() işlevini kullanabilirsiniz.

Örnekler

Örnek 1 - Bir dosyanın grubunun bulunması

<?php
$dosya = 'index.php';
print_r(posix_getgrgid(filegroup($dosya)));
?>

Hatalar/İstisnalar

Başarısızlık halinde bir E_WARNING çıktılanır.

Notlar

Bilginize: Bu işlevin sonuçları önbelleğe kaydedilir. Daha ayrıntılı bilgi edinmek için clearstatcache() işlevine bakınız.

İpucu

PHP 5.0.0 sürümünden itibaren bu işlev bazı URL sarmalayıcıları ile kullanılabilmektedir. stat() ailesini destekleyen sarmalayıcıların listesini Supported Protocols and Wrappers başlığı altında bulabilirsiniz.

Ayrıca Bakınız

  • fileowner() - Dosya sahibini döndürür
  • posix_getgrgid() - Grup kimliği belirtilen grup hakkında bilgi verir
  • safe_mode_gid

filectime
fileinode
Dosya Sistemi İşlevleri


Dosyanın düğüm numarasını döndürür

filegroup
filemtime
Dosya Sistemi İşlevleri
PHP Manual

fileinode

(PHP 4, PHP 5, PHP 7)

fileinode — Dosyanın düğüm numarasını döndürür

Açıklama

int fileinode ( string $dosyaismi )

Dosyanın düğüm numarasını döndürür.

Değiştirgeler

filename

Dosya yolu.

Dönen Değerler

Hata durumunda FALSE aksi takdirde dosyanın düğüm numarasını döndürür.

Örnekler

Örnek 1 - Bir dosyanın düğüm numarasının geçerli dosya ile karşılaştırılması

<?php
$dosya = 'index.php';
if (getmyinode() == fileinode($dosya)) {
    echo 'Geçerli dosyayı sınıyorsunuz.';
}
?>

Notlar

Bilginize: Bu işlevin sonuçları önbelleğe kaydedilir. Daha ayrıntılı bilgi edinmek için clearstatcache() işlevine bakınız.

İpucu

PHP 5.0.0 sürümünden itibaren bu işlev bazı URL sarmalayıcıları ile kullanılabilmektedir. stat() ailesini destekleyen sarmalayıcıların listesini Supported Protocols and Wrappers başlığı altında bulabilirsiniz.

Ayrıca Bakınız

  • getmyinode() - Çalışan betiğin dosya düğümü numarasını döndürür
  • stat() - Bir dosya hakkında bilgi döndürür

filegroup
filemtime
Dosya Sistemi İşlevleri


Dosyanın değişiklik zamanını döndürür

fileinode
fileowner
Dosya Sistemi İşlevleri
PHP Manual

filemtime

(PHP 4, PHP 5, PHP 7)

filemtime — Dosyanın değişiklik zamanını döndürür

Açıklama

int filemtime ( string $dosyaismi )

Bu işlev belirtilen dosyanın veri bloklarına yazıldığı, yani dosya içeriğinin değişikliğe uğradığı zamanı döndürür.

Değiştirgeler

dosyaismi

Dosya yolu.

Dönen Değerler

Hata durumunda FALSE aksi takdirde dosyanın son değişiklik zamanını döndürür. Zaman, date() işlevi için uygun bir Unix zaman damgası olarak döner.

Örnekler

Örnek 1 - filemtime() örneği

<?php
// Çıktı şöyle bir şey olur:
// birdosya.txt dosyasının son değişiklik zamanı: December 29 2008 22:16:23.

$dosya = 'birdosya.txt';
if (file_exists($dosya)) {
    echo "$dosya dosyasının son değişiklik zamanı: " .
          date ("F d Y H:i:s.", filemtime($dosya));
}
?>

Notlar

Bilginize:

Zaman çözünürlüğünün dosya sistemine göre farklı olabileceğini unutmayın.

Bilginize: Bu işlevin sonuçları önbelleğe kaydedilir. Daha ayrıntılı bilgi edinmek için clearstatcache() işlevine bakınız.

İpucu

PHP 5.0.0 sürümünden itibaren bu işlev bazı URL sarmalayıcıları ile kullanılabilmektedir. stat() ailesini destekleyen sarmalayıcıların listesini Supported Protocols and Wrappers başlığı altında bulabilirsiniz.

Ayrıca Bakınız

  • filectime() - Dosyanın dosya düğümü değişiklik zamanını döndürür
  • stat() - Bir dosya hakkında bilgi döndürür
  • touch() - Dosyanın erişim ve değişiklik zamanını ayarlar
  • getlastmod() - Geçerli sayfanın son değişiklik zamanını döndürür
fileinode
fileowner
Dosya Sistemi İşlevleri


Dosya sahibini döndürür

filemtime
fileperms
Dosya Sistemi İşlevleri
PHP Manual

fileowner

(PHP 4, PHP 5, PHP 7)

fileowner — Dosya sahibini döndürür

Açıklama

int fileowner ( string $dosyaismi )

Dosya sahibini döndürür.

Değiştirgeler

dosyaismi

Dosya yolu.

Dönen Değerler

Hata durumunda FALSE aksi takdirde dosyanın sahibinin kullanıcı kimliği döner. Sayısal biçemde dönen kullanıcı kimliğinden kullanıcı ismini elde etmek için posix_getpwuid() işlevini kullanabilirsiniz.

Örnekler

Örnek 1 - Bir dosyanın sahibinin bulunması

<?php
$dosya = 'index.php';
print_r(posix_getpwuid(fileowner($dosya)));
?>

Notlar

Bilginize: Bu işlevin sonuçları önbelleğe kaydedilir. Daha ayrıntılı bilgi edinmek için clearstatcache() işlevine bakınız.

İpucu

PHP 5.0.0 sürümünden itibaren bu işlev bazı URL sarmalayıcıları ile kullanılabilmektedir. stat() ailesini destekleyen sarmalayıcıların listesini Supported Protocols and Wrappers başlığı altında bulabilirsiniz.

Ayrıca Bakınız

  • filegroup() - Dosyanın sahibi olan grubu döndürür
  • stat() - Bir dosya hakkında bilgi döndürür
  • posix_getpwuid() - Kullanıcı kimliği belirtilen kullanıcı hakkında bilgi döndürür
filemtime
fileperms
Dosya Sistemi İşlevleri


Dosya izinlerini döndürür

fileowner
filesize
Dosya Sistemi İşlevleri
PHP Manual

fileperms

(PHP 4, PHP 5, PHP 7)

fileperms — Dosya izinlerini döndürür

Açıklama

int fileperms ( string $dosyaismi )

Belirtilen dosya ile ilgili izinleri döndürür.

Değiştirgeler

dosyaismi

Dosya yolu.

Dönen Değerler

Bir hata durumunda FALSE, aksi takdirde dosyanın izinlerini döndürür.

Örnekler

Örnek 1 - İzinlerin sekizlik değer olarak gösterilmesi

<?php
echo substr(sprintf('%o', fileperms('/tmp')), -4);
echo substr(sprintf('%o', fileperms('/etc/passwd')), -4);
?>

Yukarıdaki örneğin çıktısı:

1777
0644

Örnek 2 - Tüm izinlerin gösterilmesi

<?php
$perms = fileperms('/etc/passwd');

if (($perms & 0xC000) == 0xC000) {
    // Soket
    $info = 's';
} elseif (($perms & 0xA000) == 0xA000) {
    // Sembolik bağ
    $info = 'l';
} elseif (($perms & 0x8000) == 0x8000) {
    // Sıradan dosya
    $info = '-';
} elseif (($perms & 0x6000) == 0x6000) {
    // Blok aygıtı
    $info = 'b';
} elseif (($perms & 0x4000) == 0x4000) {
    // Dizin
    $info = 'd';
} elseif (($perms & 0x2000) == 0x2000) {
    // Karakter aygıtı
    $info = 'c';
} elseif (($perms & 0x1000) == 0x1000) {
    // FIFO boru
    $info = 'p';
} else {
    // Bilinmiyor
    $info = 'u';
}

// Kullanıcı
$info .= (($perms & 0x0100) ? 'r' : '-');
$info .= (($perms & 0x0080) ? 'w' : '-');
$info .= (($perms & 0x0040) ?
            (($perms & 0x0800) ? 's' : 'x' ) :
            (($perms & 0x0800) ? 'S' : '-'));

// Grup
$info .= (($perms & 0x0020) ? 'r' : '-');
$info .= (($perms & 0x0010) ? 'w' : '-');
$info .= (($perms & 0x0008) ?
            (($perms & 0x0400) ? 's' : 'x' ) :
            (($perms & 0x0400) ? 'S' : '-'));

// Herkes
$info .= (($perms & 0x0004) ? 'r' : '-');
$info .= (($perms & 0x0002) ? 'w' : '-');
$info .= (($perms & 0x0001) ?
            (($perms & 0x0200) ? 't' : 'x' ) :
            (($perms & 0x0200) ? 'T' : '-'));

echo $info;
?>

Yukarıdaki örneğin çıktısı:

-rw-r--r--

Notlar

Bilginize: Bu işlevin sonuçları önbelleğe kaydedilir. Daha ayrıntılı bilgi edinmek için clearstatcache() işlevine bakınız.

İpucu

PHP 5.0.0 sürümünden itibaren bu işlev bazı URL sarmalayıcıları ile kullanılabilmektedir. stat() ailesini destekleyen sarmalayıcıların listesini Supported Protocols and Wrappers başlığı altında bulabilirsiniz.

Ayrıca Bakınız

  • chmod() - Dosya kipini değiştirir
  • is_readable() - Bir dosyanın mevcut ve okunabilir olup olmadığını söyler
  • stat() - Bir dosya hakkında bilgi döndürür

fileowner
filesize
Dosya Sistemi İşlevleri


Dosya uzunluğunu döndürür

fileperms
filetype
Dosya Sistemi İşlevleri
PHP Manual

filesize

(PHP 4, PHP 5, PHP 7)

filesize — Dosya uzunluğunu döndürür

Açıklama

int filesize ( string $dosyaismi )

Belirtilen dosyanın uzunluğunu döndürür.

Değiştirgeler

dosyaismi

Dosya yolu.

Dönen Değerler

Başarı durumunda dosya boyunu bayt cinsinden döndürür, aksi takdirde FALSE döndürür ve ayrıca E_WARNING seviyesinde bir hata iletisi üretilir.

Bilginize: PHP'nin tamsayı türü işaretli olduğundan ve çoğu platform 32 bitlik tamsayılar kullandığından filesize() işlevi 2GB'tan büyük dosyalarda beklenmedik sonuçlar döndürebilir. 2GB ile 4GB arasındaki dosyalarda boyut normal olarak sprintf("%u", filesize($dosya)) üzerinden gelir.

Örnekler

Örnek 1 - filesize() örneği

<?php

// çıktısı:
// somefile.txt: 1024 bytes

$filename = 'somefile.txt';
echo $filename . ': ' . filesize($filename) . ' bytes';

?>

Notlar

Bilginize: Bu işlevin sonuçları önbelleğe kaydedilir. Daha ayrıntılı bilgi edinmek için clearstatcache() işlevine bakınız.

İpucu

PHP 5.0.0 sürümünden itibaren bu işlev bazı URL sarmalayıcıları ile kullanılabilmektedir. stat() ailesini destekleyen sarmalayıcıların listesini Supported Protocols and Wrappers başlığı altında bulabilirsiniz.

Ayrıca Bakınız

  • file_exists() - Bir dosya veya dizinin mevcut olup olmadığına bakar

fileperms
filetype
Dosya Sistemi İşlevleri


Dosya türünü döndürür

filesize
flock
Dosya Sistemi İşlevleri
PHP Manual

filetype

(PHP 4, PHP 5, PHP 7)

filetype — Dosya türünü döndürür

Açıklama

string filetype ( string $dosyaismi )

Belirtilen dosyanın türünü döndürür.

Değiştirgeler

dosyaismi

Dosya yolu.

Dönen Değerler

Dosyanın türünü döndürür. Olası değerler: fifo, char, dir, block, link, file, socket ve unknown.

Bir hata oluşursa FALSE döner. eğer stat çağrısı başarısız olur veya dosya türü anlaşılamazsa ayrıca, bir E_NOTICE iletisi çıktılanır.

Örnekler

Örnek 1 - filetype() örneği

<?php

echo filetype('/etc/passwd');  // file
echo filetype('/etc/');        // dir

?>

Notlar

Bilginize: Bu işlevin sonuçları önbelleğe kaydedilir. Daha ayrıntılı bilgi edinmek için clearstatcache() işlevine bakınız.

İpucu

PHP 5.0.0 sürümünden itibaren bu işlev bazı URL sarmalayıcıları ile kullanılabilmektedir. stat() ailesini destekleyen sarmalayıcıların listesini Supported Protocols and Wrappers başlığı altında bulabilirsiniz.

Ayrıca Bakınız

  • is_dir() - Bir dosyanın bir dizin olup olmadığını söyler
  • is_file() - Bir dosyanın sıradan bir dosya olup olmadığını söyler
  • is_link() - Bir dosyanın sembolik bağ olup olmadığını söyler
  • file_exists() - Bir dosya veya dizinin mevcut olup olmadığına bakar
  • stat() - Bir dosya hakkında bilgi döndürür
  • mime_content_type() - Detect MIME Content-type for a file

filesize
flock
Dosya Sistemi İşlevleri


Taşınabilir tavsiye niteliğinde dosya kilitleme

filetype
fnmatch
Dosya Sistemi İşlevleri
PHP Manual

flock

(PHP 4, PHP 5, PHP 7)

flock — Taşınabilir tavsiye niteliğinde dosya kilitleme

Açıklama

bool flock ( resource $dt , int $işlem [, int &$engellensin ] )

flock() işlevi, sanal olarak her platformda (çoğu Unix türevi yanında Windows da dahil) kullanılabilen basit bir okuma/yazma modeli oluşturmanızı mümkün kılar.

Kilit, fclose() işlevi ile serbest bırakılır (ayrıca, betik sonlandığında özdevinimli olarak çağrılır).

PHP, tavsiye niteliğinde dosyaların tamamını kilitlemenin taşınabilir bir türünü destekler (yani, dosyalara erişen tüm programların dosyaları kilitlerken aynı yöntemi kullanmaları zorunludur, aksi takdirde kullandıkları yöntem çalışmayacaktır). Öntanımlı olarak, bu işlev istenen kilit alınıncaya kadar bekler. Bu durum aşağıda açıklanan LOCK_NB seçeneği ile (Windows dışındaki platformlarda) değiştirilebilir.

Değiştirgeler

dt

Dosya tanıtıcısı geçerli olmalı ve fopen() veya fsockopen() tarafından başarıyla açılmış bir dosya için döndürülmüş olmalıdır (ve henüz fclose() tarafından kapatılmamış olmalıdır).

işlem

işlem şunlardan biri olabilir:

  • Paylaşımlı bir kilit (okuyucu) edinmek için LOCK_SH.
  • Ayrıcalıklı bir kilit (yazıcı) edinmek için LOCK_EX.
  • Bir kilidi (paylaşımlı veya ayrıcalıklı) serbest bırakmak için LOCK_UN.

Kilitleme sırasında işlevinin engelleme yapmasını istemiyorsanız LOCK_NB eklemek de mümkündür (Windows'ta desteklenmez).

engellesin

Kilidin engellemesi için isteğe bağlı üçüncü değiştirgeye TRUE atanır (EWOULDBLOCK errno kuralı).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
4.0.1 | LOCK_XXX sabitleri eklendi. Daha önce LOCK_SH için 1, LOCK_EX için 2, LOCK_UN için 3 ve LOCK_NB için 4 belirtilmesi zorunluydu.

Örnekler

Örnek 1 - flock() örneği

<?php

$dt = fopen("/tmp/lock.txt", "w");

if (flock($dt, LOCK_EX)) { // ayrıcalıklı bir kilit oluşturalım
    ftruncate($fp, 0);  // dosyayı kırp
    fwrite($dt, "Buraya bir şeyler yazalım\n");
    flock($dt, LOCK_UN); // kilidi serbest bırakalım
} else {
    echo "Kilit edinilemedi!";
}

fclose($dt);

?>

Notlar

Bilginize:

flock() işlevi Windows altında zorunlu olarak kilitler.

Bilginize:

flock() işlevi bir dosya tanıtıcısı gerektirdiğinden bir dosyayı yazmak amacıyla açarken (fopen() işlevinde "w" veya "w+" değiştirgeleri ile) içeriğini silebilmek için dosyaya başkalarının erişimini engellemeniz, yani özel bir kilit dosyası kullanmanız gerekir.

Uyarı

Ardıl kodda dt değiştirgesine başka bir değer atanması kilidin serbest kalmasına sebep olur.

Uyarı

flock() işlevi NFS ve diğer bir çok ağ dosya sistemi üzerinde çalışmaz. Ayrıntılı bilgi için işletim sisteminizin belgelerine bakınız.

Bazı işletim sistemlerinde flock() işlevi süreç seviyesinde gerçeklenmiştir. ISAPI gibi çok evreli bir API kullanıldığında, dosyaları aynı sunucu örneğinin paralel evrelerinde çalışan diğer PHP betiklerine karşı flock() üzerinden korumak mümkün olmayabilir!

flock() işlevi, FAT ve türevleri gibi artık antika olmuş dosya sistemlerinde desteklenmez ve bu ortamlarda daima FALSE döndürür (özellikle Windows 98 için).

filetype
fnmatch
Dosya Sistemi İşlevleri


Dosya ismi belirtilen kalıpla eşleşiyor mu diye bakar

flock
fopen
Dosya Sistemi İşlevleri
PHP Manual

fnmatch

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

fnmatch — Dosya ismi belirtilen kalıpla eşleşiyor mu diye bakar

Açıklama

bool fnmatch ( string $kalıp , string $dizge [, int $seçenekler = 0 ] )

fnmatch() işlevi, belirtilen dizge'nin belirtilen dosya kalıbı ile eşleşip eşleşmediğine bakar.

Değiştirgeler

kalıp

Kabuk dosya ismi kalıbı.

dizge

Sınanacak dizge. İşlev özellikle dosya isimleri için yararlı olsa da sıradan dizgeler için de kullanılabilir.

Ortalama bir kullanıcı, kabuk dosya ismi kalıplarını veya bunların en basit biçimleri olan '?' ve '*' karakterlerini kullanabilir. Bu bakımdan, programcı olmayan kullanıcılar için preg_match() yerine fnmatch() kullanımı daha uygun olabilir.

seçenekler

Belirtilebilecek seçenekler:

fnmatch() işlevinin seçenekler değiştirgesinde belirtilebilecek seçenekler
Seçenek | Açıklama
FNM_NOESCAPE | \ karakteri kalıplarda özel olarak ele alınmaz. Normalde, \ kendinden sonraki karakteri önceler; bu seçenek etkinse bu özellik kapatılır, böylece sadece kendisiyle eşleşebilir. Önceleme etkin olduğunda, \? kalıbı sadece ? karakteri ile eşleşir, çünkü kalıp içindeki soru işareti sıradan bir karakter gibi işlem görür. Eğer FNM_NOESCAPE seçeneği etkinse, \ sıradan bir karakterdir.
FNM_PATHNAME | Bu POSIX.2 ile gelen bir FNM_FILE_NAME takma ismidir.
FNM_PERIOD

. karakteri dosya isimlerinin başında ise özel olarak ele alınır. Bu seçenek etkinse ve . karakteri dizge dizgesinin ilk karakteri ise kalıp ile eşleşemez.

FNM_PERIOD ve FNM_FILE_NAME birlikte belirtilmişse, . karakterinin dizge dizgesinin başında olmasının yanında / karakterini izlediği durumda da eşleşme sağlanır. (Kabuk FNM_PERIOD ve FNM_FILE_NAME seçeneklerini dosya isimleriyle eşleşme ararken birlikte kullanır.)

FNM_CASEFOLD | dizge ile kalıp karşılaştırılırken harf büyüklüğüne bakılmaz.

Dönen Değerler

Eşleşme sağlanmışsa TRUE aksi takdirde FALSE.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | İşlev Windows platformlarında da kullanılabilir oldu.

Örnekler

Örnek 1 - Bir renk isminin bir kabuk dosya kalıbıyla eşleştirilmesi

<?php
if (fnmatch("*gr[ae]y", $color)) {
  echo "some form of gray ...";
}
?>

Notlar

Uyarı

Bu işlev şimdilik POSIX uyumlu olmayan sistemlerde kullanılamamaktadır.

Ayrıca Bakınız

  • glob() - Bir kalıpla eşleşen dosya yollarını bulur
  • preg_match() - Bir düzenli ifadeyi eşleştirmeye çalışır
  • sscanf() - Girdi dizgesini belli bir biçeme göre yorumlar
  • printf() - Biçemli bir dizge çıktılar
  • sprintf() - Biçemli bir dizge döndürür

flock
fopen
Dosya Sistemi İşlevleri


Bir dosya veya URL'yi açar

fnmatch
fpassthru
Dosya Sistemi İşlevleri
PHP Manual

fopen

(PHP 4, PHP 5, PHP 7)

fopen — Bir dosya veya URL'yi açar

Açıklama

resource fopen ( string $dosyaismi , string $kip [, bool $include_path_kullan = false [, resource $bağlam ]] )

fopen() işlevi dosyaismi ile belirtilen özkaynak için bir akım açar.

Değiştirgeler

dosyaismi

Eğer dosyaismi "şema://...", biçeminde belirtilmişse bir URL belirtildiği varsayılır ve PHP bu şema için bir protokol eylemcisi (başka bir deyişle bir sarmalayıcı) bulmaya çalışır. Eğer bu protokol için kayıtlı bir sarmalayıcı yoksa PHP, sorunun giderilmesine yardımcı olmanız için bir uyarı verip belirtilen dosya ismini sıradan bir dosya gibi ele alarak işleme devam eder.

Eğer PHP dosyaismi ile belirtilen dosyanın bir yerel dosya olduğuna karar verirse bu dosya üzerinde bir akım açmaya çalışır. Dosya PHP için erişilebilir olmalıdır, yani dosyanın bu erişim için yeterli izinlere sahip olduğundan emin olmanız gerekir. safe_mode, veya open_basedir yönergesi etkinse bunlarla ilgili kısıtlamalar uygulanabilir.

Eğer PHP dosyaismi ile belirtilen dosyanın bir URL olduğuna ve bununla ilgili kayıtlı bir protokol olduğuna karar verirse ve bu protokol bir ağ protokolü olarak kaydedilmişse PHP allow_url_fopen yönergesinin etkin olup olmadığına bakar. Eğer yönergeye 'Off' değeri atanmışsa PHP bir uyarı verip işlevin başarısız olmasını sağlar.

Bilginize:

Desteklenen protokolleri Supported Protocols and Wrappers bölümünde bulabilirsiniz. Bazı protokoller (sarmalayıcılar) bağlam ve/veya php.ini seçeneklerini destekler. Kullanılabilecek seçeneklerin neler olduğunu öğrenmek için protokolle ilgili sayfaya bakınız (örneğin, http sarmalayıcısı user_agent php.ini yönergesini kullanır).

Windows platformunda dosya yolunu belirtmekte kullanılan tersbölü çizgilerini öncelemeyi unutmayın. Daha da iyisi dosya yolunu belirtmek için bölü çizgilerini kullanın. Örnek:

<?php
$dt = fopen("c:\\veri\\bilgi.txt", "r");
?>

kip

kip değiştirgesinde akım için gerekli erişim türü belirtilir. Şunlardan biri olabilir:

fopen() işlevinin kip değiştirgesinde belirtilebilecek kip çeşitleri
Kip | Açıklama
'r' | Akım sadece okumak için açılır; dosya konumlayıcı dosyanın başlangıcına yerleştirilir.
'r+' | Akım hem okumak hem de yazmak için açılır; dosya konumlayıcı dosyanın başlangıcına yerleştirilir.
'w' | Akım sadece yazmak için açılır; dosya konumlayıcı dosyanın başlangıcına yerleştirilir ve dosya uzunluğu sıfır yapılır. Dosya mevcut değilse oluşturulmaya çalışılır.
'w+' | Akım hem okumak hem de yazmak için açılır; dosya konumlayıcı dosyanın başlangıcına yerleştirilir ve dosya uzunluğu sıfır yapılır. Dosya mevcut değilse oluşturulmaya çalışılır.
'a' | Akım sadece yazmak için açılır; dosya konumlayıcı dosyanın sonuna yerleştirilir. Dosya mevcut değilse oluşturulmaya çalışılır.
'a+' | Akım hem okumak hem de yazmak için açılır; dosya konumlayıcı dosyanın sonuna yerleştirilir. Dosya mevcut değilse oluşturulmaya çalışılır.
'x' | Dosya oluşturulur ve sadece yazmak için açılır; dosya konumlayıcı dosyanın başlangıcına yerleştirilir. Dosya zaten mevcutsa fopen() FALSE döndürürek başarısız olur ve E_WARNING seviyesinde bir hata üretir. Dosya mevcut değilse oluşturulmaya çalışılır. Bu işlem, open(2) sistem çağrısı için O_EXCL|O_CREAT seçeneklerini belirtmeye eşdeğerdir.
'x+' | Dosya oluşturulur ve hem okumak hem de yazmak için açılır; dosya konumlayıcı dosyanın başlangıcına yerleştirilir. Dosya zaten mevcutsa fopen() FALSE döndürürek başarısız olur ve E_WARNING seviyesinde bir hata üretir. Dosya mevcut değilse oluşturulmaya çalışılır. Bu işlem, open(2) sistem çağrısı için O_EXCL|O_CREAT seçeneklerini belirtmeye eşdeğerdir.

Bilginize:

Her işletim sistemi ailesinin farklı satır sonlandırma kuralları vardır. Bir metin dosyasını yazarken işletim sisteminizin gerektirdiği satır sonlandırma karakterlerini kullanmanız gerekir. Unix ve türevleri satırları sonlandırmak için \n, Windows ailesi \r\n, Mac'ler ise \r karakterini kullanırlar.

Dosyalarınızı yazarken yanlış satır sonlandırma karakterleri kullanırsanız, dosyayı başka uygulamalarda açtığınızda tuhaf görünebilir.

Windows'un \n karakterlerini şeffaf olarak \r\n karakterlerine dönüştürmesini sağlayan bir metin kipi dönüşüm seçeneği ('t') vardır. Eğer satır sonlandırma karakterlerinin değişmeden kalmasını istiyorsanız ikil kipi devreye sokan 'b' seçeneğini kullanabilirsiniz. Bu seçenekleri ('b' veya 't') kip değiştirgesinde daima son karakter olarak belirtin.

Öntanımlı dönüşüm kipi kullandığınız PHP sürümüne ve SAPI'ye bağlıdır. Bu bakımdan uyumluluk için daima uygun seçeneği belirtmelisiniz. Salt metin dosyalarla çalışıyorsanız ve betiğinizde satır sonu karakteri olarak \n kullanıyorsanız, fakat dosyalarınızın notepad gibi uygulamalarla da okunabilmesini istiyorsanız 't' kipini kullanmanız, diğer tüm durumlarda ise 'b' kipini kullanmanız gerekir.

İkil dosyalarla çalışırken 'b' seçeneğini belirtmezseniz, verinizle ilgili tuhaf sorunlarla karşılaşabilirsiniz (örneğin, bozuk resim dosyaları ve \r\n karakterlerine bağlı tuhaf sorunlar).

Bilginize:

Uyumluluk adına, dosyaları fopen() ile açarken daima 'b' seçeneğini kullanmanızı hararetle tavsiye ederiz.

Bilginize:

Tekrar, uyumluluk adına, dosyanızı 't' seçeneğinin kullanılmasını gerektirmeyecek satır sonlandırma karakterleri ile yazmanızı ve dosyayı açarken daima 'b' seçeneğini kullanmanızı hararetle tavsiye ederiz.

include_path_kullan

Açacağınız dosyanın aranacağı yollara include_path yönergesinde belirtilen yolları da dahil etmek isterseniz, isteğe bağlı olan bu üçüncü değiştirgeyle '1' veya TRUE değerini aktarmalısınız.

bağlam

Bilginize: Bağlamsal destek PHP 5.0.0 ile eklenmiştir. Bağlamlar hakkında bilgi edinmek için Akım İşlevleri belgesine bakınız.

Dönen Değerler

Başarı durumunda bir dosya tanıtıcısı aksi takdirde FALSE döner.

Hatalar/İstisnalar

Dosya başarıyla açılamazsa E_WARNING seviyesinde bir hata üretilir. Bu uyarının çıktılanmaması için işlev isminin başına @ karakterini ekleyebilirsiniz.

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.2 | PHP 4.3.2'den beri, ikil ve metin ayrımı yapan tüm platformlar için ikil kip öntanımlıdır. PHP sürümünüzü yükselttikten sonra sorunlarla karşılaşırsanız, betiğinizi taşınabilir duruma getirene kadar sorundan kurtulmak için 't' seçeneğini kullanmayı deneyebilirsiniz.
4.3.2 | 'x' ve 'x+' seçenekleri eklendi.

Örnekler

Örnek 1 - fopen() örnekleri

<?php
$dt = fopen("/home/rasmus/file.txt", "r");
$dt = fopen("/home/rasmus/file.gif", "wb");
$dt = fopen("http://www.example.com/", "r");
$dt = fopen("ftp://user:password@example.com/somefile.txt", "w");
?>

Notlar

Uyarı

Microsoft IIS, SSL kullanırken bir close_notify göndermeden bağlantıyı kapatarak protokolle çelişir. Verinin sonuna ulaştığınız zaman PHP bunu "SSL: Fatal Protocol Error" (SSL: "Ölümcül Protokol Hatası") olarak raporlar. Bu sorunu bertaraf etmek için error_reporting değerini uyarıları içermeyecek bir seviyeye indirmek gerekir. PHP, akımı https:// şemasını kullanarak açarsanız hatalı IIS sunucu yazılımını saptayıp uyarıları engelleyebilir. Bir ssl:// soketi oluşturmak için fsockopen() kullanılacaksa uyarıları saptayıp engellemekten geliştirici sorumludur.

Bilginize: Güvenli kip etkinken, PHP, betiğin çalıştığı dizinin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığını sınar.

PHP'nin sunucu modülü sürümünü kullanıyorsanız ve dosyaları okumak ve yazmak ile ilgili sorunlar bakımından deneyimliyseniz, sunucu sürecinin bu dosya ve dizinlere erişim izninin olması gerektiğini aklınızdan çıkarmamalısınız.

Ayrıca Bakınız

  • Supported Protocols and Wrappers
  • fclose() - Açık bir dosya tanıtıcısını kapatır
  • fgets() - Dosya tanıtıcısından bir satır döndürür
  • fread() - Dosyayı ikil kipte okur
  • fwrite() - Dosyaya ikil kipte yazar
  • fsockopen() - Bir internet veya Unix alan soketi bağlantısı açar
  • file() - Dosya içeriğinin tamamını bir diziye okur
  • file_exists() - Bir dosya veya dizinin mevcut olup olmadığına bakar
  • is_readable() - Bir dosyanın mevcut ve okunabilir olup olmadığını söyler
  • stream_set_timeout() - Akımın zaman aşımı süresini ayarlar
  • popen() - Bir süreç tanıtıcısı açar
  • stream_context_create() - Bir akım bağlamı oluşturur

fnmatch
fpassthru
Dosya Sistemi İşlevleri


Bir dosya tanıtıcısında kalan verinin tamamını çıktılar

fopen
fputcsv
Dosya Sistemi İşlevleri
PHP Manual

fpassthru

(PHP 4, PHP 5, PHP 7)

fpassthru — Bir dosya tanıtıcısında kalan verinin tamamını çıktılar

Açıklama

int fpassthru ( resource $dt )

Belirtilen dosya tanıtıcısını geçerli konumdan dosya sonuna kadar okur ve sonucu çıktı tamponuna yazar.

Veriyi dosyaya yazmayı bitirmişseniz, dosya konumlayıcıyı dosyanın başlangıcına getirmek için rewind() işlevini kullanabilirsiniz.

Dosyada değişiklik yapmadan veya dosya konumlayıcıyı belli bir konuma taşımadan sadece bir dosyanın içeriğini dökümlemekse amacınız, sizi fopen() çağrısı yapmaktan kurtaran readfile() işlevini kullanabilirsiniz.

Değiştirgeler

dt

Dosya tanıtıcısı geçerli olmalı ve fopen() veya fsockopen() tarafından başarıyla açılmış bir dosya için döndürülmüş olmalıdır (ve henüz fclose() tarafından kapatılmamış olmalıdır).

Dönen Değerler

Bir hata oluşursa FALSE aksi takdirde dt'den okunup çıktı tamponuna aktarılan karakterlerin sayısı ile döner.

Örnekler

Örnek 1 - İkil dosyalarla fpassthru() kullanımı

<?php

// dosyayı ikil kipte açalım
$name = './img/ok.png';
$fp = fopen($name, 'rb');

// Doğru başlıkları gönderelim
header("Content-Type: image/png");
header("Content-Length: " . filesize($name));

// Resmi tampona atıp betiği durduralım
fpassthru($fp);
exit;

?>

Notlar

Bilginize:

İkil ve metin dosyaları farklı ele alan sistemlerde (Windows gibi) dosya açılırken fopen() işlevinin kip değiştirgesine 'b' harfi dahil edilmelidir.

Sisteminiz b seçeneğinin kullanımını gerektirmiyor olsa bile, betiğinizin taşınabilirliği açısından bu seçeneğin de kullanılmasını teşvik ediyoruz.

Ayrıca Bakınız

  • readfile() - Bir dosyayı çıktılar
  • fopen() - Bir dosya veya URL'yi açar
  • popen() - Bir süreç tanıtıcısı açar
  • fsockopen() - Bir internet veya Unix alan soketi bağlantısı açar

fopen
fputcsv
Dosya Sistemi İşlevleri


Satırı CSV olarak biçemler ve dosya tanıtıcısına yazar

fpassthru
fputs
Dosya Sistemi İşlevleri
PHP Manual

fputcsv

(PHP 5 >= 5.1.0, PHP 7)

fputcsv — Satırı CSV olarak biçemler ve dosya tanıtıcısına yazar

Açıklama

int fputcsv ( resource $dt , array $alanlar [, string $ayraç = ',' [, string $sınırlayıcı = '"' ]] )

fputcsv() işlevi alanlar dizisi içinde aktarılan bir dizgeyi bir CSV satırı olarak biçemler ve sonuna bir satırsonu karakteri ekleyerek dt ile belirtilen dosya tanıtıcısına yazar.

Değiştirgeler

dt

Dosya tanıtıcısı geçerli olmalı ve fopen() veya fsockopen() tarafından başarıyla açılmış bir dosya için döndürülmüş olmalıdır (ve henüz fclose() tarafından kapatılmamış olmalıdır).

alanlar

Değer dizisi.

ayraç

İsteğe bağlı bu değiştirge ile tek karakterlik alan ayracı belirtilir.

sınırlayıcı

İsteğe bağlı bu değiştirge ile tek karakterlik alan sınırlayıcı belirtilir.

Dönen Değerler

Başarısızlık durumunda FALSE aksi takdirde yazılan dizgenin uzunluğu döner.

Örnekler

Örnek 1 - fputcsv() örneği

<?php

$liste = array (
    'aaa,bbb,ccc,dddd',
    '123,456,789',
    '"aaa","bbb"'
);

$dt = fopen('file.csv', 'w');

foreach ($liste as $satır) {
    fputcsv($dt, split(',', $satır));
}

fclose($dt);
?>

Notlar

Bilginize: Eğer PHP'nin Macintosh bilgisayarlarda çalışırken veya bu bilgisayarlarda oluşturulmuş dosyalarla çalışırken satır sonlarını tanımamaması gibi bir sorunla karşılaşırsanız, auto_detect_line_endings çalışma anı seçeneğini etkin kılarak bu sorunu çözebilirsiniz.

Ayrıca Bakınız

  • fgetcsv() - Dosya tanıtıcısından CSV alanlarını çözümleyerek bir satır döndürür

fpassthru
fputs
Dosya Sistemi İşlevleri


fwrite işlevinin takma adıdır

fputcsv
fread
Dosya Sistemi İşlevleri
PHP Manual

fputs

(PHP 4, PHP 5, PHP 7)

fputs — fwrite() işlevinin takma adıdır

Açıklama

Bu işlev fwrite() işlevinin takma adıdır.

fputcsv
fread
Dosya Sistemi İşlevleri


Dosyayı ikil kipte okur

fputs
fscanf
Dosya Sistemi İşlevleri
PHP Manual

fread

(PHP 4, PHP 5, PHP 7)

fread — Dosyayı ikil kipte okur

Açıklama

string fread ( resource $dt , int $uzunluk )

fread() işlevi, dt dosya tanıtıcısı ile belirtilen dosya akımından uzunluk bayta kadar veri okur. Okuma işlemi aşağıdaki koşullardan biri sağlanır sağlanmaz durur:

  • uzunluk bayt okununca.
  • Dosya sonuna ulaşılınca.
  • Bir paket kullanılabilir hale gelince (ağ akımları için).
  • 8192 bayt okununca (akım kullanıcı alanında açıldıktan sonra).

Değiştirgeler

dt

Bir dosya tanıtıcısı. Genellikle fopen() kullanılarak oluşturulur.

uzunluk

Okunacak azami bayt sayısı.

Dönen Değerler

Hata durumunda FALSE aksi takdirde okunan dizge döner.

Örnekler

Örnek 1 - Basit bir fread() örneği

<?php
// bir dosyanın içeriğini bir dizge olarak okuyalım
$dosya = "/usr/local/birmetin.txt";
$dt = fopen($dosya, "r");
$içerik = fread($dt, filesize($dosya));
fclose($dt);
?>

Örnek 2 -İkil fread() örneği

Uyarı

İkil ve metin dosyaları farklı ele alan sistemlerde (Windows gibi) dosya açılırken fopen() işlevinin kip değiştirgesine 'b' harfi dahil edilmelidir.

<?php
$dosya = "c:\\files\\birresim.gif";
$dt = fopen($dosya, "rb");
$içerik = fread($dt, filesize($dosya));
fclose($dt);
?>

Örnek 3 - Uzak fread() örnekleri

Uyarı

Okuma işlemi sıradan bir dosyadan değil de popen() ve fsockopen() işlevinden veya uzak dosyalar okunurken dönen akımlardan yapılıyorsa bir paket kullanılabilir hale gelince okuma işlemi durur. Yani, veriyi aşağıdaki örnekte gösterildiği gibi parçalar halinde toplamalısınız.

<?php
// PHP 5 ve sonrası için
$dt = fopen("http://www.example.com/", "rb");
$içerik = stream_get_contents($dt);
fclose($dt);
?>
<?php
$dt = fopen("http://www.example.com/", "rb");
$içerik = '';
while (!feof($dt)) {
  $içerik .= fread($dt, 8192);
}
fclose($dt);
?>

Notlar

Bilginize:

İstediğiniz bir dosyanın içeriğini bir dizge olarak almaksa, yukarıdaki koddan çok daha iyi başarım sağlayan file_get_contents() işlevini kullanın.

Bilginize:

fread() işlevinin mevcut dosya konumundan okuduğuna dikkat edin. Dosya konumlayıcının mevcut konumunu öğrenmek için ftell(), konumu dosyanın başına taşımak için rewind()işlevini kullanın.

Ayrıca Bakınız

  • fwrite() - Dosyaya ikil kipte yazar
  • fopen() - Bir dosya veya URL'yi açar
  • fsockopen() - Bir internet veya Unix alan soketi bağlantısı açar
  • popen() - Bir süreç tanıtıcısı açar
  • fgets() - Dosya tanıtıcısından bir satır döndürür
  • fgetss() - Dosya tanıtıcısından bir satırı HTML etiketlerinden arındırarak döndürür
  • fscanf() - Bir dosyadaki girdiyi belli bir biçeme göre çözümler
  • file() - Dosya içeriğinin tamamını bir diziye okur
  • fpassthru() - Bir dosya tanıtıcısında kalan verinin tamamını çıktılar
  • ftell() - Dosya okuma/yazma konumlayıcının mevcut konumu ile döner
  • rewind() - Bir dosya tanıtıcısında konumu başa taşır

fputs
fscanf
Dosya Sistemi İşlevleri


Bir dosyadaki girdiyi belli bir biçeme göre çözümler

fread
fseek
Dosya Sistemi İşlevleri
PHP Manual

fscanf

(PHP 4 >= 4.0.1, PHP 5, PHP 7)

fscanf — Bir dosyadaki girdiyi belli bir biçeme göre çözümler

Açıklama

mixed fscanf ( resource $dt , string $biçem [, mixed &$... ] )

fscanf() işlevi, girdisini dt ile ilişkili bir dosyadan alması ve bu girdiyi belirtilen biçem'e göre yorumlaması dışında sscanf() işlevine benzer. Biçemin açıklaması için sprintf() işlevinin belgesine bakınız.

Biçem dizgesindeki boşluk karakterleri girdi akımındaki boşluk karakterleri ile eşleşir. Yani, biçem dizgesindeki bir sekme karakteri (\t) girdi dizgesindeki tek bir boşluk karakteri (" ") ile eşleşebilir.

Her fscanf() çağrısı dosyadan tek bir satır okur.

Değiştirgeler

dt

Bir dosya tanıtıcısı. Genellikle fopen() kullanılarak oluşturulur.

biçem

Biçem dizgesi sprintf() işlevinin belgesinde açıklandığı gibi belirtilir.

...

İsteğe bağlı atanmış değerler.

Dönen Değerler

Bu işleve sadece iki değiştirge aktarılırsa çözümlenen değerler bir dizi olarak döndürülür. Aksi takdirde, eğer isteğe bağlı değiştirgeler aktarılırsa işlev atanan değerlerin sayısı ile döner. İsteğe bağlı değerler gönderimli aktarılmalıdır.

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.0 | Bu sürümden önce, dosyadan okunun baytların azami sayısı 512 idi (veya ilk satırsonu karakterine kadardı; hangisi önce vuku bulursa). Fakat şimdi satırlar keyfi uzunlukta okunup taranabilmektedir.

Örnekler

Örnek 1 - fscanf() örneği

<?php
$dt = fopen("kişiler.txt", "r");
while ($kişiselveri = fscanf($dt, "%s\t%s\t%s\n")) {
    list ($isim, $meslek, $ülkekodu) = $kişiselveri;
    //... değerlerle yapılan işlemler
}
fclose($dt);
?>

Örnek 2 - kişiler.txt içeriği

avni      avanak        tr
varyemez  işadamı       us
tenten    gezgin        fr
zagor     kahraman      ca

Ayrıca Bakınız

  • fread() - Dosyayı ikil kipte okur
  • fgets() - Dosya tanıtıcısından bir satır döndürür
  • fgetss() - Dosya tanıtıcısından bir satırı HTML etiketlerinden arındırarak döndürür
  • sscanf() - Girdi dizgesini belli bir biçeme göre yorumlar
  • printf() - Biçemli bir dizge çıktılar
  • sprintf() - Biçemli bir dizge döndürür

fread
fseek
Dosya Sistemi İşlevleri


Dosya tanıtıcısında konumu bir yerden başka bir yere taşır

fscanf
fstat
Dosya Sistemi İşlevleri
PHP Manual

fseek

(PHP 4, PHP 5, PHP 7)

fseek — Dosya tanıtıcısında konumu bir yerden başka bir yere taşır

Açıklama

int fseek ( resource $dt , int $nereye [, int $nereden ] )

Dosya tanıtıcısı dt ile belirtilen bir dosyada konum göstericisini belli bir konuma götürür. Dosyanın başlangıcından itibaren bayt sayısı olarak ölçülen yeni konum, nereden değerine nereye değeri eklenerek belirtilir.

Değiştirgeler

dt

Bir dosya tanıtıcısı. Genellikle fopen() kullanılarak oluşturulur.

nereye

Yeni konum.

Konumu dosya sonunun öncesine taşımak için bu değiştirgeyle negatif bir değer, nereye değiştirgesiyle de SEEK_END aktarın.

nereye

Mevcut konumun nasıl yorumlanacağı belirtilir:

  • SEEK_SET - nereye konumunun dosya başlangıcına göre belirtildiği varsayılır.
  • SEEK_CUR - nereye konumunun mevcut dosya konumuna göre bayt sayısı olarak belirtildiği varsayılır. Bu miktar pozitif veya negatif olabilir.
  • SEEK_END - nereye konumunun dosya sonuna göre belirtildiği varsayılır.

Eğer nereden belirtilmezse, SEEK_SET öntanımlıdır.

Dönen Değerler

Başarı durumunda 0 aksi takdirde -1 döner. Dosya sonundan sonrasına konumlama bir hata olarak ele alınmaz.

Örnekler

Örnek 1 - fseek() örneği

<?php

$fp = fopen('dosya.txt', 'r');

// Biraz veri okuyalım
$data = fgets($fp, 4096);

// rewind($fp) çağrısı yapmış gibi
// dosyanın başına dönelim;
fseek($fp, 0);

?>

Notlar

Bilginize:

Eğer dosya ekleme ("a" veya "a+") kipinde açılmışsa, dosyaya yazılan her veri konuma bakılmaksızın daima dosyanın sonuna eklenir.

Bilginize:

Eğer "http://" veya "ftp://" biçemi kullanılırsa fopen() tarafından döndürülen dosya tanıtıcısı kullanılmayabilir. Ayrıca, fseek() işlevi, sadece sona ekleme kipinde ('a' seçeneğiyle) açılmış akımlar için yanlış sonuçlar verebilir.

Ayrıca Bakınız

  • ftell() - Dosya okuma/yazma konumlayıcının mevcut konumu ile döner
  • rewind() - Bir dosya tanıtıcısında konumu başa taşır

fscanf
fstat
Dosya Sistemi İşlevleri


Bir açık dosya tanıtıcısı kullanarak bir dosya hakkında bilgi döndürür

fseek
ftell
Dosya Sistemi İşlevleri
PHP Manual

fstat

(PHP 4, PHP 5, PHP 7)

fstat — Bir açık dosya tanıtıcısı kullanarak bir dosya hakkında bilgi döndürür

Açıklama

array fstat ( resource $dt )

Dosya tanıtıcısı dt olan bir dosya ile ilgili istatistikleri döndürür. Bir dosya ismi yerine açık bir dosya tanıtıcısı üzerinde çalışması dışında stat() işlevi gibidir.

Değiştirgeler

dt

Bir dosya tanıtıcısı. Genellikle fopen() kullanılarak oluşturulur.

Dönen Değerler

Dosya ile ilgili istatistikleri içeren bir dizi döndürür. Dönen dizinin biçemi hakkında bilgi edinmek için stat() işlevine bakınız.

Örnekler

Örnek 1 - fstat() örneği

<?php

// bir dosya açalım
$fp = fopen("/etc/passwd", "r");

// istatistikleri toplayalım
$fstat = fstat($fp);

// dosyayı kapatalım
fclose($fp);

// sadece ilişkisel kısmı basar
print_r(array_slice($fstat, 13));

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [dev] => 771
    [ino] => 488704
    [mode] => 33188
    [nlink] => 1
    [uid] => 0
    [gid] => 0
    [rdev] => 0
    [size] => 1114
    [atime] => 1061067181
    [mtime] => 1056136526
    [ctime] => 1056136526
    [blksize] => 4096
    [blocks] => 8
)

Notlar

Bilginize: Dosyaların sunucunun dosya sistemi üzerinden erişilebilir olması gerektiğinden bu işlev uzak dosyalar üzerinde çalışmayacaktır.

fseek
ftell
Dosya Sistemi İşlevleri


Dosya okuma/yazma konumlayıcının mevcut konumu ile döner

fstat
ftruncate
Dosya Sistemi İşlevleri
PHP Manual

ftell

(PHP 4, PHP 5, PHP 7)

ftell — Dosya okuma/yazma konumlayıcının mevcut konumu ile döner

Açıklama

int ftell ( resource $dt )

Dosya tanıtıcısı dt ile belirtilen dosyadaki dosya konumlayıcının konumunu döndürür.

Değiştirgeler

dt

Dosya tanıtıcısı geçerli olmalı ve fopen() veya popen() tarafından başarıyla açılmış bir dosya için döndürülmüş olmalıdır. ftell() işlevi sadece ekleme kipinde ('a' seçeneği ile) açılmış akımlarda yanlış sonuçlar verebilir.

Dönen Değerler

Dosya tanıtıcısı dt ile belirtilen dosyadaki dosya konumlayıcının konumunu (dosyanın başlangıcına göre) döndürür.

Bir hata oluşursa FALSE döner.

Örnekler

Örnek 1 - ftell() örneği

<?php

// Bir dosya açıp biraz veri okuyalım
$fp = fopen("/etc/passwd", "r");
$data = fgets($fp, 12);

// Bakalım neredeyiz?
echo ftell($fp); // 11

fclose($fp);

?>

Ayrıca Bakınız

  • fopen() - Bir dosya veya URL'yi açar
  • popen() - Bir süreç tanıtıcısı açar
  • fseek() - Dosya tanıtıcısında konumu bir yerden başka bir yere taşır
  • rewind() - Bir dosya tanıtıcısında konumu başa taşır

fstat
ftruncate
Dosya Sistemi İşlevleri


Bir dosyayı belli bir uzunlukta budar

ftell
fwrite
Dosya Sistemi İşlevleri
PHP Manual

ftruncate

(PHP 4, PHP 5, PHP 7)

ftruncate — Bir dosyayı belli bir uzunlukta budar

Açıklama

bool ftruncate ( resource $dt , int $boyut )

Dosya tanıtıcısı dt ile belirtilen dosyanın uzunluğunu boyut baytla sınırlar.

Değiştirgeler

dt

Dosya tanıtıcısı.

Bilginize:

dt yazmak için açılmış olmalıdır.

boyut

Budama boyu.

Bilginize:

Eğer boyut dosyadan büyükse dosya \0 baytları ile doldurularak boyut bayta genişletilir.

Eğer boyut dosyadan küçükse artan kısım kaybedilir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
PHP 4.3.3 | ftruncate() işlevi bu sürümün öncesinde başarı durumunda mantıksal TRUE yerine tamsayı 1 döndürürdü.

Örnekler

Örnek 1 - Dosya boyutunu sınırlama örneği

<?php
$dosya = 'lorem_ipsum.txt';

$dt = fopen($dosya, 'r+');
ftruncate($dt, rand(1, filesize($dosya)));
rewind($dt);
echo fread($dt, filesize($dosya));
fclose($dt);
?>

Notlar

Bilginize:

Dosya tanıtıcısı değişmez.

Ayrıca Bakınız

  • fopen() - Bir dosya veya URL'yi açar
  • fseek() - Dosya tanıtıcısında konumu bir yerden başka bir yere taşır

ftell
fwrite
Dosya Sistemi İşlevleri


Dosyaya ikil kipte yazar

ftruncate
glob
Dosya Sistemi İşlevleri
PHP Manual

fwrite

(PHP 4, PHP 5, PHP 7)

fwrite — Dosyaya ikil kipte yazar

Açıklama

int fwrite ( resource $dt , string $dizge [, int $uzunluk ] )

fwrite() işlevi, dizge dizgesini dosya tanıtıcısı dt ile belirtilen dosya akımına yazar.

Değiştirgeler

dt

Bir dosya tanıtıcısı. Genellikle fopen() kullanılarak oluşturulur.

dizge

Akıma yazılacak dizge.

uzunluk

uzunluk değiştirgesi belirtilmişse yazma işlemi uzunluk bayt yazıldıktan sonra veya dizge dizgesinin sonuna gelindiğinde durur (hangisi önce vuku bulursa).

uzunluk değiştirgesi belirtildiği takdirde magic_quotes_runtime yapılandırma yönergesi yoksayılarak dizge dizgesinde bölü çizgileri ayıklaması yapılmaz.

Dönen Değerler

fwrite() işlevi bir hata oluşmamışsa yazılan baytların sayısı ile aksi takdirde FALSE ile döner.

Notlar

Bilginize:

Bir ağ akımına yazarken, dizgenin tamamı yazılamadan akım kapanabilir. Bu durum fwrite() dönüş değerinden saptanabilir:

<?php
function fwrite_stream($fp, $string) {
    for ($written = 0; $written < strlen($string); $written += $fwrite) {
        $fwrite = fwrite($fp, substr($string, $written));
        if (!$fwrite) {
            return $fwrite;
        }
    }
    return $written;
}
?>

Bilginize:

İkil ve metin dosyaları farklı ele alan sistemlerde (Windows gibi) dosya açılırken fopen() işlevinin kip değiştirgesine 'b' harfi dahil edilmelidir.

Bilginize:

Eğer dt dosya sonuna ekleme kipinde açılmışsa (bazı sistemlerde ve dosya yerel dosya sisteminde olduğu sürece dizge uzunluğu dosya sisteminin blok boyunu aşmadığı takdirde) yazma işlemi atomiktir. Yani, fwrite() işlevini çağırmadan önce dosya tanıtıcısını flock() ile kilitlemeye gerek yoktur; tüm veri kesintiye uğramaksızın yazılacaktır.

Bilginize:

Eğer dosya tanıtıcısında peşpeşe iki yazma yaparsanız, her iki veri de dosyanın sonuna eklenir:

<?php
$dt = fopen('veri.txt', 'w');
fwrite($dt, '1');
fwrite($dt, '23');
fclose($dt);

// veri.txt dosyasının içeriği '123' değil '23' olacaktır.
?>

Örnekler

Örnek 1 - Basit bir fwrite() örneği

<?php
$dosya = 'dnm.txt';
$veri = "Bunu dosyaya ekleyelim\n";

// Önce dosya mevcut mu ve yazılabilir mi, bakalım.
if (is_writable($dosya)) {

    // Örneğimizde $dosya'yı ekleme kipinde açıyoruz.
    // Konumlayıcı dosyanın sonunda olduğundan fwrite()
    // $veri dizgesini dosyanın sonuna ekleyecektir.
    if (!$dt = fopen($dosya, 'a')) {
         echo "$dosya dosyası açılamadı";
         exit;
    }

    // $veri'yi açılan dosyaya yazalım.
    if (fwrite($dt, $veri) === FALSE) {
        echo "$dosya dosyasına yazılamıyor";
        exit;
    }

    echo "$dosya dosyasına '$veri' başarıyla yazıldı";

    fclose($dt);

} else {
    echo "$dosya dosyası yazılabilir değil";
}
?>

Ayrıca Bakınız

  • fread() - Dosyayı ikil kipte okur
  • fopen() - Bir dosya veya URL'yi açar
  • fsockopen() - Bir internet veya Unix alan soketi bağlantısı açar
  • popen() - Bir süreç tanıtıcısı açar
  • file_get_contents() - Dosya içeriğinin tamamını bir dizge olarak döndürür

ftruncate
glob
Dosya Sistemi İşlevleri


Bir kalıpla eşleşen dosya yollarını bulur

fwrite
is_dir
Dosya Sistemi İşlevleri
PHP Manual

glob

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

glob — Bir kalıpla eşleşen dosya yollarını bulur

Açıklama

array glob ( string $kalıp [, int $seçenekler = 0 ] )

glob() işlevi, dosya yollarını, kabuklarda kullanılana benzer şekilde, libc glob() işlevi tarafından kullanılan kurallara uygun olarak belli bir kalıp ile eşleştirmeye çalışır.

Değiştirgeler

kalıp

Dosya eşleştirme kalıbı. Yaklaşık (~) veya değiştirge yorumlaması yapılmaz.

seçenekler

Geçerli seçenekler:

  • GLOB_MARK - Dönen her dizine bir bölü çizgisi ekler.
  • GLOB_NOSORT - Dosyaları dizinde göründükleri sırayla döndürür (sıralamaz).
  • GLOB_NOCHECK - Hiçbir eşleşme bulunamazsa arama kalıbını döndürür.
  • GLOB_NOESCAPE - Tersbölüler denetim karakterlerini öncelemez.
  • GLOB_BRACE - {a,b,c} kalıbını 'a', 'b', veya 'c' ile eşleşecek şekilde genişletir.
  • GLOB_ONLYDIR - Sadece kalıpla eşleşen dizinleri döndürür.
  • GLOB_ERR - Okuma hatalarında işlemi durdurur (okunamayan dizinler gibi); öntanımlı olarak hatalar yoksayılır.

Dönen Değerler

Eşleşen dosya ve dizinleri içeren bir dizi döndürür. Bir eşleşme bulunamazsa veya hata oluşursa FALSE döndürür.

Bilginize:

Bazı sistemlerde boş eşleşme ile hata durumunu ayrımsamak mümkün değildir.

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.0 | GLOB_ERR eklendi.
4.3.3 | GLOB_ONLYDIR, Windows ve GNU C kullanılmayan diğer sistemlerde kullanılabilir oldu.

Örnekler

Örnek 1 glob() işlevini opendir() ve arkadaşları ile değiştirmenin uygun yolu

<?php
foreach (glob("*.txt") as $dosya) {
    echo "$dosya boyu " . filesize($dosya) . "\n";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

funclist.txt boyu 44686
funcsummary.txt boyu 267625
quickref.txt boyu 137820

Notlar

Bilginize: Dosyaların sunucunun dosya sistemi üzerinden erişilebilir olması gerektiğinden bu işlev uzak dosyalar üzerinde çalışmayacaktır.

Bilginize: Bu işlevi bazı sistemlerde kullanamazsınız (örneğin, eski Sun OS'lar).

Bilginize: GLOB_BRACE seçeneği, Solaris gibi bazı GNU olmayan sistemlerde kullanılamaz.

Ayrıca Bakınız

  • opendir() - Belirtilen dizin için bir tanıtıcı döndürür
  • readdir() - Dizinden bir girdinin ismini okur
  • closedir() - Dizin tanıtıcısını kapatır
  • fnmatch() - Dosya ismi belirtilen kalıpla eşleşiyor mu diye bakar

fwrite
is_dir
Dosya Sistemi İşlevleri


Bir dosyanın bir dizin olup olmadığını söyler

glob
is_executable
Dosya Sistemi İşlevleri
PHP Manual

is_dir

(PHP 4, PHP 5, PHP 7)

is_dir — Bir dosyanın bir dizin olup olmadığını söyler

Açıklama

bool is_dir ( string $dosyaismi )

Belirtilen dosyanın bir dizin olup olmadığını söyler.

Değiştirgeler

dosyaismi

Dosyanın yolu. Eğer dosyaismi bir göreli yol belirtiyorsa, çalışma dizinine göreli olduğu varsayılır; bir sembolik veya sabit bağ ise bağ çözümlenip hedefinin bir dizin olup olmadığına bakılır. open_basedir veya safe_mode etkin kılınmışsa ilgili kısıtlamalar uygulanabilir.

Dönen Değerler

dosyaismi ile belirtilen dosya mevcutsa ve bir dizin ise TRUE aksi takdirde FALSE döndürür.

Örnekler

Örnek 1 - is_dir() örneği

<?php
var_dump(is_dir('bir_dosya.txt'));
var_dump(is_dir('bir_dizin/abc'));

var_dump(is_dir('..')); // bir dizin yukarı
?>

Yukarıdaki örneğin çıktısı:

bool(false)
bool(false)
bool(true)

Hatalar/İstisnalar

Başarısızlık durumunda bir E_WARNING çıktılanır.

Notlar

Bilginize: Bu işlevin sonuçları önbelleğe kaydedilir. Daha ayrıntılı bilgi edinmek için clearstatcache() işlevine bakınız.

İpucu

PHP 5.0.0 sürümünden itibaren bu işlev bazı URL sarmalayıcıları ile kullanılabilmektedir. stat() ailesini destekleyen sarmalayıcıların listesini Supported Protocols and Wrappers başlığı altında bulabilirsiniz.

Ayrıca Bakınız

  • chdir() - Dizin değiştirir
  • dir() - Return an instance of the Directory class
  • opendir() - Belirtilen dizin için bir tanıtıcı döndürür
  • is_file() - Bir dosyanın sıradan bir dosya olup olmadığını söyler
  • is_link() - Bir dosyanın sembolik bağ olup olmadığını söyler

glob
is_executable
Dosya Sistemi İşlevleri


Bir dosyanın çalıştırılabilir bir dosya olup olmadığını söyler

is_dir
is_file
Dosya Sistemi İşlevleri
PHP Manual

is_executable

(PHP 4, PHP 5, PHP 7)

is_executable — Bir dosyanın çalıştırılabilir bir dosya olup olmadığını söyler

Açıklama

bool is_executable ( string $dosyaismi )

Belirtilen dosyanın çalıştırılabilir bir dosya olup olmadığını söyler.

Değiştirgeler

dosyaismi

Dosyanın yolu.

Dönen Değerler

dosyaismi ile belirtilen dosya mevcutsa ve çalıştırılabilir bir dosya ise TRUE aksi takdirde FALSE döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.0 | is_executable() işlevi Windows üzerinde de kullanılabilir oldu.

Örnekler

Örnek 1 - is_executable() örneği

<?php

$dosya = '/home/vincent/somefile.sh';

if (is_executable($dosya)) {
    echo $dosya.' çalıştırılabilir';
} else {
    echo $dosya.' çalıştırılamaz';
}

?>

Notlar

Bilginize: Bu işlevin sonuçları önbelleğe kaydedilir. Daha ayrıntılı bilgi edinmek için clearstatcache() işlevine bakınız.

İpucu

PHP 5.0.0 sürümünden itibaren bu işlev bazı URL sarmalayıcıları ile kullanılabilmektedir. stat() ailesini destekleyen sarmalayıcıların listesini Supported Protocols and Wrappers başlığı altında bulabilirsiniz.

Ayrıca Bakınız

  • is_file() - Bir dosyanın sıradan bir dosya olup olmadığını söyler
  • is_link() - Bir dosyanın sembolik bağ olup olmadığını söyler

is_dir
is_file
Dosya Sistemi İşlevleri


Bir dosyanın sıradan bir dosya olup olmadığını söyler

is_executable
is_link
Dosya Sistemi İşlevleri
PHP Manual

is_file

(PHP 4, PHP 5, PHP 7)

is_file — Bir dosyanın sıradan bir dosya olup olmadığını söyler

Açıklama

bool is_file ( string $dosyaismi )

Belirtilen dosyanın sıradan bir dosya olup olmadığını söyler.

Değiştirgeler

dosyaismi

Dosyanın yolu.

Dönen Değerler

dosyaismi ile belirtilen dosya mevcutsa ve sıradan bir dosya ise TRUE aksi takdirde FALSE döndürür.

Örnekler

Örnek 1 - is_file() örneği

<?php
var_dump(is_file('bir_dosya.txt')) . "\n";
var_dump(is_file('/usr/bin/')) . "\n";
?>

Yukarıdaki örneğin çıktısı:

bool(true)
bool(false)

Notlar

Bilginize: Bu işlevin sonuçları önbelleğe kaydedilir. Daha ayrıntılı bilgi edinmek için clearstatcache() işlevine bakınız.

İpucu

PHP 5.0.0 sürümünden itibaren bu işlev bazı URL sarmalayıcıları ile kullanılabilmektedir. stat() ailesini destekleyen sarmalayıcıların listesini Supported Protocols and Wrappers başlığı altında bulabilirsiniz.

Ayrıca Bakınız

  • is_dir() - Bir dosyanın bir dizin olup olmadığını söyler
  • is_link() - Bir dosyanın sembolik bağ olup olmadığını söyler

is_executable
is_link
Dosya Sistemi İşlevleri


Bir dosyanın sembolik bağ olup olmadığını söyler

is_file
is_readable
Dosya Sistemi İşlevleri
PHP Manual

is_link

(PHP 4, PHP 5, PHP 7)

is_link — Bir dosyanın sembolik bağ olup olmadığını söyler

Açıklama

bool is_link ( string $filename )

Belirtilen dosyanın bir sembolik bağ olup olmadığını söyler.

Değiştirgeler

dosyaismi

Dosyanın yolu.

Dönen Değerler

dosyaismi ile belirtilen dosya mevcutsa ve bir sembolik bağ ise TRUE aksi takdirde FALSE döndürür.

Örnekler

Örnek 1 - Bir sembolik bağın oluşturulup sınanması

<?php
$bağ = dosya';

if(is_link($bağ))
{
    echo(readlink($bağ));
}
else
{
    symlink('dosya.php', $bağ);
}
?>

Notlar

Bilginize: Bu işlevin sonuçları önbelleğe kaydedilir. Daha ayrıntılı bilgi edinmek için clearstatcache() işlevine bakınız.

İpucu

PHP 5.0.0 sürümünden itibaren bu işlev bazı URL sarmalayıcıları ile kullanılabilmektedir. stat() ailesini destekleyen sarmalayıcıların listesini Supported Protocols and Wrappers başlığı altında bulabilirsiniz.

Ayrıca Bakınız

  • is_dir() - Bir dosyanın bir dizin olup olmadığını söyler
  • is_file() - Bir dosyanın sıradan bir dosya olup olmadığını söyler
  • readlink() - Bir sembolik bağın hedefi ile döner

is_file
is_readable
Dosya Sistemi İşlevleri


Bir dosyanın mevcut ve okunabilir olup olmadığını söyler

is_link
is_uploaded_file
Dosya Sistemi İşlevleri
PHP Manual

is_readable

(PHP 4, PHP 5, PHP 7)

is_readable — Bir dosyanın mevcut ve okunabilir olup olmadığını söyler

Açıklama

bool is_readable ( string $dosyaismi )

Bir dosyanın mevcut ve okunabilir olup olmadığını söyler.

Değiştirgeler

dosyaismi

Dosyanın yolu.

Dönen Değerler

dosyaismi ile belirtilen dosya mevcutsa ve okunabilirse TRUE aksi takdirde FALSE döndürür.

Örnekler

Örnek 1 - is_readable() örneği

<?php
$dosya = 'dnm.txt';
if (is_readable($dosya)) {
    echo 'Dosya okunabilir';
} else {
    echo 'Dosya okunamaz';
}
?>

Notlar

PHP'nin sadece HTTP sunucusunun aidiyetinde çalıştığı kullanıcının sahibi olduğu dosyalara erişebildiğini aklınızdan çıkarmayın. Güvenli kip sınırlamaları PHP 5.1.5 öncesinde hesaba katılmaz.

Bilginize: Bu işlevin sonuçları önbelleğe kaydedilir. Daha ayrıntılı bilgi edinmek için clearstatcache() işlevine bakınız.

İpucu

PHP 5.0.0 sürümünden itibaren bu işlev bazı URL sarmalayıcıları ile kullanılabilmektedir. stat() ailesini destekleyen sarmalayıcıların listesini Supported Protocols and Wrappers başlığı altında bulabilirsiniz.

Bilginize:

Sınama etkin kullanıcı veya grup kimliği ile değil gerçek kullanıcı veya grup kimliği ile yapılır.

Ayrıca Bakınız

  • is_writable() - Bir dosyanın yazılabilir olup olmadığını söyler
  • file_exists() - Bir dosya veya dizinin mevcut olup olmadığına bakar
  • fgets() - Dosya tanıtıcısından bir satır döndürür

is_link
is_uploaded_file
Dosya Sistemi İşlevleri


Bir dosya HTTP POST üzerinden karşıya yüklenebilecekse bunu söyler

is_readable
is_writable
Dosya Sistemi İşlevleri
PHP Manual

is_uploaded_file

(PHP 4 >= 4.0.3, PHP 5, PHP 7)

is_uploaded_file — Bir dosya HTTP POST üzerinden karşıya yüklenebilecekse bunu söyler

Açıklama

bool is_uploaded_file ( string $dosyaismi )

dosyaismi ile belirtilen dosya HTTP POST üzerinden karşıya yüklenebiliyorsa TRUE döndürür. Yetkisiz kullanıcıların /etc/passwd gibi üzerinde işlem yapmalarının yasak olduğu dosyaları betik üzerinden dışarı göndermelerine engel olmaya yardımcı olur.

Bir dosyanın karşıya yüklenmesi ile dosya içeriğinin kullanıcıya veya aynı sistem üzerindeki diğer kullanıcılara ifşa edilmesini sağlayacak şeyleri yapma şansı doğacaksa bu sınamalar oldukça önem kazanır.

İşlemin gerektiği gibi yapılabilmesi için is_uploaded_file() işlevi $_FILES['userfile']['tmp_name'] gibi bir değiştirgeye ihtiyaç duyar - istemcilerin makinesinde karşıya yüklenen dosyanın ismi $_FILES['userfile']['name'] çalışmaz.

Değiştirgeler

dosyaismi

Sınanacak dosyanın ismi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - is_uploaded_file() örneği

<?php

if (is_uploaded_file($_FILES['userfile']['tmp_name'])) {
   echo $_FILES['userfile']['name'] ." dosyası başarıyla karşıya yüklendi.\n";
   echo "Dosya içeriği:\n";
   readfile($_FILES['userfile']['tmp_name']);
} else {
   echo "Saldırısı olasılığı: ";
   echo "'". $_FILES['userfile']['tmp_name'] . "' ";
   echo "dosyası karşıya yüklenmek isteniyor.";
}

?>

Ayrıca Bakınız

  • move_uploaded_file() - Karşıya yüklenen bir dosyayı yeni bir yere taşır
  • $_FILES
  • Basit bir kullanım örneği için Karşıya dosya yükleme bölümüne bakınız.

is_readable
is_writable
Dosya Sistemi İşlevleri


Bir dosyanın yazılabilir olup olmadığını söyler

is_uploaded_file
is_writeable
Dosya Sistemi İşlevleri
PHP Manual

is_writable

(PHP 4, PHP 5, PHP 7)

is_writable — Bir dosyanın yazılabilir olup olmadığını söyler

Açıklama

bool is_writable ( string $dosyaismi )

dosyaismi ile belirtilen dosya mevcutsa ve yazılabilirse TRUE döndürür. dosyaismi olarak bir dizin belirtirerek bir dizinin yazılabilirliğini sınayabilirsiniz.

PHP'nin sadece HTTP sunucusunun aidiyetinde çalıştığı kullanıcının sahibi olduğu dosyalara erişebildiğini aklınızdan çıkarmayın. Güvenli kip sınırlamaları hesaba katılmaz.

Değiştirgeler

dosyaismi

Sınanacak dosya ismi.

Dönen Değerler

dosyaismi ile belirtilen dosya mevcutsa ve yazılabilirse TRUE aksi takdirde FALSE döndürür.

Örnekler

Örnek 1 - is_writable() örneği

<?php
$dosya = 'dnm.txt';
if (is_writable($dosya)) {
    echo 'Dosyaya yazılabilir';
} else {
    echo 'Dosyaya yazılamaz';
}
?>

Notlar

Bilginize: Bu işlevin sonuçları önbelleğe kaydedilir. Daha ayrıntılı bilgi edinmek için clearstatcache() işlevine bakınız.

İpucu

PHP 5.0.0 sürümünden itibaren bu işlev bazı URL sarmalayıcıları ile kullanılabilmektedir. stat() ailesini destekleyen sarmalayıcıların listesini Supported Protocols and Wrappers başlığı altında bulabilirsiniz.

Ayrıca Bakınız

  • is_readable() - Bir dosyanın mevcut ve okunabilir olup olmadığını söyler
  • file_exists() - Bir dosya veya dizinin mevcut olup olmadığına bakar
  • fwrite() - Dosyaya ikil kipte yazar

is_uploaded_file
is_writeable
Dosya Sistemi İşlevleri


is_writable işlevinin takma adıdır

is_writable
lchgrp
Dosya Sistemi İşlevleri
PHP Manual

is_writeable

(PHP 4, PHP 5, PHP 7)

is_writeable — is_writable() işlevinin takma adıdır

Açıklama

Bu işlev is_writable() işlevinin takma adıdır.

is_writable
lchgrp
Dosya Sistemi İşlevleri


Bir sembolik bağın grubunu değiştirir

is_writeable
lchown
Dosya Sistemi İşlevleri
PHP Manual

lchgrp

(PHP 5 >= 5.1.2, PHP 7)

lchgrp — Bir sembolik bağın grubunu değiştirir

Açıklama

bool lchgrp ( string $dosyaismi , mixed $grup )

dosyaismi ile belirtilen sembolik bağın grubunu grup olarak değiştirir.

Bir sembolik bağın grubunu keyfi olarak sadece root değiştirebilir; diğer kullanıcılar sadece sahibi oldukları bir sembolik bağın grubunu üyesi oldukları gruplarla değiştirebilirler.

Değiştirgeler

dosyaismi

Sembolik bağın yolu.

grup

Grup ismi veya numarası.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Bir sembolik bağın grubunun değiştirilmesi

<?php
$hedef = 'dosya.php';
$bağ = 'dosya.html';
symlink($hedef, $bağ);

lchgrp($bağ, 8);
?>

Notlar

Bilginize: Dosyaların sunucunun dosya sistemi üzerinden erişilebilir olması gerektiğinden bu işlev uzak dosyalar üzerinde çalışmayacaktır.

Bilginize: Güvenli kip etkinken, PHP, dosya ve dizinlerin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığını sınar.

Bilginize: Bu işlev Windows sistemlerinde çalışmaz.

Ayrıca Bakınız

  • chgrp() - Dosya grubunu değiştirir
  • lchown() - Bir sembolik bağın sahibini değiştirir
  • chown() - Dosyanın sahibini değiştirir
  • chmod() - Dosya kipini değiştirir

is_writeable
lchown
Dosya Sistemi İşlevleri


Bir sembolik bağın sahibini değiştirir

lchgrp
link
Dosya Sistemi İşlevleri
PHP Manual

lchown

(PHP 5 >= 5.1.2, PHP 7)

lchown — Bir sembolik bağın sahibini değiştirir

Açıklama

bool lchown ( string $dosyaismi , mixed $kullanıcı )

dosyaismi ile belirtilen sembolik bağın sahibini kullanıcı yapar.

Bir sembolik bağın sahibini sadece root değiştirebilir.

Değiştirgeler

dosyaismi

Sembolik bağın yolu.

kullanıcı

Kullanıcı ismi veya numarası.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Bir sembolik bağın sahibinin değiştirilmesi

<?php
$hedef = 'dosya.php';
$bağ = 'dosya.html';
symlink($hedef, $bağ);

lchown($bağ, 8);
?>

Notlar

Bilginize: Dosyaların sunucunun dosya sistemi üzerinden erişilebilir olması gerektiğinden bu işlev uzak dosyalar üzerinde çalışmayacaktır.

Bilginize: Güvenli kip etkinken, PHP, dosya ve dizinlerin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığını sınar.

Bilginize: Bu işlev Windows sistemlerinde çalışmaz.

Ayrıca Bakınız

  • chown() - Dosyanın sahibini değiştirir
  • lchgrp() - Bir sembolik bağın grubunu değiştirir
  • chgrp() - Dosya grubunu değiştirir
  • chmod() - Dosya kipini değiştirir

lchgrp
link
Dosya Sistemi İşlevleri


Sabit bir bağ oluşturur

lchown
linkinfo
Dosya Sistemi İşlevleri
PHP Manual

link

(PHP 4, PHP 5, PHP 7)

link — Sabit bir bağ oluşturur

Açıklama

bool link ( string $bağ , string $hedef )

link() işlevi sabit bağ oluşturur.

Değiştirgeler

bağ

Bağ dosyası ismi.

hedef

Bağın hedefi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

Bilginize: Sadece Windows için: Bu işlev PHP'nin yükseltgenmiş kipte veya UAC iptal edilmiş durumdayken çalıştırılmasını gerektirir.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | İşlev Windows platformlarında da (Vista, Server 2008 ve üstü) kullanılabilir oldu.

Örnekler

Örnek 1 - Basit bir sabit bağ oluşturma örneği

<?php

$hedef = 'mevcut.uzt'; // Bu dosya mevcut.
$bağ = 'yeni.uzt';     // Bu da bağ dosyamız olsun.

link($hedef, $bağ);
?>

Notlar

Bilginize: Dosyaların sunucunun dosya sistemi üzerinden erişilebilir olması gerektiğinden bu işlev uzak dosyalar üzerinde çalışmayacaktır.

Ayrıca Bakınız

  • symlink() - Bir sembolik bağ oluşturur
  • readlink() - Bir sembolik bağın hedefi ile döner
  • linkinfo() - Bir bağ hakkında bilgi verir

lchown
linkinfo
Dosya Sistemi İşlevleri


Bir bağ hakkında bilgi verir

link
lstat
Dosya Sistemi İşlevleri
PHP Manual

linkinfo

(PHP 4, PHP 5, PHP 7)

linkinfo — Bir bağ hakkında bilgi verir

Açıklama

int linkinfo ( string $yol )

Bir bağ hakkında bilgi verir.

Bu işlev yol değiştirgesi ile belirtilen bağın gerçekte etkin olup olmadığını (stat.h dosyasında tanımlı S_ISLNK makrosunun kullandığı yöntemle) sınamak için kullanılır.

Değiştirgeler

yol

Bağ dosyasının yolu.

Dönen Değerler

linkinfo() işlevi lstat sistem çağrısından dönen Unix C stat yapısının st_dev alanının içeriğini döndürür. Bir hata durumunda 0 veya FALSE döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | İşlev Windows platformlarında da (Vista, Server 2008 ve üstü) kullanılabilir oldu.

Örnekler

Örnek 1 - linkinfo() örneği

<?php

echo linkinfo('/vmlinuz'); // 835

?>

Ayrıca Bakınız

  • symlink() - Bir sembolik bağ oluşturur
  • link() - Sabit bir bağ oluşturur
  • readlink() - Bir sembolik bağın hedefi ile döner

link
lstat
Dosya Sistemi İşlevleri


Bir dosya veya sembolik bağ hakkında bilgi verir

linkinfo
mkdir
Dosya Sistemi İşlevleri
PHP Manual

lstat

(PHP 4, PHP 5, PHP 7)

lstat — Bir dosya veya sembolik bağ hakkında bilgi verir

Açıklama

array lstat ( string $dosyaismi )

dosyaismi ile belirtilen bir dosya veya sembolik bağın istatistiklerini toplar.

Değiştirgeler

dosyaismi

Bir dosya veya sembolik bağın yolu.

Dönen Değerler

lstat() işlevinin döndürdüğü dizinin yapısı hakkında bilgi edinmek için stat() sayfasına bakınız. dosyaismi değiştirgesinin bir sembolik bağ olması durumunda sembolik bağın hedefi yerine sembolik bağın kendisi hakkında bilgi döndürmesi bakımından stat() işlevinden farklıdır.

Örnekler

Örnek 1 - stat() ve lstat() karşılaştırması

<?php
symlink('dosya.php', 'dosya');

// Dosya ve dosya.php için bilgileri karşılaştıralım
array_diff(stat('dosya'), lstat('dosya'));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

İik dosya arasındaki bilgi farkları:

Array
(
    [ino] => 97236376
    [mode] => 33188
    [size] => 34
    [atime] => 1223580003
    [mtime] => 1223581848
    [ctime] => 1223581848
    [blocks] => 8
)

Notlar

Bilginize: Bu işlevin sonuçları önbelleğe kaydedilir. Daha ayrıntılı bilgi edinmek için clearstatcache() işlevine bakınız.

İpucu

PHP 5.0.0 sürümünden itibaren bu işlev bazı URL sarmalayıcıları ile kullanılabilmektedir. stat() ailesini destekleyen sarmalayıcıların listesini Supported Protocols and Wrappers başlığı altında bulabilirsiniz.

Ayrıca Bakınız

  • stat() - Bir dosya hakkında bilgi döndürür

linkinfo
mkdir
Dosya Sistemi İşlevleri


Dizin oluşturur

lstat
move_uploaded_file
Dosya Sistemi İşlevleri
PHP Manual

mkdir

(PHP 4, PHP 5, PHP 7)

mkdir — Dizin oluşturur

Açıklama

bool mkdir ( string $yol [, int $kip = 0777 [, bool $ardışık = false [, resource $bağlam ]]] )

Yolu belirtilen dizini oluşturmaya çalışır.

Değiştirgeler

yol

Oluşturulacak dizinin yolu.

kip

Kip öntanımlı olarak, olası en geniş erişim izni anlamına gelen 0777'dir. Erişim tipleri hakkında ayrıntılı bilgi edinmek için chmod() sayfasına bakınız.

Bilginize:

kip Windows'ta yoksayılır.

Başına 0 getirerek kipi sekizlik tabanda belirtmek daha kullanışlı olabilir. Ayrıca, erişim kipi umask() kullanarak değiştirilebilen erişim maskesi ile de değiştirilebilir.

ardışık

Öntanımlı olarak FALSE'tır.

bağlam

Bilginize: Bağlamsal destek PHP 5.0.0 ile eklenmiştir. Bağlamlar hakkında bilgi edinmek için Akım İşlevleri belgesine bakınız.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.0 | ardışık değiştirgesi eklendi.
5.0.0 | PHP 5.0.0 sürümünden itibaren bu işlev bazı URL sarmalayıcıları ile kullanılabilmektedir. mkdir() işlevini destekleyen sarmalayıcıların listesini Supported Protocols and Wrappers başlığı altında bulabilirsiniz.
4.2.0 | mode değiştirgesi seçimlik hale geldi.

Örnekler

Örnek 1 - mkdir() örneği

<?php
mkdir("/dizinim/için/bir/yol", 0700);
?>

Notlar

Bilginize: Güvenli kip etkinken, PHP, betiğin çalıştığı dizinin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığını sınar.

Ayrıca Bakınız

  • rmdir() - Dizin siler

lstat
move_uploaded_file
Dosya Sistemi İşlevleri


Karşıya yüklenen bir dosyayı yeni bir yere taşır

mkdir
parse_ini_file
Dosya Sistemi İşlevleri
PHP Manual

move_uploaded_file

(PHP 4 >= 4.0.3, PHP 5, PHP 7)

move_uploaded_file — Karşıya yüklenen bir dosyayı yeni bir yere taşır

Açıklama

bool move_uploaded_file ( string $dosyaismi , string $hedef )

Bu işlev, dosyaismi ile belirtilen dosyanın karşıya yüklenen geçerli bir dosya olduğundan emin olduktan sonra (PHP'nin HTTP POST mekanizması ile karşıya yüklenen bir dosya ise) dosyayı hedef ile belirtilen adrese taşır.

Bir dosyanın karşıya yüklenmesi ile dosya içeriğinin kullanıcıya veya aynı sistem üzerindeki diğer kullanıcılara ifşa edilmesini sağlayacak şeyleri yapma şansı doğacaksa bu sınamalar oldukça önem kazanır.

Değiştirgeler

dosyaismi

Karşıya yüklenen dosyanın ismi.

hedef

Dosyanın taşınacağı adres.

Dönen Değerler

Eğer dosyaismi karşıya yüklenen geçerli bir dosya değilse işlem gerçekleşmez ve işlev FALSE ile döner.

Eğer dosyaismi karşıya yüklenen geçerli bir dosya ise fakat bir sebeple taşınamıyorsa işlem gerçekleşmez ve işlev FALSE ile dönerken ek olarak bir uyarı çıktılanır.

Örnekler

Örnek 1 - Çok sayıda dosyanın karşıya yüklenmesi

<?php
$uploads_dir = '/uploads';
foreach ($_FILES["pictures"]["error"] as $key => $error) {
    if ($error == UPLOAD_ERR_OK) {
        $tmp_name = $_FILES["pictures"]["tmp_name"][$key];
        $name = $_FILES["pictures"]["name"][$key];
        move_uploaded_file($tmp_name, "$uploads_dir/$name");
    }
}
?>

Notlar

Bilginize:

move_uploaded_file() işlevi safe_mode ve open_basedir yönergelerinden etkilenir. Bununla birlikte, karşıya yüklenecek dosyaların hedef'e taşınmasına izin verilmesinden dolayı yapılacak işlem bu sınırlamalarla çelişir. move_uploaded_file() işlevi, karşıya yüklenecek dosyaların sadece PHP üzerinden taşınmasına izin vererek işlemin güvenliğini sağlar.

Uyarı

Hedefte bir dosya varsa üzerine yazılır.

Ayrıca Bakınız

  • is_uploaded_file() - Bir dosya HTTP POST üzerinden karşıya yüklenebilecekse bunu söyler
  • Basit bir kullanım örneği için Karşıya dosya yükleme bölümüne bakınız.

mkdir
parse_ini_file
Dosya Sistemi İşlevleri


Bir yapılandırma dosyasını çözümler

move_uploaded_file
parse_ini_string
Dosya Sistemi İşlevleri
PHP Manual

parse_ini_file

(PHP 4, PHP 5, PHP 7)

parse_ini_file — Bir yapılandırma dosyasını çözümler

Açıklama

array parse_ini_file ( string $dosyaismi [, bool $bölümleri_işle = false [, int $tarama_kipi = INI_SCANNER_NORMAL ]] )

parse_ini_file() işlevi dosyaismi ile belirtilen yapılandırma dosyasını yükler ve içindeki ayarları bir ilişkisel dizi içinde döndürür.

Belirtilen dosyanın yapısı php.ini dosyasının yapısıyla aynı olmalıdır.

Değiştirgeler

dosyaismi

Çözümlenecek yapılandırma dosyası.

bölümleri_işle

Bu değiştirgeye TRUE atanırsa bölüm isimlerini ve içerdikleri ayarları içeren çok boyutlu bir dizi döner. Değiştirgenin öntanımlı değeri FALSE'tır.

tarama_kipi

Değeri INI_SCANNER_NORMAL (öntanımlıdır) veya INI_SCANNER_RAW olabilir. Eğer INI_SCANNER_RAW belirtilirse seçenek değerleri çözümlenmez.

Dönen Değerler

Başarısızlık durumunda FALSE aksi takdirde ayarları bir ilişkisel dizi içinde döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | İsteğe bağlı tarama_kipi değiştirgesi eklendi.
5.2.7 | Sözdizimi hatasında boş bir dizi yerine FALSE döndürülmeye başlandı.
5.2.4 | Sayılardan oluşan anahtarlar ve bölüm isimleri artık PHP tamsayıları olarak değerlendirilmeye başlanmıştır. Bu bakımdan 0 ile başlayanlar sekizlik, 0x ile başlayanlar onaltılık tabanda değerlendirilir.
5.0.0 | Çift tırnak içine alınmış değerler satırsonu karakterleri içerebilir.
4.2.1 | Bu işlev safe_mode ve open_basedir yönergelerinden etkilenir olmuştur.

Örnekler

Örnek 1 - misal.ini içeriği

; Bu bir yapılandırma dosyası örneğidir.
; php.ini içinde ';' ile başlayan satırlar açıklamadır.

[ilk_bölüm]
bir = 1
yedi = 7
hayvan = AT

[ikinci_bölüm]
yol = "/usr/local/bin"
URL = "http://localhost/~kullanici"

[üçüncü_bölüm]
phpversion[] = "5.0"
phpversion[] = "5.1"
phpversion[] = "5.2"
phpversion[] = "5.3"

Örnek 2 - parse_ini_file() örneği

INI dosyası içinde sabitler de çözümlenebilir, bu bakımdan parse_ini_file() işlevini çalıştırmadan önce bir sabiti bir ini değeri olarak tanımlamışsanız, bu sabit de sonuca dahil edilir. Sadece ini değerleri değerlendirmeye alınır. Örnek:

<?php

define('AT', 'Doru at');

// Bölümleri çözümlemeyelim
$ini_dizisi = parse_ini_file("misal.ini");
print_r($ini_dizisi);

// Bölümleri de çözümleyelim
$ini_dizisi = parse_ini_file("misal.ini", true);
print_r($ini_dizisi);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [bir] => 1
    [yedi] => 7
    [hayvan] => Doru at
    [yol] => /usr/local/bin
    [URL] => http://localhost/~kullanici
    [phpversion] => Array
        (
            [0] => 5.0
            [1] => 5.1
            [2] => 5.2
            [3] => 5.3
        )

)
Array
(
    [ilk_bölüm] => Array
        (
            [bir] => 1
            [yedi] => 7
            [hayvan] => Doru at
        )

    [ikinci_bölüm] => Array
        (
            [yol] => /usr/local/bin
            [URL] => http://localhost/~kullanici
        )

    [üçüncü_bölüm] => Array
        (
            [phpversion] => Array
                (
                    [0] => 5.0
                    [1] => 5.1
                    [2] => 5.2
                    [3] => 5.3
                )

        )

)

Örnek 3 - Bir php.ini dosyasının parse_ini_file() ile çözümlenmesi

<?php
// Aşağıdaki sonuçları karşılaştırmak için basit bir işlev
function evethayır($ifade)
{
 return($ifade ? 'Evet' : 'Hayır');
}

// php_ini_loaded_file() ile php.ini dosyasının yolunu öğrenelim.
// İşlev PHP 5.2.4'ten beri kullanılabiliyor.
$ini_yolu = php_ini_loaded_file();

// php.ini dosyasını çözümleyelim
$ini = parse_ini_file($ini_yolu);

// Değerleri karşılaştırıp basalım; get_cfg_var() ile de aynı
// sonuçların alınacağına dikkat ediniz
echo '(çözümlenen) magic_quotes_gpc =' .
    evethayır($ini['magic_quotes_gpc']) . PHP_EOL;
echo '(yüklenen) magic_quotes_gpc = ' .
    evethayır(get_cfg_var('magic_quotes_gpc')) . PHP_EOL;
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

(çözümlenen) magic_quotes_gpc = Evet
(yüklenen) magic_quotes_gpc = Evet

Notlar

Bilginize:

Bu işlev php.ini dosyasına hiçbir şey yapmaz. Zaten betiğinizi çalıştırdığınız sırada işlem yapılır. Bu işlevi sadece kendi uygulamanızın yapılandırma dosyasını okumak için kullanabilirsiniz.

Bilginize:

INI dosyasındaki bir değer harf ve rakamların haricinde karakterler içeriyorsa bu değeri çift tırnak (") imlerinin arasına almalısınız.

Bilginize: INI dosyalarında anahtar olarak kullanılmaması gereken anahtar sözcükler vardır: none, null, yes, no, on, off, true ve false. null, no ve false değerleri "" olarak, yes ve true ise "1" olarak sonuçlanır. {}|&~![()^" karakterleri anahtar içinde hiçbir yerde kullanılamaz ve değer olarak da özel bir anlama sahiptirler.

Ayrıca Bakınız

  • parse_ini_string() - Bir yapılandırma dizgesini çözümler

move_uploaded_file
parse_ini_string
Dosya Sistemi İşlevleri


Bir yapılandırma dizgesini çözümler

parse_ini_file
pathinfo
Dosya Sistemi İşlevleri
PHP Manual

parse_ini_string

(PHP 5 >= 5.3.0, PHP 7)

parse_ini_string — Bir yapılandırma dizgesini çözümler

Açıklama

array parse_ini_string ( string $ini [, bool $bölümleri_işle = false [, int $tarama_kipi = INI_SCANNER_NORMAL ]] )

parse_ini_string() işlevi ini dizgesi içindeki ayarları bir ilişkisel dizi içinde döndürür.

ini dizgesinin yapısı php.ini dosyasının yapısıyla aynı olmalıdır.

Değiştirgeler

ini

Çözümlenecek ini dosyası içeriği.

bölümleri_işle

Bu değiştirgeye TRUE atanırsa bölüm isimlerini ve içerdikleri ayarları içeren çok boyutlu bir dizi döner. Değiştirgenin öntanımlı değeri FALSE'tır.

tarama_kipi

Değeri INI_SCANNER_NORMAL (öntanımlıdır) veya INI_SCANNER_RAW olabilir. Eğer INI_SCANNER_RAW belirtilirse seçenek değerleri çözümlenmez.

Dönen Değerler

Başarısızlık durumunda FALSE aksi takdirde ayarları bir ilişkisel dizi içinde döndürür.

Notlar

Bilginize: INI dosyalarında anahtar olarak kullanılmaması gereken bazı özel sözcükler vardır. null, yes, no, true, false, on, off, none bunlardan bazılarıdır. null, no ve false "" ile sonuçlanırken, yes ve true "1" ile sonuçlanır. {}|&~![()^" karakterleri hiçbir yerde anahtar veya değer olarak kullanılmamalıdır.

Ayrıca Bakınız

  • parse_ini_file() - Bir yapılandırma dosyasını çözümler

parse_ini_file
pathinfo
Dosya Sistemi İşlevleri


Bir dosya yolu hakkında bilgi döndürür

parse_ini_string
pclose
Dosya Sistemi İşlevleri
PHP Manual

pathinfo

(PHP 4 >= 4.0.3, PHP 5, PHP 7)

pathinfo — Bir dosya yolu hakkında bilgi döndürür

Açıklama

mixed pathinfo ( string $yol [, int $seçenekler = PATHINFO_DIRNAME | PATHINFO_BASENAME | PATHINFO_EXTENSION | PATHINFO_FILENAME ] )

pathinfo() işlevi belirtilen yol hakkında bilgi içeren bir ilişkisel dizi döndürür.

Değiştirgeler

yol

Bilgi toplanacak yol.

seçenekler

İsteğe bağlı seçenekler değiştirgesinde hangi bileşenlerin döndürüleceğini PATHINFO_DIRNAME, PATHINFO_BASENAME, PATHINFO_EXTENSION ve PATHINFO_FILENAME seçeneklerinin birleşimi olarak belirtebilirsiniz. Tüm bileşenlerin döndürülmesi öntanımlıdır.

Dönen Değerler

İlişkisel dizide dönen bileşenler: dirname (dizin ismi), basename (uzantısız isim), extension (uzantı) ve filename (dosya ismi).

Eğer seçenekler belirtilirse ve tüm bileşenler istenmemişse işlev bir ilişkisel dizi değil, bir dizge döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
5.2.0 | PATHINFO_FILENAME sabiti eklendi.

Örnekler

Örnek 1 - pathinfo() örneği

<?php
$path_parts = pathinfo('/siteler/htdocs/index.html');

echo $path_parts['dirname'], "\n";
echo $path_parts['basename'], "\n";
echo $path_parts['extension'], "\n";
echo $path_parts['filename'], "\n"; // PHP 5.2.0'dan beri.
?>

Yukarıdaki örneğin çıktısı:

/siteler/htdocs
index.html
html
index

Notlar

Bilginize:

Geçerli dosya yolu bilgisinin alınması hakkında daha ayrıntılı bilgi edinmek için Öntanımlı Değişkenler bölümüne bakınız.

Ayrıca Bakınız

  • dirname() - Belirtilen dosya yolunun dizin bileşenini döndürür
  • basename() - Dosya yolunun dosya ismi bileşenini döndürür
  • parse_url() - Bir URL'yi bileşenlerine ayırır
  • realpath() - Normalleştirilmiş mutlak dosya yolunu döndürür

parse_ini_string
pclose
Dosya Sistemi İşlevleri


Bir süreç tanıtıcısını kapatır

pathinfo
popen
Dosya Sistemi İşlevleri
PHP Manual

pclose

(PHP 4, PHP 5, PHP 7)

pclose — Bir süreç tanıtıcısını kapatır

Açıklama

int pclose ( resource $dt )

popen() tarafından açılmış bir boruhattının dosya tanıtıcısını kapatır.

Değiştirgeler

dt

Dosya tanıtıcısı geçerli olmalı ve başarılı bir popen() çağrısından dönmüş olmalıdır.

Dönen Değerler

Çalışan sürecin sonlandırma çıkış kodu ile döner.

Örnekler

Örnek 1 - pclose() örneği

<?php
$dt = popen('/bin/ls', 'r');
pclose($handle);
?>

Ayrıca Bakınız

  • popen() - Bir süreç tanıtıcısı açar

pathinfo
popen
Dosya Sistemi İşlevleri


Bir süreç tanıtıcısı açar

pclose
readfile
Dosya Sistemi İşlevleri
PHP Manual

popen

(PHP 4, PHP 5, PHP 7)

popen — Bir süreç tanıtıcısı açar

Açıklama

resource popen ( string $komut , string $kip )

Belirtilen komut tarafından çatallanarak çalıştırılan bir sürece bir boruhattı açar.

Değiştirgeler

komut

Komut.

kip

Kip.

Dönen Değerler

fopen() işlevi tarafından döndürülenden farklı olarak hem okuma hem de yazma için kullanılabilen ve pclose() ile kapatılması gereken bir dosya tanıtıcısı ile döner. Bu tanıtıcı, fgets(), fgetss() ve fwrite() işlevleri tarafından kullanılabilir.

Bir hata oluşursa FALSE döner.

Örnekler

Örnek 1 - popen() örneği

<?php
$handle = popen("/bin/ls", "r");
?>

Belirtilen komut dosyası bulunamazsa da geçerli bir tanıtıcı döner. Bu tuhaf görünebilir fakat böyle olması gerekir; böylece kabuk tarafından döndürülen hata iletisine erişmeniz sağlanır:

Örnek 2 - Hata döndüren popen() örneği

<?php
error_reporting(E_ALL);

/* Komutu std. hataya yönlendirelim. */
$bt = popen('/bir/yol/calistirilabilirdosya 2>&1', 'r');
echo "'$tanıtıcı'; " . gettype($bt) . "\n";
$okunan = fread($bt, 2096);
echo $okunan;
pclose($bt);
?>

Notlar

Bilginize:

İki yönlü destek arıyorsanız proc_open() kullanın.

Bilginize: Güvenli kip etkinken, dosyaları sadece safe_mode_exec_dir ile çalıştırabilirsiniz. Uygulamadan kaynaklanan sebeplerle çalıştırılabilirin dosya yolunda .. bileşenine şimdilik izin verilmemektedir.

Uyarı

güvenli kipin etkin kılınmasıyla, komut dizgesi escapeshellcmd() ile öncelenir. Böylece, echo y | echo x komut dizgesi echo y \| echo x haline gelir.

Ayrıca Bakınız

  • pclose() - Bir süreç tanıtıcısını kapatır
  • fopen() - Bir dosya veya URL'yi açar
  • proc_open() - Bir komutu çalıştırır ve G/Ç için bir dosya tanıtıcı açar

pclose
readfile
Dosya Sistemi İşlevleri


Bir dosyayı çıktılar

popen
readlink
Dosya Sistemi İşlevleri
PHP Manual

readfile

(PHP 4, PHP 5, PHP 7)

readfile — Bir dosyayı çıktılar

Açıklama

int readfile ( string $dosyaismi [, bool $include_path_kullan = false [, resource $bağlan ]] )

Bir dosyayı okuyup çıktı tamponuna yazar.

Değiştirgeler

dosyaismi

Okunacak dosya.

include_path_kullan

Dosyanın include_path yolunda da aranmasını istiyorsanız bu isteğe bağlı değiştirgeye TRUE atamalısınız.

bağlam

Bir bağlam akımı özkaynağı.

Dönen Değerler

Bir hata oluşmuşsa FALSE döner ve işlev @readfile() şeklinde çağrılmamışsa bir hata iletisi basılır. Herşey yolunda gitmişse dosyadan okunan baytların sayısını döndürür.

Örnekler

Örnek 1 readfile() kullanarak dosya indirmeyi zorlamak

<?php
$file = 'monkey.gif';

if (file_exists($file)) {
    header('Content-Description: File Transfer');
    header('Content-Type: application/octet-stream');
    header('Content-Disposition: attachment; filename='.basename($file));
    header('Content-Transfer-Encoding: binary');
    header('Expires: 0');
    header('Cache-Control: must-revalidate, post-check=0, pre-check=0');
    header('Pragma: public');
    header('Content-Length: ' . filesize($file));
    ob_clean();
    flush();
    readfile($file);
    exit;
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Notlar

İpucu

fopen sarmalayıcıları etkin kılınmışsa bu işlevde dosya ismi olarak bir URL belirtebilirsiniz. Dosya isminin nasıl belirtilebileceği hakkında bilgi edinmek için fopen() işlevine bakınız. Sarmalayıcıların neler yapabildiği, kullanım bilgileri ve bunlar tarafından kullanılan öntanımlı değişkenler hakkında bilgi edinmek için ise Supported Protocols and Wrappers bölümüne bakınız.

Bilginize: Bağlamsal destek PHP 5.0.0 ile eklenmiştir. Bağlamlar hakkında bilgi edinmek için Akım İşlevleri belgesine bakınız.

Ayrıca Bakınız

  • fpassthru() - Bir dosya tanıtıcısında kalan verinin tamamını çıktılar
  • file() - Dosya içeriğinin tamamını bir diziye okur
  • fopen() - Bir dosya veya URL'yi açar
  • include - include
  • require - require
  • virtual() - Bir Apache alt isteği gerçekleştirir
  • file_get_contents() - Dosya içeriğinin tamamını bir dizge olarak döndürür
  • Supported Protocols and Wrappers

popen
readlink
Dosya Sistemi İşlevleri


Bir sembolik bağın hedefi ile döner

readfile
realpath_cache_get
Dosya Sistemi İşlevleri
PHP Manual

readlink

(PHP 4, PHP 5, PHP 7)

readlink — Bir sembolik bağın hedefi ile döner

Açıklama

string readlink ( string $yol )

readlink() işlevi, C readlink işlevinin yaptığını yapar.

Değiştirgeler

yol

Sembolik bağ yolu.

Dönen Değerler

Hata durumunda FALSE aksi takdirde sembolik bağın içeriğini döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | İşlev Windows platformlarında da (Vista, Server 2008 ve üstü) kullanılabilir oldu.

Örnekler

Örnek 1 - readlink() örneği

<?php

// örn, /boot/vmlinux-2.4.20-xfs döner
echo readlink('/vmlinuz');

?>

Ayrıca Bakınız

  • is_link() - Bir dosyanın sembolik bağ olup olmadığını söyler
  • symlink() - Bir sembolik bağ oluşturur
  • linkinfo() - Bir bağ hakkında bilgi verir

readfile
realpath_cache_get
Dosya Sistemi İşlevleri


Get realpath cache entries

readlink
realpath_cache_size
Dosya Sistemi İşlevleri
PHP Manual

realpath_cache_get

(PHP 5 >= 5.3.2, PHP 7)

realpath_cache_get — Get realpath cache entries

Açıklama

array realpath_cache_get ( void )

Get the contents of the realpath cache.

Dönen Değerler

Returns an array of realpath cache entries. The keys are original path entries, and the values are arrays of data items, containing the resolved path, expiration date, and other options kept in the cache.

Örnekler

Örnek 1 realpath_cache_get() example

<?php
var_dump(realpath_cache_get());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(2) {
  ["/test"]=>
  array(4) {
    ["key"]=>
    int(123456789)
    ["is_dir"]=>
    bool(true)
    ["realpath"]=>
    string(5) "/test"
    ["expires"]=>
    int(1260318939)
  }
  ["/test/test.php"]=>
  array(4) {
    ["key"]=>
    int(987654321)
    ["is_dir"]=>
    bool(false)
    ["realpath"]=>
    string(12) "/root/test.php"
    ["expires"]=>
    int(1260318939)
  }
}

Ayrıca Bakınız

  • realpath_cache_size() - Get realpath cache size

readlink
realpath_cache_size
Dosya Sistemi İşlevleri


Get realpath cache size

realpath_cache_get
realpath
Dosya Sistemi İşlevleri
PHP Manual

realpath_cache_size

(PHP 5 >= 5.3.2, PHP 7)

realpath_cache_size — Get realpath cache size

Açıklama

int realpath_cache_size ( void )

Get the amount of memory used by the realpath cache.

Dönen Değerler

Returns how much memory realpath cache is using.

Örnekler

Örnek 1 realpath_cache_size() example

<?php
var_dump(realpath_cache_size());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(412)

Ayrıca Bakınız

  • realpath_cache_get() - Get realpath cache entries
  • The realpath_cache_size configuration option

realpath_cache_get
realpath
Dosya Sistemi İşlevleri


Normalleştirilmiş mutlak dosya yolunu döndürür

realpath_cache_size
rename
Dosya Sistemi İşlevleri
PHP Manual

realpath

(PHP 4, PHP 5, PHP 7)

realpath — Normalleştirilmiş mutlak dosya yolunu döndürür

Açıklama

string realpath ( string $yol )

realpath() işlevi tüm sembolik bağları genişletir ve '/./', '/../' gösterimlerini çözümleyip belirtilen yol'a bir '/' ekler ve normalleştirilmiş mutlak dosya yolu olarak döndürür.

Değiştirgeler

yol

Sınanacak dosya yolu.

Dönen Değerler

Başarı durumunda normalleştirilmiş mutlak dosya yolunu döndürür. Sonuç hiçbir sembolik bağ, '/./' veya '/../' bileşenlerini içermez.

Başarısızlık durumunda, örneğin dosya mevcut olmadığında realpath() FALSE ile döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | 5.3.0 öncesinde, *BSD sistemlerde sadece sonuncu yol bileşeninin mevcut olmaması durumunda realpath() başarısız olmaz.

Örnekler

Örnek 1 - realpath() örneği

<?php
chdir('/var/log/');
echo realpath('./../../etc/passwd');
?>

Yukarıdaki örneğin çıktısı:

/etc/passwd

Örnek 2 - Windows'ta realpath()

Windows'ta realpath() Unix tarzı dosya yolunu Windows tarzı dosya yoluna dönüştürür.

<?php
echo realpath('/windows/system32');
?>

Yukarıdaki örneğin çıktısı:

C:\WINDOWS\System32

Ayrıca Bakınız

  • basename() - Dosya yolunun dosya ismi bileşenini döndürür
  • dirname() - Belirtilen dosya yolunun dizin bileşenini döndürür
  • pathinfo() - Bir dosya yolu hakkında bilgi döndürür

realpath_cache_size
rename
Dosya Sistemi İşlevleri


Bir dosya veya dizinin ismini değiştirir

realpath
rewind
Dosya Sistemi İşlevleri
PHP Manual

rename

(PHP 4, PHP 5, PHP 7)

rename — Bir dosya veya dizinin ismini değiştirir

Açıklama

bool rename ( string $eski_isim , string $yeni_isim [, resource $bağlam ] )

İsmi eski_isim ile belirtilen bir dosya veya dizinin ismini yeni_isim olarak değiştirir.

Değiştirgeler

eski_isim

Bilginize:

Eski isim. eski_isim'de kullanılan sarmalayıcının yeni_isim'deki sarmalayıcı ile aynı olması gerekir.

yeni_isim

Yeni isim.

context

Bilginize: Bağlamsal destek PHP 5.0.0 ile eklenmiştir. Bağlamlar hakkında bilgi edinmek için Akım İşlevleri belgesine bakınız.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.0 | PHP 5.0.0'dan beri rename() bazı URL sarmalayıcıları ile de kullanılabilmektedir. rename() tarafından desteklenen sarmalayıcıların listesi için Supported Protocols and Wrappers bölümüne bakınız.
4.3.3 | rename() işlevi Unix türevlerinde disk bölümleri arasında dosya ismi değişikliği yapabilir olmuştur.

Örnekler

Örnek 1 - rename()örneği

<?php
rename("/tmp/tmp_file.txt", "/home/user/login/docs/my_file.txt");
?>

Ayrıca Bakınız

  • copy() - Dosya kopyalar
  • unlink() - Bir dosyayı siler
  • move_uploaded_file() - Karşıya yüklenen bir dosyayı yeni bir yere taşır

realpath
rewind
Dosya Sistemi İşlevleri


Bir dosya tanıtıcısında konumu başa taşır

rename
rmdir
Dosya Sistemi İşlevleri
PHP Manual

rewind

(PHP 4, PHP 5, PHP 7)

rewind — Bir dosya tanıtıcısında konumu başa taşır

Açıklama

bool rewind ( resource $dt )

Dosya konumu göstericisini dt dosya akımının başlangıcına konumlandırır.

Bilginize:

Dosyayı dosya sonuna ekleme kipinde ("a" veya "a+") açmışsanız, dosya konum göstericisinin yerine bakılmaksızın dosyaya yazılan her veri daima dosyanın sonuna yazılır.

Değiştirgeler

dt

Dosya tanıtıcısı geçerli olmalı ve fopen() tarafından başarıyla açılmış bir dosyayı göstermelidir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - rewind() üste yazma örneği

<?php
$dt = fopen('dosya.txt', 'r+');

fwrite($dt, 'Uzunca bir cümle.');
rewind($dt);
fwrite($dt, 'Foo');
rewind($dt);

echo fread($dt, filesize('dosya.txt'));

fclose($dt);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Uzunca bir cümle.

Ayrıca Bakınız

  • fread() - Dosyayı ikil kipte okur
  • fseek() - Dosya tanıtıcısında konumu bir yerden başka bir yere taşır
  • ftell() - Dosya okuma/yazma konumlayıcının mevcut konumu ile döner
  • fwrite() - Dosyaya ikil kipte yazar

rename
rmdir
Dosya Sistemi İşlevleri


Dizin siler

rewind
set_file_buffer
Dosya Sistemi İşlevleri
PHP Manual

rmdir

(PHP 4, PHP 5, PHP 7)

rmdir — Dizin siler

Açıklama

bool rmdir ( string $dizinismi [, resource $bağlam ] )

Yolu dizinismi ile belirtilen dizini silmeye çalışır. Silinebilmesi için dizin boş olmalı ve erişim izinleri buna izin vermelidir.

Değiştirgeler

dizinismi

Dizinin yolu.

context

Bilginize: Bağlamsal destek PHP 5.0.0 ile eklenmiştir. Bağlamlar hakkında bilgi edinmek için Akım İşlevleri belgesine bakınız.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.0 | PHP 5.0.0'dan beri rmdir() bazı URL sarmalayıcıları ile de kullanılabilmektedir. rmdir() tarafından desteklenen sarmalayıcıların listesi için Supported Protocols and Wrappers bölümüne bakınız.

Örnekler

Örnek 1 - rmdir() örneği

<?php
if (!is_dir('misaller')) {
    mkdir('misaller');
}

rmdir('misaller');
?>

Notlar

Bilginize: Güvenli kip etkinken, PHP, betiğin çalıştığı dizinin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığını sınar.

Ayrıca Bakınız

  • is_dir() - Bir dosyanın bir dizin olup olmadığını söyler
  • mkdir() - Dizin oluşturur
  • unlink() - Bir dosyayı siler

rewind
set_file_buffer
Dosya Sistemi İşlevleri


stream_set_write_buffer işlevinin takma adıdır

rmdir
stat
Dosya Sistemi İşlevleri
PHP Manual

set_file_buffer

(PHP 4, PHP 5, PHP 7)

set_file_buffer — stream_set_write_buffer() işlevinin takma adıdır

Açıklama

Bu işlev, stream_set_write_buffer() işlevinin takma adıdır.

rmdir
stat
Dosya Sistemi İşlevleri


Bir dosya hakkında bilgi döndürür

set_file_buffer
symlink
Dosya Sistemi İşlevleri
PHP Manual

stat

(PHP 4, PHP 5, PHP 7)

stat — Bir dosya hakkında bilgi döndürür

Açıklama

array stat ( string $dosyaismi )

dosyaismi ile belirtilen dosyanın istatistiklerini toplar. Eğer dosyaismi bir sembolik bağ ise istatistikler bağ dosyasından değil hedefinden toplanır.

lstat(), sembolik bağların durumunu döndürmesi dışında stat() işlevine eşdeğerdir.

Değiştirgeler

dosyaismi

Dosyanın yolu.

Dönen Değerler

stat() and fstat() sonuç biçemi
İndis | Anahtar (PHP 4.0.6'dan beri) | Açıklama
0 | dev | aygıt numarası
1 | ino | dosya düğümü numarası *
2 | mode | dosya düğümü koruma kipi
3 | nlink | bağ sayısı
4 | uid | sahibinin kullanıcı kimliği *
5 | gid | sahibinin grup kimliği *
6 | rdev | dosya düğümü aygıtı ise aygıt türü
7 | size | bayt sayısı
8 | atime | son erişim zamanı (Unix zaman damgası)
9 | mtime | son değişiklik zamanı (Unix zaman damgası)
10 | ctime | dosya düğümü son değişiklik zamanı (Unix zaman damgası)
11 | blksize | dosya sisteminin G/Ç blok boyu **
12 | blocks | ayrılmış 512 baytlık blokların sayısı **
* Windows üzerinde daima 0'dır.

** Sadece st_blksize türünü destekleyen sistemlerde geçerlidir; diğer sistemlerde (Windows gibi) -1 döner.

Hata durumunda stat() FALSE döndürür.

Hatalar/İstisnalar

Başarısızlık durumunda bir E_WARNING çıktılanır.

Sürüm Bilgisi

Sürüm: | Açıklama
4.0.6 | Bu özniteliklerin sayısal indisli bir dizi içinde döndürülmesi yanında bunlara anahtarlar isimleri olarak da erişilebilir oldu.

Örnekler

Örnek 1 - stat() örneği

<?php
/* Dosya durumunu alalım */
$stat = stat('C:\php\php.exe');

/*
 * Dosya erişim zamanını basalım.
 * Bu, fileatime() çağrısına eşdeğerdir.
 */
echo 'Erişim zamanı: ' . $stat['atime'];

/*
 * Dosya değişiklik zamanını basalım.
 * Bu, filemtime() çağrısına eşdeğerdir.
 */
echo 'Değişiklik zamanı: ' . $stat['mtime'];

/* Aygıt numarasını basalım */
echo 'Aygıt numarası: ' . $stat['dev'];

Örnek 2 - stat() bilgisinin touch() ile birlikte kullanımı

<?php
/* Dosya durumunu alalım */
$stat = @stat('C:\php\php.exe');

/* Bilgiyi alırken başarısız olduk mu? */
if(!$stat)
{
    echo 'Stat çağrısı başarısız oldu...';
}
else
{
    /*
     * Mevcut erişim zamanını 1 hafta öncesi olarak isteyelim
     */
    $atime = $stat['atime'] + 604800;

    /* Dosyaya erişelim */
    if(!@touch('some_file.txt', time(), $atime))
    {
        echo 'Dosyaya erişilemedi...';
    }
    else
    {
        echo 'Dosyaya başarıyla erişildi...';
    }
}
?>

Notlar

Bilginize:

Zaman çözünürlüğünün dosya sistemine göre farklı olabileceğini unutmayın.

Bilginize: Bu işlevin sonuçları önbelleğe kaydedilir. Daha ayrıntılı bilgi edinmek için clearstatcache() işlevine bakınız.

İpucu

PHP 5.0.0 sürümünden itibaren bu işlev bazı URL sarmalayıcıları ile kullanılabilmektedir. stat() ailesini destekleyen sarmalayıcıların listesini Supported Protocols and Wrappers başlığı altında bulabilirsiniz.

Ayrıca Bakınız

  • lstat() - Bir dosya veya sembolik bağ hakkında bilgi verir
  • fstat() - Bir açık dosya tanıtıcısı kullanarak bir dosya hakkında bilgi döndürür
  • filemtime() - Dosyanın değişiklik zamanını döndürür
  • filegroup() - Dosyanın sahibi olan grubu döndürür

set_file_buffer
symlink
Dosya Sistemi İşlevleri


Bir sembolik bağ oluşturur

stat
tempnam
Dosya Sistemi İşlevleri
PHP Manual

symlink

(PHP 4, PHP 5, PHP 7)

symlink — Bir sembolik bağ oluşturur

Açıklama

bool symlink ( string $hedef , string $bağ )

symlink() işlevi mevcut hedef'e bağ değiştirgesinde belirtilen isimle bir sembolik bağ oluşturur.

Değiştirgeler

hedef

Bağın hedefi.

bağ

Sembolik bağın ismi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | İşlev Windows platformlarında da (Vista, Server 2008 ve üstü) kullanılabilir oldu.

Örnekler

Örnek 1 - Bir sembolik bağ oluşturmak

<?php
$hedef = 'uploads.php';
$bağ = 'uploads';
symlink($hedef, $bağ);

echo(readlink($bağ));
?>

Notlar

Bilginize: Sadece Windows için
PHP'nin çalıştığı sistem Windows Vista/Windows Server 2008 ise bu işlev çalışacaktır. Diğer Windows sürümleri sembolik bağları desteklememektedir.

Ayrıca Bakınız

  • link() - Sabit bir bağ oluşturur
  • readlink() - Bir sembolik bağın hedefi ile döner
  • linkinfo() - Bir bağ hakkında bilgi verir

stat
tempnam
Dosya Sistemi İşlevleri


Eşsiz bir isimle dosya oluşturur

symlink
tmpfile
Dosya Sistemi İşlevleri
PHP Manual

tempnam

(PHP 4, PHP 5, PHP 7)

tempnam — Eşsiz bir isimle dosya oluşturur

Açıklama

string tempnam ( string $dizin , string $önek )

Belirtilen dizinde eşsiz bir isimle bir dosya oluşturur ve erişim izinlerini 0600'e ayarlar. Eğer belirtilen dizin mevcut değilse tempnam() sistem geçici dizininde bir dosya oluşturup bunun ismini döndürür.

Değiştirgeler

dizin

Geçici dosyanın oluşturulacağı dizin.

önek

Üretilecek geçici dosyaismi için önek.

Bilginize: Windows önekin sadece ilk üç karakterini kullanır.

Dönen Değerler

Başarısızlık durumunda FALSE aksi takdirde yeni geçici dosyanın ismiyle döner.

Sürüm Bilgisi

Sürüm: | Açıklama
4.0.6 | PHP 4.0.6 öncesinde, tempnam() işlevinin davranışı sisteme bağlıydı. Windows'ta TMP ortam değişkeni dizin ile belirtilen dizini geçersiz kılar, Linux üzerinde TMPDIR ortam değişkeninin önceliği vardır, SVR4'te ise eğer dizin mevcut bir dizini gösteriyorsa daima bu dizin kullanılır. Tereddüt ederseniz sistem belgelerinizde tempnam(3) işlevinin açıklamasına bakınız.
4.0.3 | Bu işlevin davranışı 4.0.3 sürümünde değişti. Geçici dosya, dosyanın bulunacağı dosya sisteminde, betiğin dosyayı oluşturmakta gecikmesinden önce ve dosya isminin oluşturulduğu an arasında yarış koşullarının oluşmasını engellemek için de oluşturulur. İhtiyacınız kalmadığında dosyanın silinmesini isterseniz bu özdevinimli olarak yapılmayacaktır.

Örnekler

Örnek 1 - tempnam() örneği

<?php
$geçicidosya = tempnam("/tmp", "FOO");

$tutamak = fopen($geçicidosya, "w");
fwrite($tutamak, "geçici dosya yazılıyor");
fclose($tutamak);

// bir takım kodlar

unlink($geçicidosya);
?>

Notlar

Bilginize: PHP dizin ile belirtilen dizinde bir dosya oluşturamazsa son çare olarak sistem öntanımlısını dener. NTFS dosya sisteminde bu durum, dizin ile belirtilen dizin 65534'ten dana fazla dosya içerdiğinde de ortaya çıkar.

Ayrıca Bakınız

  • tmpfile() - Geçici bir dosya oluşturur
  • sys_get_temp_dir() - Geçici dosyalar için kullanılan dizini döndürür
  • unlink() - Bir dosyayı siler

symlink
tmpfile
Dosya Sistemi İşlevleri


Geçici bir dosya oluşturur

tempnam
touch
Dosya Sistemi İşlevleri
PHP Manual

tmpfile

(PHP 4, PHP 5, PHP 7)

tmpfile — Geçici bir dosya oluşturur

Açıklama

resource tmpfile ( void )

Eşsiz bir isimle oku-yaz (w+) kipinde geçici bir dosya oluşturur ve bu dosya için bir dosya tanıtıcısı döndürür.

Dosya (fclose() kullanarak) kapatıldığında veya betik sonlandığında dosya özdevinimli olarak silinir.

Ayrıntılı bilgi edinmek için tmpfile(3) hakkında sistem belgelerine ve stdio.h başlık dosyasına bakınız.

Dönen Değerler

Başarısızlık durumunda FALSE aksi takdirde fopen() işlevinin yaptığı gibi yeni dosya için bir dosya tanıtıcısı ile döner.

Örnekler

Örnek 1 - tmpfile() örneği

<?php
$temp = tmpfile();
fwrite($temp, "geçici dosyaya yazılıyor");
fseek($temp, 0);
echo fread($temp, 1024);
fclose($temp); // Dosyanın silinmesine sebep olur
?>

Yukarıdaki örneğin çıktısı:

geçici dosyaya yazılıyor

Ayrıca Bakınız

  • tempnam() - Eşsiz bir isimle dosya oluşturur
  • sys_get_temp_dir() - Geçici dosyalar için kullanılan dizini döndürür

tempnam
touch
Dosya Sistemi İşlevleri


Dosyanın erişim ve değişiklik zamanını ayarlar

tmpfile
umask
Dosya Sistemi İşlevleri
PHP Manual

touch

(PHP 4, PHP 5, PHP 7)

touch — Dosyanın erişim ve değişiklik zamanını ayarlar

Açıklama

bool touch ( string $dosyaismi [, int $zaman = time() [, int $ezamanı ]] )

dosyaismi değiştirgesi ile ismi belirtilen dosyanın erişim ve değişiklik zamanlarını zaman değiştirgesi ile belirtilen zamana ayarlamaya çalışır.

Dosya mevcut değilse oluşturulur.

Değiştirgeler

dosyaismi

Erişilecek dosyanın ismi.

zaman

Değişiklik zamanı. Eğer zaman belirtilmemişse, o anki zaman kullanılır.

ezamanı

Belirtilmişse dosyanın erişim zamanı ezamanı değerine ayarlanır. Aksi takdirde zaman değerine ayarlanır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | Windows altında bir dizinin değişiklik zamanını ayarlamak mümkün oldu.

Örnekler

Örnek 1 - touch() örneği

<?php
if (touch($dosyaismi)) {
    echo "$dosyaismi için değişiklik zamanı şimdiye ayarlandı";
} else {
    echo "$dosyaismi için değişiklik zamanı değiştirilemedi";
}
?>

Örnek 2 -touch() ve zaman kullanımı

<?php
/*
 * Dosyanın değişiklik zamanını bir saat önceye ayarlayalım
 */
$zaman = time() - 3600;

/* Dosyaya erişelim */
if(!touch('bir_dosya.txt', $zaman))
{
    echo 'Hoop, bir şeyler yanlış oldu...';
}
else
{
    echo 'Dosyaya başarıyla erişildi';
}
?>

Notlar

Bilginize:

Zaman çözünürlüğünün dosya sistemine göre farklı olabileceğini unutmayın.

Uyarı

PHP 5.3.0 öncesinde, Windows altında bu işlevle bir dizinin değişiklik zamanını değiştirmek mümkün değildi.

tmpfile
umask
Dosya Sistemi İşlevleri


Geçerli izin maskesini değiştirir

touch
unlink
Dosya Sistemi İşlevleri
PHP Manual

umask

(PHP 4, PHP 5, PHP 7)

umask — Geçerli izin maskesini değiştirir

Açıklama

int umask ([ int $maske ] )

umask() işlevi PHP'nin izin maskesini maske & 0777 olarak ayarlar ve eskisini döndürür. PHP bir sunucu modülü olarak kullanıldığında izin maskesi her isteğin bitiminde eski değerine döndürülür.

Değiştirgeler

maske

Yeni izin maskesi.

Dönen Değerler

umask() işlevi değiştirgesiz kullanıldığında geçerli izin maskesini, aksi takdirde eski izin maskesini döndürür.

Örnekler

Örnek 1 - umask() örneği

<?php
$eski = umask(0);
chmod("/bir/dizin/bir_dosya.txt", 0755);
umask($eski);

// Sınayalım
if ($eski != umask()) {
    die('İzin maskesine eski değeri atanırken bir hata oluştu');
}
?>

Notlar

Bilginize:

Bu işlevi çok evreli sunucularda kullanmaktan kaçının. Dosya izinlerini dosyayı oluşturduktan sonra chmod() ile değiştirmek daha iyidir. umask() kullanımı çalışmakta olan betiklerin ve aynı izin maskesini kullanması sebebiyle HTTP sunucusunun beklenmedik davranışlar göstermesiyle sonuçlanabilir.

touch
unlink
Dosya Sistemi İşlevleri


Bir dosyayı siler

umask
Inotify
Dosya Sistemi İşlevleri
PHP Manual

unlink

(PHP 4, PHP 5, PHP 7)

unlink — Bir dosyayı siler

Açıklama

bool unlink ( string $dosyaismi [, resource $bağlam ] )

dosyaismi ile belirtilen dosyayı siler. Unix C unlink() işlevine benzer.

Değiştirgeler

dosyaismi

Dosya yolu.

bağlam

Bilginize: Bağlamsal destek PHP 5.0.0 ile eklenmiştir. Bağlamlar hakkında bilgi edinmek için Akım İşlevleri belgesine bakınız.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.0 | PHP 5.0.0'dan beri unlink() ayrıca bazı URL sarmalayıcılarıyla da kullanılabilmektedir. unlink() tarafından desteklenen sarmalayıcıların listesi için Supported Protocols and Wrappers bölümüne bakınız.

Örnekler

Örnek 1 - Basit unlink() kullanımı

<?php
$fh = fopen('deneme.html', 'a');
fwrite($fh, '<h1>Menhaba Dünya!</h1>');
fclose($fh);

mkdir('dnmdizini', 0777);

unlink('deneme.html');
unlink('dnmdizini');
?>

Ayrıca Bakınız

  • rmdir() - Dizin siler

umask
Inotify
Dosya Sistemi İşlevleri


Inotify

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Yapılandırma/Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Inotify İşlevleri
    • inotify_add_watch — Add a watch to an initialized inotify instance
    • inotify_init — Initialize an inotify instance
    • inotify_queue_len — Return a number upper than zero if there are pending events
    • inotify_read — Read events from an inotify instance
    • inotify_rm_watch — Remove an existing watch from an inotify instance
unlink
Giriş
Dosya Sistemiyle İlgili Eklentiler


Giriş

The inotify extension exposes the inotify functions inotify_init(), inotify_add_watch() and inotify_rm_watch().

As the C inotify_init() function returns a file descriptor, PHP's inotify_init() returns a stream resource, usable with standard stream functions, like stream_select(), stream_set_blocking() and fclose(). inotify_read() replaces the C way of reading inotify events.

Inotify
Yapılandırma/Kurulum
Inotify


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Yapılandırma/Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Inotify


Gereksinimler

This extension requires Linux 2.6.13 or newer, and a recent libC.

Yapılandırma/Kurulum
Yapılandırma/Kurulum
Yapılandırma/Kurulum


Yapılandırma/Kurulum
PHP Manual

Yapılandırma/Kurulum

Bu » PECL eklentisi PHP ile gelmez.

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/inotify.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum
PHP Manual


Çalışma Anı Yapılandırması

Bu eklentinin php.ini'de tanımlı yapılandırma yönergesi yoktur.

Yapılandırma/Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Özkaynak Türleri

This extension defines a stream resource returned by inotify_init().

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

Inotify constants usable with inotify_add_watch() and/or returned by inotify_read()
IN_ACCESS (integer)
File was accessed (read) (*)
IN_MODIFY (integer)
File was modified (*)
IN_ATTRIB (integer)
Metadata changed (e.g. permissions, mtime, etc.) (*)
IN_CLOSE_WRITE (integer)
File opened for writing was closed (*)
IN_CLOSE_NOWRITE (integer)
File not opened for writing was closed (*)
IN_OPEN (integer)
File was opened (*)
IN_MOVED_TO (integer)
File moved into watched directory (*)
IN_MOVED_FROM (integer)
File moved out of watched directory (*)
IN_CREATE (integer)
File or directory created in watched directory (*)
IN_DELETE (integer)
File or directory deleted in watched directory (*)
IN_DELETE_SELF (integer)
Watched file or directory was deleted
IN_MOVE_SELF (integer)
Watch file or directory was moved
IN_CLOSE (integer)
Equals to IN_CLOSE_WRITE | IN_CLOSE_NOWRITE
IN_MOVE (integer)
Equals to IN_MOVED_FROM | IN_MOVED_TO
IN_ALL_EVENTS (integer)
Bitmask of all the above constants
IN_UNMOUNT (integer)
File system containing watched object was unmounted
IN_Q_OVERFLOW (integer)
Event queue overflowed (wd is -1 for this event)
IN_IGNORED (integer)
Watch was removed (explicitly by inotify_rm_watch() or because file was removed or filesystem unmounted
IN_ISDIR (integer)
Subject of this event is a directory
IN_ONLYDIR (integer)
Only watch pathname if it is a directory (Since Linux 2.6.15)
IN_DONT_FOLLOW (integer)
Do not dereference pathname if it is a symlink (Since Linux 2.6.15)
IN_MASK_ADD (integer)
Add events to watch mask for this pathname if it already exists (instead of replacing mask).
IN_ONESHOT (integer)
Monitor pathname for one event, then remove from watch list.

Bilginize: The events marked with an asterisk (*) above can occur for files in watched directories.

Özkaynak Türleri
Inotify İşlevleri
Inotify


Inotify İşlevleri

İçindekiler

  • inotify_add_watch — Add a watch to an initialized inotify instance
  • inotify_init — Initialize an inotify instance
  • inotify_queue_len — Return a number upper than zero if there are pending events
  • inotify_read — Read events from an inotify instance
  • inotify_rm_watch — Remove an existing watch from an inotify instance
Öntanımlı Sabitler
inotify_add_watch
Inotify


Add a watch to an initialized inotify instance

Inotify İşlevleri
inotify_init
Inotify İşlevleri
PHP Manual

inotify_add_watch

(PECL inotify >= 0.1.2)

inotify_add_watch — Add a watch to an initialized inotify instance

Açıklama

int inotify_add_watch ( resource $inotify_instance , string $pathname , int $mask )

inotify_add_watch() adds a new watch or modify an existing watch for the file or directory specified in pathname.

Using inotify_add_watch() on a watched object replaces the existing watch. Using the IN_MASK_ADD constant adds (OR) events to the existing watch.

Değiştirgeler

inotify_instance

inotify_init() tarafından döndürülen özkaynak

pathname

File or directory to watch

mask

Events to watch for. See Yerleşik Sabitler.

Dönen Değerler

The return value is a unique (inotify instance wide) watch descriptor.

Ayrıca Bakınız

  • inotify_init() - Initialize an inotify instance

Inotify İşlevleri
inotify_init
Inotify İşlevleri


Initialize an inotify instance

inotify_add_watch
inotify_queue_len
Inotify İşlevleri
PHP Manual

inotify_init

(PECL inotify >= 0.1.2)

inotify_init — Initialize an inotify instance

Açıklama

resource inotify_init ( void )

Initialize an inotify instance for use with inotify_add_watch()

Dönen Değerler

A stream resource or FALSE on error.

Örnekler

Örnek 1 Example usage of inotify

<?php
// Open an inotify instance
$fd = inotify_init();

// Watch __FILE__ for metadata changes (e.g. mtime)
$watch_descriptor = inotify_add_watch($fd, __FILE__, IN_ATTRIB);

// generate an event
touch(__FILE__);

// Read events
$events = inotify_read($fd);
print_r($events);

// The following methods allows to use inotify functions without blocking on inotify_read():

// - Using stream_select() on $fd:
$read = array($fd);
$write = null;
$except = null;
stream_select($read,$write,$except,0);

// - Using stream_set_blocking() on $fd
stream_set_blocking($fd, 0);
inotify_read($fd); // Does no block, and return false if no events are pending

// - Using inotify_queue_len() to check if event queue is not empty
$queue_len = inotify_queue_len($fd); // If > 0, inotify_read() will not block

// Stop watching __FILE__ for metadata changes
inotify_rm_watch($fd, $watch_descriptor);

// Close the inotify instance
// This may have closed all watches if this was not already done
fclose($fd);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(
  array(
    'wd' => 1,     // Equals $watch_descriptor
    'mask' => 4,   // IN_ATTRIB bit is set
    'cookie' => 0, // unique id to connect related events (e.g.
                   // IN_MOVE_FROM and IN_MOVE_TO events)
    'name' => '',  // the name of a file (e.g. if we monitored changes
                   // in a directory)
  ),
);

Ayrıca Bakınız

  • inotify_add_watch() - Add a watch to an initialized inotify instance
  • inotify_rm_watch() - Remove an existing watch from an inotify instance
  • inotify_queue_len() - Return a number upper than zero if there are pending events
  • inotify_read() - Read events from an inotify instance
  • fclose() - Açık bir dosya tanıtıcısını kapatır

inotify_add_watch
inotify_queue_len
Inotify İşlevleri


Return a number upper than zero if there are pending events

inotify_init
inotify_read
Inotify İşlevleri
PHP Manual

inotify_queue_len

(PECL inotify >= 0.1.2)

inotify_queue_len — Return a number upper than zero if there are pending events

Açıklama

int inotify_queue_len ( resource $inotify_instance )

This function allows to know if inotify_read() will block or not. If a number upper than zero is returned, there are pending events and inotify_read() will not block.

Değiştirgeler

inotify_instance

inotify_init() tarafından döndürülen özkaynak

Dönen Değerler

Returns a number upper than zero if there are pending events.

Ayrıca Bakınız

  • inotify_init() - Initialize an inotify instance
  • stream_select() - Belirtilen akım dizisi üzerinde belirtilen zaman aşımı ile select() sistem çağrısının eşdeğeri olarak çalışır
  • stream_set_blocking() - Akımın engelleme kipini ayarlar

inotify_init
inotify_read
Inotify İşlevleri


Read events from an inotify instance

inotify_queue_len
inotify_rm_watch
Inotify İşlevleri
PHP Manual

inotify_read

(PECL inotify >= 0.1.2)

inotify_read — Read events from an inotify instance

Açıklama

array inotify_read ( resource $inotify_instance )

Read inotify events from an inotify instance.

Değiştirgeler

inotify_instance

inotify_init() tarafından döndürülen özkaynak

Dönen Değerler

An array of inotify events or FALSE if no events was pending and inotify_instance is non-blocking. Each event is an array with the following keys:

  • wd is a watch descriptor returned by inotify_add_watch()
  • mask is a bit mask of events
  • cookie is a unique id to connect related events (e.g. IN_MOVE_FROM and IN_MOVE_TO)
  • name is the name of a file (e.g. if a file was modified in a watched directory)

Ayrıca Bakınız

  • inotify_init() - Initialize an inotify instance
  • stream_select() - Belirtilen akım dizisi üzerinde belirtilen zaman aşımı ile select() sistem çağrısının eşdeğeri olarak çalışır
  • stream_set_blocking() - Akımın engelleme kipini ayarlar
  • inotify_queue_len() - Return a number upper than zero if there are pending events

inotify_queue_len
inotify_rm_watch
Inotify İşlevleri


Remove an existing watch from an inotify instance

inotify_read
MIME Türü
Inotify İşlevleri
PHP Manual

inotify_rm_watch

(PECL inotify >= 0.1.2)

inotify_rm_watch — Remove an existing watch from an inotify instance

Açıklama

bool inotify_rm_watch ( resource $inotify_instance , int $watch_descriptor )

inotify_rm_watch() removes the watch watch_descriptor from the inotify instance inotify_instance.

Değiştirgeler

inotify_instance

inotify_init() tarafından döndürülen özkaynak

watch_descriptor

Watch to remove from the instance

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • inotify_init() - Initialize an inotify instance

inotify_read
MIME Türü
Inotify İşlevleri


MIME Türü

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
inotify_rm_watch
Giriş
Dosya Sistemiyle İlgili Eklentiler


Giriş

Uyarı

Fileinfo PECL eklentisi aynı işlevselliği fazlasıyla sağladığından bu eklentinin kullanımı önerilmemektedir.

Bu modüldeki işlevler dosyanın belli yerlerindeki sihirli bayt dizilimlerine bakarak bir dosyanın kodlamasını ve içerik türünü tahmin etmeye çalışırlar. Bu çok güçlü bir yaklaşım olmasa da kullanılan ampirik yöntemler oldukça işe yaramaktadır.

Bu eklenti, Apache'nin, Ian F. Darwin tarafından gerçeklenen file komutuna dayanan mod_mime_magic modülünden türetilmiştir. Tarihsel gelişim ve telif hakkı bilgileri için kaynak koduna bakınız.

MIME Türü
Yapılandırma/Kurulum
MIME Türü


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
MIME Türü


Kurulum

MIME türü işlevleri desteğini sağlamak için PHP'yi --with-mime-magic yapılandırma seçeneğini kullanarak derlemelisiniz. Eklenti, Apache httpd ile birlikte dağıtılan basitleştirilmiş magic dosyasının bir kopyasına ihtiyaç duyar.

Bilginize:

Yapılandırma seçeneği olarak PHP 4.3.2'den itibaren --enable-mime-magic yerine --with-mime-magic kullanılmaktadır.

Bilginize:

Bu eklenti, genellikle standart Linux dağıtımlarıyla gelen ve file komutunun son sürümlerince kullanılan tam donanımlı magic dosyasıyla çalışabilecek kabiliyette değildir.

Bilginize: Win32 Kullanıcılarının Dikkatine

Bu modülü Windows ortamında kullanırken, php.ini dosyanızda paketle birlikte gelen magic.mime dosyasının yolunu belirtmeniz gerekir.

Örnek 1 - magic.mime dosya yolunun belirtilmesi

mime_magic.magicfile = "$PHP_INSTALL_DIR\magic.mime"

Burada $PHP_INSTALL_DIR yerine PHP'nin kurulu olduğu asıl yolu (c:\php gibi) belirtmeyi unutmayın.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

MIME Türü yapılandırma seçenekleri
İsim | Öntanımlı | Değişiklik Yeri | Sürüm Bilgisi
mime_magic.debug | "0" | PHP_INI_SYSTEM | PHP 5.0.0'dan beri kullanılmaktadır.
mime_magic.magicfile | "/bir/yol/php/magic.mime" | PHP_INI_SYSTEM | HP 4.3.0'dan beri kullanılmaktadır.
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

mime_magic.debug bool

Hata ayıklama kipini açar/kapar.

mime_magic.magicfile string

magic.mime dosyasının yolu.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
Proctitle
MIME Türü


Proctitle

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Proctitle İşlevleri
    • setproctitle — Set the process title
    • setthreadtitle — Set the thread title
Öntanımlı Sabitler
Giriş
Dosya Sistemiyle İlgili Eklentiler


Giriş

This extension allows changing the current process', and thread, name on Linux and *BSD systems. This is useful when using pcntl_fork() to identify running processes in process list

Proctitle
Yapılandırma/Kurulum
Proctitle


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Proctitle


Gereksinimler

Nothing special.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/proctitle.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
Proctitle İşlevleri
Proctitle


Proctitle İşlevleri

İçindekiler

  • setproctitle — Set the process title
  • setthreadtitle — Set the thread title
Öntanımlı Sabitler
setproctitle
Proctitle


Set the process title

Proctitle İşlevleri
setthreadtitle
Proctitle İşlevleri
PHP Manual

setproctitle

(PECL proctitle >= 0.1.0)

setproctitle — Set the process title

Açıklama

void setproctitle ( string $title )

Sets the process title of the current process.

Değiştirgeler

title

The title to use as the process title.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 setproctitle() example

Running the example below will change the process title (visible with ps a for example).

<?php
setproctitle("myscript");
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

$ ps a
  PID TTY      STAT   TIME COMMAND
 1168 pts/3    S      0:00 myscript

Ayrıca Bakınız

  • cli_set_process_title() - Sets the process title
  • pcntl_fork() - Çalışan süreci çatallar
  • setthreadtitle() - Set the thread title
Proctitle İşlevleri
setthreadtitle
Proctitle İşlevleri


Set the thread title

setproctitle
xattr
Proctitle İşlevleri
PHP Manual

setthreadtitle

(PECL proctitle >= 0.1.2)

setthreadtitle — Set the thread title

Açıklama

bool setthreadtitle ( string $title )

Sets the thread title.

Değiştirgeler

title

The title to use as the thread title.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 setthreadtitle() example

Running the example below will change the thread title (visible with ps c for example).

<?php
setthreadtitle("myscript");
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

$ ps c
  PID TTY      STAT   TIME COMMAND
 1178 pts/3    S      0:00 myscript

Ayrıca Bakınız

  • pcntl_fork() - Çalışan süreci çatallar
  • setproctitle() - Set the process title
setproctitle
xattr
Proctitle İşlevleri


xattr

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • xattr İşlevleri
    • xattr_get — Bir özniteliğin değerini döndürür
    • xattr_list — Ek özniteliklerin listesini döndürür
    • xattr_remove — Bir ek özniteliği siler
    • xattr_set — Bir ek özniteliği tanımlar
    • xattr_supported — Dosya sistemi ek öznitelikleri destekliyor mu diye bakar
setthreadtitle
Giriş
Dosya Sistemiyle İlgili Eklentiler


Giriş

Xattr eklentisi bir dosya sisteminin ek özniteliklerinde değişiklik yapmaya yarar.

xattr
Yapılandırma/Kurulum
xattr


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
xattr


Gereksinimler

xattr eklentisini kullanmak için, libattr sisteminizde kurulu olmalıdır. Libattr » http://oss.sgi.com/projects/xfs/ adresinden edinilebilir.

Bilginize:

Bu işlevler sadece ek özniteliklerin desteklendiği dosya sistemlerinde dosya sistemi bağlanırken etkinleştirildikleri takdirde çalışır. Ek öznitelikleri desteklediği bilinen dosya sistemleri şunlardır: ext2, ext3, reiserfs, jfs ve xfs.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/xattr

Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

XATTR_ROOT (integer)
Özniteliği root isim alanında tanımlar; root yetkisi gerektirir.
XATTR_DONTFOLLOW (integer)
Sembolik bağlar izlenmez, sembolik bağın kendisinde işlem yapar.
XATTR_CREATE (integer)
Ek öznitelik zaten tanımlıysa işlev başarısız olur.
XATTR_REPLACE (integer)
Öznitelik evvelce tanımlanmamışsa işlev başarısız olur.
Özkaynak Türleri
xattr İşlevleri
xattr


xattr İşlevleri

İçindekiler

  • xattr_get — Bir özniteliğin değerini döndürür
  • xattr_list — Ek özniteliklerin listesini döndürür
  • xattr_remove — Bir ek özniteliği siler
  • xattr_set — Bir ek özniteliği tanımlar
  • xattr_supported — Dosya sistemi ek öznitelikleri destekliyor mu diye bakar
Öntanımlı Sabitler
xattr_get
xattr


Bir özniteliğin değerini döndürür

xattr İşlevleri
xattr_list
xattr İşlevleri
PHP Manual

xattr_get

(PECL xattr >= 0.9.0)

xattr_get — Bir özniteliğin değerini döndürür

Açıklama

string xattr_get ( string $dosya , string $isim [, int $seçenekler = 0 ] )

Belirtilen dosyanın belirtilen özniteliğinin değerini döndürür.

Ek öznitelikler iki isim alanına sahiptir: kullanıcı ve root. Kullanıcı isim alanını tüm kullanıcılar kullanabilir; root isim alanını ise sadece root yetkilerine sahip kullanıcılar kullanabilir. xattr eklentisi öntanımlı olarak kullanıcı isim alanında işlem yapar, fakat bu davranış seçenekler değiştirgesi ile değiştirilebilir.

Değiştirgeler

dosya

Özniteliği sorgulanacak dosyanın yolu.

isim

Özniteliğin ismi.

seçenekler

Desteklenen xattr seçenekleri
XATTR_DONTFOLLOW | Sembolik bağlar izlenmez, sembolik bağın kendisinde işlem yapar.
XATTR_ROOT | Özniteliği root isim alanında tanımlar; root yetkisi gerektirir.

Dönen Değerler

Öznitelik tanımlı değilse FALSE tanımlıysa değeri bir dizge olarak döndürür.

Örnekler

Örnek 1 - Yönetici dosyayı imzalamış mı diye bakmak

<?php
$dosya = '/usr/local/sbin/bir_dosya';
$imza = xattr_get($dosya, 'Root imzasi', XATTR_ROOT);

/* ... $imza geçerli mi diye bakılsın ... */

?>

Ayrıca Bakınız

  • xattr_list() - Ek özniteliklerin listesini döndürür
  • xattr_set() - Bir ek özniteliği tanımlar
  • xattr_remove() - Bir ek özniteliği siler

xattr İşlevleri
xattr_list
xattr İşlevleri


Ek özniteliklerin listesini döndürür

xattr_get
xattr_remove
xattr İşlevleri
PHP Manual

xattr_list

(PECL xattr >= 0.9.0)

xattr_list — Ek özniteliklerin listesini döndürür

Açıklama

array xattr_list ( string $dosya [, int $seçenekler = 0 ] )

Belirtilen dosyanın ek özniteliklerinin listesini döndürür.

Ek öznitelikler iki isim alanına sahiptir: kullanıcı ve root. Kullanıcı isim alanını tüm kullanıcılar kullanabilir; root isim alanını ise sadece root yetkilerine sahip kullanıcılar kullanabilir. xattr eklentisi öntanımlı olarak kullanıcı isim alanında işlem yapar, fakat bu davranış seçenekler değiştirgesi ile değiştirilebilir.

Değiştirgeler

dosya

Dosya yolu.

seçenekler

Desteklenen xattr seçenekleri
XATTR_DONTFOLLOW | Sembolik bağlar izlenmez, sembolik bağın kendisinde işlem yapar.
XATTR_ROOT | Özniteliği root isim alanında tanımlar; root yetkisi gerektirir.

Dönen Değerler

Ek özniteliklerin isimlerini içeren bir dizi döndürür.

Örnekler

Örnek 1 - Bir dosyanın tüm özniteliklerini listelemek

<?php
$file = 'some_file';
$root_attributes = xattr_list($file, XATTR_ROOT);
$user_attributes = xattr_list($file);

echo "root öznitelikleri: \n";
foreach ($root_attributes as $attr_name) {
    printf("%s\n", $attr_name);
}

echo "\n kullanıcı öznitelikleri: \n";
foreach ($attributes as $attr_name) {
    printf("%s\n", $attr_name);
}

?>

Ayrıca Bakınız

  • xattr_get() - Bir özniteliğin değerini döndürür

xattr_get
xattr_remove
xattr İşlevleri


Bir ek özniteliği siler

xattr_list
xattr_set
xattr İşlevleri
PHP Manual

xattr_remove

(PECL xattr >= 0.9.0)

xattr_remove — Bir ek özniteliği siler

Açıklama

bool xattr_remove ( string $dosya , string $isim [, int $seçenekler = 0 ] )

Belirtilen dosyanın belirtilen özniteliğini siler.

Ek öznitelikler iki isim alanına sahiptir: kullanıcı ve root. Kullanıcı isim alanını tüm kullanıcılar kullanabilir; root isim alanını ise sadece root yetkilerine sahip kullanıcılar kullanabilir. xattr eklentisi öntanımlı olarak kullanıcı isim alanında işlem yapar, fakat bu davranış seçenekler değiştirgesi ile değiştirilebilir.

Değiştirgeler

dosya

Özniteliği silinecek dosyanın yolu.

isim

Silinecek özniteliğin ismi.

seçenekler

Desteklenen xattr seçenekleri
XATTR_DONTFOLLOW | Sembolik bağlar izlenmez, sembolik bağın kendisinde işlem yapar.
XATTR_ROOT | Özniteliği root isim alanında tanımlar; root yetkisi gerektirir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Bir dosyanın ek özniteliklerinin tamamını silmek

<?php
$dosya = '/mnt/hda1/bir_dosya';
$öznitelikler = xattr_list($dosya);

foreach ($öznitelikler as $öznitelik) {
    xattr_remove($dosya, $öznitelik);
}
?>

Ayrıca Bakınız

  • xattr_list() - Ek özniteliklerin listesini döndürür
  • xattr_set() - Bir ek özniteliği tanımlar
  • xattr_get() - Bir özniteliğin değerini döndürür

xattr_list
xattr_set
xattr İşlevleri


Bir ek özniteliği tanımlar

xattr_remove
xattr_supported
xattr İşlevleri
PHP Manual

xattr_set

(PECL xattr >= 0.9.0)

xattr_set — Bir ek özniteliği tanımlar

Açıklama

bool xattr_set ( string $dosya , string $isim , string $değer [, int $seçenekler = 0 ] )

Belirtilen dosyanın belirtilen özniteliğini tanımlar.

Ek öznitelikler iki isim alanına sahiptir: kullanıcı ve root. Kullanıcı isim alanını tüm kullanıcılar kullanabilir; root isim alanını ise sadece root yetkilerine sahip kullanıcılar kullanabilir. xattr eklentisi öntanımlı olarak kullanıcı isim alanında işlem yapar, fakat bu davranış seçenekler değiştirgesi ile değiştirilebilir.

Değiştirgeler

dosya

Özniteliği tanımlanacak dosyanın yolu.

isim

Ek özniteliğin ismi. Öznitelik yoksa oluşturulur varsa değeri değiştirilir. Bu davranışı seçenekler değiştirgesi ile değiştirebilirsiniz.

değer

Özniteliğin değeri.

seçenekler

Desteklenen xattr seçenekleri
XATTR_CREATE | Ek öznitelik zaten tanımlıysa işlev başarısız olur.
XATTR_REPLACE | Öznitelik evvelce tanımlanmamışsa işlev başarısız olur.
XATTR_DONTFOLLOW | Sembolik bağlar izlenmez, sembolik bağın kendisinde işlem yapar.
XATTR_ROOT | Özniteliği root isim alanında tanımlar; root yetkisi gerektirir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Bir .wav dosyasında ek öznitelik tanımlamak

<?php
$file = 'sevilen_sarki.wav';
xattr_set($file, 'Sarkici', 'Birisi');
xattr_set($file, 'Kalite', 'Eh iste');
xattr_set($file, 'Dinleme sayisi', '34');

/* ... bazı kodlar ... */

printf("Bu şarkı %d kere çalınmış", xattr_get($file, 'Dinleme sayisi'));
?>

Ayrıca Bakınız

  • xattr_get() - Bir özniteliğin değerini döndürür
  • xattr_remove() - Bir ek özniteliği siler

xattr_remove
xattr_supported
xattr İşlevleri


Dosya sistemi ek öznitelikleri destekliyor mu diye bakar

xattr_set
xdiff
xattr İşlevleri
PHP Manual

xattr_supported

(PECL xattr >= 1.0.0)

xattr_supported — Dosya sistemi ek öznitelikleri destekliyor mu diye bakar

Açıklama

bool xattr_supported ( string $dosya [, int $seçenekler = 0 ] )

Belirtilen dosyayı içeren dosya sistemi ek öznitelikleri destekliyorsa TRUE döner. Dosya için okuma izni gerekir.

Değiştirgeler

dosya

Sınanacak dosyanın yolu.

seçenekler

Desteklenen xattr seçenekleri
XATTR_DONTFOLLOW Sembolik bağlar izlenmez, sembolik bağın kendisinde işlem yapar.

Dönen Değerler

Dosya sistemi ek öznitelikleri destekliyorsa TRUE, desteklemiyorsa FALSE, yanlış yol belirtimi veya okuma izninin yokluğu gibi sebeplerle destek saptanamazsa NULL döner.

Örnekler

Örnek 1 - xattr_supported() örneği

Aşağıdaki kodda ek öznitelikler kullanılabiliyor mu diye bakılmaktadır.

<?php
$dosya = '/mnt/hda1/bir_dosya';

if (xattr_supported($dosya)) {
    /* ... xattr_* işlevleri burada kullanılabilir ... */
}

?>

Ayrıca Bakınız

  • xattr_get() - Bir özniteliğin değerini döndürür
  • xattr_list() - Ek özniteliklerin listesini döndürür

xattr_set
xdiff
xattr İşlevleri


xdiff

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • xdiff İşlevleri
    • xdiff_file_bdiff_size — Belirtilen ikil yama uygulanarak oluşturulacak dosyanın boyutunu döndürür
    • xdiff_file_bdiff — İki dosyanın ikil farkını alır
    • xdiff_file_bpatch — Bir dosyaya bir ikil yama uygular
    • xdiff_file_diff_binary — xdiff_file_bdiff işlevinin takma adıdır
    • xdiff_file_diff — İki dosyanın tekil farkını alır
    • xdiff_file_merge3 — Üç dosyayı tek dosya haline getirir
    • xdiff_file_patch_binary — xdiff_file_bpatch işlevinin takma adıdır
    • xdiff_file_patch — Bir dosyaya bir tekil yama uygular
    • xdiff_file_rabdiff — Rabin'in çok terimli parmakizi algoritmasını kullanarak iki dizgenin ikil olarak farkını alır
    • xdiff_string_bdiff_size — Belirtilen ikil yama uygulanarak oluşturulacak dosyanın boyutunu döndürür
    • xdiff_string_bdiff — İki dizgenin ikil farkını alır
    • xdiff_string_bpatch — Bir dizgeyi bir ikil fark dizgesiyle yamar
    • xdiff_string_diff_binary — xdiff_string_bdiff işlevinin takma adıdır
    • xdiff_string_diff — İki dizgenin tekil farkını alır
    • xdiff_string_merge3 — Üç dizgeyi tek bir dizge haline getirir
    • xdiff_string_patch_binary — xdiff_string_bpatch işlevinin takma ismidir
    • xdiff_string_patch — Bir dizgeyi bir tekil fark dizgesi ile yamar
    • xdiff_string_rabdiff — Rabin'in çok terimli parmakizi algoritmasını kullanarak iki dizgenin ikil olarak farkını alır
xattr_supported
Giriş
Dosya Sistemiyle İlgili Eklentiler


Giriş

xdiff eklentisi, dosyaların farklı sürümleri arasındaki farkları içeren yama dosyalarını oluşturmanızı ve bunları uygulamanızı sağlar.

Eklenti iki işlem kipini destekler: Dizgeler ve dosyalar. Ayrıca iki farklı yama biçemini destekler: Tekil ve ikil. Tekilleştirilmiş yamalar kolayca okundukları için metin dosyaları için çok uygundur. İkil yamalar ise arşivler ve resimler gibi ikil dosyalar için uygun olup basılamayan karakterleri de elde edebilirler ve ikil olarak güvenilirdirler.

1.5.0 sürümünden başlayarak ikil yamaları üretmek için iki ayrı işlev kümesi kullanılmaktadır. Yeni işlevler, xdiff_string_rabdiff() ve xdiff_file_rabdiff(), eski işlevlerle uyumlu çıktılar üretmekle birlikte ürettikleri çıktılar daha hızlı ve daha küçüktür. İkil yamaların üretim yöntemleri ve bunların farkları hakkında daha ayrıntılı bilgi edinmek için » libxdiff sitesine bakınız.

xdiff eklentisi bu işlevleri gerçeklemek için libxdiff kütüphanesini kullanmaktadır. Daha fazla bilgi için » http://www.xmailserver.org/xdiff-lib.html adresine bakınız.

xdiff
Yapılandırma/Kurulum
xdiff


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
xdiff


Gereksinimler

xdiff eklentisini kullanmak için sisteminizde libxdiff kurulu olmalıdır. libxdiff » http://www.xmailserver.org/xdiff-lib.html adresinden edinilebilir.

Bilginize:

Bellek sınırlarını zorlamamak için libxdiff'in en azından 0.7 sürümü gerekir.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/xdiff

Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

XDIFF_PATCH_NORMAL (integer)
xdiff_string_patch() ve xdiff_file_patch() işlevlerinin yamayı özgün dosyaya uygulayıp dosyanın yeni sürümünü elde etmek amacıyla kullanılacağını belirtir. Bu öntanımlı işlem kipidir.
XDIFF_PATCH_REVERSE (integer)
xdiff_string_patch() ve xdiff_file_patch() işlevlerinin yamayı yeni sürüme uygulayıp dosyanın özgün sürümünü elde etmek amacıyla kullanılacağını belirtir.
Özkaynak Türleri
xdiff İşlevleri
xdiff


xdiff İşlevleri

İçindekiler

  • xdiff_file_bdiff_size — Belirtilen ikil yama uygulanarak oluşturulacak dosyanın boyutunu döndürür
  • xdiff_file_bdiff — İki dosyanın ikil farkını alır
  • xdiff_file_bpatch — Bir dosyaya bir ikil yama uygular
  • xdiff_file_diff_binary — xdiff_file_bdiff işlevinin takma adıdır
  • xdiff_file_diff — İki dosyanın tekil farkını alır
  • xdiff_file_merge3 — Üç dosyayı tek dosya haline getirir
  • xdiff_file_patch_binary — xdiff_file_bpatch işlevinin takma adıdır
  • xdiff_file_patch — Bir dosyaya bir tekil yama uygular
  • xdiff_file_rabdiff — Rabin'in çok terimli parmakizi algoritmasını kullanarak iki dizgenin ikil olarak farkını alır
  • xdiff_string_bdiff_size — Belirtilen ikil yama uygulanarak oluşturulacak dosyanın boyutunu döndürür
  • xdiff_string_bdiff — İki dizgenin ikil farkını alır
  • xdiff_string_bpatch — Bir dizgeyi bir ikil fark dizgesiyle yamar
  • xdiff_string_diff_binary — xdiff_string_bdiff işlevinin takma adıdır
  • xdiff_string_diff — İki dizgenin tekil farkını alır
  • xdiff_string_merge3 — Üç dizgeyi tek bir dizge haline getirir
  • xdiff_string_patch_binary — xdiff_string_bpatch işlevinin takma ismidir
  • xdiff_string_patch — Bir dizgeyi bir tekil fark dizgesi ile yamar
  • xdiff_string_rabdiff — Rabin'in çok terimli parmakizi algoritmasını kullanarak iki dizgenin ikil olarak farkını alır
Öntanımlı Sabitler
xdiff_file_bdiff_size
xdiff


Belirtilen ikil yama uygulanarak oluşturulacak dosyanın boyutunu döndürür

xdiff İşlevleri
xdiff_file_bdiff
xdiff İşlevleri
PHP Manual

xdiff_file_bdiff_size

(PECL xdiff >= 1.5.0)

xdiff_file_bdiff_size — Belirtilen ikil yama uygulanarak oluşturulacak dosyanın boyutunu döndürür

Açıklama

int xdiff_file_bdiff_size ( string $dosya )

Belirtilen ikil yama dizgesini özgün dosyaya uyguladıktan sonra oluşacak yeni dosyanın boyutunu döndürür.

Değiştirgeler

dosya

xdiff_file_bdiff() veya xdiff_file_rabdiff() tarafından oluşturulmuş ikil yama dosyasının yolu.

Dönen Değerler

Oluşacak dosyanın boyutunu döndürür.

Örnekler

Örnek 1 - xdiff_file_bdiff_size() örneği

Aşağıdaki kodda, bir ikil yama uygulanarak oluşturulacak dosyanın boyutu döndürülmektedir.

<?php
$length = xdiff_string_bdiff_size('file.bdiff');
echo "Elde edilen dosya $length bayt uzunluktadır";
?>

Ayrıca Bakınız

  • xdiff_file_bdiff() - İki dosyanın ikil farkını alır
  • xdiff_file_rabdiff() - Rabin'in çok terimli parmakizi algoritmasını kullanarak iki dizgenin ikil olarak farkını alır
  • xdiff_file_bpatch() - Bir dosyaya bir ikil yama uygular

xdiff İşlevleri
xdiff_file_bdiff
xdiff İşlevleri


İki dosyanın ikil farkını alır

xdiff_file_bdiff_size
xdiff_file_bpatch
xdiff İşlevleri
PHP Manual

xdiff_file_bdiff

(PECL xdiff >= 1.5.0)

xdiff_file_bdiff — İki dosyanın ikil farkını alır

Açıklama

bool xdiff_file_bdiff ( string $eski_dosya , string $yeni_dosya , string $hedef )

eski_dosya ile yeni_dosya arasındaki farklardan bir ikil fark dizgesi oluşturup sonucu hedef dosyasına kaydeder. Bu işlev hem metin hem de ikil verilerle çalışabilir. Elde edilen yama daha sonra xdiff_file_bpatch() ve xdiff_string_bpatch() işleviyle uygulanabilir.

Değiştirgeler

eski_dosya

İlk dosyanın yolu. Eski dosya olarak ele alınır.

yeni_dosya

İkinci dosyanın yolu. Yeni dosya olarak ele alınır.

hedef

Elde edilen yamanın kaydedileceği dosyanın yolu. Dosya ikil bir dosya olacağından içeriği insanlarca okunabilir olmayacaktır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - xdiff_file_bdiff() örneği

Aşağıda iki arşiv dosyasının ikil farkı alınmaktadır.

<?php
$old_version = 'my_script_1.0.tgz';
$new_version = 'my_script_1.1.tgz';

xdiff_file_bdiff($old_version, $new_version, 'my_script.bdiff');
?>

Notlar

Bilginize:

Her iki dosya da belleğe yükleneceğinden memory_limit yönergenizde yeteri kadar bellek belirtmiş olmalısınız.

Ayrıca Bakınız

  • xdiff_file_bpatch() - Bir dosyaya bir ikil yama uygular

xdiff_file_bdiff_size
xdiff_file_bpatch
xdiff İşlevleri


Bir dosyaya bir ikil yama uygular

xdiff_file_bdiff
xdiff_file_diff_binary
xdiff İşlevleri
PHP Manual

xdiff_file_bpatch

(PECL xdiff >= 1.5.0)

xdiff_file_bpatch — Bir dosyaya bir ikil yama uygular

Açıklama

bool xdiff_file_bpatch ( string $dosya , string $yama , string $hedef )

Belirtilen dosya'ya ikil yama'yı uygular ve sonucu hedef'e kaydeder. Bu işlev xdiff_file_bdiff() ve xdiff_file_rabdiff() işlevleriyle veya bunların dizgelerle çalışan eşdeğerleriyle üretilmiş yamaları kabul eder.

Değiştirgeler

dosya

Yamanın uygulanacağı dosyanın yolu.

yama

İkil yama dosyası.

hedef

Sonucun kaydedileceği dosyanın yolu.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - xdiff_file_bpatch() örneği

Aşağıda bir dosyaya ikil yama uygulanmaktadır.

<?php
$old_version = 'archive-1.0.tgz';
$patch = 'archive.bpatch';

$result = xdiff_file_bpatch($old_version, $patch, 'archive-1.1.tgz');
if ($result) {
   echo "Dosya yamandı";
} else {
   echo "Dosya yamanamadı";
}

?>

Notlar

Bilginize:

Her iki dosya da (dosya ve yama) belleğe yükleneceğinden memory_limit yönergenizde yeteri kadar bellek belirtmiş olmalısınız.

Ayrıca Bakınız

  • xdiff_file_bdiff() - İki dosyanın ikil farkını alır
  • xdiff_file_rabdiff() - Rabin'in çok terimli parmakizi algoritmasını kullanarak iki dizgenin ikil olarak farkını alır

xdiff_file_bdiff
xdiff_file_diff_binary
xdiff İşlevleri


xdiff_file_bdiff işlevinin takma adıdır

xdiff_file_bpatch
xdiff_file_diff
xdiff İşlevleri
PHP Manual

xdiff_file_diff_binary

(PECL xdiff >= 0.2.0)

xdiff_file_diff_binary — xdiff_file_bdiff() işlevinin takma adıdır

Açıklama

bool xdiff_file_diff_binary ( string $eski_dosya , string $yeni_dosya , string $hedef )

eski_dosya ile yeni_dosya arasındaki farklardan bir ikil fark dizgesi oluşturup sonucu hedef dosyasına kaydeder. Bu işlev hem metin hem de ikil verilerle çalışabilir. Elde edilen yama daha sonra xdiff_file_bpatch() işleviyle uygulanabilir.

1.5.0 sürümünden itibaren, bu işlev xdiff_file_bdiff() işlevinin takma adıdır.

Değiştirgeler

eski_dosya

İlk dosyanın yolu. Eski dosya olarak ele alınır.

yeni_dosya

İkinci dosyanın yolu. Yeni dosya olarak ele alınır.

hedef

Elde edilen yamanın kaydedileceği dosyanın yolu. Dosya ikil bir dosya olacağından içeriği insanlarca okunabilir olmayacaktır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - xdiff_file_diff_binary() örneği

Aşağıda iki arşiv dosyasının ikil farkı alınmaktadır.

<?php
$old_version = 'my_script_1.0.tgz';
$new_version = 'my_script_1.1.tgz';

xdiff_file_diff_binary($old_version, $new_version, 'my_script.bdiff');
?>

Notlar

Bilginize:

Her iki dosya da belleğe yükleneceğinden memory_limit yönergenizde yeteri kadar bellek belirtmiş olmalısınız.

Ayrıca Bakınız

  • xdiff_file_bdiff() - İki dosyanın ikil farkını alır
  • xdiff_file_bpatch() - Bir dosyaya bir ikil yama uygular

xdiff_file_bpatch
xdiff_file_diff
xdiff İşlevleri


İki dosyanın tekil farkını alır

xdiff_file_diff_binary
xdiff_file_merge3
xdiff İşlevleri
PHP Manual

xdiff_file_diff

(PECL xdiff >= 0.2.0)

xdiff_file_diff — İki dosyanın tekil farkını alır

Açıklama

bool xdiff_file_diff ( string $eski_dosya , string $yeni_dosya , string $hedef [, int $bağlam = 3 [, bool $küçült = false ]] )

eski_dosya ile yeni_dosya arasındaki farklardan bir tekil fark dizgesi oluşturup sonucu hedef'e kaydeder. Elde edilen fark dizgesi insanlarca okunabilen bir dizgedir. İsteğe bağlı bağlam değiştirgesi ile her değişikliğin altında ve üstünde kaç bağlam satırının bulunacağı belirtilir. Seçimlik küçült değiştirgesinde TRUE atandığı takdirde mümkün olan en küçük yama dizgesi oluşturulmaya çalışılır (işlem biraz uzun sürebilir).

Değiştirgeler

eski_dosya

İlk dosyanın yolu. Eski dosya olarak ele alınır.

yeni_dosya

İkinci dosyanın yolu. Yeni dosya olarak ele alınır.

hedef

Elde edilen yamanın kaydedileceği dosyanın yolu.

bağlam

Her değişikliğin altında ve üstünde kaç bağlam satırının bulunacağı belirtilir.

küçült

TRUE atandığı takdirde mümkün olan en küçük yama dizgesi oluşturulmaya çalışılır (işlem biraz uzun sürebilir).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - xdiff_file_diff() örneği

Aşağıdaki kodda, iki PHP dosyasının iki bağlam satırlı tekil farkı alınmaktadır.

<?php
$old_version = 'my_script.php';
$new_version = 'my_new_script.php';

xdiff_file_diff($old_version, $new_version, 'my_script.diff', 2);
?>

Notlar

Bilginize:

Bu işlev ikil dosyalarla iyi çalışmaz. İkil fark dosyası elde etmek için xdiff_file_bdiff() veya xdiff_file_rabdiff() işlevini kullanın.

Ayrıca Bakınız

  • xdiff_file_patch() - Bir dosyaya bir tekil yama uygular

xdiff_file_diff_binary
xdiff_file_merge3
xdiff İşlevleri


Üç dosyayı tek dosya haline getirir

xdiff_file_diff
xdiff_file_patch_binary
xdiff İşlevleri
PHP Manual

xdiff_file_merge3

(PECL xdiff >= 0.2.0)

xdiff_file_merge3 — Üç dosyayı tek dosya haline getirir

Açıklama

mixed xdiff_file_merge3 ( string $eski_dosya , string $yeni_dosya1 , string $yeni_dosya2 , string $hedef )

Üç dosyayı tek bir dosya oluşturacak şekilde katıştırır ve sonucu bir dosyaya kaydeder. eski_dosya verinin özgün sürümü olup yeni_dosya1 ve yeni_dosya2 özgün sürümün değiştirilmiş iki sürümüdür.

Değiştirgeler

eski_dosya

İlk dosyanın yolu. Eski dosya olarak ele alınır.

yeni_dosya1

İkinci dosyanın yolu. eski_dosya'nın değiştirilmiş sürümü olarak ele alınır.

yeni_dosya2

Üçüncü dosyanın yolu. eski_dosya'nın değiştirilmiş sürümü olarak ele alınır.

hedef

Sonucun kaydedileceği dosyanın yolu.

Dönen Değerler

Dahili bir hata oluşmuşsa FALSE, katıştırma başarılıysa TRUE, reddedilen değişiklikler varsa reddedilen parçaları içeren bir dizge döner.

Örnekler

Örnek 1 - xdiff_file_merge3() örneği

Aşağıdaki kodda bir betiğin üç sürümü katıştırılıp tek bir betik elde edilmektedir.

<?php
$old_version = 'original_script.php';
$fix1 = 'script_with_fix1.php';
$fix2 = 'script_with_fix2.php';

$errors = xdiff_file_merge3($old_version, $fix1, $fix2, 'fixed_script.php');
if (is_string($errors)) {
    echo "Reddedilenler:\n";
    echo $errors;
}
?>

Ayrıca Bakınız

  • xdiff_string_merge3() - Üç dizgeyi tek bir dizge haline getirir

xdiff_file_diff
xdiff_file_patch_binary
xdiff İşlevleri


xdiff_file_bpatch işlevinin takma adıdır

xdiff_file_merge3
xdiff_file_patch
xdiff İşlevleri
PHP Manual

xdiff_file_patch_binary

(PECL xdiff >= 0.2.0)

xdiff_file_patch_binary — xdiff_file_bpatch() işlevinin takma adıdır

Açıklama

bool xdiff_file_patch_binary ( string $dosya , string $yama , string $hedef )

Belirtilen dosya'ya ikil yama'yı uygular ve sonucu hedef'e kaydeder. Bu işlev xdiff_file_bdiff() ve xdiff_file_rabdiff() işlevleriyle veya bunların dizgelerle çalışan eşdeğerleriyle üretilmiş yamaları kabul eder.

1.5.0 sürümünden itibaren, bu işlev xdiff_file_bpatch() işlevinin takma adıdır.

Değiştirgeler

dosya

Yamanın uygulanacağı dosyanın yolu.

yama

İkil yama dosyası.

hedef

Sonucun kaydedileceği dosyanın yolu.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - xdiff_file_patch_binary() örneği

Aşağıdaki kodda, bir dosya bir ikil fark dizgesiyle yamanmaktadır.

<?php
$eski_dosya = 'archive-1.0.tgz';
$yama = 'archive.bpatch';

$sonuç = xdiff_file_patch_binary($eski_dosya, $yama, 'archive-1.1.tgz');
if ($sonuç) {
   echo "Dosya yamandı";
} else {
   echo "Dosya yamanamadı";
}

?>

Notlar

Bilginize:

Her iki dosya da (dosya ve yama) belleğe yükleneceğinden memory_limit yönergenizde yeteri kadar bellek belirtmiş olmalısınız.

Ayrıca Bakınız

  • xdiff_string_patch_binary() - xdiff_string_bpatch işlevinin takma ismidir

xdiff_file_merge3
xdiff_file_patch
xdiff İşlevleri


Bir dosyaya bir tekil yama uygular

xdiff_file_patch_binary
xdiff_file_rabdiff
xdiff İşlevleri
PHP Manual

xdiff_file_patch

(PECL xdiff >= 0.2.0)

xdiff_file_patch — Bir dosyaya bir tekil yama uygular

Açıklama

mixed xdiff_file_patch ( string $dosya , string $yama , string $hedef [, int $seçenekler = DIFF_PATCH_NORMAL ] )

Belirtilen dosya'ya tekil yama'yı uygular ve sonucu hedef'e kaydeder. yama dizgesi xdiff_file_diff() veya xdiff_string_diff() ile üretilmiş tekil türde bir fark dizgesi olmalıdır. İsteğe bağlı seçenekler değiştirgesi ile işlem kipi belirtilebilir.

Değiştirgeler

dosya

Yamanın uygulanacağı dosyanın yolu.

yama

xdiff_string_diff() ve xdiff_file_diff() işlevleriyle veya uygun araçlarla üretilmiş tekil yama dizgesi.

hedef

Sonucun kaydedileceği dosyanın yolu..

seçenekler

XDIFF_PATCH_NORMAL (öntanımlı kip, normal yama) veya XDIFF_PATCH_REVERSE (tersinir yama) olabilir.

1.5.0 sürümünden itibaren XDIFF_PATCH_IGNORESPACE sabiti bit seviyesinde VEYAlanarak belirtilebilmektedir.

Dönen Değerler

Dahili bir hata oluşmuşsa FALSE, yama başarıyla uygulanmışsa TRUE, reddedilen değişiklikler varsa reddedilen parçaları içeren bir dizge döner.

Örnekler

Örnek 1 - xdiff_file_patch() örneği

Aşağıdaki kodda, bir dosya bir tekil fark dizgesiyle yamanmaktadır.

<?php
$eski_dosya = 'my_script-1.0.php';
$yama = 'my_script.patch';

$hatalar = xdiff_file_patch($eski_dosya, $yama, 'my_script-1.1.php');
if (is_string($hatalar)) {
   echo "Reddedilenler:\n";
   echo $hatalar;
}

?>

Örnek 2 - Yamayı geri alma örneği

Aşağıdaki kodda uygulanmış bir yama geri alınmaktadır.

<?php
$yeni_dosya = 'my_script-1.1.php';
$yama = 'my_script.patch';

$hatalar = xdiff_file_patch($yeni_dosya, $yama, 'my_script-1.0.php', XDIFF_PATCH_REVERSE);
if (is_string($hatalar)) {
   echo "Reddedilenler:\n";
   echo $hatalar;
}

?>

Ayrıca Bakınız

  • xdiff_file_diff() - İki dosyanın tekil farkını alır

xdiff_file_patch_binary
xdiff_file_rabdiff
xdiff İşlevleri


Rabin'in çok terimli parmakizi algoritmasını kullanarak iki dizgenin ikil olarak farkını alır

xdiff_file_patch
xdiff_string_bdiff_size
xdiff İşlevleri
PHP Manual

xdiff_file_rabdiff

(PECL xdiff >= 1.5.0)

xdiff_file_rabdiff — Rabin'in çok terimli parmakizi algoritmasını kullanarak iki dizgenin ikil olarak farkını alır

Açıklama

bool xdiff_file_rabdiff ( string $eski_dosya , string $yeni_dosya , string $hedef )

İki dosyanın ikil farkını alır ve sonucu bir dosyaya kaydeder. Bu işlevin xdiff_file_bdiff() işlevinden farkı, farklı algoritmalar kullanılması nedeniyle daha hızlı çalışması ve daha küçük fark üretmesidir. Bu işlev hem metin hem de ikil verilerle çalışabilir. Elde edilen yama daha sonra xdiff_string_bpatch() veya xdiff_file_bpatch() işleviyle uygulanabilir.

Algoritmalar arasındaki farklarla ilgili daha ayrıntılı bilgi edinmek için » libxdiff sitesine bakınız.

Değiştirgeler

eski_dosya

İlk ikil veri dosyası; eski dosya olarak ele alınır.

yeni_dosya

İkinci ikil veri dosyası; yeni dosya olarak ele alınır.

hedef

Elde edilen yama dosyasının dosya yolu. Elde edilen dosya ikil biçemde olup insanlarca okunamayacaktır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - xdiff_file_rabdiff() örneği

Aşağıdaki kodda iki arşivin ikil farkı alınmaktadır.

<?php
$old_version = 'my_script_1.0.tgz';
$new_version = 'my_script_1.1.tgz';

xdiff_file_rabdiff($old_version, $new_version, 'my_script.bdiff');
?>

Notlar

Bilginize:

Her iki dosya da belleğe yükleneceğinden memory_limit yönergenizde yeteri kadar bellek belirtmiş olmalısınız.

Ayrıca Bakınız

  • xdiff_file_bpatch() - Bir dosyaya bir ikil yama uygular

xdiff_file_patch
xdiff_string_bdiff_size
xdiff İşlevleri


Belirtilen ikil yama uygulanarak oluşturulacak dosyanın boyutunu döndürür

xdiff_file_rabdiff
xdiff_string_bdiff
xdiff İşlevleri
PHP Manual

xdiff_string_bdiff_size

(PECL xdiff >= 1.5.0)

xdiff_string_bdiff_size — Belirtilen ikil yama uygulanarak oluşturulacak dosyanın boyutunu döndürür

Açıklama

int xdiff_string_bdiff_size ( string $yama )

Belirtilen ikil yama dizgesini özgün dosyaya uyguladıktan sonra oluşacak yeni dosyanın boyutunu döndürür.

Değiştirgeler

yama

xdiff_string_bdiff() veya xdiff_string_rabdiff() tarafından oluşturulmuş bir ikil yama dizgesi.

Dönen Değerler

Oluşacak dosyanın boyutunu döndürür.

Örnekler

Örnek 1 - xdiff_string_bdiff_size() örneği

Aşağıdaki kodda, bir ikil yama uygulanarak oluşturulacak dosyanın boyutu döndürülmektedir.

<?php
$binary_patch = file_get_contents('file.bdiff');
$length = xdiff_string_bdiff_size($binary_patch);
echo "Elde edilen dosya $length bayt uzunluktadır";
?>

Ayrıca Bakınız

  • xdiff_string_bdiff() - İki dizgenin ikil farkını alır
  • xdiff_string_rabdiff() - Rabin'in çok terimli parmakizi algoritmasını kullanarak iki dizgenin ikil olarak farkını alır
  • xdiff_string_bpatch() - Bir dizgeyi bir ikil fark dizgesiyle yamar

xdiff_file_rabdiff
xdiff_string_bdiff
xdiff İşlevleri


İki dizgenin ikil farkını alır

xdiff_string_bdiff_size
xdiff_string_bpatch
xdiff İşlevleri
PHP Manual

xdiff_string_bdiff

(PECL xdiff >= 1.5.0)

xdiff_string_bdiff — İki dizgenin ikil farkını alır

Açıklama

string xdiff_string_bdiff ( string $eski_veri , string $yeni_veri )

eski_veri dizgesi ile yeni_veri dizgesi arasındaki farklardan bir ikil fark dizgesi oluşturup sonucu döndürür. Bu işlev hem metin hem de ikil verilerle çalışabilir. Elde edilen yama daha sonra xdiff_string_bpatch() veya xdiff_file_bpatch() işleviyle uygulanabilir.

Değiştirgeler

eski_veri

İlk veri dizgesi. Eski veri olarak ele alınır.

yeni_veri

İkinci veri dizgesi. Yeni veri olarak ele alınır.

Dönen Değerler

Bir hata oluşmuşsa FALSE yoksa elde edilen fark dizgesi döner.

Ayrıca Bakınız

  • xdiff_string_bpatch() - Bir dizgeyi bir ikil fark dizgesiyle yamar

xdiff_string_bdiff_size
xdiff_string_bpatch
xdiff İşlevleri


Bir dizgeyi bir ikil fark dizgesiyle yamar

xdiff_string_bdiff
xdiff_string_diff_binary
xdiff İşlevleri
PHP Manual

xdiff_string_bpatch

(PECL xdiff >= 1.5.0)

xdiff_string_bpatch — Bir dizgeyi bir ikil fark dizgesiyle yamar

Açıklama

string xdiff_string_bpatch ( string $dizge , string $yama )

Belirtilen dizge dizgesini ikil yama dizgesi ile yamar. Bu işlev xdiff_string_bdiff() ve xdiff_string_rabdiff() işlevleriyle veya bunların dosyalarla çalışan eşdeğerleriyle üretilmiş yamaları kabul eder.

Değiştirgeler

dizge

Yamanacak ikil dizge.

yama

İkil yama dizgesi.

Dönen Değerler

Bir hata oluşursa FALSE yoksa yamanmış dizgeyi döndürür.

Ayrıca Bakınız

  • xdiff_string_bdiff() - İki dizgenin ikil farkını alır
  • xdiff_string_rabdiff() - Rabin'in çok terimli parmakizi algoritmasını kullanarak iki dizgenin ikil olarak farkını alır

xdiff_string_bdiff
xdiff_string_diff_binary
xdiff İşlevleri


xdiff_string_bdiff işlevinin takma adıdır

xdiff_string_bpatch
xdiff_string_diff
xdiff İşlevleri
PHP Manual

xdiff_string_diff_binary

(PECL xdiff >= 0.2.0)

xdiff_string_diff_binary — xdiff_string_bdiff() işlevinin takma adıdır

Açıklama

string xdiff_string_bdiff ( string $eski_veri , string $yeni_veri )

eski_veri dizgesi ile yeni_veri dizgesi arasındaki farklardan bir ikil fark dizgesi oluşturup sonucu döndürür. Bu işlev hem metin hem de ikil verilerle çalışabilir. Elde edilen yama daha sonra xdiff_string_bpatch() veya xdiff_file_bpatch() işleviyle uygulanabilir.

1.5.0 sürümünden itibaren, bu işlev xdiff_string_bdiff() işlevinin takma adıdır.

Değiştirgeler

eski_veri

İlk veri dizgesi. Eski veri olarak ele alınır.

yeni_veri

İkinci veri dizgesi. Yeni veri olarak ele alınır.

Dönen Değerler

Bir hata oluşmuşsa FALSE yoksa elde edilen fark dizgesi döner.

Ayrıca Bakınız

  • xdiff_string_bdiff() - İki dizgenin ikil farkını alır
  • xdiff_string_bpatch() - Bir dizgeyi bir ikil fark dizgesiyle yamar

xdiff_string_bpatch
xdiff_string_diff
xdiff İşlevleri


İki dizgenin tekil farkını alır

xdiff_string_diff_binary
xdiff_string_merge3
xdiff İşlevleri
PHP Manual

xdiff_string_diff

(PECL xdiff >= 0.2.0)

xdiff_string_diff — İki dizgenin tekil farkını alır

Açıklama

string xdiff_string_diff ( string $eski_veri , string $yeni_veri [, int $bağlam = 3 [, bool $küçült = false ]] )

eski_veri dizgesi ile yeni_veri dizgesi arasındaki farklardan bir tekil fark dizgesi oluşturup sonucu döndürür. Elde edilen fark dizgesi insanlarca okunabilen bir dizgedir. İsteğe bağlı bağlam değiştirgesi ile her değişikliğin altında ve üstünde kaç bağlam satırının bulunacağı belirtilir. Seçimlik küçült değiştirgesinde TRUE atandığı takdirde mümkün olan en küçük yama dizgesi oluşturulmaya çalışılır (işlem biraz uzun sürebilir).

Değiştirgeler

eski_veri

İlk veri dizgesi. Eski veri olarak ele alınır.

yeni_veri

İkinci veri dizgesi. Yeni veri olarak ele alınır.

bağlam

Her değişikliğin altında ve üstünde kaç bağlam satırının bulunacağı belirtilir.

küçült

TRUE atandığı takdirde mümkün olan en küçük yama dizgesi oluşturulmaya çalışılır (işlem biraz uzun sürebilir).

Dönen Değerler

Bir hata oluşmuşsa FALSE yoksa elde edilen fark dizgesi döner.

Örnekler

Örnek 1 - xdiff_string_diff() örneği

Aşağıdaki kodda iki makaleden bir tekil fark dizgesi elde edilmektedir.

$eski_makale = file_get_contents('./old_article.txt');
/* Yeni makalenin HTML forma yapıştırıldığı varsayılıyor */
$yeni_makale =$_REQUEST['article'];

$yama = xdiff_string_diff($eski_makale, $yeni_makale, 1);
if (is_string($yama)) {
    echo "İki makale arasındaki farklar:\n";
    echo $yama;
}

?>

Notlar

Bilginize:

Bu işlev ikil dizgelerle iyi çalışmaz. İkil fark dizgesi elde etmek için xdiff_string_bdiff() veya xdiff_string_rabdiff() işlevini kullanın.

Ayrıca Bakınız

  • xdiff_string_patch() - Bir dizgeyi bir tekil fark dizgesi ile yamar

xdiff_string_diff_binary
xdiff_string_merge3
xdiff İşlevleri


Üç dizgeyi tek bir dizge haline getirir

xdiff_string_diff
xdiff_string_patch_binary
xdiff İşlevleri
PHP Manual

xdiff_string_merge3

(PECL xdiff >= 0.2.0)

xdiff_string_merge3 — Üç dizgeyi tek bir dizge haline getirir

Açıklama

mixed xdiff_string_merge3 ( string $eski_veri , string $yeni_veri1 , string $yeni_veri2 [, string &$hatalar ] )

Belirtilen üç dizgeyi karıştırıp tek bir dizge halinde döndürür. eski_veri verinin özgün sürümü olup yeni_veri1 ve yeni_veri2 özgün sürümün değiştirilmiş iki sürümüdür. Katıştırma işlemi sırasında reddedilen parçalar, belirtildiği takdirde hatalar değişkeninde saklanır.

Değiştirgeler

eski_veri

Özgün veri. Eski veri olarak ele alınır.

yeni_veri1

İkinci veri dizgesi. eski_veri dizgesinin değiştirilmiş sürümü olarak ele alınır.

yeni_veri2

Üçüncü veri dizgesi. eski_veri dizgesinin değiştirilmiş sürümü olarak ele alınır.

hatalar

Katıştırma işlemi sırasında reddedilen parçalar, belirtildiği takdirde bu değişkende saklanır.

Dönen Değerler

Dahili bir hata oluşmuşsa FALSE, elde edilen dizge boşsa TRUE yoksa elde edilen dizge döner.

Ayrıca Bakınız

  • xdiff_file_merge3() - Üç dosyayı tek dosya haline getirir

xdiff_string_diff
xdiff_string_patch_binary
xdiff İşlevleri


xdiff_string_bpatch işlevinin takma ismidir

xdiff_string_merge3
xdiff_string_patch
xdiff İşlevleri
PHP Manual

xdiff_string_patch_binary

(PECL xdiff >= 0.2.0)

xdiff_string_patch_binary — xdiff_string_bpatch() işlevinin takma ismidir

Açıklama

string xdiff_string_patch_binary ( string $dizge , string $yama )

Belirtilen dizge dizgesini ikil yama dizgesi ile yamar. Bu işlev xdiff_string_bdiff() ve xdiff_string_rabdiff() işlevleriyle veya bunların dosyalarla çalışan eşdeğerleriyle üretilmiş yamaları kabul eder.

1.5.0 sürümünden itibaren, bu işlev xdiff_string_bpatch() işlevinin takma adıdır.

Değiştirgeler

dizge

Yamanacak ikil dizge.

yama

İkil yama dizgesi.

Dönen Değerler

Bir hata oluşursa FALSE yoksa yamanmış dizgeyi döndürür.

Ayrıca Bakınız

  • xdiff_string_bpatch() - Bir dizgeyi bir ikil fark dizgesiyle yamar
  • xdiff_string_bdiff() - İki dizgenin ikil farkını alır
  • xdiff_string_rabdiff() - Rabin'in çok terimli parmakizi algoritmasını kullanarak iki dizgenin ikil olarak farkını alır

xdiff_string_merge3
xdiff_string_patch
xdiff İşlevleri


Bir dizgeyi bir tekil fark dizgesi ile yamar

xdiff_string_patch_binary
xdiff_string_rabdiff
xdiff İşlevleri
PHP Manual

xdiff_string_patch

(PECL xdiff >= 0.2.0)

xdiff_string_patch — Bir dizgeyi bir tekil fark dizgesi ile yamar

Açıklama

string xdiff_string_patch ( string $dizge , string $yama [, int $seçenekler [, string &$hata ]] )

Belirtilen tekil fark dizgesi yama ile dizge dizgesini yamar ve sonucu döndürür. yama dizgesi xdiff_file_diff() veya xdiff_string_diff() ile üretilmiş tekil türde bir fark dizgesi olmalıdır. İsteğe bağlı seçenekler değiştirgesi ile işlem kipi belirtilebilir. Reddedilen yama parçaları, belirtildiği takdirde hata değişkeninde döndürülür.

Değiştirgeler

dizge

Yamanacak dizge.

yama

xdiff_string_diff() ve xdiff_file_diff() işlevleriyle veya uygun araçlarla üretilmiş tekil yama dizgesi.

seçenekler

XDIFF_PATCH_NORMAL (öntanımlı kip, normal yama) veya XDIFF_PATCH_REVERSE (tersinir yama) olabilir.

1.5.0 sürümünden itibaren XDIFF_PATCH_IGNORESPACE sabiti bit seviyesinde VEYAlanarak belirtilebilmektedir.

hata

Sağlandığı takdirde, reddedilen yama parçaları bu değişkende döndürülür.

Dönen Değerler

Hata oluşursa FALSE yoksa yamanmış dizgeyi döndürür.

Örnekler

Örnek 1 - xdiff_string_patch() örneği

Aşağıdaki kodda bir makaleye değişiklikler uygulamaktadır.

<?php
$eski_makale = file_get_contents('./old_article.txt');
/* Yamanın HTML forma yapıştırıldığı varsayılıyor */
$fark = $_SERVER['yama'];

$hatalar = '';

$yeni_makale = xdiff_string_patch($eski_makale, $fark,
                  XDIFF_PATCH_NORMAL, $hatalar);
if (is_string($yeni_makale)) {
    echo "Yeni makale:\n";
    echo $yeni_makale;
}

if (strlen($hatalar)) {
    echo "Reddedilenler: \n";
    echo $hatalar;
}

?>

Ayrıca Bakınız

  • xdiff_string_diff() - İki dizgenin tekil farkını alır

xdiff_string_patch_binary
xdiff_string_rabdiff
xdiff İşlevleri


Rabin'in çok terimli parmakizi algoritmasını kullanarak iki dizgenin ikil olarak farkını alır

xdiff_string_patch
İnsan Dilleri ve Karakter Kodlaması Desteği
xdiff İşlevleri
PHP Manual

xdiff_string_rabdiff

(PECL xdiff >= 1.5.0)

xdiff_string_rabdiff — Rabin'in çok terimli parmakizi algoritmasını kullanarak iki dizgenin ikil olarak farkını alır

Açıklama

string xdiff_string_bdiff ( string $eski_veri , string $yeni_veri )

İki dizgenin ikil farkını alır ve sonucu döndürür. Bu işlevin xdiff_string_bdiff() işlevinden farkı, farklı algoritmalar kullanılması nedeniyle daha hızlı çalışması ve daha küçük fark üretilmesidir. Bu işlev hem metin hem de ikil verilerle çalışabilir. Elde edilen yama daha sonra xdiff_string_bpatch() veya xdiff_file_bpatch() işleviyle uygulanabilir.

Algoritmalar arasındaki farklarla ilgili daha ayrıntılı bilgi edinmek için » libxdiff sitesine bakınız.

Değiştirgeler

eski_veri

İlk ikil veri dizgesi; eski veri olarak ele alınır.

yeni_veri

İkinci ikil veri dizgesi; yeni veri olarak ele alınır.

Dönen Değerler

Bir hata oluşmuşsa FALSE aksi takdirde eski ve yeni veri arasındaki farkları içeren ikil bir dizge döner.

Ayrıca Bakınız

  • xdiff_string_bpatch() - Bir dizgeyi bir ikil fark dizgesiyle yamar

xdiff_string_patch
İnsan Dilleri ve Karakter Kodlaması Desteği
xdiff İşlevleri


İnsan Dilleri ve Karakter Kodlaması Desteği

  • Enchant — Enchant spelling library
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • Enchant İşlevleri
  • FriBiDi
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • FriBiDi İşlevleri
  • Gender — Determine gender of firstnames
    • Giriş
    • Yapılandırma/Kurulum
    • Örnekler
    • Gender\Gender — The Gender\Gender class
  • Gettext
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Gettext İşlevleri
  • iconv
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • iconv İşlevleri
  • intl — Uluslararasılaştırma İşlevleri
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • Collator — Collator sınıfı
    • NumberFormatter — NumberFormatter sınıfı
    • Locale — Locale sınıfı
    • Normalizer — Normalizer sınıfı
    • MessageFormatter — MessageFormatter sınıfı
    • IntlDateFormatter — IntlDateFormatter sınıfı
    • Grapheme İşlevleri
    • IDN İşlevleri
    • intl İşlevleri
  • Çok Baytlı Dizgeler
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Desteklenen kodlamaların özetleri
    • Japonca çok baytlı kodlamanın temelleri
    • HTTP Girdisi ve Çıktısı
    • Desteklenen Karakter Kodlamaları
    • İşlevlerin Aşırı Yüklenme Özelliği
    • PHP Karakter Kodlaması Gereksinimleri
    • Çok baytlı Dizge İşlevleri
  • Pspell
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Pspell İşlevleri
  • Recode — GNU Recode
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Recode İşlevleri
xdiff_string_rabdiff
Enchant
İşlev Başvuru Kılavuzu


Enchant spelling library

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
  • Enchant İşlevleri
    • enchant_broker_describe — Enumerates the Enchant providers
    • enchant_broker_dict_exists — Whether a dictionary exists or not. Using non-empty tag
    • enchant_broker_free_dict — Free a dictionary resource
    • enchant_broker_free — Free the broker resource and its dictionnaries
    • enchant_broker_get_dict_path — Get the directory path for a given backend
    • enchant_broker_get_error — Returns the last error of the broker
    • enchant_broker_init — create a new broker object capable of requesting
    • enchant_broker_list_dicts — Returns a list of available dictionaries
    • enchant_broker_request_dict — create a new dictionary using a tag
    • enchant_broker_request_pwl_dict — creates a dictionary using a PWL file
    • enchant_broker_set_dict_path — Set the directory path for a given backend
    • enchant_broker_set_ordering — Declares a preference of dictionaries to use for the language
    • enchant_dict_add_to_personal — add a word to personal word list
    • enchant_dict_add_to_session — add 'word' to this spell-checking session
    • enchant_dict_check — Check whether a word is correctly spelled or not
    • enchant_dict_describe — Describes an individual dictionary
    • enchant_dict_get_error — Returns the last error of the current spelling-session
    • enchant_dict_is_in_session — whether or not 'word' exists in this spelling-session
    • enchant_dict_quick_check — Check the word is correctly spelled and provide suggestions
    • enchant_dict_store_replacement — Add a correction for a word
    • enchant_dict_suggest — Will return a list of values if any of those pre-conditions are not met
İnsan Dilleri ve Karakter Kodlaması Desteği
Giriş
İnsan Dilleri ve Karakter Kodlaması Desteği


Giriş

Enchant is the PHP binding for the » Enchant library. Enchant steps in to provide uniformity and conformity on top of all spelling libraries, and implement certain features that may be lacking in any individual provider library. Everything should "just work" for any and every definition of "just working."

Enchant supports the following backends:

  • Aspell/Pspell (intends to replace Ispell)

  • Ispell (old as sin, could be interpreted as a defacto standard)

  • MySpell/Hunspell (an OOo projects, also used by Mozilla)

  • Uspell (primarily Yiddish, Hebrew, and Eastern European languages - hosted in AbiWord's CVS under the module "uspell")

  • Hspell (Hebrew)

  • AppleSpell (Mac OSX)

Enchant
Yapılandırma/Kurulum
Enchant


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Enchant


Gereksinimler

This version uses the functions of the » Enchant library by Dom Lachowicz. You need Enchant 1.2.4 or later.

Enchant also requires » Glib 2.6 or greater. Pre-compiled Windows libraries are available from » http://ftp.gnome.org/pub/gnome/binaries/win32/glib/.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

This extension is bundled with PHP as of PHP 5.3.0. Before this time, enchant was a PECL extension. Users of versions prior to 5.3.0 may use the » PECL extension.

Provided the required libraries are installed, users of PHP 5.3.0 or later may enable enchant by adding the --with-enchant[=dir] option when compiling PHP.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Özkaynak Türleri

There are two types of resources in this extension. The first one is the broker (backends manager) and the second is for the dictionary.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

ENCHANT_MYSPELL (integer)
Dictionary type for MySpell. Used with enchant_broker_get_dict_path() and enchant_broker_set_dict_path().
ENCHANT_ISPELL (integer)
Dictionary type for Ispell. Used with enchant_broker_get_dict_path() and enchant_broker_set_dict_path().

Özkaynak Türleri
Örnekler
Enchant


Örnekler

Örnek 1 Enchant Usage Example

<?php
$tag = 'en_US';
$r = enchant_broker_init();
$bprovides = enchant_broker_describe($r);
echo "Current broker provides the following backend(s):\n";
print_r($bprovides);

$dicts = enchant_broker_list_dicts($r);
print_r($dicts);
if (enchant_broker_dict_exists($r,$tag)) {
    $d = enchant_broker_request_dict($r, $tag);
    $dprovides = enchant_dict_describe($d);
    echo "dictionary $tag provides:\n";
    $wordcorrect = enchant_dict_check($d, "soong");
    print_r($dprovides);
    if (!$wordcorrect) {
        $suggs = enchant_dict_suggest($d, "soong");
        echo "Suggestions for 'soong':";
        print_r($suggs);
    }
    enchant_broker_free_dict($d);
} else {
}
enchant_broker_free($r);
?>
Öntanımlı Sabitler
Enchant İşlevleri
Enchant


Enchant İşlevleri

İçindekiler

  • enchant_broker_describe — Enumerates the Enchant providers
  • enchant_broker_dict_exists — Whether a dictionary exists or not. Using non-empty tag
  • enchant_broker_free_dict — Free a dictionary resource
  • enchant_broker_free — Free the broker resource and its dictionnaries
  • enchant_broker_get_dict_path — Get the directory path for a given backend
  • enchant_broker_get_error — Returns the last error of the broker
  • enchant_broker_init — create a new broker object capable of requesting
  • enchant_broker_list_dicts — Returns a list of available dictionaries
  • enchant_broker_request_dict — create a new dictionary using a tag
  • enchant_broker_request_pwl_dict — creates a dictionary using a PWL file
  • enchant_broker_set_dict_path — Set the directory path for a given backend
  • enchant_broker_set_ordering — Declares a preference of dictionaries to use for the language
  • enchant_dict_add_to_personal — add a word to personal word list
  • enchant_dict_add_to_session — add 'word' to this spell-checking session
  • enchant_dict_check — Check whether a word is correctly spelled or not
  • enchant_dict_describe — Describes an individual dictionary
  • enchant_dict_get_error — Returns the last error of the current spelling-session
  • enchant_dict_is_in_session — whether or not 'word' exists in this spelling-session
  • enchant_dict_quick_check — Check the word is correctly spelled and provide suggestions
  • enchant_dict_store_replacement — Add a correction for a word
  • enchant_dict_suggest — Will return a list of values if any of those pre-conditions are not met
Örnekler
enchant_broker_describe
Enchant


Enumerates the Enchant providers

Enchant İşlevleri
enchant_broker_dict_exists
Enchant İşlevleri
PHP Manual

enchant_broker_describe

(PHP 5 >= 5.3.0, PHP 7, PECL enchant >= 0.1.0)

enchant_broker_describe — Enumerates the Enchant providers

Açıklama

array enchant_broker_describe ( resource $broker )

Enumerates the Enchant providers and tells you some rudimentary information about them. The same info is provided through phpinfo().

Değiştirgeler

broker

Broker resource

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 List the backends provided by the given broker

<?php
$r = enchant_broker_init();
$bprovides = enchant_broker_describe($r);
echo "Current broker provides the following backend(s):\n";
print_r($bprovides);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Current broker provides the following backend(s):
Array
(
    [0] => Array
        (
            [name] => aspell
            [desc] => Aspell Provider
            [file] => /usr/lib/enchant/libenchant_aspell.so
        )

    [1] => Array
        (
            [name] => hspell
            [desc] => Hspell Provider
            [file] => /usr/lib/enchant/libenchant_hspell.so
        )

    [2] => Array
        (
            [name] => ispell
            [desc] => Ispell Provider
            [file] => /usr/lib/enchant/libenchant_ispell.so
        )

    [3] => Array
        (
            [name] => myspell
            [desc] => Myspell Provider
            [file] => /usr/lib/enchant/libenchant_myspell.so
        )

)

Enchant İşlevleri
enchant_broker_dict_exists
Enchant İşlevleri


Whether a dictionary exists or not. Using non-empty tag

enchant_broker_describe
enchant_broker_free_dict
Enchant İşlevleri
PHP Manual

enchant_broker_dict_exists

(PHP 5 >= 5.3.0, PHP 7, PECL enchant >= 0.1.0 )

enchant_broker_dict_exists — Whether a dictionary exists or not. Using non-empty tag

Açıklama

bool enchant_broker_dict_exists ( resource $broker , string $tag )

Tells if a dictionary exists or not, using a non-empty tags

Değiştirgeler

broker

Broker resource

tag

non-empty tag in the LOCALE format, ex: us_US, ch_DE, etc.

Dönen Değerler

Returns TRUE when the tag exist or FALSE when not.

Örnekler

Örnek 1 A enchant_broker_dict_exists() example

<?php
$tag = 'en_US';
$r = enchant_broker_init();
if (enchant_broker_dict_exists($r,$tag)) {
    echo $tag . " dictionary found.\n";
}
?>

Ayrıca Bakınız

  • enchant_broker_describe() - Enumerates the Enchant providers

enchant_broker_describe
enchant_broker_free_dict
Enchant İşlevleri


Free a dictionary resource

enchant_broker_dict_exists
enchant_broker_free
Enchant İşlevleri
PHP Manual

enchant_broker_free_dict

(PHP 5 >= 5.3.0, PHP 7, PECL enchant >= 0.1.0 )

enchant_broker_free_dict — Free a dictionary resource

Açıklama

bool enchant_broker_free_dict ( resource $dict )

Free a dictionary resource.

Değiştirgeler

dict

Dictionary resource.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • enchant_broker_request_dict() - create a new dictionary using a tag
  • enchant_broker_request_pwl_dict() - creates a dictionary using a PWL file

enchant_broker_dict_exists
enchant_broker_free
Enchant İşlevleri


Free the broker resource and its dictionnaries

enchant_broker_free_dict
enchant_broker_get_dict_path
Enchant İşlevleri
PHP Manual

enchant_broker_free

(PHP 5 >= 5.3.0, PHP 7, PECL enchant >= 0.1.0 )

enchant_broker_free — Free the broker resource and its dictionnaries

Açıklama

bool enchant_broker_free ( resource $broker )

Free a broker resource with all its dictionaries.

Değiştirgeler

broker

Broker resource

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • enchant_broker_init() - create a new broker object capable of requesting

enchant_broker_free_dict
enchant_broker_get_dict_path
Enchant İşlevleri


Get the directory path for a given backend

enchant_broker_free
enchant_broker_get_error
Enchant İşlevleri
PHP Manual

enchant_broker_get_dict_path

(PHP 5 >= 5.3.1, PHP 7, PECL enchant >= 1.0.1)

enchant_broker_get_dict_path — Get the directory path for a given backend

Açıklama

bool enchant_broker_get_dict_path ( resource $broker , int $dict_type )

Get the directory path for a given backend.

Değiştirgeler

broker

Broker resource.

dict_type

The type of the dictionaries, i.e. ENCHANT_MYSPELL or ENCHANT_ISPELL.

Dönen Değerler

Returns the path of the dictionary directory on success başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • enchant_broker_set_dict_path() - Set the directory path for a given backend

enchant_broker_free
enchant_broker_get_error
Enchant İşlevleri


Returns the last error of the broker

enchant_broker_get_dict_path
enchant_broker_init
Enchant İşlevleri
PHP Manual

enchant_broker_get_error

(PHP 5 >= 5.3.0, PHP 7, PECL enchant >= 0.1.0 )

enchant_broker_get_error — Returns the last error of the broker

Açıklama

string enchant_broker_get_error ( resource $broker )

Returns the last error which occurred in this broker.

Değiştirgeler

broker

Broker resource.

Dönen Değerler

Return the msg string if an error was found or FALSE

enchant_broker_get_dict_path
enchant_broker_init
Enchant İşlevleri


create a new broker object capable of requesting

enchant_broker_get_error
enchant_broker_list_dicts
Enchant İşlevleri
PHP Manual

enchant_broker_init

(PHP 5 >= 5.3.0, PHP 7, PECL enchant >= 0.1.0 )

enchant_broker_init — create a new broker object capable of requesting

Açıklama

resource enchant_broker_init ( void )

Değiştirgeler

Dönen Değerler

Returns a broker resource on success or FALSE.

Ayrıca Bakınız

  • enchant_broker_free() - Free the broker resource and its dictionnaries

enchant_broker_get_error
enchant_broker_list_dicts
Enchant İşlevleri


Returns a list of available dictionaries

enchant_broker_init
enchant_broker_request_dict
Enchant İşlevleri
PHP Manual

enchant_broker_list_dicts

(PHP 5 >= 5.3.0, PHP 7, PECL enchant >= 1.0.1)

enchant_broker_list_dicts — Returns a list of available dictionaries

Açıklama

mixed enchant_broker_list_dicts ( resource $broker )

Returns a list of available dictionaries with their details.

Değiştirgeler

broker

Broker resource

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 List all available dictionaries for one broker

<?php
$r = enchant_broker_init();
$dicts = enchant_broker_list_dicts($r);
print_r($dicts);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [0] => Array
        (
            [lang_tag] => de
            [provider_name] => aspell
            [provider_desc] => Aspell Provider
            [provider_file] => /usr/lib/enchant/libenchant_aspell.so
        )

    [1] => Array
        (
            [lang_tag] => de_DE
            [provider_name] => aspell
            [provider_desc] => Aspell Provider
            [provider_file] => /usr/lib/enchant/libenchant_aspell.so
        )

    [3] => Array
        (
            [lang_tag] => en
            [provider_name] => aspell
            [provider_desc] => Aspell Provider
            [provider_file] => /usr/lib/enchant/libenchant_aspell.so
        )

    [4] => Array
        (
            [lang_tag] => en_GB
            [provider_name] => aspell
            [provider_desc] => Aspell Provider
            [provider_file] => /usr/lib/enchant/libenchant_aspell.so
        )

    [5] => Array
        (
            [lang_tag] => en_US
            [provider_name] => aspell
            [provider_desc] => Aspell Provider
            [provider_file] => /usr/lib/enchant/libenchant_aspell.so
        )

    [6] => Array
        (
            [lang_tag] => hi_IN
            [provider_name] => myspell
            [provider_desc] => Myspell Provider
            [provider_file] => /usr/lib/enchant/libenchant_myspell.so
        )

)

Ayrıca Bakınız

  • enchant_broker_describe() - Enumerates the Enchant providers

enchant_broker_init
enchant_broker_request_dict
Enchant İşlevleri


create a new dictionary using a tag

enchant_broker_list_dicts
enchant_broker_request_pwl_dict
Enchant İşlevleri
PHP Manual

enchant_broker_request_dict

(PHP 5 >= 5.3.0, PHP 7, PECL enchant >= 0.1.0 )

enchant_broker_request_dict — create a new dictionary using a tag

Açıklama

resource enchant_broker_request_dict ( resource $broker , string $tag )

create a new dictionary using tag, the non-empty language tag you wish to request a dictionary for ("en_US", "de_DE", ...)

Değiştirgeler

broker

Broker resource

tag

A tag describing the locale, for example en_US, de_DE

Dönen Değerler

Returns a dictionary resource on success başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 A enchant_broker_request_dict() example

Check if a dictionary exists using enchant_broker_dict_exists() and request it.

<?php
$tag = 'en_US';
$broker = enchant_broker_init();
if (enchant_broker_dict_exists($broker,$tag)) {
    $dict = enchant_broker_request_dict($r, $tag);
}
?>

Ayrıca Bakınız

  • enchant_dict_describe() - Describes an individual dictionary
  • enchant_broker_dict_exists() - Whether a dictionary exists or not. Using non-empty tag
  • enchant_broker_free_dict() - Free a dictionary resource

enchant_broker_list_dicts
enchant_broker_request_pwl_dict
Enchant İşlevleri


creates a dictionary using a PWL file

enchant_broker_request_dict
enchant_broker_set_dict_path
Enchant İşlevleri
PHP Manual

enchant_broker_request_pwl_dict

(PHP 5 >= 5.3.0, PHP 7, PECL enchant >= 0.1.0 )

enchant_broker_request_pwl_dict — creates a dictionary using a PWL file

Açıklama

resource enchant_broker_request_pwl_dict ( resource $broker , string $filename )

Creates a dictionary using a PWL file. A PWL file is personal word file one word per line.

Değiştirgeler

broker

Broker resource

filename

Path to the PWL file. If there is no such file, a new one will be created if possible.

Dönen Değerler

Returns a dictionary resource on success başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • enchant_dict_describe() - Describes an individual dictionary
  • enchant_broker_dict_exists() - Whether a dictionary exists or not. Using non-empty tag
  • enchant_broker_free_dict() - Free a dictionary resource

enchant_broker_request_dict
enchant_broker_set_dict_path
Enchant İşlevleri


Set the directory path for a given backend

enchant_broker_request_pwl_dict
enchant_broker_set_ordering
Enchant İşlevleri
PHP Manual

enchant_broker_set_dict_path

(PHP 5 >= 5.3.1, PHP 7, PECL enchant >= 1.0.1)

enchant_broker_set_dict_path — Set the directory path for a given backend

Açıklama

bool enchant_broker_set_dict_path ( resource $broker , int $dict_type , string $value )

Set the directory path for a given backend.

Değiştirgeler

broker

Broker resource.

dict_type

The type of the dictionaries, i.e. ENCHANT_MYSPELL or ENCHANT_ISPELL.

value

The path of the dictionary directory.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • enchant_broker_get_dict_path() - Get the directory path for a given backend

enchant_broker_request_pwl_dict
enchant_broker_set_ordering
Enchant İşlevleri


Declares a preference of dictionaries to use for the language

enchant_broker_set_dict_path
enchant_dict_add_to_personal
Enchant İşlevleri
PHP Manual

enchant_broker_set_ordering

(PHP 5 >= 5.3.0, PHP 7, PECL enchant >= 0.1.0 )

enchant_broker_set_ordering — Declares a preference of dictionaries to use for the language

Açıklama

bool enchant_broker_set_ordering ( resource $broker , string $tag , string $ordering )

Declares a preference of dictionaries to use for the language described/referred to by 'tag'. The ordering is a comma delimited list of provider names. As a special exception, the "*" tag can be used as a language tag to declare a default ordering for any language that does not explicitly declare an ordering.

Değiştirgeler

broker

Broker resource

tag

Language tag. The special "*" tag can be used as a language tag to declare a default ordering for any language that does not explicitly declare an ordering.

ordering

Comma delimited list of provider names

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

enchant_broker_set_dict_path
enchant_dict_add_to_personal
Enchant İşlevleri


add a word to personal word list

enchant_broker_set_ordering
enchant_dict_add_to_session
Enchant İşlevleri
PHP Manual

enchant_dict_add_to_personal

(PHP 5 >= 5.3.0, PHP 7, PECL enchant >= 0.1.0 )

enchant_dict_add_to_personal — add a word to personal word list

Açıklama

void enchant_dict_add_to_personal ( resource $dict , string $word )

Add a word to personal word list of the given dictionary.

Değiştirgeler

dict

Dictionary resource

word

The word to add

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnek 1 Adding a word to a PWL

<?php

$filename = './my_word_list.pwl';
$word = 'Supercalifragilisticexpialidocious';

$broker = enchant_broker_init();
$dict = enchant_broker_request_pwl_dict($broker, $filename);

enchant_dict_add_to_personal($dict, $word);

enchant_broker_free($broker);

?>

Ayrıca Bakınız

  • enchant_broker_request_pwl_dict() - creates a dictionary using a PWL file
  • enchant_broker_request_dict() - create a new dictionary using a tag

enchant_broker_set_ordering
enchant_dict_add_to_session
Enchant İşlevleri


add 'word' to this spell-checking session

enchant_dict_add_to_personal
enchant_dict_check
Enchant İşlevleri
PHP Manual

enchant_dict_add_to_session

(PHP 5 >= 5.3.0, PHP 7, PECL enchant >= 0.1.0 )

enchant_dict_add_to_session — add 'word' to this spell-checking session

Açıklama

void enchant_dict_add_to_session ( resource $dict , string $word )

Add a word to the given dictionary. It will be added only for the active spell-checking session.

Değiştirgeler

dict

Dictionary resource

word

The word to add

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • enchant_broker_request_dict() - create a new dictionary using a tag

enchant_dict_add_to_personal
enchant_dict_check
Enchant İşlevleri


Check whether a word is correctly spelled or not

enchant_dict_add_to_session
enchant_dict_describe
Enchant İşlevleri
PHP Manual

enchant_dict_check

(PHP 5 >= 5.3.0, PHP 7, PECL enchant >= 0.1.0 )

enchant_dict_check — Check whether a word is correctly spelled or not

Açıklama

bool enchant_dict_check ( resource $dict , string $word )

If the word is correctly spelled return TRUE, otherwise return FALSE

Değiştirgeler

dict

Dictionary resource

word

The word to check

Dönen Değerler

Returns TRUE if the word is spelled correctly, FALSE if not.

enchant_dict_add_to_session
enchant_dict_describe
Enchant İşlevleri


Describes an individual dictionary

enchant_dict_check
enchant_dict_get_error
Enchant İşlevleri
PHP Manual

enchant_dict_describe

(PHP 5 >= 5.3.0, PHP 7, PECL enchant >= 0.1.0 )

enchant_dict_describe — Describes an individual dictionary

Açıklama

mixed enchant_dict_describe ( resource $dict )

Returns the details of the dictionary.

Değiştirgeler

dict

Dictionary resource

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 A enchant_dict_describe() example

Check if a dictionary exists using enchant_broker_dict_exists() and show the detail of it.

<?php
$tag = 'en_US';
$broker = enchant_broker_init();
if (enchant_broker_dict_exists($broker,$tag)) {
    $dict = enchant_broker_request_dict($r, $tag);
    $dict_details = enchant_dict_describe($dict);
    print_r($dict_details);
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [lang] => en_US
    [name] => aspell
    [desc] => Aspell Provider
    [file] => /usr/lib/enchant/libenchant_aspell.so
)

enchant_dict_check
enchant_dict_get_error
Enchant İşlevleri


Returns the last error of the current spelling-session

enchant_dict_describe
enchant_dict_is_in_session
Enchant İşlevleri
PHP Manual

enchant_dict_get_error

(PHP 5 >= 5.3.0, PHP 7, PECL enchant >= 0.1.0 )

enchant_dict_get_error — Returns the last error of the current spelling-session

Açıklama

string enchant_dict_get_error ( resource $dict )

Returns the last error of the current spelling-session

Değiştirgeler

dict

Dictinaray resource

Dönen Değerler

Returns the error message as string or FALSE if no error occurred.

enchant_dict_describe
enchant_dict_is_in_session
Enchant İşlevleri


whether or not 'word' exists in this spelling-session

enchant_dict_get_error
enchant_dict_quick_check
Enchant İşlevleri
PHP Manual

enchant_dict_is_in_session

(PHP 5 >= 5.3.0, PHP 7, PECL enchant >= 0.1.0 )

enchant_dict_is_in_session — whether or not 'word' exists in this spelling-session

Açıklama

bool enchant_dict_is_in_session ( resource $dict , string $word )

Tells whether or not a word already exists in the current session.

Değiştirgeler

dict

Dictionary resource

word

The word to lookup

Dönen Değerler

Returns TRUE if the word exists or FALSE

Ayrıca Bakınız

  • enchant_dict_add_to_session() - add 'word' to this spell-checking session

enchant_dict_get_error
enchant_dict_quick_check
Enchant İşlevleri


Check the word is correctly spelled and provide suggestions

enchant_dict_is_in_session
enchant_dict_store_replacement
Enchant İşlevleri
PHP Manual

enchant_dict_quick_check

(PHP 5 >= 5.3.0, PHP 7, PECL enchant:0.2.0-1.0.1)

enchant_dict_quick_check — Check the word is correctly spelled and provide suggestions

Açıklama

bool enchant_dict_quick_check ( resource $dict , string $word [, array &$suggestions ] )

If the word is correctly spelled return TRUE, otherwise return FALSE, if suggestions variable is provided, fill it with spelling alternatives.

Değiştirgeler

dict

Dictionary resource

word

The word to check

suggestions

If the word is not correctly spelled, this variable will contain an array of suggestions.

Dönen Değerler

Returns TRUE if the word is correctly spelled or FALSE

Örnekler

Örnek 1 A enchant_dict_quick_check() example

<?php
$tag = 'en_US';
$r = enchant_broker_init();

if (enchant_broker_dict_exists($r,$tag)) {
    $d = enchant_broker_request_dict($r, $tag);
    enchant_dict_quick_check($d, 'soong', $suggs);
    print_r($suggs);
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [0] => song
    [1] => snog
    [2] => soon
    [3] => Sang
    [4] => Sung
    [5] => sang
    [6] => sung
    [7] => sponge
    [8] => spongy
    [9] => snag
    [10] => snug
    [11] => sonic
    [12] => sing
    [13] => songs
    [14] => Son
    [15] => Sonja
    [16] => Synge
    [17] => son
    [18] => Sejong
    [19] => sarong
    [20] => sooner
    [21] => Sony
    [22] => sown
    [23] => scone
    [24] => song's
)

Ayrıca Bakınız

  • enchant_dict_check() - Check whether a word is correctly spelled or not
  • enchant_dict_suggest() - Will return a list of values if any of those pre-conditions are not met

enchant_dict_is_in_session
enchant_dict_store_replacement
Enchant İşlevleri


Add a correction for a word

enchant_dict_quick_check
enchant_dict_suggest
Enchant İşlevleri
PHP Manual

enchant_dict_store_replacement

(PHP 5 >= 5.3.0, PHP 7, PECL enchant >= 0.1.0 )

enchant_dict_store_replacement — Add a correction for a word

Açıklama

void enchant_dict_store_replacement ( resource $dict , string $mis , string $cor )

Add a correction for 'mis' using 'cor'. Notes that you replaced @mis with @cor, so it's possibly more likely that future occurrences of @mis will be replaced with @cor. So it might bump @cor up in the suggestion list.

Değiştirgeler

dict

Dictionary resource

mis

The work to fix

cor

The correct word

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

enchant_dict_quick_check
enchant_dict_suggest
Enchant İşlevleri


Will return a list of values if any of those pre-conditions are not met

enchant_dict_store_replacement
FriBiDi
Enchant İşlevleri
PHP Manual

enchant_dict_suggest

(PHP 5 >= 5.3.0, PHP 7, PECL enchant >= 0.1.0 )

enchant_dict_suggest — Will return a list of values if any of those pre-conditions are not met

Açıklama

array enchant_dict_suggest ( resource $dict , string $word )

Değiştirgeler

dict

Dictionary resource

word

Word to use for the suggestions.

Dönen Değerler

Will returns an array of suggestions if the word is bad spelled.

Örnekler

Örnek 1 A enchant_dict_suggest() example

<?php
$tag = 'en_US';
$r = enchant_broker_init();
if (enchant_broker_dict_exists($r,$tag)) {
    $d = enchant_broker_request_dict($r, $tag);

    $wordcorrect = enchant_dict_check($d, "soong");
    if (!$wordcorrect) {
        $suggs = enchant_dict_suggest($d, "soong");
        echo "Suggestions for 'soong':";
        print_r($suggs);
    }
    enchant_broker_free_dict($d);
}
enchant_broker_free($r);
?>

Ayrıca Bakınız

  • enchant_dict_check() - Check whether a word is correctly spelled or not
  • enchant_dict_quick_check() - Check the word is correctly spelled and provide suggestions

enchant_dict_store_replacement
FriBiDi
Enchant İşlevleri


FriBiDi

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • FriBiDi İşlevleri
    • fribidi_log2vis — Convert a logical string to a visual one
enchant_dict_suggest
Giriş
İnsan Dilleri ve Karakter Kodlaması Desteği


Giriş

FriBiDi is a free implementation of the » Unicode Bidirectional Algorithm.

FriBiDi
Yapılandırma/Kurulum
FriBiDi


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
FriBiDi


Gereksinimler

You must download and install the » FriBiDi package.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu » PECL eklentisi PHP ile gelmez. Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/fribidi.

In order to use these functions you must compile PHP with Fribidi support by using the --with-fribidi[=DIR] configure option.

Windows users will enable php_fribidi.dll inside of php.ini in order to use these functions. Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

FRIBIDI_CHARSET_UTF8 (integer)
Unicode
FRIBIDI_CHARSET_8859_6 (integer)
Arabic
FRIBIDI_CHARSET_8859_8 (integer)
Hebrew
FRIBIDI_CHARSET_CP1255 (integer)
Hebrew/Yiddish
FRIBIDI_CHARSET_CP1256 (integer)
Arabic
FRIBIDI_CHARSET_ISIRI_3342 (integer)
Persian
FRIBIDI_CHARSET_CAP_RTL (integer)
Used for test purposes, will treat CAPS as non-English letters
FRIBIDI_RTL (integer)
Right to left
FRIBIDI_LTR (integer)
Left to right
FRIBIDI_AUTO (integer)
Autodetect the base direction
Özkaynak Türleri
FriBiDi İşlevleri
FriBiDi


FriBiDi İşlevleri

İçindekiler

  • fribidi_log2vis — Convert a logical string to a visual one
Öntanımlı Sabitler
fribidi_log2vis
FriBiDi


Convert a logical string to a visual one

FriBiDi İşlevleri
Gender
FriBiDi İşlevleri
PHP Manual

fribidi_log2vis

(PHP 4 >= 4.0.4 and PHP 4 <= 4.1.0, PECL fribidi >= 1.0)

fribidi_log2vis — Convert a logical string to a visual one

Açıklama

string fribidi_log2vis ( string $str , string $direction , int $charset )

Converts a logical string to a visual one.

Değiştirgeler

str

The logical string.

direction

One of FRIBIDI_RTL, FRIBIDI_LTR or FRIBIDI_AUTO.

charset

One of the FRIBIDI_CHARSET_XXX constants.

Dönen Değerler

Returns the visual string on success başarısızlık durumunda FALSE döner.

FriBiDi İşlevleri
Gender
FriBiDi İşlevleri


Determine gender of firstnames

  • Giriş
  • Yapılandırma/Kurulum
    • Kurulum
  • Örnekler
    • Usage example.
  • Gender\Gender — The Gender\Gender class
    • Gender\Gender::connect — Connect to an external name dictionary.
    • Gender\Gender::__construct — Construct the Gender object.
    • Gender\Gender::country — Get textual country representation
    • Gender\Gender::get — Get gender of a name.
    • Gender\Gender::isNick — Check if the name0 is an alias of the name1.
    • Gender\Gender::similarNames — Get similar names.
fribidi_log2vis
Giriş
İnsan Dilleri ve Karakter Kodlaması Desteği


Giriş

Gender PHP extension is a port of the gender.c program originally written by Joerg Michael. The main purpose is to find out the gender of firstnames. The current database contains >40000 firstnames from 54 countries.

Gender
Yapılandırma/Kurulum
Gender


Yapılandırma/Kurulum

İçindekiler

  • Kurulum
Giriş
Kurulum
Gender


Kurulum

Bu » PECL eklentisi PHP ile gelmez.

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/gender.

A DLL for this PECL extension is available under » http://windows.php.net/downloads/pecl/releases/gender/.

Yapılandırma/Kurulum
Örnekler
Yapılandırma/Kurulum


Örnekler

İçindekiler

  • Usage example.
Kurulum
Usage example.
Gender


Usage example.

Gender class usage example.

Örnek 1 Usage example.

<?php

namespace Gender;

$gender = new Gender;

$name = "Milene";
$country = Gender::FRANCE;

$result = $gender->get($name, $country);

$data = $gender->country($country);

switch($result) {
    case Gender::IS_FEMALE:
        printf("The name %s is female in %s\n", $name, $data['country']);
    break;

    case Gender::IS_MOSTLY_FEMALE:
        printf("The name %s is mostly female in %s\n", $name, $data['country']);
    break;

    case Gender::IS_MALE:
        printf("The name %s is male in %s\n", $name, $data['country']);
    break;

    case Gender::IS_MOSTLY_MALE:
        printf("The name %s is mostly male in %s\n", $name, $data['country']);
    break;

    case Gender::IS_UNISEX_NAME:
        printf("The name %s is unisex in %s\n", $name, $data['country']);
    break;

    case Gender::IS_A_COUPLE:
        printf("The name %s is both male and female in %s\n", $name, $data['country']);
    break;

    case Gender::NAME_NOT_FOUND:
        printf("The name %s was not found for %s\n", $name, $data['country']);
    break;

    case Gender::ERROR_IN_NAME:
        echo "There is an error in the given name!\n";
    break;

    default:
        echo "An error occurred!\n";
    break;

}
Örnekler
Gender\Gender
Örnekler


The Gender\Gender class

(PECL gender >= 0.6.0)

Giriş

Sınıf Sözdizimi

Gender\Gender {
/* Constants */
const integer IS_FEMALE = 70 ;
const integer IS_MOSTLY_FEMALE = 102 ;
const integer IS_MALE = 77 ;
const integer IS_MOSTLY_MALE = 109 ;
const integer IS_UNISEX_NAME = 63 ;
const integer IS_A_COUPLE = 67 ;
const integer NAME_NOT_FOUND = 32 ;
const integer ERROR_IN_NAME = 69 ;
const integer ANY_COUNTRY = 0 ;
const integer BRITAIN = 1 ;
const integer IRELAND = 2 ;
const integer USA = 3 ;
const integer SPAIN = 4 ;
const integer PORTUGAL = 5 ;
const integer ITALY = 6 ;
const integer MALTA = 7 ;
const integer FRANCE = 8 ;
const integer BELGIUM = 9 ;
const integer LUXEMBOURG = 10 ;
const integer NETHERLANDS = 11 ;
const integer GERMANY = 12 ;
const integer EAST_FRISIA = 13 ;
const integer AUSTRIA = 14 ;
const integer SWISS = 15 ;
const integer ICELAND = 16 ;
const integer DENMARK = 17 ;
const integer NORWAY = 18 ;
const integer SWEDEN = 19 ;
const integer FINLAND = 20 ;
const integer ESTONIA = 21 ;
const integer LATVIA = 22 ;
const integer LITHUANIA = 23 ;
const integer POLAND = 24 ;
const integer CZECH_REP = 25 ;
const integer SLOVAKIA = 26 ;
const integer HUNGARY = 27 ;
const integer ROMANIA = 28 ;
const integer BULGARIA = 29 ;
const integer BOSNIA = 30 ;
const integer CROATIA = 31 ;
const integer KOSOVO = 32 ;
const integer MACEDONIA = 33 ;
const integer MONTENEGRO = 34 ;
const integer SERBIA = 35 ;
const integer SLOVENIA = 36 ;
const integer ALBANIA = 37 ;
const integer GREECE = 38 ;
const integer RUSSIA = 39 ;
const integer BELARUS = 40 ;
const integer MOLDOVA = 41 ;
const integer UKRAINE = 42 ;
const integer ARMENIA = 43 ;
const integer AZERBAIJAN = 44 ;
const integer GEORGIA = 45 ;
const integer KAZAKH_UZBEK = 46 ;
const integer TURKEY = 47 ;
const integer ARABIA = 48 ;
const integer ISRAEL = 49 ;
const integer CHINA = 50 ;
const integer INDIA = 51 ;
const integer JAPAN = 52 ;
const integer KOREA = 53 ;
/* Yöntemler */
public boolean connect ( string $dsn )
public __construct ([ string $dsn ] )
public array country ( integer $country )
public integer get ( string $name [, integer $country ] )
public array isNick ( string $name0 , string $name1 [, integer $country ] )
public array similarNames ( string $name [, integer $country ] )
}

Öntanımlı Sabitler

Gender\Gender::IS_FEMALE

Gender\Gender::IS_MOSTLY_FEMALE

Gender\Gender::IS_MALE

Gender\Gender::IS_MOSTLY_MALE

Gender\Gender::IS_UNISEX_NAME

Gender\Gender::IS_A_COUPLE

Gender\Gender::NAME_NOT_FOUND

Gender\Gender::ERROR_IN_NAME

Gender\Gender::ANY_COUNTRY

Gender\Gender::BRITAIN

Gender\Gender::IRELAND

Gender\Gender::USA

Gender\Gender::SPAIN

Gender\Gender::PORTUGAL

Gender\Gender::ITALY

Gender\Gender::MALTA

Gender\Gender::FRANCE

Gender\Gender::BELGIUM

Gender\Gender::LUXEMBOURG

Gender\Gender::NETHERLANDS

Gender\Gender::GERMANY

Gender\Gender::EAST_FRISIA

Gender\Gender::AUSTRIA

Gender\Gender::SWISS

Gender\Gender::ICELAND

Gender\Gender::DENMARK

Gender\Gender::NORWAY

Gender\Gender::SWEDEN

Gender\Gender::FINLAND

Gender\Gender::ESTONIA

Gender\Gender::LATVIA

Gender\Gender::LITHUANIA

Gender\Gender::POLAND

Gender\Gender::CZECH_REP

Gender\Gender::SLOVAKIA

Gender\Gender::HUNGARY

Gender\Gender::ROMANIA

Gender\Gender::BULGARIA

Gender\Gender::BOSNIA

Gender\Gender::CROATIA

Gender\Gender::KOSOVO

Gender\Gender::MACEDONIA

Gender\Gender::MONTENEGRO

Gender\Gender::SERBIA

Gender\Gender::SLOVENIA

Gender\Gender::ALBANIA

Gender\Gender::GREECE

Gender\Gender::RUSSIA

Gender\Gender::BELARUS

Gender\Gender::MOLDOVA

Gender\Gender::UKRAINE

Gender\Gender::ARMENIA

Gender\Gender::AZERBAIJAN

Gender\Gender::GEORGIA

Gender\Gender::KAZAKH_UZBEK

Gender\Gender::TURKEY

Gender\Gender::ARABIA

Gender\Gender::ISRAEL

Gender\Gender::CHINA

Gender\Gender::INDIA

Gender\Gender::JAPAN

Gender\Gender::KOREA

İçindekiler

  • Gender\Gender::connect — Connect to an external name dictionary.
  • Gender\Gender::__construct — Construct the Gender object.
  • Gender\Gender::country — Get textual country representation
  • Gender\Gender::get — Get gender of a name.
  • Gender\Gender::isNick — Check if the name0 is an alias of the name1.
  • Gender\Gender::similarNames — Get similar names.
Usage example.
Gender\Gender::connect
Gender


Connect to an external name dictionary.

Gender\Gender
Gender\Gender::__construct
Gender\Gender
PHP Manual

Gender\Gender::connect

(PECL gender >= 0.6.0)

Gender\Gender::connect — Connect to an external name dictionary.

Açıklama

public boolean Gender\Gender::connect ( string $dsn )

Connect to an external name dictionary. Currently only streams are supported.

Değiştirgeler

dsn

DSN to open.

Dönen Değerler

Boolean as success of failure.

Gender\Gender
Gender\Gender::__construct
Gender\Gender


Construct the Gender object.

Gender\Gender::connect
Gender\Gender::country
Gender\Gender
PHP Manual

Gender\Gender::__construct

(PECL gender >= 0.6.0)

Gender\Gender::__construct — Construct the Gender object.

Açıklama

public Gender\Gender::__construct ([ string $dsn ] )

Create a Gender object optionally connecting to an external name dictionary. When no external database was given, compiled in data will be used.

Değiştirgeler

dsn

DSN to open.

Dönen Değerler

Gender\Gender::connect
Gender\Gender::country
Gender\Gender


Get textual country representation

Gender\Gender::__construct
Gender\Gender::get
Gender\Gender
PHP Manual

Gender\Gender::country

(PECL gender >= 0.8.0)

Gender\Gender::country — Get textual country representation

Açıklama

public array Gender\Gender::country ( integer $country )

Returns the textual representation of a country from a Gender class constant.

Değiştirgeler

country

A country ID specified by a Gender\Gender class constant.

Dönen Değerler

Returns an array with the short and full names of the country on success başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Using Gender\Gender::country()

$gender = new Gender\Gender;
var_dump($gender->country(Gender\Gender::BRITAIN));

Yukarıdaki örneğin çıktısı:

array(2) {
  'country_short' =>
  string(2) "UK"
  'country' =>
  string(13) "Great Britain"
}

Gender\Gender::__construct
Gender\Gender::get
Gender\Gender


Get gender of a name.

Gender\Gender::country
Gender\Gender::isNick
Gender\Gender
PHP Manual

Gender\Gender::get

(PECL gender >= 0.6.0)

Gender\Gender::get — Get gender of a name.

Açıklama

public integer Gender\Gender::get ( string $name [, integer $country ] )

Get the gender of the name in a particular country.

Değiştirgeler

name

Name to check.

country

Country id identified by Gender class constant.

Dönen Değerler

Returns gender of the name.

Gender\Gender::country
Gender\Gender::isNick
Gender\Gender


Check if the name0 is an alias of the name1.

Gender\Gender::get
Gender\Gender::similarNames
Gender\Gender
PHP Manual

Gender\Gender::isNick

(PECL gender >= 0.9.0)

Gender\Gender::isNick — Check if the name0 is an alias of the name1.

Açıklama

public array Gender\Gender::isNick ( string $name0 , string $name1 [, integer $country ] )

Check whether the name0 is a nick of the name1.

Değiştirgeler

name0

Name to check.

name1

Name to check.

country

Country id identified by Gender class constant. If ommited ANY_COUNTRY is used.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Gender\Gender::get
Gender\Gender::similarNames
Gender\Gender


Get similar names.

Gender\Gender::isNick
Gettext
Gender\Gender
PHP Manual

Gender\Gender::similarNames

(PECL gender >= 0.9.0)

Gender\Gender::similarNames — Get similar names.

Açıklama

public array Gender\Gender::similarNames ( string $name [, integer $country ] )

Get similar names for the given name and country.

Değiştirgeler

name

Name to check.

country

Country id identified by Gender class constant. If ommited ANY_COUNTRY is used.

Dönen Değerler

Returns an array with the similar names found.

Gender\Gender::isNick
Gettext
Gender\Gender


Gettext

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Gettext İşlevleri
    • bind_textdomain_codeset — Belli bir uygulamanın iletileri için karakter kodlaması tanımlar
    • bindtextdomain — Uygulama adı için bir yol tanımlar
    • dcgettext — Belirtilen arama için geçerli uygulama adını değiştirir
    • dcngettext — dcgettext işlevinin çoğul biçemli sürümü
    • dgettext — Geçerli uygulama adını değiştirir
    • dngettext — dgettext işlevinin çoğul biçemli sürümü
    • gettext — Geçerli uygulama alanında bir iletiyi arar
    • ngettext — gettext işlevinin çoğul biçemli sürümü
    • textdomain — Öntanımlı uygulama adını tanımlar
Gender\Gender::similarNames
Giriş
İnsan Dilleri ve Karakter Kodlaması Desteği


Giriş

Gettext işlevleri PHP uygulamalarınızı uluslararasılaştırmak için kullanabileceğiniz NLS (Yerel Dil Desteği) arayüzünü gerçekler. Bu işlevlerin ayrıntılı açıklamaları için sisteminizdeki gettext belgelerine veya » http://www.gnu.org/software/gettext/manual/gettext.html adresine bakınız.

Gettext
Yapılandırma/Kurulum
Gettext


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Gettext


Gereksinimler

Bu işlevleri kullanabilmek için » http://www.gnu.org/software/gettext/gettext.html adresinden GNU gettext paketini indirip kurmanız gerekir.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

GNU gettext desteği için PHP paketini derlerken --with-gettext[=DiZiN] yapılandırma seçeneğini kullanmalısınız. Burada DiZiN, gettext'in kurulu olduğu dizin olup /usr/local öntanımlıdır.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
Gettext İşlevleri
Gettext


Gettext İşlevleri

İçindekiler

  • bind_textdomain_codeset — Belli bir uygulamanın iletileri için karakter kodlaması tanımlar
  • bindtextdomain — Uygulama adı için bir yol tanımlar
  • dcgettext — Belirtilen arama için geçerli uygulama adını değiştirir
  • dcngettext — dcgettext işlevinin çoğul biçemli sürümü
  • dgettext — Geçerli uygulama adını değiştirir
  • dngettext — dgettext işlevinin çoğul biçemli sürümü
  • gettext — Geçerli uygulama alanında bir iletiyi arar
  • ngettext — gettext işlevinin çoğul biçemli sürümü
  • textdomain — Öntanımlı uygulama adını tanımlar
Öntanımlı Sabitler
bind_textdomain_codeset
Gettext


Belli bir uygulamanın iletileri için karakter kodlaması tanımlar

Gettext İşlevleri
bindtextdomain
Gettext İşlevleri
PHP Manual

bind_textdomain_codeset

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

bind_textdomain_codeset — Belli bir uygulamanın iletileri için karakter kodlaması tanımlar

Açıklama

string bind_textdomain_codeset ( string $uygulama_adı , string $karküm )

bind_textdomain_codeset() işlevi, gettext() ve taydaşları tarafından belli bir uygulama_adı için döndürülen iletilerin hangi karakter kodlaması ile kodlanacağını belirler.

Değiştirgeler

uygulama_adı

Gettext iletileri için uygulama veya paket adı.

karküm

Karakter kümesi

Dönen Değerler

Başarılı olursa bir dizge ile döner.

Gettext İşlevleri
bindtextdomain
Gettext İşlevleri


Uygulama adı için bir yol tanımlar

bind_textdomain_codeset
dcgettext
Gettext İşlevleri
PHP Manual

bindtextdomain

(PHP 4, PHP 5, PHP 7)

bindtextdomain — Uygulama adı için bir yol tanımlar

Açıklama

string bindtextdomain ( string $uygulama_adı , string $dizin )

bindtextdomain() işleve bir uygulama için yol tanımlar.

Değiştirgeler

uygulama_adı

Gettext iletileri için uygulama veya paket adı.

dizin

Bir dizinin yolu.

Dönen Değerler

uygulama_adı için tanımlanan tam dizin yolu.

Örnekler

Örnek 1 - bindtextdomain() örneği

<?php

$domain = 'myapp';
echo bindtextdomain($domain, '/usr/share/myapp/locale');

?>

Yukarıdaki örneğin çıktısı:

/usr/share/myapp/locale

bind_textdomain_codeset
dcgettext
Gettext İşlevleri


Belirtilen arama için geçerli uygulama adını değiştirir

bindtextdomain
dcngettext
Gettext İşlevleri
PHP Manual

dcgettext

(PHP 4, PHP 5, PHP 7)

dcgettext — Belirtilen arama için geçerli uygulama adını değiştirir

Açıklama

string dcgettext ( string $uygulama_adı , string $ileti , int $yerel )

dcgettext() işlevi, belirtilen iletinin belli bir uygulama_adı altında aranabilmesini sağlar.

Değiştirgeler

uygulama_adı

Gettext iletileri için uygulama veya paket adı.

ileti

Özgün ileti.

yerel

Yerel kategorisi.

Dönen Değerler

Başarılı olursa bir dizge ile döner.

Ayrıca Bakınız

  • gettext() - Geçerli uygulama alanında bir iletiyi arar

bindtextdomain
dcngettext
Gettext İşlevleri


dcgettext işlevinin çoğul biçemli sürümü

dcgettext
dgettext
Gettext İşlevleri
PHP Manual

dcngettext

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

dcngettext — dcgettext işlevinin çoğul biçemli sürümü

Açıklama

string dcngettext ( string $uygulama_adı , string $msgid1 , string $msgid2 , int $n , int $yerel )

dcngettext() işlevi, belirtilen çoğul iletilerin belli bir uygulama_adı altında aranabilmesini sağlar.

Değiştirgeler

uygulama_adı

Gettext iletileri için uygulama veya paket adı.

msgid1

msgid2

n

yerel

Dönen Değerler

Başarılı olursa bir dizge ile döner.

Ayrıca Bakınız

  • ngettext() - gettext işlevinin çoğul biçemli sürümü

dcgettext
dgettext
Gettext İşlevleri


Geçerli uygulama adını değiştirir

dcngettext
dngettext
Gettext İşlevleri
PHP Manual

dgettext

(PHP 4, PHP 5, PHP 7)

dgettext — Geçerli uygulama adını değiştirir

Açıklama

string dgettext ( string $uygulama_adı , string $ileti )

dgettext() işlevi, belirtilen iletinin belli bir uygulama_adı altında aranabilmesini sağlar.

Değiştirgeler

uygulama_adı

Gettext iletileri için uygulama veya paket adı.

ileti

Özgün ileti.

Dönen Değerler

Başarılı olursa bir dizge ile döner.

Ayrıca Bakınız

  • gettext() - Geçerli uygulama alanında bir iletiyi arar

dcngettext
dngettext
Gettext İşlevleri


dgettext işlevinin çoğul biçemli sürümü

dgettext
gettext
Gettext İşlevleri
PHP Manual

dngettext

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

dngettext — dgettext işlevinin çoğul biçemli sürümü

Açıklama

string dngettext ( string $uygulama_adı , string $msgid1 , string $msgid2 , int $n )

dngettext()işlevi, belirtilen çoğul biçemli iletilerin belli bir uygulama_adı altında aranabilmesini sağlar.

Değiştirgeler

uygulama_adı

Gettext iletileri için uygulama veya paket adı.

msgid1

msgid2

n

Dönen Değerler

Başarılı olursa bir dizge döndürür.

Ayrıca Bakınız

  • ngettext() - gettext işlevinin çoğul biçemli sürümü

dgettext
gettext
Gettext İşlevleri


Geçerli uygulama alanında bir iletiyi arar

dngettext
ngettext
Gettext İşlevleri
PHP Manual

gettext

(PHP 4, PHP 5, PHP 7)

gettext — Geçerli uygulama alanında bir iletiyi arar

Açıklama

string gettext ( string $ileti )

Geçerli uygulama alanında bir iletiyi arar.

Değiştirgeler

ileti

Çevrilecek ileti.

Dönen Değerler

Çevrilmişse çevrilmiş iletiyle, çevrilmemişse belirtilen iletiyle döner.

Örnekler

Örnek 1 - gettext() örneği

<?php
// Dili Türkçe yapalım
setlocale(LC_ALL, 'tr_TR');

// Çevirilerin bulunduğu yeri belirtelim
bindtextdomain("myPHPApp", "./locale");

// Uygulama adını belirtelim
textdomain("myPHPApp");

// Böylece çevirilerin aranacağı yer
// ./locale/tr_TR/LC_MESSAGES/myPHPApp.mo olarak belirlendi.

// Bir ileti basalım
echo gettext("Welcome to My PHP Application");

// gettext() için rumuz olarak _() kullanalım
echo _("Have a nice day");
?>

Notlar

Bilginize:

Bu işlev için takma ad olarak altçizgi imini ('_') kullanabilirsiniz.

Ayrıca Bakınız

  • setlocale() - Yereli ayarlar

dngettext
ngettext
Gettext İşlevleri


gettext işlevinin çoğul biçemli sürümü

gettext
textdomain
Gettext İşlevleri
PHP Manual

ngettext

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

ngettext — gettext işlevinin çoğul biçemli sürümü

Açıklama

string ngettext ( string $msgid1 , string $msgid2 , int $n )

gettext() işlevinin çoğul biçemli sürümüdür. Bazı dillerde çoğul biçemli iletiler için birden fazla ileti gerekebilir.

Değiştirgeler

msgid1

msgid2

n

Dönen Değerler

n sayısı için msgid1 ve msgid2 ile betimlenen doğru çoğul biçemli iletiyi döndürür.

Örnekler

Örnek 1 ngettext() örneği

<?php

setlocale(LC_ALL, 'cs_CZ');
printf(ngettext("%d window", "%d windows", 1), 1); // 1 okno
printf(ngettext("%d window", "%d windows", 2), 2); // 2 okna
printf(ngettext("%d window", "%d windows", 5), 5); // 5 oken

?>

gettext
textdomain
Gettext İşlevleri


Öntanımlı uygulama adını tanımlar

ngettext
iconv
Gettext İşlevleri
PHP Manual

textdomain

(PHP 4, PHP 5, PHP 7)

textdomain — Öntanımlı uygulama adını tanımlar

Açıklama

string textdomain ( string $uygulama_adı )

gettext() çağrılarının yapıldığı arama bölgesini tanımlar. Bu arama bölgesine genellikle uygulamanın adı verilir.

Değiştirgeler

uygulama_adı

İletilerin ait olduğu uygulamanın adı; mevcut ayarların aynen kullanılması için NULL da belirtilebilir.

Dönen Değerler

Başarılı olduğu takdirde (muhtemelen değiştirdiği) uygulama veya paket ismiyle döner.

ngettext
iconv
Gettext İşlevleri


iconv

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • iconv İşlevleri
    • iconv_get_encoding — iconv eklentisinin dahili yapılandırma değişkenlerini döndürür
    • iconv_mime_decode_headers — Bir defada birden fazla MIME başlık alanını çözümler
    • iconv_mime_decode — Bir MIME başlık alanının kodunu çözer
    • iconv_mime_encode — Bir MIME başlık alanı tertipler
    • iconv_set_encoding — Karakter kodlaması dönüşümü için geçerli karakter kümesini tanımlar
    • iconv_strlen — Dizgenin karakter sayısı ile döner
    • iconv_strpos — Samanlıktakı ilk iğneyi bulur
    • iconv_strrpos — Samanlıktakı son iğneyi bulur
    • iconv_substr — Bir dizgenin bir alt dizgesini döndürür
    • iconv — Dizgenin karakter kodlamasını dönüştürür
    • ob_iconv_handler — Çıktı tamponu eylemcisi olarak karakter kodlaması dönüşümü yapar
textdomain
Giriş
İnsan Dilleri ve Karakter Kodlaması Desteği


Giriş

Bu modül, iconv karakter kümesi dönüştürme oluşumu için bir arayüz içerir. Bu modülle, bir dizgenin karakter kodlamasını yerel kodlamadan herhangi bir başka bir kodlamaya dönüştürebilirsiniz. Desteklenen karakter kümeleri sisteminizde kurulu iconv gerçeklenimine bağlıdır. iconv işlevinin bazı sistemlerde beklendiği gibi çalışmayabileceğine dikkat ediniz. Böyle bir durumda, daha uygun sonuçlar üreteceğinden » GNU libiconv kütüphanesinin kurulması önerilir.

PHP 5.0.0'dan beri bu eklenti çok dilli betikleri yazmanızı kolaylaştıracak çeşitli işlevler içermektedir. Yeni özellikleri keşfetmek için bundan sonraki bölümlere bakınız.

iconv
Yapılandırma/Kurulum
iconv


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
iconv


Gereksinimler

Günümüz POSIX-uyumlu sistemlerinden birini kullanıyorsanız standart C kütüphaneleri iconv oluşumlarını içerdiğinden bu özelliği elde etmek için hiçbir şey yapmanız gerekmez. Aksi takdirde, sisteminize » libiconv kütüphanesini kurmanız gerekir.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu modülle sağlanan işlevleri kullanabilmek için PHP'nin --with-iconv[=DiZiN] yapılandırma seçeneği ile derlenmesi gerekir.

Bilginize: Windows® Kullanıcılarının Dikkatine
Bu modülü Windows® ortamında kullanabilmek için PHP/Win32 çalıştırılabilir paketi ile dağıtılan iconv.dll veya iconv-1.3.dll (4.2.1 öncesi) dosyasının yolunun PATH ortam değişkeninde belirtilmiş olması veya dosyanın Windows\System dizininde olması gerekir. Bu modül PHP 5'ten itibaren PHP'nin bir parçası olduğundan iconv.dll ve php_iconv.dll artık gerekmemektedir.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Iconv Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
iconv.input_encoding | "ISO-8859-1" | PHP_INI_ALL | PHP 4.0.5'ten beri kullanılabilmektedir.
iconv.output_encoding | "ISO-8859-1" | PHP_INI_ALL | PHP 4.0.5'ten beri kullanılabilmektedir.
iconv.internal_encoding | "ISO-8859-1" | PHP_INI_ALL | PHP 4.0.5'ten beri kullanılabilmektedir.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

Uyarı

Bazı sistemler (IBM AIX gibi) "ISO-8859-1" yerine "ISO8859-1" kullanırlar. Dolayısıyla yapılandırma seçeneklerinde ve işlev değiştirgelerinde bu değerin kullanılması gerekir.

iconv.input_encoding string

Şu an bu seçenek kullanılmamaktadır.

iconv.output_encoding string

iconv.internal_encoding string

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

PHP 4.3.0'dan beri hangi iconv gerçekleniminin bu eklentiye uygun olduğunu çalışma anında tanımlamak mümkündür.

iconv sabitleri
İsim | Tür | Açıklama
ICONV_IMPL | string | Gerçeklenimin ismi.
ICONV_VERSION | string | Gerçeklenimin sürümü.

Bilginize:

Bu sabitleri kullanarak gerçeklenim bağımlısı betikler yazmanız kesinlikle önerilmez.

PHP 5.0.0'dan beri,aşağıdaki sabitler kullanılabilmektedir:

PHP 5.0.0'dan beri kullanılabilen iconv sabitleri
İsim | Tür | Açıklama
ICONV_MIME_DECODE_STRICT | integer | iconv_mime_decode() için kullanılan bir bit maskesi
ICONV_MIME_DECODE_CONTINUE_ON_ERROR | integer | iconv_mime_decode() için kullanılan bir bit maskesi

Özkaynak Türleri
iconv İşlevleri
iconv


iconv İşlevleri

Ayrıca Bakınız

GNU Recode işlevleri.

İçindekiler

  • iconv_get_encoding — iconv eklentisinin dahili yapılandırma değişkenlerini döndürür
  • iconv_mime_decode_headers — Bir defada birden fazla MIME başlık alanını çözümler
  • iconv_mime_decode — Bir MIME başlık alanının kodunu çözer
  • iconv_mime_encode — Bir MIME başlık alanı tertipler
  • iconv_set_encoding — Karakter kodlaması dönüşümü için geçerli karakter kümesini tanımlar
  • iconv_strlen — Dizgenin karakter sayısı ile döner
  • iconv_strpos — Samanlıktakı ilk iğneyi bulur
  • iconv_strrpos — Samanlıktakı son iğneyi bulur
  • iconv_substr — Bir dizgenin bir alt dizgesini döndürür
  • iconv — Dizgenin karakter kodlamasını dönüştürür
  • ob_iconv_handler — Çıktı tamponu eylemcisi olarak karakter kodlaması dönüşümü yapar
Öntanımlı Sabitler
iconv_get_encoding
iconv


iconv eklentisinin dahili yapılandırma değişkenlerini döndürür

iconv İşlevleri
iconv_mime_decode_headers
iconv İşlevleri
PHP Manual

iconv_get_encoding

(PHP 4 >= 4.0.5, PHP 5, PHP 7)

iconv_get_encoding — iconv eklentisinin dahili yapılandırma değişkenlerini döndürür

Açıklama

mixed iconv_get_encoding ([ string $tür = "all" ] )

iconv eklentisinin dahili yapılandırma değişkenlerini döndürür.

Değiştirgeler

tür

İsteğe bağlı type değiştirgesi ile şunlardan biri belirtilebilir:

  • Hepsi için all
  • Girdi karakter kodlaması için input_encoding
  • Çıktı karakter kodlaması için output_encoding
  • Dahili karakter kodlaması için internal_encoding

Dönen Değerler

Başarısızlık durumunda FALSE aksi takdirde dahili yapılandırma değişkeninin değeri döner.

Eğer tür belirtilmezse veya "all" belirtilirse, iconv_get_encoding() bu değişkenleri içeren bir dizi ile döner.

Örnekler

Örnek 1 - iconv_get_encoding() örneği

<pre>
<?php
iconv_set_encoding("internal_encoding", "UTF-8");
iconv_set_encoding("output_encoding", "ISO-8859-1");
var_dump(iconv_get_encoding('all'));
?>
</pre>

Yukarıdaki örneğin çıktısı:

Array
(
    [input_encoding] => ISO-8859-1
    [output_encoding] => ISO-8859-1
    [internal_encoding] => UTF-8
)

Ayrıca Bakınız

  • iconv_set_encoding() - Karakter kodlaması dönüşümü için geçerli karakter kümesini tanımlar
  • ob_iconv_handler() - Çıktı tamponu eylemcisi olarak karakter kodlaması dönüşümü yapar

iconv İşlevleri
iconv_mime_decode_headers
iconv İşlevleri


Bir defada birden fazla MIME başlık alanını çözümler

iconv_get_encoding
iconv_mime_decode
iconv İşlevleri
PHP Manual

iconv_mime_decode_headers

(PHP 5, PHP 7)

iconv_mime_decode_headers — Bir defada birden fazla MIME başlık alanını çözümler

Açıklama

array iconv_mime_decode_headers ( string $kodlanmış_başlıklar [, int $kip = 0 [, string $karküm = ini_set("iconv.internal_encoding") ]] )

Çok sayıda MIME başlık alanını bir kerede çözümler.

Değiştirgeler

kodlanmış_başlıklar

Bir dizge olarak kodlanmış başlıklar.

kip

kip değiştirgesi, işlev bozuk bir MIME başlık alanı saptadığı takdirde işlevin davranışını belirler. Aşağıdaki değerleri bir bit maskesi olarak belirtebilirsiniz:

iconv_mime_decode_headers() tarafından desteklenen bit maskeleri
Değer | Sabit | Açıklama
1 | ICONV_MIME_DECODE_STRICT | Belirtilirse, başlık, » RFC2047'de tanımlanan standartlarla tam uyumlu kodlanır. Bu seçenek öntanımlı olarak kapalıdır, çünkü belirtime uymayan ve doğru MIME başlıkları üretmeyen pek çok kullanıcı eposta istemcisi var.
2 | ICONV_MIME_DECODE_CONTINUE_ON_ERROR | Belirtilirse, iconv_mime_decode_headers() işlevi yazım hatalarını yoksayıp belirtilen başlığı işlemeye devam etmeye çalışır.

karküm

İsteğe bağlı karküm değiştirgesi elde edilecek dizgenin karakter kümesini belirler. Belirtilmezse, dizgenin karakter kodlamasının iconv.internal_encoding yönergesinde belirtilen kodlama olacağı varsayılır.

Dönen Değerler

kodlanmış_başlıklar dizgesi ile belirtilen kodlanmış MIME başlık alanlarını çözümleyip sonucu bir ilişkisel dizi olarak döndürür. Bu işlem sırasında bir hata oluşursa FALSE döner.

Dönen dizideki her anahtar bir başlık alanına, her değer de anahtarla ilgili bir başlık değerine karşılıktır. Aynı isimde birden fazla alan varsa işlev bunları özdevinimli olarak göründükleri sırayla sayısal indisli bir diziye yerleştirir.

Örnekler

Örnek 1 - iconv_mime_decode_headers() örneği

<?php
$headers_string = <<<EOF
Subject: =?UTF-8?B?UHLDvGZ1bmcgUHLDvGZ1bmc=?=
To: example@example.com
Date: Thu, 1 Jan 1970 00:00:00 +0000
Message-Id: <example@example.com>
Received: from localhost (localhost [127.0.0.1]) by localhost
    with SMTP id example for <example@example.com>;
    Thu, 1 Jan 1970 00:00:00 +0000 (UTC)
    (envelope-from example-return-0000-example=example.com@example.com)
Received: (qmail 0 invoked by uid 65534); 1 Thu 2003 00:00:00 +0000

EOF;

$headers =  iconv_mime_decode_headers($headers_string, 0, "ISO-8859-1");
print_r($headers);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [Subject] => Prüfung Prüfung
    [To] => example@example.com
    [Date] => Thu, 1 Jan 1970 00:00:00 +0000
    [Message-Id] => <example@example.com>
    [Received] => Array
        (
            [0] => from localhost (localhost [127.0.0.1]) by localhost with SMTP id example for <example@example.com>; Thu, 1 Jan 1970 00:00:00 +0000 (UTC) (envelope-from example-return-0000-example=example.com@example.com)
            [1] => (qmail 0 invoked by uid 65534); 1 Thu 2003 00:00:00 +0000
        )

)

Ayrıca Bakınız

  • iconv_mime_decode() - Bir MIME başlık alanının kodunu çözer
  • mb_decode_mimeheader() - MIME başlık alanındaki dizgeyi dönüştürür
  • imap_mime_header_decode() - MIME başlık elemanlarının kodlamasını açar
  • imap_base64() - Base64 kodlu dizgeyi 8 bitlik dizgeye dönüştürür
  • imap_qprint() - Bir 7 bitlik dizgeyi 8 bitlik dizgeye dönüştürür

iconv_get_encoding
iconv_mime_decode
iconv İşlevleri


Bir MIME başlık alanının kodunu çözer

iconv_mime_decode_headers
iconv_mime_encode
iconv İşlevleri
PHP Manual

iconv_mime_decode

(PHP 5, PHP 7)

iconv_mime_decode — Bir MIME başlık alanının kodunu çözer

Açıklama

string iconv_mime_decode ( string $kodlanmış_başlık [, int $kip = 0 [, string $karküm = ini_set("iconv.internal_encoding") ]] )

Bir MIME başlık alanının kodunu çözer.

Değiştirgeler

kodlanmış_başlık

Bir dizge olarak kodlanmış başlık.

kip

kip değiştirgesi, işlev bozuk bir MIME başlık alanı saptadığı takdirde işlevin davranışını belirler. Aşağıdaki değerleri bir bit maskesi olarak belirtebilirsiniz:

iconv_mime_decode() tarafından desteklenen bit maskeleri
Değer | Sabit | Açıklama
1 | ICONV_MIME_DECODE_STRICT | Belirtilirse, başlık, » RFC2047'de tanımlanan standartlarla tam uyumlu kodlanır. Bu seçenek öntanımlı olarak kapalıdır, çünkü belirtime uymayan ve doğru MIME başlıkları üretmeyen pek çok kullanıcı eposta istemcisi var.
2 | ICONV_MIME_DECODE_CONTINUE_ON_ERROR | Belirtilirse, iconv_mime_decode_headers() işlevi yazım hatalarını yoksayıp belirtilen başlığı işlemeye devam etmeye çalışır.

karküm

İsteğe bağlı karküm değiştirgesi elde edilecek dizgenin karakter kümesini belirler. Belirtilmezse, dizgenin karakter kodlamasının iconv.internal_encoding yönergesinde belirtilen kodlama olacağı varsayılır.

Dönen Değerler

Başarı durumunda kodu çözülmüş MIME alanı, aksi takdirde FALSE döner.

Örnekler

Örnek 1 - iconv_mime_decode() örneği

<?php
// Sonuç: "Subject: Prüfung Prüfung"
echo iconv_mime_decode("Subject: =?UTF-8?B?UHLDvGZ1bmcgUHLDvGZ1bmc=?=",
                       0, "ISO-8859-1");
?>

Ayrıca Bakınız

  • iconv_mime_decode_headers() - Bir defada birden fazla MIME başlık alanını çözümler
  • mb_decode_mimeheader() - MIME başlık alanındaki dizgeyi dönüştürür
  • imap_mime_header_decode() - MIME başlık elemanlarının kodlamasını açar
  • imap_base64() - Base64 kodlu dizgeyi 8 bitlik dizgeye dönüştürür
  • imap_qprint() - Bir 7 bitlik dizgeyi 8 bitlik dizgeye dönüştürür

iconv_mime_decode_headers
iconv_mime_encode
iconv İşlevleri


Bir MIME başlık alanı tertipler

iconv_mime_decode
iconv_set_encoding
iconv İşlevleri
PHP Manual

iconv_mime_encode

(PHP 5, PHP 7)

iconv_mime_encode — Bir MIME başlık alanı tertipler

Açıklama

string iconv_mime_encode ( string $alan_adı , string $alan_değeri [, array $tercihler = NULL ] )

Örnekteki gibi, geçerli bir MIME başlık alanını bir dizge olarak tertipleyip döndürür:

Subject: Re: PHP =?utf-8?q?=C3=87eviri?= Grubu
Bu örnekte, "Subject" alan ismi, "Re: PHP =?utf-8?..." ise alanın değeridir.

Değiştirgeler

alan_adı

Alan ismi.

alan_değeri

Alanın değeri.

tercihler

İsteğe bağlı tercihler değiştirgesinde yapılandırma öğelerini içeren bir dizi belirterek iconv_mime_encode() işlevinin davranışını belirleyebilirsiniz. Desteklenen öğeler aşağıda listelenmiştir. Öğe isimlerinin harf büyüklüğüne duyarlı oluşuna dikkat ediniz.

iconv_mime_encode() tarafından desteklenen yapılandırma öğeleri
Öğe | Tür | Açıklama | Öntanımlı değer | Örnek
scheme | string | Alan değerinin kodlanmasında kullanılacak yöntemi belirler. Bu öğenin değeri "B" veya "Q" olabilir. "B" base64 kodlama şemasını, "Q" ise quoted-printable kodlama şemasını betimler. | B | B
input-charset | string | alan_adı ve alan_değeri değiştirgeleri için girdi karakter kümesini belirler. Belirtilmezse, iconv.internal_encoding INI yönergesinin değerinin kullanılacağı varsayılır. | iconv.internal_encoding | ISO-8859-1
output-charset | string | MIME başlığını tertiplemekte kullanılacak karakter kümesini belirler. Belirtilmezse, input-charset kullanılır. | iconv.internal_encoding | UTF-8
line-length | integer | Başlık satırının azami uzunluğunu belirler. » RFC2822 - Genel Ağ İleti Biçemi belirtimine göre, bu değerden daha uzun bir başlık alanı satırı, en uzunu bu kadar baytlık satırlar halinde katlanır. Belirtilmezse, satır uzunluğu 76 karakterle sınırlanır. | 76 | 996
line-break-chars | string | Uzun başlık alanlarına satır katlama uygulandığında satır sonlarına eklenecek dizgeyi belirler. Belirtilmezse, "\r\n" (CR LF) öntanımlıdır. Bu öğenin input-charset değerinden bağımsız olarak daima bir ASCII dizge olarak ele alınacağına dikkat ediniz. | \r\n | \n

Dönen Değerler

Başarı durumunda kodlanmış MIME alanı, aksi takdirde FALSE döner.

Örnekler

Örnek 1 - iconv_mime_encode() örneği

<?php
$preferences = array(
    "input-charset" => "ISO-8859-1",
    "output-charset" => "UTF-8",
    "line-length" => 76,
    "line-break-chars" => "\n"
);
$preferences["scheme"] = "Q";
// Sonucu: "Subject: =?UTF-8?Q?Pr=C3=BCfung_Pr=C3=BCfung?="
echo iconv_mime_encode("Subject", "Prüfung Prüfung", $preferences);

$preferences["scheme"] = "B";
// Sonucu: "Subject: =?UTF-8?B?UHLDvGZ1bmcgUHLDvGZ1bmc=?="
echo iconv_mime_encode("Subject", "Prüfung Prüfung", $preferences);
?>

Ayrıca Bakınız

  • imap_binary() - 8 bitlik bir dizgeyi bir base64 dizgesine dönüştürür
  • mb_encode_mimeheader() - Dizgeyi MIME başlığı için kodlar
  • imap_8bit() - 8 bitlik bir dizgeyi 7 bitlik (quoted-printable) bir dizgeye dönüştürür
  • quoted_printable_encode() - 8 bitlik bir dizgenin ASCII olarak basılabilir (quoted-printable) sürümünü döndürür

iconv_mime_decode
iconv_set_encoding
iconv İşlevleri


Karakter kodlaması dönüşümü için geçerli karakter kümesini tanımlar

iconv_mime_encode
iconv_strlen
iconv İşlevleri
PHP Manual

iconv_set_encoding

(PHP 4 >= 4.0.5, PHP 5, PHP 7)

iconv_set_encoding — Karakter kodlaması dönüşümü için geçerli karakter kümesini tanımlar

Açıklama

bool iconv_set_encoding ( string $türü , string $karküm )

türü belirtilen dahili yapılandırma yönergesine değer olarak karküm atar.

Değiştirgeler

türü

Bir dizge olarak şunlardan biri olabilir:

  • input_encoding
  • output_encoding
  • internal_encoding

karküm

Karakter kümesi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - iconv_set_encoding() örneği

<?php
iconv_set_encoding("internal_encoding", "UTF-8");
iconv_set_encoding("output_encoding", "ISO-8859-9");
?>

Ayrıca Bakınız

  • iconv_get_encoding() - iconv eklentisinin dahili yapılandırma değişkenlerini döndürür
  • ob_iconv_handler() - Çıktı tamponu eylemcisi olarak karakter kodlaması dönüşümü yapar

iconv_mime_encode
iconv_strlen
iconv İşlevleri


Dizgenin karakter sayısı ile döner

iconv_set_encoding
iconv_strpos
iconv İşlevleri
PHP Manual

iconv_strlen

(PHP 5, PHP 7)

iconv_strlen — Dizgenin karakter sayısı ile döner

Açıklama

int iconv_strlen ( string $dizge [, string $karküm = ini_set("iconv.internal_encoding") ] )

Taydaşı olan strlen() işlevinden farklı olarak bayt değil karakter sayar. Karakterler karküm ile belirlenen karakter kümesine göre değerlendirilirler.

Değiştirgeler

dizge

Karakter sayısı hesaplanacak dizge.

karküm

Eğer karküm belirtilmezse, dizgenin karakter kodlamasının iconv.internal_encoding yönergesinde belirtilen kodlama olduğu varsayılır.

Dönen Değerler

dizge dizgesinin karakter sayısını bir tamsayı olarak döndürür.

Ayrıca Bakınız

  • strlen() - Dizge uzunluğunu döndürür
  • mb_strlen() - Dizge uzunluğu ile döner

iconv_set_encoding
iconv_strpos
iconv İşlevleri


Samanlıktakı ilk iğneyi bulur

iconv_strlen
iconv_strrpos
iconv İşlevleri
PHP Manual

iconv_strpos

(PHP 5, PHP 7)

iconv_strpos — Samanlıktakı ilk iğneyi bulur

Açıklama

int iconv_strpos ( string $samanlık , string $iğne [, int $başlangıç = 0 [, string $karküm = ini_set("iconv.internal_encoding") ]] )

Samanlık içindeki ilk iğnenin yerini bulur.

Taydaşı olan strpos() işlevinden farklı olarak, ilk iğnenin başlangıcına kadar bayt sayısını değil karakter sayısını döndürür. Karakterler karküm ile belirlenen karakter kümesine göre karakter olarak sayılırlar.

Değiştirgeler

samanlık

Aramanın yapılacağı dizge.

iğne

Aranacak alt dizge.

başlangıç

Aramanın başlatılacağı konum (seçimlik).

karküm

Eğer karküm belirtilmezse, dizgenin karakter kodlamasının iconv.internal_encoding yönergesinde belirtilen kodlama olduğu varsayılır.

Eğer samanlık veya iğne birer dizge değilse bir dizgeye dönüştürülür ve değeri kendisi olan bir sabit gibi ele alınır.

Dönen Değerler

İlk iğne'nin samanlık içinde bulunduğu yerin indisi ile döner.

Eğer samanlık içinde iğne yoksa FALSE döndürür.

Uyarı

Bu işlev mantıksal FALSE değeriyle dönebileceği gibi FALSE olarak değerlendirilebilecek mantıksal olmayan bir değerle de dönebilir. Bu konuda daha fazla bilgi edinmek için Mantıksal Değerler bölümüne bakabilirsiniz. Bu işlevden dönen değeri sınamak için === işlecini kullanınız.

Ayrıca Bakınız

  • strpos() - Bir alt dizgenin ilkinin konumunu bulur
  • iconv_strrpos() - Samanlıktakı son iğneyi bulur
  • mb_strpos() - Bir dizgenin içinde başka bir dizgeye ilk rastlanılan noktanın indisini döndürür

iconv_strlen
iconv_strrpos
iconv İşlevleri


Samanlıktakı son iğneyi bulur

iconv_strpos
iconv_substr
iconv İşlevleri
PHP Manual

iconv_strrpos

(PHP 5, PHP 7)

iconv_strrpos — Samanlıktakı son iğneyi bulur

Açıklama

int iconv_strrpos ( string $samanlık , string $iğne [, string $karküm = ini_set("iconv.internal_encoding") ] )

Taydaşı olan strpos() işlevinden farklı olarak, sonuncu iğnenin başlangıcına kadar bayt sayısını değil karakter sayısını döndürür.

Değiştirgeler

samanlık

Aramanın yapılacağı dizge.

iğne

Aranacak alt dizge.

karküm

Eğer karküm belirtilmezse, dizgenin karakter kodlamasının iconv.internal_encoding yönergesinde belirtilen kodlama olduğu varsayılır.

Eğer samanlık veya iğne birer dizge değilse bir dizgeye dönüştürülür ve değeri kendisi olan bir sabit gibi ele alınır.

Dönen Değerler

Sonuncu iğne'nin samanlık içinde bulunduğu yerin indisi ile döner. Karakterler karküm ile belirlenen karakter kümesine göre karakter olarak sayılırlar (bayt olarak değil).

Eğer samanlık içinde iğne yoksa FALSE döndürür.

Uyarı

Bu işlev mantıksal FALSE değeriyle dönebileceği gibi FALSE olarak değerlendirilebilecek mantıksal olmayan bir değerle de dönebilir. Bu konuda daha fazla bilgi edinmek için Mantıksal Değerler bölümüne bakabilirsiniz. Bu işlevden dönen değeri sınamak için === işlecini kullanınız.

Ayrıca Bakınız

  • strrpos() - Bir dizgede bir karakterin sonuncusunu bulur
  • iconv_strpos() - Samanlıktakı ilk iğneyi bulur
  • mb_strrpos() - Bir dizgenin içinde başka bir dizgeye son rastlanılan noktanın indisini döndürür

iconv_strpos
iconv_substr
iconv İşlevleri


Bir dizgenin bir alt dizgesini döndürür

iconv_strrpos
iconv
iconv İşlevleri
PHP Manual

iconv_substr

(PHP 5, PHP 7)

iconv_substr — Bir dizgenin bir alt dizgesini döndürür

Açıklama

string iconv_substr ( string $dizge , int $başlangıç [, int $uzunluk = strlen($str) [, string $karküm = ini_set("iconv.internal_encoding") ]] )

dizge dizgesinden başlangıç konumu başlangıç ile belirtilen karakterden başlayan uzunluk karakterlik bir dizge döndürür.

Değiştirgeler

dizge

Özgün dizge.

başlangıç

başlangıç negatif bir değer değilse, çıkarılacak alt dizgenin başlangıç karakteri, özgün dizgenin ilk karakteri 0 olmak üzere başlangıç'ıncı karakter olur.

başlangıç negatif bir değer ise, çıkarılacak alt dizgenin ilk karakteri sondan sayılarak bulunur.

uzunluk

uzunluk pozitif bir değerse, dönen dizge en fazla uzunluk karakter içerir (özgün dizgenin uzunluğuna bağlı olarak).

uzunluk negatif bir değerse, özgün dizgenin başından itibaren başlangıçıncı karakterden başlayıp, özgün dizgenin sondan itibaren uzunluk'uncu karakterinde biten alt dizge döndürülür. başlangıç da negatifse, her iki değerin pozitif olduğu durumda uygulanan işlem bu kez özgün dizgenin sonundan başlanarak uygulanır.

karküm

karküm belirtilmezse, dizge karakter kodlamasının iconv.internal_encoding yönergesinde belirtilen kodlama olduğu varsayılır.

başlangıç ve uzunluk değiştirgelerinde sayılanlar bayt değil dizgenin karakter kümesine göre birer karakterdir. İşlevin taydaşı olan substr() işlevinde baytlar sayılır.

Dönen Değerler

Belirtilen dizge dizgesinin başlangıç ve uzunluk ile belirtilen parçasını döndürür.

Eğer dizge uzunluğu, başlangıç değerinden küçükse FALSE döner.

Ayrıca Bakınız

  • substr() - Dizgenin bir kısmını döndürür
  • mb_substr() - Dizgenin bir alt dizgesini alır
  • mb_strcut() - Dizgenin başlangıcı ve uzunluğu belirtilen parçası ile döner

iconv_strrpos
iconv
iconv İşlevleri


Dizgenin karakter kodlamasını dönüştürür

iconv_substr
ob_iconv_handler
iconv İşlevleri
PHP Manual

iconv

(PHP 4 >= 4.0.5, PHP 5, PHP 7)

iconv — Dizgenin karakter kodlamasını dönüştürür

Açıklama

string iconv ( string $kodlamadan , string $kodlamaya , string $dizge )

dizge dizgesinin karakter kodlamasını kodlamadan kodlamaya çevirir.

Değiştirgeler

kodlamadan

Girdi karakter kümesi.

kodlamaya

Çıktı karakter kümesi.

Çıktı karakter kümesinin sonuna //TRANSLIT dizgesini eklerseniz, bu karakter kümesinde gösterilemeyen bir karaktere rastlanırsa bu karakterin yerine görünüş bakımından benzer bir karakter yerleştirilir. //IGNORE dizgesini eklerseniz, çıktı kararakter kümesinde gösterilemeyen bir karakter saptandığında karakter yoksayılır. Bunların hiçbiri yapılmazsa, dönüşüm ilk kuraldışı karakterde durdurulur ve bir E_NOTICE üretilir.

dizge

Dönüştürülecek dizge.

Dönen Değerler

Dönüşüm başarılı olursa dönüştürülen dizge, aksi takdirde FALSE döner.

Örnekler

Örnek 1 - iconv() örneği

<?php
$text = "Bu bir Euro simgesidir: '€'.";

echo 'Original : ', $text, PHP_EOL;
echo 'TRANSLIT : ', iconv("UTF-8", "ISO-8859-1//TRANSLIT", $text), PHP_EOL;
echo 'IGNORE   : ', iconv("UTF-8", "ISO-8859-1//IGNORE", $text), PHP_EOL;
echo 'Plain    : ', iconv("UTF-8", "ISO-8859-1", $text), PHP_EOL;
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Original : Bu bir Euro simgesidir: '€'.
TRANSLIT : Bu bir Euro simgesidir: 'EUR'.
IGNORE   : Bu bir Euro simgesidir: ''.
Plain    :
Notice: iconv(): Detected an illegal character in input string in .\iconv-example.php on line 7
This is the Euro symbol '

iconv_substr
ob_iconv_handler
iconv İşlevleri


Çıktı tamponu eylemcisi olarak karakter kodlaması dönüşümü yapar

iconv
intl
iconv İşlevleri
PHP Manual

ob_iconv_handler

(PHP 4 >= 4.0.5, PHP 5, PHP 7)

ob_iconv_handler — Çıktı tamponu eylemcisi olarak karakter kodlaması dönüşümü yapar

Açıklama

string ob_iconv_handler ( string $içerik , int $durum )

Dizgenin karakter kodlamasını dahili kodlamadan (internal_encoding) çıktı kodlamasına (output_encoding) dönüştürür.

internal_encoding ve output_encoding ya php.ini dosyasında ya da iconv_set_encoding() işleviyle tanımlanmalıdır.

Değiştirgeler

Bu değiştirgeler için ob_start() işlevine bakınız.

Dönen Değerler

Dönüş değerleri için ob_start() işlevine bakınız.

Örnekler

Örnek 1 - ob_iconv_handler() örneği

<?php
iconv_set_encoding("internal_encoding", "UTF-8");
iconv_set_encoding("output_encoding", "ISO-8859-9");
ob_start("ob_iconv_handler"); // çıktı tamponlamayı başlat
?>

Ayrıca Bakınız

  • iconv_get_encoding() - iconv eklentisinin dahili yapılandırma değişkenlerini döndürür
  • iconv_set_encoding() - Karakter kodlaması dönüşümü için geçerli karakter kümesini tanımlar
  • Çıktı Denetim İşlevleri

iconv
intl
iconv İşlevleri


Uluslararasılaştırma İşlevleri

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
    • Bu eklentinin temel kullanımı
  • Collator — Collator sınıfı
    • Collator::asort — Diziyi indislerin arasındaki ilişkilere göre sıralar
    • Collator::compare — İki Evrenkodlu dizgeyi karşılaştırır
    • Collator::__construct — Bir karşılaştırıcı oluşturur
    • Collator::create — Bir karşılaştırıcı oluşturur
    • Collator::getAttribute — Karşılaştırma özniteliğinin değerini döndürür
    • Collator::getErrorCode — Karşılaştırıcının son hata kodunu döndürür
    • Collator::getErrorMessage — Karşılaştırıcının son hata iletisini döndürür
    • Collator::getLocale — Karşılaştırıcının yerel ismini döndürür
    • Collator::getSortKey — Get sorting key for a string
    • Collator::getStrength — Geçerli karşılaştırma seviyesini döndürür
    • Collator::setAttribute — Karşılaştırma özniteliği tanımlar
    • Collator::setStrength — Sıralamanın seviyesini ayarlar
    • Collator::sortWithSortKeys — Bir diziyi belirtilen karşılaştırıcıyı ve sıralama anahtarlarını kullanarak sıralar
    • Collator::sort — Belirtilen karşılaştırıcıyı kullanarak diziyi sıralar
  • NumberFormatter — NumberFormatter sınıfı
    • NumberFormatter::create — Bir sayı biçemleyici oluşturur
    • NumberFormatter::formatCurrency — Bir para değerini biçemler
    • NumberFormatter::format — Bir sayıyı biçemler
    • NumberFormatter::getAttribute — Bir sayısal öznitelikle döner
    • NumberFormatter::getErrorCode — Biçemleyicinin son hata numarası ile döner
    • NumberFormatter::getErrorMessage — Biçemleyicinin son hata iletisini döndürür
    • NumberFormatter::getLocale — Biçemleyici yerelin ismi ile döner
    • NumberFormatter::getPattern — biçemleyici tarafından kullanılan kalıp dizgesi ile döner
    • NumberFormatter::getSymbol — Simge değeri ile döner
    • NumberFormatter::getTextAttribute — Bir metin öznitelik ile döner
    • NumberFormatter::parseCurrency — Bir para gösteriminin sayısal değeri ile döner
    • NumberFormatter::parse — Bir sayı dizgesini sayıya dönüştürür
    • NumberFormatter::setAttribute — Bir öznitelik tanımlar
    • NumberFormatter::setPattern — Biçemleyici kalıbı tanımlar
    • NumberFormatter::setSymbol — Bir simge değeri tanımlar
    • NumberFormatter::setTextAttribute — Bir metin öznitelik tanımlar
  • Locale — Locale sınıfı
    • Locale::acceptFromHttp — HTTP "Accept-Language" başlığıyla en iyi eşleşen yereli bulmaya çalışır
    • Locale::canonicalize — Canonicalize the locale string
    • Locale::composeLocale — Doğru sıralanmış yerel ile döner
    • Locale::filterMatches — Bir dil yaftasının bir yerelle eşleşip eşleşmediğine bakar
    • Locale::getAllVariants — Girdi yerelindeki tüm lehçeleri döndürür
    • Locale::getDefault — Öntanımlı yerel değerini döndürür
    • Locale::getDisplayLanguage — Girdi yerelindeki anadil kodunun yerelleştirilmiş ismini döndürür
    • Locale::getDisplayName — Girdi yerelinin yerelleştirilmiş ismini döndürür
    • Locale::getDisplayRegion — Girdi yereli için yerelleştirilmiş ülke ismini döndürür
    • Locale::getDisplayScript — Girdi yereli yazı türünün yerelleştirilmiş ismini döndürür
    • Locale::getDisplayVariant — Girdi yereli lehçesinin yerelleştirilmiş ismini döndürür
    • Locale::getKeywords — Girdi yerelindeki anahtar sözcükleri döndürür
    • Locale::getPrimaryLanguage — Girdi yerelinden anadil kodunu döndürür
    • Locale::getRegion — Girdi yerelinden ülke kodunu döndürür
    • Locale::getScript — Girdi yereli için yazı yaftasını döndürür
    • Locale::lookup — En iyi eşleşen dili bulmak için dil yaftası listesini araştırır
    • Locale::parseLocale — Yerel yaftasını oluşturan alt yaftaları içeren bir dizi döndürür
    • Locale::setDefault — Öntanımlı çalışma anı yerelini tanımlar
  • Normalizer — Normalizer sınıfı
    • Normalizer::isNormalized — Belirtilen dizge normalleştirilmiş mi diye bakar
    • Normalizer::normalize — Belirtilen girdiyi normalleştirir ve dizge olarak döndürür
  • MessageFormatter — MessageFormatter sınıfı
    • MessageFormatter::create — Yeni bir ileti biçemleyici nesne oluşturur
    • MessageFormatter::formatMessage — İletiyi çabuk biçemler
    • MessageFormatter::format — İleti biçemler
    • MessageFormatter::getErrorCode — Son işlemin hata kodunu döndürür
    • MessageFormatter::getErrorMessage — Son işlemin hata iletisini döndürür
    • MessageFormatter::getLocale — Biçemleyicinin oluşturulduğu yereli döndürür
    • MessageFormatter::getPattern — Biçemleyici tarafından kullanılan kalıbı döndürür
    • MessageFormatter::parseMessage — Girdi dizgesini hızla çözümler
    • MessageFormatter::parse — Girdi dizgesini kalıba uygun olarak çözümler
    • MessageFormatter::setPattern — Biçemleyici tarafından kullanılacak kalıbı tanımlar
  • IntlDateFormatter — IntlDateFormatter sınıfı
    • IntlDateFormatter::create — Bir tarih biçemleyici oluşturur
    • IntlDateFormatter::format — Tarih/saat değerini bir dizge olarak biçemler
    • IntlDateFormatter::formatObject — Formats an object
    • IntlDateFormatter::getCalendar — IntlDateFormatter tarafından kullanılan takvimi döndürür
    • IntlDateFormatter::getDateType — IntlDateFormatter tarafından kullanılan tarih gösterim türünü döndürür
    • IntlDateFormatter::getErrorCode — Son işlemin hata kodunu döndürür
    • IntlDateFormatter::getErrorMessage — Son işlemin hata iletisini döndürür
    • IntlDateFormatter::getLocale — Biçemleyicinin kullandığı yereli döndürür
    • IntlDateFormatter::getPattern — IntlDateFormatter tarafından kullanılan kalıbı döndürür
    • IntlDateFormatter::getTimeType — IntlDateFormatter tarafından kullanılan zaman gösterim türünü döndürür
    • IntlDateFormatter::getTimeZoneId — IntlDateFormatter tarafından kullanılan zaman dilimini döndürür
    • IntlDateFormatter::getCalendarObject — Get copy of formatter's calendar object
    • IntlDateFormatter::getTimeZone — Get formatter's timezone
    • IntlDateFormatter::isLenient — IntlDateFormatter esnek çözümleme mi yapıyor diye bakar
    • IntlDateFormatter::localtime — Tarih dizgesini alanlarına çözümler
    • IntlDateFormatter::parse — Dizgeyi bir zaman damgası değerine dönüştürür
    • IntlDateFormatter::setCalendar — Kullanılacak takvimi tanımlar
    • IntlDateFormatter::setLenient — Çözümleyiciye esneklik verir
    • IntlDateFormatter::setPattern — IntlDateFormatter tarafından kullanılan kalıbı tanımlar
    • IntlDateFormatter::setTimeZoneId — Kullanılacak zaman dilimini tanımlar
    • IntlDateFormatter::setTimeZone — Sets formatter's timezone
  • Grapheme İşlevleri
    • grapheme_extract — UTF-8 kodlanmış bir metin tamponundan öntanımlı sesletim kümelerinden oluşan bir dizilimi döndürür
    • grapheme_stripos — Harf büyüklüğüne duyarsız olarak bir dizgede ilk sesletim biriminin yerini bulur
    • grapheme_stristr — Harf büyüklüğüne duyarsız olarak bir dizgedeki ilk sesletim birimine göre ilk veya ikinci parça ile döner
    • grapheme_strlen — Dizgenin sesletim birimi cinsinden uzunluğunu döndürür
    • grapheme_strpos — Bir dizgede ilk sesletim biriminin yerini bulur
    • grapheme_strripos — Harf büyüklüğüne duyarsız olarak bir dizgedeki sonuncu sesletim biriminin yerini bulur
    • grapheme_strrpos — Bir dizgedeki sonuncu sesletim biriminin yerini bulur
    • grapheme_strstr — Bir dizgedeki ilk sesletim birimine göre ilk veya ikinci parça ile döner
    • grapheme_substr — Bir alt dizge döndürür
  • IDN İşlevleri
    • idn_to_ascii — Alan adını IDNA ASCII biçimine dönüştürür
    • idn_to_utf8 — Alan adı kodlamasını IDNA ASCII'den evrenkoda dönüştürür
  • intl İşlevleri
    • intl_error_name — Belirtilen hata kodunun simgesel ismini döndürür
    • intl_get_error_code — Son hatanın kodunu döndürür
    • intl_get_error_message — Son hatayı açıklayan bir dizge ile döner
    • intl_is_failure — Belirtilen hata kodunun bir başarısızlık göstergesi olup olmadığına bakar
ob_iconv_handler
Giriş
İnsan Dilleri ve Karakter Kodlaması Desteği


Giriş

Uluslararasılaştırma eklentisi » ICU kütüphanesi için bir sarmalayıcı olup PHP programcısının betiklerinde UCA uyumlu karşılaştırma ve tarih/zaman/sayı/para biçemleme işlemleri yapabilmesini sağlar.

ICU API'leri yakından izlendiğinden C/C++ veya Java'da ICU ile çalışma deneyimi olan kişiler PHP API'sini de kolayca kullanabilir. Ayrıca ICU belgeleri de çeşitli ICU işlevlerini anlamaya yardımcı olacaktır.

Eklenti çeşitli modüllerden oluşur ve her biri ICU'nun belli bir API'si ile ilgilidir:

  • Karşılaştırıcı: Yerele duyarlı sıralama destekli dizge karşılaştırma yeteneği sağlar.
  • Sayı Biçemleyici: Sayıların yerelleştirilmiş biçeme veya belirtilen şablona ya da belli bir kural kümesine uygun olarak gösterilmesini ve dizgelerin sayılara çözümlenmesini mümkün kılar.
  • İleti Biçemleyici: Yerel kurallara ve belirtilen şablona göre biçemlenmiş verileri (sayılar, tarihler gibi) birleştirerek iletilerin oluşturulmasını ve içinden verileri çıkararak iletilerin çözümlenmesini mümkün kılar.
  • Normalleştirici: Metni Evrenkod normalleştirme biçimlerinden birine dönüştürecek bir işlev ve normalleştirilmiş bir dizgeyi sınayacak bir yordam sağlar.
  • Yerel: Yerel betimleyicilerden alt etiketleri almak için, yerel betimleyicilerle işlevler biçiminde etkileşim kurar; yerel betimleyicileri çözümler, birleştirir ve eşleştirir (sorgular ve süzer).

Kaynakça

  • » Çeşitli ICU belgeleri

  • » ICU Kullanıcı Kılavuzu

  • » Evrenkod Karşılaştırma Algoritması

intl
Yapılandırma/Kurulum
intl


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
intl


Gereksinimler

Bu eklentiyi derlemek için » ICU kütüphanesinin 3.6 veya üstü sürümünü kurmalısınız.

Eklentinin PHP 5.2, 5.2.4+ ile derlenmesi önerilir. PHP 5.3+ kaynak ağacının bir parçasıdır.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/intl.

ICU'yu standart dizinlerden birine kurmadıysanız devingen ilintileyicinin (ld) kütüphaneyi bulabilmesi için kurduğunuz yeri LD_LIBRARY_PATH ortam değişkeninde belirtmelisiniz:

$ export LD_LIBRARY_PATH=/opt/icu/lib

Aksi takdirde, PHP ve ICU kendi öntanımlı dizinlerine kurulmuşsa yapılandırma için ek seçenekler gerekir.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Intl Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
intl.default_locale |  | PHP_INI_ALL |
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

intl.default_locale string

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

INTL_MAX_LOCALE_LEN (integer)
PHP kodunda yerel uzunluğunu 80 olarak sınırlar. Bundan daha uzun yerel isimleri kabul edilmez.
IDNA_DEFAULT (integer)
IDN işlevleri için girdideki tanımsız kodların işleme sokulması engellenir ve girdinin alan adlarıyla ilgili ASCII kurallarına uygunluğu sınanmaz.
IDNA_ALLOW_UNASSIGNED (integer)
IDN işlevleri için girdideki tanımsız kodların işleme sokulmasına izin verilir.
IDNA_USE_STD3_RULES (integer)
Girdinin alan adlarıyla ilgili ASCII kurallarına uygunluğu sınanır.

Özkaynak Türleri
Örnekler
intl


Örnekler

İçindekiler

  • Bu eklentinin temel kullanımı
Öntanımlı Sabitler
Bu eklentinin temel kullanımı
intl


Bu eklentinin temel kullanımı

Her modül iki çeşit API içerir: Yordamsal ve nesne yönelimli. Bunlar, ilgili belgelerde de açıklandığı gibi birbirlerine eşdeğerdir.

Bilginize:

Tüm girdi dizgeleri UTF-8 olmak zorundadır. Tüm çıktılar da ayrıca UTF-8'dir.

Örnek 1 - Yordamsal API kullanım örneği

<?php
$coll  = collator_create('en_US');
$result = collator_compare($coll, "string#1", "string#2");
?>

Örnek 2 - Nesne yönelimli API kullanım örneği

<?php
$coll = new Collator('en_US');
$al   = $coll->getLocale(Locale::ACTUAL_LOCALE);
echo "Asıl yerel: $al\n";

$formatter = new NumberFormatter('en_US', NumberFormatter::DECIMAL);
echo $formatter->format(1234567);
?>
Örnekler
Collator
Örnekler


Collator sınıfı

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Giriş

Yerele duyarlı sıralama desteğiyle dizge karşılaştırma yeteneği sağlar.

Sınıf Sözdizimi

Collator {
/* Yöntemler */
__construct ( string $yerel )
bool asort ( array &$dizi [, int $sıralama_türü ] )
int compare ( string $dizge1 , string $dizge2 )
static Collator create ( string $yerel )
int getAttribute ( int $öznitelik )
int getErrorCode ( void )
string getErrorMessage ( void )
string getLocale ([ int $tür ] )
public string getSortKey ( string $str )
int getStrength ( void )
bool setAttribute ( int $öznitelik , int $değer )
bool setStrength ( int $nitelik )
bool sortWithSortKeys ( array &$dizi )
bool sort ( array &$arr [, int $sıralama_türü ] )
}

Öntanımlı Sabitler

Collator::FRENCH_COLLATION (integer)

Dizgenin geri planındaki farklı aksanlara göre dizgeleri sıralar. Bu öznitelik Fransızca yerellerde ve bir kaç başka yerelde özdevinimli olarak etkindir. Kullanıcılar normalde bu özniteliği açıkça etkinleştirme ihtiyacı duymazlar. Bu özniteliğe On değeri atamanın başarım açısından bir bedeli vardır fakat sıralama anahtarının uzunluğu tesirsizdir. Olası değerler şunlardır:

  • Collator::ON
  • Collator::OFF(öntanımlı)
  • Collator::DEFAULT_VALUE

Örnek 1 - FRENCH_COLLATION kuralları

  • F=OFF cote < coté < côte < côté
  • F=ON cote < côte < coté < côté

Collator::ALTERNATE_HANDLING (integer)

Alternate özniteliği, UCA'da değişken karakterler denen karakterleri (boşluk karakterleri, noktalama imleri ve simgeler) denetim altında tutmak için kullanılır. Eğer bu özniteliğe NonIgnorable (N) değeri atanırsa bu karakterler arasındaki farklar harfler arasındaki farklarla aynı önemdedir. Eğer Shifted (S) atanırsa bu karakterler çok düşük önemde olurlar. Shifted değeri çoğunlukla Strength (etki seviyesi) ile birlikte Dördüncüllüğü (Quaternary) belirtmekte kullanılır. Böyle bir durumda, boşluk karakterleri, noktalama imleri ve simgelerin dizgeleri karşılaştırırken hesaba katılabilmesi için dizgelerin tüm diğer şeyler (temel harfler, aksanlar ve harf büyüklüğü) bakımından eşdeğer olmaları gerekir. Eğer özniteliğe Shifted atanmazsa üçüncül (Tertiary) ve dördüncül (Quaternary) etki seviyeleri arasında hiçbir fark yoktur. Daha fazla bilgi ve örnekler için » UCA sitesindeki "Variable_Weighting" konusuna bakınız. Özniteliğin değerlerinin basitçe On ve Off olmamasının sebebi gelecekte başka değerlerin eklenebilecek olmasıdır. UCA seçeneği Blanked üçüncül etki seviyesi ile ifade edilir ve özniteliğe Shifted atanır. Çoğu yerel için NonIgnorable öntanımlıdır. Eğer Shifted seçilirse ve noktalama dışında birbirinin aynı çok sayıda dizge varsa işlem daha yavaş olabilir; etki seviyesi ayrıca arttırılmadıkça sıralama anahtarı uzunluğu tesirsiz olacaktır.

Olası değerler:

  • Collator::NON_IGNORABLE(öntanımlı)
  • Collator::SHIFTED
  • Collator::DEFAULT_VALUE

Örnek 2 - ALTERNATE_HANDLING kuralları

  • S=3, A=N di Silva < Di Silva < diSilva < U.S.A. < USA
  • S=3, A=S di Silva = diSilva < Di Silva < U.S.A. = USA
  • S=4, A=S di Silva < diSilva < Di Silva < U.S.A. < USA

Collator::CASE_FIRST (integer)

Case_First özniteliği, dizgeler arasında başka farkların olmadığı durumda büyük harflerin küçük harflerden önce mi yoksa sonra mı olacağını belirler. Olası değerler, büyük harflerin önce geleceğini belirten Uppercase_First (U), küçük harflerin önce olacağını belirten Lowercase_First (L) değerlerine ilaveten standart Default ve Off değerleridir. Sonuçları bakımından Off ve Lowercase_First arasında hemen hemen hiç fark yoktur. Bu bakımdan kullanıcılar genelde Lowercase_First kullanmazlar, sadece Off veya Uppercase_First kullanırlar. X ve L arasındaki farkların ayrıntıları ile ilgilenen kullanıcılar Karşılaştırma Özelleştirmesini incelemelidirler. L veya U belirtmenin dizge karşılaştırma başarımında etkisi olmaz, fakat sıralama anahtarı uzunluğunu etkiler.

Olası değerler:

  • Collator::OFF(öntanımlı)
  • Collator::LOWER_FIRST
  • Collator::UPPER_FIRST
  • Collator:DEFAULT

Örnek 3 - CASE_FIRST kuralları

  • C=X or C=L "china" < "China" < "denmark" < "Denmark"
  • C=U "China" < "china" < "Denmark" < "denmark"

Collator::CASE_LEVEL (integer)

Case_Level özniteliği harf büyüklüğünü değil aksanları yoksaymak için kullanılır. Böyle bir durumda, etki seviyesine (Strength) Primary ve Case_Level özniteliğine On atanır. Çoğu yerelde On öntanımlıdır ve bu değerin küçük bir dizge karşılaştırma başarımı ve sıralama anahtarı ektisi vardır.

Olası değerler:

  • Collator::OFF(öntanımlı)
  • Collator::ON
  • Collator::DEFAULT_VALUE

Örnek 4 - CASE_LEVEL kuralları

  • S=1, E=X role = Role = rôle
  • S=1, E=O role = rôle < Role

Collator::NORMALIZATION_MODE (integer)

Normalleştirme ayarı, karşılaştırmada metnin tamamen normalleştirilip normalleştirilmeyeceğini belirler. Değeri off olsa bile (çoğu yerel için öntanımlıdır) ortak kullanımda gösterildiği haliyle metin doğru olarak karşılaştırılacaktır (Ayrıntılar için UTN #5'e bakınız). Sadece, meşru sırada olmayan aksan imleri sorun çıkarır. Özniteliğe On atanmışsa, olası tüm metin girdiler için en iyi sonuçlar garanti edilir ve normalleştirme gerektiren dizilimlerin sıklığına bağlı olarak orta seviyede bir dizge karşılaştırma başarımı maliyeti vardır. Sıralama anahtarı uzunluğu üzerinde önemli bir etkisi yoktur. Eğer girdi metninin NFD veya NFKD normalleştirme şekillerinden birinde olduğu biliniyorsa bu normalleştirme seçeneğini etkin kılmaya gerek yoktur.

Olası değerler:

  • Collator::OFF(öntanımlı)
  • Collator::ON
  • Collator::DEFAULT_VALUE

Collator::STRENGTH (integer)

ICU Karşılaştırma hizmeti çok seviyeli karşılaştırmayı destekler (bunlara seviye (level) dendiği gibi tesir derecesi de (Strength) denir). Bu seviyeler sayesinde ICU, dizgeleri yerel uzlaşımlara bağlı olarak hassas bir şekilde sıralar. Bununla birlikte, metin içinde dizge araması, seviyelerin seçilerek devreye sokulmasına izin verilerek çeşitli eşleşme koşullarıyla gerçekleştirilebilir. Daha ayrıntılı bilgi edinmek için collator_set_strength() işlevine bakınız.

Olası değerler:

  • Collator::PRIMARY
  • Collator::SECONDARY
  • Collator::TERTIARY(öntanımlı)
  • Collator::QUATERNARY
  • Collator::IDENTICAL
  • Collator::DEFAULT_VALUE

Collator::HIRAGANA_QUATERNARY_MODE (integer)

JIS x 4061 ile uyumluluk Hiragana ve Katakana karakterler arasında ayrım sağlayacak ek seviyeler gerektirir. Eğer standartla uyumluluk gerekirse bu özniteliğe On atanmalı ve seviye olarak Quaternary (dördüncül) kullanılmalıdır. Bu, sıralama anahtarı uzunluğunu ve dizge karşılaştırma başarımını etkiler.

Olası değerler:

  • Collator::OFF(öntanımlı)
  • Collator::ON
  • Collator::DEFAULT_VALUE

Collator::NUMERIC_COLLATION (integer)

Etkin kılınırsa bu öznitelik, rakamlardan oluşan altdizgelerin sayısal değerleri için bir karşılaştırma anahtarı üretir. Bu, sıralamada '2''den sonra '100' almanın bir yoludur.

Olası değerler:

  • Collator::OFF(default)
  • Collator::ON
  • Collator::DEFAULT_VALUE

Collator::DEFAULT_VALUE (integer)
Collator::PRIMARY (integer)
Collator::SECONDARY (integer)
Collator::TERTIARY (integer)
Collator::DEFAULT_STRENGTH (integer)
Collator::QUATERNARY (integer)
Collator::IDENTICAL (integer)
Collator::OFF (integer)
Collator::ON (integer)
Collator::SHIFTED (integer)
Collator::NON_IGNORABLE (integer)
Collator::LOWER_FIRST (integer)
Collator::UPPER_FIRST (integer)

İçindekiler

  • Collator::asort — Diziyi indislerin arasındaki ilişkilere göre sıralar
  • Collator::compare — İki Evrenkodlu dizgeyi karşılaştırır
  • Collator::__construct — Bir karşılaştırıcı oluşturur
  • Collator::create — Bir karşılaştırıcı oluşturur
  • Collator::getAttribute — Karşılaştırma özniteliğinin değerini döndürür
  • Collator::getErrorCode — Karşılaştırıcının son hata kodunu döndürür
  • Collator::getErrorMessage — Karşılaştırıcının son hata iletisini döndürür
  • Collator::getLocale — Karşılaştırıcının yerel ismini döndürür
  • Collator::getSortKey — Get sorting key for a string
  • Collator::getStrength — Geçerli karşılaştırma seviyesini döndürür
  • Collator::setAttribute — Karşılaştırma özniteliği tanımlar
  • Collator::setStrength — Sıralamanın seviyesini ayarlar
  • Collator::sortWithSortKeys — Bir diziyi belirtilen karşılaştırıcıyı ve sıralama anahtarlarını kullanarak sıralar
  • Collator::sort — Belirtilen karşılaştırıcıyı kullanarak diziyi sıralar
Bu eklentinin temel kullanımı
Collator::asort
intl


Diziyi indislerin arasındaki ilişkilere göre sıralar

Collator
Collator::compare
Collator
PHP Manual

Collator::asort

collator_asort

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Collator::asort -- collator_asort — Diziyi indislerin arasındaki ilişkilere göre sıralar

Açıklama

Nesne yönelimli kullanım

bool Collator::asort ( array &$dizi [, int $sıralama_türü ] )

Yordamsal kullanım

bool collator_asort ( Collator $karşılaştırıcı , array &$dizi [, int $sıralama_türü ] )

Bir diziyi indislerinin arasındaki ilişkilere uygun olarak sıralar. Elemanlarının sıralamasının önem kazandığı yerlerde ilişkisel dizilerin içeriğini sıraya sokmakta kullanılır. Dizi elemanları yerele özgü kurallara göre sıralanır.

PHP'nin standart asort() işlevinin eşdeğeridir.

Değiştirgeler

karşılaştırıcı

Collator nesnesi.

dizi

Sıralanacak dizgeleri içeren dizi.

sıralama_türü

İsteğe bağlı sıralama türü şunlardan biri olabilir:

  • Collator::SORT_REGULAR - öğeleri normal olarak karşılaştırır (tür değişmez).

  • Collator::SORT_NUMERIC - öğeler sayısal olarak sıralanır.

  • Collator::SORT_STRING - öğeler dizge olarak karşılaştırılır.

Öntanımlı değer Collator::SORT_REGULAR olup geçersiz sıralama türü belirtildiğinde de geçerli olur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - collator_asort() örneği

<?php
$coll = collator_create( 'en_US' );
$arr = array(
     'a' => '100',
     'b' => '50',
     'c' => '7'
);
collator_asort( $coll, $arr, Collator::SORT_NUMERIC );
var_export( $arr );

collator_asort( $coll, $arr, Collator::SORT_STRING );
var_export( $arr );
?>

Yukarıdaki örneğin çıktısı:

array (
  'c' => '7',
  'b' => '50',
  'a' => '100',
)array (
  'a' => '100',
  'b' => '50',
  'c' => '7',
)

Ayrıca Bakınız

  • Collator sabitleri
  • collator_sort() - Belirtilen karşılaştırıcıyı kullanarak diziyi sıralar
  • collator_sort_with_sort_keys() - Bir diziyi belirtilen karşılaştırıcıyı ve sıralama anahtarlarını kullanarak sıralar

Collator
Collator::compare
Collator


İki Evrenkodlu dizgeyi karşılaştırır

Collator::asort
Collator::__construct
Collator
PHP Manual

Collator::compare

collator_compare

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Collator::compare -- collator_compare — İki Evrenkodlu dizgeyi karşılaştırır

Açıklama

Nesne yönelimli kullanım

int Collator::compare ( string $dizge1 , string $dizge2 )

Yordamsal kullanım

int collator_compare ( Collator $karşılaştırıcı , string $dizge1 , string $dizge2 )

İki evrenkodlu dizgeyi yerelin karşılaştırma kurallarına uygun olarak karşılaştırır.

Değiştirgeler

coll

Collator nesnesi.

dizge1

Karşılaştırılacak dizgelerden biri.

dizge2

Karşılaştırılacak dizgelerden biri.

Dönen Değerler

Dönen karşılaştırma sonuçları:

  • dizge1, dizge2'den büyükse: 1

  • dizge1 ve dizge2 aynıysa: 0

  • dizge1, dizge2'den küçükse: 2

Hata oluşmuşsa FALSE döner.

Uyarı

Bu işlev mantıksal FALSE değeriyle dönebileceği gibi FALSE olarak değerlendirilebilecek mantıksal olmayan bir değerle de dönebilir. Bu konuda daha fazla bilgi edinmek için Mantıksal Değerler bölümüne bakabilirsiniz. Bu işlevden dönen değeri sınamak için === işlecini kullanınız.

Örnekler

Örnek 1 - collator_compare() örneği

<?php
$s1 = 'Hello';
$s2 = 'hello';

$coll = collator_create( 'en_US' );
$res  = collator_compare( $coll, $s1, $s2 );

if ($res === false) {
    echo collator_get_error_message( $coll );
} else if( $res > 0 ) {
    echo "s1, s2'den büyüktür\n";
} else if( $res < 0 ) {
    echo "s1, s2'den küçüktür\n";
} else {
    echo "s1 ve s2 aynıdır\n";
}
?>

Yukarıdaki örneğin çıktısı:

s1, s2'den büyüktür

Ayrıca Bakınız

  • collator_sort() - Belirtilen karşılaştırıcıyı kullanarak diziyi sıralar

Collator::asort
Collator::__construct
Collator


Bir karşılaştırıcı oluşturur

Collator::compare
Collator::create
Collator
PHP Manual

Collator::__construct

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Collator::__construct — Bir karşılaştırıcı oluşturur

Açıklama

Collator::__construct ( string $yerel )

Yeni bir Collator örneği oluşturur.

Değiştirgeler

yerel

Kullanılacak karşılaştırma kurallarını içeren yerel. Yerel olarak özel değerler verilebilir; eğer NULL verilirse öntanımlı yerelin karşılaştırma kuralları geçerli olur. Eğer boş dizge ("") veya "root" verilirse UCA kuralları geçerli olur.

Kullanıcının farklı ülke ve yörelerle ilgili beklentilerine bağlı olarak, doğru sıralama ve eşleştirmeyi yapabilmek için yerel (Locale) en önemli özniteliktir. Öntanımlı » UCA kuralları sadece Felemenkçe, Portekizce gibi bir kaç yerel için doğru sıralama yapar (buradaki "doğru" sözcüğü, kullanıcının dille ilgili beklentileri ile ilgilidir). Öntanımlı yerelin yetmediği noktada UCA'nın beklediğiniz sıralamayı yapabilmesi için doğru yereli belirtmelisiniz. Yerelin seçilmesiyle, yerel için makul sayılabilecek tüm öznitelikler özdevinimli olarak belli değerlere ayarlanır. Bu bakımdan çoğunlukla yerele özgü özniteliklerin ayrıca belirtilmesi gerekmez. Bazı durumlarda yerel seçimi dizge karşılaştırma başarımında ve/veya sıralama anahtarı uzunluğunda bir fark oluşturabilir.

Dönen Değerler

Bir Collator örneği.

Hatalar/İstisnalar

Hata durumunda "boş" bir nesne döner. Neler olup bittiğini öğrenmek için intl_get_error_code() ve/veya intl_get_error_message() işlevini kullanabilirsiniz.

Örnekler

Örnek 1 - Collator::__construct() örneği

<?php
$coll = new Collator( 'en_CA' );
?>

Ayrıca Bakınız

  • Collator::create() - Bir karşılaştırıcı oluşturur
  • collator_create() - Bir karşılaştırıcı oluşturur

Collator::compare
Collator::create
Collator


Bir karşılaştırıcı oluşturur

Collator::__construct
Collator::getAttribute
Collator
PHP Manual

Collator::create

collator_create

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Collator::create -- collator_create — Bir karşılaştırıcı oluşturur

Açıklama

Nesne yönelimli kullanım

static Collator Collator::create ( string $yerel )

Yordamsal kullanım

Collator collator_create ( string $yerel )

Dizgeler yerel kurallara uygun olarak karşılaştırılır.

Değiştirgeler

yerel

Gereken karşılaştırma kurallarını içeren yerel. Yerel olarak özel değerler verilebilir; eğer NULL verilirse öntanımlı yerelin karşılaştırma kuralları geçerli olur. Eğer boş dizge ("") veya "root" verilirse UCA kuralları geçerli olur.

Dönen Değerler

Bir hata oluşursa NULL, aksi takdirde Collator nesnesinin yeni bir örneği.

Örnekler

Örnek 1 - collator_create() örneği

<?php
$coll = collator_create( 'en_US' );

if( !isset( $coll ) ) {
    printf( "Nesne örneği oluşturulamadı: %s\n", intl_get_error_message() );
    exit( 1 );
}
?>

Ayrıca Bakınız

  • Collator::__construct() - Bir karşılaştırıcı oluşturur

Collator::__construct
Collator::getAttribute
Collator


Karşılaştırma özniteliğinin değerini döndürür

Collator::create
Collator::getErrorCode
Collator
PHP Manual

Collator::getAttribute

collator_get_attribute

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Collator::getAttribute -- collator_get_attribute — Karşılaştırma özniteliğinin değerini döndürür

Açıklama

Nesne yönelimli kullanım

int Collator::getAttribute ( int $öznitelik )

Yordamsal kullanım

int collator_get_attribute ( Collator $karşılaştırıcı , int $öznitelik )

Karşılaştırma özniteliğinin değerini tamsayı olarak döndürür.

Değiştirgeler

karşılaştırıcı

Collator nesnesi.

öznitelik

Değeri öğrenilecek öznitelik.

Dönen Değerler

Bir hata oluşursa FALSE, aksi takdirde özniteliğin değeri.

Örnekler

Örnek 1 - collator_get_attribute() örneği

<?php
$coll = collator_create( 'en_CA' );
$val = collator_get_attribute( $coll, Collator::NUMERIC_COLLATION );
if( $val === false )
{
    // Hata ile ilgili işlemler.
}
?>

Ayrıca Bakınız

  • Collator sabitleri
  • collator_set_attribute() - Karşılaştırma özniteliği tanımlar
  • collator_get_strength() - Geçerli karşılaştırma seviyesini döndürür

Collator::create
Collator::getErrorCode
Collator


Karşılaştırıcının son hata kodunu döndürür

Collator::getAttribute
Collator::getErrorMessage
Collator
PHP Manual

Collator::getErrorCode

collator_get_error_code

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Collator::getErrorCode -- collator_get_error_code — Karşılaştırıcının son hata kodunu döndürür

Açıklama

Nesne yönelimli kullanım

int Collator::getErrorCode ( void )

Yordamsal kullanım

int collator_get_error_code ( Collator $karşılaştırıcı )

Değiştirgeler

karşılaştırıcı

Collator nesnesi.

Dönen Değerler

Son karşılaştırma işlevi çağrısında oluşan hatanın kodu.

Örnekler

Örnek 1 - collator_get_error_code() örneği

<?php
$coll = collator_create( 'en_US' );
if( collator_get_attribute( $coll, Collator::FRENCH_COLLATION ) === false )
        handle_error( collator_get_error_code() );
?>

Ayrıca Bakınız

  • collator_get_error_message() - Karşılaştırıcının son hata iletisini döndürür

Collator::getAttribute
Collator::getErrorMessage
Collator


Karşılaştırıcının son hata iletisini döndürür

Collator::getErrorCode
Collator::getLocale
Collator
PHP Manual

Collator::getErrorMessage

collator_get_error_message

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Collator::getErrorMessage -- collator_get_error_message — Karşılaştırıcının son hata iletisini döndürür

Açıklama

Nesne yönelimli kullanım

string Collator::getErrorMessage ( void )

Yordamsal kullanım

string collator_get_error_message ( Collator $karşılaştırıcı )

Son hatanın iletisini döndürür.

Değiştirgeler

karşılaştırıcı

Collator nesnesi.

Dönen Değerler

Son karşılaştırma işlevi çağrısında oluşan hatanın açıklaması.

Örnekler

Örnek 1 - collator_get_error_message() örneği

<?php
$coll = collator_create( 'lt' );
if( collator_compare( $coll, 'y', 'k' ) === false ) {
    echo collator_get_error_message( $coll );
}
?>

Ayrıca Bakınız

  • collator_get_error_code() - Karşılaştırıcının son hata kodunu döndürür

Collator::getErrorCode
Collator::getLocale
Collator


Karşılaştırıcının yerel ismini döndürür

Collator::getErrorMessage
Collator::getSortKey
Collator
PHP Manual

Collator::getLocale

collator_get_locale

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Collator::getLocale -- collator_get_locale — Karşılaştırıcının yerel ismini döndürür

Açıklama

Nesne yönelimli kullanım

string Collator::getLocale ([ int $tür ] )

Yordamsal kullanım

string collator_get_locale ( Collator $karşılaştırıcı , int $tür )

Karşılaştırıcının yerel adını döndürür.

Değiştirgeler

karşılaştırıcı

Collator nesnesi.

tür

Geçerli yerel için Locale::VALID_LOCALE, fiili yerel için Locale::ACTUAL_LOCALE belirtilir. Fiili yerel öntanımlıdır.

Dönen Değerler

Karşılaştırma verisinin geldiği gerçek yerel ismi. Eğer karşılaştırıcı kurallardan örneklenmişse veya hata oluşursa FALSE döner.

Örnekler

Örnek 1 - collator_get_locale() örneği

<?php
$coll    = collator_create( 'tr_TR_Istanbul' );
$res_val = collator_get_locale( $coll, Locale::VALID_LOCALE );
$res_act = collator_get_locale( $coll, Locale::ACTUAL_LOCALE );
echo "İstenen yerel ismi: tr_TR_Istanbul\n";
printf("Geçerli yerel ismi: %s\nFiili yerel ismi: %s\n", $res_val, $res_act );
?>

Yukarıdaki örneğin çıktısı:

İstenen yerel ismi: tr_TR_Istanbul
Geçerli yerel ismi: tr_TR
Fiili yerel ismi: tr

Ayrıca Bakınız

  • collator_create() - Bir karşılaştırıcı oluşturur

Collator::getErrorMessage
Collator::getSortKey
Collator


Get sorting key for a string

Collator::getLocale
Collator::getStrength
Collator
PHP Manual

Collator::getSortKey

collator_get_sort_key

(PHP 5 >= 5.3.11, PHP 7, PECL intl >= 1.0.3)

Collator::getSortKey -- collator_get_sort_key — Get sorting key for a string

Açıklama

Nesne yönelimli kullanım

public string Collator::getSortKey ( string $str )

Yordamsal kullanım

string collator_get_sort_key ( Collator $coll , string $str )

Return collation key for a string.

Değiştirgeler

coll

Collator object.

str

The string to produce the key from.

Dönen Değerler

Returns the collation key for the string. Collation keys can be compared directly instead of strings.

Uyarı

Bu işlev mantıksal FALSE değeriyle dönebileceği gibi FALSE olarak değerlendirilebilecek mantıksal olmayan bir değerle de dönebilir. Bu konuda daha fazla bilgi edinmek için Mantıksal Değerler bölümüne bakabilirsiniz. Bu işlevden dönen değeri sınamak için === işlecini kullanınız.

Örnekler

Örnek 1 collator_get_sort_key()example

<?php
$s1 = 'Hello';

$coll = collator_create( 'en_US' );
$res  = collator_get_sort_key( $coll, $s1);

echo urlencode($res);
?>

Yukarıdaki örneğin çıktısı:

71%3F%3FE%01%09%01%8F%08%00

Ayrıca Bakınız

  • collator_sort() - Belirtilen karşılaştırıcıyı kullanarak diziyi sıralar
  • collator_sort_with_sort_keys() - Bir diziyi belirtilen karşılaştırıcıyı ve sıralama anahtarlarını kullanarak sıralar

Collator::getLocale
Collator::getStrength
Collator


Geçerli karşılaştırma seviyesini döndürür

Collator::getSortKey
Collator::setAttribute
Collator
PHP Manual

Collator::getStrength

collator_get_strength

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Collator::getStrength -- collator_get_strength — Geçerli karşılaştırma seviyesini döndürür

Açıklama

Nesne yönelimli kullanım

int Collator::getStrength ( void )

Yordamsal kullanım

int collator_get_strength ( Collator $karşılaştırıcı )

Geçerli karşılaştırma seviyesini döndürür.

Değiştirgeler

karşılaştırıcı

Collator nesnesi.

Dönen Değerler

Hata oluşursa FALSE, aksi takdirde karşılaştırma seviyesi.

Örnekler

Örnek 1 - collator_get_strength() örneği

<?php
$coll     = collator_create( 'en_US' );
$strength = collator_get_strength( $coll );
?>

Ayrıca Bakınız

  • Collator sabitleri
  • collator_set_strength() - Sıralamanın seviyesini ayarlar
  • collator_get_attribute() - Karşılaştırma özniteliğinin değerini döndürür

Collator::getSortKey
Collator::setAttribute
Collator


Karşılaştırma özniteliği tanımlar

Collator::getStrength
Collator::setStrength
Collator
PHP Manual

Collator::setAttribute

collator_set_attribute

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Collator::setAttribute -- collator_set_attribute — Karşılaştırma özniteliği tanımlar

Açıklama

Nesne yönelimli kullanım

bool Collator::setAttribute ( int $öznitelik , int $değer )

Yordamsal kullanım

bool collator_set_attribute ( Collator $karşılaştırıcı , int $öznitelik , int $değer )

Değiştirgeler

karşılaştırıcı

Collator nesnesi.

öznitelik

Öznitelik.

değer

Özniteliğe atanacak değer.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - collator_set_attribute() örneği

<?php
$coll = collator_create( 'en_CA' );
$val  = collator_get_attribute( $coll, Collator::NUMERIC_COLLATION );
if ($val === false) {
    // Hata işleme.
} elseif ($val === Collator::ON) {
    // Bazı işlemler.
}
?>

Ayrıca Bakınız

  • Collator sabitleri
  • collator_get_attribute() - Karşılaştırma özniteliğinin değerini döndürür
  • collator_set_strength() - Sıralamanın seviyesini ayarlar

Collator::getStrength
Collator::setStrength
Collator


Sıralamanın seviyesini ayarlar

Collator::setAttribute
Collator::sortWithSortKeys
Collator
PHP Manual

Collator::setStrength

collator_set_strength

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Collator::setStrength -- collator_set_strength — Sıralamanın seviyesini ayarlar

Açıklama

Nesne yönelimli kullanım

bool Collator::setStrength ( int $nitelik )

Yordamsal kullanım

bool collator_set_strength ( Collator $karşılaştırıcı , int $seviye )

» ICU Karşılaştırma Hizmeti çok seviyeli karşılaştırmayı destekler. Bu sınıflandırma sayesinde ICU dizgeleri sıralamayı yerel uzlaşımlara uygun olarak daha büyük hassasiyetle yerine getirir. Bununla birlikte, seviyelerin seçmeli olarak devreye sokulabilmesi sayesinde metin içinde bir dizgenin aranması çeşitli eşleşme koşullarıyla yapılabilir.

  1. Birincil seviye: Bu genel olarak, temel karakterler arasındaki farkları ("a" < "b" gibi) ifade etmek için kullanılır. Bu en güçlü farktır. Örneğin sözlükler bu temel karakterlere göre farklı bölümlere ayrılırlar. Buna ayrıca 1. seviyeden nitelik adı verilir.

  2. İkincil seviye: Karakterlerdeki aksanlar ikincil farklar olarak ele alınır (örneğin, "as" < "às" < "at") Dile bağlı olarak harfler arasındaki diğer farklar da ikincil farklar olarak ele alınabilir. Dizgelerin içinde herhangi bir yerde birincil dereceden bir farkın varlığında ikincil seviyeden bir fark yoksayılır. Buna ayrıca 2. seviyeden nitelik adı verilir.

    Bilginize:

    Bazı dillerde (Danca gibi) bazı aksanlı karakterler temel karakterler olarak ele alınırlar. Bununla birlikte çoğu dilde aksanlı bir karakter aynı harfin aksansız olanına göre ikinci dereceden bir farktan başka bir şey değildir.

  3. Üçüncül seviye: Büyük ve küçük harfler arasındaki farklar üçüncül seviyeden farklardandır (örneğin, "ao" < "Ao" < "aò"). Buna ek olarak, bir harfin büyük veya küçük harflisinin temel karakterlerden farkları da ("A" ve " " gibi) üçüncül seviyedendir. Bu farklara diğer bir örnek de büyük ve küçük Kana arasındaki farktır. Dizgelerin içinde herhangi bir yerde bir birincil veya ikincil seviyeden farkın varlığında üçüncül seviyeden bir fark yoksayılır.

  4. Dördüncül seviye: 13. seviyede, noktalama yoksayıldığında (Noktalamanın Yoksayılması'na bakınız), noktalamalı ve noktalamasız sözcükleri ayırmakta ek bir seviye kullanılabilir (örneğin, "ab" < "a-b" < "aB"). Bu fark, birinci, ikincil veya üçüncül seviyeden farkların varlığında yoksayılır. Bu, 4. seviyeden nitelik olarak da bilinir. Dördüncül seviye sadece, noktalamanın yok sayılması gerekliyse veya bir Japonca metin işleniyorsa kullanılmalıdır (Hiragana işlemi'ne bakınız).

  5. Eş seviye: Diğer tüm seviyelerin eşitliğinde eşitliği bozmak için eş seviye kullanılır. NFD biçimindeki her dizgenin Evrenkod kod değerleri, 14. seviyede fark bulunmayan durumda, bu seviyede karşılaştırılır. Örneğin İbranice şive imleri sadece bu seviyede ayrımsanır. Bu seviye gereksiz yere kullanılmamalı, iki dizge arasındaki sadece kod değerleri arasındaki farklar gibi oldukça nadir durumlarda kullanılmalıdır. Bu seviyenin kullanımı, esasen, hem arttırımlı karşılaştırma hem de sıralama anahtarı üretiminde (sıralama anahtarı uzunluğunu arttırması gibi) başarımı azaltır. Bu, 5. seviyeden nitelik olarak da bilinir.

Örneğin, bazıları, metin içinde arama yaparken aksanlı karakterleri veya aksanlı karakterleri ve büyük/küçük harf farklarını yoksaymayı seçebilirler. Hemen hemen tüm karakterler ilk üç seviyeye göre ayrımsanabilir ve bu bakımdan çoğu yerelde üçüncül (Tertiary) seviye öntanımlıdır. Bununla birlikte, Alternate özniteliğine Shifted atanırsa, boşluk ve noktalama karakterleri ve simgeler diğer taraftan yoksayılmadıkça bunlar arasındaki eşitlikleri bozmak için dördüncül (Quaternary) seviye kullanılabilir. Karakterler arasında çok hassas ayrım gerekliyse, eş (Identical) seviye de kullanılabilir. (Örneğin, Matematiksel Kalın Küçük A ile Matematiksel Eğik Küçük A arasındaki ayrımı sadece eş seviye sağlayabilir.) Bununla birlikte, üçüncül ve eş seviyelerden daha yüksek seviyelerin kullanımı belirgin şekilde daha uzun sıralama anahtarları ve eş dizgeler arasında daha yavaş karşılaştırma başarımı ile sonuçlanır.

Değiştirgeler

coll

Collator nesnesi.

seviye

Atanacak seviye.

Olası değerler:

  • Collator::PRIMARY

  • Collator::SECONDARY

  • Collator::TERTIARY

  • Collator::QUATERNARY

  • Collator::IDENTICAL

  • Collator::DEFAULT

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - collator_set_strength() örneği

<?php
$arr  = array( 'aò', 'Ao', 'ao' );
$coll = collator_create( 'en_US' );

// Diziyi öntanımlı seviyeyle sıralayalım.
collator_sort( $coll, $arr );
var_export( $arr );

// Diziyi birincil seviyeyle sıralayalım.
collator_set_strength( $coll, Collator::PRIMARY );
collator_sort( $coll, $arr );
var_export( $arr );
?>

Yukarıdaki örneğin çıktısı:

array (
  0 => 'ao',
  1 => 'Ao',
  2 => 'aò',
)
array (
  0 => 'aò',
  1 => 'Ao',
  2 => 'ao',
)

Ayrıca Bakınız

  • Collator sabitleri
  • collator_get_strength() - Geçerli karşılaştırma seviyesini döndürür

Collator::setAttribute
Collator::sortWithSortKeys
Collator


Bir diziyi belirtilen karşılaştırıcıyı ve sıralama anahtarlarını kullanarak sıralar

Collator::setStrength
Collator::sort
Collator
PHP Manual

Collator::sortWithSortKeys

collator_sort_with_sort_keys

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Collator::sortWithSortKeys -- collator_sort_with_sort_keys — Bir diziyi belirtilen karşılaştırıcıyı ve sıralama anahtarlarını kullanarak sıralar

Açıklama

Nesne yönelimli kullanım

bool Collator::sortWithSortKeys ( array &$dizi )

Yordamsal kullanım

bool collator_sort_with_sort_keys ( Collator $karşılaştırıcı , array &$dizi )

collator_sort() işlevine benzer, fakat büyük dizilerde daha fazla hız kazanmak için ucol_getSortKey() tarafından üretilen ICU sıralama anahtarını kullanır.

Değiştirgeler

karşılaştırıcı

Collator nesnesi.

dizi

Sıralanacak dizge dizisi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - collator_sort_with_sort_keys() örneği

<?php
$arr  = array( 'Kuytu', 'Kuğu', 'Kuş' );
$coll = collator_create( 'tr' );

collator_sort_with_sort_keys( $coll, $arr );
var_export( $arr );
?>

Yukarıdaki örneğin çıktısı:

array (
  0 => 'Kuğu',
  1 => 'Kuş',
  2 => 'Kuytu',
)

Ayrıca Bakınız

  • Collator sabitleri
  • collator_sort() - Belirtilen karşılaştırıcıyı kullanarak diziyi sıralar
  • collator_asort() - Diziyi indislerin arasındaki ilişkilere göre sıralar

Collator::setStrength
Collator::sort
Collator


Belirtilen karşılaştırıcıyı kullanarak diziyi sıralar

Collator::sortWithSortKeys
NumberFormatter
Collator
PHP Manual

Collator::sort

collator_sort

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Collator::sort -- collator_sort — Belirtilen karşılaştırıcıyı kullanarak diziyi sıralar

Açıklama

Nesne yönelimli kullanım

bool Collator::sort ( array &$arr [, int $sıralama_türü ] )

Yordamsal kullanım

bool collator_sort ( Collator $karşılaştırıcı , array &$arr [, int $sıralama_seçeneği ] )

Bu işlev bir diziyi geçerli yerel kurallarına uygun olarak sıralar.

Standart PHP sort() işlevine eşdeğerdir.

Değiştirgeler

karşılaştırıcı

Collator nesnesi.

dizi

Sıralanacak dizge dizisi.

sıralama_türü

İsteğe bağla sıralama türü, şunlardan biri olabilir:

  • Collator::SORT_REGULAR - öğeler normal olarak karşılaştırılır (türleri değiştirilmez).

  • Collator::SORT_NUMERIC - öğeler sayısal olarak karşılaştırılır.

  • Collator::SORT_STRING - öğeler dizgesel olarak karşılaştırılır.

Öntanımlı sıralama türü: Collator::SORT_REGULAR.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - collator_sort() örneği

<?php
$coll = collator_create( 'tr_TR' );
$arr  = array( 'zor', 'ışık', 'çok', 'iğne' );

var_export( $arr );
collator_sort( $coll, $arr );
var_export( $arr );
?>

Yukarıdaki örneğin çıktısı:

array (
  0 => 'zor',
  1 => 'ışık',
  2 => 'çok',
  3 => 'iğne',
)array (
  0 => 'çok',
  1 => 'ışık',
  2 => 'iğne',
  3 => 'zor',
)

Ayrıca Bakınız

  • Collator sabitleri
  • collator_asort() - Diziyi indislerin arasındaki ilişkilere göre sıralar
  • collator_sort_with_sort_keys() - Bir diziyi belirtilen karşılaştırıcıyı ve sıralama anahtarlarını kullanarak sıralar

Collator::sortWithSortKeys
NumberFormatter
Collator


NumberFormatter sınıfı

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Giriş

Programlar sayılar üzerinde işlem yapmak ve bunları saklamak için yerelden bağımsız bir ikil gösterim kullanırlar. Sayılar gösterilirken veya basılırken bunlar yerele özgü dizgelere dönüştürülür. Örneğin, 12345.67 sayısı ABD için "12,345.67", Fransa için "12 345,67" ve Almanya ve Türkiye için "12.345,67" biçimindedir.

NumberFormatter (SayıBiçemleyici) sınıfınca sağlanmış yöntemleri çağırmak suretiyle sayıları, paraları ve yüzdeleri öntanımlı yerele veya belirtilen yerele uygun olarak biçemleyebilirsiniz. NumberFormatter sınıfı yerele duyarlı olduğundan her yerel için yeni bir sayı biçemleyici oluşturmanız gerekir. NumberFormatter sınıfının yöntemleri kayan noktalı sayılar gibi ilkel sayı türlerini biçemler ve bunları yerele özgü dizgeler olarak çıktılar.

Paraları, uygun bir sayı ve para birimi simgesiyle biçemleyip bir dizge olarak döndürmek için bir biçemleyici oluşturmak amacıyla para biçemleme türünü kullanabilirsiniz. Şüphesiz, NumberFormatter sınıfı paralar arasındaki kıymet oranlarını bilmez ve belirtilen paranın değerini belirtilen yerele göre dönüştürmez. Yani para birimi ne olursa olsun para biriminin yanında hep belirttiğiniz miktarı görürsünüz. 9988776.65 değeri için sonuçlar şöyle olabilir:

  • Fransa'da 9 988 776,65 €
  • Türkiye'de 9.988.776,65 YTL veya 9.988.776 TL
  • ABD'de $9,988,776.65

Yüzdeleri biçemlemek için, yüzde biçemleme türü kullanılarak yerele özgü bir biçemleyici oluşturulur. Bu biçemleyici ile örneğin, 0.75 gibi bir ondalık sayı %75 olarak gösterilir.

Sayıların hecelenmesi gibi daha karmaşık biçemlemeler için kurala dayalı sayı biçemleyici kullanılır.

Sınıf Sözdizimi

NumberFormatter {
/* Yöntemler */
__construct ( string $yerel , int $tür [, string $kalıp ] )
static NumberFormatter create ( string $yerel , int $tür [, string $kalıp ] )
string formatCurrency ( float $değer , string $para_birimi )
string format ( number $değer [, int $tür ] )
int getAttribute ( int $biçemleyici )
int getErrorCode ( void )
string getErrorMessage ( void )
string getLocale ([ int $tür ] )
string getPattern ( void )
string getSymbol ( int $öznitelik )
string getTextAttribute ( int $öznitelik )
float parseCurrency ( string $değer , string &$dizge [, int &$konum ] )
mixed parse ( string $değer [, int $tür [, int &$konum ]] )
bool setAttribute ( int $öznitelik , int $değer )
bool setPattern ( string $kalıp )
bool setSymbol ( int $öznitelik , string $değer )
bool setTextAttribute ( int $öznitelik , string $değer )
}

Öntanımlı Sabitler

Bu biçemler numfmt_create() işlevi tarafından biçemleyici türünü tanımlamak için kullanılırlar.

NumberFormatter::PATTERN_DECIMAL (integer)
Şablona göre tanımlı ondalık biçem
NumberFormatter::DECIMAL (integer)
Ondalık biçem
NumberFormatter::CURRENCY (integer)
Para birimi biçemi
NumberFormatter::PERCENT (integer)
Yüzde biçemi
NumberFormatter::SCIENTIFIC (integer)
Bilimsel sayı gösterim biçemi
NumberFormatter::SPELLOUT (integer)
Kurala dayalı heceleme biçemi
NumberFormatter::ORDINAL (integer)
Kurala dayalı sıra gösterim biçemi
NumberFormatter::DURATION (integer)
Kurala dayalı süre gösterim biçemi
NumberFormatter::PATTERN_RULEBASED (integer)
Şablona göre tanımlı kurala dayalı biçem
NumberFormatter::DEFAULT_STYLE (integer)
Yerele özgü öntanımlı biçem
NumberFormatter::IGNORE (integer)
PATTERN_DECIMAL için takma ad

Bu sabitler sayıların nasıl çözümlenip biçemleneceğini tanımlar. numfmt_format() ve numfmt_parse() işlevlerinin değiştirgeleri olarak kullanılırlar.

NumberFormatter::TYPE_DEFAULT (integer)
Türü değişken türünden türet
NumberFormatter::TYPE_INT32 (integer)
32 bitlik tamsayı olarak çözümle/biçemle
NumberFormatter::TYPE_INT64 (integer)
64 bitlik tamsayı olarak çözümle/biçemle
NumberFormatter::TYPE_DOUBLE (integer)
Bir kayan noktalı sayı olarak çözümle/biçemle
NumberFormatter::TYPE_CURRENCY (integer)
Para birimi olarak çözümle/biçemle

numfmt_get_attribute() ve numfmt_set_attribute() işlevi tarafından kullanılan sayı biçemleme öznitelikleri:

NumberFormatter::PARSE_INT_ONLY (integer)
Sadece tamsayıları çözümle.
NumberFormatter::GROUPING_USED (integer)
Gruplama ayracı kullan.
NumberFormatter::DECIMAL_ALWAYS_SHOWN (integer)
Ondalık noktayı daima göster.
NumberFormatter::MAX_INTEGER_DIGITS (integer)
Azami tamsayı hane sayısı.
NumberFormatter::MIN_INTEGER_DIGITS (integer)
Asgari tamsayı hane sayısı.
NumberFormatter::INTEGER_DIGITS (integer)
Tamsayı hane sayısı.
NumberFormatter::MAX_FRACTION_DIGITS (integer)
Ondalık kısım azami hane sayısı
NumberFormatter::MIN_FRACTION_DIGITS (integer)
Ondalık kısım asgari hane sayısı.
NumberFormatter::FRACTION_DIGITS (integer)
Ondalık kısım hane sayısı
NumberFormatter::MULTIPLIER (integer)
Çarpan.
NumberFormatter::GROUPING_SIZE (integer)
Grup genişliği.
NumberFormatter::ROUNDING_MODE (integer)
Yuvarlama kipi.
NumberFormatter::ROUNDING_INCREMENT (integer)
Yuvarlama artışı.
NumberFormatter::FORMAT_WIDTH (integer)
Çıktı biçeminde dolgu genişliği.
NumberFormatter::PADDING_POSITION (integer)
Dolgunun konumu. Olası değerler için dolgu konumlama sabitlerine bakınız.
NumberFormatter::SECONDARY_GROUPING_SIZE (integer)
İkincil gruplama genişliği.
NumberFormatter::SIGNIFICANT_DIGITS_USED (integer)
Kıymetli haneleri kullan.
NumberFormatter::MIN_SIGNIFICANT_DIGITS (integer)
Asgari kıymetli hane sayısı.
NumberFormatter::MAX_SIGNIFICANT_DIGITS (integer)
Azami kıymetli hane sayısı.
NumberFormatter::LENIENT_PARSE (integer)
Kurala dayalı biçemlerde kullanılan esnek çözümleme kipi.

numfmt_get_text_attribute() ve numfmt_set_text_attribute() işlevlerinde kullanılan sayı biçemi metin öznitelikleri:

NumberFormatter::POSITIVE_PREFIX (integer)
Pozitif öneki.
NumberFormatter::POSITIVE_SUFFIX (integer)
Pozitif soneki.
NumberFormatter::NEGATIVE_PREFIX (integer)
Negatif öneki.
NumberFormatter::NEGATIVE_SUFFIX (integer)
Negatif soneki.
NumberFormatter::PADDING_CHARACTER (integer)
Dolgu karakteri.
NumberFormatter::CURRENCY_CODE (integer)
ISO para birimi.
NumberFormatter::DEFAULT_RULESET (integer)
Öntanımlı kural kümesi. Sadece kurala dayalı biçemleyicilerle kullanılabilir.
NumberFormatter::PUBLIC_RULESETS (integer)
Genel kural kümeleri. Sadece kurala dayalı biçemleyicilerle kullanılabilir. Salt okunur bir özniteliktir. Genel kural kümeleri, kural kümesi isimleri noktalı virgüllerle (;) ayrılarak tek bir dizge halinde gönderilir.

numfmt_get_symbol() ve numfmt_set_symbol() işlevleri tarafından kullanılan sayı biçemleme simgeleri.

NumberFormatter::DECIMAL_SEPARATOR_SYMBOL (integer)
Ondalık ayraç.
NumberFormatter::GROUPING_SEPARATOR_SYMBOL (integer)
Gruplama ayracı.
NumberFormatter::PATTERN_SEPARATOR_SYMBOL (integer)
Şablon ayracı.
NumberFormatter::PERCENT_SYMBOL (integer)
Yüzde imi.
NumberFormatter::ZERO_DIGIT_SYMBOL (integer)
Sıfır.
NumberFormatter::DIGIT_SYMBOL (integer)
Şablonda bir rakamı ifade eden karakter.
NumberFormatter::MINUS_SIGN_SYMBOL (integer)
Eksi imi.
NumberFormatter::PLUS_SIGN_SYMBOL (integer)
Artı imi.
NumberFormatter::CURRENCY_SYMBOL (integer)
Para birimi simgesi.
NumberFormatter::INTL_CURRENCY_SYMBOL (integer)
Uluslararası para birimi simgesi.
NumberFormatter::MONETARY_SEPARATOR_SYMBOL (integer)
Para ayracı.
NumberFormatter::EXPONENTIAL_SYMBOL (integer)
Üstel imi.
NumberFormatter::PERMILL_SYMBOL (integer)
Binde imi.
NumberFormatter::PAD_ESCAPE_SYMBOL (integer)
Öncelem dolgu karakteri.
NumberFormatter::INFINITY_SYMBOL (integer)
Sonsuz imi.
NumberFormatter::NAN_SYMBOL (integer)
Bir-sayı-değil imi.
NumberFormatter::SIGNIFICANT_DIGIT_SYMBOL (integer)
Kıymetli hane imi.
NumberFormatter::MONETARY_GROUPING_SEPARATOR_SYMBOL (integer)
Para gruplama imi.

numfmt_get_attribute()
ve numfmt_set_attribute() işlevleri tarafından
NumberFormatter::ROUNDING_MODE özniteliği ile
kullanılan yuvarlama kipi değerleri.

NumberFormatter::ROUND_CEILING (integer)
Pozitif sonsuza yuvarlama kipi.
NumberFormatter::ROUND_DOWN (integer)
Sıfıra yuvarlama kipi.
NumberFormatter::ROUND_FLOOR (integer)
Negatif sonsuza yuvarlama kipi.
NumberFormatter::ROUND_HALFDOWN (integer)
İki komşuya da eşit uzaklıkta olmamak koşuluyla aşağı yuvarlama kipi.
NumberFormatter::ROUND_HALFEVEN (integer)
İki komşuya da eşit uzaklıkta olmamak koşuluyla çift sayılı komşuya yuvarlama kipi.
NumberFormatter::ROUND_HALFUP (integer)
İki komşuya da eşit uzaklıkta olmamak koşuluyla yukarı yuvarlama kipi.
NumberFormatter::ROUND_UP (integer)
Sıfırdan öteye yuvarlama kipi.

numfmt_get_attribute()
ve numfmt_set_attribute() işlevleri tarafından
NumberFormatter::PADDING_POSITION özniteliği ile
birlikte kullanılan dolgu konumu değerleri:

NumberFormatter::PAD_AFTER_PREFIX (integer)
Dolgu karakterlerini önekten sonra yerleştir.
NumberFormatter::PAD_AFTER_SUFFIX (integer)
Dolgu karakterlerini sonekten sonra yerleştir.
NumberFormatter::PAD_BEFORE_PREFIX (integer)
Dolgu karakterlerini önekten önce yerleştir.
NumberFormatter::PAD_BEFORE_SUFFIX (integer)
Dolgu karakterlerini sonekten önce yerleştir.

Ayrıca Bakınız

  • » ICU biçemleme belgeleri
  • » ICU sayı biçemleyicileri
  • » ICU ondalık sayı biçemleyicileri
  • » ICU kurala dayalı sayı biçemleyecileri

İçindekiler

  • NumberFormatter::create — Bir sayı biçemleyici oluşturur
  • NumberFormatter::formatCurrency — Bir para değerini biçemler
  • NumberFormatter::format — Bir sayıyı biçemler
  • NumberFormatter::getAttribute — Bir sayısal öznitelikle döner
  • NumberFormatter::getErrorCode — Biçemleyicinin son hata numarası ile döner
  • NumberFormatter::getErrorMessage — Biçemleyicinin son hata iletisini döndürür
  • NumberFormatter::getLocale — Biçemleyici yerelin ismi ile döner
  • NumberFormatter::getPattern — biçemleyici tarafından kullanılan kalıp dizgesi ile döner
  • NumberFormatter::getSymbol — Simge değeri ile döner
  • NumberFormatter::getTextAttribute — Bir metin öznitelik ile döner
  • NumberFormatter::parseCurrency — Bir para gösteriminin sayısal değeri ile döner
  • NumberFormatter::parse — Bir sayı dizgesini sayıya dönüştürür
  • NumberFormatter::setAttribute — Bir öznitelik tanımlar
  • NumberFormatter::setPattern — Biçemleyici kalıbı tanımlar
  • NumberFormatter::setSymbol — Bir simge değeri tanımlar
  • NumberFormatter::setTextAttribute — Bir metin öznitelik tanımlar
Collator::sort
NumberFormatter::create
intl


Bir sayı biçemleyici oluşturur

NumberFormatter
NumberFormatter::formatCurrency
NumberFormatter
PHP Manual

NumberFormatter::create

numfmt_create

NumberFormatter::__construct

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::create -- numfmt_create -- NumberFormatter::__construct — Bir sayı biçemleyici oluşturur

Açıklama

Nesne yönelimli kullanım

static NumberFormatter NumberFormatter::create ( string $yerel , int $tür [, string $kalıp ] )

Yordamsal kullanım

NumberFormatter numfmt_create ( string $yerel , int $tür [, string $kalıp ] )

Nesne yönelimli kullanım (kurucu):

NumberFormatter::__construct ( string $yerel , int $tür [, string $kalıp ] )

Bir sayı biçemleyici oluşturur.

Değiştirgeler

yerel

Sayının biçemleneceği yerel (tr_TR gibi bir yerel ismi).

tür

Biçemleyici türü sabitlerinden biri. Eğer değer olarak NumberFormatter::PATTERN_DECIMAL veya NumberFormatter::PATTERN_RULEBASED belirtilmişse, sayı biçemi, numfmt_set_pattern tarafından desteklenen kalıp karakterlerine veya » ICU RuleBasedNumberFormat belgesinde açıklanan sözdizimine uygun olarak belirtilen kalıba uygun olarak açılır.

kalıp

Biçemleyici türünün bir kalıp gerektirmesi durumunda kalıp dizgesi.

Dönen Değerler

Bir hata oluşursa FALSE, aksi takdirde NumberFormatter nesnesi döner.

Örnekler

Örnek 1 - numfmt_create() örneği

<?php
$fmt = numfmt_create( 'de_DE', NumberFormatter::DECIMAL );
echo numfmt_format($fmt, 1234567.891234567890000)."\n";
$fmt = numfmt_create( 'it', NumberFormatter::SPELLOUT );
echo numfmt_format($fmt, 1142)."\n";
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$fmt = new NumberFormatter( 'de_DE', NumberFormatter::DECIMAL );
echo $fmt->format(1234567.891234567890000)."\n";
$fmt = new NumberFormatter( 'it', NumberFormatter::SPELLOUT );
echo $fmt->format(1142)."\n";
?>

Yukarıdaki örneğin çıktısı:

1.234.567,891
millicentoquarantadue

Ayrıca Bakınız

  • numfmt_format() - Bir sayıyı biçemler
  • numfmt_parse() - Bir sayı dizgesini sayıya dönüştürür

NumberFormatter
NumberFormatter::formatCurrency
NumberFormatter


Bir para değerini biçemler

NumberFormatter::create
NumberFormatter::format
NumberFormatter
PHP Manual

NumberFormatter::formatCurrency

numfmt_format_currency

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::formatCurrency -- numfmt_format_currency — Bir para değerini biçemler

Açıklama

Nesne yönelimli kullanım

string NumberFormatter::formatCurrency ( float $değer , string $para_birimi )

Yordamsal kullanım

string numfmt_format_currency ( NumberFormatter $biçemleyici , float $değer , string $para_birimi )

Biçemleyici kurallarına uygun olarak para değerini biçemler.

Değiştirgeler

biçemleyici

NumberFormatter nesnesi.

değer

Sayısal olarak para değeri.

para_birimi

3 harfli ISO 4217 para birimi.

Dönen Değerler

Biçemlenmiş para değeri dizgesi.

Örnekler

Örnek 1 - numfmt_format_currency() örneği

<?php
$fmt = numfmt_create( 'tr_TR', NumberFormatter::CURRENCY );
echo numfmt_format_currency($fmt, 1234567.891234567890000, "EUR")."\n";
echo numfmt_format_currency($fmt, 1234567.891234567890000, "TRL")."\n";
echo numfmt_format_currency($fmt, 1234567.891234567890000, "YTL")."\n\n";
$fmt = numfmt_create( 'de_DE', NumberFormatter::CURRENCY );
echo numfmt_format_currency($fmt, 1234567.891234567890000, "EUR")."\n";
echo numfmt_format_currency($fmt, 1234567.891234567890000, "TRL")."\n";
echo numfmt_format_currency($fmt, 1234567.891234567890000, "TRY")."\n";
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$fmt = new NumberFormatter( 'tr_TR', NumberFormatter::CURRENCY );
echo $fmt->formatCurrency(1234567.891234567890000, "EUR")."\n";
echo $fmt->formatCurrency(1234567.891234567890000, "TRL")."\n";
echo $fmt->formatCurrency(1234567.891234567890000, "YTL")."\n\n";
$fmt = new NumberFormatter( 'de_DE', NumberFormatter::CURRENCY );
echo $fmt->formatCurrency(1234567.891234567890000, "EUR")."\n";
echo $fmt->formatCurrency(1234567.891234567890000, "TRL")."\n";
echo $fmt->formatCurrency(1234567.891234567890000, "TRY")."\n";
?>

Yukarıdaki örneğin çıktısı:

1.234.567,89 €
1.234.568 TL
1.234.567,89 YTL

1.234.567,89 €
1.234.568 TRL
1.234.567,89 TRY

Ayrıca Bakınız

  • numfmt_get_error_code() - Biçemleyicinin son hata numarası ile döner
  • numfmt_format() - Bir sayıyı biçemler
  • numfmt_parse_currency() - Bir para gösteriminin sayısal değeri ile döner

NumberFormatter::create
NumberFormatter::format
NumberFormatter


Bir sayıyı biçemler

NumberFormatter::formatCurrency
NumberFormatter::getAttribute
NumberFormatter
PHP Manual

NumberFormatter::format

numfmt_format

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::format -- numfmt_format — Bir sayıyı biçemler

Açıklama

Nesne yönelimli kullanım

string NumberFormatter::format ( number $değer [, int $tür ] )

Yordamsal kullanım

string numfmt_format ( NumberFormatter $biçemleyici , number $değer [, int $tür ] )

Bir sayıyı biçemleyici kurallarına uygun olarak biçemler.

Değiştirgeler

biçemleyici

NumberFormatter nesnesi.

değer

Biçemlenecek değer. integer veya double türünde olabilir, diğer değerler bir sayısal değere dönüştürülür.

tür

Kullanılacak biçemleme türü.

Dönen Değerler

Bir hata oluşursa FALSE, aksi takdirde biçemlenmiş değeri içeren dizge döner.

Örnekler

Örnek 1 - numfmt_format() örneği

<?php
$fmt = numfmt_create( 'tr_TR', NumberFormatter::DECIMAL );
$data = numfmt_format($fmt, 1234567.891234567890000);
if(intl_is_failure(numfmt_format($fmt))) {
    report_error("Biçemleyici hatası");
}
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$fmt = new NumberFormatter( 'tr_TR', NumberFormatter::DECIMAL );
$fmt->format(1234567.891234567890000);
if(intl_is_failure($fmt->getErrorCode())) {
    report_error("Biçemleyici hatası");
}
?>

Yukarıdaki örneğin çıktısı:

1.234.567,891

Ayrıca Bakınız

  • numfmt_get_error_code() - Biçemleyicinin son hata numarası ile döner
  • numfmt_format_currency() - Bir para değerini biçemler
  • numfmt_parse() - Bir sayı dizgesini sayıya dönüştürür

NumberFormatter::formatCurrency
NumberFormatter::getAttribute
NumberFormatter


Bir sayısal öznitelikle döner

NumberFormatter::format
NumberFormatter::getErrorCode
NumberFormatter
PHP Manual

NumberFormatter::getAttribute

numfmt_get_attribute

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::getAttribute -- numfmt_get_attribute — Bir sayısal öznitelikle döner

Açıklama

Nesne yönelimli kullanım

int NumberFormatter::getAttribute ( int $biçemleyici )

Yordamsal kullanım

int numfmt_get_attribute ( NumberFormatter $biçemleyici , int $öznitelik )

Biçemleyici ile ilgili sayısal bir özniteliğin değeri ile döner. Tamsayı hanelerin sayısı, sayısal bir öznitelik örneği olarak verilebilir.

Değiştirgeler

biçemleyici

NumberFormatter nesnesi.

öznitelik

Öznitelik belirteci; sayısal öznitelik sabitlerinden biri.

Dönen Değerler

Bir hata oluşursa FALSE, aksi takdirde öznitelik değeri döner.

Örnekler

Örnek 1 - numfmt_get_attribute() örneği

<?php
$fmt = numfmt_create( 'tr_TR', NumberFormatter::DECIMAL );
echo "Hane sayısı: ".numfmt_get_attribute($fmt, NumberFormatter::MAX_FRACTION_DIGITS)."\n";
echo numfmt_format($fmt, 1234567.891234567890000)."\n";
numfmt_set_attribute($fmt, NumberFormatter::MAX_FRACTION_DIGITS, 2);
echo "Hane sayısı: ".numfmt_get_attribute($fmt, NumberFormatter::MAX_FRACTION_DIGITS)."\n";
echo numfmt_format($fmt, 1234567.891234567890000)."\n";
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$fmt = new NumberFormatter( 'tr_TR', NumberFormatter::DECIMAL );
echo "Hane sayısı: ".$fmt->getAttribute(NumberFormatter::MAX_FRACTION_DIGITS)."\n";
echo $fmt->format(1234567.891234567890000)."\n";
$fmt->setAttribute(NumberFormatter::MAX_FRACTION_DIGITS, 2);
echo "Hane sayısı: ".$fmt->getAttribute(NumberFormatter::MAX_FRACTION_DIGITS)."\n";
echo $fmt->format(1234567.891234567890000)."\n";
?>

Yukarıdaki örneğin çıktısı:

Hane sayısı: 3
1.234.567,891
Hane sayısı: 2
1.234.567,89

Ayrıca Bakınız

  • numfmt_get_error_code() - Biçemleyicinin son hata numarası ile döner
  • numfmt_get_text_attribute() - Bir metin öznitelik ile döner
  • numfmt_set_attribute() - Bir öznitelik tanımlar

NumberFormatter::format
NumberFormatter::getErrorCode
NumberFormatter


Biçemleyicinin son hata numarası ile döner

NumberFormatter::getAttribute
NumberFormatter::getErrorMessage
NumberFormatter
PHP Manual

NumberFormatter::getErrorCode

numfmt_get_error_code

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::getErrorCode -- numfmt_get_error_code — Biçemleyicinin son hata numarası ile döner

Açıklama

Nesne yönelimli kullanım

int NumberFormatter::getErrorCode ( void )

Yordamsal kullanım

int numfmt_get_error_code ( NumberFormatter $biçemleyici )

Biçimleyicinin çağrılan son işlevinden dönen hatanın numarasını döndürür.

Değiştirgeler

biçemleyici

NumberFormatter nesnesi.

Dönen Değerler

Biçimleyicinin çağrılan son işlevinden dönen hatanın numarası.

Örnekler

Örnek 1 - numfmt_get_error_code() örneği

<?php
$fmt  = numfmt_create( 'tr_TR', NumberFormatter::DECIMAL );
$data = numfmt_format($fmt, 1234567.891234567890000);
if(intl_is_failure(numfmt_get_error_code($fmt))) {
    report_error("Biçemleyici hatası");
}
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$fmt = new NumberFormatter( 'tr_TR', NumberFormatter::DECIMAL );
$fmt->format(1234567.891234567890000);
if(intl_is_failure($fmt->getErrorCode())) {
    report_error("Biçemleyici hatası");
}
?>

Ayrıca Bakınız

  • numfmt_get_error_message() - Biçemleyicinin son hata iletisini döndürür
  • intl_get_error_code() - Son hatanın kodunu döndürür
  • intl_is_failure() - Belirtilen hata kodunun bir başarısızlık göstergesi olup olmadığına bakar

NumberFormatter::getAttribute
NumberFormatter::getErrorMessage
NumberFormatter


Biçemleyicinin son hata iletisini döndürür

NumberFormatter::getErrorCode
NumberFormatter::getLocale
NumberFormatter
PHP Manual

NumberFormatter::getErrorMessage

numfmt_get_error_message

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::getErrorMessage -- numfmt_get_error_message — Biçemleyicinin son hata iletisini döndürür

Açıklama

Nesne yönelimli kullanım

string NumberFormatter::getErrorMessage ( void )

Yordamsal kullanım

string numfmt_get_error_message ( NumberFormatter $biçemleyici )

Biçimleyicinin çağrılan son işlevinden dönen hatanın iletisini döndürür.

Değiştirgeler

biçemleyici

NumberFormatter nesnesi.

Dönen Değerler

Biçimleyicinin çalışan son işlevinden dönen hatanın iletisini döndürür.

Örnekler

Örnek 1 - numfmt_get_error_message() örneği

<?php
$fmt = numfmt_create( 'tr_TR', NumberFormatter::DECIMAL );
$data = numfmt_format($fmt, 1234567.891234567890000);
if(intl_is_failure(numfmt_get_error_code($fmt))) {
    report_error("Biçemleyici hatası");
}
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$fmt = new NumberFormatter( 'tr_TR', NumberFormatter::DECIMAL );
$fmt->format(1234567.891234567890000);
if(intl_is_failure($fmt->getErrorCode())) {
    report_error("Biçemleyici hatası");
}
?>

Ayrıca Bakınız

  • numfmt_get_error_code() - Biçemleyicinin son hata numarası ile döner
  • intl_get_error_code() - Son hatanın kodunu döndürür
  • intl_is_failure() - Belirtilen hata kodunun bir başarısızlık göstergesi olup olmadığına bakar

NumberFormatter::getErrorCode
NumberFormatter::getLocale
NumberFormatter


Biçemleyici yerelin ismi ile döner

NumberFormatter::getErrorMessage
NumberFormatter::getPattern
NumberFormatter
PHP Manual

NumberFormatter::getLocale

numfmt_get_locale

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::getLocale -- numfmt_get_locale — Biçemleyici yerelin ismi ile döner

Açıklama

Nesne yönelimli kullanım

string NumberFormatter::getLocale ([ int $tür ] )

Yordamsal kullanım

string numfmt_get_locale ( NumberFormatter $biçemleyici [, int $tür ] )

Biçemleyici yerelin ismi ile döner.

Değiştirgeler

fmt

NumberFormatter nesnesi.

tür

Geçerli yereli Locale::VALID_LOCALE sabitiyle fiili yereli Locale::ACTUAL_LOCALE sabitiyle belirtebilirsiniz. Fiili yerel öntanımlıdır.

Dönen Değerler

Biçemleyici yerelin ismi ile döner.

Örnekler

Örnek 1 - numfmt_get_locale() örneği

<?php
$req     = 'tr_TR_OTTOMAN';
$fmt     = numfmt_create( $req,  NumberFormatter::DECIMAL);
$res_val = numfmt_get_locale( $fmt, Locale::VALID_LOCALE );
$res_act = numfmt_get_locale( $fmt, Locale::ACTUAL_LOCALE );
printf( "İstenen yerel ismi: %s\nGeçerli yerel ismi: %s\nFiili yerel ismi: %s\n",
         $req, $res_val, $res_act );
?>

Yukarıdaki örneğin çıktısı:

İstenen yerel ismi: tr_TR_OTTOMAN
Geçerli yerel ismi: tr_TR
Fiili yerel ismi: tr

Ayrıca Bakınız

  • numfmt_create() - Bir sayı biçemleyici oluşturur
  • numfmt_get_error_code() - Biçemleyicinin son hata numarası ile döner

NumberFormatter::getErrorMessage
NumberFormatter::getPattern
NumberFormatter


biçemleyici tarafından kullanılan kalıp dizgesi ile döner

NumberFormatter::getLocale
NumberFormatter::getSymbol
NumberFormatter
PHP Manual

NumberFormatter::getPattern

numfmt_get_pattern

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::getPattern -- numfmt_get_pattern — biçemleyici tarafından kullanılan kalıp dizgesi ile döner

Açıklama

Nesne yönelimli kullanım

string NumberFormatter::getPattern ( void )

Yordamsal kullanım

string numfmt_get_pattern ( NumberFormatter $biçemleyici )

Biçemleyici tarafından kullanılan kalıp dizgesi ile döner

Değiştirgeler

fmt

NumberFormatter nesnesi.

Dönen Değerler

Bir hata oluşursa FALSE, aksi takdirde biçemleyici tarafından kullanılan kalıp dizgesi ile döner.

Örnekler

Örnek 1 - numfmt_get_pattern() örneği

<?php
$fmt = numfmt_create( 'tr_TR', NumberFormatter::DECIMAL );
echo "Kalıp: ".numfmt_get_pattern($fmt)."\n";
echo numfmt_format($fmt, 1234567.891234567890000)."\n";
numfmt_set_pattern($fmt, "#0.# kg");
echo "Kalıp: ".numfmt_get_pattern($fmt)."\n";
echo numfmt_format($fmt, 1234567.891234567890000)."\n";
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$fmt = new NumberFormatter( 'tr_TR', NumberFormatter::DECIMAL );
echo "Kalıp: ".$fmt->getPattern()."\n";
echo $fmt->format(1234567.891234567890000)."\n";
$fmt->setPattern("#0.# kg");
echo "Kalıp: ".$fmt->getPattern()."\n";
echo $fmt->format(1234567.891234567890000)."\n";
?>

Yukarıdaki örneğin çıktısı:

Kalıp: #,##0.###
1.234.567,891
Kalıp: #0.# kg
1234567,9 kg

Ayrıca Bakınız

  • numfmt_get_error_code() - Biçemleyicinin son hata numarası ile döner
  • numfmt_set_pattern() - Biçemleyici kalıbı tanımlar
  • numfmt_create() - Bir sayı biçemleyici oluşturur

NumberFormatter::getLocale
NumberFormatter::getSymbol
NumberFormatter


Simge değeri ile döner

NumberFormatter::getPattern
NumberFormatter::getTextAttribute
NumberFormatter
PHP Manual

NumberFormatter::getSymbol

numfmt_get_symbol

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::getSymbol -- numfmt_get_symbol — Simge değeri ile döner

Açıklama

Nesne yönelimli kullanım

string NumberFormatter::getSymbol ( int $öznitelik )

Yordamsal kullanım

string numfmt_get_symbol ( NumberFormatter $biçemleyici , int $öznitelik )

Biçemleyici ile ilgili bir simge döndürür. Biçemleyici, bir sayıda yüzde imi gibi yerele bağlı karakterleri ifade eden simgeler kullanır. Bu arayüz, kurala dayalı biçemleyicileri desteklemez.

Değiştirgeler

biçemleyici

NumberFormatter nesnesi.

öznitelik

Biçem simgesi sabitlerinden biri olarak simge belirteci.

Dönen Değerler

Bir hata oluşursa FALSE, aksi takdirde simge dizgesi döner.

Örnekler

Örnek 1 - numfmt_get_symbol() örneği

<?php
$fmt = numfmt_create( 'tr_TR', NumberFormatter::DECIMAL );
echo "Ayraç: ".numfmt_get_symbol($fmt, NumberFormatter::GROUPING_SEPARATOR_SYMBOL)."\n";
echo numfmt_format($fmt, 1234567.891234567890000)."\n";
numfmt_set_symbol($fmt, NumberFormatter::GROUPING_SEPARATOR_SYMBOL, "*");
echo "Ayraç: ".numfmt_get_symbol($fmt, NumberFormatter::GROUPING_SEPARATOR_SYMBOL)."\n";
echo numfmt_format($fmt, 1234567.891234567890000)."\n";
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$fmt = new NumberFormatter( 'tr_TR', NumberFormatter::DECIMAL );
echo "Ayraç: ".$fmt->getSymbol(NumberFormatter::GROUPING_SEPARATOR_SYMBOL)."\n";
echo $fmt->format(1234567.891234567890000)."\n";
$fmt->setSymbol(NumberFormatter::GROUPING_SEPARATOR_SYMBOL, "*");
echo "Ayraç: ".$fmt->getSymbol(NumberFormatter::GROUPING_SEPARATOR_SYMBOL)."\n";
echo $fmt->format(1234567.891234567890000)."\n";
?>

Yukarıdaki örneğin çıktısı:

Ayraç: .
1.234.567,891
Ayraç: *
1*234*567,891

Ayrıca Bakınız

  • numfmt_get_error_code() - Biçemleyicinin son hata numarası ile döner
  • numfmt_set_symbol() - Bir simge değeri tanımlar

NumberFormatter::getPattern
NumberFormatter::getTextAttribute
NumberFormatter


Bir metin öznitelik ile döner

NumberFormatter::getSymbol
NumberFormatter::parseCurrency
NumberFormatter
PHP Manual

NumberFormatter::getTextAttribute

numfmt_get_text_attribute

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::getTextAttribute -- numfmt_get_text_attribute — Bir metin öznitelik ile döner

Açıklama

Nesne yönelimli kullanım

string NumberFormatter::getTextAttribute ( int $öznitelik )

Yordamsal kullanım

string numfmt_get_text_attribute ( NumberFormatter $biçemleyici , int $öznitelik )

Biçemleyici ile ilgili bir metin öznitelik değeri ile döner. Pozitif sayı soneki, bir metin öznitelik örneği olarak verilebilir. Eğer biçimleyici özniteliği anlamazsa U_UNSUPPORTED_ERROR hatası üretilir. Kurala dayalı biçemleyiciler sadece NumberFormatter::DEFAULT_RULESET ve NumberFormatter::PUBLIC_RULESETS kural kümeleridir.

Değiştirgeler

biçemleyici

NumberFormatter nesnesi.

öznitelik

Öznitelik belirteci. Metin öznitelik sabitlerinden biri.

Dönen Değerler

Bir hata oluşursa FALSE, aksi takdirde öznitelik değeri döner.

Örnekler

Örnek 1 - numfmt_get_text_attribute() örneği

<?php
$fmt = numfmt_create( 'tr_TR', NumberFormatter::DECIMAL );
echo "Önek: ".numfmt_get_text_attribute($fmt, NumberFormatter::NEGATIVE_PREFIX)."\n";
echo numfmt_format($fmt, -1234567.891234567890000)."\n";
numfmt_set_text_attribute($fmt, NumberFormatter::NEGATIVE_PREFIX, "EKSİ");
echo "Önek: ".numfmt_get_text_attribute($fmt, NumberFormatter::NEGATIVE_PREFIX)."\n";
echo numfmt_format($fmt, -1234567.891234567890000)."\n";
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$fmt = new NumberFormatter( 'tr_TR', NumberFormatter::DECIMAL );
echo "Önek: ".$fmt->getTextAttribute(NumberFormatter::NEGATIVE_PREFIX)."\n";
echo $fmt->format(-1234567.891234567890000)."\n";
$fmt->setTextAttribute(NumberFormatter::NEGATIVE_PREFIX, "EKSİ");
echo "Önek: ".$fmt->getTextAttribute(NumberFormatter::NEGATIVE_PREFIX)."\n";
echo $fmt->format(-1234567.891234567890000)."\n";
?>

Yukarıdaki örneğin çıktısı:

Önek: -
-1.234.567,891
Önek: EKSİ
EKSİ1.234.567,891

Ayrıca Bakınız

  • numfmt_get_error_code() - Biçemleyicinin son hata numarası ile döner
  • numfmt_get_attribute() - Bir sayısal öznitelikle döner
  • numfmt_set_text_attribute() - Bir metin öznitelik tanımlar

NumberFormatter::getSymbol
NumberFormatter::parseCurrency
NumberFormatter


Bir para gösteriminin sayısal değeri ile döner

NumberFormatter::getTextAttribute
NumberFormatter::parse
NumberFormatter
PHP Manual

NumberFormatter::parseCurrency

numfmt_parse_currency

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::parseCurrency -- numfmt_parse_currency — Bir para gösteriminin sayısal değeri ile döner

Açıklama

Nesne yönelimli kullanım

float NumberFormatter::parseCurrency ( string $değer , string &$dizge [, int &$konum ] )

Yordamsal kullanım

float numfmt_parse_currency ( NumberFormatter $biçemleyici , string $değer , string &$para_simgesi [, int &$konum ] )

Geçerli biçemleyiciyi kullanarak, bir para dizgesini double türünde bir sayıya ve para birimine dönüştürür.

Değiştirgeler

biçemleyici

NumberFormatter nesnesi.

para_simgesi

Para biriminin döndürüleceği değiştirge (3 harflik ISO 4217 para birimi).

konum

Çözümlemenin başlatılacağı dizge konumu. İşlev döndüğünde bu değiştirge çözümlemenin bittiği konumu gösterir.

Dönen Değerler

Bir hata oluşursa FALSE, aksi takdirde dönüştürülen sayı değeri döner.

Örnekler

Örnek 1 - numfmt_parse_currency() örneği

<?php
$fmt = numfmt_create( 'tr_TR', NumberFormatter::CURRENCY );
$num = "1.234.567,89 $";
echo numfmt_parse_currency($fmt, $num, $curr)." $curr paramız var.\n";
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$fmt = new NumberFormatter( 'tr_TR', NumberFormatter::CURRENCY );
$num = "1.234.567,89 $";
echo $fmt->parseCurrency($num, $curr)." $curr paramız var.\n";
?>

Yukarıdaki örneğin çıktısı:

1234567.89 USD paramız var.

Ayrıca Bakınız

  • numfmt_get_error_code() - Biçemleyicinin son hata numarası ile döner
  • numfmt_parse() - Bir sayı dizgesini sayıya dönüştürür
  • numfmt_format_currency() - Bir para değerini biçemler

NumberFormatter::getTextAttribute
NumberFormatter::parse
NumberFormatter


Bir sayı dizgesini sayıya dönüştürür

NumberFormatter::parseCurrency
NumberFormatter::setAttribute
NumberFormatter
PHP Manual

NumberFormatter::parse

numfmt_parse

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::parse -- numfmt_parse — Bir sayı dizgesini sayıya dönüştürür

Açıklama

Nesne yönelimli kullanım

mixed NumberFormatter::parse ( string $değer [, int $tür [, int &$konum ]] )

Yordamsal kullanım

mixed numfmt_parse ( NumberFormatter $biçemleyici , string $değer [, int $tür [, int &$konum ]] )

Geçerli biçemleyici kurallarına uygun olarak bir dizgeyi bir sayıya çevirir.

Değiştirgeler

fmt

NumberFormatter nesnesi.

tür

Kullanılacak biçemleme türü. Öntanımlı olarak, NumberFormatter::TYPE_DOUBLE kullanılır.

konum

Çözümlemenin başlatılacağı dizge konumu. İşlev döndüğünde bu değiştirge çözümlemenin bittiği konumu gösterir.

Dönen Değerler

Bir hata oluşursa FALSE, aksi takdirde dönüştürülen sayı değeri döner.

Örnekler

Örnek 1 - numfmt_parse() örneği

<?php
$fmt = numfmt_create( 'tr_TR', NumberFormatter::DECIMAL );
$num = "1.234.567,891";
echo numfmt_parse($fmt, $num)."\n";
echo numfmt_parse($fmt, $num, NumberFormatter::TYPE_INT32)."\n";
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$fmt = new NumberFormatter( 'tr_TR', NumberFormatter::DECIMAL );
$num = "1.234.567,891";
echo $fmt->parse($num)."\n";
echo $fmt->parse($num, NumberFormatter::TYPE_INT32)."\n";
?>

Yukarıdaki örneğin çıktısı:

1234567.891
1234567

Ayrıca Bakınız

  • numfmt_get_error_code() - Biçemleyicinin son hata numarası ile döner
  • numfmt_format() - Bir sayıyı biçemler
  • numfmt_parse_currency() - Bir para gösteriminin sayısal değeri ile döner

NumberFormatter::parseCurrency
NumberFormatter::setAttribute
NumberFormatter


Bir öznitelik tanımlar

NumberFormatter::parse
NumberFormatter::setPattern
NumberFormatter
PHP Manual

NumberFormatter::setAttribute

numfmt_set_attribute

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::setAttribute -- numfmt_set_attribute — Bir öznitelik tanımlar

Açıklama

Nesne yönelimli kullanım

bool NumberFormatter::setAttribute ( int $öznitelik , int $değer )

Yordamsal kullanım

bool numfmt_set_attribute ( NumberFormatter $biçemleyici , int $öznitelik , int $değer )

Biçemleyici ile ilgili sayısal bir özniteliğe bir değer tanımlar. Tamsayı hanelerin sayısı, sayısal bir öznitelik örneği olarak verilebilir.

Değiştirgeler

biçemleyici

NumberFormatter nesnesi.

öznitelik

Öznitelik belirteci; sayısal öznitelik sabitlerinden biri.

değer

Öznitelik değeri.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - numfmt_set_attribute() örneği

<?php
$fmt = numfmt_create( 'tr_TR', NumberFormatter::DECIMAL );
echo "Hane sayısı: ".numfmt_get_attribute($fmt, NumberFormatter::MAX_FRACTION_DIGITS)."\n";
echo numfmt_format($fmt, 1234567.891234567890000)."\n";
numfmt_set_attribute($fmt, NumberFormatter::MAX_FRACTION_DIGITS, 2);
echo "Hane sayısı: ".numfmt_get_attribute($fmt, NumberFormatter::MAX_FRACTION_DIGITS)."\n";
echo numfmt_format($fmt, 1234567.891234567890000)."\n";
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$fmt = new NumberFormatter( 'tr_TR', NumberFormatter::DECIMAL );
echo "Hane sayısı: ".$fmt->getAttribute(NumberFormatter::MAX_FRACTION_DIGITS)."\n";
echo $fmt->format(1234567.891234567890000)."\n";
$fmt->setAttribute(NumberFormatter::MAX_FRACTION_DIGITS, 2);
echo "Hane sayısı: ".$fmt->getAttribute(NumberFormatter::MAX_FRACTION_DIGITS)."\n";
echo $fmt->format(1234567.891234567890000)."\n";
?>

Yukarıdaki örneğin çıktısı:

Hane sayısı: 3
1.234.567,891
Hane sayısı: 2
1.234.567,89

Ayrıca Bakınız

  • numfmt_get_error_code() - Biçemleyicinin son hata numarası ile döner
  • numfmt_get_attribute() - Bir sayısal öznitelikle döner
  • numfmt_set_text_attribute() - Bir metin öznitelik tanımlar

NumberFormatter::parse
NumberFormatter::setPattern
NumberFormatter


Biçemleyici kalıbı tanımlar

NumberFormatter::setAttribute
NumberFormatter::setSymbol
NumberFormatter
PHP Manual

NumberFormatter::setPattern

numfmt_set_pattern

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::setPattern -- numfmt_set_pattern — Biçemleyici kalıbı tanımlar

Açıklama

Nesne yönelimli kullanım

bool NumberFormatter::setPattern ( string $kalıp )

Yordamsal kullanım

bool numfmt_set_pattern ( NumberFormatter $biçemleyici , string $kalıp )

Biçemleyici tarafından kullanılan kalıbı tanımlar. Kurala dayalı biçemleyicilerde kullanılamaz.

Değiştirgeler

biçemleyici

NumberFormatter nesnesi.

kalıp
numfmt_set_pattern() tarafından desteklenen kalıp karakterleri
simge | Konum | Yerelleşti rilebilir mi | Açıklama
0 | Rakam | Evet | Rakam
1-9 | Rakam | Evet | Yuvarlama belirten '1'den '9'a kadar rakam
@ Rakam Hayır Anlamlı hane.
# Rakam Evet Rakam; sıfır yokluk ifade eder.
. Rakam Evet Ondalık veya kuruş ayracı.
- Rakam Evet Eksi imi.
, Rakam Evet Gruplama ayracı.
E | Rakam | Evet | Bilimsel gösterimde sayı ile üssü ayırır. Önek veya sonek içinde tırnak içine alınmaz.
+ Üs Evet Yerelleştirilmiş artı imi ile potitif üs için önek. Önek veya sonek içinde tırnak içine alınmaz.
; Alt kalıplar arasında Evet Pozitif ve negatif alt kalıpları ayırır.
% Önek veya sonek Evet 100 ile çarpma veya yüzde gösterimi.
‰ (\u2030) | Önek veya sonek | Evet | 1000 ile çarpma veya binde gösterimi.
¤ (\u00A4) | Önek veya sonek | Hayır | Tek olursa yerel para simgesi ile, çift olursa uluslararası para simgesi ile değiştirilir. Bu simgenin bulunduğu bir kalıpta ondalık ayraç yerine kuruş ayracı kullanılır.
' Önek veya sonek Hayır Önek veya sonek içinde özel karakterleri tırnak içine almak için kullanılır. Örneğin, "'#'#" kalıbı 123 sayısını "#123" olarak biçemler. Tek tırnağın kendisini belirtmek için "# o''clock" örneğindeki gibi kendisiyle öncelenir.
* Önek veya sonek Evet Dolgu karakterini önceler.

Ayrıca, » ICU DecimalFormat belgesinden de yararlanılabilir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 numfmt_set_pattern() örneği

<?php
$fmt = numfmt_create( 'tr_TR', NumberFormatter::DECIMAL );
echo "Kalıp: ".numfmt_get_pattern($fmt)."\n";
echo numfmt_format($fmt, 1234567.891234567890000)."\n";
numfmt_set_pattern($fmt, "#0.# kg");
echo "Kalıp: ".numfmt_get_pattern($fmt)."\n";
echo numfmt_format($fmt, 1234567.891234567890000)."\n";
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$fmt = new NumberFormatter( 'tr_TR', NumberFormatter::DECIMAL );
echo "Kalıp: ".$fmt->getPattern()."\n";
echo $fmt->format(1234567.891234567890000)."\n";
$fmt->setPattern("#0.# kg");
echo "Kalıp: ".$fmt->getPattern()."\n";
echo $fmt->format(1234567.891234567890000)."\n";
?>

Yukarıdaki örneğin çıktısı:

Kalıp: #,##0.###
1.234.567,891
Kalıp: #0.# kg
1234567,9 kg

Ayrıca Bakınız

  • numfmt_get_error_code() - Biçemleyicinin son hata numarası ile döner
  • numfmt_create() - Bir sayı biçemleyici oluşturur
  • numfmt_get_pattern() - biçemleyici tarafından kullanılan kalıp dizgesi ile döner

NumberFormatter::setAttribute
NumberFormatter::setSymbol
NumberFormatter


Bir simge değeri tanımlar

NumberFormatter::setPattern
NumberFormatter::setTextAttribute
NumberFormatter
PHP Manual

NumberFormatter::setSymbol

numfmt_set_symbol

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::setSymbol -- numfmt_set_symbol — Bir simge değeri tanımlar

Açıklama

Nesne yönelimli kullanım

bool NumberFormatter::setSymbol ( int $öznitelik , string $değer )

Yordamsal kullanım

bool numfmt_set_symbol ( NumberFormatter $biçemleyici , int $öznitelik , string $değer )

Bir biçemleyici ile ilgili bir simge tanımlar. Biçemleyici, bir sayıda yüzde imi gibi yerele bağlı karakterleri ifade eden simgeler kullanır. Bu arayüz, kurala dayalı biçemleyicileri desteklemez.

Değiştirgeler

biçemleyici

NumberFormatter nesnesi.

öznitelik

Biçem simgesi sabitlerinden biri olarak simge belirteci.

değer

Simge için metin.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - numfmt_set_symbol() örneği

<?php
$fmt = numfmt_create( 'tr_TR', NumberFormatter::DECIMAL );
echo "Ayraç: ".numfmt_get_symbol($fmt, NumberFormatter::GROUPING_SEPARATOR_SYMBOL)."\n";
echo numfmt_format($fmt, 1234567.891234567890000)."\n";
numfmt_set_symbol($fmt, NumberFormatter::GROUPING_SEPARATOR_SYMBOL, "*");
echo "Ayraç: ".numfmt_get_symbol($fmt, NumberFormatter::GROUPING_SEPARATOR_SYMBOL)."\n";
echo numfmt_format($fmt, 1234567.891234567890000)."\n";
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$fmt = new NumberFormatter( 'tr_TR', NumberFormatter::DECIMAL );
echo "Ayraç: ".$fmt->getSymbol(NumberFormatter::GROUPING_SEPARATOR_SYMBOL)."\n";
echo $fmt->format(1234567.891234567890000)."\n";
$fmt->setSymbol(NumberFormatter::GROUPING_SEPARATOR_SYMBOL, "*");
echo "Ayraç: ".$fmt->getSymbol(NumberFormatter::GROUPING_SEPARATOR_SYMBOL)."\n";
echo $fmt->format(1234567.891234567890000)."\n";
?>

Yukarıdaki örneğin çıktısı:

Ayraç: .
1.234.567,891
Ayraç: *
1*234*567,891

Ayrıca Bakınız

  • numfmt_get_error_code() - Biçemleyicinin son hata numarası ile döner
  • numfmt_get_symbol() - Simge değeri ile döner

NumberFormatter::setPattern
NumberFormatter::setTextAttribute
NumberFormatter


Bir metin öznitelik tanımlar

NumberFormatter::setSymbol
Locale
NumberFormatter
PHP Manual

NumberFormatter::setTextAttribute

numfmt_set_text_attribute

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

NumberFormatter::setTextAttribute -- numfmt_set_text_attribute — Bir metin öznitelik tanımlar

Açıklama

Nesne yönelimli kullanım

bool NumberFormatter::setTextAttribute ( int $öznitelik , string $değer )

Yordamsal kullanım

bool numfmt_set_text_attribute ( NumberFormatter $biçemleyici , int $öznitelik , string $değer )

Biçemleyici ile ilgili bir metin tanımlar. Bir metin özniteliğe bir örnek olarak pozitif sayı soneki gösterilebilir. Eğer biçemleyici özniteliği anlamazsa U_UNSUPPORTED_ERROR hatası üretilir. Kurala dayalı biçemleyiciler sadece NumberFormatter::DEFAULT_RULESET ve NumberFormatter::PUBLIC_RULESETS kural kümeleridir.

Değiştirgeler

biçemleyici

NumberFormatter nesnesi.

öznitelik

Öznitelik belirteci. metin öznitelik sabitlerinden biri.

değer

Öznitelik değeri için metin.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Yordamsal kullanım örneği

<?php
$fmt = numfmt_create( 'tr_TR', NumberFormatter::DECIMAL );
echo "Önek: ".numfmt_get_text_attribute($fmt, NumberFormatter::NEGATIVE_PREFIX)."\n";
echo numfmt_format($fmt, -1234567.891234567890000)."\n";
numfmt_set_text_attribute($fmt, NumberFormatter::NEGATIVE_PREFIX, "EKSİ");
echo "Önek: ".numfmt_get_text_attribute($fmt, NumberFormatter::NEGATIVE_PREFIX)."\n";
echo numfmt_format($fmt, -1234567.891234567890000)."\n";
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$fmt = new NumberFormatter( 'tr_TR', NumberFormatter::DECIMAL );
echo "Önek: ".$fmt->getTextAttribute(NumberFormatter::NEGATIVE_PREFIX)."\n";
echo $fmt->format(-1234567.891234567890000)."\n";
$fmt->setTextAttribute(NumberFormatter::NEGATIVE_PREFIX, "EKSİ");
echo "Önek: ".$fmt->getTextAttribute(NumberFormatter::NEGATIVE_PREFIX)."\n";
echo $fmt->format(-1234567.891234567890000)."\n";
?>

Yukarıdaki örneğin çıktısı:

Önek: -
-1.234.567,891
Önek: EKSİ
EKSİ1.234.567,891

Ayrıca Bakınız

  • numfmt_get_error_code() - Biçemleyicinin son hata numarası ile döner
  • numfmt_get_text_attribute() - Bir metin öznitelik ile döner
  • numfmt_set_attribute() - Bir öznitelik tanımlar

NumberFormatter::setSymbol
Locale
NumberFormatter


Locale sınıfı

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Giriş

Bir yerel (Locale), API'den dili, kültürü ve bölgeye özge özellikleri öğrenmek için kullanılan bir betimleyicidir. PHP yerelleri ICU (ve birçok Unix benzeri sistem üreticisi, Mac, Java, vs.) tarafından kullanılan CLDR yerelleriyle aynı yöntemle düzenlenip betimlenirler. Yereller, (alt çizgi yerine tire kullanılan) RFC 4646 dil yaftalarına ek olarak daha geleneksel olan alt çizgi kullanan betimleyiciler kullanılarak da betimlenebilir. Aksi belirtilmedikçe bu sınıftaki işlevler her iki gösterim biçemine de duyarlıdır.

Yerel betimleyicileri için örnekler:

  • tr-TR (Türkçe, Türkiye)
  • zh-Hant-TW (Çince, Geleneksel Yazı, Tayvan)
  • fr-CA, fr-FR (Kanada Fransızcası ve Fransa Fransızcası)

Locale sınıfı (ve ilgili yordamsal işlevler) yerel betimleyicileri ile etkileşim, bir betimleyicinin iyi biçimliliğini, geçerliliğini doğrulama, vs. için kullanılırlar. UAX #35'teki (ve ICU tarafından miras alınan) CLDR tarafından kullanılan eklentiler ICU'da da normal olarak geçerlidir ve kullanılırlar.

Locale sınıfı bir nesne olarak örneklenemez. Sağlanan tüm işlev/yöntemler duruktur.

Boş veya NULL dizge "kök" yerel olarak ele alınır ve CLDR'de "en_US_POSIX" yereline denktir. Dil yaftaları (ve dolayısıyla yerel betimleyicileri) harf büyüklüğüne duyarsızdır. Belirtimle harf eşleştirmesi yapacak bir meşrulaştırma işlevi mevcuttur.

Sınıf Sözdizimi

Locale {
/* Yöntemler */
static string acceptFromHttp ( string $başlık )
public static string canonicalize ( string $locale )
static string composeLocale ( array $alt_yaftalar )
static bool filterMatches ( string $dil_yaftası , string $yerel [, bool $meşru = false ] )
static array getAllVariants ( string $yerel )
static string getDefault ( void )
static string getDisplayLanguage ( string $dil_yereli [, string $adlandırma_yereli ] )
static string getDisplayName ( string $hedef_yerel [, string $adlandırma_yereli ] )
static string getDisplayRegion ( string $ülke_yereli [, string $adlandırma_yereli ] )
static string getDisplayScript ( string $yazı_yereli [, string $adlandırma_yereli ] )
static string getDisplayVariant ( string $lehçe_yereli [, string $adlandırma_yereli ] )
static array getKeywords ( string $yerel )
static string getPrimaryLanguage ( string $yerel )
static string getRegion ( string $yerel )
static string getScript ( string $yerel )
static string lookup ( array $dil_yaftası , string $yerel [, bool $meşru = false [, string $öntanımlı ]] )
static array parseLocale ( string $yerel )
static bool setDefault ( string $yerel )
}

Öntanımlı Sabitler

Locale::DEFAULT_LOCALE (null)
NumberFormatter gibi yereli etkileyen çeşitli sınıfların çeşitli yöntemlerinde yerel değiştirgesi olarak kullanılır. Bu sabit, bu yöntemlerin öntanımlı yereli kullanmasını sağlar.

Bu sabitler çeşitli sınıfların getLocalte yöntemleri için yerel seçimlerini belirler.

Locale::ACTUAL_LOCALE (string)
Asıl verinin geldiği yereldir.
Locale::VALID_LOCALE (string)
ICU tarafından desteklenen en geçerli yereldir.

Bu sabitler, yerellerin nasıl çözümlenip oluşturulduğunu tanımlar. Bunların, locale_compose() işlevinin dizi değiştirgesinde anahtar olarak kullanılması gerekir ve locale_parse() işlevinden dönen ilişkisel dizinin anahtarlarıdırlar.

Locale::LANG_TAG (string)
Dil alt yaftası
Locale::EXTLANG_TAG (string)
Ek dil alt yaftası
Locale::SCRIPT_TAG (string)
Yazı alt yaftası
Locale::REGION_TAG (string)
Bölge yaftası
Locale::VARIANT_TAG (string)
Lehçe alt yaftası
Locale::GRANDFATHERED_LANG_TAG (string)
Ebeveyn dil alt yaftası
Locale::PRIVATE_TAG (string)
Özel alt yafta

Ayrıca Bakınız

  • » RFC 4646 - Dilleri Betimleyen Yaftalar
  • » RFC 4647 - Dil Yaftalarıyla Eşleşme
  • » Evrenkod CLDR Projesi: Ortak Yerel Veri Deposu
  • » IANA Dil Alt Yaftaları Kütüğü
  • » ICU Kullanıcı Kılavuzu - Yerel
  • » ICU Locale API'si

İçindekiler

  • Locale::acceptFromHttp — HTTP "Accept-Language" başlığıyla en iyi eşleşen yereli bulmaya çalışır
  • Locale::canonicalize — Canonicalize the locale string
  • Locale::composeLocale — Doğru sıralanmış yerel ile döner
  • Locale::filterMatches — Bir dil yaftasının bir yerelle eşleşip eşleşmediğine bakar
  • Locale::getAllVariants — Girdi yerelindeki tüm lehçeleri döndürür
  • Locale::getDefault — Öntanımlı yerel değerini döndürür
  • Locale::getDisplayLanguage — Girdi yerelindeki anadil kodunun yerelleştirilmiş ismini döndürür
  • Locale::getDisplayName — Girdi yerelinin yerelleştirilmiş ismini döndürür
  • Locale::getDisplayRegion — Girdi yereli için yerelleştirilmiş ülke ismini döndürür
  • Locale::getDisplayScript — Girdi yereli yazı türünün yerelleştirilmiş ismini döndürür
  • Locale::getDisplayVariant — Girdi yereli lehçesinin yerelleştirilmiş ismini döndürür
  • Locale::getKeywords — Girdi yerelindeki anahtar sözcükleri döndürür
  • Locale::getPrimaryLanguage — Girdi yerelinden anadil kodunu döndürür
  • Locale::getRegion — Girdi yerelinden ülke kodunu döndürür
  • Locale::getScript — Girdi yereli için yazı yaftasını döndürür
  • Locale::lookup — En iyi eşleşen dili bulmak için dil yaftası listesini araştırır
  • Locale::parseLocale — Yerel yaftasını oluşturan alt yaftaları içeren bir dizi döndürür
  • Locale::setDefault — Öntanımlı çalışma anı yerelini tanımlar
NumberFormatter::setTextAttribute
Locale::acceptFromHttp
intl


HTTP "Accept-Language" başlığıyla en iyi eşleşen yereli bulmaya çalışır

Locale
Locale::canonicalize
Locale
PHP Manual

Locale::acceptFromHttp

locale_accept_from_http

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::acceptFromHttp -- locale_accept_from_http — HTTP "Accept-Language" başlığıyla en iyi eşleşen yereli bulmaya çalışır

Açıklama

Nesne yönelimli kullanım

static string Locale::acceptFromHttp ( string $başlık )

Yordamsal kullanım

string locale_accept_from_http ( string $başlık )

HTTP "Accept-Language" başlığında talep edilen dillerle en uyumlu yereli bulmaya çalışır.

Değiştirgeler

başlık

"Accept-Language" başlığını RFC 2616'daki biçeme uygun olarak içeren dizge .

Dönen Değerler

Başlıkla eşleşen yerel.

Örnekler

Örnek 1 - locale_accept_from_http() örneği

<?php
$locale = locale_accept_from_http($_SERVER['HTTP_ACCEPT_LANGUAGE']);
echo $locale;
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$locale = Locale::acceptFromHttp($_SERVER['HTTP_ACCEPT_LANGUAGE']);
echo $locale;
?>

Yukarıdaki örneğin çıktısı:

tr_TR

Ayrıca Bakınız

  • locale_lookup() - En iyi eşleşen dili bulmak için dil yaftası listesini araştırır

Locale
Locale::canonicalize
Locale


Canonicalize the locale string

Locale::acceptFromHttp
Locale::composeLocale
Locale
PHP Manual

Locale::canonicalize

locale_canonicalize

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::canonicalize -- locale_canonicalize — Canonicalize the locale string

Açıklama

public static string Locale::canonicalize ( string $locale )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

locale

Dönen Değerler

Locale::acceptFromHttp
Locale::composeLocale
Locale


Doğru sıralanmış yerel ile döner

Locale::canonicalize
Locale::filterMatches
Locale
PHP Manual

Locale::composeLocale

locale_compose

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::composeLocale -- locale_compose — Doğru sıralanmış yerel ile döner

Açıklama

Nesne yönelimli kullanım

static string Locale::composeLocale ( array $alt_yaftalar )

Yordamsal kullanım

string locale_compose ( array $alt_yaftalar )

Anahtarların yerel alt yaftalarının betimleyicileri, değerlerin ise bu alt yaftalarla ilişkili değerler olduğu bir ilişkisel dizi ile belirtilen yereli bu alt yaftaları doğru sırayla birleştirerek oluşturur.

Değiştirgeler

alt_yaftalar

Anahtarların yerel alt yaftalarının betimleyicileri, değerlerin ise bu alt yaftalarla ilişkili değerler olduğu bir ilişkisel dizi.

Bilginize:

'extlang' anahtarı en fazla 3 değer alabilirken 'variant' ve 'private' alt yaftaları en fazla 15 değer alabilir ve 0-14 indislerine sahip olabilir. Bu bakımdan, girdi dizisindeki anahtarlar variant0, variant1, ...,variant14 olabilir. Döndürülen yerele bu yaftalar sonek olarak bu sırayla yerleştirilir.

'variant', 'private' ve 'extlang' için çoklu değerler belli bir anahtarın ('variant' gibi) alt dizisi olarak belirtilebileceği gibi 'variant0', 'variant1', şeklinde ayrı ayrı anahtar-değer çiftleriyle de belirtilebilir.

Dönen Değerler

Oluşturulan yerel.

Örnekler

Örnek 1 - locale_compose() örneği

<?php
$arr = array(
    'language'=>'en' ,
    'script'  =>'Hans' ,
    'region'  =>'CN',
    'variant2'=>'rozaj' ,
    'variant1'=>'nedis' ,
    'private1'=>'prv1' ,
    'private2'=>'prv2'
);
echo locale_compose( $arr );
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$arr = array(
    'language'=>'en' ,
    'script'  =>'Hans' ,
    'region'  =>'CN',
    'variant2'=>'rozaj' ,
    'variant1'=>'nedis' ,
    'private1'=>'prv1' ,
    'private2'=>'prv2'
);
echo Locale::composeLocale( $arr );
?>

Yukarıdaki örneğin çıktısı:

Locale: en_Hans_CN_nedis_rozaj_x_prv1_prv2

Ayrıca Bakınız

  • locale_parse() - Yerel yaftasını oluşturan alt yaftaları içeren bir dizi döndürür

Locale::canonicalize
Locale::filterMatches
Locale


Bir dil yaftasının bir yerelle eşleşip eşleşmediğine bakar

Locale::composeLocale
Locale::getAllVariants
Locale
PHP Manual

Locale::filterMatches

locale_filter_matches

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::filterMatches -- locale_filter_matches — Bir dil yaftasının bir yerelle eşleşip eşleşmediğine bakar

Açıklama

Nesne yönelimli kullanım

static bool Locale::filterMatches ( string $dil_yaftası , string $yerel [, bool $meşru = false ] )

Yordamsal kullanım

bool locale_filter_matches ( string $dil_yaftası , string $yerel [, bool $meşru = false ] )

RFC 4647'nin temel süzme algoritmasına göre bir dil yaftasının bir yerelle eşleşip eşleşmediğine bakar.

Değiştirgeler

dil_yaftası

Sınanacak dil yaftası.

yerel

Dil yaftasının sınanacağı yerel.

meşru

TRUE ise değiştirgeler eşleştirilmeden önce meşru biçeme dönüştürülür.

Dönen Değerler

dil_yaftası ile yerel eşleşirse TRUE eşleşmezse FALSE.

Örnekler

Örnek 1 - locale_filter_matches() örneği

<?php
echo (locale_filter_matches('de-DEVA','de-DE', false)) ?
          "Eşleşir" : "Eşleşmez";
echo '; ';
echo (locale_filter_matches('de-DE_1996','de-DE', false)) ?
          "Eşleşir" : "Eşleşmez";
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
echo (Locale::filterMatches('de-DEVA','de-DE', false)) ?
          "Eşleşir" : "Eşleşmez";
echo '; ';
echo (Locale::filterMatches('de-DE-1996','de-DE', false)) ?
          "Eşleşir" : "Eşleşmez";
?>

Yukarıdaki örneğin çıktısı:

Eşleşmez; Eşleşir

Ayrıca Bakınız

  • locale_lookup() - En iyi eşleşen dili bulmak için dil yaftası listesini araştırır

Locale::composeLocale
Locale::getAllVariants
Locale


Girdi yerelindeki tüm lehçeleri döndürür

Locale::filterMatches
Locale::getDefault
Locale
PHP Manual

Locale::getAllVariants

locale_get_all_variants

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::getAllVariants -- locale_get_all_variants — Girdi yerelindeki tüm lehçeleri döndürür

Açıklama

Nesne yönelimli kullanım

static array Locale::getAllVariants ( string $yerel )

Yordamsal kullanım

array locale_get_all_variants ( string $yerel )

Girdi yerelindeki tüm lehçeleri döndürür.

Değiştirgeler

yerel

Lehçelerin çıkarılacağı yerel.

Dönen Değerler

Varsa girdi yerelindeki tüm lehçeler bir dizi içinde döner, yoksa NULL döner.

Örnekler

Örnek 1 - locale_get_all_variants() örneği

<?php
$arr = locale_get_all_variants('sl_IT_NEDIS_ROJAZ_1901');
var_export( $arr );
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$arr = Locale::getAllVariants('sl_IT_NEDIS_ROJAZ_1901');
var_export( $arr );
?>

Yukarıdaki örneğin çıktısı:

array (
    0 => 'NEDIS',
    1 => 'ROJAZ',
    2 => '1901',
)

Ayrıca Bakınız

  • locale_get_primary_language() - Girdi yerelinden anadil kodunu döndürür
  • locale_get_script() - Girdi yereli için yazı yaftasını döndürür
  • locale_get_region() - Girdi yerelinden ülke kodunu döndürür

Locale::filterMatches
Locale::getDefault
Locale


Öntanımlı yerel değerini döndürür

Locale::getAllVariants
Locale::getDisplayLanguage
Locale
PHP Manual

Locale::getDefault

locale_get_default

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::getDefault -- locale_get_default — Öntanımlı yerel değerini döndürür

Açıklama

Nesne yönelimli kullanım

static string Locale::getDefault ( void )

Yordamsal kullanım

string locale_get_default ( void )

Küresel 'default_locale' değişkenindeki öntanımlı yerel değerini döndürür. Bu değer PHP yapılandırması sırasında php.ini dosyasında intl.default_locale yönergesine atanır. Öntanımlı yerel, php.ini dosyasında belirtilmemişse ICU'nun uloc_getDefault() işlevi kullanılır.

Değiştirgeler

Dönen Değerler

Geçerli çalışma anı yereli.

Örnekler

Örnek 1 - locale_get_default() örneği

<?php
ini_set('intl.default_locale', 'tr-TR');
echo locale_get_default();
echo '; ';
locale_set_default('en');
echo locale_get_default();
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
ini_set('intl.default_locale', 'tr-TR');
echo Locale::getDefault();
echo '; ';
Locale::setDefault('en');
echo Locale::getDefault();
?>

Yukarıdaki örneğin çıktısı:

tr-TR; en

Ayrıca Bakınız

  • locale_set_default() - Öntanımlı çalışma anı yerelini tanımlar

Locale::getAllVariants
Locale::getDisplayLanguage
Locale


Girdi yerelindeki anadil kodunun yerelleştirilmiş ismini döndürür

Locale::getDefault
Locale::getDisplayName
Locale
PHP Manual

Locale::getDisplayLanguage

locale_get_display_language

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::getDisplayLanguage -- locale_get_display_language — Girdi yerelindeki anadil kodunun yerelleştirilmiş ismini döndürür

Açıklama

Nesne yönelimli kullanım

static string Locale::getDisplayLanguage ( string $dil_yereli [, string $adlandırma_yereli ] )

Yordamsal kullanım

string locale_get_display_language ( string $dil_yereli [, string $adlandırma_yereli ] )

Girdi yerelindeki anadil kodunun yerelleştirilmiş ismini döndürür. Öntanımlı yerel kullanılmışsa NULL döner.

Değiştirgeler

dil_yereli

Anadil adı döndürülecek yerel.

adlandırma_yereli

İsteğe bağlı olarak anadil isminin gösteriminde kullanılacak yerel.

Dönen Değerler

hedef_yerel ile belirtilen yerelin anadil kodunun adlandırma_yereli ile belirtilen yereldeki ismini döndürür.

Örnekler

Örnek 1 - locale_get_display_language() örneği

<?php
echo locale_get_display_language('sl-Latn-IT-nedis', 'en');
echo ";\n";
echo locale_get_display_language('sl-Latn-IT-nedis', 'fr');
echo ";\n";
echo locale_get_display_language('sl-Latn-IT-nedis', 'tr');
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
echo Locale::getDisplayLanguage('sl-Latn-IT-nedis', 'en');
echo ";\n";
echo Locale::getDisplayLanguage('sl-Latn-IT-nedis', 'fr');
echo ";\n";
echo Locale::getDisplayLanguage('sl-Latn-IT-nedis', 'tr');
?>

Yukarıdaki örneğin çıktısı:

Slovenian;
slovène;
Slovence

Ayrıca Bakınız

  • locale_get_display_name() - Girdi yerelinin yerelleştirilmiş ismini döndürür
  • locale_get_display_script() - Girdi yereli yazı türünün yerelleştirilmiş ismini döndürür
  • locale_get_display_region() - Girdi yereli için yerelleştirilmiş ülke ismini döndürür
  • locale_get_display_variant() - Girdi yereli lehçesinin yerelleştirilmiş ismini döndürür

Locale::getDefault
Locale::getDisplayName
Locale


Girdi yerelinin yerelleştirilmiş ismini döndürür

Locale::getDisplayLanguage
Locale::getDisplayRegion
Locale
PHP Manual

Locale::getDisplayName

locale_get_display_name

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::getDisplayName -- locale_get_display_name — Girdi yerelinin yerelleştirilmiş ismini döndürür

Açıklama

Nesne yönelimli kullanım

static string Locale::getDisplayName ( string $hedef_yerel [, string $adlandırma_yereli ] )

Yordamsal kullanım

string locale_get_display_name ( string $hedef_yerel [, string $adlandırma_yereli ] )

Girdi yerelinin yerelleştirilmiş ismini döndürür. Öntanımlı yerel kullanılmışsa NULL döner.

Değiştirgeler

hedef_yerel

İsmi gösterilecek yerel.

adlandırma_yereli

İsteğe bağlı olarak yerel isminin gösteriminde kullanılacak yerel.

Dönen Değerler

hedef_yerel ile belirtilen yerelin adlandırma_yereli ile belirtilen yereldeki ismini döndürür.

Örnekler

Örnek 1 - locale_get_display_name() örneği

<?php
echo locale_get_display_name('sl-Latn-IT-nedis', 'en');
echo ";\n";
echo locale_get_display_name('sl-Latn-IT-nedis', 'fr');
echo ";\n";
echo locale_get_display_name('sl-Latn-IT-nedis', 'tr');
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
echo Locale::getDisplayName('sl-Latn-IT-nedis', 'en');
echo ";\n";
echo Locale::getDisplayName('sl-Latn-IT-nedis', 'fr');
echo ";\n";
echo Locale::getDisplayName('sl-Latn-IT-nedis', 'tr');
?>

Yukarıdaki örneğin çıktısı:

Slovenian (Latin, Italy, Natisone dialect);
slovène (latin, Italie, dialecte de Natisone);
Slovence (Latin, İtalya, Natisone Lehçesi)

Ayrıca Bakınız

  • locale_get_display_language() - Girdi yerelindeki anadil kodunun yerelleştirilmiş ismini döndürür
  • locale_get_display_script() - Girdi yereli yazı türünün yerelleştirilmiş ismini döndürür
  • locale_get_display_region() - Girdi yereli için yerelleştirilmiş ülke ismini döndürür
  • locale_get_display_variant() - Girdi yereli lehçesinin yerelleştirilmiş ismini döndürür

Locale::getDisplayLanguage
Locale::getDisplayRegion
Locale


Girdi yereli için yerelleştirilmiş ülke ismini döndürür

Locale::getDisplayName
Locale::getDisplayScript
Locale
PHP Manual

Locale::getDisplayRegion

locale_get_display_region

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::getDisplayRegion -- locale_get_display_region — Girdi yereli için yerelleştirilmiş ülke ismini döndürür

Açıklama

Nesne yönelimli kullanım

static string Locale::getDisplayRegion ( string $ülke_yereli [, string $adlandırma_yereli ] )

Yordamsal kullanım

string locale_get_display_region ( string $ülke_yereli [, string $adlandırma_yereli ] )

Girdi yereli için yerelleştirilmiş ülke ismini döndürür. Öntanımlı yerel kullanılmışsa NULL döner.

Değiştirgeler

ülke_yereli

Ülke ismi gösterilecek yerel.

adlandırma_yereli

İsteğe bağlı olarak ülke isminin gösteriminde kullanılacak yerel.

Dönen Değerler

ülke_yereli değiştirgesindeki yerel yaftasında belirtilen ülke isminin adlandırma_yereli ile belirtilen yereldeki karşılığını döndürür.

Örnekler

Örnek 1 - locale_get_display_region() örneği

<?php
echo locale_get_display_region('sl-Latn-IT-nedis', 'en');
echo ";\n";
echo locale_get_display_region('sl-Latn-IT-nedis', 'fr');
echo ";\n";
echo locale_get_display_region('sl-Latn-IT-nedis', 'tr');
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
echo Locale::getDisplayRegion('sl-Latn-IT-nedis', 'en');
echo ";\n";
echo Locale::getDisplayRegion('sl-Latn-IT-nedis', 'fr');
echo ";\n";
echo Locale::getDisplayRegion('sl-Latn-IT-nedis', 'tr');
?>

Yukarıdaki örneğin çıktısı:

Italy;
Italie;
İtalya

Ayrıca Bakınız

  • locale_get_display_name() - Girdi yerelinin yerelleştirilmiş ismini döndürür
  • locale_get_display_language() - Girdi yerelindeki anadil kodunun yerelleştirilmiş ismini döndürür
  • locale_get_display_script() - Girdi yereli yazı türünün yerelleştirilmiş ismini döndürür
  • locale_get_display_variant() - Girdi yereli lehçesinin yerelleştirilmiş ismini döndürür

Locale::getDisplayName
Locale::getDisplayScript
Locale


Girdi yereli yazı türünün yerelleştirilmiş ismini döndürür

Locale::getDisplayRegion
Locale::getDisplayVariant
Locale
PHP Manual

Locale::getDisplayScript

locale_get_display_script

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::getDisplayScript -- locale_get_display_script — Girdi yereli yazı türünün yerelleştirilmiş ismini döndürür

Açıklama

Nesne yönelimli kullanım

static string Locale::getDisplayScript ( string $yazı_yereli [, string $adlandırma_yereli ] )

Yordamsal kullanım

string locale_get_display_script ( string $yazı_yereli [, string $adlandırma_yereli ] )

Girdi yereli yazı türünün yerelleştirilmiş ismini döndürür. Öntanımlı yerel kullanılmışsa NULL döner.

Değiştirgeler

yazı_yereli

Yazı türü gösterilecek yerel.

adlandırma_yereli

İsteğe bağlı olarak yazı isminin gösteriminde kullanılacak yerel.

Dönen Değerler

yazı_yereli değiştirgesindeki yerel yaftasında belirtilen yazı isminin adlandırma_yereli ile belirtilen yereldeki karşılığını döndürür.

Örnekler

Örnek 1 - locale_get_display_script() örneği

<?php
echo locale_get_display_script('sl-Latn-IT-nedis', 'en');
echo ";\n";
echo locale_get_display_script('sl-Latn-IT-nedis', 'de');
echo ";\n";
echo locale_get_display_script('sl-Latn-IT-nedis', 'tr');
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
echo Locale::getDisplayScript('sl-Latn-IT-nedis', 'en');
echo ";\n";
echo Locale::getDisplayScript('sl-Latn-IT-nedis', 'de');
echo ";\n";
echo Locale::getDisplayScript('sl-Latn-IT-nedis', 'tr');
?>

Yukarıdaki örneğin çıktısı:

Latin;
Lateinisch;
Latin

Ayrıca Bakınız

  • locale_get_display_name() - Girdi yerelinin yerelleştirilmiş ismini döndürür
  • locale_get_display_language() - Girdi yerelindeki anadil kodunun yerelleştirilmiş ismini döndürür
  • locale_get_display_region() - Girdi yereli için yerelleştirilmiş ülke ismini döndürür
  • locale_get_display_variant() - Girdi yereli lehçesinin yerelleştirilmiş ismini döndürür

Locale::getDisplayRegion
Locale::getDisplayVariant
Locale


Girdi yereli lehçesinin yerelleştirilmiş ismini döndürür

Locale::getDisplayScript
Locale::getKeywords
Locale
PHP Manual

Locale::getDisplayVariant

locale_get_display_variant

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::getDisplayVariant -- locale_get_display_variant — Girdi yereli lehçesinin yerelleştirilmiş ismini döndürür

Açıklama

Nesne yönelimli kullanım

static string Locale::getDisplayVariant ( string $lehçe_yereli [, string $adlandırma_yereli ] )

Yordamsal kullanım

string locale_get_display_variant ( string $lehçe_yereli [, string $adlandırma_yereli ] )

Girdi yereli lehçesinin yerelleştirilmiş ismini döndürür. Öntanımlı yerel kullanılmışsa NULL döner.

Değiştirgeler

lehçe_yereli

Lehçe ismi döndürülecek yerel.

adlandırma_yereli

İsteğe bağlı olarak lehçe isminin gösteriminde kullanılacak yerel.

Dönen Değerler

lehçe_yereli ile belirtilen yerel yaftasında belirtilen lehçe isminin adlandırma_yereli ile belirtilen yereldeki karşılığını döndürür.

Örnekler

Örnek 1 - locale_get_display_variant() örneği

<?php
echo locale_get_display_variant('sl-Latn-IT-nedis', 'en');
echo ";\n";
echo locale_get_display_variant('sl-Latn-IT-nedis', 'fr');
echo ";\n";
echo locale_get_display_variant('sl-Latn-IT-nedis', 'tr');
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
echo Locale::getDisplayVariant('sl-Latn-IT-nedis', 'en');
echo ";\n";
echo Locale::getDisplayVariant('sl-Latn-IT-nedis', 'fr');
echo ";\n";
echo Locale::getDisplayVariant('sl-Latn-IT-nedis', 'tr');
?>

Yukarıdaki örneğin çıktısı:

Natisone dialect;
dialecte de Natisone;
Natisone Lehçesi

Ayrıca Bakınız

  • locale_get_display_name() - Girdi yerelinin yerelleştirilmiş ismini döndürür
  • locale_get_display_language() - Girdi yerelindeki anadil kodunun yerelleştirilmiş ismini döndürür
  • locale_get_display_script() - Girdi yereli yazı türünün yerelleştirilmiş ismini döndürür
  • locale_get_display_region() - Girdi yereli için yerelleştirilmiş ülke ismini döndürür

Locale::getDisplayScript
Locale::getKeywords
Locale


Girdi yerelindeki anahtar sözcükleri döndürür

Locale::getDisplayVariant
Locale::getPrimaryLanguage
Locale
PHP Manual

Locale::getKeywords

locale_get_keywords

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::getKeywords -- locale_get_keywords — Girdi yerelindeki anahtar sözcükleri döndürür

Açıklama

Nesne yönelimli kullanım

static array Locale::getKeywords ( string $yerel )

Yordamsal kullanım

array locale_get_keywords ( string $yerel )

Girdi yerelindeki anahtar sözcükleri döndürür.

Değiştirgeler

yerel

Anahtar sözcüklerin çıkarılacağı yerel.

Dönen Değerler

Belirtilen yerel ile ilgili anahtar-değer çiftlerini içeren bir ilişkisel dizi döner.

Örnekler

Örnek 1 - locale_get_keywords() örneği

<?php
$keywords_arr = locale_get_keywords( 'de_DE@currency=EUR;collation=PHONEBOOK' );
if ($keywords_arr) {
    foreach ($keywords_arr as $key => $value) {
        echo "$key = $value\n";
    }
}
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$keywords_arr = Locale::getKeywords( 'de_DE@currency=EUR;collation=PHONEBOOK' );
if ($keywords_arr) {
    foreach( $keywords_arr as $key => $value){
        echo "$key = $value\n";
    }
}
?>

Yukarıdaki örneğin çıktısı:

collation = PHONEBOOK
currency = EUR

Ayrıca Bakınız

  • locale_get_all_variants() - Girdi yerelindeki tüm lehçeleri döndürür

Locale::getDisplayVariant
Locale::getPrimaryLanguage
Locale


Girdi yerelinden anadil kodunu döndürür

Locale::getKeywords
Locale::getRegion
Locale
PHP Manual

Locale::getPrimaryLanguage

locale_get_primary_language

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::getPrimaryLanguage -- locale_get_primary_language — Girdi yerelinden anadil kodunu döndürür

Açıklama

Nesne yönelimli kullanım

static string Locale::getPrimaryLanguage ( string $yerel )

Yordamsal kullanım

string locale_get_primary_language ( string $yerel )

Girdi yerelinde belirtilen anadil kodunu döndürür.

Değiştirgeler

yerel

Anadil kodu çıkarılacak yerel.

Dönen Değerler

Varsa anadil kodu, yoksa NULL döner.

Örnekler

Örnek 1 - locale_get_primary_language() örneği

<?php
echo locale_get_primary_language('zh-Hant');
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
echo Locale::getPrimaryLanguage('zh-Hant');
?>

Yukarıdaki örneğin çıktısı:

zh

Ayrıca Bakınız

  • locale_get_script() - Girdi yereli için yazı yaftasını döndürür
  • locale_get_region() - Girdi yerelinden ülke kodunu döndürür
  • locale_get_all_variants() - Girdi yerelindeki tüm lehçeleri döndürür

Locale::getKeywords
Locale::getRegion
Locale


Girdi yerelinden ülke kodunu döndürür

Locale::getPrimaryLanguage
Locale::getScript
Locale
PHP Manual

Locale::getRegion

locale_get_region

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::getRegion -- locale_get_region — Girdi yerelinden ülke kodunu döndürür

Açıklama

Nesne yönelimli kullanım

static string Locale::getRegion ( string $yerel )

Yordamsal kullanım

string locale_get_region ( string $yerel )

Girdi yerelinde belirtilen ülke kodunu döndürür

Değiştirgeler

yerel

Ülke kodu çıkarılacak yerel.

Dönen Değerler

Varsa ülke alt yaftası, yoksa NULL döner.

Örnekler

Örnek 1 - locale_get_region() örneği

<?php
echo locale_get_region('de-CH-1901');
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
echo Locale::getRegion('de-CH-1901');
?>

Yukarıdaki örneğin çıktısı:

CH

Ayrıca Bakınız

  • locale_get_primary_language() - Girdi yerelinden anadil kodunu döndürür
  • locale_get_script() - Girdi yereli için yazı yaftasını döndürür
  • locale_get_all_variants() - Girdi yerelindeki tüm lehçeleri döndürür

Locale::getPrimaryLanguage
Locale::getScript
Locale


Girdi yereli için yazı yaftasını döndürür

Locale::getRegion
Locale::lookup
Locale
PHP Manual

Locale::getScript

locale_get_script

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::getScript -- locale_get_script — Girdi yereli için yazı yaftasını döndürür

Açıklama

Nesne yönelimli kullanım

static string Locale::getScript ( string $yerel )

Yordamsal kullanım

string locale_get_script ( string $yerel )

Girdi yereli için yazı yaftasını döndürür.

Değiştirgeler

yerel

Yazı alt yaftası çıkarılacak yerel.

Dönen Değerler

Varsa yazı alt yaftası, yoksa NULL döner.

Örnekler

Örnek 1 locale_get_script() örneği

<?php
echo locale_get_script('sr-Cyrl');
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
echo Locale::getScript('sr-Cyrl');
?>

Yukarıdaki örneğin çıktısı:

Cyrl

Ayrıca Bakınız

  • locale_get_primary_language() - Girdi yerelinden anadil kodunu döndürür
  • locale_get_region() - Girdi yerelinden ülke kodunu döndürür
  • locale_get_all_variants() - Girdi yerelindeki tüm lehçeleri döndürür

Locale::getRegion
Locale::lookup
Locale


En iyi eşleşen dili bulmak için dil yaftası listesini araştırır

Locale::getScript
Locale::parseLocale
Locale
PHP Manual

Locale::lookup

locale_lookup

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::lookup -- locale_lookup — En iyi eşleşen dili bulmak için dil yaftası listesini araştırır

Açıklama

Nesne yönelimli kullanım

static string Locale::lookup ( array $dil_yaftası , string $yerel [, bool $meşru = false [, string $öntanımlı ]] )

Yordamsal kullanım

string locale_lookup ( array $dil_yaftası , string $yerel [, bool $meşru = false [, string $öntanımlı ]] )

RFC 4647'nin arama algoritmasına uygun olarak, yerel ile belirtilen dil aralığı ile en iyi eşleşen dil yaftasını dil_yaftası içindeki öğeler arasında arar.

Değiştirgeler

dil_yaftası

yerel ile karşılaştırılacak dil yaftalarının listesini içeren bir dizi. En fazya 100 öğeye izin verilir.

yerel

Dil aralığını eşleştirmek için kullanılacak yerel.

meşru

TRUE ise değiştirgeler eşleştirilmeden önce meşru biçeme dönüştürülür.

öntanımlı

Bir eşleşme bulunamadığı takdirde kullanılacak yerel.

Dönen Değerler

Bulunduğu takdirde en iyi eşleşen dil yaftası, aksi takdirde öntanımlı değer döner.

Örnekler

Örnek 1 - locale_lookup() örneği

<?php
$arr = array(
    'de-DEVA',
    'de-DE-1996',
    'de',
    'de-De'
);
echo locale_lookup($arr, 'de-DE-1996-x-prv1-prv2', 'en_US');
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$arr = array(
    'de-DEVA',
    'de-DE-1996',
    'de',
    'de-De'
);
echo Locale::lookup($arr, 'de-DE-1996-x-prv1-prv2', 'en_US');
?>

Yukarıdaki örneğin çıktısı:

de_de_1996

Ayrıca Bakınız

  • locale_filter_matches() - Bir dil yaftasının bir yerelle eşleşip eşleşmediğine bakar

Locale::getScript
Locale::parseLocale
Locale


Yerel yaftasını oluşturan alt yaftaları içeren bir dizi döndürür

Locale::lookup
Locale::setDefault
Locale
PHP Manual

Locale::parseLocale

locale_parse

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::parseLocale -- locale_parse — Yerel yaftasını oluşturan alt yaftaları içeren bir dizi döndürür

Açıklama

Nesne yönelimli kullanım

static array Locale::parseLocale ( string $yerel )

Yordamsal kullanım

array locale_parse ( string $yerel )

Yerel alt yaftalarını anahtar-değer çiftleri halinde içeren bir dizi döndürür.

Değiştirgeler

yerel

Alt yafta dizisi çıkarılacak yerel. Bilginize: 'extlang' anahtarı en fazla 3 değer alabilirken 'variant' ve 'private' alt yaftaları en fazla 15 değer alabilir.

Dönen Değerler

Anahtarların yerel alt yaftalarının betimleyicileri, değerlerin ise bu alt yaftalarla ilişkili değerler olduğu bir ilişkisel dizi ile döner. Dizi içeriği yerel alt yaftaların yerel değerindeki belirtiliş sırasına göre oluşturulur. Örneğin, alt yaftalar '-varX-varY-varZ' biçiminde belirtilmişse, dönen dizi şunları içerecektir: variant0=>varX , variant1=>varY , variant2=>varZ

Örnekler

Örnek 1 - locale_parse() örneği

<?php
$arr = locale_parse('sl-Latn-IT-nedis');
if ($arr) {
    foreach ($arr as $key => $value) {
        echo "$key : $value , ";
    }
}
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$arr = Locale::parseLocale('sl-Latn-IT-nedis');
if ($arr) {
    foreach ($arr as $key => $value) {
        echo "$key : $value , ";
    }
}
?>

Yukarıdaki örneğin çıktısı:

language : sl , script : Latn , region : IT , variant0 : NEDIS ,

Ayrıca Bakınız

  • locale_compose() - Doğru sıralanmış yerel ile döner

Locale::lookup
Locale::setDefault
Locale


Öntanımlı çalışma anı yerelini tanımlar

Locale::parseLocale
Normalizer
Locale
PHP Manual

Locale::setDefault

locale_set_default

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Locale::setDefault -- locale_set_default — Öntanımlı çalışma anı yerelini tanımlar

Açıklama

Nesne yönelimli kullanım

static bool Locale::setDefault ( string $yerel )

Yordamsal kullanım

bool locale_set_default ( string $yerel )

Öntanımlı çalışma anı yerelini yerel olarak tanımlar. Bu değişiklik, küresel 'default_locale' INTL yerel betimleyicisinin değerini ayarlar. UAX #35 uzantıları kabul edilir.

Değiştirgeler

yerel

BCP 47 uyumlu bir dil yaftası.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - locale_set_default() örneği

<?php
locale_set_default('tr-TR');
echo locale_get_default();
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
Locale::setDefault('tr-TR');
echo Locale::getDefault();
?>

Yukarıdaki örneğin çıktısı:

tr-TR

Ayrıca Bakınız

  • locale_get_default() - Öntanımlı yerel değerini döndürür

Locale::parseLocale
Normalizer
Locale


Normalizer sınıfı

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Giriş

Normalleştirme, karakterlerin ve karakter dizilimlerinin biçemsel olarak tanımlanmış temel bir gösterim oluşturacak şekilde dönüştürülme işlemidir. Bu işlem, bir metin aranırken veya sıralanırken gereken karşılaştırma ihtiyaçlarının karşılanması için çok önemli olup bunun yanında, metnin saklanması sırasında metnin uygun gösterimle saklandığından emin olunmasını da sağlar.

Unicode Konsorsiyumu, uygulamaların çeşitli ihtiyaçlarını karşılamak üzere bazı normalleştirme biçimleri tanımlamıştır:

  • Normalleştirme Biçimi D (NFD) - Normal Ayrıştırma
  • Normalleştirme Biçimi C (NFC) - Normal Ayrıştırmayı izleyen Normal Birleştirme
  • Normalleştirme Biçimi KD (NFKD) - Uyumluluk Ayrıştırması
  • Normalleştirme Biçimi KC (NFKC) - Uyumluluk Ayrıştırmasını izleyen Normal Birleştirme
Farklı biçimler, metin üzerindeki dünüşüm kümesinin kurallarına uygun olarak tanımlanır, dönüşümler ise hem bir algoritma hem de bir veri dosyaları kümesi olarak ifade edilir.

Sınıf Sözdizimi

Normalizer {
/* Yöntemler */
static bool isNormalized ( string $girdi [, string $biçem ] )
static string normalize ( string $girdi [, string $biçim ] )
}

Öntanımlı Sabitler

Aşağıdaki sabitler normalleştirici tarafından kullanılan normalleştirme biçimlerini tanımlar:

Normalizer::FORM_C (string)
Normalleştirme Biçimi C (NFC) - Normal Ayrıştırmayı izleyen Normal Birleştirme
Normalizer::FORM_D (string)
Normalleştirme Biçimi D (NFD) - Normal Ayrıştırma
Normalizer::FORM_KC (string)
Normalleştirme Biçimi KC (NFKC) -Uyumluluk Ayrıştırmasını izleyen Normal Birleştirme
Normalizer::FORM_KD (string)
Normalleştirme Biçimi KD (NFKD) - Uyumluluk Ayrıştırması
Normalizer::NONE (string)
Ayrıştırma/Birleştirme yok
Normalizer::OPTION_DEFAULT (string)
Öntanımlı normalleştirme seçenekleri

Ayrıca Bakınız

  • » Evrenkod Normalleştirmesi
  • » Evrenkod Normalleştirme SSS'si
  • » ICU Kullanıcı Kılavuzu - Normalleştirme
  • » ICU API Başvuru Kılavuzu - Normalleştirme

İçindekiler

  • Normalizer::isNormalized — Belirtilen dizge normalleştirilmiş mi diye bakar
  • Normalizer::normalize — Belirtilen girdiyi normalleştirir ve dizge olarak döndürür
Locale::setDefault
Normalizer::isNormalized
intl


Belirtilen dizge normalleştirilmiş mi diye bakar

Normalizer
Normalizer::normalize
Normalizer
PHP Manual

Normalizer::isNormalized

normalizer_is_normalized

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Normalizer::isNormalized -- normalizer_is_normalized — Belirtilen dizge normalleştirilmiş mi diye bakar

Açıklama

Nesne yönelimli kullanım

static bool Normalizer::isNormalized ( string $girdi [, string $biçem ] )

Yordamsal kullanım

bool normalizer_is_normalized ( string $girdi [, string $biçim ] )

Belirtilen dizge belirtilen normalleştirme türünde mi diye bakar.

Değiştirgeler

girdi

Normalleştirilmiş mi diye bakılacak dizge.

biçim

Normalleştirme biçimlerinden biri. Normalizer::FORM_C öntanımlıdır.

Dönen Değerler

Dizge normalleştirilmişse TRUE aksi takdirde veya bir hata oluşursa FALSE.

Örnekler

Örnek 1 - normalizer_is_normalized() örneği

<?php
$char_A_ring = "\xC3\x85"; // 'å' (U+00C5)
$char_combining_ring_above = "\xCC\x8A";  // 'COMBINING RING ABOVE' (U+030A)

$char_orig = 'A' . $char_combining_ring_above;
$char_norm = normalizer_normalize( 'A' . $char_combining_ring_above,
              Normalizer::FORM_C );

echo ( normalizer_is_normalized($char_orig, Normalizer::FORM_C) ) ?
        "normalleştirilmiş" : "normalleştirilmemiş";
echo '; ';
echo ( normalizer_is_normalized($char_norm, Normalizer::FORM_C) ) ?
        "normalleştirilmiş" : "normalleştirilmemiş";
?>

Örnek 2 - Nesne yönelimli örnek

<?php
$char_A_ring = "\xC3\x85"; // 'å' (U+00C5)
$char_combining_ring_above = "\xCC\x8A";  // 'COMBINING RING ABOVE' (U+030A)

$char_orig = 'A' . $char_combining_ring_above;
$char_norm = Normalizer::normalize( 'A' . $char_combining_ring_above,
             Normalizer::FORM_C );

echo ( Normalizer::isNormalized($char_orig, Normalizer::FORM_C) ) ?
        "normalleştirilmiş" : "normalleştirilmemiş";
echo '; ';
echo ( Normalizer::isNormalized($char_norm, Normalizer::FORM_C) ) ?
        "normalleştirilmiş" : "normalleştirilmemiş";
?>

Yukarıdaki örneğin çıktısı:

normalleştirilmemiş; normalleştirilmiş

Ayrıca Bakınız

  • normalizer_normalize() - Belirtilen girdiyi normalleştirir ve dizge olarak döndürür

Normalizer
Normalizer::normalize
Normalizer


Belirtilen girdiyi normalleştirir ve dizge olarak döndürür

Normalizer::isNormalized
MessageFormatter
Normalizer
PHP Manual

Normalizer::normalize

normalizer_normalize

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Normalizer::normalize -- normalizer_normalize — Belirtilen girdiyi normalleştirir ve dizge olarak döndürür

Açıklama

Nesne yönelimli kullanım

static string Normalizer::normalize ( string $girdi [, string $biçim ] )

Yordamsal kullanım

string normalizer_normalize ( string $girdi [, string $biçim ] )

Belirtilen girdiyi normalleştirir ve dizge olarak döndürür.

Değiştirgeler

girdi

Normalleştirilecek dizge

biçim

Normalleştirme biçimlerinden biri. Normalizer::FORM_C öntanımlıdır.

Dönen Değerler

Bir hata oluşursa NULL, aksi takdirde normalleştirilen dizge döner.

Örnekler

Örnek 1 - normalizer_normalize() örneği

<?php
$char_A_ring = "\xC3\x85"; // 'å' (U+00C5)
$char_combining_ring_above = "\xCC\x8A";  // 'COMBINING RING ABOVE' (U+030A)

$char_1 = normalizer_normalize( $char_A_ring, Normalizer::FORM_C );
$char_2 = normalizer_normalize( 'A' . $char_combining_ring_above,
                                 Normalizer::FORM_C );

echo urlencode($char_1);
echo ' ';
echo urlencode($char_2);
?>

Örnek 2 - Nesne yönelimli örnek

<?php
$char_A_ring = "\xC3\x85"; // 'å' (U+00C5)
$char_combining_ring_above = "\xCC\x8A";  // 'COMBINING RING ABOVE' (U+030A)

$char_1 = Normalizer::normalize( $char_A_ring, Normalizer::FORM_C );
$char_2 = Normalizer::normalize( 'A' . $char_combining_ring_above,
                                 Normalizer::FORM_C );

echo urlencode($char_1);
echo ' ';
echo urlencode($char_2);
?>

Yukarıdaki örneğin çıktısı:

%C3%85 %C3%85

Ayrıca Bakınız

  • normalizer_is_normalized() - Belirtilen dizge normalleştirilmiş mi diye bakar

Normalizer::isNormalized
MessageFormatter
Normalizer


MessageFormatter sınıfı

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Giriş

MessageFormatter (İleti Biçemleyici), dilden bağımsız iletiler üretmeyi ve birleştirmeyi mümkün kılan somut bir sınıftır. Bu sınıfın yöntemleri, son kullanıcılar tarafından görülecek iletileri derlemek için kullanılır.

MessageFormatter sınıfı, program tarafından sağlanan çeşitli (metin, sayı ve tarih gibi) veri parçaları sayesinde iletilerin montajını yapar. MessageFormatter'ın bir sınıf olmasından dolayı programın bu veri parçalarının sırasını bilmeye ihtiyacı yoktur. Sınıf bu veri parçaları için biçemleme belirtimlerini kullanarak iletiyi bir özkaynak paketi içinde tek bir dizge halinde monte eder. Örneğin, MessageFormatter "Finished printing x out of y files..." cümlesini çeviriye izin verecek esneklikte basmanıza yardımcı olacaktır.

Öncelikle, bir son kullanıcı iletisi bir cümle olarak oluşturulur ve bir dizge olarak elde edilir. Cümle yapısı, sözcük sırası, bayı biçemi ve daha bir çok şey dilden dile farklılıklar gösterdiğinden bu işlem yerelleştiriciler açısından sorunlara yol açar. İletileri dilden bağımsız bir yolla oluşturmak için iletinin parçaları her veri için bir anahtar sağlanarak ayrı ayrı yerlerde tutulur. MessageFormatter sınıfı bu anahtarları kullanarak ileti parçalarını birleştirebilir, bunları yerelleştirebilir ve son kullanıcıya iyi biçimlenmiş bir dizge olarak gösterebilir.

MessageFormatter, bir nesne kümesini alır, bunları biçemler ve bunları uygun yerlerde bir şablon içine yerleştirir. Seçim biçemleri, çoğul biçemlerin sayılarla eşleştirilip bir öğe dizisinden seçilebilmesini sağlar. Genelde, değiştirgeler ve özkaynaklar üzerinden gelen ileti biçemi çalışma anında devingen olarak değiştirgelere atanır.

Sınıf Sözdizimi

MessageFormatter {
/* Yöntemler */
__construct ( string $yerel , string $kalıp )
MessageFormatter create ( string $locale , string $pattern )
static string formatMessage ( string $yerel , string $kalıp , array $değiştirgeler )
string format ( array $değiştirgeler )
int getErrorCode ( void )
string getErrorMessage ( void )
string getLocale ( void )
string getPattern ( void )
static array parseMessage ( string $yerel , string $değer )
array parse ( string $değer )
bool setPattern ( string $kalıp )
}

Ayrıca Bakınız

  • » ICU biçemleme belgeleri
  • » ICU ileti biçemleme belgesi
  • » ICU ileti biçemleyicileri
  • » ICU seçim biçemleyicileri

İçindekiler

  • MessageFormatter::create — Yeni bir ileti biçemleyici nesne oluşturur
  • MessageFormatter::formatMessage — İletiyi çabuk biçemler
  • MessageFormatter::format — İleti biçemler
  • MessageFormatter::getErrorCode — Son işlemin hata kodunu döndürür
  • MessageFormatter::getErrorMessage — Son işlemin hata iletisini döndürür
  • MessageFormatter::getLocale — Biçemleyicinin oluşturulduğu yereli döndürür
  • MessageFormatter::getPattern — Biçemleyici tarafından kullanılan kalıbı döndürür
  • MessageFormatter::parseMessage — Girdi dizgesini hızla çözümler
  • MessageFormatter::parse — Girdi dizgesini kalıba uygun olarak çözümler
  • MessageFormatter::setPattern — Biçemleyici tarafından kullanılacak kalıbı tanımlar
Normalizer::normalize
MessageFormatter::create
intl


Yeni bir ileti biçemleyici nesne oluşturur

MessageFormatter
MessageFormatter::formatMessage
MessageFormatter
PHP Manual

MessageFormatter::create

MessageFormatter::__construct

msgfmt_create

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

MessageFormatter::create -- MessageFormatter::__construct -- msgfmt_create — Yeni bir ileti biçemleyici nesne oluşturur

Açıklama

Nesne yönelimli kullanım (yöntem)

MessageFormatter MessageFormatter::create ( string $locale , string $pattern )

Nesne yönelimli kullanım (kurucu):

MessageFormatter::__construct ( string $yerel , string $kalıp )

Yordamsal kullanım

MessageFormatter msgfmt_create ( string $yerel , string $kalıp )

Yeni bir ileti biçemleyici nesne oluşturur.

Değiştirgeler

yerel

Değiştirgelerin biçemlenmesinde kullanılacak yerel.

kalıp

Değiştirgelerin içine yerleştirileceği dizge. Kalıp 'tek tırnak dostu' sözdizimi kullanır; yorumlanmadan önce dahili olarak » umsg_autoQuoteApostrophe işlevinden geçirilir.

Dönen Değerler

Biçemleyici nesne.

Örnekler

Örnek 1 - msgfmt_create() örneği

<?php
$fmt = msgfmt_create("en_US", "{0,number,integer} monkeys on {1,number,
        integer} trees make {2,number} monkeys per tree");
echo msgfmt_format($fmt, array(4560, 123, 4560/123));
$fmt = msgfmt_create("tr", "{0,number,integer} ağaçta {1,number,
        integer} maymun, ağaç başına {2,number} maymun eder");
echo msgfmt_format($fmt, array(123, 4560, 4560/123));
?>

Örnek 2 - Nesne yönelimli örnek

<?php
$fmt = new MessageFormatter("en_US", "{0,number,integer} monkeys on {1,number,
        integer} trees make {2,number} monkeys per tree");
echo $fmt->format(array(4560, 123, 4560/123));
$fmt = new MessageFormatter("tr", "{0,number,integer} ağaçta {1,number,
        integer} maymun, ağaç başına {2,number} maymun eder");
echo $fmt->format(array(123, 4560, 4560/123));
?>

Yukarıdaki örneğin çıktısı:

4,560 monkeys on 123 trees make 37.073 monkeys per tree
123 ağaçta 4.560 maymun, ağaç başına 37,073 maymun eder

Ayrıca Bakınız

  • msgfmt_format() - İleti biçemler
  • msgfmt_parse() - Girdi dizgesini kalıba uygun olarak çözümler
  • msgfmt_get_error_code() - Son işlemin hata kodunu döndürür
  • msgfmt_get_error_message() - Son işlemin hata iletisini döndürür

MessageFormatter
MessageFormatter::formatMessage
MessageFormatter


İletiyi çabuk biçemler

MessageFormatter::create
MessageFormatter::format
MessageFormatter
PHP Manual

MessageFormatter::formatMessage

msgfmt_format_message

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

MessageFormatter::formatMessage -- msgfmt_format_message — İletiyi çabuk biçemler

Açıklama

Nesne yönelimli kullanım

static string MessageFormatter::formatMessage ( string $yerel , string $kalıp , array $değiştirgeler )

Yordamsal kullanım

string msgfmt_format_message ( string $yerel , string $kalıp , array $değiştirgeler )

Girdi dizgesini bir biçemleyici nesne oluşturmaya gerek bırakmaksızın biçemler. Bu işlevi, çözümleme işleminin bir kereliğine yapılıp değiştirgelerin ve durumun saklanmasına ihtiyaç olmadığı zaman kullanın.

Değiştirgeler

yerel

Yerele bağlı kısımların biçemlenmesinde kullanılacak yerel.

kalıp

İçine veri yerleştirilecek kalıp dizgesi. Kalıp 'tek tırnak dostu' sözdizimi kullanır; yorumlanmadan önce dahili olarak » umsg_autoQuoteApostrophe işlevinden geçirilir.

değiştirgeler

Biçem dizgesine yerleştirilecek değiştirgeleri içeren dizi.

Dönen Değerler

Bir hata oluşmuşsa FALSE, aksi takdirde biçemlenmiş kalıp dizgesi ile döner.

Örnekler

Örnek 1 - msgfmt_format_message() örneği

<?php
echo msgfmt_format_message("en_US", "{0,number,integer} monkeys on {1,number,
     integer} trees make {2,number} monkeys per tree",
        array(4560, 123, 4560/123));
echo msgfmt_format_message("tr", "{0,number,integer} ağaçta {1,number,
     integer} maymun, ağaç başına {2,number} maymun eder",
        array(123, 4560, 4560/123));

Örnek 2 - Nesne yönelimli örnek

<?php
echo msgfmt_format_message("en_US", "{0,number,integer} monkeys on {1,number,
     integer} trees make {2,number} monkeys per tree",
        array(4560, 123, 4560/123));
echo msgfmt_format_message("tr", "{0,number,integer} ağaçta {1,number,
     integer} maymun, ağaç başına {2,number} maymun eder",
        array(123, 4560, 4560/123));
?>

Yukarıdaki örneğin çıktısı:

4,560 monkeys on 123 trees make 37.073 monkeys per tree
123 ağaçta 4.560 maymun, ağaç başına 37,073 maymun eder

Ayrıca Bakınız

  • msgfmt_create() - Yeni bir ileti biçemleyici nesne oluşturur
  • msgfmt_parse() - Girdi dizgesini kalıba uygun olarak çözümler
  • msgfmt_get_error_code() - Son işlemin hata kodunu döndürür
  • msgfmt_get_error_message() - Son işlemin hata iletisini döndürür

MessageFormatter::create
MessageFormatter::format
MessageFormatter


İleti biçemler

MessageFormatter::formatMessage
MessageFormatter::getErrorCode
MessageFormatter
PHP Manual

MessageFormatter::format

msgfmt_format

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

MessageFormatter::format -- msgfmt_format — İleti biçemler

Açıklama

Nesne yönelimli kullanım

string MessageFormatter::format ( array $değiştirgeler )

Yordamsal kullanım

string msgfmt_format ( MessageFormatter $biçemleyici , array $değiştirgeler )

Yerelin kurallarına uygun olarak biçem dizgesi içine veri yerleştirerek iletiyi biçemler.

Değiştirgeler

biçemleyici

İleti biçemleyici.

değiştirgeler

Biçem dizgesine yerleştirilecek değiştirgeler.

Dönen Değerler

Bir hata oluşmuşsa FALSE, aksi takdirde biçemlenmiş dizge ile döner.

Örnekler

Örnek 1 - msgfmt_format() örneği

<?php
$fmt = msgfmt_create("en_US", "{0,number,integer} monkeys on {1,number,
        integer} trees make {2,number} monkeys per tree");
echo msgfmt_format($fmt, array(4560, 123, 4560/123));
$fmt = msgfmt_create("tr", "{0,number,integer} ağaçta {1,number,
        integer} maymun, ağaç başına {2,number} maymun eder");
echo msgfmt_format($fmt, array(123, 4560, 4560/123));
?>

Örnek 2 - Nesne yönelimli örnek

<?php
$fmt = new MessageFormatter("en_US", "{0,number,integer} monkeys on {1,
        number,integer} trees make {2,number} monkeys per tree");
echo $fmt->format(array(4560, 123, 4560/123));
$fmt = new MessageFormatter("tr", "{0,number,integer} ağaçta {1,
        number,integer} maymun, ağaç başına {2,number} maymun eder");
echo $fmt->format(array(123, 4560, 4560/123));
?>

Yukarıdaki örneğin çıktısı:

4,560 monkeys on 123 trees make 37.073 monkeys per tree
123 ağaçta 4.560 maymun, ağaç başına 37,073 maymun eder

Ayrıca Bakınız

  • msgfmt_create() - Yeni bir ileti biçemleyici nesne oluşturur
  • msgfmt_parse() - Girdi dizgesini kalıba uygun olarak çözümler
  • msgfmt_format_message() - İletiyi çabuk biçemler
  • msgfmt_get_error_code() - Son işlemin hata kodunu döndürür
  • msgfmt_get_error_message() - Son işlemin hata iletisini döndürür

MessageFormatter::formatMessage
MessageFormatter::getErrorCode
MessageFormatter


Son işlemin hata kodunu döndürür

MessageFormatter::format
MessageFormatter::getErrorMessage
MessageFormatter
PHP Manual

MessageFormatter::getErrorCode

msgfmt_get_error_code

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

MessageFormatter::getErrorCode -- msgfmt_get_error_code — Son işlemin hata kodunu döndürür

Açıklama

Nesne yönelimli kullanım

int MessageFormatter::getErrorCode ( void )

Yordamsal kullanım

int msgfmt_get_error_code ( MessageFormatter $biçemleyici )

Son işlemin hata kodunu döndürür.

Değiştirgeler

biçemleyici

İleti biçemleyici

Dönen Değerler

UErrorCode değerlerinden biri olarak hata kodu. İlk değer: U_ZERO_ERROR.

Örnekler

Örnek 1 - msgfmt_get_error_code() örneği

<?php
$fmt = msgfmt_create( "tr_TR", "{0, number} ağaçta {1, number} maymun var." );
$str = msgfmt_format($fmt, array());
if(!$str) {
    echo "ERROR: ".msgfmt_get_error_message($fmt) . " (" . msgfmt_get_error_code($fmt) . ")\n";
}
?>

Örnek 2 - Nesne yönelimli örnek

<?php
$fmt = new MessageFormatter( "tr_TR", "{0, number} ağaçta {1, number} maymun var." );
$str = $fmt->format(array());
if(!$str) {
    echo "ERROR: ".$fmt->getErrorMessage()." (" . $fmt->getErrorCode().")\n";
}
?>

Yukarıdaki örneğin çıktısı:

ERROR: msgfmt_format: not enough parameters: U_ILLEGAL_ARGUMENT_ERROR (1)

Ayrıca Bakınız

  • msgfmt_get_error_message() - Son işlemin hata iletisini döndürür
  • intl_get_error_code() - Son hatanın kodunu döndürür
  • intl_is_failure() - Belirtilen hata kodunun bir başarısızlık göstergesi olup olmadığına bakar

MessageFormatter::format
MessageFormatter::getErrorMessage
MessageFormatter


Son işlemin hata iletisini döndürür

MessageFormatter::getErrorCode
MessageFormatter::getLocale
MessageFormatter
PHP Manual

MessageFormatter::getErrorMessage

msgfmt_get_error_message

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

MessageFormatter::getErrorMessage -- msgfmt_get_error_message — Son işlemin hata iletisini döndürür

Açıklama

Nesne yönelimli kullanım

string MessageFormatter::getErrorMessage ( void )

Yordamsal kullanım

string msgfmt_get_error_message ( MessageFormatter $biçemleyici )

Son işlemin hata iletisini döndürür.

Değiştirgeler

biçemleyici

İleti biçemleyici.

Dönen Değerler

Son hatanın açıklaması.

Örnekler

Örnek 1 - msgfmt_get_error_message() örneği

<?php
$fmt = msgfmt_create( "tr_TR", "{0, number} ağaçta {1, number} maymun var." );
$str = msgfmt_format($fmt, array());
if(!$str) {
    echo "ERROR: ".msgfmt_get_error_message($fmt) . " (" . msgfmt_get_error_code($fmt) . ")\n";
}
?>

Örnek 2 - Nesne yönelimli örnek

<?php
$fmt = new MessageFormatter( "tr_TR", "{0, number} ağaçta {1, number} maymun var." );
$str = $fmt->format(array());
if(!$str) {
    echo "ERROR: ".$fmt->getErrorMessage()." (" . $fmt->getErrorCode().")\n";
}
?>

Yukarıdaki örneğin çıktısı:

ERROR: msgfmt_format: not enough parameters: U_ILLEGAL_ARGUMENT_ERROR (1)

Ayrıca Bakınız

  • msgfmt_get_error_code() - Son işlemin hata kodunu döndürür
  • intl_get_error_code() - Son hatanın kodunu döndürür
  • intl_is_failure() - Belirtilen hata kodunun bir başarısızlık göstergesi olup olmadığına bakar

MessageFormatter::getErrorCode
MessageFormatter::getLocale
MessageFormatter


Biçemleyicinin oluşturulduğu yereli döndürür

MessageFormatter::getErrorMessage
MessageFormatter::getPattern
MessageFormatter
PHP Manual

MessageFormatter::getLocale

msgfmt_get_locale

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

MessageFormatter::getLocale -- msgfmt_get_locale — Biçemleyicinin oluşturulduğu yereli döndürür

Açıklama

Nesne yönelimli kullanım

string MessageFormatter::getLocale ( void )

Yordamsal kullanım

string msgfmt_get_locale ( NumberFormatter $biçemleyici )

Biçemleyicinin oluşturulduğu yereli döndürür.

Değiştirgeler

biçemleyici

Biçemleyici nesne

Dönen Değerler

Yerel ismi

Örnekler

Örnek 1 - msgfmt_get_locale() örneği

<?php
$fmt = msgfmt_create('tr_TR', "Sayı: {0,number}");
echo msgfmt_get_locale($fmt);
?>

Örnek 2 - Nesne yönelimli örnek

<?php
$fmt = new MessageFormatter('tr_TR', "Sayı: {0,number}");
echo $fmt->getLocale();
?>

Yukarıdaki örneğin çıktısı:

tr_TR

Ayrıca Bakınız

  • msgfmt_create() - Yeni bir ileti biçemleyici nesne oluşturur

MessageFormatter::getErrorMessage
MessageFormatter::getPattern
MessageFormatter


Biçemleyici tarafından kullanılan kalıbı döndürür

MessageFormatter::getLocale
MessageFormatter::parseMessage
MessageFormatter
PHP Manual

MessageFormatter::getPattern

msgfmt_get_pattern

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

MessageFormatter::getPattern -- msgfmt_get_pattern — Biçemleyici tarafından kullanılan kalıbı döndürür

Açıklama

Nesne yönelimli kullanım

string MessageFormatter::getPattern ( void )

Yordamsal kullanım

string msgfmt_get_pattern ( MessageFormatter $fmt )

Biçemleyici tarafından kullanılan kalıbı döndürür.

Değiştirgeler

biçemleyici

İleti biçemleyici.

Dönen Değerler

İleti biçemleyici tarafından kullanılan kalıp dizgesi.

Örnekler

Örnek 1 - msgfmt_get_pattern() örneği

<?php
$fmt = msgfmt_create( "tr_TR", "{0, number} ağaçta {1, number} maymun var." );
echo "Öntanımlı kalıp: '" . msgfmt_get_pattern( $fmt ) . "'\n";
echo "Biçemleme sonucu: " . msgfmt_format( $fmt, array(123, 456) ) . "\n";

msgfmt_set_pattern( $fmt, "{0, number} maymuna karşılık {1, number} ağaç var." );
echo "Yeni kalıp: '" . msgfmt_get_pattern( $fmt ) . "'\n";
echo "Biçemleme sonucu: " . msgfmt_format( $fmt, array(456, 123) ) . "\n";
?>
?>

Örnek 2 - Nesne yönelimli örnek

<?php
$fmt = new MessageFormatter( "tr_TR", "{0, number} ağaçta {1, number} maymun var." );
echo "Öntanımlı kalıp: '" . $fmt->getPattern() . "'\n";
echo "Biçemleme sonucu: " . $fmt->format(array(123, 456)) . "\n";

$fmt->setPattern("{0, number} maymuna karşılık {1, number} ağaç var." );
echo "Yeni kalıp: '" . $fmt->getPattern() . "'\n";
echo "Biçemleme sonucu: " . $fmt->format(array(456, 123)) . "\n";
?>

Yukarıdaki örneğin çıktısı:

Öntanımlı kalıp: '{0, number} ağaçta {1, number} maymun var.'
Biçemleme sonucu: 123 ağaçta 456 maymun var.
Yeni kalıp: '{0, number} maymuna karşılık {1, number} ağaç var.'
Biçemleme sonucu: 456 maymuna karşılık 123 ağaç var.

Ayrıca Bakınız

  • msgfmt_create() - Yeni bir ileti biçemleyici nesne oluşturur
  • msgfmt_set_pattern() - Biçemleyici tarafından kullanılacak kalıbı tanımlar

MessageFormatter::getLocale
MessageFormatter::parseMessage
MessageFormatter


Girdi dizgesini hızla çözümler

MessageFormatter::getPattern
MessageFormatter::parse
MessageFormatter
PHP Manual

MessageFormatter::parseMessage

msgfmt_parse_message

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

MessageFormatter::parseMessage -- msgfmt_parse_message — Girdi dizgesini hızla çözümler

Açıklama

Nesne yönelimli kullanım

static array MessageFormatter::parseMessage ( string $yerel , string $değer )

Yordamsal kullanım

array msgfmt_parse_message ( string $yerel , string $değer )

Girdi dizgesini bir biçemleyici nesne oluşturmaya gerek bırakmaksızın çözümler. Bu işlevi, çözümleme işleminin bir kereliğine yapılıp değiştirgelerin ve durumun saklanmasına ihtiyaç olmadığı zaman kullanın.

Değiştirgeler

yerel

Yerele bağlı kısımların çözümlenmesinde kullanılacak yerel.

değer

Öğeleri çözümlenecek dizge.

Dönen Değerler

Bir hata oluşmuşsa FALSE, aksi takdirde çözümleme sonucu elde edilen öğeleri içeren bir dizi.

Örnekler

Örnek 1 - msgfmt_parse_message() örneği

<?php
$res = msgfmt_parse_message('en_US', "{0,number,integer} monkeys on {1,
               number,integer} trees make {2,number} monkeys per tree",
               "4,560 monkeys on 123 trees make 37.073 monkeys per tree");
var_export($res);

$res = msgfmt_parse_message('tr',"{0,number,integer} ağaçta {1,
              number,integer} maymun, ağaç başına {2,number} maymun eder",
                 "123 ağaçta 4.560 maymun, ağaç başına 37,073 maymun eder");
var_export($res);
?>

Örnek 2 - Nesne yönelimli örnek

<?php
$res = MessageFormatter::parseMessage('en_US', "{0,number,
 integer} monkeys on {1,number,integer} trees make {2,number} monkeys per tree",
 "4,560 monkeys on 123 trees make 37.073 monkeys per tree");
var_export($res);

$res = MessageFormatter::parseMessage('tr', "{0,number,integer} ağaçta {1,
              number,integer} maymun, ağaç başına {2,number} maymun eder",
                 "123 ağaçta 4.560 maymun, ağaç başına 37,073 maymun eder");
var_export($res);
?>

Yukarıdaki örneğin çıktısı:

array (
  0 => 4560,
  1 => 123,
  2 => 37.073,
)array (
  0 => 123,
  1 => 4560,
  2 => 37.073,
)

Ayrıca Bakınız

  • msgfmt_create() - Yeni bir ileti biçemleyici nesne oluşturur
  • msgfmt_format_message() - İletiyi çabuk biçemler
  • msgfmt_parse() - Girdi dizgesini kalıba uygun olarak çözümler

MessageFormatter::getPattern
MessageFormatter::parse
MessageFormatter


Girdi dizgesini kalıba uygun olarak çözümler

MessageFormatter::parseMessage
MessageFormatter::setPattern
MessageFormatter
PHP Manual

MessageFormatter::parse

msgfmt_parse

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

MessageFormatter::parse -- msgfmt_parse — Girdi dizgesini kalıba uygun olarak çözümler

Açıklama

Nesne yönelimli kullanım

array MessageFormatter::parse ( string $değer )

Yordamsal kullanım

array msgfmt_parse ( MessageFormatter $biçemleyici , string $değer )

Girdi dizgesini çözümler ve elde edilen öğeleri bir dizi içinde döndürür.

Değiştirgeler

biçemleyici

İleti biçemleyici.

değer

Çözümlenecek dizge.

Dönen Değerler

Bir hata oluşmuşsa FALSE, aksi takdirde çözümleme sonucu elde edilen öğeleri içeren bir dizi.

Örnekler

Örnek 1 - msgfmt_parse() örneği

<?php
$fmt = msgfmt_create('en_US', "{0,number,integer} monkeys on {1,number,
                      integer} trees make {2,number} monkeys per tree");
$res = msgfmt_parse($fmt,
             "4,560 monkeys on 123 trees make 37.073 monkeys per tree");
var_export($res);

$fmt = msgfmt_create('tr', "{0,number,integer} ağaçta {1,number,
                  integer} maymun, ağaç başına {2,number} maymun eder");
$res = msgfmt_parse($fmt,
              "123 ağaçta 4.560 maymun, ağaç başına 37,073 maymun eder");
var_export($res);
?>

Örnek 2 - Nesne yönelimli örnek

<?php
$fmt = new MessageFormatter('en_US', "{0,number,integer} monkeys on {1,
                number,integer} trees make {2,number} monkeys per tree");
$res = $fmt->parse("4,560 monkeys on 123 trees make 37.073 monkeys per tree");
var_export($res);

$fmt = new MessageFormatter('tr', "{0,number,integer} ağaçta {1,
            number,integer} maymun, ağaç başına {2,number} maymun eder");
$res = $fmt->parse("123 ağaçta 4.560 maymun, ağaç başına 37,073 maymun eder");
var_export($res);
?>

Yukarıdaki örneğin çıktısı:

array (
  0 => 4560,
  1 => 123,
  2 => 37.073,
)array (
  0 => 123,
  1 => 4560,
  2 => 37.073,
)

Ayrıca Bakınız

  • msgfmt_create() - Yeni bir ileti biçemleyici nesne oluşturur
  • msgfmt_format() - İleti biçemler
  • msgfmt_parse_message() - Girdi dizgesini hızla çözümler

MessageFormatter::parseMessage
MessageFormatter::setPattern
MessageFormatter


Biçemleyici tarafından kullanılacak kalıbı tanımlar

MessageFormatter::parse
IntlDateFormatter
MessageFormatter
PHP Manual

MessageFormatter::setPattern

msgfmt_set_pattern

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

MessageFormatter::setPattern -- msgfmt_set_pattern — Biçemleyici tarafından kullanılacak kalıbı tanımlar

Açıklama

Nesne yönelimli kullanım

bool MessageFormatter::setPattern ( string $kalıp )

Yordamsal kullanım

bool msgfmt_set_pattern ( MessageFormatter $biçemleyici , string $kalıp )

Biçemleyici tarafından kullanılacak kalıbı tanımlar.

Değiştirgeler

biçemleyici

İleti biçemleyici

kalıp

Bu ileti biçemleyici tarafından kullanılacak kalıp dizgesi. Kalıp 'tek tırnak dostu' sözdizimi kullanır; yorumlanmadan önce dahili olarak » umsg_autoQuoteApostrophe işlevinden geçirilir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - msgfmt_set_pattern() örneği

<?php
$fmt = msgfmt_create( "tr_TR", "{0, number} ağaçta {1, number} maymun var." );
echo "Öntanımlı kalıp: '" . msgfmt_get_pattern( $fmt ) . "'\n";
echo "Biçemleme sonucu: " . msgfmt_format( $fmt, array(123, 456) ) . "\n";

msgfmt_set_pattern( $fmt, "{0, number} maymuna karşılık {1, number} ağaç var." );
echo "Yeni kalıp: '" . msgfmt_get_pattern( $fmt ) . "'\n";
echo "Biçemleme sonucu: " . msgfmt_format( $fmt, array(456, 123) ) . "\n";
?>

Örnek 2 - Nesne yönelimli örnek

<?php
$fmt = new MessageFormatter( "tr_TR", "{0, number} ağaçta {1, number} maymun var." );
echo "Öntanımlı kalıp: '" . $fmt->getPattern() . "'\n";
echo "Biçemleme sonucu: " . $fmt->format(array(123, 456)) . "\n";

$fmt->setPattern("{0, number} maymuna karşılık {1, number} ağaç var." );
echo "Yeni kalıp: '" . $fmt->getPattern() . "'\n";
echo "Biçemleme sonucu: " . $fmt->format(array(456, 123)) . "\n";
?>

Yukarıdaki örneğin çıktısı:

Öntanımlı kalıp: '{0, number} ağaçta {1, number} maymun var.'
Biçemleme sonucu: 123 ağaçta 456 maymun var.
Yeni kalıp: '{0, number} maymuna karşılık {1, number} ağaç var.'
Biçemleme sonucu: 456 maymuna karşılık 123 ağaç var.

Ayrıca Bakınız

  • msgfmt_create() - Yeni bir ileti biçemleyici nesne oluşturur
  • msgfmt_get_pattern() - Biçemleyici tarafından kullanılan kalıbı döndürür

MessageFormatter::parse
IntlDateFormatter
MessageFormatter


IntlDateFormatter sınıfı

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

Giriş

Date Formatter (Tarih Biçemleyici), şablon dizgeleri ve/veya kayıtlı şablonları kullanarak yerele bağlı tarih biçemlemeyi/çözümlemeyi etkin kılan somut bir sınıftır.

Bu sınıf, ICU tarih biçemleme işlevselliğini temsil eder. Kullanıcıların tarihleri yerelleştirilmiş biçemde gösterebilmesini veya şablon dizgelerini ve kayıtlı şablonları kullanarak, dizgeleri PHP tarih değerleri olarak çözümlemelerini mümkün kılar.

Sınıf Sözdizimi

IntlDateFormatter {
/* Yöntemler */
__construct ( string $yerel , int $tarih_türü , int $saat_türü [, string $zaman_dilimi [, int $takvim [, string $kalıp ]]] )
static IntlDateFormatter create ( string $yerel , int $tarih_türü , int $saat_türü [, string $zaman_dilimi [, int $takvim [, string $kalıp ]]] )
string format ( mixed $değer )
public static string formatObject ( object $object [, mixed $format = NULL [, string $locale = NULL ]] )
int getCalendar ( void )
int getDateType ( void )
int getErrorCode ( void )
string getErrorMessage ( void )
string getLocale ([ int $tür ] )
string getPattern ( void )
int getTimeType ( void )
string getTimeZoneId ( void )
public IntlCalendar getCalendarObject ( void )
public IntlTimeZone getTimeZone ( void )
bool isLenient ( void )
array localtime ( string $dizge [, int &$başlangıç ] )
int parse ( string $dizge [, int &$başlangıç ] )
bool setCalendar ( int $takvim )
bool setLenient ( bool $esnek )
bool setPattern ( string $kalıp )
bool setTimeZoneId ( string $zaman_dilimi )
public boolean setTimeZone ( mixed $zone )
}

Ayrıca Bakınız

  • » ICU Tarih biçemcisi

Öntanımlı Sabitler

Bu sabitler, DateType ve TimeType kurucularında farklı biçemler belirtmek için kullanılırlar.

IntlDateFormatter::NONE (string)
Bu elemanı içerme
IntlDateFormatter::FULL (string)
Tamamen belirtilmiş biçim (01 Ocak 1970 Perşembe 02:00:00 Türkiye Saati)
IntlDateFormatter::LONG (string)
Uzun biçim (01 Ocak 1970 Perşembe veya 02:00:00)
IntlDateFormatter::MEDIUM (string)
Ortalama biçim (01 Oca 1970)
IntlDateFormatter::SHORT (string)
En kısa biçim, sadece esas veri (12/13/52 or 3:30pm)

Aşağıdaki sabitler takvim belirtmek için kullanılır. Bu takvimlerin tamamı doğrudan Gregoriyen takvimine dayanır. Gregoriyen olmayan takvimlerin yerelde belirtilmesi gerekir. Örnek: locale="hi@calendar=BUDDHIST".

IntlDateFormatter::TRADITIONAL (string)
Gregoriyen olmayan takvim
IntlDateFormatter::GREGORIAN (string)
Gregoriyen takvimi

İçindekiler

  • IntlDateFormatter::create — Bir tarih biçemleyici oluşturur
  • IntlDateFormatter::format — Tarih/saat değerini bir dizge olarak biçemler
  • IntlDateFormatter::formatObject — Formats an object
  • IntlDateFormatter::getCalendar — IntlDateFormatter tarafından kullanılan takvimi döndürür
  • IntlDateFormatter::getDateType — IntlDateFormatter tarafından kullanılan tarih gösterim türünü döndürür
  • IntlDateFormatter::getErrorCode — Son işlemin hata kodunu döndürür
  • IntlDateFormatter::getErrorMessage — Son işlemin hata iletisini döndürür
  • IntlDateFormatter::getLocale — Biçemleyicinin kullandığı yereli döndürür
  • IntlDateFormatter::getPattern — IntlDateFormatter tarafından kullanılan kalıbı döndürür
  • IntlDateFormatter::getTimeType — IntlDateFormatter tarafından kullanılan zaman gösterim türünü döndürür
  • IntlDateFormatter::getTimeZoneId — IntlDateFormatter tarafından kullanılan zaman dilimini döndürür
  • IntlDateFormatter::getCalendarObject — Get copy of formatter's calendar object
  • IntlDateFormatter::getTimeZone — Get formatter's timezone
  • IntlDateFormatter::isLenient — IntlDateFormatter esnek çözümleme mi yapıyor diye bakar
  • IntlDateFormatter::localtime — Tarih dizgesini alanlarına çözümler
  • IntlDateFormatter::parse — Dizgeyi bir zaman damgası değerine dönüştürür
  • IntlDateFormatter::setCalendar — Kullanılacak takvimi tanımlar
  • IntlDateFormatter::setLenient — Çözümleyiciye esneklik verir
  • IntlDateFormatter::setPattern — IntlDateFormatter tarafından kullanılan kalıbı tanımlar
  • IntlDateFormatter::setTimeZoneId — Kullanılacak zaman dilimini tanımlar
  • IntlDateFormatter::setTimeZone — Sets formatter's timezone
MessageFormatter::setPattern
IntlDateFormatter::create
intl


Bir tarih biçemleyici oluşturur

IntlDateFormatter
IntlDateFormatter::format
IntlDateFormatter
PHP Manual

IntlDateFormatter::create

datefmt_create

IntlDateFormatter::__construct

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::create -- datefmt_create -- IntlDateFormatter::__construct — Bir tarih biçemleyici oluşturur

Açıklama

Nesne yönelimli kullanım

static IntlDateFormatter IntlDateFormatter::create ( string $yerel , int $tarih_türü , int $saat_türü [, string $zaman_dilimi [, int $takvim [, string $kalıp ]]] )

Nesne yönelimli kullanım (kurucu)

IntlDateFormatter::__construct ( string $yerel , int $tarih_türü , int $saat_türü [, string $zaman_dilimi [, int $takvim [, string $kalıp ]]] )

Yordamsal kullanım

IntlDateFormatter datefmt_create ( string $yerel , int $tarih_türü , int $saat_türü [, string $zaman_dilimi [, int $takvim [, string $kalıp ]]] )

Bir tarih biçemleyici oluşturur

Değiştirgeler

yerel

Biçemleme ve çözümleme için kullanılacak yerel.

tarih_türü

Kullanılacak tarih türü (yok, kısa, orta, uzun, tam). IntlDateFormatter sabitlerinden biri olmalıdır.

saat_türü

Kullanılacak saat türü (yok, kısa, orta, uzun, tam). IntlDateFormatter sabitlerinden biri olmalıdır.

zaman_dilimi

Zaman dilimi. Sistem öntanımlısı, öntanımlıdır.

takvim

Biçemleme ve çözümleme için kullanılacak takvim; Gregoriyen öntanımlıdır. IntlDateFormatter takvim sabitlerinden biri olmalıdır.

kalıp

Biçemleme ve çözümleme için kullanılacak isteğe beğlı kalıp.

Dönen Değerler

Örnekler

Örnek 1 - datefmt_create() örneği

<?php
$fmt = datefmt_create("tr_TR", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL,'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN);
echo "İlk biçemli çıktı: ".datefmt_format($fmt, 1234567890);
$fmt = datefmt_create("en-US", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL, 'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN);
echo "\nİkinci biçemli çıktı: ".datefmt_format($fmt, 1234567890);

$fmt = datefmt_create("tr_TR", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL, 'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN, "dd/MM/yyyy");
echo "\nİlk kalıbın çıktısı: ".datefmt_format( $fmt, 1234567890);
$fmt = datefmt_create("en-US", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL, 'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN, "MM/dd/yyyy");
echo "\nİkinci kalıbın çıktısı: ".datefmt_format($fmt, 1234567890);
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$fmt = new IntlDateFormatter("tr_TR", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL,'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN);
echo "İlk biçemli çıktı: ".$fmt->format(1234567890);
$fmt = new IntlDateFormatter("en-US", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL, 'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN);
echo "\nİkinci biçemli çıktı: ".$fmt->format(1234567890);

$fmt = new IntlDateFormatter("tr_TR", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL,'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN, "dd/MM/yyyy");
echo "\nİlk kalıbın çıktısı: ".$fmt->format(1234567890);
$fmt = new IntlDateFormatter("en-US", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL, 'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN, "MM/dd/yyyy");
echo "\nİkinci kalıbın çıktısı: ".$fmt->format(1234567890);
?>

Yukarıdaki örneğin çıktısı:

İlk biçemli çıktı: 14 Şubat 2009 Cumartesi 01:31:30 Türkiye Saati
İkinci biçemli çıktı: Saturday, February 14, 2009 1:31:30 AM Turkey Time
İlk kalıbın çıktısı: 14/02/2009
İkinci kalıbın çıktısı: 02/14/2009

Ayrıca Bakınız

  • datefmt_format() - Tarih/saat değerini bir dizge olarak biçemler
  • datefmt_parse() - Dizgeyi bir zaman damgası değerine dönüştürür
  • datefmt_get_error_code() - Son işlemin hata kodunu döndürür
  • datefmt_get_error_message() - Son işlemin hata iletisini döndürür

IntlDateFormatter
IntlDateFormatter::format
IntlDateFormatter


Tarih/saat değerini bir dizge olarak biçemler

IntlDateFormatter::create
IntlDateFormatter::formatObject
IntlDateFormatter
PHP Manual

IntlDateFormatter::format

datefmt_format

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::format -- datefmt_format — Tarih/saat değerini bir dizge olarak biçemler

Açıklama

Nesne yönelimli kullanım

string IntlDateFormatter::format ( mixed $değer )

Yordamsal kullanım

string datefmt_format ( IntlDateFormatter $biçemleyici , mixed $değer )

Zaman değerini bir dizge olarak biçemler.

Değiştirgeler

biçemleyici

Biçemleyici nesne.

değer

Biçemlenecek değer. Tamsayı olarak bir Unix zaman damgası (Unix zaman başlangıcından itibaren saniye sayısı) olabileceği gibi bir localtime() dizisi de olabilir.

Dönen Değerler

Bir hata oluşmuşsa FALSE aksi takdirde biçemli dizge.

Örnekler

Örnek 1 - datefmt_format() örneği

<?php
$fmt = datefmt_create("tr_TR", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL,'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN);
echo "İlk biçemli çıktı: ".datefmt_format($fmt, 1234567890);
$fmt = datefmt_create("en-US", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL, 'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN);
echo "\nİkinci biçemli çıktı: ".datefmt_format($fmt, 1234567890);

$fmt = datefmt_create("tr_TR", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL, 'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN, "dd/MM/yyyy");
echo "\nİlk kalıbın çıktısı: ".datefmt_format( $fmt, 1234567890);
$fmt = datefmt_create("en-US", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL, 'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN, "MM/dd/yyyy");
echo "\nİkinci kalıbın çıktısı: ".datefmt_format($fmt, 1234567890);
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$fmt = new IntlDateFormatter("tr_TR", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL,'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN);
echo "İlk biçemli çıktı: ".$fmt->format(1234567890);
$fmt = new IntlDateFormatter("en-US", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL, 'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN);
echo "\nİkinci biçemli çıktı: ".$fmt->format(1234567890);

$fmt = new IntlDateFormatter("tr_TR", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL,'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN, "dd/MM/yyyy");
echo "\nİlk kalıbın çıktısı: ".$fmt->format(1234567890);
$fmt = new IntlDateFormatter("en-US", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL, 'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN, "MM/dd/yyyy");
echo "\nİkinci kalıbın çıktısı: ".$fmt->format(1234567890);
?>

Yukarıdaki örneğin çıktısı:

İlk biçemli çıktı: 14 Şubat 2009 Cumartesi 01:31:30 Türkiye Saati
İkinci biçemli çıktı: Saturday, February 14, 2009 1:31:30 AM Turkey Time
İlk kalıbın çıktısı: 14/02/2009
İkinci kalıbın çıktısı: 02/14/2009

Ayrıca Bakınız

  • datefmt_create() - Bir tarih biçemleyici oluşturur
  • datefmt_parse() - Dizgeyi bir zaman damgası değerine dönüştürür
  • datefmt_get_error_code() - Son işlemin hata kodunu döndürür
  • datefmt_get_error_message() - Son işlemin hata iletisini döndürür

IntlDateFormatter::create
IntlDateFormatter::formatObject
IntlDateFormatter


Formats an object

IntlDateFormatter::format
IntlDateFormatter::getCalendar
IntlDateFormatter
PHP Manual

IntlDateFormatter::formatObject

datefmt_format_object

(PHP 5 >= 5.5.0, PHP 7, PECL intl >= 3.0.0)

IntlDateFormatter::formatObject -- datefmt_format_object — Formats an object

Açıklama

Nesne yönelimli kullanım

public static string IntlDateFormatter::formatObject ( object $object [, mixed $format = NULL [, string $locale = NULL ]] )

Yordamsal kullanım

public static string datefmt_format_object ( object $object [, mixed $format = NULL [, string $locale = NULL ]] )

This function allows formatting an IntlCalendar or DateTime object without first explicitly creating a IntlDateFormatter object.

The temporary IntlDateFormatter that will be created will take the timezone from the passed in object. The timezone database bundled with PHP will not be used - ICU's will be used instead. The timezone identifier used in DateTime objects must therefore also exist in ICU's database.

Değiştirgeler

object

An object of type IntlCalendar or DateTime. The timezone information in the object will be used.

format

How to format the date/time. This can either be an array with two elements (first the date style, then the time style, these being one of the constants IntlDateFormatter::NONE, IntlDateFormatter::SHORT, IntlDateFormatter::MEDIUM, IntlDateFormatter::LONG, IntlDateFormatter::FULL), a long with the value of one of these constants (in which case it will be used both for the time and the date) or a string with the format described in » the ICU documentation. If NULL, the default style will be used.

locale

The locale to use, or NULL to use the default one.

Dönen Değerler

A string with result başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 IntlDateFormatter::formatObject() examples

<?php
/* default timezone is irrelevant; timezone taken from the object */
ini_set('date.timezone', 'UTC');
/* default locale is taken from this ini setting */
ini_set('intl.default_locale', 'fr_FR');

$cal = IntlCalendar::fromDateTime("2013-06-06 17:05:06 Europe/Dublin");
echo "default:\n\t",
        IntlDateFormatter::formatObject($cal),
        "\n";

echo "long \$format (full):\n\t",
        IntlDateFormatter::formatObject($cal, IntlDateFormatter::FULL),
        "\n";

echo "array \$format (none, full):\n\t",
        IntlDateFormatter::formatObject($cal, array(
                IntlDateFormatter::NONE,
                IntlDateFormatter::FULL)),
        "\n";

echo "string \$format (d 'of' MMMM y):\n\t",
        IntlDateFormatter::formatObject($cal, "d 'of' MMMM y", 'en_US'),
        "\n";

echo "with DateTime:\n\t",
        IntlDateFormatter::formatObject(
                new DateTime("2013-09-09 09:09:09 Europe/Madrid"),
                IntlDateFormatter::FULL,
                'es_ES'),
        "\n";

Yukarıdaki örneğin çıktısı:

default:
    6 juin 2013 17:05:06
long $format (full):
    jeudi 6 juin 2013 17:05:06 heure d'été irlandaise
array $format (none, full):
    17:05:06 heure d'été irlandaise
string $format (d 'of' MMMM y):
    6 of June 2013
with DateTime:
    lunes, 9 de septiembre de 2013 09:09:09 Hora de verano de Europa central

IntlDateFormatter::format
IntlDateFormatter::getCalendar
IntlDateFormatter


IntlDateFormatter tarafından kullanılan takvimi döndürür

IntlDateFormatter::formatObject
IntlDateFormatter::getDateType
IntlDateFormatter
PHP Manual

IntlDateFormatter::getCalendar

datefmt_get_calendar

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::getCalendar -- datefmt_get_calendar — IntlDateFormatter tarafından kullanılan takvimi döndürür

Açıklama

Nesne yönelimli kullanım

int IntlDateFormatter::getCalendar ( void )

Yordamsal kullanım

int datefmt_get_calendar ( IntlDateFormatter $biçemleyici )

Biçemleyici tarafından kullanılan takvimi döndürür.

Değiştirgeler

biçemleyici

Biçemleyici nesne.

Dönen Değerler

Biçemleyici tarafından kullanılan takvim.

Örnekler

Örnek 1 - datefmt_get_calendar() örneği

<?php
$fmt = datefmt_create("en_US", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL, 'America/Los_Angeles',
        IntlDateFormatter::GREGORIAN  );
echo "Biçemleyicinin takvimi: ".datefmt_get_calendar($fmt);
datefmt_set_calendar($fmt,IntlDateFormatter::TRADITIONAL);
echo "\nBiçemleyicinin yeni takvimi: ".datefmt_get_calendar($fmt);
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$fmt = new IntlDateFormatter("en_US", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL, 'America/Los_Angeles',
        IntlDateFormatter::GREGORIAN  );
echo "Biçemleyicinin takvimi: ".$fmt->getCalendar();
$fmt->setCalendar(IntlDateFormatter::TRADITIONAL);
echo "\nBiçemleyicinin yeni takvimi: ".$fmt->getCalendar();

?>

Yukarıdaki örneğin çıktısı:

Biçemleyicinin takvimi: 1
Biçemleyicinin yeni takvimi: 0

Ayrıca Bakınız

  • datefmt_set_calendar() - Kullanılacak takvimi tanımlar
  • datefmt_create() - Bir tarih biçemleyici oluşturur

IntlDateFormatter::formatObject
IntlDateFormatter::getDateType
IntlDateFormatter


IntlDateFormatter tarafından kullanılan tarih gösterim türünü döndürür

IntlDateFormatter::getCalendar
IntlDateFormatter::getErrorCode
IntlDateFormatter
PHP Manual

IntlDateFormatter::getDateType

datefmt_get_datetype

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::getDateType -- datefmt_get_datetype — IntlDateFormatter tarafından kullanılan tarih gösterim türünü döndürür

Açıklama

Nesne yönelimli kullanım

int IntlDateFormatter::getDateType ( void )

Yordamsal kullanım

int datefmt_get_datetype ( IntlDateFormatter $biçemleyici )

Biçemleyici tarafından kullanılan tarih gösterim türünü döndürür.

Değiştirgeler

biçemleyici

Biçemleyici nesne.

Dönen Değerler

Geçerli tarih gösterim türü.

Örnekler

Örnek 1 - datefmt_get_datetype() örneği

<?php
$fmt = datefmt_create("tr_TR", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL,'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN);
echo "Biçemleyicinin tarih gösterim türü: ".datefmt_get_datetype($fmt);
echo "\nBiçemli çıktı: ".datefmt_format($fmt, 1234567890);
$fmt = datefmt_create("tr_TR", IntlDateFormatter::SHORT,
        IntlDateFormatter::FULL, 'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN);
echo "\nBiçemleyicinin yeni tarih gösterim türü: ".datefmt_get_datetype($fmt);
echo "\nİkinci biçemli çıktı: ".datefmt_format($fmt, 1234567890);
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$fmt = new IntlDateFormatter("tr_TR", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL,'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN);
echo "Biçemleyicinin tarih gösterim türü: ".$fmt->getDateType();
echo "\nBiçemli çıktı: ".datefmt_format( $fmt, 1234567890);
$fmt = new IntlDateFormatter("tr_TR", IntlDateFormatter::SHORT,
        IntlDateFormatter::FULL,'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN);
echo "\nBiçemleyicinin yeni tarih gösterim türü: ".$fmt->getDateType();
echo "\nİkinci biçemli çıktı: ".datefmt_format( $fmt, 1234567890);
?>

Yukarıdaki örneğin çıktısı:

Biçemleyicinin tarih gösterim türü: 0
Biçemli çıktı: 14 Şubat 2009 Cumartesi 01:31:30 Türkiye Saati
Biçemleyicinin yeni tarih gösterim türü: 3
İkinci biçemli çıktı: 14.02.2009 01:31:30

Ayrıca Bakınız

  • datefmt_get_timetype() - IntlDateFormatter tarafından kullanılan zaman gösterim türünü döndürür
  • datefmt_create() - Bir tarih biçemleyici oluşturur

IntlDateFormatter::getCalendar
IntlDateFormatter::getErrorCode
IntlDateFormatter


Son işlemin hata kodunu döndürür

IntlDateFormatter::getDateType
IntlDateFormatter::getErrorMessage
IntlDateFormatter
PHP Manual

IntlDateFormatter::getErrorCode

datefmt_get_error_code

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::getErrorCode -- datefmt_get_error_code — Son işlemin hata kodunu döndürür

Açıklama

Nesne yönelimli kullanım

int IntlDateFormatter::getErrorCode ( void )

Yordamsal kullanım

int datefmt_get_error_code ( IntlDateFormatter $biçemleyici )

Son işlemin hata kodunu döndürür.

Değiştirgeler

biçemleyici

Biçemleyici nesne.

Dönen Değerler

UErrorCode değerlerinden biri olarak bir hata kodu. İlk değer: U_ZERO_ERROR.

Örnekler

Örnek 1 - datefmt_get_error_code() örneği

<?php
$fmt = datefmt_create("en_US", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL, 'America/Los_Angeles',
        IntlDateFormatter::GREGORIAN  );
$str = datefmt_format($fmt);
if(!$str) {
    echo "HATA: ".datefmt_get_error_message($fmt) . " (" .
      datefmt_get_error_code($fmt) . ")\n";
}
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$fmt = new IntlDateFormatter("en_US", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL, 'America/Los_Angeles',
        IntlDateFormatter::GREGORIAN  );
$str = $fmt->format();
if(!$str) {
    echo "HATA: ".$fmt->getErrorMessage() . " (" .$fmt->getErrorCode() .")\n";
}
?>

Yukarıdaki örneğin çıktısı:

HATA: U_ZERO_ERROR (0)

Ayrıca Bakınız

  • datefmt_get_error_message() - Son işlemin hata iletisini döndürür
  • intl_get_error_code() - Son hatanın kodunu döndürür
  • intl_is_failure() - Belirtilen hata kodunun bir başarısızlık göstergesi olup olmadığına bakar

IntlDateFormatter::getDateType
IntlDateFormatter::getErrorMessage
IntlDateFormatter


Son işlemin hata iletisini döndürür

IntlDateFormatter::getErrorCode
IntlDateFormatter::getLocale
IntlDateFormatter
PHP Manual

IntlDateFormatter::getErrorMessage

datefmt_get_error_message

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::getErrorMessage -- datefmt_get_error_message — Son işlemin hata iletisini döndürür

Açıklama

Nesne yönelimli kullanım

string IntlDateFormatter::getErrorMessage ( void )

Yordamsal kullanım

string datefmt_get_error_message ( IntlDateFormatter $biçemleyici )

Son işlemin hata iletisini döndürür.

Değiştirgeler

biçemleyici

Biçemleyici nesne.

Dönen Değerler

Son hatanın metni.

Örnekler

Örnek 1 - datefmt_get_error_message() örneği

<?php
$fmt = datefmt_create("en_US", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL,'America/Los_Angeles',
        IntlDateFormatter::GREGORIAN  );
$str = datefmt_format($fmt);
if(!$str) {
    echo "HATA: ".datefmt_get_error_message($fmt) . " (" .
          datefmt_get_error_code($fmt) . ")\n";
}
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$fmt = new IntlDateFormatter("en_US", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL,'America/Los_Angeles',
        IntlDateFormatter::GREGORIAN  );
$str = $fmt->format();
if(!$str) {
    echo "HATA: ".$fmt->getErrorMessage() . " (" .$fmt->getErrorCode() . ")\n";
}

?>

Yukarıdaki örneğin çıktısı:

HATA: U_ZERO_ERROR (0)

Ayrıca Bakınız

  • datefmt_get_error_code() - Son işlemin hata kodunu döndürür
  • intl_get_error_code() - Son hatanın kodunu döndürür
  • intl_is_failure() - Belirtilen hata kodunun bir başarısızlık göstergesi olup olmadığına bakar

IntlDateFormatter::getErrorCode
IntlDateFormatter::getLocale
IntlDateFormatter


Biçemleyicinin kullandığı yereli döndürür

IntlDateFormatter::getErrorMessage
IntlDateFormatter::getPattern
IntlDateFormatter
PHP Manual

IntlDateFormatter::getLocale

datefmt_get_locale

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::getLocale -- datefmt_get_locale — Biçemleyicinin kullandığı yereli döndürür

Açıklama

Nesne yönelimli kullanım

string IntlDateFormatter::getLocale ([ int $tür ] )

Yordamsal kullanım

string datefmt_get_locale ( IntlDateFormatter $biçemleyici [, int $tür ] )

Biçemleyicinin kullandığı yereli döndürür.

Değiştirgeler

biçemleyici

Biçemleyici nesne.

tür

Geçerli yerel için Locale::VALID_LOCALE, fiili yerel için Locale::ACTUAL_LOCALE belirtilir. Fiili yerel öntanımlıdır.

Dönen Değerler

Hata oluşmuşsa FALSE, oluşmamışsa biçemleyicinin kullandığı yerel.

Örnekler

Örnek 1 - datefmt_get_locale() örneği

<?php
$fmt = datefmt_create("en_US", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL,'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN  );
echo "Biçemleyici yereli: ".datefmt_get_locale($fmt);
echo "\nBiçemli çıktı: ".datefmt_format( $fmt , 0);

$fmt = datefmt_create("tr-TR", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL,'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN  );
echo "\nBiçemleyici yereli: ".datefmt_get_locale($fmt);
echo "\nYeni biçemli çıktı: ".datefmt_format( $fmt , 0);
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$fmt = new IntlDateFormatter("en_US", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL,'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN  );
echo "Biçemleyici yereli: ".$fmt->getLocale();
echo "\nBiçemli çıktı: ".$fmt->format(0);

$fmt = new IntlDateFormatter("tr-TR", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL,'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN  );
echo "\nBiçemleyici yereli: ".$fmt->getLocale();
echo "\nYeni biçemli çıktı: ".$fmt->format(0);
?>

Yukarıdaki örneğin çıktısı:

Biçemleyici yereli: en
Biçemli çıktı: Thursday, January 1, 1970 2:00:00 AM Turkey Time
Biçemleyici yereli: tr
Yeni biçemli çıktı: 01 Ocak 1970 Perşembe 02:00:00 Türkiye Saati

Ayrıca Bakınız

  • datefmt_create() - Bir tarih biçemleyici oluşturur

IntlDateFormatter::getErrorMessage
IntlDateFormatter::getPattern
IntlDateFormatter


IntlDateFormatter tarafından kullanılan kalıbı döndürür

IntlDateFormatter::getLocale
IntlDateFormatter::getTimeType
IntlDateFormatter
PHP Manual

IntlDateFormatter::getPattern

datefmt_get_pattern

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::getPattern -- datefmt_get_pattern — IntlDateFormatter tarafından kullanılan kalıbı döndürür

Açıklama

Nesne yönelimli kullanım

string IntlDateFormatter::getPattern ( void )

Yordamsal kullanım

string datefmt_get_pattern ( IntlDateFormatter $biçemleyici )

Biçemleyici tarafından kullanılan kalıbı döndürür.

Değiştirgeler

biçemleyici

Biçemleyici nesne.

Dönen Değerler

Çözümleme/biçemleme amacıyla kullanılan kalıp dizgesi.

Örnekler

Örnek 1 - datefmt_get_pattern() örneği

<?php
$fmt = datefmt_create(  "tr_TR" ,IntlDateFormatter::FULL,
        IntlDateFormatter::FULL, 'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN, "dd/MM/yyyy");
echo "Biçem kalıbı: ".datefmt_get_pattern($fmt)."\n";
echo "İlk biçem kalıplı çıktı: ".datefmt_format( $fmt , 0)."\n";
datefmt_set_pattern($fmt,'dd-MM-yyyy hh:mm:ss z');
echo "Yeni biçem kalıbı: ".datefmt_get_pattern($fmt)."\n";
echo "İkinci biçem kalıplı çıktı: ".datefmt_format( $fmt , 0)."\n";
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$fmt = new IntlDateFormatter( "tr_TR" ,IntlDateFormatter::FULL,
        IntlDateFormatter::FULL, 'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN, "dd/MM/yyyy"  );
echo "Biçem kalıbı: ".$fmt->getPattern()."\n";
echo "İlk biçem kalıplı çıktı: ".datefmt_format( $fmt , 0)."\n";
$fmt->setPattern('dd-MM-yyyy hh:mm:ss z');
echo "Yeni biçem kalıbı: ".$fmt->getPattern()."\n";
echo "İkinci biçem kalıplı çıktı: ".datefmt_format( $fmt , 0)."\n";
?>

Yukarıdaki örneğin çıktısı:

Biçem kalıbı: dd/MM/yyyy
İlk biçem kalıplı çıktı: 01/01/1970
Yeni biçem kalıbı: dd-MM-yyyy hh:mm:ss z
İkinci biçem kalıplı çıktı: 01-01-1970 02:00:00 GMT+02:00

Ayrıca Bakınız

  • datefmt_set_pattern() - IntlDateFormatter tarafından kullanılan kalıbı tanımlar
  • datefmt_create() - Bir tarih biçemleyici oluşturur

IntlDateFormatter::getLocale
IntlDateFormatter::getTimeType
IntlDateFormatter


IntlDateFormatter tarafından kullanılan zaman gösterim türünü döndürür

IntlDateFormatter::getPattern
IntlDateFormatter::getTimeZoneId
IntlDateFormatter
PHP Manual

IntlDateFormatter::getTimeType

datefmt_get_timetype

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::getTimeType -- datefmt_get_timetype — IntlDateFormatter tarafından kullanılan zaman gösterim türünü döndürür

Açıklama

Nesne yönelimli kullanım

int IntlDateFormatter::getTimeType ( void )

Yordamsal kullanım

int datefmt_get_timetype ( IntlDateFormatter $biçemleyici )

IntlDateFormatter tarafından kullanılan zaman gösterim türünü döndürür.

Değiştirgeler

biçemleyici

Biçemleyici nesne.

Dönen Değerler

Biçemleyicinin geçerli tarih gösterim türü.

Örnekler

Örnek 1 - datefmt_get_timetype() örneği

<?php
$fmt = datefmt_create("tr_TR", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL,'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN);
echo "Biçemleyicinin tarih gösterim türü: ".datefmt_get_timetype($fmt);
echo "\nBiçemli çıktı: ".datefmt_format($fmt, 1234567890);
$fmt = datefmt_create("tr_TR", IntlDateFormatter::FULL,
        IntlDateFormatter::SHORT, 'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN);
echo "\nBiçemleyicinin yeni tarih gösterim türü: ".datefmt_get_timetype($fmt);
echo "\nİkinci biçemli çıktı: ".datefmt_format($fmt, 1234567890);
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$fmt = new IntlDateFormatter("tr_TR", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL,'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN);
echo "Biçemleyicinin tarih gösterim türü: ".$fmt->getTimeType();
echo "\nBiçemli çıktı: ".datefmt_format( $fmt, 1234567890);
$fmt = new IntlDateFormatter("tr_TR", IntlDateFormatter::FULL,
        IntlDateFormatter::SHORT,'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN);
echo "\nBiçemleyicinin yeni tarih gösterim türü: ".$fmt->getTimeType();
echo "\nİkinci biçemli çıktı: ".datefmt_format( $fmt, 1234567890);
?>

Yukarıdaki örneğin çıktısı:

Biçemleyicinin tarih gösterim türü: 0
Biçemli çıktı: 14 Şubat 2009 Cumartesi 01:31:30 Türkiye Saati
Biçemleyicinin yeni tarih gösterim türü: 3
İkinci biçemli çıktı: 14 Şubat 2009 Cumartesi 01:31

Ayrıca Bakınız

  • datefmt_get_datetype() - IntlDateFormatter tarafından kullanılan tarih gösterim türünü döndürür
  • datefmt_create() - Bir tarih biçemleyici oluşturur

IntlDateFormatter::getPattern
IntlDateFormatter::getTimeZoneId
IntlDateFormatter


IntlDateFormatter tarafından kullanılan zaman dilimini döndürür

IntlDateFormatter::getTimeType
IntlDateFormatter::getCalendarObject
IntlDateFormatter
PHP Manual

IntlDateFormatter::getTimeZoneId

datefmt_get_timezone_id

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::getTimeZoneId -- datefmt_get_timezone_id — IntlDateFormatter tarafından kullanılan zaman dilimini döndürür

Açıklama

Nesne yönelimli kullanım

string IntlDateFormatter::getTimeZoneId ( void )

Yordamsal kullanım

string datefmt_get_timezone_id ( IntlDateFormatter $biçemleyici )

IntlDateFormatter tarafından kullanılan zaman dilimini döndürür.

Değiştirgeler

biçemleyici

Biçemleyici nesne.

Dönen Değerler

IntlDateFormatter tarafından kullanılan zaman dilimi.

Örnekler

Örnek 1 - datefmt_get_timezone_id() örneği

<?php
$fmt = datefmt_create(  "en_US" ,IntlDateFormatter::FULL,IntlDateFormatter::FULL,'America/Los_Angeles',IntlDateFormatter::GREGORIAN  );
echo "Biçemleyicinin zaman dilimi: ".datefmt_get_timezone_id($fmt);
datefmt_set_timezone_id($fmt,'CN');
echo "Yeni biçemleyicinin zaman dilimi: ".datefmt_get_timezone_id($fmt);

?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$fmt = new IntlDateFormatter( "en_US" ,IntlDateFormatter::FULL,IntlDateFormatter::FULL,'America/Los_Angeles',IntlDateFormatter::GREGORIAN  );
echo "timezone_id of the formatter is : ".$fmt->getTimezoneId();
$fmt->setTimezoneId('CN');
echo "Now timezone_id of the formatter is : ".$fmt->getTimezoneId();

?>

Yukarıdaki örneğin çıktısı:

Biçemleyicinin zaman dilimi: America/Los_Angeles
Yeni biçemleyicinin zaman dilimi: CN

Ayrıca Bakınız

  • datefmt_set_timezone_id() - Kullanılacak zaman dilimini tanımlar
  • datefmt_create() - Bir tarih biçemleyici oluşturur

IntlDateFormatter::getTimeType
IntlDateFormatter::getCalendarObject
IntlDateFormatter


Get copy of formatter's calendar object

IntlDateFormatter::getTimeZoneId
IntlDateFormatter::getTimeZone
IntlDateFormatter
PHP Manual

IntlDateFormatter::getCalendarObject

datefmt_get_calendar_object

(PHP 5 >= 5.5.0, PHP 7, PECL intl >= 3.0.0)

IntlDateFormatter::getCalendarObject -- datefmt_get_calendar_object — Get copy of formatter's calendar object

Açıklama

Nesne yönelimli kullanım

public IntlCalendar IntlDateFormatter::getCalendarObject ( void )

Yordamsal kullanım

IntlCalendar datefmt_get_calendar_object ( void )

Obtain a copy of the calendar object used internally by this formatter. This calendar will have a type (as in gregorian, japanese, buddhist, roc, persian, islamic, etc.) and a timezone that match the type and timezone used by the formatter. The date/time of the object is unspecified.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A copy of the internal calendar object used by this formatter.

Örnekler

Örnek 1 IntlDateFormatter::getCalendarObject() example

<?php
$formatter = IntlDateFormatter::create(
    "fr_FR@calendar=islamic",
    NULL,
    NULL,
    "GMT-01:00",
    IntlDateFormatter::TRADITIONAL
);

$cal = $formatter->getCalendarObject();

var_dump(
    $cal->getType(),
    $cal->getTimeZone(),
    $cal->getLocale(Locale::VALID_LOCALE)
);

Yukarıdaki örneğin çıktısı:

string(7) "islamic"
object(IntlTimeZone)#3 (4) {
  ["valid"]=>
  bool(true)
  ["id"]=>
  string(9) "GMT-01:00"
  ["rawOffset"]=>
  int(-3600000)
  ["currentOffset"]=>
  int(-3600000)
}
string(5) "fr_FR"

Ayrıca Bakınız

  • IntlDateFormatter::getCalendar() - IntlDateFormatter tarafından kullanılan takvimi döndürür
  • IntlDateFormatter::setCalendar() - Kullanılacak takvimi tanımlar
  • IntlCalendar

IntlDateFormatter::getTimeZoneId
IntlDateFormatter::getTimeZone
IntlDateFormatter


Get formatter's timezone

IntlDateFormatter::getCalendarObject
IntlDateFormatter::isLenient
IntlDateFormatter
PHP Manual

IntlDateFormatter::getTimeZone

datefmt_get_timezone

(PHP 5 >= 5.5.0, PHP 7, PECL intl >= 3.0.0)

IntlDateFormatter::getTimeZone -- datefmt_get_timezone — Get formatter's timezone

Açıklama

Nesne yönelimli kullanım

public IntlTimeZone IntlDateFormatter::getTimeZone ( void )

Yordamsal kullanım

IntlTimeZone datefmt_get_timezone ( void )

Returns an IntlTimeZone object representing the timezone that will be used by this object to format dates and times. When formatting IntlCalendar and DateTime objects with this IntlDateFormatter, the timezone used will be the one returned by this method, not the one associated with the objects being formatted.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The associated IntlTimeZone object başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 IntlDateFormatter::getTimeZone() examples

<?php

$madrid = IntlDateFormatter::create(NULL, NULL, NULL, 'Europe/Madrid');
$lisbon = IntlDateFormatter::create(NULL, NULL, NULL, 'Europe/Lisbon');

var_dump($madrid->getTimezone());
echo $madrid->getTimezone()->getDisplayName(
        false, IntlTimeZone::DISPLAY_GENERIC_LOCATION, "en_US"), "\n";
echo $lisbon->getTimeZone()->getId(), "\n";
//The id can also be retrieved with ->getTimezoneId()
echo $lisbon->getTimeZoneId(), "\n";

Yukarıdaki örneğin çıktısı:

object(IntlTimeZone)#4 (4) {
  ["valid"]=>
  bool(true)
  ["id"]=>
  string(13) "Europe/Madrid"
  ["rawOffset"]=>
  int(3600000)
  ["currentOffset"]=>
  int(7200000)
}
Spain Time
Europe/Lisbon
Europe/Lisbon

Ayrıca Bakınız

  • IntlDateFormatter::getTimeZoneId() - IntlDateFormatter tarafından kullanılan zaman dilimini döndürür
  • IntlDateFormatter::setTimeZone() - Sets formatter's timezone
  • IntlTimeZone

IntlDateFormatter::getCalendarObject
IntlDateFormatter::isLenient
IntlDateFormatter


IntlDateFormatter esnek çözümleme mi yapıyor diye bakar

IntlDateFormatter::getTimeZone
IntlDateFormatter::localtime
IntlDateFormatter
PHP Manual

IntlDateFormatter::isLenient

datefmt_is_lenient

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::isLenient -- datefmt_is_lenient — IntlDateFormatter esnek çözümleme mi yapıyor diye bakar

Açıklama

Nesne yönelimli kullanım

bool IntlDateFormatter::isLenient ( void )

Yordamsal kullanım

bool datefmt_is_lenient ( IntlDateFormatter $biçemleyici )

Kalıpla tam olarak eşleşmeyen girdilerin yorumlanmasında çözümleyicinin esnek mi yoksa katı mı davrandığına bakar.

Değiştirgeler

biçemleyici

Biçemleyici nesne.

Dönen Değerler

Çözümleyici esnekse TRUE değilse FALSE.

Örnekler

Örnek 1 - datefmt_is_lenient() örneği

<?php
$fmt = datefmt_create("tr_TR", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL, 'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN  ,"dd/mm/yyyy");
echo "Biçemleyici esnek mi?: ";
if( $fmt->isLenient() ){
        echo('EVET');
}else{
        echo('HAYIR');
}
datefmt_parse($fmt,"35/13/1971");
echo "\n '35/13/1971' çözümlenmeye çalışılıyor. Sonuç: " .
        datefmt_parse($fmt,"35/13/1971");
if( intl_get_error_code() !=0 ){
        echo "\n Hata iletisi: ".intl_get_error_message();
        echo "\n Hata kodu: ".intl_get_error_code();
}
datefmt_set_lenient($fmt,false);
echo "\nYeni biçemleyici esnek mi?: ";
if( $fmt->isLenient() ){
        echo('EVET');
}else{
        echo('HAYIR');
}
datefmt_parse($fmt,"35/13/1971");
echo "\n '35/13/1971' çözümlenmeye çalışılıyor. Sonuç: " .
        datefmt_parse($fmt,"35/13/1971");
if( intl_get_error_code() !=0 ){
        echo "\n Hata iletisi: ".intl_get_error_message();
        echo "\n Hata kodu: ".intl_get_error_code()."\n";
}
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$fmt = new IntlDateFormatter("tr_TR", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL, 'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN,"dd/mm/yyyy"  );
echo "Biçemleyici esnek mi?: ";
if( $fmt->isLenient() ){
        echo('EVET');
}else{
        echo('HAYIR');
}
$fmt->parse("35/13/1971");
echo "\n '35/13/1971' çözümlenmeye çalışılıyor. Sonuç: " .
        $fmt->parse("35/13/1971");
if( intl_get_error_code() !=0 ){
        echo "\n Hata iletisi: ".intl_get_error_message();
        echo "\n Hata kodu: ".intl_get_error_code();
}

$fmt->setLenient(FALSE);
echo "\nYeni biçemleyici esnek mi?: ";
if( $fmt->isLenient() ){
        echo('EVET');
}else{
        echo('HAYIR');
}
$fmt->parse("35/13/1971");
echo "\n '35/13/1971' çözümlenmeye çalışılıyor. Sonuç: " .$fmt->parse("35/13/1971");
if( intl_get_error_code() !=0 ){
        echo "\n Hata iletisi: ".intl_get_error_message();
        echo "\n Hata kodu: ".intl_get_error_code()."\n";
}
?>

Yukarıdaki örneğin çıktısı:

Biçemleyici esnek mi?: EVET
 '35/13/1971' çözümlenmeye çalışılıyor. Sonuç: 34467180
Yeni biçemleyici esnek mi?: HAYIR
 '35/13/1971' çözümlenmeye çalışılıyor. Sonuç:
 Hata iletisi: Date parsing failed: U_PARSE_ERROR
 Hata kodu: 9

Ayrıca Bakınız

  • datefmt_set_lenient() - Çözümleyiciye esneklik verir
  • datefmt_create() - Bir tarih biçemleyici oluşturur

IntlDateFormatter::getTimeZone
IntlDateFormatter::localtime
IntlDateFormatter


Tarih dizgesini alanlarına çözümler

IntlDateFormatter::isLenient
IntlDateFormatter::parse
IntlDateFormatter
PHP Manual

IntlDateFormatter::localtime

datefmt_localtime

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::localtime -- datefmt_localtime — Tarih dizgesini alanlarına çözümler

Açıklama

Nesne yönelimli kullanım

array IntlDateFormatter::localtime ( string $dizge [, int &$başlangıç ] )

Yordamsal kullanım

array datefmt_localtime ( IntlDateFormatter $biçemleyici , string $dizge [, int &$başlangıç ] )

Belirtilen dizge'nin başlangıç konumundan itibaren olabildiğince çok veri toplayarak tarihi oluşturan alanları bir dizi içine ayrıştırır.

Değiştirgeler

biçemleyici

Biçemleyici nesnesi.

dizge

Dönüştürülecek dizge.

başlangıç

başlangıç, dizgenin başlangıcı 0 kabul edilerek bulunur. Dizgeden veri toplanırken bir hata oluşmazsa, bu değiştirgeye -1 yerleştirilir, aksi takdirde hata oluştuğu sırada okunan son konum yerleştirilir. başlangıç > strlen($dizge) ise çözümleme, anında başarısız olur.

Dönen Değerler

Yerel zamana uygun, tamsayılardan oluşan bir dizi; 'tm_hour' alanındaki saat değeri, 24 saatliktir.

Örnekler

Örnek 1 - datefmt_localtime() örneği

<?php
$fmt = datefmt_create("en_US", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL, 'America/Los_Angeles',
        IntlDateFormatter::GREGORIAN  );
$arr = datefmt_localtime($fmt,
        "Wednesday, December 31, 1969 4:00:00 PM PT");
echo "Çözümleme sonucu:\n";
if ($arr) {
    foreach ($arr as $key => $value) {
        echo "$key : $value\n";
    }
}
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$fmt = new IntlDateFormatter("en_US", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL, 'America/Los_Angeles',
        1);
$arr = $fmt->localtime("Wednesday, December 31, 1969 4:00:00 PM PT");
echo "Çözümleme sonucu:\n";
if ($arr) {
    foreach ($arr as $key => $value) {
        echo "$key: $value\n";
    }
}
?>

Yukarıdaki örneğin çıktısı:

Çözümleme sonucu:
tm_sec: 0
tm_min: 0
tm_hour: 16
tm_year: 69
tm_mday: 31
tm_wday: 3
tm_yday: 365
tm_mon: 11
tm_isdst: 0

Ayrıca Bakınız

  • datefmt_create() - Bir tarih biçemleyici oluşturur
  • datefmt_format() - Tarih/saat değerini bir dizge olarak biçemler
  • datefmt_parse() - Dizgeyi bir zaman damgası değerine dönüştürür
  • datefmt_get_error_code() - Son işlemin hata kodunu döndürür
  • datefmt_get_error_message() - Son işlemin hata iletisini döndürür

IntlDateFormatter::isLenient
IntlDateFormatter::parse
IntlDateFormatter


Dizgeyi bir zaman damgası değerine dönüştürür

IntlDateFormatter::localtime
IntlDateFormatter::setCalendar
IntlDateFormatter
PHP Manual

IntlDateFormatter::parse

datefmt_parse

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::parse -- datefmt_parse — Dizgeyi bir zaman damgası değerine dönüştürür

Açıklama

Nesne yönelimli kullanım

int IntlDateFormatter::parse ( string $dizge [, int &$başlangıç ] )

Yordamsal kullanım

int datefmt_parse ( IntlDateFormatter $biçemleyici , string $dizge [, int &$başlangıç ] )

Belirtilen dizge'nin başlangıç konumundan itibaren olabildiğinçe çok veri toplayarak bir arttırımlı zaman değeri oluşturmaya çalışır.

Değiştirgeler

biçemleyici

Biçemleyici nesne.

dizge

Zaman damgasına dönüştürülecek dizge.

başlangıç

başlangıç, dizgenin başlangıcı 0 kabul edilerek bulunur. Dizgeden veri toplanırken bir hata oluşmazsa, bu değiştirgeye -1 yerleştirilir, aksi takdirde hata oluştuğu sırada okunan son konum yerleştirilir. başlangıç > strlen($dizge) ise çözümleme, anında başarısız olur.

Dönen Değerler

Zaman damgası.

Örnekler

Örnek 1 - datefmt_parse() örneği

<?php
$fmt = new IntlDateFormatter("en_US", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL, 'America/Los_Angeles',
        IntlDateFormatter::GREGORIAN  );
echo "İlk çözümleme sonucu: ".
        $fmt->parse("Wednesday, December 20, 1989 4:00:00 PM PT");
$fmt = new IntlDateFormatter("tr-TR", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL, 'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN  );
echo "\nİkinci  çözümleme sonucu: ".
        $fmt->parse("21 Aralık 1989 Perşembe 02:00:00 Türkiye Saati")."\n";
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$fmt = datefmt_create( "en_US", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL,'America/Los_Angeles',
        IntlDateFormatter::GREGORIAN  );
echo "İlk çözümleme sonucu: ". datefmt_parse( $fmt,
        "Wednesday, December 20, 1989 4:00:00 PM PT");
$fmt = datefmt_create( "tr-TR", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL,'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN  );
echo "\nİkinci  çözümleme sonucu: ".datefmt_parse( $fmt,
        "21 Aralık 1989 Perşembe 02:00:00 Türkiye Saati")."\n";
?>

Yukarıdaki örneğin çıktısı:

İlk çözümleme sonucu: 630201600
İkinci  çözümleme sonucu: 630201600

Ayrıca Bakınız

  • datefmt_create() - Bir tarih biçemleyici oluşturur
  • datefmt_format() - Tarih/saat değerini bir dizge olarak biçemler
  • datefmt_localtime() - Tarih dizgesini alanlarına çözümler
  • datefmt_get_error_code() - Son işlemin hata kodunu döndürür
  • datefmt_get_error_message() - Son işlemin hata iletisini döndürür

IntlDateFormatter::localtime
IntlDateFormatter::setCalendar
IntlDateFormatter


Kullanılacak takvimi tanımlar

IntlDateFormatter::parse
IntlDateFormatter::setLenient
IntlDateFormatter
PHP Manual

IntlDateFormatter::setCalendar

datefmt_set_calendar

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::setCalendar -- datefmt_set_calendar — Kullanılacak takvimi tanımlar

Açıklama

Nesne yönelimli kullanım

bool IntlDateFormatter::setCalendar ( int $takvim )

Yordamsal kullanım

bool datefmt_set_calendar ( IntlDateFormatter $biçemleyici , int $takvim )

Biçemleyici tarafından kullanılacak takvimi tanımlar.

Değiştirgeler

biçemleyici

Biçemleyici nesne.

takvim

Kullanılacak takvim IntlDateFormatter::GREGORIAN öntanımlıdır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - datefmt_set_calendar() örneği

<?php
$fmt = datefmt_create("tr_TR", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL, 'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN);
echo "Biçemleyici takvimi: ".datefmt_get_calendar($fmt);
datefmt_set_calendar($fmt,IntlDateFormatter::TRADITIONAL);
echo "\nYenisi: ".datefmt_get_calendar($fmt);
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$fmt = new IntlDateFormatter("tr_TR", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL, 'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN  );
echo "Biçemleyici takvimi: ".$fmt->getCalendar();
$fmt->setCalendar(IntlDateFormatter::TRADITIONAL);
echo "\nYenisi: ".$fmt->getCalendar();
?>

Yukarıdaki örneğin çıktısı:

Biçemleyici takvimi: 1
Yenisi: 0

Ayrıca Bakınız

  • datefmt_get_calendar() - IntlDateFormatter tarafından kullanılan takvimi döndürür
  • datefmt_create() - Bir tarih biçemleyici oluşturur

IntlDateFormatter::parse
IntlDateFormatter::setLenient
IntlDateFormatter


Çözümleyiciye esneklik verir

IntlDateFormatter::setCalendar
IntlDateFormatter::setPattern
IntlDateFormatter
PHP Manual

IntlDateFormatter::setLenient

datefmt_set_lenient

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::setLenient -- datefmt_set_lenient — Çözümleyiciye esneklik verir

Açıklama

Nesne yönelimli kullanım

bool IntlDateFormatter::setLenient ( bool $esnek )

Yordamsal kullanım

bool datefmt_set_lenient ( IntlDateFormatter $biçemleyici , bool $esnek )

Kalıpla tam olarak eşleşmeyen girdilerin yorumlanmasında çözümleyicinin esnek mi yoksa katı mı davranacağını belirler. Esnek çözümleme etkin olduğunda çözümleyici kusurlu tarih ve saat kalıplarını kabul eder ve olabildiğince bir değer oluşturmaya çalışır. Fazladan boşluklar, tanınmayan dizgecikler veya geçersiz değerler ("February 30th" gibi) kabul edilmez.

Değiştirgeler

biçemleyici

Biçemleyici nesne.

esnek

Çözümleyicinin esnek olması isteniyorsa TRUE istenmiyorsa FALSE belirtilir. FALSE öntanımlıdır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - datefmt_set_lenient() örneği

<?php
$fmt = datefmt_create("tr_TR", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL, 'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN  ,"dd/mm/yyyy");
echo "Biçemleyici esnek mi?: ";
if( $fmt->isLenient() ){
        echo('EVET');
}else{
        echo('HAYIR');
}
datefmt_parse($fmt,"35/13/1971");
echo "\n '35/13/1971' çözümlenmeye çalışılıyor. Sonuç: " .
        datefmt_parse($fmt,"35/13/1971");
if( intl_get_error_code() !=0 ){
        echo "\n Hata iletisi: ".intl_get_error_message();
        echo "\n Hata kodu: ".intl_get_error_code();
}
datefmt_set_lenient($fmt,false);
echo "\nYeni biçemleyici esnek mi?: ";
if( $fmt->isLenient() ){
        echo('EVET');
}else{
        echo('HAYIR');
}
datefmt_parse($fmt,"35/13/1971");
echo "\n '35/13/1971' çözümlenmeye çalışılıyor. Sonuç: " .
        datefmt_parse($fmt,"35/13/1971");
if( intl_get_error_code() !=0 ){
        echo "\n Hata iletisi: ".intl_get_error_message();
        echo "\n Hata kodu: ".intl_get_error_code()."\n";
}
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$fmt = new IntlDateFormatter("tr_TR", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL, 'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN,"dd/mm/yyyy"  );
echo "Biçemleyici esnek mi?: ";
if( $fmt->isLenient() ){
        echo('EVET');
}else{
        echo('HAYIR');
}
$fmt->parse("35/13/1971");
echo "\n '35/13/1971' çözümlenmeye çalışılıyor. Sonuç: " .
        $fmt->parse("35/13/1971");
if( intl_get_error_code() !=0 ){
        echo "\n Hata iletisi: ".intl_get_error_message();
        echo "\n Hata kodu: ".intl_get_error_code();
}

$fmt->setLenient(FALSE);
echo "\nYeni biçemleyici esnek mi?: ";
if( $fmt->isLenient() ){
        echo('EVET');
}else{
        echo('HAYIR');
}
$fmt->parse("35/13/1971");
echo "\n '35/13/1971' çözümlenmeye çalışılıyor. Sonuç: " .$fmt->parse("35/13/1971");
if( intl_get_error_code() !=0 ){
        echo "\n Hata iletisi: ".intl_get_error_message();
        echo "\n Hata kodu: ".intl_get_error_code()."\n";
}
?>

Yukarıdaki örneğin çıktısı:

Biçemleyici esnek mi?: EVET
 '35/13/1971' çözümlenmeye çalışılıyor. Sonuç: 34467180
Yeni biçemleyici esnek mi?: HAYIR
 '35/13/1971' çözümlenmeye çalışılıyor. Sonuç:
 Hata iletisi: Date parsing failed: U_PARSE_ERROR
 Hata kodu: 9

Ayrıca Bakınız

  • datefmt_is_lenient() - IntlDateFormatter esnek çözümleme mi yapıyor diye bakar
  • datefmt_create() - Bir tarih biçemleyici oluşturur

IntlDateFormatter::setCalendar
IntlDateFormatter::setPattern
IntlDateFormatter


IntlDateFormatter tarafından kullanılan kalıbı tanımlar

IntlDateFormatter::setLenient
IntlDateFormatter::setTimeZoneId
IntlDateFormatter
PHP Manual

IntlDateFormatter::setPattern

datefmt_set_pattern

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

IntlDateFormatter::setPattern -- datefmt_set_pattern — IntlDateFormatter tarafından kullanılan kalıbı tanımlar

Açıklama

Nesne yönelimli kullanım

bool IntlDateFormatter::setPattern ( string $kalıp )

Yordamsal kullanım

bool datefmt_set_pattern ( IntlDateFormatter $biçemleyici , string $kalıp )

IntlDateFormatter tarafından kullanılan kalıbı tanımlar.

Değiştirgeler

biçemleyici

Biçemleyici nesne.

kalıp

Kullanılacak kalıp dizgesi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. Yanlış oluşturulmuş biçem dizgeleri genelde hataya sebep olur.

Örnekler

Örnek 1 - datefmt_set_pattern() örneği

<?php
$fmt = datefmt_create(  "tr_TR" ,IntlDateFormatter::FULL,
        IntlDateFormatter::FULL, 'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN, "dd/MM/yyyy");
echo "Biçem kalıbı: ".datefmt_get_pattern($fmt)."\n";
echo "İlk biçem kalıplı çıktı: ".datefmt_format( $fmt , 0)."\n";
datefmt_set_pattern($fmt,'dd-MM-yyyy hh:mm:ss z');
echo "Yeni biçem kalıbı: ".datefmt_get_pattern($fmt)."\n";
echo "İkinci biçem kalıplı çıktı: ".datefmt_format( $fmt , 0)."\n";
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$fmt = new IntlDateFormatter( "tr_TR" ,IntlDateFormatter::FULL,
        IntlDateFormatter::FULL, 'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN, "dd/MM/yyyy"  );
echo "Biçem kalıbı: ".$fmt->getPattern()."\n";
echo "İlk biçem kalıplı çıktı: ".datefmt_format( $fmt , 0)."\n";
$fmt->setPattern('dd-MM-yyyy hh:mm:ss z');
echo "Yeni biçem kalıbı: ".$fmt->getPattern()."\n";
echo "İkinci biçem kalıplı çıktı: ".datefmt_format( $fmt , 0)."\n";
?>

Yukarıdaki örneğin çıktısı:

Biçem kalıbı: dd/MM/yyyy
İlk biçem kalıplı çıktı: 01/01/1970
Yeni biçem kalıbı: dd-MM-yyyy hh:mm:ss z
İkinci biçem kalıplı çıktı: 01-01-1970 02:00:00 GMT+02:00

Ayrıca Bakınız

  • datefmt_get_pattern() - IntlDateFormatter tarafından kullanılan kalıbı döndürür
  • datefmt_create() - Bir tarih biçemleyici oluşturur

IntlDateFormatter::setLenient
IntlDateFormatter::setTimeZoneId
IntlDateFormatter


Kullanılacak zaman dilimini tanımlar

IntlDateFormatter::setPattern
IntlDateFormatter::setTimeZone
IntlDateFormatter
PHP Manual

IntlDateFormatter::setTimeZoneId

datefmt_set_timezone_id

(PHP 5 >= 5.3.0, PECL intl >= 1.0.0)

IntlDateFormatter::setTimeZoneId -- datefmt_set_timezone_id — Kullanılacak zaman dilimini tanımlar

Açıklama

Nesne yönelimli kullanım

bool IntlDateFormatter::setTimeZoneId ( string $zaman_dilimi )

Yordamsal kullanım

bool datefmt_set_timezone_id ( IntlDateFormatter $biçemleyici , string $zaman_dilimi )

Kullanılacak zaman dilimini tanımlar.

Değiştirgeler

biçemleyici

Biçemleyici nesne.

zaman_dilimi

Kullanılacak zaman dilimini içeren dizge. NULL veya boş dizge belirtilirse öntanımlı zaman dilimi kullanılır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - datefmt_set_timezone_id() örneği

<?php
$fmt = datefmt_create(  "tr_TR", IntlDateFormatter::FULL,
        IntlDateFormatter::FULL, 'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN  );
echo "Biçemleyicinin zaman dilimi: ".datefmt_get_timezone_id($fmt)."\n";
datefmt_set_timezone_id($fmt,'CN');
echo "Biçemleyicinin zaman dilimi: ".datefmt_get_timezone_id($fmt)."\n";
?>

Örnek 2 - Nesne yönelimli kullanım örneği

<?php
$fmt = new IntlDateFormatter( "tr_TR" ,IntlDateFormatter::FULL,
        IntlDateFormatter::FULL, 'Europe/Istanbul',
        IntlDateFormatter::GREGORIAN  );
echo "Biçemleyicinin zaman dilimi: ".$fmt->getTimezoneId();
$fmt->setTimezoneId('CN');
echo "Biçemleyicinin zaman dilimi: ".$fmt->getTimezoneId();

?>

Yukarıdaki örneğin çıktısı:

Biçemleyicinin zaman dilimi: Europe/Istanbul
Biçemleyicinin yeni zaman dilimi: CN

Ayrıca Bakınız

  • datefmt_get_timezone_id() - IntlDateFormatter tarafından kullanılan zaman dilimini döndürür
  • datefmt_create() - Bir tarih biçemleyici oluşturur

IntlDateFormatter::setPattern
IntlDateFormatter::setTimeZone
IntlDateFormatter


Sets formatter's timezone

IntlDateFormatter::setTimeZoneId
Grapheme İşlevleri
IntlDateFormatter
PHP Manual

IntlDateFormatter::setTimeZone

datefmt_set_timezone

(PHP 5 >= 5.5.0, PHP 7, PECL intl >= 3.0.0)

IntlDateFormatter::setTimeZone -- datefmt_set_timezone — Sets formatter's timezone

Açıklama

Nesne yönelimli kullanım

public boolean IntlDateFormatter::setTimeZone ( mixed $zone )

Yordamsal kullanım

boolean datefmt_set_timezone ( mixed $zone )

Sets the timezone that will be used when formatting dates or times with this object.

Değiştirgeler

zone

The timezone to use for this formatter. This can be specified in the following forms:

  • NULL, in which case the default timezone will be used, as specified in the ini setting date.timezone or through the function date_default_timezone_set() and as returned by date_default_timezone_get().

  • An IntlTimeZone, which will be used directly.

  • A DateTimeZone. Its identifier will be extracted and an ICU timezone object will be created; the timezone will be backed by ICU's database, not PHP's.

  • A string, which should be a valid ICU timezone identifier. See IntlTimeZone::createTimeZoneIDEnumeration(). Raw offsets such as "GMT+08:30" are also accepted.

Dönen Değerler

Returns TRUE on success and FALSE on failure.

Örnekler

Örnek 1 IntlDateFormatter::setTimeZone() examples

<?php
ini_set('date.timezone', 'Europe/Amsterdam');

$formatter = IntlDateFormatter::create(NULL, NULL, NULL, "UTC");

$formatter->setTimeZone(NULL);
echo "NULL\n    ", $formatter->getTimeZone()->getId(), "\n";

$formatter->setTimeZone(IntlTimeZone::createTimeZone('Europe/Lisbon'));
echo "IntlTimeZone\n    ", $formatter->getTimeZone()->getId(), "\n";

$formatter->setTimeZone(new DateTimeZone('Europe/Paris'));
echo "DateTimeZone\n    ", $formatter->getTimeZone()->getId(), "\n";

$formatter->setTimeZone('Europe/Rome');
echo "String\n    ", $formatter->getTimeZone()->getId(), "\n";

$formatter->setTimeZone('GMT+00:30');
print_r($formatter->getTimeZone());

Yukarıdaki örneğin çıktısı:

NULL
    Europe/Amsterdam
IntlTimeZone
    Europe/Lisbon
DateTimeZone
    Europe/Paris
String
    Europe/Rome
IntlTimeZone Object
(
    [valid] => 1
    [id] => GMT+00:30
    [rawOffset] => 1800000
    [currentOffset] => 1800000
)

Ayrıca Bakınız

  • IntlDateFormatter::getTimeZone() - Get formatter's timezone

IntlDateFormatter::setTimeZoneId
Grapheme İşlevleri
IntlDateFormatter


Grapheme İşlevleri

İçindekiler

  • grapheme_extract — UTF-8 kodlanmış bir metin tamponundan öntanımlı sesletim kümelerinden oluşan bir dizilimi döndürür
  • grapheme_stripos — Harf büyüklüğüne duyarsız olarak bir dizgede ilk sesletim biriminin yerini bulur
  • grapheme_stristr — Harf büyüklüğüne duyarsız olarak bir dizgedeki ilk sesletim birimine göre ilk veya ikinci parça ile döner
  • grapheme_strlen — Dizgenin sesletim birimi cinsinden uzunluğunu döndürür
  • grapheme_strpos — Bir dizgede ilk sesletim biriminin yerini bulur
  • grapheme_strripos — Harf büyüklüğüne duyarsız olarak bir dizgedeki sonuncu sesletim biriminin yerini bulur
  • grapheme_strrpos — Bir dizgedeki sonuncu sesletim biriminin yerini bulur
  • grapheme_strstr — Bir dizgedeki ilk sesletim birimine göre ilk veya ikinci parça ile döner
  • grapheme_substr — Bir alt dizge döndürür
IntlDateFormatter::setTimeZone
grapheme_extract
intl


UTF-8 kodlanmış bir metin tamponundan öntanımlı sesletim kümelerinden oluşan bir dizilimi döndürür

Grapheme İşlevleri
grapheme_stripos
Grapheme İşlevleri
PHP Manual

grapheme_extract

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

grapheme_extract — UTF-8 kodlanmış bir metin tamponundan öntanımlı sesletim kümelerinden oluşan bir dizilimi döndürür

Açıklama

Yordamsal kullanım

string grapheme_extract ( string $samanlık , int $boyut [, int $birim [, int $başlangıç [, int &$sonraki ]]] )

UTF-8 kodlanmış bir metin tamponundan öntanımlı sesletim kümelerinden oluşan bir dizilimi döndürür.

Değiştirgeler

samanlık

Aramanın yapılacağı dizge.

boyut

Döndürülecek azami birim sayısı.

birim

boyut değiştirgesini oluşturacak birim türü:

  • GRAPHEME_EXTR_COUNT (öntanımlı) - boyut, döndürülecek öntanımlı sesletim kümesi sayısıdır.
  • GRAPHEME_EXTR_MAXBYTES - boyut, döndürülecek azami bayt sayısıdır.
  • GRAPHEME_EXTR_MAXCHARS - boyut, döndürülecek UTF-8 karakterlerin azami sayısıdır.
başlangıç

Bayt cinsinden aramanın başlatılacağı konum. Belirtildiği takdirde, sıfır veya samanlık uzunluğuna eşit veya daha küçük bir pozitif tamsayı olmalıdır. başlangıç bir UTF-8 karakterin ilk baytı değilse, sonraki karakterin ilk baytına taşınır.

sonraki

Sonraki aramanın başlangıç konumu. Çağrı sonunda dönen dizgenin son karakterinden sonraki ilk baytın konumu olacaktır.

Dönen Değerler

Belirtilen başlangıç konumunda başlayıp, boyut ve birim değiştirgelerine göre uzunluğu belirlenen bir öntanımlı sesletim kümesini içeren bir dizge ile döner.

Örnekler

Örnek 1 - grapheme_extract() örneği

<?php
$char_a_ring_nfd = "a\xCC\x8A";      // 'å' (U+00E5) normalleştirme biçimi "D"
$char_o_diaeresis_nfd = "o\xCC\x88"; // 'ö' (U+00F6) normalleştirme biçimi "D"

print urlencode(grapheme_extract( $char_a_ring_nfd . $char_o_diaeresis_nfd, 1,
                                  GRAPHEME_EXTR_COUNT, 2));

?>

Yukarıdaki örneğin çıktısı:

o%CC%88

Ayrıca Bakınız

  • grapheme_substr() - Bir alt dizge döndürür
  • » Unicode Text Segmentation: Grapheme Cluster Boundaries

Grapheme İşlevleri
grapheme_stripos
Grapheme İşlevleri


Harf büyüklüğüne duyarsız olarak bir dizgede ilk sesletim biriminin yerini bulur

grapheme_extract
grapheme_stristr
Grapheme İşlevleri
PHP Manual

grapheme_stripos

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

grapheme_stripos — Harf büyüklüğüne duyarsız olarak bir dizgede ilk sesletim biriminin yerini bulur

Açıklama

Yordamsal kullanım

int grapheme_stripos ( string $samanlık , string $iğne [, int $başlangıç ] )

Harf büyüklüğüne duyarsız olarak bir dizgede ilk sesletim biriminin yerini bulur.

Değiştirgeler

samanlık

Aramanın yapılacağı dizge. Geçerli bir UTF-8 dizgesi olmalıdır.

iğne

Aranacak dizge. Geçerli bir UTF-8 dizgesi olmalıdır.

başlangıç

samanlık içinde aramanın başlatılacağı yeri belirten isteğe bağlı değiştirge. Konum, bayt veya karakter değil, sesletim birimi cinsinden belirtilmelidir. Belirtilmezse sıfır öntanımlıdır. Döndürülen konum, belirtilen başlangıç konumuna göre değil, samanlık dizgesinin başlangıcına göredir.

Dönen Değerler

Konumu bir tamsayı olarak döndürür. iğne bulunamazsa işlev FALSE döndürür.

Örnekler

Örnek 1 - grapheme_stripos() örneği

<?php

$char_a_ring_nfd = "a\xCC\x8A";      // 'å' (U+00E5) normalleştirme biçimi "D"
$char_o_diaeresis_nfd = "o\xCC\x88"; // 'ö' (U+00F6) normalleştirme biçimi "D"
$char_O_diaeresis_nfd = "O\xCC\x88"; // 'Ö' (U+00D6) normalleştirme biçimi "D"

print grapheme_stripos( $char_a_ring_nfd . $char_a_ring_nfd .
                        $char_o_diaeresis_nfd, $char_O_diaeresis_nfd);

?>

Yukarıdaki örneğin çıktısı:

2

Ayrıca Bakınız

  • grapheme_stristr() - Harf büyüklüğüne duyarsız olarak bir dizgedeki ilk sesletim birimine göre ilk veya ikinci parça ile döner
  • grapheme_strpos() - Bir dizgede ilk sesletim biriminin yerini bulur
  • grapheme_strripos() - Harf büyüklüğüne duyarsız olarak bir dizgedeki sonuncu sesletim biriminin yerini bulur
  • grapheme_strrpos() - Bir dizgedeki sonuncu sesletim biriminin yerini bulur
  • grapheme_strstr() - Bir dizgedeki ilk sesletim birimine göre ilk veya ikinci parça ile döner
  • » Unicode Text Segmentation: Grapheme Cluster Boundaries

grapheme_extract
grapheme_stristr
Grapheme İşlevleri


Harf büyüklüğüne duyarsız olarak bir dizgedeki ilk sesletim birimine göre ilk veya ikinci parça ile döner

grapheme_stripos
grapheme_strlen
Grapheme İşlevleri
PHP Manual

grapheme_stristr

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

grapheme_stristr — Harf büyüklüğüne duyarsız olarak bir dizgedeki ilk sesletim birimine göre ilk veya ikinci parça ile döner

Açıklama

Yordamsal kullanım

string grapheme_stristr ( string $samanlık , string $iğne [, bool $ilk_parça ] )

Harf büyüklüğüne duyarsız olarak bir dizgedeki ilk sesletim birimine göre ilk veya ikinci parça ile döner

Değiştirgeler

samanlık

Aramanın yapılacağı dizge. Geçerli bir UTF-8 dizgesi olmalıdır.

iğne

Aranacak dizge. Geçerli bir UTF-8 dizgesi olmalıdır.

ilk_parça

TRUE ise iğne'nin bulunduğu ilk konuma göre samanlık dizgesinin ilk parçası döner. Öntanımlı değer: FALSE.

Dönen Değerler

iğne bulunamazsa FALSE, aksi takdirde dizge parçası ile döner.

Örnekler

Örnek 1 - grapheme_stristr() örneği

<?php

$char_a_ring_nfd = "a\xCC\x8A";      // 'å' (U+00E5) normalleştirme biçimi "D"
$char_o_diaeresis_nfd = "o\xCC\x88"; // 'ö' (U+00F6) normalleştirme biçimi "D"
$char_O_diaeresis_nfd = "O\xCC\x88"; // 'Ö' (U+00D6) normalleştirme biçimi "D"

print urlencode(grapheme_stristr( $char_a_ring_nfd . $char_o_diaeresis_nfd .
                $char_a_ring_nfd, $char_O_diaeresis_nfd));

?>

Yukarıdaki örneğin çıktısı:

o%CC%88a%CC%8A

Ayrıca Bakınız

  • grapheme_stripos() - Harf büyüklüğüne duyarsız olarak bir dizgede ilk sesletim biriminin yerini bulur
  • grapheme_strpos() - Bir dizgede ilk sesletim biriminin yerini bulur
  • grapheme_strripos() - Harf büyüklüğüne duyarsız olarak bir dizgedeki sonuncu sesletim biriminin yerini bulur
  • grapheme_strrpos() - Bir dizgedeki sonuncu sesletim biriminin yerini bulur
  • grapheme_strstr() - Bir dizgedeki ilk sesletim birimine göre ilk veya ikinci parça ile döner
  • » Unicode Text Segmentation: Grapheme Cluster Boundaries

grapheme_stripos
grapheme_strlen
Grapheme İşlevleri


Dizgenin sesletim birimi cinsinden uzunluğunu döndürür

grapheme_stristr
grapheme_strpos
Grapheme İşlevleri
PHP Manual

grapheme_strlen

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

grapheme_strlen — Dizgenin sesletim birimi cinsinden uzunluğunu döndürür

Açıklama

Yordamsal kullanım

int grapheme_strlen ( string $dizge )

Dizgenin sesletim birimi (bayt veya karakter değil) cinsinden uzunluğunu döndürür

Değiştirgeler

dizge

Uzunluğu sesletim birimi cinsinden ölçülecek dizge. Geçerli bir UTF-8 dizgesi olmalıdır.

Dönen Değerler

Dizge boşsa 0, değilse dizgenin uzunluğu.

Örnekler

Örnek 1 - grapheme_strlen() örneği

<?php

$char_a_ring_nfd = "a\xCC\x8A";      // 'å' (U+00E5) normalleştirme biçimi "D"
$char_o_diaeresis_nfd = "o\xCC\x88"; // 'ö' (U+00F6) normalleştirme biçimi "D"

print grapheme_strlen( 'abc' . $char_a_ring_nfd . $char_o_diaeresis_nfd .
                       $char_a_ring_nfd);

?>

Yukarıdaki örneğin çıktısı:

6

Ayrıca Bakınız

  • » Unicode Text Segmentation: Grapheme Cluster Boundaries

grapheme_stristr
grapheme_strpos
Grapheme İşlevleri


Bir dizgede ilk sesletim biriminin yerini bulur

grapheme_strlen
grapheme_strripos
Grapheme İşlevleri
PHP Manual

grapheme_strpos

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

grapheme_strpos — Bir dizgede ilk sesletim biriminin yerini bulur

Açıklama

Yordamsal kullanım

int grapheme_strpos ( string $samanlık , string $iğne [, int $başlangıç ] )

Bir dizgede ilk sesletim biriminin yerini bulur.

Değiştirgeler

samanlık

Aramanın yapılacağı dizge. Geçerli bir UTF-8 dizgesi olmalıdır.

iğne

Aranacak dizge. Geçerli bir UTF-8 dizgesi olmalıdır.

başlangıç

samanlık içinde aramanın başlatılacağı yeri belirten isteğe bağlı değiştirge. Konum, bayt veya karakter değil, sesletim birimi cinsinden belirtilmelidir. Belirtilmezse sıfır öntanımlıdır. Döndürülen konum, belirtilen başlangıç konumuna göre değil, samanlık dizgesinin başlangıcına göredir.

Dönen Değerler

Konumu bir tamsayı olarak döndürür. iğne bulunamazsa işlev FALSE döndürür.

Örnekler

Örnek 1 - grapheme_strpos() örneği

<?php

$char_a_ring_nfd = "a\xCC\x8A";      // 'å' (U+00E5) normalleştirme biçimi "D"
$char_o_diaeresis_nfd = "o\xCC\x88"; // 'ö' (U+00F6) normalleştirme biçimi "D"

print grapheme_strpos( $char_a_ring_nfd . $char_a_ring_nfd .
                       $char_o_diaeresis_nfd, $char_o_diaeresis_nfd);

?>

Yukarıdaki örneğin çıktısı:

2

Ayrıca Bakınız

  • grapheme_stripos() - Harf büyüklüğüne duyarsız olarak bir dizgede ilk sesletim biriminin yerini bulur
  • grapheme_stristr() - Harf büyüklüğüne duyarsız olarak bir dizgedeki ilk sesletim birimine göre ilk veya ikinci parça ile döner
  • grapheme_strripos() - Harf büyüklüğüne duyarsız olarak bir dizgedeki sonuncu sesletim biriminin yerini bulur
  • grapheme_strrpos() - Bir dizgedeki sonuncu sesletim biriminin yerini bulur
  • grapheme_strstr() - Bir dizgedeki ilk sesletim birimine göre ilk veya ikinci parça ile döner
  • » Unicode Text Segmentation: Grapheme Cluster Boundaries

grapheme_strlen
grapheme_strripos
Grapheme İşlevleri


Harf büyüklüğüne duyarsız olarak bir dizgedeki sonuncu sesletim biriminin yerini bulur

grapheme_strpos
grapheme_strrpos
Grapheme İşlevleri
PHP Manual

grapheme_strripos

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

grapheme_strripos — Harf büyüklüğüne duyarsız olarak bir dizgedeki sonuncu sesletim biriminin yerini bulur

Açıklama

Yordamsal kullanım

int grapheme_strripos ( string $samanlık , string $iğne [, int $konum ] )

Harf büyüklüğüne duyarsız olarak bir dizgedeki sonuncu sesletim biriminin yerini bulur.

Değiştirgeler

samanlık

Aramanın yapılacağı dizge. Geçerli bir UTF-8 dizgesi olmalıdır.

iğne

Aranacak dizge. Geçerli bir UTF-8 dizgesi olmalıdır.

başlangıç

samanlık içinde aramanın başlatılacağı yeri belirten isteğe bağlı değiştirge. Konum, bayt veya karakter değil, sesletim birimi cinsinden belirtilmelidir. Belirtilmezse sıfır öntanımlıdır. Döndürülen konum, belirtilen başlangıç konumuna göre değil, samanlık dizgesinin başlangıcına göredir.

Dönen Değerler

Konumu bir tamsayı olarak döndürür. iğne bulunamazsa işlev FALSE döndürür.

Örnekler

Örnek 1 - grapheme_strripos() örneği

<?php

$char_a_ring_nfd = "a\xCC\x8A";      // 'å' (U+00E5) normalleştirme biçimi "D"
$char_o_diaeresis_nfd = "o\xCC\x88"; // 'ö' (U+00F6) normalleştirme biçimi "D"
$char_O_diaeresis_nfd = "O\xCC\x88"; // 'Ö' (U+00D6) normalleştirme biçimi "D"

print grapheme_strripos( $char_a_ring_nfd . $char_o_diaeresis_nfd .
                         $char_o_diaeresis_nfd, $char_O_diaeresis_nfd);

?>

Yukarıdaki örneğin çıktısı:

2

Ayrıca Bakınız

  • grapheme_stripos() - Harf büyüklüğüne duyarsız olarak bir dizgede ilk sesletim biriminin yerini bulur
  • grapheme_stristr() - Harf büyüklüğüne duyarsız olarak bir dizgedeki ilk sesletim birimine göre ilk veya ikinci parça ile döner
  • grapheme_strpos() - Bir dizgede ilk sesletim biriminin yerini bulur
  • grapheme_strrpos() - Bir dizgedeki sonuncu sesletim biriminin yerini bulur
  • grapheme_strstr() - Bir dizgedeki ilk sesletim birimine göre ilk veya ikinci parça ile döner
  • » Unicode Text Segmentation: Grapheme Cluster Boundaries

grapheme_strpos
grapheme_strrpos
Grapheme İşlevleri


Bir dizgedeki sonuncu sesletim biriminin yerini bulur

grapheme_strripos
grapheme_strstr
Grapheme İşlevleri
PHP Manual

grapheme_strrpos

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

grapheme_strrpos — Bir dizgedeki sonuncu sesletim biriminin yerini bulur

Açıklama

Yordamsal kullanım

int grapheme_strrpos ( string $samanlık , string $iğne [, int $başlangıç ] )

Bir dizgedeki sonuncu sesletim biriminin yerini bulur.

Değiştirgeler

samanlık

Aramanın yapılacağı dizge. Geçerli bir UTF-8 dizgesi olmalıdır.

iğne

Aranacak dizge. Geçerli bir UTF-8 dizgesi olmalıdır.

başlangıç

samanlık içinde aramanın başlatılacağı yeri belirten isteğe bağlı değiştirge. Konum, bayt veya karakter değil, sesletim birimi cinsinden belirtilmelidir. Belirtilmezse sıfır öntanımlıdır. Döndürülen konum, belirtilen başlangıç konumuna göre değil, samanlık dizgesinin başlangıcına göredir.

Dönen Değerler

Konumu bir tamsayı olarak döndürür. iğne bulunamazsa işlev FALSE döndürür.

Örnekler

Örnek 1 - grapheme_strrpos() örneği

< ?php

$char_a_ring_nfd = "a\xCC\x8A";      // 'å' (U+00E5) normalleştirme biçimi "D"
$char_o_diaeresis_nfd = "o\xCC\x88"; // 'ö' (U+00F6) normalleştirme biçimi "D"

print grapheme_strrpos( $char_a_ring_nfd . $char_o_diaeresis_nfd .
                        $char_o_diaeresis_nfd, $char_o_diaeresis_nfd);

?>

Yukarıdaki örneğin çıktısı:

2

Ayrıca Bakınız

  • grapheme_stripos() - Harf büyüklüğüne duyarsız olarak bir dizgede ilk sesletim biriminin yerini bulur
  • grapheme_stristr() - Harf büyüklüğüne duyarsız olarak bir dizgedeki ilk sesletim birimine göre ilk veya ikinci parça ile döner
  • grapheme_strpos() - Bir dizgede ilk sesletim biriminin yerini bulur
  • grapheme_strripos() - Harf büyüklüğüne duyarsız olarak bir dizgedeki sonuncu sesletim biriminin yerini bulur
  • grapheme_strstr() - Bir dizgedeki ilk sesletim birimine göre ilk veya ikinci parça ile döner
  • » Unicode Text Segmentation: Grapheme Cluster Boundaries

grapheme_strripos
grapheme_strstr
Grapheme İşlevleri


Bir dizgedeki ilk sesletim birimine göre ilk veya ikinci parça ile döner

grapheme_strrpos
grapheme_substr
Grapheme İşlevleri
PHP Manual

grapheme_strstr

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

grapheme_strstr — Bir dizgedeki ilk sesletim birimine göre ilk veya ikinci parça ile döner

Açıklama

Yordamsal kullanım

string grapheme_strstr ( string $samanlık , string $iğne [, bool $ilk_parça ] )

Bir dizgedeki ilk sesletim birimine göre ilk veya ikinci parça ile döner.

Değiştirgeler

samanlık

Aramanın yapılacağı dizge. Geçerli bir UTF-8 dizgesi olmalıdır.

iğne

Aranacak dizge. Geçerli bir UTF-8 dizgesi olmalıdır.

ilk_parça

TRUE ise iğne'nin bulunduğu ilk konuma göre samanlık dizgesinin ilk parçası döner. Öntanımlı değer: FALSE.

Dönen Değerler

iğne bulunamazsa FALSE, aksi takdirde dizge parçası ile döner.

Örnekler

Örnek 1 - grapheme_strstr() örneği

<?php

$char_a_ring_nfd = "a\xCC\x8A";      // 'å' (U+00E5) normalleştirme biçimi "D"
$char_o_diaeresis_nfd = "o\xCC\x88"; // 'ö' (U+00F6) normalleştirme biçimi "D"

print urlencode(grapheme_stristr( $char_a_ring_nfd . $char_o_diaeresis_nfd .
                                  $char_a_ring_nfd, $char_o_diaeresis_nfd));

?>

Yukarıdaki örneğin çıktısı:

o%CC%88a%CC%8A

Ayrıca Bakınız

  • grapheme_stristr() - Harf büyüklüğüne duyarsız olarak bir dizgedeki ilk sesletim birimine göre ilk veya ikinci parça ile döner
  • grapheme_stripos() - Harf büyüklüğüne duyarsız olarak bir dizgede ilk sesletim biriminin yerini bulur
  • grapheme_strpos() - Bir dizgede ilk sesletim biriminin yerini bulur
  • grapheme_strripos() - Harf büyüklüğüne duyarsız olarak bir dizgedeki sonuncu sesletim biriminin yerini bulur
  • grapheme_strrpos() - Bir dizgedeki sonuncu sesletim biriminin yerini bulur
  • » Unicode Text Segmentation: Grapheme Cluster Boundaries

grapheme_strrpos
grapheme_substr
Grapheme İşlevleri


Bir alt dizge döndürür

grapheme_strstr
IDN İşlevleri
Grapheme İşlevleri
PHP Manual

grapheme_substr

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

grapheme_substr — Bir alt dizge döndürür

Açıklama

Yordamsal kullanım

int grapheme_substr ( string $dizge , int $başlangıç [, int $uzunluk ] )

Bir alt dizge döndürür.

Değiştirgeler

dizge

Aramanın yapılacağı dizge. Geçerli bir UTF-8 dizgesi olmalıdır.

başlangıç

Sesletim birimi cinsinden döndürülecek dizgenin başlangıç konumu. başlangıç negatifse, dönen dizgenin başlangıç konumu dizge'nin sonundan itibaren sayılır, değilse dizge'nin başlangıcından itibaren sıfırdan başlayarak sayılır.

uzunluk

Sesletim birimi cinsinden döndürülecek dizgenin uzunluğu. Eğer uzunluk pozitifse, dizgenin başından itibaren başlangıç'ıncı konumdan başlayan (dizgenin uzunluğuna bağlı olarak) en fazla uzunluk sayıda sesletim birimi döner. Eğer dizge, başlangıç sayıda sesletim birimi içermiyorsa veya ancak bu kadar sesletim birimi içeriyorsa işlev FALSE döndürür. Eğer uzunluk negatifse, döndürülecek dizgenin son sesletim birimi, dizgenin sonundan itibaren uzunluk'uncu sesletim birimi olur. Eğer başlangıç da negatifse, dizgenin sonundan itibaren önce başlangıç birim sayılıp döndürülecek dizgenin son sesletim birimine ulaşılır sonra da bu konumdan itibaren sayılan uzunluk'uncu birim döndürülecek dizgenin ilk sesletim birimi olur.

Dönen Değerler

Bir dizge parçası.

Örnekler

Örnek 1 - grapheme_substr() örneği

<?php

$char_a_ring_nfd = "a\xCC\x8A";      // 'å' (U+00E5) normalleştirme biçimi "D"
$char_o_diaeresis_nfd = "o\xCC\x88"; // 'ö' (U+00F6) normalleştirme biçimi "D"

print urlencode(grapheme_substr( "ao" . $char_a_ring_nfd . "bc" .
                                 $char_o_diaeresis_nfd . "O", 2, -1 ));
?>

Yukarıdaki örneğin çıktısı:

a%CC%8Abco%CC%88

Ayrıca Bakınız

  • grapheme_extract() - UTF-8 kodlanmış bir metin tamponundan öntanımlı sesletim kümelerinden oluşan bir dizilimi döndürür
  • » Unicode Text Segmentation: Grapheme Cluster Boundaries

grapheme_strstr
IDN İşlevleri
Grapheme İşlevleri


IDN İşlevleri

İçindekiler

  • idn_to_ascii — Alan adını IDNA ASCII biçimine dönüştürür
  • idn_to_utf8 — Alan adı kodlamasını IDNA ASCII'den evrenkoda dönüştürür
grapheme_substr
idn_to_ascii
intl


Alan adını IDNA ASCII biçimine dönüştürür

IDN İşlevleri
idn_to_utf8
IDN İşlevleri
PHP Manual

idn_to_ascii

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.2, PHP 7, PECL idn >= 0.1)

idn_to_ascii — Alan adını IDNA ASCII biçimine dönüştürür

Açıklama

Procedural style

string idn_to_ascii ( string $alan [, int $seçenekler ] )

Evrenkodlu alan adını IDNA ASCII kodlu alan adına dönüştürür.

Değiştirgeler

alan

Dönüştürülecek alan adı. PHP5'te UTF-8 kodlu olmalıdır.

seçenekler

IDNA_* sabitlerinden oluşan dönüşüm seçenekleri.

Dönen Değerler

ASCII uyumlu kodlanmış alan adı.

Örnekler

Örnek 1 - idn_to_ascii() örneği

<?php

echo idn_to_ascii('täst.de');

?>

Yukarıdaki örneğin çıktısı:

xn--tst-qla.de

Ayrıca Bakınız

  • idn_to_unicode()

IDN İşlevleri
idn_to_utf8
IDN İşlevleri


Alan adı kodlamasını IDNA ASCII'den evrenkoda dönüştürür

idn_to_ascii
intl İşlevleri
IDN İşlevleri
PHP Manual

idn_to_utf8

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.2, PHP 7, PECL idn >= 0.1)

idn_to_utf8 — Alan adı kodlamasını IDNA ASCII'den evrenkoda dönüştürür

Açıklama

Procedural style

string idn_to_utf8 ( string $alan [, int $seçenekler ] )

Belirtilen IDNA ASCII kodlamalı Evrenkod alan adını normal Evrenkod kodlamalı alan adına dönüştürür.

Değiştirgeler

alan

Kodlaması Evrenkod'a dönüştürülecek IDNA ASCII kodlu alan adı.

seçenekler

IDNA_* sabitlerinden oluşan dönüşüm seçenekleri.

Dönen Değerler

Evrenkod ile kodlanmış alan adı. PHP5'ta alan adı UTF-8 kodlanır.

Örnekler

Örnek 1 - idn_to_utf8() örneği

<?php

echo idn_to_utf8('xn--tst-qla.de');

?>

Yukarıdaki örneğin çıktısı:

täst.de

Ayrıca Bakınız

  • idn_to_unicode()

idn_to_ascii
intl İşlevleri
IDN İşlevleri


intl İşlevleri

İçindekiler

  • intl_error_name — Belirtilen hata kodunun simgesel ismini döndürür
  • intl_get_error_code — Son hatanın kodunu döndürür
  • intl_get_error_message — Son hatayı açıklayan bir dizge ile döner
  • intl_is_failure — Belirtilen hata kodunun bir başarısızlık göstergesi olup olmadığına bakar
idn_to_utf8
intl_error_name
intl


Belirtilen hata kodunun simgesel ismini döndürür

intl İşlevleri
intl_get_error_code
intl İşlevleri
PHP Manual

intl_error_name

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

intl_error_name — Belirtilen hata kodunun simgesel ismini döndürür

Açıklama

string intl_error_name ( int $error_code )

ICU hata kodunun ismini döndürür.

Değiştirgeler

error_code

ICU hata kodu.

Dönen Değerler

Hata kodu sabitinin ismi.

Örnekler

Örnek 1 - intl_error_name() örneği

<?php
$coll     = collator_create( 'en_RU' );
$err_code = collator_get_error_code( $coll );

printf( "%d hata kodu için sabit ismi: %s\n.", $err_code, intl_error_name( $err_code ) );
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

-128 hata kodu için sabit ismi: U_USING_FALLBACK_WARNING

Ayrıca Bakınız

  • intl_is_failure() - Belirtilen hata kodunun bir başarısızlık göstergesi olup olmadığına bakar
  • intl_get_error_code() - Son hatanın kodunu döndürür
  • intl_get_error_message() - Son hatayı açıklayan bir dizge ile döner

intl İşlevleri
intl_get_error_code
intl İşlevleri


Son hatanın kodunu döndürür

intl_error_name
intl_get_error_message
intl İşlevleri
PHP Manual

intl_get_error_code

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

intl_get_error_code — Son hatanın kodunu döndürür

Açıklama

int intl_get_error_code ( void )

Duruk yöntemlerde hata oluştuğunda hatanın alınacağı bir nesne yoksa hata kodunu öğrenmek için yararlıdır.

Dönen Değerler

Son API işlevi çağrısından dönen hata kodu.

Örnekler

Örnek 1 - intl_get_error_code() örneği

<?php
$coll = collator_create( '<bad_param>' );
if( !$coll ) {
    handle_error( intl_get_error_code() );
}
?>

Ayrıca Bakınız

  • intl_is_failure() - Belirtilen hata kodunun bir başarısızlık göstergesi olup olmadığına bakar
  • intl_error_name() - Belirtilen hata kodunun simgesel ismini döndürür
  • intl_get_error_message() - Son hatayı açıklayan bir dizge ile döner
  • collator_get_error_code() - Karşılaştırıcının son hata kodunu döndürür
  • numfmt_get_error_code() - Biçemleyicinin son hata numarası ile döner

intl_error_name
intl_get_error_message
intl İşlevleri


Son hatayı açıklayan bir dizge ile döner

intl_get_error_code
intl_is_failure
intl İşlevleri
PHP Manual

intl_get_error_message

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

intl_get_error_message — Son hatayı açıklayan bir dizge ile döner

Açıklama

string intl_get_error_message ( void )

Son çağrılan uluslararasılaştırma işlevinde oluşan hatayı açıklayan dizge ile döner.

Dönen Değerler

Son API işlevi çağrısında oluşan hatayı açıklayan dizge.

Örnekler

Örnek 1 - intl_get_error_message() örneği

<?php
if( Collator::getAvailableLocales() === false ) {
    show_error( intl_get_error_message() );
}
?>

Ayrıca Bakınız

  • intl_error_name() - Belirtilen hata kodunun simgesel ismini döndürür
  • intl_get_error_code() - Son hatanın kodunu döndürür
  • intl_is_failure() - Belirtilen hata kodunun bir başarısızlık göstergesi olup olmadığına bakar
  • collator_get_error_message() - Karşılaştırıcının son hata iletisini döndürür
  • numfmt_get_error_message() - Biçemleyicinin son hata iletisini döndürür

intl_get_error_code
intl_is_failure
intl İşlevleri


Belirtilen hata kodunun bir başarısızlık göstergesi olup olmadığına bakar

intl_get_error_message
Çok Baytlı Dizgeler
intl İşlevleri
PHP Manual

intl_is_failure

(PHP 5 >= 5.3.0, PHP 7, PECL intl >= 1.0.0)

intl_is_failure — Belirtilen hata kodunun bir başarısızlık göstergesi olup olmadığına bakar

Açıklama

bool intl_is_failure ( int $hata_kodu )

Değiştirgeler

hata_kodu

intl_get_error_code() ve collator_get_error_code() işlevlerinden dönen değer.

Dönen Değerler

Hata kodu bir başarısızlığın ifadesi ise TRUE, başarı veya uyarı ifadesi ise FALSE döner.

Örnekler

Örnek 1 - intl_is_failure() örneği

<?php
function check( $err_code )
{
    var_export( intl_is_failure( $err_code ) );
    echo "\n";
}

check( U_ZERO_ERROR );
check( U_USING_FALLBACK_WARNING );
check( U_ILLEGAL_ARGUMENT_ERROR );
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

false
false
true

Ayrıca Bakınız

  • intl_get_error_code() - Son hatanın kodunu döndürür
  • collator_get_error_code() - Karşılaştırıcının son hata kodunu döndürür
  • Collator-getErrorCode() - Karşılaştırıcının son hata kodunu döndürür

intl_get_error_message
Çok Baytlı Dizgeler
intl İşlevleri


Çok Baytlı Dizgeler

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Desteklenen kodlamaların özetleri
  • Japonca çok baytlı kodlamanın temelleri
  • HTTP Girdisi ve Çıktısı
  • Desteklenen Karakter Kodlamaları
  • İşlevlerin Aşırı Yüklenme Özelliği
  • PHP Karakter Kodlaması Gereksinimleri
  • Çok baytlı Dizge İşlevleri
    • mb_check_encoding — Dizgenin belirtilen kodlama için geçerli olup olmadığını sınar
    • mb_convert_case — Bir dizgeye büyük-küçük harf dönüşümü uygular
    • mb_convert_encoding — Karakter kodlaması dönüşümü yapar
    • mb_convert_kana — Bir "kana" dizgeyi diğerine ("zen-kaku", "han-kaku" vs.) dönüştürür
    • mb_convert_variables — Değişken içeriğinin karakter kodlamasını dönüştürür
    • mb_decode_mimeheader — MIME başlık alanındaki dizgeyi dönüştürür
    • mb_decode_numericentity — HTML sayısal karakter gösterimini karaktere dönüştürür
    • mb_detect_encoding — Karakter kodlamasını algılar
    • mb_detect_order — Karakter kodlaması algılama sırasını tanımlar/döndürür
    • mb_encode_mimeheader — Dizgeyi MIME başlığı için kodlar
    • mb_encode_numericentity — Karakter kodlarını HTML sayısal karakter gösterimlerine dönüştürür
    • mb_encoding_aliases — Get aliases of a known encoding type
    • mb_ereg_match — Çok baytlı dizge için düzenli ifadeyi eşleştirir
    • mb_ereg_replace_callback — Perform a regular expresssion seach and replace with multibyte support using a callback
    • mb_ereg_replace — Çok baytlı karakter destekli düzenli ifade yer değiştirmesi yapar
    • mb_ereg_search_getpos — Sonraki düzenli ifade eşleşmesi için başlangıç konumunu döndürür
    • mb_ereg_search_getregs — Sonuncu çok baytlı düzenli ifade eşleşmesinin sonucunu döndürür
    • mb_ereg_search_init — Çok baytlı düzenli ifade eşleşmesi için kullanılacak dizge ve düzenli ifadeyi tanımlar
    • mb_ereg_search_pos — Evvelce tanımlanmış çok baytlı dizge için çok baytlı düzenli ifadenin eşleşen parçasının uzunluğunu ve konumunu döndürür
    • mb_ereg_search_regs — Çok baytlı düzenli ifadenin eşleşen parçası ile döner
    • mb_ereg_search_setpos — Sonraki düzenli ifade eşleşmesinin başlangıç noktasını tanımlar
    • mb_ereg_search — Evvelce tanımlanmış çok baytlı dizge için çok baytlı düzenli ifade eşleştirmesi yapar
    • mb_ereg — Düzenli ifadeyi çok baytlı karakter desteğiyle eşleştirir
    • mb_eregi_replace — Harf büyüklüğüne duyarsız çok baytlı karakter destekli düzenli ifade yer değiştirmesi yapar
    • mb_eregi — Harf büyüklüğüne duyarsız çok baytlı düzenli ifade eşleştirmesi uygular
    • mb_get_info — Mbstring değiştirgelerinin dahili ayarlarını döndürür
    • mb_http_input — HTTP girdi karakter kodlamasını algılar
    • mb_http_output — HTTP çıktı karakter kodlamasını tanımlar/döndürür
    • mb_internal_encoding — Dahili karakter kodlamasını tanımlar/döndürür
    • mb_language — Geçerli dili tanımlar/döndürür
    • mb_list_encodings — Desteklenen kodlamaların tamamını bir dizi olarak döndürür
    • mb_output_handler — Çıktı tamporundaki karakter kodlamasını dönüştüren geriçağırım işlevi
    • mb_parse_str — GET/POST/COOKIE verisini çözümler ve küresel değişkenleri tanımlar
    • mb_preferred_mime_name — MIME karakter kümesi dizgesini döndürür
    • mb_regex_encoding — mbregex işlevleri için geçerli kodlamayı dizge olarak döndürür
    • mb_regex_set_options — mbregex işlevleri için öntanımlı seçenekleri tanımlar/döndürür
    • mb_send_mail — Kodlanmış olarak posta gönderir
    • mb_split — Çok baytlı bir dizgeyi düzenli ifade ile parçalara ayırır
    • mb_strcut — Dizgenin başlangıcı ve uzunluğu belirtilen parçası ile döner
    • mb_strimwidth — Dizgeyi belirtilen genişlikte kırpar
    • mb_stripos — Harf büyüklüğüne duyarsız olarak, bir dizgenin içinde başka bir dizgeye ilk rastlanılan noktanın indisini döndürür
    • mb_stristr — Harf büyüklüğüne duyarsız olarak, bir dizgenin içinde başka bir dizgeye ilk rastlanılan noktaya göre dizgenin ilk veya son bölümü ile döner
    • mb_strlen — Dizge uzunluğu ile döner
    • mb_strpos — Bir dizgenin içinde başka bir dizgeye ilk rastlanılan noktanın indisini döndürür
    • mb_strrchr — Bir dizgenin içinde bulunan bir karaktere göre dizgenin ilk veya son bölümü ile döner
    • mb_strrichr — Harf büyüklüğüne duyarsız olarak bir dizgenin içinde bulunan bir karaktere göre dizgenin ilk veya son bölümü ile döner
    • mb_strripos — Bir dizgenin içinde harf büyüklüğüne duyarsız olarak başka bir dizgeye son rastlanılan noktanın indisini döndürür
    • mb_strrpos — Bir dizgenin içinde başka bir dizgeye son rastlanılan noktanın indisini döndürür
    • mb_strstr — Bir dizgenin içinde başka bir dizgeye ilk rastlanılan noktaya göre dizgenin ilk veya son bölümü ile döner
    • mb_strtolower — Dizgeyi küçük harfli yapar
    • mb_strtoupper — Dizgeyi büyük harfli yapar
    • mb_strwidth — Dizge genişliğini döndürür
    • mb_substitute_character — İkame karakteri atar/döndürür
    • mb_substr_count — Mevcut alt dizgelerin sayısı ile döner
    • mb_substr — Dizgenin bir alt dizgesini alır
intl_is_failure
Giriş
İnsan Dilleri ve Karakter Kodlaması Desteği


Giriş

Çoğu dilde her karakter 8 bitlik bir değerle bire bir eşleşerek gösterilebilirken bazılarında bunun için bir bayttan fazlası gerekir. (Bir bayt 8 bittir. Her bit, sıfır ve bir olmak üzere en fazla iki değere sahip olabilir. Bundan dolayı, bir baytlık genişlikle 256 (2^8) farklı değer gösterilebilir.) Çok baytlı karakter kodlama şeması, normal bit seviyesi kodlama sistemindeki 256 karakterden fazlasını gösterebilmek için geliştirilmiştir.

Çok baytlı karakter kodlaması kullanılan bir dizgede bazı karakterler ardarda iki veya daha fazla baytla gösterilebildiğinden bu dizgeler üzerinde değişiklik (ekleme, sıralama, vs.) yapmak için özel işlevler gerekir. Böyle dizgelere tek baytlık karakterlere göre tasarlanmış sıradan işlevler uygulanırsa bir çok baytlı karakterin baytlarının bölünmesi çok muhtemeldir. Böyle bir durumda çok baytlı dizgenin anlamı değişecektir.

mbstring modülü, PHP'de çok baytlı kodlama ile çalışabilmeniz için çok baytlı dizge işlevleri sağlar. Bunun yanında olası karakter kodlama çiftleri arasında karakter kodlaması dönüşümleri yapılabilmesini de sağlar. mbstring modülü, UTF_8, UCS-2 gibi Evrenkod temelli kodlamaların yanında uyumluluk için tek baytlı karakter kodlamalarını da destekleyecek şekilde tasarlanmıştır.

Çok Baytlı Dizgeler
Yapılandırma/Kurulum
Çok Baytlı Dizgeler


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Çok Baytlı Dizgeler


Kurulum

mbstring öntanımlı olarak etkin modüllerden biri değildir, yani PHP'yi derlerken etkinleştirmeniz gerekir. Ayrıntılar için Yapılandırma ve Kurulum bölümüne bakınız.

mbstring modülü ile ilgili yapılandırma seçenekleri:

  • --enable-mbstring : mbstring işlevlerini etkin kılar. mbstring işlevleri kullanmak istiyorsanız yapılandırma seçeneklerinize bunu da dahil etmelisiniz.

    mbstring modülü libmbfl kütüphanesini gerektirir. Bu kütüphane mbstring ile birlikte gelmektedir. libmbfl sisteminizde zaten mevcutsa ve kurulu kütüphanenin kullanılması için --with-libmbfl[=DiZiN] seçeneğini belirtebilirsiniz.

    PHP 4.3.0'dan itibaren, mbstring modülü Japonca'nın yanında Basitleştirilmiş ve Geleneksel Çince, Korece ve Rusçayı da desteklemektedir.

    PHP 4.3.3 ve öncesinde, bu özelliği etkin kılmak için aşağıdaki diller için --enable-mbstring=DİL seçeneğini şöyle belirtmek zorunda kalırdınız:

    Basitleştirilmiş Çince desteği için: --enable-mbstring=cn Geleneksel Çince desteği için: --enable-mbstring=tw Korece desteği için: --enable-mbstring=kr Rusça desteği için: --enable-mbstring=ru Japonca desteği için (öntanımlıdır): --enable-mbstring=ja Desteklenen tüm dil kodlamalarını etkin kılmak için: --enable-mbstring=all .

    Bilginize:

    PHP 4.3.4'ten itibaren, libmbfl tarafından desteklenen kodlamaların tamamı --enable-mbstring seçeneği ile etkin kılınabilmektedir.

  • --enable-mbstr-enc-trans : mbstring dönüşüm mekanizmasını kullanarak HTTP girdi karakter kodlaması dönüşümlerini etkinleştirir. Bu seçenek etkin olduğu takdirde, HTTP girdi karakter kodlaması özdevinimli olarak mbstring.internal_encoding yapılandırma yönergesi ile belirtilen karakter kodlamasına dönüştürülür.

    Bilginize:

    PHP 4.3.0'dan itibaren, --enable-mbstr-enc-trans seçeneği kaldırılmıştır. Bunun yerine artık mbstring.encoding_translation yapılandırma yönergesi kullanılmaktadır. Bu yönergeye On değeri atamakla HTTP girdi karakter kodlaması dönüşümü etkin kılınmış olur (öntanımlı değer Off'tur).

  • --disable-mbregex : Çok baytlı karakter destekli düzenli ifade işlevlerini iptal eder.
Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

mbstring yapılandırma yönergeleri
İsim | Öntanımlı | Değiştirme Yeri | Değişiklik Bilgisi
mbstring.language | "neutral" | PHP_INI_PERDIR | PHP 4.3.0'dan beri kullanılabilmektedir.
mbstring.detect_order | NULL | PHP_INI_ALL | PHP 4.0.6'dan beri kullanılabilmektedir.
mbstring.http_input | "pass" | PHP_INI_ALL | PHP 4.0.6'dan beri kullanılabilmektedir.
mbstring.http_output | "pass" | PHP_INI_ALL | PHP 4.0.6'dan beri kullanılabilmektedir.
mbstring.internal_encoding | NULL | PHP_INI_ALL | PHP 4.0.6'dan beri kullanılabilmektedir.
mbstring.script_encoding | NULL | PHP_INI_ALL | PHP 4.3.0'dan beri kullanılabilmektedir.
mbstring.substitute_character | NULL | PHP_INI_ALL | PHP 4.0.6'dan beri kullanılabilmektedir.
mbstring.func_overload | "0" | PHP_INI_PERDIR | PHP <= 4.2.3'te PHP_INI_SYSTEM. PHP 4.2.0'dan beri kullanılabilmektedir.
mbstring.encoding_translation | "0" | PHP_INI_PERDIR | PHP 4.3.0'dan beri kullanılabilmektedir.
mbstring.strict_detection | "0" | PHP_INI_ALL | PHP 5.1.2'den beri kullanılabilmektedir.
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

mbstring.language string

Mbstring modülünde kullanılan öntanımlı ulusal dil ayarı (NLS). Bu yönerge, php.ini dosyasında kendinden sonra tanımlanması gereken mbstring.internal_encoding yönergesini özdevinimli ve sihirli olarak etkin kılar.

mbstring.encoding_translation boolean

HTTP sorgularında girdi kodlamasını algılayıp dahili karakter kodlamasına dönüştüren şeffaf karakter kodlama süzgecini etkin kılar.

mbstring.internal_encoding string

Öntanımlı dahili karakter kodlamasını tanımlar.

mbstring.http_input string

Öntanımlı HTTP girdi karakter kodlamasını tanımlar.

mbstring.http_output string

Öntanımlı HTTP çıktı karakter kodlamasını tanımlar.

mbstring.detect_order string

Öntanımlı karakter kodlaması algılama sırasını tanımlar. Ayrıca bakınız: mb_detect_order().

mbstring.substitute_character string

Geçersiz karakter kodlaması yerine kullanılacak karakteri tanımlar.

mbstring.func_overload string

Mbstring taydaşları tarafından sağlanan tek baytlık işlevlerin yerine özdevinimli olarak mbstring işlevlerinin kullanılmasını sağlar. Daha ayrınılı bilgi için İşlevlerin Aşırı Yüklenme Özelliği bölümüne bakınız.

mbstring.strict_detection boolean

Kesin kodlama algılaması etkin kılınır.

» HTML 4.01 belirtimine göre, tarayıcıların, bir formdan sayfada kullanılandan farklı bir karakter kodlaması ile veri göndermelerine izin verilmektedir. Tarayıcılar tarafından kullanılan karakter kodlamasının saptanması hakkında bilgi edinmek için mb_http_input() işlevine bakınız.

Günümüz tarayıcıları bir HTML sayfanın karakter kodlamasını kabul edilebilir bir doğrulukta tahmin edebiliyor olsalar da, Content-Type HTTP başlığının charset değiştirgesine header() işleviyle veya default_charset INI yönergesiyle uygun bir değer atamak daha iyidir.

Örnek 1 - php.ini ayar örnekleri

; Öntanımlı dili belirtin.
mbstring.language        = Neutral; öntanımlıdır; belli bir dil yoktur (UTF-8)
mbstring.language        = Turkish; öntanımlı dil Türkçe
mbstring.language        = Japanese; öntanımlı dil Japonca

;; Öntanımlı dahili kodlamasını tanımlayın.
;; Önemli: PHP'de çalışan bir karakter kodlaması belirtin
mbstring.internal_encoding    = UTF-8  ; Dahili kodlama UTF-8

;; HTTP girdi kodlaması dönüşümü etkindir.
mbstring.encoding_translation = On

;; Öntanımlı HTTP girdi karakter kodlamasını tanımlayın.
;; Önemli: Betik, http_input ayarını değiştiremez.
mbstring.http_input           = pass    ; Dönüşüm yok.
mbstring.http_input           = auto    ; HTTP girdisi özdevinimli
           ; "auto" şunlara genişletilir: "ASCII,JIS,UTF-8,EUC-JP,SJIS"
mbstring.http_input           = SJIS    ; HTTP2 girdisi SJIS olur
mbstring.http_input           = UTF-8,SJIS,EUC-JP ; Sıralama belirtir

;; Öntanımlı HTTP çıktı karakter kodlamasını tanımlayın.
mbstring.http_output          = pass    ; Dönüşüm yok.
mbstring.http_output          = UTF-8   ; HTTP çıktı kodlaması UTF-8

;; Öntanımlı kodlama algılama sırasını belirtin.
mbstring.detect_order         = auto    ; Algılama sırası özdevinimli
mbstring.detect_order         = ASCII,JIS,UTF-8,SJIS,EUC-JP ; Sıralama belirtir

;; Öntanımlı geçersiz karakter ikame karakteri
mbstring.substitute_character = 12307   ; Bir Evrenkodlu değer
mbstring.substitute_character = none    ; Karakter basılmaz
mbstring.substitute_character = long    ; Uzun, örnek: U+3000,JIS+7E7E

Örnek 2 - EUC-JP kullanıcıları için php.ini ayarları

;; Çıktı Tamponlaması kapalı
output_buffering      = Off

;; HTTP başlık karakter kümesi
default_charset       = EUC-JP

;; Öntanımlı dil: Japonca
mbstring.language = Japanese

;; HTTP girdi kodlaması dönüşümü etkin
mbstring.encoding_translation = On

;; HTTP girdi kodlaması dönüşümü: özdevinimli
mbstring.http_input   = auto

;; HTTP çıktısı EUC-JP'ye dönüştürülür
mbstring.http_output  = EUC-JP

;; Dahili kodlama EUC-JP'dir
mbstring.internal_encoding = EUC-JP

;; Geçersiz karakter basılmaz
mbstring.substitute_character = none

Örnek 3 - SJIS kullanıcıları için php.ini ayarları

;; Çıktı Tamponlaması etkin
output_buffering     = On

;; çıktı dönüşümünü mb_output_handler yapar
output_handler       = mb_output_handler

;; HTTP başlık karakter kümesi
default_charset      = Shift_JIS

;; Öntanımlı dil: Japonca
mbstring.language = Japanese

;; HTTP girdi kodlaması dönüşümü: özdevinimli
mbstring.http_input  = auto

;; HTTP çıktısı SJIS'e dönüştürülür
mbstring.http_output = SJIS

;; Dahili kodlama EUC-JP'dir
mbstring.internal_encoding = EUC-JP

;; Geçersiz karakter basılmaz
mbstring.substitute_character = none

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

MB_OVERLOAD_MAIL (integer)
MB_OVERLOAD_STRING (integer)
MB_OVERLOAD_REGEX (integer)
MB_CASE_UPPER (integer)
MB_CASE_LOWER (integer)
MB_CASE_TITLE (integer)
Özkaynak Türleri
Desteklenen kodlamaların özetleri
Çok Baytlı Dizgeler


Desteklenen kodlamaların özetleri

Desteklenen kodlamaların özetleri
IANA karakter kümesi kütüğündeki isim | Dayandığı karakter kümesi | Açıklama | Ek bilgi
ISO-10646-UCS-4 | ISO 10646 | 31 bitlik kod genişliğine sahip Evrensel Karakter Kümesi, ISO/IEC 10646 tarafından UCS-4 olarak standartlaştırılmıştır. Evrenkodlu eşlemin en son sürümü ile eşzamanlı olarak güncellenir. | Eğer bu isim kodlama dönüşüm oluşumlarında kullanılırsa, dönüştürücü ard arda gelen baytların sıralamasını başa bir bayt sıralama imi ekleyerek betimlemeye çalışır.
ISO-10646-UCS-4 | UCS-4BE | Yukarı bakınız. | UCS-4'ün tersine, bayt sıralamasında en kıymetli baytın başta olduğu varsayılır.
ISO-10646-UCS-4 | UCS-4LE | Yukarı bakınız. | UCS-4'ün tersine, bayt sıralamasında en kıymetsiz baytın başta olduğu varsayılır.
ISO-10646-UCS-2 | UCS-2 | 16 bitlik kod genişliğine sahip Evrensel Karakter Kümesi, ISO/IEC 10646 tarafından UCS-2 olarak standartlaştırılmıştır. Evrenkodlu eşlemin en son sürümü ile eşzamanlı olarak güncellenir. | Eğer bu isim kodlama dönüşüm oluşumlarında kullanılırsa, dönüştürücü ard arda gelen baytların sıralamasını başa bir bayt sıralama imi ekleyerek betimlemeye çalışır.
ISO-10646-UCS-2 | UCS-2BE | Yukarı bakınız. | UCS-2'nin tersine, bayt sıralamasında en kıymetli baytın başta olduğu varsayılır.
ISO-10646-UCS-2 | UCS-2LE | Yukarı bakınız. | UCS-2'nin tersine, bayt sıralamasında en kıymetsiz baytın başta olduğu varsayılır.
UTF-32 | Unicode | 32 bitlik birim genişlikte Evrenkod Dönüşüm Biçemi. Kodlama uzayı Evrenkod karakter kümesi standardını kullanır. Evrenkod kod uzayı 21 bit genişlikte olduğundan, bu kodlama şeması UCS-4'e eşdeğer değildir. | Eğer bu isim kodlama dönüşüm oluşumlarında kullanılırsa, dönüştürücü ard arda gelen baytların sıralamasını başa bir bayt sıralama imi ekleyerek betimlemeye çalışır.
UTF-32BE | Unicode | Yukarı bakınız. | UTF-32'nin tersine, bayt sıralamasında en kıymetli baytın başta olduğu varsayılır.
UTF-32LE | Unicode | Yukarı bakınız. | UTF-32'nin tersine, bayt sıralamasında en kıymetsiz baytın başta olduğu varsayılır.
UTF-16 | Unicode | 16 bitlik birim genişlikte Evrenkod Dönüşüm Biçemi. Unicode 2.0 ve UTF-16, 21 bitlik bir kod uzayına sahip olduğundan, UTF-16 UCS-2'ye eşdeğer değildir. | Eğer bu isim kodlama dönüşüm oluşumlarında kullanılırsa, dönüştürücü ard arda gelen baytların sıralamasını başa bir bayt sıralama imi ekleyerek betimlemeye çalışır.
UTF-16BE | Unicode | Yukarı bakınız. | UTF-16'nın tersine, bayt sıralamasında en kıymetli baytın başta olduğu varsayılır.
UTF-16LE | Unicode | Yukarı bakınız. | UTF-16'nın tersine, bayt sıralamasında en kıymetsiz baytın başta olduğu varsayılır.
UTF-8 | Unicode / UCS | 8 bitlik birim genişlikte Evrenkod Dönüşüm Biçemi. | none
UTF-7 | Unicode | » RFC2152'de belirtilen, epostalara uygun bir Evrenkod dönüşüm biçemi. | none
(none) | Unicode | » IMAP protokolünde kullanmak üzere özelleştirilmiş bir UTF-7 çeşidi. | none
US-ASCII (MIME adı olarak tercih edilir) / iso-ir-6 / ANSI_X3.4-1986 / ISO_646.irv:1991 / ASCII / ISO646-US / us / IBM367 / CP367 / csASCII | ASCII / ISO 646 | Bilgi dönüşümü için Amerikan kod standardı olup genellikle 7 bitlik kodlamayı kullanır. Ayrıca, ISO 646 ile bir uluslararası standart haline getirilmiştir. | (none)
EUC-JP (MIME adı olarak tercih edilir) / Extended_UNIX_Code_Packed_Format_for_Japanese / csEUCPkdFmtJapanese | US-ASCII / JIS X0201:1997 birleşimi (hankaku kana part) / JIS X0208:1990 / JIS X0212:1990 | İsim, Extended UNIX Code Packed Format for Japanese sözcüklerinden türetilmiş bir kısaltma olup, bu kodlama genellikle Unix ve benzeri platformlarda kullanılır. Özgün kodlama şeması, Genişletilmiş UNIX Kodu, ISO 2022 temel alınarak tasarlanmıştır. | EUC-JP adıyla anılan karakter kümesi, OS/2® ve Microsoft® Windows® tarafından kullanılan IBM932 / CP932'den farklıdır. Bu platformlar arasında dönüşüm bilgisi için EUCJP-WIN kullanın.
Shift_JIS (MIME adı olarak tercih edilir) / MS_Kanji / csShift_JIS | JIS X0201:1997 / JIS X0208:1997 birleşimi | Shift_JIS, eski kodlama şeması JIS X 0201:1976 ile uyumluluk sağlamak için pazara getirilen kişisel Japonca kelime işlemciler zamanında, 80'lerin başlarında geliştirlmiştir. IANA tanımına göre Shift_JIS karakter kümesi IBM932 / CP932'den pek az farklıdır. Bununla birlikte, "SJIS" / "Shift_JIS" çoğunlukla yanlış olarak bu kod kümelerini betimlemek için kullanılır. | CP932 kod eşlemi için, SJIS-WIN kullanın.
(none) | JIS X0201:1997 / JIS X0208:1997 / IBM eklentileri / NEC eklentileri birleşimi | Bu "kodlama" EUC-JP ile aynı kodlama şemasını kullanırsa da dayandıkları karakter kümeleri farklıdır. Yani, aynı kodlar farklı karakterlere karşılık gelir. | none
Windows-31J / csWindows31J | JIS X0201:1997 / JIS X0208:1997 / IBM eklentileri / NEC eklentileri birleşimi | Bu "kodlama" Shift_JIS ile aynı kodlama şemasını kullanırsa da dayandıkları karakter kümeleri farklıdır. Yani aynı kodlar farklı karakterlere karşılık gelir. | (none)
ISO-2022-JP (MIME adı olarak tercih edilir) / csISO2022JP | US-ASCII / JIS X0201:1976 / JIS X0208:1978 / JIS X0208:1983 | » RFC1468 | (none)
JIS |  |  |
ISO-8859-1 |  |  |
ISO-8859-2 |  |  |
ISO-8859-3 |  |  |
ISO-8859-4 |  |  |
ISO-8859-5 |  |  |
ISO-8859-6 |  |  |
ISO-8859-7 |  |  |
ISO-8859-8 |  |  |
ISO-8859-9 |  |  |
ISO-8859-10 |  |  |
ISO-8859-13 |  |  |
ISO-8859-14 |  |  |
ISO-8859-15 |  |  |
byte2be |  |  |
byte2le |  |  |
byte4be |  |  |
byte4le |  |  |
BASE64 |  |  |
HTML-ENTITIES |  |  |
7bit |  |  |
8bit |  |  |
EUC-CN |  |  |
CP936 |  |  |
HZ |  |  |
EUC-TW |  |  |
CP950 |  |  |
BIG-5 |  |  |
EUC-KR |  |  |
UHC (CP949) |  |  |
ISO-2022-KR |  |  |
Windows-1251 (CP1251) |  |  |
Windows-1252 (CP1252) |  |  |
CP866 (IBM866) |  |  |
KOI8-R |  |  |
Öntanımlı Sabitler
Japonca çok baytlı kodlamanın temelleri
Çok Baytlı Dizgeler


Japonca çok baytlı kodlamanın temelleri

Japonca karakterler sadece çok baytlı karakter kodlaması ile gösterilebilir ve çok baytlı kodlama standartlar platforma ve kullanılan metnin amacına göre değişir. Daha da kötüsü bu kodlama standartları birbirlerinden oldukça farklıdır. Bir geliştirici, Japonca bir ortamda kullanılabilecek bir HTTP uygulaması oluşturulurken doğru karakter kodlamalarını kullanabilmek için bu karmaşayı iyi bilmek zorundadır.

  • Altı bayta kadar bayt içerebilen karakterlerin saklanması
  • Çoğu Japonca çok baytlı karakter tek baytlı karakterelerin iki katı genişliktedir. Bu karakterlere Japonca'da "zen-kaku" denir ve "tam geniş" anlamına gelir. Dar olanlarına ise "han-kaku" denir ve "yarı geniş" anlamına gelir. Karakterlerin çizgesel özellikleri, bunları göstermekte kullanılan yazı tiplerine bağlıdır.
  • Bazı karakter kodlamaları, belli bir kod bölgesine (00h .. 7fh) geçmek için ISO-2022 ile tanımlanmış kaydırma (öncelem) dizilimleri kullanır.
  • SMTP/NNTP için ISO-2022-JP kullanılmalı; başlıklar ve öğeler RFC gereksinimlerine uygun olarak yeniden kodlanmalıdır. Bunlar elzem olmasa da çoğu kullanıcı aracı başka kodlama yöntemi tanımadığından bunları kullanmak daha iyidir.
  • » i-mode veya » EZweb gibi taşınabilir telefon hizmetleri için oluşturulan sayfaların Shift_JIS kullandıkları varsayılır.
  • PHP 5.4.0 itibariyle, » i-mode veya » EZweb gibi taşınabilir telefon hizmetleri için resim-yazı (pictogram) karakterleri desteklenmektedir.

Desteklenen kodlamaların özetleri
HTTP Girdisi ve Çıktısı
Çok Baytlı Dizgeler


HTTP Girdisi ve Çıktısı

HTTP giriş/çıkış karakter kodlaması dönüşümü ikil verileri de dönüştürebilir, HTTP girdi/çıktısında ikil veri kullanılması durumunda karakter kod dönüşümünü kullanıcının denetleyeceği varsayılır.

Bilginize:

PHP 4.3.2 ve öncesinde, bu işlevsellikle ilgili bir sınırlama vardır. form elemanının enctype özniteliğine multipart/form-data değeri atanmışsa mbstring POST verisinde karakter kodlaması dönüşümü yapmaz. Bu bakımdan, böyle bir durumda, gerekirse gelen veriyi kendiniz dönüştürmelisiniz.

PHP 4.3.3'ten itibaren, HTML formunun enctype özniteliğine multipart/form-data atanır ve php.ini dosyasında mbstring.encoding_translation yönergesine On değeri atanırsa POST edilen değişkenler ve karşıya yüklenen dosyaların isimleri de dahili karakter kodlamasına dönüştürülür. Bununla birlikte, sorgu anahtarlarına dönüşüm uygulanmaz.

  • HTTP Girdisi

    HTTP girdi karakter kümesini bir PHP betiğinden denetlemenin bir yolu yoktur. HTTP girdi karakter kümesi dönüşümü php.ini dosyasından kapatılır.

    Örnek 1 - HTTP girdi dönüşümünün php.ini'de kapatılması

    ;; HTTP girdi dönüşümünü kapatalım
    mbstring.http_input = pass
    ;; HTTP girdi dönüşümünü kapatalım (PHP 4.3.0 ve sonrası)
    mbstring.encoding_translation = Off

    PHP bir Apache modülü olarak kullanıldığında bu ayarları .htaccess ile dizinler için ve httpd.conf içinde sanal konaklar için geçersiz kılmak mümkündür. Ayrıntılar için Apache belgelerine ve bu kılavuzun Çalışma Anı Yapılandırması bölümüne bakınız.

  • HTTP Çıktısı

    Çıktı karakter kodlaması dönüşümünü etkin kılmanın çeşitli yolları vardır. Biri php.ini dosyasını kullanmak; diğeri ise ob_start() ile geriçağırım işlevi olarak mb_output_handler() kullanmaktır.

Örnek 2 - php.ini ayarları örneği

;; Çıktı karakter kodlaması dönüşümünü tüm PHP sayfaları için etkin kılalım

;; Çıktı tamponlamasını açalım
output_buffering    = On

;; çıktı dönüşümünü mb_output_handler yapsın
output_handler      = mb_output_handler

Örnek 3 - Betik örneği

<?php

// Çıktı karakter kodlaması dönüşümünü sadece bu sayfa için etkin kılalım

// HTTP Çıktı karakter kodlamasını SJIS yapalım
mb_http_output('SJIS');

// Geriçağırım işlevi olarak "mb_output_handler" belirtelim ve
// tamponlamayı başlatalım
ob_start('mb_output_handler');

?>

Japonca çok baytlı kodlamanın temelleri
Desteklenen Karakter Kodlamaları
Çok Baytlı Dizgeler


Desteklenen Karakter Kodlamaları

Şu anda, mbstring modülü tarafından aşağıdaki karakter kodlamaları desteklenmektedir. Bu karakter kodlamalarınının her birini mbstring işlevlerinin kodlama değiştirgesinde belirtebilirsiniz.

Bu PHP modülünde şu karakter kodlamaları desteklenmektedir:

  • UCS-4*
  • UCS-4BE
  • UCS-4LE*
  • UCS-2
  • UCS-2BE
  • UCS-2LE
  • UTF-32*
  • UTF-32BE*
  • UTF-32LE*
  • UTF-16*
  • UTF-16BE*
  • UTF-16LE*
  • UTF-7
  • UTF7-IMAP
  • UTF-8*
  • ASCII*
  • EUC-JP*
  • SJIS*
  • eucJP-win*
  • SJIS-win*
  • ISO-2022-JP
  • JIS
  • ISO-8859-1*
  • ISO-8859-2*
  • ISO-8859-3*
  • ISO-8859-4*
  • ISO-8859-5*
  • ISO-8859-6*
  • ISO-8859-7*
  • ISO-8859-8*
  • ISO-8859-9*
  • ISO-8859-10*
  • ISO-8859-13*
  • ISO-8859-14*
  • ISO-8859-15*
  • byte2be
  • byte2le
  • byte4be
  • byte4le
  • BASE64
  • HTML-ENTITIES
  • 7bit
  • 8bit
  • EUC-CN*
  • CP936
  • HZ
  • EUC-TW*
  • CP950
  • BIG-5*
  • EUC-KR*
  • UHC (CP949)
  • ISO-2022-KR
  • Windows-1251 (CP1251)
  • Windows-1252 (CP1252)
  • CP866 (IBM866)
  • KOI8-R*

* imi, bu kodlamaların düzenli ifadelerde de kullanılabildiğini ifade eder.

Bir kodlama ismi kabul eden her php.ini yönergesi ayrıca "auto" ve "pass" değerlerini de kabul eder. Bir kodlama ismi kabul eden her mbstring işlevinde ayrıca "auto" değeri de belirtilebilir.

Değer olarak "pass" atanmışsa hiçbir karakter kodlaması dönüşümü yapılmaz.

Değer olarak "auto" atanmışsa bu değer öntanımlı ulusal dil ayarı (NLS) için tanımlanmış kodlamaların listesine genişletilir. Örneğin, NLS olarak Japanese tanımlanmışsa bu değerin "ASCII,JIS,UTF-8,EUC-JP,SJIS" olduğu varsayılır.

Ayrıca bakınız: mb_detect_order()

HTTP Girdisi ve Çıktısı
İşlevlerin Aşırı Yüklenme Özelliği
Çok Baytlı Dizgeler


İşlevlerin Aşırı Yüklenme Özelliği

Genellikle, çalışan bir PHP uygulamasını çok baytlı bir ortamda çalışır duruma getirmek çoğu kişiye zor gelir. Bu durum genellikle çok baytlı kodlanmış dizgelerle düzgün şekilde çalışamayan substr() gibi standart dizge işlevleriyle yazılmış PHP uygulamalarında karşımıza çıkar.

Mbstring modülü, bir uyglamayı çok baytlı ortamlarda çalışır duruma getirmek için kod değişikliği yapılmaksızın standart dizge işlevlerinin çok baytlı taydaşlarının yerini almasını sağlayan 'işlevlerin aşırı yüklenme' özelliğini destekler. Örneğin, eğer aşırı yükleme etkin kılınmışsa substr() işlevi yerine mb_substr() işlevi çağrılır. Bu özellik, çoğu durumda, sadece tek baytlı karakter kodlamasını destekleyen uygulamaların çok baytlı karakter kodlaması kullanılan ortamlara kolayca uyarlanmasını sağlar.

İşlevlerin aşırı yüklenmesini sağlamak için php.ini dosyasında mbstring.func_overload yönergesine, aşırı yüklenecek işlev sınıflarını belirten bit maskelerinden oluşan bir değerin atanması gerekir. mail() işlevini aşırı yüklemek için 1, dizge işlevleri için 2, düzenli ifade işlevleri için 4 girmek gerekir. Örneğin, yönergeye 7 değeri atanırsa bu üç sınıfa ait işlevler aşırı yüklenecektir. Aşırı yüklenebilen işlevler aşağıda listelenmiştir.

Aşırı yüklenebilen işlevler
mbstring.func_overload değeri | özgün işlev | aşırı yükleyen işlev
1 | mail() | mb_send_mail()
2 | strlen() | mb_strlen()
2 | strpos() | mb_strpos()
2 | strrpos() | mb_strrpos()
2 | substr() | mb_substr()
2 | strtolower() | mb_strtolower()
2 | strtoupper() | mb_strtoupper()
2 | substr_count() | mb_substr_count()
4 | ereg() | mb_ereg()
4 | eregi() | mb_eregi()
4 | ereg_replace() | mb_ereg_replace()
4 | eregi_replace() | mb_eregi_replace()
4 | split() | mb_split()

Bilginize:

Dizin bağlamında yapılandırmalarda işlevlerin aşırı yüklenme özelliğinin kullanılması önerilmez. Çünkü, bu özelliğin üretim ortamında kullanılabilecek kararlılığa sahip olduğu henüz onaylanmamıştır; bu bakımdan önceden kestirilemeyen bazı davranışlarla karşılaşmak olasıdır.

Desteklenen Karakter Kodlamaları
PHP Karakter Kodlaması Gereksinimleri
Çok Baytlı Dizgeler


PHP Karakter Kodlaması Gereksinimleri

Aşağıdaki karakter kodlaması türleri PHP'de güvenle kullanılabilmektedir.

  • Tek baytlık kodlama

    • 00h .. 7fh aralığındaki karakterlerden oluşan ASCII uyumlu (ISO646 uyumlu) eşlemler.

  • Çok baytlı kodlama

    • 00h .. 7fh aralığındaki karakterlerden oluşan ASCII uyumlu (ISO646 uyumlu) eşlemler.
    • ISO2022 öncelem dizileri kullanılmaz.
    • 00h .. 7fh aralığındaki baytların hiçbiri, çok baytlı bir karakterin baytlarından biri olarak kullanılmaz.

Aşağıdaki karakter kodlamaları PHP'da çalışmayan karakter kodlaması örnekleridir.

JIS, SJIS, ISO-2022-JP, BIG-5

Özellikle bu karakter kodlamalarıyla yazılmış dizgelerin betik içinde betimleyici olarak kulanıldığı durumda, bu kodlamalarla yazılmış PHP betikleri çalışmasa da, gelen HTTP sorguları için mbstring modülünün şeffaf kodlama süzme işlevi etkin kılınarak bu kodlamalardan büyük oranda kaçınmak mümkündür.

Bilginize:

Çözümleyici, tarayıcı ve karakter kodlaması konularında uzmanlığınız yoksa dahili karakter kodlaması olarak SJIS, BIG5, CP936, CP949 ve GB18030'u kesinlikle kullanmamalısınız.

Bilginize:

PHP ile bir veritabanını bağlanıyorsanız, başarımı artırmak ve kullanım kolaylığı bakımından dahili kodlama ile veritabanında kullandığınız kodlamanın aynı olması tercih edilmelidir.

PostgreSQL kullanıyorsanız ve PostgreSQL ön ve artalan arasında özdevinimli karakter kodlaması dönüşümünü destekliyorsa, veritabanında kullanılan karakter kodlaması PHP'nin kullandığından farklı olabilir.

İşlevlerin Aşırı Yüklenme Özelliği
Çok baytlı Dizge İşlevleri
Çok Baytlı Dizgeler


Çok baytlı Dizge İşlevleri

Kaynakça

Çok baytlı karakter kodlama şemaları ve bunlarla ilgili konular oldukça karmaşık olup bu belgelemenin kapsamı dışındadır. Bu konularla ilgili daha ayrıntılı bilgi edinmek için aşağıdaki adreslere ve başka kaynaklara bakınız.

  • Evrenkod gereçleri

    » http://www.unicode.org/

  • Japonca/Korece/Çince karakter bilgileri

    » http://examples.oreilly.com/cjkvinfo/doc/cjk.inf

İçindekiler

  • mb_check_encoding — Dizgenin belirtilen kodlama için geçerli olup olmadığını sınar
  • mb_convert_case — Bir dizgeye büyük-küçük harf dönüşümü uygular
  • mb_convert_encoding — Karakter kodlaması dönüşümü yapar
  • mb_convert_kana — Bir "kana" dizgeyi diğerine ("zen-kaku", "han-kaku" vs.) dönüştürür
  • mb_convert_variables — Değişken içeriğinin karakter kodlamasını dönüştürür
  • mb_decode_mimeheader — MIME başlık alanındaki dizgeyi dönüştürür
  • mb_decode_numericentity — HTML sayısal karakter gösterimini karaktere dönüştürür
  • mb_detect_encoding — Karakter kodlamasını algılar
  • mb_detect_order — Karakter kodlaması algılama sırasını tanımlar/döndürür
  • mb_encode_mimeheader — Dizgeyi MIME başlığı için kodlar
  • mb_encode_numericentity — Karakter kodlarını HTML sayısal karakter gösterimlerine dönüştürür
  • mb_encoding_aliases — Get aliases of a known encoding type
  • mb_ereg_match — Çok baytlı dizge için düzenli ifadeyi eşleştirir
  • mb_ereg_replace_callback — Perform a regular expresssion seach and replace with multibyte support using a callback
  • mb_ereg_replace — Çok baytlı karakter destekli düzenli ifade yer değiştirmesi yapar
  • mb_ereg_search_getpos — Sonraki düzenli ifade eşleşmesi için başlangıç konumunu döndürür
  • mb_ereg_search_getregs — Sonuncu çok baytlı düzenli ifade eşleşmesinin sonucunu döndürür
  • mb_ereg_search_init — Çok baytlı düzenli ifade eşleşmesi için kullanılacak dizge ve düzenli ifadeyi tanımlar
  • mb_ereg_search_pos — Evvelce tanımlanmış çok baytlı dizge için çok baytlı düzenli ifadenin eşleşen parçasının uzunluğunu ve konumunu döndürür
  • mb_ereg_search_regs — Çok baytlı düzenli ifadenin eşleşen parçası ile döner
  • mb_ereg_search_setpos — Sonraki düzenli ifade eşleşmesinin başlangıç noktasını tanımlar
  • mb_ereg_search — Evvelce tanımlanmış çok baytlı dizge için çok baytlı düzenli ifade eşleştirmesi yapar
  • mb_ereg — Düzenli ifadeyi çok baytlı karakter desteğiyle eşleştirir
  • mb_eregi_replace — Harf büyüklüğüne duyarsız çok baytlı karakter destekli düzenli ifade yer değiştirmesi yapar
  • mb_eregi — Harf büyüklüğüne duyarsız çok baytlı düzenli ifade eşleştirmesi uygular
  • mb_get_info — Mbstring değiştirgelerinin dahili ayarlarını döndürür
  • mb_http_input — HTTP girdi karakter kodlamasını algılar
  • mb_http_output — HTTP çıktı karakter kodlamasını tanımlar/döndürür
  • mb_internal_encoding — Dahili karakter kodlamasını tanımlar/döndürür
  • mb_language — Geçerli dili tanımlar/döndürür
  • mb_list_encodings — Desteklenen kodlamaların tamamını bir dizi olarak döndürür
  • mb_output_handler — Çıktı tamporundaki karakter kodlamasını dönüştüren geriçağırım işlevi
  • mb_parse_str — GET/POST/COOKIE verisini çözümler ve küresel değişkenleri tanımlar
  • mb_preferred_mime_name — MIME karakter kümesi dizgesini döndürür
  • mb_regex_encoding — mbregex işlevleri için geçerli kodlamayı dizge olarak döndürür
  • mb_regex_set_options — mbregex işlevleri için öntanımlı seçenekleri tanımlar/döndürür
  • mb_send_mail — Kodlanmış olarak posta gönderir
  • mb_split — Çok baytlı bir dizgeyi düzenli ifade ile parçalara ayırır
  • mb_strcut — Dizgenin başlangıcı ve uzunluğu belirtilen parçası ile döner
  • mb_strimwidth — Dizgeyi belirtilen genişlikte kırpar
  • mb_stripos — Harf büyüklüğüne duyarsız olarak, bir dizgenin içinde başka bir dizgeye ilk rastlanılan noktanın indisini döndürür
  • mb_stristr — Harf büyüklüğüne duyarsız olarak, bir dizgenin içinde başka bir dizgeye ilk rastlanılan noktaya göre dizgenin ilk veya son bölümü ile döner
  • mb_strlen — Dizge uzunluğu ile döner
  • mb_strpos — Bir dizgenin içinde başka bir dizgeye ilk rastlanılan noktanın indisini döndürür
  • mb_strrchr — Bir dizgenin içinde bulunan bir karaktere göre dizgenin ilk veya son bölümü ile döner
  • mb_strrichr — Harf büyüklüğüne duyarsız olarak bir dizgenin içinde bulunan bir karaktere göre dizgenin ilk veya son bölümü ile döner
  • mb_strripos — Bir dizgenin içinde harf büyüklüğüne duyarsız olarak başka bir dizgeye son rastlanılan noktanın indisini döndürür
  • mb_strrpos — Bir dizgenin içinde başka bir dizgeye son rastlanılan noktanın indisini döndürür
  • mb_strstr — Bir dizgenin içinde başka bir dizgeye ilk rastlanılan noktaya göre dizgenin ilk veya son bölümü ile döner
  • mb_strtolower — Dizgeyi küçük harfli yapar
  • mb_strtoupper — Dizgeyi büyük harfli yapar
  • mb_strwidth — Dizge genişliğini döndürür
  • mb_substitute_character — İkame karakteri atar/döndürür
  • mb_substr_count — Mevcut alt dizgelerin sayısı ile döner
  • mb_substr — Dizgenin bir alt dizgesini alır
PHP Karakter Kodlaması Gereksinimleri
mb_check_encoding
Çok Baytlı Dizgeler


Dizgenin belirtilen kodlama için geçerli olup olmadığını sınar

Çok baytlı Dizge İşlevleri
mb_convert_case
Çok baytlı Dizge İşlevleri
PHP Manual

mb_check_encoding

(PHP 4 >= 4.4.3, PHP 5 >= 5.1.3, PHP 7)

mb_check_encoding — Dizgenin belirtilen kodlama için geçerli olup olmadığını sınar

Açıklama

bool mb_check_encoding ([ string $dizge = NULL [, string $kodlama = mb_internal_encoding() ]] )

Belirtilen bayt diziliminin belirtilen kodlamaya uygun olup olmadığını sınar. "Geçersiz Kodlama Saldırısı"'nı önlemek için yararlıdır.

Değiştirgeler

dizge

Sınanacak bayt dizilimi. Belirtilmezse, isteğin başlangıcından itibaren tüm girdi sınanır.

kodlama

Umulan kodlama.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Çok baytlı Dizge İşlevleri
mb_convert_case
Çok baytlı Dizge İşlevleri


Bir dizgeye büyük-küçük harf dönüşümü uygular

mb_check_encoding
mb_convert_encoding
Çok baytlı Dizge İşlevleri
PHP Manual

mb_convert_case

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

mb_convert_case — Bir dizgeye büyük-küçük harf dönüşümü uygular

Açıklama

string mb_convert_case ( string $dizge , int $kip = MB_CASE_UPPER [, string $kodlama = mb_internal_encoding() ] )

Belirtilen dizgeye belirtilen kipe göre büyük-küçük harf dönüşümü uygular.

Değiştirgeler

dizge

Dönüştürülecek dizge.

kip

Dönüşüm kipi. MB_CASE_UPPER, MB_CASE_LOWER veya MB_CASE_TITLE olabilir.

kodlama

kodlama değiştirgesinde karakter kodlaması belirtilir. Belirtilmediği takdirde dahili karakter kodlaması kullanılır.

Dönen Değerler

kip ile belirtilen şekilde büyük-küçük harf dönüşümü yapılmış dizge.

Evrenkod

strtolower() ve strtoupper() gibi standart büyük-küçük harf dönüşüm işlevlerinden farklı olarak, dönüşümü Evrenkodlu karakter özelliklerine göre yapar. Bu bakımdan bu işlevin davranışı yerel ayarlardan etkilenmez ve büyük-küçük harf ayrımı yapılabilen her karakteri dönüştürebilir.

Evrenkod özellikleri hakkında daha fazla bilgi için » http://www.unicode.org/unicode/reports/tr21/ adresine bakınız.

Örnekler

Örnek 1 - mb_convert_case() örneği

<?php
$str = "Pınar'ın çok sevdiği küçük bir kuzusu var.";
$str = mb_convert_case($str, MB_CASE_UPPER, "UTF-8");
echo $str; // Prints PINAR'IN ÇOK SEVDIĞI KÜÇÜK BIR KUZUSU VAR.
$str = mb_convert_case($str, MB_CASE_TITLE, "UTF-8");
echo $str; // Pinar'In Çok Sevdiği Küçük Bir Kuzusu Var.
?>

Ayrıca Bakınız

  • mb_strtolower() - Dizgeyi küçük harfli yapar
  • mb_strtoupper() - Dizgeyi büyük harfli yapar
  • strtolower() - Bir dizgenin harflerini küçük harfe çevirir
  • strtoupper() - Bir dizgenin harflerini büyük harfe çevirir
  • ucfirst() - Dizgenin ilk karakterini büyük harfe çevirir
  • ucwords() - Dizgedeki her sözcüğün ilk harfini büyük harf yapar

mb_check_encoding
mb_convert_encoding
Çok baytlı Dizge İşlevleri


Karakter kodlaması dönüşümü yapar

mb_convert_case
mb_convert_kana
Çok baytlı Dizge İşlevleri
PHP Manual

mb_convert_encoding

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

mb_convert_encoding — Karakter kodlaması dönüşümü yapar

Açıklama

string mb_convert_encoding ( string $dizge , string $kodlamaya [, mixed $kodlamadan ] )

Belirtilen dizgenin karakter kodlamasını kodlamadan kodlamaya dönüştürür.

Değiştirgeler

dizge

Kodlaması dönüştürülecek dizge.

kodlamaya

Dizgenin dönüştürüleceği kodlama.

from_encoding

kodlamadan değiştirgesinde, dizge kodlamasını algılamak için kullanılacak karakter kodlamaları bir dizi veya virgül ayraçlı liste olarak belirtilir. Belirtilmezse dahili algılama sırası kullanılır.

"auto" değeri de belirtilebir. Bu takdirde, "ASCII,JIS,UTF-8,EUC-JP,SJIS" algı sırası kullanılır.

Dönen Değerler

Kodlaması dönüştürülen dizge.

Örnekler

Örnek 1 - mb_convert_encoding() örneği

<?php
/* Dahili karakter kodlamasını SJIS'e çevirelim */
$str = mb_convert_encoding($str, "SJIS");

/* EUC-JP'den UTF-7'ye dönüştürelim */
$str = mb_convert_encoding($str, "UTF-7", "EUC-JP");

/* Kodlamayı algılayarak JIS, eucjp-win, sjis-win, kodlamalarından
   UCS-2LE'ye dönüşüm yaptıralım */
$str = mb_convert_encoding($str, "UCS-2LE", "JIS, eucjp-win, sjis-win");

/* "auto" değeri "ASCII,JIS,UTF-8,EUC-JP,SJIS" olarak genişletilir */
$str = mb_convert_encoding($str, "EUC-JP", "auto");
?>

Ayrıca Bakınız

  • mb_detect_order() - Karakter kodlaması algılama sırasını tanımlar/döndürür

mb_convert_case
mb_convert_kana
Çok baytlı Dizge İşlevleri


Bir "kana" dizgeyi diğerine ("zen-kaku", "han-kaku" vs.) dönüştürür

mb_convert_encoding
mb_convert_variables
Çok baytlı Dizge İşlevleri
PHP Manual

mb_convert_kana

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

mb_convert_kana — Bir "kana" dizgeyi diğerine ("zen-kaku", "han-kaku" vs.) dönüştürür

Açıklama

string mb_convert_kana ( string $dizge [, string $seçenek [, string $kodlama ]] )

Belirtilen dizgeye "han-kaku" - "zen-kaku" dönüşümü uygular. İşlev sadece Japonca için kullanılabilir.

Değiştirgeler

dizge

Dönüştürülecek dizge

seçenek

Dönüşüm seçeneği. "KV" öntanımlıdır.

Aşağıdaki seeneklerin bir birleşimi olarak belirtilebilir.

Olası Dönüşüm Seçenekleri
Seçenek | Anlamı
r | "zen-kaku" (tam geniş) harfleri "han-kaku" (yarı geniş) harflere dönüştürür.
R | "han-kaku" harfleri "zen-kaku" harflere dönüştürür.
n | "zen-kaku" sayıları "han-kaku" sayılara dönüştürür.
N | "han-kaku" sayıları "zen-kaku" sayılara dönüştürür.
a | "zen-kaku" harfleri ve sayıları "han-kaku"'ya dönüştürür.
A | "han-kaku" harfleri ve sayıları "zen-kaku"'ya dönüştürür. ("a" ve "A" seçeneklerine dahil karakterler: U+0022, U+0027, U+005C, U+007E hariç U+0021 - U+007E)
s | "zen-kaku" boşluğu "han-kaku" boşluğa dönüştürür (U+3000 -> U+0020).
S | "han-kaku" boşluğu "zen-kaku" boşluğa dönüştürür (U+0020 -> U+3000).
k | "zen-kaku kata-kana" kodlamasından "han-kaku kata-kana" kodlamasına dönüştürür.
K | "han-kaku kata-kana" kodlamasından "zen-kaku kata-kana" kodlamasına dönüştürür.
h | "zen-kaku hira-gana" to "han-kaku kata-kana" kodlamasına dönüştürür.
H | "han-kaku kata-kana" kodlamasından "zen-kaku hira-gana" kodlamasına dönüştürür.
c | "zen-kaku kata-kana" kodlamasından "zen-kaku hira-gana" kodlamasına dönüştürür.
C | "zen-kaku hira-gana" kodlamasından "zen-kaku kata-kana" kodlamasına dönüştürür.
V | Sesli gösterimi kapatıp bir karaktere dönüştürür. "K","H" ile kullanılır.

kodlama

kodlama değiştirgesinde karakter kodlaması belirtilir. Belirtilmediği takdirde dahili karakter kodlaması kullanılır.

Dönen Değerler

Dönüştürülen dizge.

Örnekler

Örnek 1 - mb_convert_kana() örneği

<?php
/* "kana" kodlamasını "zen-kaku" "kata-kana" yapar*/
$str = mb_convert_kana($str, "KVC");

/* "han-kaku" "kata-kana" kodlamasını "zen-kaku" "kata-kana"
   ve "zen-kaku" harf ve sayılarını "han-kaku" yapar */
$str = mb_convert_kana($str, "KVa");
?>

mb_convert_encoding
mb_convert_variables
Çok baytlı Dizge İşlevleri


Değişken içeriğinin karakter kodlamasını dönüştürür

mb_convert_kana
mb_decode_mimeheader
Çok baytlı Dizge İşlevleri
PHP Manual

mb_convert_variables

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

mb_convert_variables — Değişken içeriğinin karakter kodlamasını dönüştürür

Açıklama

string mb_convert_variables ( string $kodlamaya , mixed $kodlamadan , mixed &$değişkenler [, mixed &$... ] )

Belirtilen değişkenlerin karakter kodlamasını kodlamadan kodlamaya dönüştürür.

mb_convert_variables() işlevi, kodlama algılamasının kısa dizgelerde başarısız olmaması için dizgeleri bir dizi veya nesne içinde birleştirir. Bu bakımdan kodlamayı karıştırmak tek bir dizi veya nesne içinde imkansızdır.

Değiştirgeler

kodlamaya

Dizgenin dönüştürüleceği karakter kodlaması.

kodlamadan

kodlamadan değiştirgesinde, dizge kodlamasını algılamak için kullanılacak karakter kodlamaları bir dizi veya virgül ayraçlı liste olarak belirtilir. Belirtilmezse dahili algılama sırası kullanılır.

değişkenler

Kodlaması değiştirilecek değişkenler belirtilir. Dizi, dizge veya nesne belirtilebilir. İşlev tüm değişkenlerin aynı karakter kodlamasına sahip olduğunu varsayar.

...

Diğer değişkenler.

Dönen Değerler

Başarı durumunda dönüşüm öncesi karakter kodlaması, aksi takdirde FALSE döner.

Örnekler

Örnek 1 - mb_convert_variables() örneği

<?php
/* $post1, $post2 değişkenlinin içeriğini dahili kodlamaya dönüştürelim */
$dahilikod = mb_internal_encoding();
$girdikodu = mb_convert_variables($dahilikod, "ASCII,UTF-8,SJIS-win", $post1, $post2);
?>

mb_convert_kana
mb_decode_mimeheader
Çok baytlı Dizge İşlevleri


MIME başlık alanındaki dizgeyi dönüştürür

mb_convert_variables
mb_decode_numericentity
Çok baytlı Dizge İşlevleri
PHP Manual

mb_decode_mimeheader

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

mb_decode_mimeheader — MIME başlık alanındaki dizgeyi dönüştürür

Açıklama

string mb_decode_mimeheader ( string $dizge )

MIME başlığındaki dizgenin karakter kodlamasını dahili karakter kodlamasına dönüştürür.

Değiştirgeler

dizge

Dönüştürülecek dizge.

Dönen Değerler

Kodlaması dahili karakter kodlamasına dönüştürülmüş dizge.

Ayrıca Bakınız

  • mb_encode_mimeheader() - Dizgeyi MIME başlığı için kodlar

mb_convert_variables
mb_decode_numericentity
Çok baytlı Dizge İşlevleri


HTML sayısal karakter gösterimini karaktere dönüştürür

mb_decode_mimeheader
mb_detect_encoding
Çok baytlı Dizge İşlevleri
PHP Manual

mb_decode_numericentity

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

mb_decode_numericentity — HTML sayısal karakter gösterimini karaktere dönüştürür

Açıklama

string mb_decode_numericentity ( string $dizge , array $bölge , string $kodlama )

Belirtilen dizge dizgesindeki HTML sayısal karakter gösterimlerinden belirtilen bölge içinde kalan karakterlerin yerine karakter kodlarını yerleştirir.

Değiştirgeler

dizge

HTML karakter kodlaması kaldırılacak dizge.

bölge

Dönüşüm yapılacak kod bölgesini içeren dizi.

kodlama

kodlama değiştirgesinde karakter kodlaması belirtilir. Belirtilmediği takdirde dahili karakter kodlaması kullanılır.

Dönen Değerler

Dönüştürülen dizge.

Örnekler

Örnek 1 - bölge örneği

$bölge = array (
 int kodlama_başı1, int kodlama_sonu1, int göreli_konum1, int maske1,
 int kodlama_başı2, int kodlama_sonu2, int göreli_konum2, int maske2,
 ........
 int kodlama_başıN, int kodlama_sonuN, int göreli_konumN, int maskeN );
// kodlama_başıN ve int kodlama_sonuN için Evrenkodlu değer belirt,
// değere göreli_konumN ekleyip sonucu maskeN ile bitsel VE'le ve
// değeri sayısal gösterim dizgesine dönüştür.

Ayrıca Bakınız

  • mb_encode_numericentity() - Karakter kodlarını HTML sayısal karakter gösterimlerine dönüştürür

mb_decode_mimeheader
mb_detect_encoding
Çok baytlı Dizge İşlevleri


Karakter kodlamasını algılar

mb_decode_numericentity
mb_detect_order
Çok baytlı Dizge İşlevleri
PHP Manual

mb_detect_encoding

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

mb_detect_encoding — Karakter kodlamasını algılar

Açıklama

string mb_detect_encoding ( string $dizge [, mixed $kodlama_listesi = mb_detect_order() [, bool $kesin = false ]] )

dizge dizgesinin karakter kodlamasını algılar.

Değiştirgeler

dizge

Kodlaması algılanacak dizge.

kodlama_listesi

kodlama_listesi ile karakter kodlama listesi belirtilir. Algı sırası bir dizi veya virgül ayraçlı bir liste olarak belirtilebilir.

kodlama_listesi belirtilmezse algılama için dahili algılama sırası kullanılır.

kesin

kesin ile kesin kodlama algılamasının kullanılıp kullanılmayacağı belirtilir. FALSE öntanımlıdır.

Dönen Değerler

Karakter kodlaması belirtilen dizgeden saptanamıyorsa FALSE yoksa saptanan karakter kodlaması döner.

Örnekler

Örnek 1 - mb_detect_encoding() örneği

<?php
/* Karakter kodlamasını dahili algı sırasını kullanarak algılatalım */
echo mb_detect_encoding($str);

/* "auto" değeri "ASCII,JIS,UTF-8,EUC-JP,SJIS" olarak genişletilir */
echo mb_detect_encoding($str, "auto");

/* Kodlama listesini virgül ayraçlı liste olarak belirtelim  */
echo mb_detect_encoding($str, "JIS, eucjp-win, sjis-win");

/* Kodlama listesini dizi olarak belirtelim  */
$ary[] = "ASCII";
$ary[] = "JIS";
$ary[] = "EUC-JP";
echo mb_detect_encoding($str, $ary);
?>

Ayrıca Bakınız

  • mb_detect_order() - Karakter kodlaması algılama sırasını tanımlar/döndürür

mb_decode_numericentity
mb_detect_order
Çok baytlı Dizge İşlevleri


Karakter kodlaması algılama sırasını tanımlar/döndürür

mb_detect_encoding
mb_encode_mimeheader
Çok baytlı Dizge İşlevleri
PHP Manual

mb_detect_order

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

mb_detect_order — Karakter kodlaması algılama sırasını tanımlar/döndürür

Açıklama

mixed mb_detect_order ([ mixed $kodlama_listesi ] )

kodlama_listesi ile belirtilen özdevinimli karakter kodlaması algılama sırasını tanımlar.

Değiştirgeler

kodlama_listesi

kodlama_listesi bir dizi veya karakter kodlamalarının virgül ayraçlı listesi ya da "auto" olarak belirtilir. Değer olarak "auto" belirtilirse sıralama "ASCII, JIS, UTF-8, EUC-JP, SJIS" olur.)

kodlama_listesi belirtilmezse karakter kodlaması algılama sırasını içeren bir dizi döner.

Bu ayar, mb_detect_encoding() ve mb_send_mail() işlevini etkiler.

mbstring şimdilik aşağıdaki kodlama algılama süzgeçlerini gerçeklemiştir. Bu kodlamalarla ilgili geçersiz bir bayt dizilimine rastlanırsa kodlama algılaması başarısız olur.

UTF-8, UTF-7, ASCII, EUC-JP,SJIS, eucJP-win, SJIS-win, JIS, ISO-2022-JP

Bir ISO-8859-* karakter kodlamasını, mbstring daima ISO-8859-* olarak algılar.

UTF-16, UTF-32, UCS2 ve UCS4 için algılama daima başarısız olacaktır.

Örnek 1 - Kullanışsız algı sırası örneği

; Daima ISO-8859-1 olarak algılanır
detect_order = ISO-8859-1, UTF-8

; Daima UTF-8 olarak algılanır, çünkü UTF-8 diğerlerini de kapsar
detect_order = UTF-8, ASCII, UTF-7

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 2 - mb_detect_order() örnekleri

<?php
/* Algı sırasını virgül ayraçlı liste olarak verelim */
mb_detect_order("eucjp-win,sjis-win,UTF-8");

/* Algı sırasını dizi olarak verelim */
$dizi[] = "ASCII";
$dizi[] = "JIS";
$dizi[] = "EUC-JP";
mb_detect_order($dizi);

/* Geçerli algı sırasını görelim */
echo implode(", ", mb_detect_order());
?>

Ayrıca Bakınız

  • mb_internal_encoding() - Dahili karakter kodlamasını tanımlar/döndürür
  • mb_http_input() - HTTP girdi karakter kodlamasını algılar
  • mb_http_output() - HTTP çıktı karakter kodlamasını tanımlar/döndürür
  • mb_send_mail() - Kodlanmış olarak posta gönderir

mb_detect_encoding
mb_encode_mimeheader
Çok baytlı Dizge İşlevleri


Dizgeyi MIME başlığı için kodlar

mb_detect_order
mb_encode_numericentity
Çok baytlı Dizge İşlevleri
PHP Manual

mb_encode_mimeheader

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

mb_encode_mimeheader — Dizgeyi MIME başlığı için kodlar

Açıklama

string mb_encode_mimeheader ( string $dizge [, string $karküm [, string $aktarım_kodlaması [, string $satırsonu [, int $girinti ]]]] )

Belirtilen dizge dizgesini MIME başlığı kodlama şemasına göre kodlar.

Değiştirgeler

dizge

Kodlanacak dizge.

karküm

Dizgenin kodlanacağı karakter kümesinin ismi. Öntanımlı değer geçerli yerel dil ayarından (mbstring.language) alınır. mb_internal_encoding() ile aynı kodlama belirtilmelidir.

aktarım_kodlaması

aktarım_kodlaması ile MIME kodlama şeması belirtilir. "B" (Base64) veya "Q" (Quoted-Printable) olmalıdır. Belirtilmezse son çare olarak "B" kullanılır.

satırsonu

mb_encode_mimeheader() işlevinin satırları katlayabilmesi için satır sonu imleyici belirtir. (» RFC gereği belli bir uzunluktan daha uzun satırların katlanması gerekir. Bu uzunluk şimdilik 74 bayttır.) Belirtilmediği takdirde son çare olarak "\r\n" (CRLF) kullanılır.

girinti

İlk satırın girinti miktarı (Başlıkta dizge dizgesinden önceki karakter sayısı).

Dönen Değerler

Belirtilen dizgenin ASCII'ye dönüştürülmüş gösterimi döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.0 | girinti değiştirgesi eklendi.

Örnekler

Örnek 1 - mb_encode_mimeheader() örneği

<?php
$name = ""; // kanji
$mbox = "kru";
$doma = "gtinn.mon";
$addr = mb_encode_mimeheader($name, "UTF-7", "Q") . " <" . $mbox . "@" . $doma . ">";
echo $addr;
?>

Notlar

Bilginize:

Bu işlev daha yüksek seviyeden satır katlamaları için tasarlanmamıştır (sözcükleri bölmeden katlamak gibi). Bu davranış özgün dizgenin beklenmedik boşluklarla düzensizleşmesine sebep olabilir.

Ayrıca Bakınız

  • mb_decode_mimeheader() - MIME başlık alanındaki dizgeyi dönüştürür

mb_detect_order
mb_encode_numericentity
Çok baytlı Dizge İşlevleri


Karakter kodlarını HTML sayısal karakter gösterimlerine dönüştürür

mb_encode_mimeheader
mb_encoding_aliases
Çok baytlı Dizge İşlevleri
PHP Manual

mb_encode_numericentity

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

mb_encode_numericentity — Karakter kodlarını HTML sayısal karakter gösterimlerine dönüştürür

Açıklama

string mb_encode_numericentity ( string $dizge , array $bölge , string $kodlama )

Belirtilen dizge dizgesindeki karakter kodlarını HTML sayısal karakter gösterimlerine dönüştürür.

Değiştirgeler

dizge

HTML için kodlanacak dizge.

bölge

Dönüşüm yapılacak kod bölgesini içeren dizi.

kodlama

kodlama değiştirgesinde karakter kodlaması belirtilir. Belirtilmediği takdirde dahili karakter kodlaması kullanılır.

Dönen Değerler

Dönüştürülen dizge.

Örnekler

Örnek 1 - bölge örneği

$bölge = array (
 int kodlama_başı1, int kodlama_sonu1, int göreli_konum1, int maske1,
 int kodlama_başı2, int kodlama_sonu2, int göreli_konum2, int maske2,
 ........
 int kodlama_başıN, int kodlama_sonuN, int göreli_konumN, int maskeN );
// kodlama_başıN ve int kodlama_sonuN için Evrenkodlu değer belirt,
// değere göreli_konumN ekleyip sonucu maskeN ile bitsel VE'le ve
// değeri sayısal gösterim dizgesine dönüştür.

Örnekler

Örnek 2 - mb_encode_numericentity() örneği

<?php
/* ISO-8859-1'in sol tarafını HTML sayısal karakter gösterimine dönüştürelim */
$bölge = array(0x80, 0xff, 0, 0xff);
$dizge = mb_encode_numericentity($dizge, $bölge, "ISO-8859-1");

/* Kullanıcı tanımlı SJIS-win'i 95-104 aralığında sayısal gösterime
   dönüştürelim */
$bölge = array(
       0xe000, 0xe03e, 0x1040, 0xffff,
       0xe03f, 0xe0bb, 0x1041, 0xffff,
       0xe0bc, 0xe0fa, 0x1084, 0xffff,
       0xe0fb, 0xe177, 0x1085, 0xffff,
       0xe178, 0xe1b6, 0x10c8, 0xffff,
       0xe1b7, 0xe233, 0x10c9, 0xffff,
       0xe234, 0xe272, 0x110c, 0xffff,
       0xe273, 0xe2ef, 0x110d, 0xffff,
       0xe2f0, 0xe32e, 0x1150, 0xffff,
       0xe32f, 0xe3ab, 0x1151, 0xffff );
$dizge = mb_encode_numericentity($dizge, $bölge, "sjis-win");
?>

Ayrıca Bakınız

  • mb_decode_numericentity() - HTML sayısal karakter gösterimini karaktere dönüştürür

mb_encode_mimeheader
mb_encoding_aliases
Çok baytlı Dizge İşlevleri


Get aliases of a known encoding type

mb_encode_numericentity
mb_ereg_match
Çok baytlı Dizge İşlevleri
PHP Manual

mb_encoding_aliases

(PHP 5 >= 5.3.0, PHP 7)

mb_encoding_aliases — Get aliases of a known encoding type

Açıklama

array mb_encoding_aliases ( string $encoding )

Returns an array of aliases for a known encoding type.

Değiştirgeler

encoding

The encoding type being checked, for aliases.

Dönen Değerler

Returns a numerically indexed array of encoding aliases on success, başarısızlık durumunda FALSE döner

Hatalar/İstisnalar

Emits an E_WARNING level error if encoding is unknown.

Örnekler

Örnek 1 mb_encoding_aliases() example

<?php
$encoding        = 'ASCII';
$known_encodings = mb_list_encodings();

if (in_array($encoding, $known_encodings)) {

    $aliases = mb_encoding_aliases($encoding);
    print_r($aliases);

} else {

    echo "Unknown ($encoding) encoding.\n";

}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [0] => ANSI_X3.4-1968
    [1] => iso-ir-6
    [2] => ANSI_X3.4-1986
    [3] => ISO_646.irv:1991
    [4] => US-ASCII
    [5] => ISO646-US
    [6] => us
    [7] => IBM367
    [8] => cp367
    [9] => csASCII
)

Ayrıca Bakınız

  • mb_list_encodings() - Desteklenen kodlamaların tamamını bir dizi olarak döndürür

mb_encode_numericentity
mb_ereg_match
Çok baytlı Dizge İşlevleri


Çok baytlı dizge için düzenli ifadeyi eşleştirir

mb_encoding_aliases
mb_ereg_replace_callback
Çok baytlı Dizge İşlevleri
PHP Manual

mb_ereg_match

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

mb_ereg_match — Çok baytlı dizge için düzenli ifadeyi eşleştirir

Açıklama

bool mb_ereg_match ( string $şablon , string $dizge [, string $seçenek = "msr" ] )

Bir düzenli ifadeyi çok baytlı bir dizge ile eşleştirir.

Değiştirgeler

şablon

Düzenli ifade şablonu.

dizge

Şablonun aranacağı dizge.

seçenek

Dönen Değerler

dizge, şablon ile eşleşirse TRUE eşleşmezse FALSE döner.

Notlar

Bilginize:

Bu işlev karakter kodlaması olarak dahili kodlamayı veya mb_regex_encoding() işlevi tarafından belirtilen karakter kodlamasını kullanır.

Ayrıca Bakınız

  • mb_regex_encoding() - mbregex işlevleri için geçerli kodlamayı dizge olarak döndürür
  • mb_ereg() - Düzenli ifadeyi çok baytlı karakter desteğiyle eşleştirir

mb_encoding_aliases
mb_ereg_replace_callback
Çok baytlı Dizge İşlevleri


Perform a regular expresssion seach and replace with multibyte support using a callback

mb_ereg_match
mb_ereg_replace
Çok baytlı Dizge İşlevleri
PHP Manual

mb_ereg_replace_callback

(PHP 5 >= 5.4.1, PHP 7)

mb_ereg_replace_callback — Perform a regular expresssion seach and replace with multibyte support using a callback

Açıklama

string mb_ereg_replace_callback ( string $pattern , callable $callback , string $string [, string $option = "msr" ] )

Scans string for matches to pattern, then replaces the matched text with the output of callback function.

The behavior of this function is almost identical to mb_ereg_replace(), except for the fact that instead of replacement parameter, one should specify a callback.

Değiştirgeler

pattern

The regular expression pattern.

Multibyte characters may be used in pattern.

callback

A callback that will be called and passed an array of matched elements in the subject string. The callback should return the replacement string.

You'll often need the callback function for a mb_ereg_replace_callback() in just one place. In this case you can use an anonymous function to declare the callback within the call to mb_ereg_replace_callback(). By doing it this way you have all information for the call in one place and do not clutter the function namespace with a callback function's name not used anywhere else.

string

The string being checked.

option

Matching condition can be set by option parameter. If i is specified for this parameter, the case will be ignored. If x is specified, white space will be ignored. If m is specified, match will be executed in multiline mode and line break will be included in '.'. If p is specified, match will be executed in POSIX mode, line break will be considered as normal character. Note that e cannot be used for mb_ereg_replace_callback().

Dönen Değerler

The resultant string on success, or FALSE on error.

Notlar

Bilginize:

Bu işlev karakter kodlaması olarak dahili kodlamayı veya mb_regex_encoding() işlevi tarafından belirtilen karakter kodlamasını kullanır.

Örnekler

Örnek 1 mb_ereg_replace_callback() example

<?php
// this text was used in 2002
// we want to get this up to date for 2003
$text = "April fools day is 04/01/2002\n";
$text.= "Last christmas was 12/24/2001\n";
// the callback function
function next_year($matches)
{
  // as usual: $matches[0] is the complete match
  // $matches[1] the match for the first subpattern
  // enclosed in '(...)' and so on
  return $matches[1].($matches[2]+1);
}
echo mb_ereg_replace_callback(
            "(\d{2}/\d{2}/)(\d{4})",
            "next_year",
            $text);

?>

Yukarıdaki örneğin çıktısı:

April fools day is 04/01/2003
Last christmas was 12/24/2002

Örnek 2 mb_ereg_replace_callback() using anonymous function supported in PHP 5.3.0 or later

<?php
// this text was used in 2002
// we want to get this up to date for 2003
$text = "April fools day is 04/01/2002\n";
$text.= "Last christmas was 12/24/2001\n";

echo mb_ereg_replace_callback(
            "(\d{2}/\d{2}/)(\d{4})",
            function ($matches) {
               return $matches[1].($matches[2]+1);
            },
            $text);
?>

Ayrıca Bakınız

  • mb_regex_encoding() - mbregex işlevleri için geçerli kodlamayı dizge olarak döndürür
  • mb_ereg_replace() - Çok baytlı karakter destekli düzenli ifade yer değiştirmesi yapar
  • Anonymous functions
  • callback türü hakkında bilgi

mb_ereg_match
mb_ereg_replace
Çok baytlı Dizge İşlevleri


Çok baytlı karakter destekli düzenli ifade yer değiştirmesi yapar

mb_ereg_replace_callback
mb_ereg_search_getpos
Çok baytlı Dizge İşlevleri
PHP Manual

mb_ereg_replace

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

mb_ereg_replace — Çok baytlı karakter destekli düzenli ifade yer değiştirmesi yapar

Açıklama

string mb_ereg_replace ( string $şablon , string $yeni , string $dizge [, string $seçenek = "msr" ] )

dizge içinde şablon eşleştirilmeye çalışılır, eşleşen parça yenisi ile değiştirilir.

Değiştirgeler

sablon

Düzenli ifade olarak şablon.

sablon içinde çok baytı karakterler kullanılabilir.

yeni

Yerleştirilecek metin.

dizge

İçinde şablonun aranacağı dizge.

seçenek
Eşleştirme koşulu seçenek değiştirgesi ile belirtilebilir. i belirtilmişse harf büyüklüğü dikkate alınmaz. x belirtilmişse boşluk karakterleri dikkate alınmaz. m belirtilmişse eşleşme çok satırlı kipte gerçekleştirilir ve '.' içine satırsonu karakteri dahil edilir. p belirtilmişse POSIX kipi etkin olur ve satırsonu karakteri normal karakter olarak ele alınır. e belirtilmişse yeni değiştirgesi bir PHP ifadesi olarak değerlendirilir.

Dönen Değerler

Başarı durumunda elde edilen dizgeyle aksi takdirde FALSE ile döner.

Notlar

Bilginize:

Bu işlev karakter kodlaması olarak dahili kodlamayı veya mb_regex_encoding() işlevi tarafından belirtilen karakter kodlamasını kullanır.

Uyarı

Güvenilmez girdilerle çalışırken e değiştiricisini asla kullanmayın. Özdevinimli önceleme yapılmayacaktır (preg_replace() işlevinde olduğu gibi). Bunu dikkate almazsanız, büyük olasılıkla uygulamanızda uzaktan kod çalıştırma açıkları oluşacaktır.

Ayrıca Bakınız

  • mb_regex_encoding() - mbregex işlevleri için geçerli kodlamayı dizge olarak döndürür
  • mb_eregi_replace() - Harf büyüklüğüne duyarsız çok baytlı karakter destekli düzenli ifade yer değiştirmesi yapar

mb_ereg_replace_callback
mb_ereg_search_getpos
Çok baytlı Dizge İşlevleri


Sonraki düzenli ifade eşleşmesi için başlangıç konumunu döndürür

mb_ereg_replace
mb_ereg_search_getregs
Çok baytlı Dizge İşlevleri
PHP Manual

mb_ereg_search_getpos

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

mb_ereg_search_getpos — Sonraki düzenli ifade eşleşmesi için başlangıç konumunu döndürür

Açıklama

int mb_ereg_search_getpos ( void )

Sonraki çok baytlı düzenli ifade eşleşmesi için başlangıç konumunu döndürür.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

mb_ereg_search_getpos() işlevi,
mb_ereg_search(),
mb_ereg_search_pos(),
mb_ereg_search_regs() işlevleri için düzenli ifade
eşleşmesinin başlangıç konumunu döndürür. Konum dizgenin başlangıcından
itibaren bayt sayısını ifade eder.

Notlar

Bilginize:

Bu işlev karakter kodlaması olarak dahili kodlamayı veya mb_regex_encoding() işlevi tarafından belirtilen karakter kodlamasını kullanır.

Ayrıca Bakınız

  • mb_regex_encoding() - mbregex işlevleri için geçerli kodlamayı dizge olarak döndürür
  • mb_ereg_search_setpos() - Sonraki düzenli ifade eşleşmesinin başlangıç noktasını tanımlar

mb_ereg_replace
mb_ereg_search_getregs
Çok baytlı Dizge İşlevleri


Sonuncu çok baytlı düzenli ifade eşleşmesinin sonucunu döndürür

mb_ereg_search_getpos
mb_ereg_search_init
Çok baytlı Dizge İşlevleri
PHP Manual

mb_ereg_search_getregs

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

mb_ereg_search_getregs — Sonuncu çok baytlı düzenli ifade eşleşmesinin sonucunu döndürür

Açıklama

array mb_ereg_search_getregs ( void )

Sonuncu çok baytlı düzenli ifade eşleşmesinin sonucunu döndürür.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Son mb_ereg_search(), mb_ereg_search_pos() veya mb_ereg_search_regs() işlevi tarafından eşleştirilen alt dizgeyi içeren bir dizi. Başka eşleşmeler de varsa, ilk eleman eşleşen alt dizgeyi, ikinci eleman köşeli ayraçlı ikinci parçayı, üçüncü eleman köşeli ayraçlı üçüncü parçayı, ... içerir. Bir hata durumunda FALSE döner.

Notlar

Bilginize:

Bu işlev karakter kodlaması olarak dahili kodlamayı veya mb_regex_encoding() işlevi tarafından belirtilen karakter kodlamasını kullanır.

Ayrıca Bakınız

  • mb_regex_encoding() - mbregex işlevleri için geçerli kodlamayı dizge olarak döndürür
  • mb_ereg_search_init() - Çok baytlı düzenli ifade eşleşmesi için kullanılacak dizge ve düzenli ifadeyi tanımlar

mb_ereg_search_getpos
mb_ereg_search_init
Çok baytlı Dizge İşlevleri


Çok baytlı düzenli ifade eşleşmesi için kullanılacak dizge ve düzenli ifadeyi tanımlar

mb_ereg_search_getregs
mb_ereg_search_pos
Çok baytlı Dizge İşlevleri
PHP Manual

mb_ereg_search_init

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

mb_ereg_search_init — Çok baytlı düzenli ifade eşleşmesi için kullanılacak dizge ve düzenli ifadeyi tanımlar

Açıklama

bool mb_ereg_search_init ( string $dizge [, string $şablon [, string $seçenek = "msr" ]] )

mb_ereg_search_init() işlevi, çok baytlı düzenli ifade
eşleşmesi için kullanılacak dizge ve düzenli ifadeyi tanımlar. Bu değerler,
mb_ereg_search(),
mb_ereg_search_pos() ve
mb_ereg_search_regs() işlevleri tarafından kullanılır.

Değiştirgeler

dizge

Şablonun aranacağı dizge.

şablon

Aranacak şablon.

seçenek

Arama seçeneği. 'msr' öntanımlıdır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

Bilginize:

Bu işlev karakter kodlaması olarak dahili kodlamayı veya mb_regex_encoding() işlevi tarafından belirtilen karakter kodlamasını kullanır.

Ayrıca Bakınız

  • mb_regex_encoding() - mbregex işlevleri için geçerli kodlamayı dizge olarak döndürür
  • mb_ereg_search_regs() - Çok baytlı düzenli ifadenin eşleşen parçası ile döner

mb_ereg_search_getregs
mb_ereg_search_pos
Çok baytlı Dizge İşlevleri


Evvelce tanımlanmış çok baytlı dizge için çok baytlı düzenli ifadenin eşleşen parçasının uzunluğunu ve konumunu döndürür

mb_ereg_search_init
mb_ereg_search_regs
Çok baytlı Dizge İşlevleri
PHP Manual

mb_ereg_search_pos

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

mb_ereg_search_pos — Evvelce tanımlanmış çok baytlı dizge için çok baytlı düzenli ifadenin eşleşen parçasının uzunluğunu ve konumunu döndürür

Açıklama

array mb_ereg_search_pos ([ string $şablon [, string $seçenek = "ms" ]] )

Evvelce tanımlanmış çok baytlı dizge için çok baytlı düzenli ifadenin eşleşen parçasının uzunluğunu ve konumunu döndürür.

Eşleştirilecek dizge mb_ereg_search_init() işlevi ile belirtilir. Belirtilmezse, evvelce belirtilmiş olan kullanılır.

Değiştirgeler

şablon

Eşleştirilecek şablon.

seçenek

Arama seçeneği. 'ms' öntanımlıdır.

Dönen Değerler

Çok baytlı düzenli ifade için eşleşen parçanın konumunu ve uzunluğunu içeren bir dizi ile döner. Dizinin ilk elemanı eşleşen parçanın konumu, ikinci elemanı ise bayt cinsinden uzunluğudur. Bir hata durumunda FALSE döner.

Notlar

Bilginize:

Bu işlev karakter kodlaması olarak dahili kodlamayı veya mb_regex_encoding() işlevi tarafından belirtilen karakter kodlamasını kullanır.

Ayrıca Bakınız

  • mb_regex_encoding() - mbregex işlevleri için geçerli kodlamayı dizge olarak döndürür
  • mb_ereg_search_init() - Çok baytlı düzenli ifade eşleşmesi için kullanılacak dizge ve düzenli ifadeyi tanımlar

mb_ereg_search_init
mb_ereg_search_regs
Çok baytlı Dizge İşlevleri


Çok baytlı düzenli ifadenin eşleşen parçası ile döner

mb_ereg_search_pos
mb_ereg_search_setpos
Çok baytlı Dizge İşlevleri
PHP Manual

mb_ereg_search_regs

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

mb_ereg_search_regs — Çok baytlı düzenli ifadenin eşleşen parçası ile döner

Açıklama

array mb_ereg_search_regs ([ string $şablon [, string $seçenek = "ms" ]] )

Çok baytlı düzenli ifadenin eşleşen parçası ile döner.

Değiştirgeler

şablon

Aranacak şablon.

seçenek

Arama seçeneği. 'ms' öntanımlıdır.

Dönen Değerler

mb_ereg_search_regs() işlevi çok baytlı düzenli ifadeyi eşleştirmeye çalışır, eğer eşleşen bir parça varsa, eşleşen parçanın alt dizgesini ilk eleman olarak, köşeli ayraçlı ilk grubu ikinci eleman olarak, ikinci grubu üçüncü eleman olarak, ... bir dizi içinde döndürür. Bir hata oluşursa işlev FALSE döndürür.

Notlar

Bilginize:

Bu işlev karakter kodlaması olarak dahili kodlamayı veya mb_regex_encoding() işlevi tarafından belirtilen karakter kodlamasını kullanır.

Ayrıca Bakınız

  • mb_regex_encoding() - mbregex işlevleri için geçerli kodlamayı dizge olarak döndürür
  • mb_ereg_search_init() - Çok baytlı düzenli ifade eşleşmesi için kullanılacak dizge ve düzenli ifadeyi tanımlar

mb_ereg_search_pos
mb_ereg_search_setpos
Çok baytlı Dizge İşlevleri


Sonraki düzenli ifade eşleşmesinin başlangıç noktasını tanımlar

mb_ereg_search_regs
mb_ereg_search
Çok baytlı Dizge İşlevleri
PHP Manual

mb_ereg_search_setpos

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

mb_ereg_search_setpos — Sonraki düzenli ifade eşleşmesinin başlangıç noktasını tanımlar

Açıklama

bool mb_ereg_search_setpos ( int $konum )

mb_ereg_search_setpos() işlevi, mb_ereg_search() işlevi için başlangıç noktası tanımlar.

Değiştirgeler

konum

Başlangıç noktası olarak tanımlanacak konum.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

Bilginize:

Bu işlev karakter kodlaması olarak dahili kodlamayı veya mb_regex_encoding() işlevi tarafından belirtilen karakter kodlamasını kullanır.

Ayrıca Bakınız

  • mb_regex_encoding() - mbregex işlevleri için geçerli kodlamayı dizge olarak döndürür
  • mb_ereg_search_init() - Çok baytlı düzenli ifade eşleşmesi için kullanılacak dizge ve düzenli ifadeyi tanımlar

mb_ereg_search_regs
mb_ereg_search
Çok baytlı Dizge İşlevleri


Evvelce tanımlanmış çok baytlı dizge için çok baytlı düzenli ifade eşleştirmesi yapar

mb_ereg_search_setpos
mb_ereg
Çok baytlı Dizge İşlevleri
PHP Manual

mb_ereg_search

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

mb_ereg_search — Evvelce tanımlanmış çok baytlı dizge için çok baytlı düzenli ifade eşleştirmesi yapar

Açıklama

bool mb_ereg_search ([ string $şablon [, string $seçenek = "ms" ]] )

Evvelce tanımlanmış çok baytlı dizge için çok baytlı düzenli ifade eşleştirmesi yapar.

Değiştirgeler

şablon

Aranacak şablon.

seçenek

Arama seçeneği. 'ms' öntanımlıdır.

Dönen Değerler

Çok baytlı dizge içinde düzenli ifadeyle bir eşleşme bulunursa TRUE yoksa FALSE döner. Eşleşmenin aranacağı dizge mb_ereg_search_init() işlevi ile tanımlanır. Eğer bir şablon belirtilmezse evvelce belirtilmiş olan şablon kullanılır.

Notlar

Bilginize:

Bu işlev karakter kodlaması olarak dahili kodlamayı veya mb_regex_encoding() işlevi tarafından belirtilen karakter kodlamasını kullanır.

Ayrıca Bakınız

  • mb_regex_encoding() - mbregex işlevleri için geçerli kodlamayı dizge olarak döndürür
  • mb_ereg_search_init() - Çok baytlı düzenli ifade eşleşmesi için kullanılacak dizge ve düzenli ifadeyi tanımlar

mb_ereg_search_setpos
mb_ereg
Çok baytlı Dizge İşlevleri


Düzenli ifadeyi çok baytlı karakter desteğiyle eşleştirir

mb_ereg_search
mb_eregi_replace
Çok baytlı Dizge İşlevleri
PHP Manual

mb_ereg

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

mb_ereg — Düzenli ifadeyi çok baytlı karakter desteğiyle eşleştirir

Açıklama

int mb_ereg ( string $şablon , string $dizge [, array $sonuç ] )

Düzenli ifadeyi çok baytlı karakter desteğiyle eşleştirir.

Değiştirgeler

şablon

Aranacak şablon.

dizge

Şablonun aranacağı dizge.

sonuç

Eşleşen dizgeyi içeren dizge.

Dönen Değerler

Düzenli ifadeyi çok baytlı karakter desteğiyle çalıştırır ve eşleşme sağlanırsa 1 döndürür. İsteğe bağlı olan sonuç değiştirgesi belirtilmişse eşleşen alt dizge sonuç değiştirgesine yerleştirilip uzunluğu dönüş değeri olarak döndürülür. Boş dizgeyle eşleşme halinde işlev 1 değeriyle döner. Eğer bir eşleşme bulunamazsa veya bir hata oluşursa FALSEdöner.

Notlar

Bilginize:

Bu işlev karakter kodlaması olarak dahili kodlamayı veya mb_regex_encoding() işlevi tarafından belirtilen karakter kodlamasını kullanır.

Ayrıca Bakınız

  • mb_regex_encoding() - mbregex işlevleri için geçerli kodlamayı dizge olarak döndürür
  • mb_eregi() - Harf büyüklüğüne duyarsız çok baytlı düzenli ifade eşleştirmesi uygular

mb_ereg_search
mb_eregi_replace
Çok baytlı Dizge İşlevleri


Harf büyüklüğüne duyarsız çok baytlı karakter destekli düzenli ifade yer değiştirmesi yapar

mb_ereg
mb_eregi
Çok baytlı Dizge İşlevleri
PHP Manual

mb_eregi_replace

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

mb_eregi_replace — Harf büyüklüğüne duyarsız çok baytlı karakter destekli düzenli ifade yer değiştirmesi yapar

Açıklama

string mb_eregi_replace ( string $şablon , string $yeni , string $dizge [, string $seçenek = "msri" ] )

dizge içinde şablon eşleştirilmeye çalışılır, eşleşen parça yenisi ile değiştirilir.

Değiştirgeler

şablon

Düzenli ifade olarak şablon. Çok baytlı karakterler kullanılabilir. Harf büyüklüğü dikkate alınmaz.

yeni

Yerleştirilecek metin.

dizge

İçinde şablonun aranacağı dizge.

seçenek
mb_ereg_replace() işlevindeki gibidir.

Dönen Değerler

Başarı durumunda elde edilen dizgeyle aksi takdirde FALSE ile döner.

Notlar

Bilginize:

Bu işlev karakter kodlaması olarak dahili kodlamayı veya mb_regex_encoding() işlevi tarafından belirtilen karakter kodlamasını kullanır.

Uyarı

Güvenilmez girdilerle çalışırken e değiştiricisini asla kullanmayın. Özdevinimli önceleme yapılmayacaktır (preg_replace() işlevinde olduğu gibi). Bunu dikkate almazsanız, büyük olasılıkla uygulamanızda uzaktan kod çalıştırma açıkları oluşacaktır.

Ayrıca Bakınız

  • mb_regex_encoding() - mbregex işlevleri için geçerli kodlamayı dizge olarak döndürür
  • mb_ereg_replace() - Çok baytlı karakter destekli düzenli ifade yer değiştirmesi yapar

mb_ereg
mb_eregi
Çok baytlı Dizge İşlevleri


Harf büyüklüğüne duyarsız çok baytlı düzenli ifade eşleştirmesi uygular

mb_eregi_replace
mb_get_info
Çok baytlı Dizge İşlevleri
PHP Manual

mb_eregi

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

mb_eregi — Harf büyüklüğüne duyarsız çok baytlı düzenli ifade eşleştirmesi uygular

Açıklama

int mb_eregi ( string $şablon , string $dizge [, array $sonuç ] )

Bir düzenli ifadeyi harf büyüklüğüne duyarsız olarak çok baytlı bir dizge ile eşleştirir.

Değiştirgeler

şablon

Düzenli ifade şablonu.

dizge

Şablonun aranacağı dizge.

sonuç

Eşleşen alt dizgeyi içerecek dizge.

Dönen Değerler

Düzenli ifadeyi çok baytlı karakter desteğiyle çalıştırır ve eşleşme sağlanırsa 1 döndürür. İsteğe bağlı olan sonuç değiştirgesi belirtilmişse eşleşen alt dizge sonuç değiştirgesine yerleştirilip uzunluğu dönüş değeri olarak döndürülür. Boş dizgeyle eşleşme halinde işlev 1 değeriyle döner. Eğer bir eşleşme bulunamazsa veya bir hata oluşursa FALSEdöner.

Notlar

Bilginize:

Bu işlev karakter kodlaması olarak dahili kodlamayı veya mb_regex_encoding() işlevi tarafından belirtilen karakter kodlamasını kullanır.

Ayrıca Bakınız

  • mb_regex_encoding() - mbregex işlevleri için geçerli kodlamayı dizge olarak döndürür
  • mb_ereg() - Düzenli ifadeyi çok baytlı karakter desteğiyle eşleştirir

mb_eregi_replace
mb_get_info
Çok baytlı Dizge İşlevleri


Mbstring değiştirgelerinin dahili ayarlarını döndürür

mb_eregi
mb_http_input
Çok baytlı Dizge İşlevleri
PHP Manual

mb_get_info

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

mb_get_info — Mbstring değiştirgelerinin dahili ayarlarını döndürür

Açıklama

mixed mb_get_info ([ string $tür = "all" ] )

mb_get_info() işlevi, mbstring değiştirgelerinin dahili ayarlarını döndürür.

Değiştirgeler

tür

tür belirtilmemişse ya da "all" olarak belirtilmişse, "internal_encoding", "http_output", "http_input", "func_overload", "mail_charset", "mail_header_encoding", "mail_body_encoding" elemanlarını içeren bir dizi döner.

Eğer tür olarak "http_output", "http_input", "internal_encoding" veya"func_overload" belirtilmişse belirtilen ayar değiştirgesi döndürülür.

Dönen Değerler

tür belirtilmemişse, tür bilgisini içeren bir dizi; aksi takdirde, belirtilen türe özgü bir dizi döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.3 | "mail_charset", "mail_header_encoding" ve "mail_body_encoding" girdileri kullanılabilir oldu.
5.3.0 | "http_output_conv_mimetypes" giridisi kullanılabilir oldu.

Ayrıca Bakınız

  • mb_regex_encoding() - mbregex işlevleri için geçerli kodlamayı dizge olarak döndürür
  • mb_http_output() - HTTP çıktı karakter kodlamasını tanımlar/döndürür

mb_eregi
mb_http_input
Çok baytlı Dizge İşlevleri


HTTP girdi karakter kodlamasını algılar

mb_get_info
mb_http_output
Çok baytlı Dizge İşlevleri
PHP Manual

mb_http_input

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

mb_http_input — HTTP girdi karakter kodlamasını algılar

Açıklama

mixed mb_http_input ([ string $tür = "" ] )

HTTP girdi karakter kodlamasını algılar.

Değiştirgeler

tür

Girdi türü: GET için "G", POST için "P", COOKIE için "C", dizge için "S", liste için "L" ve tam liste için "I" (bir dizi döner). tür belirtilmezse son işlenen girdinin türü ile döner.

Dönen Değerler

Belirtilen türe ilişkin karakter kodlaması adı. mb_http_input() belirtilen HTTP girdisini işlemezse FALSE döner.

Ayrıca Bakınız

  • mb_internal_encoding() - Dahili karakter kodlamasını tanımlar/döndürür
  • mb_http_output() - HTTP çıktı karakter kodlamasını tanımlar/döndürür
  • mb_detect_order() - Karakter kodlaması algılama sırasını tanımlar/döndürür

mb_get_info
mb_http_output
Çok baytlı Dizge İşlevleri


HTTP çıktı karakter kodlamasını tanımlar/döndürür

mb_http_input
mb_internal_encoding
Çok baytlı Dizge İşlevleri
PHP Manual

mb_http_output

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

mb_http_output — HTTP çıktı karakter kodlamasını tanımlar/döndürür

Açıklama

mixed mb_http_output ([ string $kodlama ] )

HTTP çıktı karakter kodlamasını tanımlar/döndürür. Bu işlevden sonra çıktı kodlama ile belirtilen kodlamaya dönüştürülür.

Değiştirgeler

kodlama

Belirtilmişse, işlev HTTP çıktı karakter kodlamasını tanımlar.

Belirtilmemişse, işlev HTTP çıktı karakter kodlamasını döndürür.

Dönen Değerler

kodlama belirtilmemişse, işlev HTTP çıktı karakter kodlamasını döndürür. Aksi takdirde, başarı durumunda TRUE başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • mb_internal_encoding() - Dahili karakter kodlamasını tanımlar/döndürür
  • mb_http_input() - HTTP girdi karakter kodlamasını algılar
  • mb_detect_order() - Karakter kodlaması algılama sırasını tanımlar/döndürür

mb_http_input
mb_internal_encoding
Çok baytlı Dizge İşlevleri


Dahili karakter kodlamasını tanımlar/döndürür

mb_http_output
mb_language
Çok baytlı Dizge İşlevleri
PHP Manual

mb_internal_encoding

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

mb_internal_encoding — Dahili karakter kodlamasını tanımlar/döndürür

Açıklama

mixed mb_internal_encoding ([ string $kodlama = mb_internal_encoding() ] )

Dahili karakter kodlamasını tanımlar/döndürür.

Değiştirgeler

kodlama

HTTP girdi karakter kodlaması dönüşümü için kullanılan karakter kodlaması ve dizge işlevleri için mbstring modülü tarafından tanımlanmış öntanımlı karakter kodlaması adı.

Dönen Değerler

kodlama belirtilmişse başarı durumunda TRUE aksi takdirde FALSE döner. kodlama belirtilmemişse geçerli kodlamanın ismi döner.

Örnekler

Örnek 1 - mb_internal_encoding() örneği

<?php
/* Dahili karakter kodlamasını UTF-8 yapalım */
mb_internal_encoding("UTF-8");

/* Dahili karakter kodlamasını öğrenelim */
echo mb_internal_encoding();
?>

Notlar

Bilginize:

Bu işlev karakter kodlaması olarak dahili kodlamayı veya mb_regex_encoding() işlevi tarafından belirtilen karakter kodlamasını kullanır.

Ayrıca Bakınız

  • mb_http_input() - HTTP girdi karakter kodlamasını algılar
  • mb_http_output() - HTTP çıktı karakter kodlamasını tanımlar/döndürür
  • mb_detect_order() - Karakter kodlaması algılama sırasını tanımlar/döndürür

mb_http_output
mb_language
Çok baytlı Dizge İşlevleri


Geçerli dili tanımlar/döndürür

mb_internal_encoding
mb_list_encodings
Çok baytlı Dizge İşlevleri
PHP Manual

mb_language

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

mb_language — Geçerli dili tanımlar/döndürür

Açıklama

mixed mb_language ([ string $dil ] )

Geçerli dili tanımlar/döndürür.

Değiştirgeler

dil

Eposta iletilerini kodlamak için kullanılır. Geçerli değerler: "Japanese", "ja","English","en" ve "uni" (UTF-8). mb_send_mail() bu değeri epostayı kodlamak için kullanır.

Dil ve kodlama: Japonca için ISO-2022-JP/Base64, uni için UTF-8/Base64, İngilizce için ISO-8859-1/quoted printable.

Dönen Değerler

dil belirtilmiş ve geçerli ise TRUE yoksa FALSE döner. dil belirtilmezse, dilin adı bir dizge olarak döndürülür. Evvelce tanımlanmış bir dil yoksa FALSE döner.

Ayrıca Bakınız

  • mb_send_mail() - Kodlanmış olarak posta gönderir

mb_internal_encoding
mb_list_encodings
Çok baytlı Dizge İşlevleri


Desteklenen kodlamaların tamamını bir dizi olarak döndürür

mb_language
mb_output_handler
Çok baytlı Dizge İşlevleri
PHP Manual

mb_list_encodings

(PHP 5, PHP 7)

mb_list_encodings — Desteklenen kodlamaların tamamını bir dizi olarak döndürür

Açıklama

array mb_list_encodings ( void )

Desteklenen kodlamaların tamamını içeren bir dizi döndürür.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Sayısal indisli bir dizi döndürür.

Hatalar/İstisnalar

Bu işlev herhangi bir hata vermez.

Örnekler

Örnek 1 - mb_list_encodings() örneği

<?php

print_r(mb_list_encodings());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [0] => pass
    [1] => auto
    [2] => wchar
    [3] => byte2be
    [4] => byte2le
    [5] => byte4be
    [6] => byte4le
    [7] => BASE64
    [8] => UUENCODE
    [9] => HTML-ENTITIES
    [10] => Quoted-Printable
    [11] => 7bit
    [12] => 8bit
    [13] => UCS-4
    [14] => UCS-4BE
    [15] => UCS-4LE
    [16] => UCS-2
    [17] => UCS-2BE
    [18] => UCS-2LE
    [19] => UTF-32
    [20] => UTF-32BE
    [21] => UTF-32LE
    [22] => UTF-16
    [23] => UTF-16BE
    [24] => UTF-16LE
    [25] => UTF-8
    [26] => UTF-7
    [27] => UTF7-IMAP
    [28] => ASCII
    [29] => EUC-JP
    [30] => SJIS
    [31] => eucJP-win
    [32] => SJIS-win
    [33] => JIS
    [34] => ISO-2022-JP
    [35] => Windows-1252
    [36] => ISO-8859-1
    [37] => ISO-8859-2
    [38] => ISO-8859-3
    [39] => ISO-8859-4
    [40] => ISO-8859-5
    [41] => ISO-8859-6
    [42] => ISO-8859-7
    [43] => ISO-8859-8
    [44] => ISO-8859-9
    [45] => ISO-8859-10
    [46] => ISO-8859-13
    [47] => ISO-8859-14
    [48] => ISO-8859-15
    [49] => EUC-CN
    [50] => CP936
    [51] => HZ
    [52] => EUC-TW
    [53] => BIG-5
    [54] => EUC-KR
    [55] => UHC
    [56] => ISO-2022-KR
    [57] => Windows-1251
    [58] => CP866
    [59] => KOI8-R
)

mb_language
mb_output_handler
Çok baytlı Dizge İşlevleri


Çıktı tamporundaki karakter kodlamasını dönüştüren geriçağırım işlevi

mb_list_encodings
mb_parse_str
Çok baytlı Dizge İşlevleri
PHP Manual

mb_output_handler

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

mb_output_handler — Çıktı tamporundaki karakter kodlamasını dönüştüren geriçağırım işlevi

Açıklama

string mb_output_handler ( string $içerik , int $durum )

mb_output_handler() bir ob_start() geriçağırım işlevidir. mb_output_handler() işlevi çıktı tamponundaki karakterlerin dahili karakter kodlamasını HTTP çıktısı karakter kodlamasına dönüştürür.

Değiştirgeler

içerik

Çıktı tamponunun içeriği.

durum

Çıktı tamponunun durumu.

Dönen Değerler

Dönüştürülen dizge.

Sürüm Bilgisi

Sürüm: Açıklama
4.1.0

Bu işlev artık aşağıdaki koşullar sağlandığı takdirde charset HTTP başlığını eklemektedir:

  • header() işlevi kullanılarak Content-Type başlığı tanımlanmazsa.
  • Öntanımlı MIME türü text/ ile başlarsa.
  • mbstring.http_input değeri pass değilse.

Örnekler

Örnek 1 - mb_output_handler() örneği

<?php
mb_http_output("UTF-8");
ob_start("mb_output_handler");
?>

Notlar

Bilginize:

PHP 4.3.0 ve sonrası ile, bir resim verisi gibi bir ikil veriyi PHP betiğinizden göndermek isterseniz bu veriyi istemciye göndermeden önce header() işlevini kullanarak Content-Type: başlığını (örneğin, header("Content-Type: image/png") olarak) göndermelisiniz. Content-Type: başlığı gönderilmişse karakter kodlaması dönüşümü uygulanmaz.

header() işlevini kullanılarak 'Content-Type: text/*' gönderilmişse gönderilen verinin metin olarak ele alınacağını ve karakter kodlaması ayarlarına uygun olarak karakter kodlaması dönüşümü yapılacağını unutmayın.

PHP 4.2.x ve öncesi ile, bir resim verisi gibi bir ikil veriyi PHP betiğinizden göndermek isterseniz çıktı kodlamasına mb_http_output() işlevini kullanarak "pass" değerini atamalısınız.

Ayrıca Bakınız

  • ob_start() - Çıktı tamponlamasını başlatır

mb_list_encodings
mb_parse_str
Çok baytlı Dizge İşlevleri


GET/POST/COOKIE verisini çözümler ve küresel değişkenleri tanımlar

mb_output_handler
mb_preferred_mime_name
Çok baytlı Dizge İşlevleri
PHP Manual

mb_parse_str

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

mb_parse_str — GET/POST/COOKIE verisini çözümler ve küresel değişkenleri tanımlar

Açıklama

bool mb_parse_str ( string $kodlu_dizge [, array &$sonuç ] )

GET/POST/COOKIE verisini çözümler ve küresel değişkenleri tanımlar. PHP ham POST/COOKIE verisi sağlamadığından şimdilik sadece GET verisi için kullanılabilmektedir. İşlev, URL kodlu veriyi çözümler, kodlamayı algılar ve dahili kodlamaya dönüştürüp değerleri sonuç dizisine veya küresel değişkenlere atar.

Değiştirgeler

kodlu_dizge

URL kodlu veri.

sonuç

Çözümlenip karakter kodlaması dönüştürülmüş değerleri içeren bir dizi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • mb_detect_order() - Karakter kodlaması algılama sırasını tanımlar/döndürür
  • mb_internal_encoding() - Dahili karakter kodlamasını tanımlar/döndürür

mb_output_handler
mb_preferred_mime_name
Çok baytlı Dizge İşlevleri


MIME karakter kümesi dizgesini döndürür

mb_parse_str
mb_regex_encoding
Çok baytlı Dizge İşlevleri
PHP Manual

mb_preferred_mime_name

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

mb_preferred_mime_name — MIME karakter kümesi dizgesini döndürür

Açıklama

string mb_preferred_mime_name ( string $kodlama )

Belirtilen kodlama için MIME karakter kümesini bir dizge olarak döndürür.

Değiştirgeler

kodlama

Karakter kodlaması.

Dönen Değerler

kodlama ile belirtilen karakter kodlaması için MIME charset dizgesini döndürür.

Örnekler

Örnek 1 - mb_preferred_mime_name() örneği

<?php
$outputenc = "sjis-win";
mb_http_output($outputenc);
ob_start("mb_output_handler");
header("Content-Type: text/html; charset=" . mb_preferred_mime_name($outputenc));
?>

mb_parse_str
mb_regex_encoding
Çok baytlı Dizge İşlevleri


mbregex işlevleri için geçerli kodlamayı dizge olarak döndürür

mb_preferred_mime_name
mb_regex_set_options
Çok baytlı Dizge İşlevleri
PHP Manual

mb_regex_encoding

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

mb_regex_encoding — mbregex işlevleri için geçerli kodlamayı dizge olarak döndürür

Açıklama

mixed mb_regex_encoding ([ string $kodlama ] )

Çok baytlı düzenli ifade işlevleri için geçerli karakter kodlamasını bir dizge olarak döndürür.

Değiştirgeler

kodlama

kodlama değiştirgesinde karakter kodlaması belirtilir. Belirtilmediği takdirde dahili karakter kodlaması kullanılır.

Dönen Değerler

Çok baytlı düzenli ifade işlevlerinde kullanılan karakter kodlamasını döndürür.

Ayrıca Bakınız

  • mb_internal_encoding() - Dahili karakter kodlamasını tanımlar/döndürür
  • mb_ereg() - Düzenli ifadeyi çok baytlı karakter desteğiyle eşleştirir

mb_preferred_mime_name
mb_regex_set_options
Çok baytlı Dizge İşlevleri


mbregex işlevleri için öntanımlı seçenekleri tanımlar/döndürür

mb_regex_encoding
mb_send_mail
Çok baytlı Dizge İşlevleri
PHP Manual

mb_regex_set_options

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

mb_regex_set_options — mbregex işlevleri için öntanımlı seçenekleri tanımlar/döndürür

Açıklama

string mb_regex_set_options ([ string $seçenekler = "msr" ] )

Çok baytlı düzenli ifade işlevleri için seçenekler dizgesiyle belirtilen örtanımlı seçenekleri tanımlar.

Değiştirgeler

seçenekler

Tanımlanacak seçenekler.

Dönen Değerler

Önceki seçenekler. seçenekler belirtilmemişse geçerli seçenekleri içeren bir dizge ile döner.

Ayrıca Bakınız

  • mb_split() - Çok baytlı bir dizgeyi düzenli ifade ile parçalara ayırır
  • mb_ereg() - Düzenli ifadeyi çok baytlı karakter desteğiyle eşleştirir
  • mb_eregi() - Harf büyüklüğüne duyarsız çok baytlı düzenli ifade eşleştirmesi uygular

mb_regex_encoding
mb_send_mail
Çok baytlı Dizge İşlevleri


Kodlanmış olarak posta gönderir

mb_regex_set_options
mb_split
Çok baytlı Dizge İşlevleri
PHP Manual

mb_send_mail

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

mb_send_mail — Kodlanmış olarak posta gönderir

Açıklama

bool mb_send_mail ( string $kime , string $konu , string $ileti [, string $ek_başlıklar = NULL [, string $ek_değiştirge = NULL ]] )

Eposta gönderir. Başlıklar ve ileti mb_language() ayarına göre dönüştürülüp kodlanır. mail() işlevi için bir sarmalayıcı olup ayrıntılar için mail() işlevine bakınız.

Değiştirgeler

kime

Epostanın gönderileceği adres. Adresler arasına virgül koyarak çok sayıda adres belirtilebilir. Bu değiştirge özdevinimli olarak kodlanmaz.

konu

Epostanın konusu.

ileti

Postalanacak ileti.

ek_başlıklar

ek_başlıklar başlığın sonuna yerleştirilir. Genellikle ek başlıklar belirtmek için kullanılır. Aralarına bir satırsonu karakteri ("\n") konularak çok sayıda ek başlık belirtilebilir.

ek_değiştirge

ek_değiştirge bir posta sunucusu komut satırı değiştirgesidir. Sendmail kullanırken doğru Return-Path başlığı belirtmek için kullanışlıdır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.0 | Content-Type ve Content-Transfer-Encoding başlıkları PHP 5.0.0'da yeniden tanımlandı. Daha önce, daima mb_language() ile tanımlanmış değerler kullanılırdı.

Ayrıca Bakınız

  • mail() - Eposta gönderir
  • mb_encode_mimeheader() - Dizgeyi MIME başlığı için kodlar
  • mb_language() - Geçerli dili tanımlar/döndürür

mb_regex_set_options
mb_split
Çok baytlı Dizge İşlevleri


Çok baytlı bir dizgeyi düzenli ifade ile parçalara ayırır

mb_send_mail
mb_strcut
Çok baytlı Dizge İşlevleri
PHP Manual

mb_split

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

mb_split — Çok baytlı bir dizgeyi düzenli ifade ile parçalara ayırır

Açıklama

array mb_split ( string $şablon , string $dizge [, int $sınır = -1 ] )

dizge ile belirtilen bir dizgeyi şablon ile belirtilen düzenli ifadeye göre parçalara ayırır ve sonucu bir dizi olarak döndürür.

Değiştirgeler

şablon

Düzenli ifade şablonu.

dizge

Parçalara ayrılacak dizge.

sınır
İsteğe bağlı olup, belirtildiği takdirde en fazla sınır sayıda parça döndürülür.

Dönen Değerler

Dir dizi olarak sonuç.

Notlar

Bilginize:

Bu işlev karakter kodlaması olarak dahili kodlamayı veya mb_regex_encoding() işlevi tarafından belirtilen karakter kodlamasını kullanır.

Ayrıca Bakınız

  • mb_regex_encoding() - mbregex işlevleri için geçerli kodlamayı dizge olarak döndürür
  • mb_ereg() - Düzenli ifadeyi çok baytlı karakter desteğiyle eşleştirir

mb_send_mail
mb_strcut
Çok baytlı Dizge İşlevleri


Dizgenin başlangıcı ve uzunluğu belirtilen parçası ile döner

mb_split
mb_strimwidth
Çok baytlı Dizge İşlevleri
PHP Manual

mb_strcut

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

mb_strcut — Dizgenin başlangıcı ve uzunluğu belirtilen parçası ile döner

Açıklama

string mb_strcut ( string $dizge , int $başlangıç [, int $uzunluk [, string $kodlama ]] )

mb_strcut() işlevi mb_substr() işlevinin yaptığını farklı bir yöntemle yapar. Eğer başlangıç konumu çok baytlı bir karakterin ikinci veya sonraki baytındaysa başlangıcı o karaterin ilk baytına taşır.

dizge ile belirtilen dizgeden uzunluk ile belirtilenden daha kısa bir dizge ve çok baytlı dizgenin bir parçası olmayan veya çok baytlı bir karakterin ortasında olmayan karakteri çıkarır. (?)

Değiştirgeler

dizge

Parça çıkarılacak dizge.

başlangıç

Çıkarılacak parçanın başlangıç konumu.

uzunluk

Çıkarılacak parçanın uzunluğu.

kodlama

kodlama değiştirgesinde karakter kodlaması belirtilir. Belirtilmediği takdirde dahili karakter kodlaması kullanılır.

Dönen Değerler

mb_strcut() işlevi, str dizgesinden başlangıç ve uzunluk ile belirtilen parçayı döndürür.

Ayrıca Bakınız

  • mb_substr() - Dizgenin bir alt dizgesini alır
  • mb_internal_encoding() - Dahili karakter kodlamasını tanımlar/döndürür

mb_split
mb_strimwidth
Çok baytlı Dizge İşlevleri


Dizgeyi belirtilen genişlikte kırpar

mb_strcut
mb_stripos
Çok baytlı Dizge İşlevleri
PHP Manual

mb_strimwidth

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

mb_strimwidth — Dizgeyi belirtilen genişlikte kırpar

Açıklama

string mb_strimwidth ( string $dizge , int $başlangıç , int $genişlik [, string $kırpıcı [, string $kodlama ]] )

Belirtilen dizge dizgesini genişlik ile belirtilen genişlikten kırpar.

Değiştirgeler

dizge

Kırpılacak dizge.

başlangıç

Kırpma genişliğinin başlatılacağı konum. Dizgenin başından itibaren sayılır. İlk karakterin indisi 0'dır.

genişlik

Kırpma genişliği.

kırpıcı

Dizge kırpılırken dizgenin sonuna eklenen bir dizge.

kodlama

kodlama değiştirgesinde karakter kodlaması belirtilir. Belirtilmediği takdirde dahili karakter kodlaması kullanılır.

Dönen Değerler

Kırpılmış dizge ile döner. kırpıcı belirtilmişse, kırpıcı dönen değere eklenir.

Örnekler

Örnek 1 - mb_strimwidth() örneği

<?php
$str = mb_strimwidth($str, 0, 40, "..>");
?>

Ayrıca Bakınız

  • mb_strwidth() - Dizge genişliğini döndürür
  • mb_internal_encoding() - Dahili karakter kodlamasını tanımlar/döndürür

mb_strcut
mb_stripos
Çok baytlı Dizge İşlevleri


Harf büyüklüğüne duyarsız olarak, bir dizgenin içinde başka bir dizgeye ilk rastlanılan noktanın indisini döndürür

mb_strimwidth
mb_stristr
Çok baytlı Dizge İşlevleri
PHP Manual

mb_stripos

(PHP 5 >= 5.2.0, PHP 7)

mb_stripos — Harf büyüklüğüne duyarsız olarak, bir dizgenin içinde başka bir dizgeye ilk rastlanılan noktanın indisini döndürür

Açıklama

int mb_stripos ( string $samanlık , string $iğne [, int $konum [, string $kodlama ]] )

Karakter sayısına dayalı olarak güvenilir bir çok baytlı strpos() işlemi yürütür. iğne'nin ilk karakterinin yeri samanlık dizgesinin ilk karakterine göre hesaplanır. İlk karakterin indisi 0'dır. mb_strpos() işlevinden farklı olarak, mb_stripos() harf büyüklüğüne duyarsızdır.

Değiştirgeler

samanlık

İlk iğne'nin aranacağı dizge.

needle

samanlık içinde ilki aranacak dizge.

konum

samanlık içinde aramanın başlatılacağı konum.

kodlama

kodlama değiştirgesinde karakter kodlaması belirtilir. Belirtilmediği takdirde dahili karakter kodlaması kullanılır.

Dönen Değerler

İlk iğne'nin samanlık içinde bulunduğu yerin indisi ile döner. Eğer samanlık içinde iğne yoksa FALSE döndürür.

Ayrıca Bakınız

  • stripos() - Harf büyüklüğüne duyarsız olarak bir alt dizgenin ilkinin konumunu bulur
  • strpos() - Bir alt dizgenin ilkinin konumunu bulur
  • mb_strpos() - Bir dizgenin içinde başka bir dizgeye ilk rastlanılan noktanın indisini döndürür

mb_strimwidth
mb_stristr
Çok baytlı Dizge İşlevleri


Harf büyüklüğüne duyarsız olarak, bir dizgenin içinde başka bir dizgeye ilk rastlanılan noktaya göre dizgenin ilk veya son bölümü ile döner

mb_stripos
mb_strlen
Çok baytlı Dizge İşlevleri
PHP Manual

mb_stristr

(PHP 5 >= 5.2.0, PHP 7)

mb_stristr — Harf büyüklüğüne duyarsız olarak, bir dizgenin içinde başka bir dizgeye ilk rastlanılan noktaya göre dizgenin ilk veya son bölümü ile döner

Açıklama

string mb_stristr ( string $samanlık , string $iğne [, bool $ilk_parça [, string $kodlama ]] )

mb_strstr() işlevi, samanlık içinde iğne'yi bulur ve iğne'nin ilk karakterinin yerine göre samanlık dizgesinin ilk veya son parçası ile döner. Eğer samanlık içinde iğne yoksa FALSE döndürür. mb_strstr() işlevinden farklı olarak, mb_stristr() harf büyüklüğüne duyarsızdır.

Değiştirgeler

samanlık

İlk iğne'nin aranacağı dizge.

iğne

samanlık içinde aranacak dizge.

ilk_parça

samanlık dizgesinin hangi parçasının döndürüleceğini belirler. TRUE atanırsa samanlık dizgesinin ilk karakterinden (dahil) iğne dizgesinin ilk karakterine (hariç) kadar olan parçayla döner. FALSE atanırsa, iğne dizgesinin ilk karakterinden (dahil) samanlık dizgesinin son karakterine (dahil) kadar olan parça döndürülür. FALSE öntanımlıdır.

kodlama

kodlama değiştirgesinde karakter kodlaması belirtilir. Belirtilmediği takdirde dahili karakter kodlaması kullanılır.

Dönen Değerler

Eğer samanlık içinde iğne yoksa FALSE, aksi takdirde ilk veya son samanlık parçası ile döner.

Ayrıca Bakınız

  • stristr() - Harf büyüklüğüne duyarsız olarak ilk alt dizgeyi bulur
  • strstr() - İlk alt dizgeyi bulur
  • mb_strstr() - Bir dizgenin içinde başka bir dizgeye ilk rastlanılan noktaya göre dizgenin ilk veya son bölümü ile döner

mb_stripos
mb_strlen
Çok baytlı Dizge İşlevleri


Dizge uzunluğu ile döner

mb_stristr
mb_strpos
Çok baytlı Dizge İşlevleri
PHP Manual

mb_strlen

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

mb_strlen — Dizge uzunluğu ile döner

Açıklama

int mb_strlen ( string $dizge [, string $kodlama ] )

Belirtilen dizgenin karakter sayısını döndürür.

Değiştirgeler

dizge

Karakter sayısı öğrenilmek istenen dizge.

kodlama

kodlama değiştirgesinde karakter kodlaması belirtilir. Belirtilmediği takdirde dahili karakter kodlaması kullanılır.

Dönen Değerler

dizge değiştirgesi ile belirtilen dizgenin karakter sayısını döndürür. Her çok baytlı karakter 1 kabul edilir.

Ayrıca Bakınız

  • mb_internal_encoding() - Dahili karakter kodlamasını tanımlar/döndürür
  • strlen() - Dizge uzunluğunu döndürür

mb_stristr
mb_strpos
Çok baytlı Dizge İşlevleri


Bir dizgenin içinde başka bir dizgeye ilk rastlanılan noktanın indisini döndürür

mb_strlen
mb_strrchr
Çok baytlı Dizge İşlevleri
PHP Manual

mb_strpos

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

mb_strpos — Bir dizgenin içinde başka bir dizgeye ilk rastlanılan noktanın indisini döndürür

Açıklama

int mb_strpos ( string $samanlık , string $iğne [, int $konum [, string $kodlama ]] )

Bir dizgenin içinde başka bir dizgeye ilk rastlanılan noktanın indisini döndürür.

Karakter sayısına dayalı olarak güvenilir bir çok baytlı strpos() işlemi yürütür. iğne'nin ilk karakterinin yeri samanlık dizgesinin ilk karakterine göre hesaplanır. İlk karakterin indisi 0'dır.

Değiştirgeler

samanlık

İlk iğne'nin aranacağı dizge.

iğne

samanlık içinde ilki aranacak dizge.

konum

samanlık içinde aramanın başlatılacağı konum. Belirtilmezse 0 kullanılır.

kodlama

kodlama değiştirgesinde karakter kodlaması belirtilir. Belirtilmediği takdirde dahili karakter kodlaması kullanılır.

Dönen Değerler

İlk iğne'nin samanlık içinde bulunduğu yerin indisi ile döner. Eğer samanlık içinde iğne yoksa FALSE döndürür.

Ayrıca Bakınız

  • mb_strrpos() - Bir dizgenin içinde başka bir dizgeye son rastlanılan noktanın indisini döndürür
  • mb_internal_encoding() - Dahili karakter kodlamasını tanımlar/döndürür
  • strpos() - Bir alt dizgenin ilkinin konumunu bulur

mb_strlen
mb_strrchr
Çok baytlı Dizge İşlevleri


Bir dizgenin içinde bulunan bir karaktere göre dizgenin ilk veya son bölümü ile döner

mb_strpos
mb_strrichr
Çok baytlı Dizge İşlevleri
PHP Manual

mb_strrchr

(PHP 5 >= 5.2.0, PHP 7)

mb_strrchr — Bir dizgenin içinde bulunan bir karaktere göre dizgenin ilk veya son bölümü ile döner

Açıklama

string mb_strrchr ( string $samanlık , string $iğne [, bool $ilk_parça [, string $kodlama ]] )

mb_strrchr() işlevi, samanlık içinde iğne'yi bulur ve iğne'nin yerine göre samanlık dizgesinin ilk veya son parçası ile döner. Eğer samanlık içinde iğne yoksa FALSE döndürür.

Değiştirgeler

samanlık

Sonuncu iğne'nin aranacağı dizge.

iğne

samanlık içinde aranacak karakter.

ilk_parça

samanlık dizgesinin hangi parçasının döndürüleceğini belirler. TRUE atanırsa samanlık dizgesinin ilk karakterinden (dahil) iğne karakterine (hariç) kadar olan parçayla döner. FALSE atanırsa, iğne karakterinden (dahil) samanlık dizgesinin son karakterine (dahil) kadar olan parça döndürülür. FALSE öntanımlıdır.

kodlama

kodlama değiştirgesinde karakter kodlaması belirtilir. Belirtilmediği takdirde dahili karakter kodlaması kullanılır.

Dönen Değerler

Eğer samanlık içinde iğne yoksa FALSE, aksi takdirde ilk veya son samanlık parçası ile döner.

Ayrıca Bakınız

  • strrchr() - Bir dizgede belli bir karakterin sonuncusuna göre dizgenin bir parçasıyla döner
  • mb_strstr() - Bir dizgenin içinde başka bir dizgeye ilk rastlanılan noktaya göre dizgenin ilk veya son bölümü ile döner
  • mb_strrichr() - Harf büyüklüğüne duyarsız olarak bir dizgenin içinde bulunan bir karaktere göre dizgenin ilk veya son bölümü ile döner

mb_strpos
mb_strrichr
Çok baytlı Dizge İşlevleri


Harf büyüklüğüne duyarsız olarak bir dizgenin içinde bulunan bir karaktere göre dizgenin ilk veya son bölümü ile döner

mb_strrchr
mb_strripos
Çok baytlı Dizge İşlevleri
PHP Manual

mb_strrichr

(PHP 5 >= 5.2.0, PHP 7)

mb_strrichr — Harf büyüklüğüne duyarsız olarak bir dizgenin içinde bulunan bir karaktere göre dizgenin ilk veya son bölümü ile döner

Açıklama

string mb_strrichr ( string $samanlık , string $iğne [, bool $ilk_parça [, string $kodlama ]] )

mb_strrichr() işlevi, samanlık içinde iğne'yi bulur ve iğne'nin yerine göre samanlık dizgesinin ilk veya son parçası ile döner. Eğer samanlık içinde iğne yoksa FALSE döndürür. mb_strrchr() işlevinden farklı olarak mb_strrichr() harf büyüklüğüne duyarsızdır.

Değiştirgeler

samanlık

Sonuncu iğne'nin aranacağı dizge.

iğne

samanlık içinde aranacak karakter.

ilk_parça

samanlık dizgesinin hangi parçasının döndürüleceğini belirler. TRUE atanırsa samanlık dizgesinin ilk karakterinden (dahil) iğne karakterine (hariç) kadar olan parçayla döner. FALSE atanırsa, iğne karakterinden (dahil) samanlık dizgesinin son karakterine (dahil) kadar olan parça döndürülür. FALSE öntanımlıdır.

kodlama

kodlama değiştirgesinde karakter kodlaması belirtilir. Belirtilmediği takdirde dahili karakter kodlaması kullanılır.

Dönen Değerler

Eğer samanlık içinde iğne yoksa FALSE, aksi takdirde ilk veya son samanlık parçası ile döner.

Ayrıca Bakınız

  • mb_stristr() - Harf büyüklüğüne duyarsız olarak, bir dizgenin içinde başka bir dizgeye ilk rastlanılan noktaya göre dizgenin ilk veya son bölümü ile döner
  • mb_strrchr() - Bir dizgenin içinde bulunan bir karaktere göre dizgenin ilk veya son bölümü ile döner

mb_strrchr
mb_strripos
Çok baytlı Dizge İşlevleri


Bir dizgenin içinde harf büyüklüğüne duyarsız olarak başka bir dizgeye son rastlanılan noktanın indisini döndürür

mb_strrichr
mb_strrpos
Çok baytlı Dizge İşlevleri
PHP Manual

mb_strripos

(PHP 5 >= 5.2.0, PHP 7)

mb_strripos — Bir dizgenin içinde harf büyüklüğüne duyarsız olarak başka bir dizgeye son rastlanılan noktanın indisini döndürür

Açıklama

int mb_strripos ( string $samanlık , string $iğne [, int $konum [, string $kodlama ]] )

Karakter sayısına dayalı olarak güvenilir bir çok baytlı strripos() işlemi yürütür. iğne'nin ilk karakterinin yeri samanlık dizgesinin ilk karakterine göre hesaplanır. İlk karakterin indisi 0'dır. mb_strrpos() işlevinden farklı olarak mb_strripos() harf büyüklüğüne duyarsızdır.

Değiştirgeler

samanlık

Sonuncu iğne'nin aranacağı dizge.

iğne

samanlık içinde sonuncusu aranacak dizge.

konum

samanlık içinde aramanın başlatılacağı konum.

kodlama

kodlama değiştirgesinde karakter kodlaması belirtilir. Belirtilmediği takdirde dahili karakter kodlaması kullanılır.

Dönen Değerler

Sonuncu iğne'nin samanlık içinde bulunduğu yerin indisi ile döner. Eğer samanlık içinde iğne yoksa FALSE döndürür.

Ayrıca Bakınız

  • strripos() - Bir dizgede harf büyüklüğüne duyarsız olarak bir alt dizgenin sonuncusunu bulur
  • strrpos() - Bir dizgede bir karakterin sonuncusunu bulur
  • mb_strrpos() - Bir dizgenin içinde başka bir dizgeye son rastlanılan noktanın indisini döndürür

mb_strrichr
mb_strrpos
Çok baytlı Dizge İşlevleri


Bir dizgenin içinde başka bir dizgeye son rastlanılan noktanın indisini döndürür

mb_strripos
mb_strstr
Çok baytlı Dizge İşlevleri
PHP Manual

mb_strrpos

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

mb_strrpos — Bir dizgenin içinde başka bir dizgeye son rastlanılan noktanın indisini döndürür

Açıklama

int mb_strrpos ( string $samanlık , string $iğne [, int $konum [, string $kodlama ]] )

Karakter sayısına dayalı olarak güvenilir bir çok baytlı strrpos() işlemi yürütür. iğne'nin ilk karakterinin yeri samanlık dizgesinin ilk karakterine göre hesaplanır. İlk karakterin indisi 0'dır.

Değiştirgeler

samanlık

Sonuncu iğne'nin aranacağı dizge.

iğne

samanlık içinde sonuncusu aranacak dizge.

konum
samanlık içinde aramanın başlatılacağı konum. Negatif bir değer samanlık dizgesinin son karakterine göre aramanın durdurulacağı konumu belirtir.
kodlama

kodlama değiştirgesinde karakter kodlaması belirtilir. Belirtilmediği takdirde dahili karakter kodlaması kullanılır.

Dönen Değerler

Sonuncu iğne'nin samanlık içinde bulunduğu yerin indisi ile döner. Eğer samanlık içinde iğne yoksa FALSE döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
5.2.0 | İsteğe bağlı konum değiştirgesi eklendi.

Notlar

Bilginize: kodlama değiştirgesi işlev değiştirgeleri içinde üçüncülükten dördüncülüğe PHP 5.2.0 sürümünde taşındı. Geriye uyumluluk adına kodlama değiştirgesi üçüncü değiştirge olarak da belirtilebilir, fakat bunun yapılması önerilmez, çünkü bu uyumluluk özelliği yakında kaldırılacaktır.

Bilginize:

Bu işlev karakter kodlaması olarak dahili kodlamayı veya mb_regex_encoding() işlevi tarafından belirtilen karakter kodlamasını kullanır.

Ayrıca Bakınız

  • mb_strpos() - Bir dizgenin içinde başka bir dizgeye ilk rastlanılan noktanın indisini döndürür
  • mb_internal_encoding() - Dahili karakter kodlamasını tanımlar/döndürür
  • strrpos() - Bir dizgede bir karakterin sonuncusunu bulur

mb_strripos
mb_strstr
Çok baytlı Dizge İşlevleri


Bir dizgenin içinde başka bir dizgeye ilk rastlanılan noktaya göre dizgenin ilk veya son bölümü ile döner

mb_strrpos
mb_strtolower
Çok baytlı Dizge İşlevleri
PHP Manual

mb_strstr

(PHP 5 >= 5.2.0, PHP 7)

mb_strstr — Bir dizgenin içinde başka bir dizgeye ilk rastlanılan noktaya göre dizgenin ilk veya son bölümü ile döner

Açıklama

string mb_strstr ( string $samanlık , string $iğne [, bool $ilk_parça [, string $kodlama ]] )

mb_strstr() işlevi, samanlık içinde iğne'yi bulur ve iğne'nin ilk karakterinin yerine göre samanlık dizgesinin ilk veya son parçası ile döner. Eğer samanlık içinde iğne yoksa FALSE döndürür.

Değiştirgeler

samanlık

İlk iğne'nin aranacağı dizge.

iğne

samanlık içinde aranacak dizge.

ilk_parça

samanlık dizgesinin hangi parçasının döndürüleceğini belirler. TRUE atanırsa samanlık dizgesinin ilk karakterinden (dahil) iğne dizgesinin ilk karakterine (hariç) kadar olan parçayla döner. FALSE atanırsa, iğne dizgesinin ilk karakterinden (dahil) samanlık dizgesinin son karakterine (dahil) kadar olan parça döndürülür. FALSE öntanımlıdır.

kodlama

kodlama değiştirgesinde karakter kodlaması belirtilir. Belirtilmediği takdirde dahili karakter kodlaması kullanılır.

Dönen Değerler

Eğer samanlık içinde iğne yoksa FALSE, aksi takdirde ilk veya son samanlık parçası ile döner.

Ayrıca Bakınız

  • stristr() - Harf büyüklüğüne duyarsız olarak ilk alt dizgeyi bulur
  • strstr() - İlk alt dizgeyi bulur
  • mb_stristr() - Harf büyüklüğüne duyarsız olarak, bir dizgenin içinde başka bir dizgeye ilk rastlanılan noktaya göre dizgenin ilk veya son bölümü ile döner

mb_strrpos
mb_strtolower
Çok baytlı Dizge İşlevleri


Dizgeyi küçük harfli yapar

mb_strstr
mb_strtoupper
Çok baytlı Dizge İşlevleri
PHP Manual

mb_strtolower

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

mb_strtolower — Dizgeyi küçük harfli yapar

Açıklama

string mb_strtolower ( string $dizge [, string $kodlama = mb_internal_encoding() ] )

dizge içindeki 'abecesel' karakterlerin tamamını küçük harfe çevirir.

Değiştirgeler

dizge

Küçük harfli yapılacak dizge.

encoding

kodlama değiştirgesinde karakter kodlaması belirtilir. Belirtilmediği takdirde dahili karakter kodlaması kullanılır.

Dönen Değerler

İçindeki 'abecesel' karakterlerin tamamı küçük harfe çevrilmiş olarak dizge.

Evrenkod

Evrenkodun özellikleri hakkında daha fazla bilgi edinmek için » http://www.unicode.org/unicode/reports/tr21/ adresine bakınız.

strtolower() işlevinin tersine, 'abecesel' durum Evrenkodlu karakter özelliklerinden saptanır. Bu bakımdan bu işlevin davranışı yerel ayarlarından etkilenmez ve 'abecesel' özelliğe sahip her karakter (ü gibi) dönüştürülür.

Örnekler

Örnek 1 - mb_strtolower() örneği

<?php
$str = "PINAR'IN ÇOK SEVDİĞİ küçük BİR KUZUSU VAR.";
$str = mb_strtolower($str);
echo $str; // pinar'in çok sevdiği küçük bir kuzusu var.  basar
           // PHP 5.3.0alpha3-dev (cli) (built: Nov 13 2008 18:20:00)
?>

Ayrıca Bakınız

  • mb_strtoupper() - Dizgeyi büyük harfli yapar
  • mb_convert_case() - Bir dizgeye büyük-küçük harf dönüşümü uygular
  • strtolower() - Bir dizgenin harflerini küçük harfe çevirir

mb_strstr
mb_strtoupper
Çok baytlı Dizge İşlevleri


Dizgeyi büyük harfli yapar

mb_strtolower
mb_strwidth
Çok baytlı Dizge İşlevleri
PHP Manual

mb_strtoupper

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

mb_strtoupper — Dizgeyi büyük harfli yapar

Açıklama

string mb_strtoupper ( string $dizge [, string $kodlama = mb_internal_encoding() ] )

dizge içindeki 'abecesel' karakterlerin tamamını büyük harfe çevirir.

Değiştirgeler

dizge

Büyük harfli yapılacak dizge.

kodlama

kodlama değiştirgesinde karakter kodlaması belirtilir. Belirtilmediği takdirde dahili karakter kodlaması kullanılır.

Dönen Değerler

İçindeki 'abecesel' karakterlerin tamamı büyük harfe çevrilmiş olarak dizge.

Evrenkod

Evrenkodun özellikleri hakkında daha fazla bilgi edinmek için » http://www.unicode.org/unicode/reports/tr21/ adresine bakınız.

strtoupper() işlevinin tersine, 'abecesel' durum Evrenkodlu karakter özelliklerinden saptanır. Bu bakımdan bu işlevin davranışı yerel ayarlarından etkilenmez ve 'abecesel' özelliğe sahip her karakter (ü gibi) dönüştürülür.

Örnekler

Örnek 1 - mb_strtoupper() örneği

<?php
$str = "Şahizar'ın çok sevdiği küçük bir KUZUSU var.";
$str = mb_strtoupper($str);
echo $str; // ŞAHIZAR'IN ÇOK SEVDIĞI KÜÇÜK BIR KUZUSU VAR.  basar
           // PHP 5.3.0alpha3-dev (cli) (built: Nov 13 2008 18:20:00)
           // (ŞAHİZAR'IN ÇOK SEVDİĞİ KÜÇÜK BİR KUZUSU VAR. basması gerekirdi.)
?>

Ayrıca Bakınız

  • mb_strtolower() - Dizgeyi küçük harfli yapar
  • mb_convert_case() - Bir dizgeye büyük-küçük harf dönüşümü uygular
  • strtoupper() - Bir dizgenin harflerini büyük harfe çevirir

mb_strtolower
mb_strwidth
Çok baytlı Dizge İşlevleri


Dizge genişliğini döndürür

mb_strtoupper
mb_substitute_character
Çok baytlı Dizge İşlevleri
PHP Manual

mb_strwidth

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

mb_strwidth — Dizge genişliğini döndürür

Açıklama

int mb_strwidth ( string $dizge [, string $kodlama ] )

dizge dizgesinin genişliği ile döner.

Çok baytlı karakterler normalde tek baytlı karakterlerden iki misli daha geniştir.

Karakter Genişlikleri
Karakterler | Genişlik
U+0000 - U+0019 | 0
U+0020 - U+1FFF | 1
U+2000 - U+FF60 | 2
U+FF61 - U+FF9F | 1
U+FFA0 - | 2

Değiştirgeler

dizgi

Genişliği hesaplanacak dizge.

kodlama

kodlama değiştirgesinde karakter kodlaması belirtilir. Belirtilmediği takdirde dahili karakter kodlaması kullanılır.

Dönen Değerler

dizge dizgesinin genişliği.

Ayrıca Bakınız

  • mb_strimwidth() - Dizgeyi belirtilen genişlikte kırpar
  • mb_internal_encoding() - Dahili karakter kodlamasını tanımlar/döndürür

mb_strtoupper
mb_substitute_character
Çok baytlı Dizge İşlevleri


İkame karakteri atar/döndürür

mb_strwidth
mb_substr_count
Çok baytlı Dizge İşlevleri
PHP Manual

mb_substitute_character

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

mb_substitute_character — İkame karakteri atar/döndürür

Açıklama

mixed mb_substitute_character ([ mixed $ikamekrk ] )

Girdi karakter kodlaması geçersiz olduğunda veya bir karakter kodunun çıktı karakter kodlamasında mevcut olmadığı durumda geçersiz karakterin yerine kullanılacak karakteri belirtmek için kullanılır. Geçersiz karaktermerin yerine Bir NULL değer (çıktı yok), string veya integer (Evrenkodlu karakter) türünde bir değer belirtilebilir.

Bu ayarlamadan etkilenen işlevler: mb_convert_encoding(),
mb_convert_variables(),
mb_output_handler() ve mb_send_mail().

Değiştirgeler

ikamekrk

Bir integer olarak bir Evrenkod değeri veya bir string olarak aşağıdaki dizgelerden biri belirtilir:

  • "none": hiçbir şey çıktılanmaz
  • "long": Geçersiz karakterin kod değeri çıktılanır (Örnek: U+3000, JIS+7E7E)

Dönen Değerler

Eğer ikamekrk atanabilmişse TRUE, aksi takdirde FALSE döner. Eğer ikamekrk belirtilmemişse, geçerli ikame karakterinin Evrenkod değeriyle ya da "none" veya "long" değeriyle döner.

Örnekler

Örnek 1 - mb_substitute_character() örneği

<?php
/* Unicode U+3013 (GETA MARK) basılsın */
mb_substitute_character(0x3013);

/* Onaltılık biçeme ayarlayalım */
mb_substitute_character("long");

/* Geçerli ayarı göster */
echo mb_substitute_character();
?>

mb_strwidth
mb_substr_count
Çok baytlı Dizge İşlevleri


Mevcut alt dizgelerin sayısı ile döner

mb_substitute_character
mb_substr
Çok baytlı Dizge İşlevleri
PHP Manual

mb_substr_count

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

mb_substr_count — Mevcut alt dizgelerin sayısı ile döner

Açıklama

int mb_substr_count ( string $samanlık , string $iğne [, string $kodlama ] )

samanlık ile belirtilen dizge içinde iğne ile belirtilen dizgelerden kaç tane bulunduğu bilgisini verir.

Değiştirgeler

samanlık

İçinde arama yapılacak dizge.

needle

Aranacak dizge.

kodlama

kodlama değiştirgesinde karakter kodlaması belirtilir. Belirtilmediği takdirde dahili karakter kodlaması kullanılır.

Dönen Değerler

samanlık ile belirtilen dizge içinde iğne ile belirtilen dizgelerden kaç tane bulunduğu.

Örnekler

Örnek 1 - mb_substr_count() örneği

<?php
echo mb_substr_count("Bu da Buda bu da Buda.", "Bu"); // 3 basar
?>

Ayrıca Bakınız

  • mb_strpos() - Bir dizgenin içinde başka bir dizgeye ilk rastlanılan noktanın indisini döndürür
  • mb_substr() - Dizgenin bir alt dizgesini alır
  • substr_count() - Bir dizge içinde belli bir alt dizgeden kaç tane bulunduğunu bulur

mb_substitute_character
mb_substr
Çok baytlı Dizge İşlevleri


Dizgenin bir alt dizgesini alır

mb_substr_count
Pspell
Çok baytlı Dizge İşlevleri
PHP Manual

mb_substr

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

mb_substr — Dizgenin bir alt dizgesini alır

Açıklama

string mb_substr ( string $dizge , int $başlangıç [, int $uzunluk [, string $kodlama ]] )

Karakterler üzerinde güvenilir bir çok baytlı substr() işlemi gerçekleştirir. başlangıç konumuna dizge başlangıcından sayılarak erişilir. Belirtilen dizgenin ilk karakterinin indisinin 0 olduğu varsayılır.

Değiştirgeler

dizge

Alt dizge başlangıcının aranacağı dizge.

başlangıç

Alt dizgenin dizge içindeki başlangıç konumu.

uzunluk

İstenen alt dizgenin azami uzunluğu.

kodlama

kodlama değiştirgesinde karakter kodlaması belirtilir. Belirtilmediği takdirde dahili karakter kodlaması kullanılır.

Dönen Değerler

mb_substr() işlevi, yeri başlangıç ve uzunluk değiştirgeleri ile belirtilen dizge parçası ile döner.

Ayrıca Bakınız

  • mb_strcut() - Dizgenin başlangıcı ve uzunluğu belirtilen parçası ile döner
  • mb_internal_encoding() - Dahili karakter kodlamasını tanımlar/döndürür

mb_substr_count
Pspell
Çok baytlı Dizge İşlevleri


Pspell

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Pspell İşlevleri
    • pspell_add_to_personal — Add the word to a personal wordlist
    • pspell_add_to_session — Add the word to the wordlist in the current session
    • pspell_check — Check a word
    • pspell_clear_session — Clear the current session
    • pspell_config_create — Create a config used to open a dictionary
    • pspell_config_data_dir — location of language data files
    • pspell_config_dict_dir — Location of the main word list
    • pspell_config_ignore — Ignore words less than N characters long
    • pspell_config_mode — Change the mode number of suggestions returned
    • pspell_config_personal — Set a file that contains personal wordlist
    • pspell_config_repl — Set a file that contains replacement pairs
    • pspell_config_runtogether — Consider run-together words as valid compounds
    • pspell_config_save_repl — Determine whether to save a replacement pairs list along with the wordlist
    • pspell_new_config — Load a new dictionary with settings based on a given config
    • pspell_new_personal — Load a new dictionary with personal wordlist
    • pspell_new — Load a new dictionary
    • pspell_save_wordlist — Save the personal wordlist to a file
    • pspell_store_replacement — Store a replacement pair for a word
    • pspell_suggest — Suggest spellings of a word
mb_substr
Giriş
İnsan Dilleri ve Karakter Kodlaması Desteği


Giriş

These functions allow you to check the spelling of a word and offer suggestions.

Pspell
Yapılandırma/Kurulum
Pspell


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Pspell


Gereksinimler

To compile PHP with pspell support, you need the aspell library, available from » http://aspell.net/.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

If you have the libraries needed add the --with-pspell[=dir] option when compiling PHP.

Bilginize: Note to Win32 Users

Bu eklentinin çalışabilmesi için bazı DLL dosyalarının bulunduğu yerlerin Windows sistem PATH'ında tanımlı olması gerekir. Bunun nasıl yapılacağı SSS altında "PHP dizinimi Windows'ta PATH'a nasıl eklerim" başlığı altında açıklanmıştır. Eklenti, DLL dosyaları PHP dizininden Windows system dizinine taşındığında da çalışırsa da (çünkü system dizini sistem PATH'ında zaten vardır) bu önerilmez. Bu eklentinin çalışabilmesi için bulunduğu dizine PATH üzerinden erişilebilinmesi gereken dosyanın ismi: aspell-15.dll from the bin folder of the aspell installation.

Win32 support is available only in PHP 4.3.3 and later versions. Also, at least aspell version 0.50 is required.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

PSPELL_FAST (integer)
PSPELL_NORMAL (integer)
PSPELL_BAD_SPELLERS (integer)
PSPELL_RUN_TOGETHER (integer)
Özkaynak Türleri
Pspell İşlevleri
Pspell


Pspell İşlevleri

İçindekiler

  • pspell_add_to_personal — Add the word to a personal wordlist
  • pspell_add_to_session — Add the word to the wordlist in the current session
  • pspell_check — Check a word
  • pspell_clear_session — Clear the current session
  • pspell_config_create — Create a config used to open a dictionary
  • pspell_config_data_dir — location of language data files
  • pspell_config_dict_dir — Location of the main word list
  • pspell_config_ignore — Ignore words less than N characters long
  • pspell_config_mode — Change the mode number of suggestions returned
  • pspell_config_personal — Set a file that contains personal wordlist
  • pspell_config_repl — Set a file that contains replacement pairs
  • pspell_config_runtogether — Consider run-together words as valid compounds
  • pspell_config_save_repl — Determine whether to save a replacement pairs list along with the wordlist
  • pspell_new_config — Load a new dictionary with settings based on a given config
  • pspell_new_personal — Load a new dictionary with personal wordlist
  • pspell_new — Load a new dictionary
  • pspell_save_wordlist — Save the personal wordlist to a file
  • pspell_store_replacement — Store a replacement pair for a word
  • pspell_suggest — Suggest spellings of a word
Öntanımlı Sabitler
pspell_add_to_personal
Pspell


Add the word to a personal wordlist

Pspell İşlevleri
pspell_add_to_session
Pspell İşlevleri
PHP Manual

pspell_add_to_personal

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

pspell_add_to_personal — Add the word to a personal wordlist

Açıklama

bool pspell_add_to_personal ( int $dictionary_link , string $word )

pspell_add_to_personal() adds a word to the personal wordlist. If you used pspell_new_config() with pspell_config_personal() to open the dictionary, you can save the wordlist later with pspell_save_wordlist().

Değiştirgeler

dictionary_link

word

The added word.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 pspell_add_to_personal()

<?php
$pspell_config = pspell_config_create("en");
pspell_config_personal($pspell_config, "/var/dictionaries/custom.pws");
$pspell_link = pspell_new_config($pspell_config);

pspell_add_to_personal($pspell_link, "Vlad");
pspell_save_wordlist($pspell_link);
?>

Notlar

Bilginize:

This function will not work unless you have pspell .11.2 and aspell .32.5 or later.

Pspell İşlevleri
pspell_add_to_session
Pspell İşlevleri


Add the word to the wordlist in the current session

pspell_add_to_personal
pspell_check
Pspell İşlevleri
PHP Manual

pspell_add_to_session

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

pspell_add_to_session — Add the word to the wordlist in the current session

Açıklama

bool pspell_add_to_session ( int $dictionary_link , string $word )

pspell_add_to_session() adds a word to the wordlist associated with the current session. It is very similar to pspell_add_to_personal()

Değiştirgeler

dictionary_link

word

The added word.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

pspell_add_to_personal
pspell_check
Pspell İşlevleri


Check a word

pspell_add_to_session
pspell_clear_session
Pspell İşlevleri
PHP Manual

pspell_check

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

pspell_check — Check a word

Açıklama

bool pspell_check ( int $dictionary_link , string $word )

pspell_check() checks the spelling of a word.

Değiştirgeler

dictionary_link

word

The tested word.

Dönen Değerler

Returns TRUE if the spelling is correct, FALSE if not.

Örnekler

Örnek 1 pspell_check() Example

<?php
$pspell_link = pspell_new("en");

if (pspell_check($pspell_link, "testt")) {
    echo "This is a valid spelling";
} else {
    echo "Sorry, wrong spelling";
}
?>

pspell_add_to_session
pspell_clear_session
Pspell İşlevleri


Clear the current session

pspell_check
pspell_config_create
Pspell İşlevleri
PHP Manual

pspell_clear_session

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

pspell_clear_session — Clear the current session

Açıklama

bool pspell_clear_session ( int $dictionary_link )

pspell_clear_session() clears the current session. The current wordlist becomes blank, and, for example, if you try to save it with pspell_save_wordlist(), nothing happens.

Değiştirgeler

dictionary_link

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 pspell_add_to_personal() Example

<?php
$pspell_config = pspell_config_create("en");
pspell_config_personal($pspell_config, "/var/dictionaries/custom.pws");
$pspell_link = pspell_new_config($pspell_config);

pspell_add_to_personal($pspell_link, "Vlad");
pspell_clear_session($pspell_link);
pspell_save_wordlist($pspell_link);    //"Vlad" will not be saved
?>

pspell_check
pspell_config_create
Pspell İşlevleri


Create a config used to open a dictionary

pspell_clear_session
pspell_config_data_dir
Pspell İşlevleri
PHP Manual

pspell_config_create

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

pspell_config_create — Create a config used to open a dictionary

Açıklama

int pspell_config_create ( string $language [, string $spelling [, string $jargon [, string $encoding ]]] )

Create a config used to open a dictionary.

pspell_config_create() has a very similar syntax to pspell_new(). In fact, using pspell_config_create() immediately followed by pspell_new_config() will produce the exact same result. However, after creating a new config, you can also use pspell_config_*() functions before calling pspell_new_config() to take advantage of some advanced functionality.

For more information and examples, check out inline manual pspell website:» http://aspell.net/.

Değiştirgeler

language

The language parameter is the language code which consists of the two letter ISO 639 language code and an optional two letter ISO 3166 country code after a dash or underscore.

spelling

The spelling parameter is the requested spelling for languages with more than one spelling such as English. Known values are 'american', 'british', and 'canadian'.

jargon

The jargon parameter contains extra information to distinguish two different words lists that have the same language and spelling parameters.

encoding

The encoding parameter is the encoding that words are expected to be in. Valid values are 'utf-8', 'iso8859-*', 'koi8-r', 'viscii', 'cp1252', 'machine unsigned 16', 'machine unsigned 32'. This parameter is largely untested, so be careful when using.

Dönen Değerler

Retuns a pspell config identifier, or FALSE on error.

Örnekler

Örnek 1 pspell_config_create()

<?php
$pspell_config = pspell_config_create("en");
pspell_config_personal($pspell_config, "/var/dictionaries/custom.pws");
pspell_config_repl($pspell_config, "/var/dictionaries/custom.repl");
$pspell_link = pspell_new_personal($pspell_config, "en");
?>

pspell_clear_session
pspell_config_data_dir
Pspell İşlevleri


location of language data files

pspell_config_create
pspell_config_dict_dir
Pspell İşlevleri
PHP Manual

pspell_config_data_dir

(PHP 5, PHP 7)

pspell_config_data_dir — location of language data files

Açıklama

bool pspell_config_data_dir ( int $conf , string $directory )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

pspell_config_create
pspell_config_dict_dir
Pspell İşlevleri


Location of the main word list

pspell_config_data_dir
pspell_config_ignore
Pspell İşlevleri
PHP Manual

pspell_config_dict_dir

(PHP 5, PHP 7)

pspell_config_dict_dir — Location of the main word list

Açıklama

bool pspell_config_dict_dir ( int $conf , string $directory )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

pspell_config_data_dir
pspell_config_ignore
Pspell İşlevleri


Ignore words less than N characters long

pspell_config_dict_dir
pspell_config_mode
Pspell İşlevleri
PHP Manual

pspell_config_ignore

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

pspell_config_ignore — Ignore words less than N characters long

Açıklama

bool pspell_config_ignore ( int $dictionary_link , int $n )

pspell_config_ignore() should be used on a config before calling pspell_new_config(). This function allows short words to be skipped by the spell checker.

Değiştirgeler

dictionary_link

n

Words less than n characters will be skipped.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 pspell_config_ignore()

<?php
$pspell_config = pspell_config_create("en");
pspell_config_ignore($pspell_config, 5);
$pspell_link = pspell_new_config($pspell_config);
pspell_check($pspell_link, "abcd");    //will not result in an error
?>

pspell_config_dict_dir
pspell_config_mode
Pspell İşlevleri


Change the mode number of suggestions returned

pspell_config_ignore
pspell_config_personal
Pspell İşlevleri
PHP Manual

pspell_config_mode

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

pspell_config_mode — Change the mode number of suggestions returned

Açıklama

bool pspell_config_mode ( int $dictionary_link , int $mode )

pspell_config_mode() should be used on a config before calling pspell_new_config(). This function determines how many suggestions will be returned by pspell_suggest().

Değiştirgeler

dictionary_link

mode

The mode parameter is the mode in which spellchecker will work. There are several modes available:

  • PSPELL_FAST - Fast mode (least number of suggestions)
  • PSPELL_NORMAL - Normal mode (more suggestions)
  • PSPELL_BAD_SPELLERS - Slow mode (a lot of suggestions)

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 pspell_config_mode() Example

<?php
$pspell_config = pspell_config_create("en");
pspell_config_mode($pspell_config, PSPELL_FAST);
$pspell_link = pspell_new_config($pspell_config);
pspell_check($pspell_link, "thecat");
?>

pspell_config_ignore
pspell_config_personal
Pspell İşlevleri


Set a file that contains personal wordlist

pspell_config_mode
pspell_config_repl
Pspell İşlevleri
PHP Manual

pspell_config_personal

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

pspell_config_personal — Set a file that contains personal wordlist

Açıklama

bool pspell_config_personal ( int $dictionary_link , string $file )

Set a file that contains personal wordlist. The personal wordlist will be loaded and used in addition to the standard one after you call pspell_new_config(). The file is also the file where pspell_save_wordlist() will save personal wordlist to.

pspell_config_personal() should be used on a config before calling pspell_new_config().

Değiştirgeler

dictionary_link

file

The personal wordlist. If the file does not exist, it will be created. The file should be writable by whoever PHP runs as (e.g. nobody).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 pspell_config_personal()

<?php
$pspell_config = pspell_config_create("en");
pspell_config_personal($pspell_config, "/var/dictionaries/custom.pws");
$pspell_link = pspell_new_config($pspell_config);
pspell_check($pspell_link, "thecat");
?>

Notlar

Bilginize:

This function will not work unless you have pspell .11.2 and aspell .32.5 or later.

pspell_config_mode
pspell_config_repl
Pspell İşlevleri


Set a file that contains replacement pairs

pspell_config_personal
pspell_config_runtogether
Pspell İşlevleri
PHP Manual

pspell_config_repl

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

pspell_config_repl — Set a file that contains replacement pairs

Açıklama

bool pspell_config_repl ( int $dictionary_link , string $file )

Set a file that contains replacement pairs.

The replacement pairs improve the quality of the spellchecker. When a word is misspelled, and a proper suggestion was not found in the list, pspell_store_replacement() can be used to store a replacement pair and then pspell_save_wordlist() to save the wordlist along with the replacement pairs.

pspell_config_repl() should be used on a config before calling pspell_new_config().

Değiştirgeler

dictionary_link

file

The file should be writable by whoever PHP runs as (e.g. nobody).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 pspell_config_repl()

<?php
$pspell_config = pspell_config_create("en");
pspell_config_personal($pspell_config, "/var/dictionaries/custom.pws");
pspell_config_repl($pspell_config, "/var/dictionaries/custom.repl");
$pspell_link = pspell_new_config($pspell_config);
pspell_check($pspell_link, "thecat");
?>

Notlar

Bilginize:

This function will not work unless you have pspell .11.2 and aspell .32.5 or later.

pspell_config_personal
pspell_config_runtogether
Pspell İşlevleri


Consider run-together words as valid compounds

pspell_config_repl
pspell_config_save_repl
Pspell İşlevleri
PHP Manual

pspell_config_runtogether

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

pspell_config_runtogether — Consider run-together words as valid compounds

Açıklama

bool pspell_config_runtogether ( int $dictionary_link , bool $flag )

This function determines whether run-together words will be treated as legal compounds. That is, "thecat" will be a legal compound, although there should be a space between the two words. Changing this setting only affects the results returned by pspell_check(); pspell_suggest() will still return suggestions.

pspell_config_runtogether() should be used on a config before calling pspell_new_config().

Değiştirgeler

dictionary_link

flag

TRUE if run-together words should be treated as legal compounds, FALSE otherwise.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 pspell_config_runtogether()

<?php
$pspell_config = pspell_config_create("en");
pspell_config_runtogether($pspell_config, true);
$pspell_link = pspell_new_config($pspell_config);
pspell_check($pspell_link, "thecat");
?>

pspell_config_repl
pspell_config_save_repl
Pspell İşlevleri


Determine whether to save a replacement pairs list along with the wordlist

pspell_config_runtogether
pspell_new_config
Pspell İşlevleri
PHP Manual

pspell_config_save_repl

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

pspell_config_save_repl — Determine whether to save a replacement pairs list along with the wordlist

Açıklama

bool pspell_config_save_repl ( int $dictionary_link , bool $flag )

pspell_config_save_repl() determines whether pspell_save_wordlist() will save the replacement pairs along with the wordlist. Usually there is no need to use this function because if pspell_config_repl() is used, the replacement pairs will be saved by pspell_save_wordlist() anyway, and if it is not, the replacement pairs will not be saved.

pspell_config_save_repl() should be used on a config before calling pspell_new_config().

Değiştirgeler

dictionary_link

flag

TRUE if replacement pairs should be saved, FALSE otherwise.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

Bilginize:

This function will not work unless you have pspell .11.2 and aspell .32.5 or later.

pspell_config_runtogether
pspell_new_config
Pspell İşlevleri


Load a new dictionary with settings based on a given config

pspell_config_save_repl
pspell_new_personal
Pspell İşlevleri
PHP Manual

pspell_new_config

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

pspell_new_config — Load a new dictionary with settings based on a given config

Açıklama

int pspell_new_config ( int $config )

pspell_new_config() opens up a new dictionary with settings specified in a config, created with pspell_config_create() and modified with pspell_config_*() functions. This method provides you with the most flexibility and has all the functionality provided by pspell_new() and pspell_new_personal().

Değiştirgeler

config

The config parameter is the one returned by pspell_config_create() when the config was created.

Dönen Değerler

Returns a dictionary link identifier on success.

Örnekler

Örnek 1 pspell_new_config()

<?php
$pspell_config = pspell_config_create("en");
pspell_config_personal($pspell_config, "/var/dictionaries/custom.pws");
pspell_config_repl($pspell_config, "/var/dictionaries/custom.repl");
$pspell_link = pspell_new_config($pspell_config);
?>

pspell_config_save_repl
pspell_new_personal
Pspell İşlevleri


Load a new dictionary with personal wordlist

pspell_new_config
pspell_new
Pspell İşlevleri
PHP Manual

pspell_new_personal

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

pspell_new_personal — Load a new dictionary with personal wordlist

Açıklama

int pspell_new_personal ( string $personal , string $language [, string $spelling [, string $jargon [, string $encoding [, int $mode = 0 ]]]] )

pspell_new_personal() opens up a new dictionary with a personal wordlist. The wordlist can be modified and saved with pspell_save_wordlist(), if desired. However, the replacement pairs are not saved. In order to save replacement pairs, you should create a config using pspell_config_create(), set the personal wordlist file with pspell_config_personal(), set the file for replacement pairs with pspell_config_repl(), and open a new dictionary with pspell_new_config().

For more information and examples, check out inline manual pspell website:» http://aspell.net/.

Değiştirgeler

personal

The file where words added to the personal list will be stored. It should be an absolute filename beginning with '/' because otherwise it will be relative to $HOME, which is "/root" for most systems, and is probably not what you want.

language

The language code which consists of the two letter ISO 639 language code and an optional two letter ISO 3166 country code after a dash or underscore.

spelling

The requested spelling for languages with more than one spelling such as English. Known values are 'american', 'british', and 'canadian'.

jargon

Extra information to distinguish two different words lists that have the same language and spelling parameters.

encoding

The encoding that words are expected to be in. Valid values are utf-8, iso8859-*, koi8-r, viscii, cp1252, machine unsigned 16, machine unsigned 32.

mode

The mode in which spellchecker will work. There are several modes available:

  • PSPELL_FAST - Fast mode (least number of suggestions)
  • PSPELL_NORMAL - Normal mode (more suggestions)
  • PSPELL_BAD_SPELLERS - Slow mode (a lot of suggestions)
  • PSPELL_RUN_TOGETHER - Consider run-together words as legal compounds. That is, "thecat" will be a legal compound, although there should be a space between the two words. Changing this setting only affects the results returned by pspell_check(); pspell_suggest() will still return suggestions.
Mode is a bitmask constructed from different constants listed above. However, PSPELL_FAST, PSPELL_NORMAL and PSPELL_BAD_SPELLERS are mutually exclusive, so you should select only one of them.

Dönen Değerler

Returns the dictionary link identifier for use in other pspell functions.

Örnekler

Örnek 1 pspell_new_personal()

<?php
$pspell_link = pspell_new_personal ("/var/dictionaries/custom.pws",
        "en", "", "", "", PSPELL_FAST|PSPELL_RUN_TOGETHER);
?>

pspell_new_config
pspell_new
Pspell İşlevleri


Load a new dictionary

pspell_new_personal
pspell_save_wordlist
Pspell İşlevleri
PHP Manual

pspell_new

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

pspell_new — Load a new dictionary

Açıklama

int pspell_new ( string $language [, string $spelling [, string $jargon [, string $encoding [, int $mode = 0 ]]]] )

pspell_new() opens up a new dictionary and returns the dictionary link identifier for use in other pspell functions.

For more information and examples, check out inline manual pspell website:» http://aspell.net/.

Değiştirgeler

language

The language parameter is the language code which consists of the two letter ISO 639 language code and an optional two letter ISO 3166 country code after a dash or underscore.

spelling

The spelling parameter is the requested spelling for languages with more than one spelling such as English. Known values are 'american', 'british', and 'canadian'.

jargon

The jargon parameter contains extra information to distinguish two different words lists that have the same language and spelling parameters.

encoding

The encoding parameter is the encoding that words are expected to be in. Valid values are 'utf-8', 'iso8859-*', 'koi8-r', 'viscii', 'cp1252', 'machine unsigned 16', 'machine unsigned 32'. This parameter is largely untested, so be careful when using.

mode

The mode parameter is the mode in which spellchecker will work. There are several modes available:

  • PSPELL_FAST - Fast mode (least number of suggestions)
  • PSPELL_NORMAL - Normal mode (more suggestions)
  • PSPELL_BAD_SPELLERS - Slow mode (a lot of suggestions)
  • PSPELL_RUN_TOGETHER - Consider run-together words as legal compounds. That is, "thecat" will be a legal compound, although there should be a space between the two words. Changing this setting only affects the results returned by pspell_check(); pspell_suggest() will still return suggestions.
Mode is a bitmask constructed from different constants listed above. However, PSPELL_FAST, PSPELL_NORMAL and PSPELL_BAD_SPELLERS are mutually exclusive, so you should select only one of them.

Dönen Değerler

Returns the dictionary link identifier on success başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 pspell_new()

<?php
$pspell_link = pspell_new("en", "", "", "",
                           (PSPELL_FAST|PSPELL_RUN_TOGETHER));
?>

pspell_new_personal
pspell_save_wordlist
Pspell İşlevleri


Save the personal wordlist to a file

pspell_new
pspell_store_replacement
Pspell İşlevleri
PHP Manual

pspell_save_wordlist

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

pspell_save_wordlist — Save the personal wordlist to a file

Açıklama

bool pspell_save_wordlist ( int $dictionary_link )

pspell_save_wordlist() saves the personal wordlist from the current session. The location of files to be saved specified with pspell_config_personal() and (optionally) pspell_config_repl().

Değiştirgeler

dictionary_link

A dictionary link identifier opened with pspell_new_personal().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 pspell_add_to_personal()

<?php
$pspell_config = pspell_config_create("en");
pspell_config_personal($pspell_config, "/tmp/dicts/newdict");
$pspell_link = pspell_new_config($pspell_config);

pspell_add_to_personal($pspell_link, "Vlad");
pspell_save_wordlist($pspell_link);
?>

Notlar

Bilginize:

This function will not work unless you have pspell .11.2 and aspell .32.5 or later.

pspell_new
pspell_store_replacement
Pspell İşlevleri


Store a replacement pair for a word

pspell_save_wordlist
pspell_suggest
Pspell İşlevleri
PHP Manual

pspell_store_replacement

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

pspell_store_replacement — Store a replacement pair for a word

Açıklama

bool pspell_store_replacement ( int $dictionary_link , string $misspelled , string $correct )

pspell_store_replacement() stores a replacement pair for a word, so that replacement can be returned by pspell_suggest() later. In order to be able to take advantage of this function, you have to use pspell_new_personal() to open the dictionary. In order to permanently save the replacement pair, you have to use pspell_config_personal() and pspell_config_repl() to set the path where to save your custom wordlists, and then use pspell_save_wordlist() for the changes to be written to disk.

Değiştirgeler

dictionary_link

A dictionary link identifier, opened with pspell_new_personal()

misspelled

The misspelled word.

correct

The fixed spelling for the misspelled word.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 pspell_store_replacement()

<?php
$pspell_config = pspell_config_create("en");
pspell_config_personal($pspell_config, "/var/dictionaries/custom.pws");
pspell_config_repl($pspell_config, "/var/dictionaries/custom.repl");
$pspell_link = pspell_new_config($pspell_config);

pspell_store_replacement($pspell_link, $misspelled, $correct);
pspell_save_wordlist($pspell_link);
?>

Notlar

Bilginize:

This function will not work unless you have pspell .11.2 and aspell .32.5 or later.

pspell_save_wordlist
pspell_suggest
Pspell İşlevleri


Suggest spellings of a word

pspell_store_replacement
Recode
Pspell İşlevleri
PHP Manual

pspell_suggest

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

pspell_suggest — Suggest spellings of a word

Açıklama

array pspell_suggest ( int $dictionary_link , string $word )

pspell_suggest() returns an array of possible spellings for the given word.

Değiştirgeler

dictionary_link

word

The tested word.

Dönen Değerler

Returns an array of possible spellings.

Örnekler

Örnek 1 pspell_suggest() example

<?php
$pspell_link = pspell_new("en");

if (!pspell_check($pspell_link, "testt")) {
    $suggestions = pspell_suggest($pspell_link, "testt");

    foreach ($suggestions as $suggestion) {
        echo "Possible spelling: $suggestion<br />";
    }
}
?>

pspell_store_replacement
Recode
Pspell İşlevleri


GNU Recode

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Recode İşlevleri
    • recode_file — Dosyadan dosyaya karakter kodlaması dönüşümü yapar
    • recode_string — Yapılan isteğe bağlı olarak bir dizgeyi yeniden kodlar
    • recode — recode_string işlevinin takma adıdır
pspell_suggest
Giriş
İnsan Dilleri ve Karakter Kodlaması Desteği


Giriş

Bu modül, GNU Recode kütüphanesine bir arayüz içerir. GNU Recode kütüphanesi çeşitli karakter kümeleriyle kodlanmış dosyalar arasında kodlama dönüşümü yapar. Bunu tam olarak sağlayamazsa hatalı karakterlerden kurtulabilir veya bazı yaklaşımlar yapabilir. Kütüphane yaklaşık 150 farklı karakter kümesini tanır ve bunların çiftleri arasında dosya dönüşümü yapabilir. » RFC 1345'te tanımlı karakter kümelerinin çoğu desteklenmektedir.

Bilginize: Bu eklenti Windows sistemlerinde çalışmaz.

Recode
Yapılandırma/Kurulum
Recode


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Recode


Gereksinimler

Sisteminizde GNU Recode 3.5 veya üstü bir sürümün kurulu olması gerekir. Paketi » http://directory.fsf.org/All_GNU_Packages/recode.html adresinden temin edebilirsiniz..

Uyarı

Recode kütüphanesinin 3.6 sürümü bazı durumlarda dönüştürülen karakterlerin ardına tuhaf karakterler eklemektedir. Bu bakımdan Recode kütüphanesinin 3.5 sürümünü veya taydaşları olduğu iconv veya mbstring eklentisini kullanmak tercih edilmelidir.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu modülde tanımlanmış işlevleri kullanıbilmek için PHP'yi --with-recode[=DiZiN] yapılandırma seçeneğiyle derlemelisiniz.

Uyarı

mysql veya imap eklentilerinden birini yükledikten sonra recode'u bir eklenti olarak yüklerseniz PHP'de çökme ve başlatma sorunları baş gösterebilir. Recode eklentisini bu eklentilerden önce yükleyerek bu sorunları engelleyebilirsiniz. Bu sorunun sebebi tamamen tekniktir; imap ve recode tarafından kullanılan her iki C istemci kütüphanesinin de kendi hash_lookup() işlevleri vardır, mysql ve recode'un ise kendi hash_insert işlevleri vardır.

Uyarı

IMAP, recode, YAZ ve Cyrus eklentileri, aynı dahili simgeleri paylaştıklarından birlikte kullanılamazlar. Bilgi: Yaz 2.0 ve sonrası bu sorundan etkilenmemektedir.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
Recode İşlevleri
Recode


Recode İşlevleri

İçindekiler

  • recode_file — Dosyadan dosyaya karakter kodlaması dönüşümü yapar
  • recode_string — Yapılan isteğe bağlı olarak bir dizgeyi yeniden kodlar
  • recode — recode_string işlevinin takma adıdır
Öntanımlı Sabitler
recode_file
Recode


Dosyadan dosyaya karakter kodlaması dönüşümü yapar

Recode İşlevleri
recode_string
Recode İşlevleri
PHP Manual

recode_file

(PHP 4, PHP 5, PHP 7)

recode_file — Dosyadan dosyaya karakter kodlaması dönüşümü yapar

Açıklama

bool recode_file ( string $istek , resource $girdi , resource $çıktı )

Belirtilen isteğe bağlı olarak dosya tanıtıcısı girdi ile belirtilen dosyayı dosya tanıtıcısı çıktı ile belirtilen dosyaya yeniden kodlar.

Değiştirgeler

istek

Yeniden kodlama isteği türü.

girdi

Girdi olarak bir yerel dosya tanıtıcısı.

çıktı

Çıktı olarak bir yerel dosya tanıtıcısı.

Dönen Değerler

İşlemi başaramazsa FALSE, aksi takdirde TRUE döner.

Örnekler

Örnek 1 - Basit bir recode_file() örneği

<?php
$input = fopen('girdi.txt', 'r');
$output = fopen('çıktı.txt', 'w');
recode_file("ISO-8859-9..UTF-8", $input, $output);
?>

Notlar

Bu işlev henüz uzak dosyaların (URL) dosya tanıtıcıları ile çalışmamaktadır. Her iki dosya tanıtıcı da yerel olmak zorundadır.

Ayrıca Bakınız

  • fopen() - Bir dosya veya URL'yi açar

Recode İşlevleri
recode_string
Recode İşlevleri


Yapılan isteğe bağlı olarak bir dizgeyi yeniden kodlar

recode_file
recode
Recode İşlevleri
PHP Manual

recode_string

(PHP 4, PHP 5, PHP 7)

recode_string — Yapılan isteğe bağlı olarak bir dizgeyi yeniden kodlar

Açıklama

string recode_string ( string $istek , string $dizge )

Yapılan istek isteğine bağlı olarak bir dizge'yi yeniden kodlar.

Değiştirgeler

istek

Yeniden kodlama isteği türü.

dizge

Yeniden kodlanacak dizge.

Dönen Değerler

İşlemi başaramazsa FALSE, aksi takdirde yeniden kodlanan dizge ile döner.

Örnekler

Örnek 1 - Basit bir recode_string() örneği

<?php
echo recode_string("us..flat", "The following character has a diacritical mark: á");
?>

Notlar

Basit bir recode isteği de "ISO-8859-9..utf-8" olabilir.

Ayrıca Bakınız

  • Recode istekleri ile ilgili ayrıntılı bilgi için GNU Recode belgelerine bakınız.

recode_file
recode
Recode İşlevleri


recode_string işlevinin takma adıdır

recode_string
Resim İşleme ve Resim Üretimi
Recode İşlevleri
PHP Manual

recode

(PHP 4, PHP 5, PHP 7)

recode — recode_string() işlevinin takma adıdır

Açıklama

Bu işlev, recode_string() işlevinin takma adıdır.

recode_string
Resim İşleme ve Resim Üretimi
Recode İşlevleri


Resim İşleme ve Resim Üretimi

  • Cairo
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • Cairo İşlevleri
    • Cairo — The Cairo class
    • CairoContext — The CairoContext class
    • CairoException — The CairoException class
    • CairoStatus — The CairoStatus class
    • CairoSurface — The CairoSurface class
    • CairoSvgSurface — Svg Surface Backend
    • CairoImageSurface — The CairoImageSurface class
    • CairoPdfSurface — The CairoPdfSurface class
    • CairoPsSurface — The CairoPsSurface class
    • CairoSurfaceType — The CairoSurfaceType class
    • CairoFontFace — The CairoFontFace class
    • CairoFontOptions — The CairoFontOptions class
    • CairoFontSlant — The CairoFontSlant class
    • CairoFontType — The CairoFontType class
    • CairoFontWeight — The CairoFontWeight class
    • CairoScaledFont — The CairoScaledFont class
    • CairoToyFontFace — The CairoToyFontFace class
    • CairoPatternType — The CairoPatternType class
    • CairoPattern — The CairoPattern class
    • CairoGradientPattern — The CairoGradientPattern class
    • CairoSolidPattern — The CairoSolidPattern class
    • CairoSurfacePattern — The CairoSurfacePattern class
    • CairoLinearGradient — The CairoLinearGradient class
    • CairoRadialGradient — The CairoRadialGradient class
    • CairoAntialias — The CairoAntialias class
    • CairoContent — The CairoContent class
    • CairoExtend — The CairoExtend class
    • CairoFormat — The CairoFormat class
    • CairoFillRule — The CairoFillRule class
    • CairoFilter — The CairoFilter class
    • CairoHintMetrics — The CairoHintMetrics class
    • CairoHintStyle — The CairoHintStyle class
    • CairoLineCap — The CairoLineCap class
    • CairoLineJoin — The CairoLineJoin class
    • CairoMatrix — The CairoMatrix class
    • CairoOperator — The CairoOperator class
    • CairoPath — The CairoPath class
    • CairoPsLevel — The CairoPsLevel class
    • CairoSubpixelOrder — The CairoSubpixelOrder class
    • CairoSvgVersion — The CairoSvgVersion class
  • Exif — Değiş Tokuş Edilebilir Resim Bilgileri
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Exif İşlevleri
  • GD — Resim İşleme ve GD
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • GD ve Resim İşlevleri
  • Gmagick
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • Gmagick — The Gmagick class
    • GmagickDraw — The GmagickDraw class
    • GmagickPixel — The GmagickPixel class
  • ImageMagick — Resim İşleme (ImageMagick)
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • Imagick sınıfı
    • ImagickDraw sınıfı
    • ImagickPixel sınıfı
    • ImagickPixelIterator sınıfı
recode
Cairo
İşlev Başvuru Kılavuzu


Cairo

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
  • Cairo İşlevleri
    • cairo_create — Returns a new CairoContext object on the requested surface.
    • cairo_font_face_get_type — Description
    • cairo_font_face_status — Description
    • cairo_font_options_create — Description
    • cairo_font_options_equal — Description
    • cairo_font_options_get_antialias — Description
    • cairo_font_options_get_hint_metrics — Description
    • cairo_font_options_get_hint_style — Description
    • cairo_font_options_get_subpixel_order — Description
    • cairo_font_options_hash — Description
    • cairo_font_options_merge — Description
    • cairo_font_options_set_antialias — Description
    • cairo_font_options_set_hint_metrics — Description
    • cairo_font_options_set_hint_style — Description
    • cairo_font_options_set_subpixel_order — Description
    • cairo_font_options_status — Description
    • cairo_format_stride_for_width — Description
    • cairo_image_surface_create_for_data — Description
    • cairo_image_surface_create_from_png — Description
    • cairo_image_surface_create — Description
    • cairo_image_surface_get_data — Description
    • cairo_image_surface_get_format — Description
    • cairo_image_surface_get_height — Description
    • cairo_image_surface_get_stride — Description
    • cairo_image_surface_get_width — Description
    • cairo_matrix_create_scale — Takma Adı: CairoMatrix::initScale
    • cairo_matrix_create_translate — Takma Adı: CairoMatrix::initTranslate
    • cairo_matrix_invert — Description
    • cairo_matrix_multiply — Description
    • cairo_matrix_rotate — Description
    • cairo_matrix_transform_distance — Description
    • cairo_matrix_transform_point — Description
    • cairo_matrix_translate — Description
    • cairo_pattern_add_color_stop_rgb — Description
    • cairo_pattern_add_color_stop_rgba — Description
    • cairo_pattern_create_for_surface — Description
    • cairo_pattern_create_linear — Description
    • cairo_pattern_create_radial — Description
    • cairo_pattern_create_rgb — Description
    • cairo_pattern_create_rgba — Description
    • cairo_pattern_get_color_stop_count — Description
    • cairo_pattern_get_color_stop_rgba — Description
    • cairo_pattern_get_extend — Description
    • cairo_pattern_get_filter — Description
    • cairo_pattern_get_linear_points — Description
    • cairo_pattern_get_matrix — Description
    • cairo_pattern_get_radial_circles — Description
    • cairo_pattern_get_rgba — Description
    • cairo_pattern_get_surface — Description
    • cairo_pattern_get_type — Description
    • cairo_pattern_set_extend — Description
    • cairo_pattern_set_filter — Description
    • cairo_pattern_set_matrix — Description
    • cairo_pattern_status — Description
    • cairo_pdf_surface_create — Description
    • cairo_pdf_surface_set_size — Description
    • cairo_ps_get_levels — Description
    • cairo_ps_level_to_string — Description
    • cairo_ps_surface_create — Description
    • cairo_ps_surface_dsc_begin_page_setup — Description
    • cairo_ps_surface_dsc_begin_setup — Description
    • cairo_ps_surface_dsc_comment — Description
    • cairo_ps_surface_get_eps — Description
    • cairo_ps_surface_restrict_to_level — Description
    • cairo_ps_surface_set_eps — Description
    • cairo_ps_surface_set_size — Description
    • cairo_scaled_font_create — Description
    • cairo_scaled_font_extents — Description
    • cairo_scaled_font_get_ctm — Description
    • cairo_scaled_font_get_font_face — Description
    • cairo_scaled_font_get_font_matrix — Description
    • cairo_scaled_font_get_font_options — Description
    • cairo_scaled_font_get_scale_matrix — Description
    • cairo_scaled_font_get_type — Description
    • cairo_scaled_font_glyph_extents — Description
    • cairo_scaled_font_status — Description
    • cairo_scaled_font_text_extents — Description
    • cairo_surface_copy_page — Description
    • cairo_surface_create_similar — Description
    • cairo_surface_finish — Description
    • cairo_surface_flush — Description
    • cairo_surface_get_content — Description
    • cairo_surface_get_device_offset — Description
    • cairo_surface_get_font_options — Description
    • cairo_surface_get_type — Description
    • cairo_surface_mark_dirty_rectangle — Description
    • cairo_surface_mark_dirty — Description
    • cairo_surface_set_device_offset — Description
    • cairo_surface_set_fallback_resolution — Description
    • cairo_surface_show_page — Description
    • cairo_surface_status — Description
    • cairo_surface_write_to_png — Description
    • cairo_svg_surface_create — Description
    • cairo_svg_surface_restrict_to_version — Description
    • cairo_svg_version_to_string — Description
  • Cairo — The Cairo class
    • Cairo::availableFonts — Retrieves the availables font types
    • Cairo::availableSurfaces — Retrieves all available surfaces
    • Cairo::statusToString — Retrieves the current status as string
    • Cairo::version — Retrives cairo's library version
    • Cairo::versionString — Retrieves cairo version as string
  • CairoContext — The CairoContext class
    • CairoContext::appendPath — Appends a path to current path
    • CairoContext::arc — Adds a circular arc
    • CairoContext::arcNegative — Adds a negative arc
    • CairoContext::clip — Establishes a new clip region
    • CairoContext::clipExtents — Computes the area inside the current clip
    • CairoContext::clipPreserve — Establishes a new clip region from the current clip
    • CairoContext::clipRectangleList — Retrieves the current clip as a list of rectangles
    • CairoContext::closePath — Closes the current path
    • CairoContext::__construct — Creates a new CairoContext
    • CairoContext::copyPage — Emits the current page
    • CairoContext::copyPath — Creates a copy of the current path
    • CairoContext::copyPathFlat — Gets a flattened copy of the current path
    • CairoContext::curveTo — Adds a curve
    • CairoContext::deviceToUser — Transform a coordinate
    • CairoContext::deviceToUserDistance — Transform a distance
    • CairoContext::fill — Fills the current path
    • CairoContext::fillExtents — Computes the filled area
    • CairoContext::fillPreserve — Fills and preserve the current path
    • CairoContext::fontExtents — Get the font extents
    • CairoContext::getAntialias — Retrives the current antialias mode
    • CairoContext::getCurrentPoint — The getCurrentPoint purpose
    • CairoContext::getDash — The getDash purpose
    • CairoContext::getDashCount — The getDashCount purpose
    • CairoContext::getFillRule — The getFillRule purpose
    • CairoContext::getFontFace — The getFontFace purpose
    • CairoContext::getFontMatrix — The getFontMatrix purpose
    • CairoContext::getFontOptions — The getFontOptions purpose
    • CairoContext::getGroupTarget — The getGroupTarget purpose
    • CairoContext::getLineCap — The getLineCap purpose
    • CairoContext::getLineJoin — The getLineJoin purpose
    • CairoContext::getLineWidth — The getLineWidth purpose
    • CairoContext::getMatrix — The getMatrix purpose
    • CairoContext::getMiterLimit — The getMiterLimit purpose
    • CairoContext::getOperator — The getOperator purpose
    • CairoContext::getScaledFont — The getScaledFont purpose
    • CairoContext::getSource — The getSource purpose
    • CairoContext::getTarget — The getTarget purpose
    • CairoContext::getTolerance — The getTolerance purpose
    • CairoContext::glyphPath — The glyphPath purpose
    • CairoContext::hasCurrentPoint — The hasCurrentPoint purpose
    • CairoContext::identityMatrix — The identityMatrix purpose
    • CairoContext::inFill — The inFill purpose
    • CairoContext::inStroke — The inStroke purpose
    • CairoContext::lineTo — The lineTo purpose
    • CairoContext::mask — The mask purpose
    • CairoContext::maskSurface — The maskSurface purpose
    • CairoContext::moveTo — The moveTo purpose
    • CairoContext::newPath — The newPath purpose
    • CairoContext::newSubPath — The newSubPath purpose
    • CairoContext::paint — The paint purpose
    • CairoContext::paintWithAlpha — The paintWithAlpha purpose
    • CairoContext::pathExtents — The pathExtents purpose
    • CairoContext::popGroup — The popGroup purpose
    • CairoContext::popGroupToSource — The popGroupToSource purpose
    • CairoContext::pushGroup — The pushGroup purpose
    • CairoContext::pushGroupWithContent — The pushGroupWithContent purpose
    • CairoContext::rectangle — The rectangle purpose
    • CairoContext::relCurveTo — The relCurveTo purpose
    • CairoContext::relLineTo — The relLineTo purpose
    • CairoContext::relMoveTo — The relMoveTo purpose
    • CairoContext::resetClip — The resetClip purpose
    • CairoContext::restore — The restore purpose
    • CairoContext::rotate — The rotate purpose
    • CairoContext::save — The save purpose
    • CairoContext::scale — The scale purpose
    • CairoContext::selectFontFace — The selectFontFace purpose
    • CairoContext::setAntialias — The setAntialias purpose
    • CairoContext::setDash — The setDash purpose
    • CairoContext::setFillRule — The setFillRule purpose
    • CairoContext::setFontFace — The setFontFace purpose
    • CairoContext::setFontMatrix — The setFontMatrix purpose
    • CairoContext::setFontOptions — The setFontOptions purpose
    • CairoContext::setFontSize — The setFontSize purpose
    • CairoContext::setLineCap — The setLineCap purpose
    • CairoContext::setLineJoin — The setLineJoin purpose
    • CairoContext::setLineWidth — The setLineWidth purpose
    • CairoContext::setMatrix — The setMatrix purpose
    • CairoContext::setMiterLimit — The setMiterLimit purpose
    • CairoContext::setOperator — The setOperator purpose
    • CairoContext::setScaledFont — The setScaledFont purpose
    • CairoContext::setSource — The setSource purpose
    • CairoContext::setSourceRGB — The setSourceRGB purpose
    • CairoContext::setSourceRGBA — The setSourceRGBA purpose
    • CairoContext::setSourceSurface — The setSourceSurface purpose
    • CairoContext::setTolerance — The setTolerance purpose
    • CairoContext::showPage — The showPage purpose
    • CairoContext::showText — The showText purpose
    • CairoContext::status — The status purpose
    • CairoContext::stroke — The stroke purpose
    • CairoContext::strokeExtents — The strokeExtents purpose
    • CairoContext::strokePreserve — The strokePreserve purpose
    • CairoContext::textExtents — The textExtents purpose
    • CairoContext::textPath — The textPath purpose
    • CairoContext::transform — The transform purpose
    • CairoContext::translate — The translate purpose
    • CairoContext::userToDevice — The userToDevice purpose
    • CairoContext::userToDeviceDistance — The userToDeviceDistance purpose
  • CairoException — The CairoException class
  • CairoStatus — The CairoStatus class
  • CairoSurface — The CairoSurface class
    • CairoSurface::__construct — The __construct purpose
    • CairoSurface::copyPage — The copyPage purpose
    • CairoSurface::createSimilar — The createSimilar purpose
    • CairoSurface::finish — The finish purpose
    • CairoSurface::flush — The flush purpose
    • CairoSurface::getContent — The getContent purpose
    • CairoSurface::getDeviceOffset — The getDeviceOffset purpose
    • CairoSurface::getFontOptions — The getFontOptions purpose
    • CairoSurface::getType — The getType purpose
    • CairoSurface::markDirty — The markDirty purpose
    • CairoSurface::markDirtyRectangle — The markDirtyRectangle purpose
    • CairoSurface::setDeviceOffset — The setDeviceOffset purpose
    • CairoSurface::setFallbackResolution — The setFallbackResolution purpose
    • CairoSurface::showPage — The showPage purpose
    • CairoSurface::status — The status purpose
    • CairoSurface::writeToPng — The writeToPng purpose
  • CairoSvgSurface — Svg Surface Backend
    • CairoSvgSurface::__construct — The __construct purpose
    • CairoSvgSurface::getVersions — Used to retrieve a list of supported SVG versions
    • CairoSvgSurface::restrictToVersion — The restrictToVersion purpose
    • CairoSvgSurface::versionToString — The versionToString purpose
  • CairoImageSurface — The CairoImageSurface class
    • CairoImageSurface::__construct — Creates a new CairoImageSurface
    • CairoImageSurface::createForData — The createForData purpose
    • CairoImageSurface::createFromPng — Creates a new CairoImageSurface form a png image file
    • CairoImageSurface::getData — Gets the image data as string
    • CairoImageSurface::getFormat — Get the image format
    • CairoImageSurface::getHeight — Retrieves the height of the CairoImageSurface
    • CairoImageSurface::getStride — The getStride purpose
    • CairoImageSurface::getWidth — Retrieves the width of the CairoImageSurface
  • CairoPdfSurface — The CairoPdfSurface class
    • CairoPdfSurface::__construct — The __construct purpose
    • CairoPdfSurface::setSize — The setSize purpose
  • CairoPsSurface — The CairoPsSurface class
    • CairoPsSurface::__construct — The __construct purpose
    • CairoPsSurface::dscBeginPageSetup — The dscBeginPageSetup purpose
    • CairoPsSurface::dscBeginSetup — The dscBeginSetup purpose
    • CairoPsSurface::dscComment — The dscComment purpose
    • CairoPsSurface::getEps — The getEps purpose
    • CairoPsSurface::getLevels — The getLevels purpose
    • CairoPsSurface::levelToString — The levelToString purpose
    • CairoPsSurface::restrictToLevel — The restrictToLevel purpose
    • CairoPsSurface::setEps — The setEps purpose
    • CairoPsSurface::setSize — The setSize purpose
  • CairoSurfaceType — The CairoSurfaceType class
  • CairoFontFace — The CairoFontFace class
    • CairoFontFace::__construct — Creates a new CairoFontFace object
    • CairoFontFace::getType — Retrieves the font face type
    • CairoFontFace::status — Check for CairoFontFace errors
  • CairoFontOptions — The CairoFontOptions class
    • CairoFontOptions::__construct — The __construct purpose
    • CairoFontOptions::equal — The equal purpose
    • CairoFontOptions::getAntialias — The getAntialias purpose
    • CairoFontOptions::getHintMetrics — The getHintMetrics purpose
    • CairoFontOptions::getHintStyle — The getHintStyle purpose
    • CairoFontOptions::getSubpixelOrder — The getSubpixelOrder purpose
    • CairoFontOptions::hash — The hash purpose
    • CairoFontOptions::merge — The merge purpose
    • CairoFontOptions::setAntialias — The setAntialias purpose
    • CairoFontOptions::setHintMetrics — The setHintMetrics purpose
    • CairoFontOptions::setHintStyle — The setHintStyle purpose
    • CairoFontOptions::setSubpixelOrder — The setSubpixelOrder purpose
    • CairoFontOptions::status — The status purpose
  • CairoFontSlant — The CairoFontSlant class
  • CairoFontType — The CairoFontType class
  • CairoFontWeight — The CairoFontWeight class
  • CairoScaledFont — The CairoScaledFont class
    • CairoScaledFont::__construct — The __construct purpose
    • CairoScaledFont::extents — The extents purpose
    • CairoScaledFont::getCtm — The getCtm purpose
    • CairoScaledFont::getFontFace — The getFontFace purpose
    • CairoScaledFont::getFontMatrix — The getFontMatrix purpose
    • CairoScaledFont::getFontOptions — The getFontOptions purpose
    • CairoScaledFont::getScaleMatrix — The getScaleMatrix purpose
    • CairoScaledFont::getType — The getType purpose
    • CairoScaledFont::glyphExtents — The glyphExtents purpose
    • CairoScaledFont::status — The status purpose
    • CairoScaledFont::textExtents — The textExtents purpose
  • CairoToyFontFace — The CairoToyFontFace class
  • CairoPatternType — The CairoPatternType class
  • CairoPattern — The CairoPattern class
    • CairoPattern::__construct — The __construct purpose
    • CairoPattern::getMatrix — The getMatrix purpose
    • CairoPattern::getType — The getType purpose
    • CairoPattern::setMatrix — The setMatrix purpose
    • CairoPattern::status — The status purpose
  • CairoGradientPattern — The CairoGradientPattern class
    • CairoGradientPattern::addColorStopRgb — The addColorStopRgb purpose
    • CairoGradientPattern::addColorStopRgba — The addColorStopRgba purpose
    • CairoGradientPattern::getColorStopCount — The getColorStopCount purpose
    • CairoGradientPattern::getColorStopRgba — The getColorStopRgba purpose
    • CairoGradientPattern::getExtend — The getExtend purpose
    • CairoGradientPattern::setExtend — The setExtend purpose
  • CairoSolidPattern — The CairoSolidPattern class
    • CairoSolidPattern::__construct — The __construct purpose
    • CairoSolidPattern::getRgba — The getRgba purpose
  • CairoSurfacePattern — The CairoSurfacePattern class
    • CairoSurfacePattern::__construct — The __construct purpose
    • CairoSurfacePattern::getExtend — The getExtend purpose
    • CairoSurfacePattern::getFilter — The getFilter purpose
    • CairoSurfacePattern::getSurface — The getSurface purpose
    • CairoSurfacePattern::setExtend — The setExtend purpose
    • CairoSurfacePattern::setFilter — The setFilter purpose
  • CairoLinearGradient — The CairoLinearGradient class
    • CairoLinearGradient::__construct — The __construct purpose
    • CairoLinearGradient::getPoints — The getPoints purpose
  • CairoRadialGradient — The CairoRadialGradient class
    • CairoRadialGradient::__construct — The __construct purpose
    • CairoRadialGradient::getCircles — The getCircles purpose
  • CairoAntialias — The CairoAntialias class
  • CairoContent — The CairoContent class
  • CairoExtend — The CairoExtend class
  • CairoFormat — The CairoFormat class
    • CairoFormat::strideForWidth — Provides an appropiate stride to use
  • CairoFillRule — The CairoFillRule class
  • CairoFilter — The CairoFilter class
  • CairoHintMetrics — The CairoHintMetrics class
  • CairoHintStyle — The CairoHintStyle class
  • CairoLineCap — The CairoLineCap class
  • CairoLineJoin — The CairoLineJoin class
  • CairoMatrix — The CairoMatrix class
    • CairoMatrix::__construct — Creates a new CairoMatrix object
    • CairoMatrix::initIdentity — Creates a new identity matrix
    • CairoMatrix::initRotate — Creates a new rotated matrix
    • CairoMatrix::initScale — Creates a new scaling matrix
    • CairoMatrix::initTranslate — Creates a new translation matrix
    • CairoMatrix::invert — The invert purpose
    • CairoMatrix::multiply — The multiply purpose
    • CairoMatrix::rotate — The rotate purpose
    • CairoMatrix::scale — Applies scaling to a matrix
    • CairoMatrix::transformDistance — The transformDistance purpose
    • CairoMatrix::transformPoint — The transformPoint purpose
    • CairoMatrix::translate — The translate purpose
  • CairoOperator — The CairoOperator class
  • CairoPath — The CairoPath class
  • CairoPsLevel — The CairoPsLevel class
  • CairoSubpixelOrder — The CairoSubpixelOrder class
  • CairoSvgVersion — The CairoSvgVersion class
Resim İşleme ve Resim Üretimi
Giriş
Resim İşleme ve Resim Üretimi


Giriş

Cairo is a native PHP extension to create and modify graphics using the Cairo Graphics Library.

The Cairo Graphics Library is a 2D library written in C with support for multiple output devices. Currently supported output targets include the X Window System, Quartz, Win32, image buffers, PostScript, PDF, and SVG file output. Experimental backends include OpenGL (through glitz), XCB, BeOS, OS/2, and DirectFB. The library also has support for two types of text manipulation and layout. The "toy" API provides demo quality support, and the glyphs API, although full-featured, works best with a helper library such as pango. Font backend support includes FreeType, Quartz, Win32, and User fonts.

There are two types of computer graphics, vector and raster. Raster graphics are the representation of images as an array of pixels. Vector graphics use geometrical primitives such as points, lines, curves or polygons to represent images. The primitives are created using mathematical equations. The Cairo Graphics Library takes a vector approach to graphics, allowing smaller size, infinite zooming, and moving, scaling and rotating without degrading image quality.

Operations in the cairo graphics library including stroking and filling cubic Bézier splines, transforming and compositing translucent images, and antialiased text rendering. All drawing operations can be transformed by any affine transformation (scale, rotation, shear, and others) This is very similiar to drawing operations for PostScript and PDF drawing.

The Cairo PHP Extension aims to provide support for all officially supported font backends and surface backends, as well as expose all available functionality in cairo to PHP users.

Cairo
Yapılandırma/Kurulum
Cairo


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Cairo


Gereksinimler

Cairo is only available for PHP 5.2+ and PHP 5.3+ The extension also requires the cairo graphics library version 1.4 or higher. The cairo graphics library uses an even and odd numbering scheme to denote stable and unstable library versions. Both unstable and stable versions can be used with the extension, but conditional support for new features is determined by the stable version below the unstable version in use. The latest cairo release can be found at » http://cairographics.org/.

The binary files used for the windows compiles can be found at » http://cairographics.org/download/ along with the project files used to create them.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/cairo.

Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız.

Notes specific to installation on Windows

Binary builds of the extension can be found at » http://cairographics.org/download/. Download the correct zip file, place php_cairo.dll in the extensions directory, and enable it via the php.ini file in use. Please be sure the PHP minor version (5.2, 5.3) match, the thread safety (Thread Safe TS or Non-Thread Safe NTS), the architecture (x86 or x64), and the compiler version (VC6 or VC9) match or the extension will not load.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

CAIRO_STATUS_SUCCESS (integer)
CAIRO_STATUS_NO_MEMORY (integer)
CAIRO_STATUS_INVALID_RESTORE (integer)
CAIRO_STATUS_INVALID_POP_GROUP (integer)
CAIRO_STATUS_NO_CURRENT_POINT (integer)
CAIRO_STATUS_INVALID_MATRIX (integer)
CAIRO_STATUS_INVALID_STATUS (integer)
CAIRO_STATUS_NULL_POINTER (integer)
CAIRO_STATUS_INVALID_STRING (integer)
CAIRO_STATUS_INVALID_PATH_DATA (integer)
CAIRO_STATUS_READ_ERROR (integer)
CAIRO_STATUS_WRITE_ERROR (integer)
CAIRO_STATUS_SURFACE_FINISHED (integer)
CAIRO_STATUS_SURFACE_TYPE_MISMATCH (integer)
CAIRO_STATUS_PATTERN_TYPE_MISMATCH (integer)
CAIRO_STATUS_INVALID_CONTENT (integer)
CAIRO_STATUS_INVALID_FORMAT (integer)
CAIRO_STATUS_INVALID_VISUAL (integer)
CAIRO_STATUS_FILE_NOT_FOUND (integer)
CAIRO_STATUS_INVALID_DASH (integer)
CAIRO_STATUS_INVALID_DSC_COMMENT (integer)
CAIRO_STATUS_INVALID_INDEX (integer)
CAIRO_STATUS_CLIP_NOT_REPRESENTABLE (integer)
CAIRO_STATUS_TEMP_FILE_ERROR (integer)
CAIRO_STATUS_INVALID_STRIDE (integer)
CAIRO_ANTIALIAS_DEFAULT (integer)
CAIRO_ANTIALIAS_NONE (integer)
CAIRO_ANTIALIAS_GRAY (integer)
CAIRO_ANTIALIAS_SUBPIXEL (integer)
CAIRO_SUBPIXEL_ORDER_DEFAULT (integer)
CAIRO_SUBPIXEL_ORDER_RGB (integer)
CAIRO_SUBPIXEL_ORDER_BGR (integer)
CAIRO_SUBPIXEL_ORDER_VRGB (integer)
CAIRO_SUBPIXEL_ORDER_VBGR (integer)
CAIRO_FILL_RULE_WINDING (integer)
CAIRO_FILL_RULE_EVEN_ODD (integer)
CAIRO_LINE_CAP_BUTT (integer)
CAIRO_LINE_CAP_ROUND (integer)
CAIRO_LINE_CAP_SQUARE (integer)
CAIRO_LINE_JOIN_MITER (integer)
CAIRO_LINE_JOIN_ROUND (integer)
CAIRO_LINE_JOIN_BEVEL (integer)
CAIRO_OPERATOR_CLEAR (integer)
CAIRO_OPERATOR_SOURCE (integer)
CAIRO_OPERATOR_OVER (integer)
CAIRO_OPERATOR_IN (integer)
CAIRO_OPERATOR_OUT (integer)
CAIRO_OPERATOR_ATOP (integer)
CAIRO_OPERATOR_DEST (integer)
CAIRO_OPERATOR_DEST_OVER (integer)
CAIRO_OPERATOR_DEST_IN (integer)
CAIRO_OPERATOR_DEST_OUT (integer)
CAIRO_OPERATOR_DEST_ATOP (integer)
CAIRO_OPERATOR_XOR (integer)
CAIRO_OPERATOR_ADD (integer)
CAIRO_OPERATOR_SATURATE (integer)
CAIRO_PATTERN_TYPE_SOLID (integer)
CAIRO_PATTERN_TYPE_SURFACE (integer)
CAIRO_PATTERN_TYPE_LINEAR (integer)
CAIRO_PATTERN_TYPE_RADIAL (integer)
CAIRO_EXTEND_NONE (integer)
CAIRO_EXTEND_REPEAT (integer)
CAIRO_EXTEND_REFLECT (integer)
CAIRO_EXTEND_PAD (integer)
CAIRO_FILTER_FAST (integer)
CAIRO_FILTER_GOOD (integer)
CAIRO_FILTER_BEST (integer)
CAIRO_FILTER_NEAREST (integer)
CAIRO_FILTER_BILINEAR (integer)
CAIRO_FILTER_GAUSSIAN (integer)
CAIRO_HINT_STYLE_DEFAULT (integer)
CAIRO_HINT_STYLE_NONE (integer)
CAIRO_HINT_STYLE_SLIGHT (integer)
CAIRO_HINT_STYLE_MEDIUM (integer)
CAIRO_HINT_STYLE_FULL (integer)
CAIRO_HINT_METRICS_DEFAULT (integer)
CAIRO_HINT_METRICS_OFF (integer)
CAIRO_HINT_METRICS_ON (integer)
CAIRO_FONT_TYPE_TOY (integer)
CAIRO_FONT_TYPE_FT (integer)
CAIRO_FONT_TYPE_WIN32 (integer)
CAIRO_FONT_TYPE_QUARTZ (integer)
CAIRO_FONT_SLANT_NORMAL (integer)
CAIRO_FONT_SLANT_ITALIC (integer)
CAIRO_FONT_SLANT_OBLIQUE (integer)
CAIRO_FONT_WEIGHT_NORMAL (integer)
CAIRO_FONT_WEIGHT_BOLD (integer)
CAIRO_CONTENT_COLOR (integer)
CAIRO_CONTENT_ALPHA (integer)
CAIRO_CONTENT_COLOR_ALPHA (integer)
CAIRO_SURFACE_TYPE_IMAGE (integer)
CAIRO_SURFACE_TYPE_PDF (integer)
CAIRO_SURFACE_TYPE_PS (integer)
CAIRO_SURFACE_TYPE_XLIB (integer)
CAIRO_SURFACE_TYPE_XCB (integer)
CAIRO_SURFACE_TYPE_GLITZ (integer)
CAIRO_SURFACE_TYPE_QUARTZ (integer)
CAIRO_SURFACE_TYPE_WIN32 (integer)
CAIRO_SURFACE_TYPE_BEOS (integer)
CAIRO_SURFACE_TYPE_DIRECTFB (integer)
CAIRO_SURFACE_TYPE_SVG (integer)
CAIRO_SURFACE_TYPE_OS2 (integer)
CAIRO_SURFACE_TYPE_WIN32_PRINTING (integer)
CAIRO_SURFACE_TYPE_QUARTZ_IMAGE (integer)
CAIRO_FORMAT_ARGB32 (integer)
CAIRO_FORMAT_RGB24 (integer)
CAIRO_FORMAT_A8 (integer)
CAIRO_FORMAT_A1 (integer)
CAIRO_PS_LEVEL_2 (integer)
CAIRO_PS_LEVEL_3 (integer)
CAIRO_SVG_VERSION_1_1 (integer)
CAIRO_SVG_VERSION_1_2 (integer)

Özkaynak Türleri
Örnekler
Cairo


Örnekler

Description here...

Örnek 1 Cairo Example

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...
Öntanımlı Sabitler
Cairo İşlevleri
Cairo


Cairo İşlevleri

İçindekiler

  • cairo_create — Returns a new CairoContext object on the requested surface.
  • cairo_font_face_get_type — Description
  • cairo_font_face_status — Description
  • cairo_font_options_create — Description
  • cairo_font_options_equal — Description
  • cairo_font_options_get_antialias — Description
  • cairo_font_options_get_hint_metrics — Description
  • cairo_font_options_get_hint_style — Description
  • cairo_font_options_get_subpixel_order — Description
  • cairo_font_options_hash — Description
  • cairo_font_options_merge — Description
  • cairo_font_options_set_antialias — Description
  • cairo_font_options_set_hint_metrics — Description
  • cairo_font_options_set_hint_style — Description
  • cairo_font_options_set_subpixel_order — Description
  • cairo_font_options_status — Description
  • cairo_format_stride_for_width — Description
  • cairo_image_surface_create_for_data — Description
  • cairo_image_surface_create_from_png — Description
  • cairo_image_surface_create — Description
  • cairo_image_surface_get_data — Description
  • cairo_image_surface_get_format — Description
  • cairo_image_surface_get_height — Description
  • cairo_image_surface_get_stride — Description
  • cairo_image_surface_get_width — Description
  • cairo_matrix_create_scale — Takma Adı: CairoMatrix::initScale
  • cairo_matrix_create_translate — Takma Adı: CairoMatrix::initTranslate
  • cairo_matrix_invert — Description
  • cairo_matrix_multiply — Description
  • cairo_matrix_rotate — Description
  • cairo_matrix_transform_distance — Description
  • cairo_matrix_transform_point — Description
  • cairo_matrix_translate — Description
  • cairo_pattern_add_color_stop_rgb — Description
  • cairo_pattern_add_color_stop_rgba — Description
  • cairo_pattern_create_for_surface — Description
  • cairo_pattern_create_linear — Description
  • cairo_pattern_create_radial — Description
  • cairo_pattern_create_rgb — Description
  • cairo_pattern_create_rgba — Description
  • cairo_pattern_get_color_stop_count — Description
  • cairo_pattern_get_color_stop_rgba — Description
  • cairo_pattern_get_extend — Description
  • cairo_pattern_get_filter — Description
  • cairo_pattern_get_linear_points — Description
  • cairo_pattern_get_matrix — Description
  • cairo_pattern_get_radial_circles — Description
  • cairo_pattern_get_rgba — Description
  • cairo_pattern_get_surface — Description
  • cairo_pattern_get_type — Description
  • cairo_pattern_set_extend — Description
  • cairo_pattern_set_filter — Description
  • cairo_pattern_set_matrix — Description
  • cairo_pattern_status — Description
  • cairo_pdf_surface_create — Description
  • cairo_pdf_surface_set_size — Description
  • cairo_ps_get_levels — Description
  • cairo_ps_level_to_string — Description
  • cairo_ps_surface_create — Description
  • cairo_ps_surface_dsc_begin_page_setup — Description
  • cairo_ps_surface_dsc_begin_setup — Description
  • cairo_ps_surface_dsc_comment — Description
  • cairo_ps_surface_get_eps — Description
  • cairo_ps_surface_restrict_to_level — Description
  • cairo_ps_surface_set_eps — Description
  • cairo_ps_surface_set_size — Description
  • cairo_scaled_font_create — Description
  • cairo_scaled_font_extents — Description
  • cairo_scaled_font_get_ctm — Description
  • cairo_scaled_font_get_font_face — Description
  • cairo_scaled_font_get_font_matrix — Description
  • cairo_scaled_font_get_font_options — Description
  • cairo_scaled_font_get_scale_matrix — Description
  • cairo_scaled_font_get_type — Description
  • cairo_scaled_font_glyph_extents — Description
  • cairo_scaled_font_status — Description
  • cairo_scaled_font_text_extents — Description
  • cairo_surface_copy_page — Description
  • cairo_surface_create_similar — Description
  • cairo_surface_finish — Description
  • cairo_surface_flush — Description
  • cairo_surface_get_content — Description
  • cairo_surface_get_device_offset — Description
  • cairo_surface_get_font_options — Description
  • cairo_surface_get_type — Description
  • cairo_surface_mark_dirty_rectangle — Description
  • cairo_surface_mark_dirty — Description
  • cairo_surface_set_device_offset — Description
  • cairo_surface_set_fallback_resolution — Description
  • cairo_surface_show_page — Description
  • cairo_surface_status — Description
  • cairo_surface_write_to_png — Description
  • cairo_svg_surface_create — Description
  • cairo_svg_surface_restrict_to_version — Description
  • cairo_svg_version_to_string — Description
Örnekler
cairo_create
Cairo


Returns a new CairoContext object on the requested surface.

Cairo İşlevleri
cairo_font_face_get_type
Cairo İşlevleri
PHP Manual

cairo_create

(PECL cairo >= 0.1.0)

cairo_create — Returns a new CairoContext object on the requested surface.

Açıklama

CairoContext cairo_create ( CairoSurface $surface )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

surface

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_create() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

Cairo İşlevleri
cairo_font_face_get_type
Cairo İşlevleri


Description

cairo_create
cairo_font_face_status
Cairo İşlevleri
PHP Manual

cairo_font_face_get_type

(PECL cairo >= 0.1.0)

cairo_font_face_get_type — Description

Açıklama

int cairo_font_face_get_type ( CairoFontFace $fontface )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

fontface

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_font_face_get_type() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_create
cairo_font_face_status
Cairo İşlevleri


Description

cairo_font_face_get_type
cairo_font_options_create
Cairo İşlevleri
PHP Manual

cairo_font_face_status

(PECL cairo >= 0.1.0)

cairo_font_face_status — Description

Açıklama

int cairo_font_face_status ( CairoFontFace $fontface )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

fontface

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_font_face_status() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_font_face_get_type
cairo_font_options_create
Cairo İşlevleri


Description

cairo_font_face_status
cairo_font_options_equal
Cairo İşlevleri
PHP Manual

cairo_font_options_create

(PECL cairo >= 0.1.0)

cairo_font_options_create — Description

Açıklama

CairoFontOptions cairo_font_options_create ( void )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_font_options_create() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_font_face_status
cairo_font_options_equal
Cairo İşlevleri


Description

cairo_font_options_create
cairo_font_options_get_antialias
Cairo İşlevleri
PHP Manual

cairo_font_options_equal

(PECL cairo >= 0.1.0)

cairo_font_options_equal — Description

Açıklama

bool cairo_font_options_equal ( CairoFontOptions $options , CairoFontOptions $other )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

options

Description...

other

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_font_options_equal() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_font_options_create
cairo_font_options_get_antialias
Cairo İşlevleri


Description

cairo_font_options_equal
cairo_font_options_get_hint_metrics
Cairo İşlevleri
PHP Manual

cairo_font_options_get_antialias

(PECL cairo >= 0.1.0)

cairo_font_options_get_antialias — Description

Açıklama

int cairo_font_options_get_antialias ( CairoFontOptions $options )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

options

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_font_options_get_antialias() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_font_options_equal
cairo_font_options_get_hint_metrics
Cairo İşlevleri


Description

cairo_font_options_get_antialias
cairo_font_options_get_hint_style
Cairo İşlevleri
PHP Manual

cairo_font_options_get_hint_metrics

(PECL cairo >= 0.1.0)

cairo_font_options_get_hint_metrics — Description

Açıklama

int cairo_font_options_get_hint_metrics ( CairoFontOptions $options )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

options

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_font_options_get_hint_metrics() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_font_options_get_antialias
cairo_font_options_get_hint_style
Cairo İşlevleri


Description

cairo_font_options_get_hint_metrics
cairo_font_options_get_subpixel_order
Cairo İşlevleri
PHP Manual

cairo_font_options_get_hint_style

(PECL cairo >= 0.1.0)

cairo_font_options_get_hint_style — Description

Açıklama

int cairo_font_options_get_hint_style ( CairoFontOptions $options )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

options

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_font_options_get_hint_style() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_font_options_get_hint_metrics
cairo_font_options_get_subpixel_order
Cairo İşlevleri


Description

cairo_font_options_get_hint_style
cairo_font_options_hash
Cairo İşlevleri
PHP Manual

cairo_font_options_get_subpixel_order

(PECL cairo >= 0.1.0)

cairo_font_options_get_subpixel_order — Description

Açıklama

int cairo_font_options_get_subpixel_order ( CairoFontOptions $options )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

options

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_font_options_get_subpixel_order() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_font_options_get_hint_style
cairo_font_options_hash
Cairo İşlevleri


Description

cairo_font_options_get_subpixel_order
cairo_font_options_merge
Cairo İşlevleri
PHP Manual

cairo_font_options_hash

(PECL cairo >= 0.1.0)

cairo_font_options_hash — Description

Açıklama

int cairo_font_options_hash ( CairoFontOptions $options )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

options

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_font_options_hash() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_font_options_get_subpixel_order
cairo_font_options_merge
Cairo İşlevleri


Description

cairo_font_options_hash
cairo_font_options_set_antialias
Cairo İşlevleri
PHP Manual

cairo_font_options_merge

(PECL cairo >= 0.1.0)

cairo_font_options_merge — Description

Açıklama

void cairo_font_options_merge ( CairoFontOptions $options , CairoFontOptions $other )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

options

Description...

other

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_font_options_merge() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_font_options_hash
cairo_font_options_set_antialias
Cairo İşlevleri


Description

cairo_font_options_merge
cairo_font_options_set_hint_metrics
Cairo İşlevleri
PHP Manual

cairo_font_options_set_antialias

(PECL cairo >= 0.1.0)

cairo_font_options_set_antialias — Description

Açıklama

void cairo_font_options_set_antialias ( CairoFontOptions $options , int $antialias )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

options

Description...

antialias

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_font_options_set_antialias() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_font_options_merge
cairo_font_options_set_hint_metrics
Cairo İşlevleri


Description

cairo_font_options_set_antialias
cairo_font_options_set_hint_style
Cairo İşlevleri
PHP Manual

cairo_font_options_set_hint_metrics

(PECL cairo >= 0.1.0)

cairo_font_options_set_hint_metrics — Description

Açıklama

void cairo_font_options_set_hint_metrics ( CairoFontOptions $options , int $hint_metrics )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

options

Description...

hint_metrics

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_font_options_set_hint_metrics() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_font_options_set_antialias
cairo_font_options_set_hint_style
Cairo İşlevleri


Description

cairo_font_options_set_hint_metrics
cairo_font_options_set_subpixel_order
Cairo İşlevleri
PHP Manual

cairo_font_options_set_hint_style

(PECL cairo >= 0.1.0)

cairo_font_options_set_hint_style — Description

Açıklama

void cairo_font_options_set_hint_style ( CairoFontOptions $options , int $hint_style )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

options

Description...

hint_style

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_font_options_set_hint_style() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_font_options_set_hint_metrics
cairo_font_options_set_subpixel_order
Cairo İşlevleri


Description

cairo_font_options_set_hint_style
cairo_font_options_status
Cairo İşlevleri
PHP Manual

cairo_font_options_set_subpixel_order

(PECL cairo >= 0.1.0)

cairo_font_options_set_subpixel_order — Description

Açıklama

void cairo_font_options_set_subpixel_order ( CairoFontOptions $options , int $subpixel_order )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

options

Description...

subpixel_order

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_font_options_set_subpixel_order() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_font_options_set_hint_style
cairo_font_options_status
Cairo İşlevleri


Description

cairo_font_options_set_subpixel_order
cairo_format_stride_for_width
Cairo İşlevleri
PHP Manual

cairo_font_options_status

(PECL cairo >= 0.1.0)

cairo_font_options_status — Description

Açıklama

int cairo_font_options_status ( CairoFontOptions $options )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

options

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_font_options_status() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_font_options_set_subpixel_order
cairo_format_stride_for_width
Cairo İşlevleri


Description

cairo_font_options_status
cairo_image_surface_create_for_data
Cairo İşlevleri
PHP Manual

cairo_format_stride_for_width

(PECL cairo >= 0.1.0)

cairo_format_stride_for_width — Description

Açıklama

int cairo_format_stride_for_width ( int $format , int $width )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

format

Description...

width

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_format_stride_for_width() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_font_options_status
cairo_image_surface_create_for_data
Cairo İşlevleri


Description

cairo_format_stride_for_width
cairo_image_surface_create_from_png
Cairo İşlevleri
PHP Manual

cairo_image_surface_create_for_data

(PECL cairo >= 0.1.0)

cairo_image_surface_create_for_data — Description

Açıklama

CairoImageSurface cairo_image_surface_create_for_data ( string $data , int $format , int $width , int $height [, int $stride = -1 ] )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

data

Description...

format

Description...

width

Description...

height

Description...

stride

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_image_surface_create_for_data() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_format_stride_for_width
cairo_image_surface_create_from_png
Cairo İşlevleri


Description

cairo_image_surface_create_for_data
cairo_image_surface_create
Cairo İşlevleri
PHP Manual

cairo_image_surface_create_from_png

(PECL cairo >= 0.1.0)

cairo_image_surface_create_from_png — Description

Açıklama

CairoImageSurface cairo_image_surface_create_from_png ( string $file )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

file

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_image_surface_create_from_png() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_image_surface_create_for_data
cairo_image_surface_create
Cairo İşlevleri


Description

cairo_image_surface_create_from_png
cairo_image_surface_get_data
Cairo İşlevleri
PHP Manual

cairo_image_surface_create

(PECL cairo >= 0.1.0)

cairo_image_surface_create — Description

Açıklama

CairoImageSurface cairo_image_surface_create ( int $format , int $width , int $height )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

format

Description...

width

Description...

height

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_image_surface_create() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_image_surface_create_from_png
cairo_image_surface_get_data
Cairo İşlevleri


Description

cairo_image_surface_create
cairo_image_surface_get_format
Cairo İşlevleri
PHP Manual

cairo_image_surface_get_data

(PECL cairo >= 0.1.0)

cairo_image_surface_get_data — Description

Açıklama

string cairo_image_surface_get_data ( CairoImageSurface $surface )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

surface

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_image_surface_get_data() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_image_surface_create
cairo_image_surface_get_format
Cairo İşlevleri


Description

cairo_image_surface_get_data
cairo_image_surface_get_height
Cairo İşlevleri
PHP Manual

cairo_image_surface_get_format

(PECL cairo >= 0.1.0)

cairo_image_surface_get_format — Description

Açıklama

int cairo_image_surface_get_format ( CairoImageSurface $surface )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

surface

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_image_surface_get_format() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_image_surface_get_data
cairo_image_surface_get_height
Cairo İşlevleri


Description

cairo_image_surface_get_format
cairo_image_surface_get_stride
Cairo İşlevleri
PHP Manual

cairo_image_surface_get_height

(PECL cairo >= 0.1.0)

cairo_image_surface_get_height — Description

Açıklama

int cairo_image_surface_get_height ( CairoImageSurface $surface )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

surface

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_image_surface_get_height() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_image_surface_get_format
cairo_image_surface_get_stride
Cairo İşlevleri


Description

cairo_image_surface_get_height
cairo_image_surface_get_width
Cairo İşlevleri
PHP Manual

cairo_image_surface_get_stride

(PECL cairo >= 0.1.0)

cairo_image_surface_get_stride — Description

Açıklama

int cairo_image_surface_get_stride ( CairoImageSurface $surface )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

surface

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_image_surface_get_stride() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_image_surface_get_height
cairo_image_surface_get_width
Cairo İşlevleri


Description

cairo_image_surface_get_stride
cairo_matrix_create_scale
Cairo İşlevleri
PHP Manual

cairo_image_surface_get_width

(PECL cairo >= 0.1.0)

cairo_image_surface_get_width — Description

Açıklama

int cairo_image_surface_get_width ( CairoImageSurface $surface )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

surface

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_image_surface_get_width() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_image_surface_get_stride
cairo_matrix_create_scale
Cairo İşlevleri


Takma Adı: CairoMatrix::initScale

cairo_image_surface_get_width
cairo_matrix_create_translate
Cairo İşlevleri
PHP Manual

cairo_matrix_create_scale

(PECL cairo >= 0.1.0)

cairo_matrix_create_scale — Takma Adı: CairoMatrix::initScale()

Açıklama

Bu işlev şu işlevin takma adıdır: CairoMatrix::initScale().

Bu takma ad, PHP'nin ileri sürümlerinde kaldırılabileceğinden kullanılması önerilmemektedir ve şimdilik sadece geriye uyumluluk adına mevcuttur.

cairo_image_surface_get_width
cairo_matrix_create_translate
Cairo İşlevleri


Takma Adı: CairoMatrix::initTranslate

cairo_matrix_create_scale
cairo_matrix_invert
Cairo İşlevleri
PHP Manual

cairo_matrix_create_translate

(PECL cairo >= 0.1.0)

cairo_matrix_create_translate — Takma Adı: CairoMatrix::initTranslate()

Açıklama

Bu işlev şu işlevin takma adıdır: CairoMatrix::initTranslate().

Bu takma ad, PHP'nin ileri sürümlerinde kaldırılabileceğinden kullanılması önerilmemektedir ve şimdilik sadece geriye uyumluluk adına mevcuttur.

cairo_matrix_create_scale
cairo_matrix_invert
Cairo İşlevleri


Description

cairo_matrix_create_translate
cairo_matrix_multiply
Cairo İşlevleri
PHP Manual

cairo_matrix_invert

(PECL cairo >= 0.1.0)

cairo_matrix_invert — Description

Açıklama

void cairo_matrix_invert ( CairoMatrix $matrix )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

matrix

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_matrix_invert() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_matrix_create_translate
cairo_matrix_multiply
Cairo İşlevleri


Description

cairo_matrix_invert
cairo_matrix_rotate
Cairo İşlevleri
PHP Manual

cairo_matrix_multiply

(PECL cairo >= 0.1.0)

cairo_matrix_multiply — Description

Açıklama

CairoMatrix cairo_matrix_multiply ( CairoMatrix $matrix1 , CairoMatrix $matrix2 )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

matrix1

Description...

matrix2

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_matrix_multiply() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_matrix_invert
cairo_matrix_rotate
Cairo İşlevleri


Description

cairo_matrix_multiply
cairo_matrix_transform_distance
Cairo İşlevleri
PHP Manual

cairo_matrix_rotate

(PECL cairo >= 0.1.0)

cairo_matrix_rotate — Description

Açıklama

void cairo_matrix_rotate ( CairoMatrix $matrix , float $radians )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

matrix

Description...

radians

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_matrix_rotate() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_matrix_multiply
cairo_matrix_transform_distance
Cairo İşlevleri


Description

cairo_matrix_rotate
cairo_matrix_transform_point
Cairo İşlevleri
PHP Manual

cairo_matrix_transform_distance

(PECL cairo >= 0.1.0)

cairo_matrix_transform_distance — Description

Açıklama

array cairo_matrix_transform_distance ( CairoMatrix $matrix , float $dx , float $dy )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

matrix

Description...

dx

Description...

dy

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_matrix_transform_distance() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_matrix_rotate
cairo_matrix_transform_point
Cairo İşlevleri


Description

cairo_matrix_transform_distance
cairo_matrix_translate
Cairo İşlevleri
PHP Manual

cairo_matrix_transform_point

(PECL cairo >= 0.1.0)

cairo_matrix_transform_point — Description

Açıklama

array cairo_matrix_transform_point ( CairoMatrix $matrix , float $dx , float $dy )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

matrix

Description...

dx

Description...

dy

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_matrix_transform_point() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_matrix_transform_distance
cairo_matrix_translate
Cairo İşlevleri


Description

cairo_matrix_transform_point
cairo_pattern_add_color_stop_rgb
Cairo İşlevleri
PHP Manual

cairo_matrix_translate

(PECL cairo >= 0.1.0)

cairo_matrix_translate — Description

Açıklama

void cairo_matrix_translate ( CairoMatrix $matrix , float $tx , float $ty )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

matrix

Description...

tx

Description...

ty

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_matrix_translate() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_matrix_transform_point
cairo_pattern_add_color_stop_rgb
Cairo İşlevleri


Description

cairo_matrix_translate
cairo_pattern_add_color_stop_rgba
Cairo İşlevleri
PHP Manual

cairo_pattern_add_color_stop_rgb

(PECL cairo >= 0.1.0)

cairo_pattern_add_color_stop_rgb — Description

Açıklama

void cairo_pattern_add_color_stop_rgb ( CairoGradientPattern $pattern , float $offset , float $red , float $green , float $blue )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

pattern

Description...

offset

Description...

red

Description...

green

Description...

blue

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_pattern_add_color_stop_rgb() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_matrix_translate
cairo_pattern_add_color_stop_rgba
Cairo İşlevleri


Description

cairo_pattern_add_color_stop_rgb
cairo_pattern_create_for_surface
Cairo İşlevleri
PHP Manual

cairo_pattern_add_color_stop_rgba

(PECL cairo >= 0.1.0)

cairo_pattern_add_color_stop_rgba — Description

Açıklama

void cairo_pattern_add_color_stop_rgba ( CairoGradientPattern $pattern , float $offset , float $red , float $green , float $blue , float $alpha )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

pattern

Description...

offset

Description...

red

Description...

green

Description...

blue

Description...

alpha

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_pattern_add_color_stop_rgba() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_pattern_add_color_stop_rgb
cairo_pattern_create_for_surface
Cairo İşlevleri


Description

cairo_pattern_add_color_stop_rgba
cairo_pattern_create_linear
Cairo İşlevleri
PHP Manual

cairo_pattern_create_for_surface

(PECL cairo >= 0.1.0)

cairo_pattern_create_for_surface — Description

Açıklama

CairoPattern cairo_pattern_create_for_surface ( CairoSurface $surface )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

surface

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_pattern_create_for_surface() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_pattern_add_color_stop_rgba
cairo_pattern_create_linear
Cairo İşlevleri


Description

cairo_pattern_create_for_surface
cairo_pattern_create_radial
Cairo İşlevleri
PHP Manual

cairo_pattern_create_linear

(PECL cairo >= 0.1.0)

cairo_pattern_create_linear — Description

Açıklama

CairoPattern cairo_pattern_create_linear ( float $x0 , float $y0 , float $x1 , float $y1 )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

x0

Description...

y0

Description...

x1

Description...

y1

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_pattern_create_linear() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_pattern_create_for_surface
cairo_pattern_create_radial
Cairo İşlevleri


Description

cairo_pattern_create_linear
cairo_pattern_create_rgb
Cairo İşlevleri
PHP Manual

cairo_pattern_create_radial

(PECL cairo >= 0.1.0)

cairo_pattern_create_radial — Description

Açıklama

CairoPattern cairo_pattern_create_radial ( float $x0 , float $y0 , float $r0 , float $x1 , float $y1 , float $r1 )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

x0

Description...

y0

Description...

r0

Description...

x1

Description...

y1

Description...

r1

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_pattern_create_radial() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_pattern_create_linear
cairo_pattern_create_rgb
Cairo İşlevleri


Description

cairo_pattern_create_radial
cairo_pattern_create_rgba
Cairo İşlevleri
PHP Manual

cairo_pattern_create_rgb

(PECL cairo >= 0.1.0)

cairo_pattern_create_rgb — Description

Açıklama

CairoPattern cairo_pattern_create_rgb ( float $red , float $green , float $blue )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

red

Description...

green

Description...

blue

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_pattern_create_rgb() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_pattern_create_radial
cairo_pattern_create_rgba
Cairo İşlevleri


Description

cairo_pattern_create_rgb
cairo_pattern_get_color_stop_count
Cairo İşlevleri
PHP Manual

cairo_pattern_create_rgba

(PECL cairo >= 0.1.0)

cairo_pattern_create_rgba — Description

Açıklama

CairoPattern cairo_pattern_create_rgba ( float $red , float $green , float $blue , float $alpha )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

red

Description...

green

Description...

blue

Description...

alpha

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_pattern_create_rgba() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_pattern_create_rgb
cairo_pattern_get_color_stop_count
Cairo İşlevleri


Description

cairo_pattern_create_rgba
cairo_pattern_get_color_stop_rgba
Cairo İşlevleri
PHP Manual

cairo_pattern_get_color_stop_count

(PECL cairo >= 0.1.0)

cairo_pattern_get_color_stop_count — Description

Açıklama

int cairo_pattern_get_color_stop_count ( CairoGradientPattern $pattern )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

pattern

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_pattern_get_color_stop_count() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_pattern_create_rgba
cairo_pattern_get_color_stop_rgba
Cairo İşlevleri


Description

cairo_pattern_get_color_stop_count
cairo_pattern_get_extend
Cairo İşlevleri
PHP Manual

cairo_pattern_get_color_stop_rgba

(PECL cairo >= 0.1.0)

cairo_pattern_get_color_stop_rgba — Description

Açıklama

array cairo_pattern_get_color_stop_rgba ( CairoGradientPattern $pattern , int $index )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

pattern

Description...

index

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_pattern_get_color_stop_rgba() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_pattern_get_color_stop_count
cairo_pattern_get_extend
Cairo İşlevleri


Description

cairo_pattern_get_color_stop_rgba
cairo_pattern_get_filter
Cairo İşlevleri
PHP Manual

cairo_pattern_get_extend

(PECL cairo >= 0.1.0)

cairo_pattern_get_extend — Description

Açıklama

int cairo_pattern_get_extend ( string $pattern )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

pattern

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_pattern_get_extend() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_pattern_get_color_stop_rgba
cairo_pattern_get_filter
Cairo İşlevleri


Description

cairo_pattern_get_extend
cairo_pattern_get_linear_points
Cairo İşlevleri
PHP Manual

cairo_pattern_get_filter

(PECL cairo >= 0.1.0)

cairo_pattern_get_filter — Description

Açıklama

int cairo_pattern_get_filter ( CairoSurfacePattern $pattern )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

pattern

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_pattern_get_filter() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_pattern_get_extend
cairo_pattern_get_linear_points
Cairo İşlevleri


Description

cairo_pattern_get_filter
cairo_pattern_get_matrix
Cairo İşlevleri
PHP Manual

cairo_pattern_get_linear_points

(PECL cairo >= 0.1.0)

cairo_pattern_get_linear_points — Description

Açıklama

array cairo_pattern_get_linear_points ( CairoLinearGradient $pattern )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

pattern

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_pattern_get_linear_points() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_pattern_get_filter
cairo_pattern_get_matrix
Cairo İşlevleri


Description

cairo_pattern_get_linear_points
cairo_pattern_get_radial_circles
Cairo İşlevleri
PHP Manual

cairo_pattern_get_matrix

(PECL cairo >= 0.1.0)

cairo_pattern_get_matrix — Description

Açıklama

CairoMatrix cairo_pattern_get_matrix ( CairoPattern $pattern )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

pattern

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_pattern_get_matrix() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_pattern_get_linear_points
cairo_pattern_get_radial_circles
Cairo İşlevleri


Description

cairo_pattern_get_matrix
cairo_pattern_get_rgba
Cairo İşlevleri
PHP Manual

cairo_pattern_get_radial_circles

(PECL cairo >= 0.1.0)

cairo_pattern_get_radial_circles — Description

Açıklama

array cairo_pattern_get_radial_circles ( CairoRadialGradient $pattern )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

pattern

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_pattern_get_radial_circles() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_pattern_get_matrix
cairo_pattern_get_rgba
Cairo İşlevleri


Description

cairo_pattern_get_radial_circles
cairo_pattern_get_surface
Cairo İşlevleri
PHP Manual

cairo_pattern_get_rgba

(PECL cairo >= 0.1.0)

cairo_pattern_get_rgba — Description

Açıklama

array cairo_pattern_get_rgba ( CairoSolidPattern $pattern )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

pattern

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_pattern_get_rgba() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_pattern_get_radial_circles
cairo_pattern_get_surface
Cairo İşlevleri


Description

cairo_pattern_get_rgba
cairo_pattern_get_type
Cairo İşlevleri
PHP Manual

cairo_pattern_get_surface

(PECL cairo >= 0.1.0)

cairo_pattern_get_surface — Description

Açıklama

CairoSurface cairo_pattern_get_surface ( CairoSurfacePattern $pattern )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

pattern

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_pattern_get_surface() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_pattern_get_rgba
cairo_pattern_get_type
Cairo İşlevleri


Description

cairo_pattern_get_surface
cairo_pattern_set_extend
Cairo İşlevleri
PHP Manual

cairo_pattern_get_type

(PECL cairo >= 0.1.0)

cairo_pattern_get_type — Description

Açıklama

int cairo_pattern_get_type ( CairoPattern $pattern )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

pattern

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_pattern_get_type() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_pattern_get_surface
cairo_pattern_set_extend
Cairo İşlevleri


Description

cairo_pattern_get_type
cairo_pattern_set_filter
Cairo İşlevleri
PHP Manual

cairo_pattern_set_extend

(PECL cairo >= 0.1.0)

cairo_pattern_set_extend — Description

Açıklama

void cairo_pattern_set_extend ( string $pattern , string $extend )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

pattern

Description...

extend

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_pattern_set_extend() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_pattern_get_type
cairo_pattern_set_filter
Cairo İşlevleri


Description

cairo_pattern_set_extend
cairo_pattern_set_matrix
Cairo İşlevleri
PHP Manual

cairo_pattern_set_filter

(PECL cairo >= 0.1.0)

cairo_pattern_set_filter — Description

Açıklama

void cairo_pattern_set_filter ( CairoSurfacePattern $pattern , int $filter )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

pattern

Description...

filter

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_pattern_set_filter() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_pattern_set_extend
cairo_pattern_set_matrix
Cairo İşlevleri


Description

cairo_pattern_set_filter
cairo_pattern_status
Cairo İşlevleri
PHP Manual

cairo_pattern_set_matrix

(PECL cairo >= 0.1.0)

cairo_pattern_set_matrix — Description

Açıklama

void cairo_pattern_set_matrix ( CairoPattern $pattern , CairoMatrix $matrix )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

pattern

Description...

matrix

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_pattern_set_matrix() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_pattern_set_filter
cairo_pattern_status
Cairo İşlevleri


Description

cairo_pattern_set_matrix
cairo_pdf_surface_create
Cairo İşlevleri
PHP Manual

cairo_pattern_status

(PECL cairo >= 0.1.0)

cairo_pattern_status — Description

Açıklama

int cairo_pattern_status ( CairoPattern $pattern )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

pattern

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_pattern_status() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_pattern_set_matrix
cairo_pdf_surface_create
Cairo İşlevleri


Description

cairo_pattern_status
cairo_pdf_surface_set_size
Cairo İşlevleri
PHP Manual

cairo_pdf_surface_create

(PECL cairo >= 0.1.0)

cairo_pdf_surface_create — Description

Açıklama

CairoPdfSurface cairo_pdf_surface_create ( string $file , float $width , float $height )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

file

Description...

width

Description...

height

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_pdf_surface_create() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_pattern_status
cairo_pdf_surface_set_size
Cairo İşlevleri


Description

cairo_pdf_surface_create
cairo_ps_get_levels
Cairo İşlevleri
PHP Manual

cairo_pdf_surface_set_size

(PECL cairo >= 0.1.0)

cairo_pdf_surface_set_size — Description

Açıklama

void cairo_pdf_surface_set_size ( CairoPdfSurface $surface , float $width , float $height )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

surface

Description...

width

Description...

height

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_pdf_surface_set_size() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_pdf_surface_create
cairo_ps_get_levels
Cairo İşlevleri


Description

cairo_pdf_surface_set_size
cairo_ps_level_to_string
Cairo İşlevleri
PHP Manual

cairo_ps_get_levels

(PECL cairo >= 0.1.0)

cairo_ps_get_levels — Description

Açıklama

array cairo_ps_get_levels ( void )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_ps_get_levels() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_pdf_surface_set_size
cairo_ps_level_to_string
Cairo İşlevleri


Description

cairo_ps_get_levels
cairo_ps_surface_create
Cairo İşlevleri
PHP Manual

cairo_ps_level_to_string

(PECL cairo >= 0.1.0)

cairo_ps_level_to_string — Description

Açıklama

string cairo_ps_level_to_string ( int $level )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

level

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_ps_level_to_string() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_ps_get_levels
cairo_ps_surface_create
Cairo İşlevleri


Description

cairo_ps_level_to_string
cairo_ps_surface_dsc_begin_page_setup
Cairo İşlevleri
PHP Manual

cairo_ps_surface_create

(PECL cairo >= 0.1.0)

cairo_ps_surface_create — Description

Açıklama

CairoPsSurface cairo_ps_surface_create ( string $file , float $width , float $height )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

file

Description...

width

Description...

height

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_ps_surface_create() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_ps_level_to_string
cairo_ps_surface_dsc_begin_page_setup
Cairo İşlevleri


Description

cairo_ps_surface_create
cairo_ps_surface_dsc_begin_setup
Cairo İşlevleri
PHP Manual

cairo_ps_surface_dsc_begin_page_setup

(PECL cairo >= 0.1.0)

cairo_ps_surface_dsc_begin_page_setup — Description

Açıklama

void cairo_ps_surface_dsc_begin_page_setup ( CairoPsSurface $surface )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

surface

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_ps_surface_dsc_begin_page_setup() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_ps_surface_create
cairo_ps_surface_dsc_begin_setup
Cairo İşlevleri


Description

cairo_ps_surface_dsc_begin_page_setup
cairo_ps_surface_dsc_comment
Cairo İşlevleri
PHP Manual

cairo_ps_surface_dsc_begin_setup

(PECL cairo >= 0.1.0)

cairo_ps_surface_dsc_begin_setup — Description

Açıklama

void cairo_ps_surface_dsc_begin_setup ( CairoPsSurface $surface )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

surface

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_ps_surface_dsc_begin_setup() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_ps_surface_dsc_begin_page_setup
cairo_ps_surface_dsc_comment
Cairo İşlevleri


Description

cairo_ps_surface_dsc_begin_setup
cairo_ps_surface_get_eps
Cairo İşlevleri
PHP Manual

cairo_ps_surface_dsc_comment

(PECL cairo >= 0.1.0)

cairo_ps_surface_dsc_comment — Description

Açıklama

void cairo_ps_surface_dsc_comment ( CairoPsSurface $surface , string $comment )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

surface

Description...

comment

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_ps_surface_dsc_comment() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_ps_surface_dsc_begin_setup
cairo_ps_surface_get_eps
Cairo İşlevleri


Description

cairo_ps_surface_dsc_comment
cairo_ps_surface_restrict_to_level
Cairo İşlevleri
PHP Manual

cairo_ps_surface_get_eps

(PECL cairo >= 0.1.0)

cairo_ps_surface_get_eps — Description

Açıklama

bool cairo_ps_surface_get_eps ( CairoPsSurface $surface )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

surface

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_ps_surface_get_eps() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_ps_surface_dsc_comment
cairo_ps_surface_restrict_to_level
Cairo İşlevleri


Description

cairo_ps_surface_get_eps
cairo_ps_surface_set_eps
Cairo İşlevleri
PHP Manual

cairo_ps_surface_restrict_to_level

(PECL cairo >= 0.1.0)

cairo_ps_surface_restrict_to_level — Description

Açıklama

void cairo_ps_surface_restrict_to_level ( CairoPsSurface $surface , int $level )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

surface

Description...

level

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_ps_surface_restrict_to_level() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_ps_surface_get_eps
cairo_ps_surface_set_eps
Cairo İşlevleri


Description

cairo_ps_surface_restrict_to_level
cairo_ps_surface_set_size
Cairo İşlevleri
PHP Manual

cairo_ps_surface_set_eps

(PECL cairo >= 0.1.0)

cairo_ps_surface_set_eps — Description

Açıklama

void cairo_ps_surface_set_eps ( CairoPsSurface $surface , bool $level )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

surface

Description...

level

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_ps_surface_set_eps() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_ps_surface_restrict_to_level
cairo_ps_surface_set_size
Cairo İşlevleri


Description

cairo_ps_surface_set_eps
cairo_scaled_font_create
Cairo İşlevleri
PHP Manual

cairo_ps_surface_set_size

(PECL cairo >= 0.1.0)

cairo_ps_surface_set_size — Description

Açıklama

void cairo_ps_surface_set_size ( CairoPsSurface $surface , float $width , float $height )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

surface

Description...

width

Description...

height

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_ps_surface_set_size() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_ps_surface_set_eps
cairo_scaled_font_create
Cairo İşlevleri


Description

cairo_ps_surface_set_size
cairo_scaled_font_extents
Cairo İşlevleri
PHP Manual

cairo_scaled_font_create

(PECL cairo >= 0.1.0)

cairo_scaled_font_create — Description

Açıklama

CairoScaledFont cairo_scaled_font_create ( CairoFontFace $fontface , CairoMatrix $matrix , CairoMatrix $ctm , CairoFontOptions $fontoptions )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

fontface

Description...

matrix

Description...

ctm

Description...

fontoptions

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_scaled_font_create() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_ps_surface_set_size
cairo_scaled_font_extents
Cairo İşlevleri


Description

cairo_scaled_font_create
cairo_scaled_font_get_ctm
Cairo İşlevleri
PHP Manual

cairo_scaled_font_extents

(PECL cairo >= 0.1.0)

cairo_scaled_font_extents — Description

Açıklama

array cairo_scaled_font_extents ( CairoScaledFont $scaledfont )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

scaledfont

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_scaled_font_extents() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_scaled_font_create
cairo_scaled_font_get_ctm
Cairo İşlevleri


Description

cairo_scaled_font_extents
cairo_scaled_font_get_font_face
Cairo İşlevleri
PHP Manual

cairo_scaled_font_get_ctm

(PECL cairo >= 0.1.0)

cairo_scaled_font_get_ctm — Description

Açıklama

CairoMatrix cairo_scaled_font_get_ctm ( CairoScaledFont $scaledfont )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

scaledfont

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_scaled_font_get_ctm() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_scaled_font_extents
cairo_scaled_font_get_font_face
Cairo İşlevleri


Description

cairo_scaled_font_get_ctm
cairo_scaled_font_get_font_matrix
Cairo İşlevleri
PHP Manual

cairo_scaled_font_get_font_face

(PECL cairo >= 0.1.0)

cairo_scaled_font_get_font_face — Description

Açıklama

CairoFontFace cairo_scaled_font_get_font_face ( CairoScaledFont $scaledfont )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

scaledfont

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_scaled_font_get_font_face() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_scaled_font_get_ctm
cairo_scaled_font_get_font_matrix
Cairo İşlevleri


Description

cairo_scaled_font_get_font_face
cairo_scaled_font_get_font_options
Cairo İşlevleri
PHP Manual

cairo_scaled_font_get_font_matrix

(PECL cairo >= 0.1.0)

cairo_scaled_font_get_font_matrix — Description

Açıklama

CairoFontOptions cairo_scaled_font_get_font_matrix ( CairoScaledFont $scaledfont )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

scaledfont

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_scaled_font_get_font_matrix() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_scaled_font_get_font_face
cairo_scaled_font_get_font_options
Cairo İşlevleri


Description

cairo_scaled_font_get_font_matrix
cairo_scaled_font_get_scale_matrix
Cairo İşlevleri
PHP Manual

cairo_scaled_font_get_font_options

(PECL cairo >= 0.1.0)

cairo_scaled_font_get_font_options — Description

Açıklama

CairoFontOptions cairo_scaled_font_get_font_options ( CairoScaledFont $scaledfont )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

scaledfont

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_scaled_font_get_font_options() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_scaled_font_get_font_matrix
cairo_scaled_font_get_scale_matrix
Cairo İşlevleri


Description

cairo_scaled_font_get_font_options
cairo_scaled_font_get_type
Cairo İşlevleri
PHP Manual

cairo_scaled_font_get_scale_matrix

(PECL cairo >= 0.1.0)

cairo_scaled_font_get_scale_matrix — Description

Açıklama

CairoMatrix cairo_scaled_font_get_scale_matrix ( CairoScaledFont $scaledfont )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

scaledfont

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_scaled_font_get_scale_matrix() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_scaled_font_get_font_options
cairo_scaled_font_get_type
Cairo İşlevleri


Description

cairo_scaled_font_get_scale_matrix
cairo_scaled_font_glyph_extents
Cairo İşlevleri
PHP Manual

cairo_scaled_font_get_type

(PECL cairo >= 0.1.0)

cairo_scaled_font_get_type — Description

Açıklama

int cairo_scaled_font_get_type ( CairoScaledFont $scaledfont )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

scaledfont

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_scaled_font_get_type() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_scaled_font_get_scale_matrix
cairo_scaled_font_glyph_extents
Cairo İşlevleri


Description

cairo_scaled_font_get_type
cairo_scaled_font_status
Cairo İşlevleri
PHP Manual

cairo_scaled_font_glyph_extents

(PECL cairo >= 0.1.0)

cairo_scaled_font_glyph_extents — Description

Açıklama

array cairo_scaled_font_glyph_extents ( CairoScaledFont $scaledfont , array $glyphs )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

scaledfont

Description...

glyphs

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_scaled_font_glyph_extents() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_scaled_font_get_type
cairo_scaled_font_status
Cairo İşlevleri


Description

cairo_scaled_font_glyph_extents
cairo_scaled_font_text_extents
Cairo İşlevleri
PHP Manual

cairo_scaled_font_status

(PECL cairo >= 0.1.0)

cairo_scaled_font_status — Description

Açıklama

int cairo_scaled_font_status ( CairoScaledFont $scaledfont )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

scaledfont

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_scaled_font_status() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_scaled_font_glyph_extents
cairo_scaled_font_text_extents
Cairo İşlevleri


Description

cairo_scaled_font_status
cairo_surface_copy_page
Cairo İşlevleri
PHP Manual

cairo_scaled_font_text_extents

(PECL cairo >= 0.1.0)

cairo_scaled_font_text_extents — Description

Açıklama

array cairo_scaled_font_text_extents ( CairoScaledFont $scaledfont , string $text )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

scaledfont

Description...

text

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_scaled_font_text_extents() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_scaled_font_status
cairo_surface_copy_page
Cairo İşlevleri


Description

cairo_scaled_font_text_extents
cairo_surface_create_similar
Cairo İşlevleri
PHP Manual

cairo_surface_copy_page

(PECL cairo >= 0.1.0)

cairo_surface_copy_page — Description

Açıklama

void cairo_surface_copy_page ( CairoSurface $surface )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

surface

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_surface_copy_page() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_scaled_font_text_extents
cairo_surface_create_similar
Cairo İşlevleri


Description

cairo_surface_copy_page
cairo_surface_finish
Cairo İşlevleri
PHP Manual

cairo_surface_create_similar

(PECL cairo >= 0.1.0)

cairo_surface_create_similar — Description

Açıklama

CairoSurface cairo_surface_create_similar ( CairoSurface $surface , int $content , float $width , float $height )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

surface

Description...

content

Description...

width

Description...

height

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_surface_create_similar() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_surface_copy_page
cairo_surface_finish
Cairo İşlevleri


Description

cairo_surface_create_similar
cairo_surface_flush
Cairo İşlevleri
PHP Manual

cairo_surface_finish

(PECL cairo >= 0.1.0)

cairo_surface_finish — Description

Açıklama

void cairo_surface_finish ( CairoSurface $surface )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

surface

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_surface_finish() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_surface_create_similar
cairo_surface_flush
Cairo İşlevleri


Description

cairo_surface_finish
cairo_surface_get_content
Cairo İşlevleri
PHP Manual

cairo_surface_flush

(PECL cairo >= 0.1.0)

cairo_surface_flush — Description

Açıklama

void cairo_surface_flush ( CairoSurface $surface )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

surface

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_surface_flush() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_surface_finish
cairo_surface_get_content
Cairo İşlevleri


Description

cairo_surface_flush
cairo_surface_get_device_offset
Cairo İşlevleri
PHP Manual

cairo_surface_get_content

(PECL cairo >= 0.1.0)

cairo_surface_get_content — Description

Açıklama

int cairo_surface_get_content ( CairoSurface $surface )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

surface

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_surface_get_content() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_surface_flush
cairo_surface_get_device_offset
Cairo İşlevleri


Description

cairo_surface_get_content
cairo_surface_get_font_options
Cairo İşlevleri
PHP Manual

cairo_surface_get_device_offset

(PECL cairo >= 0.1.0)

cairo_surface_get_device_offset — Description

Açıklama

array cairo_surface_get_device_offset ( CairoSurface $surface )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

surface

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_surface_get_device_offset() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_surface_get_content
cairo_surface_get_font_options
Cairo İşlevleri


Description

cairo_surface_get_device_offset
cairo_surface_get_type
Cairo İşlevleri
PHP Manual

cairo_surface_get_font_options

(PECL cairo >= 0.1.0)

cairo_surface_get_font_options — Description

Açıklama

CairoFontOptions cairo_surface_get_font_options ( CairoSurface $surface )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

surface

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_surface_get_font_options() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_surface_get_device_offset
cairo_surface_get_type
Cairo İşlevleri


Description

cairo_surface_get_font_options
cairo_surface_mark_dirty_rectangle
Cairo İşlevleri
PHP Manual

cairo_surface_get_type

(PECL cairo >= 0.1.0)

cairo_surface_get_type — Description

Açıklama

int cairo_surface_get_type ( CairoSurface $surface )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

surface

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_surface_get_type() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_surface_get_font_options
cairo_surface_mark_dirty_rectangle
Cairo İşlevleri


Description

cairo_surface_get_type
cairo_surface_mark_dirty
Cairo İşlevleri
PHP Manual

cairo_surface_mark_dirty_rectangle

(PECL cairo >= 0.1.0)

cairo_surface_mark_dirty_rectangle — Description

Açıklama

void cairo_surface_mark_dirty_rectangle ( CairoSurface $surface , float $x , float $y , float $width , float $height )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

surface

Description...

x

Description...

y

Description...

width

Description...

height

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_surface_mark_dirty_rectangle() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_surface_get_type
cairo_surface_mark_dirty
Cairo İşlevleri


Description

cairo_surface_mark_dirty_rectangle
cairo_surface_set_device_offset
Cairo İşlevleri
PHP Manual

cairo_surface_mark_dirty

(PECL cairo >= 0.1.0)

cairo_surface_mark_dirty — Description

Açıklama

void cairo_surface_mark_dirty ( CairoSurface $surface )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

surface

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_surface_mark_dirty() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_surface_mark_dirty_rectangle
cairo_surface_set_device_offset
Cairo İşlevleri


Description

cairo_surface_mark_dirty
cairo_surface_set_fallback_resolution
Cairo İşlevleri
PHP Manual

cairo_surface_set_device_offset

(PECL cairo >= 0.1.0)

cairo_surface_set_device_offset — Description

Açıklama

void cairo_surface_set_device_offset ( CairoSurface $surface , float $x , float $y )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

surface

Description...

x

Description...

y

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_surface_set_device_offset() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_surface_mark_dirty
cairo_surface_set_fallback_resolution
Cairo İşlevleri


Description

cairo_surface_set_device_offset
cairo_surface_show_page
Cairo İşlevleri
PHP Manual

cairo_surface_set_fallback_resolution

(PECL cairo >= 0.1.0)

cairo_surface_set_fallback_resolution — Description

Açıklama

void cairo_surface_set_fallback_resolution ( CairoSurface $surface , float $x , float $y )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

surface

Description...

x

Description...

y

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_surface_set_fallback_resolution() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_surface_set_device_offset
cairo_surface_show_page
Cairo İşlevleri


Description

cairo_surface_set_fallback_resolution
cairo_surface_status
Cairo İşlevleri
PHP Manual

cairo_surface_show_page

(PECL cairo >= 0.1.0)

cairo_surface_show_page — Description

Açıklama

void cairo_surface_show_page ( CairoSurface $surface )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

surface

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_surface_show_page() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_surface_set_fallback_resolution
cairo_surface_status
Cairo İşlevleri


Description

cairo_surface_show_page
cairo_surface_write_to_png
Cairo İşlevleri
PHP Manual

cairo_surface_status

(PECL cairo >= 0.1.0)

cairo_surface_status — Description

Açıklama

int cairo_surface_status ( CairoSurface $surface )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

surface

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_surface_status() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_surface_show_page
cairo_surface_write_to_png
Cairo İşlevleri


Description

cairo_surface_status
cairo_svg_surface_create
Cairo İşlevleri
PHP Manual

cairo_surface_write_to_png

(PECL cairo >= 0.1.0)

cairo_surface_write_to_png — Description

Açıklama

void cairo_surface_write_to_png ( CairoSurface $surface , resource $stream )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

surface

Description...

stream

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_surface_write_to_png() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_surface_status
cairo_svg_surface_create
Cairo İşlevleri


Description

cairo_surface_write_to_png
cairo_svg_surface_restrict_to_version
Cairo İşlevleri
PHP Manual

cairo_svg_surface_create

(PECL cairo >= 0.1.0)

cairo_svg_surface_create — Description

Açıklama

CairoSvgSurface cairo_svg_surface_create ( string $file , float $width , float $height )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

file

Description...

width

Description...

height

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_svg_surface_create() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_surface_write_to_png
cairo_svg_surface_restrict_to_version
Cairo İşlevleri


Description

cairo_svg_surface_create
cairo_svg_version_to_string
Cairo İşlevleri
PHP Manual

cairo_svg_surface_restrict_to_version

(PECL cairo >= 0.1.0)

cairo_svg_surface_restrict_to_version — Description

Açıklama

void cairo_svg_surface_restrict_to_version ( CairoSvgSurface $surface , int $version )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

surface

Description...

version

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_svg_surface_restrict_to_version() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_svg_surface_create
cairo_svg_version_to_string
Cairo İşlevleri


Description

cairo_svg_surface_restrict_to_version
Cairo
Cairo İşlevleri
PHP Manual

cairo_svg_version_to_string

(PECL cairo >= 0.1.0)

cairo_svg_version_to_string — Description

Açıklama

string cairo_svg_version_to_string ( int $version )

The function description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

version

Description...

Dönen Değerler

What is returned on success and failure

Hatalar/İstisnalar

When does this function issue E_* level errors, and/or throw exceptions.

Örnekler

Örnek 1 cairo_svg_version_to_string() example

Any text that describes the purpose of the example, or what goes on in the example should be here.

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • related function name here()

cairo_svg_surface_restrict_to_version
Cairo
Cairo İşlevleri


The Cairo class

(PECL cairo >= 0.1.0)

Giriş

Simple class with some static helper methods.

Sınıf Sözdizimi

Cairo {
/* Yöntemler */
public static array availableFonts ( void )
public static array availableSurfaces ( void )
public static string statusToString ( int $status )
public static int version ( void )
public static string versionString ( void )
}

İçindekiler

  • Cairo::availableFonts — Retrieves the availables font types
  • Cairo::availableSurfaces — Retrieves all available surfaces
  • Cairo::statusToString — Retrieves the current status as string
  • Cairo::version — Retrives cairo's library version
  • Cairo::versionString — Retrieves cairo version as string
cairo_svg_version_to_string
Cairo::availableFonts
Cairo


Retrieves the availables font types

Cairo
Cairo::availableSurfaces
Cairo
PHP Manual

Cairo::availableFonts

cairo_available_fonts

(PECL cairo >= 0.1.0)

Cairo::availableFonts -- cairo_available_fonts — Retrieves the availables font types

Açıklama

Nesne yönelimli kullanım:

public static array Cairo::availableFonts ( void )

Yordamsal kullanım:

array cairo_available_fonts ( void )

Returns an array with the available font backends

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A list-type array with all available font backends.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php

/* Object Oriented Style */
var_dump(Cairo::availableFonts());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(2) {
  [0]=>
  string(5) "WIN32"
  [1]=>
  string(4) "USER"
}

Örnek 2 Yordamsal kullanım

<?php

/* Procedural style */
var_dump(cairo_available_fonts());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(2) {
  [0]=>
  string(5) "WIN32"
  [1]=>
  string(4) "USER"
}

Ayrıca Bakınız

  • Cairo::availableSurfaces() - Retrieves all available surfaces

Cairo
Cairo::availableSurfaces
Cairo


Retrieves all available surfaces

Cairo::availableFonts
Cairo::statusToString
Cairo
PHP Manual

Cairo::availableSurfaces

cairo_available_surfaces

(PECL cairo >= 0.1.0)

Cairo::availableSurfaces -- cairo_available_surfaces — Retrieves all available surfaces

Açıklama

Nesne yönelimli kullanım (method):

public static array Cairo::availableSurfaces ( void )

Yordamsal kullanım:

array cairo_available_surfaces ( void )

Returns an array with the available surface backends

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A list-type array with all available surface backends.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php

/* Object Oriented style */
var_dump(Cairo::availableSurfaces());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(6) {
  [0]=>
  string(5) "IMAGE"
  [1]=>
  string(3) "PNG"
  [2]=>
  string(3) "PDF"
  [3]=>
  string(2) "PS"
  [4]=>
  string(3) "SVG"
  [5]=>
  string(5) "WIN32"
}

Örnek 2 Yordamsal kullanım

<?php

/* Procedural style */
var_dump(cairo_available_surfaces());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(6) {
  [0]=>
  string(5) "IMAGE"
  [1]=>
  string(3) "PNG"
  [2]=>
  string(3) "PDF"
  [3]=>
  string(2) "PS"
  [4]=>
  string(3) "SVG"
  [5]=>
  string(5) "WIN32"
}

Ayrıca Bakınız

  • Cairo::availableFonts() - Retrieves the availables font types

Cairo::availableFonts
Cairo::statusToString
Cairo


Retrieves the current status as string

Cairo::availableSurfaces
Cairo::version
Cairo
PHP Manual

Cairo::statusToString

cairo_status_to_string

(PECL cairo >= 0.1.0)

Cairo::statusToString -- cairo_status_to_string — Retrieves the current status as string

Açıklama

Nesne yönelimli kullanım (method):

public static string Cairo::statusToString ( int $status )

Yordamsal kullanım:

string cairo_status_to_string ( int $status )

Retrieves the current status as a readable string

Değiştirgeler

status

A valid status code given by cairo_status() or CairoContext::status()

Dönen Değerler

A string containing the current status of a CairoContext object

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$surface = new CairoImageSurface(CairoFormat::ARGB32, 50, 50);
$context = new CairoContext($surface);

var_dump(Cairo::statusToString($context->status()));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(7) "success"

Örnek 2 Yordamsal kullanım

<?php
$surface = cairo_image_surface_create(CAIRO_FORMAT_ARGB32, 50, 50);
$context = cairo_create($surface);

var_dump(cairo_status_to_string(cairo_status($context)));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(7) "success"

Ayrıca Bakınız

  • CairoContext::status() - The status purpose

Cairo::availableSurfaces
Cairo::version
Cairo


Retrives cairo's library version

Cairo::statusToString
Cairo::versionString
Cairo
PHP Manual

Cairo::version

cairo_version

(PECL cairo >= 0.1.0)

Cairo::version -- cairo_version — Retrives cairo's library version

Açıklama

Nesne yönelimli kullanım (method):

public static int Cairo::version ( void )

Yordamsal kullanım:

int cairo_version ( void )

Retrieves the current version of the cairo library as an integer value

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Current Cairo library version integer

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
var_dump(Cairo::version());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(10808)

Örnek 2 Yordamsal kullanım

<?php
var_dump(cairo_version());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(10808)

Ayrıca Bakınız

  • Cairo::versionString() - Retrieves cairo version as string

Cairo::statusToString
Cairo::versionString
Cairo


Retrieves cairo version as string

Cairo::version
CairoContext
Cairo
PHP Manual

Cairo::versionString

cairo_version_string

(PECL cairo >= 0.1.0)

Cairo::versionString -- cairo_version_string — Retrieves cairo version as string

Açıklama

Nesne yönelimli kullanım (method):

public static string Cairo::versionString ( void )

Yordamsal kullanım:

string cairo_version_string ( void )

Retrieves the current cairo library version as a string.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Current Cairo library version string

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php

var_dump(Cairo::versionString());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(5) "1.8.8"

Örnek 2 Yordamsal kullanım

<?php

var_dump(cairo_version_string());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(5) "1.8.8"

Ayrıca Bakınız

  • Cairo::version() - Retrives cairo's library version

Cairo::version
CairoContext
Cairo


The CairoContext class

(PECL cairo >= 0.1.0)

Giriş

Context is the main object used when drawing with cairo. To draw with cairo, you create a CairoContext, set the target CairoSurface, and drawing options for the CairoContext, create shapes with functions . like CairoContext::moveTo() and CairoContext::lineTo(), and then draw shapes with CairoContext::stroke() or CairoContext::fill(). Contexts can be pushed to a stack via CairoContext::save(). They may then safely be changed, without loosing the current state. Use CairoContext::restore() to restore to the saved state.

Sınıf Sözdizimi

CairoContext {
/* Yöntemler */
public void appendPath ( CairoPath $path )
public void arc ( float $x , float $y , float $radius , float $angle1 , float $angle2 )
public void arcNegative ( float $x , float $y , float $radius , float $angle1 , float $angle2 )
public void clip ( void )
public array clipExtents ( void )
public void clipPreserve ( void )
public array clipRectangleList ( void )
public void closePath ( void )
public __construct ( CairoSurface $surface )
public void copyPage ( void )
public CairoPath copyPath ( void )
public CairoPath copyPathFlat ( void )
public void curveTo ( float $x1 , float $y1 , float $x2 , float $y2 , float $x3 , float $y3 )
public array deviceToUser ( float $x , float $y )
public array deviceToUserDistance ( float $x , float $y )
public void fill ( void )
public array fillExtents ( void )
public void fillPreserve ( void )
public array fontExtents ( void )
public int getAntialias ( void )
public array getCurrentPoint ( void )
public array getDash ( void )
public int getDashCount ( void )
public int getFillRule ( void )
public void getFontFace ( void )
public void getFontMatrix ( void )
public void getFontOptions ( void )
public void getGroupTarget ( void )
public int getLineCap ( void )
public int getLineJoin ( void )
public float getLineWidth ( void )
public void getMatrix ( void )
public float getMiterLimit ( void )
public int getOperator ( void )
public void getScaledFont ( void )
public void getSource ( void )
public void getTarget ( void )
public float getTolerance ( void )
public void glyphPath ( array $glyphs )
public bool hasCurrentPoint ( void )
public void identityMatrix ( void )
public bool inFill ( string $x , string $y )
public bool inStroke ( string $x , string $y )
public void lineTo ( string $x , string $y )
public void mask ( string $pattern )
public void maskSurface ( string $surface [, string $x [, string $y ]] )
public void moveTo ( string $x , string $y )
public void newPath ( void )
public void newSubPath ( void )
public void paint ( void )
public void paintWithAlpha ( string $alpha )
public array pathExtents ( void )
public void popGroup ( void )
public void popGroupToSource ( void )
public void pushGroup ( void )
public void pushGroupWithContent ( string $content )
public void rectangle ( string $x , string $y , string $width , string $height )
public void relCurveTo ( string $x1 , string $y1 , string $x2 , string $y2 , string $x3 , string $y3 )
public void relLineTo ( string $x , string $y )
public void relMoveTo ( string $x , string $y )
public void resetClip ( void )
public void restore ( void )
public void rotate ( string $angle )
public void save ( void )
public void scale ( string $x , string $y )
public void selectFontFace ( string $family [, string $slant [, string $weight ]] )
public void setAntialias ([ string $antialias ] )
public void setDash ( string $dashes [, string $offset ] )
public void setFillRule ( string $setting )
public void setFontFace ( CairoFontFace $fontface )
public void setFontMatrix ( string $matrix )
public void setFontOptions ( string $fontoptions )
public void setFontSize ( string $size )
public void setLineCap ( string $setting )
public void setLineJoin ( string $setting )
public void setLineWidth ( string $width )
public void setMatrix ( string $matrix )
public void setMiterLimit ( string $limit )
public void setOperator ( string $setting )
public void setScaledFont ( string $scaledfont )
public void setSource ( string $pattern )
public void setSourceRGB ( string $red , string $green , string $blue )
public void setSourceRGBA ( string $red , string $green , string $blue , string $alpha )
public void setSourceSurface ( string $surface [, string $x [, string $y ]] )
public void setTolerance ( string $tolerance )
public void showPage ( void )
public void showText ( string $text )
public int status ( void )
public void stroke ( void )
public array strokeExtents ( void )
public void strokePreserve ( void )
public array textExtents ( string $text )
public void textPath ( string $string )
public void transform ( string $matrix )
public void translate ( string $x , string $y )
public array userToDevice ( string $x , string $y )
public array userToDeviceDistance ( string $x , string $y )
}

İçindekiler

  • CairoContext::appendPath — Appends a path to current path
  • CairoContext::arc — Adds a circular arc
  • CairoContext::arcNegative — Adds a negative arc
  • CairoContext::clip — Establishes a new clip region
  • CairoContext::clipExtents — Computes the area inside the current clip
  • CairoContext::clipPreserve — Establishes a new clip region from the current clip
  • CairoContext::clipRectangleList — Retrieves the current clip as a list of rectangles
  • CairoContext::closePath — Closes the current path
  • CairoContext::__construct — Creates a new CairoContext
  • CairoContext::copyPage — Emits the current page
  • CairoContext::copyPath — Creates a copy of the current path
  • CairoContext::copyPathFlat — Gets a flattened copy of the current path
  • CairoContext::curveTo — Adds a curve
  • CairoContext::deviceToUser — Transform a coordinate
  • CairoContext::deviceToUserDistance — Transform a distance
  • CairoContext::fill — Fills the current path
  • CairoContext::fillExtents — Computes the filled area
  • CairoContext::fillPreserve — Fills and preserve the current path
  • CairoContext::fontExtents — Get the font extents
  • CairoContext::getAntialias — Retrives the current antialias mode
  • CairoContext::getCurrentPoint — The getCurrentPoint purpose
  • CairoContext::getDash — The getDash purpose
  • CairoContext::getDashCount — The getDashCount purpose
  • CairoContext::getFillRule — The getFillRule purpose
  • CairoContext::getFontFace — The getFontFace purpose
  • CairoContext::getFontMatrix — The getFontMatrix purpose
  • CairoContext::getFontOptions — The getFontOptions purpose
  • CairoContext::getGroupTarget — The getGroupTarget purpose
  • CairoContext::getLineCap — The getLineCap purpose
  • CairoContext::getLineJoin — The getLineJoin purpose
  • CairoContext::getLineWidth — The getLineWidth purpose
  • CairoContext::getMatrix — The getMatrix purpose
  • CairoContext::getMiterLimit — The getMiterLimit purpose
  • CairoContext::getOperator — The getOperator purpose
  • CairoContext::getScaledFont — The getScaledFont purpose
  • CairoContext::getSource — The getSource purpose
  • CairoContext::getTarget — The getTarget purpose
  • CairoContext::getTolerance — The getTolerance purpose
  • CairoContext::glyphPath — The glyphPath purpose
  • CairoContext::hasCurrentPoint — The hasCurrentPoint purpose
  • CairoContext::identityMatrix — The identityMatrix purpose
  • CairoContext::inFill — The inFill purpose
  • CairoContext::inStroke — The inStroke purpose
  • CairoContext::lineTo — The lineTo purpose
  • CairoContext::mask — The mask purpose
  • CairoContext::maskSurface — The maskSurface purpose
  • CairoContext::moveTo — The moveTo purpose
  • CairoContext::newPath — The newPath purpose
  • CairoContext::newSubPath — The newSubPath purpose
  • CairoContext::paint — The paint purpose
  • CairoContext::paintWithAlpha — The paintWithAlpha purpose
  • CairoContext::pathExtents — The pathExtents purpose
  • CairoContext::popGroup — The popGroup purpose
  • CairoContext::popGroupToSource — The popGroupToSource purpose
  • CairoContext::pushGroup — The pushGroup purpose
  • CairoContext::pushGroupWithContent — The pushGroupWithContent purpose
  • CairoContext::rectangle — The rectangle purpose
  • CairoContext::relCurveTo — The relCurveTo purpose
  • CairoContext::relLineTo — The relLineTo purpose
  • CairoContext::relMoveTo — The relMoveTo purpose
  • CairoContext::resetClip — The resetClip purpose
  • CairoContext::restore — The restore purpose
  • CairoContext::rotate — The rotate purpose
  • CairoContext::save — The save purpose
  • CairoContext::scale — The scale purpose
  • CairoContext::selectFontFace — The selectFontFace purpose
  • CairoContext::setAntialias — The setAntialias purpose
  • CairoContext::setDash — The setDash purpose
  • CairoContext::setFillRule — The setFillRule purpose
  • CairoContext::setFontFace — The setFontFace purpose
  • CairoContext::setFontMatrix — The setFontMatrix purpose
  • CairoContext::setFontOptions — The setFontOptions purpose
  • CairoContext::setFontSize — The setFontSize purpose
  • CairoContext::setLineCap — The setLineCap purpose
  • CairoContext::setLineJoin — The setLineJoin purpose
  • CairoContext::setLineWidth — The setLineWidth purpose
  • CairoContext::setMatrix — The setMatrix purpose
  • CairoContext::setMiterLimit — The setMiterLimit purpose
  • CairoContext::setOperator — The setOperator purpose
  • CairoContext::setScaledFont — The setScaledFont purpose
  • CairoContext::setSource — The setSource purpose
  • CairoContext::setSourceRGB — The setSourceRGB purpose
  • CairoContext::setSourceRGBA — The setSourceRGBA purpose
  • CairoContext::setSourceSurface — The setSourceSurface purpose
  • CairoContext::setTolerance — The setTolerance purpose
  • CairoContext::showPage — The showPage purpose
  • CairoContext::showText — The showText purpose
  • CairoContext::status — The status purpose
  • CairoContext::stroke — The stroke purpose
  • CairoContext::strokeExtents — The strokeExtents purpose
  • CairoContext::strokePreserve — The strokePreserve purpose
  • CairoContext::textExtents — The textExtents purpose
  • CairoContext::textPath — The textPath purpose
  • CairoContext::transform — The transform purpose
  • CairoContext::translate — The translate purpose
  • CairoContext::userToDevice — The userToDevice purpose
  • CairoContext::userToDeviceDistance — The userToDeviceDistance purpose
Cairo::versionString
CairoContext::appendPath
Cairo


Appends a path to current path

CairoContext
CairoContext::arc
CairoContext
PHP Manual

CairoContext::appendPath

cairo_append_path

(PECL cairo >= 0.1.0)

CairoContext::appendPath -- cairo_append_path — Appends a path to current path

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::appendPath ( CairoPath $path )

Yordamsal kullanım:

void cairo_append_path ( CairoContext $context , CairoPath $path )

Appends the path onto the current path. The path may be either the return value from one of CairoContext::copyPath() or CairoContext::copyPathFlat();

if path is not a valid CairoPath instance a CairoException will be thrown

Değiştirgeler

context

CairoContext object

path

CairoPath object

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php

$surface = new CairoImageSurface(CairoFormat::ARGB32, 50, 50);

$context = new CairoContext($surface);

$path = $context->copyPath();

$context->appendPath($path);

?>

Örnek 2 Yordamsal kullanım

<?php

$surface = cairo_image_surface_create(CAIRO_FORMAT_ARGB32, 50, 50);

$context = cairo_create($surface);

$path = cairo_copy_path($context);

cairo_append_path($context, $path);

?>

Ayrıca Bakınız

  • CairoPath
  • CairoContext::copyPath() - Creates a copy of the current path
  • CairoContext::copyPathFlat() - Gets a flattened copy of the current path

CairoContext
CairoContext::arc
CairoContext


Adds a circular arc

CairoContext::appendPath
CairoContext::arcNegative
CairoContext
PHP Manual

CairoContext::arc

cairo_arc

(PECL cairo >= 0.1.0)

CairoContext::arc -- cairo_arc — Adds a circular arc

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::arc ( float $x , float $y , float $radius , float $angle1 , float $angle2 )

Yordamsal kullanım:

void cairo_arc ( CairoContext $context , float $x , float $y , float $radius , float $angle1 , float $angle2 )

Adds a circular arc of the given radius to the current path. The arc is centered at (x, y), begins at angle1 and proceeds in the direction of increasing angles to end at angle2. If angle2 is less than angle1 it will be progressively increased by 2*M_PI until it is greater than angle1. If there is a current point, an initial line segment will be added to the path to connect the current point to the beginning of the arc. If this initial line is undesired, it can be avoided by calling CairoContext::newSubPath() or procedural cairo_new_sub_path() before calling CairoContext::arc() or cairo_arc(). Angles are measured in radians. An angle of 0.0 is in the direction of the positive X axis (in user space). An angle of M_PI/2.0 radians (90 degrees) is in the direction of the positive Y axis (in user space). Angles increase in the direction from the positive X axis toward the positive Y axis. So with the default transformation matrix, angles increase in a clockwise direction. (To convert from degrees to radians, use degrees * (M_PI / 180.).) This function gives the arc in the direction of increasing angles; see CairoContext::arcNegative() or cairo_arc_negative() to get the arc in the direction of decreasing angles.

Değiştirgeler

context

A valid CairoContext object

x

x position

y

y position

radius

Radius of the arc

angle1

start angle

angle2

end angle

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php

$s = new CairoImageSurface(CairoFormat::ARGB32, 100, 100);
$c = new CairoContext($s);

$c->setSourceRgb(0, 0, 0);
$c->paint();

$c->setLineWidth(1);
$c->setSourceRgb(1, 1, 1);

for ($r = 50; $r > 0; $r -= 10) {
 $c->arc(50, 50, $r, 0, 2 * M_PI);
 $c->stroke();
 $c->fill();
}

$s->writeToPng(dirname(__FILE__) . '/CairoContext__arc.png');
?>

Örnek 2 Yordamsal kullanım

<?php

$s = cairo_image_surface_create(CAIRO_SURFACE_TYPE_IMAGE, 100, 100);
$c = cairo_create($s);

cairo_set_source_rgb($c, 0, 0, 0);
cairo_paint($c);

cairo_set_source_rgb($c, 1, 1, 1);
cairo_set_line_width($c, 1);

for ($r = 50; $r > 0; $r -= 10) {
 cairo_arc($c, 50, 50, $r, 0, 2 * M_PI);
 cairo_stroke($c);
 cairo_fill($c);
}

cairo_surface_write_to_png($s, dirname(__FILE__) . '/cairo_arc.png');
?>

Ayrıca Bakınız

  • CairoContext::arcNegative() - Adds a negative arc

CairoContext::appendPath
CairoContext::arcNegative
CairoContext


Adds a negative arc

CairoContext::arc
CairoContext::clip
CairoContext
PHP Manual

CairoContext::arcNegative

cairo_arc_negative

(PECL cairo >= 0.1.0)

CairoContext::arcNegative -- cairo_arc_negative — Adds a negative arc

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::arcNegative ( float $x , float $y , float $radius , float $angle1 , float $angle2 )

Yordamsal kullanım:

void cairo_arc_negative ( CairoContext $context , float $x , float $y , float $radius , float $angle1 , float $angle2 )

Adds a circular arc of the given radius to the current path. The arc is centered at (x, y), begins at angle1 and proceeds in the direction of decreasing angles to end at angle2. If angle2 is greater than angle1 it will be progressively decreased by 2*M_PI until it is less than angle1. See CairoContext::arc() or cairo_arc() for more details. This function differs only in the direction of the arc between the two angles.

Değiştirgeler

context

A valid CairoContext object

x

double x position

y

double y position

radius

The radius of the desired negative arc

angle1

Start angle of the arc

angle2

End angle of the arc

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php

$s = new CairoImageSurface(CairoFormat::ARGB32, 100, 100);
$c = new CairoContext($s);

$c->setSourceRgb(0, 0, 0);
$c->paint();

$c->setLineWidth(1);
$c->setSourceRgb(1, 1, 1);

for ($r = 50; $r > 0; $r -= 10) {
 $c->arcNegative(50, 50, $r, 2 * M_PI, 0);
 $c->stroke();
 $c->fill();
}

$s->writeToPng(dirname(__FILE__) . '/CairoContext__arcNegative.png');
?>

Örnek 2 Yordamsal kullanım

<?php

$s = cairo_image_surface_create(CAIRO_SURFACE_TYPE_IMAGE, 100, 100);
$c = cairo_create($s);

cairo_set_source_rgb($c, 0, 0, 0);
cairo_paint($c);

cairo_set_source_rgb($c, 1, 1, 1);
cairo_set_line_width($c, 1);

for ($r = 50; $r > 0; $r -= 10) {
 cairo_arc_negative($c, 50, 50, $r, 2 * M_PI, 0);
 cairo_stroke($c);
 cairo_fill($c);
}

cairo_surface_write_to_png($s, dirname(__FILE__) . '/cairo_arc_negative.png');
?>

Ayrıca Bakınız

  • CairoContext::arc() - Adds a circular arc

CairoContext::arc
CairoContext::clip
CairoContext


Establishes a new clip region

CairoContext::arcNegative
CairoContext::clipExtents
CairoContext
PHP Manual

CairoContext::clip

cairo_clip

(PECL cairo >= 0.1.0)

CairoContext::clip -- cairo_clip — Establishes a new clip region

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::clip ( void )

Yordamsal kullanım:

void cairo_clip ( CairoContext $context )

Establishes a new clip region by intersecting the current clip region with the current path as it would be filled by CairoContext::fill() or cairo_fill() and according to the current fill rule (see CairoContext::setFillRule() or cairo_set_fill_rule()).

After CairoContext::clip() or cairo_clip(), the current path will be cleared from the cairo context.

The current clip region affects all drawing operations by effectively masking out any changes to the surface that are outside the current clip region.

Calling CairoContext::clip() or cairo_clip()
can only make the clip region smaller, never larger. But the current clip is part of the
graphics state, so a temporary restriction of the clip region can be achieved by calling
CairoContext::clip() or cairo_clip() within a
CairoContext::save()/CairoContext::restore() or
cairo_save()/cairo_restore() pair.
The only other means of increasing the size of the clip region is
CairoContext::resetClip() or procedural cairo_reset_clip().

Değiştirgeler

context

A valid CairoContext object

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php

$surface = new CairoImageSurface(CairoFormat::ARGB32, 50, 50);

$context = new CairoContext($surface);

$context->clip();

?>

Örnek 2 Yordamsal kullanım

<?php

$surface = cairo_image_surface_create(CAIRO_FORMAT_ARGB32, 50, 50);

$context = cairo_create($surface);

cairo_clip($context);

?>

Ayrıca Bakınız

  • CairoContext::resetClip() - The resetClip purpose
  • cairo_reset_clip() - The resetClip purpose

CairoContext::arcNegative
CairoContext::clipExtents
CairoContext


Computes the area inside the current clip

CairoContext::clip
CairoContext::clipPreserve
CairoContext
PHP Manual

CairoContext::clipExtents

cairo_clip_extents

(PECL cairo >= 0.1.0)

CairoContext::clipExtents -- cairo_clip_extents — Computes the area inside the current clip

Açıklama

Nesne yönelimli kullanım (method):

public array CairoContext::clipExtents ( void )

Yordamsal kullanım:

array cairo_clip_extents ( CairoContext $context )

Computes a bounding box in user coordinates covering the area inside the current clip.

Değiştirgeler

context

A valid CairoContext object

Dönen Değerler

An array containing the (float)x1, (float)y1, (float)x2, (float)y2, coordinates covering the area inside the current clip

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php

$surface = new CairoImageSurface(CairoFormat::ARGB32, 50, 50);

$context = new CairoContext($surface);

var_dump($context->clipExtents());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(4) {
  [0]=>
  float(0)
  [1]=>
  float(0)
  [2]=>
  float(50)
  [3]=>
  float(50)
}

Örnek 2 Yordamsal kullanım

<?php

$surface = cairo_image_surface_create(CAIRO_FORMAT_ARGB32, 50, 50);

$context = cairo_create($surface);

var_dump(cairo_clip_extents($context));

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(4) {
  [0]=>
  float(0)
  [1]=>
  float(0)
  [2]=>
  float(50)
  [3]=>
  float(50)
}

Ayrıca Bakınız

  • CairoContext::clip() - Establishes a new clip region

CairoContext::clip
CairoContext::clipPreserve
CairoContext


Establishes a new clip region from the current clip

CairoContext::clipExtents
CairoContext::clipRectangleList
CairoContext
PHP Manual

CairoContext::clipPreserve

cairo_clip_preserve

(PECL cairo >= 0.1.0)

CairoContext::clipPreserve -- cairo_clip_preserve — Establishes a new clip region from the current clip

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::clipPreserve ( void )

Yordamsal kullanım:

void cairo_clip_preserve ( CairoContext $context )

Establishes a new clip region by intersecting the current clip region with the current path as it would be filled by Context.fill() and according to the current FILL RULE (see CairoContext::setFillRule() or cairo_set_fill_rule()).

Unlike CairoContext::clip(), CairoContext::clipPreserve() preserves the path within the Context. The current clip region affects all drawing operations by effectively masking out any changes to the surface that are outside the current clip region.

Calling CairoContext::clipPreserve() can only make the clip region smaller, never larger. But the current clip is part of the graphics state, so a temporary restriction of the clip region can be achieved by calling CairoContext::clipPreserve() within a CairoContext::save()/CairoContext::restore() pair. The only other means of increasing the size of the clip region is CairoContext::resetClip().

Değiştirgeler

context

A valid CairoContext object

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php

$surface = new CairoImageSurface(CairoFormat::ARGB32, 50, 50);

$context = new CairoContext($surface);

$context->clipPreserve();

?>

Örnek 2 Yordamsal kullanım

<?php

$surface = cairo_image_surface_create(CAIRO_FORMAT_ARGB32, 50, 50);

$context = cairo_create($surface);

cairo_clip_preserve($context);

?>

Ayrıca Bakınız

  • CairoContext::save() - The save purpose
  • CairoContext::restore() - The restore purpose
  • CairoContext::resetClip() - The resetClip purpose

CairoContext::clipExtents
CairoContext::clipRectangleList
CairoContext


Retrieves the current clip as a list of rectangles

CairoContext::clipPreserve
CairoContext::closePath
CairoContext
PHP Manual

CairoContext::clipRectangleList

cairo_clip_rectangle_list

(PECL cairo >= 0.1.0)

CairoContext::clipRectangleList -- cairo_clip_rectangle_list — Retrieves the current clip as a list of rectangles

Açıklama

Nesne yönelimli kullanım (method):

public array CairoContext::clipRectangleList ( void )

Yordamsal kullanım:

array cairo_clip_rectangle_list ( CairoContext $context )

Returns a list-type array with the current clip region as a list of rectangles in user coordinates

Değiştirgeler

context

A valid CairoContext object created with CairoContext::__construct() or cairo_create()

Dönen Değerler

An array of user-space represented rectangles for the current clip

(The status in the list may be CAIRO_STATUS_CLIP_NOT_REPRESENTABLE to indicate that the clip region cannot be represented as a list of user-space rectangles. The status may have other values to indicate other errors.)

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php

$surface = new CairoImageSurface(CairoFormat::ARGB32, 50, 50);

$context = new CairoContext($surface);

var_dump($context->clipRectangleList());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(1) {
  [0]=>
  array(4) {
    ["x"]=>
    float(0)
    ["y"]=>
    float(0)
    ["width"]=>
    float(50)
    ["height"]=>
    float(50)
  }
}

Örnek 2 Yordamsal kullanım

<?php

$surface = cairo_image_surface_create(CAIRO_FORMAT_ARGB32, 50, 50);

$context = cairo_create($surface);

var_dump(cairo_clip_rectangle_list($context));

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(1) {
  [0]=>
  array(4) {
    ["x"]=>
    float(0)
    ["y"]=>
    float(0)
    ["width"]=>
    float(50)
    ["height"]=>
    float(50)
  }
}

Ayrıca Bakınız

  • Classname::Method()

CairoContext::clipPreserve
CairoContext::closePath
CairoContext


Closes the current path

CairoContext::clipRectangleList
CairoContext::__construct
CairoContext
PHP Manual

CairoContext::closePath

cairo_close_path

(PECL cairo >= 0.1.0)

CairoContext::closePath -- cairo_close_path — Closes the current path

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::closePath ( void )

Yordamsal kullanım:

void cairo_close_path ( CairoContext $context )

Adds a line segment to the path from the current point to the beginning of the current sub-path, (the most recent point passed to CairoContext::moveTo()), and closes this sub-path. After this call the current point will be at the joined endpoint of the sub-path.

The behavior of close_path() is distinct from simply calling CairoContext::lineTo() with the equivalent coordinate in the case of stroking. When a closed sub-path is stroked, there are no caps on the ends of the sub-path. Instead, there is a line join connecting the final and initial segments of the sub-path.

If there is no current point before the call to CairoContext::closePath(), this function will have no effect.

Değiştirgeler

context

A valid CairoContext object created with CairoContext::__construct() or cairo_create()

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php

$surface = new CairoImageSurface(CairoFormat::ARGB32, 50, 50);

$context = new CairoContext($surface);

$context->closePath();

?>

Örnek 2 Yordamsal kullanım

<?php

$surface = cairo_image_surface_create(CAIRO_FORMAT_ARGB32, 50, 50);

$context = cairo_create($surface);

cairo_close_path($context);

?>

Ayrıca Bakınız

  • CairoContext::copyPath() - Creates a copy of the current path

CairoContext::clipRectangleList
CairoContext::__construct
CairoContext


Creates a new CairoContext

CairoContext::closePath
CairoContext::copyPage
CairoContext
PHP Manual

CairoContext::__construct

(PECL cairo >= 0.1.0)

CairoContext::__construct — Creates a new CairoContext

Açıklama

public CairoContext::__construct ( CairoSurface $surface )

Creates a new CairoContext object to draw

Değiştirgeler

surface

A valid CairoSurface like CairoImageSurface or CairoPdfSurface

Dönen Değerler

A CairoContext

Örnekler

Örnek 1 CairoContext::__construct() example

<?php
// The surface to work on
$surface = new CairoImageSurface(CairoFormat::ARGB32, 50, 50);

// Create a new CairoContext for the CairoSurface
$context = new CairoContext($surface);

?>

Ayrıca Bakınız

  • Cairo::Method()

CairoContext::closePath
CairoContext::copyPage
CairoContext


Emits the current page

CairoContext::__construct
CairoContext::copyPath
CairoContext
PHP Manual

CairoContext::copyPage

cairo_copy_page

(PECL cairo >= 0.1.0)

CairoContext::copyPage -- cairo_copy_page — Emits the current page

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::copyPage ( void )

Yordamsal kullanım:

void cairo_copy_page ( CairoContext $context )

Emits the current page for backends that support multiple pages, but doesn't clear it, so, the contents of the current page will be retained for the next page too. Use CairoContext::showPage() if you want to get an empty page after the emission.

This is a convenience function that simply calls CairoSurface::copyPage() on CairoContext's target.

Değiştirgeler

context

A valid CairoContext object created with CairoContext::__construct() or cairo_create()

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php

$surface = new CairoImageSurface(CairoFormat::ARGB32, 50, 50);

$context = new CairoContext($surface);

$context->copyPage();

?>

Örnek 2 Yordamsal kullanım

<?php

$surface = cairo_image_surface_create(CAIRO_FORMAT_ARGB32, 50, 50);

$context = cairo_create($surface);

cairo_copy_page($context);

?>

Ayrıca Bakınız

  • CairoContext::showPage() - The showPage purpose
  • CairoSurface::copyPage() - The copyPage purpose

CairoContext::__construct
CairoContext::copyPath
CairoContext


Creates a copy of the current path

CairoContext::copyPage
CairoContext::copyPathFlat
CairoContext
PHP Manual

CairoContext::copyPath

cairo_copy_path

(PECL cairo >= 0.1.0)

CairoContext::copyPath -- cairo_copy_path — Creates a copy of the current path

Açıklama

Nesne yönelimli kullanım (method):

public CairoPath CairoContext::copyPath ( void )

Yordamsal kullanım:

CairoPath cairo_copy_path ( CairoContext $context )

Creates a copy of the current path and returns it to the user as a CairoPath. See CairoPath for hints on how to iterate over the returned data structure.

This function will always return a valid CairoPath object, but the result will have no data, if either of the following conditions hold:

  • 1. If there is insufficient memory to copy the path. In this case CairoPath->status will be set to CAIRO_STATUS_NO_MEMORY.
  • 2. If context is already in an error state. In this case CairoPath->status will contain the same status that would be returned by cairo_status().
In either case, CairoPath->status will be set to CAIRO_STATUS_NO_MEMORY (regardless of what the error status in cr might have been).

Değiştirgeler

context

A valid CairoContext object created with CairoContext::__construct() or cairo_create()

Dönen Değerler

A copy of the current CairoPath in the context

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php

$surface = new CairoImageSurface(CairoFormat::ARGB32, 50, 50);

$context = new CairoContext($surface);

var_dump($context->copyPath())

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(CairoPath)#3 (0) {
}

Örnek 2 Yordamsal kullanım

<?php

$surface = cairo_image_surface_create(CAIRO_FORMAT_ARGB32, 50, 50);

$context = cairo_create($surface);

var_dump(cairo_copy_path($context));

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(CairoPath)#3 (0) {
}

Ayrıca Bakınız

  • CairoContext::closePath() - Closes the current path

CairoContext::copyPage
CairoContext::copyPathFlat
CairoContext


Gets a flattened copy of the current path

CairoContext::copyPath
CairoContext::curveTo
CairoContext
PHP Manual

CairoContext::copyPathFlat

cairo_copy_path_flat

(PECL cairo >= 0.1.0)

CairoContext::copyPathFlat -- cairo_copy_path_flat — Gets a flattened copy of the current path

Açıklama

Nesne yönelimli kullanım (method):

public CairoPath CairoContext::copyPathFlat ( void )

Yordamsal kullanım:

CairoPath cairo_copy_path_flat ( CairoContext $context )

Gets a flattened copy of the current path and returns it to the user as a CairoPath.

This function is like CairoContext::copyPath() except that any curves in the path will be approximated with piecewise-linear approximations, (accurate to within the current tolerance value). That is, the result is guaranteed to not have any elements of type CAIRO_PATH_CURVE_TO which will instead be replaced by a series of CAIRO_PATH_LINE_TO elements.

Değiştirgeler

context

A CairoContext object

Dönen Değerler

A copy of the current path

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php

$surface = new CairoImageSurface(CairoFormat::ARGB32, 50, 50);

$context = new CairoContext($surface);

var_dump($context->copyPathFlat());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(CairoPath)#3 (0) {
}

Örnek 2 Yordamsal kullanım

<?php

$surface = cairo_image_surface_create(CAIRO_FORMAT_ARGB32, 50, 50);

$context = cairo_create($surface);

var_dump(cairo_copy_path_flat($context));

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(CairoPath)#3 (0) {
}

Ayrıca Bakınız

  • CairoContext::copyPath() - Creates a copy of the current path
  • CairoContext::closePath() - Closes the current path

CairoContext::copyPath
CairoContext::curveTo
CairoContext


Adds a curve

CairoContext::copyPathFlat
CairoContext::deviceToUser
CairoContext
PHP Manual

CairoContext::curveTo

cairo_curve_to

(PECL cairo >= 0.1.0)

CairoContext::curveTo -- cairo_curve_to — Adds a curve

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::curveTo ( float $x1 , float $y1 , float $x2 , float $y2 , float $x3 , float $y3 )

Yordamsal kullanım:

void cairo_curve_to ( CairoContext $context , float $x1 , float $y1 , float $x2 , float $y2 , float $x3 , float $y3 )

Adds a cubic Bezier spline to the path from the current point to position x3 ,y3 in user-space coordinates, using x1, y1 and x2, y2 as the control points. After this call the current point will be x3, y3.

If there is no current point before the call to CairoContext::curveTo() this function will behave as if preceded by a call to CairoContext::moveTo() (x1, y1).

Değiştirgeler

context

A valid CairoContext object created with CairoContext::__construct() or cairo_create()

x1

First control point in the x axis for the curve

y1

First control point in the y axis for the curve

x2

Second control point in x axis for the curve

y2

Second control point in y axis for the curve

x3

Final point in the x axis for the curve

y3

Final point in the y axis for the curve

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
$s = new CairoImageSurface(CairoFormat::ARGB32, 100, 100);
$c = new CairoContext($s);

$c->setSourceRgb(0, 0, 0);

$c->paint();

$c->moveTo(10, 50);
$c->setLineWidth(5);
$c->setSourceRgb(.1, 0, 1);
$c->curveTo(20, 80, 80, 20, 90, 50);
$c->stroke();

$s->writeToPng(dirname(__FILE__) . '/curveTo.png');
?>

Örnek 2 Yordamsal kullanım

<?php

$s = cairo_image_surface_create(CAIRO_SURFACE_TYPE_IMAGE, 100, 100);
$c = cairo_create($s);

cairo_set_source_rgb($c, 0, 0, 0);

cairo_paint($c);

cairo_move_to($c, 10, 50);
cairo_set_line_width($c, 5);
cairo_set_source_rgb($c, .1, 0, 1);
cairo_curve_to($c, 20, 80, 80, 20, 90, 50);
cairo_stroke($c);

cairo_surface_write_to_png($s, dirname(__FILE__) . '/curve_to.png');
?>

Ayrıca Bakınız

  • CairoContext::moveTo() - The moveTo purpose

CairoContext::copyPathFlat
CairoContext::deviceToUser
CairoContext


Transform a coordinate

CairoContext::curveTo
CairoContext::deviceToUserDistance
CairoContext
PHP Manual

CairoContext::deviceToUser

cairo_device_to_user

(PECL cairo >= 0.1.0)

CairoContext::deviceToUser -- cairo_device_to_user — Transform a coordinate

Açıklama

Nesne yönelimli kullanım (method):

public array CairoContext::deviceToUser ( float $x , float $y )

Yordamsal kullanım:

array cairo_device_to_user ( CairoContext $context , float $x , float $y )

Transform a coordinate from device space to user space by multiplying the given point by the inverse of the current transformation matrix (CTM).

Değiştirgeler

context

A valid CairoContext object created with CairoContext::__construct() or cairo_create()

x

x value of the coordinate

y

y value of the coordinate

Dönen Değerler

An array containing the x and y coordinates in the user-space

Ayrıca Bakınız

  • CairoContext::deviceToUserDistance() - Transform a distance

CairoContext::curveTo
CairoContext::deviceToUserDistance
CairoContext


Transform a distance

CairoContext::deviceToUser
CairoContext::fill
CairoContext
PHP Manual

CairoContext::deviceToUserDistance

cairo_device_to_user_distance

(PECL cairo >= 0.1.0)

CairoContext::deviceToUserDistance -- cairo_device_to_user_distance — Transform a distance

Açıklama

Nesne yönelimli kullanım (method):

public array CairoContext::deviceToUserDistance ( float $x , float $y )

Yordamsal kullanım:

array cairo_device_to_user_distance ( CairoContext $context , float $x , float $y )

Transform a distance vector from device space to user space. This function is similar to CairoContext::deviceToUser() or cairo_device_to_user() except that the translation components of the inverse Cairo Transformation Matrix will be ignored when transforming (x,y).

Değiştirgeler

context

A valid CairoContext object created with CairoContext::__construct() or cairo_create()

x

X component of a distance vector

y

Y component of a distance vector

Dönen Değerler

Returns an array with the x and y values of a distance vector in the user-space

Ayrıca Bakınız

  • CairoContext::deviceToUser() - Transform a coordinate

CairoContext::deviceToUser
CairoContext::fill
CairoContext


Fills the current path

CairoContext::deviceToUserDistance
CairoContext::fillExtents
CairoContext
PHP Manual

CairoContext::fill

cairo_fill

(PECL cairo >= 0.1.0)

CairoContext::fill -- cairo_fill — Fills the current path

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::fill ( void )

Yordamsal kullanım:

void cairo_fill ( CairoContext $context )

A drawing operator that fills the current path according to the current CairoFillRule, (each sub-path is implicitly closed before being filled). After CairoContext::fill() or cairo_fill(), the current path will be cleared from the CairoContext.

Değiştirgeler

context

A valid CairoContext object created with CairoContext::__construct() or cairo_create()

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php

$s = new CairoImageSurface(CairoFormat::ARGB32, 100, 100);
$c = new CairoContext($s);

$c->setSourceRgb(0, 0, 0);
$c->paint();

$c->setSourceRgb(1, 1, 1);
$c->rectangle(0, 0, 50, 50);
$c->fill();
$c->setSourceRgb(0, 1, 0);
$c->rectangle(50, 50, 50, 50);
$c->fill();

$s->writeToPng(dirname(__FILE__) . '/CairoContext_fill.png');

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php

$s = cairo_image_surface_create(CAIRO_SURFACE_TYPE_IMAGE, 100, 100);
$c = cairo_create($s);

cairo_set_source_rgb($c, 0, 0, 0);
cairo_paint($c);

cairo_set_source_rgb($c, 1, 1, 1);
cairo_rectangle($c, 0, 0, 50, 50);
cairo_fill($c);
cairo_set_source_rgb($c, 0, 1, 0);
cairo_rectangle($c, 50, 50, 50, 50);
cairo_fill($c);

cairo_surface_write_to_png($s, dirname(__FILE__) . '/cairo_fill.png');

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • CairoContext::setFillRule() - The setFillRule purpose
  • ContextContext::fillPreserve()
  • CairoFillRule

CairoContext::deviceToUserDistance
CairoContext::fillExtents
CairoContext


Computes the filled area

CairoContext::fill
CairoContext::fillPreserve
CairoContext
PHP Manual

CairoContext::fillExtents

cairo_fill_extents

(PECL cairo >= 0.1.0)

CairoContext::fillExtents -- cairo_fill_extents — Computes the filled area

Açıklama

Nesne yönelimli kullanım (method):

public array CairoContext::fillExtents ( void )

Yordamsal kullanım:

array cairo_fill_extents ( CairoContext $context )

Computes a bounding box in user coordinates covering the area that would be affected, (the "inked" area), by a CairoContext::fill() operation given the current path and fill parameters. If the current path is empty, returns an empty rectangle (0,0,0,0). Surface dimensions and clipping are not taken into account.

Contrast with CairoContext::pathExtents(), which is similar, but returns non-zero extents for some paths with no inked area, (such as a simple line segment).

Note that CairoContext::fillExtents() must necessarily do more work to compute the precise inked areas in light of the fill rule, so CairoContext::pathExtents() may be more desirable for sake of performance if the non-inked path extents are desired.

Değiştirgeler

context

A valid CairoContext object created with CairoContext::__construct() or cairo_create()

Dönen Değerler

An array with the coordinates of the afected area

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • CairoContext::fill() - Fills the current path
  • CairoContext::setFillRule() - The setFillRule purpose
  • CairoContext::fillPreserve() - Fills and preserve the current path

CairoContext::fill
CairoContext::fillPreserve
CairoContext


Fills and preserve the current path

CairoContext::fillExtents
CairoContext::fontExtents
CairoContext
PHP Manual

CairoContext::fillPreserve

cairo_fill_preserve

(PECL cairo >= 0.1.0)

CairoContext::fillPreserve -- cairo_fill_preserve — Fills and preserve the current path

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::fillPreserve ( void )

Yordamsal kullanım:

void cairo_fill_preserve ( CairoContext $context )

A drawing operator that fills the current path according to the current CairoFillRule, (each sub-path is implicitly closed before being filled). Unlike CairoContext::fill(), CairoContext::fillPreserve() (Procedural cairo_fill(), cairo_fill_preserve(), respectively) preserves the path within the Context.

Değiştirgeler

context

A valid CairoContext object created with CairoContext::__construct() or cairo_create()

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • CairoContext::setFillRule() - The setFillRule purpose
  • CairoContext::fill() - Fills the current path

CairoContext::fillExtents
CairoContext::fontExtents
CairoContext


Get the font extents

CairoContext::fillPreserve
CairoContext::getAntialias
CairoContext
PHP Manual

CairoContext::fontExtents

cairo_font_extents

(PECL cairo >= 0.1.0)

CairoContext::fontExtents -- cairo_font_extents — Get the font extents

Açıklama

Nesne yönelimli kullanım (method):

public array CairoContext::fontExtents ( void )

Yordamsal kullanım:

array cairo_font_extents ( CairoContext $context )

Gets the font extents for the currently selected font.

Değiştirgeler

context

Description...

Dönen Değerler

An array containing the font extents for the current font.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php

$sur = new CairoImageSurface(CairoFormat::ARGB32, 50, 50);
$con = new CairoContext($sur);

var_dump($con->fontExtents());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(5) {
  ["ascent"]=>
  float(10)
  ["descent"]=>
  float(3)
  ["height"]=>
  float(13.3125)
  ["max_x_advance"]=>
  float(26.65625)
  ["max_y_advance"]=>
  float(0)
}

Örnek 2 Yordamsal kullanım

<?php

$sur = cairo_image_surface_create(CAIRO_FORMAT_ARGB32, 50, 50);
$con = cairo_create($sur);

var_dump(cairo_font_extents($con));

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(5) {
  ["ascent"]=>
  float(10)
  ["descent"]=>
  float(3)
  ["height"]=>
  float(13.3125)
  ["max_x_advance"]=>
  float(26.65625)
  ["max_y_advance"]=>
  float(0)
}

Ayrıca Bakınız

  • Classname::Method()

CairoContext::fillPreserve
CairoContext::getAntialias
CairoContext


Retrives the current antialias mode

CairoContext::fontExtents
CairoContext::getCurrentPoint
CairoContext
PHP Manual

CairoContext::getAntialias

cairo_get_antialias

(PECL cairo >= 0.1.0)

CairoContext::getAntialias -- cairo_get_antialias — Retrives the current antialias mode

Açıklama

Nesne yönelimli kullanım (method):

public int CairoContext::getAntialias ( void )

Yordamsal kullanım:

int cairo_get_antialias ( CairoContext $context )

Returns the current CairoAntialias mode, as set by CairoContext::setAntialias().

Değiştirgeler

context

A valid CairoContext object created with CairoContext::__construct() or cairo_create()

Dönen Değerler

The current CairoAntialias mode.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php

$surface = new CairoImageSurface(CairoFormat::ARGB32, 50, 50);
$context = new CairoContext($surface);

$context->setAntialias(CairoAntialias::MODE_SUBPIXEL);

var_dump($context->getAntialias());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(3)

Örnek 2 Yordamsal kullanım

<?php

$sur = cairo_image_surface_create(CAIRO_FORMAT_ARGB32, 50, 50);
$con = cairo_create($sur);

cairo_set_antialias($con, CAIRO_ANTIALIAS_SUBPIXEL);

var_dump(cairo_get_antialias($con));

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(3)

Ayrıca Bakınız

  • CairoContext::setAntialias() - The setAntialias purpose
  • CairoAntialias

CairoContext::fontExtents
CairoContext::getCurrentPoint
CairoContext


The getCurrentPoint purpose

CairoContext::getAntialias
CairoContext::getDash
CairoContext
PHP Manual

CairoContext::getCurrentPoint

cairo_get_current_point

(PECL cairo >= 0.1.0)

CairoContext::getCurrentPoint -- cairo_get_current_point — The getCurrentPoint purpose

Açıklama

Nesne yönelimli kullanım

public array CairoContext::getCurrentPoint ( void )

Yordamsal kullanım

array cairo_get_current_point ( CairoContext $context )

Gets the current point of the current path, which is conceptually the final point reached by the path so far.

The current point is returned in the user-space coordinate system. If there is no defined current point or if cr is in an error status, x and y will both be set to 0.0. It is possible to check this in advance with CairoContext::hasCurrentPoint().

Most path construction functions alter the current point. See the following for details on how they affect the current point: CairoContext::newPath(),
CairoContext::newSubPath(), CairoContext::appendPath(), CairoContext::closePath(), CairoContext::moveTo(),
CairoContext::lineTo(), CairoContext::curveTo(), CairoContext::relMoveTo(),
CairoContext::relLineTo(), CairoContext::relCurveTo(),
CairoContext::arc(), CairoContext::arcNegative(), CairoContext::rectangle(),
CairoContext::textPath(), CairoContext::glyphPath().

Some functions use and alter the current point but do not otherwise change current path: CairoContext::showText().

Some functions unset the current path and as a result, current point: CairoContext::fill(), CairoContext::stroke().

Değiştirgeler

context

A valid CairoContext object.

Dönen Değerler

An array containing the x (index 0) and y (index 1) coordinates of the current point.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php

$s = new CairoImageSurface(CairoFormat::ARGB32, 100, 100);
$c = new CairoContext($s);

$c->moveTo(10, 10);

var_dump($c->getCurrentPoint());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(2) {
  [0]=>
  float(10)
  [1]=>
  float(10)
}

Örnek 2 Yordamsal kullanım

<?php

$s = cairo_image_surface_create(CAIRO_SURFACE_TYPE_IMAGE, 100, 100);
$c = cairo_create($s);

cairo_move_to($c, 10, 10);

var_dump(cairo_get_current_point($c));

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(2) {
  [0]=>
  float(10)
  [1]=>
  float(10)
}

Ayrıca Bakınız

  • CairoContext::moveTo() - The moveTo purpose
  • CairoContext::hasCurrentPoint() - The hasCurrentPoint purpose

CairoContext::getAntialias
CairoContext::getDash
CairoContext


The getDash purpose

CairoContext::getCurrentPoint
CairoContext::getDashCount
CairoContext
PHP Manual

CairoContext::getDash

cairo_get_dash

(PECL cairo >= 0.1.0)

CairoContext::getDash -- cairo_get_dash — The getDash purpose

Açıklama

Nesne yönelimli kullanım (method):

public array CairoContext::getDash ( void )

Yordamsal kullanım:

array cairo_get_dash ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::getCurrentPoint
CairoContext::getDashCount
CairoContext


The getDashCount purpose

CairoContext::getDash
CairoContext::getFillRule
CairoContext
PHP Manual

CairoContext::getDashCount

cairo_get_dash_count

(PECL cairo >= 0.1.0)

CairoContext::getDashCount -- cairo_get_dash_count — The getDashCount purpose

Açıklama

Nesne yönelimli kullanım (method):

public int CairoContext::getDashCount ( void )

Yordamsal kullanım:

int cairo_get_dash_count ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::getDash
CairoContext::getFillRule
CairoContext


The getFillRule purpose

CairoContext::getDashCount
CairoContext::getFontFace
CairoContext
PHP Manual

CairoContext::getFillRule

cairo_get_fill_rule

(PECL cairo >= 0.1.0)

CairoContext::getFillRule -- cairo_get_fill_rule — The getFillRule purpose

Açıklama

Nesne yönelimli kullanım (method):

public int CairoContext::getFillRule ( void )

Yordamsal kullanım:

int cairo_get_fill_rule ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::getDashCount
CairoContext::getFontFace
CairoContext


The getFontFace purpose

CairoContext::getFillRule
CairoContext::getFontMatrix
CairoContext
PHP Manual

CairoContext::getFontFace

cairo_get_font_face

(PECL cairo >= 0.1.0)

CairoContext::getFontFace -- cairo_get_font_face — The getFontFace purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::getFontFace ( void )

Yordamsal kullanım:

void cairo_get_font_face ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::getFillRule
CairoContext::getFontMatrix
CairoContext


The getFontMatrix purpose

CairoContext::getFontFace
CairoContext::getFontOptions
CairoContext
PHP Manual

CairoContext::getFontMatrix

cairo_get_font_matrix

(PECL cairo >= 0.1.0)

CairoContext::getFontMatrix -- cairo_get_font_matrix — The getFontMatrix purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::getFontMatrix ( void )

Yordamsal kullanım:

void cairo_get_font_matrix ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::getFontFace
CairoContext::getFontOptions
CairoContext


The getFontOptions purpose

CairoContext::getFontMatrix
CairoContext::getGroupTarget
CairoContext
PHP Manual

CairoContext::getFontOptions

cairo_get_font_options

(PECL cairo >= 0.1.0)

CairoContext::getFontOptions -- cairo_get_font_options — The getFontOptions purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::getFontOptions ( void )

Yordamsal kullanım:

void cairo_get_font_options ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::getFontMatrix
CairoContext::getGroupTarget
CairoContext


The getGroupTarget purpose

CairoContext::getFontOptions
CairoContext::getLineCap
CairoContext
PHP Manual

CairoContext::getGroupTarget

cairo_get_group_target

(PECL cairo >= 0.1.0)

CairoContext::getGroupTarget -- cairo_get_group_target — The getGroupTarget purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::getGroupTarget ( void )

Yordamsal kullanım:

void cairo_get_group_target ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::getFontOptions
CairoContext::getLineCap
CairoContext


The getLineCap purpose

CairoContext::getGroupTarget
CairoContext::getLineJoin
CairoContext
PHP Manual

CairoContext::getLineCap

cairo_get_line_cap

(PECL cairo >= 0.1.0)

CairoContext::getLineCap -- cairo_get_line_cap — The getLineCap purpose

Açıklama

Nesne yönelimli kullanım (method):

public int CairoContext::getLineCap ( void )

Yordamsal kullanım:

int cairo_get_line_cap ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::getGroupTarget
CairoContext::getLineJoin
CairoContext


The getLineJoin purpose

CairoContext::getLineCap
CairoContext::getLineWidth
CairoContext
PHP Manual

CairoContext::getLineJoin

cairo_get_line_join

(PECL cairo >= 0.1.0)

CairoContext::getLineJoin -- cairo_get_line_join — The getLineJoin purpose

Açıklama

Nesne yönelimli kullanım (method):

public int CairoContext::getLineJoin ( void )

Yordamsal kullanım:

int cairo_get_line_join ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::getLineCap
CairoContext::getLineWidth
CairoContext


The getLineWidth purpose

CairoContext::getLineJoin
CairoContext::getMatrix
CairoContext
PHP Manual

CairoContext::getLineWidth

cairo_get_line_width

(PECL cairo >= 0.1.0)

CairoContext::getLineWidth -- cairo_get_line_width — The getLineWidth purpose

Açıklama

Nesne yönelimli kullanım (method):

public float CairoContext::getLineWidth ( void )

Yordamsal kullanım:

float cairo_get_line_width ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::getLineJoin
CairoContext::getMatrix
CairoContext


The getMatrix purpose

CairoContext::getLineWidth
CairoContext::getMiterLimit
CairoContext
PHP Manual

CairoContext::getMatrix

cairo_get_matrix

(PECL cairo >= 0.1.0)

CairoContext::getMatrix -- cairo_get_matrix — The getMatrix purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::getMatrix ( void )

Yordamsal kullanım:

void cairo_get_matrix ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::getLineWidth
CairoContext::getMiterLimit
CairoContext


The getMiterLimit purpose

CairoContext::getMatrix
CairoContext::getOperator
CairoContext
PHP Manual

CairoContext::getMiterLimit

cairo_get_miter_limit

(PECL cairo >= 0.1.0)

CairoContext::getMiterLimit -- cairo_get_miter_limit — The getMiterLimit purpose

Açıklama

Nesne yönelimli kullanım (method):

public float CairoContext::getMiterLimit ( void )

Yordamsal kullanım:

float cairo_get_miter_limit ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::getMatrix
CairoContext::getOperator
CairoContext


The getOperator purpose

CairoContext::getMiterLimit
CairoContext::getScaledFont
CairoContext
PHP Manual

CairoContext::getOperator

cairo_get_operator

(PECL cairo >= 0.1.0)

CairoContext::getOperator -- cairo_get_operator — The getOperator purpose

Açıklama

Nesne yönelimli kullanım (method):

public int CairoContext::getOperator ( void )

Yordamsal kullanım:

int cairo_get_operator ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::getMiterLimit
CairoContext::getScaledFont
CairoContext


The getScaledFont purpose

CairoContext::getOperator
CairoContext::getSource
CairoContext
PHP Manual

CairoContext::getScaledFont

cairo_get_scaled_font

(PECL cairo >= 0.1.0)

CairoContext::getScaledFont -- cairo_get_scaled_font — The getScaledFont purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::getScaledFont ( void )

Yordamsal kullanım:

void cairo_get_scaled_font ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::getOperator
CairoContext::getSource
CairoContext


The getSource purpose

CairoContext::getScaledFont
CairoContext::getTarget
CairoContext
PHP Manual

CairoContext::getSource

cairo_get_source

(PECL cairo >= 0.1.0)

CairoContext::getSource -- cairo_get_source — The getSource purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::getSource ( void )

Yordamsal kullanım:

void cairo_get_source ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::getScaledFont
CairoContext::getTarget
CairoContext


The getTarget purpose

CairoContext::getSource
CairoContext::getTolerance
CairoContext
PHP Manual

CairoContext::getTarget

cairo_get_target

(PECL cairo >= 0.1.0)

CairoContext::getTarget -- cairo_get_target — The getTarget purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::getTarget ( void )

Yordamsal kullanım:

void cairo_get_target ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::getSource
CairoContext::getTolerance
CairoContext


The getTolerance purpose

CairoContext::getTarget
CairoContext::glyphPath
CairoContext
PHP Manual

CairoContext::getTolerance

cairo_get_tolerance

(PECL cairo >= 0.1.0)

CairoContext::getTolerance -- cairo_get_tolerance — The getTolerance purpose

Açıklama

Nesne yönelimli kullanım (method):

public float CairoContext::getTolerance ( void )

Yordamsal kullanım:

float cairo_get_tolerance ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::getTarget
CairoContext::glyphPath
CairoContext


The glyphPath purpose

CairoContext::getTolerance
CairoContext::hasCurrentPoint
CairoContext
PHP Manual

CairoContext::glyphPath

cairo_glyph_path

(PECL cairo >= 0.1.0)

CairoContext::glyphPath -- cairo_glyph_path — The glyphPath purpose

Açıklama

Nesne yönelimli kullanım

public void CairoContext::glyphPath ( array $glyphs )

Yordamsal kullanım

void cairo_glyph_path ( CairoContext $context , array $glyphs )

Adds closed paths for the glyphs to the current path. The generated path if filled, achieves an effect similar to that of CairoContext::showGlyphs().

Değiştirgeler

context

A CairoContext object

glyphs

Array of glyphs

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

CairoContext::getTolerance
CairoContext::hasCurrentPoint
CairoContext


The hasCurrentPoint purpose

CairoContext::glyphPath
CairoContext::identityMatrix
CairoContext
PHP Manual

CairoContext::hasCurrentPoint

cairo_has_current_point

(PECL cairo >= 0.1.0)

CairoContext::hasCurrentPoint -- cairo_has_current_point — The hasCurrentPoint purpose

Açıklama

Nesne yönelimli kullanım (method):

public bool CairoContext::hasCurrentPoint ( void )

Yordamsal kullanım:

bool cairo_has_current_point ( CairoContext $context )

Returns whether a current point is defined on the current path. See CairoContext::getCurrentPoint() for details on the current point.

Değiştirgeler

context

A valid CairoContext object.

Dönen Değerler

Whether a current point is defined

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php

$s = new CairoImageSurface(CairoFormat::ARGB32, 100, 100);
$c = new CairoContext($s);

var_dump($c->hasCurrentPoint());

$c->moveTo(10, 10);

var_dump($c->hasCurrentPoint());

?>

Yukarıdaki örneğin çıktısı:

bool(false)
bool(true)

Örnek 2 Yordamsal kullanım

<?php

$s = cairo_image_surface_create(CAIRO_SURFACE_TYPE_IMAGE, 100, 100);
$c = cairo_create($s);

var_dump(cairo_has_current_point($c));

cairo_move_to($c, 10, 10);

var_dump(cairo_has_current_point($c));

?>

Yukarıdaki örneğin çıktısı:

bool(false)
bool(true)

Ayrıca Bakınız

  • CairoContext::getCurrentPoint() - The getCurrentPoint purpose

CairoContext::glyphPath
CairoContext::identityMatrix
CairoContext


The identityMatrix purpose

CairoContext::hasCurrentPoint
CairoContext::inFill
CairoContext
PHP Manual

CairoContext::identityMatrix

cairo_identity_matrix

(PECL cairo >= 0.1.0)

CairoContext::identityMatrix -- cairo_identity_matrix — The identityMatrix purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::identityMatrix ( void )

Yordamsal kullanım:

void cairo_identity_matrix ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::hasCurrentPoint
CairoContext::inFill
CairoContext


The inFill purpose

CairoContext::identityMatrix
CairoContext::inStroke
CairoContext
PHP Manual

CairoContext::inFill

cairo_in_fill

(PECL cairo >= 0.1.0)

CairoContext::inFill -- cairo_in_fill — The inFill purpose

Açıklama

Nesne yönelimli kullanım (method):

public bool CairoContext::inFill ( string $x , string $y )

Yordamsal kullanım:

bool cairo_in_fill ( CairoContext $context , string $x , string $y )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

x

Description...

y

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::identityMatrix
CairoContext::inStroke
CairoContext


The inStroke purpose

CairoContext::inFill
CairoContext::lineTo
CairoContext
PHP Manual

CairoContext::inStroke

cairo_in_stroke

(PECL cairo >= 0.1.0)

CairoContext::inStroke -- cairo_in_stroke — The inStroke purpose

Açıklama

Nesne yönelimli kullanım (method):

public bool CairoContext::inStroke ( string $x , string $y )

Yordamsal kullanım:

bool cairo_in_stroke ( CairoContext $context , string $x , string $y )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

x

Description...

y

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::inFill
CairoContext::lineTo
CairoContext


The lineTo purpose

CairoContext::inStroke
CairoContext::mask
CairoContext
PHP Manual

CairoContext::lineTo

cairo_line_to

(PECL cairo >= 0.1.0)

CairoContext::lineTo -- cairo_line_to — The lineTo purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::lineTo ( string $x , string $y )

Yordamsal kullanım:

void cairo_line_to ( CairoContext $context , string $x , string $y )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

x

Description...

y

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::inStroke
CairoContext::mask
CairoContext


The mask purpose

CairoContext::lineTo
CairoContext::maskSurface
CairoContext
PHP Manual

CairoContext::mask

cairo_mask

(PECL cairo >= 0.1.0)

CairoContext::mask -- cairo_mask — The mask purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::mask ( string $pattern )

Yordamsal kullanım:

void cairo_mask ( CairoContext $context , CairoPattern $pattern )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

pattern

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::lineTo
CairoContext::maskSurface
CairoContext


The maskSurface purpose

CairoContext::mask
CairoContext::moveTo
CairoContext
PHP Manual

CairoContext::maskSurface

cairo_mask_surface

(PECL cairo >= 0.1.0)

CairoContext::maskSurface -- cairo_mask_surface — The maskSurface purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::maskSurface ( string $surface [, string $x [, string $y ]] )

Yordamsal kullanım:

void cairo_mask_surface ( CairoContext $context , CairoSurface $surface [, string $x [, string $y ]] )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

surface

Description...

x

Description...

y

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::mask
CairoContext::moveTo
CairoContext


The moveTo purpose

CairoContext::maskSurface
CairoContext::newPath
CairoContext
PHP Manual

CairoContext::moveTo

cairo_move_to

(PECL cairo >= 0.1.0)

CairoContext::moveTo -- cairo_move_to — The moveTo purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::moveTo ( string $x , string $y )

Yordamsal kullanım:

void cairo_move_to ( CairoContext $context , string $x , string $y )

Begin a new sub-path. After this call the current point will be (x, y).

Değiştirgeler

context

A valid CairoContext object.

x

The x coordinate of the new position.

y

The y coordinate of the new position

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php

$s = new CairoImageSurface(CairoFormat::ARGB32, 100, 100);
$c = new CairoContext($s);

$c->setSourceRgb(0, 0, 0);
$c->paint();

// Move 10 pixels across, and 10 pixels down
$c->moveTo(10, 10);
$c->lineTo(90, 90);
$c->setLineWidth(2);
$c->setSourceRgb(1, 1, 1);
$c->stroke();

// Move 90 pixels across, and 10 pixels down
$c->moveTo(90, 10);
$c->lineTo(10, 90);
$c->setLineWidth(2);
$c->setSourceRgb(1, 1, 1);
$c->stroke();

$s->writeToPng(dirname(__FILE__) . '/CairoContext_moveTo.png');
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php

$s = cairo_image_surface_create(CAIRO_SURFACE_TYPE_IMAGE, 100, 100);
$c = cairo_create($s);

cairo_set_source_rgb($c, 0, 0, 0);
cairo_paint($c);

// Move 10 pixels across, and 10 pixels down
cairo_move_to($c, 10, 10);
cairo_line_to($c, 90, 90);
cairo_set_line_width($c, 2);
cairo_set_source_rgb($c, 1, 1, 1);
cairo_stroke($c);

// Move 90 pixels across, and 10 pixels down
cairo_move_to($c, 90, 10);
cairo_line_to($c, 10, 90);
cairo_set_line_width($c, 2);
cairo_set_source_rgb($c, 1, 1, 1);
cairo_stroke($c);

cairo_surface_write_to_png($s, dirname(__FILE__) . '/cairo_move_to.png');
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::maskSurface
CairoContext::newPath
CairoContext


The newPath purpose

CairoContext::moveTo
CairoContext::newSubPath
CairoContext
PHP Manual

CairoContext::newPath

cairo_new_path

(PECL cairo >= 0.1.0)

CairoContext::newPath -- cairo_new_path — The newPath purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::newPath ( void )

Yordamsal kullanım:

void cairo_new_path ( CairoContext $context )

Clears the current path. After this call there will be no path and no current point.

Değiştirgeler

context

A valid CairoContext object.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
// [...]
CairoContext::newPath();
?>

Örnek 2 Yordamsal kullanım

<?php
// [...]
cairo_new_path($context);
?>

Ayrıca Bakınız

  • CairoContext::appendPath() - Appends a path to current path
  • CairoContext::closePath() - Closes the current path

CairoContext::moveTo
CairoContext::newSubPath
CairoContext


The newSubPath purpose

CairoContext::newPath
CairoContext::paint
CairoContext
PHP Manual

CairoContext::newSubPath

cairo_new_sub_path

(PECL cairo >= 0.1.0)

CairoContext::newSubPath -- cairo_new_sub_path — The newSubPath purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::newSubPath ( void )

Yordamsal kullanım:

void cairo_new_sub_path ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::newPath
CairoContext::paint
CairoContext


The paint purpose

CairoContext::newSubPath
CairoContext::paintWithAlpha
CairoContext
PHP Manual

CairoContext::paint

cairo_paint

(PECL cairo >= 0.1.0)

CairoContext::paint -- cairo_paint — The paint purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::paint ( void )

Yordamsal kullanım:

void cairo_paint ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::newSubPath
CairoContext::paintWithAlpha
CairoContext


The paintWithAlpha purpose

CairoContext::paint
CairoContext::pathExtents
CairoContext
PHP Manual

CairoContext::paintWithAlpha

cairo_paint_with_alpha

(PECL cairo >= 0.1.0)

CairoContext::paintWithAlpha -- cairo_paint_with_alpha — The paintWithAlpha purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::paintWithAlpha ( string $alpha )

Yordamsal kullanım:

void cairo_paint_with_alpha ( CairoContext $context , string $alpha )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

alpha

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::paint
CairoContext::pathExtents
CairoContext


The pathExtents purpose

CairoContext::paintWithAlpha
CairoContext::popGroup
CairoContext
PHP Manual

CairoContext::pathExtents

cairo_path_extents

(PECL cairo >= 0.1.0)

CairoContext::pathExtents -- cairo_path_extents — The pathExtents purpose

Açıklama

Nesne yönelimli kullanım (method):

public array CairoContext::pathExtents ( void )

Yordamsal kullanım:

array cairo_path_extents ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::paintWithAlpha
CairoContext::popGroup
CairoContext


The popGroup purpose

CairoContext::pathExtents
CairoContext::popGroupToSource
CairoContext
PHP Manual

CairoContext::popGroup

cairo_pop_group

(PECL cairo >= 0.1.0)

CairoContext::popGroup -- cairo_pop_group — The popGroup purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::popGroup ( void )

Yordamsal kullanım:

void cairo_pop_group ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::pathExtents
CairoContext::popGroupToSource
CairoContext


The popGroupToSource purpose

CairoContext::popGroup
CairoContext::pushGroup
CairoContext
PHP Manual

CairoContext::popGroupToSource

cairo_pop_group_to_source

(PECL cairo >= 0.1.0)

CairoContext::popGroupToSource -- cairo_pop_group_to_source — The popGroupToSource purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::popGroupToSource ( void )

Yordamsal kullanım:

void cairo_pop_group_to_source ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::popGroup
CairoContext::pushGroup
CairoContext


The pushGroup purpose

CairoContext::popGroupToSource
CairoContext::pushGroupWithContent
CairoContext
PHP Manual

CairoContext::pushGroup

cairo_push_group

(PECL cairo >= 0.1.0)

CairoContext::pushGroup -- cairo_push_group — The pushGroup purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::pushGroup ( void )

Yordamsal kullanım:

void cairo_push_group ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::popGroupToSource
CairoContext::pushGroupWithContent
CairoContext


The pushGroupWithContent purpose

CairoContext::pushGroup
CairoContext::rectangle
CairoContext
PHP Manual

CairoContext::pushGroupWithContent

cairo_push_group_with_content

(PECL cairo >= 0.1.0)

CairoContext::pushGroupWithContent -- cairo_push_group_with_content — The pushGroupWithContent purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::pushGroupWithContent ( string $content )

Yordamsal kullanım:

void cairo_push_group_with_content ( CairoContext $context , string $content )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

content

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::pushGroup
CairoContext::rectangle
CairoContext


The rectangle purpose

CairoContext::pushGroupWithContent
CairoContext::relCurveTo
CairoContext
PHP Manual

CairoContext::rectangle

cairo_rectangle

(PECL cairo >= 0.1.0)

CairoContext::rectangle -- cairo_rectangle — The rectangle purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::rectangle ( string $x , string $y , string $width , string $height )

Yordamsal kullanım:

void cairo_rectangle ( CairoContext $context , string $x , string $y , string $width , string $height )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

x

Description...

y

Description...

width

Description...

height

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::pushGroupWithContent
CairoContext::relCurveTo
CairoContext


The relCurveTo purpose

CairoContext::rectangle
CairoContext::relLineTo
CairoContext
PHP Manual

CairoContext::relCurveTo

cairo_rel_curve_to

(PECL cairo >= 0.1.0)

CairoContext::relCurveTo -- cairo_rel_curve_to — The relCurveTo purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::relCurveTo ( string $x1 , string $y1 , string $x2 , string $y2 , string $x3 , string $y3 )

Yordamsal kullanım:

void cairo_rel_curve_to ( CairoContext $context , string $x1 , string $y1 , string $x2 , string $y2 , string $x3 , string $y3 )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

x1

Description...

y1

Description...

x2

Description...

y2

Description...

x3

Description...

y3

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::rectangle
CairoContext::relLineTo
CairoContext


The relLineTo purpose

CairoContext::relCurveTo
CairoContext::relMoveTo
CairoContext
PHP Manual

CairoContext::relLineTo

cairo_rel_line_to

(PECL cairo >= 0.1.0)

CairoContext::relLineTo -- cairo_rel_line_to — The relLineTo purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::relLineTo ( string $x , string $y )

Yordamsal kullanım:

void cairo_rel_line_to ( CairoContext $context , string $x , string $y )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

x

Description...

y

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::relCurveTo
CairoContext::relMoveTo
CairoContext


The relMoveTo purpose

CairoContext::relLineTo
CairoContext::resetClip
CairoContext
PHP Manual

CairoContext::relMoveTo

cairo_rel_move_to

(PECL cairo >= 0.1.0)

CairoContext::relMoveTo -- cairo_rel_move_to — The relMoveTo purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::relMoveTo ( string $x , string $y )

Yordamsal kullanım:

void cairo_rel_move_to ( CairoContext $context , string $x , string $y )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

x

Description...

y

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::relLineTo
CairoContext::resetClip
CairoContext


The resetClip purpose

CairoContext::relMoveTo
CairoContext::restore
CairoContext
PHP Manual

CairoContext::resetClip

cairo_reset_clip

(PECL cairo >= 0.1.0)

CairoContext::resetClip -- cairo_reset_clip — The resetClip purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::resetClip ( void )

Yordamsal kullanım:

void cairo_reset_clip ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::relMoveTo
CairoContext::restore
CairoContext


The restore purpose

CairoContext::resetClip
CairoContext::rotate
CairoContext
PHP Manual

CairoContext::restore

cairo_restore

(PECL cairo >= 0.1.0)

CairoContext::restore -- cairo_restore — The restore purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::restore ( void )

Yordamsal kullanım:

void cairo_restore ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::resetClip
CairoContext::rotate
CairoContext


The rotate purpose

CairoContext::restore
CairoContext::save
CairoContext
PHP Manual

CairoContext::rotate

cairo_rotate

(PECL cairo >= 0.1.0)

CairoContext::rotate -- cairo_rotate — The rotate purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::rotate ( string $angle )

Yordamsal kullanım:

void cairo_rotate ( CairoContext $context , string $angle )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

angle

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::restore
CairoContext::save
CairoContext


The save purpose

CairoContext::rotate
CairoContext::scale
CairoContext
PHP Manual

CairoContext::save

cairo_save

(PECL cairo >= 0.1.0)

CairoContext::save -- cairo_save — The save purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::save ( void )

Yordamsal kullanım:

void cairo_save ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::rotate
CairoContext::scale
CairoContext


The scale purpose

CairoContext::save
CairoContext::selectFontFace
CairoContext
PHP Manual

CairoContext::scale

cairo_scale

(PECL cairo >= 0.1.0)

CairoContext::scale -- cairo_scale — The scale purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::scale ( string $x , string $y )

Yordamsal kullanım:

void cairo_scale ( CairoContext $context , string $x , string $y )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

x

Description...

y

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::save
CairoContext::selectFontFace
CairoContext


The selectFontFace purpose

CairoContext::scale
CairoContext::setAntialias
CairoContext
PHP Manual

CairoContext::selectFontFace

cairo_select_font_face

(PECL cairo >= 0.1.0)

CairoContext::selectFontFace -- cairo_select_font_face — The selectFontFace purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::selectFontFace ( string $family [, string $slant [, string $weight ]] )

Yordamsal kullanım:

void cairo_select_font_face ( CairoContext $context , string $family [, string $slant [, string $weight ]] )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

family

Description...

slant

Description...

weight

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::scale
CairoContext::setAntialias
CairoContext


The setAntialias purpose

CairoContext::selectFontFace
CairoContext::setDash
CairoContext
PHP Manual

CairoContext::setAntialias

cairo_set_antialias

(PECL cairo >= 0.1.0)

CairoContext::setAntialias -- cairo_set_antialias — The setAntialias purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::setAntialias ([ string $antialias ] )

Yordamsal kullanım:

void cairo_set_antialias ( CairoContext $context [, string $antialias ] )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

antialias

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::selectFontFace
CairoContext::setDash
CairoContext


The setDash purpose

CairoContext::setAntialias
CairoContext::setFillRule
CairoContext
PHP Manual

CairoContext::setDash

cairo_set_dash

(PECL cairo >= 0.1.0)

CairoContext::setDash -- cairo_set_dash — The setDash purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::setDash ( string $dashes [, string $offset ] )

Yordamsal kullanım:

void cairo_set_dash ( CairoContext $context , array $dashes [, string $offset ] )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

dashes

Description...

offset

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::setAntialias
CairoContext::setFillRule
CairoContext


The setFillRule purpose

CairoContext::setDash
CairoContext::setFontFace
CairoContext
PHP Manual

CairoContext::setFillRule

cairo_set_fill_rule

(PECL cairo >= 0.1.0)

CairoContext::setFillRule -- cairo_set_fill_rule — The setFillRule purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::setFillRule ( string $setting )

Yordamsal kullanım:

void cairo_set_fill_rule ( CairoContext $context , string $setting )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

setting

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::setDash
CairoContext::setFontFace
CairoContext


The setFontFace purpose

CairoContext::setFillRule
CairoContext::setFontMatrix
CairoContext
PHP Manual

CairoContext::setFontFace

cairo_set_font_face

(PECL cairo >= 0.1.0)

CairoContext::setFontFace -- cairo_set_font_face — The setFontFace purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::setFontFace ( CairoFontFace $fontface )

Yordamsal kullanım:

void cairo_set_font_face ( CairoContext $context , CairoFontFace $fontface )

Sets the font-face for a given context.

Değiştirgeler

context

A CairoContext object to change the font-face for.

fontface

A CairoFontFace object

Dönen Değerler

No value is returned

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
// New surface with white background
$s = new CairoImageSurface(CairoFormat::ARGB32, 300, 100);
$c = new CairoContext($s);
$c->setSourceRgb(1, 1, 1);
$c->paint();

// Draw some text
$c->setSourceRgb(0, 0, 0);
$c->moveTo(10, 60);
// Create a new font face
$f = new CairoToyFontFace("sans-serif", CairoFontSlant::NORMAL, CairoFontWeight::NORMAL);
$c->setFontFace($f);
$c->setFontSize(30);
$c->showText('Hello, World!');
$s->writeToPng(dirname(__FILE__) . '/setFontFace.png');
?>

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Ayrıca Bakınız

  • CairoContext::setFontSize() - The setFontSize purpose
  • CairoContext::showText() - The showText purpose

CairoContext::setFillRule
CairoContext::setFontMatrix
CairoContext


The setFontMatrix purpose

CairoContext::setFontFace
CairoContext::setFontOptions
CairoContext
PHP Manual

CairoContext::setFontMatrix

cairo_set_font_matrix

(PECL cairo >= 0.1.0)

CairoContext::setFontMatrix -- cairo_set_font_matrix — The setFontMatrix purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::setFontMatrix ( string $matrix )

Yordamsal kullanım:

void cairo_set_font_matrix ( CairoContext $context , CairoMatrix $matrix )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

matrix

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::setFontFace
CairoContext::setFontOptions
CairoContext


The setFontOptions purpose

CairoContext::setFontMatrix
CairoContext::setFontSize
CairoContext
PHP Manual

CairoContext::setFontOptions

cairo_set_font_options

(PECL cairo >= 0.1.0)

CairoContext::setFontOptions -- cairo_set_font_options — The setFontOptions purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::setFontOptions ( string $fontoptions )

Yordamsal kullanım:

void cairo_set_font_options ( CairoContext $context , CairoFontOptions $fontoptions )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

fontoptions

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::setFontMatrix
CairoContext::setFontSize
CairoContext


The setFontSize purpose

CairoContext::setFontOptions
CairoContext::setLineCap
CairoContext
PHP Manual

CairoContext::setFontSize

cairo_set_font_size

(PECL cairo >= 0.1.0)

CairoContext::setFontSize -- cairo_set_font_size — The setFontSize purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::setFontSize ( string $size )

Yordamsal kullanım:

void cairo_set_font_size ( CairoContext $context , string $size )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

size

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::setFontOptions
CairoContext::setLineCap
CairoContext


The setLineCap purpose

CairoContext::setFontSize
CairoContext::setLineJoin
CairoContext
PHP Manual

CairoContext::setLineCap

cairo_set_line_cap

(PECL cairo >= 0.1.0)

CairoContext::setLineCap -- cairo_set_line_cap — The setLineCap purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::setLineCap ( string $setting )

Yordamsal kullanım:

void cairo_set_line_cap ( CairoContext $context , string $setting )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

setting

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::setFontSize
CairoContext::setLineJoin
CairoContext


The setLineJoin purpose

CairoContext::setLineCap
CairoContext::setLineWidth
CairoContext
PHP Manual

CairoContext::setLineJoin

cairo_set_line_join

(PECL cairo >= 0.1.0)

CairoContext::setLineJoin -- cairo_set_line_join — The setLineJoin purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::setLineJoin ( string $setting )

Yordamsal kullanım:

void cairo_set_line_join ( CairoContext $context , string $setting )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

setting

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::setLineCap
CairoContext::setLineWidth
CairoContext


The setLineWidth purpose

CairoContext::setLineJoin
CairoContext::setMatrix
CairoContext
PHP Manual

CairoContext::setLineWidth

cairo_set_line_width

(PECL cairo >= 0.1.0)

CairoContext::setLineWidth -- cairo_set_line_width — The setLineWidth purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::setLineWidth ( string $width )

Yordamsal kullanım:

void cairo_set_line_width ( CairoContext $context , string $width )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

width

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::setLineJoin
CairoContext::setMatrix
CairoContext


The setMatrix purpose

CairoContext::setLineWidth
CairoContext::setMiterLimit
CairoContext
PHP Manual

CairoContext::setMatrix

cairo_set_matrix

(PECL cairo >= 0.1.0)

CairoContext::setMatrix -- cairo_set_matrix — The setMatrix purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::setMatrix ( string $matrix )

Yordamsal kullanım:

void cairo_set_matrix ( CairoContext $context , CairoMatrix $matrix )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

matrix

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::setLineWidth
CairoContext::setMiterLimit
CairoContext


The setMiterLimit purpose

CairoContext::setMatrix
CairoContext::setOperator
CairoContext
PHP Manual

CairoContext::setMiterLimit

cairo_set_miter_limit

(PECL cairo >= 0.1.0)

CairoContext::setMiterLimit -- cairo_set_miter_limit — The setMiterLimit purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::setMiterLimit ( string $limit )

Yordamsal kullanım:

void cairo_set_miter_limit ( CairoContext $context , string $limit )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

limit

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::setMatrix
CairoContext::setOperator
CairoContext


The setOperator purpose

CairoContext::setMiterLimit
CairoContext::setScaledFont
CairoContext
PHP Manual

CairoContext::setOperator

cairo_set_operator

(PECL cairo >= 0.1.0)

CairoContext::setOperator -- cairo_set_operator — The setOperator purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::setOperator ( string $setting )

Yordamsal kullanım:

void cairo_set_operator ( CairoContext $context , string $setting )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

setting

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::setMiterLimit
CairoContext::setScaledFont
CairoContext


The setScaledFont purpose

CairoContext::setOperator
CairoContext::setSource
CairoContext
PHP Manual

CairoContext::setScaledFont

cairo_set_scaled_font

(PECL cairo >= 0.1.0)

CairoContext::setScaledFont -- cairo_set_scaled_font — The setScaledFont purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::setScaledFont ( string $scaledfont )

Yordamsal kullanım:

void cairo_set_scaled_font ( CairoContext $context , CairoScaledFont $scaledfont )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

scaledfont

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::setOperator
CairoContext::setSource
CairoContext


The setSource purpose

CairoContext::setScaledFont
CairoContext::setSourceRGB
CairoContext
PHP Manual

CairoContext::setSource

cairo_set_source

(PECL cairo >= 0.1.0)

CairoContext::setSource -- cairo_set_source — The setSource purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::setSource ( string $pattern )

Yordamsal kullanım:

void cairo_set_source ( CairoContext $context , CairoPattern $pattern )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

pattern

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::setScaledFont
CairoContext::setSourceRGB
CairoContext


The setSourceRGB purpose

CairoContext::setSource
CairoContext::setSourceRGBA
CairoContext
PHP Manual

CairoContext::setSourceRGB

cairo_set_source

(PECL cairo >= 0.1.0)

CairoContext::setSourceRGB -- cairo_set_source — The setSourceRGB purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::setSourceRGB ( string $red , string $green , string $blue )

Yordamsal kullanım:

void cairo_set_source ( CairoContext $context , CairoPattern $pattern )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

pattern

Description...

red

Description...

green

Description...

blue

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::setSource
CairoContext::setSourceRGBA
CairoContext


The setSourceRGBA purpose

CairoContext::setSourceRGB
CairoContext::setSourceSurface
CairoContext
PHP Manual

CairoContext::setSourceRGBA

cairo_set_source

(PECL cairo >= 0.1.0)

CairoContext::setSourceRGBA -- cairo_set_source — The setSourceRGBA purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::setSourceRGBA ( string $red , string $green , string $blue , string $alpha )

Yordamsal kullanım:

void cairo_set_source ( CairoContext $context , CairoPattern $pattern )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

pattern

Description...

red

Description...

green

Description...

blue

Description...

alpha

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::setSourceRGB
CairoContext::setSourceSurface
CairoContext


The setSourceSurface purpose

CairoContext::setSourceRGBA
CairoContext::setTolerance
CairoContext
PHP Manual

CairoContext::setSourceSurface

cairo_set_source_surface

(PECL cairo >= 0.1.0)

CairoContext::setSourceSurface -- cairo_set_source_surface — The setSourceSurface purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::setSourceSurface ( string $surface [, string $x [, string $y ]] )

Yordamsal kullanım:

void cairo_set_source_surface ( CairoContext $context , CairoSurface $surface [, string $x [, string $y ]] )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

surface

Description...

x

Description...

y

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::setSourceRGBA
CairoContext::setTolerance
CairoContext


The setTolerance purpose

CairoContext::setSourceSurface
CairoContext::showPage
CairoContext
PHP Manual

CairoContext::setTolerance

cairo_set_tolerance

(PECL cairo >= 0.1.0)

CairoContext::setTolerance -- cairo_set_tolerance — The setTolerance purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::setTolerance ( string $tolerance )

Yordamsal kullanım:

void cairo_set_tolerance ( CairoContext $context , string $tolerance )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

tolerance

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::setSourceSurface
CairoContext::showPage
CairoContext


The showPage purpose

CairoContext::setTolerance
CairoContext::showText
CairoContext
PHP Manual

CairoContext::showPage

cairo_show_page

(PECL cairo >= 0.1.0)

CairoContext::showPage -- cairo_show_page — The showPage purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::showPage ( void )

Yordamsal kullanım:

void cairo_show_page ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::setTolerance
CairoContext::showText
CairoContext


The showText purpose

CairoContext::showPage
CairoContext::status
CairoContext
PHP Manual

CairoContext::showText

cairo_show_text

(PECL cairo >= 0.1.0)

CairoContext::showText -- cairo_show_text — The showText purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::showText ( string $text )

Yordamsal kullanım:

void cairo_show_text ( CairoContext $context , string $text )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

text

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::showPage
CairoContext::status
CairoContext


The status purpose

CairoContext::showText
CairoContext::stroke
CairoContext
PHP Manual

CairoContext::status

cairo_status

(PECL cairo >= 0.1.0)

CairoContext::status -- cairo_status — The status purpose

Açıklama

Nesne yönelimli kullanım (method):

public int CairoContext::status ( void )

Yordamsal kullanım:

int cairo_status ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::showText
CairoContext::stroke
CairoContext


The stroke purpose

CairoContext::status
CairoContext::strokeExtents
CairoContext
PHP Manual

CairoContext::stroke

cairo_stroke

(PECL cairo >= 0.1.0)

CairoContext::stroke -- cairo_stroke — The stroke purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::stroke ( void )

Yordamsal kullanım:

void cairo_stroke ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::status
CairoContext::strokeExtents
CairoContext


The strokeExtents purpose

CairoContext::stroke
CairoContext::strokePreserve
CairoContext
PHP Manual

CairoContext::strokeExtents

cairo_stroke_extents

(PECL cairo >= 0.1.0)

CairoContext::strokeExtents -- cairo_stroke_extents — The strokeExtents purpose

Açıklama

Nesne yönelimli kullanım (method):

public array CairoContext::strokeExtents ( void )

Yordamsal kullanım:

array cairo_stroke_extents ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::stroke
CairoContext::strokePreserve
CairoContext


The strokePreserve purpose

CairoContext::strokeExtents
CairoContext::textExtents
CairoContext
PHP Manual

CairoContext::strokePreserve

cairo_stroke_preserve

(PECL cairo >= 0.1.0)

CairoContext::strokePreserve -- cairo_stroke_preserve — The strokePreserve purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::strokePreserve ( void )

Yordamsal kullanım:

void cairo_stroke_preserve ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::strokeExtents
CairoContext::textExtents
CairoContext


The textExtents purpose

CairoContext::strokePreserve
CairoContext::textPath
CairoContext
PHP Manual

CairoContext::textExtents

cairo_text_extents

(PECL cairo >= 0.1.0)

CairoContext::textExtents -- cairo_text_extents — The textExtents purpose

Açıklama

Nesne yönelimli kullanım (method):

public array CairoContext::textExtents ( string $text )

Yordamsal kullanım:

array cairo_text_extents ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

text

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::strokePreserve
CairoContext::textPath
CairoContext


The textPath purpose

CairoContext::textExtents
CairoContext::transform
CairoContext
PHP Manual

CairoContext::textPath

cairo_text_path

(PECL cairo >= 0.1.0)

CairoContext::textPath -- cairo_text_path — The textPath purpose

Açıklama

Nesne yönelimli kullanım

public void CairoContext::textPath ( string $string )

Yordamsal kullanım

void cairo_text_path ( CairoContext $context , string $text )

Adds closed paths for text to the current path. The generated path, if filled, achieves an effect similar to that of CairoContext::showText().

Text conversion and positioning is done similar to CairoContext::showText().

Like CairoContext::showText(), after this call the current point is moved to the origin of where the next glyph would be placed in this same progression. That is, the current point will be at the origin of the final glyph offset by its advance values. This allows for chaining multiple calls to CairoContext::showText() without having to set current point in between.

Note: The CairoContext::textPath() function call is part of what the cairo designers call the "toy" text API. It is convenient for short demos and simple programs, but it is not expected to be adequate for serious text-using applications. See CairoContext::glyphPath() for the "real" text path API in cairo.

Değiştirgeler

context

A CairoContext object

text

Description...

string

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::textExtents
CairoContext::transform
CairoContext


The transform purpose

CairoContext::textPath
CairoContext::translate
CairoContext
PHP Manual

CairoContext::transform

cairo_transform

(PECL cairo >= 0.1.0)

CairoContext::transform -- cairo_transform — The transform purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::transform ( string $matrix )

Yordamsal kullanım:

void cairo_transform ( CairoContext $context , CairoMatrix $matrix )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

matrix

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::textPath
CairoContext::translate
CairoContext


The translate purpose

CairoContext::transform
CairoContext::userToDevice
CairoContext
PHP Manual

CairoContext::translate

cairo_translate

(PECL cairo >= 0.1.0)

CairoContext::translate -- cairo_translate — The translate purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoContext::translate ( string $x , string $y )

Yordamsal kullanım:

void cairo_translate ( CairoContext $context , string $x , string $y )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

x

Description...

y

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::transform
CairoContext::userToDevice
CairoContext


The userToDevice purpose

CairoContext::translate
CairoContext::userToDeviceDistance
CairoContext
PHP Manual

CairoContext::userToDevice

cairo_user_to_device

(PECL cairo >= 0.1.0)

CairoContext::userToDevice -- cairo_user_to_device — The userToDevice purpose

Açıklama

Nesne yönelimli kullanım (method):

public array CairoContext::userToDevice ( string $x , string $y )

Yordamsal kullanım:

array cairo_user_to_device ( CairoContext $context , string $x , string $y )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

x

Description...

y

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::translate
CairoContext::userToDeviceDistance
CairoContext


The userToDeviceDistance purpose

CairoContext::userToDevice
CairoException
CairoContext
PHP Manual

CairoContext::userToDeviceDistance

cairo_user_to_device_distance

(PECL cairo >= 0.1.0)

CairoContext::userToDeviceDistance -- cairo_user_to_device_distance — The userToDeviceDistance purpose

Açıklama

Nesne yönelimli kullanım (method):

public array CairoContext::userToDeviceDistance ( string $x , string $y )

Yordamsal kullanım:

array cairo_user_to_device_distance ( CairoContext $context , string $x , string $y )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

x

Description...

y

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoContext::userToDevice
CairoException
CairoContext


The CairoException class

(PECL cairo >= 0.1.0)

Giriş

Exception class throwed by Cairo functions and methods

Sınıf Sözdizimi

CairoException extends Exception {
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}
CairoContext::userToDeviceDistance
CairoStatus
Cairo


The CairoStatus class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

CairoStatus is used to indicate errors that can occur when using Cairo. In some cases it is returned directly by functions. but when using CairoContext, the last error, if any, is stored in the object and can be retrieved with CairoContext::status() or cairo_status(). New entries may be added in future versions.

Use Cairo::statusToString() or cairo_status_to_string() to get a human-readable representation of an error message.

Sınıf Sözdizimi

CairoStatus {
/* Sabitler */
const integer SUCCESS = 0 ;
const integer NO_MEMORY = 1 ;
const integer INVALID_RESTORE = 2 ;
const integer INVALID_POP_GROUP = 3 ;
const integer NO_CURRENT_POINT = 4 ;
const integer INVALID_MATRIX = 5 ;
const integer INVALID_STATUS = 6 ;
const integer NULL_POINTER = 7 ;
const integer INVALID_STRING = 8 ;
const integer INVALID_PATH_DATA = 9 ;
const integer READ_ERROR = 10 ;
const integer WRITE_ERROR = 11 ;
const integer SURFACE_FINISHED = 12 ;
const integer SURFACE_TYPE_MISMATCH = 13 ;
const integer PATTERN_TYPE_MISMATCH = 14 ;
const integer INVALID_CONTENT = 15 ;
const integer INVALID_FORMAT = 16 ;
const integer INVALID_VISUAL = 17 ;
const integer FILE_NOT_FOUND = 18 ;
const integer INVALID_DASH = 19 ;
const integer INVALID_DSC_COMMENT = 20 ;
const integer INVALID_INDEX = 21 ;
const integer CLIP_NOT_REPRESENTABLE = 22 ;
const integer TEMP_FILE_ERROR = 23 ;
const integer INVALID_STRIDE = 24 ;
}

Öntanımlı Sabitler

CairoStatus::SUCCESS

No error has occurred

CairoStatus::NO_MEMORY

Out of memory

CairoStatus::INVALID_RESTORE

cairo_restore() called without matching cairo_save()

CairoStatus::INVALID_POP_GROUP

No saved group to pop

CairoStatus::NO_CURRENT_POINT

No current point defined

CairoStatus::INVALID_MATRIX

Invalid matrix (not invertible)

CairoStatus::INVALID_STATUS

Invalid value for an input CairoStatus>

CairoStatus::NULL_POINTER

Null pointer

CairoStatus::INVALID_STRING

Input string not valid UTF-8 string

CairoStatus::INVALID_PATH_DATA

Input path data not valid

CairoStatus::READ_ERROR

Error while reading from input stream

CairoStatus::WRITE_ERROR

Error while writing to output stream

CairoStatus::SURFACE_FINISHED

Target surface has been finished

CairoStatus::SURFACE_TYPE_MISMATCH

The surface type is not appropriate for the operation

CairoStatus::PATTERN_TYPE_MISMATCH

The pattern type is not appropriate for the operation

CairoStatus::INVALID_CONTENT

Invalid value for an input CairoContent

CairoStatus::INVALID_FORMAT

Invalid value for an input CairoFormat

CairoStatus::INVALID_VISUAL

Invalid value for an input Visual

CairoStatus::FILE_NOT_FOUND

File not found

CairoStatus::INVALID_DASH

Invalid value for a dash setting

CairoStatus::INVALID_DSC_COMMENT

Invalid value for a DSC comment

CairoStatus::INVALID_INDEX

Invalid index passed to getter

CairoStatus::CLIP_NOT_REPRESENTABLE

Clip region not representable in desired format

CairoStatus::TEMP_FILE_ERROR

Error creating or writing to a temporary file

CairoStatus::INVALID_STRIDE

Invalid value for CairoStride

CairoException
CairoSurface
Cairo


The CairoSurface class

(PECL cairo >= 0.1.0)

Giriş

This is the base-class for all other Surface types. CairoSurface is the abstract type representing all different drawing targets that cairo can render to. The actual drawings are performed using a CairoContext.

Sınıf Sözdizimi

CairoSurface {
/* Yöntemler */
public __construct ( void )
public void copyPage ( void )
public void createSimilar ( CairoSurface $other , int $content , string $width , string $height )
public void finish ( void )
public void flush ( void )
public int getContent ( void )
public array getDeviceOffset ( void )
public void getFontOptions ( void )
public int getType ( void )
public void markDirty ( void )
public void markDirtyRectangle ( string $x , string $y , string $width , string $height )
public void setDeviceOffset ( string $x , string $y )
public void setFallbackResolution ( string $x , string $y )
public void showPage ( void )
public int status ( void )
public void writeToPng ( string $file )
}

İçindekiler

  • CairoSurface::__construct — The __construct purpose
  • CairoSurface::copyPage — The copyPage purpose
  • CairoSurface::createSimilar — The createSimilar purpose
  • CairoSurface::finish — The finish purpose
  • CairoSurface::flush — The flush purpose
  • CairoSurface::getContent — The getContent purpose
  • CairoSurface::getDeviceOffset — The getDeviceOffset purpose
  • CairoSurface::getFontOptions — The getFontOptions purpose
  • CairoSurface::getType — The getType purpose
  • CairoSurface::markDirty — The markDirty purpose
  • CairoSurface::markDirtyRectangle — The markDirtyRectangle purpose
  • CairoSurface::setDeviceOffset — The setDeviceOffset purpose
  • CairoSurface::setFallbackResolution — The setFallbackResolution purpose
  • CairoSurface::showPage — The showPage purpose
  • CairoSurface::status — The status purpose
  • CairoSurface::writeToPng — The writeToPng purpose
CairoStatus
CairoSurface::__construct
Cairo


The __construct purpose

CairoSurface
CairoSurface::copyPage
CairoSurface
PHP Manual

CairoSurface::__construct

(PECL cairo >= 0.1.0)

CairoSurface::__construct — The __construct purpose

Açıklama

public CairoSurface::__construct ( void )

CairoSurface is an abstract type and, as such, should not be instantiated in your PHP scripts.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

No return value

Notlar

Bilginize:

If you're using a PHP version before 5.3, you must destroy the CairoContext associated with a CairoSurface after you destroy the CairoSurface. Otherwise, you're left with a Circular-reference memory leak.

Ayrıca Bakınız

  • CairoImageSurface::__construct() - Creates a new CairoImageSurface

CairoSurface
CairoSurface::copyPage
CairoSurface


The copyPage purpose

CairoSurface::__construct
CairoSurface::createSimilar
CairoSurface
PHP Manual

CairoSurface::copyPage

cairo_copy_page

(PECL cairo >= 0.1.0)

CairoSurface::copyPage -- cairo_copy_page — The copyPage purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoSurface::copyPage ( void )

Yordamsal kullanım:

void cairo_copy_page ( CairoContext $context )

Emits the current page for backends that support multiple pages, but doesn't clear it, so that the contents of the current page will be retained for the next page. Use CairoSurface::showPage() if you want to get an empty page after the emission.

Değiştirgeler

context

A CairoContext object

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoSurface::__construct
CairoSurface::createSimilar
CairoSurface


The createSimilar purpose

CairoSurface::copyPage
CairoSurface::finish
CairoSurface
PHP Manual

CairoSurface::createSimilar

(PECL cairo >= 0.1.0)

CairoSurface::createSimilar — The createSimilar purpose

Açıklama

public void CairoSurface::createSimilar ( CairoSurface $other , int $content , string $width , string $height )

Create a new surface that is as compatible as possible with an existing surface. For example the new surface will have the same fallback resolution and font options as other. Generally, the new surface will also use the same backend as other, unless that is not possible for some reason. The type of the returned surface may be examined with CairoSurface::getType(). Initially the surface contents are all 0 (transparent if contents have transparency, black otherwise.)

Değiştirgeler

other

An existing surface used to select the backend of the new surface

content

The content for the new surface. See the CairoContent class for possible values.

width

Width of the new surface, (in device-space units).

height

Height of the new surface, (in device-space units).

Dönen Değerler

A new CairoSurface

Örnekler

Örnek 1 CairoSurface::createSimilar() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • CairoContent()

CairoSurface::copyPage
CairoSurface::finish
CairoSurface


The finish purpose

CairoSurface::createSimilar
CairoSurface::flush
CairoSurface
PHP Manual

CairoSurface::finish

(PECL cairo >= 0.1.0)

CairoSurface::finish — The finish purpose

Açıklama

public void CairoSurface::finish ( void )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoSurface::finish() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoSurface::createSimilar
CairoSurface::flush
CairoSurface


The flush purpose

CairoSurface::finish
CairoSurface::getContent
CairoSurface
PHP Manual

CairoSurface::flush

(PECL cairo >= 0.1.0)

CairoSurface::flush — The flush purpose

Açıklama

public void CairoSurface::flush ( void )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoSurface::flush() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoSurface::finish
CairoSurface::getContent
CairoSurface


The getContent purpose

CairoSurface::flush
CairoSurface::getDeviceOffset
CairoSurface
PHP Manual

CairoSurface::getContent

(PECL cairo >= 0.1.0)

CairoSurface::getContent — The getContent purpose

Açıklama

public int CairoSurface::getContent ( void )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoSurface::getContent() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoSurface::flush
CairoSurface::getDeviceOffset
CairoSurface


The getDeviceOffset purpose

CairoSurface::getContent
CairoSurface::getFontOptions
CairoSurface
PHP Manual

CairoSurface::getDeviceOffset

(PECL cairo >= 0.1.0)

CairoSurface::getDeviceOffset — The getDeviceOffset purpose

Açıklama

public array CairoSurface::getDeviceOffset ( void )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoSurface::getDeviceOffset() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoSurface::getContent
CairoSurface::getFontOptions
CairoSurface


The getFontOptions purpose

CairoSurface::getDeviceOffset
CairoSurface::getType
CairoSurface
PHP Manual

CairoSurface::getFontOptions

cairo_get_font_options

(PECL cairo >= 0.1.0)

CairoSurface::getFontOptions -- cairo_get_font_options — The getFontOptions purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoSurface::getFontOptions ( void )

Yordamsal kullanım:

void cairo_get_font_options ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoSurface::getDeviceOffset
CairoSurface::getType
CairoSurface


The getType purpose

CairoSurface::getFontOptions
CairoSurface::markDirty
CairoSurface
PHP Manual

CairoSurface::getType

(PECL cairo >= 0.1.0)

CairoSurface::getType — The getType purpose

Açıklama

public int CairoSurface::getType ( void )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoSurface::getType() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoSurface::getFontOptions
CairoSurface::markDirty
CairoSurface


The markDirty purpose

CairoSurface::getType
CairoSurface::markDirtyRectangle
CairoSurface
PHP Manual

CairoSurface::markDirty

(PECL cairo >= 0.1.0)

CairoSurface::markDirty — The markDirty purpose

Açıklama

public void CairoSurface::markDirty ( void )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoSurface::markDirty() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoSurface::getType
CairoSurface::markDirtyRectangle
CairoSurface


The markDirtyRectangle purpose

CairoSurface::markDirty
CairoSurface::setDeviceOffset
CairoSurface
PHP Manual

CairoSurface::markDirtyRectangle

(PECL cairo >= 0.1.0)

CairoSurface::markDirtyRectangle — The markDirtyRectangle purpose

Açıklama

public void CairoSurface::markDirtyRectangle ( string $x , string $y , string $width , string $height )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

x

Description...

y

Description...

width

Description...

height

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoSurface::markDirtyRectangle() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoSurface::markDirty
CairoSurface::setDeviceOffset
CairoSurface


The setDeviceOffset purpose

CairoSurface::markDirtyRectangle
CairoSurface::setFallbackResolution
CairoSurface
PHP Manual

CairoSurface::setDeviceOffset

(PECL cairo >= 0.1.0)

CairoSurface::setDeviceOffset — The setDeviceOffset purpose

Açıklama

public void CairoSurface::setDeviceOffset ( string $x , string $y )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

x

Description...

y

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoSurface::setDeviceOffset() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoSurface::markDirtyRectangle
CairoSurface::setFallbackResolution
CairoSurface


The setFallbackResolution purpose

CairoSurface::setDeviceOffset
CairoSurface::showPage
CairoSurface
PHP Manual

CairoSurface::setFallbackResolution

(PECL cairo >= 0.1.0)

CairoSurface::setFallbackResolution — The setFallbackResolution purpose

Açıklama

public void CairoSurface::setFallbackResolution ( string $x , string $y )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

x

Description...

y

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoSurface::setFallbackResolution() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoSurface::setDeviceOffset
CairoSurface::showPage
CairoSurface


The showPage purpose

CairoSurface::setFallbackResolution
CairoSurface::status
CairoSurface
PHP Manual

CairoSurface::showPage

cairo_show_page

(PECL cairo >= 0.1.0)

CairoSurface::showPage -- cairo_show_page — The showPage purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoSurface::showPage ( void )

Yordamsal kullanım:

void cairo_show_page ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoSurface::setFallbackResolution
CairoSurface::status
CairoSurface


The status purpose

CairoSurface::showPage
CairoSurface::writeToPng
CairoSurface
PHP Manual

CairoSurface::status

cairo_status

(PECL cairo >= 0.1.0)

CairoSurface::status -- cairo_status — The status purpose

Açıklama

Nesne yönelimli kullanım (method):

public int CairoSurface::status ( void )

Yordamsal kullanım:

int cairo_status ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoSurface::showPage
CairoSurface::writeToPng
CairoSurface


The writeToPng purpose

CairoSurface::status
CairoSvgSurface
CairoSurface
PHP Manual

CairoSurface::writeToPng

(PECL cairo >= 0.1.0)

CairoSurface::writeToPng — The writeToPng purpose

Açıklama

public void CairoSurface::writeToPng ( string $file )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

file

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoSurface::writeToPng() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoSurface::status
CairoSvgSurface
CairoSurface


Svg Surface Backend

(PECL cairo >= 0.1.0)

Giriş

Svg specific surface class, uses the SVG (standard vector graphics) surface backend.

Sınıf Sözdizimi

CairoSvgSurface extends CairoSurface {
/* Yöntemler */
public __construct ( string $file , float $width , float $height )
public static array getVersions ( void )
public void restrictToVersion ( string $version )
public static string versionToString ( int $version )
/* Miras alınan yöntemler */
public CairoSurface::__construct ( void )
public void CairoSurface::copyPage ( void )
public void CairoSurface::createSimilar ( CairoSurface $other , int $content , string $width , string $height )
public void CairoSurface::finish ( void )
public void CairoSurface::flush ( void )
public int CairoSurface::getContent ( void )
public array CairoSurface::getDeviceOffset ( void )
public void CairoSurface::getFontOptions ( void )
public int CairoSurface::getType ( void )
public void CairoSurface::markDirty ( void )
public void CairoSurface::markDirtyRectangle ( string $x , string $y , string $width , string $height )
public void CairoSurface::setDeviceOffset ( string $x , string $y )
public void CairoSurface::setFallbackResolution ( string $x , string $y )
public void CairoSurface::showPage ( void )
public int CairoSurface::status ( void )
public void CairoSurface::writeToPng ( string $file )
}

İçindekiler

  • CairoSvgSurface::__construct — The __construct purpose
  • CairoSvgSurface::getVersions — Used to retrieve a list of supported SVG versions
  • CairoSvgSurface::restrictToVersion — The restrictToVersion purpose
  • CairoSvgSurface::versionToString — The versionToString purpose
CairoSurface::writeToPng
CairoSvgSurface::__construct
Cairo


The __construct purpose

CairoSvgSurface
CairoSvgSurface::getVersions
CairoSvgSurface
PHP Manual

CairoSvgSurface::__construct

(PECL cairo >= 0.1.0)

CairoSvgSurface::__construct — The __construct purpose

Açıklama

public CairoSvgSurface::__construct ( string $file , float $width , float $height )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

file

Description...

width

Description...

height

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoSvgSurface::__construct() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoSvgSurface
CairoSvgSurface::getVersions
CairoSvgSurface


Used to retrieve a list of supported SVG versions

CairoSvgSurface::__construct
CairoSvgSurface::restrictToVersion
CairoSvgSurface
PHP Manual

CairoSvgSurface::getVersions

cairo_svg_surface_get_versions

(PECL cairo >= 0.1.0)

CairoSvgSurface::getVersions -- cairo_svg_surface_get_versions — Used to retrieve a list of supported SVG versions

Açıklama

Nesne yönelimli kullanım (method):

public static array CairoSvgSurface::getVersions ( void )

Yordamsal kullanım:

array cairo_svg_get_versions ( void )

Returns a numerically indexed array of currently available CairoSvgVersion constants. In order to retreive the string values for each item, use CairoSvgSurface::versionToString().

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a numerically indexed array of integer values.

Örnekler

Örnek 1 CairoSvgSurface::getVersions() example

<?php
/* Grab our list of versions */
$versions = CairoSvgSurface::getVersions();
var_dump($versions);

/* echo the string name of each version */
foreach($versions as $id) {
    echo CairoSvgSurface::versionToString($id), PHP_EOL;
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(2) {
  [0]=>
  int(0)
  [1]=>
  int(1)
}
SVG 1.1
SVG 1.2

Örnek 2 Yordamsal kullanım

<?php
/* Grab our list of versions */
$versions = cairo_svg_surface_get_versions();
var_dump($versions);

/* echo the string name of each version */
foreach($versions as $id) {
    echo cairo_svg_surface_version_to_string($id), PHP_EOL;
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(2) {
  [0]=>
  int(0)
  [1]=>
  int(1)
}
SVG 1.1
SVG 1.2

Ayrıca Bakınız

  • CairoSvgSurface::versionToString() - The versionToString purpose

CairoSvgSurface::__construct
CairoSvgSurface::restrictToVersion
CairoSvgSurface


The restrictToVersion purpose

CairoSvgSurface::getVersions
CairoSvgSurface::versionToString
CairoSvgSurface
PHP Manual

CairoSvgSurface::restrictToVersion

(PECL cairo >= 0.1.0)

CairoSvgSurface::restrictToVersion — The restrictToVersion purpose

Açıklama

public void CairoSvgSurface::restrictToVersion ( string $version )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

version

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoSvgSurface::restrictToVersion() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoSvgSurface::getVersions
CairoSvgSurface::versionToString
CairoSvgSurface


The versionToString purpose

CairoSvgSurface::restrictToVersion
CairoImageSurface
CairoSvgSurface
PHP Manual

CairoSvgSurface::versionToString

(PECL cairo >= 0.1.0)

CairoSvgSurface::versionToString — The versionToString purpose

Açıklama

public static string CairoSvgSurface::versionToString ( int $version )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

version

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoSvgSurface::versionToString() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoSvgSurface::restrictToVersion
CairoImageSurface
CairoSvgSurface


The CairoImageSurface class

(PECL cairo >= 0.1.0)

Giriş

CairoImageSurface provide the ability to render to memory buffers either allocated by cairo or by the calling code. The supported image formats are those defined in CairoFormat.

Sınıf Sözdizimi

CairoImageSurface extends CairoSurface {
/* Yöntemler */
public __construct ( int $format , int $width , int $height )
public static void createForData ( string $data , int $format , int $width , int $height [, int $stride = -1 ] )
public static CairoImageSurface createFromPng ( string $file )
public string getData ( void )
public int getFormat ( void )
public int getHeight ( void )
public int getStride ( void )
public int getWidth ( void )
/* Miras alınan yöntemler */
public CairoSurface::__construct ( void )
public void CairoSurface::copyPage ( void )
public void CairoSurface::createSimilar ( CairoSurface $other , int $content , string $width , string $height )
public void CairoSurface::finish ( void )
public void CairoSurface::flush ( void )
public int CairoSurface::getContent ( void )
public array CairoSurface::getDeviceOffset ( void )
public void CairoSurface::getFontOptions ( void )
public int CairoSurface::getType ( void )
public void CairoSurface::markDirty ( void )
public void CairoSurface::markDirtyRectangle ( string $x , string $y , string $width , string $height )
public void CairoSurface::setDeviceOffset ( string $x , string $y )
public void CairoSurface::setFallbackResolution ( string $x , string $y )
public void CairoSurface::showPage ( void )
public int CairoSurface::status ( void )
public void CairoSurface::writeToPng ( string $file )
}

İçindekiler

  • CairoImageSurface::__construct — Creates a new CairoImageSurface
  • CairoImageSurface::createForData — The createForData purpose
  • CairoImageSurface::createFromPng — Creates a new CairoImageSurface form a png image file
  • CairoImageSurface::getData — Gets the image data as string
  • CairoImageSurface::getFormat — Get the image format
  • CairoImageSurface::getHeight — Retrieves the height of the CairoImageSurface
  • CairoImageSurface::getStride — The getStride purpose
  • CairoImageSurface::getWidth — Retrieves the width of the CairoImageSurface
CairoSvgSurface::versionToString
CairoImageSurface::__construct
Cairo


Creates a new CairoImageSurface

CairoImageSurface
CairoImageSurface::createForData
CairoImageSurface
PHP Manual

CairoImageSurface::__construct

(PECL cairo >= 0.1.0)

CairoImageSurface::__construct — Creates a new CairoImageSurface

Açıklama

public CairoImageSurface::__construct ( int $format , int $width , int $height )

Creates a new CairoImageSuface object of type format

Değiştirgeler

format

Can be any defined in CairoFormat

width

The width of the image surface

height

The height of the image surface

Dönen Değerler

A new CairoImageSurface

Örnekler

Örnek 1 CairoImageSurface::__construct() example

<?php

// Creates a image with ARGB32 format of 50 width and 50 height
$surface = new CairoImageSurface(CairoFormat::ARGB32, 50,50);

?>

Ayrıca Bakınız

  • CairoContext::__construct() - Creates a new CairoContext

CairoImageSurface
CairoImageSurface::createForData
CairoImageSurface


The createForData purpose

CairoImageSurface::__construct
CairoImageSurface::createFromPng
CairoImageSurface
PHP Manual

CairoImageSurface::createForData

(PECL cairo >= 0.1.0)

CairoImageSurface::createForData — The createForData purpose

Açıklama

public static void CairoImageSurface::createForData ( string $data , int $format , int $width , int $height [, int $stride = -1 ] )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

data

Description...

format

Description...

width

Description...

height

Description...

stride

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoImageSurface::createForData() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoImageSurface::__construct
CairoImageSurface::createFromPng
CairoImageSurface


Creates a new CairoImageSurface form a png image file

CairoImageSurface::createForData
CairoImageSurface::getData
CairoImageSurface
PHP Manual

CairoImageSurface::createFromPng

(PECL cairo >= 0.1.0)

CairoImageSurface::createFromPng — Creates a new CairoImageSurface form a png image file

Açıklama

public static CairoImageSurface CairoImageSurface::createFromPng ( string $file )

Creates a new CairoImageSurface form a png image file

This method should be called static

Değiştirgeler

file

Path to PNG image file

Dönen Değerler

CairoImageSurface object

Örnekler

Örnek 1 CairoImageSurface::createFromPng() example

<?php

$surface = CairoImageSurface::createFromPng('/path/to/image/file.png');

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • CairoImageSurface::__construct() - Creates a new CairoImageSurface

CairoImageSurface::createForData
CairoImageSurface::getData
CairoImageSurface


Gets the image data as string

CairoImageSurface::createFromPng
CairoImageSurface::getFormat
CairoImageSurface
PHP Manual

CairoImageSurface::getData

(PECL cairo >= 0.1.0)

CairoImageSurface::getData — Gets the image data as string

Açıklama

public string CairoImageSurface::getData ( void )

Returns the image data of this surface or NULL if surface is not an image surface, or if CairoContext::finish(), procedural : cairo_surface_finish(), has been called.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The image data as string

Örnekler

Örnek 1 CairoImageSurface::getData() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • CairoImageSurface::getStride() - The getStride purpose

CairoImageSurface::createFromPng
CairoImageSurface::getFormat
CairoImageSurface


Get the image format

CairoImageSurface::getData
CairoImageSurface::getHeight
CairoImageSurface
PHP Manual

CairoImageSurface::getFormat

(PECL cairo >= 0.1.0)

CairoImageSurface::getFormat — Get the image format

Açıklama

public int CairoImageSurface::getFormat ( void )

Retrieves the image format, as one of the CairoFormat defined

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

One of the CairoFormat enums

Örnekler

Örnek 1 CairoImageSurface::getFormat() example

<?php

$surface = new CairoImageSurface(CairoFormat::ARGB32, 50, 50);

var_dump($surface->getFormat()); // 0

$surface2 = new CairoImageSurface(CairoFormat::A8, 50, 50);

var_dump($surface2->getFormat()); // 2

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(0)
int(2)

Ayrıca Bakınız

  • CairoImageSurface::getHeight() - Retrieves the height of the CairoImageSurface
  • CairoImageSurface::getWidth() - Retrieves the width of the CairoImageSurface

CairoImageSurface::getData
CairoImageSurface::getHeight
CairoImageSurface


Retrieves the height of the CairoImageSurface

CairoImageSurface::getFormat
CairoImageSurface::getStride
CairoImageSurface
PHP Manual

CairoImageSurface::getHeight

(PECL cairo >= 0.1.0)

CairoImageSurface::getHeight — Retrieves the height of the CairoImageSurface

Açıklama

public int CairoImageSurface::getHeight ( void )

This methods returns the CairoImageSurface height.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

CairoImageSurface object height

Örnekler

Örnek 1 CairoImageSurface::getHeight() example

<?php
// creates a new image surface
$surface = new CairoImageSurface(CairoFormat::ARGB32, 80, 50);

//gets the height
var_dump($surface->getHeight());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(50)

Ayrıca Bakınız

  • CairoImageSurface::getWidth() - Retrieves the width of the CairoImageSurface

CairoImageSurface::getFormat
CairoImageSurface::getStride
CairoImageSurface


The getStride purpose

CairoImageSurface::getHeight
CairoImageSurface::getWidth
CairoImageSurface
PHP Manual

CairoImageSurface::getStride

(PECL cairo >= 0.1.0)

CairoImageSurface::getStride — The getStride purpose

Açıklama

public int CairoImageSurface::getStride ( void )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoImageSurface::getStride() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoImageSurface::getHeight
CairoImageSurface::getWidth
CairoImageSurface


Retrieves the width of the CairoImageSurface

CairoImageSurface::getStride
CairoPdfSurface
CairoImageSurface
PHP Manual

CairoImageSurface::getWidth

(PECL cairo >= 0.1.0)

CairoImageSurface::getWidth — Retrieves the width of the CairoImageSurface

Açıklama

public int CairoImageSurface::getWidth ( void )

Gets the width of the CairoImageSurface

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the width of the CairoImageSurface object

Örnekler

Örnek 1 CairoImageSurface::getWidth() example

<?php
// creates a new image surface
$surface = new CairoImageSurface(CairoFormat::ARGB32, 80, 50);

//gets the width
var_dump($surface->getWidth());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(80)

Ayrıca Bakınız

  • CairoImageSurface::getHeight() - Retrieves the height of the CairoImageSurface

CairoImageSurface::getStride
CairoPdfSurface
CairoImageSurface


The CairoPdfSurface class

(PECL cairo >= 0.1.0)

Giriş

Sınıf Sözdizimi

CairoPdfSurface extends CairoSurface {
/* Yöntemler */
public __construct ( string $file , float $width , float $height )
public void setSize ( string $width , string $height )
/* Miras alınan yöntemler */
public CairoSurface::__construct ( void )
public void CairoSurface::copyPage ( void )
public void CairoSurface::createSimilar ( CairoSurface $other , int $content , string $width , string $height )
public void CairoSurface::finish ( void )
public void CairoSurface::flush ( void )
public int CairoSurface::getContent ( void )
public array CairoSurface::getDeviceOffset ( void )
public void CairoSurface::getFontOptions ( void )
public int CairoSurface::getType ( void )
public void CairoSurface::markDirty ( void )
public void CairoSurface::markDirtyRectangle ( string $x , string $y , string $width , string $height )
public void CairoSurface::setDeviceOffset ( string $x , string $y )
public void CairoSurface::setFallbackResolution ( string $x , string $y )
public void CairoSurface::showPage ( void )
public int CairoSurface::status ( void )
public void CairoSurface::writeToPng ( string $file )
}

İçindekiler

  • CairoPdfSurface::__construct — The __construct purpose
  • CairoPdfSurface::setSize — The setSize purpose
CairoImageSurface::getWidth
CairoPdfSurface::__construct
Cairo


The __construct purpose

CairoPdfSurface
CairoPdfSurface::setSize
CairoPdfSurface
PHP Manual

CairoPdfSurface::__construct

(PECL cairo >= 0.1.0)

CairoPdfSurface::__construct — The __construct purpose

Açıklama

public CairoPdfSurface::__construct ( string $file , float $width , float $height )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

file

Description...

width

Description...

height

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoPdfSurface::__construct() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoPdfSurface
CairoPdfSurface::setSize
CairoPdfSurface


The setSize purpose

CairoPdfSurface::__construct
CairoPsSurface
CairoPdfSurface
PHP Manual

CairoPdfSurface::setSize

(PECL cairo >= 0.1.0)

CairoPdfSurface::setSize — The setSize purpose

Açıklama

public void CairoPdfSurface::setSize ( string $width , string $height )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

width

Description...

height

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoPdfSurface::setSize() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoPdfSurface::__construct
CairoPsSurface
CairoPdfSurface


The CairoPsSurface class

(PECL cairo >= 0.1.0)

Giriş

Sınıf Sözdizimi

CairoPsSurface extends CairoSurface {
/* Yöntemler */
public __construct ( string $file , float $width , float $height )
public void dscBeginPageSetup ( void )
public void dscBeginSetup ( void )
public void dscComment ( string $comment )
public bool getEps ( void )
public static array getLevels ( void )
public static string levelToString ( int $level )
public void restrictToLevel ( string $level )
public void setEps ( string $level )
public void setSize ( string $width , string $height )
/* Miras alınan yöntemler */
public CairoSurface::__construct ( void )
public void CairoSurface::copyPage ( void )
public void CairoSurface::createSimilar ( CairoSurface $other , int $content , string $width , string $height )
public void CairoSurface::finish ( void )
public void CairoSurface::flush ( void )
public int CairoSurface::getContent ( void )
public array CairoSurface::getDeviceOffset ( void )
public void CairoSurface::getFontOptions ( void )
public int CairoSurface::getType ( void )
public void CairoSurface::markDirty ( void )
public void CairoSurface::markDirtyRectangle ( string $x , string $y , string $width , string $height )
public void CairoSurface::setDeviceOffset ( string $x , string $y )
public void CairoSurface::setFallbackResolution ( string $x , string $y )
public void CairoSurface::showPage ( void )
public int CairoSurface::status ( void )
public void CairoSurface::writeToPng ( string $file )
}

İçindekiler

  • CairoPsSurface::__construct — The __construct purpose
  • CairoPsSurface::dscBeginPageSetup — The dscBeginPageSetup purpose
  • CairoPsSurface::dscBeginSetup — The dscBeginSetup purpose
  • CairoPsSurface::dscComment — The dscComment purpose
  • CairoPsSurface::getEps — The getEps purpose
  • CairoPsSurface::getLevels — The getLevels purpose
  • CairoPsSurface::levelToString — The levelToString purpose
  • CairoPsSurface::restrictToLevel — The restrictToLevel purpose
  • CairoPsSurface::setEps — The setEps purpose
  • CairoPsSurface::setSize — The setSize purpose
CairoPdfSurface::setSize
CairoPsSurface::__construct
Cairo


The __construct purpose

CairoPsSurface
CairoPsSurface::dscBeginPageSetup
CairoPsSurface
PHP Manual

CairoPsSurface::__construct

(PECL cairo >= 0.1.0)

CairoPsSurface::__construct — The __construct purpose

Açıklama

public CairoPsSurface::__construct ( string $file , float $width , float $height )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

file

Description...

width

Description...

height

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoPsSurface::__construct() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoPsSurface
CairoPsSurface::dscBeginPageSetup
CairoPsSurface


The dscBeginPageSetup purpose

CairoPsSurface::__construct
CairoPsSurface::dscBeginSetup
CairoPsSurface
PHP Manual

CairoPsSurface::dscBeginPageSetup

(PECL cairo >= 0.1.0)

CairoPsSurface::dscBeginPageSetup — The dscBeginPageSetup purpose

Açıklama

public void CairoPsSurface::dscBeginPageSetup ( void )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoPsSurface::dscBeginPageSetup() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoPsSurface::__construct
CairoPsSurface::dscBeginSetup
CairoPsSurface


The dscBeginSetup purpose

CairoPsSurface::dscBeginPageSetup
CairoPsSurface::dscComment
CairoPsSurface
PHP Manual

CairoPsSurface::dscBeginSetup

(PECL cairo >= 0.1.0)

CairoPsSurface::dscBeginSetup — The dscBeginSetup purpose

Açıklama

public void CairoPsSurface::dscBeginSetup ( void )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoPsSurface::dscBeginSetup() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoPsSurface::dscBeginPageSetup
CairoPsSurface::dscComment
CairoPsSurface


The dscComment purpose

CairoPsSurface::dscBeginSetup
CairoPsSurface::getEps
CairoPsSurface
PHP Manual

CairoPsSurface::dscComment

(PECL cairo >= 0.1.0)

CairoPsSurface::dscComment — The dscComment purpose

Açıklama

public void CairoPsSurface::dscComment ( string $comment )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

comment

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoPsSurface::dscComment() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoPsSurface::dscBeginSetup
CairoPsSurface::getEps
CairoPsSurface


The getEps purpose

CairoPsSurface::dscComment
CairoPsSurface::getLevels
CairoPsSurface
PHP Manual

CairoPsSurface::getEps

(PECL cairo >= 0.1.0)

CairoPsSurface::getEps — The getEps purpose

Açıklama

public bool CairoPsSurface::getEps ( void )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoPsSurface::getEps() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoPsSurface::dscComment
CairoPsSurface::getLevels
CairoPsSurface


The getLevels purpose

CairoPsSurface::getEps
CairoPsSurface::levelToString
CairoPsSurface
PHP Manual

CairoPsSurface::getLevels

(PECL cairo >= 0.1.0)

CairoPsSurface::getLevels — The getLevels purpose

Açıklama

public static array CairoPsSurface::getLevels ( void )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoPsSurface::getLevels() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoPsSurface::getEps
CairoPsSurface::levelToString
CairoPsSurface


The levelToString purpose

CairoPsSurface::getLevels
CairoPsSurface::restrictToLevel
CairoPsSurface
PHP Manual

CairoPsSurface::levelToString

(PECL cairo >= 0.1.0)

CairoPsSurface::levelToString — The levelToString purpose

Açıklama

public static string CairoPsSurface::levelToString ( int $level )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

level

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoPsSurface::levelToString() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoPsSurface::getLevels
CairoPsSurface::restrictToLevel
CairoPsSurface


The restrictToLevel purpose

CairoPsSurface::levelToString
CairoPsSurface::setEps
CairoPsSurface
PHP Manual

CairoPsSurface::restrictToLevel

(PECL cairo >= 0.1.0)

CairoPsSurface::restrictToLevel — The restrictToLevel purpose

Açıklama

public void CairoPsSurface::restrictToLevel ( string $level )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

level

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoPsSurface::restrictToLevel() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoPsSurface::levelToString
CairoPsSurface::setEps
CairoPsSurface


The setEps purpose

CairoPsSurface::restrictToLevel
CairoPsSurface::setSize
CairoPsSurface
PHP Manual

CairoPsSurface::setEps

(PECL cairo >= 0.1.0)

CairoPsSurface::setEps — The setEps purpose

Açıklama

public void CairoPsSurface::setEps ( string $level )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

level

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoPsSurface::setEps() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoPsSurface::restrictToLevel
CairoPsSurface::setSize
CairoPsSurface


The setSize purpose

CairoPsSurface::setEps
CairoSurfaceType
CairoPsSurface
PHP Manual

CairoPsSurface::setSize

(PECL cairo >= 0.1.0)

CairoPsSurface::setSize — The setSize purpose

Açıklama

public void CairoPsSurface::setSize ( string $width , string $height )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

width

Description...

height

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoPsSurface::setSize() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoPsSurface::setEps
CairoSurfaceType
CairoPsSurface


The CairoSurfaceType class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

Sınıf Sözdizimi

CairoSurfaceType {
/* Sabitler */
const integer IMAGE = 0 ;
const integer PDF = 1 ;
const integer PS = 2 ;
const integer XLIB = 3 ;
const integer XCB = 4 ;
const integer GLITZ = 5 ;
const integer QUARTZ = 6 ;
const integer WIN32 = 7 ;
const integer BEOS = 8 ;
const integer DIRECTFB = 9 ;
const integer SVG = 10 ;
const integer OS2 = 11 ;
const integer WIN32_PRINTING = 12 ;
const integer QUARTZ_IMAGE = 13 ;
}

Öntanımlı Sabitler

CairoSurfaceType::IMAGE

Description here...

CairoSurfaceType::PDF

Description here...

CairoSurfaceType::PS

Description here...

CairoSurfaceType::XLIB

Description here...

CairoSurfaceType::XCB

Description here...

CairoSurfaceType::GLITZ

Description here...

CairoSurfaceType::QUARTZ

Description here...

CairoSurfaceType::WIN32

Description here...

CairoSurfaceType::BEOS

Description here...

CairoSurfaceType::DIRECTFB

Description here...

CairoSurfaceType::SVG

Description here...

CairoSurfaceType::OS2

Description here...

CairoSurfaceType::WIN32_PRINTING

Description here...

CairoSurfaceType::QUARTZ_IMAGE

Description here...

CairoPsSurface::setSize
CairoFontFace
Cairo


The CairoFontFace class

(PECL cairo >= 0.1.0)

Giriş

CairoFontFace abstract class represents a particular font at a particular weight, slant, and other characteristic but no transformation or size.

Note: This class can not be instantiated directly, it is created by CairoContext::getFontFace() or cairo_scaled_font_get_font_face().

Sınıf Sözdizimi

CairoFontFace {
/* Yöntemler */
public __construct ( void )
public int getType ( void )
public int status ( void )
}

İçindekiler

  • CairoFontFace::__construct — Creates a new CairoFontFace object
  • CairoFontFace::getType — Retrieves the font face type
  • CairoFontFace::status — Check for CairoFontFace errors
CairoSurfaceType
CairoFontFace::__construct
Cairo


Creates a new CairoFontFace object

CairoFontFace
CairoFontFace::getType
CairoFontFace
PHP Manual

CairoFontFace::__construct

(PECL cairo >= 0.1.0)

CairoFontFace::__construct — Creates a new CairoFontFace object

Açıklama

public CairoFontFace::__construct ( void )

CairoFontFace class represents a particular font at a particular weight, slant, and other characteristic but no transformation or size.

Note: This class can't be instantiated directly it is created by CairoContext::getFontFace() or cairo_scaled_font_get_font_face()

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

CairoFontFace

Örnekler

Örnek 1 CairoFontFace::__construct() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Class::Method()

CairoFontFace
CairoFontFace::getType
CairoFontFace


Retrieves the font face type

CairoFontFace::__construct
CairoFontFace::status
CairoFontFace
PHP Manual

CairoFontFace::getType

(PECL cairo >= 0.1.0)

CairoFontFace::getType — Retrieves the font face type

Açıklama

public int CairoFontFace::getType ( void )

This function returns the type of the backend used to create a font face. See CairoFontType class constants for available types.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A font type that can be any one defined in CairoFontType

Örnekler

Örnek 1 CairoFontFace::getType() example

<?php

// Creates the font face
$fontface = new CairoToyFontFace('sans-serif');

// Get the font face type
var_dump($fontface->getType());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(0)

Ayrıca Bakınız

  • Classname::Method()

CairoFontFace::__construct
CairoFontFace::status
CairoFontFace


Check for CairoFontFace errors

CairoFontFace::getType
CairoFontOptions
CairoFontFace
PHP Manual

CairoFontFace::status

cairo_font_face_status

(PECL cairo >= 0.1.0)

CairoFontFace::status -- cairo_font_face_status — Check for CairoFontFace errors

Açıklama

Nesne yönelimli kullanım (method):

public int CairoFontFace::status ( void )

Yordamsal kullanım:

int cairo_font_face_status ( CairoFontFace $fontface )

Checks whether an error has previously occurred for this font face

Değiştirgeler

fontface

A valid CairoFontFace object

Dönen Değerler

CAIRO_STATUS_SUCCESS or another error such as CAIRO_STATUS_NO_MEMORY.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php

// Creates the font face
$fontface = new CairoToyFontFace('sans-serif');

// Get the font face status
var_dump($fontface->status()); // should be the value of CAIRO_STATUS_SUCCESS

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(0)

Örnek 2 Yordamsal kullanım

<?php

// Creates the font face
$fontface = new CairoToyFontFace('sans-serif');

// Get the font face status
var_dump(cairo_font_face_status($fontface)); // should be the value of CAIRO_STATUS_SUCCESS

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(0)

Ayrıca Bakınız

  • Classname::Method()

CairoFontFace::getType
CairoFontOptions
CairoFontFace


The CairoFontOptions class

(PECL cairo >= 0.1.0)

Giriş

An opaque structure holding all options that are used when rendering fonts.

Individual features of a cairo_font_options_t can be set or accessed using functions named cairo_font_options_set_feature_name and cairo_font_options_get_feature_name, like cairo_font_options_set_antialias() and cairo_font_options_get_antialias().

New features may be added to CairoFontOptions in the future. For this reason CairoFontOptions::copy(), CairoFontOptions::equal(), CairoFontOptions::merge(), CairoFontOptions::hash() (cairo_font_options_copy(), cairo_font_options_equal(), cairo_font_options_merge(), and cairo_font_options_hash() in procedural way) should be used to copy, check for equality, merge, or compute a hash value of CairoFontOptions objects.

Sınıf Sözdizimi

CairoFontOptions {
/* Yöntemler */
public __construct ( void )
public bool equal ( string $other )
public int getAntialias ( void )
public int getHintMetrics ( void )
public int getHintStyle ( void )
public int getSubpixelOrder ( void )
public int hash ( void )
public void merge ( string $other )
public void setAntialias ( string $antialias )
public void setHintMetrics ( string $hint_metrics )
public void setHintStyle ( string $hint_style )
public void setSubpixelOrder ( string $subpixel_order )
public int status ( void )
}

İçindekiler

  • CairoFontOptions::__construct — The __construct purpose
  • CairoFontOptions::equal — The equal purpose
  • CairoFontOptions::getAntialias — The getAntialias purpose
  • CairoFontOptions::getHintMetrics — The getHintMetrics purpose
  • CairoFontOptions::getHintStyle — The getHintStyle purpose
  • CairoFontOptions::getSubpixelOrder — The getSubpixelOrder purpose
  • CairoFontOptions::hash — The hash purpose
  • CairoFontOptions::merge — The merge purpose
  • CairoFontOptions::setAntialias — The setAntialias purpose
  • CairoFontOptions::setHintMetrics — The setHintMetrics purpose
  • CairoFontOptions::setHintStyle — The setHintStyle purpose
  • CairoFontOptions::setSubpixelOrder — The setSubpixelOrder purpose
  • CairoFontOptions::status — The status purpose
CairoFontFace::status
CairoFontOptions::__construct
Cairo


The __construct purpose

CairoFontOptions
CairoFontOptions::equal
CairoFontOptions
PHP Manual

CairoFontOptions::__construct

(PECL cairo >= 0.1.0)

CairoFontOptions::__construct — The __construct purpose

Açıklama

public CairoFontOptions::__construct ( void )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoFontOptions::__construct() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoFontOptions
CairoFontOptions::equal
CairoFontOptions


The equal purpose

CairoFontOptions::__construct
CairoFontOptions::getAntialias
CairoFontOptions
PHP Manual

CairoFontOptions::equal

(PECL cairo >= 0.1.0)

CairoFontOptions::equal — The equal purpose

Açıklama

public bool CairoFontOptions::equal ( string $other )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

other

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoFontOptions::equal() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoFontOptions::__construct
CairoFontOptions::getAntialias
CairoFontOptions


The getAntialias purpose

CairoFontOptions::equal
CairoFontOptions::getHintMetrics
CairoFontOptions
PHP Manual

CairoFontOptions::getAntialias

cairo_get_antialias

(PECL cairo >= 0.1.0)

CairoFontOptions::getAntialias -- cairo_get_antialias — The getAntialias purpose

Açıklama

Nesne yönelimli kullanım (method):

public int CairoFontOptions::getAntialias ( void )

Yordamsal kullanım:

int cairo_get_antialias ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoFontOptions::equal
CairoFontOptions::getHintMetrics
CairoFontOptions


The getHintMetrics purpose

CairoFontOptions::getAntialias
CairoFontOptions::getHintStyle
CairoFontOptions
PHP Manual

CairoFontOptions::getHintMetrics

(PECL cairo >= 0.1.0)

CairoFontOptions::getHintMetrics — The getHintMetrics purpose

Açıklama

public int CairoFontOptions::getHintMetrics ( void )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoFontOptions::getHintMetrics() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoFontOptions::getAntialias
CairoFontOptions::getHintStyle
CairoFontOptions


The getHintStyle purpose

CairoFontOptions::getHintMetrics
CairoFontOptions::getSubpixelOrder
CairoFontOptions
PHP Manual

CairoFontOptions::getHintStyle

(PECL cairo >= 0.1.0)

CairoFontOptions::getHintStyle — The getHintStyle purpose

Açıklama

public int CairoFontOptions::getHintStyle ( void )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoFontOptions::getHintStyle() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoFontOptions::getHintMetrics
CairoFontOptions::getSubpixelOrder
CairoFontOptions


The getSubpixelOrder purpose

CairoFontOptions::getHintStyle
CairoFontOptions::hash
CairoFontOptions
PHP Manual

CairoFontOptions::getSubpixelOrder

(PECL cairo >= 0.1.0)

CairoFontOptions::getSubpixelOrder — The getSubpixelOrder purpose

Açıklama

public int CairoFontOptions::getSubpixelOrder ( void )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoFontOptions::getSubpixelOrder() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoFontOptions::getHintStyle
CairoFontOptions::hash
CairoFontOptions


The hash purpose

CairoFontOptions::getSubpixelOrder
CairoFontOptions::merge
CairoFontOptions
PHP Manual

CairoFontOptions::hash

(PECL cairo >= 0.1.0)

CairoFontOptions::hash — The hash purpose

Açıklama

public int CairoFontOptions::hash ( void )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoFontOptions::hash() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoFontOptions::getSubpixelOrder
CairoFontOptions::merge
CairoFontOptions


The merge purpose

CairoFontOptions::hash
CairoFontOptions::setAntialias
CairoFontOptions
PHP Manual

CairoFontOptions::merge

(PECL cairo >= 0.1.0)

CairoFontOptions::merge — The merge purpose

Açıklama

public void CairoFontOptions::merge ( string $other )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

other

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoFontOptions::merge() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoFontOptions::hash
CairoFontOptions::setAntialias
CairoFontOptions


The setAntialias purpose

CairoFontOptions::merge
CairoFontOptions::setHintMetrics
CairoFontOptions
PHP Manual

CairoFontOptions::setAntialias

cairo_set_antialias

(PECL cairo >= 0.1.0)

CairoFontOptions::setAntialias -- cairo_set_antialias — The setAntialias purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoFontOptions::setAntialias ( string $antialias )

Yordamsal kullanım:

void cairo_set_antialias ( CairoContext $context [, string $antialias ] )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

antialias

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoFontOptions::merge
CairoFontOptions::setHintMetrics
CairoFontOptions


The setHintMetrics purpose

CairoFontOptions::setAntialias
CairoFontOptions::setHintStyle
CairoFontOptions
PHP Manual

CairoFontOptions::setHintMetrics

(PECL cairo >= 0.1.0)

CairoFontOptions::setHintMetrics — The setHintMetrics purpose

Açıklama

public void CairoFontOptions::setHintMetrics ( string $hint_metrics )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

hint_metrics

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoFontOptions::setHintMetrics() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoFontOptions::setAntialias
CairoFontOptions::setHintStyle
CairoFontOptions


The setHintStyle purpose

CairoFontOptions::setHintMetrics
CairoFontOptions::setSubpixelOrder
CairoFontOptions
PHP Manual

CairoFontOptions::setHintStyle

(PECL cairo >= 0.1.0)

CairoFontOptions::setHintStyle — The setHintStyle purpose

Açıklama

public void CairoFontOptions::setHintStyle ( string $hint_style )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

hint_style

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoFontOptions::setHintStyle() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoFontOptions::setHintMetrics
CairoFontOptions::setSubpixelOrder
CairoFontOptions


The setSubpixelOrder purpose

CairoFontOptions::setHintStyle
CairoFontOptions::status
CairoFontOptions
PHP Manual

CairoFontOptions::setSubpixelOrder

(PECL cairo >= 0.1.0)

CairoFontOptions::setSubpixelOrder — The setSubpixelOrder purpose

Açıklama

public void CairoFontOptions::setSubpixelOrder ( string $subpixel_order )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

subpixel_order

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoFontOptions::setSubpixelOrder() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoFontOptions::setHintStyle
CairoFontOptions::status
CairoFontOptions


The status purpose

CairoFontOptions::setSubpixelOrder
CairoFontSlant
CairoFontOptions
PHP Manual

CairoFontOptions::status

cairo_status

(PECL cairo >= 0.1.0)

CairoFontOptions::status -- cairo_status — The status purpose

Açıklama

Nesne yönelimli kullanım (method):

public int CairoFontOptions::status ( void )

Yordamsal kullanım:

int cairo_status ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoFontOptions::setSubpixelOrder
CairoFontSlant
CairoFontOptions


The CairoFontSlant class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

Specifies variants of a font face based on their slant.

Sınıf Sözdizimi

CairoFontSlant {
/* Sabitler */
const integer NORMAL = 0 ;
const integer ITALIC = 1 ;
const integer OBLIQUE = 2 ;
}

Öntanımlı Sabitler

CairoFontSlant::NORMAL

Upright font style

CairoFontSlant::ITALIC

Italic font style

CairoFontSlant::OBLIQUE

Oblique font style

CairoFontOptions::status
CairoFontType
Cairo


The CairoFontType class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

CairoFontType class is an abstract final class that contains constants used to describe the type of a given CairoFontFace or CairoScaledFont. The font types are also known as "font backends" within cairo.

The type of a CairoFontFace is determined by the how it is created, an example would be the CairoToyFontFace::__construct(). The CairoFontFace type can be queried with CairoFontFace::getType() or cairo_font_face_get_type()

The various CairoFontFace functions can be used with a font face of any type.

The type of a CairoScaledFont is determined by the type of the CairoFontFace passed to CairoScaledFont::__construct() or cairo_scaled_font_create(). The scaled font type can be queried with CairoScaledFont::getType() or cairo_scaled_font_get_type().

Sınıf Sözdizimi

CairoFontType {
/* Sabitler */
const integer TOY = 0 ;
const integer FT = 1 ;
const integer WIN32 = 2 ;
const integer QUARTZ = 3 ;
}

Öntanımlı Sabitler

CairoFontType::TOY

The font was created using CairoToyFont api

CairoFontType::FT

The font is of type CairoFreeType

CairoFontType::WIN32

The font is of type Win32

CairoFontType::QUARTZ

The font is of type Quartz

CairoFontType::USER

The font was create using cairo's user font api

CairoFontSlant
CairoFontWeight
Cairo


The CairoFontWeight class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

Specifies variants of a font face based on their weight.

Sınıf Sözdizimi

CairoFontWeight {
/* Sabitler */
const integer NORMAL = 0 ;
const integer BOLD = 1 ;
}

Öntanımlı Sabitler

CairoFontWeight::NORMAL

Normal font weight

CairoFontWeight::BOLD

Bold font weight

CairoFontType
CairoScaledFont
Cairo


The CairoScaledFont class

(PECL cairo >= 0.1.0)

Giriş

Sınıf Sözdizimi

CairoScaledFont {
/* Yöntemler */
public __construct ( CairoFontFace $font_face , CairoMatrix $matrix , CairoMatrix $ctm , CairoFontOptions $options )
public array extents ( void )
public CairoMatrix getCtm ( void )
public void getFontFace ( void )
public void getFontMatrix ( void )
public void getFontOptions ( void )
public void getScaleMatrix ( void )
public int getType ( void )
public array glyphExtents ( string $glyphs )
public int status ( void )
public array textExtents ( string $text )
}

İçindekiler

  • CairoScaledFont::__construct — The __construct purpose
  • CairoScaledFont::extents — The extents purpose
  • CairoScaledFont::getCtm — The getCtm purpose
  • CairoScaledFont::getFontFace — The getFontFace purpose
  • CairoScaledFont::getFontMatrix — The getFontMatrix purpose
  • CairoScaledFont::getFontOptions — The getFontOptions purpose
  • CairoScaledFont::getScaleMatrix — The getScaleMatrix purpose
  • CairoScaledFont::getType — The getType purpose
  • CairoScaledFont::glyphExtents — The glyphExtents purpose
  • CairoScaledFont::status — The status purpose
  • CairoScaledFont::textExtents — The textExtents purpose
CairoFontWeight
CairoScaledFont::__construct
Cairo


The __construct purpose

CairoScaledFont
CairoScaledFont::extents
CairoScaledFont
PHP Manual

CairoScaledFont::__construct

(PECL cairo >= 0.1.0)

CairoScaledFont::__construct — The __construct purpose

Açıklama

public CairoScaledFont::__construct ( CairoFontFace $font_face , CairoMatrix $matrix , CairoMatrix $ctm , CairoFontOptions $options )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

font_face

Description...

matrix

Description...

ctm

Description...

options

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoScaledFont::__construct() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoScaledFont
CairoScaledFont::extents
CairoScaledFont


The extents purpose

CairoScaledFont::__construct
CairoScaledFont::getCtm
CairoScaledFont
PHP Manual

CairoScaledFont::extents

(PECL cairo >= 0.1.0)

CairoScaledFont::extents — The extents purpose

Açıklama

public array CairoScaledFont::extents ( void )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoScaledFont::extents() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoScaledFont::__construct
CairoScaledFont::getCtm
CairoScaledFont


The getCtm purpose

CairoScaledFont::extents
CairoScaledFont::getFontFace
CairoScaledFont
PHP Manual

CairoScaledFont::getCtm

(PECL cairo >= 0.1.0)

CairoScaledFont::getCtm — The getCtm purpose

Açıklama

public CairoMatrix CairoScaledFont::getCtm ( void )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoScaledFont::getCtm() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoScaledFont::extents
CairoScaledFont::getFontFace
CairoScaledFont


The getFontFace purpose

CairoScaledFont::getCtm
CairoScaledFont::getFontMatrix
CairoScaledFont
PHP Manual

CairoScaledFont::getFontFace

cairo_get_font_face

(PECL cairo >= 0.1.0)

CairoScaledFont::getFontFace -- cairo_get_font_face — The getFontFace purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoScaledFont::getFontFace ( void )

Yordamsal kullanım:

void cairo_get_font_face ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoScaledFont::getCtm
CairoScaledFont::getFontMatrix
CairoScaledFont


The getFontMatrix purpose

CairoScaledFont::getFontFace
CairoScaledFont::getFontOptions
CairoScaledFont
PHP Manual

CairoScaledFont::getFontMatrix

cairo_get_font_matrix

(PECL cairo >= 0.1.0)

CairoScaledFont::getFontMatrix -- cairo_get_font_matrix — The getFontMatrix purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoScaledFont::getFontMatrix ( void )

Yordamsal kullanım:

void cairo_get_font_matrix ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoScaledFont::getFontFace
CairoScaledFont::getFontOptions
CairoScaledFont


The getFontOptions purpose

CairoScaledFont::getFontMatrix
CairoScaledFont::getScaleMatrix
CairoScaledFont
PHP Manual

CairoScaledFont::getFontOptions

cairo_get_font_options

(PECL cairo >= 0.1.0)

CairoScaledFont::getFontOptions -- cairo_get_font_options — The getFontOptions purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoScaledFont::getFontOptions ( void )

Yordamsal kullanım:

void cairo_get_font_options ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoScaledFont::getFontMatrix
CairoScaledFont::getScaleMatrix
CairoScaledFont


The getScaleMatrix purpose

CairoScaledFont::getFontOptions
CairoScaledFont::getType
CairoScaledFont
PHP Manual

CairoScaledFont::getScaleMatrix

(PECL cairo >= 0.1.0)

CairoScaledFont::getScaleMatrix — The getScaleMatrix purpose

Açıklama

public void CairoScaledFont::getScaleMatrix ( void )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoScaledFont::getScaleMatrix() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoScaledFont::getFontOptions
CairoScaledFont::getType
CairoScaledFont


The getType purpose

CairoScaledFont::getScaleMatrix
CairoScaledFont::glyphExtents
CairoScaledFont
PHP Manual

CairoScaledFont::getType

(PECL cairo >= 0.1.0)

CairoScaledFont::getType — The getType purpose

Açıklama

public int CairoScaledFont::getType ( void )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoScaledFont::getType() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoScaledFont::getScaleMatrix
CairoScaledFont::glyphExtents
CairoScaledFont


The glyphExtents purpose

CairoScaledFont::getType
CairoScaledFont::status
CairoScaledFont
PHP Manual

CairoScaledFont::glyphExtents

(PECL cairo >= 0.1.0)

CairoScaledFont::glyphExtents — The glyphExtents purpose

Açıklama

public array CairoScaledFont::glyphExtents ( string $glyphs )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

glyphs

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoScaledFont::glyphExtents() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoScaledFont::getType
CairoScaledFont::status
CairoScaledFont


The status purpose

CairoScaledFont::glyphExtents
CairoScaledFont::textExtents
CairoScaledFont
PHP Manual

CairoScaledFont::status

cairo_status

(PECL cairo >= 0.1.0)

CairoScaledFont::status -- cairo_status — The status purpose

Açıklama

Nesne yönelimli kullanım (method):

public int CairoScaledFont::status ( void )

Yordamsal kullanım:

int cairo_status ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoScaledFont::glyphExtents
CairoScaledFont::textExtents
CairoScaledFont


The textExtents purpose

CairoScaledFont::status
CairoToyFontFace
CairoScaledFont
PHP Manual

CairoScaledFont::textExtents

cairo_text_extents

(PECL cairo >= 0.1.0)

CairoScaledFont::textExtents -- cairo_text_extents — The textExtents purpose

Açıklama

Nesne yönelimli kullanım (method):

public array CairoScaledFont::textExtents ( string $text )

Yordamsal kullanım:

array cairo_text_extents ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

text

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoScaledFont::status
CairoToyFontFace
CairoScaledFont


The CairoToyFontFace class

(PECL cairo >= 0.1.0)

Giriş

The CairoToyFontFace class can be used instead of CairoContext::selectFontFace() to create a toy font independently of a context.

Sınıf Sözdizimi

CairoToyFontFace extends CairoFontFace {
/* Miras alınan yöntemler */
}
CairoScaledFont::textExtents
CairoPatternType
Cairo


The CairoPatternType class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

CairoPatternType is used to describe the type of a given pattern.

The type of a pattern is determined by the function used to create it. The cairo_pattern_create_rgb() and cairo_pattern_create_rgba() functions create CairoPatternType::SOLID patterns. The remaining cairo_pattern_create_* functions map to pattern types in obvious ways.

Sınıf Sözdizimi

CairoPatternType {
/* Sabitler */
const integer SOLID = 0 ;
const integer SURFACE = 1 ;
const integer LINEAR = 2 ;
const integer RADIAL = 3 ;
}

Öntanımlı Sabitler

CairoPatternType::SOLID

The pattern is a solid (uniform) color. It may be opaque or translucent.

CairoPatternType::SURFACE

The pattern is a based on a surface (an image).

CairoPatternType::LINEAR

The pattern is a linear gradient.

CairoPatternType::RADIAL

The pattern is a radial gradient.

CairoToyFontFace
CairoPattern
Cairo


The CairoPattern class

(PECL cairo >= 0.1.0)

Giriş

CairoPattern is the abstract base class from which all the other pattern classes derive. It cannot be instantiated directly

Sınıf Sözdizimi

CairoPattern {
/* Yöntemler */
public __construct ( void )
public void getMatrix ( void )
public int getType ( void )
public void setMatrix ( string $matrix )
public int status ( void )
}

İçindekiler

  • CairoPattern::__construct — The __construct purpose
  • CairoPattern::getMatrix — The getMatrix purpose
  • CairoPattern::getType — The getType purpose
  • CairoPattern::setMatrix — The setMatrix purpose
  • CairoPattern::status — The status purpose
CairoPatternType
CairoPattern::__construct
Cairo


The __construct purpose

CairoPattern
CairoPattern::getMatrix
CairoPattern
PHP Manual

CairoPattern::__construct

(PECL cairo >= 0.1.0)

CairoPattern::__construct — The __construct purpose

Açıklama

public CairoPattern::__construct ( void )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoPattern::__construct() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoPattern
CairoPattern::getMatrix
CairoPattern


The getMatrix purpose

CairoPattern::__construct
CairoPattern::getType
CairoPattern
PHP Manual

CairoPattern::getMatrix

cairo_get_matrix

(PECL cairo >= 0.1.0)

CairoPattern::getMatrix -- cairo_get_matrix — The getMatrix purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoPattern::getMatrix ( void )

Yordamsal kullanım:

void cairo_get_matrix ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoPattern::__construct
CairoPattern::getType
CairoPattern


The getType purpose

CairoPattern::getMatrix
CairoPattern::setMatrix
CairoPattern
PHP Manual

CairoPattern::getType

(PECL cairo >= 0.1.0)

CairoPattern::getType — The getType purpose

Açıklama

public int CairoPattern::getType ( void )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoPattern::getType() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoPattern::getMatrix
CairoPattern::setMatrix
CairoPattern


The setMatrix purpose

CairoPattern::getType
CairoPattern::status
CairoPattern
PHP Manual

CairoPattern::setMatrix

cairo_set_matrix

(PECL cairo >= 0.1.0)

CairoPattern::setMatrix -- cairo_set_matrix — The setMatrix purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoPattern::setMatrix ( string $matrix )

Yordamsal kullanım:

void cairo_set_matrix ( CairoContext $context , CairoMatrix $matrix )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

matrix

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoPattern::getType
CairoPattern::status
CairoPattern


The status purpose

CairoPattern::setMatrix
CairoGradientPattern
CairoPattern
PHP Manual

CairoPattern::status

cairo_status

(PECL cairo >= 0.1.0)

CairoPattern::status -- cairo_status — The status purpose

Açıklama

Nesne yönelimli kullanım (method):

public int CairoPattern::status ( void )

Yordamsal kullanım:

int cairo_status ( CairoContext $context )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoPattern::setMatrix
CairoGradientPattern
CairoPattern


The CairoGradientPattern class

(PECL cairo >= 0.1.0)

Giriş

CairoGradientPattern is an abstract base class from which other Pattern classes derive. It cannot be instantiated directly.

Sınıf Sözdizimi

CairoGradientPattern extends CairoPattern {
/* Yöntemler */
public void addColorStopRgb ( string $offset , string $red , string $green , string $blue )
public void addColorStopRgba ( string $offset , string $red , string $green , string $blue , string $alpha )
public int getColorStopCount ( void )
public array getColorStopRgba ( string $index )
public int getExtend ( void )
public void setExtend ( int $extend )
/* Miras alınan yöntemler */
public CairoPattern::__construct ( void )
public void CairoPattern::getMatrix ( void )
public int CairoPattern::getType ( void )
public void CairoPattern::setMatrix ( string $matrix )
public int CairoPattern::status ( void )
}

İçindekiler

  • CairoGradientPattern::addColorStopRgb — The addColorStopRgb purpose
  • CairoGradientPattern::addColorStopRgba — The addColorStopRgba purpose
  • CairoGradientPattern::getColorStopCount — The getColorStopCount purpose
  • CairoGradientPattern::getColorStopRgba — The getColorStopRgba purpose
  • CairoGradientPattern::getExtend — The getExtend purpose
  • CairoGradientPattern::setExtend — The setExtend purpose
CairoPattern::status
CairoGradientPattern::addColorStopRgb
Cairo


The addColorStopRgb purpose

CairoGradientPattern
CairoGradientPattern::addColorStopRgba
CairoGradientPattern
PHP Manual

CairoGradientPattern::addColorStopRgb

(PECL cairo >= 0.1.0)

CairoGradientPattern::addColorStopRgb — The addColorStopRgb purpose

Açıklama

public void CairoGradientPattern::addColorStopRgb ( string $offset , string $red , string $green , string $blue )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

offset

Description...

red

Description...

green

Description...

blue

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoGradientPattern::addColorStopRgb() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoGradientPattern
CairoGradientPattern::addColorStopRgba
CairoGradientPattern


The addColorStopRgba purpose

CairoGradientPattern::addColorStopRgb
CairoGradientPattern::getColorStopCount
CairoGradientPattern
PHP Manual

CairoGradientPattern::addColorStopRgba

(PECL cairo >= 0.1.0)

CairoGradientPattern::addColorStopRgba — The addColorStopRgba purpose

Açıklama

public void CairoGradientPattern::addColorStopRgba ( string $offset , string $red , string $green , string $blue , string $alpha )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

offset

Description...

red

Description...

green

Description...

blue

Description...

alpha

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoGradientPattern::addColorStopRgba() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoGradientPattern::addColorStopRgb
CairoGradientPattern::getColorStopCount
CairoGradientPattern


The getColorStopCount purpose

CairoGradientPattern::addColorStopRgba
CairoGradientPattern::getColorStopRgba
CairoGradientPattern
PHP Manual

CairoGradientPattern::getColorStopCount

(PECL cairo >= 0.1.0)

CairoGradientPattern::getColorStopCount — The getColorStopCount purpose

Açıklama

public int CairoGradientPattern::getColorStopCount ( void )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoGradientPattern::getColorStopCount() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoGradientPattern::addColorStopRgba
CairoGradientPattern::getColorStopRgba
CairoGradientPattern


The getColorStopRgba purpose

CairoGradientPattern::getColorStopCount
CairoGradientPattern::getExtend
CairoGradientPattern
PHP Manual

CairoGradientPattern::getColorStopRgba

(PECL cairo >= 0.1.0)

CairoGradientPattern::getColorStopRgba — The getColorStopRgba purpose

Açıklama

public array CairoGradientPattern::getColorStopRgba ( string $index )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

index

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoGradientPattern::getColorStopRgba() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoGradientPattern::getColorStopCount
CairoGradientPattern::getExtend
CairoGradientPattern


The getExtend purpose

CairoGradientPattern::getColorStopRgba
CairoGradientPattern::setExtend
CairoGradientPattern
PHP Manual

CairoGradientPattern::getExtend

(PECL cairo >= 0.1.0)

CairoGradientPattern::getExtend — The getExtend purpose

Açıklama

public int CairoGradientPattern::getExtend ( void )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoGradientPattern::getExtend() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoGradientPattern::getColorStopRgba
CairoGradientPattern::setExtend
CairoGradientPattern


The setExtend purpose

CairoGradientPattern::getExtend
CairoSolidPattern
CairoGradientPattern
PHP Manual

CairoGradientPattern::setExtend

(PECL cairo >= 0.1.0)

CairoGradientPattern::setExtend — The setExtend purpose

Açıklama

public void CairoGradientPattern::setExtend ( int $extend )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

extend

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoGradientPattern::setExtend() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoGradientPattern::getExtend
CairoSolidPattern
CairoGradientPattern


The CairoSolidPattern class

(PECL cairo >= 0.1.0)

Giriş

Sınıf Sözdizimi

CairoSolidPattern extends CairoPattern {
/* Yöntemler */
public __construct ( float $red , float $green , float $blue [, float $alpha = 0 ] )
public array getRgba ( void )
/* Miras alınan yöntemler */
public CairoPattern::__construct ( void )
public void CairoPattern::getMatrix ( void )
public int CairoPattern::getType ( void )
public void CairoPattern::setMatrix ( string $matrix )
public int CairoPattern::status ( void )
}

İçindekiler

  • CairoSolidPattern::__construct — The __construct purpose
  • CairoSolidPattern::getRgba — The getRgba purpose
CairoGradientPattern::setExtend
CairoSolidPattern::__construct
Cairo


The __construct purpose

CairoSolidPattern
CairoSolidPattern::getRgba
CairoSolidPattern
PHP Manual

CairoSolidPattern::__construct

(PECL cairo >= 0.1.0)

CairoSolidPattern::__construct — The __construct purpose

Açıklama

public CairoSolidPattern::__construct ( float $red , float $green , float $blue [, float $alpha = 0 ] )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

red

Description...

green

Description...

blue

Description...

alpha

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoSolidPattern::__construct() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoSolidPattern
CairoSolidPattern::getRgba
CairoSolidPattern


The getRgba purpose

CairoSolidPattern::__construct
CairoSurfacePattern
CairoSolidPattern
PHP Manual

CairoSolidPattern::getRgba

(PECL cairo >= 0.1.0)

CairoSolidPattern::getRgba — The getRgba purpose

Açıklama

public array CairoSolidPattern::getRgba ( void )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoSolidPattern::getRgba() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoSolidPattern::__construct
CairoSurfacePattern
CairoSolidPattern


The CairoSurfacePattern class

(PECL cairo >= 0.1.0)

Giriş

Sınıf Sözdizimi

CairoSurfacePattern extends CairoPattern {
/* Yöntemler */
public __construct ( CairoSurface $surface )
public int getExtend ( void )
public int getFilter ( void )
public void getSurface ( void )
public void setExtend ( int $extend )
public void setFilter ( string $filter )
/* Miras alınan yöntemler */
public CairoPattern::__construct ( void )
public void CairoPattern::getMatrix ( void )
public int CairoPattern::getType ( void )
public void CairoPattern::setMatrix ( string $matrix )
public int CairoPattern::status ( void )
}

İçindekiler

  • CairoSurfacePattern::__construct — The __construct purpose
  • CairoSurfacePattern::getExtend — The getExtend purpose
  • CairoSurfacePattern::getFilter — The getFilter purpose
  • CairoSurfacePattern::getSurface — The getSurface purpose
  • CairoSurfacePattern::setExtend — The setExtend purpose
  • CairoSurfacePattern::setFilter — The setFilter purpose
CairoSolidPattern::getRgba
CairoSurfacePattern::__construct
Cairo


The __construct purpose

CairoSurfacePattern
CairoSurfacePattern::getExtend
CairoSurfacePattern
PHP Manual

CairoSurfacePattern::__construct

(PECL cairo >= 0.1.0)

CairoSurfacePattern::__construct — The __construct purpose

Açıklama

public CairoSurfacePattern::__construct ( CairoSurface $surface )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

surface

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoSurfacePattern::__construct() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoSurfacePattern
CairoSurfacePattern::getExtend
CairoSurfacePattern


The getExtend purpose

CairoSurfacePattern::__construct
CairoSurfacePattern::getFilter
CairoSurfacePattern
PHP Manual

CairoSurfacePattern::getExtend

(PECL cairo >= 0.1.0)

CairoSurfacePattern::getExtend — The getExtend purpose

Açıklama

public int CairoSurfacePattern::getExtend ( void )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoSurfacePattern::getExtend() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoSurfacePattern::__construct
CairoSurfacePattern::getFilter
CairoSurfacePattern


The getFilter purpose

CairoSurfacePattern::getExtend
CairoSurfacePattern::getSurface
CairoSurfacePattern
PHP Manual

CairoSurfacePattern::getFilter

(PECL cairo >= 0.1.0)

CairoSurfacePattern::getFilter — The getFilter purpose

Açıklama

public int CairoSurfacePattern::getFilter ( void )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoSurfacePattern::getFilter() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoSurfacePattern::getExtend
CairoSurfacePattern::getSurface
CairoSurfacePattern


The getSurface purpose

CairoSurfacePattern::getFilter
CairoSurfacePattern::setExtend
CairoSurfacePattern
PHP Manual

CairoSurfacePattern::getSurface

(PECL cairo >= 0.1.0)

CairoSurfacePattern::getSurface — The getSurface purpose

Açıklama

public void CairoSurfacePattern::getSurface ( void )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoSurfacePattern::getSurface() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoSurfacePattern::getFilter
CairoSurfacePattern::setExtend
CairoSurfacePattern


The setExtend purpose

CairoSurfacePattern::getSurface
CairoSurfacePattern::setFilter
CairoSurfacePattern
PHP Manual

CairoSurfacePattern::setExtend

(PECL cairo >= 0.1.0)

CairoSurfacePattern::setExtend — The setExtend purpose

Açıklama

public void CairoSurfacePattern::setExtend ( int $extend )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

extend

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoSurfacePattern::setExtend() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoSurfacePattern::getSurface
CairoSurfacePattern::setFilter
CairoSurfacePattern


The setFilter purpose

CairoSurfacePattern::setExtend
CairoLinearGradient
CairoSurfacePattern
PHP Manual

CairoSurfacePattern::setFilter

(PECL cairo >= 0.1.0)

CairoSurfacePattern::setFilter — The setFilter purpose

Açıklama

public void CairoSurfacePattern::setFilter ( string $filter )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

filter

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoSurfacePattern::setFilter() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoSurfacePattern::setExtend
CairoLinearGradient
CairoSurfacePattern


The CairoLinearGradient class

(PECL cairo >= 0.1.0)

Giriş

Create a new CairoLinearGradient along the line defined

Sınıf Sözdizimi

CairoLinearGradient extends CairoGradientPattern {
/* Yöntemler */
public __construct ( float $x0 , float $y0 , float $x1 , float $y1 )
public array getPoints ( void )
/* Miras alınan yöntemler */
public void CairoGradientPattern::addColorStopRgb ( string $offset , string $red , string $green , string $blue )
public void CairoGradientPattern::addColorStopRgba ( string $offset , string $red , string $green , string $blue , string $alpha )
public int CairoGradientPattern::getColorStopCount ( void )
public array CairoGradientPattern::getColorStopRgba ( string $index )
public int CairoGradientPattern::getExtend ( void )
public void CairoGradientPattern::setExtend ( int $extend )
}

İçindekiler

  • CairoLinearGradient::__construct — The __construct purpose
  • CairoLinearGradient::getPoints — The getPoints purpose
CairoSurfacePattern::setFilter
CairoLinearGradient::__construct
Cairo


The __construct purpose

CairoLinearGradient
CairoLinearGradient::getPoints
CairoLinearGradient
PHP Manual

CairoLinearGradient::__construct

(PECL cairo >= 0.1.0)

CairoLinearGradient::__construct — The __construct purpose

Açıklama

public CairoLinearGradient::__construct ( float $x0 , float $y0 , float $x1 , float $y1 )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

x0

Description...

y0

Description...

x1

Description...

y1

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoLinearGradient::__construct() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoLinearGradient
CairoLinearGradient::getPoints
CairoLinearGradient


The getPoints purpose

CairoLinearGradient::__construct
CairoRadialGradient
CairoLinearGradient
PHP Manual

CairoLinearGradient::getPoints

(PECL cairo >= 0.1.0)

CairoLinearGradient::getPoints — The getPoints purpose

Açıklama

public array CairoLinearGradient::getPoints ( void )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoLinearGradient::getPoints() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoLinearGradient::__construct
CairoRadialGradient
CairoLinearGradient


The CairoRadialGradient class

(PECL cairo >= 0.1.0)

Giriş

Sınıf Sözdizimi

CairoRadialGradient extends CairoGradientPattern {
/* Yöntemler */
public __construct ( float $x0 , float $y0 , float $r0 , float $x1 , float $y1 , float $r1 )
public array getCircles ( void )
/* Miras alınan yöntemler */
public void CairoGradientPattern::addColorStopRgb ( string $offset , string $red , string $green , string $blue )
public void CairoGradientPattern::addColorStopRgba ( string $offset , string $red , string $green , string $blue , string $alpha )
public int CairoGradientPattern::getColorStopCount ( void )
public array CairoGradientPattern::getColorStopRgba ( string $index )
public int CairoGradientPattern::getExtend ( void )
public void CairoGradientPattern::setExtend ( int $extend )
}

İçindekiler

  • CairoRadialGradient::__construct — The __construct purpose
  • CairoRadialGradient::getCircles — The getCircles purpose
CairoLinearGradient::getPoints
CairoRadialGradient::__construct
Cairo


The __construct purpose

CairoRadialGradient
CairoRadialGradient::getCircles
CairoRadialGradient
PHP Manual

CairoRadialGradient::__construct

(PECL cairo >= 0.1.0)

CairoRadialGradient::__construct — The __construct purpose

Açıklama

Nesne yönelimli kullanım:

public CairoRadialGradient::__construct ( float $x0 , float $y0 , float $r0 , float $x1 , float $y1 , float $r1 )

Yordamsal kullanım:

Creates a new radial gradient CairoPattern between the two circles defined by (x0, y0, r0) and (x1, y1, r1). Before using the gradient pattern, a number of color stops should be defined using CairoRadialGradient::addColorStopRgb() or CairoRadialGradient::addColorStopRgba().

Note: The coordinates here are in pattern space. For a new pattern, pattern space is identical to user space, but the relationship between the spaces can be changed with CairoRadialGradient::setMatrix().

Değiştirgeler

x0

x coordinate for the center of the start circle.

y0

y coordinate for the center of the start circle.

r0

radius of the start circle.

x1

x coordinate for the center of the end circle.

y1

y coordinate for the center of the end circle.

r1

radius of the end circle.

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoRadialGradient::__construct() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoRadialGradient
CairoRadialGradient::getCircles
CairoRadialGradient


The getCircles purpose

CairoRadialGradient::__construct
CairoAntialias
CairoRadialGradient
PHP Manual

CairoRadialGradient::getCircles

(PECL cairo >= 0.1.0)

CairoRadialGradient::getCircles — The getCircles purpose

Açıklama

public array CairoRadialGradient::getCircles ( void )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoRadialGradient::getCircles() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoRadialGradient::__construct
CairoAntialias
CairoRadialGradient


The CairoAntialias class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

Enum class that specifies the type of antialiasing to do when rendering text or shapes.

Sınıf Sözdizimi

CairoAntialias {
/* Sabitler */
const integer MODE_DEFAULT = 0 ;
const integer MODE_NONE = 1 ;
const integer MODE_GRAY = 2 ;
const integer MODE_SUBPIXEL = 3 ;
}

Öntanımlı Sabitler

CairoAntialias::MODE_DEFAULT

Use the default antialiasing for the subsystem and target device

CairoAntialias::MODE_NONE

Use a bilevel alpha mask

CairoAntialias::MODE_GRAY

Perform single-color antialiasing (using shades of gray for black text on a white background, for example).

CairoAntialias::MODE_SUBPIXEL

Perform antialiasing by taking advantage of the order of subpixel elements on devices such as LCD panels.

CairoRadialGradient::getCircles
CairoContent
Cairo


The CairoContent class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

CairoContent is used to describe the content that a surface will contain, whether color information, alpha information (translucence vs. opacity), or both.

Note: The large values here are designed to keep CairoContent values distinct from CairoContent values so that the implementation can detect the error if users confuse the two types.

Sınıf Sözdizimi

CairoContent {
/* Sabitler */
const integer COLOR = 4096 ;
const integer ALPHA = 8192 ;
const integer COLOR_ALPHA = 12288 ;
}

Öntanımlı Sabitler

CairoContent::COLOR

The surface will hold color content only.

CairoContent::ALPHA

The surface will hold alpha content only.

CairoContent::COLOR_ALPHA

The surface will hold color and alpha content.

CairoAntialias
CairoExtend
Cairo


The CairoExtend class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

Sınıf Sözdizimi

CairoExtend {
/* Sabitler */
const integer NONE = 0 ;
const integer REPEAT = 1 ;
const integer REFLECT = 2 ;
const integer PAD = 3 ;
}

Öntanımlı Sabitler

CairoExtend::NONE

Description here...

CairoExtend::REPEAT

Description here...

CairoExtend::REFLECT

Description here...

CairoExtend::PAD

Description here...

CairoContent
CairoFormat
Cairo


The CairoFormat class

(PECL cairo >= 0.1.0)

Giriş

CairoFormat enums are used to identify the memory format of the image data.

Sınıf Sözdizimi

CairoFormat {
/* Sabitler */
const integer ARGB32 = 0 ;
const integer RGB24 = 1 ;
const integer A8 = 2 ;
const integer A1 = 3 ;
/* Yöntemler */
public static int strideForWidth ( int $format , int $width )
}

Öntanımlı Sabitler

CairoFormat::ARGB32

Each pixel is a 32-bit quantity, with alpha in the upper 8 bits, then red, then green, then blue. The 32-bit quantities are stored native-endian. Pre-multiplied alpha is used. (That is, 50% transparent red is 0x80800000, not 0x80ff0000.)

CairoFormat::RGB24

Each pixel is a 32-bit quantity, with the upper 8 bits unused. Red, Green, and Blue are stored in the remaining 24 bits in that order.

CairoFormat::A8

Each pixel is a 8-bit quantity holding an alpha value.

CairoFormat::A1

Each pixel is a 1-bit quantity holding an alpha value. Pixels are packed together into 32-bit quantities. The ordering of the bits matches the endianess of the platform. On a big-endian machine, the first pixel is in the uppermost bit, on a little-endian machine the first pixel is in the least-significant bit.

İçindekiler

  • CairoFormat::strideForWidth — Provides an appropiate stride to use
CairoExtend
CairoFormat::strideForWidth
Cairo


Provides an appropiate stride to use

CairoFormat
CairoFillRule
CairoFormat
PHP Manual

CairoFormat::strideForWidth

(PECL cairo >= 0.1.0)

CairoFormat::strideForWidth — Provides an appropiate stride to use

Açıklama

public static int CairoFormat::strideForWidth ( int $format , int $width )

This method provides a stride value that will respect all alignment requirements of the accelerated image-rendering code within cairo.

Değiştirgeler

format

The desired CairoFormat to use

width

The width of the image

Dönen Değerler

The appropriate stride to use given the desired format and width, or -1 if either the format is invalid or the width too large.

Örnekler

Örnek 1 CairoFormat::strideForWidth() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoFormat
CairoFillRule
CairoFormat


The CairoFillRule class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

A CairoFillRule is used to select how paths are filled. For both fill rules, whether or not a point is included in the fill is determined by taking a ray from that point to infinity and looking at intersections with the path. The ray can be in any direction, as long as it doesn't pass through the end point of a segment or have a tricky intersection such as intersecting tangent to the path. (Note that filling is not actually implemented in this way. This is just a description of the rule that is applied.)

The default fill rule is CairoFillRule::WINDING.

Sınıf Sözdizimi

CairoFillRule {
/* Sabitler */
const integer WINDING = 0 ;
const integer EVEN_ODD = 1 ;
}

Öntanımlı Sabitler

CairoFillRule::WINDING

If the path crosses the ray from left-to-right, counts +1. If the path crosses the ray from right to left, counts -1. (Left and right are determined from the perspective of looking along the ray from the starting point.) If the total count is non-zero, the point will be filled.

CairoFillRule::EVEN_ODD

Counts the total number of intersections, without regard to the orientation of the contour. If the total number of intersections is odd, the point will be filled.

CairoFormat::strideForWidth
CairoFilter
Cairo


The CairoFilter class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

A CairoFilter is used to indicate what filtering should be applied when reading pixel values from patterns. See CairoPattern::setSource() or cairo_pattern_set_source() for indicating the desired filter to be used with a particular pattern.

Sınıf Sözdizimi

CairoFilter {
/* Sabitler */
const integer FAST = 0 ;
const integer GOOD = 1 ;
const integer BEST = 2 ;
const integer NEAREST = 3 ;
const integer BILINEAR = 4 ;
const integer GAUSSIAN = 5 ;
}

Öntanımlı Sabitler

CairoFilter::FAST

A high-performance filter, with quality similar to CairoFilter::NEAREST

CairoFilter::GOOD

A reasonable-performance filter, with quality similar to CairoFilter::BILINEAR

CairoFilter::BEST

The highest-quality available, performance may not be suitable for interactive use.

CairoFilter::NEAREST

Nearest-neighbor filtering

CairoFilter::BILINEAR

Linear interpolation in two dimensions

CairoFilter::GAUSSIAN

This filter value is currently unimplemented, and should not be used in current code.

CairoFillRule
CairoHintMetrics
Cairo


The CairoHintMetrics class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

Specifies whether to hint font metrics; hinting font metrics means quantizing them so that they are integer values in device space. Doing this improves the consistency of letter and line spacing, however it also means that text will be laid out differently at different zoom factors.

Sınıf Sözdizimi

CairoHintMetrics {
/* Sabitler */
const integer METRICS_DEFAULT = 0 ;
const integer METRICS_OFF = 1 ;
const integer METRICS_ON = 2 ;
}

Öntanımlı Sabitler

CairoHintMetrics::METRICS_DEFAULT

Hint metrics in the default manner for the font backend and target device

CairoHintMetrics::METRICS_OFF

Do not hint font metrics

CairoHintMetrics::METRICS_ON

Hint font metrics

CairoFilter
CairoHintStyle
Cairo


The CairoHintStyle class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

Specifies the type of hinting to do on font outlines. Hinting is the process of fitting outlines to the pixel grid in order to improve the appearance of the result. Since hinting outlines involves distorting them, it also reduces the faithfulness to the original outline shapes. Not all of the outline hinting styles are supported by all font backends.

Sınıf Sözdizimi

CairoHintStyle {
/* Sabitler */
const integer STYLE_DEFAULT = 0 ;
const integer STYLE_NONE = 1 ;
const integer STYLE_SLIGHT = 2 ;
const integer STYLE_MEDIUM = 3 ;
const integer STYLE_FULL = 4 ;
}

Öntanımlı Sabitler

CairoHintStyle::STYLE_DEFAULT

Use the default hint style for font backend and target device

CairoHintStyle::STYLE_NONE

Do not hint outlines

CairoHintStyle::STYLE_SLIGHT

Hint outlines slightly to improve contrast while retaining good fidelity to the original shapes.

CairoHintStyle::STYLE_MEDIUM

Hint outlines with medium strength giving a compromise between fidelity to the original shapes and contrast

CairoHintStyle::STYLE_FULL

Hint outlines to maximize contrast

CairoHintMetrics
CairoLineCap
Cairo


The CairoLineCap class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

Specifies how to render the endpoints of the path when stroking.

The default line cap style is CairoLineCap::BUTT.

Sınıf Sözdizimi

CairoLineCap {
/* Sabitler */
const integer BUTT = 0 ;
const integer ROUND = 1 ;
const integer SQUARE = 2 ;
}

Öntanımlı Sabitler

CairoLineCap::BUTT

Start(stop) the line exactly at the start(end) point

CairoLineCap::ROUND

Use a round ending, the center of the circle is the end point

CairoLineCap::SQUARE

Use squared ending, the center of the square is the end point

CairoHintStyle
CairoLineJoin
Cairo


The CairoLineJoin class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

Sınıf Sözdizimi

CairoLineJoin {
/* Sabitler */
const integer MITER = 0 ;
const integer ROUND = 1 ;
const integer BEVEL = 2 ;
}

Öntanımlı Sabitler

CairoLineJoin::MITER

Description here...

CairoLineJoin::ROUND

Description here...

CairoLineJoin::BEVEL

Description here...

CairoLineCap
CairoMatrix
Cairo


The CairoMatrix class

(PECL cairo >= 0.1.0)

Giriş

Matrices are used throughout cairo to convert between different coordinate spaces.

Sınıf Sözdizimi

CairoMatrix {
/* Yöntemler */
public __construct ([ float $xx = 1.0 [, float $yx = 0.0 [, float $xy = 0.0 [, float $yy = 1.0 [, float $x0 = 0.0 [, float $y0 = 0.0 ]]]]]] )
public static void initIdentity ( void )
public static void initRotate ( float $radians )
public static void initScale ( float $sx , float $sy )
public static void initTranslate ( float $tx , float $ty )
public void invert ( void )
public static CairoMatrix multiply ( CairoMatrix $matrix1 , CairoMatrix $matrix2 )
public void rotate ( string $sx , string $sy )
public void scale ( float $sx , float $sy )
public array transformDistance ( string $dx , string $dy )
public array transformPoint ( string $dx , string $dy )
public void translate ( string $tx , string $ty )
}

İçindekiler

  • CairoMatrix::__construct — Creates a new CairoMatrix object
  • CairoMatrix::initIdentity — Creates a new identity matrix
  • CairoMatrix::initRotate — Creates a new rotated matrix
  • CairoMatrix::initScale — Creates a new scaling matrix
  • CairoMatrix::initTranslate — Creates a new translation matrix
  • CairoMatrix::invert — The invert purpose
  • CairoMatrix::multiply — The multiply purpose
  • CairoMatrix::rotate — The rotate purpose
  • CairoMatrix::scale — Applies scaling to a matrix
  • CairoMatrix::transformDistance — The transformDistance purpose
  • CairoMatrix::transformPoint — The transformPoint purpose
  • CairoMatrix::translate — The translate purpose
CairoLineJoin
CairoMatrix::__construct
Cairo


Creates a new CairoMatrix object

CairoMatrix
CairoMatrix::initIdentity
CairoMatrix
PHP Manual

CairoMatrix::__construct

cairo_matrix_init

(PECL cairo >= 0.1.0)

CairoMatrix::__construct -- cairo_matrix_init — Creates a new CairoMatrix object

Açıklama

Nesne yönelimli kullanım (method):

public CairoMatrix::__construct ([ float $xx = 1.0 [, float $yx = 0.0 [, float $xy = 0.0 [, float $yy = 1.0 [, float $x0 = 0.0 [, float $y0 = 0.0 ]]]]]] )

Yordamsal kullanım:

object cairo_matrix_init ([ float $xx = 1.0 [, float $yx = 0.0 [, float $xy = 0.0 [, float $yy = 1.0 [, float $x0 = 0.0 [, float $y0 = 0.0 ]]]]]] )

Returns new CairoMatrix object. Matrices are used throughout cairo to convert between different coordinate spaces. Sets matrix to be the affine transformation given by xx, yx, xy, yy, x0, y0. The transformation is given by: x_new = xx * x + xy * y + x0; and y_new = yx * x + yy * y + y0;

Değiştirgeler

xx

xx component of the affine transformation

yx

yx component of the affine transformation

xy

xy component of the affine transformation

yy

yy component of the affine transformation

x0

X translation component of the affine transformation

y0

Y translation component of the affine transformation

Dönen Değerler

Returns a new CairoMatrix object that can be used with surfaces, contexts, and patterns.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* Create a new Matrix */
$matrix = new CairoMatrix(1.0, 0.5, 0.0, 1.0, 0.0, 0.0);
?>

Örnek 2 Yordamsal kullanım

<?php
/* Create a new Matrix */
$matrix = cairo_matrix_init(1.0, 0.5, 0.0, 1.0, 0.0, 0.0);
?>

Ayrıca Bakınız

  • CairoMatrix::initIdentity() - Creates a new identity matrix
  • CairoMatrix::initRotate() - Creates a new rotated matrix
  • CairoMatrix::initScale() - Creates a new scaling matrix
  • CairoMatrix::initTranslate() - Creates a new translation matrix

CairoMatrix
CairoMatrix::initIdentity
CairoMatrix


Creates a new identity matrix

CairoMatrix::__construct
CairoMatrix::initRotate
CairoMatrix
PHP Manual

CairoMatrix::initIdentity

cairo_matrix_init_identity

(PECL cairo >= 0.1.0)

CairoMatrix::initIdentity -- cairo_matrix_init_identity — Creates a new identity matrix

Açıklama

Nesne yönelimli kullanım (method):

public static void CairoMatrix::initIdentity ( void )

Yordamsal kullanım:

object cairo_matrix_init_identity ( void )

Creates a new matrix that is an identity transformation. An identity transformation means the source data is copied into the destination data without change

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a new CairoMatrix object that can be used with surfaces, contexts, and patterns.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* Create a new Matrix */
$matrix = CairoMatrix::initIdentity();
?>

Örnek 2 Yordamsal kullanım

<?php
/* Create a new Matrix */
$matrix = cairo_matrix_init_identity();
?>

Ayrıca Bakınız

  • CairoMatrix::__construct() - Creates a new CairoMatrix object
  • CairoMatrix::initRotate() - Creates a new rotated matrix
  • CairoMatrix::initScale() - Creates a new scaling matrix
  • CairoMatrix::initTranslate() - Creates a new translation matrix

CairoMatrix::__construct
CairoMatrix::initRotate
CairoMatrix


Creates a new rotated matrix

CairoMatrix::initIdentity
CairoMatrix::initScale
CairoMatrix
PHP Manual

CairoMatrix::initRotate

cairo_matrix_init_rotate

(PECL cairo >= 0.1.0)

CairoMatrix::initRotate -- cairo_matrix_init_rotate — Creates a new rotated matrix

Açıklama

Nesne yönelimli kullanım (method):

public static void CairoMatrix::initRotate ( float $radians )

Yordamsal kullanım:

object cairo_matrix_init_rotate ( float $radians )

Creats a new matrix to a transformation that rotates by radians provided

Değiştirgeler

radians

angle of rotation, in radians. The direction of rotation is defined such that positive angles rotate in the direction from the positive X axis toward the positive Y axis. With the default axis orientation of cairo, positive angles rotate in a clockwise direction.

Dönen Değerler

Returns a new CairoMatrix object that can be used with surfaces, contexts, and patterns.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* Create a new Matrix */
$matrix = CairoMatrix::initRotate(0.3);
?>

Örnek 2 Yordamsal kullanım

<?php
/* Create a new Matrix */
$matrix = cairo_matrix_init_rotate(0.3);
?>

Ayrıca Bakınız

  • CairoMatrix::__construct() - Creates a new CairoMatrix object
  • CairoMatrix::initIdentity() - Creates a new identity matrix
  • CairoMatrix::initScale() - Creates a new scaling matrix
  • CairoMatrix::initTranslate() - Creates a new translation matrix

CairoMatrix::initIdentity
CairoMatrix::initScale
CairoMatrix


Creates a new scaling matrix

CairoMatrix::initRotate
CairoMatrix::initTranslate
CairoMatrix
PHP Manual

CairoMatrix::initScale

cairo_matrix_init_scale

cairo_matrix_create_scale

(PECL cairo >= 0.1.0)

CairoMatrix::initScale -- cairo_matrix_init_scale -- cairo_matrix_create_scale — Creates a new scaling matrix

Açıklama

Nesne yönelimli kullanım (method):

public static void CairoMatrix::initScale ( float $sx , float $sy )

Yordamsal kullanım:

object cairo_matrix_init_scale ( float $sx , float $sy )

Creates a new matrix to a transformation that scales by sx and sy in the X and Y dimensions, respectively.

Değiştirgeler

sx

scale factor in the X direction

sy

scale factor in the Y direction

Dönen Değerler

Returns a new CairoMatrix object that can be used with surfaces, contexts, and patterns.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* Create a new Matrix */
$matrix = CairoMatrix::initScale(1.0, 2.0);
?>

Örnek 2 Yordamsal kullanım

<?php
/* Create a new Matrix */
$matrix = cairo_matrix_init_scale(1.0, 2.0);
?>

Ayrıca Bakınız

  • CairoMatrix::__construct() - Creates a new CairoMatrix object
  • CairoMatrix::initIdentity() - Creates a new identity matrix
  • CairoMatrix::initRotate() - Creates a new rotated matrix
  • CairoMatrix::initTranslate() - Creates a new translation matrix

CairoMatrix::initRotate
CairoMatrix::initTranslate
CairoMatrix


Creates a new translation matrix

CairoMatrix::initScale
CairoMatrix::invert
CairoMatrix
PHP Manual

CairoMatrix::initTranslate

cairo_matrix_init_translate

(PECL cairo >= 0.1.0)

CairoMatrix::initTranslate -- cairo_matrix_init_translate — Creates a new translation matrix

Açıklama

Nesne yönelimli kullanım (method):

public static void CairoMatrix::initTranslate ( float $tx , float $ty )

Yordamsal kullanım:

object cairo_matrix_init_translate ( float $tx , float $ty )

Creates a new matrix to a transformation that translates by tx and ty in the X and Y dimensions, respectively.

Değiştirgeler

tx

amount to translate in the X direction

ty

amount to translate in the Y direction

Dönen Değerler

Returns a new CairoMatrix object that can be used with surfaces, contexts, and patterns.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* Create a new Matrix */
$matrix = CairoMatrix::initTranslate(1.0, 2.0);
?>

Örnek 2 Yordamsal kullanım

<?php
/* Create a new Matrix */
$matrix = cairo_matrix_init_translate(1.0, 2.0);
?>

Ayrıca Bakınız

  • CairoMatrix::__construct() - Creates a new CairoMatrix object
  • CairoMatrix::initIdentity() - Creates a new identity matrix
  • CairoMatrix::initRotate() - Creates a new rotated matrix
  • CairoMatrix::initScale() - Creates a new scaling matrix

CairoMatrix::initScale
CairoMatrix::invert
CairoMatrix


The invert purpose

CairoMatrix::initTranslate
CairoMatrix::multiply
CairoMatrix
PHP Manual

CairoMatrix::invert

(PECL cairo >= 0.1.0)

CairoMatrix::invert — The invert purpose

Açıklama

public void CairoMatrix::invert ( void )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoMatrix::invert() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoMatrix::initTranslate
CairoMatrix::multiply
CairoMatrix


The multiply purpose

CairoMatrix::invert
CairoMatrix::rotate
CairoMatrix
PHP Manual

CairoMatrix::multiply

(PECL cairo >= 0.1.0)

CairoMatrix::multiply — The multiply purpose

Açıklama

public static CairoMatrix CairoMatrix::multiply ( CairoMatrix $matrix1 , CairoMatrix $matrix2 )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

matrix1

Description...

matrix2

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoMatrix::multiply() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoMatrix::invert
CairoMatrix::rotate
CairoMatrix


The rotate purpose

CairoMatrix::multiply
CairoMatrix::scale
CairoMatrix
PHP Manual

CairoMatrix::rotate

cairo_rotate

(PECL cairo >= 0.1.0)

CairoMatrix::rotate -- cairo_rotate — The rotate purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoMatrix::rotate ( string $sx , string $sy )

Yordamsal kullanım:

void cairo_rotate ( CairoContext $context , string $angle )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

angle

Description...

sx

Description...

sy

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoMatrix::multiply
CairoMatrix::scale
CairoMatrix


Applies scaling to a matrix

CairoMatrix::rotate
CairoMatrix::transformDistance
CairoMatrix
PHP Manual

CairoMatrix::scale

cairo_matrix_scale

(PECL cairo >= 0.1.0)

CairoMatrix::scale -- cairo_matrix_scale — Applies scaling to a matrix

Açıklama

Nesne yönelimli kullanım (method):

public void CairoMatrix::scale ( float $sx , float $sy )

Yordamsal kullanım:

void cairo_matrix_scale ( CairoContext $context , float $sx , float $sy )

Applies scaling by sx, sy to the transformation in the matrix. The effect of the new transformation is to first scale the coordinates by sx and sy, then apply the original transformation to the coordinates.

Değiştirgeler

matrix

Procedural only - CairoMatrix instance

sx

scale factor in the X direction

sy

scale factor in the Y direction

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* Apply scaling to a matrix */
$matrix = new CairoMatrix(1.0, 0.5, 0.0, 1.0, 0.0, 0.0);
$matrix->scale(0.2, 2.0);
?>

Örnek 2 Yordamsal kullanım

<?php
/* Apply scaling to a matrix */
$matrix = cairo_matrix_init(1.0, 0.5, 0.0, 1.0, 0.0, 0.0);
cairo_matrix_scale($matrix, 0.2, 2.0);
?>

Ayrıca Bakınız

  • CairoMatrix::initScale() - Creates a new scaling matrix

CairoMatrix::rotate
CairoMatrix::transformDistance
CairoMatrix


The transformDistance purpose

CairoMatrix::scale
CairoMatrix::transformPoint
CairoMatrix
PHP Manual

CairoMatrix::transformDistance

(PECL cairo >= 0.1.0)

CairoMatrix::transformDistance — The transformDistance purpose

Açıklama

public array CairoMatrix::transformDistance ( string $dx , string $dy )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

dx

Description...

dy

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoMatrix::transformDistance() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoMatrix::scale
CairoMatrix::transformPoint
CairoMatrix


The transformPoint purpose

CairoMatrix::transformDistance
CairoMatrix::translate
CairoMatrix
PHP Manual

CairoMatrix::transformPoint

(PECL cairo >= 0.1.0)

CairoMatrix::transformPoint — The transformPoint purpose

Açıklama

public array CairoMatrix::transformPoint ( string $dx , string $dy )

The method description goes here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

dx

Description...

dy

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 CairoMatrix::transformPoint() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoMatrix::transformDistance
CairoMatrix::translate
CairoMatrix


The translate purpose

CairoMatrix::transformPoint
CairoOperator
CairoMatrix
PHP Manual

CairoMatrix::translate

cairo_translate

(PECL cairo >= 0.1.0)

CairoMatrix::translate -- cairo_translate — The translate purpose

Açıklama

Nesne yönelimli kullanım (method):

public void CairoMatrix::translate ( string $tx , string $ty )

Yordamsal kullanım:

void cairo_translate ( CairoContext $context , string $x , string $y )

Description here.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

context

Description...

x

Description...

y

Description...

tx

Description...

ty

Description...

Dönen Değerler

Description...

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Örnek 2 Yordamsal kullanım

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

CairoMatrix::transformPoint
CairoOperator
CairoMatrix


The CairoOperator class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

This is used to set the compositing operator for all cairo drawing operations.

The default operator is CairoOperator::OVER

The operators marked as unbounded modify their destination even outside of the mask layer (that is, their effect is not bound by the mask layer). However, their effect can still be limited by way of clipping.

To keep things simple, the operator descriptions here document the behavior for when both source and destination are either fully transparent or fully opaque. The actual implementation works for translucent layers too. For a more detailed explanation of the effects of each operator, including the mathematical definitions, see http://cairographics.org/operators/.

Sınıf Sözdizimi

CairoOperator {
/* Sabitler */
const integer CLEAR = 0 ;
const integer SOURCE = 1 ;
const integer OVER = 2 ;
const integer IN = 3 ;
const integer OUT = 4 ;
const integer ATOP = 5 ;
const integer DEST = 6 ;
const integer DEST_OVER = 7 ;
const integer DEST_IN = 8 ;
const integer DEST_OUT = 9 ;
const integer DEST_ATOP = 10 ;
const integer XOR = 11 ;
const integer ADD = 12 ;
const integer SATURATE = 13 ;
}

Öntanımlı Sabitler

CairoOperator::CLEAR

Clear destination layer (bounded)

CairoOperator::SOURCE

Replace destination layer (bounded)

CairoOperator::OVER

Draw source layer on top of destination layer (bounded)

CairoOperator::IN

Draw source where there was destination content (unbounded)

CairoOperator::OUT

Draw source where there was no destination content (unbounded)

CairoOperator::ATOP

Draw source on top of destination content and only there

CairoOperator::DEST

Ignore the source

CairoOperator::DEST_OVER

Draw destination on top of source

CairoOperator::DEST_IN

Leave destination only where there was source content (unbounded)

CairoOperator::DEST_OUT

Leave destination only where there was no source content

CairoOperator::DEST_ATOP

Leave destination on top of source content and only there (unbounded)

CairoOperator::XOR

Source and destination are shown where there is only one of them

CairoOperator::ADD

Source and destination layers are accumulated

CairoOperator::SATURATE

Like CairoOperator::OVER, but assuming source and dest are disjoint geometries

CairoMatrix::translate
CairoPath
Cairo


The CairoPath class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

Note: CairoPath class cannot be instantiated directly, doing so will result in Fatal Error if used or passed

Sınıf Sözdizimi

CairoPath {
}
CairoOperator
CairoPsLevel
Cairo


The CairoPsLevel class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

Sınıf Sözdizimi

CairoPsLevel {
/* Sabitler */
const integer LEVEL_2 = 0 ;
const integer LEVEL_3 = 1 ;
}

Öntanımlı Sabitler

CairoPsLevel::LEVEL_2

Description here...

CairoPsLevel::LEVEL_3

Description here...

CairoPath
CairoSubpixelOrder
Cairo


The CairoSubpixelOrder class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

Sınıf Sözdizimi

CairoSubpixelOrder {
/* Sabitler */
const integer ORDER_DEFAULT = 0 ;
const integer ORDER_RGB = 1 ;
const integer ORDER_BGR = 2 ;
const integer ORDER_VRGB = 3 ;
const integer ORDER_VBGR = 4 ;
}

Öntanımlı Sabitler

CairoSubpixelOrder::ORDER_DEFAULT

Description here...

CairoSubpixelOrder::ORDER_RGB

Description here...

CairoSubpixelOrder::ORDER_BGR

Description here...

CairoSubpixelOrder::ORDER_VRGB

Description here...

CairoSubpixelOrder::ORDER_VBGR

Description here...

CairoPsLevel
CairoSvgVersion
Cairo


The CairoSvgVersion class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

Sınıf Sözdizimi

CairoSvgVersion {
/* Sabitler */
const integer VERSION_1_1 = 0 ;
const integer VERSION_1_2 = 1 ;
}

Öntanımlı Sabitler

CairoSvgVersion::VERSION_1_1

Description here...

CairoSvgVersion::VERSION_1_2

Description here...

CairoSubpixelOrder
Exif
Cairo


Değiş Tokuş Edilebilir Resim Bilgileri

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Exif İşlevleri
    • exif_imagetype — Bir resmin türünü saptar
    • exif_read_data — Bir JPEG veya TIFF resminden EXIF başlıklarını okur
    • exif_tagname — Bir indis için başlık ismini döndürür
    • exif_thumbnail — Bir TIFF veya JPEG resminin içinde gömülü küçük örneği döndürür
    • read_exif_data — exif_read_data işlevinin takma adıdır
CairoSvgVersion
Giriş
Resim İşleme ve Resim Üretimi


Giriş

Exif eklentisi ile resimlerin temel verileri üzerinde çalışabilirsiniz. Örneğin, JPEG ve TIFF resimlerin başlıklarında sayısal kameralar tarafından saklanmış ham verileri okumak için exif işlevlerini kullanabilirsiniz.

Exif
Yapılandırma/Kurulum
Exif


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Exif


Gereksinimler

PHP --enable-exif seçeneği ile derlenmelidir. PHP Exif modülü için ek bir kütüphane gerektirmez. Windows kullanıcılarının mbstring eklentisini de etkin kılmaları gerekir.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Exif desteğini etkin kılmak için PHP'yi --enable-exif seçeneği ile derleyin.

Windows kullanıcılarının, php.ini içinde hem php_mbstring.dll hem de php_exif.dll DLL'lerini etkin kılmaları gerekir. php.ini dosyanızı yapılandırırken php_mbstring.dll dosyasının php_exif.dll dosyasından önce yüklenmesini sağlamalısınız.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

mbstring modülü kullanılabildiği takdirde, exif, Evrenkod ve JIS karakter kodlamalı kullanıcı açıklamalarının dönüşümünü özdevinimli olarak yapar. Önce belirtilen karakter kümesi kullanılarak kodlama dönüştürüldükten sonra bu yapılır. Sonuç HTTP çıktısına uygun olarak diğer karakter kodlamasına dönüştürülür.

Exif yapılandırma yönergeleri
İsim | Öntanımlı Değer | Değişiklik Yeri | Sürüm Bilgisi
exif.encode_unicode | "ISO-8859-15" | PHP_INI_ALL | PHP 4.3.0'dan beri kullanılabilmektedir.
exif.decode_unicode_motorola | "UCS-2BE" | PHP_INI_ALL | PHP 4.3.0'dan beri kullanılabilmektedir.
exif.decode_unicode_intel | "UCS-2LE" | PHP_INI_ALL | PHP 4.3.0'dan beri kullanılabilmektedir.
exif.encode_jis | "" | PHP_INI_ALL | PHP 4.3.0'dan beri kullanılabilmektedir.
exif.decode_jis_motorola | "JIS" | PHP_INI_ALL | PHP 4.3.0'dan beri kullanılabilmektedir.
exif.decode_jis_intel | "JIS" | PHP_INI_ALL | PHP 4.3.0'dan beri kullanılabilmektedir.
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

exif.encode_unicode string

exif.encode_unicode, UNICODE kodlu kullanıcı açıklamalarının elde edilmesinde kullanılacak karakter kümesini tanımlar. Çoğu Asya ülkesinde kullanılabilecek olan ISO-8859-15 öntanımlıdır. Bu değer boş olabilir. Belirtildiği takdirde mbstring tarafından tanınan karakter kümelerinden biri olmalıdır. Boş olduğu takdirde mbstring eklentisinin öntanımlı dahili kodlaması kullanılır.

exif.decode_unicode_motorola string

exif.decode_unicode_motorola, resim motorola bayt sıralamasına sahipse UNICODE kodlu kullanıcı açıklamaları için resim içi karakter kümesini tanımlar. Bu değer boş olamaz fakat mbstring tarafından tanınan kodlamalar liste halinde belirtilebilir. UCS-2BE öntanımlıdır.

exif.decode_unicode_intel string

exif.decode_unicode_intel, resim intel bayt sıralamasına sahipse UNICODE kodlu kullanıcı açıklamaları için resim içi karakter kümesini tanımlar. Bu değer boş olamaz fakat mbstring tarafından tanınan kodlamalar liste halinde belirtilebilir. UCS-2LE öntanımlıdır.

exif.encode_jis string

exif.encode_jis JIS kodlu kullanıcı açıklamalarının elde edilmesinde kullanılacak karakter kümesini tanımlar. İşlevin mbstring eklentisinin öntanımlı dahili kodlamasının kullanılmasını sağlayan boş değer öntanımlı değerdir.

exif.decode_jis_motorola string

exif.decode_jis_motorola, resim motorola bayt sıralamasına sahipse JIS kodlu kullanıcı açıklamaları için resim içi karakter kümesini tanımlar. Bu değer boş olamaz fakat mbstring tarafından tanınan kodlamalar liste halinde belirtilebilir. JIS öntanımlıdır.

exif.decode_jis_intel string

exif.decode_jis_intel, resim intel bayt sıralamasına sahipse JIS kodlu kullanıcı açıklamaları için resim içi karakter kümesini tanımlar. Bu değer boş olamaz fakat mbstring tarafından tanınan kodlamalar liste halinde belirtilebilir. JIS öntanımlıdır.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

EXIF_USE_MBSTRING (integer)

Yerleşik sabitlerin bazıları exif_imagetype() işlevi tarafından listelenir.

Özkaynak Türleri
Exif İşlevleri
Exif


Exif İşlevleri

İçindekiler

  • exif_imagetype — Bir resmin türünü saptar
  • exif_read_data — Bir JPEG veya TIFF resminden EXIF başlıklarını okur
  • exif_tagname — Bir indis için başlık ismini döndürür
  • exif_thumbnail — Bir TIFF veya JPEG resminin içinde gömülü küçük örneği döndürür
  • read_exif_data — exif_read_data işlevinin takma adıdır
Öntanımlı Sabitler
exif_imagetype
Exif


Bir resmin türünü saptar

Exif İşlevleri
exif_read_data
Exif İşlevleri
PHP Manual

exif_imagetype

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

exif_imagetype — Bir resmin türünü saptar

Açıklama

int exif_imagetype ( string $dosya )

exif_imagetype() işlevi bir resmin ilk baytlarındaki dosya imzasını okur.

exif_imagetype() işlevi, desteklenmeyen dosya türlerini diğer exif işlevlerinde kullanmaktan kaçınabilmek için veya tarayıcının belli bir resim türünü gösterip göstermeyeceğini saptamak için $_SERVER['HTTP_ACCEPT'] ile birlikte kullanmak üzere tasarlanmıştır.

Değiştirgeler

dosya
İçerdiği resim türü saptanacak dosya.

Dönen Değerler

Doğru imza bulunduğu takdirde uygun sabitin değeri döndürülür, aksi takdirde FALSE döner. Dönüş değeri getimagesize() ile aynıdır fakat exif_imagetype() daha hızlıdır.

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.2 | JPC, JP2, JPX, JB2, XBM ve WBMP desteği eklendi.
4.3.0 | SWC desteği eklendi.

Öntanımlı Sabitler

exif_imagetype() dönüş değeri olarak şu sabitler tanımlıdır:

Resim türü Sabitleri
Değr | Sabit
1 | IMAGETYPE_GIF
2 | IMAGETYPE_JPEG
3 | IMAGETYPE_PNG
4 | IMAGETYPE_SWF
5 | IMAGETYPE_PSD
6 | IMAGETYPE_BMP
7 | IMAGETYPE_TIFF_II (intel bayt sıralaması)
8 | IMAGETYPE_TIFF_MM (motorola bayt sıralaması)
9 | IMAGETYPE_JPC
10 | IMAGETYPE_JP2
11 | IMAGETYPE_JPX
12 | IMAGETYPE_JB2
13 | IMAGETYPE_SWC
14 | IMAGETYPE_IFF
15 | IMAGETYPE_WBMP
16 | IMAGETYPE_XBM

Örnekler

Örnek 1 - exif_imagetype() örneği

<?php
if (exif_imagetype('image.gif') != IMAGETYPE_GIF) {
    echo 'Bu bir GIF değil.';
}
?>

Ayrıca Bakınız

  • getimagesize() - Bir resmin boyutlarını döndürür

Exif İşlevleri
exif_read_data
Exif İşlevleri


Bir JPEG veya TIFF resminden EXIF başlıklarını okur

exif_imagetype
exif_tagname
Exif İşlevleri
PHP Manual

exif_read_data

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

exif_read_data — Bir JPEG veya TIFF resminden EXIF başlıklarını okur

Açıklama

array exif_read_data ( string $dosya [, string $bölümler = NULL [, bool $diziler = false [, bool $küçük_örnek = false ]]] )

exif_read_data() işlevi bir JPEG veya TIFF resminden EXIF başlıklarını okur. Böylece sayısal kameralar tarafından üretilen temel veriler okunabilir.

Exif başlıkları sayısal kameralar tarafından üretilen JPEG/TIFF resimlerde bulunması için tasarlanmışlarsa da ne yazık ki, her sayısal kamera imalatçısı resim başlıklarının elde edilmesi konusunda farklı yaklaşımlara sahiptirler. Bu bakımdan bazı Exif başlıkları resim üzerinde mevcut olmayabilir.

Height ve Width başlıkları getimagesize() işlevinin yaptığı gibi hesaplandığından döndürülen başlığın birer parçası olmamalıdırlar. html başlığı normal HTML içinde kullanılacak metnin yükseklik/genişlik dizgesidir.

Bir Exif başlığı bir telif hakkı bilgisi içerdiği takdirde, bu iki değerden oluşur. Çözüm Exif 2.10 standadıyla uyumsuz olup COMPUTED bölümü hem Copyright.Photographer hem de Copyright.Editor başlıklarını içerirken IFD0 bölümleri iki girdiyi ayıran NULL karakterli bayt dizisini içerir. Eğer veri türü yanlışsa sadece ilk girdi döner (Exif'in normal davranışı). COMPUTED bölümü ayrıca, Copyright dizgesini de içerir ve bu dizge ya özgün telif hakkı dizgesini ya da fotoğraf ve eser düzenleyici telif haklarını içeren dizgeyi içerir.

UserComment yaftası Copyright yaftası ile aynı sorunlara sahiptir. O da iki değer saklayabilir. İlki kullanılan kodlama, ikincisi değerin kendisidir. Bu durumda, IFD bölümü sadece kodlamayı ve bayt dizisini içerir. COMPUTED bölümü UserCommentEncoding ve UserComment girdilerinin ikisini de saklar. UserComment girdisi her iki durumda da mevcuttur, dolayısıyla IFD0 bölümündeki değere tercihan kullanılmış olmalıdır.

exif_read_data() işlevi ayrıca, EXIF belirtimine uygun olarak EXIF veri başlıklarını da doğrular.

Bilginize:

Windows ME/XP bir kameraya bağlanırken Exif başlıklarını temizler.

Değiştirgeler

dosya

Okunacak resim dosyasının ismi. Bir URL belirtilemez.

bölümler

Sonuç dizisinin üretiminde kullanılmak üzere dosyadaki başlıkların virgül ayraçlı listesi. Belirtilen başlıkların hiçbiri bulunamazsa işlev FALSE döndürür.

FILE | FileName, FileSize, FileDateTime, SectionsFound (Dosyaİsmi, DosyaBoyu, DosyaTarihiSaati, BölümlarVar)
COMPUTED | html, Width, Height, IsColor (html, genişlik, yükseklik, Renklidir) ve varsa başkaları. Height ve Width, getimagesize() işlevinin yaptığı gibi hesaplanır, dolayısıyla bunlar döndürülen başlığın parçaları olmamalıdır. Ayrıca, html, normal HTML içinde kullanılacak height/width dizgesidir.
ANY_TAG | IFD0, EXIF, ... gibi bir yaftaya sahip her türlü bilgi
IFD0 | IFD0'ın tüm yaftalanmış bilgisi. Normal resim dosyalarında burada resim boyutu ve saire bulunur.
THUMBNAIL | Dosya ikinci bir IFD'ye sahipse resmin küçük bir örneğini içerdiği varsayılır. Küçük resim örneği ile ilgili tüm veriler bu bölümde saklanır.
COMMENT | JPEG resimlerin açıklama başlıkları.
EXIF | EXIF bölümü IFD0 bölümünün bir alt bölümüdür. Burada resim hakkında çok daha fazla bilgi bulunur. Bu girdilerin çoğu sayısal kamera ile ilgilidir.

diziler

Her bölümün bir dizi haline getirilip getirilmeyeceğini belirler. COMPUTED, THUMBNAIL ve COMMENT bölümleri, diğer bölümlerle karışmaması için daima bir dizi haline getirilirler.

küçük_örnek

TRUE belirtilmişse küçük resim örneğinin kendisi okunur. Aksi takdirde, sadece yaftalı veriler okunur.

Dönen Değerler

Dönen değer bir dizi olup, dizi indisleri başlık isimlerini, değerler bu başlıklarla ilgili verileri içerir. Eğer hiçbir veri döndürülemezse exif_read_data() işlevi FALSE döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.0 | Diziler dahil gömülü tüm IFD verisi okunabilir oldu. Ayrıca, gömülü küçük resim örneğinin THUMBNAIL alt dizisinde döndürülebilmesi mümkün oldu. Ayrıca, dönen değerlerle ilgili bir azami uzunluk artık söz konusu değil (bellek miktarı ile sınırlı).
4.3.0 | PHP mbstring desteğine sahipse, kullanıcı açıklamalarının kodlaması özdevinimli olarak değiştirilebiliyor. Ayrıca, eğer kullanıcı açıklaması Evrenkod veya JIS kodlaması kullanıyorsa kodlama php.ini içindeki ayara uygun olarak özdevinimli değiştirilebiliyor.
4.3.0 | Eğer resim bir IFD0 verisi içeriyorsa COMPUTED bölümü artık, kıymetli baytın başta olduğu bayt sıralamasının kullanıldığı (motorola) bayt sıralaması için 1, diğeri (intel) için 0 değerini içeren bir ByteOrderMotorola girdisine sahip. Eğer veri türü yanlışsa, COMPUTED ve UserComment artık herhangi bir telif hakkı girdisi içermiyor.

Örnekler

Örnek 1 - exif_read_data() örneği

<?php
echo "test1.jpg:<br />\n";
$exif = exif_read_data('tests/test1.jpg', 'IFD0');
echo $exif===false ? "<Başlık verisi bulunamadı.<br />\n" : "Resim başlıkları içeriyor<br />\n";

$exif = exif_read_data('tests/test2.jpg', 0, true);
echo "test2.jpg:<br />\n";
foreach ($exif as $key => $section) {
    foreach ($section as $name => $val) {
        echo "$key.$name: $val<br />\n";
    }
}
?>

Resim başlık bilgisi içermediğinden ilk çağrı başarısız olur.

Yukarıdaki örnek şuna benzer bir çıktı üretir:

test1.jpg:
Başlık verisi bulunamadı.
test2.jpg:
FILE.FileName: test2.jpg
FILE.FileDateTime: 1017666176
FILE.FileSize: 1240
FILE.FileType: 2
FILE.SectionsFound: ANY_TAG, IFD0, THUMBNAIL, COMMENT
COMPUTED.html: width="1" height="1"
COMPUTED.Height: 1
COMPUTED.Width: 1
COMPUTED.IsColor: 1
COMPUTED.ByteOrderMotorola: 1
COMPUTED.UserComment: Exif test image.
COMPUTED.UserCommentEncoding: ASCII
COMPUTED.Copyright: Photo (c) M.Boerger, Edited by M.Boerger.
COMPUTED.Copyright.Photographer: Photo (c) M.Boerger
COMPUTED.Copyright.Editor: Edited by M.Boerger.
IFD0.Copyright: Photo (c) M.Boerger
IFD0.UserComment: ASCII
THUMBNAIL.JPEGInterchangeFormat: 134
THUMBNAIL.JPEGInterchangeFormatLength: 523
COMMENT.0: Comment #1.
COMMENT.1: Comment #2.
COMMENT.2: Comment #3end
THUMBNAIL.JPEGInterchangeFormat: 134
THUMBNAIL.Thumbnail.Height: 1
THUMBNAIL.Thumbnail.Height: 1

Ayrıca Bakınız

  • exif_thumbnail() - Bir TIFF veya JPEG resminin içinde gömülü küçük örneği döndürür
  • getimagesize() - Bir resmin boyutlarını döndürür

exif_imagetype
exif_tagname
Exif İşlevleri


Bir indis için başlık ismini döndürür

exif_read_data
exif_thumbnail
Exif İşlevleri
PHP Manual

exif_tagname

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

exif_tagname — Bir indis için başlık ismini döndürür

Açıklama

string exif_tagname ( int $indis )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

indis

Resim indisi.

Dönen Değerler

indis tanımsızsa FALSE, aksi takdirde başlık ismi döner.

Ayrıca Bakınız

  • exif_imagetype() - Bir resmin türünü saptar

exif_read_data
exif_thumbnail
Exif İşlevleri


Bir TIFF veya JPEG resminin içinde gömülü küçük örneği döndürür

exif_tagname
read_exif_data
Exif İşlevleri
PHP Manual

exif_thumbnail

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

exif_thumbnail — Bir TIFF veya JPEG resminin içinde gömülü küçük örneği döndürür

Açıklama

string exif_thumbnail ( string $dosya [, int &$genişlik [, int &$yükseklik [, int &$resim_türü ]]] )

exif_thumbnail() işlevi bir TIFF veya JPEG resminin içinde gömülü küçük örneği döndürür.

Resimlerin küçük örneklerini bu işlev ile göndermek isterseniz MIME türü bilgisini header() işlevini kullanarak göndermeniz gerekir.

exif_thumbnail() bir resim oluşturamaz ama boyutlarını belirleyebilir. Bu durumda dönen değer FALSE olur fakat genişlik ve yükseklik tanımlanmış olur.

Değiştirgeler

dosya

Okunacak resim dosyasının ismi Bu resmin içinde küçük bir örneği gömülü olmalıdır.

genişlik

Döndürülecek küçük örneğin genişliği.

height

Döndürülecek küçük örneğin yüksekliği.

resim_türü

Döndürülecek küçük örneğin resim türü. TIFF veya JPEG olabilir.

Dönen Değerler

Gömülü bir resim örneği yoksa FALSE, aksi takdirde gömülü küçük örneği döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.0 | Belirtilmesi isteğe bağlı genişlik, yükseklikve resim_türü değiştirgeleri eklendi.
4.3.0 | TIFF biçemli resim örnekleri döndürülebilir oldu.

Örnekler

Örnek 1 - exif_thumbnail() örneği

<?php
if (array_key_exists('file', $_REQUEST)) {
    $image = exif_thumbnail($_REQUEST['file'], $width, $height, $type);
} else {
    $image = false;
}
if ($image!==false) {
    header('Content-type: ' .image_type_to_mime_type($type));
    echo $image;
    exit;
} else {
    // Resmin örneği yoksa, hataları burada ele alacağız
    echo 'Resmin içinde küçük bir örneği yok';
}
?>

Ayrıca Bakınız

  • exif_read_data() - Bir JPEG veya TIFF resminden EXIF başlıklarını okur
  • image_type_to_mime_type() - getimagesize, exif_read_data, exif_thumbnail, exif_imagetype ile döndürülen resim türü ile ilgili MIME türünü döndürür

exif_tagname
read_exif_data
Exif İşlevleri


exif_read_data işlevinin takma adıdır

exif_thumbnail
GD
Exif İşlevleri
PHP Manual

read_exif_data

(PHP 4 >= 4.0.1, PHP 5, PHP 7)

read_exif_data — exif_read_data() işlevinin takma adıdır

Açıklama

Bu işlev exif_read_data() işlevinin takma adıdır.

exif_thumbnail
GD
Exif İşlevleri


Resim İşleme ve GD

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
  • GD ve Resim İşlevleri
    • gd_info — Kurulu GD kütüphanesi hakkında bilgi verir
    • getimagesize — Bir resmin boyutlarını döndürür
    • getimagesizefromstring — Get the size of an image from a string
    • image_type_to_extension — Resim türü ile ilgili dosya uzantısını döndürür
    • image_type_to_mime_type — getimagesize, exif_read_data, exif_thumbnail, exif_imagetype ile döndürülen resim türü ile ilgili MIME türünü döndürür
    • image2wbmp — Bir dosyaya veya tarayıcıya bir WBMP resmi çıktılar
    • imageaffine — Return an image containing the affine transformed src image, using an optional clipping area
    • imageaffinematrixconcat — Concatenate two affine transformation matrices
    • imageaffinematrixget — Get an affine transformation matrix
    • imagealphablending — Bir resim için harmanlama kipini etkinleştirir
    • imageantialias — Kenar yumuşatma işlevlerini uygulatır
    • imagearc — Bir yay çizer
    • imagebmp — Output a BMP image to browser or file
    • imagechar — Yatay olarak bir karakter çizer
    • imagecharup — Düşey olarak bir karakter çizer
    • imagecolorallocate — Bir resim için bir renk ayırır
    • imagecolorallocatealpha — Bir resim için alfa kanallı bir renk ayırır
    • imagecolorat — Bir pikselin renk indisini döndürür
    • imagecolorclosest — Belirtilen rengin en yakın benzerinin indisini döndürür
    • imagecolorclosestalpha — Alfası ile birlikte belirtilen rengin en yakın benzerinin renk indisini verir
    • imagecolorclosesthwb — En yakın renk sıcaklığına, beyaz ve siyahlığa sahip renk indisini verir
    • imagecolordeallocate — Bir rengi tanımsız yapar
    • imagecolorexact — Belirtilen rengin indisini döndürür
    • imagecolorexactalpha — Alfası ile birlikte belirtilen rengin indisini verir
    • imagecolormatch — Bir resmin paletli sürümünün renklerini gerçek renkli sürümünün renkleriyle aynı yapar
    • imagecolorresolve — Belirtilen rengin veya en yakın benzerinin indisini döndürür
    • imagecolorresolvealpha — Alfası ile birlikte belirtilen rengin veya en yakın benzerinin renk indisini verir
    • imagecolorset — Bir palet indisi için renk tanımlar
    • imagecolorsforindex — Bir renk indisinin renk bilgisini döndürür
    • imagecolorstotal — Bir resim paletindeki renk sayısını döndürür
    • imagecolortransparent — Bir rengi şeffaflaştırır
    • imageconvolution — Bir konum ve katsayı ile 3x3'lük bir evrişim matrisini uygular
    • imagecopy — Bir resim parçasını kopyalar
    • imagecopymerge — Bir resmi kopyalar ve karıştırır
    • imagecopymergegray — Bir resmi kopyalar ve gri tonlama ile karıştırır
    • imagecopyresampled — Resmin bir parçasını örnekleyerek kopyalar ve boyutlandırır
    • imagecopyresized — Resmin bir parçasını kopyalar ve boyutlandırır
    • imagecreate — Yeni bir paletli resim oluşturur
    • imagecreatefrombmp — Bir dosya veya URL'den yeni bir resim oluşturur.
    • imagecreatefromgd2 — Bir GD2 dosyasından veya URL'sinden yeni bir resim oluşturur
    • imagecreatefromgd2part — Bir GD2 parça dosyasından veya URL'sinden yeni bir resim oluşturur
    • imagecreatefromgd — Bir GD dosyasından veya URL'sinden yeni bir resim oluşturur
    • imagecreatefromgif — Bir dosya veya URL'den yeni bir resim oluşturur.
    • imagecreatefromjpeg — Bir dosya veya URL'den yeni bir resim oluşturur.
    • imagecreatefrompng — Bir dosya veya URL'den yeni bir resim oluşturur.
    • imagecreatefromstring — Belirtilen dizgeden yeni bir resim oluşturur
    • imagecreatefromwbmp — Bir dosya veya URL'den yeni bir resim oluşturur.
    • imagecreatefromwebp — Bir dosya veya URL'den yeni bir resim oluşturur.
    • imagecreatefromxbm — Bir dosya veya URL'den yeni bir resim oluşturur.
    • imagecreatefromxpm — Bir XPM dosyasından veya URL'sinden yeni bir resim oluşturur
    • imagecreatetruecolor — Yeni bir gerçek renkli resim oluşturur
    • imagecrop — Crop an image to the given rectangle
    • imagecropauto — Crop an image automatically using one of the available modes
    • imagedashedline — Kesikli çizgi çizer
    • imagedestroy — Bir resmi bellekten siler
    • imageellipse — Bir elips çizer
    • imagefill — Resmi boyar
    • imagefilledarc — Bir yay çizer ve içini doldurur
    • imagefilledellipse — İçi dolu bir elips çizer
    • imagefilledpolygon — İçi dolu bir çokgen çizer
    • imagefilledrectangle — İçi dolu bir dikdörtgen çizer
    • imagefilltoborder — Belli bir bölgeyi belli bir renge boyar
    • imagefilter — Bir resme bir süzgeç uygular
    • imageflip — Flips an image using a given mode
    • imagefontheight — Yazı tipi yüksekliğini döndürür
    • imagefontwidth — Yazı tipi genişliğini döndürür
    • imageftbbox — Bir FreeType2 yazı tipi ile yazılacak bir metnin çerçevesini hesaplar
    • imagefttext — Bir metni bir resme bir FreeType 2 yazı tipini kullanarak yazar
    • imagegammacorrect — Bir GD resmine gamma düzeltmesi uygular
    • imagegd2 — Tarayıcıya veya bir dosyaya bir GD2 resmi çıktılar
    • imagegd — Tarayıcıya veya bir dosyaya bir GD resmi çıktılar
    • imagegetclip — Get the clipping rectangle
    • imagegif — Bir dosyaya veya tarayıcıya bir GIF resmi çıktılar
    • imagegrabscreen — Ekran görüntüsünü yakalar
    • imagegrabwindow — Bir pencereyi yakalar
    • imageinterlace — Geçişimliliği açıp kapar
    • imageistruecolor — Bir resmin gerçek renkli olup olmadığını bulur
    • imagejpeg — Tarayıcıya veya bir dosyaya bir JPEG resmi çıktılar
    • imagelayereffect — PHP ile gelen libgd'nin katmanlama etkisini kullanmak için alfa harmanlama seçeneğini ayarlar
    • imageline — Bir çizgi çizer
    • imageloadfont — Yeni bir bit eşlemli yazı tipi yükler
    • imageopenpolygon — Draws an open polygon
    • imagepalettecopy — Paleti bir resimden diğerine kopyalar
    • imagepalettetotruecolor — Converts a palette based image to true color
    • imagepng — Tarayıcıya veya bir dosyaya bir PNG resmi çıktılar
    • imagepolygon — Çokgen çizer
    • imagepsbbox — Bir PostScript Type1 yazı tipi ile yazılan bir metnin çerçevesini döndürür
    • imagepsencodefont — Bir yazı tipinin karakter kodlamasını değiştirir
    • imagepsextendfont — Bir PS yazı tipini genişletir veya daraltır
    • imagepsfreefont — Bir PostScript Type 1 yazı tipi tarafından kullanılan belleği serbest bırakır
    • imagepsloadfont — Bir dosyadan bir PostScript Type 1 yazı tipi yükler
    • imagepsslantfont — Bir yazı tipini eğer
    • imagepstext — PostScript Type1 yazı tiplerini kullanarak bir resmin üzerine bir metin çizer
    • imagerectangle — Bir dikdörtgen çizer
    • imageresolution — Get or set the resolution of the image
    • imagerotate — Bir resmi belirtilen açıya göre döndürür
    • imagesavealpha — PNG resimleri kaydederken (tek renkli şeffaflığın tersine) alfa kanalı bilgisinin kaydedilip kaydedilmeyeceğini belirtir
    • imagescale — Scale an image using the given new width and height
    • imagesetbrush — Çizgi çizmek için fırça resmi oluşturur
    • imagesetclip — Set the clipping rectangle
    • imagesetinterpolation — Set the interpolation method
    • imagesetpixel — Bir pikselin rengini değiştirir
    • imagesetstyle — Çizgi tarzını ayarlar
    • imagesetthickness — Çizgi kalınlığını ayarlar
    • imagesettile — Resmi doldurmak için döşemeyi etkin kılar
    • imagestring — Bir dizgeyi yatay olarak yazar
    • imagestringup — Bir dizgeyi 90 derece döndürülmüş olarak yazar
    • imagesx — Resmin genişliğini döndürür
    • imagesy — Resmin yüksekliğini döndürür
    • imagetruecolortopalette — Bir gerçek renkli resmi bir paletli resme dönüştürür
    • imagettfbbox — TrueType yazıtipi kullanılan bir metnin çerçevesini döndürür
    • imagettftext — Metni resme TrueType yazı tipi ile yazar
    • imagetypes — Kurulu PHP'nin desteklediği resim türlerini döndürür
    • imagewbmp — Resmi bir dosyaya veya tarayıcıya çıktılar
    • imagewebp — Output a WebP image to browser or file
    • imagexbm — Bir XBM resmini tarayıcıya veya dosyaya çıktılar
    • iptcembed — İkil IPTC verisini bir JPEG resminin içine gömer
    • iptcparse — Bir ikil IPTC bloğunu tekil etiketlere böler
    • jpeg2wbmp — Bir JPEG dosyasını WBMP dosyasına dönüştürür
    • png2wbmp — Bir PNG dosyasını WBMP dosyasına dönüştürür
read_exif_data
Giriş
Resim İşleme ve Resim Üretimi


Giriş

PHP sadece HTML çıktı oluşturmaz. Ayrıca, GIF, PNG, JPEG, WBMP ve XPM dahil çeşitli resim biçemlerinde dosyalar oluşturabilir veya bunlar üzerinde değişiklik yapabilir. Dahası, PHP resim akımlarını doğrudan tarayıcıya gönderebilir. Bunun için PHP'yi GD kütüphanesi ile derlemeniz gerekir. Hangi resim biçemlerini kullanmak istediğinize bağlı olarak PHP ve GD başka kütüphaneleri de gerektirebilir.

PHP'deki resim işlevlerini JPEG, GIF, PNG, SWF, TIFF ve JPEG2000 resimlerinin boyutlarını öğrenmek için kullanabilirsiniz.

Exif eklentesi ile JPEG ve TIFF resim başlıklarındaki bilgiler üzerinde çalışabilir, böylece sayısal kameralar tarafından üretilmiş temel verileri okuyabilirsiniz. Exif işlevleri GD kütüphanesine ihtiyaç duymaz.

Bilginize: Resimleri okumak, değiştirmek ve yazmak için kütüphanenin yeteneklerinin nasıl geliştirileceğini öğrenmek için gereksinimler sayfasına bakınız. Sayısal kameralardan aldığınız resimlerin temel verilerini okumak için exif eklentisi gerekir.

Bilginize: getimagesize() işlevi GD eklentisini gerektirmez.

GD
Yapılandırma/Kurulum
GD


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
GD


Gereksinimler

GD kütüphanesine (» http://www.libgd.org/ adresinden edinilebilir) sahipseniz resimlerde değişiklik yapabilir veya yenilerini oluşturabilirsiniz.

Üzerinde işlem yapabileceğiniz resim biçemleri kurulu GD kütüphanesine ve GD'nin bu biçemlere erişmesini sağlayan diğer kütüphanelere bağlıdır. gd-1.6'dan daha eski GD sürümleri GIF biçemli resimleri desteklerken PNG biçemlileri desteklemezler. gd-1.6'dan sonraki ve gd-2.0.28'den önceki GD sürümleri ise PNG'yi desteklerken GIF'i desteklemezler. GIF desteği gd-2.0.28'den itibaren yeniden etkin olmuştur.

Bilginize: PHP 4.3'ten beri PHP paketiyle gelmekte olan GD kütüphanesi sürümü alfa harmanlaması gibi bazı ek özelliklere sahiptir ve bakımı daha iyi yapıldığından ve daha kararlı olduğundan harici kütüphanelere tercih edilmektedir.

Bilginize:

GD 1.x desteği PHP 6.0.0'dan itibaren kaldırılmıştır; PHP 6.0.0, GD kütüphanesinin 2.0.33 ve sonraki sürümlerini gerektirmektedir.

Daha fazla resim biçemini destekleyecek şekilde GD yeteneklerini genişletebilirsiniz.

Desteklenen resim biçemleri
Resim biçemi | İndirilecek kütüphane | Ek bilgiler
gif |  | Sadece gd-1.6'dan eski ve gd-2.0.28'den yeni GD sürümlerince desteklenmektedir. Salt okunur GIF desteği PHP 4.3.0'dan beri PHP ile dağıtılan GD kütüphanesi ile kullanılabilmektedir. Yazma desteği PHP 4.3.9 ve PHP 5.0.1'den beri vardır.
jpeg-6b | » http://www.ijg.org/ | (PHP'yi derlemeden önce) jpeg-v6b kütüphanesini derlemek için yapılandırırken --enable-shared seçeneğini kullanmalısınız. Bunu yapmazsanız, PHP'yi derlemek için yapılandırırken libjpeg.(a|so) bulunamadı anlamına gelen bir hata iletisi alırsınız.
png | » http://www.libpng.org/pub/png/libpng.html | Sadece gd-1.6'dan yeni GD sürümlerince desteklenmektedir.
xpm | » ftp://metalab.unc.edu/pub/Linux/libs/X/!INDEX.html | Sisteminizde X pencere sistemi kuruluysa bu kütüphane de kurulu demektir.

Daha fazla yazı tipini destekleyecek şekilde GD yeteneklerini genişletebilirsiniz.

Desteklenen yazı tipi kütüphaneleri
Yazı tipi kütüphanesi | İndirme yeri | Ek bilgiler
FreeType 1.x | » http://www.freetype.org/ | PHP 6.0.0'dan itibaren destek kaldırılmıştır.
FreeType 2 | » http://www.freetype.org/ |
T1lib | » ftp://sunsite.unc.edu/pub/Linux/libs/graphics/) | Postscript Type 1 yazı tipleri desteği.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

GD desteğini etkin kılmak için PHP'yi --with-gd[=DiZiN] seçeneği ile derlemelisiniz; buradaki DiZiN GD'yi kurduğunuz dizindir. GD kütüphanesinin PHP ile dağıtılan sürümünü kullanmak isterseniz (4.3.0 sürümünden beri PHP paketiyle dağıtılmaktadır) PHP'yi --with-gd seçeneğiyle derlemelisiniz. GD kütüphanesi libpng ve libjpeg desteğini gerektirir.

Windows'ta, GD2 DLL php_gd2.dll dosyasını php.ini dosyasında bir eklenti olarak belirtmelisiniz. GD1 DLL php_gd.dll dosyası PHP'nin 4.3.2 sürümünde kaldırılmıştır. imagecreatetruecolor() gibi gerçek renkli resimler GD2 gerektirir.

GD'nin yeteneklerini daha fazla resim biçemi kullanmak üzere genişletmek isterseniz PHP'yi derlemek için yapılandırırken --with-XXXX seçeneklerini kullanınız.

Desteklenen resim biçemleri
Resim Biçemi | Yapılandırma Anahtarı
jpeg-6b | jpeg-6b desteğini etkinleştirmek için --with-jpeg-dir=DiZiN seçeneğini kullanın.
png | PNG desteğini etkinleştirmek için --with-png-dir=DiZiN seçeneğini kullanın. libpng zlib kütüphanesini gerektirdiğinden --with-zlib-dir[=DiZiN] seçeneğine de ihtiyacınız olacaktır.
xpm | XPM desteğini etkinleştirmek için --with-xpm-dir=DiZiN seçeneğini kullanın. Eğer yapılandırma betiği kütüphanelerinizin yerini bulamazsa X11 kütüphanelerinin kurulu olduğu yolu belirtin.

Bilginize: PHP'yi libpng desteği ile derlerken, libpng ile ilintilediğiniz GD sürümünü kullanmalısınız.

GD'nin yeteneklerini farklı yazıtiplerini kullanacak şekilde genişletmek isterseniz kurulum sırasında bunu --with-XXXX yapılandırma seçeneği ile belirtebilirsiniz.

Desteklenen yazıtipi kütüphaneleri
Yazıtipi Kütüphanesi | Yapılandırma Seçeneği
FreeType 1.x | FreeType 1.x desteğini etkinleştirmek için --with-ttf[=DiZiN] seçeneğini kullanın.
FreeType 2 | FreeType 2 desteğini etkinleştirmek için --with-freetype-dir=DiZiN seçeneğini kullanın.
T1lib | T1lib (Postscript Type 1) desteğini etkinleştirmek için --with-t1lib[=DiZiN] seçeneğini kullanın.
Doğal TrueType dizge işlevi | Doğal TrueType dizge işlevi desteğini etkinleştirmek için --enable-gd-native-ttf seçeneğini kullanın.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Resim Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Changelog
gd.jpeg_ignore_warning | "0" | PHP_INI_ALL | PHP 5.1.3'ten beri kullanılabilmektedir.
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

gd.jpeg_ignore_warning bool

jpeg2wbmp() ve imagecreatefromjpeg() tarafından üretilen uyarıları yok saymak için kullanılır.

Ayrıca, exif yapılandırma yönergelerine de bakınız.

Uyarı

Resim işlevleri bellek miktarına çok bağımlıdır. memory_limit yönergesinde yeterince büyük bir bellek miktarı belirtmeyi unutmayın.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Özkaynak Türleri

Bu eklenti iki özkaynak türüne sahiptir: Bir resim tanıtıcısı ve bir yazı tipi tanıtıcısı.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

GD_VERSION (string)
PHP'nin desteklediği GD sürümü. (PHP 5.2.4'ten beri kullanılabilmektedir.)
GD_MAJOR_VERSION (integer)
PHP'nin desteklediği GD ana sürümü. (PHP 5.2.4'ten beri kullanılabilmektedir.)
GD_MINOR_VERSION (integer)
PHP'nin desteklediği GD alt sürümü. (PHP 5.2.4'ten beri kullanılabilmektedir.)
GD_RELEASE_VERSION (integer)
PHP'nin desteklediği GD yama sürümü. (PHP 5.2.4'ten beri kullanılabilmektedir.)
GD_EXTRA_VERSION (string)
PHP'nin desteklediği GD ön (beta/rc) sürümü. (PHP 5.2.4'ten beri kullanılabilmektedir.)
GD_BUNDLED (integer)
PHP ile birlikte gelen GD kullanılmışsa 1, aksi takdirde 0.
IMG_GIF (integer)
imagetypes() işlevi tarafından bir dönüş değeri olarak kullanılır.
IMG_JPG (integer)
imagetypes() işlevi tarafından bir dönüş değeri olarak kullanılır.
IMG_JPEG (integer)
imagetypes() işlevi tarafından bir dönüş değeri olarak kullanılır.

Bilginize:

Bu sabit IMG_JPG ile aynı değere sehiptir.

IMG_PNG (integer)
imagetypes() işlevi tarafından bir dönüş değeri olarak kullanılır.
IMG_WBMP (integer)
imagetypes() işlevi tarafından bir dönüş değeri olarak kullanılır.
IMG_XPM (integer)
imagetypes() işlevi tarafından bir dönüş değeri olarak kullanılır.
IMG_COLOR_TILED (integer)
imagecolorallocate() veya imagecolorallocatealpha() ile ayrılan renk yerine kullanılabilen özel renk seçeneği.
IMG_COLOR_STYLED (integer)
imagecolorallocate() veya imagecolorallocatealpha() ile ayrılan renk yerine kullanılabilen özel renk seçeneği.
IMG_COLOR_BRUSHED (integer)
imagecolorallocate() veya imagecolorallocatealpha() ile ayrılan renk yerine kullanılabilen özel renk seçeneği.
IMG_COLOR_STYLEDBRUSHED (integer)
imagecolorallocate() veya imagecolorallocatealpha() ile ayrılan renk yerine kullanılabilen özel renk seçeneği.
IMG_COLOR_TRANSPARENT (integer)
imagecolorallocate() veya imagecolorallocatealpha() ile ayrılan renk yerine kullanılabilen özel renk seçeneği.
IMG_ARC_ROUNDED (integer)
imagefilledarc() işlevi tarafından kullanılan bir tarz sabiti.

Bilginize:

Bu sabit IMG_ARC_PIE ile aynı değere sahiptir.

IMG_ARC_PIE (integer)
imagefilledarc() işlevi tarafından kullanılan bir tarz sabiti.
IMG_ARC_CHORD (integer)
imagefilledarc() işlevi tarafından kullanılan bir tarz sabiti.
IMG_ARC_NOFILL (integer)
imagefilledarc() işlevi tarafından kullanılan bir tarz sabiti.
IMG_ARC_EDGED (integer)
imagefilledarc() işlevi tarafından kullanılan bir tarz sabiti.
IMG_GD2_RAW (integer)
imagegd2() işlevi tarafından kullanılan bir tarz sabiti.
IMG_GD2_COMPRESSED (integer)
imagegd2() işlevi tarafından kullanılan bir tarz sabiti.
IMG_EFFECT_REPLACE (integer)
imagelayereffect() işlevi tarafından kullanılan alfa harmanlama etkisi.
IMG_EFFECT_ALPHABLEND (integer)
imagelayereffect() işlevi tarafından kullanılan alfa harmanlama etkisi.
IMG_EFFECT_NORMAL (integer)
imagelayereffect() işlevi tarafından kullanılan alfa harmanlama etkisi.
IMG_EFFECT_OVERLAY (integer)
imagelayereffect() işlevi tarafından kullanılan alfa harmanlama etkisi.
IMG_FILTER_NEGATE (integer)
imagefilter() işlevi tarafından kullanılan özel GD süzgeci.
IMG_FILTER_GRAYSCALE (integer)
imagefilter() işlevi tarafından kullanılan özel GD süzgeci.
IMG_FILTER_BRIGHTNESS (integer)
imagefilter() işlevi tarafından kullanılan özel GD süzgeci.
IMG_FILTER_CONTRAST (integer)
imagefilter() işlevi tarafından kullanılan özel GD süzgeci.
IMG_FILTER_COLORIZE (integer)
imagefilter() işlevi tarafından kullanılan özel GD süzgeci.
IMG_FILTER_EDGEDETECT (integer)
imagefilter() işlevi tarafından kullanılan özel GD süzgeci.
IMG_FILTER_GAUSSIAN_BLUR (integer)
imagefilter() işlevi tarafından kullanılan özel GD süzgeci.
IMG_FILTER_SELECTIVE_BLUR (integer)
imagefilter() işlevi tarafından kullanılan özel GD süzgeci.
IMG_FILTER_EMBOSS (integer)
imagefilter() işlevi tarafından kullanılan özel GD süzgeci.
IMG_FILTER_MEAN_REMOVAL (integer)
imagefilter() işlevi tarafından kullanılan özel GD süzgeci.
IMG_FILTER_SMOOTH (integer)
imagefilter() işlevi tarafından kullanılan özel GD süzgeci.
IMG_FILTER_PIXELATE (integer)
imagefilter() işlevi tarafından kullanılan özel GD süzgeci. (PHP 5.3.0'dan beri kullanılabilmektedir.)
IMAGETYPE_GIF (integer)
image_type_to_mime_type() ve image_type_to_extension() işlevleri tarafından kullanılan resim türü sabiti.
IMAGETYPE_JPEG (integer)
image_type_to_mime_type() ve image_type_to_extension() işlevleri tarafından kullanılan resim türü sabiti.
IMAGETYPE_JPEG2000 (integer)
image_type_to_mime_type() ve image_type_to_extension() işlevleri tarafından kullanılan resim türü sabiti.
IMAGETYPE_PNG (integer)
image_type_to_mime_type() ve image_type_to_extension() işlevleri tarafından kullanılan resim türü sabiti.
IMAGETYPE_SWF (integer)
image_type_to_mime_type() ve image_type_to_extension() işlevleri tarafından kullanılan resim türü sabiti.
IMAGETYPE_PSD (integer)
image_type_to_mime_type() ve image_type_to_extension() işlevleri tarafından kullanılan resim türü sabiti.
IMAGETYPE_BMP (integer)
image_type_to_mime_type() ve image_type_to_extension() işlevleri tarafından kullanılan resim türü sabiti.
IMAGETYPE_WBMP (integer)
image_type_to_mime_type() ve image_type_to_extension() işlevleri tarafından kullanılan resim türü sabiti.
IMAGETYPE_XBM (integer)
image_type_to_mime_type() ve image_type_to_extension() işlevleri tarafından kullanılan resim türü sabiti.
IMAGETYPE_TIFF_II (integer)
image_type_to_mime_type() ve image_type_to_extension() işlevleri tarafından kullanılan resim türü sabiti.
IMAGETYPE_TIFF_MM (integer)
image_type_to_mime_type() ve image_type_to_extension() işlevleri tarafından kullanılan resim türü sabiti.
IMAGETYPE_IFF (integer)
image_type_to_mime_type() ve image_type_to_extension() işlevleri tarafından kullanılan resim türü sabiti.
IMAGETYPE_JB2 (integer)
image_type_to_mime_type() ve image_type_to_extension() işlevleri tarafından kullanılan resim türü sabiti.
IMAGETYPE_JPC (integer)
image_type_to_mime_type() ve image_type_to_extension() işlevleri tarafından kullanılan resim türü sabiti.
IMAGETYPE_JP2 (integer)
image_type_to_mime_type() ve image_type_to_extension() işlevleri tarafından kullanılan resim türü sabiti.
IMAGETYPE_JPX (integer)
image_type_to_mime_type() ve image_type_to_extension() işlevleri tarafından kullanılan resim türü sabiti.
IMAGETYPE_SWC (integer)
image_type_to_mime_type() ve image_type_to_extension() işlevleri tarafından kullanılan resim türü sabiti.
IMAGETYPE_ICO (integer)
image_type_to_mime_type() ve image_type_to_extension() işlevleri tarafından kullanılan resim türü sabiti. (PHP 5.3.0'dan beri kullanılabilmektedir.)
PNG_NO_FILTER (integer)
imagepng() işlevi tarafından kullanılan özel bir PNG süzgeci.
PNG_FILTER_NONE (integer)
imagepng() işlevi tarafından kullanılan özel bir PNG süzgeci.
PNG_FILTER_SUB (integer)
imagepng() işlevi tarafından kullanılan özel bir PNG süzgeci.
PNG_FILTER_UP (integer)
imagepng() işlevi tarafından kullanılan özel bir PNG süzgeci.
PNG_FILTER_AVG (integer)
imagepng() işlevi tarafından kullanılan özel bir PNG süzgeci.
PNG_FILTER_PAETH (integer)
imagepng() işlevi tarafından kullanılan özel bir PNG süzgeci.
PNG_ALL_FILTERS (integer)
imagepng() işlevi tarafından kullanılan özel bir PNG süzgeci.
Özkaynak Türleri
Örnekler
GD


Örnekler

İçindekiler

Öntanımlı Sabitler
GD


Örnekler
Örnekler
PHP Manual

Örnek 1 PHP ile PNG oluşturmak

<?php

header("Content-type: image/png");
$string = $_GET['text'];
$foto     = imagecreatefrompng("images/button1.png");
$turuncu = imagecolorallocate($foto, 220, 210, 60);
$px     = (imagesx($foto) - 7.5 * strlen($string)) / 2;
imagestring($foto, 3, $px, 9, $string, $turuncu);
imagepng($foto);
imagedestroy($foto);

?>
Bu örnek bir sayfadan şöyle bir etiketle çağırlabilir: <img src="button.php?text=gönder">. Yukarıdaki button.php betiği bu "gönder" dizgesini alır ve "images/button1.png" resminin üzerine yerleştirip elde edilen resmi çıktılar. Bu yöntem, her düğme için ayrı bir düğme resmi kullanmaktan daha verimlidir. Bu yöntemle düğmeler devingen olarak üretilir.

Örnekler
Örnekler


Örnekler
PHP Manual

Örnek 1 Alfa kanallarını kullanarak resme damga basmak

<?php
// Filigran uygulanacak fotoğrafı ve damgayı yükleyelim.
$damga = imagecreatefrompng('damga.png');
$foto = imagecreatefromjpeg('foto.jpeg');

// Damganın kenar boşluklarını ayarlayıp resmin
// yükseklik ve genişliğini alalım
$sağ_boşluk = 10;
$alt_boşluk = 10;
$sx = imagesx($damga);
$sy = imagesy($damga);

// Damga resmini koordinatları belirterek kenar boşlukları ile
// birlikte fotoğrafın üzerine kopyalayalım.
imagecopy($foto, $damga, imagesx($foto) - $sx - $sağ_boşluk,
                         imagesy($foto) - $sy - $alt_boşluk,
                         0, 0, imagesx($damga), imagesy($damga));

// Sonucu çıktılayıp belleği serbest bırakalım.
header('Content-type: image/png');
imagepng($foto);
imagedestroy($foto);
?>
Telif haklı fotoğraflara ve resimlere bir işaret veya damga basmanın en uygun yolu budur. Damga resminde metin olarak bir alfa kanalının varlığı halinde metne kenar yumuşatma uygulanacağına dikkat edin. Bu, kopyalama sırasında korunur.

Örnekler


GD ve Resim İşlevleri
Örnekler
PHP Manual

Örnek 1 imagecopymerge() kullanarak yarı geçirgen filigran oluşturmak

<?php
// Filigran uygulanacak fotoğrafı ve damgayı yükleyelim.
$foto = imagecreatefromjpeg('foto.jpeg');

// Önce damga resmini GD'yi kullanarak oluşturalım.
$damga = imagecreatetruecolor(100, 70);
imagefilledrectangle($damga, 0, 0, 99, 99, 0x0000FF);
imagefilledrectangle($damga, 9, 9, 90, 60, 0xFFFFFF);
$foto = imagecreatefromjpeg('foto.jpeg');
imagestring($damga, 5, 20, 20, 'libGD', 0x0000FF);
imagestring($damga, 3, 20, 40, '(c) 2007-9', 0x0000FF);

// Damganın kenar boşluklarını ayarlayıp resmin
// yükseklik ve genişliğini alalım
$yan_boşluk = 10;
$alt_boşluk = 10;
$sx = imagesx($damga);
$sy = imagesy($damga);

// %50 şeffaflıkla damgayı fotoğrafa basalım.
imagecopymerge($foto, $damga, imagesx($foto) - $sx - $yan_boşluk,
                              imagesy($foto) - $sy - $alt_boşluk, 0, 0,
                              imagesx($damga), imagesy($damga), 50);

// Sonucu kaydedip belleği serbest bırakalım.
imagepng($foto, 'damgalı_foto.png');
imagedestroy($foto);

?>
Bu örnekte özgün resim ile damgayı birleştirmek için imagecopymerge() işlevi kullanılmıştır. Bu işlevi kullanarak damgamızın ışık geçirgenliğini ayarlayabiliriz. Bu örnekte ışık geçirgenliği (başka bir deyişle şeffaflık) %50 olarak ayarlanmıştır. Uygulamada, kaldırılması zor olduğundan yarı geçirgen filigran olarak telif haklarının korunmasında kullanılır.

GD ve Resim İşlevleri
Örnekler


GD ve Resim İşlevleri

İçindekiler

  • gd_info — Kurulu GD kütüphanesi hakkında bilgi verir
  • getimagesize — Bir resmin boyutlarını döndürür
  • getimagesizefromstring — Get the size of an image from a string
  • image_type_to_extension — Resim türü ile ilgili dosya uzantısını döndürür
  • image_type_to_mime_type — getimagesize, exif_read_data, exif_thumbnail, exif_imagetype ile döndürülen resim türü ile ilgili MIME türünü döndürür
  • image2wbmp — Bir dosyaya veya tarayıcıya bir WBMP resmi çıktılar
  • imageaffine — Return an image containing the affine transformed src image, using an optional clipping area
  • imageaffinematrixconcat — Concatenate two affine transformation matrices
  • imageaffinematrixget — Get an affine transformation matrix
  • imagealphablending — Bir resim için harmanlama kipini etkinleştirir
  • imageantialias — Kenar yumuşatma işlevlerini uygulatır
  • imagearc — Bir yay çizer
  • imagebmp — Output a BMP image to browser or file
  • imagechar — Yatay olarak bir karakter çizer
  • imagecharup — Düşey olarak bir karakter çizer
  • imagecolorallocate — Bir resim için bir renk ayırır
  • imagecolorallocatealpha — Bir resim için alfa kanallı bir renk ayırır
  • imagecolorat — Bir pikselin renk indisini döndürür
  • imagecolorclosest — Belirtilen rengin en yakın benzerinin indisini döndürür
  • imagecolorclosestalpha — Alfası ile birlikte belirtilen rengin en yakın benzerinin renk indisini verir
  • imagecolorclosesthwb — En yakın renk sıcaklığına, beyaz ve siyahlığa sahip renk indisini verir
  • imagecolordeallocate — Bir rengi tanımsız yapar
  • imagecolorexact — Belirtilen rengin indisini döndürür
  • imagecolorexactalpha — Alfası ile birlikte belirtilen rengin indisini verir
  • imagecolormatch — Bir resmin paletli sürümünün renklerini gerçek renkli sürümünün renkleriyle aynı yapar
  • imagecolorresolve — Belirtilen rengin veya en yakın benzerinin indisini döndürür
  • imagecolorresolvealpha — Alfası ile birlikte belirtilen rengin veya en yakın benzerinin renk indisini verir
  • imagecolorset — Bir palet indisi için renk tanımlar
  • imagecolorsforindex — Bir renk indisinin renk bilgisini döndürür
  • imagecolorstotal — Bir resim paletindeki renk sayısını döndürür
  • imagecolortransparent — Bir rengi şeffaflaştırır
  • imageconvolution — Bir konum ve katsayı ile 3x3'lük bir evrişim matrisini uygular
  • imagecopy — Bir resim parçasını kopyalar
  • imagecopymerge — Bir resmi kopyalar ve karıştırır
  • imagecopymergegray — Bir resmi kopyalar ve gri tonlama ile karıştırır
  • imagecopyresampled — Resmin bir parçasını örnekleyerek kopyalar ve boyutlandırır
  • imagecopyresized — Resmin bir parçasını kopyalar ve boyutlandırır
  • imagecreate — Yeni bir paletli resim oluşturur
  • imagecreatefrombmp — Bir dosya veya URL'den yeni bir resim oluşturur.
  • imagecreatefromgd2 — Bir GD2 dosyasından veya URL'sinden yeni bir resim oluşturur
  • imagecreatefromgd2part — Bir GD2 parça dosyasından veya URL'sinden yeni bir resim oluşturur
  • imagecreatefromgd — Bir GD dosyasından veya URL'sinden yeni bir resim oluşturur
  • imagecreatefromgif — Bir dosya veya URL'den yeni bir resim oluşturur.
  • imagecreatefromjpeg — Bir dosya veya URL'den yeni bir resim oluşturur.
  • imagecreatefrompng — Bir dosya veya URL'den yeni bir resim oluşturur.
  • imagecreatefromstring — Belirtilen dizgeden yeni bir resim oluşturur
  • imagecreatefromwbmp — Bir dosya veya URL'den yeni bir resim oluşturur.
  • imagecreatefromwebp — Bir dosya veya URL'den yeni bir resim oluşturur.
  • imagecreatefromxbm — Bir dosya veya URL'den yeni bir resim oluşturur.
  • imagecreatefromxpm — Bir XPM dosyasından veya URL'sinden yeni bir resim oluşturur
  • imagecreatetruecolor — Yeni bir gerçek renkli resim oluşturur
  • imagecrop — Crop an image to the given rectangle
  • imagecropauto — Crop an image automatically using one of the available modes
  • imagedashedline — Kesikli çizgi çizer
  • imagedestroy — Bir resmi bellekten siler
  • imageellipse — Bir elips çizer
  • imagefill — Resmi boyar
  • imagefilledarc — Bir yay çizer ve içini doldurur
  • imagefilledellipse — İçi dolu bir elips çizer
  • imagefilledpolygon — İçi dolu bir çokgen çizer
  • imagefilledrectangle — İçi dolu bir dikdörtgen çizer
  • imagefilltoborder — Belli bir bölgeyi belli bir renge boyar
  • imagefilter — Bir resme bir süzgeç uygular
  • imageflip — Flips an image using a given mode
  • imagefontheight — Yazı tipi yüksekliğini döndürür
  • imagefontwidth — Yazı tipi genişliğini döndürür
  • imageftbbox — Bir FreeType2 yazı tipi ile yazılacak bir metnin çerçevesini hesaplar
  • imagefttext — Bir metni bir resme bir FreeType 2 yazı tipini kullanarak yazar
  • imagegammacorrect — Bir GD resmine gamma düzeltmesi uygular
  • imagegd2 — Tarayıcıya veya bir dosyaya bir GD2 resmi çıktılar
  • imagegd — Tarayıcıya veya bir dosyaya bir GD resmi çıktılar
  • imagegetclip — Get the clipping rectangle
  • imagegif — Bir dosyaya veya tarayıcıya bir GIF resmi çıktılar
  • imagegrabscreen — Ekran görüntüsünü yakalar
  • imagegrabwindow — Bir pencereyi yakalar
  • imageinterlace — Geçişimliliği açıp kapar
  • imageistruecolor — Bir resmin gerçek renkli olup olmadığını bulur
  • imagejpeg — Tarayıcıya veya bir dosyaya bir JPEG resmi çıktılar
  • imagelayereffect — PHP ile gelen libgd'nin katmanlama etkisini kullanmak için alfa harmanlama seçeneğini ayarlar
  • imageline — Bir çizgi çizer
  • imageloadfont — Yeni bir bit eşlemli yazı tipi yükler
  • imageopenpolygon — Draws an open polygon
  • imagepalettecopy — Paleti bir resimden diğerine kopyalar
  • imagepalettetotruecolor — Converts a palette based image to true color
  • imagepng — Tarayıcıya veya bir dosyaya bir PNG resmi çıktılar
  • imagepolygon — Çokgen çizer
  • imagepsbbox — Bir PostScript Type1 yazı tipi ile yazılan bir metnin çerçevesini döndürür
  • imagepsencodefont — Bir yazı tipinin karakter kodlamasını değiştirir
  • imagepsextendfont — Bir PS yazı tipini genişletir veya daraltır
  • imagepsfreefont — Bir PostScript Type 1 yazı tipi tarafından kullanılan belleği serbest bırakır
  • imagepsloadfont — Bir dosyadan bir PostScript Type 1 yazı tipi yükler
  • imagepsslantfont — Bir yazı tipini eğer
  • imagepstext — PostScript Type1 yazı tiplerini kullanarak bir resmin üzerine bir metin çizer
  • imagerectangle — Bir dikdörtgen çizer
  • imageresolution — Get or set the resolution of the image
  • imagerotate — Bir resmi belirtilen açıya göre döndürür
  • imagesavealpha — PNG resimleri kaydederken (tek renkli şeffaflığın tersine) alfa kanalı bilgisinin kaydedilip kaydedilmeyeceğini belirtir
  • imagescale — Scale an image using the given new width and height
  • imagesetbrush — Çizgi çizmek için fırça resmi oluşturur
  • imagesetclip — Set the clipping rectangle
  • imagesetinterpolation — Set the interpolation method
  • imagesetpixel — Bir pikselin rengini değiştirir
  • imagesetstyle — Çizgi tarzını ayarlar
  • imagesetthickness — Çizgi kalınlığını ayarlar
  • imagesettile — Resmi doldurmak için döşemeyi etkin kılar
  • imagestring — Bir dizgeyi yatay olarak yazar
  • imagestringup — Bir dizgeyi 90 derece döndürülmüş olarak yazar
  • imagesx — Resmin genişliğini döndürür
  • imagesy — Resmin yüksekliğini döndürür
  • imagetruecolortopalette — Bir gerçek renkli resmi bir paletli resme dönüştürür
  • imagettfbbox — TrueType yazıtipi kullanılan bir metnin çerçevesini döndürür
  • imagettftext — Metni resme TrueType yazı tipi ile yazar
  • imagetypes — Kurulu PHP'nin desteklediği resim türlerini döndürür
  • imagewbmp — Resmi bir dosyaya veya tarayıcıya çıktılar
  • imagewebp — Output a WebP image to browser or file
  • imagexbm — Bir XBM resmini tarayıcıya veya dosyaya çıktılar
  • iptcembed — İkil IPTC verisini bir JPEG resminin içine gömer
  • iptcparse — Bir ikil IPTC bloğunu tekil etiketlere böler
  • jpeg2wbmp — Bir JPEG dosyasını WBMP dosyasına dönüştürür
  • png2wbmp — Bir PNG dosyasını WBMP dosyasına dönüştürür
gd_info
GD


Kurulu GD kütüphanesi hakkında bilgi verir

GD ve Resim İşlevleri
getimagesize
GD ve Resim İşlevleri
PHP Manual

gd_info

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

gd_info — Kurulu GD kütüphanesi hakkında bilgi verir

Açıklama

array gd_info ( void )

Kurulu GD kütüphanesinin sürümü ve yapabildikleri hakkında bilgi verir.

Dönen Değerler

Bir ilişkisel dizi döner.

gd_info() tarafından döndürülen dizinin elemanları
Öznitelik | Anlamı
GD Version | Kurulu libgd sürümünü içeren string türünde bir değer.
Freetype Support | boolean türünde bir değer. Freetype desteği varsa TRUE.
Freetype Linkage | Freetype desteğinin nasıl sağlandığını açıklayan string türünde bir değer. Olası değerler: 'with freetype' (freetype ile), 'with TTF library' (TTF kütüphanesi ile) ve 'with unknown library' (bilinmeyen bir kütüphane ile). Bu eleman sadece Freetype Support elemanının değeri TRUE ise anlamlıdır.
T1Lib Support | boolean türünde bir değer. T1Lib desteği varsa TRUE.
GIF Read Support | boolean türünde bir değer. GIF resimleri okuma desteği varsa TRUE.
GIF Create Support | boolean türünde bir değer. GIF resimleri oluşturma desteği varsa TRUE.
JPEG Support | boolean türünde bir değer. JPEG desteği varsa TRUE.
PNG Support | boolean türünde bir değer. PNG desteği varsa TRUE.
WBMP Support | boolean türünde bir değer. WBMP desteği varsa TRUE.
XPM Support | boolean türünde bir değer. XPM desteği varsa TRUE.
XBM Support | boolean türünde bir değer. XBM desteği varsa TRUE.
JIS-mapped Japanese Font Support | boolean türünde bir değer. JIS eşlemli Japonca yazı tipi desteği varsa TRUE.

Bilginize:

PHP 5.3.0 öncesinde, JPEG Support özniteliğinin ismi JPG Support idi.

Örnekler

Örnek 1 gd_info() kullanımı

<?php
var_dump(gd_info());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(11) {
  ["GD Version"]=>
  string(27) "bundled (2.0.34 compatible)"
  ["FreeType Support"]=>
  bool(false)
  ["T1Lib Support"]=>
  bool(false)
  ["GIF Read Support"]=>
  bool(true)
  ["GIF Create Support"]=>
  bool(true)
  ["JPEG Support"]=>
  bool(false)
  ["PNG Support"]=>
  bool(true)
  ["WBMP Support"]=>
  bool(true)
  ["XPM Support"]=>
  bool(false)
  ["XBM Support"]=>
  bool(true)
  ["JIS-mapped Japanese Font Support"]=>
  bool(false)
}

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | JPG Support özniteliğinin ismi JPEG Support oldu.

Ayrıca Bakınız

  • imagepng() - Tarayıcıya veya bir dosyaya bir PNG resmi çıktılar
  • imagejpeg() - Tarayıcıya veya bir dosyaya bir JPEG resmi çıktılar
  • imagegif() - Bir dosyaya veya tarayıcıya bir GIF resmi çıktılar
  • imagewbmp() - Resmi bir dosyaya veya tarayıcıya çıktılar
  • imagetypes() - Kurulu PHP'nin desteklediği resim türlerini döndürür

GD ve Resim İşlevleri
getimagesize
GD ve Resim İşlevleri


Bir resmin boyutlarını döndürür

gd_info
getimagesizefromstring
GD ve Resim İşlevleri
PHP Manual

getimagesize

(PHP 4, PHP 5, PHP 7)

getimagesize — Bir resmin boyutlarını döndürür

Açıklama

array getimagesize ( string $dosyaismi [, array &$ekbilgi ] )

getimagesize() işlevi dosya ismiyle belirtilen resmin boyutlarını saptar ve resmin boyutlarından başka resim dosyası biçemini, HTML IMG etiketinin öznitelikleri olarak yükseklik ve genişliği ve resme ilişkin HTTP içerik türünü bir dizi içinde döndürür.

getimagesize() işlevi ayrıca, ekbilgi değiştirgesinde bazı ek bilgiler döndürebilir.

Bilginize: JPC ve JP2 farklı bit derinliğinde bileşenler içerebilirler. Bu durumda, "bits" değeri saptanan en büyük bit derinliğidir. Ayrıca JP2 dosyaları çok sayıda JPEG 2000 kod akımı içerebilir. Bu durumda, getimagesize() işlevi, dosyanın başlığında saptadığı ilk kod akımının değerleriyle döner.

Bilginize: Simge (icon) resimleri hakkında bilgi en yüksek bit derinliğine sahip simgeden elde edilir.

Değiştirgeler

dosyaismi

Hakkında bilgi döndürülecek resmi içeren dosyanın yolu. Burada bir yerel dosya belirtilebileceği gibi (yapılandırma izin veriyorsa) desteklenen akımlardan biri kullanılarak uzak bir dosya da belirtilebilir.

bilgi

İsteğe bağlı bu değiştirge ile resim dosyası hakkında bazı ek bilgiler edinilebilir. Şimdilik, bir ilişkisel dizi olarak farklı JPG APP imleyicileri döndürülmektedir. Bazı programlar bu APP imleyicilerini resme metin bilgisini gömmek için kullanırlar. En çok uygulananı APP13 imleyicisindeki » IPTC bilgisini gömmektir. İkil APP13 imleyicisini okunabilir hale dönüştürebilmek için iptcparse() işlevini kullanabilirsiniz.

Dönen Değerler

7 Elemanlı bir dizi ile döner.

0 ve 1 indisleri sırayla resmin genişliğini ve yüksekliğini içerir.

Bilginize:

Bazı biçemler hiç resim içermeyeceği gibi bazıları da birden fazla resim içerebilir. Bu gibi durumlarda, getimagesize() resim boyutlarını doğru olarak saptayamayabilir ve bu durumda boyutları 0 olarak döndürür.

2 indisinde resmin türünü belirtmek üzere IMAGETYPE_XXX sabitlerinden biri bulunur.

3 indisinde doğrudan IMG etiketinin öznitelikleri olarak kullanılabilecek şekilde, height="yyy" width="xxx" dizgesi bulunur.

mime indisinde resmin MIME türü bulunur. Bu dizge HTTP Content-type başlığında kullanılır:

Örnek 1 - getimagesize() ve MIME türleri

<?php
$boyutlar = getimagesize($filename);
$dt = fopen($filename, "rb");
if ($boyutlar && $dt) {
    header("Content-type: {$boyutlar['mime']}");
    fpassthru($dt);
    exit;
} else {
    // hata
}
?>

channels indisinde RGB resimler için 3, CMYK resimler için 4 değeri bulunur.

bits indisinde renk bit sayısı bulunur.

Bazı resim türleri için channels ve bits değerlerinin varlığı biraz kafa karıştırıcıdır. Örneğin, GIF daima piksel başına 3 kanal kullanır fakat genel bir renk tablosuna sahip canlandırmalı bir GIF için piksel başına bit sayısı hesaplanamaz.

Başarısızlık halinde FALSE döner.

Hatalar/İstisnalar

dosyaismi resmine erişmek imkansızsa veya resim geçersizse getimagesize() E_WARNING seviyesinde bir hata üretir. Okuma hatasında ise E_NOTICE seviyesinde bir hata üretir.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | Simge (icon) desteği eklendi.
5.2.3 | İşlev tarafından üretilen okuma hatalarının seviyesi E_WARNING'ten E_NOTICE indirgendi.
4.3.2 | JPC, JP2, JPX, JB2, XBM ve WBMP için destek eklendi.
4.3.2 | ekbilgi değiştirgesi için JPEG 2000 desteği eklendi.
4.3.0 | bits ve channels indisleri diğer resimler için de kullanılır oldu.
4.3.0 | mime indisi eklendi.
4.3.0 | SWC ve IFF desteği eklendi.
4.2.0 | TIFF desteği eklendi.
4.0.6 | BMP ve PSD desteği eklendi.
4.0.5 | URL desteği eklendi.

Örnekler

Örnek 2 - >getimagesize() dosya örneği

<?php
list($width, $height, $type, $attr) = getimagesize("img/flag.jpg");
echo "<img src=\"img/flag.jpg\" $attr alt=\"getimagesize() örneği\" />";
?>

Örnek 3 - getimagesize (URL)

<?php
$size = getimagesize("http://www.example.com/gifs/logo.gif");

// Dosya ismi boşluk karakteri içeriyorsa düzgün şekilde kodlamak gerekir
$size = getimagesize("http://www.example.com/gifs/lo%20go.gif");

?>

Örnek 4 - IPTC döndüren getimagesize() örneği

<?php
$size = getimagesize("testimg.jpg", $info);
if (isset($info["APP13"])) {
    $iptc = iptcparse($info["APP13"]);
    var_dump($iptc);
}
?>

Notlar

Bilginize:

Bu işlev için GD resim kütüphanesi gerekli değildir.

Ayrıca Bakınız

  • image_type_to_mime_type() - getimagesize, exif_read_data, exif_thumbnail, exif_imagetype ile döndürülen resim türü ile ilgili MIME türünü döndürür
  • exif_imagetype() - Bir resmin türünü saptar
  • exif_read_data() - Bir JPEG veya TIFF resminden EXIF başlıklarını okur
  • exif_thumbnail() - Bir TIFF veya JPEG resminin içinde gömülü küçük örneği döndürür

gd_info
getimagesizefromstring
GD ve Resim İşlevleri


Get the size of an image from a string

getimagesize
image_type_to_extension
GD ve Resim İşlevleri
PHP Manual

getimagesizefromstring

(PHP 5 >= 5.4.0, PHP 7)

getimagesizefromstring — Get the size of an image from a string

Açıklama

array getimagesizefromstring ( string $imagedata [, array &$imageinfo ] )

Identical to getimagesize() except that getimagesizefromstring() accepts a string instead of a file name as the first parameter.

See the getimagesize() documentation for details on how this function works.

Değiştirgeler

imagedata

The image data, as a string.

imageinfo

See getimagesize().

Dönen Değerler

See getimagesize().

Örnekler

Örnek 1 getimagesizefromstring() example

<?php
$img = '/path/to/test.png';

// Open as a file
$size_info1 = getimagesize($img);

// Or open as a string
$data       = file_get_contents($img);
$size_info2 = getimagesizefromstring($data);
?>

Ayrıca Bakınız

  • getimagesize() - Bir resmin boyutlarını döndürür

getimagesize
image_type_to_extension
GD ve Resim İşlevleri


Resim türü ile ilgili dosya uzantısını döndürür

getimagesizefromstring
image_type_to_mime_type
GD ve Resim İşlevleri
PHP Manual

image_type_to_extension

(PHP 5 >= 5.2.0, PHP 7)

image_type_to_extension — Resim türü ile ilgili dosya uzantısını döndürür

Açıklama

string image_type_to_extension ( int $resimtürü [, bool $noktalı ] )

IMAGETYPE_XXX sabiti ile ilgili dosya uzantısını döndürür.

Değiştirgeler

resimtürü

IMAGETYPE_XXX sabitlerinden biri.

notkalı

Uzantıya bir nokta eklenip eklenmeyeceği belirtilir. TRUE öntanımlıdır.

Dönen Değerler

Belirtilen resim türü ile ilgili dosya uzantısını bir dizge olarak döndürür.

Örnekler

Örnek 1 - image_type_to_extension() örneği

<?php
// Boş bir resim oluşturalım
$resim = imagecreatetruecolor(100, 100);

// Resmi kaydedelim
imagepng($resim, './dnm' . image_type_to_extension(IMAGETYPE_PNG));
imagedestroy($resim);
?>

Notlar

Bilginize:

Bu işlev için GD resim kütüphanesi gerekli değildir.

getimagesizefromstring
image_type_to_mime_type
GD ve Resim İşlevleri


getimagesize, exif_read_data, exif_thumbnail, exif_imagetype ile döndürülen resim türü ile ilgili MIME türünü döndürür

image_type_to_extension
image2wbmp
GD ve Resim İşlevleri
PHP Manual

image_type_to_mime_type

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

image_type_to_mime_type — getimagesize, exif_read_data, exif_thumbnail, exif_imagetype ile döndürülen resim türü ile ilgili MIME türünü döndürür

Açıklama

string image_type_to_mime_type ( int $resimtürü )

image_type_to_mime_type() işlevi belirtilen IMAGETYPE_XXX sabiti ile ilişkili MIME türünü döndürür.

Değiştirgeler

resimtürü

IMAGETYPE_XXX sabitlerinden biri.

Dönen Değerler

Dönen değer şunlardan biri olabilir:

Sabitlere göre dönen değerler
resimtürü | Dönen değer
IMAGETYPE_GIF | image/gif
IMAGETYPE_JPEG | image/jpeg
IMAGETYPE_PNG | image/png
IMAGETYPE_SWF | application/x-shockwave-flash
IMAGETYPE_PSD | image/psd
IMAGETYPE_BMP | image/bmp
IMAGETYPE_TIFF_II (intel bayt sırası) | image/tiff
IMAGETYPE_TIFF_MM (motorola bayt sırası) | image/tiff
IMAGETYPE_JPC | application/octet-stream
IMAGETYPE_JP2 | image/jp2
IMAGETYPE_JPX | application/octet-stream
IMAGETYPE_JB2 | application/octet-stream
IMAGETYPE_SWC | application/x-shockwave-flash
IMAGETYPE_IFF | image/iff
IMAGETYPE_WBMP | image/vnd.wap.wbmp
IMAGETYPE_XBM | image/xbm
IMAGETYPE_ICO | image/vnd.microsoft.icon

Örnekler

Örnek 1 - image_type_to_mime_type() örneği

<?php
header("Content-type: " . image_type_to_mime_type(IMAGETYPE_PNG));
?>

Notlar

Bilginize:

Bu işlev için GD resim kütüphanesi gerekli değildir.

Ayrıca Bakınız

  • getimagesize() - Bir resmin boyutlarını döndürür
  • exif_imagetype() - Bir resmin türünü saptar
  • exif_read_data() - Bir JPEG veya TIFF resminden EXIF başlıklarını okur
  • exif_thumbnail() - Bir TIFF veya JPEG resminin içinde gömülü küçük örneği döndürür

image_type_to_extension
image2wbmp
GD ve Resim İşlevleri


Bir dosyaya veya tarayıcıya bir WBMP resmi çıktılar

image_type_to_mime_type
imageaffine
GD ve Resim İşlevleri
PHP Manual

image2wbmp

(PHP 4 >= 4.0.5, PHP 5, PHP 7)

image2wbmp — Bir dosyaya veya tarayıcıya bir WBMP resmi çıktılar

Açıklama

bool image2wbmp ( resource $resim [, string $dosyaismi [, int $eşik ]] )

image2wbmp() işlevi belirtilen resmin WBMP sürümünü tarayıcıya veya belirtilmişse dosyaismi dosyasına çıktılar.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

dosyaismi

Resmin kaydedileceği dosyanın yolu. Verilmezse ham resim akımı doğrudan tarayıcıya gönderilir.

eşik

Eşik değeri; 0-255 aralığında bir değerdir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - image2wbmp() örneği

<?php
$file = 'php.png';
$image = imagecreatefrompng($file);

header('Content-type: ' . image_type_to_mime_type(IMAGETYPE_WBMP));
image2wbmp($image); // doğrudan akımı çıktılıyoruz
imagedestroy($image);
?>

Notlar

Bilginize:

WBMP desteği sadece PHP, GD-1.8 ve sonrası ile derlenmişse etkindir.

Ayrıca Bakınız

  • imagewbmp() - Resmi bir dosyaya veya tarayıcıya çıktılar

image_type_to_mime_type
imageaffine
GD ve Resim İşlevleri


Return an image containing the affine transformed src image, using an optional clipping area

image2wbmp
imageaffinematrixconcat
GD ve Resim İşlevleri
PHP Manual

imageaffine

(PHP 5 >= 5.5.0, PHP 7)

imageaffine — Return an image containing the affine transformed src image, using an optional clipping area

Açıklama

resource imageaffine ( resource $image , array $affine [, array $clip ] )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

affine

Array with keys 0 to 5.

clip

Array with keys "x", "y", "width" and "height".

Dönen Değerler

Return affined image resource on success başarısızlık durumunda FALSE döner.

image2wbmp
imageaffinematrixconcat
GD ve Resim İşlevleri


Concatenate two affine transformation matrices

imageaffine
imageaffinematrixget
GD ve Resim İşlevleri
PHP Manual

imageaffinematrixconcat

(PHP 5 >= 5.5.0, PHP 7)

imageaffinematrixconcat — Concatenate two affine transformation matrices

Açıklama

array imageaffinematrixconcat ( array $m1 , array $m2 )

Returns the concatenation of two affine transformation matrices, what is useful if multiple transformations should be applied to the same image in one go.

Değiştirgeler

m1

An affine transformation matrix (an array with keys 0 to 5 and float values).

m2

An affine transformation matrix (an array with keys 0 to 5 and float values).

Dönen Değerler

An affine transformation matrix (an array with keys 0 to 5 and float values) başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 imageaffinematrixconcat() example

<?php
$m1 = imageaffinematrixget(IMG_AFFINE_TRANSLATE, array('x' = 2, 'y' => 3));
$m2 = imageaffinematrixget(IMG_AFFINE_SCALE, array('x' = 4, 'y' => 5));
$matrix = imageaffinematrixconcat($m1, $m2);
print_r($matrix);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [0] => 4
    [1] => 0
    [2] => 0
    [3] => 5
    [4] => 8
    [5] => 15
)

Ayrıca Bakınız

  • imageaffine() - Return an image containing the affine transformed src image, using an optional clipping area
  • imageaffinematrixget() - Get an affine transformation matrix

imageaffine
imageaffinematrixget
GD ve Resim İşlevleri


Get an affine transformation matrix

imageaffinematrixconcat
imagealphablending
GD ve Resim İşlevleri
PHP Manual

imageaffinematrixget

(PHP 5 >= 5.5.0, PHP 7)

imageaffinematrixget — Get an affine transformation matrix

Açıklama

array imageaffinematrixget ( int $type , mixed $options )

Returns an affine transformation matrix.

Değiştirgeler

type

One of the IMG_AFFINE_* constants.

options

If type is IMG_AFFINE_TRANSLATE or IMG_AFFINE_SCALE, options has to be an array with keys x and y, both having float values.

If type is IMG_AFFINE_ROTATE, IMG_AFFINE_SHEAR_HORIZONTAL or IMG_AFFINE_SHEAR_VERTICAL, options has to be a float specifying the angle.

Dönen Değerler

An affine transformation matrix (an array with keys 0 to 5 and float values) başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 imageaffinematrixget() example

<?php
$matrix = imageaffinematrixget(IMG_AFFINE_TRANSLATE, array('x' = 2, 'y' => 3));
print_r($matrix);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [0] => 1
    [1] => 0
    [2] => 0
    [3] => 1
    [4] => 2
    [5] => 3
)

Ayrıca Bakınız

  • imageaffine() - Return an image containing the affine transformed src image, using an optional clipping area
  • imageaffinematrixconcat() - Concatenate two affine transformation matrices

imageaffinematrixconcat
imagealphablending
GD ve Resim İşlevleri


Bir resim için harmanlama kipini etkinleştirir

imageaffinematrixget
imageantialias
GD ve Resim İşlevleri
PHP Manual

imagealphablending

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

imagealphablending — Bir resim için harmanlama kipini etkinleştirir

Açıklama

bool imagealphablending ( resource $resim , bool $etkin )

imagealphablending() gerçek renkli resimlerde iki farklı çizim kipi kullanımına izin verir. Harmanlama kipinde, tüm çizim işlevlerine rengin alfa kanalı bileşeni sağlanır, örneğin imagesetpixel() işlevi o rengin ne kadar parlak gösterileceğini belirleyebilir. Sonuç olarak GD özdevinimli olarak, rengin çizilmesi sırasında mevcut rengin harmanlanmasını sağlar ve sonucu resimde saklar. Elde edilen piksel mattır. Harmanlamama kipinde alfa kanalı bilgisi piksel çizim rengine aynen kopyalanır. Harmanlama kipi paletli resimler için kullanılamaz.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

etkin

Harmanlama kipinin etkin olup olmayacağı; FALSE öntanımlıdır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - imagealphablending() örneği

<?php
// Bir resim oluşturalım
$im = imagecreatetruecolor(100, 100);

// Alfa harmanlamasını etkin kılalım
imagealphablending($im, true);

// Bir kare çizelim
imagefilledrectangle($im, 30, 30, 70, 70, imagecolorallocate($im, 255, 0, 0));

// Sonucu çıktılıyalım
header('Content-type: image/png');

imagepng($im);
imagedestroy($im);
?>

Notlar

Bilginize: Bu işlev GD'nin 2.0.1 veya sonraki sürümlerini gerektirir (2.0.28 veya sonraki sürümler önerilir).

imageaffinematrixget
imageantialias
GD ve Resim İşlevleri


Kenar yumuşatma işlevlerini uygulatır

imagealphablending
imagearc
GD ve Resim İşlevleri
PHP Manual

imageantialias

(PHP 4 >= 4.3.2, PHP 5, PHP 7)

imageantialias — Kenar yumuşatma işlevlerini uygulatır

Açıklama

bool imageantialias ( resource $resim , bool $etkin )

Hızlı çizilen kenar yumuşatma yöntemlerini çizgiler ve içi boş çokgenler için etkin kılar. Alfa bileşenlerini desteklemez. Doğrudan harmanlama yapar. Sadece gerçek renkli resimlerle çalışır.

Çizgi kalınlığı ve tarzı desteklenmez.

Kenar yumuşatmalı çizim ilkellerinin şeffaf artalanda kullanılmasının sonuçları belirsizdir. Harmanlama yöntemi çizgi rengiyle artalan rengini harmanlar. Alfa bileşen desteğinin yokluğu nedeniyle alfa kenar yumuşatması yapılamaz.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

etkin

Kenar yumuşatma uygulanıp uygulanmayacağı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Kenar yumuşatmalı çizginin normal çizgiyle karşılaştırılması

<?php
// İki resim oluşturalım
$aa = imagecreatetruecolor(400, 100);
$normal = imagecreatetruecolor(200, 100);

// Resmin birinde kenar yumuşatma etkin olsun
imageantialias($aa, true);

// Renkleri ayıralım
$red = imagecolorallocate($normal, 255, 0, 0);
$red_aa = imagecolorallocate($aa, 255, 0, 0);

// Resimlere birer çizgi çizelim
imageline($normal, 0, 0, 200, 100, $red);
imageline($aa, 0, 0, 200, 100, $red_aa);

// İki resmi yanyana bir resme yerleştirelim
// Soldaki kenar yumuşatmalı olsun
imagecopymerge($aa, $normal, 200, 0, 0, 0, 200, 100, 100);

// Resmi çıktılayalım
header('Content-type: image/png');

imagepng($aa);
imagedestroy($aa);
imagedestroy($normal);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Notlar

Bilginize: Bu işlev sadece, PHP, PHP paketinde bulunan GD kütüphanesi ile derlenmişse kullanılabilir.

Ayrıca Bakınız

  • imagecreatetruecolor() - Yeni bir gerçek renkli resim oluşturur

imagealphablending
imagearc
GD ve Resim İşlevleri


Bir yay çizer

imageantialias
imagebmp
GD ve Resim İşlevleri
PHP Manual

imagearc

(PHP 4, PHP 5, PHP 7)

imagearc — Bir yay çizer

Açıklama

bool imagearc ( resource $resim , int $mx , int $my , int $genişlik , int $yükseklik , int $baş , int $son , int $renk )

imagearc() işlevi koordinatları belirtilen çemberin bir yayını çizer.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

mx

Merkezin X konumu.

my

Merkezin Y konumu.

genişlik

Yay genişliği.

yükseklik

Yay yüksekliği.

baş

Derece cinsinden yayın başlangıç açısı.

son

Derece cinsinden yayın bitiş açısı. 0° saat 3 konumu olup yay saat yönünde çizilir.

renk

imagecolorallocate() ile oluşturulan bir renk tanıtıcısı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - imagearc() ile çember çizmek

<?php

// 200*200 bir resim oluşturalım
$img = imagecreatetruecolor(200, 200);

// Bir kaç renk ayıralım
$white = imagecolorallocate($img, 255, 255, 255);
$red   = imagecolorallocate($img, 255,   0,   0);
$green = imagecolorallocate($img,   0, 255,   0);
$blue  = imagecolorallocate($img,   0,   0, 255);

// kafayı çizelim
imagearc($img, 100, 100, 200, 200,  0, 360, $white);
// ağız
imagearc($img, 100, 100, 150, 150, 25, 155, $red);
// gözler
imagearc($img,  60,  75,  50,  50,  0, 360, $green);
imagearc($img, 140,  75,  50,  50,  0, 360, $blue);

// Resmi tarayıcıya gönderelim
header("Content-type: image/png");
imagepng($img);

// Belleği serbest bırakalım
imagedestroy($img);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ayrıca Bakınız

  • imagefilledarc() - Bir yay çizer ve içini doldurur
  • imageellipse() - Bir elips çizer
  • imagefilledellipse() - İçi dolu bir elips çizer

imageantialias
imagebmp
GD ve Resim İşlevleri


Output a BMP image to browser or file

imagearc
imagechar
GD ve Resim İşlevleri
PHP Manual

imagebmp

(PHP 7 >= 7.2.0)

imagebmp — Output a BMP image to browser or file

Açıklama

bool imagebmp ( resource $image , mixed $to [, bool $compressed = TRUE ] )

Outputs or saves a BMP version of the given image.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

to

Dosyanın kaydedileceği yer. NULL atanırsa dosyanın içeriği çıktılanır.

compressed

Whether the BMP should be compressed with run-length encoding (RLE), or not.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Saving a BMP file

<?php
// Create a blank image and add some text
$im = imagecreatetruecolor(120, 20);
$text_color = imagecolorallocate($im, 233, 14, 91);

imagestring($im, 1, 5, 5,  'BMP with PHP', $text_color);

// Save the image
imagebmp($im, 'php.bmp');

// Free up memory
imagedestroy($im);
?>

imagearc
imagechar
GD ve Resim İşlevleri


Yatay olarak bir karakter çizer

imagebmp
imagecharup
GD ve Resim İşlevleri
PHP Manual

imagechar

(PHP 4, PHP 5, PHP 7)

imagechar — Yatay olarak bir karakter çizer

Açıklama

bool imagechar ( resource $resim , int $yazıtipi , int $x , int $y , string $karakter , int $renk )

imagechar() işlevi karakter dizgesinin ilk karakterini resim ile belirtilen resmin üst sol x,y konumuna (resmin üst sol köşesi 0,0'dır) renk renginde çizer.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

yazıtipi

Belirtilecek değer, Latin2 kodlamalı yerleşik yazı tipleri için 1, 2, 3, 4, 5 (daha büyük numara daha yüksek yazı tipine karşılıktır) veya imageloadfont() ile tanımlanmış kendi yazı tipi betimleyicilerinizden biri olabilir.

x

Başlangıç X koordinatı.

y

Başlangıç Y koordinatı.

karakter

Çizilecek karakter.

renk

imagecolorallocate() ile oluşturulmuş bir rengin tanıtıcısı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - imagechar() örneği

<?php

$im = imagecreate(100, 100);

$dizge = 'PHP';

$artalan = imagecolorallocate($im, 255, 255, 255);
$siyah = imagecolorallocate($im, 0, 0, 0);

// Üst sol köşeye siyah bir "P" basalım
imagechar($im, 1, 0, 0, $dizge, $siyah);

header('Content-type: image/png');
imagepng($im);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ayrıca Bakınız

  • imagecharup() - Düşey olarak bir karakter çizer
  • imageloadfont() - Yeni bir bit eşlemli yazı tipi yükler

imagebmp
imagecharup
GD ve Resim İşlevleri


Düşey olarak bir karakter çizer

imagechar
imagecolorallocate
GD ve Resim İşlevleri
PHP Manual

imagecharup

(PHP 4, PHP 5, PHP 7)

imagecharup — Düşey olarak bir karakter çizer

Açıklama

bool imagecharup ( resource $image , int $font , int $x , int $y , string $c , int $color )

imagecharup() işlevi karakter dizgesinin ilk karakterini resim ile belirtilen resmin üst sol x,y konumuna (resmin üst sol köşesi 0,0'dır) renk renginde aşağıdan yukarıya doğru dikine çizer.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

yazıtipi

Belirtilecek değer, Latin2 kodlamalı yerleşik yazı tipleri için 1, 2, 3, 4, 5 (daha büyük numara daha yüksek yazı tipine karşılıktır) veya imageloadfont() ile tanımlanmış kendi yazı tipi betimleyicilerinizden biri olabilir.

x

Başlangıç X koordinatı.

y

Başlangıç Y koordinatı.

karakter

Çizilecek karakter.

renk

imagecolorallocate() ile oluşturulmuş bir rengin tanıtıcısı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - imagecharup() örneği

<?php

$im = imagecreate(100, 100);

$string = 'Neden ilk harf Z olmasın';

$bg = imagecolorallocate($im, 255, 255, 255);
$black = imagecolorallocate($im, 0, 0, 0);

// Beyaz artalana siyah bir "Z" basalım
imagecharup($im, 3, 10, 10, $string, $black);

header('Content-type: image/png');
imagepng($im);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ayrıca Bakınız

  • imagechar() - Yatay olarak bir karakter çizer
  • imageloadfont() - Yeni bir bit eşlemli yazı tipi yükler

imagechar
imagecolorallocate
GD ve Resim İşlevleri


Bir resim için bir renk ayırır

imagecharup
imagecolorallocatealpha
GD ve Resim İşlevleri
PHP Manual

imagecolorallocate

(PHP 4, PHP 5, PHP 7)

imagecolorallocate — Bir resim için bir renk ayırır

Açıklama

int imagecolorallocate ( resource $resim , int $kırmızı , int $yeşil , int $mavi )

Belirtilen renk bileşenleriyle oluşturulan renk için bir renk tanıtıcısı döndürür.

imagecolorallocate() işlevi resim'de bulunan her renk için ayrı ayrı çağırmalıdır.

Bilginize:

İlk imagecolorallocate() çağrısı, imagecreate() ile oluşturulmuş paletli resmin artalanını boyar.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

kırmızı

Rengin kırmızı bileşeninin değeri.

yeşil

Rengin yeşil bileşeninin değeri.

mavi

Rengin mavi bileşeninin değeri.

Renk bileşenlerinin değerleri onluk tabanda 0-255 aralığında, onaltılık tabanda 0x00-0xFF aralığında belirtilebilir.

Dönen Değerler

Renk ayrılamamışsa FALSE, aksi takdirde renk inidisi ile döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.3 öncesi | Renk ayrılamamışsa -1 döner.

Örnekler

Örnek 1 - imagecolorallocate() örneği

<?php

$im = imagecreate(100, 100);

// Artalan rengi kırmızı olsun
$artalan = imagecolorallocate($im, 255, 0, 0);

// Bir kaç renk ayıralım
$beyaz = imagecolorallocate($im, 255, 255, 255);
$siyah = imagecolorallocate($im, 0, 0, 0);

// Onaltılık değerlerle
$beyaz = imagecolorallocate($im, 0xFF, 0xFF, 0xFF);
$siyah = imagecolorallocate($im, 0x00, 0x00, 0x00);

?>

Ayrıca Bakınız

  • imagecolorallocatealpha() - Bir resim için alfa kanallı bir renk ayırır
  • imagecolordeallocate() - Bir rengi tanımsız yapar

imagecharup
imagecolorallocatealpha
GD ve Resim İşlevleri


Bir resim için alfa kanallı bir renk ayırır

imagecolorallocate
imagecolorat
GD ve Resim İşlevleri
PHP Manual

imagecolorallocatealpha

(PHP 4 >= 4.3.2, PHP 5, PHP 7)

imagecolorallocatealpha — Bir resim için alfa kanallı bir renk ayırır

Açıklama

int imagecolorallocatealpha ( resource $resim , int $kırmızı , int $yeşil , int $mavi , int $alfa )

imagecolorallocatealpha() işlevi alfa değiştirgesi ile ek olarak şeffaflık belirtilebilmesi dışında imagecolorallocate() işlevine eşdeğerdir.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

kırmızı

Rengin kırmızı bileşeninin değeri.

yeşil

Rengin yeşil bileşeninin değeri.

mavi

Rengin mavi bileşeninin değeri.

alfa

0-127 arasında belirtilebilir. 0 tamamen mat, 127 ise tamamen şeffaf demektir.

Renk bileşenlerinin değerleri onluk tabanda 0-255 aralığında, onaltılık tabanda 0x00-0xFF aralığında belirtilebilir.

Dönen Değerler

Renk ayrılamazsa FALSE, aksi takdirde rengin indisini döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.3 öncesi | Renk ayrılamazsa -1 döner.

Örnekler

Örnek 1 - imagecolorallocatealpha() örneği

<?php
$size = 300;
$image=imagecreatetruecolor($size, $size);

// Siyah kenar çizgili beyaz artalan
$back = imagecolorallocate($image, 255, 255, 255);
$border = imagecolorallocate($image, 0, 0, 0);
imagefilledrectangle($image, 0, 0, $size - 1, $size - 1, $back);
imagerectangle($image, 0, 0, $size - 1, $size - 1, $border);

$yellow_x = 100;
$yellow_y = 75;
$red_x    = 120;
$red_y    = 165;
$blue_x   = 187;
$blue_y   = 125;
$radius   = 150;

// Renkleri alfa değerleriyle ayıralım
$yellow = imagecolorallocatealpha($image, 255, 255, 0, 75);
$red    = imagecolorallocatealpha($image, 255, 0, 0, 75);
$blue   = imagecolorallocatealpha($image, 0, 0, 255, 75);

// Üst üste üç elips çizelim
imagefilledellipse($image, $yellow_x, $yellow_y, $radius, $radius, $yellow);
imagefilledellipse($image, $red_x, $red_y, $radius, $radius, $red);
imagefilledellipse($image, $blue_x, $blue_y, $radius, $radius, $blue);

// Başlığı çıktılamayı unutmuyoruz!
header('Content-type: image/png');

// ve sonucu çıktılıyoruz
imagepng($image);
imagedestroy($image);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Notlar

Bilginize: Bu işlev GD'nin 2.0.1 veya sonraki sürümlerini gerektirir (2.0.28 veya sonraki sürümler önerilir).

Ayrıca Bakınız

  • imagecolorallocate() - Bir resim için bir renk ayırır
  • imagecolordeallocate() - Bir rengi tanımsız yapar

imagecolorallocate
imagecolorat
GD ve Resim İşlevleri


Bir pikselin renk indisini döndürür

imagecolorallocatealpha
imagecolorclosest
GD ve Resim İşlevleri
PHP Manual

imagecolorat

(PHP 4, PHP 5, PHP 7)

imagecolorat — Bir pikselin renk indisini döndürür

Açıklama

int imagecolorat ( resource $resim , int $x , int $y )

resim ile belirtilen resmin belirtilen koordinatlardaki pikselinin renk indisini döndürür.

PHP, GD kütüphanesinin 2.0 veya üstü sürümlerinden biriyle derlenmişse ve resim gerçek renkliyse bu işlev pikselin RGB değerini bir tamsayı olarak döndürür. Kırmızı, yeşil ve mavi bileşenlerin değerlerini elde etmek için bu değere bit maskesi ve bit kaydırma uygulamak gerekir.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

x

Pikselin X konumu.

y

Pikselin Y konumu.

Dönen Değerler

Renk indisini döndürür.

Örnekler

Örnek 1 - Hesapla RGB değeri bileşenlerine ayırmak

<?php
$im = imagecreatefrompng("php.png");
$rgb = imagecolorat($im, 10, 15);
$r = ($rgb >> 16) & 0xFF;
$g = ($rgb >> 8) & 0xFF;
$b = $rgb & 0xFF;

var_dump($r, $g, $b);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(119)
int(123)
int(180)

Örnek 2 - imagecolorsforindex() ile RGB değeri bileşenlerine ayırmak

<?php
$im = imagecreatefrompng("php.png");
$rgb = imagecolorat($im, 10, 15);

$colors = imagecolorsforindex($im, $rgb);

var_dump($colors);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(4) {
  ["red"]=>
  int(119)
  ["green"]=>
  int(123)
  ["blue"]=>
  int(180)
  ["alpha"]=>
  int(127)
}

Ayrıca Bakınız

  • imagecolorset() - Bir palet indisi için renk tanımlar
  • imagecolorsforindex() - Bir renk indisinin renk bilgisini döndürür

imagecolorallocatealpha
imagecolorclosest
GD ve Resim İşlevleri


Belirtilen rengin en yakın benzerinin indisini döndürür

imagecolorat
imagecolorclosestalpha
GD ve Resim İşlevleri
PHP Manual

imagecolorclosest

(PHP 4, PHP 5, PHP 7)

imagecolorclosest — Belirtilen rengin en yakın benzerinin indisini döndürür

Açıklama

int imagecolorclosest ( resource $resim , int $kırmızı , int $yeşil , int $mavi )

Bu işlev, bileşenleri belirtilen rengin en yakın benzerinin indisini döndürür.

İstenen renk ile paletteki renk arasındaki "mesafe" rengin bileşenlerinden oluşan üç boyutlu uzayda hesaplanır.

Eğer resmi bir dosyadan oluşturmuşsanız sadece resimde kullanılan renkler çözümlenir. Palette bulunan renklerden resimde kullanılmamış olanlar çözümlenmez.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

kırmızı

Rengin kırmızı bileşeninin değeri.

yeşil

Rengin yeşil bileşeninin değeri.

mavi

Rengin mavi bileşeninin değeri.

Renk bileşenlerinin değerleri onluk tabanda 0-255 aralığında, onaltılık tabanda 0x00-0xFF aralığında belirtilebilir.

Dönen Değerler

Paletteki en yakın rengin indisi döner.

Örnekler

Örnek 1 - Bir resimde renk aramak

<?php
// Bir resim açıp paletli resme dönüştürelim
$im = imagecreatefrompng('figures/imagecolorclosest.png');
imagetruecolortopalette($im, false, 255);

// Aranacak renkler (RGB)
$colors = array(
    array(254, 145, 154),
    array(153, 145, 188),
    array(153, 90, 145),
    array(255, 137, 92)
);

// Renkleri bulmak için bir döngü kuralım.
// En yakın rengin indisini alıp o indisin rengini öğrenelim
foreach($colors as $id => $rgb)
{
    $res = imagecolorclosest($im, $rgb[0], $rgb[1], $rgb[2]);
    $res = imagecolorsforindex($im, $res);
    $res = "({$res['red']}, {$res['green']}, {$res['blue']}, {$res['alpha']})";

    echo "#$id: Aranan ($rgb[0], $rgb[1], $rgb[2], $rgb[3]); En yakın $res.\n";
}

imagedestroy($im);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

#0: Aranan (254, 145, 154); En yakın (252, 150, 148).
#1: Aranan (153, 145, 188); En yakın (148, 150, 196).
#2: Aranan (153, 90, 145); En yakın (148, 90, 156).
#3: Aranan (255, 137, 92); En yakın (252, 150, 92).

Ayrıca Bakınız

  • imagecolorexact() - Belirtilen rengin indisini döndürür
  • imagecolorclosestalpha() - Alfası ile birlikte belirtilen rengin en yakın benzerinin renk indisini verir
  • imagecolorclosesthwb() - En yakın renk sıcaklığına, beyaz ve siyahlığa sahip renk indisini verir

imagecolorat
imagecolorclosestalpha
GD ve Resim İşlevleri


Alfası ile birlikte belirtilen rengin en yakın benzerinin renk indisini verir

imagecolorclosest
imagecolorclosesthwb
GD ve Resim İşlevleri
PHP Manual

imagecolorclosestalpha

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

imagecolorclosestalpha — Alfası ile birlikte belirtilen rengin en yakın benzerinin renk indisini verir

Açıklama

int imagecolorclosestalpha ( resource $resim , int $kırmızı , int $yeşil , int $mavi , int $alfa )

Bu işlev, alfası ile birlikte belirtilen rengin paletli resimdeki en yakın benzerinin indisini döndürür.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

kırmızı

Rengin kırmızı bileşeninin değeri.

yeşil

Rengin yeşil bileşeninin değeri.

mavi

Rengin mavi bileşeninin değeri.

alfa

0-127 arasında belirtilebilir. 0 tamamen mat, 127 ise tamamen şeffaf demektir.

Renk bileşenlerinin değerleri onluk tabanda 0-255 aralığında, onaltılık tabanda 0x00-0xFF aralığında belirtilebilir.

Dönen Değerler

Paletteki en yakın rengin indisi döner.

Örnekler

Örnek 1 - Bir resimde renk aramak

<?php
// Bir resim açıp paletli resme dönüştürelim
$im = imagecreatefrompng('figures/imagecolorclosest.png');
imagetruecolortopalette($im, false, 255);

// Aranacak renkler (RGB)
$colors = array(
    array(254, 145, 154, 50),
    array(153, 145, 188, 127),
    array(153, 90, 145, 0),
    array(255, 137, 92, 84)
);

// Renkleri bulmak için bir döngü kuralım.
// En yakın rengin indisini alıp o indisin rengini öğrenelim
foreach($colors as $id => $rgb)
{
    $res = imagecolorclosestalpha($im, $rgb[0], $rgb[1], $rgb[2], $rgb[3]);
    $res = imagecolorsforindex($im, $res);
    $res = "({$res['red']}, {$res['green']}, {$res['blue']}, {$res['alpha']})";

    echo "#$id: Aranan ($rgb[0], $rgb[1], $rgb[2], $rgb[3]); En yakın $res.\n";
}

imagedestroy($im);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

#0: Aranan (254, 145, 154, 50); En yakın (252, 150, 148, 0).
#1: Aranan (153, 145, 188, 127); En yakın (148, 150, 196, 0).
#2: Aranan (153, 90, 145, 0); En yakın (148, 90, 156, 0).
#3: Aranan (255, 137, 92, 84); En yakın (252, 150, 92, 0).

Notlar

Bilginize: Bu işlev GD'nin 2.0.1 veya sonraki sürümlerini gerektirir (2.0.28 veya sonraki sürümler önerilir).

Ayrıca Bakınız

  • imagecolorexactalpha() - Alfası ile birlikte belirtilen rengin indisini verir
  • imagecolorclosest() - Belirtilen rengin en yakın benzerinin indisini döndürür
  • imagecolorclosesthwb() - En yakın renk sıcaklığına, beyaz ve siyahlığa sahip renk indisini verir

imagecolorclosest
imagecolorclosesthwb
GD ve Resim İşlevleri


En yakın renk sıcaklığına, beyaz ve siyahlığa sahip renk indisini verir

imagecolorclosestalpha
imagecolordeallocate
GD ve Resim İşlevleri
PHP Manual

imagecolorclosesthwb

(PHP 4 >= 4.0.1, PHP 5, PHP 7)

imagecolorclosesthwb — En yakın renk sıcaklığına, beyaz ve siyahlığa sahip renk indisini verir

Açıklama

int imagecolorclosesthwb ( resource $resim , int $kırmızı , int $yeşil , int $mavi )

Belirtilen resimdeki belirtilen renge en yakın renk sıcaklığına, beyaz ve siyahlığa sahip renk indisini döndürür.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

kırmızı

Rengin kırmızı bileşeninin değeri.

yeşil

Rengin yeşil bileşeninin değeri.

mavi

Rengin mavi bileşeninin değeri.

Dönen Değerler

En yakın renk sıcaklığına, beyaz ve siyahlığa sahip renk indisini döndürür.

Örnekler

Örnek 1 - imagecolorclosesthwb() örneği

<?php
$im = imagecreatefromgif('php.gif');

echo 'HWB: ' . imagecolorclosesthwb($im, 116, 115, 152);

imagedestroy($im);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

HWB: 33

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | Bu işlev artık Windows'ta da kullanılabilmektedir.

Ayrıca Bakınız

  • imagecolorclosest() - Belirtilen rengin en yakın benzerinin indisini döndürür

imagecolorclosestalpha
imagecolordeallocate
GD ve Resim İşlevleri


Bir rengi tanımsız yapar

imagecolorclosesthwb
imagecolorexact
GD ve Resim İşlevleri
PHP Manual

imagecolordeallocate

(PHP 4, PHP 5, PHP 7)

imagecolordeallocate — Bir rengi tanımsız yapar

Açıklama

bool imagecolordeallocate ( resource $resim , int $renk )

imagecolorallocate() veya imagecolorallocatealpha() ile tanımlanmış bir rengin tanıtıcısını siler.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

renk

Renk tanıtıcısı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - imagecolordeallocate() örneği

<?php
$beyaz = imagecolorallocate($im, 255, 255, 255);
imagecolordeallocate($im, $beyaz);
?>

Ayrıca Bakınız

  • imagecolorallocate() - Bir resim için bir renk ayırır
  • imagecolorallocatealpha() - Bir resim için alfa kanallı bir renk ayırır

imagecolorclosesthwb
imagecolorexact
GD ve Resim İşlevleri


Belirtilen rengin indisini döndürür

imagecolordeallocate
imagecolorexactalpha
GD ve Resim İşlevleri
PHP Manual

imagecolorexact

(PHP 4, PHP 5, PHP 7)

imagecolorexact — Belirtilen rengin indisini döndürür

Açıklama

int imagecolorexact ( resource $resim , int $kırmızı , int $yeşil , int $mavi )

Paletli bir resimden belirtilen rengin indisini döndürür.

Eğer resmi bir dosyadan oluşturmuşsanız sadece resimde kullanılan renkler çözümlenir. Palette bulunan renklerden resimde kullanılmamış olanlar çözümlenmez.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

kırmızı

Rengin kırmızı bileşeninin değeri.

yeşil

Rengin yeşil bileşeninin değeri.

mavi

Rengin mavi bileşeninin değeri.

Dönen Değerler

Renk palette mevcut değilse -1, aksi takdirde rengin indisini döndürür.

Örnekler

Örnek 1 - GD logosunun renklerini öğrenelim

<?php
// Resmi belirtelim
$im = imagecreatefrompng('./gdlogo.png');

$colors   = Array();
$colors[] = imagecolorexact($im, 255, 0, 0);
$colors[] = imagecolorexact($im, 0, 0, 0);
$colors[] = imagecolorexact($im, 255, 255, 255);
$colors[] = imagecolorexact($im, 100, 255, 52);

print_r($colors);

// Belleği serbest bırakalım
imagedestroy($im);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [0] => 16711680
    [1] => 0
    [2] => 16777215
    [3] => 6618932
)

Ayrıca Bakınız

  • imagecolorclosest() - Belirtilen rengin en yakın benzerinin indisini döndürür

imagecolordeallocate
imagecolorexactalpha
GD ve Resim İşlevleri


Alfası ile birlikte belirtilen rengin indisini verir

imagecolorexact
imagecolormatch
GD ve Resim İşlevleri
PHP Manual

imagecolorexactalpha

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

imagecolorexactalpha — Alfası ile birlikte belirtilen rengin indisini verir

Açıklama

int imagecolorexactalpha ( resource $resim , int $kırmızı , int $yeşil , int $mavi , int $alfa )

Bu işlev, alfası ile birlikte belirtilen rengin paletli resimdeki en yakın benzerinin indisini döndürür.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

kırmızı

Rengin kırmızı bileşeninin değeri.

yeşil

Rengin yeşil bileşeninin değeri.

mavi

Rengin mavi bileşeninin değeri.

alfa

0-127 arasında belirtilebilir. 0 tamamen mat, 127 ise tamamen şeffaf demektir.

Renk bileşenlerinin değerleri onluk tabanda 0-255 aralığında, onaltılık tabanda 0x00-0xFF aralığında belirtilebilir.

Dönen Değerler

Renk palette mevcut değilse -1, aksi takdirde rengin indisini döndürür.

Örnekler

Örnek 1 - GD logosunun renklerini öğrenelim

<?php

// Resmi belirtelim
$im = imagecreatefrompng('./gdlogo.png');

$colors   = Array();
$colors[] = imagecolorexactalpha($im, 255, 0, 0, 0);
$colors[] = imagecolorexactalpha($im, 0, 0, 0, 127);
$colors[] = imagecolorexactalpha($im, 255, 255, 255, 55);
$colors[] = imagecolorexactalpha($im, 100, 255, 52, 20);

print_r($colors);

// Belleği serbest bırakalım
imagedestroy($im);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [0] => 16711680
    [1] => 2130706432
    [2] => 939524095
    [3] => 342163252
)

Notlar

Bilginize: Bu işlev GD'nin 2.0.1 veya sonraki sürümlerini gerektirir (2.0.28 veya sonraki sürümler önerilir).

Ayrıca Bakınız

  • imagecolorclosestalpha() - Alfası ile birlikte belirtilen rengin en yakın benzerinin renk indisini verir

imagecolorexact
imagecolormatch
GD ve Resim İşlevleri


Bir resmin paletli sürümünün renklerini gerçek renkli sürümünün renkleriyle aynı yapar

imagecolorexactalpha
imagecolorresolve
GD ve Resim İşlevleri
PHP Manual

imagecolormatch

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

imagecolormatch — Bir resmin paletli sürümünün renklerini gerçek renkli sürümünün renkleriyle aynı yapar

Açıklama

bool imagecolormatch ( resource $resim1 , resource $resim2 )

Bir resmin paletli sürümünün renklerini gerçek renkli sürümünün renkleriyle aynı yapar.

Değiştirgeler

resim1

Resmin gerçek renkli sürümünün tanıtıcısı.

resim2

Renkleri resim1 ile aynı yapılacak paletli sürümün tanıtıcısı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - imagecolormatch() örneği

<?php
// Gerçek renkli ve paletli resimleri belirtelim
$im1 = imagecreatefrompng('./gdlogo.png');
$im2 = imagecreate(imagesx($im1), imagesy($im1));

// $im2'ye bir kaç renk ekleyelim
$colors   = Array();
$colors[] = imagecolorallocate($im2, 255, 36, 74);
$colors[] = imagecolorallocate($im2, 40, 0, 240);
$colors[] = imagecolorallocate($im2, 82, 100, 255);
$colors[] = imagecolorallocate($im2, 84, 63, 44);

// Bu renkleri gerçek renkli resimden güncelleyelim
imagecolormatch($im1, $im2);

// Belleği serbest bırakalım
imagedestroy($im1);
imagedestroy($im2);
?>

Notlar

Bilginize: Bu işlev sadece, PHP, PHP paketinde bulunan GD kütüphanesi ile derlenmişse kullanılabilir.

Bilginize: Bu işlev GD'nin 2.0.1 veya sonraki sürümlerini gerektirir (2.0.28 veya sonraki sürümler önerilir).

Ayrıca Bakınız

  • imagecreatetruecolor() - Yeni bir gerçek renkli resim oluşturur

imagecolorexactalpha
imagecolorresolve
GD ve Resim İşlevleri


Belirtilen rengin veya en yakın benzerinin indisini döndürür

imagecolormatch
imagecolorresolvealpha
GD ve Resim İşlevleri
PHP Manual

imagecolorresolve

(PHP 4, PHP 5, PHP 7)

imagecolorresolve — Belirtilen rengin veya en yakın benzerinin indisini döndürür

Açıklama

int imagecolorresolve ( resource $resim , int $kırmızı , int $yeşil , int $mavi )

Bu işlev, belirtilen rengin kendisinin veya en yakın benzerinin indisini döndürür.

Eğer resmi bir dosyadan oluşturmuşsanız sadece resimde kullanılan renkler çözümlenir. Palette bulunan renklerden resimde kullanılmamış olanlar çözümlenmez.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

kırmızı

Rengin kırmızı bileşeninin değeri.

yeşil

Rengin yeşil bileşeninin değeri.

mavi

Rengin mavi bileşeninin değeri.

Dönen Değerler

Bir renk indisi döndürür.

Örnekler

Örnek 1 - Bir resimdeki renkleri öğrenmek için imagecoloresolve() kullanımı

<?php
// Bir resim yükleyelim
$im = imagecreatefromgif('http://docs.php.net/images/php.gif');

// Resimden en yakın renkleri alalım
$colors = array();
$colors[] = imagecolorresolve($im, 255, 255, 255, 0);
$colors[] = imagecolorresolve($im, 0, 0, 200, 127);

// Sonucu çıktılayalım
print_r($colors);

imagedestroy($im);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [0] => 89
    [1] => 85
)

Ayrıca Bakınız

  • imagecolorclosest() - Belirtilen rengin en yakın benzerinin indisini döndürür

imagecolormatch
imagecolorresolvealpha
GD ve Resim İşlevleri


Alfası ile birlikte belirtilen rengin veya en yakın benzerinin renk indisini verir

imagecolorresolve
imagecolorset
GD ve Resim İşlevleri
PHP Manual

imagecolorresolvealpha

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

imagecolorresolvealpha — Alfası ile birlikte belirtilen rengin veya en yakın benzerinin renk indisini verir

Açıklama

int imagecolorresolvealpha ( resource $resim , int $kırmızı , int $yeşil , int $mavi , int $alfa )

Bu işlev, alfası ile birlikte belirtilen rengin kendisinin veya en yakın benzerinin indisini döndürür.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

kırmızı

Rengin kırmızı bileşeninin değeri.

yeşil

Rengin yeşil bileşeninin değeri.

mavi

Rengin mavi bileşeninin değeri.

alfa

0-127 arasında belirtilebilir. 0 tamamen mat, 127 ise tamamen şeffaf demektir.

Renk bileşenlerinin değerleri onluk tabanda 0-255 aralığında, onaltılık tabanda 0x00-0xFF aralığında belirtilebilir.

Dönen Değerler

Bir renk indisi döner.

Örnekler

Örnek 1 - Bir resimdeki renkleri öğrenmek için imagecolorresolvealpha() kullanımı

<?php
// Bir resim yükleyelim
$im = imagecreatefromgif('http://docs.php.net/images/php.gif');

// Resimden en yakın rengi alalım
$colors = array();
$colors[] = imagecolorresolvealpha($im, 255, 255, 255, 0);
$colors[] = imagecolorresolvealpha($im, 0, 0, 200, 127);

// Output
print_r($colors);

imagedestroy($im);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [0] => 89
    [1] => 85
)

Notlar

Bilginize: Bu işlev GD'nin 2.0.1 veya sonraki sürümlerini gerektirir (2.0.28 veya sonraki sürümler önerilir).

Ayrıca Bakınız

  • imagecolorclosestalpha() - Alfası ile birlikte belirtilen rengin en yakın benzerinin renk indisini verir

imagecolorresolve
imagecolorset
GD ve Resim İşlevleri


Bir palet indisi için renk tanımlar

imagecolorresolvealpha
imagecolorsforindex
GD ve Resim İşlevleri
PHP Manual

imagecolorset

(PHP 4, PHP 5, PHP 7)

imagecolorset — Bir palet indisi için renk tanımlar

Açıklama

void imagecolorset ( resource $resim , int $indis , int $kırmızı , int $yeşil , int $mavi )

Belirtilen palet indisine belirtilen rengi tanımlar. Bir paletli resmin renklerini boyama işlevlerini kullanmadan değiştirmek için yararlıdır.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

indis

Palet içinde bir indis.

kırmızı

Rengin kırmızı bileşeninin değeri.

yeşil

Rengin yeşil bileşeninin değeri.

mavi

Rengin mavi bileşeninin değeri.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 - imagecolorset() örneği

<?php
// 300x100 bir resim oluşturalım
$im = imagecreate(300, 100);

// Artalan rengi kırmızı olsun
imagecolorallocate($im, 255, 0, 0);

// Artalan renginin indisini alalım
$bg = imagecolorat($im, 0, 0);

// Artalan rengini mavi yapalım
imagecolorset($im, $bg, 0, 0, 255);

// Resmi tarayıcıya gönderelim
//header('Content-type: image/png');

imagepng($im);
imagedestroy($im);
?>

Ayrıca Bakınız

  • imagecolorat() - Bir pikselin renk indisini döndürür

imagecolorresolvealpha
imagecolorsforindex
GD ve Resim İşlevleri


Bir renk indisinin renk bilgisini döndürür

imagecolorset
imagecolorstotal
GD ve Resim İşlevleri
PHP Manual

imagecolorsforindex

(PHP 4, PHP 5, PHP 7)

imagecolorsforindex — Bir renk indisinin renk bilgisini döndürür

Açıklama

array imagecolorsforindex ( resource $resim , int $indis )

İndisi belirtilen rengi döndürür.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

indis

Renk indisi.

Dönen Değerler

Belirtilen renk indisi ile ilişkili red, green, blue ve alpha (kırmızı, yeşil, mavi ve alfa) anahtarlarını içeren bir ilişkisel dizi döndürür.

Örnekler

Örnek 1 - imagecolorsforindex() örneği

<?php

// Bir resim açalım
$im = imagecreatefrompng('nexen.png');

// Bir noktanın renk indisini alalım
$start_x = 40;
$start_y = 50;
$color_index = imagecolorat($im, $start_x, $start_y);

// Renk bilgisini insan okuyabilir biçeme dönüştürelim
$color_tran = imagecolorsforindex($im, $color_index);

// Sonucu görelim
print_r($color_tran);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
   [red] => 226
   [green] => 222
   [blue] => 252
   [alpha] => 0
)

Ayrıca Bakınız

  • imagecolorat() - Bir pikselin renk indisini döndürür
  • imagecolorexact() - Belirtilen rengin indisini döndürür

imagecolorset
imagecolorstotal
GD ve Resim İşlevleri


Bir resim paletindeki renk sayısını döndürür

imagecolorsforindex
imagecolortransparent
GD ve Resim İşlevleri
PHP Manual

imagecolorstotal

(PHP 4, PHP 5, PHP 7)

imagecolorstotal — Bir resim paletindeki renk sayısını döndürür

Açıklama

int imagecolorstotal ( resource $resim )

Bir resim paletindeki renk sayısını döndürür.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

Dönen Değerler

Paletli resimler için paletteki renk sayısını, gerçek renkli resimler için ise 0 döndürür.

Örnekler

Örnek 1 - imagecolorstotal() örneği

<?php
// Resmi açalım
$im = imagecreatefromgif('php.gif');

echo 'Resimdeki toplam renk sayısı: ' . imagecolorstotal($im);

// Belleği serbest bırakalım
imagedestroy($im);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Resimdeki toplam renk sayısı: 128

Ayrıca Bakınız

  • imagecolorat() - Bir pikselin renk indisini döndürür
  • imagecolorsforindex() - Bir renk indisinin renk bilgisini döndürür
  • imageistruecolor() - Bir resmin gerçek renkli olup olmadığını bulur

imagecolorsforindex
imagecolortransparent
GD ve Resim İşlevleri


Bir rengi şeffaflaştırır

imagecolorstotal
imageconvolution
GD ve Resim İşlevleri
PHP Manual

imagecolortransparent

(PHP 4, PHP 5, PHP 7)

imagecolortransparent — Bir rengi şeffaflaştırır

Açıklama

int imagecolortransparent ( resource $resim [, int $renk ] )

Belirtilen resimdeki belli bir rengi şeffaflaştırır.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

renk

imagecolorallocate() ile oluşturulan bir renk tanıtıcısı.

Dönen Değerler

Bir renk belirtilmemişse yeni şeffaf renkle, belirtilmişse mevcut rengin şeffaf rengi ile döner.

Örnekler

Örnek 1 - imagecolortransparent() örneği

<?php
// 55x30 bir resim oluşturalım
$im = imagecreatetruecolor(55, 30);
$red = imagecolorallocate($im, 255, 0, 0);
$black = imagecolorallocate($im, 0, 0, 0);

// Artalanı şeffaf yapalım
imagecolortransparent($im, $black);

// Kırmızı bir dökdörtgen çizelim
imagefilledrectangle($im, 4, 4, 50, 25, $red);

// Resmi kaydedelim
imagepng($im, './imagecolortransparent.png');
imagedestroy($im);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Notlar

Bilginize:

Şeffaflık sadece gerçek renkli resimler ve imagecopymerge() ile kopyalanır, paletli resimler ve imagecopy() ile kopyalanmaz.

Bilginize:

Şeffaflık bir resim özelliğidir, bir renk özelliği değildir. Bir rengin şeffaf olmasını isterseniz, resmin o bölgesi silinip şeffaf olarak yeniden çizilir.

imagecolorstotal
imageconvolution
GD ve Resim İşlevleri


Bir konum ve katsayı ile 3x3'lük bir evrişim matrisini uygular

imagecolortransparent
imagecopy
GD ve Resim İşlevleri
PHP Manual

imageconvolution

(PHP 5 >= 5.1.0, PHP 7)

imageconvolution — Bir konum ve katsayı ile 3x3'lük bir evrişim matrisini uygular

Açıklama

bool imageconvolution ( resource $resim , array $matris , float $katsayı , float $konum )

Bir konum ve katsayı ile 3x3'lük bir evrişim matrisini uygular.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

matris

Bir 3x3 matris: üç gerçel sayı içeren üç diziden oluşmuş bir dizi.

katsayı

Normalleştirme için kullanılan evrişim sonucu katsayısı.

konum

Renk konumu.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - PHP.net logosuna kabartma etkisi vermek

<?php
$image = imagecreatefromgif('http://www.php.net/images/php.gif');

$emboss = array(array(2, 0, 0), array(0, -1, 0), array(0, 0, -1));
imageconvolution($image, $emboss, 1, 127);

header('Content-Type: image/png');
imagepng($image, null, 9);
?>

Yukarıdaki örneğin çıktısı:

Örnek 2 - Gauss bulanıklığı

<?php
$image = imagecreatetruecolor(180,40);

// Resme bir yazı yazıp resmi bulanıklaştıralım
imagestring($image, 5, 10, 8, 'Gaussian Blur Text', 0x00ff00);
$gaussian = array(array(1.0, 2.0, 1.0), array(2.0, 4.0, 2.0), array(1.0, 2.0, 1.0));
imageconvolution($image, $gaussian, 16, 0);

// Karşılaştırma için aynı metni tekrar yazalım
imagestring($image, 5, 10, 18, 'Gaussian Blur Text', 0x00ff00);

header('Content-Type: image/png');
imagepng($image, null, 9);
?>

Yukarıdaki örneğin çıktısı:

Notlar

Bilginize: Bu işlev sadece, PHP, PHP paketinde bulunan GD kütüphanesi ile derlenmişse kullanılabilir.

Ayrıca Bakınız

  • imagefilter() - Bir resme bir süzgeç uygular

imagecolortransparent
imagecopy
GD ve Resim İşlevleri


Bir resim parçasını kopyalar

imageconvolution
imagecopymerge
GD ve Resim İşlevleri
PHP Manual

imagecopy

(PHP 4, PHP 5, PHP 7)

imagecopy — Bir resim parçasını kopyalar

Açıklama

bool imagecopy ( resource $hedef , resource $kaynak , int $hdf_x , int $hdf_y , int $kyn_x , int $kyn_y , int $kyn_gnş , int $kyn_yks )

hedef resmin hdf_x, hdf_y noktasına kaynak resmin kyn_x, kyn_y, kyn_gnş ve kyn_yks ile belirlenen parçasını kopyalar.

Değiştirgeler

hedef

Hedef resmin tanıtıcısı.

kaynak

Kaynak resmin tanıtıcısı.

hdf_x

Hedef resimdeki X koordinatı.

hdf_y

Hedef resimdeki Y koordinatı.

kyn_x

Kaynak resimdeki X koordinatı.

kyn_x

Kaynak resimdeki Y koordinatı.

kyn_gnş

Kaynak resimdeki parça genişliği.

kyn_yks

Kaynak resimdeki parça yüksekliği.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - PHP.net logosunun kırpılması

<?php
// Resim örneklerini oluşturalım
$kaynak = imagecreatefromgif('php.gif');
$hedef = imagecreatetruecolor(80, 40);

// Kopyalayalım
imagecopy($dest, $src, 0, 0, 20, 13, 80, 40);

// Resmi çıktılayıp belleği serbest bırakalım
header('Content-Type: image/gif');
imagegif($hedef);

imagedestroy($hedef);
imagedestroy($kaynak);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

imageconvolution
imagecopymerge
GD ve Resim İşlevleri


Bir resmi kopyalar ve karıştırır

imagecopy
imagecopymergegray
GD ve Resim İşlevleri
PHP Manual

imagecopymerge

(PHP 4 >= 4.0.1, PHP 5, PHP 7)

imagecopymerge — Bir resmi kopyalar ve karıştırır

Açıklama

bool imagecopymerge ( resource $hedef , resource $kaynak , int $hdf_x , int $hdf_y , int $kyn_x , int $kyn_y , int $kyn_gnş , int $kyn_yks , int $oran )

hedef resmin hdf_x, hdf_y noktasına kaynak resmin kyn_x, kyn_y, kyn_gnş ve kyn_yks ile belirlenen parçasını kopyalar.

Değiştirgeler

hedef

Hedef resmin tanıtıcısı.

kaynak

Kaynak resmin tanıtıcısı.

hdf_x

Hedef resimdeki X koordinatı.

hdf_y

Hedef resimdeki Y koordinatı.

kyn_x

Kaynak resimdeki X koordinatı.

kyn_x

Kaynak resimdeki Y koordinatı.

kyn_gnş

Kaynak resimdeki parça genişliği.

kyn_yks

Kaynak resimdeki parça yüksekliği.

oran

0-100 arasında bir değer olup, iki resim bu şeffaflık oranına göre karıştırılır. 0 değeri için hiçbir ek işlem yapılmaz. 100 için ise, gerçek renkli resimlere alfa şeffaflatması uygulanırken paletli resimlere imagecopy() işlevindeki yaklaşım uygulanır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - PHP.net logo'sunun iki kopyasının %75 şeffaflıkla karıştırılması

<?php
// Resim örneklerini oluşturalım
$dest = imagecreatefromgif('php.gif');
$src = imagecreatefromgif('php.gif');

// Kopyalayıp karıştıralım
imagecopymerge($dest, $src, 10, 10, 0, 0, 100, 47, 75);

// Resmi çıktılayıp belleği serbest bırakalım
header('Content-Type: image/gif');
imagegif($dest);

imagedestroy($dest);
imagedestroy($src);
?>

imagecopy
imagecopymergegray
GD ve Resim İşlevleri


Bir resmi kopyalar ve gri tonlama ile karıştırır

imagecopymerge
imagecopyresampled
GD ve Resim İşlevleri
PHP Manual

imagecopymergegray

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

imagecopymergegray — Bir resmi kopyalar ve gri tonlama ile karıştırır

Açıklama

bool imagecopymergegray ( resource $hedef , resource $kaynak , int $hdf_x , int $hdf_y , int $kyn_x , int $kyn_y , int $kyn_gnş , int $kyn_yks , int $oran )

hedef resmin hdf_x, hdf_y noktasına kaynak resmin kyn_x, kyn_y, kyn_gnş ve kyn_yks ile belirlenen parçasını kopyalar.

Kaynak pikselleri hedefe kopyalamadan önce gri tonlamaya dönüştürerek kaynak resmin renk sıcaklığını koruması dışında imagecopymerge() işlevi ile aynıdır.

Değiştirgeler

hedef

Hedef resmin tanıtıcısı.

kaynak

Kaynak resmin tanıtıcısı.

hdf_x

Hedef resimdeki X koordinatı.

hdf_y

Hedef resimdeki Y koordinatı.

kyn_x

Kaynak resimdeki X koordinatı.

kyn_x

Kaynak resimdeki Y koordinatı.

kyn_gnş

Kaynak resimdeki parça genişliği.

kyn_yks

Kaynak resimdeki parça yüksekliği.

oran

0-100 arasında bir değer olup, iki resim bu şeffaflık oranına göre karıştırılır. 0 değeri için hiçbir ek işlem yapılmaz. 100 için ise, gerçek renkli resimlere alfa şeffaflatması uygulanırken paletli resimlere imagecopy() işlevindeki yaklaşım uygulanır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - imagecopymergegray() örneği

<?php
// Resim örneklerini oluşturalım
$dest = imagecreatefromgif('php.gif');
$src = imagecreatefromgif('php.gif');

// Kopyalayıp karıştıralım - Grilik = 20%
imagecopymergegray($dest, $src, 10, 10, 0, 0, 100, 47, 20);

// Resmi çıktılayıp belleği serbest bırakalım
header('Content-Type: image/gif');
imagegif($dest);

imagedestroy($dest);
imagedestroy($src);
?>

imagecopymerge
imagecopyresampled
GD ve Resim İşlevleri


Resmin bir parçasını örnekleyerek kopyalar ve boyutlandırır

imagecopymergegray
imagecopyresized
GD ve Resim İşlevleri
PHP Manual

imagecopyresampled

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

imagecopyresampled — Resmin bir parçasını örnekleyerek kopyalar ve boyutlandırır

Açıklama

bool imagecopyresampled ( resource $hedef , resource $kaynak , int $hdf_x , int $hdf_y , int $kyn_x , int $kyn_y , int $hdf_gnş , int $hdf_yks , int $kyn_gnş , int $kyn_yks )

imagecopyresampled() işlevi bir resim karesini başka bir resme boyutlandırarak kopyalarken piksel renklerini ara değerlerle yumuşatarak resmin görüntü kalitesini korur.

Başka bir deyişle, imagecopyresampled() işlevi hedef resmin hdf_x, hdf_y noktasından hdf_gnş, hdf_yks ile belirlenen parçasını alıp kaynak resmin kyn_x, kyn_y noktasında, kyn_gnş ve kyn_yks ile belirlenen parçasına yerleştirir.

Eğer kaynak ve hedef koordinatları ile genişlik ve yükseklikler farklıysa parça yerleştirilirken küçültülür veya büyütülür. Koordinatlar parçanın sol üst köşesini belirtir. Bu işlev aynı resmin içinde kopyalama yapmak amacıyla da kullanılabilir (hedef ve kaynak aynı ise), fakat parçaların üstüste gelmesi halinde sonuç belirsizdir.

Değiştirgeler

hedef

Hedef resmin tanıtıcısı.

kaynak

Kaynak resmin tanıtıcısı.

hdf_x

Hedef resimdeki X koordinatı.

hdf_y

Hedef resimdeki Y koordinatı.

kyn_x

Kaynak resimdeki X koordinatı.

kyn_y

Kaynak resimdeki Y koordinatı.

hdf_gnş

Hedef resimdeki parça genişliği.

hdf_yks

Hedef resimdeki parça yüksekliği.

kyn_gnş

Kaynak resimdeki parça genişliği.

kyn_yks

Kaynak resimdeki parça yüksekliği.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Basit örnek

Bu örnekte resim yarı boyutunda yeniden örneklenmektedir.

<?php
// Dosya ve yeni boyut
$dosya = 'test.jpg';
$oran = 0.5;

// İçerik türü
header('Content-type: image/jpeg');

// Yeni resmin boyutları
list($gen, $yük) = getimagesize($filename);
$yenigen = $gen * $oran;
$yeniyük = $yük * $oran;

// Resimleri yükleyelim
$hedef = imagecreatetruecolor($yeniger, $yeniyük);
$kaynak = imagecreatefromjpeg($dosya);

// Resmi örnekleyelim
imagecopyresampled($hedef, $kaynak, 0, 0, 0, 0, $yenigen, $yeniyük, $gen, $yük);

// Resmi çıktılayalım
imagejpeg($image_p, null, 100);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Örnek 2 - Bir resmin orantılı olarak örneklenmesi

Bu örnekte resim 200 piksellik azami yükseklik ve genişlikle örneklenmektedir.

<?php
// Dosya
$dosya = 'dnm.jpg';

// Azami yükseklik ve genişlik
$gen = 200;
$yük = 200;

// İçerik türü
header('Content-type: image/jpeg');

// Yeni boyutları hesaplayalım
list($özgen, $özyük) = getimagesize($dosya);

$özoran = $özgen/$özyük;

if ($gen/$yük > $özoran) {
   $gen = $yük*$özoran;
} else {
   $yük = $gen/$özoran;
}

// Resmi örnekleyelim
$hedef = imagecreatetruecolor($gen, $yük);
$kaynak = imagecreatefromjpeg($dosya);
imagecopyresampled($hedef, $kaynak, 0, 0, 0, 0, $gen, $yük, $özgen, $özyük);

// Resmi çıktılayalım
imagejpeg($image_p, null, 100);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Notlar

Bilginize:

Paletli resimlerdeki sınırlama (255+1 renk) nedeniyle bir sorun vardır. Resmi yeniden örneklerken veya süzerken 255'ten daha çok renk gerekir ve bu nedenle yeniden örneklenen piksel renkleri için bir yaklaşım uygulanır. Paletli resimde yeni renk için paletten bir yer ayrılmaya çalışılır, eğer bu işlem başarısız olursa (teorik olarak) o renge en yakın renk seçilir. Bu her zaman görsel olarak en yakın renk olmayabilir. Bunun sonucu olarak kısmen boş resimler gibi tuhaf sonuçlar alınabilir. Bu gibi sorunlarla karşılaşmamak için hedef resim olarak gerçek renkli (örneğin, imagecreatetruecolor() ile oluşturulmuş) bir resim kullanın.

Ayrıca Bakınız

imagecopyresized() - Resmin bir parçasını kopyalar ve boyutlandırır

imagecopymergegray
imagecopyresized
GD ve Resim İşlevleri


Resmin bir parçasını kopyalar ve boyutlandırır

imagecopyresampled
imagecreate
GD ve Resim İşlevleri
PHP Manual

imagecopyresized

(PHP 4, PHP 5, PHP 7)

imagecopyresized — Resmin bir parçasını kopyalar ve boyutlandırır

Açıklama

bool imagecopyresized ( resource $hedef , resource $kaynak , int $hdf_x , int $hdf_y , int $kyn_x , int $kyn_y , int $hdf_gnş , int $hdf_yks , int $kyn_gnş , int $kyn_yks )

imagecopyresized() işlevi kaynak resmin bir bölümünü hedef resmin bir bölümüne sığacak şekilde boyutlandırarak kopyalar.

Başka bir deyişle, imagecopyresized() işlevi hedef resmin hdf_x, hdf_y noktasından hdf_gnş, hdf_yks ile belirlenen parçasını alıp kaynak resmin kyn_x, kyn_y noktasında, kyn_gnş ve kyn_yks ile belirlenen parçasına yerleştirir.

Eğer kaynak ve hedef koordinatları ile genişlik ve yükseklikler farklıysa parça yerleştirilirken küçültülür veya büyütülür. Koordinatlar parçanın sol üst köşesini belirtir. Bu işlev aynı resmin içinde kopyalama yapmak amacıyla da kullanılabilir (hedef ve kaynak aynı ise), fakat parçaların üstüste gelmesi halinde sonuç belirsizdir.

Değiştirgeler

hedef

Hedef resmin tanıtıcısı.

kaynak

Kaynak resmin tanıtıcısı.

hdf_x

Hedef resimdeki X koordinatı.

hdf_y

Hedef resimdeki Y koordinatı.

kyn_x

Kaynak resimdeki X koordinatı.

kyn_y

Kaynak resimdeki Y koordinatı.

hdf_gnş

Hedef resimdeki parça genişliği.

hdf_yks

Hedef resimdeki parça yüksekliği.

kyn_gnş

Kaynak resimdeki parça genişliği.

kyn_yks

Kaynak resimdeki parça yüksekliği.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Bir remin boyutlandırılması

Bu örnekte resim yarı boyutunda gösterilmektedir.

<?php
// Dosya ve yeni boyut
$dosya = 'test.jpg';
$oran = 0.5;

// İçerik türü
header('Content-type: image/jpeg');

// Yeni resmin boyutları
list($gen, $yük) = getimagesize($filename);
$yenigen = $gen * $oran;
$yeniyük = $yük * $oran;

// Resimleri yükleyelim
$hedef = imagecreatetruecolor($yeniger, $yeniyük);
$kaynak = imagecreatefromjpeg($dosya);

// Resmi boyutlandıralım
imagecopyresized($hedef, $kaynak, 0, 0, 0, 0, $yenigen, $yeniyük, $gen, $yük);

// Resmi çıktılayalım
imagejpeg($hedef);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Resim yarı boyutunda çıktılanır ama imagecopyresampled() kullanılsaydı kalite daha iyi olurdu.

Notlar

Bilginize:

Paletli resimlerdeki sınırlama (255+1 renk) nedeniyle bir sorun vardır. Resmi yeniden örneklerken veya süzerken 255'ten daha çok renk gerekir ve bu nedenle yeniden örneklenen piksel renkleri için bir yaklaşım uygulanır. Paletli resimde yeni renk için paletten bir yer ayrılmaya çalışılır, eğer bu işlem başarısız olursa (teorik olarak) o renge en yakın renk seçilir. Bu her zaman görsel olarak en yakın renk olmayabilir. Bunun sonucu olarak kısmen boş resimler gibi tuhaf sonuçlar alınabilir. Bu gibi sorunlarla karşılaşmamak için hedef resim olarak gerçek renkli (örneğin, imagecreatetruecolor() ile oluşturulmuş) bir resim kullanın.

Ayrıca Bakınız

imagecopyresampled() - Resmin bir parçasını örnekleyerek kopyalar ve boyutlandırır

imagecopyresampled
imagecreate
GD ve Resim İşlevleri


Yeni bir paletli resim oluşturur

imagecopyresized
imagecreatefrombmp
GD ve Resim İşlevleri
PHP Manual

imagecreate

(PHP 4, PHP 5, PHP 7)

imagecreate — Yeni bir paletli resim oluşturur

Açıklama

resource imagecreate ( int $genişlik , int $yükseklik )

imagecreate() işlevi, boyutları belirtilen boş resmi oluşturur ve onun için bir resim tanıtıcısı döndürür.

Boş resim oluşturmak için imagecreatetruecolor() işlevini kullanmanızı öneriyoruz.

Değiştirgeler

genişlik

Resmin genişliği.

yükseklik

Resmin yüksekliği.

Dönen Değerler

Hata oluşursa FALSE aksi takdirde bir resim tanıtıcısı döndürür.

Örnekler

Örnek 1 - Yeni bir GD resim akımı oluşturup bir resim çıktılamak

<?php
header("Content-type: image/png");
$im = @imagecreate(110, 20)
    or die("GD resim akımı ilklendirilemedi");
$artalan = imagecolorallocate($im, 0, 0, 0);
$önalan = imagecolorallocate($im, 233, 14, 91);
imagestring($im, 1, 5, 5,  "A Simple Text String", $önalan);
imagepng($im);
imagedestroy($im);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ayrıca Bakınız

  • imagedestroy() - Bir resmi bellekten siler
  • imagecreatetruecolor() - Yeni bir gerçek renkli resim oluşturur

imagecopyresized
imagecreatefrombmp
GD ve Resim İşlevleri


Bir dosya veya URL'den yeni bir resim oluşturur.

imagecreate
imagecreatefromgd2
GD ve Resim İşlevleri
PHP Manual

imagecreatefrombmp

(PHP 7 >= 7.2.0)

imagecreatefrombmp — Bir dosya veya URL'den yeni bir resim oluşturur.

Açıklama

resource imagecreatefrombmp ( string $filename )

imagecreatefrombmp() returns an image identifier representing the image obtained from the given filename.

İpucu

fopen sarmalayıcıları etkin kılınmışsa bu işlevde dosya ismi olarak bir URL belirtebilirsiniz. Dosya isminin nasıl belirtilebileceği hakkında bilgi edinmek için fopen() işlevine bakınız. Sarmalayıcıların neler yapabildiği, kullanım bilgileri ve bunlar tarafından kullanılan öntanımlı değişkenler hakkında bilgi edinmek için ise Supported Protocols and Wrappers bölümüne bakınız.

Değiştirgeler

filename

Path to the BMP image.

Dönen Değerler

Başarı durumunda resim dosya tanıtıcısı, hata durumunda FALSE döner.

Örnekler

Örnek 1 Convert an BMP image to a PNG image using imagecreatefrombmp()

<?php
// Load the BMP file
$im = imagecreatefrombmp('./example.bmp');

// Convert it to a PNG file with default settings
imagepng($im, './example.png');
imagedestroy($im);
?>

imagecreate
imagecreatefromgd2
GD ve Resim İşlevleri


Bir GD2 dosyasından veya URL'sinden yeni bir resim oluşturur

imagecreatefrombmp
imagecreatefromgd2part
GD ve Resim İşlevleri
PHP Manual

imagecreatefromgd2

(PHP 4 >= 4.0.7, PHP 5, PHP 7)

imagecreatefromgd2 — Bir GD2 dosyasından veya URL'sinden yeni bir resim oluşturur

Açıklama

resource imagecreatefromgd2 ( string $dosyaismi )

Dosya ismi verilen GD2 resmini betimleyen bir resim tanıtıcısı döndürür.

İpucu

fopen sarmalayıcıları etkin kılınmışsa bu işlevde dosya ismi olarak bir URL belirtebilirsiniz. Dosya isminin nasıl belirtilebileceği hakkında bilgi edinmek için fopen() işlevine bakınız. Sarmalayıcıların neler yapabildiği, kullanım bilgileri ve bunlar tarafından kullanılan öntanımlı değişkenler hakkında bilgi edinmek için ise Supported Protocols and Wrappers bölümüne bakınız.

Değiştirgeler

dosyaismi

GD2 resmin dosya yolu.

Dönen Değerler

Başarı durumunda resim dosya tanıtıcısı, hata durumunda FALSE döner.

Örnekler

Örnek 1 - imagecreatefromgd2() örneği

<?php
// Resmi açmaya çalışalım
$im = imagecreatefromgd2('./dnm.gd2');

// Resmin negatifini elde edelim (PHP 5+)
if(function_exists('imagefilter'))
{
    imagefilter($im, IMG_FILTER_NEGATE);
}

// Resmi kaydedelim
imagegd2($im, './guncel_dnm.gd2');
imagedestroy($im);
?>

Notlar

Bilginize: Bu işlev GD'nin 2.0.1 veya sonraki sürümlerini gerektirir (2.0.28 veya sonraki sürümler önerilir).

imagecreatefrombmp
imagecreatefromgd2part
GD ve Resim İşlevleri


Bir GD2 parça dosyasından veya URL'sinden yeni bir resim oluşturur

imagecreatefromgd2
imagecreatefromgd
GD ve Resim İşlevleri
PHP Manual

imagecreatefromgd2part

(PHP 4 >= 4.0.7, PHP 5, PHP 7)

imagecreatefromgd2part — Bir GD2 parça dosyasından veya URL'sinden yeni bir resim oluşturur

Açıklama

resource imagecreatefromgd2part ( string $dosyaismi , int $X , int $Y , int $genişlik , int $yükseklik )

Bir GD2 parça dosyasından veya URL'sinden yeni bir resim oluşturur.

İpucu

fopen sarmalayıcıları etkin kılınmışsa bu işlevde dosya ismi olarak bir URL belirtebilirsiniz. Dosya isminin nasıl belirtilebileceği hakkında bilgi edinmek için fopen() işlevine bakınız. Sarmalayıcıların neler yapabildiği, kullanım bilgileri ve bunlar tarafından kullanılan öntanımlı değişkenler hakkında bilgi edinmek için ise Supported Protocols and Wrappers bölümüne bakınız.

Değiştirgeler

dosyaismi

GD2 resmin dosya yolu.

X

Parçanın X konumu.

Y

Parçanın Y konumu.

genişlik

Kaynak genişliği.

yükseklik

Kaynak yüksekliği.

Dönen Değerler

Başarı durumunda resim dosya tanıtıcısı, hata durumunda FALSE döner.

Örnekler

Örnek 1 - imagecreatefromgd2part() örneği

<?php
// Bu örnek için öncelikle resim boyutuna ihtiyacımız var
$image = getimagesize('./dnm.gd2');

// Parçanın örneğini oluşturalım
$im = imagecreatefromgd2part('./dnm.gd2', 4, 4, ($image[0] / 2) - 6, ($image[1] / 2) - 6);

// Resme kabartma etkisi verelim (PHP 5+)
if(function_exists('imagefilter'))
{
    imagefilter($im, IMG_FILTER_EMBOSS);
}

// Resmi kaydedelim
imagegd2($im, './kabartma_dnm.gd2');
imagedestroy($im);
?>

Notlar

Bilginize: Bu işlev GD'nin 2.0.1 veya sonraki sürümlerini gerektirir (2.0.28 veya sonraki sürümler önerilir).

imagecreatefromgd2
imagecreatefromgd
GD ve Resim İşlevleri


Bir GD dosyasından veya URL'sinden yeni bir resim oluşturur

imagecreatefromgd2part
imagecreatefromgif
GD ve Resim İşlevleri
PHP Manual

imagecreatefromgd

(PHP 4 >= 4.0.7, PHP 5, PHP 7)

imagecreatefromgd — Bir GD dosyasından veya URL'sinden yeni bir resim oluşturur

Açıklama

resource imagecreatefromgd ( string $dosyaismi )

Dosya ismi verilen GD resmini betimleyen bir resim tanıtıcısı döndürür.

İpucu

fopen sarmalayıcıları etkin kılınmışsa bu işlevde dosya ismi olarak bir URL belirtebilirsiniz. Dosya isminin nasıl belirtilebileceği hakkında bilgi edinmek için fopen() işlevine bakınız. Sarmalayıcıların neler yapabildiği, kullanım bilgileri ve bunlar tarafından kullanılan öntanımlı değişkenler hakkında bilgi edinmek için ise Supported Protocols and Wrappers bölümüne bakınız.

Değiştirgeler

dosyaismi

GD resmin dosya yolu.

Dönen Değerler

Başarı durumunda resim dosya tanıtıcısı, hata durumunda FALSE döner.

Örnekler

Örnek 1 - imagecreatefromgd() örneği

<?php
// Resmi açmaya çalışalım
$im = @imagecreatefromgd('./dnm.gd');

// Başarılı oldu mu bakalım
if(!is_resource($im))
{
     die('Belirtilen GD resmi yüklenemedi!');
}

// Resim üzerindeki işlemler burada

// Resmi kaydedelim
imagegd($im, './guncel_dnm.gd');
imagedestroy($im);
?>

imagecreatefromgd2part
imagecreatefromgif
GD ve Resim İşlevleri


Bir dosya veya URL'den yeni bir resim oluşturur.

imagecreatefromgd
imagecreatefromjpeg
GD ve Resim İşlevleri
PHP Manual

imagecreatefromgif

(PHP 4, PHP 5, PHP 7)

imagecreatefromgif — Bir dosya veya URL'den yeni bir resim oluşturur.

Açıklama

resource imagecreatefromgif ( string $dosyaismi )

imagecreatefromgif() işlevi dosya ismi verilen resmi betimleyen bir resim tanıtıcısı döndürür.

İpucu

fopen sarmalayıcıları etkin kılınmışsa bu işlevde dosya ismi olarak bir URL belirtebilirsiniz. Dosya isminin nasıl belirtilebileceği hakkında bilgi edinmek için fopen() işlevine bakınız. Sarmalayıcıların neler yapabildiği, kullanım bilgileri ve bunlar tarafından kullanılan öntanımlı değişkenler hakkında bilgi edinmek için ise Supported Protocols and Wrappers bölümüne bakınız.

Değiştirgeler

dosyaismi

GIF resmin dosya yolu.

Dönen Değerler

Başarı durumunda resim dosya tanıtıcısı, hata durumunda FALSE döner.

Örnekler

Örnek 1 - Bir GIF yüklerken oluşan bir hatanın ele alınması

<?php
function GIFyükle($resimismi)
{
    /* Resmi açmaya çalışalım */
    $im = @imagecreatefromgif($resimismi);

    /* Başarılı oldu mu bakalım */
    if(!$im)
    {
        /* Boş bir resim oluşturalım */
        $im = imagecreatetruecolor (150, 30);
        $bgc = imagecolorallocate ($im, 255, 255, 255);
        $tc = imagecolorallocate ($im, 0, 0, 0);

        imagefilledrectangle ($im, 0, 0, 150, 30, $bgc);

        /* Hata iletisini çıktılayalım */
        imagestring ($im, 1, 5, 5, 'Error loading ' . $imgname, $tc);
    }

    return $im;
}

header('Content-Type: image/gif');

$img = GIFyükle('bogus.image');

imagegif($img);
imagedestroy($img);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Bir GIF'in yüklenmesi sırasında hata oluşması örneği

Notlar

Bilginize:

GIF desteği GD kütüphanesinin 1.6 sürümünde kaldırılmış, 2.0.28 sürümünde yeniden eklenmiştir. Bu işlev bu iki sürümün arasında kalan sürümlerde bulunmamaktadır.

Bilginize:

Canlandırılmış GIF dosyaları belleğe okunurken resim özkaynak göstercisinde yalnız ilk kare döner.

imagecreatefromgd
imagecreatefromjpeg
GD ve Resim İşlevleri


Bir dosya veya URL'den yeni bir resim oluşturur.

imagecreatefromgif
imagecreatefrompng
GD ve Resim İşlevleri
PHP Manual

imagecreatefromjpeg

(PHP 4, PHP 5, PHP 7)

imagecreatefromjpeg — Bir dosya veya URL'den yeni bir resim oluşturur.

Açıklama

resource imagecreatefromjpeg ( string $dosyaismi )

imagecreatefromjpeg() işlevi dosya ismi verilen resmi betimleyen bir resim tanıtıcısı döndürür.

İpucu

fopen sarmalayıcıları etkin kılınmışsa bu işlevde dosya ismi olarak bir URL belirtebilirsiniz. Dosya isminin nasıl belirtilebileceği hakkında bilgi edinmek için fopen() işlevine bakınız. Sarmalayıcıların neler yapabildiği, kullanım bilgileri ve bunlar tarafından kullanılan öntanımlı değişkenler hakkında bilgi edinmek için ise Supported Protocols and Wrappers bölümüne bakınız.

Değiştirgeler

dosyaismi

JPEG resmin dosya yolu.

Dönen Değerler

Başarı durumunda resim dosya tanıtıcısı, hata durumunda FALSE döner.

Örnekler

Örnek 1 - Bir JPEG yüklerken oluşan bir hatanın ele alınması

<?php
function JPEGyükle($resimismi)
{
    /* Resmi açmaya çalışalım */
    $im = @imagecreatefromjpeg($resimismi);

    /* Başarılı oldu mu bakalım */
    if(!$im)
    {
        /* Boş bir resim oluşturalım */
        $im  = imagecreatetruecolor (20, 20);
        $bgc = imagecolorallocate($im, 255, 255, 255);
        $tc  = imagecolorallocate($im, 0, 0, 0);

        imagefilledrectangle($im, 0, 0, 10, 10, $bgc);

        /* Hata iletisini çıktılayalım */
        imagestring($im, 1, 5, 5, 'Error loading ' . $imgname, $tc);
    }

    return $im;
}

header('Content-Type: image/jpeg');

$img = JPEGyükle('bogus.image');

imagejpeg($img);
imagedestroy($img);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Bir JPEG yüklerken oluşan bir hatanın ele alınması

Notlar

Bilginize: JPEG desteği sadece, PHP, GD'nin 1.8 veya sonraki bir sürümünün kurulu olduğu bir platformda derlenmişse kullanılabilir.

imagecreatefromgif
imagecreatefrompng
GD ve Resim İşlevleri


Bir dosya veya URL'den yeni bir resim oluşturur.

imagecreatefromjpeg
imagecreatefromstring
GD ve Resim İşlevleri
PHP Manual

imagecreatefrompng

(PHP 4, PHP 5, PHP 7)

imagecreatefrompng — Bir dosya veya URL'den yeni bir resim oluşturur.

Açıklama

resource imagecreatefrompng ( string $dosyaismi )

imagecreatefrompng() işlevi dosya ismi verilen resmi betimleyen bir resim tanıtıcısı döndürür.

İpucu

fopen sarmalayıcıları etkin kılınmışsa bu işlevde dosya ismi olarak bir URL belirtebilirsiniz. Dosya isminin nasıl belirtilebileceği hakkında bilgi edinmek için fopen() işlevine bakınız. Sarmalayıcıların neler yapabildiği, kullanım bilgileri ve bunlar tarafından kullanılan öntanımlı değişkenler hakkında bilgi edinmek için ise Supported Protocols and Wrappers bölümüne bakınız.

Değiştirgeler

dosyaismi

PNG resmin dosya yolu.

Dönen Değerler

Başarı durumunda resim dosya tanıtıcısı, hata durumunda FALSE döner.

Örnekler

Örnek 1 - Bir PNG yüklerken oluşan bir hatanın ele alınması

<?php
function PNGyükle($resimismi)
{
    /* Resmi açmaya çalışalım */
    $im = @imagecreatefrompng($resimismi);

    /* Başarılı oldu mu bakalım */
    if(!$im)
    {
        /* Boş bir resim oluşturalım */
        $im  = imagecreatetruecolor (20, 20);
        $bgc = imagecolorallocate($im, 255, 255, 255);
        $tc  = imagecolorallocate($im, 0, 0, 0);

        imagefilledrectangle($im, 0, 0, 10, 10, $bgc);

        /* Hata iletisini çıktılayalım */
        imagestring($im, 1, 5, 5, 'Error loading ' . $imgname, $tc);
    }

    return $im;
}

header('Content-Type: image/png');

$img = PNGyükle('bozuk.resim');

imagepng($img);
imagedestroy($img);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

imagecreatefromjpeg
imagecreatefromstring
GD ve Resim İşlevleri


Belirtilen dizgeden yeni bir resim oluşturur

imagecreatefrompng
imagecreatefromwbmp
GD ve Resim İşlevleri
PHP Manual

imagecreatefromstring

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

imagecreatefromstring — Belirtilen dizgeden yeni bir resim oluşturur

Açıklama

resource imagecreatefromstring ( string $veri )

imagecreatefromstring() işleve veri ile belirtilen resim dizgesinden elde edilen resim için bir resim tanıtıcısı döndürür. PHP desteklediği takdirde özdevinimli olaran algılanan dosya biçemleri: JPEG, PNG, GIF, WBMP ve GD2.

Değiştirgeler

veri

Resim verisini içeren dizge.

Dönen Değerler

Resim dosya biçemi desteklenmiyorsa, veri biçemi tanınmıyorsa veya resim bozuksa ya da yükenemiyorsa FALSE aksi takdirde bir resim tanıtıcısı döndürür.

Örnekler

Örnek 1 - imagecreatefromstring() örneği

<?php
$data = 'iVBORw0KGgoAAAANSUhEUgAAABwAAAASCAMAAAB/2U7WAAAABl'
       . 'BMVEUAAAD///+l2Z/dAAAASUlEQVR4XqWQUQoAIAxC2/0vXZDr'
       . 'EX4IJTRkb7lobNUStXsB0jIXIAMSsQnWlsV+wULF4Avk9fLq2r'
       . '8a5HSE35Q3eO2XP1A1wQkZSgETvDtKdQAAAABJRU5ErkJggg==';
$data = base64_decode($data);

$im = imagecreatefromstring($data);
if ($im !== false) {
    header('Content-Type: image/png');
    imagepng($im);
    imagedestroy($im);
}
else {
    echo 'Bir hata oluştu.';
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ayrıca Bakınız

  • imagecreatefromjpeg() - Bir dosya veya URL'den yeni bir resim oluşturur.
  • imagecreatefrompng() - Bir dosya veya URL'den yeni bir resim oluşturur.
  • imagecreatefromgif() - Bir dosya veya URL'den yeni bir resim oluşturur.
  • imagecreatetruecolor() - Yeni bir gerçek renkli resim oluşturur

imagecreatefrompng
imagecreatefromwbmp
GD ve Resim İşlevleri


Bir dosya veya URL'den yeni bir resim oluşturur.

imagecreatefromstring
imagecreatefromwebp
GD ve Resim İşlevleri
PHP Manual

imagecreatefromwbmp

(PHP 4 >= 4.0.1, PHP 5, PHP 7)

imagecreatefromwbmp — Bir dosya veya URL'den yeni bir resim oluşturur.

Açıklama

resource imagecreatefromwbmp ( string $dosyaismi )

imagecreatefromwbmp() işlevi dosya ismi verilen resmi betimleyen bir resim tanıtıcısı döndürür.

İpucu

fopen sarmalayıcıları etkin kılınmışsa bu işlevde dosya ismi olarak bir URL belirtebilirsiniz. Dosya isminin nasıl belirtilebileceği hakkında bilgi edinmek için fopen() işlevine bakınız. Sarmalayıcıların neler yapabildiği, kullanım bilgileri ve bunlar tarafından kullanılan öntanımlı değişkenler hakkında bilgi edinmek için ise Supported Protocols and Wrappers bölümüne bakınız.

Değiştirgeler

dosyaismi

WBMP resmin dosya yolu.

Dönen Değerler

Başarı durumunda resim dosya tanıtıcısı, hata durumunda FALSE döner.

Örnekler

Örnek 1 - Bir WBMP yüklerken oluşan bir hatanın ele alınması

<?php
function WBMPyükle($resimismi)
{
    /* Resmi açmaya çalışalım */
    $im = @imagecreatefromwbmp($resimismi);

    /* Başarılı oldu mu bakalım */
    if(!$im)
    {
        /* Boş bir resim oluşturalım */
        $im  = imagecreatetruecolor(150, 30);
        $bgc = imagecolorallocate($im, 255, 255, 255);
        $tc  = imagecolorallocate($im, 0, 0, 0);

        imagefilledrectangle($im, 0, 0, 150, 30, $bgc);

        /* Hata iletisini çıktılayalım */
        imagestring($im, 1, 5, 5, 'Yükleme hatası ' . $imgname, $tc);
    }

    return $im;
}

header('Content-Type: image/vnd.wap.wbmp');

$img = WBMPyükle('bozuk.resim');

imagewbmp($img);
imagedestroy($img);
?>

Notlar

Bilginize: WBMP desteği sadece, PHP, GD'nin 1.8 veya sonraki bir sürümünün kurulu olduğu bir platformda derlenmişse kullanılabilir.

imagecreatefromstring
imagecreatefromwebp
GD ve Resim İşlevleri


Bir dosya veya URL'den yeni bir resim oluşturur.

imagecreatefromwbmp
imagecreatefromxbm
GD ve Resim İşlevleri
PHP Manual

imagecreatefromwebp

(PHP 5 >= 5.5.0, PHP 7)

imagecreatefromwebp — Bir dosya veya URL'den yeni bir resim oluşturur.

Açıklama

resource imagecreatefromwebp ( string $filename )

imagecreatefromwebp() returns an image identifier representing the image obtained from the given filename.

İpucu

fopen sarmalayıcıları etkin kılınmışsa bu işlevde dosya ismi olarak bir URL belirtebilirsiniz. Dosya isminin nasıl belirtilebileceği hakkında bilgi edinmek için fopen() işlevine bakınız. Sarmalayıcıların neler yapabildiği, kullanım bilgileri ve bunlar tarafından kullanılan öntanımlı değişkenler hakkında bilgi edinmek için ise Supported Protocols and Wrappers bölümüne bakınız.

Değiştirgeler

filename

Path to the WebP image.

Dönen Değerler

Başarı durumunda resim dosya tanıtıcısı, hata durumunda FALSE döner.

Örnekler

Örnek 1 Convert an WebP image to a jpeg image using imagecreatefromwebp()

<?php
// Load the WebP file
$im = imagecreatefromwebp('./example.webp');

// Convert it to a jpeg file with 100% quality
imagejpeg($im, './example.jpeg', 100);
imagedestroy($im);
?>

imagecreatefromwbmp
imagecreatefromxbm
GD ve Resim İşlevleri


Bir dosya veya URL'den yeni bir resim oluşturur.

imagecreatefromwebp
imagecreatefromxpm
GD ve Resim İşlevleri
PHP Manual

imagecreatefromxbm

(PHP 4 >= 4.0.1, PHP 5, PHP 7)

imagecreatefromxbm — Bir dosya veya URL'den yeni bir resim oluşturur.

Açıklama

resource imagecreatefromxbm ( string $dosyaismi )

imagecreatefromxbm() işlevi dosya ismi verilen resmi betimleyen bir resim tanıtıcısı döndürür.

İpucu

fopen sarmalayıcıları etkin kılınmışsa bu işlevde dosya ismi olarak bir URL belirtebilirsiniz. Dosya isminin nasıl belirtilebileceği hakkında bilgi edinmek için fopen() işlevine bakınız. Sarmalayıcıların neler yapabildiği, kullanım bilgileri ve bunlar tarafından kullanılan öntanımlı değişkenler hakkında bilgi edinmek için ise Supported Protocols and Wrappers bölümüne bakınız.

Değiştirgeler

dosyaismi

XBM resmin dosya yolu.

Dönen Değerler

Başarı durumunda resim dosya tanıtıcısı, hata durumunda FALSE döner.

Örnekler

Örnek 1 - imagecreatefromxbm() örneği

<?php
// XBM dosyasını yükleyelim
$xbm = imagecreatefromxbm('./ornek.xbm');

// Bir PNG dosyasına dönüştürelim
imagepng($xbm, './ornek.png');
imagedestroy($xbm);
?>

imagecreatefromwebp
imagecreatefromxpm
GD ve Resim İşlevleri


Bir XPM dosyasından veya URL'sinden yeni bir resim oluşturur

imagecreatefromxbm
imagecreatetruecolor
GD ve Resim İşlevleri
PHP Manual

imagecreatefromxpm

(PHP 4 >= 4.0.1, PHP 5, PHP 7)

imagecreatefromxpm — Bir XPM dosyasından veya URL'sinden yeni bir resim oluşturur

Açıklama

resource imagecreatefromxpm ( string $dosyaismi )

imagecreatefromxpm() işlevi dosya ismi verilen resmi betimleyen bir resim tanıtıcısı döndürür.

İpucu

fopen sarmalayıcıları etkin kılınmışsa bu işlevde dosya ismi olarak bir URL belirtebilirsiniz. Dosya isminin nasıl belirtilebileceği hakkında bilgi edinmek için fopen() işlevine bakınız. Sarmalayıcıların neler yapabildiği, kullanım bilgileri ve bunlar tarafından kullanılan öntanımlı değişkenler hakkında bilgi edinmek için ise Supported Protocols and Wrappers bölümüne bakınız.

Değiştirgeler

dosyaismi

XPM resmin dosya yolu.

Dönen Değerler

Hata oluşursa FALSE aksi takdirde bir resim tanıtıcısı döndürür.

Örnekler

Örnek 1 - imagecreatefromxpm() örneği

<?php
// XPM desteği var mı, bakalım
if(!(imagetypes() & IMG_XPM))
{
    die('XPM desteği yok!');
}

// Resmin bir örneğini oluşturalım
$xpm = imagecreatefromxpm('./ornek.xpm');

// Burada resim üzerinde bazı işlemler yapalım

// PHP'de XPM resimleri yazmak için destek bulunmadığından
// resmi %100 kalite ile bir JPEG olarak kaydedeceğiz.
imagejpeg($im, './ornek.jpg', 100);
imagedestroy($im);
?>

Dönen Değerler

Bilginize: Bu işlev sadece, PHP, PHP paketinde bulunan GD kütüphanesi ile derlenmişse kullanılabilir.

Bilginize: Bu işlev Windows sistemlerinde çalışmaz.

imagecreatefromxbm
imagecreatetruecolor
GD ve Resim İşlevleri


Yeni bir gerçek renkli resim oluşturur

imagecreatefromxpm
imagecrop
GD ve Resim İşlevleri
PHP Manual

imagecreatetruecolor

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

imagecreatetruecolor — Yeni bir gerçek renkli resim oluşturur

Açıklama

resource imagecreatetruecolor ( int $genişlik , int $yükseklik )

imagecreatetruecolor() işlevi boyutları belirtilen siyah resmi oluşturur ve onun için bir resim tanıtıcısı döndürür.

Kullandığınız PHP ve GD sürümlerine bağlı olarak bu işlev mevcut olmayabilir. PHP 4.0.6'dan 4.1.x sürümlerine kadar bu işlev GD modülüne dahildi fakat PHP, GD2 desteği ile kurulmamışsa PHP bir ölümcül hata verip çıkardı. PHP 4.2.x sürümlerinde bu hata bir uyarıya dönüştürüldü. Diğer sürümler ise bu işlevi sadece doğru GD sürümü kurulu olduğu takdirde desteklerler.

Değiştirgeler

genişlik

Resmin genişliği.

yükseklik

Resmin yüksekliği.

Dönen Değerler

Hata oluşursa FALSE aksi takdirde bir resim tanıtıcısı döndürür.

Örnekler

Örnek 1 Yeni bir GD2 resim akımı oluşturup bir resim çıktılamak

<?php
header ('Content-type: image/png');
$im = @imagecreatetruecolor(120, 20)
      or die('GD2 resim akımı ilklendirilemedi');
$text_color = imagecolorallocate($im, 233, 14, 91);
imagestring($im, 1, 5, 5,  'A Simple Text String', $text_color);
imagepng($im);
imagedestroy($im);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Notlar

Bilginize: Bu işlev GD'nin 2.0.1 veya sonraki sürümlerini gerektirir (2.0.28 veya sonraki sürümler önerilir).

Bilginize:

Bu işlev GIF dosya biçimleri ile çalışmaz.

Ayrıca Bakınız

  • imagedestroy() - Bir resmi bellekten siler
  • imagecreate() - Yeni bir paletli resim oluşturur

imagecreatefromxpm
imagecrop
GD ve Resim İşlevleri


Crop an image to the given rectangle

imagecreatetruecolor
imagecropauto
GD ve Resim İşlevleri
PHP Manual

imagecrop

(PHP 5 >= 5.5.0, PHP 7)

imagecrop — Crop an image to the given rectangle

Açıklama

resource imagecrop ( resource $image , array $rect )

Crops an image to the given rectangular area and returns the resulting image. The given image is not modified.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

rect

The cropping rectangle as array with keys x, y, width and height.

Dönen Değerler

Return cropped image resource on success başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 imagecrop() example

This example shows how to crop an image to a square area.

<?php
$im = imagecreatefrompng('example.png');
$size = min(imagesx($im), imagesy($im));
$im2 = imagecrop($im, ['x' => 0, 'y' => 0, 'width' => $size, 'height' => $size]);
if ($im2 !== FALSE) {
    imagepng($im2, 'example-cropped.png');
}
?>

Ayrıca Bakınız

  • imagecropauto() - Crop an image automatically using one of the available modes
imagecreatetruecolor
imagecropauto
GD ve Resim İşlevleri


Crop an image automatically using one of the available modes

imagecrop
imagedashedline
GD ve Resim İşlevleri
PHP Manual

imagecropauto

(PHP 5 >= 5.5.0, PHP 7)

imagecropauto — Crop an image automatically using one of the available modes

Açıklama

resource imagecropauto ( resource $image [, int $mode = -1 [, float $threshold = .5 [, int $color = -1 ]]] )

Automatically crops an image according to the given mode.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

mode

One of the following constants:

IMG_CROP_DEFAULT
Attempts to use IMG_CROP_TRANSPARENT and if it fails it falls back to IMG_CROP_SIDES.
IMG_CROP_TRANSPARENT
Crops out a transparent background.
IMG_CROP_BLACK
Crops out a black background.
IMG_CROP_WHITE
Crops out a white background.
IMG_CROP_SIDES
Uses the 4 corners of the image to attempt to detect the background to crop.
IMG_CROP_THRESHOLD
Crops an image using the given threshold and color.
threshold

Specifies the tolerance in percent to be used while comparing the image color and the color to crop. The method used to calculate the color difference is based on the color distance in the RGB(a) cube.

Used only in IMG_CROP_THRESHOLD mode.

color

Either an RGB color value or a palette index.

Used only in IMG_CROP_THRESHOLD mode.

Dönen Değerler

Returns a cropped image resource on success başarısızlık durumunda FALSE döner. If no cropping would occur, or the complete image would be cropped, that is treated as failure, i.e. imagecrop() returns FALSE.

Örnekler

Örnek 1 Proper handling of auto-cropping

As noted in the return value section, imagecropauto() returns FALSE when there is either nothing to crop or the whole image would be cropped. In this example we have an image resource $im which should be automatically cropped only if there is something to crop; otherwise we want to proceed with the original image.

<?php
$cropped = imagecropauto($im, IMG_CROP_DEFAULT);
if ($cropped !== false) { // in case a new image resource was returned
    imagedestroy($im);    // we destroy the original image
    $im = $cropped;       // and assign the cropped image to $im
}
?>

Ayrıca Bakınız

  • imagecrop() - Crop an image to the given rectangle
imagecrop
imagedashedline
GD ve Resim İşlevleri


Kesikli çizgi çizer

imagecropauto
imagedestroy
GD ve Resim İşlevleri
PHP Manual

imagedashedline

(PHP 4, PHP 5, PHP 7)

imagedashedline — Kesikli çizgi çizer

Açıklama

bool imagedashedline ( resource $resim , int $x1 , int $y1 , int $x2 , int $y2 , int $renk )

Bu işlevin kullanımı önerilmemektedir. Yerine imagesetstyle() ve imageline() çiftini kullanın.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

x1

Sol üst köşenin X konumu.

y1

Sol üst köşenin Y konumu. Resmin sol üst köşesinin koordinatları 0, 0'dır.

x2

Sağ alt köşenin X konumu.

y2

Sağ alt köşenin Y konumu.

renk

Dolgu rengi. imagecolorallocate() ile döndürülen bir renk tanıtıcısı.

Dönen Değerler

Daima TRUE döner.

Örnekler

Örnek 1 - imagedashedline() örneği

<?php
// 100x100 bir tuval oluşturalım
$im = imagecreatetruecolor(100, 100);
$white = imagecolorallocate($im, 0xFF, 0xFF, 0xFF);

// Dikine bir kesikli çizgi çizelim
imagedashedline($im, 50, 25, 50, 75, $white);

// Resmi kaydedelim
imagepng($im, './dashedline.png');
imagedestroy($im);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Örnek 2 - Başka bir imagedashedline() örneği

<?php
// 100x100 bir tuval oluşturalım
$im = imagecreatetruecolor(100, 100);
$white = imagecolorallocate($im, 0xFF, 0xFF, 0xFF);

// Çizgi tarzını taımlayalım: İlk dört piksel beyaz,
// sonraki dört piksel renksiz. Bu, kesikli çizgi etkisi verir.
$style = Array(
                $white,
                $white,
                $white,
                $white,
                IMG_COLOR_TRANSPARENT,
                IMG_COLOR_TRANSPARENT,
                IMG_COLOR_TRANSPARENT,
                IMG_COLOR_TRANSPARENT
                );

imagesetstyle($im, $style);

// Kesikli çizgimizi çizelim
imageline($im, 50, 25, 50, 75, IMG_COLOR_STYLED);

// Resmi kaydedelim
imagepng($im, './imageline.png');
imagedestroy($im);
?>

Ayrıca Bakınız

  • imagesetstyle() - Çizgi tarzını ayarlar
  • imageline() - Bir çizgi çizer

imagecropauto
imagedestroy
GD ve Resim İşlevleri


Bir resmi bellekten siler

imagedashedline
imageellipse
GD ve Resim İşlevleri
PHP Manual

imagedestroy

(PHP 4, PHP 5, PHP 7)

imagedestroy — Bir resmi bellekten siler

Açıklama

bool imagedestroy ( resource $resim )

imagedestroy() işlevi resim için ayrılan belleği serbest bırakır.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - imagedestroy() örneği

<?php
// 100 x 100 bir tuval oluşturalım
$im = imagecreatetruecolor(100, 100);

// Üzerinde işlem yapalım ve kaydedelim

// İşimiz bitince resme ayrılan belleği serbest bırakalım
imagedestroy($im);
?>

imagedashedline
imageellipse
GD ve Resim İşlevleri


Bir elips çizer

imagedestroy
imagefill
GD ve Resim İşlevleri
PHP Manual

imageellipse

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

imageellipse — Bir elips çizer

Açıklama

bool imageellipse ( resource $resim , int $mx , int $my , int $genişlik , int $yükseklik , int $renk )

Belirtilen koordinatlar merkez olmak üzere bir elips çizer.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

mx

Merkezin X konumu.

my

Merkezin Y konumu.

genişlik

Elipsin genişliği.

yükseklik

Elipsin yüksekliği.

renk

Elipsin rengi. imagecolorallocate() tarafından döndürülen bir renk tanıtıcısı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - imageellipse() örneği

<?php

// Boş bir resim oluşturalım.
$image = imagecreatetruecolor(400, 300);

// Artalan rengini seçelim.
$bg = imagecolorallocate($image, 0, 0, 0);

// Artalanı seçtiğimiz renge boyayalım.
imagefill($image, 0, 0, $bg);

// Elips için bir renk seçelim.
$col_ellipse = imagecolorallocate($image, 255, 255, 255);

// Elipsi çizelim.
imageellipse($image, 200, 150, 300, 200, $col_ellipse);

// Resmi çıktılayalım.
header("Content-type: image/png");
imagepng($image);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Notlar

Bilginize:

Bu işlev GD'nin 2.0.2 veya sonraki bir sürümünü gerektirir.

Ayrıca Bakınız

  • imagefilledellipse() - İçi dolu bir elips çizer
  • imagearc() - Bir yay çizer

imagedestroy
imagefill
GD ve Resim İşlevleri


Resmi boyar

imageellipse
imagefilledarc
GD ve Resim İşlevleri
PHP Manual

imagefill

(PHP 4, PHP 5, PHP 7)

imagefill — Resmi boyar

Açıklama

bool imagefill ( resource $resim , int $x , int $y , int $renk )

Belirtilen koordinattan başlayarak (resmin üst sol köşesi 0.0'dır) belirtilen resmi renk ile boyar.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

x

Başlangıç noktasının X konumu.

y

Başlangıç noktasının Y konumu.

renk

Dolgu rengi. imagecolorallocate() ile oluşturulan bir renk tanıtıcısı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - imagefill() örneği

<?php

$im = imagecreatetruecolor(100, 100);

// artalan rengi kırmızı olsun
$renk = imagecolorallocate($im, 255, 0, 0);
imagefill($im, 0, 0, $renk);

header('Content-type: image/png');
imagepng($im);
imagedestroy($im);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ayrıca Bakınız

  • imagecolorallocate() - Bir resim için bir renk ayırır

imageellipse
imagefilledarc
GD ve Resim İşlevleri


Bir yay çizer ve içini doldurur

imagefill
imagefilledellipse
GD ve Resim İşlevleri
PHP Manual

imagefilledarc

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

imagefilledarc — Bir yay çizer ve içini doldurur

Açıklama

bool imagefilledarc ( resource $resim , int $mx , int $my , int $genişlik , int $yükseklik , int $baş , int $son , int $renk , int $tarz )

Belirtiren resim üzerinde merkez koordinatları verilen yay parçasını çizer.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

mx

Merkezin X konumu.

my

Merkezin Y konumu.

genişlik

Yay genişliği.

yükseklik

Yay yüksekliği.

baş

Derece cinsinden yayın başlangıç açısı.

son

Derece cinsinden yayın bitiş açısı. 0° saat 3 konumu olup yay saat yönünde çizilir.

renk

imagecolorallocate() ile oluşturulan bir renk tanıtıcısı.

tarz

Aşağıdaki olasılıklar bitsel VEYAlanarak belirtilir:

  1. IMG_ARC_PIE
  2. IMG_ARC_CHORD
  3. IMG_ARC_NOFILL
  4. IMG_ARC_EDGED
IMG_ARC_PIE ve IMG_ARC_CHORD sabitleri birlikte kullanılamaz. IMG_ARC_CHORD yayın başlangıç ve bitişini düz bir çizgiyle birleştirir (yay kirişi). IMG_ARC_PIE bir pasta dilimi üretir. IMG_ARC_NOFILL yayın ve kirişin sadece çizileceğini, içinin doldurulmayacağını belirtir. IMG_ARC_EDGED ile IMG_ARC_NOFILL birlikte yayın başlangıç ve bitişinin merkeze bir doğru ile birleştirileceğini belirtir; bu içi boş bir yay dilimini göstermenin en iyi yoludur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - 3 boyutlu bir pasta oluşturmak

<?php

// Tuvalimizi oluşturalım
$image = imagecreatetruecolor(100, 100);

// renkleri ayıralım
$beyaz    = imagecolorallocate($image, 0xFF, 0xFF, 0xFF);
$gri      = imagecolorallocate($image, 0xC0, 0xC0, 0xC0);
$koyugri  = imagecolorallocate($image, 0x90, 0x90, 0x90);
$mavi     = imagecolorallocate($image, 0x00, 0x00, 0x80);
$lacivert = imagecolorallocate($image, 0x00, 0x00, 0x50);
$kırmızı  = imagecolorallocate($image, 0xFF, 0x00, 0x00);
$kahve    = imagecolorallocate($image, 0x90, 0x00, 0x00);

// 3D etkisi oluşturalım
for ($i = 60; $i > 50; $i--) {
   imagefilledarc($image, 50, $i, 100, 50, 0, 45, $lacivert, IMG_ARC_PIE);
   imagefilledarc($image, 50, $i, 100, 50, 45, 75 , $lacivert, IMG_ARC_PIE);
   imagefilledarc($image, 50, $i, 100, 50, 75, 360 , $kahve, IMG_ARC_PIE);
}

imagefilledarc($image, 50, 50, 100, 50, 0, 45, $mavi, IMG_ARC_PIE);
imagefilledarc($image, 50, 50, 100, 50, 45, 75 , $gri, IMG_ARC_PIE);
imagefilledarc($image, 50, 50, 100, 50, 75, 360 , $kırmızı, IMG_ARC_PIE);

// Resim çıktılayalım
header('Content-type: image/png');
imagepng($image);
imagedestroy($image);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Notlar

Bilginize: Bu işlev GD'nin 2.0.1 veya sonraki sürümlerini gerektirir (2.0.28 veya sonraki sürümler önerilir).

imagefill
imagefilledellipse
GD ve Resim İşlevleri


İçi dolu bir elips çizer

imagefilledarc
imagefilledpolygon
GD ve Resim İşlevleri
PHP Manual

imagefilledellipse

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

imagefilledellipse — İçi dolu bir elips çizer

Açıklama

bool imagefilledellipse ( resource $resim , int $mx , int $my , int $genişlik , int $yükseklik , int $renk )

Belirtiren resim üzerinde merkez koordinatları verilen içi dolu elipsi çizer.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

mx

Merkezin X konumu.

my

Merkezin Y konumu.

genişlik

Elipsin genişliği.

yükseklik

Elipsin yüksekliği.

renk

Dolgu rengi. imagecolorallocate() ile oluşturulan bir renk tanıtıcısı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - imagefilledellipse() örneği

<?php

// Tuvalimizi oluşturalım
$image = imagecreatetruecolor(400, 300);

// Artalan rengini seçelim
$bg = imagecolorallocate($image, 0, 0, 0);

// Elipsin rengini seçelim
$beyaz = imagecolorallocate($image, 255, 255, 255);

// Beyaz elipsi çizelim
imagefilledellipse($image, 200, 150, 300, 200, $beyaz);

// Resmi çıktılayalım
header("Content-type: image/png");
imagepng($image);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Notlar

Bilginize: Bu işlev GD'nin 2.0.1 veya sonraki sürümlerini gerektirir (2.0.28 veya sonraki sürümler önerilir).

Ayrıca Bakınız

  • imageellipse() - Bir elips çizer
  • imagefilledarc() - Bir yay çizer ve içini doldurur

imagefilledarc
imagefilledpolygon
GD ve Resim İşlevleri


İçi dolu bir çokgen çizer

imagefilledellipse
imagefilledrectangle
GD ve Resim İşlevleri
PHP Manual

imagefilledpolygon

(PHP 4, PHP 5, PHP 7)

imagefilledpolygon — İçi dolu bir çokgen çizer

Açıklama

bool imagefilledpolygon ( resource $resim , array $noktalar , int $nokta_sayısı , int $renk )

imagefilledpolygon() belirtilen image üzerinde içi dolu bir çokgen çizer.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

noktalar

Çokgeni oluşturan kırık çizginin kırılma noktalarının x ve y koordinatlarını çizilme sırasıyla içeren dizi.

nokta_sayısı

Kırılma noktalarının sayısı; 3'ten büyük olmalıdır.

renk

Dolgu rengi. imagecolorallocate() ile oluşturulan bir renk tanıtıcısı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - imagefilledpolygon() örneği

<?php
// Kırık çizginin kırılma noktalarını içeren dizi
$values = array(
            40,  50,  // Nokta 1 (x, y)
            20,  240, // Nokta 2 (x, y)
            60,  60,  // Nokta 3 (x, y)
            240, 20,  // Nokta 4 (x, y)
            50,  40,  // Nokta 5 (x, y)
            10,  10   // Nokta 6 (x, y)
            );

// Tuvalimizi oluşturalım
$image = imagecreatetruecolor(250, 250);

// renkleri seçelim
$bg   = imagecolorallocate($image, 200, 200, 200);
$mavi = imagecolorallocate($image, 0, 0, 255);

// artalanı boyayalım
imagefilledrectangle($image, 0, 0, 249, 249, $bg);

// çokgeni çizelim
imagefilledpolygon($image, $values, 6, $mavi);

// resim çıktılayalım.
header('Content-type: image/png');
imagepng($image);
imagedestroy($image);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

imagefilledellipse
imagefilledrectangle
GD ve Resim İşlevleri


İçi dolu bir dikdörtgen çizer

imagefilledpolygon
imagefilltoborder
GD ve Resim İşlevleri
PHP Manual

imagefilledrectangle

(PHP 4, PHP 5, PHP 7)

imagefilledrectangle — İçi dolu bir dikdörtgen çizer

Açıklama

bool imagefilledrectangle ( resource $resim , int $x1 , int $y1 , int $x2 , int $y2 , int $renk )

Belirtiren resim üzerinde başlangıç ve bitiş koordinatları verilen dikdörtgeni renk ile boyayarak çizer. Resmin sol üst köşesinin koordinatları 0,0'dır.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

x1

1. noktanın X konumu

y1

1. noktanın Y konumu.

x2

2. noktanın X konumu

y2

2. noktanın Y konumu

renk

Dolgu rengi. imagecolorallocate() ile oluşturulan bir renk tanıtıcısı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - imagefilledrectangle() örneği

<?php
// Bir tuval oluşturalım
$im = imagecreatetruecolor(55, 30);
$beyaz = imagecolorallocate($im, 255, 255, 255);

// Beyaz bir dikdörtgen çizelim
imagefilledrectangle($im, 4, 4, 50, 25, $beyaz);

// resmi kaydedelim
imagepng($im, './beyazdikdortgenresmi.png');
imagedestroy($im);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

imagefilledpolygon
imagefilltoborder
GD ve Resim İşlevleri


Belli bir bölgeyi belli bir renge boyar

imagefilledrectangle
imagefilter
GD ve Resim İşlevleri
PHP Manual

imagefilltoborder

(PHP 4, PHP 5, PHP 7)

imagefilltoborder — Belli bir bölgeyi belli bir renge boyar

Açıklama

bool imagefilltoborder ( resource $resim , int $x , int $y , int $kenar , int $dolgu )

imagefilltoborder() işlevi sınırları kenar rengi ile tanımlanmış bir bölgeyi dolgu renginde boyar. Doldurma işleminin başlangıç noktası x ve y ile belirtilir. Resmin sol üst köşesinin koordinatları 0,0'dır.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

x

Başlangıç noktasının X konumu.

y

Başlangıç noktasının Y konumu.

kenar

Kenar rengi. imagecolorallocate() ile oluşturulan bir renk tanıtıcısı.

dolgu

Dolgu rengi. imagecolorallocate() ile oluşturulan bir renk tanıtıcısı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Bir elipsi belli bir renge boyamak

<?php
// Tuvalimizi oluşturup artalan rengini beyaz yapalım
$im = imagecreatetruecolor(100, 100);
imagefilledrectangle($im, 0, 0, 100, 100, imagecolorallocate($im, 255, 255, 255));

// Siyah kalemle bir elips çizelim
imageellipse($im, 50, 50, 50, 50, imagecolorallocate($im, 0, 0, 0));

// Kenar ve dolgu renklerini belirleyelim
$kenar = imagecolorallocate($im, 0, 0, 0);
$dolgu = imagecolorallocate($im, 255, 0, 0);

// Kenar rengine göre belirlenen kapalı alanı boyayalım
imagefilltoborder($im, 50, 50, $kenar, $dolgu);

// Resmi çıktılayıp belleği serbest bırakalım
header('Content-type: image/png');
imagepng($im);
imagedestroy($im);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

imagefilledrectangle
imagefilter
GD ve Resim İşlevleri


Bir resme bir süzgeç uygular

imagefilltoborder
imageflip
GD ve Resim İşlevleri
PHP Manual

imagefilter

(PHP 5, PHP 7)

imagefilter — Bir resme bir süzgeç uygular

Açıklama

bool imagefilter ( resource $resim , int $süzgeç [, int $d1 [, int $d2 [, int $d3 [, int $d4 ]]]] )

imagefilter() işlevi, türü süzgeç ile belirtilen süzgeci resim resmine uygular.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

süzgeç

süzgeç şunlardan biri olabilir:

  • IMG_FILTER_NEGATE: Resimdeki tüm renkleri zıt renge dönüştürür.
  • IMG_FILTER_GRAYSCALE: Resmi gri tonlamalı hale getirir.
  • IMG_FILTER_BRIGHTNESS: Resmin parlaklığın değiştirir. Parlaklık seviyesini belirtmek için d1 değiştirgesini kullanın.
  • IMG_FILTER_CONTRAST: Resmin karşıtlık seviyesini değiştirir. Karşıtlık seviyesini belirtmek için d1 değiştirgesini kullanın.
  • IMG_FILTER_COLORIZE: Rengi sizin belirtmeniz dışında IMG_FILTER_GRAYSCALE gibidir. Kırmızı, yeşil ve mavi renk seviyeleri belirtmek için sırayla d1, d2 ve d3 değiştirgelerini, alfa kanalı için de d4 değiştirgesini kullanın. Ana renklerin seviyesi 0 ile 255 arasında belirtilebilir.
  • IMG_FILTER_EDGEDETECT: Resmin kenarlarını vurgulamak için kenar algılaması kullanılır.
  • IMG_FILTER_EMBOSS: Resme kabartma uygular.
  • IMG_FILTER_GAUSSIAN_BLUR: Resmi Gauss yöntemiyle bulanıklaştırır.
  • IMG_FILTER_SELECTIVE_BLUR: Resmi bulanıklaştırır.
  • IMG_FILTER_MEAN_REMOVAL: Karalama taslak etkisi oluşturmak için silme işlemi uygular.
  • IMG_FILTER_SMOOTH: Resmin sert hatlarını yumuşatır. Yumuşatma seviyesini belirtmek için d1 değiştirgesini kullanın.
  • IMG_FILTER_PIXELATE: Resme mozaik etkisi verir. Mozaik boyutu için d1 mozaik etki kipini belirtmek için d2 değiştirgesini kullanın.

d1

  • IMG_FILTER_BRIGHTNESS: Parlaklık seviyesi.
  • IMG_FILTER_CONTRAST: Karşıtlık seviyesi.
  • IMG_FILTER_COLORIZE: Kırmızı bileşenin seviyesi.
  • IMG_FILTER_SMOOTH: Yumuşatma seviyesi.
  • IMG_FILTER_PIXELATE: Piksel cinsinden mozaik boyu.

d2

  • IMG_FILTER_COLORIZE: Yeşil bileşenin seviyesi.
  • IMG_FILTER_PIXELATE: Gelişkin mozaik etkisinin kullanılıp kullanılmayacağı (FALSE öntanımlıdır).

d3

  • IMG_FILTER_COLORIZE: Mavi bileşenin seviyesi.

d4

  • IMG_FILTER_COLORIZE: Alfa kanalı. 0-127 arasında belirtilebilir. 0 tamamen mat, 127 ise tamamen şeffaf demektir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | Mozaik desteği (IMG_FILTER_PIXELATE) eklendi.
5.2.5 | IMG_FILTER_COLORIZE için alfa kanalı desteği eklendi.

Örnekler

Örnek 1 - imagefilter() gri tonlama örneği

<?php
$im = imagecreatefrompng('dave.png');

if($im && imagefilter($im, IMG_FILTER_GRAYSCALE))
{
    echo 'Resme gri tonlama uygulandı.';

    imagepng($im, 'dave.png');
}
else
{
    echo 'Resme gri tonlama uygulanamadı.';
}

imagedestroy($im);
?>

Örnek 2 - imagefilter() parlaklık örneği

<?php
$im = imagecreatefrompng('sean.png');

if($im && imagefilter($im, IMG_FILTER_BRIGHTNESS, 20))
{
    echo 'Resmin parlaklığı değişti.';

    imagepng($im, 'sean.png');
    imagedestroy($im);
}
else
{
    echo 'Resmin parlaklığı değiştirilemedi.';
}
?>

Örnek 3 - imagefilter() renklendirme örneği

<?php
$im = imagecreatefrompng('philip.png');

/* K, Y, M olarak 0, 255, 0 yeşildir */
if($im && imagefilter($im, IMG_FILTER_COLORIZE, 0, 255, 0))
{
    echo 'Resim yeşertildi.';

    imagepng($im, 'philip.png');
    imagedestroy($im);
}
else
{
    echo 'Resim yeşertilemedi.';
}
?>

Örnek 4 imagefilter() negatiflik örneği

<?php
// İşlevin taşınabilir olması için, yani imagefilter() kullanamadığımız
// durumlar için kendi negatiflik işlevimizi yazalım
function negate($im)
{
    if(function_exists('imagefilter'))
    {
        return imagefilter($im, IMG_FILTER_NEGATE);
    }

    for($x = 0; $x < imagesx($im); ++$x)
    {
        for($y = 0; $y < imagesy($im); ++$y)
        {
            $index = imagecolorat($im, $x, $y);
            $rgb = imagecolorsforindex($index);
            $color = imagecolorallocate($im, 255 - $rgb['red'],
                       255 - $rgb['green'], 255 - $rgb['blue']);

            imagesetpixel($im, $x, $y, $color);
        }
    }

    return(true);
}

$im = imagecreatefromjpeg('kalle.jpg');

if($im && negate($im))
{
    echo 'Resmin negatifi başarıyla elde edildi.';

    imagejpeg($im, 'kalle.jpg', 100);
    imagedestroy($im);
}
else
{
    echo 'Resmin negatifi elde edilemedi.';
}
?>

Örnek 5 imagefilter() mozaikleştirme örneği

<?php
// PHP logosunu yükleyelim, farkları göstermek için bize iki resim lazım
$logo1 = imagecreatefrompng('./php.png');
$logo2 = imagecreatefrompng('./php.png');

// Üzerinde farkları göstermek için bir tuval oluşturalım
$output = imagecreatetruecolor(imagesx($logo1) * 2, imagesy($logo1));

// Her örneğe 3 piksellik mozaikleştirme uygulayalım
imagefilter($logo1, IMG_FILTER_PIXELATE, 3);
imagefilter($logo2, IMG_FILTER_PIXELATE, 3, true);

// Farkları çıktı resminde karıştıralım
imagecopy($output, $logo1, 0, 0, 0, 0, imagesx($logo1) - 1,
                                       imagesy($logo1) - 1);
imagecopy($output, $logo2, imagesx($logo2), 0, 0, 0,
           imagesx($logo2) - 1, imagesy($logo2) - 1);
imagedestroy($logo1);
imagedestroy($logo2);

// Farkları çıktılayalım
header('Content-Type: image/png');
imagepng($output);
imagedestroy($output);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Notlar

Bilginize: Bu işlev sadece, PHP, PHP paketinde bulunan GD kütüphanesi ile derlenmişse kullanılabilir.

Ayrıca Bakınız

  • imageconvolution() - Bir konum ve katsayı ile 3x3'lük bir evrişim matrisini uygular

imagefilltoborder
imageflip
GD ve Resim İşlevleri


Flips an image using a given mode

imagefilter
imagefontheight
GD ve Resim İşlevleri
PHP Manual

imageflip

(PHP 5 >= 5.5.0, PHP 7)

imageflip — Flips an image using a given mode

Açıklama

bool imageflip ( resource $image , int $mode )

Flips the image image using the given mode.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

mode

Flip mode, this can be one of the IMG_FLIP_* constants:

Constant | Meaning
IMG_FLIP_HORIZONTAL | Flips the image horizontally.
IMG_FLIP_VERTICAL | Flips the image vertically.
IMG_FLIP_BOTH | Flips the image both horizontally and vertically.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Flips an image vertically

This example uses the IMG_FLIP_VERTICAL constant.

<?php
// File
$filename = 'phplogo.png';

// Content type
header('Content-type: image/png');

// Load
$im = imagecreatefrompng($filename);

// Flip it vertically
imageflip($im, IMG_FLIP_VERTICAL);

// Output
imagejpeg($im);
imagedestroy($im);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Output of example: Vertically flipped image

Örnek 2 Flips the image horizontally

This example uses the IMG_FLIP_HORIZONTAL constant.

<?php
// File
$filename = 'phplogo.png';

// Content type
header('Content-type: image/png');

// Load
$im = imagecreatefrompng($filename);

// Flip it horizontally
imageflip($im, IMG_FLIP_HORIZONTAL);

// Output
imagejpeg($im);
imagedestroy($im);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Output of example: Horizontally flipped image

imagefilter
imagefontheight
GD ve Resim İşlevleri


Yazı tipi yüksekliğini döndürür

imageflip
imagefontwidth
GD ve Resim İşlevleri
PHP Manual

imagefontheight

(PHP 4, PHP 5, PHP 7)

imagefontheight — Yazı tipi yüksekliğini döndürür

Açıklama

int imagefontheight ( int $yazıtipi )

Belirtilen yazı tipinin bir karakterinin piksel cinsinden yüksekliğini döndürür.

Değiştirgeler

yazıtipi

Belirtilecek değer, Latin2 kodlamalı yerleşik yazı tipleri için 1, 2, 3, 4, 5 (daha büyük numara daha yüksek yazı tipine karşılıktır) veya imageloadfont() ile tanımlanmış kendi yazı tipi betimleyicilerinizden biri olabilir.

Dönen Değerler

Piksel cinsinden yükseklik döner.

Örnekler

Örnek 1 - Yerleşik yazı tipleri üzerinde imagefontheight()

<?php
echo 'Yazı tipi yüksekliği: ' . imagefontheight(4) . ' piksel';
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Yazı tipi yüksekliği: 16 piksel

Örnek 2 - imagefontheight() ile imageloadfont() işlevinin birlikte kullanımı

<?php
// Bir .gdf yazı tipi yükleyelim
$font = imageloadfont('anonymous.gdf');

echo 'Yazı tipi yüksekliği: ' . imagefontheight($font) . ' piksel';
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Yazı tipi yüksekliği: 43 piksel

Ayrıca Bakınız

  • imagefontwidth() - Yazı tipi genişliğini döndürür
  • imageloadfont() - Yeni bir bit eşlemli yazı tipi yükler

imageflip
imagefontwidth
GD ve Resim İşlevleri


Yazı tipi genişliğini döndürür

imagefontheight
imageftbbox
GD ve Resim İşlevleri
PHP Manual

imagefontwidth

(PHP 4, PHP 5, PHP 7)

imagefontwidth — Yazı tipi genişliğini döndürür

Açıklama

int imagefontwidth ( int $yazıtipi )

Belirtilen yazı tipindeki bir karakterin piksel cinsinden genişliğini döndürür.

Değiştirgeler

yazıtipi

Belirtilecek değer, Latin2 kodlamalı yerleşik yazı tipleri için 1, 2, 3, 4, 5 (daha büyük numara daha yüksek yazı tipine karşılıktır) veya imageloadfont() ile tanımlanmış kendi yazı tipi betimleyicilerinizden biri olabilir.

Dönen Değerler

Piksel cinsinden genişlik döndürür.

Örnekler

Örnek 1 - Yerleşik yazı tipleri üzerinde imagefontwidth()

<?php
echo 'Yazı tipi genişliği: ' . imagefontwidth(4) . ' piksel';
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Yazı tipi genişliği: 8 piksel

Örnek 2 imagefontwidth() ile imageloadfont() işlevinin birlikte kullanımı

<?php
// Bir .gdf yazı tipi yükleyelim
$font = imageloadfont('anonymous.gdf');

echo 'Yazı tipi genişliği: ' . imagefontwidth($font) . ' piksel';
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Yazı tipi genişliği: 23 piksel

Ayrıca Bakınız

  • imagefontheight() - Yazı tipi yüksekliğini döndürür
  • imageloadfont() - Yeni bir bit eşlemli yazı tipi yükler

imagefontheight
imageftbbox
GD ve Resim İşlevleri


Bir FreeType2 yazı tipi ile yazılacak bir metnin çerçevesini hesaplar

imagefontwidth
imagefttext
GD ve Resim İşlevleri
PHP Manual

imageftbbox

(PHP 4 >= 4.0.7, PHP 5, PHP 7)

imageftbbox — Bir FreeType2 yazı tipi ile yazılacak bir metnin çerçevesini hesaplar

Açıklama

array imageftbbox ( float $boyut , float $açı , string $yazıtipi , string $metin [, array $ekbilgi ] )

Bu işlev, bir FreeType2 yazı tipi ile yazılacak bir metnin çerçevesini hesaplar.

Değiştirgeler

boyut

Yazı tipi boyutu. Birimi kullandığınız GD sürümüne bağlıdır. GD1 için piksel, GD2 için punto olarak belirtilir.

açı

Metnin yazım açısı.

yazıtipi

FreeType2 yazı tipi dosyasının ismi. Bir URL olarak belirtilebilir. PHP'nin kullandığı GD kütüphanesinin sürümüne bağlı olarak, / ile başlamayan bir FreeType2 dosya ismine .ttf uzantısı eklenir ve kütüphane bu dosya ismini kütüphanede tanımlı dizinlerde arar.

metin

Çerçevesi hesaplanacak metin.

ekbilgi

ekbilgi için olası dizi indisleri
Anahtar | Türü | Anlamı
linespacing | float | Satırlar arasındaki boşluğu tanımlar.

Dönen Değerler

Metin çerçevesinin dört köşesinin koordinatlarını içeren 8 elemanlı bir dizi ile döner:

0 | Sol alt köşenin X konumu
1 | Sol alt köşenin Y konumu
2 | Sağ alt köşenin X konumu
3 | Sağ alt köşenin Y konumu
4 | Sağ üst köşenin X konumu
5 | Sağ üst köşenin Y konumu
6 | Sol üst köşenin X konumu
7 | Sol üst köşenin Y konumu

Noktalar açıdan bağımsız olarak metne görelidir. Yani, "sol üst" denince metne yatay olarak bakarkenki sol üst köşe kastedilmektedir.

Örnekler

Örnek 1 - imageftbbox() örneği

<?php
// Tuvalimizi oluşturalım
$im = imagecreatetruecolor(300, 150);
$black = imagecolorallocate($im, 0, 0, 0);
$white = imagecolorallocate($im, 255, 255, 255);

// Artalan rengi beyaz olsun
imagefilledrectangle($im, 0, 0, 299, 299, $white);

// Yazı tipi dosyamızın yolu
$font = './arial.ttf';

// Metin çerçevesini hesaplatalım
$bbox = imageftbbox(10, 0, $font, 'The PHP Documentation Group');

// Metnin yazılmaya başlanacağı koordinatlar
$x = $bbox[0] + (imagesx($im) / 2) - ($bbox[4] / 2) - 5;
$y = $bbox[1] + (imagesy($im) / 2) - ($bbox[5] / 2) - 5;

imagefttext($im, 10, 0, $x, $y, $black, $font, 'The PHP Documentation Group');

// Resmi çıktılayalım
header('Content-type: image/png');

imagepng($im);
imagedestroy($im);
?>

Notlar

Bilginize: Bu işlev GD'nin 2.0.1 veya sonraki sürümlerini gerektirir (2.0.28 veya sonraki sürümler önerilir).

Bilginize: Bu işlev sadece, PHP, freetype desteği (--with-freetype-dir=DİZİN seçeneği) ile derlenmişse kullanılabilir.

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.5 | ekbilgi değiştirgesi isteğe bağlı yapıldı.

imagefontwidth
imagefttext
GD ve Resim İşlevleri


Bir metni bir resme bir FreeType 2 yazı tipini kullanarak yazar

imageftbbox
imagegammacorrect
GD ve Resim İşlevleri
PHP Manual

imagefttext

(PHP 4 >= 4.0.7, PHP 5, PHP 7)

imagefttext — Bir metni bir resme bir FreeType 2 yazı tipini kullanarak yazar

Açıklama

array imagefttext ( resource $resim , float $boyut , float $açı , int $x , int $y , int $renk , string $yazıtipi , string $metin [, array $ekbilgi ] )

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

boyut

Kullanılacak yazı tipinin punto olarak boyutu.

açı

Derece cinsinden açı. Soldan sağa yazılan bir metnin açısı 0 derecedir. Daha büyük değerler ters saat yönünde belirtilmiş varsayılır. Örneğin 90 derecelik bir metin aşağıdan yukarı doğru yazılır.

x

x ve y ile belirtilen koordinatlar ilk harfin taban noktasını (kabaca harfin sol alt köşesi) tanımlar. Bu tanımlama, koordinatların harfin sol üst köşesini tanımladığı imagestring() işlevinden farklıdır. Resmin sol üst köşesinin koordinatları 0, 0'dır.

y

x değiştirgesine bakınız.

renk

Renk indisi. Negatif bir renk indisi kenar yumuşatmayı kapatır. imagecolorallocate() işlevine bakınız.

yazıtipi

Kullanılacak FreeType2 yazı tipi dosyasının yolu.

PHP'nin kullandığı GD kütüphanesinin sürümüne bağlı olarak, / ile başlamayan bir FreeType2 dosya ismine .ttf uzantısı eklenir ve kütüphane bu dosya ismini kütüphanede tanımlı dizinlerde arar.

GD kütüphanesinin 2.0.18'den küçük sürümlerini kullanıyorsanız, farklı yazıtipi dosyalarının aralarına noktalı virgül değil boşluk karakteri koymalısınız. Bu kurala dikkat etmezseniz şöyle bir uyarı alırsınız: Warning: Could not find/open font (Uyarı: Yazı tipi bulunamadı veya açılamadı). Boşluk içeren dosya yollarının varlığında bu sürümler için tek çözüm yazı tiplerinin boşluk içermeyen dosya yollarına taşınmasıdır.

Yazı tiplerinin betikle aynı dizinde bulunduğu durumlarda herhangi bir sorun çıkmaması için aşağıdaki çözüm kullanılabilir.

<?php
// GD ortam değişkenini tanımlayalım
putenv('GDFONTPATH=' . realpath('.'));

// Kullanılacak yaza tipinin ismi (dikkat: .ttf uzantısı yok)
$font = 'freesans';
?>

metin

Resme yerleştirilecek metin.

ekbilgi

ekbilgi için olası dizi indisleri
Anahtar | Türü | Anlamı
linespacing | float | Satırlar arasındaki boşluğu tanımlar.

Dönen Değerler

Metin çerçevesinin dört köşesinin koordinatlarını içeren 8 elemanlı bir dizi ile döner:

0 | Sol alt köşenin X konumu
1 | Sol alt köşenin Y konumu
2 | Sağ alt köşenin X konumu
3 | Sağ alt köşenin Y konumu
4 | Sağ üst köşenin X konumu
5 | Sağ üst köşenin Y konumu
6 | Sol üst köşenin X konumu
7 | Sol üst köşenin Y konumu

Örnekler

Örnek 1 - imagefttext() örneği

<?php
// 300x100 bir tuval oluşturalım
$im = imagecreatetruecolor(300, 100);
$red = imagecolorallocate($im, 0xFF, 0x00, 0x00);
$black = imagecolorallocate($im, 0x00, 0x00, 0x00);

// Artalan rengi kırmızı olsun
imagefilledrectangle($im, 0, 0, 299, 99, $red);

// ttf dosyamızın yolu
$font_file = './arial.ttf';

// 'PHP Manual' metnini 13 puntoluk yazdıralım
imagefttext($im, 13, 0, 105, 55, $black, $font_file, 'PHP Manual');

// Resmi tarayıcıya gönderelim
header('Content-Type: image/png');

imagepng($im);
imagedestroy($im);
?>

Notlar

Bilginize: Bu işlev GD'nin 2.0.1 veya sonraki sürümlerini gerektirir (2.0.28 veya sonraki sürümler önerilir).

Bilginize: Bu işlev sadece, PHP, freetype desteği (--with-freetype-dir=DİZİN seçeneği) ile derlenmişse kullanılabilir.

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.5 | ekbilgi isteğe bağlı yapıldı.

imageftbbox
imagegammacorrect
GD ve Resim İşlevleri


Bir GD resmine gamma düzeltmesi uygular

imagefttext
imagegd2
GD ve Resim İşlevleri
PHP Manual

imagegammacorrect

(PHP 4, PHP 5, PHP 7)

imagegammacorrect — Bir GD resmine gamma düzeltmesi uygular

Açıklama

bool imagegammacorrect ( resource $resim , float $girdigamma , float $çıktıgamma )

resim ile belirtilen GD resmine belirtilen girdi ve çıktı gamma düzeltmelerini uygular.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

girdigamma

Girdi gamması.

çıktıgamma

Çıktı gamması.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - imagegammacorrect() örneği

<?php
// Bir resim yükleyelim
$im = imagecreatefromgif('php.gif');

// Gammayı düzeltelim, çıktı = 1.537
imagegammacorrect($im, 1.0, 1.537);

// Resmi kaydedip belleği serbest bırakalım
imagegif($im, './php_gamma_corrected.gif');
imagedestroy($im);
?>

imagefttext
imagegd2
GD ve Resim İşlevleri


Tarayıcıya veya bir dosyaya bir GD2 resmi çıktılar

imagegammacorrect
imagegd
GD ve Resim İşlevleri
PHP Manual

imagegd2

(PHP 4 >= 4.0.7, PHP 5, PHP 7)

imagegd2 — Tarayıcıya veya bir dosyaya bir GD2 resmi çıktılar

Açıklama

bool imagegd2 ( resource $resim [, string $dosyaismi [, int $parça_boyutu [, int $tür ]]] )

Bir GD2 resmini dosyaismi ile belirtilen dosyaya çıktılar.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

dosyaismi

GD2 resminin kaydedileceği dosyanın yolu. Belirtilmezse veya NULL verilirse ham resim akımı doğrudan tarayıcıya çıktılanır.

parça_boyutu

Parça boyutu.

tür

IMG_GD2_RAW veya IMG_GD2_COMPRESSED olabilir. IMG_GD2_RAW öntanımlıdır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Bir GD2 resminin çıktılanması

<?php
// Bir tuval oluşturup üzerine bir metin çizelim
$im = imagecreatetruecolor(120, 20);
$text_color = imagecolorallocate($im, 233, 14, 91);
imagestring($im, 1, 5, 5,  "A Simple Text String", $text_color);

// Resmi çıktılayalım
imagegd2($im);

// Belleği serbest bırakalım
imagedestroy($im);
?>

Örnek 2 - Bir GD2 resminin kaydedilmesi

<?php
// Bir tuval oluşturup üzerine bir metin çizelim
$im = imagecreatetruecolor(120, 20);
$text_color = imagecolorallocate($im, 233, 14, 91);
imagestring($im, 1, 5, 5,  "A Simple Text String", $text_color);

// gd2 resmini kaydedelim
// GD2 resimlerin dosya biçemi .gd2'dir.
// http://www.libgd.org/GdFileFormats adresine bakınız
imagegd2($im, 'simple.gd');

// Belleği serbest bırakalım
imagedestroy($im);
?>

Notlar

Bilginize: Bu işlev GD'nin 2.0.1 veya sonraki sürümlerini gerektirir (2.0.28 veya sonraki sürümler önerilir).

Bilginize:

GD2 biçemi resim parçalarının hızlı yüklenebilmesi için kullanılan bir resim biçemidir. GD2 biçeminin sadece GD2 uyumlu uygulamalarda kullanılabileceğine dikkat ediniz.

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.2 | parça_boyutu ve tür değiştirgeleri eklendi.

Ayrıca Bakınız

  • imagegd() - Tarayıcıya veya bir dosyaya bir GD resmi çıktılar

imagegammacorrect
imagegd
GD ve Resim İşlevleri


Tarayıcıya veya bir dosyaya bir GD resmi çıktılar

imagegd2
imagegetclip
GD ve Resim İşlevleri
PHP Manual

imagegd

(PHP 4 >= 4.0.7, PHP 5, PHP 7)

imagegd — Tarayıcıya veya bir dosyaya bir GD resmi çıktılar

Açıklama

bool imagegd ( resource $resim [, string $dosyaismi ] )

Bir GD resmini dosyaismi ile belirtilen dosyaya çıktılar.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

dosyaismi

GD resminin kaydedileceği dosyanın yolu. Belirtilmezse veya NULL verilirse ham resim akımı doğrudan tarayıcıya çıktılanır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Bir GD resminin çıktılanması

<?php
// Bir tuval oluşturup üzerine bir metin çizelim
$im = imagecreatetruecolor(120, 20);
$text_color = imagecolorallocate($im, 233, 14, 91);
imagestring($im, 1, 5, 5,  "A Simple Text String", $text_color);

// Resmi çıktılayalım
imagegd($im);

// Belleği serbest bırakalım
imagedestroy($im);
?>

Örnek 2 - Bir GD resminin kaydedilmesi

<?php
// Bir tuval oluşturup üzerine bir metin çizelim
$im = imagecreatetruecolor(120, 20);
$text_color = imagecolorallocate($im, 233, 14, 91);
imagestring($im, 1, 5, 5,  "A Simple Text String", $text_color);

// gd resmini kaydedelim
// GD resimlerin dosya biçemi .gd'dir.
// http://www.libgd.org/GdFileFormats adresine bakınız
imagegd($im, 'simple.gd');

// Belleği serbest bırakalım
imagedestroy($im);
?>

Notlar

Bilginize:

GD biçemi resim parçalarının hızlı yüklenebilmesi için kullanılan bir resim biçemidir. GD biçeminin sadece GD uyumlu uygulamalarda kullanılabileceğine dikkat ediniz.

Ayrıca Bakınız

  • imagegd2() - Tarayıcıya veya bir dosyaya bir GD2 resmi çıktılar

imagegd2
imagegetclip
GD ve Resim İşlevleri


Get the clipping rectangle

imagegd
imagegif
GD ve Resim İşlevleri
PHP Manual

imagegetclip

(PHP 7.2)

imagegetclip — Get the clipping rectangle

Açıklama

array imagegetclip ( resource $im )

imagegetclip() retrieves the current clipping rectangle, i.e. the area beyond which no pixels will be drawn.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

Dönen Değerler

The function returns an indexed array with the coordinates of the clipping rectangle which has the following entries:

  • x-coordinate of the upper left corner
  • y-coordinate of the upper left corner
  • x-coordinate of the lower right corner
  • y-coordinate of the lower right corner

Örnekler

Örnek 1 imagegetclip() example

Setting and retrieving the clipping rectangle.

<?php
$im = imagecreate(100, 100);
imagesetclip($im, 10,10, 89,89);
print_r(imagegetclip($im));

Yukarıdaki örneğin çıktısı:

Array
(
    [0] => 10
    [1] => 10
    [2] => 89
    [3] => 89
)

Ayrıca Bakınız

  • imagesetclip() - Set the clipping rectangle
imagegd
imagegif
GD ve Resim İşlevleri


Bir dosyaya veya tarayıcıya bir GIF resmi çıktılar

imagegetclip
imagegrabscreen
GD ve Resim İşlevleri
PHP Manual

imagegif

(PHP 4, PHP 5, PHP 7)

imagegif — Bir dosyaya veya tarayıcıya bir GIF resmi çıktılar

Açıklama

bool imagegif ( resource $resim [, string $dosyaismi ] )

imagegif() işlevi resim ile belirtilen resmin GIF biçemlisini oluşturup dosyaismi dosyasına çıktılar. resim değiştirgesi imagecreate() veya imagecreatefrom* işlevleri tarafından oluşturulmuş bir resmi belirtmelidir.

Resmin artalanı imagecolortransparent() ile şeffaf yapılmışsa dosya biçemi GIF89a, aksi takdirde GIF87a'dır.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

dosyaismi

GIF resminin kaydedileceği dosyanın yolu. Belirtilmezse veya NULL verilirse ham resim akımı doğrudan tarayıcıya çıktılanır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - imagegif() ile bir resmi çıktılamak

<?php
// Boş bir resim oluşturalım
$im = imagecreatetruecolor(100, 100);

// Artalan rengi beyaz olsun
imagefilledrectangle($im, 0, 0, 99, 99, 0xFFFFFF);

// Resme bir metin çizelim
imagestring($im, 3, 40, 20, 'GD Library', 0xFFBA00);

// Resmi tarayıcıya gönderelim
header('Content-type: image/gif');

imagegif($im);
imagedestroy($im);
?>

Örnek 2 - Bir PNG resmini imagegif() ile bir GIF resmine dönüştürmek

<?php

// Resmi PNG olarak yükleyelim
$png = imagecreatefrompng('./php.png');

// Bir GIF olarak kaydedelim
imagegif($png, './php.gif');

// Belleği serbest bırakalım
imagedestroy($png);

// İşimiz bitti
echo 'PNG başarıyla GIF yapıldı!';
?>

Notlar

Bilginize:

GIF desteği GD kütüphanesinin 1.6 sürümünde tamamen kaldırılmış, gd-2.0.28'den itibaren yeniden etkin olmuştur.

Aşağıdaki kod parçası GD desteğinin durumuna bakarak taşınabilir PHP uygulamaları yazmanızı sağlar:

<?php
// Boş bir resim oluşturalım
$im = imagecreatetruecolor(100, 100);

// Resim üzerinde bazı işlemler yapalım

// Resmi çıktılayalım
if(function_exists('imagegif'))
{
    // GIF için
    header('Content-type: image/gif');

    imagegif($im);
}
elseif(function_exists('imagejpeg'))
{
    // JPEG için
    header('Content-type: image/jpeg');

    imagejpeg($im, NULL, 100);
}
elseif(function_exists('imagepng'))
{
    // PNG için
    header('Content-type: image/png');

    imagepng($im);
}
elseif(function_exists('imagewbmp'))
{
    // WBMP için
    header('Content-type: image/vnd.wap.wbmp');

    imagewbmp($im);
}
else
{
    imagedestroy($im);

    die('Bu PHP sunucusunda resim desteği yok');
}

// Resim desteği varsa belleği serbest bırakalım
if($im)
{
    imagedestroy($im);
}
?>

Bilginize:

PHP 4.0.2'den itibaren desteklenen resim biçemlerini bulmak için function_exists() yerine imagetypes() işlevini kullanabilirsiniz:

<?php
if(imagetypes() & IMG_GIF)
{
    header('Content-type: image/gif');
    imagegif($im);
}
elseif(imagetypes() & IMG_JPG)
{
    /* ... vb. */
}
?>

Ayrıca Bakınız

  • imagepng() - Tarayıcıya veya bir dosyaya bir PNG resmi çıktılar
  • imagewbmp() - Resmi bir dosyaya veya tarayıcıya çıktılar
  • imagejpeg() - Tarayıcıya veya bir dosyaya bir JPEG resmi çıktılar
  • imagetypes() - Kurulu PHP'nin desteklediği resim türlerini döndürür

imagegetclip
imagegrabscreen
GD ve Resim İşlevleri


Ekran görüntüsünü yakalar

imagegif
imagegrabwindow
GD ve Resim İşlevleri
PHP Manual

imagegrabscreen

(PHP 5 >= 5.2.2, PHP 7)

imagegrabscreen — Ekran görüntüsünü yakalar

Açıklama

resource imagegrabscreen ( void )

Ekranın tamamının bir görüntüsünü yakalar.

Dönen Değerler

Hata oluşursa FALSE aksi takdirde bir resim tanıtıcısı ile döner.

Örnekler

Örnek 1 - imagegrabscreen() örneği

Bu örnekte ekran görüntüsünün nasıl alınıp bir PNG resmi olarak kaydedileceği gösterilmiştir.

<?php
$im = imagegrabscreen();
imagepng($im, "ekranım.png");
imagedestroy($im);
?>

Notlar

Bilginize:

Bu işlev sadece Windows'ta kullanılabilmektedir.

Ayrıca Bakınız

  • imagegrabwindow() - Bir pencereyi yakalar

imagegif
imagegrabwindow
GD ve Resim İşlevleri


Bir pencereyi yakalar

imagegrabscreen
imageinterlace
GD ve Resim İşlevleri
PHP Manual

imagegrabwindow

(PHP 5 >= 5.2.2, PHP 7)

imagegrabwindow — Bir pencereyi yakalar

Açıklama

resource imagegrabwindow ( int $pencere [, int $istemci_alanı = 0 ] )

Bir pencere tanıtıcısı (pencerenin COM örneğinin HWND özelliği) kullanarak bir pencerenin tamamının veya sadece içinin görüntüsünü yakalar.

Değiştirgeler

pencere

Görüntüsü yakalanacak pencerenin COM örneğinin HWND özelliği.

istemci_alanı

Pencerenin istemci alanı.

Dönen Değerler

Hata oluşursa FALSE aksi takdirde bir resim tanıtıcısı ile döner.

Hatalar/İstisnalar

pencere geçersiz bir tanıtıcı içeriyorsa bir E_NOTICE, Windows API çok eskiyse bir E_WARNING çıktılanır.

Örnekler

Örnek 1 - imagegrabwindow() örneği

Bir pencere yakalamak için (örneğin IE):

<?php
$browser = new COM("InternetExplorer.Application");
$handle = $browser->HWND;
$browser->Visible = true;
$im = imagegrabwindow($handle);
$browser->Quit();
imagepng($im, "iesnap.png");
imagedestroy($im);
?>

Bir pencerenin sadece içeriğini yakalamak için (örneğin IE):

<?php
$browser = new COM("InternetExplorer.Application");
$handle = $browser->HWND;
$browser->Visible = true;
$browser->Navigate("http://www.libgd.org");

/* Hala çalışıyor mu? */
while ($browser->Busy) {
    com_message_pump(4000);
}
$im = imagegrabwindow($handle, 0);
$browser->Quit();
imagepng($im, "iesnap.png");
imagedestroy($im);
?>

Notlar

Bilginize:

Bu işlev sadece Windows üzerinde kullanılabilir.

Ayrıca Bakınız

  • imagegrabscreen() - Ekran görüntüsünü yakalar

imagegrabscreen
imageinterlace
GD ve Resim İşlevleri


Geçişimliliği açıp kapar

imagegrabwindow
imageistruecolor
GD ve Resim İşlevleri
PHP Manual

imageinterlace

(PHP 4, PHP 5, PHP 7)

imageinterlace — Geçişimliliği açıp kapar

Açıklama

int imageinterlace ( resource $resim [, int $geçişim = 0 ] )

imageinterlace() işlevi geçişim bitini açıp kapar.

Eğer geçişim biti etkin ve resim bir JPEG resmi olarak kullanılmışsa resim aşamalı JPEG olarak oluşturulur.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

geçişim

Sıfırdan farklıysa resim geçişimli olur aksi takdirde geçişim biti kapatılır.

Dönen Değerler

Geçişim biti ayarlanabilmişse 1 aksi takdirde 0 döner.

Örnekler

Örnek 1 - imageinterlace() ile geçişimi etkin kılmak

<?php
// Bir resim taslağı oluşturalım
$im = imagecreatefrom('php.gif');

// Geçişimi etkin kılalım
imageinterlace($im, true);

// Geçişimli resmi kaydedelim
imagegif($im, './php_interlaced.gif');
imagedestroy($im);
?>

imagegrabwindow
imageistruecolor
GD ve Resim İşlevleri


Bir resmin gerçek renkli olup olmadığını bulur

imageinterlace
imagejpeg
GD ve Resim İşlevleri
PHP Manual

imageistruecolor

(PHP 4 >= 4.3.2, PHP 5, PHP 7)

imageistruecolor — Bir resmin gerçek renkli olup olmadığını bulur

Açıklama

bool imageistruecolor ( resource $resim )

imageistruecolor() işlevi belirtilen resmin bir gerçek renkli resim olup olmadığına bakar.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

Dönen Değerler

resim gerçek renkli ise TRUE aksi takdirde FALSE döner.

Örnekler

Örnek 1 - imageistruecolor() ile resmin gerçek renkli olup olmadığının saptanması

<?php
// $im bir resim tanıtıcısı olsun

// Bakalım resim gerçek renkli miymiş?
if(!imageistruecolor($im))
{
    // Değilse gerçek renkli yeni bir taslak oluşturalım
    $tc = imagecreatetruecolor(imagesx($im), imagesy($im));

    imagecopy($tc, $im, 0, 0, 0, 0, imagesx($im), imagesy($im));
    imagedestroy($im);

    $im = $tc;
    $tc = NULL;
}

// Resim taslağıyla çalışmaya devam
?>

Notlar

Bilginize: Bu işlev GD'nin 2.0.1 veya sonraki sürümlerini gerektirir (2.0.28 veya sonraki sürümler önerilir).

Ayrıca Bakınız

  • imagecreatetruecolor() - Yeni bir gerçek renkli resim oluşturur

imageinterlace
imagejpeg
GD ve Resim İşlevleri


Tarayıcıya veya bir dosyaya bir JPEG resmi çıktılar

imageistruecolor
imagelayereffect
GD ve Resim İşlevleri
PHP Manual

imagejpeg

(PHP 4, PHP 5, PHP 7)

imagejpeg — Tarayıcıya veya bir dosyaya bir JPEG resmi çıktılar

Açıklama

bool imagejpeg ( resource $resim [, string $dosyaismi [, int $kalite ]] )

imagejpeg() işlevi resim ile belirtilen JPEG biçemli resmi tarayıcıya veya bir dosyaya çıktılar.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

dosyaismi

Resmin kaydedileceği dosyanın yolu. Belirtilmez veya NULL verilirse doğrudan ham resim akımı çıktılanır.

kalite değiştirgesini kullanmak için bu değiştirgeye NULL değeri vererek atlayabilirsiniz.

kalite

kalite isteğe bağlı olup 0'dan (en kötü kalite, en küçük dosya) 100'e (en yüksek kalite, en büyük dosya) kadar bir değer belirtilebilir. Öntanımlı değer, öntanımlı IJG kalite değeridir (yaklaşık 75).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Bir JPEG resmi çıktılamak

<?php
// Bir resim taslağı oluşturup bir metin ekleyelim
$im = imagecreatetruecolor(120, 20);
$text_color = imagecolorallocate($im, 233, 14, 91);
imagestring($im, 1, 5, 5,  'A Simple Text String', $text_color);

// İçerik türünü belirtelim
header('Content-type: image/jpeg');

// Resmi çıktılayalım
imagejpeg($im);

// Belleği serbest bırakalım
imagedestroy($im);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Örnek 2 - Bir JPEG resmi kaydetmek

<?php
// Bir resim taslağı oluşturup bir metin ekleyelim
$im = imagecreatetruecolor(120, 20);
$text_color = imagecolorallocate($im, 233, 14, 91);
imagestring($im, 1, 5, 5,  'A Simple Text String', $text_color);

// Resmi 'basitmetin.jpg' ismiyle kaydedelim
imagejpeg($im, 'basitmetin.jpg');

// Belleği serbest bırakalım
imagedestroy($im);
?>

Örnek 3 - Resmi 75% kaliteyle oluşturmak

<?php
// Bir resim taslağı oluşturup bir metin ekleyelim
$im = imagecreatetruecolor(120, 20);
$text_color = imagecolorallocate($im, 233, 14, 91);
imagestring($im, 1, 5, 5,  'A Simple Text String', $text_color);

// İçerik türünü belirtelim
header('Content-type: image/jpeg');

// Dosya ismini NULL ile atlayıp kaliteyi 75% yapalım
imagejpeg($im, NULL, 75);

// Belleği serbest bırakalım
imagedestroy($im);
?>

Notlar

Bilginize: JPEG desteği sadece, PHP, GD'nin 1.8 veya sonraki bir sürümünün kurulu olduğu bir platformda derlenmişse kullanılabilir.

Bilginize:

Aşamalı JPEG'ler çıktılamak isterseniz geçişimliliği imageinterlace() ile ayarlamalısınız.

Ayrıca Bakınız

  • imagepng() - Tarayıcıya veya bir dosyaya bir PNG resmi çıktılar
  • imagegif() - Bir dosyaya veya tarayıcıya bir GIF resmi çıktılar
  • imagewbmp() - Resmi bir dosyaya veya tarayıcıya çıktılar
  • imageinterlace() - Geçişimliliği açıp kapar
  • imagetypes() - Kurulu PHP'nin desteklediği resim türlerini döndürür

imageistruecolor
imagelayereffect
GD ve Resim İşlevleri


PHP ile gelen libgd'nin katmanlama etkisini kullanmak için alfa harmanlama seçeneğini ayarlar

imagejpeg
imageline
GD ve Resim İşlevleri
PHP Manual

imagelayereffect

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

imagelayereffect — PHP ile gelen libgd'nin katmanlama etkisini kullanmak için alfa harmanlama seçeneğini ayarlar

Açıklama

bool imagelayereffect ( resource $image , int $etki )

PHP ile gelen libgd'nin katmanlama etkisini kullanmak için alfa harmanlama seçeneğini ayarlar.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

etki

Şu sabitlerden biri olabilir:

IMG_EFFECT_REPLACE
Piksel değiştirme etkisi kullanılır (imagealphablending() işlevine TRUE aktarmaya eşdeğerdir).
IMG_EFFECT_ALPHABLEND
Normal piksel harmanlaması kullanılır(imagealphablending() işlevine FALSE aktarmaya eşdeğerdir).
IMG_EFFECT_NORMAL
IMG_EFFECT_ALPHABLEND ile aynı.
IMG_EFFECT_OVERLAY
Siyah pikseller siyah, beyaz pikseller beyaz olarak kalırken gri artalan pikselleri önalan pikselinin rengini alırlar.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - imagelayereffect() örneği

<?php
// Resim taslağını oluşturalım
$im = imagecreatetruecolor(100, 100);

// Artalanı griye boyayalım
imagefilledrectangle($im, 0, 0, 100, 100, imagecolorallocate($im, 220, 220, 220));

// Artalan renk değiştirme etkisini etkin kılalım
imagelayereffect($im, IMG_EFFECT_OVERLAY);

// Gri zemine iki elips çizelim
imagefilledellipse($im, 50, 50, 40, 40, imagecolorallocate($im, 100, 255, 100));
imagefilledellipse($im, 50, 50, 50, 80, imagecolorallocate($im, 100, 100, 255));
imagefilledellipse($im, 50, 50, 80, 50, imagecolorallocate($im, 255, 100, 100));

// Resmi çıktılayalım
header('Content-type: image/png');

imagepng($im);
imagedestroy($im);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Notlar

Bilginize: Bu işlev sadece, PHP, PHP paketinde bulunan GD kütüphanesi ile derlenmişse kullanılabilir.

Bilginize: Bu işlev GD'nin 2.0.1 veya sonraki sürümlerini gerektirir (2.0.28 veya sonraki sürümler önerilir).

imagejpeg
imageline
GD ve Resim İşlevleri


Bir çizgi çizer

imagelayereffect
imageloadfont
GD ve Resim İşlevleri
PHP Manual

imageline

(PHP 4, PHP 5, PHP 7)

imageline — Bir çizgi çizer

Açıklama

bool imageline ( resource $resim , int $x1 , int $y1 , int $x2 , int $y2 , int $renk )

Belirtilen noktaların arasına bir çizgi çizer.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

x1

İlk noktanın X konumu.

y1

İlk noktanın Y konumu.

x2

İkinci noktanın X konumu.

y2

İkinci noktanın Y konumu.

renk

Çizginin rengi. imagecolorallocate() tarafından döndürülen bir renk tanıtıcısı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Kalın bir çizgi çizelim

<?php

function imagelinethick($image, $x1, $y1, $x2, $y2, $color, $thick = 1)
{
    /* Sadece yatay ve dikey çizgiler için iyi çalışır
    imagesetthickness($image, $thick);
    return imageline($image, $x1, $y1, $x2, $y2, $color);
    */
    if ($thick == 1) {
        return imageline($image, $x1, $y1, $x2, $y2, $color);
    }
    $t = $thick / 2 - 0.5;
    if ($x1 == $x2 || $y1 == $y2) {
        return imagefilledrectangle($image, round(min($x1, $x2) - $t),
                   round(min($y1, $y2) - $t), round(max($x1, $x2) + $t),
                   round(max($y1, $y2) + $t), $color);
    }
    $k = ($y2 - $y1) / ($x2 - $x1); //y = kx + q
    $a = $t / sqrt(1 + pow($k, 2));
    $points = array(
        round($x1 - (1+$k)*$a), round($y1 + (1-$k)*$a),
        round($x1 - (1-$k)*$a), round($y1 - (1+$k)*$a),
        round($x2 + (1+$k)*$a), round($y2 - (1-$k)*$a),
        round($x2 + (1-$k)*$a), round($y2 + (1+$k)*$a),
    );
    imagefilledpolygon($image, $points, 4, $color);
    return imagepolygon($image, $points, 4, $color);
}

?>

Ayrıca Bakınız

  • imagecreatetruecolor() - Yeni bir gerçek renkli resim oluşturur
  • imagecolorallocate() - Bir resim için bir renk ayırır

imagelayereffect
imageloadfont
GD ve Resim İşlevleri


Yeni bir bit eşlemli yazı tipi yükler

imageline
imageopenpolygon
GD ve Resim İşlevleri
PHP Manual

imageloadfont

(PHP 4, PHP 5, PHP 7)

imageloadfont — Yeni bir bit eşlemli yazı tipi yükler

Açıklama

int imageloadfont ( string $dosya )

imageloadfont() işlevi bir kullanıcı tanımlı biteşlemli yazı tipini yükler ve onun için bir tanıtıcı ile döner.

Değiştirgeler

dosya

İkil ve mimariye bağımlı biçemde yazı tipi dosyası. Yani, yazı tipi dosyalarını PHP'nin çalıştığı makine ile aynı işlemciye (CPU) sahip bir makinede üretmiş olmalısınız.

Yazı tipi dosyası biçemleri
bayt konumu | C veri türü | açıklama
0-3 | int | Yazı tipindeki karakterlerin sayısı.
4-7 | int | Yazı tipindeki ilk karakterin değeri (çoğunlukla boşluk karakterinin kodu olan 32'dir).
8-11 | int | Her karakterin piksel olarak genişliği
12-15 | int | Her karakterin piksel olarak yüksekliği
16- | char | Karakter verisini içeren dizi; bir karakterin her pikseli için bir bayt olmak üzere toplam (karakter_sayısı * genişlik * yükseklik) bayt içerir.

Dönen Değerler

Yerleşik yazı tipleri ile karışmaması için daima 5'ten büyük bir yazı tipi tanıtıcısı ile döner. Bir hata oluşursa FALSE döner.

Örnekler

Örnek 1 - imageloadfont() örneği

<?php
// Yeni bir resim taslağı oluşturalım
$im = imagecreatetruecolor(50, 20);
$black = imagecolorallocate($im, 0, 0, 0);
$white = imagecolorallocate($im, 255, 255, 255);

// Artalan rengi beyaz olsun
imagefilledrectangle($im, 0, 0, 49, 19, $white);

// gd yazı tipini yükleyip 'Hello' yazalım
$font = imageloadfont('./04b.gdf');
imagestring($im, $font, 0, 0, 'Hello', $black);

// Resmi tarayıcıya gönderelim
header('Content-type: image/png');

imagepng($im);
imagedestroy($im);
?>

Ayrıca Bakınız

  • imagefontwidth() - Yazı tipi genişliğini döndürür
  • imagefontheight() - Yazı tipi yüksekliğini döndürür

imageline
imageopenpolygon
GD ve Resim İşlevleri


Draws an open polygon

imageloadfont
imagepalettecopy
GD ve Resim İşlevleri
PHP Manual

imageopenpolygon

(PHP 7 >= 7.2.0)

imageopenpolygon — Draws an open polygon

Açıklama

bool imageopenpolygon ( resource $image , array $points , int $num_points , int $color )

imageopenpolygon() draws an open polygon on the given image. Contrary to imagepolygon(), no line is drawn between the last and the first point.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

points

An array containing the polygon's vertices, e.g.:

points[0] | = x0
points[1] | = y0
points[2] | = x1
points[3] | = y1

num_points

Total number of points (vertices).

color

A color identifier created with imagecolorallocate().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 imageopenpolygon() example

<?php
// Create a blank image
$image = imagecreatetruecolor(400, 300);

// Allocate a color for the polygon
$col_poly = imagecolorallocate($image, 255, 255, 255);

// Draw the polygon
imageopenpolygon($image, array(
        0,   0,
        100, 200,
        300, 200
    ),
    3,
    $col_poly);

// Output the picture to the browser
header('Content-type: image/png');

imagepng($image);
imagedestroy($image);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Output of example : imageopenpolygon()

Ayrıca Bakınız

  • imagepolygon() - Çokgen çizer

imageloadfont
imagepalettecopy
GD ve Resim İşlevleri


Paleti bir resimden diğerine kopyalar

imageopenpolygon
imagepalettetotruecolor
GD ve Resim İşlevleri
PHP Manual

imagepalettecopy

(PHP 4 >= 4.0.1, PHP 5, PHP 7)

imagepalettecopy — Paleti bir resimden diğerine kopyalar

Açıklama

void imagepalettecopy ( resource $hedef , resource $kaynak )

imagepalettecopy() işlevi kaynak resimdeki paleti hedef resme kopyalar.

Değiştirgeler

hedef

Paletin kopyalanacağı resmin tanıtıcısı.

source

Kopyalanacak paleti içeren resmin tanıtıcısı.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 - imagepalettecopy() örneği

<?php
// Paletli iki resim oluşturalım
$palette1 = imagecreate(100, 100);
$palette2 = imagecreate(100, 100);

// İlk palette artalanı yeşil yapalım
$green = imagecolorallocate($palette1, 0, 255, 0);

// Paleti diğer resme kopyalayalım
imagepalettecopy($palette2, $palette1);

// Böylece imagecolorallocate() işlevini iki kere kullanmadan
// yeşil rengi her iki resimde de kullanabiliyoruz
imagefilledrectangle($palette2, 0, 0, 99, 99, $green);

// Resmi tarayıcıya çıktılayalım
header('Content-type: image/png');

imagepng($palette2);
imagedestroy($palette1);
imagedestroy($palette2);
?>

imageopenpolygon
imagepalettetotruecolor
GD ve Resim İşlevleri


Converts a palette based image to true color

imagepalettecopy
imagepng
GD ve Resim İşlevleri
PHP Manual

imagepalettetotruecolor

(PHP 5 >= 5.5.0, PHP 7)

imagepalettetotruecolor — Converts a palette based image to true color

Açıklama

bool imagepalettetotruecolor ( resource $src )

Converts a palette based image, created by functions like imagecreate() to a true color image, like imagecreatetruecolor().

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

Dönen Değerler

Returns TRUE if the convertion was complete, or if the source image already is a true color image, otherwise FALSE is returned.

Örnekler

Örnek 1 Converts any image resource to true color

<?php
// Backwards compatiblity
if(!function_exists('imagepalettetotruecolor'))
{
    function imagepalettetotruecolor(&$src)
    {
        if(imageistruecolor($src))
        {
            return(true);
        }

        $dst = imagecreatetruecolor(imagesx($src), imagesy($src));

        imagecopy($dst, $src, 0, 0, 0, 0, imagesx($src), imagesy($src));
        imagedestroy($src);

        $src = $dst;

        return(true);
    }
}

// Helper closure
$typeof = function() use($im)
{
    echo 'typeof($im) = ' . (imageistruecolor($im) ? 'true color' : 'palette'), PHP_EOL;
};

// Create a palette based image
$im = imagecreate(100, 100);
$typeof();

// Convert it to true color
imagepalettetotruecolor($im);
$typeof();

// Free the memory
imagedestroy($im);
?>

Yukarıdaki örneğin çıktısı:

typeof($im) = palette
typeof($im) = true color

Ayrıca Bakınız

  • imagecreatetruecolor() - Yeni bir gerçek renkli resim oluşturur
  • imageistruecolor() - Bir resmin gerçek renkli olup olmadığını bulur

imagepalettecopy
imagepng
GD ve Resim İşlevleri


Tarayıcıya veya bir dosyaya bir PNG resmi çıktılar

imagepalettetotruecolor
imagepolygon
GD ve Resim İşlevleri
PHP Manual

imagepng

(PHP 4, PHP 5, PHP 7)

imagepng — Tarayıcıya veya bir dosyaya bir PNG resmi çıktılar

Açıklama

bool imagepng ( resource $resim [, string $dosyaismi [, int $kalite [, int $süzgeçler ]]] )

resim ile belirtilen bir PNG resmini tarayıcıya veya bir dosyaya çıktılar.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

dosyaismi

Resmin kaydedileceği dosyanın yolu. Belirtilmez veya NULL verilirse doğrudan ham resim akımı çıktılanır.

Bilginize:

Eğer kalite ve süzgeçler değiştirgeleri belirtilmezse NULL geçersizdir.

kalite

Sıkıştırma düzeyi: 0'dan (sıkıştırma yok), 9'a kadar.

süzgeçler

PNG dosyasının boyutunu küçültme imkanı sağlar. PNG_FILTER_XXX sabitlerinin bir birleşiminden oluşan bir bit maskesi olarak belirtilir. Ayrıca, tüm süzgeçleri etkisiz veya etkili kılmak için (sırayla) PNG_NO_FILTER veya PNG_ALL_FILTERS sabiti kullanılabilir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.3 | süzgeçler değiştirgesi eklendi.
5.1.2 | kalite değiştirgesi eklendi.

Örnekler

<?php
$im = imagecreatefrompng("test.png");

header('Content-type: image/png');

imagepng($im);
imagedestroy($im);
?>

Ayrıca Bakınız

  • imagegif() - Bir dosyaya veya tarayıcıya bir GIF resmi çıktılar
  • imagewbmp() - Resmi bir dosyaya veya tarayıcıya çıktılar
  • imagejpeg() - Tarayıcıya veya bir dosyaya bir JPEG resmi çıktılar
  • imagetypes() - Kurulu PHP'nin desteklediği resim türlerini döndürür
  • imagesavealpha() - PNG resimleri kaydederken (tek renkli şeffaflığın tersine) alfa kanalı bilgisinin kaydedilip kaydedilmeyeceğini belirtir

imagepalettetotruecolor
imagepolygon
GD ve Resim İşlevleri


Çokgen çizer

imagepng
imagepsbbox
GD ve Resim İşlevleri
PHP Manual

imagepolygon

(PHP 4, PHP 5, PHP 7)

imagepolygon — Çokgen çizer

Açıklama

bool imagepolygon ( resource $resim , array $noktalar , int $nokta_sayısı , int $renk )

imagepolygon() belirtilen resim üzerine çokgen çizer.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

noktalar

Çokgenin köşeleri. Dizinin yerleşimi şöyledir:

noktalar[0] | = x0
noktalar[1] | = y0
noktalar[2] | = x1
noktalar[3] | = y1

nokta_sayısı

Köşe sayısı.

renk

imagecolorallocate() tarafından oluşturulmuş bir renk tanıtıcısı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - imagepolygon() örneği

<?php
// Bir resim taslağı oluşturalım
$resim = imagecreatetruecolor(400, 300);

// Çokgenin rengini ayarlayalım
$renk = imagecolorallocate($resim, 255, 255, 255);

// Çokgeni çizelim
imagepolygon($resim, array(
        0,   0,
        100, 200,
        300, 200
    ),
    3,
    $renk);

// Resmi tarayıcıya gönderelim
header('Content-type: image/png');

imagepng($resim);
imagedestroy($resim);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ayrıca Bakınız

  • imagecreate() - Yeni bir paletli resim oluşturur
  • imagecreatetruecolor() - Yeni bir gerçek renkli resim oluşturur

imagepng
imagepsbbox
GD ve Resim İşlevleri


Bir PostScript Type1 yazı tipi ile yazılan bir metnin çerçevesini döndürür

imagepolygon
imagepsencodefont
GD ve Resim İşlevleri
PHP Manual

imagepsbbox

(PHP 4, PHP 5)

imagepsbbox — Bir PostScript Type1 yazı tipi ile yazılan bir metnin çerçevesini döndürür

Açıklama

array imagepsbbox ( string $metin , resource $yazıtipi , int $boyut )
array imagepsbbox ( string $metin , resource $yazıtipi , int $boyut , int $boşluk , int $sıkışıklık , float $açı )

Bir PostScript Type1 yazı tipi ile yazılan bir metnin çerçevesini döndürür.

Metin çerçevesi yazı tipi dosyasında bulunan karakter ölçüleri kullanılarak hesaplanır. Ne yazık ki, hesaplanan değer metin resimde çizildiği zaman elde edilen boyutta olmaz. 0 derece açı ile çizilen bir metne her yönde birer pikselden daha fazla yer ayırmalısınız.

Değiştirgeler

metin

Resme yazılacak metin.

yazıtipi

imagepsloadfont() tarafından döndürülen bir yazı tipi özkaynağı.

boyut

Piksel olarak yazı tipi yüksekliği.

boşluk

Bir yazı tipi içindeki bir boşluğun öntanımlı değerini belirtmek için kullanılır. Bu miktar normal değere eklenir ve negatif olabilir. Bir em karenin binde birine eşit karakter boşluk birimi cinsinden belirtilir.

sıkışıklık

Karakterler arasındaki boşluk miktarını belirtmek için kullanılır. Bu miktar normal karakter genişliğine eklenir ve negatif olabilir. Bir em karenin binde birine eşit karakter boşluk birimi cinsinden belirtilir.

açı

Derece olarak açı.

Dönen Değerler

Aşağıdaki elemanlardan oluşan bir dizi döner:

0 | Sol kenarın X konumu
1 | Üst kenarın Y konumu
2 | Sağ kenarın X konumu
3 | Alt kenarın Y konumu

Örnekler

Örnek 1 - imagepsbbox() örneği

<?php
// Bir resim taslağı oluşturalım
$im = imagecreatetruecolor(200, 200);

// Renkleri ayarlayalım
$siyah = imagecolorallocate($im, 0, 0, 0);
$beyaz = imagecolorallocate($im, 255, 255, 255);

// PostScript yazı tipini yükleyelim
$font = imagepsloadfont('font.pfm');

// Metnin çerçevesini hesaplatalım
$bbox = imagepsbbox('Sample text is simple', $font, 12);

// Metnin X ve Y konumlarını belirtelim
$x = ($bbox[2] / 2) - 10;
$y = ($bbox[3] / 2) - 10;

// Metni resme yazalım
imagepstext($im, 'Basit bir örnek metin', $font, 12, $siyah, $beyaz, $x, $y);

// Resmi çıktılayıp belleği serbest bırakalım
header('Content-type: image/png');

imagepng($im);
imagedestroy($im);
?>

Notlar

Bilginize: Bu işlev sadece, PHP, --with-t1lib[=DİZİN] seçeneği ile derlenmişse kullanılabilir.

Ayrıca Bakınız

  • imagepstext() - PostScript Type1 yazı tiplerini kullanarak bir resmin üzerine bir metin çizer

imagepolygon
imagepsencodefont
GD ve Resim İşlevleri


Bir yazı tipinin karakter kodlamasını değiştirir

imagepsbbox
imagepsextendfont
GD ve Resim İşlevleri
PHP Manual

imagepsencodefont

(PHP 4, PHP 5)

imagepsencodefont — Bir yazı tipinin karakter kodlamasını değiştirir

Açıklama

bool imagepsencodefont ( resource $yazıtipi , string $kodlama_dosyası )

Bir dosyadan bir karakter kodlaması yöneyi yükler ve yazı tipinin kodlama yöneyini bununla değiştirir. Bir PostScript yazı tipinin öntanımlı yöneyi 127'den büyük karakterleri kapsamadığından İngilizce dışında bir dil kullanacaksanız kodlamayı mutlaka değiştirmelisiniz.

Bu işleve her seferinde yeniden kullanmamak için en iyi yöntem yapılandırma dosyasında ps.default_encoding yönergesine doğru kodlama dosyasını belirtmektir. Böylece yüklediğiniz bütün yazı tipleri özdevinimli olarak doğru kodlamayı kullanırlar.

Değiştirgeler

yazıtipi

imagepsloadfont() tarafından döndürülen bir yazı tipi özkaynağı.

kodlama_dosyası

Bu dosyanın biçemi T1libs belgelerinde açıklanmaktadır. T1lib iki kullanıma hazır dosya ile gelir: IsoLatin1.enc ve IsoLatin2.enc.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - imagepsencodefont() örneği

<?php
//Bir .pfb yazı tipi dosyası yükleyelim
$font = imagepsloadfont('./px3l.pfb');

// T1lib'e ISO Latin 1 kodlamasını kullan diyelim
imagepsencode($font, './IsoLatin1.enc');

// Burada yazı tipini kullanıyoruz

// İşimiz bitince yazı tipine ayrılan belleği serbest bırakıyoruz
imagepsfreefont($font);
?>

Notlar

Bilginize: Bu işlev sadece, PHP, --with-t1lib[=DİZİN] seçeneği ile derlenmişse kullanılabilir.

imagepsbbox
imagepsextendfont
GD ve Resim İşlevleri


Bir PS yazı tipini genişletir veya daraltır

imagepsencodefont
imagepsfreefont
GD ve Resim İşlevleri
PHP Manual

imagepsextendfont

(PHP 4, PHP 5)

imagepsextendfont — Bir PS yazı tipini genişletir veya daraltır

Açıklama

bool imagepsextendfont ( resource $yazıtipi , float $katsayı )

yazıtipi tanıtıcısı ile belirtilen PS yazı tipini genişletir veya daraltır; katsayı birden büyükse genişletir, küçükse daraltır.

Değiştirgeler

yazıtipi

imagepsloadfont() tarafından döndürülen bir yazı tipi özkaynağı.

katsayı

Yazı tipi genişlik çarpanı. Sıfırdan büyük olmalıdır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - imagepsextendfont() örneği

<?php
//Bir .pfb yazı tipi dosyası yükleyelim
$font = imagepsloadfont('./px3l.pfb');

// Yazı tipini 2.5 kere genişletiyoruz
imagepsextendfont($font, 2.5);

// Burada yazı tipini kullanıyoruz

// İşimiz bitince yazı tipine ayrılan belleği serbest bırakıyoruz
imagepsfreefont($font);
?>

Notlar

Bilginize: Bu işlev sadece, PHP, --with-t1lib[=DİZİN] seçeneği ile derlenmişse kullanılabilir.

imagepsencodefont
imagepsfreefont
GD ve Resim İşlevleri


Bir PostScript Type 1 yazı tipi tarafından kullanılan belleği serbest bırakır

imagepsextendfont
imagepsloadfont
GD ve Resim İşlevleri
PHP Manual

imagepsfreefont

(PHP 4, PHP 5)

imagepsfreefont — Bir PostScript Type 1 yazı tipi tarafından kullanılan belleği serbest bırakır

Açıklama

bool imagepsfreefont ( resource $font_index )

imagepsfreefont() işlevi bir PostScript Type 1 yazı tipi tarafından kullanılan belleği serbest bırakır.

Değiştirgeler

yazıtipi

imagepsloadfont() tarafından döndürülen bir yazı tipi özkaynağı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - imagepsfreefont() örneği

<?php
//Bir .pfb yazı tipi dosyası yükleyelim
$font = imagepsloadfont('./bchbi.pfb');

// Burada yazı tipini kullanıyoruz

// İşimiz bitince yazı tipine ayrılan belleği serbest bırakıyoruz
imagepsfreefont($font);
?>

Notlar

Bilginize: Bu işlev sadece, PHP, --with-t1lib[=DİZİN] seçeneği ile derlenmişse kullanılabilir.

Ayrıca Bakınız

  • imagepsloadfont() - Bir dosyadan bir PostScript Type 1 yazı tipi yükler

imagepsextendfont
imagepsloadfont
GD ve Resim İşlevleri


Bir dosyadan bir PostScript Type 1 yazı tipi yükler

imagepsfreefont
imagepsslantfont
GD ve Resim İşlevleri
PHP Manual

imagepsloadfont

(PHP 4, PHP 5)

imagepsloadfont — Bir dosyadan bir PostScript Type 1 yazı tipi yükler

Açıklama

resource imagepsloadfont ( string $dosyaismi )

dosyaismi ile yolu belirtilen dosyadan bir PostScript Type 1 yazı tipi yükler.

Değiştirgeler

dosyaismi

Postscript yazı tipi dosyasının yolu.

Dönen Değerler

Herşey yolunda giderse geçerli bir yazıtipi tanıtıcısı döndürür. Aksi takdirde FALSE döner.

Örnekler

Örnek 1 - imagepsloadfont() örneğ

<?php
// Yeni bir resim taslağı oluşturalım
$im = imagecreatetruecolor(350, 45);

// Renkleri ayarlayalım ve artalanı boyayalım
$siyah = imagecolorallocate($im, 0, 0, 0);
$beyaz = imagecolorallocate($im, 255, 255, 255);
imagefilledrectangle($im, 0, 0, 349, 44, $beyaz);

// Yazı tipini yükleyip resme bir metin yazalım
// ve yazı tipinine ayırdığımız belleği serbest bırakalım
$font = imagepsloadfont("bchbi.pfb");
imagepstext($im, "Deneme 123... Çalıştı!", $font, 32, $beyaz, $siyah, 32, 32);
imagepsfreefont($font);

// Resmi çıktılayalım
header('Content-type: image/png');

imagepng($im);
imagedestroy($im);
?>

Notlar

Bilginize: Bu işlev sadece, PHP, --with-t1lib[=DİZİN] seçeneği ile derlenmişse kullanılabilir.

Ayrıca Bakınız

  • imagepsfreefont() - Bir PostScript Type 1 yazı tipi tarafından kullanılan belleği serbest bırakır

imagepsfreefont
imagepsslantfont
GD ve Resim İşlevleri


Bir yazı tipini eğer

imagepsloadfont
imagepstext
GD ve Resim İşlevleri
PHP Manual

imagepsslantfont

(PHP 4, PHP 5)

imagepsslantfont — Bir yazı tipini eğer

Açıklama

bool imagepsslantfont ( resource $yazıtipi , float $eğim )

Belirtilen yazı tipini belirtildiği kadar eğer.

Değiştirgeler

yazıtipi

imagepsloadfont() tarafından döndürülen bir yazı tipi özkaynağı.

eğim

Eğiklik derecesi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - imagepsslantfont() örneği

<?php
// Bir .pfb yazı tipi dosyası yükleyelim
$font = imagepsloadfont('./px3l.pfb');

// Yazıtipini 22.5 derece eğelim
imagepsslantfont($font, 22.5);

// Burada yazı tipini kullanıyoruz

// İşimiz bitince yazı tipine ayrılan belleği serbest bırakıyoruz
imagepsfreefont($font);
?>

Notlar

Bilginize: Bu işlev sadece, PHP, --with-t1lib[=DİZİN] seçeneği ile derlenmişse kullanılabilir.

imagepsloadfont
imagepstext
GD ve Resim İşlevleri


PostScript Type1 yazı tiplerini kullanarak bir resmin üzerine bir metin çizer

imagepsslantfont
imagerectangle
GD ve Resim İşlevleri
PHP Manual

imagepstext

(PHP 4, PHP 5)

imagepstext — PostScript Type1 yazı tiplerini kullanarak bir resmin üzerine bir metin çizer

Açıklama

array imagepstext ( resource $resim , string $metin , resource $font_indisi , int $boyut , int $önalan , int $artalan , int $x , int $y [, int $boşluk = 0 [, int $sıkışıklık = 0 [, float $açı = 0.0 [, int $yumuşatma_adımları = 4 ]]]] )

PostScript Type1 yazı tiplerini kullanarak bir resmin üzerine bir metin çizer.

Bu işlevin nasıl çalıştığını anlamak için PostScript belgelerinde yazı tiplerini ve bunların ölçü sistemlerini inceleyin.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

metin

Yazılacak metin.

font_indisi

imagepsloadfont() tarafından döndürülen bir yazı tipi özkaynağı.

boyut

Piksel cinsinden yazı tipi yüksekliği.

önalan

Metni boyamakta kullanılacak renk.

artalan

Yumuşatma amacıyla metin rengine yedirilecek renk. Bu renk ile aslında resmin artalanı boyanmaz. Dolayısıyla resmin artalanının ışık geçirmeyen bir renkte olması gerekli değildir.

x

İlk karakterin sol alt köşesinin X konumu.

y

İlk karakterin sol alt köşesinin Y konumu.

boşluk

Bir yazı tipi içindeki bir boşluğun öntanımlı değerini belirtmek için kullanılır. Bu miktar normal değere eklenir ve negatif olabilir. Bir em karenin binde birine eşit karakter boşluk birimi cinsinden belirtilir.

sıkışıklık

Karakterler arasındaki boşluk miktarını belirtmek için kullanılır. Bu miktar normal karakter genişliğine eklenir ve negatif olabilir. Bir em karenin binde birine eşit karakter boşluk birimi cinsinden belirtilir.

açı

Derece olarak açı.

yumuşatma_adımları

Karakter kenarlarının yumuşatılması için kullanılacak renk sayısını belirleminizi sağlar. İzin verilen değerler 4 ve 16'dır. Metin kalitesine etkisi belirgin olan daha yüksek değerler 20'den küçük metin boyutları için önerilmektedir. Daha büyük boyutlar için 4 kullanın. Daha az hesap gerektirir.

Dönen Değerler

İşlev aşağıdaki elemanları içeren bir dizi döndürür:

0 | sol alt köşenin X konumu
1 | sol alt köşenin Y konumu
2 | sağ üst köşenin X konumu
3 | sağ üst köşenin Y konumu

Örnekler

Örnek 1 - imagepstext() örneği

<?php
// Resmi oluşturalım
$im = imagecreatetruecolor(200, 200);

// Renleri belirleyelim
$black = imagecolorallocate($im, 0, 0, 0);
$white = imagecolorallocate($im, 255, 255, 255);

// PostScript Yazıtipi
$font = imagepsloadfont('font.pfm');

// Metni resme yazalım
imagepstext($im, 'Sample text is simple', $font, 12, $black, $white, 50, 50);

// Resmi çıktılayıp belleği serbest bırakalım
header('Content-type: image/png');

imagepng($im);
imagedestroy($im);
?>

Notlar

Bilginize: Bu işlev sadece, PHP, --with-t1lib[=DİZİN] seçeneği ile derlenmişse kullanılabilir.

Ayrıca Bakınız

  • imagepsbbox() - Bir PostScript Type1 yazı tipi ile yazılan bir metnin çerçevesini döndürür

imagepsslantfont
imagerectangle
GD ve Resim İşlevleri


Bir dikdörtgen çizer

imagepstext
imageresolution
GD ve Resim İşlevleri
PHP Manual

imagerectangle

(PHP 4, PHP 5, PHP 7)

imagerectangle — Bir dikdörtgen çizer

Açıklama

bool imagerectangle ( resource $resim , int $x1 , int $y1 , int $x2 , int $y2 , int $renk )

imagerectangle() işlevi köşe koordinatları belirtilen dikdörtgeni çizer.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

x1

Sol üst köşenin X konumu.

y1

Sol üst köşenin Y konumu. Resmin sol üst köşesinin koordinatları 0, 0'dır.

x2

Sağ alt köşenin X konumu.

y2

Sağ alt köşenin Y konumu.

color

imagecolorallocate() ile oluşturulan bir renk tanıtıcısı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - imagerectangle() örneği

<?php
// 200 x 200 bir resim oluşturalım
$canvas = imagecreatetruecolor(200, 200);

// Renkleri belirleyelim
$pink = imagecolorallocate($canvas, 255, 105, 180);
$white = imagecolorallocate($canvas, 255, 255, 255);
$green = imagecolorallocate($canvas, 132, 135, 28);

// Farklı renklerde üç dikdörtgen çizelim
imagerectangle($canvas, 50, 50, 150, 150, $pink);
imagerectangle($canvas, 45, 60, 120, 100, $white);
imagerectangle($canvas, 100, 120, 75, 160, $green);

// Resmi çıktılayıp belleği serbest bırakalım
header('Content-Type: image/jpeg');

imagejpeg($canvas);
imagedestroy($canvas);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

imagepstext
imageresolution
GD ve Resim İşlevleri


Get or set the resolution of the image

imagerectangle
imagerotate
GD ve Resim İşlevleri
PHP Manual

imageresolution

(PHP 7 >= 7.2.0)

imageresolution — Get or set the resolution of the image

Açıklama

mixed imageresolution ( resource $image [, int $res_x [, int $res_y ]] )

imageresolution() allows to set and get the resolution of an image in DPI (dots per inch). If none of the optional parameters is given, the current resolution is returned as indexed array. If only res_x is given, the horizontal and vertical resolution are set to this value. If both optional parameters are given, the horizontal and vertical resolution are set to these values, respectively.

The resolution is only used as meta information when images are read from and written to formats supporting this kind of information (curently PNG and JPEG). It does not affect any drawing operations. The default resolution for new images is 96 DPI.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

res_x

The horizontal resolution in DPI.

res_y

The vertical resolution in DPI.

Dönen Değerler

When used as getter (that is without the optional parameters), it returns TRUE on success, başarısızlık durumunda FALSE döner. When used as setter (that is with one or both optional parameters given), it returns an indexed array of the horizontal and vertical resolution on success, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Setting and getting the resolution of an image

<?php
$im = imagecreatetruecolor(100, 100);
imageresolution($im, 200);
print_r(imageresolution($im));
imageresolution($im, 300, 72);
print_r(imageresolution($im));
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [0] => 200
    [1] => 200
)
Array
(
    [0] => 300
    [1] => 72
)
imagerectangle
imagerotate
GD ve Resim İşlevleri


Bir resmi belirtilen açıya göre döndürür

imageresolution
imagesavealpha
GD ve Resim İşlevleri
PHP Manual

imagerotate

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

imagerotate — Bir resmi belirtilen açıya göre döndürür

Açıklama

resource imagerotate ( resource $resim , float $açı , int $artalan [, int $şeffaflığı_yoksay = 0 ] )

Belirtilen resim resmini açı derece döndürür.

Dönüş merkezi resmin merkezi olup, döndürülen resim özgün resimden farklı boyutlara sahip olabilir.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

açı

Derece olarak dönüş açısı.

artalan

Döndürme işleminden sonra boşta kalan yerin rengi.

şeffaflığı_yoksay

Sıfırdan farklı bir değer belirtildiğinde şeffaf renkler yok sayılır.

Dönen Değerler

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.0 | şeffaflığı_yoksay değiştirgesi eklendi.

Örnekler

Örnek 1 Bir remin 180° döndürülmesi

Bu örnekte bir resim 180° (başağı) döndürülmektedir.

<?php
// Döndür ve doldur
$filename = 'test.jpg';
$degrees = 180;

// İçerik türü
header('Content-type: image/jpeg');

// resmi yükleyelim
$source = imagecreatefromjpeg($filename);

// Döndürelim
$rotate = imagerotate($source, $degrees, 0);

// Çıktılayalım
imagejpeg($rotate);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Notlar

Bilginize: Bu işlev sadece, PHP, PHP paketinde bulunan GD kütüphanesi ile derlenmişse kullanılabilir.

imageresolution
imagesavealpha
GD ve Resim İşlevleri


PNG resimleri kaydederken (tek renkli şeffaflığın tersine) alfa kanalı bilgisinin kaydedilip kaydedilmeyeceğini belirtir

imagerotate
imagescale
GD ve Resim İşlevleri
PHP Manual

imagesavealpha

(PHP 4 >= 4.3.2, PHP 5, PHP 7)

imagesavealpha — PNG resimleri kaydederken (tek renkli şeffaflığın tersine) alfa kanalı bilgisinin kaydedilip kaydedilmeyeceğini belirtir

Açıklama

bool imagesavealpha ( resource $resim , bool $alfa_kaydet )

imagesavealpha() işlevi PNG resimleri kaydederken (tek renkli şeffaflığın tersine) alfa kanalı bilgisinin tamamının kaydedilmesi için seçenek belirtir.

Bunu kullanmak için alfa harmanlamayı devreden çıkarmalısınız (imagealphablending($im, false)).

Alfa kanalını her tarayıcı desteklemez. Tarayıcınız sorun çıkarırsa, betiğinizi Mozilla'nın son sürümü gibi alfa kanalına uyumlu bir tarayıcıyla yüklemeyi deneyin.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

alfa_kaydet

Alfa kanalının kaydedilip kaydedilmeyeceği belirtilir; FALSE öntanımlıdır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - imagesavealpha() örneği

<?php
// Alfa kanalları olan bir png resmi yükleyelim.
$png = imagecreatefrompng('./alphachannel_example.png');

// Gerekli işlemleri yapalım

// Alfa harmanlamasını kapatıp alfa kayıt seçeneğini etkin kılalım
imagealphablending($png, false);
imagesavealpha($png, true);

// Resmi tarayıcıya gönderelim
header('Content-Type: image/png');

imagepng($png);
imagedestroy($png);
?>

Notlar

Bilginize: Bu işlev GD'nin 2.0.1 veya sonraki sürümlerini gerektirir (2.0.28 veya sonraki sürümler önerilir).

Ayrıca Bakınız

  • imagealphablending() - Bir resim için harmanlama kipini etkinleştirir

imagerotate
imagescale
GD ve Resim İşlevleri


Scale an image using the given new width and height

imagesavealpha
imagesetbrush
GD ve Resim İşlevleri
PHP Manual

imagescale

(PHP 5 >= 5.5.0, PHP 7)

imagescale — Scale an image using the given new width and height

Açıklama

resource imagescale ( resource $image , int $new_width [, int $new_height = -1 [, int $mode = IMG_BILINEAR_FIXED ]] )

imagescale() scales an image using the given interpolation algorithm.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

new_width

The width to scale the image to.

new_height

The height to scale the image to. If omitted or negative, the aspect ratio will be preserved.

Dikkat

You should always provide the height if using PHP 5.5.18 or earlier, or PHP 5.6.2 or earlier, as the aspect ratio calculation was incorrect.

mode

One of IMG_NEAREST_NEIGHBOUR, IMG_BILINEAR_FIXED, IMG_BICUBIC, IMG_BICUBIC_FIXED or anything else (will use two pass).

Bilginize: IMG_WEIGHTED4 is not yet supported.

Dönen Değerler

Return the scaled image resource on success başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.5.19/5.6.3 | The calculation of the height if new_height was negative or omitted was fixed; prior to these versions, the aspect ratio was not maintained correctly.

imagesavealpha
imagesetbrush
GD ve Resim İşlevleri


Çizgi çizmek için fırça resmi oluşturur

imagescale
imagesetclip
GD ve Resim İşlevleri
PHP Manual

imagesetbrush

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

imagesetbrush — Çizgi çizmek için fırça resmi oluşturur

Açıklama

bool imagesetbrush ( resource $resim , resource $fırça )

imagesetbrush() işlevi imageline() ve imagepolygon() gibi çizgi çizme işlevleri tarafından özel IMG_COLOR_STYLED veya IMG_COLOR_STYLEDBRUSHED renkli çizgiler çizmek için kullanılan fırça resmini oluşturur.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

fırça

Bir resim özkaynağı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - imagesetbrush() örneği

<?php
// Minik bir PHP logosu yükleyelim
$php = imagecreatefrompng('./php.png');

// 100x100'lük asıl resmi oluşturalım
$im = imagecreatetruecolor(100, 100);

// Artalanı beyaz renkle dolduralım
$white = imagecolorallocate($im, 255, 255, 255);
imagefilledrectangle($im, 0, 0, 299, 99, $white);

// Fırçamızı oluşturalım
imagesetbrush($im, $php);

// Fırçamızla bir çizgi çizelim
imageline($im, 50, 50, 50, 60, IMG_COLOR_BRUSHED);

// Resmi tarayıcıya gönderelim
header('Content-type: image/png');

imagepng($im);
imagedestroy($im);
imagedestroy($php);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Notlar

Bilginize:

Bir fırça ile işiniz bittiğinde özel bir işlem yapmanız gerekmez, fakat eğer fırça resmini silerseniz, yeni bir fırça resmi oluşturana kadar IMG_COLOR_BRUSHED veya IMG_COLOR_STYLEDBRUSHED rengini kullanmamalısınız!

imagescale
imagesetclip
GD ve Resim İşlevleri


Set the clipping rectangle

imagesetbrush
imagesetinterpolation
GD ve Resim İşlevleri
PHP Manual

imagesetclip

(PHP 7.2)

imagesetclip — Set the clipping rectangle

Açıklama

bool imagesetclip ( resource $im , int $x1 , int $y1 , int $x2 , int $y2 )

imagesetclip() sets the current clipping rectangle, i.e. the area beyond which no pixels will be drawn.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

x1

The x-coordinate of the upper left corner.

y1

The y-coordinate of the upper left corner.

x2

The x-coordinate of the lower right corner.

y2

The y-coordinate of the lower right corner.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • imagegetclip() - Get the clipping rectangle
imagesetbrush
imagesetinterpolation
GD ve Resim İşlevleri


Set the interpolation method

imagesetclip
imagesetpixel
GD ve Resim İşlevleri
PHP Manual

imagesetinterpolation

(PHP 5 >= 5.5.0, PHP 7)

imagesetinterpolation — Set the interpolation method

Açıklama

bool imagesetinterpolation ( resource $image [, int $method = IMG_BILINEAR_FIXED ] )

Sets the interpolation method, setting an interpolation method affects the rendering of various functions in GD, such as the imagerotate() function.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

method

The interpolation method, which can be one of the following:

  • IMG_BELL: Bell filter.
  • IMG_BESSEL: Bessel filter.
  • IMG_BICUBIC: Bicubic interpolation.
  • IMG_BICUBIC_FIXED: Fixed point implementation of the bicubic interpolation.
  • IMG_BILINEAR_FIXED: Fixed point implementation of the bilinear interpolation (default (also on image creation)).
  • IMG_BLACKMAN: Blackman window function.
  • IMG_BOX: Box blur filter.
  • IMG_BSPLINE: Spline interpolation.
  • IMG_CATMULLROM: Cubic Hermite spline interpolation.
  • IMG_GAUSSIAN: Gaussian function.
  • IMG_GENERALIZED_CUBIC: Generalized cubic spline fractal interpolation.
  • IMG_HERMITE: Hermite interpolation.
  • IMG_HAMMING: Hamming filter.
  • IMG_HANNING: Hanning filter.
  • IMG_MITCHELL: Mitchell filter.
  • IMG_POWER: Power interpolation.
  • IMG_QUADRATIC: Inverse quadratic interpolation.
  • IMG_SINC: Sinc function.
  • IMG_NEAREST_NEIGHBOUR: Nearest neighbour interpolation.
  • IMG_WEIGHTED4: Weighting filter.
  • IMG_TRIANGLE: Triangle interpolation.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 imagesetinterpolation() example

<?php
// Load an image
$im = imagecreate(500, 500);

// By default interpolation is IMG_BILINEAR_FIXED, switch
// to use the 'Mitchell' filter:
imagesetinterpolation($im, IMG_MITCHELL);

// Continue to work with $im ...
?>

Notlar

Changing the interpolation method affects the following functions when rendering:

  • imageaffine()
  • imagerotate()

imagesetclip
imagesetpixel
GD ve Resim İşlevleri


Bir pikselin rengini değiştirir

imagesetinterpolation
imagesetstyle
GD ve Resim İşlevleri
PHP Manual

imagesetpixel

(PHP 4, PHP 5, PHP 7)

imagesetpixel — Bir pikselin rengini değiştirir

Açıklama

bool imagesetpixel ( resource $resim , int $x , int $y , int $renk )

imagesetpixel() işlevi koordinatları belirtilen pikselin rengini değiştirir.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

x

Pikselin X konumu.

y

Pikselin Y konumu.

renk

imagecolorallocate() ile oluşturulmuş bir renk tanıtıcısı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - imagesetpixel() örneği

Normal bir resimle sonuçlanan rasgele bir çizim.

<?php

$x = 200;
$y = 200;

$gd = imagecreatetruecolor($x, $y);

$corners[0] = array('x' => 100, 'y' =>  10);
$corners[1] = array('x' =>   0, 'y' => 190);
$corners[2] = array('x' => 200, 'y' => 190);

$red = imagecolorallocate($gd, 255, 0, 0);

for ($i = 0; $i < 100000; $i++) {
  imagesetpixel($gd, round($x),round($y), $red);
  $a = rand(0, 2);
  $x = ($x + $corners[$a]['x']) / 2;
  $y = ($y + $corners[$a]['y']) / 2;
}

header('Content-Type: image/png');
imagepng($gd);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ayrıca Bakınız

  • imagecreatetruecolor() - Yeni bir gerçek renkli resim oluşturur
  • imagecolorallocate() - Bir resim için bir renk ayırır

imagesetinterpolation
imagesetstyle
GD ve Resim İşlevleri


Çizgi tarzını ayarlar

imagesetpixel
imagesetthickness
GD ve Resim İşlevleri
PHP Manual

imagesetstyle

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

imagesetstyle — Çizgi tarzını ayarlar

Açıklama

bool imagesetstyle ( resource $resim , array $tarz )

imagesetstyle() işlevi imageline() ve imagepolygon() gibi çizgi çizme işlevleri tarafından özel IMG_COLOR_STYLED veya IMG_COLOR_STYLEDBRUSHED renkli çizgiler çizmek için kullanılan çizgi tarzlarını ayarlamakta kullanılır.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

tarz

Piksel renklerinden oluşan bir dizi. Şeffaf bir piksel eklemek için IMG_COLOR_TRANSPARENT sabitini kullanabilirsiniz.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Aşağıdaki betik örneğinde bir tuvalin sol üst köşesinden sağ alt köşesine kesikli çizgi çizilmektedir:

Örnek 1 - imagesetstyle() örneği

<?php
header("Content-type: image/jpeg");
$im  = imagecreatetruecolor(100, 100);
$b   = imagecolorallocate($im, 255, 255, 255);
$k = imagecolorallocate($im, 255, 0, 0);

/* 5 kırmızı 5 beyaz piksellik kesikli bir çizgi çizelim */
$style = array($k, $k, $k, $k, $k, $b, $b, $b, $b, $b);
imagesetstyle($im, $style);
imageline($im, 0, 0, 100, 100, IMG_COLOR_STYLED);

/* imagesetbrush ile imagesetstyle kullanarak
   mutlu yüzlerden bir çizgi çizelim */
$style = array($b, $b, $b, $b, $b, $b, $b, $b, $b, $b, $b, $b, $k);
imagesetstyle($im, $style);

$brush = imagecreatefrompng("http://www.libpng.org/pub/png/images/smile.happy.png");
$b2 = imagecolorallocate($brush, 255, 255, 255);
imagecolortransparent($brush, $b2);
imagesetbrush($im, $brush);
imageline($im, 100, 0, 0, 100, IMG_COLOR_STYLEDBRUSHED);

imagejpeg($im);
imagedestroy($im);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ayrıca Bakınız

  • imagesetbrush() - Çizgi çizmek için fırça resmi oluşturur
  • imageline() - Bir çizgi çizer

imagesetpixel
imagesetthickness
GD ve Resim İşlevleri


Çizgi kalınlığını ayarlar

imagesetstyle
imagesettile
GD ve Resim İşlevleri
PHP Manual

imagesetthickness

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

imagesetthickness — Çizgi kalınlığını ayarlar

Açıklama

bool imagesetthickness ( resource $resim , int $kalınlık )

imagesetthickness() işlevi, dörtgen, çokgen, elips ve saire çizerken kullanılan çizgilerin kalınlığını kalınlık piksele ayarlar.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

kalınlık

Piksel cinsinden çizgi kalınlığı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - imagesetthickness() örneği

<?php
// 200x100 bir resim oluşturalım
$im = imagecreatetruecolor(200, 100);
$beyaz = imagecolorallocate($im, 0xFF, 0xFF, 0xFF);
$siyah = imagecolorallocate($im, 0x00, 0x00, 0x00);

// Artalan rengi beyaz olsun
imagefilledrectangle($im, 0, 0, 299, 99, $beyaz);

// Çizgi kalınlığını 5 piksel yapalım
imagesetthickness($im, 5);

// Dörtgeni siyah renkte çizelim
imagerectangle($im, 14, 14, 185, 85, $siyah);

// Resmi tarayıcıya gönderelim
header('Content-Type: image/png');

imagepng($im);
imagedestroy($im);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Notlar

Bilginize: Bu işlev GD'nin 2.0.1 veya sonraki sürümlerini gerektirir (2.0.28 veya sonraki sürümler önerilir).

imagesetstyle
imagesettile
GD ve Resim İşlevleri


Resmi doldurmak için döşemeyi etkin kılar

imagesetthickness
imagestring
GD ve Resim İşlevleri
PHP Manual

imagesettile

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

imagesettile — Resmi doldurmak için döşemeyi etkin kılar

Açıklama

bool imagesettile ( resource $image , resource $karo )

imagesettile() işlevi, imagefill() ve imagefilledpolygon() gibi resim doldurma işlevleri tarafından özel IMG_COLOR_TILED rengiyle doldurulmak üzere resim döşemeyi etkin kılar.

Bir karo, resim alanını doldurmak üzere yinelenen bir resim karesidir. Karo olarak herhangi bir GD resmi kullanılabilir ve karo resmine imagecolortransparent() ile şeffaf renk indisi atanabilir. Bir karo, döşeneceği alanın belli parçaları parlak olacak şekilde oluşturulabilir.

Bilginize:

Bir karo ile işiniz bittiğinde özel bir işlem yapmanız gerekmez, fakat eğer karo resmini silerseniz, yeni bir karo resmi oluşturana kadar IMG_COLOR_TILED rengini kullanmamalısınız!

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

karo

Bir karo olarak kullanılacak resim özkaynağı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - imagesettile() örneği

<?php
// Bir resim yükleyelim
$zend = imagecreatefromgif('./zend.gif');

// 200x200 bir resim oluşturalım
$im = imagecreatetruecolor(200, 200);

// Döşemeyi etkin kılalım
imagesettile($im, $zend);

// Yüklediğimiz resmin döşenmesini sağlayalım
imagefilledrectangle($im, 0, 0, 199, 199, IMG_COLOR_TILED);

// Resmi tarayıcıya gönderelim
header('Content-Type: image/png');

imagepng($im);
imagedestroy($im);
imagedestroy($zend);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

imagesetthickness
imagestring
GD ve Resim İşlevleri


Bir dizgeyi yatay olarak yazar

imagesettile
imagestringup
GD ve Resim İşlevleri
PHP Manual

imagestring

(PHP 4, PHP 5, PHP 7)

imagestring — Bir dizgeyi yatay olarak yazar

Açıklama

bool imagestring ( resource $resim , int $yazıtipi , int $x , int $y , string $dizge , int $renk )

Belirtilen dizge'yi belirtilen yere çizer.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

yazıtipi

Belirtilecek değer, Latin2 kodlamalı yerleşik yazı tipleri için 1, 2, 3, 4, 5 (daha büyük numara daha yüksek yazı tipine karşılıktır) veya imageloadfont() ile tanımlanmış kendi yazı tipi betimleyicilerinizden biri olabilir.

x

Üst sol köşenin X konumu.

y

Üst sol köşenin Y konumu.

dizge

Çizilecek dizge.

renk

imagecolorallocate() tarafından oluşturulmuş bir renk tanıtıcısı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - imagestring() örneği

<?php
// 100*30'luk bir resim oluşturalım
$im = imagecreate(100, 30);

// Beyaz artalan üstüne mavi metin
$bg = imagecolorallocate($im, 255, 255, 255);
$textcolor = imagecolorallocate($im, 0, 0, 255);

// Dizgeyi resmin sol üst tarafına yazalım
imagestring($im, 5, 0, 0, 'Hello world!', $textcolor);

// Resmi çıktılayalım
header('Content-type: image/png');

imagepng($im);
imagedestroy($im);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ayrıca Bakınız

  • imageloadfont() - Yeni bir bit eşlemli yazı tipi yükler
  • imagettftext() - Metni resme TrueType yazı tipi ile yazar

imagesettile
imagestringup
GD ve Resim İşlevleri


Bir dizgeyi 90 derece döndürülmüş olarak yazar

imagestring
imagesx
GD ve Resim İşlevleri
PHP Manual

imagestringup

(PHP 4, PHP 5, PHP 7)

imagestringup — Bir dizgeyi 90 derece döndürülmüş olarak yazar

Açıklama

bool imagestringup ( resource $resim , int $yazıtipi , int $x , int $y , string $dizge , int $renk )

Belirtilen dizgeyi belirtilen yere düşey olarak yazar.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

yazıtipi

Belirtilecek değer, Latin2 kodlamalı yerleşik yazı tipleri için 1, 2, 3, 4, 5 (daha büyük numara daha yüksek yazı tipine karşılıktır) veya imageloadfont() ile tanımlanmış kendi yazı tipi betimleyicilerinizden biri olabilir.

x

Üst sol köşenin X konumu.

y

Üst sol köşenin Y konumu.

dizge

Resme çizilecek dizge.

renk

imagecolorallocate() tarafından oluşturulmuş bir renk tanıtıcısı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - imagestring() örneği

<?php
// 100*100 bir resim oluşturalım
$im = imagecreatetruecolor(100, 100);

// Metni çizelim
$textcolor = imagecolorallocate($im, 0xFF, 0xFF, 0xFF);
imagestringup($im, 3, 40, 80, 'gd library', $textcolor);

// Resmi kaydedelim
imagepng($im, './stringup.png');
imagedestroy($im);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ayrıca Bakınız

  • imageloadfont() - Yeni bir bit eşlemli yazı tipi yükler

imagestring
imagesx
GD ve Resim İşlevleri


Resmin genişliğini döndürür

imagestringup
imagesy
GD ve Resim İşlevleri
PHP Manual

imagesx

(PHP 4, PHP 5, PHP 7)

imagesx — Resmin genişliğini döndürür

Açıklama

int imagesx ( resource $resim )

Belirtilen resmin genişliğini döndürür

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

Dönen Değerler

Hata oluşmuşsa FALSE, aksi takdirde belirtilen resmin genişliğini döndürür.

Örnekler

Örnek 1 - imagesx() örneği

<?php

// 300*200'lük bir resim oluşturalım
$img = imagecreatetruecolor(300, 200);

echo imagesx($img); // çıktısı: 300

?>

Ayrıca Bakınız

  • imagecreatetruecolor() - Yeni bir gerçek renkli resim oluşturur
  • getimagesize() - Bir resmin boyutlarını döndürür
  • imagesy() - Resmin yüksekliğini döndürür

imagestringup
imagesy
GD ve Resim İşlevleri


Resmin yüksekliğini döndürür

imagesx
imagetruecolortopalette
GD ve Resim İşlevleri
PHP Manual

imagesy

(PHP 4, PHP 5, PHP 7)

imagesy — Resmin yüksekliğini döndürür

Açıklama

int imagesy ( resource $resim )

Belirtilen resmin yüksekliğini döndürür.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

Dönen Değerler

Hata oluşmuşsa FALSE, aksi takdirde belirtilen resmin yüksekliğini döndürür.

Örnekler

Örnek 1 - imagesy() örneği

<?php

// 300*200'lük bir resim oluşturalım
$img = imagecreatetruecolor(300, 200);

echo imagesy($img); // çıktısı: 200

?>

Ayrıca Bakınız

  • imagecreatetruecolor() - Yeni bir gerçek renkli resim oluşturur
  • getimagesize() - Bir resmin boyutlarını döndürür
  • imagesx() - Resmin genişliğini döndürür

imagesx
imagetruecolortopalette
GD ve Resim İşlevleri


Bir gerçek renkli resmi bir paletli resme dönüştürür

imagesy
imagettfbbox
GD ve Resim İşlevleri
PHP Manual

imagetruecolortopalette

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

imagetruecolortopalette — Bir gerçek renkli resmi bir paletli resme dönüştürür

Açıklama

bool imagetruecolortopalette ( resource $resim , bool $titrek , int $renk_sayısı )

imagetruecolortopalette() işlevi bir gerçek renkli resmi bir paletli resme dönüştürür. Bu işlevde Bağımsız JPEG Grubunun kütüphanesindeki çok iyi sonuçlar veren özgün koddan yararlanılmıştır. Paleti elde etmek için alfa kanalı bilgisi ve mevcut renkler mümkün olduğunca korunmaya çalışılarak kodda değişiklik yapılmıştır. Bu umulduğu kadar iyi çalışmamaktadır. En yüksek çıktı kalitesine ulaşmak için en iyisi gerçek renkli resim çıktısı üretimini basitleştirmektir.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

titrek

Resmin titrek olup olmayacağı belirtilir. Resmin titrek olması için TRUE belirtildiği takdirde resim daha benekli olur fakat renk geçişleri daha iyi olur.

renk_sayısı

Palette bulunacak azami renk sayısı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Bir gerçek renkli resmi bir paletli resme dönüştürmek

<?php
// Bir gerçek renkli resim oluşturalım
$im = new imagecreatetruecolor(100, 100);

// 255 renkli bir palete sahip bir resme dönüştürelim
imagetruecolortopalette($im, false, 255);

// Resmi kaydedelim
imagepng($im, './paletteimage.png');
imagedestroy($im);
?>

Notlar

Bilginize: Bu işlev GD'nin 2.0.1 veya sonraki sürümlerini gerektirir (2.0.28 veya sonraki sürümler önerilir).

imagesy
imagettfbbox
GD ve Resim İşlevleri


TrueType yazıtipi kullanılan bir metnin çerçevesini döndürür

imagetruecolortopalette
imagettftext
GD ve Resim İşlevleri
PHP Manual

imagettfbbox

(PHP 4, PHP 5, PHP 7)

imagettfbbox — TrueType yazıtipi kullanılan bir metnin çerçevesini döndürür

Açıklama

array imagettfbbox ( float $boyut , float $açı , string $yazıtipi , string $metin )

Bir TrueType metin için yazıyı çevreleyen kutunun sınırlarını piksel cinsinden hesaplar ve sonucu bir dizi içinde döndürür.

Değiştirgeler

boyut

Yazıtipi yüksekliği. Kullandığınız GD sürümüne bağlı olarak piksel (GD1) veya punto (GD2) olarak belirtilmelidir.

açı

Belirtilen metnin yazım açısı.

yazıtipi

Kullanılacak TrueType yazıtipinin dosya yolu (URL olabilir).

PHP'nin kullandığı GD kütüphanesi sürümüne bağlı olarak, / ile başlamayan bir dosya ismine .ttf uzantısı eklenir ve kütüphane bu dosya ismini kütüphanede tanımlı dizinlerde arar.

metin

Çerçevesi hesaplanacak metin.

Dönen Değerler

Bir hata durumunda FALSE yoksa metin çerçevesinin dört köşesinin koordinatlarını içeren 8 elemanlı bir dizi döner:

anahtar | içeriği
0 | Sol alt köşenin X konumu
1 | Sol alt köşenin Y konumu
2 | Sağ alt köşenin X konumu
3 | Sağ alt köşenin Y konumu
4 | Sağ üst köşenin X konumu
5 | Sağ üst köşenin Y konumu
6 | Sol üst köşenin X konumu
7 | Sol üst köşenin Y konumu

Noktalar açıdan bağımsız olarak metne görelidir. Yani, "sol üst" denince metne yatay olarak bakarkenki sol üst köşe kastedilmektedir.

Örnekler

Örnek 1 - imagettfbbox() örneği

<?php
// 300x150'lik bir resim oluşturalım
$im = imagecreatetruecolor(300, 150);
$black = imagecolorallocate($im, 0, 0, 0);
$white = imagecolorallocate($im, 255, 255, 255);

// Artalan rengi beyaz olsun
imagefilledrectangle($im, 0, 0, 299, 299, $white);

// Bu yazı tipi dosyamız olsun
$font = './arial.ttf';

// İlk metnimizin çerçevesini oluşturalım
$bbox = imagettfbbox(10, 45, $font, 'Powered by PHP ' . phpversion());

// Bunlar bizim X ve Y koordinatlarımız olsun
$x = $bbox[0] + (imagesx($im) / 2) - ($bbox[4] / 2) - 25;
$y = $bbox[1] + (imagesy($im) / 2) - ($bbox[5] / 2) - 5;

// Metni yazalım
imagettftext($im, 10, 45, $x, $y, $black, $font, 'Powered by PHP ' . phpversion());

// Şimdi ikinci metnin çerçevesini oluşturalım
$bbox = imagettfbbox(10, 45, $font, 'and Zend Engine ' . zend_version());

// Bu metin ilkinin altında olsun
$x = $bbox[0] + (imagesx($im) / 2) - ($bbox[4] / 2) + 10;
$y = $bbox[1] + (imagesy($im) / 2) - ($bbox[5] / 2) - 5;

// Metni yazalım
imagettftext($im, 10, 45, $x, $y, $black, $font, 'and Zend Engine ' . zend_version());

// Tarayıcıya çıktılayalım
header('Content-type: image/png');

imagepng($im);
imagedestroy($im);
?>

Notlar

Bilginize:

Bu işlev hem GD kütüphanesini hem de » FreeType kütüphanesini gerektirir.

Ayrıca Bakınız

  • imagettftext() - Metni resme TrueType yazı tipi ile yazar

imagetruecolortopalette
imagettftext
GD ve Resim İşlevleri


Metni resme TrueType yazı tipi ile yazar

imagettfbbox
imagetypes
GD ve Resim İşlevleri
PHP Manual

imagettftext

(PHP 4, PHP 5, PHP 7)

imagettftext — Metni resme TrueType yazı tipi ile yazar

Açıklama

array imagettftext ( resource $resim , float $boyut , float $açı , int $x , int $y , int $renk , string $yazıtipi , string $metin )

Belirtilen metni belirtilen TrueType yazı tipi ile belirtilen resme yazar.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

boyut

Yazıtipi yüksekliği. Kullandığınız GD sürümüne bağlı olarak piksel (GD1) veya punto (GD2) olarak belirtilmelidir.

açı

Derece cinsinden açı. Soldan sağa yazılan bir metnin açısı 0 derecedir. Daha büyük değerler yelkovanın ters yönünde belirtilmiş varsayılır. Örneğin 90 derecelik bir metin aşağıdan yukarı doğru yazılır.

x

x ve y ile belirtilen koordinatlar ilk harfin taban noktasını (kabaca harfin sol alt köşesi) tanımlar. Bu tanımlama, koordinatların harfin sol üst köşesini tanımladığı imagestring() işlevinden farklıdır. Resmin sol üst köşesinin koordinatları 0, 0'dır.

y

x değiştirgesine bakınız.

renk

Renk indisi. Negatif bir renk indisi kenar yumuşatmayı kapatır. imagecolorallocate() işlevine bakınız.

yazıtipi

Kullanılacak TrueType yazıtipinin dosya yolu.

PHP'nin kullandığı GD kütüphanesi sürümüne bağlı olarak, / ile başlamayan bir dosya ismine .ttf uzantısı eklenir ve kütüphane bu dosya ismini kütüphanede tanımlı dizinlerde arar.

GD kütüphanesinin 2.0.18'den küçük sürümlerini kullanıyorsanız, farklı yazıtipi dosyalarının aralarına noktalı virgül değil boşluk karakteri koymalısınız. Bu kurala dikkat etmezseniz şöyle bir uyarı alırsınız: Warning: Could not find/open font (Uyarı: Yazı tipi bulunamadı veya açılamadı). Boşluk içeren dosya yollarının varlığında bu sürümler için tek çözüm yazı tiplerinin boşluk içermeyen dosya yollarına taşınmasıdır.

Yazı tiplerinin betikle aynı dizinde bulunduğu durumlarda herhangi bir sorun çıkmaması için aşağıdaki çözüm kullanılabilir.

<?php
// GD ortam değişkenini tanımlayalım
putenv('GDFONTPATH=' . realpath('.'));

// Kullanılacak yaza tipinin ismi (dikkat: .ttf uzantısı yok)
$font = 'freesans';
?>

metin

UTF-8 kodlanmış metin dizgesi.

Karakter numarası 127'den büyük karakterler için onluk karakter numarası (&#8364; şeklinde) belirtilebilir. Onaltılık gösterim de (&#xA9; şeklinde) desteklenmektedir. UTF-8 kodlu metinler doğrudan aktarılabilir.

&copy; gibi isimli öğeler desteklenmemektedir. Bu tür isimli öğeleri UTF-8 dizgelerde kullanmak için PHP 5.0.0'dan itibaren html_entity_decode() işlevi ile dönüştürebilirsiniz.

Eğer yazı tipi tarafından desteklenmeyen bir karakter belirtirseniz karakterin yerinde boş bir dikdörtgen görürsünüz.

Dönen Değerler

Hata durumunda FALSE yoksa metin çerçevesinin dört köşesinin koordinatlarını içeren 8 elemanlı bir dizi döner. Çerçevenin köşeleri dizide sırayla şunlardır: sol alt, sağ alt, sağ üst, sol üst. Noktalar açıdan bağımsız olarak metne görelidir. Yani, "sol üst" denince metne yatay olarak bakarkenki sol üst köşe kastedilmektedir.

Sürüm Bilgisi

Sürüm: | Açıklama
5.2.0 | metin içinde onaltılık öğeler belirtmek mümkün oldu.

Örnekler

Örnek 1 - imagettftext() örneği

Bu örnek betik, içinde Arial yazı tipi ile siyah renkte (gri gölgeli) "Testing..." yazılmış 400x30 piksellik beyaz bir PNG resmi üretecektir.

<?php
// İçerik türünü belirtelim
header('Content-type: image/png');

// Resmi boş olarak oluşturalım
$resim = imagecreatetruecolor(400, 30);

// Renkleri tanımlayalım
$beyaz = imagecolorallocate($resim, 255, 255, 255);
$gri = imagecolorallocate($resim, 128, 128, 128);
$siyah = imagecolorallocate($resim, 0, 0, 0);
imagefilledrectangle($resim, 0, 0, 399, 29, $beyaz);

// Metni tanımlayalım
$metin = 'Testing...';
// Buraya kendi dosya yolunuzu yazın
$font = 'arial.ttf';

// Metne gölge verelim
imagettftext($resim, 20, 0, 11, 21, $gri, $font, $metin);

// Metni ekleyelim
imagettftext($resim, 20, 0, 10, 20, $siyah, $font, $metin);

// imagejpeg()'ye göre daha temiz sonuç veren imagepng()'yi kullanalım
imagepng($resim);
imagedestroy($resim);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Notlar

Bilginize:

Bu işlev hem GD kütüphanesini hem de » FreeType kütüphanesini gerektirir.

Ayrıca Bakınız

  • imagettfbbox() - TrueType yazıtipi kullanılan bir metnin çerçevesini döndürür

imagettfbbox
imagetypes
GD ve Resim İşlevleri


Kurulu PHP'nin desteklediği resim türlerini döndürür

imagettftext
imagewbmp
GD ve Resim İşlevleri
PHP Manual

imagetypes

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

imagetypes — Kurulu PHP'nin desteklediği resim türlerini döndürür

Açıklama

int imagetypes ( void )

Kurulu PHP'nin desteklediği resim türlerini döndürür.

Dönen Değerler

PHP ile ilitilenmiş GD kütüphanesinin desteklediği resim biçemleri ile ilgili bir bit alanı döndürür. Bu alanla sınanabilecek sabitlerin isimleri: IMG_GIF | IMG_JPG | IMG_PNG | IMG_WBMP | IMG_XPM.

Örnekler

Örnek 1 - PNG desteğinin sınanması

<?php
if (imagetypes() & IMG_PNG) {
    echo "PNG destekleniyor";
}
?>

imagettftext
imagewbmp
GD ve Resim İşlevleri


Resmi bir dosyaya veya tarayıcıya çıktılar

imagetypes
imagewebp
GD ve Resim İşlevleri
PHP Manual

imagewbmp

(PHP 4 >= 4.0.1, PHP 5, PHP 7)

imagewbmp — Resmi bir dosyaya veya tarayıcıya çıktılar

Açıklama

bool imagewbmp ( resource $resim [, string $dosyaismi [, int $artalan ]] )

Belirtilen resmi WBMP biçemli olarak çıktılar veya kaydeder.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

dosyaismi

Resmin kaydedileceği dosyanın yolu. Belirtilmez veya NULL verilirse doğrudan ham resim akımı çıktılanır.

artalan

imagecolorallocate() tarafından sağlanmış bir tanıtıcı ile bir artalan rengi tanımlayabilirsiniz. Öntanımlı artalan rengi siyahtır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Bir WBMP resmini çıktılamak

<?php
// Boş bir resim oluşturup üzerine bir metin ekleyelim
$resim = imagecreatetruecolor(120, 20);
$metin_rengi = imagecolorallocate($resim, 233, 14, 91);
imagestring($resim, 1, 5, 5,  'Bir deneme dizgesi', $metin_rengi);

// İçerik türü başlığını ayarlayalım: image/vnd.wap.wbmp
// İpucu: içerik türleri için image_type_to_mime_type() işlevine bakınız
header('Content-type: image/vnd.wap.wbmp');

// Resmi çıktılayalım
imagewbmp($resim);

// Belleği serbest bırakalım
imagedestroy($resim);
?>

Örnek 2 - Bir WBMP resminin kaydedilmesi

<?php
// Boş bir resim oluşturup üzerine bir metin ekleyelim
$resim = imagecreatetruecolor(120, 20);
$metin_rengi = imagecolorallocate($resim, 233, 14, 91);
imagestring($resim, 1, 5, 5,  'Bir deneme dizgesi', $metin_rengi);

// Resmi kaydedelim
imagewbmp($im, 'dnm.wbmp');

// Belleği serbest bırakalım
imagedestroy($im);
?>

Örnek 3 - Resmi farklı bir artalan rengi ile çıktılamak

<?php
// Boş bir resim oluşturup üzerine bir metin ekleyelim
$resim = imagecreatetruecolor(120, 20);
$metin_rengi = imagecolorallocate($resim, 233, 14, 91);
imagestring($resim, 1, 5, 5,  'Bir deneme dizgesi', $metin_rengi);

// İçerik türü başlığını ayarlayalım: image/vnd.wap.wbmp
// İpucu: içerik türleri için image_type_to_mime_type() işlevine bakınız
header('Content-type: image/vnd.wap.wbmp');

// Yeni artalan rengini ayarlayalım
$artalan_rengi = imagecolorallocate($resim, 255, 0, 0);

imagewbmp($resim, NULL, $artalan_rengi);

// Free up memory
imagedestroy($resim);
?>

Notlar

Bilginize:

WBMP desteği sadece PHP, GD kütüphanesinin 1.8 veya sonraki sürümleri ile derlenmişse mevcuttur.

Ayrıca Bakınız

  • image2wbmp() - Bir dosyaya veya tarayıcıya bir WBMP resmi çıktılar
  • imagepng() - Tarayıcıya veya bir dosyaya bir PNG resmi çıktılar
  • imagegif() - Bir dosyaya veya tarayıcıya bir GIF resmi çıktılar
  • imagejpeg() - Tarayıcıya veya bir dosyaya bir JPEG resmi çıktılar
  • imagetypes() - Kurulu PHP'nin desteklediği resim türlerini döndürür

imagetypes
imagewebp
GD ve Resim İşlevleri


Output a WebP image to browser or file

imagewbmp
imagexbm
GD ve Resim İşlevleri
PHP Manual

imagewebp

(PHP 5 >= 5.5.0, PHP 7)

imagewebp — Output a WebP image to browser or file

Açıklama

bool imagewebp ( resource $image , mixed $to [, int $quality = 80 ] )

Outputs or save an WebP version of the given image.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

to

Dosyanın kaydedileceği yer. NULL atanırsa dosyanın içeriği çıktılanır.

quality

quality ranges from 0 (worst quality, smaller file) to 100 (best quality, biggest file).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.4.0 | Added support for passing a stream resource to to.

Örnekler

Örnek 1 Saving an WebP file

<?php
// Create a blank image and add some text
$im = imagecreatetruecolor(120, 20);
$text_color = imagecolorallocate($im, 233, 14, 91);

imagestring($im, 1, 5, 5,  'WebP with PHP', $text_color);

// Save the image
imagewebp($im, 'php.webp');

// Free up memory
imagedestroy($im);
?>

imagewbmp
imagexbm
GD ve Resim İşlevleri


Bir XBM resmini tarayıcıya veya dosyaya çıktılar

imagewebp
iptcembed
GD ve Resim İşlevleri
PHP Manual

imagexbm

(PHP 5, PHP 7)

imagexbm — Bir XBM resmini tarayıcıya veya dosyaya çıktılar

Açıklama

bool imagexbm ( resource $resim , string $dosyaismi [, int $artalan ] )

Belirtilen resmin XBM sürümünü çıktılar veya kaydeder.

Değiştirgeler

resim

imagecreatetruecolor() gibi bir resim oluşturma işlevinden dönen bir resim verisi.

dosyaismi

Resmin kaydedileceği dosyanın yolu. Belirtilmez veya NULL verilirse doğrudan ham resim akımı çıktılanır.

artalan

imagecolorallocate() tarafından sağlanmış bir tanıtıcı ile bir artalan rengi tanımlayabilirsiniz. Öntanımlı artalan rengi siyahtır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Bir XBM dosyasının kaydedilmesi

<?php
// Boş bir resim oluşturup üzerine bir metin ekleyelim
$resim = imagecreatetruecolor(120, 20);
$metin_rengi = imagecolorallocate($resim, 233, 14, 91);
imagestring($resim, 1, 5, 5,  'Bir deneme dizgesi', $metin_rengi);

// Resmi kaydedelim
imagexbm($resim, 'dnm.xbm');

// Belleği serbest bırakalım.
imagedestroy($resim);
?>

Örnek 2 - XBM dosyasını farklı bir artalan rengi ile çıktılamak

<?php
// Boş bir resim oluşturup üzerine bir metin ekleyelim
$resim = imagecreatetruecolor(120, 20);
$metin_rengi = imagecolorallocate($resim, 233, 14, 91);
imagestring($resim, 1, 5, 5,  'Bir deneme dizgesi', $metin_rengi);

// Yeni artalan rengini ayarlayalım
$artalan_rengi = imagecolorallocate($resim, 255, 0, 0);

// Resmi çıktılayalım
imagexbm($resim, NULL, $artalan_rengi);

// Belleği serbest bırakalım
imagedestroy($resim);
?>

Notlar

Bilginize: Bu işlev sadece, PHP, PHP paketinde bulunan GD kütüphanesi ile derlenmişse kullanılabilir.

imagewebp
iptcembed
GD ve Resim İşlevleri


İkil IPTC verisini bir JPEG resminin içine gömer

imagexbm
iptcparse
GD ve Resim İşlevleri
PHP Manual

iptcembed

(PHP 4, PHP 5, PHP 7)

iptcembed — İkil IPTC verisini bir JPEG resminin içine gömer

Açıklama

mixed iptcembed ( string $iptcverisi , string $jpeg_dosya_ismi [, int $kuyruk ] )

İkil IPTC verisini bir JPEG resminin içine gömer.

Değiştirgeler

iptcverisi

Yazılacak veri.

jpeg_dosya_ismi

JPEG resminin dosya yolu.

kuyruk

Kuyruk seçeneği; 2'den büyükse JPEG bir dizge olarak döner.

Dönen Değerler

Bir hata oluşursa FALSE döner. Başarı durumunda kuyruk seçeneği 2'den küçükse JPEG bir dizge olarak dönmez.

Örnekler

Örnek 1 - IPTC verisinin bir JPEG içine gömülmesi

<?php

// Thies C. Arntzen'in yazdığı iptc_make_tag() işlevi
function iptc_make_tag($rec, $data, $value)
{
    $length = strlen($value);
    $retval = chr(0x1C) . chr($rec) . chr($data);

    if($length < 0x8000)
    {
        $retval .= chr($length >> 8) .  chr($length & 0xFF);
    }
    else
    {
        $retval .= chr(0x80) .
                   chr(0x04) .
                   chr(($length >> 24) & 0xFF) .
                   chr(($length >> 16) & 0xFF) .
                   chr(($length >> 8) & 0xFF) .
                   chr($length & 0xFF);
    }

    return $retval . $value;
}

// jpeg dosyasının yolu
$path = './phplogo.jpg';

// Önce jpeg dosyasında IPTC verisi var mı diye bakacağız.
// Varsa vazgeçeceğiz, çünkü IPTC verisi varsa herhangi bir resim gömemeyiz!
$image = getimagesize($path, $info);

if(isset($info['APP13']))
{
    die('Hata: Belirtilen resimde IPTC verisi bulundu, devam edilemiyor.');
}

// IPTC etiketlerini düzenleyelim
$iptc = array(
    '2#120' => 'Test image',
    '2#116' => 'Copyright 2008-2009, The PHP Group'
);

// IPTC etiketlerini ikil veriye dönüştürelim
$data = '';

foreach($iptc as $tag => $string)
{
    $tag = substr($tag, 2);
    $data .= iptc_make_tag(2, $tag, $string);
}

// IPTC verisini resme gömelim.
$content = iptcembed($data, $path);

// Yeni resim verisini dosyaya yazalım.
$fp = fopen($path, "wb");
fwrite($fp, $content);
fclose($fp);
?>

Notlar

Bilginize:

Bu işlev için GD resim kütüphanesi gerekli değildir.

imagexbm
iptcparse
GD ve Resim İşlevleri


Bir ikil IPTC bloğunu tekil etiketlere böler

iptcembed
jpeg2wbmp
GD ve Resim İşlevleri
PHP Manual

iptcparse

(PHP 4, PHP 5, PHP 7)

iptcparse — Bir ikil IPTC bloğunu tekil etiketlere böler

Açıklama

array iptcparse ( string $iptcbloğu )

Bir » IPTC bloğunu tekil etiketler halinde çözümler.

Değiştirgeler

iptcbloğu

Bir ikil IPTC bloğu.

Dönen Değerler

İndis olarak etiket imleyici ve değer olarak değeri kullanan bir dizi döndürür. Bir hata oluşmuşsa veya hiç IPTC verisi yoksa FALSE döner.

Örnekler

Örnek 1 - getimagesize() ile iptcparse() kullanımı

<?php
$size = getimagesize('./test.jpg', $info);
if(isset($info['APP13']))
{
    $iptc = iptcparse($info['APP13']);
    var_dump($iptc);
}
?>

Notlar

Bilginize:

Bu işlev için GD resim kütüphanesi gerekli değildir.

iptcembed
jpeg2wbmp
GD ve Resim İşlevleri


Bir JPEG dosyasını WBMP dosyasına dönüştürür

iptcparse
png2wbmp
GD ve Resim İşlevleri
PHP Manual

jpeg2wbmp

(PHP 4 >= 4.0.5, PHP 5, PHP 7)

jpeg2wbmp — Bir JPEG dosyasını WBMP dosyasına dönüştürür

Açıklama

bool jpeg2wbmp ( string $jpegdosya , string $wbmpdosya , int $hdf_yüks , int $hdf_genş , int $eşik )

Bir JPEG resim dosyasını WBMP resim dosyasına dönüştürür.

Değiştirgeler

jpegdosya

JPEG dosyasının yolu.

wbmpdosya

Hedef WBMP dosyasının yolu.

hdf_yüks

Hedef resmin yüksekliği.

hdf_genş

Hedef resmin genişliği.

eşik

0'dan 8'e kadar eşik değer.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - jpeg2wbmp() örneği

<?php
// JPEG resmimiz
$jpg = './dnm.jpg';

// Resim boyutlarını öğrenelim
$boyutlar = getimagesize($jpg);

// Resmi dönüştürelim
jpeg2wbmp($jpg, './dnm.wbmp', $boyutlar[1], $boyutlar[0], 5);
?>

Notlar

Bilginize: WBMP desteği sadece, PHP, GD'nin 1.8 veya sonraki bir sürümünün kurulu olduğu bir platformda derlenmişse kullanılabilir.

Bilginize: JPEG desteği sadece, PHP, GD'nin 1.8 veya sonraki bir sürümünün kurulu olduğu bir platformda derlenmişse kullanılabilir.

Ayrıca Bakınız

  • png2wbmp() - Bir PNG dosyasını WBMP dosyasına dönüştürür

iptcparse
png2wbmp
GD ve Resim İşlevleri


Bir PNG dosyasını WBMP dosyasına dönüştürür

jpeg2wbmp
Gmagick
GD ve Resim İşlevleri
PHP Manual

png2wbmp

(PHP 4 >= 4.0.5, PHP 5, PHP 7)

png2wbmp — Bir PNG dosyasını WBMP dosyasına dönüştürür

Açıklama

bool png2wbmp ( string $pngdosya , string $wbmpdosya , int $hdf_yüks , int $hdf_genş , int $eşik )

Bir PNG resim dosyasını WBMP resim dosyasına dönüştürür.

Değiştirgeler

pngdosya

PNG dosyasının yolu.

wbmpdosya

Hedef WBMP dosyasının yolu.

hdf_yüks

Hedef resmin yüksekliği.

hdf_genş

Hedef resmin genişliği.

eşik

0'dan 8'e kadar eşik değer.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - png2wbmp() örneği

<?php
// PNG dosyamız
$png = './dnm.png';

// Resim boyutlarını öğrenelim
$boyutlar = getimagesize($png);

// Resmi dönüştürelim
png2wbmp($png, './dnm.wbmp', $boyutlar[1], $boyutlar[0], 7);
?>

Notlar

Bilginize: WBMP desteği sadece, PHP, GD'nin 1.8 veya sonraki bir sürümünün kurulu olduğu bir platformda derlenmişse kullanılabilir.

Ayrıca Bakınız

  • jpeg2wbmp() - Bir JPEG dosyasını WBMP dosyasına dönüştürür

jpeg2wbmp
Gmagick
GD ve Resim İşlevleri


Gmagick

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
  • Öntanımlı Sabitler
  • Örnekler
  • Gmagick — The Gmagick class
    • Gmagick::addimage — Adds new image to Gmagick object image list
    • Gmagick::addnoiseimage — Adds random noise to the image
    • Gmagick::annotateimage — Annotates an image with text
    • Gmagick::blurimage — Adds blur filter to image
    • Gmagick::borderimage — Surrounds the image with a border
    • Gmagick::charcoalimage — Simulates a charcoal drawing
    • Gmagick::chopimage — Removes a region of an image and trims
    • Gmagick::clear — Clears all resources associated to Gmagick object
    • Gmagick::commentimage — Adds a comment to your image
    • Gmagick::compositeimage — Composite one image onto another
    • Gmagick::__construct — The Gmagick constructor
    • Gmagick::cropimage — Extracts a region of the image
    • Gmagick::cropthumbnailimage — Creates a crop thumbnail
    • Gmagick::current — The current purpose
    • Gmagick::cyclecolormapimage — Displaces an image's colormap
    • Gmagick::deconstructimages — Returns certain pixel differences between images
    • Gmagick::despeckleimage — The despeckleimage purpose
    • Gmagick::destroy — The destroy purpose
    • Gmagick::drawimage — Renders the GmagickDraw object on the current image
    • Gmagick::edgeimage — Enhance edges within the image
    • Gmagick::embossimage — Returns a grayscale image with a three-dimensional effect
    • Gmagick::enhanceimage — Improves the quality of a noisy image
    • Gmagick::equalizeimage — Equalizes the image histogram
    • Gmagick::flipimage — Creates a vertical mirror image
    • Gmagick::flopimage — The flopimage purpose
    • Gmagick::frameimage — Adds a simulated three-dimensional border
    • Gmagick::gammaimage — Gamma-corrects an image
    • Gmagick::getcopyright — Returns the GraphicsMagick API copyright as a string
    • Gmagick::getfilename — The filename associated with an image sequence
    • Gmagick::getimagebackgroundcolor — Returns the image background color
    • Gmagick::getimageblueprimary — Returns the chromaticy blue primary point
    • Gmagick::getimagebordercolor — Returns the image border color
    • Gmagick::getimagechanneldepth — Gets the depth for a particular image channel
    • Gmagick::getimagecolors — Returns the color of the specified colormap index
    • Gmagick::getimagecolorspace — Gets the image colorspace
    • Gmagick::getimagecompose — Returns the composite operator associated with the image
    • Gmagick::getimagedelay — Gets the image delay
    • Gmagick::getimagedepth — Gets the depth of the image
    • Gmagick::getimagedispose — Gets the image disposal method
    • Gmagick::getimageextrema — Gets the extrema for the image
    • Gmagick::getimagefilename — Returns the filename of a particular image in a sequence
    • Gmagick::getimageformat — Returns the format of a particular image in a sequence
    • Gmagick::getimagegamma — Gets the image gamma
    • Gmagick::getimagegreenprimary — Returns the chromaticy green primary point
    • Gmagick::getimageheight — Returns the image height
    • Gmagick::getimagehistogram — Gets the image histogram
    • Gmagick::getimageindex — Gets the index of the current active image
    • Gmagick::getimageinterlacescheme — Gets the image interlace scheme
    • Gmagick::getimageiterations — Gets the image iterations
    • Gmagick::getimagematte — Check if the image has a matte channel
    • Gmagick::getimagemattecolor — Returns the image matte color
    • Gmagick::getimageprofile — Returns the named image profile.
    • Gmagick::getimageredprimary — Returns the chromaticity red primary point
    • Gmagick::getimagerenderingintent — Gets the image rendering intent
    • Gmagick::getimageresolution — Gets the image X and Y resolution
    • Gmagick::getimagescene — Gets the image scene
    • Gmagick::getimagesignature — Generates an SHA-256 message digest
    • Gmagick::getimagetype — Gets the potential image type.
    • Gmagick::getimageunits — Gets the image units of resolution
    • Gmagick::getimagewhitepoint — Returns the chromaticity white point
    • Gmagick::getimagewidth — Returns the width of the image
    • Gmagick::getpackagename — Returns the GraphicsMagick package name.
    • Gmagick::getquantumdepth — Returns the Gmagick quantum depth as a string.
    • Gmagick::getreleasedate — Returns the GraphicsMagick release date as a string.
    • Gmagick::getsamplingfactors — Gets the horizontal and vertical sampling factor.
    • Gmagick::getsize — Returns the size associated with the Gmagick object
    • Gmagick::getversion — Returns the GraphicsMagick API version
    • Gmagick::hasnextimage — Checks if the object has more images
    • Gmagick::haspreviousimage — Checks if the object has a previous image
    • Gmagick::implodeimage — Creates a new image as a copy
    • Gmagick::labelimage — Adds a label to an image.
    • Gmagick::levelimage — Adjusts the levels of an image
    • Gmagick::magnifyimage — Scales an image proportionally 2x
    • Gmagick::mapimage — Replaces the colors of an image with the closest color from a reference image.
    • Gmagick::medianfilterimage — Applies a digital filter
    • Gmagick::minifyimage — Scales an image proportionally to half its size
    • Gmagick::modulateimage — Control the brightness, saturation, and hue
    • Gmagick::motionblurimage — Simulates motion blur
    • Gmagick::newimage — Creates a new image
    • Gmagick::nextimage — Moves to the next image
    • Gmagick::normalizeimage — Enhances the contrast of a color image
    • Gmagick::oilpaintimage — Simulates an oil painting
    • Gmagick::previousimage — Move to the previous image in the object
    • Gmagick::profileimage — Adds or removes a profile from an image
    • Gmagick::quantizeimage — Analyzes the colors within a reference image
    • Gmagick::quantizeimages — The quantizeimages purpose
    • Gmagick::queryfontmetrics — Returns an array representing the font metrics
    • Gmagick::queryfonts — Returns the configured fonts
    • Gmagick::queryformats — Returns formats supported by Gmagick.
    • Gmagick::radialblurimage — Radial blurs an image
    • Gmagick::raiseimage — Creates a simulated 3d button-like effect
    • Gmagick::read — Reads image from filename
    • Gmagick::readimage — Reads image from filename
    • Gmagick::readimageblob — Reads image from a binary string
    • Gmagick::readimagefile — The readimagefile purpose
    • Gmagick::reducenoiseimage — Smooths the contours of an image
    • Gmagick::removeimage — Removes an image from the image list
    • Gmagick::removeimageprofile — Removes the named image profile and returns it
    • Gmagick::resampleimage — Resample image to desired resolution
    • Gmagick::resizeimage — Scales an image
    • Gmagick::rollimage — Offsets an image
    • Gmagick::rotateimage — Rotates an image
    • Gmagick::scaleimage — Scales the size of an image
    • Gmagick::separateimagechannel — Separates a channel from the image
    • Gmagick::setCompressionQuality — Sets the object's default compression quality
    • Gmagick::setfilename — Sets the filename before you read or write the image
    • Gmagick::setimagebackgroundcolor — Sets the image background color.
    • Gmagick::setimageblueprimary — Sets the image chromaticity blue primary point.
    • Gmagick::setimagebordercolor — Sets the image border color.
    • Gmagick::setimagechanneldepth — Sets the depth of a particular image channel
    • Gmagick::setimagecolorspace — Sets the image colorspace
    • Gmagick::setimagecompose — Sets the image composite operator
    • Gmagick::setimagedelay — Sets the image delay
    • Gmagick::setimagedepth — Sets the image depth
    • Gmagick::setimagedispose — Sets the image disposal method
    • Gmagick::setimagefilename — Sets the filename of a particular image in a sequence
    • Gmagick::setimageformat — Sets the format of a particular image
    • Gmagick::setimagegamma — Sets the image gamma
    • Gmagick::setimagegreenprimary — Sets the image chromaticity green primary point.
    • Gmagick::setimageindex — Set the iterator to the position in the image list specified with the index parameter
    • Gmagick::setimageinterlacescheme — Sets the interlace scheme of the image.
    • Gmagick::setimageiterations — Sets the image iterations.
    • Gmagick::setimageprofile — Adds a named profile to the Gmagick object
    • Gmagick::setimageredprimary — Sets the image chromaticity red primary point.
    • Gmagick::setimagerenderingintent — Sets the image rendering intent
    • Gmagick::setimageresolution — Sets the image resolution
    • Gmagick::setimagescene — Sets the image scene
    • Gmagick::setimagetype — Sets the image type
    • Gmagick::setimageunits — Sets the image units of resolution.
    • Gmagick::setimagewhitepoint — Sets the image chromaticity white point.
    • Gmagick::setsamplingfactors — Sets the image sampling factors.
    • Gmagick::setsize — Sets the size of the Gmagick object
    • Gmagick::shearimage — Creating a parallelogram
    • Gmagick::solarizeimage — Applies a solarizing effect to the image
    • Gmagick::spreadimage — Randomly displaces each pixel in a block
    • Gmagick::stripimage — Strips an image of all profiles and comments
    • Gmagick::swirlimage — Swirls the pixels about the center of the image
    • Gmagick::thumbnailimage — Changes the size of an image
    • Gmagick::trimimage — Remove edges from the image
    • Gmagick::write — Takma Adı: Gmagick::writeimage
    • Gmagick::writeimage — Writes an image to the specified filename
  • GmagickDraw — The GmagickDraw class
    • GmagickDraw::annotate — Draws text on the image
    • GmagickDraw::arc — Draws an arc
    • GmagickDraw::bezier — Draws a bezier curve
    • GmagickDraw::ellipse — Draws an ellipse on the image
    • GmagickDraw::getfillcolor — Returns the fill color
    • GmagickDraw::getfillopacity — Returns the opacity used when drawing
    • GmagickDraw::getfont — Returns the font
    • GmagickDraw::getfontsize — Returns the font pointsize
    • GmagickDraw::getfontstyle — Returns the font style
    • GmagickDraw::getfontweight — Returns the font weight
    • GmagickDraw::getstrokecolor — Returns the color used for stroking object outlines
    • GmagickDraw::getstrokeopacity — Returns the opacity of stroked object outlines
    • GmagickDraw::getstrokewidth — Returns the width of the stroke used to draw object outlines
    • GmagickDraw::gettextdecoration — Returns the text decoration
    • GmagickDraw::gettextencoding — Returns the code set used for text annotations
    • GmagickDraw::line — The line purpose
    • GmagickDraw::point — Draws a point
    • GmagickDraw::polygon — Draws a polygon
    • GmagickDraw::polyline — Draws a polyline
    • GmagickDraw::rectangle — Draws a rectangle
    • GmagickDraw::rotate — Applies the specified rotation to the current coordinate space
    • GmagickDraw::roundrectangle — Draws a rounded rectangle
    • GmagickDraw::scale — Adjusts the scaling factor
    • GmagickDraw::setfillcolor — Sets the fill color to be used for drawing filled objects.
    • GmagickDraw::setfillopacity — The setfillopacity purpose
    • GmagickDraw::setfont — Sets the fully-specified font to use when annotating with text.
    • GmagickDraw::setfontsize — Sets the font pointsize to use when annotating with text.
    • GmagickDraw::setfontstyle — Sets the font style to use when annotating with text
    • GmagickDraw::setfontweight — Sets the font weight
    • GmagickDraw::setstrokecolor — Sets the color used for stroking object outlines.
    • GmagickDraw::setstrokeopacity — Specifies the opacity of stroked object outlines.
    • GmagickDraw::setstrokewidth — Sets the width of the stroke used to draw object outlines.
    • GmagickDraw::settextdecoration — Specifies a decoration
    • GmagickDraw::settextencoding — Specifies the text code set
  • GmagickPixel — The GmagickPixel class
    • GmagickPixel::__construct — The GmagickPixel constructor
    • GmagickPixel::getcolor — Returns the color
    • GmagickPixel::getcolorcount — Returns the color count associated with this color
    • GmagickPixel::getcolorvalue — Gets the normalized value of the provided color channel
    • GmagickPixel::setcolor — Sets the color
    • GmagickPixel::setcolorvalue — Sets the normalized value of one of the channels
png2wbmp
Giriş
Resim İşleme ve Resim Üretimi


Giriş

Gmagick is a php extension to create, modify and obtain meta information of images using the GraphicsMagick API.

GraphicsMagick prides itself as the swiss army knife of image processing. It works with over 88 major formats including important formats like DPX, GIF, JPEG, JPEG-2000, PNG, PDF, PNM, and TIFF.

Gmagick consists of a main Gmagick class, a GmagickDraw class which is in effect a drawing wand and a GmagickPixel class of which instances represent a single pixel of an image (color, opacity).

Gmagick
Yapılandırma/Kurulum
Gmagick


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
Giriş
Gereksinimler
Gmagick


Gereksinimler

This extension works best with GraphicsMagick version 1.4+ and PHP 5.1.3+. Gmagick should work with earlier versions up to GraphicsMagick 1.2.6 but some features and formats are not supported for these versions. Windows version of GraphicsMagick is available from the GraphicsMagick website. To read about the difference between ImageMagick and GraphicsMagick, check this out: » FAQ .

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/gmagick.

Bilginize: The official name of this extension is gmagick.

For Windows, the build of the Gmagick extension is available » here

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu eklentinin php.ini'de tanımlı yapılandırma yönergesi yoktur.

Kurulum
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

Colortype constants
Gmagick::COLOR_BLACK (integer)
Black
Gmagick::COLOR_BLUE (integer)
Blue
Gmagick::COLOR_CYAN (integer)
Cyan
Gmagick::COLOR_GREEN (integer)
Green
Gmagick::COLOR_RED (integer)
Red
Gmagick::COLOR_YELLOW (integer)
Yellow
Gmagick::COLOR_MAGENTA (integer)
Magenta
Gmagick::COLOR_OPACITY (integer)
Opacity
Gmagick::COLOR_ALPHA (integer)
Alpha
Gmagick::COLOR_FUZZ (integer)
Fuzz
Composite Operator Constants
Gmagick::COMPOSITE_DEFAULT (integer)
The default composite operator
Gmagick::COMPOSITE_UNDEFINED (integer)
Undefined composite operator
Gmagick::COMPOSITE_NO (integer)
No composite operator defined
Gmagick::COMPOSITE_ADD (integer)
The result of image + image
Gmagick::COMPOSITE_ATOP (integer)
The result is the same shape as image, with composite image obscuring image where the image shapes overlap
Gmagick::COMPOSITE_BLEND (integer)
Blends the image
Gmagick::COMPOSITE_BUMPMAP (integer)
The same as COMPOSITE_MULTIPLY, except the source is converted to grayscale first.
Gmagick::COMPOSITE_CLEAR (integer)
Makes the target image transparent
Gmagick::COMPOSITE_COLORBURN (integer)
Darkens the destination image to reflect the source image
Gmagick::COMPOSITE_COLORDODGE (integer)
Brightens the destination image to reflect the source image
Gmagick::COMPOSITE_COLORIZE (integer)
Colorizes the target image using the composite image
Gmagick::COMPOSITE_COPYBLACK (integer)
Copies black from the source to target
Gmagick::COMPOSITE_COPYBLUE (integer)
Copies blue from the source to target
Gmagick::COMPOSITE_COPY (integer)
Copies the source image on the target image
Gmagick::COMPOSITE_COPYCYAN (integer)
Copies cyan from the source to target
Gmagick::COMPOSITE_COPYGREEN (integer)
Copies green from the source to target
Gmagick::COMPOSITE_COPYMAGENTA (integer)
Copies magenta from the source to target
Gmagick::COMPOSITE_COPYOPACITY (integer)
Copies opacity from the source to target
Gmagick::COMPOSITE_COPYRED (integer)
Copies red from the source to target
Gmagick::COMPOSITE_COPYYELLOW (integer)
Copies yellow from the source to target
Gmagick::COMPOSITE_DARKEN (integer)
Darkens the target image
Gmagick::COMPOSITE_DSTATOP (integer)
The part of the destination lying inside of the source is composited over the source and replaces the destination
Gmagick::COMPOSITE_DST (integer)
The target is left untouched
Gmagick::COMPOSITE_DSTIN (integer)
The parts inside the source replace the target
Gmagick::COMPOSITE_DSTOUT (integer)
The parts outside the source replace the target
Gmagick::COMPOSITE_DSTOVER (integer)
Target replaces the source
Gmagick::COMPOSITE_DIFFERENCE (integer)
Subtracts the darker of the two constituent colors from the lighter
Gmagick::COMPOSITE_DISPLACE (integer)
Shifts target image pixels as defined by the source
Gmagick::COMPOSITE_DISSOLVE (integer)
Dissolves the source in to the target
Gmagick::COMPOSITE_EXCLUSION (integer)
Produces an effect similar to that of Gmagick::COMPOSITE_DIFFERENCE, but appears as lower contrast
Gmagick::COMPOSITE_HARDLIGHT (integer)
Multiplies or screens the colors, dependent on the source color value
Gmagick::COMPOSITE_HUE (integer)
Modifies the hue of the target as defined by source
Gmagick::COMPOSITE_IN (integer)
Composites source into the target
Gmagick::COMPOSITE_LIGHTEN (integer)
Lightens the target as defined by source
Gmagick::COMPOSITE_LUMINIZE (integer)
Luminizes the target as defined by source
Gmagick::COMPOSITE_MINUS (integer)
Subtracts the source from the target
Gmagick::COMPOSITE_MODULATE (integer)
Modulates the target brightness, saturation and hue as defined by source
Gmagick::COMPOSITE_MULTIPLY (integer)
Multiplies the target to the source
Gmagick::COMPOSITE_OUT (integer)
Composites outer parts of the source on the target
Gmagick::COMPOSITE_OVER (integer)
Composites source over the target
Gmagick::COMPOSITE_OVERLAY (integer)
Overlays the source on the target
Gmagick::COMPOSITE_PLUS (integer)
Adds the source to the target
Gmagick::COMPOSITE_REPLACE (integer)
Replaces the target with the source
Gmagick::COMPOSITE_SATURATE (integer)
Saturates the target as defined by the source
Gmagick::COMPOSITE_SCREEN (integer)
The source and destination are complemented and then multiplied and then replace the destination
Gmagick::COMPOSITE_SOFTLIGHT (integer)
Darkens or lightens the colors, dependent on the source
Gmagick::COMPOSITE_SRCATOP (integer)
The part of the source lying inside of the destination is composited onto the destination
Gmagick::COMPOSITE_SRC (integer)
The source is copied to the destination
Gmagick::COMPOSITE_SRCIN (integer)
The part of the source lying inside of the destination replaces the destination
Gmagick::COMPOSITE_SRCOUT (integer)
The part of the source lying outside of the destination replaces the destination
Gmagick::COMPOSITE_SRCOVER (integer)
The source replaces the destination
Gmagick::COMPOSITE_SUBTRACT (integer)
Subtract the colors in the source image from the destination image
Gmagick::COMPOSITE_THRESHOLD (integer)
The source is composited on the target as defined by source threshold
Gmagick::COMPOSITE_XOR (integer)
The part of the source that lies outside of the destination is combined with the part of the destination that lies outside of the source
Montage Mode constants
Gmagick::MONTAGEMODE_FRAME (integer)
Gmagick::MONTAGEMODE_UNFRAME (integer)
Gmagick::MONTAGEMODE_CONCATENATE (integer)
Style constants
Gmagick::STYLE_NORMAL (integer)
Gmagick::STYLE_ITALIC (integer)
Gmagick::STYLE_OBLIQUE (integer)
Gmagick::STYLE_ANY (integer)
Filter constants
Gmagick::FILTER_UNDEFINED (integer)
Gmagick::FILTER_POINT (integer)
Gmagick::FILTER_BOX (integer)
Gmagick::FILTER_TRIANGLE (integer)
Gmagick::FILTER_HERMITE (integer)
Gmagick::FILTER_HANNING (integer)
Gmagick::FILTER_HAMMING (integer)
Gmagick::FILTER_BLACKMAN (integer)
Gmagick::FILTER_GAUSSIAN (integer)
Gmagick::FILTER_QUADRATIC (integer)
Gmagick::FILTER_CUBIC (integer)
Gmagick::FILTER_CATROM (integer)
Gmagick::FILTER_MITCHELL (integer)
Gmagick::FILTER_LANCZOS (integer)
Gmagick::FILTER_BESSEL (integer)
Gmagick::FILTER_SINC (integer)
Image type constants
Gmagick::IMGTYPE_UNDEFINED (integer)
Gmagick::IMGTYPE_BILEVEL (integer)
Gmagick::IMGTYPE_GRAYSCALE (integer)
Gmagick::IMGTYPE_GRAYSCALEMATTE (integer)
Gmagick::IMGTYPE_PALETTE (integer)
Gmagick::IMGTYPE_PALETTEMATTE (integer)
Gmagick::IMGTYPE_TRUECOLOR (integer)
Gmagick::IMGTYPE_TRUECOLORMATTE (integer)
Gmagick::IMGTYPE_COLORSEPARATION (integer)
Gmagick::IMGTYPE_COLORSEPARATIONMATTE (integer)
Gmagick::IMGTYPE_OPTIMIZE (integer)
Resolution constants
Gmagick::RESOLUTION_UNDEFINED (integer)
Gmagick::RESOLUTION_PIXELSPERINCH (integer)
Gmagick::RESOLUTION_PIXELSPERCENTIMETER (integer)
Compression constants
Gmagick::COMPRESSION_UNDEFINED (integer)
Gmagick::COMPRESSION_NO (integer)
Gmagick::COMPRESSION_BZIP (integer)
Gmagick::COMPRESSION_FAX (integer)
Gmagick::COMPRESSION_GROUP4 (integer)
Gmagick::COMPRESSION_JPEG (integer)
Gmagick::COMPRESSION_JPEG2000 (integer)
Gmagick::COMPRESSION_LOSSLESSJPEG (integer)
Gmagick::COMPRESSION_LZW (integer)
Gmagick::COMPRESSION_RLE (integer)
Gmagick::COMPRESSION_ZIP (integer)
Paint constants
Gmagick::PAINT_POINT (integer)
Gmagick::PAINT_REPLACE (integer)
Gmagick::PAINT_FLOODFILL (integer)
Gmagick::PAINT_FILLTOBORDER (integer)
Gmagick::PAINT_RESET (integer)
Gravity constants
Gmagick::GRAVITY_NORTHWEST (integer)
Gmagick::GRAVITY_NORTH (integer)
Gmagick::GRAVITY_NORTHEAST (integer)
Gmagick::GRAVITY_WEST (integer)
Gmagick::GRAVITY_CENTER (integer)
Gmagick::GRAVITY_EAST (integer)
Gmagick::GRAVITY_SOUTHWEST (integer)
Gmagick::GRAVITY_SOUTH (integer)
Gmagick::GRAVITY_SOUTHEAST (integer)
Stretch constants
Gmagick::STRETCH_NORMAL (integer)
Gmagick::STRETCH_ULTRACONDENSED (integer)
Gmagick::STRETCH_CONDENSED (integer)
Gmagick::STRETCH_SEMICONDENSED (integer)
Gmagick::STRETCH_SEMIEXPANDED (integer)
Gmagick::STRETCH_EXPANDED (integer)
Gmagick::STRETCH_EXTRAEXPANDED (integer)
Gmagick::STRETCH_ULTRAEXPANDED (integer)
Gmagick::STRETCH_ANY (integer)
Align constants
Gmagick::ALIGN_UNDEFINED (integer)
Gmagick::ALIGN_LEFT (integer)
Gmagick::ALIGN_CENTER (integer)
Gmagick::ALIGN_RIGHT (integer)
Decoration constants
Gmagick::DECORATION_NO (integer)
Gmagick::DECORATION_UNDERLINE (integer)
Gmagick::DECORATION_OVERLINE (integer)
Gmagick::DECORATION_LINETROUGH (integer)
Noise constants
Gmagick::NOISE_UNIFORM (integer)
Gmagick::NOISE_GAUSSIAN (integer)
Gmagick::NOISE_MULTIPLICATIVEGAUSSIAN (integer)
Gmagick::NOISE_IMPULSE (integer)
Gmagick::NOISE_LAPLACIAN (integer)
Gmagick::NOISE_POISSON (integer)
Channel constants
Gmagick::CHANNEL_UNDEFINED (integer)
Gmagick::CHANNEL_RED (integer)
Gmagick::CHANNEL_GRAY (integer)
Gmagick::CHANNEL_CYAN (integer)
Gmagick::CHANNEL_GREEN (integer)
Gmagick::CHANNEL_MAGENTA (integer)
Gmagick::CHANNEL_BLUE (integer)
Gmagick::CHANNEL_YELLOW (integer)
Gmagick::CHANNEL_ALPHA (integer)
Gmagick::CHANNEL_OPACITY (integer)
Gmagick::CHANNEL_MATTE (integer)
Gmagick::CHANNEL_BLACK (integer)
Gmagick::CHANNEL_INDEX (integer)
Gmagick::CHANNEL_ALL (integer)
Metric constants
Gmagick::METRIC_UNDEFINED (integer)
Gmagick::METRIC_MEANABSOLUTEERROR (integer)
Gmagick::METRIC_MEANSQUAREERROR (integer)
Gmagick::METRIC_PEAKABSOLUTEERROR (integer)
Gmagick::METRIC_PEAKSIGNALTONOISERATIO (integer)
Gmagick::METRIC_ROOTMEANSQUAREDERROR (integer)
Pixel constants
Gmagick::PIXEL_CHAR (integer)
Gmagick::PIXEL_DOUBLE (integer)
Gmagick::PIXEL_FLOAT (integer)
Gmagick::PIXEL_INTEGER (integer)
Gmagick::PIXEL_LONG (integer)
Gmagick::PIXEL_QUANTUM (integer)
Gmagick::PIXEL_SHORT (integer)
Colorspace constants
Gmagick::COLORSPACE_UNDEFINED (integer)
Gmagick::COLORSPACE_RGB (integer)
Gmagick::COLORSPACE_GRAY (integer)
Gmagick::COLORSPACE_TRANSPARENT (integer)
Gmagick::COLORSPACE_OHTA (integer)
Gmagick::COLORSPACE_LAB (integer)
Gmagick::COLORSPACE_XYZ (integer)
Gmagick::COLORSPACE_YCBCR (integer)
Gmagick::COLORSPACE_YCC (integer)
Gmagick::COLORSPACE_YIQ (integer)
Gmagick::COLORSPACE_YPBPR (integer)
Gmagick::COLORSPACE_YUV (integer)
Gmagick::COLORSPACE_CMYK (integer)
Gmagick::COLORSPACE_SRGB (integer)
Gmagick::COLORSPACE_HSB (integer)
Gmagick::COLORSPACE_HSL (integer)
Gmagick::COLORSPACE_HWB (integer)
Gmagick::COLORSPACE_REC601LUMA (integer)
Gmagick::COLORSPACE_REC709LUMA (integer)
Gmagick::COLORSPACE_LOG (integer)
Virtual Pixel Method constants
Gmagick::VIRTUALPIXELMETHOD_UNDEFINED (integer)
Gmagick::VIRTUALPIXELMETHOD_BACKGROUND (integer)
Gmagick::VIRTUALPIXELMETHOD_CONSTANT (integer)
Gmagick::VIRTUALPIXELMETHOD_EDGE (integer)
Gmagick::VIRTUALPIXELMETHOD_MIRROR (integer)
Gmagick::VIRTUALPIXELMETHOD_TILE (integer)
Gmagick::VIRTUALPIXELMETHOD_TRANSPARENT (integer)
Preview constants
Gmagick::PREVIEW_UNDEFINED (integer)
Gmagick::PREVIEW_ROTATE (integer)
Gmagick::PREVIEW_SHEAR (integer)
Gmagick::PREVIEW_ROLL (integer)
Gmagick::PREVIEW_HUE (integer)
Gmagick::PREVIEW_SATURATION (integer)
Gmagick::PREVIEW_BRIGHTNESS (integer)
Gmagick::PREVIEW_GAMMA (integer)
Gmagick::PREVIEW_SPIFF (integer)
Gmagick::PREVIEW_DULL (integer)
Gmagick::PREVIEW_GRAYSCALE (integer)
Gmagick::PREVIEW_QUANTIZE (integer)
Gmagick::PREVIEW_DESPECKLE (integer)
Gmagick::PREVIEW_REDUCENOISE (integer)
Gmagick::PREVIEW_ADDNOISE (integer)
Gmagick::PREVIEW_SHARPEN (integer)
Gmagick::PREVIEW_BLUR (integer)
Gmagick::PREVIEW_THRESHOLD (integer)
Gmagick::PREVIEW_EDGEDETECT (integer)
Gmagick::PREVIEW_SPREAD (integer)
Gmagick::PREVIEW_SOLARIZE (integer)
Gmagick::PREVIEW_SHADE (integer)
Gmagick::PREVIEW_RAISE (integer)
Gmagick::PREVIEW_SEGMENT (integer)
Gmagick::PREVIEW_SWIRL (integer)
Gmagick::PREVIEW_IMPLODE (integer)
Gmagick::PREVIEW_WAVE (integer)
Gmagick::PREVIEW_OILPAINT (integer)
Gmagick::PREVIEW_CHARCOALDRAWING (integer)
Gmagick::PREVIEW_JPEG (integer)
Rendering Intent constants
Gmagick::RENDERINGINTENT_UNDEFINED (integer)
Gmagick::RENDERINGINTENT_SATURATION (integer)
Gmagick::RENDERINGINTENT_PERCEPTUAL (integer)
Gmagick::RENDERINGINTENT_ABSOLUTE (integer)
Gmagick::RENDERINGINTENT_RELATIVE (integer)
Fillrule constants
Gmagick::FILLRULE_UNDEFINED (integer)
Gmagick::FILLRULE_EVENODD (integer)
Gmagick::FILLRULE_NONZERO (integer)
Pathunit constants
Gmagick::PATHUNITS_UNDEFINED (integer)
Gmagick::PATHUNITS_USERSPACE (integer)
Gmagick::PATHUNITS_USERSPACEONUSE (integer)
Gmagick::PATHUNITS_OBJECTBOUNDINGBOX (integer)
Linecap constants
Gmagick::LINECAP_UNDEFINED (integer)
Gmagick::LINECAP_BUTT (integer)
Gmagick::LINECAP_ROUND (integer)
Gmagick::LINECAP_SQUARE (integer)
Line Join constants
Gmagick::LINEJOIN_UNDEFINED (integer)
Gmagick::LINEJOIN_MITER (integer)
Gmagick::LINEJOIN_ROUND (integer)
Gmagick::LINEJOIN_BEVEL (integer)
Resourcetype constants
Gmagick::RESOURCETYPE_UNDEFINED (integer)
Gmagick::RESOURCETYPE_AREA (integer)
Gmagick::RESOURCETYPE_DISK (integer)
Gmagick::RESOURCETYPE_FILE (integer)
Gmagick::RESOURCETYPE_MAP (integer)
Gmagick::RESOURCETYPE_MEMORY (integer)
Orientation constants
Gmagick::ORIENTATION_UNDEFINED (integer)
Gmagick::ORIENTATION_TOPLEFT (integer)
Gmagick::ORIENTATION_TOPRIGHT (integer)
Gmagick::ORIENTATION_BOTTOMRIGHT (integer)
Gmagick::ORIENTATION_BOTTOMLEFT (integer)
Gmagick::ORIENTATION_LEFTTOP (integer)
Gmagick::ORIENTATION_RIGHTTOP (integer)
Gmagick::ORIENTATION_RIGHTBOTTOM (integer)
Gmagick::ORIENTATION_LEFTBOTTOM (integer)
Çalışma Anı Yapılandırması
Örnekler
Gmagick


Örnekler

The following shows some common Gmagick image operations.

Örnek 1 Gmagick Example

<?php
//Instantiate a new Gmagick object
$image = new Gmagick('example.jpg');

//Make thumbnail from image loaded. 0 for either axes preserves aspect ratio
$image->thumbnailImage(100, 0);

//Create a border around the image, then simulate how the image will look like as an oil painting
//Notice the chaining of mutator methods which is supported in gmagick
$image->borderImage("yellow", 8, 8)->oilPaintImage(0.3);

//Write the current image at the current state to a file
$image->write('example_thumbnail.jpg');
?>
Öntanımlı Sabitler
Gmagick
Gmagick


The Gmagick class

(PECL gmagick >= Unknown)

Giriş

Sınıf Sözdizimi

Gmagick {
/* Yöntemler */
public Gmagick addimage ( Gmagick $Gmagick )
public Gmagick addnoiseimage ( int $NOISE )
public Gmagick annotateimage ( GmagickDraw $GmagickDraw , float $x , float $y , float $angle , string $text )
public Gmagick blurimage ( float $radius , float $sigma [, int $channel ] )
public Gmagick borderimage ( GmagickPixel $color , int $width , int $height )
public Gmagick charcoalimage ( float $radius , float $sigma )
public Gmagick chopimage ( int $width , int $height , int $x , int $y )
public Gmagick clear ( void )
public Gmagick commentimage ( string $comment )
public Gmagick compositeimage ( Gmagick $source , int $COMPOSE , int $x , int $y )
public __construct ([ string $filename ] )
public Gmagick cropimage ( int $width , int $height , int $x , int $y )
public Gmagick cropthumbnailimage ( int $width , int $height )
public Gmagick current ( void )
public Gmagick cyclecolormapimage ( int $displace )
public Gmagick deconstructimages ( void )
public Gmagick despeckleimage ( void )
public bool destroy ( void )
public Gmagick drawimage ( GmagickDraw $GmagickDraw )
public Gmagick edgeimage ( float $radius )
public Gmagick embossimage ( float $radius , float $sigma )
public Gmagick enhanceimage ( void )
public Gmagick equalizeimage ( void )
public Gmagick flipimage ( void )
public Gmagick flopimage ( void )
public Gmagick frameimage ( GmagickPixel $color , int $width , int $height , int $inner_bevel , int $outer_bevel )
public Gmagick gammaimage ( float $gamma )
public string getcopyright ( void )
public string getfilename ( void )
public GmagickPixel getimagebackgroundcolor ( void )
public array getimageblueprimary ( void )
public GmagickPixel getimagebordercolor ( void )
public int getimagechanneldepth ( int $channel_type )
public int getimagecolors ( void )
public int getimagecolorspace ( void )
public int getimagecompose ( void )
public int getimagedelay ( void )
public int getimagedepth ( void )
public int getimagedispose ( void )
public array getimageextrema ( void )
public string getimagefilename ( void )
public string getimageformat ( void )
public float getimagegamma ( void )
public array getimagegreenprimary ( void )
public int getimageheight ( void )
public array getimagehistogram ( void )
public int getimageindex ( void )
public int getimageinterlacescheme ( void )
public int getimageiterations ( void )
public int getimagematte ( void )
public GmagickPixel getimagemattecolor ( void )
public string getimageprofile ( string $name )
public array getimageredprimary ( void )
public int getimagerenderingintent ( void )
public array getimageresolution ( void )
public int getimagescene ( void )
public string getimagesignature ( void )
public int getimagetype ( void )
public int getimageunits ( void )
public array getimagewhitepoint ( void )
public int getimagewidth ( void )
public string getpackagename ( void )
public array getquantumdepth ( void )
public string getreleasedate ( void )
public array getsamplingfactors ( void )
public array getsize ( void )
public array getversion ( void )
public mixed hasnextimage ( void )
public mixed haspreviousimage ( void )
public mixed implodeimage ( float $radius )
public mixed labelimage ( string $label )
public mixed levelimage ( float $blackPoint , float $gamma , float $whitePoint [, int $channel = Gmagick::CHANNEL_DEFAULT ] )
public mixed magnifyimage ( void )
public Gmagick mapimage ( gmagick $gmagick , bool $dither )
public void medianfilterimage ( float $radius )
public Gmagick minifyimage ( void )
public Gmagick modulateimage ( float $brightness , float $saturation , float $hue )
public Gmagick motionblurimage ( float $radius , float $sigma , float $angle )
public Gmagick newimage ( int $width , int $height , string $background [, string $format ] )
public bool nextimage ( void )
public Gmagick normalizeimage ([ int $channel ] )
public Gmagick oilpaintimage ( float $radius )
public bool previousimage ( void )
public Gmagick profileimage ( string $name , string $profile )
public Gmagick quantizeimage ( int $numColors , int $colorspace , int $treeDepth , bool $dither , bool $measureError )
public Gmagick quantizeimages ( int $numColors , int $colorspace , int $treeDepth , bool $dither , bool $measureError )
public array queryfontmetrics ( GmagickDraw $draw , string $text )
public array queryfonts ([ string $pattern = "*" ] )
public array queryformats ([ string $pattern = "*" ] )
public Gmagick radialblurimage ( float $angle [, int $channel = Gmagick::CHANNEL_DEFAULT ] )
public Gmagick raiseimage ( int $width , int $height , int $x , int $y , bool $raise )
public Gmagick read ( string $filename )
public Gmagick readimage ( string $filename )
public Gmagick readimageblob ( string $imageContents [, string $filename ] )
public Gmagick readimagefile ( resource $fp [, string $filename ] )
public Gmagick reducenoiseimage ( float $radius )
public Gmagick removeimage ( void )
public string removeimageprofile ( string $name )
public Gmagick resampleimage ( float $xResolution , float $yResolution , int $filter , float $blur )
public Gmagick resizeimage ( int $width , int $height , int $filter , float $blur [, bool $fit = false ] )
public Gmagick rollimage ( int $x , int $y )
public Gmagick rotateimage ( mixed $color , float $degrees )
public Gmagick scaleimage ( int $width , int $height [, bool $fit = false ] )
public Gmagick separateimagechannel ( int $channel )
Gmagick setCompressionQuality ( int $quality = 75 )
public Gmagick setfilename ( string $filename )
public Gmagick setimagebackgroundcolor ( GmagickPixel $color )
public Gmagick setimageblueprimary ( float $x , float $y )
public Gmagick setimagebordercolor ( GmagickPixel $color )
public Gmagick setimagechanneldepth ( int $channel , int $depth )
public Gmagick setimagecolorspace ( int $colorspace )
public Gmagick setimagecompose ( int $composite )
public Gmagick setimagedelay ( int $delay )
public Gmagick setimagedepth ( int $depth )
public Gmagick setimagedispose ( int $disposeType )
public Gmagick setimagefilename ( string $filename )
public Gmagick setimageformat ( string $imageFormat )
public Gmagick setimagegamma ( float $gamma )
public Gmagick setimagegreenprimary ( float $x , float $y )
public Gmagick setimageindex ( int $index )
public Gmagick setimageinterlacescheme ( int $interlace )
public Gmagick setimageiterations ( int $iterations )
public Gmagick setimageprofile ( string $name , string $profile )
public Gmagick setimageredprimary ( float $x , float $y )
public Gmagick setimagerenderingintent ( int $rendering_intent )
public Gmagick setimageresolution ( float $xResolution , float $yResolution )
public Gmagick setimagescene ( int $scene )
public Gmagick setimagetype ( int $imgType )
public Gmagick setimageunits ( int $resolution )
public Gmagick setimagewhitepoint ( float $x , float $y )
public Gmagick setsamplingfactors ( array $factors )
public Gmagick setsize ( int $columns , int $rows )
public Gmagick shearimage ( mixed $color , float $xShear , float $yShear )
public Gmagick solarizeimage ( int $threshold )
public Gmagick spreadimage ( float $radius )
public Gmagick stripimage ( void )
public Gmagick swirlimage ( float $degrees )
public Gmagick thumbnailimage ( int $width , int $height [, bool $fit = false ] )
public Gmagick trimimage ( float $fuzz )
public Gmagick writeimage ( string $filename [, bool $all_frames = false ] )
}

İçindekiler

  • Gmagick::addimage — Adds new image to Gmagick object image list
  • Gmagick::addnoiseimage — Adds random noise to the image
  • Gmagick::annotateimage — Annotates an image with text
  • Gmagick::blurimage — Adds blur filter to image
  • Gmagick::borderimage — Surrounds the image with a border
  • Gmagick::charcoalimage — Simulates a charcoal drawing
  • Gmagick::chopimage — Removes a region of an image and trims
  • Gmagick::clear — Clears all resources associated to Gmagick object
  • Gmagick::commentimage — Adds a comment to your image
  • Gmagick::compositeimage — Composite one image onto another
  • Gmagick::__construct — The Gmagick constructor
  • Gmagick::cropimage — Extracts a region of the image
  • Gmagick::cropthumbnailimage — Creates a crop thumbnail
  • Gmagick::current — The current purpose
  • Gmagick::cyclecolormapimage — Displaces an image's colormap
  • Gmagick::deconstructimages — Returns certain pixel differences between images
  • Gmagick::despeckleimage — The despeckleimage purpose
  • Gmagick::destroy — The destroy purpose
  • Gmagick::drawimage — Renders the GmagickDraw object on the current image
  • Gmagick::edgeimage — Enhance edges within the image
  • Gmagick::embossimage — Returns a grayscale image with a three-dimensional effect
  • Gmagick::enhanceimage — Improves the quality of a noisy image
  • Gmagick::equalizeimage — Equalizes the image histogram
  • Gmagick::flipimage — Creates a vertical mirror image
  • Gmagick::flopimage — The flopimage purpose
  • Gmagick::frameimage — Adds a simulated three-dimensional border
  • Gmagick::gammaimage — Gamma-corrects an image
  • Gmagick::getcopyright — Returns the GraphicsMagick API copyright as a string
  • Gmagick::getfilename — The filename associated with an image sequence
  • Gmagick::getimagebackgroundcolor — Returns the image background color
  • Gmagick::getimageblueprimary — Returns the chromaticy blue primary point
  • Gmagick::getimagebordercolor — Returns the image border color
  • Gmagick::getimagechanneldepth — Gets the depth for a particular image channel
  • Gmagick::getimagecolors — Returns the color of the specified colormap index
  • Gmagick::getimagecolorspace — Gets the image colorspace
  • Gmagick::getimagecompose — Returns the composite operator associated with the image
  • Gmagick::getimagedelay — Gets the image delay
  • Gmagick::getimagedepth — Gets the depth of the image
  • Gmagick::getimagedispose — Gets the image disposal method
  • Gmagick::getimageextrema — Gets the extrema for the image
  • Gmagick::getimagefilename — Returns the filename of a particular image in a sequence
  • Gmagick::getimageformat — Returns the format of a particular image in a sequence
  • Gmagick::getimagegamma — Gets the image gamma
  • Gmagick::getimagegreenprimary — Returns the chromaticy green primary point
  • Gmagick::getimageheight — Returns the image height
  • Gmagick::getimagehistogram — Gets the image histogram
  • Gmagick::getimageindex — Gets the index of the current active image
  • Gmagick::getimageinterlacescheme — Gets the image interlace scheme
  • Gmagick::getimageiterations — Gets the image iterations
  • Gmagick::getimagematte — Check if the image has a matte channel
  • Gmagick::getimagemattecolor — Returns the image matte color
  • Gmagick::getimageprofile — Returns the named image profile.
  • Gmagick::getimageredprimary — Returns the chromaticity red primary point
  • Gmagick::getimagerenderingintent — Gets the image rendering intent
  • Gmagick::getimageresolution — Gets the image X and Y resolution
  • Gmagick::getimagescene — Gets the image scene
  • Gmagick::getimagesignature — Generates an SHA-256 message digest
  • Gmagick::getimagetype — Gets the potential image type.
  • Gmagick::getimageunits — Gets the image units of resolution
  • Gmagick::getimagewhitepoint — Returns the chromaticity white point
  • Gmagick::getimagewidth — Returns the width of the image
  • Gmagick::getpackagename — Returns the GraphicsMagick package name.
  • Gmagick::getquantumdepth — Returns the Gmagick quantum depth as a string.
  • Gmagick::getreleasedate — Returns the GraphicsMagick release date as a string.
  • Gmagick::getsamplingfactors — Gets the horizontal and vertical sampling factor.
  • Gmagick::getsize — Returns the size associated with the Gmagick object
  • Gmagick::getversion — Returns the GraphicsMagick API version
  • Gmagick::hasnextimage — Checks if the object has more images
  • Gmagick::haspreviousimage — Checks if the object has a previous image
  • Gmagick::implodeimage — Creates a new image as a copy
  • Gmagick::labelimage — Adds a label to an image.
  • Gmagick::levelimage — Adjusts the levels of an image
  • Gmagick::magnifyimage — Scales an image proportionally 2x
  • Gmagick::mapimage — Replaces the colors of an image with the closest color from a reference image.
  • Gmagick::medianfilterimage — Applies a digital filter
  • Gmagick::minifyimage — Scales an image proportionally to half its size
  • Gmagick::modulateimage — Control the brightness, saturation, and hue
  • Gmagick::motionblurimage — Simulates motion blur
  • Gmagick::newimage — Creates a new image
  • Gmagick::nextimage — Moves to the next image
  • Gmagick::normalizeimage — Enhances the contrast of a color image
  • Gmagick::oilpaintimage — Simulates an oil painting
  • Gmagick::previousimage — Move to the previous image in the object
  • Gmagick::profileimage — Adds or removes a profile from an image
  • Gmagick::quantizeimage — Analyzes the colors within a reference image
  • Gmagick::quantizeimages — The quantizeimages purpose
  • Gmagick::queryfontmetrics — Returns an array representing the font metrics
  • Gmagick::queryfonts — Returns the configured fonts
  • Gmagick::queryformats — Returns formats supported by Gmagick.
  • Gmagick::radialblurimage — Radial blurs an image
  • Gmagick::raiseimage — Creates a simulated 3d button-like effect
  • Gmagick::read — Reads image from filename
  • Gmagick::readimage — Reads image from filename
  • Gmagick::readimageblob — Reads image from a binary string
  • Gmagick::readimagefile — The readimagefile purpose
  • Gmagick::reducenoiseimage — Smooths the contours of an image
  • Gmagick::removeimage — Removes an image from the image list
  • Gmagick::removeimageprofile — Removes the named image profile and returns it
  • Gmagick::resampleimage — Resample image to desired resolution
  • Gmagick::resizeimage — Scales an image
  • Gmagick::rollimage — Offsets an image
  • Gmagick::rotateimage — Rotates an image
  • Gmagick::scaleimage — Scales the size of an image
  • Gmagick::separateimagechannel — Separates a channel from the image
  • Gmagick::setCompressionQuality — Sets the object's default compression quality
  • Gmagick::setfilename — Sets the filename before you read or write the image
  • Gmagick::setimagebackgroundcolor — Sets the image background color.
  • Gmagick::setimageblueprimary — Sets the image chromaticity blue primary point.
  • Gmagick::setimagebordercolor — Sets the image border color.
  • Gmagick::setimagechanneldepth — Sets the depth of a particular image channel
  • Gmagick::setimagecolorspace — Sets the image colorspace
  • Gmagick::setimagecompose — Sets the image composite operator
  • Gmagick::setimagedelay — Sets the image delay
  • Gmagick::setimagedepth — Sets the image depth
  • Gmagick::setimagedispose — Sets the image disposal method
  • Gmagick::setimagefilename — Sets the filename of a particular image in a sequence
  • Gmagick::setimageformat — Sets the format of a particular image
  • Gmagick::setimagegamma — Sets the image gamma
  • Gmagick::setimagegreenprimary — Sets the image chromaticity green primary point.
  • Gmagick::setimageindex — Set the iterator to the position in the image list specified with the index parameter
  • Gmagick::setimageinterlacescheme — Sets the interlace scheme of the image.
  • Gmagick::setimageiterations — Sets the image iterations.
  • Gmagick::setimageprofile — Adds a named profile to the Gmagick object
  • Gmagick::setimageredprimary — Sets the image chromaticity red primary point.
  • Gmagick::setimagerenderingintent — Sets the image rendering intent
  • Gmagick::setimageresolution — Sets the image resolution
  • Gmagick::setimagescene — Sets the image scene
  • Gmagick::setimagetype — Sets the image type
  • Gmagick::setimageunits — Sets the image units of resolution.
  • Gmagick::setimagewhitepoint — Sets the image chromaticity white point.
  • Gmagick::setsamplingfactors — Sets the image sampling factors.
  • Gmagick::setsize — Sets the size of the Gmagick object
  • Gmagick::shearimage — Creating a parallelogram
  • Gmagick::solarizeimage — Applies a solarizing effect to the image
  • Gmagick::spreadimage — Randomly displaces each pixel in a block
  • Gmagick::stripimage — Strips an image of all profiles and comments
  • Gmagick::swirlimage — Swirls the pixels about the center of the image
  • Gmagick::thumbnailimage — Changes the size of an image
  • Gmagick::trimimage — Remove edges from the image
  • Gmagick::write — Takma Adı: Gmagick::writeimage
  • Gmagick::writeimage — Writes an image to the specified filename
Örnekler
Gmagick::addimage
Gmagick


Adds new image to Gmagick object image list

Gmagick
Gmagick::addnoiseimage
Gmagick
PHP Manual

Gmagick::addimage

(PECL gmagick >= Unknown)

Gmagick::addimage — Adds new image to Gmagick object image list

Açıklama

public Gmagick Gmagick::addimage ( Gmagick $Gmagick )

Adds new image to Gmagick object from the current position of the source object. After the operation iterator position is moved at the end of the list.

Değiştirgeler

source

The source Gmagick object

Dönen Değerler

The Gmagick object with image added

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick
Gmagick::addnoiseimage
Gmagick


Adds random noise to the image

Gmagick::addimage
Gmagick::annotateimage
Gmagick
PHP Manual

Gmagick::addnoiseimage

(PECL gmagick >= Unknown)

Gmagick::addnoiseimage — Adds random noise to the image

Açıklama

public Gmagick Gmagick::addnoiseimage ( int $NOISE )

Adds random noise to the image.

Değiştirgeler

noise_type

The type of the noise. Refer to this list of noise constants.

Dönen Değerler

The Gmagick object with noise added.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::addimage
Gmagick::annotateimage
Gmagick


Annotates an image with text

Gmagick::addnoiseimage
Gmagick::blurimage
Gmagick
PHP Manual

Gmagick::annotateimage

(PECL gmagick >= Unknown)

Gmagick::annotateimage — Annotates an image with text

Açıklama

public Gmagick Gmagick::annotateimage ( GmagickDraw $GmagickDraw , float $x , float $y , float $angle , string $text )

Annotates an image with text.

Değiştirgeler

GmagickDraw

The GmagickDraw object that contains settings for drawing the text

x

Horizontal offset in pixels to the left of text

y

Vertical offset in pixels to the baseline of text

angle

The angle at which to write the text

text

The string to draw

Dönen Değerler

The Gmagick object with annotation made.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::addnoiseimage
Gmagick::blurimage
Gmagick


Adds blur filter to image

Gmagick::annotateimage
Gmagick::borderimage
Gmagick
PHP Manual

Gmagick::blurimage

(PECL gmagick >= Unknown)

Gmagick::blurimage — Adds blur filter to image

Açıklama

public Gmagick Gmagick::blurimage ( float $radius , float $sigma [, int $channel ] )

Adds blur filter to image.

Değiştirgeler

radius

Blur radius

sigma

Standard deviation

Dönen Değerler

The blurred Gmagick object

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::annotateimage
Gmagick::borderimage
Gmagick


Surrounds the image with a border

Gmagick::blurimage
Gmagick::charcoalimage
Gmagick
PHP Manual

Gmagick::borderimage

(PECL gmagick >= Unknown)

Gmagick::borderimage — Surrounds the image with a border

Açıklama

public Gmagick Gmagick::borderimage ( GmagickPixel $color , int $width , int $height )

Surrounds the image with a border of the color defined by the bordercolor GmagickPixel object or a color string.

Değiştirgeler

color

GmagickPixel object or a string containing the border color

width

Border width

height

Border height

Dönen Değerler

The Gmagick object with border defined

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::blurimage
Gmagick::charcoalimage
Gmagick


Simulates a charcoal drawing

Gmagick::borderimage
Gmagick::chopimage
Gmagick
PHP Manual

Gmagick::charcoalimage

(PECL gmagick >= Unknown)

Gmagick::charcoalimage — Simulates a charcoal drawing

Açıklama

public Gmagick Gmagick::charcoalimage ( float $radius , float $sigma )

Simulates a charcoal drawing.

Değiştirgeler

radius

The radius of the Gaussian, in pixels, not counting the center pixel

sigma

The standard deviation of the Gaussian, in pixels

Dönen Değerler

The Gmagick object with charcoal simulation

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::borderimage
Gmagick::chopimage
Gmagick


Removes a region of an image and trims

Gmagick::charcoalimage
Gmagick::clear
Gmagick
PHP Manual

Gmagick::chopimage

(PECL gmagick >= Unknown)

Gmagick::chopimage — Removes a region of an image and trims

Açıklama

public Gmagick Gmagick::chopimage ( int $width , int $height , int $x , int $y )

Removes a region of an image and collapses the image to occupy the removed portion.

Değiştirgeler

width

Width of the chopped area

height

Height of the chopped area

x

X origo of the chopped area

y

Y origo of the chopped area

Dönen Değerler

The chopped Gmagick object

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::charcoalimage
Gmagick::clear
Gmagick


Clears all resources associated to Gmagick object

Gmagick::chopimage
Gmagick::commentimage
Gmagick
PHP Manual

Gmagick::clear

(PECL gmagick >= Unknown)

Gmagick::clear — Clears all resources associated to Gmagick object

Açıklama

public Gmagick Gmagick::clear ( void )

Clears all resources associated to Gmagick object

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The cleared Gmagick object

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::chopimage
Gmagick::commentimage
Gmagick


Adds a comment to your image

Gmagick::clear
Gmagick::compositeimage
Gmagick
PHP Manual

Gmagick::commentimage

(PECL gmagick >= Unknown)

Gmagick::commentimage — Adds a comment to your image

Açıklama

public Gmagick Gmagick::commentimage ( string $comment )

Adds a comment to your image.

Değiştirgeler

comment

The comment to add

Dönen Değerler

The Gmagick object with comment added.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::clear
Gmagick::compositeimage
Gmagick


Composite one image onto another

Gmagick::commentimage
Gmagick::__construct
Gmagick
PHP Manual

Gmagick::compositeimage

(PECL gmagick >= Unknown)

Gmagick::compositeimage — Composite one image onto another

Açıklama

public Gmagick Gmagick::compositeimage ( Gmagick $source , int $COMPOSE , int $x , int $y )

Composite one image onto another at the specified offset.

Değiştirgeler

source

Gmagick object which holds the composite image

compose

Composite operator.

x

The column offset of the composited image

y

The row offset of the composited image

Dönen Değerler

The Gmagick object with compositions.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::commentimage
Gmagick::__construct
Gmagick


The Gmagick constructor

Gmagick::compositeimage
Gmagick::cropimage
Gmagick
PHP Manual

Gmagick::__construct

(PECL gmagick >= Unknown)

Gmagick::__construct — The Gmagick constructor

Açıklama

public Gmagick::__construct ([ string $filename ] )

The Gmagick constructor.

Değiştirgeler

filename

The path to an image to load or array of paths

Dönen Değerler

Returns a new Gmagick object on success.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::compositeimage
Gmagick::cropimage
Gmagick


Extracts a region of the image

Gmagick::__construct
Gmagick::cropthumbnailimage
Gmagick
PHP Manual

Gmagick::cropimage

(PECL gmagick >= Unknown)

Gmagick::cropimage — Extracts a region of the image

Açıklama

public Gmagick Gmagick::cropimage ( int $width , int $height , int $x , int $y )

Extracts a region of the image.

Değiştirgeler

width

The width of the crop

height

The height of the crop

x

The X coordinate of the cropped region's top left corner

y

The Y coordinate of the cropped region's top left corner

Dönen Değerler

The cropped Gmagick object

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::__construct
Gmagick::cropthumbnailimage
Gmagick


Creates a crop thumbnail

Gmagick::cropimage
Gmagick::current
Gmagick
PHP Manual

Gmagick::cropthumbnailimage

(PECL gmagick >= Unknown)

Gmagick::cropthumbnailimage — Creates a crop thumbnail

Açıklama

public Gmagick Gmagick::cropthumbnailimage ( int $width , int $height )

Creates a fixed size thumbnail by first scaling the image down and cropping a specified area from the center.

Değiştirgeler

width

The width of the thumbnail

height

The Height of the thumbnail

Dönen Değerler

The cropped Gmagick object

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::cropimage
Gmagick::current
Gmagick


The current purpose

Gmagick::cropthumbnailimage
Gmagick::cyclecolormapimage
Gmagick
PHP Manual

Gmagick::current

(PECL gmagick >= Unknown)

Gmagick::current — The current purpose

Açıklama

public Gmagick Gmagick::current ( void )

Returns reference to the current gmagick object with image pointer at the correct sequence.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns self on success.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::cropthumbnailimage
Gmagick::cyclecolormapimage
Gmagick


Displaces an image's colormap

Gmagick::current
Gmagick::deconstructimages
Gmagick
PHP Manual

Gmagick::cyclecolormapimage

(PECL gmagick >= Unknown)

Gmagick::cyclecolormapimage — Displaces an image's colormap

Açıklama

public Gmagick Gmagick::cyclecolormapimage ( int $displace )

Displaces an image's colormap by a given number of positions. If you cycle the colormap a number of times you can produce a psychedelic effect.

Değiştirgeler

displace

The amount to displace the colormap.

Dönen Değerler

Returns self on success.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::current
Gmagick::deconstructimages
Gmagick


Returns certain pixel differences between images

Gmagick::cyclecolormapimage
Gmagick::despeckleimage
Gmagick
PHP Manual

Gmagick::deconstructimages

(PECL gmagick >= Unknown)

Gmagick::deconstructimages — Returns certain pixel differences between images

Açıklama

public Gmagick Gmagick::deconstructimages ( void )

Compares each image with the next in a sequence and returns the maximum bounding region of any pixel differences it discovers.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a new Gmagick object on success.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::cyclecolormapimage
Gmagick::despeckleimage
Gmagick


The despeckleimage purpose

Gmagick::deconstructimages
Gmagick::destroy
Gmagick
PHP Manual

Gmagick::despeckleimage

(PECL gmagick >= Unknown)

Gmagick::despeckleimage — The despeckleimage purpose

Açıklama

public Gmagick Gmagick::despeckleimage ( void )

Reduces the speckle noise in an image while preserving the edges of the original image.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The despeckled Gmagick object on success.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Örnekler

Örnek 1 Gmagick::despeckleimage() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

Gmagick::deconstructimages
Gmagick::destroy
Gmagick


The destroy purpose

Gmagick::despeckleimage
Gmagick::drawimage
Gmagick
PHP Manual

Gmagick::destroy

(PECL gmagick >= Unknown)

Gmagick::destroy — The destroy purpose

Açıklama

public bool Gmagick::destroy ( void )

Destroys the Gmagick object and frees all resources associated with it

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::despeckleimage
Gmagick::drawimage
Gmagick


Renders the GmagickDraw object on the current image

Gmagick::destroy
Gmagick::edgeimage
Gmagick
PHP Manual

Gmagick::drawimage

(PECL gmagick >= Unknown)

Gmagick::drawimage — Renders the GmagickDraw object on the current image

Açıklama

public Gmagick Gmagick::drawimage ( GmagickDraw $GmagickDraw )

Renders the GmagickDraw object on the current image

Değiştirgeler

GmagickDraw

The drawing operations to render on the image.

Dönen Değerler

The drawn Gmagick object

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::destroy
Gmagick::edgeimage
Gmagick


Enhance edges within the image

Gmagick::drawimage
Gmagick::embossimage
Gmagick
PHP Manual

Gmagick::edgeimage

(PECL gmagick >= Unknown)

Gmagick::edgeimage — Enhance edges within the image

Açıklama

public Gmagick Gmagick::edgeimage ( float $radius )

Enhance edges within the image with a convolution filter of the given radius. Use radius 0 and it will be auto-selected.

Değiştirgeler

radius

The radius of the operation.

Dönen Değerler

The Gmagick object with edges enhanced.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::drawimage
Gmagick::embossimage
Gmagick


Returns a grayscale image with a three-dimensional effect

Gmagick::edgeimage
Gmagick::enhanceimage
Gmagick
PHP Manual

Gmagick::embossimage

(PECL gmagick >= Unknown)

Gmagick::embossimage — Returns a grayscale image with a three-dimensional effect

Açıklama

public Gmagick Gmagick::embossimage ( float $radius , float $sigma )

Returns a grayscale image with a three-dimensional effect. We convolve the image with a Gaussian operator of the given radius and standard deviation (sigma). For reasonable results, radius should be larger than sigma. Use a radius of 0 and it will choose a suitable radius for you.

Değiştirgeler

radius

The radius of the effect

sigma

The sigma of the effect

Dönen Değerler

The embossed Gmagick object.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::edgeimage
Gmagick::enhanceimage
Gmagick


Improves the quality of a noisy image

Gmagick::embossimage
Gmagick::equalizeimage
Gmagick
PHP Manual

Gmagick::enhanceimage

(PECL gmagick >= Unknown)

Gmagick::enhanceimage — Improves the quality of a noisy image

Açıklama

public Gmagick Gmagick::enhanceimage ( void )

Applies a digital filter that improves the quality of a noisy image.

Dönen Değerler

The enhanced Gmagick object.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::embossimage
Gmagick::equalizeimage
Gmagick


Equalizes the image histogram

Gmagick::enhanceimage
Gmagick::flipimage
Gmagick
PHP Manual

Gmagick::equalizeimage

(PECL gmagick >= Unknown)

Gmagick::equalizeimage — Equalizes the image histogram

Açıklama

public Gmagick Gmagick::equalizeimage ( void )

Equalizes the image histogram.

Dönen Değerler

The equalized Gmagick object.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::enhanceimage
Gmagick::flipimage
Gmagick


Creates a vertical mirror image

Gmagick::equalizeimage
Gmagick::flopimage
Gmagick
PHP Manual

Gmagick::flipimage

(PECL gmagick >= Unknown)

Gmagick::flipimage — Creates a vertical mirror image

Açıklama

public Gmagick Gmagick::flipimage ( void )

Creates a vertical mirror image by reflecting the pixels around the central x-axis.

Dönen Değerler

The flipped Gmagick object.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::equalizeimage
Gmagick::flopimage
Gmagick


The flopimage purpose

Gmagick::flipimage
Gmagick::frameimage
Gmagick
PHP Manual

Gmagick::flopimage

(PECL gmagick >= Unknown)

Gmagick::flopimage — The flopimage purpose

Açıklama

public Gmagick Gmagick::flopimage ( void )

Creates a horizontal mirror image by reflecting the pixels around the central y-axis.

Dönen Değerler

The flopped Gmagick object.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::flipimage
Gmagick::frameimage
Gmagick


Adds a simulated three-dimensional border

Gmagick::flopimage
Gmagick::gammaimage
Gmagick
PHP Manual

Gmagick::frameimage

(PECL gmagick >= Unknown)

Gmagick::frameimage — Adds a simulated three-dimensional border

Açıklama

public Gmagick Gmagick::frameimage ( GmagickPixel $color , int $width , int $height , int $inner_bevel , int $outer_bevel )

Adds a simulated three-dimensional border around the image. The width and height specify the border width of the vertical and horizontal sides of the frame. The inner and outer bevels indicate the width of the inner and outer shadows of the frame.

Değiştirgeler

color

GmagickPixel object or a float representing the matte color

width

The width of the border

height

The height of the border

inner_bevel

The inner bevel width

outer_bevel

The outer bevel width

Dönen Değerler

The framed Gmagick object.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::flopimage
Gmagick::gammaimage
Gmagick


Gamma-corrects an image

Gmagick::frameimage
Gmagick::getcopyright
Gmagick
PHP Manual

Gmagick::gammaimage

(PECL gmagick >= Unknown)

Gmagick::gammaimage — Gamma-corrects an image

Açıklama

public Gmagick Gmagick::gammaimage ( float $gamma )

Gamma-corrects an image. The same image viewed on different devices will have perceptual differences in the way the image's intensities are represented on the screen. Specify individual gamma levels for the red, green, and blue channels, or adjust all three with the gamma parameter. Values typically range from 0.8 to 2.3.

Değiştirgeler

gamma

The amount of gamma-correction.

Dönen Değerler

The gamma corrected Gmagick object.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::frameimage
Gmagick::getcopyright
Gmagick


Returns the GraphicsMagick API copyright as a string

Gmagick::gammaimage
Gmagick::getfilename
Gmagick
PHP Manual

Gmagick::getcopyright

(PECL gmagick >= Unknown)

Gmagick::getcopyright — Returns the GraphicsMagick API copyright as a string

Açıklama

public string Gmagick::getcopyright ( void )

Returns the GraphicsMagick API copyright as a string.

Dönen Değerler

Returns a string containing the copyright notice of GraphicsMagick and Magickwand C API.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::gammaimage
Gmagick::getfilename
Gmagick


The filename associated with an image sequence

Gmagick::getcopyright
Gmagick::getimagebackgroundcolor
Gmagick
PHP Manual

Gmagick::getfilename

(PECL gmagick >= Unknown)

Gmagick::getfilename — The filename associated with an image sequence

Açıklama

public string Gmagick::getfilename ( void )

Returns the filename associated with an image sequence.

Dönen Değerler

Returns a string on success.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::getcopyright
Gmagick::getimagebackgroundcolor
Gmagick


Returns the image background color

Gmagick::getfilename
Gmagick::getimageblueprimary
Gmagick
PHP Manual

Gmagick::getimagebackgroundcolor

(PECL gmagick >= Unknown)

Gmagick::getimagebackgroundcolor — Returns the image background color

Açıklama

public GmagickPixel Gmagick::getimagebackgroundcolor ( void )

Returns the image background color.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an GmagickPixel set to the background color of the image.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::getfilename
Gmagick::getimageblueprimary
Gmagick


Returns the chromaticy blue primary point

Gmagick::getimagebackgroundcolor
Gmagick::getimagebordercolor
Gmagick
PHP Manual

Gmagick::getimageblueprimary

(PECL gmagick >= Unknown)

Gmagick::getimageblueprimary — Returns the chromaticy blue primary point

Açıklama

public array Gmagick::getimageblueprimary ( void )

Returns the chromaticity blue primary point for the image.

Değiştirgeler

x

The chromaticity blue primary x-point.

y

The chromaticity blue primary y-point.

Dönen Değerler

Array consisting of "x" and "y" coordinates of point.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::getimagebackgroundcolor
Gmagick::getimagebordercolor
Gmagick


Returns the image border color

Gmagick::getimageblueprimary
Gmagick::getimagechanneldepth
Gmagick
PHP Manual

Gmagick::getimagebordercolor

(PECL gmagick >= Unknown)

Gmagick::getimagebordercolor — Returns the image border color

Açıklama

public GmagickPixel Gmagick::getimagebordercolor ( void )

Returns the image border color.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

GmagickPixel object representing the color of the border

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::getimageblueprimary
Gmagick::getimagechanneldepth
Gmagick


Gets the depth for a particular image channel

Gmagick::getimagebordercolor
Gmagick::getimagecolors
Gmagick
PHP Manual

Gmagick::getimagechanneldepth

(PECL gmagick >= Unknown)

Gmagick::getimagechanneldepth — Gets the depth for a particular image channel

Açıklama

public int Gmagick::getimagechanneldepth ( int $channel_type )

Gets the depth for a particular image channel.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Depth of image channel

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::getimagebordercolor
Gmagick::getimagecolors
Gmagick


Returns the color of the specified colormap index

Gmagick::getimagechanneldepth
Gmagick::getimagecolorspace
Gmagick
PHP Manual

Gmagick::getimagecolors

(PECL gmagick >= Unknown)

Gmagick::getimagecolors — Returns the color of the specified colormap index

Açıklama

public int Gmagick::getimagecolors ( void )

Returns the color of the specified colormap index.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The number of colors in image.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::getimagechanneldepth
Gmagick::getimagecolorspace
Gmagick


Gets the image colorspace

Gmagick::getimagecolors
Gmagick::getimagecompose
Gmagick
PHP Manual

Gmagick::getimagecolorspace

(PECL gmagick >= Unknown)

Gmagick::getimagecolorspace — Gets the image colorspace

Açıklama

public int Gmagick::getimagecolorspace ( void )

Gets the image colorspace.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Colorspace

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::getimagecolors
Gmagick::getimagecompose
Gmagick


Returns the composite operator associated with the image

Gmagick::getimagecolorspace
Gmagick::getimagedelay
Gmagick
PHP Manual

Gmagick::getimagecompose

(PECL gmagick >= Unknown)

Gmagick::getimagecompose — Returns the composite operator associated with the image

Açıklama

public int Gmagick::getimagecompose ( void )

Returns the composite operator associated with the image.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the composite operator associated with the image.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::getimagecolorspace
Gmagick::getimagedelay
Gmagick


Gets the image delay

Gmagick::getimagecompose
Gmagick::getimagedepth
Gmagick
PHP Manual

Gmagick::getimagedelay

(PECL gmagick >= Unknown)

Gmagick::getimagedelay — Gets the image delay

Açıklama

public int Gmagick::getimagedelay ( void )

Gets the image delay

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the composite operator associated with the image.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::getimagecompose
Gmagick::getimagedepth
Gmagick


Gets the depth of the image

Gmagick::getimagedelay
Gmagick::getimagedispose
Gmagick
PHP Manual

Gmagick::getimagedepth

(PECL gmagick >= Unknown)

Gmagick::getimagedepth — Gets the depth of the image

Açıklama

public int Gmagick::getimagedepth ( void )

Gets the depth of the image.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Image depth

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::getimagedelay
Gmagick::getimagedispose
Gmagick


Gets the image disposal method

Gmagick::getimagedepth
Gmagick::getimageextrema
Gmagick
PHP Manual

Gmagick::getimagedispose

(PECL gmagick >= Unknown)

Gmagick::getimagedispose — Gets the image disposal method

Açıklama

public int Gmagick::getimagedispose ( void )

Gets the image disposal method

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the dispose method on success.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::getimagedepth
Gmagick::getimageextrema
Gmagick


Gets the extrema for the image

Gmagick::getimagedispose
Gmagick::getimagefilename
Gmagick
PHP Manual

Gmagick::getimageextrema

(PECL gmagick >= Unknown)

Gmagick::getimageextrema — Gets the extrema for the image

Açıklama

public array Gmagick::getimageextrema ( void )

Returns an associative array with the keys "min" and "max". Hata durumunda bir GmagickException istisnası oluşur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an associative array with the keys "min" and "max".

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::getimagedispose
Gmagick::getimagefilename
Gmagick


Returns the filename of a particular image in a sequence

Gmagick::getimageextrema
Gmagick::getimageformat
Gmagick
PHP Manual

Gmagick::getimagefilename

(PECL gmagick >= Unknown)

Gmagick::getimagefilename — Returns the filename of a particular image in a sequence

Açıklama

public string Gmagick::getimagefilename ( void )

Returns the filename of a particular image in a sequence

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a string with the filename of the image

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::getimageextrema
Gmagick::getimageformat
Gmagick


Returns the format of a particular image in a sequence

Gmagick::getimagefilename
Gmagick::getimagegamma
Gmagick
PHP Manual

Gmagick::getimageformat

(PECL gmagick >= Unknown)

Gmagick::getimageformat — Returns the format of a particular image in a sequence

Açıklama

public string Gmagick::getimageformat ( void )

Returns the format of a particular image in a sequence.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a string containing the image format on success.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::getimagefilename
Gmagick::getimagegamma
Gmagick


Gets the image gamma

Gmagick::getimageformat
Gmagick::getimagegreenprimary
Gmagick
PHP Manual

Gmagick::getimagegamma

(PECL gmagick >= Unknown)

Gmagick::getimagegamma — Gets the image gamma

Açıklama

public float Gmagick::getimagegamma ( void )

Gets the image gamma

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the image gamma on success

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::getimageformat
Gmagick::getimagegreenprimary
Gmagick


Returns the chromaticy green primary point

Gmagick::getimagegamma
Gmagick::getimageheight
Gmagick
PHP Manual

Gmagick::getimagegreenprimary

(PECL gmagick >= Unknown)

Gmagick::getimagegreenprimary — Returns the chromaticy green primary point

Açıklama

public array Gmagick::getimagegreenprimary ( void )

Returns the chromaticity green primary point. Returns an array with the keys "x" and "y".

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array with the keys "x" and "y" on success.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::getimagegamma
Gmagick::getimageheight
Gmagick


Returns the image height

Gmagick::getimagegreenprimary
Gmagick::getimagehistogram
Gmagick
PHP Manual

Gmagick::getimageheight

(PECL gmagick >= Unknown)

Gmagick::getimageheight — Returns the image height

Açıklama

public int Gmagick::getimageheight ( void )

Returns the image height

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the image height in pixels.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::getimagegreenprimary
Gmagick::getimagehistogram
Gmagick


Gets the image histogram

Gmagick::getimageheight
Gmagick::getimageindex
Gmagick
PHP Manual

Gmagick::getimagehistogram

(PECL gmagick >= Unknown)

Gmagick::getimagehistogram — Gets the image histogram

Açıklama

public array Gmagick::getimagehistogram ( void )

Returns the image histogram as an array of GmagickPixel objects. Throw an GmagickException on error.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the image histogram as an array of GmagickPixel objects.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::getimageheight
Gmagick::getimageindex
Gmagick


Gets the index of the current active image

Gmagick::getimagehistogram
Gmagick::getimageinterlacescheme
Gmagick
PHP Manual

Gmagick::getimageindex

(PECL gmagick >= Unknown)

Gmagick::getimageindex — Gets the index of the current active image

Açıklama

public int Gmagick::getimageindex ( void )

Returns the index of the current active image within the Gmagick object.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Index of current active image

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::getimagehistogram
Gmagick::getimageinterlacescheme
Gmagick


Gets the image interlace scheme

Gmagick::getimageindex
Gmagick::getimageiterations
Gmagick
PHP Manual

Gmagick::getimageinterlacescheme

(PECL gmagick >= Unknown)

Gmagick::getimageinterlacescheme — Gets the image interlace scheme

Açıklama

public int Gmagick::getimageinterlacescheme ( void )

Gets the image interlace scheme.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the interlace scheme as an integer on success

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::getimageindex
Gmagick::getimageiterations
Gmagick


Gets the image iterations

Gmagick::getimageinterlacescheme
Gmagick::getimagematte
Gmagick
PHP Manual

Gmagick::getimageiterations

(PECL gmagick >= Unknown)

Gmagick::getimageiterations — Gets the image iterations

Açıklama

public int Gmagick::getimageiterations ( void )

Gets the image iterations.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the image iterations as an integer.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::getimageinterlacescheme
Gmagick::getimagematte
Gmagick


Check if the image has a matte channel

Gmagick::getimageiterations
Gmagick::getimagemattecolor
Gmagick
PHP Manual

Gmagick::getimagematte

(PECL gmagick >= Unknown)

Gmagick::getimagematte — Check if the image has a matte channel

Açıklama

public int Gmagick::getimagematte ( void )

Returns TRUE if the image has a matte channel, otherwise FALSE.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the image has a matte channel, otherwise FALSE.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::getimageiterations
Gmagick::getimagemattecolor
Gmagick


Returns the image matte color

Gmagick::getimagematte
Gmagick::getimageprofile
Gmagick
PHP Manual

Gmagick::getimagemattecolor

(PECL gmagick >= Unknown)

Gmagick::getimagemattecolor — Returns the image matte color

Açıklama

public GmagickPixel Gmagick::getimagemattecolor ( void )

Returns GmagickPixel object on success. Throw an GmagickException on error.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns GmagickPixel object on success.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::getimagematte
Gmagick::getimageprofile
Gmagick


Returns the named image profile.

Gmagick::getimagemattecolor
Gmagick::getimageredprimary
Gmagick
PHP Manual

Gmagick::getimageprofile

(PECL gmagick >= Unknown)

Gmagick::getimageprofile — Returns the named image profile.

Açıklama

public string Gmagick::getimageprofile ( string $name )

Returns the named image profile.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a string containing the image profile.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::getimagemattecolor
Gmagick::getimageredprimary
Gmagick


Returns the chromaticity red primary point

Gmagick::getimageprofile
Gmagick::getimagerenderingintent
Gmagick
PHP Manual

Gmagick::getimageredprimary

(PECL gmagick >= Unknown)

Gmagick::getimageredprimary — Returns the chromaticity red primary point

Açıklama

public array Gmagick::getimageredprimary ( void )

Returns the chromaticity red primary point as an array with the keys "x" and "y".

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the chromaticity red primary point as an array with the keys "x" and "y".

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::getimageprofile
Gmagick::getimagerenderingintent
Gmagick


Gets the image rendering intent

Gmagick::getimageredprimary
Gmagick::getimageresolution
Gmagick
PHP Manual

Gmagick::getimagerenderingintent

(PECL gmagick >= Unknown)

Gmagick::getimagerenderingintent — Gets the image rendering intent

Açıklama

public int Gmagick::getimagerenderingintent ( void )

Gets the image rendering intent

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Extracts a region of the image and returns it as a a new wand

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::getimageredprimary
Gmagick::getimageresolution
Gmagick


Gets the image X and Y resolution

Gmagick::getimagerenderingintent
Gmagick::getimagescene
Gmagick
PHP Manual

Gmagick::getimageresolution

(PECL gmagick >= Unknown)

Gmagick::getimageresolution — Gets the image X and Y resolution

Açıklama

public array Gmagick::getimageresolution ( void )

Returns the resolution as an array.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the resolution as an array.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::getimagerenderingintent
Gmagick::getimagescene
Gmagick


Gets the image scene

Gmagick::getimageresolution
Gmagick::getimagesignature
Gmagick
PHP Manual

Gmagick::getimagescene

(PECL gmagick >= Unknown)

Gmagick::getimagescene — Gets the image scene

Açıklama

public int Gmagick::getimagescene ( void )

Gets the image scene.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the image scene.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::getimageresolution
Gmagick::getimagesignature
Gmagick


Generates an SHA-256 message digest

Gmagick::getimagescene
Gmagick::getimagetype
Gmagick
PHP Manual

Gmagick::getimagesignature

(PECL gmagick >= Unknown)

Gmagick::getimagesignature — Generates an SHA-256 message digest

Açıklama

public string Gmagick::getimagesignature ( void )

Generates an SHA-256 message digest for the image pixel stream.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a string containing the SHA-256 hash of the file.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::getimagescene
Gmagick::getimagetype
Gmagick


Gets the potential image type.

Gmagick::getimagesignature
Gmagick::getimageunits
Gmagick
PHP Manual

Gmagick::getimagetype

(PECL gmagick >= Unknown)

Gmagick::getimagetype — Gets the potential image type.

Açıklama

public int Gmagick::getimagetype ( void )

Gets the potential image type.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the potential image type.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::getimagesignature
Gmagick::getimageunits
Gmagick


Gets the image units of resolution

Gmagick::getimagetype
Gmagick::getimagewhitepoint
Gmagick
PHP Manual

Gmagick::getimageunits

(PECL gmagick >= Unknown)

Gmagick::getimageunits — Gets the image units of resolution

Açıklama

public int Gmagick::getimageunits ( void )

Gets the image units of resolution.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the image units of resolution.

Gmagick::getimagetype
Gmagick::getimagewhitepoint
Gmagick


Returns the chromaticity white point

Gmagick::getimageunits
Gmagick::getimagewidth
Gmagick
PHP Manual

Gmagick::getimagewhitepoint

(PECL gmagick >= Unknown)

Gmagick::getimagewhitepoint — Returns the chromaticity white point

Açıklama

public array Gmagick::getimagewhitepoint ( void )

Returns the chromaticity white point as an associative array with the keys "x" and "y".

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the chromaticity white point as an associative array with the keys "x" and "y".

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::getimageunits
Gmagick::getimagewidth
Gmagick


Returns the width of the image

Gmagick::getimagewhitepoint
Gmagick::getpackagename
Gmagick
PHP Manual

Gmagick::getimagewidth

(PECL gmagick >= Unknown)

Gmagick::getimagewidth — Returns the width of the image

Açıklama

public int Gmagick::getimagewidth ( void )

Returns the width of the image.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the image width.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::getimagewhitepoint
Gmagick::getpackagename
Gmagick


Returns the GraphicsMagick package name.

Gmagick::getimagewidth
Gmagick::getquantumdepth
Gmagick
PHP Manual

Gmagick::getpackagename

(PECL gmagick >= Unknown)

Gmagick::getpackagename — Returns the GraphicsMagick package name.

Açıklama

public string Gmagick::getpackagename ( void )

Returns the GraphicsMagick package name.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the GraphicsMagick package name as a string.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::getimagewidth
Gmagick::getquantumdepth
Gmagick


Returns the Gmagick quantum depth as a string.

Gmagick::getpackagename
Gmagick::getreleasedate
Gmagick
PHP Manual

Gmagick::getquantumdepth

(PECL gmagick >= Unknown)

Gmagick::getquantumdepth — Returns the Gmagick quantum depth as a string.

Açıklama

public array Gmagick::getquantumdepth ( void )

Returns the Gmagick quantum depth as a string.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the Gmagick quantum depth as a string.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::getpackagename
Gmagick::getreleasedate
Gmagick


Returns the GraphicsMagick release date as a string.

Gmagick::getquantumdepth
Gmagick::getsamplingfactors
Gmagick
PHP Manual

Gmagick::getreleasedate

(PECL gmagick >= Unknown)

Gmagick::getreleasedate — Returns the GraphicsMagick release date as a string.

Açıklama

public string Gmagick::getreleasedate ( void )

Returns the GraphicsMagick release date as a string.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the GraphicsMagick release date as a string.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::getquantumdepth
Gmagick::getsamplingfactors
Gmagick


Gets the horizontal and vertical sampling factor.

Gmagick::getreleasedate
Gmagick::getsize
Gmagick
PHP Manual

Gmagick::getsamplingfactors

(PECL gmagick >= Unknown)

Gmagick::getsamplingfactors — Gets the horizontal and vertical sampling factor.

Açıklama

public array Gmagick::getsamplingfactors ( void )

Gets the horizontal and vertical sampling factor.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an associative array with the horizontal and vertical sampling factors of the image.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::getreleasedate
Gmagick::getsize
Gmagick


Returns the size associated with the Gmagick object

Gmagick::getsamplingfactors
Gmagick::getversion
Gmagick
PHP Manual

Gmagick::getsize

(PECL gmagick >= Unknown)

Gmagick::getsize — Returns the size associated with the Gmagick object

Açıklama

public array Gmagick::getsize ( void )

Returns the size associated with the Gmagick object as an array with the keys "columns" and "rows".

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the size associated with the Gmagick object as an array with the keys "columns" and "rows".

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::getsamplingfactors
Gmagick::getversion
Gmagick


Returns the GraphicsMagick API version

Gmagick::getsize
Gmagick::hasnextimage
Gmagick
PHP Manual

Gmagick::getversion

(PECL gmagick >= Unknown)

Gmagick::getversion — Returns the GraphicsMagick API version

Açıklama

public array Gmagick::getversion ( void )

Returns the GraphicsMagick API version as a string and as a number.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the GraphicsMagick API version as a string and as a number.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::getsize
Gmagick::hasnextimage
Gmagick


Checks if the object has more images

Gmagick::getversion
Gmagick::haspreviousimage
Gmagick
PHP Manual

Gmagick::hasnextimage

(PECL gmagick >= Unknown)

Gmagick::hasnextimage — Checks if the object has more images

Açıklama

public mixed Gmagick::hasnextimage ( void )

Returns TRUE if the object has more images when traversing the list in the forward direction.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the object has more images when traversing the list in the forward direction, returns FALSE if there are none.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::getversion
Gmagick::haspreviousimage
Gmagick


Checks if the object has a previous image

Gmagick::hasnextimage
Gmagick::implodeimage
Gmagick
PHP Manual

Gmagick::haspreviousimage

(PECL gmagick >= Unknown)

Gmagick::haspreviousimage — Checks if the object has a previous image

Açıklama

public mixed Gmagick::haspreviousimage ( void )

Returns TRUE if the object has more images when traversing the list in the reverse direction

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the object has more images when traversing the list in the reverse direction, returns FALSE if there are none.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::hasnextimage
Gmagick::implodeimage
Gmagick


Creates a new image as a copy

Gmagick::haspreviousimage
Gmagick::labelimage
Gmagick
PHP Manual

Gmagick::implodeimage

(PECL gmagick >= Unknown)

Gmagick::implodeimage — Creates a new image as a copy

Açıklama

public mixed Gmagick::implodeimage ( float $radius )

Creates a new image that is a copy of an existing one with the image pixels "imploded" by the specified percentage.

Değiştirgeler

radius

The radius of the implode

Dönen Değerler

Returns imploded Gmagick object.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::haspreviousimage
Gmagick::labelimage
Gmagick


Adds a label to an image.

Gmagick::implodeimage
Gmagick::levelimage
Gmagick
PHP Manual

Gmagick::labelimage

(PECL gmagick >= Unknown)

Gmagick::labelimage — Adds a label to an image.

Açıklama

public mixed Gmagick::labelimage ( string $label )

Adds a label to an image.

Değiştirgeler

label

The label to add

Dönen Değerler

Gmagick with label.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::implodeimage
Gmagick::levelimage
Gmagick


Adjusts the levels of an image

Gmagick::labelimage
Gmagick::magnifyimage
Gmagick
PHP Manual

Gmagick::levelimage

(PECL gmagick >= Unknown)

Gmagick::levelimage — Adjusts the levels of an image

Açıklama

public mixed Gmagick::levelimage ( float $blackPoint , float $gamma , float $whitePoint [, int $channel = Gmagick::CHANNEL_DEFAULT ] )

Adjusts the levels of an image by scaling the colors falling between specified white and black points to the full available quantum range. The parameters provided represent the black, mid, and white points. The black point specifies the darkest color in the image. Colors darker than the black point are set to zero. Mid point specifies a gamma correction to apply to the image. White point specifies the lightest color in the image. Colors brighter than the white point are set to the maximum quantum value.

Değiştirgeler

blackPoint

The image black point

gamma

The gamma value

whitePoint

The image white point

channel

Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channeltype constants using bitwise operators. Refer to this list of channel constants.

Dönen Değerler

Gmagick object with image levelled.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::labelimage
Gmagick::magnifyimage
Gmagick


Scales an image proportionally 2x

Gmagick::levelimage
Gmagick::mapimage
Gmagick
PHP Manual

Gmagick::magnifyimage

(PECL gmagick >= Unknown)

Gmagick::magnifyimage — Scales an image proportionally 2x

Açıklama

public mixed Gmagick::magnifyimage ( void )

Conveniently scales an image proportionally to twice its original size.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Magnified Gmagick object.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::levelimage
Gmagick::mapimage
Gmagick


Replaces the colors of an image with the closest color from a reference image.

Gmagick::magnifyimage
Gmagick::medianfilterimage
Gmagick
PHP Manual

Gmagick::mapimage

(PECL gmagick >= Unknown)

Gmagick::mapimage — Replaces the colors of an image with the closest color from a reference image.

Açıklama

public Gmagick Gmagick::mapimage ( gmagick $gmagick , bool $dither )

Replaces the colors of an image with the closest color from a reference image.

Değiştirgeler

gmagick

The reference image

dither

Set this integer value to something other than zero to dither the mapped image

Dönen Değerler

Gmagick object

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::magnifyimage
Gmagick::medianfilterimage
Gmagick


Applies a digital filter

Gmagick::mapimage
Gmagick::minifyimage
Gmagick
PHP Manual

Gmagick::medianfilterimage

(PECL gmagick >= Unknown)

Gmagick::medianfilterimage — Applies a digital filter

Açıklama

public void Gmagick::medianfilterimage ( float $radius )

Applies a digital filter that improves the quality of a noisy image. Each pixel is replaced by the median in a set of neighboring pixels as defined by radius.

Değiştirgeler

radius

The radius of the pixel neighborhood.

Dönen Değerler

Gmagick object with median filter applied.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::mapimage
Gmagick::minifyimage
Gmagick


Scales an image proportionally to half its size

Gmagick::medianfilterimage
Gmagick::modulateimage
Gmagick
PHP Manual

Gmagick::minifyimage

(PECL gmagick >= Unknown)

Gmagick::minifyimage — Scales an image proportionally to half its size

Açıklama

public Gmagick Gmagick::minifyimage ( void )

A convenient method that scales an image proportionally to one-half its original size

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The Gmagick object on success

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::medianfilterimage
Gmagick::modulateimage
Gmagick


Control the brightness, saturation, and hue

Gmagick::minifyimage
Gmagick::motionblurimage
Gmagick
PHP Manual

Gmagick::modulateimage

(PECL gmagick >= Unknown)

Gmagick::modulateimage — Control the brightness, saturation, and hue

Açıklama

public Gmagick Gmagick::modulateimage ( float $brightness , float $saturation , float $hue )

Lets you control the brightness, saturation, and hue of an image. Hue is the percentage of absolute rotation from the current position. For example 50 results in a counter-clockwise rotation of 90 degrees, 150 results in a clockwise rotation of 90 degrees, with 0 and 200 both resulting in a rotation of 180 degrees.

Değiştirgeler

brightness

The percent change in brighness (-100 thru +100).

saturation

The percent change in saturation (-100 thru +100)

hue

The percent change in hue (-100 thru +100)

Dönen Değerler

The Gmagick object on success

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::minifyimage
Gmagick::motionblurimage
Gmagick


Simulates motion blur

Gmagick::modulateimage
Gmagick::newimage
Gmagick
PHP Manual

Gmagick::motionblurimage

(PECL gmagick >= Unknown)

Gmagick::motionblurimage — Simulates motion blur

Açıklama

public Gmagick Gmagick::motionblurimage ( float $radius , float $sigma , float $angle )

Simulates motion blur. We convolve the image with a Gaussian operator of the given radius and standard deviation (sigma). For reasonable results, radius should be larger than sigma. Use a radius of 0 and MotionBlurImage() selects a suitable radius for you. Angle gives the angle of the blurring motion.

Değiştirgeler

radius

The radius of the Gaussian, in pixels, not counting the center pixel.

sigma

The standard deviation of the Gaussian, in pixels.

angle

Apply the effect along this angle.

Dönen Değerler

The Gmagick object on success

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::modulateimage
Gmagick::newimage
Gmagick


Creates a new image

Gmagick::motionblurimage
Gmagick::nextimage
Gmagick
PHP Manual

Gmagick::newimage

(PECL gmagick >= Unknown)

Gmagick::newimage — Creates a new image

Açıklama

public Gmagick Gmagick::newimage ( int $width , int $height , string $background [, string $format ] )

Creates a new image with the specified background color

Değiştirgeler

width

Width of the new image

height

Height of the new image

background

The background color used for this image (as float)

format

Image format.

Dönen Değerler

The Gmagick object on success

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::motionblurimage
Gmagick::nextimage
Gmagick


Moves to the next image

Gmagick::newimage
Gmagick::normalizeimage
Gmagick
PHP Manual

Gmagick::nextimage

(PECL gmagick >= Unknown)

Gmagick::nextimage — Moves to the next image

Açıklama

public bool Gmagick::nextimage ( void )

Associates the next image in the image list with an Gmagick object.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::newimage
Gmagick::normalizeimage
Gmagick


Enhances the contrast of a color image

Gmagick::nextimage
Gmagick::oilpaintimage
Gmagick
PHP Manual

Gmagick::normalizeimage

(PECL gmagick >= Unknown)

Gmagick::normalizeimage — Enhances the contrast of a color image

Açıklama

public Gmagick Gmagick::normalizeimage ([ int $channel ] )

Enhances the contrast of a color image by adjusting the pixels color to span the entire range of colors available.

Değiştirgeler

channel

Identify which channel to normalize

Dönen Değerler

The Gmagick object on success

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::nextimage
Gmagick::oilpaintimage
Gmagick


Simulates an oil painting

Gmagick::normalizeimage
Gmagick::previousimage
Gmagick
PHP Manual

Gmagick::oilpaintimage

(PECL gmagick >= Unknown)

Gmagick::oilpaintimage — Simulates an oil painting

Açıklama

public Gmagick Gmagick::oilpaintimage ( float $radius )

Applies a special effect filter that simulates an oil painting. Each pixel is replaced by the most frequent color occurring in a circular region defined by radius.

Değiştirgeler

radius

The radius of the circular neighborhood.

Dönen Değerler

The Gmagick object on success

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::normalizeimage
Gmagick::previousimage
Gmagick


Move to the previous image in the object

Gmagick::oilpaintimage
Gmagick::profileimage
Gmagick
PHP Manual

Gmagick::previousimage

(PECL gmagick >= Unknown)

Gmagick::previousimage — Move to the previous image in the object

Açıklama

public bool Gmagick::previousimage ( void )

Associates the previous image in an image list with the Gmagick object.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::oilpaintimage
Gmagick::profileimage
Gmagick


Adds or removes a profile from an image

Gmagick::previousimage
Gmagick::quantizeimage
Gmagick
PHP Manual

Gmagick::profileimage

(PECL gmagick >= Unknown)

Gmagick::profileimage — Adds or removes a profile from an image

Açıklama

public Gmagick Gmagick::profileimage ( string $name , string $profile )

Adds or removes a ICC, IPTC, or generic profile from an image. If the profile is NULL, it is removed from the image otherwise added. Use a name of '*' and a profile of NULL to remove all profiles from the image.

Değiştirgeler

name

Name of profile to add or remove: ICC, IPTC, or generic profile.

profile

The profile.

Dönen Değerler

The Gmagick object on success

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::previousimage
Gmagick::quantizeimage
Gmagick


Analyzes the colors within a reference image

Gmagick::profileimage
Gmagick::quantizeimages
Gmagick
PHP Manual

Gmagick::quantizeimage

(PECL gmagick >= Unknown)

Gmagick::quantizeimage — Analyzes the colors within a reference image

Açıklama

public Gmagick Gmagick::quantizeimage ( int $numColors , int $colorspace , int $treeDepth , bool $dither , bool $measureError )

Analyzes the colors within a reference image and chooses a fixed number of colors to represent the image. The goal of the algorithm is to minimize the color difference between the input and output image while minimizing the processing time.

Değiştirgeler

numColors

The number of colors.

colorspace

Perform color reduction in this colorspace, typically RGBColorspace.

treeDepth

Normally, this integer value is zero or one. A zero or one tells Quantize to choose a optimal tree depth of Log4(number_colors).% A tree of this depth generally allows the best representation of the reference image with the least amount of memory and the fastest computational speed. In some cases, such as an image with low color dispersion (a few number of colors), a value other than Log4(number_colors) is required. To expand the color tree completely, use a value of 8.

dither

A value other than zero distributes the difference between an original image and the corresponding color reduced algorithm to neighboring pixels along a Hilbert curve.

measureError

A value other than zero measures the difference between the original and quantized images. This difference is the total quantization error. The error is computed by summing over all pixels in an image the distance squared in RGB space between each reference pixel value and its quantized value.

Dönen Değerler

The Gmagick object on success

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::profileimage
Gmagick::quantizeimages
Gmagick


The quantizeimages purpose

Gmagick::quantizeimage
Gmagick::queryfontmetrics
Gmagick
PHP Manual

Gmagick::quantizeimages

(PECL gmagick >= Unknown)

Gmagick::quantizeimages — The quantizeimages purpose

Açıklama

public Gmagick Gmagick::quantizeimages ( int $numColors , int $colorspace , int $treeDepth , bool $dither , bool $measureError )

Analyzes the colors within a sequence of images and chooses a fixed number of colors to represent the image. The goal of the algorithm is to minimize the color difference between the input and output image while minimizing the processing time.

Değiştirgeler

numColors

The number of colors.

colorspace

Perform color reduction in this colorspace, typically RGBColorspace.

treeDepth

Normally, this integer value is zero or one. A zero or one tells Quantize to choose a optimal tree depth of Log4(number_colors).% A tree of this depth generally allows the best representation of the reference image with the least amount of memory and the fastest computational speed. In some cases, such as an image with low color dispersion (a few number of colors), a value other than Log4(number_colors) is required. To expand the color tree completely, use a value of 8.

dither

A value other than zero distributes the difference between an original image and the corresponding color reduced algorithm to neighboring pixels along a Hilbert curve.

measureError

A value other than zero measures the difference between the original and quantized images. This difference is the total quantization error. The error is computed by summing over all pixels in an image the distance squared in RGB space between each reference pixel value and its quantized value.

Dönen Değerler

The Gmagick object on success

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::quantizeimage
Gmagick::queryfontmetrics
Gmagick


Returns an array representing the font metrics

Gmagick::quantizeimages
Gmagick::queryfonts
Gmagick
PHP Manual

Gmagick::queryfontmetrics

(PECL gmagick >= Unknown)

Gmagick::queryfontmetrics — Returns an array representing the font metrics

Açıklama

public array Gmagick::queryfontmetrics ( GmagickDraw $draw , string $text )

MagickQueryFontMetrics() returns an array representing the font metrics.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The Gmagick object on success

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::quantizeimages
Gmagick::queryfonts
Gmagick


Returns the configured fonts

Gmagick::queryfontmetrics
Gmagick::queryformats
Gmagick
PHP Manual

Gmagick::queryfonts

(PECL gmagick >= Unknown)

Gmagick::queryfonts — Returns the configured fonts

Açıklama

public array Gmagick::queryfonts ([ string $pattern = "*" ] )

Returns fonts supported by Gmagick.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The Gmagick object on success

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::queryfontmetrics
Gmagick::queryformats
Gmagick


Returns formats supported by Gmagick.

Gmagick::queryfonts
Gmagick::radialblurimage
Gmagick
PHP Manual

Gmagick::queryformats

(PECL gmagick >= Unknown)

Gmagick::queryformats — Returns formats supported by Gmagick.

Açıklama

public array Gmagick::queryformats ([ string $pattern = "*" ] )

Returns formats supported by Gmagick.

Değiştirgeler

pattern

Specifies a string containing a pattern.

Dönen Değerler

The Gmagick object on success

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::queryfonts
Gmagick::radialblurimage
Gmagick


Radial blurs an image

Gmagick::queryformats
Gmagick::raiseimage
Gmagick
PHP Manual

Gmagick::radialblurimage

(PECL gmagick >= Unknown)

Gmagick::radialblurimage — Radial blurs an image

Açıklama

public Gmagick Gmagick::radialblurimage ( float $angle [, int $channel = Gmagick::CHANNEL_DEFAULT ] )

Radial blurs an image.

Değiştirgeler

angle

The angle of the blur in degrees.

channel

Related channel

Dönen Değerler

The Gmagick object on success

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::queryformats
Gmagick::raiseimage
Gmagick


Creates a simulated 3d button-like effect

Gmagick::radialblurimage
Gmagick::read
Gmagick
PHP Manual

Gmagick::raiseimage

(PECL gmagick >= Unknown)

Gmagick::raiseimage — Creates a simulated 3d button-like effect

Açıklama

public Gmagick Gmagick::raiseimage ( int $width , int $height , int $x , int $y , bool $raise )

Creates a simulated three-dimensional button-like effect by lightening and darkening the edges of the image. Members width and height of raise_info define the width of the vertical and horizontal edge of the effect.

Değiştirgeler

width

Width of the area to raise.

height

Height of the area to raise.

x

X coordinate

y

Y coordinate

raise

A value other than zero creates a 3-D raise effect, otherwise it has a lowered effect.

Dönen Değerler

The Gmagick object on success

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::radialblurimage
Gmagick::read
Gmagick


Reads image from filename

Gmagick::raiseimage
Gmagick::readimage
Gmagick
PHP Manual

Gmagick::read

(PECL gmagick >= Unknown)

Gmagick::read — Reads image from filename

Açıklama

public Gmagick Gmagick::read ( string $filename )

Reads image from filename.

Değiştirgeler

filename

The image filename.

Dönen Değerler

The Gmagick object on success

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::raiseimage
Gmagick::readimage
Gmagick


Reads image from filename

Gmagick::read
Gmagick::readimageblob
Gmagick
PHP Manual

Gmagick::readimage

(PECL gmagick >= Unknown)

Gmagick::readimage — Reads image from filename

Açıklama

public Gmagick Gmagick::readimage ( string $filename )

Reads image from filename.

Değiştirgeler

filename

The image filename.

Dönen Değerler

The Gmagick object on success

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::read
Gmagick::readimageblob
Gmagick


Reads image from a binary string

Gmagick::readimage
Gmagick::readimagefile
Gmagick
PHP Manual

Gmagick::readimageblob

(PECL gmagick >= Unknown)

Gmagick::readimageblob — Reads image from a binary string

Açıklama

public Gmagick Gmagick::readimageblob ( string $imageContents [, string $filename ] )

Reads image from a binary string.

Değiştirgeler

imageContents

Content of image

filename

The image filename.

Dönen Değerler

The Gmagick object on success

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::readimage
Gmagick::readimagefile
Gmagick


The readimagefile purpose

Gmagick::readimageblob
Gmagick::reducenoiseimage
Gmagick
PHP Manual

Gmagick::readimagefile

(PECL gmagick >= Unknown)

Gmagick::readimagefile — The readimagefile purpose

Açıklama

public Gmagick Gmagick::readimagefile ( resource $fp [, string $filename ] )

Reads an image or image sequence from an open file descriptor.

Değiştirgeler

fp

The file descriptor.

Dönen Değerler

The Gmagick object on success

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::readimageblob
Gmagick::reducenoiseimage
Gmagick


Smooths the contours of an image

Gmagick::readimagefile
Gmagick::removeimage
Gmagick
PHP Manual

Gmagick::reducenoiseimage

(PECL gmagick >= Unknown)

Gmagick::reducenoiseimage — Smooths the contours of an image

Açıklama

public Gmagick Gmagick::reducenoiseimage ( float $radius )

Smooths the contours of an image while still preserving edge information. The algorithm works by replacing each pixel with its neighbor closest in value. A neighbor is defined by radius. Use a radius of 0 and Gmagick::reduceNoiseImage() selects a suitable radius for you.

Değiştirgeler

radius

The radius of the pixel neighborhood.

Dönen Değerler

The Gmagick object on success

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::readimagefile
Gmagick::removeimage
Gmagick


Removes an image from the image list

Gmagick::reducenoiseimage
Gmagick::removeimageprofile
Gmagick
PHP Manual

Gmagick::removeimage

(PECL gmagick >= Unknown)

Gmagick::removeimage — Removes an image from the image list

Açıklama

public Gmagick Gmagick::removeimage ( void )

Removes an image from the image list.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The Gmagick object on success.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::reducenoiseimage
Gmagick::removeimageprofile
Gmagick


Removes the named image profile and returns it

Gmagick::removeimage
Gmagick::resampleimage
Gmagick
PHP Manual

Gmagick::removeimageprofile

(PECL gmagick >= Unknown)

Gmagick::removeimageprofile — Removes the named image profile and returns it

Açıklama

public string Gmagick::removeimageprofile ( string $name )

Removes the named image profile and returns it.

Değiştirgeler

name

Name of profile to return: ICC, IPTC, or generic profile.

Dönen Değerler

The named profile.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::removeimage
Gmagick::resampleimage
Gmagick


Resample image to desired resolution

Gmagick::removeimageprofile
Gmagick::resizeimage
Gmagick
PHP Manual

Gmagick::resampleimage

(PECL gmagick >= Unknown)

Gmagick::resampleimage — Resample image to desired resolution

Açıklama

public Gmagick Gmagick::resampleimage ( float $xResolution , float $yResolution , int $filter , float $blur )

Resample image to desired resolution.

Değiştirgeler

xResolution

The new image x resolution.

yResolution

The new image y resolution.

filter

Image filter to use.

blur

The blur factor where larger than 1 is blurry, smaller than 1 is sharp.

Dönen Değerler

The Gmagick object on success

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::removeimageprofile
Gmagick::resizeimage
Gmagick


Scales an image

Gmagick::resampleimage
Gmagick::rollimage
Gmagick
PHP Manual

Gmagick::resizeimage

(PECL gmagick >= Unknown)

Gmagick::resizeimage — Scales an image

Açıklama

public Gmagick Gmagick::resizeimage ( int $width , int $height , int $filter , float $blur [, bool $fit = false ] )

Scales an image to the desired dimensions with a filter.

Değiştirgeler

width

The number of columns in the scaled image.

height

The number of rows in the scaled image.

filter

Image filter to use.

blur

The blur factor where larger than 1 is blurry, lesser than 1 is sharp.

Dönen Değerler

The Gmagick object on success

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::resampleimage
Gmagick::rollimage
Gmagick


Offsets an image

Gmagick::resizeimage
Gmagick::rotateimage
Gmagick
PHP Manual

Gmagick::rollimage

(PECL gmagick >= Unknown)

Gmagick::rollimage — Offsets an image

Açıklama

public Gmagick Gmagick::rollimage ( int $x , int $y )

Offsets an image as defined by x and y.

Değiştirgeler

x

The x offset.

y

The y offset.

Dönen Değerler

The Gmagick object on success

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::resizeimage
Gmagick::rotateimage
Gmagick


Rotates an image

Gmagick::rollimage
Gmagick::scaleimage
Gmagick
PHP Manual

Gmagick::rotateimage

(PECL gmagick >= Unknown)

Gmagick::rotateimage — Rotates an image

Açıklama

public Gmagick Gmagick::rotateimage ( mixed $color , float $degrees )

Rotates an image the specified number of degrees. Empty triangles left over from rotating the image are filled with the background color.

Değiştirgeler

color

The background pixel.

degrees

The number of degrees to rotate the image.

Dönen Değerler

The Gmagick object on success

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::rollimage
Gmagick::scaleimage
Gmagick


Scales the size of an image

Gmagick::rotateimage
Gmagick::separateimagechannel
Gmagick
PHP Manual

Gmagick::scaleimage

(PECL gmagick >= Unknown)

Gmagick::scaleimage — Scales the size of an image

Açıklama

public Gmagick Gmagick::scaleimage ( int $width , int $height [, bool $fit = false ] )

Scales the size of an image to the given dimensions. The other parameter will be calculated if 0 is passed as either param.

Değiştirgeler

width

The number of columns in the scaled image.

height

The number of rows in the scaled image.

Dönen Değerler

The Gmagick object on success.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::rotateimage
Gmagick::separateimagechannel
Gmagick


Separates a channel from the image

Gmagick::scaleimage
Gmagick::setCompressionQuality
Gmagick
PHP Manual

Gmagick::separateimagechannel

(PECL gmagick >= Unknown)

Gmagick::separateimagechannel — Separates a channel from the image

Açıklama

public Gmagick Gmagick::separateimagechannel ( int $channel )

Separates a channel from the image and returns a grayscale image. A channel is a particular color component of each pixel in the image.

Değiştirgeler

channel

Identify which channel to extract: RedChannel, GreenChannel, BlueChannel, OpacityChannel, CyanChannel, MagentaChannel, YellowChannel, BlackChannel.

Dönen Değerler

The Gmagick object on success

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::scaleimage
Gmagick::setCompressionQuality
Gmagick


Sets the object's default compression quality

Gmagick::separateimagechannel
Gmagick::setfilename
Gmagick
PHP Manual

Gmagick::setCompressionQuality

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Gmagick::setCompressionQuality — Sets the object's default compression quality

Açıklama

Gmagick Gmagick::setCompressionQuality ( int $quality = 75 )

Sets the object's default compression quality.

Değiştirgeler

quality

Dönen Değerler

The Gmagick object on success

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Örnekler

Örnek 1 Gmagick::setCompressionQuality()

<?php
$gm = new Gmagick();
$gm->read("magick:rose");
$gm->setCompressionQuality(2);
?>

Gmagick::separateimagechannel
Gmagick::setfilename
Gmagick


Sets the filename before you read or write the image

Gmagick::setCompressionQuality
Gmagick::setimagebackgroundcolor
Gmagick
PHP Manual

Gmagick::setfilename

(PECL gmagick >= Unknown)

Gmagick::setfilename — Sets the filename before you read or write the image

Açıklama

public Gmagick Gmagick::setfilename ( string $filename )

Sets the filename before you read or write an image file.

Değiştirgeler

filename

The image filename.

Dönen Değerler

The Gmagick object on success

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::setCompressionQuality
Gmagick::setimagebackgroundcolor
Gmagick


Sets the image background color.

Gmagick::setfilename
Gmagick::setimageblueprimary
Gmagick
PHP Manual

Gmagick::setimagebackgroundcolor

(PECL gmagick >= Unknown)

Gmagick::setimagebackgroundcolor — Sets the image background color.

Açıklama

public Gmagick Gmagick::setimagebackgroundcolor ( GmagickPixel $color )

Sets the image background color.

Değiştirgeler

color

The background pixel wand.

Dönen Değerler

The Gmagick object on success

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::setfilename
Gmagick::setimageblueprimary
Gmagick


Sets the image chromaticity blue primary point.

Gmagick::setimagebackgroundcolor
Gmagick::setimagebordercolor
Gmagick
PHP Manual

Gmagick::setimageblueprimary

(PECL gmagick >= Unknown)

Gmagick::setimageblueprimary — Sets the image chromaticity blue primary point.

Açıklama

public Gmagick Gmagick::setimageblueprimary ( float $x , float $y )

Sets the image chromaticity blue primary point.

Değiştirgeler

x

The blue primary x-point.

y

The blue primary y-point.

Dönen Değerler

The Gmagick object on success

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::setimagebackgroundcolor
Gmagick::setimagebordercolor
Gmagick


Sets the image border color.

Gmagick::setimageblueprimary
Gmagick::setimagechanneldepth
Gmagick
PHP Manual

Gmagick::setimagebordercolor

(PECL gmagick >= Unknown)

Gmagick::setimagebordercolor — Sets the image border color.

Açıklama

public Gmagick Gmagick::setimagebordercolor ( GmagickPixel $color )

Sets the image border color.

Değiştirgeler

color

The border pixel wand.

Dönen Değerler

The Gmagick object on success

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::setimageblueprimary
Gmagick::setimagechanneldepth
Gmagick


Sets the depth of a particular image channel

Gmagick::setimagebordercolor
Gmagick::setimagecolorspace
Gmagick
PHP Manual

Gmagick::setimagechanneldepth

(PECL gmagick >= Unknown)

Gmagick::setimagechanneldepth — Sets the depth of a particular image channel

Açıklama

public Gmagick Gmagick::setimagechanneldepth ( int $channel , int $depth )

Sets the depth of a particular image channel.

Değiştirgeler

channel

Identify which channel to extract: RedChannel, GreenChannel, BlueChannel, OpacityChannel, CyanChannel, MagentaChannel, YellowChannel, BlackChannel.

depth

The image depth in bits.

Dönen Değerler

The Gmagick object on success

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::setimagebordercolor
Gmagick::setimagecolorspace
Gmagick


Sets the image colorspace

Gmagick::setimagechanneldepth
Gmagick::setimagecompose
Gmagick
PHP Manual

Gmagick::setimagecolorspace

(PECL gmagick >= Unknown)

Gmagick::setimagecolorspace — Sets the image colorspace

Açıklama

public Gmagick Gmagick::setimagecolorspace ( int $colorspace )

Sets the image colorspace.

Değiştirgeler

colorspace

The image colorspace: UndefinedColorspace, RGBColorspace, GRAYColorspace, TransparentColorspace, OHTAColorspace, XYZColorspace, YCbCrColorspace, YCCColorspace, YIQColorspace, YPbPrColorspace, YPbPrColorspace, YUVColorspace, CMYKColorspace, sRGBColorspace, HSLColorspace, or HWBColorspace.

Dönen Değerler

The Gmagick object on success

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::setimagechanneldepth
Gmagick::setimagecompose
Gmagick


Sets the image composite operator

Gmagick::setimagecolorspace
Gmagick::setimagedelay
Gmagick
PHP Manual

Gmagick::setimagecompose

(PECL gmagick >= Unknown)

Gmagick::setimagecompose — Sets the image composite operator

Açıklama

public Gmagick Gmagick::setimagecompose ( int $composite )

Sets the image composite operator.

Değiştirgeler

composite

The image composite operator.

Dönen Değerler

The Gmagick object on success

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::setimagecolorspace
Gmagick::setimagedelay
Gmagick


Sets the image delay

Gmagick::setimagecompose
Gmagick::setimagedepth
Gmagick
PHP Manual

Gmagick::setimagedelay

(PECL gmagick >= Unknown)

Gmagick::setimagedelay — Sets the image delay

Açıklama

public Gmagick Gmagick::setimagedelay ( int $delay )

Sets the image delay

Değiştirgeler

delay

The image delay in 1/100th of a second.

Dönen Değerler

The Gmagick object on success.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::setimagecompose
Gmagick::setimagedepth
Gmagick


Sets the image depth

Gmagick::setimagedelay
Gmagick::setimagedispose
Gmagick
PHP Manual

Gmagick::setimagedepth

(PECL gmagick >= Unknown)

Gmagick::setimagedepth — Sets the image depth

Açıklama

public Gmagick Gmagick::setimagedepth ( int $depth )

Sets the image depth

Değiştirgeler

depth

The image depth in bits: 8, 16, or 32.

Dönen Değerler

The Gmagick object on success.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::setimagedelay
Gmagick::setimagedispose
Gmagick


Sets the image disposal method

Gmagick::setimagedepth
Gmagick::setimagefilename
Gmagick
PHP Manual

Gmagick::setimagedispose

(PECL gmagick >= Unknown)

Gmagick::setimagedispose — Sets the image disposal method

Açıklama

public Gmagick Gmagick::setimagedispose ( int $disposeType )

Sets the image disposal method.

Değiştirgeler

disposeType

The image disposal type.

Dönen Değerler

The Gmagick object on success

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::setimagedepth
Gmagick::setimagefilename
Gmagick


Sets the filename of a particular image in a sequence

Gmagick::setimagedispose
Gmagick::setimageformat
Gmagick
PHP Manual

Gmagick::setimagefilename

(PECL gmagick >= Unknown)

Gmagick::setimagefilename — Sets the filename of a particular image in a sequence

Açıklama

public Gmagick Gmagick::setimagefilename ( string $filename )

Sets the filename of a particular image in a sequence.

Değiştirgeler

filename

The image filename.

Dönen Değerler

The Gmagick object on success.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::setimagedispose
Gmagick::setimageformat
Gmagick


Sets the format of a particular image

Gmagick::setimagefilename
Gmagick::setimagegamma
Gmagick
PHP Manual

Gmagick::setimageformat

(PECL gmagick >= Unknown)

Gmagick::setimageformat — Sets the format of a particular image

Açıklama

public Gmagick Gmagick::setimageformat ( string $imageFormat )

Sets the format of a particular image in a sequence.

Değiştirgeler

imageFormat

The image format.

Dönen Değerler

The Gmagick object on success.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::setimagefilename
Gmagick::setimagegamma
Gmagick


Sets the image gamma

Gmagick::setimageformat
Gmagick::setimagegreenprimary
Gmagick
PHP Manual

Gmagick::setimagegamma

(PECL gmagick >= Unknown)

Gmagick::setimagegamma — Sets the image gamma

Açıklama

public Gmagick Gmagick::setimagegamma ( float $gamma )

Sets the image gamma.

Değiştirgeler

gamma

The image gamma.

Dönen Değerler

The Gmagick object on success

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::setimageformat
Gmagick::setimagegreenprimary
Gmagick


Sets the image chromaticity green primary point.

Gmagick::setimagegamma
Gmagick::setimageindex
Gmagick
PHP Manual

Gmagick::setimagegreenprimary

(PECL gmagick >= Unknown)

Gmagick::setimagegreenprimary — Sets the image chromaticity green primary point.

Açıklama

public Gmagick Gmagick::setimagegreenprimary ( float $x , float $y )

Sets the image chromaticity green primary point.

Değiştirgeler

x

The chromaticity green primary x-point.

y

The chromaticity green primary y-point.

Dönen Değerler

The Gmagick object on success.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::setimagegamma
Gmagick::setimageindex
Gmagick


Set the iterator to the position in the image list specified with the index parameter

Gmagick::setimagegreenprimary
Gmagick::setimageinterlacescheme
Gmagick
PHP Manual

Gmagick::setimageindex

(PECL gmagick >= Unknown)

Gmagick::setimageindex — Set the iterator to the position in the image list specified with the index parameter

Açıklama

public Gmagick Gmagick::setimageindex ( int $index )

Set the iterator to the position in the image list specified with the index parameter.

Değiştirgeler

index

The scene number.

Dönen Değerler

The Gmagick object on success.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::setimagegreenprimary
Gmagick::setimageinterlacescheme
Gmagick


Sets the interlace scheme of the image.

Gmagick::setimageindex
Gmagick::setimageiterations
Gmagick
PHP Manual

Gmagick::setimageinterlacescheme

(PECL gmagick >= Unknown)

Gmagick::setimageinterlacescheme — Sets the interlace scheme of the image.

Açıklama

public Gmagick Gmagick::setimageinterlacescheme ( int $interlace )

Sets the interlace scheme of the image.

Değiştirgeler

interlace

The image interlace scheme: NoInterlace, LineInterlace, PlaneInterlace, PartitionInterlace.

Dönen Değerler

The Gmagick object on success

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::setimageindex
Gmagick::setimageiterations
Gmagick


Sets the image iterations.

Gmagick::setimageinterlacescheme
Gmagick::setimageprofile
Gmagick
PHP Manual

Gmagick::setimageiterations

(PECL gmagick >= Unknown)

Gmagick::setimageiterations — Sets the image iterations.

Açıklama

public Gmagick Gmagick::setimageiterations ( int $iterations )

Sets the image iterations.

Değiştirgeler

iterations

The image delay in 1/100th of a second.

Dönen Değerler

The Gmagick object on success.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::setimageinterlacescheme
Gmagick::setimageprofile
Gmagick


Adds a named profile to the Gmagick object

Gmagick::setimageiterations
Gmagick::setimageredprimary
Gmagick
PHP Manual

Gmagick::setimageprofile

(PECL gmagick >= Unknown)

Gmagick::setimageprofile — Adds a named profile to the Gmagick object

Açıklama

public Gmagick Gmagick::setimageprofile ( string $name , string $profile )

Adds a named profile to the Gmagick object. If a profile with the same name already exists, it is replaced. This method differs from the Gmagick::profileimage() method in that it does not apply any CMS color profiles.

Değiştirgeler

name

Name of profile to add or remove: ICC, IPTC, or generic profile.

profile

The profile.

Dönen Değerler

The Gmagick object on success.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::setimageiterations
Gmagick::setimageredprimary
Gmagick


Sets the image chromaticity red primary point.

Gmagick::setimageprofile
Gmagick::setimagerenderingintent
Gmagick
PHP Manual

Gmagick::setimageredprimary

(PECL gmagick >= Unknown)

Gmagick::setimageredprimary — Sets the image chromaticity red primary point.

Açıklama

public Gmagick Gmagick::setimageredprimary ( float $x , float $y )

Sets the image chromaticity red primary point.

Değiştirgeler

x

The red primary x-point.

y

The red primary y-point.

Dönen Değerler

The Gmagick object on success.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::setimageprofile
Gmagick::setimagerenderingintent
Gmagick


Sets the image rendering intent

Gmagick::setimageredprimary
Gmagick::setimageresolution
Gmagick
PHP Manual

Gmagick::setimagerenderingintent

(PECL gmagick >= Unknown)

Gmagick::setimagerenderingintent — Sets the image rendering intent

Açıklama

public Gmagick Gmagick::setimagerenderingintent ( int $rendering_intent )

Sets the image rendering intent.

Değiştirgeler

rendering_intent

The image rendering intent: UndefinedIntent, SaturationIntent, PerceptualIntent, AbsoluteIntent, or RelativeIntent.

Dönen Değerler

The Gmagick object on success.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::setimageredprimary
Gmagick::setimageresolution
Gmagick


Sets the image resolution

Gmagick::setimagerenderingintent
Gmagick::setimagescene
Gmagick
PHP Manual

Gmagick::setimageresolution

(PECL gmagick >= Unknown)

Gmagick::setimageresolution — Sets the image resolution

Açıklama

public Gmagick Gmagick::setimageresolution ( float $xResolution , float $yResolution )

Sets the image resolution.

Değiştirgeler

xResolution

The image x resolution.

yResolution

The image y resolution.

Dönen Değerler

The Gmagick object on success.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::setimagerenderingintent
Gmagick::setimagescene
Gmagick


Sets the image scene

Gmagick::setimageresolution
Gmagick::setimagetype
Gmagick
PHP Manual

Gmagick::setimagescene

(PECL gmagick >= Unknown)

Gmagick::setimagescene — Sets the image scene

Açıklama

public Gmagick Gmagick::setimagescene ( int $scene )

Sets the image scene.

Değiştirgeler

scene

The image scene number.

Dönen Değerler

The Gmagick object on success.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::setimageresolution
Gmagick::setimagetype
Gmagick


Sets the image type

Gmagick::setimagescene
Gmagick::setimageunits
Gmagick
PHP Manual

Gmagick::setimagetype

(PECL gmagick >= Unknown)

Gmagick::setimagetype — Sets the image type

Açıklama

public Gmagick Gmagick::setimagetype ( int $imgType )

Sets the image type.

Değiştirgeler

imgType

The image type: UndefinedType, BilevelType, GrayscaleType, GrayscaleMatteType, PaletteType, PaletteMatteType, TrueColorType, TrueColorMatteType, ColorSeparationType, ColorSeparationMatteType, or OptimizeType.

Dönen Değerler

The Gmagick object on success.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::setimagescene
Gmagick::setimageunits
Gmagick


Sets the image units of resolution.

Gmagick::setimagetype
Gmagick::setimagewhitepoint
Gmagick
PHP Manual

Gmagick::setimageunits

(PECL gmagick >= Unknown)

Gmagick::setimageunits — Sets the image units of resolution.

Açıklama

public Gmagick Gmagick::setimageunits ( int $resolution )

Sets the image units of resolution.

Değiştirgeler

resolution

The image units of resolution : Undefinedresolution, PixelsPerInchResolution, or PixelsPerCentimeterResolution.

Dönen Değerler

The Gmagick object on success.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::setimagetype
Gmagick::setimagewhitepoint
Gmagick


Sets the image chromaticity white point.

Gmagick::setimageunits
Gmagick::setsamplingfactors
Gmagick
PHP Manual

Gmagick::setimagewhitepoint

(PECL gmagick >= Unknown)

Gmagick::setimagewhitepoint — Sets the image chromaticity white point.

Açıklama

public Gmagick Gmagick::setimagewhitepoint ( float $x , float $y )

Sets the image chromaticity white point.

Değiştirgeler

x

The white x-point.

y

The white y-point.

Dönen Değerler

The Gmagick object on success.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::setimageunits
Gmagick::setsamplingfactors
Gmagick


Sets the image sampling factors.

Gmagick::setimagewhitepoint
Gmagick::setsize
Gmagick
PHP Manual

Gmagick::setsamplingfactors

(PECL gmagick >= Unknown)

Gmagick::setsamplingfactors — Sets the image sampling factors.

Açıklama

public Gmagick Gmagick::setsamplingfactors ( array $factors )

Sets the image sampling factors.

Değiştirgeler

factors

An array of doubles representing the sampling factor for each color component (in RGB order).

Dönen Değerler

The Gmagick object on success.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::setimagewhitepoint
Gmagick::setsize
Gmagick


Sets the size of the Gmagick object

Gmagick::setsamplingfactors
Gmagick::shearimage
Gmagick
PHP Manual

Gmagick::setsize

(PECL gmagick >= Unknown)

Gmagick::setsize — Sets the size of the Gmagick object

Açıklama

public Gmagick Gmagick::setsize ( int $columns , int $rows )

Sets the size of the Gmagick object. Set it before you read a raw image format such as RGB, GRAY, or CMYK.

Değiştirgeler

columns

The width in pixels.

rows

The height in pixels.

Dönen Değerler

The Gmagick object on success.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::setsamplingfactors
Gmagick::shearimage
Gmagick


Creating a parallelogram

Gmagick::setsize
Gmagick::solarizeimage
Gmagick
PHP Manual

Gmagick::shearimage

(PECL gmagick >= Unknown)

Gmagick::shearimage — Creating a parallelogram

Açıklama

public Gmagick Gmagick::shearimage ( mixed $color , float $xShear , float $yShear )

Slides one edge of an image along the X or Y axis, creating a parallelogram. An X direction shear slides an edge along the X axis, while a Y direction shear slides an edge along the Y axis. The amount of the shear is controlled by a shear angle. For X direction shears, x_shear is measured relative to the Y axis, and similarly, for Y direction shears y_shear is measured relative to the X axis. Empty triangles left over from shearing the image are filled with the background color.

Değiştirgeler

color

The background pixel wand.

xShear

The number of degrees to shear the image.

yShear

The number of degrees to shear the image.

Dönen Değerler

The Gmagick object on success

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::setsize
Gmagick::solarizeimage
Gmagick


Applies a solarizing effect to the image

Gmagick::shearimage
Gmagick::spreadimage
Gmagick
PHP Manual

Gmagick::solarizeimage

(PECL gmagick >= Unknown)

Gmagick::solarizeimage — Applies a solarizing effect to the image

Açıklama

public Gmagick Gmagick::solarizeimage ( int $threshold )

Applies a special effect to the image, similar to the effect achieved in a photo darkroom by selectively exposing areas of photo sensitive paper to light. Threshold ranges from 0 to QuantumRange and is a measure of the extent of the solarization.

Değiştirgeler

threshold

Define the extent of the solarization.

Dönen Değerler

The Gmagick object on success.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::shearimage
Gmagick::spreadimage
Gmagick


Randomly displaces each pixel in a block

Gmagick::solarizeimage
Gmagick::stripimage
Gmagick
PHP Manual

Gmagick::spreadimage

(PECL gmagick >= Unknown)

Gmagick::spreadimage — Randomly displaces each pixel in a block

Açıklama

public Gmagick Gmagick::spreadimage ( float $radius )

Special effects method that randomly displaces each pixel in a block defined by the radius parameter.

Değiştirgeler

radius

Choose a random pixel in a neighborhood of this extent.

Dönen Değerler

The Gmagick object on success

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::solarizeimage
Gmagick::stripimage
Gmagick


Strips an image of all profiles and comments

Gmagick::spreadimage
Gmagick::swirlimage
Gmagick
PHP Manual

Gmagick::stripimage

(PECL gmagick >= Unknown)

Gmagick::stripimage — Strips an image of all profiles and comments

Açıklama

public Gmagick Gmagick::stripimage ( void )

Strips an image of all profiles and comments.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The Gmagick object on success

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::spreadimage
Gmagick::swirlimage
Gmagick


Swirls the pixels about the center of the image

Gmagick::stripimage
Gmagick::thumbnailimage
Gmagick
PHP Manual

Gmagick::swirlimage

(PECL gmagick >= Unknown)

Gmagick::swirlimage — Swirls the pixels about the center of the image

Açıklama

public Gmagick Gmagick::swirlimage ( float $degrees )

Swirls the pixels about the center of the image, where degrees indicates the sweep of the arc through which each pixel is moved. You get a more dramatic effect as the degrees move from 1 to 360.

Değiştirgeler

degrees

Define the tightness of the swirling effect.

Dönen Değerler

The Gmagick object on success

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::stripimage
Gmagick::thumbnailimage
Gmagick


Changes the size of an image

Gmagick::swirlimage
Gmagick::trimimage
Gmagick
PHP Manual

Gmagick::thumbnailimage

(PECL gmagick >= Unknown)

Gmagick::thumbnailimage — Changes the size of an image

Açıklama

public Gmagick Gmagick::thumbnailimage ( int $width , int $height [, bool $fit = false ] )

Changes the size of an image to the given dimensions and removes any associated profiles. The goal is to produce small low cost thumbnail images suited for display on the Web. If TRUE is given as a third parameter then columns and rows parameters are used as maximums for each side. Both sides will be scaled down until the match or are smaller than the parameter given for the side.

Değiştirgeler

width

Image width

height

Image height

Dönen Değerler

The Gmagick object on success.

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::swirlimage
Gmagick::trimimage
Gmagick


Remove edges from the image

Gmagick::thumbnailimage
Gmagick::write
Gmagick
PHP Manual

Gmagick::trimimage

(PECL gmagick >= Unknown)

Gmagick::trimimage — Remove edges from the image

Açıklama

public Gmagick Gmagick::trimimage ( float $fuzz )

Remove edges that are the background color from the image.

Değiştirgeler

fuzz

By default target must match a particular pixel color exactly. However, in many cases two colors may differ by a small amount. The fuzz member of image defines how much tolerance is acceptable to consider two colors as the same. This parameter represents the variation on the quantum range.

Dönen Değerler

The Gmagick object

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::thumbnailimage
Gmagick::write
Gmagick


Takma Adı: Gmagick::writeimage

Gmagick::trimimage
Gmagick::writeimage
Gmagick
PHP Manual

Gmagick::write

(PECL gmagick >= Unknown)

Gmagick::write — Takma Adı: Gmagick::writeimage()

Açıklama

This method is an alias of Gmagick::writeimage().

Gmagick::trimimage
Gmagick::writeimage
Gmagick


Writes an image to the specified filename

Gmagick::write
GmagickDraw
Gmagick
PHP Manual

Gmagick::writeimage

(PECL gmagick >= Unknown)

Gmagick::writeimage — Writes an image to the specified filename

Açıklama

public Gmagick Gmagick::writeimage ( string $filename [, bool $all_frames = false ] )

Writes an image to the specified filename. If the filename parameter is NULL, the image is written to the filename set by Gmagick::ReadImage() or Gmagick::SetImageFilename().

Değiştirgeler

filename

The image filename.

Dönen Değerler

The Gmagick object

Hatalar/İstisnalar

Hata durumunda bir GmagickException istisnası oluşur.

Gmagick::write
GmagickDraw
Gmagick


The GmagickDraw class

(PECL gmagick >= Unknown)

Giriş

Sınıf Sözdizimi

GmagickDraw {
/* Yöntemler */
public GmagickDraw annotate ( float $x , float $y , string $text )
public GmagickDraw arc ( float $sx , float $sy , float $ex , float $ey , float $sd , float $ed )
public GmagickDraw bezier ( array $coordinate_array )
public GmagickDraw ellipse ( float $ox , float $oy , float $rx , float $ry , float $start , float $end )
public GmagickPixel getfillcolor ( void )
public float getfillopacity ( void )
public mixed getfont ( void )
public float getfontsize ( void )
public int getfontstyle ( void )
public int getfontweight ( void )
public GmagickPixel getstrokecolor ( void )
public float getstrokeopacity ( void )
public float getstrokewidth ( void )
public int gettextdecoration ( void )
public mixed gettextencoding ( void )
public GmagickDraw line ( float $sx , float $sy , float $ex , float $ey )
public GmagickDraw point ( float $x , float $y )
public GmagickDraw polygon ( array $coordinates )
public GmagickDraw polyline ( array $coordinate_array )
public GmagickDraw rectangle ( float $x1 , float $y1 , float $x2 , float $y2 )
public GmagickDraw rotate ( float $degrees )
public GmagickDraw roundrectangle ( float $x1 , float $y1 , float $x2 , float $y2 , float $rx , float $ry )
public GmagickDraw scale ( float $x , float $y )
public GmagickDraw setfillcolor ( mixed $color )
public GmagickDraw setfillopacity ( float $fill_opacity )
public GmagickDraw setfont ( string $font )
public GmagickDraw setfontsize ( float $pointsize )
public GmagickDraw setfontstyle ( int $style )
public GmagickDraw setfontweight ( int $weight )
public GmagickDraw setstrokecolor ( mixed $color )
public GmagickDraw setstrokeopacity ( float $stroke_opacity )
public GmagickDraw setstrokewidth ( float $width )
public GmagickDraw settextdecoration ( int $decoration )
public GmagickDraw settextencoding ( string $encoding )
}

İçindekiler

  • GmagickDraw::annotate — Draws text on the image
  • GmagickDraw::arc — Draws an arc
  • GmagickDraw::bezier — Draws a bezier curve
  • GmagickDraw::ellipse — Draws an ellipse on the image
  • GmagickDraw::getfillcolor — Returns the fill color
  • GmagickDraw::getfillopacity — Returns the opacity used when drawing
  • GmagickDraw::getfont — Returns the font
  • GmagickDraw::getfontsize — Returns the font pointsize
  • GmagickDraw::getfontstyle — Returns the font style
  • GmagickDraw::getfontweight — Returns the font weight
  • GmagickDraw::getstrokecolor — Returns the color used for stroking object outlines
  • GmagickDraw::getstrokeopacity — Returns the opacity of stroked object outlines
  • GmagickDraw::getstrokewidth — Returns the width of the stroke used to draw object outlines
  • GmagickDraw::gettextdecoration — Returns the text decoration
  • GmagickDraw::gettextencoding — Returns the code set used for text annotations
  • GmagickDraw::line — The line purpose
  • GmagickDraw::point — Draws a point
  • GmagickDraw::polygon — Draws a polygon
  • GmagickDraw::polyline — Draws a polyline
  • GmagickDraw::rectangle — Draws a rectangle
  • GmagickDraw::rotate — Applies the specified rotation to the current coordinate space
  • GmagickDraw::roundrectangle — Draws a rounded rectangle
  • GmagickDraw::scale — Adjusts the scaling factor
  • GmagickDraw::setfillcolor — Sets the fill color to be used for drawing filled objects.
  • GmagickDraw::setfillopacity — The setfillopacity purpose
  • GmagickDraw::setfont — Sets the fully-specified font to use when annotating with text.
  • GmagickDraw::setfontsize — Sets the font pointsize to use when annotating with text.
  • GmagickDraw::setfontstyle — Sets the font style to use when annotating with text
  • GmagickDraw::setfontweight — Sets the font weight
  • GmagickDraw::setstrokecolor — Sets the color used for stroking object outlines.
  • GmagickDraw::setstrokeopacity — Specifies the opacity of stroked object outlines.
  • GmagickDraw::setstrokewidth — Sets the width of the stroke used to draw object outlines.
  • GmagickDraw::settextdecoration — Specifies a decoration
  • GmagickDraw::settextencoding — Specifies the text code set
Gmagick::writeimage
GmagickDraw::annotate
Gmagick


Draws text on the image

GmagickDraw
GmagickDraw::arc
GmagickDraw
PHP Manual

GmagickDraw::annotate

(PECL gmagick >= Unknown)

GmagickDraw::annotate — Draws text on the image

Açıklama

public GmagickDraw GmagickDraw::annotate ( float $x , float $y , string $text )

Draws text on the image.

Değiştirgeler

x

x ordinate to left of text

y

y ordinate to text baseline

text

text to draw

Dönen Değerler

The GmagickDraw object on success.

GmagickDraw
GmagickDraw::arc
GmagickDraw


Draws an arc

GmagickDraw::annotate
GmagickDraw::bezier
GmagickDraw
PHP Manual

GmagickDraw::arc

(PECL gmagick >= Unknown)

GmagickDraw::arc — Draws an arc

Açıklama

public GmagickDraw GmagickDraw::arc ( float $sx , float $sy , float $ex , float $ey , float $sd , float $ed )

Draws an arc falling within a specified bounding rectangle on the image.

Değiştirgeler

sx

starting x ordinate of bounding rectangle

sy

starting y ordinate of bounding rectangle

ex

ending x ordinate of bounding rectangle

ey

ending y ordinate of bounding rectangle

sd

starting degrees of rotation

ed

ending degrees of rotation

Dönen Değerler

The GmagickDraw object on success.

GmagickDraw::annotate
GmagickDraw::bezier
GmagickDraw


Draws a bezier curve

GmagickDraw::arc
GmagickDraw::ellipse
GmagickDraw
PHP Manual

GmagickDraw::bezier

(PECL gmagick >= Unknown)

GmagickDraw::bezier — Draws a bezier curve

Açıklama

public GmagickDraw GmagickDraw::bezier ( array $coordinate_array )

Draws a bezier curve through a set of points on the image.

Değiştirgeler

coordinate_array

Coordinates array

Dönen Değerler

The GmagickDraw object on success

GmagickDraw::arc
GmagickDraw::ellipse
GmagickDraw


Draws an ellipse on the image

GmagickDraw::bezier
GmagickDraw::getfillcolor
GmagickDraw
PHP Manual

GmagickDraw::ellipse

(PECL gmagick >= Unknown)

GmagickDraw::ellipse — Draws an ellipse on the image

Açıklama

public GmagickDraw GmagickDraw::ellipse ( float $ox , float $oy , float $rx , float $ry , float $start , float $end )

Draws an ellipse on the image.

Değiştirgeler

ox

origin x ordinate

oy

origin y ordinate

rx

radius in x

ry

radius in y

start

starting rotation in degrees

end

ending rotation in degrees

Dönen Değerler

The GmagickDraw object on success

GmagickDraw::bezier
GmagickDraw::getfillcolor
GmagickDraw


Returns the fill color

GmagickDraw::ellipse
GmagickDraw::getfillopacity
GmagickDraw
PHP Manual

GmagickDraw::getfillcolor

(PECL gmagick >= Unknown)

GmagickDraw::getfillcolor — Returns the fill color

Açıklama

public GmagickPixel GmagickDraw::getfillcolor ( void )

Returns the fill color used for drawing filled objects.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The GmagickPixel fill color used for drawing filled objects.

GmagickDraw::ellipse
GmagickDraw::getfillopacity
GmagickDraw


Returns the opacity used when drawing

GmagickDraw::getfillcolor
GmagickDraw::getfont
GmagickDraw
PHP Manual

GmagickDraw::getfillopacity

(PECL gmagick >= Unknown)

GmagickDraw::getfillopacity — Returns the opacity used when drawing

Açıklama

public float GmagickDraw::getfillopacity ( void )

Returns the opacity used when drawing

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the opacity used when drawing using the fill color or fill texture. Fully opaque is 1.0.

GmagickDraw::getfillcolor
GmagickDraw::getfont
GmagickDraw


Returns the font

GmagickDraw::getfillopacity
GmagickDraw::getfontsize
GmagickDraw
PHP Manual

GmagickDraw::getfont

(PECL gmagick >= Unknown)

GmagickDraw::getfont — Returns the font

Açıklama

public mixed GmagickDraw::getfont ( void )

Returns a string specifying the font used when annotating with text.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a string on success and FALSE if no font is set.

GmagickDraw::getfillopacity
GmagickDraw::getfontsize
GmagickDraw


Returns the font pointsize

GmagickDraw::getfont
GmagickDraw::getfontstyle
GmagickDraw
PHP Manual

GmagickDraw::getfontsize

(PECL gmagick >= Unknown)

GmagickDraw::getfontsize — Returns the font pointsize

Açıklama

public float GmagickDraw::getfontsize ( void )

Returns the font pointsize used when annotating with text.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the font size associated with the current GmagickDraw object.

GmagickDraw::getfont
GmagickDraw::getfontstyle
GmagickDraw


Returns the font style

GmagickDraw::getfontsize
GmagickDraw::getfontweight
GmagickDraw
PHP Manual

GmagickDraw::getfontstyle

(PECL gmagick >= Unknown)

GmagickDraw::getfontstyle — Returns the font style

Açıklama

public int GmagickDraw::getfontstyle ( void )

Returns the font style used when annotating with text.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the font style constant (STYLE_) associated with the GmagickDraw object or 0 if no style is set.

GmagickDraw::getfontsize
GmagickDraw::getfontweight
GmagickDraw


Returns the font weight

GmagickDraw::getfontstyle
GmagickDraw::getstrokecolor
GmagickDraw
PHP Manual

GmagickDraw::getfontweight

(PECL gmagick >= Unknown)

GmagickDraw::getfontweight — Returns the font weight

Açıklama

public int GmagickDraw::getfontweight ( void )

Returns the font weight used when annotating with text.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an int on success and 0 if no weight is set.

GmagickDraw::getfontstyle
GmagickDraw::getstrokecolor
GmagickDraw


Returns the color used for stroking object outlines

GmagickDraw::getfontweight
GmagickDraw::getstrokeopacity
GmagickDraw
PHP Manual

GmagickDraw::getstrokecolor

(PECL gmagick >= Unknown)

GmagickDraw::getstrokecolor — Returns the color used for stroking object outlines

Açıklama

public GmagickPixel GmagickDraw::getstrokecolor ( void )

Returns the color used for stroking object outlines.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an GmagickPixel object which describes the color.

GmagickDraw::getfontweight
GmagickDraw::getstrokeopacity
GmagickDraw


Returns the opacity of stroked object outlines

GmagickDraw::getstrokecolor
GmagickDraw::getstrokewidth
GmagickDraw
PHP Manual

GmagickDraw::getstrokeopacity

(PECL gmagick >= Unknown)

GmagickDraw::getstrokeopacity — Returns the opacity of stroked object outlines

Açıklama

public float GmagickDraw::getstrokeopacity ( void )

Returns the opacity of stroked object outlines.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a double describing the opacity.

GmagickDraw::getstrokecolor
GmagickDraw::getstrokewidth
GmagickDraw


Returns the width of the stroke used to draw object outlines

GmagickDraw::getstrokeopacity
GmagickDraw::gettextdecoration
GmagickDraw
PHP Manual

GmagickDraw::getstrokewidth

(PECL gmagick >= Unknown)

GmagickDraw::getstrokewidth — Returns the width of the stroke used to draw object outlines

Açıklama

public float GmagickDraw::getstrokewidth ( void )

Returns the width of the stroke used to draw object outlines.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a double describing the stroke width.

GmagickDraw::getstrokeopacity
GmagickDraw::gettextdecoration
GmagickDraw


Returns the text decoration

GmagickDraw::getstrokewidth
GmagickDraw::gettextencoding
GmagickDraw
PHP Manual

GmagickDraw::gettextdecoration

(PECL gmagick >= Unknown)

GmagickDraw::gettextdecoration — Returns the text decoration

Açıklama

public int GmagickDraw::gettextdecoration ( void )

Returns the decoration applied when annotating with text.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns one of the DECORATION_ constants and 0 if no decoration is set.

GmagickDraw::getstrokewidth
GmagickDraw::gettextencoding
GmagickDraw


Returns the code set used for text annotations

GmagickDraw::gettextdecoration
GmagickDraw::line
GmagickDraw
PHP Manual

GmagickDraw::gettextencoding

(PECL gmagick >= Unknown)

GmagickDraw::gettextencoding — Returns the code set used for text annotations

Açıklama

public mixed GmagickDraw::gettextencoding ( void )

Returns a string which specifies the code set used for text annotations.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a string specifying the code set or FALSE if text encoding is not set.

GmagickDraw::gettextdecoration
GmagickDraw::line
GmagickDraw


The line purpose

GmagickDraw::gettextencoding
GmagickDraw::point
GmagickDraw
PHP Manual

GmagickDraw::line

(PECL gmagick >= Unknown)

GmagickDraw::line — The line purpose

Açıklama

public GmagickDraw GmagickDraw::line ( float $sx , float $sy , float $ex , float $ey )

Draws a line on the image using the current stroke color, stroke opacity, and stroke width.

Değiştirgeler

sx

starting x ordinate

sy

starting y ordinate

ex

ending x ordinate

ey

ending y ordinate

Dönen Değerler

The GmagickDraw object on success

GmagickDraw::gettextencoding
GmagickDraw::point
GmagickDraw


Draws a point

GmagickDraw::line
GmagickDraw::polygon
GmagickDraw
PHP Manual

GmagickDraw::point

(PECL gmagick >= Unknown)

GmagickDraw::point — Draws a point

Açıklama

public GmagickDraw GmagickDraw::point ( float $x , float $y )

Draws a point using the current stroke color and stroke thickness at the specified coordinates.

Değiştirgeler

x

target x coordinate

y

target y coordinate

Dönen Değerler

The GmagickDraw object on success

GmagickDraw::line
GmagickDraw::polygon
GmagickDraw


Draws a polygon

GmagickDraw::point
GmagickDraw::polyline
GmagickDraw
PHP Manual

GmagickDraw::polygon

(PECL gmagick >= Unknown)

GmagickDraw::polygon — Draws a polygon

Açıklama

public GmagickDraw GmagickDraw::polygon ( array $coordinates )

Draws a polygon using the current stroke, stroke width, and fill color or texture, using the specified array of coordinates.

Değiştirgeler

coordinates

coordinate array

Dönen Değerler

The GmagickDraw object on success

GmagickDraw::point
GmagickDraw::polyline
GmagickDraw


Draws a polyline

GmagickDraw::polygon
GmagickDraw::rectangle
GmagickDraw
PHP Manual

GmagickDraw::polyline

(PECL gmagick >= Unknown)

GmagickDraw::polyline — Draws a polyline

Açıklama

public GmagickDraw GmagickDraw::polyline ( array $coordinate_array )

Draws a polyline using the current stroke, stroke width, and fill color or texture, using the specified array of coordinates.

Değiştirgeler

coordinate_array

The array of coordinates

Dönen Değerler

The GmagickDraw object on success

GmagickDraw::polygon
GmagickDraw::rectangle
GmagickDraw


Draws a rectangle

GmagickDraw::polyline
GmagickDraw::rotate
GmagickDraw
PHP Manual

GmagickDraw::rectangle

(PECL gmagick >= Unknown)

GmagickDraw::rectangle — Draws a rectangle

Açıklama

public GmagickDraw GmagickDraw::rectangle ( float $x1 , float $y1 , float $x2 , float $y2 )

Draws a rectangle given two coordinates and using the current stroke, stroke width, and fill settings.

Değiştirgeler

x1

x ordinate of first coordinate

y1

y ordinate of first coordinate

x2

x ordinate of second coordinate

y2

y ordinate of second coordinate

Dönen Değerler

The GmagickDraw object on success

GmagickDraw::polyline
GmagickDraw::rotate
GmagickDraw


Applies the specified rotation to the current coordinate space

GmagickDraw::rectangle
GmagickDraw::roundrectangle
GmagickDraw
PHP Manual

GmagickDraw::rotate

(PECL gmagick >= Unknown)

GmagickDraw::rotate — Applies the specified rotation to the current coordinate space

Açıklama

public GmagickDraw GmagickDraw::rotate ( float $degrees )

Applies the specified rotation to the current coordinate space.

Değiştirgeler

degrees

degrees of rotation

Dönen Değerler

The GmagickDraw object on success

GmagickDraw::rectangle
GmagickDraw::roundrectangle
GmagickDraw


Draws a rounded rectangle

GmagickDraw::rotate
GmagickDraw::scale
GmagickDraw
PHP Manual

GmagickDraw::roundrectangle

(PECL gmagick >= Unknown)

GmagickDraw::roundrectangle — Draws a rounded rectangle

Açıklama

public GmagickDraw GmagickDraw::roundrectangle ( float $x1 , float $y1 , float $x2 , float $y2 , float $rx , float $ry )

Draws a rounded rectangle given two coordinates, x and y corner radiuses and using the current stroke, stroke width, and fill settings.

Değiştirgeler

x1

x ordinate of first coordinate

y1

y ordinate of first coordinate

x2

x ordinate of second coordinate

y2

y ordinate of second coordinate

rx

radius of corner in horizontal direction

ry

radius of corner in vertical direction

Dönen Değerler

The GmagickDraw object on success

GmagickDraw::rotate
GmagickDraw::scale
GmagickDraw


Adjusts the scaling factor

GmagickDraw::roundrectangle
GmagickDraw::setfillcolor
GmagickDraw
PHP Manual

GmagickDraw::scale

(PECL gmagick >= Unknown)

GmagickDraw::scale — Adjusts the scaling factor

Açıklama

public GmagickDraw GmagickDraw::scale ( float $x , float $y )

Adjusts the scaling factor to apply in the horizontal and vertical directions to the current coordinate space.

Değiştirgeler

x

horizontal scale factor

y

vertical scale factor

Dönen Değerler

The GmagickDraw object on success

GmagickDraw::roundrectangle
GmagickDraw::setfillcolor
GmagickDraw


Sets the fill color to be used for drawing filled objects.

GmagickDraw::scale
GmagickDraw::setfillopacity
GmagickDraw
PHP Manual

GmagickDraw::setfillcolor

(PECL gmagick >= Unknown)

GmagickDraw::setfillcolor — Sets the fill color to be used for drawing filled objects.

Açıklama

public GmagickDraw GmagickDraw::setfillcolor ( mixed $color )

Sets the fill color to be used for drawing filled objects.

Değiştirgeler

color

GmagickPixel or string indicating color to use for filling.

Dönen Değerler

The GmagickDraw object on success.

GmagickDraw::scale
GmagickDraw::setfillopacity
GmagickDraw


The setfillopacity purpose

GmagickDraw::setfillcolor
GmagickDraw::setfont
GmagickDraw
PHP Manual

GmagickDraw::setfillopacity

(PECL gmagick >= Unknown)

GmagickDraw::setfillopacity — The setfillopacity purpose

Açıklama

public GmagickDraw GmagickDraw::setfillopacity ( float $fill_opacity )

Sets the opacity to use when drawing using the fill color or fill texture. Setting it to 1.0 will make fill full opaque.

Değiştirgeler

fill_opacity

Fill opacity

Dönen Değerler

The GmagickDraw object on success

GmagickDraw::setfillcolor
GmagickDraw::setfont
GmagickDraw


Sets the fully-specified font to use when annotating with text.

GmagickDraw::setfillopacity
GmagickDraw::setfontsize
GmagickDraw
PHP Manual

GmagickDraw::setfont

(PECL gmagick >= Unknown)

GmagickDraw::setfont — Sets the fully-specified font to use when annotating with text.

Açıklama

public GmagickDraw GmagickDraw::setfont ( string $font )

Sets the fully-specified font to use when annotating with text

Değiştirgeler

font

font name

Dönen Değerler

The GmagickDraw object on success

GmagickDraw::setfillopacity
GmagickDraw::setfontsize
GmagickDraw


Sets the font pointsize to use when annotating with text.

GmagickDraw::setfont
GmagickDraw::setfontstyle
GmagickDraw
PHP Manual

GmagickDraw::setfontsize

(PECL gmagick >= Unknown)

GmagickDraw::setfontsize — Sets the font pointsize to use when annotating with text.

Açıklama

public GmagickDraw GmagickDraw::setfontsize ( float $pointsize )

Sets the font pointsize to use when annotating with text.

Değiştirgeler

pointsize

Text pointsize

Dönen Değerler

The GmagickDraw object on success

GmagickDraw::setfont
GmagickDraw::setfontstyle
GmagickDraw


Sets the font style to use when annotating with text

GmagickDraw::setfontsize
GmagickDraw::setfontweight
GmagickDraw
PHP Manual

GmagickDraw::setfontstyle

(PECL gmagick >= Unknown)

GmagickDraw::setfontstyle — Sets the font style to use when annotating with text

Açıklama

public GmagickDraw GmagickDraw::setfontstyle ( int $style )

Sets the font style to use when annotating with text. The AnyStyle enumeration acts as a wild-card "don't care" option.

Değiştirgeler

style

Font style (NormalStyle, ItalicStyle, ObliqueStyle, AnyStyle)

Dönen Değerler

The GmagickDraw object on success

GmagickDraw::setfontsize
GmagickDraw::setfontweight
GmagickDraw


Sets the font weight

GmagickDraw::setfontstyle
GmagickDraw::setstrokecolor
GmagickDraw
PHP Manual

GmagickDraw::setfontweight

(PECL gmagick >= Unknown)

GmagickDraw::setfontweight — Sets the font weight

Açıklama

public GmagickDraw GmagickDraw::setfontweight ( int $weight )

Sets the font weight to use when annotating with text.

Değiştirgeler

weight

Font weight (valid range 100-900)

Dönen Değerler

The GmagickDraw object on success

GmagickDraw::setfontstyle
GmagickDraw::setstrokecolor
GmagickDraw


Sets the color used for stroking object outlines.

GmagickDraw::setfontweight
GmagickDraw::setstrokeopacity
GmagickDraw
PHP Manual

GmagickDraw::setstrokecolor

(PECL gmagick >= Unknown)

GmagickDraw::setstrokecolor — Sets the color used for stroking object outlines.

Açıklama

public GmagickDraw GmagickDraw::setstrokecolor ( mixed $color )

Sets the color used for stroking object outlines.

Değiştirgeler

color

GmagickPixel or string representing the color for the stroke.

Dönen Değerler

The GmagickDraw object on success.

GmagickDraw::setfontweight
GmagickDraw::setstrokeopacity
GmagickDraw


Specifies the opacity of stroked object outlines.

GmagickDraw::setstrokecolor
GmagickDraw::setstrokewidth
GmagickDraw
PHP Manual

GmagickDraw::setstrokeopacity

(PECL gmagick >= Unknown)

GmagickDraw::setstrokeopacity — Specifies the opacity of stroked object outlines.

Açıklama

public GmagickDraw GmagickDraw::setstrokeopacity ( float $stroke_opacity )

Specifies the opacity of stroked object outlines.

Değiştirgeler

stroke_opacity

Stroke opacity. The value 1.0 is opaque.

Dönen Değerler

The GmagickDraw object on success

GmagickDraw::setstrokecolor
GmagickDraw::setstrokewidth
GmagickDraw


Sets the width of the stroke used to draw object outlines.

GmagickDraw::setstrokeopacity
GmagickDraw::settextdecoration
GmagickDraw
PHP Manual

GmagickDraw::setstrokewidth

(PECL gmagick >= Unknown)

GmagickDraw::setstrokewidth — Sets the width of the stroke used to draw object outlines.

Açıklama

public GmagickDraw GmagickDraw::setstrokewidth ( float $width )

Sets the width of the stroke used to draw object outlines

Değiştirgeler

width

Stroke width

Dönen Değerler

The GmagickDraw object on success

GmagickDraw::setstrokeopacity
GmagickDraw::settextdecoration
GmagickDraw


Specifies a decoration

GmagickDraw::setstrokewidth
GmagickDraw::settextencoding
GmagickDraw
PHP Manual

GmagickDraw::settextdecoration

(PECL gmagick >= Unknown)

GmagickDraw::settextdecoration — Specifies a decoration

Açıklama

public GmagickDraw GmagickDraw::settextdecoration ( int $decoration )

Specifies a decoration to be applied when annotating with text.

Değiştirgeler

int

Text decoration. One of NoDecoration, UnderlineDecoration, OverlineDecoration, or LineThroughDecoration

Dönen Değerler

The GmagickDraw object on success

GmagickDraw::setstrokewidth
GmagickDraw::settextencoding
GmagickDraw


Specifies the text code set

GmagickDraw::settextdecoration
GmagickPixel
GmagickDraw
PHP Manual

GmagickDraw::settextencoding

(PECL gmagick >= Unknown)

GmagickDraw::settextencoding — Specifies the text code set

Açıklama

public GmagickDraw GmagickDraw::settextencoding ( string $encoding )

Specifies the code set to use for text annotations. The only character encoding which may be specified at this time is "UTF-8" for representing Unicode as a sequence of bytes. Specify an empty string to set text encoding to the system's default. Successful text annotation using Unicode may require fonts designed to support Unicode.

Değiştirgeler

encoding

Character string specifying text encoding

Dönen Değerler

The GmagickDraw object on success

GmagickDraw::settextdecoration
GmagickPixel
GmagickDraw


The GmagickPixel class

(PECL gmagick >= Unknown)

Giriş

Sınıf Sözdizimi

GmagickPixel {
/* Yöntemler */
public __construct ([ string $color ] )
public mixed getcolor ([ bool $as_array = false [, bool $normalize_array = false ]] )
public int getcolorcount ( void )
public float getcolorvalue ( int $color )
public GmagickPixel setcolor ( string $color )
public GmagickPixel setcolorvalue ( int $color , float $value )
}

İçindekiler

  • GmagickPixel::__construct — The GmagickPixel constructor
  • GmagickPixel::getcolor — Returns the color
  • GmagickPixel::getcolorcount — Returns the color count associated with this color
  • GmagickPixel::getcolorvalue — Gets the normalized value of the provided color channel
  • GmagickPixel::setcolor — Sets the color
  • GmagickPixel::setcolorvalue — Sets the normalized value of one of the channels
GmagickDraw::settextencoding
GmagickPixel::__construct
Gmagick


The GmagickPixel constructor

GmagickPixel
GmagickPixel::getcolor
GmagickPixel
PHP Manual

GmagickPixel::__construct

(PECL gmagick >= Unknown)

GmagickPixel::__construct — The GmagickPixel constructor

Açıklama

public GmagickPixel::__construct ([ string $color ] )

Constructs an GmagickPixel object. If a color is specified, the object is constructed and then initialised with that color before being returned.

Değiştirgeler

color

The optional color string to use as the initial value of this object.

Dönen Değerler

The GmagickPixel object on success.

GmagickPixel
GmagickPixel::getcolor
GmagickPixel


Returns the color

GmagickPixel::__construct
GmagickPixel::getcolorcount
GmagickPixel
PHP Manual

GmagickPixel::getcolor

(PECL gmagick >= Unknown)

GmagickPixel::getcolor — Returns the color

Açıklama

public mixed GmagickPixel::getcolor ([ bool $as_array = false [, bool $normalize_array = false ]] )

Returns the color described by the GmagickPixel object, as a string or an array. If the color has an opacity channel set, this is provided as a fourth value in the list.

Değiştirgeler

as_array

TRUE to indicate return of array instead of string.

normalize_array

TRUE to normalize the color values.

Dönen Değerler

A string or an array of channel values, each normalized if TRUE is given as normalize_array. Throws GmagickPixelException on error.

GmagickPixel::__construct
GmagickPixel::getcolorcount
GmagickPixel


Returns the color count associated with this color

GmagickPixel::getcolor
GmagickPixel::getcolorvalue
GmagickPixel
PHP Manual

GmagickPixel::getcolorcount

(PECL gmagick >= Unknown)

GmagickPixel::getcolorcount — Returns the color count associated with this color

Açıklama

public int GmagickPixel::getcolorcount ( void )

Returns the color count associated with this color

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the color count as an integer on success, throws GmagickPixelException on failure.

GmagickPixel::getcolor
GmagickPixel::getcolorvalue
GmagickPixel


Gets the normalized value of the provided color channel

GmagickPixel::getcolorcount
GmagickPixel::setcolor
GmagickPixel
PHP Manual

GmagickPixel::getcolorvalue

(PECL gmagick >= Unknown)

GmagickPixel::getcolorvalue — Gets the normalized value of the provided color channel

Açıklama

public float GmagickPixel::getcolorvalue ( int $color )

Retrieves the value of the color channel specified, as a floating-point number between 0 and 1.

Değiştirgeler

color

The channel to check, specified as one of the Gmagick channel constants.

Dönen Değerler

The value of the channel, as a normalized floating-point number, throwing GmagickPixelException on error.

GmagickPixel::getcolorcount
GmagickPixel::setcolor
GmagickPixel


Sets the color

GmagickPixel::getcolorvalue
GmagickPixel::setcolorvalue
GmagickPixel
PHP Manual

GmagickPixel::setcolor

(PECL gmagick >= Unknown)

GmagickPixel::setcolor — Sets the color

Açıklama

public GmagickPixel GmagickPixel::setcolor ( string $color )

Sets the color described by the GmagickPixel object, with a string (e.g. "blue", "#0000ff", "rgb(0,0,255)", "cmyk(100,100,100,10)", etc.).

Değiştirgeler

color

The color definition to use in order to initialise the GmagickPixel object.

Dönen Değerler

The GmagickPixel object on success.

GmagickPixel::getcolorvalue
GmagickPixel::setcolorvalue
GmagickPixel


Sets the normalized value of one of the channels

GmagickPixel::setcolor
ImageMagick
GmagickPixel
PHP Manual

GmagickPixel::setcolorvalue

(PECL gmagick >= Unknown)

GmagickPixel::setcolorvalue — Sets the normalized value of one of the channels

Açıklama

public GmagickPixel GmagickPixel::setcolorvalue ( int $color , float $value )

Sets the value of the specified channel of this object to the provided value, which should be between 0 and 1. This function can be used to provide an opacity channel to a GmagickPixel object.

Değiştirgeler

color

One of the Gmagick channel color constants.

value

The value to set this channel to, ranging from 0 to 1.

Dönen Değerler

The GmagickPixel object on success.

GmagickPixel::setcolor
ImageMagick
GmagickPixel


Resim İşleme (ImageMagick)

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
    • Örnekler
  • Imagick sınıfı
    • Imagick::adaptiveBlurImage — Resmi uyarlamalı olarak bulanıklaştırır
    • Imagick::adaptiveResizeImage — Nirengi noktasına göre uyarlamalı olarak resmi boyutlandırır
    • Imagick::adaptiveSharpenImage — Uyarlamalı olarak resmi netleştirir
    • Imagick::adaptiveThresholdImage — Bir yoğunluk aralığına göre her piksel için bir eşik seçer
    • Imagick::addImage — Imagick resim listesine yeni bir resim ekler
    • Imagick::addNoiseImage — Resme rasgele gürültü ekler
    • Imagick::affineTransformImage — Resmi dönüştürür
    • Imagick::animateImages — Bir resmi veya resimleri canlandırır
    • Imagick::annotateImage — Resme bir metin çizer
    • Imagick::appendImages — Bir resim kümesini ekler
    • Imagick::autoLevelImage — Description
    • Imagick::averageImages — Bir resim kümesinin ortalamasını alır
    • Imagick::blackThresholdImage — Eşiğin altında kalan tüm renkleri siyaha çevirir
    • Imagick::blueShiftImage — Description
    • Imagick::blurImage — Resme bir bulanıklık süzgeci ekler
    • Imagick::borderImage — Resme bir çerçeve çizer
    • Imagick::brightnessContrastImage — Description
    • Imagick::charcoalImage — Kara kalem çizimi taklit eder
    • Imagick::chopImage — Bir resmin bir bölgesini silerek kırpar
    • Imagick::clampImage — Description
    • Imagick::clear — Imagick nesnesi ile ilgili tüm özkaynakları temizler
    • Imagick::clipImage — 8BIM profilindeki ilk yol boyunca resmi kırpar
    • Imagick::clipImagePath — Description
    • Imagick::clipPathImage — 8BIM profili boyunca isimli yolları kırpar
    • Imagick::clone — Imagick nesnesinin tam bir kopyasını yapar
    • Imagick::clutImage — Resmin renklerini değiştirir
    • Imagick::coalesceImages — Bir resim kümesini tek bir resim olarak birleştirir
    • Imagick::colorFloodfillImage — Hedefle eşleşen her pikselin rengini değiştirir
    • Imagick::colorizeImage — Resmin her pikseline dolgu rengini karıştırır
    • Imagick::colorMatrixImage — Description
    • Imagick::combineImages — Bir veya daha fazla resmi tek bir resim halinde birleştirir
    • Imagick::commentImage — Resme bir açıklama ekler
    • Imagick::compareImageChannels — Bir veya daha fazla resmin farkını döndürür
    • Imagick::compareImageLayers — Resim katmanlarını karşılaştırıp en iyilenmiş resmi döndürür
    • Imagick::compareImages — Resmi yeniden oluşturulan resimle karşılaştırır
    • Imagick::compositeImage — Bir resmi diğeriyle birleştirir
    • Imagick::__construct — Imagick kurucusu
    • Imagick::contrastImage — Resmin zıtlığını değiştirir
    • Imagick::contrastStretchImage — Renkli bir resmin zıtlığını ayarlar
    • Imagick::convolveImage — Resme bir evrişim çekirdeği uygular
    • Imagick::count — Description
    • Imagick::cropImage — Resmin bir bölgesini çıkarır
    • Imagick::cropThumbnailImage — Resmin kırpık bir örneğini oluşturur
    • Imagick::current — Geçerli Imagick nesnesini döndürür
    • Imagick::cycleColormapImage — Bir resmin renk eşleminin bir kısmını değiştirir
    • Imagick::decipherImage — Şifreli bir resmin şifresini çözer
    • Imagick::deconstructImages — Resimler arasındaki farklı piksellerin kapladığı en büyük alanı döndürür
    • Imagick::deleteImageArtifact — Delete image artifact
    • Imagick::deleteImageProperty — Description
    • Imagick::deskewImage — Removes skew from the image
    • Imagick::despeckleImage — Resmin benekli görünümünü düzeltir
    • Imagick::destroy — Imagick nesnesini siler
    • Imagick::displayImage — Bir resmi gösterir
    • Imagick::displayImages — Bir resim dizisini gösterir
    • Imagick::distortImage — Çeşitli yöntemlerle resmi bozunuma uğratır
    • Imagick::drawImage — Belirtilen ImagickDraw nesnesini resme uygular
    • Imagick::edgeImage — Resmin kenarlarını evriştirir
    • Imagick::embossImage — Üç boyutluluk etkisi vermek için resmi gri tonlamaya dönüştürür
    • Imagick::encipherImage — Bir resmi şifreler
    • Imagick::enhanceImage — Resmin görüntü kalitesini arttırır
    • Imagick::equalizeImage — Resmin renk dağılımını dengeler
    • Imagick::evaluateImage — Resme bir ifade uygular
    • Imagick::exportImagePixels — Exports raw image pixels
    • Imagick::extentImage — Resim boyutlarını belirler
    • Imagick::filter — Description
    • Imagick::flattenImages — Bir resim dizisini tek bir resim halinde üstüste bindirir
    • Imagick::flipImage — Resmin düşeydeki yansımasını oluşturur
    • Imagick::floodFillPaintImage — Hedefle eşleşen piksellerin renklerini değiştirir
    • Imagick::flopImage — Resmin yataydaki yansımasını oluşturur
    • Imagick::forwardFourierTransformImage — Description
    • Imagick::frameImage — Üç boyutluluğu taklit ederek bir çerçeve ekler
    • Imagick::functionImage — Applies a function on the image
    • Imagick::fxImage — Bir ifadeyi resimdeki her piksele uygular
    • Imagick::gammaImage — Resmin gammasını düzeltir
    • Imagick::gaussianBlurImage — Resmi bulanıklaştırır
    • Imagick::getColorspace — Gets the colorspace
    • Imagick::getCompression — Nesnenin sıkıştırma türünü döndürür
    • Imagick::getCompressionQuality — Nesnenin sıkıştırma seviyesini döndürür
    • Imagick::getCopyright — ImageMagick telif hakkı bilgisini döndürür
    • Imagick::getFilename — Resim dizisi ile ilişkili dosya ismini döndürür
    • Imagick::getFont — Yazıtipini döndürür
    • Imagick::getFormat — Imagick nesnesinin biçemini döndürür
    • Imagick::getGravity — Gets the gravity
    • Imagick::getHomeURL — ImageMagick sitesinin adresini döndürür
    • Imagick::getImage — Yeni bir Imagick nesnesi döndürür
    • Imagick::getImageAlphaChannel — Gets the image alpha channel
    • Imagick::getImageArtifact — Get image artifact
    • Imagick::getImageAttribute — Description
    • Imagick::getImageBackgroundColor — Resmin artalan rengini döndürür
    • Imagick::getImageBlob — Resim dizisini ber ikil dizge olarak döndürür
    • Imagick::getImageBluePrimary — Resmin renk bileşenlerinden birincil mavi noktayı döndürür
    • Imagick::getImageBorderColor — Resmin çerçeve rengini döndürür
    • Imagick::getImageChannelDepth — Belirtilen kanalın derinliğini döndürür
    • Imagick::getImageChannelDistortion — Resmin kanallarını yeniden oluşturulan bir resimle karşılaştırır
    • Imagick::getImageChannelDistortions — Gets channel distortions
    • Imagick::getImageChannelExtrema — Belirtilen kanalların uç değerlerini döndürür
    • Imagick::getImageChannelKurtosis — The getImageChannelKurtosis purpose
    • Imagick::getImageChannelMean — Kanal ortalama ve standart sapmasını döndürür
    • Imagick::getImageChannelRange — Gets channel range
    • Imagick::getImageChannelStatistics — Resimdeki her kanalın istatistiklerini döndürür
    • Imagick::getImageClipMask — Resim kırpma maskesini döndürür
    • Imagick::getImageColormapColor — Renk eşlemi indisi belirtilen rengi döndürür
    • Imagick::getImageColors — Resimdeki eşsiz renklerin sayısını döndürür
    • Imagick::getImageColorspace — Resmin renk uzayını döndürür
    • Imagick::getImageCompose — Resimle ilgili birleştirme işlecini döndürür
    • Imagick::getImageCompression — Resmin sıkıştırma türünü döndürür
    • Imagick::getImageCompressionQuality — Resmin sıkıştırma seviyesini döndürür
    • Imagick::getImageDelay — Resim gecikmesini döndürür
    • Imagick::getImageDepth — Resim derinliğini döndürür
    • Imagick::getImageDispose — Resmin elden çıkarma yöntemini döndürür
    • Imagick::getImageDistortion — Resmi yeniden oluşturulmuş bir resimle karşılaştırır
    • Imagick::getImageExtrema — Resimle ilgili uç değerleri döndürür
    • Imagick::getImageFilename — Bir resim dizisindeki belli bir resmin dosya ismini döndürür
    • Imagick::getImageFormat — Bir resim dizisindeki belli bir resmin biçemini döndürür
    • Imagick::getImageGamma — Resmin gammasını döndürür
    • Imagick::getImageGeometry — Resmin genişliğini ve yüksekliğini bir ilişkisel dizi olarak döndürür
    • Imagick::getImageGravity — Gets the image gravity
    • Imagick::getImageGreenPrimary — Resmin renk bileşenlerinden birincil yeşil noktayı döndürür
    • Imagick::getImageHeight — Resmin yüksekliğini döndürür
    • Imagick::getImageHistogram — Resmin renk dağılımını döndürür
    • Imagick::getImageIndex — Geçerli etkin resmin indisini döndürür
    • Imagick::getImageInterlaceScheme — Resmin geçişim şemasını döndürür
    • Imagick::getImageInterpolateMethod — Aradeğerleme yöntemini döndürür
    • Imagick::getImageIterations — Resim yineleme sayısını döndürür
    • Imagick::getImageLength — Resim uzunluğunu döndürür
    • Imagick::getImageMagickLicense — ImageMagick lisans bilgisini içeren bir dizge döndürür
    • Imagick::getImageMatte — Resmin bir matlık kanalı varsa TRUE döndürür
    • Imagick::getImageMatteColor — Resmin matlık rengini döndürür
    • Imagick::getImageMimeType — Description
    • Imagick::getImageOrientation — Resim baskı yönünü döndürür
    • Imagick::getImagePage — Sayfa geometrisini döndürür
    • Imagick::getImagePixelColor — Belirtilen pikselin rengini döndürür
    • Imagick::getImageProfile — İsimli resim profilini döndürür
    • Imagick::getImageProfiles — Resim profillerini döndürür
    • Imagick::getImageProperties — Resim özelliklerini döndürür
    • Imagick::getImageProperty — İsimli resim özelliğini döndürür
    • Imagick::getImageRedPrimary — Resmin renk bileşenlerinden birincil kırmızı noktasını döndürür
    • Imagick::getImageRegion — Resmin bir bölgesini çıkarır
    • Imagick::getImageRenderingIntent — Resme komutların uygulanış tarzını döndürür
    • Imagick::getImageResolution — Resmin X ve Y çözünürlüklerini döndürür
    • Imagick::getImagesBlob — Tüm resim dizilerini bir ikil dizge olarak döndürür
    • Imagick::getImageScene — Resmin artalan dekorunu döndürür
    • Imagick::getImageSignature — Resmin SHA-256 ileti özetini üretir
    • Imagick::getImageSize — Resim uzunluğunu bayt cinsinden döndürür
    • Imagick::getImageTicksPerSecond — Resmin saniyedeki tik sayısını döndürür
    • Imagick::getImageTotalInkDensity — Resmin belli bir renginin toplam yoğunluğunu döndürür
    • Imagick::getImageType — Olası resim türünü döndürür
    • Imagick::getImageUnits — Resim çözünürlük birimlerini döndürür
    • Imagick::getImageVirtualPixelMethod — Sanal piksel yöntemini döndürür
    • Imagick::getImageWhitePoint — Resmin renk bileşenlerinden beyaz noktayı döndürür
    • Imagick::getImageWidth — Resim genişliğini döndürür
    • Imagick::getInterlaceScheme — Nesne geçişim şemasını döndürür
    • Imagick::getIteratorIndex — Geçerli etkin resmin indisini döndürür
    • Imagick::getNumberImages — Nesnedeki resim sayısını döndürür
    • Imagick::getOption — Belirtilen anahtarla ilgili değeri döndürür
    • Imagick::getPackageName — ImageMagick paket ismini döndürür
    • Imagick::getPage — Sayfa geometrisini döndürür
    • Imagick::getPixelIterator — Bir MagickPixelIterator nesnesi döndürür
    • Imagick::getPixelRegionIterator — Bir resim bölümü için bir ImagickPixelIterator nesnesi döndürür
    • Imagick::getPointSize — Punto değerini döndürür
    • Imagick::getQuantum — Description
    • Imagick::getQuantumDepth — Parçacık derinliğini döndürür
    • Imagick::getQuantumRange — Imagick parçacık aralığını döndürür
    • Imagick::getRegistry — Description
    • Imagick::getReleaseDate — ImageMagick dağıtım tarihini döndürür
    • Imagick::getResource — Belirtilen özkaynağın bellek kullanımını döndürür
    • Imagick::getResourceLimit — Belirtilen özkaynağın bellek kullanım sınırını döndürür
    • Imagick::getSamplingFactors — Yatay ve düşey örnekleme katsayısını döndürür
    • Imagick::getSize — Imagick nesnesi ile ilgili boyutları döndürür
    • Imagick::getSizeOffset — Boyut başlangıç noktasını döndürür
    • Imagick::getVersion — ImageMagick API sürümünü döndürür
    • Imagick::haldClutImage — Replaces colors in the image
    • Imagick::hasNextImage — Resmin sonrasında bir resim daha var mı diye bakar
    • Imagick::hasPreviousImage — Resmin öncesinde bir resim daha var mı diye bakar
    • Imagick::identifyFormat — Description
    • Imagick::identifyImage — Resmin özniteliklerini döndürerek resmi tanımlar
    • Imagick::implodeImage — Resmi kopyalamak suretiyle yeni bir resim oluşturur
    • Imagick::importImagePixels — Imports image pixels
    • Imagick::inverseFourierTransformImage — Description
    • Imagick::labelImage — Resme bir yafta ekler
    • Imagick::levelImage — Bir resmin seviyelerini ayarlar
    • Imagick::linearStretchImage — Resmin koyuluğunu doygunluk ile abartır
    • Imagick::liquidRescaleImage — Bir resmi veya resimleri canlandırır
    • Imagick::listRegistry — Description
    • Imagick::magnifyImage — Enboy oranını koruyarak resmi iki katına büyütür
    • Imagick::mapImage — Resmin renklerini belirtilen resimdeki en yakın renklerle değiştirir
    • Imagick::matteFloodfillImage — Bir rengin şeffaflık değerini değiştirir
    • Imagick::medianFilterImage — Resme bir sayısal süzgeç uygular
    • Imagick::mergeImageLayers — Resim katmanlarını katıştırır
    • Imagick::minifyImage — Enboy oranını koruyarak resmi yarı boyutuna indirir
    • Imagick::modulateImage — Resmin parlaklık, doygunluk ve renk sıcaklığını denetler
    • Imagick::montageImage — Birleşik bir resim oluşturur
    • Imagick::morphImages — Bir resim dizisini başkalaşıma uğratır
    • Imagick::morphology — Description
    • Imagick::mosaicImages — Resimlerden bir mozaik oluşturur
    • Imagick::motionBlurImage — Hareket bulanıklığını taklit eder
    • Imagick::negateImage — Resmin renklerini negatiflerine dönüştürür
    • Imagick::newImage — Yeni bir resim oluşturur
    • Imagick::newPseudoImage — Yeni bir resim oluşturur
    • Imagick::nextImage — Bir sonraki resme gider
    • Imagick::normalizeImage — Renkli bir resmin zıtlığını arttırır
    • Imagick::oilPaintImage — Yağlı boya resmi taklit eder
    • Imagick::opaquePaintImage — Hedef ile eşleşen piksellerin rengini değiştirir
    • Imagick::optimizeImageLayers — En iyilemek amacıyla resimlerin tekrarlanan bölümlerini siler
    • Imagick::orderedPosterizeImage — Resme kurallı titreklik uygular
    • Imagick::paintFloodfillImage — Belirtilen renkle eşleşen piksellerin rengini değiştirir
    • Imagick::paintOpaqueImage — Bir rengi bir başka renkle değiştirir
    • Imagick::paintTransparentImage — Resimdeki belli bir rengi dolgu rengiyle değiştirir
    • Imagick::pingImage — Temel resim özniteliklerini bir dosyadan okur
    • Imagick::pingImageBlob — Temel resim özniteliklerini bir dizgeden okur
    • Imagick::pingImageFile — Temel resim özniteliklerini bir akımdan okur
    • Imagick::polaroidImage — Polaroid resmi taklit eder
    • Imagick::posterizeImage — Resimdeki renkleri belli bir sayıya düşürür
    • Imagick::previewImages — Resim üzerinde yapılacak bir işlem için en uygun değiştirgenin tespitini hızlandırır
    • Imagick::previousImage — Bir önceki resme gider
    • Imagick::profileImage — Bir resme profil ekler veya çıkarır
    • Imagick::quantizeImage — Belli bir resim içindeki renk miktarını bulur
    • Imagick::quantizeImages — Bir resim kümesi içindeki renk miktarını bulur
    • Imagick::queryFontMetrics — Yazı tipinin özelliklerini içeren bir dizi döndürür
    • Imagick::queryFonts — Yapılandırımış yazı tiplerini döndürür
    • Imagick::queryFormats — Imagick tarafından desteklenen biçemleri döndürür
    • Imagick::radialBlurImage — Bir resme dairesel bulanıklık uygular
    • Imagick::raiseImage — 3 boyutlu düğme benzeri bir etki oluşturur
    • Imagick::randomThresholdImage — Yüksek zıtlığa sahip iki renkli bir resim oluşturur
    • Imagick::readImage — Resmi dosyadar okur
    • Imagick::readImageBlob — Resmi ikil bir dizgeden okur
    • Imagick::readImageFile — Resmi akımdan okur
    • Imagick::readimages — Description
    • Imagick::recolorImage — Resmi yeniden renklendirir
    • Imagick::reduceNoiseImage — Bir resmin dış hatlarını yumuşatır
    • Imagick::remapImage — Remaps image colors
    • Imagick::removeImage — Resim kümesinden bir resim siler
    • Imagick::removeImageProfile — İsimli resim profilini silip döndürür
    • Imagick::render — Evvelce verilmiş tüm çizim komutlarını uygular
    • Imagick::resampleImage — Belirtilen çözünürlüğe göre resmi yeniden örnekler
    • Imagick::resetImagePage — Resim sayfasını sıfırlar
    • Imagick::resizeImage — Bir resmi boyutlandırır
    • Imagick::rollImage — Bir resmin başlangıç noktasını tanımlar
    • Imagick::rotateImage — Resmi döndürür
    • Imagick::rotationalBlurImage — Description
    • Imagick::roundCorners — Resmin köşelerini yuvarlatır
    • Imagick::sampleImage — Resmi piksel örneklemeyle oranlar
    • Imagick::scaleImage — Bir resmin enboy oranını ayarlar
    • Imagick::segmentImage — Segments an image
    • Imagick::selectiveBlurImage — Description
    • Imagick::separateImageChannel — Resimden bir kanalı ayırır
    • Imagick::sepiaToneImage — Resme kızıl kahverengi tonlama uygular
    • Imagick::setBackgroundColor — Nesnenin öntanımlı artalan rengini tanımlar
    • Imagick::setColorspace — Set colorspace
    • Imagick::setCompression — Nesnenin öntanımlı sıkıştırma türünü tanımlar
    • Imagick::setCompressionQuality — Nesnenin öntanımlı sıkıştırma seviyesini tanımlar
    • Imagick::setFilename — Bir resim için dosya ismi tanımlar
    • Imagick::setFirstIterator — Imagick yineleyiciyi ilk resme konumlar
    • Imagick::setFont — Imagick nesnesinin yazı tipini tanımlar
    • Imagick::setFormat — Imagick nesnesinin biçemini tanımlar
    • Imagick::setGravity — Sets the gravity
    • Imagick::setImage — Nesnedeki resmi değiştirir
    • Imagick::setImageAlphaChannel — Resmin şeffaflık kanalını tanımlar
    • Imagick::setImageArtifact — Set image artifact
    • Imagick::setImageAttribute — Description
    • Imagick::setImageBackgroundColor — Resmin artalan rengini tanımlar
    • Imagick::setImageBias — Bir resmi evriştirmekte kullanılan yöntem için resim sapmasını tanımlar
    • Imagick::setImageBiasQuantum — Description
    • Imagick::setImageBluePrimary — Resmin renk bileşenlerinden birincil mavi noktasını tanımlar
    • Imagick::setImageBorderColor — Resmin çerçeve rengini tanımlar
    • Imagick::setImageChannelDepth — Belli bir resim kanalının derinliğini tanımlar
    • Imagick::setImageClipMask — Resim kırpma maskesini tanımlar
    • Imagick::setImageColormapColor — Renk eşlemi indisi belirtilen rengi tanımlar
    • Imagick::setImageColorspace — Resmin renk uzayını tanımlar
    • Imagick::setImageCompose — Resim birleştirme işlecini tanımlar
    • Imagick::setImageCompression — Resim sıkıştırma seviyesini tanımlar
    • Imagick::setImageCompressionQuality — Resim sıkıştırma seviyesini belirler
    • Imagick::setImageDelay — Resim gecikmesini tanımlar
    • Imagick::setImageDepth — Resim derinliğini tanımlar
    • Imagick::setImageDispose — Resmin elden çıkarma yöntemini tanımlar
    • Imagick::setImageExtent — Resmin boyutlarını tanımlar
    • Imagick::setImageFilename — Belli bir resmin dosya ismini tanımlar
    • Imagick::setImageFormat — Belli bir resmin biçemini tanımlar
    • Imagick::setImageGamma — Resmin gammasını tanımlar
    • Imagick::setImageGravity — Sets the image gravity
    • Imagick::setImageGreenPrimary — Resmin renk bileşenlerinden birincil yeşil noktasını tanımlar
    • Imagick::setImageIndex — Yineleyici konumunu tanımlar
    • Imagick::setImageInterlaceScheme — Resim geçişim şemasını tanımlar
    • Imagick::setImageInterpolateMethod — Resmin aradeğer pikseli yöntemini tanımlar
    • Imagick::setImageIterations — Resim yineleme sayısını tanımlar
    • Imagick::setImageMatte — Resmin matlık kanalını ayarlar
    • Imagick::setImageMatteColor — Resmin şeffaf rengini tanımlar
    • Imagick::setImageOpacity — Resmin matlık seviyesini tanımlar
    • Imagick::setImageOrientation — Resmin baskı yönünü tanımlar
    • Imagick::setImagePage — Resmin sayfa geometrisini tanımlar
    • Imagick::setImageProfile — Imagick nesnesine isimli bir profil ekler
    • Imagick::setImageProperty — Bir resim özelliğini tanımlar
    • Imagick::setImageRedPrimary — Resmin renk bileşenlerinden birincil kırmızı noktasını tanımlar
    • Imagick::setImageRenderingIntent — Resme komutların uygulanış tarzını belirler
    • Imagick::setImageResolution — Resmin çözünürlüğünü ayarlar
    • Imagick::setImageScene — Resmin dekorunu tanımlar
    • Imagick::setImageTicksPerSecond — Resmin saniyedeki tik sayısını tanımlar
    • Imagick::setImageType — Resim türünü tanımlar
    • Imagick::setImageUnits — Resmin çözünürlük birimlerini tanımlar
    • Imagick::setImageVirtualPixelMethod — Resmin sanal piksel yöntemini tanımlar
    • Imagick::setImageWhitePoint — Renk berraklığının beyaz noktasını tanımlar
    • Imagick::setInterlaceScheme — Resim geçişim şemasını tanımlar
    • Imagick::setIteratorIndex — Yineleyici konumunu belirler
    • Imagick::setLastIterator — Son resme bir Imagick yineleyicisi atar
    • Imagick::setOption — Bir seçenek tanımlar
    • Imagick::setPage — Imagick nesnesinin sayfa geometrisini tanımlar
    • Imagick::setPointSize — Yazı puntosunu belirler
    • Imagick::setProgressMonitor — Description
    • Imagick::setRegistry — Description
    • Imagick::setResolution — Resim çözünürlüğünü tanımlar
    • Imagick::setResourceLimit — Belli bir özkaynağın sınırını megabayt olarak tanımlar
    • Imagick::setSamplingFactors — Resim örnekleme çarpanlarını ayarlar
    • Imagick::setSize — Imagick nesnesinin boyutlarını ayarlar
    • Imagick::setSizeOffset — Imagick nesnesinin başlangıcını ve boyutlarını ayarlar
    • Imagick::setType — Resmin tür özniteliğini tanımlar
    • Imagick::shadeImage — Üç boyutluluk etkisi oluşturur
    • Imagick::shadowImage — Bir resimde gölgeleri taklit eder
    • Imagick::sharpenImage — Resmi netleştirir
    • Imagick::shaveImage — Bir resmin kenarındaki pikselleri rendeler
    • Imagick::shearImage — Bir paralalkenar oluşturur
    • Imagick::sigmoidalContrastImage — Bir resmin zıtlığını ayarlar
    • Imagick::sketchImage — Kara kalem çalışmasını taklit eder
    • Imagick::smushImages — Description
    • Imagick::solarizeImage — Resme uzun pozlama etkisi uygular
    • Imagick::sparseColorImage — Interpolates colors
    • Imagick::spliceImage — Bir resme bir rengi bütün halinde bindirerek birleştirir
    • Imagick::spreadImage — Bir kümedeki her pikseli rasgele gösterir
    • Imagick::statisticImage — Description
    • Imagick::steganoImage — Resmin içine sayısal bir filigran gizler
    • Imagick::stereoImage — İki resmi birleştirir
    • Imagick::stripImage — Resimden tüm profilleri ve açıklamaları ayıklar
    • Imagick::subImageMatch — Description
    • Imagick::swirlImage — Resmin merkezine yakın pikselleri girdap gibi döndürür
    • Imagick::textureImage — Doku resmini yatay ve düşeyde yineler
    • Imagick::thresholdImage — Bazı pikselleri bir eşiğe göre değiştir
    • Imagick::thumbnailImage — Resmin boyutlarını değiştirir
    • Imagick::tintImage — Resimdeki her piksele bir renk yöneyi uygular
    • Imagick::__toString — Returns the image as a string.
    • Imagick::transformImage — Budama miktarını ve resim geometrisini ayarlamanın uygun yolu
    • Imagick::transformImageColorspace — Transforms an image to a new colorspace.
    • Imagick::transparentPaintImage — Pikselleri şeffaflaştırır
    • Imagick::transposeImage — Resmin düşeydeki yansımasını oluşturur
    • Imagick::transverseImage — Resmin yataydaki yansımasını oluşturur
    • Imagick::trimImage — Resmin kenarlarını siler
    • Imagick::uniqueImageColors — Biri dışında tüm piksel renklerini iptal eder
    • Imagick::unsharpMaskImage — Resmi netleştirir
    • Imagick::valid — Imagick nesnesinin geçerli olup olmadığını sınar
    • Imagick::vignetteImage — Resme bir nakış süzgeci uygular
    • Imagick::waveImage — Resme bir dalga süzgeci uygular
    • Imagick::whiteThresholdImage — Eşiğin üstündeki tüm piksellerin rengini beyaza zorlar
    • Imagick::writeImage — Resmi belirtilen dosyaya yazar
    • Imagick::writeImageFile — Bir resmi belirtilen dosya tanıtıcısına yazar
    • Imagick::writeImages — Bir resmi veya resim kümesini dosyaya yazar
    • Imagick::writeImagesFile — Resim karelerini bir dosya tanıtıcısına yazar
  • ImagickDraw sınıfı
    • ImagickDraw::affine — Geçerli homojen koordinatlar matrisini ayarlar
    • ImagickDraw::annotation — Resmin üzerine bir metin çizer
    • ImagickDraw::arc — Bir yay çizer
    • ImagickDraw::bezier — Bir Bezier eğrisi çizer
    • ImagickDraw::circle — Bir daire çizer
    • ImagickDraw::clear — ImagickDraw nesnesini temizler
    • ImagickDraw::clone — Belirtilen ImagickDraw nesnesinin tam bir kopyasını yapar
    • ImagickDraw::color — Bir resmi boyar
    • ImagickDraw::comment — Bir yöney çıktı akımına bir açıklama ekler
    • ImagickDraw::composite — Bir resmi geçerli resimle bileştirir
    • ImagickDraw::__construct — ImagickDraw kurucusu
    • ImagickDraw::destroy — ImagickDraw yıkıcısı
    • ImagickDraw::ellipse — Resmin üzerine bir elips çizer
    • ImagickDraw::getClipPath — Geçerli yalıtım maskesi kimliğini döndürür
    • ImagickDraw::getClipRule — Yalıtım maskesi tarafından kullanılan çokgen dolgu kuralını döndürür
    • ImagickDraw::getClipUnits — Yalıtım maskesi birimlerinin yorumunu döndürür
    • ImagickDraw::getFillColor — Dolgu rengini döndürür
    • ImagickDraw::getFillOpacity — Çizimde kullanılan matlık değerini döndürür
    • ImagickDraw::getFillRule — Geçerli dolgu kuralını döndürür
    • ImagickDraw::getFont — Geçerli yazı tipini döndürür
    • ImagickDraw::getFontFamily — Yazı tipi ailesini döndürür
    • ImagickDraw::getFontSize — Yazı tipi yüksekliğini döndürür
    • ImagickDraw::getFontStretch — Description
    • ImagickDraw::getFontStyle — Yazı tipi tarzını döndürür
    • ImagickDraw::getFontWeight — Yazı tipi kalınlığını döndürür
    • ImagickDraw::getGravity — Metnin çekim yönünü döndürür
    • ImagickDraw::getStrokeAntialias — Nesne dış hatlarını çizmekte kullanılan vurgu yumuşatması ayarını döndürür
    • ImagickDraw::getStrokeColor — Nesne dış hatlarını çizmekte kullanılan vurgunun rengini döndürür
    • ImagickDraw::getStrokeDashArray — Kesikli çizgi örüntüsünü oluşturmakta kullanılan tireleri ve boşlukları içeren bir dizi döndürür
    • ImagickDraw::getStrokeDashOffset — Kesikli çizgi örüntüsünde tire başlangıcını döndürür
    • ImagickDraw::getStrokeLineCap — Kalın çizgilerdeki çizgi uçlarının şeklini döndürür
    • ImagickDraw::getStrokeLineJoin — Kalın çizgi ekleminin şeklini döndürür
    • ImagickDraw::getStrokeMiterLimit — Gönyenin kesildiği sınırı döndürür
    • ImagickDraw::getStrokeOpacity — Nesne dış hatlarını çizmekte kullanılan vurgunun matlığını döndürür
    • ImagickDraw::getStrokeWidth — Nesne dış hatlarını çizmekte kullanılan vurgu genişliğini döndürür
    • ImagickDraw::getTextAlignment — Metin hizalamasını döndürür
    • ImagickDraw::getTextAntialias — Geçerli metin yumuşatma ayarını döndürür
    • ImagickDraw::getTextDecoration — Metin süslemesi türünü döndürür
    • ImagickDraw::getTextEncoding — Metin çizerken kullanılan karakter kümesi ismini döndürür
    • ImagickDraw::getTextInterlineSpacing — Description
    • ImagickDraw::getTextInterwordSpacing — Description
    • ImagickDraw::getTextKerning — Description
    • ImagickDraw::getTextUnderColor — Metin artalanındaki rengi döndürür
    • ImagickDraw::getVectorGraphics — Yöney çizgesini içeren bir dizge döner
    • ImagickDraw::line — Bir çizgi çizer
    • ImagickDraw::matte — Resmin matlık kanalını boyar
    • ImagickDraw::pathClose — Geçerli hatta son elemanı ekler
    • ImagickDraw::pathCurveToAbsolute — Üçüncü dereceden bir Bezier eğrisi çizer
    • ImagickDraw::pathCurveToQuadraticBezierAbsolute — İkinci dereceden bir Bezier eğrisi çizer
    • ImagickDraw::pathCurveToQuadraticBezierRelative — İkinci dereceden bir Bezier eğrisi çizer
    • ImagickDraw::pathCurveToQuadraticBezierSmoothAbsolute — İkinci dereceden bir Bezier eğrisi çizer
    • ImagickDraw::pathCurveToQuadraticBezierSmoothRelative — İkinci dereceden bir Bezier eğrisi çizer
    • ImagickDraw::pathCurveToRelative — Üçüncü dereceden bir Bezier eğrisi çizer
    • ImagickDraw::pathCurveToSmoothAbsolute — Üçüncü dereceden bir Bezier eğrisi çizer
    • ImagickDraw::pathCurveToSmoothRelative — Üçüncü dereceden bir Bezier eğrisi çizer
    • ImagickDraw::pathEllipticArcAbsolute — Eliptik bir yay çizer
    • ImagickDraw::pathEllipticArcRelative — Bir eliptik yay çizer
    • ImagickDraw::pathFinish — Geçerli hattı sonlandırır
    • ImagickDraw::pathLineToAbsolute — Draws a line path
    • ImagickDraw::pathLineToHorizontalAbsolute — Yatay bir hat elemanı çizer
    • ImagickDraw::pathLineToHorizontalRelative — Yatay bir hat elemanı çizer
    • ImagickDraw::pathLineToRelative — Bir hat elemanı çizer
    • ImagickDraw::pathLineToVerticalAbsolute — Düşey bir hat elemanı çizer
    • ImagickDraw::pathLineToVerticalRelative — Bir düşey hat elemanı çizer
    • ImagickDraw::pathMoveToAbsolute — Yeni bir hat elemanı başlatır
    • ImagickDraw::pathMoveToRelative — Yeni bir hat elemanı başlatır
    • ImagickDraw::pathStart — Bir hat çizim listesinin başlangıcını bildirir
    • ImagickDraw::point — Bir nokta çizer
    • ImagickDraw::polygon — Bir çokgen çizer
    • ImagickDraw::polyline — Bir çoklu çizgi çizer
    • ImagickDraw::pop — Yığıttaki geçerli ImagickDraw nesnesini silip sonraki nesneyi döndürür
    • ImagickDraw::popClipPath — Bir yalıtım maskesi tanımını sonlandırır
    • ImagickDraw::popDefs — Bir tanım listesini sonlandırır
    • ImagickDraw::popPattern — Bir örüntü tanımını sonlandırır
    • ImagickDraw::push — Geçerli ImagickDraw nesnesini kopyalar ve yığıta basar
    • ImagickDraw::pushClipPath — Bir yalıtım maskesi tanımı başlatır
    • ImagickDraw::pushDefs — Bundan sonra çağrılacak yöntemlerin ImagickDraw::popDefs yöntemi çağrılıncaya kadar isimli elemanları tanımlayacağını belirtir
    • ImagickDraw::pushPattern — Bundan sonra çağrılacak yöntemlerin ImagickDraw::popPattern yöntemi çağrılıncaya kadar bir isimli örüntüyü tanımlayacağını belirtir
    • ImagickDraw::rectangle — Bir dikdörtgen çizer
    • ImagickDraw::render — Evvelce verilmiş tüm çizim komutlarını resme uygular
    • ImagickDraw::resetVectorGraphics — Description
    • ImagickDraw::rotate — Geçerli koordinat sistemini belirtilen açıda döndürür
    • ImagickDraw::roundRectangle — Köşeleri yuvarlatılmış bir dikdörtgen çizer
    • ImagickDraw::scale — Enboy oranını ayarlar
    • ImagickDraw::setClipPath — Bir isimli yalıtım maskesini resimle ilişkilendirir
    • ImagickDraw::setClipRule — Yalıtım maskesi tarafından kullanılacak çokgen dolgu kuralını belirler
    • ImagickDraw::setClipUnits — Yalıtım maskesi birimlerinin yorumunu belirler
    • ImagickDraw::setFillAlpha — Dolgu dokusu veya dolgu rengi için kullanılacak şeffaflığı belirler
    • ImagickDraw::setFillColor — Dolgulu nesnelerin çiziminde kullanılacak dolgu rengini belirler
    • ImagickDraw::setFillOpacity — Dolgu dokusu veya dolgu rengi için kullanılacak matlığı belirler
    • ImagickDraw::setFillPatternURL — Nesne dolgu örüntüsü için kullanılacak adresi belirler
    • ImagickDraw::setFillRule — Çokgen çizerken kullanılacak dolgu kuralını belirler
    • ImagickDraw::setFont — Metni çizerken kullanılacak yazı tipini tam belirtimiyle belirler
    • ImagickDraw::setFontFamily — Yazı tipi ailesini belirler
    • ImagickDraw::setFontSize — Yazı tipi yüksekliğini belirler
    • ImagickDraw::setFontStretch — Yazı tipinin karakter genişliğini belirler
    • ImagickDraw::setFontStyle — Yazı tipi tarzını belirler
    • ImagickDraw::setFontWeight — Yazı tipi kalınlığını belirler
    • ImagickDraw::setGravity — Metnin çekim yönünü belirler
    • ImagickDraw::setResolution — Description
    • ImagickDraw::setStrokeAlpha — Vurgulu nesne dış hatlarının şeffaflığını tanımlar
    • ImagickDraw::setStrokeAntialias — Vurgulu dış hatlara kenar yumuşatma uygulanıp uygulanmayacağını denetler
    • ImagickDraw::setStrokeColor — Nesne dış hatlarını vurgulamakta kullanılacak rengi tanımlar
    • ImagickDraw::setStrokeDashArray — Kesikli çizgi örüntüsünde tireleri ve boşlukları belirler
    • ImagickDraw::setStrokeDashOffset — Kesikli çizgi örüntüsünde tire başlangıcını belirler
    • ImagickDraw::setStrokeLineCap — Kalın çizgilerde çizgi uçlarının şeklini belirler
    • ImagickDraw::setStrokeLineJoin — Kalın çizgi ekleminin şeklini belirler
    • ImagickDraw::setStrokeMiterLimit — Gönyenin kesildiği sınırı tanımlar
    • ImagickDraw::setStrokeOpacity — Vurgulanmış nesne dış hatlarının matlığını tanımlar
    • ImagickDraw::setStrokePatternURL — Nesne dış hatlarının çiziminde kullanılacak örüntüyü tanımlar
    • ImagickDraw::setStrokeWidth — Nesne dış hatlarının çiziminde kullanılacak çizgi genişliğini tanımlar
    • ImagickDraw::setTextAlignment — Metni hizalar
    • ImagickDraw::setTextAntialias — Metne kenar yumuşatma uygulanıp uygulanmayacağını denetler
    • ImagickDraw::setTextDecoration — Bir karakter süslemesi tanımlar
    • ImagickDraw::setTextEncoding — Metin karakter kümesini tanımlar
    • ImagickDraw::setTextInterlineSpacing — Description
    • ImagickDraw::setTextInterwordSpacing — Description
    • ImagickDraw::setTextKerning — Description
    • ImagickDraw::setTextUnderColor — Metin çerçevesinin artalan rengini tanımlar
    • ImagickDraw::setVectorGraphics — Yöney çizgesini tanımlar
    • ImagickDraw::setViewbox — Tuval boyutunu uçtan uca tanımlar
    • ImagickDraw::skewX — Geçerli koordinat sistemini yatayda belirtilen açıda eğer
    • ImagickDraw::skewY — Geçerli koordinat sistemini düşeyde belirtilen açıda eğer
    • ImagickDraw::translate — Geçerli koordinat sisteminin başnoktasını değiştirir
  • ImagickPixel sınıfı
    • ImagickPixel::clear — Nesne ile ilişkili özkaynakları temizler
    • ImagickPixel::__construct — ImagickPixel nesnesini oluşturur
    • ImagickPixel::destroy — Nesne ile ilgili özkaynakları serbest bırakır
    • ImagickPixel::getColor — Bir renk döndürür
    • ImagickPixel::getColorAsString — Rengi bir dizge olarak döndürür
    • ImagickPixel::getColorCount — Nesnenin renk sayısını döndürür
    • ImagickPixel::getColorQuantum — Description
    • ImagickPixel::getColorValue — Belirtilen renk kanalının normalleştirilmiş değerini döndürür
    • ImagickPixel::getColorValueQuantum — Description
    • ImagickPixel::getHSL — ImagickPixel nesnesinin normalleştirilmiş HSL rengini döndürür
    • ImagickPixel::getIndex — Description
    • ImagickPixel::isPixelSimilar — Check the distance between this color and another
    • ImagickPixel::isPixelSimilarQuantum — Description
    • ImagickPixel::isSimilar — İki renk arasındaki benzerliği hesaplar
    • ImagickPixel::setColor — Renk tanımlar
    • ImagickPixel::setColorCount — Description
    • ImagickPixel::setColorValue — Renk kanallarından birinin normalleştirilmiş değerini belirler
    • ImagickPixel::setColorValueQuantum — Description
    • ImagickPixel::setHSL — Normalleştirilmiş HSL rengini ayarlar
    • ImagickPixel::setIndex — Description
  • ImagickPixelIterator sınıfı
    • ImagickPixelIterator::clear — Piksel yineleyici ile ilişkili özkaynakları temizler
    • ImagickPixelIterator::__construct — Bir ImagickPixelIterator nesnesi oluşturur
    • ImagickPixelIterator::destroy — Piksel yineleyici ile ilişkili özkaynakları serbest bırakır
    • ImagickPixelIterator::getCurrentIteratorRow — Piksel yineleyicinin üzerinde bulunduğu ImagickPixel nesneleri satırını döndürür
    • ImagickPixelIterator::getIteratorRow — Piksel yineleyicinin üzerinde bulunduğu satırın numarasını döndürür
    • ImagickPixelIterator::getNextIteratorRow — Piksel yineleyicinin sonraki satırını döndürür
    • ImagickPixelIterator::getPreviousIteratorRow — Önceki satırı döndürür
    • ImagickPixelIterator::newPixelIterator — Yeni bir piksel yineleyici döndürür
    • ImagickPixelIterator::newPixelRegionIterator — Yeni bir bölgesel piksel yineleyicisi döndürür
    • ImagickPixelIterator::resetIterator — Piksel yineleyiciyi sıfırlar
    • ImagickPixelIterator::setIteratorFirstRow — Piksel yineleyiciyi ilk piksel satırına hizalar
    • ImagickPixelIterator::setIteratorLastRow — Piksel yineleyiciyi son piksel satırına hizalar
    • ImagickPixelIterator::setIteratorRow — Piksel yineleyiciyi satırını tanımlar
    • ImagickPixelIterator::syncIterator — Piksel yineleyiciyi eşzamanlar
GmagickPixel::setcolorvalue
Giriş
Resim İşleme ve Resim Üretimi


Giriş

Imagick, doğal bir PHP eklentisi olup, resimleri oluşturmak ve değiştirmek için ImageMagick API'sini kullanır.

ImageMagick® resimleri oluşturmak, düzenlemek ve biteşlemli resimler oluşturmak için bir takım yazılımlardan meydana gelmiştir. DPX, EXR, GIF, JPEG, JPEG-2000, PDF, PhotoCD, PNG, Postscript, SVG ve TIFF dahil 100'ün üzerinde resim biçemini okur, yazar ve dönüştürebilir.

Telif Hakkı © 1999-2007 ImageMagick Studio LLC.

ImageMagick Studio LLC, resimlerle ilgili çözümlerin özgürce kullanılabilmesine adanmış bir kazançsız örgütlenmedir.

ImageMagick
Yapılandırma/Kurulum
ImageMagick


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
ImageMagick


Gereksinimler

Windows üzerinde kurulum gereksinimleri

Sürüm bilgisi aşağıdakinden farklı değildir. http://www.imagemagick.org/ adresinden kurulabilir sürüm indirilebilir, dolayısıyla bu eklentinin Windows üzerine kurulması için derlenmesine gerek yoktur.

Diğer platformlara kurulum gereksinimleri

PHP >= 5.1.3 ve ImageMagick >= 6.2.4 gerekir. Desteklenen biçemlerin miktarı tamamen ImageMagick kurulumunuzca desteklenen biçem sayısına bağlıdır. Örneğin PDF işlemlerini yapabilmek için Imagemagick, ghostscript gerektirir.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu » PECL eklentisi PHP ile gelmez.

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/imagick.

Bilginize: Bu eklentinin resmi ismi imagick'tir.

Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

COLOR_* Sabitleri

Renk Türü Sabitleri. Bu sabitler esas olarak ImagickPixel ile kullanılır.

imagick::COLOR_BLACK (integer)
Siyah
imagick::COLOR_BLUE (integer)
Mavi
imagick::COLOR_CYAN (integer)
Turkuaz
imagick::COLOR_GREEN (integer)
Yeşil
imagick::COLOR_RED (integer)
Kırmızı
imagick::COLOR_YELLOW (integer)
Sarı
imagick::COLOR_MAGENTA (integer)
Eflatun
imagick::COLOR_OPACITY (integer)
Matlık
imagick::COLOR_ALPHA (integer)
Alfa
imagick::COLOR_FUZZ (integer)
Renk benzerliği.
DISPOSE_* Sabitleri

Elden Çıkarma Türü Sabitleri

imagick::DISPOSE_UNRECOGNIZED (integer)
Tanınmayan elden çıkarma türü
imagick::DISPOSE_UNDEFINED (integer)
Tanımsız elden çıkarma türü
imagick::DISPOSE_NONE (integer)
Tanımlı elden çıkarma türü yok.
imagick::DISPOSE_BACKGROUND (integer)
Artalan
imagick::DISPOSE_PREVIOUS (integer)
Önceki
Birleştirme İşleci Sabitleri
imagick::COMPOSITE_DEFAULT (integer)
Öntanımlı birleştirme işleci
imagick::COMPOSITE_UNDEFINED (integer)
Tanımsız birleştirme işleci
imagick::COMPOSITE_NO (integer)
Hiç birleştirme işleci tanımlanmamış
imagick::COMPOSITE_ADD (integer)
Resim + resim sonucu
imagick::COMPOSITE_ATOP (integer)
Sonuç, resimle aynı görüntüyü içerir, ancak görüntülerin üst üste bindiği yerde birleşik resim bulanıklaşır.
imagick::COMPOSITE_BLEND (integer)
Resimleri kaynaştır
imagick::COMPOSITE_BUMPMAP (integer)
Kaynağın önce gri tonlamaya dönüştürülmesi dışında COMPOSITE_MULTIPLY ile aynıdır.
imagick::COMPOSITE_CLEAR (integer)
Hedef resmi şeffaf yap.
imagick::COMPOSITE_COLORBURN (integer)
Kaynak resmin yansıtmak için hedef resmi karart.
imagick::COMPOSITE_COLORDODGE (integer)
Kaynak resmin yansıtmak için hedef resmi aydınlat.
imagick::COMPOSITE_COLORIZE (integer)
Birleşik resim kullanarak hedef resmi renklendir.
imagick::COMPOSITE_COPYBLACK (integer)
Siyahı kaynaktan hedefe kopyala.
imagick::COMPOSITE_COPYBLUE (integer)
Maviyi kaynaktan hedefe kopyala.
imagick::COMPOSITE_COPY (integer)
Kaynak resmi hedef resme kopyala.
imagick::COMPOSITE_COPYCYAN (integer)
Turkuazı kaynaktan hedefe kopyala.
imagick::COMPOSITE_COPYGREEN (integer)
Yeşili kaynaktan hedefe kopyala.
imagick::COMPOSITE_COPYMAGENTA (integer)
Eflatunu kaynaktan hedefe kopyala
imagick::COMPOSITE_COPYOPACITY (integer)
Matlığı kaynaktan hedefe kopyala.
imagick::COMPOSITE_COPYRED (integer)
Kırmızıyı kaynaktan hedefe kopyala.
imagick::COMPOSITE_COPYYELLOW (integer)
Sarıyı kaynaktan hedefe kopyala.
imagick::COMPOSITE_DARKEN (integer)
Hedef resmi karart
imagick::COMPOSITE_DSTATOP (integer)
Kaynağın içinde bulunan hedef bölüm, kaynağın üzerine yerleştirilip hedef yer değiştirilir.
imagick::COMPOSITE_DST (integer)
Hedef resme dokunma.
imagick::COMPOSITE_DSTIN (integer)
Kaynağın içindeki parçaların yerine hedefi yerleştir.
imagick::COMPOSITE_DSTOUT (integer)
Kaynağın dışındaki parçaların yerine hedefi yerleştir.
imagick::COMPOSITE_DSTOVER (integer)
Hedefe kaynağı yerleştir.
imagick::COMPOSITE_DIFFERENCE (integer)
Belirleyici iki renkten koyu olanının açık olandan çıkar.
imagick::COMPOSITE_DISPLACE (integer)
Hedef resmin piksellerini kaynakta tanımlandığı gibi kaydır.
imagick::COMPOSITE_DISSOLVE (integer)
Kaynağı hedefte erit
imagick::COMPOSITE_EXCLUSION (integer)
Daha düşük zıtlıkta görünmesi dışında imagick::COMPOSITE_DIFFERENCE ile aynı etkiyi oluşturur.
imagick::COMPOSITE_HARDLIGHT (integer)
Kaynak renk değerine bağlı olarak renkleri çoğullar ve ekranlar.
imagick::COMPOSITE_HUE (integer)
Hedefin renk sıcaklığını kaynakta tanımlandığı gibi değiştirir.
imagick::COMPOSITE_IN (integer)
Kaynağı hedefe birleştirir.
imagick::COMPOSITE_LIGHTEN (integer)
Hedefi kaynakta tanımlandığı gibi aydınlatır.
imagick::COMPOSITE_LUMINIZE (integer)
Hedefi kaynakta tanımlandığı gibi ışıklandırır.
imagick::COMPOSITE_MINUS (integer)
Kaynağı hedeften çıkarır.
imagick::COMPOSITE_MODULATE (integer)
Hedef parlaklığını, doygunluğunu ve renk sıcaklığını kaynakta tanımlandığı gibi modüle eder.
imagick::COMPOSITE_MULTIPLY (integer)
Hedefi kaynağa çoğullar.
imagick::COMPOSITE_OUT (integer)
Kaynağın dış kısımlarını hedefle birleştirir.
imagick::COMPOSITE_OVER (integer)
Kaynağı hedefin üzerinde birleştirir.
imagick::COMPOSITE_OVERLAY (integer)
Kaynağı hedefin üzerine yerleştirir.
imagick::COMPOSITE_PLUS (integer)
Kaynağı hedefe ekler.
imagick::COMPOSITE_REPLACE (integer)
Kaynakla hedefi yer değiştirir.
imagick::COMPOSITE_SATURATE (integer)
Hedefi kaynakta tanımlandığı gibi ışıkla doyurur.
imagick::COMPOSITE_SCREEN (integer)
Kaynak ve hedefin eşleniği alınıp çarpıldıktan sonra hedef yer değiştirilir.
imagick::COMPOSITE_SOFTLIGHT (integer)
Kaynağa bağlı olarak renkleri açık veya koyu yapar.
imagick::COMPOSITE_SRCATOP (integer)
Hedefin içinde bulunan kaynak bölüm, hedefin üzerinde birleştirilir.
imagick::COMPOSITE_SRC (integer)
Kaynağı hedefe kopyalar.
imagick::COMPOSITE_SRCIN (integer)
Hedefin içinde bulunan kaynak bölüm, hedefle yer değiştirilir.
imagick::COMPOSITE_SRCOUT (integer)
Hedefin dışında bulunan kaynak bölüm, hedefle yer değiştirilir.
imagick::COMPOSITE_SRCOVER (integer)
Kaynak hedefle yer değiştirir.
imagick::COMPOSITE_SUBTRACT (integer)
Kaynak resimdeki renkler hedef resimden çıkarılır.
imagick::COMPOSITE_THRESHOLD (integer)
Kaynak hedefle, kaynak eşiğinde tanımlandığı gibi birleştirilir.
imagick::COMPOSITE_XOR (integer)
Hedefin dışında kalan kaynak parçası ile kaynağın dışında kalan hedef parçası birleştirilir.
Montaj Kipi Sabitleri

imagick::MONTAGEMODE_FRAME (integer)
imagick::MONTAGEMODE_UNFRAME (integer)
imagick::MONTAGEMODE_CONCATENATE (integer)
Yazı tipi Tarzı Sabitleri

imagick::STYLE_NORMAL (integer)
Normal
imagick::STYLE_ITALIC (integer)
Eğik
imagick::STYLE_OBLIQUE (integer)
Eğik
imagick::STYLE_ANY (integer)
Herhangi biri
Süzgeç Sabitleri

imagick::FILTER_UNDEFINED (integer)
imagick::FILTER_POINT (integer)
imagick::FILTER_BOX (integer)
imagick::FILTER_TRIANGLE (integer)
imagick::FILTER_HERMITE (integer)
imagick::FILTER_HANNING (integer)
imagick::FILTER_HAMMING (integer)
imagick::FILTER_BLACKMAN (integer)
imagick::FILTER_GAUSSIAN (integer)
imagick::FILTER_QUADRATIC (integer)
imagick::FILTER_CUBIC (integer)
imagick::FILTER_CATROM (integer)
imagick::FILTER_MITCHELL (integer)
imagick::FILTER_LANCZOS (integer)
imagick::FILTER_BESSEL (integer)
imagick::FILTER_SINC (integer)
Resim Türü Sabitleri

imagick::IMGTYPE_UNDEFINED (integer)
imagick::IMGTYPE_BILEVEL (integer)
imagick::IMGTYPE_GRAYSCALE (integer)
imagick::IMGTYPE_GRAYSCALEMATTE (integer)
imagick::IMGTYPE_PALETTE (integer)
imagick::IMGTYPE_PALETTEMATTE (integer)
imagick::IMGTYPE_TRUECOLOR (integer)
imagick::IMGTYPE_TRUECOLORMATTE (integer)
imagick::IMGTYPE_COLORSEPARATION (integer)
imagick::IMGTYPE_COLORSEPARATIONMATTE (integer)
imagick::IMGTYPE_OPTIMIZE (integer)
Çözünürlük Sabitleri

imagick::RESOLUTION_UNDEFINED (integer)
imagick::RESOLUTION_PIXELSPERINCH (integer)
imagick::RESOLUTION_PIXELSPERCENTIMETER (integer)
Sıkıştırma Sabitleri

imagick::COMPRESSION_UNDEFINED (integer)
imagick::COMPRESSION_NO (integer)
imagick::COMPRESSION_BZIP (integer)
imagick::COMPRESSION_FAX (integer)
imagick::COMPRESSION_GROUP4 (integer)
imagick::COMPRESSION_JPEG (integer)
imagick::COMPRESSION_JPEG2000 (integer)
imagick::COMPRESSION_LOSSLESSJPEG (integer)
imagick::COMPRESSION_LZW (integer)
imagick::COMPRESSION_RLE (integer)
imagick::COMPRESSION_ZIP (integer)
imagick::COMPRESSION_DXT1 (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.0 ve üstü
imagick::COMPRESSION_DXT3 (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.0 ve üstü
imagick::COMPRESSION_DXT5 (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.0 ve üstü
Boyama Sabitleri

imagick::PAINT_POINT (integer)
imagick::PAINT_REPLACE (integer)
imagick::PAINT_FLOODFILL (integer)
imagick::PAINT_FILLTOBORDER (integer)
imagick::PAINT_RESET (integer)
Çekim Yönü Sabitleri
imagick::GRAVITY_NORTHWEST (integer)
Kuzeybatı
imagick::GRAVITY_NORTH (integer)
Kuzey
imagick::GRAVITY_NORTHEAST (integer)
Kuzeydoğu
imagick::GRAVITY_WEST (integer)
Batı
imagick::GRAVITY_CENTER (integer)
Merkez
imagick::GRAVITY_EAST (integer)
Doğu
imagick::GRAVITY_SOUTHWEST (integer)
Güneybatı
imagick::GRAVITY_SOUTH (integer)
Güney
imagick::GRAVITY_SOUTHEAST (integer)
Güneydoğu
Yazı tipi Karakter Genişliği Sabitleri

imagick::STRETCH_NORMAL (integer)
Normal
imagick::STRETCH_ULTRACONDENSED (integer)
Çok dar
imagick::STRETCH_CONDENSED (integer)
Dar
imagick::STRETCH_SEMICONDENSED (integer)
Az dar
imagick::STRETCH_SEMIEXPANDED (integer)
Az geniş
imagick::STRETCH_EXPANDED (integer)
Geniş
imagick::STRETCH_EXTRAEXPANDED (integer)
Çok geniş
imagick::STRETCH_ULTRAEXPANDED (integer)
Epeyce geniş
imagick::STRETCH_ANY (integer)
Herhangi biri.
Hizalama Sabitleri

imagick::ALIGN_UNDEFINED (integer)
imagick::ALIGN_LEFT (integer)
imagick::ALIGN_CENTER (integer)
imagick::ALIGN_RIGHT (integer)
Metin Süsleme Sabitleri
imagick::DECORATION_NO (integer)
imagick::DECORATION_UNDERLINE (integer)
imagick::DECORATION_OVERLINE (integer)
imagick::DECORATION_LINETROUGH (integer)
Gürültü Sabitleri

imagick::NOISE_UNIFORM (integer)
imagick::NOISE_GAUSSIAN (integer)
imagick::NOISE_MULTIPLICATIVEGAUSSIAN (integer)
imagick::NOISE_IMPULSE (integer)
imagick::NOISE_LAPLACIAN (integer)
imagick::NOISE_POISSON (integer)
imagick::NOISE_RANDOM (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.3.6 ve üstü.
Kanal Sabitleri
imagick::CHANNEL_UNDEFINED (integer)
imagick::CHANNEL_RED (integer)
imagick::CHANNEL_GRAY (integer)
imagick::CHANNEL_CYAN (integer)
imagick::CHANNEL_GREEN (integer)
imagick::CHANNEL_MAGENTA (integer)
imagick::CHANNEL_BLUE (integer)
imagick::CHANNEL_YELLOW (integer)
imagick::CHANNEL_ALPHA (integer)
imagick::CHANNEL_OPACITY (integer)
imagick::CHANNEL_MATTE (integer)
imagick::CHANNEL_BLACK (integer)
imagick::CHANNEL_INDEX (integer)
imagick::CHANNEL_ALL (integer)
imagick::CHANNEL_DEFAULT (integer)
Metrik Sabitleri

imagick::METRIC_UNDEFINED (integer)
imagick::METRIC_MEANABSOLUTEERROR (integer)
imagick::METRIC_MEANSQUAREERROR (integer)
imagick::METRIC_PEAKABSOLUTEERROR (integer)
imagick::METRIC_PEAKSIGNALTONOISERATIO (integer)
imagick::METRIC_ROOTMEANSQUAREDERROR (integer)
Piksel sabitleri

imagick::PIXEL_CHAR (integer)
imagick::PIXEL_DOUBLE (integer)
imagick::PIXEL_FLOAT (integer)
imagick::PIXEL_INTEGER (integer)
imagick::PIXEL_LONG (integer)
imagick::PIXEL_QUANTUM (integer)
imagick::PIXEL_SHORT (integer)
Değerlendirme İşleci Sabitleri
imagick::EVALUATE_UNDEFINED (integer)
imagick::EVALUATE_ADD (integer)
imagick::EVALUATE_AND (integer)
imagick::EVALUATE_DIVIDE (integer)
imagick::EVALUATE_LEFTSHIFT (integer)
imagick::EVALUATE_MAX (integer)
imagick::EVALUATE_MIN (integer)
imagick::EVALUATE_MULTIPLY (integer)
imagick::EVALUATE_OR (integer)
imagick::EVALUATE_RIGHTSHIFT (integer)
imagick::EVALUATE_SET (integer)
imagick::EVALUATE_SUBTRACT (integer)
imagick::EVALUATE_XOR (integer)
imagick::EVALUATE_POW (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.4 ve üstü.
imagick::EVALUATE_LOG (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.4 ve üstü.
imagick::EVALUATE_THRESHOLD (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.4 ve üstü.
imagick::EVALUATE_THRESHOLDBLACK (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.4 ve üstü.
imagick::EVALUATE_THRESHOLDWHITE (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.4 ve üstü.
imagick::EVALUATE_GAUSSIANNOISE (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.4 ve üstü.
imagick::EVALUATE_IMPULSENOISE (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.4 ve üstü.
imagick::EVALUATE_LAPLACIANNOISE (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.4 ve üstü.
imagick::EVALUATE_MULTIPLICATIVENOISE (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.4 ve üstü.
imagick::EVALUATE_POISSONNOISE (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.4 ve üstü.
imagick::EVALUATE_UNIFORMNOISE (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.4 ve üstü.
imagick::EVALUATE_COSINE (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.4 ve üstü.
imagick::EVALUATE_SINE (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.4 ve üstü.
imagick::EVALUATE_ADDMODULUS (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.4 ve üstü.
Renk Uzayı Sabitleri
imagick::COLORSPACE_UNDEFINED (integer)
imagick::COLORSPACE_RGB (integer)
imagick::COLORSPACE_GRAY (integer)
imagick::COLORSPACE_TRANSPARENT (integer)
imagick::COLORSPACE_OHTA (integer)
imagick::COLORSPACE_LAB (integer)
imagick::COLORSPACE_XYZ (integer)
imagick::COLORSPACE_YCBCR (integer)
imagick::COLORSPACE_YCC (integer)
imagick::COLORSPACE_YIQ (integer)
imagick::COLORSPACE_YPBPR (integer)
imagick::COLORSPACE_YUV (integer)
imagick::COLORSPACE_CMYK (integer)
imagick::COLORSPACE_SRGB (integer)
imagick::COLORSPACE_HSB (integer)
imagick::COLORSPACE_HSL (integer)
imagick::COLORSPACE_HWB (integer)
imagick::COLORSPACE_REC601LUMA (integer)
imagick::COLORSPACE_REC709LUMA (integer)
imagick::COLORSPACE_LOG (integer)
imagick::COLORSPACE_CMY (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.2 ve üstü.
Sanal Piksel Yöntemi Sabitleri

imagick::VIRTUALPIXELMETHOD_UNDEFINED (integer)
imagick::VIRTUALPIXELMETHOD_BACKGROUND (integer)
imagick::VIRTUALPIXELMETHOD_CONSTANT (integer)
imagick::VIRTUALPIXELMETHOD_EDGE (integer)
imagick::VIRTUALPIXELMETHOD_MIRROR (integer)
imagick::VIRTUALPIXELMETHOD_TILE (integer)
imagick::VIRTUALPIXELMETHOD_TRANSPARENT (integer)
imagick::VIRTUALPIXELMETHOD_MASK (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.2 ve üstü.
imagick::VIRTUALPIXELMETHOD_BLACK (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.2 ve üstü.
imagick::VIRTUALPIXELMETHOD_GRAY (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.2 ve üstü.
imagick::VIRTUALPIXELMETHOD_WHITE (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.2 ve üstü.
imagick::VIRTUALPIXELMETHOD_HORIZONTALTILE (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.3 ve üstü.
imagick::VIRTUALPIXELMETHOD_VERTICALTILE (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.3 ve üstü.
Önizleme Sabitleri

imagick::PREVIEW_UNDEFINED (integer)
imagick::PREVIEW_ROTATE (integer)
imagick::PREVIEW_SHEAR (integer)
imagick::PREVIEW_ROLL (integer)
imagick::PREVIEW_HUE (integer)
imagick::PREVIEW_SATURATION (integer)
imagick::PREVIEW_BRIGHTNESS (integer)
imagick::PREVIEW_GAMMA (integer)
imagick::PREVIEW_SPIFF (integer)
imagick::PREVIEW_DULL (integer)
imagick::PREVIEW_GRAYSCALE (integer)
imagick::PREVIEW_QUANTIZE (integer)
imagick::PREVIEW_DESPECKLE (integer)
imagick::PREVIEW_REDUCENOISE (integer)
imagick::PREVIEW_ADDNOISE (integer)
imagick::PREVIEW_SHARPEN (integer)
imagick::PREVIEW_BLUR (integer)
imagick::PREVIEW_THRESHOLD (integer)
imagick::PREVIEW_EDGEDETECT (integer)
imagick::PREVIEW_SPREAD (integer)
imagick::PREVIEW_SOLARIZE (integer)
imagick::PREVIEW_SHADE (integer)
imagick::PREVIEW_RAISE (integer)
imagick::PREVIEW_SEGMENT (integer)
imagick::PREVIEW_SWIRL (integer)
imagick::PREVIEW_IMPLODE (integer)
imagick::PREVIEW_WAVE (integer)
imagick::PREVIEW_OILPAINT (integer)
imagick::PREVIEW_CHARCOALDRAWING (integer)
imagick::PREVIEW_JPEG (integer)
Uygulama Amacı Sabitleri

imagick::RENDERINGINTENT_UNDEFINED (integer)
imagick::RENDERINGINTENT_SATURATION (integer)
imagick::RENDERINGINTENT_PERCEPTUAL (integer)
imagick::RENDERINGINTENT_ABSOLUTE (integer)
imagick::RENDERINGINTENT_RELATIVE (integer)
Geçişim Sabitleri

imagick::INTERLACE_UNDEFINED (integer)
imagick::INTERLACE_NO (integer)
imagick::INTERLACE_LINE (integer)
imagick::INTERLACE_PLANE (integer)
imagick::INTERLACE_PARTITION (integer)
imagick::INTERLACE_GIF (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.3.4 ve üstü.
imagick::INTERLACE_JPEG (integer)
imagick::INTERLACE_PNG (integer)
Dolgu Kuralı Sabitleri
imagick::FILLRULE_UNDEFINED (integer)
imagick::FILLRULE_EVENODD (integer)
imagick::FILLRULE_NONZERO (integer)
Yalıtım Birimi Sabitleri

imagick::PATHUNITS_UNDEFINED (integer)
imagick::PATHUNITS_USERSPACE (integer)
imagick::PATHUNITS_USERSPACEONUSE (integer)
imagick::PATHUNITS_OBJECTBOUNDINGBOX (integer)
Çizgi Uç Türü Sabitleri

imagick::LINECAP_UNDEFINED (integer)
imagick::LINECAP_BUTT (integer)
imagick::LINECAP_ROUND (integer)
imagick::LINECAP_SQUARE (integer)
Çizgi Eklem Türü Sabitleri
imagick::LINEJOIN_UNDEFINED (integer)
Eklem şekli tanımsız.
imagick::LINEJOIN_MITER (integer)
Ekleme gönye köşesi şeklini ver.
imagick::LINEJOIN_ROUND (integer)
Gönyenin köşesini yuvarlat.
imagick::LINEJOIN_BEVEL (integer)
Gönyenin köşesini kır.
Özkaynak türü sabitleri
imagick::RESOURCETYPE_UNDEFINED (integer)
imagick::RESOURCETYPE_AREA (integer)
imagick::RESOURCETYPE_DISK (integer)
imagick::RESOURCETYPE_FILE (integer)
imagick::RESOURCETYPE_MAP (integer)
imagick::RESOURCETYPE_MEMORY (integer)
Katman Yöntemi Sabitleri

imagick::LAYERMETHOD_UNDEFINED (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.2.9 ve üstü.
imagick::LAYERMETHOD_COALESCE (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.2.9 ve üstü.
imagick::LAYERMETHOD_COMPAREANY (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.2.9 ve üstü.
imagick::LAYERMETHOD_COMPARECLEAR (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.2.9 ve üstü.
imagick::LAYERMETHOD_COMPAREOVERLAY (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.2.9 ve üstü.
imagick::LAYERMETHOD_DISPOSE (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.2.9 ve üstü.
imagick::LAYERMETHOD_OPTIMIZE (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.2.9 ve üstü.
imagick::LAYERMETHOD_OPTIMIZEIMAGE (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.3.0 ve üstü.
imagick::LAYERMETHOD_OPTIMIZEPLUS (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.2.9 ve üstü.
imagick::LAYERMETHOD_OPTIMIZETRANS (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.3.0 ve üstü.
imagick::LAYERMETHOD_REMOVEDUPS (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.3.0 ve üstü.
imagick::LAYERMETHOD_REMOVEZERO (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.3.0 ve üstü.
imagick::LAYERMETHOD_COMPOSITE (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.3.0 ve üstü.
imagick::LAYERMETHOD_MERGE (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.3.7 ve üstü.
imagick::LAYERMETHOD_FLATTEN (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.3.7 ve üstü.
imagick::LAYERMETHOD_MOSAIC (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.3.7 ve üstü.
Yön sabitleri

imagick::ORIENTATION_UNDEFINED (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.3.0 ve üstü.
imagick::ORIENTATION_TOPLEFT (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.3.0 ve üstü.
imagick::ORIENTATION_TOPRIGHT (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.3.0 ve üstü.
imagick::ORIENTATION_BOTTOMRIGHT (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.3.0 ve üstü.
imagick::ORIENTATION_BOTTOMLEFT (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.3.0 ve üstü.
imagick::ORIENTATION_LEFTTOP (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.3.0 ve üstü.
imagick::ORIENTATION_RIGHTTOP (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.3.0 ve üstü.
imagick::ORIENTATION_RIGHTBOTTOM (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.3.0 ve üstü.
imagick::ORIENTATION_LEFTBOTTOM (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.3.0 ve üstü.
Bozunum sabitleri

imagick::DISTORTION_UNDEFINED (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.3.6 ve üstü.
imagick::DISTORTION_AFFINE (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.3.6 ve üstü.
imagick::DISTORTION_AFFINEPROJECTION (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.3.6 ve üstü.
imagick::DISTORTION_ARC (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.3.6 ve üstü.
imagick::DISTORTION_BILINEAR (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.3.6 ve üstü.
imagick::DISTORTION_PERSPECTIVE (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.3.6 ve üstü.
imagick::DISTORTION_PERSPECTIVEPROJECTION (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.3.6 ve üstü.
imagick::DISTORTION_SCALEROTATETRANSLATE (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.3.6 ve üstü.
imagick::DISTORTION_POLYNOMIAL (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.6 ve üstü.
imagick::DISTORTION_POLAR (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.6 ve üstü.
imagick::DISTORTION_DEPOLAR (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.6 ve üstü.
imagick::DISTORTION_BARREL (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.6 ve üstü.
imagick::DISTORTION_BARRELINVERSE (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.6 ve üstü.
imagick::DISTORTION_SHEPARDS (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.6 ve üstü.
imagick::DISTORTION_SENTINEL (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.6 ve üstü.
ALPHACHANNEL sabitleri

imagick::ALPHACHANNEL_ACTIVATE (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.3.8 ve üstü.
imagick::ALPHACHANNEL_DEACTIVATE (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.3.8 ve üstü.
imagick::ALPHACHANNEL_RESET (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.3.8 ve üstü.
imagick::ALPHACHANNEL_SET (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.3.8 ve üstü.
imagick::ALPHACHANNEL_UNDEFINED (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.6 ve üstü.
imagick::ALPHACHANNEL_COPY (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.6 ve üstü.
imagick::ALPHACHANNEL_EXTRACT (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.6 ve üstü.
imagick::ALPHACHANNEL_OPAQUE (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.6 ve üstü.
imagick::ALPHACHANNEL_SHAPE (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.6 ve üstü.
imagick::ALPHACHANNEL_TRANSPARENT (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.6 ve üstü.
SPARSECOLORMETHOD sabitleri

imagick::SPARSECOLORMETHOD_UNDEFINED (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.6 ve üstü.
imagick::SPARSECOLORMETHOD_BARYCENTRIC (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.6 ve üstü.
imagick::SPARSECOLORMETHOD_BILINEAR (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.6 ve üstü.
imagick::SPARSECOLORMETHOD_POLYNOMIAL (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.6 ve üstü.
imagick::SPARSECOLORMETHOD_SPEPARDS (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.6 ve üstü.
imagick::SPARSECOLORMETHOD_VORONOI (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.6 ve üstü.
FUNCTION sabitleri

imagick::FUNCTION_UNDEFINED (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.9 ve üstü.
imagick::FUNCTION_POLYNOMIAL (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.9 ve üstü.
imagick::FUNCTION_SINUSOID (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.9 ve üstü.
INTERPOLATE sabitleri

imagick::INTERPOLATE_UNDEFINED (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.3.2 ve üstü.
imagick::INTERPOLATE_AVERAGE (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.3.2 ve üstü.
imagick::INTERPOLATE_BICUBIC (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.3.2 ve üstü.
imagick::INTERPOLATE_BILINEAR (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.3.2 ve üstü.
imagick::INTERPOLATE_FILTER (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.3.2 ve üstü.
imagick::INTERPOLATE_INTEGER (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.3.2 ve üstü.
imagick::INTERPOLATE_MESH (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.3.2 ve üstü.
imagick::INTERPOLATE_NEARESTNEIGHBOR (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.3.2 ve üstü.
imagick::INTERPOLATE_SPLINE (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.3.4 ve üstü.
DITHERMETHOD sabitleri

imagick::DITHERMETHOD_UNDEFINED (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.6 ve üstü.
imagick::DITHERMETHOD_NO (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.6 ve üstü.
imagick::DITHERMETHOD_RIEMERSMA (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.6 ve üstü.
imagick::DITHERMETHOD_FLOYDSTEINBERG (integer)
Bu sabitini kullanılabilmesi için gerekli ImageMagick kütüphanesinin sürüm numarası: 6.4.6 ve üstü.
Özkaynak Türleri
Örnekler
ImageMagick


Örnekler
ImageMagick
PHP Manual

Örnekler

İçindekiler

  • Örnekler
Öntanımlı Sabitler
Örnekler
ImageMagick


Örnekler
Imagick sınıfı
Örnekler
PHP Manual

Örnekler

Imagick PHP'de resim işlemlerini nesne yönelimli arayüzü sayesinde oldukça kolaylaştırır. Burada bir resmin küçük bir örneğinin nasıl elde edildiği gösterilmiştir:

Örnek 1 - Imagick ile resim örneği (thumbnail) oluşturmak

<?php

header('Content-type: image/jpeg');

$resim = new Imagick('resim.jpg');

// Genişlik veya yükseklik olarak 0 verilmişse
// enboy oranı korunur
$resim->thumbnailImage(100, 0);

echo $image;

?>

Imagick'teki SPL ve nesne yönelimli özellikler kullanarak bir dizin içindeki tüm resim dosyaları kolayca yeniden boyutlandırılabilir (Büyük sayısal kamera resimlerini HTML sayfalarında izlenebilir boyuta indirmek gibi). Temel verileri kaybetmek istemediğimizden bu örnekte resize kullanıyoruz:

Örnek 2 - Bir dizindeki tüm JPG dosyalarının küçük örneklerinin elde edilmesi

<?php

$resimler = new Imagick(glob('images/*.JPG'));

foreach($resimler as $resim) {

    // 0, resmin enboy oranına uyulmasını sağlar
    $resim->thumbnailImage(1024,0);

}

$resimler->writeImages();

?>

Burada bir resmin yansımasının oluşturulması örneklenmiştir. Yansıtma için resmin simetriği alınıp derece derece koyulaşan bir maske uygulanmıştır. Hem özgün resim hem de simetriği aynı tuvalin üzerine yerleştirilmiştir.

Örnek 3 - Bir resmin yansımasının oluşturulması

<?php
/* Resmi okuyalım */
$im = new Imagick("test.png");

/* Resmin küçük örneğini oluşturalım */
$im->thumbnailImage(200, null);

/* Resme bir çerçeve çizgisi çizelim */
$im->borderImage(new ImagickPixel("white"), 5, 5);

/* Resmi kopyalayıp simetriğini alalım */
$reflection = $im->clone();
$reflection->flipImage();

/* Yansımaya uygulanacak maskeyi oluşturalım */
$gradient = new Imagick();

/* Maske biraz büyük olmalı ve bir çerçevesi olmalı */
$gradient->newPseudoImage($reflection->getImageWidth() + 10,
        $reflection->getImageHeight() + 10, "gradient:transparent-black");

/* Maskeyi yansımaya uygulayalım */
$reflection->compositeImage($gradient, imagick::COMPOSITE_OVER, 0, 0);

/* Biraz matlık ekleyelim. (ImageMagick 6.2.9 ve sonrası gerekir.) */
$reflection->setImageOpacity( 0.3 );

/* Boş bir tuval oluşturalım */
$canvas = new Imagick();

/* Tuval her iki resmi de tutacak kadar büyük olmalı */
$width = $im->getImageWidth() + 40;
$height = ($im->getImageHeight() * 2) + 30;
$canvas->newImage($width, $height, new ImagickPixel("black"));
$canvas->setImageFormat("png");

/* Her iki resmi tuval üzerinde birleştirelim */
$canvas->compositeImage($im, imagick::COMPOSITE_OVER, 20, 10);
$canvas->compositeImage($reflection, imagick::COMPOSITE_OVER,
        20, $im->getImageHeight() + 10);

/* Resmi çıktılayalım */
header("Content-Type: image/png");
echo $canvas;
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Aşağıdaki örnekte çizim sırasında örüntülerle resmin nasıl kaplandığı gösterilmiştir.

Örnek 4 - Metni bir örüntü ile kaplamak

<?php

/* Yeni bir resim nesnesi oluşturalım */
$im = new Imagick();

/* Örüntü olarak kullanılacak yeni resmi oluşturalım. */
$im->newPseudoImage(50, 50, "gradient:red-black");

/* Bir çizim nesnesi oluşturalım */
$draw = new ImagickDraw();

/* Örüntüyü "gradient" ismiyle oluşturalım */
$draw->pushPattern('gradient', 0, 0, 50, 50);

/* Örüntüyle maskeyi birleştirelim */
$draw->composite(Imagick::COMPOSITE_OVER, 0, 0, 50, 50, $im);

/* Örüntüyü kapatalım */
$draw->popPattern();

/* "gradient" örüntüsü ile resmi kaplayalım */
$draw->setFillPatternURL('#gradient');

/* Yazı tipi boyu 52 olsun */
$draw->setFontSize(52);

/* Bir şeyler yazalım */
$draw->annotation(20, 50, "Hello World!");

/* Beyaz zemine sahip bir tuval oluşturalım */
$canvas = new Imagick();
$canvas->newImage(350, 70, "white");

/* Çizimi tuvalin üzerine yerleştirelim */
$canvas->drawImage($draw);

/* Resme çerçeve olarak 1px kalınlığında siyah çizgi çizelim */
$canvas->borderImage('black', 1, 1);

/* Resmin dosya biçemi PNG olsun*/
$canvas->setImageFormat('png');

/* Resmi çıktılayalım */
header("Content-Type: image/png");
echo $canvas;
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Canlandırmalı GIF resimleri ile çalışmak.

Örnek 5 - GIF resmini okumak ve tüm kareleri boyutlandırmak

<?php

/* Yeni bir imagick nesnesi oluşturup GIF resmi okutalım */
$im = new Imagick("example.gif");

/* Tüm resim karelerini boyutlandıralım */
foreach ($im as $frame) {
 /* 50x50 kareler */
 $frame->thumbnailImage(50, 50);

 /* Sanal tuvali doğru boyuta ayarlayalım */
 $frame->setImagePage(50, 50, 0, 0);
}

/* writeImage yerine writeImages kullanıldığını dikkat edin */
$im->writeImages("example_small.gif", true);
?>

Örnekler
Imagick sınıfı
Örnekler
PHP Manual


Imagick sınıfı

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Sınıf Sözdizimi

Imagick implements Iterator , Traversable {
bool adaptiveBlurImage ( float $yarıçap , float $sapma [, int $kanal = Imagick::CHANNEL_DEFAULT ] )
bool adaptiveResizeImage ( int $genişlik , int $yükseklik [, bool $sığdır = false ] )
bool adaptiveSharpenImage ( float $yarıçap , float $sapma [, int $kanal = Imagick::CHANNEL_DEFAULT ] )
bool adaptiveThresholdImage ( int $genişlik , int $yükseklik , int $başlangıç )
bool addImage ( Imagick $kaynak )
bool addNoiseImage ( int $gürültü_türü [, int $kanal = Imagick::CHANNEL_DEFAULT ] )
bool affineTransformImage ( ImagickDraw $matris )
bool animateImages ( string $x_sunucusu )
bool annotateImage ( ImagickDraw $çizim_ayarı , float $x , float $y , float $açı , string $metin )
Imagick appendImages ( bool $yığıt )
public void autoLevelImage ([ string $CHANNEL = Imagick::CHANNEL_DEFAULT ] )
Imagick averageImages ( void )
bool blackThresholdImage ( mixed $threshold )
public void blueShiftImage ([ float $factor = 1.5 ] )
bool blurImage ( float $yarıçap , float $sapma [, int $kanal ] )
bool borderImage ( mixed $çerçeve_rengi , int $genişlik , int $yükseklik )
public void brightnessContrastImage ( string $brightness , string $contrast [, string $CHANNEL = Imagick::CHANNEL_DEFAULT ] )
bool charcoalImage ( float $yarıçap , float $sapma )
bool chopImage ( int $genişlik , int $yükseklik , int $x , int $y )
public void clampImage ([ string $CHANNEL = Imagick::CHANNEL_DEFAULT ] )
bool clear ( void )
bool clipImage ( void )
public void clipImagePath ( string $pathname , string $inside )
bool clipPathImage ( string $yol_adı , bool $içinde )
Imagick clone ( void )
bool clutImage ( Imagick $renk_tablosu [, float $kanal = Imagick::CHANNEL_DEFAULT ] )
Imagick coalesceImages ( void )
bool colorFloodfillImage ( mixed $dolgu , float $benzerlik , mixed $çerçeve_rengi , int $x , int $y )
bool colorizeImage ( mixed $renk , mixed $matlık )
public void colorMatrixImage ( string $color_matrix = Imagick::CHANNEL_DEFAULT )
Imagick combineImages ( int $kanal )
bool commentImage ( string $açıklama )
array compareImageChannels ( Imagick $resim , int $kanal , int $metrik )
Imagick compareImageLayers ( int $yöntem )
array compareImages ( Imagick $resim , int $metrik )
bool compositeImage ( Imagick $birleşik_nesne , int $işleç , int $x , int $y [, int $kanal = Imagick::CHANNEL_ALL ] )
Imagick __construct ([ mixed $dosyalar ] )
bool contrastImage ( bool $zıtlık )
bool contrastStretchImage ( float $siyah_nokta , float $beyaz_nokta [, int $kanal = Imagick::CHANNEL_ALL ] )
bool convolveImage ( array $çekirdek [, int $kanal = Imagick::CHANNEL_ALL ] )
public void count ([ string $mode ] )
bool cropImage ( int $genişlik , int $yükseklik , int $x , int $y )
bool cropThumbnailImage ( int $genişlik , int $yükseklik )
Imagick current ( void )
bool cycleColormapImage ( int $miktar )
bool decipherImage ( string $parola )
Imagick deconstructImages ( void )
bool deleteImageArtifact ( string $artifact )
public void deleteImageProperty ( string $name )
public bool deskewImage ( float $threshold )
bool despeckleImage ( void )
bool destroy ( void )
bool displayImage ( string $sunucu )
bool displayImages ( string $sunucu )
bool distortImage ( int $yöntem , array $değiştirgeler , bool $sığdır )
bool drawImage ( ImagickDraw $işlem )
bool edgeImage ( float $yarıçap )
bool embossImage ( float $yarıçap , float $sapma )
bool encipherImage ( string $parola )
bool enhanceImage ( void )
bool equalizeImage ( void )
bool evaluateImage ( int $işleç , float $terim [, int $kanal = Imagick::CHANNEL_ALL ] )
public array exportImagePixels ( int $x , int $y , int $width , int $height , string $map , int $STORAGE )
bool extentImage ( int $genişlik , int $yükseklik , int $x , int $y )
public void filter ( ImagickKernel $ImagickKernel [, int $CHANNEL = Imagick::CHANNEL_DEFAULT ] )
Imagick flattenImages ( void )
bool flipImage ( void )
bool floodFillPaintImage ( mixed $dolgu , float $benzerlik , mixed $hedef , int $x , int $y , bool $ters [, int $kanal = Imagick::CHANNEL_DEFAULT ] )
bool flopImage ( void )
public void forwardFourierTransformimage ( bool $magnitude )
bool frameImage ( mixed $mat_renk , int $genişlik , int $yükseklik , int $iç_pah , int $dış_pah )
public bool functionImage ( int $function , array $arguments [, int $channel = Imagick::CHANNEL_DEFAULT ] )
Imagick fxImage ( string $ifade [, int $kanal = Imagick::CHANNEL_ALL ] )
bool gammaImage ( float $gamma [, int $kanal = Imagick::CHANNEL_ALL ] )
bool gaussianBlurImage ( float $yarıçap , float $sapma [, int $kanal = Imagick::CHANNEL_ALL ] )
int getColorspace ( void )
int getCompression ( void )
int getCompressionQuality ( void )
string getCopyright ( void )
string getFilename ( void )
string getFont ( void )
string getFormat ( void )
int getGravity ( void )
string getHomeURL ( void )
Imagick getImage ( void )
int getImageAlphaChannel ( void )
string getImageArtifact ( string $artifact )
public string getImageAttribute ( string $key )
ImagickPixel getImageBackgroundColor ( void )
string getImageBlob ( void )
array getImageBluePrimary ( void )
ImagickPixel getImageBorderColor ( void )
int getImageChannelDepth ( int $kanal )
float getImageChannelDistortion ( Imagick $resim , int $kanal , int $metrik )
float getImageChannelDistortions ( Imagick $reference , int $metric [, int $channel = Imagick::CHANNEL_DEFAULT ] )
array getImageChannelExtrema ( int $kanal )
public array getImageChannelKurtosis ([ int $channel = Imagick::CHANNEL_DEFAULT ] )
array getImageChannelMean ( int $kanal )
array getImageChannelRange ( int $channel )
array getImageChannelStatistics ( void )
Imagick getImageClipMask ( void )
ImagickPixel getImageColormapColor ( int $indis )
int getImageColors ( void )
int getImageColorspace ( void )
int getImageCompose ( void )
int getImageCompression ( void )
int getCompressionQuality ( void )
int getImageDelay ( void )
int getImageDepth ( void )
int getImageDispose ( void )
float getImageDistortion ( Imagick $resim , int $metrik )
array getImageExtrema ( void )
string getImageFilename ( void )
string getImageFormat ( void )
float getImageGamma ( void )
array getImageGeometry ( void )
int getImageGravity ( void )
array getImageGreenPrimary ( void )
int getImageHeight ( void )
array getImageHistogram ( void )
int getImageIndex ( void )
int getImageInterlaceScheme ( void )
int getImageInterpolateMethod ( void )
int getImageIterations ( void )
int getImageLength ( void )
string getImageMagickLicense ( void )
int getImageMatte ( void )
ImagickPixel getImageMatteColor ( void )
public string getImageMimeType ( void )
int getImageOrientation ( void )
array getImagePage ( void )
ImagickPixel getImagePixelColor ( int $x , int $y )
string getImageProfile ( string $isim )
array getImageProfiles ([ string $şablon = "*" [, bool $sadece_isimler = true ]] )
array getImageProperties ([ string $şablon = "*" [, bool $sadece_isimler = true ]] )
string getImageProperty ( string $isim )
array getImageRedPrimary ( void )
Imagick getImageRegion ( int $genişlik , int $yükseklik , int $x , int $y )
int getImageRenderingIntent ( void )
array getImageResolution ( void )
string getImagesBlob ( void )
int getImageScene ( void )
string getImageSignature ( void )
int getImageSize ( void )
int getImageTicksPerSecond ( void )
float getImageTotalInkDensity ( void )
int getImageType ( void )
int getImageUnits ( void )
int getImageVirtualPixelMethod ( void )
array getImageWhitePoint ( void )
int getImageWidth ( void )
int getInterlaceScheme ( void )
int getIteratorIndex ( void )
int getNumberImages ( void )
string getOption ( string $anahtar )
string getPackageName ( void )
array getPage ( void )
ImagickPixelIterator getPixelIterator ( void )
ImagickPixelIterator getPixelRegionIterator ( int $x , int $y , int $genişlik , int $yükseklik )
string getPointSize ( void )
public static int getQuantum ( void )
array getQuantumDepth ( void )
array getQuantumRange ( void )
public static string getRegistry ( string $key )
string getReleaseDate ( void )
int getResource ( int $tür )
int getResourceLimit ( int $tür )
array getSamplingFactors ( void )
array getSize ( void )
int getSizeOffset ( void )
array getVersion ( void )
public bool haldClutImage ( Imagick $clut [, int $channel = Imagick::CHANNEL_DEFAULT ] )
bool hasNextImage ( void )
bool hasPreviousImage ( void )
public string|false identifyFormat ( string $embedText )
array identifyImage ([ bool $hamÇıktıEkle = false ] )
bool implodeImage ( float $yarıçap )
public bool importImagePixels ( int $x , int $y , int $width , int $height , string $map , int $storage , array $pixels )
public void inverseFourierTransformImage ( string $complement , string $magnitude )
bool labelImage ( string $yafta )
bool levelImage ( float $siyah_nokta , float $gamma , float $beyaz_nokta [, int $kanal = Imagick::CHANNEL_ALL ] )
bool linearStretchImage ( float $siyah_nokta , float $beyaz_nokta )
bool liquidRescaleImage ( int $genişlik , int $yükseklik , float $delta_x , float $diklik )
public static array listRegistry ( void )
bool magnifyImage ( void )
bool mapImage ( Imagick $resim , bool $kıpırtı )
bool matteFloodfillImage ( float $alfa , float $benzerlik , mixed $çerçeve_rengi , int $x , int $y )
bool medianFilterImage ( float $yarıçap )
bool mergeImageLayers ( int $katman_yöntemi )
bool minifyImage ( void )
bool modulateImage ( float $parlaklık , float $doygunluk , float $sıcaklık )
Imagick montageImage ( ImagickDraw $nesne , string $döşeme_geometrisi , string $örnek_geometrisi , int $kip , string $çerçeve )
Imagick morphImages ( int $kare_sayısı )
public void morphology ( int $morphologyMethod , int $iterations , ImagickKernel $ImagickKernel [, string $CHANNEL ] )
Imagick mosaicImages ( void )
bool motionBlurImage ( float $yarıçap , float $sapma , float $açı [, int $kanal = Imagick::CHANNEL_DEFAULT ] )
bool negateImage ( bool $gri_tonlama [, int $kanal = Imagick::CHANNEL_ALL ] )
bool newImage ( int $genişlik , int $yükseklik , mixed $artalan [, string $biçem ] )
bool newPseudoImage ( int $genişlik , int $yükseklik , string $sözde_dizge )
bool nextImage ( void )
bool normalizeImage ([ int $kanal ] )
bool oilPaintImage ( float $yarıcap )
bool opaquePaintImage ( mixed $hedef , mixed $renk , float $benzerlik , bool $ters [, int $kanal = Imagick::CHANNEL_DEFAULT ] )
bool optimizeImageLayers ( void )
bool orderedPosterizeImage ( string $eşik_eşlemi [, int $kanal = Imagick::CHANNEL_ALL ] )
bool paintFloodfillImage ( mixed $dolgu , float $benzerlik , mixed $çerçeve_rengi , int $x , int $y [, int $kanal = Imagick::CHANNEL_ALL ] )
bool paintOpaqueImage ( mixed $eskisi , mixed $yenisi , float $benzerlik [, int $kanal = Imagick::CHANNEL_ALL ] )
bool paintTransparentImage ( mixed $hedef , float $alfa , float $benzerlik )
bool pingImage ( string $dosya )
bool pingImageBlob ( string $resim )
bool pingImageFile ( resource $dt [, string $dosya ] )
bool polaroidImage ( ImagickDraw $nesne , float $açı )
bool posterizeImage ( int $seviyeler , bool $kıpırtı )
bool previewImages ( int $preview )
bool previousImage ( void )
bool profileImage ( string $isim , string $profil )
bool quantizeImage ( int $renk_sayısı , int $renk_uzayı , int $ağaç_derinliği , bool $kıpırtı , bool $ölçme_hatası )
bool quantizeImages ( int $renk_sayısı , int $renk_uzayı , int $ağaç_derinliği , bool $kıpırtı , bool $ölçme_hatası )
array queryFontMetrics ( ImagickDraw $nesne , string $metin [, bool $çoksatırlı ] )
array queryFonts ([ string $şablon = "*" ] )
array queryFormats ([ string $şablon = "*" ] )
bool radialBlurImage ( float $açı [, int $kanal = Imagick::CHANNEL_ALL ] )
bool raiseImage ( int $genişlik , int $yükseklik , int $x , int $y , bool $çıkıntı )
bool randomThresholdImage ( float $düşük , float $yüksek [, int $kanal = Imagick::CHANNEL_ALL ] )
bool readImage ( string $dosya )
bool readImageBlob ( string $dizge [, string $dosya ] )
bool readImageFile ( resource $dt [, string $dosya ] )
public Imagick readImages ( string $filenames )
bool animateImages ( array $matris )
bool reduceNoiseImage ( float $yarıçap )
public bool remapImage ( Imagick $replacement , int $DITHER )
bool removeImage ( void )
string removeImageProfile ( string $isim )
bool render ( void )
bool resampleImage ( float $x_çözünürlüğü , float $y_çözünürlüğü , int $süzgeç , float $bulanıklık )
bool resetImagePage ( string $sayfa )
bool resizeImage ( int $genişlik , int $yükseklik , int $süzgeç , float $bulanıklık [, bool $sığdır = false ] )
bool rollImage ( int $x , int $y )
bool rotateImage ( mixed $artalan , float $açı )
public void rotationalBlurImage ( string $angle [, string $CHANNEL = Imagick::CHANNEL_DEFAULT ] )
bool roundCorners ( float $x_yarıçapı , float $y_yarıçapı [, float $vurgu_genişliği = 10 [, float $yer_değiştirme = 5 [, float $boyut_düzeltme = -6 ]]] )
bool sampleImage ( int $genişlik , int $yükseklik )
bool scaleImage ( int $genişlik , int $yükseklik [, bool $sığdır = false ] )
public bool segmentImage ( int $COLORSPACE , float $cluster_threshold , float $smooth_threshold [, bool $verbose = false ] )
public void selectiveBlurImage ( float $radius , float $sigma , float $threshold , int $CHANNEL )
bool separateImageChannel ( int $kanal )
bool sepiaToneImage ( float $eşik )
bool setBackgroundColor ( mixed $renk )
bool setColorspace ( int $COLORSPACE )
bool setCompression ( int $sıkıştırma )
bool setCompressionQuality ( int $seviye )
bool setFilename ( string $dosya )
bool setFirstIterator ( void )
bool setFont ( string $yazıtipi )
bool setFormat ( string $biçem )
bool setGravity ( int $gravity )
bool setImage ( Imagick $yenisi )
bool setImageAlphaChannel ( int $kip )
bool setImageArtifact ( string $artifact , string $value )
public void setImageAttribute ( string $key , string $value )
bool setImageBackgroundColor ( mixed $renk )
bool setImageBias ( float $sapma )
public void setImageBiasQuantum ( string $bias )
bool setImageBluePrimary ( float $x , float $y )
bool setImageBorderColor ( mixed $renk )
bool setImageChannelDepth ( int $kanal , int $derinlik )
bool setImageClipMask ( Imagick $kırpıcı_resim )
bool setImageColormapColor ( int $indis , ImagickPixel $renk )
bool setImageColorspace ( int $renk_uzayı )
bool setImageCompose ( int $işleç )
bool setImageCompression ( int $sıkıştırma )
bool setImageCompressionQuality ( int $seviye )
bool setImageDelay ( int $gecikme )
bool setImageDepth ( int $derinlik )
bool setImageDispose ( int $yöntem )
bool setImageExtent ( int $genişlik , int $yükseklik )
bool setImageFilename ( string $dosya )
bool setImageFormat ( string $biçem )
bool setImageGamma ( float $gamma )
bool setImageGravity ( int $gravity )
bool setImageGreenPrimary ( float $x , float $y )
bool setImageIndex ( int $indis )
bool setImageInterlaceScheme ( int $geçişim_şeması )
bool setImageInterpolateMethod ( int $yöntem )
bool setImageIterations ( int $yineleme )
bool setImageMatte ( bool $matlık )
bool setImageMatteColor ( mixed $şeffaf_renk )
bool setImageOpacity ( float $matlık )
bool setImageOrientation ( int $baskı_yönü )
bool setImagePage ( int $genişlik , int $yükseklik , int $x , int $y )
bool setImageProfile ( string $isim , string $profil )
bool setImageProperty ( string $isim , string $değer )
bool setImageRedPrimary ( float $x , float $y )
bool setImageRenderingIntent ( int $uygulama_tarzı )
bool setImageResolution ( float $x_çözünürlüğü , float $y_çözünürlüğü )
bool setImageScene ( int $dekor )
bool setImageTicksPerSecond ( int $tik_hızı )
bool setImageType ( int $resim_türü )
bool setImageUnits ( int $birimler )
bool setImageVirtualPixelMethod ( int $yöntem )
bool setImageWhitePoint ( float $x , float $y )
bool setInterlaceScheme ( int $geçişim_şeması )
bool setIteratorIndex ( int $indis )
bool setLastIterator ( void )
bool setOption ( string $anahtar , string $değer )
bool setPage ( int $genişlik , int $yükseklik , int $x , int $y )
bool setPointSize ( float $punto )
public void setProgressMonitor ( callable $callback )
public static void setRegistry ( string $key , string $value )
bool setResolution ( float $x_çözünürlüğü , float $y_çözünürlüğü )
bool setResourceLimit ( int $özkaynak , int $sınır )
bool setSamplingFactors ( array $çarpanlar )
bool setSize ( int $sütun , int $satır )
bool setSizeOffset ( int $sütun , int $satır , int $başlangıç )
bool setType ( int $resim_türü )
bool shadeImage ( bool $gri , float $başucu , float $yükseliş )
bool shadowImage ( float $matlık , float $sapma , int $x , int $y )
bool sharpenImage ( float $yarıçap , float $sapma [, int $kanal = Imagick::CHANNEL_ALL ] )
bool shaveImage ( int $sütun , int $satır )
bool shearImage ( mixed $artalan , float $x_kaykılması , float $y_kaykılması )
bool sigmoidalContrastImage ( bool $netleştir , float $zıtlık , float $aradeğer [, int $kanal = Imagick::CHANNEL_ALL ] )
bool sketchImage ( float $yarıçap , float $sapma , float $açı )
public Imagick smushImages ( string $stack , string $offset )
bool solarizeImage ( int $eşik )
public bool sparseColorImage ( int $SPARSE_METHOD , array $arguments [, int $channel = Imagick::CHANNEL_DEFAULT ] )
bool spliceImage ( int $genişlik , int $yükseklik , int $x , int $y )
bool spreadImage ( float $yarıçap )
public void statisticImage ( int $type , int $width , int $height [, string $CHANNEL = Imagick::CHANNEL_DEFAULT ] )
Imagick steganoImage ( Imagick $filigran , int $konum )
bool stereoImage ( Imagick $resim )
bool stripImage ( void )
public Imagick subImageMatch ( Imagick $Imagick [, array &$offset [, float &$similarity ]] )
bool swirlImage ( float $açı )
bool textureImage ( Imagick $doku_kalemi )
bool thresholdImage ( float $eşik [, int $kanal = Imagick::CHANNEL_ALL ] )
bool thumbnailImage ( int $sütun , int $satır [, bool $sığdır = false ] )
bool tintImage ( mixed $ton , mixed $matlık )
string __toString ( void )
Imagick transformImage ( string $budama , string $geometri )
bool transformImageColorspace ( int $colorspace )
bool transparentPaintImage ( mixed $hedef , float $şeffaflık , float $benzerlik , bool $ters )
bool transposeImage ( void )
bool transverseImage ( void )
bool trimImage ( float $benzerlik )
bool uniqueImageColors ( void )
bool unsharpMaskImage ( float $yarıçap , float $sapma , float $miktar , float $eşik [, int $kanal = Imagick::CHANNEL_ALL ] )
bool valid ( void )
bool vignetteImage ( float $siyahNokta , float $beyazNokta , int $x , int $y )
bool waveImage ( float $genlik , float $dalga_boyu )
bool whiteThresholdImage ( mixed $eşik )
bool writeImage ([ string $dosya ] )
bool writeImageFile ( resource $dt )
bool writeImages ( string $dosya , bool $bitişik )
bool writeImagesFile ( resource $dt )
}

Resim Yöntemleri ve küresel yöntemler

Imagick sınıfı çok sayıda resmi aynı anda işleme yeteneğine sahiptir. Bu dahili bir yığıt kullanılarak sağlanır. Daima üzerinde çalışılan resmi gösteren bir dahili gösterici vardır. İşlevlerin çoğu sadece yığıttaki geçerli resim üzerinde işlem yaparken, bazıları da Imagick sınıfının tüm resimleri üzerinde işlem yapar. Bir uzlaşım olarak, sadece yığıttaki geçerli resmi etkileyen yöntemlerin isimlerinde Image sözcüğü bulunabilir.

Sınıf yöntemleri

Çok sayıda yöntem olduğundan bunları kullanım amaçlarına göre sınıflayarak listelemek daha iyi olacak:

Kullanım Amacına göre Sınıf yöntemleri
Resim Etkileri | Veri Alma Yöntemleri | Veri Atama Yöntemleri | Resimlerin Okunması ve Yazılması | Diğer İşlemler
Imagick::adaptiveBlurImage() | Imagick::getCompression() | Imagick::setBackgroundColor() | Imagick::__construct() | Imagick::clear()
Imagick::adaptiveResizeImage() | Imagick::getFilename() | Imagick::setCompressionQuality() | Imagick::addImage() | Imagick::clone()
Imagick::adaptiveSharpenImage() | Imagick::getFormat() | Imagick::setCompression() | Imagick::appendImages() | Imagick::current()
Imagick::adaptiveTresholdImage() | Imagick::getImageBackgroundColor() | Imagick::setFilename() | Imagick::getFilename() | Imagick::destroy()
Imagick::addNoiseImage() | Imagick::getImageBlob() | Imagick::getImagesBlob() | Imagick::setFormat() | Imagick::getFormat() | Imagick::getCopyright()
Imagick::affinetransformimage() | Imagick::getImageBluePrimary() | Imagick::setImageBackgroundColor() | Imagick::getImageFilename() | Imagick::getFormat()
Imagick::annotateImage() | Imagick::getImageBorderColor() | Imagick::setFirstIterator() | Imagick::getImageFormat() | Imagick::getHomeURL()
Imagick::averageImages() | Imagick::getImageChannelDepth() | Imagick::setImageBias() | Imagick::getImage() | Imagick::commentImage()
Imagick::blackThresholdImage() | Imagick::getImageChannelDistortion() | Imagick::setImageBluePrimary() | Imagick::setImageFilename() | Imagick::getNumberImages()
Imagick::blurImage() | Imagick::getImageChannelExtrema() | Imagick::setImageBorderColor() | Imagick::setImageFormat() | Imagick::getReleaseDate()
Imagick::borderImage() | Imagick::getImageChannelMean() | Imagick::setImageChannelDepth() | Imagick::readImageFile() | Imagick::getVersion()
Imagick::charcoalImage() | Imagick::getImageChannelStatistics() | Imagick::setImageColormapColor() | Imagick::readImage() | Imagick::hasNextImage()
Imagick::chopImage() | Imagick::getImageColormapColor() | Imagick::setImageColorSpace() | Imagick::writeImages() | Imagick::hasPreviousImage()
Imagick::clipImage() | Imagick::getImageColorspace() | Imagick::setImageCompose() | Imagick::writeImage() | Imagick::labelImage()
Imagick::clipPathImage() | Imagick::getImageColors() | Imagick::setImageCompression() |  | Imagick::newImage()
Imagick::coalesceImages() | Imagick::getImageCompose() | Imagick::setImageDelay() |  | Imagick::newPseudoImage()
Imagick::colorFloodFillImage() | Imagick::getImageDelay() | Imagick::setImageDepth() |  | Imagick::nextImage()
Imagick::colorizeImage() | Imagick::getImageDepth() | Imagick::setImageDispose() |  | Imagick::pingImageBlob()
Imagick::combineImages() | Imagick::getImageDispose() | Imagick::setImageDispose() |  | Imagick::pingImageFile()
Imagick::compareImageChannels() | Imagick::getImageDistortion() | Imagick::setImageExtent() |  | Imagick::pingImage()
Imagick::compareImageLayers() | Imagick::getImageExtrema() | Imagick::setImageFilename() |  | Imagick::previousImage()
Imagick::compositeImage() | Imagick::getImageFilename() | Imagick::setImageFormat() |  | Imagick::profileImage()
Imagick::contrastImage() | Imagick::getImageFormat() | Imagick::setImageGamma() |  | Imagick::queryFormats()
Imagick::constrastStretchImage() | Imagick::getImageGamma() | Imagick::setImageGreenPrimary() |  | Imagick::removeImageProfile()
Imagick::convolveImage() | Imagick::getImageGeometry() | Imagick::setImageIndex() |  | Imagick::removeImage()
Imagick::cropImage() | Imagick::getImageGreenPrimary() | Imagick::setImageInterpolateMethod() |  | Imagick::setFirstIterator()
Imagick::cycleColormapImage() | Imagick::getImageHeight() | Imagick::setImageIterations() |  | Imagick::setImageIndex()
Imagick::deconstructImages() | Imagick::getImageHistogram() | Imagick::setImageMatteColor() |  | Imagick::valid()
Imagick::drawImage() | Imagick::getImageIndex() | Imagick::setImageMatte() |  |
Imagick::edgeImage() | Imagick::getImageInterlaceScheme() | Imagick::setImagePage() |  |
Imagick::embossImage() | Imagick::getImageInterpolateMethod() | Imagick::setImageProfile() |  |
Imagick::enhanceImage() | Imagick::getImageIterations() | Imagick::setImageProperty() |  |
Imagick::equalizeImage() | Imagick::getImageMatteColor() | Imagick::setImageRedPrimary() |  |
Imagick::evaluateImage() | Imagick::getImageMatte() | Imagick::setImageRenderingIntent() |  |
Imagick::flattenImages() | Imagick::getImagePage() | Imagick::setImageResolution() |  |
Imagick::flipImage() | Imagick::getImagePixelColor() | Imagick::setImageScene() |  |
Imagick::flopImage() | Imagick::getImageProfile() | Imagick::setImageTicksPerSecond() |  |
Imagick::imageImage() | Imagick::getImageProperty() | Imagick::setImageType() |  |
Imagick::fxImage() | Imagick::getImageRedPrimary() | Imagick::setImageUnits() |  |
Imagick::gammaImage() | Imagick::getImageRegion() | Imagick::setImageVirtualPixelMethod() |  |
Imagick::gaussianBlurImage() | Imagick::getImageRenderingIntent() | Imagick::setImageWhitepoint() |  |
Imagick::implodeImage() | Imagick::getImageResolution() | Imagick::setInterlaceScheme() |  |
Imagick::levelImage() | Imagick::getImageScene() | Imagick::setOption() |  |
Imagick::linearStretchImage() | Imagick::getImageSignature() | Imagick::setPage() |  |
Imagick::magnifyImage() | Imagick::getImageTicksPerSecond() | Imagick::setResolution() |  |
Imagick::matteFloodFilleImage() | Imagick::getImageTotalInkDensity() | Imagick::setResourceLimit() |  |
Imagick::medianFilterImage() | Imagick::getImageType() | Imagick::setSamplingFactors() |  |
Imagick::minifyImage() | Imagick::getImageUnits() | Imagick::setSizeOffset() |  |
Imagick::modulateImage() | Imagick::getImageVirtualPixelMethod() | Imagick::setSize() |  |
Imagick::montageImage() | Imagick::getImageWhitepoint() | Imagick::setType() |  |
Imagick::morphImages() | Imagick::getImageWidth() |  |  |
Imagick::mosaicImages() | Imagick::getImage() |  |  |
Imagick::motionBlurImage() | Imagick::getInterlaceScheme() |  |  |
Imagick::negateImage() | Imagick::getNumberImages() |  |  |
Imagick::normalizeImage() | Imagick::getOption() |  |  |
Imagick::oilPaintImage() | Imagick::getPackageName() |  |  |
Imagick::optimizeImageLayers() | Imagick::getPage() |  |  |
Imagick::paintOpaqueImage() | Imagick::getPixelIterator() |  |  |
Imagick::paintTransparentImage() | Imagick::getPixelRegionIterator() |  |  |
Imagick::posterizeImage() | Imagick::getQuantumDepth() |  |  |
Imagick::radialBlurImage() | Imagick::getQuantumRange() |  |  |
Imagick::raiseImage() | Imagick::getResourceLimit() |  |  |
Imagick::randomThresholdImage() | Imagick::getResource() |  |  |
Imagick::reduceNoiseImage() | Imagick::getSamplingFactors() |  |  |
Imagick::render() | Imagick::getSizeOffset() |  |  |
Imagick::resampleImage() | Imagick::getSize() |  |  |
Imagick::resizeImage() | Imagick::identifyImage() |  |  |
Imagick::rollImage() | Imagick::getImageSize() |  |  |
Imagick::rotateImage() |  |  |  |
Imagick::sampleImage() |  |  |  |
Imagick::scaleImage() |  |  |  |
Imagick::separateImageChannel() |  |  |  |
Imagick::sepiaToneImage() |  |  |  |
Imagick::shadeImage() |  |  |  |
Imagick::shadowImage() |  |  |  |
Imagick::sharpenImage() |  |  |  |
Imagick::shaveImage() |  |  |  |
Imagick::shearImage() |  |  |  |
Imagick::sigmoidalContrastImage() |  |  |  |
Imagick::sketchImage() |  |  |  |
Imagick::solarizeImage() |  |  |  |
Imagick::spliceImage() |  |  |  |
Imagick::spreadImage() |  |  |  |
Imagick::steganoImage() |  |  |  |
Imagick::stereoImage() |  |  |  |
Imagick::stripImage() |  |  |  |
Imagick::swirlImage() |  |  |  |
Imagick::textureImage() |  |  |  |
Imagick::thresholdImage() |  |  |  |
Imagick::thumbnailImage() |  |  |  |
Imagick::tintImage() |  |  |  |
Imagick::transverseImage() |  |  |  |
Imagick::trimImage() |  |  |  |
Imagick::uniqueImageColors() |  |  |  |
Imagick::unsharpMaskImage() |  |  |  |
Imagick::vignetteImage() |  |  |  |
Imagick::waveImage() |  |  |  |
Imagick::whiteThresholdImage() |  |  |  |

İçindekiler

  • Imagick::adaptiveBlurImage — Resmi uyarlamalı olarak bulanıklaştırır
  • Imagick::adaptiveResizeImage — Nirengi noktasına göre uyarlamalı olarak resmi boyutlandırır
  • Imagick::adaptiveSharpenImage — Uyarlamalı olarak resmi netleştirir
  • Imagick::adaptiveThresholdImage — Bir yoğunluk aralığına göre her piksel için bir eşik seçer
  • Imagick::addImage — Imagick resim listesine yeni bir resim ekler
  • Imagick::addNoiseImage — Resme rasgele gürültü ekler
  • Imagick::affineTransformImage — Resmi dönüştürür
  • Imagick::animateImages — Bir resmi veya resimleri canlandırır
  • Imagick::annotateImage — Resme bir metin çizer
  • Imagick::appendImages — Bir resim kümesini ekler
  • Imagick::autoLevelImage — Description
  • Imagick::averageImages — Bir resim kümesinin ortalamasını alır
  • Imagick::blackThresholdImage — Eşiğin altında kalan tüm renkleri siyaha çevirir
  • Imagick::blueShiftImage — Description
  • Imagick::blurImage — Resme bir bulanıklık süzgeci ekler
  • Imagick::borderImage — Resme bir çerçeve çizer
  • Imagick::brightnessContrastImage — Description
  • Imagick::charcoalImage — Kara kalem çizimi taklit eder
  • Imagick::chopImage — Bir resmin bir bölgesini silerek kırpar
  • Imagick::clampImage — Description
  • Imagick::clear — Imagick nesnesi ile ilgili tüm özkaynakları temizler
  • Imagick::clipImage — 8BIM profilindeki ilk yol boyunca resmi kırpar
  • Imagick::clipImagePath — Description
  • Imagick::clipPathImage — 8BIM profili boyunca isimli yolları kırpar
  • Imagick::clone — Imagick nesnesinin tam bir kopyasını yapar
  • Imagick::clutImage — Resmin renklerini değiştirir
  • Imagick::coalesceImages — Bir resim kümesini tek bir resim olarak birleştirir
  • Imagick::colorFloodfillImage — Hedefle eşleşen her pikselin rengini değiştirir
  • Imagick::colorizeImage — Resmin her pikseline dolgu rengini karıştırır
  • Imagick::colorMatrixImage — Description
  • Imagick::combineImages — Bir veya daha fazla resmi tek bir resim halinde birleştirir
  • Imagick::commentImage — Resme bir açıklama ekler
  • Imagick::compareImageChannels — Bir veya daha fazla resmin farkını döndürür
  • Imagick::compareImageLayers — Resim katmanlarını karşılaştırıp en iyilenmiş resmi döndürür
  • Imagick::compareImages — Resmi yeniden oluşturulan resimle karşılaştırır
  • Imagick::compositeImage — Bir resmi diğeriyle birleştirir
  • Imagick::__construct — Imagick kurucusu
  • Imagick::contrastImage — Resmin zıtlığını değiştirir
  • Imagick::contrastStretchImage — Renkli bir resmin zıtlığını ayarlar
  • Imagick::convolveImage — Resme bir evrişim çekirdeği uygular
  • Imagick::count — Description
  • Imagick::cropImage — Resmin bir bölgesini çıkarır
  • Imagick::cropThumbnailImage — Resmin kırpık bir örneğini oluşturur
  • Imagick::current — Geçerli Imagick nesnesini döndürür
  • Imagick::cycleColormapImage — Bir resmin renk eşleminin bir kısmını değiştirir
  • Imagick::decipherImage — Şifreli bir resmin şifresini çözer
  • Imagick::deconstructImages — Resimler arasındaki farklı piksellerin kapladığı en büyük alanı döndürür
  • Imagick::deleteImageArtifact — Delete image artifact
  • Imagick::deleteImageProperty — Description
  • Imagick::deskewImage — Removes skew from the image
  • Imagick::despeckleImage — Resmin benekli görünümünü düzeltir
  • Imagick::destroy — Imagick nesnesini siler
  • Imagick::displayImage — Bir resmi gösterir
  • Imagick::displayImages — Bir resim dizisini gösterir
  • Imagick::distortImage — Çeşitli yöntemlerle resmi bozunuma uğratır
  • Imagick::drawImage — Belirtilen ImagickDraw nesnesini resme uygular
  • Imagick::edgeImage — Resmin kenarlarını evriştirir
  • Imagick::embossImage — Üç boyutluluk etkisi vermek için resmi gri tonlamaya dönüştürür
  • Imagick::encipherImage — Bir resmi şifreler
  • Imagick::enhanceImage — Resmin görüntü kalitesini arttırır
  • Imagick::equalizeImage — Resmin renk dağılımını dengeler
  • Imagick::evaluateImage — Resme bir ifade uygular
  • Imagick::exportImagePixels — Exports raw image pixels
  • Imagick::extentImage — Resim boyutlarını belirler
  • Imagick::filter — Description
  • Imagick::flattenImages — Bir resim dizisini tek bir resim halinde üstüste bindirir
  • Imagick::flipImage — Resmin düşeydeki yansımasını oluşturur
  • Imagick::floodFillPaintImage — Hedefle eşleşen piksellerin renklerini değiştirir
  • Imagick::flopImage — Resmin yataydaki yansımasını oluşturur
  • Imagick::forwardFourierTransformImage — Description
  • Imagick::frameImage — Üç boyutluluğu taklit ederek bir çerçeve ekler
  • Imagick::functionImage — Applies a function on the image
  • Imagick::fxImage — Bir ifadeyi resimdeki her piksele uygular
  • Imagick::gammaImage — Resmin gammasını düzeltir
  • Imagick::gaussianBlurImage — Resmi bulanıklaştırır
  • Imagick::getColorspace — Gets the colorspace
  • Imagick::getCompression — Nesnenin sıkıştırma türünü döndürür
  • Imagick::getCompressionQuality — Nesnenin sıkıştırma seviyesini döndürür
  • Imagick::getCopyright — ImageMagick telif hakkı bilgisini döndürür
  • Imagick::getFilename — Resim dizisi ile ilişkili dosya ismini döndürür
  • Imagick::getFont — Yazıtipini döndürür
  • Imagick::getFormat — Imagick nesnesinin biçemini döndürür
  • Imagick::getGravity — Gets the gravity
  • Imagick::getHomeURL — ImageMagick sitesinin adresini döndürür
  • Imagick::getImage — Yeni bir Imagick nesnesi döndürür
  • Imagick::getImageAlphaChannel — Gets the image alpha channel
  • Imagick::getImageArtifact — Get image artifact
  • Imagick::getImageAttribute — Description
  • Imagick::getImageBackgroundColor — Resmin artalan rengini döndürür
  • Imagick::getImageBlob — Resim dizisini ber ikil dizge olarak döndürür
  • Imagick::getImageBluePrimary — Resmin renk bileşenlerinden birincil mavi noktayı döndürür
  • Imagick::getImageBorderColor — Resmin çerçeve rengini döndürür
  • Imagick::getImageChannelDepth — Belirtilen kanalın derinliğini döndürür
  • Imagick::getImageChannelDistortion — Resmin kanallarını yeniden oluşturulan bir resimle karşılaştırır
  • Imagick::getImageChannelDistortions — Gets channel distortions
  • Imagick::getImageChannelExtrema — Belirtilen kanalların uç değerlerini döndürür
  • Imagick::getImageChannelKurtosis — The getImageChannelKurtosis purpose
  • Imagick::getImageChannelMean — Kanal ortalama ve standart sapmasını döndürür
  • Imagick::getImageChannelRange — Gets channel range
  • Imagick::getImageChannelStatistics — Resimdeki her kanalın istatistiklerini döndürür
  • Imagick::getImageClipMask — Resim kırpma maskesini döndürür
  • Imagick::getImageColormapColor — Renk eşlemi indisi belirtilen rengi döndürür
  • Imagick::getImageColors — Resimdeki eşsiz renklerin sayısını döndürür
  • Imagick::getImageColorspace — Resmin renk uzayını döndürür
  • Imagick::getImageCompose — Resimle ilgili birleştirme işlecini döndürür
  • Imagick::getImageCompression — Resmin sıkıştırma türünü döndürür
  • Imagick::getImageCompressionQuality — Resmin sıkıştırma seviyesini döndürür
  • Imagick::getImageDelay — Resim gecikmesini döndürür
  • Imagick::getImageDepth — Resim derinliğini döndürür
  • Imagick::getImageDispose — Resmin elden çıkarma yöntemini döndürür
  • Imagick::getImageDistortion — Resmi yeniden oluşturulmuş bir resimle karşılaştırır
  • Imagick::getImageExtrema — Resimle ilgili uç değerleri döndürür
  • Imagick::getImageFilename — Bir resim dizisindeki belli bir resmin dosya ismini döndürür
  • Imagick::getImageFormat — Bir resim dizisindeki belli bir resmin biçemini döndürür
  • Imagick::getImageGamma — Resmin gammasını döndürür
  • Imagick::getImageGeometry — Resmin genişliğini ve yüksekliğini bir ilişkisel dizi olarak döndürür
  • Imagick::getImageGravity — Gets the image gravity
  • Imagick::getImageGreenPrimary — Resmin renk bileşenlerinden birincil yeşil noktayı döndürür
  • Imagick::getImageHeight — Resmin yüksekliğini döndürür
  • Imagick::getImageHistogram — Resmin renk dağılımını döndürür
  • Imagick::getImageIndex — Geçerli etkin resmin indisini döndürür
  • Imagick::getImageInterlaceScheme — Resmin geçişim şemasını döndürür
  • Imagick::getImageInterpolateMethod — Aradeğerleme yöntemini döndürür
  • Imagick::getImageIterations — Resim yineleme sayısını döndürür
  • Imagick::getImageLength — Resim uzunluğunu döndürür
  • Imagick::getImageMagickLicense — ImageMagick lisans bilgisini içeren bir dizge döndürür
  • Imagick::getImageMatte — Resmin bir matlık kanalı varsa TRUE döndürür
  • Imagick::getImageMatteColor — Resmin matlık rengini döndürür
  • Imagick::getImageMimeType — Description
  • Imagick::getImageOrientation — Resim baskı yönünü döndürür
  • Imagick::getImagePage — Sayfa geometrisini döndürür
  • Imagick::getImagePixelColor — Belirtilen pikselin rengini döndürür
  • Imagick::getImageProfile — İsimli resim profilini döndürür
  • Imagick::getImageProfiles — Resim profillerini döndürür
  • Imagick::getImageProperties — Resim özelliklerini döndürür
  • Imagick::getImageProperty — İsimli resim özelliğini döndürür
  • Imagick::getImageRedPrimary — Resmin renk bileşenlerinden birincil kırmızı noktasını döndürür
  • Imagick::getImageRegion — Resmin bir bölgesini çıkarır
  • Imagick::getImageRenderingIntent — Resme komutların uygulanış tarzını döndürür
  • Imagick::getImageResolution — Resmin X ve Y çözünürlüklerini döndürür
  • Imagick::getImagesBlob — Tüm resim dizilerini bir ikil dizge olarak döndürür
  • Imagick::getImageScene — Resmin artalan dekorunu döndürür
  • Imagick::getImageSignature — Resmin SHA-256 ileti özetini üretir
  • Imagick::getImageSize — Resim uzunluğunu bayt cinsinden döndürür
  • Imagick::getImageTicksPerSecond — Resmin saniyedeki tik sayısını döndürür
  • Imagick::getImageTotalInkDensity — Resmin belli bir renginin toplam yoğunluğunu döndürür
  • Imagick::getImageType — Olası resim türünü döndürür
  • Imagick::getImageUnits — Resim çözünürlük birimlerini döndürür
  • Imagick::getImageVirtualPixelMethod — Sanal piksel yöntemini döndürür
  • Imagick::getImageWhitePoint — Resmin renk bileşenlerinden beyaz noktayı döndürür
  • Imagick::getImageWidth — Resim genişliğini döndürür
  • Imagick::getInterlaceScheme — Nesne geçişim şemasını döndürür
  • Imagick::getIteratorIndex — Geçerli etkin resmin indisini döndürür
  • Imagick::getNumberImages — Nesnedeki resim sayısını döndürür
  • Imagick::getOption — Belirtilen anahtarla ilgili değeri döndürür
  • Imagick::getPackageName — ImageMagick paket ismini döndürür
  • Imagick::getPage — Sayfa geometrisini döndürür
  • Imagick::getPixelIterator — Bir MagickPixelIterator nesnesi döndürür
  • Imagick::getPixelRegionIterator — Bir resim bölümü için bir ImagickPixelIterator nesnesi döndürür
  • Imagick::getPointSize — Punto değerini döndürür
  • Imagick::getQuantum — Description
  • Imagick::getQuantumDepth — Parçacık derinliğini döndürür
  • Imagick::getQuantumRange — Imagick parçacık aralığını döndürür
  • Imagick::getRegistry — Description
  • Imagick::getReleaseDate — ImageMagick dağıtım tarihini döndürür
  • Imagick::getResource — Belirtilen özkaynağın bellek kullanımını döndürür
  • Imagick::getResourceLimit — Belirtilen özkaynağın bellek kullanım sınırını döndürür
  • Imagick::getSamplingFactors — Yatay ve düşey örnekleme katsayısını döndürür
  • Imagick::getSize — Imagick nesnesi ile ilgili boyutları döndürür
  • Imagick::getSizeOffset — Boyut başlangıç noktasını döndürür
  • Imagick::getVersion — ImageMagick API sürümünü döndürür
  • Imagick::haldClutImage — Replaces colors in the image
  • Imagick::hasNextImage — Resmin sonrasında bir resim daha var mı diye bakar
  • Imagick::hasPreviousImage — Resmin öncesinde bir resim daha var mı diye bakar
  • Imagick::identifyFormat — Description
  • Imagick::identifyImage — Resmin özniteliklerini döndürerek resmi tanımlar
  • Imagick::implodeImage — Resmi kopyalamak suretiyle yeni bir resim oluşturur
  • Imagick::importImagePixels — Imports image pixels
  • Imagick::inverseFourierTransformImage — Description
  • Imagick::labelImage — Resme bir yafta ekler
  • Imagick::levelImage — Bir resmin seviyelerini ayarlar
  • Imagick::linearStretchImage — Resmin koyuluğunu doygunluk ile abartır
  • Imagick::liquidRescaleImage — Bir resmi veya resimleri canlandırır
  • Imagick::listRegistry — Description
  • Imagick::magnifyImage — Enboy oranını koruyarak resmi iki katına büyütür
  • Imagick::mapImage — Resmin renklerini belirtilen resimdeki en yakın renklerle değiştirir
  • Imagick::matteFloodfillImage — Bir rengin şeffaflık değerini değiştirir
  • Imagick::medianFilterImage — Resme bir sayısal süzgeç uygular
  • Imagick::mergeImageLayers — Resim katmanlarını katıştırır
  • Imagick::minifyImage — Enboy oranını koruyarak resmi yarı boyutuna indirir
  • Imagick::modulateImage — Resmin parlaklık, doygunluk ve renk sıcaklığını denetler
  • Imagick::montageImage — Birleşik bir resim oluşturur
  • Imagick::morphImages — Bir resim dizisini başkalaşıma uğratır
  • Imagick::morphology — Description
  • Imagick::mosaicImages — Resimlerden bir mozaik oluşturur
  • Imagick::motionBlurImage — Hareket bulanıklığını taklit eder
  • Imagick::negateImage — Resmin renklerini negatiflerine dönüştürür
  • Imagick::newImage — Yeni bir resim oluşturur
  • Imagick::newPseudoImage — Yeni bir resim oluşturur
  • Imagick::nextImage — Bir sonraki resme gider
  • Imagick::normalizeImage — Renkli bir resmin zıtlığını arttırır
  • Imagick::oilPaintImage — Yağlı boya resmi taklit eder
  • Imagick::opaquePaintImage — Hedef ile eşleşen piksellerin rengini değiştirir
  • Imagick::optimizeImageLayers — En iyilemek amacıyla resimlerin tekrarlanan bölümlerini siler
  • Imagick::orderedPosterizeImage — Resme kurallı titreklik uygular
  • Imagick::paintFloodfillImage — Belirtilen renkle eşleşen piksellerin rengini değiştirir
  • Imagick::paintOpaqueImage — Bir rengi bir başka renkle değiştirir
  • Imagick::paintTransparentImage — Resimdeki belli bir rengi dolgu rengiyle değiştirir
  • Imagick::pingImage — Temel resim özniteliklerini bir dosyadan okur
  • Imagick::pingImageBlob — Temel resim özniteliklerini bir dizgeden okur
  • Imagick::pingImageFile — Temel resim özniteliklerini bir akımdan okur
  • Imagick::polaroidImage — Polaroid resmi taklit eder
  • Imagick::posterizeImage — Resimdeki renkleri belli bir sayıya düşürür
  • Imagick::previewImages — Resim üzerinde yapılacak bir işlem için en uygun değiştirgenin tespitini hızlandırır
  • Imagick::previousImage — Bir önceki resme gider
  • Imagick::profileImage — Bir resme profil ekler veya çıkarır
  • Imagick::quantizeImage — Belli bir resim içindeki renk miktarını bulur
  • Imagick::quantizeImages — Bir resim kümesi içindeki renk miktarını bulur
  • Imagick::queryFontMetrics — Yazı tipinin özelliklerini içeren bir dizi döndürür
  • Imagick::queryFonts — Yapılandırımış yazı tiplerini döndürür
  • Imagick::queryFormats — Imagick tarafından desteklenen biçemleri döndürür
  • Imagick::radialBlurImage — Bir resme dairesel bulanıklık uygular
  • Imagick::raiseImage — 3 boyutlu düğme benzeri bir etki oluşturur
  • Imagick::randomThresholdImage — Yüksek zıtlığa sahip iki renkli bir resim oluşturur
  • Imagick::readImage — Resmi dosyadar okur
  • Imagick::readImageBlob — Resmi ikil bir dizgeden okur
  • Imagick::readImageFile — Resmi akımdan okur
  • Imagick::readimages — Description
  • Imagick::recolorImage — Resmi yeniden renklendirir
  • Imagick::reduceNoiseImage — Bir resmin dış hatlarını yumuşatır
  • Imagick::remapImage — Remaps image colors
  • Imagick::removeImage — Resim kümesinden bir resim siler
  • Imagick::removeImageProfile — İsimli resim profilini silip döndürür
  • Imagick::render — Evvelce verilmiş tüm çizim komutlarını uygular
  • Imagick::resampleImage — Belirtilen çözünürlüğe göre resmi yeniden örnekler
  • Imagick::resetImagePage — Resim sayfasını sıfırlar
  • Imagick::resizeImage — Bir resmi boyutlandırır
  • Imagick::rollImage — Bir resmin başlangıç noktasını tanımlar
  • Imagick::rotateImage — Resmi döndürür
  • Imagick::rotationalBlurImage — Description
  • Imagick::roundCorners — Resmin köşelerini yuvarlatır
  • Imagick::sampleImage — Resmi piksel örneklemeyle oranlar
  • Imagick::scaleImage — Bir resmin enboy oranını ayarlar
  • Imagick::segmentImage — Segments an image
  • Imagick::selectiveBlurImage — Description
  • Imagick::separateImageChannel — Resimden bir kanalı ayırır
  • Imagick::sepiaToneImage — Resme kızıl kahverengi tonlama uygular
  • Imagick::setBackgroundColor — Nesnenin öntanımlı artalan rengini tanımlar
  • Imagick::setColorspace — Set colorspace
  • Imagick::setCompression — Nesnenin öntanımlı sıkıştırma türünü tanımlar
  • Imagick::setCompressionQuality — Nesnenin öntanımlı sıkıştırma seviyesini tanımlar
  • Imagick::setFilename — Bir resim için dosya ismi tanımlar
  • Imagick::setFirstIterator — Imagick yineleyiciyi ilk resme konumlar
  • Imagick::setFont — Imagick nesnesinin yazı tipini tanımlar
  • Imagick::setFormat — Imagick nesnesinin biçemini tanımlar
  • Imagick::setGravity — Sets the gravity
  • Imagick::setImage — Nesnedeki resmi değiştirir
  • Imagick::setImageAlphaChannel — Resmin şeffaflık kanalını tanımlar
  • Imagick::setImageArtifact — Set image artifact
  • Imagick::setImageAttribute — Description
  • Imagick::setImageBackgroundColor — Resmin artalan rengini tanımlar
  • Imagick::setImageBias — Bir resmi evriştirmekte kullanılan yöntem için resim sapmasını tanımlar
  • Imagick::setImageBiasQuantum — Description
  • Imagick::setImageBluePrimary — Resmin renk bileşenlerinden birincil mavi noktasını tanımlar
  • Imagick::setImageBorderColor — Resmin çerçeve rengini tanımlar
  • Imagick::setImageChannelDepth — Belli bir resim kanalının derinliğini tanımlar
  • Imagick::setImageClipMask — Resim kırpma maskesini tanımlar
  • Imagick::setImageColormapColor — Renk eşlemi indisi belirtilen rengi tanımlar
  • Imagick::setImageColorspace — Resmin renk uzayını tanımlar
  • Imagick::setImageCompose — Resim birleştirme işlecini tanımlar
  • Imagick::setImageCompression — Resim sıkıştırma seviyesini tanımlar
  • Imagick::setImageCompressionQuality — Resim sıkıştırma seviyesini belirler
  • Imagick::setImageDelay — Resim gecikmesini tanımlar
  • Imagick::setImageDepth — Resim derinliğini tanımlar
  • Imagick::setImageDispose — Resmin elden çıkarma yöntemini tanımlar
  • Imagick::setImageExtent — Resmin boyutlarını tanımlar
  • Imagick::setImageFilename — Belli bir resmin dosya ismini tanımlar
  • Imagick::setImageFormat — Belli bir resmin biçemini tanımlar
  • Imagick::setImageGamma — Resmin gammasını tanımlar
  • Imagick::setImageGravity — Sets the image gravity
  • Imagick::setImageGreenPrimary — Resmin renk bileşenlerinden birincil yeşil noktasını tanımlar
  • Imagick::setImageIndex — Yineleyici konumunu tanımlar
  • Imagick::setImageInterlaceScheme — Resim geçişim şemasını tanımlar
  • Imagick::setImageInterpolateMethod — Resmin aradeğer pikseli yöntemini tanımlar
  • Imagick::setImageIterations — Resim yineleme sayısını tanımlar
  • Imagick::setImageMatte — Resmin matlık kanalını ayarlar
  • Imagick::setImageMatteColor — Resmin şeffaf rengini tanımlar
  • Imagick::setImageOpacity — Resmin matlık seviyesini tanımlar
  • Imagick::setImageOrientation — Resmin baskı yönünü tanımlar
  • Imagick::setImagePage — Resmin sayfa geometrisini tanımlar
  • Imagick::setImageProfile — Imagick nesnesine isimli bir profil ekler
  • Imagick::setImageProperty — Bir resim özelliğini tanımlar
  • Imagick::setImageRedPrimary — Resmin renk bileşenlerinden birincil kırmızı noktasını tanımlar
  • Imagick::setImageRenderingIntent — Resme komutların uygulanış tarzını belirler
  • Imagick::setImageResolution — Resmin çözünürlüğünü ayarlar
  • Imagick::setImageScene — Resmin dekorunu tanımlar
  • Imagick::setImageTicksPerSecond — Resmin saniyedeki tik sayısını tanımlar
  • Imagick::setImageType — Resim türünü tanımlar
  • Imagick::setImageUnits — Resmin çözünürlük birimlerini tanımlar
  • Imagick::setImageVirtualPixelMethod — Resmin sanal piksel yöntemini tanımlar
  • Imagick::setImageWhitePoint — Renk berraklığının beyaz noktasını tanımlar
  • Imagick::setInterlaceScheme — Resim geçişim şemasını tanımlar
  • Imagick::setIteratorIndex — Yineleyici konumunu belirler
  • Imagick::setLastIterator — Son resme bir Imagick yineleyicisi atar
  • Imagick::setOption — Bir seçenek tanımlar
  • Imagick::setPage — Imagick nesnesinin sayfa geometrisini tanımlar
  • Imagick::setPointSize — Yazı puntosunu belirler
  • Imagick::setProgressMonitor — Description
  • Imagick::setRegistry — Description
  • Imagick::setResolution — Resim çözünürlüğünü tanımlar
  • Imagick::setResourceLimit — Belli bir özkaynağın sınırını megabayt olarak tanımlar
  • Imagick::setSamplingFactors — Resim örnekleme çarpanlarını ayarlar
  • Imagick::setSize — Imagick nesnesinin boyutlarını ayarlar
  • Imagick::setSizeOffset — Imagick nesnesinin başlangıcını ve boyutlarını ayarlar
  • Imagick::setType — Resmin tür özniteliğini tanımlar
  • Imagick::shadeImage — Üç boyutluluk etkisi oluşturur
  • Imagick::shadowImage — Bir resimde gölgeleri taklit eder
  • Imagick::sharpenImage — Resmi netleştirir
  • Imagick::shaveImage — Bir resmin kenarındaki pikselleri rendeler
  • Imagick::shearImage — Bir paralalkenar oluşturur
  • Imagick::sigmoidalContrastImage — Bir resmin zıtlığını ayarlar
  • Imagick::sketchImage — Kara kalem çalışmasını taklit eder
  • Imagick::smushImages — Description
  • Imagick::solarizeImage — Resme uzun pozlama etkisi uygular
  • Imagick::sparseColorImage — Interpolates colors
  • Imagick::spliceImage — Bir resme bir rengi bütün halinde bindirerek birleştirir
  • Imagick::spreadImage — Bir kümedeki her pikseli rasgele gösterir
  • Imagick::statisticImage — Description
  • Imagick::steganoImage — Resmin içine sayısal bir filigran gizler
  • Imagick::stereoImage — İki resmi birleştirir
  • Imagick::stripImage — Resimden tüm profilleri ve açıklamaları ayıklar
  • Imagick::subImageMatch — Description
  • Imagick::swirlImage — Resmin merkezine yakın pikselleri girdap gibi döndürür
  • Imagick::textureImage — Doku resmini yatay ve düşeyde yineler
  • Imagick::thresholdImage — Bazı pikselleri bir eşiğe göre değiştir
  • Imagick::thumbnailImage — Resmin boyutlarını değiştirir
  • Imagick::tintImage — Resimdeki her piksele bir renk yöneyi uygular
  • Imagick::__toString — Returns the image as a string.
  • Imagick::transformImage — Budama miktarını ve resim geometrisini ayarlamanın uygun yolu
  • Imagick::transformImageColorspace — Transforms an image to a new colorspace.
  • Imagick::transparentPaintImage — Pikselleri şeffaflaştırır
  • Imagick::transposeImage — Resmin düşeydeki yansımasını oluşturur
  • Imagick::transverseImage — Resmin yataydaki yansımasını oluşturur
  • Imagick::trimImage — Resmin kenarlarını siler
  • Imagick::uniqueImageColors — Biri dışında tüm piksel renklerini iptal eder
  • Imagick::unsharpMaskImage — Resmi netleştirir
  • Imagick::valid — Imagick nesnesinin geçerli olup olmadığını sınar
  • Imagick::vignetteImage — Resme bir nakış süzgeci uygular
  • Imagick::waveImage — Resme bir dalga süzgeci uygular
  • Imagick::whiteThresholdImage — Eşiğin üstündeki tüm piksellerin rengini beyaza zorlar
  • Imagick::writeImage — Resmi belirtilen dosyaya yazar
  • Imagick::writeImageFile — Bir resmi belirtilen dosya tanıtıcısına yazar
  • Imagick::writeImages — Bir resmi veya resim kümesini dosyaya yazar
  • Imagick::writeImagesFile — Resim karelerini bir dosya tanıtıcısına yazar
Örnekler
Imagick::adaptiveBlurImage
ImageMagick


Resmi uyarlamalı olarak bulanıklaştırır

Imagick sınıfı
Imagick::adaptiveResizeImage
Imagick sınıfı
PHP Manual

Imagick::adaptiveBlurImage

(PECL imagick 2.0.0)

Imagick::adaptiveBlurImage — Resmi uyarlamalı olarak bulanıklaştırır

Açıklama

bool Imagick::adaptiveBlurImage ( float $yarıçap , float $sapma [, int $kanal = Imagick::CHANNEL_DEFAULT ] )

Resmi uyarlamalı olarak bulanıklaştırır. Resmin geneline standart bir bulanıklık uygulanırken resmin kenarlarına uygulanan uyarlamalı bulanıklık yoğunluğu oldukça azaltılır.

Değiştirgeler

yarıçap

Merkezdeki piksel sayısı değil, piksel cinsinden Gauss işleci yarıçapıdır. Yarıcapın kendiliğinden seçilmesi için 0 belirtin.

sapma

Piksel cinsinden standart sapma.

kanal

Normalde kanal türü sabitlerinden biridir, ancak bitsel işleçler kullanılarak birden fazla kanal belirtilebilir. Imagick::CHANNEL_DEFAULT öntanımlıdır.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Örnekler

Örnek 1 - Imagick::adaptiveBlurImage() örneği

Resmi uyarlamalı olarak bulanıklaştırıp tarayıcıya çıktılayalım.

<?php

header('Content-type: image/jpeg');

$image = new Imagick('test.jpg');

$image->adaptiveBlurImage(5,3);
echo $image;

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ayrıca Bakınız

  • Imagick::blurImage() - Resme bir bulanıklık süzgeci ekler
  • Imagick::motionBlurImage() - Hareket bulanıklığını taklit eder
  • Imagick::radialBlurImage() - Bir resme dairesel bulanıklık uygular

Imagick sınıfı
Imagick::adaptiveResizeImage
Imagick sınıfı


Nirengi noktasına göre uyarlamalı olarak resmi boyutlandırır

Imagick::adaptiveBlurImage
Imagick::adaptiveSharpenImage
Imagick sınıfı
PHP Manual

Imagick::adaptiveResizeImage

(PECL imagick 2.0.0)

Imagick::adaptiveResizeImage — Nirengi noktasına göre uyarlamalı olarak resmi boyutlandırır

Açıklama

bool Imagick::adaptiveResizeImage ( int $genişlik , int $yükseklik [, bool $sığdır = false ] )

Resim verisinin nirengi noktasına göre uyarlamalı olarak resmi boyutlandırır. Sert renk değişiklikleri ile resim bulanıklaştırılmamaya çalışılır. Resmi özgün boyutlarına göre oldukça küçük boyutlara indirmek için çok kullanışlıdır. Elde edilen resim büyük bir resmin küçük bir örneği gibi görünmez. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.2.9 veya sonraki bir sürümü kuruluysa kullanılabilir.

Bilginize: sığdır değiştirgesinin davranışı Imagick 3.0.0 sürümünde değişmiştir. Evvelce 200x150 ebadındaki bir resim 400x400 ebadındaki bir alana sığdırılmak istendiğinde bu yapılmazdı. Artık resim 400x300 ebadına getirilerek belirtilen alana sığdırılmaktadır. sığdır değiştirgesi kullanıldığı takdirde yükseklik ve genişliğin ikisi de verilmelidir.

Değiştirgeler

genişlik

Küçültülen resmin genişliği.

yükseklik

Küçültülen resmin yüksekliği.

sığdır

Resmin belirtilen boyutlara sığdırılıp sığdırılmayacağı.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Sürüm Bilgisi

Sürüm: | Açıklama
2.1.0 | İsteğe bağlı sığdır değiştirgesi eklendi.
2.1.0 | Artık küçültme sırasında enboy oranı hesaba katılıyor. Bunu sağlamak için boyutlardan birini 0 vermek yeterlidir.

Örnekler

Örnek 1 - Imagick::adaptiveResizeImage()örneği

Resmi standart bir boyuta indirelim. Resmi özgün resme göre oldukça küçük boyutlara indirmek için çok kullanışlıdır.

<?php
header('Content-type: image/jpeg');

$image = new Imagick('image.jpg');
$image->adaptiveResizeImage(1024,768);

echo $image;
?>

Ayrıca Bakınız

  • Imagick::chopImage() - Bir resmin bir bölgesini silerek kırpar
  • Imagick::cropImage() - Resmin bir bölgesini çıkarır
  • Imagick::magnifyImage() - Enboy oranını koruyarak resmi iki katına büyütür
  • Imagick::minifyImage() - Enboy oranını koruyarak resmi yarı boyutuna indirir
  • Imagick::resizeImage() - Bir resmi boyutlandırır
  • Imagick::scaleImage() - Bir resmin enboy oranını ayarlar
  • Imagick::shaveImage() - Bir resmin kenarındaki pikselleri rendeler
  • Imagick::thumbnailImage() - Resmin boyutlarını değiştirir
  • Imagick::trimImage() - Resmin kenarlarını siler

Imagick::adaptiveBlurImage
Imagick::adaptiveSharpenImage
Imagick sınıfı


Uyarlamalı olarak resmi netleştirir

Imagick::adaptiveResizeImage
Imagick::adaptiveThresholdImage
Imagick sınıfı
PHP Manual

Imagick::adaptiveSharpenImage

(PECL imagick 2.0.0)

Imagick::adaptiveSharpenImage — Uyarlamalı olarak resmi netleştirir

Açıklama

bool Imagick::adaptiveSharpenImage ( float $yarıçap , float $sapma [, int $kanal = Imagick::CHANNEL_DEFAULT ] )

Yoğunlukça yakın kenarları yoğunlukça uzak olanlara göre keskinleştirerek uyarlamalı olarak resmi netleştirir. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.2.9 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

yarıçap

Merkezdeki piksel sayısı değil, piksel cinsinden Gauss işleci yarıçapıdır. Yarıcapın kendiliğinden seçilmesi için 0 belirtin.

sapma

Piksel cinsinden standart sapma.

kanal

Normalde kanal türü sabitlerinden biridir, ancak bitsel işleçler kullanılarak birden fazla kanal belirtilebilir. Imagick::CHANNEL_DEFAULT öntanımlıdır.

Dönen Değerler

Başarı durumunda TRUE döner.

Örnekler

Örnek 1 - Imagick::adaptiveSharpenImage() örneği

Yarıçap 2 ve sapma 1 piksel olmak üzere resmi uyarlamalı olarak netleştirelim.

<?php
try {
    $image = new Imagick('image.png');
    $image->adaptiveSharpenImage(2,1);
} catch(ImagickException $e) {
    echo 'Hata: ' , $e->getMessage();
    die();
}
header('Content-type: image/png');
echo $image;
?>

Ayrıca Bakınız

  • Imagick::sharpenImage() - Resmi netleştirir

Imagick::adaptiveResizeImage
Imagick::adaptiveThresholdImage
Imagick sınıfı


Bir yoğunluk aralığına göre her piksel için bir eşik seçer

Imagick::adaptiveSharpenImage
Imagick::addImage
Imagick sınıfı
PHP Manual

Imagick::adaptiveThresholdImage

(PECL imagick 2.0.0)

Imagick::adaptiveThresholdImage — Bir yoğunluk aralığına göre her piksel için bir eşik seçer

Açıklama

bool Imagick::adaptiveThresholdImage ( int $genişlik , int $yükseklik , int $başlangıç )

Komşularının yoğunluk değerlerinin aralığına göre her piksel için bağımsız bir eşik seçer. Resmin ayırdedici tepeleri içermeyen genel renk yoğunluğu dağılımına uygun bir eşik seçimini mümkün kılar.

Değiştirgeler

genişlik

Komşuluk genişliği.

yükseklik

Komşuluk yüksekliği.

başlangıç

Ortalama başlangıç.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::adaptiveSharpenImage
Imagick::addImage
Imagick sınıfı


Imagick resim listesine yeni bir resim ekler

Imagick::adaptiveThresholdImage
Imagick::addNoiseImage
Imagick sınıfı
PHP Manual

Imagick::addImage

(PECL imagick 2.0.0)

Imagick::addImage — Imagick resim listesine yeni bir resim ekler

Açıklama

bool Imagick::addImage ( Imagick $kaynak )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Kaynak Imagick resim listesinde geçerli konuma yeni bir resim ekler. İşlem sonunda yineleyici bir sonraki resim konumuna ilerletirilir.

Değiştirgeler

kaynak

Kaynak Imagick nesnesi.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::adaptiveThresholdImage
Imagick::addNoiseImage
Imagick sınıfı


Resme rasgele gürültü ekler

Imagick::addImage
Imagick::affineTransformImage
Imagick sınıfı
PHP Manual

Imagick::addNoiseImage

(PECL imagick 2.0.0)

Imagick::addNoiseImage — Resme rasgele gürültü ekler

Açıklama

bool Imagick::addNoiseImage ( int $gürültü_türü [, int $kanal = Imagick::CHANNEL_DEFAULT ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resme rasgele gürültü ekler.

Değiştirgeler

gürültü_türü

Gürültü türü sabitlerinden biri.

kanal

Normalde kanal türü sabitlerinden biridir, ancak bitsel işleçler kullanılarak birden fazla kanal belirtilebilir. Imagick::CHANNEL_DEFAULT öntanımlıdır.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::addImage
Imagick::affineTransformImage
Imagick sınıfı


Resmi dönüştürür

Imagick::addNoiseImage
Imagick::animateImages
Imagick sınıfı
PHP Manual

Imagick::affineTransformImage

(PECL imagick 2.0.0)

Imagick::affineTransformImage — Resmi dönüştürür

Açıklama

bool Imagick::affineTransformImage ( ImagickDraw $matris )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Homojen koordinatlar matrisine göre resmi dönüştürür.

Değiştirgeler

matris

Homojen koordinatlar matrisi (affine matrix).

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::addNoiseImage
Imagick::animateImages
Imagick sınıfı


Bir resmi veya resimleri canlandırır

Imagick::affineTransformImage
Imagick::annotateImage
Imagick sınıfı
PHP Manual

Imagick::animateImages

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::animateImages — Bir resmi veya resimleri canlandırır

Açıklama

bool Imagick::animateImages ( string $x_sunucusu )

Bu yöntem resmin bir yerel veya uzak X sunucusu üzerinde canlandırır. Bu yöntem Windows üzerinde kullanılamaz. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.3.6 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

x_sunucusu

X sunucusunun adresi.

Dönen Değerler

Başarı durumunda TRUE döner.

Ayrıca Bakınız

  • Imagick::displayImage() - Bir resmi gösterir

Imagick::affineTransformImage
Imagick::annotateImage
Imagick sınıfı


Resme bir metin çizer

Imagick::animateImages
Imagick::appendImages
Imagick sınıfı
PHP Manual

Imagick::annotateImage

(PECL imagick 2.0.0)

Imagick::annotateImage — Resme bir metin çizer

Açıklama

bool Imagick::annotateImage ( ImagickDraw $çizim_ayarı , float $x , float $y , float $açı , string $metin )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resme bir metin çizer.

Değiştirgeler

çizim_ayarı

Metni çizmekte kullanılacak ayarları içeren ImagickDraw nesnesi.

x

Metnin ilk harfinin taban çizgisi başlangıcının X konumu.

y

Metnin ilk harfinin taban çizgisi başlangıcının Y konumu.

açı

Resmin yazılacağı açı.

metin

Çizilecek dizge.

Dönen Değerler

Başarı durumunda TRUE döner.

Örnekler

Örnek 1 - Imagick::annotateImage() örneği

Boş bir resme bir metin çizelim.

<?php
/* Nesneleri oluşturalım */
$image = new Imagick();
$draw = new ImagickDraw();
$pixel = new ImagickPixel( 'gray' );

/* Yeni resim */
$image->newImage(800, 75, $pixel);

/* Metin siyah olsun */
$pixel->setColor('black');

/* Yazı tipi özelliklerini belirtelim */
$draw->setFont('Bookman-DemiItalic');
$draw->setFontSize( 30 );

/* Metni çizelim */
$image->annotateImage($draw, 10, 45, 0, 'The quick brown fox jumps over the lazy dog');

/* Resim biçemi */
$image->setImageFormat('png');

/* Resmi çıktılayalım */
header('Content-type: image/png');
echo $image;

?>

Ayrıca Bakınız

  • ImagickDraw::annotation() - Resmin üzerine bir metin çizer
  • ImagickDraw::setFont() - Metni çizerken kullanılacak yazı tipini tam belirtimiyle belirler

Imagick::animateImages
Imagick::appendImages
Imagick sınıfı


Bir resim kümesini ekler

Imagick::annotateImage
Imagick::autoLevelImage
Imagick sınıfı
PHP Manual

Imagick::appendImages

(PECL imagick 2.0.0)

Imagick::appendImages — Bir resim kümesini ekler

Açıklama

Imagick Imagick::appendImages ( bool $yığıt )

Daha büyük bir resmin içine bir resim kümesi ekler.

Değiştirgeler

yığıt

Yığıtın yönü (yukardan aşağıya veya aşağıdan yukarıya).

Dönen Değerler

Başarı durumunda yeni bir Imagick nesnesi döner. Hata durumunda bir ImagickException istisnası oluşur.

Örnekler

Örnek 1 - Imagick::appendImages() örneği

<?php

/* Yeni bir imagick nesnesi oluşturalım */
$im = new Imagick();

/* kırmızı, yeşil ve mavi tuvaller oluşturalım */
$im->newImage(100, 50, "red");
$im->newImage(100, 50, "green");
$im->newImage(100, 50, "blue");

/* Bunları birbirlerine ekleyelim */
$im->resetIterator();
$combined = $im->appendImages(true);

/* Elde edilen resmi çıktılayalım */
$combined->setImageFormat("png");
header("Content-Type: image/png");
echo $combined;
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Imagick::annotateImage
Imagick::autoLevelImage
Imagick sınıfı


Description

Imagick::appendImages
Imagick::averageImages
Imagick sınıfı
PHP Manual

Imagick::autoLevelImage

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::autoLevelImage — Description

Açıklama

public void Imagick::autoLevelImage ([ string $CHANNEL = Imagick::CHANNEL_DEFAULT ] )

Adjusts the levels of a particular image channel by scaling the minimum and maximum values to the full quantum range.

Değiştirgeler

CHANNEL

Which channel should the auto-levelling should be done on.

Dönen Değerler

Örnekler

Örnek 1 Imagick::autoLevelImage()

<?php
function autoLevelImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->autoLevelImage();
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>

Imagick::appendImages
Imagick::averageImages
Imagick sınıfı


Bir resim kümesinin ortalamasını alır

Imagick::autoLevelImage
Imagick::blackThresholdImage
Imagick sınıfı
PHP Manual

Imagick::averageImages

(PECL imagick 2.0.0)

Imagick::averageImages — Bir resim kümesinin ortalamasını alır

Açıklama

Imagick Imagick::averageImages ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bir resim kümesinin ortalamasını alır.

Dönen Değerler

Başarı durumunda yeni bir Imagick nesnesi döner. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::autoLevelImage
Imagick::blackThresholdImage
Imagick sınıfı


Eşiğin altında kalan tüm renkleri siyaha çevirir

Imagick::averageImages
Imagick::blueShiftImage
Imagick sınıfı
PHP Manual

Imagick::blackThresholdImage

(PECL imagick 2.0.0)

Imagick::blackThresholdImage — Eşiğin altında kalan tüm renkleri siyaha çevirir

Açıklama

bool Imagick::blackThresholdImage ( mixed $threshold )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Eşiğin altında kalan tüm renkleri siyaha çevirmesi üstündekilere dokunmaması dışında Imagick::thresholdImage() gibidir.

Değiştirgeler

eşik

Bu eşiğin altındaki herşey siyah olur.

Dönen Değerler

Başarı durumunda TRUE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
2.1.0 | Artık renk olarak rengi ifade eden bir dizge belirtilebiliyor. Evvelce sadece bir ImagickPixel nesnesi belirtilebiliyordu.

Imagick::averageImages
Imagick::blueShiftImage
Imagick sınıfı


Description

Imagick::blackThresholdImage
Imagick::blurImage
Imagick sınıfı
PHP Manual

Imagick::blueShiftImage

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::blueShiftImage — Description

Açıklama

public void Imagick::blueShiftImage ([ float $factor = 1.5 ] )

Mutes the colors of the image to simulate a scene at nighttime in the moonlight.

Değiştirgeler

factor

Dönen Değerler

Örnekler

Örnek 1 Imagick::blueShiftImage()

<?php
function blueShiftImage($imagePath, $blueShift) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->blueShiftImage($blueShift);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>

Imagick::blackThresholdImage
Imagick::blurImage
Imagick sınıfı


Resme bir bulanıklık süzgeci ekler

Imagick::blueShiftImage
Imagick::borderImage
Imagick sınıfı
PHP Manual

Imagick::blurImage

(PECL imagick 2.0.0)

Imagick::blurImage — Resme bir bulanıklık süzgeci ekler

Açıklama

bool Imagick::blurImage ( float $yarıçap , float $sapma [, int $kanal ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resme bir bulanıklık süzgeci ekler. İsteğe bağlı üçüncü değiştirgede süzgecin ekleneceği kanal belirtilir.

Değiştirgeler

yarıçap

Bulanıklık yarıçapı.

sapma

Standart sapma.

kanal

Normalde kanal türü sabitlerinden biri, ancak bitsel işleçler kullanılarak birden fazla kanal belirtilebilir. Imagick::CHANNEL_ALL öntanımlıdır.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Örnekler

Örnek 1 - Imagick::blurImage() örneği

Resmi bulanıklaştırıp tarayıcıda gösterelim.

<?php

header('Content-type: image/jpeg');

$image = new Imagick('test.jpg');

$image->blurImage(5,3);
echo $image;

?>

Ayrıca Bakınız

  • Imagick::adaptiveBlurImage() - Resmi uyarlamalı olarak bulanıklaştırır
  • Imagick::motionBlurImage() - Hareket bulanıklığını taklit eder
  • Imagick::radialBlurImage() - Bir resme dairesel bulanıklık uygular

Imagick::blueShiftImage
Imagick::borderImage
Imagick sınıfı


Resme bir çerçeve çizer

Imagick::blurImage
Imagick::brightnessContrastImage
Imagick sınıfı
PHP Manual

Imagick::borderImage

(PECL imagick 2.0.0)

Imagick::borderImage — Resme bir çerçeve çizer

Açıklama

bool Imagick::borderImage ( mixed $çerçeve_rengi , int $genişlik , int $yükseklik )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resme çerçeve_rengi ile belirtilen renkte bir çerçeve çizer.

Değiştirgeler

çerçeve_rengi

Çerçeve rengini içeren dizge veya ImagickPixel nesnesi.

genişlik

Çerçeve genişliği.

yükseklik

Çerçeve yüksekliği.

Dönen Değerler

Başarı durumunda TRUE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
2.1.0 | Artık renk olarak rengi ifade eden bir dizge belirtilebiliyor. Evvelce sadece bir ImagickPixel nesnesi belirtilebiliyordu.

Imagick::blurImage
Imagick::brightnessContrastImage
Imagick sınıfı


Description

Imagick::borderImage
Imagick::charcoalImage
Imagick sınıfı
PHP Manual

Imagick::brightnessContrastImage

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::brightnessContrastImage — Description

Açıklama

public void Imagick::brightnessContrastImage ( string $brightness , string $contrast [, string $CHANNEL = Imagick::CHANNEL_DEFAULT ] )

Change the brightness and/or contrast of an image. It converts the brightness and contrast parameters into slope and intercept and calls a polynomical function to apply to the image.

Değiştirgeler

brightness

contrast

CHANNEL

Dönen Değerler

Örnekler

Örnek 1 Imagick::brightnessContrastImage()

<?php
function brightnessContrastImage($imagePath, $brightness, $contrast, $channel) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->brightnessContrastImage($brightness, $contrast, $channel);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>

Imagick::borderImage
Imagick::charcoalImage
Imagick sınıfı


Kara kalem çizimi taklit eder

Imagick::brightnessContrastImage
Imagick::chopImage
Imagick sınıfı
PHP Manual

Imagick::charcoalImage

(PECL imagick 2.0.0)

Imagick::charcoalImage — Kara kalem çizimi taklit eder

Açıklama

bool Imagick::charcoalImage ( float $yarıçap , float $sapma )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Kara kalem çizimi taklit eder.

Değiştirgeler

yarıçap

Merkezdeki piksel sayısı değil, piksel cinsinden Gauss işleci yarıçapıdır.

sapma

Piksel cinsinden standart sapma.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::brightnessContrastImage
Imagick::chopImage
Imagick sınıfı


Bir resmin bir bölgesini silerek kırpar

Imagick::charcoalImage
Imagick::clampImage
Imagick sınıfı
PHP Manual

Imagick::chopImage

(PECL imagick 2.0.0)

Imagick::chopImage — Bir resmin bir bölgesini silerek kırpar

Açıklama

bool Imagick::chopImage ( int $genişlik , int $yükseklik , int $x , int $y )

Bir resmin bir bölgesini silerek kırpar.

Değiştirgeler

genişlik

Resmin kırpıldıktan sonraki genişliği.

yükseklik

Resmin kırpıldıktan sonraki yüksekliği.

x

Resmin kırpıldıktan sonraki genişlik başlangıcı.

y

Resmin kırpıldıktan sonraki yükseklik başlangıcı.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Örnekler

Örnek 1 - Imagick::chopImage() örneği

<?php
/* İki nesne oluşturalım */
$image = new Imagick();
$pixel = new ImagickPixel( 'gray' );

/* Yeni resim */
$image->newImage(400, 200, $pixel);

/* Kırpık resim */
$image->chopImage(200, 200, 0, 0);

/* Resim biçemi */
$image->setImageFormat('png');

/* Resmi çıktılayalım */
header('Content-type: image/png');
echo $image;

?>

Ayrıca Bakınız

  • Imagick::cropImage() - Resmin bir bölgesini çıkarır

Imagick::charcoalImage
Imagick::clampImage
Imagick sınıfı


Description

Imagick::chopImage
Imagick::clear
Imagick sınıfı
PHP Manual

Imagick::clampImage

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::clampImage — Description

Açıklama

public void Imagick::clampImage ([ string $CHANNEL = Imagick::CHANNEL_DEFAULT ] )

Restricts the color range from 0 to the quantum depth.

Değiştirgeler

CHANNEL

Dönen Değerler

Imagick::chopImage
Imagick::clear
Imagick sınıfı


Imagick nesnesi ile ilgili tüm özkaynakları temizler

Imagick::clampImage
Imagick::clipImage
Imagick sınıfı
PHP Manual

Imagick::clear

(PECL imagick 2.0.0)

Imagick::clear — Imagick nesnesi ile ilgili tüm özkaynakları temizler

Açıklama

bool Imagick::clear ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Imagick nesnesi ile ilgili tüm özkaynakları temizler.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::clampImage
Imagick::clipImage
Imagick sınıfı


8BIM profilindeki ilk yol boyunca resmi kırpar

Imagick::clear
Imagick::clipImagePath
Imagick sınıfı
PHP Manual

Imagick::clipImage

(PECL imagick 2.0.0)

Imagick::clipImage — 8BIM profilindeki ilk yol boyunca resmi kırpar

Açıklama

bool Imagick::clipImage ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Varsa, 8BIM profilindeki ilk yol boyunca resmi kırpar.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::clear
Imagick::clipImagePath
Imagick sınıfı


Description

Imagick::clipImage
Imagick::clipPathImage
Imagick sınıfı
PHP Manual

Imagick::clipImagePath

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::clipImagePath — Description

Açıklama

public void Imagick::clipImagePath ( string $pathname , string $inside )

Clips along the named paths from the 8BIM profile, if present. Later operations take effect inside the path. Id may be a number if preceded with #, to work on a numbered path, e.g., "#1" to use the first path.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

pathname

inside

Dönen Değerler

Imagick::clipImage
Imagick::clipPathImage
Imagick sınıfı


8BIM profili boyunca isimli yolları kırpar

Imagick::clipImagePath
Imagick::clone
Imagick sınıfı
PHP Manual

Imagick::clipPathImage

(PECL imagick 2.0.0)

Imagick::clipPathImage — 8BIM profili boyunca isimli yolları kırpar

Açıklama

bool Imagick::clipPathImage ( string $yol_adı , bool $içinde )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Varsa, 8BIM profili boyunca isimli yolları kırpar. Sonraki işlemler yolun içinde etkili olur. Bir # ile öncelenmişse numaralı bir yol üzerinde işlem yapılır; ilk yol için #1 gibi.

Değiştirgeler

yol_adı

Yolun ismi.

içinde

TRUE ise sonraki işlemler yolun içinde etkili olur. FALSE ise sonraki işlemler yolun dışında etkili olur.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::clipImagePath
Imagick::clone
Imagick sınıfı


Imagick nesnesinin tam bir kopyasını yapar

Imagick::clipPathImage
Imagick::clutImage
Imagick sınıfı
PHP Manual

Imagick::clone

(PECL imagick 2.0.0)

Imagick::clone — Imagick nesnesinin tam bir kopyasını yapar

Açıklama

Imagick Imagick::clone ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Imagick nesnesinin tam bir kopyasını yapar.

Dönen Değerler

Başarı durumunda yeni bir Imagick nesnesi döner. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::clipPathImage
Imagick::clutImage
Imagick sınıfı


Resmin renklerini değiştirir

Imagick::clone
Imagick::coalesceImages
Imagick sınıfı
PHP Manual

Imagick::clutImage

(PECL imagick 2.0.0)

Imagick::clutImage — Resmin renklerini değiştirir

Açıklama

bool Imagick::clutImage ( Imagick $renk_tablosu [, float $kanal = Imagick::CHANNEL_DEFAULT ] )

Resmin renklerini belirtilen renk tablosuna göre değiştirir. İsteğe bağlı ikinci değiştirgede renklerin değiştirileceği kanal belirtilir. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.3.6 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

renk_tablosu

Renk tablosunu içeren Imagick nesnesi.

kanal

Normalde kanal türü sabitlerinden biri, ancak bitsel işleçler kullanılarak birden fazla kanal belirtilebilir. Belirtilmezse sadece öntanımlı kanallar değiştirilir.

Dönen Değerler

Başarı durumunda TRUE döner.

Örnekler

Örnek 1 - Imagick::clutImage() örneği

Renk tablosuna göre resmin renklerini değiştirelim.

<?php
$image = new Imagick('test.jpg');
$clut = new Imagick();
$clut->newImage(1, 1, new ImagickPixel('black'));
$image->clutImage($clut);
$image->writeImage('test_out.jpg');
?>

Ayrıca Bakınız

  • Imagick::adaptiveBlurImage() - Resmi uyarlamalı olarak bulanıklaştırır
  • Imagick::motionBlurImage() - Hareket bulanıklığını taklit eder
  • Imagick::radialBlurImage() - Bir resme dairesel bulanıklık uygular

Imagick::clone
Imagick::coalesceImages
Imagick sınıfı


Bir resim kümesini tek bir resim olarak birleştirir

Imagick::clutImage
Imagick::colorFloodfillImage
Imagick sınıfı
PHP Manual

Imagick::coalesceImages

(PECL imagick 2.0.0)

Imagick::coalesceImages — Bir resim kümesini tek bir resim olarak birleştirir

Açıklama

Imagick Imagick::coalesceImages ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bir resim kümesini sayfa başlangıçlarını ve sıralama yöntemlerini hesaba katarak birleştirir. GIF, MIFF ve MNG canlandırma dizileri genellikle bir resim artalanı ile başlar ve sonraki her resimde boyut ve başlangıç değişiklik gösterir. Resim dizisindeki her resmin kendi boyutuyla sonraki resimle birleştirilerek yer aldığı yeni bir Imagick nesnesi döner.

Dönen Değerler

Başarı durumunda yeni bir Imagick nesnesi döner. Hata durumunda bir ImagickException istisnası oluşur.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::clutImage
Imagick::colorFloodfillImage
Imagick sınıfı


Hedefle eşleşen her pikselin rengini değiştirir

Imagick::coalesceImages
Imagick::colorizeImage
Imagick sınıfı
PHP Manual

Imagick::colorFloodfillImage

(PECL imagick 2.0.0)

Imagick::colorFloodfillImage — Hedefle eşleşen her pikselin rengini değiştirir

Açıklama

bool Imagick::colorFloodfillImage ( mixed $dolgu , float $benzerlik , mixed $çerçeve_rengi , int $x , int $y )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Hedefle eşleşen her pikselin ve yanındakinin rengini değiştirir.

Değiştirgeler

dolgu

Renk ifade eden bir dizge veya bir ImagickPixel nesnesi.

benzerlik

Renkler arasındaki azami benzerlik. Örneğin bu değere 10 atarsanız, renk kırmızı ise ve kırmızının koyulukları 100 ve 102 ise bu iki renk aynı kabul edilir.

çerçeve_rengi

Çerçeve rengini ifade eden bir dizge veya bir ImagickPixel nesnesi.

x

İşlemin başlatılacağı X konumu.

y

İşlemin başlatılacağı Y konumu.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Sürüm Bilgisi

Sürüm: | Açıklama
2.1.0 | Artık renk olarak rengi ifade eden bir dizge belirtilebiliyor. Evvelce sadece bir ImagickPixel nesnesi belirtilebiliyordu.

Imagick::coalesceImages
Imagick::colorizeImage
Imagick sınıfı


Resmin her pikseline dolgu rengini karıştırır

Imagick::colorFloodfillImage
Imagick::colorMatrixImage
Imagick sınıfı
PHP Manual

Imagick::colorizeImage

(PECL imagick 2.0.0)

Imagick::colorizeImage — Resmin her pikseline dolgu rengini karıştırır

Açıklama

bool Imagick::colorizeImage ( mixed $renk , mixed $matlık )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin her pikseline dolgu rengini karıştırır.

Değiştirgeler

renk

Renklendirme amacı ile kullanılacak renk dizgesi veya ImagickPixel nesnesi.

matlık

Matlık değerini içeren bir gerçek sayı veya ImagickPixel nesnesi. Tam matlık için 1.0; tam şeffaflık için 0.0 kullanın.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Sürüm Bilgisi

Sürüm: | Açıklama
2.1.0 | Artık renk olarak rengi ifade eden bir dizge belirtilebiliyor. Evvelce sadece bir ImagickPixel nesnesi belirtilebiliyordu.

Imagick::colorFloodfillImage
Imagick::colorMatrixImage
Imagick sınıfı


Description

Imagick::colorizeImage
Imagick::combineImages
Imagick sınıfı
PHP Manual

Imagick::colorMatrixImage

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::colorMatrixImage — Description

Açıklama

public void Imagick::colorMatrixImage ( string $color_matrix = Imagick::CHANNEL_DEFAULT )

Apply color transformation to an image. The method permits saturation changes, hue rotation, luminance to alpha, and various other effects. Although variable-sized transformation matrices can be used, typically one uses a 5x5 matrix for an RGBA image and a 6x6 for CMYKA (or RGBA with offsets). The matrix is similar to those used by Adobe Flash except offsets are in column 6 rather than 5 (in support of CMYKA images) and offsets are normalized (divide Flash offset by 255)

Değiştirgeler

color_matrix

Dönen Değerler

Örnekler

Örnek 1 Imagick::colorMatrixImage()

<?php
function colorMatrixImage($imagePath, $colorMatrix) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->setImageOpacity(1);

    //A color matrix should look like:
    //    $colorMatrix = [
    //        1.5, 0.0, 0.0, 0.0, 0.0, -0.157,
    //        0.0, 1.0, 0.5, 0.0, 0.0, -0.157,
    //        0.0, 0.0, 1.5, 0.0, 0.0, -0.157,
    //        0.0, 0.0, 0.0, 1.0, 0.0,  0.0,
    //        0.0, 0.0, 0.0, 0.0, 1.0,  0.0,
    //        0.0, 0.0, 0.0, 0.0, 0.0,  1.0
    //    ];

    $background = new \Imagick();
    $background->newPseudoImage($imagick->getImageWidth(), $imagick->getImageHeight(),  "pattern:checkerboard");

    $background->setImageFormat('png');

    $imagick->setImageFormat('png');
    $imagick->colorMatrixImage($colorMatrix);

    $background->compositeImage($imagick, \Imagick::COMPOSITE_ATOP, 0, 0);

    header("Content-Type: image/png");
    echo $background->getImageBlob();
}

?>

Imagick::colorizeImage
Imagick::combineImages
Imagick sınıfı


Bir veya daha fazla resmi tek bir resim halinde birleştirir

Imagick::colorMatrixImage
Imagick::commentImage
Imagick sınıfı
PHP Manual

Imagick::combineImages

(PECL imagick 2.0.0)

Imagick::combineImages — Bir veya daha fazla resmi tek bir resim halinde birleştirir

Açıklama

Imagick Imagick::combineImages ( int $kanal )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bir veya daha fazla resmi tek bir resim halinde birleştirir. Her resmin gri tonlama değerleri birleşik resmin kanal sırasına göre atanır. Normalde sıralama şöyledir: 1 => Red, 2 => Green, 3 => Blue, vb.

Değiştirgeler

kanal

Normalde kanal türü sabitlerinden biri, ancak bitsel işleçler kullanılarak birden fazla kanal belirtilebilir.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::colorMatrixImage
Imagick::commentImage
Imagick sınıfı


Resme bir açıklama ekler

Imagick::combineImages
Imagick::compareImageChannels
Imagick sınıfı
PHP Manual

Imagick::commentImage

(PECL imagick 2.0.0)

Imagick::commentImage — Resme bir açıklama ekler

Açıklama

bool Imagick::commentImage ( string $açıklama )

Resme bir açıklama ekler.

Değiştirgeler

açıklama

Eklenecek açıklama dizgesi.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Örnekler

Örnek 1 - Imagick::commentImage() kullanımı

Resme açıklama ekleyip açıklamayı okumak:

<?php

/* Yeni bir Imagick nesnesi oluşturalım */
$im = new imagick();

/* Boş bir resim oluşturalım */
$im->newImage(100, 100, new ImagickPixel("red"));

/* Resme bir açıklama ekleyelim */
$im->commentImage("Hello World!");

/* Açıklamayı gösterelim */
echo $im->getImageProperty("comment");

?>

Imagick::combineImages
Imagick::compareImageChannels
Imagick sınıfı


Bir veya daha fazla resmin farkını döndürür

Imagick::commentImage
Imagick::compareImageLayers
Imagick sınıfı
PHP Manual

Imagick::compareImageChannels

(PECL imagick 2.0.0)

Imagick::compareImageChannels — Bir veya daha fazla resmin farkını döndürür

Açıklama

array Imagick::compareImageChannels ( Imagick $resim , int $kanal , int $metrik )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bir veya daha fazla resmin karşılaştırıp farkını döndürür.

Değiştirgeler

resim

Karşılaştırılacak resmi içeren Imagick nesnesi.

kanal

Normalde kanal türü sabitlerinden biri, ancak bitsel işleçler kullanılarak birden fazla kanal belirtilebilir.

metrik

Metrik türü sabitlerinden biri.

Dönen Değerler

Yeniden oluşturulan resmi ve resimler arasındaki farkı içeren bir dizi döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::commentImage
Imagick::compareImageLayers
Imagick sınıfı


Resim katmanlarını karşılaştırıp en iyilenmiş resmi döndürür

Imagick::compareImageChannels
Imagick::compareImages
Imagick sınıfı
PHP Manual

Imagick::compareImageLayers

(PECL imagick 2.0.0)

Imagick::compareImageLayers — Resim katmanlarını karşılaştırıp en iyilenmiş resmi döndürür

Açıklama

Imagick Imagick::compareImageLayers ( int $yöntem )

Her resmi bir sonraki ile karşılaştırıp keşfettiği farklı pikselleri sarmalayan en büyük boyuttaki resmi döndürür. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.2.9 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

yöntem

Katman yöntemi sabitlerinden biri.

Dönen Değerler

Yeni bir Imagick nesnesi döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Örnekler

Örnek 1 - Imagick::compareImageLayers() örneği

Resim katmanlarını karşılaştırır

<?php
/* Yeni bir imagick nesnesi oluşturalım */
$im = new Imagick("test.gif");

/* Resim katmanlarını en iyileyelim */
$result = $im->compareImageLayers(imagick::LAYERMETHOD_COALESCE);

/* $result ile biraz çalışalım */
?>

Ayrıca Bakınız

  • Imagick::optimizeImageLayers() - En iyilemek amacıyla resimlerin tekrarlanan bölümlerini siler
  • Imagick::writeImages() - Bir resmi veya resim kümesini dosyaya yazar
  • Imagick::writeImage() - Resmi belirtilen dosyaya yazar

Imagick::compareImageChannels
Imagick::compareImages
Imagick sınıfı


Resmi yeniden oluşturulan resimle karşılaştırır

Imagick::compareImageLayers
Imagick::compositeImage
Imagick sınıfı
PHP Manual

Imagick::compareImages

(PECL imagick 2.0.0)

Imagick::compareImages — Resmi yeniden oluşturulan resimle karşılaştırır

Açıklama

array Imagick::compareImages ( Imagick $resim , int $metrik )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Yeniden oluşturulan resmi ve resimler arasındaki farkı içeren bir dizi döner.

Değiştirgeler

resim

Karşılaştırılacak resim.

metrik

Geçerli metrik sabitlerinden biri.

Dönen Değerler

Yeniden oluşturulan resmi ve resimler arasındaki farkı içeren bir dizi döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Örnekler

Örnek 1 - Imagick::compareImages() örneği

Resimleri karşılaştırır ve yeniden oluşturulan resmi görüntüler.

<?php

$image1 = new imagick("image1.png");
$image2 = new imagick("image2.png");

$result = $image1->compareImages($image2, Imagick::METRIC_MEANSQUAREERROR);
$result[0]->setImageFormat("png");

header("Content-Type: image/png");
echo $result[0];

?>

Imagick::compareImageLayers
Imagick::compositeImage
Imagick sınıfı


Bir resmi diğeriyle birleştirir

Imagick::compareImages
Imagick::__construct
Imagick sınıfı
PHP Manual

Imagick::compositeImage

(PECL imagick 2.0.0)

Imagick::compositeImage — Bir resmi diğeriyle birleştirir

Açıklama

bool Imagick::compositeImage ( Imagick $birleşik_nesne , int $işleç , int $x , int $y [, int $kanal = Imagick::CHANNEL_ALL ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Belirtilen konumda resmi bir başka resimle birleştirir.

Değiştirgeler

birleşik_nesne

Birleşik resmin saklanacağı Imagick nesnesi.

işleç

Birleşitirme işleci sabitlerinden biri.

x

Birleşik resmin genişlik başlangıcı.

y

Birleşik resmin yükseklik başlangıcı.

kanal

Normalde kanal türü sabitlerinden biri, ancak bitsel işleçler kullanılarak birden fazla kanal belirtilebilir.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::compareImages
Imagick::__construct
Imagick sınıfı


Imagick kurucusu

Imagick::compositeImage
Imagick::contrastImage
Imagick sınıfı
PHP Manual

Imagick::__construct

(PECL imagick 2.0.0)

Imagick::__construct — Imagick kurucusu

Açıklama

Imagick Imagick::__construct ([ mixed $dosyalar ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Imagick kurucusu.

Değiştirgeler

dosyalar

Resmin yükleneceği yol dizgesi veya aranacağı yolları içeren dizi.

Dönen Değerler

Başarı durumunda yeni bir Imagick nesnesi döner. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::compositeImage
Imagick::contrastImage
Imagick sınıfı


Resmin zıtlığını değiştirir

Imagick::__construct
Imagick::contrastStretchImage
Imagick sınıfı
PHP Manual

Imagick::contrastImage

(PECL imagick 2.0.0)

Imagick::contrastImage — Resmin zıtlığını değiştirir

Açıklama

bool Imagick::contrastImage ( bool $zıtlık )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin en koyu ve en açık pikselleri arasındaki yoğunluk farklarını ayarlar. netlik değiştirgesinde sıfırdan farklı bir değer belirtilmesi zıtlığı arttırırken, tersi azaltır.

Değiştirgeler

zıklık

Zıtlık değeri.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::__construct
Imagick::contrastStretchImage
Imagick sınıfı


Renkli bir resmin zıtlığını ayarlar

Imagick::contrastImage
Imagick::convolveImage
Imagick sınıfı
PHP Manual

Imagick::contrastStretchImage

(PECL imagick 2.0.0)

Imagick::contrastStretchImage — Renkli bir resmin zıtlığını ayarlar

Açıklama

bool Imagick::contrastStretchImage ( float $siyah_nokta , float $beyaz_nokta [, int $kanal = Imagick::CHANNEL_ALL ] )

Kullanılabilir renk aralığının tamamına yaymak için pikselleri ayarlayarak renkli resmin zıtlığını arttırır. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.2.9 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

siyah_nokta

Resmin en koyu noktası.

beyaz_nokta

Resmin en açık noktası.

kanal

Normalde kanal türü sabitlerinden biri, ancak bitsel işleçler kullanılarak birden fazla kanal belirtilebilir. Imagick::CHANNEL_ALL öntanımlıdır.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::contrastImage
Imagick::convolveImage
Imagick sınıfı


Resme bir evrişim çekirdeği uygular

Imagick::contrastStretchImage
Imagick::count
Imagick sınıfı
PHP Manual

Imagick::convolveImage

(PECL imagick 2.0.0)

Imagick::convolveImage — Resme bir evrişim çekirdeği uygular

Açıklama

bool Imagick::convolveImage ( array $çekirdek [, int $kanal = Imagick::CHANNEL_ALL ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resme özel bir evrişim çekirdeği uygular.

Değiştirgeler

çekirdek

Evrişim çekirdeği.

kanal

Normalde kanal türü sabitlerinden biri, ancak bitsel işleçler kullanılarak birden fazla kanal belirtilebilir.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::contrastStretchImage
Imagick::count
Imagick sınıfı


Description

Imagick::convolveImage
Imagick::cropImage
Imagick sınıfı
PHP Manual

Imagick::count

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::count — Description

Açıklama

public void Imagick::count ([ string $mode ] )

Returns the number of images.

Değiştirgeler

mode

An unused argument. Currently there is a non-particularly well defined feature in PHP where calling count() on a countable object might (or might not) require this method to accept a parameter. This parameter is here to be conformant with the interface of countable, even though the param is not used.

Dönen Değerler

Imagick::convolveImage
Imagick::cropImage
Imagick sınıfı


Resmin bir bölgesini çıkarır

Imagick::count
Imagick::cropThumbnailImage
Imagick sınıfı
PHP Manual

Imagick::cropImage

(PECL imagick 2.0.0)

Imagick::cropImage — Resmin bir bölgesini çıkarır

Açıklama

bool Imagick::cropImage ( int $genişlik , int $yükseklik , int $x , int $y )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin bir bölgesini çıkarır.

Değiştirgeler

genişlik

Kırpma genişliği.

yükseklik

Kırpma yüksekliği.

x

Kırpılacak bölgenin sol üst köşesinin X koordinatı.

y

Kırpılacak bölgenin sol üst köşesinin Y koordinatı.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::count
Imagick::cropThumbnailImage
Imagick sınıfı


Resmin kırpık bir örneğini oluşturur

Imagick::cropImage
Imagick::current
Imagick sınıfı
PHP Manual

Imagick::cropThumbnailImage

(PECL imagick 2.0.0)

Imagick::cropThumbnailImage — Resmin kırpık bir örneğini oluşturur

Açıklama

bool Imagick::cropThumbnailImage ( int $genişlik , int $yükseklik )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmi enboy oranının koruyarak küçülttükten/büyüttükten sonra merkezi bölgenin çevresini kırparak istenen boyuta getirir.

Değiştirgeler

genişlik

Kırpık örneğin genişliği.

yükseklik

Kırpık örneğin yüksekliği.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::cropImage
Imagick::current
Imagick sınıfı


Geçerli Imagick nesnesini döndürür

Imagick::cropThumbnailImage
Imagick::cycleColormapImage
Imagick sınıfı
PHP Manual

Imagick::current

(PECL imagick 2.0.0)

Imagick::current — Geçerli Imagick nesnesini döndürür

Açıklama

Imagick Imagick::current ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Geçerli Imagick nesnesini döndürür.

Dönen Değerler

Başarı durumunda nesnenin kendisi döner. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::cropThumbnailImage
Imagick::cycleColormapImage
Imagick sınıfı


Bir resmin renk eşleminin bir kısmını değiştirir

Imagick::current
Imagick::decipherImage
Imagick sınıfı
PHP Manual

Imagick::cycleColormapImage

(PECL imagick 2.0.0)

Imagick::cycleColormapImage — Bir resmin renk eşleminin bir kısmını değiştirir

Açıklama

bool Imagick::cycleColormapImage ( int $miktar )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bir resmin renk eşleminden belirtilen sayıda rengi değiştirir. Bu işlemi defalarca tekrarlamak suretiyle rengarenk bir resim üretebilirsiniz.

Değiştirgeler

miktar

Renk eşleminde değiştirilecek renk sayısı.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::current
Imagick::decipherImage
Imagick sınıfı


Şifreli bir resmin şifresini çözer

Imagick::cycleColormapImage
Imagick::deconstructImages
Imagick sınıfı
PHP Manual

Imagick::decipherImage

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::decipherImage — Şifreli bir resmin şifresini çözer

Açıklama

bool Imagick::decipherImage ( string $parola )

Evvelce Imagick::encipherImage() ile şifrelenmiş bir resmin şifresini çözer. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.3.9 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

parola

Parola.

Dönen Değerler

Başarı durumunda TRUE döner.

Ayrıca Bakınız

  • Imagick::encipherImage() - Bir resmi şifreler

Imagick::cycleColormapImage
Imagick::deconstructImages
Imagick sınıfı


Resimler arasındaki farklı piksellerin kapladığı en büyük alanı döndürür

Imagick::decipherImage
Imagick::deleteImageArtifact
Imagick sınıfı
PHP Manual

Imagick::deconstructImages

(PECL imagick 2.0.0)

Imagick::deconstructImages — Resimler arasındaki farklı piksellerin kapladığı en büyük alanı döndürür

Açıklama

Imagick Imagick::deconstructImages ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Her resmi bir sonraki ile karşılaştırıp keşfettiği farklı pikselleri sarmalayan en büyük boyutu döndürür.

Dönen Değerler

Başarı durumunda yeni bir Imagick nesnesi döner. Hata durumunda bir ImagickException istisnası oluşur.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::decipherImage
Imagick::deleteImageArtifact
Imagick sınıfı


Delete image artifact

Imagick::deconstructImages
Imagick::deleteImageProperty
Imagick sınıfı
PHP Manual

Imagick::deleteImageArtifact

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::deleteImageArtifact — Delete image artifact

Açıklama

bool Imagick::deleteImageArtifact ( string $artifact )

Deletes an artifact associated with the image. The difference between image properties and image artifacts is that properties are public and artifacts are private. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.5.7 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

artifact

The name of the artifact to delete

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Ayrıca Bakınız

  • Imagick::setImageArtifact() - Set image artifact
  • Imagick::getImageArtifact() - Get image artifact

Imagick::deconstructImages
Imagick::deleteImageProperty
Imagick sınıfı


Description

Imagick::deleteImageArtifact
Imagick::deskewImage
Imagick sınıfı
PHP Manual

Imagick::deleteImageProperty

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::deleteImageProperty — Description

Açıklama

public void Imagick::deleteImageProperty ( string $name )

Deletes an image property.

Değiştirgeler

name

The name of the property to delete.

Dönen Değerler

Imagick::deleteImageArtifact
Imagick::deskewImage
Imagick sınıfı


Removes skew from the image

Imagick::deleteImageProperty
Imagick::despeckleImage
Imagick sınıfı
PHP Manual

Imagick::deskewImage

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::deskewImage — Removes skew from the image

Açıklama

public bool Imagick::deskewImage ( float $threshold )

This method can be used to remove skew from for example scanned images where the paper was not properly placed on the scanning surface. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.4.5 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

threshold

Deskew threshold

Dönen Değerler

Örnekler

Örnek 1 Imagick::deskewImage()

<?php
function deskewImage($threshold) {
    $imagick = new \Imagick(realpath("images/NYTimes-Page1-11-11-1918.jpg"));
    $deskewImagick = clone $imagick;

    //This is the only thing required for deskewing.
    $deskewImagick->deskewImage($threshold);

    //The rest of this example is to make the result obvious - because
    //otherwise the result is not obvious.
    $trim = 9;

    $deskewImagick->cropImage($deskewImagick->getImageWidth() - $trim, $deskewImagick->getImageHeight(), $trim, 0);
    $imagick->cropImage($imagick->getImageWidth() - $trim, $imagick->getImageHeight(), $trim, 0);
    $deskewImagick->resizeimage($deskewImagick->getImageWidth() / 2, $deskewImagick->getImageHeight() / 2, \Imagick::FILTER_LANCZOS, 1);
    $imagick->resizeimage($imagick->getImageWidth() / 2, $imagick->getImageHeight() / 2, \Imagick::FILTER_LANCZOS, 1);
    $newCanvas = new \Imagick();
    $newCanvas->newimage($imagick->getImageWidth() + $deskewImagick->getImageWidth() + 20, $imagick->getImageHeight(), 'red', 'jpg');
    $newCanvas->compositeimage($imagick, \Imagick::COMPOSITE_COPY, 5, 0);
    $newCanvas->compositeimage($deskewImagick, \Imagick::COMPOSITE_COPY, $imagick->getImageWidth() + 10, 0);

    header("Content-Type: image/jpg");
    echo $newCanvas->getImageBlob();
}

?>

Imagick::deleteImageProperty
Imagick::despeckleImage
Imagick sınıfı


Resmin benekli görünümünü düzeltir

Imagick::deskewImage
Imagick::destroy
Imagick sınıfı
PHP Manual

Imagick::despeckleImage

(PECL imagick 2.0.0)

Imagick::despeckleImage — Resmin benekli görünümünü düzeltir

Açıklama

bool Imagick::despeckleImage ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Özgün resmin kenarlarını koruyarak benekli görünümünü düzeltir.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::deskewImage
Imagick::destroy
Imagick sınıfı


Imagick nesnesini siler

Imagick::despeckleImage
Imagick::displayImage
Imagick sınıfı
PHP Manual

Imagick::destroy

(PECL imagick 2.0.0)

Imagick::destroy — Imagick nesnesini siler

Açıklama

bool Imagick::destroy ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bu yöntem Imagick nesnesinin yıkıcısı olup nesneyle ilişkili tüm özkaynakları serbest bırakıp nesneyi siler.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::despeckleImage
Imagick::displayImage
Imagick sınıfı


Bir resmi gösterir

Imagick::destroy
Imagick::displayImages
Imagick sınıfı
PHP Manual

Imagick::displayImage

(PECL imagick 2.0.0)

Imagick::displayImage — Bir resmi gösterir

Açıklama

bool Imagick::displayImage ( string $sunucu )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmi belirtilen X pencere sunucusunda gösterir

Değiştirgeler

sunucu

X sunucusunun ismi.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::destroy
Imagick::displayImages
Imagick sınıfı


Bir resim dizisini gösterir

Imagick::displayImage
Imagick::distortImage
Imagick sınıfı
PHP Manual

Imagick::displayImages

(PECL imagick 2.0.0)

Imagick::displayImages — Bir resim dizisini gösterir

Açıklama

bool Imagick::displayImages ( string $sunucu )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resimleri belirtilen X pencere sunucusunda gösterir.

Değiştirgeler

sunucu

X sunucusunun ismi.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::displayImage
Imagick::distortImage
Imagick sınıfı


Çeşitli yöntemlerle resmi bozunuma uğratır

Imagick::displayImages
Imagick::drawImage
Imagick sınıfı
PHP Manual

Imagick::distortImage

(PECL imagick 2.0.1)

Imagick::distortImage — Çeşitli yöntemlerle resmi bozunuma uğratır

Açıklama

bool Imagick::distortImage ( int $yöntem , array $değiştirgeler , bool $sığdır )

sığdır değiştirgesinde TRUE belirtilmedikçe eski ve yeni resimler arasında boyut farkı olmaksızın çeşitli yöntemlerle resmi bozunuma uğratır.

sığdır değiştirgesinde TRUE belirtildiği takdirde bozunuma uğratılan resim başlangıcı, genişlik ve yüksekliği ayarlanarak yeni resme sığdırılmaya çalışılır. Ayrıca, çoğu durumda, kaynak resmin sanal başlangıcı eşleme sırasında hesaba katılır.

Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.3.6 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

yöntem

Bozunum yöntemi sabitlerinden biri.

değiştirgeler

Bozunum yönteminin değiştirgeleri.

sığdır

TRUE belirtildiği takdirde kaynağın bozunmuş hali yeni resme sığdırmaya çalışılır.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Örnekler

Örnek 1 - Imagick::distortImage() örneği

Resmi bozunuma uğratıp diske yazalım.

<?php
/* Yeni nesneyi oluşturalım */
$im = new Imagick();

/* Yeni checkerboard örüntüsünü oluşturalım */
$im->newPseudoImage(100, 100, "pattern:checkerboard");

/* Resim biçemi PNG olsun */
$im->setImageFormat('png');

/* Yeni görünür alanları şeffaf yapalım */
$im->setImageVirtualPixelMethod(Imagick::VIRTUALPIXELMETHOD_TRANSPARENT);

/* Matlığı etkin kılalım */
$im->setImageMatte(true);

/* Bozunuma uğratılacak noktalar */
$controlPoints = array( 10, 10,
                        10, 5,

                        10, $im->getImageHeight() - 20,
                        10, $im->getImageHeight() - 5,

                        $im->getImageWidth() - 10, 10,
                        $im->getImageWidth() - 10, 20,

                        $im->getImageWidth() - 10, $im->getImageHeight() - 10,
                        $im->getImageWidth() - 10, $im->getImageHeight() - 30);

/* Rasmi bozunuma uğratalım */
$im->distortImage(Imagick::DISTORTION_PERSPECTIVE, $controlPoints, true);

/* Resmi çıktılayalım */
header("Content-Type: image/png");
echo $im;
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ayrıca Bakınız

  • Imagick::blurImage() - Resme bir bulanıklık süzgeci ekler
  • Imagick::motionBlurImage() - Hareket bulanıklığını taklit eder
  • Imagick::radialBlurImage() - Bir resme dairesel bulanıklık uygular

Imagick::displayImages
Imagick::drawImage
Imagick sınıfı


Belirtilen ImagickDraw nesnesini resme uygular

Imagick::distortImage
Imagick::edgeImage
Imagick sınıfı
PHP Manual

Imagick::drawImage

(PECL imagick 2.0.0)

Imagick::drawImage — Belirtilen ImagickDraw nesnesini resme uygular

Açıklama

bool Imagick::drawImage ( ImagickDraw $işlem )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Belirtilen ImagickDraw nesnesini resme uygular.

Değiştirgeler

işlem

Resme uygulanacak çizim işlemi.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::distortImage
Imagick::edgeImage
Imagick sınıfı


Resmin kenarlarını evriştirir

Imagick::drawImage
Imagick::embossImage
Imagick sınıfı
PHP Manual

Imagick::edgeImage

(PECL imagick 2.0.0)

Imagick::edgeImage — Resmin kenarlarını evriştirir

Açıklama

bool Imagick::edgeImage ( float $yarıçap )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Belirtilen yarıçapa bir evrişim süzgeci uygulamak suretiyle resmin kenarlarını evriştirir. yarıçap olarak 0 verirseniz Imagick::edgeImage() size uygun bir yarıçap seçecektir.

Değiştirgeler

yarıçap

Evrişim yarıçapı.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::drawImage
Imagick::embossImage
Imagick sınıfı


Üç boyutluluk etkisi vermek için resmi gri tonlamaya dönüştürür

Imagick::edgeImage
Imagick::encipherImage
Imagick sınıfı
PHP Manual

Imagick::embossImage

(PECL imagick 2.0.0)

Imagick::embossImage — Üç boyutluluk etkisi vermek için resmi gri tonlamaya dönüştürür

Açıklama

bool Imagick::embossImage ( float $yarıçap , float $sapma )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Üç boyutluluk etkisi vermek için resmi gri tonlamaya dönüştürür. Yarıçap ve standart sapması belirtilen bir Gauss işleci ile resim evriştirilir. Makul sonuçlar elde etmek için yarıçap standart sapmadan büyük olmalıdır. yarıçap olarak 0 verirseniz Imagick::embossImage() size uygun bir yarıçap seçecektir.

Değiştirgeler

yarıçap

Etkinin uygulanacağı yarıçap.

sapma

Piksel cinsinden standart sapma.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::edgeImage
Imagick::encipherImage
Imagick sınıfı


Bir resmi şifreler

Imagick::embossImage
Imagick::enhanceImage
Imagick sınıfı
PHP Manual

Imagick::encipherImage

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::encipherImage — Bir resmi şifreler

Açıklama

bool Imagick::encipherImage ( string $parola )

Düz pikselleri şifreli piksellere dönüştürür. Resmin şifresi Imagick::decipherImage() ile çözülene kadar okunabilir olmayacaktır. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.3.9 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

parola

Parola.

Dönen Değerler

Başarı durumunda TRUE döner.

Ayrıca Bakınız

  • Imagick::decipherImage() - Şifreli bir resmin şifresini çözer

Imagick::embossImage
Imagick::enhanceImage
Imagick sınıfı


Resmin görüntü kalitesini arttırır

Imagick::encipherImage
Imagick::equalizeImage
Imagick sınıfı
PHP Manual

Imagick::enhanceImage

(PECL imagick 2.0.0)

Imagick::enhanceImage — Resmin görüntü kalitesini arttırır

Açıklama

bool Imagick::enhanceImage ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin görüntü kalitesini arttırmak için bir sayısal süzeç uygular.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::encipherImage
Imagick::equalizeImage
Imagick sınıfı


Resmin renk dağılımını dengeler

Imagick::enhanceImage
Imagick::evaluateImage
Imagick sınıfı
PHP Manual

Imagick::equalizeImage

(PECL imagick 2.0.0)

Imagick::equalizeImage — Resmin renk dağılımını dengeler

Açıklama

bool Imagick::equalizeImage ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin renk dağılımını dengeler.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::enhanceImage
Imagick::evaluateImage
Imagick sınıfı


Resme bir ifade uygular

Imagick::equalizeImage
Imagick::exportImagePixels
Imagick sınıfı
PHP Manual

Imagick::evaluateImage

(PECL imagick 2.0.0)

Imagick::evaluateImage — Resme bir ifade uygular

Açıklama

bool Imagick::evaluateImage ( int $işleç , float $terim [, int $kanal = Imagick::CHANNEL_ALL ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resme aritmetik, mantıksal ya da ilişkisel bir ifade uygular. Resmin aydınlık veya karanlık yapmak için, resmin zıtlığını azaltıp arttırmak için veya resmin negatifini elde etmek için bu yöntemi kullanabilirsiniz.

Değiştirgeler

işleç

İşleç sabitlerinden biri.

terim

İşlecin değeri.

kanal

Normalde kanal türü sabitlerinden biri, ancak bitsel işleçler kullanılarak birden fazla kanal belirtilebilir.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::equalizeImage
Imagick::exportImagePixels
Imagick sınıfı


Exports raw image pixels

Imagick::evaluateImage
Imagick::extentImage
Imagick sınıfı
PHP Manual

Imagick::exportImagePixels

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::exportImagePixels — Exports raw image pixels

Açıklama

public array Imagick::exportImagePixels ( int $x , int $y , int $width , int $height , string $map , int $STORAGE )

Exports image pixels into an array. The map defines the ordering of the exported pixels. The size of the returned array is width * height * strlen(map). Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.4.7 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

x

X-coordinate of the exported area

y

Y-coordinate of the exported area

width

Width of the exported aread

height

Height of the exported area

map

Ordering of the exported pixels. For example "RGB". Valid characters for the map are R, G, B, A, O, C, Y, M, K, I and P.

STORAGE

Refer to this list of pixel type constants

Örnekler

Örnek 1 Using Imagick::exportImagePixels()

Export image pixels into an array

<?php

/* Create new object */
$im = new Imagick();

/* Create new image */
$im->newPseudoImage(0, 0, "magick:rose");

/* Export the image pixels */
$pixels = $im->exportImagePixels(10, 10, 2, 2, "RGB", Imagick::PIXEL_CHAR);

/* Output */
var_dump($pixels);
?>

Yukarıdaki örneğin çıktısı:

array(12) {
  [0]=>
  int(72)
  [1]=>
  int(64)
  [2]=>
  int(57)
  [3]=>
  int(69)
  [4]=>
  int(59)
  [5]=>
  int(43)
  [6]=>
  int(124)
  [7]=>
  int(120)
  [8]=>
  int(-96)
  [9]=>
  int(91)
  [10]=>
  int(84)
  [11]=>
  int(111)
}

Dönen Değerler

Returns an array containing the pixels values.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::evaluateImage
Imagick::extentImage
Imagick sınıfı


Resim boyutlarını belirler

Imagick::exportImagePixels
Imagick::filter
Imagick sınıfı
PHP Manual

Imagick::extentImage

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::extentImage — Resim boyutlarını belirler

Açıklama

bool Imagick::extentImage ( int $genişlik , int $yükseklik , int $x , int $y )

Resim boyutlarını atamak için geriye uyumlu bir yöntemdir. Yöntem resmin boyutlarını belirlemekten başka resmin tuval üzerindeki başlangıç koordinatlarını da belirler. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.3.1 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

genişlik

Resmin yeni genişliği.

yükseklik

Resmin yeni yüksekliği.

x

Resmin yeni X konumu.

y

Resmin yeni Y konumu.

Dönen Değerler

Başarı durumunda TRUE döner.

Ayrıca Bakınız

  • Imagick::resizeImage() - Bir resmi boyutlandırır
  • Imagick::thumbnailImage() - Resmin boyutlarını değiştirir
  • Imagick::cropImage() - Resmin bir bölgesini çıkarır

Imagick::exportImagePixels
Imagick::filter
Imagick sınıfı


Description

Imagick::extentImage
Imagick::flattenImages
Imagick sınıfı
PHP Manual

Imagick::filter

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::filter — Description

Açıklama

public void Imagick::filter ( ImagickKernel $ImagickKernel [, int $CHANNEL = Imagick::CHANNEL_DEFAULT ] )

Applies a custom convolution kernel to the image.

Değiştirgeler

ImagickKernel

An instance of ImagickKernel that represents either a single kernel or a linked series of kernels.

CHANNEL

Normalde kanal türü sabitlerinden biridir, ancak bitsel işleçler kullanılarak birden fazla kanal belirtilebilir. Imagick::CHANNEL_DEFAULT öntanımlıdır.

Dönen Değerler

Örnekler

Örnek 1 Imagick::filter()

<?php
function filter($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $matrix = [
        [-1, 0, -1],
        [0,  5,  0],
        [-1, 0, -1],
    ];

    $kernel = \ImagickKernel::fromMatrix($matrix);
    $strength = 0.5;
    $kernel->scale($strength, \Imagick::NORMALIZE_KERNEL_VALUE);
    $kernel->addUnityKernel(1 - $strength);

    $imagick->filter($kernel);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>

Imagick::extentImage
Imagick::flattenImages
Imagick sınıfı


Bir resim dizisini tek bir resim halinde üstüste bindirir

Imagick::filter
Imagick::flipImage
Imagick sınıfı
PHP Manual

Imagick::flattenImages

(PECL imagick 2.0.0)

Imagick::flattenImages — Bir resim dizisini tek bir resim halinde üstüste bindirir

Açıklama

Imagick Imagick::flattenImages ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bir resim dizisini tek bir resim halinde üstüste bindirir. Photoshop katmanlarını tek bir resim elde edecek şekilde birleştirmek için faydalıdır.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::filter
Imagick::flipImage
Imagick sınıfı


Resmin düşeydeki yansımasını oluşturur

Imagick::flattenImages
Imagick::floodFillPaintImage
Imagick sınıfı
PHP Manual

Imagick::flipImage

(PECL imagick 2.0.0)

Imagick::flipImage — Resmin düşeydeki yansımasını oluşturur

Açıklama

bool Imagick::flipImage ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Pikselleri X eksenine göre yansıtarak resmin düşeydeki yansımasını oluşturur.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::flattenImages
Imagick::floodFillPaintImage
Imagick sınıfı


Hedefle eşleşen piksellerin renklerini değiştirir

Imagick::flipImage
Imagick::flopImage
Imagick sınıfı
PHP Manual

Imagick::floodFillPaintImage

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::floodFillPaintImage — Hedefle eşleşen piksellerin renklerini değiştirir

Açıklama

bool Imagick::floodFillPaintImage ( mixed $dolgu , float $benzerlik , mixed $hedef , int $x , int $y , bool $ters [, int $kanal = Imagick::CHANNEL_DEFAULT ] )

Hedefin ve yakın komşularının renk değerini değiştirir. Bu yöntem artık kullanımı önerilmeyen Imagick::paintFloodFillImage() işlevinin yerini almıştır. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.3.8 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

dolgu

Dolgu rengini içeren bir dizge veya bir ImagickPixel nesnesi.

benzerlik

Renkler arasındaki azami benzerlik. Örneğin bu değere 10 atarsanız, renk kırmızı ise ve kırmızının koyulukları 100 ve 102 ise bu iki renk aynı kabul edilir.

hedef

Boyanacak hedef rengi içeren bir dizge veya bir ImagickPixel nesnesi.

x

Renk değişikliğinin başlatılacağı X konumu.

y

Renk değişikliğinin başlatılacağı Y konumu.

ters

TRUE belirtilirse hedefle eşlemeyen renkler değiştirilir.

channel

Normalde kanal türü sabitlerinden biridir, ancak bitsel işleçler kullanılarak birden fazla kanal belirtilebilir. Imagick::CHANNEL_DEFAULT öntanımlıdır.

Dönen Değerler

Başarı durumunda TRUE döner.

Örnekler

Örnek 1 - Imagick::floodfillPaintImage() örneği

<?php

/* Yeni bir imagick nesnesi oluşturalım */
$im = new Imagick();

/* kırmızı, yeşil ve mavi tuvaller oluşturalım */
$im->newImage(100, 50, "red");
$im->newImage(100, 50, "green");
$im->newImage(100, 50, "blue");

/* Bunları birbirlerine ekleyelim */
$im->resetIterator();
$combined = $im->appendImages(true);

/* Elde edilen resmi karşılaştırmak için saklayalım */
$combined->writeImage("floodfillpaint_intermediate.png");

/* Boyanacak hedef piksel */
$x = 1;
$y = 1;

/* Boyanacak pikselin rengini öğrenelim */
$target = $combined->getImagePixelColor($x, $y);

/* Hedef pikseli ve aynı renkteki komşu pikselleri siyaha boyayalım */
$combined->floodfillPaintImage("black", 1, $target, $x, $y, false);

/* Sonucu kaydedelimt */
$combined->writeImage("floodfillpaint_result.png");
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Imagick::flipImage
Imagick::flopImage
Imagick sınıfı


Resmin yataydaki yansımasını oluşturur

Imagick::floodFillPaintImage
Imagick::forwardFourierTransformImage
Imagick sınıfı
PHP Manual

Imagick::flopImage

(PECL imagick 2.0.0)

Imagick::flopImage — Resmin yataydaki yansımasını oluşturur

Açıklama

bool Imagick::flopImage ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Pikselleri Y eksenine göre yansıtarak resmin yataydaki yansımasını oluşturur.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::floodFillPaintImage
Imagick::forwardFourierTransformImage
Imagick sınıfı


Description

Imagick::flopImage
Imagick::frameImage
Imagick sınıfı
PHP Manual

Imagick::forwardFourierTransformImage

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::forwardFourierTransformImage — Description

Açıklama

public void Imagick::forwardFourierTransformimage ( bool $magnitude )

Implements the discrete Fourier transform (DFT) of the image either as a magnitude / phase or real / imaginary image pair.

Değiştirgeler

magnitude

If true, return as magnitude / phase pair otherwise a real / imaginary image pair.

Dönen Değerler

Örnekler

Örnek 1 Imagick::forwardFourierTransformImage()

<?php
//Utility function for forwardTransformImage
function createMask() {
    $draw = new \ImagickDraw();

    $draw->setStrokeOpacity(0);
    $draw->setStrokeColor('rgb(255, 255, 255)');
    $draw->setFillColor('rgb(255, 255, 255)');

    //Draw a circle on the y-axis, with it's centre
    //at x, y that touches the origin
    $draw->circle(250, 250, 220, 250);

    $imagick = new \Imagick();
    $imagick->newImage(512, 512, "black");
    $imagick->drawImage($draw);
    $imagick->gaussianBlurImage(20, 20);
    $imagick->autoLevelImage();

    return $imagick;
}

function forwardFourierTransformImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->resizeimage(512, 512, \Imagick::FILTER_LANCZOS, 1);

    $mask = createMask();
    $imagick->forwardFourierTransformImage(true);

    @$imagick->setimageindex(0);
    $magnitude = $imagick->getimage();

    @$imagick->setimageindex(1);
    $imagickPhase = $imagick->getimage();

    if (true) {
        $imagickPhase->compositeImage($mask, \Imagick::COMPOSITE_MULTIPLY, 0, 0);
    }

    if (false) {
        $output = clone $imagickPhase;
        $output->setimageformat('png');
        header("Content-Type: image/png");
        echo $output->getImageBlob();
    }

    $magnitude->inverseFourierTransformImage($imagickPhase, true);

    $magnitude->setimageformat('png');
    header("Content-Type: image/png");
    echo $magnitude->getImageBlob();
}

?>

Imagick::flopImage
Imagick::frameImage
Imagick sınıfı


Üç boyutluluğu taklit ederek bir çerçeve ekler

Imagick::forwardFourierTransformImage
Imagick::functionImage
Imagick sınıfı
PHP Manual

Imagick::frameImage

(PECL imagick 2.0.0)

Imagick::frameImage — Üç boyutluluğu taklit ederek bir çerçeve ekler

Açıklama

bool Imagick::frameImage ( mixed $mat_renk , int $genişlik , int $yükseklik , int $iç_pah , int $dış_pah )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin çevresine üçboyutlu taklidi bir çerçeve ekler. genişlik ve yükseklik çerçevenin yatay ve düşey kenarlarının uzunluklarıdır. iç_pah ve dış_pah ise çerçevenin iç ve dış gölge genişlikleridir.

Değiştirgeler

mat_renk

Mat rengi ifade eden bir renk dizgesi veya bir ImagickPixel nesnesi.

genişlik

Çerçeve genişliği.

yükseklik

Çerçeve yüksekliği.

iç_pah

İç pah genişliği.

dış_pah

Dış pah genişliği.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Sürüm Bilgisi

Sürüm: | Açıklama
2.1.0 | Artık renk olarak rengi ifade eden bir dizge belirtilebiliyor. Evvelce sadece bir ImagickPixel nesnesi belirtilebiliyordu.

Imagick::forwardFourierTransformImage
Imagick::functionImage
Imagick sınıfı


Applies a function on the image

Imagick::frameImage
Imagick::fxImage
Imagick sınıfı
PHP Manual

Imagick::functionImage

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::functionImage — Applies a function on the image

Açıklama

public bool Imagick::functionImage ( int $function , array $arguments [, int $channel = Imagick::CHANNEL_DEFAULT ] )

Applies an arithmetic, relational, or logical expression to a pseudo image.

See also » ImageMagick v6 Examples - Image Transformations — Function, Multi-Argument Evaluate

Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.4.9 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

function

Refer to this list of function constants

arguments

Array of arguments to pass to this function.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Örnekler

Örnek 1 Create a sinusoidal gradient

<?php
$imagick = new Imagick();
$imagick->newPseudoImage(200, 200, 'gradient:black-white');
$arguments = array(3, -90);
$imagick->functionImage(Imagick::FUNCTION_SINUSOID, $arguments);

header("Content-Type: image/png");
$imagick->setImageFormat("png");
echo $imagick->getImageBlob();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Output of create a sinusoidal gradient

Örnek 2 Create a gradient from the polynomial (4x^2 - 4x + 1)

<?php
$imagick = new Imagick();
$imagick->newPseudoImage(200, 200, 'gradient:black-white');
$arguments = array(4, -4, 1);
$imagick->functionImage(Imagick::FUNCTION_POLYNOMIAL, $arguments);

header("Content-Type: image/png");
$imagick->setimageformat("png");
echo $imagick->getImageBlob();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Output of create a polynomial gradient

Örnek 3 Create a complex gradient from the polynomial (4x^2 - 4x^2 + 1) modulated by a sinusoidal gradient

<?php
$imagick1 = new Imagick();
$imagick1->newPseudoImage(200, 200, 'gradient:black-white');
$arguments = array(9, -90);
$imagick1->functionImage(Imagick::FUNCTION_SINUSOID, $arguments);

$imagick2 = new Imagick();
$imagick2->newPseudoImage(200, 200, 'gradient:black-white');
$arguments = array(0.5, 0);
$imagick2->functionImage(Imagick::FUNCTION_SINUSOID, $arguments);
$imagick1->compositeimage($imagick2, Imagick::COMPOSITE_MULTIPLY, 0, 0);

header("Content-Type: image/png");
$imagick1->setImageFormat("png");
echo $imagick1->getImageBlob();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Output of create complex gradient

Imagick::frameImage
Imagick::fxImage
Imagick sınıfı


Bir ifadeyi resimdeki her piksele uygular

Imagick::functionImage
Imagick::gammaImage
Imagick sınıfı
PHP Manual

Imagick::fxImage

(PECL imagick 2.0.0)

Imagick::fxImage — Bir ifadeyi resimdeki her piksele uygular

Açıklama

Imagick Imagick::fxImage ( string $ifade [, int $kanal = Imagick::CHANNEL_ALL ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Belirtilen ifadeyi resimdeki her piksele uygular. Daha fazla bilgi için » Özel etkiler için Fx resim işleci sayfasına bakınız.

Değiştirgeler

ifadeyi

Her piksele uygulanacak ifade.

kanal

Normalde kanal türü sabitlerinden biri, ancak bitsel işleçler kullanılarak birden fazla kanal belirtilebilir.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::functionImage
Imagick::gammaImage
Imagick sınıfı


Resmin gammasını düzeltir

Imagick::fxImage
Imagick::gaussianBlurImage
Imagick sınıfı
PHP Manual

Imagick::gammaImage

(PECL imagick 2.0.0)

Imagick::gammaImage — Resmin gammasını düzeltir

Açıklama

bool Imagick::gammaImage ( float $gamma [, int $kanal = Imagick::CHANNEL_ALL ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin gammasını düzeltir. Aynı resim farklı ekranlarda algısal olarak bazı farklar gösterir. Bu farkları düzeltmek için kırmızı, mavi ve yeşil kanalların gamma değerlerinde değişiklik yapılır. Bu değerler 0.8 ile 2.3 arasında belirtilir.

Değiştirgeler

gamma

Kanalın gamma düzeltmesi.

kanal

Normalde kanal türü sabitlerinden biri, ancak bitsel işleçler kullanılarak birden fazla kanal belirtilebilir.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::fxImage
Imagick::gaussianBlurImage
Imagick sınıfı


Resmi bulanıklaştırır

Imagick::gammaImage
Imagick::getColorspace
Imagick sınıfı
PHP Manual

Imagick::gaussianBlurImage

(PECL imagick 2.0.0)

Imagick::gaussianBlurImage — Resmi bulanıklaştırır

Açıklama

bool Imagick::gaussianBlurImage ( float $yarıçap , float $sapma [, int $kanal = Imagick::CHANNEL_ALL ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmi bulanıklaştırır. Yarıçap ve standart sapması belirtilen bir Gauss işleci ile resim evriştirilir. Makul sonuçlar elde etmek için yarıçap standart sapmadan büyük olmalıdır. yarıçap olarak 0 verirseniz Imagick::motionBlurImage() size uygun bir yarıçap seçecektir.

Değiştirgeler

yarıçap

Merkezdeki piksel sayısı değil, piksel cinsinden Gauss işleci yarıçapıdır.

sapma

Piksel cinsinden standart sapma.

kanal

Normalde kanal türü sabitlerinden biri, ancak bitsel işleçler kullanılarak birden fazla kanal belirtilebilir.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::gammaImage
Imagick::getColorspace
Imagick sınıfı


Gets the colorspace

Imagick::gaussianBlurImage
Imagick::getCompression
Imagick sınıfı
PHP Manual

Imagick::getColorspace

(PECL imagick 0.9.10-0.9.9)

Imagick::getColorspace — Gets the colorspace

Açıklama

int Imagick::getColorspace ( void )

Gets the global colorspace value. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.5.7 veya sonraki bir sürümü kuruluysa kullanılabilir.

Dönen Değerler

Returns an integer which can be compared against COLORSPACE constants.

Imagick::gaussianBlurImage
Imagick::getCompression
Imagick sınıfı


Nesnenin sıkıştırma türünü döndürür

Imagick::getColorspace
Imagick::getCompressionQuality
Imagick sınıfı
PHP Manual

Imagick::getCompression

(PECL imagick 2.0.0)

Imagick::getCompression — Nesnenin sıkıştırma türünü döndürür

Açıklama

int Imagick::getCompression ( void )

Nesnenin sıkıştırma türünü döndürür.

Dönen Değerler

Nesnenin sıkıştırma türünü sıkıştırma sabitlerinden biri olarak döndürür.

Imagick::getColorspace
Imagick::getCompressionQuality
Imagick sınıfı


Nesnenin sıkıştırma seviyesini döndürür

Imagick::getCompression
Imagick::getCopyright
Imagick sınıfı
PHP Manual

Imagick::getCompressionQuality

(PECL imagick 2.0.0)

Imagick::getCompressionQuality — Nesnenin sıkıştırma seviyesini döndürür

Açıklama

int Imagick::getCompressionQuality ( void )

Nesnenin sıkıştırma seviyesini döndürür.

Dönen Değerler

Nesnenin sıkıştırma seviyesini bir tamsayı olarak döndürür.

Imagick::getCompression
Imagick::getCopyright
Imagick sınıfı


ImageMagick telif hakkı bilgisini döndürür

Imagick::getCompressionQuality
Imagick::getFilename
Imagick sınıfı
PHP Manual

Imagick::getCopyright

(PECL imagick 2.0.0)

Imagick::getCopyright — ImageMagick telif hakkı bilgisini döndürür

Açıklama

string Imagick::getCopyright ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ImageMagick telif hakkı bilgisini döndürür.

Dönen Değerler

ImageMagick telif hakkı bilgisini içeren bir dizge döndürür.

Imagick::getCompressionQuality
Imagick::getFilename
Imagick sınıfı


Resim dizisi ile ilişkili dosya ismini döndürür

Imagick::getCopyright
Imagick::getFont
Imagick sınıfı
PHP Manual

Imagick::getFilename

(PECL imagick 2.0.0)

Imagick::getFilename — Resim dizisi ile ilişkili dosya ismini döndürür

Açıklama

string Imagick::getFilename ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resim dizisi ile ilişkili dosya ismini döndürür.

Dönen Değerler

Başarı durumunda bir dizge döner. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getCopyright
Imagick::getFont
Imagick sınıfı


Yazıtipini döndürür

Imagick::getFilename
Imagick::getFormat
Imagick sınıfı
PHP Manual

Imagick::getFont

(PECL imagick 2.1.0)

Imagick::getFont — Yazıtipini döndürür

Açıklama

string Imagick::getFont ( void )

Nesnenin yazıtipini döndürür. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.3.7 veya sonraki bir sürümü kuruluysa kullanılabilir.

Dönen Değerler

Bir yazıtipi tanımlı değilse FALSE, tanımlıysa yazıtipi ismini içeren bir dizge döner.

Ayrıca Bakınız

  • Imagick::setFont() - Imagick nesnesinin yazı tipini tanımlar
  • ImagickDraw::setFont() - Metni çizerken kullanılacak yazı tipini tam belirtimiyle belirler
  • ImagickDraw::getFont() - Geçerli yazı tipini döndürür

Imagick::getFilename
Imagick::getFormat
Imagick sınıfı


Imagick nesnesinin biçemini döndürür

Imagick::getFont
Imagick::getGravity
Imagick sınıfı
PHP Manual

Imagick::getFormat

(PECL imagick 2.0.0)

Imagick::getFormat — Imagick nesnesinin biçemini döndürür

Açıklama

string Imagick::getFormat ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Imagick nesnesinin biçemini döndürür.

Dönen Değerler

Imagick nesnesinin biçemini bir dizge olarak döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getFont
Imagick::getGravity
Imagick sınıfı


Gets the gravity

Imagick::getFormat
Imagick::getHomeURL
Imagick sınıfı
PHP Manual

Imagick::getGravity

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::getGravity — Gets the gravity

Açıklama

int Imagick::getGravity ( void )

Gets the global gravity property for the Imagick object. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.4.0 veya sonraki bir sürümü kuruluysa kullanılabilir.

Dönen Değerler

Returns the gravity property. Refer to the list of gravity constants.

Imagick::getFormat
Imagick::getHomeURL
Imagick sınıfı


ImageMagick sitesinin adresini döndürür

Imagick::getGravity
Imagick::getImage
Imagick sınıfı
PHP Manual

Imagick::getHomeURL

(PECL imagick 2.0.0)

Imagick::getHomeURL — ImageMagick sitesinin adresini döndürür

Açıklama

string Imagick::getHomeURL ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ImageMagick sitesinin adresini döndürür.

Dönen Değerler

ImageMagick sitesinin adresini içeren bir dizge döndürür.

Imagick::getGravity
Imagick::getImage
Imagick sınıfı


Yeni bir Imagick nesnesi döndürür

Imagick::getHomeURL
Imagick::getImageAlphaChannel
Imagick sınıfı
PHP Manual

Imagick::getImage

(PECL imagick 2.0.0)

Imagick::getImage — Yeni bir Imagick nesnesi döndürür

Açıklama

Imagick Imagick::getImage ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Geçerli resim dizisine dahil yeni bir Imagick nesnesi döndürür.

Dönen Değerler

Yeni bir Imagick nesnesi döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getHomeURL
Imagick::getImageAlphaChannel
Imagick sınıfı


Gets the image alpha channel

Imagick::getImage
Imagick::getImageArtifact
Imagick sınıfı
PHP Manual

Imagick::getImageAlphaChannel

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::getImageAlphaChannel — Gets the image alpha channel

Açıklama

int Imagick::getImageAlphaChannel ( void )

Gets the image alpha channel value. The returned value is one of the alpha channel constants. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.4.0 veya sonraki bir sürümü kuruluysa kullanılabilir.

Dönen Değerler

Returns a constant defining the current alpha channel value. Refer to this list of alpha channel constants.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImage
Imagick::getImageArtifact
Imagick sınıfı


Get image artifact

Imagick::getImageAlphaChannel
Imagick::getImageAttribute
Imagick sınıfı
PHP Manual

Imagick::getImageArtifact

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::getImageArtifact — Get image artifact

Açıklama

string Imagick::getImageArtifact ( string $artifact )

Gets an artifact associated with the image. The difference between image properties and image artifacts is that properties are public and artifacts are private. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.5.7 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

artifact

The name of the artifact

Dönen Değerler

Returns the artifact value on success.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Ayrıca Bakınız

  • Imagick::setImageArtifact() - Set image artifact
  • Imagick::deleteImageArtifact() - Delete image artifact

Imagick::getImageAlphaChannel
Imagick::getImageAttribute
Imagick sınıfı


Description

Imagick::getImageArtifact
Imagick::getImageBackgroundColor
Imagick sınıfı
PHP Manual

Imagick::getImageAttribute

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::getImageAttribute — Description

Açıklama

public string Imagick::getImageAttribute ( string $key )

Returns a named attribute.

Değiştirgeler

key

The key of the attribute to get.

Dönen Değerler

Imagick::getImageArtifact
Imagick::getImageBackgroundColor
Imagick sınıfı


Resmin artalan rengini döndürür

Imagick::getImageAttribute
Imagick::getImageBlob
Imagick sınıfı
PHP Manual

Imagick::getImageBackgroundColor

(PECL imagick 2.0.0)

Imagick::getImageBackgroundColor — Resmin artalan rengini döndürür

Açıklama

ImagickPixel Imagick::getImageBackgroundColor ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin artalan rengini döndürür.

Dönen Değerler

Resmin artalan rengini bir ImagickPixel nesnesi olarak döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageAttribute
Imagick::getImageBlob
Imagick sınıfı


Resim dizisini ber ikil dizge olarak döndürür

Imagick::getImageBackgroundColor
Imagick::getImageBluePrimary
Imagick sınıfı
PHP Manual

Imagick::getImageBlob

(PECL imagick 2.0.0)

Imagick::getImageBlob — Resim dizisini ber ikil dizge olarak döndürür

Açıklama

string Imagick::getImageBlob ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmi bellekteki biçemiyle bir ikil dizge olarak döndürür. Resmin biçemi dönen dizgenin dosya biçemine bağlıdır (GIF, JPEG, PNG, vb.). Resim biçemini değiştirmek için Imagick::setImageFormat() yöntemini kullanın.

Dönen Değerler

Resmi içeren bir ikil dizge döner. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageBackgroundColor
Imagick::getImageBluePrimary
Imagick sınıfı


Resmin renk bileşenlerinden birincil mavi noktayı döndürür

Imagick::getImageBlob
Imagick::getImageBorderColor
Imagick sınıfı
PHP Manual

Imagick::getImageBluePrimary

(PECL imagick 2.0.0)

Imagick::getImageBluePrimary — Resmin renk bileşenlerinden birincil mavi noktayı döndürür

Açıklama

array Imagick::getImageBluePrimary ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin renk bileşenlerinden birincil mavi noktayı "x" ve "y" anahtarlı bir dizi olarak döndürür.

Dönen Değerler

Başarı durumunda resmin renk bileşenlerinden birincil mavi noktayı "x" ve "y" anahtarlı bir dizi olarak döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageBlob
Imagick::getImageBorderColor
Imagick sınıfı


Resmin çerçeve rengini döndürür

Imagick::getImageBluePrimary
Imagick::getImageChannelDepth
Imagick sınıfı
PHP Manual

Imagick::getImageBorderColor

(PECL imagick 2.0.0)

Imagick::getImageBorderColor — Resmin çerçeve rengini döndürür

Açıklama

ImagickPixel Imagick::getImageBorderColor ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin çerçeve rengini döndürür.

Dönen Değerler

Resmin çerçeve rengini bir ImagickPixel nesnesi olarak döndürür.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageBluePrimary
Imagick::getImageChannelDepth
Imagick sınıfı


Belirtilen kanalın derinliğini döndürür

Imagick::getImageBorderColor
Imagick::getImageChannelDistortion
Imagick sınıfı
PHP Manual

Imagick::getImageChannelDepth

(PECL imagick 2.0.0)

Imagick::getImageChannelDepth — Belirtilen kanalın derinliğini döndürür

Açıklama

int Imagick::getImageChannelDepth ( int $kanal )

Belirtilen resim kanalının derinliğini döndürür.

Değiştirgeler

kanal

Normalde kanal türü sabitlerinden biridir, ancak bitsel işleçler kullanılarak birden fazla kanal belirtilebilir. Imagick::CHANNEL_DEFAULT öntanımlıdır.

Dönen Değerler

Belirtilen resim kanalının derinliğini bir tamsayı olarak döndürür.

Imagick::getImageBorderColor
Imagick::getImageChannelDistortion
Imagick sınıfı


Resmin kanallarını yeniden oluşturulan bir resimle karşılaştırır

Imagick::getImageChannelDepth
Imagick::getImageChannelDistortions
Imagick sınıfı
PHP Manual

Imagick::getImageChannelDistortion

(PECL imagick 2.0.0)

Imagick::getImageChannelDistortion — Resmin kanallarını yeniden oluşturulan bir resimle karşılaştırır

Açıklama

float Imagick::getImageChannelDistortion ( Imagick $resim , int $kanal , int $metrik )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin kanallarını yeniden oluşturulan bir resimle karşılaştırır ve belirtilen bozunum metriğini döndürür.

Değiştirgeler

resim

Karşılaştırılacak Imagick nesnesi.

kanal

Normalde kanal türü sabitlerinden biri, ancak bitsel işleçler kullanılarak birden fazla kanal belirtilebilir.

metric

Metrik sabitlerinden biri.

Dönen Değerler

Belirtilen bozunum metriğini bir gerçek sayı olarak döndürür.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageChannelDepth
Imagick::getImageChannelDistortions
Imagick sınıfı


Gets channel distortions

Imagick::getImageChannelDistortion
Imagick::getImageChannelExtrema
Imagick sınıfı
PHP Manual

Imagick::getImageChannelDistortions

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::getImageChannelDistortions — Gets channel distortions

Açıklama

float Imagick::getImageChannelDistortions ( Imagick $reference , int $metric [, int $channel = Imagick::CHANNEL_DEFAULT ] )

Compares one or more image channels of an image to a reconstructed image and returns the specified distortion metrics Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.4.4 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

reference

Imagick object containing the reference image

metric

Refer to this list of metric type constants.

channel

Normalde kanal türü sabitlerinden biridir, ancak bitsel işleçler kullanılarak birden fazla kanal belirtilebilir. Imagick::CHANNEL_DEFAULT öntanımlıdır.

Dönen Değerler

Returns a double describing the channel distortion.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageChannelDistortion
Imagick::getImageChannelExtrema
Imagick sınıfı


Belirtilen kanalların uç değerlerini döndürür

Imagick::getImageChannelDistortions
Imagick::getImageChannelKurtosis
Imagick sınıfı
PHP Manual

Imagick::getImageChannelExtrema

(PECL imagick 2.0.0)

Imagick::getImageChannelExtrema — Belirtilen kanalların uç değerlerini döndürür

Açıklama

array Imagick::getImageChannelExtrema ( int $kanal )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Belirtilen kanal veya kanalların uç değerlerini "minima" ve "maxima" anahtarlı bir ilişkisel dizi olarak döndürür.

Değiştirgeler

kanal

Normalde kanal türü sabitlerinden biri, ancak bitsel işleçler kullanılarak birden fazla kanal belirtilebilir.

Dönen Değerler

Başarı durumunda kanal veya kanalların uç değerlerini "minima" ve "maxima" anahtarlı bir ilişkisel dizi olarak döndürür.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageChannelDistortions
Imagick::getImageChannelKurtosis
Imagick sınıfı


The getImageChannelKurtosis purpose

Imagick::getImageChannelExtrema
Imagick::getImageChannelMean
Imagick sınıfı
PHP Manual

Imagick::getImageChannelKurtosis

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::getImageChannelKurtosis — The getImageChannelKurtosis purpose

Açıklama

public array Imagick::getImageChannelKurtosis ([ int $channel = Imagick::CHANNEL_DEFAULT ] )

Get the kurtosis and skewness of a specific channel. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.4.9 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

channel

Normalde kanal türü sabitlerinden biridir, ancak bitsel işleçler kullanılarak birden fazla kanal belirtilebilir. Imagick::CHANNEL_DEFAULT öntanımlıdır.

Dönen Değerler

Returns an array with kurtosis and skewness members.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageChannelExtrema
Imagick::getImageChannelMean
Imagick sınıfı


Kanal ortalama ve standart sapmasını döndürür

Imagick::getImageChannelKurtosis
Imagick::getImageChannelRange
Imagick sınıfı
PHP Manual

Imagick::getImageChannelMean

(PECL imagick 2.0.0)

Imagick::getImageChannelMean — Kanal ortalama ve standart sapmasını döndürür

Açıklama

array Imagick::getImageChannelMean ( int $kanal )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Belirtilen kanal veya kanalların ortalama ve standart sapmasını "mean" ve "standardDeviation" anahtarlı bir dizi olarak döndürür.

Değiştirgeler

kanal

Normalde kanal türü sabitlerinden biri, ancak bitsel işleçler kullanılarak birden fazla kanal belirtilebilir.

Dönen Değerler

Başarı durumunda kanalların ortalama ve standart sapmasını "mean" ve "standardDeviation" anahtarlı bir dizi olarak döndürür.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageChannelKurtosis
Imagick::getImageChannelRange
Imagick sınıfı


Gets channel range

Imagick::getImageChannelMean
Imagick::getImageChannelStatistics
Imagick sınıfı
PHP Manual

Imagick::getImageChannelRange

(PECL imagick 2.2.1)

Imagick::getImageChannelRange — Gets channel range

Açıklama

array Imagick::getImageChannelRange ( int $channel )

Gets the range for one or more image channels. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.4.0 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

channel

Normalde kanal türü sabitlerinden biridir, ancak bitsel işleçler kullanılarak birden fazla kanal belirtilebilir. Imagick::CHANNEL_DEFAULT öntanımlıdır.

Dönen Değerler

Returns an array containing minima and maxima values of the channel(s).

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageChannelMean
Imagick::getImageChannelStatistics
Imagick sınıfı


Resimdeki her kanalın istatistiklerini döndürür

Imagick::getImageChannelRange
Imagick::getImageClipMask
Imagick sınıfı
PHP Manual

Imagick::getImageChannelStatistics

(PECL imagick 2.0.0)

Imagick::getImageChannelStatistics — Resimdeki her kanalın istatistiklerini döndürür

Açıklama

array Imagick::getImageChannelStatistics ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resimdeki her kanalın istatistiklerini döndürür. İstatistik bilgisi kanal derinliğini, azami ve asgari uçları, ortalama ve standart sapmayı içerir.

Dönen Değerler

Resimdeki her kanalın istatistiklerini bir ilişkisel dizi olarak döndürür.

Imagick::getImageChannelRange
Imagick::getImageClipMask
Imagick sınıfı


Resim kırpma maskesini döndürür

Imagick::getImageChannelStatistics
Imagick::getImageColormapColor
Imagick sınıfı
PHP Manual

Imagick::getImageClipMask

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::getImageClipMask — Resim kırpma maskesini döndürür

Açıklama

Imagick Imagick::getImageClipMask ( void )

Kırpıcı resmi döndürür. Kırpıcı resim kırpma maskesini içeren bir Imagick nesnesidir. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.3.6 veya sonraki bir sürümü kuruluysa kullanılabilir.

Dönen Değerler

Kırpma maskesini içeren bir Imagick nesnesi döner. Hata durumunda bir ImagickException istisnası oluşur.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageChannelStatistics
Imagick::getImageColormapColor
Imagick sınıfı


Renk eşlemi indisi belirtilen rengi döndürür

Imagick::getImageClipMask
Imagick::getImageColors
Imagick sınıfı
PHP Manual

Imagick::getImageColormapColor

(PECL imagick 2.0.0)

Imagick::getImageColormapColor — Renk eşlemi indisi belirtilen rengi döndürür

Açıklama

ImagickPixel Imagick::getImageColormapColor ( int $indis )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Renk eşlemi indisi belirtilen rengi döndürür.

Değiştirgeler

indis

Renk eşlemindeki bir indis.

Dönen Değerler

Renk eşlemi indisi belirtilen rengi bir ImagickPixel nesnesi olarak döndürür.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageClipMask
Imagick::getImageColors
Imagick sınıfı


Resimdeki eşsiz renklerin sayısını döndürür

Imagick::getImageColormapColor
Imagick::getImageColorspace
Imagick sınıfı
PHP Manual

Imagick::getImageColors

(PECL imagick 2.0.0)

Imagick::getImageColors — Resimdeki eşsiz renklerin sayısını döndürür

Açıklama

int Imagick::getImageColors ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resimdeki eşsiz renklerin (piksellerin) sayısını döndürür.

Dönen Değerler

Resimdeki eşsiz renklerin (piksellerin) sayısını döndürür.

Imagick::getImageColormapColor
Imagick::getImageColorspace
Imagick sınıfı


Resmin renk uzayını döndürür

Imagick::getImageColors
Imagick::getImageCompose
Imagick sınıfı
PHP Manual

Imagick::getImageColorspace

(PECL imagick 2.0.0)

Imagick::getImageColorspace — Resmin renk uzayını döndürür

Açıklama

int Imagick::getImageColorspace ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin renk uzayını döndürür.

Dönen Değerler

Resmin renk uzayını döndürür.

Imagick::getImageColors
Imagick::getImageCompose
Imagick sınıfı


Resimle ilgili birleştirme işlecini döndürür

Imagick::getImageColorspace
Imagick::getImageCompression
Imagick sınıfı
PHP Manual

Imagick::getImageCompose

(PECL imagick 2.0.0)

Imagick::getImageCompose — Resimle ilgili birleştirme işlecini döndürür

Açıklama

int Imagick::getImageCompose ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resimle ilgili birleştirme işlecini döndürür.

Dönen Değerler

Resimle ilgili birleştirme işlecini döndürür.

Imagick::getImageColorspace
Imagick::getImageCompression
Imagick sınıfı


Resmin sıkıştırma türünü döndürür

Imagick::getImageCompose
Imagick::getImageCompressionQuality
Imagick sınıfı
PHP Manual

Imagick::getImageCompression

(PECL imagick 2.2.2)

Imagick::getImageCompression — Resmin sıkıştırma türünü döndürür

Açıklama

int Imagick::getImageCompression ( void )

Resmin sıkıştırma türünü döndürür.

Dönen Değerler

Resmin sıkıştırma türünü sıkıştırma sabitlerinden biri olarak döndürür.

Imagick::getImageCompose
Imagick::getImageCompressionQuality
Imagick sınıfı


Resmin sıkıştırma seviyesini döndürür

Imagick::getImageCompression
Imagick::getImageDelay
Imagick sınıfı
PHP Manual

Imagick::getImageCompressionQuality

(PECL imagick 2.2.2)

Imagick::getImageCompressionQuality — Resmin sıkıştırma seviyesini döndürür

Açıklama

int Imagick::getCompressionQuality ( void )

Resmin sıkıştırma seviyesini döndürür.

Dönen Değerler

Resmin sıkıştırma seviyesini bir tamsayı olarak döndürür.

Imagick::getImageCompression
Imagick::getImageDelay
Imagick sınıfı


Resim gecikmesini döndürür

Imagick::getImageCompressionQuality
Imagick::getImageDepth
Imagick sınıfı
PHP Manual

Imagick::getImageDelay

(PECL imagick 2.0.0)

Imagick::getImageDelay — Resim gecikmesini döndürür

Açıklama

int Imagick::getImageDelay ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resim gecikmesini döndürür.

Dönen Değerler

Resim gecikmesini döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageCompressionQuality
Imagick::getImageDepth
Imagick sınıfı


Resim derinliğini döndürür

Imagick::getImageDelay
Imagick::getImageDispose
Imagick sınıfı
PHP Manual

Imagick::getImageDepth

(PECL imagick 0.9.1-0.9.9)

Imagick::getImageDepth — Resim derinliğini döndürür

Açıklama

int Imagick::getImageDepth ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resim derinliğini döndürür.

Dönen Değerler

Resim derinliğini bir tamsayı olarak döndürür.

Imagick::getImageDelay
Imagick::getImageDispose
Imagick sınıfı


Resmin elden çıkarma yöntemini döndürür

Imagick::getImageDepth
Imagick::getImageDistortion
Imagick sınıfı
PHP Manual

Imagick::getImageDispose

(PECL imagick 2.0.0)

Imagick::getImageDispose — Resmin elden çıkarma yöntemini döndürür

Açıklama

int Imagick::getImageDispose ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin elden çıkarma yöntemini döndürür.

Dönen Değerler

Resmin elden çıkarma yöntemini bir elden çıkarma sabiti olarak döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageDepth
Imagick::getImageDistortion
Imagick sınıfı


Resmi yeniden oluşturulmuş bir resimle karşılaştırır

Imagick::getImageDispose
Imagick::getImageExtrema
Imagick sınıfı
PHP Manual

Imagick::getImageDistortion

(PECL imagick 2.0.0)

Imagick::getImageDistortion — Resmi yeniden oluşturulmuş bir resimle karşılaştırır

Açıklama

float Imagick::getImageDistortion ( Imagick $resim , int $metrik )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmi yeniden oluşturulmuş bir resimle karşılaştırır ve belirtilen bozunum metriğini döndürür.

Değiştirgeler

resim

Karşılaştırılacak Imagick nesnesi.

metrik

Metrik sabitlerinden biri..

Dönen Değerler

Resmi yeniden oluşturulmuş bir resimle karşılaştırır ve belirtilen bozunum metriğini döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageDispose
Imagick::getImageExtrema
Imagick sınıfı


Resimle ilgili uç değerleri döndürür

Imagick::getImageDistortion
Imagick::getImageFilename
Imagick sınıfı
PHP Manual

Imagick::getImageExtrema

(PECL imagick 2.0.0)

Imagick::getImageExtrema — Resimle ilgili uç değerleri döndürür

Açıklama

array Imagick::getImageExtrema ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resimle ilgili uç değerleri "min" ve "max" anahtarlı bir ilişkisel dizi olarak döndürür.

Dönen Değerler

"min" ve "max" anahtarlı bir ilişkisel dizi döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageDistortion
Imagick::getImageFilename
Imagick sınıfı


Bir resim dizisindeki belli bir resmin dosya ismini döndürür

Imagick::getImageExtrema
Imagick::getImageFormat
Imagick sınıfı
PHP Manual

Imagick::getImageFilename

(PECL imagick 2.0.0)

Imagick::getImageFilename — Bir resim dizisindeki belli bir resmin dosya ismini döndürür

Açıklama

string Imagick::getImageFilename ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bir resim dizisindeki belli bir resmin dosya ismini döndürür.

Dönen Değerler

Bir resim dizisindeki belli bir resmin dosya ismini bir dizge olarak döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageExtrema
Imagick::getImageFormat
Imagick sınıfı


Bir resim dizisindeki belli bir resmin biçemini döndürür

Imagick::getImageFilename
Imagick::getImageGamma
Imagick sınıfı
PHP Manual

Imagick::getImageFormat

(PECL imagick 2.0.0)

Imagick::getImageFormat — Bir resim dizisindeki belli bir resmin biçemini döndürür

Açıklama

string Imagick::getImageFormat ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bir resim dizisindeki belli bir resmin biçemini döndürür.

Dönen Değerler

Bir resim dizisindeki belli bir resmin biçemini içeren bir dizge döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageFilename
Imagick::getImageGamma
Imagick sınıfı


Resmin gammasını döndürür

Imagick::getImageFormat
Imagick::getImageGeometry
Imagick sınıfı
PHP Manual

Imagick::getImageGamma

(PECL imagick 2.0.0)

Imagick::getImageGamma — Resmin gammasını döndürür

Açıklama

float Imagick::getImageGamma ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin gammasını döndürür.

Dönen Değerler

Başarı durumunda resmin gammasını döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageFormat
Imagick::getImageGeometry
Imagick sınıfı


Resmin genişliğini ve yüksekliğini bir ilişkisel dizi olarak döndürür

Imagick::getImageGamma
Imagick::getImageGravity
Imagick sınıfı
PHP Manual

Imagick::getImageGeometry

(PECL imagick 2.0.0)

Imagick::getImageGeometry — Resmin genişliğini ve yüksekliğini bir ilişkisel dizi olarak döndürür

Açıklama

array Imagick::getImageGeometry ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin genişliğini ve yüksekliğini bir ilişkisel dizi olarak döndürür.

Dönen Değerler

Resmin genişliğini ve yüksekliğini içeren bir dizi döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageGamma
Imagick::getImageGravity
Imagick sınıfı


Gets the image gravity

Imagick::getImageGeometry
Imagick::getImageGreenPrimary
Imagick sınıfı
PHP Manual

Imagick::getImageGravity

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::getImageGravity — Gets the image gravity

Açıklama

int Imagick::getImageGravity ( void )

Gets the current gravity value of the image. Unlike Imagick::getGravity(), this method returns the gravity defined for the current image sequence. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.4.4 veya sonraki bir sürümü kuruluysa kullanılabilir.

Dönen Değerler

Returns the images gravity property. Refer to the list of gravity constants.

Imagick::getImageGeometry
Imagick::getImageGreenPrimary
Imagick sınıfı


Resmin renk bileşenlerinden birincil yeşil noktayı döndürür

Imagick::getImageGravity
Imagick::getImageHeight
Imagick sınıfı
PHP Manual

Imagick::getImageGreenPrimary

(PECL imagick 2.0.0)

Imagick::getImageGreenPrimary — Resmin renk bileşenlerinden birincil yeşil noktayı döndürür

Açıklama

array Imagick::getImageGreenPrimary ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin renk bileşenlerinden birincil yeşil noktayı "x" ve "y" anahtarlı bir dizi olarak döndürür.

Dönen Değerler

Başarı durumunda resmin renk bileşenlerinden birincil yeşil noktayı "x" ve "y" anahtarlı bir dizi olarak döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageGravity
Imagick::getImageHeight
Imagick sınıfı


Resmin yüksekliğini döndürür

Imagick::getImageGreenPrimary
Imagick::getImageHistogram
Imagick sınıfı
PHP Manual

Imagick::getImageHeight

(PECL imagick 2.0.0)

Imagick::getImageHeight — Resmin yüksekliğini döndürür

Açıklama

int Imagick::getImageHeight ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin yüksekliğini döndürür.

Dönen Değerler

Resmin yüksekliğini piksel cinsinden döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageGreenPrimary
Imagick::getImageHistogram
Imagick sınıfı


Resmin renk dağılımını döndürür

Imagick::getImageHeight
Imagick::getImageIndex
Imagick sınıfı
PHP Manual

Imagick::getImageHistogram

(PECL imagick 2.0.0)

Imagick::getImageHistogram — Resmin renk dağılımını döndürür

Açıklama

array Imagick::getImageHistogram ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin renk dağılımını bir ImagickPixel nesneleri dizisi olarak döndürür.

Dönen Değerler

Resmin renk dağılımını bir ImagickPixel nesneleri dizisi olarak döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageHeight
Imagick::getImageIndex
Imagick sınıfı


Geçerli etkin resmin indisini döndürür

Imagick::getImageHistogram
Imagick::getImageInterlaceScheme
Imagick sınıfı
PHP Manual

Imagick::getImageIndex

(PECL imagick 2.0.0)

Imagick::getImageIndex — Geçerli etkin resmin indisini döndürür

Açıklama

int Imagick::getImageIndex ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Imagick nesnesi içindeki geçerli etkin resmin indisini döndürür. Bu yöntemin kullanımı önerilmemektedir. Yerine Imagick::getIteratorIndex() yöntemini kullanın.

Dönen Değerler

Yığıttaki resmin indisini bir tamsayı olarak döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageHistogram
Imagick::getImageInterlaceScheme
Imagick sınıfı


Resmin geçişim şemasını döndürür

Imagick::getImageIndex
Imagick::getImageInterpolateMethod
Imagick sınıfı
PHP Manual

Imagick::getImageInterlaceScheme

(PECL imagick 2.0.0)

Imagick::getImageInterlaceScheme — Resmin geçişim şemasını döndürür

Açıklama

int Imagick::getImageInterlaceScheme ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin geçişim şemasını bir geçişim sabiti olarak döndürür.

Dönen Değerler

Resmin geçişim şemasını bir tamsayı olarak döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageIndex
Imagick::getImageInterpolateMethod
Imagick sınıfı


Aradeğerleme yöntemini döndürür

Imagick::getImageInterlaceScheme
Imagick::getImageIterations
Imagick sınıfı
PHP Manual

Imagick::getImageInterpolateMethod

(PECL imagick 2.0.0)

Imagick::getImageInterpolateMethod — Aradeğerleme yöntemini döndürür

Açıklama

int Imagick::getImageInterpolateMethod ( void )

Resmin aradeğerleme yöntemini Imagick::INTERPOLATE_* sabitlerinden biri olarak döndürür.

Dönen Değerler

Resmin aradeğerleme yöntemini döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageInterlaceScheme
Imagick::getImageIterations
Imagick sınıfı


Resim yineleme sayısını döndürür

Imagick::getImageInterpolateMethod
Imagick::getImageLength
Imagick sınıfı
PHP Manual

Imagick::getImageIterations

(PECL imagick 2.0.0)

Imagick::getImageIterations — Resim yineleme sayısını döndürür

Açıklama

int Imagick::getImageIterations ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resim yineleme sayısını döndürür.

Dönen Değerler

Resim yineleme sayısını bir tamsayı olarak döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageInterpolateMethod
Imagick::getImageLength
Imagick sınıfı


Resim uzunluğunu döndürür

Imagick::getImageIterations
Imagick::getImageMagickLicense
Imagick sınıfı
PHP Manual

Imagick::getImageLength

(PECL imagick 2.0.0)

Imagick::getImageLength — Resim uzunluğunu döndürür

Açıklama

int Imagick::getImageLength ( void )

Resmin bayt cinsinden uzunluğunu döndürür.

Dönen Değerler

Resim uzunluğunu bir tamsayı olarak döndürür.

Örnekler

Örnek 1 - Imagick::getImageLength() örneği

Resim dosyası uzunluğunu bayt cinsinden döndürmek

<?php
$image = new Imagick('test.jpg');
echo $image->getImageLength() . ' bayt';
?>

Imagick::getImageIterations
Imagick::getImageMagickLicense
Imagick sınıfı


ImageMagick lisans bilgisini içeren bir dizge döndürür

Imagick::getImageLength
Imagick::getImageMatte
Imagick sınıfı
PHP Manual

Imagick::getImageMagickLicense

(PECL imagick 2.0.0)

Imagick::getImageMagickLicense — ImageMagick lisans bilgisini içeren bir dizge döndürür

Açıklama

string Imagick::getImageMagickLicense ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ImageMagick lisans bilgisini içeren bir dizge döndürür.

Dönen Değerler

ImageMagick lisans bilgisini içeren bir dizge döndürür.

Imagick::getImageLength
Imagick::getImageMatte
Imagick sınıfı


Resmin bir matlık kanalı varsa TRUE döndürür

Imagick::getImageMagickLicense
Imagick::getImageMatteColor
Imagick sınıfı
PHP Manual

Imagick::getImageMatte

(PECL imagick 2.0.0)

Imagick::getImageMatte — Resmin bir matlık kanalı varsa TRUE döndürür

Açıklama

int Imagick::getImageMatte ( void )

Resmin bir matlık kanalı varsa TRUE, yoksa FALSE döndürür Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.2.9 veya sonraki bir sürümü kuruluysa kullanılabilir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Imagick::getImageMagickLicense
Imagick::getImageMatteColor
Imagick sınıfı


Resmin matlık rengini döndürür

Imagick::getImageMatte
Imagick::getImageMimeType
Imagick sınıfı
PHP Manual

Imagick::getImageMatteColor

(PECL imagick 2.0.0)

Imagick::getImageMatteColor — Resmin matlık rengini döndürür

Açıklama

ImagickPixel Imagick::getImageMatteColor ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin matlık rengini döndürür.

Dönen Değerler

Resmin matlık rengini bir ImagickPixel nesnesi olarak döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageMatte
Imagick::getImageMimeType
Imagick sınıfı


Description

Imagick::getImageMatteColor
Imagick::getImageOrientation
Imagick sınıfı
PHP Manual

Imagick::getImageMimeType

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::getImageMimeType — Description

Açıklama

public string Imagick::getImageMimeType ( void )

Returns the image mime-type.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Imagick::getImageMatteColor
Imagick::getImageOrientation
Imagick sınıfı


Resim baskı yönünü döndürür

Imagick::getImageMimeType
Imagick::getImagePage
Imagick sınıfı
PHP Manual

Imagick::getImageOrientation

(PECL imagick 2.0.0)

Imagick::getImageOrientation — Resim baskı yönünü döndürür

Açıklama

int Imagick::getImageOrientation ( void )

Resim baskı yönünü yön sabitlerinden biri olarak döndürür.

Dönen Değerler

Başarı durumunda bir tamsayı döner. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageMimeType
Imagick::getImagePage
Imagick sınıfı


Sayfa geometrisini döndürür

Imagick::getImageOrientation
Imagick::getImagePixelColor
Imagick sınıfı
PHP Manual

Imagick::getImagePage

(PECL imagick 2.0.0)

Imagick::getImagePage — Sayfa geometrisini döndürür

Açıklama

array Imagick::getImagePage ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resimle ilgili sayfa geometrisini "width", "height", "x" ve "y" anahtarlı bir dizi olarak döndürür.

Dönen Değerler

Resimle ilgili sayfa geometrisini "width", "height", "x" ve "y" anahtarlı bir dizi olarak döndürür.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageOrientation
Imagick::getImagePixelColor
Imagick sınıfı


Belirtilen pikselin rengini döndürür

Imagick::getImagePage
Imagick::getImageProfile
Imagick sınıfı
PHP Manual

Imagick::getImagePixelColor

(PECL imagick 2.0.0)

Imagick::getImagePixelColor — Belirtilen pikselin rengini döndürür

Açıklama

ImagickPixel Imagick::getImagePixelColor ( int $x , int $y )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Belirtilen pikselin rengini bir ImagickPixel nesnesi olarak döndürür.

Değiştirgeler

x

Pikselin X koordinatı.

y

Pikselin Y koordinatı.

Dönen Değerler

Koordinatları verilen pikselin rengini bir ImagickPixel nesnesi olarak döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImagePage
Imagick::getImageProfile
Imagick sınıfı


İsimli resim profilini döndürür

Imagick::getImagePixelColor
Imagick::getImageProfiles
Imagick sınıfı
PHP Manual

Imagick::getImageProfile

(PECL imagick 2.0.0)

Imagick::getImageProfile — İsimli resim profilini döndürür

Açıklama

string Imagick::getImageProfile ( string $isim )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

İsmi belirtilen resim profilini döndürür.

Değiştirgeler

isim

Döndürülecek profilin ismi.

Dönen Değerler

Resim profilini içeren bir dizge. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImagePixelColor
Imagick::getImageProfiles
Imagick sınıfı


Resim profillerini döndürür

Imagick::getImageProfile
Imagick::getImageProperties
Imagick sınıfı
PHP Manual

Imagick::getImageProfiles

(PECL imagick 2.0.0)

Imagick::getImageProfiles — Resim profillerini döndürür

Açıklama

array Imagick::getImageProfiles ([ string $şablon = "*" [, bool $sadece_isimler = true ]] )

Belirtilen şablon ile eşleşen profillerin tümünü içeren bir dizi döndürür. sadece_isimler değiştirgesinde TRUE aktarılırsa sadece profil isimleri döndürülür. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.3.6 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

şablon

Özellik isimleri için şablon.

sadece_isimler

TRUE belirtilirse sadece özellik isimleri, FALSE belirtilirse değerler de döndürülür.

Dönen Değerler

Resim profillerini ve isimlerini içeren bir dizi.

Imagick::getImageProfile
Imagick::getImageProperties
Imagick sınıfı


Resim özelliklerini döndürür

Imagick::getImageProfiles
Imagick::getImageProperty
Imagick sınıfı
PHP Manual

Imagick::getImageProperties

(PECL imagick 2.0.0)

Imagick::getImageProperties — Resim özelliklerini döndürür

Açıklama

array Imagick::getImageProperties ([ string $şablon = "*" [, bool $sadece_isimler = true ]] )

Belirtilen şablon ile eşleşen özelliklerin tümünü içeren bir dizi döndürür. sadece_isimler değiştirgesinde TRUE aktarılırsa sadece özellik isimleri döndürülür. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.3.6 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

şablon

Özellik isimleri için şablon.

sadece_isimler

TRUE belirtilirse sadece özellik isimleri döndürülür.

Dönen Değerler

Resim özelliklerini ve isimlerini içeren bir dizi.

Örnekler

Örnek 1 - Imagick::getImageProperties() örneği

EXIF bilgisini elde etme örneği.

<?php

/* Nesneyi oluşturalım */
$im = new imagick("/path/to/example.jpg");

/* EXIF bilgisini alalım */
$exifDizisi = $im->getImageProperties("exif:*");

/* EXIF özelliklerini tarayalım */
foreach ($exifDizisi as $isim => $özellik)
{
    echo "{$isim} => {$özellik}<br />\n";
}

?>

Imagick::getImageProfiles
Imagick::getImageProperty
Imagick sınıfı


İsimli resim özelliğini döndürür

Imagick::getImageProperties
Imagick::getImageRedPrimary
Imagick sınıfı
PHP Manual

Imagick::getImageProperty

(PECL imagick 2.0.0)

Imagick::getImageProperty — İsimli resim özelliğini döndürür

Açıklama

string Imagick::getImageProperty ( string $isim )

İsimli resim özelliğini döndürür.

Değiştirgeler

isim

Özelliğin ismi (Exif:DateTime gibi)

Dönen Değerler

Belirtilen özellik yoksa FALSE aksi takdirde özelliği bir dizge olarak döndürür. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.3.2 veya sonraki bir sürümü kuruluysa kullanılabilir.

Örnekler

Örnek 1 - Imagick::getImageProperty() örneği

Resim ösniteliklerinin belirtilmesi ve döndürülmesi.

<?php
$image = new Imagick();
$image->newImage(300, 200, "black");

$image->setImageProperty('Exif:Make', 'Imagick');
echo $image->getImageProperty('Exif:Make');
?>

Ayrıca Bakınız

  • Imagick::setImageProperty() - Bir resim özelliğini tanımlar

Imagick::getImageProperties
Imagick::getImageRedPrimary
Imagick sınıfı


Resmin renk bileşenlerinden birincil kırmızı noktasını döndürür

Imagick::getImageProperty
Imagick::getImageRegion
Imagick sınıfı
PHP Manual

Imagick::getImageRedPrimary

(PECL imagick 2.0.0)

Imagick::getImageRedPrimary — Resmin renk bileşenlerinden birincil kırmızı noktasını döndürür

Açıklama

array Imagick::getImageRedPrimary ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin renk bileşenlerinden birincil kırmızı noktayı "x" ve "y" anahtarlı bir dizi olarak döndürür.

Dönen Değerler

Resmin renk bileşenlerinden birincil kırmızı noktayı "x" ve "y" anahtarlı bir dizi olarak döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageProperty
Imagick::getImageRegion
Imagick sınıfı


Resmin bir bölgesini çıkarır

Imagick::getImageRedPrimary
Imagick::getImageRenderingIntent
Imagick sınıfı
PHP Manual

Imagick::getImageRegion

(PECL imagick 2.0.0)

Imagick::getImageRegion — Resmin bir bölgesini çıkarır

Açıklama

Imagick Imagick::getImageRegion ( int $genişlik , int $yükseklik , int $x , int $y )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin belirtilen bölgesini yeni bir nesne olarak döndürür.

Değiştirgeler

width

Bölgenin genişliği.

height

Bölgenin yüksekliği.

x

Bölgenin sol üst köşesinin X konumu.

y

Bölgenin sol üst köşesinin Y konumu.

Dönen Değerler

Resmin belirtilen bölgesini yeni bir nesne olarak döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageRedPrimary
Imagick::getImageRenderingIntent
Imagick sınıfı


Resme komutların uygulanış tarzını döndürür

Imagick::getImageRegion
Imagick::getImageResolution
Imagick sınıfı
PHP Manual

Imagick::getImageRenderingIntent

(PECL imagick 2.0.0)

Imagick::getImageRenderingIntent — Resme komutların uygulanış tarzını döndürür

Açıklama

int Imagick::getImageRenderingIntent ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resme komutların uygulanış tarzını döndürür

Dönen Değerler

Resme komutların uygulanış tarzını döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageRegion
Imagick::getImageResolution
Imagick sınıfı


Resmin X ve Y çözünürlüklerini döndürür

Imagick::getImageRenderingIntent
Imagick::getImagesBlob
Imagick sınıfı
PHP Manual

Imagick::getImageResolution

(PECL imagick 2.0.0)

Imagick::getImageResolution — Resmin X ve Y çözünürlüklerini döndürür

Açıklama

array Imagick::getImageResolution ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin X ve Y çözünürlüklerini içeren bir dizi döndürür.

Dönen Değerler

Çözünürlükleri içeren bir dizi. Hata durumunda bir ImagickException istisnası oluşur.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageRenderingIntent
Imagick::getImagesBlob
Imagick sınıfı


Tüm resim dizilerini bir ikil dizge olarak döndürür

Imagick::getImageResolution
Imagick::getImageScene
Imagick sınıfı
PHP Manual

Imagick::getImagesBlob

(PECL imagick 2.0.0)

Imagick::getImagesBlob — Tüm resim dizilerini bir ikil dizge olarak döndürür

Açıklama

string Imagick::getImagesBlob ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resimleri dosya biçemi ile içeren bir ikil dizi döndürür. Resmin biçemi döndürülen ikil dizgenin biçemiyle (GIF, JPEG, PNG, vb.) belirlenir. Dönen ikil dizgenin resim biçemini değiştirmek için Imagick::setImageFormat() yöntemini kullanın.

Dönen Değerler

Resimleri içeren bir ikil dizge döner. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageResolution
Imagick::getImageScene
Imagick sınıfı


Resmin artalan dekorunu döndürür

Imagick::getImagesBlob
Imagick::getImageSignature
Imagick sınıfı
PHP Manual

Imagick::getImageScene

(PECL imagick 2.0.0)

Imagick::getImageScene — Resmin artalan dekorunu döndürür

Açıklama

int Imagick::getImageScene ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin artalan dekorunu döndürür.

Dönen Değerler

Resmin artalan dekorunu döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImagesBlob
Imagick::getImageSignature
Imagick sınıfı


Resmin SHA-256 ileti özetini üretir

Imagick::getImageScene
Imagick::getImageSize
Imagick sınıfı
PHP Manual

Imagick::getImageSignature

(PECL imagick 2.0.0)

Imagick::getImageSignature — Resmin SHA-256 ileti özetini üretir

Açıklama

string Imagick::getImageSignature ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resim piksel akımının SHA-256 ileti özetini üretir.

Dönen Değerler

Dosyanın SHA-256 ileti özetini içeren bir dizge döner. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageScene
Imagick::getImageSize
Imagick sınıfı


Resim uzunluğunu bayt cinsinden döndürür

Imagick::getImageSignature
Imagick::getImageTicksPerSecond
Imagick sınıfı
PHP Manual

Imagick::getImageSize

(PECL imagick 2.0.0)

Imagick::getImageSize — Resim uzunluğunu bayt cinsinden döndürür

Açıklama

int Imagick::getImageSize ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resim uzunluğunu bayt cinsinden döndürür

Dönen Değerler

Resim bayt sayısını bir tamsayı olarak döndürür.

Imagick::getImageSignature
Imagick::getImageTicksPerSecond
Imagick sınıfı


Resmin saniyedeki tik sayısını döndürür

Imagick::getImageSize
Imagick::getImageTotalInkDensity
Imagick sınıfı
PHP Manual

Imagick::getImageTicksPerSecond

(PECL imagick 2.0.0)

Imagick::getImageTicksPerSecond — Resmin saniyedeki tik sayısını döndürür

Açıklama

int Imagick::getImageTicksPerSecond ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin saniyedeki tik sayısını döndürür.

Dönen Değerler

Resmin saniyedeki tik sayısını döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageSize
Imagick::getImageTotalInkDensity
Imagick sınıfı


Resmin belli bir renginin toplam yoğunluğunu döndürür

Imagick::getImageTicksPerSecond
Imagick::getImageType
Imagick sınıfı
PHP Manual

Imagick::getImageTotalInkDensity

(PECL imagick 2.0.0)

Imagick::getImageTotalInkDensity — Resmin belli bir renginin toplam yoğunluğunu döndürür

Açıklama

float Imagick::getImageTotalInkDensity ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin belli bir renginin toplam yoğunluğunu döndürür.

Dönen Değerler

Resmin belli bir renginin toplam yoğunluğunu döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageTicksPerSecond
Imagick::getImageType
Imagick sınıfı


Olası resim türünü döndürür

Imagick::getImageTotalInkDensity
Imagick::getImageUnits
Imagick sınıfı
PHP Manual

Imagick::getImageType

(PECL imagick 0.9.10-0.9.9)

Imagick::getImageType — Olası resim türünü döndürür

Açıklama

int Imagick::getImageType ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Olası resim türünü döndürür.

Dönen Değerler

Olası resim türünü döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageTotalInkDensity
Imagick::getImageUnits
Imagick sınıfı


Resim çözünürlük birimlerini döndürür

Imagick::getImageType
Imagick::getImageVirtualPixelMethod
Imagick sınıfı
PHP Manual

Imagick::getImageUnits

(PECL imagick 2.0.0)

Imagick::getImageUnits — Resim çözünürlük birimlerini döndürür

Açıklama

int Imagick::getImageUnits ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resim çözünürlük birimlerini döndürür.

Dönen Değerler

Resim çözünürlük birimlerini döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageType
Imagick::getImageVirtualPixelMethod
Imagick sınıfı


Sanal piksel yöntemini döndürür

Imagick::getImageUnits
Imagick::getImageWhitePoint
Imagick sınıfı
PHP Manual

Imagick::getImageVirtualPixelMethod

(PECL imagick 2.0.0)

Imagick::getImageVirtualPixelMethod — Sanal piksel yöntemini döndürür

Açıklama

int Imagick::getImageVirtualPixelMethod ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Geçerli resmin sanal piksel yöntemini döndürür.

Dönen Değerler

Başarı durumunda sanal piksel yöntemini döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageUnits
Imagick::getImageWhitePoint
Imagick sınıfı


Resmin renk bileşenlerinden beyaz noktayı döndürür

Imagick::getImageVirtualPixelMethod
Imagick::getImageWidth
Imagick sınıfı
PHP Manual

Imagick::getImageWhitePoint

(PECL imagick 2.0.0)

Imagick::getImageWhitePoint — Resmin renk bileşenlerinden beyaz noktayı döndürür

Açıklama

array Imagick::getImageWhitePoint ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin renk bileşenlerinden beyaz noktayı "x" ve "y" anahtarlı bir dizi olarak döndürür.

Dönen Değerler

Resmin renk bileşenlerinden beyaz noktayı "x" ve "y" anahtarlı bir dizi olarak döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageVirtualPixelMethod
Imagick::getImageWidth
Imagick sınıfı


Resim genişliğini döndürür

Imagick::getImageWhitePoint
Imagick::getInterlaceScheme
Imagick sınıfı
PHP Manual

Imagick::getImageWidth

(PECL imagick 2.0.0)

Imagick::getImageWidth — Resim genişliğini döndürür

Açıklama

int Imagick::getImageWidth ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resim genişliğini döndürür.

Dönen Değerler

Resim genişliğini döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageWhitePoint
Imagick::getInterlaceScheme
Imagick sınıfı


Nesne geçişim şemasını döndürür

Imagick::getImageWidth
Imagick::getIteratorIndex
Imagick sınıfı
PHP Manual

Imagick::getInterlaceScheme

(PECL imagick 2.0.0)

Imagick::getInterlaceScheme — Nesne geçişim şemasını döndürür

Açıklama

int Imagick::getInterlaceScheme ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Nesne geçişim şemasını döndürür.

Dönen Değerler

Nesne geçişim şemasını bir geçişim şeması sabiti olarak döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getImageWidth
Imagick::getIteratorIndex
Imagick sınıfı


Geçerli etkin resmin indisini döndürür

Imagick::getInterlaceScheme
Imagick::getNumberImages
Imagick sınıfı
PHP Manual

Imagick::getIteratorIndex

(PECL imagick 2.0.0)

Imagick::getIteratorIndex — Geçerli etkin resmin indisini döndürür

Açıklama

int Imagick::getIteratorIndex ( void )

Imagick nesnesi içindeki geçerli etkin resmin indisini döndürür. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.2.9 veya sonraki bir sürümü kuruluysa kullanılabilir.

Dönen Değerler

Yığıttaki resmin indisini bir tamsayı olarak döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Örnekler

Örnek 1 - Imagick::getIteratorIndex() örneği

Resimleri oluşturup yineleyici indisini tanımlar ve döndürür.

<?php
$im = new Imagick();
$im->newImage(100, 100, new ImagickPixel("red"));
$im->newImage(100, 100, new ImagickPixel("green"));
$im->newImage(100, 100, new ImagickPixel("blue"));

$im->setIteratorIndex(1);
echo $im->getIteratorIndex();
?>

Ayrıca Bakınız

  • Imagick::setIteratorIndex() - Yineleyici konumunu belirler
  • Imagick::getImageIndex() - Geçerli etkin resmin indisini döndürür
  • Imagick::setImageIndex() - Yineleyici konumunu tanımlar

Imagick::getInterlaceScheme
Imagick::getNumberImages
Imagick sınıfı


Nesnedeki resim sayısını döndürür

Imagick::getIteratorIndex
Imagick::getOption
Imagick sınıfı
PHP Manual

Imagick::getNumberImages

(PECL imagick 2.0.0)

Imagick::getNumberImages — Nesnedeki resim sayısını döndürür

Açıklama

int Imagick::getNumberImages ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Imagick nesnesi ile ilgili resimlerin sayısını döndürür.

Dönen Değerler

Başarı durumunda Imagick nesnesi ile ilgili resimlerin sayısını döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getIteratorIndex
Imagick::getOption
Imagick sınıfı


Belirtilen anahtarla ilgili değeri döndürür

Imagick::getNumberImages
Imagick::getPackageName
Imagick sınıfı
PHP Manual

Imagick::getOption

(PECL imagick 2.0.0)

Imagick::getOption — Belirtilen anahtarla ilgili değeri döndürür

Açıklama

string Imagick::getOption ( string $anahtar )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Nesnenin belirtilen anahtarla ilgili değerini döndürür.

Değiştirgeler

anahtar

Değeri döndürülecek anahtar

Dönen Değerler

Nesnenin belirtilen anahtarla ilgili değerini bir dizge olarak döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getNumberImages
Imagick::getPackageName
Imagick sınıfı


ImageMagick paket ismini döndürür

Imagick::getOption
Imagick::getPage
Imagick sınıfı
PHP Manual

Imagick::getPackageName

(PECL imagick 2.0.0)

Imagick::getPackageName — ImageMagick paket ismini döndürür

Açıklama

string Imagick::getPackageName ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ImageMagick paket ismini döndürür.

Dönen Değerler

ImageMagick paket ismini bir dizge olarak döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getOption
Imagick::getPage
Imagick sınıfı


Sayfa geometrisini döndürür

Imagick::getPackageName
Imagick::getPixelIterator
Imagick sınıfı
PHP Manual

Imagick::getPage

(PECL imagick 2.0.0)

Imagick::getPage — Sayfa geometrisini döndürür

Açıklama

array Imagick::getPage ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Imagick nesnesi ile ilgili sayfa geometrisini "width", "height", "x" ve "y" anahtarlı bir ilişkisel dizi olarak döndürür.

Dönen Değerler

Başarı durumunda Imagick nesnesi ile ilgili sayfa geometrisini "width", "height", "x" ve "y" anahtarlı bir ilişkisel dizi olarak döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getPackageName
Imagick::getPixelIterator
Imagick sınıfı


Bir MagickPixelIterator nesnesi döndürür

Imagick::getPage
Imagick::getPixelRegionIterator
Imagick sınıfı
PHP Manual

Imagick::getPixelIterator

(PECL imagick 2.0.0)

Imagick::getPixelIterator — Bir MagickPixelIterator nesnesi döndürür

Açıklama

ImagickPixelIterator Imagick::getPixelIterator ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bir MagickPixelIterator nesnesi döndürür.

Dönen Değerler

Başarı durumunda br MagickPixelIterator nesnesi döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getPage
Imagick::getPixelRegionIterator
Imagick sınıfı


Bir resim bölümü için bir ImagickPixelIterator nesnesi döndürür

Imagick::getPixelIterator
Imagick::getPointSize
Imagick sınıfı
PHP Manual

Imagick::getPixelRegionIterator

(PECL imagick 2.0.0)

Imagick::getPixelRegionIterator — Bir resim bölümü için bir ImagickPixelIterator nesnesi döndürür

Açıklama

ImagickPixelIterator Imagick::getPixelRegionIterator ( int $x , int $y , int $genişlik , int $yükseklik )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bir resim bölümü için bir ImagickPixelIterator nesnesi döndürür.

Değiştirgeler

x

Bölgenin X koordinatı.

y

Bölgenin Y koordinatı.

genişlik

Bölgenin genişliği.

yükseklik

Bölgenin yüksekliği.

Dönen Değerler

Bir resim bölümü için bir ImagickPixelIterator nesnesi döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getPixelIterator
Imagick::getPointSize
Imagick sınıfı


Punto değerini döndürür

Imagick::getPixelRegionIterator
Imagick::getQuantum
Imagick sınıfı
PHP Manual

Imagick::getPointSize

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::getPointSize — Punto değerini döndürür

Açıklama

string Imagick::getPointSize ( void )

Nesnenin yazıtipi yüksekliğini punto olarak döndürür. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.3.7 veya sonraki bir sürümü kuruluysa kullanılabilir.

Dönen Değerler

Yazıtipi yüksekliği float türünde punto cinsinden değer olarak döner.

Ayrıca Bakınız

  • Imagick::setPointSize() - Yazı puntosunu belirler

Imagick::getPixelRegionIterator
Imagick::getQuantum
Imagick sınıfı


Description

Imagick::getPointSize
Imagick::getQuantumDepth
Imagick sınıfı
PHP Manual

Imagick::getQuantum

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::getQuantum — Description

Açıklama

public static int Imagick::getQuantum ( void )

Returns the ImageMagick quantum range as an integer.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Imagick::getPointSize
Imagick::getQuantumDepth
Imagick sınıfı


Parçacık derinliğini döndürür

Imagick::getQuantum
Imagick::getQuantumRange
Imagick sınıfı
PHP Manual

Imagick::getQuantumDepth

(PECL imagick 2.0.0)

Imagick::getQuantumDepth — Parçacık derinliğini döndürür

Açıklama

array Imagick::getQuantumDepth ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Imagick parçacık derinliğini bir dizi olarak döndürür.

Dönen Değerler

Imagick parçacık derinliğini bir dizi olarak döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getQuantum
Imagick::getQuantumRange
Imagick sınıfı


Imagick parçacık aralığını döndürür

Imagick::getQuantumDepth
Imagick::getRegistry
Imagick sınıfı
PHP Manual

Imagick::getQuantumRange

(PECL imagick 2.0.0)

Imagick::getQuantumRange — Imagick parçacık aralığını döndürür

Açıklama

array Imagick::getQuantumRange ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Imagick parçacık aralığını bir dizi olarak döndürür.

Dönen Değerler

Imagick parçacık aralığını bir dizi olarak döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getQuantumDepth
Imagick::getRegistry
Imagick sınıfı


Description

Imagick::getQuantumRange
Imagick::getReleaseDate
Imagick sınıfı
PHP Manual

Imagick::getRegistry

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::getRegistry — Description

Açıklama

public static string Imagick::getRegistry ( string $key )

Get the StringRegistry entry for the named key or false if not set.

Değiştirgeler

key

The entry to get.

Dönen Değerler

Imagick::getQuantumRange
Imagick::getReleaseDate
Imagick sınıfı


ImageMagick dağıtım tarihini döndürür

Imagick::getRegistry
Imagick::getResource
Imagick sınıfı
PHP Manual

Imagick::getReleaseDate

(PECL imagick 2.0.0)

Imagick::getReleaseDate — ImageMagick dağıtım tarihini döndürür

Açıklama

string Imagick::getReleaseDate ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ImageMagick dağıtım tarihini bir dizge olarak döndürür.

Dönen Değerler

ImageMagick dağıtım tarihini bir dizge olarak döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getRegistry
Imagick::getResource
Imagick sınıfı


Belirtilen özkaynağın bellek kullanımını döndürür

Imagick::getReleaseDate
Imagick::getResourceLimit
Imagick sınıfı
PHP Manual

Imagick::getResource

(PECL imagick 2.0.0)

Imagick::getResource — Belirtilen özkaynağın bellek kullanımını döndürür

Açıklama

int Imagick::getResource ( int $tür )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

tür ile belirtilen özkaynağın bellek kullanımını megabayt olarak döndürür.

Değiştirgeler

tür

Özkaynak türü sabitlerinden biri.

Dönen Değerler

Belirtilen özkaynağın bellek kullanımını megabayt olarak döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getReleaseDate
Imagick::getResourceLimit
Imagick sınıfı


Belirtilen özkaynağın bellek kullanım sınırını döndürür

Imagick::getResource
Imagick::getSamplingFactors
Imagick sınıfı
PHP Manual

Imagick::getResourceLimit

(PECL imagick 2.0.0)

Imagick::getResourceLimit — Belirtilen özkaynağın bellek kullanım sınırını döndürür

Açıklama

int Imagick::getResourceLimit ( int $tür )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Belirtilen özkaynağın bellek kullanım sınırını megabayt olarak döndürür.

Değiştirgeler

tür

Özkaynak türü sabitlerinden biri.

Dönen Değerler

Belirtilen özkaynağın bellek kullanım sınırını megabayt olarak döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getResource
Imagick::getSamplingFactors
Imagick sınıfı


Yatay ve düşey örnekleme katsayısını döndürür

Imagick::getResourceLimit
Imagick::getSize
Imagick sınıfı
PHP Manual

Imagick::getSamplingFactors

(PECL imagick 2.0.0)

Imagick::getSamplingFactors — Yatay ve düşey örnekleme katsayısını döndürür

Açıklama

array Imagick::getSamplingFactors ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Yatay ve düşey örnekleme katsayısını döndürür.

Dönen Değerler

Yatay ve düşey örnekleme katsayısılarını bir dizi olarak döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getResourceLimit
Imagick::getSize
Imagick sınıfı


Imagick nesnesi ile ilgili boyutları döndürür

Imagick::getSamplingFactors
Imagick::getSizeOffset
Imagick sınıfı
PHP Manual

Imagick::getSize

(PECL imagick 2.0.0)

Imagick::getSize — Imagick nesnesi ile ilgili boyutları döndürür

Açıklama

array Imagick::getSize ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Imagick nesnesi ile ilgili boyutları "columns" ve "rows" anahtarlı bir dizi olarak döndürür.

Dönen Değerler

Imagick nesnesi ile ilgili boyutları "columns" ve "rows" anahtarlı bir dizi olarak döndürür.

Imagick::getSamplingFactors
Imagick::getSizeOffset
Imagick sınıfı


Boyut başlangıç noktasını döndürür

Imagick::getSize
Imagick::getVersion
Imagick sınıfı
PHP Manual

Imagick::getSizeOffset

(PECL imagick 2.0.0)

Imagick::getSizeOffset — Boyut başlangıç noktasını döndürür

Açıklama

int Imagick::getSizeOffset ( void )

Imagick nesnesi ile ilgili boyut başlangıç noktasını döndürür. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.2.9 veya sonraki bir sürümü kuruluysa kullanılabilir.

Dönen Değerler

Imagick nesnesi ile ilgili boyut başlangıç noktasını döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getSize
Imagick::getVersion
Imagick sınıfı


ImageMagick API sürümünü döndürür

Imagick::getSizeOffset
Imagick::haldClutImage
Imagick sınıfı
PHP Manual

Imagick::getVersion

(PECL imagick 2.0.0)

Imagick::getVersion — ImageMagick API sürümünü döndürür

Açıklama

array Imagick::getVersion ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ImageMagick API sürümünü bir dizge ve bir sayı olarak döndürür.

Dönen Değerler

ImageMagick API sürümünü bir dizge ve bir sayı olarak döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::getSizeOffset
Imagick::haldClutImage
Imagick sınıfı


Replaces colors in the image

Imagick::getVersion
Imagick::hasNextImage
Imagick sınıfı
PHP Manual

Imagick::haldClutImage

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::haldClutImage — Replaces colors in the image

Açıklama

public bool Imagick::haldClutImage ( Imagick $clut [, int $channel = Imagick::CHANNEL_DEFAULT ] )

Replaces colors in the image using a Hald lookup table. Hald images can be created using HALD color coder.

Değiştirgeler

clut

Imagick object containing the Hald lookup image.

channel

Normalde kanal türü sabitlerinden biridir, ancak bitsel işleçler kullanılarak birden fazla kanal belirtilebilir. Imagick::CHANNEL_DEFAULT öntanımlıdır.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Örnekler

Örnek 1 Imagick::haldClutImage()

<?php
function haldClutImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagickPalette = new \Imagick(realpath("images/hald/hald_8.png"));
    $imagickPalette->sepiatoneImage(55);
    $imagick->haldClutImage($imagickPalette);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>

Imagick::getVersion
Imagick::hasNextImage
Imagick sınıfı


Resmin sonrasında bir resim daha var mı diye bakar

Imagick::haldClutImage
Imagick::hasPreviousImage
Imagick sınıfı
PHP Manual

Imagick::hasNextImage

(PECL imagick 2.0.0)

Imagick::hasNextImage — Resmin sonrasında bir resim daha var mı diye bakar

Açıklama

bool Imagick::hasNextImage ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resim listesinde, resmin sonrasında bir resim daha varsa TRUE döndürür.

Dönen Değerler

Resmin sonrasında bir resim daha varsa TRUE yoksa FALSE döndürür.

Imagick::haldClutImage
Imagick::hasPreviousImage
Imagick sınıfı


Resmin öncesinde bir resim daha var mı diye bakar

Imagick::hasNextImage
Imagick::identifyFormat
Imagick sınıfı
PHP Manual

Imagick::hasPreviousImage

(PECL imagick 2.0.0)

Imagick::hasPreviousImage — Resmin öncesinde bir resim daha var mı diye bakar

Açıklama

bool Imagick::hasPreviousImage ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resim listesinde, resmin öncesinde bir resim daha varsa TRUE döndürür.

Dönen Değerler

Resmin öncesinde bir resim daha varsa TRUE yoksa FALSE döndürür.

Imagick::hasNextImage
Imagick::identifyFormat
Imagick sınıfı


Description

Imagick::hasPreviousImage
Imagick::identifyImage
Imagick sınıfı
PHP Manual

Imagick::identifyFormat

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::identifyFormat — Description

Açıklama

public string|false Imagick::identifyFormat ( string $embedText )

Replaces any embedded formatting characters with the appropriate image property and returns the interpreted text. See http://www.imagemagick.org/script/escape.php for escape sequences.

Değiştirgeler

embedText

A string containing formatting sequences e.g. "Trim box: %@ number of unique colors: %k".

Dönen Değerler

Örnekler

Örnek 1 Imagick::identifyFormat()

<?php
        $output = "Output of 'Trim box: %@ number of unique colors: %k' is: <br/>";
        $imagick = new \Imagick(realpath("./images/artifact/mask.png"));
        $output .= $imagick->identifyFormat("Trim box: %@ number of unique colors: %k");

?>

Imagick::hasPreviousImage
Imagick::identifyImage
Imagick sınıfı


Resmin özniteliklerini döndürerek resmi tanımlar

Imagick::identifyFormat
Imagick::implodeImage
Imagick sınıfı
PHP Manual

Imagick::identifyImage

(PECL imagick 2.0.0)

Imagick::identifyImage — Resmin özniteliklerini döndürerek resmi tanımlar

Açıklama

array Imagick::identifyImage ([ bool $hamÇıktıEkle = false ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin özniteliklerini döndürerek resmi tanımlar. Öznitelikler, resmin genişliği, yüksekliği ve benzerlerinden oluşur.

Değiştirgeler

hamÇıktıEkle

Dönen Değerler

Resmin özniteliklerini içeren bir dizi. Hata durumunda bir ImagickException istisnası oluşur.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::identifyFormat
Imagick::implodeImage
Imagick sınıfı


Resmi kopyalamak suretiyle yeni bir resim oluşturur

Imagick::identifyImage
Imagick::importImagePixels
Imagick sınıfı
PHP Manual

Imagick::implodeImage

(PECL imagick 2.0.0)

Imagick::implodeImage — Resmi kopyalamak suretiyle yeni bir resim oluşturur

Açıklama

bool Imagick::implodeImage ( float $yarıçap )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin piksellerini belirtilen yarıçapta içe çökerterek kopyalamak suretiyle yeni bir resim oluşturur.

Değiştirgeler

yarıçap

Çökertme yarıçapı.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::identifyImage
Imagick::importImagePixels
Imagick sınıfı


Imports image pixels

Imagick::implodeImage
Imagick::inverseFourierTransformImage
Imagick sınıfı
PHP Manual

Imagick::importImagePixels

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::importImagePixels — Imports image pixels

Açıklama

public bool Imagick::importImagePixels ( int $x , int $y , int $width , int $height , string $map , int $storage , array $pixels )

Imports pixels from an array into an image. The map is usually 'RGB'. This method imposes the following constraints for the parameters: amount of pixels in the array must match width x height x length of the map. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.4.5 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

x

The image x position

y

The image y position

width

The image width

height

The image height

map

Map of pixel ordering as a string. This can be for example RGB. The value can be any combination or order of R = red, G = green, B = blue, A = alpha (0 is transparent), O = opacity (0 is opaque), C = cyan, Y = yellow, M = magenta, K = black, I = intensity (for grayscale), P = pad.

storage

The pixel storage method. Refer to this list of pixel constants.

pixels

The array of pixels

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Örnekler

Örnek 1 Imagick::importImagePixels() example

<?php

/* Generate array of pixels. 2000 pixels per color stripe */
$count = 2000 * 3;

$pixels =
   array_merge(array_pad(array(), $count, 0),
               array_pad(array(), $count, 255),
               array_pad(array(), $count, 0),
               array_pad(array(), $count, 255),
               array_pad(array(), $count, 0));

/* Width and height. The area is amount of pixels divided
   by three. Three comes from 'RGB', three values per pixel */
$width = $height = pow((count($pixels) / 3), 0.5);

/* Create empty image */
$im = new Imagick();
$im->newImage($width, $height, 'gray');

/* Import the pixels into image.
   width * height * strlen("RGB") must match count($pixels) */
$im->importImagePixels(0, 0, $width, $height, "RGB", Imagick::PIXEL_CHAR, $pixels);

/* output as jpeg image */
$im->setImageFormat('jpg');
header("Content-Type: image/jpg");
echo $im;

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Output of example : Imagick::importImagePixels()

Imagick::implodeImage
Imagick::inverseFourierTransformImage
Imagick sınıfı


Description

Imagick::importImagePixels
Imagick::labelImage
Imagick sınıfı
PHP Manual

Imagick::inverseFourierTransformImage

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::inverseFourierTransformImage — Description

Açıklama

public void Imagick::inverseFourierTransformImage ( string $complement , string $magnitude )

Implements the inverse discrete Fourier transform (DFT) of the image either as a magnitude / phase or real / imaginary image pair.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

complement

The second image to combine with this one to form either the magnitude / phase or real / imaginary image pair.

magnitude

If true, combine as magnitude / phase pair otherwise a real / imaginary image pair.

Dönen Değerler

Imagick::importImagePixels
Imagick::labelImage
Imagick sınıfı


Resme bir yafta ekler

Imagick::inverseFourierTransformImage
Imagick::levelImage
Imagick sınıfı
PHP Manual

Imagick::labelImage

(PECL imagick 2.0.0)

Imagick::labelImage — Resme bir yafta ekler

Açıklama

bool Imagick::labelImage ( string $yafta )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resme bir yafta ekler.

Değiştirgeler

yafta

Eklenecek yafta.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::inverseFourierTransformImage
Imagick::levelImage
Imagick sınıfı


Bir resmin seviyelerini ayarlar

Imagick::labelImage
Imagick::linearStretchImage
Imagick sınıfı
PHP Manual

Imagick::levelImage

(PECL imagick 2.0.0)

Imagick::levelImage — Bir resmin seviyelerini ayarlar

Açıklama

bool Imagick::levelImage ( float $siyah_nokta , float $gamma , float $beyaz_nokta [, int $kanal = Imagick::CHANNEL_ALL ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Siyah ve beyaz noktalarla belirtilen kullanılabilir parçacık aralığının tamamına karşı düşen renkleri oranlayarak bir resmin seviyelerini ayarlar. Belirtilen değiştirgeler siyah, gri ve beyaz noktaları belirtir. siyah_nokta resmin kabul edilebilir en koyu rengini belirtir. Bu noktadan daha koyu renklere sıfır atanır. gamma ile resme uygulanacak gamma düzeltmesi belirtilir. beyaz_nokta resmin kabul edilebilir en açık rengini belirtir. Bu noktadan daha açık renklere azami parçacık değeri atanır.

Değiştirgeler

siyah_nokta

Resmin en koyu rengi.

gamma

Gamma düzeltmesi.

beyaz_nokta

Resmin en açık rengi.

kanal

Normalde kanal türü sabitlerinden biri, ancak bitsel işleçler kullanılarak birden fazla kanal belirtilebilir.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::labelImage
Imagick::linearStretchImage
Imagick sınıfı


Resmin koyuluğunu doygunluk ile abartır

Imagick::levelImage
Imagick::liquidRescaleImage
Imagick sınıfı
PHP Manual

Imagick::linearStretchImage

(PECL imagick 2.0.0)

Imagick::linearStretchImage — Resmin koyuluğunu doygunluk ile abartır

Açıklama

bool Imagick::linearStretchImage ( float $siyah_nokta , float $beyaz_nokta )

Resmin koyuluğunu doygunluk ile abartır.

Değiştirgeler

siyah_nokta

Resmin siyah noktası.

beyaz_nokta

Resmin beyaz noktası

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::levelImage
Imagick::liquidRescaleImage
Imagick sınıfı


Bir resmi veya resimleri canlandırır

Imagick::linearStretchImage
Imagick::listRegistry
Imagick sınıfı
PHP Manual

Imagick::liquidRescaleImage

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::liquidRescaleImage — Bir resmi veya resimleri canlandırır

Açıklama

bool Imagick::liquidRescaleImage ( int $genişlik , int $yükseklik , float $delta_x , float $diklik )

Resimlerin akışkan yeniden boyutlandırma yöntemi kullanılarak boyutlandırılmasını sağlar. Bu yöntem birleşim yerini ayırma tekniğinin bir gerçeklenimidir. Bu yöntemin çalışması için ImageMagick kütüphanesinin liblqr desteğiyle derlenmiş olması gerekir. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.3.9 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

genişlik

Hedefin genişliği.

yükseklik

Hedefin yüksekliği.

delta_x

Birleşim yerinin x ekseninı ne kadar çaprazlayacağını belirler. 0 değeri birleşim yerinin düz olmasını sağlar.

diklik

Düz olmayan birleşim yerleri için bir sapma tanımlar, Bu değiştirgenin değeri genelde 0'dır.

Dönen Değerler

Başarı durumunda TRUE döner.

Ayrıca Bakınız

  • Imagick::resizeImage() - Bir resmi boyutlandırır

Imagick::linearStretchImage
Imagick::listRegistry
Imagick sınıfı


Description

Imagick::liquidRescaleImage
Imagick::magnifyImage
Imagick sınıfı
PHP Manual

Imagick::listRegistry

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::listRegistry — Description

Açıklama

public static array Imagick::listRegistry ( void )

List all the registry settings. Returns an array of all the key/value pairs in the registry

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

An array containing the key/values from the registry.

Imagick::liquidRescaleImage
Imagick::magnifyImage
Imagick sınıfı


Enboy oranını koruyarak resmi iki katına büyütür

Imagick::listRegistry
Imagick::mapImage
Imagick sınıfı
PHP Manual

Imagick::magnifyImage

(PECL imagick 2.0.0)

Imagick::magnifyImage — Enboy oranını koruyarak resmi iki katına büyütür

Açıklama

bool Imagick::magnifyImage ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Enboy oranını koruyarak resmi iki katına büyütür.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::listRegistry
Imagick::mapImage
Imagick sınıfı


Resmin renklerini belirtilen resimdeki en yakın renklerle değiştirir

Imagick::magnifyImage
Imagick::matteFloodfillImage
Imagick sınıfı
PHP Manual

Imagick::mapImage

(PECL imagick 2.0.0)

Imagick::mapImage — Resmin renklerini belirtilen resimdeki en yakın renklerle değiştirir

Açıklama

bool Imagick::mapImage ( Imagick $resim , bool $kıpırtı )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin renklerini belirtilen resimdeki en yakın renklerle değiştirir.

Değiştirgeler

resim

kıpırtı

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::magnifyImage
Imagick::matteFloodfillImage
Imagick sınıfı


Bir rengin şeffaflık değerini değiştirir

Imagick::mapImage
Imagick::medianFilterImage
Imagick sınıfı
PHP Manual

Imagick::matteFloodfillImage

(PECL imagick 2.0.0)

Imagick::matteFloodfillImage — Bir rengin şeffaflık değerini değiştirir

Açıklama

bool Imagick::matteFloodfillImage ( float $alfa , float $benzerlik , mixed $çerçeve_rengi , int $x , int $y )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

çerçeve_rengi ile eşleşen her pikselin ve komşu pikselinin şeffaflık değerini değiştirir. imagick::PAINT_FILLTOBORDER etkinse resmin çerçeve rengi ile eşleşmeyen komşu piksellerinin şeffaflık değerleri değiştirilir.

Değiştirgeler

alfa

Şeffaflık seviyesi; 1.0 tamamen mat, 0.0 tamamen şeffaf demektir.

benzerlik

Renkler arasındaki azami benzerlik. Örneğin bu değere 10 atarsanız, renk kırmızı ise ve kırmızının koyulukları 100 ve 102 ise bu iki renk aynı kabul edilir.

çerçeve_rengi

Bir renk dizgesi veya bir ImagickPixel nesnesi.

x

İşlemin başlatılacağı noktanın X konumu.

y

İşlemin başlatılacağı noktanın Y konumu.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Sürüm Bilgisi

Sürüm: | Açıklama
2.1.0 | Artık renk olarak rengi ifade eden bir dizge belirtilebiliyor. Evvelce sadece bir ImagickPixel nesnesi belirtilebiliyordu.

Imagick::mapImage
Imagick::medianFilterImage
Imagick sınıfı


Resme bir sayısal süzgeç uygular

Imagick::matteFloodfillImage
Imagick::mergeImageLayers
Imagick sınıfı
PHP Manual

Imagick::medianFilterImage

(PECL imagick 2.0.0)

Imagick::medianFilterImage — Resme bir sayısal süzgeç uygular

Açıklama

bool Imagick::medianFilterImage ( float $yarıçap )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bir sayısal süzgeç uygulayarak bir resmin görüntü kalitesini arttırır. yarıçap ile tanımlanan bir piksel kümesindeki her pikseli kümenin ortanca rengiyle değiştirir.

Değiştirgeler

yarıçap

Ortanca renginin tespit edilip diğer piksellerine uygulanacağı piksel kümesini tanımlayan yarıçap.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::matteFloodfillImage
Imagick::mergeImageLayers
Imagick sınıfı


Resim katmanlarını katıştırır

Imagick::medianFilterImage
Imagick::minifyImage
Imagick sınıfı
PHP Manual

Imagick::mergeImageLayers

(PECL imagick 2.1.0)

Imagick::mergeImageLayers — Resim katmanlarını katıştırır

Açıklama

bool Imagick::mergeImageLayers ( int $katman_yöntemi )

Resim katmanlarını tek bir katman haline gelecek şekilde katıştırır. PSD gibi çok katmanlı resimlerle çalışırken yararlıdır. Katmanların nasıl katıştırılacağı katman_yöntemi ile belirtilir. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.3.7 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

katman_yöntemi

Katman yöntemi sabitlerinden biri.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Ayrıca Bakınız

  • Imagick::flattenImages() - Bir resim dizisini tek bir resim halinde üstüste bindirir

Imagick::medianFilterImage
Imagick::minifyImage
Imagick sınıfı


Enboy oranını koruyarak resmi yarı boyutuna indirir

Imagick::mergeImageLayers
Imagick::modulateImage
Imagick sınıfı
PHP Manual

Imagick::minifyImage

(PECL imagick 2.0.0)

Imagick::minifyImage — Enboy oranını koruyarak resmi yarı boyutuna indirir

Açıklama

bool Imagick::minifyImage ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Enboy oranını koruyarak resmi yarı boyutuna indirir.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::mergeImageLayers
Imagick::modulateImage
Imagick sınıfı


Resmin parlaklık, doygunluk ve renk sıcaklığını denetler

Imagick::minifyImage
Imagick::montageImage
Imagick sınıfı
PHP Manual

Imagick::modulateImage

(PECL imagick 2.0.0)

Imagick::modulateImage — Resmin parlaklık, doygunluk ve renk sıcaklığını denetler

Açıklama

bool Imagick::modulateImage ( float $parlaklık , float $doygunluk , float $sıcaklık )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin parlaklık, doygunluk ve renk sıcaklığını denetleyebilmenizi sağlar. Renk parlaklığını 20 arttırmak, renk doygunluğunu 10 azaltıp renk sıcaklığına dokunmamak için şu değerleri kullanın: 120,90,100.

Değiştirgeler

parlaklık

Parlaklık yüzdesi.

doygunluk

Doygunluk yüzdesi.

sıcaklık

Geçerli konumdan itibaren mutlak bir dönüş yüzdesi. Örneğin, 50 değeri saatin ters yönünde 90° dönüşle sonuçlanırken 150 değeri saat yönünde 90° ile sonuçlanır. 0 ve 200, her ikisi de 180 derecelik bir dönüşle sonuçlanır.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::minifyImage
Imagick::montageImage
Imagick sınıfı


Birleşik bir resim oluşturur

Imagick::modulateImage
Imagick::morphImages
Imagick sınıfı
PHP Manual

Imagick::montageImage

(PECL imagick 2.0.0)

Imagick::montageImage — Birleşik bir resim oluşturur

Açıklama

Imagick Imagick::montageImage ( ImagickDraw $nesne , string $döşeme_geometrisi , string $örnek_geometrisi , int $kip , string $çerçeve )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Ayrı ayrı resimleri birleştirerek birleşik bir resim haline getirir. Resimler birleşik resmin üzerine her karenin altında isteğe bağlı olarak bulunan resim ismine göre döşenir.

Değiştirgeler

nesne

Yazı tipi ismi, boyut ve renk bu nesne ile sağlanır.

döşeme_geometrisi

Satır ve sayfa başına kare sayısı (6x4+0+0 gibi).

örnek_geometrisi

Her küçük resim örneği için önerilen resim ve çerçeve boyutu.

kip

Örnek resim birleştirme kipi. Montaj kipi sabitlerine bakınız.

çerçeve

Resmi süslü bir çerçeve ile sarmalar (15x15+3+3 gibi). Çerçeve rengi olarak resmin matlık rengi kullanılır.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::modulateImage
Imagick::morphImages
Imagick sınıfı


Bir resim dizisini başkalaşıma uğratır

Imagick::montageImage
Imagick::morphology
Imagick sınıfı
PHP Manual

Imagick::morphImages

(PECL imagick 2.0.0)

Imagick::morphImages — Bir resim dizisini başkalaşıma uğratır

Açıklama

Imagick Imagick::morphImages ( int $kare_sayısı )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bir resim dizisini başkalaşıma uğratır. Hem resim piksellerinde hem de resim boyutlarında bir resimden diğerine bir başkalaşım etkisi vermek için düzgün doğrusal aradeğerleme yapar.

Değiştirgeler

kare_sayısı

Resimler arasında üretilecek resim sayısı.

Dönen Değerler

Yöntem başarılı olursa yeni bir Imagick nesnesi döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::montageImage
Imagick::morphology
Imagick sınıfı


Description

Imagick::morphImages
Imagick::mosaicImages
Imagick sınıfı
PHP Manual

Imagick::morphology

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::morphology — Description

Açıklama

public void Imagick::morphology ( int $morphologyMethod , int $iterations , ImagickKernel $ImagickKernel [, string $CHANNEL ] )

Applies a user supplied kernel to the image according to the given morphology method.

Değiştirgeler

morphologyMethod

Which morphology method to use one of the \Imagick::MORPHOLOGY_* constants.

iterations

The number of iteration to apply the morphology function. A value of -1 means loop until no change found. How this is applied may depend on the morphology method. Typically this is a value of 1.

ImagickKernel

CHANNEL

Dönen Değerler

Örnekler

Örnek 1 Convolve Imagick::morphology()

<?php
        $imagick = $this->getCharacter();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_GAUSSIAN, "5,1");
        $imagick->morphology(\Imagick::MORPHOLOGY_CONVOLVE, 2, $kernel);
        header("Content-Type: image/png");
        echo $imagick->getImageBlob();

?>

Örnek 2 Correlate Imagick::morphology()

<?php

        // Top-left pixel must be black
        // Bottom right pixel must be white
        // We don't care about the rest.

        $imagick = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromMatrix(self::$correlateMatrix, [2, 2]);
        $imagick->morphology(\Imagick::MORPHOLOGY_CORRELATE, 1, $kernel);
        header("Content-Type: image/png");
        echo $imagick->getImageBlob();

?>

Örnek 3 Erode Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_OCTAGON, "3");
        $canvas->morphology(\Imagick::MORPHOLOGY_ERODE, 2, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Örnek 4 Erode Intensity Imagick::morphology()

<?php
        $canvas = $this->getCharacter();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_OCTAGON, "1");
        $canvas->morphology(\Imagick::MORPHOLOGY_ERODE_INTENSITY, 2, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Örnek 5 Dilate Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_OCTAGON, "3");
        $canvas->morphology(\Imagick::MORPHOLOGY_DILATE, 4, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Örnek 6 Dilate intensity Imagick::morphology()

<?php
        $canvas = $this->getCharacter();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_OCTAGON, "1");
        $canvas->morphology(\Imagick::MORPHOLOGY_DILATE_INTENSITY, 4, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Örnek 7 Distance with Chebyshev kernel Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_CHEBYSHEV, "3");
        $canvas->morphology(\Imagick::MORPHOLOGY_DISTANCE, 3, $kernel);
        $canvas->autoLevelImage();
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Örnek 8 Distance with Manhattan kernel Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_MANHATTAN, "5");
        $canvas->morphology(\Imagick::MORPHOLOGY_DISTANCE, 3, $kernel);
        $canvas->autoLevelImage();
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Örnek 9 Distance with ocatagonal kernel Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_OCTAGONAL, "5");
        $canvas->morphology(\Imagick::MORPHOLOGY_DISTANCE, 3, $kernel);
        $canvas->autoLevelImage();
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Örnek 10 Distance with Euclidean kernel Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_EUCLIDEAN, "4");
        $canvas->morphology(\Imagick::MORPHOLOGY_DISTANCE, 3, $kernel);
        $canvas->autoLevelImage();
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Örnek 11 Edge Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_OCTAGON, "3");
        $canvas->morphology(\Imagick::MORPHOLOGY_EDGE, 1, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Örnek 12 Open Imagick::morphology()

<?php
        // As a result you will see that 'Open' smoothed the outline, by rounding off any sharp points, and remove any parts that is smaller than the shape used. It will also disconnect or 'open' any thin bridges.
        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_DISK, "6");
        $canvas->morphology(\Imagick::MORPHOLOGY_OPEN, 1, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Örnek 13 Open intensity Imagick::morphology()

<?php
        // As a result you will see that 'Open' smoothed the outline, by rounding off any sharp points, and remove any parts that is smaller than the shape used. It will also disconnect or 'open' any thin bridges.

        $canvas = $this->getCharacter();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_DISK, "6");
        $canvas->morphology(\Imagick::MORPHOLOGY_OPEN_INTENSITY, 1, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Örnek 14 Close Imagick::morphology()

<?php
        //The basic use of the 'Close' method is to reduce or remove any 'holes' or 'gaps' about the size of the kernel 'Structure Element'. That is 'close' parts of the background that are about that size.
        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_DISK, "6");
        $canvas->morphology(\Imagick::MORPHOLOGY_CLOSE, 1, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Örnek 15 Close Intensity Imagick::morphology()

<?php
        //The basic use of the 'Close' method is to reduce or remove any 'holes' or 'gaps' about the size of the kernel 'Structure Element'. That is 'close' parts of the background that are about that size.
        $canvas = $this->getCharacter();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_DISK, "6");
        $canvas->morphology(\Imagick::MORPHOLOGY_CLOSE_INTENSITY, 1, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Örnek 16 Smooth Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_OCTAGON, "3");
        $canvas->morphology(\Imagick::MORPHOLOGY_SMOOTH, 1, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Örnek 17 Edge in Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_OCTAGON, "3");
        $canvas->morphology(\Imagick::MORPHOLOGY_EDGE_IN, 1, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Örnek 18 Edge out Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_OCTAGON, "3");
        $canvas->morphology(\Imagick::MORPHOLOGY_EDGE_OUT, 1, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Örnek 19 The 'TopHat' method, or more specifically 'White Top Hat', returns the pixels that were removed by a Opening of the shape, that is the pixels that were removed to round off the points, and the connecting bridged between shapes. Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_DISK, "5");
        $canvas->morphology(\Imagick::MORPHOLOGY_TOP_HAT, 1, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Örnek 20 The 'BottomHat' method, also known as 'Black TopHat' is the pixels that a Closing of the shape adds to the image. That is the the pixels that were used to fill in the 'holes', 'gaps', and 'bridges'. Imagick::morphology()

<?php

        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_DISK, "5");
        $canvas->morphology(\Imagick::MORPHOLOGY_BOTTOM_HAT, 1, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Örnek 21 Hit and Miss Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        //This finds all the pixels with 3 pixels of the right edge
        $matrix = [[1, false, false, 0]];
        $kernel = \ImagickKernel::fromMatrix(
            $matrix,
            [0, 0]
        );
        $canvas->morphology(\Imagick::MORPHOLOGY_HIT_AND_MISS, 1, $kernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Örnek 22 Thinning Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $leftEdgeKernel = \ImagickKernel::fromMatrix([[0, 1]], [1, 0]);
        $rightEdgeKernel = \ImagickKernel::fromMatrix([[1, 0]], [0, 0]);
        $leftEdgeKernel->addKernel($rightEdgeKernel);

        $canvas->morphology(\Imagick::MORPHOLOGY_THINNING, 3, $leftEdgeKernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Örnek 23 Thicken Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $leftEdgeKernel = \ImagickKernel::fromMatrix([[0, 1]], [1, 0]);
        $rightEdgeKernel = \ImagickKernel::fromMatrix([[1, 0]], [0, 0]);
        $leftEdgeKernel->addKernel($rightEdgeKernel);

        $canvas->morphology(\Imagick::MORPHOLOGY_THICKEN, 3, $leftEdgeKernel);
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Örnek 24 Thick to generate a convex hull Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $diamondKernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_DIAMOND, "1");
        $convexKernel =  \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_CONVEX_HULL, "");

        // The thicken morphology doesn't handle small gaps. We close them
        // with the close morphology.
        $canvas->morphology(\Imagick::MORPHOLOGY_CLOSE, 1, $diamondKernel);
        $canvas->morphology(\Imagick::MORPHOLOGY_THICKEN, -1, $convexKernel);
        $canvas->morphology(\Imagick::MORPHOLOGY_CLOSE, 1, $diamondKernel);

        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Örnek 25 Iterative morphology Imagick::morphology()

<?php
        $canvas = $this->getCharacterOutline();
        $kernel = \ImagickKernel::fromBuiltIn(\Imagick::KERNEL_DISK, "2");
        $canvas->morphology(\Imagick::MORPHOLOGY_ITERATIVE, 3, $kernel);
        $canvas->autoLevelImage();
        header("Content-Type: image/png");
        echo $canvas->getImageBlob();

?>

Örnek 26 Helper functon to get an image silhouette Imagick::morphology()

<?php
    private function getCharacterOutline() {

        $imagick = new \Imagick(realpath("./images/character.png"));
        $character = new \Imagick();
        $character->newPseudoImage(
            $imagick->getImageWidth(),
            $imagick->getImageHeight(),
            "canvas:white"
        );
        $canvas = new \Imagick();
        $canvas->newPseudoImage(
            $imagick->getImageWidth(),
            $imagick->getImageHeight(),
            "canvas:black"
        );

        $character->compositeimage(
            $imagick,
            \Imagick::COMPOSITE_COPYOPACITY,
            0, 0
        );
        $canvas->compositeimage(
            $character,
            \Imagick::COMPOSITE_ATOP,
            0, 0
        );
        $canvas->setFormat('png');

        return $canvas;
    }

?>

Imagick::morphImages
Imagick::mosaicImages
Imagick sınıfı


Resimlerden bir mozaik oluşturur

Imagick::morphology
Imagick::motionBlurImage
Imagick sınıfı
PHP Manual

Imagick::mosaicImages

(PECL imagick 2.0.0)

Imagick::mosaicImages — Resimlerden bir mozaik oluşturur

Açıklama

Imagick Imagick::mosaicImages ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Yapışık tek bir resim oluşturmak üzere bir resim kümesini resme yanyana yerleştirir. Resmin sayfa başlangıcına göre tanımlanmış bir konumda birleştirilmiş bir dizi resmin her birini bir kalemle ilişkilendirir.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::morphology
Imagick::motionBlurImage
Imagick sınıfı


Hareket bulanıklığını taklit eder

Imagick::mosaicImages
Imagick::negateImage
Imagick sınıfı
PHP Manual

Imagick::motionBlurImage

(PECL imagick 2.0.0)

Imagick::motionBlurImage — Hareket bulanıklığını taklit eder

Açıklama

bool Imagick::motionBlurImage ( float $yarıçap , float $sapma , float $açı [, int $kanal = Imagick::CHANNEL_DEFAULT ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Hareket bulanıklığını taklit eder. Yarıçap ve standart sapması belirtilen bir Gauss işleci ile resim evriştirilir. Makul sonuçlar elde etmek için yarıçap standart sapmadan büyük olmalıdır. yarıçap olarak 0 verirseniz Imagick::motionBlurImage() size uygun bir yarıçap seçecektir. açı ile bulanıklaştırma açısı belirtilir.

Değiştirgeler

yarıçap

Merkezdeki piksel sayısı değil, piksel cinsinden Gauss işleci yarıçapıdır.

sapma

Piksel cinsinden standart sapma.

açı

Bulanıklığın uygulanacağı açı.

kanal

Normalde kanal türü sabitlerinden biri, ancak bitsel işleçler kullanılarak birden fazla kanal belirtilebilir.Bu değiştirge, sadece, derleme sırasında ImageMagick kütüphanesinin 6.4.4 veya sonraki bir sürümü kuruluysa etkilidir.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::mosaicImages
Imagick::negateImage
Imagick sınıfı


Resmin renklerini negatiflerine dönüştürür

Imagick::motionBlurImage
Imagick::newImage
Imagick sınıfı
PHP Manual

Imagick::negateImage

(PECL imagick 2.0.0)

Imagick::negateImage — Resmin renklerini negatiflerine dönüştürür

Açıklama

bool Imagick::negateImage ( bool $gri_tonlama [, int $kanal = Imagick::CHANNEL_ALL ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin renklerini negatiflerine dönüştürür. gri_tonlama değiştirgesine TRUE atanırsa resmin sadece gri tonlama renkleri negatiflerine dönüştürülür.

Değiştirgeler

gri_tonlama

TRUE atanırsa resmin sadece gri tonlu pikselleri negatiflerine dönüştürülür.

kanal

Normalde kanal türü sabitlerinden biri, ancak bitsel işleçler kullanılarak birden fazla kanal belirtilebilir.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::motionBlurImage
Imagick::newImage
Imagick sınıfı


Yeni bir resim oluşturur

Imagick::negateImage
Imagick::newPseudoImage
Imagick sınıfı
PHP Manual

Imagick::newImage

(PECL imagick 2.0.0)

Imagick::newImage — Yeni bir resim oluşturur

Açıklama

bool Imagick::newImage ( int $genişlik , int $yükseklik , mixed $artalan [, string $biçem ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bir ImagickPixel değerini artalan rengi ile ilişkilendirerek yeni bir resim oluşturur.

Değiştirgeler

genişlik

Yeni resmin genişliği.

yükseklik

Yeni resmin yüksekliği.

artalan

Yeni resmin artalan rengi.

biçem

Resim biçemi.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Sürüm Bilgisi

Sürüm: | Açıklama
2.1.0 | Artık renk olarak rengi ifade eden bir dizge belirtilebiliyor. Evvelce sadece bir ImagickPixel nesnesi belirtilebiliyordu.
2.0.1 | Seçimlik biçem değiştirgesi eklendi

Örnekler

Örnek 1 - Imagick::newImage() örneği

Yeni bir resim oluşturup görüntüleyelim.

<?php

$image = new Imagick();
$image->newImage(100, 100, new ImagickPixel('red'));
$image->setImageFormat('png');

header('Content-type: image/png');
echo $image;

?>

Imagick::negateImage
Imagick::newPseudoImage
Imagick sınıfı


Yeni bir resim oluşturur

Imagick::newImage
Imagick::nextImage
Imagick sınıfı
PHP Manual

Imagick::newPseudoImage

(PECL imagick 2.0.0)

Imagick::newPseudoImage — Yeni bir resim oluşturur

Açıklama

bool Imagick::newPseudoImage ( int $genişlik , int $yükseklik , string $sözde_dizge )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ImageMagick sözde biçemlerini kullanarak yeni bir resim oluşturur.

Değiştirgeler

genişlik

Yeni resmin genişliği.

yükseklik

Yeni resmin yüksekliği

sözde_dizge

Sözde resim tanımını içeren dizge.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::newImage
Imagick::nextImage
Imagick sınıfı


Bir sonraki resme gider

Imagick::newPseudoImage
Imagick::normalizeImage
Imagick sınıfı
PHP Manual

Imagick::nextImage

(PECL imagick 2.0.0)

Imagick::nextImage — Bir sonraki resme gider

Açıklama

bool Imagick::nextImage ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resim listesindeki bir sonraki resmi Imagick nesnesi ile ilişkilendirir.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::newPseudoImage
Imagick::normalizeImage
Imagick sınıfı


Renkli bir resmin zıtlığını arttırır

Imagick::nextImage
Imagick::oilPaintImage
Imagick sınıfı
PHP Manual

Imagick::normalizeImage

(PECL imagick 2.0.0)

Imagick::normalizeImage — Renkli bir resmin zıtlığını arttırır

Açıklama

bool Imagick::normalizeImage ([ int $kanal ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Piksel renklerini, kullanılabilen renk aralığının tamamına yaymak için ayarlayarak renkli bir resmin zıtlığını arttırır.

Değiştirgeler

kanal

Normalde kanal türü sabitlerinden biri, ancak bitsel işleçler kullanılarak birden fazla kanal belirtilebilir.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::nextImage
Imagick::oilPaintImage
Imagick sınıfı


Yağlı boya resmi taklit eder

Imagick::normalizeImage
Imagick::opaquePaintImage
Imagick sınıfı
PHP Manual

Imagick::oilPaintImage

(PECL imagick 2.0.0)

Imagick::oilPaintImage — Yağlı boya resmi taklit eder

Açıklama

bool Imagick::oilPaintImage ( float $yarıcap )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Yağlı boya etkisi oluşturmak için resme bir süzgeç uygular. Belirtilen yarıçapa göre tanımlanın dairesel bölge içindeki her piksel, o bölge içinde en sık rastlanan renkle değiştirilir.

Değiştirgeler

yarıcap

Dairesel bölgeyi belirleyen yarıçap.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::normalizeImage
Imagick::opaquePaintImage
Imagick sınıfı


Hedef ile eşleşen piksellerin rengini değiştirir

Imagick::oilPaintImage
Imagick::optimizeImageLayers
Imagick sınıfı
PHP Manual

Imagick::opaquePaintImage

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::opaquePaintImage — Hedef ile eşleşen piksellerin rengini değiştirir

Açıklama

bool Imagick::opaquePaintImage ( mixed $hedef , mixed $renk , float $benzerlik , bool $ters [, int $kanal = Imagick::CHANNEL_DEFAULT ] )

hedef ile eşleşen renkleri renk ile değiştirir. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.3.8 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

hedef

Değiştirilecek rengi içeren bir dizge veya bir ImagickPixel nesnesi.

renk

Yeni renk.

benzerlik

Renkler arasındaki azami benzerlik. Örneğin bu değere 10 atarsanız, renk kırmızı ise ve kırmızının koyulukları 100 ve 102 ise bu iki renk aynı kabul edilir.

ters

TRUE belirtilirse hedef renk ile eşleşmeyen renkteki piksellerin renkleri değiştirilir.

kanal

Normalde kanal türü sabitlerinden biridir, ancak bitsel işleçler kullanılarak birden fazla kanal belirtilebilir. Imagick::CHANNEL_DEFAULT öntanımlıdır.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::oilPaintImage
Imagick::optimizeImageLayers
Imagick sınıfı


En iyilemek amacıyla resimlerin tekrarlanan bölümlerini siler

Imagick::opaquePaintImage
Imagick::orderedPosterizeImage
Imagick sınıfı
PHP Manual

Imagick::optimizeImageLayers

(PECL imagick 2.0.0)

Imagick::optimizeImageLayers — En iyilemek amacıyla resimlerin tekrarlanan bölümlerini siler

Açıklama

bool Imagick::optimizeImageLayers ( void )

Bir hareketli GIF resminde, canlandırma sonuçlarını koruyarak her resmi önceki resimle karşılaştırıp kırpılacak en küçük resim karesini seçmeye çalışır. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.2.9 veya sonraki bir sürümü kuruluysa kullanılabilir.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Örnekler

Örnek 1 - Imagick::optimizeImageLayers() örneği

Bir GIF resmini okur, en iyiler ve yazar.

<?php
/* Yeni bir imagick nesnesi oluşturalım */
$im = new Imagick("test.gif");

/* Resim katmanlarını en iyileyelim */
$im->optimizeImageLayers();

/* Elde edilen resmi dosyaya yazalım */
$im->writeImages("test_optimized.gif", true);
?>

Ayrıca Bakınız

  • Imagick::compareImageLayers() - Resim katmanlarını karşılaştırıp en iyilenmiş resmi döndürür
  • Imagick::writeImages() - Bir resmi veya resim kümesini dosyaya yazar
  • Imagick::writeImage() - Resmi belirtilen dosyaya yazar

Imagick::opaquePaintImage
Imagick::orderedPosterizeImage
Imagick sınıfı


Resme kurallı titreklik uygular

Imagick::optimizeImageLayers
Imagick::paintFloodfillImage
Imagick sınıfı
PHP Manual

Imagick::orderedPosterizeImage

(PECL imagick 2.2.2)

Imagick::orderedPosterizeImage — Resme kurallı titreklik uygular

Açıklama

bool Imagick::orderedPosterizeImage ( string $eşik_eşlemi [, int $kanal = Imagick::CHANNEL_ALL ] )

Önceden tanımlanmış kıpırtı eşik seviyelerine göre resme titreklik uygular. Belirtilen kanal veya kanallara bağlı olarak çok sayıda eşik seviyesi bulunabilir. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.3.1 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

eşik_eşlemi

Kullanılacak eşik eşleminin ismini içeren bir dizge.

kanal

Normalde kanal türü sabitlerinden biri, ancak bitsel işleçler kullanılarak birden fazla kanal belirtilebilir.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::optimizeImageLayers
Imagick::paintFloodfillImage
Imagick sınıfı


Belirtilen renkle eşleşen piksellerin rengini değiştirir

Imagick::orderedPosterizeImage
Imagick::paintOpaqueImage
Imagick sınıfı
PHP Manual

Imagick::paintFloodfillImage

(PECL imagick 2.1.0)

Imagick::paintFloodfillImage — Belirtilen renkle eşleşen piksellerin rengini değiştirir

Açıklama

bool Imagick::paintFloodfillImage ( mixed $dolgu , float $benzerlik , mixed $çerçeve_rengi , int $x , int $y [, int $kanal = Imagick::CHANNEL_ALL ] )

Belirtilen dolgu rengiyle eşleşen piksellerin ve komşularının rengini değiştirir. ImageMagick 6.3.8 itibariyle bu yöntemin kullanımı önerilmemektedir; yerine Imagick::floodfillPaintImage() kullanılmalıdır.

Değiştirgeler

dolgu

Renk ifade eden bir dizge veya bir ImagickPixel nesnesi.

benzerlik

Renkler arasındaki azami benzerlik. Örneğin bu değere 10 atarsanız, renk kırmızı ise ve kırmızının koyulukları 100 ve 102 ise bu iki renk aynı kabul edilir.

çerçeve_rengi

Çerçeve rengini ifade eden bir dizge veya bir ImagickPixel nesnesi.

x

Dolgunun başlatılacağı X konumu.

y

Dolgunun başlatılacağı Y konumu.

kanal

Normalde kanal türü sabitlerinden biridir, ancak bitsel işleçler kullanılarak birden fazla kanal belirtilebilir. Imagick::CHANNEL_DEFAULT öntanımlıdır.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::orderedPosterizeImage
Imagick::paintOpaqueImage
Imagick sınıfı


Bir rengi bir başka renkle değiştirir

Imagick::paintFloodfillImage
Imagick::paintTransparentImage
Imagick sınıfı
PHP Manual

Imagick::paintOpaqueImage

(PECL imagick 2.0.0)

Imagick::paintOpaqueImage — Bir rengi bir başka renkle değiştirir

Açıklama

bool Imagick::paintOpaqueImage ( mixed $eskisi , mixed $yenisi , float $benzerlik [, int $kanal = Imagick::CHANNEL_ALL ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

eskisi renkteki pikselleri yenisi renge çevirir.

Değiştirgeler

eskisi

Mevcut rengi ifade eden bir dizge veya bir ImagickPixel nesnesi.

yenisi

Yeni rengi ifade eden bir dizge veya bir ImagickPixel nesnesi.

benzerlik

Renkler arasındaki azami benzerlik. Örneğin bu değere 10 atarsanız, renk kırmızı ise ve kırmızının koyulukları 100 ve 102 ise bu iki renk aynı kabul edilir.

kanal

Normalde kanal türü sabitlerinden biri, ancak bitsel işleçler kullanılarak birden fazla kanal belirtilebilir.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Sürüm Bilgisi

Sürüm: | Açıklama
2.1.0 | Artık birinci ve ikinci değiştirgelerde renk olarak rengi ifade eden bir dizge belirtilebiliyor. Evvelce sadece bir ImagickPixel nesnesi belirtilebiliyordu.

Imagick::paintFloodfillImage
Imagick::paintTransparentImage
Imagick sınıfı


Resimdeki belli bir rengi dolgu rengiyle değiştirir

Imagick::paintOpaqueImage
Imagick::pingImage
Imagick sınıfı
PHP Manual

Imagick::paintTransparentImage

(PECL imagick 2.0.0)

Imagick::paintTransparentImage — Resimdeki belli bir rengi dolgu rengiyle değiştirir

Açıklama

bool Imagick::paintTransparentImage ( mixed $hedef , float $alfa , float $benzerlik )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resimdeki belli bir rengi dolgu rengiyle değiştirir.

Değiştirgeler

hedef

Değiştirilecek renk.

alfa

Şeffaflık seviyesi: 1.0 tam mat ve 0.0 tam şeffaf.

benzerlik

Renkler arasındaki azami benzerlik. Örneğin bu değere 10 atarsanız, renk kırmızı ise ve kırmızının koyulukları 100 ve 102 ise bu iki renk aynı kabul edilir.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Sürüm Bilgisi

Sürüm: | Açıklama
2.1.0 | Artık renk olarak rengi ifade eden bir dizge belirtilebiliyor. Evvelce sadece bir ImagickPixel nesnesi belirtilebiliyordu.

Imagick::paintOpaqueImage
Imagick::pingImage
Imagick sınıfı


Temel resim özniteliklerini bir dosyadan okur

Imagick::paintTransparentImage
Imagick::pingImageBlob
Imagick sınıfı
PHP Manual

Imagick::pingImage

(PECL imagick 2.0.0)

Imagick::pingImage — Temel resim özniteliklerini bir dosyadan okur

Açıklama

bool Imagick::pingImage ( string $dosya )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bu yöntem, resmin tamamını belleğe aktarmadan resmin boyutlarının ve biçeminin sorgulanmasını sağlar.

Değiştirgeler

dosya

Bilgilerin okunacağı dosya.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::paintTransparentImage
Imagick::pingImageBlob
Imagick sınıfı


Temel resim özniteliklerini bir dizgeden okur

Imagick::pingImage
Imagick::pingImageFile
Imagick sınıfı
PHP Manual

Imagick::pingImageBlob

(PECL imagick 2.0.0)

Imagick::pingImageBlob — Temel resim özniteliklerini bir dizgeden okur

Açıklama

bool Imagick::pingImageBlob ( string $resim )

Bu yöntem, resmin tamamını belleğe aktarmadan resmin boyutlarının ve biçeminin sorgulanmasını sağlar. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.2.9 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

resim

Resim verisini içeren ikil dizge.

Dönen Değerler

Başarı durumunda TRUE döner.

Örnekler

Örnek 1 - Imagick::pingImageBlob() örneği

<?php
/* resmin içeriğini bir dizgeye okuyalım */
$image = file_get_contents("test.jpg");

/* Yeni bir imagick nesnesi oluşturalım */
$im = new Imagick();

/* Dizgeyi nesneye aktaralım */
$im->pingImageBlob($image);

/* Resmin genişlik ve yüksekliğini basalım */
echo $im->getImageWidth() . 'x' . $im->getImageHeight();
?>

Ayrıca Bakınız

  • Imagick::pingImage() - Temel resim özniteliklerini bir dosyadan okur
  • Imagick::pingImageFile() - Temel resim özniteliklerini bir akımdan okur
  • Imagick::readImage() - Resmi dosyadar okur
  • Imagick::readImageBlob() - Resmi ikil bir dizgeden okur
  • Imagick::readImageFile() - Resmi akımdan okur

Imagick::pingImage
Imagick::pingImageFile
Imagick sınıfı


Temel resim özniteliklerini bir akımdan okur

Imagick::pingImageBlob
Imagick::polaroidImage
Imagick sınıfı
PHP Manual

Imagick::pingImageFile

(PECL imagick 2.0.0)

Imagick::pingImageFile — Temel resim özniteliklerini bir akımdan okur

Açıklama

bool Imagick::pingImageFile ( resource $dt [, string $dosya ] )

Bu yöntem, resmin tamamını belleğe aktarmadan resmin boyutlarının ve biçeminin sorgulanmasını sağlar. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.2.9 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

filehandle

Resim için açık bir dosya tanıtıcısı.

dosya

Seçimlik olarak resmin dosya ismi.

Dönen Değerler

Başarı durumunda TRUE döner.

Örnekler

Örnek 1 - Imagick::pingImageFile() örneği

Uzaktaki bir dosyayı açalım

<?php
/* Uzak dosyaya fopen */
$dt = fopen("http://example.com/test.jpg");

/* Yeni bir imagick nesnesi oluşturalım */
$im = new Imagick();

/* Dosya tanıtıcısını nesneye aktaralım */
$im->pingImageFile($dt);
?>

Ayrıca Bakınız

  • Imagick::pingImage() - Temel resim özniteliklerini bir dosyadan okur
  • Imagick::pingImageBlob() - Temel resim özniteliklerini bir dizgeden okur
  • Imagick::readImage() - Resmi dosyadar okur
  • Imagick::readImageBlob() - Resmi ikil bir dizgeden okur
  • Imagick::readImageFile() - Resmi akımdan okur

Imagick::pingImageBlob
Imagick::polaroidImage
Imagick sınıfı


Polaroid resmi taklit eder

Imagick::pingImageFile
Imagick::posterizeImage
Imagick sınıfı
PHP Manual

Imagick::polaroidImage

(PECL imagick 2.0.0)

Imagick::polaroidImage — Polaroid resmi taklit eder

Açıklama

bool Imagick::polaroidImage ( ImagickDraw $nesne , float $açı )

Polaroid resmi taklit eder.Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.3.2 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

nesne

Polaroid resmin özellikleri.

açı

Polaroid açısı.

Dönen Değerler

Başarı durumunda TRUE döner.

Örnekler

Örnek 1 - Imagick::polaroidImage() örneği

<?php
/* Nesneyi oluşturalım */
$image = new Imagick('source.png');

/* Matlığı ayarlayalım */
$image->polaroidImage(new ImagickDraw(), 25);

/* Resmi çıktılayalım */
header('Content-type: image/png');
echo $image;

?>

Imagick::pingImageFile
Imagick::posterizeImage
Imagick sınıfı


Resimdeki renkleri belli bir sayıya düşürür

Imagick::polaroidImage
Imagick::previewImages
Imagick sınıfı
PHP Manual

Imagick::posterizeImage

(PECL imagick 2.0.0)

Imagick::posterizeImage — Resimdeki renkleri belli bir sayıya düşürür

Açıklama

bool Imagick::posterizeImage ( int $seviyeler , bool $kıpırtı )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resimdeki renkleri belli bir sayıya düşürür.

Değiştirgeler

seviyeler

Her kanalda izin verilen renk sayısı seviyeleri. Düşük değerler daha belirgin etkiler oluşturur.

kıpırtı

Sıfırdan farklı bir tamsayı.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::polaroidImage
Imagick::previewImages
Imagick sınıfı


Resim üzerinde yapılacak bir işlem için en uygun değiştirgenin tespitini hızlandırır

Imagick::posterizeImage
Imagick::previousImage
Imagick sınıfı
PHP Manual

Imagick::previewImages

(PECL imagick 2.0.0)

Imagick::previewImages — Resim üzerinde yapılacak bir işlem için en uygun değiştirgenin tespitini hızlandırır

Açıklama

bool Imagick::previewImages ( int $preview )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bir resim işlemini farklı derecelerde uygulayarak, resmin üretilmiş 9 küçük örneğini bir tuvale döşer. Resim üzerinde yapılacak bir işlem için en uygun değiştirgenin tespitinde çok işe yarar.

Değiştirgeler

önizleme

Önizleme türü sabitlerinden biri.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::posterizeImage
Imagick::previousImage
Imagick sınıfı


Bir önceki resme gider

Imagick::previewImages
Imagick::profileImage
Imagick sınıfı
PHP Manual

Imagick::previousImage

(PECL imagick 2.0.0)

Imagick::previousImage — Bir önceki resme gider

Açıklama

bool Imagick::previousImage ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resim listesindeki bir önceki resmi Imagick nesnesi ile ilişkilendirir.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::previewImages
Imagick::profileImage
Imagick sınıfı


Bir resme profil ekler veya çıkarır

Imagick::previousImage
Imagick::quantizeImage
Imagick sınıfı
PHP Manual

Imagick::profileImage

(PECL imagick 2.0.0)

Imagick::profileImage — Bir resme profil ekler veya çıkarır

Açıklama

bool Imagick::profileImage ( string $isim , string $profil )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resme bir ICC, IPTC veya soysal bir profil ekler veya olanı siler. Resimdeki tüm profilleri silmek için isim olarak '*', profil olarak NULL belirtin.

Değiştirgeler

isim

profil

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::previousImage
Imagick::quantizeImage
Imagick sınıfı


Belli bir resim içindeki renk miktarını bulur

Imagick::profileImage
Imagick::quantizeImages
Imagick sınıfı
PHP Manual

Imagick::quantizeImage

(PECL imagick 2.0.0)

Imagick::quantizeImage — Belli bir resim içindeki renk miktarını bulur

Açıklama

bool Imagick::quantizeImage ( int $renk_sayısı , int $renk_uzayı , int $ağaç_derinliği , bool $kıpırtı , bool $ölçme_hatası )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Belli bir resim içindeki renkleri inceleyip resmi ifade edebilecek sayıda renk seçer. Algoritmanın amacı, girdi ve çıktı resimleri arasındaki renk farkını en aza indirerek işlem zamanını kısaltmaktır.

Değiştirgeler

renk_sayısı

Renk sayısı

renk_uzayı

Renk azaltma bu renk uzayında yapılır.

ağaç_derinliği

Normalde sıfır ya da bir olup, bu takdirde renk sayısına en uygun ağaç seçilir. Ağaç derinliği, en az bellek harcayarak en yüksek işlem hızında resmin en iyi nasıl ifade edilececeğini belirler. Renk ağacını tam boyutuna genişletmek için 8 kullanın.

kıpırtı

Sıfırdan büyük bir değer komşu pikseller arasındaki farkı dağıtır.

ölçme_hatası

Özgün resimle işlem görmüş resim arasındaki farkın ölçüsü olarak sıfırdan farklı bir tamsayı.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::profileImage
Imagick::quantizeImages
Imagick sınıfı


Bir resim kümesi içindeki renk miktarını bulur

Imagick::quantizeImage
Imagick::queryFontMetrics
Imagick sınıfı
PHP Manual

Imagick::quantizeImages

(PECL imagick 2.0.0)

Imagick::quantizeImages — Bir resim kümesi içindeki renk miktarını bulur

Açıklama

bool Imagick::quantizeImages ( int $renk_sayısı , int $renk_uzayı , int $ağaç_derinliği , bool $kıpırtı , bool $ölçme_hatası )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bir resim kümesi içindeki renkleri inceleyip resmi ifade edebilecek sayıda renk seçer. Algoritmanın amacı, girdi ve çıktı resimleri arasındaki renk farkını en aza indirerek işlem zamanını kısaltmaktır.

Değiştirgeler

renk_sayısı

Renk sayısı.

renk_uzayı

Renk azaltma bu renk uzayında yapılır.

ağaç_derinliği

Normalde sıfır ya da bir olup, bu takdirde renk sayısına en uygun ağaç seçilir. Ağaç derinliği, en az bellek harcayarak en yüksek işlem hızında resmin en iyi nasıl ifade edilececeğini belirler. Renk ağacını tam boyutuna genişletmek için 8 kullanın.

kıpırtı

Sıfırdan büyük bir değer komşu pikseller arasındaki farkı dağıtır.

ölçme_hatası

Özgün resimlerle işlem görmüş resimler arasındaki farkın ölçüsü olarak sıfırdan farklı bir tamsayı.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::quantizeImage
Imagick::queryFontMetrics
Imagick sınıfı


Yazı tipinin özelliklerini içeren bir dizi döndürür

Imagick::quantizeImages
Imagick::queryFonts
Imagick sınıfı
PHP Manual

Imagick::queryFontMetrics

(PECL imagick 2.0.0)

Imagick::queryFontMetrics — Yazı tipinin özelliklerini içeren bir dizi döndürür

Açıklama

array Imagick::queryFontMetrics ( ImagickDraw $nesne , string $metin [, bool $çoksatırlı ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Yazı tipi özelliklerini içeren çok boyutlu bir dizi döndürür.

Değiştirgeler

nesne

Yazı tipi özelliklerine bakılacak ImagickDraw nesnesi.

metin

Metin dizgesi.

çoksatırlı

Boş bırakılırsa çok satırlılık özdevinimli olarak saptanır.

Dönen Değerler

Yazı tipi özelliklerini içeren çok boyutlu bir dizi. Hata durumunda bir ImagickException istisnası oluşur.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Örnekler

Örnek 1 - Imagick::queryFontMetrics() örneği

Metni çizmek için kullanılan yazı tipinin özelliklerini sorgular ve sonuçları ekrana döker.

<?php
/* Yeni bir Imagick nesnesi oluşturalım */
$im = new Imagick();

/* Bir ImagickDraw nesnesi oluşturalım */
$draw = new ImagickDraw();

/* Yazı tipini tanımlayalım */
$draw->setFont('/path/to/font.ttf');

/* Çok satırlılığı algılatarak yazı tipinin özelliklerini dökelim */
var_dump($im->queryFontMetrics($draw, "Hello World!"));
?>

Imagick::quantizeImages
Imagick::queryFonts
Imagick sınıfı


Yapılandırımış yazı tiplerini döndürür

Imagick::queryFontMetrics
Imagick::queryFormats
Imagick sınıfı
PHP Manual

Imagick::queryFonts

(PECL imagick 2.0.0)

Imagick::queryFonts — Yapılandırımış yazı tiplerini döndürür

Açıklama

array Imagick::queryFonts ([ string $şablon = "*" ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Imagick tarafından desteklenen yazı tiplerini döndürür.

Değiştirgeler

şablon

Sorgu şablonu.

Dönen Değerler

Yapılandırımış yazı tiplerini içeren bir dizi döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::queryFontMetrics
Imagick::queryFormats
Imagick sınıfı


Imagick tarafından desteklenen biçemleri döndürür

Imagick::queryFonts
Imagick::radialBlurImage
Imagick sınıfı
PHP Manual

Imagick::queryFormats

(PECL imagick 2.0.0)

Imagick::queryFormats — Imagick tarafından desteklenen biçemleri döndürür

Açıklama

array Imagick::queryFormats ([ string $şablon = "*" ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Imagick tarafından desteklenen biçemleri döndürür.

Değiştirgeler

şablon

Dönen Değerler

Imagick tarafından desteklenen biçemleri içeren bir dizi döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::queryFonts
Imagick::radialBlurImage
Imagick sınıfı


Bir resme dairesel bulanıklık uygular

Imagick::queryFormats
Imagick::raiseImage
Imagick sınıfı
PHP Manual

Imagick::radialBlurImage

(PECL imagick 2.0.0)

Imagick::radialBlurImage — Bir resme dairesel bulanıklık uygular

Açıklama

bool Imagick::radialBlurImage ( float $açı [, int $kanal = Imagick::CHANNEL_ALL ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bir resme dairesel bulanıklık uygular.

Değiştirgeler

açı

Bulanıklık açısı.

kanal

Normalde kanal türü sabitlerinden biri, ancak bitsel işleçler kullanılarak birden fazla kanal belirtilebilir. Imagick::CHANNEL_ALL öntanımlıdır. Bu değiştirge, sadece, derleme sırasında ImageMagick

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::queryFormats
Imagick::raiseImage
Imagick sınıfı


3 boyutlu düğme benzeri bir etki oluşturur

Imagick::radialBlurImage
Imagick::randomThresholdImage
Imagick sınıfı
PHP Manual

Imagick::raiseImage

(PECL imagick 2.0.0)

Imagick::raiseImage — 3 boyutlu düğme benzeri bir etki oluşturur

Açıklama

bool Imagick::raiseImage ( int $genişlik , int $yükseklik , int $x , int $y , bool $çıkıntı )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin kenarlarını karartarak ve aydınlatarak üç boyutlu düğme benzeri bir etki oluşturur.

Değiştirgeler

genişlik

Çıkıntı genişliği.

yükseklik

Çıkıntı yüksekliği.

x

y

çıkıntı

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::radialBlurImage
Imagick::randomThresholdImage
Imagick sınıfı


Yüksek zıtlığa sahip iki renkli bir resim oluşturur

Imagick::raiseImage
Imagick::readImage
Imagick sınıfı
PHP Manual

Imagick::randomThresholdImage

(PECL imagick 2.0.0)

Imagick::randomThresholdImage — Yüksek zıtlığa sahip iki renkli bir resim oluşturur

Açıklama

bool Imagick::randomThresholdImage ( float $düşük , float $yüksek [, int $kanal = Imagick::CHANNEL_ALL ] )

Piksel değerlerini tek tek belirtilen eşiğe uygun olarak değiştirir. Elde edilen resim, iki renkli yüksek zıtlığa sahip bir resim olur. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.2.9 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

düşük

Düşük nokta.

yüksek

Yüksek nokta.

kanal

Kanal kipi için geçerli herhangi bir kanal sabiti. Birden fazla kanal belirtmek isterseniz kanal sabitlerini bitsel işleçleri kullanarak birleştirebilirsiniz.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::raiseImage
Imagick::readImage
Imagick sınıfı


Resmi dosyadar okur

Imagick::randomThresholdImage
Imagick::readImageBlob
Imagick sınıfı
PHP Manual

Imagick::readImage

(PECL imagick 0.9.0-0.9.9)

Imagick::readImage — Resmi dosyadar okur

Açıklama

bool Imagick::readImage ( string $dosya )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmi belirtilen dosyadan okur.

Değiştirgeler

dosya

Dosya yolu.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::randomThresholdImage
Imagick::readImageBlob
Imagick sınıfı


Resmi ikil bir dizgeden okur

Imagick::readImage
Imagick::readImageFile
Imagick sınıfı
PHP Manual

Imagick::readImageBlob

(PECL imagick 2.0.0)

Imagick::readImageBlob — Resmi ikil bir dizgeden okur

Açıklama

bool Imagick::readImageBlob ( string $dizge [, string $dosya ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmi belirtilen ikil dizgeden okur.

Değiştirgeler

dizge

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::readImage
Imagick::readImageFile
Imagick sınıfı


Resmi akımdan okur

Imagick::readImageBlob
Imagick::readimages
Imagick sınıfı
PHP Manual

Imagick::readImageFile

(PECL imagick 2.0.0)

Imagick::readImageFile — Resmi akımdan okur

Açıklama

bool Imagick::readImageFile ( resource $dt [, string $dosya ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmi belirtilen dosya tanıtıcısından okur.

Değiştirgeler

dt

Dosya tanıtıcısı.

dosya

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::readImageBlob
Imagick::readimages
Imagick sınıfı


Description

Imagick::readImageFile
Imagick::recolorImage
Imagick sınıfı
PHP Manual

Imagick::readimages

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::readimages — Description

Açıklama

public Imagick Imagick::readImages ( string $filenames )

Reads image from an array of filenames. All the images are held in a single Imagick object.

Değiştirgeler

filenames

Dönen Değerler

The Imagick object that contains all the images.

Imagick::readImageFile
Imagick::recolorImage
Imagick sınıfı


Resmi yeniden renklendirir

Imagick::readimages
Imagick::reduceNoiseImage
Imagick sınıfı
PHP Manual

Imagick::recolorImage

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::recolorImage — Resmi yeniden renklendirir

Açıklama

bool Imagick::animateImages ( array $matris )

Resim renklerini döndürür, oranlar, keser, dönüştürür. Her boyda matris desteklense de normalde RGBA için 5x5, CMYK için 6x6 matris kullanılır. Son satırın normalleştirilmiş değerleri içermesi gerekir. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.3.6 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

matris

Renk değerlerini içeren matris.

Dönen Değerler

Başarı durumunda TRUE döner.

Ayrıca Bakınız

  • Imagick::displayImage() - Bir resmi gösterir

Imagick::readimages
Imagick::reduceNoiseImage
Imagick sınıfı


Bir resmin dış hatlarını yumuşatır

Imagick::recolorImage
Imagick::remapImage
Imagick sınıfı
PHP Manual

Imagick::reduceNoiseImage

(PECL imagick 2.0.0)

Imagick::reduceNoiseImage — Bir resmin dış hatlarını yumuşatır

Açıklama

bool Imagick::reduceNoiseImage ( float $yarıçap )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bir resmin dış hatlarını kenar bilgisini koruyarak yumuşatır. Algoritma, her pikselin rengini komşu pikselin rengine en yakın renkle değiştirerek çalışır. Komşuluk yarıçap ile belirlenir.

Değiştirgeler

yarıçap

0 belirtilirse yöntem uygun bir yarıçap seçecektir.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::recolorImage
Imagick::remapImage
Imagick sınıfı


Remaps image colors

Imagick::reduceNoiseImage
Imagick::removeImage
Imagick sınıfı
PHP Manual

Imagick::remapImage

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::remapImage — Remaps image colors

Açıklama

public bool Imagick::remapImage ( Imagick $replacement , int $DITHER )

Replaces colors an image with those defined by replacement. The colors are replaced with the closest possible color. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.4.5 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

replacement

An Imagick object containing the replacement colors

DITHER

Refer to this list of dither method constants

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::reduceNoiseImage
Imagick::removeImage
Imagick sınıfı


Resim kümesinden bir resim siler

Imagick::remapImage
Imagick::removeImageProfile
Imagick sınıfı
PHP Manual

Imagick::removeImage

(PECL imagick 2.0.0)

Imagick::removeImage — Resim kümesinden bir resim siler

Açıklama

bool Imagick::removeImage ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resim kümesinden bir resim siler.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::remapImage
Imagick::removeImageProfile
Imagick sınıfı


İsimli resim profilini silip döndürür

Imagick::removeImage
Imagick::render
Imagick sınıfı
PHP Manual

Imagick::removeImageProfile

(PECL imagick 2.0.0)

Imagick::removeImageProfile — İsimli resim profilini silip döndürür

Açıklama

string Imagick::removeImageProfile ( string $isim )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

İsimli resim profilini silip döndürür.

Değiştirgeler

isim

Dönen Değerler

Resmin profilini bir dizge olarak döndürür. Hata durumunda bir ImagickException istisnası oluşur.

Imagick::removeImage
Imagick::render
Imagick sınıfı


Evvelce verilmiş tüm çizim komutlarını uygular

Imagick::removeImageProfile
Imagick::resampleImage
Imagick sınıfı
PHP Manual

Imagick::render

(PECL imagick 2.0.0)

Imagick::render — Evvelce verilmiş tüm çizim komutlarını uygular

Açıklama

bool Imagick::render ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Evvelce verilmiş tüm çizim komutlarını uygular.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::removeImageProfile
Imagick::resampleImage
Imagick sınıfı


Belirtilen çözünürlüğe göre resmi yeniden örnekler

Imagick::render
Imagick::resetImagePage
Imagick sınıfı
PHP Manual

Imagick::resampleImage

(PECL imagick 2.0.0)

Imagick::resampleImage — Belirtilen çözünürlüğe göre resmi yeniden örnekler

Açıklama

bool Imagick::resampleImage ( float $x_çözünürlüğü , float $y_çözünürlüğü , int $süzgeç , float $bulanıklık )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Belirtilen çözünürlüğe göre resmi yeniden örnekler.

Değiştirgeler

x_çözünürlüğü

y_çözünürlüğü

süzgeç

bulanıklık

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::render
Imagick::resetImagePage
Imagick sınıfı


Resim sayfasını sıfırlar

Imagick::resampleImage
Imagick::resizeImage
Imagick sınıfı
PHP Manual

Imagick::resetImagePage

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::resetImagePage — Resim sayfasını sıfırlar

Açıklama

bool Imagick::resetImagePage ( string $sayfa )

Sayfa tanımlama biçemi: GxY+x+y. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.3.6 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

sayfa

Bir dizge olarak sayfa tanımı. Örnek: 7168x5147+0+0

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::resampleImage
Imagick::resizeImage
Imagick sınıfı


Bir resmi boyutlandırır

Imagick::resetImagePage
Imagick::rollImage
Imagick sınıfı
PHP Manual

Imagick::resizeImage

(PECL imagick 2.0.0)

Imagick::resizeImage — Bir resmi boyutlandırır

Açıklama

bool Imagick::resizeImage ( int $genişlik , int $yükseklik , int $süzgeç , float $bulanıklık [, bool $sığdır = false ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bir süzgeç kullanarak resmi boyutlarını belirtildiği gibi değiştirir.

Bilginize: sığdır değiştirgesinin davranışı Imagick 3.0.0 sürümünde değişmiştir. Evvelce 200x150 ebadındaki bir resim 400x400 ebadındaki bir alana sığdırılmak istendiğinde bu yapılmazdı. Artık resim 400x300 ebadına getirilerek belirtilen alana sığdırılmaktadır. sığdır değiştirgesi kullanıldığı takdirde yükseklik ve genişliğin ikisi de verilmelidir.

Değiştirgeler

genişlik

Resmin genişliği.

yükseklik

Resmin yüksekliği.

süzgeç

Süzgeç sabitlerinden biri.

bulanıklık

Birden büyük değerler bulanıklığı, küçük değerler netliği arttırır.

fit

Boyutlara sığdırmayı zorlayan seçimlik değiştirge.

Dönen Değerler

Başarı durumunda TRUE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
2.1.0 | Seçimlik sığdır değiştirgesi eklendi. Yöntem artık sadece yükseklik veya genişlik vererek oranlamayı da destekliyor. Hesaplanacak boyut için değiştirgeye 0 belirtmek gerekiyor.

Imagick::resetImagePage
Imagick::rollImage
Imagick sınıfı


Bir resmin başlangıç noktasını tanımlar

Imagick::resizeImage
Imagick::rotateImage
Imagick sınıfı
PHP Manual

Imagick::rollImage

(PECL imagick 2.0.0)

Imagick::rollImage — Bir resmin başlangıç noktasını tanımlar

Açıklama

bool Imagick::rollImage ( int $x , int $y )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bir resmin başlangıç noktasını tanımlar.

Değiştirgeler

x

Noktanın X konumu.

y

Noktanın Y konumu.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::resizeImage
Imagick::rotateImage
Imagick sınıfı


Resmi döndürür

Imagick::rollImage
Imagick::rotationalBlurImage
Imagick sınıfı
PHP Manual

Imagick::rotateImage

(PECL imagick 2.0.0)

Imagick::rotateImage — Resmi döndürür

Açıklama

bool Imagick::rotateImage ( mixed $artalan , float $açı )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmi belirtilen açıya göre döndürür. Resmin döndürülmesiyle boşalan üçgenler artalan rengiyle doldurulur.

Değiştirgeler

artalan

Artalan rengi.

açı

Derece cinsinden resmin dönme açısı.

Dönen Değerler

Başarı durumunda TRUE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
2.1.0 | Artık renk olarak rengi ifade eden bir dizge belirtilebiliyor. Evvelce sadece bir ImagickPixel nesnesi belirtilebiliyordu.

Imagick::rollImage
Imagick::rotationalBlurImage
Imagick sınıfı


Description

Imagick::rotateImage
Imagick::roundCorners
Imagick sınıfı
PHP Manual

Imagick::rotationalBlurImage

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::rotationalBlurImage — Description

Açıklama

public void Imagick::rotationalBlurImage ( string $angle [, string $CHANNEL = Imagick::CHANNEL_DEFAULT ] )

Rotational blurs an image.

Değiştirgeler

angle

The angle to apply the blur over.

CHANNEL

Normalde kanal türü sabitlerinden biridir, ancak bitsel işleçler kullanılarak birden fazla kanal belirtilebilir. Imagick::CHANNEL_DEFAULT öntanımlıdır.

Dönen Değerler

Örnekler

Örnek 1 Imagick::rotationalBlurImage()

<?php
function rotationalBlurImage($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->rotationalBlurImage(3);
    $imagick->rotationalBlurImage(5);
    $imagick->rotationalBlurImage(7);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>

Imagick::rotateImage
Imagick::roundCorners
Imagick sınıfı


Resmin köşelerini yuvarlatır

Imagick::rotationalBlurImage
Imagick::sampleImage
Imagick sınıfı
PHP Manual

Imagick::roundCorners

(PECL imagick 2.0.0)

Imagick::roundCorners — Resmin köşelerini yuvarlatır

Açıklama

bool Imagick::roundCorners ( float $x_yarıçapı , float $y_yarıçapı [, float $vurgu_genişliği = 10 [, float $yer_değiştirme = 5 [, float $boyut_düzeltme = -6 ]]] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin köşelerini yuvarlatır. İlk iki değiştirge yuvarlatma miktarını belirlerken, son üç değiştirge ise yuvarlatma işleminin hassas ayarı için kullanılır. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.2.9 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

x_yarıçapı

X yarıçapı.

y_yarıçapı

Y yarıçapı.

vurgu_genişliği

Vurgu genişliği

yer_değiştirme

Yer değiştirme miktarı.

boyut_düzeltme

Boyut düzeltme miktarı.

Dönen Değerler

Başarı durumunda TRUE döner.

Örnekler

Örnek 1 - Imagick::roundCorners() örneği

<?php

$image = new Imagick();
$image->newPseudoImage(100, 100, "magick:rose");
$image->setImageFormat("png");

$image->roundCorners(5,3);
$image->writeImage("rounded.png");
?>

Imagick::rotationalBlurImage
Imagick::sampleImage
Imagick sınıfı


Resmi piksel örneklemeyle oranlar

Imagick::roundCorners
Imagick::scaleImage
Imagick sınıfı
PHP Manual

Imagick::sampleImage

(PECL imagick 2.0.0)

Imagick::sampleImage — Resmi piksel örneklemeyle oranlar

Açıklama

bool Imagick::sampleImage ( int $genişlik , int $yükseklik )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmi piksel örnekleme yöntemiyle istenen boyutlara ayarlar. Diğer oranlama yöntemlerinin tersine bu yöntem resme fazladan renk eklemez.

Değiştirgeler

genişlik

yükseklik

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::roundCorners
Imagick::scaleImage
Imagick sınıfı


Bir resmin enboy oranını ayarlar

Imagick::sampleImage
Imagick::segmentImage
Imagick sınıfı
PHP Manual

Imagick::scaleImage

(PECL imagick 2.0.0)

Imagick::scaleImage — Bir resmin enboy oranını ayarlar

Açıklama

bool Imagick::scaleImage ( int $genişlik , int $yükseklik [, bool $sığdır = false ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin boyutlarını belirtilen değerlere ayarlar. 0 olarak belirtilen değiştirge resmin enboy oranı hesaba katılarak diğer değiştirgeye göre hesaplanır.

Bilginize: sığdır değiştirgesinin davranışı Imagick 3.0.0 sürümünde değişmiştir. Evvelce 200x150 ebadındaki bir resim 400x400 ebadındaki bir alana sığdırılmak istendiğinde bu yapılmazdı. Artık resim 400x300 ebadına getirilerek belirtilen alana sığdırılmaktadır. sığdır değiştirgesi kullanıldığı takdirde yükseklik ve genişliğin ikisi de verilmelidir.

Değiştirgeler

genişlik

yükseklik

sığdır

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Sürüm Bilgisi

Sürüm: | Açıklama
2.1.0 | Seçimlik sığdır değiştirgesi eklendi. Yöntem artık sadece yükseklik veya genişlik vererek oranlamayı da destekliyor. Hesaplanacak boyut için değiştirgeye 0 belirtmek gerekiyor.

Imagick::sampleImage
Imagick::segmentImage
Imagick sınıfı


Segments an image

Imagick::scaleImage
Imagick::selectiveBlurImage
Imagick sınıfı
PHP Manual

Imagick::segmentImage

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::segmentImage — Segments an image

Açıklama

public bool Imagick::segmentImage ( int $COLORSPACE , float $cluster_threshold , float $smooth_threshold [, bool $verbose = false ] )

Analyses the image and identifies units that are similar. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.4.5 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

COLORSPACE

One of the COLORSPACE constants.

cluster_threshold

A percentage describing minimum number of pixels contained in hexedra before it is considered valid.

smooth_threshold

Eliminates noise from the histogram.

verbose

Whether to output detailed information about recognised classes.

Dönen Değerler

Örnekler

Örnek 1 Imagick::segmentImage()

<?php
function segmentImage($imagePath, $colorSpace, $clusterThreshold, $smoothThreshold) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->segmentImage($colorSpace, $clusterThreshold, $smoothThreshold);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

segmentImage($imagePath, \Imagick::COLORSPACE_RGB, 5, 5);

?>

Imagick::scaleImage
Imagick::selectiveBlurImage
Imagick sınıfı


Description

Imagick::segmentImage
Imagick::separateImageChannel
Imagick sınıfı
PHP Manual

Imagick::selectiveBlurImage

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::selectiveBlurImage — Description

Açıklama

public void Imagick::selectiveBlurImage ( float $radius , float $sigma , float $threshold , int $CHANNEL )

Selectively blur an image within a contrast threshold. It is similar to the unsharpen mask that sharpens everything with contrast above a certain threshold.

Değiştirgeler

radius

sigma

threshold

CHANNEL

Normalde kanal türü sabitlerinden biridir, ancak bitsel işleçler kullanılarak birden fazla kanal belirtilebilir. Imagick::CHANNEL_DEFAULT öntanımlıdır.

Dönen Değerler

Örnekler

Örnek 1 Imagick::selectiveBlurImage()

<?php
function selectiveBlurImage($imagePath, $radius, $sigma, $threshold, $channel) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->selectiveBlurImage($radius, $sigma, $threshold, $channel);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>

Imagick::segmentImage
Imagick::separateImageChannel
Imagick sınıfı


Resimden bir kanalı ayırır

Imagick::selectiveBlurImage
Imagick::sepiaToneImage
Imagick sınıfı
PHP Manual

Imagick::separateImageChannel

(PECL imagick 2.0.0)

Imagick::separateImageChannel — Resimden bir kanalı ayırır

Açıklama

bool Imagick::separateImageChannel ( int $kanal )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resimden bir kanalı ayırır.

Değiştirgeler

kanal

Resimdeki her pikselin belli bir renk bileşeni.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::selectiveBlurImage
Imagick::sepiaToneImage
Imagick sınıfı


Resme kızıl kahverengi tonlama uygular

Imagick::separateImageChannel
Imagick::setBackgroundColor
Imagick sınıfı
PHP Manual

Imagick::sepiaToneImage

(PECL imagick 2.0.0)

Imagick::sepiaToneImage — Resme kızıl kahverengi tonlama uygular

Açıklama

bool Imagick::sepiaToneImage ( float $eşik )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resme karanlık odada uygulanan kızıl kahverengi tonlamaya benzer özel bir etki uygular.

Değiştirgeler

threshold

0 ile parçacık aralığı (QuantumRange) arasında bir değer olarak belirtilir. Makul bir tonlama için 80 iyi bir başlangıç noktasıdır.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::separateImageChannel
Imagick::setBackgroundColor
Imagick sınıfı


Nesnenin öntanımlı artalan rengini tanımlar

Imagick::sepiaToneImage
Imagick::setColorspace
Imagick sınıfı
PHP Manual

Imagick::setBackgroundColor

(PECL imagick 2.0.0)

Imagick::setBackgroundColor — Nesnenin öntanımlı artalan rengini tanımlar

Açıklama

bool Imagick::setBackgroundColor ( mixed $renk )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Nesnenin öntanımlı artalan rengini tanımlar.

Değiştirgeler

renk

Dönen Değerler

Başarı durumunda TRUE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
2.1.0 | Artık renk olarak rengi ifade eden bir dizge belirtilebiliyor. Evvelce sadece bir ImagickPixel nesnesi belirtilebiliyordu.

Imagick::sepiaToneImage
Imagick::setColorspace
Imagick sınıfı


Set colorspace

Imagick::setBackgroundColor
Imagick::setCompression
Imagick sınıfı
PHP Manual

Imagick::setColorspace

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::setColorspace — Set colorspace

Açıklama

bool Imagick::setColorspace ( int $COLORSPACE )

Sets the global colorspace value for the object. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.5.7 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

COLORSPACE

One of the COLORSPACE constants

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::setBackgroundColor
Imagick::setCompression
Imagick sınıfı


Nesnenin öntanımlı sıkıştırma türünü tanımlar

Imagick::setColorspace
Imagick::setCompressionQuality
Imagick sınıfı
PHP Manual

Imagick::setCompression

(PECL imagick 2.0.0)

Imagick::setCompression — Nesnenin öntanımlı sıkıştırma türünü tanımlar

Açıklama

bool Imagick::setCompression ( int $sıkıştırma )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Nesnenin öntanımlı sıkıştırma türünü tanımlar.

Değiştirgeler

sıkıştırma

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::setColorspace
Imagick::setCompressionQuality
Imagick sınıfı


Nesnenin öntanımlı sıkıştırma seviyesini tanımlar

Imagick::setCompression
Imagick::setFilename
Imagick sınıfı
PHP Manual

Imagick::setCompressionQuality

(PECL imagick 0.9.10-0.9.9)

Imagick::setCompressionQuality — Nesnenin öntanımlı sıkıştırma seviyesini tanımlar

Açıklama

bool Imagick::setCompressionQuality ( int $seviye )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Nesnenin öntanımlı sıkıştırma seviyesini tanımlar

Değiştirgeler

seviye

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::setCompression
Imagick::setFilename
Imagick sınıfı


Bir resim için dosya ismi tanımlar

Imagick::setCompressionQuality
Imagick::setFirstIterator
Imagick sınıfı
PHP Manual

Imagick::setFilename

(PECL imagick 2.0.0)

Imagick::setFilename — Bir resim için dosya ismi tanımlar

Açıklama

bool Imagick::setFilename ( string $dosya )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bir resim dosyasını okumak veya yazmak dosya ismi tanımlar.

Değiştirgeler

dosya

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::setCompressionQuality
Imagick::setFirstIterator
Imagick sınıfı


Imagick yineleyiciyi ilk resme konumlar

Imagick::setFilename
Imagick::setFont
Imagick sınıfı
PHP Manual

Imagick::setFirstIterator

(PECL imagick 2.0.0)

Imagick::setFirstIterator — Imagick yineleyiciyi ilk resme konumlar

Açıklama

bool Imagick::setFirstIterator ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Imagick yineleyiciyi ilk resme konumlar.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::setFilename
Imagick::setFont
Imagick sınıfı


Imagick nesnesinin yazı tipini tanımlar

Imagick::setFirstIterator
Imagick::setFormat
Imagick sınıfı
PHP Manual

Imagick::setFont

(PECL imagick 2.1.0)

Imagick::setFont — Imagick nesnesinin yazı tipini tanımlar

Açıklama

bool Imagick::setFont ( string $yazıtipi )

Imagick nesnesinin yazı tipini tanımlar. Bu yöntemle pseudo-format gibi bir başlık yazı tipi belirtilebilir. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.3.6-4 veya sonraki bir sürümü kuruluysa kullanılabilir. Yazı tipinin ImageMagick yapılandırmasına dahil edilmiş olması ve yazıtipi dosyasının mevcut olması gerekir. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.3.7 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

yazıtipi

Yazı tipi ismi veya yazı tipi dosyasının ismi.

Dönen Değerler

Başarı durumunda TRUE döner.

Örnekler

Örnek 1 - Imagick::setFont() örneği

<?php
/* Bir imagick nesnesi oluşturalım */
$im = new Imagick();

/* Nesneye bir yazı tipi atayalım */
$im->setFont("example.ttf");

/* Yeni bir başlık oluşturalım */
$im->newPseudoImage(100, 100, "caption:Hello");

/* Resim üzerinde başka işlemler yapalım */
?>

Ayrıca Bakınız

  • Imagick::getFont() - Yazıtipini döndürür
  • ImagickDraw::setFont() - Metni çizerken kullanılacak yazı tipini tam belirtimiyle belirler
  • ImagickDraw::getFont() - Geçerli yazı tipini döndürür

Imagick::setFirstIterator
Imagick::setFormat
Imagick sınıfı


Imagick nesnesinin biçemini tanımlar

Imagick::setFont
Imagick::setGravity
Imagick sınıfı
PHP Manual

Imagick::setFormat

(PECL imagick 2.0.0)

Imagick::setFormat — Imagick nesnesinin biçemini tanımlar

Açıklama

bool Imagick::setFormat ( string $biçem )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Imagick nesnesinin biçemini tanımlar.

Değiştirgeler

biçem

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::setFont
Imagick::setGravity
Imagick sınıfı


Sets the gravity

Imagick::setFormat
Imagick::setImage
Imagick sınıfı
PHP Manual

Imagick::setGravity

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::setGravity — Sets the gravity

Açıklama

bool Imagick::setGravity ( int $gravity )

Sets the global gravity property for the Imagick object. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.4.0 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

gravity

The gravity property. Refer to the list of gravity constants.

Dönen Değerler

Hiçbir değer dönmez.

Imagick::setFormat
Imagick::setImage
Imagick sınıfı


Nesnedeki resmi değiştirir

Imagick::setGravity
Imagick::setImageAlphaChannel
Imagick sınıfı
PHP Manual

Imagick::setImage

(PECL imagick 2.0.0)

Imagick::setImage — Nesnedeki resmi değiştirir

Açıklama

bool Imagick::setImage ( Imagick $yenisi )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Geçerli resmi yenisi ile değiştirir.

Değiştirgeler

yenisi

Geçerli resmin yerine konacak resim.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Örnekler

Örnek 1 - Imagick::setImage() örneği

<?php
/* Nesneleri oluşturalım */
$eskisi = new Imagick('eski.jpg');
$yenisi = new Imagick('yeni.jpg');

/* Eskisinin yerine yenisini koyalım */
$eskisi->setImage($yenisi);

/* resmi çıktılayalım */
header('Content-type: image/jpeg');
echo $eskisi;

?>

Imagick::setGravity
Imagick::setImageAlphaChannel
Imagick sınıfı


Resmin şeffaflık kanalını tanımlar

Imagick::setImage
Imagick::setImageArtifact
Imagick sınıfı
PHP Manual

Imagick::setImageAlphaChannel

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::setImageAlphaChannel — Resmin şeffaflık kanalını tanımlar

Açıklama

bool Imagick::setImageAlphaChannel ( int $kip )

Resmin şeffaflık kanalını etkin veya etkisiz kılar. kip değiştirgesi Imagick::ALPHACHANNEL_* sabitlerinden biri olmalıdır. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.3.8 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

kip

Imagick::ALPHACHANNEL_* sabitlerinden biri olmalıdır.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Ayrıca Bakınız

  • Imagick::setImageMatte() - Resmin matlık kanalını ayarlar

Imagick::setImage
Imagick::setImageArtifact
Imagick sınıfı


Set image artifact

Imagick::setImageAlphaChannel
Imagick::setImageAttribute
Imagick sınıfı
PHP Manual

Imagick::setImageArtifact

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::setImageArtifact — Set image artifact

Açıklama

bool Imagick::setImageArtifact ( string $artifact , string $value )

Associates an artifact with the image. The difference between image properties and image artifacts is that properties are public and artifacts are private. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.5.7 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

artifact

The name of the artifact

value

The value of the artifact

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Ayrıca Bakınız

  • Imagick::getImageArtifact() - Get image artifact
  • Imagick::deleteImageArtifact() - Delete image artifact

Örnekler

Örnek 1 Imagick::setImageArtifact()

<?php
function setImageArtifact() {

    $src1 = new \Imagick(realpath("./images/artifact/source1.png"));
    $src2 = new \Imagick(realpath("./images/artifact/source2.png"));

    $src2->setImageVirtualPixelMethod(\Imagick::VIRTUALPIXELMETHOD_TRANSPARENT);
    $src2->setImageArtifact('compose:args', "1,0,-0.5,0.5");
    $src1->compositeImage($src2, Imagick::COMPOSITE_MATHEMATICS, 0, 0);

    $src1->setImageFormat('png');
    header("Content-Type: image/png");
    echo $src1->getImagesBlob();
}

?>

Imagick::setImageAlphaChannel
Imagick::setImageAttribute
Imagick sınıfı


Description

Imagick::setImageArtifact
Imagick::setImageBackgroundColor
Imagick sınıfı
PHP Manual

Imagick::setImageAttribute

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::setImageAttribute — Description

Açıklama

public void Imagick::setImageAttribute ( string $key , string $value )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

key

value

Dönen Değerler

Imagick::setImageArtifact
Imagick::setImageBackgroundColor
Imagick sınıfı


Resmin artalan rengini tanımlar

Imagick::setImageAttribute
Imagick::setImageBias
Imagick sınıfı
PHP Manual

Imagick::setImageBackgroundColor

(PECL imagick 2.0.0)

Imagick::setImageBackgroundColor — Resmin artalan rengini tanımlar

Açıklama

bool Imagick::setImageBackgroundColor ( mixed $renk )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin artalan rengini tanımlar

Değiştirgeler

renk

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Sürüm Bilgisi

Sürüm: | Açıklama
2.1.0 | Artık renk olarak rengi ifade eden bir dizge belirtilebiliyor. Evvelce sadece bir ImagickPixel nesnesi belirtilebiliyordu.

Imagick::setImageAttribute
Imagick::setImageBias
Imagick sınıfı


Bir resmi evriştirmekte kullanılan yöntem için resim sapmasını tanımlar

Imagick::setImageBackgroundColor
Imagick::setImageBiasQuantum
Imagick sınıfı
PHP Manual

Imagick::setImageBias

(PECL imagick 2.0.0)

Imagick::setImageBias — Bir resmi evriştirmekte kullanılan yöntem için resim sapmasını tanımlar

Açıklama

bool Imagick::setImageBias ( float $sapma )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bir resmi evriştirmekte kullanılan yöntem (Imagick::ConvolveImage gibi()) için resim sapmasını tanımlar.

Değiştirgeler

sapma

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::setImageBackgroundColor
Imagick::setImageBiasQuantum
Imagick sınıfı


Description

Imagick::setImageBias
Imagick::setImageBluePrimary
Imagick sınıfı
PHP Manual

Imagick::setImageBiasQuantum

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::setImageBiasQuantum — Description

Açıklama

public void Imagick::setImageBiasQuantum ( string $bias )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

bias

Dönen Değerler

Imagick::setImageBias
Imagick::setImageBluePrimary
Imagick sınıfı


Resmin renk bileşenlerinden birincil mavi noktasını tanımlar

Imagick::setImageBiasQuantum
Imagick::setImageBorderColor
Imagick sınıfı
PHP Manual

Imagick::setImageBluePrimary

(PECL imagick 2.0.0)

Imagick::setImageBluePrimary — Resmin renk bileşenlerinden birincil mavi noktasını tanımlar

Açıklama

bool Imagick::setImageBluePrimary ( float $x , float $y )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin renk bileşenlerinden birincil mavi noktasını tanımlar.

Değiştirgeler

x

y

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::setImageBiasQuantum
Imagick::setImageBorderColor
Imagick sınıfı


Resmin çerçeve rengini tanımlar

Imagick::setImageBluePrimary
Imagick::setImageChannelDepth
Imagick sınıfı
PHP Manual

Imagick::setImageBorderColor

(PECL imagick 2.0.0)

Imagick::setImageBorderColor — Resmin çerçeve rengini tanımlar

Açıklama

bool Imagick::setImageBorderColor ( mixed $renk )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin çerçeve rengini tanımlar.

Değiştirgeler

renk

Çerçeve rengi.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Sürüm Bilgisi

Sürüm: | Açıklama
2.1.0 | Artık renk olarak rengi ifade eden bir dizge belirtilebiliyor. Evvelce sadece bir ImagickPixel nesnesi belirtilebiliyordu.

Imagick::setImageBluePrimary
Imagick::setImageChannelDepth
Imagick sınıfı


Belli bir resim kanalının derinliğini tanımlar

Imagick::setImageBorderColor
Imagick::setImageClipMask
Imagick sınıfı
PHP Manual

Imagick::setImageChannelDepth

(PECL imagick 2.0.0)

Imagick::setImageChannelDepth — Belli bir resim kanalının derinliğini tanımlar

Açıklama

bool Imagick::setImageChannelDepth ( int $kanal , int $derinlik )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Belli bir resim kanalının derinliğini tanımlar.

Değiştirgeler

kanal

derinlik

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::setImageBorderColor
Imagick::setImageClipMask
Imagick sınıfı


Resim kırpma maskesini tanımlar

Imagick::setImageChannelDepth
Imagick::setImageColormapColor
Imagick sınıfı
PHP Manual

Imagick::setImageClipMask

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::setImageClipMask — Resim kırpma maskesini tanımlar

Açıklama

bool Imagick::setImageClipMask ( Imagick $kırpıcı_resim )

Resmin kırpma maskesi olarak başka bir nesneyi tanımlar. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.3.6 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

kırpıcı_resim

Kırpma maskesini içeren Imagick nesnesi.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::setImageChannelDepth
Imagick::setImageColormapColor
Imagick sınıfı


Renk eşlemi indisi belirtilen rengi tanımlar

Imagick::setImageClipMask
Imagick::setImageColorspace
Imagick sınıfı
PHP Manual

Imagick::setImageColormapColor

(PECL imagick 2.0.0)

Imagick::setImageColormapColor — Renk eşlemi indisi belirtilen rengi tanımlar

Açıklama

bool Imagick::setImageColormapColor ( int $indis , ImagickPixel $renk )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Renk eşlemi indisi belirtilen rengi tanımlar.

Değiştirgeler

indis

renk

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::setImageClipMask
Imagick::setImageColorspace
Imagick sınıfı


Resmin renk uzayını tanımlar

Imagick::setImageColormapColor
Imagick::setImageCompose
Imagick sınıfı
PHP Manual

Imagick::setImageColorspace

(PECL imagick 2.0.0)

Imagick::setImageColorspace — Resmin renk uzayını tanımlar

Açıklama

bool Imagick::setImageColorspace ( int $renk_uzayı )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin renk uzayını tanımlar.

Değiştirgeler

renk_uzayı

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::setImageColormapColor
Imagick::setImageCompose
Imagick sınıfı


Resim birleştirme işlecini tanımlar

Imagick::setImageColorspace
Imagick::setImageCompression
Imagick sınıfı
PHP Manual

Imagick::setImageCompose

(PECL imagick 2.0.0)

Imagick::setImageCompose — Resim birleştirme işlecini tanımlar

Açıklama

bool Imagick::setImageCompose ( int $işleç )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resim birleştirme işlecini tanımlar. Imagick::montageImage() yöntemi kullanılırken resmin küçük örneğinin nasıl oluşturulacağını belirlemek için yararlıdır.

Değiştirgeler

işleç

Birleşterme işleci sabitlerinden biri.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::setImageColorspace
Imagick::setImageCompression
Imagick sınıfı


Resim sıkıştırma seviyesini tanımlar

Imagick::setImageCompose
Imagick::setImageCompressionQuality
Imagick sınıfı
PHP Manual

Imagick::setImageCompression

(PECL imagick 2.0.0)

Imagick::setImageCompression — Resim sıkıştırma seviyesini tanımlar

Açıklama

bool Imagick::setImageCompression ( int $sıkıştırma )

Resim sıkıştırma seviyesini tanımlar.

Değiştirgeler

sıkıştırma

Sıkıştırma sabitlerinden biri.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::setImageCompose
Imagick::setImageCompressionQuality
Imagick sınıfı


Resim sıkıştırma seviyesini belirler

Imagick::setImageCompression
Imagick::setImageDelay
Imagick sınıfı
PHP Manual

Imagick::setImageCompressionQuality

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::setImageCompressionQuality — Resim sıkıştırma seviyesini belirler

Açıklama

bool Imagick::setImageCompressionQuality ( int $seviye )

Rismin sıkıştırma seviyesini belirler.

Değiştirgeler

seviye

Tamsayı olarak sıkıştırma seviyesi.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::setImageCompression
Imagick::setImageDelay
Imagick sınıfı


Resim gecikmesini tanımlar

Imagick::setImageCompressionQuality
Imagick::setImageDepth
Imagick sınıfı
PHP Manual

Imagick::setImageDelay

(PECL imagick 2.0.0)

Imagick::setImageDelay — Resim gecikmesini tanımlar

Açıklama

bool Imagick::setImageDelay ( int $gecikme )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resim gecikmesini tanımlar.

Değiştirgeler

gecikme

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::setImageCompressionQuality
Imagick::setImageDepth
Imagick sınıfı


Resim derinliğini tanımlar

Imagick::setImageDelay
Imagick::setImageDispose
Imagick sınıfı
PHP Manual

Imagick::setImageDepth

(PECL imagick 2.0.0)

Imagick::setImageDepth — Resim derinliğini tanımlar

Açıklama

bool Imagick::setImageDepth ( int $derinlik )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resim derinliğini tanımlar.

Değiştirgeler

derinlik

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::setImageDelay
Imagick::setImageDispose
Imagick sınıfı


Resmin elden çıkarma yöntemini tanımlar

Imagick::setImageDepth
Imagick::setImageExtent
Imagick sınıfı
PHP Manual

Imagick::setImageDispose

(PECL imagick 2.0.0)

Imagick::setImageDispose — Resmin elden çıkarma yöntemini tanımlar

Açıklama

bool Imagick::setImageDispose ( int $yöntem )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin elden çıkarma yöntemini tanımlar.

Değiştirgeler

yöntem

Elden çıkarma türü sabitlerinden biri

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::setImageDepth
Imagick::setImageExtent
Imagick sınıfı


Resmin boyutlarını tanımlar

Imagick::setImageDispose
Imagick::setImageFilename
Imagick sınıfı
PHP Manual

Imagick::setImageExtent

(PECL imagick 2.0.0)

Imagick::setImageExtent — Resmin boyutlarını tanımlar

Açıklama

bool Imagick::setImageExtent ( int $genişlik , int $yükseklik )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin boyutlarını genişlik ve yükseklik olarak tanımlar.

Değiştirgeler

genişlik

yükseklik

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::setImageDispose
Imagick::setImageFilename
Imagick sınıfı


Belli bir resmin dosya ismini tanımlar

Imagick::setImageExtent
Imagick::setImageFormat
Imagick sınıfı
PHP Manual

Imagick::setImageFilename

(PECL imagick 2.0.0)

Imagick::setImageFilename — Belli bir resmin dosya ismini tanımlar

Açıklama

bool Imagick::setImageFilename ( string $dosya )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bir resim silsilesi içinde belli bir resmin dosya ismini tanımlar.

Değiştirgeler

dosya

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::setImageExtent
Imagick::setImageFormat
Imagick sınıfı


Belli bir resmin biçemini tanımlar

Imagick::setImageFilename
Imagick::setImageGamma
Imagick sınıfı
PHP Manual

Imagick::setImageFormat

(PECL imagick 2.0.0)

Imagick::setImageFormat — Belli bir resmin biçemini tanımlar

Açıklama

bool Imagick::setImageFormat ( string $biçem )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bir resim silsilesi içinde belli bir resmin biçemini tanımlar.

Değiştirgeler

biçem

Resim biçeminin dizgesel gösterimi. Desteklenen biçimler ImageMagick kurulumuna bağlıdır.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::setImageFilename
Imagick::setImageGamma
Imagick sınıfı


Resmin gammasını tanımlar

Imagick::setImageFormat
Imagick::setImageGravity
Imagick sınıfı
PHP Manual

Imagick::setImageGamma

(PECL imagick 2.0.0)

Imagick::setImageGamma — Resmin gammasını tanımlar

Açıklama

bool Imagick::setImageGamma ( float $gamma )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin gammasını tanımlar.

Değiştirgeler

gamma

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::setImageFormat
Imagick::setImageGravity
Imagick sınıfı


Sets the image gravity

Imagick::setImageGamma
Imagick::setImageGreenPrimary
Imagick sınıfı
PHP Manual

Imagick::setImageGravity

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::setImageGravity — Sets the image gravity

Açıklama

bool Imagick::setImageGravity ( int $gravity )

Sets the gravity property for the current image. This method can be used to set the gravity property for a single image sequence. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.4.4 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

gravity

The gravity property. Refer to the list of gravity constants.

Dönen Değerler

Hiçbir değer dönmez.

Imagick::setImageGamma
Imagick::setImageGreenPrimary
Imagick sınıfı


Resmin renk bileşenlerinden birincil yeşil noktasını tanımlar

Imagick::setImageGravity
Imagick::setImageIndex
Imagick sınıfı
PHP Manual

Imagick::setImageGreenPrimary

(PECL imagick 2.0.0)

Imagick::setImageGreenPrimary — Resmin renk bileşenlerinden birincil yeşil noktasını tanımlar

Açıklama

bool Imagick::setImageGreenPrimary ( float $x , float $y )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin renk bileşenlerinden birincil yeşil noktasını tanımlar.

Değiştirgeler

x

y

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::setImageGravity
Imagick::setImageIndex
Imagick sınıfı


Yineleyici konumunu tanımlar

Imagick::setImageGreenPrimary
Imagick::setImageInterlaceScheme
Imagick sınıfı
PHP Manual

Imagick::setImageIndex

(PECL imagick 2.0.0)

Imagick::setImageIndex — Yineleyici konumunu tanımlar

Açıklama

bool Imagick::setImageIndex ( int $indis )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Yineleyicinin resimdeki konumunu belirtilen indise ayarlar.

Bu yöntemin kullanımı artık önerilmemektedir. Yerine Imagick::setIteratorIndex() yöntemini kullanın.

Değiştirgeler

indis

Yineleyiciye atanacak konum.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::setImageGreenPrimary
Imagick::setImageInterlaceScheme
Imagick sınıfı


Resim geçişim şemasını tanımlar

Imagick::setImageIndex
Imagick::setImageInterpolateMethod
Imagick sınıfı
PHP Manual

Imagick::setImageInterlaceScheme

(PECL imagick 2.0.0)

Imagick::setImageInterlaceScheme — Resim geçişim şemasını tanımlar

Açıklama

bool Imagick::setImageInterlaceScheme ( int $geçişim_şeması )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resim geçişim şemasını tanımlar.

Değiştirgeler

geçişim_şeması

Geçişim sabitlerinden biri.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::setImageIndex
Imagick::setImageInterpolateMethod
Imagick sınıfı


Resmin aradeğer pikseli yöntemini tanımlar

Imagick::setImageInterlaceScheme
Imagick::setImageIterations
Imagick sınıfı
PHP Manual

Imagick::setImageInterpolateMethod

(PECL imagick 2.0.0)

Imagick::setImageInterpolateMethod — Resmin aradeğer pikseli yöntemini tanımlar

Açıklama

bool Imagick::setImageInterpolateMethod ( int $yöntem )

Resmin aradeğer pikseli yöntemini tanımlar.

Değiştirgeler

yöntem

Imagick::INTERPOLATE_* sabitlerinden biri.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::setImageInterlaceScheme
Imagick::setImageIterations
Imagick sınıfı


Resim yineleme sayısını tanımlar

Imagick::setImageInterpolateMethod
Imagick::setImageMatte
Imagick sınıfı
PHP Manual

Imagick::setImageIterations

(PECL imagick 2.0.0)

Imagick::setImageIterations — Resim yineleme sayısını tanımlar

Açıklama

bool Imagick::setImageIterations ( int $yineleme )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resim yineleme sayısını tanımlar.

Değiştirgeler

yineleme

Yineleme sayısı.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::setImageInterpolateMethod
Imagick::setImageMatte
Imagick sınıfı


Resmin matlık kanalını ayarlar

Imagick::setImageIterations
Imagick::setImageMatteColor
Imagick sınıfı
PHP Manual

Imagick::setImageMatte

(PECL imagick 2.0.0)

Imagick::setImageMatte — Resmin matlık kanalını ayarlar

Açıklama

bool Imagick::setImageMatte ( bool $matlık )

Resmin matlık kanalını ayarlar. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.2.9 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

matlık

TRUE matlık kanalını etkin kılar, FALSE iptal eder.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::setImageIterations
Imagick::setImageMatteColor
Imagick sınıfı


Resmin şeffaf rengini tanımlar

Imagick::setImageMatte
Imagick::setImageOpacity
Imagick sınıfı
PHP Manual

Imagick::setImageMatteColor

(PECL imagick 2.0.0)

Imagick::setImageMatteColor — Resmin şeffaf rengini tanımlar

Açıklama

bool Imagick::setImageMatteColor ( mixed $şeffaf_renk )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin şeffaf rengini tanımlar.

Değiştirgeler

şeffaf_renk

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Sürüm Bilgisi

Sürüm: | Açıklama
2.1.0 | Artık renk olarak rengi ifade eden bir dizge belirtilebiliyor. Evvelce sadece bir ImagickPixel nesnesi belirtilebiliyordu.

Imagick::setImageMatte
Imagick::setImageOpacity
Imagick sınıfı


Resmin matlık seviyesini tanımlar

Imagick::setImageMatteColor
Imagick::setImageOrientation
Imagick sınıfı
PHP Manual

Imagick::setImageOpacity

(PECL imagick 2.0.0)

Imagick::setImageOpacity — Resmin matlık seviyesini tanımlar

Açıklama

bool Imagick::setImageOpacity ( float $matlık )

Resmin matlık seviyesini belirtilen seviyeye ayarlar. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.3.1 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

matlık

Şeffaflık seviyesi. Tam mat: 1.0; tam şeffaf: 0.0

Dönen Değerler

Başarı durumunda TRUE döner.

Örnekler

Örnek 1 - Imagick::setImageOpacity() örneği

<?php
/* Nesneyi oluşturalım */
$image = new Imagick('source.png');

/* Matlığı ayarlayalım */
$image->setImageOpacity(0.7);

/* resmi çıktılayalım */
header('Content-type: image/png');
echo $image;

?>

Imagick::setImageMatteColor
Imagick::setImageOrientation
Imagick sınıfı


Resmin baskı yönünü tanımlar

Imagick::setImageOpacity
Imagick::setImagePage
Imagick sınıfı
PHP Manual

Imagick::setImageOrientation

(PECL imagick 2.0.0)

Imagick::setImageOrientation — Resmin baskı yönünü tanımlar

Açıklama

bool Imagick::setImageOrientation ( int $baskı_yönü )

Resmin baskı yönünü tanımlar.

Değiştirgeler

baskı_yönü

Yön sabitlerinden (ORIENTATION_) biri.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::setImageOpacity
Imagick::setImagePage
Imagick sınıfı


Resmin sayfa geometrisini tanımlar

Imagick::setImageOrientation
Imagick::setImageProfile
Imagick sınıfı
PHP Manual

Imagick::setImagePage

(PECL imagick 2.0.0)

Imagick::setImagePage — Resmin sayfa geometrisini tanımlar

Açıklama

bool Imagick::setImagePage ( int $genişlik , int $yükseklik , int $x , int $y )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin sayfa geometrisini tanımlar.

Değiştirgeler

genişlik

yükseklik

x

y

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::setImageOrientation
Imagick::setImageProfile
Imagick sınıfı


Imagick nesnesine isimli bir profil ekler

Imagick::setImagePage
Imagick::setImageProperty
Imagick sınıfı
PHP Manual

Imagick::setImageProfile

(PECL imagick 2.0.0)

Imagick::setImageProfile — Imagick nesnesine isimli bir profil ekler

Açıklama

bool Imagick::setImageProfile ( string $isim , string $profil )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Imagick nesnesine isimli bir profil ekler. Aynı isimde bir profil varsa onun yerine geçer. Bu yöntem, CMS renk profillerini uygulamayan Imagick::ProfileImage() yönteminden farklıdır.

Değiştirgeler

isim

Profilin ismi.

profil

Profil dizgesi.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::setImagePage
Imagick::setImageProperty
Imagick sınıfı


Bir resim özelliğini tanımlar

Imagick::setImageProfile
Imagick::setImageRedPrimary
Imagick sınıfı
PHP Manual

Imagick::setImageProperty

(PECL imagick 2.0.0)

Imagick::setImageProperty — Bir resim özelliğini tanımlar

Açıklama

bool Imagick::setImageProperty ( string $isim , string $değer )

Bir resim özelliğini tanımlar. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.3.2 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

isim

Özelliğin ismi.

değer

Özelliğin değeri.

Dönen Değerler

Başarı durumunda TRUE döner.

Örnekler

Örnek 1 - Imagick::setImageProperty() örneği

Resim özelliklerinini belirlinmesi ve döndürülmesi.

<?php
$image = new Imagick();
$image->newImage(300, 200, "black");

$image->setImageProperty('Exif:Make', 'Imagick');
echo $image->getImageProperty('Exif:Make');
?>

Ayrıca Bakınız

  • Imagick::getImageProperty() - İsimli resim özelliğini döndürür

Imagick::setImageProfile
Imagick::setImageRedPrimary
Imagick sınıfı


Resmin renk bileşenlerinden birincil kırmızı noktasını tanımlar

Imagick::setImageProperty
Imagick::setImageRenderingIntent
Imagick sınıfı
PHP Manual

Imagick::setImageRedPrimary

(PECL imagick 2.0.0)

Imagick::setImageRedPrimary — Resmin renk bileşenlerinden birincil kırmızı noktasını tanımlar

Açıklama

bool Imagick::setImageRedPrimary ( float $x , float $y )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin renk bileşenlerinden birincil kırmızı noktasını tanımlar.

Değiştirgeler

x

y

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::setImageProperty
Imagick::setImageRenderingIntent
Imagick sınıfı


Resme komutların uygulanış tarzını belirler

Imagick::setImageRedPrimary
Imagick::setImageResolution
Imagick sınıfı
PHP Manual

Imagick::setImageRenderingIntent

(PECL imagick 2.0.0)

Imagick::setImageRenderingIntent — Resme komutların uygulanış tarzını belirler

Açıklama

bool Imagick::setImageRenderingIntent ( int $uygulama_tarzı )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resme komutların uygulanış tarzını belirler.

Değiştirgeler

uygulama_tarzı

Uygulama tarzı sabitlerinden biri.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::setImageRedPrimary
Imagick::setImageResolution
Imagick sınıfı


Resmin çözünürlüğünü ayarlar

Imagick::setImageRenderingIntent
Imagick::setImageScene
Imagick sınıfı
PHP Manual

Imagick::setImageResolution

(PECL imagick 2.0.0)

Imagick::setImageResolution — Resmin çözünürlüğünü ayarlar

Açıklama

bool Imagick::setImageResolution ( float $x_çözünürlüğü , float $y_çözünürlüğü )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin çözünürlüğünü ayarlar.

Değiştirgeler

x_çözünürlüğü

y_çözünürlüğü

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::setImageRenderingIntent
Imagick::setImageScene
Imagick sınıfı


Resmin dekorunu tanımlar

Imagick::setImageResolution
Imagick::setImageTicksPerSecond
Imagick sınıfı
PHP Manual

Imagick::setImageScene

(PECL imagick 2.0.0)

Imagick::setImageScene — Resmin dekorunu tanımlar

Açıklama

bool Imagick::setImageScene ( int $dekor )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin dekorunu tanımlar.

Değiştirgeler

dekor

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::setImageResolution
Imagick::setImageTicksPerSecond
Imagick sınıfı


Resmin saniyedeki tik sayısını tanımlar

Imagick::setImageScene
Imagick::setImageType
Imagick sınıfı
PHP Manual

Imagick::setImageTicksPerSecond

(PECL imagick 2.0.0)

Imagick::setImageTicksPerSecond — Resmin saniyedeki tik sayısını tanımlar

Açıklama

bool Imagick::setImageTicksPerSecond ( int $tik_hızı )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin saniyedeki tik sayısını tanımlar.

Değiştirgeler

tik_hızı

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::setImageScene
Imagick::setImageType
Imagick sınıfı


Resim türünü tanımlar

Imagick::setImageTicksPerSecond
Imagick::setImageUnits
Imagick sınıfı
PHP Manual

Imagick::setImageType

(PECL imagick 2.0.0)

Imagick::setImageType — Resim türünü tanımlar

Açıklama

bool Imagick::setImageType ( int $resim_türü )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resim türünü tanımlar.

Değiştirgeler

resim_türü

Resim türü sabitlerinden biri.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::setImageTicksPerSecond
Imagick::setImageUnits
Imagick sınıfı


Resmin çözünürlük birimlerini tanımlar

Imagick::setImageType
Imagick::setImageVirtualPixelMethod
Imagick sınıfı
PHP Manual

Imagick::setImageUnits

(PECL imagick 2.0.0)

Imagick::setImageUnits — Resmin çözünürlük birimlerini tanımlar

Açıklama

bool Imagick::setImageUnits ( int $birimler )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin çözünürlük birimlerini tanımlar.

Değiştirgeler

birimler

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::setImageType
Imagick::setImageVirtualPixelMethod
Imagick sınıfı


Resmin sanal piksel yöntemini tanımlar

Imagick::setImageUnits
Imagick::setImageWhitePoint
Imagick sınıfı
PHP Manual

Imagick::setImageVirtualPixelMethod

(PECL imagick 2.0.0)

Imagick::setImageVirtualPixelMethod — Resmin sanal piksel yöntemini tanımlar

Açıklama

bool Imagick::setImageVirtualPixelMethod ( int $yöntem )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin sanal piksel yöntemini tanımlar.

Değiştirgeler

yöntem

Sanal piksel yöntemi sabitlerinden biri.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::setImageUnits
Imagick::setImageWhitePoint
Imagick sınıfı


Renk berraklığının beyaz noktasını tanımlar

Imagick::setImageVirtualPixelMethod
Imagick::setInterlaceScheme
Imagick sınıfı
PHP Manual

Imagick::setImageWhitePoint

(PECL imagick 2.0.0)

Imagick::setImageWhitePoint — Renk berraklığının beyaz noktasını tanımlar

Açıklama

bool Imagick::setImageWhitePoint ( float $x , float $y )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Renk berraklığının beyaz noktasını tanımlar.

Değiştirgeler

x

y

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::setImageVirtualPixelMethod
Imagick::setInterlaceScheme
Imagick sınıfı


Resim geçişim şemasını tanımlar

Imagick::setImageWhitePoint
Imagick::setIteratorIndex
Imagick sınıfı
PHP Manual

Imagick::setInterlaceScheme

(PECL imagick 2.0.0)

Imagick::setInterlaceScheme — Resim geçişim şemasını tanımlar

Açıklama

bool Imagick::setInterlaceScheme ( int $geçişim_şeması )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resim geçişim şemasını tanımlar.

Değiştirgeler

geçişim_şeması

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::setImageWhitePoint
Imagick::setIteratorIndex
Imagick sınıfı


Yineleyici konumunu belirler

Imagick::setInterlaceScheme
Imagick::setLastIterator
Imagick sınıfı
PHP Manual

Imagick::setIteratorIndex

(PECL imagick 2.0.0)

Imagick::setIteratorIndex — Yineleyici konumunu belirler

Açıklama

bool Imagick::setIteratorIndex ( int $indis )

Yineleyiciyi resim listesinde indisi belirtilen konuma ayarlar. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.2.9 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

indis

Yineleyicinin atanacağı konum.

Dönen Değerler

Başarı durumunda TRUE döner.

Örnekler

Örnek 1 - Imagick::setIteratorIndex() örneği

Resimleri oluşturup yineleyici indisini tanımlar ve döndürür.

<?php
$im = new Imagick();
$im->newImage(100, 100, new ImagickPixel("red"));
$im->newImage(100, 100, new ImagickPixel("green"));
$im->newImage(100, 100, new ImagickPixel("blue"));

$im->setIteratorIndex(1);
echo $im->getIteratorIndex();
?>

Ayrıca Bakınız

  • Imagick::getIteratorIndex() - Geçerli etkin resmin indisini döndürür
  • Imagick::getImageIndex() - Geçerli etkin resmin indisini döndürür
  • Imagick::setImageIndex() - Yineleyici konumunu tanımlar

Imagick::setInterlaceScheme
Imagick::setLastIterator
Imagick sınıfı


Son resme bir Imagick yineleyicisi atar

Imagick::setIteratorIndex
Imagick::setOption
Imagick sınıfı
PHP Manual

Imagick::setLastIterator

(PECL imagick 2.0.1)

Imagick::setLastIterator — Son resme bir Imagick yineleyicisi atar

Açıklama

bool Imagick::setLastIterator ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Son resme bir Imagick yineleyicisi atar.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::setIteratorIndex
Imagick::setOption
Imagick sınıfı


Bir seçenek tanımlar

Imagick::setLastIterator
Imagick::setPage
Imagick sınıfı
PHP Manual

Imagick::setOption

(PECL imagick 2.0.0)

Imagick::setOption — Bir seçenek tanımlar

Açıklama

bool Imagick::setOption ( string $anahtar , string $değer )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Belirtilen seçeneği kalemle ilişkilendirir.

Değiştirgeler

anahtar

değer

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::setLastIterator
Imagick::setPage
Imagick sınıfı


Imagick nesnesinin sayfa geometrisini tanımlar

Imagick::setOption
Imagick::setPointSize
Imagick sınıfı
PHP Manual

Imagick::setPage

(PECL imagick 2.0.0)

Imagick::setPage — Imagick nesnesinin sayfa geometrisini tanımlar

Açıklama

bool Imagick::setPage ( int $genişlik , int $yükseklik , int $x , int $y )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Imagick nesnesinin sayfa geometrisini tanımlar.

Değiştirgeler

genişlik

yükseklik

x

y

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::setOption
Imagick::setPointSize
Imagick sınıfı


Yazı puntosunu belirler

Imagick::setPage
Imagick::setProgressMonitor
Imagick sınıfı
PHP Manual

Imagick::setPointSize

(PECL imagick 2.1.0)

Imagick::setPointSize — Yazı puntosunu belirler

Açıklama

bool Imagick::setPointSize ( float $punto )

Nesnenin yazı puntosunu belirler. Bu yöntem örneğin başlık yazı tipi boyutunu belirlemek için kullanılabilir. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.3.7 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

punto

Punto cinsinden yazı tipi yüksekliği.

Dönen Değerler

Başarı durumunda TRUE döner.

Ayrıca Bakınız

  • Imagick::getPointSize() - Punto değerini döndürür

Örnekler

Örnek 1 - Imagick::setPointSize() örneği

Imagick::setPointSize kullanım örneği

<?php
/* Yeni bir imagick nesnesi oluşturalım */
$im = new Imagick();

/* Nesne için yazıtipine belirleyelim */
$im->setFont("example.ttf");

/* Yazı tipi yüksekliğini belirleyelim */
$im->setPointSize(12);

/* Resim başlığını çizelim */
$im->newPseudoImage(100, 100, "caption:Hello");

/* Resimde yapılacak diğer işlemler */
?>

Imagick::setPage
Imagick::setProgressMonitor
Imagick sınıfı


Description

Imagick::setPointSize
Imagick::setRegistry
Imagick sınıfı
PHP Manual

Imagick::setProgressMonitor

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::setProgressMonitor — Description

Açıklama

public void Imagick::setProgressMonitor ( callable $callback )

Set a callback that will be called during the processing of the Imagick image.

Değiştirgeler

callback

The progress function to call. It should return true if image processing should continue, or false if it should be cancelled. The offset parameter indicates the progress and the span parameter indicates the total amount of work needed to be done.

bool callback ( mixed $offset , mixed $span )
Dikkat

The values passed to the callback function are not consistent. In particular the span parameter can increase during image processing. Because of this calculating the percentage complete of an image operation is not trivial.

Dönen Değerler

Örnekler

Örnek 1 Imagick::setProgressMonitor()

<?php
        $abortReason = null;

        try {
            $imagick = new \Imagick(realpath($this->control->getImagePath()));
            $startTime = time();

            $callback = function ($offset, $span)  use ($startTime, &$abortReason) {
                if (((100 * $offset) / $span)  > 20) {
                    $abortReason = "Processing reached 20%";
                    return false;
                }

                $nowTime = time();

                if ($nowTime - $startTime > 5) {
                    $abortReason = "Image processing took more than 5 seconds";
                    return false;
                }
                if (($offset % 5) == 0) {
                    echo "Progress: $offset / $span <br/>";
                }
                return true;
            };

            $imagick->setProgressMonitor($callback);

            $imagick->waveImage(2, 15);

            echo "Data len is: ".strlen($imagick->getImageBlob());
        }
        catch(\ImagickException $e) {
            if ($abortReason != null) {
                echo "Image processing was aborted: ".$abortReason."<br/>";
            }
            else {
                echo "ImagickException caught: ".$e->getMessage()." Exception type is ".get_class($e);
            }
        }

?>

Imagick::setPointSize
Imagick::setRegistry
Imagick sınıfı


Description

Imagick::setProgressMonitor
Imagick::setResolution
Imagick sınıfı
PHP Manual

Imagick::setRegistry

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::setRegistry — Description

Açıklama

public static void Imagick::setRegistry ( string $key , string $value )

Sets the ImageMagick registry entry named key to value. This is most useful for setting "temporary-path" which controls where ImageMagick creates temporary images e.g. while processing PDFs.

Değiştirgeler

key

value

Dönen Değerler

Imagick::setProgressMonitor
Imagick::setResolution
Imagick sınıfı


Resim çözünürlüğünü tanımlar

Imagick::setRegistry
Imagick::setResourceLimit
Imagick sınıfı
PHP Manual

Imagick::setResolution

(PECL imagick 2.0.0)

Imagick::setResolution — Resim çözünürlüğünü tanımlar

Açıklama

bool Imagick::setResolution ( float $x_çözünürlüğü , float $y_çözünürlüğü )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resim çözünürlüğünü tanımlar.

Değiştirgeler

x_çözünürlüğü

y_çözünürlüğü

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::setRegistry
Imagick::setResourceLimit
Imagick sınıfı


Belli bir özkaynağın sınırını megabayt olarak tanımlar

Imagick::setResolution
Imagick::setSamplingFactors
Imagick sınıfı
PHP Manual

Imagick::setResourceLimit

(PECL imagick 2.0.0)

Imagick::setResourceLimit — Belli bir özkaynağın sınırını megabayt olarak tanımlar

Açıklama

bool Imagick::setResourceLimit ( int $özkaynak , int $sınır )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Türü belirtilen özkaynağın sınırını megabayt olarak tanımlar,

Değiştirgeler

özkaynak

Özkaynak türü sabitlerinden biri.

sınır

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::setResolution
Imagick::setSamplingFactors
Imagick sınıfı


Resim örnekleme çarpanlarını ayarlar

Imagick::setResourceLimit
Imagick::setSize
Imagick sınıfı
PHP Manual

Imagick::setSamplingFactors

(PECL imagick 2.0.0)

Imagick::setSamplingFactors — Resim örnekleme çarpanlarını ayarlar

Açıklama

bool Imagick::setSamplingFactors ( array $çarpanlar )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resim örnekleme çarpanlarını ayarlar.

Değiştirgeler

çarpanlar

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::setResourceLimit
Imagick::setSize
Imagick sınıfı


Imagick nesnesinin boyutlarını ayarlar

Imagick::setSamplingFactors
Imagick::setSizeOffset
Imagick sınıfı
PHP Manual

Imagick::setSize

(PECL imagick 2.0.0)

Imagick::setSize — Imagick nesnesinin boyutlarını ayarlar

Açıklama

bool Imagick::setSize ( int $sütun , int $satır )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Imagick nesnesinin boyutlarını ayarlar. RGB, GRAY veya CMYK gibi bir ham resim biçemini okumadan önce nesnenin boyutlarını ayarlamalısınız.

Değiştirgeler

sütun

satır

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::setSamplingFactors
Imagick::setSizeOffset
Imagick sınıfı


Imagick nesnesinin başlangıcını ve boyutlarını ayarlar

Imagick::setSize
Imagick::setType
Imagick sınıfı
PHP Manual

Imagick::setSizeOffset

(PECL imagick 2.0.0)

Imagick::setSizeOffset — Imagick nesnesinin başlangıcını ve boyutlarını ayarlar

Açıklama

bool Imagick::setSizeOffset ( int $sütun , int $satır , int $başlangıç )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Imagick nesnesinin başlangıcını ve boyutlarını ayarlar. RGB, GRAY veya CMYK gibi bir ham resim biçemini okumadan önce nesnenin boyutlarını ayarlamalısınız. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.2.9 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

sütun

Piksel cinsinden genişlik.

satır

Piksel cinsinden yükseklik.

başlangıç

Resim başlangıcı.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::setSize
Imagick::setType
Imagick sınıfı


Resmin tür özniteliğini tanımlar

Imagick::setSizeOffset
Imagick::shadeImage
Imagick sınıfı
PHP Manual

Imagick::setType

(PECL imagick 2.0.0)

Imagick::setType — Resmin tür özniteliğini tanımlar

Açıklama

bool Imagick::setType ( int $resim_türü )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin tür özniteliğini tanımlar.

Değiştirgeler

resim_türü

Resim türü sabitlerinden biri.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::setSizeOffset
Imagick::shadeImage
Imagick sınıfı


Üç boyutluluk etkisi oluşturur

Imagick::setType
Imagick::shadowImage
Imagick sınıfı
PHP Manual

Imagick::shadeImage

(PECL imagick 2.0.0)

Imagick::shadeImage — Üç boyutluluk etkisi oluşturur

Açıklama

bool Imagick::shadeImage ( bool $gri , float $başucu , float $yükseliş )

Üç boyutluluk etkisi vermek için bir resme belli bir mesafeden ışık düşürür. Işığın yerini başucu ve yükseliş değiştirgeleri ile belirtebilirsiniz. başucu X ekseninden uzaklığı derece cinsinden, yükseliş ise Z eksenine göre yüksekliği piksel cinsinden belirtir. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.2.9 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

gri

Sıfırdan farklı bir değer her pikselin gölgelenme koyuluğunu belirtir.

başucu

Işık kaynağının yataydaki yönünü belirtir.

yükseliş

Işık kaynağının düşeydeki yönünü belirtir.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::setType
Imagick::shadowImage
Imagick sınıfı


Bir resimde gölgeleri taklit eder

Imagick::shadeImage
Imagick::sharpenImage
Imagick sınıfı
PHP Manual

Imagick::shadowImage

(PECL imagick 2.0.0)

Imagick::shadowImage — Bir resimde gölgeleri taklit eder

Açıklama

bool Imagick::shadowImage ( float $matlık , float $sapma , int $x , int $y )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bir resimde gölgeleri taklit eder.

Değiştirgeler

matlık

sapma

x

y

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::shadeImage
Imagick::sharpenImage
Imagick sınıfı


Resmi netleştirir

Imagick::shadowImage
Imagick::shaveImage
Imagick sınıfı
PHP Manual

Imagick::sharpenImage

(PECL imagick 2.0.0)

Imagick::sharpenImage — Resmi netleştirir

Açıklama

bool Imagick::sharpenImage ( float $yarıçap , float $sapma [, int $kanal = Imagick::CHANNEL_ALL ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmi netleştirir. Yarıçap ve standart sapması belirtilen bir Gauss işleci ile resim evriştirilir. Makul sonuçlar elde etmek için yarıçap standart sapmadan büyük olmalıdır. yarıçap olarak 0 verirseniz Imagick::sharpenImage() size uygun bir yarıçap seçecektir.

Değiştirgeler

yarıçap

Merkezdeki piksel sayısı değil, piksel cinsinden Gauss işleci yarıçapıdır.

sapma

Piksel cinsinden standart sapma.

kanal

Normalde kanal türü sabitlerinden biri, ancak bitsel işleçler kullanılarak birden fazla kanal belirtilebilir. Imagick::CHANNEL_ALL öntanımlıdır.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::shadowImage
Imagick::shaveImage
Imagick sınıfı


Bir resmin kenarındaki pikselleri rendeler

Imagick::sharpenImage
Imagick::shearImage
Imagick sınıfı
PHP Manual

Imagick::shaveImage

(PECL imagick 2.0.0)

Imagick::shaveImage — Bir resmin kenarındaki pikselleri rendeler

Açıklama

bool Imagick::shaveImage ( int $sütun , int $satır )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bir resmin kenarındaki pikselleri rendeler.

Değiştirgeler

sütun

satır

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::sharpenImage
Imagick::shearImage
Imagick sınıfı


Bir paralalkenar oluşturur

Imagick::shaveImage
Imagick::sigmoidalContrastImage
Imagick sınıfı
PHP Manual

Imagick::shearImage

(PECL imagick 2.0.0)

Imagick::shearImage — Bir paralalkenar oluşturur

Açıklama

bool Imagick::shearImage ( mixed $artalan , float $x_kaykılması , float $y_kaykılması )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bir paralelkenar oluşturmak için resmin bir kenarını X ve Y eksenleri boyunca kaydırır. Kaykılma miktarı, kaykılma açısıyla belirtilir. X yönünde kaykılma için, x_kaykılması Y eksenine göre ölçülür. Y yönünde kaykılma için ise, y_kaykılması X eksenine göre ölçülür. Kaykılmadan dolayı ortaya çıkan boş üçgenler artalan rengi ile doldurulur.

Değiştirgeler

artalan

Kaykılmadan dolayı ortaya çıkan boş üçgenlerin doldurulacağı renk.

x_kaykılması

X eksenindeki kaykılmanın derece cinsinden değeri.

y_kaykılması

Y eksenindeki kaykılmanın derece cinsinden değeri.

Dönen Değerler

Başarı durumunda TRUE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
2.1.0 | İlk değiştirgede rengi ifade etmek için bir dizge belirtilebilir oldu. Evvelce sadece bir ImagickPixel nesnesi belirtilebiliyordu.

Imagick::shaveImage
Imagick::sigmoidalContrastImage
Imagick sınıfı


Bir resmin zıtlığını ayarlar

Imagick::shearImage
Imagick::sketchImage
Imagick sınıfı
PHP Manual

Imagick::sigmoidalContrastImage

(PECL imagick 2.0.0)

Imagick::sigmoidalContrastImage — Bir resmin zıtlığını ayarlar

Açıklama

bool Imagick::sigmoidalContrastImage ( bool $netleştir , float $zıtlık , float $aradeğer [, int $kanal = Imagick::CHANNEL_ALL ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bir resmin zıtlığını (contrast) doğrusal olmayan sigmamsı zıtlık algoritması ile ayarlar. Sigmamsı aktarım işlevi kullanılarak parlak ve gölgeli bölgeler ışığa doyurulmadan resmin zıtlığı arttırılır.

Değiştirgeler

netleştir

TRUE belirtilirse resmin zıtlığı arttırılır, FALSE belirtilirse düşürülür.

zıtlık

Zıtlığın ne kadar arttırılacağı/azaltılacağı belirtilir. (0: Yok, 3: Normal, 20: Aşırı)

aradeğer

Elde edilen resimde ara tonların nereye uygulanacağını belirler. (0: Beyaz, 50: Gri, 100: Siyah)

kanal

Normalde kanal türü sabitlerinden biri, ancak bitsel işleçler kullanılarak birden fazla kanal belirtilebilir. Imagick::CHANNEL_ALL öntanımlıdır.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::shearImage
Imagick::sketchImage
Imagick sınıfı


Kara kalem çalışmasını taklit eder

Imagick::sigmoidalContrastImage
Imagick::smushImages
Imagick sınıfı
PHP Manual

Imagick::sketchImage

(PECL imagick 2.0.0)

Imagick::sketchImage — Kara kalem çalışmasını taklit eder

Açıklama

bool Imagick::sketchImage ( float $yarıçap , float $sapma , float $açı )

Kara kalem çalışmasını taklit eder. Yarıçap ve standart sapması belirtilen bir Gauss işleci ile resim evriştirilir. Makul sonuçlar elde etmek için yarıçap standart sapmadan büyük olmalıdır. yarıçap olarak 0 verirseniz Imagick::sketchImage() size uygun bir yarıçap seçecektir. açı ile bulanıklaştırma açısı belirtilir. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.2.9 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

yarıçap

Merkezdeki piksel sayısı değil, piksel cinsinden Gauss işleci yarıçapıdır.

sapma

Piksel cinsinden standart sapma.

açı

Etki bu açıya uygulanır.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::sigmoidalContrastImage
Imagick::smushImages
Imagick sınıfı


Description

Imagick::sketchImage
Imagick::solarizeImage
Imagick sınıfı
PHP Manual

Imagick::smushImages

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::smushImages — Description

Açıklama

public Imagick Imagick::smushImages ( string $stack , string $offset )

Takes all images from the current image pointer to the end of the image list and smushs them to each other top-to-bottom if the stack parameter is true, otherwise left-to-right.

Değiştirgeler

stack

offset

Dönen Değerler

The new smushed image.

Örnekler

Örnek 1 Imagick::smushImages()

<?php
function smushImages($imagePath, $imagePath2) {

    $imagick = new \Imagick(realpath($imagePath));
    $imagick2 = new \Imagick(realpath($imagePath2));

    $imagick->addimage($imagick2);
    $smushed = $imagick->smushImages(false, 50);
    $smushed->setImageFormat('jpg');
    header("Content-Type: image/jpg");
    echo $smushed->getImageBlob();
}

?>

Imagick::sketchImage
Imagick::solarizeImage
Imagick sınıfı


Resme uzun pozlama etkisi uygular

Imagick::smushImages
Imagick::sparseColorImage
Imagick sınıfı
PHP Manual

Imagick::solarizeImage

(PECL imagick 2.0.0)

Imagick::solarizeImage — Resme uzun pozlama etkisi uygular

Açıklama

bool Imagick::solarizeImage ( int $eşik )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Karanlık odada ışığa duyarlı kağıdın belli alanlarına uzun süre ışık vererek elde edilen etkiye benzer bir etkiyi resme uygular. Eşik değeri, etkinin yayılma genişliğinin bir ölçüsü olup, 0 ile ParçacıkAralığı (QuantumRange) arasında bir değer olabilir.

Değiştirgeler

eşik

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::smushImages
Imagick::sparseColorImage
Imagick sınıfı


Interpolates colors

Imagick::solarizeImage
Imagick::spliceImage
Imagick sınıfı
PHP Manual

Imagick::sparseColorImage

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::sparseColorImage — Interpolates colors

Açıklama

public bool Imagick::sparseColorImage ( int $SPARSE_METHOD , array $arguments [, int $channel = Imagick::CHANNEL_DEFAULT ] )

Given the arguments array containing numeric values this method interpolates the colors found at those coordinates across the whole image using sparse_method. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.4.5 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

SPARSE_METHOD

Refer to this list of sparse method constants

arguments

An array containing the coordinates. The array is in format array(1,1, 2,45)

CHANNEL

Normalde kanal türü sabitlerinden biridir, ancak bitsel işleçler kullanılarak birden fazla kanal belirtilebilir. Imagick::CHANNEL_DEFAULT öntanımlıdır.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Örnekler

Örnek 1 SPARSECOLORMETHOD_BARYCENTRIC Imagick::sparseColorImage()

<?php
    function renderImageBarycentric2() {
        $points = [
            [0.30, 0.10, 'red'],
            [0.10, 0.80, 'blue'],
            [0.70, 0.60, 'lime'],
            [0.80, 0.20, 'yellow'],
        ];
        $imagick = createGradientImage(
            400, 400,
            $points,
            \Imagick::SPARSECOLORMETHOD_BARYCENTRIC
        );
        header("Content-Type: image/png");
        echo $imagick->getImageBlob();
    }

?>

Örnek 2 SPARSECOLORMETHOD_BILINEAR Imagick::sparseColorImage()

<?php
    function renderImageBilinear() {
        $points = [[0.30, 0.10, 'red'], [0.10, 0.80, 'blue'], [0.70, 0.60, 'lime'], [0.80, 0.20, 'yellow'],];
        $imagick = createGradientImage(500, 500, $points, \Imagick::SPARSECOLORMETHOD_BILINEAR);
        header("Content-Type: image/png");
        echo $imagick->getImageBlob();
    }

?>

Örnek 3 SPARSECOLORMETHOD_SPEPARDS Imagick::sparseColorImage()

<?php
    function renderImageShepards() {
        $points = [
            [0.30, 0.10, 'red'],
            [0.10, 0.80, 'blue'],
            [0.70, 0.60, 'lime'],
            [0.80, 0.20, 'yellow'],
        ];
        $imagick = createGradientImage(600, 600, $points, \Imagick::SPARSECOLORMETHOD_SPEPARDS);
        header("Content-Type: image/png");
        echo $imagick->getImageBlob();
    }

?>

Örnek 4 SPARSECOLORMETHOD_VORONOI Imagick::sparseColorImage()

<?php
    function renderImageVoronoi() {
        $points = [
            [0.30, 0.10, 'red'],
            [0.10, 0.80, 'blue'],
            [0.70, 0.60, 'lime'],
            [0.80, 0.20, 'yellow'],
        ];
        $imagick = createGradientImage(500, 500, $points, \Imagick::SPARSECOLORMETHOD_VORONOI);
        header("Content-Type: image/png");
        echo $imagick->getImageBlob();
    }

?>

Örnek 5 SPARSECOLORMETHOD_BARYCENTRIC Imagick::sparseColorImage()

<?php
    function renderImageBarycentric() {
        $points = [
            [0, 0, 'skyblue'],
            [-1, 1, 'skyblue'],
            [1, 1, 'black'],
        ];
        $imagick = createGradientImage(600, 200, $points, \Imagick::SPARSECOLORMETHOD_BARYCENTRIC);
        header("Content-Type: image/png");
        echo $imagick->getImageBlob();
    }

?>

Örnek 6 createGradientImage is used by other examples. Imagick::sparseColorImage()

<?php
function createGradientImage($width, $height, $colorPoints, $sparseMethod, $absolute = false) {

    $imagick = new \Imagick();
    $imagick->newImage($width, $height, "white");
    $imagick->setImageFormat("png");

    $barycentricPoints = array();

    foreach ($colorPoints as $colorPoint) {

        if ($absolute == true) {
            $barycentricPoints[] = $colorPoint[0];
            $barycentricPoints[] = $colorPoint[1];
        }
        else {
            $barycentricPoints[] = $colorPoint[0] * $width;
            $barycentricPoints[] = $colorPoint[1] * $height;
        }

        if (is_string($colorPoint[2])) {
            $imagickPixel = new \ImagickPixel($colorPoint[2]);
        }
        else if ($colorPoint[2] instanceof \ImagickPixel) {
            $imagickPixel = $colorPoint[2];
        }
        else{
            $errorMessage = sprintf(
                "Value %s is neither a string nor an ImagickPixel class. Cannot use as a color.",
                $colorPoint[2]
            );

            throw new \InvalidArgumentException(
                $errorMessage
            );
        }

        $red = $imagickPixel->getColorValue(\Imagick::COLOR_RED);
        $green = $imagickPixel->getColorValue(\Imagick::COLOR_GREEN);
        $blue = $imagickPixel->getColorValue(\Imagick::COLOR_BLUE);
        $alpha = $imagickPixel->getColorValue(\Imagick::COLOR_ALPHA);

        $barycentricPoints[] = $red;
        $barycentricPoints[] = $green;
        $barycentricPoints[] = $blue;
        $barycentricPoints[] = $alpha;
    }

    $imagick->sparseColorImage($sparseMethod, $barycentricPoints);

    return $imagick;
}

?>

Imagick::solarizeImage
Imagick::spliceImage
Imagick sınıfı


Bir resme bir rengi bütün halinde bindirerek birleştirir

Imagick::sparseColorImage
Imagick::spreadImage
Imagick sınıfı
PHP Manual

Imagick::spliceImage

(PECL imagick 2.0.0)

Imagick::spliceImage — Bir resme bir rengi bütün halinde bindirerek birleştirir

Açıklama

bool Imagick::spliceImage ( int $genişlik , int $yükseklik , int $x , int $y )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bir resme bir rengi bütün halinde bindirerek birleştirir.

Değiştirgeler

genişlik

yükseklik

x

y

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::sparseColorImage
Imagick::spreadImage
Imagick sınıfı


Bir kümedeki her pikseli rasgele gösterir

Imagick::spliceImage
Imagick::statisticImage
Imagick sınıfı
PHP Manual

Imagick::spreadImage

(PECL imagick 2.0.0)

Imagick::spreadImage — Bir kümedeki her pikseli rasgele gösterir

Açıklama

bool Imagick::spreadImage ( float $yarıçap )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

yarıçap değiştirgesi ile belirtilen bir küme içindeki her pikseli rasgele gösteren özel bir etki yaratır.

Değiştirgeler

yarıçap

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::spliceImage
Imagick::statisticImage
Imagick sınıfı


Description

Imagick::spreadImage
Imagick::steganoImage
Imagick sınıfı
PHP Manual

Imagick::statisticImage

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::statisticImage — Description

Açıklama

public void Imagick::statisticImage ( int $type , int $width , int $height [, string $CHANNEL = Imagick::CHANNEL_DEFAULT ] )

Replace each pixel with corresponding statistic from the neighborhood of the specified width and height.

Değiştirgeler

type

width

height

CHANNEL

Dönen Değerler

Örnekler

Örnek 1 Imagick::statisticImage()

<?php
function statisticImage($imagePath, $statisticType, $width, $height, $channel) {
    $imagick = new \Imagick(realpath($imagePath));

    $imagick->statisticImage(
        $statisticType,
        $width,
        $height,
        $channel
    );

    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

statisticImage($imagePath, \Imagick::STATISTIC_MEDIAN, 5, 5, \Imagick::CHANNEL_DEFAULT);

?>

Imagick::spreadImage
Imagick::steganoImage
Imagick sınıfı


Resmin içine sayısal bir filigran gizler

Imagick::statisticImage
Imagick::stereoImage
Imagick sınıfı
PHP Manual

Imagick::steganoImage

(PECL imagick 2.0.0)

Imagick::steganoImage — Resmin içine sayısal bir filigran gizler

Açıklama

Imagick Imagick::steganoImage ( Imagick $filigran , int $konum )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin içine sayısal bir filigran gizler. Daha sonra bu filigranı resmin kimliğini doğrulamak için kullanabilirsiniz.

Değiştirgeler

filigran

Resmin içine gizlenecek filigran resmi.

konum

Filigranın resmin içinde yerleştirileceği konum.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::statisticImage
Imagick::stereoImage
Imagick sınıfı


İki resmi birleştirir

Imagick::steganoImage
Imagick::stripImage
Imagick sınıfı
PHP Manual

Imagick::stereoImage

(PECL imagick 2.0.0)

Imagick::stereoImage — İki resmi birleştirir

Açıklama

bool Imagick::stereoImage ( Imagick $resim )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

İki resmi bir sağda biri solda olmak üzere bir resim çifti haline getirir.

Değiştirgeler

resim

Diğer resim.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::steganoImage
Imagick::stripImage
Imagick sınıfı


Resimden tüm profilleri ve açıklamaları ayıklar

Imagick::stereoImage
Imagick::subImageMatch
Imagick sınıfı
PHP Manual

Imagick::stripImage

(PECL imagick 2.0.0)

Imagick::stripImage — Resimden tüm profilleri ve açıklamaları ayıklar

Açıklama

bool Imagick::stripImage ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resimden tüm profilleri ve açıklamaları ayıklar.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::stereoImage
Imagick::subImageMatch
Imagick sınıfı


Description

Imagick::stripImage
Imagick::swirlImage
Imagick sınıfı
PHP Manual

Imagick::subImageMatch

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::subImageMatch — Description

Açıklama

public Imagick Imagick::subImageMatch ( Imagick $Imagick [, array &$offset [, float &$similarity ]] )

Searches for a subimage in the current image and returns a similarity image such that an exact match location is completely white and if none of the pixels match, black, otherwise some gray level in-between. You can also pass in the optional parameters bestMatch and similarity. After calling the function similarity will be set to the 'score' of the similarity between the subimage and the matching position in the larger image, bestMatch will contain an associative array with elements x, y, width, height that describe the matching region.

Değiştirgeler

Imagick

offset

similarity

A new image that displays the amount of similarity at each pixel.

Dönen Değerler

Örnekler

Örnek 1 Imagick::subImageMatch()

<?php
function subImageMatch($imagePath) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick2 = clone $imagick;
    $imagick2->cropimage(40, 40, 250, 110);
    $imagick2->vignetteimage(0, 1, 3, 3);

    $similarity = null;
    $bestMatch = null;
    $comparison = $imagick->subImageMatch($imagick2, $bestMatch, $similarity);

    $comparison->setImageFormat('png');
    header("Content-Type: image/png");
    echo $imagick->getImageBlob();
}

?>

Imagick::stripImage
Imagick::swirlImage
Imagick sınıfı


Resmin merkezine yakın pikselleri girdap gibi döndürür

Imagick::subImageMatch
Imagick::textureImage
Imagick sınıfı
PHP Manual

Imagick::swirlImage

(PECL imagick 2.0.0)

Imagick::swirlImage — Resmin merkezine yakın pikselleri girdap gibi döndürür

Açıklama

bool Imagick::swirlImage ( float $açı )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin merkezine yakın pikselleri girdap gibi döndürür. açı ile her pikselin çizeceği yayın açısı belirtilir.

Değiştirgeler

açı

En iyi etki 1..360 derece arasında alınır.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::subImageMatch
Imagick::textureImage
Imagick sınıfı


Doku resmini yatay ve düşeyde yineler

Imagick::swirlImage
Imagick::thresholdImage
Imagick sınıfı
PHP Manual

Imagick::textureImage

(PECL imagick 2.0.0)

Imagick::textureImage — Doku resmini yatay ve düşeyde yineler

Açıklama

bool Imagick::textureImage ( Imagick $doku_kalemi )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Doku resmini tuval resmi üzerine yatay ve düşeyde yanyana yerleştirir.

Değiştirgeler

doku_kalemi

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::swirlImage
Imagick::thresholdImage
Imagick sınıfı


Bazı pikselleri bir eşiğe göre değiştir

Imagick::textureImage
Imagick::thumbnailImage
Imagick sınıfı
PHP Manual

Imagick::thresholdImage

(PECL imagick 2.0.0)

Imagick::thresholdImage — Bazı pikselleri bir eşiğe göre değiştir

Açıklama

bool Imagick::thresholdImage ( float $eşik [, int $kanal = Imagick::CHANNEL_ALL ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Her pikselin yoğunluğunu belli bir eşikle karşılaştırarak bazı pikselleri değiştirir. Sonuçta iki renkli yüksek zıtlığa sahip bir resim elde edilir.

Değiştirgeler

eşik

kanal

Normalde kanal türü sabitlerinden biri, ancak bitsel işleçler kullanılarak birden fazla kanal belirtilebilir. Imagick::CHANNEL_ALL öntanımlıdır.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::textureImage
Imagick::thumbnailImage
Imagick sınıfı


Resmin boyutlarını değiştirir

Imagick::thresholdImage
Imagick::tintImage
Imagick sınıfı
PHP Manual

Imagick::thumbnailImage

(PECL imagick 2.0.0)

Imagick::thumbnailImage — Resmin boyutlarını değiştirir

Açıklama

bool Imagick::thumbnailImage ( int $sütun , int $satır [, bool $sığdır = false ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bir resmin boyutlarını belirtilen boyutlara indirir ve resimle ilişkili profilleri siler. Yöntemin amacı, bir HTML sayfada gösterilmek üzere resmin küçük bir örneğini oluşturmaktır.

Bilginize: sığdır değiştirgesinin davranışı Imagick 3.0.0 sürümünde değişmiştir. Evvelce 200x150 ebadındaki bir resim 400x400 ebadındaki bir alana sığdırılmak istendiğinde bu yapılmazdı. Artık resim 400x300 ebadına getirilerek belirtilen alana sığdırılmaktadır. sığdır değiştirgesi kullanıldığı takdirde yükseklik ve genişliğin ikisi de verilmelidir.

Değiştirgeler

sütun

Resmin genişliği.

satır

Resmin yüksekliği.

sığdır

TRUE belirtildiği takdirde, her iki yönde de azami uzunluk olarak satır ve sütun değerleri kullanılır. İki kenarın uzunluğu belirtilen boyuta veya biraz daha altına inene kadar küçültülür.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::thresholdImage
Imagick::tintImage
Imagick sınıfı


Resimdeki her piksele bir renk yöneyi uygular

Imagick::thumbnailImage
Imagick::__toString
Imagick sınıfı
PHP Manual

Imagick::tintImage

(PECL imagick 2.0.0)

Imagick::tintImage — Resimdeki her piksele bir renk yöneyi uygular

Açıklama

bool Imagick::tintImage ( mixed $ton , mixed $matlık )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resimdeki her piksele bir renk yöneyi uygular. Yöneyin uzunluğu siyah ve beyaz için 0, ara tonlar için ise en azamisidir. Kullanılan yöney ağırlığı işlevi: f(x)=(1-(4.0*((x-0.5)*(x-0.5)))).

Değiştirgeler

ton

matlık

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Sürüm Bilgisi

Sürüm: | Açıklama
2.1.0 | Artık, ilk değiştirge için bir renk dizgesi ve ikinci değiştirge olarak opaklık miktarını ifade eden bir gerçek sayı belirtilebilmektedir. Önceki sürümlerde sadece bir ImagickPixel nesnesinin belirtilmesine izin verilirdi.

Imagick::thumbnailImage
Imagick::__toString
Imagick sınıfı


Returns the image as a string.

Imagick::tintImage
Imagick::transformImage
Imagick sınıfı
PHP Manual

Imagick::__toString

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::__toString — Returns the image as a string.

Açıklama

string Imagick::__toString ( void )

Returns the current image as string. This will only return a single image; it should not be used for Imagick objects that contain multiple images e.g. an animated GIF or PDF with multiple pages.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the string content on success or an empty string on failure.

Ayrıca Bakınız

  • Imagick::getImageBlob() - Resim dizisini ber ikil dizge olarak döndürür
  • Imagick::getImagesBlob() - Tüm resim dizilerini bir ikil dizge olarak döndürür
Imagick::tintImage
Imagick::transformImage
Imagick sınıfı


Budama miktarını ve resim geometrisini ayarlamanın uygun yolu

Imagick::__toString
Imagick::transformImageColorspace
Imagick sınıfı
PHP Manual

Imagick::transformImage

(PECL imagick 2.0.0)

Imagick::transformImage — Budama miktarını ve resim geometrisini ayarlamanın uygun yolu

Açıklama

Imagick Imagick::transformImage ( string $budama , string $geometri )

Birer dizge olarak budama miktarını ve resim geometrisini ayarlamak için uygun bir yol. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.2.9 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

budama

Resmin budanan parçasının geometrisini tanımlayan bir dizge.

geometri

Resmin budanmış halinin geometrisini tanımlayan bir dizge.

Dönen Değerler

Başarı durumunda TRUE döner.

Örnekler

Örnek 1 Imagick::transformImage() örneği

Bu örnekte 100x100 siyah bir resim elde edilmektedir.

<?php
$image = new Imagick();
$image->newImage(300, 200, "black");
$new_image = $image->transformImage("100x100", "100x100");
$new_image->writeImage('test_out.jpg');
?>

Ayrıca Bakınız

  • Imagick::adaptiveBlurImage() - Resmi uyarlamalı olarak bulanıklaştırır
  • Imagick::motionBlurImage() - Hareket bulanıklığını taklit eder
  • Imagick::radialBlurImage() - Bir resme dairesel bulanıklık uygular
  • Imagick::cropImage() - Resmin bir bölgesini çıkarır
  • Imagick::resizeImage() - Bir resmi boyutlandırır
  • Imagick::thumbnailImage() - Resmin boyutlarını değiştirir

Imagick::__toString
Imagick::transformImageColorspace
Imagick sınıfı


Transforms an image to a new colorspace.

Imagick::transformImage
Imagick::transparentPaintImage
Imagick sınıfı
PHP Manual

Imagick::transformImageColorspace

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::transformImageColorspace — Transforms an image to a new colorspace.

Açıklama

bool Imagick::transformImageColorspace ( int $colorspace )

Transforms an image to a new colorspace.

Değiştirgeler

colorspace

The colorspace the image should be transformed to, one of the COLORSPACE constants e.g. Imagick::COLORSPACE_CMYK.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Imagick::transformImageColorspace() example

Transforms an image to a new colorspace, and then extracts a single channel so that the individual channel values can be viewed.

<?php
function transformImageColorspace($imagePath, $colorSpace, $channel) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->transformimagecolorspace($colorSpace);
    //channel should be one of the channel constants e.g. \Imagick::CHANNEL_BLUE
    $imagick->separateImageChannel($channel);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}
?>

Ayrıca Bakınız

  • Imagick::setColorSpace() - Set colorspace

Örnekler

Örnek 2 Imagick::transformImageColorspace()

<?php
function transformImageColorspace($imagePath, $colorSpace, $channel) {
    $imagick = new \Imagick(realpath($imagePath));
    $imagick->transformimagecolorspace($colorSpace);
    $imagick->separateImageChannel($channel);
    header("Content-Type: image/jpg");
    echo $imagick->getImageBlob();
}

?>

Imagick::transformImage
Imagick::transparentPaintImage
Imagick sınıfı


Pikselleri şeffaflaştırır

Imagick::transformImageColorspace
Imagick::transposeImage
Imagick sınıfı
PHP Manual

Imagick::transparentPaintImage

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::transparentPaintImage — Pikselleri şeffaflaştırır

Açıklama

bool Imagick::transparentPaintImage ( mixed $hedef , float $şeffaflık , float $benzerlik , bool $ters )

hedef renkteki pikselleri şeffaflaştırır. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.3.8 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

hedef

Şeffaf yapılacak renk.

şeffaflık

Şeffaflık derecesi: 1.0 tamamen mat, 0.0 tamamen şeffaf.

benzerlik

Renkler arasındaki azami benzerlik. Örneğin bu değere 10 atarsanız, renk kırmızı ise ve kırmızının koyulukları 100 ve 102 ise bu iki renk aynı kabul edilir.

ters

TRUE belirtilirse hedef renkle eşleşmeyen renkler şeffaflaştırılır.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::transformImageColorspace
Imagick::transposeImage
Imagick sınıfı


Resmin düşeydeki yansımasını oluşturur

Imagick::transparentPaintImage
Imagick::transverseImage
Imagick sınıfı
PHP Manual

Imagick::transposeImage

(PECL imagick 2.0.0)

Imagick::transposeImage — Resmin düşeydeki yansımasını oluşturur

Açıklama

bool Imagick::transposeImage ( void )

Pikselleri 90 derece döndürerek ve x eksenine göre yansıtarak resmin düşeydeki yansımasını oluşturur. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.2.9 veya sonraki bir sürümü kuruluysa kullanılabilir.

Dönen Değerler

Başarı durumunda TRUE döner.

Ayrıca Bakınız

  • Imagick::transverseImage() - Resmin yataydaki yansımasını oluşturur

Imagick::transparentPaintImage
Imagick::transverseImage
Imagick sınıfı


Resmin yataydaki yansımasını oluşturur

Imagick::transposeImage
Imagick::trimImage
Imagick sınıfı
PHP Manual

Imagick::transverseImage

(PECL imagick 2.0.0)

Imagick::transverseImage — Resmin yataydaki yansımasını oluşturur

Açıklama

bool Imagick::transverseImage ( void )

Pikselleri 270 derece döndürerek ve y eksenine göre yansıtarak resmin yataydaki yansımasını oluşturur. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.2.9 veya sonraki bir sürümü kuruluysa kullanılabilir.

Dönen Değerler

Başarı durumunda TRUE döner.

Ayrıca Bakınız

  • Imagick::transposeImage() - Resmin düşeydeki yansımasını oluşturur

Imagick::transposeImage
Imagick::trimImage
Imagick sınıfı


Resmin kenarlarını siler

Imagick::transverseImage
Imagick::uniqueImageColors
Imagick sınıfı
PHP Manual

Imagick::trimImage

(PECL imagick 2.0.0)

Imagick::trimImage — Resmin kenarlarını siler

Açıklama

bool Imagick::trimImage ( float $benzerlik )

Artalan rengi olarak resmin kenarlarını siler. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.2.9 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

benzerlik

Renkler arasındaki azami benzerlik. Örneğin bu değere 10 atarsanız, renk kırmızı ise ve kırmızının koyulukları 100 ve 102 ise bu iki renk aynı kabul edilir. Öntanımlı olarak hedefin belli bir piksel rengi ile tam olarak eşleşmesi gerekir. Ancak, çoğu durumda iki renk arasında küçük bir fark vardır. benzerlik değiştirgesi iki rengin aynı kabul edilebilmesi için ne kadarlık bir farkın kabul edilebilir olduğunu belirler. Bu değiştirge tanecik aralığında bir değişimi ifade eder.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Örnekler

Örnek 1 - Imagick::trimImage() örneği

Resmin kenarlarını kırpıp tarayıcıda gösterelim.

<?php
/* Bir resmi okuyarak nesnemizi oluşturalım */
$im = new Imagick("image.jpg");

/* Resmi kırpalım. */
$im->trimImage(0);

/* ve çıktılayalım */
header("Content-Type: image/" . $im->getImageFormat());
echo $im;
?>

Ayrıca Bakınız

  • Imagick::getQuantumDepth() - Parçacık derinliğini döndürür
  • Imagick::getQuantumRange() - Imagick parçacık aralığını döndürür

Imagick::transverseImage
Imagick::uniqueImageColors
Imagick sınıfı


Biri dışında tüm piksel renklerini iptal eder

Imagick::trimImage
Imagick::unsharpMaskImage
Imagick sınıfı
PHP Manual

Imagick::uniqueImageColors

(PECL imagick 2.0.0)

Imagick::uniqueImageColors — Biri dışında tüm piksel renklerini iptal eder

Açıklama

bool Imagick::uniqueImageColors ( void )

Biri dışında tüm piksel renklerini iptal eder. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.2.9 veya sonraki bir sürümü kuruluysa kullanılabilir.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::trimImage
Imagick::unsharpMaskImage
Imagick sınıfı


Resmi netleştirir

Imagick::uniqueImageColors
Imagick::valid
Imagick sınıfı
PHP Manual

Imagick::unsharpMaskImage

(PECL imagick 2.0.0)

Imagick::unsharpMaskImage — Resmi netleştirir

Açıklama

bool Imagick::unsharpMaskImage ( float $yarıçap , float $sapma , float $miktar , float $eşik [, int $kanal = Imagick::CHANNEL_ALL ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmi netleştirir. Yarıçap ve standart sapması belirtilen bir Gauss işleci ile resim evriştirilir. Makul sonuçlar elde etmek için yarıçap standart sapmadan büyük olmalıdır. yarıçap olarak 0 verirseniz Imagick::unsharpMaskImage() size uygun bir yarıçap seçecektir.

Değiştirgeler

yarıçap

sapma

Standart sapma.

miktar

eşik

kanal

Normalde kanal türü sabitlerinden biri, ancak bitsel işleçler kullanılarak birden fazla kanal belirtilebilir. Imagick::CHANNEL_ALL öntanımlıdır.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Imagick::uniqueImageColors
Imagick::valid
Imagick sınıfı


Imagick nesnesinin geçerli olup olmadığını sınar

Imagick::unsharpMaskImage
Imagick::vignetteImage
Imagick sınıfı
PHP Manual

Imagick::valid

(PECL imagick 2.0.0)

Imagick::valid — Imagick nesnesinin geçerli olup olmadığını sınar

Açıklama

bool Imagick::valid ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Imagick nesnesinin geçerli olup olmadığını sınar.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::unsharpMaskImage
Imagick::vignetteImage
Imagick sınıfı


Resme bir nakış süzgeci uygular

Imagick::valid
Imagick::waveImage
Imagick sınıfı
PHP Manual

Imagick::vignetteImage

(PECL imagick 2.0.0)

Imagick::vignetteImage — Resme bir nakış süzgeci uygular

Açıklama

bool Imagick::vignetteImage ( float $siyahNokta , float $beyazNokta , int $x , int $y )

Resmin kenarlarını nakış tarzında yumuşatır. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.2.9 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

siyahNokta

Siyah nokta.

beyazNokta

Beyaz nokta.

x

Elipsin X konumu.

y

Elipsin Y konumu.

Dönen Değerler

Başarı durumunda TRUE döner.

Ayrıca Bakınız

  • Imagick::waveImage() - Resme bir dalga süzgeci uygular
  • Imagick::swirlImage() - Resmin merkezine yakın pikselleri girdap gibi döndürür

Imagick::valid
Imagick::waveImage
Imagick sınıfı


Resme bir dalga süzgeci uygular

Imagick::vignetteImage
Imagick::whiteThresholdImage
Imagick sınıfı
PHP Manual

Imagick::waveImage

(PECL imagick 2.0.0)

Imagick::waveImage — Resme bir dalga süzgeci uygular

Açıklama

bool Imagick::waveImage ( float $genlik , float $dalga_boyu )

Resme bir dalga süzgeci uygular. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.2.9 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

genlik

Dalganın genliği.

dalga_boyu

Dalga uzunluğu.

Dönen Değerler

Başarı durumunda TRUE döner.

Hatalar/İstisnalar

Hata durumunda bir ImagickException istisnası oluşur.

Ayrıca Bakınız

  • Imagick::solarizeImage() - Resme uzun pozlama etkisi uygular
  • Imagick::oilpaintImage() - Yağlı boya resmi taklit eder
  • Imagick::embossImage() - Üç boyutluluk etkisi vermek için resmi gri tonlamaya dönüştürür
  • Imagick::addNoiseImage() - Resme rasgele gürültü ekler
  • Imagick::swirlImage() - Resmin merkezine yakın pikselleri girdap gibi döndürür

Imagick::vignetteImage
Imagick::whiteThresholdImage
Imagick sınıfı


Eşiğin üstündeki tüm piksellerin rengini beyaza zorlar

Imagick::waveImage
Imagick::writeImage
Imagick sınıfı
PHP Manual

Imagick::whiteThresholdImage

(PECL imagick 2.0.0)

Imagick::whiteThresholdImage — Eşiğin üstündeki tüm piksellerin rengini beyaza zorlar

Açıklama

bool Imagick::whiteThresholdImage ( mixed $eşik )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Eşiğin üzerindeki piksellerin tümünü beyaza boyamaya çalışması ve eşiğin altında kalan renklere hiç dokunmaması dışında Imagick::ThresholdImage() yöntemine benzer.

Değiştirgeler

eşik

Dönen Değerler

Başarı durumunda TRUE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
2.1.0 | Değiştirge olarak bir rengi ifade eden bir dizgenin belirtilebilmesi sağlandı. Önceki sürümlerde sadece bir ImagickPixel nesnesi belirtmeye izin verilirdi.

Imagick::waveImage
Imagick::writeImage
Imagick sınıfı


Resmi belirtilen dosyaya yazar

Imagick::whiteThresholdImage
Imagick::writeImageFile
Imagick sınıfı
PHP Manual

Imagick::writeImage

(PECL imagick 0.9.0-0.9.9)

Imagick::writeImage — Resmi belirtilen dosyaya yazar

Açıklama

bool Imagick::writeImage ([ string $dosya ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmi belirtilen dosyaya yazar. dosya olarak NULL verilmişse resim, Imagick::ReadImage() veya Imagick::SetImageFilename() ile belirlenen dosyaya yazılır.

Değiştirgeler

dosya

Resmin yazılacağı dosyanın yolu.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::whiteThresholdImage
Imagick::writeImageFile
Imagick sınıfı


Bir resmi belirtilen dosya tanıtıcısına yazar

Imagick::writeImage
Imagick::writeImages
Imagick sınıfı
PHP Manual

Imagick::writeImageFile

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::writeImageFile — Bir resmi belirtilen dosya tanıtıcısına yazar

Açıklama

bool Imagick::writeImageFile ( resource $dt )

Resmi belirtilen dosya tanıtıcısına yazar. Dosya tanıtıcısı fopen() gibi bir işlevle açılmış olmalıdır. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.3.6 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

dt

Resmin yazılacağı dosya tanıtıcısı.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::writeImage
Imagick::writeImages
Imagick sınıfı


Bir resmi veya resim kümesini dosyaya yazar

Imagick::writeImageFile
Imagick::writeImagesFile
Imagick sınıfı
PHP Manual

Imagick::writeImages

(PECL imagick 0.9.0-0.9.9)

Imagick::writeImages — Bir resmi veya resim kümesini dosyaya yazar

Açıklama

bool Imagick::writeImages ( string $dosya , bool $bitişik )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bir resmi veya resim kümesini belirtilen dosyaya yazar.

Değiştirgeler

dosya

Resmin yazılacağı dosyanın yolu.

bitişik

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::writeImageFile
Imagick::writeImagesFile
Imagick sınıfı


Resim karelerini bir dosya tanıtıcısına yazar

Imagick::writeImages
ImagickDraw sınıfı
Imagick sınıfı
PHP Manual

Imagick::writeImagesFile

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Imagick::writeImagesFile — Resim karelerini bir dosya tanıtıcısına yazar

Açıklama

bool Imagick::writeImagesFile ( resource $dt )

Tüm resim karelerini belirtiler dosya tanıtıcısına yazar. Bu işlevi, canlandırmalı GIF'leri ve diğer çok kareli resimleri açık bir dosya tanıtıcısına yazmak için kullanabilirsiniz. Bu yöntem, derleme sırasında ImageMagick kütüphanesinin 6.3.6 veya sonraki bir sürümü kuruluysa kullanılabilir.

Değiştirgeler

dt

Resimlerin yazılacağı dosya tanıtıcısı.

Dönen Değerler

Başarı durumunda TRUE döner.

Imagick::writeImages
ImagickDraw sınıfı
Imagick sınıfı


ImagickDraw sınıfı

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Sınıf Sözdizimi

ImagickDraw {
bool affine ( array $matris )
bool annotation ( float $x , float $y , string $metin )
bool arc ( float $sx , float $sy , float $ex , float $ey , float $sd , float $ed )
bool bezier ( array $noktalar )
bool circle ( float $ox , float $oy , float $px , float $py )
bool clear ( void )
ImagickDraw clone ( void )
bool color ( float $x , float $y , int $boyamaYöntemi )
bool comment ( string $açıklama )
bool composite ( int $işleç , float $x , float $y , float $genişlik , float $yükseklik , Imagick $resim )
ImagickDraw __construct ( void )
bool destroy ( void )
bool ellipse ( float $ox , float $oy , float $rx , float $ry , float $başlangıç , float $bitiş )
string getClipPath ( void )
int getClipRule ( void )
int getClipUnits ( void )
ImagickPixel getFillColor ( void )
float getFillOpacity ( void )
int getFillRule ( void )
string getFont ( void )
string getFontFamily ( void )
float getFontSize ( void )
public int getFontStretch ( void )
int getFontStyle ( void )
int getFontWeight ( void )
int getGravity ( void )
bool getStrokeAntialias ( void )
ImagickPixel getStrokeColor ( ImagickPixel $vurgu_rengi )
array getStrokeDashArray ( void )
float getStrokeDashOffset ( void )
int getStrokeLineCap ( void )
int getStrokeLineJoin ( void )
int getStrokeMiterLimit ( void )
float getStrokeOpacity ( void )
float getStrokeWidth ( void )
int getTextAlignment ( void )
bool getTextAntialias ( void )
int getTextDecoration ( void )
string getTextEncoding ( void )
public float getTextInterlineSpacing ( void )
public float getTextInterwordSpacing ( void )
public float getTextKerning ( void )
ImagickPixel getTextUnderColor ( void )
string getVectorGraphics ( void )
bool line ( float $bx , float $by , float $sx , float $sy )
bool matte ( float $x , float $y , int $boyamaYöntemi )
bool pathClose ( void )
bool pathCurveToAbsolute ( float $x1 , float $y1 , float $x2 , float $y2 , float $x , float $y )
bool pathCurveToQuadraticBezierAbsolute ( float $x1 , float $y1 , float $x , float $y )
bool pathCurveToQuadraticBezierRelative ( float $x1 , float $y1 , float $x , float $y )
bool pathCurveToQuadraticBezierSmoothAbsolute ( float $x , float $y )
bool pathCurveToQuadraticBezierSmoothRelative ( float $x , float $y )
bool pathCurveToRelative ( float $x1 , float $y1 , float $x2 , float $y2 , float $x , float $y )
bool pathCurveToSmoothAbsolute ( float $x2 , float $y2 , float $x , float $y )
bool pathCurveToSmoothRelative ( float $x2 , float $y2 , float $x , float $y )
bool pathEllipticArcAbsolute ( float $rx , float $ry , float $x_ekseni_açısı , bool $büyük_yay , bool $saat_yönü , float $x , float $y )
bool pathEllipticArcRelative ( float $rx , float $ry , float $x_ekseni_açısı , bool $büyük_yay , bool $saat_yönü , float $x , float $y )
bool pathFinish ( void )
bool pathLineToAbsolute ( float $x , float $y )
bool pathLineToHorizontalAbsolute ( float $x )
bool pathLineToHorizontalRelative ( float $x )
bool pathLineToRelative ( float $x , float $y )
bool pathLineToVerticalAbsolute ( float $y )
bool pathLineToVerticalRelative ( float $y )
bool pathMoveToAbsolute ( float $x , float $y )
bool pathMoveToRelative ( float $x , float $y )
bool pathStart ( void )
bool point ( float $x , float $y )
bool polygon ( array $koordinatlar )
bool polyline ( array $koordinatlar )
bool pop ( void )
bool popClipPath ( void )
bool popDefs ( void )
bool popPattern ( void )
bool push ( void )
bool pushClipPath ( string $yalıtım_maskesi_kimliği )
bool pushDefs ( void )
bool pushPattern ( string $örüntü_kimliği , float $x , float $y , float $genişlik , float $yükseklik )
bool rectangle ( float $x1 , float $y1 , float $x2 , float $y2 )
bool render ( void )
public void resetVectorGraphics ( void )
bool rotate ( float $açı )
bool roundRectangle ( float $x1 , float $y1 , float $x2 , float $y2 , float $rx , float $ry )
bool scale ( float $x , float $y )
bool setClipPath ( string $yalıtım_maskesi )
bool setClipRule ( int $dolgu_kuralı )
bool setClipUnits ( int $yalıtım_birimleri )
bool setFillAlpha ( float $şeffaflık )
bool setFillColor ( ImagickPixel $dolgu_rengi )
bool setFillOpacity ( float $matlık )
bool setFillPatternURL ( string $dolgu_adresi )
bool setFillRule ( int $dolgu_kuralı )
bool setFont ( string $yazıtipi_adı )
bool setFontFamily ( string $yazıtipi_ailesi )
bool setFontSize ( float $punto )
bool setFontStretch ( int $gerginlik )
bool setFontStyle ( int $tarz )
bool setFontWeight ( int $kalınlık )
bool setGravity ( int $çekimYönü )
public void setResolution ( string $x_resolution , string $y_resolution )
bool setStrokeAlpha ( float $şeffaflık )
bool setStrokeAntialias ( bool $vurguyu_yumuşat )
bool setStrokeColor ( ImagickPixel $vurgu_rengi )
bool setStrokeDashArray ( array $tireDizisi )
bool setStrokeDashOffset ( float $tire_başlangıcı )
bool setStrokeLineCap ( int $uçTürü )
bool setStrokeLineJoin ( int $eklemTürü )
bool setStrokeMiterLimit ( int $gönyeSınırı )
bool setStrokeOpacity ( float $vurgu_matlığı )
bool setStrokePatternURL ( string $örüntü_adresi )
bool setStrokeWidth ( float $vurgu_genişliği )
bool setTextAlignment ( int $hizalama )
bool setTextAntialias ( bool $yumuşat )
bool setTextDecoration ( int $süs )
bool setTextEncoding ( string $karküm )
public void setTextInterlineSpacing ( float $spacing )
public void setTextInterwordSpacing ( float $spacing )
public void setTextKerning ( float $kerning )
bool setTextUnderColor ( ImagickPixel $artalan )
bool setVectorGraphics ( string $xml )
bool setViewbox ( int $x1 , int $y1 , int $x2 , int $y2 )
bool skewX ( float $derece )
bool skewY ( float $derece )
bool translate ( float $x , float $y )
}

İçindekiler

  • ImagickDraw::affine — Geçerli homojen koordinatlar matrisini ayarlar
  • ImagickDraw::annotation — Resmin üzerine bir metin çizer
  • ImagickDraw::arc — Bir yay çizer
  • ImagickDraw::bezier — Bir Bezier eğrisi çizer
  • ImagickDraw::circle — Bir daire çizer
  • ImagickDraw::clear — ImagickDraw nesnesini temizler
  • ImagickDraw::clone — Belirtilen ImagickDraw nesnesinin tam bir kopyasını yapar
  • ImagickDraw::color — Bir resmi boyar
  • ImagickDraw::comment — Bir yöney çıktı akımına bir açıklama ekler
  • ImagickDraw::composite — Bir resmi geçerli resimle bileştirir
  • ImagickDraw::__construct — ImagickDraw kurucusu
  • ImagickDraw::destroy — ImagickDraw yıkıcısı
  • ImagickDraw::ellipse — Resmin üzerine bir elips çizer
  • ImagickDraw::getClipPath — Geçerli yalıtım maskesi kimliğini döndürür
  • ImagickDraw::getClipRule — Yalıtım maskesi tarafından kullanılan çokgen dolgu kuralını döndürür
  • ImagickDraw::getClipUnits — Yalıtım maskesi birimlerinin yorumunu döndürür
  • ImagickDraw::getFillColor — Dolgu rengini döndürür
  • ImagickDraw::getFillOpacity — Çizimde kullanılan matlık değerini döndürür
  • ImagickDraw::getFillRule — Geçerli dolgu kuralını döndürür
  • ImagickDraw::getFont — Geçerli yazı tipini döndürür
  • ImagickDraw::getFontFamily — Yazı tipi ailesini döndürür
  • ImagickDraw::getFontSize — Yazı tipi yüksekliğini döndürür
  • ImagickDraw::getFontStretch — Description
  • ImagickDraw::getFontStyle — Yazı tipi tarzını döndürür
  • ImagickDraw::getFontWeight — Yazı tipi kalınlığını döndürür
  • ImagickDraw::getGravity — Metnin çekim yönünü döndürür
  • ImagickDraw::getStrokeAntialias — Nesne dış hatlarını çizmekte kullanılan vurgu yumuşatması ayarını döndürür
  • ImagickDraw::getStrokeColor — Nesne dış hatlarını çizmekte kullanılan vurgunun rengini döndürür
  • ImagickDraw::getStrokeDashArray — Kesikli çizgi örüntüsünü oluşturmakta kullanılan tireleri ve boşlukları içeren bir dizi döndürür
  • ImagickDraw::getStrokeDashOffset — Kesikli çizgi örüntüsünde tire başlangıcını döndürür
  • ImagickDraw::getStrokeLineCap — Kalın çizgilerdeki çizgi uçlarının şeklini döndürür
  • ImagickDraw::getStrokeLineJoin — Kalın çizgi ekleminin şeklini döndürür
  • ImagickDraw::getStrokeMiterLimit — Gönyenin kesildiği sınırı döndürür
  • ImagickDraw::getStrokeOpacity — Nesne dış hatlarını çizmekte kullanılan vurgunun matlığını döndürür
  • ImagickDraw::getStrokeWidth — Nesne dış hatlarını çizmekte kullanılan vurgu genişliğini döndürür
  • ImagickDraw::getTextAlignment — Metin hizalamasını döndürür
  • ImagickDraw::getTextAntialias — Geçerli metin yumuşatma ayarını döndürür
  • ImagickDraw::getTextDecoration — Metin süslemesi türünü döndürür
  • ImagickDraw::getTextEncoding — Metin çizerken kullanılan karakter kümesi ismini döndürür
  • ImagickDraw::getTextInterlineSpacing — Description
  • ImagickDraw::getTextInterwordSpacing — Description
  • ImagickDraw::getTextKerning — Description
  • ImagickDraw::getTextUnderColor — Metin artalanındaki rengi döndürür
  • ImagickDraw::getVectorGraphics — Yöney çizgesini içeren bir dizge döner
  • ImagickDraw::line — Bir çizgi çizer
  • ImagickDraw::matte — Resmin matlık kanalını boyar
  • ImagickDraw::pathClose — Geçerli hatta son elemanı ekler
  • ImagickDraw::pathCurveToAbsolute — Üçüncü dereceden bir Bezier eğrisi çizer
  • ImagickDraw::pathCurveToQuadraticBezierAbsolute — İkinci dereceden bir Bezier eğrisi çizer
  • ImagickDraw::pathCurveToQuadraticBezierRelative — İkinci dereceden bir Bezier eğrisi çizer
  • ImagickDraw::pathCurveToQuadraticBezierSmoothAbsolute — İkinci dereceden bir Bezier eğrisi çizer
  • ImagickDraw::pathCurveToQuadraticBezierSmoothRelative — İkinci dereceden bir Bezier eğrisi çizer
  • ImagickDraw::pathCurveToRelative — Üçüncü dereceden bir Bezier eğrisi çizer
  • ImagickDraw::pathCurveToSmoothAbsolute — Üçüncü dereceden bir Bezier eğrisi çizer
  • ImagickDraw::pathCurveToSmoothRelative — Üçüncü dereceden bir Bezier eğrisi çizer
  • ImagickDraw::pathEllipticArcAbsolute — Eliptik bir yay çizer
  • ImagickDraw::pathEllipticArcRelative — Bir eliptik yay çizer
  • ImagickDraw::pathFinish — Geçerli hattı sonlandırır
  • ImagickDraw::pathLineToAbsolute — Draws a line path
  • ImagickDraw::pathLineToHorizontalAbsolute — Yatay bir hat elemanı çizer
  • ImagickDraw::pathLineToHorizontalRelative — Yatay bir hat elemanı çizer
  • ImagickDraw::pathLineToRelative — Bir hat elemanı çizer
  • ImagickDraw::pathLineToVerticalAbsolute — Düşey bir hat elemanı çizer
  • ImagickDraw::pathLineToVerticalRelative — Bir düşey hat elemanı çizer
  • ImagickDraw::pathMoveToAbsolute — Yeni bir hat elemanı başlatır
  • ImagickDraw::pathMoveToRelative — Yeni bir hat elemanı başlatır
  • ImagickDraw::pathStart — Bir hat çizim listesinin başlangıcını bildirir
  • ImagickDraw::point — Bir nokta çizer
  • ImagickDraw::polygon — Bir çokgen çizer
  • ImagickDraw::polyline — Bir çoklu çizgi çizer
  • ImagickDraw::pop — Yığıttaki geçerli ImagickDraw nesnesini silip sonraki nesneyi döndürür
  • ImagickDraw::popClipPath — Bir yalıtım maskesi tanımını sonlandırır
  • ImagickDraw::popDefs — Bir tanım listesini sonlandırır
  • ImagickDraw::popPattern — Bir örüntü tanımını sonlandırır
  • ImagickDraw::push — Geçerli ImagickDraw nesnesini kopyalar ve yığıta basar
  • ImagickDraw::pushClipPath — Bir yalıtım maskesi tanımı başlatır
  • ImagickDraw::pushDefs — Bundan sonra çağrılacak yöntemlerin ImagickDraw::popDefs yöntemi çağrılıncaya kadar isimli elemanları tanımlayacağını belirtir
  • ImagickDraw::pushPattern — Bundan sonra çağrılacak yöntemlerin ImagickDraw::popPattern yöntemi çağrılıncaya kadar bir isimli örüntüyü tanımlayacağını belirtir
  • ImagickDraw::rectangle — Bir dikdörtgen çizer
  • ImagickDraw::render — Evvelce verilmiş tüm çizim komutlarını resme uygular
  • ImagickDraw::resetVectorGraphics — Description
  • ImagickDraw::rotate — Geçerli koordinat sistemini belirtilen açıda döndürür
  • ImagickDraw::roundRectangle — Köşeleri yuvarlatılmış bir dikdörtgen çizer
  • ImagickDraw::scale — Enboy oranını ayarlar
  • ImagickDraw::setClipPath — Bir isimli yalıtım maskesini resimle ilişkilendirir
  • ImagickDraw::setClipRule — Yalıtım maskesi tarafından kullanılacak çokgen dolgu kuralını belirler
  • ImagickDraw::setClipUnits — Yalıtım maskesi birimlerinin yorumunu belirler
  • ImagickDraw::setFillAlpha — Dolgu dokusu veya dolgu rengi için kullanılacak şeffaflığı belirler
  • ImagickDraw::setFillColor — Dolgulu nesnelerin çiziminde kullanılacak dolgu rengini belirler
  • ImagickDraw::setFillOpacity — Dolgu dokusu veya dolgu rengi için kullanılacak matlığı belirler
  • ImagickDraw::setFillPatternURL — Nesne dolgu örüntüsü için kullanılacak adresi belirler
  • ImagickDraw::setFillRule — Çokgen çizerken kullanılacak dolgu kuralını belirler
  • ImagickDraw::setFont — Metni çizerken kullanılacak yazı tipini tam belirtimiyle belirler
  • ImagickDraw::setFontFamily — Yazı tipi ailesini belirler
  • ImagickDraw::setFontSize — Yazı tipi yüksekliğini belirler
  • ImagickDraw::setFontStretch — Yazı tipinin karakter genişliğini belirler
  • ImagickDraw::setFontStyle — Yazı tipi tarzını belirler
  • ImagickDraw::setFontWeight — Yazı tipi kalınlığını belirler
  • ImagickDraw::setGravity — Metnin çekim yönünü belirler
  • ImagickDraw::setResolution — Description
  • ImagickDraw::setStrokeAlpha — Vurgulu nesne dış hatlarının şeffaflığını tanımlar
  • ImagickDraw::setStrokeAntialias — Vurgulu dış hatlara kenar yumuşatma uygulanıp uygulanmayacağını denetler
  • ImagickDraw::setStrokeColor — Nesne dış hatlarını vurgulamakta kullanılacak rengi tanımlar
  • ImagickDraw::setStrokeDashArray — Kesikli çizgi örüntüsünde tireleri ve boşlukları belirler
  • ImagickDraw::setStrokeDashOffset — Kesikli çizgi örüntüsünde tire başlangıcını belirler
  • ImagickDraw::setStrokeLineCap — Kalın çizgilerde çizgi uçlarının şeklini belirler
  • ImagickDraw::setStrokeLineJoin — Kalın çizgi ekleminin şeklini belirler
  • ImagickDraw::setStrokeMiterLimit — Gönyenin kesildiği sınırı tanımlar
  • ImagickDraw::setStrokeOpacity — Vurgulanmış nesne dış hatlarının matlığını tanımlar
  • ImagickDraw::setStrokePatternURL — Nesne dış hatlarının çiziminde kullanılacak örüntüyü tanımlar
  • ImagickDraw::setStrokeWidth — Nesne dış hatlarının çiziminde kullanılacak çizgi genişliğini tanımlar
  • ImagickDraw::setTextAlignment — Metni hizalar
  • ImagickDraw::setTextAntialias — Metne kenar yumuşatma uygulanıp uygulanmayacağını denetler
  • ImagickDraw::setTextDecoration — Bir karakter süslemesi tanımlar
  • ImagickDraw::setTextEncoding — Metin karakter kümesini tanımlar
  • ImagickDraw::setTextInterlineSpacing — Description
  • ImagickDraw::setTextInterwordSpacing — Description
  • ImagickDraw::setTextKerning — Description
  • ImagickDraw::setTextUnderColor — Metin çerçevesinin artalan rengini tanımlar
  • ImagickDraw::setVectorGraphics — Yöney çizgesini tanımlar
  • ImagickDraw::setViewbox — Tuval boyutunu uçtan uca tanımlar
  • ImagickDraw::skewX — Geçerli koordinat sistemini yatayda belirtilen açıda eğer
  • ImagickDraw::skewY — Geçerli koordinat sistemini düşeyde belirtilen açıda eğer
  • ImagickDraw::translate — Geçerli koordinat sisteminin başnoktasını değiştirir
Imagick::writeImagesFile
ImagickDraw::affine
ImageMagick


Geçerli homojen koordinatlar matrisini ayarlar

ImagickDraw sınıfı
ImagickDraw::annotation
ImagickDraw sınıfı
PHP Manual

ImagickDraw::affine

(PECL imagick 2.0.0)

ImagickDraw::affine — Geçerli homojen koordinatlar matrisini ayarlar

Açıklama

bool ImagickDraw::affine ( array $matris )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Belirtilen matrise göre homojen koordinatlar matrisini ayarlar.

Değiştirgeler

matris

Bir dizi olarak homojen koordinatlar matrisi (Affine matrix).

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw sınıfı
ImagickDraw::annotation
ImagickDraw sınıfı


Resmin üzerine bir metin çizer

ImagickDraw::affine
ImagickDraw::arc
ImagickDraw sınıfı
PHP Manual

ImagickDraw::annotation

(PECL imagick 2.0.0)

ImagickDraw::annotation — Resmin üzerine bir metin çizer

Açıklama

bool ImagickDraw::annotation ( float $x , float $y , string $metin )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin üzerine bir metin çizer.

Değiştirgeler

x

Metnin çizileceği yerin X koordinatı.

y

Metnin çizileceği yerin Y koordinatı.

metin

Resmin üzerine çizilecek metin.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::affine
ImagickDraw::arc
ImagickDraw sınıfı


Bir yay çizer

ImagickDraw::annotation
ImagickDraw::bezier
ImagickDraw sınıfı
PHP Manual

ImagickDraw::arc

(PECL imagick 2.0.0)

ImagickDraw::arc — Bir yay çizer

Açıklama

bool ImagickDraw::arc ( float $sx , float $sy , float $ex , float $ey , float $sd , float $ed )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resim üzerinde belirtilen çerçeveye başlangıç ve bitiş açıları verilen yayı çizer.

Değiştirgeler

sx

Çerçevenin sol üst köşesinin X konumu.

sy

Çerçevenin sol üst köşesinin Y konumu.

ex

Çerçevenin sağ alt köşesinin X konumu.

ey

Çerçevenin sağ alt köşesinin Y konumu.

sd

Yayın başlangıç açısı.

ed

Yayın bitiş açısı.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::annotation
ImagickDraw::bezier
ImagickDraw sınıfı


Bir Bezier eğrisi çizer

ImagickDraw::arc
ImagickDraw::circle
ImagickDraw sınıfı
PHP Manual

ImagickDraw::bezier

(PECL imagick 2.0.0)

ImagickDraw::bezier — Bir Bezier eğrisi çizer

Açıklama

bool ImagickDraw::bezier ( array $noktalar )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resim üzerine noktaları verilen Bezier eğrisini çizer.

Değiştirgeler

noktalar

Çok boyutlu bir dizi; örnek: array( array( 'x' => 1, 'y' => 2 ), array( 'x' => 3, 'y' => 4 ) )

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::arc
ImagickDraw::circle
ImagickDraw sınıfı


Bir daire çizer

ImagickDraw::bezier
ImagickDraw::clear
ImagickDraw sınıfı
PHP Manual

ImagickDraw::circle

(PECL imagick 2.0.0)

ImagickDraw::circle — Bir daire çizer

Açıklama

bool ImagickDraw::circle ( float $ox , float $oy , float $px , float $py )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin üzerine bir daire çizer.

Değiştirgeler

ox

Merkezin X koordinatı.

oy

Merkezin Y koordinatı.

px

Çember X koordinatı

py

Çember Y koordinatı

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::bezier
ImagickDraw::clear
ImagickDraw sınıfı


ImagickDraw nesnesini temizler

ImagickDraw::circle
ImagickDraw::clone
ImagickDraw sınıfı
PHP Manual

ImagickDraw::clear

(PECL imagick 2.0.0)

ImagickDraw::clear — ImagickDraw nesnesini temizler

Açıklama

bool ImagickDraw::clear ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ImagickDraw nesnesini verilmiş komutlardan temizleyip ayarları öntanımlı değerlerle sıfırlar.

Dönen Değerler

Temiz bir ImagickDraw nesnesi döner.

ImagickDraw::circle
ImagickDraw::clone
ImagickDraw sınıfı


Belirtilen ImagickDraw nesnesinin tam bir kopyasını yapar

ImagickDraw::clear
ImagickDraw::color
ImagickDraw sınıfı
PHP Manual

ImagickDraw::clone

(PECL imagick 2.0.0)

ImagickDraw::clone — Belirtilen ImagickDraw nesnesinin tam bir kopyasını yapar

Açıklama

ImagickDraw ImagickDraw::clone ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Belirtilen ImagickDraw nesnesinin tam bir kopyasını yapar.

Dönen Değerler

Bir ImagickDraw nesnesi döner.

ImagickDraw::clear
ImagickDraw::color
ImagickDraw sınıfı


Bir resmi boyar

ImagickDraw::clone
ImagickDraw::comment
ImagickDraw sınıfı
PHP Manual

ImagickDraw::color

(PECL imagick 2.0.0)

ImagickDraw::color — Bir resmi boyar

Açıklama

bool ImagickDraw::color ( float $x , float $y , int $boyamaYöntemi )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Geçerli dolgu rengini ve belirtilen boyama yöntemini kullanarak belirtilen konumdan başlayarak resmi boyar.

Değiştirgeler

x

Boyamanın başlayacağı X konumu.

y

Boyamanın başlayacağı Y konumu.

boyamaYöntemi

PAINT_ sabitlerinden biri.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::clone
ImagickDraw::comment
ImagickDraw sınıfı


Bir yöney çıktı akımına bir açıklama ekler

ImagickDraw::color
ImagickDraw::composite
ImagickDraw sınıfı
PHP Manual

ImagickDraw::comment

(PECL imagick 2.0.0)

ImagickDraw::comment — Bir yöney çıktı akımına bir açıklama ekler

Açıklama

bool ImagickDraw::comment ( string $açıklama )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bir yöney çıktı akımına belirtilen açıklamayı ekler.

Değiştirgeler

açıklama

Yöney çıktı akımına eklenecek açıklama dizgesi.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::color
ImagickDraw::composite
ImagickDraw sınıfı


Bir resmi geçerli resimle bileştirir

ImagickDraw::comment
ImagickDraw::__construct
ImagickDraw sınıfı
PHP Manual

ImagickDraw::composite

(PECL imagick 2.0.0)

ImagickDraw::composite — Bir resmi geçerli resimle bileştirir

Açıklama

bool ImagickDraw::composite ( int $işleç , float $x , float $y , float $genişlik , float $yükseklik , Imagick $resim )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Belirtilen birleştirme işlecini kullanarak belirtilen noktaya belirtilen boyutta belirtilen resmi geçerli resimle birleştirir.

Değiştirgeler

işleç

Birleştirme işleci sabitlerinden biri.

x

Sol üst köşenin yatay konumu.

y

Sol üst köşenin düşey konumu.

genişlik

Birleşik resmin genişliği,

yükseklik

Birleşik resmin yüksekliği.

resim

Birleştirilecek resmin alınacağı Imagick nesnesi.

Dönen Değerler

Başarı durumunda TRUE döner.

ImagickDraw::comment
ImagickDraw::__construct
ImagickDraw sınıfı


ImagickDraw kurucusu

ImagickDraw::composite
ImagickDraw::destroy
ImagickDraw sınıfı
PHP Manual

ImagickDraw::__construct

(PECL imagick 2.0.0)

ImagickDraw::__construct — ImagickDraw kurucusu

Açıklama

ImagickDraw ImagickDraw::__construct ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ImagickDraw kurucusu.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::composite
ImagickDraw::destroy
ImagickDraw sınıfı


ImagickDraw yıkıcısı

ImagickDraw::__construct
ImagickDraw::ellipse
ImagickDraw sınıfı
PHP Manual

ImagickDraw::destroy

(PECL imagick 2.0.0)

ImagickDraw::destroy — ImagickDraw yıkıcısı

Açıklama

bool ImagickDraw::destroy ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ImagickDraw nesnesi ile ilişkili tüm özkaynakları serbest bırakır.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::__construct
ImagickDraw::ellipse
ImagickDraw sınıfı


Resmin üzerine bir elips çizer

ImagickDraw::destroy
ImagickDraw::getClipPath
ImagickDraw sınıfı
PHP Manual

ImagickDraw::ellipse

(PECL imagick 2.0.0)

ImagickDraw::ellipse — Resmin üzerine bir elips çizer

Açıklama

bool ImagickDraw::ellipse ( float $ox , float $oy , float $rx , float $ry , float $başlangıç , float $bitiş )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Resmin üzerine bir elips çizer.

Değiştirgeler

ox

oy

rx

ry

başlangıç

bitiş

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::destroy
ImagickDraw::getClipPath
ImagickDraw sınıfı


Geçerli yalıtım maskesi kimliğini döndürür

ImagickDraw::ellipse
ImagickDraw::getClipRule
ImagickDraw sınıfı
PHP Manual

ImagickDraw::getClipPath

(PECL imagick 2.0.0)

ImagickDraw::getClipPath — Geçerli yalıtım maskesi kimliğini döndürür

Açıklama

string ImagickDraw::getClipPath ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Geçerli yalıtım maskesi kimliğini döndürür.

Dönen Değerler

Bir yalıtım maskesi yoksa FALSE aksi takdirde geçerli yalıtım maskesi kimliğini bir dizge olarak döndürür.

ImagickDraw::ellipse
ImagickDraw::getClipRule
ImagickDraw sınıfı


Yalıtım maskesi tarafından kullanılan çokgen dolgu kuralını döndürür

ImagickDraw::getClipPath
ImagickDraw::getClipUnits
ImagickDraw sınıfı
PHP Manual

ImagickDraw::getClipRule

(PECL imagick 2.0.0)

ImagickDraw::getClipRule — Yalıtım maskesi tarafından kullanılan çokgen dolgu kuralını döndürür

Açıklama

int ImagickDraw::getClipRule ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Yalıtım maskesi tarafından kullanılan çokgen dolgu kuralını döndürür.

Dönen Değerler

Dolgu kuralı sabitlerinden biri.

ImagickDraw::getClipPath
ImagickDraw::getClipUnits
ImagickDraw sınıfı


Yalıtım maskesi birimlerinin yorumunu döndürür

ImagickDraw::getClipRule
ImagickDraw::getFillColor
ImagickDraw sınıfı
PHP Manual

ImagickDraw::getClipUnits

(PECL imagick 2.0.0)

ImagickDraw::getClipUnits — Yalıtım maskesi birimlerinin yorumunu döndürür

Açıklama

int ImagickDraw::getClipUnits ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Yalıtım maskesi birimlerinin yorumunu döndürür.

Dönen Değerler

Başarı durumunda bir tamsayı döner.

ImagickDraw::getClipRule
ImagickDraw::getFillColor
ImagickDraw sınıfı


Dolgu rengini döndürür

ImagickDraw::getClipUnits
ImagickDraw::getFillOpacity
ImagickDraw sınıfı
PHP Manual

ImagickDraw::getFillColor

(PECL imagick 2.0.0)

ImagickDraw::getFillColor — Dolgu rengini döndürür

Açıklama

ImagickPixel ImagickDraw::getFillColor ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Dolgulu nesnelerin çiziminde kullanılan dolgu rengini döndürür.

Dönen Değerler

Bir ImagickPixel nesnesi.

ImagickDraw::getClipUnits
ImagickDraw::getFillOpacity
ImagickDraw sınıfı


Çizimde kullanılan matlık değerini döndürür

ImagickDraw::getFillColor
ImagickDraw::getFillRule
ImagickDraw sınıfı
PHP Manual

ImagickDraw::getFillOpacity

(PECL imagick 2.0.0)

ImagickDraw::getFillOpacity — Çizimde kullanılan matlık değerini döndürür

Açıklama

float ImagickDraw::getFillOpacity ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Dolgu dokusu veya dolgu rengi için kullanılan matlık değerini döndürür. Tam matlık değeri 1.0'dır.

Dönen Değerler

Matlık değerini bir gerçek sayı olarak döndürür.

ImagickDraw::getFillColor
ImagickDraw::getFillRule
ImagickDraw sınıfı


Geçerli dolgu kuralını döndürür

ImagickDraw::getFillOpacity
ImagickDraw::getFont
ImagickDraw sınıfı
PHP Manual

ImagickDraw::getFillRule

(PECL imagick 2.0.0)

ImagickDraw::getFillRule — Geçerli dolgu kuralını döndürür

Açıklama

int ImagickDraw::getFillRule ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Çokgen çizerken kullanılan dolgu kuralını döndürür.

Dönen Değerler

Dolgu kuralı sabitlerinden biri.

ImagickDraw::getFillOpacity
ImagickDraw::getFont
ImagickDraw sınıfı


Geçerli yazı tipini döndürür

ImagickDraw::getFillRule
ImagickDraw::getFontFamily
ImagickDraw sınıfı
PHP Manual

ImagickDraw::getFont

(PECL imagick 2.0.0)

ImagickDraw::getFont — Geçerli yazı tipini döndürür

Açıklama

string ImagickDraw::getFont ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Metin çizerken kullanılan yazı tipi adını bir dizge olarak döndürür.

Dönen Değerler

Başarı durumanda bir dizge yoksa FALSE döner.

ImagickDraw::getFillRule
ImagickDraw::getFontFamily
ImagickDraw sınıfı


Yazı tipi ailesini döndürür

ImagickDraw::getFont
ImagickDraw::getFontSize
ImagickDraw sınıfı
PHP Manual

ImagickDraw::getFontFamily

(PECL imagick 2.0.0)

ImagickDraw::getFontFamily — Yazı tipi ailesini döndürür

Açıklama

string ImagickDraw::getFontFamily ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Metin çizerken kullanılan yazı tipi ailesinin ismini döndürür.

Dönen Değerler

Yazı tipi ailesi belirlenmemişse FALSE, aksi takdirde yazı tipi ailesinin ismini içeren bir dizge döner.

ImagickDraw::getFont
ImagickDraw::getFontSize
ImagickDraw sınıfı


Yazı tipi yüksekliğini döndürür

ImagickDraw::getFontFamily
ImagickDraw::getFontStretch
ImagickDraw sınıfı
PHP Manual

ImagickDraw::getFontSize

(PECL imagick 2.0.0)

ImagickDraw::getFontSize — Yazı tipi yüksekliğini döndürür

Açıklama

float ImagickDraw::getFontSize ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Metin çizmekte kullanılan yazı tipi yüksekliğini punto olarak döndürür.

Dönen Değerler

ImagickDraw nesnesi ile ilişkilendirilmiş yazı tipinin yüksekliğini döndürür.

ImagickDraw::getFontFamily
ImagickDraw::getFontStretch
ImagickDraw sınıfı


Description

ImagickDraw::getFontSize
ImagickDraw::getFontStyle
ImagickDraw sınıfı
PHP Manual

ImagickDraw::getFontStretch

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

ImagickDraw::getFontStretch — Description

Açıklama

public int ImagickDraw::getFontStretch ( void )

Gets the font stretch to use when annotating with text. Returns a StretchType.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

ImagickDraw::getFontSize
ImagickDraw::getFontStyle
ImagickDraw sınıfı


Yazı tipi tarzını döndürür

ImagickDraw::getFontStretch
ImagickDraw::getFontWeight
ImagickDraw sınıfı
PHP Manual

ImagickDraw::getFontStyle

(PECL imagick 2.0.0)

ImagickDraw::getFontStyle — Yazı tipi tarzını döndürür

Açıklama

int ImagickDraw::getFontStyle ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Metin çizerken kullanılan yazı tipi tarzını döndürür

Dönen Değerler

Bir tarz belirlenmemişse 0, aksi takdirde ImagickDraw nesnesiyle ilişkilendirilen yazı tipi tarzı sabitlerinden biri döner.

ImagickDraw::getFontStretch
ImagickDraw::getFontWeight
ImagickDraw sınıfı


Yazı tipi kalınlığını döndürür

ImagickDraw::getFontStyle
ImagickDraw::getGravity
ImagickDraw sınıfı
PHP Manual

ImagickDraw::getFontWeight

(PECL imagick 2.0.0)

ImagickDraw::getFontWeight — Yazı tipi kalınlığını döndürür

Açıklama

int ImagickDraw::getFontWeight ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Metin çizerken kullanılan yazı tipi kalınlığını döndürür.

Dönen Değerler

Kalınlık belirlenmemişse 0, aksi takdirde bir tamsayı döner.

ImagickDraw::getFontStyle
ImagickDraw::getGravity
ImagickDraw sınıfı


Metnin çekim yönünü döndürür

ImagickDraw::getFontWeight
ImagickDraw::getStrokeAntialias
ImagickDraw sınıfı
PHP Manual

ImagickDraw::getGravity

(PECL imagick 2.0.0)

ImagickDraw::getGravity — Metnin çekim yönünü döndürür

Açıklama

int ImagickDraw::getGravity ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Metin yerleştirilirken kullanılan çekim yönünü döndürür.

Dönen Değerler

Çekim yönü belirlenmemişse 0, aksi takdirde çekim yönü sabitlerinden biri döner.

ImagickDraw::getFontWeight
ImagickDraw::getStrokeAntialias
ImagickDraw sınıfı


Nesne dış hatlarını çizmekte kullanılan vurgu yumuşatması ayarını döndürür

ImagickDraw::getGravity
ImagickDraw::getStrokeColor
ImagickDraw sınıfı
PHP Manual

ImagickDraw::getStrokeAntialias

(PECL imagick 2.0.0)

ImagickDraw::getStrokeAntialias — Nesne dış hatlarını çizmekte kullanılan vurgu yumuşatması ayarını döndürür

Açıklama

bool ImagickDraw::getStrokeAntialias ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Vurgu kenar yumuşatması ayarını döndürür. Vurgulu dış hatlara öntanımlı olarak kenar yumuşatması uygulanır. Yumuşatma iptal edildiğinde vurgulu kenar piksellerinin rengi belirlenirken vurgu ve tuval rengi parlaklık bakımından karşılaştırılır (eşikleme).

Dönen Değerler

Kenar yumuşatma etkinse TRUE değilse FALSE döner.

ImagickDraw::getGravity
ImagickDraw::getStrokeColor
ImagickDraw sınıfı


Nesne dış hatlarını çizmekte kullanılan vurgunun rengini döndürür

ImagickDraw::getStrokeAntialias
ImagickDraw::getStrokeDashArray
ImagickDraw sınıfı
PHP Manual

ImagickDraw::getStrokeColor

(PECL imagick 2.0.0)

ImagickDraw::getStrokeColor — Nesne dış hatlarını çizmekte kullanılan vurgunun rengini döndürür

Açıklama

ImagickPixel ImagickDraw::getStrokeColor ( ImagickPixel $vurgu_rengi )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Nesne dış hatlarını çizmekte kullanılan vurgunun rengini döndürür.

Değiştirgeler

vurgu_rengi

Dönen Değerler

Vurgunun rengini bir ImagickPixel nesnesi olarak döndürür.

ImagickDraw::getStrokeAntialias
ImagickDraw::getStrokeDashArray
ImagickDraw sınıfı


Kesikli çizgi örüntüsünü oluşturmakta kullanılan tireleri ve boşlukları içeren bir dizi döndürür

ImagickDraw::getStrokeColor
ImagickDraw::getStrokeDashOffset
ImagickDraw sınıfı
PHP Manual

ImagickDraw::getStrokeDashArray

(PECL imagick 2.0.0)

ImagickDraw::getStrokeDashArray — Kesikli çizgi örüntüsünü oluşturmakta kullanılan tireleri ve boşlukları içeren bir dizi döndürür

Açıklama

array ImagickDraw::getStrokeDashArray ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Kesikli çizgi örüntüsünü oluşturmakta kullanılan tireleri ve boşlukları içeren bir dizi döndürür.

Dönen Değerler

Dizi oluşturulmamışsa boş bir dizi, aksi takdirde tireleri ve boşlukları içeren bir dizi döndürür.

ImagickDraw::getStrokeColor
ImagickDraw::getStrokeDashOffset
ImagickDraw sınıfı


Kesikli çizgi örüntüsünde tire başlangıcını döndürür

ImagickDraw::getStrokeDashArray
ImagickDraw::getStrokeLineCap
ImagickDraw sınıfı
PHP Manual

ImagickDraw::getStrokeDashOffset

(PECL imagick 2.0.0)

ImagickDraw::getStrokeDashOffset — Kesikli çizgi örüntüsünde tire başlangıcını döndürür

Açıklama

float ImagickDraw::getStrokeDashOffset ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Kesikli çizgi örüntüsünde tire başlangıcını döndürür.

Dönen Değerler

Tire başlangıcı belirlenmemişse 0, aksi takdirde başlangıcı belirten bir gerçek sayı döner.

ImagickDraw::getStrokeDashArray
ImagickDraw::getStrokeLineCap
ImagickDraw sınıfı


Kalın çizgilerdeki çizgi uçlarının şeklini döndürür

ImagickDraw::getStrokeDashOffset
ImagickDraw::getStrokeLineJoin
ImagickDraw sınıfı
PHP Manual

ImagickDraw::getStrokeLineCap

(PECL imagick 2.0.0)

ImagickDraw::getStrokeLineCap — Kalın çizgilerdeki çizgi uçlarının şeklini döndürür

Açıklama

int ImagickDraw::getStrokeLineCap ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Kalın çizgilerdeki çizgi uçlarının şeklini döndürür.

Dönen Değerler

Uç şekli belirlenmemişse 0, aksi takdirde çizgi ucu sabitlerinden biri döner.

ImagickDraw::getStrokeDashOffset
ImagickDraw::getStrokeLineJoin
ImagickDraw sınıfı


Kalın çizgi ekleminin şeklini döndürür

ImagickDraw::getStrokeLineCap
ImagickDraw::getStrokeMiterLimit
ImagickDraw sınıfı
PHP Manual

ImagickDraw::getStrokeLineJoin

(PECL imagick 2.0.0)

ImagickDraw::getStrokeLineJoin — Kalın çizgi ekleminin şeklini döndürür

Açıklama

int ImagickDraw::getStrokeLineJoin ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Kalın çizgi eklemlerinin şeklini döndürür.

Dönen Değerler

Eklem şekli belirlenmemişse 0, aksi takdirde çizgi eklemi sabitlerinden biri döner.

ImagickDraw::getStrokeLineCap
ImagickDraw::getStrokeMiterLimit
ImagickDraw sınıfı


Gönyenin kesildiği sınırı döndürür

ImagickDraw::getStrokeLineJoin
ImagickDraw::getStrokeOpacity
ImagickDraw sınıfı
PHP Manual

ImagickDraw::getStrokeMiterLimit

(PECL imagick 2.0.0)

ImagickDraw::getStrokeMiterLimit — Gönyenin kesildiği sınırı döndürür

Açıklama

int ImagickDraw::getStrokeMiterLimit ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Gönyenin kesildiği sınırı döndürür. İki kalın çizgi keskin bir açı ile kesiştiğinde kesişim yeri gönye köşesi biçimini alacak şekilde çizgi fazlalıkları atılır. Bu gönye köşesini uzatmak mümkündür. Gönye sınırı ile gönye uzunluğunun çizgi genişliğine oranına bir sınırlama getirilir.

Dönen Değerler

Gönye sınırı belirlenmemişse 0, aksi takdirde gönye sınırını belirten bir tamsayı döner.

ImagickDraw::getStrokeLineJoin
ImagickDraw::getStrokeOpacity
ImagickDraw sınıfı


Nesne dış hatlarını çizmekte kullanılan vurgunun matlığını döndürür

ImagickDraw::getStrokeMiterLimit
ImagickDraw::getStrokeWidth
ImagickDraw sınıfı
PHP Manual

ImagickDraw::getStrokeOpacity

(PECL imagick 2.0.0)

ImagickDraw::getStrokeOpacity — Nesne dış hatlarını çizmekte kullanılan vurgunun matlığını döndürür

Açıklama

float ImagickDraw::getStrokeOpacity ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Nesne dış hatlarını çizmekte kullanılan vurgunun matlığını döndürür.

Dönen Değerler

Nesne dış hatlarını çizmekte kullanılan vurgunun matlığını bir gerçek sayı olarak döndürür.

ImagickDraw::getStrokeMiterLimit
ImagickDraw::getStrokeWidth
ImagickDraw sınıfı


Nesne dış hatlarını çizmekte kullanılan vurgu genişliğini döndürür

ImagickDraw::getStrokeOpacity
ImagickDraw::getTextAlignment
ImagickDraw sınıfı
PHP Manual

ImagickDraw::getStrokeWidth

(PECL imagick 2.0.0)

ImagickDraw::getStrokeWidth — Nesne dış hatlarını çizmekte kullanılan vurgu genişliğini döndürür

Açıklama

float ImagickDraw::getStrokeWidth ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Nesne dış hatlarını çizmekte kullanılan vurgu genişliğini döndürür.

Dönen Değerler

Nesne dış hatlarını çizmekte kullanılan vurgu genişliğini bir gerçek sayı olarak döndürür.

ImagickDraw::getStrokeOpacity
ImagickDraw::getTextAlignment
ImagickDraw sınıfı


Metin hizalamasını döndürür

ImagickDraw::getStrokeWidth
ImagickDraw::getTextAntialias
ImagickDraw sınıfı
PHP Manual

ImagickDraw::getTextAlignment

(PECL imagick 2.0.0)

ImagickDraw::getTextAlignment — Metin hizalamasını döndürür

Açıklama

int ImagickDraw::getTextAlignment ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Metne uygulanan hizalama türünü döndürür.

Dönen Değerler

Hiçbir hizalama yoksa 0, aksi takdirde hizalama sabitlerinden biri döner.

ImagickDraw::getStrokeWidth
ImagickDraw::getTextAntialias
ImagickDraw sınıfı


Geçerli metin yumuşatma ayarını döndürür

ImagickDraw::getTextAlignment
ImagickDraw::getTextDecoration
ImagickDraw sınıfı
PHP Manual

ImagickDraw::getTextAntialias

(PECL imagick 2.0.0)

ImagickDraw::getTextAntialias — Geçerli metin yumuşatma ayarını döndürür

Açıklama

bool ImagickDraw::getTextAntialias ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Metne yumuşatma uygulanıp uygulanmadığı bilgisi döner. Metinlere öntanımlı olarak yumuşatma uygulanır.

Dönen Değerler

Metne yumuşatma uygulanıyorsa TRUE yoksa FALSE döner.

ImagickDraw::getTextAlignment
ImagickDraw::getTextDecoration
ImagickDraw sınıfı


Metin süslemesi türünü döndürür

ImagickDraw::getTextAntialias
ImagickDraw::getTextEncoding
ImagickDraw sınıfı
PHP Manual

ImagickDraw::getTextDecoration

(PECL imagick 2.0.0)

ImagickDraw::getTextDecoration — Metin süslemesi türünü döndürür

Açıklama

int ImagickDraw::getTextDecoration ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Metne uygulanan süslemenin türünü döndürür.

Dönen Değerler

Bir süsleme yoksa 0, aksi takdirde süsleme türü sabitlerinden biri döner.

ImagickDraw::getTextAntialias
ImagickDraw::getTextEncoding
ImagickDraw sınıfı


Metin çizerken kullanılan karakter kümesi ismini döndürür

ImagickDraw::getTextDecoration
ImagickDraw::getTextInterlineSpacing
ImagickDraw sınıfı
PHP Manual

ImagickDraw::getTextEncoding

(PECL imagick 2.0.0)

ImagickDraw::getTextEncoding — Metin çizerken kullanılan karakter kümesi ismini döndürür

Açıklama

string ImagickDraw::getTextEncoding ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Metin çizerken kullanılan karakter kümesi ismini döndürür.

Dönen Değerler

Karakter kodlaması tanımsızsa FALSE aksi takdirde metin çizerken kullanılan karakter kümesi ismini bir dizge olarak döndürür.

ImagickDraw::getTextDecoration
ImagickDraw::getTextInterlineSpacing
ImagickDraw sınıfı


Description

ImagickDraw::getTextEncoding
ImagickDraw::getTextInterwordSpacing
ImagickDraw sınıfı
PHP Manual

ImagickDraw::getTextInterlineSpacing

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

ImagickDraw::getTextInterlineSpacing — Description

Açıklama

public float ImagickDraw::getTextInterlineSpacing ( void )

Gets the text interword spacing.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

ImagickDraw::getTextEncoding
ImagickDraw::getTextInterwordSpacing
ImagickDraw sınıfı


Description

ImagickDraw::getTextInterlineSpacing
ImagickDraw::getTextKerning
ImagickDraw sınıfı
PHP Manual

ImagickDraw::getTextInterwordSpacing

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

ImagickDraw::getTextInterwordSpacing — Description

Açıklama

public float ImagickDraw::getTextInterwordSpacing ( void )

Gets the text interword spacing.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

ImagickDraw::getTextInterlineSpacing
ImagickDraw::getTextKerning
ImagickDraw sınıfı


Description

ImagickDraw::getTextInterwordSpacing
ImagickDraw::getTextUnderColor
ImagickDraw sınıfı
PHP Manual

ImagickDraw::getTextKerning

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

ImagickDraw::getTextKerning — Description

Açıklama

public float ImagickDraw::getTextKerning ( void )

Gets the text kerning.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

ImagickDraw::getTextInterwordSpacing
ImagickDraw::getTextUnderColor
ImagickDraw sınıfı


Metin artalanındaki rengi döndürür

ImagickDraw::getTextKerning
ImagickDraw::getVectorGraphics
ImagickDraw sınıfı
PHP Manual

ImagickDraw::getTextUnderColor

(PECL imagick 2.0.0)

ImagickDraw::getTextUnderColor — Metin artalanındaki rengi döndürür

Açıklama

ImagickPixel ImagickDraw::getTextUnderColor ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Metin çerçevesi artalanının rengini döndürür.

Dönen Değerler

Rengi ifade eden bir ImagickPixel nesnesi döner.

ImagickDraw::getTextKerning
ImagickDraw::getVectorGraphics
ImagickDraw sınıfı


Yöney çizgesini içeren bir dizge döner

ImagickDraw::getTextUnderColor
ImagickDraw::line
ImagickDraw sınıfı
PHP Manual

ImagickDraw::getVectorGraphics

(PECL imagick 2.0.0)

ImagickDraw::getVectorGraphics — Yöney çizgesini içeren bir dizge döner

Açıklama

string ImagickDraw::getVectorGraphics ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ImagickDraw nesnesi örneklenene kadar yapılan çizge çağrıları ile üretilen yöney çizgesini içeren bir dizge döner.

Dönen Değerler

Yöney çizgesini içeren bir dizge döner.

ImagickDraw::getTextUnderColor
ImagickDraw::line
ImagickDraw sınıfı


Bir çizgi çizer

ImagickDraw::getVectorGraphics
ImagickDraw::matte
ImagickDraw sınıfı
PHP Manual

ImagickDraw::line

(PECL imagick 2.0.0)

ImagickDraw::line — Bir çizgi çizer

Açıklama

bool ImagickDraw::line ( float $bx , float $by , float $sx , float $sy )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Geçerli vurgu rengi, matlığı ve genişliğini kullanarak resme bir çizgi çizer.

Değiştirgeler

bx

Başlangıç noktasının X koordinatı.

by

Başlangıç noktasının Y koordinatı.

sx

Bitiş noktasının X koordinatı.

sy

Bitiş noktasının Y koordinatı.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::getVectorGraphics
ImagickDraw::matte
ImagickDraw sınıfı


Resmin matlık kanalını boyar

ImagickDraw::line
ImagickDraw::pathClose
ImagickDraw sınıfı
PHP Manual

ImagickDraw::matte

(PECL imagick 2.0.0)

ImagickDraw::matte — Resmin matlık kanalını boyar

Açıklama

bool ImagickDraw::matte ( float $x , float $y , int $boyamaYöntemi )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Pikselleri şeffaflaştırmak için resmin matlık kanalını boyar.

Değiştirgeler

x

Mat pikselin X koordinatı.

y

Mat pikselin Y koordinatı.

boyamaYöntemi

Boyama sabitlerinden biri

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

ImagickDraw::line
ImagickDraw::pathClose
ImagickDraw sınıfı


Geçerli hatta son elemanı ekler

ImagickDraw::matte
ImagickDraw::pathCurveToAbsolute
ImagickDraw sınıfı
PHP Manual

ImagickDraw::pathClose

(PECL imagick 2.0.0)

ImagickDraw::pathClose — Geçerli hatta son elemanı ekler

Açıklama

bool ImagickDraw::pathClose ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Geçerli nokta ile son çizilen hat elemanının başlangıç noktası (genellikle son moveto noktasıdır) arasına bir hat elemanı ekleyerek hattı kapatır.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::matte
ImagickDraw::pathCurveToAbsolute
ImagickDraw sınıfı


Üçüncü dereceden bir Bezier eğrisi çizer

ImagickDraw::pathClose
ImagickDraw::pathCurveToQuadraticBezierAbsolute
ImagickDraw sınıfı
PHP Manual

ImagickDraw::pathCurveToAbsolute

(PECL imagick 2.0.0)

ImagickDraw::pathCurveToAbsolute — Üçüncü dereceden bir Bezier eğrisi çizer

Açıklama

bool ImagickDraw::pathCurveToAbsolute ( float $x1 , float $y1 , float $x2 , float $y2 , float $x , float $y )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Mutlak koordinatları kullanarak, eğrinin başlangıcındaki denetim noktası olarak (x1, y1), sonundaki denetim noktası olarak (x2, y2) kullanılarak geçerli noktadan belirtilen (x,y) noktasına üçüncü dereceden bir Bezier eğrisi çizer. Bezier eğrisinin son (x,y) noktası geçerli nokta haline gelir.

Değiştirgeler

x1

Başlangıçtaki denetim noktasının X koordinatı.

y1

Başlangıçtaki denetim noktasının Y koordinatı.

x2

Sondaki denetim noktasının X koordinatı.

y2

Sondaki denetim noktasının Y koordinatı.

x

Eğrinin son noktasının X koordinatı.

y

Eğrinin son noktasının Y koordinatı.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::pathClose
ImagickDraw::pathCurveToQuadraticBezierAbsolute
ImagickDraw sınıfı


İkinci dereceden bir Bezier eğrisi çizer

ImagickDraw::pathCurveToAbsolute
ImagickDraw::pathCurveToQuadraticBezierRelative
ImagickDraw sınıfı
PHP Manual

ImagickDraw::pathCurveToQuadraticBezierAbsolute

(PECL imagick 2.0.0)

ImagickDraw::pathCurveToQuadraticBezierAbsolute — İkinci dereceden bir Bezier eğrisi çizer

Açıklama

bool ImagickDraw::pathCurveToQuadraticBezierAbsolute ( float $x1 , float $y1 , float $x , float $y )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Mutlak koordinatları kullanarak, denetim noktası (x1, y1) olmak üzere geçerli noktadan belirtilen (x,y) noktasına ikinci dereceden bir Bezier eğrisi çizer. Bezier eğrisinin son (x,y) noktası geçerli nokta haline gelir.

Değiştirgeler

x1

Denetim noktasının X koordinatı.

y1

Denetim noktasının Y koordinatı.

x

Eğrinin son noktasının X koordinatı.

y

Eğrinin son noktasının Y koordinatı.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::pathCurveToAbsolute
ImagickDraw::pathCurveToQuadraticBezierRelative
ImagickDraw sınıfı


İkinci dereceden bir Bezier eğrisi çizer

ImagickDraw::pathCurveToQuadraticBezierAbsolute
ImagickDraw::pathCurveToQuadraticBezierSmoothAbsolute
ImagickDraw sınıfı
PHP Manual

ImagickDraw::pathCurveToQuadraticBezierRelative

(PECL imagick 2.0.0)

ImagickDraw::pathCurveToQuadraticBezierRelative — İkinci dereceden bir Bezier eğrisi çizer

Açıklama

bool ImagickDraw::pathCurveToQuadraticBezierRelative ( float $x1 , float $y1 , float $x , float $y )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Göreli koordinatları kullanarak, denetim noktası (x1, y1) olmak üzere geçerli noktadan belirtilen (x,y) noktasına ikinci dereceden bir Bezier eğrisi çizer. Bezier eğrisinin son (x,y) noktası geçerli nokta haline gelir.

Değiştirgeler

x1

Denetim noktasının X koordinatı.

y1

Denetim noktasının Y koordinatı.

x

Eğrinin son noktasının X koordinatı.

y

Eğrinin son noktasının Y koordinatı.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::pathCurveToQuadraticBezierAbsolute
ImagickDraw::pathCurveToQuadraticBezierSmoothAbsolute
ImagickDraw sınıfı


İkinci dereceden bir Bezier eğrisi çizer

ImagickDraw::pathCurveToQuadraticBezierRelative
ImagickDraw::pathCurveToQuadraticBezierSmoothRelative
ImagickDraw sınıfı
PHP Manual

ImagickDraw::pathCurveToQuadraticBezierSmoothAbsolute

(PECL imagick 2.0.0)

ImagickDraw::pathCurveToQuadraticBezierSmoothAbsolute — İkinci dereceden bir Bezier eğrisi çizer

Açıklama

bool ImagickDraw::pathCurveToQuadraticBezierSmoothAbsolute ( float $x , float $y )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Mutlak koordinatları kullanarak, geçerli noktadan belirtilen (x,y) noktasına ikinci dereceden bir Bezier eğrisi çizer. Önceki komutun geçerli noktaya göre denetim noktasının yansıması denetim noktası olarak ele alınır. (Böyle bir komut yoksa veya önceki komut ImagickDraw::pathCurveToQuadraticBezierAbsolute(), ImagickDraw::pathCurveToQuadraticBezierRelative(), ImagickDraw::pathCurveToQuadraticBezierSmoothAbsolute() veya ImagickDraw::pathCurveToQuadraticBezierSmoothRelative() değilse ilk denetim noktası olarak geçerli nokta kullanılır.) İşlemin sonunda Bezier eğrisinin son (x,y) noktası geçerli nokta haline gelir.

Değiştirgeler

x

Eğrinin son noktasının X koordinatı.

y

Eğrinin son noktasının Y koordinatı.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::pathCurveToQuadraticBezierRelative
ImagickDraw::pathCurveToQuadraticBezierSmoothRelative
ImagickDraw sınıfı


İkinci dereceden bir Bezier eğrisi çizer

ImagickDraw::pathCurveToQuadraticBezierSmoothAbsolute
ImagickDraw::pathCurveToRelative
ImagickDraw sınıfı
PHP Manual

ImagickDraw::pathCurveToQuadraticBezierSmoothRelative

(PECL imagick 2.0.0)

ImagickDraw::pathCurveToQuadraticBezierSmoothRelative — İkinci dereceden bir Bezier eğrisi çizer

Açıklama

bool ImagickDraw::pathCurveToQuadraticBezierSmoothRelative ( float $x , float $y )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Göreli koordinatları kullanarak, geçerli noktadan belirtilen (x,y) noktasına ikinci dereceden bir Bezier eğrisi çizer. Önceki komutun geçerli noktaya göre denetim noktasının yansıması denetim noktası olarak ele alınır. (Böyle bir komut yoksa veya önceki komut ImagickDraw::pathCurveToQuadraticBezierAbsolute(), ImagickDraw::pathCurveToQuadraticBezierRelative(), ImagickDraw::pathCurveToQuadraticBezierSmoothAbsolute() veya ImagickDraw::pathCurveToQuadraticBezierSmoothRelative() değilse ilk denetim noktası olarak geçerli nokta kullanılır.) İşlemin sonunda Bezier eğrisinin son (x,y) noktası geçerli nokta haline gelir.

Değiştirgeler

x

Eğrinin son noktasının X koordinatı.

y

Eğrinin son noktasının Y koordinatı.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::pathCurveToQuadraticBezierSmoothAbsolute
ImagickDraw::pathCurveToRelative
ImagickDraw sınıfı


Üçüncü dereceden bir Bezier eğrisi çizer

ImagickDraw::pathCurveToQuadraticBezierSmoothRelative
ImagickDraw::pathCurveToSmoothAbsolute
ImagickDraw sınıfı
PHP Manual

ImagickDraw::pathCurveToRelative

(PECL imagick 2.0.0)

ImagickDraw::pathCurveToRelative — Üçüncü dereceden bir Bezier eğrisi çizer

Açıklama

bool ImagickDraw::pathCurveToRelative ( float $x1 , float $y1 , float $x2 , float $y2 , float $x , float $y )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Göreli koordinatları kullanarak, eğrinin başlangıcındaki denetim noktası olarak (x1, y1), sonundaki denetim noktası olarak (x2, y2) kullanılarak geçerli noktadan belirtilen (x,y) noktasına üçüncü dereceden bir Bezier eğrisi çizer. Bezier eğrisinin son (x,y) noktası geçerli nokta haline gelir.

Değiştirgeler

x1

Başlangıçtaki denetim noktasının X koordinatı.

y1

Başlangıçtaki denetim noktasının Y koordinatı.

x2

Sondaki denetim noktasının X koordinatı.

y2

Sondaki denetim noktasının Y koordinatı.

x

Eğrinin son noktasının X koordinatı.

y

Eğrinin son noktasının Y koordinatı.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::pathCurveToQuadraticBezierSmoothRelative
ImagickDraw::pathCurveToSmoothAbsolute
ImagickDraw sınıfı


Üçüncü dereceden bir Bezier eğrisi çizer

ImagickDraw::pathCurveToRelative
ImagickDraw::pathCurveToSmoothRelative
ImagickDraw sınıfı
PHP Manual

ImagickDraw::pathCurveToSmoothAbsolute

(PECL imagick 2.0.0)

ImagickDraw::pathCurveToSmoothAbsolute — Üçüncü dereceden bir Bezier eğrisi çizer

Açıklama

bool ImagickDraw::pathCurveToSmoothAbsolute ( float $x2 , float $y2 , float $x , float $y )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Mutlak koordinatları kullanarak, geçerli noktadan belirtilen (x,y) noktasına üçüncü dereceden bir Bezier eğrisi çizer. Önceki komutun geçerli noktaya göre ikinci denetim noktasının yansıması ilk denetim noktası olarak ele alınır. (Böyle bir komut yoksa veya önceki komut ImagickDraw::pathCurveToAbsolute(), ImagickDraw::pathCurveToRelative(), ImagickDraw::pathCurveToSmoothAbsolute() veya ImagickDraw::pathCurveToSmoothRelative() değilse ilk denetim noktası olarak geçerli nokta kullanılır.) (x2, y2) ikinci (yani eğrinin sonundaki) denetim noktasıdır. İşlemin sonunda Bezier eğrisinin son (x,y) noktası geçerli nokta haline gelir.

Değiştirgeler

x2

Sondaki denetim noktasının X koordinatı.

y2

Sondaki denetim noktasının Y koordinatı.

x

Eğrinin son noktasının X koordinatı.

y

Eğrinin son noktasının Y koordinatı

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::pathCurveToRelative
ImagickDraw::pathCurveToSmoothRelative
ImagickDraw sınıfı


Üçüncü dereceden bir Bezier eğrisi çizer

ImagickDraw::pathCurveToSmoothAbsolute
ImagickDraw::pathEllipticArcAbsolute
ImagickDraw sınıfı
PHP Manual

ImagickDraw::pathCurveToSmoothRelative

(PECL imagick 2.0.0)

ImagickDraw::pathCurveToSmoothRelative — Üçüncü dereceden bir Bezier eğrisi çizer

Açıklama

bool ImagickDraw::pathCurveToSmoothRelative ( float $x2 , float $y2 , float $x , float $y )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Göreli koordinatları kullanarak, geçerli noktadan belirtilen (x,y) noktasına üçüncü dereceden bir Bezier eğrisi çizer. Önceki komutun geçerli noktaya göre ikinci denetim noktasının yansıması ilk denetim noktası olarak ele alınır. (Böyle bir komut yoksa veya önceki komut ImagickDraw::pathCurveToAbsolute(), ImagickDraw::pathCurveToRelative(), ImagickDraw::pathCurveToSmoothAbsolute() veya ImagickDraw::pathCurveToSmoothRelative() değilse ilk denetim noktası olarak geçerli nokta kullanılır.) (x2, y2) ikinci (yani eğrinin sonundaki) denetim noktasıdır. İşlemin sonunda Bezier eğrisinin son (x,y) noktası geçerli nokta haline gelir.

Değiştirgeler

x2

Sondaki denetim noktasının X koordinatı.

y2

Sondaki denetim noktasının Y koordinatı.

x

Eğrinin son noktasının X koordinatı.

y

Eğrinin son noktasının Y koordinatı

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::pathCurveToSmoothAbsolute
ImagickDraw::pathEllipticArcAbsolute
ImagickDraw sınıfı


Eliptik bir yay çizer

ImagickDraw::pathCurveToSmoothRelative
ImagickDraw::pathEllipticArcRelative
ImagickDraw sınıfı
PHP Manual

ImagickDraw::pathEllipticArcAbsolute

(PECL imagick 2.0.0)

ImagickDraw::pathEllipticArcAbsolute — Eliptik bir yay çizer

Açıklama

bool ImagickDraw::pathEllipticArcAbsolute ( float $rx , float $ry , float $x_ekseni_açısı , bool $büyük_yay , bool $saat_yönü , float $x , float $y )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Mutlak koordinatları kullanarak geçerli noktadan (x, y) koordinatlarına bir eliptik yay çizer. Elipsin büyüklüğü ve yönü (rx, ry) yarıçapları ve x_ekseni_açısı tarafından tanımlanır. x_ekseni_açısı elipsin geçerli koordinat sistemine göre ne kadar döndürüleceğini belirler. Elipsin merkezi diğer değiştirgelerden yararlanılarak özdevinimli olarak hesaplanır. Yayın nasıl çizileceği büyük_yay ve saat_yönü değiştirgelerine göre belirlenip buna göre hesaplanır. Eğer büyük_yay için TRUE belirtilmişse kullanılabilecek en büyük yay çizilir. Eğer saat_yönü için TRUE belirtilirse, yay, saat akrebi yönünde çizilir.

Değiştirgeler

rx

x yarıçapı.

ry

y yarıçapı.

x_ekseni_açısı

x ekseni dönüş açısı.

büyük_yay

TRUE belirtilmişse kullanılabilecek en büyük yay çizilir.

saat_yönü

TRUE belirtilirse yay saat akrebi yönünde çizilir.

x

x koordinatı.

y

y koordinatı.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::pathCurveToSmoothRelative
ImagickDraw::pathEllipticArcRelative
ImagickDraw sınıfı


Bir eliptik yay çizer

ImagickDraw::pathEllipticArcAbsolute
ImagickDraw::pathFinish
ImagickDraw sınıfı
PHP Manual

ImagickDraw::pathEllipticArcRelative

(PECL imagick 2.0.0)

ImagickDraw::pathEllipticArcRelative — Bir eliptik yay çizer

Açıklama

bool ImagickDraw::pathEllipticArcRelative ( float $rx , float $ry , float $x_ekseni_açısı , bool $büyük_yay , bool $saat_yönü , float $x , float $y )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Göreli koordinatları kullanarak geçerli noktadan (x, y) koordinatlarına bir eliptik yay çizer. Elipsin büyüklüğü ve yönü (rx, ry) yarıçapları ve x_ekseni_açısı tarafından tanımlanır. x_ekseni_açısı elipsin geçerli koordinat sistemine göre ne kadar döndürüleceğini belirler. Elipsin merkezi diğer değiştirgelerden yararlanılarak özdevinimli olarak hesaplanır. Yayın nasıl çizileceği büyük_yay ve saat_yönü değiştirgelerine göre belirlenip buna göre hesaplanır. Eğer büyük_yay için TRUE belirtilmişse kullanılabilecek en büyük yay çizilir. Eğer saat_yönü için TRUE belirtilirse, yay, saat akrebi yönünde çizilir.

Değiştirgeler

rx

x yarıçapı.

ry

y yarıçapı.

x_ekseni_açısı

x ekseni dönüş açısı.

büyük_yay

TRUE belirtilmişse kullanılabilecek en büyük yay çizilir.

saat_yönü

TRUE belirtilirse yay saat akrebi yönünde çizilir.

x

x koordinatı.

y

y koordinatı.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::pathEllipticArcAbsolute
ImagickDraw::pathFinish
ImagickDraw sınıfı


Geçerli hattı sonlandırır

ImagickDraw::pathEllipticArcRelative
ImagickDraw::pathLineToAbsolute
ImagickDraw sınıfı
PHP Manual

ImagickDraw::pathFinish

(PECL imagick 2.0.0)

ImagickDraw::pathFinish — Geçerli hattı sonlandırır

Açıklama

bool ImagickDraw::pathFinish ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Geçerli hattı sonlandırır.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::pathEllipticArcRelative
ImagickDraw::pathLineToAbsolute
ImagickDraw sınıfı


Draws a line path

ImagickDraw::pathFinish
ImagickDraw::pathLineToHorizontalAbsolute
ImagickDraw sınıfı
PHP Manual

ImagickDraw::pathLineToAbsolute

(PECL imagick 2.0.0)

ImagickDraw::pathLineToAbsolute — Draws a line path

Açıklama

bool ImagickDraw::pathLineToAbsolute ( float $x , float $y )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Mutlak koordinatları kullanarak geçerli noktadan belirtilen noktaya bir hat elemanı çizer. Belirtilen nokta geçerli nokta haline gelir.

Değiştirgeler

x

Hedef noktanın X konumu.

y

Hedef noktanın Y konumu.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::pathFinish
ImagickDraw::pathLineToHorizontalAbsolute
ImagickDraw sınıfı


Yatay bir hat elemanı çizer

ImagickDraw::pathLineToAbsolute
ImagickDraw::pathLineToHorizontalRelative
ImagickDraw sınıfı
PHP Manual

ImagickDraw::pathLineToHorizontalAbsolute

(PECL imagick 2.0.0)

ImagickDraw::pathLineToHorizontalAbsolute — Yatay bir hat elemanı çizer

Açıklama

bool ImagickDraw::pathLineToHorizontalAbsolute ( float $x )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Mutlak koordinatları kullanarak geçerli noktadan belirtilen noktaya yatay bir hat elemanı çizer. Belirtilen nokta geçerli nokta haline gelir.

Değiştirgeler

x

Hedef noktanın X koordinatı.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::pathLineToAbsolute
ImagickDraw::pathLineToHorizontalRelative
ImagickDraw sınıfı


Yatay bir hat elemanı çizer

ImagickDraw::pathLineToHorizontalAbsolute
ImagickDraw::pathLineToRelative
ImagickDraw sınıfı
PHP Manual

ImagickDraw::pathLineToHorizontalRelative

(PECL imagick 2.0.0)

ImagickDraw::pathLineToHorizontalRelative — Yatay bir hat elemanı çizer

Açıklama

bool ImagickDraw::pathLineToHorizontalRelative ( float $x )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Göreli koordinatları kullanarak geçerli noktadan belirtilen noktaya yatay bir hat elemanı çizer. Belirtilen nokta geçerli nokta haline gelir.

Değiştirgeler

x

Hedef noktanın X koordinatı.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::pathLineToHorizontalAbsolute
ImagickDraw::pathLineToRelative
ImagickDraw sınıfı


Bir hat elemanı çizer

ImagickDraw::pathLineToHorizontalRelative
ImagickDraw::pathLineToVerticalAbsolute
ImagickDraw sınıfı
PHP Manual

ImagickDraw::pathLineToRelative

(PECL imagick 2.0.0)

ImagickDraw::pathLineToRelative — Bir hat elemanı çizer

Açıklama

bool ImagickDraw::pathLineToRelative ( float $x , float $y )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Göreli koordinatları kullanarak geçerli noktadan belirtilen noktaya bir hat elemanı çizer. Belirtilen nokta geçerli nokta haline gelir.

Değiştirgeler

x

Hedef noktanın X konumu.

y

Hedef noktanın Y konumu.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::pathLineToHorizontalRelative
ImagickDraw::pathLineToVerticalAbsolute
ImagickDraw sınıfı


Düşey bir hat elemanı çizer

ImagickDraw::pathLineToRelative
ImagickDraw::pathLineToVerticalRelative
ImagickDraw sınıfı
PHP Manual

ImagickDraw::pathLineToVerticalAbsolute

(PECL imagick 2.0.0)

ImagickDraw::pathLineToVerticalAbsolute — Düşey bir hat elemanı çizer

Açıklama

bool ImagickDraw::pathLineToVerticalAbsolute ( float $y )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Mutlak koordinatları kullanarak geçerli noktadan belirtilen noktaya düşey bir hat elemanı çizer. Belirtilen nokta geçerli nokta haline gelir.

Değiştirgeler

y

Y koordinatı.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::pathLineToRelative
ImagickDraw::pathLineToVerticalRelative
ImagickDraw sınıfı


Bir düşey hat elemanı çizer

ImagickDraw::pathLineToVerticalAbsolute
ImagickDraw::pathMoveToAbsolute
ImagickDraw sınıfı
PHP Manual

ImagickDraw::pathLineToVerticalRelative

(PECL imagick 2.0.0)

ImagickDraw::pathLineToVerticalRelative — Bir düşey hat elemanı çizer

Açıklama

bool ImagickDraw::pathLineToVerticalRelative ( float $y )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Göreli koordinatları kullanarak geçerli noktadan belirtilen noktaya düşey bir hat elemanı çizer. Belirtilen nokta geçerli nokta haline gelir.

Değiştirgeler

y

Y koordinatı.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::pathLineToVerticalAbsolute
ImagickDraw::pathMoveToAbsolute
ImagickDraw sınıfı


Yeni bir hat elemanı başlatır

ImagickDraw::pathLineToVerticalRelative
ImagickDraw::pathMoveToRelative
ImagickDraw sınıfı
PHP Manual

ImagickDraw::pathMoveToAbsolute

(PECL imagick 2.0.0)

ImagickDraw::pathMoveToAbsolute — Yeni bir hat elemanı başlatır

Açıklama

bool ImagickDraw::pathMoveToAbsolute ( float $x , float $y )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Belirtilen koordinatları mutlak koordinatlar olarak kullanıp yeni bir hat elemanı başlatır. Belirtilen koordinat geçerli koordinat haline gelir.

Değiştirgeler

x

Başlangıç noktasının X konumu.

y

Başlangıç noktasının Y konumu.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::pathLineToVerticalRelative
ImagickDraw::pathMoveToRelative
ImagickDraw sınıfı


Yeni bir hat elemanı başlatır

ImagickDraw::pathMoveToAbsolute
ImagickDraw::pathStart
ImagickDraw sınıfı
PHP Manual

ImagickDraw::pathMoveToRelative

(PECL imagick 2.0.0)

ImagickDraw::pathMoveToRelative — Yeni bir hat elemanı başlatır

Açıklama

bool ImagickDraw::pathMoveToRelative ( float $x , float $y )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Belirtilen koordinatları göreli koordinatlar olarak kullanıp yeni bir hat elemanı başlatır. Belirtilen koordinat geçerli koordinat haline gelir.

Değiştirgeler

x

Hedef X konumu.

y

Hedef Y konumu.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::pathMoveToAbsolute
ImagickDraw::pathStart
ImagickDraw sınıfı


Bir hat çizim listesinin başlangıcını bildirir

ImagickDraw::pathMoveToRelative
ImagickDraw::point
ImagickDraw sınıfı
PHP Manual

ImagickDraw::pathStart

(PECL imagick 2.0.0)

ImagickDraw::pathStart — Bir hat çizim listesinin başlangıcını bildirir

Açıklama

bool ImagickDraw::pathStart ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bir ImagickDraw::pathFinish() yönergesi ile sonlandırılana kadar ImagickDraw::path yönergeleri ile çizilecek bir hattın başlangıcını bildirir. Çizim için kullanılan ImagickDraw::path yönergeleri tek başlarına işlevsel olmadıklarından daima ImagickDraw::pathStart() ile ImagickDraw::pathFinish() yönergeleri arasında kullanılmalıdırlar.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::pathMoveToRelative
ImagickDraw::point
ImagickDraw sınıfı


Bir nokta çizer

ImagickDraw::pathStart
ImagickDraw::polygon
ImagickDraw sınıfı
PHP Manual

ImagickDraw::point

(PECL imagick 2.0.0)

ImagickDraw::point — Bir nokta çizer

Açıklama

bool ImagickDraw::point ( float $x , float $y )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Geçerli vurgu rengini ve vurgu kalınlığını kullanarak koordinatları belirtilen noktayı çizer.

Değiştirgeler

x

Noktanın X konumu.

y

Noktanın Y konumu.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::pathStart
ImagickDraw::polygon
ImagickDraw sınıfı


Bir çokgen çizer

ImagickDraw::point
ImagickDraw::polyline
ImagickDraw sınıfı
PHP Manual

ImagickDraw::polygon

(PECL imagick 2.0.0)

ImagickDraw::polygon — Bir çokgen çizer

Açıklama

bool ImagickDraw::polygon ( array $koordinatlar )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Belirtilen koordinat dizisini, geçerli vurgu rengini, vurgu genişliğini, dolgu rengini veya dokuyu kullanarak bir çokgen çizer.

Değiştirgeler

koordinatlar

X ve Y koordinatlarını içeren çok boyutlu dizi. Örnek: array( array( 'x' => 3, 'y' => 4 ), array( 'x' => 2, 'y' => 6 ) );

Dönen Değerler

Başarı durumunda TRUE döner.

ImagickDraw::point
ImagickDraw::polyline
ImagickDraw sınıfı


Bir çoklu çizgi çizer

ImagickDraw::polygon
ImagickDraw::pop
ImagickDraw sınıfı
PHP Manual

ImagickDraw::polyline

(PECL imagick 2.0.0)

ImagickDraw::polyline — Bir çoklu çizgi çizer

Açıklama

bool ImagickDraw::polyline ( array $koordinatlar )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Belirtilen koordinat dizisini, geçerli vurgu rengini, vurgu genişliğini, dolgu rengini veya dokuyu kullanarak bir çoklu çizgi çizer.

Değiştirgeler

koordinatlar

X ve Y koordinatlarını içeren dizi. Örnek: array( array( 'x' => 4, 'y' => 6 ), array( 'x' => 8, 'y' => 10 ) )

Dönen Değerler

Başarı durumunda TRUE döner.

ImagickDraw::polygon
ImagickDraw::pop
ImagickDraw sınıfı


Yığıttaki geçerli ImagickDraw nesnesini silip sonraki nesneyi döndürür

ImagickDraw::polyline
ImagickDraw::popClipPath
ImagickDraw sınıfı
PHP Manual

ImagickDraw::pop

(PECL imagick 2.0.0)

ImagickDraw::pop — Yığıttaki geçerli ImagickDraw nesnesini silip sonraki nesneyi döndürür

Açıklama

bool ImagickDraw::pop ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ImagickDraw yığıtından geçerli nesneyi siler ve yığıta ondan önce basılmış nesneyi döndürür. Yığıtta çok sayıda nesne bulunabilir. Yığıta basılandan daha fazla ImagickDraw nesnesini çekmeye çalışmak bir hata oluşmasına sebep olur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

ImagickDraw::polyline
ImagickDraw::popClipPath
ImagickDraw sınıfı


Bir yalıtım maskesi tanımını sonlandırır

ImagickDraw::pop
ImagickDraw::popDefs
ImagickDraw sınıfı
PHP Manual

ImagickDraw::popClipPath

(PECL imagick 2.0.0)

ImagickDraw::popClipPath — Bir yalıtım maskesi tanımını sonlandırır

Açıklama

bool ImagickDraw::popClipPath ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bir yalıtım maskesi tanımını sonlandırır.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::pop
ImagickDraw::popDefs
ImagickDraw sınıfı


Bir tanım listesini sonlandırır

ImagickDraw::popClipPath
ImagickDraw::popPattern
ImagickDraw sınıfı
PHP Manual

ImagickDraw::popDefs

(PECL imagick 2.0.0)

ImagickDraw::popDefs — Bir tanım listesini sonlandırır

Açıklama

bool ImagickDraw::popDefs ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bir tanım listesini sonlandırır.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::popClipPath
ImagickDraw::popPattern
ImagickDraw sınıfı


Bir örüntü tanımını sonlandırır

ImagickDraw::popDefs
ImagickDraw::push
ImagickDraw sınıfı
PHP Manual

ImagickDraw::popPattern

(PECL imagick 2.0.0)

ImagickDraw::popPattern — Bir örüntü tanımını sonlandırır

Açıklama

bool ImagickDraw::popPattern ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bir örüntü tanımını sonlandırır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

ImagickDraw::popDefs
ImagickDraw::push
ImagickDraw sınıfı


Geçerli ImagickDraw nesnesini kopyalar ve yığıta basar

ImagickDraw::popPattern
ImagickDraw::pushClipPath
ImagickDraw sınıfı
PHP Manual

ImagickDraw::push

(PECL imagick 2.0.0)

ImagickDraw::push — Geçerli ImagickDraw nesnesini kopyalar ve yığıta basar

Açıklama

bool ImagickDraw::push ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Yeni bir ImagickDraw nesnesi oluşturmak için geçerli ImagickDraw nesnesinin bir kopyasını oluşturur ve ImagickDraw yığıtına yerleştirir. Özgün ImagickDraw nesnesi ImagickDraw::pop() ile yığıttan çekilebilir. Tüm ImagickDraw nesneleri bir ImagickDraw yığıtında saklanır. Her ImagickDraw::pop() çağrısına karşılık evvelce yapılmış bir ImagickDraw::push() çağrısı olmalıdır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

ImagickDraw::popPattern
ImagickDraw::pushClipPath
ImagickDraw sınıfı


Bir yalıtım maskesi tanımı başlatır

ImagickDraw::push
ImagickDraw::pushDefs
ImagickDraw sınıfı
PHP Manual

ImagickDraw::pushClipPath

(PECL imagick 2.0.0)

ImagickDraw::pushClipPath — Bir yalıtım maskesi tanımı başlatır

Açıklama

bool ImagickDraw::pushClipPath ( string $yalıtım_maskesi_kimliği )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bir ImagickDraw::popClipPath() çağrısı ile sonlandırılana kadar verilecek çizim komutları ile oluşturulacak bir yalıtım maskesi tanımını başlatır.

Değiştirgeler

yalıtım_maskesi_kimliği

Yalıtım maskesi (clip path) kimliği.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::push
ImagickDraw::pushDefs
ImagickDraw sınıfı


Bundan sonra çağrılacak yöntemlerin ImagickDraw::popDefs yöntemi çağrılıncaya kadar isimli elemanları tanımlayacağını belirtir

ImagickDraw::pushClipPath
ImagickDraw::pushPattern
ImagickDraw sınıfı
PHP Manual

ImagickDraw::pushDefs

(PECL imagick 2.0.0)

ImagickDraw::pushDefs — Bundan sonra çağrılacak yöntemlerin ImagickDraw::popDefs() yöntemi çağrılıncaya kadar isimli elemanları tanımlayacağını belirtir

Açıklama

bool ImagickDraw::pushDefs ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bundan sonra çağrılacak yöntemlerin ImagickDraw::popDefs() yöntemi çağrılıncaya kadar isimli elemanları (çizim parçaları, dokular gibi) tanımlayacağını belirtir. Bunlar kısa zamanda güvenle verimli olarak kullanılabilir.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::pushClipPath
ImagickDraw::pushPattern
ImagickDraw sınıfı


Bundan sonra çağrılacak yöntemlerin ImagickDraw::popPattern yöntemi çağrılıncaya kadar bir isimli örüntüyü tanımlayacağını belirtir

ImagickDraw::pushDefs
ImagickDraw::rectangle
ImagickDraw sınıfı
PHP Manual

ImagickDraw::pushPattern

(PECL imagick 2.0.0)

ImagickDraw::pushPattern — Bundan sonra çağrılacak yöntemlerin ImagickDraw::popPattern() yöntemi çağrılıncaya kadar bir isimli örüntüyü tanımlayacağını belirtir

Açıklama

bool ImagickDraw::pushPattern ( string $örüntü_kimliği , float $x , float $y , float $genişlik , float $yükseklik )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bundan sonra çağrılacak yöntemlerin ImagickDraw::popPattern() yöntemi çağrılıncaya kadar bir isimli örüntüyü tanımlayacağını belirtir. Örüntü uzayı, sol üst köşenin koordinatları, bir genişlik ve bir yükseklikle belirtilerek örüntünün kendi çizim uzayı haline gelir. Çizilebilen her şey örüntünün tanımında kullanılabilir. İsimli örüntüler çizgi ve fırça tanımları olarak kullanılabilir.

Değiştirgeler

örüntü_kimliği

Örüntü kimliği.

x

Sol üst köşenin X konumu.

y

Sol üst köşenin Y konumu.

genişlik

Örüntünün genişliği.

yükseklik

Örüntünün yüksekliği.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

ImagickDraw::pushDefs
ImagickDraw::rectangle
ImagickDraw sınıfı


Bir dikdörtgen çizer

ImagickDraw::pushPattern
ImagickDraw::render
ImagickDraw sınıfı
PHP Manual

ImagickDraw::rectangle

(PECL imagick 2.0.0)

ImagickDraw::rectangle — Bir dikdörtgen çizer

Açıklama

bool ImagickDraw::rectangle ( float $x1 , float $y1 , float $x2 , float $y2 )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Köşegen koordinatları belirtilen dikdörtgeni çizer. Çizim için geçerli çizgi türü, çizgi kalınlığı ve dolgu ayarları kullanılır.

Değiştirgeler

x1

Sol üst köşenin X konumu.

y1

Sol üst köşenin Y konumu.

x2

Sağ alt köşenin X konumu.

y2

Sağ alt köşenin Y konumu.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::pushPattern
ImagickDraw::render
ImagickDraw sınıfı


Evvelce verilmiş tüm çizim komutlarını resme uygular

ImagickDraw::rectangle
ImagickDraw::resetVectorGraphics
ImagickDraw sınıfı
PHP Manual

ImagickDraw::render

(PECL imagick 2.0.0)

ImagickDraw::render — Evvelce verilmiş tüm çizim komutlarını resme uygular

Açıklama

bool ImagickDraw::render ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Evvelce verilmiş tüm çizim komutlarını resme uygular.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

ImagickDraw::rectangle
ImagickDraw::resetVectorGraphics
ImagickDraw sınıfı


Description

ImagickDraw::render
ImagickDraw::rotate
ImagickDraw sınıfı
PHP Manual

ImagickDraw::resetVectorGraphics

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

ImagickDraw::resetVectorGraphics — Description

Açıklama

public void ImagickDraw::resetVectorGraphics ( void )

Resets the vector graphics.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

ImagickDraw::render
ImagickDraw::rotate
ImagickDraw sınıfı


Geçerli koordinat sistemini belirtilen açıda döndürür

ImagickDraw::resetVectorGraphics
ImagickDraw::roundRectangle
ImagickDraw sınıfı
PHP Manual

ImagickDraw::rotate

(PECL imagick 2.0.0)

ImagickDraw::rotate — Geçerli koordinat sistemini belirtilen açıda döndürür

Açıklama

bool ImagickDraw::rotate ( float $açı )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Geçerli koordinat sistemini belirtilen açıda döndürür

Değiştirgeler

açı

Derece cinsinden döndürme açısı.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::resetVectorGraphics
ImagickDraw::roundRectangle
ImagickDraw sınıfı


Köşeleri yuvarlatılmış bir dikdörtgen çizer

ImagickDraw::rotate
ImagickDraw::scale
ImagickDraw sınıfı
PHP Manual

ImagickDraw::roundRectangle

(PECL imagick 2.0.0)

ImagickDraw::roundRectangle — Köşeleri yuvarlatılmış bir dikdörtgen çizer

Açıklama

bool ImagickDraw::roundRectangle ( float $x1 , float $y1 , float $x2 , float $y2 , float $rx , float $ry )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Köşegen koordinatları belirtilen dikdörtgeni, köşelerini x ve y yarıçaplarına göre yuvarlatarak çizer. Çizim için geçerli çizgi türü, çizgi kalınlığı ve dolgu ayarları kullanılır.

Değiştirgeler

x1

Sol üst köşenin X konumu.

y1

Sol üst köşenin Y konumu.

x2

Sağ alt köşenin X konumu.

y2

Sağ alt köşenin Y konumu.

rx

x yarıçapı

ry

y yarıçapı

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::rotate
ImagickDraw::scale
ImagickDraw sınıfı


Enboy oranını ayarlar

ImagickDraw::roundRectangle
ImagickDraw::setClipPath
ImagickDraw sınıfı
PHP Manual

ImagickDraw::scale

(PECL imagick 2.0.0)

ImagickDraw::scale — Enboy oranını ayarlar

Açıklama

bool ImagickDraw::scale ( float $x , float $y )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Geçerli koordinat sisteminde yatay ve düşey yönlerde uygulanacak enboy oranını belirler.

Değiştirgeler

x

Yatay katsayı.

y

Düşey katsayı.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::roundRectangle
ImagickDraw::setClipPath
ImagickDraw sınıfı


Bir isimli yalıtım maskesini resimle ilişkilendirir

ImagickDraw::scale
ImagickDraw::setClipRule
ImagickDraw sınıfı
PHP Manual

ImagickDraw::setClipPath

(PECL imagick 2.0.0)

ImagickDraw::setClipPath — Bir isimli yalıtım maskesini resimle ilişkilendirir

Açıklama

bool ImagickDraw::setClipPath ( string $yalıtım_maskesi )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bir isimli yalıtım maskesini resimle ilişkilendirir. Yürürlükte kaldığı sürece, sadece yalıtım maskesiyle sınırlanan alanlar değiştirilir.

Değiştirgeler

yalıtım_maskesi

Resimle ilişkilendirilecek yalıtım maskesinin ismi.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::scale
ImagickDraw::setClipRule
ImagickDraw sınıfı


Yalıtım maskesi tarafından kullanılacak çokgen dolgu kuralını belirler

ImagickDraw::setClipPath
ImagickDraw::setClipUnits
ImagickDraw sınıfı
PHP Manual

ImagickDraw::setClipRule

(PECL imagick 2.0.0)

ImagickDraw::setClipRule — Yalıtım maskesi tarafından kullanılacak çokgen dolgu kuralını belirler

Açıklama

bool ImagickDraw::setClipRule ( int $dolgu_kuralı )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Yalıtım maskesi tarafından kullanılacak çokgen dolgu kuralını belirler.

Değiştirgeler

dolgu_kuralı

Dolgu kuralı sabitlerinden biri

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::setClipPath
ImagickDraw::setClipUnits
ImagickDraw sınıfı


Yalıtım maskesi birimlerinin yorumunu belirler

ImagickDraw::setClipRule
ImagickDraw::setFillAlpha
ImagickDraw sınıfı
PHP Manual

ImagickDraw::setClipUnits

(PECL imagick 2.0.0)

ImagickDraw::setClipUnits — Yalıtım maskesi birimlerinin yorumunu belirler

Açıklama

bool ImagickDraw::setClipUnits ( int $yalıtım_birimleri )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Yalıtım maskesi birimlerinin yorumunu belirler

Değiştirgeler

yalıtım_birimleri

Yalıtım birimi sabitlerinden biri.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::setClipRule
ImagickDraw::setFillAlpha
ImagickDraw sınıfı


Dolgu dokusu veya dolgu rengi için kullanılacak şeffaflığı belirler

ImagickDraw::setClipUnits
ImagickDraw::setFillColor
ImagickDraw sınıfı
PHP Manual

ImagickDraw::setFillAlpha

(PECL imagick 2.0.0)

ImagickDraw::setFillAlpha — Dolgu dokusu veya dolgu rengi için kullanılacak şeffaflığı belirler

Açıklama

bool ImagickDraw::setFillAlpha ( float $şeffaflık )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Dolgu dokusu veya dolgu rengi için kullanılacak şeffaflığı belirler. Tam şeffaflık 1.0'dır.

Değiştirgeler

şeffaflık

Dolgunun ışık geçirgenliği.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::setClipUnits
ImagickDraw::setFillColor
ImagickDraw sınıfı


Dolgulu nesnelerin çiziminde kullanılacak dolgu rengini belirler

ImagickDraw::setFillAlpha
ImagickDraw::setFillOpacity
ImagickDraw sınıfı
PHP Manual

ImagickDraw::setFillColor

(PECL imagick 2.0.0)

ImagickDraw::setFillColor — Dolgulu nesnelerin çiziminde kullanılacak dolgu rengini belirler

Açıklama

bool ImagickDraw::setFillColor ( ImagickPixel $dolgu_rengi )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Dolgulu nesnelerin çiziminde kullanılacak dolgu rengini belirler.

Değiştirgeler

dolgu_rengi

Renk olarak kullanılacak ImagickPixel nesnesi.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::setFillAlpha
ImagickDraw::setFillOpacity
ImagickDraw sınıfı


Dolgu dokusu veya dolgu rengi için kullanılacak matlığı belirler

ImagickDraw::setFillColor
ImagickDraw::setFillPatternURL
ImagickDraw sınıfı
PHP Manual

ImagickDraw::setFillOpacity

(PECL imagick 2.0.0)

ImagickDraw::setFillOpacity — Dolgu dokusu veya dolgu rengi için kullanılacak matlığı belirler

Açıklama

bool ImagickDraw::setFillOpacity ( float $matlık )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Dolgu dokusu veya dolgu rengi için kullanılacak matlığı belirler. Tam matlık değeri 1.0'dır.

Değiştirgeler

matlık

Dolgunun ışık geçirmezliği.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::setFillColor
ImagickDraw::setFillPatternURL
ImagickDraw sınıfı


Nesne dolgu örüntüsü için kullanılacak adresi belirler

ImagickDraw::setFillOpacity
ImagickDraw::setFillRule
ImagickDraw sınıfı
PHP Manual

ImagickDraw::setFillPatternURL

(PECL imagick 2.0.0)

ImagickDraw::setFillPatternURL — Nesne dolgu örüntüsü için kullanılacak adresi belirler

Açıklama

bool ImagickDraw::setFillPatternURL ( string $dolgu_adresi )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Nesne dolgu örüntüsü için kullanılacak adresi belirler. Şimdilik sadece yerel betimleyiciler ("#betimleyici") desteklenmektedir. Bu yerel betimleyiciler genelde ImagickDraw::pushPattern() ve/veya ImagickDraw::popPattern() ile bir isimli örüntü tanımlamak suretiyle oluşturulurlar.

Değiştirgeler

dolgu_adresi

Dolgu örüntüsünün temin edileceği adres.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

ImagickDraw::setFillOpacity
ImagickDraw::setFillRule
ImagickDraw sınıfı


Çokgen çizerken kullanılacak dolgu kuralını belirler

ImagickDraw::setFillPatternURL
ImagickDraw::setFont
ImagickDraw sınıfı
PHP Manual

ImagickDraw::setFillRule

(PECL imagick 2.0.0)

ImagickDraw::setFillRule — Çokgen çizerken kullanılacak dolgu kuralını belirler

Açıklama

bool ImagickDraw::setFillRule ( int $dolgu_kuralı )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Çokgen çizerken kullanılacak dolgu kuralını belirler.

Değiştirgeler

dolgu_kuralı

Dolgu kuralı sabitlerinden biri.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::setFillPatternURL
ImagickDraw::setFont
ImagickDraw sınıfı


Metni çizerken kullanılacak yazı tipini tam belirtimiyle belirler

ImagickDraw::setFillRule
ImagickDraw::setFontFamily
ImagickDraw sınıfı
PHP Manual

ImagickDraw::setFont

(PECL imagick 2.0.0)

ImagickDraw::setFont — Metni çizerken kullanılacak yazı tipini tam belirtimiyle belirler

Açıklama

bool ImagickDraw::setFont ( string $yazıtipi_adı )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Metni çizerken kullanılacak yazı tipini tam belirtimiyle belirler.

Değiştirgeler

yazıtipi_adı

Dönen Değerler

Başarı durumunda TRUE döner.

ImagickDraw::setFillRule
ImagickDraw::setFontFamily
ImagickDraw sınıfı


Yazı tipi ailesini belirler

ImagickDraw::setFont
ImagickDraw::setFontSize
ImagickDraw sınıfı
PHP Manual

ImagickDraw::setFontFamily

(PECL imagick 2.0.0)

ImagickDraw::setFontFamily — Yazı tipi ailesini belirler

Açıklama

bool ImagickDraw::setFontFamily ( string $yazıtipi_ailesi )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Metni çizerken kullanılacak yazı tipi ailesini belirler.

Değiştirgeler

yazıtipi_ailesi

Yazı tipi ailesi.

Dönen Değerler

Başarı durumunda TRUE döner.

ImagickDraw::setFont
ImagickDraw::setFontSize
ImagickDraw sınıfı


Yazı tipi yüksekliğini belirler

ImagickDraw::setFontFamily
ImagickDraw::setFontStretch
ImagickDraw sınıfı
PHP Manual

ImagickDraw::setFontSize

(PECL imagick 2.0.0)

ImagickDraw::setFontSize — Yazı tipi yüksekliğini belirler

Açıklama

bool ImagickDraw::setFontSize ( float $punto )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Yazı tipi yüksekliğini punto olarak belirler.

Değiştirgeler

punto

Punto olarak yazı tipi yüksekliği.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::setFontFamily
ImagickDraw::setFontStretch
ImagickDraw sınıfı


Yazı tipinin karakter genişliğini belirler

ImagickDraw::setFontSize
ImagickDraw::setFontStyle
ImagickDraw sınıfı
PHP Manual

ImagickDraw::setFontStretch

(PECL imagick 2.0.0)

ImagickDraw::setFontStretch — Yazı tipinin karakter genişliğini belirler

Açıklama

bool ImagickDraw::setFontStretch ( int $gerginlik )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Metni çizerken kullanılacak yazı tipi karakter genişliğini belirler.

Değiştirgeler

gerginlik

Yazı tipi karakter genişliği sabitlerinden biri

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::setFontSize
ImagickDraw::setFontStyle
ImagickDraw sınıfı


Yazı tipi tarzını belirler

ImagickDraw::setFontStretch
ImagickDraw::setFontWeight
ImagickDraw sınıfı
PHP Manual

ImagickDraw::setFontStyle

(PECL imagick 2.0.0)

ImagickDraw::setFontStyle — Yazı tipi tarzını belirler

Açıklama

bool ImagickDraw::setFontStyle ( int $tarz )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Metni çizerken kullanılacak yazı tipi tarzını belirler.

Değiştirgeler

style

Yazı tipi tarzı sabitlerinden biri.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::setFontStretch
ImagickDraw::setFontWeight
ImagickDraw sınıfı


Yazı tipi kalınlığını belirler

ImagickDraw::setFontStyle
ImagickDraw::setGravity
ImagickDraw sınıfı
PHP Manual

ImagickDraw::setFontWeight

(PECL imagick 2.0.0)

ImagickDraw::setFontWeight — Yazı tipi kalınlığını belirler

Açıklama

bool ImagickDraw::setFontWeight ( int $kalınlık )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Metni çizerken kullanılacak yazı tipi kalınlığını belirler.

Değiştirgeler

yükseklik

Dönen Değerler

ImagickDraw::setFontStyle
ImagickDraw::setGravity
ImagickDraw sınıfı


Metnin çekim yönünü belirler

ImagickDraw::setFontWeight
ImagickDraw::setResolution
ImagickDraw sınıfı
PHP Manual

ImagickDraw::setGravity

(PECL imagick 2.0.0)

ImagickDraw::setGravity — Metnin çekim yönünü belirler

Açıklama

bool ImagickDraw::setGravity ( int $çekimYönü )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Metin yerleştirilirken kullanılacak çekim yönünü belirler.

Değiştirgeler

çekimYönü

Çekim yönü sabitlerinden biri.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::setFontWeight
ImagickDraw::setResolution
ImagickDraw sınıfı


Description

ImagickDraw::setGravity
ImagickDraw::setStrokeAlpha
ImagickDraw sınıfı
PHP Manual

ImagickDraw::setResolution

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

ImagickDraw::setResolution — Description

Açıklama

public void ImagickDraw::setResolution ( string $x_resolution , string $y_resolution )

Sets the resolution.

Değiştirgeler

x_resolution

y_resolution

Dönen Değerler

ImagickDraw::setGravity
ImagickDraw::setStrokeAlpha
ImagickDraw sınıfı


Vurgulu nesne dış hatlarının şeffaflığını tanımlar

ImagickDraw::setResolution
ImagickDraw::setStrokeAntialias
ImagickDraw sınıfı
PHP Manual

ImagickDraw::setStrokeAlpha

(PECL imagick 2.0.0)

ImagickDraw::setStrokeAlpha — Vurgulu nesne dış hatlarının şeffaflığını tanımlar

Açıklama

bool ImagickDraw::setStrokeAlpha ( float $şeffaflık )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Vurgulu nesne dış hatlarının ışık geçirgenliğini tanımlar.

Değiştirgeler

şeffaflık

Işık geçirgenliği.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::setResolution
ImagickDraw::setStrokeAntialias
ImagickDraw sınıfı


Vurgulu dış hatlara kenar yumuşatma uygulanıp uygulanmayacağını denetler

ImagickDraw::setStrokeAlpha
ImagickDraw::setStrokeColor
ImagickDraw sınıfı
PHP Manual

ImagickDraw::setStrokeAntialias

(PECL imagick 2.0.0)

ImagickDraw::setStrokeAntialias — Vurgulu dış hatlara kenar yumuşatma uygulanıp uygulanmayacağını denetler

Açıklama

bool ImagickDraw::setStrokeAntialias ( bool $vurguyu_yumuşat )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Vurgulu dış hatlara kenar yumuşatma uygulanıp uygulanmayacağını belirler. Vurgulu dış hatlara öntanımlı olarak yumuşatma uygulanır. Yumaşatma iptal edildiğinde vurgulu kenar piksellerinin rengi belirlenirken vurgu ve tuval rengi parlaklık bakımından karşılaştırılır (eşikleme).

Değiştirgeler

vurguyu_yumuşat

Vurgulu dış hatlara öntanımlı olarak yumuşatma uygulanır.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::setStrokeAlpha
ImagickDraw::setStrokeColor
ImagickDraw sınıfı


Nesne dış hatlarını vurgulamakta kullanılacak rengi tanımlar

ImagickDraw::setStrokeAntialias
ImagickDraw::setStrokeDashArray
ImagickDraw sınıfı
PHP Manual

ImagickDraw::setStrokeColor

(PECL imagick 2.0.0)

ImagickDraw::setStrokeColor — Nesne dış hatlarını vurgulamakta kullanılacak rengi tanımlar

Açıklama

bool ImagickDraw::setStrokeColor ( ImagickPixel $vurgu_rengi )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Nesne dış hatlarını vurgulamakta kullanılacak rengi tanımlar.

Değiştirgeler

vurgu_rengi

Nesne dış hatlarını vurgulamakta kullanılacak renk.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::setStrokeAntialias
ImagickDraw::setStrokeDashArray
ImagickDraw sınıfı


Kesikli çizgi örüntüsünde tireleri ve boşlukları belirler

ImagickDraw::setStrokeColor
ImagickDraw::setStrokeDashOffset
ImagickDraw sınıfı
PHP Manual

ImagickDraw::setStrokeDashArray

(PECL imagick 2.0.0)

ImagickDraw::setStrokeDashArray — Kesikli çizgi örüntüsünde tireleri ve boşlukları belirler

Açıklama

bool ImagickDraw::setStrokeDashArray ( array $tireDizisi )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Kesikli çizgi örüntüsünü oluşturmakta kullanılacak tireleri ve boşlukları tanımlar. tireDizisi, kesikli çizgiyi oluşturan tire ve boşlukların kesikli çizgide yer alış sırasına göre dizildiği ve bunların uzunluklarının piksel sayısı cinsinden belirtildiği bir dizidir. Mevcut bir tire dizisini silmek için değiştirgeye sıfır elemanlı bir dizi aktarmak yeterlidir. Kullanışlı bir tire dizisi genellikle 5 3 2 üyelerinden oluşur.

Değiştirgeler

tireDizisi

Tire ve boşlukların uzunluklarını içeren dizi.

Dönen Değerler

Başarı durumunda TRUE döner.

ImagickDraw::setStrokeColor
ImagickDraw::setStrokeDashOffset
ImagickDraw sınıfı


Kesikli çizgi örüntüsünde tire başlangıcını belirler

ImagickDraw::setStrokeDashArray
ImagickDraw::setStrokeLineCap
ImagickDraw sınıfı
PHP Manual

ImagickDraw::setStrokeDashOffset

(PECL imagick 2.0.0)

ImagickDraw::setStrokeDashOffset — Kesikli çizgi örüntüsünde tire başlangıcını belirler

Açıklama

bool ImagickDraw::setStrokeDashOffset ( float $tire_başlangıcı )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Kesikli çizgi örüntüsünde tire başlangıcını belirler.

Değiştirgeler

dash_offset

Tire başlangıcı.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::setStrokeDashArray
ImagickDraw::setStrokeLineCap
ImagickDraw sınıfı


Kalın çizgilerde çizgi uçlarının şeklini belirler

ImagickDraw::setStrokeDashOffset
ImagickDraw::setStrokeLineJoin
ImagickDraw sınıfı
PHP Manual

ImagickDraw::setStrokeLineCap

(PECL imagick 2.0.0)

ImagickDraw::setStrokeLineCap — Kalın çizgilerde çizgi uçlarının şeklini belirler

Açıklama

bool ImagickDraw::setStrokeLineCap ( int $uçTürü )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Kalın çizgilerde çizgi uçlarının şeklini belirler.

Değiştirgeler

linecap

Çizgi ucu sabitlerinden biri.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::setStrokeDashOffset
ImagickDraw::setStrokeLineJoin
ImagickDraw sınıfı


Kalın çizgi ekleminin şeklini belirler

ImagickDraw::setStrokeLineCap
ImagickDraw::setStrokeMiterLimit
ImagickDraw sınıfı
PHP Manual

ImagickDraw::setStrokeLineJoin

(PECL imagick 2.0.0)

ImagickDraw::setStrokeLineJoin — Kalın çizgi ekleminin şeklini belirler

Açıklama

bool ImagickDraw::setStrokeLineJoin ( int $eklemTürü )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Kalın çizgi eklemlerinin şeklini (gönye, yuvarlak, eğimli) belirler.

Değiştirgeler

eklemTürü

Çizgi eklemi sabitlerinden biri.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::setStrokeLineCap
ImagickDraw::setStrokeMiterLimit
ImagickDraw sınıfı


Gönyenin kesildiği sınırı tanımlar

ImagickDraw::setStrokeLineJoin
ImagickDraw::setStrokeOpacity
ImagickDraw sınıfı
PHP Manual

ImagickDraw::setStrokeMiterLimit

(PECL imagick 2.0.0)

ImagickDraw::setStrokeMiterLimit — Gönyenin kesildiği sınırı tanımlar

Açıklama

bool ImagickDraw::setStrokeMiterLimit ( int $gönyeSınırı )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Gönyenin kesildiği sınırı tanımlar. İki kalın çizgi keskin bir açı ile kesiştiğinde kesişim yeri gönye köşesi biçimini alacak şekilde çizgi fazlalıkları atılır. Bu gönye köşesini uzatmak mümkündür. gönyeSınırı gönye uzunluğunun çizgi genişliğine oranına bir sınırlama getirir.

Değiştirgeler

gönyeSınırı

Gönye uzatma sınırı.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::setStrokeLineJoin
ImagickDraw::setStrokeOpacity
ImagickDraw sınıfı


Vurgulanmış nesne dış hatlarının matlığını tanımlar

ImagickDraw::setStrokeMiterLimit
ImagickDraw::setStrokePatternURL
ImagickDraw sınıfı
PHP Manual

ImagickDraw::setStrokeOpacity

(PECL imagick 2.0.0)

ImagickDraw::setStrokeOpacity — Vurgulanmış nesne dış hatlarının matlığını tanımlar

Açıklama

bool ImagickDraw::setStrokeOpacity ( float $vurgu_matlığı )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Vurgulanmış nesne dış hatlarının matlığını tanımlar.

Değiştirgeler

vurgu_matlığı

Tam matlık değeri 1.0'dır.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::setStrokeMiterLimit
ImagickDraw::setStrokePatternURL
ImagickDraw sınıfı


Nesne dış hatlarının çiziminde kullanılacak örüntüyü tanımlar

ImagickDraw::setStrokeOpacity
ImagickDraw::setStrokeWidth
ImagickDraw sınıfı
PHP Manual

ImagickDraw::setStrokePatternURL

(PECL imagick 2.0.0)

ImagickDraw::setStrokePatternURL — Nesne dış hatlarının çiziminde kullanılacak örüntüyü tanımlar

Açıklama

bool ImagickDraw::setStrokePatternURL ( string $örüntü_adresi )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Nesne dış hatlarının çiziminde kullanılacak örüntüyü tanımlar.

Değiştirgeler

örüntü_adresi

Dış hatların çiziminde kullanılacak örüntünün adresi.

Dönen Değerler

Başarı durumunda TRUE döner.

ImagickDraw::setStrokeOpacity
ImagickDraw::setStrokeWidth
ImagickDraw sınıfı


Nesne dış hatlarının çiziminde kullanılacak çizgi genişliğini tanımlar

ImagickDraw::setStrokePatternURL
ImagickDraw::setTextAlignment
ImagickDraw sınıfı
PHP Manual

ImagickDraw::setStrokeWidth

(PECL imagick 2.0.0)

ImagickDraw::setStrokeWidth — Nesne dış hatlarının çiziminde kullanılacak çizgi genişliğini tanımlar

Açıklama

bool ImagickDraw::setStrokeWidth ( float $vurgu_genişliği )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Nesne dış hatlarının çiziminde kullanılacak çizgi genişliğini tanımlar.

Değiştirgeler

vurgu_genişliği

Nesne dış hatları için çizgi genişliği.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::setStrokePatternURL
ImagickDraw::setTextAlignment
ImagickDraw sınıfı


Metni hizalar

ImagickDraw::setStrokeWidth
ImagickDraw::setTextAntialias
ImagickDraw sınıfı
PHP Manual

ImagickDraw::setTextAlignment

(PECL imagick 2.0.0)

ImagickDraw::setTextAlignment — Metni hizalar

Açıklama

bool ImagickDraw::setTextAlignment ( int $hizalama )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Metin çizilirken metne uygulanacak hizalama türünü tanımlar.

Değiştirgeler

hizalama

Hizalama sabitlerinden biri.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::setStrokeWidth
ImagickDraw::setTextAntialias
ImagickDraw sınıfı


Metne kenar yumuşatma uygulanıp uygulanmayacağını denetler

ImagickDraw::setTextAlignment
ImagickDraw::setTextDecoration
ImagickDraw sınıfı
PHP Manual

ImagickDraw::setTextAntialias

(PECL imagick 2.0.0)

ImagickDraw::setTextAntialias — Metne kenar yumuşatma uygulanıp uygulanmayacağını denetler

Açıklama

bool ImagickDraw::setTextAntialias ( bool $yumuşat )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Metne kenar yumuşatma uygulanıp uygulanmayacağını denetler. Öntanımlı olarak kenar yumuşatma uygulanır.

Değiştirgeler

yumuşat

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::setTextAlignment
ImagickDraw::setTextDecoration
ImagickDraw sınıfı


Bir karakter süslemesi tanımlar

ImagickDraw::setTextAntialias
ImagickDraw::setTextEncoding
ImagickDraw sınıfı
PHP Manual

ImagickDraw::setTextDecoration

(PECL imagick 2.0.0)

ImagickDraw::setTextDecoration — Bir karakter süslemesi tanımlar

Açıklama

bool ImagickDraw::setTextDecoration ( int $süs )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Metin çizilirken uygulanacak süsleme belirtilir.

Değiştirgeler

süs

Süsleme türü sabitlerinden biri.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::setTextAntialias
ImagickDraw::setTextEncoding
ImagickDraw sınıfı


Metin karakter kümesini tanımlar

ImagickDraw::setTextDecoration
ImagickDraw::setTextInterlineSpacing
ImagickDraw sınıfı
PHP Manual

ImagickDraw::setTextEncoding

(PECL imagick 2.0.0)

ImagickDraw::setTextEncoding — Metin karakter kümesini tanımlar

Açıklama

bool ImagickDraw::setTextEncoding ( string $karküm )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Metinleri çizerken kullanılacak karakter kümesini tanımlar. Şimdilik belirtilebilecek tek karakter kümesi, Evrenkod karakterlerini çok baytlı olarak ifade eden "UTF-8"'dir. karküm olarak boş bir dizge belirtirseniz sistem öntanımlısı kullanılır. Metinlerin başarıyla çizilebilmesi için Evrenkod destekli yazı tipleri kullanmalısınız.

Değiştirgeler

karküm

Karakter kümesi ismi.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::setTextDecoration
ImagickDraw::setTextInterlineSpacing
ImagickDraw sınıfı


Description

ImagickDraw::setTextEncoding
ImagickDraw::setTextInterwordSpacing
ImagickDraw sınıfı
PHP Manual

ImagickDraw::setTextInterlineSpacing

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

ImagickDraw::setTextInterlineSpacing — Description

Açıklama

public void ImagickDraw::setTextInterlineSpacing ( float $spacing )

Sets the text interline spacing.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

spacing

Dönen Değerler

ImagickDraw::setTextEncoding
ImagickDraw::setTextInterwordSpacing
ImagickDraw sınıfı


Description

ImagickDraw::setTextInterlineSpacing
ImagickDraw::setTextKerning
ImagickDraw sınıfı
PHP Manual

ImagickDraw::setTextInterwordSpacing

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

ImagickDraw::setTextInterwordSpacing — Description

Açıklama

public void ImagickDraw::setTextInterwordSpacing ( float $spacing )

Sets the text interword spacing.

Değiştirgeler

spacing

Dönen Değerler

ImagickDraw::setTextInterlineSpacing
ImagickDraw::setTextKerning
ImagickDraw sınıfı


Description

ImagickDraw::setTextInterwordSpacing
ImagickDraw::setTextUnderColor
ImagickDraw sınıfı
PHP Manual

ImagickDraw::setTextKerning

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

ImagickDraw::setTextKerning — Description

Açıklama

public void ImagickDraw::setTextKerning ( float $kerning )

Sets the text kerning

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

kerning

Dönen Değerler

ImagickDraw::setTextInterwordSpacing
ImagickDraw::setTextUnderColor
ImagickDraw sınıfı


Metin çerçevesinin artalan rengini tanımlar

ImagickDraw::setTextKerning
ImagickDraw::setVectorGraphics
ImagickDraw sınıfı
PHP Manual

ImagickDraw::setTextUnderColor

(PECL imagick 2.0.0)

ImagickDraw::setTextUnderColor — Metin çerçevesinin artalan rengini tanımlar

Açıklama

bool ImagickDraw::setTextUnderColor ( ImagickPixel $artalan )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Metin çerçevesinin artalan rengini tanımlar.

Değiştirgeler

artalan

Artalan rengi.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::setTextKerning
ImagickDraw::setVectorGraphics
ImagickDraw sınıfı


Yöney çizgesini tanımlar

ImagickDraw::setTextUnderColor
ImagickDraw::setViewbox
ImagickDraw sınıfı
PHP Manual

ImagickDraw::setVectorGraphics

(PECL imagick 2.0.0)

ImagickDraw::setVectorGraphics — Yöney çizgesini tanımlar

Açıklama

bool ImagickDraw::setVectorGraphics ( string $xml )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Belirtilen ImagickDraw nesnesi ile ilişkili yöney çizgesini tanımlar. Bu yöntemi, yöney çizgesinin durumununda ısrarcı olmak için bir yöntem olarak ImagickDraw::getVectorGraphics() ile birlikte kullanın.

Değiştirgeler

xml

Yöney çizgesini içeren XML.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

ImagickDraw::setTextUnderColor
ImagickDraw::setViewbox
ImagickDraw sınıfı


Tuval boyutunu uçtan uca tanımlar

ImagickDraw::setVectorGraphics
ImagickDraw::skewX
ImagickDraw sınıfı
PHP Manual

ImagickDraw::setViewbox

(PECL imagick 2.0.0)

ImagickDraw::setViewbox — Tuval boyutunu uçtan uca tanımlar

Açıklama

bool ImagickDraw::setViewbox ( int $x1 , int $y1 , int $x2 , int $y2 )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Tuval boyutunun uçtan uca belirler. Normal olarak,tuval resmi ile aynı boyut kullanılarak belirtilir. Yöney verisi SVG veya MVG biçemleninde saklandığı takdirde, görüntüleyicinin üzerinde yöney verisini kullanacağı tuval boyunu belirtirken bu çerçeve kullanılır.

Değiştirgeler

x1

Sol üst X konumu.

y1

Sol üst Y konumu.

x2

Sağ alt X konumu.

y2

Sağ alt Y konumu.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::setVectorGraphics
ImagickDraw::skewX
ImagickDraw sınıfı


Geçerli koordinat sistemini yatayda belirtilen açıda eğer

ImagickDraw::setViewbox
ImagickDraw::skewY
ImagickDraw sınıfı
PHP Manual

ImagickDraw::skewX

(PECL imagick 2.0.0)

ImagickDraw::skewX — Geçerli koordinat sistemini yatayda belirtilen açıda eğer

Açıklama

bool ImagickDraw::skewX ( float $derece )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Geçerli koordinat sistemini yatayda belirtilen açıda eğer.

Değiştirgeler

derece

Eğim açısı.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::setViewbox
ImagickDraw::skewY
ImagickDraw sınıfı


Geçerli koordinat sistemini düşeyde belirtilen açıda eğer

ImagickDraw::skewX
ImagickDraw::translate
ImagickDraw sınıfı
PHP Manual

ImagickDraw::skewY

(PECL imagick 2.0.0)

ImagickDraw::skewY — Geçerli koordinat sistemini düşeyde belirtilen açıda eğer

Açıklama

bool ImagickDraw::skewY ( float $derece )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Geçerli koordinat sistemini düşey yönde belirtilen açıda eğer.

Değiştirgeler

derece

Eğim açısı.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::skewX
ImagickDraw::translate
ImagickDraw sınıfı


Geçerli koordinat sisteminin başnoktasını değiştirir

ImagickDraw::skewY
ImagickPixel sınıfı
ImagickDraw sınıfı
PHP Manual

ImagickDraw::translate

(PECL imagick 2.0.0)

ImagickDraw::translate — Geçerli koordinat sisteminin başnoktasını değiştirir

Açıklama

bool ImagickDraw::translate ( float $x , float $y )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Geçerli koordinat sisteminin başnoktasını belirtilen koordinatlara taşımak suretiyle koordinat sistemine bir dönüşüm uygular.

Değiştirgeler

x

Yatay dönüşüm noktası.

y

Düşey dönüşüm noktası.

Dönen Değerler

Hiçbir değer dönmez.

ImagickDraw::skewY
ImagickPixel sınıfı
ImagickDraw sınıfı


ImagickPixel sınıfı

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Sınıf Sözdizimi

ImagickPixel {
bool clear ( void )
ImagickPixel __construct ([ string $renk ] )
bool destroy ( void )
array getColor ([ bool $normal = false ] )
string getColorAsString ( void )
int getColorCount ( void )
public mixed getColorQuantum ( void )
float getColorValue ( int $kanal )
public mixed getColorValueQuantum ( void )
array getHSL ( void )
public int getIndex ( void )
bool isPixelSimilar ( ImagickPixel $color , float $fuzz )
public bool isPixelSimilarQuantum ( string $color [, string $fuzz ] )
bool isSimilar ( ImagickPixel $renk , float $benzerlik )
bool setColor ( string $renk )
public void setcolorcount ( string $colorCount )
bool setColorValue ( int $kanal , float $değer )
public void setColorValueQuantum ( int $color , mixed $value )
bool setHSL ( float $sıcaklık , float $doygunluk , float $parlaklık )
public void setIndex ( int $index )
}

İçindekiler

  • ImagickPixel::clear — Nesne ile ilişkili özkaynakları temizler
  • ImagickPixel::__construct — ImagickPixel nesnesini oluşturur
  • ImagickPixel::destroy — Nesne ile ilgili özkaynakları serbest bırakır
  • ImagickPixel::getColor — Bir renk döndürür
  • ImagickPixel::getColorAsString — Rengi bir dizge olarak döndürür
  • ImagickPixel::getColorCount — Nesnenin renk sayısını döndürür
  • ImagickPixel::getColorQuantum — Description
  • ImagickPixel::getColorValue — Belirtilen renk kanalının normalleştirilmiş değerini döndürür
  • ImagickPixel::getColorValueQuantum — Description
  • ImagickPixel::getHSL — ImagickPixel nesnesinin normalleştirilmiş HSL rengini döndürür
  • ImagickPixel::getIndex — Description
  • ImagickPixel::isPixelSimilar — Check the distance between this color and another
  • ImagickPixel::isPixelSimilarQuantum — Description
  • ImagickPixel::isSimilar — İki renk arasındaki benzerliği hesaplar
  • ImagickPixel::setColor — Renk tanımlar
  • ImagickPixel::setColorCount — Description
  • ImagickPixel::setColorValue — Renk kanallarından birinin normalleştirilmiş değerini belirler
  • ImagickPixel::setColorValueQuantum — Description
  • ImagickPixel::setHSL — Normalleştirilmiş HSL rengini ayarlar
  • ImagickPixel::setIndex — Description
ImagickDraw::translate
ImagickPixel::clear
ImageMagick


Nesne ile ilişkili özkaynakları temizler

ImagickPixel sınıfı
ImagickPixel::__construct
ImagickPixel sınıfı
PHP Manual

ImagickPixel::clear

(PECL imagick 2.0.0)

ImagickPixel::clear — Nesne ile ilişkili özkaynakları temizler

Açıklama

bool ImagickPixel::clear ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Belirtilen ImagickPixel nesnesini ilk oluşturulduğu duruma döndürür. Bu ayrıca, nesne ile ilişkilendirilmiş rengi de tanımsız yapar.

Dönen Değerler

Başarı durumunda TRUE döner.

ImagickPixel sınıfı
ImagickPixel::__construct
ImagickPixel sınıfı


ImagickPixel nesnesini oluşturur

ImagickPixel::clear
ImagickPixel::destroy
ImagickPixel sınıfı
PHP Manual

ImagickPixel::__construct

(PECL imagick 2.0.0)

ImagickPixel::__construct — ImagickPixel nesnesini oluşturur

Açıklama

ImagickPixel ImagickPixel::__construct ([ string $renk ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ImagickPixel nesnesini oluşturur. Bir renk belirtilmişse nesne bu renk kullanılarak ilklendirilir.

Değiştirgeler

renk

Bu nesnenin ilklendirilmesinde kullanılmak üzere belirtilmesi isteğe bağlı renk dizgesi.

Dönen Değerler

Oluşturma veya ilklendirme başarılı olursa bir ImagickPixel nesnesi döner, aksi halde bir ImagickPixelException istisnası oluşur.

ImagickPixel::clear
ImagickPixel::destroy
ImagickPixel sınıfı


Nesne ile ilgili özkaynakları serbest bırakır

ImagickPixel::__construct
ImagickPixel::getColor
ImagickPixel sınıfı
PHP Manual

ImagickPixel::destroy

(PECL imagick 2.0.0)

ImagickPixel::destroy — Nesne ile ilgili özkaynakları serbest bırakır

Açıklama

bool ImagickPixel::destroy ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ImagickPixel nesnesi tarafından kullanılmış özkaynakları serbest bırakarak (nesneyi silerek) nesne ile ilişkilendirilmiş rengi tanımsız yapar. Nesne bu yöntem çağrıldıktan sonra artık kullanılmamalıdır.

Dönen Değerler

Başarı durumunda TRUE döner.

ImagickPixel::__construct
ImagickPixel::getColor
ImagickPixel sınıfı


Bir renk döndürür

ImagickPixel::destroy
ImagickPixel::getColorAsString
ImagickPixel sınıfı
PHP Manual

ImagickPixel::getColor

(PECL imagick 2.0.0)

ImagickPixel::getColor — Bir renk döndürür

Açıklama

array ImagickPixel::getColor ([ bool $normal = false ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ImagickPixel nesnesiyle tanımlanmış rengi bir dizi olarak döndürür. Renk bir matlık kanalına sahipse bu dördüncü bir elemanla sağlanır.

Değiştirgeler

normal

Renk değerleri normalleştirilmiş mi? FALSE öntanımlıdır.

Dönen Değerler

Kanal değerlerini içeren bir dizi. Değiştirge olarak TRUE belirtilmişse elemanların her biri normalleştirilmiş bir değer içerir. Bir hata durumunda ImagickPixelException istisnası oluşur.

ImagickPixel::destroy
ImagickPixel::getColorAsString
ImagickPixel sınıfı


Rengi bir dizge olarak döndürür

ImagickPixel::getColor
ImagickPixel::getColorCount
ImagickPixel sınıfı
PHP Manual

ImagickPixel::getColorAsString

(PECL imagick 2.1.0)

ImagickPixel::getColorAsString — Rengi bir dizge olarak döndürür

Açıklama

string ImagickPixel::getColorAsString ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ImagickPixel nesnesinin rengini bir dizge olarak döndürür.

Değiştirgeler

Dönen Değerler

ImagickPixel nesnesinin rengi bir dizge olarak döner.

ImagickPixel::getColor
ImagickPixel::getColorCount
ImagickPixel sınıfı


Nesnenin renk sayısını döndürür

ImagickPixel::getColorAsString
ImagickPixel::getColorQuantum
ImagickPixel sınıfı
PHP Manual

ImagickPixel::getColorCount

(PECL imagick 2.0.0)

ImagickPixel::getColorCount — Nesnenin renk sayısını döndürür

Açıklama

int ImagickPixel::getColorCount ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Belirtilen renk nesnesi ile ilişkili renk sayısını döndürür.

Dönen Değerler

Başarı durumunda renk sayısı bir tamsayı olarak döner, aksi takdirde bir ImagickPixelException istisnası oluşur.

ImagickPixel::getColorAsString
ImagickPixel::getColorQuantum
ImagickPixel sınıfı


Description

ImagickPixel::getColorCount
ImagickPixel::getColorValue
ImagickPixel sınıfı
PHP Manual

ImagickPixel::getColorQuantum

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

ImagickPixel::getColorQuantum — Description

Açıklama

public mixed ImagickPixel::getColorQuantum ( void )

Returns the color of the pixel in an array as Quantum values. If ImageMagick was compiled as HDRI these will be floats, otherwise they will be integers.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The quantum value of the color element. Float if ImageMagick was compiled with HDRI, otherwise an int.

ImagickPixel::getColorCount
ImagickPixel::getColorValue
ImagickPixel sınıfı


Belirtilen renk kanalının normalleştirilmiş değerini döndürür

ImagickPixel::getColorQuantum
ImagickPixel::getColorValueQuantum
ImagickPixel sınıfı
PHP Manual

ImagickPixel::getColorValue

(PECL imagick 2.0.0)

ImagickPixel::getColorValue — Belirtilen renk kanalının normalleştirilmiş değerini döndürür

Açıklama

float ImagickPixel::getColorValue ( int $kanal )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Belirtilen renk kanalının değerini 0 ile 1 arasında bir gerçek sayı olarak döndürür.

Değiştirgeler

kanal

Imagick kanal sabitlerinden biri.

Dönen Değerler

Belirtilen renk kanalının değerini 0 ile 1 arasında bir gerçek sayı olarak döndürür. Bir hata durumunda bir ImagickPixelException istisnası oluşur.

ImagickPixel::getColorQuantum
ImagickPixel::getColorValueQuantum
ImagickPixel sınıfı


Description

ImagickPixel::getColorValue
ImagickPixel::getHSL
ImagickPixel sınıfı
PHP Manual

ImagickPixel::getColorValueQuantum

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

ImagickPixel::getColorValueQuantum — Description

Açıklama

public mixed ImagickPixel::getColorValueQuantum ( void )

Gets the quantum value of a color in the ImagickPixel. Return value is a float if ImageMagick was compiled with HDRI, otherwise an integer.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The quantum value of the color element. Float if ImageMagick was compiled with HDRI, otherwise an int.

Örnekler

Örnek 1 ImagickPixel::getColorValueQuantum()

<?php
        $color = new \ImagickPixel('rgb(128, 5, 255)');
        $colorRed = $color->getColorValueQuantum(\Imagick::COLOR_RED);
        $colorGreen = $color->getColorValueQuantum(\Imagick::COLOR_GREEN);
        $colorBlue = $color->getColorValueQuantum(\Imagick::COLOR_BLUE);
        $colorAlpha = $color->getColorValueQuantum(\Imagick::COLOR_ALPHA);

        printf(
            "Red: %s Green: %s  Blue %s Alpha: %s",
            $colorRed,
            $colorGreen,
            $colorBlue,
            $colorAlpha
        );

?>

ImagickPixel::getColorValue
ImagickPixel::getHSL
ImagickPixel sınıfı


ImagickPixel nesnesinin normalleştirilmiş HSL rengini döndürür

ImagickPixel::getColorValueQuantum
ImagickPixel::getIndex
ImagickPixel sınıfı
PHP Manual

ImagickPixel::getHSL

(PECL imagick 2.0.0)

ImagickPixel::getHSL — ImagickPixel nesnesinin normalleştirilmiş HSL rengini döndürür

Açıklama

array ImagickPixel::getHSL ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bir ImagickPixel nesnesi olarak tanımlı normalleştirilmiş HSL rengini her elemanında 0.0 ile 1.0 arasında bir değer içeren üç elemanlı bir dizi olarak döndürür.

Dönen Değerler

Rengin sıcaklık, doygunluk ve parlaklık değerleri sırayla "hue", "saturation" ve "luminosity" anahtarlarıyla bir ilişkisel dizi olarak döner. Başarısızlık durumunda bir ImagickPixelException istisnası oluşur.

ImagickPixel::getColorValueQuantum
ImagickPixel::getIndex
ImagickPixel sınıfı


Description

ImagickPixel::getHSL
ImagickPixel::isPixelSimilar
ImagickPixel sınıfı
PHP Manual

ImagickPixel::getIndex

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

ImagickPixel::getIndex — Description

Açıklama

public int ImagickPixel::getIndex ( void )

Gets the colormap index of the pixel wand.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

ImagickPixel::getHSL
ImagickPixel::isPixelSimilar
ImagickPixel sınıfı


Check the distance between this color and another

ImagickPixel::getIndex
ImagickPixel::isPixelSimilarQuantum
ImagickPixel sınıfı
PHP Manual

ImagickPixel::isPixelSimilar

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

ImagickPixel::isPixelSimilar — Check the distance between this color and another

Açıklama

bool ImagickPixel::isPixelSimilar ( ImagickPixel $color , float $fuzz )

Checks the distance between the color described by this ImagickPixel object and that of the provided object, by plotting their RGB values on the color cube. If the distance between the two points is less than the fuzz value given, the colors are similar. This method replaces ImagickPixel::isSimilar() and correctly normalises the fuzz value to ImageMagick QuantumRange.

Değiştirgeler

color

The ImagickPixel object to compare this object against.

fuzz

The maximum distance within which to consider these colors as similar. The theoretical maximum for this value is the square root of three (1.732).

Dönen Değerler

Başarı durumunda TRUE döner.

ImagickPixel::getIndex
ImagickPixel::isPixelSimilarQuantum
ImagickPixel sınıfı


Description

ImagickPixel::isPixelSimilar
ImagickPixel::isSimilar
ImagickPixel sınıfı
PHP Manual

ImagickPixel::isPixelSimilarQuantum

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

ImagickPixel::isPixelSimilarQuantum — Description

Açıklama

public bool ImagickPixel::isPixelSimilarQuantum ( string $color [, string $fuzz ] )

Returns true if the distance between two colors is less than the specified distance. The fuzz value should be in the range 0-QuantumRange. The maximum value represents the longest possible distance in the colorspace. e.g. from RGB(0, 0, 0) to RGB(255, 255, 255) for the RGB colorspace

Değiştirgeler

color

fuzz

Dönen Değerler

ImagickPixel::isPixelSimilar
ImagickPixel::isSimilar
ImagickPixel sınıfı


İki renk arasındaki benzerliği hesaplar

ImagickPixel::isPixelSimilarQuantum
ImagickPixel::setColor
ImagickPixel sınıfı
PHP Manual

ImagickPixel::isSimilar

(PECL imagick 2.0.0)

ImagickPixel::isSimilar — İki renk arasındaki benzerliği hesaplar

Açıklama

bool ImagickPixel::isSimilar ( ImagickPixel $renk , float $benzerlik )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

renk değiştirgesi ile belirtilen ImagickPixel nesnesinin rengi ile bu nesnenin rengi arasındaki benzerliği hesaplar. Eğer iki nesne arasındaki benzerlik benzerlik ile belirtilen değerden küçükse iki renk benzerdir. Bu işlev eskidir. Yerine ImagickPixel::isPixelSimilar() kullanılnalıdır.

Değiştirgeler

renk

Bu nesne ile karşılaştırılacak ImagickPixel nesnesi.

benzerlik

Renkler arasındaki azami benzerlik. Örneğin bu değere 10 atarsanız, renk kırmızı ise ve kırmızının koyulukları 100 ve 102 ise bu iki renk aynı kabul edilir. Bu değerin kuramsal azamisi üçün kareköküne eşit bir değerdir (1.732).

Dönen Değerler

Başarı durumunda TRUE döner.

ImagickPixel::isPixelSimilarQuantum
ImagickPixel::setColor
ImagickPixel sınıfı


Renk tanımlar

ImagickPixel::isSimilar
ImagickPixel::setColorCount
ImagickPixel sınıfı
PHP Manual

ImagickPixel::setColor

(PECL imagick 2.0.0)

ImagickPixel::setColor — Renk tanımlar

Açıklama

bool ImagickPixel::setColor ( string $renk )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Bir renk dizgesi olarak verilen rengi ImagickPixel nesnesi olarak tanımlar. Renk dizgesi örnekleri: "blue", "#0000ff", "rgb(0,0,255)", "cmyk(100,100,100,10)"

Değiştirgeler

renk

ImagickPixel nesnesini ilklendirmekte kullanılacak renk dizgesi.

Dönen Değerler

Belirtilen renk ile nesne tanımlanabilmişse TRUE aksi takdirde FALSE.

ImagickPixel::isSimilar
ImagickPixel::setColorCount
ImagickPixel sınıfı


Description

ImagickPixel::setColor
ImagickPixel::setColorValue
ImagickPixel sınıfı
PHP Manual

ImagickPixel::setColorCount

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

ImagickPixel::setColorCount — Description

Açıklama

public void ImagickPixel::setcolorcount ( string $colorCount )

Sets the color count associated with this color.

Değiştirgeler

colorCount

Dönen Değerler

ImagickPixel::setColor
ImagickPixel::setColorValue
ImagickPixel sınıfı


Renk kanallarından birinin normalleştirilmiş değerini belirler

ImagickPixel::setColorCount
ImagickPixel::setColorValueQuantum
ImagickPixel sınıfı
PHP Manual

ImagickPixel::setColorValue

(PECL imagick 2.0.0)

ImagickPixel::setColorValue — Renk kanallarından birinin normalleştirilmiş değerini belirler

Açıklama

bool ImagickPixel::setColorValue ( int $kanal , float $değer )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

0 ile 1 arasında bir değerle belirtilen renk kanalı değeriyle nesnenin rengini ayarlar. Bu işlev bir ImagickPixel nesnesi için bir matlık kanalı sağlamakta kullanılabilir.

Değiştirgeler

kanal

Imagick kanal rengi sabitlerinden biri.

değer

Kanal değeri 0 ile 1 arasında olmalıdır.

Dönen Değerler

Başarı durumunda TRUE döner.

ImagickPixel::setColorCount
ImagickPixel::setColorValueQuantum
ImagickPixel sınıfı


Description

ImagickPixel::setColorValue
ImagickPixel::setHSL
ImagickPixel sınıfı
PHP Manual

ImagickPixel::setColorValueQuantum

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

ImagickPixel::setColorValueQuantum — Description

Açıklama

public void ImagickPixel::setColorValueQuantum ( int $color , mixed $value )

Sets the quantum value of a color element of the ImagickPixel.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

color

Which color element to set e.g. \Imagick::COLOR_GREEN.

value

The quantum value to set the color element to. This should be a float if ImageMagick was compiled with HDRI otherwise an int in the range 0 to Imagick::getQuantum().

Dönen Değerler

Örnekler

Örnek 1 ImagickPixel::setColorValueQuantum()

<?php
function setColorValueQuantum() {
    $image = new \Imagick();

    $quantumRange = $image->getQuantumRange();

    $draw = new \ImagickDraw();
    $color = new \ImagickPixel('blue');
    $color->setcolorValueQuantum(\Imagick::COLOR_RED, 128 * $quantumRange['quantumRangeLong'] / 256);

    $draw->setstrokewidth(1.0);
    $draw->setStrokeColor($color);
    $draw->setFillColor($color);
    $draw->rectangle(200, 200, 300, 300);

    $image->newImage(500, 500, "SteelBlue2");
    $image->setImageFormat("png");

    $image->drawImage($draw);

    header("Content-Type: image/png");
    echo $image->getImageBlob();
}

?>

ImagickPixel::setColorValue
ImagickPixel::setHSL
ImagickPixel sınıfı


Normalleştirilmiş HSL rengini ayarlar

ImagickPixel::setColorValueQuantum
ImagickPixel::setIndex
ImagickPixel sınıfı
PHP Manual

ImagickPixel::setHSL

(PECL imagick 2.0.0)

ImagickPixel::setHSL — Normalleştirilmiş HSL rengini ayarlar

Açıklama

bool ImagickPixel::setHSL ( float $sıcaklık , float $doygunluk , float $parlaklık )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ImagickPixel nesnesi ile tanımlanan rengin sıcaklığını, doygunluğunu ve parlaklığını normalleştirir.

Değiştirgeler

sıcaklık

Kırmızının değeri 0 olmak üzere sıcaklık dairesindeki bir yay parçası olarak (0 ile 1 arasında) renk sıcaklığının (hue) normalleştirilmiş değeri.

doygunluk

Doygunluk için normalleştirilmiş değer; tam doygunluk 1'dir.

parlaklık

Parlaklık için normalleştirilmiş değer. 0.5 parlaklıkla tam sıcaklık ve doygunluğun sağlandığı siyahın 0, beyazın 1 ile temsil edildiği bir aralıkta belirtilir.

Dönen Değerler

Başarı durumunda TRUE döner.

ImagickPixel::setColorValueQuantum
ImagickPixel::setIndex
ImagickPixel sınıfı


Description

ImagickPixel::setHSL
ImagickPixelIterator sınıfı
ImagickPixel sınıfı
PHP Manual

ImagickPixel::setIndex

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

ImagickPixel::setIndex — Description

Açıklama

public void ImagickPixel::setIndex ( int $index )

Sets the colormap index of the pixel wand.

Değiştirgeler

index

Dönen Değerler

ImagickPixel::setHSL
ImagickPixelIterator sınıfı
ImagickPixel sınıfı


ImagickPixelIterator sınıfı

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Sınıf Sözdizimi

ImagickPixelIterator {
bool clear ( void )
ImagickPixelIterator __construct ( Imagick $kalem )
bool destroy ( void )
array getCurrentIteratorRow ( void )
int getIteratorRow ( void )
array getNextIteratorRow ( void )
array getPreviousIteratorRow ( void )
bool newPixelIterator ( Imagick $kalem )
bool newPixelRegionIterator ( Imagick $kalem , int $x , int $y , int $sütun_sayısı , int $satır_sayısı )
bool resetIterator ( void )
bool setIteratorFirstRow ( void )
bool setIteratorLastRow ( void )
bool setIteratorRow ( int $satır )
bool syncIterator ( void )
}

İçindekiler

  • ImagickPixelIterator::clear — Piksel yineleyici ile ilişkili özkaynakları temizler
  • ImagickPixelIterator::__construct — Bir ImagickPixelIterator nesnesi oluşturur
  • ImagickPixelIterator::destroy — Piksel yineleyici ile ilişkili özkaynakları serbest bırakır
  • ImagickPixelIterator::getCurrentIteratorRow — Piksel yineleyicinin üzerinde bulunduğu ImagickPixel nesneleri satırını döndürür
  • ImagickPixelIterator::getIteratorRow — Piksel yineleyicinin üzerinde bulunduğu satırın numarasını döndürür
  • ImagickPixelIterator::getNextIteratorRow — Piksel yineleyicinin sonraki satırını döndürür
  • ImagickPixelIterator::getPreviousIteratorRow — Önceki satırı döndürür
  • ImagickPixelIterator::newPixelIterator — Yeni bir piksel yineleyici döndürür
  • ImagickPixelIterator::newPixelRegionIterator — Yeni bir bölgesel piksel yineleyicisi döndürür
  • ImagickPixelIterator::resetIterator — Piksel yineleyiciyi sıfırlar
  • ImagickPixelIterator::setIteratorFirstRow — Piksel yineleyiciyi ilk piksel satırına hizalar
  • ImagickPixelIterator::setIteratorLastRow — Piksel yineleyiciyi son piksel satırına hizalar
  • ImagickPixelIterator::setIteratorRow — Piksel yineleyiciyi satırını tanımlar
  • ImagickPixelIterator::syncIterator — Piksel yineleyiciyi eşzamanlar
ImagickPixel::setIndex
ImagickPixelIterator::clear
ImageMagick


Piksel yineleyici ile ilişkili özkaynakları temizler

ImagickPixelIterator sınıfı
ImagickPixelIterator::__construct
ImagickPixelIterator sınıfı
PHP Manual

ImagickPixelIterator::clear

(PECL imagick 2.0.0)

ImagickPixelIterator::clear — Piksel yineleyici ile ilişkili özkaynakları temizler

Açıklama

bool ImagickPixelIterator::clear ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Piksel yineleyiciyi ilk oluşturulduğu duruma getirir.

Dönen Değerler

Başarı durumunda TRUE döner.

ImagickPixelIterator sınıfı
ImagickPixelIterator::__construct
ImagickPixelIterator sınıfı


Bir ImagickPixelIterator nesnesi oluşturur

ImagickPixelIterator::clear
ImagickPixelIterator::destroy
ImagickPixelIterator sınıfı
PHP Manual

ImagickPixelIterator::__construct

(PECL imagick 2.0.0)

ImagickPixelIterator::__construct — Bir ImagickPixelIterator nesnesi oluşturur

Açıklama

ImagickPixelIterator ImagickPixelIterator::__construct ( Imagick $kalem )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Yeni bir ImagickPixelIterator nesnesi oluşturur.

Dönen Değerler

Başarı durumunda TRUE döner.

ImagickPixelIterator::clear
ImagickPixelIterator::destroy
ImagickPixelIterator sınıfı


Piksel yineleyici ile ilişkili özkaynakları serbest bırakır

ImagickPixelIterator::__construct
ImagickPixelIterator::getCurrentIteratorRow
ImagickPixelIterator sınıfı
PHP Manual

ImagickPixelIterator::destroy

(PECL imagick 2.0.0)

ImagickPixelIterator::destroy — Piksel yineleyici ile ilişkili özkaynakları serbest bırakır

Açıklama

bool ImagickPixelIterator::destroy ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Piksel yineleyici ile ilişkili özkaynakları serbest bırakır (nesneyi siler).

Dönen Değerler

Başarı durumunda TRUE döner.

ImagickPixelIterator::__construct
ImagickPixelIterator::getCurrentIteratorRow
ImagickPixelIterator sınıfı


Piksel yineleyicinin üzerinde bulunduğu ImagickPixel nesneleri satırını döndürür

ImagickPixelIterator::destroy
ImagickPixelIterator::getIteratorRow
ImagickPixelIterator sınıfı
PHP Manual

ImagickPixelIterator::getCurrentIteratorRow

(PECL imagick 2.0.0)

ImagickPixelIterator::getCurrentIteratorRow — Piksel yineleyicinin üzerinde bulunduğu ImagickPixel nesneleri satırını döndürür

Açıklama

array ImagickPixelIterator::getCurrentIteratorRow ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Piksel yineleyicinin üzerinde bulunduğu satırı ImagickPixel nesnelerinden oluşan bir dizi olarak döndürür.

Dönen Değerler

Piksel yineleyicinin üzerinde bulunduğu satır, ImagickPixel nesnelerinden oluşan bir dizi olarak döner.

ImagickPixelIterator::destroy
ImagickPixelIterator::getIteratorRow
ImagickPixelIterator sınıfı


Piksel yineleyicinin üzerinde bulunduğu satırın numarasını döndürür

ImagickPixelIterator::getCurrentIteratorRow
ImagickPixelIterator::getNextIteratorRow
ImagickPixelIterator sınıfı
PHP Manual

ImagickPixelIterator::getIteratorRow

(PECL imagick 2.0.0)

ImagickPixelIterator::getIteratorRow — Piksel yineleyicinin üzerinde bulunduğu satırın numarasını döndürür

Açıklama

int ImagickPixelIterator::getIteratorRow ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Piksel yineleyicinin üzerinde bulunduğu satırınn numarasını döndürür.

Dönen Değerler

Satır numarasını bir tamsayı olarak döndürür. Bir hata durumunda bir ImagickPixelIteratorException istisnası oluşur.

ImagickPixelIterator::getCurrentIteratorRow
ImagickPixelIterator::getNextIteratorRow
ImagickPixelIterator sınıfı


Piksel yineleyicinin sonraki satırını döndürür

ImagickPixelIterator::getIteratorRow
ImagickPixelIterator::getPreviousIteratorRow
ImagickPixelIterator sınıfı
PHP Manual

ImagickPixelIterator::getNextIteratorRow

(PECL imagick 2.0.0)

ImagickPixelIterator::getNextIteratorRow — Piksel yineleyicinin sonraki satırını döndürür

Açıklama

array ImagickPixelIterator::getNextIteratorRow ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Sonraki satırı piksel yineleyicideki piksel kalemlerinden oluşan bir dizi olarak döndürür.

Dönen Değerler

Önceki satırı ImagickPixel nesnelerinden oluşan bir dizi olarak döndürür. Bir hata durumunda bir ImagickPixelIteratorException istisnası oluşur.

ImagickPixelIterator::getIteratorRow
ImagickPixelIterator::getPreviousIteratorRow
ImagickPixelIterator sınıfı


Önceki satırı döndürür

ImagickPixelIterator::getNextIteratorRow
ImagickPixelIterator::newPixelIterator
ImagickPixelIterator sınıfı
PHP Manual

ImagickPixelIterator::getPreviousIteratorRow

(PECL imagick 2.0.0)

ImagickPixelIterator::getPreviousIteratorRow — Önceki satırı döndürür

Açıklama

array ImagickPixelIterator::getPreviousIteratorRow ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Önceki satırı piksel yineleyicideki piksel kalemlerinden oluşan bir dizi olarak döndürür.

Dönen Değerler

Önceki satırı ImagickPixel nesnelerinden oluşan bir dizi olarak döndürür. Bir hata durumunda bir ImagickPixelIteratorException istisnası oluşur.

ImagickPixelIterator::getNextIteratorRow
ImagickPixelIterator::newPixelIterator
ImagickPixelIterator sınıfı


Yeni bir piksel yineleyici döndürür

ImagickPixelIterator::getPreviousIteratorRow
ImagickPixelIterator::newPixelRegionIterator
ImagickPixelIterator sınıfı
PHP Manual

ImagickPixelIterator::newPixelIterator

(PECL imagick 2.0.0)

ImagickPixelIterator::newPixelIterator — Yeni bir piksel yineleyici döndürür

Açıklama

bool ImagickPixelIterator::newPixelIterator ( Imagick $kalem )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Yeni bir piksel yineleyici döndürür.

Dönen Değerler

Başarı durumunda TRUE döner. Hata durumunda bir ImagickPixelIteratorException istisnası oluşur.

ImagickPixelIterator::getPreviousIteratorRow
ImagickPixelIterator::newPixelRegionIterator
ImagickPixelIterator sınıfı


Yeni bir bölgesel piksel yineleyicisi döndürür

ImagickPixelIterator::newPixelIterator
ImagickPixelIterator::resetIterator
ImagickPixelIterator sınıfı
PHP Manual

ImagickPixelIterator::newPixelRegionIterator

(PECL imagick 2.0.0)

ImagickPixelIterator::newPixelRegionIterator — Yeni bir bölgesel piksel yineleyicisi döndürür

Açıklama

bool ImagickPixelIterator::newPixelRegionIterator ( Imagick $kalem , int $x , int $y , int $sütun_sayısı , int $satır_sayısı )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Yeni bir bölgesel piksel yineleyicisi döndürür.

Değiştirgeler

kalem

x

y

sütun_sayısı

satır_sayısı

Dönen Değerler

Başarılı olursa yeni bir ImagickPixelIterator nesnesi, aksi takdirde bir ImagickPixelIteratorException istisnası oluşur.

ImagickPixelIterator::newPixelIterator
ImagickPixelIterator::resetIterator
ImagickPixelIterator sınıfı


Piksel yineleyiciyi sıfırlar

ImagickPixelIterator::newPixelRegionIterator
ImagickPixelIterator::setIteratorFirstRow
ImagickPixelIterator sınıfı
PHP Manual

ImagickPixelIterator::resetIterator

(PECL imagick 2.0.0)

ImagickPixelIterator::resetIterator — Piksel yineleyiciyi sıfırlar

Açıklama

bool ImagickPixelIterator::resetIterator ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Piksel yineleyiciyi sıfırlar. Bir piksel taşıyıcısındaki tüm pikseller üzerinde yineleme yapmak için ImagickPixelIterator::getNextIteratorRow() ile birlikte kullanınız.

Dönen Değerler

Başarı durumunda TRUE döner.

ImagickPixelIterator::newPixelRegionIterator
ImagickPixelIterator::setIteratorFirstRow
ImagickPixelIterator sınıfı


Piksel yineleyiciyi ilk piksel satırına hizalar

ImagickPixelIterator::resetIterator
ImagickPixelIterator::setIteratorLastRow
ImagickPixelIterator sınıfı
PHP Manual

ImagickPixelIterator::setIteratorFirstRow

(PECL imagick 2.0.0)

ImagickPixelIterator::setIteratorFirstRow — Piksel yineleyiciyi ilk piksel satırına hizalar

Açıklama

bool ImagickPixelIterator::setIteratorFirstRow ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Piksel yineleyiciyi ilk piksel satırına hizalar.

Dönen Değerler

Başarı durumunda TRUE döner.

ImagickPixelIterator::resetIterator
ImagickPixelIterator::setIteratorLastRow
ImagickPixelIterator sınıfı


Piksel yineleyiciyi son piksel satırına hizalar

ImagickPixelIterator::setIteratorFirstRow
ImagickPixelIterator::setIteratorRow
ImagickPixelIterator sınıfı
PHP Manual

ImagickPixelIterator::setIteratorLastRow

(PECL imagick 2.0.0)

ImagickPixelIterator::setIteratorLastRow — Piksel yineleyiciyi son piksel satırına hizalar

Açıklama

bool ImagickPixelIterator::setIteratorLastRow ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Piksel yineleyiciyi son piksel satırına hizalar.

Dönen Değerler

Başarı durumunda TRUE döner.

ImagickPixelIterator::setIteratorFirstRow
ImagickPixelIterator::setIteratorRow
ImagickPixelIterator sınıfı


Piksel yineleyiciyi satırını tanımlar

ImagickPixelIterator::setIteratorLastRow
ImagickPixelIterator::syncIterator
ImagickPixelIterator sınıfı
PHP Manual

ImagickPixelIterator::setIteratorRow

(PECL imagick 2.0.0)

ImagickPixelIterator::setIteratorRow — Piksel yineleyiciyi satırını tanımlar

Açıklama

bool ImagickPixelIterator::setIteratorRow ( int $satır )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Piksel yineleyiciyi satırını tanımlar.

Değiştirgeler

satır

Dönen Değerler

Başarı durumunda TRUE döner.

ImagickPixelIterator::setIteratorLastRow
ImagickPixelIterator::syncIterator
ImagickPixelIterator sınıfı


Piksel yineleyiciyi eşzamanlar

ImagickPixelIterator::setIteratorRow
Postayla İlgili Eklentiler
ImagickPixelIterator sınıfı
PHP Manual

ImagickPixelIterator::syncIterator

(PECL imagick 2.0.0)

ImagickPixelIterator::syncIterator — Piksel yineleyiciyi eşzamanlar

Açıklama

bool ImagickPixelIterator::syncIterator ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Piksel yineleyiciyi eşzamanlar.

Dönen Değerler

Başarı durumunda TRUE döner.

ImagickPixelIterator::setIteratorRow
Postayla İlgili Eklentiler
ImagickPixelIterator sınıfı


Postayla İlgili Eklentiler

  • Cyrus — Cyrus IMAP administration
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Cyrus İşlevleri
  • IMAP — IMAP, POP3 ve NNTP
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • IMAP İşlevleri
  • Eposta
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Eposta İşlevleri
  • Mailparse
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Mailparse İşlevleri
  • vpopmail
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • vpopmail İşlevleri
ImagickPixelIterator::syncIterator
Cyrus
İşlev Başvuru Kılavuzu


Cyrus IMAP administration

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Cyrus İşlevleri
    • cyrus_authenticate — Authenticate against a Cyrus IMAP server
    • cyrus_bind — Bind callbacks to a Cyrus IMAP connection
    • cyrus_close — Close connection to a Cyrus IMAP server
    • cyrus_connect — Connect to a Cyrus IMAP server
    • cyrus_query — Send a query to a Cyrus IMAP server
    • cyrus_unbind — Unbind ...
Postayla İlgili Eklentiler
Giriş
Postayla İlgili Eklentiler


Giriş

Bilginize: Bu eklenti Windows sistemlerinde çalışmaz.

Bilginize:

Bu eklenti » PECL deposuna taşınmış olup şu sürümden itibaren PHP kaynak paketinde dağıtılmamaktatır: PHP 5.0.0.

Cyrus
Yapılandırma/Kurulum
Cyrus


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Cyrus


Kurulum

To enable Cyrus IMAP support and to use these functions you have to compile PHP with the --with-cyrus option.

Uyarı

IMAP, recode, YAZ ve Cyrus eklentileri, aynı dahili simgeleri paylaştıklarından birlikte kullanılamazlar. Bilgi: Yaz 2.0 ve sonrası bu sorundan etkilenmemektedir.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Özkaynak Türleri

This extension defines a Cyrus IMAP connection identifier returned by cyrus_connect().

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

CYRUS_CONN_NONSYNCLITERAL (integer)
CYRUS_CONN_INITIALRESPONSE (integer)
CYRUS_CALLBACK_NUMBERED (integer)
CYRUS_CALLBACK_NOLITERAL (integer)
Özkaynak Türleri
Cyrus İşlevleri
Cyrus


Cyrus İşlevleri

İçindekiler

  • cyrus_authenticate — Authenticate against a Cyrus IMAP server
  • cyrus_bind — Bind callbacks to a Cyrus IMAP connection
  • cyrus_close — Close connection to a Cyrus IMAP server
  • cyrus_connect — Connect to a Cyrus IMAP server
  • cyrus_query — Send a query to a Cyrus IMAP server
  • cyrus_unbind — Unbind ...
Öntanımlı Sabitler
cyrus_authenticate
Cyrus


Authenticate against a Cyrus IMAP server

Cyrus İşlevleri
cyrus_bind
Cyrus İşlevleri
PHP Manual

cyrus_authenticate

(PHP 4 >= 4.1.0, PECL cyrus 1.0)

cyrus_authenticate — Authenticate against a Cyrus IMAP server

Açıklama

void cyrus_authenticate ( resource $connection [, string $mechlist [, string $service [, string $user [, int $minssf [, int $maxssf [, string $authname [, string $password ]]]]]]] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Dönen Değerler

Hiçbir değer dönmez.

Cyrus İşlevleri
cyrus_bind
Cyrus İşlevleri


Bind callbacks to a Cyrus IMAP connection

cyrus_authenticate
cyrus_close
Cyrus İşlevleri
PHP Manual

cyrus_bind

(PHP 4 >= 4.1.0, PECL cyrus 1.0)

cyrus_bind — Bind callbacks to a Cyrus IMAP connection

Açıklama

bool cyrus_bind ( resource $connection , array $callbacks )

Binds callbacks to a Cyrus IMAP connection.

Değiştirgeler

connection

The connection handle.

callbacks

An array of callbacks.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

cyrus_authenticate
cyrus_close
Cyrus İşlevleri


Close connection to a Cyrus IMAP server

cyrus_bind
cyrus_connect
Cyrus İşlevleri
PHP Manual

cyrus_close

(PHP 4 >= 4.1.0, PECL cyrus 1.0)

cyrus_close — Close connection to a Cyrus IMAP server

Açıklama

bool cyrus_close ( resource $connection )

Closes the connection to a Cyrus IMAP server.

Değiştirgeler

connection

The connection handle.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

cyrus_bind
cyrus_connect
Cyrus İşlevleri


Connect to a Cyrus IMAP server

cyrus_close
cyrus_query
Cyrus İşlevleri
PHP Manual

cyrus_connect

(PHP 4 >= 4.1.0, PECL cyrus 1.0)

cyrus_connect — Connect to a Cyrus IMAP server

Açıklama

resource cyrus_connect ([ string $host [, string $port [, int $flags ]]] )

Connects to a Cyrus IMAP server.

Değiştirgeler

host

The Cyrus IMAP host name.

port

The port number.

flags

Dönen Değerler

Returns a connection handler on success başarısızlık durumunda FALSE döner.

cyrus_close
cyrus_query
Cyrus İşlevleri


Send a query to a Cyrus IMAP server

cyrus_connect
cyrus_unbind
Cyrus İşlevleri
PHP Manual

cyrus_query

(PHP 4 >= 4.1.0, PECL cyrus 1.0)

cyrus_query — Send a query to a Cyrus IMAP server

Açıklama

array cyrus_query ( resource $connection , string $query )

Sends a query to a Cyrus IMAP server.

Değiştirgeler

connection

The connection handle.

query

The query string.

Dönen Değerler

Returns an associative array with the following keys: text, msgno, and keyword.

cyrus_connect
cyrus_unbind
Cyrus İşlevleri


Unbind ...

cyrus_query
IMAP
Cyrus İşlevleri
PHP Manual

cyrus_unbind

(PHP 4 >= 4.1.0, PECL cyrus 1.0)

cyrus_unbind — Unbind ...

Açıklama

bool cyrus_unbind ( resource $connection , string $trigger_name )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

connection

The connection handle.

trigger_name

The trigger name.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

cyrus_query
IMAP
Cyrus İşlevleri


IMAP, POP3 ve NNTP

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • IMAP İşlevleri
    • imap_8bit — 8 bitlik bir dizgeyi 7 bitlik (quoted-printable) bir dizgeye dönüştürür
    • imap_alerts — Oluşan tüm IMAP uyarı iletilerini döndürür
    • imap_append — Belirtilen posta kutusuna bir dizge ileti ekler
    • imap_base64 — Base64 kodlu dizgeyi 8 bitlik dizgeye dönüştürür
    • imap_binary — 8 bitlik bir dizgeyi bir base64 dizgesine dönüştürür
    • imap_body — İleti gövdesini okur
    • imap_bodystruct — Belirtilen iletinin bir gövde bölümünün yapısını okur
    • imap_check — Posta kutusu bilgilerini döndürür
    • imap_clearflag_full — İletilerdeki imleri temizler
    • imap_close — IMAP akımını kapatır
    • imap_create — Takma Adı: imap_createmailbox
    • imap_createmailbox — Yeni bir posta kutusu oluşturur
    • imap_delete — Belirtilen iletiyi silindi olarak imler
    • imap_deletemailbox — Bir posta kutusunu siler
    • imap_errors — Oluşan tüm IMAP hatalarının iletilerini döndürür
    • imap_expunge — Silindi imli tüm iletileri gerçekten siler
    • imap_fetch_overview — Belirtilen iletinin başlıklarından belli bilgileri toplar
    • imap_fetchbody — Belirtilen iletinin belli bir gövde bölümünü döndürür
    • imap_fetchheader — Bir iletinin başlığını döndürür
    • imap_fetchmime — Fetch MIME headers for a particular section of the message
    • imap_fetchstructure — Belli bir iletinin yapısını okur
    • imap_fetchtext — Takma Adı: imap_body
    • imap_gc — IMAP önbelleğini temizler
    • imap_get_quota — Belirtilen kullanıcının kota ayarlarını döndürür
    • imap_get_quotaroot — Kullanıcının kendi kota ayarlarını döndürür
    • imap_getacl — Belirtilen posta kutusunun erişim izinlerini döndürür
    • imap_getmailboxes — Posta kutuları hakkında ayrıntılı bilgi döndürür
    • imap_getsubscribed — Üyesi olunan tüm posta kutularını listeler
    • imap_header — imap_headerinfo işlevinin takma adıdır
    • imap_headerinfo — Belirtilen iletinin başlığını okur
    • imap_headers — Bir posta kutusu içindeki tüm iletilerin başlıklarını döndürür
    • imap_last_error — Geçerli sayfa isteği sırasında oluşan son IMAP hatasının açıklamasını döndürür
    • imap_list — Posta kutularını listeler
    • imap_listmailbox — imap_list işlevinin takma adıdır
    • imap_listscan — Belirtilen metin ile eşleşen posta kutularını listeler
    • imap_listsubscribed — imap_lsub işlevinin takma adıdır
    • imap_lsub — Üyesi olunan tüm posta kutularını listeler
    • imap_mail_compose — Zarfı ve gövdesi belirtilen MIME iletisini oluşturur
    • imap_mail_copy — Belirtilen iletileri bir posta kutusuna kopyalar
    • imap_mail_move — Belirtilen iletiyi bir posta kutusuna taşır
    • imap_mail — Bir eposta iletisi gönderir
    • imap_mailboxmsginfo — Posta kutusu hakkında bilgi döndürür
    • imap_mime_header_decode — MIME başlık elemanlarının kodlamasını açar
    • imap_msgno — Belirtilen eşsiz kimlik için ileti numarasını döndürür
    • imap_num_msg — Posta kutusundaki ileti sayısını döndürür
    • imap_num_recent — Posta kutusuna en son gelen ileti sayısını döndürür
    • imap_open — Belirtilen posta kutusuna yeni bir IMAP akımı açar
    • imap_ping — Belirtilen IMAP akımı hala etkin mi diye bakar
    • imap_qprint — Bir 7 bitlik dizgeyi 8 bitlik dizgeye dönüştürür
    • imap_rename — Takma Adı: imap_renamemailbox
    • imap_renamemailbox — Posta kutusunun ismini değiştirir
    • imap_reopen — IMAP akımını yeni posta kutusunda yeniden açar
    • imap_rfc822_parse_adrlist — Bir adres dizgesini çözümler
    • imap_rfc822_parse_headers — Bir dizgedeki eposta başlıklarını çözümler
    • imap_rfc822_write_address — Posta kutusu, alan adı ve kişisel bilgi ile gerektiği gibi biçemlenmiş bir eposta adresi dönürür
    • imap_savebody — Belirtilen iletinin gövdesini bir dosyaya kaydeder
    • imap_scan — Takma Adı: imap_listscan
    • imap_scanmailbox — imap_listscan işlevinin takma adıdır
    • imap_search — Belirtilen kurala uyan iletileri bir dizi içinde döndürür
    • imap_set_quota — Belirtilen posta kutusu için bir kota tanımlar
    • imap_setacl — Belirtilen posta kutusu ile ilgili erişim izinlerini tanımlar
    • imap_setflag_full — İletileri imler
    • imap_sort — İletileri sıralar ve döndürür
    • imap_status — Bir posta kutusunun durum bilgisini döndürür
    • imap_subscribe — Bir posta kutusuna üyeliği başlatır
    • imap_thread — Bir iletinin konu ağacını döndürür
    • imap_timeout — IMAP zaman aşımını tanımlar veya döndürür
    • imap_uid — Numarası belirtilen iletiyle ilgili eşsiz kimliği döndürür
    • imap_undelete — Silindi diye imlenmiş bir iletinin imini kaldırır
    • imap_unsubscribe — Bir posta kutusundan üyeliği sonlandırır
    • imap_utf7_decode — Bir dizgenin karakter kodlamasını takviyeli UTF-7'den ISO-8859-1'e dönüştürür
    • imap_utf7_encode — ISO-8859-1 kodlu bir dizgenin kodlamasını takviyeli UTF-7'ye dönüştürür
    • imap_utf8 — MIME kodlu metni UTF-8'e dönüştürür
cyrus_unbind
Giriş
Postayla İlgili Eklentiler


Giriş

Bu işlevler sayesinde sadece IMAP protokolü ile değil NNTP, POP3 ve yerel posta kutusu erişim yöntemleri ile de çalışabilirsiniz.

Bununla birlikte, bazı IMAP işlevlerinin POP protokolü ile düzgün çalışmayacağını bilmenizde yarar var.

IMAP
Yapılandırma/Kurulum
IMAP


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
IMAP


Gereksinimler

Bu eklenti, sisteminizde c-client kütüphanesinin kurulu olmasını gerektirir. En son sürümünü » ftp://ftp.cac.washington.edu/imap/ adresinden indirip kurabilirsiniz.

IMAP kaynak dosyalarının doğrudan sistemin include/ dizinine kopyalanmaması büyük önem taşır, aksi takdirde orada bazı sorunlar çıkabilir. En iyisi sistemde /usr/local/imap-2000b/ gibi yeni bir dizin oluşturup (yeri ve adı kullandığınız IMAP sürümüne bağlıdır) içine lib/ ve include/ gibi yeni dizinler açmaktır. IMAP kaynak ağacınızın c-client dizinindeki tüm *.h dosyalarını include/ altına ve tüm *.c dosyalarını lib/ altına kopyalayın. Buna ek olarak IMAP'ı derlerken c-client.a diye bir dosya oluşturulur. Bu dosyayı da lib/ dizininin altına koyup adını libc-client.a olarak değiştirin.

Bilginize:

c-client kütüphanesinin SSL ve/veya Kerberos destekli olmasını isterseniz paket ile birlikte gelen belgeleri okuyun.

Bilginize: Mandrake Linux'ta, IMAP kütüphanesi (libc-client.a) Kerberos desteği olmaksızın derlenir. SSL'li ayrı bir sürüm daha kurulur (client-PHP4.a). Bu bakımdan Kerberos desteği için kütüphanenin yeniden derlenmesi gerekir.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu işlevlerin çalışması için PHP'yi --with-imap[=DiZiN] seçeneği ile derlemelisiniz. Buradaki DiZiN c-client kurulumunun yapıldığı ana dizindir (PREFIX). Örneğimizde olduğu gibi --with- imap=/usr/local/imap-2000b seçeneğini kullanmalısınız. Bu konum, yukarıda açıklanan DiZiNe bağlı olarak değişiklik gösterebilir. Windows kullanıcılarının php_imap.dll DLL'ini php.ini dosyasına dahil etmeleri gerekebilir.

IMAP, Windows 2000'den önceki sistemlerde desteklenmemektedir. Bunu sebebi posta sunucularına SSL bağlantıları oluşturulurken şifreleme işlevlerinin kullanımıdır.

Bilginize: C-client kütüphanesinin yapılandırmasına bağlı olarak PHP yapılandırma seçeneklerine --with-imap-ssl=/bir/yol/openssl/ ve/veya --with-kerberos=/bir/yol/kerberos seçeneğini eklemeniz gerekebilir.

Uyarı

IMAP, recode, YAZ ve Cyrus eklentileri, aynı dahili simgeleri paylaştıklarından birlikte kullanılamazlar. Bilgi: Yaz 2.0 ve sonrası bu sorundan etkilenmemektedir.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

NIL (integer)
OP_DEBUG (integer)
OP_READONLY (integer)
Open mailbox read-only
OP_ANONYMOUS (integer)
Haberler için bir .newsrc kullanmayın veya güncellemeyin (sadece NNTP için).
OP_SHORTCACHE (integer)
OP_SILENT (integer)
OP_PROTOTYPE (integer)
OP_HALFOPEN (integer)
IMAP ve NNTP isimleri için bir posta kutusu değil bir bağlantı açılır.
OP_EXPUNGE (integer)
OP_SECURE (integer)
CL_EXPUNGE (integer)
imap_close() çağrıldığında kapatmadan önce posta kutusu sessizce silinir.
FT_UID (integer)
Değiştirge bir kullanıcı kimliğidir.
FT_PEEK (integer)
Zaten varsa \Seen seçeneği tekrar atanmaz.
FT_NOT (integer)
FT_INTERNAL (integer)
Dönen dizge dahili biçemde olur, CRLF ile meşrulaştırılmaz.
FT_PREFETCHTEXT (integer)
ST_UID (integer)
Sıralama değiştirgesi sıra numaraları yerine kullanıcı kimliklerini içerir.
ST_SILENT (integer)
ST_SET (integer)
CP_UID (integer)
Sıra numaraları kullanıcı kimliklerini içerir.
CP_MOVE (integer)
imap_mail_copy() ile kopyalandıktan sonra geçerli posta kutusundaki iletiler silinir.
SE_UID (integer)
Sıra numaraları yerine kullanıcı kimlikleri döndürülür.
SE_FREE (integer)
SE_NOPREFETCH (integer)
Aranan iletiler önce alınıp sonra aranmaz.
SO_FREE (integer)
SO_NOSERVER (integer)
SA_MESSAGES (integer)
SA_RECENT (integer)
SA_UNSEEN (integer)
SA_UIDNEXT (integer)
SA_UIDVALIDITY (integer)
SA_ALL (integer)
LATT_NOINFERIORS (integer)
Bu posta kutusunun "çocukları" yoktur (altında başka posta kutusu yoktur).
LATT_NOSELECT (integer)
Bu bir posta kutusu değil sadece bir taşıyıcıdır - bu yüzden onu açamazsınız.
LATT_MARKED (integer)
Posta kutusu imlenmiş. Sadece UW-IMAPD tarafından kullanılır.
LATT_UNMARKED (integer)
Posta kutusu imlenmemiş. Sadece UW-IMAPD tarafından kullanılır.
SORTDATE (integer)
imap_sort() için sıralama kuralı: İleti tarihi.
SORTARRIVAL (integer)
imap_sort() için sıralama kuralı: Geliş tarihi.
SORTFROM (integer)
imap_sort() için sıralama kuralı: İlk Kimden adresindeki posta kutusu.
SORTSUBJECT (integer)
imap_sort() için sıralama kuralı: İleti konusu
SORTTO (integer)
imap_sort() için sıralama kuralı: İlk Kime adresindeki posta kutusu.
SORTCC (integer)
imap_sort() için sıralama kuralı: İlk karbon kopya adresindeki posta kutusu.
SORTSIZE (integer)
imap_sort() için sıralama kuralı: Sekizlik olarak ileti uzunluğu.
TYPETEXT (integer)
TYPEMULTIPART (integer)
TYPEMESSAGE (integer)
TYPEAPPLICATION (integer)
TYPEAUDIO (integer)
TYPEIMAGE (integer)
TYPEVIDEO (integer)
TYPEOTHER (integer)
ENC7BIT (integer)
ENC8BIT (integer)
ENCBINARY (integer)
ENCBASE64 (integer)
ENCQUOTEDPRINTABLE (integer)
ENCOTHER (integer)
IMAP_OPENTIMEOUT (integer)
IMAP_READTIMEOUT (integer)
IMAP_WRITETIMEOUT (integer)
IMAP_CLOSETIMEOUT (integer)
LATT_REFERRAL (integer)
LATT_HASCHILDREN (integer)
LATT_HASNOCHILDREN (integer)
TYPEMODEL (integer)
IMAP_GC_ELT (integer)
Çöp toplayıcı; ileti önbellek elemanlarını temizler.
IMAP_GC_ENV (integer)
Çöp toplayıcı; zarfları ve ileti gövdelerini temizler.
IMAP_GC_TEXTS (integer)
Çöp toplayıcı; metinleri temizler.
Özkaynak Türleri
IMAP İşlevleri
IMAP


IMAP İşlevleri

Ayrıca Bakınız

Bu belgede bulunan işlev açıklamalarında tüm ayrıntılara yer verilememiştir. Bu bilgileri c-client kütüphanesinin belgelerinden ve aşağıdaki RFC'lerden edinebilirsiniz:

  • » RFC2821: Simple Mail Transfer Protocol (SMTP) - Basit dosya Aktarım Protokolü.
  • » RFC2822: Standard for ARPA internet text messages - ARPA genel ağ metin iletileri standardı.
  • » RFC2060: Internet Message Access Protocol (IMAP) Version 4rev1 - Genel ağ İleti Erişim Protokolü 4.1 sürümü.
  • » RFC1939: Post Office Protocol Version 3 (POP3) - Postane Protokolünün 3. sürümü.
  • » RFC977: Network News Transfer Protocol (NNTP) - Ağ Haberleri Aktarım Protokolü.
  • » RFC2076: Common Internet Message Headers - Genel Ağ Ortak İleti Başlıkları.
  • » RFC2045, » RFC2046, » RFC2047, » RFC2048 ve » RFC2049: Multipurpose Internet Mail Extensions (MIME) - Çok Amaçlı Genel Ağ Posta Eklentileri.
Ayrıca, » Programming Internet Email - Genel Ağ Epostasını Programlamak (David Wood) ve » Managing IMAP - IMAP Yönetimi (Dianna Mullet & Kevin Mullet) kitaplarında ayrıntılı bir genel bakış mevcuttur.

İçindekiler

  • imap_8bit — 8 bitlik bir dizgeyi 7 bitlik (quoted-printable) bir dizgeye dönüştürür
  • imap_alerts — Oluşan tüm IMAP uyarı iletilerini döndürür
  • imap_append — Belirtilen posta kutusuna bir dizge ileti ekler
  • imap_base64 — Base64 kodlu dizgeyi 8 bitlik dizgeye dönüştürür
  • imap_binary — 8 bitlik bir dizgeyi bir base64 dizgesine dönüştürür
  • imap_body — İleti gövdesini okur
  • imap_bodystruct — Belirtilen iletinin bir gövde bölümünün yapısını okur
  • imap_check — Posta kutusu bilgilerini döndürür
  • imap_clearflag_full — İletilerdeki imleri temizler
  • imap_close — IMAP akımını kapatır
  • imap_create — Takma Adı: imap_createmailbox
  • imap_createmailbox — Yeni bir posta kutusu oluşturur
  • imap_delete — Belirtilen iletiyi silindi olarak imler
  • imap_deletemailbox — Bir posta kutusunu siler
  • imap_errors — Oluşan tüm IMAP hatalarının iletilerini döndürür
  • imap_expunge — Silindi imli tüm iletileri gerçekten siler
  • imap_fetch_overview — Belirtilen iletinin başlıklarından belli bilgileri toplar
  • imap_fetchbody — Belirtilen iletinin belli bir gövde bölümünü döndürür
  • imap_fetchheader — Bir iletinin başlığını döndürür
  • imap_fetchmime — Fetch MIME headers for a particular section of the message
  • imap_fetchstructure — Belli bir iletinin yapısını okur
  • imap_fetchtext — Takma Adı: imap_body
  • imap_gc — IMAP önbelleğini temizler
  • imap_get_quota — Belirtilen kullanıcının kota ayarlarını döndürür
  • imap_get_quotaroot — Kullanıcının kendi kota ayarlarını döndürür
  • imap_getacl — Belirtilen posta kutusunun erişim izinlerini döndürür
  • imap_getmailboxes — Posta kutuları hakkında ayrıntılı bilgi döndürür
  • imap_getsubscribed — Üyesi olunan tüm posta kutularını listeler
  • imap_header — imap_headerinfo işlevinin takma adıdır
  • imap_headerinfo — Belirtilen iletinin başlığını okur
  • imap_headers — Bir posta kutusu içindeki tüm iletilerin başlıklarını döndürür
  • imap_last_error — Geçerli sayfa isteği sırasında oluşan son IMAP hatasının açıklamasını döndürür
  • imap_list — Posta kutularını listeler
  • imap_listmailbox — imap_list işlevinin takma adıdır
  • imap_listscan — Belirtilen metin ile eşleşen posta kutularını listeler
  • imap_listsubscribed — imap_lsub işlevinin takma adıdır
  • imap_lsub — Üyesi olunan tüm posta kutularını listeler
  • imap_mail_compose — Zarfı ve gövdesi belirtilen MIME iletisini oluşturur
  • imap_mail_copy — Belirtilen iletileri bir posta kutusuna kopyalar
  • imap_mail_move — Belirtilen iletiyi bir posta kutusuna taşır
  • imap_mail — Bir eposta iletisi gönderir
  • imap_mailboxmsginfo — Posta kutusu hakkında bilgi döndürür
  • imap_mime_header_decode — MIME başlık elemanlarının kodlamasını açar
  • imap_msgno — Belirtilen eşsiz kimlik için ileti numarasını döndürür
  • imap_num_msg — Posta kutusundaki ileti sayısını döndürür
  • imap_num_recent — Posta kutusuna en son gelen ileti sayısını döndürür
  • imap_open — Belirtilen posta kutusuna yeni bir IMAP akımı açar
  • imap_ping — Belirtilen IMAP akımı hala etkin mi diye bakar
  • imap_qprint — Bir 7 bitlik dizgeyi 8 bitlik dizgeye dönüştürür
  • imap_rename — Takma Adı: imap_renamemailbox
  • imap_renamemailbox — Posta kutusunun ismini değiştirir
  • imap_reopen — IMAP akımını yeni posta kutusunda yeniden açar
  • imap_rfc822_parse_adrlist — Bir adres dizgesini çözümler
  • imap_rfc822_parse_headers — Bir dizgedeki eposta başlıklarını çözümler
  • imap_rfc822_write_address — Posta kutusu, alan adı ve kişisel bilgi ile gerektiği gibi biçemlenmiş bir eposta adresi dönürür
  • imap_savebody — Belirtilen iletinin gövdesini bir dosyaya kaydeder
  • imap_scan — Takma Adı: imap_listscan
  • imap_scanmailbox — imap_listscan işlevinin takma adıdır
  • imap_search — Belirtilen kurala uyan iletileri bir dizi içinde döndürür
  • imap_set_quota — Belirtilen posta kutusu için bir kota tanımlar
  • imap_setacl — Belirtilen posta kutusu ile ilgili erişim izinlerini tanımlar
  • imap_setflag_full — İletileri imler
  • imap_sort — İletileri sıralar ve döndürür
  • imap_status — Bir posta kutusunun durum bilgisini döndürür
  • imap_subscribe — Bir posta kutusuna üyeliği başlatır
  • imap_thread — Bir iletinin konu ağacını döndürür
  • imap_timeout — IMAP zaman aşımını tanımlar veya döndürür
  • imap_uid — Numarası belirtilen iletiyle ilgili eşsiz kimliği döndürür
  • imap_undelete — Silindi diye imlenmiş bir iletinin imini kaldırır
  • imap_unsubscribe — Bir posta kutusundan üyeliği sonlandırır
  • imap_utf7_decode — Bir dizgenin karakter kodlamasını takviyeli UTF-7'den ISO-8859-1'e dönüştürür
  • imap_utf7_encode — ISO-8859-1 kodlu bir dizgenin kodlamasını takviyeli UTF-7'ye dönüştürür
  • imap_utf8 — MIME kodlu metni UTF-8'e dönüştürür
Öntanımlı Sabitler
imap_8bit
IMAP


8 bitlik bir dizgeyi 7 bitlik (quoted-printable) bir dizgeye dönüştürür

IMAP İşlevleri
imap_alerts
IMAP İşlevleri
PHP Manual

imap_8bit

(PHP 4, PHP 5, PHP 7)

imap_8bit — 8 bitlik bir dizgeyi 7 bitlik (quoted-printable) bir dizgeye dönüştürür

Açıklama

string imap_8bit ( string $dizge )

» RFC 2045'in 6.7. bölümüne uygun olarak 8 bitlik bir dizgeyi 7 bitlik (quoted-printable) bir dizgeye dönüştürür.

Değiştirgeler

dizge

Dönüştürülecek 8 bitlik dizge.

Dönen Değerler

7 bitlik (quoted-printable) bir dizge döner.

Ayrıca Bakınız

  • imap_qprint() - Bir 7 bitlik dizgeyi 8 bitlik dizgeye dönüştürür

IMAP İşlevleri
imap_alerts
IMAP İşlevleri


Oluşan tüm IMAP uyarı iletilerini döndürür

imap_8bit
imap_append
IMAP İşlevleri
PHP Manual

imap_alerts

(PHP 4, PHP 5, PHP 7)

imap_alerts — Oluşan tüm IMAP uyarı iletilerini döndürür

Açıklama

array imap_alerts ( void )

Son imap_alerts() çağrısından beri veya sayfa isteğinin başından beri oluşan tüm uyarı iletilerini içeren bir dizi döndürür.

imap_alerts() çağrısı uyarı yığıtını temizler. IMAP belirtimi bu iletilerin kullanıcıya aktarılmasını gerektirir.

Dönen Değerler

Üretilmiş tüm uyarı iletilerini içeren bir dizi döner. Eğer hiç uyarı iletisi yoksa FALSE döner.

Ayrıca Bakınız

  • imap_errors() - Oluşan tüm IMAP hatalarının iletilerini döndürür

imap_8bit
imap_append
IMAP İşlevleri


Belirtilen posta kutusuna bir dizge ileti ekler

imap_alerts
imap_base64
IMAP İşlevleri
PHP Manual

imap_append

(PHP 4, PHP 5, PHP 7)

imap_append — Belirtilen posta kutusuna bir dizge ileti ekler

Açıklama

bool imap_append ( resource $imap_akımı , string $pk , string $ileti [, string $seçenekler = NULL ] )

Belirtilen posta kutusuna (pk) bir dizge ileti ekler.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

pk

Posta kutusu ismi; daha fazla bilgi için imap_open() işlevine bakınız.

ileti

Bir dizge olarak eklenecek ileti.

Cyrus IMAP sunucusuna gönderirken, iletide satır sonu karakteri olarak "\n" değil "\r\n" kullanmalısınz, yoksa işlem başarısız olur.

seçenekler

Belirtildiği takdirde posta kutusuna bu seçenekler de yazılır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - imap_append() örneği

<?php
$stream = imap_open("{imap.example.org}INBOX.Drafts", "username", "password");

$check = imap_check($stream);
echo "Ekleme öncesi ileti sayısı: ". $check->Nmsgs . "\n";

imap_append($stream, "{imap.example.org}INBOX.Drafts"
                   , "From: me@example.com\r\n"
                   . "To: you@example.com\r\n"
                   . "Subject: test\r\n"
                   . "\r\n"
                   . "Bu bir deneme iletisidir, lütfen yok sayın.\r\n"
                   );

$check = imap_check($stream);
echo "Ekleme sonrası ileti sayısı: ". $check->Nmsgs . "\n";

imap_close($stream);
?>

imap_alerts
imap_base64
IMAP İşlevleri


Base64 kodlu dizgeyi 8 bitlik dizgeye dönüştürür

imap_append
imap_binary
IMAP İşlevleri
PHP Manual

imap_base64

(PHP 4, PHP 5, PHP 7)

imap_base64 — Base64 kodlu dizgeyi 8 bitlik dizgeye dönüştürür

Açıklama

string imap_base64 ( string $dizge )

Base-64 kodlu dizge dizgesini 8 bitlik bir dizgeye dönüştürür.

Değiştirgeler

metin

Base64 kodlu metin.

Dönen Değerler

8 bitlik bir dizge döner.

Ayrıca Bakınız

  • imap_binary() - 8 bitlik bir dizgeyi bir base64 dizgesine dönüştürür
  • base64_encode() - Veriye MIME base64 kodlaması uygular
  • base64_decode() - MIME base64 ile kodlanmış verinin kodunu açar
  • » RFC2045, Bölüm 6.8

imap_append
imap_binary
IMAP İşlevleri


8 bitlik bir dizgeyi bir base64 dizgesine dönüştürür

imap_base64
imap_body
IMAP İşlevleri
PHP Manual

imap_binary

(PHP 4, PHP 5, PHP 7)

imap_binary — 8 bitlik bir dizgeyi bir base64 dizgesine dönüştürür

Açıklama

string imap_binary ( string $dizge )

8 bitlik dizge, » RFC 2045'in 6.8. bölümüne uygun olarak bir base64 dizgesine dönüştürülür.

Değiştirgeler

dizge

8 bitlik dizge.

Dönen Değerler

Base64 ile kodlanmış bir dizge döndürür.

Ayrıca Bakınız

  • imap_base64() - Base64 kodlu dizgeyi 8 bitlik dizgeye dönüştürür

imap_base64
imap_body
IMAP İşlevleri


İleti gövdesini okur

imap_binary
imap_bodystruct
IMAP İşlevleri
PHP Manual

imap_body

(PHP 4, PHP 5, PHP 7)

imap_body — İleti gövdesini okur

Açıklama

string imap_body ( resource $imap_akımı , int $iletinum [, int $seçenekler = 0 ] )

iletinum ile belirtilen iletinin gövdesini döndürür.

imap_body() işlevi ileti gövdesinin bire bir kopyasını döndürür. Çok parçalı MIME kodlu bir iletiden tek bir parçayı elde etmek için önce yapı imap_fetchstructure() ile incelenmeli sonra da gövdeden istenen bölüm imap_fetchbody()ile çıkarılmalıdır.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

iletinum

İleti numarası.

seçenekler

Şunlardan gerekenleri içeren bir bit maskesidir:

  • FT_UID - iletinum bir eşsiz kimliktir.
  • FT_PEEK - \Seen imi tanımlıysa bir daha tanımlanmaz.
  • FT_INTERNAL -CRLF ile meşrulaştırılmamış olarak dizgeyi dahili biçemde döndürür.

Dönen Değerler

Belirtilen iletinin gövdesi bir dizge olarak döner.

imap_binary
imap_bodystruct
IMAP İşlevleri


Belirtilen iletinin bir gövde bölümünün yapısını okur

imap_body
imap_check
IMAP İşlevleri
PHP Manual

imap_bodystruct

(PHP 4, PHP 5, PHP 7)

imap_bodystruct — Belirtilen iletinin bir gövde bölümünün yapısını okur

Açıklama

object imap_bodystruct ( resource $imap_akımı , int $iletinum , string $bölüm )

Belirtilen iletinin bölüm ile belirtilen gövde bölümünün yapısını okur.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

iletinum

İleti numarası.

bölüm

Okunacak gövde bölümü.

Dönen Değerler

Bilgi bir nesne içinde döndürülür. Nesnenin yapısı ve özellikleri hakkında bilgi almak için imap_fetchstructure() işlevine bakınız.

Ayrıca Bakınız

  • imap_fetchstructure() - Belli bir iletinin yapısını okur

imap_body
imap_check
IMAP İşlevleri


Posta kutusu bilgilerini döndürür

imap_bodystruct
imap_clearflag_full
IMAP İşlevleri
PHP Manual

imap_check

(PHP 4, PHP 5, PHP 7)

imap_check — Posta kutusu bilgilerini döndürür

Açıklama

object imap_check ( resource $imap_akımı )

Posta kutusu bilgilerini döndürür.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

Dönen Değerler

Şu özelliklere sahip bir nesne döner:

  • Date - » RFC 2822'ye uygun olarak biçemlenmiş sistem zamanı.
  • Driver - Posta kutusuna erişirken kullanılan protokol: POP3, IMAP, NNTP
  • Mailbox - Posta kutusunun ismi.
  • Nmsgs - Posta kutusundaki ileti sayısı.
  • Recent - Posta kutusuna son gelen ileti sayısı.

Başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - imap_check() örneği

<?php

$imap_obj = imap_check($imap_stream);
var_dump($imap_obj);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(stdClass)(5) {
  ["Date"]=>
  string(37) "Wed, 10 Dec 2003 17:56:54 +0100 (CET)"
  ["Driver"]=>
  string(4) "imap"
  ["Mailbox"]=>
  string(54)
  "{www.example.com:143/imap/user="foo@example.com"}INBOX"
  ["Nmsgs"]=>
  int(1)
  ["Recent"]=>
  int(0)
}

imap_bodystruct
imap_clearflag_full
IMAP İşlevleri


İletilerdeki imleri temizler

imap_check
imap_close
IMAP İşlevleri
PHP Manual

imap_clearflag_full

(PHP 4, PHP 5, PHP 7)

imap_clearflag_full — İletilerdeki imleri temizler

Açıklama

bool imap_clearflag_full ( resource $imap_akımı , string $aralık , string $imler [, int $seçenekler = 0 ] )

Belirtilen aralık içindeki iletilerden imler ile belirtilen imleri siler.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

aralık

İleti numaraları aralığı. İstenen iletileri X,Y biçeminde sıralayabilir veya X:Y biçeminde bir aralık olarak belirtebilirsiniz.

imler

» RFC 2060'ta belirtildiği gibi silinecek imleri "\\Seen" (okundu), "\\Answered" (yanıtlandı), "\\Flagged (imli)", "\\Deleted" (silindi), "\\Draft" (taslak) olarak belirtebilirsiniz.

seçenekler

Şunlardan gerekenleri içeren bir bit maskesidir:

  • ST_UID - aralık değiştirgesinin eşsiz kimlikleri içerdiği varsayılır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • imap_setflag_full() - İletileri imler

imap_check
imap_close
IMAP İşlevleri


IMAP akımını kapatır

imap_clearflag_full
imap_create
IMAP İşlevleri
PHP Manual

imap_close

(PHP 4, PHP 5, PHP 7)

imap_close — IMAP akımını kapatır

Açıklama

bool imap_close ( resource $imap_akımı [, int $seçenek = 0 ] )

Belirtilen IMAP akımını kapatır.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

seçenek

Değer olarak CL_EXPUNGE belirtilirse, posta kutusu kapatılmadan önce silindi olarak imlenmiş iletiler posta kutusundan silinir. Bu işlevselliği imap_expunge() işleviyle de elde edebilirsiniz.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • imap_open() - Belirtilen posta kutusuna yeni bir IMAP akımı açar

imap_clearflag_full
imap_create
IMAP İşlevleri


Takma Adı: imap_createmailbox

imap_close
imap_createmailbox
IMAP İşlevleri
PHP Manual

imap_create

(PHP 4, PHP 5, PHP 7)

imap_create — Takma Adı: imap_createmailbox()

Açıklama

Bu işlev şu işlevin takma adıdır: imap_createmailbox().

imap_close
imap_createmailbox
IMAP İşlevleri


Yeni bir posta kutusu oluşturur

imap_create
imap_delete
IMAP İşlevleri
PHP Manual

imap_createmailbox

(PHP 4, PHP 5, PHP 7)

imap_createmailbox — Yeni bir posta kutusu oluşturur

Açıklama

bool imap_createmailbox ( resource $imap_akımı , string $pk )

pk ile belirtilen posta kutusunu oluşturur.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

pk

Posta kutusu ismi; daha fazla bilgi için imap_open() işlevine bakınız. Uluslararası karakterler içeren posta kutusu isimleri imap_utf7_encode() ile kodlanmalıdır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - imap_createmailbox() örneği

<?php
$mbox = imap_open("{imap.example.org}", "username", "password", OP_HALFOPEN)
     or die("bağlanılamadı: " . imap_last_error());

$name1 = "phpnewbox";
$name2 = imap_utf7_encode("phpnewböx");

$newname = $name1;

echo "Yeni posta kutusu: '$name1'<br />\n";

// Gelen kutusunda önce "phptestbox" adında yeni bir posta kutusu
// oluşturacağız. Oluşturduktan sonra durumuna bakacağız ve son olarak
// gelen kutusunu ilk haline getirmek için yeni posta kutusunu sileceğiz.

if (@imap_createmailbox($mbox, imap_utf7_encode("{imap.example.org}INBOX.$newname"))) {
  $status = @imap_status($mbox, "{imap.example.org}INBOX.$newname", SA_ALL);
  if ($status) {
      echo "Yeni posta kutusu '$name1' ile ilgili durum:<br />\n";
      echo "İleti sayısı:         " . $status->messages    . "<br />\n";
      echo "Son gelen sayısı:     " . $status->recent      . "<br />\n";
      echo "Okunmamış sayısı:     " . $status->unseen      . "<br />\n";
      echo "Sonraki eşsiz kimlik: " . $status->uidnext     . "<br />\n";
      echo "Kimlik doğrulaması:   " . $status->uidvalidity . "<br />\n";

    if (imap_renamemailbox($mbox, "{imap.example.org}INBOX.$newname",
        "{imap.example.org}INBOX.$name2")) {
      echo "Yeni posta kutusunun ismi '$name1' iken '$name2' yapıldı<br />\n";
        $newname = $name2;
    } else {
        echo "imap_renamemailbox başarısız oldu: " .
          imap_last_error() . "<br />\n";
    }
  } else {
      echo "Yeni posta kutusunun durumuna bakılırken bir hata oluştu: " .
        imap_last_error() . "<br />\n";
  }

  if (@imap_deletemailbox($mbox, "{imap.example.org}INBOX.$newname")) {
      echo "Yeni posta kutusu silindi.<br />\n";
  } else {
      echo "Yeni posta kutusu için imap_deletemailbox başarısız oldu: " .
          implode("<br />\n", imap_errors()) . "<br />\n";
  }

} else {
    echo "Yeni posta kutusu oluşturulamadı: " .
        implode("<br />\n", imap_errors()) . "<br />\n";
}

imap_close($mbox);
?>

Ayrıca Bakınız

  • imap_renamemailbox() - Posta kutusunun ismini değiştirir
  • imap_deletemailbox() - Bir posta kutusunu siler

imap_create
imap_delete
IMAP İşlevleri


Belirtilen iletiyi silindi olarak imler

imap_createmailbox
imap_deletemailbox
IMAP İşlevleri
PHP Manual

imap_delete

(PHP 4, PHP 5, PHP 7)

imap_delete — Belirtilen iletiyi silindi olarak imler

Açıklama

bool imap_delete ( resource $imap_akımı , int $iletinum [, int $seçenekler = 0 ] )

iletinum ile belirtilen iletileri silinmek üzere imler. Bu iletiler bir imap_expunge() çağrısına kadar veya CL_EXPUNGE seçeneği ile yapılan bir imap_close() çağrısına kadar posta kutusunda kalır.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

iletinum

İleti numarası.

seçenekler

Bu değiştirgede FT_UID sabiti belirtilirse iletinum değiştirgesinin eşsiz kimlikleri içerdiği varsayılır.

Dönen Değerler

TRUE döner.

Örnekler

Örnek 1 - imap_delete() örneği

<?php

$mbox = imap_open("{imap.example.org}INBOX", "username", "password")
    or die("bağlanılamadı: " . imap_last_error());

$check = imap_mailboxmsginfo($mbox);
echo "Silme imlemesi öncesi ileti sayısı: " . $check->Nmsgs . "<br />\n";

imap_delete($mbox, 1);

$check = imap_mailboxmsginfo($mbox);
echo "Silme imlemesi sonrası ileti sayısı: " . $check->Nmsgs . "<br />\n";

imap_expunge($mbox);

$check = imap_mailboxmsginfo($mbox);
echo "İletiler silindikten sonraki ileti sayısı: " .
      $check->Nmsgs . "<br />\n";

imap_close($mbox);
?>

Notlar

Bilginize:

POP3 posta kutuları bağlantılar arasında ileti imlerini saklamazlar. Bu nedenle silinmek üzere imlenmiş iletileri gerçekten silmek için imap_expunge() işlevini aynı oturumda kullanmalısınız.

Ayrıca Bakınız

  • imap_undelete() - Silindi diye imlenmiş bir iletinin imini kaldırır
  • imap_expunge() - Silindi imli tüm iletileri gerçekten siler
  • imap_close() - IMAP akımını kapatır

imap_createmailbox
imap_deletemailbox
IMAP İşlevleri


Bir posta kutusunu siler

imap_delete
imap_errors
IMAP İşlevleri
PHP Manual

imap_deletemailbox

(PHP 4, PHP 5, PHP 7)

imap_deletemailbox — Bir posta kutusunu siler

Açıklama

bool imap_deletemailbox ( resource $imap_akımı , string $pk )

pk ile belirtilen posta kutusunu siler.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

pk

Posta kutusu ismi; daha fazla bilgi için imap_open() işlevine bakınız.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • imap_createmailbox() - Yeni bir posta kutusu oluşturur
  • imap_renamemailbox() - Posta kutusunun ismini değiştirir
  • imap_open() - Belirtilen posta kutusuna yeni bir IMAP akımı açar

imap_delete
imap_errors
IMAP İşlevleri


Oluşan tüm IMAP hatalarının iletilerini döndürür

imap_deletemailbox
imap_expunge
IMAP İşlevleri
PHP Manual

imap_errors

(PHP 4, PHP 5, PHP 7)

imap_errors — Oluşan tüm IMAP hatalarının iletilerini döndürür

Açıklama

array imap_errors ( void )

Hata yığıtı sıfırlandığından beri veya bu sayfa isteği sırasında oluşan tüm IMAP hatalarını döndürür.

imap_errors() çağrısı hata yığıtını temizler.

Dönen Değerler

Son imap_errors() çağrısından beri veya sayfa isteğinin başından beri oluşan tüm hataların iletilerini içeren bir dizi döndürür. Döndürülecek hiç hata iletisi yoksa FALSE döner.

Ayrıca Bakınız

  • imap_last_error() - Geçerli sayfa isteği sırasında oluşan son IMAP hatasının açıklamasını döndürür
  • imap_alerts() - Oluşan tüm IMAP uyarı iletilerini döndürür

imap_deletemailbox
imap_expunge
IMAP İşlevleri


Silindi imli tüm iletileri gerçekten siler

imap_errors
imap_fetch_overview
IMAP İşlevleri
PHP Manual

imap_expunge

(PHP 4, PHP 5, PHP 7)

imap_expunge — Silindi imli tüm iletileri gerçekten siler

Açıklama

bool imap_expunge ( resource $imap_akımı )

imap_delete(), imap_mail_move() veya imap_setflag_full() tarafından 'silindi' olarak imlenmiş tüm iletileri siler.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

Dönen Değerler

TRUE döner.

imap_errors
imap_fetch_overview
IMAP İşlevleri


Belirtilen iletinin başlıklarından belli bilgileri toplar

imap_expunge
imap_fetchbody
IMAP İşlevleri
PHP Manual

imap_fetch_overview

(PHP 4, PHP 5, PHP 7)

imap_fetch_overview — Belirtilen iletinin başlıklarından belli bilgileri toplar

Açıklama

array imap_fetch_overview ( resource $imap_akımı , string $aralık [, int $seçenekler = 0 ] )

aralık ile belirtilen iletilerin posta başlıklarını alır ve içinden belli bilgileri toplar.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

aralık

İleti numaraları aralığı. İstenen iletileri X,Y biçeminde sıralayabilir veya X:Y biçeminde bir aralık olarak belirtebilirsiniz.

seçenekler

Bu değiştirgede FT_UID sabiti belirtilirse aralık değiştirgesi ileti numaralarını veya eşsiz kimlikleri içerebilir.

Dönen Değerler

Her biri belli bir iletiye ait nesnelerden oluşan bir dizi döner. Nesne, sadece iletide mevcut olan özellikleri içerir. Olası özellikler:

  • subject - İleti konusu.
  • from - Kimden.
  • to - Kime.
  • date - İletinin gönderildiği tarih.
  • message_id - İleti kimliği.
  • references - İleti kimliğine gönderimler.
  • in_reply_to - İleti, bu ileti kimliğine bir yanıttır.
  • size - İletinin bayt cinsinden uzunluğu.
  • uid - İletinin posta kusunudaki eşsiz kimliği.
  • msgno - İletinin posta kusunudaki sıra numarası
  • recent - İleti son gönderilenlerden olarak imlenmiş.
  • flagged - İleti imlenmiş.
  • answered - İleti, yanıtlandı olarak imlenmiş.
  • deleted - İleti, silindi olarak imlenmiş.
  • seen - İleti, okundu olarak imlenmiş.
  • draft - İleti taslak olarak imlenmiş.

Örnekler

Örnek 1 - imap_fetch_overview() örneği

<?php
$mbox = imap_open("{imap.example.org:143}INBOX", "username", "password")
     or die("bağlanılamadı: " . imap_last_error());

$MC = imap_check($mbox);

// INBOX içindeki tüm iletilerle ilgili bilgileri toplayalım
$result = imap_fetch_overview($mbox,"1:{$MC->Nmsgs}",0);
foreach ($result as $overview) {
    echo "#{$overview->msgno} ({$overview->date}) - From: {$overview->from}
    {$overview->subject}\n";
}
imap_close($mbox);
?>

Ayrıca Bakınız

  • imap_fetchheader() - Bir iletinin başlığını döndürür

imap_expunge
imap_fetchbody
IMAP İşlevleri


Belirtilen iletinin belli bir gövde bölümünü döndürür

imap_fetch_overview
imap_fetchheader
IMAP İşlevleri
PHP Manual

imap_fetchbody

(PHP 4, PHP 5, PHP 7)

imap_fetchbody — Belirtilen iletinin belli bir gövde bölümünü döndürür

Açıklama

string imap_fetchbody ( resource $imap_akımı , int $iletinum , string $bölüm [, int $seçenekler = 0 ] )

Belirtilen iletinin belli bir gövde bölümünü döndürür. Gövde parçaları bu işlevle çözülmez.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

iletinum

İleti numarası.

bölüm

Parça numarası. IMAP4 belirtimine uygun olarak, gövde parçasını indisleyen noktalarla ayrılmış sayılardan oluşan bir dizge olarak belirtilir.

seçenekler

Aşağıdaki sabitlerin biri veya birkaçından oluşan bir bit maskesidir:

  • FT_UID - iletinum değiştirgesinin eşsiz kimlik olarak ele alınmasını sağlar.
  • FT_PEEK - Zaten ileti \Seen (okundu) imliyse tekrar okundu olarak imlenmez.
  • FT_INTERNAL - Satırları CRLF'lerle meşrulaştırılmadan dizgenin "dahili" biçemiyle döndürülmesini sağlar.

Dönen Değerler

Belirtilen ileti bölümünü bir dizge olarak döndürür.

Ayrıca Bakınız

  • imap_savebody() - Belirtilen iletinin gövdesini bir dosyaya kaydeder
  • imap_fetchstructure() - Belli bir iletinin yapısını okur

imap_fetch_overview
imap_fetchheader
IMAP İşlevleri


Bir iletinin başlığını döndürür

imap_fetchbody
imap_fetchmime
IMAP İşlevleri
PHP Manual

imap_fetchheader

(PHP 4, PHP 5, PHP 7)

imap_fetchheader — Bir iletinin başlığını döndürür

Açıklama

string imap_fetchheader ( resource $imap_akımı , int $iletinum [, int $seçenekler = 0 ] )

Belirtilen iletinin » RFC2822 biçemli başlığının tamamını herhangi bir işlemden geçirmeden döndürür.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

iletinum

İleti numarası.

seçenekler

Olası seçenekler:

  • FT_UID - The iletinum değiştirgesinin bir eşsiz kimlik olarak ele alınmasını sağlar.
  • FT_INTERNAL - Satırları CRLF'lerle meşrulaştırılmadan dizgenin "dahili" biçemiyle döndürülmesini sağlar.
  • FT_PREFETCHTEXT - Aynı anda ileti metninin de alınmasını sağlar. İletinin tam metni istendiği durumda (içeriğin yerel bir dosyaya kaydedilmek istenmesi gibi) IMAP bağlantısında ek bir RTT (gecikme) oluşmasını engeller.

Dönen Değerler

Belirtilen iletinin başlığını içeren bir dizge döner.

Ayrıca Bakınız

  • imap_fetch_overview() - Belirtilen iletinin başlıklarından belli bilgileri toplar

imap_fetchbody
imap_fetchmime
IMAP İşlevleri


Fetch MIME headers for a particular section of the message

imap_fetchheader
imap_fetchstructure
IMAP İşlevleri
PHP Manual

imap_fetchmime

(PHP 5 >= 5.3.6, PHP 7)

imap_fetchmime — Fetch MIME headers for a particular section of the message

Açıklama

string imap_fetchmime ( resource $imap_stream , int $msg_number , string $section [, int $options = 0 ] )

Fetch the MIME headers of a particular section of the body of the specified messages.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

msg_number

The message number

section

The part number. It is a string of integers delimited by period which index into a body part list as per the IMAP4 specification

options

A bitmask with one or more of the following:

  • FT_UID - The msg_number is a UID
  • FT_PEEK - Do not set the \Seen flag if not already set
  • FT_INTERNAL - The return string is in internal format, will not canonicalize to CRLF.

Dönen Değerler

Returns the MIME headers of a particular section of the body of the specified messages as a text string.

Ayrıca Bakınız

  • imap_fetchbody() - Belirtilen iletinin belli bir gövde bölümünü döndürür
  • imap_fetchstructure() - Belli bir iletinin yapısını okur
  • imap_fetchheader() - Bir iletinin başlığını döndürür

imap_fetchheader
imap_fetchstructure
IMAP İşlevleri


Belli bir iletinin yapısını okur

imap_fetchmime
imap_fetchtext
IMAP İşlevleri
PHP Manual

imap_fetchstructure

(PHP 4, PHP 5, PHP 7)

imap_fetchstructure — Belli bir iletinin yapısını okur

Açıklama

object imap_fetchstructure ( resource $imap_akımı , int $iletinum [, int $seçenekler = 0 ] )

Belirtilen ileti için yapılandırılmış tüm bilgiyi döndürür.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

iletinum

İleti numarası.

seçenekler

Bu isteğe bağlı değiştirgede tek bir seçenek belirtilebilir: iletinum değiştirgesinin eşsiz kimlik olarak ele alınmasını sağlayan FT_UID sabiti.

Dönen Değerler

Aşağıdaki özelliklere sahip bir nesne döner. Nesne ayrıca her MIME eklentisi için benzer birer nesne içerir.

imap_fetchstructure() işlevinden dönen nesnenin özellikleri
type | Birincil gövde türü.
encoding | Gövde aktarım kodlaması.
ifsubtype | Bir alt MIME türünde dizge varsa TRUE.
subtype | MIME alt türü.
ifdescription | Bir açıklama dizgesi varsa TRUE
description | Açıklama dizgesinin içeriği.
ifid | Kimliklendirici bir dizge varsa TRUE.
id | Kimliklendirme dizgesi.
lines | Satır sayısı.
bytes | Bayt sayısı.
ifdisposition | Bir Content-Disposition: başlığı varsa TRUE.
disposition | Content-Disposition: başlıklı dizge.
ifdparameters | dparameters dizisi mevcutsa TRUE.
dparameters | Content-disposition MIME başlığındaki değiştirgelere karşı düşen "attribute" ve "value" özelliklerine sahip nesnelerden oluşan bir dizi.
ifparameters | parameters dizisi mevcutsa TRUE.
parameters | "attribute" ve "value" özelliklerine sahip nesnelerden oluşan bir dizi.
parts | Her biri bir MIME gövde parçasına karşılık gelen ve üst seviye nesnenin yapısına eşdeğer nesnelerden oluşan bir dizi.

Birincil gövde türü
0 | text (metin)
1 | multipart (çok parçalı)
2 | message (ileti)
3 | application (çalıştırılabilir)
4 | audio (işitsel)
5 | image (resim)
6 | video (görsel)
7 | other (diğer)

Aktarım kodlaması
0 | 7BIT
1 | 8BIT
2 | BINARY
3 | BASE64
4 | QUOTED-PRINTABLE
5 | OTHER

Ayrıca Bakınız

  • imap_fetchbody() - Belirtilen iletinin belli bir gövde bölümünü döndürür
  • imap_bodystruct() - Belirtilen iletinin bir gövde bölümünün yapısını okur

imap_fetchmime
imap_fetchtext
IMAP İşlevleri


Takma Adı: imap_body

imap_fetchstructure
imap_gc
IMAP İşlevleri
PHP Manual

imap_fetchtext

(PHP 4, PHP 5, PHP 7)

imap_fetchtext — Takma Adı: imap_body()

Açıklama

Bu işlev şu işlevin takma adıdır: imap_body().

imap_fetchstructure
imap_gc
IMAP İşlevleri


IMAP önbelleğini temizler

imap_fetchtext
imap_get_quota
IMAP İşlevleri
PHP Manual

imap_gc

(PHP 5 >= 5.3.0, PHP 7)

imap_gc — IMAP önbelleğini temizler

Açıklama

string imap_gc ( resource $imap_akımı , int $önbellek_türü )

Türü belirtilen önbellek girdilerini siler.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

önbellek_türü

Silinecek önbellek türü. Şu sabitlerden biri veya birkaçı belirtilebilir: IMAP_GC_ELT (ileti önbellek elemanları), IMAP_GC_ENV (zarflar ve gövdeler), IMAP_GC_TEXTS (metinler).

Dönen Değerler

TRUE döner.

Örnekler

Örnek 1 - imap_gc() örneği

<?php

$mbox = imap_open("{imap.example.org:143}", "username", "password");

imap_gc($mbox, IMAP_GC_ELT);

?>

imap_fetchtext
imap_get_quota
IMAP İşlevleri


Belirtilen kullanıcının kota ayarlarını döndürür

imap_gc
imap_get_quotaroot
IMAP İşlevleri
PHP Manual

imap_get_quota

(PHP 4 >= 4.0.5, PHP 5, PHP 7)

imap_get_quota — Belirtilen kullanıcının kota ayarlarını döndürür

Açıklama

array imap_get_quota ( resource $imap_akımı , string $kullanıcı )

Belirtilen kullanıcının posta kutusunun kota ayarlarını ve istatistiklerini döndürür.

Bu işlev sadece yönetici tarafından kullanılır. Diğer kullanıcıların imap_get_quotaroot() işlevini kullanmaları gerekir.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

quota_root

Genelde user.isim biçeminde olup 'isim' hakkında bilgi istenecek posta kutusunun ismidir.

Dönen Değerler

Belirtilen posta kutusunun kapasitesi ile ilgili bilgileri bir ilişkisel dizi içinde döndürür. Tüm değerler bir özkaynağın adını anahtar olarak alan birer dizidir ve bu alt diziler 'usage' ve 'limit' indisli değerler içerir. Bir hata durumunda FALSE döner.

PHP 4.3'ten itibaren, işlev » RFC 2087'ye daha fazla uyumludur. Dönen dizi sınırsız sayıda özkaynağı (iletiler, alt dizinler gibi) destekleyecek şekilde değiştirilmiştir. Her özkaynakla ilgili bilgiler ayrıca alt dizinlere konmuştur. İlişkisel dizinin her anahtarı değer olarak 'usage' ve 'limit' indisli bir dizi içerir.

Geriye uyumluluk adına özgün erişim yöntemleri hala kullanılabilmekteyse de bir güncelleme önerilir.

Örnekler

Örnek 1 - imap_get_quota() örneği

<?php
$mbox = imap_open("{imap.example.org}", "mailadmin", "password", OP_HALFOPEN)
      or die("bağlanılamadı: " . imap_last_error());

$quota_value = imap_get_quota($mbox, "user.kalowsky");
if (is_array($quota_value)) {
    echo "Kullanılan: "  . $quota_value['usage'];
    echo "Azami boyut: " . $quota_value['limit'];
}

imap_close($mbox);
?>

Örnek 2 - imap_get_quota() 4.3 ve üstü örneği

<?php
$mbox = imap_open("{imap.example.org}", "mailadmin", "password", OP_HALFOPEN)
      or die("bağlanılamadı: " . imap_last_error());

$quota_values = imap_get_quota($mbox, "user.kalowsky");
if (is_array($quota_values)) {
   $storage = $quota_values['STORAGE'];
   echo "Kullanılmış saklama alanı:     " .  $storage['usage'];
   echo "Saklama alanının azami boyutu: " .  $storage['limit'];

   $message = $quota_values['MESSAGE'];
   echo "İletinin uzunluğu:        " .  $message['usage'];
   echo "İleti için azami uzunluk: " .  $message['limit'];

   /* ...  */
}

imap_close($mbox);
?>

Notlar

Bu işlev sadece c-client2000 ve üstü kütüphane sürümleriyle kullanılabilir.

imap_akımı posta yöneticisi olarak açılmış olmalıdır, yoksa işlev başarısız olur.

Ayrıca Bakınız

  • imap_open() - Belirtilen posta kutusuna yeni bir IMAP akımı açar
  • imap_set_quota() - Belirtilen posta kutusu için bir kota tanımlar
  • imap_get_quotaroot() - Kullanıcının kendi kota ayarlarını döndürür

imap_gc
imap_get_quotaroot
IMAP İşlevleri


Kullanıcının kendi kota ayarlarını döndürür

imap_get_quota
imap_getacl
IMAP İşlevleri
PHP Manual

imap_get_quotaroot

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

imap_get_quotaroot — Kullanıcının kendi kota ayarlarını döndürür

Açıklama

array imap_get_quotaroot ( resource $imap_akımı , string $pk )

Kullanıcının kota ayarlarını döndürür. 'limit' değeri kullanıcının posta kutusu için izin verilen azami toplam kullanım alanını gösterir. 'usage' değeri ise kullanıcının o anki toplam posta kutusu kullanımını gösterir.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

pk

Normalde posta kutusunun ismidir (örneğin, INBOX).

Dönen Değerler

Belirtilen posta kutusunun kapasitesi ile ilgili bilgileri bir ilişkisel dizi içinde döndürür. Tüm değerler bir özkaynağın adını anahtar olarak alan birer dizidir ve bu alt diziler 'usage' ve 'limit' indisli değerler içerir.

Bir hata durumunda FALSE, sunucudan alınan yanıt çözümlenemezse bağlantı hakkında bilgi içeren bir dizi döner.

Örnekler

Örnek 1 - imap_get_quotaroot() örneği

<?php
$mbox = imap_open("{imap.example.org}", "kalowsky", "password", OP_HALFOPEN)
      or die("bağlanılamadı: " . imap_last_error());

$quota = imap_get_quotaroot($mbox, "INBOX");
if (is_array($quota)) {
   $storage = $quota_values['STORAGE'];
   echo "Kullanılmış saklama alanı:     " .  $storage['usage'];
   echo "Saklama alanının azami boyutu: " .  $storage['limit'];

   $message = $quota_values['MESSAGE'];
   echo "İletinin uzunluğu:        " .  $message['usage'];
   echo "İleti için azami uzunluk: " .  $message['limit'];

   /* ...  */

}

imap_close($mbox);
?>

Notlar

Bu işlev sadece c-client2000 ve üstü kütüphane sürümleriyle kullanılabilir.

imap_akımı posta kutusu kotasına bakılacak kullanıcı için açılmış olmalıdır.

Ayrıca Bakınız

  • imap_open() - Belirtilen posta kutusuna yeni bir IMAP akımı açar
  • imap_set_quota() - Belirtilen posta kutusu için bir kota tanımlar
  • imap_get_quota() - Belirtilen kullanıcının kota ayarlarını döndürür

imap_get_quota
imap_getacl
IMAP İşlevleri


Belirtilen posta kutusunun erişim izinlerini döndürür

imap_get_quotaroot
imap_getmailboxes
IMAP İşlevleri
PHP Manual

imap_getacl

(PHP 5, PHP 7)

imap_getacl — Belirtilen posta kutusunun erişim izinlerini döndürür

Açıklama

array imap_getacl ( resource $imap_akımı , string $pk )

Belirtilen posta kutusunun (pk) erişim izinlerini döndürür.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

pk

Posta kutusunun ismi; bilgi için imap_open()işlevine bakınız.

Dönen Değerler

"dizin" => "izinler" çiftlerinden oluşan bir ilişkisel dizi döner.

Örnekler

Örnek 1 - imap_getacl() örneği

<?php

print_r(imap_getacl($conn_id, 'user.joecool'));

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [asubfolder] => lrswipcda
    [anothersubfolder] => lrswipcda
)

Notlar

Bu işlev sadece c-client2000 ve üstü kütüphane sürümleriyle kullanılabilir.

Ayrıca Bakınız

  • imap_setacl() - Belirtilen posta kutusu ile ilgili erişim izinlerini tanımlar

imap_get_quotaroot
imap_getmailboxes
IMAP İşlevleri


Posta kutuları hakkında ayrıntılı bilgi döndürür

imap_getacl
imap_getsubscribed
IMAP İşlevleri
PHP Manual

imap_getmailboxes

(PHP 4, PHP 5, PHP 7)

imap_getmailboxes — Posta kutuları hakkında ayrıntılı bilgi döndürür

Açıklama

array imap_getmailboxes ( resource $imap_akımı , string $hedef , string $kalıp )

Posta kutusu listesini okuyup her PK için ayrıntılı bilgi döndürür.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

hedef

imap_open() işlevinde açıklandığı gibi normal olarak bir sunucu belirtimi olmalıdır.

pattern

Posta kutusu hiyerarşisi içine aramanın başlayacağı yeri belirtir.

kalıp içinde belirtilebilecek iki özel karakter vardır: Alt dizinlere inilmesini sağlayan '*' ve alt dizinlere inilmemesini sağlayan '%'. kalıp olarak '*' posta kutusu hiyerarşisi içindeki tüm posta kutularının listelenmesini, '%' ise sadece tepe seviyedeki posta kutularının listelenmesini sağlar. kalıp olarak '~/mail/%' belirtilirse alt dizinlere inilmeden sadece ~/mail dizini altındaki posta kutuları listelenir.

Dönen Değerler

Posta kutusu bilgilerini içeren nesnelerden oluşan bir dizi döner. Her nesnenin üç özelliği vardır: Posta kutusunun ismini içeren name, hiyerarşik ayracı içeren delimiter ve attributes. attributes özelliği şu değerleri içerebilen bir bit maskesidir:

  • LATT_NOINFERIORS - "Çocuklar" olmaksızın posta kutusunun kendisi (bunun altında posta kutusu bulunmaz). Bu posta kutusu altında imap_createmailbox() çalışmaz.

  • LATT_NOSELECT - Sadece bir taşıyıcıdır, bir posta kutusu değildir - bu açılamaz.

  • LATT_MARKED - Posta kutusu imlidir. Yani, son erişimden bu yana yeni gelmiş iletiler var demektir. Her IMAP sunucusu bu bilgiyi sağlamaz.

  • LATT_UNMARKED - Posta kutusu imsizdir, posta kutusunda yeni gelmiş ileti yoktur. MARKED veya UNMARKED bilgisi sağlanmışsa IMAP sunucusunun bu posta kutusunda bu özelliği desteklediğini varsayabiliriz.

Örnekler

Örnek 1 - imap_getmailboxes() örneği

<?php
$mbox = imap_open("{imap.example.org}", "username", "password", OP_HALFOPEN)
      or die("bağlanılamadı: " . imap_last_error());

$list = imap_getmailboxes($mbox, "{imap.example.org}", "*");
if (is_array($list)) {
    foreach ($list as $key => $val) {
        echo "($key) ";
        echo imap_utf7_decode($val->name) . ",";
        echo "'" . $val->delimiter . "',";
        echo $val->attributes . "<br />\n";
    }
} else {
    echo "imap_getmailboxes başarısız oldu: " . imap_last_error() . "\n";
}

imap_close($mbox);
?>

Ayrıca Bakınız

  • imap_getsubscribed() - Üyesi olunan tüm posta kutularını listeler

imap_getacl
imap_getsubscribed
IMAP İşlevleri


Üyesi olunan tüm posta kutularını listeler

imap_getmailboxes
imap_header
IMAP İşlevleri
PHP Manual

imap_getsubscribed

(PHP 4, PHP 5, PHP 7)

imap_getsubscribed — Üyesi olunan tüm posta kutularını listeler

Açıklama

array imap_getsubscribed ( resource $imap_akımı , string $hedef , string $kalıp )

Üyesi olunan tüm posta kutularını bir dizi içinde döndürür.

Sadece kullanıcının üyesi olduğu posta kutularını döndürmesi dışında imap_getmailboxes() işlevine benzer.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

hedef

imap_open() işlevinde açıklandığı gibi normal olarak bir sunucu belirtimi olmalıdır.

kalıp

Posta kutusu hiyerarşisi içine aramanın başlayacağı yeri belirtir.

kalıp içinde belirtilebilecek iki özel karakter vardır: Alt dizinlere inilmesini sağlayan '*' ve alt dizinlere inilmemesini sağlayan '%'. kalıp olarak '*' posta kutusu hiyerarşisi içindeki tüm posta kutularının listelenmesini, '%' ise sadece tepe seviyedeki posta kutularının listelenmesini sağlar. kalıp olarak '~/mail/%' belirtilirse alt dizinlere inilmeden sadece ~/mail dizini altındaki posta kutuları listelenir.

Dönen Değerler

Posta kutusu bilgilerini içeren nesnelerden oluşan bir dizi döner. Her nesnenin üç özelliği vardır: Posta kutusunun ismini içeren name, hiyerarşik ayracı içeren delimiter ve attributes. attributes özelliği şu değerleri içerebilen bir bit maskesidir:

  • LATT_NOINFERIORS - "Çocuklar" olmaksızın posta kutusunun kendisi (bunun altında posta kutusu bulunmaz).
  • LATT_NOSELECT - Sadece bir taşıyıcıdır, bir posta kutusu değildir - bu açılamaz.
  • LATT_MARKED - Posta kutusu imlidir. Sadece UW-IMAPD kullanır.
  • LATT_UNMARKED - Posta kutusu imsizdir. Sadece UW-IMAPD kullanır.

imap_getmailboxes
imap_header
IMAP İşlevleri


imap_headerinfo işlevinin takma adıdır

imap_getsubscribed
imap_headerinfo
IMAP İşlevleri
PHP Manual

imap_header

(PHP 4, PHP 5, PHP 7)

imap_header — imap_headerinfo() işlevinin takma adıdır

Açıklama

Bu işlev, imap_headerinfo() işlevinin takma adıdır.

imap_getsubscribed
imap_headerinfo
IMAP İşlevleri


Belirtilen iletinin başlığını okur

imap_header
imap_headers
IMAP İşlevleri
PHP Manual

imap_headerinfo

(PHP 4, PHP 5, PHP 7)

imap_headerinfo — Belirtilen iletinin başlığını okur

Açıklama

object imap_headerinfo ( resource $imap_akımı , int $iletinum [, int $uzunluk = 0 [, int $konu_uzunluğu = 0 [, string $öntanımlı_konak = NULL ]]] )

İleti numarası belirtilen iletinin başlıklarını okuyup elde ettiği bilgiyi bir nesne içinde döndürür.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

iletinum

İleti numarası.

uzunluk

fetchfrom özelliği için karakter sayısı. Sıfır veya daha büyük bir tamsayı olmalıdır.

konu_uzunluğu

fetchsubject özelliği için karakter sayısı. Sıfır veya daha büyük bir tamsayı olmalıdır.

öntanımlı_konak

Dönen Değerler

Aşağıdaki özelliklere sahip bir nesne döner:

  • toaddress - to: satırının tamamı, en fazla 1024 karakter.
  • to - To: satırındaki nesnelerden oluşan bir dizi. Nesneler şu özelliklere sahiptir: personal, adl, mailbox ve host.
  • fromaddress - from: satırının tamamı, en fazla 1024 karakter.
  • from - From: satırındaki nesnelerden oluşan bir dizi. Nesneler şu özelliklere sahiptir: personal, adl, mailbox ve host.
  • ccaddress - cc: satırının tamamı, en fazla 1024 karakter.
  • cc - Cc: satırındaki nesnelerden oluşan bir dizi. Nesneler şu özelliklere sahiptir: personal, adl, mailbox ve host.
  • bccaddress - bcc: satırının tamamı, en fazla 1024 karakter.
  • bcc - Bcc: satırındaki nesnelerden oluşan bir dizi. Nesneler şu özelliklere sahiptir: personal, adl, mailbox ve host.
  • reply_toaddress - Reply-To: satırının tamamı, en fazla 1024 karakter.
  • reply_to - Reply-To: satırındaki nesnelerden oluşan bir dizi. Nesneler şu özelliklere sahiptir: personal, adl, mailbox ve host.
  • senderaddress - sender: satırının tamamı, en fazla 1024 karakter.
  • sender - Sender: satırındaki nesnelerden oluşan bir dizi. Nesneler şu özelliklere sahiptir: personal, adl, mailbox ve host
  • return_pathaddress - Return-Path: satırının tamamı, en fazla 1024 karakter.
  • return_path - Return-Path: satırındaki nesnelerden oluşan bir dizi. Nesneler şu özelliklere sahiptir: personal, adl, mailbox ve host
  • remail -
  • date - Başlıklarda bulunan ileti tarihi.
  • Date - date ile aynı.
  • subject - İleti konusu
  • Subject - subject ile aynı.
  • in_reply_to -
  • message_id -
  • newsgroups -
  • followup_to -
  • references -
  • Recent - Son gelenlerdense ve okunmuşsa R, son gelenlerdense ve okunmamışsa N, son gelenlerden değilse ' '.
  • Unseen - Son gelenlerden değilse ve okunmamışsa U, okunmuş olsun ya da olmasın son gelenlerdense ' '.
  • Flagged - İmli ise F, değilse ' '.
  • Answered - Yanıtlanmışsa A, yanıtlanmamışsa ' '.
  • Deleted - Silinmişse D, silinmemişse ' '.
  • Draft - Taslaksa X, değilse ' '.
  • Msgno - İleti numarası.
  • MailDate -
  • Size - İleti uzunluğu
  • udate - Unix zamanı olarak ileti tarihi.
  • fetchfrom - uzunluk karakterlik from: satırı.
  • fetchsubject - konu_uzunluğu karakterlik subject: satırı.

Ayrıca Bakınız

  • imap_fetch_overview() - Belirtilen iletinin başlıklarından belli bilgileri toplar

imap_header
imap_headers
IMAP İşlevleri


Bir posta kutusu içindeki tüm iletilerin başlıklarını döndürür

imap_headerinfo
imap_last_error
IMAP İşlevleri
PHP Manual

imap_headers

(PHP 4, PHP 5, PHP 7)

imap_headers — Bir posta kutusu içindeki tüm iletilerin başlıklarını döndürür

Açıklama

array imap_headers ( resource $imap_akımı )

Posta kutusu içindeki tüm iletilerin başlıklarını döndürür.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

Dönen Değerler

Başlık bilgisiyle biçemlenmiş dizgelerden oluşan bir dizi döner. Her eleman bir eposta iletisine aittir.

imap_headerinfo
imap_last_error
IMAP İşlevleri


Geçerli sayfa isteği sırasında oluşan son IMAP hatasının açıklamasını döndürür

imap_headers
imap_list
IMAP İşlevleri
PHP Manual

imap_last_error

(PHP 4, PHP 5, PHP 7)

imap_last_error — Geçerli sayfa isteği sırasında oluşan son IMAP hatasının açıklamasını döndürür

Açıklama

string imap_last_error ( void )

Geçerli sayfa isteği sırasında oluşan son IMAP hatasının açıklamasını döndürür. Hata yığıtına dokunulmaz, dolayısıyla işlev peşpeşe çağrılırsa hep aynı ileti dönecektir.

Dönen Değerler

Ortada bir hata iletisi yoksa FALSE, varsa son IMAP hatasının açıklamasını içeren bir dizge döndürür

Ayrıca Bakınız

  • imap_errors() - Oluşan tüm IMAP hatalarının iletilerini döndürür

imap_headers
imap_list
IMAP İşlevleri


Posta kutularını listeler

imap_last_error
imap_listmailbox
IMAP İşlevleri
PHP Manual

imap_list

(PHP 4, PHP 5, PHP 7)

imap_list — Posta kutularını listeler

Açıklama

array imap_list ( resource $imap_akımı , string $hedef , string $kalıp )

Posta kutusu listesini okur.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

hedef

imap_open() işlevinde açıklandığı gibi normal olarak bir sunucu belirtimi olmalıdır.

kalıp

Posta kutusu hiyerarşisi içine aramanın başlayacağı yeri belirtir.

kalıp içinde belirtilebilecek iki özel karakter vardır: Alt dizinlere inilmesini sağlayan '*' ve alt dizinlere inilmemesini sağlayan '%'. kalıp olarak '*' posta kutusu hiyerarşisi içindeki tüm posta kutularının listelenmesini, '%' ise sadece tepe seviyedeki posta kutularının listelenmesini sağlar. kalıp olarak '~/mail/%' belirtilirse alt dizinlere inilmeden sadece ~/mail dizini altındaki posta kutuları listelenir.

Dönen Değerler

Posta kutusu isimlerini içeren bir dizi döner.

Örnekler

Örnek 1 - imap_list() örneği

<?php
$mbox = imap_open("{imap.example.org}", "username", "password", OP_HALFOPEN)
      or die("bağlanılamadı: " . imap_last_error());

$list = imap_list($mbox, "{imap.example.org}", "*");
if (is_array($list)) {
    foreach ($list as $val) {
        echo imap_utf7_decode($val) . "\n";
    }
} else {
    echo "imap_list başarısız oldu: " . imap_last_error() . "\n";
}

imap_close($mbox);
?>

Ayrıca Bakınız

  • imap_getmailboxes() - Posta kutuları hakkında ayrıntılı bilgi döndürür
  • imap_lsub() - Üyesi olunan tüm posta kutularını listeler

imap_last_error
imap_listmailbox
IMAP İşlevleri


imap_list işlevinin takma adıdır

imap_list
imap_listscan
IMAP İşlevleri
PHP Manual

imap_listmailbox

(PHP 4, PHP 5, PHP 7)

imap_listmailbox — imap_list() işlevinin takma adıdır

Açıklama

Bu işlev, imap_list() işlevinin takma adıdır.

imap_list
imap_listscan
IMAP İşlevleri


Belirtilen metin ile eşleşen posta kutularını listeler

imap_listmailbox
imap_listsubscribed
IMAP İşlevleri
PHP Manual

imap_listscan

(PHP 4, PHP 5, PHP 7)

imap_listscan — Belirtilen metin ile eşleşen posta kutularını listeler

Açıklama

array imap_listscan ( resource $imap_akımı , string $hedef , string $kalıp , string $içerik )

Posta kutusu metninde içerik bulunan posta kutusu isimlerini içeren bir dizi döndürür.

Posta kutusu verisi içinde içerik dizgesinin varlığına bakması dışında imap_list() işlevine benzer.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

hedef

imap_open() işlevinde açıklandığı gibi normal olarak bir sunucu belirtimi olmalıdır.

kalıp

Posta kutusu hiyerarşisi içine aramanın başlayacağı yeri belirtir.

kalıp içinde belirtilebilecek iki özel karakter vardır: Alt dizinlere inilmesini sağlayan '*' ve alt dizinlere inilmemesini sağlayan '%'. kalıp olarak '*' posta kutusu hiyerarşisi içindeki tüm posta kutularının listelenmesini, '%' ise sadece tepe seviyedeki posta kutularının listelenmesini sağlar. kalıp olarak '~/mail/%' belirtilirse alt dizinlere inilmeden sadece ~/mail dizini altındaki posta kutuları listelenir.

içerik

Aranacak dizge.

Dönen Değerler

Posta kutusu metninde içerik dizgesi geçen posta kutusu isimlerini bir dizi içinde döndürür.

Ayrıca Bakınız

  • imap_listmailbox() - imap_list işlevinin takma adıdır
  • imap_search() - Belirtilen kurala uyan iletileri bir dizi içinde döndürür

imap_listmailbox
imap_listsubscribed
IMAP İşlevleri


imap_lsub işlevinin takma adıdır

imap_listscan
imap_lsub
IMAP İşlevleri
PHP Manual

imap_listsubscribed

(PHP 4, PHP 5, PHP 7)

imap_listsubscribed — imap_lsub() işlevinin takma adıdır

Açıklama

Bu işlev, imap_lsub() işlevinin takma adıdır.

imap_listscan
imap_lsub
IMAP İşlevleri


Üyesi olunan tüm posta kutularını listeler

imap_listsubscribed
imap_mail_compose
IMAP İşlevleri
PHP Manual

imap_lsub

(PHP 4, PHP 5, PHP 7)

imap_lsub — Üyesi olunan tüm posta kutularını listeler

Açıklama

array imap_lsub ( resource $imap_akımı , string $hedef , string $kalıp )

Üyesi olunan tüm posta kutularını bir dizi içinde döndürür.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

hedef

imap_open() işlevinde açıklandığı gibi normal olarak bir sunucu belirtimi olmalıdır.

kalıp

Posta kutusu hiyerarşisi içine aramanın başlayacağı yeri belirtir.

kalıp içinde belirtilebilecek iki özel karakter vardır: Alt dizinlere inilmesini sağlayan '*' ve alt dizinlere inilmemesini sağlayan '%'. kalıp olarak '*' posta kutusu hiyerarşisi içindeki tüm posta kutularının listelenmesini, '%' ise sadece tepe seviyedeki posta kutularının listelenmesini sağlar. kalıp olarak '~/mail/%' belirtilirse alt dizinlere inilmeden sadece ~/mail dizini altındaki posta kutuları listelenir.

Dönen Değerler

Üye olunan tüm posta kutularını bir dizi içinde döndürür.

Ayrıca Bakınız

  • imap_list() - Posta kutularını listeler
  • imap_getmailboxes() - Posta kutuları hakkında ayrıntılı bilgi döndürür

imap_listsubscribed
imap_mail_compose
IMAP İşlevleri


Zarfı ve gövdesi belirtilen MIME iletisini oluşturur

imap_lsub
imap_mail_copy
IMAP İşlevleri
PHP Manual

imap_mail_compose

(PHP 4, PHP 5, PHP 7)

imap_mail_compose — Zarfı ve gövdesi belirtilen MIME iletisini oluşturur

Açıklama

string imap_mail_compose ( array $zarf , array $gövde )

Belirtilen zarf ve gövde bölümlerini kullanarak bir MIME iletisi oluşturur.

Değiştirgeler

zarf

Başlıkları içeren bir ilişkisel dizi.

gövde

Gövdeleri içeren bir ilişkisel dizi.

İlişkisel dizi şu anahtarları içerir: "type", "encoding", "subtype", "description" ve "contents.data"

Dönen Değerler

MIME iletisi döner.

Örnekler

Örnek 1 - imap_mail_compose() örneği

<?php

$envelope["from"]= "joe@example.com";
$envelope["to"]  = "foo@example.com";
$envelope["cc"]  = "bar@example.com";

$part1["type"] = TYPEMULTIPART;
$part1["subtype"] = "mixed";

$filename = "/tmp/imap.c.gz";
$fp = fopen($filename, "r");
$contents = fread($fp, filesize($filename));
fclose($fp);

$part2["type"] = TYPEAPPLICATION;
$part2["encoding"] = ENCBINARY;
$part2["subtype"] = "octet-stream";
$part2["description"] = basename($filename);
$part2["contents.data"] = $contents;

$part3["type"] = TYPETEXT;
$part3["subtype"] = "plain";
$part3["description"] = "description3";
$part3["contents.data"] = "contents.data3\n\n\n\t";

$body[1] = $part1;
$body[2] = $part2;
$body[3] = $part3;

echo nl2br(imap_mail_compose($envelope, $body));

?>

imap_lsub
imap_mail_copy
IMAP İşlevleri


Belirtilen iletileri bir posta kutusuna kopyalar

imap_mail_compose
imap_mail_move
IMAP İşlevleri
PHP Manual

imap_mail_copy

(PHP 4, PHP 5, PHP 7)

imap_mail_copy — Belirtilen iletileri bir posta kutusuna kopyalar

Açıklama

bool imap_mail_copy ( resource $imap_akımı , string $iletiler , string $pk [, int $seçenekler = 0 ] )

iletiler değiştirgesinde belirtilen posta iletileri belirtilen posta kutusuna (pk) kopyalanır.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

iletiler

Kopyalanacak iletiler, » RFC 2060'da açıklandığı gibi bir ileti numarası aralığı olarak belirtilir.

pk

Posta kutusu ismi; daha fazla bilgi için imap_open()işlevine bakınız.

seçenekler

Aşağıdakilerin birini veya tamamını içeren bir bit maskesidir:

  • CP_UID - Sıra numaraları eşsiz kimlikleri içerir.
  • CP_MOVE - Kopyalandıktan sonra ileti yerel posta kutusundan silinir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • imap_mail_move() - Belirtilen iletiyi bir posta kutusuna taşır

imap_mail_compose
imap_mail_move
IMAP İşlevleri


Belirtilen iletiyi bir posta kutusuna taşır

imap_mail_copy
imap_mail
IMAP İşlevleri
PHP Manual

imap_mail_move

(PHP 4, PHP 5, PHP 7)

imap_mail_move — Belirtilen iletiyi bir posta kutusuna taşır

Açıklama

bool imap_mail_move ( resource $imap_akımı , string $iletiler , string $pk [, int $seçenekler = 0 ] )

iletiler değiştirgesinde belirtilen posta iletileri belirtilen posta kutusuna (pk) taşınır.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

iletiler

Taşınacak iletiler, » RFC 2060'da açıklandığı gibi bir ileti numarası aralığı olarak belirtilir.

pk

Posta kutusu ismi; daha fazla bilgi için imap_open() işlevine bakınız.

seçenekler

Şimdilik tek bir seçenek desteklenmektedir:

  • CP_UID - Sıra numaraları eşsiz kimlikleri içerir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • imap_mail_copy() - Belirtilen iletileri bir posta kutusuna kopyalar

imap_mail_copy
imap_mail
IMAP İşlevleri


Bir eposta iletisi gönderir

imap_mail_move
imap_mailboxmsginfo
IMAP İşlevleri
PHP Manual

imap_mail

(PHP 4, PHP 5, PHP 7)

imap_mail — Bir eposta iletisi gönderir

Açıklama

bool imap_mail ( string $kime , string $konu , string $ileti [, string $ek_başlıklar = NULL [, string $cc = NULL [, string $bcc = NULL [, string $dönüş_yolu = NULL ]]]] )

Cc ve Bcc alıcıları doğru yorumlanan epostaların gönderimine imkan verir.

kime, cc ve bcc değiştirgeleri birer dizge olup » RFC 822'ye göre yorumlanırlar.

Değiştirgeler

kime

Alıcının adresi.

konu

Postanın konusu.

ileti

Postanın gövdesi.

ek_başlıklar

Posta üzerinde gönderilecek ek başlıkları içeren bir dizge.

cc

bcc

Kara karbon kopya alıcıları (bcc) olarak belirtilen alıcılar eposta başlıklarında görünmez.

dönüş_yolu

Posta teslim edilemezse kullanılacak dönüş adresi bu değiştirgede belirtilir. PHP'nin çok sayıda kullanıcı için posta istemcisi olarak çalıştığı durumda yararlıdır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • mail() - Eposta gönderir

imap_mail_move
imap_mailboxmsginfo
IMAP İşlevleri


Posta kutusu hakkında bilgi döndürür

imap_mail
imap_mime_header_decode
IMAP İşlevleri
PHP Manual

imap_mailboxmsginfo

(PHP 4, PHP 5, PHP 7)

imap_mailboxmsginfo — Posta kutusu hakkında bilgi döndürür

Açıklama

object imap_mailboxmsginfo ( resource $imap_akımı )

Sunucudaki posta kutusunun durumunu sorgular. imap_status() işlevine benzemekle birlikte, biraz zaman alsa da posta kutusundaki iletilerin toplam uzunluğunu da döndürür.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

Dönen Değerler

Aşağıdaki özelliklere sahip bir nesne döner:

Posta kutusu özellikleri
Date | Son değişiklik tarihi (günün zamanı)
Driver | Sürücü
Mailbox | Posta kutusu ismi
Nmsgs | İleti sayısı
Recent | Son gelen ileti sayısı
Unread | Okunmamış ileti sayısı
Deleted | Silinmiş ileti sayısı
Size | Posta kutusunun boyu

Hata durumunda FALSE döner.

Örnekler

Örnek 1 - imap_mailboxmsginfo() örneği

<?php

$mbox = imap_open("{imap.example.org}INBOX", "username", "password")
      or die("bağlanılamadı: " . imap_last_error());

$check = imap_mailboxmsginfo($mbox);

if ($check) {
    echo "Date: "     . $check->Date    . "<br />\n" ;
    echo "Driver: "   . $check->Driver  . "<br />\n" ;
    echo "Mailbox: "  . $check->Mailbox . "<br />\n" ;
    echo "Messages: " . $check->Nmsgs   . "<br />\n" ;
    echo "Recent: "   . $check->Recent  . "<br />\n" ;
    echo "Unread: "   . $check->Unread  . "<br />\n" ;
    echo "Deleted: "  . $check->Deleted . "<br />\n" ;
    echo "Size: "     . $check->Size    . "<br />\n" ;
} else {
    echo "imap_check() hata verdi: " . imap_last_error() . "<br />\n";
}

imap_close($mbox);

?>

imap_mail
imap_mime_header_decode
IMAP İşlevleri


MIME başlık elemanlarının kodlamasını açar

imap_mailboxmsginfo
imap_msgno
IMAP İşlevleri
PHP Manual

imap_mime_header_decode

(PHP 4, PHP 5, PHP 7)

imap_mime_header_decode — MIME başlık elemanlarının kodlamasını açar

Açıklama

array imap_mime_header_decode ( string $dizge )

ASCII olmayan karakterler içeren MIME ileti başlıklarının kodlamasını açar (» RFC 2047'ye bakınız).

Değiştirgeler

dizge

MIME kodlu metin.

Dönen Değerler

Kodu açılan başlıklar bir nesne dizisi olarak döndürülür. Her nesnenin iki özelliği vardır: charset ve text.

Başlıklar kodlanmamışsa, yani salt ASCII iseler nesnenin charset özelliğine default değeri atanır.

Örnekler

Örnek 1 - imap_mime_header_decode() örneği

<?php
$text = "=?ISO-8859-1?Q?Keld_J=F8rn_Simonsen?= <keld@example.com>";

$elements = imap_mime_header_decode($text);
for ($i=0; $i<count($elements); $i++) {
    echo "Charset: {$elements[$i]->charset}\n";
    echo "Text: {$elements[$i]->text}\n\n";
}
?>

Yukarıdaki örneğin çıktısı:

Charset: ISO-8859-1
Text: Keld Jørn Simonsen

Charset: default
Text:  <keld@example.com>

Yukarıdaki örnekte dizi iki elemanlıdır. İlk elemandaki nesne ISO-8859-1 kodlu bir dizge içerirken ikincisi salt ASCII bir dizge içermektedir.

Ayrıca Bakınız

  • imap_utf8() - MIME kodlu metni UTF-8'e dönüştürür

imap_mailboxmsginfo
imap_msgno
IMAP İşlevleri


Belirtilen eşsiz kimlik için ileti numarasını döndürür

imap_mime_header_decode
imap_num_msg
IMAP İşlevleri
PHP Manual

imap_msgno

(PHP 4, PHP 5, PHP 7)

imap_msgno — Belirtilen eşsiz kimlik için ileti numarasını döndürür

Açıklama

int imap_msgno ( resource $imap_akımı , int $uid )

Belirtilen eşsiz kimlik (uid) için ileti numarasını döndürür.

Bu işlev imap_uid() işlevinin tersidir.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

uid

İletinin eşsiz kimliği.

Dönen Değerler

İletinin sıra numarası bir tamsayı olarak döner.

Ayrıca Bakınız

  • imap_uid() - Numarası belirtilen iletiyle ilgili eşsiz kimliği döndürür

imap_mime_header_decode
imap_num_msg
IMAP İşlevleri


Posta kutusundaki ileti sayısını döndürür

imap_msgno
imap_num_recent
IMAP İşlevleri
PHP Manual

imap_num_msg

(PHP 4, PHP 5, PHP 7)

imap_num_msg — Posta kutusundaki ileti sayısını döndürür

Açıklama

int imap_num_msg ( resource $imap_akımı )

Posta kutusundaki ileti sayısını döndürür.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

Dönen Değerler

İleti sayısı bir tamsayı olarak döner.

Ayrıca Bakınız

  • imap_num_recent() - Posta kutusuna en son gelen ileti sayısını döndürür
  • imap_status() - Bir posta kutusunun durum bilgisini döndürür

imap_msgno
imap_num_recent
IMAP İşlevleri


Posta kutusuna en son gelen ileti sayısını döndürür

imap_num_msg
imap_open
IMAP İşlevleri
PHP Manual

imap_num_recent

(PHP 4, PHP 5, PHP 7)

imap_num_recent — Posta kutusuna en son gelen ileti sayısını döndürür

Açıklama

int imap_num_recent ( resource $imap_akımı )

Posta kutusuna en son gelen ileti sayısını döndürür.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

Dönen Değerler

Son gelen ileti sayısını bir tamsayı olarak döndürür.

Ayrıca Bakınız

  • imap_num_msg() - Posta kutusundaki ileti sayısını döndürür
  • imap_status() - Bir posta kutusunun durum bilgisini döndürür

imap_num_msg
imap_open
IMAP İşlevleri


Belirtilen posta kutusuna yeni bir IMAP akımı açar

imap_num_recent
imap_ping
IMAP İşlevleri
PHP Manual

imap_open

(PHP 4, PHP 5, PHP 7)

imap_open — Belirtilen posta kutusuna yeni bir IMAP akımı açar

Açıklama

resource imap_open ( string $pk , string $kullanıcı , string $parola [, int $seçenekler = NIL [, int $dnm_sayısı = 0 ]] )

Belirtilen posta kutusuna (pk) bir IMAP akımı açar.

Bu işlev POP3 ve NNTP sunucularına oturum açmak için de kullanılabilirse de bazı işlevler ve özellikler sadece IMAP sunucularında kullanılabilmektedir.

Değiştirgeler

pk

Bir posta kutusu ismi, bir sunucu ve sunucu üzerindeki bir posta kutusu yolundan oluşur. INBOX özel bir isim olup kullanıcıların kişisel posta kutularını betimler. Uluslararası karakterler içeren posta kutusu isimleri, ASCII bölgesinde basılabilir hale getirilmek üzere imap_utf7_encode() ile kodlanır.

Posta kutusu isminin sunucu parçası '{' ve '}' ayraçları arasına yazılmış sunucu adı veya IP adresine iki nokta imi ile eklemlenebilen isteğe bağlı bir port ve '/' ile eklemlenebilen yine isteğe bağlı bir protokol belirtiminden oluşur.

Tüm posta kutusu değiştirgelerinde sunucu parçasının belirtilmesi zorunludur.

Tüm isimler { ayracı ile başlar ve genelde şu sözdizimine sahiptir: "{" uzak_sistem_adı [":" port] [imler] "}" [pk_ismi]. Sözdizimini oluşturan parçaların açıklamaları:

  • uzak_sistem_adı - Genel Ağ alan adı veya sunucunun IP adresi.
  • port - İsteğe bağlı TCP port numarası; öntanımlı değeri hizmetin öntanımlı port numarasıdır.
  • imler - İsteğe bağlı imlerin açıklamaları için aşağıdaki tabloya bakınız.
  • pk_ismi - Uzak posta kutusu ismi; INBOX öntanımlı isimdir.

İsimler için seçimlik imler
İm | Açıklama
/service=hizmet | Posta kutusuna erişimi sağlayan hizmetin adı; "imap" öntanımlı değerdir.
/user=kullanıcı | Sunucuya oturum açmak için uzak kullanıcı ismi
/authuser=kullanıcı | Kimlik doğrulaması için kullanılacak kullanıcı ismi; belirtilirse parola olarak bu kullanıcının parolası kullanılır.
/anonymous | Bir anonim kullanıcı olarak erişim
/debug | Uygulamanın hata ayıklama günlüğündeki protokol uzaktan ölçümü kaydedilir.
/secure | Salt metin bir parola ağ üzerinden aktarılmaz.
/imap, /imap2, /imap2bis, /imap4, /imap4rev1 | /service=imap'a eşdeğerdir.
/pop3 | /service=pop3'e eşdeğerdir.
/nntp | /service=nntp'ye eşdeğerdir.
/norsh | Ön kimlik doğrulamalı IMAP oturumu oluşturmak için rsh veya ssh kullanılmaz
/ssl | Oturumu şifrelemek için use the SSL kullanılır.
/validate-cert | TLS/SSL sunucusundaki sertifikaları doğrular (bu öntanımlı davranıştır)
/novalidate-cert | TLS/SSL sunucusundaki sertifikalar doğrulanmaz; sunucu öz- imzalı sertifikalar kullanıyorsa gerekir.
/tls | Oturumu şifrelemek için start-TLS kullanımı zorlanır ve bunu desteklemeyen sunuculara bağlantı reddedilir.
/notls | Oturumu şifrelemek için sunucular desteklese bile start-TLS kullanılmaz.
/readonly | Salt-okunur posta kutusu açma isteği yapılır. (Sadece IMAP içindir. NNTP'de yoksayılır, SMTP ve POP3 ile kullanıldığında ise hata oluşur).

kullanıcı

Kullanıcı ismi.

Parola

kullanıcı ile ilişkili parola.

seçenekler

Aşağıdakilerden bir veya birkaçını içeren bir bit maskesidir:

  • OP_READONLY - Posta kutusu salt-okunu açılır.
  • OP_ANONYMOUS - Haberler (sadece NNTP) için .newsrc kullanılmaz ve güncellenmez.
  • OP_HALFOPEN - IMAP ve NNTP isimleri için bir posta kutusu değil bir bağlantı açar.
  • CL_EXPUNGE - Kapatmadan önce posta kutusu sessizce silinir (ayrıca bakınız: imap_delete() ve imap_expunge())
  • OP_DEBUG - Hata ayıklama protokolü pazarlığı yapılır.
  • OP_SHORTCACHE - Küçük (sadece elt) önbellekleme
  • OP_SILENT - Olaylar aktarılmaz (dahili kullanım)
  • OP_PROTOTYPE - Sürücü önörneği döner.
  • OP_SECURE - Güvenilir olmayan bağlantıyla kimlik doğrulaması yapılmaz.

dnm_sayısı

Azami bağlantı denemesi sayısı.

Dönen Değerler

Hata durumunda FALSE yoksa bir IMAP akımı döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.2.0 | dnm_sayısı değiştirgesi eklendi.

Örnekler

Örnek 1 - imap_open() işlevinin farklı kullanımları

<?php
// Yerel makinenin 143. portunda çalışan IMAP sunucusuna bağlanalım
$mbox = imap_open("{localhost:143}INBOX", "birey", "parola");

// Yerel makinenin 110. portunda çalışan POP3 sunucusuna bağlanalım
$mbox = imap_open ("{localhost:110/pop3}INBOX", "birey", "parola");

// Protokol belirtimi olarak /ssl kullanarak
// bir SSL IMAP veya POP3 sunucusuna bağlanalım
$mbox = imap_open ("{localhost:993/imap/ssl}INBOX", "birey", "parola");

// Protokol belirtimi olarak /ssl/novalidate-cert kullanarak öz-imzalı
// sertifika kullanan bir SSL IMAP veya POP3 sunucusuna bağlanalım
$mbox = imap_open ("{localhost:995/pop3/ssl/novalidate-cert}",
          "birey", "parola");

// Yerel makinenin 119. portunda çalışan NNTP sunucusuna bağlanalım
$nntp = imap_open ("{localhost:119/nntp}comp.test", "", "");
// Bir uzak sunucuya bağlanmak için "localhost" yerine sunucunun adını
// veya IP adresini yazın.
?>

Örnek 2 - imap_open() örneği

<?php
$mbox = imap_open("{imap.example.org:143}", "birey", "parola");

echo "<h1>Posta kutuları</h1>\n";
$folders = imap_listmailbox($mbox, "{imap.example.org:143}", "*");

if ($folders == false) {
    echo "İşlem başarısız oldu<br />\n";
} else {
    foreach ($folders as $val) {
        echo $val . "<br />\n";
    }
}

echo "<h1>INBOX içindeki başlıklar</h1>\n";
$headers = imap_headers($mbox);

if ($headers == false) {
    echo "İşlem başarısız oldu<br />\n";
} else {
    foreach ($headers as $val) {
        echo $val . "<br />\n";
    }
}

imap_close($mbox);
?>

Ayrıca Bakınız

  • imap_close() - IMAP akımını kapatır

imap_num_recent
imap_ping
IMAP İşlevleri


Belirtilen IMAP akımı hala etkin mi diye bakar

imap_open
imap_qprint
IMAP İşlevleri
PHP Manual

imap_ping

(PHP 4, PHP 5, PHP 7)

imap_ping — Belirtilen IMAP akımı hala etkin mi diye bakar

Açıklama

bool imap_ping ( resource $imap_akımı )

imap_ping() işlevi hala etkin olup olmadığını anlamak için belirtilen akıma ping atar. Yeni postaların varlığını sınamak için kullanılabilir; özellikle belli bir süre etkinlik olmadığında bağlantıyı kapatan sunucularda belli aralıklarla yeni eposta gelip gelmediğine bakmak için iyi bir yöntemdir.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

Dönen Değerler

Akım hala etkinse TRUE, diğer tüm durumlarda FALSE döner.

Örnekler

Örnek 1 - imap_ping() örneği

<?php

$imap = imap_open("{imap.example.org}", "mailadmin", "password");

// bir süre geçtikten sonra
if (!imap_ping($imap)) {
    // yeniden bağlanmaya çalış
}

?>

imap_open
imap_qprint
IMAP İşlevleri


Bir 7 bitlik dizgeyi 8 bitlik dizgeye dönüştürür

imap_ping
imap_rename
IMAP İşlevleri
PHP Manual

imap_qprint

(PHP 4, PHP 5, PHP 7)

imap_qprint — Bir 7 bitlik dizgeyi 8 bitlik dizgeye dönüştürür

Açıklama

string imap_qprint ( string $dizge )

Belirtilen 7 bitlik (quoted-printable kodlu) dizgenin kodlamasını » RFC2045, bölüm 6.7'ye uygun olarak 8 bite dönüştürür.

Değiştirgeler

dizge

7 bitlik (quoted-printable) dizge.

Dönen Değerler

8 bitlik dizge döner.

Ayrıca Bakınız

  • imap_8bit() - 8 bitlik bir dizgeyi 7 bitlik (quoted-printable) bir dizgeye dönüştürür

imap_ping
imap_rename
IMAP İşlevleri


Takma Adı: imap_renamemailbox

imap_qprint
imap_renamemailbox
IMAP İşlevleri
PHP Manual

imap_rename

(PHP 4, PHP 5, PHP 7)

imap_rename — Takma Adı: imap_renamemailbox()

Açıklama

Bu işlev şu işlevin takma adıdır: imap_renamemailbox().

imap_qprint
imap_renamemailbox
IMAP İşlevleri


Posta kutusunun ismini değiştirir

imap_rename
imap_reopen
IMAP İşlevleri
PHP Manual

imap_renamemailbox

(PHP 4, PHP 5, PHP 7)

imap_renamemailbox — Posta kutusunun ismini değiştirir

Açıklama

bool imap_renamemailbox ( resource $imap_akımı , string $eskisi , string $yenisi )

Posta kutusunun ismini değiştirir. Posta kutusu isimlerinin biçemi için imap_open() işlevine bakın.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

eskisi

Eski posta kutusu ismi.

yenisi

Yeni posta kutusu ismi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • imap_createmailbox() - Yeni bir posta kutusu oluşturur
  • imap_deletemailbox() - Bir posta kutusunu siler

imap_rename
imap_reopen
IMAP İşlevleri


IMAP akımını yeni posta kutusunda yeniden açar

imap_renamemailbox
imap_rfc822_parse_adrlist
IMAP İşlevleri
PHP Manual

imap_reopen

(PHP 4, PHP 5, PHP 7)

imap_reopen — IMAP akımını yeni posta kutusunda yeniden açar

Açıklama

bool imap_reopen ( resource $imap_akımı , string $pk [, int $seçenekler = 0 [, int $dnm_sayısı = 0 ]] )

Bir IMAP veya NNTP sunucu üzerinde belirtilen posta kutusu için (pk) belirtilen akımı yeniden açar.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

pk

Posta kutusu adı; ayrıntılar için imap_open()işlevine bakınız.

seçenekler

Aşağıdakilerden gerekenleri içeren bir bit maskesi olarak belirtilir:

  • OP_READONLY - Posta kutusunu salt-okunur açar
  • OP_ANONYMOUS - Haberler (sadece NNTP) için .newsrc kullanılmaz ve güncellenmez.
  • OP_HALFOPEN - IMAP ve NNTP isimleri için bir posta kutusu değil bir bağlantı açar.
  • OP_EXPUNGE - Akım yeniden başlatılacağı zaman eskisi sessizce silinir.
  • CL_EXPUNGE - Kapatmadan önce posta kutusu sessizce silinir (ayrıca bakınız: imap_delete() ve imap_expunge())

dnm_sayısı

Azama bağlantı denemesi sayısı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.2.0 | dnm_sayısı değiştirgesi eklendi

Örnekler

Örnek 1 - imap_reopen() örneği

<?php
$mbox = imap_open("{imap.example.org:143}INBOX", "username", "password")
          or die(implode(", ", imap_errors()));
// ...
imap_reopen($mbox, "{imap.example.org:143}INBOX.Sent")
          or die(implode(", ", imap_errors()));
// ..
?>

imap_renamemailbox
imap_rfc822_parse_adrlist
IMAP İşlevleri


Bir adres dizgesini çözümler

imap_reopen
imap_rfc822_parse_headers
IMAP İşlevleri
PHP Manual

imap_rfc822_parse_adrlist

(PHP 4, PHP 5, PHP 7)

imap_rfc822_parse_adrlist — Bir adres dizgesini çözümler

Açıklama

array imap_rfc822_parse_adrlist ( string $adres , string $konak_adı )

Belirtilen adresleri içeren dizgeyi » RFC 2822'de tanımlandığı gibi çözümler.

Değiştirgeler

adres

Eposta adreslerini içeren bir dizge.

konak_adı

Öntanımlı konak adı.

Dönen Değerler

Bir nesne dizisi döner. Nesnelerin özellikleri şunlardır:

  • mailbox - Posta kutusu ismi (kullanıcı adı)
  • host - Alan adı
  • personal - Kullanıcının adı ve soyadı.
  • adl - @ alan adres yolu

Örnekler

Örnek 1 - imap_rfc822_parse_adrlist() örneği

<?php

$address_string = "Joe Doe <doe@example.com>, postmaster@example.com, root";
$address_array  = imap_rfc822_parse_adrlist($address_string, "example.com");
if (!is_array($address_array) || count($address_array) < 1) {
    die("Bir şeyler yanlış\n");
}

foreach ($address_array as $id => $val) {
    echo "# $id\n";
    echo "  Posta kutusu:  " . $val->mailbox . "\n";
    echo "  Alan adı:      " . $val->host . "\n";
    echo "  Adı ve soyadı: " . $val->personal . "\n";
    echo "  adl:           " . $val->adl . "\n";
}
?>

Yukarıdaki örneğin çıktısı:

# 0
  Posta kutusu:  doe
  Alan adı:      example.com
  Adı ve soyadı: Joe Doe
  adl:
# 1
  Posta kutusu:  postmaster
  Alan adı:      example.com
  Adı ve soyadı:
  adl:
# 2
  Posta kutusu:  root
  Alan adı:      example.com
  Adı ve soyadı:
  adl:

Ayrıca Bakınız

  • imap_rfc822_parse_headers() - Bir dizgedeki eposta başlıklarını çözümler

imap_reopen
imap_rfc822_parse_headers
IMAP İşlevleri


Bir dizgedeki eposta başlıklarını çözümler

imap_rfc822_parse_adrlist
imap_rfc822_write_address
IMAP İşlevleri
PHP Manual

imap_rfc822_parse_headers

(PHP 4, PHP 5, PHP 7)

imap_rfc822_parse_headers — Bir dizgedeki eposta başlıklarını çözümler

Açıklama

object imap_rfc822_parse_headers ( string $başlıklar [, string $konakadı = "UNKNOWN" ] )

imap_header() işlevindeki gibi çeşitli başlık elemanlarından oluşan bir nesne döner.

Değiştirgeler

başlıklar

Çözümlenecek başlık verisi.

konakadı

Öntanımlı konak adı.

Dönen Değerler

imap_header() işlevindeki gibi bir nesne döndürür, farklı olarak IMAP sunucusundan gelen diğer özellikler ve imler hariç tutulur.

Ayrıca Bakınız

  • imap_rfc822_parse_adrlist() - Bir adres dizgesini çözümler

imap_rfc822_parse_adrlist
imap_rfc822_write_address
IMAP İşlevleri


Posta kutusu, alan adı ve kişisel bilgi ile gerektiği gibi biçemlenmiş bir eposta adresi dönürür

imap_rfc822_parse_headers
imap_savebody
IMAP İşlevleri
PHP Manual

imap_rfc822_write_address

(PHP 4, PHP 5, PHP 7)

imap_rfc822_write_address — Posta kutusu, alan adı ve kişisel bilgi ile gerektiği gibi biçemlenmiş bir eposta adresi dönürür

Açıklama

string imap_rfc822_write_address ( string $posta_kutusu , string $alan_adı , string $adı_soyadı )

Belirtilen verilerle » RFC 2822'de tanımlandığı gibi düzgün olarak biçemlenmiş bir eposta adresi döndürür.

Değiştirgeler

posta_kutusu

Posta kutusu ismi; daha fazla bilgi için imap_open() işlevine bakınız.

alan_adı

Eposta adresinin alan adı parçası.

adı_soyadı

Eposta adresi sahibinin adı ve soyadı.

Dönen Değerler

» RFC 2822'de tanımlandığı gibi düzgün olarak biçemlenmiş bir eposta adresi döner.

Örnekler

Örnek 1 - imap_rfc822_write_address() örneği

<?php
echo imap_rfc822_write_address("hartmut", "example.com", "Hartmut Holzgraefe");
?>

Yukarıdaki örneğin çıktısı:

Hartmut Holzgraefe <hartmut@example.com>

imap_rfc822_parse_headers
imap_savebody
IMAP İşlevleri


Belirtilen iletinin gövdesini bir dosyaya kaydeder

imap_rfc822_write_address
imap_scan
IMAP İşlevleri
PHP Manual

imap_savebody

(PHP 5 >= 5.1.3, PHP 7)

imap_savebody — Belirtilen iletinin gövdesini bir dosyaya kaydeder

Açıklama

bool imap_savebody ( resource $imap_akımı , mixed $dosya , int $iletinum [, string $parçanum = "" [, int $seçenekler = 0 ]] )

Belirtilen ileti gövdesinin belirtilen parçasını bir dosyaya kaydeder.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

dosya

Bir dizge olarak ileti parçasının kaydedileceği dosyanın yolu veya fopen() tarafından döndürülmüş geçerli bir dosya tanıtıcısı.

iletinum

İleti numarası.

parçanum

Parça numarası. IMAP4 belirtimine uygun olarak bir gövde parça listesi içindeki indisleri nokta ile ayrılmış tamsayılar biçeminde içeren bir dizge.

seçenekler

Şunlardan gerekenleri içeren bir bit maskesidir:

  • FT_UID - iletinum bir eşsiz kimliktir.
  • FT_PEEK - \Seen imi tanımlıysa bir daha tanımlanmaz.
  • FT_INTERNAL - CRLF ile meşrulaştırılmamış olarak dizgeyi dahili biçemde döndürür.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • imap_fetchbody() - Belirtilen iletinin belli bir gövde bölümünü döndürür

imap_rfc822_write_address
imap_scan
IMAP İşlevleri


Takma Adı: imap_listscan

imap_savebody
imap_scanmailbox
IMAP İşlevleri
PHP Manual

imap_scan

(PHP 4, PHP 5, PHP 7)

imap_scan — Takma Adı: imap_listscan()

Açıklama

Bu işlev şu işlevin takma adıdır: imap_listscan().

imap_savebody
imap_scanmailbox
IMAP İşlevleri


imap_listscan işlevinin takma adıdır

imap_scan
imap_search
IMAP İşlevleri
PHP Manual

imap_scanmailbox

(PHP 4, PHP 5, PHP 7)

imap_scanmailbox — imap_listscan() işlevinin takma adıdır

Açıklama

Bu işlev, imap_listscan() işlevinin takma adıdır.

imap_scan
imap_search
IMAP İşlevleri


Belirtilen kurala uyan iletileri bir dizi içinde döndürür

imap_scanmailbox
imap_set_quota
IMAP İşlevleri
PHP Manual

imap_search

(PHP 4, PHP 5, PHP 7)

imap_search — Belirtilen kurala uyan iletileri bir dizi içinde döndürür

Açıklama

array imap_search ( resource $imap_akımı , string $kural [, int $seçenekler = SE_FREE [, string $karküm = NIL ]] )

Belirtilen IMAP akımı üzerinde açılmış posta kutusunda bir arama gerçekleştirir.

Örneğin, "annem" tarafından gönderilen yanıtlanmamış tüm iletileri döndürmek için şu kural kullanılır: "UNANSWERED FROM annem". Arama işlemi harf büyüklüğüne duyarsızdır. UW c-client kaynak kodundan okunan kural listesi eksik veya yanlış olabilir (ayrıca bakınız: » RFC2060, bölüm 6.4.4).

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

kural

Boşluk ayraçlı bir dizge olup aşağıdaki anahtar sözcüklere izin verilir. Çok sözcüklü değiştirgelerin çift tırnak içine alınması gerekir (örnek: FROM "joey smith").

  • ALL - Kuralın kalanı ile eşleşen tüm iletiler döndürülür.
  • ANSWERED - \\ANSWERED (yanıtlandı) imli iletiler döndürülür.
  • BCC "dizge" - Bcc: başlığında "dizge" bulunan iletiler döndürülür
  • BEFORE "tarih" - Date: başlığındaki "tarih" tarihinden önceki iletiler döndürülür.
  • BODY "dizge" - İleti gövdesindeki "dizge" ile eşleşen iletiler döndürülür
  • CC "dizge" - Cc: başlığında "dizge" bulunan iletiler döndürülür.
  • DELETED - silinen iletiler döndürülür.
  • FLAGGED - \\FLAGGED imli (bazan Önemli ve Acil diye de nitelenir) iletiler döndürülür.
  • FROM "dizge" - From: başlığında "dizge" bulunan iletiler döndürülür.
  • KEYWORD "dizge" - Bir anahtar sözcük olarak "ileti" içeren iletiler döndürülür.
  • NEW - Yeni iletiler döndürülür.
  • OLD - Eski iletiler döndürülür.
  • ON "tarih" - Date: başlığında "tarih" bulunan iletiler döndürülür.
  • RECENT - \\RECENT (en yeni) imli iletiler döndürülür.
  • SEEN - \\SEEN (okundu) imli iletiler döndürülür.
  • SINCE "tarih" - Date: başlığında "tarih" tarihinden sonraki tarihli iletiler döndürülür.
  • SUBJECT "dizge" - Subject: başlığında "dizge" bulunan iletiler döndürülür.
  • TEXT "dizge" - "dizge" metniyle eşleşen iletiler döndürülür.
  • TO "dizge" - To: başlığında "dizge" bulunan iletiler döndürülür.
  • UNANSWERED - Yanıtlanmamış iletiler döndürülür.
  • UNDELETED - Silinmiş iletiler döndürülür.
  • UNFLAGGED - İmlenmemiş iletiler döndürülür.
  • UNKEYWORD "dizge" - "dizge" anahtar sözcüğünü içermeyen iletiler döndürülür.
  • UNSEEN - Henüz okunmamış iletiler döndürülür.

seçenekler

Tek geçerli değer, iletilerin dizi içinde ileti numaralarıyla değil eşsiz kimlikleriyle dönmesini sağlayan SE_UID sabitidir.

karküm

Karakter kümesi.

Dönen Değerler

İleti numaralarını veya eşsiz kimlikleri içeren bir dizi döner.

kural ile belirtilen arama kuralı anlaşılamazsa veya kurala uyan hiçbir ileti yoksa FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.3 | karküm değiştirgesi eklendi.

Ayrıca Bakınız

  • imap_listscan() - Belirtilen metin ile eşleşen posta kutularını listeler

imap_scanmailbox
imap_set_quota
IMAP İşlevleri


Belirtilen posta kutusu için bir kota tanımlar

imap_search
imap_setacl
IMAP İşlevleri
PHP Manual

imap_set_quota

(PHP 4 >= 4.0.5, PHP 5, PHP 7)

imap_set_quota — Belirtilen posta kutusu için bir kota tanımlar

Açıklama

bool imap_set_quota ( resource $imap_akımı , string $posta_kutusu , int $kota_sınırı )

Belirtilen posta kutusu için bir kota üst sınırı tanımlar.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

posta_kutusu

Kotası tanımlanacak posta kutusu. IMAP standardına uygun olarak kullanıcı.isim biçeminde belirtilmelidir.

kota_sınırı

posta_kutusu'nun azami boyu (KB olarak)

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - imap_set_quota() örneği

<?php
$mbox = imap_open("{imap.example.org:143}", "mailadmin", "password");

if (!imap_set_quota($mbox, "user.kalowsky", 3000)) {
    echo "Kota ayarlanırken bir sorun çıktı\n";
    return;
}

imap_close($mbox);
?>

Notlar

Bu işlev şimdilik sadece c-client2000 ve üstü kütüphane sürümlerini kullananlar tarafından kullanılabilmektedir.

Belirtilen imap_akımı posta yöneticisi tarafından açılmış olmalıdır, yoksa işlev başarısız olur.

Ayrıca Bakınız

  • imap_open() - Belirtilen posta kutusuna yeni bir IMAP akımı açar
  • imap_get_quota() - Belirtilen kullanıcının kota ayarlarını döndürür

imap_search
imap_setacl
IMAP İşlevleri


Belirtilen posta kutusu ile ilgili erişim izinlerini tanımlar

imap_set_quota
imap_setflag_full
IMAP İşlevleri
PHP Manual

imap_setacl

(PHP 4 >= 4.0.7, PHP 5, PHP 7)

imap_setacl — Belirtilen posta kutusu ile ilgili erişim izinlerini tanımlar

Açıklama

bool imap_setacl ( resource $imap_akımı , string $posta_kutusu , string $kullanıcı , string $izinler )

Belirtilen posta kutusu ile ilgili erişim izinlerini tanımlar.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

posta_kutusu

Posta kutusu ismi; daha fazla bilgi için imap_open() işlevine bakınız.

kullanıcı

Erişim izinleri değiştirilecek kullanıcı.

izinler

Kullanıcıya verilecek izinler. Boş bir dizge atanması geçerli izinleri siler.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

Bu işlev sadece c-client2000 ve üstü kütüphane sürümlerini kullanan kullanıcılar için kullanılabilir.

Ayrıca Bakınız

  • imap_getacl() - Belirtilen posta kutusunun erişim izinlerini döndürür

imap_set_quota
imap_setflag_full
IMAP İşlevleri


İletileri imler

imap_setacl
imap_sort
IMAP İşlevleri
PHP Manual

imap_setflag_full

(PHP 4, PHP 5, PHP 7)

imap_setflag_full — İletileri imler

Açıklama

bool imap_setflag_full ( resource $imap_akımı , string $aralık , string $im [, int $seçenekler = NIL ] )

Belirtilen aralık içindeki iletilerin imlerine belirtilen im imini ekler.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

aralık

İleti numaraları aralığı. İmlenecek iletileri X,Y biçeminde sıralayabilir veya X:Y biçeminde bir aralık olarak belirtebilirsiniz.

im

» RFC 2060 tarafından tanımlanmış şu imler belirtilebilir: \Seen (okundu), \Answered (yanıtlandı), \Flagged (imlendi), \Deleted (silindi) ve \Draft (taslak).

seçenekler

Şu seçeneklerden sadece birini içerebilir:

  • ST_UID - aralık değiştirgesi sıra numaraları yerine eşsiz kimlikleri içerir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - imap_setflag_full() örneği

<?php
$pk = imap_open("{imap.example.org:143}", "birey", "parola")
     or die("bağlanılamadı: " . imap_last_error());

$durum = imap_setflag_full($pk, "2,5", "\\Seen \\Flagged");

echo gettype($durum) . "\n";
echo $durum . "\n";

imap_close($pk);
?>

Ayrıca Bakınız

  • imap_clearflag_full() - İletilerdeki imleri temizler

imap_setacl
imap_sort
IMAP İşlevleri


İletileri sıralar ve döndürür

imap_setflag_full
imap_status
IMAP İşlevleri
PHP Manual

imap_sort

(PHP 4, PHP 5, PHP 7)

imap_sort — İletileri sıralar ve döndürür

Açıklama

array imap_sort ( resource $imap_akımı , int $kural , int $tersine [, int $seçenekler = 0 [, string $arama_kuralı = NULL [, string $karküm = NIL ]]] )

Belirtilen değiştirgelere göre iletileri sıralar ve döndürür.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

kural

Şunlardan sadece biri belirtilebilir:

  • SORTDATE - İleti tarihi
  • SORTARRIVAL - Geliş tarihi
  • SORTFROM -İlk Kimden adresindeki posta kutusu
  • SORTSUBJECT - İleti konusu
  • SORTTO - İlk Kime adresindeki posta kutusu
  • SORTCC - İlk Karbon Kopya adresindeki posta kutusu
  • SORTSIZE - Sekizlik olarak ileti uzunluğu

tersine

1 atanırsa sıralama ters yönde yapılır.

seçenekler

Aşağıda, lazım olanlardan oluşan bir bit maskesi olarak belirtilir:

  • SE_UID - Sıra numarası yerine eşsiz kimlikler döner.
  • SE_NOPREFETCH - Arama yapılacak iletiler önce alınmaz.

arama_kuralı

karküm

Dönen Değerler

Belirtilen değiştirgelere göre sıralanmış olarak bir ileti dizisi döner.

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.3 | karküm değiştirgesi eklendi.

imap_setflag_full
imap_status
IMAP İşlevleri


Bir posta kutusunun durum bilgisini döndürür

imap_sort
imap_subscribe
IMAP İşlevleri
PHP Manual

imap_status

(PHP 4, PHP 5, PHP 7)

imap_status — Bir posta kutusunun durum bilgisini döndürür

Açıklama

object imap_status ( resource $imap_akımı , string $posta_kutusu , int $seçenekler )

Belirtilen posta_kutusu hakkında durum bilgisi döndürür.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

posta_kutusu

Posta kutusu ismi; daha fazla bilgi için imap_open() işlevine bakınız.

seçenekler

Geçerli seçenekler:

  • SA_MESSAGES - Posta kutusundaki ileti sayısını $durum->messages yapar.
  • SA_RECENT - Posta kutusundaki son iletinin numarasını $durum->recent yapar.
  • SA_UNSEEN - Posta kutusundaki okunmamış (yeni) ileti sayısını $durum->unseen yapar.
  • SA_UIDNEXT - Posta kutusunda kullanılacak sonraki eşsiz kimliği $durum->uidnext yapar.
  • SA_UIDVALIDITY - Posta kutusundaki eşsiz kimlikler geçersiz olduğunda değişen bir sabitin değerini $durum->uidvalidity yapar.
  • SA_ALL - Yukarıdakilerin hepsini tanımlar.

Dönen Değerler

Durum bilgisini içeren bir nesne döndürür. Nesne şu özelliklere sahiptir: messages, recent, unseen, uidnext ve uidvalidity.

Ayrıca, seçenekler değiştirgesine yukarıdaki sabitleri içeren bir bit maskesi atanır.

Örnekler

Örnek 1 - imap_status() örneği

<?php
$pk = imap_open("{imap.example.com}", "birey", "parola", OP_HALFOPEN)
      or die("bağlanılamadı: " . imap_last_error());

$durum = imap_status($pk, "{imap.example.org}INBOX", SA_ALL);
if ($durum) {
  echo "İleti sayısı:        " . $durum->messages    . "<br />\n";
  echo "Yeni gelenler:       " . $durum->recent      . "<br />\n";
  echo "Okunmamışlar:        " . $durum->unseen      . "<br />\n";
  echo "Sonraki eşsiz kimlik:" . $durum->uidnext     . "<br />\n";
  echo "kimli geçerli mi?:   " . $durum->uidvalidity . "<br />\n";
} else {
  echo "imap_status başarısız oldu: " . imap_last_error() . "\n";
}

imap_close($pk);
?>

imap_sort
imap_subscribe
IMAP İşlevleri


Bir posta kutusuna üyeliği başlatır

imap_status
imap_thread
IMAP İşlevleri
PHP Manual

imap_subscribe

(PHP 4, PHP 5, PHP 7)

imap_subscribe — Bir posta kutusuna üyeliği başlatır

Açıklama

bool imap_subscribe ( resource $imap_akımı , string $posta_kutusu )

Belirtilen posta kutusuna yeni bir üyelik başlatır.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

posta_kutusu

Posta kutusu ismi; daha fazla bilgi için imap_open() işlevine bakınız.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • imap_unsubscribe() - Bir posta kutusundan üyeliği sonlandırır

imap_status
imap_thread
IMAP İşlevleri


Bir iletinin konu ağacını döndürür

imap_subscribe
imap_timeout
IMAP İşlevleri
PHP Manual

imap_thread

(PHP 4 >= 4.0.7, PHP 5, PHP 7)

imap_thread — Bir iletinin konu ağacını döndürür

Açıklama

array imap_thread ( resource $imap_akımı [, int $seçenekler = SE_FREE ] )

Bir iletinin konu ağacını döndürür.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

seçenekler

Dönen Değerler

Bir iletinin konu ağacını REFERENCES alanına göre içeren bir ilişkisel dizi döner. İşlem sırasında bir hata oluşmuşsa FALSE döner.

Posta kutusundaki her ileti sonuç dizisinde üç girdi ile temsil edilir:

  • $thread["XX.num"] - geçerli ileti numarası

  • $thread["XX.next"] - sonraki

  • $thread["XX.branch"] - dal

Örnekler

Örnek 1 - imap_thread() örneği

<?php

// Bir haber grubundaki bir tartışmayı HTML olarak çıktılayalım

$nntp = imap_open('{news.example.com:119/nntp}some.newsgroup', '', '');
$threads = imap_thread($nntp);

foreach ($threads as $key => $val) {
  $tree = explode('.', $key);
  if ($tree[1] == 'num') {
    $header = imap_headerinfo($nntp, $val);
    echo "<ul>\n\t<li>" . $header->fromaddress . "\n";
  } elseif ($tree[1] == 'branch') {
    echo "\t</li>\n</ul>\n";
  }
}

imap_close($nntp);

?>

imap_subscribe
imap_timeout
IMAP İşlevleri


IMAP zaman aşımını tanımlar veya döndürür

imap_thread
imap_uid
IMAP İşlevleri
PHP Manual

imap_timeout

(PHP 4 >= 4.3.3, PHP 5, PHP 7)

imap_timeout — IMAP zaman aşımını tanımlar veya döndürür

Açıklama

mixed imap_timeout ( int $türü [, int $süre = -1 ] )

IMAP zaman aşımını tanımlar veya döndürür.

Değiştirgeler

türü

Şunlardan biridir: IMAP_OPENTIMEOUT, IMAP_READTIMEOUT, IMAP_WRITETIMEOUT, IMAP_CLOSETIMEOUT.

süre

Saniye cinsinden zaman aşımı süresi.

Dönen Değerler

süre değiştirgesi belirtilmişse TRUE başarısızlık durumunda ise FALSE döner.

süre belirtilmemişse veya -1 ise türü ile belirtilen türdeki geçerli zaman aşımı süresini bir tamsayı olarak döndürür.

Örnekler

Örnek 1 - imap_timeout() örneği

<?php

echo "Okuma zaman aşımı: " . imap_timeout(IMAP_READTIMEOUT) . "\n";

?>

imap_thread
imap_uid
IMAP İşlevleri


Numarası belirtilen iletiyle ilgili eşsiz kimliği döndürür

imap_timeout
imap_undelete
IMAP İşlevleri
PHP Manual

imap_uid

(PHP 4, PHP 5, PHP 7)

imap_uid — Numarası belirtilen iletiyle ilgili eşsiz kimliği döndürür

Açıklama

int imap_uid ( resource $imap_akımı , int $iletinum )

Numarası belirtilen iletiyle ilgili eşsiz kimliğini döndürür. Adından anlaşılacağı gibi eşsiz kimlik eşsiz bir betimleyici olup posta kutusundaki her değişiklikte ileti numarası değişse bile o değişmez.

Bu işlev, imap_msgno() işlevinin tersidir.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

iletinum

İleti numarası.

Dönen Değerler

Belirtilen iletinin eşsiz kimliği döner.

Notlar

Bilginize:

Bu işlev POP3 posta kutularında kullanılamaz.

Ayrıca Bakınız

  • imap_msgno() - Belirtilen eşsiz kimlik için ileti numarasını döndürür

imap_timeout
imap_undelete
IMAP İşlevleri


Silindi diye imlenmiş bir iletinin imini kaldırır

imap_uid
imap_unsubscribe
IMAP İşlevleri
PHP Manual

imap_undelete

(PHP 4, PHP 5, PHP 7)

imap_undelete — Silindi diye imlenmiş bir iletinin imini kaldırır

Açıklama

bool imap_undelete ( resource $imap_akımı , int $iletinum [, int $seçenekler = 0 ] )

Belirtilen iletiden imap_delete() veya imap_mail_move() işleviyle konmuş silme imini kaldırır.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

iletinum

İleti numarası.

seçenekler

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • imap_delete() - Belirtilen iletiyi silindi olarak imler
  • imap_mail_move() - Belirtilen iletiyi bir posta kutusuna taşır

imap_uid
imap_unsubscribe
IMAP İşlevleri


Bir posta kutusundan üyeliği sonlandırır

imap_undelete
imap_utf7_decode
IMAP İşlevleri
PHP Manual

imap_unsubscribe

(PHP 4, PHP 5, PHP 7)

imap_unsubscribe — Bir posta kutusundan üyeliği sonlandırır

Açıklama

bool imap_unsubscribe ( resource $imap_akımı , string $posta_kutusu )

Belirtilen posta_kutusu ile üyeliği sonlandırır.

Değiştirgeler

imap_akımı

imap_open() işlevinden dönen bir IMAP akımı.

posta_kutusu

Posta kutusu ismi; daha fazla bilgi için imap_open() işlevine bakınız.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • imap_subscribe() - Bir posta kutusuna üyeliği başlatır

imap_undelete
imap_utf7_decode
IMAP İşlevleri


Bir dizgenin karakter kodlamasını takviyeli UTF-7'den ISO-8859-1'e dönüştürür

imap_unsubscribe
imap_utf7_encode
IMAP İşlevleri
PHP Manual

imap_utf7_decode

(PHP 4, PHP 5, PHP 7)

imap_utf7_decode — Bir dizgenin karakter kodlamasını takviyeli UTF-7'den ISO-8859-1'e dönüştürür

Açıklama

string imap_utf7_decode ( string $metin )

Takviyeli UTF-7 ile kodlanmış metin dizgesinin karakter kodlamasını ISO-8859-1'e dönüştürür.

Basılabilir ASCII karakter aralığı dışında kalan karakterler içeren posta kutusu isimlerini kodlamak için gerekir.

Değiştirgeler

metin

» RFC 2060'ın 5.1.3. bölümünde tanımlanan takviyeli UTF-7 (özgün UTF-7 » RFC 1642'de tanımlanmıştır) ile kodlanmış bir dizge.

Dönen Değerler

metin, geçersiz takviyeli UTF-7 kodları veya ISO-8859-1'de bulunmayan karakterler içeriyorsa FALSE, yoksa dönüştürülmüş dizge döner.

Ayrıca Bakınız

  • imap_utf7_encode() - ISO-8859-1 kodlu bir dizgenin kodlamasını takviyeli UTF-7'ye dönüştürür

imap_unsubscribe
imap_utf7_encode
IMAP İşlevleri


ISO-8859-1 kodlu bir dizgenin kodlamasını takviyeli UTF-7'ye dönüştürür

imap_utf7_decode
imap_utf8
IMAP İşlevleri
PHP Manual

imap_utf7_encode

(PHP 4, PHP 5, PHP 7)

imap_utf7_encode — ISO-8859-1 kodlu bir dizgenin kodlamasını takviyeli UTF-7'ye dönüştürür

Açıklama

string imap_utf7_encode ( string $veri )

Belirtilen veri dizgesinin karakter kodlamasını takviyeli UTF-7'ye dönüştürür.

Basılabilir ASCII karakter aralığı dışında kalan karakterler içeren posta kutusu isimlerini kodlamak için gerekir.

Değiştirgeler

veri

ISO-8859-1 kodlu bir dizge.

Dönen Değerler

veri dizgesinin » RFC 2060'ın 5.1.3. bölümünde tanımlanan takviyeli UTF-7 (özgün UTF-7 » RFC 1642'de tanımlanmıştır) ile kodlanmış halini döndürür.

Ayrıca Bakınız

  • imap_utf7_decode() - Bir dizgenin karakter kodlamasını takviyeli UTF-7'den ISO-8859-1'e dönüştürür

imap_utf7_decode
imap_utf8
IMAP İşlevleri


MIME kodlu metni UTF-8'e dönüştürür

imap_utf7_encode
Eposta
IMAP İşlevleri
PHP Manual

imap_utf8

(PHP 4, PHP 5, PHP 7)

imap_utf8 — MIME kodlu metni UTF-8'e dönüştürür

Açıklama

string imap_utf8 ( string $mimeli_metin )

Belirtilen MIME kodlu mimeli_metin dizgesinin karakter kodlamasını UTF-8'e dönüştürür.

Değiştirgeler

mimeli_metin

MIME kodlu dizge. MIME kodlama yöntemi » RFC2047'de, UTF-8 belirtimi ise » RFC2044'te açıklanmıştır.

Dönen Değerler

UTF-8 kodlanmış bir dizge.

Ayrıca Bakınız

  • imap_mime_header_decode() - MIME başlık elemanlarının kodlamasını açar

imap_utf7_encode
Eposta
IMAP İşlevleri


Eposta

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Eposta İşlevleri
    • ezmlm_hash — EZMLM için gereken ileti özetini hesaplar
    • mail — Eposta gönderir
imap_utf8
Giriş
Postayla İlgili Eklentiler


Giriş

mail() işlevi eposta göndermeyi mümkün kılar.

Eposta
Yapılandırma/Kurulum
Eposta


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Eposta


Gereksinimler

Eposta işlevlerinin kullanılabilmesi için PHP'nin derlenmesi sırasında sendmail çalıştırılabilirine erişebilmesi gerekir. Eğer qmail, postfix gibi başka bir eposta gönderme programı kullanıyorsanız PHP'nin, bunların sendmail sarmalayıcılarını kullanıldığından emin olmalısınız. PHP, sendmail dosyasını önce PATH ortam değişkenindeki yollarda arar. Bulamazsa şu yolları arar: /usr/bin:/usr/sbin:/usr/etc:/etc:/usr/ucblib:/usr/lib. sendmail dosyasının PATH ortam değişkenindeki yollardan birinde bulunmasını sağlarsanız iyi olur. Ayrıca, PHP'yi derleyen kullanıcının da sendmail çalıştırılabilirine erişimi olması gerekir.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Eposta eklentisi yapılandırma yönergeleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
mail.add_x_header | "0" | PHP_INI_PERDIR | PHP 5.3.0'dan beri kullanılabilmektedir.
mail.log | NULL | PHP_INI_PERDIR | PHP 5.3.0'dan beri kullanılabilmektedir. (PHP_INI_SYSTEM|PHP_INI_PERDIR)
mail.force_extra_parameters | NULL | PHP_INI_PERDIR | PHP 5.0.0'dan beri kullanılabilmektedir. (PHP_INI_SYSTEM|PHP_INI_PERDIR)
SMTP | "localhost" | PHP_INI_ALL |
smtp_port | "25" | PHP_INI_ALL | PHP 4.3.0'dan beri kullanılabilmektedir.
sendmail_from | NULL | PHP_INI_ALL |
sendmail_path | "/usr/sbin/sendmail -t -i" | PHP_INI_SYSTEM |
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

mail.add_x_header bool

Betiğin kullanıcı kimliğini ve dosya adını değer olarak alan X-PHP-Originating-Script başlığını ekler.

mail.log string

Tüm mail() çağrılarının günlükleneceği dosyanın tam yolu. Günlük girdileri betiğin tam yolu, satır numarası, To adresi ve başlıkları içerir.

mail.force_extra_parameters string

Belirtilen değiştirgelerin sendmail çalıştırılabilirine ek değiştirgeler olarak aktarılmasını sağlar. Bu değiştirgeler güvenli kipte bile daima mail() işlevinin beşinci değiştirgesinin değerinin yerine kullanılır.

SMTP string

Sadece Windows altında kullanılır: PHP'nin mail() işleviyle eposta göndermek için kullanacağı SMTP sunucusunun konak ismi veya IP adresi.

smtp_port int

Sadece Windows altında kullanılır: mail() işlevi ile eposta gönderirken SMTP yönergesinde belirtilen sunucuya bağlantı için kullanılacak port numarası; 25 öntanımlıdır. PHP 4.3.0'dan itibaren kullanılabilmektedir.

sendmail_from string

Windows altında PHP'den eposta gönderirken kullanılan gönderici ("From:") eposta adresi. Bu adres ayrıca "Return-Path:" başlığının değeri olarak da kullanılır.

sendmail_path string

sendmail programının bulunduğu yer; normalde /usr/sbin/sendmail veya /usr/lib/sendmail'dir. configure bu yeri sizin için bulup, bu yeri yönergenin öntanımlı değeri haline getirir; eğer bu işlem başarısız olursa, programın yerini siz de belirtebilirsiniz.

sendmail kullanılmayan sistemlerde bu yönergeye aynı amaçla kullanılan programın yerini yazmalısınız. Örneğin, » Qmail kullananlar /var/qmail/bin/sendmail veya /var/qmail/bin/qmail-inject gibi bir atama yapabilirler.

qmail-inject epostayı gönderirken herhangi bir seçenek belirtmeyi gerektirmez.

Bu yönerge Windows altında da çalışır. Belirtildiği takdirde, smtp, smtp_port ve sendmail_from yönergeleri yok sayılır ve bu yönergede belirtilen komut çalıştırılır.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
Eposta İşlevleri
Eposta


Eposta İşlevleri

İçindekiler

  • ezmlm_hash — EZMLM için gereken ileti özetini hesaplar
  • mail — Eposta gönderir
Öntanımlı Sabitler
ezmlm_hash
Eposta


EZMLM için gereken ileti özetini hesaplar

Eposta İşlevleri
mail
Eposta İşlevleri
PHP Manual

ezmlm_hash

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

ezmlm_hash — EZMLM için gereken ileti özetini hesaplar

Açıklama

int ezmlm_hash ( string $adres )

ezmlm_hash() işlevi EZMLM eposta listelerini bir MySQL veritabanınıda tutarken gereken ileti özetini hesaplar.

Değiştirgeler

adres

Özeti hesaplanacak eposta adresi.

Dönen Değerler

adres ile belirtilen eposta adresinin özetini bir dizge olarak döndürür.

Örnekler

Örnek 1 - Adres özetinin hesaplanıp bir kullanıcının üye yapılması

<?php

$adres = "joecool@example.com";
$özet = ezmlm_hash($adres);
$sorgu = sprintf("INSERT INTO sample VALUES (%s, '%s')", $özet, $adres);
$db->query($sorgu); // PHPLIB db arayüzü kullanılarak

?>

Eposta İşlevleri
mail
Eposta İşlevleri


Eposta gönderir

ezmlm_hash
Mailparse
Eposta İşlevleri
PHP Manual

mail

(PHP 4, PHP 5, PHP 7)

mail — Eposta gönderir

Açıklama

bool mail ( string $kime , string $konu , string $ileti [, string $ek_başlıklar [, string $ek_değiştirgeler ]] )

Sends an email.

Değiştirgeler

kime

Epostanın alıcısı veya alıcıları.

Bu dizgenin biçemi » RFC 2822'ye uygun olmalıdır. Bazı örnekler:

  • user@example.com
  • user@example.com, anotheruser@example.com
  • User <user@example.com>
  • User <user@example.com>, Another User <anotheruser@example.com>

konu

Epostanın konusu.

Dikkat

Konu » RFC 2047'nin koşullarını yerine getirmelidir.

ileti

Gönderilecek ileti.

Her satır bir satırsonu (\n) karakteri ile bitmeli ve 70 karakterden uzun olmamalıdır.

Dikkat

(Sadece Windows'ta) PHP, bir SMTP sunucu ile doğrudan konuşacaksa, bir satırın başında noktaya rastlanırsa bu nokta silinir. Bu hoşunuza gitmiyorsa bu noktaları çift nokta haline getirin.

<?php
$text = str_replace("\n.", "\n..", $text);
?>

ek_başlıklar (seçimlik)

Eposta başlığının sonuna yerleştirilecek dizge.

Bu genellikle ek başlıklar eklemek için kullanılır (From, Cc, Bcc gibi). Çok sayıda başlık eklenecekse bunlar birer CRLF (\r\n) ile birbirlerinden ayrılmalıdır.

Bilginize:

Eposta gönderilirken bir From başlığı içermesi gerekir. Bu başlık, bu değiştirge ile belirtilebileceği gibi öntanımlı gönderici adresini php.ini dosyasında da belirtmek mümkündür.

Bunu yapmazsanız şöyle bir hata alırsınız: Warning: mail(): "sendmail_from" not set in php.ini or custom "From:" header missing (Uyarı: mail(): php.ini dosyasında "sendmail_from" atanmamış veya özel "From:" başlığı eksik). From başlığı Windows altında Return-Path başlığını da tanımlar.

Bilginize:

Eğer ileti alınmazsa satırsonlarını CRLF (\r\n) ile değil sadece LF (\n) ile sonlandırmayı deneyin. Bazı düşük kaliteli Unix eposta sunucuları LF karakterlerini özdevinimli olarak CRLF karakterleri ile değiştirir (CRLF kullanıldıysa sonuç CRCRLF olur). Bu yöntem » RFC 2822'ye uygun olmadığından başka çare yoksa kullanılmalıdır.

ek_değiştirgeler (seçimlik)

Eposta gönderirken kullanılan programa komut satırı seçenekleri aktarmak için kullanılır. Eposta gönderme programının adı sendmail_path yapılandırma yönergesinde belirtilir. Örneğin, sendmail kullanılıyorsa bu değiştirgeyi -f komut satırı seçeneği ile zarf gönderici adresini belirtmek için kullanabilirsiniz.

Zarf göndericisinin (-f) bu değiştirge ile belirtildiği durumda, iletiye bir 'X-Warning' başlığının eklenmemesi için HTTP sunucusunu çalıştıran kullanıcının sendmail yapılandırma dosyasını güvenilir kullanıcı olarak kaydedilmesi gerekir. sendmail kullanıcıları için, bu dosyanın yeri: /etc/mail/trusted-users.

Dönen Değerler

Eposta sunucu tarafından başarıyla teslim alınmışsa TRUE, aksi takdirde FALSE döner.

Yalnız şuna dikkat edin: Epostanın sunucu tarafından teslim alınması, epostanın alıcısına ulaştığı anlamına gelmez.

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.0 (Sadece Windows) | Tüm özel başlıklar (From, Cc, Bcc, Date gibi) desteklenir ve bunlar harf büyüklüğüne duyarsızdır. (Özel başlıklar ilk MTA tarafından değil, PHP tarafından yorumlanır. PHP'nin 4.3'ten önceki sürümlerinde sadece Cc başlığı, o da harf büyüklüğüne duyarlı olarak desteklenirdi.)
4.2.3 | ek_değiştirgeler, eğer safe_mode etkin değilse iptal edilir ve mail() işlevi bunu bir uyarı iletisi ile belirtip FALSE döndürür.
4.0.5 | ek_değiştirgeler değiştirgesi eklendi.

Örnekler

Örnek 1 - Eposta gönderimi

mail() işlevi ile basit bir eposta gönderelim:

<?php
// İleti
$ileti = "Line 1\nLine 2\nLine 3";

// Satırlarımızın 70 karakterden uzun olanlarını katlamamız lazım
$ileti = wordwrap($ileti, 70);

// Epostayı gönderelim
mail('kafeinli@example.com', 'İleti konusu', $ileti);
?>

Örnek 2 - Ek başlıklarla eposta gönderimi

From ve Reply-To adreslerini ek başlıklar olarak belirtelim:

<?php
$kime      = 'nobody@example.com';
$konu      = 'konu';
$ileti     = 'Merhaba';
$başlıklar = 'From: webmaster@example.com' . "\r\n" .
    'Reply-To: webmaster@example.com' . "\r\n" .
    'X-Mailer: PHP/' . phpversion();

mail($kime, $konu, $ileti, $başlıklar);
?>

Örnek 3 - Ek komut satırı seçenekleriyle eposta gönderimi

sendmail_path yönergesinde belirtilen posta gönderme programına komut satırı değiştirgeleri aktarmak için ek_değiştirgeler değiştirgesi kullanılabilir.

<?php
mail('nobody@example.com', 'the subject', 'the message', null,
   '-fwebmaster@example.com');
?>

Örnek 4 - HTML eposta gönderimi

mail() işleviyle HTML eposta göndermek de mümkündür.

<?php
// çok sayıda alıcı
$to  = 'aidan@example.com' . ', '; // virgüle dikkat
$to .= 'wez@example.com';

// konu
$subject = 'Ağustos ayında hatırlanacak doğum günleri';

// ileti
$message = '
<html>
<head>
  <title>Ağustos ayında hatırlanacak doğum günleri</title>
</head>
<body>
  <p>Ağustos ayındaki doğum günleri!</p>
  <table>
    <tr>
      <th>Kişi</th><th>Gün</th><th>Ay</th><th>Yıl</th>
    </tr>
    <tr>
      <td>Ali</td><td>3</td><td>Ağustos</td><td>1970</td>
    </tr>
    <tr>
      <td>Veli</td><td>17</td><td>Ağustos</td><td>1973</td>
    </tr>
  </table>
</body>
</html>
';

// HTML eposta göndermek için, the Content-type başlığı belirtilmeli
$headers  = 'MIME-Version: 1.0' . "\r\n";
$headers .= 'Content-type: text/html; CHARSET=Windows-1254' . "\r\n";

// Ek başlıklar
$headers .= 'To: Mary <mary@example.com>, Kelly <kelly@example.com>' . "\r\n";
$headers .= 'From: Birthday Reminder <birthday@example.com>' . "\r\n";
$headers .= 'Cc: birthdayarchive@example.com' . "\r\n";
$headers .= 'Bcc: birthdaycheck@example.com' . "\r\n";

// İletiyi postalayalım
mail($to, $subject, $message, $headers);
?>

Bilginize:

HTML veya daha karmaşık bir eposta göndermek isterseniz » PEAR::Mail_Mime PEAR paketini kullanmanızı öneririz.

Notlar

Bilginize:

mail() işlevinin Windows gerçeklenimi bir çok bakımdan Unix gerçekleniminden farklıdır. Birincisi, iletileri göndermek için yerel bir program kullanılmaz, doğrudan soketlerle çalışılır ve MTA'nın soketi dinlediği varsayılır.

İkincisi, From:, Cc:, Bcc: ve Date: gibi özel başlıklar, epostayı ilk alan MTA tarafından yorumlanmaz, fakat PHP tarafından çözümlenir.

Aslında, to değiştirgesinin "Birad Soyad <birisi@example.com>" biçeminde bir adres olmaması gerekir. mail komutu MTA ile anlaşırken bunu gerektiği gibi çözümleyemeyebilir.

Bilginize:

Çok sayıda epostayı göndermek için mail() işlevini bir döngüye sokmak hiç de iyi bir fikir değildir. Bu işlev her eposta için SMTP soketini açıp kapadığından verimli değildir.

Çok sayıda eposta göndermek için, » PEAR::Mail ve » PEAR::Mail_Queue paketlerine bakınız.

Bilginize:

Şu RFC'ler yararlı olabilir: » RFC 1896, » RFC 2045, » RFC 2046, » RFC 2047, » RFC 2048, » RFC 2049 ve » RFC 2822.

Ayrıca Bakınız

  • imap_mail() - Bir eposta iletisi gönderir
  • » PEAR::Mail
  • » PEAR::Mail_Mime

ezmlm_hash
Mailparse
Eposta İşlevleri


Mailparse

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Mailparse İşlevleri
    • mailparse_determine_best_xfer_encoding — Gets the best way of encoding
    • mailparse_msg_create — Create a mime mail resource
    • mailparse_msg_extract_part_file — Extracts/decodes a message section
    • mailparse_msg_extract_part — Extracts/decodes a message section
    • mailparse_msg_extract_whole_part_file — Extracts a message section including headers without decoding the transfer encoding
    • mailparse_msg_free — Frees a MIME resource
    • mailparse_msg_get_part_data — Returns an associative array of info about the message
    • mailparse_msg_get_part — Returns a handle on a given section in a mimemessage
    • mailparse_msg_get_structure — Returns an array of mime section names in the supplied message
    • mailparse_msg_parse_file — Parses a file
    • mailparse_msg_parse — Incrementally parse data into buffer
    • mailparse_rfc822_parse_addresses — Parse RFC 822 compliant addresses
    • mailparse_stream_encode — Streams data from source file pointer, apply encoding and write to destfp
    • mailparse_uudecode_all — Scans the data from fp and extract each embedded uuencoded file
mail
Giriş
Postayla İlgili Eklentiler


Giriş

Mailparse is an extension for parsing and working with email messages. It can deal with » RFC 822 and » RFC 2045 (MIME) compliant messages.

Mailparse is stream based, which means that it does not keep in-memory copies of the files it processes - so it is very resource efficient when dealing with large messages.

Bilginize:

Mailparse requires the mbstring extension, and mbstring must be loaded before mailparse.

Bu eklenti » PECL deposuna taşınmış olup şu sürümden itibaren PHP kaynak paketinde dağıtılmamaktatır: PHP 4.2.0.

Mailparse
Yapılandırma/Kurulum
Mailparse


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Mailparse


Kurulum

Bu » PECL eklentisi PHP ile gelmez. Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/mailparse.

In order to use these functions you must compile PHP with mailparse support by using the --enable-mailparse configure option.

Windows users will enable php_mailparse.dll inside of php.ini in order to use these functions. Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız.

It is necessary that the mbstring extension is loaded before mailparse.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

MAILPARSE_EXTRACT_OUTPUT (integer)
MAILPARSE_EXTRACT_STREAM (integer)
MAILPARSE_EXTRACT_RETURN (integer)
Özkaynak Türleri
Mailparse İşlevleri
Mailparse


Mailparse İşlevleri

İçindekiler

  • mailparse_determine_best_xfer_encoding — Gets the best way of encoding
  • mailparse_msg_create — Create a mime mail resource
  • mailparse_msg_extract_part_file — Extracts/decodes a message section
  • mailparse_msg_extract_part — Extracts/decodes a message section
  • mailparse_msg_extract_whole_part_file — Extracts a message section including headers without decoding the transfer encoding
  • mailparse_msg_free — Frees a MIME resource
  • mailparse_msg_get_part_data — Returns an associative array of info about the message
  • mailparse_msg_get_part — Returns a handle on a given section in a mimemessage
  • mailparse_msg_get_structure — Returns an array of mime section names in the supplied message
  • mailparse_msg_parse_file — Parses a file
  • mailparse_msg_parse — Incrementally parse data into buffer
  • mailparse_rfc822_parse_addresses — Parse RFC 822 compliant addresses
  • mailparse_stream_encode — Streams data from source file pointer, apply encoding and write to destfp
  • mailparse_uudecode_all — Scans the data from fp and extract each embedded uuencoded file
Öntanımlı Sabitler
mailparse_determine_best_xfer_encoding
Mailparse


Gets the best way of encoding

Mailparse İşlevleri
mailparse_msg_create
Mailparse İşlevleri
PHP Manual

mailparse_determine_best_xfer_encoding

(PECL mailparse >= 0.9.0)

mailparse_determine_best_xfer_encoding — Gets the best way of encoding

Açıklama

string mailparse_determine_best_xfer_encoding ( resource $fp )

Figures out the best way of encoding the content read from the given file pointer.

Değiştirgeler

fp

A valid file pointer, which must be seek-able.

Dönen Değerler

Returns one of the character encodings supported by the mbstring module.

Örnekler

Örnek 1 mailparse_determine_best_xfer_encoding() example

<?php

$fp = fopen('somemail.eml', 'r');
echo 'Best encoding: ' . mailparse_determine_best_xfer_encoding($fp);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Best encoding: 7bit

Mailparse İşlevleri
mailparse_msg_create
Mailparse İşlevleri


Create a mime mail resource

mailparse_determine_best_xfer_encoding
mailparse_msg_extract_part_file
Mailparse İşlevleri
PHP Manual

mailparse_msg_create

(PECL mailparse >= 0.9.0)

mailparse_msg_create — Create a mime mail resource

Açıklama

resource mailparse_msg_create ( void )

Create a MIME mail resource.

Dönen Değerler

Returns a handle that can be used to parse a message.

Ayrıca Bakınız

  • mailparse_msg_free() - Frees a MIME resource
  • mailparse_msg_parse_file() - Parses a file

mailparse_determine_best_xfer_encoding
mailparse_msg_extract_part_file
Mailparse İşlevleri


Extracts/decodes a message section

mailparse_msg_create
mailparse_msg_extract_part
Mailparse İşlevleri
PHP Manual

mailparse_msg_extract_part_file

(PECL mailparse >= 0.9.0)

mailparse_msg_extract_part_file — Extracts/decodes a message section

Açıklama

string mailparse_msg_extract_part_file ( resource $mimemail , mixed $filename [, callable $callbackfunc ] )

Extracts/decodes a message section from the supplied filename.

The contents of the section will be decoded according to their transfer encoding - base64, quoted-printable and uuencoded text are supported.

Değiştirgeler

mimemail

A valid MIME resource, created with mailparse_msg_create().

filename

Can be a file name or a valid stream resource.

callbackfunc

If set, this must be either a valid callback that will be passed the extracted section, or NULL to make this function return the extracted section.

If not specified, the contents will be sent to "stdout".

Dönen Değerler

If callbackfunc is not NULL returns TRUE on success.

If callbackfunc is set to NULL, returns the extracted section as a string.

Returns FALSE on error.

Ayrıca Bakınız

  • mailparse_msg_extract_part() - Extracts/decodes a message section
  • mailparse_msg_extract_whole_part_file() - Extracts a message section including headers without decoding the transfer encoding

mailparse_msg_create
mailparse_msg_extract_part
Mailparse İşlevleri


Extracts/decodes a message section

mailparse_msg_extract_part_file
mailparse_msg_extract_whole_part_file
Mailparse İşlevleri
PHP Manual

mailparse_msg_extract_part

(PECL mailparse >= 0.9.0)

mailparse_msg_extract_part — Extracts/decodes a message section

Açıklama

void mailparse_msg_extract_part ( resource $mimemail , string $msgbody [, callable $callbackfunc ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

mimemail

A valid MIME resource.

msgbody

callbackfunc

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • mailparse_msg_extract_part_file() - Extracts/decodes a message section
  • mailparse_msg_extract_whole_part_file() - Extracts a message section including headers without decoding the transfer encoding

mailparse_msg_extract_part_file
mailparse_msg_extract_whole_part_file
Mailparse İşlevleri


Extracts a message section including headers without decoding the transfer encoding

mailparse_msg_extract_part
mailparse_msg_free
Mailparse İşlevleri
PHP Manual

mailparse_msg_extract_whole_part_file

(PECL mailparse >= 0.9.0)

mailparse_msg_extract_whole_part_file — Extracts a message section including headers without decoding the transfer encoding

Açıklama

string mailparse_msg_extract_whole_part_file ( resource $mimemail , string $filename [, callable $callbackfunc ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

mimemail

A valid MIME resource.

filename

callbackfunc

Dönen Değerler

Ayrıca Bakınız

  • mailparse_msg_extract_part() - Extracts/decodes a message section
  • mailparse_msg_extract_part_file() - Extracts/decodes a message section

mailparse_msg_extract_part
mailparse_msg_free
Mailparse İşlevleri


Frees a MIME resource

mailparse_msg_extract_whole_part_file
mailparse_msg_get_part_data
Mailparse İşlevleri
PHP Manual

mailparse_msg_free

(PECL mailparse >= 0.9.0)

mailparse_msg_free — Frees a MIME resource

Açıklama

bool mailparse_msg_free ( resource $mimemail )

Frees a MIME resource.

Değiştirgeler

mimemail

A valid MIME resource allocated by mailparse_msg_create() or mailparse_msg_parse_file().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • mailparse_msg_create() - Create a mime mail resource
  • mailparse_msg_parse_file() - Parses a file

mailparse_msg_extract_whole_part_file
mailparse_msg_get_part_data
Mailparse İşlevleri


Returns an associative array of info about the message

mailparse_msg_free
mailparse_msg_get_part
Mailparse İşlevleri
PHP Manual

mailparse_msg_get_part_data

(PECL mailparse >= 0.9.0)

mailparse_msg_get_part_data — Returns an associative array of info about the message

Açıklama

array mailparse_msg_get_part_data ( resource $mimemail )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

mimemail

A valid MIME resource.

mailparse_msg_free
mailparse_msg_get_part
Mailparse İşlevleri


Returns a handle on a given section in a mimemessage

mailparse_msg_get_part_data
mailparse_msg_get_structure
Mailparse İşlevleri
PHP Manual

mailparse_msg_get_part

(PECL mailparse >= 0.9.0)

mailparse_msg_get_part — Returns a handle on a given section in a mimemessage

Açıklama

resource mailparse_msg_get_part ( resource $mimemail , string $mimesection )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

mimemail

A valid MIME resource.

mimesection

mailparse_msg_get_part_data
mailparse_msg_get_structure
Mailparse İşlevleri


Returns an array of mime section names in the supplied message

mailparse_msg_get_part
mailparse_msg_parse_file
Mailparse İşlevleri
PHP Manual

mailparse_msg_get_structure

(PECL mailparse >= 0.9.0)

mailparse_msg_get_structure — Returns an array of mime section names in the supplied message

Açıklama

array mailparse_msg_get_structure ( resource $mimemail )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

mimemail

A valid MIME resource.

mailparse_msg_get_part
mailparse_msg_parse_file
Mailparse İşlevleri


Parses a file

mailparse_msg_get_structure
mailparse_msg_parse
Mailparse İşlevleri
PHP Manual

mailparse_msg_parse_file

(PECL mailparse >= 0.9.0)

mailparse_msg_parse_file — Parses a file

Açıklama

resource mailparse_msg_parse_file ( string $filename )

Parses a file. This is the optimal way of parsing a mail file that you have on disk.

Değiştirgeler

filename

Path to the file holding the message. The file is opened and streamed through the parser.

Dönen Değerler

Returns a MIME resource representing the structure, or FALSE on error.

Ayrıca Bakınız

  • mailparse_msg_free() - Frees a MIME resource
  • mailparse_msg_create() - Create a mime mail resource

mailparse_msg_get_structure
mailparse_msg_parse
Mailparse İşlevleri


Incrementally parse data into buffer

mailparse_msg_parse_file
mailparse_rfc822_parse_addresses
Mailparse İşlevleri
PHP Manual

mailparse_msg_parse

(PECL mailparse >= 0.9.0)

mailparse_msg_parse — Incrementally parse data into buffer

Açıklama

bool mailparse_msg_parse ( resource $mimemail , string $data )

Incrementally parse data into the supplied mime mail resource.

This function allow you to stream portions of a file at a time, rather than read and parse the whole thing.

Değiştirgeler

mimemail

A valid MIME resource.

data

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

mailparse_msg_parse_file
mailparse_rfc822_parse_addresses
Mailparse İşlevleri


Parse RFC 822 compliant addresses

mailparse_msg_parse
mailparse_stream_encode
Mailparse İşlevleri
PHP Manual

mailparse_rfc822_parse_addresses

(PECL mailparse >= 0.9.0)

mailparse_rfc822_parse_addresses — Parse RFC 822 compliant addresses

Açıklama

array mailparse_rfc822_parse_addresses ( string $addresses )

Parses a » RFC 822 compliant recipient list, such as that found in the To: header.

Değiştirgeler

addresses

A string containing addresses, like in: Wez Furlong <wez@example.com>, doe@example.com

Bilginize:

This string must not include the header name.

Dönen Değerler

Returns an array of associative arrays with the following keys for each recipient:

display | The recipient name, for display purpose. If this part is not set for a recipient, this key will hold the same value as address.
address | The email address
is_group | TRUE if the recipient is a newsgroup, FALSE otherwise.

Örnekler

Örnek 1 mailparse_rfc822_parse_addresses() example

<?php

$to = 'Wez Furlong <wez@example.com>, doe@example.com';
var_dump(mailparse_rfc822_parse_addresses($to));

?>

Yukarıdaki örneğin çıktısı:

array(2) {
  [0]=>
  array(3) {
    ["display"]=>
    string(11) "Wez Furlong"
    ["address"]=>
    string(15) "wez@example.com"
    ["is_group"]=>
    bool(false)
  }
  [1]=>
  array(3) {
    ["display"]=>
    string(15) "doe@example.com"
    ["address"]=>
    string(15) "doe@example.com"
    ["is_group"]=>
    bool(false)
  }
}

mailparse_msg_parse
mailparse_stream_encode
Mailparse İşlevleri


Streams data from source file pointer, apply encoding and write to destfp

mailparse_rfc822_parse_addresses
mailparse_uudecode_all
Mailparse İşlevleri
PHP Manual

mailparse_stream_encode

(PECL mailparse >= 0.9.0)

mailparse_stream_encode — Streams data from source file pointer, apply encoding and write to destfp

Açıklama

bool mailparse_stream_encode ( resource $sourcefp , resource $destfp , string $encoding )

Streams data from the source file pointer, apply encoding and write to the destination file pointer.

Değiştirgeler

sourcefp

A valid file handle. The file is streamed through the parser.

destfp

The destination file handle in which the encoded data will be written.

encoding

One of the character encodings supported by the mbstring module.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 mailparse_stream_encode() example

<?php

// email.eml contents: hello, this is some text=hello.
$fp = fopen('email.eml', 'r');

$dest = tmpfile();

mailparse_stream_encode($fp, $dest, "quoted-printable");

rewind($dest);

// Display new file contents
fpassthru($dest);

?>

Yukarıdaki örneğin çıktısı:

hello, this is some text=3Dhello.

mailparse_rfc822_parse_addresses
mailparse_uudecode_all
Mailparse İşlevleri


Scans the data from fp and extract each embedded uuencoded file

mailparse_stream_encode
vpopmail
Mailparse İşlevleri
PHP Manual

mailparse_uudecode_all

(PECL mailparse >= 0.9.0)

mailparse_uudecode_all — Scans the data from fp and extract each embedded uuencoded file

Açıklama

array mailparse_uudecode_all ( resource $fp )

Scans the data from the given file pointer and extract each embedded uuencoded file into a temporary file.

Değiştirgeler

fp

A valid file pointer.

Dönen Değerler

Returns an array of associative arrays listing filename information.

filename | Path to the temporary file name created
origfilename | The original filename, for uuencoded parts only
The first filename entry is the message body. The next entries are the decoded uuencoded files.

Örnekler

Örnek 1 mailparse_uudecode_all() example

<?php

$text = <<<EOD
To: fred@example.com

hello, this is some text hello.
blah blah blah.

begin 644 test.txt
/=&AI<R!I<R!A('1E<W0*
`
end

EOD;

$fp = tmpfile();
fwrite($fp, $text);

$data = mailparse_uudecode_all($fp);

echo "BODY\n";
readfile($data[0]["filename"]);
echo "UUE ({$data[1]['origfilename']})\n";
readfile($data[1]["filename"]);

// Clean up
unlink($data[0]["filename"]);
unlink($data[1]["filename"]);

?>

Yukarıdaki örneğin çıktısı:

BODY
To: fred@example.com

hello, this is some text hello.
blah blah blah.

UUE (test.txt)
this is a test

mailparse_stream_encode
vpopmail
Mailparse İşlevleri


vpopmail

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • vpopmail İşlevleri
    • vpopmail_add_alias_domain_ex — Mevcut bir sanal alana takma ad ekler.
    • vpopmail_add_alias_domain — Bir sanal alan için bir takma ad ekler
    • vpopmail_add_domain_ex — Yeni bir sanal alan adı ekler
    • vpopmail_add_domain — Yeni bir sanal alan adı ekler
    • vpopmail_add_user — Belirtilen sanal alana yeni bir kullanıcı ekler
    • vpopmail_alias_add — Bir sanal takma ad ekler
    • vpopmail_alias_del_domain — Bir alan adının tüm sanal takma adlarını siler
    • vpopmail_alias_del — Bir kullanıcının tüm sanal takma adlarını siler
    • vpopmail_alias_get_all — Bir alan adı için bir takma adın tüm satırlarını döndürür
    • vpopmail_alias_get — Bir alan adı için bir rumuzun tüm satırlarını döndürür
    • vpopmail_auth_user — Bir kullanıcı/alan/parolayı doğrulatmaya çalışır.
    • vpopmail_del_domain_ex — Bir sanal alanı siler
    • vpopmail_del_domain — Bir sanal alanı siler
    • vpopmail_del_user — Sanal alandan belirtilen kullanıcıyı siler
    • vpopmail_error — Son vpopmail hatasının iletisini döndürür
    • vpopmail_passwd — Bir sanal kullanıcının parolasını değiştirir
    • vpopmail_set_user_quota — Bir sanal kullanıcıya kota koyar
mailparse_uudecode_all
Giriş
Postayla İlgili Eklentiler


Giriş

Uyarı

Bu eklenti DENEYSELDİR. Bu eklentinin davranışı, işlev isimleri ve tüm belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu eklentiyi kullanmayın.

Bu eklenti PHP 4.3.0'dan beri » PECL eklentilerinden biridir.

vpopmail
Yapılandırma/Kurulum
vpopmail


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
vpopmail


Kurulum

Bu » PECL eklentisi PHP ile gelmez.

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/vpopmail.

Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
vpopmail İşlevleri
vpopmail


vpopmail İşlevleri

İçindekiler

  • vpopmail_add_alias_domain_ex — Mevcut bir sanal alana takma ad ekler.
  • vpopmail_add_alias_domain — Bir sanal alan için bir takma ad ekler
  • vpopmail_add_domain_ex — Yeni bir sanal alan adı ekler
  • vpopmail_add_domain — Yeni bir sanal alan adı ekler
  • vpopmail_add_user — Belirtilen sanal alana yeni bir kullanıcı ekler
  • vpopmail_alias_add — Bir sanal takma ad ekler
  • vpopmail_alias_del_domain — Bir alan adının tüm sanal takma adlarını siler
  • vpopmail_alias_del — Bir kullanıcının tüm sanal takma adlarını siler
  • vpopmail_alias_get_all — Bir alan adı için bir takma adın tüm satırlarını döndürür
  • vpopmail_alias_get — Bir alan adı için bir rumuzun tüm satırlarını döndürür
  • vpopmail_auth_user — Bir kullanıcı/alan/parolayı doğrulatmaya çalışır.
  • vpopmail_del_domain_ex — Bir sanal alanı siler
  • vpopmail_del_domain — Bir sanal alanı siler
  • vpopmail_del_user — Sanal alandan belirtilen kullanıcıyı siler
  • vpopmail_error — Son vpopmail hatasının iletisini döndürür
  • vpopmail_passwd — Bir sanal kullanıcının parolasını değiştirir
  • vpopmail_set_user_quota — Bir sanal kullanıcıya kota koyar
Öntanımlı Sabitler
vpopmail_add_alias_domain_ex
vpopmail


Mevcut bir sanal alana takma ad ekler.

vpopmail İşlevleri
vpopmail_add_alias_domain
vpopmail İşlevleri
PHP Manual

vpopmail_add_alias_domain_ex

(PHP 4 >= 4.0.5, PECL vpopmail >= 0.2)

vpopmail_add_alias_domain_ex — Mevcut bir sanal alana takma ad ekler.

Açıklama

bool vpopmail_add_alias_domain_ex ( string $eski_alan_adı , string $yeni_alan_adı )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

vpopmail İşlevleri
vpopmail_add_alias_domain
vpopmail İşlevleri


Bir sanal alan için bir takma ad ekler

vpopmail_add_alias_domain_ex
vpopmail_add_domain_ex
vpopmail İşlevleri
PHP Manual

vpopmail_add_alias_domain

(PHP 4 >= 4.0.5, PECL vpopmail >= 0.2)

vpopmail_add_alias_domain — Bir sanal alan için bir takma ad ekler

Açıklama

bool vpopmail_add_alias_domain ( string $alan_adı , string $alan_adı_rumuzu )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

vpopmail_add_alias_domain_ex
vpopmail_add_domain_ex
vpopmail İşlevleri


Yeni bir sanal alan adı ekler

vpopmail_add_alias_domain
vpopmail_add_domain
vpopmail İşlevleri
PHP Manual

vpopmail_add_domain_ex

(PHP 4 >= 4.0.5, PECL vpopmail >= 0.2)

vpopmail_add_domain_ex — Yeni bir sanal alan adı ekler

Açıklama

bool vpopmail_add_domain_ex ( string $alan_adı , string $parola [, string $kota [, string $bounce [, bool $apop ]]] )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

vpopmail_add_alias_domain
vpopmail_add_domain
vpopmail İşlevleri


Yeni bir sanal alan adı ekler

vpopmail_add_domain_ex
vpopmail_add_user
vpopmail İşlevleri
PHP Manual

vpopmail_add_domain

(PHP 4 >= 4.0.5, PECL vpopmail >= 0.2)

vpopmail_add_domain — Yeni bir sanal alan adı ekler

Açıklama

bool vpopmail_add_domain ( string $alan_adı , string $dizin , int $uid , int $gid )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

vpopmail_add_domain_ex
vpopmail_add_user
vpopmail İşlevleri


Belirtilen sanal alana yeni bir kullanıcı ekler

vpopmail_add_domain
vpopmail_alias_add
vpopmail İşlevleri
PHP Manual

vpopmail_add_user

(PHP 4 >= 4.0.5, PECL vpopmail >= 0.2)

vpopmail_add_user — Belirtilen sanal alana yeni bir kullanıcı ekler

Açıklama

bool vpopmail_add_user ( string $kullanıcı , string $alan_adı , string $parola [, string $gecos [, bool $apop ]] )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

vpopmail_add_domain
vpopmail_alias_add
vpopmail İşlevleri


Bir sanal takma ad ekler

vpopmail_add_user
vpopmail_alias_del_domain
vpopmail İşlevleri
PHP Manual

vpopmail_alias_add

(PHP 4 >= 4.0.7, PECL vpopmail >= 0.2)

vpopmail_alias_add — Bir sanal takma ad ekler

Açıklama

bool vpopmail_alias_add ( string $kullanıcı , string $alan_adı , string $takma_ad )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

vpopmail_add_user
vpopmail_alias_del_domain
vpopmail İşlevleri


Bir alan adının tüm sanal takma adlarını siler

vpopmail_alias_add
vpopmail_alias_del
vpopmail İşlevleri
PHP Manual

vpopmail_alias_del_domain

(PHP 4 >= 4.0.7, PECL vpopmail >= 0.2)

vpopmail_alias_del_domain — Bir alan adının tüm sanal takma adlarını siler

Açıklama

bool vpopmail_alias_del_domain ( string $alan_adı )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

vpopmail_alias_add
vpopmail_alias_del
vpopmail İşlevleri


Bir kullanıcının tüm sanal takma adlarını siler

vpopmail_alias_del_domain
vpopmail_alias_get_all
vpopmail İşlevleri
PHP Manual

vpopmail_alias_del

(PHP 4 >= 4.0.7, PECL vpopmail >= 0.2)

vpopmail_alias_del — Bir kullanıcının tüm sanal takma adlarını siler

Açıklama

bool vpopmail_alias_del ( string $kullanıcı , string $alan_adı )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

vpopmail_alias_del_domain
vpopmail_alias_get_all
vpopmail İşlevleri


Bir alan adı için bir takma adın tüm satırlarını döndürür

vpopmail_alias_del
vpopmail_alias_get
vpopmail İşlevleri
PHP Manual

vpopmail_alias_get_all

(PHP 4 >= 4.0.7, PECL vpopmail >= 0.2)

vpopmail_alias_get_all — Bir alan adı için bir takma adın tüm satırlarını döndürür

Açıklama

array vpopmail_alias_get_all ( string $alan_adı )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

vpopmail_alias_del
vpopmail_alias_get
vpopmail İşlevleri


Bir alan adı için bir rumuzun tüm satırlarını döndürür

vpopmail_alias_get_all
vpopmail_auth_user
vpopmail İşlevleri
PHP Manual

vpopmail_alias_get

(PHP 4 >= 4.0.7, PECL vpopmail >= 0.2)

vpopmail_alias_get — Bir alan adı için bir rumuzun tüm satırlarını döndürür

Açıklama

array vpopmail_alias_get ( string $takma_ad , string $alan_adı )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

vpopmail_alias_get_all
vpopmail_auth_user
vpopmail İşlevleri


Bir kullanıcı/alan/parolayı doğrulatmaya çalışır.

vpopmail_alias_get
vpopmail_del_domain_ex
vpopmail İşlevleri
PHP Manual

vpopmail_auth_user

(PHP 4 >= 4.0.5, PECL vpopmail >= 0.2)

vpopmail_auth_user — Bir kullanıcı/alan/parolayı doğrulatmaya çalışır.

Açıklama

bool vpopmail_auth_user ( string $kullanıcı , string $alan_adı , string $parola [, string $apop ] )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

vpopmail_alias_get
vpopmail_del_domain_ex
vpopmail İşlevleri


Bir sanal alanı siler

vpopmail_auth_user
vpopmail_del_domain
vpopmail İşlevleri
PHP Manual

vpopmail_del_domain_ex

(PHP 4 >= 4.0.5, PECL vpopmail >= 0.2)

vpopmail_del_domain_ex — Bir sanal alanı siler

Açıklama

bool vpopmail_del_domain_ex ( string $alan_adı )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

vpopmail_auth_user
vpopmail_del_domain
vpopmail İşlevleri


Bir sanal alanı siler

vpopmail_del_domain_ex
vpopmail_del_user
vpopmail İşlevleri
PHP Manual

vpopmail_del_domain

(PHP 4 >= 4.0.5, PECL vpopmail >= 0.2)

vpopmail_del_domain — Bir sanal alanı siler

Açıklama

bool vpopmail_del_domain ( string $alan_adı )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

vpopmail_del_domain_ex
vpopmail_del_user
vpopmail İşlevleri


Sanal alandan belirtilen kullanıcıyı siler

vpopmail_del_domain
vpopmail_error
vpopmail İşlevleri
PHP Manual

vpopmail_del_user

(PHP 4 >= 4.0.5, PECL vpopmail >= 0.2)

vpopmail_del_user — Sanal alandan belirtilen kullanıcıyı siler

Açıklama

bool vpopmail_del_user ( string $kullanıcı , string $alan_adı )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

vpopmail_del_domain
vpopmail_error
vpopmail İşlevleri


Son vpopmail hatasının iletisini döndürür

vpopmail_del_user
vpopmail_passwd
vpopmail İşlevleri
PHP Manual

vpopmail_error

(PHP 4 >= 4.0.5, PECL vpopmail >= 0.2)

vpopmail_error — Son vpopmail hatasının iletisini döndürür

Açıklama

string vpopmail_error ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

vpopmail_del_user
vpopmail_passwd
vpopmail İşlevleri


Bir sanal kullanıcının parolasını değiştirir

vpopmail_error
vpopmail_set_user_quota
vpopmail İşlevleri
PHP Manual

vpopmail_passwd

(PHP 4 >= 4.0.5, PECL vpopmail >= 0.2)

vpopmail_passwd — Bir sanal kullanıcının parolasını değiştirir

Açıklama

bool vpopmail_passwd ( string $kullanıcı , string $alan_adı , string $parola [, bool $apop ] )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

vpopmail_error
vpopmail_set_user_quota
vpopmail İşlevleri


Bir sanal kullanıcıya kota koyar

vpopmail_passwd
Matematiksel Eklentiler
vpopmail İşlevleri
PHP Manual

vpopmail_set_user_quota

(PHP 4 >= 4.0.5, PECL vpopmail >= 0.2)

vpopmail_set_user_quota — Bir sanal kullanıcıya kota koyar

Açıklama

bool vpopmail_set_user_quota ( string $kullanıcı , string $alan_adı , string $kota )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

vpopmail_passwd
Matematiksel Eklentiler
vpopmail İşlevleri


Matematiksel Eklentiler

  • BC Math — BCMath Keyfi Duyarlıklı Matematik
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • BC Math İşlevleri
  • GMP — GNU Multiple Precision
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • GMP İşlevleri
    • GMP — The GMP class
  • Lapack
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Lapack — The Lapack class
    • LapackException — The LapackException class
  • Math — Mathematical Functions
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Math İşlevleri
  • Statistics
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Statistic İşlevleri
  • Trader — Technical Analysis for Traders
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Trader İşlevleri
vpopmail_set_user_quota
BC Math
İşlev Başvuru Kılavuzu


BCMath Keyfi Duyarlıklı Matematik

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • BC Math İşlevleri
    • bcadd — İki keyfi duyarlıklı sayıyı toplar
    • bccomp — İki keyfi duyarlıklı sayıyı karşılaştırır
    • bcdiv — İki keyfi duyarlıklı sayıyı böler
    • bcmod — Keyfi duyarlıklı sayılarda bölme işleminden kalanı bulur
    • bcmul — İki keyfi duyarlıklı sayıyı çarpar
    • bcpow — Keyfi duyarlıklı sayılar için üs alma işlemi yapar
    • bcpowmod — Önce bir keyfi duyarlıklı sayının diğerine göre üs alma işlemini yapar, sonra sonucun modüle göre kalanını bulur
    • bcscale — Bütün bc matematik işlevleri için öntanımlı ölçek değiştirgesini ayarlar
    • bcsqrt — Keyfi duyarlıklı bir sayının karekök alma işlemini yapar
    • bcsub — Keyfi duyarlıklı sayılar arasında çıkartma işlemi yapar
Matematiksel Eklentiler
Giriş
Matematiksel Eklentiler


Giriş

Keyfi duyarlıklı matematik işlemleri için PHP ikilik hesap makinesi işlevleri sağlar. Hesap makinesi herhangi bir boyut ve tamlıkta sayıları destekler, dizge gösterimlerini verebilir.

BC Math
Yapılandırma/Kurulum
BC Math


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
BC Math


Gereksinimler

PHP 4.0.4 sürümünden beri PHP libbcmath ile birlikte paketlenir. Bu eklenti için herhangi bir dış kütüphane kullanmanıza gerek yoktur.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu işlevler, PHP --enable-bcmath ile yapılandırıldı ise erişilebilirdir.

PHP'nin Windows sürümünde bu eklenti yerleşik olarak gelmektedir. Bu işlevleri Windows'ta kullanmak için herhangi bir eklenti kurmanıza gerek yoktur.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

BC matematik yapılandırma seçenekleri
İsim | Öntanımlı değeri | Değişiklik yeri | Değişiklik bilgisi
bcmath.scale | "0" | PHP_INI_ALL |
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

bcmath.scale integer

Bütün bcmath işlevleri için ondalık hane sayısı, ayrıca bcscale() işlevine bakınız.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
BC Math İşlevleri
BC Math


BC Math İşlevleri

İçindekiler

  • bcadd — İki keyfi duyarlıklı sayıyı toplar
  • bccomp — İki keyfi duyarlıklı sayıyı karşılaştırır
  • bcdiv — İki keyfi duyarlıklı sayıyı böler
  • bcmod — Keyfi duyarlıklı sayılarda bölme işleminden kalanı bulur
  • bcmul — İki keyfi duyarlıklı sayıyı çarpar
  • bcpow — Keyfi duyarlıklı sayılar için üs alma işlemi yapar
  • bcpowmod — Önce bir keyfi duyarlıklı sayının diğerine göre üs alma işlemini yapar, sonra sonucun modüle göre kalanını bulur
  • bcscale — Bütün bc matematik işlevleri için öntanımlı ölçek değiştirgesini ayarlar
  • bcsqrt — Keyfi duyarlıklı bir sayının karekök alma işlemini yapar
  • bcsub — Keyfi duyarlıklı sayılar arasında çıkartma işlemi yapar
Öntanımlı Sabitler
bcadd
BC Math


İki keyfi duyarlıklı sayıyı toplar

BC Math İşlevleri
bccomp
BC Math İşlevleri
PHP Manual

bcadd

(PHP 4, PHP 5, PHP 7)

bcadd — İki keyfi duyarlıklı sayıyı toplar

Açıklama

string bcadd ( string $sol_terim , string $sag_terim [, int $olcek ] )

sol_terim ile sag_terim toplamını alır.

Değiştirgeler

sol_terim

Dizge olarak sol terim.

sag_terim

Dizge olarak sağ terim.

bölüntü

Bu seçimlik değiştirge ondalık iminin sağında kaç hane gösterileceğini belirler. Bunu betik genelinde geçerli olacak şekilde atamak için bcscale() işlevini kullanın.

Dönen Değerler

İki terimin toplamını dizge olarak verir.

Örnekler

Örnek 1 bcadd() örneği

<?php

$a = '1.234';
$b = '5';

echo bcadd($a, $b);     // 6
echo bcadd($a, $b, 4);  // 6.2340

?>

Ayrıca Bakınız

  • bcsub() - Keyfi duyarlıklı sayılar arasında çıkartma işlemi yapar

BC Math İşlevleri
bccomp
BC Math İşlevleri


İki keyfi duyarlıklı sayıyı karşılaştırır

bcadd
bcdiv
BC Math İşlevleri
PHP Manual

bccomp

(PHP 4, PHP 5, PHP 7)

bccomp — İki keyfi duyarlıklı sayıyı karşılaştırır

Açıklama

int bccomp ( string $sol_terim , string $sag_terim [, int $olcek ] )

sol_terim ile sag_terim'i karşılaştırır ve sonucu tamsayı olarak geri verir.

Değiştirgeler

sol_terim

Dizge olarak sol terim.

sag_terim

Dizge olarak sağ terim.

olcek

Seçime bağlı olcek değiştirgesi, karşılaştırmada dikkate alınacak ondalık bölümden sonraki hane sayısını ayarlar.

Dönen Değerler

Eğer iki terim eşitse 0 döndürür, sol_terim sag_terim'den büyükse 1, değilse -1 döndürür.

Örnekler

Örnek 1 bccomp() örneği

<?php

echo bccomp('1', '2') . "\n";   // -1
echo bccomp('1.00001', '1', 3); // 0
echo bccomp('1.00001', '1', 5); // 1

?>
bcadd
bcdiv
BC Math İşlevleri


İki keyfi duyarlıklı sayıyı böler

bccomp
bcmod
BC Math İşlevleri
PHP Manual

bcdiv

(PHP 4, PHP 5, PHP 7)

bcdiv — İki keyfi duyarlıklı sayıyı böler

Açıklama

string bcdiv ( string $sol_terim , string $sag_terim [, int $olcek ] )

sol_terim ile sag_terim arasında bölme işlemi yapar.

Değiştirgeler

sol_terim

Dizge olarak sol terim.

sag_terim

Dizge olarak sağ terim.

bölüntü

Bu seçimlik değiştirge ondalık iminin sağında kaç hane gösterileceğini belirler. Bunu betik genelinde geçerli olacak şekilde atamak için bcscale() işlevini kullanın.

Dönen Değerler

Bölme sonucunu dizge olarak hesaplar. Eğer sag_terim 0'sa NULL geri döndürür.

Örnekler

Örnek 1 bcdiv() örneği

<?php

echo bcdiv('105', '6.55957', 3);  // 16.007

?>

Ayrıca Bakınız

  • bcmul() - İki keyfi duyarlıklı sayıyı çarpar

bccomp
bcmod
BC Math İşlevleri


Keyfi duyarlıklı sayılarda bölme işleminden kalanı bulur

bcdiv
bcmul
BC Math İşlevleri
PHP Manual

bcmod

(PHP 4, PHP 5, PHP 7)

bcmod — Keyfi duyarlıklı sayılarda bölme işleminden kalanı bulur

Açıklama

string bcmod ( string $sol_terim , string $modul )

sol_terim'in modul'e bölünmesinden kalanı bulur

Değiştirgeler

sol_terim

Dizge olarak sol terim.

modul

Dizge olarak modül.

Dönen Değerler

Dizge olarak kalanı veya modul 0 ise NULL döndürür.

Örnekler

Örnek 1 bcmod() örneği

<?php
echo bcmod('4', '2'); // 0
echo bcmod('2', '4'); // 2
?>

Ayrıca Bakınız

  • bcdiv() - İki keyfi duyarlıklı sayıyı böler

bcdiv
bcmul
BC Math İşlevleri


İki keyfi duyarlıklı sayıyı çarpar

bcmod
bcpow
BC Math İşlevleri
PHP Manual

bcmul

(PHP 4, PHP 5, PHP 7)

bcmul — İki keyfi duyarlıklı sayıyı çarpar

Açıklama

string bcmul ( string $sol_terim , string $sag_terim [, int $olcek ] )

sol_terim ile sag_terim'i çarpar.

Değiştirgeler

sol_terim

Dizge olarak sol terim.

sag_terim

Dizge olarak sağ terim.

bölüntü

Bu seçimlik değiştirge ondalık iminin sağında kaç hane gösterileceğini belirler. Bunu betik genelinde geçerli olacak şekilde atamak için bcscale() işlevini kullanın.

Dönen Değerler

Sonucu dizge olarak döndürür.

Örnekler

Örnek 1 bcmul() örneği

<?php
echo bcmul('1.34747474747', '35', 3); // 47.161
echo bcmul('2', '4'); // 8
?>

Ayrıca Bakınız

  • bcdiv() - İki keyfi duyarlıklı sayıyı böler

bcmod
bcpow
BC Math İşlevleri


Keyfi duyarlıklı sayılar için üs alma işlemi yapar

bcmul
bcpowmod
BC Math İşlevleri
PHP Manual

bcpow

(PHP 4, PHP 5, PHP 7)

bcpow — Keyfi duyarlıklı sayılar için üs alma işlemi yapar

Açıklama

string bcpow ( string $sol_terim , string $sag_terim [, int $olcek ] )

sol_terim'in sag_terim'e göre üs alma işlemini yapar.

Değiştirgeler

sol_terim

Dizge olarak sol terim.

sag_terim

Dizge olarak sağ terim.

bölüntü

Bu seçimlik değiştirge ondalık iminin sağında kaç hane gösterileceğini belirler. Bunu betik genelinde geçerli olacak şekilde atamak için bcscale() işlevini kullanın.

Dönen Değerler

Sonucu dizge olarak döndürür.

Örnekler

Örnek 1 bcpow() örneği

<?php

echo bcpow('4.2', '3', 2); // 74.08

?>

Ayrıca Bakınız

  • bcpowmod() - Önce bir keyfi duyarlıklı sayının diğerine göre üs alma işlemini yapar, sonra sonucun modüle göre kalanını bulur
  • bcsqrt() - Keyfi duyarlıklı bir sayının karekök alma işlemini yapar

bcmul
bcpowmod
BC Math İşlevleri


Önce bir keyfi duyarlıklı sayının diğerine göre üs alma işlemini yapar, sonra sonucun modüle göre kalanını bulur

bcpow
bcscale
BC Math İşlevleri
PHP Manual

bcpowmod

(PHP 5, PHP 7)

bcpowmod — Önce bir keyfi duyarlıklı sayının diğerine göre üs alma işlemini yapar, sonra sonucun modüle göre kalanını bulur

Açıklama

string bcpowmod ( string $sol_terim , string $sag_terim , string $modul [, int $olcek ] )

sol_terim'in sag_terim'e göre üssünü bulur, sonucun modul ile kalanını bulur.

Değiştirgeler

sol_terim

Dizge olarak sol terim.

sag_terim

Dizge olarak sağ terim.

modul

Dizge olarak modül.

bölüntü

Bu seçimlik değiştirge ondalık iminin sağında kaç hane gösterileceğini belirler. Bunu betik genelinde geçerli olacak şekilde atamak için bcscale() işlevini kullanın.

Dönen Değerler

Dizge olarak sonucu veya modul 0 ise NULL döndürür.

Notlar

Bilginize:

Bu işlev kalan bulma işlemleri yaptığı için doğal olmayan sayılar beklenmeyen sonuçlar verebilir. Doğal sayı 0 olmayan herhangi bir pozitif tamsayıdır.

Örnekler

Örnekteki 2 deyim denktir. Bununla birlikte bcpowmod() deyimi daha az zamanda sonuç verir ve daha büyük değiştirgeleri kabul eder.

<?php
$a = bcpowmod($x, $y, $mod);

$b = bcmod(bcpow($x, $y), $mod);

// $a ve $b sonuclari esittir.

?>

Ayrıca Bakınız

  • bcpow() - Keyfi duyarlıklı sayılar için üs alma işlemi yapar
  • bcmod() - Keyfi duyarlıklı sayılarda bölme işleminden kalanı bulur

bcpow
bcscale
BC Math İşlevleri


Bütün bc matematik işlevleri için öntanımlı ölçek değiştirgesini ayarlar

bcpowmod
bcsqrt
BC Math İşlevleri
PHP Manual

bcscale

(PHP 4, PHP 5, PHP 7)

bcscale — Bütün bc matematik işlevleri için öntanımlı ölçek değiştirgesini ayarlar

Açıklama

bool bcscale ( int $olcek )

Sonradan bir ölçek belirtilmeden çağrılan bütün bc matematik işlevleri için öntanımlı ölçek değiştirgesini ayarlar.

Değiştirgeler

olcek

Ölçek katsayısı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 bcscale() örneği

<?php

// ontanimli olcek : 3
bcscale(3);
echo bcdiv('105', '6.55957'); // 16.007

// bcscale() cagrilmamasi ile esdegerdir
echo bcdiv('105', '6.55957', 3); // 16.007

?>

bcpowmod
bcsqrt
BC Math İşlevleri


Keyfi duyarlıklı bir sayının karekök alma işlemini yapar

bcscale
bcsub
BC Math İşlevleri
PHP Manual

bcsqrt

(PHP 4, PHP 5, PHP 7)

bcsqrt — Keyfi duyarlıklı bir sayının karekök alma işlemini yapar

Açıklama

string bcsqrt ( string $terim [, int $olcek ] )

terim'in karekökünü döndürür.

Değiştirgeler

terim

Dizge olarak terim.

bölüntü

Bu seçimlik değiştirge ondalık iminin sağında kaç hane gösterileceğini belirler. Bunu betik genelinde geçerli olacak şekilde atamak için bcscale() işlevini kullanın.

Dönen Değerler

Dizge olarak karekökü veya terim negatifse NULL döndürür.

Örnekler

Örnek 1 bcsqrt() örneği

<?php

echo bcsqrt('2', 3); // 1.414

?>

Ayrıca Bakınız

  • bcpow() - Keyfi duyarlıklı sayılar için üs alma işlemi yapar

bcscale
bcsub
BC Math İşlevleri


Keyfi duyarlıklı sayılar arasında çıkartma işlemi yapar

bcsqrt
GMP
BC Math İşlevleri
PHP Manual

bcsub

(PHP 4, PHP 5, PHP 7)

bcsub — Keyfi duyarlıklı sayılar arasında çıkartma işlemi yapar

Açıklama

string bcsub ( string $sol_terim , string $sag_terim [, int $olcek ] )

sol_terim'den sag_terim'i çıkartır.

Değiştirgeler

sol_terim

Dizge olarak sol terim.

sag_terim

Dizge olarak sağ terim

bölüntü

Bu seçimlik değiştirge ondalık iminin sağında kaç hane gösterileceğini belirler. Bunu betik genelinde geçerli olacak şekilde atamak için bcscale() işlevini kullanın.

Dönen Değerler

Dizge olarak çıkartma sonucunu verir.

Örnekler

Örnek 1 bcsub() örneği

<?php

$a = '1.234';
$b = '5';

echo bcsub($a, $b);     // -3
echo bcsub($a, $b, 4);  // -3.7660

?>

Ayrıca Bakınız

  • bcadd() - İki keyfi duyarlıklı sayıyı toplar

bcsqrt
GMP
BC Math İşlevleri


GNU Multiple Precision

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
  • GMP İşlevleri
    • gmp_abs — Absolute value
    • gmp_add — Add numbers
    • gmp_and — Bitwise AND
    • gmp_clrbit — Clear bit
    • gmp_cmp — Compare numbers
    • gmp_com — Calculates one's complement
    • gmp_div_q — Divide numbers
    • gmp_div_qr — Divide numbers and get quotient and remainder
    • gmp_div_r — Remainder of the division of numbers
    • gmp_div — Takma Adı: gmp_div_q
    • gmp_divexact — Exact division of numbers
    • gmp_export — Export to a binary string
    • gmp_fact — Factorial
    • gmp_gcd — Calculate GCD
    • gmp_gcdext — Calculate GCD and multipliers
    • gmp_hamdist — Hamming distance
    • gmp_import — Import from a binary string
    • gmp_init — Create GMP number
    • gmp_intval — Convert GMP number to integer
    • gmp_invert — Inverse by modulo
    • gmp_jacobi — Jacobi symbol
    • gmp_legendre — Legendre symbol
    • gmp_mod — Modulo operation
    • gmp_mul — Multiply numbers
    • gmp_neg — Negate number
    • gmp_nextprime — Find next prime number
    • gmp_or — Bitwise OR
    • gmp_perfect_square — Perfect square check
    • gmp_popcount — Population count
    • gmp_pow — Raise number into power
    • gmp_powm — Raise number into power with modulo
    • gmp_prob_prime — Check if number is "probably prime"
    • gmp_random_bits — Random number
    • gmp_random_range — Random number
    • gmp_random_seed — Sets the RNG seed
    • gmp_random — Random number
    • gmp_root — Take the integer part of nth root
    • gmp_rootrem — Take the integer part and remainder of nth root
    • gmp_scan0 — Scan for 0
    • gmp_scan1 — Scan for 1
    • gmp_setbit — Set bit
    • gmp_sign — Sign of number
    • gmp_sqrt — Calculate square root
    • gmp_sqrtrem — Square root with remainder
    • gmp_strval — Convert GMP number to string
    • gmp_sub — Subtract numbers
    • gmp_testbit — Tests if a bit is set
    • gmp_xor — Bitwise XOR
  • GMP — The GMP class
bcsub
Giriş
Matematiksel Eklentiler


Giriş

These functions allow for arbitrary-length integers to be worked with using the GNU MP library.

Bilginize:

Most GMP functions accept GMP number arguments. These are shown in this documentation as GMP objects. However, note that PHP 5.5 and earlier represented GMP numbers as resources. Most of these functions will also accept numeric and string arguments, so long as it is possible to convert the latter to a number. Also, if there is a more performant function that can operate on the arguments (integers only), then it will be used instead (this is done transparently). See also the gmp_init() function.

Bilginize:

From PHP 5.6 onwards, the arithmetic, bitwise, and comparison operators may be used with the GMP objects returned from gmp_init() and other GMP functions.

Uyarı

Large integers must be specified as strings - otherwise, PHP will coerce them to floats, resulting in a loss of precision.

Bilginize: This extension is available on Windows platforms since PHP 5.1.0.

GMP
Yapılandırma/Kurulum
GMP


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
GMP


Gereksinimler

The GMP library can be downloaded from » http://gmplib.org/#DOWNLOAD. This site also has the GMP manual available.

At least GMP version 2 is required, with some functions requiring a more recent version of the GMP library.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

In order to have these functions available, PHP must be compiled with GMP support by using the --with-gmp option.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Özkaynak Türleri

Prior to PHP 5.6, most GMP functions operate on or return GMP number resources. PHP 5.6 onwards uses GMP objects in place of GMP number resources.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

GMP_ROUND_ZERO (integer)
GMP_ROUND_PLUSINF (integer)
GMP_ROUND_MINUSINF (integer)
GMP_MSW_FIRST (integer)
GMP_LSW_FIRST (integer)
GMP_LITTLE_ENDIAN (integer)
GMP_BIG_ENDIAN (integer)
GMP_NATIVE_ENDIAN (integer)
GMP_VERSION (string)
The GMP library version
Özkaynak Türleri
Örnekler
GMP


Örnekler

Örnek 1 Factorial function using GMP

<?php
function fact($x)
{
    $return = 1;
    for ($i=2; $i <= $x; $i++) {
        $return = gmp_mul($return, $i);
    }
    return $return;
}

echo gmp_strval(fact(1000)) . "\n";
?>

This will calculate factorial of 1000 (pretty big number) very fast.

Öntanımlı Sabitler
GMP İşlevleri
GMP


GMP İşlevleri

Ayrıca Bakınız

More mathematical functions can be found in the Matematiksel Eklentiler section

İçindekiler

  • gmp_abs — Absolute value
  • gmp_add — Add numbers
  • gmp_and — Bitwise AND
  • gmp_clrbit — Clear bit
  • gmp_cmp — Compare numbers
  • gmp_com — Calculates one's complement
  • gmp_div_q — Divide numbers
  • gmp_div_qr — Divide numbers and get quotient and remainder
  • gmp_div_r — Remainder of the division of numbers
  • gmp_div — Takma Adı: gmp_div_q
  • gmp_divexact — Exact division of numbers
  • gmp_export — Export to a binary string
  • gmp_fact — Factorial
  • gmp_gcd — Calculate GCD
  • gmp_gcdext — Calculate GCD and multipliers
  • gmp_hamdist — Hamming distance
  • gmp_import — Import from a binary string
  • gmp_init — Create GMP number
  • gmp_intval — Convert GMP number to integer
  • gmp_invert — Inverse by modulo
  • gmp_jacobi — Jacobi symbol
  • gmp_legendre — Legendre symbol
  • gmp_mod — Modulo operation
  • gmp_mul — Multiply numbers
  • gmp_neg — Negate number
  • gmp_nextprime — Find next prime number
  • gmp_or — Bitwise OR
  • gmp_perfect_square — Perfect square check
  • gmp_popcount — Population count
  • gmp_pow — Raise number into power
  • gmp_powm — Raise number into power with modulo
  • gmp_prob_prime — Check if number is "probably prime"
  • gmp_random_bits — Random number
  • gmp_random_range — Random number
  • gmp_random_seed — Sets the RNG seed
  • gmp_random — Random number
  • gmp_root — Take the integer part of nth root
  • gmp_rootrem — Take the integer part and remainder of nth root
  • gmp_scan0 — Scan for 0
  • gmp_scan1 — Scan for 1
  • gmp_setbit — Set bit
  • gmp_sign — Sign of number
  • gmp_sqrt — Calculate square root
  • gmp_sqrtrem — Square root with remainder
  • gmp_strval — Convert GMP number to string
  • gmp_sub — Subtract numbers
  • gmp_testbit — Tests if a bit is set
  • gmp_xor — Bitwise XOR
Örnekler
gmp_abs
GMP


Absolute value

GMP İşlevleri
gmp_add
GMP İşlevleri
PHP Manual

gmp_abs

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gmp_abs — Absolute value

Açıklama

GMP gmp_abs ( GMP $a )

Get the absolute value of a number.

Değiştirgeler

a

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

Dönen Değerler

Returns the absolute value of a, as a GMP number.

Örnekler

Örnek 1 gmp_abs() example

<?php
$abs1 = gmp_abs("274982683358");
$abs2 = gmp_abs("-274982683358");

echo gmp_strval($abs1) . "\n";
echo gmp_strval($abs2) . "\n";
?>

Yukarıdaki örneğin çıktısı:

274982683358
274982683358

GMP İşlevleri
gmp_add
GMP İşlevleri


Add numbers

gmp_abs
gmp_and
GMP İşlevleri
PHP Manual

gmp_add

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gmp_add — Add numbers

Açıklama

GMP gmp_add ( GMP $a , GMP $b )

Add two numbers.

Değiştirgeler

a

The first summand (augent).

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

b

The second summand (addend).

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

Dönen Değerler

A GMP number representing the sum of the arguments.

Örnekler

Örnek 1 gmp_add() example

<?php
$sum = gmp_add("123456789012345", "76543210987655");
echo gmp_strval($sum) . "\n";
?>

Yukarıdaki örneğin çıktısı:

200000000000000

gmp_abs
gmp_and
GMP İşlevleri


Bitwise AND

gmp_add
gmp_clrbit
GMP İşlevleri
PHP Manual

gmp_and

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gmp_and — Bitwise AND

Açıklama

GMP gmp_and ( GMP $a , GMP $b )

Calculates bitwise AND of two GMP numbers.

Değiştirgeler

a

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

b

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

Dönen Değerler

A GMP number representing the bitwise AND comparison.

Örnekler

Örnek 1 gmp_and() example

<?php
$and1 = gmp_and("0xfffffffff4", "0x4");
$and2 = gmp_and("0xfffffffff4", "0x8");
echo gmp_strval($and1) . "\n";
echo gmp_strval($and2) . "\n";
?>

Yukarıdaki örneğin çıktısı:

4
0
gmp_add
gmp_clrbit
GMP İşlevleri


Clear bit

gmp_and
gmp_cmp
GMP İşlevleri
PHP Manual

gmp_clrbit

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gmp_clrbit — Clear bit

Açıklama

void gmp_clrbit ( GMP $a , int $index )

Clears (sets to 0) bit index in a. The index starts at 0.

Değiştirgeler

a

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

index

The index of the bit to clear. Index 0 represents the least significant bit.

Dönen Değerler

A GMP number resource in PHP 5.5 and earlier, or a GMP object in PHP 5.6 and later.

Örnekler

Örnek 1 gmp_clrbit() example

<?php
$a = gmp_init("0xff");
gmp_clrbit($a, 0); // index starts at 0, least significant bit
echo gmp_strval($a) . "\n";
?>

Yukarıdaki örneğin çıktısı:

254

Notlar

Bilginize:

Unlike most of the other GMP functions, gmp_clrbit() must be called with a GMP resource that already exists (using gmp_init() for example). One will not be automatically created.

Ayrıca Bakınız

  • gmp_setbit() - Set bit
  • gmp_testbit() - Tests if a bit is set

gmp_and
gmp_cmp
GMP İşlevleri


Compare numbers

gmp_clrbit
gmp_com
GMP İşlevleri
PHP Manual

gmp_cmp

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gmp_cmp — Compare numbers

Açıklama

int gmp_cmp ( GMP $a , GMP $b )

Compares two numbers.

Değiştirgeler

a

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

b

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

Dönen Değerler

Returns a positive value if a > b, zero if a = b and a negative value if a < b.

Örnekler

Örnek 1 gmp_cmp() example

<?php
$cmp1 = gmp_cmp("1234", "1000"); // greater than
$cmp2 = gmp_cmp("1000", "1234"); // less than
$cmp3 = gmp_cmp("1234", "1234"); // equal to

echo "$cmp1 $cmp2 $cmp3\n";
?>

Yukarıdaki örneğin çıktısı:

1 -1 0
gmp_clrbit
gmp_com
GMP İşlevleri


Calculates one's complement

gmp_cmp
gmp_div_q
GMP İşlevleri
PHP Manual

gmp_com

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gmp_com — Calculates one's complement

Açıklama

GMP gmp_com ( GMP $a )

Returns the one's complement of a.

Değiştirgeler

a

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

Dönen Değerler

Returns the one's complement of a, as a GMP number.

Örnekler

Örnek 1 gmp_com() example

<?php
$com = gmp_com("1234");
echo gmp_strval($com) . "\n";
?>

Yukarıdaki örneğin çıktısı:

-1235
gmp_cmp
gmp_div_q
GMP İşlevleri


Divide numbers

gmp_com
gmp_div_qr
GMP İşlevleri
PHP Manual

gmp_div_q

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gmp_div_q — Divide numbers

Açıklama

GMP gmp_div_q ( GMP $a , GMP $b [, int $round = GMP_ROUND_ZERO ] )

Divides a by b and returns the integer result.

Değiştirgeler

a

The number being divided.

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

b

The number that a is being divided by.

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

round

The result rounding is defined by the round, which can have the following values:

  • GMP_ROUND_ZERO: The result is truncated towards 0.
  • GMP_ROUND_PLUSINF: The result is rounded towards +infinity.
  • GMP_ROUND_MINUSINF: The result is rounded towards -infinity.

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

Dönen Değerler

A GMP number resource in PHP 5.5 and earlier, or a GMP object in PHP 5.6 and later.

Örnekler

Örnek 1 gmp_div_q() example

<?php
$div1 = gmp_div_q("100", "5");
echo gmp_strval($div1) . "\n";

$div2 = gmp_div_q("1", "3");
echo gmp_strval($div2) . "\n";

$div3 = gmp_div_q("1", "3", GMP_ROUND_PLUSINF);
echo gmp_strval($div3) . "\n";

$div4 = gmp_div_q("-1", "4", GMP_ROUND_PLUSINF);
echo gmp_strval($div4) . "\n";

$div5 = gmp_div_q("-1", "4", GMP_ROUND_MINUSINF);
echo gmp_strval($div5) . "\n";
?>

Yukarıdaki örneğin çıktısı:

20
0
1
0
-1

Notlar

Bilginize:

This function can also be called as gmp_div().

Ayrıca Bakınız

  • gmp_div_r() - Remainder of the division of numbers
  • gmp_div_qr() - Divide numbers and get quotient and remainder

gmp_com
gmp_div_qr
GMP İşlevleri


Divide numbers and get quotient and remainder

gmp_div_q
gmp_div_r
GMP İşlevleri
PHP Manual

gmp_div_qr

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gmp_div_qr — Divide numbers and get quotient and remainder

Açıklama

array gmp_div_qr ( GMP $n , GMP $d [, int $round = GMP_ROUND_ZERO ] )

The function divides n by d.

Değiştirgeler

n

The number being divided.

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

d

The number that n is being divided by.

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

round

See the gmp_div_q() function for description of the round argument.

Dönen Değerler

Returns an array, with the first element being [n/d] (the integer result of the division) and the second being (n - [n/d] * d) (the remainder of the division).

Örnekler

Örnek 1 Division of GMP numbers

<?php
$a = gmp_init("0x41682179fbf5");
$res = gmp_div_qr($a, "0xDEFE75");
printf("Result is: q - %s, r - %s",
       gmp_strval($res[0]), gmp_strval($res[1]));
?>

Ayrıca Bakınız

  • gmp_div_q() - Divide numbers
  • gmp_div_r() - Remainder of the division of numbers

gmp_div_q
gmp_div_r
GMP İşlevleri


Remainder of the division of numbers

gmp_div_qr
gmp_div
GMP İşlevleri
PHP Manual

gmp_div_r

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gmp_div_r — Remainder of the division of numbers

Açıklama

GMP gmp_div_r ( GMP $n , GMP $d [, int $round = GMP_ROUND_ZERO ] )

Calculates remainder of the integer division of n by d. The remainder has the sign of the n argument, if not zero.

Değiştirgeler

n

The number being divided.

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

d

The number that n is being divided by.

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

round

See the gmp_div_q() function for description of the round argument.

Dönen Değerler

The remainder, as a GMP number.

Örnekler

Örnek 1 gmp_div_r() example

<?php
$div = gmp_div_r("105", "20");
echo gmp_strval($div) . "\n";
?>

Yukarıdaki örneğin çıktısı:

5

Ayrıca Bakınız

  • gmp_div_q() - Divide numbers
  • gmp_div_qr() - Divide numbers and get quotient and remainder

gmp_div_qr
gmp_div
GMP İşlevleri


Takma Adı: gmp_div_q

gmp_div_r
gmp_divexact
GMP İşlevleri
PHP Manual

gmp_div

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gmp_div — Takma Adı: gmp_div_q()

Açıklama

Bu işlev şu işlevin takma adıdır: gmp_div_q().

gmp_div_r
gmp_divexact
GMP İşlevleri


Exact division of numbers

gmp_div
gmp_export
GMP İşlevleri
PHP Manual

gmp_divexact

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gmp_divexact — Exact division of numbers

Açıklama

GMP gmp_divexact ( GMP $n , GMP $d )

Divides n by d, using fast "exact division" algorithm. This function produces correct results only when it is known in advance that d divides n.

Değiştirgeler

n

The number being divided.

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

d

The number that a is being divided by.

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

Dönen Değerler

A GMP number resource in PHP 5.5 and earlier, or a GMP object in PHP 5.6 and later.

Örnekler

Örnek 1 gmp_divexact() example

<?php
$div1 = gmp_divexact("10", "2");
echo gmp_strval($div1) . "\n";

$div2 = gmp_divexact("10", "3"); // bogus result
echo gmp_strval($div2) . "\n";
?>

Yukarıdaki örneğin çıktısı:

5
2863311534

gmp_div
gmp_export
GMP İşlevleri


Export to a binary string

gmp_divexact
gmp_fact
GMP İşlevleri
PHP Manual

gmp_export

(PHP 5 >= 5.6.1, PHP 7)

gmp_export — Export to a binary string

Açıklama

string gmp_export ( GMP $gmpnumber , integer $word_size , integer $options )

Export a GMP number to a binary string

Değiştirgeler

gmpnumber

The GMP number being exported

word_size

Default value is 1. The number of bytes in each chunk of binary data. This is mainly used in conjunction with the options parameter.

options

Default value is GMP_MSW_FIRST | GMP_NATIVE_ENDIAN.

Dönen Değerler

Returns a string başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 gmp_export() example

<?php
$number = gmp_init(16705);
echo gmp_export($number) . "\n";
?>

Yukarıdaki örneğin çıktısı:

AA

gmp_divexact
gmp_fact
GMP İşlevleri


Factorial

gmp_export
gmp_gcd
GMP İşlevleri
PHP Manual

gmp_fact

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gmp_fact — Factorial

Açıklama

GMP gmp_fact ( mixed $a )

Calculates factorial (a!) of a.

Değiştirgeler

a

The factorial number.

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

Dönen Değerler

A GMP number resource in PHP 5.5 and earlier, or a GMP object in PHP 5.6 and later.

Örnekler

Örnek 1 gmp_fact() example

<?php
$fact1 = gmp_fact(5); // 5 * 4 * 3 * 2 * 1
echo gmp_strval($fact1) . "\n";

$fact2 = gmp_fact(50); // 50 * 49 * 48, ... etc
echo gmp_strval($fact2) . "\n";
?>

Yukarıdaki örneğin çıktısı:

120
30414093201713378043612608166064768844377641568960512000000000000

gmp_export
gmp_gcd
GMP İşlevleri


Calculate GCD

gmp_fact
gmp_gcdext
GMP İşlevleri
PHP Manual

gmp_gcd

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gmp_gcd — Calculate GCD

Açıklama

GMP gmp_gcd ( GMP $a , GMP $b )

Calculate greatest common divisor of a and b. The result is always positive even if either of, or both, input operands are negative.

Değiştirgeler

a

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

b

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

Dönen Değerler

A positive GMP number that divides into both a and b.

Örnekler

Örnek 1 gmp_gcd() example

<?php
$gcd = gmp_gcd("12", "21");
echo gmp_strval($gcd) . "\n";
?>

Yukarıdaki örneğin çıktısı:

3

gmp_fact
gmp_gcdext
GMP İşlevleri


Calculate GCD and multipliers

gmp_gcd
gmp_hamdist
GMP İşlevleri
PHP Manual

gmp_gcdext

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gmp_gcdext — Calculate GCD and multipliers

Açıklama

array gmp_gcdext ( GMP $a , GMP $b )

Calculates g, s, and t, such that a*s + b*t = g = gcd(a,b), where gcd is the greatest common divisor. Returns an array with respective elements g, s and t.

This function can be used to solve linear Diophantine equations in two variables. These are equations that allow only integer solutions and have the form: a*x + b*y = c. For more information, go to the » "Diophantine Equation" page at MathWorld

Değiştirgeler

a

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

b

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

Dönen Değerler

An array of GMP numbers.

Örnekler

Örnek 1 Solving a linear Diophantine equation

<?php
// Solve the equation a*s + b*t = g
// where a = 12, b = 21, g = gcd(12, 21) = 3
$a = gmp_init(12);
$b = gmp_init(21);
$g = gmp_gcd($a, $b);
$r = gmp_gcdext($a, $b);

$check_gcd = (gmp_strval($g) == gmp_strval($r['g']));
$eq_res = gmp_add(gmp_mul($a, $r['s']), gmp_mul($b, $r['t']));
$check_res = (gmp_strval($g) == gmp_strval($eq_res));

if ($check_gcd && $check_res) {
    $fmt = "Solution: %d*%d + %d*%d = %d\n";
    printf($fmt, gmp_strval($a), gmp_strval($r['s']), gmp_strval($b),
    gmp_strval($r['t']), gmp_strval($r['g']));
} else {
    echo "Error while solving the equation\n";
}

// output: Solution: 12*2 + 21*-1 = 3
?>

gmp_gcd
gmp_hamdist
GMP İşlevleri


Hamming distance

gmp_gcdext
gmp_import
GMP İşlevleri
PHP Manual

gmp_hamdist

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gmp_hamdist — Hamming distance

Açıklama

int gmp_hamdist ( GMP $a , GMP $b )

Returns the hamming distance between a and b. Both operands should be non-negative.

Değiştirgeler

a

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

It should be positive.

b

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

It should be positive.

Dönen Değerler

A GMP number resource in PHP 5.5 and earlier, or a GMP object in PHP 5.6 and later.

Örnekler

Örnek 1 gmp_hamdist() example

<?php
$ham1 = gmp_init("1001010011", 2);
$ham2 = gmp_init("1011111100", 2);
echo gmp_hamdist($ham1, $ham2) . "\n";

/* hamdist is equivalent to: */
echo gmp_popcount(gmp_xor($ham1, $ham2)) . "\n";
?>

Yukarıdaki örneğin çıktısı:

6
6

Ayrıca Bakınız

  • gmp_popcount() - Population count
  • gmp_xor() - Bitwise XOR

gmp_gcdext
gmp_import
GMP İşlevleri


Import from a binary string

gmp_hamdist
gmp_init
GMP İşlevleri
PHP Manual

gmp_import

(PHP 5 >= 5.6.1, PHP 7)

gmp_import — Import from a binary string

Açıklama

GMP gmp_import ( string $data , integer $word_size , integer $options )

Import a GMP number from a binary string

Değiştirgeler

data

The binary string being imported

word_size

Default value is 1. The number of bytes in each chunk of binary data. This is mainly used in conjunction with the options parameter.

options

Default value is GMP_MSW_FIRST | GMP_NATIVE_ENDIAN.

Dönen Değerler

Returns a GMP number başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 gmp_import() example

<?php
$number = gmp_import("\0");
echo gmp_strval($number) . "\n";

$number = gmp_import("\0\1\2");
echo gmp_strval($number) . "\n";
?>

Yukarıdaki örneğin çıktısı:

0
258

gmp_hamdist
gmp_init
GMP İşlevleri


Create GMP number

gmp_import
gmp_intval
GMP İşlevleri
PHP Manual

gmp_init

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gmp_init — Create GMP number

Açıklama

GMP gmp_init ( mixed $number [, int $base = 0 ] )

Creates a GMP number from an integer or string.

Değiştirgeler

number

An integer or a string. The string representation can be decimal, hexadecimal or octal.

base

The base.

The base may vary from 2 to 36. If base is 0 (default value), the actual base is determined from the leading characters: if the first two characters are 0x or 0X, hexadecimal is assumed, otherwise if the first character is "0", octal is assumed, otherwise decimal is assumed.

Dönen Değerler

A GMP number resource in PHP 5.5 and earlier, or a GMP object in PHP 5.6 and later.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.2 | The base was extended from 2 to 36, to 2 to 62 and -2 to -36.

Notlar

Bilginize:

To use the extended base introduced in PHP 5.3.2, then PHP must be compiled against GMP 4.2.0 or greater.

Örnekler

Örnek 1 Creating GMP number

<?php
$a = gmp_init(123456);
$b = gmp_init("0xFFFFDEBACDFEDF7200");
?>

Notlar

Bilginize:

It is not necessary to call this function in order to use integers or strings in place of GMP numbers in GMP functions (such as with gmp_add()). Function arguments are automatically converted to GMP numbers, if such conversion is possible and needed, using the same rules as gmp_init().

gmp_import
gmp_intval
GMP İşlevleri


Convert GMP number to integer

gmp_init
gmp_invert
GMP İşlevleri
PHP Manual

gmp_intval

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gmp_intval — Convert GMP number to integer

Açıklama

int gmp_intval ( GMP $gmpnumber )

This function converts GMP number into native PHP integers.

Değiştirgeler

gmpnumber

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

Dönen Değerler

The integer value of gmpnumber.

Örnekler

Örnek 1 gmp_intval() example

<?php
// displays correct result
echo gmp_intval("2147483647") . "\n";

// displays wrong result, above PHP integer limit
echo gmp_intval("2147483648") . "\n";

// displays correct result
echo gmp_strval("2147483648") . "\n";
?>

Yukarıdaki örneğin çıktısı:

2147483647
2147483647
2147483648

Notlar

Uyarı

This function returns a useful result only if the number actually fits the PHP integer (i.e., signed long type). To simply print the GMP number, use gmp_strval().

gmp_init
gmp_invert
GMP İşlevleri


Inverse by modulo

gmp_intval
gmp_jacobi
GMP İşlevleri
PHP Manual

gmp_invert

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gmp_invert — Inverse by modulo

Açıklama

GMP gmp_invert ( GMP $a , GMP $b )

Computes the inverse of a modulo b.

Değiştirgeler

a

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

b

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

Dönen Değerler

A GMP number on success or FALSE if an inverse does not exist.

Örnekler

Örnek 1 gmp_invert() example

<?php
echo gmp_invert("5", "10"); // no inverse, outputs nothing, result is FALSE
$invert = gmp_invert("5", "11");
echo gmp_strval($invert) . "\n";
?>

Yukarıdaki örneğin çıktısı:

9

gmp_intval
gmp_jacobi
GMP İşlevleri


Jacobi symbol

gmp_invert
gmp_legendre
GMP İşlevleri
PHP Manual

gmp_jacobi

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gmp_jacobi — Jacobi symbol

Açıklama

int gmp_jacobi ( GMP $a , GMP $p )

Computes » Jacobi symbol of a and p. p should be odd and must be positive.

Değiştirgeler

a

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

p

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

Should be odd and must be positive.

Dönen Değerler

A GMP number resource in PHP 5.5 and earlier, or a GMP object in PHP 5.6 and later.

Örnekler

Örnek 1 gmp_jacobi() example

<?php
echo gmp_jacobi("1", "3") . "\n";
echo gmp_jacobi("2", "3") . "\n";
?>

Yukarıdaki örneğin çıktısı:

1
0

gmp_invert
gmp_legendre
GMP İşlevleri


Legendre symbol

gmp_jacobi
gmp_mod
GMP İşlevleri
PHP Manual

gmp_legendre

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gmp_legendre — Legendre symbol

Açıklama

int gmp_legendre ( GMP $a , GMP $p )

Compute the » Legendre symbol of a and p. p should be odd and must be positive.

Değiştirgeler

a

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

p

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

Should be odd and must be positive.

Dönen Değerler

A GMP number resource in PHP 5.5 and earlier, or a GMP object in PHP 5.6 and later.

Örnekler

Örnek 1 gmp_legendre() example

<?php
echo gmp_legendre("1", "3") . "\n";
echo gmp_legendre("2", "3") . "\n";
?>

Yukarıdaki örneğin çıktısı:

1
0

gmp_jacobi
gmp_mod
GMP İşlevleri


Modulo operation

gmp_legendre
gmp_mul
GMP İşlevleri
PHP Manual

gmp_mod

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gmp_mod — Modulo operation

Açıklama

GMP gmp_mod ( GMP $n , GMP $d )

Calculates n modulo d. The result is always non-negative, the sign of d is ignored.

Değiştirgeler

n

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

d

The modulo that is being evaluated.

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

Dönen Değerler

A GMP number resource in PHP 5.5 and earlier, or a GMP object in PHP 5.6 and later.

Örnekler

Örnek 1 gmp_mod() example

<?php
$mod = gmp_mod("8", "3");
echo gmp_strval($mod) . "\n";
?>

Yukarıdaki örneğin çıktısı:

2

gmp_legendre
gmp_mul
GMP İşlevleri


Multiply numbers

gmp_mod
gmp_neg
GMP İşlevleri
PHP Manual

gmp_mul

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gmp_mul — Multiply numbers

Açıklama

GMP gmp_mul ( GMP $a , GMP $b )

Multiplies a by b and returns the result.

Değiştirgeler

a

A number that will be multiplied by b.

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

b

A number that will be multiplied by a.

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

Dönen Değerler

A GMP number resource in PHP 5.5 and earlier, or a GMP object in PHP 5.6 and later.

Örnekler

Örnek 1 gmp_mul() example

<?php
$mul = gmp_mul("12345678", "2000");
echo gmp_strval($mul) . "\n";
?>

Yukarıdaki örneğin çıktısı:

24691356000

gmp_mod
gmp_neg
GMP İşlevleri


Negate number

gmp_mul
gmp_nextprime
GMP İşlevleri
PHP Manual

gmp_neg

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gmp_neg — Negate number

Açıklama

GMP gmp_neg ( GMP $a )

Returns the negative value of a number.

Değiştirgeler

a

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

Dönen Değerler

Returns -a, as a GMP number.

Örnekler

Örnek 1 gmp_neg() example

<?php
$neg1 = gmp_neg("1");
echo gmp_strval($neg1) . "\n";
$neg2 = gmp_neg("-1");
echo gmp_strval($neg2) . "\n";
?>

Yukarıdaki örneğin çıktısı:

-1
1

gmp_mul
gmp_nextprime
GMP İşlevleri


Find next prime number

gmp_neg
gmp_or
GMP İşlevleri
PHP Manual

gmp_nextprime

(PHP 5 >= 5.2.0, PHP 7)

gmp_nextprime — Find next prime number

Açıklama

GMP gmp_nextprime ( int $a )

Find next prime number

Değiştirgeler

a

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

Dönen Değerler

Return the next prime number greater than a, as a GMP number.

Örnekler

Örnek 1 gmp_nextprime() example

<?php
$prime1 = gmp_nextprime(10); // next prime number greater than 10
$prime2 = gmp_nextprime(-1000); // next prime number greater than -1000

echo gmp_strval($prime1) . "\n";
echo gmp_strval($prime2) . "\n";
?>

Yukarıdaki örneğin çıktısı:

11
-997

Notlar

Bilginize:

This function uses a probabilistic algorithm to identify primes and chances to get a composite number are extremely small.

gmp_neg
gmp_or
GMP İşlevleri


Bitwise OR

gmp_nextprime
gmp_perfect_square
GMP İşlevleri
PHP Manual

gmp_or

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gmp_or — Bitwise OR

Açıklama

GMP gmp_or ( GMP $a , GMP $b )

Calculates bitwise inclusive OR of two GMP numbers.

Değiştirgeler

a

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

b

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

Dönen Değerler

A GMP number resource in PHP 5.5 and earlier, or a GMP object in PHP 5.6 and later.

Örnekler

Örnek 1 gmp_or() example

<?php
$or1 = gmp_or("0xfffffff2", "4");
echo gmp_strval($or1, 16) . "\n";
$or2 = gmp_or("0xfffffff2", "2");
echo gmp_strval($or2, 16) . "\n";
?>

Yukarıdaki örneğin çıktısı:

fffffff6
fffffff2

gmp_nextprime
gmp_perfect_square
GMP İşlevleri


Perfect square check

gmp_or
gmp_popcount
GMP İşlevleri
PHP Manual

gmp_perfect_square

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gmp_perfect_square — Perfect square check

Açıklama

bool gmp_perfect_square ( GMP $a )

Check if a number is a perfect square.

Değiştirgeler

a

The number being checked as a perfect square.

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

Dönen Değerler

Returns TRUE if a is a perfect square, FALSE otherwise.

Örnekler

Örnek 1 gmp_perfect_square() example

<?php
// 3 * 3, perfect square
var_dump(gmp_perfect_square("9"));

// not a perfect square
var_dump(gmp_perfect_square("7"));

// 1234567890 * 1234567890, perfect square
var_dump(gmp_perfect_square("1524157875019052100"));
?>

Yukarıdaki örneğin çıktısı:

bool(true)
bool(false)
bool(true)

Ayrıca Bakınız

  • gmp_sqrt() - Calculate square root
  • gmp_sqrtrem() - Square root with remainder

gmp_or
gmp_popcount
GMP İşlevleri


Population count

gmp_perfect_square
gmp_pow
GMP İşlevleri
PHP Manual

gmp_popcount

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gmp_popcount — Population count

Açıklama

int gmp_popcount ( GMP $a )

Get the population count.

Değiştirgeler

a

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

Dönen Değerler

The population count of a, as an integer.

Örnekler

Örnek 1 gmp_popcount() example

<?php
$pop1 = gmp_init("10000101", 2); // 3 1's
echo gmp_popcount($pop1) . "\n";
$pop2 = gmp_init("11111110", 2); // 7 1's
echo gmp_popcount($pop2) . "\n";
?>

Yukarıdaki örneğin çıktısı:

3
7

gmp_perfect_square
gmp_pow
GMP İşlevleri


Raise number into power

gmp_popcount
gmp_powm
GMP İşlevleri
PHP Manual

gmp_pow

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gmp_pow — Raise number into power

Açıklama

GMP gmp_pow ( GMP $base , int $exp )

Raise base into power exp.

Değiştirgeler

base

The base number.

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

exp

The positive power to raise the base.

Dönen Değerler

The new (raised) number, as a GMP number. The case of 0^0 yields 1.

Örnekler

Örnek 1 gmp_pow() example

<?php
$pow1 = gmp_pow("2", 31);
echo gmp_strval($pow1) . "\n";
$pow2 = gmp_pow("0", 0);
echo gmp_strval($pow2) . "\n";
$pow3 = gmp_pow("2", -1); // Negative exp, generates warning
echo gmp_strval($pow3) . "\n";
?>

Yukarıdaki örneğin çıktısı:

2147483648
1

gmp_popcount
gmp_powm
GMP İşlevleri


Raise number into power with modulo

gmp_pow
gmp_prob_prime
GMP İşlevleri
PHP Manual

gmp_powm

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gmp_powm — Raise number into power with modulo

Açıklama

GMP gmp_powm ( GMP $base , GMP $exp , GMP $mod )

Calculate (base raised into power exp) modulo mod. If exp is negative, result is undefined.

Değiştirgeler

base

The base number.

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

exp

The positive power to raise the base.

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

mod

The modulo.

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

Dönen Değerler

The new (raised) number, as a GMP number.

Örnekler

Örnek 1 gmp_powm() example

<?php
$pow1 = gmp_powm("2", "31", "2147483649");
echo gmp_strval($pow1) . "\n";
?>

Yukarıdaki örneğin çıktısı:

2147483648

gmp_pow
gmp_prob_prime
GMP İşlevleri


Check if number is "probably prime"

gmp_powm
gmp_random_bits
GMP İşlevleri
PHP Manual

gmp_prob_prime

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gmp_prob_prime — Check if number is "probably prime"

Açıklama

int gmp_prob_prime ( GMP $a [, int $reps = 10 ] )

The function uses Miller-Rabin's probabilistic test to check if a number is a prime.

Değiştirgeler

a

The number being checked as a prime.

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

reps

Reasonable values of reps vary from 5 to 10 (default being 10); a higher value lowers the probability for a non-prime to pass as a "probable" prime.

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

Dönen Değerler

If this function returns 0, a is definitely not prime. If it returns 1, then a is "probably" prime. If it returns 2, then a is surely prime.

Örnekler

Örnek 1 gmp_prob_prime() example

<?php
// definitely not a prime
echo gmp_prob_prime("6") . "\n";

// probably a prime
echo gmp_prob_prime("1111111111111111111") . "\n";

// definitely a prime
echo gmp_prob_prime("11") . "\n";
?>

Yukarıdaki örneğin çıktısı:

0
1
2

gmp_powm
gmp_random_bits
GMP İşlevleri


Random number

gmp_prob_prime
gmp_random_range
GMP İşlevleri
PHP Manual

gmp_random_bits

(PHP 5 >= 5.6.3, PHP 7)

gmp_random_bits — Random number

Açıklama

GMP gmp_random_bits ( integer $bits )

Generate a random number. The number will be between 0 and (2 ** bits) - 1.

bits must greater than 0, and the maximum value is restricted by available memory.

Değiştirgeler

bits

The number of bits.

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

Dönen Değerler

A random GMP number.

Örnekler

Örnek 1 gmp_random_bits() example

<?php
$rand1 = gmp_random_bits(3); // random number from 0 to 7
$rand2 = gmp_random_bits(5); // random number from 0 to 31

echo gmp_strval($rand1) . "\n";
echo gmp_strval($rand2) . "\n";
?>

Yukarıdaki örneğin çıktısı:

3
15

gmp_prob_prime
gmp_random_range
GMP İşlevleri


Random number

gmp_random_bits
gmp_random_seed
GMP İşlevleri
PHP Manual

gmp_random_range

(PHP 5 >= 5.6.3, PHP 7)

gmp_random_range — Random number

Açıklama

GMP gmp_random_range ( GMP $min , GMP $max )

Generate a random number. The number will be between min and max.

min and max can both be negative but min must always be less than max.

Değiştirgeler

min

A GMP number representing the lower bound for the random number

max

A GMP number representing the upper bound for the random number

Dönen Değerler

A random GMP number.

Örnekler

Örnek 1 gmp_random_range() example

<?php
$rand1 = gmp_random_range(0, 100);    // random number between 0 and 100
$rand2 = gmp_random_range(-100, -10); // random number between -100 and -10

echo gmp_strval($rand1) . "\n";
echo gmp_strval($rand2) . "\n";
?>

Yukarıdaki örneğin çıktısı:

42
-67

gmp_random_bits
gmp_random_seed
GMP İşlevleri


Sets the RNG seed

gmp_random_range
gmp_random
GMP İşlevleri
PHP Manual

gmp_random_seed

(PHP 7)

gmp_random_seed — Sets the RNG seed

Açıklama

mixed gmp_random_seed ( mixed $seed )

Değiştirgeler

seed

The seed to be set for the gmp_random(), gmp_random_bits(), and gmp_random_range() functions.

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

Dönen Değerler

Returns NULL on success.

Hatalar/İstisnalar

Issues an E_WARNING and returns FALSE if seed is not valid.

Örnekler

Örnek 1 gmp_random_seed() example

<?php
// set the seed
gmp_random_seed(100);

var_dump(gmp_strval(gmp_random(1)));

// set the seed to something else
gmp_random_seed(gmp_init(-100));

var_dump(gmp_strval(gmp_random_bits(10)));

// set the seed to something invalid
var_dump(gmp_random_seed('not a number'));

Yukarıdaki örneğin çıktısı:

string(20) "15370156633245019617"
string(3) "683"

Warning: gmp_random_seed(): Unable to convert variable to GMP - string is not an integer in %s on line %d
bool(false)

Ayrıca Bakınız

  • gmp_init() - Create GMP number
  • gmp_random() - Random number
  • gmp_random_bits() - Random number
  • gmp_random_range() - Random number
gmp_random_range
gmp_random
GMP İşlevleri


Random number

gmp_random_seed
gmp_root
GMP İşlevleri
PHP Manual

gmp_random

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gmp_random — Random number

Açıklama

GMP gmp_random ([ int $limiter = 20 ] )

Generate a random number. The number will be between zero and the number of bits per limb multiplied by limiter. If limiter is negative, negative numbers are generated.

A limb is an internal GMP mechanism. The number of bits in a limb is not static, and can vary from system to system. Generally, the number of bits in a limb is either 16 or 32, but this is not guaranteed.

Değiştirgeler

limiter

The limiter.

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

Dönen Değerler

A random GMP number.

Örnekler

Örnek 1 gmp_random() example

<?php
$rand1 = gmp_random(1); // random number from 0 to 1 * bits per limb
$rand2 = gmp_random(2); // random number from 0 to 2 * bits per limb

echo gmp_strval($rand1) . "\n";
echo gmp_strval($rand2) . "\n";
?>

Yukarıdaki örneğin çıktısı:

1915834968
8642564075890328087

gmp_random_seed
gmp_root
GMP İşlevleri


Take the integer part of nth root

gmp_random
gmp_rootrem
GMP İşlevleri
PHP Manual

gmp_root

(PHP 5 >= 5.6.0, PHP 7)

gmp_root — Take the integer part of nth root

Açıklama

GMP gmp_root ( GMP $a , int $nth )

Takes the nth root of a and returns the integer component of the result.

Değiştirgeler

a

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

nth

The positive root to take of a.

Dönen Değerler

The integer component of the resultant root, as a GMP number.

gmp_random
gmp_rootrem
GMP İşlevleri


Take the integer part and remainder of nth root

gmp_root
gmp_scan0
GMP İşlevleri
PHP Manual

gmp_rootrem

(PHP 5 >= 5.6.0, PHP 7)

gmp_rootrem — Take the integer part and remainder of nth root

Açıklama

array gmp_rootrem ( GMP $a , int $nth )

Takes the nth root of a and returns the integer component and remainder of the result.

Değiştirgeler

a

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

nth

The positive root to take of a.

Dönen Değerler

A two element array, where the first element is the integer component of the root, and the second element is the remainder, both represented as GMP numbers.

gmp_root
gmp_scan0
GMP İşlevleri


Scan for 0

gmp_rootrem
gmp_scan1
GMP İşlevleri
PHP Manual

gmp_scan0

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gmp_scan0 — Scan for 0

Açıklama

int gmp_scan0 ( GMP $a , int $start )

Scans a, starting with bit start, towards more significant bits, until the first clear bit is found.

Değiştirgeler

a

The number to scan.

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

start

The starting bit.

Dönen Değerler

Returns the index of the found bit, as an integer. The index starts from 0.

Örnekler

Örnek 1 gmp_scan0() example

<?php
// "0" bit is found at position 3. index starts at 0
$s1 = gmp_init("10111", 2);
echo gmp_scan0($s1, 0) . "\n";

// "0" bit is found at position 7. index starts at 5
$s2 = gmp_init("101110000", 2);
echo gmp_scan0($s2, 5) . "\n";
?>

Yukarıdaki örneğin çıktısı:

3
7

gmp_rootrem
gmp_scan1
GMP İşlevleri


Scan for 1

gmp_scan0
gmp_setbit
GMP İşlevleri
PHP Manual

gmp_scan1

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gmp_scan1 — Scan for 1

Açıklama

int gmp_scan1 ( GMP $a , int $start )

Scans a, starting with bit start, towards more significant bits, until the first set bit is found.

Değiştirgeler

a

The number to scan.

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

start

The starting bit.

Dönen Değerler

Returns the index of the found bit, as an integer. If no set bit is found, -1 is returned.

Örnekler

Örnek 1 gmp_scan1() example

<?php
// "1" bit is found at position 3. index starts at 0
$s1 = gmp_init("01000", 2);
echo gmp_scan1($s1, 0) . "\n";

// "1" bit is found at position 9. index starts at 5
$s2 = gmp_init("01000001111", 2);
echo gmp_scan1($s2, 5) . "\n";
?>

Yukarıdaki örneğin çıktısı:

3
9

gmp_scan0
gmp_setbit
GMP İşlevleri


Set bit

gmp_scan1
gmp_sign
GMP İşlevleri
PHP Manual

gmp_setbit

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gmp_setbit — Set bit

Açıklama

void gmp_setbit ( GMP &$a , int $index [, bool $bit_on = true ] )

Sets bit index in a.

Değiştirgeler

a

The value to modify.

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

index

The index of the bit to set. Index 0 represents the least significant bit.

bit_on

True to set the bit (set it to 1/on); false to clear the bit (set it to 0/off).

Dönen Değerler

A GMP number resource in PHP 5.5 and earlier, or a GMP object in PHP 5.6 and later.

Örnekler

Örnek 1 gmp_setbit() example - 0 index

<?php
$a = gmp_init("2"); //
echo gmp_strval($a), ' -> 0b', gmp_strval($a, 2), "\n";
gmp_setbit($a, 0); // 0b10 now becomes 0b11
echo gmp_strval($a), ' -> 0b', gmp_strval($a, 2), "\n";
?>

Yukarıdaki örneğin çıktısı:

2 -> 0b10
3 -> 0b11

Örnek 2 gmp_setbit() example - 1 index

<?php
$a = gmp_init("0xfd");
echo gmp_strval($a), ' -> 0b', gmp_strval($a, 2), "\n";
gmp_setbit($a, 1); // index starts at 0
echo gmp_strval($a), ' -> 0b', gmp_strval($a, 2), "\n";
?>

Yukarıdaki örneğin çıktısı:

253 -> 0b11111101
255 -> 0b11111111

Örnek 3 gmp_setbit() example - clearing a bit

<?php
$a = gmp_init("0xff");
echo gmp_strval($a), ' -> 0b', gmp_strval($a, 2), "\n";
gmp_setbit($a, 0, false); // clear bit at index 0
echo gmp_strval($a), ' -> 0b', gmp_strval($a, 2), "\n";
?>

Yukarıdaki örneğin çıktısı:

255 -> 0b11111111
254 -> 0b11111110

Notlar

Bilginize:

Unlike most of the other GMP functions, gmp_setbit() must be called with a GMP resource that already exists (using gmp_init() for example). One will not be automatically created.

Ayrıca Bakınız

  • gmp_clrbit() - Clear bit
  • gmp_testbit() - Tests if a bit is set

gmp_scan1
gmp_sign
GMP İşlevleri


Sign of number

gmp_setbit
gmp_sqrt
GMP İşlevleri
PHP Manual

gmp_sign

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gmp_sign — Sign of number

Açıklama

int gmp_sign ( GMP $a )

Checks the sign of a number.

Değiştirgeler

a

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

Dönen Değerler

Returns 1 if a is positive, -1 if a is negative, and 0 if a is zero.

Örnekler

Örnek 1 gmp_sign() example

<?php
// positive
echo gmp_sign("500") . "\n";

// negative
echo gmp_sign("-500") . "\n";

// zero
echo gmp_sign("0") . "\n";
?>

Yukarıdaki örneğin çıktısı:

1
-1
0

Ayrıca Bakınız

  • gmp_abs() - Absolute value
  • abs() - Absolute value

gmp_setbit
gmp_sqrt
GMP İşlevleri


Calculate square root

gmp_sign
gmp_sqrtrem
GMP İşlevleri
PHP Manual

gmp_sqrt

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gmp_sqrt — Calculate square root

Açıklama

GMP gmp_sqrt ( GMP $a )

Calculates square root of a.

Değiştirgeler

a

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

Dönen Değerler

The integer portion of the square root, as a GMP number.

Örnekler

Örnek 1 gmp_sqrt() example

<?php
$sqrt1 = gmp_sqrt("9");
$sqrt2 = gmp_sqrt("7");
$sqrt3 = gmp_sqrt("1524157875019052100");

echo gmp_strval($sqrt1) . "\n";
echo gmp_strval($sqrt2) . "\n";
echo gmp_strval($sqrt3) . "\n";
?>

Yukarıdaki örneğin çıktısı:

3
2
1234567890

gmp_sign
gmp_sqrtrem
GMP İşlevleri


Square root with remainder

gmp_sqrt
gmp_strval
GMP İşlevleri
PHP Manual

gmp_sqrtrem

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gmp_sqrtrem — Square root with remainder

Açıklama

array gmp_sqrtrem ( GMP $a )

Calculate the square root of a number, with remainder.

Değiştirgeler

a

The number being square rooted.

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

Dönen Değerler

Returns array where first element is the integer square root of a and the second is the remainder (i.e., the difference between a and the first element squared).

Örnekler

Örnek 1 gmp_sqrtrem() example

<?php
list($sqrt1, $sqrt1rem) = gmp_sqrtrem("9");
list($sqrt2, $sqrt2rem) = gmp_sqrtrem("7");
list($sqrt3, $sqrt3rem) = gmp_sqrtrem("1048576");

echo gmp_strval($sqrt1) . ", " . gmp_strval($sqrt1rem) . "\n";
echo gmp_strval($sqrt2) . ", " . gmp_strval($sqrt2rem) . "\n";
echo gmp_strval($sqrt3) . ", " . gmp_strval($sqrt3rem) . "\n";
?>

Yukarıdaki örneğin çıktısı:

3, 0
2, 3
1024, 0

gmp_sqrt
gmp_strval
GMP İşlevleri


Convert GMP number to string

gmp_sqrtrem
gmp_sub
GMP İşlevleri
PHP Manual

gmp_strval

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gmp_strval — Convert GMP number to string

Açıklama

string gmp_strval ( GMP $gmpnumber [, int $base = 10 ] )

Convert GMP number to string representation in base base. The default base is 10.

Değiştirgeler

gmpnumber

The GMP number that will be converted to a string.

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

base

The base of the returned number. The default base is 10. Allowed values for the base are from 2 to 62 and -2 to -36.

Dönen Değerler

The number, as a string.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.2 | The base was extended from 2 to 36, to 2 to 62 and -2 to -36.

Notlar

Bilginize:

To use the extended base introduced in PHP 5.3.2, then PHP must be compiled against GMP 4.2.0 or greater.

Örnekler

Örnek 1 Converting a GMP number to a string

<?php
$a = gmp_init("0x41682179fbf5");
printf("Decimal: %s, 36-based: %s", gmp_strval($a), gmp_strval($a,36));
?>

gmp_sqrtrem
gmp_sub
GMP İşlevleri


Subtract numbers

gmp_strval
gmp_testbit
GMP İşlevleri
PHP Manual

gmp_sub

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gmp_sub — Subtract numbers

Açıklama

GMP gmp_sub ( GMP $a , GMP $b )

Subtracts b from a and returns the result.

Değiştirgeler

a

The number being subtracted from.

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

b

The number subtracted from a.

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

Dönen Değerler

A GMP number resource in PHP 5.5 and earlier, or a GMP object in PHP 5.6 and later.

Örnekler

Örnek 1 gmp_sub() example

<?php
$sub = gmp_sub("281474976710656", "4294967296"); // 2^48 - 2^32
echo gmp_strval($sub) . "\n";
?>

Yukarıdaki örneğin çıktısı:

281470681743360

gmp_strval
gmp_testbit
GMP İşlevleri


Tests if a bit is set

gmp_sub
gmp_xor
GMP İşlevleri
PHP Manual

gmp_testbit

(PHP 5 >= 5.3.0, PHP 7)

gmp_testbit — Tests if a bit is set

Açıklama

bool gmp_testbit ( GMP $a , int $index )

Tests if the specified bit is set.

Değiştirgeler

a

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

index

The bit to test

Dönen Değerler

Returns TRUE if the bit is set in resource $a, otherwise FALSE.

Hatalar/İstisnalar

An E_WARNING level error is issued when index is less than zero, and FALSE is returned.

Örnekler

Örnek 1 gmp_testbit() example

<?php
$n = gmp_init("1000000");
var_dump(gmp_testbit($n, 1));
gmp_setbit($n, 1);
var_dump(gmp_testbit($n, 1));
?>

Yukarıdaki örneğin çıktısı:

bool(false)
bool(true)

Ayrıca Bakınız

  • gmp_setbit() - Set bit
  • gmp_clrbit() - Clear bit

gmp_sub
gmp_xor
GMP İşlevleri


Bitwise XOR

gmp_testbit
GMP
GMP İşlevleri
PHP Manual

gmp_xor

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

gmp_xor — Bitwise XOR

Açıklama

GMP gmp_xor ( GMP $a , GMP $b )

Calculates bitwise exclusive OR (XOR) of two GMP numbers.

Değiştirgeler

a

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

b

Either a GMP number resource in PHP 5.5 and earlier, a GMP object in PHP 5.6 and later, or a numeric string provided that it is possible to convert the latter to a number.

Dönen Değerler

A GMP number resource in PHP 5.5 and earlier, or a GMP object in PHP 5.6 and later.

Örnekler

Örnek 1 gmp_xor() example

<?php
$xor1 = gmp_init("1101101110011101", 2);
$xor2 = gmp_init("0110011001011001", 2);

$xor3 = gmp_xor($xor1, $xor2);

echo gmp_strval($xor3, 2) . "\n";
?>

Yukarıdaki örneğin çıktısı:

1011110111000100

gmp_testbit
GMP
GMP İşlevleri


The GMP class

(PHP 5 >= 5.6.0, PHP 7)

Giriş

A GMP number. These objects support overloaded arithmetic, bitwise and comparison operators.

Bilginize:

No object oriented interface is provided to manipulate GMP objects. Please use the procedural GMP API.

GMP implements Serializable {
}
gmp_xor
Lapack
GMP


Lapack

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Lapack — The Lapack class
    • Lapack::eigenValues — This function returns the eigenvalues for a given square matrix
    • Lapack::identity — Return an identity matrix
    • Lapack::leastSquaresByFactorisation — Calculate the linear least squares solution of a matrix using QR factorisation
    • Lapack::leastSquaresBySVD — Solve the linear least squares problem, using SVD
    • Lapack::pseudoInverse — Calculate the inverse of a matrix
    • Lapack::singularValues — Calculated the singular values of a matrix
    • Lapack::solveLinearEquation — Solve a system of linear equations
  • LapackException — The LapackException class
GMP
Giriş
Matematiksel Eklentiler


Giriş

LAPACK is written in Fortran 90 and provides routines for solving systems of simultaneous linear equations, least-squares solutions of linear systems of equations, eigenvalue problems, and singular value problems. This extension wraps the LAPACKE C bindings to allow access to several processes exposed by the library. Most functions work with arrays of arrays, representing rectangular matrices in row major order - so a two by two matrix [1 2; 3 4] would be array(array(1, 2), array(3, 4))

Lapack
Yapılandırma/Kurulum
Lapack


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Lapack


Gereksinimler

Lapack requires the LAPACK and LAPACKE libraries.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Most distribution LAPACK packages do not include lapacke, so the easiest method is to build from source:

  svn co https://icl.cs.utk.edu/svn/lapack-dev/lapack/trunk lapack
  cd lapack
  mkdir build
  cd build
  cmake -D BUILD_SHARED_LIBS=ON -D LAPACKE=ON ../
  make
  sudo make install
Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
Lapack
Lapack


The Lapack class

(PECL lapack >= 0.1.0)

Giriş

LAPACK is written in Fortran 90 and provides routines for solving systems of simultaneous linear equations, least-squares solutions of linear systems of equations, eigenvalue problems, and singular value problems. This extension wraps the LAPACKE C bindings to allow access to several processes exposed by the library. Most functions work with arrays of arrays, representing rectangular matrices in row major order - so a two by two matrix [1 2; 3 4] would be array(array(1, 2), array(3, 4)).

All of the functions are called statically, for example $eig = Lapack::eigenvalues($a);

Sınıf Sözdizimi

Lapack {
/* Yöntemler */
public static array eigenValues ( array $a [, array $left [, array $right ]] )
public static array identity ( int $n )
public static array leastSquaresByFactorisation ( array $a , array $b )
public static array leastSquaresBySVD ( array $a , array $b )
public static array pseudoInverse ( array $a )
public static array singularValues ( array $a )
public static array solveLinearEquation ( array $a , array $b )
}

İçindekiler

  • Lapack::eigenValues — This function returns the eigenvalues for a given square matrix
  • Lapack::identity — Return an identity matrix
  • Lapack::leastSquaresByFactorisation — Calculate the linear least squares solution of a matrix using QR factorisation
  • Lapack::leastSquaresBySVD — Solve the linear least squares problem, using SVD
  • Lapack::pseudoInverse — Calculate the inverse of a matrix
  • Lapack::singularValues — Calculated the singular values of a matrix
  • Lapack::solveLinearEquation — Solve a system of linear equations
Öntanımlı Sabitler
Lapack::eigenValues
Lapack


This function returns the eigenvalues for a given square matrix

Lapack
Lapack::identity
Lapack
PHP Manual

Lapack::eigenValues

(PECL lapack >= 0.1.0)

Lapack::eigenValues — This function returns the eigenvalues for a given square matrix

Açıklama

public static array Lapack::eigenValues ( array $a [, array $left [, array $right ]] )

Calculate the eigenvalues for a square matrix, and optionally calculate the left and right eigenvectors.

Değiştirgeler

a

The matrix to calculate the eigenvalues for.

left

Optional parameter - if an array is passed here, it will be filled with the left eigenvectors

right

Optional parameter - if an array is passed here, it will be filled with the right eigenvectors

Dönen Değerler

Returns an array of arrays representing the eigenvalues for the array.

Örnekler

Örnek 1 Using Lapack::eigenValues():

<?php

 $a = array(
     array(-1.01,   0.86,  -4.60,  3.31,  -4.81  ),
     array( 3.98,   0.53,  -7.04,  5.29,   3.55  ),
     array( 3.30,   8.26,  -3.89,  8.20,  -1.51  ),
     array( 4.43,   4.96,  -7.66, -7.33,   6.18  ),
     array( 7.31,  -6.43,  -6.16,  2.47,   5.58  ),
 );

 $result = Lapack::eigenValues($a);

 ?>

Lapack
Lapack::identity
Lapack


Return an identity matrix

Lapack::eigenValues
Lapack::leastSquaresByFactorisation
Lapack
PHP Manual

Lapack::identity

(PECL lapack >= 0.1.0)

Lapack::identity — Return an identity matrix

Açıklama

public static array Lapack::identity ( int $n )

Return a size n identity matrix

Değiştirgeler

n

The height and width of the identity matrix.

Dönen Değerler

Will return a an array of n arrays, each containing n entries. The diagonals of the matrix will be 1s, the other positions 0.

Lapack::eigenValues
Lapack::leastSquaresByFactorisation
Lapack


Calculate the linear least squares solution of a matrix using QR factorisation

Lapack::identity
Lapack::leastSquaresBySVD
Lapack
PHP Manual

Lapack::leastSquaresByFactorisation

(PECL lapack >= 0.1.0)

Lapack::leastSquaresByFactorisation — Calculate the linear least squares solution of a matrix using QR factorisation

Açıklama

public static array Lapack::leastSquaresByFactorisation ( array $a , array $b )

Solve the linear least squares problem, find min x in || B - Ax || Returns an array representing x. Expects arrays of arrays, and will return an array of arrays in the dimension B num cols x A num cols. Uses QR or LQ factorisation on matrix A.

Değiştirgeler

a

Matrix A

b

Matrix B

Dönen Değerler

Array of the solution matrix

Örnekler

Örnek 1 Using Lapack::leastSquaresByFactorisation():

<?php

 $a = array(
     array( 1.44,  -7.84,  -4.39,   4.53),
     array(-9.96,  -0.28,  -3.24,   3.83),
     array(-7.55,   3.24,   6.27,  -6.64),
     array( 8.34,   8.09,   5.28,   2.06),
     array( 7.08,   2.52,   0.74,  -2.47),
     array(-5.45,  -5.70,  -1.19,   4.70),
 );

 $b = array(
     array( 8.58,   9.35),
     array( 8.26,  -4.43),
     array( 8.48,  -0.70),
     array(-5.28,  -0.26),
     array( 5.72,  -7.36),
     array( 8.93,  -2.52),
 );

 $result = Lapack::leastSquaresByFactorisation($a, $b);
 ?>

Lapack::identity
Lapack::leastSquaresBySVD
Lapack


Solve the linear least squares problem, using SVD

Lapack::leastSquaresByFactorisation
Lapack::pseudoInverse
Lapack
PHP Manual

Lapack::leastSquaresBySVD

(PECL lapack >= 0.1.0)

Lapack::leastSquaresBySVD — Solve the linear least squares problem, using SVD

Açıklama

public static array Lapack::leastSquaresBySVD ( array $a , array $b )

Solve the linear least squares problem, find min x in || B - Ax || Returns an array representing x. Expects arrays of arrays, and will return an array of arrays in the dimension B num cols x A num cols. Uses SVD with a divide and conquer algorithm.

Değiştirgeler

a

Matrix A

b

Matrix B

Dönen Değerler

Returns the solution as an array of arrays.

Örnekler

Örnek 1 Using Lapack::leastSquaresBySVD():

<?php

  $a = array(
      array( 1.44,  -7.84,  -4.39,   4.53),
      array(-9.96,  -0.28,  -3.24,   3.83),
      array(-7.55,   3.24,   6.27,  -6.64),
      array( 8.34,   8.09,   5.28,   2.06),
      array( 7.08,   2.52,   0.74,  -2.47),
      array(-5.45,  -5.70,  -1.19,   4.70),
  );

  $b = array(
      array( 8.58,   9.35),
      array( 8.26,  -4.43),
      array( 8.48,  -0.70),
      array(-5.28,  -0.26),
      array( 5.72,  -7.36),
      array( 8.93,  -2.52),
  );

  $result = Lapack::leastSquaresBySVD($a, $b);

  ?>

Lapack::leastSquaresByFactorisation
Lapack::pseudoInverse
Lapack


Calculate the inverse of a matrix

Lapack::leastSquaresBySVD
Lapack::singularValues
Lapack
PHP Manual

Lapack::pseudoInverse

(PECL lapack >= 0.1.0)

Lapack::pseudoInverse — Calculate the inverse of a matrix

Açıklama

public static array Lapack::pseudoInverse ( array $a )

Find the pseudoinverse of a matrix A.

Değiştirgeler

a

Matrix to invert

Dönen Değerler

Inverted matrix (array of arrays).

Örnekler

Örnek 1 Using Lapack::pseudoInverse():

<?php

   $a = array(
       array( 8, 1, 6 ),
       array( 3, 5, 7 ),
       array( 4, 9, 2 ),
   );

   $result = Lapack::pseudoInverse($a);

   ?>

Lapack::leastSquaresBySVD
Lapack::singularValues
Lapack


Calculated the singular values of a matrix

Lapack::pseudoInverse
Lapack::solveLinearEquation
Lapack
PHP Manual

Lapack::singularValues

(PECL lapack >= 0.1.0)

Lapack::singularValues — Calculated the singular values of a matrix

Açıklama

public static array Lapack::singularValues ( array $a )

Calculate the singular values of the matrix A.

Değiştirgeler

a

The matrix to calculate the singular values for

Dönen Değerler

The singular values

Örnekler

Örnek 1 Using Lapack::singularValues():

<?php

    $a = array(
        array( 7.52,  -1.10,  -7.95,  1.08  ),
        array(-0.76,   0.62,   9.34, -7.10  ),
        array( 5.13,   6.62,  -5.66,  0.87  ),
        array(-4.75,   8.52,   5.75,  5.30  ),
        array( 1.33,   4.91,  -5.49, -3.52  ),
        array(-2.40,  -6.77,   2.34,  3.95  ),
    );

    $result = Lapack::singularValues($a);

    ?>

Lapack::pseudoInverse
Lapack::solveLinearEquation
Lapack


Solve a system of linear equations

Lapack::singularValues
LapackException
Lapack
PHP Manual

Lapack::solveLinearEquation

(PECL lapack >= 0.1.0)

Lapack::solveLinearEquation — Solve a system of linear equations

Açıklama

public static array Lapack::solveLinearEquation ( array $a , array $b )

This function computes the solution to the system of linear equations with a square matrix A and multiple right-hand sides B. Solves A * X = B for multiple B.

Değiştirgeler

a

Square matrix of linear equations

b

Right hand side to be solved for

Dönen Değerler

Matrix X

Örnekler

Örnek 1 Using Lapack::singularValues():

<?php

    $a = array(
        array( 6.80,  -6.05,  -0.45,   8.32,  -9.67   ),
        array(-2.11,  -3.30,   2.58,   2.71,  -5.14   ),
        array( 5.66,   5.36,  -2.70,   4.35,  -7.26   ),
        array( 5.97,  -4.44,   0.27,  -7.17,   6.08   ),
        array( 8.23,   1.08,   9.04,   2.14,  -6.87   ),
    );

    $b = array(
       array(  4.02,  -1.56,   9.81   ),
       array(  6.19,   4.00,  -4.09   ),
       array( -8.22,  -8.67,  -4.57   ),
       array( -7.57,   1.75,  -8.61   ),
       array( -3.03,   2.86,   8.99   ),
    );

    $result = Lapack::solveLinearEquation($a, $b);

    ?>

Lapack::singularValues
LapackException
Lapack


The LapackException class

(PECL lapack >= 0.1.0)

Giriş

Exception thrown when an error is caught in the LAPACK functions

Sınıf Sözdizimi

lapackexception extends Exception {
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}
Lapack::solveLinearEquation
Math
Lapack


Mathematical Functions

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Math İşlevleri
    • abs — Absolute value
    • acos — Arc cosine
    • acosh — Inverse hyperbolic cosine
    • asin — Arc sine
    • asinh — Inverse hyperbolic sine
    • atan2 — Arc tangent of two variables
    • atan — Arc tangent
    • atanh — Inverse hyperbolic tangent
    • base_convert — Convert a number between arbitrary bases
    • bindec — Binary to decimal
    • ceil — Round fractions up
    • cos — Cosine
    • cosh — Hyperbolic cosine
    • decbin — Decimal to binary
    • dechex — Decimal to hexadecimal
    • decoct — Decimal to octal
    • deg2rad — Converts the number in degrees to the radian equivalent
    • exp — Calculates the exponent of e
    • expm1 — Returns exp(number) - 1, computed in a way that is accurate even when the value of number is close to zero
    • floor — Round fractions down
    • fmod — Returns the floating point remainder (modulo) of the division of the arguments
    • getrandmax — Show largest possible random value
    • hexdec — Hexadecimal to decimal
    • hypot — Calculate the length of the hypotenuse of a right-angle triangle
    • intdiv — Integer division
    • is_finite — Finds whether a value is a legal finite number
    • is_infinite — Finds whether a value is infinite
    • is_nan — Finds whether a value is not a number
    • lcg_value — Combined linear congruential generator
    • log10 — Base-10 logarithm
    • log1p — Returns log(1 + number), computed in a way that is accurate even when the value of number is close to zero
    • log — Natural logarithm
    • max — Find highest value
    • min — Find lowest value
    • mt_getrandmax — Show largest possible random value
    • mt_rand — Generate a random value via the Mersenne Twister Random Number Generator
    • mt_srand — Seeds the Mersenne Twister Random Number Generator
    • octdec — Octal to decimal
    • pi — Get value of pi
    • pow — Exponential expression
    • rad2deg — Converts the radian number to the equivalent number in degrees
    • rand — Generate a random integer
    • round — Rounds a float
    • sin — Sine
    • sinh — Hyperbolic sine
    • sqrt — Square root
    • srand — Seed the random number generator
    • tan — Tangent
    • tanh — Hyperbolic tangent
LapackException
Giriş
Matematiksel Eklentiler


Giriş

These math functions will only handle values within the range of the integer and float types on your computer (this corresponds currently to the C types long resp. double). If you need to handle bigger numbers, take a look at the arbitrary precision math functions.

See also the manual page on arithmetic operators.

Math
Yapılandırma/Kurulum
Math


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Math


Öntanımlı Sabitler

Aşağıdaki sabitler PHP çekirdeğinin parçası olarak daima kullanılabilir durumdadır.

Math constants
Constant | Value | Description | Availability
M_PI | 3.14159265358979323846 | Pi |
M_E | 2.7182818284590452354 | e |
M_LOG2E | 1.4426950408889634074 | log_2 e |
M_LOG10E | 0.43429448190325182765 | log_10 e |
M_LN2 | 0.69314718055994530942 | log_e 2 |
M_LN10 | 2.30258509299404568402 | log_e 10 |
M_PI_2 | 1.57079632679489661923 | pi/2 |
M_PI_4 | 0.78539816339744830962 | pi/4 |
M_1_PI | 0.31830988618379067154 | 1/pi |
M_2_PI | 0.63661977236758134308 | 2/pi |
M_SQRTPI | 1.77245385090551602729 | sqrt(pi) | PHP 5.2.0
M_2_SQRTPI | 1.12837916709551257390 | 2/sqrt(pi) |
M_SQRT2 | 1.41421356237309504880 | sqrt(2) |
M_SQRT3 | 1.73205080756887729352 | sqrt(3) | PHP 5.2.0
M_SQRT1_2 | 0.70710678118654752440 | 1/sqrt(2) |
M_LNPI | 1.14472988584940017414 | log_e(pi) | PHP 5.2.0
M_EULER | 0.57721566490153286061 | Euler constant | PHP 5.2.0
PHP_ROUND_HALF_UP | 1 | Round halves up | PHP 5.3.0
PHP_ROUND_HALF_DOWN | 2 | Round halves down | PHP 5.3.0
PHP_ROUND_HALF_EVEN | 3 | Round halves to even numbers | PHP 5.3.0
PHP_ROUND_HALF_ODD | 4 | Round halves to odd numbers | PHP 5.3.0
NAN | NAN (as a float) | Not A Number |
INF | INF (as a float) | The infinite |

All constants without a labeled PHP version above are available starting with PHP 5.0.0.

Özkaynak Türleri
Math İşlevleri
Math


Math İşlevleri

İçindekiler

  • abs — Absolute value
  • acos — Arc cosine
  • acosh — Inverse hyperbolic cosine
  • asin — Arc sine
  • asinh — Inverse hyperbolic sine
  • atan2 — Arc tangent of two variables
  • atan — Arc tangent
  • atanh — Inverse hyperbolic tangent
  • base_convert — Convert a number between arbitrary bases
  • bindec — Binary to decimal
  • ceil — Round fractions up
  • cos — Cosine
  • cosh — Hyperbolic cosine
  • decbin — Decimal to binary
  • dechex — Decimal to hexadecimal
  • decoct — Decimal to octal
  • deg2rad — Converts the number in degrees to the radian equivalent
  • exp — Calculates the exponent of e
  • expm1 — Returns exp(number) - 1, computed in a way that is accurate even when the value of number is close to zero
  • floor — Round fractions down
  • fmod — Returns the floating point remainder (modulo) of the division of the arguments
  • getrandmax — Show largest possible random value
  • hexdec — Hexadecimal to decimal
  • hypot — Calculate the length of the hypotenuse of a right-angle triangle
  • intdiv — Integer division
  • is_finite — Finds whether a value is a legal finite number
  • is_infinite — Finds whether a value is infinite
  • is_nan — Finds whether a value is not a number
  • lcg_value — Combined linear congruential generator
  • log10 — Base-10 logarithm
  • log1p — Returns log(1 + number), computed in a way that is accurate even when the value of number is close to zero
  • log — Natural logarithm
  • max — Find highest value
  • min — Find lowest value
  • mt_getrandmax — Show largest possible random value
  • mt_rand — Generate a random value via the Mersenne Twister Random Number Generator
  • mt_srand — Seeds the Mersenne Twister Random Number Generator
  • octdec — Octal to decimal
  • pi — Get value of pi
  • pow — Exponential expression
  • rad2deg — Converts the radian number to the equivalent number in degrees
  • rand — Generate a random integer
  • round — Rounds a float
  • sin — Sine
  • sinh — Hyperbolic sine
  • sqrt — Square root
  • srand — Seed the random number generator
  • tan — Tangent
  • tanh — Hyperbolic tangent
Öntanımlı Sabitler
abs
Math


Absolute value

Math İşlevleri
acos
Math İşlevleri
PHP Manual

abs

(PHP 4, PHP 5, PHP 7)

abs — Absolute value

Açıklama

number abs ( mixed $number )

Returns the absolute value of number.

Değiştirgeler

number

The numeric value to process

Dönen Değerler

The absolute value of number. If the argument number is of type float, the return type is also float, otherwise it is integer (as float usually has a bigger value range than integer).

Örnekler

Örnek 1 abs() example

<?php
echo abs(-4.2); // 4.2 (double/float)
echo abs(5);    // 5 (integer)
echo abs(-5);   // 5 (integer)
?>

Ayrıca Bakınız

  • gmp_abs() - Absolute value
  • gmp_sign() - Sign of number

Math İşlevleri
acos
Math İşlevleri


Arc cosine

abs
acosh
Math İşlevleri
PHP Manual

acos

(PHP 4, PHP 5, PHP 7)

acos — Arc cosine

Açıklama

float acos ( float $arg )

Returns the arc cosine of arg in radians. acos() is the complementary function of cos(), which means that a==cos(acos(a)) for every value of a that is within acos()' range.

Değiştirgeler

arg

The argument to process

Dönen Değerler

The arc cosine of arg in radians.

Ayrıca Bakınız

  • cos() - Cosine
  • acosh() - Inverse hyperbolic cosine
  • asin() - Arc sine
  • atan() - Arc tangent

abs
acosh
Math İşlevleri


Inverse hyperbolic cosine

acos
asin
Math İşlevleri
PHP Manual

acosh

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

acosh — Inverse hyperbolic cosine

Açıklama

float acosh ( float $arg )

Returns the inverse hyperbolic cosine of arg, i.e. the value whose hyperbolic cosine is arg.

Değiştirgeler

arg

The value to process

Dönen Değerler

The inverse hyperbolic cosine of arg

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | This function is now available on all platforms

Ayrıca Bakınız

  • cosh() - Hyperbolic cosine
  • acos() - Arc cosine
  • asinh() - Inverse hyperbolic sine
  • atanh() - Inverse hyperbolic tangent

acos
asin
Math İşlevleri


Arc sine

acosh
asinh
Math İşlevleri
PHP Manual

asin

(PHP 4, PHP 5, PHP 7)

asin — Arc sine

Açıklama

float asin ( float $arg )

Returns the arc sine of arg in radians. asin() is the complementary function of sin(), which means that a==sin(asin(a)) for every value of a that is within asin()'s range.

Değiştirgeler

arg

The argument to process

Dönen Değerler

The arc sine of arg in radians

Ayrıca Bakınız

  • sin() - Sine
  • asinh() - Inverse hyperbolic sine
  • acos() - Arc cosine
  • atan() - Arc tangent

acosh
asinh
Math İşlevleri


Inverse hyperbolic sine

asin
atan2
Math İşlevleri
PHP Manual

asinh

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

asinh — Inverse hyperbolic sine

Açıklama

float asinh ( float $arg )

Returns the inverse hyperbolic sine of arg, i.e. the value whose hyperbolic sine is arg.

Değiştirgeler

arg

The argument to process

Dönen Değerler

The inverse hyperbolic sine of arg

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | This function is now available on all platforms

Ayrıca Bakınız

  • sinh() - Hyperbolic sine
  • asin() - Arc sine
  • acosh() - Inverse hyperbolic cosine
  • atanh() - Inverse hyperbolic tangent

asin
atan2
Math İşlevleri


Arc tangent of two variables

asinh
atan
Math İşlevleri
PHP Manual

atan2

(PHP 4, PHP 5, PHP 7)

atan2 — Arc tangent of two variables

Açıklama

float atan2 ( float $y , float $x )

This function calculates the arc tangent of the two variables x and y. It is similar to calculating the arc tangent of y / x, except that the signs of both arguments are used to determine the quadrant of the result.

The function returns the result in radians, which is between -PI and PI (inclusive).

Değiştirgeler

y

Dividend parameter

x

Divisor parameter

Dönen Değerler

The arc tangent of y/x in radians.

Ayrıca Bakınız

  • atan() - Arc tangent

asinh
atan
Math İşlevleri


Arc tangent

atan2
atanh
Math İşlevleri
PHP Manual

atan

(PHP 4, PHP 5, PHP 7)

atan — Arc tangent

Açıklama

float atan ( float $arg )

Returns the arc tangent of arg in radians. atan() is the complementary function of tan(), which means that a==tan(atan(a)) for every value of a that is within atan()'s range.

Değiştirgeler

arg

The argument to process

Dönen Değerler

The arc tangent of arg in radians.

Ayrıca Bakınız

  • tan() - Tangent
  • atanh() - Inverse hyperbolic tangent
  • asin() - Arc sine
  • acos() - Arc cosine

atan2
atanh
Math İşlevleri


Inverse hyperbolic tangent

atan
base_convert
Math İşlevleri
PHP Manual

atanh

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

atanh — Inverse hyperbolic tangent

Açıklama

float atanh ( float $arg )

Returns the inverse hyperbolic tangent of arg, i.e. the value whose hyperbolic tangent is arg.

Değiştirgeler

arg

The argument to process

Dönen Değerler

Inverse hyperbolic tangent of arg

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | This function is now available on all platforms

Ayrıca Bakınız

  • tanh() - Hyperbolic tangent
  • atan() - Arc tangent
  • asinh() - Inverse hyperbolic sine
  • acosh() - Inverse hyperbolic cosine

atan
base_convert
Math İşlevleri


Convert a number between arbitrary bases

atanh
bindec
Math İşlevleri
PHP Manual

base_convert

(PHP 4, PHP 5, PHP 7)

base_convert — Convert a number between arbitrary bases

Açıklama

string base_convert ( string $number , int $frombase , int $tobase )

Returns a string containing number represented in base tobase. The base in which number is given is specified in frombase. Both frombase and tobase have to be between 2 and 36, inclusive. Digits in numbers with a base higher than 10 will be represented with the letters a-z, with a meaning 10, b meaning 11 and z meaning 35. The case of the letters doesn't matter, i.e. number is interpreted case-insensitively.

Uyarı

base_convert() may lose precision on large numbers due to properties related to the internal "double" or "float" type used. Please see the Floating point numbers section in the manual for more specific information and limitations.

Değiştirgeler

number

The number to convert. Any invalid characters in number are silently ignored.

frombase

The base number is in

tobase

The base to convert number to

Dönen Değerler

number converted to base tobase

Örnekler

Örnek 1 base_convert() example

<?php
$hexadecimal = 'a37334';
echo base_convert($hexadecimal, 16, 2);
?>

Yukarıdaki örneğin çıktısı:

101000110111001100110100

Ayrıca Bakınız

  • intval() - Bir değişkenin tamsayı değerini döndürür

atanh
bindec
Math İşlevleri


Binary to decimal

base_convert
ceil
Math İşlevleri
PHP Manual

bindec

(PHP 4, PHP 5, PHP 7)

bindec — Binary to decimal

Açıklama

number bindec ( string $binary_string )

Returns the decimal equivalent of the binary number represented by the binary_string argument.

bindec() converts a binary number to an integer or, if needed for size reasons, float.

bindec() interprets all binary_string values as unsigned integers. This is because bindec() sees the most significant bit as another order of magnitude rather than as the sign bit.

Değiştirgeler

binary_string

The binary string to convert

Uyarı

The parameter must be a string. Using other data types will produce unexpected results.

Dönen Değerler

The decimal value of binary_string

Örnekler

Örnek 1 bindec() example

<?php
echo bindec('110011') . "\n";
echo bindec('000110011') . "\n";

echo bindec('111');
?>

Yukarıdaki örneğin çıktısı:

51
51
7

Örnek 2 bindec() interprets input as unsigned integers

<?php
/*
 * The lesson from this example is in the output
 * rather than the PHP code itself.
 */

$magnitude_lower = pow(2, (PHP_INT_SIZE * 8) - 2);
p($magnitude_lower - 1);
p($magnitude_lower, 'See the rollover?  Watch it next time around...');

p(PHP_INT_MAX, 'PHP_INT_MAX');
p(~PHP_INT_MAX, 'interpreted to be one more than PHP_INT_MAX');

if (PHP_INT_SIZE == 4) {
    $note = 'interpreted to be the largest unsigned integer';
} else {
    $note = 'interpreted to be the largest unsigned integer
              (18446744073709551615) but skewed by float precision';
}
p(-1, $note);

function p($input, $note = '') {
    echo "input:        $input\n";

    $format = '%0' . (PHP_INT_SIZE * 8) . 'b';
    $bin = sprintf($format, $input);
    echo "binary:       $bin\n";

    ini_set('precision', 20);  // For readability on 64 bit boxes.
    $dec = bindec($bin);
    echo 'bindec():     ' . $dec . "\n";

    if ($note) {
        echo "NOTE:         $note\n";
    }

    echo "\n";
}
?>

Yukarıdaki örneğin 32 bitlik makinelerdeki çıktısı:

input:        1073741823
binary:       00111111111111111111111111111111
bindec():     1073741823

input:        1073741824
binary:       01000000000000000000000000000000
bindec():     1073741824
NOTE:         See the rollover?  Watch it next time around...

input:        2147483647
binary:       01111111111111111111111111111111
bindec():     2147483647
NOTE:         PHP_INT_MAX

input:        -2147483648
binary:       10000000000000000000000000000000
bindec():     2147483648
NOTE:         interpreted to be one more than PHP_INT_MAX

input:        -1
binary:       11111111111111111111111111111111
bindec():     4294967295
NOTE:         interpreted to be the largest unsigned integer

Yukarıdaki örneğin 64 bitlik makinelerdeki çıktısı:

input:        4611686018427387903
binary:       0011111111111111111111111111111111111111111111111111111111111111
bindec():     4611686018427387903

input:        4611686018427387904
binary:       0100000000000000000000000000000000000000000000000000000000000000
bindec():     4611686018427387904
NOTE:         See the rollover?  Watch it next time around...

input:        9223372036854775807
binary:       0111111111111111111111111111111111111111111111111111111111111111
bindec():     9223372036854775807
NOTE:         PHP_INT_MAX

input:        -9223372036854775808
binary:       1000000000000000000000000000000000000000000000000000000000000000
bindec():     9223372036854775808
NOTE:         interpreted to be one more than PHP_INT_MAX

input:        -1
binary:       1111111111111111111111111111111111111111111111111111111111111111
bindec():     18446744073709551616
NOTE:         interpreted to be the largest unsigned integer
              (18446744073709551615) but skewed by float precision

Notlar

Bilginize:

The function can convert numbers that are too large to fit into the platforms integer type, larger values are returned as float in that case.

Ayrıca Bakınız

  • decbin() - Decimal to binary
  • octdec() - Octal to decimal
  • hexdec() - Hexadecimal to decimal
  • base_convert() - Convert a number between arbitrary bases

base_convert
ceil
Math İşlevleri


Round fractions up

bindec
cos
Math İşlevleri
PHP Manual

ceil

(PHP 4, PHP 5, PHP 7)

ceil — Round fractions up

Açıklama

float ceil ( float $value )

Returns the next highest integer value by rounding up value if necessary.

Değiştirgeler

value

The value to round

Dönen Değerler

value rounded up to the next highest integer. The return value of ceil() is still of type float as the value range of float is usually bigger than that of integer.

Örnekler

Örnek 1 ceil() example

<?php
echo ceil(4.3);    // 5
echo ceil(9.999);  // 10
echo ceil(-3.14);  // -3
?>

Ayrıca Bakınız

  • floor() - Round fractions down
  • round() - Rounds a float

bindec
cos
Math İşlevleri


Cosine

ceil
cosh
Math İşlevleri
PHP Manual

cos

(PHP 4, PHP 5, PHP 7)

cos — Cosine

Açıklama

float cos ( float $arg )

cos() returns the cosine of the arg parameter. The arg parameter is in radians.

Değiştirgeler

arg

An angle in radians

Dönen Değerler

The cosine of arg

Örnekler

Örnek 1 cos() example

<?php

echo cos(M_PI); // -1

?>

Ayrıca Bakınız

  • acos() - Arc cosine
  • sin() - Sine
  • tan() - Tangent
  • deg2rad() - Converts the number in degrees to the radian equivalent

ceil
cosh
Math İşlevleri


Hyperbolic cosine

cos
decbin
Math İşlevleri
PHP Manual

cosh

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

cosh — Hyperbolic cosine

Açıklama

float cosh ( float $arg )

Returns the hyperbolic cosine of arg, defined as (exp(arg) + exp(-arg))/2.

Değiştirgeler

arg

The argument to process

Dönen Değerler

The hyperbolic cosine of arg

Ayrıca Bakınız

  • cos() - Cosine
  • acosh() - Inverse hyperbolic cosine
  • sinh() - Hyperbolic sine
  • cosh()

cos
decbin
Math İşlevleri


Decimal to binary

cosh
dechex
Math İşlevleri
PHP Manual

decbin

(PHP 4, PHP 5, PHP 7)

decbin — Decimal to binary

Açıklama

string decbin ( int $number )

Returns a string containing a binary representation of the given number argument.

Değiştirgeler

number

Decimal value to convert

Range of inputs on 32-bit machines
positive number | negative number | return value
0 | 0
1 | 1
2 | 10
... normal progression ...
2147483646 | 1111111111111111111111111111110
2147483647 (largest signed integer) | 1111111111111111111111111111111 (31 1's)
2147483648 | -2147483648 | 10000000000000000000000000000000
... normal progression ...
4294967294 | -2 | 11111111111111111111111111111110
4294967295 (largest unsigned integer) | -1 | 11111111111111111111111111111111 (32 1's)
Range of inputs on 64-bit machines
positive number | negative number | return value
0 | 0
1 | 1
2 | 10
... normal progression ...
9223372036854775806 | 111111111111111111111111111111111111111111111111111111111111110
9223372036854775807 (largest signed integer) | 111111111111111111111111111111111111111111111111111111111111111 (63 1's)
-9223372036854775808 | 1000000000000000000000000000000000000000000000000000000000000000
... normal progression ...
-2 | 1111111111111111111111111111111111111111111111111111111111111110
-1 | 1111111111111111111111111111111111111111111111111111111111111111 (64 1's)

Dönen Değerler

Binary string representation of number

Örnekler

Örnek 1 decbin() example

<?php
echo decbin(12) . "\n";
echo decbin(26);
?>

Yukarıdaki örneğin çıktısı:

1100
11010

Ayrıca Bakınız

  • bindec() - Binary to decimal
  • decoct() - Decimal to octal
  • dechex() - Decimal to hexadecimal
  • base_convert() - Convert a number between arbitrary bases
  • printf() - Biçemli bir dizge çıktılar, using %b, %032b or %064b as the format
  • sprintf(), using %b, %032b or %064b as the format

cosh
dechex
Math İşlevleri


Decimal to hexadecimal

decbin
decoct
Math İşlevleri
PHP Manual

dechex

(PHP 4, PHP 5, PHP 7)

dechex — Decimal to hexadecimal

Açıklama

string dechex ( int $number )

Returns a string containing a hexadecimal representation of the given unsigned number argument.

The largest number that can be converted is PHP_INT_MAX * 2 + 1 (or -1): on 32-bit platforms, this will be 4294967295 in decimal, which results in dechex() returning ffffffff.

Değiştirgeler

number

The decimal value to convert.

As PHP's integer type is signed, but dechex() deals with unsigned integers, negative integers will be treated as though they were unsigned.

Dönen Değerler

Hexadecimal string representation of number.

Örnekler

Örnek 1 dechex() example

<?php
echo dechex(10) . "\n";
echo dechex(47);
?>

Yukarıdaki örneğin çıktısı:

a
2f

Örnek 2 dechex() example with large integers

<?php
// The output below assumes a 32-bit platform.
// Note that the output is the same for all values.
echo dechex(-1)."\n";
echo dechex(PHP_INT_MAX * 2 + 1)."\n";
echo dechex(pow(2, 32) - 1)."\n";
?>

Yukarıdaki örneğin çıktısı:

ffffffff
ffffffff
ffffffff

Ayrıca Bakınız

  • hexdec() - Hexadecimal to decimal
  • decbin() - Decimal to binary
  • decoct() - Decimal to octal
  • base_convert() - Convert a number between arbitrary bases

decbin
decoct
Math İşlevleri


Decimal to octal

dechex
deg2rad
Math İşlevleri
PHP Manual

decoct

(PHP 4, PHP 5, PHP 7)

decoct — Decimal to octal

Açıklama

string decoct ( int $number )

Returns a string containing an octal representation of the given number argument. The largest number that can be converted depends on the platform in use. For 32-bit platforms this is usually 4294967295 in decimal resulting in 37777777777. For 64-bit platforms this is usually 9223372036854775807 in decimal resulting in 777777777777777777777.

Değiştirgeler

number

Decimal value to convert

Dönen Değerler

Octal string representation of number

Örnekler

Örnek 1 decoct() example

<?php
echo decoct(15) . "\n";
echo decoct(264);
?>

Yukarıdaki örneğin çıktısı:

17
410

Ayrıca Bakınız

  • octdec() - Octal to decimal
  • decbin() - Decimal to binary
  • dechex() - Decimal to hexadecimal
  • base_convert() - Convert a number between arbitrary bases

dechex
deg2rad
Math İşlevleri


Converts the number in degrees to the radian equivalent

decoct
exp
Math İşlevleri
PHP Manual

deg2rad

(PHP 4, PHP 5, PHP 7)

deg2rad — Converts the number in degrees to the radian equivalent

Açıklama

float deg2rad ( float $number )

This function converts number from degrees to the radian equivalent.

Değiştirgeler

number

Angular value in degrees

Dönen Değerler

The radian equivalent of number

Örnekler

Örnek 1 deg2rad() example

<?php

echo deg2rad(45); // 0.785398163397
var_dump(deg2rad(45) === M_PI_4); // bool(true)

?>

Ayrıca Bakınız

  • rad2deg() - Converts the radian number to the equivalent number in degrees

decoct
exp
Math İşlevleri


Calculates the exponent of e

deg2rad
expm1
Math İşlevleri
PHP Manual

exp

(PHP 4, PHP 5, PHP 7)

exp — Calculates the exponent of e

Açıklama

float exp ( float $arg )

Returns e raised to the power of arg.

Bilginize:

'e' is the base of the natural system of logarithms, or approximately 2.718282.

Değiştirgeler

arg

The argument to process

Dönen Değerler

'e' raised to the power of arg

Örnekler

Örnek 1 exp() example

<?php
echo exp(12) . "\n";
echo exp(5.7);
?>

Yukarıdaki örneğin çıktısı:

1.6275E+005
298.87

Ayrıca Bakınız

  • log() - Natural logarithm
  • pow() - Exponential expression

deg2rad
expm1
Math İşlevleri


Returns exp(number) - 1, computed in a way that is accurate even when the value of number is close to zero

exp
floor
Math İşlevleri
PHP Manual

expm1

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

expm1 — Returns exp(number) - 1, computed in a way that is accurate even when the value of number is close to zero

Açıklama

float expm1 ( float $arg )

expm1() returns the equivalent to 'exp(arg) - 1' computed in a way that is accurate even if the value of arg is near zero, a case where 'exp (arg) - 1' would be inaccurate due to subtraction of two numbers that are nearly equal.

Değiştirgeler

arg

The argument to process

Dönen Değerler

'e' to the power of arg minus one

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | This function is now available on all platforms

Ayrıca Bakınız

  • log1p() - Returns log(1 + number), computed in a way that is accurate even when the value of number is close to zero
  • exp() - Calculates the exponent of e

exp
floor
Math İşlevleri


Round fractions down

expm1
fmod
Math İşlevleri
PHP Manual

floor

(PHP 4, PHP 5, PHP 7)

floor — Round fractions down

Açıklama

mixed floor ( float $value )

Returns the next lowest integer value (as float) by rounding down value if necessary.

Değiştirgeler

value

The numeric value to round

Dönen Değerler

value rounded to the next lowest integer. The return value of floor() is still of type float because the value range of float is usually bigger than that of integer. This function returns FALSE in case of an error (e.g. passing an array).

Örnekler

Örnek 1 floor() example

<?php
echo floor(4.3);   // 4
echo floor(9.999); // 9
echo floor(-3.14); // -4
?>

Ayrıca Bakınız

  • ceil() - Round fractions up
  • round() - Rounds a float

expm1
fmod
Math İşlevleri


Returns the floating point remainder (modulo) of the division of the arguments

floor
getrandmax
Math İşlevleri
PHP Manual

fmod

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

fmod — Returns the floating point remainder (modulo) of the division of the arguments

Açıklama

float fmod ( float $x , float $y )

Returns the floating point remainder of dividing the dividend (x) by the divisor (y). The remainder (r) is defined as: x = i * y + r, for some integer i. If y is non-zero, r has the same sign as x and a magnitude less than the magnitude of y.

Değiştirgeler

x

The dividend

y

The divisor

Dönen Değerler

The floating point remainder of x/y

Örnekler

Örnek 1 Using fmod()

<?php
$x = 5.7;
$y = 1.3;
$r = fmod($x, $y);
// $r equals 0.5, because 4 * 1.3 + 0.5 = 5.7
?>

Ayrıca Bakınız

  • / - Floating-point division
  • % - Integer modulus
  • intdiv() - Integer division

floor
getrandmax
Math İşlevleri


Show largest possible random value

fmod
hexdec
Math İşlevleri
PHP Manual

getrandmax

(PHP 4, PHP 5, PHP 7)

getrandmax — Show largest possible random value

Açıklama

int getrandmax ( void )

Returns the maximum value that can be returned by a call to rand().

Dönen Değerler

The largest possible random value returned by rand()

Ayrıca Bakınız

  • rand() - Generate a random integer
  • srand() - Seed the random number generator
  • mt_getrandmax() - Show largest possible random value

fmod
hexdec
Math İşlevleri


Hexadecimal to decimal

getrandmax
hypot
Math İşlevleri
PHP Manual

hexdec

(PHP 4, PHP 5, PHP 7)

hexdec — Hexadecimal to decimal

Açıklama

number hexdec ( string $hex_string )

Returns the decimal equivalent of the hexadecimal number represented by the hex_string argument. hexdec() converts a hexadecimal string to a decimal number.

hexdec() will ignore any non-hexadecimal characters it encounters.

Değiştirgeler

hex_string

The hexadecimal string to convert

Dönen Değerler

The decimal representation of hex_string

Örnekler

Örnek 1 hexdec() example

<?php
var_dump(hexdec("See"));
var_dump(hexdec("ee"));
// both print "int(238)"

var_dump(hexdec("that")); // print "int(10)"
var_dump(hexdec("a0")); // print "int(160)"
?>

Notlar

Bilginize:

The function can convert numbers that are too large to fit into the platforms integer type, larger values are returned as float in that case.

Ayrıca Bakınız

  • dechex() - Decimal to hexadecimal
  • bindec() - Binary to decimal
  • octdec() - Octal to decimal
  • base_convert() - Convert a number between arbitrary bases

getrandmax
hypot
Math İşlevleri


Calculate the length of the hypotenuse of a right-angle triangle

hexdec
intdiv
Math İşlevleri
PHP Manual

hypot

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

hypot — Calculate the length of the hypotenuse of a right-angle triangle

Açıklama

float hypot ( float $x , float $y )

hypot() returns the length of the hypotenuse of a right-angle triangle with sides of length x and y, or the distance of the point (x, y) from the origin. This is equivalent to sqrt(x*x + y*y).

Değiştirgeler

x

Length of first side

y

Length of second side

Dönen Değerler

Calculated length of the hypotenuse

hexdec
intdiv
Math İşlevleri


Integer division

hypot
is_finite
Math İşlevleri
PHP Manual

intdiv

(PHP 7)

intdiv — Integer division

Açıklama

int intdiv ( int $dividend , int $divisor )

Returns the integer quotient of the division of dividend by divisor.

Değiştirgeler

dividend

Number to be divided.

divisor

Number which divides the dividend.

Dönen Değerler

The integer quotient of the division of dividend by divisor.

Hatalar/İstisnalar

If divisor is 0, a DivisionByZeroError exception is thrown. If the dividend is PHP_INT_MIN and the divisor is -1, then an ArithmeticError exception is thrown.

Örnekler

Örnek 1 intdiv() example

<?php
var_dump(intdiv(3, 2));
var_dump(intdiv(-3, 2));
var_dump(intdiv(3, -2));
var_dump(intdiv(-3, -2));
var_dump(intdiv(PHP_INT_MAX, PHP_INT_MAX));
var_dump(intdiv(PHP_INT_MIN, PHP_INT_MIN));
var_dump(intdiv(PHP_INT_MIN, -1));
var_dump(intdiv(1, 0));
?>
int(1)
int(-1)
int(-1)
int(1)
int(1)
int(1)

Fatal error: Uncaught ArithmeticError: Division of PHP_INT_MIN by -1 is not an integer in %s on line 8
Fatal error: Uncaught DivisionByZeroError: Division by zero in %s on line 9

Ayrıca Bakınız

  • / - Floating-point division
  • % - Integer modulus
  • fmod() - Floating-point modulo

hypot
is_finite
Math İşlevleri


Finds whether a value is a legal finite number

intdiv
is_infinite
Math İşlevleri
PHP Manual

is_finite

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

is_finite — Finds whether a value is a legal finite number

Açıklama

bool is_finite ( float $val )

Checks whether val is a legal finite on this platform.

Değiştirgeler

val

The value to check

Dönen Değerler

TRUE if val is a legal finite number within the allowed range for a PHP float on this platform, else FALSE.

Ayrıca Bakınız

  • is_infinite() - Finds whether a value is infinite
  • is_nan() - Finds whether a value is not a number

intdiv
is_infinite
Math İşlevleri


Finds whether a value is infinite

is_finite
is_nan
Math İşlevleri
PHP Manual

is_infinite

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

is_infinite — Finds whether a value is infinite

Açıklama

bool is_infinite ( float $val )

Returns TRUE if val is infinite (positive or negative), like the result of log(0) or any value too big to fit into a float on this platform.

Değiştirgeler

val

The value to check

Dönen Değerler

TRUE if val is infinite, else FALSE.

Ayrıca Bakınız

  • is_finite() - Finds whether a value is a legal finite number
  • is_nan() - Finds whether a value is not a number

is_finite
is_nan
Math İşlevleri


Finds whether a value is not a number

is_infinite
lcg_value
Math İşlevleri
PHP Manual

is_nan

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

is_nan — Finds whether a value is not a number

Açıklama

bool is_nan ( float $val )

Checks whether val is 'not a number', like the result of acos(1.01).

Değiştirgeler

val

The value to check

Dönen Değerler

Returns TRUE if val is 'not a number', else FALSE.

Örnekler

Örnek 1 is_nan() example

<?php
// Invalid calculation, will return a
// NaN value
$nan = acos(8);

var_dump($nan, is_nan($nan));
?>

Yukarıdaki örneğin çıktısı:

float(NAN)
bool(true)

Ayrıca Bakınız

  • is_finite() - Finds whether a value is a legal finite number
  • is_infinite() - Finds whether a value is infinite

is_infinite
lcg_value
Math İşlevleri


Combined linear congruential generator

is_nan
log10
Math İşlevleri
PHP Manual

lcg_value

(PHP 4, PHP 5, PHP 7)

lcg_value — Combined linear congruential generator

Açıklama

float lcg_value ( void )

lcg_value() returns a pseudo random number in the range of (0, 1). The function combines two CGs with periods of 2^31 - 85 and 2^31 - 249. The period of this function is equal to the product of both primes.

Dikkat

Bu işlev kriptografik olarak güvenilir değerler üretmez ve kriptografik amaçlarla kullanılmamalıdır. Kriptografik olarak güvenilir bir değere ihtiyaç duyuyorsanız bunun yerine random_int(), random_bytes() veya openssl_random_pseudo_bytes() işlevini deneyebilirsiniz.

Dönen Değerler

A pseudo random float value in the range of (0, 1)

Ayrıca Bakınız

  • rand() - Generate a random integer
  • mt_rand() - Generate a random value via the Mersenne Twister Random Number Generator

is_nan
log10
Math İşlevleri


Base-10 logarithm

lcg_value
log1p
Math İşlevleri
PHP Manual

log10

(PHP 4, PHP 5, PHP 7)

log10 — Base-10 logarithm

Açıklama

float log10 ( float $arg )

Returns the base-10 logarithm of arg.

Değiştirgeler

arg

The argument to process

Dönen Değerler

The base-10 logarithm of arg

Ayrıca Bakınız

  • log() - Natural logarithm

lcg_value
log1p
Math İşlevleri


Returns log(1 + number), computed in a way that is accurate even when the value of number is close to zero

log10
log
Math İşlevleri
PHP Manual

log1p

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

log1p — Returns log(1 + number), computed in a way that is accurate even when the value of number is close to zero

Açıklama

float log1p ( float $number )

log1p() returns log(1 + number) computed in a way that is accurate even when the value of number is close to zero. log() might only return log(1) in this case due to lack of precision.

Değiştirgeler

number

The argument to process

Dönen Değerler

log(1 + number)

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | This function is now available on all platforms

Ayrıca Bakınız

  • expm1() - Returns exp(number) - 1, computed in a way that is accurate even when the value of number is close to zero
  • log() - Natural logarithm
  • log10() - Base-10 logarithm

log10
log
Math İşlevleri


Natural logarithm

log1p
max
Math İşlevleri
PHP Manual

log

(PHP 4, PHP 5, PHP 7)

log — Natural logarithm

Açıklama

float log ( float $arg [, float $base = M_E ] )

If the optional base parameter is specified, log() returns logbase arg, otherwise log() returns the natural logarithm of arg.

Değiştirgeler

arg

The value to calculate the logarithm for

base

The optional logarithmic base to use (defaults to 'e' and so to the natural logarithm).

Dönen Değerler

The logarithm of arg to base, if given, or the natural logarithm.

Ayrıca Bakınız

  • log10() - Base-10 logarithm
  • exp() - Calculates the exponent of e
  • pow() - Exponential expression

log1p
max
Math İşlevleri


Find highest value

log
min
Math İşlevleri
PHP Manual

max

(PHP 4, PHP 5, PHP 7)

max — Find highest value

Açıklama

mixed max ( array $values )
mixed max ( mixed $value1 , mixed $value2 [, mixed $... ] )

If the first and only parameter is an array, max() returns the highest value in that array. If at least two parameters are provided, max() returns the biggest of these values.

Bilginize:

Values of different types will be compared using the standard comparison rules. For instance, a non-numeric string will be compared to an integer as though it were 0, but multiple non-numeric string values will be compared alphanumerically. The actual value returned will be of the original type with no conversion applied.

Dikkat

Be careful when passing arguments with mixed types values because max() can produce unpredictable results.

Değiştirgeler

values

An array containing the values.

value1

Any comparable value.

value2

Any comparable value.

...

Any comparable value.

Dönen Değerler

max() returns the parameter value considered "highest" according to standard comparisons. If multiple values of different types evaluate as equal (e.g. 0 and 'abc') the first provided to the function will be returned.

If an empty array is passed, then FALSE will be returned and an E_WARNING error will be emitted.

Örnekler

Örnek 1 Example uses of max()

<?php
echo max(2, 3, 1, 6, 7);  // 7
echo max(array(2, 4, 5)); // 5

// The string 'hello' when compared to an int is treated as 0
// Since the two values are equal, the order they are provided determines the result
echo max(0, 'hello');     // 0
echo max('hello', 0);     // hello

// Here we are comparing -1 < 0, so 'hello' is the highest value
echo max('hello', -1);    // hello

// With multiple arrays of different lengths, max returns the longest
$val = max(array(2, 2, 2), array(1, 1, 1, 1)); // array(1, 1, 1, 1)

// Multiple arrays of the same length are compared from left to right
// so in our example: 2 == 2, but 5 > 4
$val = max(array(2, 4, 8), array(2, 5, 1)); // array(2, 5, 1)

// If both an array and non-array are given, the array will be returned
// as comparisons treat arrays as greater than any other value
$val = max('string', array(2, 5, 7), 42);   // array(2, 5, 7)

// If one argument is NULL or a boolean, it will be compared against
// other values using the rule FALSE < TRUE regardless of the other types involved
// In the below example, -10 is treated as TRUE in the comparison
$val = max(-10, FALSE); // -10

// 0, on the other hand, is treated as FALSE, so is "lower than" TRUE
$val = max(0, TRUE); // TRUE
?>

Ayrıca Bakınız

  • min() - Find lowest value
  • count() - Bir dizideki eleman sayısını veya bir nesnedeki özellik sayısını döndürür

log
min
Math İşlevleri


Find lowest value

max
mt_getrandmax
Math İşlevleri
PHP Manual

min

(PHP 4, PHP 5, PHP 7)

min — Find lowest value

Açıklama

mixed min ( array $values )
mixed min ( mixed $value1 , mixed $value2 [, mixed $... ] )

If the first and only parameter is an array, min() returns the lowest value in that array. If at least two parameters are provided, min() returns the smallest of these values.

Bilginize:

Values of different types will be compared using the standard comparison rules. For instance, a non-numeric string will be compared to an integer as though it were 0, but multiple non-numeric string values will be compared alphanumerically. The actual value returned will be of the original type with no conversion applied.

Dikkat

Be careful when passing arguments with mixed types values because min() can produce unpredictable results.

Değiştirgeler

values

An array containing the values.

value1

Any comparable value.

value2

Any comparable value.

...

Any comparable value.

Dönen Değerler

min() returns the parameter value considered "lowest" according to standard comparisons. If multiple values of different types evaluate as equal (e.g. 0 and 'abc') the first provided to the function will be returned.

If an empty array is passed, then FALSE will be returned and an E_WARNING error will be emitted.

Örnekler

Örnek 1 Example uses of min()

<?php
echo min(2, 3, 1, 6, 7);  // 1
echo min(array(2, 4, 5)); // 2

// The string 'hello' when compared to an int is treated as 0
// Since the two values are equal, the order they are provided determines the result
echo min(0, 'hello');     // 0
echo min('hello', 0);     // hello

// Here we are comparing -1 < 0, so -1 is the lowest value
echo min('hello', -1);    // -1

// With multiple arrays of different lengths, min returns the shortest
$val = min(array(2, 2, 2), array(1, 1, 1, 1)); // array(2, 2, 2)

// Multiple arrays of the same length are compared from left to right
// so in our example: 2 == 2, but 4 < 5
$val = min(array(2, 4, 8), array(2, 5, 1)); // array(2, 4, 8)

// If both an array and non-array are given, the array is never returned
// as comparisons treat arrays as greater than any other value
$val = min('string', array(2, 5, 7), 42);   // string

// If one argument is NULL or a boolean, it will be compared against
// other values using the rules FALSE < TRUE and NULL == FALSE regardless of the
// other types involved
// In the below examples, both -10 and 10 are treated as TRUE in the comparison
$val = min(-10, FALSE, 10); // FALSE
$val = min(-10, NULL, 10);  // NULL

// 0, on the other hand, is treated as FALSE, so is "lower than" TRUE
$val = min(0, TRUE); // 0
?>

Ayrıca Bakınız

  • max() - Find highest value
  • count() - Bir dizideki eleman sayısını veya bir nesnedeki özellik sayısını döndürür

max
mt_getrandmax
Math İşlevleri


Show largest possible random value

min
mt_rand
Math İşlevleri
PHP Manual

mt_getrandmax

(PHP 4, PHP 5, PHP 7)

mt_getrandmax — Show largest possible random value

Açıklama

int mt_getrandmax ( void )

Returns the maximum value that can be returned by a call to mt_rand().

Dönen Değerler

Returns the maximum random value returned by a call to mt_rand() without arguments, which is the maximum value that can be used for its max parameter without the result being scaled up (and therefore less random).

Örnekler

Örnek 1 Calculate a random floating-point number

<?php
function randomFloat($min = 0, $max = 1) {
    return $min + mt_rand() / mt_getrandmax() * ($max - $min);
}

var_dump(randomFloat());
var_dump(randomFloat(2, 20));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

float(0.91601131712832)
float(16.511210331931)

Ayrıca Bakınız

  • mt_rand() - Generate a random value via the Mersenne Twister Random Number Generator
  • mt_srand() - Seeds the Mersenne Twister Random Number Generator
  • getrandmax() - Show largest possible random value

min
mt_rand
Math İşlevleri


Generate a random value via the Mersenne Twister Random Number Generator

mt_getrandmax
mt_srand
Math İşlevleri
PHP Manual

mt_rand

(PHP 4, PHP 5, PHP 7)

mt_rand — Generate a random value via the Mersenne Twister Random Number Generator

Açıklama

int mt_rand ( void )
int mt_rand ( int $min , int $max )
Dikkat

Bu işlev kriptografik olarak güvenilir değerler üretmez ve kriptografik amaçlarla kullanılmamalıdır. Kriptografik olarak güvenilir bir değere ihtiyaç duyuyorsanız bunun yerine random_int(), random_bytes() veya openssl_random_pseudo_bytes() işlevini deneyebilirsiniz.

Many random number generators of older libcs have dubious or unknown characteristics and are slow. The mt_rand() function is a drop-in replacement for the older rand(). It uses a random number generator with known characteristics using the » Mersenne Twister, which will produce random numbers four times faster than what the average libc rand() provides.

If called without the optional min, max arguments mt_rand() returns a pseudo-random value between 0 and mt_getrandmax(). If you want a random number between 5 and 15 (inclusive), for example, use mt_rand(5, 15).

Değiştirgeler

min

Optional lowest value to be returned (default: 0)

max

Optional highest value to be returned (default: mt_getrandmax())

Dönen Değerler

A random integer value between min (or 0) and max (or mt_getrandmax(), inclusive), or FALSE if max is less than min.

Sürüm Bilgisi

Sürüm: | Açıklama
7.1.0 | rand() has been made an alias of mt_rand().
7.1.0 | mt_rand()has been updated to use the fixed, correct, version of the Mersenne Twister algorithm. To fall back to the old behaviour, use mt_srand() with MT_RAND_PHP as the second paramter.
5.3.4 | Issues an E_WARNING and returns FALSE if max < min.

Örnekler

Örnek 1 mt_rand() example

<?php
echo mt_rand() . "\n";
echo mt_rand() . "\n";

echo mt_rand(5, 15);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

1604716014
1478613278
6

Notlar

Uyarı

min max range must be within the range mt_getrandmax(). i.e. (max - min) <= mt_getrandmax() Otherwise, mt_rand() may return poor random numbers than it should be.

Ayrıca Bakınız

  • mt_srand() - Seeds the Mersenne Twister Random Number Generator
  • mt_getrandmax() - Show largest possible random value
  • random_int() - Generates cryptographically secure pseudo-random integers
  • random_bytes() - Generates cryptographically secure pseudo-random bytes
  • openssl_random_pseudo_bytes() - Yarı-rasgele dizge üretir
  • rand() - Generate a random integer

mt_getrandmax
mt_srand
Math İşlevleri


Seeds the Mersenne Twister Random Number Generator

mt_rand
octdec
Math İşlevleri
PHP Manual

mt_srand

(PHP 4, PHP 5, PHP 7)

mt_srand — Seeds the Mersenne Twister Random Number Generator

Açıklama

void mt_srand ([ int $seed [, int $mode = MT_RAND_MT19937 ]] )

Seeds the random number generator with seed or with a random value if no seed is given.

Bilginize: Özdevinimli olarak yapıldığından srand() veya mt_srand() işleviyle rasgele sayı üretecini tohumlamaya ihtiyaç yoktur.

Değiştirgeler

seed

An arbitrary integer seed value.

mode

Use one of the following constants to specify the implementation of the algorithm to use.

Constant | Açıklama
MT_RAND_MT19937 | Uses the fixed, correct, Mersenne Twister implementation, available as of PHP 7.1.0.
MT_RAND_PHP | Uses an incorrect Mersenne Twister implementation which was used as the default up till PHP 7.1.0. This mode is available for backward compatibility.

Dönen Değerler

Hiçbir değer dönmez.

Sürüm Bilgisi

Sürüm: | Açıklama
7.1.0 | srand() has been made an alias of mt_srand().
7.1.0 | mt_rand()has been updated to use the fixed, correct, version of the Mersenne Twister algorithm. To fall back to the old behaviour, use mt_srand() with MT_RAND_PHP as the second paramter.
5.2.1 | The Mersenne Twister implementation in PHP now uses a new seeding algorithm by Richard Wagner. Identical seeds no longer produce the same sequence of values they did in previous versions. This behavior is not expected to change again, but it is considered unsafe to rely upon it nonetheless.

Örnekler

Örnek 1 mt_srand() example

<?php
// seed with microseconds
function make_seed()
{
  list($usec, $sec) = explode(' ', microtime());
  return $sec + $usec * 1000000;
}
mt_srand(make_seed());
$randval = mt_rand();
?>

Ayrıca Bakınız

  • mt_rand() - Generate a random value via the Mersenne Twister Random Number Generator
  • mt_getrandmax() - Show largest possible random value
  • srand() - Seed the random number generator

mt_rand
octdec
Math İşlevleri


Octal to decimal

mt_srand
pi
Math İşlevleri
PHP Manual

octdec

(PHP 4, PHP 5, PHP 7)

octdec — Octal to decimal

Açıklama

number octdec ( string $octal_string )

Returns the decimal equivalent of the octal number represented by the octal_string argument.

Değiştirgeler

octal_string

The octal string to convert

Dönen Değerler

The decimal representation of octal_string

Örnekler

Örnek 1 octdec() example

<?php
echo octdec('77') . "\n";
echo octdec(decoct(45));
?>

Yukarıdaki örneğin çıktısı:

63
45

Notlar

Bilginize:

The function can convert numbers that are too large to fit into the platforms integer type, larger values are returned as float in that case.

Ayrıca Bakınız

  • decoct() - Decimal to octal
  • bindec() - Binary to decimal
  • hexdec() - Hexadecimal to decimal
  • base_convert() - Convert a number between arbitrary bases

mt_srand
pi
Math İşlevleri


Get value of pi

octdec
pow
Math İşlevleri
PHP Manual

pi

(PHP 4, PHP 5, PHP 7)

pi — Get value of pi

Açıklama

float pi ( void )

Returns an approximation of pi. The returned float has a precision based on the precision directive in php.ini, which defaults to 14. Also, you can use the M_PI constant which yields identical results to pi().

Dönen Değerler

The value of pi as float.

Örnekler

Örnek 1 pi() example

<?php
echo pi(); // 3.1415926535898
echo M_PI; // 3.1415926535898
?>

octdec
pow
Math İşlevleri


Exponential expression

pi
rad2deg
Math İşlevleri
PHP Manual

pow

(PHP 4, PHP 5, PHP 7)

pow — Exponential expression

Açıklama

number pow ( number $base , number $exp )

Returns base raised to the power of exp.

Bilginize:

In PHP 5.6 onwards, you may prefer to use the ** operator.

Değiştirgeler

base

The base to use

exp

The exponent

Dönen Değerler

base raised to the power of exp. If both arguments are non-negative integers and the result can be represented as an integer, the result will be returned with integer type, otherwise it will be returned as a float.

Örnekler

Örnek 1 Some examples of pow()

<?php

var_dump(pow(2, 8)); // int(256)
echo pow(-1, 20); // 1
echo pow(0, 0); // 1
echo pow(10, -1); // 0.1

echo pow(-1, 5.5); // PHP >=5.2.2: NAN
echo pow(-1, 5.5); // PHP <5.2.2: -NAN
?>

Notlar

Bilginize:

This function will convert all input to a number, even non-scalar values, which could lead to weird results.

Ayrıca Bakınız

  • exp() - Calculates the exponent of e
  • sqrt() - Square root
  • bcpow() - Keyfi duyarlıklı sayılar için üs alma işlemi yapar
  • gmp_pow() - Raise number into power

pi
rad2deg
Math İşlevleri


Converts the radian number to the equivalent number in degrees

pow
rand
Math İşlevleri
PHP Manual

rad2deg

(PHP 4, PHP 5, PHP 7)

rad2deg — Converts the radian number to the equivalent number in degrees

Açıklama

float rad2deg ( float $number )

This function converts number from radian to degrees.

Değiştirgeler

number

A radian value

Dönen Değerler

The equivalent of number in degrees

Örnekler

Örnek 1 rad2deg() example

<?php

echo rad2deg(M_PI_4); // 45

?>

Ayrıca Bakınız

  • deg2rad() - Converts the number in degrees to the radian equivalent

pow
rand
Math İşlevleri


Generate a random integer

rad2deg
round
Math İşlevleri
PHP Manual

rand

(PHP 4, PHP 5, PHP 7)

rand — Generate a random integer

Açıklama

int rand ( void )
int rand ( int $min , int $max )

If called without the optional min, max arguments rand() returns a pseudo-random integer between 0 and getrandmax(). If you want a random number between 5 and 15 (inclusive), for example, use rand(5, 15).

Dikkat

Bu işlev kriptografik olarak güvenilir değerler üretmez ve kriptografik amaçlarla kullanılmamalıdır. Kriptografik olarak güvenilir bir değere ihtiyaç duyuyorsanız bunun yerine random_int(), random_bytes() veya openssl_random_pseudo_bytes() işlevini deneyebilirsiniz.

Bilginize: On some platforms (such as Windows), getrandmax() is only 32767. If you require a range larger than 32767, specifying min and max will allow you to create a range larger than this, or consider using mt_rand() instead.

Bilginize: As of PHP 7.1.0, rand() has been made an alias of mt_rand().

Değiştirgeler

min

The lowest value to return (default: 0)

max

The highest value to return (default: getrandmax())

Dönen Değerler

A pseudo random value between min (or 0) and max (or getrandmax(), inclusive).

Sürüm Bilgisi

Sürüm: | Açıklama
7.1.0 | rand() has been made an alias of mt_rand().

Örnekler

Örnek 1 rand() example

<?php
echo rand() . "\n";
echo rand() . "\n";

echo rand(5, 15);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

7771
22264
11

Notlar

Uyarı

min max range must be within the range getrandmax(). i.e. (max - min) <= getrandmax() Otherwise, rand() may return poor-quality random numbers.

Ayrıca Bakınız

  • srand() - Seed the random number generator
  • getrandmax() - Show largest possible random value
  • mt_rand() - Generate a random value via the Mersenne Twister Random Number Generator
  • random_int() - Generates cryptographically secure pseudo-random integers
  • random_bytes() - Generates cryptographically secure pseudo-random bytes
  • openssl_random_pseudo_bytes() - Yarı-rasgele dizge üretir

rad2deg
round
Math İşlevleri


Rounds a float

rand
sin
Math İşlevleri
PHP Manual

round

(PHP 4, PHP 5, PHP 7)

round — Rounds a float

Açıklama

float round ( float $val [, int $precision = 0 [, int $mode = PHP_ROUND_HALF_UP ]] )

Returns the rounded value of val to specified precision (number of digits after the decimal point). precision can also be negative or zero (default).

Bilginize: PHP doesn't handle strings like "12,300.2" correctly by default. See converting from strings.

Değiştirgeler

val

The value to round

precision

The optional number of decimal digits to round to.

mode

Use one of the following constants to specify the mode in which rounding occurs.

Constant | Açıklama
PHP_ROUND_HALF_UP | Round val up to precision decimal places away from zero, when it is half way there. Making 1.5 into 2 and -1.5 into -2.
PHP_ROUND_HALF_DOWN | Round val down to precision decimal places towards zero, when it is half way there. Making 1.5 into 1 and -1.5 into -1.
PHP_ROUND_HALF_EVEN | Round val to precision decimal places towards the next even value.
PHP_ROUND_HALF_ODD | Round val to precision decimal places towards the next odd value.

Dönen Değerler

The rounded value

Örnekler

Örnek 1 round() examples

<?php
echo round(3.4);         // 3
echo round(3.5);         // 4
echo round(3.6);         // 4
echo round(3.6, 0);      // 4
echo round(1.95583, 2);  // 1.96
echo round(1241757, -3); // 1242000
echo round(5.045, 2);    // 5.05
echo round(5.055, 2);    // 5.06
?>

Örnek 2 mode examples

<?php
echo round(9.5, 0, PHP_ROUND_HALF_UP);   // 10
echo round(9.5, 0, PHP_ROUND_HALF_DOWN); // 9
echo round(9.5, 0, PHP_ROUND_HALF_EVEN); // 10
echo round(9.5, 0, PHP_ROUND_HALF_ODD);  // 9

echo round(8.5, 0, PHP_ROUND_HALF_UP);   // 9
echo round(8.5, 0, PHP_ROUND_HALF_DOWN); // 8
echo round(8.5, 0, PHP_ROUND_HALF_EVEN); // 8
echo round(8.5, 0, PHP_ROUND_HALF_ODD);  // 9
?>

Örnek 3 mode with precision examples

<?php
/* Using PHP_ROUND_HALF_UP with 1 decimal digit precision */
echo round( 1.55, 1, PHP_ROUND_HALF_UP);   //  1.6
echo round( 1.54, 1, PHP_ROUND_HALF_UP);   //  1.5
echo round(-1.55, 1, PHP_ROUND_HALF_UP);   // -1.6
echo round(-1.54, 1, PHP_ROUND_HALF_UP);   // -1.5

/* Using PHP_ROUND_HALF_DOWN with 1 decimal digit precision */
echo round( 1.55, 1, PHP_ROUND_HALF_DOWN); //  1.5
echo round( 1.54, 1, PHP_ROUND_HALF_DOWN); //  1.5
echo round(-1.55, 1, PHP_ROUND_HALF_DOWN); // -1.5
echo round(-1.54, 1, PHP_ROUND_HALF_DOWN); // -1.5

/* Using PHP_ROUND_HALF_EVEN with 1 decimal digit precision */
echo round( 1.55, 1, PHP_ROUND_HALF_EVEN); //  1.6
echo round( 1.54, 1, PHP_ROUND_HALF_EVEN); //  1.5
echo round(-1.55, 1, PHP_ROUND_HALF_EVEN); // -1.6
echo round(-1.54, 1, PHP_ROUND_HALF_EVEN); // -1.5

/* Using PHP_ROUND_HALF_ODD with 1 decimal digit precision */
echo round( 1.55, 1, PHP_ROUND_HALF_ODD);  //  1.5
echo round( 1.54, 1, PHP_ROUND_HALF_ODD);  //  1.5
echo round(-1.55, 1, PHP_ROUND_HALF_ODD);  // -1.5
echo round(-1.54, 1, PHP_ROUND_HALF_ODD);  // -1.5
?>

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | The mode parameter was introduced.
5.2.7 | The inner workings of round() was changed to conform to the C99 standard.

Ayrıca Bakınız

  • ceil() - Round fractions up
  • floor() - Round fractions down
  • number_format() - Sayıyı binlik bölümlere ayırır

rand
sin
Math İşlevleri


Sine

round
sinh
Math İşlevleri
PHP Manual

sin

(PHP 4, PHP 5, PHP 7)

sin — Sine

Açıklama

float sin ( float $arg )

sin() returns the sine of the arg parameter. The arg parameter is in radians.

Değiştirgeler

arg

A value in radians

Dönen Değerler

The sine of arg

Örnekler

Örnek 1 sin() example

<?php

// Precision depends on your precision directive
echo sin(deg2rad(60));  //  0.866025403 ...
echo sin(60);           // -0.304810621 ...

?>

Ayrıca Bakınız

  • asin() - Arc sine
  • sinh() - Hyperbolic sine
  • cos() - Cosine
  • tan() - Tangent
  • deg2rad() - Converts the number in degrees to the radian equivalent

round
sinh
Math İşlevleri


Hyperbolic sine

sin
sqrt
Math İşlevleri
PHP Manual

sinh

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

sinh — Hyperbolic sine

Açıklama

float sinh ( float $arg )

Returns the hyperbolic sine of arg, defined as (exp(arg) - exp(-arg))/2.

Değiştirgeler

arg

The argument to process

Dönen Değerler

The hyperbolic sine of arg

Ayrıca Bakınız

  • sin() - Sine
  • asinh() - Inverse hyperbolic sine
  • cosh() - Hyperbolic cosine
  • tanh() - Hyperbolic tangent

sin
sqrt
Math İşlevleri


Square root

sinh
srand
Math İşlevleri
PHP Manual

sqrt

(PHP 4, PHP 5, PHP 7)

sqrt — Square root

Açıklama

float sqrt ( float $arg )

Returns the square root of arg.

Değiştirgeler

arg

The argument to process

Dönen Değerler

The square root of arg or the special value NAN for negative numbers.

Örnekler

Örnek 1 sqrt() example

<?php
// Precision depends on your precision directive
echo sqrt(9); // 3
echo sqrt(10); // 3.16227766 ...
?>

Ayrıca Bakınız

  • pow() - Exponential expression

sinh
srand
Math İşlevleri


Seed the random number generator

sqrt
tan
Math İşlevleri
PHP Manual

srand

(PHP 4, PHP 5, PHP 7)

srand — Seed the random number generator

Açıklama

void srand ([ int $seed ] )

Seeds the random number generator with seed or with a random value if no seed is given.

Bilginize: Özdevinimli olarak yapıldığından srand() veya mt_srand() işleviyle rasgele sayı üretecini tohumlamaya ihtiyaç yoktur.

Bilginize: As of PHP 7.1.0, srand() has been made an alias of mt_srand().

Değiştirgeler

seed

An arbitrary integer seed value.

Dönen Değerler

Hiçbir değer dönmez.

Sürüm Bilgisi

Sürüm: | Açıklama
7.1.0 | srand() has been made an alias of mt_srand().

Örnekler

Örnek 1 srand() example

<?php
// seed with microseconds
function make_seed()
{
  list($usec, $sec) = explode(' ', microtime());
  return $sec + $usec * 1000000;
}
srand(make_seed());
$randval = rand();
?>

Ayrıca Bakınız

  • rand() - Generate a random integer
  • getrandmax() - Show largest possible random value
  • mt_srand() - Seeds the Mersenne Twister Random Number Generator

sqrt
tan
Math İşlevleri


Tangent

srand
tanh
Math İşlevleri
PHP Manual

tan

(PHP 4, PHP 5, PHP 7)

tan — Tangent

Açıklama

float tan ( float $arg )

tan() returns the tangent of the arg parameter. The arg parameter is in radians.

Değiştirgeler

arg

The argument to process in radians

Dönen Değerler

The tangent of arg

Örnekler

Örnek 1 tan() example

<?php

echo tan(M_PI_4); // 1

?>

Ayrıca Bakınız

  • atan() - Arc tangent
  • atan2() - Arc tangent of two variables
  • sin() - Sine
  • cos() - Cosine
  • tanh() - Hyperbolic tangent
  • deg2rad() - Converts the number in degrees to the radian equivalent

srand
tanh
Math İşlevleri


Hyperbolic tangent

tan
Statistics
Math İşlevleri
PHP Manual

tanh

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

tanh — Hyperbolic tangent

Açıklama

float tanh ( float $arg )

Returns the hyperbolic tangent of arg, defined as sinh(arg)/cosh(arg).

Değiştirgeler

arg

The argument to process

Dönen Değerler

The hyperbolic tangent of arg

Ayrıca Bakınız

  • tan() - Tangent
  • atanh() - Inverse hyperbolic tangent
  • sinh() - Hyperbolic sine
  • cosh() - Hyperbolic cosine

tan
Statistics
Math İşlevleri


Statistics

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Statistic İşlevleri
    • stats_absolute_deviation — Returns the absolute deviation of an array of values
    • stats_cdf_beta — CDF function for BETA Distribution. Calculates any one parameter of the beta distribution given values for the others.
    • stats_cdf_binomial — Calculates any one parameter of the binomial distribution given values for the others.
    • stats_cdf_cauchy — Not documented
    • stats_cdf_chisquare — Calculates any one parameter of the chi-square distribution given values for the others.
    • stats_cdf_exponential — Not documented
    • stats_cdf_f — Calculates any one parameter of the F distribution given values for the others.
    • stats_cdf_gamma — Calculates any one parameter of the gamma distribution given values for the others.
    • stats_cdf_laplace — Not documented
    • stats_cdf_logistic — Not documented
    • stats_cdf_negative_binomial — Calculates any one parameter of the negative binomial distribution given values for the others.
    • stats_cdf_noncentral_chisquare — Calculates any one parameter of the non-central chi-square distribution given values for the others.
    • stats_cdf_noncentral_f — Calculates any one parameter of the Non-central F distribution given values for the others.
    • stats_cdf_poisson — Calculates any one parameter of the Poisson distribution given values for the others.
    • stats_cdf_t — Calculates any one parameter of the T distribution given values for the others.
    • stats_cdf_uniform — Not documented
    • stats_cdf_weibull — Not documented
    • stats_covariance — Computes the covariance of two data sets
    • stats_den_uniform — Not documented
    • stats_dens_beta — Not documented
    • stats_dens_cauchy — Not documented
    • stats_dens_chisquare — Not documented
    • stats_dens_exponential — Not documented
    • stats_dens_f — Açıklama
    • stats_dens_gamma — Not documented
    • stats_dens_laplace — Not documented
    • stats_dens_logistic — Not documented
    • stats_dens_negative_binomial — Not documented
    • stats_dens_normal — Not documented
    • stats_dens_pmf_binomial — Not documented
    • stats_dens_pmf_hypergeometric — Açıklama
    • stats_dens_pmf_poisson — Not documented
    • stats_dens_t — Not documented
    • stats_dens_weibull — Not documented
    • stats_harmonic_mean — Returns the harmonic mean of an array of values
    • stats_kurtosis — Computes the kurtosis of the data in the array
    • stats_rand_gen_beta — Generates beta random deviate
    • stats_rand_gen_chisquare — Generates random deviate from the distribution of a chisquare with "df" degrees of freedom random variable.
    • stats_rand_gen_exponential — Generates a single random deviate from an exponential distribution with mean "av"
    • stats_rand_gen_f — Generates a random deviate
    • stats_rand_gen_funiform — Generates uniform float between low (exclusive) and high (exclusive)
    • stats_rand_gen_gamma — Generates random deviates from a gamma distribution
    • stats_rand_gen_ibinomial_negative — Generates a single random deviate from a negative binomial distribution. Arguments : n - the number of trials in the negative binomial distribution from which a random deviate is to be generated (n > 0), p - the probability of an event (0 < p < 1)).
    • stats_rand_gen_ibinomial — Generates a single random deviate from a binomial distribution whose number of trials is "n" (n >= 0) and whose probability of an event in each trial is "pp" ([0;1]). Method : algorithm BTPE
    • stats_rand_gen_int — Generates random integer between 1 and 2147483562
    • stats_rand_gen_ipoisson — Generates a single random deviate from a Poisson distribution with mean "mu" (mu >= 0.0).
    • stats_rand_gen_iuniform — Generates integer uniformly distributed between LOW (inclusive) and HIGH (inclusive)
    • stats_rand_gen_noncenral_chisquare — Generates random deviate from the distribution of a noncentral chisquare with "df" degrees of freedom and noncentrality parameter "xnonc". d must be >= 1.0, xnonc must >= 0.0
    • stats_rand_gen_noncentral_f — Generates a random deviate from the noncentral F (variance ratio) distribution with "dfn" degrees of freedom in the numerator, and "dfd" degrees of freedom in the denominator, and noncentrality parameter "xnonc". Method : directly generates ratio of noncentral numerator chisquare variate to central denominator chisquare variate.
    • stats_rand_gen_noncentral_t — Generates a single random deviate from a noncentral T distribution
    • stats_rand_gen_normal — Generates a single random deviate from a normal distribution with mean, av, and standard deviation, sd (sd >= 0). Method : Renames SNORM from TOMS as slightly modified by BWB to use RANF instead of SUNIF.
    • stats_rand_gen_t — Generates a single random deviate from a T distribution
    • stats_rand_get_seeds — Not documented
    • stats_rand_phrase_to_seeds — generate two seeds for the RGN random number generator
    • stats_rand_ranf — Returns a random floating point number from a uniform distribution over 0 - 1 (endpoints of this interval are not returned) using the current generator
    • stats_rand_setall — Not documented
    • stats_skew — Computes the skewness of the data in the array
    • stats_standard_deviation — Returns the standard deviation
    • stats_stat_binomial_coef — Not documented
    • stats_stat_correlation — Not documented
    • stats_stat_gennch — Not documented
    • stats_stat_independent_t — Not documented
    • stats_stat_innerproduct — Açıklama
    • stats_stat_noncentral_t — Calculates any one parameter of the noncentral t distribution give values for the others.
    • stats_stat_paired_t — Not documented
    • stats_stat_percentile — Not documented
    • stats_stat_powersum — Not documented
    • stats_variance — Returns the population variance
tanh
Giriş
Matematiksel Eklentiler


Giriş

This is the statistics extension. It contains few dozens of functions useful for statistical computations. It is a wrapper around 2 scientific libraries, namely DCDFLIB (Library of C routines for Cumulative Distributions Functions, Inverses, and Other parameters) by B. Brown & J. Lavato and RANDLIB by Barry Brown, James Lavato & Kathy Russell. Includes CD and PD functions.

Statistics
Yapılandırma/Kurulum
Statistics


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Statistics


Gereksinimler

No external libraries are needed. The extension comes bundled with the libraries used.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu » PECL eklentisi PHP ile gelmez.

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/stats.

Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
Statistic İşlevleri
Statistics


Statistic İşlevleri

İçindekiler

  • stats_absolute_deviation — Returns the absolute deviation of an array of values
  • stats_cdf_beta — CDF function for BETA Distribution. Calculates any one parameter of the beta distribution given values for the others.
  • stats_cdf_binomial — Calculates any one parameter of the binomial distribution given values for the others.
  • stats_cdf_cauchy — Not documented
  • stats_cdf_chisquare — Calculates any one parameter of the chi-square distribution given values for the others.
  • stats_cdf_exponential — Not documented
  • stats_cdf_f — Calculates any one parameter of the F distribution given values for the others.
  • stats_cdf_gamma — Calculates any one parameter of the gamma distribution given values for the others.
  • stats_cdf_laplace — Not documented
  • stats_cdf_logistic — Not documented
  • stats_cdf_negative_binomial — Calculates any one parameter of the negative binomial distribution given values for the others.
  • stats_cdf_noncentral_chisquare — Calculates any one parameter of the non-central chi-square distribution given values for the others.
  • stats_cdf_noncentral_f — Calculates any one parameter of the Non-central F distribution given values for the others.
  • stats_cdf_poisson — Calculates any one parameter of the Poisson distribution given values for the others.
  • stats_cdf_t — Calculates any one parameter of the T distribution given values for the others.
  • stats_cdf_uniform — Not documented
  • stats_cdf_weibull — Not documented
  • stats_covariance — Computes the covariance of two data sets
  • stats_den_uniform — Not documented
  • stats_dens_beta — Not documented
  • stats_dens_cauchy — Not documented
  • stats_dens_chisquare — Not documented
  • stats_dens_exponential — Not documented
  • stats_dens_f — Açıklama
  • stats_dens_gamma — Not documented
  • stats_dens_laplace — Not documented
  • stats_dens_logistic — Not documented
  • stats_dens_negative_binomial — Not documented
  • stats_dens_normal — Not documented
  • stats_dens_pmf_binomial — Not documented
  • stats_dens_pmf_hypergeometric — Açıklama
  • stats_dens_pmf_poisson — Not documented
  • stats_dens_t — Not documented
  • stats_dens_weibull — Not documented
  • stats_harmonic_mean — Returns the harmonic mean of an array of values
  • stats_kurtosis — Computes the kurtosis of the data in the array
  • stats_rand_gen_beta — Generates beta random deviate
  • stats_rand_gen_chisquare — Generates random deviate from the distribution of a chisquare with "df" degrees of freedom random variable.
  • stats_rand_gen_exponential — Generates a single random deviate from an exponential distribution with mean "av"
  • stats_rand_gen_f — Generates a random deviate
  • stats_rand_gen_funiform — Generates uniform float between low (exclusive) and high (exclusive)
  • stats_rand_gen_gamma — Generates random deviates from a gamma distribution
  • stats_rand_gen_ibinomial_negative — Generates a single random deviate from a negative binomial distribution. Arguments : n - the number of trials in the negative binomial distribution from which a random deviate is to be generated (n > 0), p - the probability of an event (0 < p < 1)).
  • stats_rand_gen_ibinomial — Generates a single random deviate from a binomial distribution whose number of trials is "n" (n >= 0) and whose probability of an event in each trial is "pp" ([0;1]). Method : algorithm BTPE
  • stats_rand_gen_int — Generates random integer between 1 and 2147483562
  • stats_rand_gen_ipoisson — Generates a single random deviate from a Poisson distribution with mean "mu" (mu >= 0.0).
  • stats_rand_gen_iuniform — Generates integer uniformly distributed between LOW (inclusive) and HIGH (inclusive)
  • stats_rand_gen_noncenral_chisquare — Generates random deviate from the distribution of a noncentral chisquare with "df" degrees of freedom and noncentrality parameter "xnonc". d must be >= 1.0, xnonc must >= 0.0
  • stats_rand_gen_noncentral_f — Generates a random deviate from the noncentral F (variance ratio) distribution with "dfn" degrees of freedom in the numerator, and "dfd" degrees of freedom in the denominator, and noncentrality parameter "xnonc". Method : directly generates ratio of noncentral numerator chisquare variate to central denominator chisquare variate.
  • stats_rand_gen_noncentral_t — Generates a single random deviate from a noncentral T distribution
  • stats_rand_gen_normal — Generates a single random deviate from a normal distribution with mean, av, and standard deviation, sd (sd >= 0). Method : Renames SNORM from TOMS as slightly modified by BWB to use RANF instead of SUNIF.
  • stats_rand_gen_t — Generates a single random deviate from a T distribution
  • stats_rand_get_seeds — Not documented
  • stats_rand_phrase_to_seeds — generate two seeds for the RGN random number generator
  • stats_rand_ranf — Returns a random floating point number from a uniform distribution over 0 - 1 (endpoints of this interval are not returned) using the current generator
  • stats_rand_setall — Not documented
  • stats_skew — Computes the skewness of the data in the array
  • stats_standard_deviation — Returns the standard deviation
  • stats_stat_binomial_coef — Not documented
  • stats_stat_correlation — Not documented
  • stats_stat_gennch — Not documented
  • stats_stat_independent_t — Not documented
  • stats_stat_innerproduct — Açıklama
  • stats_stat_noncentral_t — Calculates any one parameter of the noncentral t distribution give values for the others.
  • stats_stat_paired_t — Not documented
  • stats_stat_percentile — Not documented
  • stats_stat_powersum — Not documented
  • stats_variance — Returns the population variance
Öntanımlı Sabitler
stats_absolute_deviation
Statistics


Returns the absolute deviation of an array of values

Statistic İşlevleri
stats_cdf_beta
Statistic İşlevleri
PHP Manual

stats_absolute_deviation

(PECL stats >= 1.0.0)

stats_absolute_deviation — Returns the absolute deviation of an array of values

Açıklama

float stats_absolute_deviation ( array $a )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

a

Dönen Değerler

Statistic İşlevleri
stats_cdf_beta
Statistic İşlevleri


CDF function for BETA Distribution. Calculates any one parameter of the beta distribution given values for the others.

stats_absolute_deviation
stats_cdf_binomial
Statistic İşlevleri
PHP Manual

stats_cdf_beta

(PECL stats >= 1.0.0)

stats_cdf_beta — CDF function for BETA Distribution. Calculates any one parameter of the beta distribution given values for the others.

Açıklama

float stats_cdf_beta ( float $par1 , float $par2 , float $par3 , int $which )

Method Cumulative distribution function (P) is calculated directly by code associated with the following reference. DiDinato, A. R. and Morris, A. H. Algorithm 708: Significant Digit Computation of the Incomplete Beta Function Ratios. ACM Trans. Math. Softw. 18 (1993), 360-373. Computation of other parameters involve a search for a value that produces the desired value of P. The search relies on the monotonicity of P with the other parameter. Note The beta density is proportional to t^(A-1) * (1-t)^(B-1) Arguments P -- The integral from 0 to X of the chi-square distribution. Input range: [0, 1]. Q -- 1-P. Input range: [0, 1]. P + Q = 1.0. X -- Upper limit of integration of beta density. Input range: [0,1]. Search range: [0,1] Y -- 1-X. Input range: [0,1]. Search range: [0,1] X + Y = 1.0. A -- The first parameter of the beta density. Input range: (0, +infinity). Search range: [1D-100,1D100] B -- The second parameter of the beta density. Input range: (0, +infinity). Search range: [1D-100,1D100] STATUS -- 0 if calculation completed correctly -I if input parameter number I is out of range 1 if answer appears to be lower than lowest search bound 2 if answer appears to be higher than greatest search bound 3 if P + Q .ne. 1 4 if X + Y .ne. 1 BOUND -- Undefined if STATUS is 0 Bound exceeded by parameter number I if STATUS is negative. Lower search bound if STATUS is 1. Upper search bound if STATUS is 2.

Değiştirgeler

par1

par2

par3

which

Integer indicating which of the next four argument values is to be calculated from the others. Legal range: 1..4 which = 1 : Calculate P and Q from X,Y,A and B which = 2 : Calculate X and Y from P,Q,A and B which = 3 : Calculate A from P,Q,X,Y and B which = 4 : Calculate B from P,Q,X,Y and A

Dönen Değerler

STATUS -- 0 if calculation completed correctly -I if input parameter number I is out of range 1 if answer appears to be lower than lowest search bound 2 if answer appears to be higher than greatest search bound 3 if P + Q .ne. 1 4 if X + Y .ne. 1

stats_absolute_deviation
stats_cdf_binomial
Statistic İşlevleri


Calculates any one parameter of the binomial distribution given values for the others.

stats_cdf_beta
stats_cdf_cauchy
Statistic İşlevleri
PHP Manual

stats_cdf_binomial

(PECL stats >= 1.0.0)

stats_cdf_binomial — Calculates any one parameter of the binomial distribution given values for the others.

Açıklama

float stats_cdf_binomial ( float $par1 , float $par2 , float $par3 , int $which )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

par1

par2

par3

which

Dönen Değerler

stats_cdf_beta
stats_cdf_cauchy
Statistic İşlevleri


Not documented

stats_cdf_binomial
stats_cdf_chisquare
Statistic İşlevleri
PHP Manual

stats_cdf_cauchy

(PECL stats >= 1.0.0)

stats_cdf_cauchy — Not documented

Açıklama

float stats_cdf_cauchy ( float $par1 , float $par2 , float $par3 , int $which )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

par1

par2

par3

which

Dönen Değerler

stats_cdf_binomial
stats_cdf_chisquare
Statistic İşlevleri


Calculates any one parameter of the chi-square distribution given values for the others.

stats_cdf_cauchy
stats_cdf_exponential
Statistic İşlevleri
PHP Manual

stats_cdf_chisquare

(PECL stats >= 1.0.0)

stats_cdf_chisquare — Calculates any one parameter of the chi-square distribution given values for the others.

Açıklama

float stats_cdf_chisquare ( float $par1 , float $par2 , int $which )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

par1

par2

which

Dönen Değerler

stats_cdf_cauchy
stats_cdf_exponential
Statistic İşlevleri


Not documented

stats_cdf_chisquare
stats_cdf_f
Statistic İşlevleri
PHP Manual

stats_cdf_exponential

(PECL stats >= 1.0.0)

stats_cdf_exponential — Not documented

Açıklama

float stats_cdf_exponential ( float $par1 , float $par2 , int $which )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

par1

par2

which

Dönen Değerler

stats_cdf_chisquare
stats_cdf_f
Statistic İşlevleri


Calculates any one parameter of the F distribution given values for the others.

stats_cdf_exponential
stats_cdf_gamma
Statistic İşlevleri
PHP Manual

stats_cdf_f

(PECL stats >= 1.0.0)

stats_cdf_f — Calculates any one parameter of the F distribution given values for the others.

Açıklama

float stats_cdf_f ( float $par1 , float $par2 , float $par3 , int $which )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

par1

par2

par3

which

Dönen Değerler

stats_cdf_exponential
stats_cdf_gamma
Statistic İşlevleri


Calculates any one parameter of the gamma distribution given values for the others.

stats_cdf_f
stats_cdf_laplace
Statistic İşlevleri
PHP Manual

stats_cdf_gamma

(PECL stats >= 1.0.0)

stats_cdf_gamma — Calculates any one parameter of the gamma distribution given values for the others.

Açıklama

float stats_cdf_gamma ( float $par1 , float $par2 , float $par3 , int $which )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

par1

par2

par3

which

Dönen Değerler

stats_cdf_f
stats_cdf_laplace
Statistic İşlevleri


Not documented

stats_cdf_gamma
stats_cdf_logistic
Statistic İşlevleri
PHP Manual

stats_cdf_laplace

(PECL stats >= 1.0.0)

stats_cdf_laplace — Not documented

Açıklama

float stats_cdf_laplace ( float $par1 , float $par2 , float $par3 , int $which )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

par1

par2

par3

which

Dönen Değerler

stats_cdf_gamma
stats_cdf_logistic
Statistic İşlevleri


Not documented

stats_cdf_laplace
stats_cdf_negative_binomial
Statistic İşlevleri
PHP Manual

stats_cdf_logistic

(PECL stats >= 1.0.0)

stats_cdf_logistic — Not documented

Açıklama

float stats_cdf_logistic ( float $par1 , float $par2 , float $par3 , int $which )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

par1

par2

par3

which

Dönen Değerler

stats_cdf_laplace
stats_cdf_negative_binomial
Statistic İşlevleri


Calculates any one parameter of the negative binomial distribution given values for the others.

stats_cdf_logistic
stats_cdf_noncentral_chisquare
Statistic İşlevleri
PHP Manual

stats_cdf_negative_binomial

(PECL stats >= 1.0.0)

stats_cdf_negative_binomial — Calculates any one parameter of the negative binomial distribution given values for the others.

Açıklama

float stats_cdf_negative_binomial ( float $par1 , float $par2 , float $par3 , int $which )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

par1

par2

par3

which

Dönen Değerler

stats_cdf_logistic
stats_cdf_noncentral_chisquare
Statistic İşlevleri


Calculates any one parameter of the non-central chi-square distribution given values for the others.

stats_cdf_negative_binomial
stats_cdf_noncentral_f
Statistic İşlevleri
PHP Manual

stats_cdf_noncentral_chisquare

(PECL stats >= 1.0.0)

stats_cdf_noncentral_chisquare — Calculates any one parameter of the non-central chi-square distribution given values for the others.

Açıklama

float stats_cdf_noncentral_chisquare ( float $par1 , float $par2 , float $par3 , int $which )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

par1

par2

par3

which

Dönen Değerler

stats_cdf_negative_binomial
stats_cdf_noncentral_f
Statistic İşlevleri


Calculates any one parameter of the Non-central F distribution given values for the others.

stats_cdf_noncentral_chisquare
stats_cdf_poisson
Statistic İşlevleri
PHP Manual

stats_cdf_noncentral_f

(PECL stats >= 1.0.0)

stats_cdf_noncentral_f — Calculates any one parameter of the Non-central F distribution given values for the others.

Açıklama

float stats_cdf_noncentral_f ( float $par1 , float $par2 , float $par3 , float $par4 , int $which )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

par1

par2

par3

par4

which

Dönen Değerler

stats_cdf_noncentral_chisquare
stats_cdf_poisson
Statistic İşlevleri


Calculates any one parameter of the Poisson distribution given values for the others.

stats_cdf_noncentral_f
stats_cdf_t
Statistic İşlevleri
PHP Manual

stats_cdf_poisson

(PECL stats >= 1.0.0)

stats_cdf_poisson — Calculates any one parameter of the Poisson distribution given values for the others.

Açıklama

float stats_cdf_poisson ( float $par1 , float $par2 , int $which )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

par1

par2

which

Dönen Değerler

stats_cdf_noncentral_f
stats_cdf_t
Statistic İşlevleri


Calculates any one parameter of the T distribution given values for the others.

stats_cdf_poisson
stats_cdf_uniform
Statistic İşlevleri
PHP Manual

stats_cdf_t

(PECL stats >= 1.0.0)

stats_cdf_t — Calculates any one parameter of the T distribution given values for the others.

Açıklama

float stats_cdf_t ( float $par1 , float $par2 , int $which )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

par1

par2

which

Dönen Değerler

stats_cdf_poisson
stats_cdf_uniform
Statistic İşlevleri


Not documented

stats_cdf_t
stats_cdf_weibull
Statistic İşlevleri
PHP Manual

stats_cdf_uniform

(PECL stats >= 1.0.0)

stats_cdf_uniform — Not documented

Açıklama

float stats_cdf_uniform ( float $par1 , float $par2 , float $par3 , int $which )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

par1

par2

par3

which

Dönen Değerler

stats_cdf_t
stats_cdf_weibull
Statistic İşlevleri


Not documented

stats_cdf_uniform
stats_covariance
Statistic İşlevleri
PHP Manual

stats_cdf_weibull

(PECL stats >= 1.0.0)

stats_cdf_weibull — Not documented

Açıklama

float stats_cdf_weibull ( float $par1 , float $par2 , float $par3 , int $which )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

par1

par2

par3

which

Dönen Değerler

stats_cdf_uniform
stats_covariance
Statistic İşlevleri


Computes the covariance of two data sets

stats_cdf_weibull
stats_den_uniform
Statistic İşlevleri
PHP Manual

stats_covariance

(PECL stats >= 1.0.0)

stats_covariance — Computes the covariance of two data sets

Açıklama

float stats_covariance ( array $a , array $b )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

a

b

Dönen Değerler

stats_cdf_weibull
stats_den_uniform
Statistic İşlevleri


Not documented

stats_covariance
stats_dens_beta
Statistic İşlevleri
PHP Manual

stats_den_uniform

(PECL stats >= 1.0.0)

stats_den_uniform — Not documented

Açıklama

float stats_den_uniform ( float $x , float $a , float $b )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

x

a

b

Dönen Değerler

stats_covariance
stats_dens_beta
Statistic İşlevleri


Not documented

stats_den_uniform
stats_dens_cauchy
Statistic İşlevleri
PHP Manual

stats_dens_beta

(PECL stats >= 1.0.0)

stats_dens_beta — Not documented

Açıklama

float stats_dens_beta ( float $x , float $a , float $b )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

x

a

b

Dönen Değerler

stats_den_uniform
stats_dens_cauchy
Statistic İşlevleri


Not documented

stats_dens_beta
stats_dens_chisquare
Statistic İşlevleri
PHP Manual

stats_dens_cauchy

(PECL stats >= 1.0.0)

stats_dens_cauchy — Not documented

Açıklama

float stats_dens_cauchy ( float $x , float $ave , float $stdev )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

x

ave

stdev

Dönen Değerler

stats_dens_beta
stats_dens_chisquare
Statistic İşlevleri


Not documented

stats_dens_cauchy
stats_dens_exponential
Statistic İşlevleri
PHP Manual

stats_dens_chisquare

(PECL stats >= 1.0.0)

stats_dens_chisquare — Not documented

Açıklama

float stats_dens_chisquare ( float $x , float $dfr )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

x

dfr

Dönen Değerler

stats_dens_cauchy
stats_dens_exponential
Statistic İşlevleri


Not documented

stats_dens_chisquare
stats_dens_f
Statistic İşlevleri
PHP Manual

stats_dens_exponential

(PECL stats >= 1.0.0)

stats_dens_exponential — Not documented

Açıklama

float stats_dens_exponential ( float $x , float $scale )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

x

scale

Dönen Değerler

stats_dens_chisquare
stats_dens_f
Statistic İşlevleri


stats_dens_exponential
stats_dens_gamma
Statistic İşlevleri
PHP Manual

stats_dens_f

(PECL stats >= 1.0.0)

stats_dens_f —

Açıklama

float stats_dens_f ( float $x , float $dfr1 , float $dfr2 )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

x

dfr1

dfr2

Dönen Değerler

stats_dens_exponential
stats_dens_gamma
Statistic İşlevleri


Not documented

stats_dens_f
stats_dens_laplace
Statistic İşlevleri
PHP Manual

stats_dens_gamma

(PECL stats >= 1.0.0)

stats_dens_gamma — Not documented

Açıklama

float stats_dens_gamma ( float $x , float $shape , float $scale )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

x

shape

scale

Dönen Değerler

stats_dens_f
stats_dens_laplace
Statistic İşlevleri


Not documented

stats_dens_gamma
stats_dens_logistic
Statistic İşlevleri
PHP Manual

stats_dens_laplace

(PECL stats >= 1.0.0)

stats_dens_laplace — Not documented

Açıklama

float stats_dens_laplace ( float $x , float $ave , float $stdev )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

x

ave

stdev

Dönen Değerler

stats_dens_gamma
stats_dens_logistic
Statistic İşlevleri


Not documented

stats_dens_laplace
stats_dens_negative_binomial
Statistic İşlevleri
PHP Manual

stats_dens_logistic

(PECL stats >= 1.0.0)

stats_dens_logistic — Not documented

Açıklama

float stats_dens_logistic ( float $x , float $ave , float $stdev )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

x

ave

stdev

Dönen Değerler

stats_dens_laplace
stats_dens_negative_binomial
Statistic İşlevleri


Not documented

stats_dens_logistic
stats_dens_normal
Statistic İşlevleri
PHP Manual

stats_dens_negative_binomial

(PECL stats >= 1.0.0)

stats_dens_negative_binomial — Not documented

Açıklama

float stats_dens_negative_binomial ( float $x , float $n , float $pi )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

x

n

pi

Dönen Değerler

stats_dens_logistic
stats_dens_normal
Statistic İşlevleri


Not documented

stats_dens_negative_binomial
stats_dens_pmf_binomial
Statistic İşlevleri
PHP Manual

stats_dens_normal

(PECL stats >= 1.0.0)

stats_dens_normal — Not documented

Açıklama

float stats_dens_normal ( float $x , float $ave , float $stdev )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

x

ave

stdev

Dönen Değerler

stats_dens_negative_binomial
stats_dens_pmf_binomial
Statistic İşlevleri


Not documented

stats_dens_normal
stats_dens_pmf_hypergeometric
Statistic İşlevleri
PHP Manual

stats_dens_pmf_binomial

(PECL stats >= 1.0.0)

stats_dens_pmf_binomial — Not documented

Açıklama

float stats_dens_pmf_binomial ( float $x , float $n , float $pi )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

x

n

pi

Dönen Değerler

stats_dens_normal
stats_dens_pmf_hypergeometric
Statistic İşlevleri


stats_dens_pmf_binomial
stats_dens_pmf_poisson
Statistic İşlevleri
PHP Manual

stats_dens_pmf_hypergeometric

(PECL stats >= 1.0.0)

stats_dens_pmf_hypergeometric —

Açıklama

float stats_dens_pmf_hypergeometric ( float $n1 , float $n2 , float $N1 , float $N2 )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

n1

n2

N1

N2

Dönen Değerler

stats_dens_pmf_binomial
stats_dens_pmf_poisson
Statistic İşlevleri


Not documented

stats_dens_pmf_hypergeometric
stats_dens_t
Statistic İşlevleri
PHP Manual

stats_dens_pmf_poisson

(PECL stats >= 1.0.0)

stats_dens_pmf_poisson — Not documented

Açıklama

float stats_dens_pmf_poisson ( float $x , float $lb )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

x

lb

Dönen Değerler

stats_dens_pmf_hypergeometric
stats_dens_t
Statistic İşlevleri


Not documented

stats_dens_pmf_poisson
stats_dens_weibull
Statistic İşlevleri
PHP Manual

stats_dens_t

(PECL stats >= 1.0.0)

stats_dens_t — Not documented

Açıklama

float stats_dens_t ( float $x , float $dfr )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

x

dfr

Dönen Değerler

stats_dens_pmf_poisson
stats_dens_weibull
Statistic İşlevleri


Not documented

stats_dens_t
stats_harmonic_mean
Statistic İşlevleri
PHP Manual

stats_dens_weibull

(PECL stats >= 1.0.0)

stats_dens_weibull — Not documented

Açıklama

float stats_dens_weibull ( float $x , float $a , float $b )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

x

a

b

Dönen Değerler

stats_dens_t
stats_harmonic_mean
Statistic İşlevleri


Returns the harmonic mean of an array of values

stats_dens_weibull
stats_kurtosis
Statistic İşlevleri
PHP Manual

stats_harmonic_mean

(PECL stats >= 1.0.0)

stats_harmonic_mean — Returns the harmonic mean of an array of values

Açıklama

number stats_harmonic_mean ( array $a )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

a

Dönen Değerler

stats_dens_weibull
stats_kurtosis
Statistic İşlevleri


Computes the kurtosis of the data in the array

stats_harmonic_mean
stats_rand_gen_beta
Statistic İşlevleri
PHP Manual

stats_kurtosis

(PECL stats >= 1.0.0)

stats_kurtosis — Computes the kurtosis of the data in the array

Açıklama

float stats_kurtosis ( array $a )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

a

Dönen Değerler

stats_harmonic_mean
stats_rand_gen_beta
Statistic İşlevleri


Generates beta random deviate

stats_kurtosis
stats_rand_gen_chisquare
Statistic İşlevleri
PHP Manual

stats_rand_gen_beta

(PECL stats >= 1.0.0)

stats_rand_gen_beta — Generates beta random deviate

Açıklama

float stats_rand_gen_beta ( float $a , float $b )

Returns a random deviate from the beta distribution with parameters A and B. The density of the beta is x^(a-1) * (1-x)^(b-1) / B(a,b) for 0 < x <. Method R. C. H. Cheng.

Değiştirgeler

a

b

Dönen Değerler

stats_kurtosis
stats_rand_gen_chisquare
Statistic İşlevleri


Generates random deviate from the distribution of a chisquare with "df" degrees of freedom random variable.

stats_rand_gen_beta
stats_rand_gen_exponential
Statistic İşlevleri
PHP Manual

stats_rand_gen_chisquare

(PECL stats >= 1.0.0)

stats_rand_gen_chisquare — Generates random deviate from the distribution of a chisquare with "df" degrees of freedom random variable.

Açıklama

float stats_rand_gen_chisquare ( float $df )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

df

Dönen Değerler

stats_rand_gen_beta
stats_rand_gen_exponential
Statistic İşlevleri


Generates a single random deviate from an exponential distribution with mean "av"

stats_rand_gen_chisquare
stats_rand_gen_f
Statistic İşlevleri
PHP Manual

stats_rand_gen_exponential

(PECL stats >= 1.0.0)

stats_rand_gen_exponential — Generates a single random deviate from an exponential distribution with mean "av"

Açıklama

float stats_rand_gen_exponential ( float $av )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

av

Dönen Değerler

stats_rand_gen_chisquare
stats_rand_gen_f
Statistic İşlevleri


Generates a random deviate

stats_rand_gen_exponential
stats_rand_gen_funiform
Statistic İşlevleri
PHP Manual

stats_rand_gen_f

(PECL stats >= 1.0.0)

stats_rand_gen_f — Generates a random deviate

Açıklama

float stats_rand_gen_f ( float $dfn , float $dfd )

Generates a random deviate from the F (variance ratio) distribution with "dfn" degrees of freedom in the numerator and "dfd" degrees of freedom in the denominator. Method : directly generates ratio of chisquare variates.

Değiştirgeler

dfn

dfd

Dönen Değerler

stats_rand_gen_exponential
stats_rand_gen_funiform
Statistic İşlevleri


Generates uniform float between low (exclusive) and high (exclusive)

stats_rand_gen_f
stats_rand_gen_gamma
Statistic İşlevleri
PHP Manual

stats_rand_gen_funiform

(PECL stats >= 1.0.0)

stats_rand_gen_funiform — Generates uniform float between low (exclusive) and high (exclusive)

Açıklama

float stats_rand_gen_funiform ( float $low , float $high )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

low

high

Dönen Değerler

stats_rand_gen_f
stats_rand_gen_gamma
Statistic İşlevleri


Generates random deviates from a gamma distribution

stats_rand_gen_funiform
stats_rand_gen_ibinomial_negative
Statistic İşlevleri
PHP Manual

stats_rand_gen_gamma

(PECL stats >= 1.0.0)

stats_rand_gen_gamma — Generates random deviates from a gamma distribution

Açıklama

float stats_rand_gen_gamma ( float $a , float $r )

Generates random deviates from the gamma distribution whose density is (A**R)/Gamma(R) * X**(R-1) * Exp(-A*X).

Değiştirgeler

a

location parameter of Gamma distribution (a > 0).

r

shape parameter of Gamma distribution (r > 0).

Dönen Değerler

stats_rand_gen_funiform
stats_rand_gen_ibinomial_negative
Statistic İşlevleri


Generates a single random deviate from a negative binomial distribution. Arguments : n - the number of trials in the negative binomial distribution from which a random deviate is to be generated (n > 0), p - the probability of an event (0 < p < 1)).

stats_rand_gen_gamma
stats_rand_gen_ibinomial
Statistic İşlevleri
PHP Manual

stats_rand_gen_ibinomial_negative

(PECL stats >= 1.0.0)

stats_rand_gen_ibinomial_negative — Generates a single random deviate from a negative binomial distribution. Arguments : n - the number of trials in the negative binomial distribution from which a random deviate is to be generated (n > 0), p - the probability of an event (0 < p < 1)).

Açıklama

int stats_rand_gen_ibinomial_negative ( int $n , float $p )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

n

p

Dönen Değerler

stats_rand_gen_gamma
stats_rand_gen_ibinomial
Statistic İşlevleri


Generates a single random deviate from a binomial distribution whose number of trials is "n" (n >= 0) and whose probability of an event in each trial is "pp" ([0;1]). Method : algorithm BTPE

stats_rand_gen_ibinomial_negative
stats_rand_gen_int
Statistic İşlevleri
PHP Manual

stats_rand_gen_ibinomial

(PECL stats >= 1.0.0)

stats_rand_gen_ibinomial — Generates a single random deviate from a binomial distribution whose number of trials is "n" (n >= 0) and whose probability of an event in each trial is "pp" ([0;1]). Method : algorithm BTPE

Açıklama

int stats_rand_gen_ibinomial ( int $n , float $pp )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

n

pp

Dönen Değerler

stats_rand_gen_ibinomial_negative
stats_rand_gen_int
Statistic İşlevleri


Generates random integer between 1 and 2147483562

stats_rand_gen_ibinomial
stats_rand_gen_ipoisson
Statistic İşlevleri
PHP Manual

stats_rand_gen_int

(PECL stats >= 1.0.0)

stats_rand_gen_int — Generates random integer between 1 and 2147483562

Açıklama

int stats_rand_gen_int ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Dönen Değerler

stats_rand_gen_ibinomial
stats_rand_gen_ipoisson
Statistic İşlevleri


Generates a single random deviate from a Poisson distribution with mean "mu" (mu >= 0.0).

stats_rand_gen_int
stats_rand_gen_iuniform
Statistic İşlevleri
PHP Manual

stats_rand_gen_ipoisson

(PECL stats >= 1.0.0)

stats_rand_gen_ipoisson — Generates a single random deviate from a Poisson distribution with mean "mu" (mu >= 0.0).

Açıklama

int stats_rand_gen_ipoisson ( float $mu )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

mu

Dönen Değerler

stats_rand_gen_int
stats_rand_gen_iuniform
Statistic İşlevleri


Generates integer uniformly distributed between LOW (inclusive) and HIGH (inclusive)

stats_rand_gen_ipoisson
stats_rand_gen_noncenral_chisquare
Statistic İşlevleri
PHP Manual

stats_rand_gen_iuniform

(PECL stats >= 1.0.0)

stats_rand_gen_iuniform — Generates integer uniformly distributed between LOW (inclusive) and HIGH (inclusive)

Açıklama

int stats_rand_gen_iuniform ( int $low , int $high )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

low

high

Dönen Değerler

stats_rand_gen_ipoisson
stats_rand_gen_noncenral_chisquare
Statistic İşlevleri


Generates random deviate from the distribution of a noncentral chisquare with "df" degrees of freedom and noncentrality parameter "xnonc". d must be >= 1.0, xnonc must >= 0.0

stats_rand_gen_iuniform
stats_rand_gen_noncentral_f
Statistic İşlevleri
PHP Manual

stats_rand_gen_noncenral_chisquare

(PECL stats >= 1.0.0)

stats_rand_gen_noncenral_chisquare — Generates random deviate from the distribution of a noncentral chisquare with "df" degrees of freedom and noncentrality parameter "xnonc". d must be >= 1.0, xnonc must >= 0.0

Açıklama

float stats_rand_gen_noncenral_chisquare ( float $df , float $xnonc )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

df

xnonc

Dönen Değerler

stats_rand_gen_iuniform
stats_rand_gen_noncentral_f
Statistic İşlevleri


Generates a random deviate from the noncentral F (variance ratio) distribution with "dfn" degrees of freedom in the numerator, and "dfd" degrees of freedom in the denominator, and noncentrality parameter "xnonc". Method : directly generates ratio of noncentral numerator chisquare variate to central 

stats_rand_gen_noncenral_chisquare
stats_rand_gen_noncentral_t
Statistic İşlevleri
PHP Manual

stats_rand_gen_noncentral_f

(PECL stats >= 1.0.0)

stats_rand_gen_noncentral_f — Generates a random deviate from the noncentral F (variance ratio) distribution with "dfn" degrees of freedom in the numerator, and "dfd" degrees of freedom in the denominator, and noncentrality parameter "xnonc". Method : directly generates ratio of noncentral numerator chisquare variate to central denominator chisquare variate.

Açıklama

float stats_rand_gen_noncentral_f ( float $dfn , float $dfd , float $xnonc )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

dfn

dfd

xnonc

Dönen Değerler

stats_rand_gen_noncenral_chisquare
stats_rand_gen_noncentral_t
Statistic İşlevleri


Generates a single random deviate from a noncentral T distribution

stats_rand_gen_noncentral_f
stats_rand_gen_normal
Statistic İşlevleri
PHP Manual

stats_rand_gen_noncentral_t

(PECL stats >= 1.0.0)

stats_rand_gen_noncentral_t — Generates a single random deviate from a noncentral T distribution

Açıklama

float stats_rand_gen_noncentral_t ( float $df , float $xnonc )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

df

xnonc

Dönen Değerler

stats_rand_gen_noncentral_f
stats_rand_gen_normal
Statistic İşlevleri


Generates a single random deviate from a normal distribution with mean, av, and standard deviation, sd (sd >= 0). Method : Renames SNORM from TOMS as slightly modified by BWB to use RANF instead of SUNIF.

stats_rand_gen_noncentral_t
stats_rand_gen_t
Statistic İşlevleri
PHP Manual

stats_rand_gen_normal

(PECL stats >= 1.0.0)

stats_rand_gen_normal — Generates a single random deviate from a normal distribution with mean, av, and standard deviation, sd (sd >= 0). Method : Renames SNORM from TOMS as slightly modified by BWB to use RANF instead of SUNIF.

Açıklama

float stats_rand_gen_normal ( float $av , float $sd )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

av

sd

Dönen Değerler

stats_rand_gen_noncentral_t
stats_rand_gen_t
Statistic İşlevleri


Generates a single random deviate from a T distribution

stats_rand_gen_normal
stats_rand_get_seeds
Statistic İşlevleri
PHP Manual

stats_rand_gen_t

(PECL stats >= 1.0.0)

stats_rand_gen_t — Generates a single random deviate from a T distribution

Açıklama

float stats_rand_gen_t ( float $df )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

df

Dönen Değerler

stats_rand_gen_normal
stats_rand_get_seeds
Statistic İşlevleri


Not documented

stats_rand_gen_t
stats_rand_phrase_to_seeds
Statistic İşlevleri
PHP Manual

stats_rand_get_seeds

(PECL stats >= 1.0.0)

stats_rand_get_seeds — Not documented

Açıklama

array stats_rand_get_seeds ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Dönen Değerler

stats_rand_gen_t
stats_rand_phrase_to_seeds
Statistic İşlevleri


generate two seeds for the RGN random number generator

stats_rand_get_seeds
stats_rand_ranf
Statistic İşlevleri
PHP Manual

stats_rand_phrase_to_seeds

(PECL stats >= 1.0.0)

stats_rand_phrase_to_seeds — generate two seeds for the RGN random number generator

Açıklama

array stats_rand_phrase_to_seeds ( string $phrase )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

phrase

Dönen Değerler

stats_rand_get_seeds
stats_rand_ranf
Statistic İşlevleri


Returns a random floating point number from a uniform distribution over 0 - 1 (endpoints of this interval are not returned) using the current generator

stats_rand_phrase_to_seeds
stats_rand_setall
Statistic İşlevleri
PHP Manual

stats_rand_ranf

(PECL stats >= 1.0.0)

stats_rand_ranf — Returns a random floating point number from a uniform distribution over 0 - 1 (endpoints of this interval are not returned) using the current generator

Açıklama

float stats_rand_ranf ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Dönen Değerler

stats_rand_phrase_to_seeds
stats_rand_setall
Statistic İşlevleri


Not documented

stats_rand_ranf
stats_skew
Statistic İşlevleri
PHP Manual

stats_rand_setall

(PECL stats >= 1.0.0)

stats_rand_setall — Not documented

Açıklama

void stats_rand_setall ( int $iseed1 , int $iseed2 )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

iseed1

iseed2

Dönen Değerler

stats_rand_ranf
stats_skew
Statistic İşlevleri


Computes the skewness of the data in the array

stats_rand_setall
stats_standard_deviation
Statistic İşlevleri
PHP Manual

stats_skew

(PECL stats >= 1.0.0)

stats_skew — Computes the skewness of the data in the array

Açıklama

float stats_skew ( array $a )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

a

Dönen Değerler

stats_rand_setall
stats_standard_deviation
Statistic İşlevleri


Returns the standard deviation

stats_skew
stats_stat_binomial_coef
Statistic İşlevleri
PHP Manual

stats_standard_deviation

(PECL stats >= 1.0.0)

stats_standard_deviation — Returns the standard deviation

Açıklama

float stats_standard_deviation ( array $a [, bool $sample = false ] )

Değiştirgeler

a

The array of data to find the standard deviation for. Note that all values of the array will be cast to float.

sample

Indicates if a represents a sample of the population; defaults to FALSE.

Dönen Değerler

Returns the standard deviation on success; FALSE on failure.

Hatalar/İstisnalar

Raises an E_WARNING when there are fewer than 2 values in a.

stats_skew
stats_stat_binomial_coef
Statistic İşlevleri


Not documented

stats_standard_deviation
stats_stat_correlation
Statistic İşlevleri
PHP Manual

stats_stat_binomial_coef

(PECL stats >= 1.0.0)

stats_stat_binomial_coef — Not documented

Açıklama

float stats_stat_binomial_coef ( int $x , int $n )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

x

n

Dönen Değerler

stats_standard_deviation
stats_stat_correlation
Statistic İşlevleri


Not documented

stats_stat_binomial_coef
stats_stat_gennch
Statistic İşlevleri
PHP Manual

stats_stat_correlation

(PECL stats >= 1.0.0)

stats_stat_correlation — Not documented

Açıklama

float stats_stat_correlation ( array $arr1 , array $arr2 )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

arr1

arr2

Dönen Değerler

stats_stat_binomial_coef
stats_stat_gennch
Statistic İşlevleri


Not documented

stats_stat_correlation
stats_stat_independent_t
Statistic İşlevleri
PHP Manual

stats_stat_gennch

(PECL stats >= 1.0.0)

stats_stat_gennch — Not documented

Açıklama

float stats_stat_gennch ( int $n )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

n

Dönen Değerler

stats_stat_correlation
stats_stat_independent_t
Statistic İşlevleri


Not documented

stats_stat_gennch
stats_stat_innerproduct
Statistic İşlevleri
PHP Manual

stats_stat_independent_t

(PECL stats >= 1.0.0)

stats_stat_independent_t — Not documented

Açıklama

float stats_stat_independent_t ( array $arr1 , array $arr2 )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

arr1

arr2

Dönen Değerler

stats_stat_gennch
stats_stat_innerproduct
Statistic İşlevleri


stats_stat_independent_t
stats_stat_noncentral_t
Statistic İşlevleri
PHP Manual

stats_stat_innerproduct

(PECL stats >= 1.0.0)

stats_stat_innerproduct —

Açıklama

float stats_stat_innerproduct ( array $arr1 , array $arr2 )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

arr1

arr2

Dönen Değerler

stats_stat_independent_t
stats_stat_noncentral_t
Statistic İşlevleri


Calculates any one parameter of the noncentral t distribution give values for the others.

stats_stat_innerproduct
stats_stat_paired_t
Statistic İşlevleri
PHP Manual

stats_stat_noncentral_t

(PECL stats >= 1.0.0)

stats_stat_noncentral_t — Calculates any one parameter of the noncentral t distribution give values for the others.

Açıklama

float stats_stat_noncentral_t ( float $par1 , float $par2 , float $par3 , int $which )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

par1

par2

par3

which

Dönen Değerler

stats_stat_innerproduct
stats_stat_paired_t
Statistic İşlevleri


Not documented

stats_stat_noncentral_t
stats_stat_percentile
Statistic İşlevleri
PHP Manual

stats_stat_paired_t

(PECL stats >= 1.0.0)

stats_stat_paired_t — Not documented

Açıklama

float stats_stat_paired_t ( array $arr1 , array $arr2 )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

arr1

arr2

Dönen Değerler

stats_stat_noncentral_t
stats_stat_percentile
Statistic İşlevleri


Not documented

stats_stat_paired_t
stats_stat_powersum
Statistic İşlevleri
PHP Manual

stats_stat_percentile

(PECL stats >= 1.0.0)

stats_stat_percentile — Not documented

Açıklama

float stats_stat_percentile ( float $df , float $xnonc )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

df

xnonc

Dönen Değerler

stats_stat_paired_t
stats_stat_powersum
Statistic İşlevleri


Not documented

stats_stat_percentile
stats_variance
Statistic İşlevleri
PHP Manual

stats_stat_powersum

(PECL stats >= 1.0.0)

stats_stat_powersum — Not documented

Açıklama

float stats_stat_powersum ( array $arr , float $power )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

arr

power

Dönen Değerler

stats_stat_percentile
stats_variance
Statistic İşlevleri


Returns the population variance

stats_stat_powersum
Trader
Statistic İşlevleri
PHP Manual

stats_variance

(PECL stats >= 1.0.0)

stats_variance — Returns the population variance

Açıklama

float stats_variance ( array $a [, bool $sample = false ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

a

sample

Dönen Değerler

stats_stat_powersum
Trader
Statistic İşlevleri


Technical Analysis for Traders

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
  • Öntanımlı Sabitler
  • Trader İşlevleri
    • trader_acos — Vector Trigonometric ACos
    • trader_ad — Chaikin A/D Line
    • trader_add — Vector Arithmetic Add
    • trader_adosc — Chaikin A/D Oscillator
    • trader_adx — Average Directional Movement Index
    • trader_adxr — Average Directional Movement Index Rating
    • trader_apo — Absolute Price Oscillator
    • trader_aroon — Aroon
    • trader_aroonosc — Aroon Oscillator
    • trader_asin — Vector Trigonometric ASin
    • trader_atan — Vector Trigonometric ATan
    • trader_atr — Average True Range
    • trader_avgprice — Average Price
    • trader_bbands — Bollinger Bands
    • trader_beta — Beta
    • trader_bop — Balance Of Power
    • trader_cci — Commodity Channel Index
    • trader_cdl2crows — Two Crows
    • trader_cdl3blackcrows — Three Black Crows
    • trader_cdl3inside — Three Inside Up/Down
    • trader_cdl3linestrike — Three-Line Strike
    • trader_cdl3outside — Three Outside Up/Down
    • trader_cdl3starsinsouth — Three Stars In The South
    • trader_cdl3whitesoldiers — Three Advancing White Soldiers
    • trader_cdlabandonedbaby — Abandoned Baby
    • trader_cdladvanceblock — Advance Block
    • trader_cdlbelthold — Belt-hold
    • trader_cdlbreakaway — Breakaway
    • trader_cdlclosingmarubozu — Closing Marubozu
    • trader_cdlconcealbabyswall — Concealing Baby Swallow
    • trader_cdlcounterattack — Counterattack
    • trader_cdldarkcloudcover — Dark Cloud Cover
    • trader_cdldoji — Doji
    • trader_cdldojistar — Doji Star
    • trader_cdldragonflydoji — Dragonfly Doji
    • trader_cdlengulfing — Engulfing Pattern
    • trader_cdleveningdojistar — Evening Doji Star
    • trader_cdleveningstar — Evening Star
    • trader_cdlgapsidesidewhite — Up/Down-gap side-by-side white lines
    • trader_cdlgravestonedoji — Gravestone Doji
    • trader_cdlhammer — Hammer
    • trader_cdlhangingman — Hanging Man
    • trader_cdlharami — Harami Pattern
    • trader_cdlharamicross — Harami Cross Pattern
    • trader_cdlhighwave — High-Wave Candle
    • trader_cdlhikkake — Hikkake Pattern
    • trader_cdlhikkakemod — Modified Hikkake Pattern
    • trader_cdlhomingpigeon — Homing Pigeon
    • trader_cdlidentical3crows — Identical Three Crows
    • trader_cdlinneck — In-Neck Pattern
    • trader_cdlinvertedhammer — Inverted Hammer
    • trader_cdlkicking — Kicking
    • trader_cdlkickingbylength — Kicking - bull/bear determined by the longer marubozu
    • trader_cdlladderbottom — Ladder Bottom
    • trader_cdllongleggeddoji — Long Legged Doji
    • trader_cdllongline — Long Line Candle
    • trader_cdlmarubozu — Marubozu
    • trader_cdlmatchinglow — Matching Low
    • trader_cdlmathold — Mat Hold
    • trader_cdlmorningdojistar — Morning Doji Star
    • trader_cdlmorningstar — Morning Star
    • trader_cdlonneck — On-Neck Pattern
    • trader_cdlpiercing — Piercing Pattern
    • trader_cdlrickshawman — Rickshaw Man
    • trader_cdlrisefall3methods — Rising/Falling Three Methods
    • trader_cdlseparatinglines — Separating Lines
    • trader_cdlshootingstar — Shooting Star
    • trader_cdlshortline — Short Line Candle
    • trader_cdlspinningtop — Spinning Top
    • trader_cdlstalledpattern — Stalled Pattern
    • trader_cdlsticksandwich — Stick Sandwich
    • trader_cdltakuri — Takuri (Dragonfly Doji with very long lower shadow)
    • trader_cdltasukigap — Tasuki Gap
    • trader_cdlthrusting — Thrusting Pattern
    • trader_cdltristar — Tristar Pattern
    • trader_cdlunique3river — Unique 3 River
    • trader_cdlupsidegap2crows — Upside Gap Two Crows
    • trader_cdlxsidegap3methods — Upside/Downside Gap Three Methods
    • trader_ceil — Vector Ceil
    • trader_cmo — Chande Momentum Oscillator
    • trader_correl — Pearson's Correlation Coefficient (r)
    • trader_cos — Vector Trigonometric Cos
    • trader_cosh — Vector Trigonometric Cosh
    • trader_dema — Double Exponential Moving Average
    • trader_div — Vector Arithmetic Div
    • trader_dx — Directional Movement Index
    • trader_ema — Exponential Moving Average
    • trader_errno — Get error code
    • trader_exp — Vector Arithmetic Exp
    • trader_floor — Vector Floor
    • trader_get_compat — Get compatibility mode
    • trader_get_unstable_period — Get unstable period
    • trader_ht_dcperiod — Hilbert Transform - Dominant Cycle Period
    • trader_ht_dcphase — Hilbert Transform - Dominant Cycle Phase
    • trader_ht_phasor — Hilbert Transform - Phasor Components
    • trader_ht_sine — Hilbert Transform - SineWave
    • trader_ht_trendline — Hilbert Transform - Instantaneous Trendline
    • trader_ht_trendmode — Hilbert Transform - Trend vs Cycle Mode
    • trader_kama — Kaufman Adaptive Moving Average
    • trader_linearreg_angle — Linear Regression Angle
    • trader_linearreg_intercept — Linear Regression Intercept
    • trader_linearreg_slope — Linear Regression Slope
    • trader_linearreg — Linear Regression
    • trader_ln — Vector Log Natural
    • trader_log10 — Vector Log10
    • trader_ma — Moving average
    • trader_macd — Moving Average Convergence/Divergence
    • trader_macdext — MACD with controllable MA type
    • trader_macdfix — Moving Average Convergence/Divergence Fix 12/26
    • trader_mama — MESA Adaptive Moving Average
    • trader_mavp — Moving average with variable period
    • trader_max — Highest value over a specified period
    • trader_maxindex — Index of highest value over a specified period
    • trader_medprice — Median Price
    • trader_mfi — Money Flow Index
    • trader_midpoint — MidPoint over period
    • trader_midprice — Midpoint Price over period
    • trader_min — Lowest value over a specified period
    • trader_minindex — Index of lowest value over a specified period
    • trader_minmax — Lowest and highest values over a specified period
    • trader_minmaxindex — Indexes of lowest and highest values over a specified period
    • trader_minus_di — Minus Directional Indicator
    • trader_minus_dm — Minus Directional Movement
    • trader_mom — Momentum
    • trader_mult — Vector Arithmetic Mult
    • trader_natr — Normalized Average True Range
    • trader_obv — On Balance Volume
    • trader_plus_di — Plus Directional Indicator
    • trader_plus_dm — Plus Directional Movement
    • trader_ppo — Percentage Price Oscillator
    • trader_roc — Rate of change : ((price/prevPrice)-1)*100
    • trader_rocp — Rate of change Percentage: (price-prevPrice)/prevPrice
    • trader_rocr100 — Rate of change ratio 100 scale: (price/prevPrice)*100
    • trader_rocr — Rate of change ratio: (price/prevPrice)
    • trader_rsi — Relative Strength Index
    • trader_sar — Parabolic SAR
    • trader_sarext — Parabolic SAR - Extended
    • trader_set_compat — Set compatibility mode
    • trader_set_unstable_period — Set unstable period
    • trader_sin — Vector Trigonometric Sin
    • trader_sinh — Vector Trigonometric Sinh
    • trader_sma — Simple Moving Average
    • trader_sqrt — Vector Square Root
    • trader_stddev — Standard Deviation
    • trader_stoch — Stochastic
    • trader_stochf — Stochastic Fast
    • trader_stochrsi — Stochastic Relative Strength Index
    • trader_sub — Vector Arithmetic Subtraction
    • trader_sum — Summation
    • trader_t3 — Triple Exponential Moving Average (T3)
    • trader_tan — Vector Trigonometric Tan
    • trader_tanh — Vector Trigonometric Tanh
    • trader_tema — Triple Exponential Moving Average
    • trader_trange — True Range
    • trader_trima — Triangular Moving Average
    • trader_trix — 1-day Rate-Of-Change (ROC) of a Triple Smooth EMA
    • trader_tsf — Time Series Forecast
    • trader_typprice — Typical Price
    • trader_ultosc — Ultimate Oscillator
    • trader_var — Variance
    • trader_wclprice — Weighted Close Price
    • trader_willr — Williams' %R
    • trader_wma — Weighted Moving Average
stats_variance
Giriş
Matematiksel Eklentiler


Giriş

The trader extension is a free open source stock library based on TA-Lib. It's dedicated to trading software developers requiring to perform technical analysis of financial market data. Alongside many indicators like ADX, MACD, RSI, Stochastic, TRIX the candlestick pattern recognition and several vector arithmetic and algebraic functions are present.

Calculations can be done in two modes - TA-Lib and Metastock. Changing it using trader_set_compat() will affect the way some trader functions work.

Some trader functions provide different results depending of the "starting point" of the data being involved. This is often referred as a function having memories. An example of such function is the Exponential Moving Average. It is possible to control the unstable period (the amount of data to strip off) using trader_set_unstable_period() function.

Extended documentation about indicators, formulas and implementations in other programming languages can be found under » tadoc.org.

Trader
Yapılandırma/Kurulum
Trader


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
Giriş
Gereksinimler
Trader


Gereksinimler

The trader extension is based on » TA-Lib. TA-Lib is fully integrated into the extension, therefore no external libraries are needed.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu » PECL eklentisi PHP ile gelmez.

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/trader.

A DLL for this PECL extension is available under » http://windows.php.net/downloads/pecl/releases/trader/.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Trader Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
trader.real_precision | 3 | PHP_INI_ALL | Since trader 0.2.1
trader.real_round_mode | HALF_DOWN | PHP_INI_ALL | Since trader 0.3.0

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

trader.real_precision integer

All the values in the returned arrays will be rounded to this precision. However the calculations inside TA-Lib happen with unrounded values.

trader.real_round_mode string

Controls the trader real rounding policy. Valid values are HALF_UP, HALF_DOWN, HALF_EVEN and HALF_ODD. The behaviour is identical to the round() function used with the mode argument.

Kurulum
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

TRADER_MA_TYPE_SMA (integer)
TRADER_MA_TYPE_EMA (integer)
TRADER_MA_TYPE_WMA (integer)
TRADER_MA_TYPE_DEMA (integer)
TRADER_MA_TYPE_TEMA (integer)
TRADER_MA_TYPE_TRIMA (integer)
TRADER_MA_TYPE_KAMA (integer)
TRADER_MA_TYPE_MAMA (integer)
TRADER_MA_TYPE_T3 (integer)
TRADER_REAL_MIN (double)
TRADER_REAL_MAX (double)
TRADER_FUNC_UNST_ADX (integer)
TRADER_FUNC_UNST_ADXR (integer)
TRADER_FUNC_UNST_ATR (integer)
TRADER_FUNC_UNST_CMO (integer)
TRADER_FUNC_UNST_DX (integer)
TRADER_FUNC_UNST_EMA (integer)
TRADER_FUNC_UNST_HT_DCPERIOD (integer)
TRADER_FUNC_UNST_HT_DCPHASE (integer)
TRADER_FUNC_UNST_HT_PHASOR (integer)
TRADER_FUNC_UNST_HT_SINE (integer)
TRADER_FUNC_UNST_HT_TRENDLINE (integer)
TRADER_FUNC_UNST_HT_TRENDMODE (integer)
TRADER_FUNC_UNST_KAMA (integer)
TRADER_FUNC_UNST_MAMA (integer)
TRADER_FUNC_UNST_MFI (integer)
TRADER_FUNC_UNST_MINUS_DI (integer)
TRADER_FUNC_UNST_MINUS_DM (integer)
TRADER_FUNC_UNST_NATR (integer)
TRADER_FUNC_UNST_PLUS_DI (integer)
TRADER_FUNC_UNST_PLUS_DM (integer)
TRADER_FUNC_UNST_RSI (integer)
TRADER_FUNC_UNST_STOCHRSI (integer)
TRADER_FUNC_UNST_T3 (integer)
TRADER_FUNC_UNST_ALL (integer)
TRADER_FUNC_UNST_NONE (integer)
TRADER_COMPATIBILITY_DEFAULT (integer)
TRADER_COMPATIBILITY_METASTOCK (integer)
TRADER_ERR_SUCCESS (integer)
TRADER_ERR_LIB_NOT_INITIALIZE (integer)
TRADER_ERR_BAD_PARAM (integer)
TRADER_ERR_ALLOC_ERR (integer)
TRADER_ERR_GROUP_NOT_FOUND (integer)
TRADER_ERR_FUNC_NOT_FOUND (integer)
TRADER_ERR_INVALID_HANDLE (integer)
TRADER_ERR_INVALID_PARAM_HOLDER (integer)
TRADER_ERR_INVALID_PARAM_HOLDER_TYPE (integer)
TRADER_ERR_INVALID_PARAM_FUNCTION (integer)
TRADER_ERR_INPUT_NOT_ALL_INITIALIZE (integer)
TRADER_ERR_OUTPUT_NOT_ALL_INITIALIZE (integer)
TRADER_ERR_OUT_OF_RANGE_START_INDEX (integer)
TRADER_ERR_OUT_OF_RANGE_END_INDEX (integer)
TRADER_ERR_INVALID_LIST_TYPE (integer)
TRADER_ERR_BAD_OBJECT (integer)
TRADER_ERR_NOT_SUPPORTED (integer)
TRADER_ERR_INTERNAL_ERROR (integer)
TRADER_ERR_UNKNOWN_ERROR (integer)

Çalışma Anı Yapılandırması
Trader İşlevleri
Trader


Trader İşlevleri

İçindekiler

  • trader_acos — Vector Trigonometric ACos
  • trader_ad — Chaikin A/D Line
  • trader_add — Vector Arithmetic Add
  • trader_adosc — Chaikin A/D Oscillator
  • trader_adx — Average Directional Movement Index
  • trader_adxr — Average Directional Movement Index Rating
  • trader_apo — Absolute Price Oscillator
  • trader_aroon — Aroon
  • trader_aroonosc — Aroon Oscillator
  • trader_asin — Vector Trigonometric ASin
  • trader_atan — Vector Trigonometric ATan
  • trader_atr — Average True Range
  • trader_avgprice — Average Price
  • trader_bbands — Bollinger Bands
  • trader_beta — Beta
  • trader_bop — Balance Of Power
  • trader_cci — Commodity Channel Index
  • trader_cdl2crows — Two Crows
  • trader_cdl3blackcrows — Three Black Crows
  • trader_cdl3inside — Three Inside Up/Down
  • trader_cdl3linestrike — Three-Line Strike
  • trader_cdl3outside — Three Outside Up/Down
  • trader_cdl3starsinsouth — Three Stars In The South
  • trader_cdl3whitesoldiers — Three Advancing White Soldiers
  • trader_cdlabandonedbaby — Abandoned Baby
  • trader_cdladvanceblock — Advance Block
  • trader_cdlbelthold — Belt-hold
  • trader_cdlbreakaway — Breakaway
  • trader_cdlclosingmarubozu — Closing Marubozu
  • trader_cdlconcealbabyswall — Concealing Baby Swallow
  • trader_cdlcounterattack — Counterattack
  • trader_cdldarkcloudcover — Dark Cloud Cover
  • trader_cdldoji — Doji
  • trader_cdldojistar — Doji Star
  • trader_cdldragonflydoji — Dragonfly Doji
  • trader_cdlengulfing — Engulfing Pattern
  • trader_cdleveningdojistar — Evening Doji Star
  • trader_cdleveningstar — Evening Star
  • trader_cdlgapsidesidewhite — Up/Down-gap side-by-side white lines
  • trader_cdlgravestonedoji — Gravestone Doji
  • trader_cdlhammer — Hammer
  • trader_cdlhangingman — Hanging Man
  • trader_cdlharami — Harami Pattern
  • trader_cdlharamicross — Harami Cross Pattern
  • trader_cdlhighwave — High-Wave Candle
  • trader_cdlhikkake — Hikkake Pattern
  • trader_cdlhikkakemod — Modified Hikkake Pattern
  • trader_cdlhomingpigeon — Homing Pigeon
  • trader_cdlidentical3crows — Identical Three Crows
  • trader_cdlinneck — In-Neck Pattern
  • trader_cdlinvertedhammer — Inverted Hammer
  • trader_cdlkicking — Kicking
  • trader_cdlkickingbylength — Kicking - bull/bear determined by the longer marubozu
  • trader_cdlladderbottom — Ladder Bottom
  • trader_cdllongleggeddoji — Long Legged Doji
  • trader_cdllongline — Long Line Candle
  • trader_cdlmarubozu — Marubozu
  • trader_cdlmatchinglow — Matching Low
  • trader_cdlmathold — Mat Hold
  • trader_cdlmorningdojistar — Morning Doji Star
  • trader_cdlmorningstar — Morning Star
  • trader_cdlonneck — On-Neck Pattern
  • trader_cdlpiercing — Piercing Pattern
  • trader_cdlrickshawman — Rickshaw Man
  • trader_cdlrisefall3methods — Rising/Falling Three Methods
  • trader_cdlseparatinglines — Separating Lines
  • trader_cdlshootingstar — Shooting Star
  • trader_cdlshortline — Short Line Candle
  • trader_cdlspinningtop — Spinning Top
  • trader_cdlstalledpattern — Stalled Pattern
  • trader_cdlsticksandwich — Stick Sandwich
  • trader_cdltakuri — Takuri (Dragonfly Doji with very long lower shadow)
  • trader_cdltasukigap — Tasuki Gap
  • trader_cdlthrusting — Thrusting Pattern
  • trader_cdltristar — Tristar Pattern
  • trader_cdlunique3river — Unique 3 River
  • trader_cdlupsidegap2crows — Upside Gap Two Crows
  • trader_cdlxsidegap3methods — Upside/Downside Gap Three Methods
  • trader_ceil — Vector Ceil
  • trader_cmo — Chande Momentum Oscillator
  • trader_correl — Pearson's Correlation Coefficient (r)
  • trader_cos — Vector Trigonometric Cos
  • trader_cosh — Vector Trigonometric Cosh
  • trader_dema — Double Exponential Moving Average
  • trader_div — Vector Arithmetic Div
  • trader_dx — Directional Movement Index
  • trader_ema — Exponential Moving Average
  • trader_errno — Get error code
  • trader_exp — Vector Arithmetic Exp
  • trader_floor — Vector Floor
  • trader_get_compat — Get compatibility mode
  • trader_get_unstable_period — Get unstable period
  • trader_ht_dcperiod — Hilbert Transform - Dominant Cycle Period
  • trader_ht_dcphase — Hilbert Transform - Dominant Cycle Phase
  • trader_ht_phasor — Hilbert Transform - Phasor Components
  • trader_ht_sine — Hilbert Transform - SineWave
  • trader_ht_trendline — Hilbert Transform - Instantaneous Trendline
  • trader_ht_trendmode — Hilbert Transform - Trend vs Cycle Mode
  • trader_kama — Kaufman Adaptive Moving Average
  • trader_linearreg_angle — Linear Regression Angle
  • trader_linearreg_intercept — Linear Regression Intercept
  • trader_linearreg_slope — Linear Regression Slope
  • trader_linearreg — Linear Regression
  • trader_ln — Vector Log Natural
  • trader_log10 — Vector Log10
  • trader_ma — Moving average
  • trader_macd — Moving Average Convergence/Divergence
  • trader_macdext — MACD with controllable MA type
  • trader_macdfix — Moving Average Convergence/Divergence Fix 12/26
  • trader_mama — MESA Adaptive Moving Average
  • trader_mavp — Moving average with variable period
  • trader_max — Highest value over a specified period
  • trader_maxindex — Index of highest value over a specified period
  • trader_medprice — Median Price
  • trader_mfi — Money Flow Index
  • trader_midpoint — MidPoint over period
  • trader_midprice — Midpoint Price over period
  • trader_min — Lowest value over a specified period
  • trader_minindex — Index of lowest value over a specified period
  • trader_minmax — Lowest and highest values over a specified period
  • trader_minmaxindex — Indexes of lowest and highest values over a specified period
  • trader_minus_di — Minus Directional Indicator
  • trader_minus_dm — Minus Directional Movement
  • trader_mom — Momentum
  • trader_mult — Vector Arithmetic Mult
  • trader_natr — Normalized Average True Range
  • trader_obv — On Balance Volume
  • trader_plus_di — Plus Directional Indicator
  • trader_plus_dm — Plus Directional Movement
  • trader_ppo — Percentage Price Oscillator
  • trader_roc — Rate of change : ((price/prevPrice)-1)*100
  • trader_rocp — Rate of change Percentage: (price-prevPrice)/prevPrice
  • trader_rocr100 — Rate of change ratio 100 scale: (price/prevPrice)*100
  • trader_rocr — Rate of change ratio: (price/prevPrice)
  • trader_rsi — Relative Strength Index
  • trader_sar — Parabolic SAR
  • trader_sarext — Parabolic SAR - Extended
  • trader_set_compat — Set compatibility mode
  • trader_set_unstable_period — Set unstable period
  • trader_sin — Vector Trigonometric Sin
  • trader_sinh — Vector Trigonometric Sinh
  • trader_sma — Simple Moving Average
  • trader_sqrt — Vector Square Root
  • trader_stddev — Standard Deviation
  • trader_stoch — Stochastic
  • trader_stochf — Stochastic Fast
  • trader_stochrsi — Stochastic Relative Strength Index
  • trader_sub — Vector Arithmetic Subtraction
  • trader_sum — Summation
  • trader_t3 — Triple Exponential Moving Average (T3)
  • trader_tan — Vector Trigonometric Tan
  • trader_tanh — Vector Trigonometric Tanh
  • trader_tema — Triple Exponential Moving Average
  • trader_trange — True Range
  • trader_trima — Triangular Moving Average
  • trader_trix — 1-day Rate-Of-Change (ROC) of a Triple Smooth EMA
  • trader_tsf — Time Series Forecast
  • trader_typprice — Typical Price
  • trader_ultosc — Ultimate Oscillator
  • trader_var — Variance
  • trader_wclprice — Weighted Close Price
  • trader_willr — Williams' %R
  • trader_wma — Weighted Moving Average
Öntanımlı Sabitler
trader_acos
Trader


Vector Trigonometric ACos

Trader İşlevleri
trader_ad
Trader İşlevleri
PHP Manual

trader_acos

(PECL trader >= 0.2.0)

trader_acos — Vector Trigonometric ACos

Açıklama

array trader_acos ( array $real )

Calculates the arc cosine for each value in real and returns the resulting array.

Değiştirgeler

real

Array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

Trader İşlevleri
trader_ad
Trader İşlevleri


Chaikin A/D Line

trader_acos
trader_add
Trader İşlevleri
PHP Manual

trader_ad

(PECL trader >= 0.2.0)

trader_ad — Chaikin A/D Line

Açıklama

array trader_ad ( array $high , array $low , array $close , array $volume )

Değiştirgeler

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

volume

Volume traded, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_acos
trader_add
Trader İşlevleri


Vector Arithmetic Add

trader_ad
trader_adosc
Trader İşlevleri
PHP Manual

trader_add

(PECL trader >= 0.2.0)

trader_add — Vector Arithmetic Add

Açıklama

array trader_add ( array $real0 , array $real1 )

Calculates the vector addition of real0 to real1 and returns the resulting vector.

Değiştirgeler

real0

Array of real values.

real1

Array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_ad
trader_adosc
Trader İşlevleri


Chaikin A/D Oscillator

trader_add
trader_adx
Trader İşlevleri
PHP Manual

trader_adosc

(PECL trader >= 0.2.0)

trader_adosc — Chaikin A/D Oscillator

Açıklama

array trader_adosc ( array $high , array $low , array $close , array $volume [, integer $fastPeriod [, integer $slowPeriod ]] )

Değiştirgeler

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

volume

Volume traded, array of real values.

fastPeriod

Number of period for the fast MA. Valid range from 2 to 100000.

slowPeriod

Number of period for the slow MA. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_add
trader_adx
Trader İşlevleri


Average Directional Movement Index

trader_adosc
trader_adxr
Trader İşlevleri
PHP Manual

trader_adx

(PECL trader >= 0.2.0)

trader_adx — Average Directional Movement Index

Açıklama

array trader_adx ( array $high , array $low , array $close [, integer $timePeriod ] )

Değiştirgeler

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_adosc
trader_adxr
Trader İşlevleri


Average Directional Movement Index Rating

trader_adx
trader_apo
Trader İşlevleri
PHP Manual

trader_adxr

(PECL trader >= 0.2.0)

trader_adxr — Average Directional Movement Index Rating

Açıklama

array trader_adxr ( array $high , array $low , array $close [, integer $timePeriod ] )

Değiştirgeler

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_adx
trader_apo
Trader İşlevleri


Absolute Price Oscillator

trader_adxr
trader_aroon
Trader İşlevleri
PHP Manual

trader_apo

(PECL trader >= 0.2.0)

trader_apo — Absolute Price Oscillator

Açıklama

array trader_apo ( array $real [, integer $fastPeriod [, integer $slowPeriod [, integer $mAType ]]] )

Değiştirgeler

real

Array of real values.

fastPeriod

Number of period for the fast MA. Valid range from 2 to 100000.

slowPeriod

Number of period for the slow MA. Valid range from 2 to 100000.

mAType

Type of Moving Average. TRADER_MA_TYPE_* series of constants should be used.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_adxr
trader_aroon
Trader İşlevleri


Aroon

trader_apo
trader_aroonosc
Trader İşlevleri
PHP Manual

trader_aroon

(PECL trader >= 0.2.0)

trader_aroon — Aroon

Açıklama

array trader_aroon ( array $high , array $low [, integer $timePeriod ] )

Değiştirgeler

high

High price, array of real values.

low

Low price, array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_apo
trader_aroonosc
Trader İşlevleri


Aroon Oscillator

trader_aroon
trader_asin
Trader İşlevleri
PHP Manual

trader_aroonosc

(PECL trader >= 0.2.0)

trader_aroonosc — Aroon Oscillator

Açıklama

array trader_aroonosc ( array $high , array $low [, integer $timePeriod ] )

Değiştirgeler

high

High price, array of real values.

low

Low price, array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_aroon
trader_asin
Trader İşlevleri


Vector Trigonometric ASin

trader_aroonosc
trader_atan
Trader İşlevleri
PHP Manual

trader_asin

(PECL trader >= 0.2.0)

trader_asin — Vector Trigonometric ASin

Açıklama

array trader_asin ( array $real )

Calculates the arc sine for each value in real and returns the resulting array.

Değiştirgeler

real

Array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_aroonosc
trader_atan
Trader İşlevleri


Vector Trigonometric ATan

trader_asin
trader_atr
Trader İşlevleri
PHP Manual

trader_atan

(PECL trader >= 0.2.0)

trader_atan — Vector Trigonometric ATan

Açıklama

array trader_atan ( array $real )

Calculates the arc tangent for each value in real and returns the resulting array.

Değiştirgeler

real

Array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_asin
trader_atr
Trader İşlevleri


Average True Range

trader_atan
trader_avgprice
Trader İşlevleri
PHP Manual

trader_atr

(PECL trader >= 0.2.0)

trader_atr — Average True Range

Açıklama

array trader_atr ( array $high , array $low , array $close [, integer $timePeriod ] )

Değiştirgeler

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_atan
trader_avgprice
Trader İşlevleri


Average Price

trader_atr
trader_bbands
Trader İşlevleri
PHP Manual

trader_avgprice

(PECL trader >= 0.2.0)

trader_avgprice — Average Price

Açıklama

array trader_avgprice ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_atr
trader_bbands
Trader İşlevleri


Bollinger Bands

trader_avgprice
trader_beta
Trader İşlevleri
PHP Manual

trader_bbands

(PECL trader >= 0.2.0)

trader_bbands — Bollinger Bands

Açıklama

array trader_bbands ( array $real [, integer $timePeriod [, float $nbDevUp [, float $nbDevDn [, integer $mAType ]]]] )

Değiştirgeler

real

Array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

nbDevUp

Deviation multiplier for upper band. Valid range from TRADER_REAL_MIN to TRADER_REAL_MAX.

nbDevDn

Deviation multiplier for lower band. Valid range from TRADER_REAL_MIN to TRADER_REAL_MAX.

mAType

Type of Moving Average. TRADER_MA_TYPE_* series of constants should be used.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_avgprice
trader_beta
Trader İşlevleri


Beta

trader_bbands
trader_bop
Trader İşlevleri
PHP Manual

trader_beta

(PECL trader >= 0.2.0)

trader_beta — Beta

Açıklama

array trader_beta ( array $real0 , array $real1 [, integer $timePeriod ] )

Değiştirgeler

real0

Array of real values.

real1

Array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_bbands
trader_bop
Trader İşlevleri


Balance Of Power

trader_beta
trader_cci
Trader İşlevleri
PHP Manual

trader_bop

(PECL trader >= 0.2.0)

trader_bop — Balance Of Power

Açıklama

array trader_bop ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_beta
trader_cci
Trader İşlevleri


Commodity Channel Index

trader_bop
trader_cdl2crows
Trader İşlevleri
PHP Manual

trader_cci

(PECL trader >= 0.2.0)

trader_cci — Commodity Channel Index

Açıklama

array trader_cci ( array $high , array $low , array $close [, integer $timePeriod ] )

Değiştirgeler

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_bop
trader_cdl2crows
Trader İşlevleri


Two Crows

trader_cci
trader_cdl3blackcrows
Trader İşlevleri
PHP Manual

trader_cdl2crows

(PECL trader >= 0.2.0)

trader_cdl2crows — Two Crows

Açıklama

array trader_cdl2crows ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cci
trader_cdl3blackcrows
Trader İşlevleri


Three Black Crows

trader_cdl2crows
trader_cdl3inside
Trader İşlevleri
PHP Manual

trader_cdl3blackcrows

(PECL trader >= 0.2.0)

trader_cdl3blackcrows — Three Black Crows

Açıklama

array trader_cdl3blackcrows ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdl2crows
trader_cdl3inside
Trader İşlevleri


Three Inside Up/Down

trader_cdl3blackcrows
trader_cdl3linestrike
Trader İşlevleri
PHP Manual

trader_cdl3inside

(PECL trader >= 0.2.0)

trader_cdl3inside — Three Inside Up/Down

Açıklama

array trader_cdl3inside ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdl3blackcrows
trader_cdl3linestrike
Trader İşlevleri


Three-Line Strike

trader_cdl3inside
trader_cdl3outside
Trader İşlevleri
PHP Manual

trader_cdl3linestrike

(PECL trader >= 0.2.0)

trader_cdl3linestrike — Three-Line Strike

Açıklama

array trader_cdl3linestrike ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdl3inside
trader_cdl3outside
Trader İşlevleri


Three Outside Up/Down

trader_cdl3linestrike
trader_cdl3starsinsouth
Trader İşlevleri
PHP Manual

trader_cdl3outside

(PECL trader >= 0.2.0)

trader_cdl3outside — Three Outside Up/Down

Açıklama

array trader_cdl3outside ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdl3linestrike
trader_cdl3starsinsouth
Trader İşlevleri


Three Stars In The South

trader_cdl3outside
trader_cdl3whitesoldiers
Trader İşlevleri
PHP Manual

trader_cdl3starsinsouth

(PECL trader >= 0.2.0)

trader_cdl3starsinsouth — Three Stars In The South

Açıklama

array trader_cdl3starsinsouth ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdl3outside
trader_cdl3whitesoldiers
Trader İşlevleri


Three Advancing White Soldiers

trader_cdl3starsinsouth
trader_cdlabandonedbaby
Trader İşlevleri
PHP Manual

trader_cdl3whitesoldiers

(PECL trader >= 0.2.0)

trader_cdl3whitesoldiers — Three Advancing White Soldiers

Açıklama

array trader_cdl3whitesoldiers ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdl3starsinsouth
trader_cdlabandonedbaby
Trader İşlevleri


Abandoned Baby

trader_cdl3whitesoldiers
trader_cdladvanceblock
Trader İşlevleri
PHP Manual

trader_cdlabandonedbaby

(PECL trader >= 0.2.0)

trader_cdlabandonedbaby — Abandoned Baby

Açıklama

array trader_cdlabandonedbaby ( array $open , array $high , array $low , array $close [, float $penetration ] )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

penetration

Percentage of penetration of a candle within another candle.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdl3whitesoldiers
trader_cdladvanceblock
Trader İşlevleri


Advance Block

trader_cdlabandonedbaby
trader_cdlbelthold
Trader İşlevleri
PHP Manual

trader_cdladvanceblock

(PECL trader >= 0.2.0)

trader_cdladvanceblock — Advance Block

Açıklama

array trader_cdladvanceblock ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdlabandonedbaby
trader_cdlbelthold
Trader İşlevleri


Belt-hold

trader_cdladvanceblock
trader_cdlbreakaway
Trader İşlevleri
PHP Manual

trader_cdlbelthold

(PECL trader >= 0.2.0)

trader_cdlbelthold — Belt-hold

Açıklama

array trader_cdlbelthold ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdladvanceblock
trader_cdlbreakaway
Trader İşlevleri


Breakaway

trader_cdlbelthold
trader_cdlclosingmarubozu
Trader İşlevleri
PHP Manual

trader_cdlbreakaway

(PECL trader >= 0.2.0)

trader_cdlbreakaway — Breakaway

Açıklama

array trader_cdlbreakaway ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdlbelthold
trader_cdlclosingmarubozu
Trader İşlevleri


Closing Marubozu

trader_cdlbreakaway
trader_cdlconcealbabyswall
Trader İşlevleri
PHP Manual

trader_cdlclosingmarubozu

(PECL trader >= 0.2.0)

trader_cdlclosingmarubozu — Closing Marubozu

Açıklama

array trader_cdlclosingmarubozu ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdlbreakaway
trader_cdlconcealbabyswall
Trader İşlevleri


Concealing Baby Swallow

trader_cdlclosingmarubozu
trader_cdlcounterattack
Trader İşlevleri
PHP Manual

trader_cdlconcealbabyswall

(PECL trader >= 0.2.0)

trader_cdlconcealbabyswall — Concealing Baby Swallow

Açıklama

array trader_cdlconcealbabyswall ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdlclosingmarubozu
trader_cdlcounterattack
Trader İşlevleri


Counterattack

trader_cdlconcealbabyswall
trader_cdldarkcloudcover
Trader İşlevleri
PHP Manual

trader_cdlcounterattack

(PECL trader >= 0.2.0)

trader_cdlcounterattack — Counterattack

Açıklama

array trader_cdlcounterattack ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdlconcealbabyswall
trader_cdldarkcloudcover
Trader İşlevleri


Dark Cloud Cover

trader_cdlcounterattack
trader_cdldoji
Trader İşlevleri
PHP Manual

trader_cdldarkcloudcover

(PECL trader >= 0.2.0)

trader_cdldarkcloudcover — Dark Cloud Cover

Açıklama

array trader_cdldarkcloudcover ( array $open , array $high , array $low , array $close [, float $penetration ] )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

penetration

Percentage of penetration of a candle within another candle.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdlcounterattack
trader_cdldoji
Trader İşlevleri


Doji

trader_cdldarkcloudcover
trader_cdldojistar
Trader İşlevleri
PHP Manual

trader_cdldoji

(PECL trader >= 0.2.0)

trader_cdldoji — Doji

Açıklama

array trader_cdldoji ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdldarkcloudcover
trader_cdldojistar
Trader İşlevleri


Doji Star

trader_cdldoji
trader_cdldragonflydoji
Trader İşlevleri
PHP Manual

trader_cdldojistar

(PECL trader >= 0.2.0)

trader_cdldojistar — Doji Star

Açıklama

array trader_cdldojistar ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdldoji
trader_cdldragonflydoji
Trader İşlevleri


Dragonfly Doji

trader_cdldojistar
trader_cdlengulfing
Trader İşlevleri
PHP Manual

trader_cdldragonflydoji

(PECL trader >= 0.2.0)

trader_cdldragonflydoji — Dragonfly Doji

Açıklama

array trader_cdldragonflydoji ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdldojistar
trader_cdlengulfing
Trader İşlevleri


Engulfing Pattern

trader_cdldragonflydoji
trader_cdleveningdojistar
Trader İşlevleri
PHP Manual

trader_cdlengulfing

(PECL trader >= 0.2.0)

trader_cdlengulfing — Engulfing Pattern

Açıklama

array trader_cdlengulfing ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdldragonflydoji
trader_cdleveningdojistar
Trader İşlevleri


Evening Doji Star

trader_cdlengulfing
trader_cdleveningstar
Trader İşlevleri
PHP Manual

trader_cdleveningdojistar

(PECL trader >= 0.2.0)

trader_cdleveningdojistar — Evening Doji Star

Açıklama

array trader_cdleveningdojistar ( array $open , array $high , array $low , array $close [, float $penetration ] )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

penetration

Percentage of penetration of a candle within another candle.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdlengulfing
trader_cdleveningstar
Trader İşlevleri


Evening Star

trader_cdleveningdojistar
trader_cdlgapsidesidewhite
Trader İşlevleri
PHP Manual

trader_cdleveningstar

(PECL trader >= 0.2.0)

trader_cdleveningstar — Evening Star

Açıklama

array trader_cdleveningstar ( array $open , array $high , array $low , array $close [, float $penetration ] )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

penetration

Percentage of penetration of a candle within another candle.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdleveningdojistar
trader_cdlgapsidesidewhite
Trader İşlevleri


Up/Down-gap side-by-side white lines

trader_cdleveningstar
trader_cdlgravestonedoji
Trader İşlevleri
PHP Manual

trader_cdlgapsidesidewhite

(PECL trader >= 0.2.0)

trader_cdlgapsidesidewhite — Up/Down-gap side-by-side white lines

Açıklama

array trader_cdlgapsidesidewhite ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdleveningstar
trader_cdlgravestonedoji
Trader İşlevleri


Gravestone Doji

trader_cdlgapsidesidewhite
trader_cdlhammer
Trader İşlevleri
PHP Manual

trader_cdlgravestonedoji

(PECL trader >= 0.2.0)

trader_cdlgravestonedoji — Gravestone Doji

Açıklama

array trader_cdlgravestonedoji ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdlgapsidesidewhite
trader_cdlhammer
Trader İşlevleri


Hammer

trader_cdlgravestonedoji
trader_cdlhangingman
Trader İşlevleri
PHP Manual

trader_cdlhammer

(PECL trader >= 0.2.0)

trader_cdlhammer — Hammer

Açıklama

array trader_cdlhammer ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdlgravestonedoji
trader_cdlhangingman
Trader İşlevleri


Hanging Man

trader_cdlhammer
trader_cdlharami
Trader İşlevleri
PHP Manual

trader_cdlhangingman

(PECL trader >= 0.2.0)

trader_cdlhangingman — Hanging Man

Açıklama

array trader_cdlhangingman ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdlhammer
trader_cdlharami
Trader İşlevleri


Harami Pattern

trader_cdlhangingman
trader_cdlharamicross
Trader İşlevleri
PHP Manual

trader_cdlharami

(PECL trader >= 0.2.0)

trader_cdlharami — Harami Pattern

Açıklama

array trader_cdlharami ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdlhangingman
trader_cdlharamicross
Trader İşlevleri


Harami Cross Pattern

trader_cdlharami
trader_cdlhighwave
Trader İşlevleri
PHP Manual

trader_cdlharamicross

(PECL trader >= 0.2.0)

trader_cdlharamicross — Harami Cross Pattern

Açıklama

array trader_cdlharamicross ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdlharami
trader_cdlhighwave
Trader İşlevleri


High-Wave Candle

trader_cdlharamicross
trader_cdlhikkake
Trader İşlevleri
PHP Manual

trader_cdlhighwave

(PECL trader >= 0.2.0)

trader_cdlhighwave — High-Wave Candle

Açıklama

array trader_cdlhighwave ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdlharamicross
trader_cdlhikkake
Trader İşlevleri


Hikkake Pattern

trader_cdlhighwave
trader_cdlhikkakemod
Trader İşlevleri
PHP Manual

trader_cdlhikkake

(PECL trader >= 0.2.0)

trader_cdlhikkake — Hikkake Pattern

Açıklama

array trader_cdlhikkake ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdlhighwave
trader_cdlhikkakemod
Trader İşlevleri


Modified Hikkake Pattern

trader_cdlhikkake
trader_cdlhomingpigeon
Trader İşlevleri
PHP Manual

trader_cdlhikkakemod

(PECL trader >= 0.2.0)

trader_cdlhikkakemod — Modified Hikkake Pattern

Açıklama

array trader_cdlhikkakemod ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdlhikkake
trader_cdlhomingpigeon
Trader İşlevleri


Homing Pigeon

trader_cdlhikkakemod
trader_cdlidentical3crows
Trader İşlevleri
PHP Manual

trader_cdlhomingpigeon

(PECL trader >= 0.2.0)

trader_cdlhomingpigeon — Homing Pigeon

Açıklama

array trader_cdlhomingpigeon ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdlhikkakemod
trader_cdlidentical3crows
Trader İşlevleri


Identical Three Crows

trader_cdlhomingpigeon
trader_cdlinneck
Trader İşlevleri
PHP Manual

trader_cdlidentical3crows

(PECL trader >= 0.2.0)

trader_cdlidentical3crows — Identical Three Crows

Açıklama

array trader_cdlidentical3crows ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdlhomingpigeon
trader_cdlinneck
Trader İşlevleri


In-Neck Pattern

trader_cdlidentical3crows
trader_cdlinvertedhammer
Trader İşlevleri
PHP Manual

trader_cdlinneck

(PECL trader >= 0.2.0)

trader_cdlinneck — In-Neck Pattern

Açıklama

array trader_cdlinneck ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdlidentical3crows
trader_cdlinvertedhammer
Trader İşlevleri


Inverted Hammer

trader_cdlinneck
trader_cdlkicking
Trader İşlevleri
PHP Manual

trader_cdlinvertedhammer

(PECL trader >= 0.2.0)

trader_cdlinvertedhammer — Inverted Hammer

Açıklama

array trader_cdlinvertedhammer ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdlinneck
trader_cdlkicking
Trader İşlevleri


Kicking

trader_cdlinvertedhammer
trader_cdlkickingbylength
Trader İşlevleri
PHP Manual

trader_cdlkicking

(PECL trader >= 0.2.0)

trader_cdlkicking — Kicking

Açıklama

array trader_cdlkicking ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdlinvertedhammer
trader_cdlkickingbylength
Trader İşlevleri


Kicking - bull/bear determined by the longer marubozu

trader_cdlkicking
trader_cdlladderbottom
Trader İşlevleri
PHP Manual

trader_cdlkickingbylength

(PECL trader >= 0.2.0)

trader_cdlkickingbylength — Kicking - bull/bear determined by the longer marubozu

Açıklama

array trader_cdlkickingbylength ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdlkicking
trader_cdlladderbottom
Trader İşlevleri


Ladder Bottom

trader_cdlkickingbylength
trader_cdllongleggeddoji
Trader İşlevleri
PHP Manual

trader_cdlladderbottom

(PECL trader >= 0.2.0)

trader_cdlladderbottom — Ladder Bottom

Açıklama

array trader_cdlladderbottom ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdlkickingbylength
trader_cdllongleggeddoji
Trader İşlevleri


Long Legged Doji

trader_cdlladderbottom
trader_cdllongline
Trader İşlevleri
PHP Manual

trader_cdllongleggeddoji

(PECL trader >= 0.2.0)

trader_cdllongleggeddoji — Long Legged Doji

Açıklama

array trader_cdllongleggeddoji ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdlladderbottom
trader_cdllongline
Trader İşlevleri


Long Line Candle

trader_cdllongleggeddoji
trader_cdlmarubozu
Trader İşlevleri
PHP Manual

trader_cdllongline

(PECL trader >= 0.2.0)

trader_cdllongline — Long Line Candle

Açıklama

array trader_cdllongline ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdllongleggeddoji
trader_cdlmarubozu
Trader İşlevleri


Marubozu

trader_cdllongline
trader_cdlmatchinglow
Trader İşlevleri
PHP Manual

trader_cdlmarubozu

(PECL trader >= 0.2.0)

trader_cdlmarubozu — Marubozu

Açıklama

array trader_cdlmarubozu ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdllongline
trader_cdlmatchinglow
Trader İşlevleri


Matching Low

trader_cdlmarubozu
trader_cdlmathold
Trader İşlevleri
PHP Manual

trader_cdlmatchinglow

(PECL trader >= 0.2.0)

trader_cdlmatchinglow — Matching Low

Açıklama

array trader_cdlmatchinglow ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdlmarubozu
trader_cdlmathold
Trader İşlevleri


Mat Hold

trader_cdlmatchinglow
trader_cdlmorningdojistar
Trader İşlevleri
PHP Manual

trader_cdlmathold

(PECL trader >= 0.2.0)

trader_cdlmathold — Mat Hold

Açıklama

array trader_cdlmathold ( array $open , array $high , array $low , array $close [, float $penetration ] )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

penetration

Percentage of penetration of a candle within another candle.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdlmatchinglow
trader_cdlmorningdojistar
Trader İşlevleri


Morning Doji Star

trader_cdlmathold
trader_cdlmorningstar
Trader İşlevleri
PHP Manual

trader_cdlmorningdojistar

(PECL trader >= 0.2.0)

trader_cdlmorningdojistar — Morning Doji Star

Açıklama

array trader_cdlmorningdojistar ( array $open , array $high , array $low , array $close [, float $penetration ] )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

penetration

Percentage of penetration of a candle within another candle.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdlmathold
trader_cdlmorningstar
Trader İşlevleri


Morning Star

trader_cdlmorningdojistar
trader_cdlonneck
Trader İşlevleri
PHP Manual

trader_cdlmorningstar

(PECL trader >= 0.2.0)

trader_cdlmorningstar — Morning Star

Açıklama

array trader_cdlmorningstar ( array $open , array $high , array $low , array $close [, float $penetration ] )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

penetration

Percentage of penetration of a candle within another candle.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdlmorningdojistar
trader_cdlonneck
Trader İşlevleri


On-Neck Pattern

trader_cdlmorningstar
trader_cdlpiercing
Trader İşlevleri
PHP Manual

trader_cdlonneck

(PECL trader >= 0.2.0)

trader_cdlonneck — On-Neck Pattern

Açıklama

array trader_cdlonneck ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdlmorningstar
trader_cdlpiercing
Trader İşlevleri


Piercing Pattern

trader_cdlonneck
trader_cdlrickshawman
Trader İşlevleri
PHP Manual

trader_cdlpiercing

(PECL trader >= 0.2.0)

trader_cdlpiercing — Piercing Pattern

Açıklama

array trader_cdlpiercing ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdlonneck
trader_cdlrickshawman
Trader İşlevleri


Rickshaw Man

trader_cdlpiercing
trader_cdlrisefall3methods
Trader İşlevleri
PHP Manual

trader_cdlrickshawman

(PECL trader >= 0.2.0)

trader_cdlrickshawman — Rickshaw Man

Açıklama

array trader_cdlrickshawman ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdlpiercing
trader_cdlrisefall3methods
Trader İşlevleri


Rising/Falling Three Methods

trader_cdlrickshawman
trader_cdlseparatinglines
Trader İşlevleri
PHP Manual

trader_cdlrisefall3methods

(PECL trader >= 0.2.0)

trader_cdlrisefall3methods — Rising/Falling Three Methods

Açıklama

array trader_cdlrisefall3methods ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdlrickshawman
trader_cdlseparatinglines
Trader İşlevleri


Separating Lines

trader_cdlrisefall3methods
trader_cdlshootingstar
Trader İşlevleri
PHP Manual

trader_cdlseparatinglines

(PECL trader >= 0.2.0)

trader_cdlseparatinglines — Separating Lines

Açıklama

array trader_cdlseparatinglines ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdlrisefall3methods
trader_cdlshootingstar
Trader İşlevleri


Shooting Star

trader_cdlseparatinglines
trader_cdlshortline
Trader İşlevleri
PHP Manual

trader_cdlshootingstar

(PECL trader >= 0.2.0)

trader_cdlshootingstar — Shooting Star

Açıklama

array trader_cdlshootingstar ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdlseparatinglines
trader_cdlshortline
Trader İşlevleri


Short Line Candle

trader_cdlshootingstar
trader_cdlspinningtop
Trader İşlevleri
PHP Manual

trader_cdlshortline

(PECL trader >= 0.2.0)

trader_cdlshortline — Short Line Candle

Açıklama

array trader_cdlshortline ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdlshootingstar
trader_cdlspinningtop
Trader İşlevleri


Spinning Top

trader_cdlshortline
trader_cdlstalledpattern
Trader İşlevleri
PHP Manual

trader_cdlspinningtop

(PECL trader >= 0.2.0)

trader_cdlspinningtop — Spinning Top

Açıklama

array trader_cdlspinningtop ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdlshortline
trader_cdlstalledpattern
Trader İşlevleri


Stalled Pattern

trader_cdlspinningtop
trader_cdlsticksandwich
Trader İşlevleri
PHP Manual

trader_cdlstalledpattern

(PECL trader >= 0.2.0)

trader_cdlstalledpattern — Stalled Pattern

Açıklama

array trader_cdlstalledpattern ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdlspinningtop
trader_cdlsticksandwich
Trader İşlevleri


Stick Sandwich

trader_cdlstalledpattern
trader_cdltakuri
Trader İşlevleri
PHP Manual

trader_cdlsticksandwich

(PECL trader >= 0.2.0)

trader_cdlsticksandwich — Stick Sandwich

Açıklama

array trader_cdlsticksandwich ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdlstalledpattern
trader_cdltakuri
Trader İşlevleri


Takuri (Dragonfly Doji with very long lower shadow)

trader_cdlsticksandwich
trader_cdltasukigap
Trader İşlevleri
PHP Manual

trader_cdltakuri

(PECL trader >= 0.2.0)

trader_cdltakuri — Takuri (Dragonfly Doji with very long lower shadow)

Açıklama

array trader_cdltakuri ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdlsticksandwich
trader_cdltasukigap
Trader İşlevleri


Tasuki Gap

trader_cdltakuri
trader_cdlthrusting
Trader İşlevleri
PHP Manual

trader_cdltasukigap

(PECL trader >= 0.2.0)

trader_cdltasukigap — Tasuki Gap

Açıklama

array trader_cdltasukigap ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdltakuri
trader_cdlthrusting
Trader İşlevleri


Thrusting Pattern

trader_cdltasukigap
trader_cdltristar
Trader İşlevleri
PHP Manual

trader_cdlthrusting

(PECL trader >= 0.2.0)

trader_cdlthrusting — Thrusting Pattern

Açıklama

array trader_cdlthrusting ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdltasukigap
trader_cdltristar
Trader İşlevleri


Tristar Pattern

trader_cdlthrusting
trader_cdlunique3river
Trader İşlevleri
PHP Manual

trader_cdltristar

(PECL trader >= 0.2.0)

trader_cdltristar — Tristar Pattern

Açıklama

array trader_cdltristar ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdlthrusting
trader_cdlunique3river
Trader İşlevleri


Unique 3 River

trader_cdltristar
trader_cdlupsidegap2crows
Trader İşlevleri
PHP Manual

trader_cdlunique3river

(PECL trader >= 0.2.0)

trader_cdlunique3river — Unique 3 River

Açıklama

array trader_cdlunique3river ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdltristar
trader_cdlupsidegap2crows
Trader İşlevleri


Upside Gap Two Crows

trader_cdlunique3river
trader_cdlxsidegap3methods
Trader İşlevleri
PHP Manual

trader_cdlupsidegap2crows

(PECL trader >= 0.2.0)

trader_cdlupsidegap2crows — Upside Gap Two Crows

Açıklama

array trader_cdlupsidegap2crows ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdlunique3river
trader_cdlxsidegap3methods
Trader İşlevleri


Upside/Downside Gap Three Methods

trader_cdlupsidegap2crows
trader_ceil
Trader İşlevleri
PHP Manual

trader_cdlxsidegap3methods

(PECL trader >= 0.2.0)

trader_cdlxsidegap3methods — Upside/Downside Gap Three Methods

Açıklama

array trader_cdlxsidegap3methods ( array $open , array $high , array $low , array $close )

Değiştirgeler

open

Opening price, array of real values.

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdlupsidegap2crows
trader_ceil
Trader İşlevleri


Vector Ceil

trader_cdlxsidegap3methods
trader_cmo
Trader İşlevleri
PHP Manual

trader_ceil

(PECL trader >= 0.2.0)

trader_ceil — Vector Ceil

Açıklama

array trader_ceil ( array $real )

Calculates the next higest integer for each value in real and returns the resulting array.

Değiştirgeler

real

Array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cdlxsidegap3methods
trader_cmo
Trader İşlevleri


Chande Momentum Oscillator

trader_ceil
trader_correl
Trader İşlevleri
PHP Manual

trader_cmo

(PECL trader >= 0.2.0)

trader_cmo — Chande Momentum Oscillator

Açıklama

array trader_cmo ( array $real [, integer $timePeriod ] )

Değiştirgeler

real

Array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_ceil
trader_correl
Trader İşlevleri


Pearson's Correlation Coefficient (r)

trader_cmo
trader_cos
Trader İşlevleri
PHP Manual

trader_correl

(PECL trader >= 0.2.0)

trader_correl — Pearson's Correlation Coefficient (r)

Açıklama

array trader_correl ( array $real0 , array $real1 [, integer $timePeriod ] )

Değiştirgeler

real0

Array of real values.

real1

Array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cmo
trader_cos
Trader İşlevleri


Vector Trigonometric Cos

trader_correl
trader_cosh
Trader İşlevleri
PHP Manual

trader_cos

(PECL trader >= 0.2.0)

trader_cos — Vector Trigonometric Cos

Açıklama

array trader_cos ( array $real )

Calculates the cosine for each value in real and returns the resulting array.

Değiştirgeler

real

Array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_correl
trader_cosh
Trader İşlevleri


Vector Trigonometric Cosh

trader_cos
trader_dema
Trader İşlevleri
PHP Manual

trader_cosh

(PECL trader >= 0.2.0)

trader_cosh — Vector Trigonometric Cosh

Açıklama

array trader_cosh ( array $real )

Calculates the hyperbolic cosine for each value in real and returns the resulting array.

Değiştirgeler

real

Array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cos
trader_dema
Trader İşlevleri


Double Exponential Moving Average

trader_cosh
trader_div
Trader İşlevleri
PHP Manual

trader_dema

(PECL trader >= 0.2.0)

trader_dema — Double Exponential Moving Average

Açıklama

array trader_dema ( array $real [, integer $timePeriod ] )

Değiştirgeler

real

Array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_cosh
trader_div
Trader İşlevleri


Vector Arithmetic Div

trader_dema
trader_dx
Trader İşlevleri
PHP Manual

trader_div

(PECL trader >= 0.2.0)

trader_div — Vector Arithmetic Div

Açıklama

array trader_div ( array $real0 , array $real1 )

Divides each value from real0 by the corresponding value from real1 and returns the resulting array.

Değiştirgeler

real0

Array of real values.

real1

Array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_dema
trader_dx
Trader İşlevleri


Directional Movement Index

trader_div
trader_ema
Trader İşlevleri
PHP Manual

trader_dx

(PECL trader >= 0.2.0)

trader_dx — Directional Movement Index

Açıklama

array trader_dx ( array $high , array $low , array $close [, integer $timePeriod ] )

Değiştirgeler

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_div
trader_ema
Trader İşlevleri


Exponential Moving Average

trader_dx
trader_errno
Trader İşlevleri
PHP Manual

trader_ema

(PECL trader >= 0.2.0)

trader_ema — Exponential Moving Average

Açıklama

array trader_ema ( array $real [, integer $timePeriod ] )

Değiştirgeler

real

Array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_dx
trader_errno
Trader İşlevleri


Get error code

trader_ema
trader_exp
Trader İşlevleri
PHP Manual

trader_errno

(PECL trader >= 0.3.0)

trader_errno — Get error code

Açıklama

integer trader_errno ( void )

Get error code of the last operation.

Dönen Değerler

Returns the error code identified by one of the TRADER_ERR_* constants.

trader_ema
trader_exp
Trader İşlevleri


Vector Arithmetic Exp

trader_errno
trader_floor
Trader İşlevleri
PHP Manual

trader_exp

(PECL trader >= 0.2.0)

trader_exp — Vector Arithmetic Exp

Açıklama

array trader_exp ( array $real )

Calculates e raised to the power of each value in real. Returns an array with the calculated data.

Değiştirgeler

real

Array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_errno
trader_floor
Trader İşlevleri


Vector Floor

trader_exp
trader_get_compat
Trader İşlevleri
PHP Manual

trader_floor

(PECL trader >= 0.2.0)

trader_floor — Vector Floor

Açıklama

array trader_floor ( array $real )

Calculates the next lowest integer for each value in real and returns the resulting array.

Değiştirgeler

real

Array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_exp
trader_get_compat
Trader İşlevleri


Get compatibility mode

trader_floor
trader_get_unstable_period
Trader İşlevleri
PHP Manual

trader_get_compat

(PECL trader >= 0.2.2)

trader_get_compat — Get compatibility mode

Açıklama

integer trader_get_compat ( void )

Get compatibility mode which affects the way calculations are done by all the extension functions.

Dönen Değerler

Returns the compatibility mode id which can be identified by TRADER_COMPATIBILITY_* series of constants.

trader_floor
trader_get_unstable_period
Trader İşlevleri


Get unstable period

trader_get_compat
trader_ht_dcperiod
Trader İşlevleri
PHP Manual

trader_get_unstable_period

(PECL trader >= 0.2.2)

trader_get_unstable_period — Get unstable period

Açıklama

integer trader_get_unstable_period ( integer $functionId )

Get unstable period factor for a particular function.

Değiştirgeler

functionId

Function ID the factor to be read for. TRADER_FUNC_UNST_* series of constants should be used.

Dönen Değerler

Returns the unstable period factor for the corresponding function.

trader_get_compat
trader_ht_dcperiod
Trader İşlevleri


Hilbert Transform - Dominant Cycle Period

trader_get_unstable_period
trader_ht_dcphase
Trader İşlevleri
PHP Manual

trader_ht_dcperiod

(PECL trader >= 0.2.0)

trader_ht_dcperiod — Hilbert Transform - Dominant Cycle Period

Açıklama

array trader_ht_dcperiod ( array $real )

Değiştirgeler

real

Array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_get_unstable_period
trader_ht_dcphase
Trader İşlevleri


Hilbert Transform - Dominant Cycle Phase

trader_ht_dcperiod
trader_ht_phasor
Trader İşlevleri
PHP Manual

trader_ht_dcphase

(PECL trader >= 0.2.0)

trader_ht_dcphase — Hilbert Transform - Dominant Cycle Phase

Açıklama

array trader_ht_dcphase ( array $real )

Değiştirgeler

real

Array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_ht_dcperiod
trader_ht_phasor
Trader İşlevleri


Hilbert Transform - Phasor Components

trader_ht_dcphase
trader_ht_sine
Trader İşlevleri
PHP Manual

trader_ht_phasor

(PECL trader >= 0.2.0)

trader_ht_phasor — Hilbert Transform - Phasor Components

Açıklama

array trader_ht_phasor ( array $real )

Değiştirgeler

real

Array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_ht_dcphase
trader_ht_sine
Trader İşlevleri


Hilbert Transform - SineWave

trader_ht_phasor
trader_ht_trendline
Trader İşlevleri
PHP Manual

trader_ht_sine

(PECL trader >= 0.2.0)

trader_ht_sine — Hilbert Transform - SineWave

Açıklama

array trader_ht_sine ( array $real )

Değiştirgeler

real

Array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_ht_phasor
trader_ht_trendline
Trader İşlevleri


Hilbert Transform - Instantaneous Trendline

trader_ht_sine
trader_ht_trendmode
Trader İşlevleri
PHP Manual

trader_ht_trendline

(PECL trader >= 0.2.0)

trader_ht_trendline — Hilbert Transform - Instantaneous Trendline

Açıklama

array trader_ht_trendline ( array $real )

Değiştirgeler

real

Array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_ht_sine
trader_ht_trendmode
Trader İşlevleri


Hilbert Transform - Trend vs Cycle Mode

trader_ht_trendline
trader_kama
Trader İşlevleri
PHP Manual

trader_ht_trendmode

(PECL trader >= 0.2.0)

trader_ht_trendmode — Hilbert Transform - Trend vs Cycle Mode

Açıklama

array trader_ht_trendmode ( array $real )

Değiştirgeler

real

Array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_ht_trendline
trader_kama
Trader İşlevleri


Kaufman Adaptive Moving Average

trader_ht_trendmode
trader_linearreg_angle
Trader İşlevleri
PHP Manual

trader_kama

(PECL trader >= 0.2.0)

trader_kama — Kaufman Adaptive Moving Average

Açıklama

array trader_kama ( array $real [, integer $timePeriod ] )

Değiştirgeler

real

Array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_ht_trendmode
trader_linearreg_angle
Trader İşlevleri


Linear Regression Angle

trader_kama
trader_linearreg_intercept
Trader İşlevleri
PHP Manual

trader_linearreg_angle

(PECL trader >= 0.2.0)

trader_linearreg_angle — Linear Regression Angle

Açıklama

array trader_linearreg_angle ( array $real [, integer $timePeriod ] )

Değiştirgeler

real

Array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_kama
trader_linearreg_intercept
Trader İşlevleri


Linear Regression Intercept

trader_linearreg_angle
trader_linearreg_slope
Trader İşlevleri
PHP Manual

trader_linearreg_intercept

(PECL trader >= 0.2.0)

trader_linearreg_intercept — Linear Regression Intercept

Açıklama

array trader_linearreg_intercept ( array $real [, integer $timePeriod ] )

Değiştirgeler

real

Array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_linearreg_angle
trader_linearreg_slope
Trader İşlevleri


Linear Regression Slope

trader_linearreg_intercept
trader_linearreg
Trader İşlevleri
PHP Manual

trader_linearreg_slope

(PECL trader >= 0.2.0)

trader_linearreg_slope — Linear Regression Slope

Açıklama

array trader_linearreg_slope ( array $real [, integer $timePeriod ] )

Değiştirgeler

real

Array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_linearreg_intercept
trader_linearreg
Trader İşlevleri


Linear Regression

trader_linearreg_slope
trader_ln
Trader İşlevleri
PHP Manual

trader_linearreg

(PECL trader >= 0.2.0)

trader_linearreg — Linear Regression

Açıklama

array trader_linearreg ( array $real [, integer $timePeriod ] )

Değiştirgeler

real

Array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_linearreg_slope
trader_ln
Trader İşlevleri


Vector Log Natural

trader_linearreg
trader_log10
Trader İşlevleri
PHP Manual

trader_ln

(PECL trader >= 0.2.0)

trader_ln — Vector Log Natural

Açıklama

array trader_ln ( array $real )

Calculates the natural logarithm for each value in real and returns the resulting array.

Değiştirgeler

real

Array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_linearreg
trader_log10
Trader İşlevleri


Vector Log10

trader_ln
trader_ma
Trader İşlevleri
PHP Manual

trader_log10

(PECL trader >= 0.2.0)

trader_log10 — Vector Log10

Açıklama

array trader_log10 ( array $real )

Calculates the base-10 logarithm for each value in real and returns the resulting array.

Değiştirgeler

real

Array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_ln
trader_ma
Trader İşlevleri


Moving average

trader_log10
trader_macd
Trader İşlevleri
PHP Manual

trader_ma

(PECL trader >= 0.2.0)

trader_ma — Moving average

Açıklama

array trader_ma ( array $real [, integer $timePeriod [, integer $mAType ]] )

Değiştirgeler

real

Array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

mAType

Type of Moving Average. TRADER_MA_TYPE_* series of constants should be used.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_log10
trader_macd
Trader İşlevleri


Moving Average Convergence/Divergence

trader_ma
trader_macdext
Trader İşlevleri
PHP Manual

trader_macd

(PECL trader >= 0.2.0)

trader_macd — Moving Average Convergence/Divergence

Açıklama

array trader_macd ( array $real [, integer $fastPeriod [, integer $slowPeriod [, integer $signalPeriod ]]] )

Değiştirgeler

real

Array of real values.

fastPeriod

Number of period for the fast MA. Valid range from 2 to 100000.

slowPeriod

Number of period for the slow MA. Valid range from 2 to 100000.

signalPeriod

Smoothing for the signal line (nb of period). Valid range from 1 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_ma
trader_macdext
Trader İşlevleri


MACD with controllable MA type

trader_macd
trader_macdfix
Trader İşlevleri
PHP Manual

trader_macdext

(PECL trader >= 0.2.0)

trader_macdext — MACD with controllable MA type

Açıklama

array trader_macdext ( array $real [, integer $fastPeriod [, integer $fastMAType [, integer $slowPeriod [, integer $slowMAType [, integer $signalPeriod [, integer $signalMAType ]]]]]] )

Değiştirgeler

real

Array of real values.

fastPeriod

Number of period for the fast MA. Valid range from 2 to 100000.

fastMAType

Type of Moving Average for fast MA. TRADER_MA_TYPE_* series of constants should be used.

slowPeriod

Number of period for the slow MA. Valid range from 2 to 100000.

slowMAType

Type of Moving Average for slow MA. TRADER_MA_TYPE_* series of constants should be used.

signalPeriod

Smoothing for the signal line (nb of period). Valid range from 1 to 100000.

signalMAType

Type of Moving Average for signal line. TRADER_MA_TYPE_* series of constants should be used.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_macd
trader_macdfix
Trader İşlevleri


Moving Average Convergence/Divergence Fix 12/26

trader_macdext
trader_mama
Trader İşlevleri
PHP Manual

trader_macdfix

(PECL trader >= 0.2.0)

trader_macdfix — Moving Average Convergence/Divergence Fix 12/26

Açıklama

array trader_macdfix ( array $real [, integer $signalPeriod ] )

Değiştirgeler

real

Array of real values.

signalPeriod

Smoothing for the signal line (nb of period). Valid range from 1 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_macdext
trader_mama
Trader İşlevleri


MESA Adaptive Moving Average

trader_macdfix
trader_mavp
Trader İşlevleri
PHP Manual

trader_mama

(PECL trader >= 0.2.0)

trader_mama — MESA Adaptive Moving Average

Açıklama

array trader_mama ( array $real [, float $fastLimit [, float $slowLimit ]] )

Değiştirgeler

real

Array of real values.

fastLimit

Upper limit use in the adaptive algorithm. Valid range from 0.01 to 0.99.

slowLimit

Lower limit use in the adaptive algorithm. Valid range from 0.01 to 0.99.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_macdfix
trader_mavp
Trader İşlevleri


Moving average with variable period

trader_mama
trader_max
Trader İşlevleri
PHP Manual

trader_mavp

(PECL trader >= 0.2.0)

trader_mavp — Moving average with variable period

Açıklama

array trader_mavp ( array $real , array $periods [, integer $minPeriod [, integer $maxPeriod [, integer $mAType ]]] )

Değiştirgeler

real

Array of real values.

periods

Array of real values.

minPeriod

Value less than minimum will be changed to Minimum period. Valid range from 2 to 100000

maxPeriod

Value higher than minimum will be changed to Maximum period. Valid range from 2 to 100000

mAType

Type of Moving Average. TRADER_MA_TYPE_* series of constants should be used.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_mama
trader_max
Trader İşlevleri


Highest value over a specified period

trader_mavp
trader_maxindex
Trader İşlevleri
PHP Manual

trader_max

(PECL trader >= 0.2.0)

trader_max — Highest value over a specified period

Açıklama

array trader_max ( array $real [, integer $timePeriod ] )

Değiştirgeler

real

Array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_mavp
trader_maxindex
Trader İşlevleri


Index of highest value over a specified period

trader_max
trader_medprice
Trader İşlevleri
PHP Manual

trader_maxindex

(PECL trader >= 0.2.0)

trader_maxindex — Index of highest value over a specified period

Açıklama

array trader_maxindex ( array $real [, integer $timePeriod ] )

Değiştirgeler

real

Array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_max
trader_medprice
Trader İşlevleri


Median Price

trader_maxindex
trader_mfi
Trader İşlevleri
PHP Manual

trader_medprice

(PECL trader >= 0.2.0)

trader_medprice — Median Price

Açıklama

array trader_medprice ( array $high , array $low )

Değiştirgeler

high

High price, array of real values.

low

Low price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_maxindex
trader_mfi
Trader İşlevleri


Money Flow Index

trader_medprice
trader_midpoint
Trader İşlevleri
PHP Manual

trader_mfi

(PECL trader >= 0.2.0)

trader_mfi — Money Flow Index

Açıklama

array trader_mfi ( array $high , array $low , array $close , array $volume [, integer $timePeriod ] )

Değiştirgeler

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

volume

Volume traded, array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_medprice
trader_midpoint
Trader İşlevleri


MidPoint over period

trader_mfi
trader_midprice
Trader İşlevleri
PHP Manual

trader_midpoint

(PECL trader >= 0.2.0)

trader_midpoint — MidPoint over period

Açıklama

array trader_midpoint ( array $real [, integer $timePeriod ] )

Değiştirgeler

real

Array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_mfi
trader_midprice
Trader İşlevleri


Midpoint Price over period

trader_midpoint
trader_min
Trader İşlevleri
PHP Manual

trader_midprice

(PECL trader >= 0.2.0)

trader_midprice — Midpoint Price over period

Açıklama

array trader_midprice ( array $high , array $low [, integer $timePeriod ] )

Değiştirgeler

high

High price, array of real values.

low

Low price, array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_midpoint
trader_min
Trader İşlevleri


Lowest value over a specified period

trader_midprice
trader_minindex
Trader İşlevleri
PHP Manual

trader_min

(PECL trader >= 0.2.0)

trader_min — Lowest value over a specified period

Açıklama

array trader_min ( array $real [, integer $timePeriod ] )

Değiştirgeler

real

Array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_midprice
trader_minindex
Trader İşlevleri


Index of lowest value over a specified period

trader_min
trader_minmax
Trader İşlevleri
PHP Manual

trader_minindex

(PECL trader >= 0.2.0)

trader_minindex — Index of lowest value over a specified period

Açıklama

array trader_minindex ( array $real [, integer $timePeriod ] )

Değiştirgeler

real

Array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_min
trader_minmax
Trader İşlevleri


Lowest and highest values over a specified period

trader_minindex
trader_minmaxindex
Trader İşlevleri
PHP Manual

trader_minmax

(PECL trader >= 0.2.0)

trader_minmax — Lowest and highest values over a specified period

Açıklama

array trader_minmax ( array $real [, integer $timePeriod ] )

Değiştirgeler

real

Array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_minindex
trader_minmaxindex
Trader İşlevleri


Indexes of lowest and highest values over a specified period

trader_minmax
trader_minus_di
Trader İşlevleri
PHP Manual

trader_minmaxindex

(PECL trader >= 0.2.0)

trader_minmaxindex — Indexes of lowest and highest values over a specified period

Açıklama

array trader_minmaxindex ( array $real [, integer $timePeriod ] )

Değiştirgeler

real

Array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_minmax
trader_minus_di
Trader İşlevleri


Minus Directional Indicator

trader_minmaxindex
trader_minus_dm
Trader İşlevleri
PHP Manual

trader_minus_di

(PECL trader >= 0.2.0)

trader_minus_di — Minus Directional Indicator

Açıklama

array trader_minus_di ( array $high , array $low , array $close [, integer $timePeriod ] )

Değiştirgeler

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_minmaxindex
trader_minus_dm
Trader İşlevleri


Minus Directional Movement

trader_minus_di
trader_mom
Trader İşlevleri
PHP Manual

trader_minus_dm

(PECL trader >= 0.2.0)

trader_minus_dm — Minus Directional Movement

Açıklama

array trader_minus_dm ( array $high , array $low [, integer $timePeriod ] )

Değiştirgeler

high

High price, array of real values.

low

Low price, array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_minus_di
trader_mom
Trader İşlevleri


Momentum

trader_minus_dm
trader_mult
Trader İşlevleri
PHP Manual

trader_mom

(PECL trader >= 0.2.0)

trader_mom — Momentum

Açıklama

array trader_mom ( array $real [, integer $timePeriod ] )

Değiştirgeler

real

Array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_minus_dm
trader_mult
Trader İşlevleri


Vector Arithmetic Mult

trader_mom
trader_natr
Trader İşlevleri
PHP Manual

trader_mult

(PECL trader >= 0.2.0)

trader_mult — Vector Arithmetic Mult

Açıklama

array trader_mult ( array $real0 , array $real1 )

Calculates the vector dot product of real0 with real1 and returns the resulting vector.

Değiştirgeler

real0

Array of real values.

real1

Array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_mom
trader_natr
Trader İşlevleri


Normalized Average True Range

trader_mult
trader_obv
Trader İşlevleri
PHP Manual

trader_natr

(PECL trader >= 0.2.0)

trader_natr — Normalized Average True Range

Açıklama

array trader_natr ( array $high , array $low , array $close [, integer $timePeriod ] )

Değiştirgeler

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_mult
trader_obv
Trader İşlevleri


On Balance Volume

trader_natr
trader_plus_di
Trader İşlevleri
PHP Manual

trader_obv

(PECL trader >= 0.2.0)

trader_obv — On Balance Volume

Açıklama

array trader_obv ( array $real , array $volume )

Değiştirgeler

real

Array of real values.

volume

Volume traded, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_natr
trader_plus_di
Trader İşlevleri


Plus Directional Indicator

trader_obv
trader_plus_dm
Trader İşlevleri
PHP Manual

trader_plus_di

(PECL trader >= 0.2.0)

trader_plus_di — Plus Directional Indicator

Açıklama

array trader_plus_di ( array $high , array $low , array $close [, integer $timePeriod ] )

Değiştirgeler

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_obv
trader_plus_dm
Trader İşlevleri


Plus Directional Movement

trader_plus_di
trader_ppo
Trader İşlevleri
PHP Manual

trader_plus_dm

(PECL trader >= 0.2.0)

trader_plus_dm — Plus Directional Movement

Açıklama

array trader_plus_dm ( array $high , array $low [, integer $timePeriod ] )

Değiştirgeler

high

High price, array of real values.

low

Low price, array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_plus_di
trader_ppo
Trader İşlevleri


Percentage Price Oscillator

trader_plus_dm
trader_roc
Trader İşlevleri
PHP Manual

trader_ppo

(PECL trader >= 0.2.0)

trader_ppo — Percentage Price Oscillator

Açıklama

array trader_ppo ( array $real [, integer $fastPeriod [, integer $slowPeriod [, integer $mAType ]]] )

Değiştirgeler

real

Array of real values.

fastPeriod

Number of period for the fast MA. Valid range from 2 to 100000.

slowPeriod

Number of period for the slow MA. Valid range from 2 to 100000.

mAType

Type of Moving Average. TRADER_MA_TYPE_* series of constants should be used.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_plus_dm
trader_roc
Trader İşlevleri


Rate of change : ((price/prevPrice)-1)*100

trader_ppo
trader_rocp
Trader İşlevleri
PHP Manual

trader_roc

(PECL trader >= 0.2.0)

trader_roc — Rate of change : ((price/prevPrice)-1)*100

Açıklama

array trader_roc ( array $real [, integer $timePeriod ] )

Değiştirgeler

real

Array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_ppo
trader_rocp
Trader İşlevleri


Rate of change Percentage: (price-prevPrice)/prevPrice

trader_roc
trader_rocr100
Trader İşlevleri
PHP Manual

trader_rocp

(PECL trader >= 0.2.0)

trader_rocp — Rate of change Percentage: (price-prevPrice)/prevPrice

Açıklama

array trader_rocp ( array $real [, integer $timePeriod ] )

Değiştirgeler

real

Array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_roc
trader_rocr100
Trader İşlevleri


Rate of change ratio 100 scale: (price/prevPrice)*100

trader_rocp
trader_rocr
Trader İşlevleri
PHP Manual

trader_rocr100

(PECL trader >= 0.2.0)

trader_rocr100 — Rate of change ratio 100 scale: (price/prevPrice)*100

Açıklama

array trader_rocr100 ( array $real [, integer $timePeriod ] )

Değiştirgeler

real

Array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_rocp
trader_rocr
Trader İşlevleri


Rate of change ratio: (price/prevPrice)

trader_rocr100
trader_rsi
Trader İşlevleri
PHP Manual

trader_rocr

(PECL trader >= 0.2.0)

trader_rocr — Rate of change ratio: (price/prevPrice)

Açıklama

array trader_rocr ( array $real [, integer $timePeriod ] )

Değiştirgeler

real

Array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_rocr100
trader_rsi
Trader İşlevleri


Relative Strength Index

trader_rocr
trader_sar
Trader İşlevleri
PHP Manual

trader_rsi

(PECL trader >= 0.2.0)

trader_rsi — Relative Strength Index

Açıklama

array trader_rsi ( array $real [, integer $timePeriod ] )

Değiştirgeler

real

Array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_rocr
trader_sar
Trader İşlevleri


Parabolic SAR

trader_rsi
trader_sarext
Trader İşlevleri
PHP Manual

trader_sar

(PECL trader >= 0.2.0)

trader_sar — Parabolic SAR

Açıklama

array trader_sar ( array $high , array $low [, float $acceleration [, float $maximum ]] )

Değiştirgeler

high

High price, array of real values.

low

Low price, array of real values.

acceleration

Acceleration Factor used up to the Maximum value. Valid range from 0 to TRADER_REAL_MAX.

maximum

Acceleration Factor Maximum value. Valid range from 0 to TRADER_REAL_MAX.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_rsi
trader_sarext
Trader İşlevleri


Parabolic SAR - Extended

trader_sar
trader_set_compat
Trader İşlevleri
PHP Manual

trader_sarext

(PECL trader >= 0.2.0)

trader_sarext — Parabolic SAR - Extended

Açıklama

array trader_sarext ( array $high , array $low [, float $startValue [, float $offsetOnReverse [, float $accelerationInitLong [, float $accelerationLong [, float $accelerationMaxLong [, float $accelerationInitShort [, float $accelerationShort [, float $accelerationMaxShort ]]]]]]]] )

Değiştirgeler

high

High price, array of real values.

low

Low price, array of real values.

startValue

Start value and direction. 0 for Auto, >0 for Long, <0 for Short. Valid range from TRADER_REAL_MIN to TRADER_REAL_MAX.

offsetOnReverse

Percent offset added/removed to initial stop on short/long reversal. Valid range from 0 to TRADER_REAL_MAX.

accelerationInitLong

Acceleration Factor initial value for the Long direction. Valid range from 0 to TRADER_REAL_MAX.

accelerationLong

Acceleration Factor for the Long direction. Valid range from 0 to TRADER_REAL_MAX.

accelerationMaxLong

Acceleration Factor maximum value for the Long direction. Valid range from 0 to TRADER_REAL_MAX.

accelerationInitShort

Acceleration Factor initial value for the Short direction. Valid range from 0 to TRADER_REAL_MAX.

accelerationShort

Acceleration Factor for the Short direction. Valid range from 0 to TRADER_REAL_MAX.

accelerationMaxShort

Acceleration Factor maximum value for the Short direction. Valid range from 0 to TRADER_REAL_MAX.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_sar
trader_set_compat
Trader İşlevleri


Set compatibility mode

trader_sarext
trader_set_unstable_period
Trader İşlevleri
PHP Manual

trader_set_compat

(PECL trader >= 0.2.2)

trader_set_compat — Set compatibility mode

Açıklama

void trader_set_compat ( integer $compatId )

Set compatibility mode which will affect the way calculations are done by all the extension functions.

Değiştirgeler

compatId

Compatibility Id. TRADER_COMPATIBILITY_* series of constants should be used.

Dönen Değerler

Hiçbir değer dönmez.

trader_sarext
trader_set_unstable_period
Trader İşlevleri


Set unstable period

trader_set_compat
trader_sin
Trader İşlevleri
PHP Manual

trader_set_unstable_period

(PECL trader >= 0.2.2)

trader_set_unstable_period — Set unstable period

Açıklama

void trader_set_unstable_period ( integer $functionId , integer $timePeriod )

Influences unstable period factor for functions, which are sensible to it. More information about unstable periods can be found on the » TA-Lib API documentation page.

Değiştirgeler

functionId

Function ID the factor should be set for. TRADER_FUNC_UNST_* constant series can be used to affect the corresponding function.

timePeriod

Unstable period value.

Dönen Değerler

Hiçbir değer dönmez.

trader_set_compat
trader_sin
Trader İşlevleri


Vector Trigonometric Sin

trader_set_unstable_period
trader_sinh
Trader İşlevleri
PHP Manual

trader_sin

(PECL trader >= 0.2.0)

trader_sin — Vector Trigonometric Sin

Açıklama

array trader_sin ( array $real )

Calculates the sine for each value in real and returns the resulting array.

Değiştirgeler

real

Array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_set_unstable_period
trader_sinh
Trader İşlevleri


Vector Trigonometric Sinh

trader_sin
trader_sma
Trader İşlevleri
PHP Manual

trader_sinh

(PECL trader >= 0.2.0)

trader_sinh — Vector Trigonometric Sinh

Açıklama

array trader_sinh ( array $real )

Calculates the hyperbolic sine for each value in real and returns the resulting array.

Değiştirgeler

real

Array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_sin
trader_sma
Trader İşlevleri


Simple Moving Average

trader_sinh
trader_sqrt
Trader İşlevleri
PHP Manual

trader_sma

(PECL trader >= 0.2.0)

trader_sma — Simple Moving Average

Açıklama

array trader_sma ( array $real [, integer $timePeriod ] )

Değiştirgeler

real

Array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_sinh
trader_sqrt
Trader İşlevleri


Vector Square Root

trader_sma
trader_stddev
Trader İşlevleri
PHP Manual

trader_sqrt

(PECL trader >= 0.2.0)

trader_sqrt — Vector Square Root

Açıklama

array trader_sqrt ( array $real )

Calculates the square root of each value in real and returns the resulting array.

Değiştirgeler

real

Array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_sma
trader_stddev
Trader İşlevleri


Standard Deviation

trader_sqrt
trader_stoch
Trader İşlevleri
PHP Manual

trader_stddev

(PECL trader >= 0.2.0)

trader_stddev — Standard Deviation

Açıklama

array trader_stddev ( array $real [, integer $timePeriod [, float $nbDev ]] )

Değiştirgeler

real

Array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

nbDev

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_sqrt
trader_stoch
Trader İşlevleri


Stochastic

trader_stddev
trader_stochf
Trader İşlevleri
PHP Manual

trader_stoch

(PECL trader >= 0.2.0)

trader_stoch — Stochastic

Açıklama

array trader_stoch ( array $high , array $low , array $close [, integer $fastK_Period [, integer $slowK_Period [, integer $slowK_MAType [, integer $slowD_Period [, integer $slowD_MAType ]]]]] )

Değiştirgeler

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

fastK_Period

Time period for building the Fast-K line. Valid range from 1 to 100000.

slowK_Period

Smoothing for making the Slow-K line. Valid range from 1 to 100000, usually set to 3.

slowK_MAType

Type of Moving Average for Slow-K. TRADER_MA_TYPE_* series of constants should be used.

slowD_Period

Smoothing for making the Slow-D line. Valid range from 1 to 100000.

slowD_MAType

Type of Moving Average for Slow-D. TRADER_MA_TYPE_* series of constants should be used.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_stddev
trader_stochf
Trader İşlevleri


Stochastic Fast

trader_stoch
trader_stochrsi
Trader İşlevleri
PHP Manual

trader_stochf

(PECL trader >= 0.2.0)

trader_stochf — Stochastic Fast

Açıklama

array trader_stochf ( array $high , array $low , array $close [, integer $fastK_Period [, integer $fastD_Period [, integer $fastD_MAType ]]] )

Değiştirgeler

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

fastK_Period

Time period for building the Fast-K line. Valid range from 1 to 100000.

fastD_Period

Smoothing for making the Fast-D line. Valid range from 1 to 100000, usually set to 3.

fastD_MAType

Type of Moving Average for Fast-D. TRADER_MA_TYPE_* series of constants should be used.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_stoch
trader_stochrsi
Trader İşlevleri


Stochastic Relative Strength Index

trader_stochf
trader_sub
Trader İşlevleri
PHP Manual

trader_stochrsi

(PECL trader >= 0.2.0)

trader_stochrsi — Stochastic Relative Strength Index

Açıklama

array trader_stochrsi ( array $real [, integer $timePeriod [, integer $fastK_Period [, integer $fastD_Period [, integer $fastD_MAType ]]]] )

Değiştirgeler

real

Array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

fastK_Period

Time period for building the Fast-K line. Valid range from 1 to 100000.

fastD_Period

Smoothing for making the Fast-D line. Valid range from 1 to 100000, usually set to 3.

fastD_MAType

Type of Moving Average for Fast-D. TRADER_MA_TYPE_* series of constants should be used.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_stochf
trader_sub
Trader İşlevleri


Vector Arithmetic Subtraction

trader_stochrsi
trader_sum
Trader İşlevleri
PHP Manual

trader_sub

(PECL trader >= 0.2.0)

trader_sub — Vector Arithmetic Subtraction

Açıklama

array trader_sub ( array $real0 , array $real1 )

Calculates the vector subtraction of real1 from real0 and returns the resulting vector.

Değiştirgeler

real0

Array of real values.

real1

Array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_stochrsi
trader_sum
Trader İşlevleri


Summation

trader_sub
trader_t3
Trader İşlevleri
PHP Manual

trader_sum

(PECL trader >= 0.2.0)

trader_sum — Summation

Açıklama

array trader_sum ( array $real [, integer $timePeriod ] )

Değiştirgeler

real

Array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_sub
trader_t3
Trader İşlevleri


Triple Exponential Moving Average (T3)

trader_sum
trader_tan
Trader İşlevleri
PHP Manual

trader_t3

(PECL trader >= 0.2.0)

trader_t3 — Triple Exponential Moving Average (T3)

Açıklama

array trader_t3 ( array $real [, integer $timePeriod [, float $vFactor ]] )

Değiştirgeler

real

Array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

vFactor

Volume Factor. Valid range from 1 to 0.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_sum
trader_tan
Trader İşlevleri


Vector Trigonometric Tan

trader_t3
trader_tanh
Trader İşlevleri
PHP Manual

trader_tan

(PECL trader >= 0.2.0)

trader_tan — Vector Trigonometric Tan

Açıklama

array trader_tan ( array $real )

Calculates the tangent for each value in real and returns the resulting array.

Değiştirgeler

real

Array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_t3
trader_tanh
Trader İşlevleri


Vector Trigonometric Tanh

trader_tan
trader_tema
Trader İşlevleri
PHP Manual

trader_tanh

(PECL trader >= 0.2.0)

trader_tanh — Vector Trigonometric Tanh

Açıklama

array trader_tanh ( array $real )

Calculates the hyperbolic tangent for each value in real and returns the resulting array.

Değiştirgeler

real

Array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_tan
trader_tema
Trader İşlevleri


Triple Exponential Moving Average

trader_tanh
trader_trange
Trader İşlevleri
PHP Manual

trader_tema

(PECL trader >= 0.2.0)

trader_tema — Triple Exponential Moving Average

Açıklama

array trader_tema ( array $real [, integer $timePeriod ] )

Değiştirgeler

real

Array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_tanh
trader_trange
Trader İşlevleri


True Range

trader_tema
trader_trima
Trader İşlevleri
PHP Manual

trader_trange

(PECL trader >= 0.2.0)

trader_trange — True Range

Açıklama

array trader_trange ( array $high , array $low , array $close )

Değiştirgeler

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_tema
trader_trima
Trader İşlevleri


Triangular Moving Average

trader_trange
trader_trix
Trader İşlevleri
PHP Manual

trader_trima

(PECL trader >= 0.2.0)

trader_trima — Triangular Moving Average

Açıklama

array trader_trima ( array $real [, integer $timePeriod ] )

Değiştirgeler

real

Array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_trange
trader_trix
Trader İşlevleri


1-day Rate-Of-Change (ROC) of a Triple Smooth EMA

trader_trima
trader_tsf
Trader İşlevleri
PHP Manual

trader_trix

(PECL trader >= 0.2.0)

trader_trix — 1-day Rate-Of-Change (ROC) of a Triple Smooth EMA

Açıklama

array trader_trix ( array $real [, integer $timePeriod ] )

Değiştirgeler

real

Array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_trima
trader_tsf
Trader İşlevleri


Time Series Forecast

trader_trix
trader_typprice
Trader İşlevleri
PHP Manual

trader_tsf

(PECL trader >= 0.2.0)

trader_tsf — Time Series Forecast

Açıklama

array trader_tsf ( array $real [, integer $timePeriod ] )

Değiştirgeler

real

Array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_trix
trader_typprice
Trader İşlevleri


Typical Price

trader_tsf
trader_ultosc
Trader İşlevleri
PHP Manual

trader_typprice

(PECL trader >= 0.2.0)

trader_typprice — Typical Price

Açıklama

array trader_typprice ( array $high , array $low , array $close )

Değiştirgeler

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_tsf
trader_ultosc
Trader İşlevleri


Ultimate Oscillator

trader_typprice
trader_var
Trader İşlevleri
PHP Manual

trader_ultosc

(PECL trader >= 0.2.0)

trader_ultosc — Ultimate Oscillator

Açıklama

array trader_ultosc ( array $high , array $low , array $close [, integer $timePeriod1 [, integer $timePeriod2 [, integer $timePeriod3 ]]] )

Değiştirgeler

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

timePeriod1

Number of bars for 1st period. Valid range from 1 to 100000.

timePeriod2

Number of bars for 2nd period. Valid range from 1 to 100000.

timePeriod3

Number of bars for 3rd period. Valid range from 1 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_typprice
trader_var
Trader İşlevleri


Variance

trader_ultosc
trader_wclprice
Trader İşlevleri
PHP Manual

trader_var

(PECL trader >= 0.2.0)

trader_var — Variance

Açıklama

array trader_var ( array $real [, integer $timePeriod [, float $nbDev ]] )

Değiştirgeler

real

Array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

nbDev

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_ultosc
trader_wclprice
Trader İşlevleri


Weighted Close Price

trader_var
trader_willr
Trader İşlevleri
PHP Manual

trader_wclprice

(PECL trader >= 0.2.0)

trader_wclprice — Weighted Close Price

Açıklama

array trader_wclprice ( array $high , array $low , array $close )

Değiştirgeler

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_var
trader_willr
Trader İşlevleri


Williams' %R

trader_wclprice
trader_wma
Trader İşlevleri
PHP Manual

trader_willr

(PECL trader >= 0.2.0)

trader_willr — Williams' %R

Açıklama

array trader_willr ( array $high , array $low , array $close [, integer $timePeriod ] )

Değiştirgeler

high

High price, array of real values.

low

Low price, array of real values.

close

Closing price, array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_wclprice
trader_wma
Trader İşlevleri


Weighted Moving Average

trader_willr
Salt Metin Olmayan MIME Çıktılama
Trader İşlevleri
PHP Manual

trader_wma

(PECL trader >= 0.2.0)

trader_wma — Weighted Moving Average

Açıklama

array trader_wma ( array $real [, integer $timePeriod ] )

Değiştirgeler

real

Array of real values.

timePeriod

Number of period. Valid range from 2 to 100000.

Dönen Değerler

Returns an array with calculated data or false on failure.

trader_willr
Salt Metin Olmayan MIME Çıktılama
Trader İşlevleri


Salt Metin Olmayan MIME Çıktılama

  • FDF — Forms Data Format
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • FDF İşlevleri
  • GnuPG — GNU Privacy Guard
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • GnuPG İşlevleri
  • haru — Haru PDF
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • Builtin Fonts And Encodings
    • HaruException — The HaruException class
    • HaruDoc — The HaruDoc class
    • HaruPage — The HaruPage class
    • HaruFont — The HaruFont class
    • HaruImage — The HaruImage class
    • HaruEncoder — The HaruEncoder class
    • HaruOutline — The HaruOutline class
    • HaruAnnotation — The HaruAnnotation class
    • HaruDestination — The HaruDestination class
  • Ming — Ming (flash)
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • Ming İşlevleri
    • SWFAction — The SWFAction class
    • SWFBitmap — The SWFBitmap class
    • SWFButton — The SWFButton class
    • SWFDisplayItem — The SWFDisplayItem class
    • SWFFill — The SWFFill class
    • SWFFont — The SWFFont class
    • SWFFontChar — The SWFFontChar class
    • SWFGradient — The SWFGradient class
    • SWFMorph — The SWFMorph class
    • SWFMovie — The SWFMovie class
    • SWFPrebuiltClip — The SWFPrebuiltClip class
    • SWFShape — The SWFShape class
    • SWFSound — The SWFSound class
    • SWFSoundInstance — The SWFSoundInstance class
    • SWFSprite — The SWFSprite class
    • SWFText — The SWFText class
    • SWFTextField — The SWFTextField class
    • SWFVideoStream — The SWFVideoStream class
  • PDF
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • PDF İşlevleri
  • PS — PostScript document creation
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • PS İşlevleri
  • RPM Reader — RPM Header Reading
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • RPM Reader İşlevleri
trader_wma
FDF
İşlev Başvuru Kılavuzu


Forms Data Format

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
  • FDF İşlevleri
    • fdf_add_doc_javascript — Adds javascript code to the FDF document
    • fdf_add_template — Adds a template into the FDF document
    • fdf_close — Close an FDF document
    • fdf_create — Create a new FDF document
    • fdf_enum_values — Call a user defined function for each document value
    • fdf_errno — Return error code for last fdf operation
    • fdf_error — Return error description for FDF error code
    • fdf_get_ap — Get the appearance of a field
    • fdf_get_attachment — Extracts uploaded file embedded in the FDF
    • fdf_get_encoding — Get the value of the /Encoding key
    • fdf_get_file — Get the value of the /F key
    • fdf_get_flags — Gets the flags of a field
    • fdf_get_opt — Gets a value from the opt array of a field
    • fdf_get_status — Get the value of the /STATUS key
    • fdf_get_value — Get the value of a field
    • fdf_get_version — Gets version number for FDF API or file
    • fdf_header — Sets FDF-specific output headers
    • fdf_next_field_name — Get the next field name
    • fdf_open_string — Read a FDF document from a string
    • fdf_open — Open a FDF document
    • fdf_remove_item — Sets target frame for form
    • fdf_save_string — Returns the FDF document as a string
    • fdf_save — Save a FDF document
    • fdf_set_ap — Set the appearance of a field
    • fdf_set_encoding — Sets FDF character encoding
    • fdf_set_file — Set PDF document to display FDF data in
    • fdf_set_flags — Sets a flag of a field
    • fdf_set_javascript_action — Sets an javascript action of a field
    • fdf_set_on_import_javascript — Adds javascript code to be executed when Acrobat opens the FDF
    • fdf_set_opt — Sets an option of a field
    • fdf_set_status — Set the value of the /STATUS key
    • fdf_set_submit_form_action — Sets a submit form action of a field
    • fdf_set_target_frame — Set target frame for form display
    • fdf_set_value — Set the value of a field
    • fdf_set_version — Sets version number for a FDF file
Salt Metin Olmayan MIME Çıktılama
Giriş
Salt Metin Olmayan MIME Çıktılama


Giriş

Forms Data Format (FDF) is a format for handling forms within PDF documents. You should read the documentation at » http://www.adobe.com/devnet/acrobat/fdftoolkit.html for more information on what FDF is and how it is used in general.

The general idea of FDF is similar to HTML forms. The difference is basically the format how data is transmitted to the server when the submit button is pressed (this is actually the Form Data Format) and the format of the form itself (which is the Portable Document Format, PDF). Processing the FDF data is one of the features provided by the fdf functions. But there is more. One may as well take an existing PDF form and populated the input fields with data without modifying the form itself. In such a case one would create a FDF document (fdf_create()) set the values of each input field (fdf_set_value()) and associate it with a PDF form (fdf_set_file()). Finally it has to be sent to the browser with MimeType application/vnd.fdf. The Acrobat reader plugin of your browser recognizes the MimeType, reads the associated PDF form and fills in the data from the FDF document.

If you look at an FDF-document with a text editor you will find a catalogue object with the name FDF. Such an object may contain a number of entries like Fields, F, Status etc.. The most commonly used entries are Fields which points to a list of input fields, and F which contains the filename of the PDF-document this data belongs to. Those entries are referred to in the FDF documentation as /F-Key or /Status-Key. Modifying this entries is done by functions like fdf_set_file() and fdf_set_status(). Fields are modified with fdf_set_value(), fdf_set_opt() etc..

FDF
Yapılandırma/Kurulum
FDF


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
FDF


Gereksinimler

You need the FDF toolkit SDK available from » http://www.adobe.com/devnet/acrobat/fdftoolkit.html. As of PHP 4.3.0 you need at least SDK version 5.0. The FDF toolkit library is available in binary form only, platforms supported by Adobe are Win32, Linux, Solaris and AIX.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu eklentinin geliştirmesi durmuştur. Ancak, kaynak kodunu PECL SVN deposunda bulabilirsiniz. Yeri: » http://svn.php.net/viewvc/pecl/fdf.

This extension is no longer bundled with PHP as of PHP 5.3.0.

Bilginize: If you run into problems configuring PHP with fdftk support, check whether the header file fdftk.h and the library libfdftk.so are at the right place. The configure script supports both the directory structure of the FDF SDK distribution and the usual DIR/include / DIR/lib layout, so you can point it either directly to the unpacked distribution directory or put the header file and the appropriate library for your platform into e.g. /usr/local/include and /usr/local/lib and configure with --with-fdftk=/usr/local .

Bilginize: Note to Win32 Users

Bu eklentinin çalışabilmesi için bazı DLL dosyalarının bulunduğu yerlerin Windows sistem PATH'ında tanımlı olması gerekir. Bunun nasıl yapılacağı SSS altında "PHP dizinimi Windows'ta PATH'a nasıl eklerim" başlığı altında açıklanmıştır. Eklenti, DLL dosyaları PHP dizininden Windows system dizinine taşındığında da çalışırsa da (çünkü system dizini sistem PATH'ında zaten vardır) bu önerilmez. Bu eklentinin çalışabilmesi için bulunduğu dizine PATH üzerinden erişilebilinmesi gereken dosyanın ismi: fdftk.dll

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Özkaynak Türleri

Most fdf functions require a fdf resource as their first parameter. A fdf resource is a handle to an opened fdf file. fdf resources may be obtained using fdf_create(), fdf_open() and fdf_open_string().

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

FDFValue (integer)
FDFStatus (integer)
FDFFile (integer)
FDFID (integer)
FDFFf (integer)
FDFSetFf (integer)
FDFClearFf (integer)
FDFFlags (integer)
FDFSetF (integer)
FDFClrF (integer)
FDFAP (integer)
FDFAS (integer)
FDFAction (integer)
FDFAA (integer)
FDFAPRef (integer)
FDFIF (integer)
FDFEnter (integer)
FDFExit (integer)
FDFDown (integer)
FDFUp (integer)
FDFFormat (integer)
FDFValidate (integer)
FDFKeystroke (integer)
FDFCalculate (integer)
FDFNormalAP (integer)
FDFRolloverAP (integer)
FDFDownAP (integer)
Özkaynak Türleri
Örnekler
FDF


Örnekler

The following examples shows just the evaluation of form data.

Örnek 1 Evaluating a FDF document

<?php
// Open fdf from input string provided by the extension
// The pdf form contained several input text fields with the names
// volume, date, comment, publisher, preparer, and two checkboxes
// show_publisher and show_preparer.
$fdf = fdf_open_string($HTTP_FDF_DATA);
$volume = fdf_get_value($fdf, "volume");
echo "The volume field has the value '<b>$volume</b>'<br />";

$date = fdf_get_value($fdf, "date");
echo "The date field has the value '<b>$date</b>'<br />";

$comment = fdf_get_value($fdf, "comment");
echo "The comment field has the value '<b>$comment</b>'<br />";

if (fdf_get_value($fdf, "show_publisher") == "On") {
  $publisher = fdf_get_value($fdf, "publisher");
  echo "The publisher field has the value '<b>$publisher</b>'<br />";
} else
  echo "Publisher shall not be shown.<br />";

if (fdf_get_value($fdf, "show_preparer") == "On") {
  $preparer = fdf_get_value($fdf, "preparer");
  echo "The preparer field has the value '<b>$preparer</b>'<br />";
} else
  echo "Preparer shall not be shown.<br />";
fdf_close($fdf);
?>

Öntanımlı Sabitler
FDF İşlevleri
FDF


FDF İşlevleri

İçindekiler

  • fdf_add_doc_javascript — Adds javascript code to the FDF document
  • fdf_add_template — Adds a template into the FDF document
  • fdf_close — Close an FDF document
  • fdf_create — Create a new FDF document
  • fdf_enum_values — Call a user defined function for each document value
  • fdf_errno — Return error code for last fdf operation
  • fdf_error — Return error description for FDF error code
  • fdf_get_ap — Get the appearance of a field
  • fdf_get_attachment — Extracts uploaded file embedded in the FDF
  • fdf_get_encoding — Get the value of the /Encoding key
  • fdf_get_file — Get the value of the /F key
  • fdf_get_flags — Gets the flags of a field
  • fdf_get_opt — Gets a value from the opt array of a field
  • fdf_get_status — Get the value of the /STATUS key
  • fdf_get_value — Get the value of a field
  • fdf_get_version — Gets version number for FDF API or file
  • fdf_header — Sets FDF-specific output headers
  • fdf_next_field_name — Get the next field name
  • fdf_open_string — Read a FDF document from a string
  • fdf_open — Open a FDF document
  • fdf_remove_item — Sets target frame for form
  • fdf_save_string — Returns the FDF document as a string
  • fdf_save — Save a FDF document
  • fdf_set_ap — Set the appearance of a field
  • fdf_set_encoding — Sets FDF character encoding
  • fdf_set_file — Set PDF document to display FDF data in
  • fdf_set_flags — Sets a flag of a field
  • fdf_set_javascript_action — Sets an javascript action of a field
  • fdf_set_on_import_javascript — Adds javascript code to be executed when Acrobat opens the FDF
  • fdf_set_opt — Sets an option of a field
  • fdf_set_status — Set the value of the /STATUS key
  • fdf_set_submit_form_action — Sets a submit form action of a field
  • fdf_set_target_frame — Set target frame for form display
  • fdf_set_value — Set the value of a field
  • fdf_set_version — Sets version number for a FDF file
Örnekler
fdf_add_doc_javascript
FDF


Adds javascript code to the FDF document

FDF İşlevleri
fdf_add_template
FDF İşlevleri
PHP Manual

fdf_add_doc_javascript

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

fdf_add_doc_javascript — Adds javascript code to the FDF document

Açıklama

bool fdf_add_doc_javascript ( resource $fdf_document , string $script_name , string $script_code )

Adds a script to the FDF, which Acrobat then adds to the doc-level scripts of a document, once the FDF is imported into it.

Değiştirgeler

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

script_name

The script name.

script_code

The script code. It is strongly suggested to use \r for linebreaks within the script code.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Adding JavaScript code to a FDF

<?php
$fdf = fdf_create();
fdf_add_doc_javascript($fdf, "PlusOne", "function PlusOne(x)\r{\r  return x+1;\r}\r");
fdf_save($fdf);
?>

will create a FDF like this:

%FDF-1.2
%âãÏÓ
1 0 obj
<<
/FDF << /JavaScript << /Doc [ (PlusOne)(function PlusOne\(x\)\r{\r  return x+1;\r}\r)] >> >>
>>
endobj
trailer
<<
/Root 1 0 R

>>
%%EOF

FDF İşlevleri
fdf_add_template
FDF İşlevleri


Adds a template into the FDF document

fdf_add_doc_javascript
fdf_close
FDF İşlevleri
PHP Manual

fdf_add_template

(PHP 4, PHP 5, PHP 7)

fdf_add_template — Adds a template into the FDF document

Açıklama

bool fdf_add_template ( resource $fdf_document , int $newpage , string $filename , string $template , int $rename )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

fdf_add_doc_javascript
fdf_close
FDF İşlevleri


Close an FDF document

fdf_add_template
fdf_create
FDF İşlevleri
PHP Manual

fdf_close

(PHP 4, PHP 5, PHP 7)

fdf_close — Close an FDF document

Açıklama

void fdf_close ( resource $fdf_document )

Closes the FDF document.

Değiştirgeler

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • fdf_open() - Open a FDF document

fdf_add_template
fdf_create
FDF İşlevleri


Create a new FDF document

fdf_close
fdf_enum_values
FDF İşlevleri
PHP Manual

fdf_create

(PHP 4, PHP 5, PHP 7)

fdf_create — Create a new FDF document

Açıklama

resource fdf_create ( void )

Creates a new FDF document.

This function is needed if one would like to populate input fields in a PDF document with data.

Dönen Değerler

Returns a FDF document handle, or FALSE on error.

Örnekler

Örnek 1 Populating a PDF document

<?php
$outfdf = fdf_create();
fdf_set_value($outfdf, "volume", $volume, 0);

fdf_set_file($outfdf, "http:/testfdf/resultlabel.pdf");
fdf_save($outfdf, "outtest.fdf");
fdf_close($outfdf);
Header("Content-type: application/vnd.fdf");
$fp = fopen("outtest.fdf", "r");
fpassthru($fp);
unlink("outtest.fdf");
?>

Ayrıca Bakınız

  • fdf_close() - Close an FDF document
  • fdf_save() - Save a FDF document
  • fdf_open() - Open a FDF document

fdf_close
fdf_enum_values
FDF İşlevleri


Call a user defined function for each document value

fdf_create
fdf_errno
FDF İşlevleri
PHP Manual

fdf_enum_values

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

fdf_enum_values — Call a user defined function for each document value

Açıklama

bool fdf_enum_values ( resource $fdf_document , callable $function [, mixed $userdata ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

fdf_create
fdf_errno
FDF İşlevleri


Return error code for last fdf operation

fdf_enum_values
fdf_error
FDF İşlevleri
PHP Manual

fdf_errno

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

fdf_errno — Return error code for last fdf operation

Açıklama

int fdf_errno ( void )

Gets the error code set by the last FDF function call.

A textual description of the error may be obtained using with fdf_error().

Dönen Değerler

Returns the error code as an integer, or zero if there was no errors.

Ayrıca Bakınız

  • fdf_error() - Return error description for FDF error code

fdf_enum_values
fdf_error
FDF İşlevleri


Return error description for FDF error code

fdf_errno
fdf_get_ap
FDF İşlevleri
PHP Manual

fdf_error

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

fdf_error — Return error description for FDF error code

Açıklama

string fdf_error ([ int $error_code = -1 ] )

Gets a textual description for the FDF error code given in error_code.

Değiştirgeler

error_code

An error code obtained with fdf_errno(). If not provided, this function uses the internal error code set by the last operation.

Dönen Değerler

Returns the error message as a string, or the string no error if nothing went wrong.

Ayrıca Bakınız

  • fdf_errno() - Return error code for last fdf operation

fdf_errno
fdf_get_ap
FDF İşlevleri


Get the appearance of a field

fdf_error
fdf_get_attachment
FDF İşlevleri
PHP Manual

fdf_get_ap

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

fdf_get_ap — Get the appearance of a field

Açıklama

bool fdf_get_ap ( resource $fdf_document , string $field , int $face , string $filename )

Gets the appearance of a field (i.e. the value of the /AP key) and stores it in a file.

Değiştirgeler

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

field

face

The possible values are FDFNormalAP, FDFRolloverAP and FDFDownAP.

filename

The appearance will be stored in this parameter.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

fdf_error
fdf_get_attachment
FDF İşlevleri


Extracts uploaded file embedded in the FDF

fdf_get_ap
fdf_get_encoding
FDF İşlevleri
PHP Manual

fdf_get_attachment

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

fdf_get_attachment — Extracts uploaded file embedded in the FDF

Açıklama

array fdf_get_attachment ( resource $fdf_document , string $fieldname , string $savepath )

Extracts a file uploaded by means of the "file selection" field fieldname and stores it under savepath.

Değiştirgeler

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

fieldname

savepath

May be the name of a plain file or an existing directory in which the file is to be created under its original name. Any existing file under the same name will be overwritten.

Bilginize:

There seems to be no other way to find out the original filename but to store the file using a directory as savepath and check for the basename it was stored under.

Dönen Değerler

The returned array contains the following fields:

  • path - path were the file got stored
  • size - size of the stored file in bytes
  • type - mimetype if given in the FDF

Örnekler

Örnek 1 Storing an uploaded file

<?php
  $fdf = fdf_open_string($HTTP_FDF_DATA);
  $data = fdf_get_attachment($fdf, "filename", "/tmpdir");
  echo "The uploaded file is stored in $data[path]";
?>

fdf_get_ap
fdf_get_encoding
FDF İşlevleri


Get the value of the /Encoding key

fdf_get_attachment
fdf_get_file
FDF İşlevleri
PHP Manual

fdf_get_encoding

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

fdf_get_encoding — Get the value of the /Encoding key

Açıklama

string fdf_get_encoding ( resource $fdf_document )

Gets the value of the /Encoding key.

Değiştirgeler

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

Dönen Değerler

Returns the encoding as a string. An empty string is returned if the default PDFDocEncoding/Unicode scheme is used.

Ayrıca Bakınız

  • fdf_set_encoding() - Sets FDF character encoding

fdf_get_attachment
fdf_get_file
FDF İşlevleri


Get the value of the /F key

fdf_get_encoding
fdf_get_flags
FDF İşlevleri
PHP Manual

fdf_get_file

(PHP 4, PHP 5, PHP 7)

fdf_get_file — Get the value of the /F key

Açıklama

string fdf_get_file ( resource $fdf_document )

Gets the value of the /F key.

Değiştirgeler

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

Dönen Değerler

Returns the key value, as a string.

Ayrıca Bakınız

  • fdf_set_file() - Set PDF document to display FDF data in

fdf_get_encoding
fdf_get_flags
FDF İşlevleri


Gets the flags of a field

fdf_get_file
fdf_get_opt
FDF İşlevleri
PHP Manual

fdf_get_flags

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

fdf_get_flags — Gets the flags of a field

Açıklama

int fdf_get_flags ( resource $fdf_document , string $fieldname , int $whichflags )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

fdf_get_file
fdf_get_opt
FDF İşlevleri


Gets a value from the opt array of a field

fdf_get_flags
fdf_get_status
FDF İşlevleri
PHP Manual

fdf_get_opt

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

fdf_get_opt — Gets a value from the opt array of a field

Açıklama

mixed fdf_get_opt ( resource $fdf_document , string $fieldname [, int $element = -1 ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

fdf_get_flags
fdf_get_status
FDF İşlevleri


Get the value of the /STATUS key

fdf_get_opt
fdf_get_value
FDF İşlevleri
PHP Manual

fdf_get_status

(PHP 4, PHP 5, PHP 7)

fdf_get_status — Get the value of the /STATUS key

Açıklama

string fdf_get_status ( resource $fdf_document )

Gets the value of the /STATUS key.

Değiştirgeler

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

Dönen Değerler

Returns the key value, as a string.

Ayrıca Bakınız

  • fdf_set_status() - Set the value of the /STATUS key

fdf_get_opt
fdf_get_value
FDF İşlevleri


Get the value of a field

fdf_get_status
fdf_get_version
FDF İşlevleri
PHP Manual

fdf_get_value

(PHP 4, PHP 5, PHP 7)

fdf_get_value — Get the value of a field

Açıklama

mixed fdf_get_value ( resource $fdf_document , string $fieldname [, int $which = -1 ] )

Gets the value for the requested field.

Değiştirgeler

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

fieldname

Name of the FDF field, as a string.

which

Elements of an array field can be retrieved by passing this optional parameter, starting at zero. For non-array fields, this parameter will be ignored.

Dönen Değerler

Returns the field value.

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.0 | Support for arrays and the which parameter were added.

Ayrıca Bakınız

  • fdf_set_value() - Set the value of a field

fdf_get_status
fdf_get_version
FDF İşlevleri


Gets version number for FDF API or file

fdf_get_value
fdf_header
FDF İşlevleri
PHP Manual

fdf_get_version

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

fdf_get_version — Gets version number for FDF API or file

Açıklama

string fdf_get_version ([ resource $fdf_document ] )

Return the FDF version for the given document, or the toolkit API version number if no parameter is given.

Değiştirgeler

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

Dönen Değerler

Returns the version as a string. For the current FDF toolkit 5.0 the API version number is 5.0 and the document version number is either 1.2, 1.3 or 1.4.

Ayrıca Bakınız

  • fdf_set_version() - Sets version number for a FDF file

fdf_get_value
fdf_header
FDF İşlevleri


Sets FDF-specific output headers

fdf_get_version
fdf_next_field_name
FDF İşlevleri
PHP Manual

fdf_header

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

fdf_header — Sets FDF-specific output headers

Açıklama

void fdf_header ( void )

This is a convenience function to set appropriate HTTP headers for FDF output. It sets the Content-type: to application/vnd.fdf.

Dönen Değerler

Hiçbir değer dönmez.

fdf_get_version
fdf_next_field_name
FDF İşlevleri


Get the next field name

fdf_header
fdf_open_string
FDF İşlevleri
PHP Manual

fdf_next_field_name

(PHP 4, PHP 5, PHP 7)

fdf_next_field_name — Get the next field name

Açıklama

string fdf_next_field_name ( resource $fdf_document [, string $fieldname ] )

Gets the name of the field after the given field. This name can be used with several functions.

Değiştirgeler

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

fieldname

Name of the FDF field, as a string. If not given, the first field will be assumed.

Dönen Değerler

Returns the field name as a string.

Örnekler

Örnek 1 Detecting all fieldnames in a FDF

<?php
$fdf = fdf_open($HTTP_FDF_DATA);
for ($field = fdf_next_field_name($fdf);
    $field != "";
    $field = fdf_next_field_name($fdf, $field)) {
    echo "field: $field\n";
}
?>

Ayrıca Bakınız

  • fdf_get_value() - Get the value of a field

fdf_header
fdf_open_string
FDF İşlevleri


Read a FDF document from a string

fdf_next_field_name
fdf_open
FDF İşlevleri
PHP Manual

fdf_open_string

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

fdf_open_string — Read a FDF document from a string

Açıklama

resource fdf_open_string ( string $fdf_data )

Reads form data from a string.

You can use fdf_open_string() together with $HTTP_FDF_DATA to process FDF form input from a remote client.

Değiştirgeler

fdf_data

The data as returned from a PDF form or created using fdf_create() and fdf_save_string().

Dönen Değerler

Returns a FDF document handle, or FALSE on error.

Örnekler

Örnek 1 Accessing the form data

<?php
$fdf = fdf_open_string($HTTP_FDF_DATA);
/* ... */
fdf_close($fdf);
?>

Ayrıca Bakınız

  • fdf_open() - Open a FDF document
  • fdf_close() - Close an FDF document
  • fdf_create() - Create a new FDF document
  • fdf_save_string() - Returns the FDF document as a string

fdf_next_field_name
fdf_open
FDF İşlevleri


Open a FDF document

fdf_open_string
fdf_remove_item
FDF İşlevleri
PHP Manual

fdf_open

(PHP 4, PHP 5, PHP 7)

fdf_open — Open a FDF document

Açıklama

resource fdf_open ( string $filename )

Opens a file with form data.

You can also use fdf_open_string() to process the results of a PDF form POST request.

Değiştirgeler

filename

Path to the FDF file. This file must contain the data as returned from a PDF form or created using fdf_create() and fdf_save().

Dönen Değerler

Returns a FDF document handle, or FALSE on error.

Örnekler

Örnek 1 Accessing the form data

<?php
// Save the FDF data into a temp file
$fdffp = fopen("test.fdf", "w");
fwrite($fdffp, $HTTP_FDF_DATA, strlen($HTTP_FDF_DATA));
fclose($fdffp);

// Open temp file and evaluate data
$fdf = fdf_open("test.fdf");
/* ... */
fdf_close($fdf);
?>

Ayrıca Bakınız

  • fdf_open_string() - Read a FDF document from a string
  • fdf_close() - Close an FDF document
  • fdf_create() - Create a new FDF document
  • fdf_save() - Save a FDF document

fdf_open_string
fdf_remove_item
FDF İşlevleri


Sets target frame for form

fdf_open
fdf_save_string
FDF İşlevleri
PHP Manual

fdf_remove_item

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

fdf_remove_item — Sets target frame for form

Açıklama

bool fdf_remove_item ( resource $fdf_document , string $fieldname , int $item )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

fdf_open
fdf_save_string
FDF İşlevleri


Returns the FDF document as a string

fdf_remove_item
fdf_save
FDF İşlevleri
PHP Manual

fdf_save_string

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

fdf_save_string — Returns the FDF document as a string

Açıklama

string fdf_save_string ( resource $fdf_document )

Returns the FDF document as a string.

Değiştirgeler

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

Dönen Değerler

Returns the document as a string, or FALSE on error.

Örnekler

Örnek 1 Retrieving FDF as a string

<?php
$fdf = fdf_create();
fdf_set_value($fdf, "foo", "bar");
$str = fdf_save_string($fdf);
fdf_close($fdf);
echo $str;
?>

Yukarıdaki örneğin çıktısı:

%FDF-1.2
%âãÏÓ
1 0 obj
<<
/FDF << /Fields 2 0 R >>
>>
endobj
2 0 obj
[
<< /T (foo)/V (bar)>>
]
endobj
trailer
<<
/Root 1 0 R

>>
%%EOF

Ayrıca Bakınız

  • fdf_open_string() - Read a FDF document from a string
  • fdf_close() - Close an FDF document
  • fdf_create() - Create a new FDF document
  • fdf_save() - Save a FDF document

fdf_remove_item
fdf_save
FDF İşlevleri


Save a FDF document

fdf_save_string
fdf_set_ap
FDF İşlevleri
PHP Manual

fdf_save

(PHP 4, PHP 5, PHP 7)

fdf_save — Save a FDF document

Açıklama

bool fdf_save ( resource $fdf_document [, string $filename ] )

Saves a FDF document.

Değiştirgeler

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

filename

If provided, the resulting FDF will be written in this parameter. Otherwise, this function will write the FDF to the default PHP output stream.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • fdf_close() - Close an FDF document
  • fdf_create() - Create a new FDF document
  • fdf_save_string() - Returns the FDF document as a string

fdf_save_string
fdf_set_ap
FDF İşlevleri


Set the appearance of a field

fdf_save
fdf_set_encoding
FDF İşlevleri
PHP Manual

fdf_set_ap

(PHP 4, PHP 5, PHP 7)

fdf_set_ap — Set the appearance of a field

Açıklama

bool fdf_set_ap ( resource $fdf_document , string $field_name , int $face , string $filename , int $page_number )

Sets the appearance of a field (i.e. the value of the /AP key).

Değiştirgeler

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

field_name

face

The possible values FDFNormalAP, FDFRolloverAP and FDFDownAP.

filename

page_number

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

fdf_save
fdf_set_encoding
FDF İşlevleri


Sets FDF character encoding

fdf_set_ap
fdf_set_file
FDF İşlevleri
PHP Manual

fdf_set_encoding

(PHP 4 >= 4.0.7, PHP 5, PHP 7)

fdf_set_encoding — Sets FDF character encoding

Açıklama

bool fdf_set_encoding ( resource $fdf_document , string $encoding )

Sets the character encoding for the FDF document.

Değiştirgeler

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

encoding

The encoding name. The following values are supported: "Shift-JIS", "UHC", "GBK" and "BigFive".

An empty string resets the encoding to the default PDFDocEncoding/Unicode scheme.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

fdf_set_ap
fdf_set_file
FDF İşlevleri


Set PDF document to display FDF data in

fdf_set_encoding
fdf_set_flags
FDF İşlevleri
PHP Manual

fdf_set_file

(PHP 4, PHP 5, PHP 7)

fdf_set_file — Set PDF document to display FDF data in

Açıklama

bool fdf_set_file ( resource $fdf_document , string $url [, string $target_frame ] )

Selects a different PDF document to display the form results in then the form it originated from.

Değiştirgeler

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

url

Should be given as an absolute URL.

target_frame

Use this parameter to specify the frame in which the document will be displayed. You can also set the default value for this parameter using fdf_set_target_frame().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Passing FDF data to a second form

<?php
  /* set content type for Adobe FDF */
  fdf_header();

  /* start new fdf */
  $fdf = fdf_create();

  /* set field "foo" to value "bar" */
  fdf_set_value($fdf, "foo", "bar");

  /* tell client to display FDF data using "fdf_form.pdf" */
  fdf_set_file($fdf, "http://www.example.com/fdf_form.pdf");

  /* output fdf */
  fdf_save($fdf);

  /* clean up */
  fdf_close($fdf);
?>

Ayrıca Bakınız

  • fdf_get_file() - Get the value of the /F key
  • fdf_set_target_frame() - Set target frame for form display

fdf_set_encoding
fdf_set_flags
FDF İşlevleri


Sets a flag of a field

fdf_set_file
fdf_set_javascript_action
FDF İşlevleri
PHP Manual

fdf_set_flags

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

fdf_set_flags — Sets a flag of a field

Açıklama

bool fdf_set_flags ( resource $fdf_document , string $fieldname , int $whichFlags , int $newFlags )

Sets certain flags of the given field.

Değiştirgeler

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

fieldname

Name of the FDF field, as a string.

whichFlags

newFlags

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • fdf_set_opt() - Sets an option of a field

fdf_set_file
fdf_set_javascript_action
FDF İşlevleri


Sets an javascript action of a field

fdf_set_flags
fdf_set_on_import_javascript
FDF İşlevleri
PHP Manual

fdf_set_javascript_action

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

fdf_set_javascript_action — Sets an javascript action of a field

Açıklama

bool fdf_set_javascript_action ( resource $fdf_document , string $fieldname , int $trigger , string $script )

Sets a javascript action for the given field.

Değiştirgeler

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

fieldname

Name of the FDF field, as a string.

trigger

script

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • fdf_set_submit_form_action() - Sets a submit form action of a field

fdf_set_flags
fdf_set_on_import_javascript
FDF İşlevleri


Adds javascript code to be executed when Acrobat opens the FDF

fdf_set_javascript_action
fdf_set_opt
FDF İşlevleri
PHP Manual

fdf_set_on_import_javascript

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

fdf_set_on_import_javascript — Adds javascript code to be executed when Acrobat opens the FDF

Açıklama

bool fdf_set_on_import_javascript ( resource $fdf_document , string $script , bool $before_data_import )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Ayrıca Bakınız

  • fdf_add_doc_javascript() - Adds javascript code to the FDF document
  • fdf_set_javascript_action() - Sets an javascript action of a field

fdf_set_javascript_action
fdf_set_opt
FDF İşlevleri


Sets an option of a field

fdf_set_on_import_javascript
fdf_set_status
FDF İşlevleri
PHP Manual

fdf_set_opt

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

fdf_set_opt — Sets an option of a field

Açıklama

bool fdf_set_opt ( resource $fdf_document , string $fieldname , int $element , string $str1 , string $str2 )

Sets options of the given field.

Değiştirgeler

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

fieldname

Name of the FDF field, as a string.

element

str1

str2

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • fdf_set_flags() - Sets a flag of a field

fdf_set_on_import_javascript
fdf_set_status
FDF İşlevleri


Set the value of the /STATUS key

fdf_set_opt
fdf_set_submit_form_action
FDF İşlevleri
PHP Manual

fdf_set_status

(PHP 4, PHP 5, PHP 7)

fdf_set_status — Set the value of the /STATUS key

Açıklama

bool fdf_set_status ( resource $fdf_document , string $status )

Sets the value of the /STATUS key. When a client receives a FDF with a status set it will present the value in an alert box.

Değiştirgeler

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

status

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • fdf_get_status() - Get the value of the /STATUS key

fdf_set_opt
fdf_set_submit_form_action
FDF İşlevleri


Sets a submit form action of a field

fdf_set_status
fdf_set_target_frame
FDF İşlevleri
PHP Manual

fdf_set_submit_form_action

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

fdf_set_submit_form_action — Sets a submit form action of a field

Açıklama

bool fdf_set_submit_form_action ( resource $fdf_document , string $fieldname , int $trigger , string $script , int $flags )

Sets a submit form action for the given field.

Değiştirgeler

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

fieldname

Name of the FDF field, as a string.

trigger

script

flags

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • fdf_set_javascript_action() - Sets an javascript action of a field

fdf_set_status
fdf_set_target_frame
FDF İşlevleri


Set target frame for form display

fdf_set_submit_form_action
fdf_set_value
FDF İşlevleri
PHP Manual

fdf_set_target_frame

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

fdf_set_target_frame — Set target frame for form display

Açıklama

bool fdf_set_target_frame ( resource $fdf_document , string $frame_name )

Sets the target frame to display a result PDF defined with fdf_save_file() in.

Değiştirgeler

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

frame_name

The frame name, as a string.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • fdf_save_file()

fdf_set_submit_form_action
fdf_set_value
FDF İşlevleri


Set the value of a field

fdf_set_target_frame
fdf_set_version
FDF İşlevleri
PHP Manual

fdf_set_value

(PHP 4, PHP 5, PHP 7)

fdf_set_value — Set the value of a field

Açıklama

bool fdf_set_value ( resource $fdf_document , string $fieldname , mixed $value [, int $isName ] )

Sets the value for the given field.

Değiştirgeler

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

fieldname

Name of the FDF field, as a string.

value

This parameter will be stored as a string unless it is an array. In this case all array elements will be stored as a value array.

isName

Bilginize:

In older versions of the FDF toolkit last parameter determined if the field value was to be converted to a PDF Name (= 1) or set to a PDF String (= 0).

The value is no longer used in the current toolkit version 5.0. For compatibility reasons it is still supported as an optional parameter beginning with PHP 4.3, but ignored internally.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.0 | Support for arrays in the value parameter was added.

Ayrıca Bakınız

  • fdf_get_value() - Get the value of a field
  • fdf_remove_item() - Sets target frame for form

fdf_set_target_frame
fdf_set_version
FDF İşlevleri


Sets version number for a FDF file

fdf_set_value
GnuPG
FDF İşlevleri
PHP Manual

fdf_set_version

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

fdf_set_version — Sets version number for a FDF file

Açıklama

bool fdf_set_version ( resource $fdf_document , string $version )

Sets the FDF version for the given document.

Some features supported by this extension are only available in newer FDF versions.

Değiştirgeler

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

version

The version number. For the current FDF toolkit 5.0, this may be either 1.2, 1.3 or 1.4.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • fdf_get_version() - Gets version number for FDF API or file

fdf_set_value
GnuPG
FDF İşlevleri


GNU Privacy Guard

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
    • Clearsign text
  • GnuPG İşlevleri
    • gnupg_adddecryptkey — Add a key for decryption
    • gnupg_addencryptkey — Add a key for encryption
    • gnupg_addsignkey — Add a key for signing
    • gnupg_cleardecryptkeys — Removes all keys which were set for decryption before
    • gnupg_clearencryptkeys — Removes all keys which were set for encryption before
    • gnupg_clearsignkeys — Removes all keys which were set for signing before
    • gnupg_decrypt — Decrypts a given text
    • gnupg_decryptverify — Decrypts and verifies a given text
    • gnupg_encrypt — Encrypts a given text
    • gnupg_encryptsign — Encrypts and signs a given text
    • gnupg_export — Exports a key
    • gnupg_geterror — Returns the errortext, if a function fails
    • gnupg_getprotocol — Returns the currently active protocol for all operations
    • gnupg_import — Imports a key
    • gnupg_init — Initialize a connection
    • gnupg_keyinfo — Returns an array with information about all keys that matches the given pattern
    • gnupg_setarmor — Toggle armored output
    • gnupg_seterrormode — Sets the mode for error_reporting
    • gnupg_setsignmode — Sets the mode for signing
    • gnupg_sign — Signs a given text
    • gnupg_verify — Verifies a signed text
fdf_set_version
Giriş
Salt Metin Olmayan MIME Çıktılama


Giriş

This module allows you to interact with » gnupg.

GnuPG
Yapılandırma/Kurulum
GnuPG


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
GnuPG


Gereksinimler

This extension requires the » gpgme library

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/gnupg.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

GNUPG_SIG_MODE_NORMAL (integer)
GNUPG_SIG_MODE_DETACH (integer)
GNUPG_SIG_MODE_CLEAR (integer)
GNUPG_VALIDITY_UNKNOWN (integer)
GNUPG_VALIDITY_UNDEFINED (integer)
GNUPG_VALIDITY_NEVER (integer)
GNUPG_VALIDITY_MARGINAL (integer)
GNUPG_VALIDITY_FULL (integer)
GNUPG_VALIDITY_ULTIMATE (integer)
GNUPG_PROTOCOL_OpenPGP (integer)
GNUPG_PROTOCOL_CMS (integer)
GNUPG_SIGSUM_VALID (integer)
GNUPG_SIGSUM_GREEN (integer)
GNUPG_SIGSUM_RED (integer)
GNUPG_SIGSUM_KEY_REVOKED (integer)
GNUPG_SIGSUM_KEY_EXPIRED (integer)
GNUPG_SIGSUM_KEY_MISSING (integer)
GNUPG_SIGSUM_SIG_EXPIRED (integer)
GNUPG_SIGSUM_CRL_MISSING (integer)
GNUPG_SIGSUM_CRL_TOO_OLD (integer)
GNUPG_SIGSUM_BAD_POLICY (integer)
GNUPG_SIGSUM_SYS_ERROR (integer)
GNUPG_ERROR_WARNING (integer)
GNUPG_ERROR_EXCEPTION (integer)
GNUPG_ERROR_SILENT (integer)
Özkaynak Türleri
Örnekler
GnuPG


Örnekler

İçindekiler

  • Clearsign text
Öntanımlı Sabitler
Clearsign text
GnuPG


Clearsign text

This example will clearsign a given text.

Örnek 1 gnupg clearsign example (procedural)

<?php
// init gnupg
$res = gnupg_init();
// not really needed. Clearsign is default
gnupg_setsignmode($res,GNUPG_SIG_MODE_CLEAR);
// add key with passphrase 'test' for signing
gnupg_addsignkey($res,"8660281B6051D071D94B5B230549F9DC851566DC","test");
// sign
$signed = gnupg_sign($res,"just a test");
echo $signed;
?>

Örnek 2 gnupg clearsign example (OO)

<?php
// new class
$gnupg = new gnupg();
// not really needed. Clearsign is default
$gnupg->setsignmode(gnupg::SIG_MODE_CLEAR);
// add key with passphrase 'test' for signing
$gnupg->addsignkey("8660281B6051D071D94B5B230549F9DC851566DC","test");
// sign
$signed = $gnupg->sign("just a test");
echo $signed;
?>

Örnek 3 keylistiterator

This extension also comes with an Iterator for your keyring.

<?php
// create a new iterator for listing all public keys that matches 'example'
$iterator = new gnupg_keylistiterator("example");
foreach($iterator as $fingerprint => $userid){
    echo $fingerprint." -> ".$userid."\n";
}
?>
Örnekler
GnuPG İşlevleri
Örnekler


GnuPG İşlevleri

Notlar

This extension makes use of the keyring of the current user. This keyring is normally located in ~./.gnupg/. To specify a custom location, store the path to the keyring in the environment variable GNUPGHOME. See putenv for more information how to do this.

Some functions require the specification of a key. This specification can be anything that refers to a unique key (userid, key-id, fingerprint, ...). This documentation uses the fingerprint in all examples.

Bilginize:

As alternative to the explicitly documented functions using resources, you can also use an object-oriented style using gnupg objects.

İçindekiler

  • gnupg_adddecryptkey — Add a key for decryption
  • gnupg_addencryptkey — Add a key for encryption
  • gnupg_addsignkey — Add a key for signing
  • gnupg_cleardecryptkeys — Removes all keys which were set for decryption before
  • gnupg_clearencryptkeys — Removes all keys which were set for encryption before
  • gnupg_clearsignkeys — Removes all keys which were set for signing before
  • gnupg_decrypt — Decrypts a given text
  • gnupg_decryptverify — Decrypts and verifies a given text
  • gnupg_encrypt — Encrypts a given text
  • gnupg_encryptsign — Encrypts and signs a given text
  • gnupg_export — Exports a key
  • gnupg_geterror — Returns the errortext, if a function fails
  • gnupg_getprotocol — Returns the currently active protocol for all operations
  • gnupg_import — Imports a key
  • gnupg_init — Initialize a connection
  • gnupg_keyinfo — Returns an array with information about all keys that matches the given pattern
  • gnupg_setarmor — Toggle armored output
  • gnupg_seterrormode — Sets the mode for error_reporting
  • gnupg_setsignmode — Sets the mode for signing
  • gnupg_sign — Signs a given text
  • gnupg_verify — Verifies a signed text
Clearsign text
gnupg_adddecryptkey
GnuPG


Add a key for decryption

GnuPG İşlevleri
gnupg_addencryptkey
GnuPG İşlevleri
PHP Manual

gnupg_adddecryptkey

(PECL gnupg >= 0.5)

gnupg_adddecryptkey — Add a key for decryption

Açıklama

bool gnupg_adddecryptkey ( resource $identifier , string $fingerprint , string $passphrase )

Değiştirgeler

identifier

Gnupg tanıtıcısı, bir gnupg_init() çağrısından veya gnupg nesnesinden elde edilir.

fingerprint

Parmakizi anahtarı.

passphrase

The pass phrase.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Procedural gnupg_adddecryptkey() example

<?php
$res = gnupg_init();
gnupg_adddecryptkey($res,"8660281B6051D071D94B5B230549F9DC851566DC","test");
?>

Örnek 2 OO gnupg_adddecryptkey() example

<?php
$gpg = new gnupg();
$gpg -> adddecryptkey("8660281B6051D071D94B5B230549F9DC851566DC","test");
?>

GnuPG İşlevleri
gnupg_addencryptkey
GnuPG İşlevleri


Add a key for encryption

gnupg_adddecryptkey
gnupg_addsignkey
GnuPG İşlevleri
PHP Manual

gnupg_addencryptkey

(PECL gnupg >= 0.5)

gnupg_addencryptkey — Add a key for encryption

Açıklama

bool gnupg_addencryptkey ( resource $identifier , string $fingerprint )

Değiştirgeler

identifier

Gnupg tanıtıcısı, bir gnupg_init() çağrısından veya gnupg nesnesinden elde edilir.

fingerprint

Parmakizi anahtarı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Procedural gnupg_addencryptkey() example

<?php
$res = gnupg_init();
gnupg_addencryptkey($res,"8660281B6051D071D94B5B230549F9DC851566DC");
?>

Örnek 2 OO gnupg_addencryptkey() example

<?php
$gpg = new gnupg();
$gpg -> addencryptkey("8660281B6051D071D94B5B230549F9DC851566DC");
?>

gnupg_adddecryptkey
gnupg_addsignkey
GnuPG İşlevleri


Add a key for signing

gnupg_addencryptkey
gnupg_cleardecryptkeys
GnuPG İşlevleri
PHP Manual

gnupg_addsignkey

(PECL gnupg >= 0.5)

gnupg_addsignkey — Add a key for signing

Açıklama

bool gnupg_addsignkey ( resource $identifier , string $fingerprint [, string $passphrase ] )

Değiştirgeler

identifier

Gnupg tanıtıcısı, bir gnupg_init() çağrısından veya gnupg nesnesinden elde edilir.

fingerprint

Parmakizi anahtarı.

passphrase

The pass phrase.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Procedural gnupg_addsignkey() example

<?php
$res = gnupg_init();
gnupg_addsignkey($res,"8660281B6051D071D94B5B230549F9DC851566DC","test");
?>

Örnek 2 OO gnupg_addsignkey() example

<?php
$gpg = new gnupg();
$gpg -> addsignkey("8660281B6051D071D94B5B230549F9DC851566DC","test");
?>

gnupg_addencryptkey
gnupg_cleardecryptkeys
GnuPG İşlevleri


Removes all keys which were set for decryption before

gnupg_addsignkey
gnupg_clearencryptkeys
GnuPG İşlevleri
PHP Manual

gnupg_cleardecryptkeys

(PECL gnupg >= 0.5)

gnupg_cleardecryptkeys — Removes all keys which were set for decryption before

Açıklama

bool gnupg_cleardecryptkeys ( resource $identifier )

Değiştirgeler

identifier

Gnupg tanıtıcısı, bir gnupg_init() çağrısından veya gnupg nesnesinden elde edilir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Procedural gnupg_cleardecryptkeys() example

<?php
$res = gnupg_init();
gnupg_cleardecryptkeys($res);
?>

Örnek 2 OO gnupg_cleardecryptkeys() example

<?php
$gpg = new gnupg();
$gpg -> cleardecryptkeys();
?>

gnupg_addsignkey
gnupg_clearencryptkeys
GnuPG İşlevleri


Removes all keys which were set for encryption before

gnupg_cleardecryptkeys
gnupg_clearsignkeys
GnuPG İşlevleri
PHP Manual

gnupg_clearencryptkeys

(PECL gnupg >= 0.5)

gnupg_clearencryptkeys — Removes all keys which were set for encryption before

Açıklama

bool gnupg_clearencryptkeys ( resource $identifier )

Değiştirgeler

identifier

Gnupg tanıtıcısı, bir gnupg_init() çağrısından veya gnupg nesnesinden elde edilir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Procedural gnupg_clearencryptkeys() example

<?php
$res = gnupg_init();
gnupg_clearencryptkeys($res);
?>

Örnek 2 OO gnupg_clearencryptkeys() example

<?php
$gpg = new gnupg();
$gpg -> clearencryptkeys();
?>

gnupg_cleardecryptkeys
gnupg_clearsignkeys
GnuPG İşlevleri


Removes all keys which were set for signing before

gnupg_clearencryptkeys
gnupg_decrypt
GnuPG İşlevleri
PHP Manual

gnupg_clearsignkeys

(PECL gnupg >= 0.5)

gnupg_clearsignkeys — Removes all keys which were set for signing before

Açıklama

bool gnupg_clearsignkeys ( resource $identifier )

Değiştirgeler

identifier

Gnupg tanıtıcısı, bir gnupg_init() çağrısından veya gnupg nesnesinden elde edilir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Procedural gnupg_clearsignkeys() example

<?php
$res = gnupg_init();
gnupg_clearsignkeys($res);
?>

Örnek 2 OO gnupg_clearsignkeys() example

<?php
$gpg = new gnupg();
$gpg -> clearsignkeys();
?>

gnupg_clearencryptkeys
gnupg_decrypt
GnuPG İşlevleri


Decrypts a given text

gnupg_clearsignkeys
gnupg_decryptverify
GnuPG İşlevleri
PHP Manual

gnupg_decrypt

(PECL gnupg >= 0.1)

gnupg_decrypt — Decrypts a given text

Açıklama

string gnupg_decrypt ( resource $identifier , string $text )

Decrypts the given text with the keys, which were set with gnupg_adddecryptkey before.

Değiştirgeler

identifier

Gnupg tanıtıcısı, bir gnupg_init() çağrısından veya gnupg nesnesinden elde edilir.

text

The text being decrypted.

Dönen Değerler

On success, this function returns the decrypted text. On failure, this function returns FALSE.

Örnekler

Örnek 1 Procedural gnupg_decrypt() example

<?php
$res = gnupg_init();
gnupg_adddecryptkey($res,"8660281B6051D071D94B5B230549F9DC851566DC","test");
$plain = gnupg_decrypt($res,$encrypted_text);
echo $plain;
?>

Örnek 2 OO gnupg_encrypt() example

<?php
$gpg = new gnupg();
$gpg -> adddecryptkey("8660281B6051D071D94B5B230549F9DC851566DC","test");
$plain = $gpg -> decrypt($encrypted_text);
echo $plain;
?>

gnupg_clearsignkeys
gnupg_decryptverify
GnuPG İşlevleri


Decrypts and verifies a given text

gnupg_decrypt
gnupg_encrypt
GnuPG İşlevleri
PHP Manual

gnupg_decryptverify

(PECL gnupg >= 0.2)

gnupg_decryptverify — Decrypts and verifies a given text

Açıklama

array gnupg_decryptverify ( resource $identifier , string $text , string &$plaintext )

Decrypts and verifies a given text and returns information about the signature.

Değiştirgeler

identifier

Gnupg tanıtıcısı, bir gnupg_init() çağrısından veya gnupg nesnesinden elde edilir.

text

The text being decrypted.

plaintext

The parameter plaintext gets filled with the decrypted text.

Dönen Değerler

On success, this function returns information about the signature and fills the plaintext parameter with the decrypted text. On failure, this function returns FALSE.

Örnekler

Örnek 1 Procedural gnupg_decryptverify() example

<?php
$plaintext = "";
$res = gnupg_init();
gnupg_adddecryptkey($res,"8660281B6051D071D94B5B230549F9DC851566DC","test");
$info = gnupg_decryptverify($res,$text,$plaintext);
print_r($info);
?>

Örnek 2 OO gnupg_decryptverify() example

<?php
$plaintext = "";
$gpg = new gnupg();
$gpg -> adddecryptkey("8660281B6051D071D94B5B230549F9DC851566DC","test");
$info = $gpg -> decryptverify($text,$plaintext);
print_r($info);
?>

gnupg_decrypt
gnupg_encrypt
GnuPG İşlevleri


Encrypts a given text

gnupg_decryptverify
gnupg_encryptsign
GnuPG İşlevleri
PHP Manual

gnupg_encrypt

(PECL gnupg >= 0.1)

gnupg_encrypt — Encrypts a given text

Açıklama

string gnupg_encrypt ( resource $identifier , string $plaintext )

Encrypts the given plaintext with the keys, which were set with gnupg_addencryptkey before and returns the encrypted text.

Değiştirgeler

identifier

Gnupg tanıtıcısı, bir gnupg_init() çağrısından veya gnupg nesnesinden elde edilir.

plaintext

The text being encrypted.

Dönen Değerler

On success, this function returns the encrypted text. On failure, this function returns FALSE.

Örnekler

Örnek 1 Procedural gnupg_encrypt() example

<?php
$res = gnupg_init();
gnupg_addencryptkey($res,"8660281B6051D071D94B5B230549F9DC851566DC");
$enc = gnupg_encrypt($res, "just a test");
echo $enc;
?>

Örnek 2 OO gnupg_encrypt() example

<?php
$gpg = new gnupg();
$gpg -> addencryptkey("8660281B6051D071D94B5B230549F9DC851566DC");
$enc = $gpg -> encrypt("just a test");
echo $enc;
?>

gnupg_decryptverify
gnupg_encryptsign
GnuPG İşlevleri


Encrypts and signs a given text

gnupg_encrypt
gnupg_export
GnuPG İşlevleri
PHP Manual

gnupg_encryptsign

(PECL gnupg >= 0.2)

gnupg_encryptsign — Encrypts and signs a given text

Açıklama

string gnupg_encryptsign ( resource $identifier , string $plaintext )

Encrypts and signs the given plaintext with the keys, which were set with gnupg_addsignkey and gnupg_addencryptkey before and returns the encrypted and signed text.

Değiştirgeler

identifier

Gnupg tanıtıcısı, bir gnupg_init() çağrısından veya gnupg nesnesinden elde edilir.

plaintext

The text being encrypted.

Dönen Değerler

On success, this function returns the encrypted and signed text. On failure, this function returns FALSE.

Örnekler

Örnek 1 Procedural gnupg_encryptsign() example

<?php
$res = gnupg_init();
gnupg_addencryptkey($res,"8660281B6051D071D94B5B230549F9DC851566DC");
gnupg_addsignkey($res,"8660281B6051D071D94B5B230549F9DC851566DC","test");
$enc = gnupg_encryptsign($res, "just a test");
echo $enc;
?>

Örnek 2 OO gnupg_encryptsign() example

<?php
$gpg = new gnupg();
$gpg -> addencryptkey("8660281B6051D071D94B5B230549F9DC851566DC");
$gpg -> addsignkey("8660281B6051D071D94B5B230549F9DC851566DC","test");
$enc = $gpg -> encryptsign("just a test");
echo $enc;
?>

gnupg_encrypt
gnupg_export
GnuPG İşlevleri


Exports a key

gnupg_encryptsign
gnupg_geterror
GnuPG İşlevleri
PHP Manual

gnupg_export

(PECL gnupg >= 0.1)

gnupg_export — Exports a key

Açıklama

string gnupg_export ( resource $identifier , string $fingerprint )

Exports the key fingerprint.

Değiştirgeler

identifier

Gnupg tanıtıcısı, bir gnupg_init() çağrısından veya gnupg nesnesinden elde edilir.

fingerprint

Parmakizi anahtarı.

Dönen Değerler

On success, this function returns the keydata. On failure, this function returns FALSE.

Örnekler

Örnek 1 Procedural gnupg_export() example

<?php
$res = gnupg_init();
$export = gnupg_export($res,"8660281B6051D071D94B5B230549F9DC851566DC");
echo $export;
?>

Örnek 2 OO gnupg_export() example

<?php
$gpg = new gnupg();
$export = $gpg -> export("8660281B6051D071D94B5B230549F9DC851566DC");
?>

gnupg_encryptsign
gnupg_geterror
GnuPG İşlevleri


Returns the errortext, if a function fails

gnupg_export
gnupg_getprotocol
GnuPG İşlevleri
PHP Manual

gnupg_geterror

(PECL gnupg >= 0.1)

gnupg_geterror — Returns the errortext, if a function fails

Açıklama

string gnupg_geterror ( resource $identifier )

Değiştirgeler

identifier

Gnupg tanıtıcısı, bir gnupg_init() çağrısından veya gnupg nesnesinden elde edilir.

Dönen Değerler

Returns an errortext, if an error has occurred, otherwise FALSE.

Örnekler

Örnek 1 Procedural gnupg_geterror() example

<?php
$res = gnupg_init();
echo gnupg_geterror($res);
?>

Örnek 2 OO gnupg_geterror() example

<?php
$gpg = new gnupg();
echo $gpg -> geterror();
?>

gnupg_export
gnupg_getprotocol
GnuPG İşlevleri


Returns the currently active protocol for all operations

gnupg_geterror
gnupg_import
GnuPG İşlevleri
PHP Manual

gnupg_getprotocol

(PECL gnupg >= 0.1)

gnupg_getprotocol — Returns the currently active protocol for all operations

Açıklama

int gnupg_getprotocol ( resource $identifier )

Değiştirgeler

identifier

Gnupg tanıtıcısı, bir gnupg_init() çağrısından veya gnupg nesnesinden elde edilir.

Dönen Değerler

Returns the currently active protocol, which can be one of GNUPG_PROTOCOL_OpenPGP or GNUPG_PROTOCOL_CMS.

Örnekler

Örnek 1 Procedural gnupg_getprotocol() example

<?php
$res = gnupg_init();
echo gnupg_getprotocol($res);
?>

Örnek 2 OO gnupg_getprotocol() example

<?php
$gpg = new gnupg();
echo $gpg -> getprotocol();
?>

gnupg_geterror
gnupg_import
GnuPG İşlevleri


Imports a key

gnupg_getprotocol
gnupg_init
GnuPG İşlevleri
PHP Manual

gnupg_import

(PECL gnupg >= 0.3)

gnupg_import — Imports a key

Açıklama

array gnupg_import ( resource $identifier , string $keydata )

Imports the key keydata and returns an array with information about the importprocess.

Değiştirgeler

identifier

Gnupg tanıtıcısı, bir gnupg_init() çağrısından veya gnupg nesnesinden elde edilir.

keydata

The data key that is being imported.

Dönen Değerler

On success, this function returns and info-array about the importprocess. On failure, this function returns FALSE.

Örnekler

Örnek 1 Procedural gnupg_import() example

<?php
$res = gnupg_init();
$info = gnupg_import($res,$keydata);
print_r($info);
?>

Örnek 2 OO gnupg_import() example

<?php
$gpg = new gnupg();
$info = $gpg -> import($keydata);
print_r($info);
?>

gnupg_getprotocol
gnupg_init
GnuPG İşlevleri


Initialize a connection

gnupg_import
gnupg_keyinfo
GnuPG İşlevleri
PHP Manual

gnupg_init

(PECL gnupg >= 0.4)

gnupg_init — Initialize a connection

Açıklama

resource gnupg_init ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A GnuPG resource connection used by other GnuPG functions.

Örnekler

Örnek 1 Procedural gnupg_init() example

<?php
$res = gnupg_init();
?>

Örnek 2 OO gnupg initializer example

<?php
$gpg = new gnupg();
?>

gnupg_import
gnupg_keyinfo
GnuPG İşlevleri


Returns an array with information about all keys that matches the given pattern

gnupg_init
gnupg_setarmor
GnuPG İşlevleri
PHP Manual

gnupg_keyinfo

(PECL gnupg >= 0.1)

gnupg_keyinfo — Returns an array with information about all keys that matches the given pattern

Açıklama

array gnupg_keyinfo ( resource $identifier , string $pattern )

Değiştirgeler

identifier

Gnupg tanıtıcısı, bir gnupg_init() çağrısından veya gnupg nesnesinden elde edilir.

pattern

The pattern being checked against the keys.

Dönen Değerler

Returns an array with information about all keys that matches the given pattern or FALSE, if an error has occurred.

Örnekler

Örnek 1 Procedural gnupg_keyinfo() example

<?php
$res = gnupg_init();
$info = gnupg_keyinfo($res, 'test');
print_r($info);
?>

Örnek 2 OO gnupg_keyinfo() example

<?php
$gpg = new gnupg();
$info = $gpg -> keyinfo("test");
print_r($info);
?>

gnupg_init
gnupg_setarmor
GnuPG İşlevleri


Toggle armored output

gnupg_keyinfo
gnupg_seterrormode
GnuPG İşlevleri
PHP Manual

gnupg_setarmor

(PECL gnupg >= 0.1)

gnupg_setarmor — Toggle armored output

Açıklama

bool gnupg_setarmor ( resource $identifier , int $armor )

Toggle the armored output.

Değiştirgeler

identifier

Gnupg tanıtıcısı, bir gnupg_init() çağrısından veya gnupg nesnesinden elde edilir.

armor

Pass a non-zero integer-value to this function to enable armored-output (default). Pass 0 to disable armored output.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Procedural gnupg_setarmor() example

<?php
$res = gnupg_init();
gnupg_setarmor($res,1); // enable armored output;
gnupg_setarmor($res,0); // disable armored output;
?>

Örnek 2 OO gnupg_setarmor() example

<?php
$gpg = new gnupg();
$gpg -> setarmor(1); // enable armored output;
$gpg -> setarmor(0); // disable armored output;
?>

gnupg_keyinfo
gnupg_seterrormode
GnuPG İşlevleri


Sets the mode for error_reporting

gnupg_setarmor
gnupg_setsignmode
GnuPG İşlevleri
PHP Manual

gnupg_seterrormode

(PECL gnupg >= 0.6)

gnupg_seterrormode — Sets the mode for error_reporting

Açıklama

void gnupg_seterrormode ( resource $identifier , int $errormode )

Sets the mode for error_reporting.

Değiştirgeler

identifier

Gnupg tanıtıcısı, bir gnupg_init() çağrısından veya gnupg nesnesinden elde edilir.

errormode

The error mode.

errormode takes a constant indicating what type of error_reporting should be used. The possible values are GNUPG_ERROR_WARNING, GNUPG_ERROR_EXCEPTION and GNUPG_ERROR_SILENT. By default GNUPG_ERROR_SILENT is used.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Procedural gnupg_seterrormode() example

<?php
$res = gnupg_init();
gnupg_seterrormode($res,GNUPG_ERROR_WARNING); // raise a PHP-Warning in case of an error
?>

Örnek 2 OO gnupg_seterrormode() example

<?php
$gpg = new gnupg();
$gpg -> seterrormode(gnupg::ERROR_EXCEPTION); // throw an exception in case of an error
?>

gnupg_setarmor
gnupg_setsignmode
GnuPG İşlevleri


Sets the mode for signing

gnupg_seterrormode
gnupg_sign
GnuPG İşlevleri
PHP Manual

gnupg_setsignmode

(PECL gnupg >= 0.1)

gnupg_setsignmode — Sets the mode for signing

Açıklama

bool gnupg_setsignmode ( resource $identifier , int $signmode )

Sets the mode for signing.

Değiştirgeler

identifier

Gnupg tanıtıcısı, bir gnupg_init() çağrısından veya gnupg nesnesinden elde edilir.

sigmode

The mode for signing.

signmode takes a constant indicating what type of signature should be produced. The possible values are GNUPG_SIG_MODE_NORMAL, GNUPG_SIG_MODE_DETACH and GNUPG_SIG_MODE_CLEAR. By default GNUPG_SIG_MODE_CLEAR is used.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Procedural gnupg_setsignmode() example

<?php
$res = gnupg_init();
gnupg_setsignmode($res,GNUPG_SIG_MODE_DETACH); // produce a detached signature
?>

Örnek 2 OO gnupg_setsignmode() example

<?php
$gpg = new gnupg();
$gpg -> setsignmode(gnupg::SIG_MODE_DETACH); // produce a detached signature
?>

gnupg_seterrormode
gnupg_sign
GnuPG İşlevleri


Signs a given text

gnupg_setsignmode
gnupg_verify
GnuPG İşlevleri
PHP Manual

gnupg_sign

(PECL gnupg >= 0.1)

gnupg_sign — Signs a given text

Açıklama

string gnupg_sign ( resource $identifier , string $plaintext )

Signs the given plaintext with the keys, which were set with gnupg_addsignkey before and returns the signed text or the signature, depending on what was set with gnupg_setsignmode.

Değiştirgeler

identifier

Gnupg tanıtıcısı, bir gnupg_init() çağrısından veya gnupg nesnesinden elde edilir.

plaintext

The plain text being signed.

Dönen Değerler

On success, this function returns the signed text or the signature. On failure, this function returns FALSE.

Örnekler

Örnek 1 Procedural gnupg_sign() example

<?php
$res = gnupg_init();
gnupg_addsignkey($res,"8660281B6051D071D94B5B230549F9DC851566DC","test");
$signed = gnupg_sign($res, "just a test");
echo $signed;
?>

Örnek 2 OO gnupg_sign() example

<?php
$gpg = new gnupg();
$gpg->addsignkey("8660281B6051D071D94B5B230549F9DC851566DC","test");
$signed = $gpg->sign("just a test");
echo $signed;
?>

gnupg_setsignmode
gnupg_verify
GnuPG İşlevleri


Verifies a signed text

gnupg_sign
haru
GnuPG İşlevleri
PHP Manual

gnupg_verify

(PECL gnupg >= 0.1)

gnupg_verify — Verifies a signed text

Açıklama

array gnupg_verify ( resource $identifier , string $signed_text , string $signature [, string &$plaintext ] )

Verifies the given signed_text and returns information about the signature.

Değiştirgeler

identifier

Gnupg tanıtıcısı, bir gnupg_init() çağrısından veya gnupg nesnesinden elde edilir.

signed_text

The signed text.

signature

The signature. To verify a clearsigned text, set signature to FALSE.

plaintext

The plain text. If this optional parameter is passed, it is filled with the plain text.

Dönen Değerler

On success, this function returns information about the signature. On failure, this function returns FALSE.

Örnekler

Örnek 1 Procedural gnupg_verify() example

<?php
$plaintext = "";
$res = gnupg_init();
// clearsigned
$info = gnupg_verify($res,$signed_text,false,$plaintext);
print_r($info);
// detached signature
$info = gnupg_verify($res,$signed_text,$signature);
print_r($info);
?>

Örnek 2 OO gnupg_verify() example

<?php
$plaintext = "";
$gpg = new gnupg();
// clearsigned
$info = $gpg -> verify($signed_text,false,$plaintext);
print_r($info);
// detached signature
$info = $gpg -> verify($signed_text,$signature);
print_r($info);
?>

gnupg_sign
haru
GnuPG İşlevleri


Haru PDF

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
    • Basic PECL/haru example
  • Builtin Fonts And Encodings
    • Builtin Fonts
    • Builtin Encodings
  • HaruException — The HaruException class
  • HaruDoc — The HaruDoc class
    • HaruDoc::addPage — Add new page to the document
    • HaruDoc::addPageLabel — Set the numbering style for the specified range of pages
    • HaruDoc::__construct — Construct new HaruDoc instance
    • HaruDoc::createOutline — Create a HaruOutline instance
    • HaruDoc::getCurrentEncoder — Get HaruEncoder currently used in the document
    • HaruDoc::getCurrentPage — Return current page of the document
    • HaruDoc::getEncoder — Get HaruEncoder instance for the specified encoding
    • HaruDoc::getFont — Get HaruFont instance
    • HaruDoc::getInfoAttr — Get current value of the specified document attribute
    • HaruDoc::getPageLayout — Get current page layout
    • HaruDoc::getPageMode — Get current page mode
    • HaruDoc::getStreamSize — Get the size of the temporary stream
    • HaruDoc::insertPage — Insert new page just before the specified page
    • HaruDoc::loadJPEG — Load a JPEG image
    • HaruDoc::loadPNG — Load PNG image and return HaruImage instance
    • HaruDoc::loadRaw — Load a RAW image
    • HaruDoc::loadTTC — Load the font with the specified index from TTC file
    • HaruDoc::loadTTF — Load TTF font file
    • HaruDoc::loadType1 — Load Type1 font
    • HaruDoc::output — Write the document data to the output buffer
    • HaruDoc::readFromStream — Read data from the temporary stream
    • HaruDoc::resetError — Reset error state of the document handle
    • HaruDoc::resetStream — Rewind the temporary stream
    • HaruDoc::save — Save the document into the specified file
    • HaruDoc::saveToStream — Save the document into a temporary stream
    • HaruDoc::setCompressionMode — Set compression mode for the document
    • HaruDoc::setCurrentEncoder — Set the current encoder for the document
    • HaruDoc::setEncryptionMode — Set encryption mode for the document
    • HaruDoc::setInfoAttr — Set the info attribute of the document
    • HaruDoc::setInfoDateAttr — Set the datetime info attributes of the document
    • HaruDoc::setOpenAction — Define which page is shown when the document is opened
    • HaruDoc::setPageLayout — Set how pages should be displayed
    • HaruDoc::setPageMode — Set how the document should be displayed
    • HaruDoc::setPagesConfiguration — Set the number of pages per set of pages
    • HaruDoc::setPassword — Set owner and user passwords for the document
    • HaruDoc::setPermission — Set permissions for the document
    • HaruDoc::useCNSEncodings — Enable Chinese simplified encodings
    • HaruDoc::useCNSFonts — Enable builtin Chinese simplified fonts
    • HaruDoc::useCNTEncodings — Enable Chinese traditional encodings
    • HaruDoc::useCNTFonts — Enable builtin Chinese traditional fonts
    • HaruDoc::useJPEncodings — Enable Japanese encodings
    • HaruDoc::useJPFonts — Enable builtin Japanese fonts
    • HaruDoc::useKREncodings — Enable Korean encodings
    • HaruDoc::useKRFonts — Enable builtin Korean fonts
  • HaruPage — The HaruPage class
    • HaruPage::arc — Append an arc to the current path
    • HaruPage::beginText — Begin a text object and set the current text position to (0,0)
    • HaruPage::circle — Append a circle to the current path
    • HaruPage::closePath — Append a straight line from the current point to the start point of the path
    • HaruPage::concat — Concatenate current transformation matrix of the page and the specified matrix
    • HaruPage::createDestination — Create new HaruDestination instance
    • HaruPage::createLinkAnnotation — Create new HaruAnnotation instance
    • HaruPage::createTextAnnotation — Create new HaruAnnotation instance
    • HaruPage::createURLAnnotation — Create and return new HaruAnnotation instance
    • HaruPage::curveTo2 — Append a Bezier curve to the current path
    • HaruPage::curveTo3 — Append a Bezier curve to the current path
    • HaruPage::curveTo — Append a Bezier curve to the current path
    • HaruPage::drawImage — Show image at the page
    • HaruPage::ellipse — Append an ellipse to the current path
    • HaruPage::endPath — End current path object without filling and painting operations
    • HaruPage::endText — End current text object
    • HaruPage::eofill — Fill current path using even-odd rule
    • HaruPage::eoFillStroke — Fill current path using even-odd rule, then paint the path
    • HaruPage::fill — Fill current path using nonzero winding number rule
    • HaruPage::fillStroke — Fill current path using nonzero winding number rule, then paint the path
    • HaruPage::getCharSpace — Get the current value of character spacing
    • HaruPage::getCMYKFill — Get the current filling color
    • HaruPage::getCMYKStroke — Get the current stroking color
    • HaruPage::getCurrentFont — Get the currently used font
    • HaruPage::getCurrentFontSize — Get the current font size
    • HaruPage::getCurrentPos — Get the current position for path painting
    • HaruPage::getCurrentTextPos — Get the current position for text printing
    • HaruPage::getDash — Get the current dash pattern
    • HaruPage::getFillingColorSpace — Get the current filling color space
    • HaruPage::getFlatness — Get the flatness of the page
    • HaruPage::getGMode — Get the current graphics mode
    • HaruPage::getGrayFill — Get the current filling color
    • HaruPage::getGrayStroke — Get the current stroking color
    • HaruPage::getHeight — Get the height of the page
    • HaruPage::getHorizontalScaling — Get the current value of horizontal scaling
    • HaruPage::getLineCap — Get the current line cap style
    • HaruPage::getLineJoin — Get the current line join style
    • HaruPage::getLineWidth — Get the current line width
    • HaruPage::getMiterLimit — Get the value of miter limit
    • HaruPage::getRGBFill — Get the current filling color
    • HaruPage::getRGBStroke — Get the current stroking color
    • HaruPage::getStrokingColorSpace — Get the current stroking color space
    • HaruPage::getTextLeading — Get the current value of line spacing
    • HaruPage::getTextMatrix — Get the current text transformation matrix of the page
    • HaruPage::getTextRenderingMode — Get the current text rendering mode
    • HaruPage::getTextRise — Get the current value of text rising
    • HaruPage::getTextWidth — Get the width of the text using current fontsize, character spacing and word spacing
    • HaruPage::getTransMatrix — Get the current transformation matrix of the page
    • HaruPage::getWidth — Get the width of the page
    • HaruPage::getWordSpace — Get the current value of word spacing
    • HaruPage::lineTo — Draw a line from the current point to the specified point
    • HaruPage::measureText — Calculate the byte length of characters which can be included on one line of the specified width
    • HaruPage::moveTextPos — Move text position to the specified offset
    • HaruPage::moveTo — Set starting point for new drawing path
    • HaruPage::moveToNextLine — Move text position to the start of the next line
    • HaruPage::rectangle — Append a rectangle to the current path
    • HaruPage::setCharSpace — Set character spacing for the page
    • HaruPage::setCMYKFill — Set filling color for the page
    • HaruPage::setCMYKStroke — Set stroking color for the page
    • HaruPage::setDash — Set the dash pattern for the page
    • HaruPage::setFlatness — Set flatness for the page
    • HaruPage::setFontAndSize — Set font and fontsize for the page
    • HaruPage::setGrayFill — Set filling color for the page
    • HaruPage::setGrayStroke — Sets stroking color for the page
    • HaruPage::setHeight — Set height of the page
    • HaruPage::setHorizontalScaling — Set horizontal scaling for the page
    • HaruPage::setLineCap — Set the shape to be used at the ends of lines
    • HaruPage::setLineJoin — Set line join style for the page
    • HaruPage::setLineWidth — Set line width for the page
    • HaruPage::setMiterLimit — Set the current value of the miter limit of the page
    • HaruPage::setRGBFill — Set filling color for the page
    • HaruPage::setRGBStroke — Set stroking color for the page
    • HaruPage::setRotate — Set rotation angle of the page
    • HaruPage::setSize — Set size and direction of the page
    • HaruPage::setSlideShow — Set transition style for the page
    • HaruPage::setTextLeading — Set text leading (line spacing) for the page
    • HaruPage::setTextMatrix — Set the current text transformation matrix of the page
    • HaruPage::setTextRenderingMode — Set text rendering mode for the page
    • HaruPage::setTextRise — Set the current value of text rising
    • HaruPage::setWidth — Set width of the page
    • HaruPage::setWordSpace — Set word spacing for the page
    • HaruPage::showText — Print text at the current position of the page
    • HaruPage::showTextNextLine — Move the current position to the start of the next line and print the text
    • HaruPage::stroke — Paint current path
    • HaruPage::textOut — Print the text on the specified position
    • HaruPage::textRect — Print the text inside the specified region
  • HaruFont — The HaruFont class
    • HaruFont::getAscent — Get the vertical ascent of the font
    • HaruFont::getCapHeight — Get the distance from the baseline of uppercase letters
    • HaruFont::getDescent — Get the vertical descent of the font
    • HaruFont::getEncodingName — Get the name of the encoding
    • HaruFont::getFontName — Get the name of the font
    • HaruFont::getTextWidth — Get the total width of the text, number of characters, number of words and number of spaces
    • HaruFont::getUnicodeWidth — Get the width of the character in the font
    • HaruFont::getXHeight — Get the distance from the baseline of lowercase letters
    • HaruFont::measureText — Calculate the number of characters which can be included within the specified width
  • HaruImage — The HaruImage class
    • HaruImage::getBitsPerComponent — Get the number of bits used to describe each color component of the image
    • HaruImage::getColorSpace — Get the name of the color space
    • HaruImage::getHeight — Get the height of the image
    • HaruImage::getSize — Get size of the image
    • HaruImage::getWidth — Get the width of the image
    • HaruImage::setColorMask — Set the color mask of the image
    • HaruImage::setMaskImage — Set the image mask
  • HaruEncoder — The HaruEncoder class
    • HaruEncoder::getByteType — Get the type of the byte in the text
    • HaruEncoder::getType — Get the type of the encoder
    • HaruEncoder::getUnicode — Convert the specified character to unicode
    • HaruEncoder::getWritingMode — Get the writing mode of the encoder
  • HaruOutline — The HaruOutline class
    • HaruOutline::setDestination — Set the destination for the outline
    • HaruOutline::setOpened — Set the initial state of the outline
  • HaruAnnotation — The HaruAnnotation class
    • HaruAnnotation::setBorderStyle — Set the border style of the annotation
    • HaruAnnotation::setHighlightMode — Set the highlighting mode of the annotation
    • HaruAnnotation::setIcon — Set the icon style of the annotation
    • HaruAnnotation::setOpened — Set the initial state of the annotation
  • HaruDestination — The HaruDestination class
    • HaruDestination::setFit — Set the appearance of the page to fit the window
    • HaruDestination::setFitB — Set the appearance of the page to fit the bounding box of the page within the window
    • HaruDestination::setFitBH — Set the appearance of the page to fit the width of the bounding box
    • HaruDestination::setFitBV — Set the appearance of the page to fit the height of the boudning box
    • HaruDestination::setFitH — Set the appearance of the page to fit the window width
    • HaruDestination::setFitR — Set the appearance of the page to fit the specified rectangle
    • HaruDestination::setFitV — Set the appearance of the page to fit the window height
    • HaruDestination::setXYZ — Set the appearance of the page
gnupg_verify
Giriş
Salt Metin Olmayan MIME Çıktılama


Giriş

The PECL/haru extension provides bindings to the libHaru library. libHaru is a free, cross platform, and Open Source library for generating PDF files.

The Haru library (libHaru) may be found here: » http://libharu.org.

Uyarı

Bu eklenti DENEYSELDİR. Bu eklentinin davranışı, işlev isimleri ve tüm belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu eklentiyi kullanmayın.

haru
Yapılandırma/Kurulum
haru


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
haru


Gereksinimler

You need to install libharu first to be able to use PECL/haru. PECL/haru is tested with libharu 2.0.8, older versions might or might not work for you. PECL/haru also requires PHP 5.1.3 or newer.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/haru.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
Örnekler
haru


Örnekler

İçindekiler

  • Basic PECL/haru example
Öntanımlı Sabitler
Basic PECL/haru example
haru


Basic PECL/haru example

Örnek 1 Fancy "Hello world"

<?php

$doc = new HaruDoc;

$doc->setPageMode(HaruDoc::PAGE_MODE_USE_THUMBS); /* show thumbnails */

$page = $doc->addPage(); /* add page to the document */
$page->setSize(HaruPage::SIZE_A4, HaruPage::LANDSCAPE); /* set the page to use A4 landscape format */

$courier = $doc->getFont("Courier-Bold"); /* we'll use the bundled font a few lines below */

$page->setRGBStroke(0, 0, 0); /* set colors */
$page->setRGBFill(0.7, 0.8, 0.9);
$page->rectangle(150, 150, 550, 250); /* draw a rectangle */

$page->fillStroke(); /* fill and stroke it */

$page->setDash(array(3, 3), 0); /* set dash style for lines at this page */
$page->setFontAndSize($courier, 60); /* set font and size */

$page->setRGBStroke(0.5, 0.5, 0.1); /* set line color */
$page->setRGBFill(1, 1, 1); /* set filling color */

$page->setTextRenderingMode(HaruPage::FILL_THEN_STROKE); /* fill and stroke text */

/* print the text */
$page->beginText();
$page->textOut(210, 270, "Hello World!");
$page->endText();

$doc->save("/tmp/test.pdf"); /* save the document into a file */

?>

Open the result document in your favourite PDF viewer and you should see a light-blue rectangle and white "Hello World!" on it.

Örnekler
Builtin Fonts And Encodings
Örnekler


Builtin Fonts And Encodings

İçindekiler

  • Builtin Fonts
  • Builtin Encodings
Basic PECL/haru example
Builtin Fonts
haru


Builtin Fonts

These Base14 fonts are built-in into PDF and all viewers can display them. Using these fonts may decrease the size of the result file and make the processing faster, avoiding loading external fonts. However the fonts support only latin1 character set and you have to load external fonts if you need to use an other character set.

The Base14 fonts:

  • Courier

  • Courier-Bold

  • Courier-Oblique

  • Courier-BoldOblique

  • Helvetica

  • Helvetica-Bold

  • Helvetica-Oblique

  • Helvetica-BoldOblique

  • Times-Roman

  • Times-Bold

  • Times-Italic

  • Times-BoldItalic

  • Symbol

  • ZapfDingbats

Builtin Fonts And Encodings
Builtin Encodings
Builtin Fonts And Encodings


Builtin Encodings

Single-byte character set encodings
Name | Description
StandardEncoding | The default encoding of PDF.
MacRomanEncoding | The standard encoding of Mac OS.
WinAnsiEncoding | The standard encoding of Windows.
FontSpecific | The font built-in encoding.
ISO8859-2 | Latin2 (East European)
ISO8859-3 | Latin3 (South European)
ISO8859-4 | Latin4 (North European)
ISO8859-5 | Cyrillic
ISO8859-6 | Arabic
ISO8859-7 | Greek
ISO8859-8 | Hebrew
ISO8859-9 | Latin5 (Turkish)
ISO8859-10 | Latin6 (Nordic)
ISO8859-11 | Thai
ISO8859-13 | Latin7 (Baltic Rim)
ISO8859-14 | Latin8 (Celtic)
ISO8859-15 | Latin9
ISO8859-16 | Latin10
CP1250 | MS Windows Codepage 1250.
CP1251 | MS Windows Codepage 1251.
CP1252 | MS Windows Codepage 1252.
CP1253 | MS Windows Codepage 1253.
CP1254 | MS Windows Codepage 1254.
CP1255 | MS Windows Codepage 1255.
CP1256 | MS Windows Codepage 1256.
CP1257 | MS Windows Codepage 1257.
CP1258 | MS Windows Codepage 1258.
KOI8-R | Cyrillic character set.
Multi-byte character set encodings
Name | Description
GB-EUC-H | EUC-CN encoding.
GB-EUC-V | Vertical writing version of GB-EUC-H.
GBK-EUC-H | Microsoft Code Page 936 (lfCharSet 0x86) GBK encoding.
GBK-EUC-V | Vertical writing version of GBK-EUC-H.
ETen-B5-H | Microsoft Code Page 950 (lfCharSet 0x88) Big Five character set with ETen extensions.
ETen-B5-V | Vertical writing version of ETen-B5-H.
90ms-RKSJ-H | Microsoft Code Page 932, JIS X 0208 character.
90ms-RKSJ-V | Vertical writing version of 90ms-RKSJ-V.
90msp-RKSJ-H | Microsoft Code Page 932, JIS X 0208 character (proportional).
EUC-H | JIS X 0208 character set, EUC-JP encoding.
EUC-V | Vertical writing version of EUC-H.
KSC-EUC-H | KS X 1001:1992 character set, EUC-KR encoding.
KSC-EUC-V | Vertical writing version of KSC-EUC-V.
KSCms-UHC-H | Microsoft Code Page 949 (lfCharSet 0x81), KS X 1001:1992 character set plus 8822 additional hangul, Unified Hangul Code (UHC) encoding (proportional).
KSCms-UHC-HW-H | Microsoft Code Page 949 (lfCharSet 0x81), KS X 1001:1992 character set plus 8822 additional hangul, Unified Hangul Code (UHC) encoding (fixed width).
KSCms-UHC-HW-V | Vertical writing version of KSCms-UHC-HW-H.
Builtin Fonts
HaruException
Builtin Fonts And Encodings


The HaruException class

(PECL haru >= 0.0.1)

Giriş

Haru PDF Exception Class.

Sınıf Sözdizimi

HaruException extends Exception {
/* Inherits */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}
Builtin Encodings
HaruDoc
haru


The HaruDoc class

(PECL haru >= 0.0.1)

Giriş

Haru PDF Document Class.

Sınıf Sözdizimi

HaruDoc {
/* Yöntemler */
object addPage ( void )
bool addPageLabel ( int $first_page , int $style , int $first_num [, string $prefix = "" ] )
__construct ( void )
object createOutline ( string $title [, object $parent_outline [, object $encoder ]] )
object getCurrentEncoder ( void )
object getCurrentPage ( void )
object getEncoder ( string $encoding )
object getFont ( string $fontname [, string $encoding ] )
string getInfoAttr ( int $type )
int getPageLayout ( void )
int getPageMode ( void )
int getStreamSize ( void )
object insertPage ( object $page )
object loadJPEG ( string $filename )
object loadPNG ( string $filename [, bool $deferred = false ] )
object loadRaw ( string $filename , int $width , int $height , int $color_space )
string loadTTC ( string $fontfile , int $index [, bool $embed = false ] )
string loadTTF ( string $fontfile [, bool $embed = false ] )
string loadType1 ( string $afmfile [, string $pfmfile ] )
bool output ( void )
string readFromStream ( int $bytes )
bool resetError ( void )
bool resetStream ( void )
bool save ( string $file )
bool saveToStream ( void )
bool setCompressionMode ( int $mode )
bool setCurrentEncoder ( string $encoding )
bool setEncryptionMode ( int $mode [, int $key_len = 5 ] )
bool setInfoAttr ( int $type , string $info )
bool setInfoDateAttr ( int $type , int $year , int $month , int $day , int $hour , int $min , int $sec , string $ind , int $off_hour , int $off_min )
bool setOpenAction ( object $destination )
bool setPageLayout ( int $layout )
bool setPageMode ( int $mode )
bool setPagesConfiguration ( int $page_per_pages )
bool setPassword ( string $owner_password , string $user_password )
bool setPermission ( int $permission )
bool useCNSEncodings ( void )
bool useCNSFonts ( void )
bool useCNTEncodings ( void )
bool useCNTFonts ( void )
bool useJPEncodings ( void )
bool useJPFonts ( void )
bool useKREncodings ( void )
bool useKRFonts ( void )
}

Öntanımlı Sabitler

Type | Name | Description
int | HaruDoc::CS_DEVICE_GRAY |
int | HaruDoc::CS_DEVICE_RGB |
int | HaruDoc::CS_DEVICE_CMYK |
int | HaruDoc::CS_CAL_GRAY |
int | HaruDoc::CS_CAL_RGB |
int | HaruDoc::CS_LAB |
int | HaruDoc::CS_ICC_BASED |
int | HaruDoc::CS_SEPARATION |
int | HaruDoc::CS_DEVICE_N |
int | HaruDoc::CS_INDEXED |
int | HaruDoc::CS_PATTERN |
int | HaruDoc::ENABLE_READ |
int | HaruDoc::ENABLE_PRINT |
int | HaruDoc::ENABLE_EDIT_ALL |
int | HaruDoc::ENABLE_COPY |
int | HaruDoc::ENABLE_EDIT |
int | HaruDoc::ENCRYPT_R2 |
int | HaruDoc::ENCRYPT_R3 |
int | HaruDoc::INFO_AUTHOR |
int | HaruDoc::INFO_CREATOR |
int | HaruDoc::INFO_TITLE |
int | HaruDoc::INFO_SUBJECT |
int | HaruDoc::INFO_KEYWORDS |
int | HaruDoc::INFO_CREATION_DATE |
int | HaruDoc::INFO_MOD_DATE |
int | HaruDoc::COMP_NONE |
int | HaruDoc::COMP_TEXT |
int | HaruDoc::COMP_IMAGE |
int | HaruDoc::COMP_METADATA |
int | HaruDoc::COMP_ALL |
int | HaruDoc::PAGE_LAYOUT_SINGLE |
int | HaruDoc::PAGE_LAYOUT_ONE_COLUMN |
int | HaruDoc::PAGE_LAYOUT_TWO_COLUMN_LEFT |
int | HaruDoc::PAGE_LAYOUT_TWO_COLUMN_RIGHT |
int | HaruDoc::PAGE_MODE_USE_NONE |
int | HaruDoc::PAGE_MODE_USE_OUTLINE |
int | HaruDoc::PAGE_MODE_USE_THUMBS |
int | HaruDoc::PAGE_MODE_FULL_SCREEN |

İçindekiler

  • HaruDoc::addPage — Add new page to the document
  • HaruDoc::addPageLabel — Set the numbering style for the specified range of pages
  • HaruDoc::__construct — Construct new HaruDoc instance
  • HaruDoc::createOutline — Create a HaruOutline instance
  • HaruDoc::getCurrentEncoder — Get HaruEncoder currently used in the document
  • HaruDoc::getCurrentPage — Return current page of the document
  • HaruDoc::getEncoder — Get HaruEncoder instance for the specified encoding
  • HaruDoc::getFont — Get HaruFont instance
  • HaruDoc::getInfoAttr — Get current value of the specified document attribute
  • HaruDoc::getPageLayout — Get current page layout
  • HaruDoc::getPageMode — Get current page mode
  • HaruDoc::getStreamSize — Get the size of the temporary stream
  • HaruDoc::insertPage — Insert new page just before the specified page
  • HaruDoc::loadJPEG — Load a JPEG image
  • HaruDoc::loadPNG — Load PNG image and return HaruImage instance
  • HaruDoc::loadRaw — Load a RAW image
  • HaruDoc::loadTTC — Load the font with the specified index from TTC file
  • HaruDoc::loadTTF — Load TTF font file
  • HaruDoc::loadType1 — Load Type1 font
  • HaruDoc::output — Write the document data to the output buffer
  • HaruDoc::readFromStream — Read data from the temporary stream
  • HaruDoc::resetError — Reset error state of the document handle
  • HaruDoc::resetStream — Rewind the temporary stream
  • HaruDoc::save — Save the document into the specified file
  • HaruDoc::saveToStream — Save the document into a temporary stream
  • HaruDoc::setCompressionMode — Set compression mode for the document
  • HaruDoc::setCurrentEncoder — Set the current encoder for the document
  • HaruDoc::setEncryptionMode — Set encryption mode for the document
  • HaruDoc::setInfoAttr — Set the info attribute of the document
  • HaruDoc::setInfoDateAttr — Set the datetime info attributes of the document
  • HaruDoc::setOpenAction — Define which page is shown when the document is opened
  • HaruDoc::setPageLayout — Set how pages should be displayed
  • HaruDoc::setPageMode — Set how the document should be displayed
  • HaruDoc::setPagesConfiguration — Set the number of pages per set of pages
  • HaruDoc::setPassword — Set owner and user passwords for the document
  • HaruDoc::setPermission — Set permissions for the document
  • HaruDoc::useCNSEncodings — Enable Chinese simplified encodings
  • HaruDoc::useCNSFonts — Enable builtin Chinese simplified fonts
  • HaruDoc::useCNTEncodings — Enable Chinese traditional encodings
  • HaruDoc::useCNTFonts — Enable builtin Chinese traditional fonts
  • HaruDoc::useJPEncodings — Enable Japanese encodings
  • HaruDoc::useJPFonts — Enable builtin Japanese fonts
  • HaruDoc::useKREncodings — Enable Korean encodings
  • HaruDoc::useKRFonts — Enable builtin Korean fonts
HaruException
HaruDoc::addPage
haru


Add new page to the document

HaruDoc
HaruDoc::addPageLabel
HaruDoc
PHP Manual

HaruDoc::addPage

(PECL haru >= 0.0.1)

HaruDoc::addPage — Add new page to the document

Açıklama

object HaruDoc::addPage ( void )

Adds a new page to the document.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a new HaruPage instance.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruDoc::insertPage() - Insert new page just before the specified page

HaruDoc
HaruDoc::addPageLabel
HaruDoc


Set the numbering style for the specified range of pages

HaruDoc::addPage
HaruDoc::__construct
HaruDoc
PHP Manual

HaruDoc::addPageLabel

(PECL haru >= 0.0.1)

HaruDoc::addPageLabel — Set the numbering style for the specified range of pages

Açıklama

bool HaruDoc::addPageLabel ( int $first_page , int $style , int $first_num [, string $prefix = "" ] )

Set the numbering style for the specified range of pages.

Değiştirgeler

first_page

The first page included into the labeling range.

style

The numbering style. The following values are allowed:

  • HaruPage::NUM_STYLE_DECIMAL - page label is displayed using decimal numerals.
  • HaruPage::NUM_STYLE_UPPER_ROMAN - page label is displayed using uppercase Roman numerals.
  • HaruPage::NUM_STYLE_LOWER_ROMAN - page label is displayed using lowercase Roman numerals.
  • HaruPage::NUM_STYLE_UPPER_LETTER - page label is displayed using uppercase letters (from A to Z).
  • HaruPage::NUM_STYLE_LOWER_LETTERS - page label is displayed using lowercase letters (from a to z).

first_num

The first page number in this range.

prefix

The prefix for the page label.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruDoc::addPage
HaruDoc::__construct
HaruDoc


Construct new HaruDoc instance

HaruDoc::addPageLabel
HaruDoc::createOutline
HaruDoc
PHP Manual

HaruDoc::__construct

(PECL haru >= 0.0.1)

HaruDoc::__construct — Construct new HaruDoc instance

Açıklama

HaruDoc::__construct ( void )

Constructs new HaruDoc instance.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruDoc::addPageLabel
HaruDoc::createOutline
HaruDoc


Create a HaruOutline instance

HaruDoc::__construct
HaruDoc::getCurrentEncoder
HaruDoc
PHP Manual

HaruDoc::createOutline

(PECL haru >= 0.0.1)

HaruDoc::createOutline — Create a HaruOutline instance

Açıklama

object HaruDoc::createOutline ( string $title [, object $parent_outline [, object $encoder ]] )

Create a HaruOutline instance.

Değiştirgeler

title

The caption of new outline object.

parent_outline

A valid HaruOutline instance or NULL.

encoder

A valid HaruEncoder instance or NULL.

Dönen Değerler

Returns a new HaruOutline instance.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruDoc::__construct
HaruDoc::getCurrentEncoder
HaruDoc


Get HaruEncoder currently used in the document

HaruDoc::createOutline
HaruDoc::getCurrentPage
HaruDoc
PHP Manual

HaruDoc::getCurrentEncoder

(PECL haru >= 0.0.1)

HaruDoc::getCurrentEncoder — Get HaruEncoder currently used in the document

Açıklama

object HaruDoc::getCurrentEncoder ( void )

Get the HaruEncoder currently used in the document.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns HaruEncoder currently used in the document or FALSE if encoder is not set.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruDoc::setCurrentEncoder() - Set the current encoder for the document

HaruDoc::createOutline
HaruDoc::getCurrentPage
HaruDoc


Return current page of the document

HaruDoc::getCurrentEncoder
HaruDoc::getEncoder
HaruDoc
PHP Manual

HaruDoc::getCurrentPage

(PECL haru >= 0.0.1)

HaruDoc::getCurrentPage — Return current page of the document

Açıklama

object HaruDoc::getCurrentPage ( void )

Get current page of the document.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns HaruPage instance on success or FALSE if there is no current page at the moment.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruDoc::getCurrentEncoder
HaruDoc::getEncoder
HaruDoc


Get HaruEncoder instance for the specified encoding

HaruDoc::getCurrentPage
HaruDoc::getFont
HaruDoc
PHP Manual

HaruDoc::getEncoder

(PECL haru >= 0.0.1)

HaruDoc::getEncoder — Get HaruEncoder instance for the specified encoding

Açıklama

object HaruDoc::getEncoder ( string $encoding )

Get the HaruEncoder instance for the specified encoding.

Değiştirgeler

encoding

The encoding name. See Builtin Encodings for the list of allowed values.

Dönen Değerler

Returns a HaruEncoder instance for the specified encoding.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruDoc::setCurrentEncoder() - Set the current encoder for the document
  • HaruDoc::getCurrentEncoder() - Get HaruEncoder currently used in the document

HaruDoc::getCurrentPage
HaruDoc::getFont
HaruDoc


Get HaruFont instance

HaruDoc::getEncoder
HaruDoc::getInfoAttr
HaruDoc
PHP Manual

HaruDoc::getFont

(PECL haru >= 0.0.1)

HaruDoc::getFont — Get HaruFont instance

Açıklama

object HaruDoc::getFont ( string $fontname [, string $encoding ] )

Get a HaruFont instance.

Değiştirgeler

fontname

The name of the font. See Builtin Fonts for the list of builtin fonts. You can also use the name of a font loaded via HaruDoc::loadTTF(), HaruDoc::loadTTC() and HaruDoc::loadType1().

encoding

The encoding to use. See Builtin Encodings for the list of supported encodings.

Dönen Değerler

Returns a HaruFont instance with the specified fontname and encoding.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::setFontAndSize() - Set font and fontsize for the page
  • HaruPage::setCurrentFont()

HaruDoc::getEncoder
HaruDoc::getInfoAttr
HaruDoc


Get current value of the specified document attribute

HaruDoc::getFont
HaruDoc::getPageLayout
HaruDoc
PHP Manual

HaruDoc::getInfoAttr

(PECL haru >= 0.0.1)

HaruDoc::getInfoAttr — Get current value of the specified document attribute

Açıklama

string HaruDoc::getInfoAttr ( int $type )

Get the current value of the specified document attribute.

Değiştirgeler

type

The type of the attribute. The following values are available:

  • HaruDoc::INFO_AUTHOR
  • HaruDoc::INFO_CREATOR
  • HaruDoc::INFO_TITLE
  • HaruDoc::INFO_SUBJECT
  • HaruDoc::INFO_KEYWORDS
  • HaruDoc::INFO_CREATION_DATE
  • HaruDoc::INFO_MOD_DATE

Dönen Değerler

Returns the string value of the specified document attribute.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruDoc::setInfoAttr() - Set the info attribute of the document
  • HaruDoc::setInfoDateAttr() - Set the datetime info attributes of the document

HaruDoc::getFont
HaruDoc::getPageLayout
HaruDoc


Get current page layout

HaruDoc::getInfoAttr
HaruDoc::getPageMode
HaruDoc
PHP Manual

HaruDoc::getPageLayout

(PECL haru >= 0.0.1)

HaruDoc::getPageLayout — Get current page layout

Açıklama

int HaruDoc::getPageLayout ( void )

Get the current page layout. See HaruDoc::setPageLayout() for the list of possible values.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the page layout currently set in the document or FALSE if page layout was not set. See HaruDoc::setPageLayout() for the list of possible values.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruDoc::setPageLayout() - Set how pages should be displayed

HaruDoc::getInfoAttr
HaruDoc::getPageMode
HaruDoc


Get current page mode

HaruDoc::getPageLayout
HaruDoc::getStreamSize
HaruDoc
PHP Manual

HaruDoc::getPageMode

(PECL haru >= 0.0.1)

HaruDoc::getPageMode — Get current page mode

Açıklama

int HaruDoc::getPageMode ( void )

Get the current page mode. See HaruDoc::setPageMode() for the list of possible values.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the page mode currently set in the document. See HaruDoc::setPageMode() for the list of possible values.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruDoc::setPageMode() - Set how the document should be displayed

HaruDoc::getPageLayout
HaruDoc::getStreamSize
HaruDoc


Get the size of the temporary stream

HaruDoc::getPageMode
HaruDoc::insertPage
HaruDoc
PHP Manual

HaruDoc::getStreamSize

(PECL haru >= 0.0.1)

HaruDoc::getStreamSize — Get the size of the temporary stream

Açıklama

int HaruDoc::getStreamSize ( void )

Get the size of the temporary stream.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the size of the data in the temporary stream of the document. The size is zero if the document was not saved to the temporary stream.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruDoc::saveToStream() - Save the document into a temporary stream
  • HaruDoc::resetStream() - Rewind the temporary stream
  • HaruDoc::readFromStream() - Read data from the temporary stream

HaruDoc::getPageMode
HaruDoc::insertPage
HaruDoc


Insert new page just before the specified page

HaruDoc::getStreamSize
HaruDoc::loadJPEG
HaruDoc
PHP Manual

HaruDoc::insertPage

(PECL haru >= 0.0.1)

HaruDoc::insertPage — Insert new page just before the specified page

Açıklama

object HaruDoc::insertPage ( object $page )

Creates a new page and inserts just before the specified page.

Değiştirgeler

page

A valid HaruPage instance.

Dönen Değerler

Returns a new HaruPage instance.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruDoc::addPage() - Add new page to the document

HaruDoc::getStreamSize
HaruDoc::loadJPEG
HaruDoc


Load a JPEG image

HaruDoc::insertPage
HaruDoc::loadPNG
HaruDoc
PHP Manual

HaruDoc::loadJPEG

(PECL haru >= 0.0.1)

HaruDoc::loadJPEG — Load a JPEG image

Açıklama

object HaruDoc::loadJPEG ( string $filename )

Loads the specified JPEG image.

Değiştirgeler

filename

A valid JPEG image file.

Dönen Değerler

Returns a new HaruImage instance.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruDoc::loadPNG() - Load PNG image and return HaruImage instance
  • HaruDoc::loadRAW() - Load a RAW image

HaruDoc::insertPage
HaruDoc::loadPNG
HaruDoc


Load PNG image and return HaruImage instance

HaruDoc::loadJPEG
HaruDoc::loadRaw
HaruDoc
PHP Manual

HaruDoc::loadPNG

(PECL haru >= 0.0.1)

HaruDoc::loadPNG — Load PNG image and return HaruImage instance

Açıklama

object HaruDoc::loadPNG ( string $filename [, bool $deferred = false ] )

Loads a PNG image.

Libharu might be built without libpng support, in this case each call to this function would result in exception.

Değiştirgeler

filename

The name of a PNG image file.

deferred

Do not load data immediately. You can set deferred parameter to TRUE for deferred data loading, in this case only size and color are loaded immediately.

Dönen Değerler

Returns a HaruImage instance.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruDoc::loadJPEG() - Load a JPEG image
  • HaruDoc::loadRAW() - Load a RAW image

HaruDoc::loadJPEG
HaruDoc::loadRaw
HaruDoc


Load a RAW image

HaruDoc::loadPNG
HaruDoc::loadTTC
HaruDoc
PHP Manual

HaruDoc::loadRaw

(PECL haru >= 0.0.1)

HaruDoc::loadRaw — Load a RAW image

Açıklama

object HaruDoc::loadRaw ( string $filename , int $width , int $height , int $color_space )

Loads a RAW image.

Değiştirgeler

filename

The name of a RAW image file.

width

The width of the image.

height

The height of the image.

color_space

The color space of the image. Can be one of the following values:

  • HaruDoc::CS_DEVICE_GRAY
  • HaruDoc::CS_DEVICE_RGB
  • HaruDoc::CS_DEVICE_CMYK

Dönen Değerler

Returns a HaruImage instance.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruDoc::loadJPEG() - Load a JPEG image
  • HaruDoc::loadPNG() - Load PNG image and return HaruImage instance

HaruDoc::loadPNG
HaruDoc::loadTTC
HaruDoc


Load the font with the specified index from TTC file

HaruDoc::loadRaw
HaruDoc::loadTTF
HaruDoc
PHP Manual

HaruDoc::loadTTC

(PECL haru >= 0.0.1)

HaruDoc::loadTTC — Load the font with the specified index from TTC file

Açıklama

string HaruDoc::loadTTC ( string $fontfile , int $index [, bool $embed = false ] )

Loads the TrueType font with the specified index from a TrueType collection file.

Değiştirgeler

fontfile

The TrueType collection file.

index

The index of the font in the collection file.

embed

When set to TRUE, the glyph data of the font is embedded into the PDF file, otherwise only the matrix data is included.

Dönen Değerler

Returns the name of the loaded font on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruDoc::loadTTF() - Load TTF font file
  • HaruDoc::loadType1() - Load Type1 font

HaruDoc::loadRaw
HaruDoc::loadTTF
HaruDoc


Load TTF font file

HaruDoc::loadTTC
HaruDoc::loadType1
HaruDoc
PHP Manual

HaruDoc::loadTTF

(PECL haru >= 0.0.1)

HaruDoc::loadTTF — Load TTF font file

Açıklama

string HaruDoc::loadTTF ( string $fontfile [, bool $embed = false ] )

Loads the given TTF file and (optionally) embed its data into the document.

Değiştirgeler

fontfile

The TTF file to load.

embed

When set to TRUE, the glyph data of the font is embedded into the PDF file, otherwise only the matrix data is included.

Dönen Değerler

Returns the name of the loaded font on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruDoc::loadTTC() - Load the font with the specified index from TTC file
  • HaruDoc::loadType1() - Load Type1 font

HaruDoc::loadTTC
HaruDoc::loadType1
HaruDoc


Load Type1 font

HaruDoc::loadTTF
HaruDoc::output
HaruDoc
PHP Manual

HaruDoc::loadType1

(PECL haru >= 0.0.1)

HaruDoc::loadType1 — Load Type1 font

Açıklama

string HaruDoc::loadType1 ( string $afmfile [, string $pfmfile ] )

Loads Type1 font from the given file and registers it in the PDF document.

Değiştirgeler

afmfile

Path to an AFM file.

pfmfile

Path to a PFA/PFB file, optional. If it's not set only the glyph data of the font is embedded into the PDF document.

Dönen Değerler

Returns the name of the loaded font on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruDoc::loadTTC() - Load the font with the specified index from TTC file
  • HaruDoc::loadTTF() - Load TTF font file

HaruDoc::loadTTF
HaruDoc::output
HaruDoc


Write the document data to the output buffer

HaruDoc::loadType1
HaruDoc::readFromStream
HaruDoc
PHP Manual

HaruDoc::output

(PECL haru >= 0.0.1)

HaruDoc::output — Write the document data to the output buffer

Açıklama

bool HaruDoc::output ( void )

Writes the document data into standard output.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruDoc::save() - Save the document into the specified file

HaruDoc::loadType1
HaruDoc::readFromStream
HaruDoc


Read data from the temporary stream

HaruDoc::output
HaruDoc::resetError
HaruDoc
PHP Manual

HaruDoc::readFromStream

(PECL haru >= 0.0.1)

HaruDoc::readFromStream — Read data from the temporary stream

Açıklama

string HaruDoc::readFromStream ( int $bytes )

Read data from the temporary stream.

Değiştirgeler

bytes

The bytes parameter specifies how many bytes to read, though the stream may contain less bytes than requested.

Dönen Değerler

Returns data from the temporary stream.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruDoc::saveToStream() - Save the document into a temporary stream
  • HaruDoc::resetStream() - Rewind the temporary stream
  • HaruDoc::getStreamSize() - Get the size of the temporary stream

HaruDoc::output
HaruDoc::resetError
HaruDoc


Reset error state of the document handle

HaruDoc::readFromStream
HaruDoc::resetStream
HaruDoc
PHP Manual

HaruDoc::resetError

(PECL haru >= 0.0.1)

HaruDoc::resetError — Reset error state of the document handle

Açıklama

bool HaruDoc::resetError ( void )

Once an error code is set, most of the operations, including I/O processing functions cannot be performed. In case if you want to continue after the cause of the error has been fixed, you have to invoke this function in order to reset the document error state.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Always succeeds and returns TRUE.

HaruDoc::readFromStream
HaruDoc::resetStream
HaruDoc


Rewind the temporary stream

HaruDoc::resetError
HaruDoc::save
HaruDoc
PHP Manual

HaruDoc::resetStream

(PECL haru >= 0.0.1)

HaruDoc::resetStream — Rewind the temporary stream

Açıklama

bool HaruDoc::resetStream ( void )

Rewinds the temporary stream of the document.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruDoc::saveToStream() - Save the document into a temporary stream
  • HaruDoc::getStreamSize() - Get the size of the temporary stream
  • HaruDoc::readFromStream() - Read data from the temporary stream

HaruDoc::resetError
HaruDoc::save
HaruDoc


Save the document into the specified file

HaruDoc::resetStream
HaruDoc::saveToStream
HaruDoc
PHP Manual

HaruDoc::save

(PECL haru >= 0.0.1)

HaruDoc::save — Save the document into the specified file

Açıklama

bool HaruDoc::save ( string $file )

Saves the document into the specified file.

Değiştirgeler

file

The file to save the document to.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruDoc::output() - Write the document data to the output buffer

HaruDoc::resetStream
HaruDoc::saveToStream
HaruDoc


Save the document into a temporary stream

HaruDoc::save
HaruDoc::setCompressionMode
HaruDoc
PHP Manual

HaruDoc::saveToStream

(PECL haru >= 0.0.1)

HaruDoc::saveToStream — Save the document into a temporary stream

Açıklama

bool HaruDoc::saveToStream ( void )

Saves the document data into a temporary stream.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruDoc::resetStream() - Rewind the temporary stream
  • HaruDoc::getStreamSize() - Get the size of the temporary stream
  • HaruDoc::readFromStream() - Read data from the temporary stream

HaruDoc::save
HaruDoc::setCompressionMode
HaruDoc


Set compression mode for the document

HaruDoc::saveToStream
HaruDoc::setCurrentEncoder
HaruDoc
PHP Manual

HaruDoc::setCompressionMode

(PECL haru >= 0.0.1)

HaruDoc::setCompressionMode — Set compression mode for the document

Açıklama

bool HaruDoc::setCompressionMode ( int $mode )

Defines compression mode for the document. In case when libharu was compiled without Zlib support this function will always throw HaruException.

Değiştirgeler

mode

The compression mode to use. The value is a combination of the following flags:

  • HaruDoc::COMP_NONE - all contents is not compressed.
  • HaruDoc::COMP_TEXT - compress the text data.
  • HaruDoc::COMP_IMAGE - compress the image data.
  • HaruDoc::COMP_METADATA - compress other data (fonts, cmaps).
  • HaruDoc::COMP_ALL - compress all data.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruDoc::saveToStream
HaruDoc::setCurrentEncoder
HaruDoc


Set the current encoder for the document

HaruDoc::setCompressionMode
HaruDoc::setEncryptionMode
HaruDoc
PHP Manual

HaruDoc::setCurrentEncoder

(PECL haru >= 0.0.1)

HaruDoc::setCurrentEncoder — Set the current encoder for the document

Açıklama

bool HaruDoc::setCurrentEncoder ( string $encoding )

Defines the encoder currently used in the document.

Değiştirgeler

encoding

The name of the encoding to use. See Builtin Encodings for the list of allowed values.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruDoc::setCompressionMode
HaruDoc::setEncryptionMode
HaruDoc


Set encryption mode for the document

HaruDoc::setCurrentEncoder
HaruDoc::setInfoAttr
HaruDoc
PHP Manual

HaruDoc::setEncryptionMode

(PECL haru >= 0.0.1)

HaruDoc::setEncryptionMode — Set encryption mode for the document

Açıklama

bool HaruDoc::setEncryptionMode ( int $mode [, int $key_len = 5 ] )

Defines encryption mode for the document. The encryption mode cannot be set before setting the password.

Değiştirgeler

mode

The encryption mode to use. Can be one of the following:

  • HaruDoc::ENCRYPT_R2 - use "revision2" algorithm.
  • HaruDoc::ENCRYPT_R3 - use "revision3" algorithm. Using this value bumps the version of PDF to 1.4.

key_len

The encryption key length in bytes. This parameter is optional and used only when mode is HaruDoc::ENCRYPT_R3. The default value is 5 (40bit).

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruDoc::setPassword() - Set owner and user passwords for the document
  • HaruDoc::setPermission() - Set permissions for the document

HaruDoc::setCurrentEncoder
HaruDoc::setInfoAttr
HaruDoc


Set the info attribute of the document

HaruDoc::setEncryptionMode
HaruDoc::setInfoDateAttr
HaruDoc
PHP Manual

HaruDoc::setInfoAttr

(PECL haru >= 0.0.1)

HaruDoc::setInfoAttr — Set the info attribute of the document

Açıklama

bool HaruDoc::setInfoAttr ( int $type , string $info )

Defines an info attribute. Uses the current encoding of the document.

Değiştirgeler

type

The type of the attribute. Can be one of the following:

  • HaruDoc::INFO_AUTHOR
  • HaruDoc::INFO_CREATOR
  • HaruDoc::INFO_TITLE
  • HaruDoc::INFO_SUBJECT
  • HaruDoc::INFO_KEYWORDS

info

The value of the attribute.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruDoc::setInfoDateAttr() - Set the datetime info attributes of the document

HaruDoc::setEncryptionMode
HaruDoc::setInfoDateAttr
HaruDoc


Set the datetime info attributes of the document

HaruDoc::setInfoAttr
HaruDoc::setOpenAction
HaruDoc
PHP Manual

HaruDoc::setInfoDateAttr

(PECL haru >= 0.0.1)

HaruDoc::setInfoDateAttr — Set the datetime info attributes of the document

Açıklama

bool HaruDoc::setInfoDateAttr ( int $type , int $year , int $month , int $day , int $hour , int $min , int $sec , string $ind , int $off_hour , int $off_min )

Sets the datetime info attributes of the document.

Değiştirgeler

type

The type of the attribute. Can be one of the following:

  • HaruDoc::INFO_CREATION_DATE
  • HaruDoc::INFO_MOD_DATE

year

month

Between 1 and 12.

day

Between 1 and 31, 30, 29 or 28 (different for each month).

hour

Between 0 and 23.

min

Between 0 and 59.

sec

Between 0 and 59.

ind

The timezone relation to UTC, can be "", " ", "+", "-" and "Z".

off_hour

If ind is not " " or "", values between 0 and 23 are valid. Otherwise, this parameter is ignored.

off_min

If ind is not " " or "", values between 0 and 59 are valid. Otherwise, this parameter is ignored.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruDoc::setInfoAttr() - Set the info attribute of the document

HaruDoc::setInfoAttr
HaruDoc::setOpenAction
HaruDoc


Define which page is shown when the document is opened

HaruDoc::setInfoDateAttr
HaruDoc::setPageLayout
HaruDoc
PHP Manual

HaruDoc::setOpenAction

(PECL haru >= 0.0.1)

HaruDoc::setOpenAction — Define which page is shown when the document is opened

Açıklama

bool HaruDoc::setOpenAction ( object $destination )

Defines which page should be shown when the document is opened.

Değiştirgeler

destination

A valid HaruDestination instance.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruDoc::setInfoDateAttr
HaruDoc::setPageLayout
HaruDoc


Set how pages should be displayed

HaruDoc::setOpenAction
HaruDoc::setPageMode
HaruDoc
PHP Manual

HaruDoc::setPageLayout

(PECL haru >= 0.0.1)

HaruDoc::setPageLayout — Set how pages should be displayed

Açıklama

bool HaruDoc::setPageLayout ( int $layout )

Defines how pages should be displayed.

Değiştirgeler

layout

The following values are accepted:

  • HaruDoc::PAGE_LAYOUT_SINGLE - only one page is displayed.
  • HaruDoc::PAGE_LAYOUT_ONE_COLUMN - display the pages in one column.
  • HaruDoc::PAGE_LAYOUT_TWO_COLUMN_LEFT - display pages in two columns, first page left.
  • HaruDoc::PAGE_LAYOUT_TWO_COLUMN_RIGHT - display pages in two columns, first page right.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruDoc::getPageLayout() - Get current page layout

HaruDoc::setOpenAction
HaruDoc::setPageMode
HaruDoc


Set how the document should be displayed

HaruDoc::setPageLayout
HaruDoc::setPagesConfiguration
HaruDoc
PHP Manual

HaruDoc::setPageMode

(PECL haru >= 0.0.1)

HaruDoc::setPageMode — Set how the document should be displayed

Açıklama

bool HaruDoc::setPageMode ( int $mode )

Defines how the document should be displayed.

Değiştirgeler

mode

The following values are accepted:

  • HaruDoc::PAGE_MODE_USE_NONE - display the document with neither outline nor thumbnail.
  • HaruDoc::PAGE_MODE_USE_OUTLINE - display the document with outline pane.
  • HaruDoc::PAGE_MODE_USE_THUMBS - display the document with thumbnail pane.
  • HaruDoc::PAGE_MODE_FULL_SCREEN - display the document with full screen mode.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruDoc::getPageMode() - Get current page mode

HaruDoc::setPageLayout
HaruDoc::setPagesConfiguration
HaruDoc


Set the number of pages per set of pages

HaruDoc::setPageMode
HaruDoc::setPassword
HaruDoc
PHP Manual

HaruDoc::setPagesConfiguration

(PECL haru >= 0.0.1)

HaruDoc::setPagesConfiguration — Set the number of pages per set of pages

Açıklama

bool HaruDoc::setPagesConfiguration ( int $page_per_pages )

By default the document has one pages object as a root for all pages. All page objects are create as branches of this object. One pages object can contain only 8191, therefore the maximum number of pages per document is 8191. But you can change that fact by setting page_per_pages parameter, so that the root pages object contains 8191 more pages (not page) objects, which in turn contain 8191 pages each. So the maximum number of pages in the document becomes 8191*page_per_pages.

Değiştirgeler

page_per_pages

The numbers of pages that a pages object can contain.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruDoc::setPageMode
HaruDoc::setPassword
HaruDoc


Set owner and user passwords for the document

HaruDoc::setPagesConfiguration
HaruDoc::setPermission
HaruDoc
PHP Manual

HaruDoc::setPassword

(PECL haru >= 0.0.1)

HaruDoc::setPassword — Set owner and user passwords for the document

Açıklama

bool HaruDoc::setPassword ( string $owner_password , string $user_password )

Defines owner and user passwords for the document. Setting the passwords makes the document contents encrypted.

Değiştirgeler

owner_password

The password of the owner, which can change permissions of the document. Empty password is not accepted. Owner's password cannot be the same as the user's password.

user_password

The password of the user. Can be empty.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruDoc::setEncryptionMode() - Set encryption mode for the document
  • HaruDoc::setPermission() - Set permissions for the document

HaruDoc::setPagesConfiguration
HaruDoc::setPermission
HaruDoc


Set permissions for the document

HaruDoc::setPassword
HaruDoc::useCNSEncodings
HaruDoc
PHP Manual

HaruDoc::setPermission

(PECL haru >= 0.0.1)

HaruDoc::setPermission — Set permissions for the document

Açıklama

bool HaruDoc::setPermission ( int $permission )

Defines permissions for the document.

Değiştirgeler

permission

The values is a combination of these flags:

  • HaruDoc::ENABLE_READ - user can read the document.
  • HaruDoc::ENABLE_PRINT - user can print the document.
  • HaruDoc::ENABLE_EDIT_ALL - user can edit the contents of the document other than annotations and form fields.
  • HaruDoc::ENABLE_COPY - user can copy the text and the graphics of the document.
  • HaruDoc::ENABLE_EDIT - user can add or modify the annotations and form fields of the document.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruDoc::setPassword() - Set owner and user passwords for the document
  • HaruDoc::setEncryptionMode() - Set encryption mode for the document

HaruDoc::setPassword
HaruDoc::useCNSEncodings
HaruDoc


Enable Chinese simplified encodings

HaruDoc::setPermission
HaruDoc::useCNSFonts
HaruDoc
PHP Manual

HaruDoc::useCNSEncodings

(PECL haru >= 0.0.1)

HaruDoc::useCNSEncodings — Enable Chinese simplified encodings

Açıklama

bool HaruDoc::useCNSEncodings ( void )

Enables Chinese simplified encodings.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruDoc::useCNSFonts() - Enable builtin Chinese simplified fonts

HaruDoc::setPermission
HaruDoc::useCNSFonts
HaruDoc


Enable builtin Chinese simplified fonts

HaruDoc::useCNSEncodings
HaruDoc::useCNTEncodings
HaruDoc
PHP Manual

HaruDoc::useCNSFonts

(PECL haru >= 0.0.1)

HaruDoc::useCNSFonts — Enable builtin Chinese simplified fonts

Açıklama

bool HaruDoc::useCNSFonts ( void )

Enables builtin Chinese simplified fonts.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruDoc::useCNSEncodings() - Enable Chinese simplified encodings

HaruDoc::useCNSEncodings
HaruDoc::useCNTEncodings
HaruDoc


Enable Chinese traditional encodings

HaruDoc::useCNSFonts
HaruDoc::useCNTFonts
HaruDoc
PHP Manual

HaruDoc::useCNTEncodings

(PECL haru >= 0.0.1)

HaruDoc::useCNTEncodings — Enable Chinese traditional encodings

Açıklama

bool HaruDoc::useCNTEncodings ( void )

Enables Chinese traditional encodings.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruDoc::useCNTFonts() - Enable builtin Chinese traditional fonts

HaruDoc::useCNSFonts
HaruDoc::useCNTFonts
HaruDoc


Enable builtin Chinese traditional fonts

HaruDoc::useCNTEncodings
HaruDoc::useJPEncodings
HaruDoc
PHP Manual

HaruDoc::useCNTFonts

(PECL haru >= 0.0.1)

HaruDoc::useCNTFonts — Enable builtin Chinese traditional fonts

Açıklama

bool HaruDoc::useCNTFonts ( void )

Enables builtin Chinese traditional fonts.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruDoc::useCNTEncodings() - Enable Chinese traditional encodings

HaruDoc::useCNTEncodings
HaruDoc::useJPEncodings
HaruDoc


Enable Japanese encodings

HaruDoc::useCNTFonts
HaruDoc::useJPFonts
HaruDoc
PHP Manual

HaruDoc::useJPEncodings

(PECL haru >= 0.0.1)

HaruDoc::useJPEncodings — Enable Japanese encodings

Açıklama

bool HaruDoc::useJPEncodings ( void )

Enables Japanese encodings.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruDoc::useJPFonts() - Enable builtin Japanese fonts

HaruDoc::useCNTFonts
HaruDoc::useJPFonts
HaruDoc


Enable builtin Japanese fonts

HaruDoc::useJPEncodings
HaruDoc::useKREncodings
HaruDoc
PHP Manual

HaruDoc::useJPFonts

(PECL haru >= 0.0.1)

HaruDoc::useJPFonts — Enable builtin Japanese fonts

Açıklama

bool HaruDoc::useJPFonts ( void )

Enables builtin Japanese fonts.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruDoc::useJPEncodings() - Enable Japanese encodings

HaruDoc::useJPEncodings
HaruDoc::useKREncodings
HaruDoc


Enable Korean encodings

HaruDoc::useJPFonts
HaruDoc::useKRFonts
HaruDoc
PHP Manual

HaruDoc::useKREncodings

(PECL haru >= 0.0.1)

HaruDoc::useKREncodings — Enable Korean encodings

Açıklama

bool HaruDoc::useKREncodings ( void )

Enables Korean encodings.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruDoc::useKRFonts() - Enable builtin Korean fonts

HaruDoc::useJPFonts
HaruDoc::useKRFonts
HaruDoc


Enable builtin Korean fonts

HaruDoc::useKREncodings
HaruPage
HaruDoc
PHP Manual

HaruDoc::useKRFonts

(PECL haru >= 0.0.1)

HaruDoc::useKRFonts — Enable builtin Korean fonts

Açıklama

bool HaruDoc::useKRFonts ( void )

Enables builtin Korean fonts.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruDoc::useKREncodings() - Enable Korean encodings

HaruDoc::useKREncodings
HaruPage
HaruDoc


The HaruPage class

(PECL haru >= 0.0.1)

Giriş

Haru PDF Page Class.

Sınıf Sözdizimi

HaruPage {
/* Yöntemler */
bool arc ( float $x , float $y , float $ray , float $ang1 , float $ang2 )
bool beginText ( void )
bool circle ( float $x , float $y , float $ray )
bool closePath ( void )
bool concat ( float $a , float $b , float $c , float $d , float $x , float $y )
object createDestination ( void )
object createLinkAnnotation ( array $rectangle , object $destination )
object createTextAnnotation ( array $rectangle , string $text [, object $encoder ] )
object createURLAnnotation ( array $rectangle , string $url )
bool curveTo2 ( float $x2 , float $y2 , float $x3 , float $y3 )
bool curveTo3 ( float $x1 , float $y1 , float $x3 , float $y3 )
bool curveTo ( float $x1 , float $y1 , float $x2 , float $y2 , float $x3 , float $y3 )
bool drawImage ( object $image , float $x , float $y , float $width , float $height )
bool ellipse ( float $x , float $y , float $xray , float $yray )
bool endPath ( void )
bool endText ( void )
bool eofill ( void )
bool eoFillStroke ([ bool $close_path = false ] )
bool fill ( void )
bool fillStroke ([ bool $close_path = false ] )
float getCharSpace ( void )
array getCMYKFill ( void )
array getCMYKStroke ( void )
object getCurrentFont ( void )
float getCurrentFontSize ( void )
array getCurrentPos ( void )
array getCurrentTextPos ( void )
array getDash ( void )
int getFillingColorSpace ( void )
float getFlatness ( void )
int getGMode ( void )
float getGrayFill ( void )
float getGrayStroke ( void )
float getHeight ( void )
float getHorizontalScaling ( void )
int getLineCap ( void )
int getLineJoin ( void )
float getLineWidth ( void )
float getMiterLimit ( void )
array getRGBFill ( void )
array getRGBStroke ( void )
int getStrokingColorSpace ( void )
float getTextLeading ( void )
array getTextMatrix ( void )
int getTextRenderingMode ( void )
float getTextRise ( void )
float getTextWidth ( string $text )
array getTransMatrix ( void )
float getWidth ( void )
float getWordSpace ( void )
bool lineTo ( float $x , float $y )
int measureText ( string $text , float $width [, bool $wordwrap = false ] )
bool moveTextPos ( float $x , float $y [, bool $set_leading = false ] )
bool moveTo ( float $x , float $y )
bool moveToNextLine ( void )
bool rectangle ( float $x , float $y , float $width , float $height )
bool setCharSpace ( float $char_space )
bool setCMYKFill ( float $c , float $m , float $y , float $k )
bool setCMYKStroke ( float $c , float $m , float $y , float $k )
bool setDash ( array $pattern , int $phase )
bool setFlatness ( float $flatness )
bool setFontAndSize ( object $font , float $size )
bool setGrayFill ( float $value )
bool setGrayStroke ( float $value )
bool setHeight ( float $height )
bool setHorizontalScaling ( float $scaling )
bool setLineCap ( int $cap )
bool setLineJoin ( int $join )
bool setLineWidth ( float $width )
bool setMiterLimit ( float $limit )
bool setRGBFill ( float $r , float $g , float $b )
bool setRGBStroke ( float $r , float $g , float $b )
bool setRotate ( int $angle )
bool setSize ( int $size , int $direction )
bool setSlideShow ( int $type , float $disp_time , float $trans_time )
bool setTextLeading ( float $text_leading )
bool setTextMatrix ( float $a , float $b , float $c , float $d , float $x , float $y )
bool setTextRenderingMode ( int $mode )
bool setTextRise ( float $rise )
bool setWidth ( float $width )
bool setWordSpace ( float $word_space )
bool showText ( string $text )
bool showTextNextLine ( string $text [, float $word_space = 0 [, float $char_space = 0 ]] )
bool stroke ([ bool $close_path = false ] )
bool textOut ( float $x , float $y , string $text )
bool textRect ( float $left , float $top , float $right , float $bottom , string $text [, int $align = HaruPage::TALIGN_LEFT ] )
}

Öntanımlı Sabitler

Type | Name | Description
int | HaruPage::GMODE_PAGE_DESCRIPTION |
int | HaruPage::GMODE_TEXT_OBJECT |
int | HaruPage::GMODE_PATH_OBJECT |
int | HaruPage::GMODE_CLIPPING_PATH |
int | HaruPage::GMODE_SHADING |
int | HaruPage::GMODE_INLINE_IMAGE |
int | HaruPage::GMODE_EXTERNAL_OBJECT |
int | HaruPage::BUTT_END |
int | HaruPage::ROUND_END |
int | HaruPage::PROJECTING_SCUARE_END |
int | HaruPage::MITER_JOIN |
int | HaruPage::ROUND_JOIN |
int | HaruPage::BEVEL_JOIN |
int | HaruPage::FILL |
int | HaruPage::STROKE |
int | HaruPage::FILL_THEN_STROKE |
int | HaruPage::INVISIBLE |
int | HaruPage::FILL_CLIPPING |
int | HaruPage::STROKE_CLIPPING |
int | HaruPage::FILL_STROKE_CLIPPING |
int | HaruPage::CLIPPING |
int | HaruPage::TALIGN_LEFT |
int | HaruPage::TALIGN_RIGHT |
int | HaruPage::TALIGN_CENTER |
int | HaruPage::TALIGN_JUSTIFY |
int | HaruPage::SIZE_LETTER |
int | HaruPage::SIZE_LEGAL |
int | HaruPage::SIZE_A3 |
int | HaruPage::SIZE_A4 |
int | HaruPage::SIZE_A5 |
int | HaruPage::SIZE_B4 |
int | HaruPage::SIZE_B5 |
int | HaruPage::SIZE_EXECUTIVE |
int | HaruPage::SIZE_US4x6 |
int | HaruPage::SIZE_US4x8 |
int | HaruPage::SIZE_US5x7 |
int | HaruPage::SIZE_COMM10 |
int | HaruPage::PORTRAIT |
int | HaruPage::LANDSCAPE |
int | HaruPage::TS_WIPE_LIGHT |
int | HaruPage::TS_WIPE_UP |
int | HaruPage::TS_WIPE_LEFT |
int | HaruPage::TS_WIPE_DOWN |
int | HaruPage::TS_BARN_DOORS_HORIZONTAL_OUT |
int | HaruPage::TS_BARN_DOORS_HORIZONTAL_IN |
int | HaruPage::TS_BARN_DOORS_VERTICAL_OUT |
int | HaruPage::TS_BARN_DOORS_VERTICAL_IN |
int | HaruPage::TS_BOX_OUT |
int | HaruPage::TS_BOX_IN |
int | HaruPage::TS_BLINDS_HORIZONTAL |
int | HaruPage::TS_BLINDS_VERTICAL |
int | HaruPage::TS_DISSOLVE |
int | HaruPage::TS_GLITTER_RIGHT |
int | HaruPage::TS_GLITTER_DOWN |
int | HaruPage::TS_GLITTER_TOP_LEFT_TO_BOTTOM_RIGHT |
int | HaruPage::TS_REPLACE |
int | HaruPage::NUM_STYLE_DECIMAL |
int | HaruPage::NUM_STYLE_UPPER_ROMAN |
int | HaruPage::NUM_STYLE_LOWER_ROMAN |
int | HaruPage::NUM_STYLE_UPPER_LETTERS |
int | HaruPage::NUM_STYLE_LOWER_LETTERS |

İçindekiler

  • HaruPage::arc — Append an arc to the current path
  • HaruPage::beginText — Begin a text object and set the current text position to (0,0)
  • HaruPage::circle — Append a circle to the current path
  • HaruPage::closePath — Append a straight line from the current point to the start point of the path
  • HaruPage::concat — Concatenate current transformation matrix of the page and the specified matrix
  • HaruPage::createDestination — Create new HaruDestination instance
  • HaruPage::createLinkAnnotation — Create new HaruAnnotation instance
  • HaruPage::createTextAnnotation — Create new HaruAnnotation instance
  • HaruPage::createURLAnnotation — Create and return new HaruAnnotation instance
  • HaruPage::curveTo2 — Append a Bezier curve to the current path
  • HaruPage::curveTo3 — Append a Bezier curve to the current path
  • HaruPage::curveTo — Append a Bezier curve to the current path
  • HaruPage::drawImage — Show image at the page
  • HaruPage::ellipse — Append an ellipse to the current path
  • HaruPage::endPath — End current path object without filling and painting operations
  • HaruPage::endText — End current text object
  • HaruPage::eofill — Fill current path using even-odd rule
  • HaruPage::eoFillStroke — Fill current path using even-odd rule, then paint the path
  • HaruPage::fill — Fill current path using nonzero winding number rule
  • HaruPage::fillStroke — Fill current path using nonzero winding number rule, then paint the path
  • HaruPage::getCharSpace — Get the current value of character spacing
  • HaruPage::getCMYKFill — Get the current filling color
  • HaruPage::getCMYKStroke — Get the current stroking color
  • HaruPage::getCurrentFont — Get the currently used font
  • HaruPage::getCurrentFontSize — Get the current font size
  • HaruPage::getCurrentPos — Get the current position for path painting
  • HaruPage::getCurrentTextPos — Get the current position for text printing
  • HaruPage::getDash — Get the current dash pattern
  • HaruPage::getFillingColorSpace — Get the current filling color space
  • HaruPage::getFlatness — Get the flatness of the page
  • HaruPage::getGMode — Get the current graphics mode
  • HaruPage::getGrayFill — Get the current filling color
  • HaruPage::getGrayStroke — Get the current stroking color
  • HaruPage::getHeight — Get the height of the page
  • HaruPage::getHorizontalScaling — Get the current value of horizontal scaling
  • HaruPage::getLineCap — Get the current line cap style
  • HaruPage::getLineJoin — Get the current line join style
  • HaruPage::getLineWidth — Get the current line width
  • HaruPage::getMiterLimit — Get the value of miter limit
  • HaruPage::getRGBFill — Get the current filling color
  • HaruPage::getRGBStroke — Get the current stroking color
  • HaruPage::getStrokingColorSpace — Get the current stroking color space
  • HaruPage::getTextLeading — Get the current value of line spacing
  • HaruPage::getTextMatrix — Get the current text transformation matrix of the page
  • HaruPage::getTextRenderingMode — Get the current text rendering mode
  • HaruPage::getTextRise — Get the current value of text rising
  • HaruPage::getTextWidth — Get the width of the text using current fontsize, character spacing and word spacing
  • HaruPage::getTransMatrix — Get the current transformation matrix of the page
  • HaruPage::getWidth — Get the width of the page
  • HaruPage::getWordSpace — Get the current value of word spacing
  • HaruPage::lineTo — Draw a line from the current point to the specified point
  • HaruPage::measureText — Calculate the byte length of characters which can be included on one line of the specified width
  • HaruPage::moveTextPos — Move text position to the specified offset
  • HaruPage::moveTo — Set starting point for new drawing path
  • HaruPage::moveToNextLine — Move text position to the start of the next line
  • HaruPage::rectangle — Append a rectangle to the current path
  • HaruPage::setCharSpace — Set character spacing for the page
  • HaruPage::setCMYKFill — Set filling color for the page
  • HaruPage::setCMYKStroke — Set stroking color for the page
  • HaruPage::setDash — Set the dash pattern for the page
  • HaruPage::setFlatness — Set flatness for the page
  • HaruPage::setFontAndSize — Set font and fontsize for the page
  • HaruPage::setGrayFill — Set filling color for the page
  • HaruPage::setGrayStroke — Sets stroking color for the page
  • HaruPage::setHeight — Set height of the page
  • HaruPage::setHorizontalScaling — Set horizontal scaling for the page
  • HaruPage::setLineCap — Set the shape to be used at the ends of lines
  • HaruPage::setLineJoin — Set line join style for the page
  • HaruPage::setLineWidth — Set line width for the page
  • HaruPage::setMiterLimit — Set the current value of the miter limit of the page
  • HaruPage::setRGBFill — Set filling color for the page
  • HaruPage::setRGBStroke — Set stroking color for the page
  • HaruPage::setRotate — Set rotation angle of the page
  • HaruPage::setSize — Set size and direction of the page
  • HaruPage::setSlideShow — Set transition style for the page
  • HaruPage::setTextLeading — Set text leading (line spacing) for the page
  • HaruPage::setTextMatrix — Set the current text transformation matrix of the page
  • HaruPage::setTextRenderingMode — Set text rendering mode for the page
  • HaruPage::setTextRise — Set the current value of text rising
  • HaruPage::setWidth — Set width of the page
  • HaruPage::setWordSpace — Set word spacing for the page
  • HaruPage::showText — Print text at the current position of the page
  • HaruPage::showTextNextLine — Move the current position to the start of the next line and print the text
  • HaruPage::stroke — Paint current path
  • HaruPage::textOut — Print the text on the specified position
  • HaruPage::textRect — Print the text inside the specified region
HaruDoc::useKRFonts
HaruPage::arc
haru


Append an arc to the current path

HaruPage
HaruPage::beginText
HaruPage
PHP Manual

HaruPage::arc

(PECL haru >= 0.0.1)

HaruPage::arc — Append an arc to the current path

Açıklama

bool HaruPage::arc ( float $x , float $y , float $ray , float $ang1 , float $ang2 )

Appends an arc to the current path.

Değiştirgeler

x

Horizontal coordinate of the center.

y

Vertical coordinate of the center.

ray

The ray of the arc.

ang1

The angle of the beginning.

ang2

The angle of the end. Must be greater than ang1.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruPage
HaruPage::beginText
HaruPage


Begin a text object and set the current text position to (0,0)

HaruPage::arc
HaruPage::circle
HaruPage
PHP Manual

HaruPage::beginText

(PECL haru >= 0.0.1)

HaruPage::beginText — Begin a text object and set the current text position to (0,0)

Açıklama

bool HaruPage::beginText ( void )

Begins new text object and sets the current text position to (0,0).

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruPage::arc
HaruPage::circle
HaruPage


Append a circle to the current path

HaruPage::beginText
HaruPage::closePath
HaruPage
PHP Manual

HaruPage::circle

(PECL haru >= 0.0.1)

HaruPage::circle — Append a circle to the current path

Açıklama

bool HaruPage::circle ( float $x , float $y , float $ray )

Appends a circle to the current path.

Değiştirgeler

x

Horizontal coordinate of the center point.

y

Vertical coordinate of the center point.

ray

The ray of the circle.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruPage::beginText
HaruPage::closePath
HaruPage


Append a straight line from the current point to the start point of the path

HaruPage::circle
HaruPage::concat
HaruPage
PHP Manual

HaruPage::closePath

(PECL haru >= 0.0.1)

HaruPage::closePath — Append a straight line from the current point to the start point of the path

Açıklama

bool HaruPage::closePath ( void )

Appends a straight line from the current point to the start point of the path.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruPage::circle
HaruPage::concat
HaruPage


Concatenate current transformation matrix of the page and the specified matrix

HaruPage::closePath
HaruPage::createDestination
HaruPage
PHP Manual

HaruPage::concat

(PECL haru >= 0.0.1)

HaruPage::concat — Concatenate current transformation matrix of the page and the specified matrix

Açıklama

bool HaruPage::concat ( float $a , float $b , float $c , float $d , float $x , float $y )

Concatenates current transformation matrix of the page and the specified matrix.

Değiştirgeler

a

b

c

d

x

y

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruPage::closePath
HaruPage::createDestination
HaruPage


Create new HaruDestination instance

HaruPage::concat
HaruPage::createLinkAnnotation
HaruPage
PHP Manual

HaruPage::createDestination

(PECL haru >= 0.0.1)

HaruPage::createDestination — Create new HaruDestination instance

Açıklama

object HaruPage::createDestination ( void )

Create a new HaruDestination instance.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a new HaruDestination instance.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruPage::concat
HaruPage::createLinkAnnotation
HaruPage


Create new HaruAnnotation instance

HaruPage::createDestination
HaruPage::createTextAnnotation
HaruPage
PHP Manual

HaruPage::createLinkAnnotation

(PECL haru >= 0.0.1)

HaruPage::createLinkAnnotation — Create new HaruAnnotation instance

Açıklama

object HaruPage::createLinkAnnotation ( array $rectangle , object $destination )

Creates a new HaruAnnotation instance.

Değiştirgeler

rectangle

An array with 4 coordinates of the clickable area.

destination

Valid HaruDestination instance.

Dönen Değerler

Returns a new HaruAnnotation instance.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruPage::createDestination
HaruPage::createTextAnnotation
HaruPage


Create new HaruAnnotation instance

HaruPage::createLinkAnnotation
HaruPage::createURLAnnotation
HaruPage
PHP Manual

HaruPage::createTextAnnotation

(PECL haru >= 0.0.1)

HaruPage::createTextAnnotation — Create new HaruAnnotation instance

Açıklama

object HaruPage::createTextAnnotation ( array $rectangle , string $text [, object $encoder ] )

Creates a new HaruAnnotation instance.

Değiştirgeler

rectangle

An array with 4 coordinates of the annotation area.

text

The text to be displayed.

encoder

Optional HaruEncoder instance.

Dönen Değerler

Returns a new HaruAnnotation instance.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruPage::createLinkAnnotation
HaruPage::createURLAnnotation
HaruPage


Create and return new HaruAnnotation instance

HaruPage::createTextAnnotation
HaruPage::curveTo2
HaruPage
PHP Manual

HaruPage::createURLAnnotation

(PECL haru >= 0.0.1)

HaruPage::createURLAnnotation — Create and return new HaruAnnotation instance

Açıklama

object HaruPage::createURLAnnotation ( array $rectangle , string $url )

Creates a new HaruAnnotation instance.

Değiştirgeler

rectangle

An array with 4 coordinates of the clickable area.

url

The URL to open.

Dönen Değerler

Returns a new HaruAnnotation instance.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruPage::createTextAnnotation
HaruPage::curveTo2
HaruPage


Append a Bezier curve to the current path

HaruPage::createURLAnnotation
HaruPage::curveTo3
HaruPage
PHP Manual

HaruPage::curveTo2

(PECL haru >= 0.0.1)

HaruPage::curveTo2 — Append a Bezier curve to the current path

Açıklama

bool HaruPage::curveTo2 ( float $x2 , float $y2 , float $x3 , float $y3 )

Appends a Bezier curve to the current path. The current point and the point (x2, y2) are used as the control points for the Bezier curve and current point is moved to the point (x3, y3).

Değiştirgeler

x2

A Bezier curve control point.

y2

A Bezier curve control point.

x3

The current point moves here.

x3

The current point moves here.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruPage::createURLAnnotation
HaruPage::curveTo3
HaruPage


Append a Bezier curve to the current path

HaruPage::curveTo2
HaruPage::curveTo
HaruPage
PHP Manual

HaruPage::curveTo3

(PECL haru >= 0.0.1)

HaruPage::curveTo3 — Append a Bezier curve to the current path

Açıklama

bool HaruPage::curveTo3 ( float $x1 , float $y1 , float $x3 , float $y3 )

Appends a Bezier curve to the current path. The point (x1, y1) and the point (x3, y3) are used as the control points for a Bezier curve and current point is moved to the point (x3, y3).

Değiştirgeler

x1

A Bezier curve control point.

y1

A Bezier curve control point.

x3

The current point moves here.

x3

The current point moves here.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruPage::curveTo2
HaruPage::curveTo
HaruPage


Append a Bezier curve to the current path

HaruPage::curveTo3
HaruPage::drawImage
HaruPage
PHP Manual

HaruPage::curveTo

(PECL haru >= 0.0.1)

HaruPage::curveTo — Append a Bezier curve to the current path

Açıklama

bool HaruPage::curveTo ( float $x1 , float $y1 , float $x2 , float $y2 , float $x3 , float $y3 )

Append a Bezier curve to the current path. The point (x1, y1) and the point (x2, y2) are used as the control points for a Bezier curve and current point is moved to the point (x3, y3).

Değiştirgeler

x1

A Bezier curve control point.

y1

A Bezier curve control point.

x2

A Bezier curve control point.

y2

A Bezier curve control point.

x3

The current point moves here.

x3

The current point moves here.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruPage::curveTo3
HaruPage::drawImage
HaruPage


Show image at the page

HaruPage::curveTo
HaruPage::ellipse
HaruPage
PHP Manual

HaruPage::drawImage

(PECL haru >= 0.0.1)

HaruPage::drawImage — Show image at the page

Açıklama

bool HaruPage::drawImage ( object $image , float $x , float $y , float $width , float $height )

Show image at the page.

Değiştirgeler

image

Valid HaruImage instance.

x

The left border of the area where the image is displayed.

y

The lower border of the area where the image is displayed.

width

The width of the image area.

height

The height of the image area.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruPage::curveTo
HaruPage::ellipse
HaruPage


Append an ellipse to the current path

HaruPage::drawImage
HaruPage::endPath
HaruPage
PHP Manual

HaruPage::ellipse

(PECL haru >= 0.0.1)

HaruPage::ellipse — Append an ellipse to the current path

Açıklama

bool HaruPage::ellipse ( float $x , float $y , float $xray , float $yray )

Appends an ellipse to the current path.

Değiştirgeler

x

Horizontal coordinate of the center.

y

Vertical coordinate of the center.

xray

The ray of the ellipse in the x direction.

yray

The ray of the ellipse in the y direction.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruPage::drawImage
HaruPage::endPath
HaruPage


End current path object without filling and painting operations

HaruPage::ellipse
HaruPage::endText
HaruPage
PHP Manual

HaruPage::endPath

(PECL haru >= 0.0.1)

HaruPage::endPath — End current path object without filling and painting operations

Açıklama

bool HaruPage::endPath ( void )

Ends current path object without performing filling and painting operations.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruPage::ellipse
HaruPage::endText
HaruPage


End current text object

HaruPage::endPath
HaruPage::eofill
HaruPage
PHP Manual

HaruPage::endText

(PECL haru >= 0.0.1)

HaruPage::endText — End current text object

Açıklama

bool HaruPage::endText ( void )

Finalizes current text object.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruPage::endPath
HaruPage::eofill
HaruPage


Fill current path using even-odd rule

HaruPage::endText
HaruPage::eoFillStroke
HaruPage
PHP Manual

HaruPage::eofill

(PECL haru >= 0.0.1)

HaruPage::eofill — Fill current path using even-odd rule

Açıklama

bool HaruPage::eofill ( void )

Fills current path using even-odd rule.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruPage::endText
HaruPage::eoFillStroke
HaruPage


Fill current path using even-odd rule, then paint the path

HaruPage::eofill
HaruPage::fill
HaruPage
PHP Manual

HaruPage::eoFillStroke

(PECL haru >= 0.0.1)

HaruPage::eoFillStroke — Fill current path using even-odd rule, then paint the path

Açıklama

bool HaruPage::eoFillStroke ([ bool $close_path = false ] )

Fills current path using even-odd rule, then paints the path.

Değiştirgeler

close_path

Optional parameter. When set to TRUE, the function closes the current path. Default to FALSE.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruPage::eofill
HaruPage::fill
HaruPage


Fill current path using nonzero winding number rule

HaruPage::eoFillStroke
HaruPage::fillStroke
HaruPage
PHP Manual

HaruPage::fill

(PECL haru >= 0.0.1)

HaruPage::fill — Fill current path using nonzero winding number rule

Açıklama

bool HaruPage::fill ( void )

Fills current path using nonzero winding number rule.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruPage::eoFillStroke
HaruPage::fillStroke
HaruPage


Fill current path using nonzero winding number rule, then paint the path

HaruPage::fill
HaruPage::getCharSpace
HaruPage
PHP Manual

HaruPage::fillStroke

(PECL haru >= 0.0.1)

HaruPage::fillStroke — Fill current path using nonzero winding number rule, then paint the path

Açıklama

bool HaruPage::fillStroke ([ bool $close_path = false ] )

Fills current path using nonzero winding number rule, then paints the path.

Değiştirgeler

close_path

Optional parameter. When set to TRUE, the function closes the current path. Default to FALSE.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruPage::fill
HaruPage::getCharSpace
HaruPage


Get the current value of character spacing

HaruPage::fillStroke
HaruPage::getCMYKFill
HaruPage
PHP Manual

HaruPage::getCharSpace

(PECL haru >= 0.0.1)

HaruPage::getCharSpace — Get the current value of character spacing

Açıklama

float HaruPage::getCharSpace ( void )

Get the current value of character spacing.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the current value of character spacing.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruPage::fillStroke
HaruPage::getCMYKFill
HaruPage


Get the current filling color

HaruPage::getCharSpace
HaruPage::getCMYKStroke
HaruPage
PHP Manual

HaruPage::getCMYKFill

(PECL haru >= 0.0.1)

HaruPage::getCMYKFill — Get the current filling color

Açıklama

array HaruPage::getCMYKFill ( void )

Returns the current filling color.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the current filling color as an array with 4 elements ("c", "m", "y" and "k").

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruPage::getCharSpace
HaruPage::getCMYKStroke
HaruPage


Get the current stroking color

HaruPage::getCMYKFill
HaruPage::getCurrentFont
HaruPage
PHP Manual

HaruPage::getCMYKStroke

(PECL haru >= 0.0.1)

HaruPage::getCMYKStroke — Get the current stroking color

Açıklama

array HaruPage::getCMYKStroke ( void )

Get the current stroking color.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the current stroking color as an array with 4 elements ("c", "m", "y" and "k").

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruPage::getCMYKFill
HaruPage::getCurrentFont
HaruPage


Get the currently used font

HaruPage::getCMYKStroke
HaruPage::getCurrentFontSize
HaruPage
PHP Manual

HaruPage::getCurrentFont

(PECL haru >= 0.0.1)

HaruPage::getCurrentFont — Get the currently used font

Açıklama

object HaruPage::getCurrentFont ( void )

Get the currently used font.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the currently used font as an instance of HaruFont.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruPage::getCMYKStroke
HaruPage::getCurrentFontSize
HaruPage


Get the current font size

HaruPage::getCurrentFont
HaruPage::getCurrentPos
HaruPage
PHP Manual

HaruPage::getCurrentFontSize

(PECL haru >= 0.0.1)

HaruPage::getCurrentFontSize — Get the current font size

Açıklama

float HaruPage::getCurrentFontSize ( void )

Get the current font size.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the current font size.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruPage::getCurrentFont
HaruPage::getCurrentPos
HaruPage


Get the current position for path painting

HaruPage::getCurrentFontSize
HaruPage::getCurrentTextPos
HaruPage
PHP Manual

HaruPage::getCurrentPos

(PECL haru >= 0.0.1)

HaruPage::getCurrentPos — Get the current position for path painting

Açıklama

array HaruPage::getCurrentPos ( void )

Get the current position for path painting.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the current position for path painting as an array of with two elements - "x" and "y".

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruPage::getCurrentFontSize
HaruPage::getCurrentTextPos
HaruPage


Get the current position for text printing

HaruPage::getCurrentPos
HaruPage::getDash
HaruPage
PHP Manual

HaruPage::getCurrentTextPos

(PECL haru >= 0.0.1)

HaruPage::getCurrentTextPos — Get the current position for text printing

Açıklama

array HaruPage::getCurrentTextPos ( void )

Get the current position for text printing.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the current position for text printing as an array with 2 elements - "x" and "y".

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruPage::getCurrentPos
HaruPage::getDash
HaruPage


Get the current dash pattern

HaruPage::getCurrentTextPos
HaruPage::getFillingColorSpace
HaruPage
PHP Manual

HaruPage::getDash

(PECL haru >= 0.0.1)

HaruPage::getDash — Get the current dash pattern

Açıklama

array HaruPage::getDash ( void )

Get the current dash pattern. See HaruPage::setDash() for more information on dash patterns.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the current dash pattern as an array of two elements - "pattern" and "phase" or FALSE if dash pattern was not set.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::setDash() - Set the dash pattern for the page

HaruPage::getCurrentTextPos
HaruPage::getFillingColorSpace
HaruPage


Get the current filling color space

HaruPage::getDash
HaruPage::getFlatness
HaruPage
PHP Manual

HaruPage::getFillingColorSpace

(PECL haru >= 0.0.1)

HaruPage::getFillingColorSpace — Get the current filling color space

Açıklama

int HaruPage::getFillingColorSpace ( void )

Get the current filling color space.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the current filling color space. The result value is one of the following:

  • HaruDoc::CS_DEVICE_GRAY
  • HaruDoc::CS_DEVICE_RGB
  • HaruDoc::CS_DEVICE_CMYK
  • HaruDoc::CS_CAL_GRAY
  • HaruDoc::CS_CAL_RGB
  • HaruDoc::CS_LAB
  • HaruDoc::CS_ICC_BASED
  • HaruDoc::CS_SEPARATION
  • HaruDoc::CS_DEVICE_N
  • HaruDoc::CS_INDEXED
  • HaruDoc::CS_PATTERN

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruPage::getDash
HaruPage::getFlatness
HaruPage


Get the flatness of the page

HaruPage::getFillingColorSpace
HaruPage::getGMode
HaruPage
PHP Manual

HaruPage::getFlatness

(PECL haru >= 0.0.1)

HaruPage::getFlatness — Get the flatness of the page

Açıklama

float HaruPage::getFlatness ( void )

Get the flatness of the page.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the flatness of the page.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::setFlatness() - Set flatness for the page

HaruPage::getFillingColorSpace
HaruPage::getGMode
HaruPage


Get the current graphics mode

HaruPage::getFlatness
HaruPage::getGrayFill
HaruPage
PHP Manual

HaruPage::getGMode

(PECL haru >= 0.0.1)

HaruPage::getGMode — Get the current graphics mode

Açıklama

int HaruPage::getGMode ( void )

Get the current graphics mode.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the current graphics mode. The result value is one of the following:

  • HaruPage::GMODE_PAGE_DESCRIPTION
  • HaruPage::GMODE_TEXT_OBJECT
  • HaruPage::GMODE_PATH_OBJECT
  • HaruPage::GMODE_CLIPPING_PATH
  • HaruPage::GMODE_SHADING
  • HaruPage::GMODE_INLINE_IMAGE
  • HaruPage::GMODE_EXTERNAL_OBJECT

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruPage::getFlatness
HaruPage::getGrayFill
HaruPage


Get the current filling color

HaruPage::getGMode
HaruPage::getGrayStroke
HaruPage
PHP Manual

HaruPage::getGrayFill

(PECL haru >= 0.0.1)

HaruPage::getGrayFill — Get the current filling color

Açıklama

float HaruPage::getGrayFill ( void )

Get the current filling color.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the current filling color.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::setGrayFill() - Set filling color for the page

HaruPage::getGMode
HaruPage::getGrayStroke
HaruPage


Get the current stroking color

HaruPage::getGrayFill
HaruPage::getHeight
HaruPage
PHP Manual

HaruPage::getGrayStroke

(PECL haru >= 0.0.1)

HaruPage::getGrayStroke — Get the current stroking color

Açıklama

float HaruPage::getGrayStroke ( void )

Get the current stroking color.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the current stroking color.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::setGrayStroke() - Sets stroking color for the page

HaruPage::getGrayFill
HaruPage::getHeight
HaruPage


Get the height of the page

HaruPage::getGrayStroke
HaruPage::getHorizontalScaling
HaruPage
PHP Manual

HaruPage::getHeight

(PECL haru >= 0.0.1)

HaruPage::getHeight — Get the height of the page

Açıklama

float HaruPage::getHeight ( void )

Get the height of the page.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the height of the page.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::setHeight() - Set height of the page

HaruPage::getGrayStroke
HaruPage::getHorizontalScaling
HaruPage


Get the current value of horizontal scaling

HaruPage::getHeight
HaruPage::getLineCap
HaruPage
PHP Manual

HaruPage::getHorizontalScaling

(PECL haru >= 0.0.1)

HaruPage::getHorizontalScaling — Get the current value of horizontal scaling

Açıklama

float HaruPage::getHorizontalScaling ( void )

Get the current value of the horizontal scaling.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the current value of horizontal scaling.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::setHorizontalScaling() - Set horizontal scaling for the page

HaruPage::getHeight
HaruPage::getLineCap
HaruPage


Get the current line cap style

HaruPage::getHorizontalScaling
HaruPage::getLineJoin
HaruPage
PHP Manual

HaruPage::getLineCap

(PECL haru >= 0.0.1)

HaruPage::getLineCap — Get the current line cap style

Açıklama

int HaruPage::getLineCap ( void )

Get the current line cap style.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the current line cap style. The result value is one of the following:

  • HaruPage::BUTT_END - the line is squared off at the endpoint of the path.
  • HaruPage::ROUND_END - the end of the line becomes a semicircle with center in the end point of the path.
  • HaruPage::PROJECTING_SCUARE_END - the line continues to the point that exceeds half of the stroke width the end point.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::setLineCap() - Set the shape to be used at the ends of lines

HaruPage::getHorizontalScaling
HaruPage::getLineJoin
HaruPage


Get the current line join style

HaruPage::getLineCap
HaruPage::getLineWidth
HaruPage
PHP Manual

HaruPage::getLineJoin

(PECL haru >= 0.0.1)

HaruPage::getLineJoin — Get the current line join style

Açıklama

int HaruPage::getLineJoin ( void )

Get the current line join style.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the current line join style. The result value is one of the following:

  • HaruPage::MITER_JOIN
  • HaruPage::ROUND_JOIN
  • HaruPage::BEVEL_JOIN

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::setLineJoin() - Set line join style for the page

HaruPage::getLineCap
HaruPage::getLineWidth
HaruPage


Get the current line width

HaruPage::getLineJoin
HaruPage::getMiterLimit
HaruPage
PHP Manual

HaruPage::getLineWidth

(PECL haru >= 0.0.1)

HaruPage::getLineWidth — Get the current line width

Açıklama

float HaruPage::getLineWidth ( void )

Get the current line width.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the current line width.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::setLineWidth() - Set line width for the page

HaruPage::getLineJoin
HaruPage::getMiterLimit
HaruPage


Get the value of miter limit

HaruPage::getLineWidth
HaruPage::getRGBFill
HaruPage
PHP Manual

HaruPage::getMiterLimit

(PECL haru >= 0.0.1)

HaruPage::getMiterLimit — Get the value of miter limit

Açıklama

float HaruPage::getMiterLimit ( void )

Get the value of the miter limit.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the value of the miter limit.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::setMiterLimit() - Set the current value of the miter limit of the page

HaruPage::getLineWidth
HaruPage::getRGBFill
HaruPage


Get the current filling color

HaruPage::getMiterLimit
HaruPage::getRGBStroke
HaruPage
PHP Manual

HaruPage::getRGBFill

(PECL haru >= 0.0.1)

HaruPage::getRGBFill — Get the current filling color

Açıklama

array HaruPage::getRGBFill ( void )

Get the current filling color.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the current filling color as an array with 3 elements: "r", "g" and "b".

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::setRGBFill() - Set filling color for the page

HaruPage::getMiterLimit
HaruPage::getRGBStroke
HaruPage


Get the current stroking color

HaruPage::getRGBFill
HaruPage::getStrokingColorSpace
HaruPage
PHP Manual

HaruPage::getRGBStroke

(PECL haru >= 0.0.1)

HaruPage::getRGBStroke — Get the current stroking color

Açıklama

array HaruPage::getRGBStroke ( void )

Get the current stroking color.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the current stroking color.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::setRGBStroke() - Set stroking color for the page

HaruPage::getRGBFill
HaruPage::getStrokingColorSpace
HaruPage


Get the current stroking color space

HaruPage::getRGBStroke
HaruPage::getTextLeading
HaruPage
PHP Manual

HaruPage::getStrokingColorSpace

(PECL haru >= 0.0.1)

HaruPage::getStrokingColorSpace — Get the current stroking color space

Açıklama

int HaruPage::getStrokingColorSpace ( void )

Get the current stroking color space.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the current stroking color space. The list of return values is the same as for HaruPage::getFillingColorSpace()

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::getFillingColorSpace() - Get the current filling color space

HaruPage::getRGBStroke
HaruPage::getTextLeading
HaruPage


Get the current value of line spacing

HaruPage::getStrokingColorSpace
HaruPage::getTextMatrix
HaruPage
PHP Manual

HaruPage::getTextLeading

(PECL haru >= 0.0.1)

HaruPage::getTextLeading — Get the current value of line spacing

Açıklama

float HaruPage::getTextLeading ( void )

Get the current value of line spacing.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the current value of line spacing.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::setTextLeading() - Set text leading (line spacing) for the page

HaruPage::getStrokingColorSpace
HaruPage::getTextMatrix
HaruPage


Get the current text transformation matrix of the page

HaruPage::getTextLeading
HaruPage::getTextRenderingMode
HaruPage
PHP Manual

HaruPage::getTextMatrix

(PECL haru >= 0.0.1)

HaruPage::getTextMatrix — Get the current text transformation matrix of the page

Açıklama

array HaruPage::getTextMatrix ( void )

Get the current text transformation matrix of the page.

Dönen Değerler

Returns the current text transformation matrix of the page as an array of 6 elements: "a", "b", "c", "d", "x" and "y".

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::setTextMatrix() - Set the current text transformation matrix of the page

HaruPage::getTextLeading
HaruPage::getTextRenderingMode
HaruPage


Get the current text rendering mode

HaruPage::getTextMatrix
HaruPage::getTextRise
HaruPage
PHP Manual

HaruPage::getTextRenderingMode

(PECL haru >= 0.0.1)

HaruPage::getTextRenderingMode — Get the current text rendering mode

Açıklama

int HaruPage::getTextRenderingMode ( void )

Get the current text rendering mode.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the current text rendering mode. The result value is one of the following:

  • HaruPage::FILL
  • HaruPage::STROKE
  • HaruPage::FILL_THEN_STROKE
  • HaruPage::INVISIBLE
  • HaruPage::FILL_CLIPPING
  • HaruPage::STROKE_CLIPPING
  • HaruPage::FILL_STROKE_CLIPPING
  • HaruPage::CLIPPING

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::setTextRenderingMode() - Set text rendering mode for the page

HaruPage::getTextMatrix
HaruPage::getTextRise
HaruPage


Get the current value of text rising

HaruPage::getTextRenderingMode
HaruPage::getTextWidth
HaruPage
PHP Manual

HaruPage::getTextRise

(PECL haru >= 0.0.1)

HaruPage::getTextRise — Get the current value of text rising

Açıklama

float HaruPage::getTextRise ( void )

Get the current value of text rising.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the current value of text rising.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::setTextRise() - Set the current value of text rising

HaruPage::getTextRenderingMode
HaruPage::getTextWidth
HaruPage


Get the width of the text using current fontsize, character spacing and word spacing

HaruPage::getTextRise
HaruPage::getTransMatrix
HaruPage
PHP Manual

HaruPage::getTextWidth

(PECL haru >= 0.0.1)

HaruPage::getTextWidth — Get the width of the text using current fontsize, character spacing and word spacing

Açıklama

float HaruPage::getTextWidth ( string $text )

Get the width of the text using current fontsize, character spacing and word spacing

Değiştirgeler

text

The text to measure.

Dönen Değerler

Returns the width of the text using current fontsize, character spacing and word spacing.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::measureText() - Calculate the byte length of characters which can be included on one line of the specified width

HaruPage::getTextRise
HaruPage::getTransMatrix
HaruPage


Get the current transformation matrix of the page

HaruPage::getTextWidth
HaruPage::getWidth
HaruPage
PHP Manual

HaruPage::getTransMatrix

(PECL haru >= 0.0.1)

HaruPage::getTransMatrix — Get the current transformation matrix of the page

Açıklama

array HaruPage::getTransMatrix ( void )

Get the current transformation matrix of the page.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the current transformation matrix of the page as an array of 6 elements: "a", "b", "c", "d", "x" and "y".

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::concat() - Concatenate current transformation matrix of the page and the specified matrix

HaruPage::getTextWidth
HaruPage::getWidth
HaruPage


Get the width of the page

HaruPage::getTransMatrix
HaruPage::getWordSpace
HaruPage
PHP Manual

HaruPage::getWidth

(PECL haru >= 0.0.1)

HaruPage::getWidth — Get the width of the page

Açıklama

float HaruPage::getWidth ( void )

Get the width of the page.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the width of the page.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::setWidth() - Set width of the page

HaruPage::getTransMatrix
HaruPage::getWordSpace
HaruPage


Get the current value of word spacing

HaruPage::getWidth
HaruPage::lineTo
HaruPage
PHP Manual

HaruPage::getWordSpace

(PECL haru >= 0.0.1)

HaruPage::getWordSpace — Get the current value of word spacing

Açıklama

float HaruPage::getWordSpace ( void )

Get the current value of word spacing.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the current value of word spacing.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::setWordSpace() - Set word spacing for the page

HaruPage::getWidth
HaruPage::lineTo
HaruPage


Draw a line from the current point to the specified point

HaruPage::getWordSpace
HaruPage::measureText
HaruPage
PHP Manual

HaruPage::lineTo

(PECL haru >= 0.0.1)

HaruPage::lineTo — Draw a line from the current point to the specified point

Açıklama

bool HaruPage::lineTo ( float $x , float $y )

Draws a line from the current point to the specified point.

Değiştirgeler

x

y

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::curveTo() - Append a Bezier curve to the current path
  • HaruPage::curveTo2() - Append a Bezier curve to the current path
  • HaruPage::curveTo3() - Append a Bezier curve to the current path

HaruPage::getWordSpace
HaruPage::measureText
HaruPage


Calculate the byte length of characters which can be included on one line of the specified width

HaruPage::lineTo
HaruPage::moveTextPos
HaruPage
PHP Manual

HaruPage::measureText

(PECL haru >= 0.0.1)

HaruPage::measureText — Calculate the byte length of characters which can be included on one line of the specified width

Açıklama

int HaruPage::measureText ( string $text , float $width [, bool $wordwrap = false ] )

Get the byte length of characters which can be included on one line of the specified width.

Değiştirgeler

text

The text to measure.

width

The width of the line.

wordwrap

When this parameter is set to TRUE the function "emulates" word wrapping by stopping after the last full word (delimited by whitespace) that can fit on the line.

Dönen Değerler

Returns the byte length of characters which can be included within the specified width. For single-byte encodings, this is equal to the number of characters. For multi-byte encodings, this is not necessarily the case.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruFont::measureText() - Calculate the number of characters which can be included within the specified width

HaruPage::lineTo
HaruPage::moveTextPos
HaruPage


Move text position to the specified offset

HaruPage::measureText
HaruPage::moveTo
HaruPage
PHP Manual

HaruPage::moveTextPos

(PECL haru >= 0.0.1)

HaruPage::moveTextPos — Move text position to the specified offset

Açıklama

bool HaruPage::moveTextPos ( float $x , float $y [, bool $set_leading = false ] )

Moves text position to the specified offset. If the start position of the current line is (x1, y1), the start of the next line is (x1 + x, y1 + y).

Değiştirgeler

x

The specified text position offset.

y

The specified text position offset.

set_leading

If set to TRUE, the function sets the text leading to -y.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::moveToNextLine() - Move text position to the start of the next line

HaruPage::measureText
HaruPage::moveTo
HaruPage


Set starting point for new drawing path

HaruPage::moveTextPos
HaruPage::moveToNextLine
HaruPage
PHP Manual

HaruPage::moveTo

(PECL haru >= 0.0.1)

HaruPage::moveTo — Set starting point for new drawing path

Açıklama

bool HaruPage::moveTo ( float $x , float $y )

Defines starting point for new drawing path.

Değiştirgeler

x

A new starting point coordinate.

y

A new starting point coordinate.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruPage::moveTextPos
HaruPage::moveToNextLine
HaruPage


Move text position to the start of the next line

HaruPage::moveTo
HaruPage::rectangle
HaruPage
PHP Manual

HaruPage::moveToNextLine

(PECL haru >= 0.0.1)

HaruPage::moveToNextLine — Move text position to the start of the next line

Açıklama

bool HaruPage::moveToNextLine ( void )

Moves text position to the start of the next line.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::moveTextPos() - Move text position to the specified offset

HaruPage::moveTo
HaruPage::rectangle
HaruPage


Append a rectangle to the current path

HaruPage::moveToNextLine
HaruPage::setCharSpace
HaruPage
PHP Manual

HaruPage::rectangle

(PECL haru >= 0.0.1)

HaruPage::rectangle — Append a rectangle to the current path

Açıklama

bool HaruPage::rectangle ( float $x , float $y , float $width , float $height )

Appends a rectangle to the current drawing path.

Değiştirgeler

x

The left border of the rectangle.

y

The lower border of the rectangle.

width

The width of the rectangle.

height

The height of the rectangle.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruPage::moveToNextLine
HaruPage::setCharSpace
HaruPage


Set character spacing for the page

HaruPage::rectangle
HaruPage::setCMYKFill
HaruPage
PHP Manual

HaruPage::setCharSpace

(PECL haru >= 0.0.1)

HaruPage::setCharSpace — Set character spacing for the page

Açıklama

bool HaruPage::setCharSpace ( float $char_space )

Defines character spacing for the page.

Değiştirgeler

char_space

The new character spacing for the page.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::getCharSpace() - Get the current value of character spacing

HaruPage::rectangle
HaruPage::setCMYKFill
HaruPage


Set filling color for the page

HaruPage::setCharSpace
HaruPage::setCMYKStroke
HaruPage
PHP Manual

HaruPage::setCMYKFill

(PECL haru >= 0.0.1)

HaruPage::setCMYKFill — Set filling color for the page

Açıklama

bool HaruPage::setCMYKFill ( float $c , float $m , float $y , float $k )

Defines filling color for the page.

Değiştirgeler

c

m

y

k

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::getCMYKFill() - Get the current filling color

HaruPage::setCharSpace
HaruPage::setCMYKStroke
HaruPage


Set stroking color for the page

HaruPage::setCMYKFill
HaruPage::setDash
HaruPage
PHP Manual

HaruPage::setCMYKStroke

(PECL haru >= 0.0.1)

HaruPage::setCMYKStroke — Set stroking color for the page

Açıklama

bool HaruPage::setCMYKStroke ( float $c , float $m , float $y , float $k )

Defines stroking color for the page.

Değiştirgeler

c

m

y

k

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::getCMYKStroke() - Get the current stroking color

HaruPage::setCMYKFill
HaruPage::setDash
HaruPage


Set the dash pattern for the page

HaruPage::setCMYKStroke
HaruPage::setFlatness
HaruPage
PHP Manual

HaruPage::setDash

(PECL haru >= 0.0.1)

HaruPage::setDash — Set the dash pattern for the page

Açıklama

bool HaruPage::setDash ( array $pattern , int $phase )

Defines the dash pattern for the page.

Değiştirgeler

pattern

An array (8 elements max) which contains a pattern of dashes and gaps used for lines on the page.

phase

The phase on which the pattern begins.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::getDash() - Get the current dash pattern

HaruPage::setCMYKStroke
HaruPage::setFlatness
HaruPage


Set flatness for the page

HaruPage::setDash
HaruPage::setFontAndSize
HaruPage
PHP Manual

HaruPage::setFlatness

(PECL haru >= 0.0.1)

HaruPage::setFlatness — Set flatness for the page

Açıklama

bool HaruPage::setFlatness ( float $flatness )

Defines flatness for the page.

Değiştirgeler

flatness

The defined flatness for the page.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::getFlatness() - Get the flatness of the page

HaruPage::setDash
HaruPage::setFontAndSize
HaruPage


Set font and fontsize for the page

HaruPage::setFlatness
HaruPage::setGrayFill
HaruPage
PHP Manual

HaruPage::setFontAndSize

(PECL haru >= 0.0.1)

HaruPage::setFontAndSize — Set font and fontsize for the page

Açıklama

bool HaruPage::setFontAndSize ( object $font , float $size )

Defines current font and its size for the page.

Değiştirgeler

font

A valid HaruFont instance.

size

The size of the font.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruDoc::getFont() - Get HaruFont instance

HaruPage::setFlatness
HaruPage::setGrayFill
HaruPage


Set filling color for the page

HaruPage::setFontAndSize
HaruPage::setGrayStroke
HaruPage
PHP Manual

HaruPage::setGrayFill

(PECL haru >= 0.0.1)

HaruPage::setGrayFill — Set filling color for the page

Açıklama

bool HaruPage::setGrayFill ( float $value )

Defines filling color for the page.

Değiştirgeler

value

The value of gray level between 0 and 1.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::getGrayFill() - Get the current filling color

HaruPage::setFontAndSize
HaruPage::setGrayStroke
HaruPage


Sets stroking color for the page

HaruPage::setGrayFill
HaruPage::setHeight
HaruPage
PHP Manual

HaruPage::setGrayStroke

(PECL haru >= 0.0.1)

HaruPage::setGrayStroke — Sets stroking color for the page

Açıklama

bool HaruPage::setGrayStroke ( float $value )

Defines stroking color for the page.

Değiştirgeler

value

The value of gray level between 0 and 1.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::getGrayStroke() - Get the current stroking color

HaruPage::setGrayFill
HaruPage::setHeight
HaruPage


Set height of the page

HaruPage::setGrayStroke
HaruPage::setHorizontalScaling
HaruPage
PHP Manual

HaruPage::setHeight

(PECL haru >= 0.0.1)

HaruPage::setHeight — Set height of the page

Açıklama

bool HaruPage::setHeight ( float $height )

Defines height of the page.

Değiştirgeler

height

The defined height for the page.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::getHeight() - Get the height of the page

HaruPage::setGrayStroke
HaruPage::setHorizontalScaling
HaruPage


Set horizontal scaling for the page

HaruPage::setHeight
HaruPage::setLineCap
HaruPage
PHP Manual

HaruPage::setHorizontalScaling

(PECL haru >= 0.0.1)

HaruPage::setHorizontalScaling — Set horizontal scaling for the page

Açıklama

bool HaruPage::setHorizontalScaling ( float $scaling )

Set the horizontal scaling for the page.

Değiştirgeler

scaling

The horizontal scaling for text showing on the page. The initial value is 100.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::getHorizontalScaling() - Get the current value of horizontal scaling

HaruPage::setHeight
HaruPage::setLineCap
HaruPage


Set the shape to be used at the ends of lines

HaruPage::setHorizontalScaling
HaruPage::setLineJoin
HaruPage
PHP Manual

HaruPage::setLineCap

(PECL haru >= 0.0.1)

HaruPage::setLineCap — Set the shape to be used at the ends of lines

Açıklama

bool HaruPage::setLineCap ( int $cap )

Defines the shape to be used at the ends of lines.

Değiştirgeler

cap

Must be one of the following values:

  • HaruPage::BUTT_END - the line is squared off at the endpoint of the path.
  • HaruPage::ROUND_END - the end of the line becomes a semicircle with center in the end point of the path.
  • HaruPage::PROJECTING_SCUARE_END - the line continues to the point that exceeds half of the stroke width the end point.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::getLineCap() - Get the current line cap style

HaruPage::setHorizontalScaling
HaruPage::setLineJoin
HaruPage


Set line join style for the page

HaruPage::setLineCap
HaruPage::setLineWidth
HaruPage
PHP Manual

HaruPage::setLineJoin

(PECL haru >= 0.0.1)

HaruPage::setLineJoin — Set line join style for the page

Açıklama

bool HaruPage::setLineJoin ( int $join )

Defines line join style for the page.

Değiştirgeler

join

Must be one of the following values:

  • HaruPage::MITER_JOIN
  • HaruPage::ROUND_JOIN
  • HaruPage::BEVEL_JOIN

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::getLineJoin() - Get the current line join style

HaruPage::setLineCap
HaruPage::setLineWidth
HaruPage


Set line width for the page

HaruPage::setLineJoin
HaruPage::setMiterLimit
HaruPage
PHP Manual

HaruPage::setLineWidth

(PECL haru >= 0.0.1)

HaruPage::setLineWidth — Set line width for the page

Açıklama

bool HaruPage::setLineWidth ( float $width )

Defines line width for the page.

Değiştirgeler

width

The defined line width for the page.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::getLineWidth() - Get the current line width

HaruPage::setLineJoin
HaruPage::setMiterLimit
HaruPage


Set the current value of the miter limit of the page

HaruPage::setLineWidth
HaruPage::setRGBFill
HaruPage
PHP Manual

HaruPage::setMiterLimit

(PECL haru >= 0.0.1)

HaruPage::setMiterLimit — Set the current value of the miter limit of the page

Açıklama

bool HaruPage::setMiterLimit ( float $limit )

Set the current value of the miter limit of the page.

Değiştirgeler

limit

Defines the current value of the miter limit of the page.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::getMiterLimit() - Get the value of miter limit

HaruPage::setLineWidth
HaruPage::setRGBFill
HaruPage


Set filling color for the page

HaruPage::setMiterLimit
HaruPage::setRGBStroke
HaruPage
PHP Manual

HaruPage::setRGBFill

(PECL haru >= 0.0.1)

HaruPage::setRGBFill — Set filling color for the page

Açıklama

bool HaruPage::setRGBFill ( float $r , float $g , float $b )

Defines filling color for the page. All values must be between 0 and 1.

Değiştirgeler

r

g

b

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::getRGBFill() - Get the current filling color

HaruPage::setMiterLimit
HaruPage::setRGBStroke
HaruPage


Set stroking color for the page

HaruPage::setRGBFill
HaruPage::setRotate
HaruPage
PHP Manual

HaruPage::setRGBStroke

(PECL haru >= 0.0.1)

HaruPage::setRGBStroke — Set stroking color for the page

Açıklama

bool HaruPage::setRGBStroke ( float $r , float $g , float $b )

Defines stroking color for the page. All values must be between 0 and 1.

Değiştirgeler

r

g

b

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::getRGBStroke() - Get the current stroking color

HaruPage::setRGBFill
HaruPage::setRotate
HaruPage


Set rotation angle of the page

HaruPage::setRGBStroke
HaruPage::setSize
HaruPage
PHP Manual

HaruPage::setRotate

(PECL haru >= 0.0.1)

HaruPage::setRotate — Set rotation angle of the page

Açıklama

bool HaruPage::setRotate ( int $angle )

Defines rotation angle of the page.

Değiştirgeler

angle

Must be a multiple of 90 degrees.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruPage::setRGBStroke
HaruPage::setSize
HaruPage


Set size and direction of the page

HaruPage::setRotate
HaruPage::setSlideShow
HaruPage
PHP Manual

HaruPage::setSize

(PECL haru >= 0.0.1)

HaruPage::setSize — Set size and direction of the page

Açıklama

bool HaruPage::setSize ( int $size , int $direction )

Changes size and direction of the page to a predefined format.

Değiştirgeler

size

Must be one of the following values:

  • HaruPage::SIZE_LETTER
  • HaruPage::SIZE_LEGAL
  • HaruPage::SIZE_A3
  • HaruPage::SIZE_A4
  • HaruPage::SIZE_A5
  • HaruPage::SIZE_B4
  • HaruPage::SIZE_B5
  • HaruPage::SIZE_EXECUTIVE
  • HaruPage::SIZE_US4x6
  • HaruPage::SIZE_US4x8
  • HaruPage::SIZE_US5x7
  • HaruPage::SIZE_COMM10

direction

Must be one of the following values:

  • HaruPage::PORTRAIT
  • HaruPage::LANDSCAPE

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::setWidth() - Set width of the page
  • HaruPage::setHeight() - Set height of the page

HaruPage::setRotate
HaruPage::setSlideShow
HaruPage


Set transition style for the page

HaruPage::setSize
HaruPage::setTextLeading
HaruPage
PHP Manual

HaruPage::setSlideShow

(PECL haru >= 0.0.1)

HaruPage::setSlideShow — Set transition style for the page

Açıklama

bool HaruPage::setSlideShow ( int $type , float $disp_time , float $trans_time )

Defines transition style for the page.

Değiştirgeler

type

Must be one of the following values:

  • HaruPage::TS_WIPE_RIGHT
  • HaruPage::TS_WIPE_LEFT
  • HaruPage::TS_WIPE_UP
  • HaruPage::TS_WIPE_DOWN
  • HaruPage::TS_BARN_DOORS_HORIZONTAL_OUT
  • HaruPage::TS_BARN_DOORS_HORIZONTAL_IN
  • HaruPage::TS_BARN_DOORS_VERTICAL_OUT
  • HaruPage::TS_BARN_DOORS_VERTICAL_IN
  • HaruPage::TS_BOX_OUT
  • HaruPage::TS_BOX_IN
  • HaruPage::TS_BLINDS_HORIZONTAL
  • HaruPage::TS_BLINDS_VERTICAL
  • HaruPage::TS_DISSOLVE
  • HaruPage::TS_GLITTER_RIGHT
  • HaruPage::TS_GLITTER_DOWN
  • HaruPage::TS_GLITTER_TOP_LEFT_TO_BOTTOM_RIGHT
  • HaruPage::TS_REPLACE

disp_time

The display duration of the page in seconds.

trans_time

The duration of the transition effect in seconds.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruPage::setSize
HaruPage::setTextLeading
HaruPage


Set text leading (line spacing) for the page

HaruPage::setSlideShow
HaruPage::setTextMatrix
HaruPage
PHP Manual

HaruPage::setTextLeading

(PECL haru >= 0.0.1)

HaruPage::setTextLeading — Set text leading (line spacing) for the page

Açıklama

bool HaruPage::setTextLeading ( float $text_leading )

Set the text leading (line spacing) for the page.

Değiştirgeler

text_leading

Defines line spacing for the page.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::getTextLeading() - Get the current value of line spacing

HaruPage::setSlideShow
HaruPage::setTextMatrix
HaruPage


Set the current text transformation matrix of the page

HaruPage::setTextLeading
HaruPage::setTextRenderingMode
HaruPage
PHP Manual

HaruPage::setTextMatrix

(PECL haru >= 0.0.1)

HaruPage::setTextMatrix — Set the current text transformation matrix of the page

Açıklama

bool HaruPage::setTextMatrix ( float $a , float $b , float $c , float $d , float $x , float $y )

Defines the text transformation matrix of the page.

Değiştirgeler

a

Width multiplier.

b

Vertical skew in radians.

c

Horizontal skew in radians.

d

Height multiplier.

x

Horizontal position for text.

y

Vertical position for text.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::getTextMatrix() - Get the current text transformation matrix of the page

HaruPage::setTextLeading
HaruPage::setTextRenderingMode
HaruPage


Set text rendering mode for the page

HaruPage::setTextMatrix
HaruPage::setTextRise
HaruPage
PHP Manual

HaruPage::setTextRenderingMode

(PECL haru >= 0.0.1)

HaruPage::setTextRenderingMode — Set text rendering mode for the page

Açıklama

bool HaruPage::setTextRenderingMode ( int $mode )

Defines text rendering mode for the page.

Değiştirgeler

mode

Must be one of the following values:

  • HaruPage::FILL
  • HaruPage::STROKE
  • HaruPage::FILL_THEN_STROKE
  • HaruPage::INVISIBLE
  • HaruPage::FILL_CLIPPING
  • HaruPage::STROKE_CLIPPING
  • HaruPage::FILL_STROKE_CLIPPING
  • HaruPage::CLIPPING

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::getTextRenderingMode() - Get the current text rendering mode

HaruPage::setTextMatrix
HaruPage::setTextRise
HaruPage


Set the current value of text rising

HaruPage::setTextRenderingMode
HaruPage::setWidth
HaruPage
PHP Manual

HaruPage::setTextRise

(PECL haru >= 0.0.1)

HaruPage::setTextRise — Set the current value of text rising

Açıklama

bool HaruPage::setTextRise ( float $rise )

Set the current value of text rising.

Değiştirgeler

rise

Defines the current value of text rising.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::getTextRise() - Get the current value of text rising

HaruPage::setTextRenderingMode
HaruPage::setWidth
HaruPage


Set width of the page

HaruPage::setTextRise
HaruPage::setWordSpace
HaruPage
PHP Manual

HaruPage::setWidth

(PECL haru >= 0.0.1)

HaruPage::setWidth — Set width of the page

Açıklama

bool HaruPage::setWidth ( float $width )

Set the width of the page.

Değiştirgeler

width

Defines width of the page.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::getWidth() - Get the width of the page

HaruPage::setTextRise
HaruPage::setWordSpace
HaruPage


Set word spacing for the page

HaruPage::setWidth
HaruPage::showText
HaruPage
PHP Manual

HaruPage::setWordSpace

(PECL haru >= 0.0.1)

HaruPage::setWordSpace — Set word spacing for the page

Açıklama

bool HaruPage::setWordSpace ( float $word_space )

Set the word spacing for the page.

Değiştirgeler

word_space

Defines word spacing for the page.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::getWordSpace() - Get the current value of word spacing

HaruPage::setWidth
HaruPage::showText
HaruPage


Print text at the current position of the page

HaruPage::setWordSpace
HaruPage::showTextNextLine
HaruPage
PHP Manual

HaruPage::showText

(PECL haru >= 0.0.1)

HaruPage::showText — Print text at the current position of the page

Açıklama

bool HaruPage::showText ( string $text )

Prints out the text at the current position of the page.

Değiştirgeler

text

The text to show.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::showTextNextLine() - Move the current position to the start of the next line and print the text
  • HaruPage::textOut() - Print the text on the specified position

HaruPage::setWordSpace
HaruPage::showTextNextLine
HaruPage


Move the current position to the start of the next line and print the text

HaruPage::showText
HaruPage::stroke
HaruPage
PHP Manual

HaruPage::showTextNextLine

(PECL haru >= 0.0.1)

HaruPage::showTextNextLine — Move the current position to the start of the next line and print the text

Açıklama

bool HaruPage::showTextNextLine ( string $text [, float $word_space = 0 [, float $char_space = 0 ]] )

Moves the current position to the start of the next line and print out the text.

Değiştirgeler

text

The text to show.

word_space

The word spacing.

char_space

The character spacing.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::showText() - Print text at the current position of the page
  • HaruPage::textOut() - Print the text on the specified position

HaruPage::showText
HaruPage::stroke
HaruPage


Paint current path

HaruPage::showTextNextLine
HaruPage::textOut
HaruPage
PHP Manual

HaruPage::stroke

(PECL haru >= 0.0.1)

HaruPage::stroke — Paint current path

Açıklama

bool HaruPage::stroke ([ bool $close_path = false ] )

Paints the current path.

Değiştirgeler

close_path

Closes the current path if set to TRUE.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruPage::showTextNextLine
HaruPage::textOut
HaruPage


Print the text on the specified position

HaruPage::stroke
HaruPage::textRect
HaruPage
PHP Manual

HaruPage::textOut

(PECL haru >= 0.0.1)

HaruPage::textOut — Print the text on the specified position

Açıklama

bool HaruPage::textOut ( float $x , float $y , string $text )

Prints the text on the specified position.

Değiştirgeler

x

y

text

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::showTextNextLine() - Move the current position to the start of the next line and print the text
  • HaruPage::showText() - Print text at the current position of the page

HaruPage::stroke
HaruPage::textRect
HaruPage


Print the text inside the specified region

HaruPage::textOut
HaruFont
HaruPage
PHP Manual

HaruPage::textRect

(PECL haru >= 0.0.1)

HaruPage::textRect — Print the text inside the specified region

Açıklama

bool HaruPage::textRect ( float $left , float $top , float $right , float $bottom , string $text [, int $align = HaruPage::TALIGN_LEFT ] )

Prints the text inside the specified region.

Değiştirgeler

left

Left border of the text area.

top

Top border of the text area.

right

Right border of the text area.

bottom

Lower border of the text area.

text

The text to print.

align

Text alignment. Must be one of the following values:

  • HaruPage::TALIGN_LEFT
  • HaruPage::TALIGN_RIGHT
  • HaruPage::TALIGN_CENTER
  • HaruPage::TALIGN_JUSTIFY

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

Ayrıca Bakınız

  • HaruPage::showTextNextLine() - Move the current position to the start of the next line and print the text
  • HaruPage::showText() - Print text at the current position of the page
  • HaruPage::textOut() - Print the text on the specified position

HaruPage::textOut
HaruFont
HaruPage


The HaruFont class

(PECL haru >= 0.0.1)

Giriş

Haru PDF Font Class.

Sınıf Sözdizimi

HaruFont {
/* Yöntemler */
int getAscent ( void )
int getCapHeight ( void )
int getDescent ( void )
string getEncodingName ( void )
string getFontName ( void )
array getTextWidth ( string $text )
int getUnicodeWidth ( int $character )
int getXHeight ( void )
int measureText ( string $text , float $width , float $font_size , float $char_space , float $word_space [, bool $word_wrap = false ] )
}

İçindekiler

  • HaruFont::getAscent — Get the vertical ascent of the font
  • HaruFont::getCapHeight — Get the distance from the baseline of uppercase letters
  • HaruFont::getDescent — Get the vertical descent of the font
  • HaruFont::getEncodingName — Get the name of the encoding
  • HaruFont::getFontName — Get the name of the font
  • HaruFont::getTextWidth — Get the total width of the text, number of characters, number of words and number of spaces
  • HaruFont::getUnicodeWidth — Get the width of the character in the font
  • HaruFont::getXHeight — Get the distance from the baseline of lowercase letters
  • HaruFont::measureText — Calculate the number of characters which can be included within the specified width
HaruPage::textRect
HaruFont::getAscent
haru


Get the vertical ascent of the font

HaruFont
HaruFont::getCapHeight
HaruFont
PHP Manual

HaruFont::getAscent

(PECL haru >= 0.0.1)

HaruFont::getAscent — Get the vertical ascent of the font

Açıklama

int HaruFont::getAscent ( void )

Get the vertical ascent of the font.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the vertical ascent of the font.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruFont
HaruFont::getCapHeight
HaruFont


Get the distance from the baseline of uppercase letters

HaruFont::getAscent
HaruFont::getDescent
HaruFont
PHP Manual

HaruFont::getCapHeight

(PECL haru >= 0.0.1)

HaruFont::getCapHeight — Get the distance from the baseline of uppercase letters

Açıklama

int HaruFont::getCapHeight ( void )

Get the distance from the baseline of uppercase letters.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the distance from the baseline of uppercase letters.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruFont::getAscent
HaruFont::getDescent
HaruFont


Get the vertical descent of the font

HaruFont::getCapHeight
HaruFont::getEncodingName
HaruFont
PHP Manual

HaruFont::getDescent

(PECL haru >= 0.0.1)

HaruFont::getDescent — Get the vertical descent of the font

Açıklama

int HaruFont::getDescent ( void )

Get the vertical descent of the font.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Return the vertical descent of the font.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruFont::getCapHeight
HaruFont::getEncodingName
HaruFont


Get the name of the encoding

HaruFont::getDescent
HaruFont::getFontName
HaruFont
PHP Manual

HaruFont::getEncodingName

(PECL haru >= 0.0.1)

HaruFont::getEncodingName — Get the name of the encoding

Açıklama

string HaruFont::getEncodingName ( void )

Get the name of the font encoding.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the name of the font encoding.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruFont::getDescent
HaruFont::getFontName
HaruFont


Get the name of the font

HaruFont::getEncodingName
HaruFont::getTextWidth
HaruFont
PHP Manual

HaruFont::getFontName

(PECL haru >= 0.0.1)

HaruFont::getFontName — Get the name of the font

Açıklama

string HaruFont::getFontName ( void )

Get the name of the font.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the name of the font.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruFont::getEncodingName
HaruFont::getTextWidth
HaruFont


Get the total width of the text, number of characters, number of words and number of spaces

HaruFont::getFontName
HaruFont::getUnicodeWidth
HaruFont
PHP Manual

HaruFont::getTextWidth

(PECL haru >= 0.0.1)

HaruFont::getTextWidth — Get the total width of the text, number of characters, number of words and number of spaces

Açıklama

array HaruFont::getTextWidth ( string $text )

Get the total width of the text, number of characters, number of words and number of spaces.

Değiştirgeler

text

The text to measure.

Dönen Değerler

Returns the total width of the text, number of characters, number of words and number of spaces in the given text.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruFont::getFontName
HaruFont::getUnicodeWidth
HaruFont


Get the width of the character in the font

HaruFont::getTextWidth
HaruFont::getXHeight
HaruFont
PHP Manual

HaruFont::getUnicodeWidth

(PECL haru >= 0.0.1)

HaruFont::getUnicodeWidth — Get the width of the character in the font

Açıklama

int HaruFont::getUnicodeWidth ( int $character )

Get the width of the character in the font.

Değiştirgeler

character

The code of the character.

Dönen Değerler

Returns the width of the character in the font.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruFont::getTextWidth
HaruFont::getXHeight
HaruFont


Get the distance from the baseline of lowercase letters

HaruFont::getUnicodeWidth
HaruFont::measureText
HaruFont
PHP Manual

HaruFont::getXHeight

(PECL haru >= 0.0.1)

HaruFont::getXHeight — Get the distance from the baseline of lowercase letters

Açıklama

int HaruFont::getXHeight ( void )

Gets the distance from the baseline of lowercase letters.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the distance from the baseline of lowercase letters.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruFont::getUnicodeWidth
HaruFont::measureText
HaruFont


Calculate the number of characters which can be included within the specified width

HaruFont::getXHeight
HaruImage
HaruFont
PHP Manual

HaruFont::measureText

(PECL haru >= 0.0.1)

HaruFont::measureText — Calculate the number of characters which can be included within the specified width

Açıklama

int HaruFont::measureText ( string $text , float $width , float $font_size , float $char_space , float $word_space [, bool $word_wrap = false ] )

Calculate the number of characters which can be included within the specified width.

Değiştirgeler

text

The text to fit the width.

width

The width of the area to put the text to.

font_size

The size of the font.

char_space

The character spacing.

word_space

The word spacing.

word_wrap

When this parameter is set to TRUE the function "emulates" word wrapping and doesn't include the part of the current word if reached the end of the area.

Dönen Değerler

Returns the number of characters which can be included within the specified width.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruFont::getXHeight
HaruImage
HaruFont


The HaruImage class

(PECL haru >= 0.0.1)

Giriş

Haru PDF Image Class.

Sınıf Sözdizimi

HaruImage {
/* Yöntemler */
int getBitsPerComponent ( void )
string getColorSpace ( void )
int getHeight ( void )
array getSize ( void )
int getWidth ( void )
bool setColorMask ( int $rmin , int $rmax , int $gmin , int $gmax , int $bmin , int $bmax )
bool setMaskImage ( object $mask_image )
}

İçindekiler

  • HaruImage::getBitsPerComponent — Get the number of bits used to describe each color component of the image
  • HaruImage::getColorSpace — Get the name of the color space
  • HaruImage::getHeight — Get the height of the image
  • HaruImage::getSize — Get size of the image
  • HaruImage::getWidth — Get the width of the image
  • HaruImage::setColorMask — Set the color mask of the image
  • HaruImage::setMaskImage — Set the image mask
HaruFont::measureText
HaruImage::getBitsPerComponent
haru


Get the number of bits used to describe each color component of the image

HaruImage
HaruImage::getColorSpace
HaruImage
PHP Manual

HaruImage::getBitsPerComponent

(PECL haru >= 0.0.1)

HaruImage::getBitsPerComponent — Get the number of bits used to describe each color component of the image

Açıklama

int HaruImage::getBitsPerComponent ( void )

Gets the number of bits used to describe each color component of the image.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the number of bits used to describe each color component of the image.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruImage
HaruImage::getColorSpace
HaruImage


Get the name of the color space

HaruImage::getBitsPerComponent
HaruImage::getHeight
HaruImage
PHP Manual

HaruImage::getColorSpace

(PECL haru >= 0.0.1)

HaruImage::getColorSpace — Get the name of the color space

Açıklama

string HaruImage::getColorSpace ( void )

Get the name of the color space.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the name of the color space of the image. The name is one of the following values:

  • "DeviceGray"
  • "DeviceRGB"
  • "DeviceCMYK"
  • "Indexed"

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruImage::getBitsPerComponent
HaruImage::getHeight
HaruImage


Get the height of the image

HaruImage::getColorSpace
HaruImage::getSize
HaruImage
PHP Manual

HaruImage::getHeight

(PECL haru >= 0.0.1)

HaruImage::getHeight — Get the height of the image

Açıklama

int HaruImage::getHeight ( void )

Get the height of the image.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the height of the image.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruImage::getColorSpace
HaruImage::getSize
HaruImage


Get size of the image

HaruImage::getHeight
HaruImage::getWidth
HaruImage
PHP Manual

HaruImage::getSize

(PECL haru >= 0.0.1)

HaruImage::getSize — Get size of the image

Açıklama

array HaruImage::getSize ( void )

Get the size of the image.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array with two elements: width and height, which contain appropriate dimensions of the image.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruImage::getHeight
HaruImage::getWidth
HaruImage


Get the width of the image

HaruImage::getSize
HaruImage::setColorMask
HaruImage
PHP Manual

HaruImage::getWidth

(PECL haru >= 0.0.1)

HaruImage::getWidth — Get the width of the image

Açıklama

int HaruImage::getWidth ( void )

Get the width of the image.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the width of the image.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruImage::getSize
HaruImage::setColorMask
HaruImage


Set the color mask of the image

HaruImage::getWidth
HaruImage::setMaskImage
HaruImage
PHP Manual

HaruImage::setColorMask

(PECL haru >= 0.0.1)

HaruImage::setColorMask — Set the color mask of the image

Açıklama

bool HaruImage::setColorMask ( int $rmin , int $rmax , int $gmin , int $gmax , int $bmin , int $bmax )

Defines the transparent color of the image using the RGB range values. The color within the range is displayed as a transparent color. The color space of the image must be RGB.

Değiştirgeler

rmin

The lower limit of red. Must be between 0 and 255.

rmax

The upper limit of red. Must be between 0 and 255.

gmin

The lower limit of green. Must be between 0 and 255.

gmax

The upper limit of green. Must be between 0 and 255.

bmin

The lower limit of blue. Must be between 0 and 255.

bmax

The upper limit of blue. Must be between 0 and 255.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruImage::getWidth
HaruImage::setMaskImage
HaruImage


Set the image mask

HaruImage::setColorMask
HaruEncoder
HaruImage
PHP Manual

HaruImage::setMaskImage

(PECL haru >= 0.0.1)

HaruImage::setMaskImage — Set the image mask

Açıklama

bool HaruImage::setMaskImage ( object $mask_image )

Sets the image used as image-mask. It must be 1bit gray-scale color image.

Değiştirgeler

mask_image

A valid HaruImage instance.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruImage::setColorMask
HaruEncoder
HaruImage


The HaruEncoder class

(PECL haru >= 0.0.1)

Giriş

Haru PDF Encoder Class.

Sınıf Sözdizimi

HaruEncoder {
/* Yöntemler */
int getByteType ( string $text , int $index )
int getType ( void )
int getUnicode ( int $character )
int getWritingMode ( void )
}

Öntanımlı Sabitler

Type | Name | Description
int | HaruEncoder::TYPE_SINGLE_BYTE |
int | HaruEncoder::TYPE_DOUBLE_BYTE |
int | HaruEncoder::TYPE_UNINITIALIZED |
int | HaruEncoder::UNKNOWN |
int | HaruEncoder::WMODE_HORIZONTAL |
int | HaruEncoder::WMODE_VERTICAL |
int | HaruEncoder::BYTE_TYPE_SINGLE |
int | HaruEncoder::BYTE_TYPE_LEAD |
int | HaruEncoder::BYTE_TYPE_TRAIL |
int | HaruEncoder::BYTE_TYPE_UNKNOWN |

İçindekiler

  • HaruEncoder::getByteType — Get the type of the byte in the text
  • HaruEncoder::getType — Get the type of the encoder
  • HaruEncoder::getUnicode — Convert the specified character to unicode
  • HaruEncoder::getWritingMode — Get the writing mode of the encoder
HaruImage::setMaskImage
HaruEncoder::getByteType
haru


Get the type of the byte in the text

HaruEncoder
HaruEncoder::getType
HaruEncoder
PHP Manual

HaruEncoder::getByteType

(PECL haru >= 0.0.1)

HaruEncoder::getByteType — Get the type of the byte in the text

Açıklama

int HaruEncoder::getByteType ( string $text , int $index )

Get the type of the byte in the text.

Değiştirgeler

text

The text.

index

The position in the text.

Dönen Değerler

Returns the type of the byte in the text on the specified position. The result is one of the following values:

  • HaruEncoder::BYTE_TYPE_SINGLE - single byte character.
  • HaruEncoder::BYTE_TYPE_LEAD - lead byte of a double-byte character.
  • HaruEncoder::BYTE_TYPE_TRAIL - trailing byte of a double-byte character.
  • HaruEncoder::BYTE_TYPE_UNKNOWN - invalid encoder or cannot detect the byte type.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruEncoder
HaruEncoder::getType
HaruEncoder


Get the type of the encoder

HaruEncoder::getByteType
HaruEncoder::getUnicode
HaruEncoder
PHP Manual

HaruEncoder::getType

(PECL haru >= 0.0.1)

HaruEncoder::getType — Get the type of the encoder

Açıklama

int HaruEncoder::getType ( void )

Get the type of the encoder.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the type of the encoder. The result is one of the following values:

  • HaruEncoder::TYPE_SINGLE_BYTE - the encoder is for single byte characters.
  • HaruEncoder::TYPE_DOUBLE_BYTE - the encoder is for multibyte characters.
  • HaruEncoder::TYPE_UNINITIALIZED - the encoder is not initialized.
  • HaruEncoder::UNKNOWN - the encoder is invalid.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruEncoder::getByteType
HaruEncoder::getUnicode
HaruEncoder


Convert the specified character to unicode

HaruEncoder::getType
HaruEncoder::getWritingMode
HaruEncoder
PHP Manual

HaruEncoder::getUnicode

(PECL haru >= 0.0.1)

HaruEncoder::getUnicode — Convert the specified character to unicode

Açıklama

int HaruEncoder::getUnicode ( int $character )

Converts the specified character to unicode.

Değiştirgeler

character

The character code to convert.

Dönen Değerler

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruEncoder::getType
HaruEncoder::getWritingMode
HaruEncoder


Get the writing mode of the encoder

HaruEncoder::getUnicode
HaruOutline
HaruEncoder
PHP Manual

HaruEncoder::getWritingMode

(PECL haru >= 0.0.1)

HaruEncoder::getWritingMode — Get the writing mode of the encoder

Açıklama

int HaruEncoder::getWritingMode ( void )

Get the writing mode of the encoder.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the writing mode of the encoder. The result value is on of the following:

  • HaruEncoder::WMODE_HORIZONTAL - horizontal writing mode.
  • HaruEncoder::WMODE_VERTICAL - vertical writing mode.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruEncoder::getUnicode
HaruOutline
HaruEncoder


The HaruOutline class

(PECL haru >= 0.0.1)

Giriş

Haru PDF Outline Class.

Sınıf Sözdizimi

HaruOutline {
/* Yöntemler */
bool setDestination ( object $destination )
bool setOpened ( bool $opened )
}

İçindekiler

  • HaruOutline::setDestination — Set the destination for the outline
  • HaruOutline::setOpened — Set the initial state of the outline
HaruEncoder::getWritingMode
HaruOutline::setDestination
haru


Set the destination for the outline

HaruOutline
HaruOutline::setOpened
HaruOutline
PHP Manual

HaruOutline::setDestination

(PECL haru >= 0.0.1)

HaruOutline::setDestination — Set the destination for the outline

Açıklama

bool HaruOutline::setDestination ( object $destination )

Sets a destination object which becomes a target to jump to when the outline is clicked.

Değiştirgeler

destination

A valid HaruDestination instance.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruOutline
HaruOutline::setOpened
HaruOutline


Set the initial state of the outline

HaruOutline::setDestination
HaruAnnotation
HaruOutline
PHP Manual

HaruOutline::setOpened

(PECL haru >= 0.0.1)

HaruOutline::setOpened — Set the initial state of the outline

Açıklama

bool HaruOutline::setOpened ( bool $opened )

Defines whether this node is opened or not when the outline is displayed for the first time.

Değiştirgeler

opened

TRUE means open, FALSE - closed.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruOutline::setDestination
HaruAnnotation
HaruOutline


The HaruAnnotation class

(PECL haru >= 0.0.1)

Giriş

Haru PDF Annotation Class.

Sınıf Sözdizimi

HaruAnnotation {
/* Yöntemler */
bool setBorderStyle ( float $width , int $dash_on , int $dash_off )
bool setHighlightMode ( int $mode )
bool setIcon ( int $icon )
bool setOpened ( bool $opened )
}

Öntanımlı Sabitler

Type | Name | Description
int | HaruAnnotation::NO_HIGHLIGHT |
int | HaruAnnotation::INVERT_BOX |
int | HaruAnnotation::INVERT_BORDER |
int | HaruAnnotation::DOWN_APPEARANCE |
int | HaruAnnotation::ICON_COMMENT |
int | HaruAnnotation::ICON_KEY |
int | HaruAnnotation::ICON_NOTE |
int | HaruAnnotation::ICON_HELP |
int | HaruAnnotation::ICON_NEW_PARAGRAPH |
int | HaruAnnotation::ICON_PARAGRAPH |
int | HaruAnnotation::ICON_INSERT |

İçindekiler

  • HaruAnnotation::setBorderStyle — Set the border style of the annotation
  • HaruAnnotation::setHighlightMode — Set the highlighting mode of the annotation
  • HaruAnnotation::setIcon — Set the icon style of the annotation
  • HaruAnnotation::setOpened — Set the initial state of the annotation
HaruOutline::setOpened
HaruAnnotation::setBorderStyle
haru


Set the border style of the annotation

HaruAnnotation
HaruAnnotation::setHighlightMode
HaruAnnotation
PHP Manual

HaruAnnotation::setBorderStyle

(PECL haru >= 0.0.1)

HaruAnnotation::setBorderStyle — Set the border style of the annotation

Açıklama

bool HaruAnnotation::setBorderStyle ( float $width , int $dash_on , int $dash_off )

Defines the style of the border of the annotation. This function may be used with link annotations only.

Değiştirgeler

width

The width of the border line.

dash_on

The dash style.

dash_off

The dash style.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruAnnotation
HaruAnnotation::setHighlightMode
HaruAnnotation


Set the highlighting mode of the annotation

HaruAnnotation::setBorderStyle
HaruAnnotation::setIcon
HaruAnnotation
PHP Manual

HaruAnnotation::setHighlightMode

(PECL haru >= 0.0.1)

HaruAnnotation::setHighlightMode — Set the highlighting mode of the annotation

Açıklama

bool HaruAnnotation::setHighlightMode ( int $mode )

Defines the appearance of the annotation when clicked. This function may be used with link annotations only.

Değiştirgeler

mode

The highlighting mode of the annotation. Can take only these values:

  • HaruAnnotation::NO_HIGHLIGHT - no highlighting.
  • HaruAnnotation::INVERT_BOX - invert the contents of the annotation.
  • HaruAnnotation::INVERT_BORDER - invert the border of the annotation.
  • HaruAnnotation::DOWN_APPEARANCE - dent the annotation.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruAnnotation::setBorderStyle
HaruAnnotation::setIcon
HaruAnnotation


Set the icon style of the annotation

HaruAnnotation::setHighlightMode
HaruAnnotation::setOpened
HaruAnnotation
PHP Manual

HaruAnnotation::setIcon

(PECL haru >= 0.0.1)

HaruAnnotation::setIcon — Set the icon style of the annotation

Açıklama

bool HaruAnnotation::setIcon ( int $icon )

Defines the style of the annotation icon. This function may be used with text annotations only.

Değiştirgeler

icon

The style of the icon. Can take only these values:

  • HaruAnnotation::ICON_COMMENT
  • HaruAnnotation::ICON_KEY
  • HaruAnnotation::ICON_NOTE
  • HaruAnnotation::ICON_HELP
  • HaruAnnotation::ICON_NEW_PARAGRAPH
  • HaruAnnotation::ICON_PARAGRAPH
  • HaruAnnotation::ICON_INSERT

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruAnnotation::setHighlightMode
HaruAnnotation::setOpened
HaruAnnotation


Set the initial state of the annotation

HaruAnnotation::setIcon
HaruDestination
HaruAnnotation
PHP Manual

HaruAnnotation::setOpened

(PECL haru >= 0.0.1)

HaruAnnotation::setOpened — Set the initial state of the annotation

Açıklama

bool HaruAnnotation::setOpened ( bool $opened )

Defines whether the annotation is initially displayed open. This function may be used with text annotations only.

Değiştirgeler

opened

TRUE means the annotation is initially displayed open, FALSE - means it's closed.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruAnnotation::setIcon
HaruDestination
HaruAnnotation


The HaruDestination class

(PECL haru >= 0.0.1)

Giriş

Haru PDF Destination Class.

Sınıf Sözdizimi

HaruDestination {
/* Yöntemler */
bool setFit ( void )
bool setFitB ( void )
bool setFitBH ( float $top )
bool setFitBV ( float $left )
bool setFitH ( float $top )
bool setFitR ( float $left , float $bottom , float $right , float $top )
bool setFitV ( float $left )
bool setXYZ ( float $left , float $top , float $zoom )
}

İçindekiler

  • HaruDestination::setFit — Set the appearance of the page to fit the window
  • HaruDestination::setFitB — Set the appearance of the page to fit the bounding box of the page within the window
  • HaruDestination::setFitBH — Set the appearance of the page to fit the width of the bounding box
  • HaruDestination::setFitBV — Set the appearance of the page to fit the height of the boudning box
  • HaruDestination::setFitH — Set the appearance of the page to fit the window width
  • HaruDestination::setFitR — Set the appearance of the page to fit the specified rectangle
  • HaruDestination::setFitV — Set the appearance of the page to fit the window height
  • HaruDestination::setXYZ — Set the appearance of the page
HaruAnnotation::setOpened
HaruDestination::setFit
haru


Set the appearance of the page to fit the window

HaruDestination
HaruDestination::setFitB
HaruDestination
PHP Manual

HaruDestination::setFit

(PECL haru >= 0.0.1)

HaruDestination::setFit — Set the appearance of the page to fit the window

Açıklama

bool HaruDestination::setFit ( void )

Defines the appearance of the page to fit the window.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruDestination
HaruDestination::setFitB
HaruDestination


Set the appearance of the page to fit the bounding box of the page within the window

HaruDestination::setFit
HaruDestination::setFitBH
HaruDestination
PHP Manual

HaruDestination::setFitB

(PECL haru >= 0.0.1)

HaruDestination::setFitB — Set the appearance of the page to fit the bounding box of the page within the window

Açıklama

bool HaruDestination::setFitB ( void )

Defines the appearance of the page to fit the bounding box of the page within the window.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruDestination::setFit
HaruDestination::setFitBH
HaruDestination


Set the appearance of the page to fit the width of the bounding box

HaruDestination::setFitB
HaruDestination::setFitBV
HaruDestination
PHP Manual

HaruDestination::setFitBH

(PECL haru >= 0.0.1)

HaruDestination::setFitBH — Set the appearance of the page to fit the width of the bounding box

Açıklama

bool HaruDestination::setFitBH ( float $top )

Defines the appearance of the page to magnifying to fit the width of the bounding box and setting the top position of the page to the value of top.

Değiştirgeler

top

The top coordinates of the page.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruDestination::setFitB
HaruDestination::setFitBV
HaruDestination


Set the appearance of the page to fit the height of the boudning box

HaruDestination::setFitBH
HaruDestination::setFitH
HaruDestination
PHP Manual

HaruDestination::setFitBV

(PECL haru >= 0.0.1)

HaruDestination::setFitBV — Set the appearance of the page to fit the height of the boudning box

Açıklama

bool HaruDestination::setFitBV ( float $left )

Defines the appearance of the page to magnifying to fit the height of the bounding box and setting the left position of the page to the value of left.

Değiştirgeler

left

The left coordinates of the page.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruDestination::setFitBH
HaruDestination::setFitH
HaruDestination


Set the appearance of the page to fit the window width

HaruDestination::setFitBV
HaruDestination::setFitR
HaruDestination
PHP Manual

HaruDestination::setFitH

(PECL haru >= 0.0.1)

HaruDestination::setFitH — Set the appearance of the page to fit the window width

Açıklama

bool HaruDestination::setFitH ( float $top )

Defines the appearance of the page to fit the window width and sets the top position of the page to the value of top.

Değiştirgeler

top

The top position of the page.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruDestination::setFitBV
HaruDestination::setFitR
HaruDestination


Set the appearance of the page to fit the specified rectangle

HaruDestination::setFitH
HaruDestination::setFitV
HaruDestination
PHP Manual

HaruDestination::setFitR

(PECL haru >= 0.0.1)

HaruDestination::setFitR — Set the appearance of the page to fit the specified rectangle

Açıklama

bool HaruDestination::setFitR ( float $left , float $bottom , float $right , float $top )

Defines the appearance of the page to fit the rectangle by the parameters.

Değiştirgeler

left

The left coordinates of the page.

bottom

The bottom coordinates of the page.

right

The right coordinates of the page.

top

The top coordinates of the page.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruDestination::setFitH
HaruDestination::setFitV
HaruDestination


Set the appearance of the page to fit the window height

HaruDestination::setFitR
HaruDestination::setXYZ
HaruDestination
PHP Manual

HaruDestination::setFitV

(PECL haru >= 0.0.1)

HaruDestination::setFitV — Set the appearance of the page to fit the window height

Açıklama

bool HaruDestination::setFitV ( float $left )

Defines the appearance of the page to fit the window height.

Değiştirgeler

left

The left position of the page.

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruDestination::setFitR
HaruDestination::setXYZ
HaruDestination


Set the appearance of the page

HaruDestination::setFitV
Ming
HaruDestination
PHP Manual

HaruDestination::setXYZ

(PECL haru >= 0.0.1)

HaruDestination::setXYZ — Set the appearance of the page

Açıklama

bool HaruDestination::setXYZ ( float $left , float $top , float $zoom )

Defines the appearance of the page using three parameters: left, top and zoom.

Değiştirgeler

left

The left position of the page.

top

The top position of the page.

zoom

The magnification factor. The value must be between 0.08 (8%) and 32 (3200%).

Dönen Değerler

Returns TRUE on success.

Hatalar/İstisnalar

Hata durumunda bir HaruException istisnası oluşur.

HaruDestination::setFitV
Ming
HaruDestination


Ming (flash)

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
    • SWFAction Examples
    • SWFSPrite basic examples
  • Ming İşlevleri
    • ming_keypress — Returns the action flag for keyPress(char)
    • ming_setcubicthreshold — Set cubic threshold
    • ming_setscale — Set the global scaling factor.
    • ming_setswfcompression — Sets the SWF output compression
    • ming_useconstants — Use constant pool
    • ming_useswfversion — Sets the SWF version
  • SWFAction — The SWFAction class
    • SWFAction::__construct — Creates a new SWFAction
  • SWFBitmap — The SWFBitmap class
    • SWFBitmap::__construct — Loads Bitmap object
    • SWFBitmap::getHeight — Returns the bitmap's height
    • SWFBitmap::getWidth — Returns the bitmap's width
  • SWFButton — The SWFButton class
    • SWFButton::addAction — Adds an action
    • SWFButton::addASound — Associates a sound with a button transition
    • SWFButton::addShape — Adds a shape to a button
    • SWFButton::__construct — Creates a new Button
    • SWFButton::setAction — Sets the action
    • SWFButton::setDown — Alias for addShape(shape, SWFBUTTON_DOWN)
    • SWFButton::setHit — Alias for addShape(shape, SWFBUTTON_HIT)
    • SWFButton::setMenu — enable track as menu button behaviour
    • SWFButton::setOver — Alias for addShape(shape, SWFBUTTON_OVER)
    • SWFButton::setUp — Alias for addShape(shape, SWFBUTTON_UP)
  • SWFDisplayItem — The SWFDisplayItem class
    • SWFDisplayItem::addAction — Adds this SWFAction to the given SWFSprite instance
    • SWFDisplayItem::addColor — Adds the given color to this item's color transform
    • SWFDisplayItem::endMask — Another way of defining a MASK layer
    • SWFDisplayItem::getRot — Açıklama
    • SWFDisplayItem::getX — Açıklama
    • SWFDisplayItem::getXScale — Açıklama
    • SWFDisplayItem::getXSkew — Açıklama
    • SWFDisplayItem::getY — Açıklama
    • SWFDisplayItem::getYScale — Açıklama
    • SWFDisplayItem::getYSkew — Açıklama
    • SWFDisplayItem::move — Moves object in relative coordinates
    • SWFDisplayItem::moveTo — Moves object in global coordinates
    • SWFDisplayItem::multColor — Multiplies the item's color transform
    • SWFDisplayItem::remove — Removes the object from the movie
    • SWFDisplayItem::rotate — Rotates in relative coordinates
    • SWFDisplayItem::rotateTo — Rotates the object in global coordinates
    • SWFDisplayItem::scale — Scales the object in relative coordinates
    • SWFDisplayItem::scaleTo — Scales the object in global coordinates
    • SWFDisplayItem::setDepth — Sets z-order
    • SWFDisplayItem::setMaskLevel — Defines a MASK layer at level
    • SWFDisplayItem::setMatrix — Sets the item's transform matrix
    • SWFDisplayItem::setName — Sets the object's name
    • SWFDisplayItem::setRatio — Sets the object's ratio
    • SWFDisplayItem::skewX — Sets the X-skew
    • SWFDisplayItem::skewXTo — Sets the X-skew
    • SWFDisplayItem::skewY — Sets the Y-skew
    • SWFDisplayItem::skewYTo — Sets the Y-skew
  • SWFFill — The SWFFill class
    • SWFFill::moveTo — Moves fill origin
    • SWFFill::rotateTo — Sets fill's rotation
    • SWFFill::scaleTo — Sets fill's scale
    • SWFFill::skewXTo — Sets fill x-skew
    • SWFFill::skewYTo — Sets fill y-skew
  • SWFFont — The SWFFont class
    • SWFFont::__construct — Loads a font definition
    • SWFFont::getAscent — Returns the ascent of the font, or 0 if not available
    • SWFFont::getDescent — Returns the descent of the font, or 0 if not available
    • SWFFont::getLeading — Returns the leading of the font, or 0 if not available
    • SWFFont::getShape — Returns the glyph shape of a char as a text string
    • SWFFont::getUTF8Width — Calculates the width of the given string in this font at full height
    • SWFFont::getWidth — Returns the string's width
  • SWFFontChar — The SWFFontChar class
    • SWFFontChar::addChars — Adds characters to a font for exporting font
    • SWFFontChar::addUTF8Chars — Adds characters to a font for exporting font
  • SWFGradient — The SWFGradient class
    • SWFGradient::addEntry — Adds an entry to the gradient list
    • SWFGradient::__construct — Creates a gradient object
  • SWFMorph — The SWFMorph class
    • SWFMorph::__construct — Creates a new SWFMorph object
    • SWFMorph::getShape1 — Gets a handle to the starting shape
    • SWFMorph::getShape2 — Gets a handle to the ending shape
  • SWFMovie — The SWFMovie class
    • SWFMovie::add — Adds any type of data to a movie
    • SWFMovie::addExport — Açıklama
    • SWFMovie::addFont — Açıklama
    • SWFMovie::__construct — Creates a new movie object, representing an SWF version 4 movie
    • SWFMovie::importChar — Açıklama
    • SWFMovie::importFont — Açıklama
    • SWFMovie::labelFrame — Labels a frame
    • SWFMovie::nextFrame — Moves to the next frame of the animation
    • SWFMovie::output — Dumps your lovingly prepared movie out
    • SWFMovie::remove — Removes the object instance from the display list
    • SWFMovie::save — Saves the SWF movie in a file
    • SWFMovie::saveToFile — Açıklama
    • SWFMovie::setbackground — Sets the background color
    • SWFMovie::setDimension — Sets the movie's width and height
    • SWFMovie::setFrames — Sets the total number of frames in the animation
    • SWFMovie::setRate — Sets the animation's frame rate
    • SWFMovie::startSound — Açıklama
    • SWFMovie::stopSound — Açıklama
    • SWFMovie::streamMP3 — Streams a MP3 file
    • SWFMovie::writeExports — Açıklama
  • SWFPrebuiltClip — The SWFPrebuiltClip class
    • SWFPrebuiltClip::__construct — Returns a SWFPrebuiltClip object
  • SWFShape — The SWFShape class
    • SWFShape::addFill — Adds a solid fill to the shape
    • SWFShape::__construct — Creates a new shape object
    • SWFShape::drawArc — Draws an arc of radius r centered at the current location, from angle startAngle to angle endAngle measured clockwise from 12 o'clock
    • SWFShape::drawCircle — Draws a circle of radius r centered at the current location, in a counter-clockwise fashion
    • SWFShape::drawCubic — Draws a cubic bezier curve using the current position and the three given points as control points
    • SWFShape::drawCubicTo — Draws a cubic bezier curve using the current position and the three given points as control points
    • SWFShape::drawCurve — Draws a curve (relative)
    • SWFShape::drawCurveTo — Draws a curve
    • SWFShape::drawGlyph — Draws the first character in the given string into the shape using the glyph definition from the given font
    • SWFShape::drawLine — Draws a line (relative)
    • SWFShape::drawLineTo — Draws a line
    • SWFShape::movePen — Moves the shape's pen (relative)
    • SWFShape::movePenTo — Moves the shape's pen
    • SWFShape::setLeftFill — Sets left rasterizing color
    • SWFShape::setLine — Sets the shape's line style
    • SWFShape::setRightFill — Sets right rasterizing color
  • SWFSound — The SWFSound class
    • SWFSound::__construct — Returns a new SWFSound object from given file
  • SWFSoundInstance — The SWFSoundInstance class
    • SWFSoundInstance::loopCount — Açıklama
    • SWFSoundInstance::loopInPoint — Açıklama
    • SWFSoundInstance::loopOutPoint — Açıklama
    • SWFSoundInstance::noMultiple — Açıklama
  • SWFSprite — The SWFSprite class
    • SWFSprite::add — Adds an object to a sprite
    • SWFSprite::__construct — Creates a movie clip (a sprite)
    • SWFSprite::labelFrame — Labels frame
    • SWFSprite::nextFrame — Moves to the next frame of the animation
    • SWFSprite::remove — Removes an object to a sprite
    • SWFSprite::setFrames — Sets the total number of frames in the animation
    • SWFSprite::startSound — Açıklama
    • SWFSprite::stopSound — Açıklama
  • SWFText — The SWFText class
    • SWFText::addString — Draws a string
    • SWFText::addUTF8String — Writes the given text into this SWFText object at the current pen position, using the current font, height, spacing, and color
    • SWFText::__construct — Creates a new SWFText object
    • SWFText::getAscent — Returns the ascent of the current font at its current size, or 0 if not available
    • SWFText::getDescent — Returns the descent of the current font at its current size, or 0 if not available
    • SWFText::getLeading — Returns the leading of the current font at its current size, or 0 if not available
    • SWFText::getUTF8Width — calculates the width of the given string in this text objects current font and size
    • SWFText::getWidth — Computes string's width
    • SWFText::moveTo — Moves the pen
    • SWFText::setColor — Sets the current text color
    • SWFText::setFont — Sets the current font
    • SWFText::setHeight — Sets the current font height
    • SWFText::setSpacing — Sets the current font spacing
  • SWFTextField — The SWFTextField class
    • SWFTextField::addChars — adds characters to a font that will be available within a textfield
    • SWFTextField::addString — Concatenates the given string to the text field
    • SWFTextField::align — Sets the text field alignment
    • SWFTextField::__construct — Creates a text field object
    • SWFTextField::setBounds — Sets the text field width and height
    • SWFTextField::setColor — Sets the color of the text field
    • SWFTextField::setFont — Sets the text field font
    • SWFTextField::setHeight — Sets the font height of this text field font
    • SWFTextField::setIndentation — Sets the indentation of the first line
    • SWFTextField::setLeftMargin — Sets the left margin width of the text field
    • SWFTextField::setLineSpacing — Sets the line spacing of the text field
    • SWFTextField::setMargins — Sets the margins width of the text field
    • SWFTextField::setName — Sets the variable name
    • SWFTextField::setPadding — Sets the padding of this textfield
    • SWFTextField::setRightMargin — Sets the right margin width of the text field
  • SWFVideoStream — The SWFVideoStream class
    • SWFVideoStream::__construct — Returns a SWFVideoStream object
    • SWFVideoStream::getNumFrames — Returns the number of frames in the video
    • SWFVideoStream::setDimension — Sets video dimension
HaruDestination::setXYZ
Giriş
Salt Metin Olmayan MIME Çıktılama


Giriş

First of all: Ming is not an acronym. Ming is an open-source (LGPL) library which allows you to create SWF ("Flash") format movies. Ming supports almost all of Flash 4's features, including: shapes, gradients, bitmaps (pngs and jpegs), morphs ("shape tweens"), text, buttons, actions, sprites ("movie clips"), streaming mp3, and color transforms --the only thing that's missing is sound events.

Note that all values specifying length, distance, size, etc. are in "twips", twenty units per pixel. That's pretty much arbitrary, though, since the player scales the movie to whatever pixel size is specified in the embed/object tag, or the entire frame if not embedded.

Ming offers a number of advantages over the existing PHP/libswf module. You can use Ming anywhere you can compile the code, whereas libswf is closed-source and only available for a few platforms, Windows not one of them. Ming provides some insulation from the mundane details of the SWF file format, wrapping the movie elements in PHP objects. Also, Ming is still being maintained; if there's a feature that you want to see, just let us know at » http://www.libming.org/.

Uyarı

Bu eklenti DENEYSELDİR. Bu eklentinin davranışı, işlev isimleri ve tüm belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu eklentiyi kullanmayın.

Bilginize:

Bu eklenti » PECL deposuna taşınmış olup şu sürümden itibaren PHP kaynak paketinde dağıtılmamaktatır: PHP 5.3.0.

Ming
Yapılandırma/Kurulum
Ming


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Ming


Gereksinimler

To use Ming with PHP, you first need to build and install the Ming library. Source code and installation instructions are available at the Ming home page: » http://www.libming.org/ along with examples, a small tutorial, and the latest news.

Download the ming archive. Unpack the archive. Go in the Ming directory. make. make install.

This will build libming.so and install it into /usr/lib/, and copy ming.h into /usr/include/. Edit the PREFIX= line in the Makefile to change the installation directory.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/ming.

Bu eklenti » PECL deposuna taşınmış olup şu sürümden itibaren PHP kaynak paketinde dağıtılmamaktatır: PHP 5.3.0

Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

MING_NEW (integer)
MING_ZLIB (integer)
SWFBUTTON_HIT (integer)
SWFBUTTON_DOWN (integer)
SWFBUTTON_OVER (integer)
SWFBUTTON_UP (integer)
SWFBUTTON_MOUSEUPOUTSIDE (integer)
SWFBUTTON_DRAGOVER (integer)
SWFBUTTON_DRAGOUT (integer)
SWFBUTTON_MOUSEUP (integer)
SWFBUTTON_MOUSEDOWN (integer)
SWFBUTTON_MOUSEOUT (integer)
SWFBUTTON_MOUSEOVER (integer)
SWFFILL_RADIAL_GRADIENT (integer)
SWFFILL_LINEAR_GRADIENT (integer)
SWFFILL_TILED_BITMAP (integer)
SWFFILL_CLIPPED_BITMAP (integer)
SWFTEXTFIELD_HASLENGTH (integer)
SWFTEXTFIELD_NOEDIT (integer)
SWFTEXTFIELD_PASSWORD (integer)
SWFTEXTFIELD_MULTILINE (integer)
SWFTEXTFIELD_WORDWRAP (integer)
SWFTEXTFIELD_DRAWBOX (integer)
SWFTEXTFIELD_NOSELECT (integer)
SWFTEXTFIELD_HTML (integer)
SWFTEXTFIELD_ALIGN_LEFT (integer)
SWFTEXTFIELD_ALIGN_RIGHT (integer)
SWFTEXTFIELD_ALIGN_CENTER (integer)
SWFTEXTFIELD_ALIGN_JUSTIFY (integer)
SWFACTION_ONLOAD (integer)
SWFACTION_ENTERFRAME (integer)
SWFACTION_UNLOAD (integer)
SWFACTION_MOUSEMOVE (integer)
SWFACTION_MOUSEDOWN (integer)
SWFACTION_MOUSEUP (integer)
SWFACTION_KEYDOWN (integer)
SWFACTION_KEYUP (integer)
SWFACTION_DATA (integer)
Özkaynak Türleri
Örnekler
Ming


Örnekler

İçindekiler

  • SWFAction Examples
  • SWFSPrite basic examples
Öntanımlı Sabitler
SWFAction Examples
Ming


SWFAction Examples

This simple example will move the red square across the window.

Örnek 1 swfaction() example

<?php
  $s = new SWFShape();
  $f = $s->addFill(0xff, 0, 0);
  $s->setRightFill($f);

  $s->movePenTo(-500, -500);
  $s->drawLineTo(500, -500);
  $s->drawLineTo(500, 500);
  $s->drawLineTo(-500, 500);
  $s->drawLineTo(-500, -500);

  $p = new SWFSprite();
  $i = $p->add($s);
  $i->setDepth(1);
  $p->nextFrame();

  for ($n=0; $n<5; ++$n) {
    $i->rotate(-15);
    $p->nextFrame();
  }

  $m = new SWFMovie();
  $m->setBackground(0xff, 0xff, 0xff);
  $m->setDimension(6000, 4000);

  $i = $m->add($p);
  $i->setDepth(1);
  $i->moveTo(-500,2000);
  $i->setName("box");

  $m->add(new SWFAction("/box.x += 3;"));
  $m->nextFrame();
  $m->add(new SWFAction("gotoFrame(0); play();"));
  $m->nextFrame();

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

This simple example tracks down your mouse on the screen.

Örnek 2 swfaction() example

<?php

  $m = new SWFMovie();
  $m->setRate(36.0);
  $m->setDimension(1200, 800);
  $m->setBackground(0, 0, 0);

  /* mouse tracking sprite - empty, but follows mouse so we can
     get its x and y coordinates */

  $i = $m->add(new SWFSprite());
  $i->setName('mouse');

  $m->add(new SWFAction("
    startDrag('/mouse', 1); /* '1' means lock sprite to the mouse */
  "));

  /* might as well turn off antialiasing, since these are just squares. */

  $m->add(new SWFAction("
    this.quality = 0;
  "));

  /* morphing box */
  $r = new SWFMorph();
  $s = $r->getShape1();

  /* Note this is backwards from normal shapes.  No idea why. */
  $s->setLeftFill($s->addFill(0xff, 0xff, 0xff));
  $s->movePenTo(-40, -40);
  $s->drawLine(80, 0);
  $s->drawLine(0, 80);
  $s->drawLine(-80, 0);
  $s->drawLine(0, -80);

  $s = $r->getShape2();

  $s->setLeftFill($s->addFill(0x00, 0x00, 0x00));
  $s->movePenTo(-1, -1);
  $s->drawLine(2, 0);
  $s->drawLine(0, 2);
  $s->drawLine(-2, 0);
  $s->drawLine(0, -2);

  /* sprite container for morphing box -
     this is just a timeline w/ the box morphing */

  $box = new SWFSprite();
  $box->add(new SWFAction("
    stop();
  "));
  $i = $box->add($r);

  for ($n=0; $n<=20; ++$n) {
    $i->setRatio($n/20);
    $box->nextFrame();
  }

  /* this container sprite allows us to use the same action code many times */

  $cell = new SWFSprite();
  $i = $cell->add($box);
  $i->setName('box');

  $cell->add(new SWFAction("

    setTarget('box');

    /* ...x means the x coordinate of the parent, i.e. (..).x */
    dx = (/mouse.x + random(6)-3 - ...x)/5;
    dy = (/mouse.y + random(6)-3 - ...y)/5;
    gotoFrame(int(dx*dx + dy*dy));

  "));

  $cell->nextFrame();
  $cell->add(new SWFAction("

    gotoFrame(0);
    play();

  "));

  $cell->nextFrame();

  /* finally, add a bunch of the cells to the movie */

  for ($x=0; $x<12; ++$x) {
    for ($y=0; $y<8; ++$y) {
      $i = $m->add($cell);
      $i->moveTo(100*$x+50, 100*$y+50);
    }
  }

  $m->nextFrame();

  $m->add(new SWFAction("

    gotoFrame(1);
    play();

  "));

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

Same as above, but with nice colored balls...

Örnek 3 swfaction() example

<?php

  $m = new SWFMovie();
  $m->setDimension(11000, 8000);
  $m->setBackground(0x00, 0x00, 0x00);

  $m->add(new SWFAction("

this.quality = 0;
/frames.visible = 0;
startDrag('/mouse', 1);

  "));

  // mouse tracking sprite
  $t = new SWFSprite();
  $i = $m->add($t);
  $i->setName('mouse');

  $g = new SWFGradient();
  $g->addEntry(0, 0xff, 0xff, 0xff, 0xff);
  $g->addEntry(0.1, 0xff, 0xff, 0xff, 0xff);
  $g->addEntry(0.5, 0xff, 0xff, 0xff, 0x5f);
  $g->addEntry(1.0, 0xff, 0xff, 0xff, 0);

  // gradient shape thing
  $s = new SWFShape();
  $f = $s->addFill($g, SWFFILL_RADIAL_GRADIENT);
  $f->scaleTo(0.03);
  $s->setRightFill($f);
  $s->movePenTo(-600, -600);
  $s->drawLine(1200, 0);
  $s->drawLine(0, 1200);
  $s->drawLine(-1200, 0);
  $s->drawLine(0, -1200);

  // need to make this a sprite so we can multColor it
  $p = new SWFSprite();
  $p->add($s);
  $p->nextFrame();

  // put the shape in here, each frame a different color
  $q = new SWFSprite();
  $q->add(new SWFAction("gotoFrame(random(7)+1); stop();"));
  $i = $q->add($p);

  $i->multColor(1.0, 1.0, 1.0);
  $q->nextFrame();
  $i->multColor(1.0, 0.5, 0.5);
  $q->nextFrame();
  $i->multColor(1.0, 0.75, 0.5);
  $q->nextFrame();
  $i->multColor(1.0, 1.0, 0.5);
  $q->nextFrame();
  $i->multColor(0.5, 1.0, 0.5);
  $q->nextFrame();
  $i->multColor(0.5, 0.5, 1.0);
  $q->nextFrame();
  $i->multColor(1.0, 0.5, 1.0);
  $q->nextFrame();

  // finally, this one contains the action code
  $p = new SWFSprite();
  $i = $p->add($q);
  $i->setName('frames');
  $p->add(new SWFAction("

dx = (/:mousex-/:lastx)/3 + random(10)-5;
dy = (/:mousey-/:lasty)/3;
x = /:mousex;
y = /:mousey;
alpha = 100;

  "));
  $p->nextFrame();

  $p->add(new SWFAction("

this.x = x;
this.y = y;
this.alpha = alpha;
x += dx;
y += dy;
dy += 3;
alpha -= 8;

  "));
  $p->nextFrame();

  $p->add(new SWFAction("prevFrame(); play();"));
  $p->nextFrame();

  $i = $m->add($p);
  $i->setName('frames');
  $m->nextFrame();

  $m->add(new SWFAction("

lastx = mousex;
lasty = mousey;
mousex = /mouse.x;
mousey = /mouse.y;

++num;

if (num == 11)
  num = 1;

removeClip('char' & num);
duplicateClip(/frames, 'char' & num, num);

  "));

  $m->nextFrame();
  $m->add(new SWFAction("prevFrame(); play();"));

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

Örnekler
SWFSPrite basic examples
Örnekler


SWFSPrite basic examples

This simple example will spin gracefully a big red square.

Örnek 1 swfsprite() example

<?php
$s = new SWFShape();
$s->setRightFill($s->addFill(0xff, 0, 0));
$s->movePenTo(-500, -500);
$s->drawLineTo(500, -500);
$s->drawLineTo(500, 500);
$s->drawLineTo(-500, 500);
$s->drawLineTo(-500, -500);

$p = new SWFSprite();
$i = $p->add($s);
$p->nextFrame();
$i->rotate(15);
$p->nextFrame();
$i->rotate(15);
$p->nextFrame();
$i->rotate(15);
$p->nextFrame();
$i->rotate(15);
$p->nextFrame();
$i->rotate(15);
$p->nextFrame();

$m = new SWFMovie();
$i = $m->add($p);
$i->moveTo(1500, 1000);
$i->setName("blah");

$m->setBackground(0xff, 0xff, 0xff);
$m->setDimension(3000, 2000);

header('Content-type: application/x-shockwave-flash');
$m->output();
?>

SWFAction Examples
Ming İşlevleri
Örnekler


Ming İşlevleri

İçindekiler

  • ming_keypress — Returns the action flag for keyPress(char)
  • ming_setcubicthreshold — Set cubic threshold
  • ming_setscale — Set the global scaling factor.
  • ming_setswfcompression — Sets the SWF output compression
  • ming_useconstants — Use constant pool
  • ming_useswfversion — Sets the SWF version
SWFSPrite basic examples
ming_keypress
Ming


Returns the action flag for keyPress(char)

Ming İşlevleri
ming_setcubicthreshold
Ming İşlevleri
PHP Manual

ming_keypress

(PHP 5 <= 5.3.0, PECL ming SVN)

ming_keypress — Returns the action flag for keyPress(char)

Açıklama

int ming_keypress ( string $char )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Ming İşlevleri
ming_setcubicthreshold
Ming İşlevleri


Set cubic threshold

ming_keypress
ming_setscale
Ming İşlevleri
PHP Manual

ming_setcubicthreshold

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PECL ming SVN)

ming_setcubicthreshold — Set cubic threshold

Açıklama

void ming_setcubicthreshold ( int $threshold )

Sets the threshold error for drawing cubic beziers.

Değiştirgeler

threshold

The Threshold. Lower is more accurate, hence larger file size.

Dönen Değerler

Hiçbir değer dönmez.

ming_keypress
ming_setscale
Ming İşlevleri


Set the global scaling factor.

ming_setcubicthreshold
ming_setswfcompression
Ming İşlevleri
PHP Manual

ming_setscale

(PHP 4 >= 4.0.5, PHP 5, PHP 7, PECL ming SVN)

ming_setscale — Set the global scaling factor.

Açıklama

void ming_setscale ( float $scale )

Sets the scale of the output SWF. Inside the SWF file, coordinates are measured in TWIPS, rather than PIXELS. There are 20 TWIPS in 1 pixel.

Değiştirgeler

scale

The scale to be set.

Dönen Değerler

Hiçbir değer dönmez.

ming_setcubicthreshold
ming_setswfcompression
Ming İşlevleri


Sets the SWF output compression

ming_setscale
ming_useconstants
Ming İşlevleri
PHP Manual

ming_setswfcompression

(PHP 5.2.1-5.3.0, PHP 7, PECL ming SVN)

ming_setswfcompression — Sets the SWF output compression

Açıklama

void ming_setswfcompression ( int $level )

Sets the SWF output compression level.

Değiştirgeler

level

The new compression level. Should be a value between 1 and 9 inclusive.

Dönen Değerler

Hiçbir değer dönmez.

ming_setscale
ming_useconstants
Ming İşlevleri


Use constant pool

ming_setswfcompression
ming_useswfversion
Ming İşlevleri
PHP Manual

ming_useconstants

(PHP 5 <= 5.3.0, PECL ming SVN)

ming_useconstants — Use constant pool

Açıklama

void ming_useconstants ( int $use )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Dönen Değerler

Hiçbir değer dönmez.

ming_setswfcompression
ming_useswfversion
Ming İşlevleri


Sets the SWF version

ming_useconstants
SWFAction
Ming İşlevleri
PHP Manual

ming_useswfversion

(PHP 4 >= 4.2.0, PHP 5 <= 5.3.0, PECL ming SVN)

ming_useswfversion — Sets the SWF version

Açıklama

void ming_useswfversion ( int $version )

Sets the SWF version to be used in the movie. This affect the bahaviour of Action Script.

Değiştirgeler

version

SWF version to use.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 ming_useswfversion() example

<?php

$movie = new SWFMovie();
ming_useswfversion(4); // Flash 4

?>

ming_useconstants
SWFAction
Ming İşlevleri


The SWFAction class

(PHP 5 <= 5.3.0, PECL ming SVN)

Giriş

SWFAction.

Sınıf Sözdizimi

SWFAction {
/* Yöntemler */
__construct ( string $script )
}

Açıklama

The script syntax is based on the C language, but with a lot taken out- the SWF bytecode machine is just too simpleminded to do a lot of things we might like. For instance, we can't implement function calls without a tremendous amount of hackery because the jump bytecode has a hardcoded offset value. No pushing your calling address to the stack and returning- every function would have to know exactly where to return to.

So what's left? The compiler recognises the following tokens:

  • break
  • for
  • continue
  • if
  • else
  • do
  • while

There is no typed data; all values in the SWF action machine are stored as strings. The following functions can be used in expressions:

time()
Returns the number of milliseconds (?) elapsed since the movie started.
random(seed)
Returns a pseudo-random number in the range 0-seed.
length(expr)
Returns the length of the given expression.
int(number)
Returns the given number rounded down to the nearest integer.
concat(expr, expr)
Returns the concatenation of the given expressions.
ord(expr)
Returns the ASCII code for the given character
chr(num)
Returns the character for the given ASCII code
substr(string, location, length)
Returns the substring of length length at location location of the given string string.

Additionally, the following commands may be used:

duplicateClip(clip, name, depth)
Duplicate the named movie clip (aka sprite). The new movie clip has name name and is at depth depth.
removeClip(expr)
Removes the named movie clip.
trace(expr)
Write the given expression to the trace log. Doubtful that the browser plugin does anything with this.
startDrag(target, lock, [left, top, right, bottom])
Start dragging the movie clip target. The lock argument indicates whether to lock the mouse (?)- use 0 (FALSE) or 1 (TRUE). Optional parameters define a bounding area for the dragging.
stopDrag()
Stop dragging my heart around. And this movie clip, too.
callFrame(expr)
Call the named frame as a function.
getURL(url, target, [method])
Load the given URL into the named target. The target argument corresponds to HTML document targets (such as "_top" or "_blank"). The optional method argument can be POST or GET if you want to submit variables back to the server.
loadMovie(url, target)
Load the given URL into the named target. The target argument can be a frame name (I think), or one of the magical values "_level0" (replaces current movie) or "_level1" (loads new movie on top of current movie).
nextFrame()
Go to the next frame.
prevFrame()
Go to the last (or, rather, previous) frame.
play()
Start playing the movie.
stop()
Stop playing the movie.
toggleQuality()
Toggle between high and low quality.
stopSounds()
Stop playing all sounds.
gotoFrame(num)
Go to frame number num. Frame numbers start at 0.
gotoFrame(name)
Go to the frame named name. Which does a lot of good, since I haven't added frame labels yet.
setTarget(expr)
Sets the context for action. Or so they say- I really have no idea what this does.
And there's one weird extra thing. The expression frameLoaded(num) can be used in if statements and while loops to check if the given frame number has been loaded yet. Well, it's supposed to, anyway, but I've never tested it and I seriously doubt it actually works. You can just use /:framesLoaded instead.

Movie clips (all together now- aka sprites) have properties. You can read all of them (or can you?), you can set some of them, and here they are:

  • x
  • y
  • xScale
  • yScale
  • currentFrame - (read-only)
  • totalFrames - (read-only)
  • alpha - transparency level
  • visible - 1=on, 0=off (?)
  • width - (read-only)
  • height - (read-only)
  • rotation
  • target - (read-only) (???)
  • framesLoaded - (read-only)
  • name
  • dropTarget - (read-only) (???)
  • url - (read-only) (???)
  • highQuality - 1=high, 0=low (?)
  • focusRect - (???)
  • soundBufTime - (???)
So, setting a sprite's x position is as simple as /box.x = 100;. Why the slash in front of the box, though? That's how flash keeps track of the sprites in the movie, just like a Unix filesystem- here it shows that box is at the top level. If the sprite named box had another sprite named biff inside of it, you'd set its x position with /box/biff.x = 100;. At least, I think so; correct me if I'm wrong here.

İçindekiler

  • SWFAction::__construct — Creates a new SWFAction
ming_useswfversion
SWFAction::__construct
Ming


Creates a new SWFAction

SWFAction
SWFBitmap
SWFAction
PHP Manual

SWFAction::__construct

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFAction::__construct — Creates a new SWFAction

Açıklama

SWFAction::__construct ( string $script )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Creates a new SWFAction and compiles the given script in it.

Değiştirgeler

script

An ActionScript snippet to associate with the SWFAction. See SWFAction for more details.

SWFAction
SWFBitmap
SWFAction


The SWFBitmap class

(PHP 5 <= 5.3.0, PECL ming SVN)

Giriş

SWFBitmap.

Sınıf Sözdizimi

SWFBitmap {
/* Yöntemler */
__construct ( mixed $file [, mixed $alphafile ] )
float getHeight ( void )
float getWidth ( void )
}

İçindekiler

  • SWFBitmap::__construct — Loads Bitmap object
  • SWFBitmap::getHeight — Returns the bitmap's height
  • SWFBitmap::getWidth — Returns the bitmap's width
SWFAction::__construct
SWFBitmap::__construct
Ming


Loads Bitmap object

SWFBitmap
SWFBitmap::getHeight
SWFBitmap
PHP Manual

SWFBitmap::__construct

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFBitmap::__construct — Loads Bitmap object

Açıklama

SWFBitmap::__construct ( mixed $file [, mixed $alphafile ] )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Creates the new SWFBitmap object from the given file.

Değiştirgeler

For both parameters you can provide a file pointer returned by fopen() or the image data, as a binary string.

file

Bilginize:

We can only deal with baseline (frame 0) jpegs, no baseline optimized or progressive scan jpegs!

You can't import png images directly, though- have to use the png2dbl utility to make a dbl ("define bits lossless") file from the png. The reason for this is that I don't want a dependency on the png library in ming- autoconf should solve this, but that's not set up yet.

alphafile

An MSK file to be used as an alpha mask for a JPEG image.

Örnekler

Örnek 1 Importing a DBL file

<?php
$s = new SWFShape();
$f = $s->addFill(new SWFBitmap(file_get_contents("image.dbl")));
$s->setRightFill($f);

$s->drawLine(32, 0);
$s->drawLine(0, 32);
$s->drawLine(-32, 0);
$s->drawLine(0, -32);

$m = new SWFMovie();
$m->setDimension(32, 32);
$m->add($s);

header('Content-type: application/x-shockwave-flash');
$m->output();
?>

Örnek 2 Using an alpha mask

<?php

$s = new SWFShape();

// .msk file generated with "gif2mask" utility
$f = $s->addFill(new SWFBitmap(file_get_contents("alphafill.jpg"), file_get_contents("alphafill.msk")));
$s->setRightFill($f);

$s->drawLine(640, 0);
$s->drawLine(0, 480);
$s->drawLine(-640, 0);
$s->drawLine(0, -480);

$c = new SWFShape();
$c->setRightFill($c->addFill(0x99, 0x99, 0x99));
$c->drawLine(40, 0);
$c->drawLine(0, 40);
$c->drawLine(-40, 0);
$c->drawLine(0, -40);

$m = new SWFMovie();
$m->setDimension(640, 480);
$m->setBackground(0xcc, 0xcc, 0xcc);

// draw checkerboard background
for ($y=0; $y<480; $y+=40) {
  for ($x=0; $x<640; $x+=80) {
    $i = $m->add($c);
    $i->moveTo($x, $y);
  }

  $y+=40;

  for ($x=40; $x<640; $x+=80) {
    $i = $m->add($c);
    $i->moveTo($x, $y);
  }
}

$m->add($s);

header('Content-type: application/x-shockwave-flash');
$m->output();
?>

SWFBitmap
SWFBitmap::getHeight
SWFBitmap


Returns the bitmap's height

SWFBitmap::__construct
SWFBitmap::getWidth
SWFBitmap
PHP Manual

SWFBitmap::getHeight

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFBitmap::getHeight — Returns the bitmap's height

Açıklama

float SWFBitmap::getHeight ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Returns the bitmap's height.

Dönen Değerler

Returns the bitmap height in pixels.

Ayrıca Bakınız

  • SWFBitmap::getWidth() - Returns the bitmap's width

SWFBitmap::__construct
SWFBitmap::getWidth
SWFBitmap


Returns the bitmap's width

SWFBitmap::getHeight
SWFButton
SWFBitmap
PHP Manual

SWFBitmap::getWidth

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFBitmap::getWidth — Returns the bitmap's width

Açıklama

float SWFBitmap::getWidth ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Returns the bitmap's width.

Dönen Değerler

Returns the bitmap width in pixels.

Ayrıca Bakınız

  • SWFBitmap::getHeight() - Returns the bitmap's height

SWFBitmap::getHeight
SWFButton
SWFBitmap


The SWFButton class

(PHP 5 <= 5.3.0, PECL ming SVN)

Giriş

SWFButton.

Sınıf Sözdizimi

SWFButton {
/* Yöntemler */
void addAction ( SWFAction $action , int $flags )
SWFSoundInstance addASound ( SWFSound $sound , int $flags )
void addShape ( SWFShape $shape , int $flags )
__construct ( void )
void setAction ( SWFAction $action )
void setDown ( SWFShape $shape )
void setHit ( SWFShape $shape )
void setMenu ( int $flag )
void setOver ( SWFShape $shape )
void setUp ( SWFShape $shape )
}

İçindekiler

  • SWFButton::addAction — Adds an action
  • SWFButton::addASound — Associates a sound with a button transition
  • SWFButton::addShape — Adds a shape to a button
  • SWFButton::__construct — Creates a new Button
  • SWFButton::setAction — Sets the action
  • SWFButton::setDown — Alias for addShape(shape, SWFBUTTON_DOWN)
  • SWFButton::setHit — Alias for addShape(shape, SWFBUTTON_HIT)
  • SWFButton::setMenu — enable track as menu button behaviour
  • SWFButton::setOver — Alias for addShape(shape, SWFBUTTON_OVER)
  • SWFButton::setUp — Alias for addShape(shape, SWFBUTTON_UP)
SWFBitmap::getWidth
SWFButton::addAction
Ming


Adds an action

SWFButton
SWFButton::addASound
SWFButton
PHP Manual

SWFButton::addAction

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFButton::addAction — Adds an action

Açıklama

void SWFButton::addAction ( SWFAction $action , int $flags )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Adds the given action to the button for the given conditions.

Değiştirgeler

action

An SWFAction, returned by SWFAction::__construct().

flags

The following flags are valid: SWFBUTTON_MOUSEOVER, SWFBUTTON_MOUSEOUT, SWFBUTTON_MOUSEUP, SWFBUTTON_MOUSEUPOUTSIDE, SWFBUTTON_MOUSEDOWN, SWFBUTTON_DRAGOUT and SWFBUTTON_DRAGOVER.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SWFButton::addShape() - Adds a shape to a button
  • SWFAction

SWFButton
SWFButton::addASound
SWFButton


Associates a sound with a button transition

SWFButton::addAction
SWFButton::addShape
SWFButton
PHP Manual

SWFButton::addASound

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFButton::addASound — Associates a sound with a button transition

Açıklama

SWFSoundInstance SWFButton::addASound ( SWFSound $sound , int $flags )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

SWFButton::addAction
SWFButton::addShape
SWFButton


Adds a shape to a button

SWFButton::addASound
SWFButton::__construct
SWFButton
PHP Manual

SWFButton::addShape

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFButton::addShape — Adds a shape to a button

Açıklama

void SWFButton::addShape ( SWFShape $shape , int $flags )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Adds the given shape to the button.

Değiştirgeler

shape

An SWFShape instance

flags

The following flags are valid: SWFBUTTON_UP, SWFBUTTON_OVER, SWFBUTTON_DOWN and SWFBUTTON_HIT.

SWFBUTTON_HIT isn't ever displayed, it defines the hit region for the button. That is, everywhere the hit shape would be drawn is considered a "touchable" part of the button.

Dönen Değerler

Hiçbir değer dönmez.

SWFButton::addASound
SWFButton::__construct
SWFButton


Creates a new Button

SWFButton::addShape
SWFButton::setAction
SWFButton
PHP Manual

SWFButton::__construct

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFButton::__construct — Creates a new Button

Açıklama

SWFButton::__construct ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Creates a new Button.

Örnekler

This simple example will show your usual interactions with buttons : rollover, rollon, mouseup, mousedown, noaction.

Örnek 1 Usual interactions with buttons

<?php

$f = new SWFFont("_serif");

$p = new SWFSprite();

function label($string)
{
  global $f;

  $t = new SWFTextField();
  $t->setFont($f);
  $t->addString($string);
  $t->setHeight(200);
  $t->setBounds(3200, 200);
  return $t;
}

function addLabel($string)
{
  global $p;

  $i = $p->add(label($string));
  $p->nextFrame();
  $p->remove($i);
}

$p->add(new SWFAction("stop();"));
addLabel("NO ACTION");
addLabel("SWFBUTTON_MOUSEUP");
addLabel("SWFBUTTON_MOUSEDOWN");
addLabel("SWFBUTTON_MOUSEOVER");
addLabel("SWFBUTTON_MOUSEOUT");
addLabel("SWFBUTTON_MOUSEUPOUTSIDE");
addLabel("SWFBUTTON_DRAGOVER");
addLabel("SWFBUTTON_DRAGOUT");

function rect($r, $g, $b)
{
  $s = new SWFShape();
  $s->setRightFill($s->addFill($r, $g, $b));
  $s->drawLine(600, 0);
  $s->drawLine(0, 600);
  $s->drawLine(-600, 0);
  $s->drawLine(0, -600);

  return $s;
}

$b = new SWFButton();
$b->addShape(rect(0xff, 0, 0), SWFBUTTON_UP | SWFBUTTON_HIT);
$b->addShape(rect(0, 0xff, 0), SWFBUTTON_OVER);
$b->addShape(rect(0, 0, 0xff), SWFBUTTON_DOWN);

$b->addAction(new SWFAction("setTarget('/label'); gotoFrame(1);"),
          SWFBUTTON_MOUSEUP);

$b->addAction(new SWFAction("setTarget('/label'); gotoFrame(2);"),
      SWFBUTTON_MOUSEDOWN);

$b->addAction(new SWFAction("setTarget('/label'); gotoFrame(3);"),
      SWFBUTTON_MOUSEOVER);

$b->addAction(new SWFAction("setTarget('/label'); gotoFrame(4);"),
      SWFBUTTON_MOUSEOUT);

$b->addAction(new SWFAction("setTarget('/label'); gotoFrame(5);"),
      SWFBUTTON_MOUSEUPOUTSIDE);

$b->addAction(new SWFAction("setTarget('/label'); gotoFrame(6);"),
      SWFBUTTON_DRAGOVER);

$b->addAction(new SWFAction("setTarget('/label'); gotoFrame(7);"),
      SWFBUTTON_DRAGOUT);

$m = new SWFMovie();
$m->setDimension(4000, 3000);

$i = $m->add($p);
$i->setName("label");
$i->moveTo(400, 1900);

$i = $m->add($b);
$i->moveTo(400, 900);

header('Content-type: application/x-shockwave-flash');
$m->output();
?>

This simple example will enables you to drag draw a big red button on the windows. No drag-and-drop, just moving around.

Örnek 2 Drag example

<?php

$s = new SWFShape();
$s->setRightFill($s->addFill(0xff, 0, 0));
$s->drawLine(1000,0);
$s->drawLine(0,1000);
$s->drawLine(-1000,0);
$s->drawLine(0,-1000);

$b = new SWFButton();
$b->addShape($s, SWFBUTTON_HIT | SWFBUTTON_UP | SWFBUTTON_DOWN | SWFBUTTON_OVER);

$b->addAction(new SWFAction("startDrag('/test', 0);"), // '0' means don't lock to mouse
      SWFBUTTON_MOUSEDOWN);

$b->addAction(new SWFAction("stopDrag();"),
      SWFBUTTON_MOUSEUP | SWFBUTTON_MOUSEUPOUTSIDE);

$p = new SWFSprite();
$p->add($b);
$p->nextFrame();

$m = new SWFMovie();
$i = $m->add($p);
$i->setName('test');
$i->moveTo(1000,1000);

header('Content-type: application/x-shockwave-flash');
$m->output();
?>

SWFButton::addShape
SWFButton::setAction
SWFButton


Sets the action

SWFButton::__construct
SWFButton::setDown
SWFButton
PHP Manual

SWFButton::setAction

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFButton::setAction — Sets the action

Açıklama

void SWFButton::setAction ( SWFAction $action )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Sets the action to be performed when the button is clicked.

This is a shortcut for SWFButton::addAction() called with the SWFBUTTON_MOUSEUP flag.

Değiştirgeler

action

An SWFAction, returned by SWFAction::__construct().

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SWFButton::addAction() - Adds an action
  • SWFAction

SWFButton::__construct
SWFButton::setDown
SWFButton


Alias for addShape(shape, SWFBUTTON_DOWN)

SWFButton::setAction
SWFButton::setHit
SWFButton
PHP Manual

SWFButton::setDown

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFButton::setDown — Alias for addShape(shape, SWFBUTTON_DOWN)

Açıklama

void SWFButton::setDown ( SWFShape $shape )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swfbutton::setdown() alias for addShape(shape, SWFBUTTON_DOWN).

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SWFButton::addShape() - Adds a shape to a button
  • SWFAction

SWFButton::setAction
SWFButton::setHit
SWFButton


Alias for addShape(shape, SWFBUTTON_HIT)

SWFButton::setDown
SWFButton::setMenu
SWFButton
PHP Manual

SWFButton::setHit

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFButton::setHit — Alias for addShape(shape, SWFBUTTON_HIT)

Açıklama

void SWFButton::setHit ( SWFShape $shape )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swfbutton::sethit() alias for addShape(shape, SWFBUTTON_HIT).

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SWFButton::addShape() - Adds a shape to a button
  • SWFAction

SWFButton::setDown
SWFButton::setMenu
SWFButton


enable track as menu button behaviour

SWFButton::setHit
SWFButton::setOver
SWFButton
PHP Manual

SWFButton::setMenu

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFButton::setMenu — enable track as menu button behaviour

Açıklama

void SWFButton::setMenu ( int $flag )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

flag

This parameter can be used for a slight different behavior of buttons. You can set it to 0 (off) or 1 (on).

Dönen Değerler

Hiçbir değer dönmez.

SWFButton::setHit
SWFButton::setOver
SWFButton


Alias for addShape(shape, SWFBUTTON_OVER)

SWFButton::setMenu
SWFButton::setUp
SWFButton
PHP Manual

SWFButton::setOver

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFButton::setOver — Alias for addShape(shape, SWFBUTTON_OVER)

Açıklama

void SWFButton::setOver ( SWFShape $shape )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swfbutton::setover() alias for addShape(shape, SWFBUTTON_OVER).

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SWFButton::addShape() - Adds a shape to a button
  • SWFAction

SWFButton::setMenu
SWFButton::setUp
SWFButton


Alias for addShape(shape, SWFBUTTON_UP)

SWFButton::setOver
SWFDisplayItem
SWFButton
PHP Manual

SWFButton::setUp

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFButton::setUp — Alias for addShape(shape, SWFBUTTON_UP)

Açıklama

void SWFButton::setUp ( SWFShape $shape )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swfbutton::setup() alias for addShape(shape, SWFBUTTON_UP).

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SWFButton::addShape() - Adds a shape to a button
  • SWFAction

SWFButton::setOver
SWFDisplayItem
SWFButton


The SWFDisplayItem class

(PHP 5 <= 5.3.0, PECL ming SVN)

Giriş

SWFDisplayItem.

Sınıf Sözdizimi

SWFDisplayItem {
/* Yöntemler */
void addAction ( SWFAction $action , int $flags )
void addColor ( int $red , int $green , int $blue [, int $a ] )
void endMask ( void )
float getRot ( void )
float getX ( void )
float getXScale ( void )
float getXSkew ( void )
float getY ( void )
float getYScale ( void )
float getYSkew ( void )
void move ( float $dx , float $dy )
void moveTo ( float $x , float $y )
void multColor ( float $red , float $green , float $blue [, float $a ] )
void remove ( void )
void rotate ( float $angle )
void rotateTo ( float $angle )
void scale ( float $dx , float $dy )
void scaleTo ( float $x [, float $y ] )
void setDepth ( int $depth )
void setMaskLevel ( int $level )
void setMatrix ( float $a , float $b , float $c , float $d , float $x , float $y )
void setName ( string $name )
void setRatio ( float $ratio )
void skewX ( float $ddegrees )
void skewXTo ( float $degrees )
void skewY ( float $ddegrees )
void skewYTo ( float $degrees )
}

İçindekiler

  • SWFDisplayItem::addAction — Adds this SWFAction to the given SWFSprite instance
  • SWFDisplayItem::addColor — Adds the given color to this item's color transform
  • SWFDisplayItem::endMask — Another way of defining a MASK layer
  • SWFDisplayItem::getRot — Açıklama
  • SWFDisplayItem::getX — Açıklama
  • SWFDisplayItem::getXScale — Açıklama
  • SWFDisplayItem::getXSkew — Açıklama
  • SWFDisplayItem::getY — Açıklama
  • SWFDisplayItem::getYScale — Açıklama
  • SWFDisplayItem::getYSkew — Açıklama
  • SWFDisplayItem::move — Moves object in relative coordinates
  • SWFDisplayItem::moveTo — Moves object in global coordinates
  • SWFDisplayItem::multColor — Multiplies the item's color transform
  • SWFDisplayItem::remove — Removes the object from the movie
  • SWFDisplayItem::rotate — Rotates in relative coordinates
  • SWFDisplayItem::rotateTo — Rotates the object in global coordinates
  • SWFDisplayItem::scale — Scales the object in relative coordinates
  • SWFDisplayItem::scaleTo — Scales the object in global coordinates
  • SWFDisplayItem::setDepth — Sets z-order
  • SWFDisplayItem::setMaskLevel — Defines a MASK layer at level
  • SWFDisplayItem::setMatrix — Sets the item's transform matrix
  • SWFDisplayItem::setName — Sets the object's name
  • SWFDisplayItem::setRatio — Sets the object's ratio
  • SWFDisplayItem::skewX — Sets the X-skew
  • SWFDisplayItem::skewXTo — Sets the X-skew
  • SWFDisplayItem::skewY — Sets the Y-skew
  • SWFDisplayItem::skewYTo — Sets the Y-skew
SWFButton::setUp
SWFDisplayItem::addAction
Ming


Adds this SWFAction to the given SWFSprite instance

SWFDisplayItem
SWFDisplayItem::addColor
SWFDisplayItem
PHP Manual

SWFDisplayItem::addAction

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFDisplayItem::addAction — Adds this SWFAction to the given SWFSprite instance

Açıklama

void SWFDisplayItem::addAction ( SWFAction $action , int $flags )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

action

An SWFAction, returned by SWFAction::__construct().

flags

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SWFAction

SWFDisplayItem
SWFDisplayItem::addColor
SWFDisplayItem


Adds the given color to this item's color transform

SWFDisplayItem::addAction
SWFDisplayItem::endMask
SWFDisplayItem
PHP Manual

SWFDisplayItem::addColor

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFDisplayItem::addColor — Adds the given color to this item's color transform

Açıklama

void SWFDisplayItem::addColor ( int $red , int $green , int $blue [, int $a ] )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swfdisplayitem::addcolor() adds the color to this item's color transform. The color is given in its RGB form.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie::add().

Dönen Değerler

Hiçbir değer dönmez.

Dönen Değerler

Hiçbir değer dönmez.

SWFDisplayItem::addAction
SWFDisplayItem::endMask
SWFDisplayItem


Another way of defining a MASK layer

SWFDisplayItem::addColor
SWFDisplayItem::getRot
SWFDisplayItem
PHP Manual

SWFDisplayItem::endMask

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFDisplayItem::endMask — Another way of defining a MASK layer

Açıklama

void SWFDisplayItem::endMask ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Dönen Değerler

Hiçbir değer dönmez.

SWFDisplayItem::addColor
SWFDisplayItem::getRot
SWFDisplayItem


SWFDisplayItem::endMask
SWFDisplayItem::getX
SWFDisplayItem
PHP Manual

SWFDisplayItem::getRot

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFDisplayItem::getRot —

Açıklama

float SWFDisplayItem::getRot ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

SWFDisplayItem::endMask
SWFDisplayItem::getX
SWFDisplayItem


SWFDisplayItem::getRot
SWFDisplayItem::getXScale
SWFDisplayItem
PHP Manual

SWFDisplayItem::getX

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFDisplayItem::getX —

Açıklama

float SWFDisplayItem::getX ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Ayrıca Bakınız

  • SWFDisplayItem::getY() - Açıklama

SWFDisplayItem::getRot
SWFDisplayItem::getXScale
SWFDisplayItem


SWFDisplayItem::getX
SWFDisplayItem::getXSkew
SWFDisplayItem
PHP Manual

SWFDisplayItem::getXScale

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFDisplayItem::getXScale —

Açıklama

float SWFDisplayItem::getXScale ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Ayrıca Bakınız

  • SWFDisplayItem::getYScale() - Açıklama

SWFDisplayItem::getX
SWFDisplayItem::getXSkew
SWFDisplayItem


SWFDisplayItem::getXScale
SWFDisplayItem::getY
SWFDisplayItem
PHP Manual

SWFDisplayItem::getXSkew

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFDisplayItem::getXSkew —

Açıklama

float SWFDisplayItem::getXSkew ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Ayrıca Bakınız

  • SWFDisplayItem::getYSkew() - Açıklama

SWFDisplayItem::getXScale
SWFDisplayItem::getY
SWFDisplayItem


SWFDisplayItem::getXSkew
SWFDisplayItem::getYScale
SWFDisplayItem
PHP Manual

SWFDisplayItem::getY

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFDisplayItem::getY —

Açıklama

float SWFDisplayItem::getY ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Ayrıca Bakınız

  • SWFDisplayItem::getX() - Açıklama

SWFDisplayItem::getXSkew
SWFDisplayItem::getYScale
SWFDisplayItem


SWFDisplayItem::getY
SWFDisplayItem::getYSkew
SWFDisplayItem
PHP Manual

SWFDisplayItem::getYScale

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFDisplayItem::getYScale —

Açıklama

float SWFDisplayItem::getYScale ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Ayrıca Bakınız

  • SWFDisplayItem::getXScale() - Açıklama

SWFDisplayItem::getY
SWFDisplayItem::getYSkew
SWFDisplayItem


SWFDisplayItem::getYScale
SWFDisplayItem::move
SWFDisplayItem
PHP Manual

SWFDisplayItem::getYSkew

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFDisplayItem::getYSkew —

Açıklama

float SWFDisplayItem::getYSkew ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Ayrıca Bakınız

  • SWFDisplayItem::getXSkew() - Açıklama

SWFDisplayItem::getYScale
SWFDisplayItem::move
SWFDisplayItem


Moves object in relative coordinates

SWFDisplayItem::getYSkew
SWFDisplayItem::moveTo
SWFDisplayItem
PHP Manual

SWFDisplayItem::move

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFDisplayItem::move — Moves object in relative coordinates

Açıklama

void SWFDisplayItem::move ( float $dx , float $dy )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swfdisplayitem::move() moves the current object by (dx,dy) from its current position.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie::add().

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SWFDisplayItem::moveTo() - Moves object in global coordinates

SWFDisplayItem::getYSkew
SWFDisplayItem::moveTo
SWFDisplayItem


Moves object in global coordinates

SWFDisplayItem::move
SWFDisplayItem::multColor
SWFDisplayItem
PHP Manual

SWFDisplayItem::moveTo

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFDisplayItem::moveTo — Moves object in global coordinates

Açıklama

void SWFDisplayItem::moveTo ( float $x , float $y )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swfdisplayitem::moveto() moves the current object to (x,y) in global coordinates.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie::add().

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SWFDisplayItem::move() - Moves object in relative coordinates

SWFDisplayItem::move
SWFDisplayItem::multColor
SWFDisplayItem


Multiplies the item's color transform

SWFDisplayItem::moveTo
SWFDisplayItem::remove
SWFDisplayItem
PHP Manual

SWFDisplayItem::multColor

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFDisplayItem::multColor — Multiplies the item's color transform

Açıklama

void SWFDisplayItem::multColor ( float $red , float $green , float $blue [, float $a ] )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swfdisplayitem::multcolor() multiplies the item's color transform by the given values.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie::add().

Değiştirgeler

These parameters are floats between 0.0 and 1.0:

red

Value of red component

green

Value of green component

blue

Value of blue component

a

Value of alpha component

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

This simple example will modify your picture's atmosphere to Halloween (use a landscape or bright picture).

Örnek 1 swfdisplayitem::multcolor() example

<?php

$b = new SWFBitmap(file_get_contents("backyard.jpg"));
// note use your own picture :-)
$s = new SWFShape();
$s->setRightFill($s->addFill($b));
$s->drawLine($b->getWidth(), 0);
$s->drawLine(0, $b->getHeight());
$s->drawLine(-$b->getWidth(), 0);
$s->drawLine(0, -$b->getHeight());

$m = new SWFMovie();
$m->setDimension($b->getWidth(), $b->getHeight());

$i = $m->add($s);

for ($n=0; $n<=20; ++$n) {
  $i->multColor(1.0-$n/10, 1.0, 1.0);
  $i->addColor(0xff*$n/20, 0, 0);
  $m->nextFrame();
}

header('Content-type: application/x-shockwave-flash');
$m->output();
?>

SWFDisplayItem::moveTo
SWFDisplayItem::remove
SWFDisplayItem


Removes the object from the movie

SWFDisplayItem::multColor
SWFDisplayItem::rotate
SWFDisplayItem
PHP Manual

SWFDisplayItem::remove

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFDisplayItem::remove — Removes the object from the movie

Açıklama

void SWFDisplayItem::remove ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swfdisplayitem::remove() removes this object from the movie's display list.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie::add().

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SWFMovie::add() - Adds any type of data to a movie

SWFDisplayItem::multColor
SWFDisplayItem::rotate
SWFDisplayItem


Rotates in relative coordinates

SWFDisplayItem::remove
SWFDisplayItem::rotateTo
SWFDisplayItem
PHP Manual

SWFDisplayItem::rotate

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFDisplayItem::rotate — Rotates in relative coordinates

Açıklama

void SWFDisplayItem::rotate ( float $angle )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swfdisplayitem::rotate() rotates the current object by angle degrees from its current rotation.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie::add().

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SWFDisplayItem::rotateTo() - Rotates the object in global coordinates

SWFDisplayItem::remove
SWFDisplayItem::rotateTo
SWFDisplayItem


Rotates the object in global coordinates

SWFDisplayItem::rotate
SWFDisplayItem::scale
SWFDisplayItem
PHP Manual

SWFDisplayItem::rotateTo

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFDisplayItem::rotateTo — Rotates the object in global coordinates

Açıklama

void SWFDisplayItem::rotateTo ( float $angle )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swfdisplayitem::rotateto() set the current object rotation to angle degrees in global coordinates.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie::add().

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

This example bring three rotating string from the background to the foreground. Pretty nice.

Örnek 1 swfdisplayitem::rotateto() example

<?php
$thetext =  "ming!";

$f = new SWFFont("Bauhaus 93.fdb");

$m = new SWFMovie();
$m->setRate(24.0);
$m->setDimension(2400, 1600);
$m->setBackground(0xff, 0xff, 0xff);

// functions with huge numbers of arbitrary
// arguments are always a good idea!  Really!

function text($r, $g, $b, $a, $rot, $x, $y, $scale, $string)
{
  global $f, $m;

  $t = new SWFText();
  $t->setFont($f);
  $t->setColor($r, $g, $b, $a);
  $t->setHeight(960);
  $t->moveTo(-($f->getWidth($string))/2, $f->getAscent()/2);
  $t->addString($string);

  // we can add properties just like a normal PHP var,
  // as long as the names aren't already used.
  // e.g., we can't set $i->scale, because that's a function

  $i = $m->add($t);
  $i->x = $x;
  $i->y = $y;
  $i->rot = $rot;
  $i->s = $scale;
  $i->rotateTo($rot);
  $i->scale($scale, $scale);

  // but the changes are local to the function, so we have to
  // return the changed object.  kinda weird..

  return $i;
}

function step($i)
{
  $oldrot = $i->rot;
  $i->rot = 19*$i->rot/20;
  $i->x = (19*$i->x + 1200)/20;
  $i->y = (19*$i->y + 800)/20;
  $i->s = (19*$i->s + 1.0)/20;

  $i->rotateTo($i->rot);
  $i->scaleTo($i->s, $i->s);
  $i->moveTo($i->x, $i->y);

  return $i;
}

// see?  it sure paid off in legibility:

$i1 = text(0xff, 0x33, 0x33, 0xff, 900, 1200, 800, 0.03, $thetext);
$i2 = text(0x00, 0x33, 0xff, 0x7f, -560, 1200, 800, 0.04, $thetext);
$i3 = text(0xff, 0xff, 0xff, 0x9f, 180, 1200, 800, 0.001, $thetext);

for ($i=1; $i<=100; ++$i) {
  $i1 = step($i1);
  $i2 = step($i2);
  $i3 = step($i3);

  $m->nextFrame();
}

header('Content-type: application/x-shockwave-flash');
$m->output();
?>

Ayrıca Bakınız

  • SWFDisplayItem::rotate() - Rotates in relative coordinates

SWFDisplayItem::rotate
SWFDisplayItem::scale
SWFDisplayItem


Scales the object in relative coordinates

SWFDisplayItem::rotateTo
SWFDisplayItem::scaleTo
SWFDisplayItem
PHP Manual

SWFDisplayItem::scale

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFDisplayItem::scale — Scales the object in relative coordinates

Açıklama

void SWFDisplayItem::scale ( float $dx , float $dy )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swfdisplayitem::scale() scales the current object by (dx,dy) from its current size.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie::add().

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SWFDisplayItem::scaleTo() - Scales the object in global coordinates

SWFDisplayItem::rotateTo
SWFDisplayItem::scaleTo
SWFDisplayItem


Scales the object in global coordinates

SWFDisplayItem::scale
SWFDisplayItem::setDepth
SWFDisplayItem
PHP Manual

SWFDisplayItem::scaleTo

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFDisplayItem::scaleTo — Scales the object in global coordinates

Açıklama

void SWFDisplayItem::scaleTo ( float $x [, float $y ] )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swfdisplayitem::scaleto() scales the current object to (x,y) in global coordinates.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie::add().

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SWFDisplayItem::scale() - Scales the object in relative coordinates

SWFDisplayItem::scale
SWFDisplayItem::setDepth
SWFDisplayItem


Sets z-order

SWFDisplayItem::scaleTo
SWFDisplayItem::setMaskLevel
SWFDisplayItem
PHP Manual

SWFDisplayItem::setDepth

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFDisplayItem::setDepth — Sets z-order

Açıklama

void SWFDisplayItem::setDepth ( int $depth )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swfdisplayitem::setdepth() sets the object's z-order to depth. Depth defaults to the order in which instances are created (by adding a shape/text to a movie)- newer ones are on top of older ones. If two objects are given the same depth, only the later-defined one can be moved.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie::add().

Dönen Değerler

Hiçbir değer dönmez.

SWFDisplayItem::scaleTo
SWFDisplayItem::setMaskLevel
SWFDisplayItem


Defines a MASK layer at level

SWFDisplayItem::setDepth
SWFDisplayItem::setMatrix
SWFDisplayItem
PHP Manual

SWFDisplayItem::setMaskLevel

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFDisplayItem::setMaskLevel — Defines a MASK layer at level

Açıklama

void SWFDisplayItem::setMaskLevel ( int $level )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Dönen Değerler

Hiçbir değer dönmez.

SWFDisplayItem::setDepth
SWFDisplayItem::setMatrix
SWFDisplayItem


Sets the item's transform matrix

SWFDisplayItem::setMaskLevel
SWFDisplayItem::setName
SWFDisplayItem
PHP Manual

SWFDisplayItem::setMatrix

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFDisplayItem::setMatrix — Sets the item's transform matrix

Açıklama

void SWFDisplayItem::setMatrix ( float $a , float $b , float $c , float $d , float $x , float $y )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Dönen Değerler

Hiçbir değer dönmez.

SWFDisplayItem::setMaskLevel
SWFDisplayItem::setName
SWFDisplayItem


Sets the object's name

SWFDisplayItem::setMatrix
SWFDisplayItem::setRatio
SWFDisplayItem
PHP Manual

SWFDisplayItem::setName

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFDisplayItem::setName — Sets the object's name

Açıklama

void SWFDisplayItem::setName ( string $name )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swfdisplayitem::setname() sets the object's name to name, for targetting with action script. Only useful on sprites.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie::add().

Dönen Değerler

Hiçbir değer dönmez.

SWFDisplayItem::setMatrix
SWFDisplayItem::setRatio
SWFDisplayItem


Sets the object's ratio

SWFDisplayItem::setName
SWFDisplayItem::skewX
SWFDisplayItem
PHP Manual

SWFDisplayItem::setRatio

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFDisplayItem::setRatio — Sets the object's ratio

Açıklama

void SWFDisplayItem::setRatio ( float $ratio )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swfdisplayitem::setratio() sets the object's ratio to ratio. Obviously only useful for morphs.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie::add().

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

This simple example will morph nicely three concentric circles.

Örnek 1 swfdisplayitem::setname() example

<?php

$p = new SWFMorph();

$g = new SWFGradient();
$g->addEntry(0.0, 0, 0, 0);
$g->addEntry(0.16, 0xff, 0xff, 0xff);
$g->addEntry(0.32, 0, 0, 0);
$g->addEntry(0.48, 0xff, 0xff, 0xff);
$g->addEntry(0.64, 0, 0, 0);
$g->addEntry(0.80, 0xff, 0xff, 0xff);
$g->addEntry(1.00, 0, 0, 0);

$s = $p->getShape1();
$f = $s->addFill($g, SWFFILL_RADIAL_GRADIENT);
$f->scaleTo(0.05);
$s->setLeftFill($f);
$s->movePenTo(-160, -120);
$s->drawLine(320, 0);
$s->drawLine(0, 240);
$s->drawLine(-320, 0);
$s->drawLine(0, -240);

$g = new SWFGradient();
$g->addEntry(0.0, 0, 0, 0);
$g->addEntry(0.16, 0xff, 0, 0);
$g->addEntry(0.32, 0, 0, 0);
$g->addEntry(0.48, 0, 0xff, 0);
$g->addEntry(0.64, 0, 0, 0);
$g->addEntry(0.80, 0, 0, 0xff);
$g->addEntry(1.00, 0, 0, 0);

$s = $p->getShape2();
$f = $s->addFill($g, SWFFILL_RADIAL_GRADIENT);
$f->scaleTo(0.05);
$f->skewXTo(1.0);
$s->setLeftFill($f);
$s->movePenTo(-160, -120);
$s->drawLine(320, 0);
$s->drawLine(0, 240);
$s->drawLine(-320, 0);
$s->drawLine(0, -240);

$m = new SWFMovie();
$m->setDimension(320, 240);
$i = $m->add($p);
$i->moveTo(160, 120);

for ($n=0; $n<=1.001; $n+=0.01) {
    $i->setRatio($n);
    $m->nextFrame();
}

header('Content-type: application/x-shockwave-flash');
$m->output();
?>

SWFDisplayItem::setName
SWFDisplayItem::skewX
SWFDisplayItem


Sets the X-skew

SWFDisplayItem::setRatio
SWFDisplayItem::skewXTo
SWFDisplayItem
PHP Manual

SWFDisplayItem::skewX

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFDisplayItem::skewX — Sets the X-skew

Açıklama

void SWFDisplayItem::skewX ( float $ddegrees )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swfdisplayitem::skewx() adds ddegrees to current x-skew.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie::add().

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SWFDisplayItem::skewXTo() - Sets the X-skew
  • SWFDisplayItem::skewY() - Sets the Y-skew
  • SWFDisplayItem::skewYTo() - Sets the Y-skew

SWFDisplayItem::setRatio
SWFDisplayItem::skewXTo
SWFDisplayItem


Sets the X-skew

SWFDisplayItem::skewX
SWFDisplayItem::skewY
SWFDisplayItem
PHP Manual

SWFDisplayItem::skewXTo

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFDisplayItem::skewXTo — Sets the X-skew

Açıklama

void SWFDisplayItem::skewXTo ( float $degrees )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swfdisplayitem::skewxto() sets the x-skew to degrees. For degrees is 1.0, it means a 45-degree forward slant. More is more forward, less is more backward.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie::add().

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SWFDisplayItem::skewX() - Sets the X-skew
  • SWFDisplayItem::skewY() - Sets the Y-skew
  • SWFDisplayItem::skewYTo() - Sets the Y-skew

SWFDisplayItem::skewX
SWFDisplayItem::skewY
SWFDisplayItem


Sets the Y-skew

SWFDisplayItem::skewXTo
SWFDisplayItem::skewYTo
SWFDisplayItem
PHP Manual

SWFDisplayItem::skewY

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFDisplayItem::skewY — Sets the Y-skew

Açıklama

void SWFDisplayItem::skewY ( float $ddegrees )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swfdisplayitem::skewy() adds ddegrees to current y-skew.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie::add().

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SWFDisplayItem::skewYTo() - Sets the Y-skew
  • SWFDisplayItem::skewX() - Sets the X-skew
  • SWFDisplayItem::skewXTo() - Sets the X-skew

SWFDisplayItem::skewXTo
SWFDisplayItem::skewYTo
SWFDisplayItem


Sets the Y-skew

SWFDisplayItem::skewY
SWFFill
SWFDisplayItem
PHP Manual

SWFDisplayItem::skewYTo

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFDisplayItem::skewYTo — Sets the Y-skew

Açıklama

void SWFDisplayItem::skewYTo ( float $degrees )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swfdisplayitem::skewyto() sets the y-skew to degrees. For degrees is 1.0, it means a 45-degree forward slant. More is more upward, less is more downward.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie::add().

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SWFDisplayItem::skewY() - Sets the Y-skew
  • SWFDisplayItem::skewX() - Sets the X-skew
  • SWFDisplayItem::skewXTo() - Sets the X-skew

SWFDisplayItem::skewY
SWFFill
SWFDisplayItem


The SWFFill class

(PHP 5 <= 5.3.0, PECL ming SVN)

Giriş

The SWFFill object allows you to transform (scale, skew, rotate) bitmap and gradient fills.

swffill objects are created by the SWFShape::addFill() method.

Sınıf Sözdizimi

SWFFill {
/* Yöntemler */
void moveTo ( float $x , float $y )
void rotateTo ( float $angle )
void scaleTo ( float $x [, float $y ] )
void skewXTo ( float $x )
void skewYTo ( float $y )
}

İçindekiler

  • SWFFill::moveTo — Moves fill origin
  • SWFFill::rotateTo — Sets fill's rotation
  • SWFFill::scaleTo — Sets fill's scale
  • SWFFill::skewXTo — Sets fill x-skew
  • SWFFill::skewYTo — Sets fill y-skew
SWFDisplayItem::skewYTo
SWFFill::moveTo
Ming


Moves fill origin

SWFFill
SWFFill::rotateTo
SWFFill
PHP Manual

SWFFill::moveTo

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFFill::moveTo — Moves fill origin

Açıklama

void SWFFill::moveTo ( float $x , float $y )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Moves the fill origin to the given global coordinates.

Değiştirgeler

x

X-coordinate

y

Y-coordinate

Dönen Değerler

Hiçbir değer dönmez.

SWFFill
SWFFill::rotateTo
SWFFill


Sets fill's rotation

SWFFill::moveTo
SWFFill::scaleTo
SWFFill
PHP Manual

SWFFill::rotateTo

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFFill::rotateTo — Sets fill's rotation

Açıklama

void SWFFill::rotateTo ( float $angle )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Sets the fill rotation to the given angle.

Değiştirgeler

angle

The rotation angle, in degrees.

Dönen Değerler

Hiçbir değer dönmez.

SWFFill::moveTo
SWFFill::scaleTo
SWFFill


Sets fill's scale

SWFFill::rotateTo
SWFFill::skewXTo
SWFFill
PHP Manual

SWFFill::scaleTo

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFFill::scaleTo — Sets fill's scale

Açıklama

void SWFFill::scaleTo ( float $x [, float $y ] )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Sets the fill scale to the given coordinates.

Değiştirgeler

x

X-coordinate

y

Y-coordinate

Dönen Değerler

Hiçbir değer dönmez.

SWFFill::rotateTo
SWFFill::skewXTo
SWFFill


Sets fill x-skew

SWFFill::scaleTo
SWFFill::skewYTo
SWFFill
PHP Manual

SWFFill::skewXTo

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFFill::skewXTo — Sets fill x-skew

Açıklama

void SWFFill::skewXTo ( float $x )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Sets the fill x-skew to x.

Değiştirgeler

x

When x is 1.0, it is a 45-degree forward slant. More is more forward, less is more backward.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SWFFill::skewYTo() - Sets fill y-skew

SWFFill::scaleTo
SWFFill::skewYTo
SWFFill


Sets fill y-skew

SWFFill::skewXTo
SWFFont
SWFFill
PHP Manual

SWFFill::skewYTo

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFFill::skewYTo — Sets fill y-skew

Açıklama

void SWFFill::skewYTo ( float $y )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Sets the fill y-skew to y.

Değiştirgeler

y

When y is 1.0, it is a 45-degree upward slant. More is more upward, less is more downward.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SWFFill::skewXTo() - Sets fill x-skew

SWFFill::skewXTo
SWFFont
SWFFill


The SWFFont class

(PHP 5 <= 5.3.0, PECL ming SVN)

Giriş

The SWFFont object represent a reference to the font definition, for us with SWFText::setFont() and SWFTextField::setFont().

Sınıf Sözdizimi

SWFFont {
/* Yöntemler */
__construct ( string $filename )
float getAscent ( void )
float getDescent ( void )
float getLeading ( void )
string getShape ( int $code )
float getUTF8Width ( string $string )
float getWidth ( string $string )
}

İçindekiler

  • SWFFont::__construct — Loads a font definition
  • SWFFont::getAscent — Returns the ascent of the font, or 0 if not available
  • SWFFont::getDescent — Returns the descent of the font, or 0 if not available
  • SWFFont::getLeading — Returns the leading of the font, or 0 if not available
  • SWFFont::getShape — Returns the glyph shape of a char as a text string
  • SWFFont::getUTF8Width — Calculates the width of the given string in this font at full height
  • SWFFont::getWidth — Returns the string's width
SWFFill::skewYTo
SWFFont::__construct
Ming


Loads a font definition

SWFFont
SWFFont::getAscent
SWFFont
PHP Manual

SWFFont::__construct

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFFont::__construct — Loads a font definition

Açıklama

SWFFont::__construct ( string $filename )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

If filename is the name of an FDB file (i.e., it ends in ".fdb"), load the font definition found in said file. Otherwise, create a browser-defined font reference.

FDB ("font definition block") is a very simple wrapper for the SWF DefineFont2 block which contains a full description of a font. One may create FDB files from SWT Generator template files with the included makefdb utility- look in the util directory off the main ming distribution directory.

Browser-defined fonts don't contain any information about the font other than its name. It is assumed that the font definition will be provided by the movie player. The fonts _serif, _sans, and _typewriter should always be available. For example:

<?php
$f = newSWFFont("_sans");
?>
will give you the standard sans-serif font, probably the same as what you'd get with <font name="sans-serif"> in HTML.

SWFFont
SWFFont::getAscent
SWFFont


Returns the ascent of the font, or 0 if not available

SWFFont::__construct
SWFFont::getDescent
SWFFont
PHP Manual

SWFFont::getAscent

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFFont::getAscent — Returns the ascent of the font, or 0 if not available

Açıklama

float SWFFont::getAscent ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Ayrıca Bakınız

  • SWFFont::getDescent() - Returns the descent of the font, or 0 if not available

SWFFont::__construct
SWFFont::getDescent
SWFFont


Returns the descent of the font, or 0 if not available

SWFFont::getAscent
SWFFont::getLeading
SWFFont
PHP Manual

SWFFont::getDescent

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFFont::getDescent — Returns the descent of the font, or 0 if not available

Açıklama

float SWFFont::getDescent ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Ayrıca Bakınız

  • SWFFont::getAscent() - Returns the ascent of the font, or 0 if not available

SWFFont::getAscent
SWFFont::getLeading
SWFFont


Returns the leading of the font, or 0 if not available

SWFFont::getDescent
SWFFont::getShape
SWFFont
PHP Manual

SWFFont::getLeading

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFFont::getLeading — Returns the leading of the font, or 0 if not available

Açıklama

float SWFFont::getLeading ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

SWFFont::getDescent
SWFFont::getShape
SWFFont


Returns the glyph shape of a char as a text string

SWFFont::getLeading
SWFFont::getUTF8Width
SWFFont
PHP Manual

SWFFont::getShape

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFFont::getShape — Returns the glyph shape of a char as a text string

Açıklama

string SWFFont::getShape ( int $code )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

SWFFont::getLeading
SWFFont::getUTF8Width
SWFFont


Calculates the width of the given string in this font at full height

SWFFont::getShape
SWFFont::getWidth
SWFFont
PHP Manual

SWFFont::getUTF8Width

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFFont::getUTF8Width — Calculates the width of the given string in this font at full height

Açıklama

float SWFFont::getUTF8Width ( string $string )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Ayrıca Bakınız

  • SWFFont::getWidth() - Returns the string's width

SWFFont::getShape
SWFFont::getWidth
SWFFont


Returns the string's width

SWFFont::getUTF8Width
SWFFontChar
SWFFont
PHP Manual

SWFFont::getWidth

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFFont::getWidth — Returns the string's width

Açıklama

float SWFFont::getWidth ( string $string )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swffont::getwidth() returns the string string's width, using font's default scaling. You'll probably want to use the swftext() version of this method which uses the text object's scale.

Ayrıca Bakınız

  • SWFFont::getUTF8Width() - Calculates the width of the given string in this font at full height

SWFFont::getUTF8Width
SWFFontChar
SWFFont


The SWFFontChar class

(PHP 5 <= 5.3.0, PECL ming SVN)

Giriş

SWFFontChar.

Sınıf Sözdizimi

SWFFontChar {
/* Yöntemler */
void addChars ( string $char )
void addUTF8Chars ( string $char )
}

İçindekiler

  • SWFFontChar::addChars — Adds characters to a font for exporting font
  • SWFFontChar::addUTF8Chars — Adds characters to a font for exporting font
SWFFont::getWidth
SWFFontChar::addChars
Ming


Adds characters to a font for exporting font

SWFFontChar
SWFFontChar::addUTF8Chars
SWFFontChar
PHP Manual

SWFFontChar::addChars

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFFontChar::addChars — Adds characters to a font for exporting font

Açıklama

void SWFFontChar::addChars ( string $char )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SWFFontChar::addUTF8Chars() - Adds characters to a font for exporting font

SWFFontChar
SWFFontChar::addUTF8Chars
SWFFontChar


Adds characters to a font for exporting font

SWFFontChar::addChars
SWFGradient
SWFFontChar
PHP Manual

SWFFontChar::addUTF8Chars

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFFontChar::addUTF8Chars — Adds characters to a font for exporting font

Açıklama

void SWFFontChar::addUTF8Chars ( string $char )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SWFFontChar::addChars() - Adds characters to a font for exporting font

SWFFontChar::addChars
SWFGradient
SWFFontChar


The SWFGradient class

(PHP 5 <= 5.3.0, PECL ming SVN)

Giriş

SWFGradient.

Sınıf Sözdizimi

SWFGradient {
/* Yöntemler */
void addEntry ( float $ratio , int $red , int $green , int $blue [, int $alpha = 255 ] )
__construct ( void )
}

İçindekiler

  • SWFGradient::addEntry — Adds an entry to the gradient list
  • SWFGradient::__construct — Creates a gradient object
SWFFontChar::addUTF8Chars
SWFGradient::addEntry
Ming


Adds an entry to the gradient list

SWFGradient
SWFGradient::__construct
SWFGradient
PHP Manual

SWFGradient::addEntry

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFGradient::addEntry — Adds an entry to the gradient list

Açıklama

void SWFGradient::addEntry ( float $ratio , int $red , int $green , int $blue [, int $alpha = 255 ] )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swfgradient::addentry() adds an entry to the gradient list. ratio is a number between 0 and 1 indicating where in the gradient this color appears. Thou shalt add entries in order of increasing ratio.

red, green, blue is a color (RGB mode).

Dönen Değerler

Hiçbir değer dönmez.

SWFGradient
SWFGradient::__construct
SWFGradient


Creates a gradient object

SWFGradient::addEntry
SWFMorph
SWFGradient
PHP Manual

SWFGradient::__construct

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFGradient::__construct — Creates a gradient object

Açıklama

SWFGradient::__construct ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swfgradient() creates a new SWFGradient object.

After you've added the entries to your gradient, you can use the gradient in a shape fill with the swfshape::addfill() method.

SWFGradient has the following methods : swfgradient::addentry().

This simple example will draw a big black-to-white gradient as background, and a reddish disc in its center.

Örnek 1 swfgradient() example

<?php

  $m = new SWFMovie();
  $m->setDimension(320, 240);

  $s = new SWFShape();

  // first gradient- black to white
  $g = new SWFGradient();
  $g->addEntry(0.0, 0, 0, 0);
  $g->addEntry(1.0, 0xff, 0xff, 0xff);

  $f = $s->addFill($g, SWFFILL_LINEAR_GRADIENT);
  $f->scaleTo(0.01);
  $f->moveTo(160, 120);
  $s->setRightFill($f);
  $s->drawLine(320, 0);
  $s->drawLine(0, 240);
  $s->drawLine(-320, 0);
  $s->drawLine(0, -240);

  $m->add($s);

  $s = new SWFShape();

  // second gradient- radial gradient from red to transparent
  $g = new SWFGradient();
  $g->addEntry(0.0, 0xff, 0, 0, 0xff);
  $g->addEntry(1.0, 0xff, 0, 0, 0);

  $f = $s->addFill($g, SWFFILL_RADIAL_GRADIENT);
  $f->scaleTo(0.005);
  $f->moveTo(160, 120);
  $s->setRightFill($f);
  $s->drawLine(320, 0);
  $s->drawLine(0, 240);
  $s->drawLine(-320, 0);
  $s->drawLine(0, -240);

  $m->add($s);

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

SWFGradient::addEntry
SWFMorph
SWFGradient


The SWFMorph class

(PHP 5 <= 5.3.0, PECL ming SVN)

Giriş

The methods here are sort of weird. It would make more sense to just have newSWFMorph(shape1, shape2);, but as things are now, shape2 needs to know that it's the second part of a morph. (This, because it starts writing its output as soon as it gets drawing commands- if it kept its own description of its shapes and wrote on completion this and some other things would be much easier.)

Sınıf Sözdizimi

SWFMorph {
/* Yöntemler */
__construct ( void )
SWFShape getShape1 ( void )
SWFShape getShape2 ( void )
}

İçindekiler

  • SWFMorph::__construct — Creates a new SWFMorph object
  • SWFMorph::getShape1 — Gets a handle to the starting shape
  • SWFMorph::getShape2 — Gets a handle to the ending shape
SWFGradient::__construct
SWFMorph::__construct
Ming


Creates a new SWFMorph object

SWFMorph
SWFMorph::getShape1
SWFMorph
PHP Manual

SWFMorph::__construct

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFMorph::__construct — Creates a new SWFMorph object

Açıklama

SWFMorph::__construct ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Creates a new SWFMorph object.

Also called a "shape tween". This thing lets you make those tacky twisting things that make your computer choke. Oh, joy!

Örnekler

This simple example will morph a big red square into a smaller blue black-bordered square.

Örnek 1 swfmorph() example

<?php
  $p = new SWFMorph();

  $s = $p->getShape1();
  $s->setLine(0, 0, 0, 0);

  /* Note that this is backwards from normal shapes (left instead of right).
     I have no idea why, but this seems to work.. */

  $s->setLeftFill($s->addFill(0xff, 0, 0));
  $s->movePenTo(-1000,-1000);
  $s->drawLine(2000,0);
  $s->drawLine(0,2000);
  $s->drawLine(-2000,0);
  $s->drawLine(0,-2000);

  $s = $p->getShape2();
  $s->setLine(60,0,0,0);
  $s->setLeftFill($s->addFill(0, 0, 0xff));
  $s->movePenTo(0,-1000);
  $s->drawLine(1000,1000);
  $s->drawLine(-1000,1000);
  $s->drawLine(-1000,-1000);
  $s->drawLine(1000,-1000);

  $m = new SWFMovie();
  $m->setDimension(3000,2000);
  $m->setBackground(0xff, 0xff, 0xff);

  $i = $m->add($p);
  $i->moveTo(1500,1000);

  for ($r=0.0; $r<=1.0; $r+=0.1) {
    $i->setRatio($r);
    $m->nextFrame();
  }

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

SWFMorph
SWFMorph::getShape1
SWFMorph


Gets a handle to the starting shape

SWFMorph::__construct
SWFMorph::getShape2
SWFMorph
PHP Manual

SWFMorph::getShape1

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFMorph::getShape1 — Gets a handle to the starting shape

Açıklama

SWFShape SWFMorph::getShape1 ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Gets the morph's starting shape.

Dönen Değerler

Returns a SWFShape object.

Ayrıca Bakınız

  • SWFMorph::getShape2() - Gets a handle to the ending shape

SWFMorph::__construct
SWFMorph::getShape2
SWFMorph


Gets a handle to the ending shape

SWFMorph::getShape1
SWFMovie
SWFMorph
PHP Manual

SWFMorph::getShape2

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFMorph::getShape2 — Gets a handle to the ending shape

Açıklama

SWFShape SWFMorph::getShape2 ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Gets the morph's ending shape.

Dönen Değerler

Returns a SWFShape object.

Ayrıca Bakınız

  • SWFMorph::getShape1() - Gets a handle to the starting shape

SWFMorph::getShape1
SWFMovie
SWFMorph


The SWFMovie class

(PHP 5 <= 5.3.0, PECL ming SVN)

Giriş

SWFMovie is a movie object representing an SWF movie.

Sınıf Sözdizimi

SWFMovie {
/* Yöntemler */
mixed add ( object $instance )
void addExport ( SWFCharacter $char , string $name )
mixed addFont ( SWFFont $font )
__construct ([ int $version ] )
SWFSprite importChar ( string $libswf , string $name )
SWFFontChar importFont ( string $libswf , string $name )
void labelFrame ( string $label )
void nextFrame ( void )
int output ([ int $compression ] )
void remove ( object $instance )
int save ( string $filename [, int $compression = -1 ] )
int saveToFile ( resource $x [, int $compression = -1 ] )
void setbackground ( int $red , int $green , int $blue )
void setDimension ( float $width , float $height )
void setFrames ( int $number )
void setRate ( float $rate )
SWFSoundInstance startSound ( SWFSound $sound )
void stopSound ( SWFSound $sound )
int streamMP3 ( mixed $mp3file [, float $skip = 0 ] )
void writeExports ( void )
}

İçindekiler

  • SWFMovie::add — Adds any type of data to a movie
  • SWFMovie::addExport — Açıklama
  • SWFMovie::addFont — Açıklama
  • SWFMovie::__construct — Creates a new movie object, representing an SWF version 4 movie
  • SWFMovie::importChar — Açıklama
  • SWFMovie::importFont — Açıklama
  • SWFMovie::labelFrame — Labels a frame
  • SWFMovie::nextFrame — Moves to the next frame of the animation
  • SWFMovie::output — Dumps your lovingly prepared movie out
  • SWFMovie::remove — Removes the object instance from the display list
  • SWFMovie::save — Saves the SWF movie in a file
  • SWFMovie::saveToFile — Açıklama
  • SWFMovie::setbackground — Sets the background color
  • SWFMovie::setDimension — Sets the movie's width and height
  • SWFMovie::setFrames — Sets the total number of frames in the animation
  • SWFMovie::setRate — Sets the animation's frame rate
  • SWFMovie::startSound — Açıklama
  • SWFMovie::stopSound — Açıklama
  • SWFMovie::streamMP3 — Streams a MP3 file
  • SWFMovie::writeExports — Açıklama
SWFMorph::getShape2
SWFMovie::add
Ming


Adds any type of data to a movie

SWFMovie
SWFMovie::addExport
SWFMovie
PHP Manual

SWFMovie::add

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFMovie::add — Adds any type of data to a movie

Açıklama

mixed SWFMovie::add ( object $instance )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Adds an SWF object instance to the current movie.

Değiştirgeler

instance

Any type of object instance, like SWFShape, SWFText, SWFFont.

Dönen Değerler

For displayable types (shape, text, button, sprite), this returns an SWFDisplayItem, a handle to the object in a display list. Thus, you can add the same shape to a movie multiple times and get separate handles back for each separate instance.

Ayrıca Bakınız

  • SWFMovie::remove() - Removes the object instance from the display list

SWFMovie
SWFMovie::addExport
SWFMovie


SWFMovie::add
SWFMovie::addFont
SWFMovie
PHP Manual

SWFMovie::addExport

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFMovie::addExport —

Açıklama

void SWFMovie::addExport ( SWFCharacter $char , string $name )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Dönen Değerler

Hiçbir değer dönmez.

SWFMovie::add
SWFMovie::addFont
SWFMovie


SWFMovie::addExport
SWFMovie::__construct
SWFMovie
PHP Manual

SWFMovie::addFont

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFMovie::addFont —

Açıklama

mixed SWFMovie::addFont ( SWFFont $font )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Dönen Değerler

Hiçbir değer dönmez.

SWFMovie::addExport
SWFMovie::__construct
SWFMovie


Creates a new movie object, representing an SWF version 4 movie

SWFMovie::addFont
SWFMovie::importChar
SWFMovie
PHP Manual

SWFMovie::__construct

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFMovie::__construct — Creates a new movie object, representing an SWF version 4 movie

Açıklama

SWFMovie::__construct ([ int $version ] )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Creates a new movie object, representing an SWF movie.

Değiştirgeler

version

The desired SWF version. Default is 4.

SWFMovie::addFont
SWFMovie::importChar
SWFMovie


SWFMovie::__construct
SWFMovie::importFont
SWFMovie
PHP Manual

SWFMovie::importChar

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFMovie::importChar —

Açıklama

SWFSprite SWFMovie::importChar ( string $libswf , string $name )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Ayrıca Bakınız

  • SWFMovie::importFont() - Açıklama

SWFMovie::__construct
SWFMovie::importFont
SWFMovie


SWFMovie::importChar
SWFMovie::labelFrame
SWFMovie
PHP Manual

SWFMovie::importFont

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFMovie::importFont —

Açıklama

SWFFontChar SWFMovie::importFont ( string $libswf , string $name )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Ayrıca Bakınız

  • SWFMovie::importChar() - Açıklama

SWFMovie::importChar
SWFMovie::labelFrame
SWFMovie


Labels a frame

SWFMovie::importFont
SWFMovie::nextFrame
SWFMovie
PHP Manual

SWFMovie::labelFrame

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFMovie::labelFrame — Labels a frame

Açıklama

void SWFMovie::labelFrame ( string $label )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Dönen Değerler

Hiçbir değer dönmez.

SWFMovie::importFont
SWFMovie::nextFrame
SWFMovie


Moves to the next frame of the animation

SWFMovie::labelFrame
SWFMovie::output
SWFMovie
PHP Manual

SWFMovie::nextFrame

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFMovie::nextFrame — Moves to the next frame of the animation

Açıklama

void SWFMovie::nextFrame ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Moves to the next frame of the animation.

Dönen Değerler

Hiçbir değer dönmez.

SWFMovie::labelFrame
SWFMovie::output
SWFMovie


Dumps your lovingly prepared movie out

SWFMovie::nextFrame
SWFMovie::remove
SWFMovie
PHP Manual

SWFMovie::output

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFMovie::output — Dumps your lovingly prepared movie out

Açıklama

int SWFMovie::output ([ int $compression ] )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Dumps the SWFMovie.

Don't forget to send the Content-Type HTTP header file before using this function, in order to display the movie in a browser.

Değiştirgeler

compression

The compression level can be a value between 0 and 9, defining the SWF compression similar to gzip compression.

This parameter is only available as of Flash MX (6).

Dönen Değerler

Return the number of bytes written or FALSE on error.

Örnekler

Örnek 1 Displaying your $movie in a browser

<?php
header('Content-type: application/x-shockwave-flash');
$movie->output();
?>

Ayrıca Bakınız

  • SWFMovie::save() - Saves the SWF movie in a file
  • SWFMovie::saveToFile() - Açıklama

SWFMovie::nextFrame
SWFMovie::remove
SWFMovie


Removes the object instance from the display list

SWFMovie::output
SWFMovie::save
SWFMovie
PHP Manual

SWFMovie::remove

(PHP 5.2.1-5.3.0, PHP 7, PECL ming SVN)

SWFMovie::remove — Removes the object instance from the display list

Açıklama

void SWFMovie::remove ( object $instance )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Removes the given object instance from the display list.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SWFMovie::add() - Adds any type of data to a movie

SWFMovie::output
SWFMovie::save
SWFMovie


Saves the SWF movie in a file

SWFMovie::remove
SWFMovie::saveToFile
SWFMovie
PHP Manual

SWFMovie::save

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFMovie::save — Saves the SWF movie in a file

Açıklama

int SWFMovie::save ( string $filename [, int $compression = -1 ] )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Saves the SWF movie to the specified filename.

Değiştirgeler

filename

The path to the saved SWF document.

compression

The compression level can be a value between 0 and 9, defining the SWF compression similar to gzip compression.

This parameter is only available as of Flash MX (6).

Dönen Değerler

Return the number of bytes written or FALSE on error.

Ayrıca Bakınız

  • SWFMovie::output() - Dumps your lovingly prepared movie out
  • SWFMovie::saveToFile() - Açıklama

SWFMovie::remove
SWFMovie::saveToFile
SWFMovie


SWFMovie::save
SWFMovie::setbackground
SWFMovie
PHP Manual

SWFMovie::saveToFile

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFMovie::saveToFile —

Açıklama

int SWFMovie::saveToFile ( resource $x [, int $compression = -1 ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

X

compression

The compression level can be a value between 0 and 9, defining the SWF compression similar to gzip compression.

This parameter is only available as of Flash MX (6).

Dönen Değerler

Return the number of bytes written or FALSE on error.

Ayrıca Bakınız

  • SWFMovie::output() - Dumps your lovingly prepared movie out
  • SWFMovie::save() - Saves the SWF movie in a file

SWFMovie::save
SWFMovie::setbackground
SWFMovie


Sets the background color

SWFMovie::saveToFile
SWFMovie::setDimension
SWFMovie
PHP Manual

SWFMovie::setbackground

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFMovie::setbackground — Sets the background color

Açıklama

void SWFMovie::setbackground ( int $red , int $green , int $blue )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Sets the background color.

Why is there no rgba version? Think about it, you might want to let the HTML background show through. There's a way to do that, but it only works on IE4. Search the » http://www.macromedia.com/ site for details.

Değiştirgeler

These parameters are integers between 0 and 255 or hexadecimals between 0x00 and 0xFF:

red

Value of red component

green

Value of green component

blue

Value of blue component

Dönen Değerler

Hiçbir değer dönmez.

SWFMovie::saveToFile
SWFMovie::setDimension
SWFMovie


Sets the movie's width and height

SWFMovie::setbackground
SWFMovie::setFrames
SWFMovie
PHP Manual

SWFMovie::setDimension

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFMovie::setDimension — Sets the movie's width and height

Açıklama

void SWFMovie::setDimension ( float $width , float $height )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Sets the movie's dimension to the specified width and height.

Değiştirgeler

width

The movie width.

height

The movie height.

Dönen Değerler

Hiçbir değer dönmez.

SWFMovie::setbackground
SWFMovie::setFrames
SWFMovie


Sets the total number of frames in the animation

SWFMovie::setDimension
SWFMovie::setRate
SWFMovie
PHP Manual

SWFMovie::setFrames

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFMovie::setFrames — Sets the total number of frames in the animation

Açıklama

void SWFMovie::setFrames ( int $number )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Sets the total number of frames in the animation to the given number.

Değiştirgeler

number

The number of frames.

Dönen Değerler

Hiçbir değer dönmez.

SWFMovie::setDimension
SWFMovie::setRate
SWFMovie


Sets the animation's frame rate

SWFMovie::setFrames
SWFMovie::startSound
SWFMovie
PHP Manual

SWFMovie::setRate

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFMovie::setRate — Sets the animation's frame rate

Açıklama

void SWFMovie::setRate ( float $rate )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Sets the frame rate to the specified rate.

Animation will slow down if the player can't render frames fast enough- unless there's a streaming sound, in which case display frames are sacrificed to keep sound from skipping.

Değiştirgeler

rate

The frame rate, in frame per seconds.

Dönen Değerler

Hiçbir değer dönmez.

SWFMovie::setFrames
SWFMovie::startSound
SWFMovie


SWFMovie::setRate
SWFMovie::stopSound
SWFMovie
PHP Manual

SWFMovie::startSound

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFMovie::startSound —

Açıklama

SWFSoundInstance SWFMovie::startSound ( SWFSound $sound )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Ayrıca Bakınız

  • SWFMovie::stopSound() - Açıklama

SWFMovie::setRate
SWFMovie::stopSound
SWFMovie


SWFMovie::startSound
SWFMovie::streamMP3
SWFMovie
PHP Manual

SWFMovie::stopSound

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFMovie::stopSound —

Açıklama

void SWFMovie::stopSound ( SWFSound $sound )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SWFMovie::startSound() - Açıklama

SWFMovie::startSound
SWFMovie::streamMP3
SWFMovie


Streams a MP3 file

SWFMovie::stopSound
SWFMovie::writeExports
SWFMovie
PHP Manual

SWFMovie::streamMP3

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFMovie::streamMP3 — Streams a MP3 file

Açıklama

int SWFMovie::streamMP3 ( mixed $mp3file [, float $skip = 0 ] )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Streams the given MP3 file mp3file.

This method is not very robust in dealing with oddities (can skip over an initial ID3 tag, but that's about it).

Note that the movie isn't smart enough to put enough frames in to contain the entire mp3 stream- you'll have to add (length of song * frames per second) frames to get the entire stream in.

Değiştirgeler

mp3file

Can be a file pointer returned by fopen() or the MP3 data, as a binary string.

skip

Number of seconds to skip.

Dönen Değerler

Return number of frames.

Sürüm Bilgisi

Sürüm: | Açıklama
5.2.0 | skip added

Örnekler

Örnek 1 Streaming example

<?php
$m = new SWFMovie();
$m->setRate(12.0);
$m->streamMp3(file_get_contents("distortobass.mp3"));
// use your own MP3

// The file is 11.85 seconds at 12.0 fps = 142 frames
$m->setFrames(142);

header('Content-type: application/x-shockwave-flash');
$m->output();
?>

SWFMovie::stopSound
SWFMovie::writeExports
SWFMovie


SWFMovie::streamMP3
SWFPrebuiltClip
SWFMovie
PHP Manual

SWFMovie::writeExports

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFMovie::writeExports —

Açıklama

void SWFMovie::writeExports ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Dönen Değerler

Hiçbir değer dönmez.

SWFMovie::streamMP3
SWFPrebuiltClip
SWFMovie


The SWFPrebuiltClip class

(PHP 5.0.5-5.3.0, PHP 7, PECL ming SVN)

Giriş

SWFPrebuiltClip.

Sınıf Sözdizimi

SWFPrebuiltClip {
/* Yöntemler */
__construct ( mixed $file )
}

İçindekiler

  • SWFPrebuiltClip::__construct — Returns a SWFPrebuiltClip object
SWFMovie::writeExports
SWFPrebuiltClip::__construct
Ming


Returns a SWFPrebuiltClip object

SWFPrebuiltClip
SWFShape
SWFPrebuiltClip
PHP Manual

SWFPrebuiltClip::__construct

(PHP 5.0.5-5.3.0, PHP 7, PECL ming SVN)

SWFPrebuiltClip::__construct — Returns a SWFPrebuiltClip object

Açıklama

SWFPrebuiltClip::__construct ( mixed $file )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

SWFPrebuiltClip
SWFShape
SWFPrebuiltClip


The SWFShape class

(PHP 5 <= 5.3.0, PECL ming SVN)

Giriş

SWFShape.

Sınıf Sözdizimi

SWFShape {
/* Yöntemler */
SWFFill addFill ( int $red , int $green , int $blue [, int $alpha = 255 ] )
__construct ( void )
void drawArc ( float $r , float $startAngle , float $endAngle )
void drawCircle ( float $r )
int drawCubic ( float $bx , float $by , float $cx , float $cy , float $dx , float $dy )
int drawCubicTo ( float $bx , float $by , float $cx , float $cy , float $dx , float $dy )
int drawCurve ( float $controldx , float $controldy , float $anchordx , float $anchordy [, float $targetdx ], float $targetdy )
int drawCurveTo ( float $controlx , float $controly , float $anchorx , float $anchory [, float $targetx ], float $targety )
void drawGlyph ( SWFFont $font , string $character [, int $size ] )
void drawLine ( float $dx , float $dy )
void drawLineTo ( float $x , float $y )
void movePen ( float $dx , float $dy )
void movePenTo ( float $x , float $y )
void setLeftFill ( SWFGradient $fill )
void setLine ( SWFShape $shape )
void setRightFill ( SWFGradient $fill )
}

İçindekiler

  • SWFShape::addFill — Adds a solid fill to the shape
  • SWFShape::__construct — Creates a new shape object
  • SWFShape::drawArc — Draws an arc of radius r centered at the current location, from angle startAngle to angle endAngle measured clockwise from 12 o'clock
  • SWFShape::drawCircle — Draws a circle of radius r centered at the current location, in a counter-clockwise fashion
  • SWFShape::drawCubic — Draws a cubic bezier curve using the current position and the three given points as control points
  • SWFShape::drawCubicTo — Draws a cubic bezier curve using the current position and the three given points as control points
  • SWFShape::drawCurve — Draws a curve (relative)
  • SWFShape::drawCurveTo — Draws a curve
  • SWFShape::drawGlyph — Draws the first character in the given string into the shape using the glyph definition from the given font
  • SWFShape::drawLine — Draws a line (relative)
  • SWFShape::drawLineTo — Draws a line
  • SWFShape::movePen — Moves the shape's pen (relative)
  • SWFShape::movePenTo — Moves the shape's pen
  • SWFShape::setLeftFill — Sets left rasterizing color
  • SWFShape::setLine — Sets the shape's line style
  • SWFShape::setRightFill — Sets right rasterizing color
SWFPrebuiltClip::__construct
SWFShape::addFill
Ming


Adds a solid fill to the shape

SWFShape
SWFShape::__construct
SWFShape
PHP Manual

SWFShape::addFill

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFShape::addFill — Adds a solid fill to the shape

Açıklama

SWFFill SWFShape::addFill ( int $red , int $green , int $blue [, int $alpha = 255 ] )
SWFFill addFill ( SWFBitmap $bitmap [, int $flags ] )
SWFFill addFill ( SWFGradient $gradient [, int $flags ] )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

SWFShape::addFill() adds a solid fill to the shape's list of fill styles. SWFShape::addFill() accepts three different types of arguments.

red, green, blue is a color (RGB mode).

The bitmap argument is an SWFBitmap() object. The flags argument can be one of the following values: SWFFILL_CLIPPED_BITMAP, SWFFILL_TILED_BITMAP, SWFFILL_LINEAR_GRADIENT or SWFFILL_RADIAL_GRADIENT. Default is SWFFILL_TILED_BITMAP for SWFBitmap and SWFFILL_LINEAR_GRADIENT for SWFGradient.

The gradient argument is an SWFGradient() object. The flags argument can be one of the following values : SWFFILL_RADIAL_GRADIENT or SWFFILL_LINEAR_GRADIENT. Default is SWFFILL_LINEAR_GRADIENT. I'm sure about this one. Really.

SWFShape::addFill() returns an SWFFill()
object for use with the SWFShape::setLeftFill()
and SWFShape::setRightFill() functions
described below.

Örnekler

This simple example will draw a frame on a bitmap. Ah, here's another buglet in the flash player- it doesn't seem to care about the second shape's bitmap's transformation in a morph. According to spec, the bitmap should stretch along with the shape in this example..

Örnek 1 SWFShape::addFill() example

<?php

$p = new SWFMorph();

$b = new SWFBitmap(file_get_contents("alphafill.jpg"));
// use your own bitmap
$width = $b->getWidth();
$height = $b->getHeight();

$s = $p->getShape1();
$f = $s->addFill($b, SWFFILL_TILED_BITMAP);
$f->moveTo(-$width/2, -$height/4);
$f->scaleTo(1.0, 0.5);
$s->setLeftFill($f);
$s->movePenTo(-$width/2, -$height/4);
$s->drawLine($width, 0);
$s->drawLine(0, $height/2);
$s->drawLine(-$width, 0);
$s->drawLine(0, -$height/2);

$s = $p->getShape2();
$f = $s->addFill($b, SWFFILL_TILED_BITMAP);

// these two have no effect!
$f->moveTo(-$width/4, -$height/2);
$f->scaleTo(0.5, 1.0);

$s->setLeftFill($f);
$s->movePenTo(-$width/4, -$height/2);
$s->drawLine($width/2, 0);
$s->drawLine(0, $height);
$s->drawLine(-$width/2, 0);
$s->drawLine(0, -$height);

$m = new SWFMovie();
$m->setDimension($width, $height);
$i = $m->add($p);
$i->moveTo($width/2, $height/2);

for ($n=0; $n<1.001; $n+=0.03) {
    $i->setRatio($n);
    $m->nextFrame();
}

header('Content-type: application/x-shockwave-flash');
$m->output();
?>

Ayrıca Bakınız

  • SWFShape::setLeftFill() - Sets left rasterizing color
  • SWFShape::setRightFill() - Sets right rasterizing color

SWFShape
SWFShape::__construct
SWFShape


Creates a new shape object

SWFShape::addFill
SWFShape::drawArc
SWFShape
PHP Manual

SWFShape::__construct

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFShape::__construct — Creates a new shape object

Açıklama

SWFShape::__construct ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Created a new SWFShape object.

Örnekler

This simple example will draw a big red elliptic quadrant.

Örnek 1 swfshape() example

<?php
$s = new SWFShape();
$s->setLine(40, 0x7f, 0, 0);
$s->setRightFill($s->addFill(0xff, 0, 0));
$s->movePenTo(200, 200);
$s->drawLineTo(6200, 200);
$s->drawLineTo(6200, 4600);
$s->drawCurveTo(200, 4600, 200, 200);

$m = new SWFMovie();
$m->setDimension(6400, 4800);
$m->setRate(12.0);
$m->add($s);
$m->nextFrame();

header('Content-type: application/x-shockwave-flash');
$m->output();
?>

SWFShape::addFill
SWFShape::drawArc
SWFShape


Draws an arc of radius r centered at the current location, from angle startAngle to angle endAngle measured clockwise from 12 o'clock

SWFShape::__construct
SWFShape::drawCircle
SWFShape
PHP Manual

SWFShape::drawArc

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFShape::drawArc — Draws an arc of radius r centered at the current location, from angle startAngle to angle endAngle measured clockwise from 12 o'clock

Açıklama

void SWFShape::drawArc ( float $r , float $startAngle , float $endAngle )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SWFShape::drawCircle() - Draws a circle of radius r centered at the current location, in a counter-clockwise fashion

SWFShape::__construct
SWFShape::drawCircle
SWFShape


Draws a circle of radius r centered at the current location, in a counter-clockwise fashion

SWFShape::drawArc
SWFShape::drawCubic
SWFShape
PHP Manual

SWFShape::drawCircle

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFShape::drawCircle — Draws a circle of radius r centered at the current location, in a counter-clockwise fashion

Açıklama

void SWFShape::drawCircle ( float $r )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Dönen Değerler

Hiçbir değer dönmez.

SWFShape::drawArc
SWFShape::drawCubic
SWFShape


Draws a cubic bezier curve using the current position and the three given points as control points

SWFShape::drawCircle
SWFShape::drawCubicTo
SWFShape
PHP Manual

SWFShape::drawCubic

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFShape::drawCubic — Draws a cubic bezier curve using the current position and the three given points as control points

Açıklama

int SWFShape::drawCubic ( float $bx , float $by , float $cx , float $cy , float $dx , float $dy )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Ayrıca Bakınız

  • SWFShape::drawCubicTo() - Draws a cubic bezier curve using the current position and the three given points as control points

SWFShape::drawCircle
SWFShape::drawCubicTo
SWFShape


Draws a cubic bezier curve using the current position and the three given points as control points

SWFShape::drawCubic
SWFShape::drawCurve
SWFShape
PHP Manual

SWFShape::drawCubicTo

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFShape::drawCubicTo — Draws a cubic bezier curve using the current position and the three given points as control points

Açıklama

int SWFShape::drawCubicTo ( float $bx , float $by , float $cx , float $cy , float $dx , float $dy )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Ayrıca Bakınız

  • SWFShape::drawCubic() - Draws a cubic bezier curve using the current position and the three given points as control points

SWFShape::drawCubic
SWFShape::drawCurve
SWFShape


Draws a curve (relative)

SWFShape::drawCubicTo
SWFShape::drawCurveTo
SWFShape
PHP Manual

SWFShape::drawCurve

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFShape::drawCurve — Draws a curve (relative)

Açıklama

int SWFShape::drawCurve ( float $controldx , float $controldy , float $anchordx , float $anchordy [, float $targetdx ], float $targetdy )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swfshape::drawcurve() draws a quadratic curve (using the current line style,set by swfshape::setline()) from the current pen position to the relative position (anchorx,anchory) using relative control point (controlx,controly). That is, head towards the control point, then smoothly turn to the anchor point.

With 6 parameters, it draws a cubic bezier to point (x+targetdx, x+targetdy) with control points (x+controldx, y+controldy) and (x+anchordx, y+anchordy).

Ayrıca Bakınız

  • SWFShape::drawCurve()

SWFShape::drawCubicTo
SWFShape::drawCurveTo
SWFShape


Draws a curve

SWFShape::drawCurve
SWFShape::drawGlyph
SWFShape
PHP Manual

SWFShape::drawCurveTo

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFShape::drawCurveTo — Draws a curve

Açıklama

int SWFShape::drawCurveTo ( float $controlx , float $controly , float $anchorx , float $anchory [, float $targetx ], float $targety )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swfshape::drawcurveto() draws a quadratic curve (using the current line style, set by swfshape::setline()) from the current pen position to (anchorx,anchory) using (controlx,controly) as a control point. That is, head towards the control point, then smoothly turn to the anchor point.

With 6 parameters, it draws a cubic bezier to point (targetx, targety) with control points (controlx, controly) and (anchorx, anchory).

Ayrıca Bakınız

  • SWFShape::drawCurveTo()

SWFShape::drawCurve
SWFShape::drawGlyph
SWFShape


Draws the first character in the given string into the shape using the glyph definition from the given font

SWFShape::drawCurveTo
SWFShape::drawLine
SWFShape
PHP Manual

SWFShape::drawGlyph

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFShape::drawGlyph — Draws the first character in the given string into the shape using the glyph definition from the given font

Açıklama

void SWFShape::drawGlyph ( SWFFont $font , string $character [, int $size ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Dönen Değerler

Hiçbir değer dönmez.

SWFShape::drawCurveTo
SWFShape::drawLine
SWFShape


Draws a line (relative)

SWFShape::drawGlyph
SWFShape::drawLineTo
SWFShape
PHP Manual

SWFShape::drawLine

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFShape::drawLine — Draws a line (relative)

Açıklama

void SWFShape::drawLine ( float $dx , float $dy )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swfshape::drawline() draws a line (using the current line style set by swfshape::setline()) from the current pen position to displacement (dx,dy).

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SWFShape::drawLineTo() - Draws a line

SWFShape::drawGlyph
SWFShape::drawLineTo
SWFShape


Draws a line

SWFShape::drawLine
SWFShape::movePen
SWFShape
PHP Manual

SWFShape::drawLineTo

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFShape::drawLineTo — Draws a line

Açıklama

void SWFShape::drawLineTo ( float $x , float $y )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swfshape::setrightfill() draws a line (using the current line style, set by swfshape::setline()) from the current pen position to point (x,y) in the shape's coordinate space.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SWFShape::drawLine() - Draws a line (relative)

SWFShape::drawLine
SWFShape::movePen
SWFShape


Moves the shape's pen (relative)

SWFShape::drawLineTo
SWFShape::movePenTo
SWFShape
PHP Manual

SWFShape::movePen

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFShape::movePen — Moves the shape's pen (relative)

Açıklama

void SWFShape::movePen ( float $dx , float $dy )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swfshape::setrightfill() move the shape's pen from coordinates (current x,current y) to (current x + dx, current y + dy) in the shape's coordinate space.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SWFShape::movePenTo() - Moves the shape's pen

SWFShape::drawLineTo
SWFShape::movePenTo
SWFShape


Moves the shape's pen

SWFShape::movePen
SWFShape::setLeftFill
SWFShape
PHP Manual

SWFShape::movePenTo

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFShape::movePenTo — Moves the shape's pen

Açıklama

void SWFShape::movePenTo ( float $x , float $y )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swfshape::setrightfill() move the shape's pen to (x,y) in the shape's coordinate space.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SWFShape::movePen() - Moves the shape's pen (relative)

SWFShape::movePen
SWFShape::setLeftFill
SWFShape


Sets left rasterizing color

SWFShape::movePenTo
SWFShape::setLine
SWFShape
PHP Manual

SWFShape::setLeftFill

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFShape::setLeftFill — Sets left rasterizing color

Açıklama

void SWFShape::setLeftFill ( SWFGradient $fill )
void setLeftFill ( int $red , int $green , int $blue [, int $a ] )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

What this nonsense is about is, every edge segment borders at most two fills. When rasterizing the object, it's pretty handy to know what those fills are ahead of time, so the swf format requires these to be specified.

swfshape::setleftfill() sets the fill on the left side of the edge- that is, on the interior if you're defining the outline of the shape in a counter-clockwise fashion. The fill object is an SWFFill object returned from one of the addFill functions above.

This seems to be reversed when you're defining a shape in a morph, though. If your browser crashes, just try setting the fill on the other side.

Shortcut for $swfshape->setleftfill($s->addfill($r, $g, $b [, $a]));.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SWFShape::setRightFill() - Sets right rasterizing color

SWFShape::movePenTo
SWFShape::setLine
SWFShape


Sets the shape's line style

SWFShape::setLeftFill
SWFShape::setRightFill
SWFShape
PHP Manual

SWFShape::setLine

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFShape::setLine — Sets the shape's line style

Açıklama

void SWFShape::setLine ( SWFShape $shape )
void setLine ( int $width , int $red , int $green , int $blue [, int $a ] )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swfshape::setline() sets the shape's line style. width is the line's width. If width is 0, the line's style is removed (then, all other arguments are ignored). If width > 0, then line's color is set to red, green, blue. Last parameter a is optional.

You must declare all line styles before you use them (see example).

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

This simple example will draw a big "!#%*@", in funny colors and gracious style.

Örnek 1 swfshape::setline() example

<?php
$s = new SWFShape();
$f1 = $s->addFill(0xff, 0, 0);
$f2 = $s->addFill(0xff, 0x7f, 0);
$f3 = $s->addFill(0xff, 0xff, 0);
$f4 = $s->addFill(0, 0xff, 0);
$f5 = $s->addFill(0, 0, 0xff);

// bug: have to declare all line styles before you use them
$s->setLine(40, 0x7f, 0, 0);
$s->setLine(40, 0x7f, 0x3f, 0);
$s->setLine(40, 0x7f, 0x7f, 0);
$s->setLine(40, 0, 0x7f, 0);
$s->setLine(40, 0, 0, 0x7f);

$f = new SWFFont('Techno.fdb');

$s->setRightFill($f1);
$s->setLine(40, 0x7f, 0, 0);
$s->drawGlyph($f, '!');
$s->movePen($f->getWidth('!'), 0);

$s->setRightFill($f2);
$s->setLine(40, 0x7f, 0x3f, 0);
$s->drawGlyph($f, '#');
$s->movePen($f->getWidth('#'), 0);

$s->setRightFill($f3);
$s->setLine(40, 0x7f, 0x7f, 0);
$s->drawGlyph($f, '%');
$s->movePen($f->getWidth('%'), 0);

$s->setRightFill($f4);
$s->setLine(40, 0, 0x7f, 0);
$s->drawGlyph($f, '*');
$s->movePen($f->getWidth('*'), 0);

$s->setRightFill($f5);
$s->setLine(40, 0, 0, 0x7f);
$s->drawGlyph($f, '@');

$m = new SWFMovie();
$m->setDimension(3000,2000);
$m->setRate(12.0);
$i = $m->add($s);
$i->moveTo(1500-$f->getWidth("!#%*@")/2, 1000+$f->getAscent()/2);

header('Content-type: application/x-shockwave-flash');
$m->output();
?>

Dönen Değerler

Hiçbir değer dönmez.

SWFShape::setLeftFill
SWFShape::setRightFill
SWFShape


Sets right rasterizing color

SWFShape::setLine
SWFSound
SWFShape
PHP Manual

SWFShape::setRightFill

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

SWFShape::setRightFill — Sets right rasterizing color

Açıklama

void SWFShape::setRightFill ( SWFGradient $fill )
void setRightFill ( int $red , int $green , int $blue [, int $a ] )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Shortcut for $swfshape->setrightfill($s->addfill($r, $g, $b [, $a]));.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SWFShape::setLeftFill() - Sets left rasterizing color

SWFShape::setLine
SWFSound
SWFShape


The SWFSound class

(PHP 5 <= 5.3.0, PECL ming SVN)

Giriş

SWFSound.

Sınıf Sözdizimi

SWFSound {
/* Yöntemler */
__construct ( string $filename [, int $flags = 0 ] )
}

İçindekiler

  • SWFSound::__construct — Returns a new SWFSound object from given file
SWFShape::setRightFill
SWFSound::__construct
Ming


Returns a new SWFSound object from given file

SWFSound
SWFSoundInstance
SWFSound
PHP Manual

SWFSound::__construct

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFSound::__construct — Returns a new SWFSound object from given file

Açıklama

SWFSound::__construct ( string $filename [, int $flags = 0 ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

SWFSound
SWFSoundInstance
SWFSound


The SWFSoundInstance class

(PHP 5 <= 5.3.0, PECL ming SVN)

Giriş

SWFSoundInstance objects are returned by the SWFSprite::startSound() and SWFMovie::startSound() methods.

Sınıf Sözdizimi

SWFSoundInstance {
/* Yöntemler */
void loopCount ( int $point )
void loopInPoint ( int $point )
void loopOutPoint ( int $point )
void noMultiple ( void )
}

İçindekiler

  • SWFSoundInstance::loopCount — Açıklama
  • SWFSoundInstance::loopInPoint — Açıklama
  • SWFSoundInstance::loopOutPoint — Açıklama
  • SWFSoundInstance::noMultiple — Açıklama
SWFSound::__construct
SWFSoundInstance::loopCount
Ming


SWFSoundInstance
SWFSoundInstance::loopInPoint
SWFSoundInstance
PHP Manual

SWFSoundInstance::loopCount

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFSoundInstance::loopCount —

Açıklama

void SWFSoundInstance::loopCount ( int $point )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

point

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SWFSoundInstance::loopOutPoint() - Açıklama

SWFSoundInstance
SWFSoundInstance::loopInPoint
SWFSoundInstance


SWFSoundInstance::loopCount
SWFSoundInstance::loopOutPoint
SWFSoundInstance
PHP Manual

SWFSoundInstance::loopInPoint

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFSoundInstance::loopInPoint —

Açıklama

void SWFSoundInstance::loopInPoint ( int $point )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

point

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SWFSoundInstance::loopOutPoint() - Açıklama

SWFSoundInstance::loopCount
SWFSoundInstance::loopOutPoint
SWFSoundInstance


SWFSoundInstance::loopInPoint
SWFSoundInstance::noMultiple
SWFSoundInstance
PHP Manual

SWFSoundInstance::loopOutPoint

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFSoundInstance::loopOutPoint —

Açıklama

void SWFSoundInstance::loopOutPoint ( int $point )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

point

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SWFSoundInstance::loopInPoint() - Açıklama

SWFSoundInstance::loopInPoint
SWFSoundInstance::noMultiple
SWFSoundInstance


SWFSoundInstance::loopOutPoint
SWFSprite
SWFSoundInstance
PHP Manual

SWFSoundInstance::noMultiple

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFSoundInstance::noMultiple —

Açıklama

void SWFSoundInstance::noMultiple ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Dönen Değerler

Hiçbir değer dönmez.

SWFSoundInstance::loopOutPoint
SWFSprite
SWFSoundInstance


The SWFSprite class

(PHP 5 <= 5.3.0, PECL ming SVN)

Giriş

An SWFSprite is also known as a "movie clip", this allows one to create objects which are animated in their own timelines. Hence, the sprite has most of the same methods as the movie.

Sınıf Sözdizimi

SWFSprite {
/* Yöntemler */
void add ( object $object )
__construct ( void )
void labelFrame ( string $label )
void nextFrame ( void )
void remove ( object $object )
void setFrames ( int $number )
SWFSoundInstance startSound ( SWFSound $sount )
void stopSound ( SWFSound $sount )
}

İçindekiler

  • SWFSprite::add — Adds an object to a sprite
  • SWFSprite::__construct — Creates a movie clip (a sprite)
  • SWFSprite::labelFrame — Labels frame
  • SWFSprite::nextFrame — Moves to the next frame of the animation
  • SWFSprite::remove — Removes an object to a sprite
  • SWFSprite::setFrames — Sets the total number of frames in the animation
  • SWFSprite::startSound — Açıklama
  • SWFSprite::stopSound — Açıklama
SWFSoundInstance::noMultiple
SWFSprite::add
Ming


Adds an object to a sprite

SWFSprite
SWFSprite::__construct
SWFSprite
PHP Manual

SWFSprite::add

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFSprite::add — Adds an object to a sprite

Açıklama

void SWFSprite::add ( object $object )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swfsprite::add() adds a swfshape(), a
swfbutton(), a swftext(),
a swfaction() or a swfsprite() object.

For displayable types (swfshape(),
swfbutton(), swftext(),
swfaction() or swfsprite()),
this returns a handle  to the object in a display list.

Dönen Değerler

Hiçbir değer dönmez.

SWFSprite
SWFSprite::__construct
SWFSprite


Creates a movie clip (a sprite)

SWFSprite::add
SWFSprite::labelFrame
SWFSprite
PHP Manual

SWFSprite::__construct

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFSprite::__construct — Creates a movie clip (a sprite)

Açıklama

SWFSprite::__construct ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Creates a new SWFSprite object.

SWFSprite::add
SWFSprite::labelFrame
SWFSprite


Labels frame

SWFSprite::__construct
SWFSprite::nextFrame
SWFSprite
PHP Manual

SWFSprite::labelFrame

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFSprite::labelFrame — Labels frame

Açıklama

void SWFSprite::labelFrame ( string $label )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Dönen Değerler

Hiçbir değer dönmez.

SWFSprite::__construct
SWFSprite::nextFrame
SWFSprite


Moves to the next frame of the animation

SWFSprite::labelFrame
SWFSprite::remove
SWFSprite
PHP Manual

SWFSprite::nextFrame

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFSprite::nextFrame — Moves to the next frame of the animation

Açıklama

void SWFSprite::nextFrame ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swfsprite::setframes() moves to the next frame of the animation.

Dönen Değerler

Hiçbir değer dönmez.

SWFSprite::labelFrame
SWFSprite::remove
SWFSprite


Removes an object to a sprite

SWFSprite::nextFrame
SWFSprite::setFrames
SWFSprite
PHP Manual

SWFSprite::remove

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFSprite::remove — Removes an object to a sprite

Açıklama

void SWFSprite::remove ( object $object )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swfsprite::remove() remove a swfshape(), a
swfbutton(), a swftext(),
a swfaction() or a swfsprite() object
from the sprite.

Dönen Değerler

Hiçbir değer dönmez.

SWFSprite::nextFrame
SWFSprite::setFrames
SWFSprite


Sets the total number of frames in the animation

SWFSprite::remove
SWFSprite::startSound
SWFSprite
PHP Manual

SWFSprite::setFrames

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFSprite::setFrames — Sets the total number of frames in the animation

Açıklama

void SWFSprite::setFrames ( int $number )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swfsprite::setframes() sets the total number of frames in the animation to numberofframes.

Dönen Değerler

Hiçbir değer dönmez.

SWFSprite::remove
SWFSprite::startSound
SWFSprite


SWFSprite::setFrames
SWFSprite::stopSound
SWFSprite
PHP Manual

SWFSprite::startSound

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFSprite::startSound —

Açıklama

SWFSoundInstance SWFSprite::startSound ( SWFSound $sount )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Ayrıca Bakınız

  • SWFSprite::stopSound() - Açıklama

SWFSprite::setFrames
SWFSprite::stopSound
SWFSprite


SWFSprite::startSound
SWFText
SWFSprite
PHP Manual

SWFSprite::stopSound

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFSprite::stopSound —

Açıklama

void SWFSprite::stopSound ( SWFSound $sount )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SWFSprite::startSound() - Açıklama

SWFSprite::startSound
SWFText
SWFSprite


The SWFText class

(PHP 5 <= 5.3.0, PECL ming SVN)

Giriş

SWFText.

Sınıf Sözdizimi

SWFText {
/* Yöntemler */
void addString ( string $string )
void addUTF8String ( string $text )
__construct ( void )
float getAscent ( void )
float getDescent ( void )
float getLeading ( void )
float getUTF8Width ( string $string )
float getWidth ( string $string )
void moveTo ( float $x , float $y )
void setColor ( int $red , int $green , int $blue [, int $a = 255 ] )
void setFont ( SWFFont $font )
void setHeight ( float $height )
void setSpacing ( float $spacing )
}

İçindekiler

  • SWFText::addString — Draws a string
  • SWFText::addUTF8String — Writes the given text into this SWFText object at the current pen position, using the current font, height, spacing, and color
  • SWFText::__construct — Creates a new SWFText object
  • SWFText::getAscent — Returns the ascent of the current font at its current size, or 0 if not available
  • SWFText::getDescent — Returns the descent of the current font at its current size, or 0 if not available
  • SWFText::getLeading — Returns the leading of the current font at its current size, or 0 if not available
  • SWFText::getUTF8Width — calculates the width of the given string in this text objects current font and size
  • SWFText::getWidth — Computes string's width
  • SWFText::moveTo — Moves the pen
  • SWFText::setColor — Sets the current text color
  • SWFText::setFont — Sets the current font
  • SWFText::setHeight — Sets the current font height
  • SWFText::setSpacing — Sets the current font spacing
SWFSprite::stopSound
SWFText::addString
Ming


Draws a string

SWFText
SWFText::addUTF8String
SWFText
PHP Manual

SWFText::addString

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFText::addString — Draws a string

Açıklama

void SWFText::addString ( string $string )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swftext::addstring() draws the string string at the current pen (cursor) location. Pen is at the baseline of the text; i.e., ascending text is in the -y direction.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SWFText::addUTF8String() - Writes the given text into this SWFText object at the current pen position, using the current font, height, spacing, and color

SWFText
SWFText::addUTF8String
SWFText


Writes the given text into this SWFText object at the current pen position, using the current font, height, spacing, and color

SWFText::addString
SWFText::__construct
SWFText
PHP Manual

SWFText::addUTF8String

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFText::addUTF8String — Writes the given text into this SWFText object at the current pen position, using the current font, height, spacing, and color

Açıklama

void SWFText::addUTF8String ( string $text )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SWFText::addString() - Draws a string

SWFText::addString
SWFText::__construct
SWFText


Creates a new SWFText object

SWFText::addUTF8String
SWFText::getAscent
SWFText
PHP Manual

SWFText::__construct

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFText::__construct — Creates a new SWFText object

Açıklama

SWFText::__construct ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Creates a new SWFText object, fresh for manipulating.

Örnekler

This simple example will draw a big yellow "PHP generates Flash with Ming" text, on white background.

Örnek 1 swftext() example

<?php
$f = new SWFFont("Techno.fdb");
$t = new SWFText();
$t->setFont($f);
$t->moveTo(200, 2400);
$t->setColor(0xff, 0xff, 0);
$t->setHeight(1200);
$t->addString("PHP generates Flash with Ming!!");

$m = new SWFMovie();
$m->setDimension(5400, 3600);

$m->add($t);

header('Content-type: application/x-shockwave-flash');
$m->output();
?>

SWFText::addUTF8String
SWFText::getAscent
SWFText


Returns the ascent of the current font at its current size, or 0 if not available

SWFText::__construct
SWFText::getDescent
SWFText
PHP Manual

SWFText::getAscent

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFText::getAscent — Returns the ascent of the current font at its current size, or 0 if not available

Açıklama

float SWFText::getAscent ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Ayrıca Bakınız

  • SWFText::getDescent() - Returns the descent of the current font at its current size, or 0 if not available

SWFText::__construct
SWFText::getDescent
SWFText


Returns the descent of the current font at its current size, or 0 if not available

SWFText::getAscent
SWFText::getLeading
SWFText
PHP Manual

SWFText::getDescent

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFText::getDescent — Returns the descent of the current font at its current size, or 0 if not available

Açıklama

float SWFText::getDescent ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Ayrıca Bakınız

  • SWFText::getAscent() - Returns the ascent of the current font at its current size, or 0 if not available

SWFText::getAscent
SWFText::getLeading
SWFText


Returns the leading of the current font at its current size, or 0 if not available

SWFText::getDescent
SWFText::getUTF8Width
SWFText
PHP Manual

SWFText::getLeading

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFText::getLeading — Returns the leading of the current font at its current size, or 0 if not available

Açıklama

float SWFText::getLeading ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

SWFText::getDescent
SWFText::getUTF8Width
SWFText


calculates the width of the given string in this text objects current font and size

SWFText::getLeading
SWFText::getWidth
SWFText
PHP Manual

SWFText::getUTF8Width

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFText::getUTF8Width — calculates the width of the given string in this text objects current font and size

Açıklama

float SWFText::getUTF8Width ( string $string )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Ayrıca Bakınız

  • SWFText::getWidth() - Computes string's width

SWFText::getLeading
SWFText::getWidth
SWFText


Computes string's width

SWFText::getUTF8Width
SWFText::moveTo
SWFText
PHP Manual

SWFText::getWidth

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFText::getWidth — Computes string's width

Açıklama

float SWFText::getWidth ( string $string )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Returns the rendered width of the string at the text object's current font, scale, and spacing settings.

Ayrıca Bakınız

  • SWFText::getUTF8Width() - calculates the width of the given string in this text objects current font and size

SWFText::getUTF8Width
SWFText::moveTo
SWFText


Moves the pen

SWFText::getWidth
SWFText::setColor
SWFText
PHP Manual

SWFText::moveTo

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFText::moveTo — Moves the pen

Açıklama

void SWFText::moveTo ( float $x , float $y )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swftext::moveto() moves the pen (or cursor, if that makes more sense) to (x,y) in text object's coordinate space. If either is zero, though, value in that dimension stays the same. Annoying, should be fixed.

Dönen Değerler

Hiçbir değer dönmez.

SWFText::getWidth
SWFText::setColor
SWFText


Sets the current text color

SWFText::moveTo
SWFText::setFont
SWFText
PHP Manual

SWFText::setColor

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFText::setColor — Sets the current text color

Açıklama

void SWFText::setColor ( int $red , int $green , int $blue [, int $a = 255 ] )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Changes the current text color.

Değiştirgeler

These parameters are integers between 0 and 255 or hexadecimals between 0x00 and 0xFF:

red

Value of red component

green

Value of green component

blue

Value of blue component

a

Value of alpha component

Dönen Değerler

Hiçbir değer dönmez.

SWFText::moveTo
SWFText::setFont
SWFText


Sets the current font

SWFText::setColor
SWFText::setHeight
SWFText
PHP Manual

SWFText::setFont

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFText::setFont — Sets the current font

Açıklama

void SWFText::setFont ( SWFFont $font )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swftext::setfont() sets the current font to font.

Dönen Değerler

Hiçbir değer dönmez.

SWFText::setColor
SWFText::setHeight
SWFText


Sets the current font height

SWFText::setFont
SWFText::setSpacing
SWFText
PHP Manual

SWFText::setHeight

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFText::setHeight — Sets the current font height

Açıklama

void SWFText::setHeight ( float $height )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swftext::setheight() sets the current font height to height. Default is 240.

Dönen Değerler

Hiçbir değer dönmez.

SWFText::setFont
SWFText::setSpacing
SWFText


Sets the current font spacing

SWFText::setHeight
SWFTextField
SWFText
PHP Manual

SWFText::setSpacing

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFText::setSpacing — Sets the current font spacing

Açıklama

void SWFText::setSpacing ( float $spacing )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swftext::setspacing() sets the current font spacing to spacing. Default is 1.0. 0 is all of the letters written at the same point. This doesn't really work that well because it inflates the advance across the letter, doesn't add the same amount of spacing between the letters. I should try and explain that better, prolly. Or just fix the damn thing to do constant spacing. This was really just a way to figure out how letter advances work, anyway.. So nyah.

Dönen Değerler

Hiçbir değer dönmez.

SWFText::setHeight
SWFTextField
SWFText


The SWFTextField class

(PHP 5 <= 5.3.0, PECL ming SVN)

Giriş

SWFTextField.

Sınıf Sözdizimi

SWFTextField {
/* Yöntemler */
void addChars ( string $chars )
void addString ( string $string )
void align ( int $alignement )
__construct ([ int $flags ] )
void setBounds ( float $width , float $height )
void setColor ( int $red , int $green , int $blue [, int $a = 255 ] )
void setFont ( SWFFont $font )
void setHeight ( float $height )
void setIndentation ( float $width )
void setLeftMargin ( float $width )
void setLineSpacing ( float $height )
void setMargins ( float $left , float $right )
void setName ( string $name )
void setPadding ( float $padding )
void setRightMargin ( float $width )
}

İçindekiler

  • SWFTextField::addChars — adds characters to a font that will be available within a textfield
  • SWFTextField::addString — Concatenates the given string to the text field
  • SWFTextField::align — Sets the text field alignment
  • SWFTextField::__construct — Creates a text field object
  • SWFTextField::setBounds — Sets the text field width and height
  • SWFTextField::setColor — Sets the color of the text field
  • SWFTextField::setFont — Sets the text field font
  • SWFTextField::setHeight — Sets the font height of this text field font
  • SWFTextField::setIndentation — Sets the indentation of the first line
  • SWFTextField::setLeftMargin — Sets the left margin width of the text field
  • SWFTextField::setLineSpacing — Sets the line spacing of the text field
  • SWFTextField::setMargins — Sets the margins width of the text field
  • SWFTextField::setName — Sets the variable name
  • SWFTextField::setPadding — Sets the padding of this textfield
  • SWFTextField::setRightMargin — Sets the right margin width of the text field
SWFText::setSpacing
SWFTextField::addChars
Ming


adds characters to a font that will be available within a textfield

SWFTextField
SWFTextField::addString
SWFTextField
PHP Manual

SWFTextField::addChars

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFTextField::addChars — adds characters to a font that will be available within a textfield

Açıklama

void SWFTextField::addChars ( string $chars )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SWFTextField::addString() - Concatenates the given string to the text field

SWFTextField
SWFTextField::addString
SWFTextField


Concatenates the given string to the text field

SWFTextField::addChars
SWFTextField::align
SWFTextField
PHP Manual

SWFTextField::addString

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFTextField::addString — Concatenates the given string to the text field

Açıklama

void SWFTextField::addString ( string $string )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swftextfield::setname() concatenates the string string to the text field.

Dönen Değerler

Hiçbir değer dönmez.

SWFTextField::addChars
SWFTextField::align
SWFTextField


Sets the text field alignment

SWFTextField::addString
SWFTextField::__construct
SWFTextField
PHP Manual

SWFTextField::align

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFTextField::align — Sets the text field alignment

Açıklama

void SWFTextField::align ( int $alignement )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swftextfield::align() sets the text field alignment to alignement. Valid values for alignement are : SWFTEXTFIELD_ALIGN_LEFT, SWFTEXTFIELD_ALIGN_RIGHT, SWFTEXTFIELD_ALIGN_CENTER and SWFTEXTFIELD_ALIGN_JUSTIFY.

Dönen Değerler

Hiçbir değer dönmez.

SWFTextField::addString
SWFTextField::__construct
SWFTextField


Creates a text field object

SWFTextField::align
SWFTextField::setBounds
SWFTextField
PHP Manual

SWFTextField::__construct

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFTextField::__construct — Creates a text field object

Açıklama

SWFTextField::__construct ([ int $flags ] )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swftextfield() creates a new text field object. Text Fields are less flexible than swftext() objects- they can't be rotated, scaled non-proportionally, or skewed, but they can be used as form entries, and they can use browser-defined fonts.

The optional flags change the text field's behavior. It has the following possibles values :

  • SWFTEXTFIELD_DRAWBOX draws the outline of the textfield
  • SWFTEXTFIELD_HASLENGTH
  • SWFTEXTFIELD_HTML allows text markup using HTML-tags
  • SWFTEXTFIELD_MULTILINE allows multiple lines
  • SWFTEXTFIELD_NOEDIT indicates that the field shouldn't be user-editable
  • SWFTEXTFIELD_NOSELECT makes the field non-selectable
  • SWFTEXTFIELD_PASSWORD obscures the data entry
  • SWFTEXTFIELD_WORDWRAP allows text to wrap
Flags are combined with the bitwise OR operation. For example,
<?php
$t = newSWFTextField(SWFTEXTFIELD_PASSWORD | SWFTEXTFIELD_NOEDIT);
?>
creates a totally useless non-editable password field.

SWFTextField has the following methods : swftextfield::setfont(),
swftextfield::setbounds(), swftextfield::align(),
swftextfield::setheight(), swftextfield::setleftmargin(),
swftextfield::setrightmargin(), swftextfield::setmargins(),
swftextfield::setindentation(), swftextfield::setlinespacing(),
swftextfield::setcolor(), swftextfield::setname() and
swftextfield::addstring().

SWFTextField::align
SWFTextField::setBounds
SWFTextField


Sets the text field width and height

SWFTextField::__construct
SWFTextField::setColor
SWFTextField
PHP Manual

SWFTextField::setBounds

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFTextField::setBounds — Sets the text field width and height

Açıklama

void SWFTextField::setBounds ( float $width , float $height )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swftextfield::setbounds() sets the text field width to width and height to height. If you don't set the bounds yourself, Ming makes a poor guess at what the bounds are.

Dönen Değerler

Hiçbir değer dönmez.

SWFTextField::__construct
SWFTextField::setColor
SWFTextField


Sets the color of the text field

SWFTextField::setBounds
SWFTextField::setFont
SWFTextField
PHP Manual

SWFTextField::setColor

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFTextField::setColor — Sets the color of the text field

Açıklama

void SWFTextField::setColor ( int $red , int $green , int $blue [, int $a = 255 ] )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swftextfield::setcolor() sets the color of the text field. Default is fully opaque black. Color is represented using RGB system.

Değiştirgeler

These parameters are integers between 0 and 255 or hexadecimals between 0x00 and 0xFF:

red

Value of red component

green

Value of green component

blue

Value of blue component

a

Value of alpha component

Dönen Değerler

Hiçbir değer dönmez.

SWFTextField::setBounds
SWFTextField::setFont
SWFTextField


Sets the text field font

SWFTextField::setColor
SWFTextField::setHeight
SWFTextField
PHP Manual

SWFTextField::setFont

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFTextField::setFont — Sets the text field font

Açıklama

void SWFTextField::setFont ( SWFFont $font )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swftextfield::setfont() sets the text field font to the [browser-defined?] font font.

Dönen Değerler

Hiçbir değer dönmez.

SWFTextField::setColor
SWFTextField::setHeight
SWFTextField


Sets the font height of this text field font

SWFTextField::setFont
SWFTextField::setIndentation
SWFTextField
PHP Manual

SWFTextField::setHeight

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFTextField::setHeight — Sets the font height of this text field font

Açıklama

void SWFTextField::setHeight ( float $height )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swftextfield::setheight() sets the font height of this text field font to the given height height. Default is 240.

Dönen Değerler

Hiçbir değer dönmez.

SWFTextField::setFont
SWFTextField::setIndentation
SWFTextField


Sets the indentation of the first line

SWFTextField::setHeight
SWFTextField::setLeftMargin
SWFTextField
PHP Manual

SWFTextField::setIndentation

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFTextField::setIndentation — Sets the indentation of the first line

Açıklama

void SWFTextField::setIndentation ( float $width )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swftextfield::setindentation() sets the indentation of the first line in the text field, to width.

Dönen Değerler

Hiçbir değer dönmez.

SWFTextField::setHeight
SWFTextField::setLeftMargin
SWFTextField


Sets the left margin width of the text field

SWFTextField::setIndentation
SWFTextField::setLineSpacing
SWFTextField
PHP Manual

SWFTextField::setLeftMargin

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFTextField::setLeftMargin — Sets the left margin width of the text field

Açıklama

void SWFTextField::setLeftMargin ( float $width )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swftextfield::setleftmargin() sets the left margin width of the text field to width. Default is 0.

Dönen Değerler

Hiçbir değer dönmez.

SWFTextField::setIndentation
SWFTextField::setLineSpacing
SWFTextField


Sets the line spacing of the text field

SWFTextField::setLeftMargin
SWFTextField::setMargins
SWFTextField
PHP Manual

SWFTextField::setLineSpacing

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFTextField::setLineSpacing — Sets the line spacing of the text field

Açıklama

void SWFTextField::setLineSpacing ( float $height )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swftextfield::setlinespacing() sets the line spacing of the text field to the height of height. Default is 40.

Dönen Değerler

Hiçbir değer dönmez.

SWFTextField::setLeftMargin
SWFTextField::setMargins
SWFTextField


Sets the margins width of the text field

SWFTextField::setLineSpacing
SWFTextField::setName
SWFTextField
PHP Manual

SWFTextField::setMargins

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFTextField::setMargins — Sets the margins width of the text field

Açıklama

void SWFTextField::setMargins ( float $left , float $right )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swftextfield::setmargins() set both margins at once, for the man on the go.

Dönen Değerler

Hiçbir değer dönmez.

SWFTextField::setLineSpacing
SWFTextField::setName
SWFTextField


Sets the variable name

SWFTextField::setMargins
SWFTextField::setPadding
SWFTextField
PHP Manual

SWFTextField::setName

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFTextField::setName — Sets the variable name

Açıklama

void SWFTextField::setName ( string $name )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swftextfield::setname() sets the variable name of this text field to name, for form posting and action scripting purposes.

Dönen Değerler

Hiçbir değer dönmez.

SWFTextField::setMargins
SWFTextField::setPadding
SWFTextField


Sets the padding of this textfield

SWFTextField::setName
SWFTextField::setRightMargin
SWFTextField
PHP Manual

SWFTextField::setPadding

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFTextField::setPadding — Sets the padding of this textfield

Açıklama

void SWFTextField::setPadding ( float $padding )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Dönen Değerler

Hiçbir değer dönmez.

SWFTextField::setName
SWFTextField::setRightMargin
SWFTextField


Sets the right margin width of the text field

SWFTextField::setPadding
SWFVideoStream
SWFTextField
PHP Manual

SWFTextField::setRightMargin

(PHP 5 <= 5.3.0, PECL ming SVN)

SWFTextField::setRightMargin — Sets the right margin width of the text field

Açıklama

void SWFTextField::setRightMargin ( float $width )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

swftextfield::setrightmargin() sets the right margin width of the text field to width. Default is 0.

Dönen Değerler

Hiçbir değer dönmez.

SWFTextField::setPadding
SWFVideoStream
SWFTextField


The SWFVideoStream class

(PHP 5.0.5-5.3.0, PHP 7, PECL ming SVN)

Giriş

SWFVideoStream.

Sınıf Sözdizimi

SWFVideoStream {
/* Yöntemler */
__construct ([ string $file ] )
int getNumFrames ( void )
void setDimension ( int $x , int $y )
}

İçindekiler

  • SWFVideoStream::__construct — Returns a SWFVideoStream object
  • SWFVideoStream::getNumFrames — Returns the number of frames in the video
  • SWFVideoStream::setDimension — Sets video dimension
SWFTextField::setRightMargin
SWFVideoStream::__construct
Ming


Returns a SWFVideoStream object

SWFVideoStream
SWFVideoStream::getNumFrames
SWFVideoStream
PHP Manual

SWFVideoStream::__construct

(PHP 5.0.5-5.3.0, PHP 7, PECL ming SVN)

SWFVideoStream::__construct — Returns a SWFVideoStream object

Açıklama

SWFVideoStream::__construct ([ string $file ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

SWFVideoStream
SWFVideoStream::getNumFrames
SWFVideoStream


Returns the number of frames in the video

SWFVideoStream::__construct
SWFVideoStream::setDimension
SWFVideoStream
PHP Manual

SWFVideoStream::getNumFrames

(PHP 5.0.5-5.3.0, PHP 7, PECL ming SVN)

SWFVideoStream::getNumFrames — Returns the number of frames in the video

Açıklama

int SWFVideoStream::getNumFrames ( void )

This function returns the number of video-frames of a SWFVideoStream.

Dönen Değerler

Returns the number of frames, as an integer

SWFVideoStream::__construct
SWFVideoStream::setDimension
SWFVideoStream


Sets video dimension

SWFVideoStream::getNumFrames
PDF
SWFVideoStream
PHP Manual

SWFVideoStream::setDimension

(PHP 5.0.5-5.3.0, PHP 7, PECL ming SVN)

SWFVideoStream::setDimension — Sets video dimension

Açıklama

void SWFVideoStream::setDimension ( int $x , int $y )

Sets the width and height for streamed videos.

Değiştirgeler

x

Width in pixels.

y

Height in pixels.

Dönen Değerler

Hiçbir değer dönmez.

SWFVideoStream::getNumFrames
PDF
SWFVideoStream


PDF

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
    • Basic Usage Examples
  • PDF İşlevleri
    • PDF_activate_item — Activate structure element or other content item
    • PDF_add_annotation — Add annotation [deprecated]
    • PDF_add_bookmark — Add bookmark for current page [deprecated]
    • PDF_add_launchlink — Add launch annotation for current page [deprecated]
    • PDF_add_locallink — Add link annotation for current page [deprecated]
    • PDF_add_nameddest — Create named destination
    • PDF_add_note — Set annotation for current page [deprecated]
    • PDF_add_outline — Add bookmark for current page [deprecated]
    • PDF_add_pdflink — Add file link annotation for current page [deprecated]
    • PDF_add_table_cell — Add a cell to a new or existing table
    • PDF_add_textflow — Create Textflow or add text to existing Textflow
    • PDF_add_thumbnail — Add thumbnail for current page
    • PDF_add_weblink — Add weblink for current page [deprecated]
    • PDF_arc — Draw a counterclockwise circular arc segment
    • PDF_arcn — Draw a clockwise circular arc segment
    • PDF_attach_file — Add file attachment for current page [deprecated]
    • PDF_begin_document — Create new PDF file
    • PDF_begin_font — Start a Type 3 font definition
    • PDF_begin_glyph — Start glyph definition for Type 3 font
    • PDF_begin_item — Open structure element or other content item
    • PDF_begin_layer — Start layer
    • PDF_begin_page_ext — Start new page
    • PDF_begin_page — Start new page [deprecated]
    • PDF_begin_pattern — Start pattern definition
    • PDF_begin_template_ext — Start template definition
    • PDF_begin_template — Start template definition [deprecated]
    • PDF_circle — Draw a circle
    • PDF_clip — Clip to current path
    • PDF_close_image — Close image
    • PDF_close_pdi_page — Close the page handle
    • PDF_close_pdi — Close the input PDF document [deprecated]
    • PDF_close — Close pdf resource [deprecated]
    • PDF_closepath_fill_stroke — Close, fill and stroke current path
    • PDF_closepath_stroke — Close and stroke path
    • PDF_closepath — Close current path
    • PDF_concat — Concatenate a matrix to the CTM
    • PDF_continue_text — Output text in next line
    • PDF_create_3dview — Create 3D view
    • PDF_create_action — Create action for objects or events
    • PDF_create_annotation — Create rectangular annotation
    • PDF_create_bookmark — Create bookmark
    • PDF_create_field — Create form field
    • PDF_create_fieldgroup — Create form field group
    • PDF_create_gstate — Create graphics state object
    • PDF_create_pvf — Create PDFlib virtual file
    • PDF_create_textflow — Create textflow object
    • PDF_curveto — Draw Bezier curve
    • PDF_define_layer — Create layer definition
    • PDF_delete_pvf — Delete PDFlib virtual file
    • PDF_delete_table — Delete table object
    • PDF_delete_textflow — Delete textflow object
    • PDF_delete — Delete PDFlib object
    • PDF_encoding_set_char — Add glyph name and/or Unicode value
    • PDF_end_document — Close PDF file
    • PDF_end_font — Terminate Type 3 font definition
    • PDF_end_glyph — Terminate glyph definition for Type 3 font
    • PDF_end_item — Close structure element or other content item
    • PDF_end_layer — Deactivate all active layers
    • PDF_end_page_ext — Finish page
    • PDF_end_page — Finish page
    • PDF_end_pattern — Finish pattern
    • PDF_end_template — Finish template
    • PDF_endpath — End current path
    • PDF_fill_imageblock — Fill image block with variable data
    • PDF_fill_pdfblock — Fill PDF block with variable data
    • PDF_fill_stroke — Fill and stroke path
    • PDF_fill_textblock — Fill text block with variable data
    • PDF_fill — Fill current path
    • PDF_findfont — Prepare font for later use [deprecated]
    • PDF_fit_image — Place image or template
    • PDF_fit_pdi_page — Place imported PDF page
    • PDF_fit_table — Place table on page
    • PDF_fit_textflow — Format textflow in rectangular area
    • PDF_fit_textline — Place single line of text
    • PDF_get_apiname — Get name of unsuccessfull API function
    • PDF_get_buffer — Get PDF output buffer
    • PDF_get_errmsg — Get error text
    • PDF_get_errnum — Get error number
    • PDF_get_font — Get font [deprecated]
    • PDF_get_fontname — Get font name [deprecated]
    • PDF_get_fontsize — Font handling [deprecated]
    • PDF_get_image_height — Get image height [deprecated]
    • PDF_get_image_width — Get image width [deprecated]
    • PDF_get_majorversion — Get major version number [deprecated]
    • PDF_get_minorversion — Get minor version number [deprecated]
    • PDF_get_parameter — Get string parameter
    • PDF_get_pdi_parameter — Get PDI string parameter [deprecated]
    • PDF_get_pdi_value — Get PDI numerical parameter [deprecated]
    • PDF_get_value — Get numerical parameter
    • PDF_info_font — Query detailed information about a loaded font
    • PDF_info_matchbox — Query matchbox information
    • PDF_info_table — Retrieve table information
    • PDF_info_textflow — Query textflow state
    • PDF_info_textline — Perform textline formatting and query metrics
    • PDF_initgraphics — Reset graphic state
    • PDF_lineto — Draw a line
    • PDF_load_3ddata — Load 3D model
    • PDF_load_font — Search and prepare font
    • PDF_load_iccprofile — Search and prepare ICC profile
    • PDF_load_image — Open image file
    • PDF_makespotcolor — Make spot color
    • PDF_moveto — Set current point
    • PDF_new — Create PDFlib object
    • PDF_open_ccitt — Open raw CCITT image [deprecated]
    • PDF_open_file — Create PDF file [deprecated]
    • PDF_open_gif — Open GIF image [deprecated]
    • PDF_open_image_file — Read image from file [deprecated]
    • PDF_open_image — Use image data [deprecated]
    • PDF_open_jpeg — Open JPEG image [deprecated]
    • PDF_open_memory_image — Open image created with PHP's image functions [not supported]
    • PDF_open_pdi_document — Prepare a pdi document
    • PDF_open_pdi_page — Prepare a page
    • PDF_open_pdi — Open PDF file [deprecated]
    • PDF_open_tiff — Open TIFF image [deprecated]
    • PDF_pcos_get_number — Get value of pCOS path with type number or boolean
    • PDF_pcos_get_stream — Get contents of pCOS path with type stream, fstream, or string
    • PDF_pcos_get_string — Get value of pCOS path with type name, string, or boolean
    • PDF_place_image — Place image on the page [deprecated]
    • PDF_place_pdi_page — Place PDF page [deprecated]
    • PDF_process_pdi — Process imported PDF document
    • PDF_rect — Draw rectangle
    • PDF_restore — Restore graphics state
    • PDF_resume_page — Resume page
    • PDF_rotate — Rotate coordinate system
    • PDF_save — Save graphics state
    • PDF_scale — Scale coordinate system
    • PDF_set_border_color — Set border color of annotations [deprecated]
    • PDF_set_border_dash — Set border dash style of annotations [deprecated]
    • PDF_set_border_style — Set border style of annotations [deprecated]
    • PDF_set_char_spacing — Set character spacing [deprecated]
    • PDF_set_duration — Set duration between pages [deprecated]
    • PDF_set_gstate — Activate graphics state object
    • PDF_set_horiz_scaling — Set horizontal text scaling [deprecated]
    • PDF_set_info_author — Fill the author document info field [deprecated]
    • PDF_set_info_creator — Fill the creator document info field [deprecated]
    • PDF_set_info_keywords — Fill the keywords document info field [deprecated]
    • PDF_set_info_subject — Fill the subject document info field [deprecated]
    • PDF_set_info_title — Fill the title document info field [deprecated]
    • PDF_set_info — Fill document info field
    • PDF_set_layer_dependency — Define relationships among layers
    • PDF_set_leading — Set distance between text lines [deprecated]
    • PDF_set_parameter — Set string parameter
    • PDF_set_text_matrix — Set text matrix [deprecated]
    • PDF_set_text_pos — Set text position
    • PDF_set_text_rendering — Determine text rendering [deprecated]
    • PDF_set_text_rise — Set text rise [deprecated]
    • PDF_set_value — Set numerical parameter
    • PDF_set_word_spacing — Set spacing between words [deprecated]
    • PDF_setcolor — Set fill and stroke color
    • PDF_setdash — Set simple dash pattern
    • PDF_setdashpattern — Set dash pattern
    • PDF_setflat — Set flatness
    • PDF_setfont — Set font
    • PDF_setgray_fill — Set fill color to gray [deprecated]
    • PDF_setgray_stroke — Set stroke color to gray [deprecated]
    • PDF_setgray — Set color to gray [deprecated]
    • PDF_setlinecap — Set linecap parameter
    • PDF_setlinejoin — Set linejoin parameter
    • PDF_setlinewidth — Set line width
    • PDF_setmatrix — Set current transformation matrix
    • PDF_setmiterlimit — Set miter limit
    • PDF_setpolydash — Set complicated dash pattern [deprecated]
    • PDF_setrgbcolor_fill — Set fill rgb color values [deprecated]
    • PDF_setrgbcolor_stroke — Set stroke rgb color values [deprecated]
    • PDF_setrgbcolor — Set fill and stroke rgb color values [deprecated]
    • PDF_shading_pattern — Define shading pattern
    • PDF_shading — Define blend
    • PDF_shfill — Fill area with shading
    • PDF_show_boxed — Output text in a box [deprecated]
    • PDF_show_xy — Output text at given position
    • PDF_show — Output text at current position
    • PDF_skew — Skew the coordinate system
    • PDF_stringwidth — Return width of text
    • PDF_stroke — Stroke path
    • PDF_suspend_page — Suspend page
    • PDF_translate — Set origin of coordinate system
    • PDF_utf16_to_utf8 — Convert string from UTF-16 to UTF-8
    • PDF_utf32_to_utf16 — Convert string from UTF-32 to UTF-16
    • PDF_utf8_to_utf16 — Convert string from UTF-8 to UTF-16
SWFVideoStream::setDimension
Giriş
Salt Metin Olmayan MIME Çıktılama


Giriş

The PDF functions in PHP can create PDF files using the PDFlib library from PDFlib GmbH (» www.pdflib.com). A restricted version called PDFlib Lite 7 is available for free, but it is no longer maintained since 2010. PDFlib integration for PHP is still actively maintained by PDFlib GmbH. It is mainly targeted at the commercial PDFlib versions, but can also be used for the old PDFlib Lite.

If you want to use PDFlib we urge you start with the examples which are included in all PDFlib packages, and refer to the extensive manuals in PDF format which are also included. At a minimum you should take a look at the hello.php sample to learn basic setup for PDFlib usage.

Bilginize:

If you're interested in alternative free PDF generators that do not utilize external PDF libraries, see this related FAQ.

PDF
Yapılandırma/Kurulum
PDF


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
PDF


Gereksinimler

PDFlib Lite is available as open source. However, the PDFlib Lite license allows free use only under certain conditions. PDFlib Lite supports a subset of PDFlib's functionality; please see the PDFlib web site for details. The full version of PDFlib is available for download at » http://www.pdflib.com/products/pdflib-family/, but requires that you purchase a license for commercial use.

Issues with older versions of PDFlib

Any version of PHP 4 after March 9, 2000 does not support versions of PDFlib older than 3.0.

PDFlib 4.0 or greater is supported by PHP 4.3.0 and later.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu » PECL eklentisi PHP ile gelmez. Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/pdflib.

To get these functions to work in PHP < 4.3.9, you have to compile PHP with --with-pdflib[=DIR] . DIR is the PDFlib base install directory, defaults to /usr/local.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Özkaynak Türleri

PDF_new() creates a new PDFlib object required by most PDF functions.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
Örnekler
PDF


Örnekler

İçindekiler

  • Basic Usage Examples
Öntanımlı Sabitler
Basic Usage Examples
PDF


Basic Usage Examples

Most of the functions are fairly easy to use. The most difficult part is probably creating your first PDF document. The following example should help to get you started. It is developed for PHP 4 and creates the file hello.pdf with one page. It defines some document info field contents, loads the Helvetica-Bold font and outputs the text "Hello world! (says PHP)".

Örnek 1 Hello World example from PDFlib distribution for PHP 4

<?php
$p = PDF_new();

/*  open new PDF file; insert a file name to create the PDF on disk */
if (PDF_begin_document($p, "", "") == 0) {
    die("Error: " . PDF_get_errmsg($p));
}

PDF_set_info($p, "Creator", "hello.php");
PDF_set_info($p, "Author", "Rainer Schaaf");
PDF_set_info($p, "Title", "Hello world (PHP)!");

PDF_begin_page_ext($p, 595, 842, "");

$font = PDF_load_font($p, "Helvetica-Bold", "winansi", "");

PDF_setfont($p, $font, 24.0);
PDF_set_text_pos($p, 50, 700);
PDF_show($p, "Hello world!");
PDF_continue_text($p, "(says PHP)");
PDF_end_page_ext($p, "");

PDF_end_document($p, "");

$buf = PDF_get_buffer($p);
$len = strlen($buf);

header("Content-type: application/pdf");
header("Content-Length: $len");
header("Content-Disposition: inline; filename=hello.pdf");
print $buf;

PDF_delete($p);
?>

The following example comes with the PDFlib distribution for PHP 5. It uses the new exception handling and object encapsulation features available in PHP 5. It creates the file hello.pdf with one page. It defines some document info field contents, loads the Helvetica-Bold font and outputs the text "Hello world! (says PHP)".

Örnek 2 Hello World example from PDFlib distribution for PHP 5

<?php

try {
    $p = new PDFlib();

    /*  open new PDF file; insert a file name to create the PDF on disk */
    if ($p->begin_document("", "") == 0) {
        die("Error: " . $p->get_errmsg());
    }

    $p->set_info("Creator", "hello.php");
    $p->set_info("Author", "Rainer Schaaf");
    $p->set_info("Title", "Hello world (PHP)!");

    $p->begin_page_ext(595, 842, "");

    $font = $p->load_font("Helvetica-Bold", "winansi", "");

    $p->setfont($font, 24.0);
    $p->set_text_pos(50, 700);
    $p->show("Hello world!");
    $p->continue_text("(says PHP)");
    $p->end_page_ext("");

    $p->end_document("");

    $buf = $p->get_buffer();
    $len = strlen($buf);

    header("Content-type: application/pdf");
    header("Content-Length: $len");
    header("Content-Disposition: inline; filename=hello.pdf");
    print $buf;
}
catch (PDFlibException $e) {
    die("PDFlib exception occurred in hello sample:\n" .
    "[" . $e->get_errnum() . "] " . $e->get_apiname() . ": " .
    $e->get_errmsg() . "\n");
}
catch (Exception $e) {
    die($e);
}
$p = 0;
?>

Örnekler
PDF İşlevleri
Örnekler


PDF İşlevleri

Remarks about Deprecated PDFlib Functions

Starting with PHP 4.0.5, the PHP extension for PDFlib is officially supported by PDFlib GmbH. This means that all the functions described in the PDFlib Reference Manual are supported by PHP 4 with exactly the same meaning and the same parameters. However, with PDFlib Version 5.0.4 or higher all parameters have to be specified. For compatibility reasons, this binding for PDFlib still supports most of the deprecated functions, but they should be replaced by their new versions. PDFlib GmbH will not support any problems arising from the use of these deprecated functions. The documentation in this section indicates old functions as "Deprecated" and gives the replacement function to be used instead.

İçindekiler

  • PDF_activate_item — Activate structure element or other content item
  • PDF_add_annotation — Add annotation [deprecated]
  • PDF_add_bookmark — Add bookmark for current page [deprecated]
  • PDF_add_launchlink — Add launch annotation for current page [deprecated]
  • PDF_add_locallink — Add link annotation for current page [deprecated]
  • PDF_add_nameddest — Create named destination
  • PDF_add_note — Set annotation for current page [deprecated]
  • PDF_add_outline — Add bookmark for current page [deprecated]
  • PDF_add_pdflink — Add file link annotation for current page [deprecated]
  • PDF_add_table_cell — Add a cell to a new or existing table
  • PDF_add_textflow — Create Textflow or add text to existing Textflow
  • PDF_add_thumbnail — Add thumbnail for current page
  • PDF_add_weblink — Add weblink for current page [deprecated]
  • PDF_arc — Draw a counterclockwise circular arc segment
  • PDF_arcn — Draw a clockwise circular arc segment
  • PDF_attach_file — Add file attachment for current page [deprecated]
  • PDF_begin_document — Create new PDF file
  • PDF_begin_font — Start a Type 3 font definition
  • PDF_begin_glyph — Start glyph definition for Type 3 font
  • PDF_begin_item — Open structure element or other content item
  • PDF_begin_layer — Start layer
  • PDF_begin_page_ext — Start new page
  • PDF_begin_page — Start new page [deprecated]
  • PDF_begin_pattern — Start pattern definition
  • PDF_begin_template_ext — Start template definition
  • PDF_begin_template — Start template definition [deprecated]
  • PDF_circle — Draw a circle
  • PDF_clip — Clip to current path
  • PDF_close_image — Close image
  • PDF_close_pdi_page — Close the page handle
  • PDF_close_pdi — Close the input PDF document [deprecated]
  • PDF_close — Close pdf resource [deprecated]
  • PDF_closepath_fill_stroke — Close, fill and stroke current path
  • PDF_closepath_stroke — Close and stroke path
  • PDF_closepath — Close current path
  • PDF_concat — Concatenate a matrix to the CTM
  • PDF_continue_text — Output text in next line
  • PDF_create_3dview — Create 3D view
  • PDF_create_action — Create action for objects or events
  • PDF_create_annotation — Create rectangular annotation
  • PDF_create_bookmark — Create bookmark
  • PDF_create_field — Create form field
  • PDF_create_fieldgroup — Create form field group
  • PDF_create_gstate — Create graphics state object
  • PDF_create_pvf — Create PDFlib virtual file
  • PDF_create_textflow — Create textflow object
  • PDF_curveto — Draw Bezier curve
  • PDF_define_layer — Create layer definition
  • PDF_delete_pvf — Delete PDFlib virtual file
  • PDF_delete_table — Delete table object
  • PDF_delete_textflow — Delete textflow object
  • PDF_delete — Delete PDFlib object
  • PDF_encoding_set_char — Add glyph name and/or Unicode value
  • PDF_end_document — Close PDF file
  • PDF_end_font — Terminate Type 3 font definition
  • PDF_end_glyph — Terminate glyph definition for Type 3 font
  • PDF_end_item — Close structure element or other content item
  • PDF_end_layer — Deactivate all active layers
  • PDF_end_page_ext — Finish page
  • PDF_end_page — Finish page
  • PDF_end_pattern — Finish pattern
  • PDF_end_template — Finish template
  • PDF_endpath — End current path
  • PDF_fill_imageblock — Fill image block with variable data
  • PDF_fill_pdfblock — Fill PDF block with variable data
  • PDF_fill_stroke — Fill and stroke path
  • PDF_fill_textblock — Fill text block with variable data
  • PDF_fill — Fill current path
  • PDF_findfont — Prepare font for later use [deprecated]
  • PDF_fit_image — Place image or template
  • PDF_fit_pdi_page — Place imported PDF page
  • PDF_fit_table — Place table on page
  • PDF_fit_textflow — Format textflow in rectangular area
  • PDF_fit_textline — Place single line of text
  • PDF_get_apiname — Get name of unsuccessfull API function
  • PDF_get_buffer — Get PDF output buffer
  • PDF_get_errmsg — Get error text
  • PDF_get_errnum — Get error number
  • PDF_get_font — Get font [deprecated]
  • PDF_get_fontname — Get font name [deprecated]
  • PDF_get_fontsize — Font handling [deprecated]
  • PDF_get_image_height — Get image height [deprecated]
  • PDF_get_image_width — Get image width [deprecated]
  • PDF_get_majorversion — Get major version number [deprecated]
  • PDF_get_minorversion — Get minor version number [deprecated]
  • PDF_get_parameter — Get string parameter
  • PDF_get_pdi_parameter — Get PDI string parameter [deprecated]
  • PDF_get_pdi_value — Get PDI numerical parameter [deprecated]
  • PDF_get_value — Get numerical parameter
  • PDF_info_font — Query detailed information about a loaded font
  • PDF_info_matchbox — Query matchbox information
  • PDF_info_table — Retrieve table information
  • PDF_info_textflow — Query textflow state
  • PDF_info_textline — Perform textline formatting and query metrics
  • PDF_initgraphics — Reset graphic state
  • PDF_lineto — Draw a line
  • PDF_load_3ddata — Load 3D model
  • PDF_load_font — Search and prepare font
  • PDF_load_iccprofile — Search and prepare ICC profile
  • PDF_load_image — Open image file
  • PDF_makespotcolor — Make spot color
  • PDF_moveto — Set current point
  • PDF_new — Create PDFlib object
  • PDF_open_ccitt — Open raw CCITT image [deprecated]
  • PDF_open_file — Create PDF file [deprecated]
  • PDF_open_gif — Open GIF image [deprecated]
  • PDF_open_image_file — Read image from file [deprecated]
  • PDF_open_image — Use image data [deprecated]
  • PDF_open_jpeg — Open JPEG image [deprecated]
  • PDF_open_memory_image — Open image created with PHP's image functions [not supported]
  • PDF_open_pdi_document — Prepare a pdi document
  • PDF_open_pdi_page — Prepare a page
  • PDF_open_pdi — Open PDF file [deprecated]
  • PDF_open_tiff — Open TIFF image [deprecated]
  • PDF_pcos_get_number — Get value of pCOS path with type number or boolean
  • PDF_pcos_get_stream — Get contents of pCOS path with type stream, fstream, or string
  • PDF_pcos_get_string — Get value of pCOS path with type name, string, or boolean
  • PDF_place_image — Place image on the page [deprecated]
  • PDF_place_pdi_page — Place PDF page [deprecated]
  • PDF_process_pdi — Process imported PDF document
  • PDF_rect — Draw rectangle
  • PDF_restore — Restore graphics state
  • PDF_resume_page — Resume page
  • PDF_rotate — Rotate coordinate system
  • PDF_save — Save graphics state
  • PDF_scale — Scale coordinate system
  • PDF_set_border_color — Set border color of annotations [deprecated]
  • PDF_set_border_dash — Set border dash style of annotations [deprecated]
  • PDF_set_border_style — Set border style of annotations [deprecated]
  • PDF_set_char_spacing — Set character spacing [deprecated]
  • PDF_set_duration — Set duration between pages [deprecated]
  • PDF_set_gstate — Activate graphics state object
  • PDF_set_horiz_scaling — Set horizontal text scaling [deprecated]
  • PDF_set_info_author — Fill the author document info field [deprecated]
  • PDF_set_info_creator — Fill the creator document info field [deprecated]
  • PDF_set_info_keywords — Fill the keywords document info field [deprecated]
  • PDF_set_info_subject — Fill the subject document info field [deprecated]
  • PDF_set_info_title — Fill the title document info field [deprecated]
  • PDF_set_info — Fill document info field
  • PDF_set_layer_dependency — Define relationships among layers
  • PDF_set_leading — Set distance between text lines [deprecated]
  • PDF_set_parameter — Set string parameter
  • PDF_set_text_matrix — Set text matrix [deprecated]
  • PDF_set_text_pos — Set text position
  • PDF_set_text_rendering — Determine text rendering [deprecated]
  • PDF_set_text_rise — Set text rise [deprecated]
  • PDF_set_value — Set numerical parameter
  • PDF_set_word_spacing — Set spacing between words [deprecated]
  • PDF_setcolor — Set fill and stroke color
  • PDF_setdash — Set simple dash pattern
  • PDF_setdashpattern — Set dash pattern
  • PDF_setflat — Set flatness
  • PDF_setfont — Set font
  • PDF_setgray_fill — Set fill color to gray [deprecated]
  • PDF_setgray_stroke — Set stroke color to gray [deprecated]
  • PDF_setgray — Set color to gray [deprecated]
  • PDF_setlinecap — Set linecap parameter
  • PDF_setlinejoin — Set linejoin parameter
  • PDF_setlinewidth — Set line width
  • PDF_setmatrix — Set current transformation matrix
  • PDF_setmiterlimit — Set miter limit
  • PDF_setpolydash — Set complicated dash pattern [deprecated]
  • PDF_setrgbcolor_fill — Set fill rgb color values [deprecated]
  • PDF_setrgbcolor_stroke — Set stroke rgb color values [deprecated]
  • PDF_setrgbcolor — Set fill and stroke rgb color values [deprecated]
  • PDF_shading_pattern — Define shading pattern
  • PDF_shading — Define blend
  • PDF_shfill — Fill area with shading
  • PDF_show_boxed — Output text in a box [deprecated]
  • PDF_show_xy — Output text at given position
  • PDF_show — Output text at current position
  • PDF_skew — Skew the coordinate system
  • PDF_stringwidth — Return width of text
  • PDF_stroke — Stroke path
  • PDF_suspend_page — Suspend page
  • PDF_translate — Set origin of coordinate system
  • PDF_utf16_to_utf8 — Convert string from UTF-16 to UTF-8
  • PDF_utf32_to_utf16 — Convert string from UTF-32 to UTF-16
  • PDF_utf8_to_utf16 — Convert string from UTF-8 to UTF-16
Basic Usage Examples
PDF_activate_item
PDF


Activate structure element or other content item

PDF İşlevleri
PDF_add_annotation
PDF İşlevleri
PHP Manual

PDF_activate_item

(PECL pdflib >= 2.0.0)

PDF_activate_item — Activate structure element or other content item

Açıklama

bool PDF_activate_item ( resource $pdfdoc , int $id )

Activates a previously created structure element or other content item. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF İşlevleri
PDF_add_annotation
PDF İşlevleri


Add annotation [deprecated]

PDF_activate_item
PDF_add_bookmark
PDF İşlevleri
PHP Manual

PDF_add_annotation

(PHP 4, PECL pdflib >= 1.0.0)

PDF_add_annotation — Add annotation [deprecated]

Açıklama

This function is deprecated, use PDF_create_annotation() with type=Text instead.

PDF_activate_item
PDF_add_bookmark
PDF İşlevleri


Add bookmark for current page [deprecated]

PDF_add_annotation
PDF_add_launchlink
PDF İşlevleri
PHP Manual

PDF_add_bookmark

(PHP 4 >= 4.0.1, PECL pdflib >= 1.0.0)

PDF_add_bookmark — Add bookmark for current page [deprecated]

Açıklama

This function is deprecated since PDFlib version 6, use PDF_create_bookmark() instead.

PDF_add_annotation
PDF_add_launchlink
PDF İşlevleri


Add launch annotation for current page [deprecated]

PDF_add_bookmark
PDF_add_locallink
PDF İşlevleri
PHP Manual

PDF_add_launchlink

(PHP 4 >= 4.0.5, PECL pdflib >= 1.0.0)

PDF_add_launchlink — Add launch annotation for current page [deprecated]

Açıklama

bool PDF_add_launchlink ( resource $pdfdoc , float $llx , float $lly , float $urx , float $ury , string $filename )

Adds a link to a web resource.

This function is deprecated since PDFlib version 6,
use PDF_create_action() with
type=Launch and
PDF_create_annotation() with
type=Link instead.

PDF_add_bookmark
PDF_add_locallink
PDF İşlevleri


Add link annotation for current page [deprecated]

PDF_add_launchlink
PDF_add_nameddest
PDF İşlevleri
PHP Manual

PDF_add_locallink

(PHP 4 >= 4.0.5, PECL pdflib >= 1.0.0)

PDF_add_locallink — Add link annotation for current page [deprecated]

Açıklama

bool PDF_add_locallink ( resource $pdfdoc , float $lowerleftx , float $lowerlefty , float $upperrightx , float $upperrighty , int $page , string $dest )

Add a link annotation to a target within the current PDF file. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

This function is deprecated since PDFlib version 6, use
PDF_create_action() with type=GoTo
and PDF_create_annotation() with
type=Link instead.

PDF_add_launchlink
PDF_add_nameddest
PDF İşlevleri


Create named destination

PDF_add_locallink
PDF_add_note
PDF İşlevleri
PHP Manual

PDF_add_nameddest

(PECL pdflib >= 2.0.0)

PDF_add_nameddest — Create named destination

Açıklama

bool PDF_add_nameddest ( resource $pdfdoc , string $name , string $optlist )

Creates a named destination on an arbitrary page in the current document. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_add_locallink
PDF_add_note
PDF İşlevleri


Set annotation for current page [deprecated]

PDF_add_nameddest
PDF_add_outline
PDF İşlevleri
PHP Manual

PDF_add_note

(PHP 4 >= 4.0.5, PECL pdflib >= 1.0.0)

PDF_add_note — Set annotation for current page [deprecated]

Açıklama

bool PDF_add_note ( resource $pdfdoc , float $llx , float $lly , float $urx , float $ury , string $contents , string $title , string $icon , int $open )

Sets an annotation for the current page. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

This function is deprecated since PDFlib version 6, use PDF_create_annotation() with type=Text instead.

PDF_add_nameddest
PDF_add_outline
PDF İşlevleri


Add bookmark for current page [deprecated]

PDF_add_note
PDF_add_pdflink
PDF İşlevleri
PHP Manual

PDF_add_outline

(PHP 4, PECL pdflib >= 1.0.0)

PDF_add_outline — Add bookmark for current page [deprecated]

Açıklama

This function is deprecated, use PDF_create_bookmark() instead.

PDF_add_note
PDF_add_pdflink
PDF İşlevleri


Add file link annotation for current page [deprecated]

PDF_add_outline
PDF_add_table_cell
PDF İşlevleri
PHP Manual

PDF_add_pdflink

(PHP 4, PECL pdflib >= 1.0.0)

PDF_add_pdflink — Add file link annotation for current page [deprecated]

Açıklama

bool PDF_add_pdflink ( resource $pdfdoc , float $bottom_left_x , float $bottom_left_y , float $up_right_x , float $up_right_y , string $filename , int $page , string $dest )

Add a file link annotation to a PDF target. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

This function is deprecated since PDFlib version 6, use
PDF_create_action() with
type=GoToR and
PDF_create_annotation() with
type=Link instead.

PDF_add_outline
PDF_add_table_cell
PDF İşlevleri


Add a cell to a new or existing table

PDF_add_pdflink
PDF_add_textflow
PDF İşlevleri
PHP Manual

PDF_add_table_cell

(PECL pdflib >= 2.1.0)

PDF_add_table_cell — Add a cell to a new or existing table

Açıklama

int PDF_add_table_cell ( resource $pdfdoc , int $table , int $column , int $row , string $text , string $optlist )

Adds a cell to a new or existing table.

PDF_add_pdflink
PDF_add_textflow
PDF İşlevleri


Create Textflow or add text to existing Textflow

PDF_add_table_cell
PDF_add_thumbnail
PDF İşlevleri
PHP Manual

PDF_add_textflow

(PECL pdflib >= 2.1.0)

PDF_add_textflow — Create Textflow or add text to existing Textflow

Açıklama

int PDF_add_textflow ( resource $pdfdoc , int $textflow , string $text , string $optlist )

Creates a Textflow object, or adds text and explicit options to an existing Textflow.

PDF_add_table_cell
PDF_add_thumbnail
PDF İşlevleri


Add thumbnail for current page

PDF_add_textflow
PDF_add_weblink
PDF İşlevleri
PHP Manual

PDF_add_thumbnail

(PHP 4 >= 4.0.5, PECL pdflib >= 1.0.0)

PDF_add_thumbnail — Add thumbnail for current page

Açıklama

bool PDF_add_thumbnail ( resource $pdfdoc , int $image )

Adds an existing image as thumbnail for the current page. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_add_textflow
PDF_add_weblink
PDF İşlevleri


Add weblink for current page [deprecated]

PDF_add_thumbnail
PDF_arc
PDF İşlevleri
PHP Manual

PDF_add_weblink

(PHP 4, PECL pdflib >= 1.0.0)

PDF_add_weblink — Add weblink for current page [deprecated]

Açıklama

bool PDF_add_weblink ( resource $pdfdoc , float $lowerleftx , float $lowerlefty , float $upperrightx , float $upperrighty , string $url )

Adds a weblink annotation to a target url on the Web. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

This function is deprecated since PDFlib version 6, use
PDF_create_action() with type=URI
and PDF_create_annotation() with
type=Link instead.

PDF_add_thumbnail
PDF_arc
PDF İşlevleri


Draw a counterclockwise circular arc segment

PDF_add_weblink
PDF_arcn
PDF İşlevleri
PHP Manual

PDF_arc

(PHP 4, PECL pdflib >= 1.0.0)

PDF_arc — Draw a counterclockwise circular arc segment

Açıklama

bool PDF_arc ( resource $p , float $x , float $y , float $r , float $alpha , float $beta )

Adds a counterclockwise circular arc.

PDF_add_weblink
PDF_arcn
PDF İşlevleri


Draw a clockwise circular arc segment

PDF_arc
PDF_attach_file
PDF İşlevleri
PHP Manual

PDF_arcn

(PHP 4 >= 4.0.5, PECL pdflib >= 1.0.0)

PDF_arcn — Draw a clockwise circular arc segment

Açıklama

bool PDF_arcn ( resource $p , float $x , float $y , float $r , float $alpha , float $beta )

Except for the drawing direction, this function behaves exactly like PDF_arc().

PDF_arc
PDF_attach_file
PDF İşlevleri


Add file attachment for current page [deprecated]

PDF_arcn
PDF_begin_document
PDF İşlevleri
PHP Manual

PDF_attach_file

(PHP 4 >= 4.0.5, PECL pdflib >= 1.0.0)

PDF_attach_file — Add file attachment for current page [deprecated]

Açıklama

bool PDF_attach_file ( resource $pdfdoc , float $llx , float $lly , float $urx , float $ury , string $filename , string $description , string $author , string $mimetype , string $icon )

Adds a file attachment annotation. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

This function is deprecated since PDFlib version 6, use PDF_create_annotation() with type=FileAttachment instead.

PDF_arcn
PDF_begin_document
PDF İşlevleri


Create new PDF file

PDF_attach_file
PDF_begin_font
PDF İşlevleri
PHP Manual

PDF_begin_document

(PECL pdflib >= 2.0.0)

PDF_begin_document — Create new PDF file

Açıklama

int PDF_begin_document ( resource $pdfdoc , string $filename , string $optlist )

Creates a new PDF file subject to various options.

PDF_attach_file
PDF_begin_font
PDF İşlevleri


Start a Type 3 font definition

PDF_begin_document
PDF_begin_glyph
PDF İşlevleri
PHP Manual

PDF_begin_font

(PECL pdflib >= 2.0.0)

PDF_begin_font — Start a Type 3 font definition

Açıklama

bool PDF_begin_font ( resource $pdfdoc , string $filename , float $a , float $b , float $c , float $d , float $e , float $f , string $optlist )

Starts a Type 3 font definition.

PDF_begin_document
PDF_begin_glyph
PDF İşlevleri


Start glyph definition for Type 3 font

PDF_begin_font
PDF_begin_item
PDF İşlevleri
PHP Manual

PDF_begin_glyph

(PECL pdflib >= 2.0.0)

PDF_begin_glyph — Start glyph definition for Type 3 font

Açıklama

bool PDF_begin_glyph ( resource $pdfdoc , string $glyphname , float $wx , float $llx , float $lly , float $urx , float $ury )

Starts a glyph definition for a Type 3 font.

PDF_begin_font
PDF_begin_item
PDF İşlevleri


Open structure element or other content item

PDF_begin_glyph
PDF_begin_layer
PDF İşlevleri
PHP Manual

PDF_begin_item

(PECL pdflib >= 2.0.0)

PDF_begin_item — Open structure element or other content item

Açıklama

int PDF_begin_item ( resource $pdfdoc , string $tag , string $optlist )

Opens a structure element or other content item with attributes supplied as options.

PDF_begin_glyph
PDF_begin_layer
PDF İşlevleri


Start layer

PDF_begin_item
PDF_begin_page_ext
PDF İşlevleri
PHP Manual

PDF_begin_layer

(PECL pdflib >= 2.0.0)

PDF_begin_layer — Start layer

Açıklama

bool PDF_begin_layer ( resource $pdfdoc , int $layer )

Starts a layer for subsequent output on the page. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

This function requires PDF 1.5.

PDF_begin_item
PDF_begin_page_ext
PDF İşlevleri


Start new page

PDF_begin_layer
PDF_begin_page
PDF İşlevleri
PHP Manual

PDF_begin_page_ext

(PECL pdflib >= 2.0.0)

PDF_begin_page_ext — Start new page

Açıklama

bool PDF_begin_page_ext ( resource $pdfdoc , float $width , float $height , string $optlist )

Adds a new page to the document, and specifies various options. The parameters width and height are the dimensions of the new page in points. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Common Page Sizes in Points
name | size
A0 | 2380 x 3368
A1 | 1684 x 2380
A2 | 1190 x 1684
A3 | 842 x 1190
A4 | 595 x 842
A5 | 421 x 595
A6 | 297 x 421
B5 | 501 x 709
letter (8.5" x 11") | 612 x 792
legal (8.5" x 14") | 612 x 1008
ledger (17" x 11") | 1224 x 792
11" x 17" | 792 x 1224

PDF_begin_layer
PDF_begin_page
PDF İşlevleri


Start new page [deprecated]

PDF_begin_page_ext
PDF_begin_pattern
PDF İşlevleri
PHP Manual

PDF_begin_page

(PHP 4, PECL pdflib >= 1.0.0)

PDF_begin_page — Start new page [deprecated]

Açıklama

bool PDF_begin_page ( resource $pdfdoc , float $width , float $height )

Adds a new page to the document. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

This function is deprecated since PDFlib version 6, use PDF_begin_page_ext() instead.

PDF_begin_page_ext
PDF_begin_pattern
PDF İşlevleri


Start pattern definition

PDF_begin_page
PDF_begin_template_ext
PDF İşlevleri
PHP Manual

PDF_begin_pattern

(PHP 4 >= 4.0.5, PECL pdflib >= 1.0.0)

PDF_begin_pattern — Start pattern definition

Açıklama

int PDF_begin_pattern ( resource $pdfdoc , float $width , float $height , float $xstep , float $ystep , int $painttype )

Starts a new pattern definition.

PDF_begin_page
PDF_begin_template_ext
PDF İşlevleri


Start template definition

PDF_begin_pattern
PDF_begin_template
PDF İşlevleri
PHP Manual

PDF_begin_template_ext

(PECL pdflib >= 2.1.0)

PDF_begin_template_ext — Start template definition

Açıklama

int PDF_begin_template_ext ( resource $pdfdoc , float $width , float $height , string $optlist )

Starts a new template definition.

PDF_begin_pattern
PDF_begin_template
PDF İşlevleri


Start template definition [deprecated]

PDF_begin_template_ext
PDF_circle
PDF İşlevleri
PHP Manual

PDF_begin_template

(PHP 4 >= 4.0.5, PECL pdflib >= 1.0.0)

PDF_begin_template — Start template definition [deprecated]

Açıklama

int PDF_begin_template ( resource $pdfdoc , float $width , float $height )

Starts a new template definition.

This function is deprecated since PDFlib version 7, use PDF_begin_template_ext() instead.

PDF_begin_template_ext
PDF_circle
PDF İşlevleri


Draw a circle

PDF_begin_template
PDF_clip
PDF İşlevleri
PHP Manual

PDF_circle

(PHP 4, PECL pdflib >= 1.0.0)

PDF_circle — Draw a circle

Açıklama

bool PDF_circle ( resource $pdfdoc , float $x , float $y , float $r )

Adds a circle. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_begin_template
PDF_clip
PDF İşlevleri


Clip to current path

PDF_circle
PDF_close_image
PDF İşlevleri
PHP Manual

PDF_clip

(PHP 4, PECL pdflib >= 1.0.0)

PDF_clip — Clip to current path

Açıklama

bool PDF_clip ( resource $p )

Uses the current path as clipping path, and terminate the path. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_circle
PDF_close_image
PDF İşlevleri


Close image

PDF_clip
PDF_close_pdi_page
PDF İşlevleri
PHP Manual

PDF_close_image

(PHP 4, PECL pdflib >= 1.0.0)

PDF_close_image — Close image

Açıklama

bool PDF_close_image ( resource $p , int $image )

Closes an image retrieved with the PDF_open_image() function.

PDF_clip
PDF_close_pdi_page
PDF İşlevleri


Close the page handle

PDF_close_image
PDF_close_pdi
PDF İşlevleri
PHP Manual

PDF_close_pdi_page

(PHP 4 >= 4.0.5, PECL pdflib >= 1.0.0)

PDF_close_pdi_page — Close the page handle

Açıklama

bool PDF_close_pdi_page ( resource $p , int $page )

Closes the page handle, and frees all page-related resources. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_close_image
PDF_close_pdi
PDF İşlevleri


Close the input PDF document [deprecated]

PDF_close_pdi_page
PDF_close
PDF İşlevleri
PHP Manual

PDF_close_pdi

(PHP 4 >= 4.0.5, PECL pdflib >= 1.0.0)

PDF_close_pdi — Close the input PDF document [deprecated]

Açıklama

bool PDF_close_pdi ( resource $p , int $doc )

Closes all open page handles, and closes the input PDF document. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

This function is deprecated since PDFlib version 7, use PDF_close_pdi_document() instead.

PDF_close_pdi_page
PDF_close
PDF İşlevleri


Close pdf resource [deprecated]

PDF_close_pdi
PDF_closepath_fill_stroke
PDF İşlevleri
PHP Manual

PDF_close

(PHP 4, PECL pdflib >= 1.0.0)

PDF_close — Close pdf resource [deprecated]

Açıklama

bool PDF_close ( resource $p )

Closes the generated PDF file, and frees all document-related resources. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

This function is deprecated since PDFlib version 6, use PDF_end_document() instead.

PDF_close_pdi
PDF_closepath_fill_stroke
PDF İşlevleri


Close, fill and stroke current path

PDF_close
PDF_closepath_stroke
PDF İşlevleri
PHP Manual

PDF_closepath_fill_stroke

(PHP 4, PECL pdflib >= 1.0.0)

PDF_closepath_fill_stroke — Close, fill and stroke current path

Açıklama

bool PDF_closepath_fill_stroke ( resource $p )

Closes the path, fills, and strokes it. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_close
PDF_closepath_stroke
PDF İşlevleri


Close and stroke path

PDF_closepath_fill_stroke
PDF_closepath
PDF İşlevleri
PHP Manual

PDF_closepath_stroke

(PHP 4, PECL pdflib >= 1.0.0)

PDF_closepath_stroke — Close and stroke path

Açıklama

bool PDF_closepath_stroke ( resource $p )

Closes the path, and strokes it. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_closepath_fill_stroke
PDF_closepath
PDF İşlevleri


Close current path

PDF_closepath_stroke
PDF_concat
PDF İşlevleri
PHP Manual

PDF_closepath

(PHP 4, PECL pdflib >= 1.0.0)

PDF_closepath — Close current path

Açıklama

bool PDF_closepath ( resource $p )

Closes the current path. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_closepath_stroke
PDF_concat
PDF İşlevleri


Concatenate a matrix to the CTM

PDF_closepath
PDF_continue_text
PDF İşlevleri
PHP Manual

PDF_concat

(PHP 4 >= 4.0.5, PECL pdflib >= 1.0.0)

PDF_concat — Concatenate a matrix to the CTM

Açıklama

bool PDF_concat ( resource $p , float $a , float $b , float $c , float $d , float $e , float $f )

Concatenates a matrix to the current transformation matrix (CTM). Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_closepath
PDF_continue_text
PDF İşlevleri


Output text in next line

PDF_concat
PDF_create_3dview
PDF İşlevleri
PHP Manual

PDF_continue_text

(PHP 4, PECL pdflib >= 1.0.0)

PDF_continue_text — Output text in next line

Açıklama

bool PDF_continue_text ( resource $p , string $text )

Prints text at the next line. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_concat
PDF_create_3dview
PDF İşlevleri


Create 3D view

PDF_continue_text
PDF_create_action
PDF İşlevleri
PHP Manual

PDF_create_3dview

(PECL pdflib >= 2.1.0)

PDF_create_3dview — Create 3D view

Açıklama

int PDF_create_3dview ( resource $pdfdoc , string $username , string $optlist )

Creates a 3D view.

This function requires PDF 1.6.

PDF_continue_text
PDF_create_action
PDF İşlevleri


Create action for objects or events

PDF_create_3dview
PDF_create_annotation
PDF İşlevleri
PHP Manual

PDF_create_action

(PECL pdflib >= 2.0.0)

PDF_create_action — Create action for objects or events

Açıklama

int PDF_create_action ( resource $pdfdoc , string $type , string $optlist )

Creates an action which can be applied to various objects and events.

PDF_create_3dview
PDF_create_annotation
PDF İşlevleri


Create rectangular annotation

PDF_create_action
PDF_create_bookmark
PDF İşlevleri
PHP Manual

PDF_create_annotation

(PECL pdflib >= 2.0.0)

PDF_create_annotation — Create rectangular annotation

Açıklama

bool PDF_create_annotation ( resource $pdfdoc , float $llx , float $lly , float $urx , float $ury , string $type , string $optlist )

Creates a rectangular annotation on the current page.

PDF_create_action
PDF_create_bookmark
PDF İşlevleri


Create bookmark

PDF_create_annotation
PDF_create_field
PDF İşlevleri
PHP Manual

PDF_create_bookmark

(PECL pdflib >= 2.0.0)

PDF_create_bookmark — Create bookmark

Açıklama

int PDF_create_bookmark ( resource $pdfdoc , string $text , string $optlist )

Creates a bookmark subject to various options.

PDF_create_annotation
PDF_create_field
PDF İşlevleri


Create form field

PDF_create_bookmark
PDF_create_fieldgroup
PDF İşlevleri
PHP Manual

PDF_create_field

(PECL pdflib >= 2.0.0)

PDF_create_field — Create form field

Açıklama

bool PDF_create_field ( resource $pdfdoc , float $llx , float $lly , float $urx , float $ury , string $name , string $type , string $optlist )

Creates a form field on the current page subject to various options.

PDF_create_bookmark
PDF_create_fieldgroup
PDF İşlevleri


Create form field group

PDF_create_field
PDF_create_gstate
PDF İşlevleri
PHP Manual

PDF_create_fieldgroup

(PECL pdflib >= 2.0.0)

PDF_create_fieldgroup — Create form field group

Açıklama

bool PDF_create_fieldgroup ( resource $pdfdoc , string $name , string $optlist )

Creates a form field group subject to various options.

PDF_create_field
PDF_create_gstate
PDF İşlevleri


Create graphics state object

PDF_create_fieldgroup
PDF_create_pvf
PDF İşlevleri
PHP Manual

PDF_create_gstate

(PECL pdflib >= 2.0.0)

PDF_create_gstate — Create graphics state object

Açıklama

int PDF_create_gstate ( resource $pdfdoc , string $optlist )

Creates a graphics state object subject to various options.

PDF_create_fieldgroup
PDF_create_pvf
PDF İşlevleri


Create PDFlib virtual file

PDF_create_gstate
PDF_create_textflow
PDF İşlevleri
PHP Manual

PDF_create_pvf

(PECL pdflib >= 2.0.0)

PDF_create_pvf — Create PDFlib virtual file

Açıklama

bool PDF_create_pvf ( resource $pdfdoc , string $filename , string $data , string $optlist )

Creates a named virtual read-only file from data provided in memory.

PDF_create_gstate
PDF_create_textflow
PDF İşlevleri


Create textflow object

PDF_create_pvf
PDF_curveto
PDF İşlevleri
PHP Manual

PDF_create_textflow

(PECL pdflib >= 2.0.0)

PDF_create_textflow — Create textflow object

Açıklama

int PDF_create_textflow ( resource $pdfdoc , string $text , string $optlist )

Preprocesses text for later formatting and creates a textflow object.

PDF_create_pvf
PDF_curveto
PDF İşlevleri


Draw Bezier curve

PDF_create_textflow
PDF_define_layer
PDF İşlevleri
PHP Manual

PDF_curveto

(PHP 4, PECL pdflib >= 1.0.0)

PDF_curveto — Draw Bezier curve

Açıklama

bool PDF_curveto ( resource $p , float $x1 , float $y1 , float $x2 , float $y2 , float $x3 , float $y3 )

Draws a Bezier curve from the current point, using 3 more control points. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_create_textflow
PDF_define_layer
PDF İşlevleri


Create layer definition

PDF_curveto
PDF_delete_pvf
PDF İşlevleri
PHP Manual

PDF_define_layer

(PECL pdflib >= 2.0.0)

PDF_define_layer — Create layer definition

Açıklama

int PDF_define_layer ( resource $pdfdoc , string $name , string $optlist )

Creates a new layer definition.

This function requires PDF 1.5.

PDF_curveto
PDF_delete_pvf
PDF İşlevleri


Delete PDFlib virtual file

PDF_define_layer
PDF_delete_table
PDF İşlevleri
PHP Manual

PDF_delete_pvf

(PECL pdflib >= 2.0.0)

PDF_delete_pvf — Delete PDFlib virtual file

Açıklama

int PDF_delete_pvf ( resource $pdfdoc , string $filename )

Deletes a named virtual file and frees its data structures (but not the contents).

PDF_define_layer
PDF_delete_table
PDF İşlevleri


Delete table object

PDF_delete_pvf
PDF_delete_textflow
PDF İşlevleri
PHP Manual

PDF_delete_table

(PECL pdflib >= 2.1.0)

PDF_delete_table — Delete table object

Açıklama

bool PDF_delete_table ( resource $pdfdoc , int $table , string $optlist )

Deletes a table and all associated data structures.

PDF_delete_pvf
PDF_delete_textflow
PDF İşlevleri


Delete textflow object

PDF_delete_table
PDF_delete
PDF İşlevleri
PHP Manual

PDF_delete_textflow

(PECL pdflib >= 2.0.0)

PDF_delete_textflow — Delete textflow object

Açıklama

bool PDF_delete_textflow ( resource $pdfdoc , int $textflow )

Deletes a textflow and the associated data structures.

PDF_delete_table
PDF_delete
PDF İşlevleri


Delete PDFlib object

PDF_delete_textflow
PDF_encoding_set_char
PDF İşlevleri
PHP Manual

PDF_delete

(PHP 4 >= 4.0.5, PECL pdflib >= 1.0.0)

PDF_delete — Delete PDFlib object

Açıklama

bool PDF_delete ( resource $pdfdoc )

Deletes a PDFlib object, and frees all internal resources. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_delete_textflow
PDF_encoding_set_char
PDF İşlevleri


Add glyph name and/or Unicode value

PDF_delete
PDF_end_document
PDF İşlevleri
PHP Manual

PDF_encoding_set_char

(PECL pdflib >= 2.0.0)

PDF_encoding_set_char — Add glyph name and/or Unicode value

Açıklama

bool PDF_encoding_set_char ( resource $pdfdoc , string $encoding , int $slot , string $glyphname , int $uv )

Adds a glyph name and/or Unicode value to a custom encoding.

PDF_delete
PDF_end_document
PDF İşlevleri


Close PDF file

PDF_encoding_set_char
PDF_end_font
PDF İşlevleri
PHP Manual

PDF_end_document

(PECL pdflib >= 2.0.0)

PDF_end_document — Close PDF file

Açıklama

bool PDF_end_document ( resource $pdfdoc , string $optlist )

Closes the generated PDF file and applies various options.

PDF_encoding_set_char
PDF_end_font
PDF İşlevleri


Terminate Type 3 font definition

PDF_end_document
PDF_end_glyph
PDF İşlevleri
PHP Manual

PDF_end_font

(PECL pdflib >= 2.0.0)

PDF_end_font — Terminate Type 3 font definition

Açıklama

bool PDF_end_font ( resource $pdfdoc )

Terminates a Type 3 font definition.

PDF_end_document
PDF_end_glyph
PDF İşlevleri


Terminate glyph definition for Type 3 font

PDF_end_font
PDF_end_item
PDF İşlevleri
PHP Manual

PDF_end_glyph

(PECL pdflib >= 2.0.0)

PDF_end_glyph — Terminate glyph definition for Type 3 font

Açıklama

bool PDF_end_glyph ( resource $pdfdoc )

Terminates a glyph definition for a Type 3 font.

PDF_end_font
PDF_end_item
PDF İşlevleri


Close structure element or other content item

PDF_end_glyph
PDF_end_layer
PDF İşlevleri
PHP Manual

PDF_end_item

(PECL pdflib >= 2.0.0)

PDF_end_item — Close structure element or other content item

Açıklama

bool PDF_end_item ( resource $pdfdoc , int $id )

Closes a structure element or other content item.

PDF_end_glyph
PDF_end_layer
PDF İşlevleri


Deactivate all active layers

PDF_end_item
PDF_end_page_ext
PDF İşlevleri
PHP Manual

PDF_end_layer

(PECL pdflib >= 2.0.0)

PDF_end_layer — Deactivate all active layers

Açıklama

bool PDF_end_layer ( resource $pdfdoc )

Deactivates all active layers. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

This function requires PDF 1.5.

PDF_end_item
PDF_end_page_ext
PDF İşlevleri


Finish page

PDF_end_layer
PDF_end_page
PDF İşlevleri
PHP Manual

PDF_end_page_ext

(PECL pdflib >= 2.0.0)

PDF_end_page_ext — Finish page

Açıklama

bool PDF_end_page_ext ( resource $pdfdoc , string $optlist )

Finishes a page, and applies various options. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_end_layer
PDF_end_page
PDF İşlevleri


Finish page

PDF_end_page_ext
PDF_end_pattern
PDF İşlevleri
PHP Manual

PDF_end_page

(PHP 4, PECL pdflib >= 1.0.0)

PDF_end_page — Finish page

Açıklama

bool PDF_end_page ( resource $p )

Finishes the page. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_end_page_ext
PDF_end_pattern
PDF İşlevleri


Finish pattern

PDF_end_page
PDF_end_template
PDF İşlevleri
PHP Manual

PDF_end_pattern

(PHP 4 >= 4.0.5, PECL pdflib >= 1.0.0)

PDF_end_pattern — Finish pattern

Açıklama

bool PDF_end_pattern ( resource $p )

Finishes the pattern definition. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_end_page
PDF_end_template
PDF İşlevleri


Finish template

PDF_end_pattern
PDF_endpath
PDF İşlevleri
PHP Manual

PDF_end_template

(PHP 4 >= 4.0.5, PECL pdflib >= 1.0.0)

PDF_end_template — Finish template

Açıklama

bool PDF_end_template ( resource $p )

Finishes a template definition. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_end_pattern
PDF_endpath
PDF İşlevleri


End current path

PDF_end_template
PDF_fill_imageblock
PDF İşlevleri
PHP Manual

PDF_endpath

(PHP 4, PECL pdflib >= 1.0.0)

PDF_endpath — End current path

Açıklama

bool PDF_endpath ( resource $p )

Ends the current path without filling or stroking it.

PDF_end_template
PDF_fill_imageblock
PDF İşlevleri


Fill image block with variable data

PDF_endpath
PDF_fill_pdfblock
PDF İşlevleri
PHP Manual

PDF_fill_imageblock

(PECL pdflib >= 2.0.0)

PDF_fill_imageblock — Fill image block with variable data

Açıklama

int PDF_fill_imageblock ( resource $pdfdoc , int $page , string $blockname , int $image , string $optlist )

Fills an image block with variable data according to its properties.

This function is only available in the PDFlib Personalization Server (PPS).

PDF_endpath
PDF_fill_pdfblock
PDF İşlevleri


Fill PDF block with variable data

PDF_fill_imageblock
PDF_fill_stroke
PDF İşlevleri
PHP Manual

PDF_fill_pdfblock

(PECL pdflib >= 2.0.0)

PDF_fill_pdfblock — Fill PDF block with variable data

Açıklama

int PDF_fill_pdfblock ( resource $pdfdoc , int $page , string $blockname , int $contents , string $optlist )

Fills a PDF block with variable data according to its properties.

This function is only available in the PDFlib Personalization Server (PPS).

PDF_fill_imageblock
PDF_fill_stroke
PDF İşlevleri


Fill and stroke path

PDF_fill_pdfblock
PDF_fill_textblock
PDF İşlevleri
PHP Manual

PDF_fill_stroke

(PHP 4, PECL pdflib >= 1.0.0)

PDF_fill_stroke — Fill and stroke path

Açıklama

bool PDF_fill_stroke ( resource $p )

Fills and strokes the current path with the current fill and stroke color. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_fill_pdfblock
PDF_fill_textblock
PDF İşlevleri


Fill text block with variable data

PDF_fill_stroke
PDF_fill
PDF İşlevleri
PHP Manual

PDF_fill_textblock

(PECL pdflib >= 2.0.0)

PDF_fill_textblock — Fill text block with variable data

Açıklama

int PDF_fill_textblock ( resource $pdfdoc , int $page , string $blockname , string $text , string $optlist )

Fills a text block with variable data according to its properties.

This function is only available in the PDFlib Personalization Server (PPS).

PDF_fill_stroke
PDF_fill
PDF İşlevleri


Fill current path

PDF_fill_textblock
PDF_findfont
PDF İşlevleri
PHP Manual

PDF_fill

(PHP 4, PECL pdflib >= 1.0.0)

PDF_fill — Fill current path

Açıklama

bool PDF_fill ( resource $p )

Fills the interior of the current path with the current fill color. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_fill_textblock
PDF_findfont
PDF İşlevleri


Prepare font for later use [deprecated]

PDF_fill
PDF_fit_image
PDF İşlevleri
PHP Manual

PDF_findfont

(PHP 4 >= 4.0.5, PECL pdflib >= 1.0.0)

PDF_findfont — Prepare font for later use [deprecated]

Açıklama

int PDF_findfont ( resource $p , string $fontname , string $encoding , int $embed )

Search for a font and prepare it for later use with PDF_setfont(). The metrics will be loaded, and if embed is nonzero, the font file will be checked, but not yet used. encoding is one of builtin, macroman, winansi, host, a user-defined encoding name or the name of a CMap. Parameter embed is optional before PHP 4.3.5 or with PDFlib less than 5.

This function is deprecated since PDFlib version 5, use PDF_load_font() instead.

PDF_fill
PDF_fit_image
PDF İşlevleri


Place image or template

PDF_findfont
PDF_fit_pdi_page
PDF İşlevleri
PHP Manual

PDF_fit_image

(PECL pdflib >= 2.0.0)

PDF_fit_image — Place image or template

Açıklama

bool PDF_fit_image ( resource $pdfdoc , int $image , float $x , float $y , string $optlist )

Places an image or template on the page, subject to various options. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_findfont
PDF_fit_pdi_page
PDF İşlevleri


Place imported PDF page

PDF_fit_image
PDF_fit_table
PDF İşlevleri
PHP Manual

PDF_fit_pdi_page

(PECL pdflib >= 2.0.0)

PDF_fit_pdi_page — Place imported PDF page

Açıklama

bool PDF_fit_pdi_page ( resource $pdfdoc , int $page , float $x , float $y , string $optlist )

Places an imported PDF page on the page, subject to various options. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_fit_image
PDF_fit_table
PDF İşlevleri


Place table on page

PDF_fit_pdi_page
PDF_fit_textflow
PDF İşlevleri
PHP Manual

PDF_fit_table

(PECL pdflib >= 2.1.0)

PDF_fit_table — Place table on page

Açıklama

string PDF_fit_table ( resource $pdfdoc , int $table , float $llx , float $lly , float $urx , float $ury , string $optlist )

Places a table on the page fully or partially.

PDF_fit_pdi_page
PDF_fit_textflow
PDF İşlevleri


Format textflow in rectangular area

PDF_fit_table
PDF_fit_textline
PDF İşlevleri
PHP Manual

PDF_fit_textflow

(PECL pdflib >= 2.0.0)

PDF_fit_textflow — Format textflow in rectangular area

Açıklama

string PDF_fit_textflow ( resource $pdfdoc , int $textflow , float $llx , float $lly , float $urx , float $ury , string $optlist )

Formats the next portion of a textflow into a rectangular area.

PDF_fit_table
PDF_fit_textline
PDF İşlevleri


Place single line of text

PDF_fit_textflow
PDF_get_apiname
PDF İşlevleri
PHP Manual

PDF_fit_textline

(PECL pdflib >= 2.0.0)

PDF_fit_textline — Place single line of text

Açıklama

bool PDF_fit_textline ( resource $pdfdoc , string $text , float $x , float $y , string $optlist )

Places a single line of text on the page, subject to various options. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_fit_textflow
PDF_get_apiname
PDF İşlevleri


Get name of unsuccessfull API function

PDF_fit_textline
PDF_get_buffer
PDF İşlevleri
PHP Manual

PDF_get_apiname

(PECL pdflib >= 2.0.0)

PDF_get_apiname — Get name of unsuccessfull API function

Açıklama

string PDF_get_apiname ( resource $pdfdoc )

Gets the name of the API function which threw the last exception or failed.

PDF_fit_textline
PDF_get_buffer
PDF İşlevleri


Get PDF output buffer

PDF_get_apiname
PDF_get_errmsg
PDF İşlevleri
PHP Manual

PDF_get_buffer

(PHP 4 >= 4.0.5, PECL pdflib >= 1.0.0)

PDF_get_buffer — Get PDF output buffer

Açıklama

string PDF_get_buffer ( resource $p )

Fetches the buffer containing the generated PDF data.

PDF_get_apiname
PDF_get_errmsg
PDF İşlevleri


Get error text

PDF_get_buffer
PDF_get_errnum
PDF İşlevleri
PHP Manual

PDF_get_errmsg

(PECL pdflib >= 2.0.0)

PDF_get_errmsg — Get error text

Açıklama

string PDF_get_errmsg ( resource $pdfdoc )

Gets the text of the last thrown exception or the reason for a failed function call.

PDF_get_buffer
PDF_get_errnum
PDF İşlevleri


Get error number

PDF_get_errmsg
PDF_get_font
PDF İşlevleri
PHP Manual

PDF_get_errnum

(PECL pdflib >= 2.0.0)

PDF_get_errnum — Get error number

Açıklama

int PDF_get_errnum ( resource $pdfdoc )

Gets the number of the last thrown exception or the reason for a failed function call.

PDF_get_errmsg
PDF_get_font
PDF İşlevleri


Get font [deprecated]

PDF_get_errnum
PDF_get_fontname
PDF İşlevleri
PHP Manual

PDF_get_font

(PHP 4, PECL pdflib >= 1.0.0)

PDF_get_font — Get font [deprecated]

Açıklama

This function is deprecated since PDFlib version 3, use PDF_get_value() with the parameter font instead.

PDF_get_errnum
PDF_get_fontname
PDF İşlevleri


Get font name [deprecated]

PDF_get_font
PDF_get_fontsize
PDF İşlevleri
PHP Manual

PDF_get_fontname

(PHP 4, PECL pdflib >= 1.0.0)

PDF_get_fontname — Get font name [deprecated]

Açıklama

This function is deprecated since PDFlib version 3, use PDF_get_parameter() with the parameter fontname instead.

PDF_get_font
PDF_get_fontsize
PDF İşlevleri


Font handling [deprecated]

PDF_get_fontname
PDF_get_image_height
PDF İşlevleri
PHP Manual

PDF_get_fontsize

(PHP 4, PECL pdflib >= 1.0.0)

PDF_get_fontsize — Font handling [deprecated]

Açıklama

This function is deprecated since PDFlib version 3, use PDF_get_value() with the parameter fontsizeinstead.

PDF_get_fontname
PDF_get_image_height
PDF İşlevleri


Get image height [deprecated]

PDF_get_fontsize
PDF_get_image_width
PDF İşlevleri
PHP Manual

PDF_get_image_height

(PHP 4, PECL pdflib >= 1.0.0)

PDF_get_image_height — Get image height [deprecated]

Açıklama

This function is deprecated since PDFlib version 3, use PDF_get_value() with the parameter imageheight instead.

PDF_get_fontsize
PDF_get_image_width
PDF İşlevleri


Get image width [deprecated]

PDF_get_image_height
PDF_get_majorversion
PDF İşlevleri
PHP Manual

PDF_get_image_width

(PHP 4, PECL pdflib >= 1.0.0)

PDF_get_image_width — Get image width [deprecated]

Açıklama

This function is deprecated since PDFlib version 3, use PDF_get_value() with the parameter imagewidth instead.

PDF_get_image_height
PDF_get_majorversion
PDF İşlevleri


Get major version number [deprecated]

PDF_get_image_width
PDF_get_minorversion
PDF İşlevleri
PHP Manual

PDF_get_majorversion

(PHP 4 >= 4.2.0, PECL pdflib >= 1.0.0)

PDF_get_majorversion — Get major version number [deprecated]

Açıklama

int PDF_get_majorversion ( void )

This function is deprecated since PDFlib version 5, use PDF_get_value() with the parameter major instead.

PDF_get_image_width
PDF_get_minorversion
PDF İşlevleri


Get minor version number [deprecated]

PDF_get_majorversion
PDF_get_parameter
PDF İşlevleri
PHP Manual

PDF_get_minorversion

(PHP 4 >= 4.2.0, PECL pdflib >= 1.0.0)

PDF_get_minorversion — Get minor version number [deprecated]

Açıklama

int PDF_get_minorversion ( void )

Returns the minor version number of the PDFlib version.

This function is deprecated since PDFlib version 5, use PDF_get_value() with the parameter minor instead.

PDF_get_majorversion
PDF_get_parameter
PDF İşlevleri


Get string parameter

PDF_get_minorversion
PDF_get_pdi_parameter
PDF İşlevleri
PHP Manual

PDF_get_parameter

(PHP 4 >= 4.0.1, PECL pdflib >= 1.0.0)

PDF_get_parameter — Get string parameter

Açıklama

string PDF_get_parameter ( resource $p , string $key , float $modifier )

Gets the contents of some PDFlib parameter with string type.

PDF_get_minorversion
PDF_get_pdi_parameter
PDF İşlevleri


Get PDI string parameter [deprecated]

PDF_get_parameter
PDF_get_pdi_value
PDF İşlevleri
PHP Manual

PDF_get_pdi_parameter

(PHP 4 >= 4.0.5, PECL pdflib >= 1.0.0)

PDF_get_pdi_parameter — Get PDI string parameter [deprecated]

Açıklama

string PDF_get_pdi_parameter ( resource $p , string $key , int $doc , int $page , int $reserved )

Gets the contents of a PDI document parameter with string type.

This function is deprecated since PDFlib version 7, use PDF_pcos_get_string() instead.

PDF_get_parameter
PDF_get_pdi_value
PDF İşlevleri


Get PDI numerical parameter [deprecated]

PDF_get_pdi_parameter
PDF_get_value
PDF İşlevleri
PHP Manual

PDF_get_pdi_value

(PHP 4 >= 4.0.5, PECL pdflib >= 1.0.0)

PDF_get_pdi_value — Get PDI numerical parameter [deprecated]

Açıklama

float PDF_get_pdi_value ( resource $p , string $key , int $doc , int $page , int $reserved )

Gets the contents of a PDI document parameter with numerical type.

This function is deprecated since PDFlib version 7, use PDF_pcos_get_number() instead.

PDF_get_pdi_parameter
PDF_get_value
PDF İşlevleri


Get numerical parameter

PDF_get_pdi_value
PDF_info_font
PDF İşlevleri
PHP Manual

PDF_get_value

(PHP 4 >= 4.0.1, PECL pdflib >= 1.0.0)

PDF_get_value — Get numerical parameter

Açıklama

float PDF_get_value ( resource $p , string $key , float $modifier )

Gets the value of some PDFlib parameter with numerical type.

PDF_get_pdi_value
PDF_info_font
PDF İşlevleri


Query detailed information about a loaded font

PDF_get_value
PDF_info_matchbox
PDF İşlevleri
PHP Manual

PDF_info_font

(PECL pdflib >= 2.1.0)

PDF_info_font — Query detailed information about a loaded font

Açıklama

float PDF_info_font ( resource $pdfdoc , int $font , string $keyword , string $optlist )

Queries detailed information about a loaded font.

PDF_get_value
PDF_info_matchbox
PDF İşlevleri


Query matchbox information

PDF_info_font
PDF_info_table
PDF İşlevleri
PHP Manual

PDF_info_matchbox

(PECL pdflib >= 2.1.0)

PDF_info_matchbox — Query matchbox information

Açıklama

float PDF_info_matchbox ( resource $pdfdoc , string $boxname , int $num , string $keyword )

Queries information about a matchbox on the current page.

PDF_info_font
PDF_info_table
PDF İşlevleri


Retrieve table information

PDF_info_matchbox
PDF_info_textflow
PDF İşlevleri
PHP Manual

PDF_info_table

(PECL pdflib >= 2.1.0)

PDF_info_table — Retrieve table information

Açıklama

float PDF_info_table ( resource $pdfdoc , int $table , string $keyword )

Retrieves table information related to the most recently placed table instance.

PDF_info_matchbox
PDF_info_textflow
PDF İşlevleri


Query textflow state

PDF_info_table
PDF_info_textline
PDF İşlevleri
PHP Manual

PDF_info_textflow

(PECL pdflib >= 2.0.0)

PDF_info_textflow — Query textflow state

Açıklama

float PDF_info_textflow ( resource $pdfdoc , int $textflow , string $keyword )

Queries the current state of a textflow.

PDF_info_table
PDF_info_textline
PDF İşlevleri


Perform textline formatting and query metrics

PDF_info_textflow
PDF_initgraphics
PDF İşlevleri
PHP Manual

PDF_info_textline

(PECL pdflib >= 2.1.0)

PDF_info_textline — Perform textline formatting and query metrics

Açıklama

float PDF_info_textline ( resource $pdfdoc , string $text , string $keyword , string $optlist )

Performs textline formatting and queries the resulting metrics.

PDF_info_textflow
PDF_initgraphics
PDF İşlevleri


Reset graphic state

PDF_info_textline
PDF_lineto
PDF İşlevleri
PHP Manual

PDF_initgraphics

(PHP 4 >= 4.0.5, PECL pdflib >= 1.0.0)

PDF_initgraphics — Reset graphic state

Açıklama

bool PDF_initgraphics ( resource $p )

Reset all color and graphics state parameters to their defaults. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_info_textline
PDF_lineto
PDF İşlevleri


Draw a line

PDF_initgraphics
PDF_load_3ddata
PDF İşlevleri
PHP Manual

PDF_lineto

(PHP 4, PECL pdflib >= 1.0.0)

PDF_lineto — Draw a line

Açıklama

bool PDF_lineto ( resource $p , float $x , float $y )

Draws a line from the current point to another point. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_initgraphics
PDF_load_3ddata
PDF İşlevleri


Load 3D model

PDF_lineto
PDF_load_font
PDF İşlevleri
PHP Manual

PDF_load_3ddata

(PECL pdflib >= 2.1.0)

PDF_load_3ddata — Load 3D model

Açıklama

int PDF_load_3ddata ( resource $pdfdoc , string $filename , string $optlist )

Loads a 3D model from a disk-based or virtual file.

This function requires PDF 1.6.

PDF_lineto
PDF_load_font
PDF İşlevleri


Search and prepare font

PDF_load_3ddata
PDF_load_iccprofile
PDF İşlevleri
PHP Manual

PDF_load_font

(PECL pdflib >= 2.0.0)

PDF_load_font — Search and prepare font

Açıklama

int PDF_load_font ( resource $pdfdoc , string $fontname , string $encoding , string $optlist )

Searches for a font and prepares it for later use.

PDF_load_3ddata
PDF_load_iccprofile
PDF İşlevleri


Search and prepare ICC profile

PDF_load_font
PDF_load_image
PDF İşlevleri
PHP Manual

PDF_load_iccprofile

(PECL pdflib >= 2.0.0)

PDF_load_iccprofile — Search and prepare ICC profile

Açıklama

int PDF_load_iccprofile ( resource $pdfdoc , string $profilename , string $optlist )

Searches for an ICC profile, and prepares it for later use.

PDF_load_font
PDF_load_image
PDF İşlevleri


Open image file

PDF_load_iccprofile
PDF_makespotcolor
PDF İşlevleri
PHP Manual

PDF_load_image

(PECL pdflib >= 2.0.0)

PDF_load_image — Open image file

Açıklama

int PDF_load_image ( resource $pdfdoc , string $imagetype , string $filename , string $optlist )

Opens a disk-based or virtual image file subject to various options.

PDF_load_iccprofile
PDF_makespotcolor
PDF İşlevleri


Make spot color

PDF_load_image
PDF_moveto
PDF İşlevleri
PHP Manual

PDF_makespotcolor

(PHP 4 >= 4.0.5, PECL pdflib >= 1.0.0)

PDF_makespotcolor — Make spot color

Açıklama

int PDF_makespotcolor ( resource $p , string $spotname )

Finds a built-in spot color name, or makes a named spot color from the current fill color. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_load_image
PDF_moveto
PDF İşlevleri


Set current point

PDF_makespotcolor
PDF_new
PDF İşlevleri
PHP Manual

PDF_moveto

(PHP 4, PECL pdflib >= 1.0.0)

PDF_moveto — Set current point

Açıklama

bool PDF_moveto ( resource $p , float $x , float $y )

Sets the current point for graphics output. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_makespotcolor
PDF_new
PDF İşlevleri


Create PDFlib object

PDF_moveto
PDF_open_ccitt
PDF İşlevleri
PHP Manual

PDF_new

(PHP 4 >= 4.0.5, PECL pdflib >= 1.0.0)

PDF_new — Create PDFlib object

Açıklama

resource PDF_new ( void )

Creates a new PDFlib object with default settings.

PDF_moveto
PDF_open_ccitt
PDF İşlevleri


Open raw CCITT image [deprecated]

PDF_new
PDF_open_file
PDF İşlevleri
PHP Manual

PDF_open_ccitt

(PHP 4 >= 4.0.5, PECL pdflib >= 1.0.0)

PDF_open_ccitt — Open raw CCITT image [deprecated]

Açıklama

int PDF_open_ccitt ( resource $pdfdoc , string $filename , int $width , int $height , int $BitReverse , int $k , int $Blackls1 )

Opens a raw CCITT image.

This function is deprecated since PDFlib version 5, use PDF_load_image() instead.

PDF_new
PDF_open_file
PDF İşlevleri


Create PDF file [deprecated]

PDF_open_ccitt
PDF_open_gif
PDF İşlevleri
PHP Manual

PDF_open_file

(PHP 4 >= 4.0.5, PECL pdflib >= 1.0.0)

PDF_open_file — Create PDF file [deprecated]

Açıklama

bool PDF_open_file ( resource $p , string $filename )

Creates a new PDF file using the supplied file name. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

This function is deprecated since PDFlib version 6, use PDF_begin_document() instead.

PDF_open_ccitt
PDF_open_gif
PDF İşlevleri


Open GIF image [deprecated]

PDF_open_file
PDF_open_image_file
PDF İşlevleri
PHP Manual

PDF_open_gif

(PHP 4, PECL pdflib >= 1.0.0)

PDF_open_gif — Open GIF image [deprecated]

Açıklama

This function is deprecated since PDFlib version 3, use PDF_load_image() instead.

PDF_open_file
PDF_open_image_file
PDF İşlevleri


Read image from file [deprecated]

PDF_open_gif
PDF_open_image
PDF İşlevleri
PHP Manual

PDF_open_image_file

(PHP 4, PECL pdflib >= 1.0.0)

PDF_open_image_file — Read image from file [deprecated]

Açıklama

int PDF_open_image_file ( resource $p , string $imagetype , string $filename , string $stringparam , int $intparam )

Opens an image file.

This function is deprecated since PDFlib version 5, use PDF_load_image() with the colorize, ignoremask, invert, mask, masked, and page options instead.

PDF_open_gif
PDF_open_image
PDF İşlevleri


Use image data [deprecated]

PDF_open_image_file
PDF_open_jpeg
PDF İşlevleri
PHP Manual

PDF_open_image

(PHP 4 >= 4.0.5, PECL pdflib >= 1.0.0)

PDF_open_image — Use image data [deprecated]

Açıklama

int PDF_open_image ( resource $p , string $imagetype , string $source , string $data , int $length , int $width , int $height , int $components , int $bpc , string $params )

Uses image data from a variety of data sources.

This function is deprecated since PDFlib version 5, use virtual files and PDF_load_image() instead.

PDF_open_image_file
PDF_open_jpeg
PDF İşlevleri


Open JPEG image [deprecated]

PDF_open_image
PDF_open_memory_image
PDF İşlevleri
PHP Manual

PDF_open_jpeg

(PHP 4, PECL pdflib >= 1.0.0)

PDF_open_jpeg — Open JPEG image [deprecated]

Açıklama

This function is deprecated since PDFlib version 3, use PDF_load_image() instead.

PDF_open_image
PDF_open_memory_image
PDF İşlevleri


Open image created with PHP's image functions [not supported]

PDF_open_jpeg
PDF_open_pdi_document
PDF İşlevleri
PHP Manual

PDF_open_memory_image

(PHP 4, PECL pdflib >= 1.0.0)

PDF_open_memory_image — Open image created with PHP's image functions [not supported]

Açıklama

int PDF_open_memory_image ( resource $p , resource $image )

This function is not supported by PDFlib GmbH.

PDF_open_jpeg
PDF_open_pdi_document
PDF İşlevleri


Prepare a pdi document

PDF_open_memory_image
PDF_open_pdi_page
PDF İşlevleri
PHP Manual

PDF_open_pdi_document

(PECL pdflib >= 2.1.0)

PDF_open_pdi_document — Prepare a pdi document

Açıklama

int PDF_open_pdi_document ( resource $p , string $filename , string $optlist )

Open a disk-based or virtual PDF document and prepare it for later use.

PDF_open_memory_image
PDF_open_pdi_page
PDF İşlevleri


Prepare a page

PDF_open_pdi_document
PDF_open_pdi
PDF İşlevleri
PHP Manual

PDF_open_pdi_page

(PHP 4 >= 4.0.5, PECL pdflib >= 1.0.0)

PDF_open_pdi_page — Prepare a page

Açıklama

int PDF_open_pdi_page ( resource $p , int $doc , int $pagenumber , string $optlist )

Prepares a page for later use with PDF_fit_pdi_page().

PDF_open_pdi_document
PDF_open_pdi
PDF İşlevleri


Open PDF file [deprecated]

PDF_open_pdi_page
PDF_open_tiff
PDF İşlevleri
PHP Manual

PDF_open_pdi

(PHP 4 >= 4.0.5, PECL pdflib >= 1.0.0)

PDF_open_pdi — Open PDF file [deprecated]

Açıklama

int PDF_open_pdi ( resource $pdfdoc , string $filename , string $optlist , int $len )

Opens a disk-based or virtual PDF document and prepares it for later use.

This function is deprecated since PDFlib version 7, use PDF_open_pdi_document() instead.

PDF_open_pdi_page
PDF_open_tiff
PDF İşlevleri


Open TIFF image [deprecated]

PDF_open_pdi
PDF_pcos_get_number
PDF İşlevleri
PHP Manual

PDF_open_tiff

(PHP 4, PECL pdflib >= 1.0.0)

PDF_open_tiff — Open TIFF image [deprecated]

Açıklama

This function is deprecated since PDFlib version 3, use PDF_load_image() instead.

PDF_open_pdi
PDF_pcos_get_number
PDF İşlevleri


Get value of pCOS path with type number or boolean

PDF_open_tiff
PDF_pcos_get_stream
PDF İşlevleri
PHP Manual

PDF_pcos_get_number

(PECL pdflib >= 2.1.0)

PDF_pcos_get_number — Get value of pCOS path with type number or boolean

Açıklama

float PDF_pcos_get_number ( resource $p , int $doc , string $path )

Gets the value of a pCOS path with type number or boolean.

PDF_open_tiff
PDF_pcos_get_stream
PDF İşlevleri


Get contents of pCOS path with type stream, fstream, or string

PDF_pcos_get_number
PDF_pcos_get_string
PDF İşlevleri
PHP Manual

PDF_pcos_get_stream

(PECL pdflib >= 2.1.0)

PDF_pcos_get_stream — Get contents of pCOS path with type stream, fstream, or string

Açıklama

string PDF_pcos_get_stream ( resource $p , int $doc , string $optlist , string $path )

Gets the contents of a pCOS path with type stream, fstream, or string.

PDF_pcos_get_number
PDF_pcos_get_string
PDF İşlevleri


Get value of pCOS path with type name, string, or boolean

PDF_pcos_get_stream
PDF_place_image
PDF İşlevleri
PHP Manual

PDF_pcos_get_string

(PECL pdflib >= 2.1.0)

PDF_pcos_get_string — Get value of pCOS path with type name, string, or boolean

Açıklama

string PDF_pcos_get_string ( resource $p , int $doc , string $path )

Gets the value of a pCOS path with type name, string, or boolean.

PDF_pcos_get_stream
PDF_place_image
PDF İşlevleri


Place image on the page [deprecated]

PDF_pcos_get_string
PDF_place_pdi_page
PDF İşlevleri
PHP Manual

PDF_place_image

(PHP 4, PECL pdflib >= 1.0.0)

PDF_place_image — Place image on the page [deprecated]

Açıklama

bool PDF_place_image ( resource $pdfdoc , int $image , float $x , float $y , float $scale )

Places an image and scales it. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

This function is deprecated since PDFlib version 5, use PDF_fit_image() instead.

PDF_pcos_get_string
PDF_place_pdi_page
PDF İşlevleri


Place PDF page [deprecated]

PDF_place_image
PDF_process_pdi
PDF İşlevleri
PHP Manual

PDF_place_pdi_page

(PHP 4 >= 4.0.6, PECL pdflib >= 1.0.0)

PDF_place_pdi_page — Place PDF page [deprecated]

Açıklama

bool PDF_place_pdi_page ( resource $pdfdoc , int $page , float $x , float $y , float $sx , float $sy )

Places a PDF page and scales it. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

This function is deprecated since PDFlib version 5, use PDF_fit_pdi_page() instead.

PDF_place_image
PDF_process_pdi
PDF İşlevleri


Process imported PDF document

PDF_place_pdi_page
PDF_rect
PDF İşlevleri
PHP Manual

PDF_process_pdi

(PECL pdflib >= 2.0.0)

PDF_process_pdi — Process imported PDF document

Açıklama

int PDF_process_pdi ( resource $pdfdoc , int $doc , int $page , string $optlist )

Processes certain elements of an imported PDF document.

PDF_place_pdi_page
PDF_rect
PDF İşlevleri


Draw rectangle

PDF_process_pdi
PDF_restore
PDF İşlevleri
PHP Manual

PDF_rect

(PHP 4, PECL pdflib >= 1.0.0)

PDF_rect — Draw rectangle

Açıklama

bool PDF_rect ( resource $p , float $x , float $y , float $width , float $height )

Draws a rectangle. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_process_pdi
PDF_restore
PDF İşlevleri


Restore graphics state

PDF_rect
PDF_resume_page
PDF İşlevleri
PHP Manual

PDF_restore

(PHP 4, PECL pdflib >= 1.0.0)

PDF_restore — Restore graphics state

Açıklama

bool PDF_restore ( resource $p )

Restores the most recently saved graphics state. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_rect
PDF_resume_page
PDF İşlevleri


Resume page

PDF_restore
PDF_rotate
PDF İşlevleri
PHP Manual

PDF_resume_page

(PECL pdflib >= 2.0.0)

PDF_resume_page — Resume page

Açıklama

bool PDF_resume_page ( resource $pdfdoc , string $optlist )

Resumes a page to add more content to it.

PDF_restore
PDF_rotate
PDF İşlevleri


Rotate coordinate system

PDF_resume_page
PDF_save
PDF İşlevleri
PHP Manual

PDF_rotate

(PHP 4, PECL pdflib >= 1.0.0)

PDF_rotate — Rotate coordinate system

Açıklama

bool PDF_rotate ( resource $p , float $phi )

Rotates the coordinate system. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_resume_page
PDF_save
PDF İşlevleri


Save graphics state

PDF_rotate
PDF_scale
PDF İşlevleri
PHP Manual

PDF_save

(PHP 4, PECL pdflib >= 1.0.0)

PDF_save — Save graphics state

Açıklama

bool PDF_save ( resource $p )

Saves the current graphics state. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_rotate
PDF_scale
PDF İşlevleri


Scale coordinate system

PDF_save
PDF_set_border_color
PDF İşlevleri
PHP Manual

PDF_scale

(PHP 4, PECL pdflib >= 1.0.0)

PDF_scale — Scale coordinate system

Açıklama

bool PDF_scale ( resource $p , float $sx , float $sy )

Scales the coordinate system. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_save
PDF_set_border_color
PDF İşlevleri


Set border color of annotations [deprecated]

PDF_scale
PDF_set_border_dash
PDF İşlevleri
PHP Manual

PDF_set_border_color

(PHP 4, PECL pdflib >= 1.0.0)

PDF_set_border_color — Set border color of annotations [deprecated]

Açıklama

bool PDF_set_border_color ( resource $p , float $red , float $green , float $blue )

Sets the border color for all kinds of annotations. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

This function is deprecated since PDFlib version 6, use the option annotcolor in PDF_create_annotation() instead.

PDF_scale
PDF_set_border_dash
PDF İşlevleri


Set border dash style of annotations [deprecated]

PDF_set_border_color
PDF_set_border_style
PDF İşlevleri
PHP Manual

PDF_set_border_dash

(PHP 4 >= 4.0.1, PECL pdflib >= 1.0.0)

PDF_set_border_dash — Set border dash style of annotations [deprecated]

Açıklama

bool PDF_set_border_dash ( resource $pdfdoc , float $black , float $white )

Sets the border dash style for all kinds of annotations. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

This function is deprecated since PDFlib version 6, use the option dasharray in PDF_create_annotation() instead.

PDF_set_border_color
PDF_set_border_style
PDF İşlevleri


Set border style of annotations [deprecated]

PDF_set_border_dash
PDF_set_char_spacing
PDF İşlevleri
PHP Manual

PDF_set_border_style

(PHP 4, PECL pdflib >= 1.0.0)

PDF_set_border_style — Set border style of annotations [deprecated]

Açıklama

bool PDF_set_border_style ( resource $pdfdoc , string $style , float $width )

Sets the border style for all kinds of annotations. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

This function is deprecated since PDFlib version 6, use the options borderstyle and linewidth in PDF_create_annotation() instead.

PDF_set_border_dash
PDF_set_char_spacing
PDF İşlevleri


Set character spacing [deprecated]

PDF_set_border_style
PDF_set_duration
PDF İşlevleri
PHP Manual

PDF_set_char_spacing

(PHP 4, PECL pdflib >= 1.0.0)

PDF_set_char_spacing — Set character spacing [deprecated]

Açıklama

This function is deprecated since PDFlib version 3, use PDF_set_value() with parameter charspacing instead.

PDF_set_border_style
PDF_set_duration
PDF İşlevleri


Set duration between pages [deprecated]

PDF_set_char_spacing
PDF_set_gstate
PDF İşlevleri
PHP Manual

PDF_set_duration

(PHP 4, PECL pdflib >= 1.0.0)

PDF_set_duration — Set duration between pages [deprecated]

Açıklama

This function is deprecated since PDFlib version 3, use the duration option in PDF_begin_page_ext() or PDF_end_page_ext() instead.

PDF_set_char_spacing
PDF_set_gstate
PDF İşlevleri


Activate graphics state object

PDF_set_duration
PDF_set_horiz_scaling
PDF İşlevleri
PHP Manual

PDF_set_gstate

(PECL pdflib >= 2.0.0)

PDF_set_gstate — Activate graphics state object

Açıklama

bool PDF_set_gstate ( resource $pdfdoc , int $gstate )

Activates a graphics state object.

PDF_set_duration
PDF_set_horiz_scaling
PDF İşlevleri


Set horizontal text scaling [deprecated]

PDF_set_gstate
PDF_set_info_author
PDF İşlevleri
PHP Manual

PDF_set_horiz_scaling

(PHP 4, PECL pdflib >= 1.0.0)

PDF_set_horiz_scaling — Set horizontal text scaling [deprecated]

Açıklama

This function is deprecated since PDFlib version 3, use PDF_set_value() with parameter horizscaling instead.

PDF_set_gstate
PDF_set_info_author
PDF İşlevleri


Fill the author document info field [deprecated]

PDF_set_horiz_scaling
PDF_set_info_creator
PDF İşlevleri
PHP Manual

PDF_set_info_author

(PHP 4, PECL pdflib >= 1.0.0)

PDF_set_info_author — Fill the author document info field [deprecated]

Açıklama

This function is deprecated since PDFlib version 3, use PDF_set_info() instead.

PDF_set_horiz_scaling
PDF_set_info_creator
PDF İşlevleri


Fill the creator document info field [deprecated]

PDF_set_info_author
PDF_set_info_keywords
PDF İşlevleri
PHP Manual

PDF_set_info_creator

(PHP 4, PECL pdflib >= 1.0.0)

PDF_set_info_creator — Fill the creator document info field [deprecated]

Açıklama

This function is deprecated since PDFlib version 3, use PDF_set_info() instead.

PDF_set_info_author
PDF_set_info_keywords
PDF İşlevleri


Fill the keywords document info field [deprecated]

PDF_set_info_creator
PDF_set_info_subject
PDF İşlevleri
PHP Manual

PDF_set_info_keywords

(PHP 4, PECL pdflib >= 1.0.0)

PDF_set_info_keywords — Fill the keywords document info field [deprecated]

Açıklama

This function is deprecated since PDFlib version 3, use PDF_set_info() instead.

PDF_set_info_creator
PDF_set_info_subject
PDF İşlevleri


Fill the subject document info field [deprecated]

PDF_set_info_keywords
PDF_set_info_title
PDF İşlevleri
PHP Manual

PDF_set_info_subject

(PHP 4, PECL pdflib >= 1.0.0)

PDF_set_info_subject — Fill the subject document info field [deprecated]

Açıklama

This function is deprecated since PDFlib version 3, use PDF_set_info() instead.

PDF_set_info_keywords
PDF_set_info_title
PDF İşlevleri


Fill the title document info field [deprecated]

PDF_set_info_subject
PDF_set_info
PDF İşlevleri
PHP Manual

PDF_set_info_title

(PHP 4, PECL pdflib >= 1.0.0)

PDF_set_info_title — Fill the title document info field [deprecated]

Açıklama

This function is deprecated since PDFlib version 3, use PDF_set_info() instead.

PDF_set_info_subject
PDF_set_info
PDF İşlevleri


Fill document info field

PDF_set_info_title
PDF_set_layer_dependency
PDF İşlevleri
PHP Manual

PDF_set_info

(PHP 4 >= 4.0.1, PECL pdflib >= 1.0.0)

PDF_set_info — Fill document info field

Açıklama

bool PDF_set_info ( resource $p , string $key , string $value )

Fill document information field key with value. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_set_info_title
PDF_set_layer_dependency
PDF İşlevleri


Define relationships among layers

PDF_set_info
PDF_set_leading
PDF İşlevleri
PHP Manual

PDF_set_layer_dependency

(PECL pdflib >= 2.0.0)

PDF_set_layer_dependency — Define relationships among layers

Açıklama

bool PDF_set_layer_dependency ( resource $pdfdoc , string $type , string $optlist )

Defines hierarchical and group relationships among layers. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

This function requires PDF 1.5.

PDF_set_info
PDF_set_leading
PDF İşlevleri


Set distance between text lines [deprecated]

PDF_set_layer_dependency
PDF_set_parameter
PDF İşlevleri
PHP Manual

PDF_set_leading

(PHP 4, PECL pdflib >= 1.0.0)

PDF_set_leading — Set distance between text lines [deprecated]

Açıklama

This function is deprecated since PDFlib version 3, use PDF_set_value() with the parameter leading instead.

PDF_set_layer_dependency
PDF_set_parameter
PDF İşlevleri


Set string parameter

PDF_set_leading
PDF_set_text_matrix
PDF İşlevleri
PHP Manual

PDF_set_parameter

(PHP 4, PECL pdflib >= 1.0.0)

PDF_set_parameter — Set string parameter

Açıklama

bool PDF_set_parameter ( resource $p , string $key , string $value )

Sets some PDFlib parameter with string type. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_set_leading
PDF_set_text_matrix
PDF İşlevleri


Set text matrix [deprecated]

PDF_set_parameter
PDF_set_text_pos
PDF İşlevleri
PHP Manual

PDF_set_text_matrix

(PHP 4 <= 4.0.4)

PDF_set_text_matrix — Set text matrix [deprecated]

Açıklama

This function is deprecated since PDFlib version 3, use PDF_scale(), PDF_translate(), PDF_rotate(), or PDF_skew() instead.

PDF_set_parameter
PDF_set_text_pos
PDF İşlevleri


Set text position

PDF_set_text_matrix
PDF_set_text_rendering
PDF İşlevleri
PHP Manual

PDF_set_text_pos

(PHP 4, PECL pdflib >= 1.0.0)

PDF_set_text_pos — Set text position

Açıklama

bool PDF_set_text_pos ( resource $p , float $x , float $y )

Sets the position for text output on the page. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_set_text_matrix
PDF_set_text_rendering
PDF İşlevleri


Determine text rendering [deprecated]

PDF_set_text_pos
PDF_set_text_rise
PDF İşlevleri
PHP Manual

PDF_set_text_rendering

(PHP 4, PECL pdflib >= 1.0.0)

PDF_set_text_rendering — Determine text rendering [deprecated]

Açıklama

This function is deprecated since PDFlib version 3, use PDF_set_value() with the textrendering parameter instead.

PDF_set_text_pos
PDF_set_text_rise
PDF İşlevleri


Set text rise [deprecated]

PDF_set_text_rendering
PDF_set_value
PDF İşlevleri
PHP Manual

PDF_set_text_rise

(PHP 4, PECL pdflib >= 1.0.0)

PDF_set_text_rise — Set text rise [deprecated]

Açıklama

This function is deprecated since PDFlib version 3, use PDF_set_value() with the textrise parameter instead.

PDF_set_text_rendering
PDF_set_value
PDF İşlevleri


Set numerical parameter

PDF_set_text_rise
PDF_set_word_spacing
PDF İşlevleri
PHP Manual

PDF_set_value

(PHP 4 >= 4.0.1, PECL pdflib >= 1.0.0)

PDF_set_value — Set numerical parameter

Açıklama

bool PDF_set_value ( resource $p , string $key , float $value )

Sets the value of some PDFlib parameter with numerical type. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_set_text_rise
PDF_set_word_spacing
PDF İşlevleri


Set spacing between words [deprecated]

PDF_set_value
PDF_setcolor
PDF İşlevleri
PHP Manual

PDF_set_word_spacing

(PHP 4, PECL pdflib >= 1.0.0)

PDF_set_word_spacing — Set spacing between words [deprecated]

Açıklama

This function is deprecated since PDFlib version 3, use PDF_set_value() with the wordspacing parameter instead.

PDF_set_value
PDF_setcolor
PDF İşlevleri


Set fill and stroke color

PDF_set_word_spacing
PDF_setdash
PDF İşlevleri
PHP Manual

PDF_setcolor

(PHP 4 >= 4.0.5, PECL pdflib >= 1.0.0)

PDF_setcolor — Set fill and stroke color

Açıklama

bool PDF_setcolor ( resource $p , string $fstype , string $colorspace , float $c1 , float $c2 , float $c3 , float $c4 )

Sets the current color space and color. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_set_word_spacing
PDF_setdash
PDF İşlevleri


Set simple dash pattern

PDF_setcolor
PDF_setdashpattern
PDF İşlevleri
PHP Manual

PDF_setdash

(PHP 4, PECL pdflib >= 1.0.0)

PDF_setdash — Set simple dash pattern

Açıklama

bool PDF_setdash ( resource $pdfdoc , float $b , float $w )

Sets the current dash pattern to b black and w white units. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_setcolor
PDF_setdashpattern
PDF İşlevleri


Set dash pattern

PDF_setdash
PDF_setflat
PDF İşlevleri
PHP Manual

PDF_setdashpattern

(PECL pdflib >= 2.0.0)

PDF_setdashpattern — Set dash pattern

Açıklama

bool PDF_setdashpattern ( resource $pdfdoc , string $optlist )

Sets a dash pattern defined by an option list. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_setdash
PDF_setflat
PDF İşlevleri


Set flatness

PDF_setdashpattern
PDF_setfont
PDF İşlevleri
PHP Manual

PDF_setflat

(PHP 4, PECL pdflib >= 1.0.0)

PDF_setflat — Set flatness

Açıklama

bool PDF_setflat ( resource $pdfdoc , float $flatness )

Sets the flatness parameter. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_setdashpattern
PDF_setfont
PDF İşlevleri


Set font

PDF_setflat
PDF_setgray_fill
PDF İşlevleri
PHP Manual

PDF_setfont

(PHP 4 >= 4.0.5, PECL pdflib >= 1.0.0)

PDF_setfont — Set font

Açıklama

bool PDF_setfont ( resource $pdfdoc , int $font , float $fontsize )

Sets the current font in the specified fontsize, using a font handle returned by PDF_load_font(). Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_setflat
PDF_setgray_fill
PDF İşlevleri


Set fill color to gray [deprecated]

PDF_setfont
PDF_setgray_stroke
PDF İşlevleri
PHP Manual

PDF_setgray_fill

(PHP 4, PECL pdflib >= 1.0.0)

PDF_setgray_fill — Set fill color to gray [deprecated]

Açıklama

bool PDF_setgray_fill ( resource $p , float $g )

Sets the current fill color to a gray value between 0 and 1 inclusive. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

This function is deprecated since PDFlib version 4, use PDF_setcolor() instead.

PDF_setfont
PDF_setgray_stroke
PDF İşlevleri


Set stroke color to gray [deprecated]

PDF_setgray_fill
PDF_setgray
PDF İşlevleri
PHP Manual

PDF_setgray_stroke

(PHP 4, PECL pdflib >= 1.0.0)

PDF_setgray_stroke — Set stroke color to gray [deprecated]

Açıklama

bool PDF_setgray_stroke ( resource $p , float $g )

Sets the current stroke color to a gray value between 0 and 1 inclusive. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

This function is deprecated since PDFlib version 4, use PDF_setcolor() instead.

PDF_setgray_fill
PDF_setgray
PDF İşlevleri


Set color to gray [deprecated]

PDF_setgray_stroke
PDF_setlinecap
PDF İşlevleri
PHP Manual

PDF_setgray

(PHP 4, PECL pdflib >= 1.0.0)

PDF_setgray — Set color to gray [deprecated]

Açıklama

bool PDF_setgray ( resource $p , float $g )

Sets the current fill and stroke color to a gray value between 0 and 1 inclusive. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

This function is deprecated since PDFlib version 4, use PDF_setcolor() instead.

PDF_setgray_stroke
PDF_setlinecap
PDF İşlevleri


Set linecap parameter

PDF_setgray
PDF_setlinejoin
PDF İşlevleri
PHP Manual

PDF_setlinecap

(PHP 4, PECL pdflib >= 1.0.0)

PDF_setlinecap — Set linecap parameter

Açıklama

bool PDF_setlinecap ( resource $p , int $linecap )

Sets the linecap parameter to control the shape at the end of a path with respect to stroking.

PDF_setgray
PDF_setlinejoin
PDF İşlevleri


Set linejoin parameter

PDF_setlinecap
PDF_setlinewidth
PDF İşlevleri
PHP Manual

PDF_setlinejoin

(PHP 4, PECL pdflib >= 1.0.0)

PDF_setlinejoin — Set linejoin parameter

Açıklama

bool PDF_setlinejoin ( resource $p , int $value )

Sets the linejoin parameter to specify the shape at the corners of paths that are stroked. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_setlinecap
PDF_setlinewidth
PDF İşlevleri


Set line width

PDF_setlinejoin
PDF_setmatrix
PDF İşlevleri
PHP Manual

PDF_setlinewidth

(PHP 4, PECL pdflib >= 1.0.0)

PDF_setlinewidth — Set line width

Açıklama

bool PDF_setlinewidth ( resource $p , float $width )

Sets the current line width. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_setlinejoin
PDF_setmatrix
PDF İşlevleri


Set current transformation matrix

PDF_setlinewidth
PDF_setmiterlimit
PDF İşlevleri
PHP Manual

PDF_setmatrix

(PHP 4 >= 4.0.5, PECL pdflib >= 1.0.0)

PDF_setmatrix — Set current transformation matrix

Açıklama

bool PDF_setmatrix ( resource $p , float $a , float $b , float $c , float $d , float $e , float $f )

Explicitly sets the current transformation matrix. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_setlinewidth
PDF_setmiterlimit
PDF İşlevleri


Set miter limit

PDF_setmatrix
PDF_setpolydash
PDF İşlevleri
PHP Manual

PDF_setmiterlimit

(PHP 4, PECL pdflib >= 1.0.0)

PDF_setmiterlimit — Set miter limit

Açıklama

bool PDF_setmiterlimit ( resource $pdfdoc , float $miter )

Sets the miter limit.Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_setmatrix
PDF_setpolydash
PDF İşlevleri


Set complicated dash pattern [deprecated]

PDF_setmiterlimit
PDF_setrgbcolor_fill
PDF İşlevleri
PHP Manual

PDF_setpolydash

(PHP 4 >= 4.0.5, PECL pdflib >= 1.0.0)

PDF_setpolydash — Set complicated dash pattern [deprecated]

Açıklama

This function is deprecated since PDFlib version 5, use PDF_setdashpattern() instead.

PDF_setmiterlimit
PDF_setrgbcolor_fill
PDF İşlevleri


Set fill rgb color values [deprecated]

PDF_setpolydash
PDF_setrgbcolor_stroke
PDF İşlevleri
PHP Manual

PDF_setrgbcolor_fill

(PHP 4, PECL pdflib >= 1.0.0)

PDF_setrgbcolor_fill — Set fill rgb color values [deprecated]

Açıklama

bool PDF_setrgbcolor_fill ( resource $p , float $red , float $green , float $blue )

Sets the current fill color to the supplied RGB values. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

This function is deprecated since PDFlib version 4, use PDF_setcolor() instead.

PDF_setpolydash
PDF_setrgbcolor_stroke
PDF İşlevleri


Set stroke rgb color values [deprecated]

PDF_setrgbcolor_fill
PDF_setrgbcolor
PDF İşlevleri
PHP Manual

PDF_setrgbcolor_stroke

(PHP 4, PECL pdflib >= 1.0.0)

PDF_setrgbcolor_stroke — Set stroke rgb color values [deprecated]

Açıklama

bool PDF_setrgbcolor_stroke ( resource $p , float $red , float $green , float $blue )

Sets the current stroke color to the supplied RGB values. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

This function is deprecated since PDFlib version 4, use PDF_setcolor() instead.

PDF_setrgbcolor_fill
PDF_setrgbcolor
PDF İşlevleri


Set fill and stroke rgb color values [deprecated]

PDF_setrgbcolor_stroke
PDF_shading_pattern
PDF İşlevleri
PHP Manual

PDF_setrgbcolor

(PHP 4, PECL pdflib >= 1.0.0)

PDF_setrgbcolor — Set fill and stroke rgb color values [deprecated]

Açıklama

bool PDF_setrgbcolor ( resource $p , float $red , float $green , float $blue )

Sets the current fill and stroke color to the supplied RGB values. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

This function is deprecated since PDFlib version 4, use PDF_setcolor() instead.

PDF_setrgbcolor_stroke
PDF_shading_pattern
PDF İşlevleri


Define shading pattern

PDF_setrgbcolor
PDF_shading
PDF İşlevleri
PHP Manual

PDF_shading_pattern

(PECL pdflib >= 2.0.0)

PDF_shading_pattern — Define shading pattern

Açıklama

int PDF_shading_pattern ( resource $pdfdoc , int $shading , string $optlist )

Defines a shading pattern using a shading object.

This function requires PDF 1.4 or above.

PDF_setrgbcolor
PDF_shading
PDF İşlevleri


Define blend

PDF_shading_pattern
PDF_shfill
PDF İşlevleri
PHP Manual

PDF_shading

(PECL pdflib >= 2.0.0)

PDF_shading — Define blend

Açıklama

int PDF_shading ( resource $pdfdoc , string $shtype , float $x0 , float $y0 , float $x1 , float $y1 , float $c1 , float $c2 , float $c3 , float $c4 , string $optlist )

Defines a blend from the current fill color to another color.

This function requires PDF 1.4 or above.

PDF_shading_pattern
PDF_shfill
PDF İşlevleri


Fill area with shading

PDF_shading
PDF_show_boxed
PDF İşlevleri
PHP Manual

PDF_shfill

(PECL pdflib >= 2.0.0)

PDF_shfill — Fill area with shading

Açıklama

bool PDF_shfill ( resource $pdfdoc , int $shading )

Fills an area with a shading, based on a shading object.

This function requires PDF 1.4 or above.

PDF_shading
PDF_show_boxed
PDF İşlevleri


Output text in a box [deprecated]

PDF_shfill
PDF_show_xy
PDF İşlevleri
PHP Manual

PDF_show_boxed

(PHP 4, PECL pdflib >= 1.0.0)

PDF_show_boxed — Output text in a box [deprecated]

Açıklama

int PDF_show_boxed ( resource $p , string $text , float $left , float $top , float $width , float $height , string $mode , string $feature )

This function is deprecated since PDFlib version 6, use PDF_fit_textline() for single lines, or the PDF_*_textflow() functions for multi-line formatting instead.

PDF_shfill
PDF_show_xy
PDF İşlevleri


Output text at given position

PDF_show_boxed
PDF_show
PDF İşlevleri
PHP Manual

PDF_show_xy

(PHP 4, PECL pdflib >= 1.0.0)

PDF_show_xy — Output text at given position

Açıklama

bool PDF_show_xy ( resource $p , string $text , float $x , float $y )

Prints text in the current font. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_show_boxed
PDF_show
PDF İşlevleri


Output text at current position

PDF_show_xy
PDF_skew
PDF İşlevleri
PHP Manual

PDF_show

(PHP 4, PECL pdflib >= 1.0.0)

PDF_show — Output text at current position

Açıklama

bool PDF_show ( resource $pdfdoc , string $text )

Prints text in the current font and size at the current position. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_show_xy
PDF_skew
PDF İşlevleri


Skew the coordinate system

PDF_show
PDF_stringwidth
PDF İşlevleri
PHP Manual

PDF_skew

(PHP 4, PECL pdflib >= 1.0.0)

PDF_skew — Skew the coordinate system

Açıklama

bool PDF_skew ( resource $p , float $alpha , float $beta )

Skews the coordinate system in x and y direction by alpha and beta degrees, respectively. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_show
PDF_stringwidth
PDF İşlevleri


Return width of text

PDF_skew
PDF_stroke
PDF İşlevleri
PHP Manual

PDF_stringwidth

(PHP 4, PECL pdflib >= 1.0.0)

PDF_stringwidth — Return width of text

Açıklama

float PDF_stringwidth ( resource $p , string $text , int $font , float $fontsize )

Returns the width of text in an arbitrary font.

PDF_skew
PDF_stroke
PDF İşlevleri


Stroke path

PDF_stringwidth
PDF_suspend_page
PDF İşlevleri
PHP Manual

PDF_stroke

(PHP 4, PECL pdflib >= 1.0.0)

PDF_stroke — Stroke path

Açıklama

bool PDF_stroke ( resource $p )

Strokes the path with the current color and line width, and clear it. Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

PDF_stringwidth
PDF_suspend_page
PDF İşlevleri


Suspend page

PDF_stroke
PDF_translate
PDF İşlevleri
PHP Manual

PDF_suspend_page

(PECL pdflib >= 2.0.0)

PDF_suspend_page — Suspend page

Açıklama

bool PDF_suspend_page ( resource $pdfdoc , string $optlist )

Suspends the current page so that it can later be resumed with PDF_resume_page().

PDF_stroke
PDF_translate
PDF İşlevleri


Set origin of coordinate system

PDF_suspend_page
PDF_utf16_to_utf8
PDF İşlevleri
PHP Manual

PDF_translate

(PHP 4, PECL pdflib >= 1.0.0)

PDF_translate — Set origin of coordinate system

Açıklama

bool PDF_translate ( resource $p , float $tx , float $ty )

Translates the origin of the coordinate system.

PDF_suspend_page
PDF_utf16_to_utf8
PDF İşlevleri


Convert string from UTF-16 to UTF-8

PDF_translate
PDF_utf32_to_utf16
PDF İşlevleri
PHP Manual

PDF_utf16_to_utf8

(PECL pdflib >= 2.0.3)

PDF_utf16_to_utf8 — Convert string from UTF-16 to UTF-8

Açıklama

string PDF_utf16_to_utf8 ( resource $pdfdoc , string $utf16string )

Converts a string from UTF-16 format to UTF-8.

PDF_translate
PDF_utf32_to_utf16
PDF İşlevleri


Convert string from UTF-32 to UTF-16

PDF_utf16_to_utf8
PDF_utf8_to_utf16
PDF İşlevleri
PHP Manual

PDF_utf32_to_utf16

(PECL pdflib >= Unknown future)

PDF_utf32_to_utf16 — Convert string from UTF-32 to UTF-16

Açıklama

string PDF_utf32_to_utf16 ( resource $pdfdoc , string $utf32string , string $ordering )

Converts a string from UTF-32 format to UTF-16.

PDF_utf16_to_utf8
PDF_utf8_to_utf16
PDF İşlevleri


Convert string from UTF-8 to UTF-16

PDF_utf32_to_utf16
PS
PDF İşlevleri
PHP Manual

PDF_utf8_to_utf16

(PECL pdflib >= 2.0.3)

PDF_utf8_to_utf16 — Convert string from UTF-8 to UTF-16

Açıklama

string PDF_utf8_to_utf16 ( resource $pdfdoc , string $utf8string , string $ordering )

Converts a string from UTF-8 format to UTF-16.

PDF_utf32_to_utf16
PS
PDF İşlevleri


PostScript document creation

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • PS İşlevleri
    • ps_add_bookmark — Add bookmark to current page
    • ps_add_launchlink — Adds link which launches file
    • ps_add_locallink — Adds link to a page in the same document
    • ps_add_note — Adds note to current page
    • ps_add_pdflink — Adds link to a page in a second pdf document
    • ps_add_weblink — Adds link to a web location
    • ps_arc — Draws an arc counterclockwise
    • ps_arcn — Draws an arc clockwise
    • ps_begin_page — Start a new page
    • ps_begin_pattern — Start a new pattern
    • ps_begin_template — Start a new template
    • ps_circle — Draws a circle
    • ps_clip — Clips drawing to current path
    • ps_close_image — Closes image and frees memory
    • ps_close — Closes a PostScript document
    • ps_closepath_stroke — Closes and strokes path
    • ps_closepath — Closes path
    • ps_continue_text — Continue text in next line
    • ps_curveto — Draws a curve
    • ps_delete — Deletes all resources of a PostScript document
    • ps_end_page — End a page
    • ps_end_pattern — End a pattern
    • ps_end_template — End a template
    • ps_fill_stroke — Fills and strokes the current path
    • ps_fill — Fills the current path
    • ps_findfont — Loads a font
    • ps_get_buffer — Fetches the full buffer containig the generated PS data
    • ps_get_parameter — Gets certain parameters
    • ps_get_value — Gets certain values
    • ps_hyphenate — Hyphenates a word
    • ps_include_file — Reads an external file with raw PostScript code
    • ps_lineto — Draws a line
    • ps_makespotcolor — Create spot color
    • ps_moveto — Sets current point
    • ps_new — Creates a new PostScript document object
    • ps_open_file — Opens a file for output
    • ps_open_image_file — Opens image from file
    • ps_open_image — Reads an image for later placement
    • ps_open_memory_image — Takes an GD image and returns an image for placement in a PS document
    • ps_place_image — Places image on the page
    • ps_rect — Draws a rectangle
    • ps_restore — Restore previously save context
    • ps_rotate — Sets rotation factor
    • ps_save — Save current context
    • ps_scale — Sets scaling factor
    • ps_set_border_color — Sets color of border for annotations
    • ps_set_border_dash — Sets length of dashes for border of annotations
    • ps_set_border_style — Sets border style of annotations
    • ps_set_info — Sets information fields of document
    • ps_set_parameter — Sets certain parameters
    • ps_set_text_pos — Sets position for text output
    • ps_set_value — Sets certain values
    • ps_setcolor — Sets current color
    • ps_setdash — Sets appearance of a dashed line
    • ps_setflat — Sets flatness
    • ps_setfont — Sets font to use for following output
    • ps_setgray — Sets gray value
    • ps_setlinecap — Sets appearance of line ends
    • ps_setlinejoin — Sets how contected lines are joined
    • ps_setlinewidth — Sets width of a line
    • ps_setmiterlimit — Sets the miter limit
    • ps_setoverprintmode — Sets overprint mode
    • ps_setpolydash — Sets appearance of a dashed line
    • ps_shading_pattern — Creates a pattern based on a shading
    • ps_shading — Creates a shading for later use
    • ps_shfill — Fills an area with a shading
    • ps_show_boxed — Output text in a box
    • ps_show_xy2 — Output text at position
    • ps_show_xy — Output text at given position
    • ps_show2 — Output a text at current position
    • ps_show — Output text
    • ps_string_geometry — Gets geometry of a string
    • ps_stringwidth — Gets width of a string
    • ps_stroke — Draws the current path
    • ps_symbol_name — Gets name of a glyph
    • ps_symbol_width — Gets width of a glyph
    • ps_symbol — Output a glyph
    • ps_translate — Sets translation
PDF_utf8_to_utf16
Giriş
Salt Metin Olmayan MIME Çıktılama


Giriş

This module allows to create PostScript documents. It has many similarities with the pdf extension. Actually the API is almost identical and one can in many cases just replace the prefix of each function from pdf_ to ps_. This also works for functions which has no meaning in the PostScript document (like adding hyperlinks) but will have an effect if the document is converted to PDF.

Documents created by this extension are sometimes even superior to documents created with the pdf extension, because pslib's text rendering functions can handle kerning, hyphenation and ligatures which results in much better output of boxed text.

PS
Yapılandırma/Kurulum
PS


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
PS


Gereksinimler

You need at least pslib >= 0.1.12. The ps library (pslib) is available at » http://pslib.sourceforge.net/.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/ps.

Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Özkaynak Türleri

This extension defines a PostScript document resource returned by ps_new().

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

The following two tables lists all constants defined by the ps extension.

Contants for line caps
Name | Meaning
ps_LINECAP_BUTT |
ps_LINECAP_ROUND |
ps_LINECAP_SQUARED |
Contants for line joins
Name | Meaning
ps_LINEJOIN_MITER |
ps_LINEJOIN_ROUND |
ps_LINEJOIN_BEVEL |

Özkaynak Türleri
PS İşlevleri
PS


PS İşlevleri

Contact Information

If you have comments, bugfixes, enhancements for either this extension or pslib then please drop me a mail » steinm@php.net. Any help is very welcome.

İçindekiler

  • ps_add_bookmark — Add bookmark to current page
  • ps_add_launchlink — Adds link which launches file
  • ps_add_locallink — Adds link to a page in the same document
  • ps_add_note — Adds note to current page
  • ps_add_pdflink — Adds link to a page in a second pdf document
  • ps_add_weblink — Adds link to a web location
  • ps_arc — Draws an arc counterclockwise
  • ps_arcn — Draws an arc clockwise
  • ps_begin_page — Start a new page
  • ps_begin_pattern — Start a new pattern
  • ps_begin_template — Start a new template
  • ps_circle — Draws a circle
  • ps_clip — Clips drawing to current path
  • ps_close_image — Closes image and frees memory
  • ps_close — Closes a PostScript document
  • ps_closepath_stroke — Closes and strokes path
  • ps_closepath — Closes path
  • ps_continue_text — Continue text in next line
  • ps_curveto — Draws a curve
  • ps_delete — Deletes all resources of a PostScript document
  • ps_end_page — End a page
  • ps_end_pattern — End a pattern
  • ps_end_template — End a template
  • ps_fill_stroke — Fills and strokes the current path
  • ps_fill — Fills the current path
  • ps_findfont — Loads a font
  • ps_get_buffer — Fetches the full buffer containig the generated PS data
  • ps_get_parameter — Gets certain parameters
  • ps_get_value — Gets certain values
  • ps_hyphenate — Hyphenates a word
  • ps_include_file — Reads an external file with raw PostScript code
  • ps_lineto — Draws a line
  • ps_makespotcolor — Create spot color
  • ps_moveto — Sets current point
  • ps_new — Creates a new PostScript document object
  • ps_open_file — Opens a file for output
  • ps_open_image_file — Opens image from file
  • ps_open_image — Reads an image for later placement
  • ps_open_memory_image — Takes an GD image and returns an image for placement in a PS document
  • ps_place_image — Places image on the page
  • ps_rect — Draws a rectangle
  • ps_restore — Restore previously save context
  • ps_rotate — Sets rotation factor
  • ps_save — Save current context
  • ps_scale — Sets scaling factor
  • ps_set_border_color — Sets color of border for annotations
  • ps_set_border_dash — Sets length of dashes for border of annotations
  • ps_set_border_style — Sets border style of annotations
  • ps_set_info — Sets information fields of document
  • ps_set_parameter — Sets certain parameters
  • ps_set_text_pos — Sets position for text output
  • ps_set_value — Sets certain values
  • ps_setcolor — Sets current color
  • ps_setdash — Sets appearance of a dashed line
  • ps_setflat — Sets flatness
  • ps_setfont — Sets font to use for following output
  • ps_setgray — Sets gray value
  • ps_setlinecap — Sets appearance of line ends
  • ps_setlinejoin — Sets how contected lines are joined
  • ps_setlinewidth — Sets width of a line
  • ps_setmiterlimit — Sets the miter limit
  • ps_setoverprintmode — Sets overprint mode
  • ps_setpolydash — Sets appearance of a dashed line
  • ps_shading_pattern — Creates a pattern based on a shading
  • ps_shading — Creates a shading for later use
  • ps_shfill — Fills an area with a shading
  • ps_show_boxed — Output text in a box
  • ps_show_xy2 — Output text at position
  • ps_show_xy — Output text at given position
  • ps_show2 — Output a text at current position
  • ps_show — Output text
  • ps_string_geometry — Gets geometry of a string
  • ps_stringwidth — Gets width of a string
  • ps_stroke — Draws the current path
  • ps_symbol_name — Gets name of a glyph
  • ps_symbol_width — Gets width of a glyph
  • ps_symbol — Output a glyph
  • ps_translate — Sets translation
Öntanımlı Sabitler
ps_add_bookmark
PS


Add bookmark to current page

PS İşlevleri
ps_add_launchlink
PS İşlevleri
PHP Manual

ps_add_bookmark

(PECL ps >= 1.1.0)

ps_add_bookmark — Add bookmark to current page

Açıklama

int ps_add_bookmark ( resource $psdoc , string $text [, int $parent = 0 [, int $open = 0 ]] )

Adds a bookmark for the current page. Bookmarks usually appear in PDF-Viewers left of the page in a hierarchical tree. Clicking on a bookmark will jump to the given page.

The note will not be visible if the document is printed or viewed but it will show up if the document is converted to pdf by either Acrobat Distiller™ or Ghostview.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

text

The text used for displaying the bookmark.

parent

A bookmark previously created by this function which is used as the parent of the new bookmark.

open

If open is unequal to zero the bookmark will be shown open by the pdf viewer.

Dönen Değerler

The returned value is a reference for the bookmark. It is only used if the bookmark shall be used as a parent. The value is greater zero if the function succeeds. In case of an error zero will be returned.

Ayrıca Bakınız

  • ps_add_launchlink() - Adds link which launches file
  • ps_add_pdflink() - Adds link to a page in a second pdf document
  • ps_add_weblink() - Adds link to a web location

PS İşlevleri
ps_add_launchlink
PS İşlevleri


Adds link which launches file

ps_add_bookmark
ps_add_locallink
PS İşlevleri
PHP Manual

ps_add_launchlink

(PECL ps >= 1.1.0)

ps_add_launchlink — Adds link which launches file

Açıklama

bool ps_add_launchlink ( resource $psdoc , float $llx , float $lly , float $urx , float $ury , string $filename )

Places a hyperlink at the given position pointing to a file program which is being started when clicked on. The hyperlink's source position is a rectangle with its lower left corner at (llx, lly) and its upper right corner at (urx, ury). The rectangle has by default a thin blue border.

The note will not be visible if the document is printed or viewed but it will show up if the document is converted to pdf by either Acrobat Distiller™ or Ghostview.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

llx

The x-coordinate of the lower left corner.

lly

The y-coordinate of the lower left corner.

urx

The x-coordinate of the upper right corner.

ury

The y-coordinate of the upper right corner.

filename

The path of the program to be started, when the link is clicked on.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_add_locallink() - Adds link to a page in the same document
  • ps_add_pdflink() - Adds link to a page in a second pdf document
  • ps_add_weblink() - Adds link to a web location

ps_add_bookmark
ps_add_locallink
PS İşlevleri


Adds link to a page in the same document

ps_add_launchlink
ps_add_note
PS İşlevleri
PHP Manual

ps_add_locallink

(PECL ps >= 1.1.0)

ps_add_locallink — Adds link to a page in the same document

Açıklama

bool ps_add_locallink ( resource $psdoc , float $llx , float $lly , float $urx , float $ury , int $page , string $dest )

Places a hyperlink at the given position pointing to a page in the same document. Clicking on the link will jump to the given page. The first page in a document has number 1.

The hyperlink's source position is a rectangle with its lower left corner at (llx, lly) and its upper right corner at (urx, ury). The rectangle has by default a thin blue border.

The note will not be visible if the document is printed or viewed but it will show up if the document is converted to pdf by either Acrobat Distiller™ or Ghostview.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

llx

The x-coordinate of the lower left corner.

lly

The y-coordinate of the lower left corner.

urx

The x-coordinate of the upper right corner.

ury

The y-coordinate of the upper right corner.

page

The number of the page displayed when clicking on the link.

dest

The parameter dest determines how the document is being viewed. It can be fitpage, fitwidth, fitheight, or fitbbox.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_add_launchlink() - Adds link which launches file
  • ps_add_pdflink() - Adds link to a page in a second pdf document
  • ps_add_weblink() - Adds link to a web location

ps_add_launchlink
ps_add_note
PS İşlevleri


Adds note to current page

ps_add_locallink
ps_add_pdflink
PS İşlevleri
PHP Manual

ps_add_note

(PECL ps >= 1.1.0)

ps_add_note — Adds note to current page

Açıklama

bool ps_add_note ( resource $psdoc , float $llx , float $lly , float $urx , float $ury , string $contents , string $title , string $icon , int $open )

Adds a note at a certain position on the page. Notes are like little rectangular sheets with text on it, which can be placed anywhere on a page. They are shown either folded or unfolded. If folded, the specified icon is used as a placeholder.

The note will not be visible if the document is printed or viewed but it will show up if the document is converted to pdf by either Acrobat Distiller™ or Ghostview.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

llx

The x-coordinate of the lower left corner.

lly

The y-coordinate of the lower left corner.

urx

The x-coordinate of the upper right corner.

ury

The y-coordinate of the upper right corner.

contents

The text of the note.

title

The title of the note as displayed in the header of the note.

icon

The icon shown if the note is folded. This parameter can be set to comment, insert, note, paragraph, newparagraph, key, or help.

open

If open is unequal to zero the note will be shown unfolded after opening the document with a pdf viewer.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_add_pdflink() - Adds link to a page in a second pdf document
  • ps_add_launchlink() - Adds link which launches file
  • ps_add_locallink() - Adds link to a page in the same document
  • ps_add_weblink() - Adds link to a web location

ps_add_locallink
ps_add_pdflink
PS İşlevleri


Adds link to a page in a second pdf document

ps_add_note
ps_add_weblink
PS İşlevleri
PHP Manual

ps_add_pdflink

(PECL ps >= 1.1.0)

ps_add_pdflink — Adds link to a page in a second pdf document

Açıklama

bool ps_add_pdflink ( resource $psdoc , float $llx , float $lly , float $urx , float $ury , string $filename , int $page , string $dest )

Places a hyperlink at the given position pointing to a second pdf document. Clicking on the link will branch to the document at the given page. The first page in a document has number 1.

The hyperlink's source position is a rectangle with its lower left corner at (llx, lly) and its upper right corner at (urx, ury). The rectangle has by default a thin blue border.

The note will not be visible if the document is printed or viewed but it will show up if the document is converted to pdf by either Acrobat Distiller™ or Ghostview.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

llx

The x-coordinate of the lower left corner.

lly

The y-coordinate of the lower left corner.

urx

The x-coordinate of the upper right corner.

ury

The y-coordinate of the upper right corner.

filename

The name of the pdf document to be opened when clicking on this link.

page

The page number of the destination pdf document

dest

The parameter dest determines how the document is being viewed. It can be fitpage, fitwidth, fitheight, or fitbbox.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_add_launchlink() - Adds link which launches file
  • ps_add_locallink() - Adds link to a page in the same document
  • ps_add_weblink() - Adds link to a web location

ps_add_note
ps_add_weblink
PS İşlevleri


Adds link to a web location

ps_add_pdflink
ps_arc
PS İşlevleri
PHP Manual

ps_add_weblink

(PECL ps >= 1.1.0)

ps_add_weblink — Adds link to a web location

Açıklama

bool ps_add_weblink ( resource $psdoc , float $llx , float $lly , float $urx , float $ury , string $url )

Places a hyperlink at the given position pointing to a web page. The hyperlink's source position is a rectangle with its lower left corner at (llx, lly) and its upper right corner at (urx, ury). The rectangle has by default a thin blue border.

The note will not be visible if the document is printed or viewed but it will show up if the document is converted to pdf by either Acrobat Distiller™ or Ghostview.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

llx

The x-coordinate of the lower left corner.

lly

The y-coordinate of the lower left corner.

urx

The x-coordinate of the upper right corner.

ury

The y-coordinate of the upper right corner.

url

The url of the hyperlink to be opened when clicking on this link, e.g. http://www.php.net.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_add_launchlink() - Adds link which launches file
  • ps_add_locallink() - Adds link to a page in the same document
  • ps_add_pdflink() - Adds link to a page in a second pdf document

ps_add_pdflink
ps_arc
PS İşlevleri


Draws an arc counterclockwise

ps_add_weblink
ps_arcn
PS İşlevleri
PHP Manual

ps_arc

(PECL ps >= 1.1.0)

ps_arc — Draws an arc counterclockwise

Açıklama

bool ps_arc ( resource $psdoc , float $x , float $y , float $radius , float $alpha , float $beta )

Draws a portion of a circle with at middle point at (x, y). The arc starts at an angle of alpha and ends at an angle of beta. It is drawn counterclockwise (use ps_arcn() to draw clockwise). The subpath added to the current path starts on the arc at angle alpha and ends on the arc at angle beta.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

x

The x-coordinate of the circle's middle point.

y

The y-coordinate of the circle's middle point.

radius

The radius of the circle

alpha

The start angle given in degrees.

beta

The end angle given in degrees.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_arcn() - Draws an arc clockwise

ps_add_weblink
ps_arcn
PS İşlevleri


Draws an arc clockwise

ps_arc
ps_begin_page
PS İşlevleri
PHP Manual

ps_arcn

(PECL ps >= 1.1.0)

ps_arcn — Draws an arc clockwise

Açıklama

bool ps_arcn ( resource $psdoc , float $x , float $y , float $radius , float $alpha , float $beta )

Draws a portion of a circle with at middle point at (x, y). The arc starts at an angle of alpha and ends at an angle of beta. It is drawn clockwise (use ps_arc() to draw counterclockwise). The subpath added to the current path starts on the arc at angle beta and ends on the arc at angle alpha.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

x

The x-coordinate of the circle's middle point.

y

The y-coordinate of the circle's middle point.

radius

The radius of the circle

alpha

The starting angle given in degrees.

beta

The end angle given in degrees.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_arc() - Draws an arc counterclockwise

ps_arc
ps_begin_page
PS İşlevleri


Start a new page

ps_arcn
ps_begin_pattern
PS İşlevleri
PHP Manual

ps_begin_page

(PECL ps >= 1.1.0)

ps_begin_page — Start a new page

Açıklama

bool ps_begin_page ( resource $psdoc , float $width , float $height )

Starts a new page. Although the parameters width and height imply a different page size for each page, this is not possible in PostScript. The first call of ps_begin_page() will set the page size for the whole document. Consecutive calls will have no effect, except for creating a new page. The situation is different if you intent to convert the PostScript document into PDF. This function places pdfmarks into the document which can set the size for each page indiviually. The resulting PDF document will have different page sizes.

Though PostScript does not know different page sizes, pslib places a bounding box for each page into the document. This size is evaluated by some PostScript viewers and will have precedence over the BoundingBox in the Header of the document. This can lead to unexpected results when you set a BoundingBox whose lower left corner is not (0, 0), because the bounding box of the page will always have a lower left corner (0, 0) and overwrites the global setting.

Each page is encapsulated into save/restore. This means, that most of the settings made on one page will not be retained on the next page.

If there is up to the first call of ps_begin_page() no call of ps_findfont(), then the header of the PostScript document will be output and the bounding box will be set to the size of the first page. The lower left corner of the bounding box is set to (0, 0). If ps_findfont() was called before, then the header has been output already, and the document will not have a valid bounding box. In order to prevent this, one should call ps_set_info() to set the info field BoundingBox and possibly Orientation before any ps_findfont() or ps_begin_page() calls.

Bilginize:

Up to version 0.2.6 of pslib, this function will always overwrite the BoundingBox and Orientation, if it has been set before with ps_set_info() and ps_findfont() has not been called before.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

width

The width of the page in pixel, e.g. 596 for A4 format.

height

The height of the page in pixel, e.g. 842 for A4 format.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_end_page() - End a page
  • ps_findfont() - Loads a font
  • ps_set_info() - Sets information fields of document

ps_arcn
ps_begin_pattern
PS İşlevleri


Start a new pattern

ps_begin_page
ps_begin_template
PS İşlevleri
PHP Manual

ps_begin_pattern

(PECL ps >= 1.2.0)

ps_begin_pattern — Start a new pattern

Açıklama

int ps_begin_pattern ( resource $psdoc , float $width , float $height , float $xstep , float $ystep , int $painttype )

Starts a new pattern. A pattern is like a page containing e.g. a drawing which can be used for filling areas. It is used like a color by calling ps_setcolor() and setting the color space to pattern.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

width

The width of the pattern in pixel.

height

The height of the pattern in pixel.

x-step

The distance in pixel of placements of the pattern in horizontal direction.

y-step

The distance in pixel of placements of the pattern in vertical direction.

painttype

Must be 1 or 2.

Dönen Değerler

The identifier of the pattern başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Creating and using a pattern

<?php
$ps = ps_new();

if (!ps_open_file($ps, "pattern.ps")) {
  print "Cannot open PostScript file\n";
  exit;
}

ps_set_parameter($ps, "warning", "true");
ps_set_info($ps, "Creator", "pattern.php");
ps_set_info($ps, "Author", "Uwe Steinmann");
ps_set_info($ps, "Title", "Pattern example");

$pspattern = ps_begin_pattern($ps, 10.0, 10.0, 10.0, 10.0, 1);
ps_setlinewidth($ps, 0.2);
ps_setcolor($ps, "stroke", "rgb", 0.0, 0.0, 1.0, 0.0);
ps_moveto($ps, 0, 0);
ps_lineto($ps, 7, 7);
ps_stroke($ps);
ps_moveto($ps, 0, 7);
ps_lineto($ps, 7, 0);
ps_stroke($ps);
ps_end_pattern($ps);

ps_begin_page($ps, 596, 842);
ps_setcolor($ps, "both", "pattern", $pspattern, 0.0, 0.0, 0.0);
ps_rect($ps, 50, 400, 200, 200);
ps_fill($ps);
ps_end_page($ps);

ps_close($ps);
ps_delete($ps);
?>

Ayrıca Bakınız

  • ps_end_pattern() - End a pattern
  • ps_setcolor() - Sets current color
  • ps_shading_pattern() - Creates a pattern based on a shading

ps_begin_page
ps_begin_template
PS İşlevleri


Start a new template

ps_begin_pattern
ps_circle
PS İşlevleri
PHP Manual

ps_begin_template

(PECL ps >= 1.2.0)

ps_begin_template — Start a new template

Açıklama

int ps_begin_template ( resource $psdoc , float $width , float $height )

Starts a new template. A template is called a form in the postscript language. It is created similar to a pattern but used like an image. Templates are often used for drawings which are placed several times through out the document, e.g. like a company logo. All drawing functions may be used within a template. The template will not be drawn until it is placed by ps_place_image().

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

width

The width of the template in pixel.

height

The height of the template in pixel.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Creating and using a template

<?php
$ps = ps_new();

if (!ps_open_file($ps, "template.ps")) {
  print "Cannot open PostScript file\n";
  exit;
}

ps_set_parameter($ps, "warning", "true");
ps_set_info($ps, "Creator", "template.php");
ps_set_info($ps, "Author", "Uwe Steinmann");
ps_set_info($ps, "Title", "Template example");

$pstemplate = ps_begin_template($ps, 30.0, 30.0);
ps_moveto($ps, 0, 0);
ps_lineto($ps, 30, 30);
ps_moveto($ps, 0, 30);
ps_lineto($ps, 30, 0);
ps_stroke($ps);
ps_end_template($ps);

ps_begin_page($ps, 596, 842);
ps_place_image($ps, $pstemplate, 20.0, 20.0, 1.0);
ps_place_image($ps, $pstemplate, 50.0, 30.0, 0.5);
ps_place_image($ps, $pstemplate, 70.0, 70.0, 0.6);
ps_place_image($ps, $pstemplate, 30.0, 50.0, 1.3);
ps_end_page($ps);

ps_close($ps);
ps_delete($ps);
?>

Ayrıca Bakınız

  • ps_end_template() - End a template

ps_begin_pattern
ps_circle
PS İşlevleri


Draws a circle

ps_begin_template
ps_clip
PS İşlevleri
PHP Manual

ps_circle

(PECL ps >= 1.1.0)

ps_circle — Draws a circle

Açıklama

bool ps_circle ( resource $psdoc , float $x , float $y , float $radius )

Draws a circle with its middle point at (x, y). The circle starts and ends at position (x+radius, y). If this function is called outside a path it will start a new path. If it is called within a path it will add the circle as a subpath. If the last drawing operation does not end in point (x+radius, y) then there will be a gap in the path.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

x

The x-coordinate of the circle's middle point.

y

The y-coordinate of the circle's middle point.

radius

The radius of the circle

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_arc() - Draws an arc counterclockwise
  • ps_arcn() - Draws an arc clockwise

ps_begin_template
ps_clip
PS İşlevleri


Clips drawing to current path

ps_circle
ps_close_image
PS İşlevleri
PHP Manual

ps_clip

(PECL ps >= 1.1.0)

ps_clip — Clips drawing to current path

Açıklama

bool ps_clip ( resource $psdoc )

Takes the current path and uses it to define the border of a clipping area. Everything drawn outside of that area will not be visible.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_closepath() - Closes path

ps_circle
ps_close_image
PS İşlevleri


Closes image and frees memory

ps_clip
ps_close
PS İşlevleri
PHP Manual

ps_close_image

(PECL ps >= 1.1.0)

ps_close_image — Closes image and frees memory

Açıklama

void ps_close_image ( resource $psdoc , int $imageid )

Closes an image and frees its resources. Once an image is closed it cannot be used anymore.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

imageid

Resource identifier of the image as returned by ps_open_image() or ps_open_image_file().

Dönen Değerler

Returns NULL on success başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_open_image() - Reads an image for later placement
  • ps_open_image_file() - Opens image from file

ps_clip
ps_close
PS İşlevleri


Closes a PostScript document

ps_close_image
ps_closepath_stroke
PS İşlevleri
PHP Manual

ps_close

(PECL ps >= 1.1.0)

ps_close — Closes a PostScript document

Açıklama

bool ps_close ( resource $psdoc )

Closes the PostScript document.

This function writes the trailer of the PostScript document. It also writes the bookmark tree. ps_close() does not free any resources, which is done by ps_delete().

This function is also called by ps_delete() if it has not been called before.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_open_file() - Opens a file for output
  • ps_delete() - Deletes all resources of a PostScript document

ps_close_image
ps_closepath_stroke
PS İşlevleri


Closes and strokes path

ps_close
ps_closepath
PS İşlevleri
PHP Manual

ps_closepath_stroke

(PECL ps >= 1.1.0)

ps_closepath_stroke — Closes and strokes path

Açıklama

bool ps_closepath_stroke ( resource $psdoc )

Connects the last point with first point of a path and draws the resulting closed line.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_closepath() - Closes path

ps_close
ps_closepath
PS İşlevleri


Closes path

ps_closepath_stroke
ps_continue_text
PS İşlevleri
PHP Manual

ps_closepath

(PECL ps >= 1.1.0)

ps_closepath — Closes path

Açıklama

bool ps_closepath ( resource $psdoc )

Connects the last point with the first point of a path. The resulting path can be used for stroking, filling, clipping, etc..

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_clip() - Clips drawing to current path
  • ps_closepath_stroke() - Closes and strokes path

ps_closepath_stroke
ps_continue_text
PS İşlevleri


Continue text in next line

ps_closepath
ps_curveto
PS İşlevleri
PHP Manual

ps_continue_text

(PECL ps >= 1.1.0)

ps_continue_text — Continue text in next line

Açıklama

bool ps_continue_text ( resource $psdoc , string $text )

Output a text one line below the last line. The line spacing is taken from the value "leading" which must be set with ps_set_value(). The actual position of the text is determined by the values "textx" and "texty" which can be requested with ps_get_value()

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

text

The text to output.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_show() - Output text
  • ps_show_xy() - Output text at given position
  • ps_show_boxed() - Output text in a box

ps_closepath
ps_curveto
PS İşlevleri


Draws a curve

ps_continue_text
ps_delete
PS İşlevleri
PHP Manual

ps_curveto

(PECL ps >= 1.1.0)

ps_curveto — Draws a curve

Açıklama

bool ps_curveto ( resource $psdoc , float $x1 , float $y1 , float $x2 , float $y2 , float $x3 , float $y3 )

Add a section of a cubic Bézier curve described by the three given control points to the current path.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

x1

x-coordinate of first control point.

y1

y-coordinate of first control point.

x2

x-coordinate of second control point.

y2

y-coordinate of second control point.

x3

x-coordinate of third control point.

y3

y-coordinate of third control point.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_lineto() - Draws a line

ps_continue_text
ps_delete
PS İşlevleri


Deletes all resources of a PostScript document

ps_curveto
ps_end_page
PS İşlevleri
PHP Manual

ps_delete

(PECL ps >= 1.1.0)

ps_delete — Deletes all resources of a PostScript document

Açıklama

bool ps_delete ( resource $psdoc )

Mainly frees memory used by the document. Also closes a file, if it was not closed before with ps_close(). You should in any case close the file with ps_close() before, because ps_close() not just closes the file but also outputs a trailor containing PostScript comments like the number of pages in the document and adding the bookmark hierarchy.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_close() - Closes a PostScript document

ps_curveto
ps_end_page
PS İşlevleri


End a page

ps_delete
ps_end_pattern
PS İşlevleri
PHP Manual

ps_end_page

(PECL ps >= 1.1.0)

ps_end_page — End a page

Açıklama

bool ps_end_page ( resource $psdoc )

Ends a page which was started with ps_begin_page(). Ending a page will leave the current drawing context, which e.g. requires to reload fonts if they were loading within the page, and to set many other drawing parameters like the line width, or color..

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_begin_page() - Start a new page

ps_delete
ps_end_pattern
PS İşlevleri


End a pattern

ps_end_page
ps_end_template
PS İşlevleri
PHP Manual

ps_end_pattern

(PECL ps >= 1.2.0)

ps_end_pattern — End a pattern

Açıklama

bool ps_end_pattern ( resource $psdoc )

Ends a pattern which was started with ps_begin_pattern(). Once a pattern has been ended, it can be used like a color to fill areas.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_begin_pattern() - Start a new pattern

ps_end_page
ps_end_template
PS İşlevleri


End a template

ps_end_pattern
ps_fill_stroke
PS İşlevleri
PHP Manual

ps_end_template

(PECL ps >= 1.2.0)

ps_end_template — End a template

Açıklama

bool ps_end_template ( resource $psdoc )

Ends a template which was started with ps_begin_template(). Once a template has been ended, it can be used like an image.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_begin_template() - Start a new template

ps_end_pattern
ps_fill_stroke
PS İşlevleri


Fills and strokes the current path

ps_end_template
ps_fill
PS İşlevleri
PHP Manual

ps_fill_stroke

(PECL ps >= 1.1.0)

ps_fill_stroke — Fills and strokes the current path

Açıklama

bool ps_fill_stroke ( resource $psdoc )

Fills and draws the path constructed with previously called drawing functions like ps_lineto().

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_fill() - Fills the current path
  • ps_stroke() - Draws the current path

ps_end_template
ps_fill
PS İşlevleri


Fills the current path

ps_fill_stroke
ps_findfont
PS İşlevleri
PHP Manual

ps_fill

(PECL ps >= 1.1.0)

ps_fill — Fills the current path

Açıklama

bool ps_fill ( resource $psdoc )

Fills the path constructed with previously called drawing functions like ps_lineto().

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_fill_stroke() - Fills and strokes the current path
  • ps_stroke() - Draws the current path

ps_fill_stroke
ps_findfont
PS İşlevleri


Loads a font

ps_fill
ps_get_buffer
PS İşlevleri
PHP Manual

ps_findfont

(PECL ps >= 1.1.0)

ps_findfont — Loads a font

Açıklama

int ps_findfont ( resource $psdoc , string $fontname , string $encoding [, bool $embed = false ] )

Loads a font for later use. Before text is output with a loaded font it must be set with ps_setfont(). This function needs the adobe font metric file in order to calculate the space used up by the characters. A font which is loaded within a page will only be available on that page. Fonts which are to be used in the complete document have to be loaded before the first call of ps_begin_page(). Calling ps_findfont() between pages will make that font available for all following pages.

The name of the afm file must be fontname.afm. If the font shall be embedded the file fontname.pfb containing the font outline must be present as well.

Calling ps_findfont() before the first page requires to output the postscript header which includes the BoundingBox for the whole document. Usually the BoundingBox is set with the first call of ps_begin_page() which now comes after ps_findfont(). Consequently the BoundingBox has not been set and a warning will be issued when ps_findfont() is called. In order to prevent this situation, one should call ps_set_parameter() to set the BoundingBox before ps_findfont() is called.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

fontname

The name of the font.

encoding

ps_findfont() will try to load the file passed in the parameter encoding. Encoding files are of the same syntax as those used by dvips(1). They contain a font encoding vector (which is currently not used but must be present) and a list of extra ligatures to extend the list of ligatures derived from the afm file.

encoding can be NULL or the empty string if the default encoding (TeXBase1) shall be used.

If the encoding is set to builtin then there will be no reencoding and the font specific encoding will be used. This is very useful with symbol fonts.

embed

If set to a value >0 the font will be embedded into the document. This requires the font outline (.pfb file) to be present.

Dönen Değerler

Returns the identifier of the font or zero in case of an error. The identifier is a positive number.

Ayrıca Bakınız

  • ps_begin_page() - Start a new page
  • ps_setfont() - Sets font to use for following output

ps_fill
ps_get_buffer
PS İşlevleri


Fetches the full buffer containig the generated PS data

ps_findfont
ps_get_parameter
PS İşlevleri
PHP Manual

ps_get_buffer

(PECL ps >= 1.1.0)

ps_get_buffer — Fetches the full buffer containig the generated PS data

Açıklama

string ps_get_buffer ( resource $psdoc )

This function is not implemented yet. It will always return an empty string. The idea for a later implementation is to write the contents of the postscript file into an internal buffer if in memory creation is requested, and retrieve the buffer content with this function. Currently, documents created in memory are send to the browser without buffering.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

Ayrıca Bakınız

  • ps_open_file() - Opens a file for output

ps_findfont
ps_get_parameter
PS İşlevleri


Gets certain parameters

ps_get_buffer
ps_get_value
PS İşlevleri
PHP Manual

ps_get_parameter

(PECL ps >= 1.1.0)

ps_get_parameter — Gets certain parameters

Açıklama

string ps_get_parameter ( resource $psdoc , string $name [, float $modifier ] )

Gets several parameters which were directly set by ps_set_parameter() or indirectly by one of the other functions. Parameters are by definition string values. This function cannot be used to retrieve resources which were also set by ps_set_parameter().

The parameter name can have the following values.

fontname

The name of the currently active font or the font whose identifier is passed in parameter modifier.

fontencoding

The encoding of the currently active font.

dottedversion

The version of the underlying pslib library in the format <major>.<minor>.<subminor>

scope

The current drawing scope. Can be object, document, null, page, pattern, path, template, prolog, font, glyph.

ligaturedisolvechar

The character which dissolves a ligature. If your are using a font which contains the ligature `ff' and `|' is the char to dissolve the ligature, then `f|f' will result in two `f' instead of the ligature `ff'.

imageencoding

The encoding used for encoding images. Can be either hex or 85. hex encoding uses two bytes in the postscript file each byte in the image. 85 stand for Ascii85 encoding.

linenumbermode

Set to paragraph if lines are numbered within a paragraph or box if they are numbered within the surrounding box.

linebreak

Only used if text is output with ps_show_boxed(). If set to TRUE a carriage return will add a line break.

parbreak

Only used if text is output with ps_show_boxed(). If set to TRUE a carriage return will start a new paragraph.

hyphenation

Only used if text is output with ps_show_boxed(). If set to TRUE the paragraph will be hyphenated if a hypen dictionary is set and exists.

hyphendict

Filename of the dictionary used for hyphenation pattern.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

name

Name of the parameter.

modifier

An identifier needed if a parameter of a resource is requested, e.g. the size of an image. In such a case the resource id is passed.

Dönen Değerler

Returns the value of the parameter başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_set_parameter() - Sets certain parameters

ps_get_buffer
ps_get_value
PS İşlevleri


Gets certain values

ps_get_parameter
ps_hyphenate
PS İşlevleri
PHP Manual

ps_get_value

(PECL ps >= 1.1.0)

ps_get_value — Gets certain values

Açıklama

float ps_get_value ( resource $psdoc , string $name [, float $modifier ] )

Gets several values which were set by ps_set_value(). Values are by definition float values.

The parameter name can have the following values.

fontsize

The size of the currently active font or the font whose identifier is passed in parameter modifier.

font

The currently active font itself.

imagewidth

The width of the image whose id is passed in the parameter modifier.

imageheight

The height of the image whose id is passed in the parameter modifier.

capheight

The height of a capital M in the currently active font or the font whose identifier is passed in parameter modifier.

ascender

The ascender of the currently active font or the font whose identifier is passed in parameter modifier.

descender

The descender of the currently active font or the font whose identifier is passed in parameter modifier.

italicangle

The italicangle of the currently active font or the font whose identifier is passed in parameter modifier.

underlineposition

The underlineposition of the currently active font or the font whose identifier is passed in parameter modifier.

underlinethickness

The underlinethickness of the currently active font or the font whose identifier is passed in parameter modifier.

textx

The current x-position for text output.

texty

The current y-position for text output.

textrendering

The current mode for text rendering.

textrise

The space by which text is risen above the base line.

leading

The distance between text lines in points.

wordspacing

The space between words as a multiple of the width of a space char.

charspacing

The space between chars. If charspacing is != 0.0 ligatures will always be dissolved.

hyphenminchars

Minimum number of chars hyphenated at the end of a word.

parindent

Indention of the first n line in a paragraph.

numindentlines

Number of line in a paragraph to indent if parindent != 0.0.

parskip

Distance between paragraphs.

linenumberspace

Overall space in front of each line for the line number.

linenumbersep

Space between the line and the line number.

major

The major version number of pslib.

minor

The minor version number of pslib.

subminor, revision

The subminor version number of pslib.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

name

Name of the value.

modifier

The parameter modifier specifies the resource for which the value is to be retrieved. This can be the id of a font or an image.

Dönen Değerler

Returns the value of the parameter or FALSE.

Ayrıca Bakınız

  • ps_set_value() - Sets certain values

ps_get_parameter
ps_hyphenate
PS İşlevleri


Hyphenates a word

ps_get_value
ps_include_file
PS İşlevleri
PHP Manual

ps_hyphenate

(PECL ps >= 1.1.1)

ps_hyphenate — Hyphenates a word

Açıklama

array ps_hyphenate ( resource $psdoc , string $text )

Hyphenates the passed word. ps_hyphenate() evaluates the value hyphenminchars (set by ps_set_value()) and the parameter hyphendict (set by ps_set_parameter()). hyphendict must be set before calling this function.

This function requires the locale category LC_CTYPE to be set properly. This is done when the extension is initialized by using the environment variables. On Unix systems read the man page of locale for more information.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

text

text should not contain any non alpha characters. Possible positions for breaks are returned in an array of interger numbers. Each number is the position of the char in text after which a hyphenation can take place.

Dönen Değerler

An array of integers indicating the position of possible breaks in the text başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Hyphennate a text

<?php
$word = "Koordinatensystem";
$psdoc = ps_new();
ps_set_parameter($psdoc, "hyphendict", "hyph_de.dic");
$hyphens = ps_hyphenate($psdoc, $word);
for($i=0; $i<strlen($word); $i++) {
  echo $word[$i];
  if(in_array($i, $hyphens))
    echo "-";
}
ps_delete($psdoc);
?>

Yukarıdaki örneğin çıktısı:

Ko-ordi-na-ten-sys-tem

Ayrıca Bakınız

  • ps_show_boxed() - Output text in a box
  • locale(1)

ps_get_value
ps_include_file
PS İşlevleri


Reads an external file with raw PostScript code

ps_hyphenate
ps_lineto
PS İşlevleri
PHP Manual

ps_include_file

(PECL ps >= 1.3.4)

ps_include_file — Reads an external file with raw PostScript code

Açıklama

bool ps_include_file ( resource $psdoc , string $file )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

file

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

ps_hyphenate
ps_lineto
PS İşlevleri


Draws a line

ps_include_file
ps_makespotcolor
PS İşlevleri
PHP Manual

ps_lineto

(PECL ps >= 1.1.0)

ps_lineto — Draws a line

Açıklama

bool ps_lineto ( resource $psdoc , float $x , float $y )

Adds a straight line from the current point to the given coordinates to the current path. Use ps_moveto() to set the starting point of the line.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

x

x-coordinate of the end point of the line.

y

y-coordinate of the end point of the line.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Drawing a rectangle

<?php
$ps = ps_new();
if (!ps_open_file($ps, "rectangle.ps")) {
  print "Cannot open PostScript file\n";
  exit;
}

ps_set_info($ps, "Creator", "rectangle.php");
ps_set_info($ps, "Author", "Uwe Steinmann");
ps_set_info($ps, "Title", "Lineto example");

ps_begin_page($ps, 596, 842);
ps_moveto($ps, 100, 100);
ps_lineto($ps, 100, 200);
ps_lineto($ps, 200, 200);
ps_lineto($ps, 200, 100);
ps_lineto($ps, 100, 100);
ps_stroke($ps);
ps_end_page($ps);

ps_delete($ps);
?>

Ayrıca Bakınız

  • ps_moveto() - Sets current point

ps_include_file
ps_makespotcolor
PS İşlevleri


Create spot color

ps_lineto
ps_moveto
PS İşlevleri
PHP Manual

ps_makespotcolor

(PECL ps >= 1.1.0)

ps_makespotcolor — Create spot color

Açıklama

int ps_makespotcolor ( resource $psdoc , string $name [, int $reserved = 0 ] )

Creates a spot color from the current fill color. The fill color must be defined in rgb, cmyk or gray colorspace. The spot color name can be an arbitrary name. A spot color can be set as any color with ps_setcolor(). When the document is not printed but displayed by an postscript viewer the given color in the specified color space is use.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

name

Name of the spot color, e.g. Pantone 5565.

Dönen Değerler

The id of the new spot color or 0 in case of an error.

Örnekler

Örnek 1 Creating and using a spot color

<?php
$ps = ps_new();
if (!ps_open_file($ps, "spotcolor.ps")) {
  print "Cannot open PostScript file\n";
  exit;
}

ps_set_info($ps, "Creator", "spotcolor.php");
ps_set_info($ps, "Author", "Uwe Steinmann");
ps_set_info($ps, "Title", "Spot color example");

ps_begin_page($ps, 596, 842);
ps_setcolor($ps, "fill", "cmyk", 0.37, 0.0, 0.34, 0.34);
$spotcolor = ps_makespotcolor($ps, "PANTONE 5565 C", 0);
ps_setcolor($ps, "fill", "spot", $spotcolor, 0.5, 0.0, 0.0);
ps_moveto($ps, 100, 100);
ps_lineto($ps, 100, 200);
ps_lineto($ps, 200, 200);
ps_lineto($ps, 200, 100);
ps_lineto($ps, 100, 100);
ps_fill($ps);
ps_end_page($ps);

ps_delete($ps);
?>

This example creates the spot color "PANTONE 5565 C" which is a darker green (olive) and fills a rectangle with 50% intensity.

Ayrıca Bakınız

  • ps_setcolor() - Sets current color

ps_lineto
ps_moveto
PS İşlevleri


Sets current point

ps_makespotcolor
ps_new
PS İşlevleri
PHP Manual

ps_moveto

(PECL ps >= 1.1.0)

ps_moveto — Sets current point

Açıklama

bool ps_moveto ( resource $psdoc , float $x , float $y )

Sets the current point to new coordinates. If this is the first call of ps_moveto() after a previous path has been ended then it will start a new path. If this function is called in the middle of a path it will just set the current point and start a subpath.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

x

x-coordinate of the point to move to.

y

y-coordinate of the point to move to.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_lineto() - Draws a line

ps_makespotcolor
ps_new
PS İşlevleri


Creates a new PostScript document object

ps_moveto
ps_open_file
PS İşlevleri
PHP Manual

ps_new

(PECL ps >= 1.1.0)

ps_new — Creates a new PostScript document object

Açıklama

resource ps_new ( void )

Creates a new document instance. It does not create the file on disk or in memory, it just sets up everything. ps_new() is usually followed by a call of ps_open_file() to actually create the postscript document.

Dönen Değerler

Resource of PostScript document başarısızlık durumunda FALSE döner. The return value is passed to all other functions as the first argument.

Ayrıca Bakınız

  • ps_delete() - Deletes all resources of a PostScript document

ps_moveto
ps_open_file
PS İşlevleri


Opens a file for output

ps_new
ps_open_image_file
PS İşlevleri
PHP Manual

ps_open_file

(PECL ps >= 1.1.0)

ps_open_file — Opens a file for output

Açıklama

bool ps_open_file ( resource $psdoc [, string $filename ] )

Creates a new file on disk and writes the PostScript document into it. The file will be closed when ps_close() is called.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

filename

The name of the postscript file. If filename is not passed the document will be created in memory and all output will go straight to the browser.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_close() - Closes a PostScript document

ps_new
ps_open_image_file
PS İşlevleri


Opens image from file

ps_open_file
ps_open_image
PS İşlevleri
PHP Manual

ps_open_image_file

(PECL ps >= 1.1.0)

ps_open_image_file — Opens image from file

Açıklama

int ps_open_image_file ( resource $psdoc , string $type , string $filename [, string $stringparam [, int $intparam = 0 ]] )

Loads an image for later use.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

type

The type of the image. Possible values are png, jpeg, or eps.

filename

The name of the file containing the image data.

stringparam

Not used.

intparam

Not used.

Dönen Değerler

Returns identifier of image or zero in case of an error. The identifier is a positive number greater than 0.

Ayrıca Bakınız

  • ps_open_image() - Reads an image for later placement
  • ps_place_image() - Places image on the page
  • ps_close_image() - Closes image and frees memory

ps_open_file
ps_open_image
PS İşlevleri


Reads an image for later placement

ps_open_image_file
ps_open_memory_image
PS İşlevleri
PHP Manual

ps_open_image

(PECL ps >= 1.1.0)

ps_open_image — Reads an image for later placement

Açıklama

int ps_open_image ( resource $psdoc , string $type , string $source , string $data , int $lenght , int $width , int $height , int $components , int $bpc , string $params )

Reads an image which is already available in memory. The parameter source is currently not evaluated and assumed to be memory. The image data is a sequence of pixels starting in th upper left corner and ending in the lower right corner. Each pixel consists of components color components, and each component has bpc bits.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

type

The type of the image. Possible values are png, jpeg, or eps.

source

Not used.

data

The image data.

length

The length of the image data.

width

The width of the image.

height

The height of the image.

components

The number of components for each pixel. This can be 1 (gray scale images), 3 (rgb images), or 4 (cmyk, rgba images).

bpc

Number of bits per component (quite often 8).

params

Dönen Değerler

Returns identifier of image or zero in case of an error. The identifier is a positive number greater than 0.

Ayrıca Bakınız

  • ps_open_image_file() - Opens image from file
  • ps_place_image() - Places image on the page
  • ps_close_image() - Closes image and frees memory

ps_open_image_file
ps_open_memory_image
PS İşlevleri


Takes an GD image and returns an image for placement in a PS document

ps_open_image
ps_place_image
PS İşlevleri
PHP Manual

ps_open_memory_image

(PECL ps >= 1.1.0)

ps_open_memory_image — Takes an GD image and returns an image for placement in a PS document

Açıklama

int ps_open_memory_image ( resource $psdoc , int $gd )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

gd

ps_open_image
ps_place_image
PS İşlevleri


Places image on the page

ps_open_memory_image
ps_rect
PS İşlevleri
PHP Manual

ps_place_image

(PECL ps >= 1.1.0)

ps_place_image — Places image on the page

Açıklama

bool ps_place_image ( resource $psdoc , int $imageid , float $x , float $y , float $scale )

Places a formerly loaded image on the page. The image can be scaled. If the image shall be rotated as well, you will have to rotate the coordinate system before with ps_rotate().

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

imageid

The resource identifier of the image as returned by ps_open_image() or ps_open_image_file().

x

x-coordinate of the lower left corner of the image.

y

y-coordinate of the lower left corner of the image.

scale

The scaling factor for the image. A scale of 1.0 will result in a resolution of 72 dpi, because each pixel is equivalent to 1 point.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_open_image() - Reads an image for later placement
  • ps_open_image_file() - Opens image from file

ps_open_memory_image
ps_rect
PS İşlevleri


Draws a rectangle

ps_place_image
ps_restore
PS İşlevleri
PHP Manual

ps_rect

(PECL ps >= 1.1.0)

ps_rect — Draws a rectangle

Açıklama

bool ps_rect ( resource $psdoc , float $x , float $y , float $width , float $height )

Draws a rectangle with its lower left corner at (x, y). The rectangle starts and ends in its lower left corner. If this function is called outside a path it will start a new path. If it is called within a path it will add the rectangle as a subpath. If the last drawing operation does not end in the lower left corner then there will be a gap in the path.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

x

x-coordinate of the lower left corner of the rectangle.

y

y-coordinate of the lower left corner of the rectangle.

width

The width of the image.

height

The height of the image.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_arc() - Draws an arc counterclockwise
  • ps_cirle()
  • ps_lineto() - Draws a line

ps_place_image
ps_restore
PS İşlevleri


Restore previously save context

ps_rect
ps_rotate
PS İşlevleri
PHP Manual

ps_restore

(PECL ps >= 1.1.0)

ps_restore — Restore previously save context

Açıklama

bool ps_restore ( resource $psdoc )

Restores a previously saved graphics context. Any call of ps_save() must be accompanied by a call to ps_restore(). All coordinate transformations, line style settings, color settings, etc. are being restored to the state before the call of ps_save().

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_save() - Save current context

ps_rect
ps_rotate
PS İşlevleri


Sets rotation factor

ps_restore
ps_save
PS İşlevleri
PHP Manual

ps_rotate

(PECL ps >= 1.1.0)

ps_rotate — Sets rotation factor

Açıklama

bool ps_rotate ( resource $psdoc , float $rot )

Sets the rotation of the coordinate system.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

rot

Angle of rotation in degree.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Rotation of the coordinate system

<?php
function rectangle($ps) {
    ps_moveto($ps, 0, 0);
    ps_lineto($ps, 0, 50);
    ps_lineto($ps, 50, 50);
    ps_lineto($ps, 50, 0);
    ps_lineto($ps, 0, 0);
    ps_stroke($ps);
}

$ps = ps_new();
if (!ps_open_file($ps, "rotation.ps")) {
  print "Cannot open PostScript file\n";
  exit;
}

ps_set_info($ps, "Creator", "rotation.php");
ps_set_info($ps, "Author", "Uwe Steinmann");
ps_set_info($ps, "Title", "Rotation example");
ps_set_info($ps, "BoundingBox", "0 0 596 842");

$psfont = ps_findfont($ps, "Helvetica", "", 0);

ps_begin_page($ps, 596, 842);
ps_set_text_pos($ps, 100, 100);
ps_save($ps);
ps_translate($ps, 100, 100);
ps_rotate($ps, 45);
rectangle($ps);
ps_restore($ps);
ps_setfont($ps, $psfont, 8.0);
ps_show($ps, "Text without rotation");
ps_end_page($ps);

ps_delete($ps);
?>

The above example illustrates a very common way of rotating a graphic (in this case just a rectangle) by simply rotating the coordinate system. Since the graphic's coordinate system assumes (0,0) to be the origin, the page coordinate system is also translated to place the graphics not on the edge of the page. Pay attention to the order of ps_translate() and ps_rotate(). In the above case the rectancle is rotated around the point (100, 100) in the untranslated coordinate system. Switching the two statements has a completely different result.

In order to output the following text at the original position, all modifications of the coordinate system are encapsulated in ps_save() and ps_restore().

Ayrıca Bakınız

  • ps_scale() - Sets scaling factor
  • ps_translate() - Sets translation

ps_restore
ps_save
PS İşlevleri


Save current context

ps_rotate
ps_scale
PS İşlevleri
PHP Manual

ps_save

(PECL ps >= 1.1.0)

ps_save — Save current context

Açıklama

bool ps_save ( resource $psdoc )

Saves the current graphics context, containing colors, translation and rotation settings and some more. A saved context can be restored with ps_restore().

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_restore() - Restore previously save context

ps_rotate
ps_scale
PS İşlevleri


Sets scaling factor

ps_save
ps_set_border_color
PS İşlevleri
PHP Manual

ps_scale

(PECL ps >= 1.1.0)

ps_scale — Sets scaling factor

Açıklama

bool ps_scale ( resource $psdoc , float $x , float $y )

Sets horizontal and vertical scaling of the coordinate system.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

x

Scaling factor in horizontal direction.

y

Scaling factor in vertical direction.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_rotate() - Sets rotation factor
  • ps_translate() - Sets translation

ps_save
ps_set_border_color
PS İşlevleri


Sets color of border for annotations

ps_scale
ps_set_border_dash
PS İşlevleri
PHP Manual

ps_set_border_color

(PECL ps >= 1.1.0)

ps_set_border_color — Sets color of border for annotations

Açıklama

bool ps_set_border_color ( resource $psdoc , float $red , float $green , float $blue )

Links added with one of the functions ps_add_weblink(), ps_add_pdflink(), etc. will be displayed with a surounded rectangle when the postscript document is converted to pdf and viewed in a pdf viewer. This rectangle is not visible in the postscript document. This function sets the color of the rectangle's border line.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

red

The red component of the border color.

green

The green component of the border color.

blue

The blue component of the border color.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_set_border_dash() - Sets length of dashes for border of annotations
  • ps_set_border_style() - Sets border style of annotations

ps_scale
ps_set_border_dash
PS İşlevleri


Sets length of dashes for border of annotations

ps_set_border_color
ps_set_border_style
PS İşlevleri
PHP Manual

ps_set_border_dash

(PECL ps >= 1.1.0)

ps_set_border_dash — Sets length of dashes for border of annotations

Açıklama

bool ps_set_border_dash ( resource $psdoc , float $black , float $white )

Links added with one of the functions ps_add_weblink(), ps_add_pdflink(), etc. will be displayed with a surounded rectangle when the postscript document is converted to pdf and viewed in a pdf viewer. This rectangle is not visible in the postscript document. This function sets the length of the black and white portion of a dashed border line.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

black

The length of the dash.

white

The length of the gap between dashes.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_set_border_color() - Sets color of border for annotations
  • ps_set_border_style() - Sets border style of annotations

ps_set_border_color
ps_set_border_style
PS İşlevleri


Sets border style of annotations

ps_set_border_dash
ps_set_info
PS İşlevleri
PHP Manual

ps_set_border_style

(PECL ps >= 1.1.0)

ps_set_border_style — Sets border style of annotations

Açıklama

bool ps_set_border_style ( resource $psdoc , string $style , float $width )

Links added with one of the functions ps_add_weblink(), ps_add_pdflink(), etc. will be displayed with a surounded rectangle when the postscript document is converted to pdf and viewed in a pdf viewer. This rectangle is not visible in the postscript document. This function sets the appearance and width of the border line.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

style

style can be solid or dashed.

width

The line width of the border.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_set_border_color() - Sets color of border for annotations
  • ps_set_border_dash() - Sets length of dashes for border of annotations

ps_set_border_dash
ps_set_info
PS İşlevleri


Sets information fields of document

ps_set_border_style
ps_set_parameter
PS İşlevleri
PHP Manual

ps_set_info

(PECL ps >= 1.1.0)

ps_set_info — Sets information fields of document

Açıklama

bool ps_set_info ( resource $p , string $key , string $val )

Sets certain information fields of the document. This fields will be shown as a comment in the header of the PostScript file. If the document is converted to pdf this fields will also be used for the document information.

The BoundingBox is usually set to the value given to the first page. This only works if ps_findfont() has not been called before. In such cases the BoundingBox would be left unset unless you set it explicitly with this function.

This function will have no effect anymore when the header of the postscript file has been already written. It must be called before the first page or the first call of ps_findfont().

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

key

The name of the information field to set. The values which can be set are Keywords, Subject, Title, Creator, Author, BoundingBox, and Orientation. Be aware that some of them has a meaning to PostScript viewers.

value

The value of the information field. The field Orientation can be set to either Portrait or Landscape. The BoundingBox is a string consisting of four numbers. The first two numbers are the coordinates of the lower left corner of the page. The last two numbers are the coordinates of the upper right corner.

Bilginize:

Up to version 0.2.6 of pslib, the BoundingBox and Orientation will be overwritten by ps_begin_page(), unless ps_findfont() has been called before.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_findfont() - Loads a font
  • ps_begin_page() - Start a new page

ps_set_border_style
ps_set_parameter
PS İşlevleri


Sets certain parameters

ps_set_info
ps_set_text_pos
PS İşlevleri
PHP Manual

ps_set_parameter

(PECL ps >= 1.1.0)

ps_set_parameter — Sets certain parameters

Açıklama

bool ps_set_parameter ( resource $psdoc , string $name , string $value )

Sets several parameters which are used by many functions. Parameters are by definition string values.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

name

For a list of possible names see ps_get_parameter().

value

The value of the parameter.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_get_parameters()
  • ps_set_value() - Sets certain values

ps_set_info
ps_set_text_pos
PS İşlevleri


Sets position for text output

ps_set_parameter
ps_set_value
PS İşlevleri
PHP Manual

ps_set_text_pos

(PECL ps >= 1.1.0)

ps_set_text_pos — Sets position for text output

Açıklama

bool ps_set_text_pos ( resource $psdoc , float $x , float $y )

Set the position for the next text output. You may alternatively set the x and y value separately by calling ps_set_value() and choosing textx respectively texty as the value name.

If you want to output text at a certain position it is more convenient to use ps_show_xy() instead of setting the text position and calling ps_show().

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

x

x-coordinate of the new text position.

y

y-coordinate of the new text position.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Placing text at a given position

<?php
$ps = ps_new();
if (!ps_open_file($ps, "text.ps")) {
  print "Cannot open PostScript file\n";
  exit;
}

ps_set_info($ps, "Creator", "rectangle.php");
ps_set_info($ps, "Author", "Uwe Steinmann");
ps_set_info($ps, "Title", "Text placement example");

ps_begin_page($ps, 596, 842);
$psfont = ps_findfont($ps, "Helvetica", "", 0);
ps_setfont($ps, $psfont, 8.0);
ps_show_xy($ps, "Some text at (100, 100)", 100, 100);

ps_set_value($ps, "textx", 100);
ps_set_value($ps, "texty", 120);
ps_show($ps, "Some text at (100, 120)");
ps_end_page($ps);

ps_delete($ps);
?>

Ayrıca Bakınız

  • ps_set_value() - Sets certain values
  • ps_show() - Output text

ps_set_parameter
ps_set_value
PS İşlevleri


Sets certain values

ps_set_text_pos
ps_setcolor
PS İşlevleri
PHP Manual

ps_set_value

(PECL ps >= 1.1.0)

ps_set_value — Sets certain values

Açıklama

bool ps_set_value ( resource $psdoc , string $name , float $value )

Sets several values which are used by many functions. Parameters are by definition float values.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

name

The name can be one of the following:

textrendering

The way how text is shown.

textx

The x coordinate for text output.

texty

The y coordinate for text output.

wordspacing

The distance between words relative to the width of a space.

leading

The distance between lines in pixels.

value

The value of the parameter.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_get_value() - Gets certain values
  • ps_set_parameter() - Sets certain parameters

ps_set_text_pos
ps_setcolor
PS İşlevleri


Sets current color

ps_set_value
ps_setdash
PS İşlevleri
PHP Manual

ps_setcolor

(PECL ps >= 1.1.0)

ps_setcolor — Sets current color

Açıklama

bool ps_setcolor ( resource $psdoc , string $type , string $colorspace , float $c1 , float $c2 , float $c3 , float $c4 )

Sets the color for drawing, filling, or both.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

type

The parameter type can be both, fill, or fillstroke.

colorspace

The colorspace should be one of gray, rgb, cmyk, spot, pattern. Depending on the colorspace either only the first, the first three or all parameters will be used.

c1

Depending on the colorspace this is either the red component (rgb), the cyan component (cmyk), the gray value (gray), the identifier of the spot color or the identifier of the pattern.

c2

Depending on the colorspace this is either the green component (rgb), the magenta component (cmyk).

c3

Depending on the colorspace this is either the blue component (rgb), the yellow component (cmyk).

c4

This must only be set in cmyk colorspace and specifies the black component.

Bugs

The second parameter is currently not always evaluated. The color is sometimes set for filling and drawing just as if fillstroke were passed.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

ps_set_value
ps_setdash
PS İşlevleri


Sets appearance of a dashed line

ps_setcolor
ps_setflat
PS İşlevleri
PHP Manual

ps_setdash

(PECL ps >= 1.1.0)

ps_setdash — Sets appearance of a dashed line

Açıklama

bool ps_setdash ( resource $psdoc , float $on , float $off )

Sets the length of the black and white portions of a dashed line.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

on

The length of the dash.

off

The length of the gap between dashes.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_setpolydash() - Sets appearance of a dashed line

ps_setcolor
ps_setflat
PS İşlevleri


Sets flatness

ps_setdash
ps_setfont
PS İşlevleri
PHP Manual

ps_setflat

(PECL ps >= 1.1.0)

ps_setflat — Sets flatness

Açıklama

bool ps_setflat ( resource $psdoc , float $value )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

value

The value must be between 0.2 and 1.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

ps_setdash
ps_setfont
PS İşlevleri


Sets font to use for following output

ps_setflat
ps_setgray
PS İşlevleri
PHP Manual

ps_setfont

(PECL ps >= 1.1.0)

ps_setfont — Sets font to use for following output

Açıklama

bool ps_setfont ( resource $psdoc , int $fontid , float $size )

Sets a font, which has to be loaded before with ps_findfont(). Outputting text without setting a font results in an error.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

fontid

The font identifier as returned by ps_findfont().

size

The size of the font.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_findfont() - Loads a font
  • ps_set_text_pos() - Sets position for text output for an example.

ps_setflat
ps_setgray
PS İşlevleri


Sets gray value

ps_setfont
ps_setlinecap
PS İşlevleri
PHP Manual

ps_setgray

(PECL ps >= 1.1.0)

ps_setgray — Sets gray value

Açıklama

bool ps_setgray ( resource $psdoc , float $gray )

Sets the gray value for all following drawing operations.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

gray

The value must be between 0 (white) and 1 (black).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_setcolor() - Sets current color

ps_setfont
ps_setlinecap
PS İşlevleri


Sets appearance of line ends

ps_setgray
ps_setlinejoin
PS İşlevleri
PHP Manual

ps_setlinecap

(PECL ps >= 1.1.0)

ps_setlinecap — Sets appearance of line ends

Açıklama

bool ps_setlinecap ( resource $psdoc , int $type )

Sets how line ends look like.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

type

The type of line ends. Possible values are PS_LINECAP_BUTT, PS_LINECAP_ROUND, or PS_LINECAP_SQUARED.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_setlinejoin() - Sets how contected lines are joined
  • ps_setlinewidth() - Sets width of a line
  • ps_setmiterlimit() - Sets the miter limit

ps_setgray
ps_setlinejoin
PS İşlevleri


Sets how contected lines are joined

ps_setlinecap
ps_setlinewidth
PS İşlevleri
PHP Manual

ps_setlinejoin

(PECL ps >= 1.1.0)

ps_setlinejoin — Sets how contected lines are joined

Açıklama

bool ps_setlinejoin ( resource $psdoc , int $type )

Sets how lines are joined.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

type

The way lines are joined. Possible values are PS_LINEJOIN_MITER, PS_LINEJOIN_ROUND, or PS_LINEJOIN_BEVEL.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_setlinecap() - Sets appearance of line ends
  • ps_setlinewidth() - Sets width of a line
  • ps_setmiterlimit() - Sets the miter limit

ps_setlinecap
ps_setlinewidth
PS İşlevleri


Sets width of a line

ps_setlinejoin
ps_setmiterlimit
PS İşlevleri
PHP Manual

ps_setlinewidth

(PECL ps >= 1.1.0)

ps_setlinewidth — Sets width of a line

Açıklama

bool ps_setlinewidth ( resource $psdoc , float $width )

Sets the line width for all following drawing operations.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

width

The width of lines in points.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_setlinecap() - Sets appearance of line ends
  • ps_setlinejoin() - Sets how contected lines are joined
  • ps_setmiterlimit() - Sets the miter limit

ps_setlinejoin
ps_setmiterlimit
PS İşlevleri


Sets the miter limit

ps_setlinewidth
ps_setoverprintmode
PS İşlevleri
PHP Manual

ps_setmiterlimit

(PECL ps >= 1.1.0)

ps_setmiterlimit — Sets the miter limit

Açıklama

bool ps_setmiterlimit ( resource $psdoc , float $value )

If two lines join in a small angle and the line join is set to PS_LINEJOIN_MITER, then the resulting spike will be very long. The miter limit is the maximum ratio of the miter length (the length of the spike) and the line width.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

value

The maximum ratio between the miter length and the line width. Larger values (> 10) will result in very long spikes when two lines meet in a small angle. Keep the default unless you know what you are doing.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_setlinecap() - Sets appearance of line ends
  • ps_setlinejoin() - Sets how contected lines are joined
  • ps_setlinewidth() - Sets width of a line

ps_setlinewidth
ps_setoverprintmode
PS İşlevleri


Sets overprint mode

ps_setmiterlimit
ps_setpolydash
PS İşlevleri
PHP Manual

ps_setoverprintmode

(PECL ps >= 1.3.0)

ps_setoverprintmode — Sets overprint mode

Açıklama

bool ps_setoverprintmode ( resource $psdoc , int $mode )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

mode

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

ps_setmiterlimit
ps_setpolydash
PS İşlevleri


Sets appearance of a dashed line

ps_setoverprintmode
ps_shading_pattern
PS İşlevleri
PHP Manual

ps_setpolydash

(PECL ps >= 1.1.0)

ps_setpolydash — Sets appearance of a dashed line

Açıklama

bool ps_setpolydash ( resource $psdoc , float $arr )

Sets the length of the black and white portions of a dashed line. ps_setpolydash() is used to set more complicated dash patterns.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

arr

arr is a list of length elements alternately for the black and white portion.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Drawing a dashed line

<?php
$ps = ps_new();
if (!ps_open_file($ps, "polydash.ps")) {
   print "Cannot open PostScript file\n";
     exit;
}

ps_set_info($ps, "Creator", "polydash.php");
ps_set_info($ps, "Author", "Uwe Steinmann");
ps_set_info($ps, "Title", "Poly dash example");

ps_begin_page($ps, 596, 842);
ps_setpolydash($ps, array(10, 5, 2, 5));
ps_moveto($ps, 100, 100);
ps_lineto($ps, 200, 200);
ps_stroke($ps);
ps_end_page($ps);

ps_delete($ps);
?>

This example draws a line with a 10 and 2 points long line, and gaps of 5 points inbetween.

Ayrıca Bakınız

  • ps_setdash() - Sets appearance of a dashed line

ps_setoverprintmode
ps_shading_pattern
PS İşlevleri


Creates a pattern based on a shading

ps_setpolydash
ps_shading
PS İşlevleri
PHP Manual

ps_shading_pattern

(PECL ps >= 1.3.0)

ps_shading_pattern — Creates a pattern based on a shading

Açıklama

int ps_shading_pattern ( resource $psdoc , int $shadingid , string $optlist )

Creates a pattern based on a shading, which has to be created before with ps_shading(). Shading patterns can be used like regular patterns.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

shadingid

The identifier of a shading previously created with ps_shading().

optlist

This argument is not currently used.

Dönen Değerler

The identifier of the pattern başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_shading() - Creates a shading for later use
  • ps_shfill() - Fills an area with a shading

ps_setpolydash
ps_shading
PS İşlevleri


Creates a shading for later use

ps_shading_pattern
ps_shfill
PS İşlevleri
PHP Manual

ps_shading

(PECL ps >= 1.3.0)

ps_shading — Creates a shading for later use

Açıklama

int ps_shading ( resource $psdoc , string $type , float $x0 , float $y0 , float $x1 , float $y1 , float $c1 , float $c2 , float $c3 , float $c4 , string $optlist )

Creates a shading, which can be used by ps_shfill() or ps_shading_pattern().

The color of the shading can be in any color space except for pattern.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

type

The type of shading can be either radial or axial. Each shading starts with the current fill color and ends with the given color values passed in the parameters c1 to c4 (see ps_setcolor() for their meaning).

x0, x1, y0, y1

The coordinates x0, y0, x1, y1 are the start and end point of the shading. If the type of shading is radial the two points are the middle points of a starting and ending circle.

c1, c2, c3, c4

See ps_setcolor() for their meaning.

optlist

If the shading is of type radial the optlist must also contain the parameters r0 and r1 with the radius of the start and end circle.

Dönen Değerler

Returns the identifier of the pattern başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_shading_pattern() - Creates a pattern based on a shading
  • ps_shfill() - Fills an area with a shading

ps_shading_pattern
ps_shfill
PS İşlevleri


Fills an area with a shading

ps_shading
ps_show_boxed
PS İşlevleri
PHP Manual

ps_shfill

(PECL ps >= 1.3.0)

ps_shfill — Fills an area with a shading

Açıklama

bool ps_shfill ( resource $psdoc , int $shadingid )

Fills an area with a shading, which has to be created before with ps_shading(). This is an alternative way to creating a pattern from a shading ps_shading_pattern() and using the pattern as the filling color.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

shadingid

The identifier of a shading previously created with ps_shading().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_shading() - Creates a shading for later use
  • ps_shading_pattern() - Creates a pattern based on a shading

ps_shading
ps_show_boxed
PS İşlevleri


Output text in a box

ps_shfill
ps_show_xy2
PS İşlevleri
PHP Manual

ps_show_boxed

(PECL ps >= 1.1.0)

ps_show_boxed — Output text in a box

Açıklama

int ps_show_boxed ( resource $psdoc , string $text , float $left , float $bottom , float $width , float $height , string $hmode [, string $feature ] )

Outputs a text in a given box. The lower left corner of the box is at (left, bottom). Line breaks will be inserted where needed. Multiple spaces are treated as one. Tabulators are treated as spaces.

The text will be hyphenated if the parameter hyphenation is set to TRUE and the parameter hyphendict contains a valid filename for a hyphenation file. The line spacing is taken from the value leading. Paragraphs can be separated by an empty line just like in TeX. If the value parindent is set to value > 0.0 then the first n lines will be indented. The number n of lines is set by the parameter numindentlines. In order to prevent indenting of the first m paragraphs set the value parindentskip to a positive number.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

text

The text to be output into the given box.

left

x-coordinate of the lower left corner of the box.

bottom

y-coordinate of the lower left corner of the box.

width

Width of the box.

height

Height of the box.

hmode

The parameter hmode can be "justify", "fulljustify", "right", "left", or "center". The difference of "justify" and "fulljustify" just affects the last line of the box. In fulljustify mode the last line will be left and right justified unless this is also the last line of paragraph. In justify mode it will always be left justified.

feature

Used parameters

The output of ps_show_boxed() can be configured with several parameters and values which must be set with either ps_set_parameter() or ps_set_value(). Beside the parameters and values which affect text output, the following parameters and values are evaluated.

leading (value)

Distance between baselines of two consecutive lines.

linebreak (parameter)

Set to "true" if you want a carriage return to start a new line instead of treating it as a space. Defaults to "false".

parbreak (parameter)

Set to "true" if you want a carriage return on a single line to start a new paragraph instead of treating it as a space. Defaults to "true".

hyphenation (parameter)

Set to "true" in order to turn hyphenation on. This requires a dictionary to be set with the parameter "hyphendict". Defaults to "false".

hyphendict (parameter)

Filename of the dictionary used for hyphenation pattern (see below).

hyphenminchar (value)

The number of chars which must at least be left over before or after the hyphen. This implies that only words of at least two times this value will be hyphenated. The default value is three. Setting a value of zero will result in the default value.

parindent (value)

Set the amount of space in pixel for indenting the first m lines of a paragraph. m can be set with the value "numindentlines".

parskip (value)

Set the amount of extra space in pixel between paragraphs. Defaults to 0 which will result in a normal line distance.

numindentlines (value)

Number of lines from the start of the paragraph which will be indented. Defaults to 1.

parindentskip (value)

Number of paragraphs in the box whose first lines will not be indented. This defaults to 0. This is useful for paragraphs right after a section heading or text being continued in a second box. In both case one would set this to 1.

linenumbermode (parameter)

Set how lines are to be numbered. Possible values are "box" for numbering lines in the whole box or "paragraph" to number lines within each paragraph.

linenumberspace (value)

The space for the column left of the numbered line containing the line number. The line number will be right justified into this column. Defaults to 20.

linenumbersep (value)

The space between the column with line numbers and the line itself. Defaults to 5.

Hyphenation

Text is hyphenated if the parameter hyphenation is set to true and a valid hyphenation dictionary is set. pslib does not ship its own hyphenation dictionary but uses one from openoffice, scribus or koffice. You can find their dictionaries for different languages in one of the following directories if the software is installed:

  • /usr/share/apps/koffice/hyphdicts/
  • /usr/lib/scribus/dicts/
  • /usr/lib/openoffice/share/dict/ooo/
Currently scribus appears to have the most complete hyphenation dictionaries.

Dönen Değerler

Number of characters that could not be written.

Ayrıca Bakınız

  • ps_continue_text() - Continue text in next line

ps_shfill
ps_show_xy2
PS İşlevleri


Output text at position

ps_show_boxed
ps_show_xy
PS İşlevleri
PHP Manual

ps_show_xy2

(PECL ps >= 1.1.0)

ps_show_xy2 — Output text at position

Açıklama

bool ps_show_xy2 ( resource $psdoc , string $text , int $len , float $xcoor , float $ycoor )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

ps_show_boxed
ps_show_xy
PS İşlevleri


Output text at given position

ps_show_xy2
ps_show2
PS İşlevleri
PHP Manual

ps_show_xy

(PECL ps >= 1.1.0)

ps_show_xy — Output text at given position

Açıklama

bool ps_show_xy ( resource $psdoc , string $text , float $x , float $y )

Output a text at the given text position.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

text

The text to be output.

x

x-coordinate of the lower left corner of the box surrounding the text.

y

y-coordinate of the lower left corner of the box surrounding the text.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_continue_text() - Continue text in next line
  • ps_show() - Output text

ps_show_xy2
ps_show2
PS İşlevleri


Output a text at current position

ps_show_xy
ps_show
PS İşlevleri
PHP Manual

ps_show2

(PECL ps >= 1.1.0)

ps_show2 — Output a text at current position

Açıklama

bool ps_show2 ( resource $psdoc , string $text , int $len )

Output text at the current position. Do not print more than len characters.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

text

The text to be output.

len

The maximum number of characters to print.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

ps_show_xy
ps_show
PS İşlevleri


Output text

ps_show2
ps_string_geometry
PS İşlevleri
PHP Manual

ps_show

(PECL ps >= 1.1.0)

ps_show — Output text

Açıklama

bool ps_show ( resource $psdoc , string $text )

Output a text at the current text position. The text position can be set by storing the x and y coordinates into the values textx and texty with the function ps_set_value(). The function will issue an error if a font was not set before with ps_setfont().

ps_show() evaluates the following parameters and values as set by ps_set_parameter() and ps_set_value().

charspacing (value)

Distance between two consecutive glyphs. If this value is unequal to zero then all ligatures will be resolved. Values less than zero are allowed.

kerning (parameter)

Setting this parameter to "false" will turn off kerning. Kerning is turned on by default.

ligatures (parameter)

Setting this parameter to "false" will turn off the use of ligatures. Ligatures are turned on by default.

underline (parameter)

Setting this parameter to "true" will turn on underlining. Underlining is turned off by default.

overline (parameter)

Setting this parameter to "true" will turn on overlining. Overlining is turned off by default.

strikeout (parameter)

Setting this parameter to "true" will turn on striking out. Striking out is turned off by default.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

text

The text to be output.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_continue_text() - Continue text in next line
  • ps_show_xy() - Output text at given position
  • ps_setfont() - Sets font to use for following output

ps_show2
ps_string_geometry
PS İşlevleri


Gets geometry of a string

ps_show
ps_stringwidth
PS İşlevleri
PHP Manual

ps_string_geometry

(PECL ps >= 1.2.0)

ps_string_geometry — Gets geometry of a string

Açıklama

array ps_string_geometry ( resource $psdoc , string $text [, int $fontid = 0 [, float $size = 0.0 ]] )

This function is similar to ps_stringwidth() but returns an array of dimensions containing the width, ascender, and descender of the text.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

text

The text for which the geometry is to be calculated.

fontid

The identifier of the font to be used. If not font is specified the current font will be used.

size

The size of the font. If no size is specified the current size is used.

Dönen Değerler

An array of the dimensions of a string. The element 'width' contains the width of the string as returned by ps_stringwidth(). The element 'descender' contains the maximum descender and 'ascender' the maximum ascender of the string.

Ayrıca Bakınız

  • ps_continue_text() - Continue text in next line
  • ps_stringwidth() - Gets width of a string

ps_show
ps_stringwidth
PS İşlevleri


Gets width of a string

ps_string_geometry
ps_stroke
PS İşlevleri
PHP Manual

ps_stringwidth

(PECL ps >= 1.1.0)

ps_stringwidth — Gets width of a string

Açıklama

float ps_stringwidth ( resource $psdoc , string $text [, int $fontid = 0 [, float $size = 0.0 ]] )

Calculates the width of a string in points if it was output in the given font and font size. This function needs an Adobe font metrics file to calculate the precise width. If kerning is turned on, it will be taken into account.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

text

The text for which the width is to be calculated.

fontid

The identifier of the font to be used. If not font is specified the current font will be used.

size

The size of the font. If no size is specified the current size is used.

Dönen Değerler

Width of a string in points.

Ayrıca Bakınız

  • ps_string_geometry() - Gets geometry of a string

ps_string_geometry
ps_stroke
PS İşlevleri


Draws the current path

ps_stringwidth
ps_symbol_name
PS İşlevleri
PHP Manual

ps_stroke

(PECL ps >= 1.1.0)

ps_stroke — Draws the current path

Açıklama

bool ps_stroke ( resource $psdoc )

Draws the path constructed with previously called drawing functions like ps_lineto().

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_closepath_stroke() - Closes and strokes path
  • ps_fill() - Fills the current path
  • ps_fill_stroke() - Fills and strokes the current path

ps_stringwidth
ps_symbol_name
PS İşlevleri


Gets name of a glyph

ps_stroke
ps_symbol_width
PS İşlevleri
PHP Manual

ps_symbol_name

(PECL ps >= 1.2.0)

ps_symbol_name — Gets name of a glyph

Açıklama

string ps_symbol_name ( resource $psdoc , int $ord [, int $fontid = 0 ] )

This function needs an Adobe font metrics file to know which glyphs are available.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

ord

The parameter ord is the position of the glyph in the font encoding vector.

fontid

The identifier of the font to be used. If not font is specified the current font will be used.

Dönen Değerler

The name of a glyph in the given font.

Ayrıca Bakınız

  • ps_symbol() - Output a glyph
  • ps_symbol_width() - Gets width of a glyph

ps_stroke
ps_symbol_width
PS İşlevleri


Gets width of a glyph

ps_symbol_name
ps_symbol
PS İşlevleri
PHP Manual

ps_symbol_width

(PECL ps >= 1.2.0)

ps_symbol_width — Gets width of a glyph

Açıklama

float ps_symbol_width ( resource $psdoc , int $ord [, int $fontid = 0 [, float $size = 0.0 ]] )

Calculates the width of a glyph in points if it was output in the given font and font size. This function needs an Adobe font metrics file to calculate the precise width.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

ord

The position of the glyph in the font encoding vector.

fontid

The identifier of the font to be used. If not font is specified the current font will be used.

size

The size of the font. If no size is specified the current size is used.

Dönen Değerler

The width of a glyph in points.

Ayrıca Bakınız

  • ps_symbol() - Output a glyph
  • ps_symbol_name() - Gets name of a glyph

ps_symbol_name
ps_symbol
PS İşlevleri


Output a glyph

ps_symbol_width
ps_translate
PS İşlevleri
PHP Manual

ps_symbol

(PECL ps >= 1.2.0)

ps_symbol — Output a glyph

Açıklama

bool ps_symbol ( resource $psdoc , int $ord )

Output the glyph at position ord in the font encoding vector of the current font. The font encoding for a font can be set when loading the font with ps_findfont().

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

ord

The position of the glyph in the font encoding vector.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ps_symbol_name() - Gets name of a glyph
  • ps_symbol_width() - Gets width of a glyph

ps_symbol_width
ps_translate
PS İşlevleri


Sets translation

ps_symbol
RPM Reader
PS İşlevleri
PHP Manual

ps_translate

(PECL ps >= 1.1.0)

ps_translate — Sets translation

Açıklama

bool ps_translate ( resource $psdoc , float $x , float $y )

Sets a new initial point of the coordinate system.

Değiştirgeler

psdoc

Resource identifier of the postscript file as returned by ps_new().

x

x-coordinate of the origin of the translated coordinate system.

y

y-coordinate of the origin of the translated coordinate system.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Translation of the coordinate system

<?php
function rectangle($ps) {
    ps_moveto($ps, 0, 0);
    ps_lineto($ps, 0, 50);
    ps_lineto($ps, 50, 50);
    ps_lineto($ps, 50, 0);
    ps_lineto($ps, 0, 0);
    ps_stroke($ps);
}

$ps = ps_new();
if (!ps_open_file($ps, "translate.ps")) {
  print "Cannot open PostScript file\n";
  exit;
}

ps_set_info($ps, "Creator", "translate.php");
ps_set_info($ps, "Author", "Uwe Steinmann");
ps_set_info($ps, "Title", "Translated example");
ps_set_info($ps, "BoundingBox", "0 0 596 842");

$psfont = ps_findfont($ps, "Helvetica", "", 0);

ps_begin_page($ps, 596, 842);
ps_set_text_pos($ps, 100, 100);
ps_translate($ps, 500, 750);
rectangle($ps);
ps_translate($ps, -500, -750);
ps_setfont($ps, $psfont, 8.0);
ps_show($ps, "Text at initial position");
ps_end_page($ps);

ps_begin_page($ps, 596, 842);
ps_set_text_pos($ps, 100, 100);
ps_save($ps);
ps_translate($ps, 500, 750);
rectangle($ps);
ps_restore($ps);
ps_setfont($ps, $psfont, 8.0);
ps_show($ps, "Text at initial position");
ps_end_page($ps);

ps_delete($ps);
?>

The above example demonstrates two possible ways to place a graphic (in this case just a rectangle) at any position on the page, while the graphic itself uses its own coordinate system. The trick is to change the origin of the current coordinate system before drawing the rectangle. The translation has to be undone after the graphic has been drawn.

On the second page a slightly different and more elegant approach is applied. Instead of undoing the translation with a second call of ps_translate() the graphics context is saved before modifying the coordinate system and restored after drawing the rectangle.

Ayrıca Bakınız

  • ps_scale() - Sets scaling factor
  • ps_rotate() - Sets rotation factor

ps_symbol
RPM Reader
PS İşlevleri


RPM Header Reading

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
    • Basic usage
  • RPM Reader İşlevleri
    • rpm_close — Closes an RPM file
    • rpm_get_tag — Retrieves a header tag from an RPM file
    • rpm_is_valid — Tests a filename for validity as an RPM file
    • rpm_open — Opens an RPM file
    • rpm_version — Returns a string representing the current version of the rpmreader extension
ps_translate
Giriş
Salt Metin Olmayan MIME Çıktılama


Giriş

This module allows you to read the meta information stored in the headers of a » RedHat Package Manager (» RPM) file.

RPM Reader
Yapılandırma/Kurulum
RPM Reader


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
RPM Reader


Gereksinimler

The RPMReader extension requires PHP 5.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu » PECL eklentisi PHP ile gelmez.

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/rpmreader.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Özkaynak Türleri

There is one resource type used by the RPMReader module. The resource is a file pointer which identifies the RPM file with which to work.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

The following list of constants are used to obtain information using the rpm_get_tag() function. These constants represent the tag number to be retrieved from the RPM file's header section. Descriptions are given below as to what data the tag number constants reference.

RPMREADER_MINIMUM (integer)
The minimum valid value of any RPM tag number.
RPMREADER_NAME (integer)
The name of the RPM package.
RPMREADER_VERSION (integer)
The version of the RPM package.
RPMREADER_RELEASE (integer)
The release of the RPM package.
RPMREADER_EPOCH (integer)
RPMREADER_SERIAL (integer)
RPMREADER_SUMMARY (integer)
The summary text of the RPM package.
RPMREADER_DESCRIPTION (integer)
The full description text of the RPM package.
RPMREADER_BUILDTIME (integer)
The date and time when the RPM package was built.
RPMREADER_BUILDHOST (integer)
The name of the host on which the RPM package was built.
RPMREADER_INSTALLTIME (integer)
RPMREADER_SIZE (integer)
The size of the RPM package.
RPMREADER_DISTRIBUTION (integer)
RPMREADER_VENDOR (integer)
RPMREADER_GIF (integer)
RPMREADER_XPM (integer)
RPMREADER_LICENSE (integer)
RPMREADER_COPYRIGHT (integer)
RPMREADER_PACKAGER (integer)
RPMREADER_GROUP (integer)
RPMREADER_SOURCE (integer)
RPMREADER_PATCH (integer)
RPMREADER_URL (integer)
RPMREADER_OS (integer)
RPMREADER_ARCH (integer)
RPMREADER_PREIN (integer)
RPMREADER_POSTIN (integer)
RPMREADER_PREUN (integer)
RPMREADER_POSTUN (integer)
RPMREADER_OLDFILENAMES (integer)
The list of files in an RPM package (deprecated format). The correct way is now to use a combination of 3 tags (RPMREADER_BASENAMES, RPMREADER_DIRINDEXES, RPMREADER_DIRNAMES) in what RPM now calls "CompressedFileNames". This tag is still used in older RPM files that did not use the "CompressedFileNames" method and is maintained for backward compatibility.
RPMREADER_FILESIZES (integer)
RPMREADER_FILESTATES (integer)
RPMREADER_FILEMODES (integer)
RPMREADER_FILERDEVS (integer)
RPMREADER_FILEMTIMES (integer)
RPMREADER_FILEMD5S (integer)
RPMREADER_FILELINKTOS (integer)
RPMREADER_FILEFLAGS (integer)
RPMREADER_FILEUSERNAME (integer)
RPMREADER_FILEGROUPNAME (integer)
RPMREADER_ICON (integer)
RPMREADER_SOURCERPM (integer)
RPMREADER_FILEVERIFYFLAGS (integer)
RPMREADER_ARCHIVESIZE (integer)
RPMREADER_PROVIDENAME (integer)
RPMREADER_PROVIDES (integer)
RPMREADER_REQUIREFLAGS (integer)
RPMREADER_REQUIRENAME (integer)
RPMREADER_REQUIREVERSION (integer)
RPMREADER_CONFLICTFLAGS (integer)
RPMREADER_CONFLICTNAME (integer)
RPMREADER_CONFLICTVERSION (integer)
RPMREADER_EXCLUDEARCH (integer)
RPMREADER_EXCLUDEOS (integer)
RPMREADER_EXCLUSIVEARCH (integer)
RPMREADER_EXCLUSIVEOS (integer)
RPMREADER_RPMVERSION (integer)
RPMREADER_TRIGGERSCRIPTS (integer)
RPMREADER_TRIGGERNAME (integer)
RPMREADER_TRIGGERVERSION (integer)
RPMREADER_TRIGGERFLAGS (integer)
RPMREADER_TRIGGERINDEX (integer)
RPMREADER_VERIFYSCRIPT (integer)
RPMREADER_CHANGELOGTIME (integer)
The list of dates from changelog entries.
RPMREADER_CHANGELOGNAME (integer)
The list of changelog entry names.
RPMREADER_CHANGELOGTEXT (integer)
The list of the text from changelog entries.
RPMREADER_PREINPROG (integer)
RPMREADER_POSTINPROG (integer)
RPMREADER_PREUNPROG (integer)
RPMREADER_POSTUNPROG (integer)
RPMREADER_BUILDARCHS (integer)
RPMREADER_OBSOLETENAME (integer)
RPMREADER_OBSOLETES (integer)
RPMREADER_VERIFYSCRIPTPROG (integer)
RPMREADER_TRIGGERSCRIPTPROG (integer)
RPMREADER_COOKIE (integer)
RPMREADER_FILEDEVICES (integer)
RPMREADER_FILEINODES (integer)
RPMREADER_FILELANGS (integer)
RPMREADER_PREFIXES (integer)
RPMREADER_INSTPREFIXES (integer)
RPMREADER_PROVIDEFLAGS (integer)
RPMREADER_PROVIDEVERSION (integer)
RPMREADER_OBSOLETEFLAGS (integer)
RPMREADER_OBSOLETEVERSION (integer)
RPMREADER_DIRINDEXES (integer)
The list of indices that relate directory names to files in the RPM package. This tag is used in conjunction with RPMREADER_BASENAMES and RPMREADER_DIRNAMES to reconstruct filenames in the RPM package stored with the new "CompressedFileNames" method in RPM.
RPMREADER_BASENAMES (integer)
The list of the names of files in the RPM package without path information. This tag is used in conjunction with RPMREADER_DIRINDEXES and RPMREADER_DIRNAMES to reconstruct filenames in the RPM package stored with the new "CompressedFileNames" method in RPM.
RPMREADER_DIRNAMES (integer)
The list of directory names used by files in the RPM package. This tag is used in conjunction with RPMREADER_BASENAMES and RPMREADER_DIRINDEXES to reconstruct filenames in the RPM package stored with the new "CompressedFileNames" method in RPM.
RPMREADER_OPTFLAGS (integer)
RPMREADER_DISTURL (integer)
RPMREADER_PAYLOADFORMAT (integer)
RPMREADER_PAYLOADCOMPRESSOR (integer)
RPMREADER_PAYLOADFLAGS (integer)
RPMREADER_INSTALLCOLOR (integer)
RPMREADER_INSTALLTID (integer)
RPMREADER_REMOVETID (integer)
RPMREADER_RHNPLATFORM (integer)
RPMREADER_PLATFORM (integer)
RPMREADER_PATCHESNAME (integer)
RPMREADER_PATCHESFLAGS (integer)
RPMREADER_PATCHESVERSION (integer)
RPMREADER_CACHECTIME (integer)
RPMREADER_CACHEPKGPATH (integer)
RPMREADER_CACHEPKGSIZE (integer)
RPMREADER_CACHEPKGMTIME (integer)
RPMREADER_FILECOLORS (integer)
RPMREADER_FILECLASS (integer)
RPMREADER_CLASSDICT (integer)
RPMREADER_FILEDEPENDSX (integer)
RPMREADER_FILEDEPENDSN (integer)
RPMREADER_DEPENDSDICT (integer)
RPMREADER_SOURCEPKGID (integer)
RPMREADER_FILECONTEXTS (integer)
RPMREADER_FSCONTEXTS (integer)
RPMREADER_RECONTEXTS (integer)
RPMREADER_POLICIES (integer)
RPMREADER_MAXIMUM (integer)
The maximum valid value of any RPM tag number.

Özkaynak Türleri
Örnekler
RPM Reader


Örnekler

İçindekiler

  • Basic usage
Öntanımlı Sabitler
Basic usage
RPM Reader


Basic usage

This example will open an RPM file and read the name, version, and release from the RPM file, echo the results, and close the RPM file.

Örnek 1 Basic RPMReader Example

<?php

$filename = "/path/to/file.rpm";

// open file
$rpmr = rpm_open($filename);

// get "Name" tag
$name = rpm_get_tag($rpmr, RPMREADER_NAME);

// get "Version" tag
$ver = rpm_get_tag($rpmr, RPMREADER_VERSION);

// get "Release" tag
$rel = rpm_get_tag($rpmr, RPMREADER_RELEASE);

echo "$name-$ver-$rel<br>\n";

// close file
rpm_close($rpmr);

?>
Örnekler
RPM Reader İşlevleri
Örnekler


RPM Reader İşlevleri

İçindekiler

  • rpm_close — Closes an RPM file
  • rpm_get_tag — Retrieves a header tag from an RPM file
  • rpm_is_valid — Tests a filename for validity as an RPM file
  • rpm_open — Opens an RPM file
  • rpm_version — Returns a string representing the current version of the rpmreader extension
Basic usage
rpm_close
RPM Reader


Closes an RPM file

RPM Reader İşlevleri
rpm_get_tag
RPM Reader İşlevleri
PHP Manual

rpm_close

(PECL rpmreader >= 0.1.0)

rpm_close — Closes an RPM file

Açıklama

bool rpm_close ( resource $rpmr )

rpm_close() will close an RPM file pointer.

Değiştirgeler

rpmr

A file pointer resource successfully opened by rpm_open().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 rpm_close() example

<?php

$file = "/path/to/file.rpm";
$rpmr = rpm_open($file);

rpm_close($rpmr);

?>

Ayrıca Bakınız

  • rpm_open() - Opens an RPM file

RPM Reader İşlevleri
rpm_get_tag
RPM Reader İşlevleri


Retrieves a header tag from an RPM file

rpm_close
rpm_is_valid
RPM Reader İşlevleri
PHP Manual

rpm_get_tag

(PECL rpmreader >= 0.1.0)

rpm_get_tag — Retrieves a header tag from an RPM file

Açıklama

mixed rpm_get_tag ( resource $rpmr , int $tagnum )

rpm_get_tag() will retrieve a given tag from the RPM file's header and return it.

Değiştirgeler

rpmr

A file pointer resource successfully opened by rpm_open().

tagnum

The tag number to retrieve from the RPM header. This value can be specified using the list of constants defined by this module.

Dönen Değerler

The return value can be of various types depending on the tagnum supplied to the function.

Örnekler

Örnek 1 rpm_get_tag() example

<?php

$file = "/path/to/file.rpm";
$rpmr = rpm_open($file);

$name = rpm_get_tag($rpmr, RPMREADER_NAME);
echo "$name<br>\n";

rpm_close($rpmr);

?>

Ayrıca Bakınız

  • rpm_open() - Opens an RPM file
  • rpm_close() - Closes an RPM file

rpm_close
rpm_is_valid
RPM Reader İşlevleri


Tests a filename for validity as an RPM file

rpm_get_tag
rpm_open
RPM Reader İşlevleri
PHP Manual

rpm_is_valid

(PECL rpmreader >= 0.1.0)

rpm_is_valid — Tests a filename for validity as an RPM file

Açıklama

bool rpm_is_valid ( string $filename )

rpm_is_valid() will test an RPM file for validity as an RPM file. This is not the same as rpm_open() as it only checks the file for validity but does not return a file pointer to be used by further functions.

Değiştirgeler

filename

The filename of the RPM file you wish to check for validity.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 rpm_is_valid() example

<?php

$file = "/path/to/file.rpm";

if (rpm_is_valid($file)) {
    echo "File is recognized as an RPM file.<br>\n";
}
else {
    echo "File is not recognized as an RPM file.<br>\n";
}

?>

rpm_get_tag
rpm_open
RPM Reader İşlevleri


Opens an RPM file

rpm_is_valid
rpm_version
RPM Reader İşlevleri
PHP Manual

rpm_open

(PECL rpmreader >= 0.1.0)

rpm_open — Opens an RPM file

Açıklama

resource rpm_open ( string $filename )

rpm_open() will open an RPM file and will determine if the file is a valid RPM file.

Değiştirgeler

filename

The filename of the RPM file you wish to open.

Dönen Değerler

If the open succeeds, then rpm_open() will return a file pointer resource to the newly opened file. On error, the function will return FALSE.

Örnekler

Örnek 1 rpm_open() example

<?php

$file = "/path/to/file.rpm";
$rpmr = rpm_open($file);

rpm_close($rpmr);

?>

Ayrıca Bakınız

  • rpm_close() - Closes an RPM file

rpm_is_valid
rpm_version
RPM Reader İşlevleri


Returns a string representing the current version of the rpmreader extension

rpm_open
Süreç Denetim Eklentileri
RPM Reader İşlevleri
PHP Manual

rpm_version

(PECL rpmreader >= 0.3.0)

rpm_version — Returns a string representing the current version of the rpmreader extension

Açıklama

string rpm_version ( void )

rpm_version() will return the current version of the rpmreader extension.

Dönen Değerler

rpm_version() will return a string representing the rpmreader version currently loaded in PHP.

Örnekler

Örnek 1 rpm_version() example

<?php

$rpmr_ver = rpm_version();

echo "$rpmr_ver<br />\n";

?>

rpm_open
Süreç Denetim Eklentileri
RPM Reader İşlevleri


Süreç Denetim Eklentileri

  • Eio
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • Eio İşlevleri
  • Ev
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • Watchers
    • Watcher callbacks
    • Periodic watcher operation modes
    • Ev — The Ev class
    • EvCheck — The EvCheck class
    • EvChild — The EvChild class
    • EvEmbed — The EvEmbed class
    • EvFork — The EvFork class
    • EvIdle — The EvIdle class
    • EvIo — The EvIo class
    • EvLoop — The EvLoop class
    • EvPeriodic — The EvPeriodic class
    • EvPrepare — The EvPrepare class
    • EvSignal — The EvSignal class
    • EvStat — The EvStat class
    • EvTimer — The EvTimer class
    • EvWatcher — The EvWatcher class
  • Expect
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • Expect İşlevleri
  • Libevent
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • Libevent İşlevleri
  • PCNTL — Süreç Denetimi
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • Süreç Denetim İşlevleri
  • POSIX
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • POSIX İşlevleri
  • Program Çalıştırma — Sistem Programlarının Çalıştırılması
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Program Çalıştırma İşlevleri
  • pthreads
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Threaded — The Threaded class
    • Thread — The Thread class
    • Worker — The Worker class
    • Collectable — The Collectable interface
    • Modifiers — Method Modifiers
    • Pool — The Pool class
    • Mutex — The Mutex class
    • Cond — The Cond class
  • Semaphore — Semaphore, Shared Memory and IPC
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Semaphore İşlevleri
  • Shared Memory
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • Shared Memory İşlevleri
  • Sync
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • SyncMutex — The SyncMutex class
    • SyncSemaphore — The SyncSemaphore class
    • SyncEvent — The SyncEvent class
    • SyncReaderWriter — The SyncReaderWriter class
    • SyncSharedMemory — The SyncSharedMemory class
rpm_version
Eio
İşlev Başvuru Kılavuzu


Eio

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
  • Eio İşlevleri
    • eio_busy — Artificially increase load. Could be useful in tests, benchmarking.
    • eio_cancel — Cancels a request
    • eio_chmod — Change file/direcrory permissions.
    • eio_chown — Change file/direcrory permissions.
    • eio_close — Close file
    • eio_custom — Execute custom request like any other eio_* call.
    • eio_dup2 — Duplicate a file descriptor
    • eio_event_loop — Polls libeio until all requests proceeded
    • eio_fallocate — Allows the caller to directly manipulate the allocated disk space for a file
    • eio_fchmod — Change file permissions.
    • eio_fchown — Change file ownership
    • eio_fdatasync — Synchronize a file's in-core state with storage device.
    • eio_fstat — Get file status
    • eio_fstatvfs — Get file system statistics
    • eio_fsync — Synchronize a file's in-core state with storage device
    • eio_ftruncate — Truncate a file
    • eio_futime — Change file last access and modification times
    • eio_get_event_stream — Get stream representing a variable used in internal communications with libeio.
    • eio_get_last_error — Returns string describing the last error associated with a request resource
    • eio_grp_add — Adds a request to the request group.
    • eio_grp_cancel — Cancels a request group
    • eio_grp_limit — Set group limit
    • eio_grp — Creates a request group.
    • eio_init — (Re-)initialize Eio
    • eio_link — Create a hardlink for file
    • eio_lstat — Get file status
    • eio_mkdir — Create directory
    • eio_mknod — Create a special or ordinary file.
    • eio_nop — Does nothing, except go through the whole request cycle.
    • eio_npending — Returns number of finished, but unhandled requests
    • eio_nready — Returns number of not-yet handled requests
    • eio_nreqs — Returns number of requests to be processed
    • eio_nthreads — Returns number of threads currently in use
    • eio_open — Opens a file
    • eio_poll — Can be to be called whenever there are pending requests that need finishing.
    • eio_read — Read from a file descriptor at given offset.
    • eio_readahead — Perform file readahead into page cache
    • eio_readdir — Reads through a whole directory
    • eio_readlink — Read value of a symbolic link.
    • eio_realpath — Get the canonicalized absolute pathname.
    • eio_rename — Change the name or location of a file.
    • eio_rmdir — Remove a directory
    • eio_seek — Repositions the offset of the open file associated with the fd argument to the argument offset according to the directive whence
    • eio_sendfile — Transfer data between file descriptors
    • eio_set_max_idle — Set maximum number of idle threads.
    • eio_set_max_parallel — Set maximum parallel threads
    • eio_set_max_poll_reqs — Set maximum number of requests processed in a poll.
    • eio_set_max_poll_time — Set maximum poll time
    • eio_set_min_parallel — Set minimum parallel thread number
    • eio_stat — Get file status
    • eio_statvfs — Get file system statistics
    • eio_symlink — Create a symbolic link
    • eio_sync_file_range — Sync a file segment with disk
    • eio_sync — Commit buffer cache to disk
    • eio_syncfs — Calls Linux' syncfs syscall, if available
    • eio_truncate — Truncate a file
    • eio_unlink — Delete a name and possibly the file it refers to
    • eio_utime — Change file last access and modification times.
    • eio_write — Write to file
Süreç Denetim Eklentileri
Giriş
Süreç Denetim Eklentileri


Giriş

This extension provides asyncronous POSIX I/O by means of » libeio C library written by Marc Lehmann.

Bilginize: Bu eklenti Windows sistemlerinde çalışmaz.

Uyarı

It is important to aware that each request is executed in a thread, and the order of execution of continuously queued requests basically is unpredictable. For instance, the following piece of code is incorrect.

Örnek 1 Incorrect requests

<?php
// Request to create symlink of $filename to $link
eio_symlink($filename, $link);

// Request to move $filename to $new_filename
eio_rename($filename, $new_filename);

// Process requests
eio_event_loop();
?>
In the example above eio_rename() request may finish before eio_symlink(). To fix it you might call eio_rename() in the callback of eio_symlink():

Örnek 2 Calling request from a request callback

<?php
function my_symlink_done($filename, $result) {
 // Request to move $filename to $new_filename
 eio_rename($filename, "/path/to/new-name");

 // Process requests
 eio_event_loop();
}

// Request to create symlink of $filename to $link
eio_symlink($filename, $link, EIO_PRI_DEFAULT, "my_symlink_done", $filename);

// Process requests
eio_event_loop();
?>
Alternatively, you might want to create a request group:

Örnek 3 Calling request from a request callback

<?php
/* Is called when the group requests are done */
function my_grp_done($data, $result) {
 // ...
}

function my_symlink_done($filename, $result) {
 // Create eio_rename request and add it to the group
 $req = eio_rename($filename, "/path/to/new-name");
 eio_grp_add($grp, $req);
 // You might want to add more requests...
}

// Create a request group
$grp = eio_grp("my_grp_done", "my_grp_data");

// Create eio_symlink request and add it to the group
// Pass $filename to the callback
$req = eio_symlink($filename, $link,
  EIO_PRI_DEFAULT, "my_symlink_done", $filename);
eio_grp_add($grp, $req);

// Process requests
eio_event_loop();
?>
Group is a special kind of request that could accumulate a set of regular eio requests. This could be used to create a complex request that opens, reads and closes a file.

Since version 0.3.0 alpha, a variable used in communications with libeio internally, could be retrieved with eio_get_event_stream(). The variable could be used to bind to an event loop supported by some other extension. You might organize a simple event loop where eio and libevent work together:

Örnek 4 Using eio with libevent

<?php
function my_eio_poll($fd, $events, $arg) {
    /* Some libevent regulation might go here .. */
    if (eio_nreqs()) {
        eio_poll();
    }
    /* .. and here */
}

function my_res_cb($d, $r) {
    var_dump($r); var_dump($d);
}

$base = event_base_new();
$event = event_new();

// This stream is used to bind with libevent
$fd = eio_get_event_stream();

eio_nop(EIO_PRI_DEFAULT, "my_res_cb", "nop data");
eio_mkdir("/tmp/abc-eio-temp", 0750, EIO_PRI_DEFAULT, "my_res_cb", "mkdir data");
/* some other eio_* calls here ... */

// set event flags
event_set($event, $fd, EV_READ /*| EV_PERSIST*/, "my_eio_poll", array($event, $base));

// set event base
event_base_set($event, $base);

// enable event
event_add($event);

// start event loop
event_base_loop($base);

/* The same will be available via buffered libevent interface */
?>

Eio
Yapılandırma/Kurulum
Eio


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Eio


Gereksinimler

This extension has » libeio library embedded. So you do NOT need to install libeio separately.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/eio.

For information about manual installation, please read the file INSTALL included in the package.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Özkaynak Türleri

There are two resource types in this extension: request and request group.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

Request priority constants:

EIO_PRI_MIN (integer)
Request minimal prioriry
EIO_PRI_DEFAULT (integer)
Request default prioriry
EIO_PRI_MAX (integer)
Request maximal prioriry

eio_seek() whence argument:

EIO_SEEK_SET (integer)
The offset is set to specified number of bytes(offset).
EIO_SEEK_CUR (integer)
The offset is set to its current location plus offset bytes.
EIO_SEEK_END (integer)
The offset is set to the size of the file plus offset bytes.

Flags used with eio_readdir():

EIO_READDIR_DENTS (integer)
eio_readdir() flag. If specified, the result argument of the callback becomes an array with the following keys: 'names' - array of directory names 'dents' - array of struct eio_dirent-like arrays having the following keys each: 'name' - the directory name; 'type' - one of EIO_DT_* constants; 'inode' - the inode number, if available, otherwise unspecified;
EIO_READDIR_DIRS_FIRST (integer)
When this flag is specified, the names will be returned in an order where likely directories come first, in optimal stat order.
EIO_READDIR_STAT_ORDER (integer)
When this flag is specified, then the names will be returned in an order suitable for stat'ing each one. When planning to stat() all files in the given directory, the returned order will likely be fastest.
EIO_READDIR_FOUND_UNKNOWN (integer)
EIO_DT_UNKNOWN (integer)
Unknown node type(very common). Further stat() needed.
EIO_DT_FIFO (integer)
FIFO node type
EIO_DT_CHR (integer)
Node type
EIO_DT_MPC (integer)
Multiplexed char device (v7+coherent) node type
EIO_DT_DIR (integer)
Directory node type
EIO_DT_NAM (integer)
Xenix special named file node type
EIO_DT_BLK (integer)
Node type
EIO_DT_MPB (integer)
Multiplexed block device (v7+coherent)
EIO_DT_REG (integer)
Node type
EIO_DT_NWK (integer)
EIO_DT_CMP (integer)
HP-UX network special node type
EIO_DT_LNK (integer)
Link node type
EIO_DT_SOCK (integer)
Socket node type
EIO_DT_DOOR (integer)
Solaris door node type
EIO_DT_WHT (integer)
Node type
EIO_DT_MAX (integer)
Highest node type value

Access modes for eio_open() flags argument:

EIO_O_RDONLY (integer)
EIO_O_WRONLY (integer)
EIO_O_RDWR (integer)
EIO_O_NONBLOCK (integer)
EIO_O_APPEND (integer)
EIO_O_CREAT (integer)
EIO_O_TRUNC (integer)
EIO_O_EXCL (integer)
EIO_O_FSYNC (integer)

mode argument flags for eio_open():

EIO_S_IRUSR (integer)
EIO_S_IWUSR (integer)
EIO_S_IXUSR (integer)
EIO_S_IRGRP (integer)
EIO_S_IWGRP (integer)
EIO_S_IXGRP (integer)
EIO_S_IROTH (integer)
EIO_S_IWOTH (integer)
EIO_S_IXOTH (integer)
EIO_S_IFREG (integer)
EIO_S_IFCHR (integer)
EIO_S_IFBLK (integer)
EIO_S_IFIFO (integer)
EIO_S_IFSOCK (integer)

eio_sync_file_range() flags:

EIO_SYNC_FILE_RANGE_WAIT_BEFORE (integer)
EIO_SYNC_FILE_RANGE_WRITE (integer)
EIO_SYNC_FILE_RANGE_WAIT_AFTER (integer)

eio_fallocate() flags:

EIO_FALLOC_FL_KEEP_SIZE (integer)

Bilginize:

EIO_S_I* constants have the same meaning as their S_I* POSIX counterparts.

Bilginize:

EIO_SYNC_FILE_* constants have the same meaning as their SYNC_FILE_** counterparts.

Bilginize:

EIO_O_* constants have the same meaning as their O_* POSIX counterparts.

Özkaynak Türleri
Örnekler
Eio


Örnekler

Örnek 1 Cancelling a request

<?php
 /* Is called when eio_nop() finished */
 function my_nop_cb($data, $result) {
  echo "my_nop ", $data, "\n";
 }

// This eio_nop() call will be cancelled
$req = eio_nop(EIO_PRI_DEFAULT, "my_nop_cb", "1");
var_dump($req);
eio_cancel($req);

// This time eio_nop() will be processed
eio_nop(EIO_PRI_DEFAULT, "my_nop_cb", "2");

// Process requests
eio_event_loop();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

resource(4) of type (EIO Request Descriptor)
my_nop 2

Örnek 2 Calling eio_chmod()

<?php
$temp_filename = dirname(__FILE__) ."/eio-temp-file.tmp";
touch($temp_filename);

/* Is called when eio_chmod() finished */
function my_chmod_callback($data, $result) {
    global $temp_filename;

    if ($result == 0 && !is_readable($temp_filename) && is_writable($temp_filename)) {
        echo "eio_chmod_ok";
    }

    @unlink($temp_filename);
}

eio_chmod($temp_filename, 0200, EIO_PRI_DEFAULT, "my_chmod_callback");
eio_event_loop();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

eio_chmod_ok

Örnek 3 Making a custom request

<?php
/* Callback for the custom callback */
function my_custom_callback($data, $result) {
    var_dump($data);
    var_dump(count($result));
    var_dump($result['data_modified']);
    var_dump($result['result']);
}

/* The custom request */
function my_custom($data) {
    var_dump($data);

    $result  = array(
        'result'        => 1001,
        'data_modified' => "my custom data",
    );

    return $result;
}

$data = "my_custom_data";
$req = eio_custom("my_custom", EIO_PRI_DEFAULT, "my_custom_callback", $data);
var_dump($req);
eio_event_loop();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

resource(4) of type (EIO Request Descriptor)
string(14) "my_custom_data"
string(14) "my_custom_data"
int(2)
string(14) "my custom data"
int(1001)

Örnek 4 Grouping requests

<?php
/*
 * Create a group request to open, read and close a file
 */

$temp_filename = dirname(__FILE__) ."/eio-file.tmp";
$fp = fopen($temp_filename, "w");
fwrite($fp, "some data");
fclose($fp);

/* Is called when the group requests are done */
function my_grp_done($data, $result) {
 global $temp_filename;
 var_dump($result == 0);
 @unlink($temp_filename);
}

/* Is called when eio_open() done */
function my_grp_file_opened_callback($data, $result) {
 global $my_file_fd, $grp;

 $my_file_fd = $result;

 var_dump($result > 0);

 // Create eio_read() request and add it to the group
 $req = eio_read($my_file_fd, 4, 0, EIO_PRI_DEFAULT, "my_grp_file_read_callback");
 eio_grp_add($grp, $req);
}

/* Is called when eio_read() done */
function my_grp_file_read_callback($data, $result) {
 global $my_file_fd, $grp;

 var_dump($result);

 // Create eio_close() request and add it to the group
 $req = eio_close($my_file_fd);
 eio_grp_add($grp, $req);
}

$grp = eio_grp("my_grp_done", "my_grp_data");

// Create eio_open() request and add it to the group
$req = eio_open($temp_filename, EIO_O_RDWR | EIO_O_APPEND , NULL,
  EIO_PRI_DEFAULT, "my_grp_file_opened_callback", NULL);
eio_grp_add($grp, $req);
var_dump($grp);

eio_event_loop();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

resource(6) of type (EIO Group Descriptor)
bool(true)
string(4) "some"
bool(true)

Örnek 5 Using eio with libevent extension

<?php
function my_eio_poll($fd, $events, $arg) {
    /* Some libevent regulation might go here .. */
    if (eio_nreqs()) {
        eio_poll();
    }
    /* .. and here */
}

function my_nop_cb($d, $r) {
    var_dump($r); var_dump($d);
}

$base = event_base_new();
$event = event_new();

$fd = eio_get_event_stream();
var_dump($fd);

eio_nop(EIO_PRI_DEFAULT, "my_nop_cb", "nop data");
eio_mkdir("/tmp/abc-eio-temp", 0750, EIO_PRI_DEFAULT, "my_nop_cb", "nop data");
/* some other eio_* calls here ... */

// set event flags
event_set($event, $fd, EV_READ /*| EV_PERSIST*/, "my_eio_poll", array($event, $base));

// set event base
event_base_set($event, $base);

// enable event
event_add($event);

// start event loop
event_base_loop($base);

/* The same will be available via buffered libevent interface */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(3)
int(0)
string(8) "nop data"
int(0)
string(10) "mkdir data"

Örnek 6 Using eio with event extension

<?php
$base = new EventBase();

// Retrieve eio polling stream.
// Note, this variable should be alive as long as the event loop is running.
$eio_stream = eio_get_event_stream();

// Bind eio polling stream to the event loop.
$poll_event = new Event($base, $eio_stream, Event::READ, function () {
  if (eio_nreqs()) {
    eio_poll();
  }
});
$poll_event->add();

// Add eio jobs
eio_nop(EIO_PRI_DEFAULT, function () {
  echo "eio_nop\n";
});

// Add events
$timer = Event::timer($base, function () {
  echo "2 seconds elapsed\n";
});
$timer->add(2);

// Dispatch events.
$base->dispatch();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

eio_nop
2 seconds elapsed

Öntanımlı Sabitler
Eio İşlevleri
Eio


Eio İşlevleri

İçindekiler

  • eio_busy — Artificially increase load. Could be useful in tests, benchmarking.
  • eio_cancel — Cancels a request
  • eio_chmod — Change file/direcrory permissions.
  • eio_chown — Change file/direcrory permissions.
  • eio_close — Close file
  • eio_custom — Execute custom request like any other eio_* call.
  • eio_dup2 — Duplicate a file descriptor
  • eio_event_loop — Polls libeio until all requests proceeded
  • eio_fallocate — Allows the caller to directly manipulate the allocated disk space for a file
  • eio_fchmod — Change file permissions.
  • eio_fchown — Change file ownership
  • eio_fdatasync — Synchronize a file's in-core state with storage device.
  • eio_fstat — Get file status
  • eio_fstatvfs — Get file system statistics
  • eio_fsync — Synchronize a file's in-core state with storage device
  • eio_ftruncate — Truncate a file
  • eio_futime — Change file last access and modification times
  • eio_get_event_stream — Get stream representing a variable used in internal communications with libeio.
  • eio_get_last_error — Returns string describing the last error associated with a request resource
  • eio_grp_add — Adds a request to the request group.
  • eio_grp_cancel — Cancels a request group
  • eio_grp_limit — Set group limit
  • eio_grp — Creates a request group.
  • eio_init — (Re-)initialize Eio
  • eio_link — Create a hardlink for file
  • eio_lstat — Get file status
  • eio_mkdir — Create directory
  • eio_mknod — Create a special or ordinary file.
  • eio_nop — Does nothing, except go through the whole request cycle.
  • eio_npending — Returns number of finished, but unhandled requests
  • eio_nready — Returns number of not-yet handled requests
  • eio_nreqs — Returns number of requests to be processed
  • eio_nthreads — Returns number of threads currently in use
  • eio_open — Opens a file
  • eio_poll — Can be to be called whenever there are pending requests that need finishing.
  • eio_read — Read from a file descriptor at given offset.
  • eio_readahead — Perform file readahead into page cache
  • eio_readdir — Reads through a whole directory
  • eio_readlink — Read value of a symbolic link.
  • eio_realpath — Get the canonicalized absolute pathname.
  • eio_rename — Change the name or location of a file.
  • eio_rmdir — Remove a directory
  • eio_seek — Repositions the offset of the open file associated with the fd argument to the argument offset according to the directive whence
  • eio_sendfile — Transfer data between file descriptors
  • eio_set_max_idle — Set maximum number of idle threads.
  • eio_set_max_parallel — Set maximum parallel threads
  • eio_set_max_poll_reqs — Set maximum number of requests processed in a poll.
  • eio_set_max_poll_time — Set maximum poll time
  • eio_set_min_parallel — Set minimum parallel thread number
  • eio_stat — Get file status
  • eio_statvfs — Get file system statistics
  • eio_symlink — Create a symbolic link
  • eio_sync_file_range — Sync a file segment with disk
  • eio_sync — Commit buffer cache to disk
  • eio_syncfs — Calls Linux' syncfs syscall, if available
  • eio_truncate — Truncate a file
  • eio_unlink — Delete a name and possibly the file it refers to
  • eio_utime — Change file last access and modification times.
  • eio_write — Write to file
Örnekler
eio_busy
Eio


Artificially increase load. Could be useful in tests, benchmarking.

Eio İşlevleri
eio_cancel
Eio İşlevleri
PHP Manual

eio_busy

(PECL eio >= 0.0.1dev)

eio_busy — Artificially increase load. Could be useful in tests, benchmarking.

Açıklama

resource eio_busy ( int $delay [, int $pri = EIO_PRI_DEFAULT [, callable $callback = NULL [, mixed $data = NULL ]]] )

eio_busy() artificially increases load taking delay seconds to execute. May be used for debugging, or benchmarking.

Değiştirgeler

delay

Delay in seconds

pri

The request priority: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, or NULL. If NULL passed, pri internally is set to EIO_PRI_DEFAULT.

callback

This callback is called when all the group requests are done.

data

Arbitrary variable passed to callback.

Dönen Değerler

eio_busy() returns request resource on success or FALSE on error.

Ayrıca Bakınız

  • eio_nop
Eio İşlevleri
eio_cancel
Eio İşlevleri


Cancels a request

eio_busy
eio_chmod
Eio İşlevleri
PHP Manual

eio_cancel

(PECL eio >= 0.0.1dev)

eio_cancel — Cancels a request

Açıklama

void eio_cancel ( resource $req )

eio_cancel() cancels a request specified by req

Değiştirgeler

req

The request resource

pri

The request priority: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, or NULL. If NULL passed, pri internally is set to EIO_PRI_DEFAULT.

callback

callback function is called when the request is done. It should match the following prototype:

void callback(mixed $data, int $result[, resource $req]);
data

is custom data passed to the request.

result

request-specific result value; basically, the value returned by corresponding system call.

req

is optional request resource which can be used with functions like eio_get_last_error()

data

Arbitrary variable passed to callback.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 eio_cancel() example

<?php
 /* Is called when eio_nop() finished */
 function my_nop_cb($data, $result) {
  echo "my_nop ", $data, "\n";
 }

// This eio_nop() call will be cancelled
$req = eio_nop(EIO_PRI_DEFAULT, "my_nop_cb", "1");
var_dump($req);
eio_cancel($req);

// This time eio_nop() will be processed
eio_nop(EIO_PRI_DEFAULT, "my_nop_cb", "2");

// Process requests
eio_event_loop();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

resource(4) of type (EIO Request Descriptor)
my_nop 2

Ayrıca Bakınız

  • eio_grp_cancel
eio_busy
eio_chmod
Eio İşlevleri


Change file/direcrory permissions.

eio_cancel
eio_chown
Eio İşlevleri
PHP Manual

eio_chmod

(PECL eio >= 0.0.1dev)

eio_chmod — Change file/direcrory permissions.

Açıklama

resource eio_chmod ( string $path , int $mode [, int $pri = EIO_PRI_DEFAULT [, callable $callback = NULL [, mixed $data = NULL ]]] )

eio_chmod() changes file, or direcrory permissions. The new permissions are specified by mode.

Değiştirgeler

path

Path to the target file or directory

Uyarı

Avoid relative paths

mode

The new permissions. E.g. 0644.

pri

The request priority: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, or NULL. If NULL passed, pri internally is set to EIO_PRI_DEFAULT.

callback

callback function is called when the request is done. It should match the following prototype:

void callback(mixed $data, int $result[, resource $req]);
data

is custom data passed to the request.

result

request-specific result value; basically, the value returned by corresponding system call.

req

is optional request resource which can be used with functions like eio_get_last_error()

data

Arbitrary variable passed to callback.

Dönen Değerler

eio_chmod() returns request resource on success or FALSE on error.

Ayrıca Bakınız

  • eio_chown
eio_cancel
eio_chown
Eio İşlevleri


Change file/direcrory permissions.

eio_chmod
eio_close
Eio İşlevleri
PHP Manual

eio_chown

(PECL eio >= 0.0.1dev)

eio_chown — Change file/direcrory permissions.

Açıklama

resource eio_chown ( string $path , int $uid [, int $gid = -1 [, int $pri = EIO_PRI_DEFAULT [, callable $callback = NULL [, mixed $data = NULL ]]]] )

Changes file, or directory permissions.

Değiştirgeler

path

Path to file or directory.

Uyarı

Avoid relative paths

uid

User ID. Is ignored when equal to -1.

gid

Group ID. Is ignored when equal to -1.

pri

The request priority: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, or NULL. If NULL passed, pri internally is set to EIO_PRI_DEFAULT.

callback

callback function is called when the request is done. It should match the following prototype:

void callback(mixed $data, int $result[, resource $req]);
data

is custom data passed to the request.

result

request-specific result value; basically, the value returned by corresponding system call.

req

is optional request resource which can be used with functions like eio_get_last_error()

data

Arbitrary variable passed to callback.

Dönen Değerler

eio_chown() returns request resource on success or FALSE on error.

Ayrıca Bakınız

  • eio_chmod
eio_chmod
eio_close
Eio İşlevleri


Close file

eio_chown
eio_custom
Eio İşlevleri
PHP Manual

eio_close

(PECL eio >= 0.0.1dev)

eio_close — Close file

Açıklama

resource eio_close ( mixed $fd [, int $pri = EIO_PRI_DEFAULT [, callable $callback = NULL [, mixed $data = NULL ]]] )

eio_close() closes file specified by fd.

Değiştirgeler

fd

Stream, Socket resource, or numeric file descriptor

pri

The request priority: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, or NULL. If NULL passed, pri internally is set to EIO_PRI_DEFAULT.

callback

callback function is called when the request is done. It should match the following prototype:

void callback(mixed $data, int $result[, resource $req]);
data

is custom data passed to the request.

result

request-specific result value; basically, the value returned by corresponding system call.

req

is optional request resource which can be used with functions like eio_get_last_error()

data

Arbitrary variable passed to callback.

Dönen Değerler

eio_close() returns request resource on success or FALSE on error.

Ayrıca Bakınız

  • eio_open
eio_chown
eio_custom
Eio İşlevleri


Execute custom request like any other eio_* call.

eio_close
eio_dup2
Eio İşlevleri
PHP Manual

eio_custom

(PECL eio >= 0.0.1dev)

eio_custom — Execute custom request like any other eio_* call.

Açıklama

resource eio_custom ( callable $execute , int $pri , callable $callback [, mixed $data = NULL ] )

eio_custom() executes custom function specified by execute processing it just like any other eio_* call.

Değiştirgeler

execute

Specifies the request function that should match the following prototype:

      mixed execute(mixed data);
callback is event completion callback that should match the following prototype:
      void callback(mixed data, mixed result);
data is the data passed to execute via data argument without modifications result value returned by execute

pri

The request priority: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, or NULL. If NULL passed, pri internally is set to EIO_PRI_DEFAULT.

callback

callback function is called when the request is done. It should match the following prototype:

void callback(mixed $data, int $result[, resource $req]);
data

is custom data passed to the request.

result

request-specific result value; basically, the value returned by corresponding system call.

req

is optional request resource which can be used with functions like eio_get_last_error()

data

Arbitrary variable passed to callback.

Dönen Değerler

eio_custom() returns request resource on success or FALSE on error.

Örnekler

Örnek 1 eio_custom() example

<?php
/* Callback for the custom callback */
function my_custom_callback($data, $result) {
    var_dump($data);
    var_dump(count($result));
    var_dump($result['data_modified']);
    var_dump($result['result']);
}

/* The custom request */
function my_custom($data) {
    var_dump($data);

    $result  = array(
        'result'        => 1001,
        'data_modified' => "my custom data",
    );

    return $result;
}

$data = "my_custom_data";
$req = eio_custom("my_custom", EIO_PRI_DEFAULT, "my_custom_callback", $data);
var_dump($req);
eio_event_loop();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

resource(4) of type (EIO Request Descriptor)
string(14) "my_custom_data"
string(14) "my_custom_data"
int(2)
string(14) "my custom data"
int(1001)
eio_close
eio_dup2
Eio İşlevleri


Duplicate a file descriptor

eio_custom
eio_event_loop
Eio İşlevleri
PHP Manual

eio_dup2

(PECL eio >= 0.0.1dev)

eio_dup2 — Duplicate a file descriptor

Açıklama

resource eio_dup2 ( mixed $fd , mixed $fd2 [, int $pri = EIO_PRI_DEFAULT [, callable $callback = NULL [, mixed $data = NULL ]]] )

eio_dup2() duplicates file descriptor.

Değiştirgeler

fd

Source stream, Socket resource, or numeric file descriptor

fd2

Target stream, Socket resource, or numeric file descriptor

pri

The request priority: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, or NULL. If NULL passed, pri internally is set to EIO_PRI_DEFAULT.

callback

callback function is called when the request is done. It should match the following prototype:

void callback(mixed $data, int $result[, resource $req]);
data

is custom data passed to the request.

result

request-specific result value; basically, the value returned by corresponding system call.

req

is optional request resource which can be used with functions like eio_get_last_error()

data

Arbitrary variable passed to callback.

Dönen Değerler

eio_dup2() returns request resource on success or FALSE on error.

eio_custom
eio_event_loop
Eio İşlevleri


Polls libeio until all requests proceeded

eio_dup2
eio_fallocate
Eio İşlevleri
PHP Manual

eio_event_loop

(PECL eio >= 0.0.1dev)

eio_event_loop — Polls libeio until all requests proceeded

Açıklama

bool eio_event_loop ( void )

eio_event_loop() polls libeio until all requests proceeded.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

eio_event_loop() returns TRUE on success or FALSE on error.

Örnekler

Örnek 1 eio_event_loop() example

<?php
$temp_filename = "eio-temp-file.tmp";
touch($temp_filename);

/* Is called when eio_chmod() finished */
function my_chmod_callback($data, $result) {
    global $temp_filename;

    if ($result == 0 && !is_readable($temp_filename) && is_writable($temp_filename)) {
        echo "eio_chmod_ok";
    }

    @unlink($temp_filename);
}

eio_chmod($temp_filename, 0200, EIO_PRI_DEFAULT, "my_chmod_callback");
eio_event_loop();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

eio_chmod_ok

Ayrıca Bakınız

  • eio_poll
eio_dup2
eio_fallocate
Eio İşlevleri


Allows the caller to directly manipulate the allocated disk space for a file

eio_event_loop
eio_fchmod
Eio İşlevleri
PHP Manual

eio_fallocate

(PECL eio >= 0.0.1dev)

eio_fallocate — Allows the caller to directly manipulate the allocated disk space for a file

Açıklama

resource eio_fallocate ( mixed $fd , int $mode , int $offset , int $length [, int $pri = EIO_PRI_DEFAULT [, callable $callback = NULL [, mixed $data = NULL ]]] )

eio_fallocate() allows the caller to directly manipulate the allocated disk space for the file specified by fd file descriptor for the byte range starting at offset and continuing for length bytes.

Bilginize: File should be opened for writing

EIO_O_CREAT should be logically OR'd with EIO_O_WRONLY, or EIO_O_RDWR

Değiştirgeler

fd

Stream, Socket resource, or numeric file descriptor, e.g. returned by eio_open().

mode

Currently only one flag is supported for mode: EIO_FALLOC_FL_KEEP_SIZE (the same as POSIX constant FALLOC_FL_KEEP_SIZE).

offset

Specifies start of the byte range.

length

Specifies length the byte range.

pri

The request priority: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, or NULL. If NULL passed, pri internally is set to EIO_PRI_DEFAULT.

callback

callback function is called when the request is done. It should match the following prototype:

void callback(mixed $data, int $result[, resource $req]);
data

is custom data passed to the request.

result

request-specific result value; basically, the value returned by corresponding system call.

req

is optional request resource which can be used with functions like eio_get_last_error()

data

Arbitrary variable passed to callback.

Dönen Değerler

eio_fallocate() returns request resource on success or FALSE on error.

eio_event_loop
eio_fchmod
Eio İşlevleri


Change file permissions.

eio_fallocate
eio_fchown
Eio İşlevleri
PHP Manual

eio_fchmod

(PECL eio >= 0.0.1dev)

eio_fchmod — Change file permissions.

Açıklama

resource eio_fchmod ( mixed $fd , int $mode [, int $pri = EIO_PRI_DEFAULT [, callable $callback = NULL [, mixed $data = NULL ]]] )

eio_fchmod() changes permissions for the file specified by fd file descriptor.

Değiştirgeler

fd

Stream, Socket resource, or numeric file descriptor, e.g. returned by eio_open().

mode

The new permissions. E.g. 0644.

pri

The request priority: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, or NULL. If NULL passed, pri internally is set to EIO_PRI_DEFAULT.

callback

callback function is called when the request is done. It should match the following prototype:

void callback(mixed $data, int $result[, resource $req]);
data

is custom data passed to the request.

result

request-specific result value; basically, the value returned by corresponding system call.

req

is optional request resource which can be used with functions like eio_get_last_error()

data

Arbitrary variable passed to callback.

Dönen Değerler

eio_fchmod() returns request resource on success or FALSE on error.

Ayrıca Bakınız

  • eio_fchown
eio_fallocate
eio_fchown
Eio İşlevleri


Change file ownership

eio_fchmod
eio_fdatasync
Eio İşlevleri
PHP Manual

eio_fchown

(PECL eio >= 0.0.1dev)

eio_fchown — Change file ownership

Açıklama

resource eio_fchown ( mixed $fd , int $uid [, int $gid = -1 [, int $pri = EIO_PRI_DEFAULT [, callable $callback = NULL [, mixed $data = NULL ]]]] )

eio_fchown() changes ownership of the file specified by fd file descriptor.

Değiştirgeler

fd

Stream, Socket resource, or numeric file descriptor.

uid

User ID. Is ignored when equal to -1.

gid

Group ID. Is ignored when equal to -1.

pri

The request priority: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, or NULL. If NULL passed, pri internally is set to EIO_PRI_DEFAULT.

callback

callback function is called when the request is done. It should match the following prototype:

void callback(mixed $data, int $result[, resource $req]);
data

is custom data passed to the request.

result

request-specific result value; basically, the value returned by corresponding system call.

req

is optional request resource which can be used with functions like eio_get_last_error()

data

Arbitrary variable passed to callback.

Ayrıca Bakınız

  • eio_fchmod
eio_fchmod
eio_fdatasync
Eio İşlevleri


Synchronize a file's in-core state with storage device.

eio_fchown
eio_fstat
Eio İşlevleri
PHP Manual

eio_fdatasync

(PECL eio >= 0.0.1dev)

eio_fdatasync — Synchronize a file's in-core state with storage device.

Açıklama

resource eio_fdatasync ( mixed $fd [, int $pri = EIO_PRI_DEFAULT [, callable $callback = NULL [, mixed $data = NULL ]]] )

eio_fdatasync() synchronizes a file's in-core state with storage device.

Değiştirgeler

fd

Stream, Socket resource, or numeric file descriptor, e.g. returned by eio_open().

pri

The request priority: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, or NULL. If NULL passed, pri internally is set to EIO_PRI_DEFAULT.

callback

callback function is called when the request is done. It should match the following prototype:

void callback(mixed $data, int $result[, resource $req]);
data

is custom data passed to the request.

result

request-specific result value; basically, the value returned by corresponding system call.

req

is optional request resource which can be used with functions like eio_get_last_error()

data

Arbitrary variable passed to callback.

Dönen Değerler

eio_fdatasync() returns request resource on success or FALSE on error.

eio_fchown
eio_fstat
Eio İşlevleri


Get file status

eio_fdatasync
eio_fstatvfs
Eio İşlevleri
PHP Manual

eio_fstat

(PECL eio >= 0.0.1dev)

eio_fstat — Get file status

Açıklama

resource eio_fstat ( mixed $fd , int $pri , callable $callback [, mixed $data ] )

eio_fstat() returns file status information in result argument of callback

Değiştirgeler

fd

Stream, Socket resource, or numeric file descriptor.

pri

The request priority: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, or NULL. If NULL passed, pri internally is set to EIO_PRI_DEFAULT.

callback

callback function is called when the request is done. It should match the following prototype:

void callback(mixed $data, int $result[, resource $req]);
data

is custom data passed to the request.

result

request-specific result value; basically, the value returned by corresponding system call.

req

is optional request resource which can be used with functions like eio_get_last_error()

data

Arbitrary variable passed to callback.

Dönen Değerler

eio_busy() returns request resource on success or FALSE on error.

Örnekler

Örnek 1 eio_lstat() example

<?php
// Create temporary file
$tmp_filename = dirname(__FILE__) ."/eio-file.tmp";
touch($tmp_filename);

/* Is called when eio_fstat() done */
function my_res_cb($data, $result) {
 // Should output array with stat info
 var_dump($result);

 if ($data['fd']) {
  // Close temporary file
  eio_close($data['fd']);
  eio_event_loop();
 }
 // Remove temporary file
 @unlink($data['file']);
}

/* Is called when eio_open() done */
function my_open_cb($data, $result) {
 // Prepare data for callback
 $d = array(
  'fd'  => $result,
  'file'=> $data
 );
 // Request stat info
 eio_fstat($result, EIO_PRI_DEFAULT, "my_res_cb", $d);
 // Process request(s)
 eio_event_loop();
}

// Open temporary file
eio_open($tmp_filename, EIO_O_RDONLY, NULL, EIO_PRI_DEFAULT,
  "my_open_cb", $tmp_filename);
eio_event_loop();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(12) {
 ["st_dev"]=>
  int(2050)
  ["st_ino"]=>
  int(2489159)
  ["st_mode"]=>
  int(33188)
  ["st_nlink"]=>
  int(1)
  ["st_uid"]=>
  int(1000)
  ["st_gid"]=>
  int(100)
  ["st_rdev"]=>
  int(0)
  ["st_blksize"]=>
  int(4096)
  ["st_blocks"]=>
  int(0)
  ["st_atime"]=>
  int(1318239506)
  ["st_mtime"]=>
  int(1318239506)
  ["st_ctime"]=>
  int(1318239506)
}

Ayrıca Bakınız

  • eio_lstat
  • eio_stat
eio_fdatasync
eio_fstatvfs
Eio İşlevleri


Get file system statistics

eio_fstat
eio_fsync
Eio İşlevleri
PHP Manual

eio_fstatvfs

(PECL eio >= 0.0.1dev)

eio_fstatvfs — Get file system statistics

Açıklama

resource eio_fstatvfs ( mixed $fd , int $pri , callable $callback [, mixed $data ] )

eio_fstatvfs() returns file system statistics in result of callback.

Değiştirgeler

fd

A file descriptor of a file within the mounted file system.

pri

The request priority: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, or NULL. If NULL passed, pri internally is set to EIO_PRI_DEFAULT.

callback

callback function is called when the request is done. It should match the following prototype:

void callback(mixed $data, int $result[, resource $req]);
data

is custom data passed to the request.

result

request-specific result value; basically, the value returned by corresponding system call.

req

is optional request resource which can be used with functions like eio_get_last_error()

data

Arbitrary variable passed to callback.

Dönen Değerler

eio_fstatvfs() returns request resource on success or FALSE on error.

Ayrıca Bakınız

  • eio_statvfs
eio_fstat
eio_fsync
Eio İşlevleri


Synchronize a file's in-core state with storage device

eio_fstatvfs
eio_ftruncate
Eio İşlevleri
PHP Manual

eio_fsync

(PECL eio >= 0.0.1dev)

eio_fsync — Synchronize a file's in-core state with storage device

Açıklama

resource eio_fsync ( mixed $fd [, int $pri = EIO_PRI_DEFAULT [, callable $callback = NULL [, mixed $data = NULL ]]] )

Synchronize a file's in-core state with storage device

Değiştirgeler

fd

Stream, Socket resource, or numeric file descriptor.

pri

The request priority: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, or NULL. If NULL passed, pri internally is set to EIO_PRI_DEFAULT.

callback

callback function is called when the request is done. It should match the following prototype:

void callback(mixed $data, int $result[, resource $req]);
data

is custom data passed to the request.

result

request-specific result value; basically, the value returned by corresponding system call.

req

is optional request resource which can be used with functions like eio_get_last_error()

data

Arbitrary variable passed to callback.

Dönen Değerler

eio_fsync() returns request resource on success or FALSE on error.

Ayrıca Bakınız

  • eio_sync
eio_fstatvfs
eio_ftruncate
Eio İşlevleri


Truncate a file

eio_fsync
eio_futime
Eio İşlevleri
PHP Manual

eio_ftruncate

(PECL eio >= 0.0.1dev)

eio_ftruncate — Truncate a file

Açıklama

resource eio_ftruncate ( mixed $fd [, int $offset = 0 [, int $pri = EIO_PRI_DEFAULT [, callable $callback = NULL [, mixed $data = NULL ]]]] )

eio_ftruncate() causes a regular file referenced by fd file descriptor to be truncated to precisely length bytes.

Değiştirgeler

fd

Stream, Socket resource, or numeric file descriptor.

offset

Offset from beginning of the file

pri

The request priority: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, or NULL. If NULL passed, pri internally is set to EIO_PRI_DEFAULT.

callback

callback function is called when the request is done. It should match the following prototype:

void callback(mixed $data, int $result[, resource $req]);
data

is custom data passed to the request.

result

request-specific result value; basically, the value returned by corresponding system call.

req

is optional request resource which can be used with functions like eio_get_last_error()

data

Arbitrary variable passed to callback.

Dönen Değerler

eio_ftruncate() returns request resource on success or FALSE on error.

Ayrıca Bakınız

  • eio_truncate
eio_fsync
eio_futime
Eio İşlevleri


Change file last access and modification times

eio_ftruncate
eio_get_event_stream
Eio İşlevleri
PHP Manual

eio_futime

(PECL eio >= 0.0.1dev)

eio_futime — Change file last access and modification times

Açıklama

resource eio_futime ( mixed $fd , float $atime , float $mtime [, int $pri = EIO_PRI_DEFAULT [, callable $callback = NULL [, mixed $data = NULL ]]] )

eio_futime() changes file last access and modification times.

Değiştirgeler

fd

Stream, Socket resource, or numeric file descriptor, e.g. returned by eio_open()

atime

Access time

mtime

Modification time

pri

The request priority: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, or NULL. If NULL passed, pri internally is set to EIO_PRI_DEFAULT.

callback

callback function is called when the request is done. It should match the following prototype:

void callback(mixed $data, int $result[, resource $req]);
data

is custom data passed to the request.

result

request-specific result value; basically, the value returned by corresponding system call.

req

is optional request resource which can be used with functions like eio_get_last_error()

data

Arbitrary variable passed to callback.

Dönen Değerler

eio_futime() returns request resource on success or FALSE on error.

Ayrıca Bakınız

  • eio_utime
eio_ftruncate
eio_get_event_stream
Eio İşlevleri


Get stream representing a variable used in internal communications with libeio.

eio_futime
eio_get_last_error
Eio İşlevleri
PHP Manual

eio_get_event_stream

(PECL eio >= 0.3.1b)

eio_get_event_stream — Get stream representing a variable used in internal communications with libeio.

Açıklama

mixed eio_get_event_stream ( void )

eio_get_event_stream() acquires stream representing a variable used in internal communications with libeio. Could be used to bind with some event loop provided by other PECL extension, for example libevent.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

eio_get_event_stream() returns stream on success; otherwise, NULL

Örnekler

Örnek 1 Using eio with libevent

<?php
function my_eio_poll($fd, $events, $arg) {
    /* Some libevent regulation might go here .. */
    if (eio_nreqs()) {
        eio_poll();
    }
    /* .. and here */
}

function my_res_cb($d, $r) {
    var_dump($r); var_dump($d);
}

$base = event_base_new();
$event = event_new();

$fd = eio_get_event_stream();
var_dump($fd);

eio_nop(EIO_PRI_DEFAULT, "my_res_cb", "nop data");
eio_mkdir("/tmp/abc-eio-temp", 0750, EIO_PRI_DEFAULT, "my_res_cb", "mkdir data");
/* some other eio_* calls here ... */

// set event flags
event_set($event, $fd, EV_READ /*| EV_PERSIST*/, "my_eio_poll", array($event, $base));

// set event base
event_base_set($event, $base);

// enable event
event_add($event);

// start event loop
event_base_loop($base);

/* The same will be available via buffered libevent interface */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(3)
int(0)
string(8) "nop data"
int(0)
string(10) "mkdir data"
eio_futime
eio_get_last_error
Eio İşlevleri


Returns string describing the last error associated with a request resource

eio_get_event_stream
eio_grp_add
Eio İşlevleri
PHP Manual

eio_get_last_error

(PECL eio >= 1.0.0)

eio_get_last_error — Returns string describing the last error associated with a request resource

Açıklama

string eio_get_last_error ( resource $req )

eio_get_last_error() returns string describing the last error associated with req.

Değiştirgeler

req

The request resource

Dönen Değerler

eio_get_last_error() returns string describing the last error associated with the request resource specified by req.

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

eio_get_event_stream
eio_grp_add
Eio İşlevleri


Adds a request to the request group.

eio_get_last_error
eio_grp_cancel
Eio İşlevleri
PHP Manual

eio_grp_add

(PECL eio >= 0.0.1dev)

eio_grp_add — Adds a request to the request group.

Açıklama

void eio_grp_add ( resource $grp , resource $req )

eio_grp_add() adds a request to the request group.

Değiştirgeler

grp

The request group resource returned by eio_grp()

req

The request resource

Dönen Değerler

eio_grp_add() doesn't return a value.

Örnekler

Örnek 1 Grouping requests

<?php
/*
 * Create a group request to open, read and close a file
 */

// Create temporary file and write some bytes to it
$temp_filename = dirname(__FILE__) ."/eio-file.tmp";
$fp = fopen($temp_filename, "w");
fwrite($fp, "some data");
fclose($fp);

/* Is called when the group requests are done */
function my_grp_done($data, $result) {
 var_dump($result == 0);
 @unlink($data);
}

/* Is called when eio_open() done */
function my_grp_file_opened_callback($data, $result) {
 global $grp;

 // $result should contain the file descriptor
 var_dump($result > 0);

 // Create eio_read() request and add it to the group
 // Pass file descriptor to the callback
 $req = eio_read($result, 4, 0,
   EIO_PRI_DEFAULT, "my_grp_file_read_callback", $result);
 eio_grp_add($grp, $req);
}

/* Is called when eio_read() done */
function my_grp_file_read_callback($data, $result) {
 global $grp;

 // Read bytes
 var_dump($result);

 // Create eio_close() request and add it to the group
 // $data should contain the file descriptor
 $req = eio_close($data);
 eio_grp_add($grp, $req);
}

// Create request group
$grp = eio_grp("my_grp_done", $temp_filename);
var_dump($grp);

// Create eio_open() request and add it to the group
$req = eio_open($temp_filename, EIO_O_RDWR | EIO_O_APPEND , NULL,
  EIO_PRI_DEFAULT, "my_grp_file_opened_callback", NULL);
eio_grp_add($grp, $req);

// Process requests
eio_event_loop();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

resource(6) of type (EIO Group Descriptor)
bool(true)
string(4) "some"
bool(true)

Ayrıca Bakınız

  • eio_grp
  • eio_grp_cancel
  • eio_grp_limit
eio_get_last_error
eio_grp_cancel
Eio İşlevleri


Cancels a request group

eio_grp_add
eio_grp_limit
Eio İşlevleri
PHP Manual

eio_grp_cancel

(PECL eio >= 0.0.1dev)

eio_grp_cancel — Cancels a request group

Açıklama

void eio_grp_cancel ( resource $grp )

eio_grp_cancel() cancels a group request specified by grp request group resource.

Değiştirgeler

grp

The request group resource returned by eio_grp().

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • eio_grp
  • eio_grp_add
eio_grp_add
eio_grp_limit
Eio İşlevleri


Set group limit

eio_grp_cancel
eio_grp
Eio İşlevleri
PHP Manual

eio_grp_limit

(PECL eio >= 0.0.1dev)

eio_grp_limit — Set group limit

Açıklama

void eio_grp_limit ( resource $grp , int $limit )

Limit number of requests in the request group.

Değiştirgeler

grp

The request group resource.

limit

Number of requests in the group.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • eio_grp_add
eio_grp_cancel
eio_grp
Eio İşlevleri


Creates a request group.

eio_grp_limit
eio_init
Eio İşlevleri
PHP Manual

eio_grp

(PECL eio >= 0.0.1dev)

eio_grp — Creates a request group.

Açıklama

resource eio_grp ( callable $callback [, string $data = NULL ] )

eio_grp() creates a request group.

Değiştirgeler

callback

callback function is called when the request is done. It should match the following prototype:

void callback(mixed $data, int $result[, resource $req]);
data

is custom data passed to the request.

result

request-specific result value; basically, the value returned by corresponding system call.

req

is optional request resource which can be used with functions like eio_get_last_error()

data

Arbitrary variable passed to callback.

Dönen Değerler

eio_grp() returns request group resource on success or FALSE on error.

Örnekler

Örnek 1 eio_grp() example

<?php
$temp_filename = dirname(__FILE__) ."/eio-file.tmp";
$fp = fopen($temp_filename, "w");
fwrite($fp, "some data");
fclose($fp);
$my_file_fd = NULL;

/* Is called when the group requests are done */
function my_grp_done($data, $result) {
 // Remove the file, if it still exists
 @unlink($data);
}

/* Is called when the temporary file is opened */
function my_grp_file_opened_callback($data, $result) {
 global $my_file_fd, $grp;

 $my_file_fd = $result;

 $req = eio_read($my_file_fd, 4, 0,
   EIO_PRI_DEFAULT, "my_grp_file_read_callback");
 eio_grp_add($grp, $req);
}

/* Is called when the file is read */
function my_grp_file_read_callback($data, $result) {
 global $my_file_fd, $grp;

 var_dump($result);

 // Create request to close the file
 $req = eio_close($my_file_fd);

 // Add request to the group
 eio_grp_add($grp, $req);
}

// Create request group
$grp = eio_grp("my_grp_done", $temp_filename);

// Create request
$req = eio_open($temp_filename, EIO_O_RDWR | EIO_O_APPEND , NULL,
  EIO_PRI_DEFAULT, "my_grp_file_opened_callback", NULL);

// Add request to the group
eio_grp_add($grp, $req);

// Process requests
eio_event_loop();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(4) "some"

Ayrıca Bakınız

  • eio_grp_cancel
  • eio_grp_add
eio_grp_limit
eio_init
Eio İşlevleri


(Re-)initialize Eio

eio_grp
eio_link
Eio İşlevleri
PHP Manual

eio_init

(PECL eio = 1.0.0)

eio_init — (Re-)initialize Eio

Açıklama

void eio_init ( void )

eio_init() (re-)initializes Eio. It allocates memory for internal structures of libeio and Eio itself. You may call eio_init() before using Eio functions. Otherwise it will be called internally first time you invoke an Eio function in a process.

Uyarı

Bu kullanımı önerilmeyen özellik gelecekte kesinlikle KALDIRILACAKTIR. Since Eio 1.1.0 eio_init() is deprecated. In Eio 1.0.0 because of » libeio's restrictions you must call eio_init() in child process, if you fork one by any means. You have to avoid using Eio in parent process, if you use it in childs.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

eio_grp
eio_link
Eio İşlevleri


Create a hardlink for file

eio_init
eio_lstat
Eio İşlevleri
PHP Manual

eio_link

(PECL eio >= 0.0.1dev)

eio_link — Create a hardlink for file

Açıklama

resource eio_link ( string $path , string $new_path [, int $pri = EIO_PRI_DEFAULT [, callable $callback = NULL [, mixed $data = NULL ]]] )

eio_link() creates a hardlink new_path for a file specified by path.

Değiştirgeler

path

Source file path.

new_path

Target file path.

pri

The request priority: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, or NULL. If NULL passed, pri internally is set to EIO_PRI_DEFAULT.

callback

callback function is called when the request is done. It should match the following prototype:

void callback(mixed $data, int $result[, resource $req]);
data

is custom data passed to the request.

result

request-specific result value; basically, the value returned by corresponding system call.

req

is optional request resource which can be used with functions like eio_get_last_error()

data

Arbitrary variable passed to callback.

Dönen Değerler

Örnekler

Örnek 1 eio_link() example

<?php
$filename = dirname(__FILE__)."/symlink.dat";
touch($filename);
$link = dirname(__FILE__)."/symlink.link";
$hardlink = dirname(__FILE__)."/hardlink.link";

function my_hardlink_cb($data, $result) {
    global $link, $filename;
    var_dump(file_exists($data) && !is_link($data));
    @unlink($data);

    eio_symlink($filename, $link, EIO_PRI_DEFAULT, "my_symlink_cb", $link);
}

function my_symlink_cb($data, $result) {
    global $link, $filename;
    var_dump(file_exists($data) && is_link($data));

    if (!eio_readlink($data, EIO_PRI_DEFAULT, "my_readlink_cb", NULL)) {
        @unlink($link);
        @unlink($filename);
    }
}

function my_readlink_cb($data, $result) {
    global $filename, $link;
    var_dump($result);

    @unlink($link);
    @unlink($filename);
}

eio_link($filename, $hardlink, EIO_PRI_DEFAULT, "my_hardlink_cb", $hardlink);
eio_event_loop();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(true)
bool(true)
string(%d) "%ssymlink.dat"

Ayrıca Bakınız

  • eio_symlink
eio_init
eio_lstat
Eio İşlevleri


Get file status

eio_link
eio_mkdir
Eio İşlevleri
PHP Manual

eio_lstat

(PECL eio >= 0.0.1dev)

eio_lstat — Get file status

Açıklama

resource eio_lstat ( string $path , int $pri , callable $callback [, mixed $data = NULL ] )

eio_lstat() returns file status information in result argument of callback

Değiştirgeler

path

The file path

pri

The request priority: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, or NULL. If NULL passed, pri internally is set to EIO_PRI_DEFAULT.

callback

callback function is called when the request is done. It should match the following prototype:

void callback(mixed $data, int $result[, resource $req]);
data

is custom data passed to the request.

result

request-specific result value; basically, the value returned by corresponding system call.

req

is optional request resource which can be used with functions like eio_get_last_error()

data

Arbitrary variable passed to callback.

Dönen Değerler

eio_lstat() returns request resource on success or FALSE on error.

Örnekler

Örnek 1 eio_lstat() example

<?php
$tmp_filename = dirname(__FILE__). "/eio-file.tmp";
touch($tmp_filename);

function my_res_cb($data, $result) {
    var_dump($data);
    var_dump($result);
}

function my_open_cb($data, $result) {
    eio_close($result);
    eio_event_loop();

    @unlink($data);
}

eio_lstat($tmp_filename, EIO_PRI_DEFAULT, "my_res_cb", "eio_lstat");
eio_open($tmp_filename, EIO_O_RDONLY, NULL,
 EIO_PRI_DEFAULT, "my_open_cb", $tmp_filename);
eio_event_loop();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(9) "eio_lstat"
array(12) {
 ["st_dev"]=>
  int(2050)
  ["st_ino"]=>
  int(2099197)
  ["st_mode"]=>
  int(33188)
  ["st_nlink"]=>
  int(1)
  ["st_uid"]=>
  int(1000)
  ["st_gid"]=>
  int(100)
  ["st_rdev"]=>
  int(0)
  ["st_blksize"]=>
  int(4096)
  ["st_blocks"]=>
  int(0)
  ["st_atime"]=>
  int(1318235777)
  ["st_mtime"]=>
  int(1318235777)
  ["st_ctime"]=>
  int(1318235777)
}

Ayrıca Bakınız

  • eio_stat
  • eio_fstat
eio_link
eio_mkdir
Eio İşlevleri


Create directory

eio_lstat
eio_mknod
Eio İşlevleri
PHP Manual

eio_mkdir

(PECL eio >= 0.0.1dev)

eio_mkdir — Create directory

Açıklama

resource eio_mkdir ( string $path , int $mode [, int $pri = EIO_PRI_DEFAULT [, callable $callback = NULL [, mixed $data = NULL ]]] )

eio_mkdir() creates directory with specified access mode.

Değiştirgeler

path

Path for the new directory.

mode

Access mode, e.g. 0755

pri

The request priority: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, or NULL. If NULL passed, pri internally is set to EIO_PRI_DEFAULT.

callback

callback function is called when the request is done. It should match the following prototype:

void callback(mixed $data, int $result[, resource $req]);
data

is custom data passed to the request.

result

request-specific result value; basically, the value returned by corresponding system call.

req

is optional request resource which can be used with functions like eio_get_last_error()

data

Arbitrary variable passed to callback.

Dönen Değerler

eio_mkdir() returns request resource on success or FALSE on error.

Örnekler

Örnek 1 eio_mkdir() example

<?php
$temp_dirname = "eio-temp-dir";

/* Is called when eio_mkdir() finishes */
function my_mkdir_callback($data, $result) {
 if ($result == 0 && is_dir($temp_dirname)
   && !is_readable($temp_dirname)
   && is_writable($temp_dirname)) {
  echo "eio_mkdir_ok";
 }

 // Remove directory
    if (file_exists($data))
        rmdir($temp_dirname);
}

// Create directory with access mode 0300
eio_mkdir($temp_dirname, 0300, EIO_PRI_DEFAULT, "my_mkdir_callback", $temp_dirname);
eio_event_loop();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

eio_mkdir_ok

Ayrıca Bakınız

  • eio_rmdir
eio_lstat
eio_mknod
Eio İşlevleri


Create a special or ordinary file.

eio_mkdir
eio_nop
Eio İşlevleri
PHP Manual

eio_mknod

(PECL eio >= 0.0.1dev)

eio_mknod — Create a special or ordinary file.

Açıklama

resource eio_mknod ( string $path , int $mode , int $dev [, int $pri = EIO_PRI_DEFAULT [, callable $callback = NULL [, mixed $data = NULL ]]] )

eio_mknod() creates ordinary or special(often) file.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

path

Path for the new node(file).

mode

Specifies both the permissions to use and the type of node to be created. It should be a combination (using bitwise OR) of one of the file types listed below and the permissions for the new node(e.g. 0640). Possible file types are: EIO_S_IFREG(regular file), EIO_S_IFCHR(character file), EIO_S_IFBLK(block special file), EIO_S_IFIFO(FIFO - named pipe) and EIO_S_IFSOCK(UNIX domain socket). To specify permissions EIO_S_I* constants could be used.

dev

If the file type is EIO_S_IFCHR or EIO_S_IFBLK then dev specifies the major and minor numbers of the newly created device special file. Otherwise dev ignored. See mknod(2) man page for details.

pri

The request priority: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, or NULL. If NULL passed, pri internally is set to EIO_PRI_DEFAULT.

callback

callback function is called when the request is done. It should match the following prototype:

void callback(mixed $data, int $result[, resource $req]);
data

is custom data passed to the request.

result

request-specific result value; basically, the value returned by corresponding system call.

req

is optional request resource which can be used with functions like eio_get_last_error()

data

Arbitrary variable passed to callback.

Dönen Değerler

eio_mknod() returns request resource on success or FALSE on error.

Örnekler

Örnek 1 eio_mknod() example

<?php
// FIFO name
$temp_filename = "/tmp/eio-temp-fifo";

/* Is called when eio_mknod() finishes */
function my_mknod_callback($data, $result) {
    $s = stat($data);
    var_dump($s);

    if ($result == 0) {
        echo "eio_mknod_ok";
    }

    @unlink($data);
}

eio_mknod($temp_filename, EIO_S_IFIFO, 0,
    EIO_PRI_DEFAULT, "my_mknod_callback", $temp_filename);
eio_event_loop();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(26) {
  [0]=>
  int(17)
  [1]=>
  int(2337608)
  [2]=>
  int(4096)
  [3]=>
  int(1)
  [4]=>
  int(1000)
  [5]=>
  int(100)
  [6]=>
  int(0)
  [7]=>
  int(0)
  [8]=>
  int(1318241261)
  [9]=>
  int(1318241261)
  [10]=>
  int(1318241261)
  [11]=>
  int(4096)
  [12]=>
  int(0)
  ["dev"]=>
  int(17)
  ["ino"]=>
  int(2337608)
  ["mode"]=>
  int(4096)
  ["nlink"]=>
  int(1)
  ["uid"]=>
  int(1000)
  ["gid"]=>
  int(100)
  ["rdev"]=>
  int(0)
  ["size"]=>
  int(0)
  ["atime"]=>
  int(1318241261)
  ["mtime"]=>
  int(1318241261)
  ["ctime"]=>
  int(1318241261)
  ["blksize"]=>
  int(4096)
  ["blocks"]=>
  int(0)
}
eio_mknod_ok

Ayrıca Bakınız

  • eio_open
eio_mkdir
eio_nop
Eio İşlevleri


Does nothing, except go through the whole request cycle.

eio_mknod
eio_npending
Eio İşlevleri
PHP Manual

eio_nop

(PECL eio >= 0.0.1dev)

eio_nop — Does nothing, except go through the whole request cycle.

Açıklama

resource eio_nop ([ int $pri = EIO_PRI_DEFAULT [, callable $callback = NULL [, mixed $data = NULL ]]] )

eio_nop() does nothing, except go through the whole request cycle. Could be useful in debugging.

Değiştirgeler

pri

The request priority: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, or NULL. If NULL passed, pri internally is set to EIO_PRI_DEFAULT.

callback

callback function is called when the request is done. It should match the following prototype:

void callback(mixed $data, int $result[, resource $req]);
data

is custom data passed to the request.

result

request-specific result value; basically, the value returned by corresponding system call.

req

is optional request resource which can be used with functions like eio_get_last_error()

data

Arbitrary variable passed to callback.

Dönen Değerler

eio_nop() returns request resource on success or FALSE on error.

Ayrıca Bakınız

  • eio_busy
eio_mknod
eio_npending
Eio İşlevleri


Returns number of finished, but unhandled requests

eio_nop
eio_nready
Eio İşlevleri
PHP Manual

eio_npending

(PECL eio >= 0.0.1dev)

eio_npending — Returns number of finished, but unhandled requests

Açıklama

int eio_npending ( void )

eio_npending() returns number of finished, but unhandled requests

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

eio_npending() returns number of finished, but unhandled requests.

Ayrıca Bakınız

  • eio_nreqs
  • eio_nready
  • eio_nthreads
eio_nop
eio_nready
Eio İşlevleri


Returns number of not-yet handled requests

eio_npending
eio_nreqs
Eio İşlevleri
PHP Manual

eio_nready

(PECL eio >= 0.0.1dev)

eio_nready — Returns number of not-yet handled requests

Açıklama

int eio_nready ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

eio_nready() returns number of not-yet handled requests

Ayrıca Bakınız

  • eio_nreqs
  • eio_nready
  • eio_nthreads
eio_npending
eio_nreqs
Eio İşlevleri


Returns number of requests to be processed

eio_nready
eio_nthreads
Eio İşlevleri
PHP Manual

eio_nreqs

(PECL eio >= 0.0.1dev)

eio_nreqs — Returns number of requests to be processed

Açıklama

int eio_nreqs ( void )

eio_nreqs() could be called in a custom loop calling eio_poll().

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

eio_nreqs() returns number of requests to be processed.

Örnekler

Örnek 1 eio_nreqs() example

<?php
function res_cb($data, $result) {
    var_dump($data);
    var_dump($result);
}

eio_nop(EIO_PRI_DEFAULT, "res_cb", "1");
eio_nop(EIO_PRI_DEFAULT, "res_cb", "2");
eio_nop(EIO_PRI_DEFAULT, "res_cb", "3");

while (eio_nreqs()) {
    eio_poll();
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(1) "1"
int(0)
string(1) "3"
int(0)
string(1) "2"
int(0)

Ayrıca Bakınız

  • eio_poll
  • eio_nready
eio_nready
eio_nthreads
Eio İşlevleri


Returns number of threads currently in use

eio_nreqs
eio_open
Eio İşlevleri
PHP Manual

eio_nthreads

(PECL eio >= 0.0.1dev)

eio_nthreads — Returns number of threads currently in use

Açıklama

int eio_nthreads ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

eio_nthreads() returns number of threads currently in use.

Ayrıca Bakınız

  • eio_npending
  • eio_nready
  • eio_nreqs
eio_nreqs
eio_open
Eio İşlevleri


Opens a file

eio_nthreads
eio_poll
Eio İşlevleri
PHP Manual

eio_open

(PECL eio >= 0.0.1dev)

eio_open — Opens a file

Açıklama

resource eio_open ( string $path , int $flags , int $mode , int $pri , callable $callback [, mixed $data = NULL ] )

eio_open() opens file specified by path in access mode mode with

Değiştirgeler

path

Path of the file to be opened.

Uyarı

In some SAPIs(e.g. PHP-FPM) it could fail, if you don't specify full path.

flags

One of EIO_O_* constants, or their combinations. EIO_O_* constants have the same meaning, as their corresponding O_* counterparts defined in fnctl.h C header file. Default is EIO_O_RDWR.

mode

One of EIO_S_I* constants, or their combination (via bitwise OR operator). The constants have the same meaning as their S_I* counterparts defined in » sys/stat.h C header file. Required, if a file is created. Otherwise ignored.

pri

The request priority: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, or NULL. If NULL passed, pri internally is set to EIO_PRI_DEFAULT.

callback

callback function is called when the request is done. It should match the following prototype:

void callback(mixed $data, int $result[, resource $req]);
data

is custom data passed to the request.

result

request-specific result value; basically, the value returned by corresponding system call.

req

is optional request resource which can be used with functions like eio_get_last_error()

data

Arbitrary variable passed to callback.

Dönen Değerler

eio_open() returns file descriptor in result argument of callback on success; otherwise, result is equal to -1.

Örnekler

Örnek 1 eio_open() example

<?php
$temp_filename = "eio-temp-file.tmp";

/* Is called when eio_close() finishes */
function my_close_cb($data, $result) {
 // Zero indicates success
    var_dump($result == 0);
 @unlink($data);
}

/* Is called when eio_open() finishes */
function my_file_opened_callback($data, $result) {
 // $result should contain the file descriptor
    var_dump($result > 0);

    if ($result > 0) {
  // Close the file
        eio_close($result, EIO_PRI_DEFAULT, "my_close_cb", $data);
        eio_event_loop();
    }
}

// Create new file for reading and writing
// Deny group and others to do anything with that file
eio_open($temp_filename, EIO_O_CREAT | EIO_O_RDWR, EIO_S_IRUSR | EIO_S_IWUSR,
  EIO_PRI_DEFAULT, "my_file_opened_callback", $temp_filename);
eio_event_loop();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(true)
bool(true)

Ayrıca Bakınız

  • eio_mknod
eio_nthreads
eio_poll
Eio İşlevleri


Can be to be called whenever there are pending requests that need finishing.

eio_open
eio_read
Eio İşlevleri
PHP Manual

eio_poll

(PECL eio >= 0.0.1dev)

eio_poll — Can be to be called whenever there are pending requests that need finishing.

Açıklama

int eio_poll ( void )

eio_poll() can be used to implement special event loop. For this eio_nreqs() could be used to test if there are unprocessed requests.

Bilginize:

Applicable only when implementing userspace event loop.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

If any request invocation returns a non-zero value, returns that value. Otherwise, it returns 0.

Örnekler

Örnek 1 eio_poll() example

<?php
function res_cb($data, $result) {
    var_dump($data);
    var_dump($result);
}

eio_nop(EIO_PRI_DEFAULT, "res_cb", "1");
eio_nop(EIO_PRI_DEFAULT, "res_cb", "2");
eio_nop(EIO_PRI_DEFAULT, "res_cb", "3");

while (eio_nreqs()) {
    // Some specific IPC or so
    eio_poll();
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(1) "1"
int(0)
string(1) "3"
int(0)
string(1) "2"
int(0)

Ayrıca Bakınız

  • eio_nreqs
eio_open
eio_read
Eio İşlevleri


Read from a file descriptor at given offset.

eio_poll
eio_readahead
Eio İşlevleri
PHP Manual

eio_read

(PECL eio >= 0.0.1dev)

eio_read — Read from a file descriptor at given offset.

Açıklama

resource eio_read ( mixed $fd , int $length , int $offset , int $pri , callable $callback [, mixed $data = NULL ] )

eio_read() reads up to length bytes from fd file descriptor at offset. The read bytes are stored in result argument of callback.

Değiştirgeler

fd

Stream, Socket resource, or numeric file descriptor

length

Maximum number of bytes to read.

offset

Offset within the file.

pri

The request priority: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, or NULL. If NULL passed, pri internally is set to EIO_PRI_DEFAULT.

callback

callback function is called when the request is done. It should match the following prototype:

void callback(mixed $data, int $result[, resource $req]);
data

is custom data passed to the request.

result

request-specific result value; basically, the value returned by corresponding system call.

req

is optional request resource which can be used with functions like eio_get_last_error()

data

Arbitrary variable passed to callback.

Dönen Değerler

eio_read() stores read bytes in result argument of callback function.

Örnekler

Örnek 1 eio_read() example

<?php
// Open a temporary file and write some bytes there
$temp_filename = "eio-temp-file.tmp";
$fp = fopen($temp_filename, "w");
fwrite($fp, "1234567890");
fclose($fp);

/* Is called when eio_read() is done */
function my_read_cb($data, $result) {
    global $temp_filename;

 // Output read bytes
    var_dump($result);

 // Close file
    eio_close($data);
    eio_event_loop();

 // Remove temporary file
    @unlink($temp_filename);
}

/* Is called when eio_open() is done */
function my_file_opened_callback($data, $result) {
 // $result should contain the file descriptor
    if ($result > 0) {
  // Read 5 bytes starting from third
        eio_read($result, 5, 2, EIO_PRI_DEFAULT, "my_read_cb", $result);
        eio_event_loop();
    } else {
  // eio_open() failed
        unlink($data);
    }
}

// Open the file for reading and writing
eio_open($temp_filename, EIO_O_RDWR, NULL,
    EIO_PRI_DEFAULT, "my_file_opened_callback", $temp_filename);
eio_event_loop();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(5) "34567"

Ayrıca Bakınız

  • eio_open
  • eio_write
  • eio_close
  • eio_event_loop
eio_poll
eio_readahead
Eio İşlevleri


Perform file readahead into page cache

eio_read
eio_readdir
Eio İşlevleri
PHP Manual

eio_readahead

(PECL eio >= 0.0.1dev)

eio_readahead — Perform file readahead into page cache

Açıklama

resource eio_readahead ( mixed $fd , int $offset , int $length [, int $pri = EIO_PRI_DEFAULT [, callable $callback = NULL [, mixed $data = NULL ]]] )

eio_readahead() populates the page cache with data from a file so that subsequent reads from that file will not block on disk I/O. See READAHEAD(2) man page for details.

Değiştirgeler

fd

Stream, Socket resource, or numeric file descriptor

offset

Starting point from which data is to be read.

length

Number of bytes to be read.

pri

The request priority: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, or NULL. If NULL passed, pri internally is set to EIO_PRI_DEFAULT.

callback

callback function is called when the request is done. It should match the following prototype:

void callback(mixed $data, int $result[, resource $req]);
data

is custom data passed to the request.

result

request-specific result value; basically, the value returned by corresponding system call.

req

is optional request resource which can be used with functions like eio_get_last_error()

data

Arbitrary variable passed to callback.

Dönen Değerler

eio_readahead() returns request resource on success or FALSE on error.

eio_read
eio_readdir
Eio İşlevleri


Reads through a whole directory

eio_readahead
eio_readlink
Eio İşlevleri
PHP Manual

eio_readdir

(PECL eio >= 0.0.1dev)

eio_readdir — Reads through a whole directory

Açıklama

resource eio_readdir ( string $path , int $flags , int $pri , callable $callback [, string $data = NULL ] )

Reads through a whole directory(via the opendir, readdir and closedir system calls) and returns either the names or an array in result argument of callback function, depending on the flags argument.

Değiştirgeler

path

Directory path.

flags

Combination of EIO_READDIR_* constants.

pri

The request priority: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, or NULL. If NULL passed, pri internally is set to EIO_PRI_DEFAULT.

callback

callback function is called when the request is done. It should match the following prototype:

void callback(mixed $data, int $result[, resource $req]);
data

is custom data passed to the request.

result

request-specific result value; basically, the value returned by corresponding system call.

req

is optional request resource which can be used with functions like eio_get_last_error()

data

Arbitrary variable passed to callback.

Dönen Değerler

eio_readdir() returns request resource on success, or FALSE on error. Sets result argument of callback function according to flags:

EIO_READDIR_DENTS (integer)
eio_readdir() flag. If specified, the result argument of the callback becomes an array with the following keys: 'names' - array of directory names 'dents' - array of struct eio_dirent-like arrays having the following keys each: 'name' - the directory name; 'type' - one of EIO_DT_* constants; 'inode' - the inode number, if available, otherwise unspecified;
EIO_READDIR_DIRS_FIRST (integer)
When this flag is specified, the names will be returned in an order where likely directories come first, in optimal stat order.
EIO_READDIR_STAT_ORDER (integer)
When this flag is specified, then the names will be returned in an order suitable for stat'ing each one. When planning to stat() all files in the given directory, the returned order will likely be fastest.
EIO_READDIR_FOUND_UNKNOWN (integer)

Node types:

EIO_DT_UNKNOWN (integer)
Unknown node type(very common). Further stat() needed.
EIO_DT_FIFO (integer)
FIFO node type
EIO_DT_CHR (integer)
Node type
EIO_DT_MPC (integer)
Multiplexed char device (v7+coherent) node type
EIO_DT_DIR (integer)
Directory node type
EIO_DT_NAM (integer)
Xenix special named file node type
EIO_DT_BLK (integer)
Node type
EIO_DT_MPB (integer)
Multiplexed block device (v7+coherent)
EIO_DT_REG (integer)
Node type
EIO_DT_NWK (integer)
EIO_DT_CMP (integer)
HP-UX network special node type
EIO_DT_LNK (integer)
Link node type
EIO_DT_SOCK (integer)
Socket node type
EIO_DT_DOOR (integer)
Solaris door node type
EIO_DT_WHT (integer)
Node type
EIO_DT_MAX (integer)
Highest node type value

Örnekler

Örnek 1 eio_readdir() example

<?php
/* Is called when eio_readdir() finishes */
function my_readdir_callback($data, $result) {
    echo __FUNCTION__, " called\n";
    echo "data: "; var_dump($data);
    echo "result: "; var_dump($result);
    echo "\n";
}

eio_readdir("/var/spool/news", EIO_READDIR_STAT_ORDER | EIO_READDIR_DIRS_FIRST,
  EIO_PRI_DEFAULT, "my_readdir_callback");
eio_event_loop();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

my_readdir_callback called
data: NULL
result: array(2) {
 ["names"]=>
  array(7) {
   [0]=>
    string(7) "archive"
    [1]=>
    string(8) "articles"
    [2]=>
    string(8) "incoming"
    [3]=>
    string(7) "innfeed"
    [4]=>
    string(8) "outgoing"
    [5]=>
    string(8) "overview"
    [6]=>
    string(3) "tmp"
  }
 ["dents"]=>
  array(7) {
   [0]=>
    array(3)
    {
     ["name"]=>
      string(7)
      "archive"
      ["type"]=>
      int(4)
      ["inode"]=>
      int(393265)
    }
   [1]=>
    array(3)
    {
     ["name"]=>
      string(8)
      "articles"
      ["type"]=>
      int(4)
      ["inode"]=>
      int(393266)
    }
   [2]=>
    array(3)
    {
     ["name"]=>
      string(8)
      "incoming"
      ["type"]=>
      int(4)
      ["inode"]=>
      int(393267)
    }
   [3]=>
    array(3)
    {
     ["name"]=>
      string(7)
      "innfeed"
      ["type"]=>
      int(4)
      ["inode"]=>
      int(393269)
    }
   [4]=>
    array(3)
    {
     ["name"]=>
      string(8)
      "outgoing"
      ["type"]=>
      int(4)
      ["inode"]=>
      int(393270)
    }
   [5]=>
    array(3)
    {
     ["name"]=>
      string(8)
      "overview"
      ["type"]=>
      int(4)
      ["inode"]=>
      int(393271)
    }
   [6]=>
    array(3)
    {
     ["name"]=>
      string(3)
      "tmp"
      ["type"]=>
      int(4)
      ["inode"]=>
      int(393272)
    }
  }
}
eio_readahead
eio_readlink
Eio İşlevleri


Read value of a symbolic link.

eio_readdir
eio_realpath
Eio İşlevleri
PHP Manual

eio_readlink

(PECL eio >= 0.0.1dev)

eio_readlink — Read value of a symbolic link.

Açıklama

resource eio_readlink ( string $path , int $pri , callable $callback [, string $data = NULL ] )

Değiştirgeler

path

Source symbolic link path

pri

The request priority: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, or NULL. If NULL passed, pri internally is set to EIO_PRI_DEFAULT.

callback

callback function is called when the request is done. It should match the following prototype:

void callback(mixed $data, int $result[, resource $req]);
data

is custom data passed to the request.

result

request-specific result value; basically, the value returned by corresponding system call.

req

is optional request resource which can be used with functions like eio_get_last_error()

data

Arbitrary variable passed to callback.

Dönen Değerler

eio_readlink() returns request resource on success or FALSE on error.

Örnekler

Örnek 1 eio_readlink() example

<?php
$filename = dirname(__FILE__)."/symlink.dat";
touch($filename);
$link = dirname(__FILE__)."/symlink.link";
$hardlink = dirname(__FILE__)."/hardlink.link";

function my_hardlink_cb($data, $result) {
    global $link, $filename;
    var_dump(file_exists($data) && !is_link($data));
    @unlink($data);

    eio_symlink($filename, $link, EIO_PRI_DEFAULT, "my_symlink_cb", $link);
}

function my_symlink_cb($data, $result) {
    global $link, $filename;
    var_dump(file_exists($data) && is_link($data));

    if (!eio_readlink($data, EIO_PRI_DEFAULT, "my_readlink_cb", NULL)) {
        @unlink($link);
        @unlink($filename);
    }
}

function my_readlink_cb($data, $result) {
    global $filename, $link;
    var_dump($result);

    @unlink($link);
    @unlink($filename);
}

eio_link($filename, $hardlink, EIO_PRI_DEFAULT, "my_hardlink_cb", $hardlink);
eio_event_loop();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(true)
bool(true)
string(16) "/tmp/symlink.dat"

Ayrıca Bakınız

  • eio_symlink
eio_readdir
eio_realpath
Eio İşlevleri


Get the canonicalized absolute pathname.

eio_readlink
eio_rename
Eio İşlevleri
PHP Manual

eio_realpath

(PECL eio >= 0.0.1dev)

eio_realpath — Get the canonicalized absolute pathname.

Açıklama

resource eio_realpath ( string $path , int $pri , callable $callback [, string $data = NULL ] )

eio_realpath() returns the canonicalized absolute pathname in result argument of callback function.

Değiştirgeler

path

Short pathname

pri

callback

data

Dönen Değerler

Örnekler

Örnek 1 eio_realpath() example

<?php
var_dump(getcwd());

function my_realpath_allback($data, $result) {
    var_dump($result);
}

eio_realpath("../", EIO_PRI_DEFAULT, "my_realpath_allback");
eio_event_loop();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(12) "/home/ruslan"
string(5) "/home"
eio_readlink
eio_rename
Eio İşlevleri


Change the name or location of a file.

eio_realpath
eio_rmdir
Eio İşlevleri
PHP Manual

eio_rename

(PECL eio >= 0.0.1dev)

eio_rename — Change the name or location of a file.

Açıklama

resource eio_rename ( string $path , string $new_path [, int $pri = EIO_PRI_DEFAULT [, callable $callback = NULL [, mixed $data = NULL ]]] )

eio_rename() renames or moves a file to new location.

Değiştirgeler

path

Source path

new_path

Target path

pri

The request priority: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, or NULL. If NULL passed, pri internally is set to EIO_PRI_DEFAULT.

callback

callback function is called when the request is done. It should match the following prototype:

void callback(mixed $data, int $result[, resource $req]);
data

is custom data passed to the request.

result

request-specific result value; basically, the value returned by corresponding system call.

req

is optional request resource which can be used with functions like eio_get_last_error()

data

Arbitrary variable passed to callback.

Dönen Değerler

eio_rename() returns request resource on success or FALSE on error.

Örnekler

Örnek 1 eio_rename() example

<?php
$filename = dirname(__FILE__)."/eio-temp-file.dat";
touch($filename);
$new_filename = dirname(__FILE__)."/eio-temp-file-new.dat";

function my_rename_cb($data, $result) {
    global $filename, $new_filename;

    if ($result == 0 && !file_exists($filename) && file_exists($new_filename)) {
        @unlink($new_filename);
        echo "eio_rename_ok";
    } else {
        @unlink($filename);
    }
}

eio_rename($filename, $new_filename, EIO_PRI_DEFAULT, "my_rename_cb", $filename);
eio_event_loop();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

eio_rename_ok
eio_realpath
eio_rmdir
Eio İşlevleri


Remove a directory

eio_rename
eio_seek
Eio İşlevleri
PHP Manual

eio_rmdir

(PECL eio >= 0.0.1dev)

eio_rmdir — Remove a directory

Açıklama

resource eio_rmdir ( string $path [, int $pri = EIO_PRI_DEFAULT [, callable $callback = NULL [, mixed $data = NULL ]]] )

eio_rmdir() removes a directory.

Değiştirgeler

path

Directory path

pri

The request priority: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, or NULL. If NULL passed, pri internally is set to EIO_PRI_DEFAULT.

callback

callback function is called when the request is done. It should match the following prototype:

void callback(mixed $data, int $result[, resource $req]);
data

is custom data passed to the request.

result

request-specific result value; basically, the value returned by corresponding system call.

req

is optional request resource which can be used with functions like eio_get_last_error()

data

Arbitrary variable passed to callback.

Dönen Değerler

eio_rmdir() returns request resource on success or FALSE on error.

Örnekler

Örnek 1 eio_rmdir() example

<?php
$temp_dirname = "eio-temp-dir";
mkdir($temp_dirname);

function my_rmdir_callback($data, $result) {
    if ($result == 0 && !file_exists($data)) {
        echo "eio_rmdir_ok";
    } else if (file_exists($data)) {
        rmdir($data);
    }
}

eio_rmdir($temp_dirname, EIO_PRI_DEFAULT, "my_rmdir_callback", $temp_dirname);
eio_event_loop();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

eio_rmdir_ok

Ayrıca Bakınız

  • eio_mkdir
eio_rename
eio_seek
Eio İşlevleri


Repositions the offset of the open file associated with the fd argument to the argument offset according to the directive whence

eio_rmdir
eio_sendfile
Eio İşlevleri
PHP Manual

eio_seek

(PECL eio >= 0.5.0b)

eio_seek — Repositions the offset of the open file associated with the fd argument to the argument offset according to the directive whence

Açıklama

resource eio_seek ( mixed $fd , int $offset , int $whence [, int $pri = EIO_PRI_DEFAULT [, callable $callback = NULL [, mixed $data = NULL ]]] )

eio_seek() repositions the offset of the open file associated with stream, Socket resource, or file descriptor specified by fd to the argument offset according to the directive whence as follows:

  • EIO_SEEK_SET - Set position equal to offset bytes.
  • EIO_SEEK_CUR - Set position to current location plus offset.
  • EIO_SEEK_END - Set position to end-of-file plus offset.

Değiştirgeler

fd

Stream, Socket resource, or numeric file descriptor

offset

Starting point from which data is to be read.

length

Number of bytes to be read.

pri

The request priority: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, or NULL. If NULL passed, pri internally is set to EIO_PRI_DEFAULT.

callback

callback function is called when the request is done. It should match the following prototype:

void callback(mixed $data, int $result[, resource $req]);
data

is custom data passed to the request.

result

request-specific result value; basically, the value returned by corresponding system call.

req

is optional request resource which can be used with functions like eio_get_last_error()

data

Arbitrary variable passed to callback.

Dönen Değerler

eio_seek() returns request resource on success or FALSE on error.

eio_rmdir
eio_sendfile
Eio İşlevleri


Transfer data between file descriptors

eio_seek
eio_set_max_idle
Eio İşlevleri
PHP Manual

eio_sendfile

(PECL eio >= 0.0.1dev)

eio_sendfile — Transfer data between file descriptors

Açıklama

resource eio_sendfile ( mixed $out_fd , mixed $in_fd , int $offset , int $length [, int $pri [, callable $callback [, string $data ]]] )

eio_sendfile() copies data between one file descriptor and another. See SENDFILE(2) man page for details.

Değiştirgeler

out_fd

Output stream, Socket resource, or file descriptor. Should be opened for writing.

in_fd

Input stream, Socket resource, or file descriptor. Should be opened for reading.

offset

Offset within the source file.

length

Number of bytes to copy.

pri

The request priority: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, or NULL. If NULL passed, pri internally is set to EIO_PRI_DEFAULT.

callback

callback function is called when the request is done. It should match the following prototype:

void callback(mixed $data, int $result[, resource $req]);
data

is custom data passed to the request.

result

request-specific result value; basically, the value returned by corresponding system call.

req

is optional request resource which can be used with functions like eio_get_last_error()

data

Arbitrary variable passed to callback.

Dönen Değerler

eio_sendfile() returns request resource on success or FALSE on error.

eio_seek
eio_set_max_idle
Eio İşlevleri


Set maximum number of idle threads.

eio_sendfile
eio_set_max_parallel
Eio İşlevleri
PHP Manual

eio_set_max_idle

(PECL eio >= 0.0.1dev)

eio_set_max_idle — Set maximum number of idle threads.

Açıklama

void eio_set_max_idle ( int $nthreads )

Değiştirgeler

nthreads

Number of idle threads.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • eio_set_min_parallel
  • eio_set_max_parallel
eio_sendfile
eio_set_max_parallel
Eio İşlevleri


Set maximum parallel threads

eio_set_max_idle
eio_set_max_poll_reqs
Eio İşlevleri
PHP Manual

eio_set_max_parallel

(PECL eio >= 0.0.1dev)

eio_set_max_parallel — Set maximum parallel threads

Açıklama

void eio_set_max_parallel ( int $nthreads )

Değiştirgeler

nthreads

Number of parallel threads

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • eio_set_min_parallel
eio_set_max_idle
eio_set_max_poll_reqs
Eio İşlevleri


Set maximum number of requests processed in a poll.

eio_set_max_parallel
eio_set_max_poll_time
Eio İşlevleri
PHP Manual

eio_set_max_poll_reqs

(PECL eio >= 0.0.1dev)

eio_set_max_poll_reqs — Set maximum number of requests processed in a poll.

Açıklama

void eio_set_max_poll_reqs ( int $nreqs )

Değiştirgeler

nreqs

Number of requests

Dönen Değerler

Hiçbir değer dönmez.

eio_set_max_parallel
eio_set_max_poll_time
Eio İşlevleri


Set maximum poll time

eio_set_max_poll_reqs
eio_set_min_parallel
Eio İşlevleri
PHP Manual

eio_set_max_poll_time

(PECL eio >= 0.0.1dev)

eio_set_max_poll_time — Set maximum poll time

Açıklama

void eio_set_max_poll_time ( float $nseconds )

Polling stops, if poll took longer than nseconds seconds.

Değiştirgeler

nseconds

Number of seconds

Dönen Değerler

Hiçbir değer dönmez.

eio_set_max_poll_reqs
eio_set_min_parallel
Eio İşlevleri


Set minimum parallel thread number

eio_set_max_poll_time
eio_stat
Eio İşlevleri
PHP Manual

eio_set_min_parallel

(PECL eio >= 0.0.1dev)

eio_set_min_parallel — Set minimum parallel thread number

Açıklama

void eio_set_min_parallel ( string $nthreads )

Değiştirgeler

nthreads

Number of parallel threads.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • eio_set_max_parallel
eio_set_max_poll_time
eio_stat
Eio İşlevleri


Get file status

eio_set_min_parallel
eio_statvfs
Eio İşlevleri
PHP Manual

eio_stat

(PECL eio >= 0.0.1dev)

eio_stat — Get file status

Açıklama

resource eio_stat ( string $path , int $pri , callable $callback [, mixed $data = NULL ] )

eio_stat() returns file status information in result argument of callback

Değiştirgeler

path

The file path

pri

The request priority: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, or NULL. If NULL passed, pri internally is set to EIO_PRI_DEFAULT.

callback

callback function is called when the request is done. It should match the following prototype:

void callback(mixed $data, int $result[, resource $req]);
data

is custom data passed to the request.

result

request-specific result value; basically, the value returned by corresponding system call.

req

is optional request resource which can be used with functions like eio_get_last_error()

data

Arbitrary variable passed to callback.

Dönen Değerler

eio_stat() returns request resource on success or FALSE on error. On success assigns result argument of callback to an array.

Örnekler

Örnek 1 eio_stat() example

<?php
$tmp_filename = "eio-file.tmp";
touch($tmp_filename);

function my_res_cb($data, $result) {
    var_dump($data);
    var_dump($result);
}

function my_open_cb($data, $result) {
    eio_close($result);
    eio_event_loop();

    @unlink($data);
}

eio_stat($tmp_filename, EIO_PRI_DEFAULT, "my_res_cb", "eio_stat");
eio_open($tmp_filename, EIO_O_RDONLY, NULL,
 EIO_PRI_DEFAULT, "my_open_cb", $tmp_filename);
eio_event_loop();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(8) "eio_stat"
array(12) {
  ["st_dev"]=>
  int(2050)
  ["st_ino"]=>
  int(2489173)
  ["st_mode"]=>
  int(33188)
  ["st_nlink"]=>
  int(1)
  ["st_uid"]=>
  int(1000)
  ["st_gid"]=>
  int(100)
  ["st_rdev"]=>
  int(0)
  ["st_blksize"]=>
  int(4096)
  ["st_blocks"]=>
  int(0)
  ["st_atime"]=>
  int(1318250380)
  ["st_mtime"]=>
  int(1318250380)
  ["st_ctime"]=>
  int(1318250380)
}

Ayrıca Bakınız

  • eio_lstat
  • eio_fstat
eio_set_min_parallel
eio_statvfs
Eio İşlevleri


Get file system statistics

eio_stat
eio_symlink
Eio İşlevleri
PHP Manual

eio_statvfs

(PECL eio >= 0.0.1dev)

eio_statvfs — Get file system statistics

Açıklama

resource eio_statvfs ( string $path , int $pri , callable $callback [, mixed $data ] )

eio_statvfs() returns file system statistics information in result argument of callback

Değiştirgeler

path

Pathname of any file within the mounted file system

pri

The request priority: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, or NULL. If NULL passed, pri internally is set to EIO_PRI_DEFAULT.

callback

callback function is called when the request is done. It should match the following prototype:

void callback(mixed $data, int $result[, resource $req]);
data

is custom data passed to the request.

result

request-specific result value; basically, the value returned by corresponding system call.

req

is optional request resource which can be used with functions like eio_get_last_error()

data

Arbitrary variable passed to callback.

Dönen Değerler

eio_statvfs() returns request resource on success or FALSE on error. On success assigns result argument of callback to an array.

Örnekler

Örnek 1 eio_statvfs() example

<?php
$tmp_filename = '/tmp/eio-file.tmp';
touch($tmp_filename);

function my_statvfs_callback($data, $result) {
    var_dump($data);
    var_dump($result);

 @unlink($data);
}

eio_statvfs($tmp_filename, EIO_PRI_DEFAULT, "my_statvfs_callback", $tmp_filename);
eio_event_loop();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(17) "/tmp/eio-file.tmp"
array(11) {
  ["f_bsize"]=>
  int(4096)
  ["f_frsize"]=>
  int(4096)
  ["f_blocks"]=>
  int(262144)
  ["f_bfree"]=>
  int(262111)
  ["f_bavail"]=>
  int(262111)
  ["f_files"]=>
  int(1540815)
  ["f_ffree"]=>
  int(1540743)
  ["f_favail"]=>
  int(1540743)
  ["f_fsid"]=>
  int(0)
  ["f_flag"]=>
  int(4102)
  ["f_namemax"]=>
  int(255)
}
eio_stat
eio_symlink
Eio İşlevleri


Create a symbolic link

eio_statvfs
eio_sync_file_range
Eio İşlevleri
PHP Manual

eio_symlink

(PECL eio >= 0.0.1dev)

eio_symlink — Create a symbolic link

Açıklama

resource eio_symlink ( string $path , string $new_path [, int $pri = EIO_PRI_DEFAULT [, callable $callback = NULL [, mixed $data = NULL ]]] )

eio_symlink() creates a symbolic link new_path to path.

Değiştirgeler

path

Source path

new_path

Target path

pri

The request priority: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, or NULL. If NULL passed, pri internally is set to EIO_PRI_DEFAULT.

callback

callback function is called when the request is done. It should match the following prototype:

void callback(mixed $data, int $result[, resource $req]);
data

is custom data passed to the request.

result

request-specific result value; basically, the value returned by corresponding system call.

req

is optional request resource which can be used with functions like eio_get_last_error()

data

Arbitrary variable passed to callback.

Dönen Değerler

eio_symlink() returns request resource on success or FALSE on error.

Örnekler

Örnek 1 eio_symlink() example

<?php
$filename = dirname(__FILE__)."/symlink.dat";
touch($filename);
$link = dirname(__FILE__)."/symlink.link";

function my_symlink_cb($data, $result) {
    global $link, $filename;
    var_dump(file_exists($data) && is_link($data));

    if (!eio_readlink($data, EIO_PRI_DEFAULT, "my_readlink_cb", NULL)) {
        @unlink($link);
        @unlink($filename);
    }
}

function my_readlink_cb($data, $result) {
    global $filename, $link;
    var_dump($result);

    @unlink($link);
    @unlink($filename);
}

eio_symlink($filename, $link, EIO_PRI_DEFAULT, "my_symlink_cb", $link);
eio_event_loop();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(true)
string(16) "/tmp/symlink.dat"

Ayrıca Bakınız

  • eio_link
eio_statvfs
eio_sync_file_range
Eio İşlevleri


Sync a file segment with disk

eio_symlink
eio_sync
Eio İşlevleri
PHP Manual

eio_sync_file_range

(PECL eio >= 0.0.1dev)

eio_sync_file_range — Sync a file segment with disk

Açıklama

resource eio_sync_file_range ( mixed $fd , int $offset , int $nbytes , int $flags [, int $pri = EIO_PRI_DEFAULT [, callable $callback = NULL [, mixed $data = NULL ]]] )

eio_sync_file_range() permits fine control when synchronizing the open file referred to by the file descriptor fd with disk.

Değiştirgeler

fd

File descriptor

offset

The starting byte of the file range to be synchronized

nbytes

Specifies the length of the range to be synchronized, in bytes. If nbytes is zero, then all bytes from offset through to the end of file are synchronized.

flags

A bit-mask. Can include any of the following values: EIO_SYNC_FILE_RANGE_WAIT_BEFORE, EIO_SYNC_FILE_RANGE_WRITE, EIO_SYNC_FILE_RANGE_WAIT_AFTER. These flags have the same meaning as their SYNC_FILE_RANGE_* counterparts(see SYNC_FILE_RANGE(2) man page).

pri

The request priority: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, or NULL. If NULL passed, pri internally is set to EIO_PRI_DEFAULT.

callback

callback function is called when the request is done. It should match the following prototype:

void callback(mixed $data, int $result[, resource $req]);
data

is custom data passed to the request.

result

request-specific result value; basically, the value returned by corresponding system call.

req

is optional request resource which can be used with functions like eio_get_last_error()

data

Arbitrary variable passed to callback.

Dönen Değerler

eio_sync_file_range() returns request resource on success or FALSE on error.

eio_symlink
eio_sync
Eio İşlevleri


Commit buffer cache to disk

eio_sync_file_range
eio_syncfs
Eio İşlevleri
PHP Manual

eio_sync

(PECL eio >= 0.0.1dev)

eio_sync — Commit buffer cache to disk

Açıklama

resource eio_sync ([ int $pri = EIO_PRI_DEFAULT [, callable $callback = NULL [, mixed $data = NULL ]]] )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

eio_sync() returns request resource on success or FALSE on error.

eio_sync_file_range
eio_syncfs
Eio İşlevleri


Calls Linux' syncfs syscall, if available

eio_sync
eio_truncate
Eio İşlevleri
PHP Manual

eio_syncfs

(PECL eio >= 0.0.1dev)

eio_syncfs — Calls Linux' syncfs syscall, if available

Açıklama

resource eio_syncfs ( mixed $fd [, int $pri = EIO_PRI_DEFAULT [, callable $callback = NULL [, mixed $data = NULL ]]] )

Değiştirgeler

fd

File descriptor

pri

The request priority: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, or NULL. If NULL passed, pri internally is set to EIO_PRI_DEFAULT.

callback

callback function is called when the request is done. It should match the following prototype:

void callback(mixed $data, int $result[, resource $req]);
data

is custom data passed to the request.

result

request-specific result value; basically, the value returned by corresponding system call.

req

is optional request resource which can be used with functions like eio_get_last_error()

data

Arbitrary variable passed to callback.

Dönen Değerler

eio_syncfs() returns request resource on success or FALSE on error.

eio_sync
eio_truncate
Eio İşlevleri


Truncate a file

eio_syncfs
eio_unlink
Eio İşlevleri
PHP Manual

eio_truncate

(PECL eio >= 0.0.1dev)

eio_truncate — Truncate a file

Açıklama

resource eio_truncate ( string $path [, int $offset = 0 [, int $pri = EIO_PRI_DEFAULT [, callable $callback = NULL [, mixed $data = NULL ]]]] )

eio_truncate() causes the regular file named by path to be truncated to a size of precisely length bytes

Değiştirgeler

path

File path

offset

Offset from beginning of the file.

pri

The request priority: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, or NULL. If NULL passed, pri internally is set to EIO_PRI_DEFAULT.

callback

callback function is called when the request is done. It should match the following prototype:

void callback(mixed $data, int $result[, resource $req]);
data

is custom data passed to the request.

result

request-specific result value; basically, the value returned by corresponding system call.

req

is optional request resource which can be used with functions like eio_get_last_error()

data

Arbitrary variable passed to callback.

Dönen Değerler

eio_busy() returns request resource on success or FALSE on error.

Ayrıca Bakınız

  • eio_ftruncate
eio_syncfs
eio_unlink
Eio İşlevleri


Delete a name and possibly the file it refers to

eio_truncate
eio_utime
Eio İşlevleri
PHP Manual

eio_unlink

(PECL eio >= 0.0.1dev)

eio_unlink — Delete a name and possibly the file it refers to

Açıklama

resource eio_unlink ( string $path [, int $pri = EIO_PRI_DEFAULT [, callable $callback = NULL [, mixed $data = NULL ]]] )

eio_unlink() deletes a name from the file system.

Değiştirgeler

path

Path to file

pri

The request priority: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, or NULL. If NULL passed, pri internally is set to EIO_PRI_DEFAULT.

callback

callback function is called when the request is done. It should match the following prototype:

void callback(mixed $data, int $result[, resource $req]);
data

is custom data passed to the request.

result

request-specific result value; basically, the value returned by corresponding system call.

req

is optional request resource which can be used with functions like eio_get_last_error()

data

Arbitrary variable passed to callback.

Dönen Değerler

eio_unlink() returns request resource on success or FALSE on error.

eio_truncate
eio_utime
Eio İşlevleri


Change file last access and modification times.

eio_unlink
eio_write
Eio İşlevleri
PHP Manual

eio_utime

(PECL eio >= 0.0.1dev)

eio_utime — Change file last access and modification times.

Açıklama

resource eio_utime ( string $path , float $atime , float $mtime [, int $pri = EIO_PRI_DEFAULT [, callable $callback = NULL [, mixed $data = NULL ]]] )

Değiştirgeler

path

Path to the file.

atime

Access time

mtime

Modification time

pri

The request priority: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, or NULL. If NULL passed, pri internally is set to EIO_PRI_DEFAULT.

callback

callback function is called when the request is done. It should match the following prototype:

void callback(mixed $data, int $result[, resource $req]);
data

is custom data passed to the request.

result

request-specific result value; basically, the value returned by corresponding system call.

req

is optional request resource which can be used with functions like eio_get_last_error()

data

Arbitrary variable passed to callback.

Dönen Değerler

eio_utime() returns request resource on success or FALSE on error.

Ayrıca Bakınız

  • eio_futime
eio_unlink
eio_write
Eio İşlevleri


Write to file

eio_utime
Ev
Eio İşlevleri
PHP Manual

eio_write

(PECL eio >= 0.0.1dev)

eio_write — Write to file

Açıklama

resource eio_write ( mixed $fd , string $str [, int $length = 0 [, int $offset = 0 [, int $pri = EIO_PRI_DEFAULT [, callable $callback = NULL [, mixed $data = NULL ]]]]] )

eio_write() writes up to length bytes from str at offset offset from the beginning of the file.

Değiştirgeler

fd

Stream, Socket resource, or numeric file descriptor, e.g. returned by eio_open()

str

Source string

length

Maximum number of bytes to write.

offset

Offset from the beginning of file.

pri

The request priority: EIO_PRI_DEFAULT, EIO_PRI_MIN, EIO_PRI_MAX, or NULL. If NULL passed, pri internally is set to EIO_PRI_DEFAULT.

callback

callback function is called when the request is done. It should match the following prototype:

void callback(mixed $data, int $result[, resource $req]);
data

is custom data passed to the request.

result

request-specific result value; basically, the value returned by corresponding system call.

req

is optional request resource which can be used with functions like eio_get_last_error()

data

Arbitrary variable passed to callback.

Dönen Değerler

eio_write() returns request resource on success or FALSE on error.

Ayrıca Bakınız

  • eio_open
eio_utime
Ev
Eio İşlevleri


Ev

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
  • Watchers
  • Watcher callbacks
  • Periodic watcher operation modes
  • Ev — The Ev class
    • Ev::backend — Returns an integer describing the backend used by libev.
    • Ev::depth — Returns recursion depth
    • Ev::embeddableBackends — Returns the set of backends that are embeddable in other event loops.
    • Ev::feedSignal — Feed a signal event info Ev
    • Ev::feedSignalEvent — Feed signal event into the default loop
    • Ev::iteration — Return the number of times the default event loop has polled for new events.
    • Ev::now — Returns the time when the last iteration of the default event loop has started.
    • Ev::nowUpdate — Establishes the current time by querying the kernel, updating the time returned by Ev::now in the progress.
    • Ev::recommendedBackends — Returns a bit mask of recommended backends for current platform.
    • Ev::resume — Resume previously suspended default event loop
    • Ev::run — Begin checking for events and calling callbacks for the default loop
    • Ev::sleep — Block the process for the given number of seconds.
    • Ev::stop — Stops the default event loop
    • Ev::supportedBackends — Returns the set of backends supported by current libev configuration.
    • Ev::suspend — Suspend the default event loop
    • Ev::time — Returns the current time in fractional seconds since the epoch.
    • Ev::verify — Performs internal consistency checks(for debugging)
  • EvCheck — The EvCheck class
    • EvCheck::__construct — Constructs the EvCheck watcher object
    • EvCheck::createStopped — Create instance of a stopped EvCheck watcher
  • EvChild — The EvChild class
    • EvChild::__construct — Constructs the EvChild watcher object
    • EvChild::createStopped — Create instance of a stopped EvCheck watcher
    • EvChild::set — Configures the watcher
  • EvEmbed — The EvEmbed class
    • EvEmbed::__construct — Constructs the EvEmbed object
    • EvEmbed::createStopped — Create stopped EvEmbed watcher object
    • EvEmbed::set — Configures the watcher
    • EvEmbed::sweep — Make a single, non-blocking sweep over the embedded loop.
  • EvFork — The EvFork class
    • EvFork::__construct — Constructs the EvFork watcher object
    • EvFork::createStopped — Creates a stopped instance of EvFork watcher class
  • EvIdle — The EvIdle class
    • EvIdle::__construct — Constructs the EvIdle watcher object
    • EvIdle::createStopped — Creates instance of a stopped EvIdle watcher object
  • EvIo — The EvIo class
    • EvIo::__construct — Constructs EvIo watcher object
    • EvIo::createStopped — Create stopped EvIo watcher object
    • EvIo::set — Configures the watcher
  • EvLoop — The EvLoop class
    • EvLoop::backend — Returns an integer describing the backend used by libev.
    • EvLoop::check — Creates EvCheck object associated with the current event loop instance
    • EvLoop::child — Creates EvChild object associated with the current event loop
    • EvLoop::__construct — Constructs the event loop object
    • EvLoop::defaultLoop — Returns or creates the default event loop.
    • EvLoop::embed — Creates an instance of EvEmbed watcher associated with the current EvLoop object.
    • EvLoop::fork — Creates EvFork watcher object associated with the current event loop instance
    • EvLoop::idle — Creates EvIdle watcher object associated with the current event loop instance
    • EvLoop::invokePending — Invoke all pending watchers while resetting their pending state
    • EvLoop::io — Create EvIo watcher object associated with the current event loop instance
    • EvLoop::loopFork — Must be called after a fork
    • EvLoop::now — Returns the current "event loop time"
    • EvLoop::nowUpdate — Establishes the current time by querying the kernel, updating the time returned by EvLoop::now in the progress.
    • EvLoop::periodic — Creates EvPeriodic watcher object associated with the current event loop instance
    • EvLoop::prepare — Creates EvPrepare watcher object associated with the current event loop instance
    • EvLoop::resume — Resume previously suspended default event loop
    • EvLoop::run — Begin checking for events and calling callbacks for the loop
    • EvLoop::signal — Creates EvSignal watcher object associated with the current event loop instance
    • EvLoop::stat — Creates EvStat watcher object associated with the current event loop instance
    • EvLoop::stop — Stops the event loop
    • EvLoop::suspend — Suspend the loop
    • EvLoop::timer — Creates EvTimer watcher object associated with the current event loop instance
    • EvLoop::verify — Performs internal consistency checks(for debugging)
  • EvPeriodic — The EvPeriodic class
    • EvPeriodic::again — Simply stops and restarts the periodic watcher again.
    • EvPeriodic::at — Returns the absolute time that this watcher is supposed to trigger next
    • EvPeriodic::__construct — Constructs EvPeriodic watcher object
    • EvPeriodic::createStopped — Create a stopped EvPeriodic watcher
    • EvPeriodic::set — Configures the watcher
  • EvPrepare — The EvPrepare class
    • EvPrepare::__construct — Constructs EvPrepare watcher object
    • EvPrepare::createStopped — Creates a stopped instance of EvPrepare watcher
  • EvSignal — The EvSignal class
    • EvSignal::__construct — Constructs EvPeriodic watcher object
    • EvSignal::createStopped — Create stopped EvSignal watcher object
    • EvSignal::set — Configures the watcher
  • EvStat — The EvStat class
    • EvStat::attr — Returns the values most recently detected by Ev
    • EvStat::__construct — Constructs EvStat watcher object
    • EvStat::createStopped — Create a stopped EvStat watcher object
    • EvStat::prev — Returns the previous set of values returned by EvStat::attr
    • EvStat::set — Configures the watcher
    • EvStat::stat — Initiates the stat call
  • EvTimer — The EvTimer class
    • EvTimer::again — Restarts the timer watcher
    • EvTimer::__construct — Constructs an EvTimer watcher object
    • EvTimer::createStopped — Creates EvTimer stopped watcher object
    • EvTimer::set — Configures the watcher
  • EvWatcher — The EvWatcher class
    • EvWatcher::clear — Clear watcher pending status
    • EvWatcher::__construct — Abstract constructor of a watcher object
    • EvWatcher::feed — Feeds the given revents set into the event loop
    • EvWatcher::getLoop — Returns the loop responsible for the watcher
    • EvWatcher::invoke — Invokes the watcher callback with the given received events bit mask
    • EvWatcher::keepalive — Configures whether to keep the loop from returning
    • EvWatcher::setCallback — Sets new callback for the watcher
    • EvWatcher::start — Starts the watcher
    • EvWatcher::stop — Stops the watcher
eio_write
Giriş
Süreç Denetim Eklentileri


Giriş

This extension provides inteface to » libev library - a high performance full-featured event loop written in C.

Bilginize: Bu eklenti Windows sistemlerinde çalışmaz.

Libev is an event loop: one registers interest in certain events (such as a file descriptor being readable or a timeout occurring), and it will manage these event sources and provide the program with events.

To do this, it must take more or less complete control over the process (or thread) by executing the event loop handler, and will then communicate events via a callback mechanism.

You register interest in certain events by registering so-called event watchers, and then hand it over to libev by starting the watcher.

For details refer to the » documentation of libev

Ev
Yapılandırma/Kurulum
Ev


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Ev


Gereksinimler

libev library is embedded into this extension. You don't need to install it separately.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu » PECL eklentisi PHP ile gelmez.

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/ev .

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Most constants are moved to Ev singleton class.

Özkaynak Türleri
Örnekler
Ev


Örnekler

Örnek 1 Simple timers

<?php
// Create and start timer firing after 2 seconds
$w1 = new EvTimer(2, 0, function () {
    echo "2 seconds elapsed\n";
});

// Create and launch timer firing after 2 seconds repeating each second
// until we manually stop it
$w2 = new EvTimer(2, 1, function ($w) {
    echo "is called every second, is launched after 2 seconds\n";
    echo "iteration = ", Ev::iteration(), PHP_EOL;

    // Stop the watcher after 5 iterations
    Ev::iteration() == 5 and $w->stop();
    // Stop the watcher if further calls cause more than 10 iterations
    Ev::iteration() >= 10 and $w->stop();
});

// Create stopped timer. It will be inactive until we start it ourselves
$w_stopped = EvTimer::createStopped(10, 5, function($w) {
    echo "Callback of a timer created as stopped\n";

    // Stop the watcher after 2 iterations
    Ev::iteration() >= 2 and $w->stop();
});

// Loop until Ev::stop() is called or all of watchers stop
Ev::run();

// Start and look if it works
$w_stopped->start();
echo "Run single iteration\n";
Ev::run(Ev::RUN_ONCE);

echo "Restart the second watcher and try to handle the same events, but don't block\n";
$w2->again();
Ev::run(Ev::RUN_NOWAIT);

$w = new EvTimer(10, 0, function() {});
echo "Running a blocking loop\n";
Ev::run();
echo "END\n";
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

2 seconds elapsed
is called every second, is launched after 2 seconds
iteration = 1
is called every second, is launched after 2 seconds
iteration = 2
is called every second, is launched after 2 seconds
iteration = 3
is called every second, is launched after 2 seconds
iteration = 4
is called every second, is launched after 2 seconds
iteration = 5
Run single iteration
Callback of a timer created as stopped
Restart the second watcher and try to handle the same events, but don't block
Running a blocking loop
is called every second, is launched after 2 seconds
iteration = 8
is called every second, is launched after 2 seconds
iteration = 9
is called every second, is launched after 2 seconds
iteration = 10
END

Örnek 2 Periodic timer. Tick each 10.5 seconds

<?php
$w = new EvPeriodic(0., 10.5, NULL, function ($w, $revents) {
    echo time(), PHP_EOL;
});

Ev::run();
?>

Örnek 3 Periodic timer. Use reschedule callback

<?php
// Tick each 10.5 seconds

function reschedule_cb ($watcher, $now) {
    return $now + (10.5. - fmod($now, 10.5));
}

$w = new EvPeriodic(0., 0., "reschedule_cb", function ($w, $revents) {
    echo time(), PHP_EOL;
});

Ev::run();
?>

Örnek 4 Periodic timer. Tick every 10.5 seconds starting at now

<?php
// Tick every 10.5 seconds starting at now
$w = new EvPeriodic(fmod(Ev::now(), 10.5), 10.5, NULL, function ($w, $revents) {
    echo time(), PHP_EOL;
});

Ev::run();
?>

Örnek 5 Wait until STDIN is readable

<?php
// Wait until STDIN is readable
$w = new EvIo(STDIN, Ev::READ, function ($watcher, $revents) {
    echo "STDIN is readable\n";
});

Ev::run(Ev::RUN_ONCE);
?>

Örnek 6 Use some async I/O to access a socket

<?php
/* Use some async I/O to access a socket */

// `sockets' extension still logs warnings
// for EINPROGRESS, EAGAIN/EWOULDBLOCK etc.
error_reporting(E_ERROR);

$e_nonblocking = array (/*EAGAIN or EWOULDBLOCK*/11, /*EINPROGRESS*/115);

// Get the port for the WWW service
$service_port = getservbyname('www', 'tcp');

// Get the IP address for the target host
$address = gethostbyname('google.co.uk');

// Create a TCP/IP socket
$socket = socket_create(AF_INET, SOCK_STREAM, SOL_TCP);
if ($socket === FALSE) {
    echo "socket_create() failed: reason: "
        .socket_strerror(socket_last_error()) . "\n";
}

// Set O_NONBLOCK flag
socket_set_nonblock($socket);

// Abort on timeout
$timeout_watcher = new EvTimer(10.0, 0., function () use ($socket) {
    socket_close($socket);
    Ev::stop(Ev::BREAK_ALL);
});

// Make HEAD request when the socket is writable
$write_watcher = new EvIo($socket, Ev::WRITE, function ($w)
    use ($socket, $timeout_watcher, $e_nonblocking)
{
    // Stop timeout watcher
    $timeout_watcher->stop();
    // Stop write watcher
    $w->stop();

    $in = "HEAD / HTTP/1.1\r\n";
    $in .= "Host: google.co.uk\r\n";
    $in .= "Connection: Close\r\n\r\n";

    if (!socket_write($socket, $in, strlen($in))) {
        trigger_error("Failed writing $in to socket", E_USER_ERROR);
    }

    $read_watcher = new EvIo($socket, Ev::READ, function ($w, $re)
        use ($socket, $e_nonblocking)
    {
        // Socket is readable. recv() 20 bytes using non-blocking mode
        $ret = socket_recv($socket, $out, 20, MSG_DONTWAIT);

        if ($ret) {
            echo $out;
        } elseif ($ret === 0) {
            // All read
            $w->stop();
            socket_close($socket);
            return;
        }

        // Caught EINPROGRESS, EAGAIN, or EWOULDBLOCK
        if (in_array(socket_last_error(), $e_nonblocking)) {
            return;
        }

        $w->stop();
        socket_close($socket);
    });

    Ev::run();
});

$result = socket_connect($socket, $address, $service_port);

Ev::run();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

HTTP/1.1 301 Moved Permanently
Location: http://www.google.co.uk/
Content-Type: text/html; CHARSET=Windows-1254
Date: Sun, 23 Dec 2012 16:08:27 GMT
Expires: Tue, 22 Jan 2013 16:08:27 GMT
Cache-Control: public, max-age=2592000
Server: gws
Content-Length: 221
X-XSS-Protection: 1; mode=block
X-Frame-Options: SAMEORIGIN
Connection: close

Örnek 7 Embedding one loop into another

<?php
/*
* Try to get an embeddable event loop and embed it into the default event loop.
* If it is impossible, use the default
* loop. The default loop is stored in $loop_hi, while the embeddable loop is
* stored in $loop_lo(which is $loop_hi in the case no embeddable loop can be
* used).
*
* Sample translated to PHP
* http://pod.tst.eu/http://cvs.schmorp.de/libev/ev.pod#Examples_CONTENT-9
*/
$loop_hi = EvLoop::defaultLoop();
$loop_lo = NULL;
$embed   = NULL;

/*
* See if there is a chance of getting one that works
* (flags' value of 0 means autodetection)
*/
$loop_lo = Ev::embeddableBackends() & Ev::recommendedBackends()
    ? new EvLoop(Ev::embeddableBackends() & Ev::recommendedBackends())
    : 0;

if ($loop_lo) {
    $embed = new EvEmbed($loop_lo, function () {});
} else {
    $loop_lo = $loop_hi;
}
?>

Örnek 8 Embedding loop created with kqueue backend into the default loop

<?php
/*
* Check if kqueue is available but not recommended and create a kqueue backend
* for use with sockets (which usually work with any kqueue implementation).
* Store the kqueue/socket-only event loop in loop_socket. (One might optionally
* use EVFLAG_NOENV, too)
*
* Example borrowed from
* http://pod.tst.eu/http://cvs.schmorp.de/libev/ev.pod#Examples_CONTENT-9
*/
$loop        = EvLoop::defaultLoop();
$socket_loop = NULL;
$embed       = NULL;

if (Ev::supportedBackends() & ~Ev::recommendedBackends() & Ev::BACKEND_KQUEUE) {
    if (($socket_loop = new EvLoop(Ev::BACKEND_KQUEUE))) {
        $embed = new EvEmbed($loop);
    }
}

if (!$socket_loop) {
    $socket_loop = $loop;
}

// Now use $socket_loop for all sockets, and $loop for anything else
?>

Örnek 9 Handle SIGTERM signal

<?php
$w = new EvSignal(SIGTERM, function ($watcher) {
    echo "SIGTERM received\n";
    $watcher->stop();
});

Ev::run();
?>

Örnek 10 Monitor changes of /var/log/messages

<?php
// Use 10 second update interval.
$w = new EvStat("/var/log/messages", 8, function ($w) {
    echo "/var/log/messages changed\n";

    $attr = $w->attr();

    if ($attr['nlink']) {
        printf("Current size: %ld\n", $attr['size']);
        printf("Current atime: %ld\n", $attr['atime']);
        printf("Current mtime: %ld\n", $attr['mtime']);
    } else {
        fprintf(STDERR, "`messages` file is not there!");
        $w->stop();
    }
});

Ev::run();
?>

Örnek 11 Monotor changes of /var/log/messages. Avoid missing updates by means of one second delay

<?php
$timer = EvTimer::createStopped(0., 1.02, function ($w) {
    $w->stop();

    $stat = $w->data;

    // 1 second after the most recent change of the file
    printf("Current size: %ld\n", $stat->attr()['size']);
});

$stat = new EvStat("/var/log/messages", 0., function () use ($timer) {
    // Reset timer watcher
    $timer->again();
});

$timer->data = $stat;

Ev::run();
?>

Örnek 12 Process status changes

<?php
$pid = pcntl_fork();

if ($pid == -1) {
    fprintf(STDERR, "pcntl_fork failed\n");
} elseif ($pid) {
    $w = new EvChild($pid, FALSE, function ($w, $revents) {
        $w->stop();

        printf("Process %d exited with status %d\n", $w->rpid, $w->rstatus);
    });

    Ev::run();

    // Protect against Zombies
    pcntl_wait($status);
} else {
    //Forked child
    exit(2);
}
?>
Öntanımlı Sabitler
Watchers
Ev


Watchers

A watcher is an object that gets created to record interest in some event. For instance, the following code waits for STDIN to become readable:

<?php
// Wait until STDIN is readable
$w = new EvIo(STDIN, Ev::READ, function ($watcher, $revents) {
 echo "STDIN is readable\n";
});
Ev::run(Ev::RUN_ONCE);
?>

All the watcher constructors automatically start the watchers. createStopped methods create stopped watchers(e.g. EvIo::createStopped() )

Note that a watcher will automatically be stopped when the watcher object is destroyed. Therefore, the watcher objects returned by the constructors or factory methods should be kept.

Note also that all methods changing some watcher property( set , priority etc.) automatically stop and start it again if it is active, which means pending events get lost.

See also: Watcher callbacks .

Örnekler
Watcher callbacks
Ev


Watcher callbacks

All watchers can be active(waiting for events) or inactive(paused). Only active watchers will have their callbacks invoked. All callbacks will be called with at least two arguments: watcher - the watcher, and revents a bitmask of received events.

Watcher callbacks are passed to the watcher contructors(the classes derived from EvWatcher - EvCheck::__construct() , EvChild::__construct() etc.). A watcher callback should match the following prototype:

void callback ([ object $watcher = NULL [, int $revents = NULL ]] )

watcher

The watcher instance(of a class extending EvWatcher ).

revents

Watcher received events .

Each watcher type has its associated bit in revents , so one can use the same callback for multiple watchers. The event mask is named after the type, i.e. EvChild (or EvLoop::child() ) sets EV::CHILD , EvPrepare (or EvLoop::prepare() ) sets Ev::PREPARE , EvPeriodic (or EvLoop::periodic() ) sets Ev::PERIODIC and so on, with the exception of I/O events (which can set both Ev::READ and Ev::WRITE bits).

Watchers
Periodic watcher operation modes
Ev


Periodic watcher operation modes

EvPeriodic watcher works in different modes depending on the offset , interval and reschedule_cb parameters.

  1. Absolute timer . In this mode interval = 0 , reschedule_cb = NULL. This time simply fires at the wallclock time offset and doesn't repeat. It will not adjust when a time jump occurs, that is, if it is to be run at January 1st 2014 then it will run when the system time reaches or surpasses this time.

  2. Repeating interval timer . In this mode interval > 0 , reschedule_cb = NULL; the watcher will always be scheduled to timeout at the next offset + N * interval time(for some integer N ) and then repeat, regardless of any time jumps.

    This can be used to create timers that do not drift with respect to system time:

    <?php
    $hourly     = EvPeriodic(0, 3600, NULL, function () {
      echo     "once per hour\n";
    };
    ?>
    That doesn't mean there will always be 3600 seconds in between triggers, but only that the callback will be called when the system time shows a full hour( UTC ).

    EvPeriodic will try to run the callback in this mode at the next possible time where time = offset ( mod interval ), regardless of any time jumps.

  3. Manual reschedule mode . In this mode reschedule_cb is a callable .

    interval and offset are both being ignored. Instead, each time the periodic watcher gets scheduled, the reschedule callback ( reschedule_cb ) will be called with the watcher as first, and the current time as second argument.

    This callback must not stop or destroy this or any other periodic watchers, ever, and must not call any event loop functions or methods. To stop it return 1e30 and stop it afterwards. An EvPrepare watcher may be used for this task.

    It must return the next time to trigger, based on the passed time value (that is, the lowest time value larger than or equal to the second argument). It will usually be called just before the callback will be triggered, but might be called at other times, too.

    Örnek 1 Using reschedule callback

    <?php
    // Tick each 10.5 seconds

    function reschedule_cb ($watcher, $now) {
       return     $now + (10.5. - fmod($now, 10.5));
    }

    $w = new EvPeriodic(0., 0., "reschedule_cb", function ($w, $revents) {
       echo     time(), PHP_EOL;
    });

    Ev::run();
    ?>
Watcher callbacks
Ev
Ev


The Ev class

(PECL ev >= 0.2.0)

Giriş

Ev is a static class providing access to the default loop and to some common operations.

Sınıf Sözdizimi

final Ev {
/* Constants */
const integer FLAG_AUTO = 0 ;
const integer FLAG_NOENV = 16777216 ;
const integer FLAG_FORKCHECK = 33554432 ;
const integer FLAG_NOINOTIFY = 1048576 ;
const integer FLAG_SIGNALFD = 2097152 ;
const integer FLAG_NOSIGMASK = 4194304 ;
const integer RUN_NOWAIT = 1 ;
const integer RUN_ONCE = 2 ;
const integer BREAK_CANCEL = 0 ;
const integer BREAK_ONE = 1 ;
const integer BREAK_ALL = 2 ;
const integer MINPRI = -2 ;
const integer MAXPRI = 2 ;
const integer READ = 1 ;
const integer WRITE = 2 ;
const integer TIMER = 256 ;
const integer PERIODIC = 512 ;
const integer SIGNAL = 1024 ;
const integer CHILD = 2048 ;
const integer STAT = 4096 ;
const integer IDLE = 8192 ;
const integer PREPARE = 16384 ;
const integer CHECK = 32768 ;
const integer EMBED = 65536 ;
const integer CUSTOM = 16777216 ;
const integer ERROR = 2147483648 ;
const integer BACKEND_SELECT = 1 ;
const integer BACKEND_POLL = 2 ;
const integer BACKEND_EPOLL = 4 ;
const integer BACKEND_KQUEUE = 8 ;
const integer BACKEND_DEVPOLL = 16 ;
const integer BACKEND_PORT = 32 ;
const integer BACKEND_ALL = 63 ;
const integer BACKEND_MASK = 65535 ;
/* Yöntemler */
final public static int backend ( void )
final public static int depth ( void )
final public static void embeddableBackends ( void )
final public static void feedSignal ( int $signum )
final public static void feedSignalEvent ( int $signum )
final public static int iteration ( void )
final public static double now ( void )
final public static void nowUpdate ( void )
final public static void recommendedBackends ( void )
final public static void resume ( void )
final public static void run ([ int $flags ] )
final public static void sleep ( double $seconds )
final public static void stop ([ int $how ] )
final public static void supportedBackends ( void )
final public static void suspend ( void )
final public static double time ( void )
final public static void verify ( void )
}

Öntanımlı Sabitler

Flags passed to create a loop:

Ev::FLAG_AUTO

The default flags value

Ev::FLAG_NOENV

If this flag used(or the program runs setuid or setgid), libev won't look at the environment variable LIBEV_FLAGS . Otherwise(by default), LIBEV_FLAGS will override the flags completely if it is found. Useful for performance tests and searching for bugs.

Ev::FLAG_FORKCHECK

Makes libev check for a fork in each iteration, instead of calling EvLoop::fork() manually. This works by calling getpid() on every iteration of the loop, and thus this might slow down the event loop with lots of loop iterations, but usually is not noticeable. This flag setting cannot be overridden or specified in the LIBEV_FLAGS environment variable.

Ev::FLAG_NOINOTIFY

When this flag is specified, libev won't attempt to use the inotify API for its » ev_stat watchers. The flag can be useful to conserve inotify file descriptors, as otherwise each loop using ev_stat watchers consumes one inotify handle.

Ev::FLAG_SIGNALFD

When this flag is specified, libev will attempt to use the signalfd API for its » ev_signal (and » ev_child ) watchers. This API delivers signals synchronously, which makes it both faster and might make it possible to get the queued signal data. It can also simplify signal handling with threads, as long as signals are properly blocked in threads. Signalfd will not be used by default.

Ev::FLAG_NOSIGMASK

When this flag is specified, libev will avoid to modify the signal mask. Specifically, this means having to make sure signals are unblocked before receiving them.

This behaviour is useful for custom signal handling, or handling signals only in specific threads.

Flags passed to Ev::run() , or EvLoop::run()

Ev::RUN_NOWAIT

Means that event loop will look for new events, will handle those events and any already outstanding ones, but will not wait and block the process in case there are no events and will return after one iteration of the loop. This is sometimes useful to poll and handle new events while doing lengthy calculations, to keep the program responsive.

Ev::RUN_ONCE

Means that event loop will look for new events (waiting if necessary) and will handle those and any already outstanding ones. It will block the process until at least one new event arrives (which could be an event internal to libev itself, so there is no guarantee that a user-registered callback will be called), and will return after one iteration of the loop.

Flags passed to Ev::stop() , or EvLoop::stop()

Ev::BREAK_CANCEL

Cancel the break operation.

Ev::BREAK_ONE

Makes the innermost Ev::run() (or EvLoop::run() ) call return.

Ev::BREAK_ALL

Makes all nested Ev::run() (or EvLoop::run() ) calls return.

Watcher priorities:

Ev::MINPRI

Minimum allowed watcher priority.

Ev::MAXPRI

Maximum allowed watcher priority.

Bit masks of (received) events:

Ev::READ

The file descriptor in the EvIo watcher has become readable.

Ev::WRITE

The file descriptor in the EvIo watcher has become writable.

Ev::TIMER

EvTimer watcher has been timed out.

Ev::PERIODIC

EvPeriodic watcher has been timed out.

Ev::SIGNAL

A signal specified in EvSignal::__construct() has been received.

Ev::CHILD

The pid specified in EvChild::__construct() has received a status change.

Ev::STAT

The path specified in EvStat watcher changed its attributes.

Ev::IDLE

EvIdle watcher works when there is nothing to do with other watchers.

Ev::PREPARE

All EvPrepare watchers are invoked just before Ev::run() starts. Thus, EvPrepare watchers are the last watchers invoked before the event loop sleeps or polls for new events.

Ev::CHECK

All EvCheck watchers are queued just after Ev::run() has gathered the new events, but before it queues any callbacks for any received events. Thus, EvCheck watchers will be invoked before any other watchers of the same or lower priority within an event loop iteration.

Ev::EMBED

The embedded event loop specified in the EvEmbed watcher needs attention.

Ev::CUSTOM

Not ever sent(or otherwise used) by libev itself, but can be freely used by libev users to signal watchers (e.g. via EvWatcher::feed() ).

Ev::ERROR

An unspecified error has occurred, the watcher has been stopped. This might happen because the watcher could not be properly started because libev ran out of memory, a file descriptor was found to be closed or any other problem. Libev considers these application bugs. See also » ANATOMY OF A WATCHER

Backend flags:

Ev::BACKEND_SELECT

select(2) backend

Ev::BACKEND_POLL

poll(2) backend

Ev::BACKEND_EPOLL

Linux-specific epoll(7) backend for both pre- and post-2.6.9 kernels

Ev::BACKEND_KQUEUE

kqueue backend used on most BSD systems. EvEmbed watcher could be used to embed one loop(with kqueue backend) into another. For instance, one can try to create an event loop with kqueue backend and use it for sockets only.

Ev::BACKEND_DEVPOLL

Solaris 8 backend. This is not implemented yet.

Ev::BACKEND_PORT

Solaris 10 event port mechanism with a good scaling.

Ev::BACKEND_ALL

Try all backends(even currupted ones). It's not recommended to use it explicitly. Bitwise operators should be applied here(e.g. Ev::BACKEND_ALL & ~ Ev::BACKEND_KQUEUE ) Use Ev::recommendedBackends() , or don't specify any backends at all.

Ev::BACKEND_MASK

Not a backend, but a mask to select all backend bits from flags value to mask out any backends(e.g. when modifying the LIBEV_FLAGS environment variable).

Bilginize:

For the default loop during module initialization phase Ev registers » ev_loop_fork call by means of pthread_atfork (if available).

Bilginize:

There are methods providing access to the default event loop in Ev class(e.g. Ev::iteration() , Ev::depth() etc.) For custom loops (created with EvLoop::__construct() ) these values may be accessed via corresponding properties and methods of the EvLoop class.

The instance of the default event loop itself can be fetched by means of EvLoop::defaultLoop() method.

İçindekiler

  • Ev::backend — Returns an integer describing the backend used by libev.
  • Ev::depth — Returns recursion depth
  • Ev::embeddableBackends — Returns the set of backends that are embeddable in other event loops.
  • Ev::feedSignal — Feed a signal event info Ev
  • Ev::feedSignalEvent — Feed signal event into the default loop
  • Ev::iteration — Return the number of times the default event loop has polled for new events.
  • Ev::now — Returns the time when the last iteration of the default event loop has started.
  • Ev::nowUpdate — Establishes the current time by querying the kernel, updating the time returned by Ev::now in the progress.
  • Ev::recommendedBackends — Returns a bit mask of recommended backends for current platform.
  • Ev::resume — Resume previously suspended default event loop
  • Ev::run — Begin checking for events and calling callbacks for the default loop
  • Ev::sleep — Block the process for the given number of seconds.
  • Ev::stop — Stops the default event loop
  • Ev::supportedBackends — Returns the set of backends supported by current libev configuration.
  • Ev::suspend — Suspend the default event loop
  • Ev::time — Returns the current time in fractional seconds since the epoch.
  • Ev::verify — Performs internal consistency checks(for debugging)
Periodic watcher operation modes
Ev::backend
Ev


Returns an integer describing the backend used by libev.

Ev
Ev::depth
Ev
PHP Manual

Ev::backend

(PECL ev >= 0.2.0)

Ev::backend — Returns an integer describing the backend used by libev.

Açıklama

final public static int Ev::backend ( void )

Returns an integer describing the backend used by libev . See Backend flags

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an integer(bit mask) describing the backend used by libev .

Ayrıca Bakınız

  • EvEmbed
  • Ev::embeddableBackends() - Returns the set of backends that are embeddable in other event loops.
  • Ev::recommendedBackends() - Returns a bit mask of recommended backends for current platform.
  • Ev::supportedBackends() - Returns the set of backends supported by current libev configuration.
  • Backend flags
Ev
Ev::depth
Ev


Returns recursion depth

Ev::backend
Ev::embeddableBackends
Ev
PHP Manual

Ev::depth

(PECL ev >= 0.2.0)

Ev::depth — Returns recursion depth

Açıklama

final public static int Ev::depth ( void )

The number of times Ev::run() was entered minus the number of times Ev::run() was exited normally, in other words, the recursion depth. Outside Ev::run() , this number is 0 . In a callback, this number is 1 , unless Ev::run() was invoked recursively (or from another thread), in which case it is higher.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

ev_depth() returns recursion depth of the default loop.

Ayrıca Bakınız

  • Ev::iteration() - Return the number of times the default event loop has polled for new events.
Ev::backend
Ev::embeddableBackends
Ev


Returns the set of backends that are embeddable in other event loops.

Ev::depth
Ev::feedSignal
Ev
PHP Manual

Ev::embeddableBackends

(PECL ev >= 0.2.0)

Ev::embeddableBackends — Returns the set of backends that are embeddable in other event loops.

Açıklama

final public static void Ev::embeddableBackends ( void )

Returns the set of backends that are embeddable in other event loops.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a bit mask which can containing backend flags combined using bitwise OR operator.

Örnekler

Örnek 1 Embedding loop created with kqueue backend into the default loop

<?php
/*
* Check if kqueue is available but not recommended and create a kqueue backend
* for use with sockets (which usually work with any kqueue implementation).
* Store the kqueue/socket-only event loop in loop_socket. (One might optionally
* use EVFLAG_NOENV, too)
*
* Example borrowed from
* http://pod.tst.eu/http://cvs.schmorp.de/libev/ev.pod#Examples_CONTENT-9
*/
$loop        = EvLoop::defaultLoop();
$socket_loop = NULL;
$embed       = NULL;

if (Ev::supportedBackends() & ~Ev::recommendedBackends() & Ev::BACKEND_KQUEUE) {
 if (($socket_loop = new EvLoop(Ev::BACKEND_KQUEUE))) {
  $embed = new EvEmbed($loop);
 }
}

if (!$socket_loop) {
 $socket_loop = $loop;
}

// Now use $socket_loop for all sockets, and $loop for anything else
?>

Ayrıca Bakınız

  • EvEmbed
  • Ev::recommendedBackends() - Returns a bit mask of recommended backends for current platform.
  • Ev::supportedBackends() - Returns the set of backends supported by current libev configuration.
  • Backend flags
  • Examples
Ev::depth
Ev::feedSignal
Ev


Feed a signal event info Ev

Ev::embeddableBackends
Ev::feedSignalEvent
Ev
PHP Manual

Ev::feedSignal

(PECL ev >= 0.2.0)

Ev::feedSignal — Feed a signal event info Ev

Açıklama

final public static void Ev::feedSignal ( int $signum )

Simulates a signal receive. It is safe to call this function at any time, from any context, including signal handlers or random threads. Its main use is to customise signal handling in the process.

Unlike Ev::feedSignalEvent() , this works regardless of which loop has registered the signal.

Değiştirgeler

signum

Signal number. See signal(7) man page for detals. You can use constants exported by pcntl extension.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • Ev::feedSignalEvent() - Feed signal event into the default loop
Ev::embeddableBackends
Ev::feedSignalEvent
Ev


Feed signal event into the default loop

Ev::feedSignal
Ev::iteration
Ev
PHP Manual

Ev::feedSignalEvent

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Ev::feedSignalEvent — Feed signal event into the default loop

Açıklama

final public static void Ev::feedSignalEvent ( int $signum )

Feed signal event into the default loop. Ev will react to this call as if the signal specified by signal had occurred.

Değiştirgeler

signum

Signal number. See signal(7) man page for detals. See also constants exported by pcntl extension.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • Ev::feedSignal() - Feed a signal event info Ev
Ev::feedSignal
Ev::iteration
Ev


Return the number of times the default event loop has polled for new events.

Ev::feedSignalEvent
Ev::now
Ev
PHP Manual

Ev::iteration

(PECL ev >= 0.2.0)

Ev::iteration — Return the number of times the default event loop has polled for new events.

Açıklama

final public static int Ev::iteration ( void )

Return the number of times the event loop has polled for new events. Sometimes useful as a generation counter.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns number of polls of the default event loop.

Ayrıca Bakınız

  • Ev::depth() - Returns recursion depth
Ev::feedSignalEvent
Ev::now
Ev


Returns the time when the last iteration of the default event loop has started.

Ev::iteration
Ev::nowUpdate
Ev
PHP Manual

Ev::now

(PECL ev >= 0.2.0)

Ev::now — Returns the time when the last iteration of the default event loop has started.

Açıklama

final public static double Ev::now ( void )

Returns the time when the last iteration of the default event loop has started. This is the time that timers( EvTimer and EvPeriodic ) are based on, and referring to it is usually faster then calling Ev::time() .

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns number of seconds(fractional) representing the time when the last iteration of the default event loop has started.

Ayrıca Bakınız

  • Ev::nowUpdate() - Establishes the current time by querying the kernel, updating the time returned by Ev::now in the progress.
Ev::iteration
Ev::nowUpdate
Ev


Establishes the current time by querying the kernel, updating the time returned by Ev::now in the progress.

Ev::now
Ev::recommendedBackends
Ev
PHP Manual

Ev::nowUpdate

(PECL ev >= 0.2.0)

Ev::nowUpdate — Establishes the current time by querying the kernel, updating the time returned by Ev::now in the progress.

Açıklama

final public static void Ev::nowUpdate ( void )

Establishes the current time by querying the kernel, updating the time returned by Ev::now() in the progress. This is a costly operation and is usually done automatically within Ev::run() .

This method is rarely useful, but when some event callback runs for a very long time without entering the event loop, updating libev 's consideration of the current time is a good idea.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • Ev::now() - Returns the time when the last iteration of the default event loop has started.
Ev::now
Ev::recommendedBackends
Ev


Returns a bit mask of recommended backends for current platform.

Ev::nowUpdate
Ev::resume
Ev
PHP Manual

Ev::recommendedBackends

(PECL ev >= 0.2.0)

Ev::recommendedBackends — Returns a bit mask of recommended backends for current platform.

Açıklama

final public static void Ev::recommendedBackends ( void )

Returns the set of all backends compiled into this binary of libev and also recommended for this platform, meaning it will work for most file descriptor types. This set is often smaller than the one returned by ev_supported_backends() , as for example kqueue is broken on most BSD systems and will not be auto-detected unless it is requested explicitly. This is the set of backends that libev will probe no backends specified explicitly.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a bit mask which can containing backend flags combined using bitwise OR operator.

Örnekler

Örnek 1 Embedding one loop into another

<?php
/*
* Try to get an embeddable event loop and embed it into the default event loop.
* If it is impossible, use the default
* loop. The default loop is stored in $loop_hi, while the embeddable loop is
* stored in $loop_lo(which is $loop_hi in the case no embeddable loop can be
* used).
*
* Sample translated to PHP
* http://pod.tst.eu/http://cvs.schmorp.de/libev/ev.pod#Examples_CONTENT-9
*/
$loop_hi = EvLoop::defaultLoop();
$loop_lo = NULL;
$embed   = NULL;

/*
* See if there is a chance of getting one that works
* (flags' value of 0 means autodetection)
*/
$loop_lo = Ev::embeddableBackends() & Ev::recommendedBackends()
 ? new EvLoop(Ev::embeddableBackends() & Ev::recommendedBackends())
 : 0;

if ($loop_lo) {
 $embed = new EvEmbed($loop_lo, function () {});
} else {
 $loop_lo = $loop_hi;
}
?>

Ayrıca Bakınız

  • EvEmbed
  • Ev::embeddableBackends() - Returns the set of backends that are embeddable in other event loops.
  • Ev::supportedBackends() - Returns the set of backends supported by current libev configuration.
  • Backend flags
  • Examples
Ev::nowUpdate
Ev::resume
Ev


Resume previously suspended default event loop

Ev::recommendedBackends
Ev::run
Ev
PHP Manual

Ev::resume

(PECL ev >= 0.2.0)

Ev::resume — Resume previously suspended default event loop

Açıklama

final public static void Ev::resume ( void )

Ev::suspend() and Ev::resume() methods suspend and resume a loop correspondingly.

All timer watchers will be delayed by the time spend between suspend and resume , and all periodic watchers will be rescheduled(that is, they will lose any events that would have occurred while suspended).

After calling Ev::suspend() it is not allowed to call any function on the given loop other than Ev::resume() . Also it is not allowed to call Ev::resume() without a previous call to Ev::suspend() .

Calling suspend / resume has the side effect of updating the event loop time(see Ev::nowUpdate() ).

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • Ev::suspend() - Suspend the default event loop
Ev::recommendedBackends
Ev::run
Ev


Begin checking for events and calling callbacks for the default loop

Ev::resume
Ev::sleep
Ev
PHP Manual

Ev::run

(PECL ev >= 0.2.0)

Ev::run — Begin checking for events and calling callbacks for the default loop

Açıklama

final public static void Ev::run ([ int $flags ] )

Begin checking for events and calling callbacks for the default loop . Returns when a callback calls Ev::stop() method, or the flags are nonzero(in which case the return value is true) or when there are no active watchers which reference the loop( EvWatcher::keepalive() is TRUE), in which case the return value will be FALSE. The return value can generally be interpreted as if TRUE, there is more work left to do .

Değiştirgeler

flags

Optional parameter flags can be one of the following:

List for possible values of flags
flags | Description
0 | The default behavior described above
Ev::RUN_ONCE | Block at most one(wait, but don't loop)
Ev::RUN_NOWAIT | Don't block at all(fetch/handle events, but don't wait)

See the run flag constants .

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • Ev::stop() - Stops the default event loop
  • EvLoop::run() - Begin checking for events and calling callbacks for the loop
Ev::resume
Ev::sleep
Ev


Block the process for the given number of seconds.

Ev::run
Ev::stop
Ev
PHP Manual

Ev::sleep

(PECL ev >= 0.2.0)

Ev::sleep — Block the process for the given number of seconds.

Açıklama

final public static void Ev::sleep ( double $seconds )

Block the process for the given number of seconds.

Değiştirgeler

seconds

Fractional number of seconds

Dönen Değerler

Hiçbir değer dönmez.

Ev::run
Ev::stop
Ev


Stops the default event loop

Ev::sleep
Ev::supportedBackends
Ev
PHP Manual

Ev::stop

(PECL ev >= 0.2.0)

Ev::stop — Stops the default event loop

Açıklama

final public static void Ev::stop ([ int $how ] )

Stops the default event loop

Değiştirgeler

how

One of Ev::BREAK_* constants .

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • Ev::run() - Begin checking for events and calling callbacks for the default loop
Ev::sleep
Ev::supportedBackends
Ev


Returns the set of backends supported by current libev configuration.

Ev::stop
Ev::suspend
Ev
PHP Manual

Ev::supportedBackends

(PECL ev >= 0.2.0)

Ev::supportedBackends — Returns the set of backends supported by current libev configuration.

Açıklama

final public static void Ev::supportedBackends ( void )

Returns the set of backends supported by current libev configuration.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a bit mask which can containing backend flags combined using bitwise OR operator.

Örnekler

Örnek 1 Embedding loop created with kqueue backend into the default loop

<?php
/*
* Check if kqueue is available but not recommended and create a kqueue backend
* for use with sockets (which usually work with any kqueue implementation).
* Store the kqueue/socket-only event loop in loop_socket. (One might optionally
* use EVFLAG_NOENV, too)
*
* Example borrowed from
* http://pod.tst.eu/http://cvs.schmorp.de/libev/ev.pod#Examples_CONTENT-9
*/
$loop        = EvLoop::defaultLoop();
$socket_loop = NULL;
$embed       = NULL;

if (Ev::supportedBackends() & ~Ev::recommendedBackends() & Ev::BACKEND_KQUEUE) {
 if (($socket_loop = new EvLoop(Ev::BACKEND_KQUEUE))) {
  $embed = new EvEmbed($loop);
 }
}

if (!$socket_loop) {
 $socket_loop = $loop;
}

// Now use $socket_loop for all sockets, and $loop for anything else
?>

Ayrıca Bakınız

  • EvEmbed
  • Ev::recommendedBackends() - Returns a bit mask of recommended backends for current platform.
  • Ev::embeddableBackends() - Returns the set of backends that are embeddable in other event loops.
  • Backend flags
  • Examples
Ev::stop
Ev::suspend
Ev


Suspend the default event loop

Ev::supportedBackends
Ev::time
Ev
PHP Manual

Ev::suspend

(PECL ev >= 0.2.0)

Ev::suspend — Suspend the default event loop

Açıklama

final public static void Ev::suspend ( void )

Ev::suspend() and Ev::resume() methods suspend and resume the default loop correspondingly.

All timer watchers will be delayed by the time spend between suspend and resume , and all periodic watchers will be rescheduled(that is, they will lose any events that would have occurred while suspended).

After calling Ev::suspend() it is not allowed to call any function on the given loop other than Ev::resume() . Also it is not allowed to call Ev::resume() without a previous call to Ev::suspend() .

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • Ev::resume() - Resume previously suspended default event loop
Ev::supportedBackends
Ev::time
Ev


Returns the current time in fractional seconds since the epoch.

Ev::suspend
Ev::verify
Ev
PHP Manual

Ev::time

(PECL ev >= 0.2.0)

Ev::time — Returns the current time in fractional seconds since the epoch.

Açıklama

final public static double Ev::time ( void )

Returns the current time in fractional seconds since the epoch. Consider using Ev::now()

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the current time in fractional seconds since the epoch.

Ayrıca Bakınız

  • Ev::now() - Returns the time when the last iteration of the default event loop has started.
Ev::suspend
Ev::verify
Ev


Performs internal consistency checks(for debugging)

Ev::time
EvCheck
Ev
PHP Manual

Ev::verify

(PECL ev >= 0.2.0)

Ev::verify — Performs internal consistency checks(for debugging)

Açıklama

final public static void Ev::verify ( void )

Performs internal consistency checks(for debugging libev ) and abort the program if any data structures were found to be corrupted.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Ev::time
EvCheck
Ev


The EvCheck class

(PECL ev >= 0.2.0)

Giriş

EvPrepare and EvCheck watchers are usually used in pairs. EvPrepare watchers get invoked before the process blocks, EvCheck afterwards.

It is not allowed to call EvLoop::run() or similar methods or functions that enter the current event loop from either EvPrepare or EvCheck watchers. Other loops than the current one are fine, however. The rationale behind this is that one don't need to check for recursion in those watchers, i.e. the sequence will always be: EvPrepare -> blocking -> EvCheck , so having a watcher of each kind they will always be called in pairs bracketing the blocking call.

The main purpose is to integrate other event mechanisms into libev and their use is somewhat advanced. They could be used, for example, to track variable changes, implement custom watchers, integrate net-snmp or a coroutine library and lots more. They are also occasionally useful to cache some data and want to flush it before blocking.

It is recommended to give EvCheck watchers highest( Ev::MAXPRI ) priority, to ensure that they are being run before any other watchers after the poll (this doesn't matter for EvPrepare watchers).

Also, EvCheck watchers should not activate/feed events. While libev fully supports this, they might get executed before other EvCheck watchers did their job.

Sınıf Sözdizimi

EvCheck extends EvWatcher {
/* Miras alınan özellikler */
public $is_active ;
public $data ;
public $is_pending ;
public $priority ;
/* Yöntemler */
public __construct ( callable $callback [, mixed $data [, int $priority ]] )
final public static object createStopped ( string $callback [, string $data [, string $priority ]] )
/* Miras alınan yöntemler */
public int EvWatcher::clear ( void )
abstract public EvWatcher::__construct ( void )
public void EvWatcher::feed ( int $revents )
public EvLoop EvWatcher::getLoop ( void )
public void EvWatcher::invoke ( int $revents )
public bool EvWatcher::keepalive ([ bool $value ] )
public void EvWatcher::setCallback ( callable $callback )
public void EvWatcher::start ( void )
public void EvWatcher::stop ( void )
}

İçindekiler

  • EvCheck::__construct — Constructs the EvCheck watcher object
  • EvCheck::createStopped — Create instance of a stopped EvCheck watcher
Ev::verify
EvCheck::__construct
Ev


Constructs the EvCheck watcher object

EvCheck
EvCheck::createStopped
EvCheck
PHP Manual

EvCheck::__construct

(PECL ev >= 0.2.0)

EvCheck::__construct — Constructs the EvCheck watcher object

Açıklama

public EvCheck::__construct ( callable $callback [, mixed $data [, int $priority ]] )

Constructs the EvCheck watcher object.

Değiştirgeler

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

Dönen Değerler

Returns EvCheck object on success.

Ayrıca Bakınız

  • EvPrepare
  • EvLoop::check() - Creates EvCheck object associated with the current event loop instance
EvCheck
EvCheck::createStopped
EvCheck


Create instance of a stopped EvCheck watcher

EvCheck::__construct
EvChild
EvCheck
PHP Manual

EvCheck::createStopped

(PECL ev >= 0.2.0)

EvCheck::createStopped — Create instance of a stopped EvCheck watcher

Açıklama

final public static object EvCheck::createStopped ( string $callback [, string $data [, string $priority ]] )

Create instance of a stopped EvCheck watcher

Değiştirgeler

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

Dönen Değerler

Returns EvCheck object on success.

Ayrıca Bakınız

  • EvPrepare
EvCheck::__construct
EvChild
EvCheck


The EvChild class

(PECL ev >= 0.2.0)

Giriş

EvChild watchers trigger when the process receives a SIGCHLD in response to some child status changes (most typically when a child dies or exits). It is permissible to install an EvChild watcher after the child has been forked(which implies it might have already exited), as long as the event loop isn't entered(or is continued from a watcher), i.e. forking and then immediately registering a watcher for the child is fine, but forking and registering a watcher a few event loop iterations later or in the next callback invocation is not.

It is allowed to register EvChild watchers in the default loop only.

Sınıf Sözdizimi

EvChild extends EvWatcher {
/* Özellikler */
public $pid ;
public $rpid ;
public $rstatus ;
/* Miras alınan özellikler */
public $is_active ;
public $data ;
public $is_pending ;
public $priority ;
/* Yöntemler */
public __construct ( int $pid , bool $trace , callable $callback [, mixed $data = NULL [, int $priority = 0 ]] )
final public static object createStopped ( int $pid , bool $trace , callable $callback [, mixed $data [, int $priority ]] )
public void set ( int $pid , bool $trace )
/* Miras alınan yöntemler */
public int EvWatcher::clear ( void )
abstract public EvWatcher::__construct ( void )
public void EvWatcher::feed ( int $revents )
public EvLoop EvWatcher::getLoop ( void )
public void EvWatcher::invoke ( int $revents )
public bool EvWatcher::keepalive ([ bool $value ] )
public void EvWatcher::setCallback ( callable $callback )
public void EvWatcher::start ( void )
public void EvWatcher::stop ( void )
}

Özellikler

pid

Readonly . The process ID this watcher watches out for, or 0 , meaning any process ID.

rpid

Readonly .The process ID that detected a status change.

rstatus

Readonly . The process exit status caused by rpid .

İçindekiler

  • EvChild::__construct — Constructs the EvChild watcher object
  • EvChild::createStopped — Create instance of a stopped EvCheck watcher
  • EvChild::set — Configures the watcher
EvCheck::createStopped
EvChild::__construct
Ev


Constructs the EvChild watcher object

EvChild
EvChild::createStopped
EvChild
PHP Manual

EvChild::__construct

(PECL ev >= 0.2.0)

EvChild::__construct — Constructs the EvChild watcher object

Açıklama

public EvChild::__construct ( int $pid , bool $trace , callable $callback [, mixed $data = NULL [, int $priority = 0 ]] )

Constructs the EvChild watcher object.

Call the callback when a status change for process ID pid (or any PID if pid is 0 ) has been received(a status change happens when the process terminates or is killed, or, when trace is TRUE, additionally when it is stopped or continued). In other words, when the process receives a SIGCHLD , Ev will fetch the outstanding exit/wait status for all changed/zombie children and call the callback.

It is valid to install a child watcher after an EvChild has exited but before the event loop has started its next iteration. For example, first one calls fork , then the new child process might exit, and only then an EvChild watcher is installed in the parent for the new PID .

You can access both exit/tracing status and pid by using the rstatus and rpid properties of the watcher object.

The number of PID watchers per PID is unlimited. All of them will be called.

The EvChild::createStopped() method doesn't start(activate) the newly created watcher.

Değiştirgeler

pid

Wait for status changes of process PID(or any process if PID is specified as 0 ).

trace

If FALSE, only activate the watcher when the process terminates. Otherwise(TRUE) additionally activate the watcher when the process is stopped or continued.

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

Dönen Değerler

Returns EvChild object on success.

Ayrıca Bakınız

  • EvLoop::child() - Creates EvChild object associated with the current event loop
EvChild
EvChild::createStopped
EvChild


Create instance of a stopped EvCheck watcher

EvChild::__construct
EvChild::set
EvChild
PHP Manual

EvChild::createStopped

(PECL ev >= 0.2.0)

EvChild::createStopped — Create instance of a stopped EvCheck watcher

Açıklama

final public static object EvChild::createStopped ( int $pid , bool $trace , callable $callback [, mixed $data [, int $priority ]] )

The same as EvChild::__construct() , but doesn't start the watcher automatically.

Değiştirgeler

pid

The same as for EvChild::__construct()

trace

The same as for EvChild::__construct()

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

Dönen Değerler

Ayrıca Bakınız

  • EvChild::__construct() - Constructs the EvChild watcher object
  • EvLoop::child() - Creates EvChild object associated with the current event loop
EvChild::__construct
EvChild::set
EvChild


Configures the watcher

EvChild::createStopped
EvEmbed
EvChild
PHP Manual

EvChild::set

(PECL ev >= 0.2.0)

EvChild::set — Configures the watcher

Açıklama

public void EvChild::set ( int $pid , bool $trace )

Değiştirgeler

pid

The same as for EvChild::__construct()

trace

The same as for EvChild::__construct()

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • EvChild::__construct() - Constructs the EvChild watcher object
EvChild::createStopped
EvEmbed
EvChild


The EvEmbed class

(PECL ev >= 0.2.0)

Giriş

Used to embed one event loop into another.

Sınıf Sözdizimi

EvEmbed extends EvWatcher {
/* Özellikler */
public $embed ;
/* Yöntemler */
public __construct ( object $other [, callable $callback [, mixed $data [, int $priority ]]] )
final public static void createStopped ( object $other [, callable $callback [, mixed $data [, int $priority ]]] )
public void set ( object $other )
public void sweep ( void )
/* Miras alınan yöntemler */
public int EvWatcher::clear ( void )
abstract public EvWatcher::__construct ( void )
public void EvWatcher::feed ( int $revents )
public EvLoop EvWatcher::getLoop ( void )
public void EvWatcher::invoke ( int $revents )
public bool EvWatcher::keepalive ([ bool $value ] )
public void EvWatcher::setCallback ( callable $callback )
public void EvWatcher::start ( void )
public void EvWatcher::stop ( void )
}

Özellikler

is_active

data

is_pending

priority

embed

İçindekiler

  • EvEmbed::__construct — Constructs the EvEmbed object
  • EvEmbed::createStopped — Create stopped EvEmbed watcher object
  • EvEmbed::set — Configures the watcher
  • EvEmbed::sweep — Make a single, non-blocking sweep over the embedded loop.
EvChild::set
EvEmbed::__construct
Ev


Constructs the EvEmbed object

EvEmbed
EvEmbed::createStopped
EvEmbed
PHP Manual

EvEmbed::__construct

(PECL ev >= 0.2.0)

EvEmbed::__construct — Constructs the EvEmbed object

Açıklama

public EvEmbed::__construct ( object $other [, callable $callback [, mixed $data [, int $priority ]]] )

This is a rather advanced watcher type that lets to embed one event loop into another(currently only IO events are supported in the embedded loop, other types of watchers might be handled in a delayed or incorrect fashion and must not be used).

See » the libev documentation for details.

This watcher is most useful on BSD systems without working kqueue to still be able to handle a large number of sockets. See example below.

Değiştirgeler

other

Instance of EvLoop . The loop to embed, this loop must be embeddable(see Ev::embeddableBackends() ).

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

Dönen Değerler

Returns EvEmbed object on success.

Örnekler

Örnek 1 Embedding loop created with kqueue backend into the default loop

<?php
/*
 * Check if kqueue is available but not recommended and create a kqueue backend
 * for use with sockets (which usually work with any kqueue implementation).
 * Store the kqueue/socket-only event loop in loop_socket. (One might optionally
 * use EVFLAG_NOENV, too)
 *
 * Example borrowed from
 * http://pod.tst.eu/http://cvs.schmorp.de/libev/ev.pod#Examples_CONTENT-9
 */
$loop        = EvLoop::defaultLoop();
$socket_loop = NULL;
$embed       = NULL;

if (Ev::supportedBackends() & ~Ev::recommendedBackends() & Ev::BACKEND_KQUEUE) {
    if (($socket_loop = new EvLoop(Ev::BACKEND_KQUEUE))) {
        $embed = new EvEmbed($loop);
    }
}

if (!$socket_loop) {
    $socket_loop = $loop;
}

// Now use $socket_loop for all sockets, and $loop for anything else
?>

Ayrıca Bakınız

  • Ev::embeddableBackends() - Returns the set of backends that are embeddable in other event loops.
EvEmbed
EvEmbed::createStopped
EvEmbed


Create stopped EvEmbed watcher object

EvEmbed::__construct
EvEmbed::set
EvEmbed
PHP Manual

EvEmbed::createStopped

(PECL ev >= 0.2.0)

EvEmbed::createStopped — Create stopped EvEmbed watcher object

Açıklama

final public static void EvEmbed::createStopped ( object $other [, callable $callback [, mixed $data [, int $priority ]]] )

The same as EvEmbed::__construct() , but doesn't start the watcher automatically.

Değiştirgeler

other

The same as for EvEmbed::__construct()

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

Dönen Değerler

Returns stopped EvEmbed object on success.

Ayrıca Bakınız

  • EvEmbed::__construct() - Constructs the EvEmbed object
  • Ev::embeddableBackends() - Returns the set of backends that are embeddable in other event loops.
EvEmbed::__construct
EvEmbed::set
EvEmbed


Configures the watcher

EvEmbed::createStopped
EvEmbed::sweep
EvEmbed
PHP Manual

EvEmbed::set

(PECL ev >= 0.2.0)

EvEmbed::set — Configures the watcher

Açıklama

public void EvEmbed::set ( object $other )

Configures the watcher to use other event loop object.

Değiştirgeler

other

The same as for EvEmbed::__construct()

Dönen Değerler

Hiçbir değer dönmez.

EvEmbed::createStopped
EvEmbed::sweep
EvEmbed


Make a single, non-blocking sweep over the embedded loop.

EvEmbed::set
EvFork
EvEmbed
PHP Manual

EvEmbed::sweep

(PECL ev >= 0.2.0)

EvEmbed::sweep — Make a single, non-blocking sweep over the embedded loop.

Açıklama

public void EvEmbed::sweep ( void )

Make a single, non-blocking sweep over the embedded loop. Works similarly to the following, but in the most appropriate way for embedded loops:

<?php
$other->start(Ev::RUN_NOWAIT);
?>

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • EvWatcher::start() - Starts the watcher
EvEmbed::set
EvFork
EvEmbed


The EvFork class

(PECL ev >= 0.2.0)

Giriş

Fork watchers are called when a fork() was detected (usually because whoever signalled libev about it by calling EvLoop::fork() ). The invocation is done before the event loop blocks next and before EvCheck watchers are being called, and only in the child after the fork. Note, that if whoever calling EvLoop::fork() calls it in the wrong process, the fork handlers will be invoked, too.

Sınıf Sözdizimi

EvFork extends EvWatcher {
/* Miras alınan özellikler */
public $is_active ;
public $data ;
public $is_pending ;
public $priority ;
/* Yöntemler */
public __construct ( callable $callback [, mixed $data = NULL [, int $priority = 0 ]] )
final public static object createStopped ( string $callback [, string $data [, string $priority ]] )
/* Miras alınan yöntemler */
public int EvWatcher::clear ( void )
abstract public EvWatcher::__construct ( void )
public void EvWatcher::feed ( int $revents )
public EvLoop EvWatcher::getLoop ( void )
public void EvWatcher::invoke ( int $revents )
public bool EvWatcher::keepalive ([ bool $value ] )
public void EvWatcher::setCallback ( callable $callback )
public void EvWatcher::start ( void )
public void EvWatcher::stop ( void )
}

İçindekiler

  • EvFork::__construct — Constructs the EvFork watcher object
  • EvFork::createStopped — Creates a stopped instance of EvFork watcher class
EvEmbed::sweep
EvFork::__construct
Ev


Constructs the EvFork watcher object

EvFork
EvFork::createStopped
EvFork
PHP Manual

EvFork::__construct

(PECL ev >= 0.2.0)

EvFork::__construct — Constructs the EvFork watcher object

Açıklama

public EvFork::__construct ( callable $callback [, mixed $data = NULL [, int $priority = 0 ]] )

Constructs the EvFork watcher object and starts the watcher automatically.

Değiştirgeler

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

Dönen Değerler

Returns EvFork object on success.

Ayrıca Bakınız

  • EvLoop::fork() - Creates EvFork watcher object associated with the current event loop instance
  • EvCheck
EvFork
EvFork::createStopped
EvFork


Creates a stopped instance of EvFork watcher class

EvFork::__construct
EvIdle
EvFork
PHP Manual

EvFork::createStopped

(PECL ev >= 0.2.0)

EvFork::createStopped — Creates a stopped instance of EvFork watcher class

Açıklama

final public static object EvFork::createStopped ( string $callback [, string $data [, string $priority ]] )

The same as EvFork::__construct() , but doesn't start the watcher automatically.

Değiştirgeler

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

Dönen Değerler

Returns EvFork(stopped) object on success.

Ayrıca Bakınız

  • EvFork::__construct() - Constructs the EvFork watcher object
EvFork::__construct
EvIdle
EvFork


The EvIdle class

(PECL ev >= 0.2.0)

Giriş

EvIdle watchers trigger events when no other events of the same or higher priority are pending ( EvPrepare , EvCheck and other EvIdle watchers do not count as receiving events ).

Thus, as long as the process is busy handling sockets or timeouts(or even signals) of the same or higher priority it will not be triggered. But when the process is in idle(or only lower-priority watchers are pending), the EvIdle watchers are being called once per event loop iteration - until stopped, that is, or the process receives more events and becomes busy again with higher priority stuff.

Apart from keeping the process non-blocking(which is a useful on its own sometimes), EvIdle watchers are a good place to do "pseudo-background processing" , or delay processing stuff to after the event loop has handled all outstanding events.

The most noticeable effect is that as long as any idle watchers are active, the process will not block when waiting for new events.

Sınıf Sözdizimi

EvIdle extends EvWatcher {
/* Miras alınan özellikler */
public $is_active ;
public $data ;
public $is_pending ;
public $priority ;
/* Yöntemler */
public __construct ( callable $callback [, mixed $data [, int $priority ]] )
final public static object createStopped ( string $callback [, mixed $data [, int $priority ]] )
/* Miras alınan yöntemler */
public int EvWatcher::clear ( void )
abstract public EvWatcher::__construct ( void )
public void EvWatcher::feed ( int $revents )
public EvLoop EvWatcher::getLoop ( void )
public void EvWatcher::invoke ( int $revents )
public bool EvWatcher::keepalive ([ bool $value ] )
public void EvWatcher::setCallback ( callable $callback )
public void EvWatcher::start ( void )
public void EvWatcher::stop ( void )
}

İçindekiler

  • EvIdle::__construct — Constructs the EvIdle watcher object
  • EvIdle::createStopped — Creates instance of a stopped EvIdle watcher object
EvFork::createStopped
EvIdle::__construct
Ev


Constructs the EvIdle watcher object

EvIdle
EvIdle::createStopped
EvIdle
PHP Manual

EvIdle::__construct

(PECL ev >= 0.2.0)

EvIdle::__construct — Constructs the EvIdle watcher object

Açıklama

public EvIdle::__construct ( callable $callback [, mixed $data [, int $priority ]] )

Constructs the EvIdle watcher object and starts the watcher automatically.

Değiştirgeler

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

Dönen Değerler

Returns EvIdle object on success.

Ayrıca Bakınız

  • EvIdle::createStopped() - Creates instance of a stopped EvIdle watcher object
  • EvLoop::idle() - Creates EvIdle watcher object associated with the current event loop instance
EvIdle
EvIdle::createStopped
EvIdle


Creates instance of a stopped EvIdle watcher object

EvIdle::__construct
EvIo
EvIdle
PHP Manual

EvIdle::createStopped

(PECL ev >= 0.2.0)

EvIdle::createStopped — Creates instance of a stopped EvIdle watcher object

Açıklama

final public static object EvIdle::createStopped ( string $callback [, mixed $data [, int $priority ]] )

The same as EvIdle::__construct() , but doesn't start the watcher automatically.

Değiştirgeler

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

Dönen Değerler

Returns EvIdle object on success.

Ayrıca Bakınız

  • EvIdle::__construct() - Constructs the EvIdle watcher object
  • EvLoop::idle() - Creates EvIdle watcher object associated with the current event loop instance
EvIdle::__construct
EvIo
EvIdle


The EvIo class

(PECL ev >= 0.2.0)

Giriş

EvIo watchers check whether a file descriptor(or socket, or a stream castable to numeric file descriptor) is readable or writable in each iteration of the event loop, or, more precisely, when reading would not block the process and writing would at least be able to write some data. This behaviour is called level-triggering because events are kept receiving as long as the condition persists. To stop receiving events just stop the watcher.

The number of read and/or write event watchers per fd is unlimited. Setting all file descriptors to non-blocking mode is also usually a good idea(but not required).

Another thing to watch out for is that it is quite easy to receive false readiness notifications, i.e. the callback might be called with Ev::READ but a subsequent read() will actually block because there is no data. It is very easy to get into this situation. Thus it is best to always use non-blocking I/O: An extra read() returning EAGAIN (or similar) is far preferable to a program hanging until some data arrives.

If for some reason it is impossible to run the fd in non-blocking mode, then separately re-test whether a file descriptor is really ready. Some people additionally use SIGALRM and an interval timer, just to be sure thry won't block infinitely.

Always consider using non-blocking mode.

Sınıf Sözdizimi

EvIo extends EvWatcher {
/* Özellikler */
public $fd ;
public $events ;
/* Miras alınan özellikler */
public $is_active ;
public $data ;
public $is_pending ;
public $priority ;
/* Yöntemler */
public __construct ( mixed $fd , int $events , callable $callback [, mixed $data [, int $priority ]] )
final public static EvIo createStopped ( mixed $fd , int $events , callable $callback [, mixed $data = NULL [, int $priority = 0 ]] )
public void set ( mixed $fd , int $events )
/* Miras alınan yöntemler */
public int EvWatcher::clear ( void )
abstract public EvWatcher::__construct ( void )
public void EvWatcher::feed ( int $revents )
public EvLoop EvWatcher::getLoop ( void )
public void EvWatcher::invoke ( int $revents )
public bool EvWatcher::keepalive ([ bool $value ] )
public void EvWatcher::setCallback ( callable $callback )
public void EvWatcher::start ( void )
public void EvWatcher::stop ( void )
}

Özellikler

fd

events

İçindekiler

  • EvIo::__construct — Constructs EvIo watcher object
  • EvIo::createStopped — Create stopped EvIo watcher object
  • EvIo::set — Configures the watcher
EvIdle::createStopped
EvIo::__construct
Ev


Constructs EvIo watcher object

EvIo
EvIo::createStopped
EvIo
PHP Manual

EvIo::__construct

(PECL ev >= 0.2.0)

EvIo::__construct — Constructs EvIo watcher object

Açıklama

public EvIo::__construct ( mixed $fd , int $events , callable $callback [, mixed $data [, int $priority ]] )

Constructs EvIo watcher object and starts the watcher automatically.

Değiştirgeler

fd

Can be a stream opened with fopen() or similar functions, numeric file descriptor, or socket.

events

Ev::READ and/or Ev::WRITE . See the bit masks .

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

Dönen Değerler

Returns EvIo object on success.

Ayrıca Bakınız

  • EvIo::createStopped() - Create stopped EvIo watcher object
  • EvLoop::io() - Create EvIo watcher object associated with the current event loop instance
EvIo
EvIo::createStopped
EvIo


Create stopped EvIo watcher object

EvIo::__construct
EvIo::set
EvIo
PHP Manual

EvIo::createStopped

(PECL ev >= 0.2.0)

EvIo::createStopped — Create stopped EvIo watcher object

Açıklama

final public static EvIo EvIo::createStopped ( mixed $fd , int $events , callable $callback [, mixed $data = NULL [, int $priority = 0 ]] )

The same as EvIo::__construct() , but doesn't start the watcher automatically.

Değiştirgeler

fd

The same as for EvIo::__construct()

events

The same as for EvIo::__construct()

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

Dönen Değerler

Returns EvIo object on success.

Ayrıca Bakınız

  • EvIo::__construct() - Constructs EvIo watcher object
  • EvLoop::io() - Create EvIo watcher object associated with the current event loop instance
EvIo::__construct
EvIo::set
EvIo


Configures the watcher

EvIo::createStopped
EvLoop
EvIo
PHP Manual

EvIo::set

(PECL ev >= 0.2.0)

EvIo::set — Configures the watcher

Açıklama

public void EvIo::set ( mixed $fd , int $events )

Configures the EvIo watcher

Değiştirgeler

fd

The same as for EvIo::__construct()

events

The same as for EvIo::__construct()

Dönen Değerler

Hiçbir değer dönmez.

EvIo::createStopped
EvLoop
EvIo


The EvLoop class

(PECL ev >= 0.2.0)

Giriş

Represents an event loop that is always distinct from the default loop . Unlike the default loop , it cannot handle EvChild watchers.

Having threads we have to create a loop per thread, and use the default loop in the parent thread.

The default event loop is initialized automatically by Ev . It is accessible via methods of the Ev class, or via EvLoop::defaultLoop() method.

Sınıf Sözdizimi

final EvLoop {
/* Özellikler */
public $data ;
public $backend ;
public $is_default_loop ;
public $iteration ;
public $pending ;
public $io_interval ;
public $timeout_interval ;
public $depth ;
/* Yöntemler */
public int backend ( void )
final public EvCheck check ( string $callback [, string $data [, string $priority ]] )
final public EvChild child ( string $pid , string $trace , string $callback [, string $data [, string $priority ]] )
public __construct ([ int $flags [, mixed $data = NULL [, double $io_interval = 0.0 [, double $timeout_interval = 0.0 ]]]] )
public static EvLoop defaultLoop ([ int $flags = Ev::FLAG_AUTO [, mixed $data = NULL [, double $io_interval = 0. [, double $timeout_interval = 0. ]]]] )
final public EvEmbed embed ( string $other [, string $callback [, string $data [, string $priority ]]] )
final public EvFork fork ( callable $callback [, mixed $data = NULL [, int $priority = 0 ]] )
final public EvIdle idle ( callable $callback [, mixed $data = NULL [, int $priority = 0 ]] )
public void invokePending ( void )
final public EvIo io ( mixed $fd , int $events , callable $callback [, mixed $data = NULL [, int $priority = 0 ]] )
public void loopFork ( void )
public double now ( void )
public void nowUpdate ( void )
final public EvPeriodic periodic ( double $offset , double $interval , callable $callback [, mixed $data = NULL [, int $priority = 0 ]] )
final public EvPrepare prepare ( callable $callback [, mixed $data = NULL [, int $priority = 0 ]] )
public void resume ( void )
public void run ([ int $flags = 0 ] )
final public EvSignal signal ( int $signum , callable $callback [, mixed $data = NULL [, int $priority = 0 ]] )
final public EvStat stat ( string $path , double $interval , callable $callback [, mixed $data = NULL [, int $priority = 0 ]] )
public void stop ([ int $how ] )
public void suspend ( void )
final public EvTimer timer ( double $after , double $repeat , callable $callback [, mixed $data = NULL [, int $priority = 0 ]] )
public void verify ( void )
}

Özellikler

data

Custom data attached to loop

backend

Readonly . The backend flags indicating the event backend in use.

is_default_loop

Readonly . TRUE if it is the default event loop.

iteration

The current iteration count of the loop. See Ev::iteration()

pending

The number of pending watchers. 0 indicates that there are no watchers pending.

io_interval

Higher io_interval allows libev to spend more time collecting EvIo events, so more events can be handled per iteration, at the cost of increasing latency. Timeouts (both EvPeriodic and EvTimer ) will not be affected. Setting this to a non-zero value will introduce an additional sleep() call into most loop iterations. The sleep time ensures that libev will not poll for EvIo events more often than once per this interval, on average. Many programs can usually benefit by setting the io_interval to a value near 0.1 , which is often enough for interactive servers(not for games). It usually doesn't make much sense to set it to a lower value than 0.01 , as this approaches the timing granularity of most systems.

See also » FUNCTIONS CONTROLLING EVENT LOOPS .

timeout_interval

Higher timeout_interval allows libev to spend more time collecting timeouts, at the expense of increased latency/jitter/inexactness(the watcher callback will be called later). EvIo watchers will not be affected. Setting this to a non-null value will not introduce any overhead in libev . See also » FUNCTIONS CONTROLLING EVENT LOOPS .

depth

The recursion depth. See Ev::depth() .

İçindekiler

  • EvLoop::backend — Returns an integer describing the backend used by libev.
  • EvLoop::check — Creates EvCheck object associated with the current event loop instance
  • EvLoop::child — Creates EvChild object associated with the current event loop
  • EvLoop::__construct — Constructs the event loop object
  • EvLoop::defaultLoop — Returns or creates the default event loop.
  • EvLoop::embed — Creates an instance of EvEmbed watcher associated with the current EvLoop object.
  • EvLoop::fork — Creates EvFork watcher object associated with the current event loop instance
  • EvLoop::idle — Creates EvIdle watcher object associated with the current event loop instance
  • EvLoop::invokePending — Invoke all pending watchers while resetting their pending state
  • EvLoop::io — Create EvIo watcher object associated with the current event loop instance
  • EvLoop::loopFork — Must be called after a fork
  • EvLoop::now — Returns the current "event loop time"
  • EvLoop::nowUpdate — Establishes the current time by querying the kernel, updating the time returned by EvLoop::now in the progress.
  • EvLoop::periodic — Creates EvPeriodic watcher object associated with the current event loop instance
  • EvLoop::prepare — Creates EvPrepare watcher object associated with the current event loop instance
  • EvLoop::resume — Resume previously suspended default event loop
  • EvLoop::run — Begin checking for events and calling callbacks for the loop
  • EvLoop::signal — Creates EvSignal watcher object associated with the current event loop instance
  • EvLoop::stat — Creates EvStat watcher object associated with the current event loop instance
  • EvLoop::stop — Stops the event loop
  • EvLoop::suspend — Suspend the loop
  • EvLoop::timer — Creates EvTimer watcher object associated with the current event loop instance
  • EvLoop::verify — Performs internal consistency checks(for debugging)
EvIo::set
EvLoop::backend
Ev


Returns an integer describing the backend used by libev.

EvLoop
EvLoop::check
EvLoop
PHP Manual

EvLoop::backend

(PECL ev >= 0.2.0)

EvLoop::backend — Returns an integer describing the backend used by libev.

Açıklama

public int EvLoop::backend ( void )

The same as Ev::backend() , but for the loop instance.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an integer describing the backend used by libev. See Ev::backend() .

Ayrıca Bakınız

  • Ev::backend() - Returns an integer describing the backend used by libev.
EvLoop
EvLoop::check
EvLoop


Creates EvCheck object associated with the current event loop instance

EvLoop::backend
EvLoop::child
EvLoop
PHP Manual

EvLoop::check

(PECL ev >= 0.2.0)

EvLoop::check — Creates EvCheck object associated with the current event loop instance

Açıklama

final public EvCheck EvLoop::check ( string $callback [, string $data [, string $priority ]] )

Creates EvCheck object associated with the current event loop instance.

Değiştirgeler

All parameters have the same meaning as for EvCheck::__construct()

Dönen Değerler

Returns EvCheck object on success.

Ayrıca Bakınız

  • EvCheck::__construct() - Constructs the EvCheck watcher object
EvLoop::backend
EvLoop::child
EvLoop


Creates EvChild object associated with the current event loop

EvLoop::check
EvLoop::__construct
EvLoop
PHP Manual

EvLoop::child

(PECL ev >= 0.2.0)

EvLoop::child — Creates EvChild object associated with the current event loop

Açıklama

final public EvChild EvLoop::child ( string $pid , string $trace , string $callback [, string $data [, string $priority ]] )

Creates EvChild object associated with the current event loop.

Değiştirgeler

All parameters have the same meaning as for EvChild::__construct()

Dönen Değerler

Returns EvChild object on success.

Ayrıca Bakınız

  • EvChild::__construct() - Constructs the EvChild watcher object
EvLoop::check
EvLoop::__construct
EvLoop


Constructs the event loop object

EvLoop::child
EvLoop::defaultLoop
EvLoop
PHP Manual

EvLoop::__construct

(PECL ev >= 0.2.0)

EvLoop::__construct — Constructs the event loop object

Açıklama

public EvLoop::__construct ([ int $flags [, mixed $data = NULL [, double $io_interval = 0.0 [, double $timeout_interval = 0.0 ]]]] )

Constructs the event loop object.

Değiştirgeler

flags

One of the event loop flags

data

Custom data associated with the loop.

io_interval

See io_interval

timeout_interval

See timeout_interval

Dönen Değerler

Returns new EvLoop object.

Ayrıca Bakınız

  • EvLoop::defaultLoop() - Returns or creates the default event loop.
EvLoop::child
EvLoop::defaultLoop
EvLoop


Returns or creates the default event loop.

EvLoop::__construct
EvLoop::embed
EvLoop
PHP Manual

EvLoop::defaultLoop

(PECL ev >= 0.2.0)

EvLoop::defaultLoop — Returns or creates the default event loop.

Açıklama

public static EvLoop EvLoop::defaultLoop ([ int $flags = Ev::FLAG_AUTO [, mixed $data = NULL [, double $io_interval = 0. [, double $timeout_interval = 0. ]]]] )

If the default event loop is not created, EvLoop::defaultLoop() creates it with the specified parameters. Otherwise, it just returns the object representing previously created instance ignoring all the parameters.

Değiştirgeler

flags

One of the event loop flags

data

Custom data to associate with the loop.

io_collect_interval

See io_interval

timeout_collect_interval

See timeout_interval

Dönen Değerler

Returns EvLoop object on success.

Ayrıca Bakınız

  • EvLoop::__construct() - Constructs the event loop object
EvLoop::__construct
EvLoop::embed
EvLoop


Creates an instance of EvEmbed watcher associated with the current EvLoop object.

EvLoop::defaultLoop
EvLoop::fork
EvLoop
PHP Manual

EvLoop::embed

(PECL ev >= 0.2.0)

EvLoop::embed — Creates an instance of EvEmbed watcher associated with the current EvLoop object.

Açıklama

final public EvEmbed EvLoop::embed ( string $other [, string $callback [, string $data [, string $priority ]]] )

Creates an instance of EvEmbed watcher associated with the current EvLoop object.

Değiştirgeler

All parameters have the same meaning as for EvEmbed::__construct() .

Dönen Değerler

Returns EvEmbed object on success.

Ayrıca Bakınız

  • EvEmbed::__construct() - Constructs the EvEmbed object
EvLoop::defaultLoop
EvLoop::fork
EvLoop


Creates EvFork watcher object associated with the current event loop instance

EvLoop::embed
EvLoop::idle
EvLoop
PHP Manual

EvLoop::fork

(PECL ev >= 0.2.0)

EvLoop::fork — Creates EvFork watcher object associated with the current event loop instance

Açıklama

final public EvFork EvLoop::fork ( callable $callback [, mixed $data = NULL [, int $priority = 0 ]] )

Creates EvFork watcher object associated with the current event loop instance

Değiştirgeler

All parameters have the same meaning as for EvFork::__construct()

Dönen Değerler

Returns EvFork object on success.

Ayrıca Bakınız

  • EvFork::__construct() - Constructs the EvFork watcher object
EvLoop::embed
EvLoop::idle
EvLoop


Creates EvIdle watcher object associated with the current event loop instance

EvLoop::fork
EvLoop::invokePending
EvLoop
PHP Manual

EvLoop::idle

(PECL ev >= 0.2.0)

EvLoop::idle — Creates EvIdle watcher object associated with the current event loop instance

Açıklama

final public EvIdle EvLoop::idle ( callable $callback [, mixed $data = NULL [, int $priority = 0 ]] )

Creates EvIdle watcher object associated with the current event loop instance

Değiştirgeler

All the parameters have the same meaning as for EvIdle::__construct()

Dönen Değerler

Returns EvIdle object on success.

Ayrıca Bakınız

  • EvIdle::__construct() - Constructs the EvIdle watcher object
EvLoop::fork
EvLoop::invokePending
EvLoop


Invoke all pending watchers while resetting their pending state

EvLoop::idle
EvLoop::io
EvLoop
PHP Manual

EvLoop::invokePending

(PECL ev >= 0.2.0)

EvLoop::invokePending — Invoke all pending watchers while resetting their pending state

Açıklama

public void EvLoop::invokePending ( void )

Invoke all pending watchers while resetting their pending state.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

EvLoop::idle
EvLoop::io
EvLoop


Create EvIo watcher object associated with the current event loop instance

EvLoop::invokePending
EvLoop::loopFork
EvLoop
PHP Manual

EvLoop::io

(PECL ev >= 0.2.0)

EvLoop::io — Create EvIo watcher object associated with the current event loop instance

Açıklama

final public EvIo EvLoop::io ( mixed $fd , int $events , callable $callback [, mixed $data = NULL [, int $priority = 0 ]] )

Create EvIo watcher object associated with the current event loop instance.

Değiştirgeler

All parameters have the same meaning as for EvIo::__construct()

Dönen Değerler

Returns EvIo object on success.

Ayrıca Bakınız

  • EvIo::__construct() - Constructs EvIo watcher object
EvLoop::invokePending
EvLoop::loopFork
EvLoop


Must be called after a fork

EvLoop::io
EvLoop::now
EvLoop
PHP Manual

EvLoop::loopFork

(PECL ev >= 0.2.0)

EvLoop::loopFork — Must be called after a fork

Açıklama

public void EvLoop::loopFork ( void )

Must be called after a fork in the child, before entering or continuing the event loop. An alternative is to use Ev::FLAG_FORKCHECK which calls this function automatically, at some performance loss (refer to the » libev documentation ).

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

EvLoop::io
EvLoop::now
EvLoop


Returns the current "event loop time"

EvLoop::loopFork
EvLoop::nowUpdate
EvLoop
PHP Manual

EvLoop::now

(PECL ev >= 0.2.0)

EvLoop::now — Returns the current "event loop time"

Açıklama

public double EvLoop::now ( void )

Returns the current "event loop time", which is the time the event loop received events and started processing them. This timestamp does not change as long as callbacks are being processed, and this is also the base time used for relative timers. You can treat it as the timestamp of the event occurring(or more correctly, libev finding out about it).

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns time of the event loop in (fractional) seconds.

Ayrıca Bakınız

  • Ev::now() - Returns the time when the last iteration of the default event loop has started.
EvLoop::loopFork
EvLoop::nowUpdate
EvLoop


Establishes the current time by querying the kernel, updating the time returned by EvLoop::now in the progress.

EvLoop::now
EvLoop::periodic
EvLoop
PHP Manual

EvLoop::nowUpdate

(PECL ev >= 0.2.0)

EvLoop::nowUpdate — Establishes the current time by querying the kernel, updating the time returned by EvLoop::now in the progress.

Açıklama

public void EvLoop::nowUpdate ( void )

Establishes the current time by querying the kernel, updating the time returned by EvLoop::now() in the progress. This is a costly operation and is usually done automatically within EvLoop::run() .

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • EvLoop::now() - Returns the current "event loop time"
  • Ev::nowUpdate() - Establishes the current time by querying the kernel, updating the time returned by Ev::now in the progress.
EvLoop::now
EvLoop::periodic
EvLoop


Creates EvPeriodic watcher object associated with the current event loop instance

EvLoop::nowUpdate
EvLoop::prepare
EvLoop
PHP Manual

EvLoop::periodic

(PECL ev >= 0.2.0)

EvLoop::periodic — Creates EvPeriodic watcher object associated with the current event loop instance

Açıklama

final public EvPeriodic EvLoop::periodic ( double $offset , double $interval , callable $callback [, mixed $data = NULL [, int $priority = 0 ]] )

Creates EvPeriodic watcher object associated with the current event loop instance

Değiştirgeler

All parameters have the same maening as for EvPeriodic::__construct()

Dönen Değerler

Returns EvPeriodic object on success.

Ayrıca Bakınız

  • EvPeriodic::__construct() - Constructs EvPeriodic watcher object
EvLoop::nowUpdate
EvLoop::prepare
EvLoop


Creates EvPrepare watcher object associated with the current event loop instance

EvLoop::periodic
EvLoop::resume
EvLoop
PHP Manual

EvLoop::prepare

(PECL ev >= 0.2.0)

EvLoop::prepare — Creates EvPrepare watcher object associated with the current event loop instance

Açıklama

final public EvPrepare EvLoop::prepare ( callable $callback [, mixed $data = NULL [, int $priority = 0 ]] )

Creates EvPrepare watcher object associated with the current event loop instance

Değiştirgeler

All parameters have the same maening as for EvPrepare()

Dönen Değerler

Returns EvPrepare object on success

Ayrıca Bakınız

  • EvPrepare::__construct() - Constructs EvPrepare watcher object
EvLoop::periodic
EvLoop::resume
EvLoop


Resume previously suspended default event loop

EvLoop::prepare
EvLoop::run
EvLoop
PHP Manual

EvLoop::resume

(PECL ev >= 0.2.0)

EvLoop::resume — Resume previously suspended default event loop

Açıklama

public void EvLoop::resume ( void )

EvLoop::suspend() and EvLoop::resume() methods suspend and resume a loop correspondingly.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • EvLoop::suspend() - Suspend the loop
  • Ev::resume() - Resume previously suspended default event loop
EvLoop::prepare
EvLoop::run
EvLoop


Begin checking for events and calling callbacks for the loop

EvLoop::resume
EvLoop::signal
EvLoop
PHP Manual

EvLoop::run

(PECL ev >= 0.2.0)

EvLoop::run — Begin checking for events and calling callbacks for the loop

Açıklama

public void EvLoop::run ([ int $flags = 0 ] )

Begin checking for events and calling callbacks for the current event loop. Returns when a callback calls Ev::stop() method, or the flags are nonzero(in which case the return value is true) or when there are no active watchers which reference the loop( EvWatcher::keepalive() is TRUE), in which case the return value will be FALSE. The return value can generally be interpreted as if TRUE, there is more work left to do .

Değiştirgeler

flags

Optional parameter flags can be one of the following:

List for possible values of flags
flags | Description
0 | The default behavior described above
Ev::RUN_ONCE | Block at most one(wait, but don't loop)
Ev::RUN_NOWAIT | Don't block at all(fetch/handle events, but don't wait)

See the run flag constants .

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • EvLoop::stop() - Stops the event loop
  • Ev::run() - Begin checking for events and calling callbacks for the default loop
EvLoop::resume
EvLoop::signal
EvLoop


Creates EvSignal watcher object associated with the current event loop instance

EvLoop::run
EvLoop::stat
EvLoop
PHP Manual

EvLoop::signal

(PECL ev >= 0.2.0)

EvLoop::signal — Creates EvSignal watcher object associated with the current event loop instance

Açıklama

final public EvSignal EvLoop::signal ( int $signum , callable $callback [, mixed $data = NULL [, int $priority = 0 ]] )

Creates EvSignal watcher object associated with the current event loop instance

Değiştirgeler

All parameters have the same meaning as for EvSignal::__construct()

Dönen Değerler

Returns EvSignal object on success

Ayrıca Bakınız

  • EvSignal::__construct() - Constructs EvPeriodic watcher object
EvLoop::run
EvLoop::stat
EvLoop


Creates EvStat watcher object associated with the current event loop instance

EvLoop::signal
EvLoop::stop
EvLoop
PHP Manual

EvLoop::stat

(PECL ev >= 0.2.0)

EvLoop::stat — Creates EvStat watcher object associated with the current event loop instance

Açıklama

final public EvStat EvLoop::stat ( string $path , double $interval , callable $callback [, mixed $data = NULL [, int $priority = 0 ]] )

Creates EvStat watcher object associated with the current event loop instance

Değiştirgeler

All parameters have the same meaning as for EvSignal::__construct()

Dönen Değerler

Returns EvStat object on success

Ayrıca Bakınız

  • EvSignal::__construct() - Constructs EvPeriodic watcher object
EvLoop::signal
EvLoop::stop
EvLoop


Stops the event loop

EvLoop::stat
EvLoop::suspend
EvLoop
PHP Manual

EvLoop::stop

(PECL ev >= 0.2.0)

EvLoop::stop — Stops the event loop

Açıklama

public void EvLoop::stop ([ int $how ] )

Stops the event loop

Değiştirgeler

how

One of Ev::BREAK_* constants .

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • EvLoop::run() - Begin checking for events and calling callbacks for the loop
  • Ev::stop() - Stops the default event loop
EvLoop::stat
EvLoop::suspend
EvLoop


Suspend the loop

EvLoop::stop
EvLoop::timer
EvLoop
PHP Manual

EvLoop::suspend

(PECL ev >= 0.2.0)

EvLoop::suspend — Suspend the loop

Açıklama

public void EvLoop::suspend ( void )

EvLoop::suspend() and EvLoop::resume() methods suspend and resume a loop correspondingly.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • EvLoop::resume() - Resume previously suspended default event loop
  • Ev::suspend() - Suspend the default event loop
EvLoop::stop
EvLoop::timer
EvLoop


Creates EvTimer watcher object associated with the current event loop instance

EvLoop::suspend
EvLoop::verify
EvLoop
PHP Manual

EvLoop::timer

(PECL ev >= 0.2.0)

EvLoop::timer — Creates EvTimer watcher object associated with the current event loop instance

Açıklama

final public EvTimer EvLoop::timer ( double $after , double $repeat , callable $callback [, mixed $data = NULL [, int $priority = 0 ]] )

Creates EvTimer watcher object associated with the current event loop instance

Değiştirgeler

All parameters have the same meaning as for EvTimer::__construct()

Dönen Değerler

Returns EvTimer object on success

Ayrıca Bakınız

  • EvTimer::__construct() - Constructs an EvTimer watcher object
EvLoop::suspend
EvLoop::verify
EvLoop


Performs internal consistency checks(for debugging)

EvLoop::timer
EvPeriodic
EvLoop
PHP Manual

EvLoop::verify

(PECL ev >= 0.2.0)

EvLoop::verify — Performs internal consistency checks(for debugging)

Açıklama

public void EvLoop::verify ( void )

Performs internal consistency checks(for debugging libev ) and abort the program if any data structures were found to be corrupted.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • Ev::verify() - Performs internal consistency checks(for debugging)
EvLoop::timer
EvPeriodic
EvLoop


The EvPeriodic class

(PECL ev >= 0.2.0)

Giriş

Periodic watchers are also timers of a kind, but they are very versatile.

Unlike EvTimer , EvPeriodic watchers are not based on real time(or relative time, the physical time that passes) but on wall clock time(absolute time, calendar or clock). The difference is that wall clock time can run faster or slower than real time, and time jumps are not uncommon(e.g. when adjusting it).

EvPeriodic watcher can be configured to trigger after some specific point in time. For example, if an EvPeriodic watcher is configured to trigger "in 10 seconds" (e.g. EvLoop::now() + 10.0 , i.e. an absolute time, not a delay), and the system clock is reset to January of the previous year , then it will take a year or more to trigger the event (unlike an EvTimer , which would still trigger roughly 10 seconds after starting it as it uses a relative timeout).

As with timers, the callback is guaranteed to be invoked only when the point in time where it is supposed to trigger has passed. If multiple timers become ready during the same loop iteration then the ones with earlier time-out values are invoked before ones with later time-out values (but this is no longer true when a callback calls EvLoop::run() recursively).

Sınıf Sözdizimi

EvPeriodic extends EvWatcher {
/* Özellikler */
public $offset ;
public $interval ;
/* Miras alınan özellikler */
public $is_active ;
public $data ;
public $is_pending ;
public $priority ;
/* Yöntemler */
public void again ( void )
public double at ( void )
public __construct ( double $offset , string $interval , callable $reschedule_cb , callable $callback [, mixed $data = NULL [, int $priority = 0 ]] )
final public static EvPeriodic createStopped ( double $offset , double $interval , callable $reschedule_cb , callable $callback [, mixed $data = NULL [, int $priority = 0 ]] )
public void set ( double $offset , double $interval )
/* Miras alınan yöntemler */
public int EvWatcher::clear ( void )
abstract public EvWatcher::__construct ( void )
public void EvWatcher::feed ( int $revents )
public EvLoop EvWatcher::getLoop ( void )
public void EvWatcher::invoke ( int $revents )
public bool EvWatcher::keepalive ([ bool $value ] )
public void EvWatcher::setCallback ( callable $callback )
public void EvWatcher::start ( void )
public void EvWatcher::stop ( void )
}

Özellikler

offset

When repeating, this contains the offset value, otherwise this is the absolute point in time(the offset value passed to EvPeriodic::set() , although libev might modify this value for better numerical stability).

interval

The current interval value. Can be modified any time, but changes only take effect when the periodic timer fires or EvPeriodic::again() is being called.

İçindekiler

  • EvPeriodic::again — Simply stops and restarts the periodic watcher again.
  • EvPeriodic::at — Returns the absolute time that this watcher is supposed to trigger next
  • EvPeriodic::__construct — Constructs EvPeriodic watcher object
  • EvPeriodic::createStopped — Create a stopped EvPeriodic watcher
  • EvPeriodic::set — Configures the watcher
EvLoop::verify
EvPeriodic::again
Ev


Simply stops and restarts the periodic watcher again.

EvPeriodic
EvPeriodic::at
EvPeriodic
PHP Manual

EvPeriodic::again

(PECL ev >= 0.2.0)

EvPeriodic::again — Simply stops and restarts the periodic watcher again.

Açıklama

public void EvPeriodic::again ( void )

Simply stops and restarts the periodic watcher again. This is only useful when attributes are changed.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • EvTimer::again() - Restarts the timer watcher
EvPeriodic
EvPeriodic::at
EvPeriodic


Returns the absolute time that this watcher is supposed to trigger next

EvPeriodic::again
EvPeriodic::__construct
EvPeriodic
PHP Manual

EvPeriodic::at

(PECL ev >= 0.2.0)

EvPeriodic::at — Returns the absolute time that this watcher is supposed to trigger next

Açıklama

public double EvPeriodic::at ( void )

When the watcher is active, returns the absolute time that this watcher is supposed to trigger next. This is not the same as the offset argument to EvPeriodic::set() or EvPeriodic::__construct() , but indeed works even in interval mode.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the absolute time this watcher is supposed to trigger next in seconds.

EvPeriodic::again
EvPeriodic::__construct
EvPeriodic


Constructs EvPeriodic watcher object

EvPeriodic::at
EvPeriodic::createStopped
EvPeriodic
PHP Manual

EvPeriodic::__construct

(PECL ev >= 0.2.0)

EvPeriodic::__construct — Constructs EvPeriodic watcher object

Açıklama

public EvPeriodic::__construct ( double $offset , string $interval , callable $reschedule_cb , callable $callback [, mixed $data = NULL [, int $priority = 0 ]] )

Constructs EvPeriodic watcher object and starts it automatically. EvPeriodic::createStopped() method creates stopped periodic watcher.

Değiştirgeler

offset

See Periodic watcher operation modes

interval

See Periodic watcher operation modes

reschedule_cb

Reschedule callback. You can pass NULL. See Periodic watcher operation modes

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

Dönen Değerler

Returns EvPeriodic object on success.

Örnekler

Örnek 1 Periodic timer. Use reschedule callback

<?php
// Tick each 10.5 seconds

function reschedule_cb ($watcher, $now) {
 return $now + (10.5. - fmod($now, 10.5));
}

$w = new EvPeriodic(0., 0., "reschedule_cb", function ($w, $revents) {
 echo time(), PHP_EOL;
});
Ev::run();
?>

Örnek 2 Periodic timer. Tick every 10.5 seconds starting at now

<?php
// Tick every 10.5 seconds starting at now
$w = new EvPeriodic(fmod(Ev::now(), 10.5), 10.5, NULL, function ($w, $revents) {
 echo time(), PHP_EOL;
});
Ev::run();
?>

Örnek 3 Hourly watcher

<?php
$hourly = EvPeriodic(0, 3600, NULL, function () {
 echo "once per hour\n";
});
?>

Ayrıca Bakınız

  • Periodic watcher operation modes
  • EvTimer
  • EvPeriodic::createStopped() - Create a stopped EvPeriodic watcher
EvPeriodic::at
EvPeriodic::createStopped
EvPeriodic


Create a stopped EvPeriodic watcher

EvPeriodic::__construct
EvPeriodic::set
EvPeriodic
PHP Manual

EvPeriodic::createStopped

(PECL ev >= 0.2.0)

EvPeriodic::createStopped — Create a stopped EvPeriodic watcher

Açıklama

final public static EvPeriodic EvPeriodic::createStopped ( double $offset , double $interval , callable $reschedule_cb , callable $callback [, mixed $data = NULL [, int $priority = 0 ]] )

Create EvPeriodic object. Unlike EvPeriodic::__construct() this method doesn't start the watcher automatically.

Değiştirgeler

offset

See Periodic watcher operation modes

interval

See Periodic watcher operation modes

reschedule_cb

Reschedule callback. You can pass NULL. See Periodic watcher operation modes

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

Dönen Değerler

Returns EvPeriodic watcher object on success.

Ayrıca Bakınız

  • EvPeriodic::__construct() - Constructs EvPeriodic watcher object
  • EvTimer::createStopped() - Creates EvTimer stopped watcher object
EvPeriodic::__construct
EvPeriodic::set
EvPeriodic


Configures the watcher

EvPeriodic::createStopped
EvPrepare
EvPeriodic
PHP Manual

EvPeriodic::set

(PECL ev >= 0.2.0)

EvPeriodic::set — Configures the watcher

Açıklama

public void EvPeriodic::set ( double $offset , double $interval )

(Re-)Configures EvPeriodic watcher

Değiştirgeler

offset

The same meaning as for EvPeriodic::__construct() . See Periodic watcher operation modes

interval

The same meaning as for EvPeriodic::__construct() . See Periodic watcher operation modes

Dönen Değerler

Hiçbir değer dönmez.

EvPeriodic::createStopped
EvPrepare
EvPeriodic


The EvPrepare class

(PECL ev >= 0.2.0)

Giriş

EvPrepare and EvCheck watchers are usually used in pairs. EvPrepare watchers get invoked before the process blocks, EvCheck afterwards.

It is not allowed to call EvLoop::run() or similar methods or functions that enter the current event loop from either EvPrepare or EvCheck watchers. Other loops than the current one are fine, however. The rationale behind this is that one don't need to check for recursion in those watchers, i.e. the sequence will always be: EvPrepare -> blocking -> EvCheck , so having a watcher of each kind they will always be called in pairs bracketing the blocking call.

The main purpose is to integrate other event mechanisms into libev and their use is somewhat advanced. They could be used, for example, to track variable changes, implement custom watchers, integrate net-snmp or a coroutine library and lots more. They are also occasionally useful to cache some data and want to flush it before blocking.

It is recommended to give EvCheck watchers highest( Ev::MAXPRI ) priority, to ensure that they are being run before any other watchers after the poll (this doesn't matter for EvPrepare watchers).

Also, EvCheck watchers should not activate/feed events. While libev fully supports this, they might get executed before other EvCheck watchers did their job.

Sınıf Sözdizimi

EvPrepare extends EvWatcher {
/* Miras alınan özellikler */
public $is_active ;
public $data ;
public $is_pending ;
public $priority ;
/* Yöntemler */
public __construct ( string $callback [, string $data [, string $priority ]] )
final public static EvPrepare createStopped ( callable $callback [, mixed $data = NULL [, int $priority = 0 ]] )
/* Miras alınan yöntemler */
public int EvWatcher::clear ( void )
abstract public EvWatcher::__construct ( void )
public void EvWatcher::feed ( int $revents )
public EvLoop EvWatcher::getLoop ( void )
public void EvWatcher::invoke ( int $revents )
public bool EvWatcher::keepalive ([ bool $value ] )
public void EvWatcher::setCallback ( callable $callback )
public void EvWatcher::start ( void )
public void EvWatcher::stop ( void )
}

İçindekiler

  • EvPrepare::__construct — Constructs EvPrepare watcher object
  • EvPrepare::createStopped — Creates a stopped instance of EvPrepare watcher
EvPeriodic::set
EvPrepare::__construct
Ev


Constructs EvPrepare watcher object

EvPrepare
EvPrepare::createStopped
EvPrepare
PHP Manual

EvPrepare::__construct

(PECL ev >= 0.2.0)

EvPrepare::__construct — Constructs EvPrepare watcher object

Açıklama

public EvPrepare::__construct ( string $callback [, string $data [, string $priority ]] )

Constructs EvPrepare watcher object. And starts the watcher automatically. If need a stopped watcher consider using EvPrepare::createStopped()

Değiştirgeler

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

Dönen Değerler

Returns EvPrepare object on success.

Ayrıca Bakınız

  • EvCheck
EvPrepare
EvPrepare::createStopped
EvPrepare


Creates a stopped instance of EvPrepare watcher

EvPrepare::__construct
EvSignal
EvPrepare
PHP Manual

EvPrepare::createStopped

(PECL ev >= 0.2.0)

EvPrepare::createStopped — Creates a stopped instance of EvPrepare watcher

Açıklama

final public static EvPrepare EvPrepare::createStopped ( callable $callback [, mixed $data = NULL [, int $priority = 0 ]] )

Creates a stopped instance of EvPrepare watcher. Unlike EvPrepare::__construct() , this method doesn' start the watcher automatically.

Değiştirgeler

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

Dönen Değerler

Return EvPrepare object on success.

Ayrıca Bakınız

  • EvPrepare::__construct() - Constructs EvPrepare watcher object
  • EvWatcher::start() - Starts the watcher
EvPrepare::__construct
EvSignal
EvPrepare


The EvSignal class

(PECL ev >= 0.2.0)

Giriş

EvSignal watchers will trigger an event when the process receives a specific signal one or more times. Even though signals are very asynchronous, libev will try its best to deliver signals synchronously, i.e. as part of the normal event processing, like any other event.

There is no limit for the number of watchers for the same signal, but only within the same loop, i.e. one can watch for SIGINT in the default loop and for SIGIO in another loop, but it is not allowed to watch for SIGINT in both the default loop and another loop at the same time. At the moment, SIGCHLD is permanently tied to the default loop.

If possible and supported, libev will install its handlers with SA_RESTART (or equivalent) behaviour enabled, so system calls should not be unduly interrupted. In case of a problem with system calls getting interrupted by signals, all the signals can be blocked in an EvCheck watcher and unblocked in a EvPrepare watcher.

Sınıf Sözdizimi

EvSignal extends EvWatcher {
/* Özellikler */
public $signum ;
/* Miras alınan özellikler */
public $is_active ;
public $data ;
public $is_pending ;
public $priority ;
/* Yöntemler */
public __construct ( int $signum , callable $callback [, mixed $data = NULL [, int $priority = 0 ]] )
final public static EvSignal createStopped ( int $signum , callable $callback [, mixed $data = NULL [, int $priority = 0 ]] )
public void set ( int $signum )
/* Miras alınan yöntemler */
public int EvWatcher::clear ( void )
abstract public EvWatcher::__construct ( void )
public void EvWatcher::feed ( int $revents )
public EvLoop EvWatcher::getLoop ( void )
public void EvWatcher::invoke ( int $revents )
public bool EvWatcher::keepalive ([ bool $value ] )
public void EvWatcher::setCallback ( callable $callback )
public void EvWatcher::start ( void )
public void EvWatcher::stop ( void )
}

Özellikler

signum

Signal number. See the constants exported by pcntl extension. See also signal(7) man page.

İçindekiler

  • EvSignal::__construct — Constructs EvPeriodic watcher object
  • EvSignal::createStopped — Create stopped EvSignal watcher object
  • EvSignal::set — Configures the watcher
EvPrepare::createStopped
EvSignal::__construct
Ev


Constructs EvPeriodic watcher object

EvSignal
EvSignal::createStopped
EvSignal
PHP Manual

EvSignal::__construct

(PECL ev >= 0.2.0)

EvSignal::__construct — Constructs EvPeriodic watcher object

Açıklama

public EvSignal::__construct ( int $signum , callable $callback [, mixed $data = NULL [, int $priority = 0 ]] )

Constructs EvPeriodic watcher object and starts it automatically. For a stopped periodic watcher consider using EvSignal::createStopped() method.

Değiştirgeler

signum

Signal number. See constants exported by pcntl extension. See also signal(7) man page.

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

Dönen Değerler

Returns EvSignal object on success.

Örnekler

Örnek 1 Handle SIGTERM signal

<?php
$w = new EvSignal(SIGTERM, function ($watcher) {
    echo "SIGTERM received\n";
    $watcher->stop();
});

Ev::run();
?>

Ayrıca Bakınız

  • EvSignal::createStopped() - Create stopped EvSignal watcher object
EvSignal
EvSignal::createStopped
EvSignal


Create stopped EvSignal watcher object

EvSignal::__construct
EvSignal::set
EvSignal
PHP Manual

EvSignal::createStopped

(PECL ev >= 0.2.0)

EvSignal::createStopped — Create stopped EvSignal watcher object

Açıklama

final public static EvSignal EvSignal::createStopped ( int $signum , callable $callback [, mixed $data = NULL [, int $priority = 0 ]] )

Create stopped EvSignal watcher object. Unlike EvSignal::__construct() , this method does't start the watcher automatically.

Değiştirgeler

signum

Signal number. See constants exported by pcntl extension. See also signal(7) man page.

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

Dönen Değerler

Returns EvSignal object on success.

Ayrıca Bakınız

  • EvWatcher::start() - Starts the watcher
  • EvSignal::__construct() - Constructs EvPeriodic watcher object
EvSignal::__construct
EvSignal::set
EvSignal


Configures the watcher

EvSignal::createStopped
EvStat
EvSignal
PHP Manual

EvSignal::set

(PECL ev >= 0.2.0)

EvSignal::set — Configures the watcher

Açıklama

public void EvSignal::set ( int $signum )

Configures the watcher.

Değiştirgeler

signum

Signal number. The same as for EvSignal::__construct()

Dönen Değerler

Hiçbir değer dönmez.

EvSignal::createStopped
EvStat
EvSignal


The EvStat class

(PECL ev >= 0.2.0)

Giriş

EvStat monitors a file system path for attribute changes. It calls stat() on that path in regular intervals(or when the OS signals it changed) and sees if it changed compared to the last time, invoking the callback if it did.

The path does not need to exist: changing from "path exists" to "path does not exist" is a status change like any other. The condition "path does not exist" is signified by the 'nlink' item being 0(returned by EvStat::attr() method).

The path must not end in a slash or contain special components such as '.' or .. . The path should be absolute: if it is relative and the working directory changes, then the behaviour is undefined.

Since there is no portable change notification interface available, the portable implementation simply calls stat() regularly on the path to see if it changed somehow. For this case a recommended polling interval can be specified. If one specifies a polling interval of 0.0 (highly recommended) then a suitable, unspecified default value will be used(which could be expected to be around 5 seconds, although this might change dynamically). libev will also impose a minimum interval which is currently around 0.1 , but that's usually overkill.

This watcher type is not meant for massive numbers of EvStat watchers, as even with OS-supported change notifications, this can be resource-intensive.

Sınıf Sözdizimi

EvStat extends EvWatcher {
/* Özellikler */
public $path ;
public $interval ;
/* Miras alınan özellikler */
public $is_active ;
public $data ;
public $is_pending ;
public $priority ;
/* Yöntemler */
public array attr ( void )
public __construct ( string $path , double $interval , callable $callback [, mixed $data = NULL [, int $priority = 0 ]] )
final public static void createStopped ( string $path , double $interval , callable $callback [, mixed $data = NULL [, int $priority = 0 ]] )
public void prev ( void )
public void set ( string $path , double $interval )
public bool stat ( void )
/* Miras alınan yöntemler */
public int EvWatcher::clear ( void )
abstract public EvWatcher::__construct ( void )
public void EvWatcher::feed ( int $revents )
public EvLoop EvWatcher::getLoop ( void )
public void EvWatcher::invoke ( int $revents )
public bool EvWatcher::keepalive ([ bool $value ] )
public void EvWatcher::setCallback ( callable $callback )
public void EvWatcher::start ( void )
public void EvWatcher::stop ( void )
}

Özellikler

interval

Readonly . Hint on how quickly a change is expected to be detected and should normally be specified as 0.0 to let libev choose a suitable value.

path

Readonly . The path to wait for status changes on.

İçindekiler

  • EvStat::attr — Returns the values most recently detected by Ev
  • EvStat::__construct — Constructs EvStat watcher object
  • EvStat::createStopped — Create a stopped EvStat watcher object
  • EvStat::prev — Returns the previous set of values returned by EvStat::attr
  • EvStat::set — Configures the watcher
  • EvStat::stat — Initiates the stat call
EvSignal::set
EvStat::attr
Ev


Returns the values most recently detected by Ev

EvStat
EvStat::__construct
EvStat
PHP Manual

EvStat::attr

(PECL ev >= 0.2.0)

EvStat::attr — Returns the values most recently detected by Ev

Açıklama

public array EvStat::attr ( void )

Returns array of the values most recently detected by Ev

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns array with the values most recently detect by Ev(without actual stat 'ing):

List for item keys of the array returned by EvStat::attr()
Key | Description
'dev' | ID of device containing file
'ino' | inode number
'mode' | protection
'nlink' | number of hard links
'uid' | user ID of owner
'size' | total size, in bytes
'gid' | group ID of owner
'rdev' | device ID (if special file)
'blksize' | blocksize for file system I/O
'blocks' | number of 512B blocks allocated
'atime' | time of last access
'ctime' | time of last status change
'mtime' | time of last modification

See stat(2) man page for details.

Örnekler

Örnek 1 Monitor changes of /var/log/messages

<?php
// Use 10 second update interval.
$w = new EvStat("/var/log/messages", 8, function ($w) {
    echo "/var/log/messages changed\n";

    $attr = $w->attr();

    if ($attr['nlink']) {
        printf("Current size: %ld\n", $attr['size']);
        printf("Current atime: %ld\n", $attr['atime']);
        printf("Current mtime: %ld\n", $attr['mtime']);
    } else {
        fprintf(STDERR, "`messages` file is not there!");
        $w->stop();
    }
});

Ev::run();
?>

Ayrıca Bakınız

  • EvStat::prev() - Returns the previous set of values returned by EvStat::attr
  • EvStat::stat() - Initiates the stat call
EvStat
EvStat::__construct
EvStat


Constructs EvStat watcher object

EvStat::attr
EvStat::createStopped
EvStat
PHP Manual

EvStat::__construct

(PECL ev >= 0.2.0)

EvStat::__construct — Constructs EvStat watcher object

Açıklama

public EvStat::__construct ( string $path , double $interval , callable $callback [, mixed $data = NULL [, int $priority = 0 ]] )

Constructs EvStat watcher object and starts the watcher automatically.

Değiştirgeler

path

The path to wait for status changes on.

interval

Hint on how quickly a change is expected to be detected and should normally be specified as 0.0 to let libev choose a suitable value.

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

Dönen Değerler

Returns EvStat watcher object on succes.

Örnekler

Örnek 1 Monitor changes of /var/log/messages

<?php
// Use 10 second update interval.
$w = new EvStat("/var/log/messages", 8, function ($w) {
 echo "/var/log/messages changed\n";

 $attr = $w->attr();

 if ($attr['nlink']) {
  printf("Current size: %ld\n", $attr['size']);
  printf("Current atime: %ld\n", $attr['atime']);
  printf("Current mtime: %ld\n", $attr['mtime']);
 } else {
  fprintf(STDERR, "`messages` file is not there!");
  $w->stop();
 }
});

Ev::run();
?>
EvStat::attr
EvStat::createStopped
EvStat


Create a stopped EvStat watcher object

EvStat::__construct
EvStat::prev
EvStat
PHP Manual

EvStat::createStopped

(PECL ev >= 0.2.0)

EvStat::createStopped — Create a stopped EvStat watcher object

Açıklama

final public static void EvStat::createStopped ( string $path , double $interval , callable $callback [, mixed $data = NULL [, int $priority = 0 ]] )

Creates EvStat watcher object, but doesn't start it automatically(unlike EvStat::__construct() ).

Değiştirgeler

path

The path to wait for status changes on.

interval

Hint on how quickly a change is expected to be detected and should normally be specified as 0.0 to let libev choose a suitable value.

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

Dönen Değerler

Returns a stopped EvStat watcher object on success.

Ayrıca Bakınız

  • EvStat::__construct() - Constructs EvStat watcher object
  • EvWatcher::start() - Starts the watcher
EvStat::__construct
EvStat::prev
EvStat


Returns the previous set of values returned by EvStat::attr

EvStat::createStopped
EvStat::set
EvStat
PHP Manual

EvStat::prev

(PECL ev >= 0.2.0)

EvStat::prev — Returns the previous set of values returned by EvStat::attr

Açıklama

public void EvStat::prev ( void )

Just like EvStat::attr() , but returns the previous set of values.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array with the same structure as the array returned by EvStat::attr() . The array contains previously detected values.

Ayrıca Bakınız

  • EvStat::attr() - Returns the values most recently detected by Ev
  • EvStat::stat() - Initiates the stat call
EvStat::createStopped
EvStat::set
EvStat


Configures the watcher

EvStat::prev
EvStat::stat
EvStat
PHP Manual

EvStat::set

(PECL ev >= 0.2.0)

EvStat::set — Configures the watcher

Açıklama

public void EvStat::set ( string $path , double $interval )

Configures the watcher.

Değiştirgeler

path

The path to wait for status changes on.

interval

Hint on how quickly a change is expected to be detected and should normally be specified as 0.0 to let libev choose a suitable value.

Dönen Değerler

Hiçbir değer dönmez.

EvStat::prev
EvStat::stat
EvStat


Initiates the stat call

EvStat::set
EvTimer
EvStat
PHP Manual

EvStat::stat

(PECL ev >= 0.2.0)

EvStat::stat — Initiates the stat call

Açıklama

public bool EvStat::stat ( void )

Initiates the stat call(updates internal cache). It stats(using lstat ) the path specified in the watcher and sets to the values found.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if path exists. Otherwise FALSE.

Ayrıca Bakınız

  • EvStat::attr() - Returns the values most recently detected by Ev
  • EvStat::prev() - Returns the previous set of values returned by EvStat::attr
EvStat::set
EvTimer
EvStat


The EvTimer class

(PECL ev >= 0.2.0)

Giriş

EvTimer watchers are simple relative timers that generate an event after a given time, and optionally repeating in regular intervals after that.

The timers are based on real time, that is, if one registers an event that times out after an hour and resets the system clock to January last year , it will still time out after(roughly) one hour. "Roughly" because detecting time jumps is hard, and some inaccuracies are unavoidable.

The callback is guaranteed to be invoked only after its timeout has passed (not at, so on systems with very low-resolution clocks this might introduce a small delay). If multiple timers become ready during the same loop iteration then the ones with earlier time-out values are invoked before ones of the same priority with later time-out values (but this is no longer true when a callback calls EvLoop::run() recursively).

The timer itself will do a best-effort at avoiding drift, that is, if a timer is configured to trigger every 10 seconds, then it will normally trigger at exactly 10 second intervals. If, however, the script cannot keep up with the timer because it takes longer than those 10 seconds to do) the timer will not fire more than once per event loop iteration.

Sınıf Sözdizimi

EvTimer extends EvWatcher {
/* Özellikler */
public $repeat ;
public $remaining ;
/* Miras alınan özellikler */
public $is_active ;
public $data ;
public $is_pending ;
public $priority ;
/* Yöntemler */
public void again ( void )
public __construct ( double $after , double $repeat , callable $callback [, mixed $data = NULL [, int $priority = 0 ]] )
final public static EvTimer createStopped ( double $after , double $repeat , callable $callback [, mixed $data = NULL [, int $priority = 0 ]] )
public void set ( double $after , double $repeat )
/* Miras alınan yöntemler */
public int EvWatcher::clear ( void )
abstract public EvWatcher::__construct ( void )
public void EvWatcher::feed ( int $revents )
public EvLoop EvWatcher::getLoop ( void )
public void EvWatcher::invoke ( int $revents )
public bool EvWatcher::keepalive ([ bool $value ] )
public void EvWatcher::setCallback ( callable $callback )
public void EvWatcher::start ( void )
public void EvWatcher::stop ( void )
}

Özellikler

repeat

If repeat is 0.0 , then it will automatically be stopped once the timeout is reached. If it is positive, then the timer will automatically be configured to trigger again every repeat seconds later, until stopped manually.

remaining

Returns the remaining time until a timer fires. If the timer is active, then this time is relative to the current event loop time, otherwise it's the timeout value currently configured.

That is, after instanciating an EvTimer with an after value of 5.0 and repeat value of 7.0 , remaining returns 5.0 . When the timer is started and one second passes, remaining will return 4.0 . When the timer expires and is restarted, it will return roughly 7.0 (likely slightly less as callback invocation takes some time too), and so on.

İçindekiler

  • EvTimer::again — Restarts the timer watcher
  • EvTimer::__construct — Constructs an EvTimer watcher object
  • EvTimer::createStopped — Creates EvTimer stopped watcher object
  • EvTimer::set — Configures the watcher
EvStat::stat
EvTimer::again
Ev


Restarts the timer watcher

EvTimer
EvTimer::__construct
EvTimer
PHP Manual

EvTimer::again

(PECL ev >= 0.2.0)

EvTimer::again — Restarts the timer watcher

Açıklama

public void EvTimer::again ( void )

This will act as if the timer timed out and restart it again if it is repeating. The exact semantics are:

  1. if the timer is pending, its pending status is cleared.

  2. if the timer is started but non-repeating, stop it (as if it timed out).

  3. if the timer is repeating, either start it if necessary (with the repeat value), or reset the running timer to the repeat value.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • EvWatcher::stop() - Stops the watcher
EvTimer
EvTimer::__construct
EvTimer


Constructs an EvTimer watcher object

EvTimer::again
EvTimer::createStopped
EvTimer
PHP Manual

EvTimer::__construct

(PECL ev >= 0.2.0)

EvTimer::__construct — Constructs an EvTimer watcher object

Açıklama

public EvTimer::__construct ( double $after , double $repeat , callable $callback [, mixed $data = NULL [, int $priority = 0 ]] )

Constructs an EvTimer watcher object.

Değiştirgeler

after

Configures the timer to trigger after after seconds.

repeat

If repeat is 0.0 , then it will automatically be stopped once the timeout is reached. If it is positive, then the timer will automatically be configured to trigger again every repeat seconds later, until stopped manually.

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

Dönen Değerler

Returns EvTimer object on success.

Örnekler

Örnek 1 Simple timers

<?php
// Create and start timer firing after 2 seconds
$w1 = new EvTimer(2, 0, function () {
    echo "2 seconds elapsed\n";
});

// Create and launch timer firing after 2 seconds repeating each second
// until we manually stop it
$w2 = new EvTimer(2, 1, function ($w) {
    echo "is called every second, is launched after 2 seconds\n";
    echo "iteration = ", Ev::iteration(), PHP_EOL;

    // Stop the watcher after 5 iterations
    Ev::iteration() == 5 and $w->stop();
    // Stop the watcher if further calls cause more than 10 iterations
    Ev::iteration() >= 10 and $w->stop();
});

// Create stopped timer. It will be inactive until we start it ourselves
$w_stopped = EvTimer::createStopped(10, 5, function($w) {
    echo "Callback of a timer created as stopped\n";

    // Stop the watcher after 2 iterations
    Ev::iteration() >= 2 and $w->stop();
});

// Loop until Ev::stop() is called or all of watchers stop
Ev::run();

// Start and look if it works
$w_stopped->start();
echo "Run single iteration\n";
Ev::run(Ev::RUN_ONCE);

echo "Restart the second watcher and try to handle the same events, but don't block\n";
$w2->again();
Ev::run(Ev::RUN_NOWAIT);

$w = new EvTimer(10, 0, function() {});
echo "Running a blocking loop\n";
Ev::run();
echo "END\n";
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

2 seconds elapsed
is called every second, is launched after 2 seconds
iteration = 1
is called every second, is launched after 2 seconds
iteration = 2
is called every second, is launched after 2 seconds
iteration = 3
is called every second, is launched after 2 seconds
iteration = 4
is called every second, is launched after 2 seconds
iteration = 5
Run single iteration
Callback of a timer created as stopped
Restart the second watcher and try to handle the same events, but don't block
Running a blocking loop
is called every second, is launched after 2 seconds
iteration = 8
is called every second, is launched after 2 seconds
iteration = 9
is called every second, is launched after 2 seconds
iteration = 10
END

Ayrıca Bakınız

  • EvTimer::createStopped() - Creates EvTimer stopped watcher object
  • EvPeriodic
  • » ev_timer - relative and optionally repeating timeouts
  • » Be smart about timeouts
EvTimer::again
EvTimer::createStopped
EvTimer


Creates EvTimer stopped watcher object

EvTimer::__construct
EvTimer::set
EvTimer
PHP Manual

EvTimer::createStopped

(PECL ev >= 0.2.0)

EvTimer::createStopped — Creates EvTimer stopped watcher object

Açıklama

final public static EvTimer EvTimer::createStopped ( double $after , double $repeat , callable $callback [, mixed $data = NULL [, int $priority = 0 ]] )

Creates EvTimer stopped watcher object. Unlike EvTimer::__construct() , this method doesn't start the watcher automatically.

Değiştirgeler

after

Configures the timer to trigger after after seconds.

repeat

If repeat is 0.0 , then it will automatically be stopped once the timeout is reached. If it is positive, then the timer will automatically be configured to trigger again every repeat seconds later, until stopped manually.

callback

See Watcher callbacks .

data

Custom data associated with the watcher.

priority

Watcher priority

Dönen Değerler

Returns EvTimer watcher object on success.

Örnekler

Örnek 1 Monotor changes of /var/log/messages. Avoid missing updates by means of one second delay

<?php
$timer = EvTimer::createStopped(0., 1.02, function ($w) {
    $w->stop();

    $stat = $w->data;

    // 1 second after the most recent change of the file
    printf("Current size: %ld\n", $stat->attr()['size']);
});

$stat = new EvStat("/var/log/messages", 0., function () use ($timer) {
    // Reset timer watcher
    $timer->again();
});

$timer->data = $stat;

Ev::run();
?>

Ayrıca Bakınız

  • EvTimer::__construct() - Constructs an EvTimer watcher object
  • EvPeriodic
EvTimer::__construct
EvTimer::set
EvTimer


Configures the watcher

EvTimer::createStopped
EvWatcher
EvTimer
PHP Manual

EvTimer::set

(PECL ev >= 0.2.0)

EvTimer::set — Configures the watcher

Açıklama

public void EvTimer::set ( double $after , double $repeat )

Configures the watcher

Değiştirgeler

after

Configures the timer to trigger after after seconds.

repeat

If repeat is 0.0 , then it will automatically be stopped once the timeout is reached. If it is positive, then the timer will automatically be configured to trigger again every repeat seconds later, until stopped manually.

Dönen Değerler

Hiçbir değer dönmez.

EvTimer::createStopped
EvWatcher
EvTimer


The EvWatcher class

(PECL ev >= 0.2.0)

Giriş

EvWatcher is a base class for all watchers( EvCheck , EvChild etc.). Since EvWatcher 's constructor is abstract , one can't(and don't need to) create EvWatcher objects directly.

Sınıf Sözdizimi

abstract EvWatcher {
/* Özellikler */
public $is_active ;
public $data ;
public $is_pending ;
public $priority ;
/* Yöntemler */
public int clear ( void )
abstract public __construct ( void )
public void feed ( int $revents )
public EvLoop getLoop ( void )
public void invoke ( int $revents )
public bool keepalive ([ bool $value ] )
public void setCallback ( callable $callback )
public void start ( void )
public void stop ( void )
}

Özellikler

is_active

Readonly . TRUE if the watcher is active. FALSE otherwise.

data

User custom data associated with the watcher

is_pending

Readonly .TRUE if the watcher is pending, i.e. it has outstanding events, but its callback has not yet been invoked. FALSE otherwise. As long, as a watcher is pending(but not active), one must not change its priority.

priority

Integer between Ev::MINPRI and Ev::MAXPRI . Pending watchers with higher priority will be invoked before watchers with lower priority, but priority will not keep watchers from being executed(except for EvIdle watchers). EvIdle watchers provide functionality to suppress invocation when higher priority events are pending.

İçindekiler

  • EvWatcher::clear — Clear watcher pending status
  • EvWatcher::__construct — Abstract constructor of a watcher object
  • EvWatcher::feed — Feeds the given revents set into the event loop
  • EvWatcher::getLoop — Returns the loop responsible for the watcher
  • EvWatcher::invoke — Invokes the watcher callback with the given received events bit mask
  • EvWatcher::keepalive — Configures whether to keep the loop from returning
  • EvWatcher::setCallback — Sets new callback for the watcher
  • EvWatcher::start — Starts the watcher
  • EvWatcher::stop — Stops the watcher
EvTimer::set
EvWatcher::clear
Ev


Clear watcher pending status

EvWatcher
EvWatcher::__construct
EvWatcher
PHP Manual

EvWatcher::clear

(PECL ev >= 0.2.0)

EvWatcher::clear — Clear watcher pending status

Açıklama

public int EvWatcher::clear ( void )

If the watcher is pending, this method clears its pending status and returns its revents bitset(as if its callback was invoked). If the watcher isn't pending it does nothing and returns 0 .

Sometimes it can be useful to "poll" a watcher instead of waiting for its callback to be invoked, which can be accomplished with this function.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

In case if the watcher is pending, returns revents bitset as if the watcher callback had been invoked. Otherwise returns 0 .

EvWatcher
EvWatcher::__construct
EvWatcher


Abstract constructor of a watcher object

EvWatcher::clear
EvWatcher::feed
EvWatcher
PHP Manual

EvWatcher::__construct

(PECL ev >= 0.2.0)

EvWatcher::__construct — Abstract constructor of a watcher object

Açıklama

abstract public EvWatcher::__construct ( void )

EvWatcher::__construct() is an abstract constructor of a watcher object implemented in the derived classes.

EvWatcher::clear
EvWatcher::feed
EvWatcher


Feeds the given revents set into the event loop

EvWatcher::__construct
EvWatcher::getLoop
EvWatcher
PHP Manual

EvWatcher::feed

(PECL ev >= 0.2.0)

EvWatcher::feed — Feeds the given revents set into the event loop

Açıklama

public void EvWatcher::feed ( int $revents )

Feeds the given revents set into the event loop, as if the specified event had happened for the watcher.

Değiştirgeler

revents

Bit mask of watcher received events .

Dönen Değerler

Hiçbir değer dönmez.

EvWatcher::__construct
EvWatcher::getLoop
EvWatcher


Returns the loop responsible for the watcher

EvWatcher::feed
EvWatcher::invoke
EvWatcher
PHP Manual

EvWatcher::getLoop

(PECL ev >= 0.2.0)

EvWatcher::getLoop — Returns the loop responsible for the watcher

Açıklama

public EvLoop EvWatcher::getLoop ( void )

Returns the loop responsible for the watcher

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns EvLoop event loop object responsible for the watcher.

EvWatcher::feed
EvWatcher::invoke
EvWatcher


Invokes the watcher callback with the given received events bit mask

EvWatcher::getLoop
EvWatcher::keepalive
EvWatcher
PHP Manual

EvWatcher::invoke

(PECL ev >= 0.2.0)

EvWatcher::invoke — Invokes the watcher callback with the given received events bit mask

Açıklama

public void EvWatcher::invoke ( int $revents )

Invokes the watcher callback with the given received events bit mask.

Değiştirgeler

revents

Bit mask of watcher received events .

Dönen Değerler

Hiçbir değer dönmez.

EvWatcher::getLoop
EvWatcher::keepalive
EvWatcher


Configures whether to keep the loop from returning

EvWatcher::invoke
EvWatcher::setCallback
EvWatcher
PHP Manual

EvWatcher::keepalive

(PECL ev >= 0.2.0)

EvWatcher::keepalive — Configures whether to keep the loop from returning

Açıklama

public bool EvWatcher::keepalive ([ bool $value ] )

Configures whether to keep the loop from returning. With keepalive value set to FALSE the watcher won't keep Ev::run() / EvLoop::run() from returning even though the watcher is active.

Watchers have keepalive value TRUE by default.

Clearing keepalive status is useful when returning from Ev::run() / EvLoop::run() just because of the watcher is undesirable. It could be a long running UDP socket watcher or so.

Değiştirgeler

value

With keepalive value set to FALSE the watcher won't keep Ev::run() / EvLoop::run() from returning even though the watcher is active.

Dönen Değerler

Returns the previous state.

Örnekler

Örnek 1 Register an I/O watcher for some UDP socket but do not keep the event loop from running just because of that watcher.

<?php
$udp_socket = ...
$udp_watcher = new EvIo($udp_socket, Ev::READ, function () { /* ... */ });
$udp_watcher->keepalive(FALSE);
?>
EvWatcher::invoke
EvWatcher::setCallback
EvWatcher


Sets new callback for the watcher

EvWatcher::keepalive
EvWatcher::start
EvWatcher
PHP Manual

EvWatcher::setCallback

(PECL ev >= 0.2.0)

EvWatcher::setCallback — Sets new callback for the watcher

Açıklama

public void EvWatcher::setCallback ( callable $callback )

Sets new callback for the watcher

Değiştirgeler

callback

See Watcher callbacks .

Dönen Değerler

Hiçbir değer dönmez.

EvWatcher::keepalive
EvWatcher::start
EvWatcher


Starts the watcher

EvWatcher::setCallback
EvWatcher::stop
EvWatcher
PHP Manual

EvWatcher::start

(PECL ev >= 0.2.0)

EvWatcher::start — Starts the watcher

Açıklama

public void EvWatcher::start ( void )

Marks the watcher as active. Note that only active watchers will receive events.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • EvWatcher::stop() - Stops the watcher
EvWatcher::setCallback
EvWatcher::stop
EvWatcher


Stops the watcher

EvWatcher::start
Expect
EvWatcher
PHP Manual

EvWatcher::stop

(PECL ev >= 0.2.0)

EvWatcher::stop — Stops the watcher

Açıklama

public void EvWatcher::stop ( void )

Marks the watcher as inactive. Note that only active watchers will receive events.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • EvWatcher::start() - Starts the watcher
EvWatcher::start
Expect
EvWatcher


Expect

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
    • Expect Usage Examples
  • Expect İşlevleri
    • expect_expectl — Waits until the output from a process matches one of the patterns, a specified time period has passed, or an EOF is seen
    • expect_popen — Execute command via Bourne shell, and open the PTY stream to the process
EvWatcher::stop
Giriş
Süreç Denetim Eklentileri


Giriş

This extension allows to interact with processes through PTY. You may consider using the expect:// wrapper with the filesystem functions which provide a simpler and more intuitive interface.

Expect
Yapılandırma/Kurulum
Expect


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Expect


Gereksinimler

This module uses the functions of the » expect library. You need libexpect version >= 5.43.0.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu » PECL eklentisi PHP ile gelmez. Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/expect.

In order to use these functions you must compile PHP with expect support by using the --with-expect[=DIR] configure option.

Windows users will enable php_expect.dll inside of php.ini in order to use these functions. Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

In order to configure expect extension, there are configuration options in the configuration file php.ini.

Expect Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Changelog
expect.timeout | "10" | PHP_INI_ALL |
expect.loguser | "1" | PHP_INI_ALL |
expect.logfile | "" | PHP_INI_ALL |
expect.match_max | "" | PHP_INI_ALL |
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

expect.timeout integer

The timeout period for waiting for the data, when using the expect_expectl() function.

A value of "-1" disables a timeout from occurring.

Bilginize:

A value of "0" causes the expect_expectl() function to return immediately.

expect.loguser boolean

Whether expect should send any output from the spawned process to stdout. Since interactive programs typically echo their input, this usually suffices to show both sides of the conversation.

expect.logfile string

Name of the file, where the output from the spawned process will be written. If this file doesn't exist, it will be created.

Bilginize:

If this configuration is not empty, the output is written regardless of the value of expect.loguser.

expect.match_max integer

Changes default size (2000 bytes) of the buffer used to match asterisks in patterns.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Özkaynak Türleri

expect_popen() returns an open PTY stream used by expect_expectl().

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

EXP_GLOB (integer)
Indicates that the pattern is a glob-style string pattern.
EXP_EXACT (integer)
Indicates that the pattern is an exact string.
EXP_REGEXP (integer)
Indicates that the pattern is a regexp-style string pattern.
EXP_EOF (integer)
Value, returned by expect_expectl(), when EOF is reached.
EXP_TIMEOUT (integer)
Value, returned by expect_expectl() upon timeout of seconds, specified in value of expect.timeout
EXP_FULLBUFFER (integer)
Value, returned by expect_expectl() if no pattern have been matched.
Özkaynak Türleri
Örnekler
Expect


Örnekler

İçindekiler

  • Expect Usage Examples
Öntanımlı Sabitler
Expect Usage Examples
Expect


Expect Usage Examples

Örnek 1 Expect Usage Example

This example connects to the remote host via SSH, and prints the remote uptime.

<?php
ini_set("expect.loguser", "Off");

$stream = fopen("expect://ssh root@remotehost uptime", "r");

$cases = array (
    array (0 => "password:", 1 => PASSWORD)
);

switch (expect_expectl ($stream, $cases)) {
    case PASSWORD:
        fwrite ($stream, "password\n");
        break;

    default:
        die ("Error was occurred while connecting to the remote host!\n");
}

while ($line = fgets($stream)) {
      print $line;
}
fclose ($stream);
?>

The following example connects to the remote host, determines whether installed OS is for 32 or 64 bit, then runs update for specific package.

Örnek 2 Another Expect Usage Example

<?php
ini_set("expect.timeout", -1);
ini_set("expect.loguser", "Off");

$stream = expect_popen("ssh root@remotehost");

while (true) {
    switch (expect_expectl ($stream, array (
            array ("password:", PASSWORD), // SSH is asking for password
            array ("yes/no)?", YESNO), // SSH is asking whether to store the host entry
            array ("~$ ", SHELL, EXP_EXACT), // We've got the shell!
    ))) {
        case PASSWORD:
            fwrite ($stream, "secret\n");
            break;

        case YESNO:
            fwrite ($stream, "yes\n");
            break;

        case SHELL:
            fwrite ($stream, "uname -a\n");
            while (true) {
                    switch (expect_expectl ($stream, array (
                            array ("~$ ", SHELL, EXP_EXACT), // We've got the shell!
                            array ("^Linux.*$", UNAME, EXP_REGEXP), // uname -a output
                    ), $match)) {
                        case UNAME:
                            $uname .= $match[0];
                            break;

                        case SHELL:
                            // Run update:
                            if (strstr ($uname, "x86_64")) {
                                    fwrite ($stream, "rpm -Uhv http://mirrorsite/somepath/some_64bit.rpm\n");
                            } else {
                                    fwrite ($stream, "rpm -Uhv http://mirrorsite/somepath/some_32bit.rpm\n");
                            }
                            fwrite ($stream, "exit\n");
                            break 2;

                        case EXP_TIMEOUT:
                        case EXP_EOF:
                            break 2;

                        default:
                            die ("Error has occurred!\n");
                    }
            }
            break 2;

        case EXP_TIMEOUT:
        case EXP_EOF:
            break 2;

        default:
            die ("Error has occurred!\n");
    }
}

fclose ($stream);
?>
Örnekler
Expect İşlevleri
Örnekler


Expect İşlevleri

İçindekiler

  • expect_expectl — Waits until the output from a process matches one of the patterns, a specified time period has passed, or an EOF is seen
  • expect_popen — Execute command via Bourne shell, and open the PTY stream to the process
Expect Usage Examples
expect_expectl
Expect


Waits until the output from a process matches one of the patterns, a specified time period has passed, or an EOF is seen

Expect İşlevleri
expect_popen
Expect İşlevleri
PHP Manual

expect_expectl

(PECL expect >= 0.1.0)

expect_expectl — Waits until the output from a process matches one of the patterns, a specified time period has passed, or an EOF is seen

Açıklama

int expect_expectl ( resource $expect , array $cases [, array &$match ] )

Waits until the output from a process matches one of the patterns, a specified time period has passed, or an EOF is seen.

If match is provided, then it is filled with the result of search. The matched string can be found in match[0]. The match substrings (according to the parentheses) in the original pattern can be found in match[1], match[2], and so on, up to match[9] (the limitation of libexpect).

Değiştirgeler

expect

An Expect stream, previously opened with expect_popen().

cases

An array of expect cases. Each expect case is an indexed array, as described in the following table:

Expect Case Array
Index Key | Value Type | Description | Is Mandatory | Default Value
0 | string | pattern, that will be matched against the output from the stream | yes
1 | mixed | value, that will be returned by this function, if the pattern matches | yes
2 | integer | pattern type, one of: EXP_GLOB, EXP_EXACT or EXP_REGEXP | no | EXP_GLOB

Dönen Değerler

Returns value associated with the pattern that was matched.

On failure this function returns: EXP_EOF, EXP_TIMEOUT or EXP_FULLBUFFER

Sürüm Bilgisi

Sürüm: | Açıklama
0.2.1 | Prior to version 0.2.1, in match parameter a match string was returned, not an array of match substrings.

Örnekler

Örnek 1 expect_expectl() example

<?php
// Copies file from remote host:
ini_set("expect.timeout", 30);

$stream = fopen("expect://scp user@remotehost:/var/log/messages /home/user/messages.txt", "r");

$cases = array(
    // array(pattern, value to return if pattern matched)
    array("password:", "asked for password"),
    array("yes/no)?",  "asked for yes/no")
);

while (true) {
    switch (expect_expectl($stream, $cases)) {
        case "asked for password":
            fwrite($stream, "my password\n");
            break;
        case "asked for yes/no":
            fwrite($stream, "yes\n");
            break;
        case EXP_TIMEOUT:
        case EXP_EOF:
            break 2; // break both the switch statement and the while loop
        default:
            die "Error has occurred!";
    }
}

fclose($stream);
?>

Ayrıca Bakınız

  • expect_popen() - Execute command via Bourne shell, and open the PTY stream to the process

Expect İşlevleri
expect_popen
Expect İşlevleri


Execute command via Bourne shell, and open the PTY stream to the process

expect_expectl
Libevent
Expect İşlevleri
PHP Manual

expect_popen

(PECL expect >= 0.1.0)

expect_popen — Execute command via Bourne shell, and open the PTY stream to the process

Açıklama

resource expect_popen ( string $command )

Execute command via Bourne shell, and open the PTY stream to the process.

Değiştirgeler

command

Command to execute.

Dönen Değerler

Returns an open PTY stream to the processes stdio, stdout, and stderr.

On failure this function returns FALSE.

Örnekler

Örnek 1 expect_popen() example

<?php
// Login to the PHP.net CVS repository:
$stream = expect_popen ("cvs -d :pserver:anonymous@cvs.php.net:/repository login");
sleep (3);
fwrite ($stream, "phpfi\n");
fclose ($stream);
?>

Ayrıca Bakınız

  • popen() - Bir süreç tanıtıcısı açar

expect_expectl
Libevent
Expect İşlevleri


Libevent

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
  • Libevent İşlevleri
    • event_add — Add an event to the set of monitored events
    • event_base_free — Destroy event base
    • event_base_loop — Handle events
    • event_base_loopbreak — Abort event loop
    • event_base_loopexit — Exit loop after a time
    • event_base_new — Create and initialize new event base
    • event_base_priority_init — Set the number of event priority levels
    • event_base_reinit — Reinitialize the event base after a fork
    • event_base_set — Associate event base with an event
    • event_buffer_base_set — Associate buffered event with an event base
    • event_buffer_disable — Disable a buffered event
    • event_buffer_enable — Enable a buffered event
    • event_buffer_fd_set — Change a buffered event file descriptor
    • event_buffer_free — Destroy buffered event
    • event_buffer_new — Create new buffered event
    • event_buffer_priority_set — Assign a priority to a buffered event
    • event_buffer_read — Read data from a buffered event
    • event_buffer_set_callback — Set or reset callbacks for a buffered event
    • event_buffer_timeout_set — Set read and write timeouts for a buffered event
    • event_buffer_watermark_set — Set the watermarks for read and write events
    • event_buffer_write — Write data to a buffered event
    • event_del — Remove an event from the set of monitored events
    • event_free — Free event resource
    • event_new — Create new event
    • event_priority_set — Assign a priority to an event.
    • event_set — Prepare an event
    • event_timer_add — Takma Adı: event_add
    • event_timer_del — Takma Adı: event_del
    • event_timer_new — Takma Adı: event_new
    • event_timer_set — Prepare a timer event
expect_popen
Giriş
Süreç Denetim Eklentileri


Giriş

Libevent is a library that provides a mechanism to execute a callback function when a specific event occurs on a file descriptor or after a timeout has been reached.

More information about Libevent can be found at » http://libevent.org/.

Libevent
Yapılandırma/Kurulum
Libevent


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Libevent


Gereksinimler

This extension requires » libevent library. Minimal required version is 1.4.0.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/libevent.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Özkaynak Türleri

There are several resource types used in the extension. These resources are event, event base and buffered event.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

EV_TIMEOUT (integer)
EV_READ (integer)
EV_WRITE (integer)
EV_SIGNAL (integer)
EV_PERSIST (integer)
EVLOOP_NONBLOCK (integer)
EVLOOP_ONCE (integer)
Özkaynak Türleri
Örnekler
Libevent


Örnekler

Örnek 1 polling STDIN using basic API

<?php

function print_line($fd, $events, $arg)
{
    static $max_requests = 0;

    $max_requests++;

    if ($max_requests == 10) {
        // exit loop after 10 writes
        event_base_loopexit($arg[1]);
    }

    // print the line
    echo  fgets($fd);
}

// create base and event
$base = event_base_new();
$event = event_new();

$fd = STDIN;

// set event flags
event_set($event, $fd, EV_READ | EV_PERSIST, "print_line", array($event, $base));
// set event base
event_base_set($event, $base);

// enable event
event_add($event);
// start event loop
event_base_loop($base);

?>

Örnek 2 polling STDIN using buffered event API

<?php

function print_line($buf, $arg)
{
    static $max_requests;

    $max_requests++;

    if ($max_requests == 10) {
        event_base_loopexit($arg);
    }

    // print the line
    echo event_buffer_read($buf, 4096);
}

function error_func($buf, $what, $arg)
{
    // handle errors
}

$base = event_base_new();
$eb = event_buffer_new(STDIN, "print_line", NULL, "error_func", $base);

event_buffer_base_set($eb, $base);
event_buffer_enable($eb, EV_READ);

event_base_loop($base);

?>

Öntanımlı Sabitler
Libevent İşlevleri
Libevent


Libevent İşlevleri

İçindekiler

  • event_add — Add an event to the set of monitored events
  • event_base_free — Destroy event base
  • event_base_loop — Handle events
  • event_base_loopbreak — Abort event loop
  • event_base_loopexit — Exit loop after a time
  • event_base_new — Create and initialize new event base
  • event_base_priority_init — Set the number of event priority levels
  • event_base_reinit — Reinitialize the event base after a fork
  • event_base_set — Associate event base with an event
  • event_buffer_base_set — Associate buffered event with an event base
  • event_buffer_disable — Disable a buffered event
  • event_buffer_enable — Enable a buffered event
  • event_buffer_fd_set — Change a buffered event file descriptor
  • event_buffer_free — Destroy buffered event
  • event_buffer_new — Create new buffered event
  • event_buffer_priority_set — Assign a priority to a buffered event
  • event_buffer_read — Read data from a buffered event
  • event_buffer_set_callback — Set or reset callbacks for a buffered event
  • event_buffer_timeout_set — Set read and write timeouts for a buffered event
  • event_buffer_watermark_set — Set the watermarks for read and write events
  • event_buffer_write — Write data to a buffered event
  • event_del — Remove an event from the set of monitored events
  • event_free — Free event resource
  • event_new — Create new event
  • event_priority_set — Assign a priority to an event.
  • event_set — Prepare an event
  • event_timer_add — Takma Adı: event_add
  • event_timer_del — Takma Adı: event_del
  • event_timer_new — Takma Adı: event_new
  • event_timer_set — Prepare a timer event
Örnekler
event_add
Libevent


Add an event to the set of monitored events

Libevent İşlevleri
event_base_free
Libevent İşlevleri
PHP Manual

event_add

(PECL libevent >= 0.0.1)

event_add — Add an event to the set of monitored events

Açıklama

bool event_add ( resource $event [, int $timeout = -1 ] )

event_add() schedules the execution of the event when the event specified in event_set() occurs or in at least the time specified by the timeout argument. If timeout was not specified, not timeout is set. The event must be already initalized by event_set() and event_base_set() functions. If the event already has a timeout set, it is replaced by the new one.

Değiştirgeler

event

Valid event resource.

timeout

Optional timeout (in microseconds).

Dönen Değerler

event_add() returns TRUE on success or FALSE on error.

Libevent İşlevleri
event_base_free
Libevent İşlevleri


Destroy event base

event_add
event_base_loop
Libevent İşlevleri
PHP Manual

event_base_free

(PECL libevent >= 0.0.1)

event_base_free — Destroy event base

Açıklama

void event_base_free ( resource $event_base )

Destroys the specified event_base and frees all the resources associated. Note that it's not possible to destroy an event base with events attached to it.

Değiştirgeler

event_base

Valid event base resource.

event_add
event_base_loop
Libevent İşlevleri


Handle events

event_base_free
event_base_loopbreak
Libevent İşlevleri
PHP Manual

event_base_loop

(PECL libevent >= 0.0.1)

event_base_loop — Handle events

Açıklama

int event_base_loop ( resource $event_base [, int $flags = 0 ] )

Starts event loop for the specified event base.

Değiştirgeler

event_base

Valid event base resource.

flags

Optional parameter, which can take any combination of EVLOOP_ONCE and EVLOOP_NONBLOCK.

Dönen Değerler

event_base_loop() returns 0 on success, -1 on error and 1 if no events were registered.

event_base_free
event_base_loopbreak
Libevent İşlevleri


Abort event loop

event_base_loop
event_base_loopexit
Libevent İşlevleri
PHP Manual

event_base_loopbreak

(PECL libevent >= 0.0.1)

event_base_loopbreak — Abort event loop

Açıklama

bool event_base_loopbreak ( resource $event_base )

Abort the active event loop immediately. The behaviour is similar to break statement.

Değiştirgeler

event_base

Valid event base resource.

Dönen Değerler

event_base_loopbreak() returns TRUE on success or FALSE on error.

event_base_loop
event_base_loopexit
Libevent İşlevleri


Exit loop after a time

event_base_loopbreak
event_base_new
Libevent İşlevleri
PHP Manual

event_base_loopexit

(PECL libevent >= 0.0.1)

event_base_loopexit — Exit loop after a time

Açıklama

bool event_base_loopexit ( resource $event_base [, int $timeout = -1 ] )

The next event loop iteration after the given timer expires will complete normally, then exit without blocking for events again.

Değiştirgeler

event_base

Valid event base resource.

timeout

Optional timeout parameter (in microseconds).

Dönen Değerler

event_base_loopexit() returns TRUE on success or FALSE on error.

event_base_loopbreak
event_base_new
Libevent İşlevleri


Create and initialize new event base

event_base_loopexit
event_base_priority_init
Libevent İşlevleri
PHP Manual

event_base_new

(PECL libevent >= 0.0.1)

event_base_new — Create and initialize new event base

Açıklama

resource event_base_new ( void )

Returns new event base, which can be used later in event_base_set(), event_base_loop() and other functions.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

event_base_new() returns valid event base resource on success or FALSE on error.

event_base_loopexit
event_base_priority_init
Libevent İşlevleri


Set the number of event priority levels

event_base_new
event_base_reinit
Libevent İşlevleri
PHP Manual

event_base_priority_init

(PECL libevent >= 0.0.2)

event_base_priority_init — Set the number of event priority levels

Açıklama

bool event_base_priority_init ( resource $event_base , int $npriorities )

Sets the number of different event priority levels.

By default all events are scheduled with the same priority (npriorities/2). Using event_base_priority_init() you can change the number of event priority levels and then set a desired priority for each event.

Değiştirgeler

event_base

Valid event base resource.

npriorities

The number of event priority levels.

Dönen Değerler

event_base_priority_init() returns TRUE on success or FALSE on error.

event_base_new
event_base_reinit
Libevent İşlevleri


Reinitialize the event base after a fork

event_base_priority_init
event_base_set
Libevent İşlevleri
PHP Manual

event_base_reinit

(PECL libevent >= 0.1.0)

event_base_reinit — Reinitialize the event base after a fork

Açıklama

bool event_base_reinit ( resource $event_base )

Some event mechanisms do not survive across fork. The event_base needs to be reinitialized with this function.

Değiştirgeler

event_base

Valid event base resource that needs to be re-initialized.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

event_base_priority_init
event_base_set
Libevent İşlevleri


Associate event base with an event

event_base_reinit
event_buffer_base_set
Libevent İşlevleri
PHP Manual

event_base_set

(PECL libevent >= 0.0.1)

event_base_set — Associate event base with an event

Açıklama

bool event_base_set ( resource $event , resource $event_base )

Associates the event_base with the event.

Değiştirgeler

event

Valid event resource.

event_base

Valid event base resource.

Dönen Değerler

event_base_set() returns TRUE on success or FALSE on error.

event_base_reinit
event_buffer_base_set
Libevent İşlevleri


Associate buffered event with an event base

event_base_set
event_buffer_disable
Libevent İşlevleri
PHP Manual

event_buffer_base_set

(PECL libevent >= 0.0.1)

event_buffer_base_set — Associate buffered event with an event base

Açıklama

bool event_buffer_base_set ( resource $bevent , resource $event_base )

Assign the specified bevent to the event_base.

Değiştirgeler

bevent

Valid buffered event resource.

event_base

Valid event base resource.

Dönen Değerler

event_buffer_base_set() returns TRUE on success or FALSE on error.

event_base_set
event_buffer_disable
Libevent İşlevleri


Disable a buffered event

event_buffer_base_set
event_buffer_enable
Libevent İşlevleri
PHP Manual

event_buffer_disable

(PECL libevent >= 0.0.1)

event_buffer_disable — Disable a buffered event

Açıklama

bool event_buffer_disable ( resource $bevent , int $events )

Disables the specified buffered event.

Değiştirgeler

bevent

Valid buffered event resource.

events

Any combination of EV_READ and EV_WRITE.

Dönen Değerler

event_buffer_disable() returns TRUE on success or FALSE on error.

event_buffer_base_set
event_buffer_enable
Libevent İşlevleri


Enable a buffered event

event_buffer_disable
event_buffer_fd_set
Libevent İşlevleri
PHP Manual

event_buffer_enable

(PECL libevent >= 0.0.1)

event_buffer_enable — Enable a buffered event

Açıklama

bool event_buffer_enable ( resource $bevent , int $events )

Enables the specified buffered event.

Değiştirgeler

bevent

Valid buffered event resource.

events

Any combination of EV_READ and EV_WRITE.

Dönen Değerler

event_buffer_enable() returns TRUE on success or FALSE on error.

event_buffer_disable
event_buffer_fd_set
Libevent İşlevleri


Change a buffered event file descriptor

event_buffer_enable
event_buffer_free
Libevent İşlevleri
PHP Manual

event_buffer_fd_set

(PECL libevent >= 0.0.1)

event_buffer_fd_set — Change a buffered event file descriptor

Açıklama

void event_buffer_fd_set ( resource $bevent , resource $fd )

Changes the file descriptor on which the buffered event operates.

Değiştirgeler

bevent

Valid buffered event resource.

fd

Valid PHP stream, must be castable to file descriptor.

event_buffer_enable
event_buffer_free
Libevent İşlevleri


Destroy buffered event

event_buffer_fd_set
event_buffer_new
Libevent İşlevleri
PHP Manual

event_buffer_free

(PECL libevent >= 0.0.1)

event_buffer_free — Destroy buffered event

Açıklama

void event_buffer_free ( resource $bevent )

Destroys the specified buffered event and frees all the resources associated.

Değiştirgeler

bevent

Valid buffered event resource.

event_buffer_fd_set
event_buffer_new
Libevent İşlevleri


Create new buffered event

event_buffer_free
event_buffer_priority_set
Libevent İşlevleri
PHP Manual

event_buffer_new

(PECL libevent >= 0.0.1)

event_buffer_new — Create new buffered event

Açıklama

resource event_buffer_new ( resource $stream , mixed $readcb , mixed $writecb , mixed $errorcb [, mixed $arg ] )

Libevent provides an abstraction layer on top of the regular event API. Using buffered event you don't need to deal with the I/O manually, instead it provides input and output buffers that get filled and drained automatically.

Değiştirgeler

stream

Valid PHP stream resource. Must be castable to file descriptor.

readcb

Callback to invoke where there is data to read, or NULL if no callback is desired.

writecb

Callback to invoke where the descriptor is ready for writing, or NULL if no callback is desired.

errorcb

Callback to invoke where there is an error on the descriptor, cannot be NULL.

arg

An argument that will be passed to each of the callbacks (optional).

Dönen Değerler

event_buffer_new() returns new buffered event resource on success or FALSE on error.

event_buffer_free
event_buffer_priority_set
Libevent İşlevleri


Assign a priority to a buffered event

event_buffer_new
event_buffer_read
Libevent İşlevleri
PHP Manual

event_buffer_priority_set

(PECL libevent >= 0.0.1)

event_buffer_priority_set — Assign a priority to a buffered event

Açıklama

bool event_buffer_priority_set ( resource $bevent , int $priority )

Assign a priority to the bevent.

Değiştirgeler

bevent

Valid buffered event resource.

priority

Priority level. Cannot be less than zero and cannot exceed maximum priority level of the event base (see event_base_priority_init()).

Dönen Değerler

event_buffer_priority_set() returns TRUE on success or FALSE on error.

event_buffer_new
event_buffer_read
Libevent İşlevleri


Read data from a buffered event

event_buffer_priority_set
event_buffer_set_callback
Libevent İşlevleri
PHP Manual

event_buffer_read

(PECL libevent >= 0.0.1)

event_buffer_read — Read data from a buffered event

Açıklama

string event_buffer_read ( resource $bevent , int $data_size )

Reads data from the input buffer of the buffered event.

Değiştirgeler

bevent

Valid buffered event resource.

data_size

Data size in bytes.

event_buffer_priority_set
event_buffer_set_callback
Libevent İşlevleri


Set or reset callbacks for a buffered event

event_buffer_read
event_buffer_timeout_set
Libevent İşlevleri
PHP Manual

event_buffer_set_callback

(PECL libevent >= 0.0.4)

event_buffer_set_callback — Set or reset callbacks for a buffered event

Açıklama

bool event_buffer_set_callback ( resource $event , mixed $readcb , mixed $writecb , mixed $errorcb [, mixed $arg ] )

Sets or changes existing callbacks for the buffered event.

Değiştirgeler

event

Valid buffered event resource.

readcb

Callback to invoke where there is data to read, or NULL if no callback is desired.

writecb

Callback to invoke where the descriptor is ready for writing, or NULL if no callback is desired.

errorcb

Callback to invoke where there is an error on the descriptor, cannot be NULL.

arg

An argument that will be passed to each of the callbacks (optional).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

event_buffer_read
event_buffer_timeout_set
Libevent İşlevleri


Set read and write timeouts for a buffered event

event_buffer_set_callback
event_buffer_watermark_set
Libevent İşlevleri
PHP Manual

event_buffer_timeout_set

(PECL libevent >= 0.0.1)

event_buffer_timeout_set — Set read and write timeouts for a buffered event

Açıklama

void event_buffer_timeout_set ( resource $bevent , int $read_timeout , int $write_timeout )

Sets the read and write timeouts for the specified buffered event.

Değiştirgeler

bevent

Valid buffered event resource.

read_timeout

Read timeout (in seconds).

write_timeout

Write timeout (in seconds).

event_buffer_set_callback
event_buffer_watermark_set
Libevent İşlevleri


Set the watermarks for read and write events

event_buffer_timeout_set
event_buffer_write
Libevent İşlevleri
PHP Manual

event_buffer_watermark_set

(PECL libevent >= 0.0.1)

event_buffer_watermark_set — Set the watermarks for read and write events

Açıklama

void event_buffer_watermark_set ( resource $bevent , int $events , int $lowmark , int $highmark )

Sets the watermarks for read and write events. Libevent does not invoke read callback unless there is at least lowmark bytes in the input buffer; if the read buffer is beyond the highmark, reading is stopped. On output, the write callback is invoked whenever the buffered data falls below the lowmark.

Değiştirgeler

bevent

Valid buffered event resource.

events

Any combination of EV_READ and EV_WRITE.

lowmark

Low watermark.

highmark

High watermark.

event_buffer_timeout_set
event_buffer_write
Libevent İşlevleri


Write data to a buffered event

event_buffer_watermark_set
event_del
Libevent İşlevleri
PHP Manual

event_buffer_write

(PECL libevent >= 0.0.1)

event_buffer_write — Write data to a buffered event

Açıklama

bool event_buffer_write ( resource $bevent , string $data [, int $data_size = -1 ] )

Writes data to the specified buffered event. The data is appended to the output buffer and written to the descriptor when it becomes available for writing.

Değiştirgeler

bevent

Valid buffered event resource.

data

The data to be written.

data_size

Optional size parameter. event_buffer_write() writes all the data by default.

Dönen Değerler

event_buffer_write() returns TRUE on success or FALSE on error.

event_buffer_watermark_set
event_del
Libevent İşlevleri


Remove an event from the set of monitored events

event_buffer_write
event_free
Libevent İşlevleri
PHP Manual

event_del

(PECL libevent >= 0.0.1)

event_del — Remove an event from the set of monitored events

Açıklama

bool event_del ( resource $event )

Cancels the event.

Değiştirgeler

event

Valid event resource.

Dönen Değerler

event_del() returns TRUE on success or FALSE on error.

event_buffer_write
event_free
Libevent İşlevleri


Free event resource

event_del
event_new
Libevent İşlevleri
PHP Manual

event_free

(PECL libevent >= 0.0.1)

event_free — Free event resource

Açıklama

void event_free ( resource $event )

Frees previously created event resource.

Değiştirgeler

event

Valid event resource.

event_del
event_new
Libevent İşlevleri


Create new event

event_free
event_priority_set
Libevent İşlevleri
PHP Manual

event_new

(PECL libevent >= 0.0.1)

event_new — Create new event

Açıklama

resource event_new ( void )

Creates and returns a new event resource.

Dönen Değerler

event_new() returns a new event resource on success or FALSE on error.

event_free
event_priority_set
Libevent İşlevleri


Assign a priority to an event.

event_new
event_set
Libevent İşlevleri
PHP Manual

event_priority_set

(PECL libevent >= 0.0.5)

event_priority_set — Assign a priority to an event.

Açıklama

bool event_priority_set ( resource $event , int $priority )

Assign a priority to the event.

Değiştirgeler

event

Valid event resource.

priority

Priority level. Cannot be less than zero and cannot exceed maximum priority level of the event base (see event_base_priority_init()).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

event_new
event_set
Libevent İşlevleri


Prepare an event

event_priority_set
event_timer_add
Libevent İşlevleri
PHP Manual

event_set

(PECL libevent >= 0.0.1)

event_set — Prepare an event

Açıklama

bool event_set ( resource $event , mixed $fd , int $events , mixed $callback [, mixed $arg ] )

Prepares the event to be used in event_add(). The event is prepared to call the function specified by the callback on the events specified in parameter events, which is a set of the following flags: EV_TIMEOUT, EV_SIGNAL, EV_READ, EV_WRITE and EV_PERSIST.

If EV_SIGNAL bit is set in parameter events, the fd is interpreted as signal number.

After initializing the event, use event_base_set() to associate the event with its event base.

In case of matching event, these three arguments are passed to the callback function:

fd

Signal number or resource indicating the stream.

events

A flag indicating the event. Consists of the following flags: EV_TIMEOUT, EV_SIGNAL, EV_READ, EV_WRITE and EV_PERSIST.

arg

Optional parameter, previously passed to event_set() as arg.

Değiştirgeler

event

Valid event resource.

fd

Valid PHP stream resource. The stream must be castable to file descriptor, so you most likely won't be able to use any of filtered streams.

events

A set of flags indicating the desired event, can be EV_READ and/or EV_WRITE. The additional flag EV_PERSIST makes the event to persist until event_del() is called, otherwise the callback is invoked only once.

callback

Callback function to be called when the matching event occurs.

arg

Optional callback parameter.

Dönen Değerler

event_set() returns TRUE on success or FALSE on error.

Sürüm Bilgisi

Sürüm: | Açıklama
0.0.4 | EV_SIGNAL support was added.
event_priority_set
event_timer_add
Libevent İşlevleri


Takma Adı: event_add

event_set
event_timer_del
Libevent İşlevleri
PHP Manual

event_timer_add

(PECL libevent >= 0.0.2)

event_timer_add — Takma Adı: event_add()

Açıklama

Bu işlev şu işlevin takma adıdır: event_add().

event_set
event_timer_del
Libevent İşlevleri


Takma Adı: event_del

event_timer_add
event_timer_new
Libevent İşlevleri
PHP Manual

event_timer_del

(PECL libevent >= 0.0.2)

event_timer_del — Takma Adı: event_del()

Açıklama

Bu işlev şu işlevin takma adıdır: event_del().

event_timer_add
event_timer_new
Libevent İşlevleri


Takma Adı: event_new

event_timer_del
event_timer_set
Libevent İşlevleri
PHP Manual

event_timer_new

(PECL libevent >= 0.0.2)

event_timer_new — Takma Adı: event_new()

Açıklama

Bu işlev şu işlevin takma adıdır: event_new().

event_timer_del
event_timer_set
Libevent İşlevleri


Prepare a timer event

event_timer_new
PCNTL
Libevent İşlevleri
PHP Manual

event_timer_set

(PECL libevent >= 0.0.2)

event_timer_set — Prepare a timer event

Açıklama

bool event_timer_set ( resource $event , callable $callback [, mixed $arg ] )

Prepares the timer event to be used in event_add(). The event is prepared to call the function specified by the callback when the event timeout elapses.

After initializing the event, use event_base_set() to associate the event with its event base.

In case of matching event, these three arguments are passed to the callback function:

fd

Signal number or resource indicating the stream.

events

A flag indicating the event. This will always be EV_TIMEOUT for timer events.

arg

Optional parameter, previously passed to event_timer_set() as arg.

Değiştirgeler

event

Valid event resource.

callback

Callback function to be called when the matching event occurs.

arg

Optional callback parameter.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

event_timer_new
PCNTL
Libevent İşlevleri


Süreç Denetimi

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
  • Süreç Denetim İşlevleri
    • pcntl_alarm — Belli bir süre sonra SIGALRM sinyali gönderir
    • pcntl_errno — Takma Adı: pcntl_get_last_error
    • pcntl_exec — Belirtilen programı geçerli süreç ortamında çalıştırır
    • pcntl_fork — Çalışan süreci çatallar
    • pcntl_get_last_error — Retrieve the error number set by the last pcntl function which failed
    • pcntl_getpriority — Bir sürecin önceliğini döndürür
    • pcntl_setpriority — Sürecin önceliğini değiştirir
    • pcntl_signal_dispatch — Askıdaki sinyaller için sinyal eylemciyi çağırır
    • pcntl_signal_get_handler — Get the current handler for specified signal
    • pcntl_signal — Bir sinyal eylemci belirtir
    • pcntl_sigprocmask — Sinyalleri ekler, siler veya engeller
    • pcntl_sigtimedwait — Sinyalleri zaman aşımı dolana kadar bekler
    • pcntl_sigwaitinfo — Belirtilen sinyalleri bekler
    • pcntl_strerror — Retrieve the system error message associated with the given errno
    • pcntl_wait — Çatallanmış bir çocuğun durum kodu için bekler
    • pcntl_waitpid — Bir çocuk sürecin çıkmasını bekler ve durum kodunu döndürür
    • pcntl_wexitstatus — Sonlanmış çocuk sürecin dönüş kodunu döndürür
    • pcntl_wifexited — Durum kodunun normal bir çıkışı mı işaret ettiğine bakar
    • pcntl_wifsignaled — Durum kodunun bir sinyal sebebiyle bir sonlanmayı mı işaret ettiğine bakar
    • pcntl_wifstopped — Çocuk sürecin durmuş olup olmadığına bakar
    • pcntl_wstopsig — Çocuk sürecin durmasına sebep olan sinyali döndürür
    • pcntl_wtermsig — Çocuk sürecin sonlanmasına sebep olan sinyali döndürür
event_timer_set
Giriş
Süreç Denetim Eklentileri


Giriş

PHP'deki Süreç Denetimi desteği, Unix tarzı süreç oluşturma, program çalıştırma, sinyal işleme ve süreç sonlandırmayı gerçekleştirir. Süreç Denetimi bir HTTP sunucu ortamında etkinleştirilmemelidir yoksa ortamda kullanılan bir Süreç Denetimi işlevi beklenmedik sonuçlar verebilir.

Bu belge Süreç Denetim işlevlerinin her birinin genel kullanımını açıklamak amacıyla oluşturulmuştur. Unix süreç denetimi hakkında ayrıntılı bilgi edinmek için fork(2), waitpid(2) ve signal(2) kılavuz sayfaları ile sistem belgelerinize ve Advanced Programming in the UNIX Environment [W. Richard Stevens (Addison-Wesley)] gibi kaynaklara bakınız.

PCNTL eklentisi, sinyal işleme geriçağırım mekanizması olarak, önceki mekanizmadan daha hızlı olduğu için artık tikleri kullanmaktadır. Bu değişiklik "kullanıcı tikleri" ile aynı anlamsallıktadır. Geriçağırım işlevlerinizin yerlerini belirtmek için declare() deyimini kullanın. Bu, eşzamansız olayların işlenme maliyetini küçültür. Geçmişte, PHP'nin PCNTL destekli derlenmesi, betiğiniz PCNTL kullanmasa bile hep bu maliyetin yüksek olmasına sebep olurdu.

PHP 4.3.0 öncesinde tüm PCNTL betiklerinin çalışması için yapması gereken tek ayar, ya geriçağırım işlevlerinin bulunduğu bölümde declare() kullanmak ya da yeni declare() küresel sözdizimini kullanarak bu işlevleri betiğin tamamı için etkin kılmaktı.

Bilginize: Bu eklenti Windows sistemlerinde çalışmaz.

PCNTL
Yapılandırma/Kurulum
PCNTL


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
PCNTL


Kurulum

PHP'deki Süreç Denetimi desteği öntanımlı olarak etkin değildir. PHP'yi derlerken Süreç Denetim eklentisini etkin kılmak isterseniz --enable-pcntl yapılandırma seçeneği ile PHP'nin CGI veya CLI sürümünü derlemek zorundasınız.

Bilginize:

Şimdilik bu eklenti, Unix türevi olmayan platformlarda (Windows gibi) çalışmamaktadır.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Aşağıda Süreç Denetim işlevleri tarafından desteklenen sinyaller listelenmiştir. Bu sinyallerin öntanımlı davranışları hakkında bilgi edinmek için signal(7) kılavuz sayfasına bakınız.

WNOHANG (integer)
WUNTRACED (integer)
SIG_IGN (integer)
SIG_DFL (integer)
SIG_ERR (integer)
SIGHUP (integer)
SIGINT (integer)
SIGQUIT (integer)
SIGILL (integer)
SIGTRAP (integer)
SIGABRT (integer)
SIGIOT (integer)
SIGBUS (integer)
SIGFPE (integer)
SIGKILL (integer)
SIGUSR1 (integer)
SIGSEGV (integer)
SIGUSR2 (integer)
SIGPIPE (integer)
SIGALRM (integer)
SIGTERM (integer)
SIGSTKFLT (integer)
SIGCLD (integer)
SIGCHLD (integer)
SIGCONT (integer)
SIGSTOP (integer)
SIGTSTP (integer)
SIGTTIN (integer)
SIGTTOU (integer)
SIGURG (integer)
SIGXCPU (integer)
SIGXFSZ (integer)
SIGVTALRM (integer)
SIGPROF (integer)
SIGWINCH (integer)
SIGPOLL (integer)
SIGIO (integer)
SIGPWR (integer)
SIGSYS (integer)
SIGBABY (integer)
SIG_BLOCK (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
SIG_UNBLOCK (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
SIG_SETMASK (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
SI_USER (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
SI_NOINFO (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
SI_KERNEL (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
SI_QUEUE (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
SI_TIMER (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
SI_MSGGQ (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
SI_ASYNCIO (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
SI_SIGIO (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
SI_TKILL (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
CLD_EXITED (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
CLD_KILLED (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
CLD_DUMPED (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
CLD_TRAPPED (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
CLD_STOPPED (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
CLD_CONTINUED (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
TRAP_BRKPT (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
TRAP_TRACE (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
POLL_IN (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
POLL_OUT (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
POLL_MSG (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
POLL_ERR (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
POLL_PRI (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
POLL_HUP (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
ILL_ILLOPC (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
ILL_ILLOPN (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
ILL_ILLADR (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
ILL_ILLTRP (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
ILL_PRVOPC (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
ILL_PRVREG (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
ILL_COPROC (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
ILL_BADSTK (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
FPE_INTDIV (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
FPE_INTOVF (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
FPE_FLTDIV (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
FPE_FLTOVF (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
FPE_FLTUND (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
FPE_FLTRES (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
FPE_FLTINV (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
FPE_FLTSUB (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
SEGV_MAPERR (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
SEGV_ACCERR (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
BUS_ADRALN (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
BUS_ADRERR (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
BUS_OBJERR (integer)
PHP 5.3.0'dan beri kullanılabilmektedir.
Özkaynak Türleri
Örnekler
PCNTL


Örnekler

İçindekiler

Öntanımlı Sabitler
PCNTL


Örnekler
Süreç Denetim İşlevleri
Örnekler
PHP Manual

Bu örnekte bir sinyal eylemci ile bir artalan süreci çocuk süreç haline gelmektedir.

Örnek 1 Süreç Denetimi örneği

<?php
declare(ticks=1);

$pid = pcntl_fork();
if ($pid == -1) {
     die("çatallama yapılamadı");
} else if ($pid) {
     exit(); // Ana süreç
} else {
     // Çocuk süreç
}

// denetim uçbirimini terkedelim
if (posix_setsid() == -1) {
    die("uçbirim terkedilemedi");
}

// sinyal eylemcilerimizi tanıtalım
pcntl_signal(SIGTERM, "sig_handler");
pcntl_signal(SIGHUP, "sig_handler");

// Görevler yerine getirilene kadar döngüde kalalım
while (1) {

    // işe yarar şeyler burada

}

function sig_handler($signo)
{

     switch ($signo) {
         case SIGTERM:
             // Kapanma işlemleri
             exit;
             break;
         case SIGHUP:
             // Yeniden başlatma işlemleri
             break;
         default:
             // Tüm diğer sinyallerle ilgili işlemler
     }

}

?>
Örnekler
Süreç Denetim İşlevleri
Örnekler


Süreç Denetim İşlevleri

Ayrıca Bakınız

POSIX İşlevleri

İçindekiler

  • pcntl_alarm — Belli bir süre sonra SIGALRM sinyali gönderir
  • pcntl_errno — Takma Adı: pcntl_get_last_error
  • pcntl_exec — Belirtilen programı geçerli süreç ortamında çalıştırır
  • pcntl_fork — Çalışan süreci çatallar
  • pcntl_get_last_error — Retrieve the error number set by the last pcntl function which failed
  • pcntl_getpriority — Bir sürecin önceliğini döndürür
  • pcntl_setpriority — Sürecin önceliğini değiştirir
  • pcntl_signal_dispatch — Askıdaki sinyaller için sinyal eylemciyi çağırır
  • pcntl_signal_get_handler — Get the current handler for specified signal
  • pcntl_signal — Bir sinyal eylemci belirtir
  • pcntl_sigprocmask — Sinyalleri ekler, siler veya engeller
  • pcntl_sigtimedwait — Sinyalleri zaman aşımı dolana kadar bekler
  • pcntl_sigwaitinfo — Belirtilen sinyalleri bekler
  • pcntl_strerror — Retrieve the system error message associated with the given errno
  • pcntl_wait — Çatallanmış bir çocuğun durum kodu için bekler
  • pcntl_waitpid — Bir çocuk sürecin çıkmasını bekler ve durum kodunu döndürür
  • pcntl_wexitstatus — Sonlanmış çocuk sürecin dönüş kodunu döndürür
  • pcntl_wifexited — Durum kodunun normal bir çıkışı mı işaret ettiğine bakar
  • pcntl_wifsignaled — Durum kodunun bir sinyal sebebiyle bir sonlanmayı mı işaret ettiğine bakar
  • pcntl_wifstopped — Çocuk sürecin durmuş olup olmadığına bakar
  • pcntl_wstopsig — Çocuk sürecin durmasına sebep olan sinyali döndürür
  • pcntl_wtermsig — Çocuk sürecin sonlanmasına sebep olan sinyali döndürür
pcntl_alarm
PCNTL


Belli bir süre sonra SIGALRM sinyali gönderir

Süreç Denetim İşlevleri
pcntl_errno
Süreç Denetim İşlevleri
PHP Manual

pcntl_alarm

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

pcntl_alarm — Belli bir süre sonra SIGALRM sinyali gönderir

Açıklama

int pcntl_alarm ( int $saniye )

saniye ile belirtilen sürenin sonunda sürece bir SIGALRM sinyali gönderir. Yapılan her pcntl_alarm() çağrısı bir öncekini geçersiz kılar.

Değiştirgeler

saniye

Sinyal gönderilene kadar beklenecek süre. Sıfır belirtilirse hiçbir sinyal gönderilmez.

Dönen Değerler

Devreye girmeden geçersiz hale getirilmiş önceki çağrının süresini döndürür. Böyle bir çağrı yoksa 0 döner.

Süreç Denetim İşlevleri
pcntl_errno
Süreç Denetim İşlevleri


Takma Adı: pcntl_get_last_error

pcntl_alarm
pcntl_exec
Süreç Denetim İşlevleri
PHP Manual

pcntl_errno

(PHP 5 >= 5.3.4, PHP 7)

pcntl_errno — Takma Adı: pcntl_get_last_error()

Açıklama

Bu işlev şu işlevin takma adıdır: pcntl_get_last_error()

pcntl_alarm
pcntl_exec
Süreç Denetim İşlevleri


Belirtilen programı geçerli süreç ortamında çalıştırır

pcntl_errno
pcntl_fork
Süreç Denetim İşlevleri
PHP Manual

pcntl_exec

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

pcntl_exec — Belirtilen programı geçerli süreç ortamında çalıştırır

Açıklama

void pcntl_exec ( string $yol [, array $değiştirgeler [, array $ortam ]] )

Belirtilen programı belirtilen değiştirgelerle çalıştırır.

Değiştirgeler

yol

İkil bir çalıştırılabilirin veya ilk satırında kendini çalıştıracak yorumlayıcının ( #!/usr/local/bin/perl gibi) belirtildiği bir betiğin dosya yolu. Daha fazla bilgi için execve(2) kılavuz sayfasına bakınız.

değiştirgeler

Programa komut satırında aktarılacak değiştirgeleri içeren dizi.

ortam

Programa ortam olarak aktarılacak dizgelerden oluşan bir dizi. Dizi elemanlarının her biri isim => değer biçiminde, isim ortam değişkeninin ismi olmak üzere bir isim-değer çifti içerir.

Dönen Değerler

Hata durumunda FALSE döner. Başarı durumunda işlev dönmez.

pcntl_errno
pcntl_fork
Süreç Denetim İşlevleri


Çalışan süreci çatallar

pcntl_exec
pcntl_get_last_error
Süreç Denetim İşlevleri
PHP Manual

pcntl_fork

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

pcntl_fork — Çalışan süreci çatallar

Açıklama

int pcntl_fork ( void )

Çalışan süreçten, sadece PID ve PPID'si farklı bir çocuk süreç oluşturur. Bu konu ile ilgili ayrıntılar için sisteminizdeki fork(2) kılavuz sayfasına bakınız.

Dönen Değerler

Başarı durumunda, ana sürecin icra evresinde çocuk sürecin süreç kimliği, çocuk sürecin icra evresinde ise 0 döner. Hiç çocuk süreç oluşturulmamışsa veya bir hata oluşmuşsa -1 döner.

Örnekler

Örnek 1 - pcntl_fork() örneği

<?php

$pid = pcntl_fork();
if ($pid == -1) {
     die('çatallanamadı');
} else if ($pid) {
     // ana süreç
     pcntl_wait($status); // Zombi çocuklar için koruma
} else {
     // çocuk süreç
}

?>

Ayrıca Bakınız

  • pcntl_waitpid() - Bir çocuk sürecin çıkmasını bekler ve durum kodunu döndürür
  • pcntl_signal() - Bir sinyal eylemci belirtir

pcntl_exec
pcntl_get_last_error
Süreç Denetim İşlevleri


Retrieve the error number set by the last pcntl function which failed

pcntl_fork
pcntl_getpriority
Süreç Denetim İşlevleri
PHP Manual

pcntl_get_last_error

(PHP 5 >= 5.3.4, PHP 7)

pcntl_get_last_error — Retrieve the error number set by the last pcntl function which failed

Açıklama

int pcntl_get_last_error ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns error code.

Ayrıca Bakınız

  • pcntl_strerror() - Retrieve the system error message associated with the given errno
pcntl_fork
pcntl_getpriority
Süreç Denetim İşlevleri


Bir sürecin önceliğini döndürür

pcntl_get_last_error
pcntl_setpriority
Süreç Denetim İşlevleri
PHP Manual

pcntl_getpriority

(PHP 5, PHP 7)

pcntl_getpriority — Bir sürecin önceliğini döndürür

Açıklama

int pcntl_getpriority ([ int $pid = getmypid() [, int $süreç_türü = PRIO_PROCESS ]] )

pid ile belirtilen sürecin öncelik seviyesini döndürür. Öncelik seviyeleri sistem türüne ve çekirdeğe göre farklılık gösterdiğinden ayrıntılı bilgi için sisteminizdeki setpriority(2) kılavuz sayfasına bakınız.

Değiştirgeler

pid

Belirtilmezse işlevi çağıran sürecin süreç kimliği kullanılır.

süreç_türü

PRIO_PGRP, PRIO_USER ve PRIO_PROCESS sabitlerinden biri.

Dönen Değerler

Hata durumunda FALSE yoksa belirtilen sürecin öncelik seviyesini döndürür. Düşük sayısal değerler daha yüksek öncelik sağlar.

Uyarı

Bu işlev mantıksal FALSE değeriyle dönebileceği gibi FALSE olarak değerlendirilebilecek mantıksal olmayan bir değerle de dönebilir. Bu konuda daha fazla bilgi edinmek için Mantıksal Değerler bölümüne bakabilirsiniz. Bu işlevden dönen değeri sınamak için === işlecini kullanınız.

Ayrıca Bakınız

  • pcntl_setpriority() - Sürecin önceliğini değiştirir

pcntl_get_last_error
pcntl_setpriority
Süreç Denetim İşlevleri


Sürecin önceliğini değiştirir

pcntl_getpriority
pcntl_signal_dispatch
Süreç Denetim İşlevleri
PHP Manual

pcntl_setpriority

(PHP 5, PHP 7)

pcntl_setpriority — Sürecin önceliğini değiştirir

Açıklama

bool pcntl_setpriority ( int $öncelik [, int $pid = getmypid() [, int $süreç_türü = PRIO_PROCESS ]] )

pid süreç kimlikli sürecin önceliğini değiştirir.

Değiştirgeler

öncelik

Genelde -20 ile 20 arasında bir değerdir. Öntanımlı öncelik 0 olup daha küçük değerler sürecin önceliğini arttırır. Öncelik seviyeleri sistem türüne ve çekirdeğe göre farklılık gösterdiğinden ayrıntılı bilgi için sisteminizdeki setpriority(2) kılavuz sayfasına bakınız.

pid

Belirtilmezse işlevi çağıran sürecin süreç kimliği kullanılır.

süreç_türü

PRIO_PGRP, PRIO_USER ve PRIO_PROCESS sabitlerinden biri.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • pcntl_getpriority() - Bir sürecin önceliğini döndürür

pcntl_getpriority
pcntl_signal_dispatch
Süreç Denetim İşlevleri


Askıdaki sinyaller için sinyal eylemciyi çağırır

pcntl_setpriority
pcntl_signal_get_handler
Süreç Denetim İşlevleri
PHP Manual

pcntl_signal_dispatch

(PHP 5 >= 5.3.0, PHP 7)

pcntl_signal_dispatch — Askıdaki sinyaller için sinyal eylemciyi çağırır

Açıklama

bool pcntl_signal_dispatch ( void )

Askıdaki her sinyal için pcntl_signal() tarafından tanımlanmış eylemci işlevi çağırır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - pcntl_signal_dispatch() örneği

<?php
echo "Sinyal eylemcimizi kuralım...\n";
pcntl_signal(SIGHUP,  function($signo) {
     echo "sinyal eylemci çağrıldı\n";
});

echo "Kendimize SIGHUP gönderelim...\n";
posix_kill(posix_getpid(), SIGHUP);

echo "Sinyal yakalanıyor...\n";
pcntl_signal_dispatch();

echo "Bitti\n";

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Sinyal eylemcimizi kuralım...
Kendimize SIGHUP gönderelim...
Sinyal yakalanıyor...
sinyal eylemci çağrıldı
Bitti

Ayrıca Bakınız

  • pcntl_signal() - Bir sinyal eylemci belirtir
  • pcntl_sigprocmask() - Sinyalleri ekler, siler veya engeller
  • pcntl_sigwaitinfo() - Belirtilen sinyalleri bekler
  • pcntl_sigtimedwait() - Sinyalleri zaman aşımı dolana kadar bekler

pcntl_setpriority
pcntl_signal_get_handler
Süreç Denetim İşlevleri


Get the current handler for specified signal

pcntl_signal_dispatch
pcntl_signal
Süreç Denetim İşlevleri
PHP Manual

pcntl_signal_get_handler

(PHP 7.1)

pcntl_signal_get_handler — Get the current handler for specified signal

Açıklama

int|string pcntl_signal_get_handler ( int $signo )

The pcntl_signal_get_handler() function will get the current handler for the specified signo.

Değiştirgeler

signo

The signal number.

Dönen Değerler

This function may return an integer value that refers to SIG_DFL or SIG_IGN. If you set a custom handler a string value containing the function name is returned.

Sürüm Bilgisi

Sürüm: | Açıklama
Enter the version of change here | Describe the change

Örnekler

Örnek 1 pcntl_signal_get_handler() example

<?php
var_dump(pcntl_signal_get_handler(SIGUSR1)); // Outputs: int(0)

function pcntl_test($signo) {}
pcntl_signal(SIGUSR1, 'pcntl_test');
var_dump(pcntl_signal_get_handler(SIGUSR1)); // Outputs: string(10) "pcntl_test"

pcntl_signal(SIGUSR1, SIG_DFL);
var_dump(pcntl_signal_get_handler(SIGUSR1)); // Outputs: int(0)

pcntl_signal(SIGUSR1, SIG_IGN);
var_dump(pcntl_signal_get_handler(SIGUSR1)); // Outputs: int(1)
?>

Ayrıca Bakınız

  • pcntl_signal() - Bir sinyal eylemci belirtir
pcntl_signal_dispatch
pcntl_signal
Süreç Denetim İşlevleri


Bir sinyal eylemci belirtir

pcntl_signal_get_handler
pcntl_sigprocmask
Süreç Denetim İşlevleri
PHP Manual

pcntl_signal

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

pcntl_signal — Bir sinyal eylemci belirtir

Açıklama

bool pcntl_signal ( int $sinyal , callback $eylemci [, bool $yeniden_syscalls = true ] )

sinyal ile belirtilen sinyal için yeni bir eylemci işlev ismi tanımlar.

Değiştirgeler

sinyal

Sinyal numarası.

eylemci

Kullanıcı tarafından oluşturulmuş bir işlevin veya yöntemin ismi ya da şu iki küresel sabitten biri: SIG_IGN, SIG_DFL.

Bilginize:

Eylemciyi bir nesnenin yöntemi olarak belirtirseniz, eylemci değiştirilene veya betik sonlanana kadar geçerli olmak üzere nesnenin başvuru sayısı arttırılır.

yeniden_syscalls

Bu sinyal geldiğinde yeniden sistem çağrısı yapılıp yapılmayacağını belirler. Öntanımlı değer: TRUE.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.0 | yeniden_syscalls değiştirgesi eklendi.
4.3.0 | Bir geriçağırım işlevi olarak bir nesne yöntemi kullanılabilir oldu.
4.3.0 | PHP 4.3.0'dan itibaren, PCNTL, sinyal işleme geriçağırım mekanizması olarak kullanıcı tiklerini kullanmaya başladı. Bu değişiklik "kullanıcı tiklerinin" kullanıldığı anlamındadır. Geriçağırım işlevlerinizin gerektiği gibi çalışması için yerlerini declare() deyimini kullanarak belirtmelisiniz (örnekteki gibi).

Örnekler

Örnek 1 - pcntl_signal() örneği

<?php
// PHP 4.3.0'dan beri tikler kullanılıyor
declare(ticks = 1);

// sinyal eylemcimiz
function sig_handler($signo)
{

     switch ($signo) {
         case SIGTERM:
             // kapanma işlemleri
             exit;
             break;
         case SIGHUP:
             // yeniden başlatma işlemleri
             break;
         case SIGUSR1:
             echo "SIGUSR1 yakalandı...\n";
             break;
         default:
             // Diğer sinyallerin işlemleri
     }

}

echo "Sinyal eylemci kuruluyor...\n";

// Sinyal eylemcileri belirleyelim
pcntl_signal(SIGTERM, "sig_handler");
pcntl_signal(SIGHUP,  "sig_handler");
pcntl_signal(SIGUSR1, "sig_handler");

// Veya bir nesne kullanalım (PHP 4.3.0 ve sonrası)
// pcntl_signal(SIGUSR1, array($obj, "do_something");

echo"Kendimize SIGTERM gönderelim...\n";

// geçerli süreç kimliğine SIGUSR1 gönder
posix_kill(posix_getpid(), SIGUSR1);

echo "Done\n"

?>

Ayrıca Bakınız

  • pcntl_fork() - Çalışan süreci çatallar
  • pcntl_waitpid() - Bir çocuk sürecin çıkmasını bekler ve durum kodunu döndürür

pcntl_signal_get_handler
pcntl_sigprocmask
Süreç Denetim İşlevleri


Sinyalleri ekler, siler veya engeller

pcntl_signal
pcntl_sigtimedwait
Süreç Denetim İşlevleri
PHP Manual

pcntl_sigprocmask

(PHP 5 >= 5.3.0, PHP 7)

pcntl_sigprocmask — Sinyalleri ekler, siler veya engeller

Açıklama

bool pcntl_sigprocmask ( int $nasıl , array $sinyaller [, array &$eskiler ] )

nasıl değiştirgesine bağlı olarak sinyalleri ekler, siler veya engeller.

Değiştirgeler

nasıl

pcntl_sigprocmask() işlevinin davranışını belirler. Olası değerler:

  • SIG_BLOCK: Belirtilen sinyalleri geçerli engellenen sinyaller listesine ekle.
  • SIG_UNBLOCK:Belirtilen sinyalleri geçerli engellenen sinyaller listesinden sil.
  • SIG_SETMASK: Belirtilen sinyalleri geçerli engellenen sinyaller listesindekilerin yerine koy.

sinyaller

Sinyal listesi.

eskiler

İşlev çağrılmadan önce engellenmekte olan sinyallerin listesi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - pcntl_sigprocmask() örneği

<?php
pcntl_sigprocmask(SIG_BLOCK, array(SIGHUP));
$eskiler = array();
pcntl_sigprocmask(SIG_UNBLOCK, array(SIGHUP), $eskiler);
?>

Ayrıca Bakınız

  • pcntl_sigwaitinfo() - Belirtilen sinyalleri bekler
  • pcntl_sigtimedwait() - Sinyalleri zaman aşımı dolana kadar bekler

pcntl_signal
pcntl_sigtimedwait
Süreç Denetim İşlevleri


Sinyalleri zaman aşımı dolana kadar bekler

pcntl_sigprocmask
pcntl_sigwaitinfo
Süreç Denetim İşlevleri
PHP Manual

pcntl_sigtimedwait

(PHP 5 >= 5.3.0, PHP 7)

pcntl_sigtimedwait — Sinyalleri zaman aşımı dolana kadar bekler

Açıklama

int pcntl_sigtimedwait ( array $sinyaller [, array &$bilgi [, int $saniye = 0 [, int $nanosaniye = 0 ]]] )

Betiğin en çok ne kadar süreyle sinyal bekleyeceğini belirten son iki değiştigesi haricinde pcntl_sigwaitinfo() işleviyle aynıdır.

Değiştirgeler

sinyaller

Beklenecek sinyalleri içeren dizi.

bilgi

Sinyallerle ilgili bilgilerin saklandığı dizi. Ayrıntılar için pcntl_sigwaitinfo() işlevine bakınız.

saniye

Saniye cinsinden zaman aşımı.

nanoseconds

Nano saniye cinsinden zaman aşımı.

Dönen Değerler

Başarı durumunda sinyal numarasını döndürür.

Ayrıca Bakınız

  • pcntl_sigprocmask() - Sinyalleri ekler, siler veya engeller
  • pcntl_sigwaitinfo() - Belirtilen sinyalleri bekler

pcntl_sigprocmask
pcntl_sigwaitinfo
Süreç Denetim İşlevleri


Belirtilen sinyalleri bekler

pcntl_sigtimedwait
pcntl_strerror
Süreç Denetim İşlevleri
PHP Manual

pcntl_sigwaitinfo

(PHP 5 >= 5.3.0, PHP 7)

pcntl_sigwaitinfo — Belirtilen sinyalleri bekler

Açıklama

int pcntl_sigwaitinfo ( array $sinyaller [, array &$bilgi ] )

sinyaller değiştirgesinde belirtilen sinyallerden biri alınıncaya kadar işlevi çağıran betiğin çalışmasını askıya alır. Sinyallerden biri zaten askıda ise (örneğin, pcntl_sigprocmask() ile engellenmiş olabilir), pcntl_sigwaitinfo() hiç beklemeden döner.

Değiştirgeler

sinyaller

Beklenecek sinyalleri içeren dizi.

bilgi

Sinyallerle ilgili bilgilerin saklandığı dizi.

Tüm sinyaller için kullanılan elemanlar şunlardır:

  • signo: Sinyal numarası
  • errno: Bir hata numarası
  • code: Sinyal kodu

SIGCHLD sinyali için şunlar bulunabilir:

  • status: Çıkış değeri veya sinyali
  • utime: Harcanan kullanıcı zamanı
  • stime: Harcanan sistem zamanı
  • pid: Gönderen sürecin kimliği
  • uid: Gönderen sürecin gerçek kullanıcı kimliği

SIGILL, SIGFPE, SIGSEGV ve SIGBUS sinyali için şunlar bulunabilir:

  • addr: Başarısızlığa sebep olan bellek adresi

SIGPOLL sinyali için şunlar bulunabilir:

  • band: Band olayı
  • fd: Dosya tanıtıcı numarası

Dönen Değerler

Başarı durumunda sinyal numarasını döndürür.

Örnekler

Örnek 1 - pcntl_sigwaitinfo() örneği

<?php
echo "SIGHUP sinyalini engelleyelim\n";
pcntl_sigprocmask(SIG_BLOCK, array(SIGHUP));

echo "Kendimize SIGHUP gönderelim\n";
posix_kill(posix_getpid(), SIGHUP);

echo "Sinyal bekleniyor\n";
$info = array();
pcntl_sigwaitinfo(array(SIGHUP), $info);
?>

Ayrıca Bakınız

  • pcntl_sigprocmask() - Sinyalleri ekler, siler veya engeller
  • pcntl_sigtimedwait() - Sinyalleri zaman aşımı dolana kadar bekler

pcntl_sigtimedwait
pcntl_strerror
Süreç Denetim İşlevleri


Retrieve the system error message associated with the given errno

pcntl_sigwaitinfo
pcntl_wait
Süreç Denetim İşlevleri
PHP Manual

pcntl_strerror

(PHP 5 >= 5.3.4, PHP 7)

pcntl_strerror — Retrieve the system error message associated with the given errno

Açıklama

string pcntl_strerror ( int $errno )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

errno

Dönen Değerler

Returns error description on success başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • pcntl_get_last_error() - Retrieve the error number set by the last pcntl function which failed
pcntl_sigwaitinfo
pcntl_wait
Süreç Denetim İşlevleri


Çatallanmış bir çocuğun durum kodu için bekler

pcntl_strerror
pcntl_waitpid
Süreç Denetim İşlevleri
PHP Manual

pcntl_wait

(PHP 5, PHP 7)

pcntl_wait — Çatallanmış bir çocuğun durum kodu için bekler

Açıklama

int pcntl_wait ( int &$durum [, int $seçenekler = 0 ] )

Bir çocuk süreç çıkana veya sonlandırıcı bir sinyal alana ya da bir sinyal eylemcisi çağrılana kadar çalışmakta olan sürecin çalışmasını askıya alır. Bir çocuk zaten çıkmışsa (yani bir zombi süreçse) işlev beklemeden döner. Çocuk sürecin kullandığı sistem özkaynakları serbest bırakılır. Sisteminizde waitpid'in nasıl çalıştığı hakkında ayrıntılı bilgi edinmek için waitpid(2) kılavuz sayfasına bakınız.

Bilginize:

seçenekler değiştirgesi olmadan, pid değiştirgesinde -1 belirterek bir pcntl_waitpid() çağrısı yapmaya denktir.

Değiştirgeler

durum

pcntl_wait()  işlevi durum
değiştirgesinde durum bilgisini şu işlevler ile değerendirilmek üzere
saklar: pcntl_wifexited(),
pcntl_wifstopped(),
pcntl_wifsignaled(),
pcntl_wexitstatus(),
pcntl_wtermsig() ve
pcntl_wstopsig().

seçenekler

Sisteminizde wait3 kullanılabiliyorsa (geneldde BSD sistemlerinde bulunur) isteğe bağlı olan seçenekler değişirgesini kullanabilirsiniz. Aksi takdirde bu değiştirgede belirtilen seçeneklerin hiçbir etkisi olmayacaktır. Değiştirgenin değeri aşağıdaki küresel sabitlerin bitsel VEYAlanmışıdır:

Olası seçenekler
WNOHANG | Çıkmış çocuk süreç yoksa hemen dön.
WUNTRACED | Durumu raporlanmamış ve durmuş çocuklar varsa dön.

Dönen Değerler

Çocuk süreç çıkmışsa süreç kimliği, hata oluşmuşsa -1, (wait3 bulunan sistemlerde) WNOHANG kullanılmış ama ortada bir çocuk süreç yoksa 0 ile döner.

Ayrıca Bakınız

  • pcntl_fork() - Çalışan süreci çatallar
  • pcntl_signal() - Bir sinyal eylemci belirtir
  • pcntl_wifexited() - Durum kodunun normal bir çıkışı mı işaret ettiğine bakar
  • pcntl_wifstopped() - Çocuk sürecin durmuş olup olmadığına bakar
  • pcntl_wifsignaled() - Durum kodunun bir sinyal sebebiyle bir sonlanmayı mı işaret ettiğine bakar
  • pcntl_wexitstatus() - Sonlanmış çocuk sürecin dönüş kodunu döndürür
  • pcntl_wtermsig() - Çocuk sürecin sonlanmasına sebep olan sinyali döndürür
  • pcntl_wstopsig() - Çocuk sürecin durmasına sebep olan sinyali döndürür
  • pcntl_waitpid() - Bir çocuk sürecin çıkmasını bekler ve durum kodunu döndürür

pcntl_strerror
pcntl_waitpid
Süreç Denetim İşlevleri


Bir çocuk sürecin çıkmasını bekler ve durum kodunu döndürür

pcntl_wait
pcntl_wexitstatus
Süreç Denetim İşlevleri
PHP Manual

pcntl_waitpid

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

pcntl_waitpid — Bir çocuk sürecin çıkmasını bekler ve durum kodunu döndürür

Açıklama

int pcntl_waitpid ( int $pid , int &$durum [, int $seçenekler = 0 ] )

pid ile belirtilen çocuk süreç çıkana veya sonlandırıcı bir sinyal alana ya da bir sinyal eylemcisi çağrılana kadar çalışmakta olan sürecin çalışmasını askıya alır.

pid ile belirtilen çocuk zaten çıkmışsa (yani bir zombi süreçse) işlev beklemeden döner. Çocuk sürecin kullandığı sistem özkaynakları serbest bırakılır. Sisteminizde waitpid'in nasıl çalıştığı hakkında ayrıntılı bilgi edinmek için waitpid(2) kılavuz sayfasına bakınız.

Değiştirgeler

pid

pid değeri şunlardan biri olabilir:

pid için olası değerler
< -1 | Süreç grup kimliği pid'in mutlak değeriyle eşleşen çocuk süreç için beklenir.
-1 | Herhangi bir çocuk süreç için beklenir; bu, wait işlevinin davranışıyla aynıdır.
0 | Süreç grup kimliği çağıran sürecinkiyle aynı olan çocuk süreç için beklenir.
> 0 | Süreç grup kimliği pid ile eşleşen çocuk süreç için beklenir.

Bilginize:

pid değiştirgesine -1 belirtmek, (seçenekler haricinde) pcntl_wait() işlevselliğine denktir.

durum

pcntl_waitpid() işlevi durum
değiştirgesinde şu işlevler ile değerendirilmek üzere durum bilgisini
saklar: pcntl_wifexited(),
pcntl_wifstopped(),
pcntl_wifsignaled(),
pcntl_wexitstatus(),
pcntl_wtermsig() ve
pcntl_wstopsig().

seçenekler

Değeri aşağıdaki küresel sabitlerin bitsel VEYAlanmışıdır:

Olasıseçenekler
WNOHANG | Çıkmış çocuk süreç yoksa hemen dön.
WUNTRACED | Durumu raporlanmamış ve durmuş çocuklar varsa dön.

Dönen Değerler

Çocuk süreç çıkmışsa süreç kimliği, hata oluşmuşsa -1, WNOHANG kullanılmış ama ortada bir çocuk süreç yoksa 0 ile döner.

Ayrıca Bakınız

  • pcntl_fork() - Çalışan süreci çatallar
  • pcntl_signal() - Bir sinyal eylemci belirtir
  • pcntl_wifexited() - Durum kodunun normal bir çıkışı mı işaret ettiğine bakar
  • pcntl_wifstopped() - Çocuk sürecin durmuş olup olmadığına bakar
  • pcntl_wifsignaled() - Durum kodunun bir sinyal sebebiyle bir sonlanmayı mı işaret ettiğine bakar
  • pcntl_wexitstatus() - Sonlanmış çocuk sürecin dönüş kodunu döndürür
  • pcntl_wtermsig() - Çocuk sürecin sonlanmasına sebep olan sinyali döndürür
  • pcntl_wstopsig() - Çocuk sürecin durmasına sebep olan sinyali döndürür

pcntl_wait
pcntl_wexitstatus
Süreç Denetim İşlevleri


Sonlanmış çocuk sürecin dönüş kodunu döndürür

pcntl_waitpid
pcntl_wifexited
Süreç Denetim İşlevleri
PHP Manual

pcntl_wexitstatus

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

pcntl_wexitstatus — Sonlanmış çocuk sürecin dönüş kodunu döndürür

Açıklama

int pcntl_wexitstatus ( int $durum )

Sonlanmış çocuk sürecin dönüş kodunu döndürür. Bu işlev, sadece pcntl_wifexited() işlevinin TRUE döndürdüğü durumlarda işe yarar.

Değiştirgeler

durum

durum değiştirgesi başarılı bir pcntl_waitpid() çağrısından dönen durum değiştirgesidir.

Dönen Değerler

Dönüş kodunu bir tamsayı olarak döndürür.

Ayrıca Bakınız

  • pcntl_waitpid() - Bir çocuk sürecin çıkmasını bekler ve durum kodunu döndürür
  • pcntl_wifexited() - Durum kodunun normal bir çıkışı mı işaret ettiğine bakar

pcntl_waitpid
pcntl_wifexited
Süreç Denetim İşlevleri


Durum kodunun normal bir çıkışı mı işaret ettiğine bakar

pcntl_wexitstatus
pcntl_wifsignaled
Süreç Denetim İşlevleri
PHP Manual

pcntl_wifexited

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

pcntl_wifexited — Durum kodunun normal bir çıkışı mı işaret ettiğine bakar

Açıklama

bool pcntl_wifexited ( int $durum )

Çocuk sürecin durum kodunun normal bir çıkışı mı işaret ettiğine bakar

Değiştirgeler

durum

durum değiştirgesi başarılı bir pcntl_waitpid() çağrısından dönen durum değiştirgesidir.

Dönen Değerler

Çocuk sürecin durum kodu normal bir çıkış anlamına geliyorsa TRUE, diğer tüm durumlarda FALSE döner.

Ayrıca Bakınız

  • pcntl_waitpid() - Bir çocuk sürecin çıkmasını bekler ve durum kodunu döndürür
  • pcntl_wexitstatus() - Sonlanmış çocuk sürecin dönüş kodunu döndürür

pcntl_wexitstatus
pcntl_wifsignaled
Süreç Denetim İşlevleri


Durum kodunun bir sinyal sebebiyle bir sonlanmayı mı işaret ettiğine bakar

pcntl_wifexited
pcntl_wifstopped
Süreç Denetim İşlevleri
PHP Manual

pcntl_wifsignaled

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

pcntl_wifsignaled — Durum kodunun bir sinyal sebebiyle bir sonlanmayı mı işaret ettiğine bakar

Açıklama

bool pcntl_wifsignaled ( int $status )

Çocuk sürecin yakalanmayan bir sinyal sebebiyle mi çıktığına bakar.

Değiştirgeler

durum

durum değiştirgesi başarılı bir pcntl_waitpid() çağrısından dönen durum değiştirgesidir.

Dönen Değerler

Çocuk süreç yakalanmayan bir sinyal sebebiyle çıkmışsa TRUE, diğer tüm durumlarda FALSE döner.

Ayrıca Bakınız

  • pcntl_waitpid() - Bir çocuk sürecin çıkmasını bekler ve durum kodunu döndürür
  • pcntl_signal() - Bir sinyal eylemci belirtir

pcntl_wifexited
pcntl_wifstopped
Süreç Denetim İşlevleri


Çocuk sürecin durmuş olup olmadığına bakar

pcntl_wifsignaled
pcntl_wstopsig
Süreç Denetim İşlevleri
PHP Manual

pcntl_wifstopped

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

pcntl_wifstopped — Çocuk sürecin durmuş olup olmadığına bakar

Açıklama

bool pcntl_wifstopped ( int $durum )

Çocuk sürecin durdurulmuş olup olmadığına bakar. Bunun mümkün olması için WUNTRACED seçeneği kullanılarak evvelce yapılmış bir pcntl_waitpid() çağrısı yapılmış olmalıdır.

Değiştirgeler

durum

durum değiştirgesi başarılı bir pcntl_waitpid() çağrısından dönen durum değiştirgesidir.

Dönen Değerler

Çocuk süreç durdurulmuşsa TRUE, diğer durumlarda FALSE döner.

Ayrıca Bakınız

  • pcntl_waitpid() - Bir çocuk sürecin çıkmasını bekler ve durum kodunu döndürür

pcntl_wifsignaled
pcntl_wstopsig
Süreç Denetim İşlevleri


Çocuk sürecin durmasına sebep olan sinyali döndürür

pcntl_wifstopped
pcntl_wtermsig
Süreç Denetim İşlevleri
PHP Manual

pcntl_wstopsig

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

pcntl_wstopsig — Çocuk sürecin durmasına sebep olan sinyali döndürür

Açıklama

int pcntl_wstopsig ( int $status )

Çocuk sürecin durmasına sebep olan sinyalin numarasını döndürür. Bu işlev sadece pcntl_wifstopped() işlevinin TRUE döndürdüğü durumlarda işe yarar.

Değiştirgeler

durum

durum değiştirgesi başarılı bir pcntl_waitpid() çağrısından dönen durum değiştirgesidir.

Dönen Değerler

Sinyal numarası döner.

Ayrıca Bakınız

  • pcntl_waitpid() - Bir çocuk sürecin çıkmasını bekler ve durum kodunu döndürür
  • pcntl_wifstopped() - Çocuk sürecin durmuş olup olmadığına bakar

pcntl_wifstopped
pcntl_wtermsig
Süreç Denetim İşlevleri


Çocuk sürecin sonlanmasına sebep olan sinyali döndürür

pcntl_wstopsig
POSIX
Süreç Denetim İşlevleri
PHP Manual

pcntl_wtermsig

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

pcntl_wtermsig — Çocuk sürecin sonlanmasına sebep olan sinyali döndürür

Açıklama

int pcntl_wtermsig ( int $durum )

Çocuk sürecin sonlanmasına sebep olan sinyalin numarasını döndürür. Bu işlev sadece pcntl_wifsignaled() işlevinin TRUE döndürdüğü durumlarda işe yarar.

Değiştirgeler

durum

durum değiştirgesi başarılı bir pcntl_waitpid() çağrısından dönen durum değiştirgesidir.

Dönen Değerler

Sinyal numarasını bir tamsayı olarak döndürür.

Ayrıca Bakınız

  • pcntl_waitpid() - Bir çocuk sürecin çıkmasını bekler ve durum kodunu döndürür
  • pcntl_signal() - Bir sinyal eylemci belirtir
  • pcntl_wifsignaled() - Durum kodunun bir sinyal sebebiyle bir sonlanmayı mı işaret ettiğine bakar

pcntl_wstopsig
POSIX
Süreç Denetim İşlevleri


POSIX

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
    • posix_access constants
    • posix_mknod constants
    • posix_setrlimit sabitleri
  • POSIX İşlevleri
    • posix_access — Bir dosyanın izinlerine bakar
    • posix_ctermid — Denetim uçbiriminin dosya yolunu döndürür
    • posix_errno — Takma Adı: posix_get_last_error
    • posix_get_last_error — Başarısız olan son POSIX işlevinden atanan hata numarasını döndürür
    • posix_getcwd — Çalışılan dizinin tam yolunu döndürür
    • posix_getegid — Çalışan sürecin etkin grup kimliğini döndürür
    • posix_geteuid — Çalışan sürecin etkin kullanıcı kimliğini döndürür
    • posix_getgid — Çalışan sürecin gerçek grup kimliğini döndürür
    • posix_getgrgid — Grup kimliği belirtilen grup hakkında bilgi verir
    • posix_getgrnam — İsmi belirtilen grup hakkında bilgi verir
    • posix_getgroups — Çalışan sürecin üyesi olduğu grupları döndürür
    • posix_getlogin — Oturumu açan kullanıcının ismini döndürür
    • posix_getpgid — Süreç kimliği belirtilen sürecin süreç grup kimliğini döndürür
    • posix_getpgrp — Çalışan sürecin süreç grup kimliğini döndürür
    • posix_getpid — Çalışan sürecin süreç kimliğini döndürür
    • posix_getppid — Üst süreç kimliğini döndürür
    • posix_getpwnam — Kullanıcı adı belirtilen kullanıcı hakkında bilgi döndürür
    • posix_getpwuid — Kullanıcı kimliği belirtilen kullanıcı hakkında bilgi döndürür
    • posix_getrlimit — Sistem özkaynak sınırları hakkında bilgi verir
    • posix_getsid — Geçerli sürecin oturum kimliğini döndürür
    • posix_getuid — Geçerli sürecin gerçek kullanıcı kimliğini döndürür
    • posix_initgroups — Grup erişim listesini hesaplar
    • posix_isatty — Dosya tanıtıcısı bir etkileşimli uçbirimle ilişkili mi diye bakar
    • posix_kill — Bir sürece bir sinyal gönderir
    • posix_mkfifo — Bir isimli boru dosyası (FIFO) oluşturur
    • posix_mknod — Özel veya sıralı (POSIX.1) bir dosya oluşturur
    • posix_setegid — Geçerli sürecin etkin grup kimliğini belirler
    • posix_seteuid — Geçerli sürecin etkin kullanıcı kimliğini belirler
    • posix_setgid — Geçerli sürecin grup kimliğini tanımlar
    • posix_setpgid — İş denetimi için süreç grup kimliğini tanımlar
    • posix_setrlimit — Set system resource limits
    • posix_setsid — Geçerli süreci bir oturumun lider süreci haline getirir
    • posix_setuid — Geçerli sürecin kullanıcı kimliğini tanımlar
    • posix_strerror — Belirtilen hatanum ile ilgili sistem hata iletisini döndürür
    • posix_times — Süreçle ilgili işlemci zamanlarını döndürür
    • posix_ttyname — Uçbirim aygıt ismini belirler
    • posix_uname — Sistem hakkında bilgi verir
pcntl_wtermsig
Giriş
Süreç Denetim Eklentileri


Giriş

Bu eklenti, IEEE 1003.1 (POSIX.1) standardında tanımlanmış işlevler için bir arayüzdür.

Uyarı

posix_getpwnam() gibi POSIX işlevleri ile hassas verilere erişilebilmektedir. Güvenli kip etkinken hiçbir POSIX işlevi hiçbir erişim sınaması yapmayacaktır. Böyle ortamlarda çalışıyorsanız POSIX eklentisini derleme sırasında --disable-posix seçeneğini kullanarak tamamen iptal etmenizi hararetle öneririz.

Bilginize: Bu eklenti Windows sistemlerinde çalışmaz.

POSIX
Yapılandırma/Kurulum
POSIX


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
POSIX


Kurulum

POSIX işlevleri öntanımlı olarak etkindir. Bu işlevleri PHP'yi derlerken --disable-posix seçeneğini kullanarak iptal edebilirsiniz.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

İçindekiler

  • posix_access constants
  • posix_mknod constants
  • posix_setrlimit sabitleri

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

Özkaynak Türleri
posix_access constants
POSIX


posix_access constants

Öntanımlı Sabitler
posix_mknod constants
Öntanımlı Sabitler
PHP Manual

posix_access() constants

Bilginize:

Bu sabitler PHP 5.1.0 sürümünden itibaren geçerlidir. Bazılarının sisteminizde kullanılamayabileceğini aklınızdan çıkarmayın.

POSIX_F_OK (integer)
Dosya mevcut mu diye bak.
POSIX_R_OK (integer)
Dosya mevcut mu ve okuma izinleri var mı diye bak.
POSIX_W_OK (integer)
Dosya mevcut mu ve yazma izinleri var mı diye bak.
POSIX_X_OK (integer)
Dosya mevcut mu ve çalıştırma izinleri var mı diye bak.
Öntanımlı Sabitler
posix_mknod constants
Öntanımlı Sabitler


posix_mknod constants

posix_access constants
posix_setrlimit sabitleri
Öntanımlı Sabitler
PHP Manual

posix_mknod() constants

Bilginize:

Bu sabitler PHP 5.1.0 sürümünden itibaren geçerlidir. Bazılarının sisteminizde kullanılamayabileceğini aklınızdan çıkarmayın.

POSIX_S_IFBLK (integer)
Blok aygıtı dosyası.
POSIX_S_IFCHR (integer)
Karakter aygıtı dosyası.
POSIX_S_IFIFO (integer)
FIFO (isimli boru) aygıtı dosyası
POSIX_S_IFREG (integer)
Normal dosya
POSIX_S_IFSOCK (integer)
Soket
posix_access constants
posix_setrlimit sabitleri
Öntanımlı Sabitler


posix_setrlimit sabitleri

posix_mknod constants
POSIX İşlevleri
Öntanımlı Sabitler
PHP Manual

posix_setrlimit() sabitleri

Bilginize:

Bu sabitler PHP 5.1.0'dan beri kullanılabilmektedir. Bunlardan bazılarının sisteminizde bulunmayabileceğini unutmayın.

Bilginize:

Aşağıdaki bilgileri işletim sisteminizdeki setrlimit() kılavuz sayfasıyla karşılaştırarak, işletim sisteminiz POSIX'i tamamen gerçeklemek iddiasında olsa bile, sanki bu sınırların yorumlanışında bazı değişiklikler varmış gibi okumanız yararlı olabilir.

POSIX_RLIMIT_AS (integer)
Sürecin adres alanının bayt cinsinden azami boyutu. Ayrıca, PHP'nin memory_limit yapılandırma yönergesine de bakın.
POSIX_RLIMIT_CORE (integer)
İşletim sistemi hata döküm (core) dosyasının azami boyutu. 0 atanırsa bu dosya üretilmez.
POSIX_RLIMIT_CPU (integer)
Sürecin kullanabileceği işlemci zamanının saniye cinsinden azami miktarı. Yazılımsal sınıra ulaşılırsa pcntl_signal() işlevi ile yakalanabilen SIGXCPU sinyali gönderilir. İşletim sistemine bağlı olarak, donanımsal sınıra ulaşılana kadar her saniyede bir ek bir SIGXCPU sinyali gönerilir, bu noktaya ulaşıldığında yakalanamayebilen SIGKILL sinyali gönderilir. Ayrıca, set_time_limit() işlevine de bakınız.
POSIX_RLIMIT_DATA (integer)
Sürecin veri segmanının bayt cinsinden azami boyutu. brk() veya sbrk() işlevlerini kullanmakta olan bir eklenti olmadıkça bunun PHP'nin çalışmasına etkisi oldukça düşüktür.
POSIX_RLIMIT_FSIZE (integer)
Bayt cinsinden, sürecin oluşturabileceği azami dosya boyutu.
POSIX_RLIMIT_LOCKS (integer)
Sürecin oluşturabileceği azami kilit sayısı. Bu sadece oldukça eski sürümlü Linux çekirdeklerinde desteklenir.
POSIX_RLIMIT_MEMLOCK (integer)
Bellekte kilitlenebilen azami bayt sayısı.
POSIX_RLIMIT_MSGQUEUE (integer)
POSIX mesaj kuyrukları için ayrılabilen azami bayt sayısı. PHP, POSIX mesaj kuyrukları desteğiyle gelmediği için bu desteği özellikle kullanan bir eklenti olmadıkça bu sınırın bir etkisi olmayacaktır.
POSIX_RLIMIT_NICE (integer)
Sürecin yeniden tanımlanabilen nice önceliğinin azami miktarı. Bu değer 20 - sınır şeklinde kullanılacağından negatif olmamalıdır.
POSIX_RLIMIT_NOFILE (integer)
Süreç tarafından açılabilen dosya tanıtıcıların azami sayısının bir fazlası.
POSIX_RLIMIT_NPROC (integer)
Sürecin gerçek kullanıcı kimliğini kullanmak üzere oluşturulabilen azami süreç (bazı sistemlerde evrelerin de) sayısı.
POSIX_RLIMIT_RSS (integer)
Sayfa cinsinden sürecin yerleştiği azami boyut.
POSIX_RLIMIT_RTPRIO (integer)
sched_setscheduler() ve sched_setparam() çağrılarıyla atanabilen azami gerçek zamanlılık önceliği.
POSIX_RLIMIT_RTTIME (integer)
Gerçek zamanlılık zamanlamasının kullanılması durumunda engelleyici bir sistem çağrısı yapılmaksızın sürecin tüketebileceği işlemci zamanının mikro saniye cinsinden azami miktarı.
POSIX_RLIMIT_SIGPENDING (integer)
Sürecin gerçek kullanıcı kimliğiyle kuyruklayabileceği azami sinyal sayısı.
POSIX_RLIMIT_STACK (integer)
Süreç yığıtının bayt cinsinden azami boyutu.
POSIX_RLIMIT_INFINITY (integer)
Bir kaynak sınırı için değer olarak sonsuzluk belirtir.
posix_mknod constants
POSIX İşlevleri
Öntanımlı Sabitler


POSIX İşlevleri

Ayrıca Bakınız

Ayrıca bakınız: Süreç Denetim İşlevleri

İçindekiler

  • posix_access — Bir dosyanın izinlerine bakar
  • posix_ctermid — Denetim uçbiriminin dosya yolunu döndürür
  • posix_errno — Takma Adı: posix_get_last_error
  • posix_get_last_error — Başarısız olan son POSIX işlevinden atanan hata numarasını döndürür
  • posix_getcwd — Çalışılan dizinin tam yolunu döndürür
  • posix_getegid — Çalışan sürecin etkin grup kimliğini döndürür
  • posix_geteuid — Çalışan sürecin etkin kullanıcı kimliğini döndürür
  • posix_getgid — Çalışan sürecin gerçek grup kimliğini döndürür
  • posix_getgrgid — Grup kimliği belirtilen grup hakkında bilgi verir
  • posix_getgrnam — İsmi belirtilen grup hakkında bilgi verir
  • posix_getgroups — Çalışan sürecin üyesi olduğu grupları döndürür
  • posix_getlogin — Oturumu açan kullanıcının ismini döndürür
  • posix_getpgid — Süreç kimliği belirtilen sürecin süreç grup kimliğini döndürür
  • posix_getpgrp — Çalışan sürecin süreç grup kimliğini döndürür
  • posix_getpid — Çalışan sürecin süreç kimliğini döndürür
  • posix_getppid — Üst süreç kimliğini döndürür
  • posix_getpwnam — Kullanıcı adı belirtilen kullanıcı hakkında bilgi döndürür
  • posix_getpwuid — Kullanıcı kimliği belirtilen kullanıcı hakkında bilgi döndürür
  • posix_getrlimit — Sistem özkaynak sınırları hakkında bilgi verir
  • posix_getsid — Geçerli sürecin oturum kimliğini döndürür
  • posix_getuid — Geçerli sürecin gerçek kullanıcı kimliğini döndürür
  • posix_initgroups — Grup erişim listesini hesaplar
  • posix_isatty — Dosya tanıtıcısı bir etkileşimli uçbirimle ilişkili mi diye bakar
  • posix_kill — Bir sürece bir sinyal gönderir
  • posix_mkfifo — Bir isimli boru dosyası (FIFO) oluşturur
  • posix_mknod — Özel veya sıralı (POSIX.1) bir dosya oluşturur
  • posix_setegid — Geçerli sürecin etkin grup kimliğini belirler
  • posix_seteuid — Geçerli sürecin etkin kullanıcı kimliğini belirler
  • posix_setgid — Geçerli sürecin grup kimliğini tanımlar
  • posix_setpgid — İş denetimi için süreç grup kimliğini tanımlar
  • posix_setrlimit — Set system resource limits
  • posix_setsid — Geçerli süreci bir oturumun lider süreci haline getirir
  • posix_setuid — Geçerli sürecin kullanıcı kimliğini tanımlar
  • posix_strerror — Belirtilen hatanum ile ilgili sistem hata iletisini döndürür
  • posix_times — Süreçle ilgili işlemci zamanlarını döndürür
  • posix_ttyname — Uçbirim aygıt ismini belirler
  • posix_uname — Sistem hakkında bilgi verir
posix_setrlimit sabitleri
posix_access
POSIX


Bir dosyanın izinlerine bakar

POSIX İşlevleri
posix_ctermid
POSIX İşlevleri
PHP Manual

posix_access

(PHP 5 >= 5.1.0, PHP 7)

posix_access — Bir dosyanın izinlerine bakar

Açıklama

bool posix_access ( string $dosya [, int $kip = POSIX_F_OK ] )

Belirtilen dosya için kullanıcının izinlerine bakar.

Değiştirgeler

dosya

Sınanacak dosyanın yolu.

kip

Şunların biri veya birkaçından oluşan bir bit maskesi: POSIX_F_OK, POSIX_R_OK, POSIX_W_OK ve POSIX_X_OK. POSIX_F_OK öntanımlıdır.

POSIX_R_OK, POSIX_W_OK ve POSIX_X_OK sabitleri ile sırayla dosyanın mevcudiyeti ve okunabilirliği, yazılabilirliği ve çalıştırılabilirliği sınanır. Dosyanın sadece mevcudiyetine bakmak için POSIX_F_OKkullanılabilir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - posix_access() örneği

Bu örnekte, bir dosyanın okunabilir ve yazılabilir olup olmadığına bakılmakta, değilse bir hata iletisi gösterilmektedir.

<?php

$file = 'bir_dosya';

if (posix_access($file, POSIX_R_OK | POSIX_W_OK)) {
    echo 'Dosya hem okunabiliyor hem de yazılabiliyor!';

} else {
    $error = posix_get_last_error();

    echo "Hata $error: " . posix_strerror($error);
}

?>

Notlar

Bilginize: Güvenli kip etkinken, PHP, dosya ve dizinlerin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığını sınar.

Ayrıca Bakınız

  • posix_get_last_error() - Başarısız olan son POSIX işlevinden atanan hata numarasını döndürür
  • posix_strerror() - Belirtilen hatanum ile ilgili sistem hata iletisini döndürür

POSIX İşlevleri
posix_ctermid
POSIX İşlevleri


Denetim uçbiriminin dosya yolunu döndürür

posix_access
posix_errno
POSIX İşlevleri
PHP Manual

posix_ctermid

(PHP 4, PHP 5, PHP 7)

posix_ctermid — Denetim uçbiriminin dosya yolunu döndürür

Açıklama

string posix_ctermid ( void )

Sürecin denetim uçbiriminin dosya yolunu içeren bir dizge döner. Hata durumunda atanan hata numarasına posix_get_last_error() işlevi ile erişilebilir.

Dönen Değerler

İşlem sırasında bir hata oluşursa posix_get_last_error() işlevi ile öğrenilmek üzere bir hata numarası atanır ve FALSE döner, yoksa uçbirimin yolunu içeren bir dizge döner.

Örnekler

Örnek 1 - posix_ctermid() örneği

Bu örnekte üzerinde çalışılan uçbirimin yolu gösterilmektedir.

<?php
echo posix_ctermid() . " üzerinde çalışıyorum.";
?>

Ayrıca Bakınız

  • posix_ttyname() - Uçbirim aygıt ismini belirler
  • posix_get_last_error() - Başarısız olan son POSIX işlevinden atanan hata numarasını döndürür

posix_access
posix_errno
POSIX İşlevleri


Takma Adı: posix_get_last_error

posix_ctermid
posix_get_last_error
POSIX İşlevleri
PHP Manual

posix_errno

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

posix_errno — Takma Adı: posix_get_last_error()

Açıklama

Bu işlev şu işlevin takma adıdır: posix_get_last_error().

posix_ctermid
posix_get_last_error
POSIX İşlevleri


Başarısız olan son POSIX işlevinden atanan hata numarasını döndürür

posix_errno
posix_getcwd
POSIX İşlevleri
PHP Manual

posix_get_last_error

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

posix_get_last_error — Başarısız olan son POSIX işlevinden atanan hata numarasını döndürür

Açıklama

int posix_get_last_error ( void )

Başarısız olan son POSIX işlevinden atanan hata numarasını döndürür. Dönen hata numarası ile ilgili ileti ise posix_strerror() işlevi ile edinilebilir.

Dönen Değerler

Bir hata oluşmamışsa 0, yoksa son oluşan hatanın numarasını döndürür.

Örnekler

Örnek 1 - posix_get_last_error() örneği

Bu örnekte çalıştırılmamış bir süreç öldürülmeye çalışılmakta ve oluşan hatanın numarası gösterilmektedir.

<?php
posix_kill(999459,SIGKILL);
echo 'Oluşan hatanın numarası: '.posix_get_last_error();
?>

Ayrıca Bakınız

  • posix_strerror() - Belirtilen hatanum ile ilgili sistem hata iletisini döndürür

posix_errno
posix_getcwd
POSIX İşlevleri


Çalışılan dizinin tam yolunu döndürür

posix_get_last_error
posix_getegid
POSIX İşlevleri
PHP Manual

posix_getcwd

(PHP 4, PHP 5, PHP 7)

posix_getcwd — Çalışılan dizinin tam yolunu döndürür

Açıklama

string posix_getcwd ( void )

Betiğin çalışma dizininin mutlak yolunu döndürür. Hata durumunda atanan hata numarasına posix_get_last_error() işlevi ile erişilebilir.

Dönen Değerler

İşlem sırasında bir hata oluşursa posix_get_last_error() işlevi ile öğrenilmek üzere bir hata numarası atanır ve FALSE döner, yoksa mutlak dizin yolunu içeren bir dizge döner.

Örnekler

Örnek 1 - posix_getcwd() örneği

Bu örnek, betiğin çalıştığı dizinin tam yolunu göstermektedir.

<?php
echo 'Çalışma dizinim: '.posix_getcwd();
?>

Notlar

Bilginize:

  • Okuma ve arama izni yoksa
  • veya mutlak yol artık mevcut değilse
bu işlev başarısız olur.

posix_get_last_error
posix_getegid
POSIX İşlevleri


Çalışan sürecin etkin grup kimliğini döndürür

posix_getcwd
posix_geteuid
POSIX İşlevleri
PHP Manual

posix_getegid

(PHP 4, PHP 5, PHP 7)

posix_getegid — Çalışan sürecin etkin grup kimliğini döndürür

Açıklama

int posix_getegid ( void )

Çalışan sürecin etkin grup kimliğini döndürür.

Dönen Değerler

Etkin grup kimliği bir tamsayı olarak döner.

Örnekler

Örnek 1 - posix_getegid() örneği

Bu örnekte posix_setegid() ile değitirilmeden önce ve değiştirildikten sonraki etkin grup kimliği gösterilmiştir.

<?php
echo 'Gerçek grup kimliğim: '.posix_getgid(); //20
posix_setegid(40);
echo 'Gerçek grup kimliğim: '.posix_getgid(); //20
echo 'Etkin grup kimliğim: '.posix_getegid(); //40
?>

Notlar

posix_getegid() işlevi, posix_getgid() işlevinden farklı bir sonuçla dönmesinin sebebi, posix_setegid() ile sadece etkin grup kimliğini değiştirilebilmesidir.

Ayrıca Bakınız

  • posix_getgrgid() - Grup kimliği belirtilen grup hakkında bilgi verir
  • posix_getgid() - Çalışan sürecin gerçek grup kimliğini döndürür
  • posix_setgid() - Geçerli sürecin grup kimliğini tanımlar

posix_getcwd
posix_geteuid
POSIX İşlevleri


Çalışan sürecin etkin kullanıcı kimliğini döndürür

posix_getegid
posix_getgid
POSIX İşlevleri
PHP Manual

posix_geteuid

(PHP 4, PHP 5, PHP 7)

posix_geteuid — Çalışan sürecin etkin kullanıcı kimliğini döndürür

Açıklama

int posix_geteuid ( void )

Çalışan sürecin etkin kullanıcı kimliğini döndürür. Kullanıcı isminine dönüşüm ile ilgili bilgi için posix_getpwuid() işlevine bakınız.

Dönen Değerler

Kullanıcı kimliği bir tamsayı olarak döner.

Örnekler

Örnek 1 - posix_geteuid() örneği

Bu örnekte etkin kullanıcı kimliği posix_seteuid() ile değiştirilmeden önce ve değiştirildikten sonra gerçek ve etkin kullanıcı kimlikleri arasındaki fark gösterilmektedir.

<?php
echo posix_getuid()."\n"; //10001
echo posix_geteuid()."\n"; //10001
posix_seteuid(10000);
echo posix_getuid()."\n"; //10001
echo posix_geteuid()."\n"; //10000
?>

Ayrıca Bakınız

  • posix_getpwuid() - Kullanıcı kimliği belirtilen kullanıcı hakkında bilgi döndürür
  • posix_getuid() - Geçerli sürecin gerçek kullanıcı kimliğini döndürür
  • posix_setuid() - Geçerli sürecin kullanıcı kimliğini tanımlar
  • POSIX geteuid(2) kılavuz sayfası

posix_getegid
posix_getgid
POSIX İşlevleri


Çalışan sürecin gerçek grup kimliğini döndürür

posix_geteuid
posix_getgrgid
POSIX İşlevleri
PHP Manual

posix_getgid

(PHP 4, PHP 5, PHP 7)

posix_getgid — Çalışan sürecin gerçek grup kimliğini döndürür

Açıklama

int posix_getgid ( void )

Çalışan sürecin gerçek grup kimliğini döndürür.

Dönen Değerler

Gerçek grup kimliği bir tamsayı olarak döner.

Örnekler

Örnek 1 - posix_getgid() örneği

Örnekte etkin grup kimliği değişmeden ve değiştikten sonra gerçek grup kimliği gösterilmektedir.

<?php
echo 'Gerçek grup kimliğim: '.posix_getgid(); //20
posix_setegid(40);
echo 'Gerçek grup kimliğim: '.posix_getgid(); //20
echo 'Etkin grup kimliğim: '.posix_getegid(); //40
?>

Ayrıca Bakınız

  • posix_getgrgid() - Grup kimliği belirtilen grup hakkında bilgi verir
  • posix_getegid() - Çalışan sürecin etkin grup kimliğini döndürür
  • posix_setgid() - Geçerli sürecin grup kimliğini tanımlar
  • POSIX getgid(2) kılavuz sayfası

posix_geteuid
posix_getgrgid
POSIX İşlevleri


Grup kimliği belirtilen grup hakkında bilgi verir

posix_getgid
posix_getgrnam
POSIX İşlevleri
PHP Manual

posix_getgrgid

(PHP 4, PHP 5, PHP 7)

posix_getgrgid — Grup kimliği belirtilen grup hakkında bilgi verir

Açıklama

array posix_getgrgid ( int $gid )

gid grup kimlikli grup hakkında bilgi döndürür.

Değiştirgeler

gid

Grup kimliği.

Dönen Değerler

Dönen dizinin elemanları:

Grup bilgileri dizisi
Anahtar | Açıklama
name | Grubun ismi. En fazla 16 karakter uzunlukta olabilir.
passwd | Şifreli olarak grup parolası. Sistemde "shadow" parolalar kullanılıyorsa sadece bir * imi bulunur.
gid | Sayısal olarak grup kimliği. İşlevi çağırıken gid değiştirgesine atananla aynı olmalıdır.
members | Grubun üyelerinin isimlerini birer dizge olarak içeren bir dizidir.

Sürüm Bilgisi

Sürüm: | Açıklama
4.2.0 | Bu sürümdün önce, members gruptaki üye sayısını içerirdi ve üye isimleri sayısal indislerleriyle dönerdi.

Örnekler

Örnek 1 - posix_getgrgid() örneği

<?php

$groupid   = posix_getegid();
$groupinfo = posix_getgrgid($groupid);

print_r($groupinfo);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [name]    => toons
    [passwd]  => x
    [members] => Array
        (
            [0] => tom
            [1] => jerry
        )
    [gid]     => 42
)

Ayrıca Bakınız

  • posix_getegid() - Çalışan sürecin etkin grup kimliğini döndürür
  • posix_getgrnam() - İsmi belirtilen grup hakkında bilgi verir
  • filegroup() - Dosyanın sahibi olan grubu döndürür
  • stat() - Bir dosya hakkında bilgi döndürür
  • safe_mode_gid
  • POSIX getgrgid(3) kılavuz sayfası

posix_getgid
posix_getgrnam
POSIX İşlevleri


İsmi belirtilen grup hakkında bilgi verir

posix_getgrgid
posix_getgroups
POSIX İşlevleri
PHP Manual

posix_getgrnam

(PHP 4, PHP 5, PHP 7)

posix_getgrnam — İsmi belirtilen grup hakkında bilgi verir

Açıklama

array posix_getgrnam ( string $isim )

İsmi belirtilen grup hakkında bilgi döndürür.

Değiştirgeler

isim

Grubun ismi

Dönen Değerler

Dönen dizinin elemanları:

Grup bilgileri dizisi
Anahtar | Açıklama
name | Grubun ismi. İşlevi çağırıken isim değiştirgesine atananla aynı olmalıdır. En fazla 16 karakter uzunlukta olabilir.
passwd | Şifreli olarak grup parolası. Sistemde "shadow" parolalar kullanılıyorsa sadece bir * imi bulunur.
gid | Sayısal olarak grup kimliği.
members | Grubun üyelerinin isimlerini birer dizge olarak içeren bir dizidir.

Sürüm Bilgisi

Sürüm: | Açıklama
4.2.0 | Bu sürümdün önce, members gruptaki üye sayısını içerirdi ve üye isimleri sayısal indislerleriyle dönerdi.

Örnekler

Örnek 1 - posix_getgrnam() örneği

<?php

$groupinfo = posix_getgrnam("toons");

print_r($groupinfo);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [name]    => toons
    [passwd]  => x
    [members] => Array
        (
            [0] => tom
            [1] => jerry
        )
    [gid]     => 42
)

Ayrıca Bakınız

  • posix_getegid() - Çalışan sürecin etkin grup kimliğini döndürür
  • posix_getgrgid() - Grup kimliği belirtilen grup hakkında bilgi verir
  • filegroup() - Dosyanın sahibi olan grubu döndürür
  • stat() - Bir dosya hakkında bilgi döndürür
  • safe_mode_gid
  • POSIX getgrnam(3) kılavuz sayfası

posix_getgrgid
posix_getgroups
POSIX İşlevleri


Çalışan sürecin üyesi olduğu grupları döndürür

posix_getgrnam
posix_getlogin
POSIX İşlevleri
PHP Manual

posix_getgroups

(PHP 4, PHP 5, PHP 7)

posix_getgroups — Çalışan sürecin üyesi olduğu grupları döndürür

Açıklama

array posix_getgroups ( void )

Çalışan sürecin üyesi olduğu grupları döndürür.

Dönen Değerler

Çalışan sürecin üyesi olduğu grupların grup kimliklerini tamsayı olarak içeren bir dizi döner.

Örnekler

Örnek 1 - posix_getgroups() örneği

<?php

$groups = posix_getgroups();

print_r($groups);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [0] => 4
    [1] => 20
    [2] => 24
    [3] => 25
    [4] => 29
    [5] => 30
    [6] => 33
    [7] => 44
    [8] => 46
    [9] => 104
    [10] => 109
    [11] => 110
    [12] => 1000
)

Ayrıca Bakınız

  • posix_getgrgid() - Grup kimliği belirtilen grup hakkında bilgi verir

posix_getgrnam
posix_getlogin
POSIX İşlevleri


Oturumu açan kullanıcının ismini döndürür

posix_getgroups
posix_getpgid
POSIX İşlevleri
PHP Manual

posix_getlogin

(PHP 4, PHP 5, PHP 7)

posix_getlogin — Oturumu açan kullanıcının ismini döndürür

Açıklama

string posix_getlogin ( void )

Oturumu açan (dolayısıyla çalışan sürecin sahibi olan) kullanıcının ismini döndürür.

Dönen Değerler

Kullanıcı ismi bir dizge olarak döner.

Örnekler

Örnek 1 - posix_getlogin() örneği

<?php
echo posix_getlogin(); //apache
?>

Ayrıca Bakınız

  • posix_getpwnam() - Kullanıcı adı belirtilen kullanıcı hakkında bilgi döndürür
  • POSIX getlogin(3) kılavuz sayfası

posix_getgroups
posix_getpgid
POSIX İşlevleri


Süreç kimliği belirtilen sürecin süreç grup kimliğini döndürür

posix_getlogin
posix_getpgrp
POSIX İşlevleri
PHP Manual

posix_getpgid

(PHP 4, PHP 5, PHP 7)

posix_getpgid — Süreç kimliği belirtilen sürecin süreç grup kimliğini döndürür

Açıklama

int posix_getpgid ( int $pid )

pid süreç kimlikli sürecin süreç grup kimliğini döndürür.

Değiştirgeler

pid

Süreç kimliği.

Dönen Değerler

Süreç grup kimliği bir tamsayı olarak döner.

Örnekler

Örnek 1 - posix_getpgid() örneği

<?php
$pid = posix_getppid();
echo posix_getpgid($pid); //35
?>

Notlar

Bilginize:

Bu bir POSIX işlevi değildir, BSD ve System V sistemlerinde vardır. Eğer sisteminiz bu işlevi desteklemiyorsa PHP derlenirken bu işlev derlenmeyecektir. Bir işlevin varlığına function_exists() ile bakabilirsiniz.

Ayrıca Bakınız

  • posix_getppid() - Üst süreç kimliğini döndürür
  • man page SETPGID(2)

posix_getlogin
posix_getpgrp
POSIX İşlevleri


Çalışan sürecin süreç grup kimliğini döndürür

posix_getpgid
posix_getpid
POSIX İşlevleri
PHP Manual

posix_getpgrp

(PHP 4, PHP 5, PHP 7)

posix_getpgrp — Çalışan sürecin süreç grup kimliğini döndürür

Açıklama

int posix_getpgrp ( void )

Çalışan sürecin süreç grup kimliğini döndürür.

Dönen Değerler

Süreç grup kimliği bir tamsayı olarak döner.

Ayrıca Bakınız

  • Süreç grupları hakkında bilgi için POSIX.1 standardı ve getpgrp(2) kılavuz sayfası.

posix_getpgid
posix_getpid
POSIX İşlevleri


Çalışan sürecin süreç kimliğini döndürür

posix_getpgrp
posix_getppid
POSIX İşlevleri
PHP Manual

posix_getpid

(PHP 4, PHP 5, PHP 7)

posix_getpid — Çalışan sürecin süreç kimliğini döndürür

Açıklama

int posix_getpid ( void )

Çalışan sürecin kendi süreç kimliğini döndürür.

Dönen Değerler

Süreç kimliği bir tamsayı olarak döner.

Örnekler

Örnek 1 - posix_getpid() örneği

<?php
echo posix_getpid(); //8805
?>

Ayrıca Bakınız

  • posix_kill() - Bir sürece bir sinyal gönderir
  • POSIX getpid(2) kılavuz sayfası

posix_getpgrp
posix_getppid
POSIX İşlevleri


Üst süreç kimliğini döndürür

posix_getpid
posix_getpwnam
POSIX İşlevleri
PHP Manual

posix_getppid

(PHP 4, PHP 5, PHP 7)

posix_getppid — Üst süreç kimliğini döndürür

Açıklama

int posix_getppid ( void )

Çalışan süreci çalıştıran sürecin süreç kimliğini döndürür.

Dönen Değerler

Süreç kimliği bir tamsayı olarak döner.

Örnekler

Örnek 1 - posix_getppid() örneği

<?php
echo posix_getppid(); //8259
?>

posix_getpid
posix_getpwnam
POSIX İşlevleri


Kullanıcı adı belirtilen kullanıcı hakkında bilgi döndürür

posix_getppid
posix_getpwuid
POSIX İşlevleri
PHP Manual

posix_getpwnam

(PHP 4, PHP 5, PHP 7)

posix_getpwnam — Kullanıcı adı belirtilen kullanıcı hakkında bilgi döndürür

Açıklama

array posix_getpwnam ( string $isim )

Kullanıcı ismi isim olan kullanıcı hakkında bilgi içeren bir dizi döndürür.

Değiştirgeler

isim

Kullanıcının sistemde oturum açarken kullandığı kısa ad.

Dönen Değerler

İşlem başarısız olursa FALSE, yoksa aşağıdaki elemanları içeren bir dizi döner:

Kullanıcı bilgileri dizisi
Anahtar | Açıklama
name | Kullanıcının kullanıcı ismi. Kullanıcının gerçek ismi değil, en fazla 16 karakter uzunlukta olabilen ve sistemde oturum açarken kullandığı kısa adıdır. İşlevi çağırıken isim değiştirgesine atananla aynı olmalıdır.
passwd | Kullanıcının parolası bu elemanda şifreli olarak bulunur. Sistemde "shadow" parolalar kullanılıyorsa sadece bir * imi bulunur.
uid | Kullanıcı kimliği.
gid | Kullanıcının grup kimliği. Grup ismini ve üye listesini öğrenmek için posix_getgrgid()işlevini kullanabilirsiniz.
gecos | GECOS, Honeywell sistemlerden kalma artık kullanılmayan bir alan olmakla beraber içeriği POSIX tarafından şekillendirilmiştir.Alan birbirlerinden virgül ile ayrılmış olarak kullanıcının tam ismini, iş ve ev telefonlarını ve büro numarasını içerebilir. Çoğu sistemde kullanıcının tam ismi için kullanılmaktadır.
dir | Kullanıcının ev dizininin mutlak yolunu içerir.
shell | Kullanıcının öntanımlı kabuğunu çalıştıran dosyanın mutlak yolu.

Örnekler

Örnek 1 - posix_getpwnam() örneği

<?php

$userinfo = posix_getpwnam("tom");

print_r($userinfo);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [name]    => tom
    [passwd]  => x
    [uid]     => 10000
    [gid]     => 42
    [geocs]   => "tom,,,"
    [dir]     => "/home/tom"
    [shell]   => "/bin/bash"
)

Ayrıca Bakınız

  • posix_getpwuid() - Kullanıcı kimliği belirtilen kullanıcı hakkında bilgi döndürür
  • POSIX getpwnam(3) kılavuz sayfası

posix_getppid
posix_getpwuid
POSIX İşlevleri


Kullanıcı kimliği belirtilen kullanıcı hakkında bilgi döndürür

posix_getpwnam
posix_getrlimit
POSIX İşlevleri
PHP Manual

posix_getpwuid

(PHP 4, PHP 5, PHP 7)

posix_getpwuid — Kullanıcı kimliği belirtilen kullanıcı hakkında bilgi döndürür

Açıklama

array posix_getpwuid ( int $uid )

uid kullanıcı kimlikli kullanıcı hakkında bilgiyi bir dizi içinde döndürür.

Değiştirgeler

uid

Kullanıcı kimliği.

Dönen Değerler

Şu elemanları içeren bir ilişkisel dizi döner:

Kullanıcı bilgileri dizisi
Anahtar | Açıklama
name | Kullanıcının kullanıcı ismi. Kullanıcının gerçek ismi değil, en fazla 16 karakter uzunlukta olabilen ve sistemde oturum açarken kullandığı kısa adıdır.
passwd | Kullanıcının parolası bu elemanda şifreli olarak bulunur. Sistemde "shadow" parolalar kullanılıyorsa sadece bir * imi bulunur.
uid | Kullanıcı kimliği. İşlevi çağırıken uid değiştirgesine atananla aynı olmalıdır.
gid | Kullanıcının grup kimliği. Grup ismini ve üye listesini öğrenmek için posix_getgrgid()işlevini kullanabilirsiniz.
gecos | GECOS, Honeywell sistemlerden kalma artık kullanılmayan bir alan olmakla beraber içeriği POSIX tarafından şekillendirilmiştir.Alan birbirlerinden virgül ile ayrılmış olarak kullanıcının tam ismini, iş ve ev telefonlarını ve büro numarasını içerebilir. Çoğu sistemde kullanıcının tam ismi için kullanılmaktadır.
dir | Kullanıcının ev dizininin mutlak yolunu içerir.
shell | Kullanıcının öntanımlı kabuğunu çalıştıran dosyanın mutlak yolu.

Örnekler

Örnek 1 - posix_getpwuid() örneği

<?php

$userinfo = posix_getpwuid(10000);

print_r($userinfo);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [name]    => tom
    [passwd]  => x
    [uid]     => 10000
    [gid]     => 42
    [geocs]   => "tom,,,"
    [dir]     => "/home/tom"
    [shell]   => "/bin/bash"
)

Ayrıca Bakınız

  • posix_getpwnam() - Kullanıcı adı belirtilen kullanıcı hakkında bilgi döndürür
  • POSIX getpwnam(3) kılavuz sayfası

posix_getpwnam
posix_getrlimit
POSIX İşlevleri


Sistem özkaynak sınırları hakkında bilgi verir

posix_getpwuid
posix_getsid
POSIX İşlevleri
PHP Manual

posix_getrlimit

(PHP 4, PHP 5, PHP 7)

posix_getrlimit — Sistem özkaynak sınırları hakkında bilgi verir

Açıklama

array posix_getrlimit ( void )

Geçerli özkaynakların normal [soft] ve üst [hard] sınırları hakkında bilgi içeren bir dizi döndürür.

Her özkaynak için bir normal bir de üst sınır vardır. Normal sınır sistem çekirdeğinin dayattağı sınırdır. Üst sınır ise normal sınır için bir tavandır. Yetkisiz bir süreç sadece kendi normal sınırlarını 0'dan üst sınıra kadar bir aralıkta ayarlayabilir ve kendi üst sınırını geri döndürülemez şekilde düşürebilir.

Dönen Değerler

Her elemanında bir sınır tanımlanmış bir ilişkisel dizi döndürür. Her özkaynak için bir normal [soft] bir de üst [hard] sınır vardır.

Dönmesi olası sınır değerlerin listesi
Sınır ismi | Sınır açıklaması
core | Çekirdeğin oluşturduğu core dosyasının azami boyu. 0 olduğu takdirde core dosyası oluşturulmaz. Oluşturulan core dosyasının boyu burada belirtilenden daha büyükse bu boya indirilir (kırpılır).
totalmem | Süreç belleğinin bayt cinsinden azami boyutu.
virtualmem | Süreç sanal belleğinin bayt cinsinden azami boyutu.
data | Süreç veri bölütünün bayt cinsinden azami boyutu.
stack | Süreç yığıtının bayt cinsinden azami boyutu.
rss | Fiziksel bellekteki azami sanal sayfa sayısı.
maxproc | Ana sürecin gerçek kullanıcı kimliği için oluşturulabilecek çocuk süreçlerin azami sayısı.
memlock | Fiziksel bellekte kilitlenebilecek azami bayt sayısı.
cpu | İşlemciyi kullanması için sürece tanınan süre.
filesize | Bayt cinsinden azami dosya boyutu.
openfiles | Azami açık dosya tanıtıcı sayısının bir fazlası.

Örnekler

Örnek 1 - posix_getrlimit() örneği

<?php

$limits = posix_getrlimit();

print_r($limits);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [soft core] => 0
    [hard core] => unlimited
    [soft data] => unlimited
    [hard data] => unlimited
    [soft stack] => 8388608
    [hard stack] => unlimited
    [soft totalmem] => unlimited
    [hard totalmem] => unlimited
    [soft rss] => unlimited
    [hard rss] => unlimited
    [soft maxproc] => unlimited
    [hard maxproc] => unlimited
    [soft memlock] => unlimited
    [hard memlock] => unlimited
    [soft cpu] => unlimited
    [hard cpu] => unlimited
    [soft filesize] => unlimited
    [hard filesize] => unlimited
    [soft openfiles] => 1024
    [hard openfiles] => 1024
)

Notlar

Bilginize:

Bu bir POSIX işlevi değildir, BSD ve System V sistemlerinde vardır. Eğer sisteminiz bu işlevi desteklemiyorsa PHP derlenirken bu işlev derlenmeyecektir. Bir işlevin varlığına function_exists() ile bakabilirsiniz.

Ayrıca Bakınız

  • getrlimit(2) kılavuz sayfası

posix_getpwuid
posix_getsid
POSIX İşlevleri


Geçerli sürecin oturum kimliğini döndürür

posix_getrlimit
posix_getuid
POSIX İşlevleri
PHP Manual

posix_getsid

(PHP 4, PHP 5, PHP 7)

posix_getsid — Geçerli sürecin oturum kimliğini döndürür

Açıklama

int posix_getsid ( int $pid )

pid süreç kimlikli sürecin oturum kimliğini döndürür. Bir sürecin oturum kimliği oturum liderinin süreç grup kimliğidir.

Değiştirgeler

pid

Süreç kimliği. 0 belirtilirse geçerli süreç belirtilmiş varsayılır. Geçersiz bir pid belirtilirse FALSE döner ve oluşan hataya posix_get_last_error() işlevi üzerinden erişilebilir.

Dönen Değerler

Oturum kimliği bir tamsayı olarak döndürülür.

Örnekler

Örnek 1 - posix_getsid() örneği

<?php
$pid = posix_getpid();
echo posix_getsid($pid); //8805
?>

Ayrıca Bakınız

  • posix_getpgid() - Süreç kimliği belirtilen sürecin süreç grup kimliğini döndürür
  • posix_setsid() - Geçerli süreci bir oturumun lider süreci haline getirir
  • POSIX getsid(2) kılavuz sayfası

posix_getrlimit
posix_getuid
POSIX İşlevleri


Geçerli sürecin gerçek kullanıcı kimliğini döndürür

posix_getsid
posix_initgroups
POSIX İşlevleri
PHP Manual

posix_getuid

(PHP 4, PHP 5, PHP 7)

posix_getuid — Geçerli sürecin gerçek kullanıcı kimliğini döndürür

Açıklama

int posix_getuid ( void )

Geçerli sürecin gerçek kullanıcı kimliğini döndürür.

Dönen Değerler

Kullanıcı kimliğini bir tamsayı olarak döndürür.

Örnekler

Örnek 1 - posix_getuid() örneği

<?php
echo posix_getuid(); //10000
?>

Ayrıca Bakınız

  • posix_getpwuid() - Kullanıcı kimliği belirtilen kullanıcı hakkında bilgi döndürür
  • POSIX getuid(2) kılavuz sayfası

posix_getsid
posix_initgroups
POSIX İşlevleri


Grup erişim listesini hesaplar

posix_getuid
posix_isatty
POSIX İşlevleri
PHP Manual

posix_initgroups

(PHP 5 >= 5.2.0, PHP 7)

posix_initgroups — Grup erişim listesini hesaplar

Açıklama

bool posix_initgroups ( string $isim , int $ana_gid )

İsmi belirtilen kullanıcının grup erişim listesini hesaplar.

Değiştirgeler

isim

Kullanıcı ismi.

ana_gid

Genelde passwd dosyasındaki grup numarasıdır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • initgroups(3) kılavuz sayfasına bakınız.

posix_getuid
posix_isatty
POSIX İşlevleri


Dosya tanıtıcısı bir etkileşimli uçbirimle ilişkili mi diye bakar

posix_initgroups
posix_kill
POSIX İşlevleri
PHP Manual

posix_isatty

(PHP 4, PHP 5, PHP 7)

posix_isatty — Dosya tanıtıcısı bir etkileşimli uçbirimle ilişkili mi diye bakar

Açıklama

bool posix_isatty ( int $dt )

dt dosya tanıtıcısı bir etkileşimli uçbirimle ilişkili mi diye bakar.

Değiştirgeler

dt

Dosya tanıtıcısı.

Dönen Değerler

dt bir uçbirime bağlı açık bir dosya tanıtıcısı ise TRUE, diğer tüm durumlarda FALSE döner.

Ayrıca Bakınız

  • posix_ttyname() - Uçbirim aygıt ismini belirler

posix_initgroups
posix_kill
POSIX İşlevleri


Bir sürece bir sinyal gönderir

posix_isatty
posix_mkfifo
POSIX İşlevleri
PHP Manual

posix_kill

(PHP 4, PHP 5, PHP 7)

posix_kill — Bir sürece bir sinyal gönderir

Açıklama

bool posix_kill ( int $pid , int $sinyal )

pid süreç kimlikli sürece sinyal sinyalini gönderir.

Değiştirgeler

pid

Süreç kimliği.

sinyal

PCNTL sinyal sabitlerinen biri.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • 0, -1 ve diğer negatif süreç kimlikleri ile 0. sinyal hakkında ayrıntılı bilgi için kill(2) kılavuz sayfasına bakınız.

posix_isatty
posix_mkfifo
POSIX İşlevleri


Bir isimli boru dosyası (FIFO) oluşturur

posix_kill
posix_mknod
POSIX İşlevleri
PHP Manual

posix_mkfifo

(PHP 4, PHP 5, PHP 7)

posix_mkfifo — Bir isimli boru dosyası (FIFO) oluşturur

Açıklama

bool posix_mkfifo ( string $dosya , int $kip )

Dosya sisteminde, süreçlerin iki yönlü iletişimi için özel bir FIFO dosyası oluşturur.

Değiştirgeler

dosya

FIFO dosyasının yolu.

kip

Sekizlik gösterimle izinler (0644 gibi). Yeni oluşturulan FIFO dosyasının izinleri ayrıca geçerli umask() değerine de bağlıdır. Oluşturulan dosyanın izinleri kip & ~umask ifadesinin sonucudur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

Bilginize: Güvenli kip etkinken, PHP, dosya ve dizinlerin sahibinin betiği çalıştıran kullanıcı ile aynı olup olmadığını sınar.

posix_kill
posix_mknod
POSIX İşlevleri


Özel veya sıralı (POSIX.1) bir dosya oluşturur

posix_mkfifo
posix_setegid
POSIX İşlevleri
PHP Manual

posix_mknod

(PHP 5 >= 5.1.0, PHP 7)

posix_mknod — Özel veya sıralı (POSIX.1) bir dosya oluşturur

Açıklama

bool posix_mknod ( string $yol , int $kip [, int $büyük = 0 [, int $küçük = 0 ]] )

Özel veya sıralı (POSIX.1) bir dosya oluşturur.

Değiştirgeler

yol

Oluşturulacak dosyanın yolu.

kip

İzinlerle şu sabitleren biri bitsel VEYAlanarak belirtilir: POSIX_S_IFREG, POSIX_S_IFCHR, POSIX_S_IFBLK, POSIX_S_IFIFO, POSIX_S_IFSOCK.

büyük

Büyük aygıt numarası (S_IFCHR veya S_IFBLK belirtirken gerekir).

küçük

Küçük aygıt numarası (öntanımlı değer: 0).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - posix_mknod() örneği

<?php

$file = '/tmp/tmpfile';  // dosya ismi
$type = POSIX_S_IFBLK;   // dosya türü (blok aygıtı)
$permissions = 0777;     // sekizlik izinler
$major = 1;
$minor = 8;              // /dev/random

if (!posix_mknod($file, $type | $permissions, $major, $minor)) {
    die('Hata ' . posix_get_last_error() . ': ' . posix_strerror(posix_get_last_error()));
}

?>

Ayrıca Bakınız

  • posix_mkfifo() - Bir isimli boru dosyası (FIFO) oluşturur

posix_mkfifo
posix_setegid
POSIX İşlevleri


Geçerli sürecin etkin grup kimliğini belirler

posix_mknod
posix_seteuid
POSIX İşlevleri
PHP Manual

posix_setegid

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

posix_setegid — Geçerli sürecin etkin grup kimliğini belirler

Açıklama

bool posix_setegid ( int $gid )

Geçerli sürecin etkin grup kimliğini belirler. Bu işlev root yetkisi gerektirir.

Değiştirgeler

gid

Grup kimliği.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - posix_setegid() örneği

Örnekte etkin grup kimliği değişmeden ve değiştikten sonra gösterilmektedir.

<?php
echo 'Etkin grup kimliğim: '.posix_getegid(); //20
posix_setegid(40);
echo 'Etkin grup kimliğim: '.posix_getegid(); //40
echo 'Gerçek grup kimliğim: '.posix_getgid(); //20
?>

Ayrıca Bakınız

  • posix_getgrgid() - Grup kimliği belirtilen grup hakkında bilgi verir
  • posix_getgid() - Çalışan sürecin gerçek grup kimliğini döndürür
  • posix_setgid() - Geçerli sürecin grup kimliğini tanımlar

posix_mknod
posix_seteuid
POSIX İşlevleri


Geçerli sürecin etkin kullanıcı kimliğini belirler

posix_setegid
posix_setgid
POSIX İşlevleri
PHP Manual

posix_seteuid

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

posix_seteuid — Geçerli sürecin etkin kullanıcı kimliğini belirler

Açıklama

bool posix_seteuid ( int $uid )

Geçerli sürecin etkin kullanıcı kimliğini belirler. Bu işlev root yetkisi gerektirir.

Değiştirgeler

uid

Kullanıcı kimliği.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • posix_setgid() - Geçerli sürecin grup kimliğini tanımlar

posix_setegid
posix_setgid
POSIX İşlevleri


Geçerli sürecin grup kimliğini tanımlar

posix_seteuid
posix_setpgid
POSIX İşlevleri
PHP Manual

posix_setgid

(PHP 4, PHP 5, PHP 7)

posix_setgid — Geçerli sürecin grup kimliğini tanımlar

Açıklama

bool posix_setgid ( int $gid )

Geçerli sürecin gerçek grup kimliğini tanımlar. Bu işlev normalde root yetkisi gerektirir. Uygun olan posix_setgid() işlevini, posix_setuid() işlevinden önce çağırmaktır.

Bilginize:

İşlev root tarafından kullanıldığında ayrıca etkin grup kimliği de tanımlanır.

Değiştirgeler

gid

Grup kimliği.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - posix_setgid() örneği

Örnekte gerçek grup kimliği değişmeden ve değiştikten sonra gösterilmektedir.

<?php
echo 'Gerçek grup kimliğim: '.posix_getgid(); //20
posix_setgid(40);
echo 'Gerçek grup kimliğim: '.posix_getgid(); //40
echo 'Etkin grup kimliğim: '.posix_getegid(); //40
?>

Ayrıca Bakınız

  • posix_getgrgid() - Grup kimliği belirtilen grup hakkında bilgi verir
  • posix_getgid() - Çalışan sürecin gerçek grup kimliğini döndürür

posix_seteuid
posix_setpgid
POSIX İşlevleri


İş denetimi için süreç grup kimliğini tanımlar

posix_setgid
posix_setrlimit
POSIX İşlevleri
PHP Manual

posix_setpgid

(PHP 4, PHP 5, PHP 7)

posix_setpgid — İş denetimi için süreç grup kimliğini tanımlar

Açıklama

bool posix_setpgid ( int $pid , int $pgid )

pid sürecini pgid süreç grubuna dahil eder.

Değiştirgeler

pid

Süreç kimliği.

pgid

Süreç grubu kimliği.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • Süreç grupları ve iş denetimi hakkında daha fazla bilgi edinmek için POSIX.1 standardına ve setsid(2) kılavuz sayfasına bakınız.

posix_setgid
posix_setrlimit
POSIX İşlevleri


Set system resource limits

posix_setpgid
posix_setsid
POSIX İşlevleri
PHP Manual

posix_setrlimit

(PHP 7)

posix_setrlimit — Set system resource limits

Açıklama

bool posix_setrlimit ( int $resource , int $softlimit , int $hardlimit )

posix_setrlimit() sets the soft and hard limits for a given system resource.

Each resource has an associated soft and hard limit. The soft limit is the value that the kernel enforces for the corresponding resource. The hard limit acts as a ceiling for the soft limit. An unprivileged process may only set its soft limit to a value from 0 to the hard limit, and irreversibly lower its hard limit.

Değiştirgeler

resource

The resource limit constant corresponding to the limit that is being set.

softlimit

The soft limit, in whatever unit the resource limit requires, or POSIX_RLIMIT_INFINITY.

hardlimit

The hard limit, in whatever unit the resource limit requires, or POSIX_RLIMIT_INFINITY.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • man page SETRLIMIT(2)
  • posix_getrlimit() - Sistem özkaynak sınırları hakkında bilgi verir

posix_setpgid
posix_setsid
POSIX İşlevleri


Geçerli süreci bir oturumun lider süreci haline getirir

posix_setrlimit
posix_setuid
POSIX İşlevleri
PHP Manual

posix_setsid

(PHP 4, PHP 5, PHP 7)

posix_setsid — Geçerli süreci bir oturumun lider süreci haline getirir

Açıklama

int posix_setsid ( void )

Geçerli süreci bir oturumun lider süreci haline getirir.

Dönen Değerler

Hata durumunda -1, yoksa oturum kimliği döner.

Ayrıca Bakınız

  • Süreç grupları ve iş denetimi hakkında daha fazla bilgi edinmek için POSIX.1 standardına ve setsid(2) kılavuz sayfasına bakınız.

posix_setrlimit
posix_setuid
POSIX İşlevleri


Geçerli sürecin kullanıcı kimliğini tanımlar

posix_setsid
posix_strerror
POSIX İşlevleri
PHP Manual

posix_setuid

(PHP 4, PHP 5, PHP 7)

posix_setuid — Geçerli sürecin kullanıcı kimliğini tanımlar

Açıklama

bool posix_setuid ( int $uid )

Geçerli sürecin gerçek kullanıcı kimliğini tanımlar. Bu işlevi kullanabilmek için root yetkisine sahip olmanız gerekir.

Değiştirgeler

uid

Kullanıcı kimliği.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - posix_setuid() örneği

Bu örnekte geçerli kullanıcı kimliği gösterilip başka bir değere ayarlanmaktadır.

<?php
echo posix_getuid()."\n"; //10001
echo posix_geteuid()."\n"; //10001
posix_setuid(10000);
echo posix_getuid()."\n"; //10000
echo posix_geteuid()."\n"; //10000
?>

Ayrıca Bakınız

  • posix_setgid() - Geçerli sürecin grup kimliğini tanımlar
  • posix_seteuid() - Geçerli sürecin etkin kullanıcı kimliğini belirler
  • posix_getuid() - Geçerli sürecin gerçek kullanıcı kimliğini döndürür
  • posix_geteuid() - Çalışan sürecin etkin kullanıcı kimliğini döndürür

posix_setsid
posix_strerror
POSIX İşlevleri


Belirtilen hatanum ile ilgili sistem hata iletisini döndürür

posix_setuid
posix_times
POSIX İşlevleri
PHP Manual

posix_strerror

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

posix_strerror — Belirtilen hatanum ile ilgili sistem hata iletisini döndürür

Açıklama

string posix_strerror ( int $hatanum )

Belirtilen hatanum ile ilgili sistem hata iletisini döndürür. hatanum, posix_get_last_error() işlevinden dönmüş bir değer olabilir.

Değiştirgeler

hatanum

posix_get_last_error() işlevinden dönmüş bir POSIX hata numarası. 0 belirtilirse "Success" dizgesi döner.

Dönen Değerler

Hata iletisini bir dizge olarak döndürür.

Örnekler

Örnek 1 - posix_strerror() örneği

Bu örnekte çalışmayan bir süreç öldürülmeye çalışılacak ve dönen hata iletisi gösterilecektir.

<?php
posix_kill(50,SIGKILL);
echo posix_strerror(posix_get_last_error())."\n";
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

No such process

Ayrıca Bakınız

  • posix_get_last_error() - Başarısız olan son POSIX işlevinden atanan hata numarasını döndürür

posix_setuid
posix_times
POSIX İşlevleri


Süreçle ilgili işlemci zamanlarını döndürür

posix_strerror
posix_ttyname
POSIX İşlevleri
PHP Manual

posix_times

(PHP 4, PHP 5, PHP 7)

posix_times — Süreçle ilgili işlemci zamanlarını döndürür

Açıklama

array posix_times ( void )

O an ki işlemci kullanımı ile ilgili bilgi verir.

Dönen Değerler

O an ki işlemci kullanımı hakkındaki bilgileri indisli bir dizge olarak döndürür. İndisler şunlardır:

  • ticks - sistem açıldığından beri sayılan saat tiklerinin sayısı.
  • utime - geçerli süreç tarafından harcanan kullanıcı zamanı.
  • stime - geçerli süreç tarafından harcanan sistem zamanı.
  • cutime - geçerli süreç ve çocukları tarafından harcanan kullanıcı zamanı.
  • cstime - geçerli süreç ve çocukları tarafından harcanan sistem zamanı.

Notlar

Uyarı

Bu işlev, büyük süreler için negatif değerler döndürebileceğinden güvenilir değildir.

Örnekler

Örnek 1 - posix_times() örneği

<?php

$times = posix_times();

print_r($times);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [ticks] => 25814410
    [utime] => 1
    [stime] => 1
    [cutime] => 0
    [cstime] => 0
)

posix_strerror
posix_ttyname
POSIX İşlevleri


Uçbirim aygıt ismini belirler

posix_times
posix_uname
POSIX İşlevleri
PHP Manual

posix_ttyname

(PHP 4, PHP 5, PHP 7)

posix_ttyname — Uçbirim aygıt ismini belirler

Açıklama

string posix_ttyname ( int $dt )

dt ile belirtilen dosya tanıtıcısının üzerinde açıldığı uçbirim aygıtının mutlak dosya yolunu bir dizge olarak döndürür.

Değiştirgeler

dt

Dosya tanıtıcısı.

Dönen Değerler

İşlem başarısız olursa FALSE yoksa dt tanıtıcısının mutlak dosya yolunu bir dizge olarak döndürür.

posix_times
posix_uname
POSIX İşlevleri


Sistem hakkında bilgi verir

posix_ttyname
Program Çalıştırma
POSIX İşlevleri
PHP Manual

posix_uname

(PHP 4, PHP 5, PHP 7)

posix_uname — Sistem hakkında bilgi verir

Açıklama

array posix_uname ( void )

Sistem hakkında bilgi verir.

POSIX standardı, değerlerin biçemleri hakkında önkabuller yapılmamasını gerektirir. Örneğin, bir sürüm numarası üç rakamdan oluşur yoksa bu işlev hiçbir şey döndürmez gibi önkabullerin yapılmaması gerekir.

Dönen Değerler

Sistem hakkında özet bilgiyi bir dizge olarak döndürür. Dizgenin içerdiği verilerin indisleri şunlardır:

  • sysname - işletim sisteminin ismi (Linux gibi)
  • nodename - sistem ismi (makinem.yerel gibi)
  • release - işletim siteminin sürüm numarası (2.6.28 gibi)
  • version - işletim sisteminin sürüm bilgileri (#4 Tue Jul 20 17:01:36 MEST 1999 gibi)
  • machine - sistem mimarisi (i686 gibi)
  • domainname - DNS alanadı (example.com gibi)

domainname bir GNU oluşumu olup POSIX.1'e ait değildir. Dolayısıyla bu alan sadece GNU sistemlerinde ve GNU Libc kullanılan sistemlerde mevcuttur.

Örnekler

Örnek 1 - posix_uname() örneği

<?php
$uname=posix_uname();
print_r($uname);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [sysname] => Linux
    [nodename] => makinem.yerel
    [release] => 2.6.29.5-1
    [version] => #1 SMP PREEMPT Tue Jun 16 14:39:34 EEST 2009
    [machine] => x86_64
)

posix_ttyname
Program Çalıştırma
POSIX İşlevleri


Sistem Programlarının Çalıştırılması

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Program Çalıştırma İşlevleri
    • escapeshellarg — Bir komutun değiştirge dizgesini önceler
    • escapeshellcmd — Kabuk meta karakterlerini önceler
    • exec — Bir komut çalıştırır
    • passthru — Harici bir programı çalıştırır ve çıktısını ham olarak gösterir
    • proc_close — proc_open tarafından açılmış bir süreci kapatır ve sürecin çıkış kodunu döndürür
    • proc_get_status — proc_open tarafından açılmış bir süreç hakkında bilgi döndürür
    • proc_nice — Çalışan sürecin önceliğini değiştirir
    • proc_open — Bir komutu çalıştırır ve G/Ç için bir dosya tanıtıcı açar
    • proc_terminate — proc_open ile açılmış bir süreci öldürür
    • shell_exec — Komutu kabukta çalıştırır ve çıktısının tamamını bir dizge olarak döndürür
    • system — Belirtilen harici komutu çalıştırır ve çıktısını gösterir
posix_uname
Giriş
Süreç Denetim Eklentileri


Giriş

Bu bölümdeki işlevler, komutları sistemin kendisinde çalıştırmak ve güvenli kılmak için tasarlanmıştır.

Bilginize:

Windows altında, tüm çalıştırma işlevleri cmd.exe üzerinden çağrılır. Bu bakımdan bu işlevleri çağıran kullanıcının komutu çalıştıracak yetkilerle donatılmış olması gerekir. Bunun tek istisnası, bypass_shell seçeneği ile proc_open() işlevidir.

Program Çalıştırma
Yapılandırma/Kurulum
Program Çalıştırma


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Program Çalıştırma


Özkaynak Türleri

Bu eklenti, proc_open() işlevi tarafından döndürülen ve süreç özkaynağı adı verilen bir özkaynak tanımlar.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
Program Çalıştırma İşlevleri
Program Çalıştırma


Program Çalıştırma İşlevleri

Notlar

Uyarı

Kilitlenerek açılmış dosyaların (özellikle açık oturumlarda) bir programı artalanda çalıştırmadan önce kapatılması gerekir.

Ayrıca Bakınız

Bu işlevler ayrıca, çalıştırma işleci ile de yakından ilgilidir. Ayrıca, güvenli kipte safe_mode_exec_dir yönergesini de ayarlamalısınız.

İçindekiler

  • escapeshellarg — Bir komutun değiştirge dizgesini önceler
  • escapeshellcmd — Kabuk meta karakterlerini önceler
  • exec — Bir komut çalıştırır
  • passthru — Harici bir programı çalıştırır ve çıktısını ham olarak gösterir
  • proc_close — proc_open tarafından açılmış bir süreci kapatır ve sürecin çıkış kodunu döndürür
  • proc_get_status — proc_open tarafından açılmış bir süreç hakkında bilgi döndürür
  • proc_nice — Çalışan sürecin önceliğini değiştirir
  • proc_open — Bir komutu çalıştırır ve G/Ç için bir dosya tanıtıcı açar
  • proc_terminate — proc_open ile açılmış bir süreci öldürür
  • shell_exec — Komutu kabukta çalıştırır ve çıktısının tamamını bir dizge olarak döndürür
  • system — Belirtilen harici komutu çalıştırır ve çıktısını gösterir
Öntanımlı Sabitler
escapeshellarg
Program Çalıştırma


Bir komutun değiştirge dizgesini önceler

Program Çalıştırma İşlevleri
escapeshellcmd
Program Çalıştırma İşlevleri
PHP Manual

escapeshellarg

(PHP 4 >= 4.0.3, PHP 5, PHP 7)

escapeshellarg — Bir komutun değiştirge dizgesini önceler

Açıklama

string escapeshellarg ( string $değiştirge )

escapeshellarg() işlevi, tek bir değiştirge olarak ele alınmak üzere bir dizgeyi tek tırnaklarla sarmalar ve tek başına bulunan tek tırnakları da önceler. Bu işlev kullanıcı girdisinden gelen kabuk işlevi değiştirgelerini tek tek öncelemekte kullanılmalıdır. exec(), system() ve çalıştırma işlecine aktarılacak değiştirgeler bu işlemden geçirilmelidir.

Değiştirgeler

değiştirge

Öncelenecek değiştirge.

Dönen Değerler

Öncelenmiş dizge.

Örnekler

Örnek 1 - escapeshellarg() örneği

<?php
system('ls '.escapeshellarg($dir));
?>

Ayrıca Bakınız

  • escapeshellcmd() - Kabuk meta karakterlerini önceler
  • exec() - Bir komut çalıştırır
  • popen() - Bir süreç tanıtıcısı açar
  • system() - Belirtilen harici komutu çalıştırır ve çıktısını gösterir
  • Çalıştırma İşleci

Program Çalıştırma İşlevleri
escapeshellcmd
Program Çalıştırma İşlevleri


Kabuk meta karakterlerini önceler

escapeshellarg
exec
Program Çalıştırma İşlevleri
PHP Manual

escapeshellcmd

(PHP 4, PHP 5, PHP 7)

escapeshellcmd — Kabuk meta karakterlerini önceler

Açıklama

string escapeshellcmd ( string $komut )

escapeshellcmd() işlevi, içinde keyfi komutlar çalıştırarak bir kabuk komutunu kandırmak için kullanılabilecek bir dizgenin içerdiği karakterleri önceler. Bu işlev, exec() veya system() işlevlerine ya da çalıştırma işlecine aktarılmadan önce kullanıcı girdisi olarak alınan veriyi öncelemek için kullanılmalıdır.

Bir tersbölü çizgisi ile öncelenen karakterler şunlardır: #&;`|*?~<>^()[]{}$\, \x0A ve \xFF. ' ve " karakterleri sadece çiftler halinde kullanılmışsa öncelenir. Windows'a tüm bu karakterlere ek olarak % karakteri yerine bir boşluk yerleştirilir.

Değiştirgeler

komut

Öncelenecek komut dizgesi.

Dönen Değerler

Öncelenmiş komut dizgesi.

Örnekler

Örnek 1 - escapeshellcmd() örneği

<?php
$e = escapeshellcmd($userinput);

// $e boşluk içeriyorsa burada dikkate almayacağız
system("echo $e");
$f = escapeshellcmd($filename);

// ve burada tırnakları kullanıyoruz
system("touch \"/tmp/$f\"; ls -l \"/tmp/$f\"");
?>

Ayrıca Bakınız

  • escapeshellarg() - Bir komutun değiştirge dizgesini önceler
  • exec() - Bir komut çalıştırır
  • popen() - Bir süreç tanıtıcısı açar
  • system() - Belirtilen harici komutu çalıştırır ve çıktısını gösterir
  • Çalıştırma İşleci

escapeshellarg
exec
Program Çalıştırma İşlevleri


Bir komut çalıştırır

escapeshellcmd
passthru
Program Çalıştırma İşlevleri
PHP Manual

exec

(PHP 4, PHP 5, PHP 7)

exec — Bir komut çalıştırır

Açıklama

string exec ( string $komut [, array &$çıktı [, int &$dönüş_değeri ]] )

exec() işlevi belirtilen komut'u çalıştırır.

Değiştirgeler

komut

Çalıştırılacak komut.

çıktı

Bu değiştirge belirtilmişse, dizinin her elemanına komut çıktısının bir satırı yazılır. Satırların sonundaki \n gibi boşluk karakterleri dizide bulunmaz. Dizi zaten bazı elemanlar içeriyorsa exec() çıktısı dizinin sonuna eklenir. Eğer işlevin çıktısının böyle dizi sonuna eklemesini istemezseniz, diziyi exec() işlevine aktarmadan önce üzerinde bir unset() çağrısı yapmalısınız.

dönüş_değeri

çıktı değiştirgesinin yanında bir dönüş_değeri değiştirgesi belirtilmişse komutun çıkış durumu bu değiştirgeye yazılır.

Dönen Değerler

Komut çıktısının son satırı. Bir komutu, çıktısı ortamla etkileşime girmeden doğrudan geri aktarılsın isterseniz passthru() işlevini kullanın.

Çalıştırılan komutun çıktısını almak istiyorsanız çıktı değiştirgesini belirtmeyi unutmayın.

Örnekler

Örnek 1 - exec() örneği

<?php
// php/httpd süreçlerinin sahibi olan kullanıcının ismini çıktılayalım
// Tabii, whoami komutu olan bir sistemde.
echo exec('whoami');
?>

Notlar

Uyarı

Kullanıcı kaynaklı verilerin bu işlev üzerinden aktarımına izin verecekseniz, kullanıcının bazı komutlar çalıştırarak sistemi kandıramaması için escapeshellarg() veya escapeshellcmd() işlevlerini kullanınız.

Bilginize:

Eğer bir uygulama bu işlevle başlatılmışsa uygulamanın artalanda çalışmasını sürdürebilmesi için uygulama çıktısı ya bir dosyaya ya da başka bir çıktı akımına yönlendirilmelidir. Aksi takdirde, uygulama sonlanana kadar PHP askıda kalacaktır.

Bilginize: Güvenli kip etkinken, dosyaları sadece safe_mode_exec_dir ile çalıştırabilirsiniz. Uygulamadan kaynaklanan sebeplerle çalıştırılabilirin dosya yolunda .. bileşenine şimdilik izin verilmemektedir.

Uyarı

güvenli kipin etkin kılınmasıyla, komut dizgesi escapeshellcmd() ile öncelenir. Böylece, echo y | echo x komut dizgesi echo y \| echo x haline gelir.

Ayrıca Bakınız

  • system() - Belirtilen harici komutu çalıştırır ve çıktısını gösterir
  • passthru() - Harici bir programı çalıştırır ve çıktısını ham olarak gösterir
  • escapeshellcmd() - Kabuk meta karakterlerini önceler
  • pcntl_exec() - Belirtilen programı geçerli süreç ortamında çalıştırır
  • Çalıştırma İşleci

escapeshellcmd
passthru
Program Çalıştırma İşlevleri


Harici bir programı çalıştırır ve çıktısını ham olarak gösterir

exec
proc_close
Program Çalıştırma İşlevleri
PHP Manual

passthru

(PHP 4, PHP 5, PHP 7)

passthru — Harici bir programı çalıştırır ve çıktısını ham olarak gösterir

Açıklama

void passthru ( string $komut [, int &$dönüş_değeri ] )

passthru() işlevi komut çalıştıran bir işlev olarak exec() işlevine benzer. Bir Unix komutunun ikil çıktısının doğrudan tarayıcıya aktarılmasını istediğiniz durumlarda exec() veya system() işlevlerinin yerine bu işlevi kullanmalısınız. Bu işlevi kullanmanın yararlı olduğu yerlerden biri, bir resim akımını doğrudan çıktılayan pbmplus gibi araçların kullanımıdır. İçerik türünü image/gif olarak ayarlayıp, bir gif çıktılamak için bir pbmplus aracını çalıştırırsanız, doğrudan resim çıktılayan bir PHP betiğiniz olur.

Değiştirgeler

komut

Çalıştırılacak komut.

dönüş_değeri

Bu değiştirge belirtilmişse, Unix komutunun çıkış değeri bu değişkene yazılır.

Dönen Değerler

Hiçbir değer dönmez.

Notlar

Uyarı

Kullanıcı kaynaklı verilerin bu işlev üzerinden aktarımına izin verecekseniz, kullanıcının bazı komutlar çalıştırarak sistemi kandıramaması için escapeshellarg() veya escapeshellcmd() işlevlerini kullanınız.

Bilginize:

Eğer bir uygulama bu işlevle başlatılmışsa uygulamanın artalanda çalışmasını sürdürebilmesi için uygulama çıktısı ya bir dosyaya ya da başka bir çıktı akımına yönlendirilmelidir. Aksi takdirde, uygulama sonlanana kadar PHP askıda kalacaktır.

Bilginize: Güvenli kip etkinken, dosyaları sadece safe_mode_exec_dir ile çalıştırabilirsiniz. Uygulamadan kaynaklanan sebeplerle çalıştırılabilirin dosya yolunda .. bileşenine şimdilik izin verilmemektedir.

Uyarı

güvenli kipin etkin kılınmasıyla, komut dizgesi escapeshellcmd() ile öncelenir. Böylece, echo y | echo x komut dizgesi echo y \| echo x haline gelir.

Ayrıca Bakınız

  • exec() - Bir komut çalıştırır
  • system() - Belirtilen harici komutu çalıştırır ve çıktısını gösterir
  • popen() - Bir süreç tanıtıcısı açar
  • escapeshellcmd() - Kabuk meta karakterlerini önceler
  • Çalıştırma İşleci

exec
proc_close
Program Çalıştırma İşlevleri


proc_open tarafından açılmış bir süreci kapatır ve sürecin çıkış kodunu döndürür

passthru
proc_get_status
Program Çalıştırma İşlevleri
PHP Manual

proc_close

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

proc_close — proc_open() tarafından açılmış bir süreci kapatır ve sürecin çıkış kodunu döndürür

Açıklama

int proc_close ( resource $süreç )

proc_close() işlevi, proc_open() tarafından açılmış süreçleri kapatması dışında pclose() işlevi gibidir. proc_close() sürecin sonlanmasını bekler ve çıkış kodunu döndürür. Bu sürece açılan borular varsa, bir kısır döngü oluşmaması için bu işlevi çağırmadan önce fclose() ile onları kapatmalısınız. Açık borular varken çocuk süreç çıkmayı reddedecektir.

Değiştirgeler

süreç

proc_open() tarafından açılmış bir süreç.

Dönen Değerler

Sonlandırılan sürecin çıkış kodunu döndürür.

passthru
proc_get_status
Program Çalıştırma İşlevleri


proc_open tarafından açılmış bir süreç hakkında bilgi döndürür

proc_close
proc_nice
Program Çalıştırma İşlevleri
PHP Manual

proc_get_status

(PHP 5, PHP 7)

proc_get_status — proc_open() tarafından açılmış bir süreç hakkında bilgi döndürür

Açıklama

array proc_get_status ( resource $süreç )

proc_get_status() işlevi, proc_open() tarafından açılmış bir süreçle ilgili verileri döndürür.

Değiştirgeler

süreç

Hakkında bilgi döndürülecek proc_open() özkaynağı.

Dönen Değerler

Başarısızlık durumunda FALSE, aksi takdirde toplanan verileri içeren bir dizi döner. Dönen dizi şu elemanları içerir:

Eleman | Türü | Açıklama
command | string | proc_open() işlevine aktarılan komut dizgesi.
pid | int | Süreç kimliği.
running | bool | Süreç hala çalışıyorsa TRUE, sonlanmışsa FALSE.
signaled | bool | Alt süreç yakalanmayan bir sinyal ile sonlanmışsa TRUE. Windows üzerinde daima FALSE'tır.
stopped | bool | Alt süreç bir sinyal ile durdurulmuşsa TRUE. Windows üzerinde daima FALSE'tır.
exitcode | int | Süreç tarafından döndürülen çıkış kodu (sadece running FALSE ise anlamlıdır). İşlevin sadece ilk çağrısı gerçek değeri döndürür, diğerleri -1 döndürecektir.
termsig | int | Alt sürecin sonlanmasını sağlayan sinyalin numarası (sadece signaled TRUE ise anlamlıdır).
stopsig | int | Alt sürecin durdurulmasını sağlayan sinyalin numarası (sadece stopped TRUE ise anlamlıdır).

Ayrıca Bakınız

  • proc_open() - Bir komutu çalıştırır ve G/Ç için bir dosya tanıtıcı açar

proc_close
proc_nice
Program Çalıştırma İşlevleri


Çalışan sürecin önceliğini değiştirir

proc_get_status
proc_open
Program Çalıştırma İşlevleri
PHP Manual

proc_nice

(PHP 5, PHP 7)

proc_nice — Çalışan sürecin önceliğini değiştirir

Açıklama

bool proc_nice ( int $fark )

proc_nice() işlevi çalışan sürecin önceliğini fark kadar değiştirir. Pozitif bir fark sürecin önceliğini düşürürken negatif bir fark önceliği arttıracaktır.

proc_nice() işlevinin proc_open() ve onunla ilişkili diğer işlevlerle bir ilişkisi yoktur.

Değiştirgeler

fark

Önceliği değiştirecek fark.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. Kullanıcının önceliği değiştirme yetkisinin olmaması gibi hata durumlarında E_WARNING seviyesinde bir ileti çıktılanır.

Notlar

Bilginize: Kullanılabilirlik

proc_nice() işlevi sadece sisteminiz 'nice' yeteneğine sahipse mevcut olacaktır. 'nice' bulunan sistemler: SVr4, SVID EXT, AT&T, X/OPEN, BSD 4.3. Yani, Windows'ta proc_nice() diye bir işlev yoktur.

proc_get_status
proc_open
Program Çalıştırma İşlevleri


Bir komutu çalıştırır ve G/Ç için bir dosya tanıtıcı açar

proc_nice
proc_terminate
Program Çalıştırma İşlevleri
PHP Manual

proc_open

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

proc_open — Bir komutu çalıştırır ve G/Ç için bir dosya tanıtıcı açar

Açıklama

resource proc_open ( string $komut , array $tanıtıcılar , array &$borular [, string $dizin [, array $ortam [, array $seçenekler ]]] )

proc_open() işlevi, program çalıştırma konusunda daha geniş denetim imkanı sağlaması dışında popen() gibidir.

Değiştirgeler

cmd

Çalıştırılacak komut.

tanıtıcılar

İndisli bir dizi olup, indisler tanıtıcı numaralarını, değerler ise PHP'nin çocuk süreçlere bu tanıtıcıları nasıl aktaracağını gösterir. 0 indisi, standart girdi; 1 indisi, standart çıktı; 2 indisi ise standart hata içindir.

Her eleman şunları içerebilir:

  • Sürece aktarılacak boruyu tanımlayan bir dizi. İlk eleman tanıtıcı türü, ikincisi belirtilen türde bir seçenektir. Geçerli türler: pipe (ikinci eleman sürece okuma ucunu aktaran r veya yazma ucunu aktaran w olabilir) ve file (ikinci eleman bir dosya ismidir).
  • Gerçek bir dosya tanıtıcısına karşılık gelen bir akım özkaynağı (örneğin, STDIN, bir soket, açılmış bir dosya gibi).

Dosya tanıtıcıları 0, 1 ve 2 ile sınırlı değildir; çocuk sürece aktarılmak üzere herhangi bir dosya tanıtıcı belirtebilirsiniz. Böylece, betiğiniz diğer betiklerin arasında bir yardımcı süreç olarak çalışabilir. Bu özellikle, güvenlikle ilgili konularda PGP, GPG ve openssl gibi programlara anahtar parolasını aktarmak için kullanışlıdır. Ayrıca, bu programlar tarafından yardımcı dosya tanıtıcılarıyla sağlanan durum bilgisini okumak için de kullanışlıdır.

borular

PHP'nin oluşturduğu boru uçlarına karşılık gelen dosya tanıtıcılarını içeren indisli bir dizi.

dizin

Komutun ilk çalıştırılacağı dizin. İlk çalıştırma dizini mutlak bir dosya yolu olabileceği gibi öntanımlı çalışma dizinini kullanmak isterseniz NULL da olabilir. Öntanımlı çalıştırma dizini PHP sürecinin çalıştırıldığı dizindir.

ortam

Çalıştırılacak komutun ortamına aktarılacak ortam değişkenleri dizisi. PHP süreci ile aynı ortamı kullanmak isterseniz NULL belirtebilirsiniz.

seçenekler

Ek seçenekler belirtme imkanı sunar. Olası seçenekler:

  • suppress_errors (sadece windows): Değer olarak TRUE belirtilirse bu işlev tarafından üretilen hatalar baskılanır.
  • bypass_shell (sadece windows): Değer olarak TRUE belirtilirse cmd.exe kabuğu es geçilir.
  • context: Dosyaları açarken kullanılan (stream_context_create() ile oluşturulmuş) akım bağlamı
  • binary_pipes: Borular, normal olarak stream_encoding() ile değil ikil kipte açılır.

Dönen Değerler

Süreci ifade eden bir özkaynak döner. Bu özkaynak ile işiniz bittiğinde proc_close() ile serbest bırakmalısınız. Hata durumunda işlev FALSE döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
6.0.0 | seçenekler değiştirgesinin olası seçeneklerine context ve binary_pipes seçenekleri eklendi.
5.2.1 | seçenekler değiştirgesinin olası seçeneklerine bypass_shell seçeneği eklendi.
5.0.0 | dizin, ortam ve seçenekler değiştirgeleri eklendi.

Örnekler

Örnek 1 - proc_open() örneği

<?php
$tanıtıcılar = array(
   0 => array("pipe", "r"),  // stdin, alt sürecin okuyacağı borudur
   1 => array("pipe", "w"),  // stdout, alt sürecin yazacağı borudur
   2 => array("file", "/tmp/hatalar", "a") // stderr çıktısı bu dosyaya yazılır
);

$dizin = '/tmp';
$ortam = array('bir_seçenek' => 'aeiou');

$süreç = proc_open('php', $tanıtıcılar, $borular, $dizin, $ortam);

if (is_resource($süreç)) {
    // $borular artık şöyledir:
    // 0 => alt sürecin std. girdisine yazmak için tanıtıcı
    // 1 => alt sürecin std. çıktısını okumak için tanıtıcı
    // Hata çıktıları varsa /tmp/hatalar dosyasına yazılacak

    fwrite($borular[0], '<?php print_r($_ENV); ?>');
    fclose($borular[0]);

    echo stream_get_contents($borular[1]);
    fclose($borular[1]);

    // Bir kısır döngü oluşmaması için proc_close işlevini
    // çağırmadan önce açık boruların kapatılması hayati önemdedir.
    $dönen_değer = proc_close($süreç);

    echo "komut $dönen_değer değerini döndürdü\n";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [bir_seçenek] => aeiou
    [PWD] => /tmp
    [SHLVL] => 1
    [_] => /usr/local/bin/php
)
komut 0 değerini döndürdü

Notlar

Bilginize: Windows uyumluluğu

2 (strerr) tanıtıcısı hariç, tanıtıcılar çocuk süreçlere kalıtım yoluyla aktarılırlar, fakat Windows mimarisi dosya tanıtıcılarını düşük seviyeli tanıtıcılarla ilişkilendirmediğinden çocuk süreç bu tanıtıcılara erişemez. stdin, stdout ve stderr beklendiği gibi çalışır.

Bilginize:

Eğer ihtiyacınız tek yönlü bir boru ise kullanımı daha kolay olan popen() işlevini kullanın.

Ayrıca Bakınız

  • popen() - Bir süreç tanıtıcısı açar
  • exec() - Bir komut çalıştırır
  • system() - Belirtilen harici komutu çalıştırır ve çıktısını gösterir
  • passthru() - Harici bir programı çalıştırır ve çıktısını ham olarak gösterir
  • stream_select() - Belirtilen akım dizisi üzerinde belirtilen zaman aşımı ile select() sistem çağrısının eşdeğeri olarak çalışır
  • Çalıştırma İşleci

proc_nice
proc_terminate
Program Çalıştırma İşlevleri


proc_open ile açılmış bir süreci öldürür

proc_open
shell_exec
Program Çalıştırma İşlevleri
PHP Manual

proc_terminate

(PHP 5, PHP 7)

proc_terminate — proc_open ile açılmış bir süreci öldürür

Açıklama

bool proc_terminate ( resource $süreç [, int $sinyal = 15 ] )

Belirtilen (proc_open() tarafından açılmış) sürece bir sinyal gönderir ve sürecin sonlanmasını beklemeden döner.

proc_terminate() bir süreci sonlandırmanızı ve sonucu beklemeden diğer işlemlere devam edebilmenizi sağlar. Sürecin sonlanıp sonlanmadığını proc_get_status() işlevini kullanarak yoklayabilirsiniz.

Değiştirgeler

süreç

proc_open() tarafından açılmış bir süreç özkaynağı.

sinyal

İsteğe bağlı bu değiştirge sadece POSIX sistemlerde kullanışlıdır. Bu sistemlerde bir süreci kill(2) sistem çağrısı ile öldürebilirsiniz. Değiştirgenin öntanımlı değeri SIGTERM'dir.

Dönen Değerler

Sürecin sonlanma durumu ile döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.2.2 | Önceki sürümler belirtilen süreç özkaynağını yok ederler.

Ayrıca Bakınız

  • proc_open() - Bir komutu çalıştırır ve G/Ç için bir dosya tanıtıcı açar
  • proc_close() - proc_open tarafından açılmış bir süreci kapatır ve sürecin çıkış kodunu döndürür
  • proc_get_status() - proc_open tarafından açılmış bir süreç hakkında bilgi döndürür

proc_open
shell_exec
Program Çalıştırma İşlevleri


Komutu kabukta çalıştırır ve çıktısının tamamını bir dizge olarak döndürür

proc_terminate
system
Program Çalıştırma İşlevleri
PHP Manual

shell_exec

(PHP 4, PHP 5, PHP 7)

shell_exec — Komutu kabukta çalıştırır ve çıktısının tamamını bir dizge olarak döndürür

Açıklama

string shell_exec ( string $komut )

Bu işlev çalıştırma işleci kullanmakla eşdeğerdir.

Değiştirgeler

komut

Çalıştırılacak komut.

Dönen Değerler

Çalıştırılan komutun çıktısı bir dizge olarak döner.

Örnekler

Örnek 1 - shell_exec() örneği

<?php
$çıktı = shell_exec('ls -lart');
echo "<pre>$çıktı</pre>";
?>

Notlar

Bilginize:

Bu işlev, PHP güvenli kipte çalışırken iptal edilir.

Ayrıca Bakınız

  • exec() - Bir komut çalıştırır
  • escapeshellcmd() - Kabuk meta karakterlerini önceler

proc_terminate
system
Program Çalıştırma İşlevleri


Belirtilen harici komutu çalıştırır ve çıktısını gösterir

shell_exec
pthreads
Program Çalıştırma İşlevleri
PHP Manual

system

(PHP 4, PHP 5, PHP 7)

system — Belirtilen harici komutu çalıştırır ve çıktısını gösterir

Açıklama

string system ( string $komut [, int &$dönüş_değeri ] )

system() işlevi C dilindeki adaşı gibi verilen komut'u çalıştırır ve sonucunu çıktılar.

PHP bir sunucu modülü olarak çalışırken, bu işlev her çıktı satırından sonra HTTP sunucusunun çıktı tamponunu boşaltmaya çalışır.

Bir komutu, çıktısı ortamla etkileşime girmeden çalıştırmak isterseniz passthru() işlevini kullanın.

Değiştirgeler

komut

Çalıştırılacak komut.

dönüş_değeri

Bu değiştirge belirtilmişse çalıştırılan komutun çıktısı bu değişkene yazılır.

Dönen Değerler

Başarısızlık durumunda FALSE aksi takdirde komut çıktısının son satırı döner.

Örnekler

Örnek 1 - system() örneği

<?php
echo '<pre>';

// "ls" kabuk komutunun sonucunu çıktılar ve
// çıktının son satırını $son_satır ile döndürürken,
// işlevin dönüş değerini $sonuç değişkenine kaydeder.
$son_satır = system('ls', $sonuç);

// Bilgileri basalım
echo '
</pre>
<hr />Çıktının son satırı: ' . $son_satır . '
<hr />Dönüş değeri: ' . $sonuç;
?>

Notlar

Uyarı

Kullanıcı kaynaklı verilerin bu işlev üzerinden aktarımına izin verecekseniz, kullanıcının bazı komutlar çalıştırarak sistemi kandıramaması için escapeshellarg() veya escapeshellcmd() işlevlerini kullanınız.

Bilginize:

Eğer bir uygulama bu işlevle başlatılmışsa uygulamanın artalanda çalışmasını sürdürebilmesi için uygulama çıktısı ya bir dosyaya ya da başka bir çıktı akımına yönlendirilmelidir. Aksi takdirde, uygulama sonlanana kadar PHP askıda kalacaktır.

Bilginize: Güvenli kip etkinken, dosyaları sadece safe_mode_exec_dir ile çalıştırabilirsiniz. Uygulamadan kaynaklanan sebeplerle çalıştırılabilirin dosya yolunda .. bileşenine şimdilik izin verilmemektedir.

Uyarı

güvenli kipin etkin kılınmasıyla, komut dizgesi escapeshellcmd() ile öncelenir. Böylece, echo y | echo x komut dizgesi echo y \| echo x haline gelir.

Ayrıca Bakınız

  • exec() - Bir komut çalıştırır
  • passthru() - Harici bir programı çalıştırır ve çıktısını ham olarak gösterir
  • popen() - Bir süreç tanıtıcısı açar
  • escapeshellcmd() - Kabuk meta karakterlerini önceler
  • pcntl_exec() - Belirtilen programı geçerli süreç ortamında çalıştırır
  • Çalıştırma İşleci

shell_exec
pthreads
Program Çalıştırma İşlevleri


pthreads

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
  • Öntanımlı Sabitler
  • Threaded — The Threaded class
    • Threaded::chunk — Manipulation
    • Threaded::count — Manipulation
    • Threaded::extend — Runtime Manipulation
    • Threaded::from — Creation
    • Threaded::getTerminationInfo — Error Detection
    • Threaded::isRunning — State Detection
    • Threaded::isTerminated — State Detection
    • Threaded::isWaiting — State Detection
    • Threaded::lock — Synchronization
    • Threaded::merge — Manipulation
    • Threaded::notify — Synchronization
    • Threaded::pop — Manipulation
    • Threaded::run — Execution
    • Threaded::shift — Manipulation
    • Threaded::synchronized — Synchronization
    • Threaded::unlock — Synchronization
    • Threaded::wait — Synchronization
  • Thread — The Thread class
    • Thread::detach — Execution
    • Thread::getCreatorId — Identification
    • Thread::getCurrentThread — Identification
    • Thread::getCurrentThreadId — Identification
    • Thread::getThreadId — Identification
    • Thread::globally — Execution
    • Thread::isJoined — State Detection
    • Thread::isStarted — State Detection
    • Thread::join — Synchronization
    • Thread::kill — Execution
    • Thread::start — Execution
  • Worker — The Worker class
    • Worker::collect — Collect references to completed tasks
    • Worker::getStacked — Gets the remaining stack size
    • Worker::isShutdown — State Detection
    • Worker::isWorking — State Detection
    • Worker::shutdown — Shutdown the worker
    • Worker::stack — Stacking work
    • Worker::unstack — Unstacking work
  • Collectable — The Collectable interface
    • Collectable::isGarbage — Determine whether an object has been marked as garbage
    • Collectable::setGarbage — Mark an object as garbage
  • Modifiers — Method Modifiers
  • Pool — The Pool class
    • Pool::collect — Collect references to completed tasks
    • Pool::__construct — Creates a new Pool of Workers
    • Pool::resize — Resize the Pool
    • Pool::shutdown — Shutdown all workers
    • Pool::submit — Submits an object for execution
    • Pool::submitTo — Submits a task to a specific worker for execution
  • Mutex — The Mutex class
    • Mutex::create — Create a Mutex
    • Mutex::destroy — Destroy Mutex
    • Mutex::lock — Acquire Mutex
    • Mutex::trylock — Attempt to Acquire Mutex
    • Mutex::unlock — Release Mutex
  • Cond — The Cond class
    • Cond::broadcast — Broadcast a Condition
    • Cond::create — Create a Condition
    • Cond::destroy — Destroy a Condition
    • Cond::signal — Signal a Condition
    • Cond::wait — Wait for Condition
system
Giriş
Süreç Denetim Eklentileri


Giriş

pthreads is an object-orientated API that provides all of the tools needed for multi-threading in PHP. PHP applications can create, read, write, execute and synchronize with Threads, Workers and Threaded objects.

Uyarı

The pthreads extension cannot be used in a web server environment. Threading in PHP should therefore remain to CLI-based applications only.

The Threaded class forms the basis of the functionality that allows pthreads to operate. It exposes synchronization methods and some useful interfaces for the programmer.

The Thread class enables for threads to be created by simply extending it and implementing a run method. Any members can be written to and read by any context with a reference to the thread. Any context can also execute any public and protected methods. The body of the run method will be executed in a separate thread when the Thread::start() method of the implementation is called from the context that created it. Only the context that creates a thread can start and join it.

The Worker class has a persistent state, and will be available from the call to Thread::start() (an inherited method) until the object goes out of scope, or is explicitly shutdown (via Worker::shutdown()). Any context with a reference to the worker object can stack tasks onto the Worker (via Worker::stack()), where these tasks will be executed by the worker in a separate thread. The run method of a worker object will be executed before any objects on the worker's stack, enabling for resources to be initialized that the objects to be executed may need.

The Pool class is used to create a group of workers to distribute Threaded objects amongst them. It is the easiest and most efficient way of using multiple threads in PHP applications.

Dikkat

The Pool class does not extend the Threaded class, and so pool-based objects are considered a normal PHP objects. As such, its instances of it should not be shared amongst different contexts.

The Volatile class is new to pthreads v3. It is used to denote mutable Threaded properties of Threaded classes (since these are now immutable by default).

Synchronization is an important ability when threading. All of the objects that pthreads creates have built in synchronization in the (which will be familiar to java programmers) form of Threaded::wait() and Threaded::notify(). Calling Threaded::wait() on an object will cause the context to wait for another context to call Threaded::notify() on the same object. This mechanism allows for powerful synchronization between Threaded objects in PHP.

Dikkat

Any objects that are intended for use in the multi-threaded parts of your application should extend Threaded.

Method Modifiers: The protected methods of Threaded Objects are protected by pthreads, such that only one context may call that method at a time. The private methods of Threaded Objects can only be called from within the Threaded Object during execution.

Data Storage: As a rule of thumb, any data type that can be serialized can be used as a member of a Threaded object, it can be read and written from any context with a reference to the Threaded Object. Not every type of data is stored serially, basic types are stored in their true form. Complex types, Arrays, and Objects that are not Threaded are stored serially; they can be read and written to the Threaded Object from any context with a reference. With the exception of Threaded Objects any reference used to set a member of a Threaded Object is separated from the reference in the Threaded Object; the same data can be read directly from the Threaded Object at any time by any context with a reference to the Threaded Object.

Static Members: When a new context is created ( Thread or Worker ), they are generally copied, but resources and objects with internal state are nullified (for safety reasons). This allows them to function as a kind of thread local storage. For example, upon starting the context, a class whose static members include connection information for a database server, and the connection itself, will only have the simple connection information copied, not the connection. Allowing the new context to initiate a connection in the same way as the context that created it, storing the connection in the same place without affecting the original context.

Dikkat

When print_r, var_dump and other object debug functions are executed, they do not include recursion protection.

Bilginize:

Resources: The extensions and functionality that define resources in PHP are completely unprepared for this kind of environment; pthreads makes provisions for Resources to be shared among contexts, however, for most types of resource it should be considered unsafe. Extreme caution and care should be used when sharing resources among contexts.

Dikkat

In the environment which pthreads executes, some restrictions and limitations are necessary in order to provide a stable environment.

pthreads
Yapılandırma/Kurulum
pthreads


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
Giriş
Gereksinimler
pthreads


Gereksinimler

pthreads requires a build of PHP with ZTS (Zend Thread Safety) enabled ( --enable-maintainer-zts or --enable-zts on Windows )

Dikkat

Zend Thread Safety cannot be enabled post build; it is a build time configuration option.

pthreads should build anywhere there is a working Posix Threads header (pthread.h) and ZTS build of PHP, including Windows (using the pthread-w32 project from redhat).

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

pthreads releases are hosted by PECL and the source code by » github, the easiest route to installation is the normal PECL route: » http://pecl.php.net/package/pthreads.

Windows users can download prebuilt release binaries from the » PECL website.

Dikkat

Windows users need to take the additional step of adding pthreadVC2.dll (distributed with Windows releases) to their PATH.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

PTHREADS_INHERIT_ALL (integer)
The default options for all Threads, causes pthreads to copy the environment when new Threads are started
PTHREADS_INHERIT_NONE (integer)
Do not inherit anything when new Threads are started
PTHREADS_INHERIT_INI (integer)
Inherit INI entries when new Threads are started
PTHREADS_INHERIT_CONSTANTS (integer)
Inherit user declared constants when new Threads are started
PTHREADS_INHERIT_CLASSES (integer)
Inherit user declared classes when new Threads are started
PTHREADS_INHERIT_FUNCTIONS (integer)
Inherit user declared functions when new Threads are started
PTHREADS_INHERIT_INCLUDES (integer)
Inherit included file information when new Threads are started
PTHREADS_INHERIT_COMMENTS (integer)
Inherit all comments when new Threads are started
PTHREADS_ALLOW_HEADERS (integer)
Allow new Threads to send headers to standard output (normally prohibited)

Çalışma Anı Yapılandırması
Threaded
pthreads


The Threaded class

(PECL pthreads >= 2.0.0)

Giriş

Threaded objects form the basis of pthreads ability to execute user code in parallel; they expose synchronization methods and various useful interfaces.

Threaded objects, most importantly, provide implicit safety for the programmer; all operations on the object scope are safe.

Sınıf Sözdizimi

Threaded implements Traversable , Countable , ArrayAccess {
/* Yöntemler */
public array chunk ( integer $size , boolean $preserve )
public integer count ( void )
public bool extend ( string $class )
public Threaded from ( Closure $run [, Closure $construct [, array $args ]] )
public array getTerminationInfo ( void )
public boolean isRunning ( void )
public boolean isTerminated ( void )
public boolean isWaiting ( void )
public boolean lock ( void )
public boolean merge ( mixed $from [, bool $overwrite ] )
public boolean notify ( void )
public boolean pop ( void )
public void run ( void )
public mixed shift ( void )
public mixed synchronized ( Closure $block [, mixed $... ] )
public boolean unlock ( void )
public boolean wait ([ integer $timeout ] )
}

İçindekiler

  • Threaded::chunk — Manipulation
  • Threaded::count — Manipulation
  • Threaded::extend — Runtime Manipulation
  • Threaded::from — Creation
  • Threaded::getTerminationInfo — Error Detection
  • Threaded::isRunning — State Detection
  • Threaded::isTerminated — State Detection
  • Threaded::isWaiting — State Detection
  • Threaded::lock — Synchronization
  • Threaded::merge — Manipulation
  • Threaded::notify — Synchronization
  • Threaded::pop — Manipulation
  • Threaded::run — Execution
  • Threaded::shift — Manipulation
  • Threaded::synchronized — Synchronization
  • Threaded::unlock — Synchronization
  • Threaded::wait — Synchronization
Öntanımlı Sabitler
Threaded::chunk
pthreads


Manipulation

Threaded
Threaded::count
Threaded
PHP Manual

Threaded::chunk

(PECL pthreads >= 2.0.0)

Threaded::chunk — Manipulation

Açıklama

public array Threaded::chunk ( integer $size , boolean $preserve )

Fetches a chunk of the objects property table of the given size, optionally preserving keys

Değiştirgeler

size

The number of items to fetch

preserve

Preserve the keys of members, by default false

Dönen Değerler

An array of items from the objects property table

Örnekler

Örnek 1 Fetch a chunk of the property table

<?php
$safe = new Threaded();

while (count($safe) < 10) {
    $safe[] = count($safe);
}

var_dump($safe->chunk(5));
?>

Yukarıdaki örneğin çıktısı:

array(5) {
  [0]=>
  int(0)
  [1]=>
  int(1)
  [2]=>
  int(2)
  [3]=>
  int(3)
  [4]=>
  int(4)
}

Threaded
Threaded::count
Threaded


Manipulation

Threaded::chunk
Threaded::extend
Threaded
PHP Manual

Threaded::count

(PECL pthreads >= 2.0.0)

Threaded::count — Manipulation

Açıklama

public integer Threaded::count ( void )

Returns the number of properties for this object

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Örnekler

Örnek 1 Counting the properties of an object

<?php
$safe = new Threaded();

while (count($safe) < 10) {
    $safe[] = count($safe);
}

var_dump(count($safe));
?>

Yukarıdaki örneğin çıktısı:

int(10)

Threaded::chunk
Threaded::extend
Threaded


Runtime Manipulation

Threaded::count
Threaded::from
Threaded
PHP Manual

Threaded::extend

(PECL pthreads >= 2.0.8)

Threaded::extend — Runtime Manipulation

Açıklama

public bool Threaded::extend ( string $class )

Makes thread safe standard class at runtime

Değiştirgeler

class

The class to extend

Dönen Değerler

A boolean indication of success

Örnekler

Örnek 1 Runtime inheritance

<?php
class My {}

Threaded::extend(My::class);

$my = new My();

var_dump($my instanceof Threaded);
?>

Yukarıdaki örneğin çıktısı:

bool(true)

Threaded::count
Threaded::from
Threaded


Creation

Threaded::extend
Threaded::getTerminationInfo
Threaded
PHP Manual

Threaded::from

(PECL pthreads >= 2.0.9)

Threaded::from — Creation

Uyarı

This method has been removed in pthreads v3.

Açıklama

public Threaded Threaded::from ( Closure $run [, Closure $construct [, array $args ]] )

Creates an anonymous Threaded object from closures

Değiştirgeler

run

The closure to use for ::run

construct

The constructor to use for anonymous object

args

The arguments to pass to constructor

Dönen Değerler

A new anonymous Threaded object

Örnekler

Örnek 1 Thread safe objects from closures

<?php
$pool = new Pool(4);
$pool->submit(Collectable::from(function(){
    echo "Hello World";
    $this->setGarbage();
}));
/* ... */
$pool->shutdown();
?>

Yukarıdaki örneğin çıktısı:

Hello World

Threaded::extend
Threaded::getTerminationInfo
Threaded


Error Detection

Threaded::from
Threaded::isRunning
Threaded
PHP Manual

Threaded::getTerminationInfo

(PECL pthreads < 3.0.0)

Threaded::getTerminationInfo — Error Detection

Uyarı

This method has been removed in pthreads v3.

Açıklama

public array Threaded::getTerminationInfo ( void )

Retrieves terminal error information from the referenced object

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

array containing the termination conditions of the referenced object

Örnekler

Örnek 1 Detecting fatal errors in Threads

<?php
class My extends Thread {
    public function run() {
        @not_found();
    }
}

$my = new My();
$my->start();
$my->join();

var_dump($my->isTerminated(), $my->getTerminationInfo());
?>

Yukarıdaki örneğin çıktısı:

bool(true)
array(4) {
  ["scope"]=>
  string(2) "My"
  ["function"]=>
  string(3) "run"
  ["file"]=>
  string(29) "/usr/src/pthreads/sandbox.php"
  ["line"]=>
  int(4)
}

Threaded::from
Threaded::isRunning
Threaded


State Detection

Threaded::getTerminationInfo
Threaded::isTerminated
Threaded
PHP Manual

Threaded::isRunning

(PECL pthreads >= 2.0.0)

Threaded::isRunning — State Detection

Açıklama

public boolean Threaded::isRunning ( void )

Tell if the referenced object is executing

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A boolean indication of state

Bilginize:

A object is considered running while executing the run method

Örnekler

Örnek 1 Detect the state of the referenced object

<?php
class My extends Thread {
    public function run() {
        $this->synchronized(function($thread){
            if (!$thread->done)
                $thread->wait();
        }, $this);
    }
}
$my = new My();
$my->start();
var_dump($my->isRunning());
$my->synchronized(function($thread){
    $thread->done = true;
    $thread->notify();
}, $my);
?>

Yukarıdaki örneğin çıktısı:

bool(true)

Threaded::getTerminationInfo
Threaded::isTerminated
Threaded


State Detection

Threaded::isRunning
Threaded::isWaiting
Threaded
PHP Manual

Threaded::isTerminated

(PECL pthreads >= 2.0.0)

Threaded::isTerminated — State Detection

Açıklama

public boolean Threaded::isTerminated ( void )

Tell if the referenced object was terminated during execution; suffered fatal errors, or threw uncaught exceptions

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A boolean indication of state

Örnekler

Örnek 1 Detect the state of the referenced object

<?php
class My extends Thread {
    public function run() {
        i_do_not_exist();
    }
}
$my = new My();
$my->start();
$my->join();
var_dump($my->isTerminated());
?>

Yukarıdaki örneğin çıktısı:

bool(true)

Threaded::isRunning
Threaded::isWaiting
Threaded


State Detection

Threaded::isTerminated
Threaded::lock
Threaded
PHP Manual

Threaded::isWaiting

(PECL pthreads < 3.0.0)

Threaded::isWaiting — State Detection

Uyarı

This method has been removed in pthreads v3.

Açıklama

public boolean Threaded::isWaiting ( void )

Tell if the referenced object is waiting for notification

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A boolean indication of state

Örnekler

Örnek 1 Detect the state of the referenced object

<?php
class My extends Thread {
    public function run() {
        $this->synchronized(function($thread){
            if (!$this->done)
                $thread->wait();
        }, $this);
    }

    protected $done;
}
$my = new My();
$my->start();
$my->synchronized(function($thread){
    var_dump(
        $thread->isWaiting());
    $thread->done = true;
    $thread->notify();
}, $my);
?>

Yukarıdaki örneğin çıktısı:

bool(true)

Threaded::isTerminated
Threaded::lock
Threaded


Synchronization

Threaded::isWaiting
Threaded::merge
Threaded
PHP Manual

Threaded::lock

(PECL pthreads < 3.0.0)

Threaded::lock — Synchronization

Uyarı

This method has been removed in pthreads v3.

Açıklama

public boolean Threaded::lock ( void )

Lock the referenced objects property table

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A boolean indication of success

Örnekler

Örnek 1 Locking Object Properties

<?php
class My extends Thread {
    public function run() {
        var_dump($this->lock());
        /** nobody can read or write **/
        var_dump($this->unlock());
        /** reading / writing resumed for all other contexts */
    }
}
$my = new My();
$my->start();
?>

Yukarıdaki örneğin çıktısı:

bool(true)
bool(true)

Threaded::isWaiting
Threaded::merge
Threaded


Manipulation

Threaded::lock
Threaded::notify
Threaded
PHP Manual

Threaded::merge

(PECL pthreads >= 2.0.0)

Threaded::merge — Manipulation

Açıklama

public boolean Threaded::merge ( mixed $from [, bool $overwrite ] )

Merges data into the current object

Değiştirgeler

from

The data to merge

overwrite

Overwrite existing keys, by default true

Dönen Değerler

A boolean indication of success

Örnekler

Örnek 1 Merging into the property table of a threaded object

<?php
$array = [];

while (count($array) < 10)
    $array[] = count($array);

$stdClass = new stdClass();
$stdClass->foo = "foo";
$stdClass->bar = "bar";
$stdClass->baz = "baz";

$safe = new Threaded();
$safe->merge($array);

$safe->foo = "bar";
$safe->merge($stdClass, false);

var_dump($safe);
?>

Yukarıdaki örneğin çıktısı:

object(Threaded)#2 (13) {
  ["0"]=>
  int(0)
  ["1"]=>
  int(1)
  ["2"]=>
  int(2)
  ["3"]=>
  int(3)
  ["4"]=>
  int(4)
  ["5"]=>
  int(5)
  ["6"]=>
  int(6)
  ["7"]=>
  int(7)
  ["8"]=>
  int(8)
  ["9"]=>
  int(9)
  ["foo"]=>
  string(3) "bar"
  ["bar"]=>
  string(3) "bar"
  ["baz"]=>
  string(3) "baz"
}

Threaded::lock
Threaded::notify
Threaded


Synchronization

Threaded::merge
Threaded::pop
Threaded
PHP Manual

Threaded::notify

(PECL pthreads >= 2.0.0)

Threaded::notify — Synchronization

Açıklama

public boolean Threaded::notify ( void )

Send notification to the referenced object

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A boolean indication of success

Örnekler

Örnek 1 Notifications and Waiting

<?php
class My extends Thread {
    public function run() {
        /** cause this thread to wait **/
        $this->synchronized(function($thread){
            if (!$thread->done)
                $thread->wait();
        }, $this);
    }
}
$my = new My();
$my->start();
/** send notification to the waiting thread **/
$my->synchronized(function($thread){
    $thread->done = true;
    $thread->notify();
}, $my);
var_dump($my->join());
?>

Yukarıdaki örneğin çıktısı:

bool(true)

Threaded::merge
Threaded::pop
Threaded


Manipulation

Threaded::notify
Threaded::run
Threaded
PHP Manual

Threaded::pop

(PECL pthreads >= 2.0.0)

Threaded::pop — Manipulation

Açıklama

public boolean Threaded::pop ( void )

Pops an item from the objects property table

Dönen Değerler

The last item from the objects property table

Örnekler

Örnek 1 Popping the last item from the property table of a threaded object

<?php
$safe = new Threaded();

while (count($safe) < 10)
    $safe[] = count($safe);

var_dump($safe->pop());
?>

Yukarıdaki örneğin çıktısı:

int(9)

Threaded::notify
Threaded::run
Threaded


Execution

Threaded::pop
Threaded::shift
Threaded
PHP Manual

Threaded::run

(PECL pthreads >= 2.0.0)

Threaded::run — Execution

Açıklama

public void Threaded::run ( void )

The programmer should always implement the run method for objects that are intended for execution.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The methods return value, if used, will be ignored

Threaded::pop
Threaded::shift
Threaded


Manipulation

Threaded::run
Threaded::synchronized
Threaded
PHP Manual

Threaded::shift

(PECL pthreads >= 2.0.0)

Threaded::shift — Manipulation

Açıklama

public mixed Threaded::shift ( void )

Shifts an item from the objects property table

Dönen Değerler

The first item from the objects property table

Örnekler

Örnek 1 Shifting the first item from the property table of a threaded object

<?php
$safe = new Threaded();

while (count($safe) < 10)
    $safe[] = count($safe);

var_dump($safe->shift());
?>

Yukarıdaki örneğin çıktısı:

int(0)

Threaded::run
Threaded::synchronized
Threaded


Synchronization

Threaded::shift
Threaded::unlock
Threaded
PHP Manual

Threaded::synchronized

(PECL pthreads >= 2.0.0)

Threaded::synchronized — Synchronization

Açıklama

public mixed Threaded::synchronized ( Closure $block [, mixed $... ] )

Executes the block while retaining the referenced objects synchronization lock for the calling context

Değiştirgeler

block

The block of code to execute

...

Variable length list of arguments to use as function arguments to the block

Dönen Değerler

The return value from the block

Örnekler

Örnek 1 Synchronizing

<?php
class My extends Thread {
    public function run() {
        $this->synchronized(function($thread){
            if (!$thread->done)
                $thread->wait();
        }, $this);
    }
}
$my = new My();
$my->start();
$my->synchronized(function($thread){
    $thread->done = true;
    $thread->notify();
}, $my);
var_dump($my->join());
?>

Yukarıdaki örneğin çıktısı:

bool(true)

Threaded::shift
Threaded::unlock
Threaded


Synchronization

Threaded::synchronized
Threaded::wait
Threaded
PHP Manual

Threaded::unlock

(PECL pthreads < 3.0.0)

Threaded::unlock — Synchronization

Uyarı

This method has been removed in pthreads v3.

Açıklama

public boolean Threaded::unlock ( void )

Unlock the referenced objects storage for the calling context

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A boolean indication of success

Örnekler

Örnek 1 Locking the property table of a threaded object

<?php
class My extends Thread {
    public function run() {
        var_dump($this->lock());
        /** nobody can read or write **/
        var_dump($this->unlock());
        /** reading / writing resumed for all other contexts */
    }
}
$my = new My();
$my->start();
?>

Yukarıdaki örneğin çıktısı:

bool(true)
bool(true)

Threaded::synchronized
Threaded::wait
Threaded


Synchronization

Threaded::unlock
Thread
Threaded
PHP Manual

Threaded::wait

(PECL pthreads >= 2.0.0)

Threaded::wait — Synchronization

Açıklama

public boolean Threaded::wait ([ integer $timeout ] )

Will cause the calling context to wait for notification from the referenced object

Değiştirgeler

timeout

An optional timeout in microseconds

Dönen Değerler

A boolean indication of success

Örnekler

Örnek 1 Notifications and Waiting

<?php
class My extends Thread {
    public function run() {
        /** cause this thread to wait **/
        $this->synchronized(function($thread){
            if (!$thread->done)
                $thread->wait();
        }, $this);
    }
}
$my = new My();
$my->start();
/** send notification to the waiting thread **/
$my->synchronized(function($thread){
    $thread->done = true;
    $thread->notify();
}, $my);
var_dump($my->join());
?>

Yukarıdaki örneğin çıktısı:

bool(true)

Threaded::unlock
Thread
Threaded


The Thread class

(PECL pthreads >= 2.0.0)

Giriş

When the start method of a Thread is invoked, the run method code will be executed in separate Thread, in parallel.

After the run method is executed the Thread will exit immediately, it will be joined with the creating Thread at the appropriate time.

Uyarı

Relying on the engine to determine when a Thread should join may cause undesirable behaviour; the programmer should be explicit, where possible.

Sınıf Sözdizimi

Thread extends Threaded implements Countable , Traversable , ArrayAccess {
/* Yöntemler */
public void detach ( void )
public integer getCreatorId ( void )
public static Thread getCurrentThread ( void )
public static integer getCurrentThreadId ( void )
public integer getThreadId ( void )
public static mixed globally ( void )
public boolean isJoined ( void )
public boolean isStarted ( void )
public boolean join ( void )
public void kill ( void )
public boolean start ([ integer $options ] )
/* Miras alınan yöntemler */
public array Threaded::chunk ( integer $size , boolean $preserve )
public integer Threaded::count ( void )
public bool Threaded::extend ( string $class )
public Threaded Threaded::from ( Closure $run [, Closure $construct [, array $args ]] )
public array Threaded::getTerminationInfo ( void )
public boolean Threaded::isRunning ( void )
public boolean Threaded::isTerminated ( void )
public boolean Threaded::isWaiting ( void )
public boolean Threaded::lock ( void )
public boolean Threaded::merge ( mixed $from [, bool $overwrite ] )
public boolean Threaded::notify ( void )
public boolean Threaded::pop ( void )
public void Threaded::run ( void )
public mixed Threaded::shift ( void )
public mixed Threaded::synchronized ( Closure $block [, mixed $... ] )
public boolean Threaded::unlock ( void )
public boolean Threaded::wait ([ integer $timeout ] )
}

İçindekiler

  • Thread::detach — Execution
  • Thread::getCreatorId — Identification
  • Thread::getCurrentThread — Identification
  • Thread::getCurrentThreadId — Identification
  • Thread::getThreadId — Identification
  • Thread::globally — Execution
  • Thread::isJoined — State Detection
  • Thread::isStarted — State Detection
  • Thread::join — Synchronization
  • Thread::kill — Execution
  • Thread::start — Execution
Threaded::wait
Thread::detach
pthreads


Execution

Thread
Thread::getCreatorId
Thread
PHP Manual

Thread::detach

(PECL pthreads < 3.0.0)

Thread::detach — Execution

Uyarı

This method has been removed in pthreads v3.

Açıklama

public void Thread::detach ( void )

Detaches the referenced Thread from the calling context, dangerous!

Uyarı

This method can cause undefined, unsafe behaviour. It should not usually be used, it is present for completeness and advanced use cases.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Thread
Thread::getCreatorId
Thread


Identification

Thread::detach
Thread::getCurrentThread
Thread
PHP Manual

Thread::getCreatorId

(PECL pthreads >= 2.0.0)

Thread::getCreatorId — Identification

Açıklama

public integer Thread::getCreatorId ( void )

Will return the identity of the Thread that created the referenced Thread

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A numeric identity

Örnekler

Örnek 1 Return the identity of the Thread or Process that created the referenced Thread

<?php
class My extends Thread {
    public function run() {
        printf("%s created by Thread #%lu\n", __CLASS__, $this->getCreatorId());
    }
}
$my = new My();
$my->start();
?>

Yukarıdaki örneğin çıktısı:

My created by Thread #123456778899

Thread::detach
Thread::getCurrentThread
Thread


Identification

Thread::getCreatorId
Thread::getCurrentThreadId
Thread
PHP Manual

Thread::getCurrentThread

(PECL pthreads >= 2.0.0)

Thread::getCurrentThread — Identification

Açıklama

public static Thread Thread::getCurrentThread ( void )

Return a reference to the currently executing Thread

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

An object representing the currently executing Thread

Örnekler

Örnek 1 Return the currently executing Thread

<?php
class My extends Thread {
    public function run() {
        var_dump(Thread::getCurrentThread());
    }
}
$my = new My();
$my->start();
?>

Yukarıdaki örneğin çıktısı:

object(My)#2 (0) {
}

Thread::getCreatorId
Thread::getCurrentThreadId
Thread


Identification

Thread::getCurrentThread
Thread::getThreadId
Thread
PHP Manual

Thread::getCurrentThreadId

(PECL pthreads >= 2.0.0)

Thread::getCurrentThreadId — Identification

Açıklama

public static integer Thread::getCurrentThreadId ( void )

Will return the identity of the currently executing Thread

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A numeric identity

Örnekler

Örnek 1 Return the identity of the currently executing Thread

<?php
class My extends Thread {
    public function run() {
        printf("%s is Thread #%lu\n", __CLASS__, Thread::getCurrentThreadId());
    }
}
$my = new My();
$my->start();
?>

Yukarıdaki örneğin çıktısı:

My is Thread #123456778899

Thread::getCurrentThread
Thread::getThreadId
Thread


Identification

Thread::getCurrentThreadId
Thread::globally
Thread
PHP Manual

Thread::getThreadId

(PECL pthreads >= 2.0.0)

Thread::getThreadId — Identification

Açıklama

public integer Thread::getThreadId ( void )

Will return the identity of the referenced Thread

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A numeric identity

Örnekler

Örnek 1 Return the identity of the referenced Thread

<?php
class My extends Thread {
    public function run() {
        printf("%s is Thread #%lu\n", __CLASS__, $this->getThreadId());
    }
}
$my = new My();
$my->start();
?>

Yukarıdaki örneğin çıktısı:

My is Thread #123456778899

Thread::getCurrentThreadId
Thread::globally
Thread


Execution

Thread::getThreadId
Thread::isJoined
Thread
PHP Manual

Thread::globally

(PECL pthreads < 3.0.0)

Thread::globally — Execution

Uyarı

This method has been removed in pthreads v3.

Açıklama

public static mixed Thread::globally ( void )

Will execute a Callable in the global scope

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The return value of the Callable

Örnekler

Örnek 1 Execute in the global scope

<?php
class My extends Thread {
    public function run() {
        global $std;

        Thread::globally(function(){
            $std = new stdClass;
        });

        var_dump($std);
    }
}
$my = new My();
$my->start();
?>

Yukarıdaki örneğin çıktısı:

object(stdClass)#3 (0) {
}

Thread::getThreadId
Thread::isJoined
Thread


State Detection

Thread::globally
Thread::isStarted
Thread
PHP Manual

Thread::isJoined

(PECL pthreads >= 2.0.0)

Thread::isJoined — State Detection

Açıklama

public boolean Thread::isJoined ( void )

Tell if the referenced Thread has been joined

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A boolean indication of state

Örnekler

Örnek 1 Detect the state of the referenced Thread

<?php
class My extends Thread {
    public function run() {
        $this->synchronized(function($thread){
            if (!$thread->done)
                $thread->wait();
        }, $this);
    }
}
$my = new My();
$my->start();
var_dump($my->isJoined());
$my->synchronized(function($thread){
    $thread->done = true;
    $thread->notify();
}, $my);
?>

Yukarıdaki örneğin çıktısı:

bool(false)

Thread::globally
Thread::isStarted
Thread


State Detection

Thread::isJoined
Thread::join
Thread
PHP Manual

Thread::isStarted

(PECL pthreads >= 2.0.0)

Thread::isStarted — State Detection

Açıklama

public boolean Thread::isStarted ( void )

Tell if the referenced Thread was started

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

boolean indication of state

Örnekler

Örnek 1 Tell if the referenced Thread was started

<?php
$worker = new Worker();
$worker->start();
var_dump($worker->isStarted());
?>

Yukarıdaki örneğin çıktısı:

bool(true)

Thread::isJoined
Thread::join
Thread


Synchronization

Thread::isStarted
Thread::kill
Thread
PHP Manual

Thread::join

(PECL pthreads >= 2.0.0)

Thread::join — Synchronization

Açıklama

public boolean Thread::join ( void )

Causes the calling context to wait for the referenced Thread to finish executing

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A boolean indication of success

Örnekler

Örnek 1 Join with the referenced Thread

<?php
class My extends Thread {
    public function run() {
        /* ... */
    }
}
$my = new My();
$my->start();
/* ... */
var_dump($my->join());
/* ... */
?>

Yukarıdaki örneğin çıktısı:

bool(true)

Thread::isStarted
Thread::kill
Thread


Execution

Thread::join
Thread::start
Thread
PHP Manual

Thread::kill

(PECL pthreads < 3.0.0)

Thread::kill — Execution

Uyarı

This method has been removed in pthreads v3.

Açıklama

public void Thread::kill ( void )

Forces the referenced Thread to terminate

Uyarı

The programmer should not ordinarily kill Threads by force

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A boolean indication of success

Örnekler

Örnek 1 Kill the referenced Thread

<?php
class T extends Thread {
    public function run() {
        $stdin = fopen("php://stdin", "r");
        while(($line = fgets($stdin))) {
            echo $line;
        }
    }
}

$t = new T();
$t->start();

var_dump($t->kill());
?>

Yukarıdaki örneğin çıktısı:

bool(true)

Thread::join
Thread::start
Thread


Execution

Thread::kill
Worker
Thread
PHP Manual

Thread::start

(PECL pthreads >= 2.0.0)

Thread::start — Execution

Açıklama

public boolean Thread::start ([ integer $options ] )

Will start a new Thread to execute the implemented run method

Değiştirgeler

options

An optional mask of inheritance constants, by default PTHREADS_INHERIT_ALL

Dönen Değerler

A boolean indication of success

Örnekler

Örnek 1 Starting Threads

<?php
class My extends Thread {
    public function run() {
        /** ... **/
    }
}
$my = new My();
var_dump($my->start());
?>

Yukarıdaki örneğin çıktısı:

bool(true)

Thread::kill
Worker
Thread


The Worker class

(PECL pthreads >= 2.0.0)

Giriş

Worker Threads have a persistent context, as such should be used over Threads in most cases.

When a Worker is started, the run method will be executed, but the Thread will not leave until one of the following conditions are met:

  • the Worker goes out of scope (no more references remain)

  • the programmer calls shutdown

  • the script dies

This means the programmer can reuse the context throughout execution; placing objects on the stack of the Worker will cause the Worker to execute the stacked objects run method.

Uyarı

The programmer must retain references to stacked objects until they are executed or unstacked; the Pool class provides a higher level abstraction of the Worker functionality and manages references for the programmer.

Sınıf Sözdizimi

Worker extends Thread implements Traversable , Countable , ArrayAccess {
/* Yöntemler */
public int collect ([ Callable $collector ] )
public int getStacked ( void )
public bool isShutdown ( void )
public boolean isWorking ( void )
public bool shutdown ( void )
public int stack ( Threaded &$work )
public int unstack ( void )
/* Miras alınan yöntemler */
public void Thread::detach ( void )
public integer Thread::getCreatorId ( void )
public static Thread Thread::getCurrentThread ( void )
public static integer Thread::getCurrentThreadId ( void )
public integer Thread::getThreadId ( void )
public static mixed Thread::globally ( void )
public boolean Thread::isJoined ( void )
public boolean Thread::isStarted ( void )
public boolean Thread::join ( void )
public void Thread::kill ( void )
public boolean Thread::start ([ integer $options ] )
}

İçindekiler

  • Worker::collect — Collect references to completed tasks
  • Worker::getStacked — Gets the remaining stack size
  • Worker::isShutdown — State Detection
  • Worker::isWorking — State Detection
  • Worker::shutdown — Shutdown the worker
  • Worker::stack — Stacking work
  • Worker::unstack — Unstacking work
Thread::start
Worker::collect
pthreads


Collect references to completed tasks

Worker
Worker::getStacked
Worker
PHP Manual

Worker::collect

(PECL pthreads >= 3.0.0)

Worker::collect — Collect references to completed tasks

Açıklama

public int Worker::collect ([ Callable $collector ] )

Allows the worker to collect references determined to be garbage by the optionally given collector.

Değiştirgeler

collector

A Callable collector that returns a boolean on whether the task can be collected or not. Only in rare cases should a custom collector need to be used.

Dönen Değerler

The number of remaining tasks on the worker's stack to be collected.

Örnekler

Örnek 1 A basic example of Worker::collect()

<?php
$worker = new Worker();

echo "There are currently {$worker->collect()} tasks on the stack to be collected\n";

for ($i = 0; $i < 15; ++$i) {
    $worker->stack(new class extends Threaded {});
}

echo "There are {$worker->collect()} tasks remaining on the stack to be collected\n";

$worker->start();

while ($worker->collect()); // blocks until all tasks have finished executing

echo "There are now {$worker->collect()} tasks on the stack to be collected\n";

$worker->shutdown();

Yukarıdaki örneğin çıktısı:

There are currently 0 tasks on the stack to be collected
There are 15 tasks remaining on the stack to be collected
There are now 0 tasks on the stack to be collected

Worker
Worker::getStacked
Worker


Gets the remaining stack size

Worker::collect
Worker::isShutdown
Worker
PHP Manual

Worker::getStacked

(PECL pthreads >= 2.0.0)

Worker::getStacked — Gets the remaining stack size

Açıklama

public int Worker::getStacked ( void )

Returns the number of tasks left on the stack

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the number of tasks currently waiting to be executed by the worker

Örnekler

Örnek 1 A basic example of Worker::getStacked

<?php
$worker = new Worker();

for ($i = 0; $i < 5; ++$i) {
    $worker->stack(new class extends Threaded {});
}

echo "There are {$worker->getStacked()} stacked tasks\n";

Yukarıdaki örneğin çıktısı:

There are 5 stacked tasks

Worker::collect
Worker::isShutdown
Worker


State Detection

Worker::getStacked
Worker::isWorking
Worker
PHP Manual

Worker::isShutdown

(PECL pthreads >= 2.0.0)

Worker::isShutdown — State Detection

Açıklama

public bool Worker::isShutdown ( void )

Whether the worker has been shutdown or not.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns whether the worker has been shutdown or not.

Örnekler

Örnek 1 Detect the state of a worker

<?php
$worker = new Worker();
$worker->start();

var_dump($worker->isShutdown());

$worker->shutdown();

var_dump($worker->isShutdown());

Yukarıdaki örneğin çıktısı:

bool(false)
bool(true)

Worker::getStacked
Worker::isWorking
Worker


State Detection

Worker::isShutdown
Worker::shutdown
Worker
PHP Manual

Worker::isWorking

(PECL pthreads >= 2.0.0)

Worker::isWorking — State Detection

Uyarı

This method has been removed in pthreads v3. The Worker::getStacked() method should be used to see if the worker still has tasks to execute.

Açıklama

public boolean Worker::isWorking ( void )

Tell if a Worker is executing Stackables

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A boolean indication of state

Örnekler

Örnek 1 Detect the state of a Worker

<?php
$my = new Worker();
$my->start();
/* ... */
if ($my->isWorking()) {
    /* ... the Worker is busy executing another object */
}
?>

Worker::isShutdown
Worker::shutdown
Worker


Shutdown the worker

Worker::isWorking
Worker::stack
Worker
PHP Manual

Worker::shutdown

(PECL pthreads >= 2.0.0)

Worker::shutdown — Shutdown the worker

Açıklama

public bool Worker::shutdown ( void )

Shuts down the worker after executing all of the stacked tasks.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Whether the worker was successfully shutdown or not.

Örnekler

Örnek 1 Shutdown the referenced worker

<?php
$my = new Worker();
$my->start();
/* stack/execute tasks */
var_dump($my->shutdown());

Yukarıdaki örneğin çıktısı:

bool(true)

Worker::isWorking
Worker::stack
Worker


Stacking work

Worker::shutdown
Worker::unstack
Worker
PHP Manual

Worker::stack

(PECL pthreads >= 2.0.0)

Worker::stack — Stacking work

Açıklama

public int Worker::stack ( Threaded &$work )

Appends the new work to the stack of the referenced worker.

Değiştirgeler

work

A Threaded object to be executed by the worker.

Dönen Değerler

The new size of the stack.

Örnekler

Örnek 1 Stacking a task for execution onto a worker

<?php
$worker = new Worker();
$work = new class extends Threaded {};

var_dump($worker->stack($work));

Yukarıdaki örneğin çıktısı:

int(1)

Worker::shutdown
Worker::unstack
Worker


Unstacking work

Worker::stack
Collectable
Worker
PHP Manual

Worker::unstack

(PECL pthreads >= 2.0.0)

Worker::unstack — Unstacking work

Açıklama

public int Worker::unstack ( void )

Removes the first task (the oldest one) in the stack.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The new size of the stack.

Sürüm Bilgisi

Sürüm: | Açıklama
v3 | The parameter to specify the task to unstack has been removed. Now, only the first task in the stack is removed.

Örnekler

Örnek 1 Removing objects from the stack of Workers

<?php
$my = new Worker();
$work = new class extends Threaded {};

var_dump($my->stack($work));
var_dump($my->unstack());

Yukarıdaki örneğin çıktısı:

int(1)
int(0)

Worker::stack
Collectable
Worker


The Collectable interface

(PECL pthreads >= 2.0.8)

Giriş

Dikkat

Collectable was previously a class (in pthreads v2 and below). Now, it is an interface in pthreads v3 that is implemented by the Threaded class.

Represents a garbage-collectable object.

Arayüz Sözdizimi

Collectable extends Threaded {
/* Yöntemler */
public bool isGarbage ( void )
public void setGarbage ( void )
}

İçindekiler

  • Collectable::isGarbage — Determine whether an object has been marked as garbage
  • Collectable::setGarbage — Mark an object as garbage
Worker::unstack
Collectable::isGarbage
pthreads


Determine whether an object has been marked as garbage

Collectable
Collectable::setGarbage
Collectable
PHP Manual

Collectable::isGarbage

(PECL pthreads >= 2.0.8)

Collectable::isGarbage — Determine whether an object has been marked as garbage

Açıklama

public bool Collectable::isGarbage ( void )

Can be called in Pool::collect() to determine if this object is garbage.

Ayrıca Bakınız

  • Pool::collect() - Collect references to completed tasks

Collectable
Collectable::setGarbage
Collectable


Mark an object as garbage

Collectable::isGarbage
Modifiers
Collectable
PHP Manual

Collectable::setGarbage

(PECL pthreads < 3.0.0)

Collectable::setGarbage — Mark an object as garbage

Açıklama

public void Collectable::setGarbage ( void )

Should be called once per object when the object is finished being executed or referenced.

Ayrıca Bakınız

  • Collectable::isGarbage() - Determine whether an object has been marked as garbage

Collectable::isGarbage
Modifiers
Collectable


Method Modifiers

pthreads overrides the functionality of the protected and private method modifiers in order to provide functionality more suited to multi-threaded objects. pthreads applies this functionality to all Threaded objects from creation.

Örnek 1 protected method example: protected methods can only be executed by one Thread at a time.

<?php
class ExampleThread extends Thread {
    public function run() {
        /* thread code */
        if ($this->synchronized()) {

        }
    }

    protected function exclusive() {
        /* synchronized method */
    }
}

$thread = new ExampleThread();
if ($thread->start()) {
    $thread->exclusive();
}
?>

Örnek 2 private method example: private methods may only be executed by the Threaded object during execution

<?php
class ExampleThread extends Thread {
    public function run() {
        /* thread code */
        if ($this->insideonly()) {

        }
    }

    private function insideonly() {
        /* private method */
    }
}

$thread = new ExampleThread();
if ($thread->start()) {
    $thread->insideonly();
}
?>
Collectable::setGarbage
Pool
pthreads


The Pool class

(PECL pthreads >= 2.0.0)

Giriş

A Pool is a container for, and controller of, an adjustable number of Workers.

Pooling provides a higher level abstraction of the Worker functionality, including the management of references in the way required by pthreads.

Sınıf Sözdizimi

Pool {
/* Özellikler */
protected $size ;
protected $class ;
protected $workers ;
protected $work ;
protected $ctor ;
protected $last ;
/* Yöntemler */
public int collect ([ Callable $collector ] )
public Pool __construct ( integer $size [, string $class [, array $ctor ]] )
public void resize ( integer $size )
public void shutdown ( void )
public int submit ( Threaded $task )
public int submitTo ( int $worker , Threaded $task )
}

Özellikler

size

maximum number of Workers this Pool can use

class

the class of the Worker

ctor

the arguments for constructor of new Workers

workers

references to Workers

work

references to Threaded objects submitted to the Pool

last

offset in workers of the last Worker used

İçindekiler

  • Pool::collect — Collect references to completed tasks
  • Pool::__construct — Creates a new Pool of Workers
  • Pool::resize — Resize the Pool
  • Pool::shutdown — Shutdown all workers
  • Pool::submit — Submits an object for execution
  • Pool::submitTo — Submits a task to a specific worker for execution
Modifiers
Pool::collect
pthreads


Collect references to completed tasks

Pool
Pool::__construct
Pool
PHP Manual

Pool::collect

(PECL pthreads >= 2.0.0)

Pool::collect — Collect references to completed tasks

Açıklama

public int Pool::collect ([ Callable $collector ] )

Allows the pool to collect references determined to be garbage by the optionally given collector.

Değiştirgeler

collector

A Callable collector that returns a boolean on whether the task can be collected or not. Only in rare cases should a custom collector need to be used.

Dönen Değerler

The number of remaining tasks in the pool to be collected.

Sürüm Bilgisi

Sürüm: | Açıklama
v3 | An integer is now returned, and the collector parameter is now optional.

Örnekler

Örnek 1 A basic example of Pool::collect()

<?php
$pool = new Pool(4);

for ($i = 0; $i < 15; ++$i) {
    $pool->submit(new class extends Threaded {});
}

while ($pool->collect()); // blocks until all tasks have finished executing

$pool->shutdown();

Pool
Pool::__construct
Pool


Creates a new Pool of Workers

Pool::collect
Pool::resize
Pool
PHP Manual

Pool::__construct

(PECL pthreads >= 2.0.0)

Pool::__construct — Creates a new Pool of Workers

Açıklama

public Pool Pool::__construct ( integer $size [, string $class [, array $ctor ]] )

Construct a new pool of workers. Pools lazily create their threads, which means new threads will only be spawned when they are required to execute tasks.

Değiştirgeler

size

The maximum number of workers for this pool to create

class

The class for new Workers. If no class is given, then it defaults to the Worker class.

ctor

An array of arguments to be passed to new workers' constructors

Dönen Değerler

The new pool

Örnekler

Örnek 1 Creating Pools

<?php
class MyWorker extends Worker {

    public function __construct(Something $something) {
        $this->something = $something;
    }

    public function run() {
        /** ... **/
    }
}

$pool = new Pool(8, \MyWorker::class, [new Something()]);

var_dump($pool);
?>

Yukarıdaki örneğin çıktısı:

object(Pool)#1 (6) {
  ["size":protected]=>
  int(8)
  ["class":protected]=>
  string(8) "MyWorker"
  ["workers":protected]=>
  NULL
  ["work":protected]=>
  NULL
  ["ctor":protected]=>
  array(1) {
    [0]=>
    object(Something)#2 (0) {
    }
  }
  ["last":protected]=>
  int(0)
}

Pool::collect
Pool::resize
Pool


Resize the Pool

Pool::__construct
Pool::shutdown
Pool
PHP Manual

Pool::resize

(PECL pthreads >= 2.0.0)

Pool::resize — Resize the Pool

Açıklama

public void Pool::resize ( integer $size )

Resize the Pool

Değiştirgeler

size

The maximum number of Workers this Pool can create

Dönen Değerler

void

Pool::__construct
Pool::shutdown
Pool


Shutdown all workers

Pool::resize
Pool::submit
Pool
PHP Manual

Pool::shutdown

(PECL pthreads >= 2.0.0)

Pool::shutdown — Shutdown all workers

Açıklama

public void Pool::shutdown ( void )

Shuts down all of the workers in the pool. This will block until all submitted tasks have been executed.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

No value is returned.

Örnekler

Örnek 1 Shutting down a pool

<?php
class Task extends Threaded
{
    public function run()
    {
        usleep(500000);
    }
}

$pool = new Pool(4);

for ($i = 0; $i < 10; ++$i) {
    $pool->submit(new Task());
}

$pool->shutdown(); // blocks until all submitted tasks have finished executing

Pool::resize
Pool::submit
Pool


Submits an object for execution

Pool::shutdown
Pool::submitTo
Pool
PHP Manual

Pool::submit

(PECL pthreads >= 2.0.0)

Pool::submit — Submits an object for execution

Açıklama

public int Pool::submit ( Threaded $task )

Submit the task to the next Worker in the Pool

Değiştirgeler

size

The task for execution

Dönen Değerler

the identifier of the Worker executing the object

Örnekler

Örnek 1 Submitting Tasks

<?php
class MyWork extends Threaded {

    public function run() {
        /* ... */
    }
}

class MyWorker extends Worker {

    public function __construct(Something $something) {
        $this->something = $something;
    }

    public function run() {
        /** ... **/
    }
}

$pool = new Pool(8, \MyWorker::class, [new Something()]);
$pool->submit(new MyWork());
var_dump($pool);
?>

Yukarıdaki örneğin çıktısı:

object(Pool)#1 (6) {
  ["size":protected]=>
  int(8)
  ["class":protected]=>
  string(8) "MyWorker"
  ["workers":protected]=>
  array(1) {
    [0]=>
    object(MyWorker)#4 (1) {
      ["something"]=>
      object(Something)#5 (0) {
      }
    }
  }
  ["work":protected]=>
  array(1) {
    [0]=>
    object(MyWork)#3 (1) {
      ["worker"]=>
      object(MyWorker)#5 (1) {
        ["something"]=>
        object(Something)#6 (0) {
        }
      }
    }
  }
  ["ctor":protected]=>
  array(1) {
    [0]=>
    object(Something)#2 (0) {
    }
  }
  ["last":protected]=>
  int(1)
}

Pool::shutdown
Pool::submitTo
Pool


Submits a task to a specific worker for execution

Pool::submit
Mutex
Pool
PHP Manual

Pool::submitTo

(PECL pthreads >= 2.0.0)

Pool::submitTo — Submits a task to a specific worker for execution

Açıklama

public int Pool::submitTo ( int $worker , Threaded $task )

Submit a task to the specified worker in the pool. The workers are indexed from 0, and will only exist if the pool has needed to create them (since threads are lazily spawned).

Değiştirgeler

worker

The worker to stack the task onto, indexed from 0.

task

The task for execution.

Dönen Değerler

The identifier of the worker that accepted the task.

Örnekler

Örnek 1 Submitting tasks to a specific worker

<?php
class Task extends Threaded {
    public function run() {
        var_dump(Thread::getCurrentThreadID());
    }
}

$pool = new Pool(2);

$pool->submit(new Task());

for ($i = 0; $i < 5; ++$i) {
    $pool->submitTo(0, new Task()); // stack all tasks onto the first worker
}

$pool->submitTo(1, new Task()); // cannot stack the task onto the second worker due to it not existing yet

$pool->shutdown();

Yukarıdaki örneğin çıktısı:

int(4475011072)
int(4475011072)
int(4475011072)
int(4475011072)
int(4475011072)
int(4475011072)

Fatal error: Uncaught Exception: The selected worker (1) does not exist in %s:%d

Pool::submit
Mutex
Pool


The Mutex class

(PECL pthreads < 3.0.0)

Giriş

Uyarı

The Mutex class has been removed in pthreads v3.

The static methods contained in the Mutex class provide direct access to Posix Mutex functionality.

Sınıf Sözdizimi

Mutex {
/* Yöntemler */
final public static long create ([ boolean $lock ] )
final public static boolean destroy ( long $mutex )
final public static boolean lock ( long $mutex )
final public static boolean trylock ( long $mutex )
final public static boolean unlock ( long $mutex [, boolean $destroy ] )
}

İçindekiler

  • Mutex::create — Create a Mutex
  • Mutex::destroy — Destroy Mutex
  • Mutex::lock — Acquire Mutex
  • Mutex::trylock — Attempt to Acquire Mutex
  • Mutex::unlock — Release Mutex
Pool::submitTo
Mutex::create
pthreads


Create a Mutex

Mutex
Mutex::destroy
Mutex
PHP Manual

Mutex::create

(PECL pthreads < 3.0.0)

Mutex::create — Create a Mutex

Uyarı

The Mutex class has been removed in pthreads v3.

Açıklama

final public static long Mutex::create ([ boolean $lock ] )

Create, and optionally lock a new Mutex for the caller

Değiştirgeler

lock

Setting lock to true will lock the Mutex for the caller before returning the handle

Dönen Değerler

A newly created and optionally locked Mutex handle

Örnekler

Örnek 1 Mutex Creation and Destruction

<?php
/** You cannot use the "new" keyword, a Mutex is not a PHP object **/
$mutex = Mutex::create();
/** You have the physical address of the Mutex **/
var_dump($mutex);
/** Always destroy mutex you have created **/
Mutex::destroy($mutex);
?>

Yukarıdaki örneğin çıktısı:

int(40096976)

Mutex
Mutex::destroy
Mutex


Destroy Mutex

Mutex::create
Mutex::lock
Mutex
PHP Manual

Mutex::destroy

(PECL pthreads < 3.0.0)

Mutex::destroy — Destroy Mutex

Uyarı

The Mutex class has been removed in pthreads v3.

Açıklama

final public static boolean Mutex::destroy ( long $mutex )

Destroying Mutex handles must be carried out explicitly by the programmer when they are finished with the Mutex handle.

Değiştirgeler

mutex

A handle returned by a previous call to Mutex::create(). The handle should not be locked by any Thread when Mutex::destroy() is called.

Dönen Değerler

A boolean indication of success

Örnekler

Örnek 1 Mutex Creation and Destruction

<?php
/** You cannot use the "new" keyword, a Mutex is not a PHP object **/
$mutex = Mutex::create();
/** You have the physical address of the Mutex **/
var_dump($mutex);
/** Always destroy mutex you have created **/
Mutex::destroy($mutex);
?>

Yukarıdaki örneğin çıktısı:

int(40096976)

Mutex::create
Mutex::lock
Mutex


Acquire Mutex

Mutex::destroy
Mutex::trylock
Mutex
PHP Manual

Mutex::lock

(PECL pthreads < 3.0.0)

Mutex::lock — Acquire Mutex

Uyarı

The Mutex class has been removed in pthreads v3.

Açıklama

final public static boolean Mutex::lock ( long $mutex )

Attempt to lock the Mutex for the caller.

An attempt to lock a Mutex owned (locked) by another Thread will result in blocking.

Değiştirgeler

mutex

A handle returned by a previous call to Mutex::create().

Dönen Değerler

A boolean indication of success.

Örnekler

Örnek 1 Mutex Locking and Unlocking

<?php
/** You cannot use the "new" keyword, a Mutex is not a PHP object **/
$mutex = Mutex::create();
/** You can now lock the mutex in any context **/
var_dump(Mutex::lock($mutex));
/** It is invalid to attempt to destroy a locked Mutex **/
var_dump(Mutex::unlock($mutex));
/** Always destroy mutex you have created **/
Mutex::destroy($mutex);
?>

Yukarıdaki örneğin çıktısı:

bool(true)
bool(true)

Mutex::destroy
Mutex::trylock
Mutex


Attempt to Acquire Mutex

Mutex::lock
Mutex::unlock
Mutex
PHP Manual

Mutex::trylock

(PECL pthreads < 3.0.0)

Mutex::trylock — Attempt to Acquire Mutex

Uyarı

The Mutex class has been removed in pthreads v3.

Açıklama

final public static boolean Mutex::trylock ( long $mutex )

Attempt to lock the Mutex for the caller without blocking if the Mutex is owned (locked) by another Thread.

Değiştirgeler

mutex

A handle returned by a previous call to Mutex::create().

Dönen Değerler

A boolean indication of success.

Örnekler

Örnek 1 Mutex Locking and Unlocking

<?php
/** You cannot use the "new" keyword, a Mutex is not a PHP object **/
$mutex = Mutex::create();
/** You can now try to lock the mutex in any context **/
var_dump(Mutex::trylock($mutex));
/** It is invalid to attempt to destroy a locked Mutex **/
var_dump(Mutex::unlock($mutex));
/** Always destroy mutex you have created **/
Mutex::destroy($mutex);
?>

Yukarıdaki örneğin çıktısı:

bool(true)
bool(true)

Mutex::lock
Mutex::unlock
Mutex


Release Mutex

Mutex::trylock
Cond
Mutex
PHP Manual

Mutex::unlock

(PECL pthreads < 3.0.0)

Mutex::unlock — Release Mutex

Uyarı

The Mutex class has been removed in pthreads v3.

Açıklama

final public static boolean Mutex::unlock ( long $mutex [, boolean $destroy ] )

Attempts to unlock the Mutex for the caller, optionally destroying the Mutex handle. The calling thread should own the Mutex at the time of the call.

Değiştirgeler

mutex

A handle returned by a previous call to Mutex::create().

destroy

When true pthreads will destroy the Mutex after a successful unlock.

Dönen Değerler

A boolean indication of success.

Örnekler

Örnek 1 Mutex Locking and Unlocking

<?php
/** You cannot use the "new" keyword, a Mutex is not a PHP object **/
$mutex = Mutex::create();
/** You can now lock the mutex in any context **/
var_dump(Mutex::lock($mutex));
/** It is invalid to attempt to destroy a locked Mutex **/
var_dump(Mutex::unlock($mutex));
/** Always destroy mutex you have created **/
Mutex::destroy($mutex);
?>

Yukarıdaki örneğin çıktısı:

bool(true)
bool(true)

Mutex::trylock
Cond
Mutex


The Cond class

(PECL pthreads < 3.0.0)

Giriş

Uyarı

The Cond class has been removed in pthreads v3.

The static methods contained in the Cond class provide direct access to Posix Condition Variables.

Sınıf Sözdizimi

Cond {
/* Yöntemler */
final public static boolean broadcast ( long $condition )
final public static long create ( void )
final public static boolean destroy ( long $condition )
final public static boolean signal ( long $condition )
final public static boolean wait ( long $condition , long $mutex [, long $timeout ] )
}

İçindekiler

  • Cond::broadcast — Broadcast a Condition
  • Cond::create — Create a Condition
  • Cond::destroy — Destroy a Condition
  • Cond::signal — Signal a Condition
  • Cond::wait — Wait for Condition
Mutex::unlock
Cond::broadcast
pthreads


Broadcast a Condition

Cond
Cond::create
Cond
PHP Manual

Cond::broadcast

(PECL pthreads < 3.0.0)

Cond::broadcast — Broadcast a Condition

Uyarı

The Cond class has been removed in pthreads v3.

Açıklama

final public static boolean Cond::broadcast ( long $condition )

Broadcast to all Threads blocking on a call to Cond::wait().

Değiştirgeler

condition

A handle to a Condition Variable returned by a previous call to Cond::create()

Dönen Değerler

A boolean indication of success.

Örnekler

Örnek 1 Condition Broadcasting

<?php
/** You cannot use the "new" keyword, a Cond is not a PHP object **/
$cond = Cond::create();
/** The caller must lock the associated Mutex before a call to broadcast **/
var_dump(Cond::broadcast($cond));
/** Always destroy Cond you have created **/
Cond::destroy($cond);
?>

Yukarıdaki örneğin çıktısı:

bool(true)

Cond
Cond::create
Cond


Create a Condition

Cond::broadcast
Cond::destroy
Cond
PHP Manual

Cond::create

(PECL pthreads < 3.0.0)

Cond::create — Create a Condition

Uyarı

The Cond class has been removed in pthreads v3.

Açıklama

final public static long Cond::create ( void )

Creates a new Condition Variable for the caller.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A handle to a Condition Variable

Örnekler

Örnek 1 Condition Creation and Destruction

<?php
/** You cannot use the "new" keyword, a Cond is not a PHP object **/
$cond = Cond::create();
/** You can now use the Cond in any context **/
var_dump($cond);
/** Always destroy Cond you have created **/
Cond::destroy($cond);
?>

Yukarıdaki örneğin çıktısı:

int(4540682)

Cond::broadcast
Cond::destroy
Cond


Destroy a Condition

Cond::create
Cond::signal
Cond
PHP Manual

Cond::destroy

(PECL pthreads < 3.0.0)

Cond::destroy — Destroy a Condition

Uyarı

The Cond class has been removed in pthreads v3.

Açıklama

final public static boolean Cond::destroy ( long $condition )

Destroying Condition Variable handles must be carried out explicitly by the programmer when they are finished with the Condition Variable. No Threads should be blocking on a call to Cond::wait() when the call to Cond::destroy() takes place.

Değiştirgeler

condition

A handle to a Condition Variable returned by a previous call to Cond::create()

Dönen Değerler

A boolean indication of success.

Örnekler

Örnek 1 Condition Creation and Destruction

<?php
/** You cannot use the "new" keyword, a Cond is not a PHP object **/
$cond = Cond::create();
/** You can now use the Cond in any context **/
var_dump($cond);
/** Always destroy Cond you have created **/
Cond::destroy($cond);
?>

Yukarıdaki örneğin çıktısı:

int(4540682)

Cond::create
Cond::signal
Cond


Signal a Condition

Cond::destroy
Cond::wait
Cond
PHP Manual

Cond::signal

(PECL pthreads < 3.0.0)

Cond::signal — Signal a Condition

Uyarı

The Cond class has been removed in pthreads v3.

Açıklama

final public static boolean Cond::signal ( long $condition )

Değiştirgeler

condition

A handle returned by a previous call to Cond::create()

Dönen Değerler

A boolean indication of success.

Örnekler

Örnek 1 Condition Signalling

<?php
/** You cannot use the "new" keyword, a Cond is not a PHP object **/
$cond = Cond::create();
/** The caller must lock the associated Mutex before a call to broadcast **/
var_dump(Cond::signal($cond));
/** Always destroy Cond you have created **/
Cond::destroy($cond);
?>

Yukarıdaki örneğin çıktısı:

bool(true)

Cond::destroy
Cond::wait
Cond


Wait for Condition

Cond::signal
Semaphore
Cond
PHP Manual

Cond::wait

(PECL pthreads < 3.0.0)

Cond::wait — Wait for Condition

Uyarı

The Cond class has been removed in pthreads v3.

Açıklama

final public static boolean Cond::wait ( long $condition , long $mutex [, long $timeout ] )

Wait for a signal on a Condition Variable, optionally specifying a timeout to limit waiting time.

Değiştirgeler

condition

A handle returned by a previous call to Cond::create().

mutex

A handle returned by a previous call to Mutex::create() and owned (locked) by the caller.

timeout

An optional timeout, in microseconds ( millionths of a second ).

Dönen Değerler

A boolean indication of success.

Örnekler

Örnek 1 Waiting for Conditions

<?php
/** PLEASE NOTE THIS EXAMPLE WILL CAUSE THE PROCESS TO HANG **/
$mutex = Mutex::create(true);
/** You cannot use the "new" keyword, a Cond is not a PHP object **/
$cond = Cond::create();
/** The caller must lock the associated Mutex before a call to broadcast **/
var_dump(Cond::wait($cond, $mutex));
/** Always destroy Cond you have created **/
Cond::destroy($cond);
Mutex::unlock($mutex);
Mutex::destroy($mutex);
?>

Yukarıdaki örneğin çıktısı:

int(49685473)

Cond::signal
Semaphore
Cond


Semaphore, Shared Memory and IPC

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Semaphore İşlevleri
    • ftok — Convert a pathname and a project identifier to a System V IPC key
    • msg_get_queue — Create or attach to a message queue
    • msg_queue_exists — Check whether a message queue exists
    • msg_receive — Receive a message from a message queue
    • msg_remove_queue — Destroy a message queue
    • msg_send — Send a message to a message queue
    • msg_set_queue — Set information in the message queue data structure
    • msg_stat_queue — Returns information from the message queue data structure
    • sem_acquire — Acquire a semaphore
    • sem_get — Get a semaphore id
    • sem_release — Release a semaphore
    • sem_remove — Remove a semaphore
    • shm_attach — Creates or open a shared memory segment
    • shm_detach — Disconnects from shared memory segment
    • shm_get_var — Returns a variable from shared memory
    • shm_has_var — Check whether a specific entry exists
    • shm_put_var — Inserts or updates a variable in shared memory
    • shm_remove_var — Removes a variable from shared memory
    • shm_remove — Removes shared memory from Unix systems
Cond::wait
Giriş
Süreç Denetim Eklentileri


Giriş

This module provides wrappers for the System V IPC family of functions. It includes semaphores, shared memory and inter-process messaging (IPC).

Semaphores may be used to provide exclusive access to resources on the current machine, or to limit the number of processes that may simultaneously use a resource.

This module provides also shared memory functions using System V shared memory. Shared memory may be used to provide access to global variables. Different httpd-daemons and even other programs (such as Perl, C, ...) are able to access this data to provide a global data-exchange. Remember, that shared memory is NOT safe against simultaneous access. Use semaphores for synchronization.

Limits of Shared Memory by the Unix OS
SHMMAX | max size of shared memory, normally 131072 bytes
SHMMIN | minimum size of shared memory, normally 1 byte
SHMMNI | max amount of shared memory segments on a system, normally 100
SHMSEG | max amount of shared memory segments per process, normally 6

The messaging functions may be used to send and receive messages to/from other processes. They provide a simple and effective means of exchanging data between processes, without the need for setting up an alternative using Unix domain sockets.

Bilginize: Bu eklenti Windows sistemlerinde çalışmaz.

Semaphore
Yapılandırma/Kurulum
Semaphore


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Semaphore


Kurulum

Support for this functions are not enabled by default. To enable System V semaphore support compile PHP with the option --enable-sysvsem . To enable the System V shared memory support compile PHP with the option --enable-sysvshm . To enable the System V messages support compile PHP with the option --enable-sysvmsg .

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Semaphore Configuration Options
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
sysvshm.init_mem | 10000 | PHP_INI_SYSTEM |
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

sysvshm.init_mem int

A default size of the shared memory segment.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

System V message constants
Constant | Type | Changelog
MSG_IPC_NOWAIT | integer |
MSG_EAGAIN | integer | As of 5.2.0
MSG_ENOMSG | integer | As of 5.2.0
MSG_NOERROR | integer |
MSG_EXCEPT | integer |

Özkaynak Türleri
Semaphore İşlevleri
Semaphore


Semaphore İşlevleri

İçindekiler

  • ftok — Convert a pathname and a project identifier to a System V IPC key
  • msg_get_queue — Create or attach to a message queue
  • msg_queue_exists — Check whether a message queue exists
  • msg_receive — Receive a message from a message queue
  • msg_remove_queue — Destroy a message queue
  • msg_send — Send a message to a message queue
  • msg_set_queue — Set information in the message queue data structure
  • msg_stat_queue — Returns information from the message queue data structure
  • sem_acquire — Acquire a semaphore
  • sem_get — Get a semaphore id
  • sem_release — Release a semaphore
  • sem_remove — Remove a semaphore
  • shm_attach — Creates or open a shared memory segment
  • shm_detach — Disconnects from shared memory segment
  • shm_get_var — Returns a variable from shared memory
  • shm_has_var — Check whether a specific entry exists
  • shm_put_var — Inserts or updates a variable in shared memory
  • shm_remove_var — Removes a variable from shared memory
  • shm_remove — Removes shared memory from Unix systems
Öntanımlı Sabitler
ftok
Semaphore


Convert a pathname and a project identifier to a System V IPC key

Semaphore İşlevleri
msg_get_queue
Semaphore İşlevleri
PHP Manual

ftok

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

ftok — Convert a pathname and a project identifier to a System V IPC key

Açıklama

int ftok ( string $pathname , string $proj )

The function converts the pathname of an existing accessible file and a project identifier into an integer for use with for example shmop_open() and other System V IPC keys.

Değiştirgeler

pathname

Path to an accessible file.

proj

Project identifier. This must be a one character string.

Dönen Değerler

On success the return value will be the created key value, otherwise -1 is returned.

Ayrıca Bakınız

  • shmop_open() - Create or open shared memory block
  • sem_get() - Get a semaphore id

Semaphore İşlevleri
msg_get_queue
Semaphore İşlevleri


Create or attach to a message queue

ftok
msg_queue_exists
Semaphore İşlevleri
PHP Manual

msg_get_queue

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

msg_get_queue — Create or attach to a message queue

Açıklama

resource msg_get_queue ( int $key [, int $perms = 0666 ] )

msg_get_queue() returns an id that can be used to access the System V message queue with the given key. The first call creates the message queue with the optional perms. A second call to msg_get_queue() for the same key will return a different message queue identifier, but both identifiers access the same underlying message queue.

Değiştirgeler

key

Message queue numeric ID

perms

Queue permissions. Default to 0666. If the message queue already exists, the perms will be ignored.

Dönen Değerler

Returns a resource handle that can be used to access the System V message queue.

Ayrıca Bakınız

  • msg_remove_queue() - Destroy a message queue
  • msg_receive() - Receive a message from a message queue
  • msg_send() - Send a message to a message queue
  • msg_stat_queue() - Returns information from the message queue data structure
  • msg_set_queue() - Set information in the message queue data structure

ftok
msg_queue_exists
Semaphore İşlevleri


Check whether a message queue exists

msg_get_queue
msg_receive
Semaphore İşlevleri
PHP Manual

msg_queue_exists

(PHP 5 >= 5.3.0, PHP 7)

msg_queue_exists — Check whether a message queue exists

Açıklama

bool msg_queue_exists ( int $key )

Checks whether the message queue key exists.

Değiştirgeler

key

Queue key.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • msg_remove_queue() - Destroy a message queue
  • msg_receive() - Receive a message from a message queue
  • msg_stat_queue() - Returns information from the message queue data structure

msg_get_queue
msg_receive
Semaphore İşlevleri


Receive a message from a message queue

msg_queue_exists
msg_remove_queue
Semaphore İşlevleri
PHP Manual

msg_receive

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

msg_receive — Receive a message from a message queue

Açıklama

bool msg_receive ( resource $queue , int $desiredmsgtype , int &$msgtype , int $maxsize , mixed &$message [, bool $unserialize = true [, int $flags = 0 [, int &$errorcode ]]] )

msg_receive() will receive the first message from the specified queue of the type specified by desiredmsgtype.

Değiştirgeler

queue

desiredmsgtype

If desiredmsgtype is 0, the message from the front of the queue is returned. If desiredmsgtype is greater than 0, then the first message of that type is returned. If desiredmsgtype is less than 0, the first message on the queue with the lowest type less than or equal to the absolute value of desiredmsgtype will be read. If no messages match the criteria, your script will wait until a suitable message arrives on the queue. You can prevent the script from blocking by specifying MSG_IPC_NOWAIT in the flags parameter.

msgtype

The type of the message that was received will be stored in this parameter.

maxsize

The maximum size of message to be accepted is specified by the maxsize; if the message in the queue is larger than this size the function will fail (unless you set flags as described below).

message

The received message will be stored in message, unless there were errors receiving the message.

unserialize

If set to TRUE, the message is treated as though it was serialized using the same mechanism as the session module. The message will be unserialized and then returned to your script. This allows you to easily receive arrays or complex object structures from other PHP scripts, or if you are using the WDDX serializer, from any WDDX compatible source.

If unserialize is FALSE, the message will be returned as a binary-safe string.

flags

The optional flags allows you to pass flags to the low-level msgrcv system call. It defaults to 0, but you may specify one or more of the following values (by adding or ORing them together).

Flag values for msg_receive
MSG_IPC_NOWAIT | If there are no messages of the desiredmsgtype, return immediately and do not wait. The function will fail and return an integer value corresponding to MSG_ENOMSG.
MSG_EXCEPT | Using this flag in combination with a desiredmsgtype greater than 0 will cause the function to receive the first message that is not equal to desiredmsgtype.
MSG_NOERROR | If the message is longer than maxsize, setting this flag will truncate the message to maxsize and will not signal an error.

errorcode

If the function fails, the optional errorcode will be set to the value of the system errno variable.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Upon successful completion the message queue data structure is updated as follows: msg_lrpid is set to the process-ID of the calling process, msg_qnum is decremented by 1 and msg_rtime is set to the current time.

Ayrıca Bakınız

  • msg_remove_queue() - Destroy a message queue
  • msg_send() - Send a message to a message queue
  • msg_stat_queue() - Returns information from the message queue data structure
  • msg_set_queue() - Set information in the message queue data structure

msg_queue_exists
msg_remove_queue
Semaphore İşlevleri


Destroy a message queue

msg_receive
msg_send
Semaphore İşlevleri
PHP Manual

msg_remove_queue

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

msg_remove_queue — Destroy a message queue

Açıklama

bool msg_remove_queue ( resource $queue )

msg_remove_queue() destroys the message queue specified by the queue. Only use this function when all processes have finished working with the message queue and you need to release the system resources held by it.

Değiştirgeler

queue

Message queue resource handle

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • msg_get_queue() - Create or attach to a message queue
  • msg_receive() - Receive a message from a message queue
  • msg_stat_queue() - Returns information from the message queue data structure
  • msg_set_queue() - Set information in the message queue data structure

msg_receive
msg_send
Semaphore İşlevleri


Send a message to a message queue

msg_remove_queue
msg_set_queue
Semaphore İşlevleri
PHP Manual

msg_send

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

msg_send — Send a message to a message queue

Açıklama

bool msg_send ( resource $queue , int $msgtype , mixed $message [, bool $serialize = true [, bool $blocking = true [, int &$errorcode ]]] )

msg_send() sends a message of type msgtype (which MUST be greater than 0) to the message queue specified by queue.

Değiştirgeler

queue

msgtype

message

serialize

The optional serialize controls how the message is sent. serialize defaults to TRUE which means that the message is serialized using the same mechanism as the session module before being sent to the queue. This allows complex arrays and objects to be sent to other PHP scripts, or if you are using the WDDX serializer, to any WDDX compatible client.

blocking

If the message is too large to fit in the queue, your script will wait until another process reads messages from the queue and frees enough space for your message to be sent. This is called blocking; you can prevent blocking by setting the optional blocking parameter to FALSE, in which case msg_send() will immediately return FALSE if the message is too big for the queue, and set the optional errorcode to MSG_EAGAIN, indicating that you should try to send your message again a little later on.

errorcode

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Upon successful completion the message queue data structure is updated as follows: msg_lspid is set to the process-ID of the calling process, msg_qnum is incremented by 1 and msg_stime is set to the current time.

Ayrıca Bakınız

  • msg_remove_queue() - Destroy a message queue
  • msg_receive() - Receive a message from a message queue
  • msg_stat_queue() - Returns information from the message queue data structure
  • msg_set_queue() - Set information in the message queue data structure

msg_remove_queue
msg_set_queue
Semaphore İşlevleri


Set information in the message queue data structure

msg_send
msg_stat_queue
Semaphore İşlevleri
PHP Manual

msg_set_queue

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

msg_set_queue — Set information in the message queue data structure

Açıklama

bool msg_set_queue ( resource $queue , array $data )

msg_set_queue() allows you to change the values of the msg_perm.uid, msg_perm.gid, msg_perm.mode and msg_qbytes fields of the underlying message queue data structure.

Changing the data structure will require that PHP be running as the same user that created the queue, owns the queue (as determined by the existing msg_perm.xxx fields), or be running with root privileges. root privileges are required to raise the msg_qbytes values above the system defined limit.

Değiştirgeler

queue

Message queue resource handle

data

You specify the values you require by setting the value of the keys that you require in the data array.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • msg_remove_queue() - Destroy a message queue
  • msg_receive() - Receive a message from a message queue
  • msg_stat_queue() - Returns information from the message queue data structure
  • msg_get_queue() - Create or attach to a message queue

msg_send
msg_stat_queue
Semaphore İşlevleri


Returns information from the message queue data structure

msg_set_queue
sem_acquire
Semaphore İşlevleri
PHP Manual

msg_stat_queue

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

msg_stat_queue — Returns information from the message queue data structure

Açıklama

array msg_stat_queue ( resource $queue )

msg_stat_queue() returns the message queue meta data for the message queue specified by the queue. This is useful, for example, to determine which process sent the message that was just received.

Değiştirgeler

queue

Message queue resource handle

Dönen Değerler

The return value is an array whose keys and values have the following meanings:

Array structure for msg_stat_queue
msg_perm.uid | The uid of the owner of the queue.
msg_perm.gid | The gid of the owner of the queue.
msg_perm.mode | The file access mode of the queue.
msg_stime | The time that the last message was sent to the queue.
msg_rtime | The time that the last message was received from the queue.
msg_ctime | The time that the queue was last changed.
msg_qnum | The number of messages waiting to be read from the queue.
msg_qbytes | The maximum number of bytes allowed in one message queue. On Linux, this value may be read and modified via /proc/sys/kernel/msgmnb.
msg_lspid | The pid of the process that sent the last message to the queue.
msg_lrpid | The pid of the process that received the last message from the queue.

Ayrıca Bakınız

  • msg_remove_queue() - Destroy a message queue
  • msg_receive() - Receive a message from a message queue
  • msg_get_queue() - Create or attach to a message queue
  • msg_set_queue() - Set information in the message queue data structure

msg_set_queue
sem_acquire
Semaphore İşlevleri


Acquire a semaphore

msg_stat_queue
sem_get
Semaphore İşlevleri
PHP Manual

sem_acquire

(PHP 4, PHP 5, PHP 7)

sem_acquire — Acquire a semaphore

Açıklama

bool sem_acquire ( resource $sem_identifier [, bool $nowait = false ] )

sem_acquire() by default blocks (if necessary) until the semaphore can be acquired. A process attempting to acquire a semaphore which it has already acquired will block forever if acquiring the semaphore would cause its maximum number of semaphore to be exceeded.

After processing a request, any semaphores acquired by the process but not explicitly released will be released automatically and a warning will be generated.

Değiştirgeler

sem_identifier

sem_identifier is a semaphore resource, obtained from sem_get().

nowait

Specifies if the process shouldn't wait for the semaphore to be acquired. If set to true, the call will return false immediately if a semaphore cannot be immediately acquired.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.6.1 | The $nowait parameter was added.

Ayrıca Bakınız

  • sem_get() - Get a semaphore id
  • sem_release() - Release a semaphore

msg_stat_queue
sem_get
Semaphore İşlevleri


Get a semaphore id

sem_acquire
sem_release
Semaphore İşlevleri
PHP Manual

sem_get

(PHP 4, PHP 5, PHP 7)

sem_get — Get a semaphore id

Açıklama

resource sem_get ( int $key [, int $max_acquire = 1 [, int $perm = 0666 [, int $auto_release = 1 ]]] )

sem_get() returns an id that can be used to access the System V semaphore with the given key.

A second call to sem_get() for the same key will return a different semaphore identifier, but both identifiers access the same underlying semaphore.

Değiştirgeler

key

max_acquire

The number of processes that can acquire the semaphore simultaneously is set to max_acquire.

perm

The semaphore permissions. Actually this value is set only if the process finds it is the only process currently attached to the semaphore.

auto_release

Specifies if the semaphore should be automatically released on request shutdown.

Dönen Değerler

Returns a positive semaphore identifier on success, or FALSE on error.

Notlar

Uyarı

When using sem_get() to access a semaphore created outside PHP, note that the semaphore must have been created as a set of 3 semaphores (for example, by specifying 3 as the nsems parameter when calling the C semget() function), otherwise PHP will be unable to access the semaphore.

Ayrıca Bakınız

  • sem_acquire() - Acquire a semaphore
  • sem_release() - Release a semaphore
  • ftok() - Convert a pathname and a project identifier to a System V IPC key

sem_acquire
sem_release
Semaphore İşlevleri


Release a semaphore

sem_get
sem_remove
Semaphore İşlevleri
PHP Manual

sem_release

(PHP 4, PHP 5, PHP 7)

sem_release — Release a semaphore

Açıklama

bool sem_release ( resource $sem_identifier )

sem_release() releases the semaphore if it is currently acquired by the calling process, otherwise a warning is generated.

After releasing the semaphore, sem_acquire() may be called to re-acquire it.

Değiştirgeler

sem_identifier

A Semaphore resource handle as returned by sem_get().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • sem_get() - Get a semaphore id
  • sem_acquire() - Acquire a semaphore

sem_get
sem_remove
Semaphore İşlevleri


Remove a semaphore

sem_release
shm_attach
Semaphore İşlevleri
PHP Manual

sem_remove

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

sem_remove — Remove a semaphore

Açıklama

bool sem_remove ( resource $sem_identifier )

sem_remove() removes the given semaphore.

After removing the semaphore, it is no longer accessible.

Değiştirgeler

sem_identifier

A semaphore resource identifier as returned by sem_get().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • sem_get() - Get a semaphore id
  • sem_release() - Release a semaphore
  • sem_acquire() - Acquire a semaphore

sem_release
shm_attach
Semaphore İşlevleri


Creates or open a shared memory segment

sem_remove
shm_detach
Semaphore İşlevleri
PHP Manual

shm_attach

(PHP 4, PHP 5, PHP 7)

shm_attach — Creates or open a shared memory segment

Açıklama

resource shm_attach ( int $key [, int $memsize [, int $perm = 0666 ]] )

shm_attach() returns an id that can be used to access the System V shared memory with the given key, the first call creates the shared memory segment with memsize and the optional perm-bits perm.

A second call to shm_attach() for the same key will return a different shared memory identifier, but both identifiers access the same underlying shared memory. memsize and perm will be ignored.

Değiştirgeler

key

A numeric shared memory segment ID

memsize

The memory size. If not provided, default to the sysvshm.init_mem in the php.ini, otherwise 10000 bytes.

perm

The optional permission bits. Default to 0666.

Dönen Değerler

Returns a shared memory segment identifier.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | This function now returns a resource instead of an integer.

Notlar

Bilginize:

This function used to return an integer value prior to PHP 5.3.0. To achieve the same value in a portable manner, the return value can be cast to an integer like:

<?php
// Create a temporary file and return its path
$tmp = tempnam('/tmp', 'PHP');

// Get the file token key
$key = ftok($tmp, 'a');

// Attach the SHM resource, notice the cast afterwards
$id = shm_attach($key);

if ($id === false) {
    die('Unable to create the shared memory segment');
}

// Cast to integer, since prior to PHP 5.3.0 the resource id
// is returned which can be exposed when casting a resource
// to an integer
$id = (integer) $id;
?>

Ayrıca Bakınız

  • shm_detach() - Disconnects from shared memory segment
  • ftok() - Convert a pathname and a project identifier to a System V IPC key

sem_remove
shm_detach
Semaphore İşlevleri


Disconnects from shared memory segment

shm_attach
shm_get_var
Semaphore İşlevleri
PHP Manual

shm_detach

(PHP 4, PHP 5, PHP 7)

shm_detach — Disconnects from shared memory segment

Açıklama

bool shm_detach ( resource $shm_identifier )

shm_detach() disconnects from the shared memory given by the shm_identifier created by shm_attach(). Remember, that shared memory still exist in the Unix system and the data is still present.

Değiştirgeler

shm_identifier

A shared memory resource handle as returned by shm_attach()

Dönen Değerler

shm_detach() always returns TRUE.

Ayrıca Bakınız

  • shm_attach() - Creates or open a shared memory segment
  • shm_remove() - Removes shared memory from Unix systems
  • shm_remove_var() - Removes a variable from shared memory

shm_attach
shm_get_var
Semaphore İşlevleri


Returns a variable from shared memory

shm_detach
shm_has_var
Semaphore İşlevleri
PHP Manual

shm_get_var

(PHP 4, PHP 5, PHP 7)

shm_get_var — Returns a variable from shared memory

Açıklama

mixed shm_get_var ( resource $shm_identifier , int $variable_key )

shm_get_var() returns the variable with a given variable_key, in the given shared memory segment. The variable is still present in the shared memory.

Değiştirgeler

shm_identifier

Shared memory segment, obtained from shm_attach().

variable_key

The variable key.

Dönen Değerler

Returns the variable with the given key.

Ayrıca Bakınız

  • shm_has_var() - Check whether a specific entry exists
  • shm_put_var() - Inserts or updates a variable in shared memory

shm_detach
shm_has_var
Semaphore İşlevleri


Check whether a specific entry exists

shm_get_var
shm_put_var
Semaphore İşlevleri
PHP Manual

shm_has_var

(PHP 5 >= 5.3.0, PHP 7)

shm_has_var — Check whether a specific entry exists

Açıklama

bool shm_has_var ( resource $shm_identifier , int $variable_key )

Checks whether a specific key exists inside a shared memory segment.

Değiştirgeler

shm_identifier

Shared memory segment, obtained from shm_attach().

variable_key

The variable key.

Dönen Değerler

Returns TRUE if the entry exists, otherwise FALSE

Ayrıca Bakınız

  • shm_get_var() - Returns a variable from shared memory
  • shm_put_var() - Inserts or updates a variable in shared memory

shm_get_var
shm_put_var
Semaphore İşlevleri


Inserts or updates a variable in shared memory

shm_has_var
shm_remove_var
Semaphore İşlevleri
PHP Manual

shm_put_var

(PHP 4, PHP 5, PHP 7)

shm_put_var — Inserts or updates a variable in shared memory

Açıklama

bool shm_put_var ( resource $shm_identifier , int $variable_key , mixed $variable )

shm_put_var() inserts or updates the variable with the given variable_key.

Warnings (E_WARNING level) will be issued if shm_identifier is not a valid SysV shared memory index or if there was not enough shared memory remaining to complete your request.

Değiştirgeler

shm_identifier

A shared memory resource handle as returned by shm_attach()

variable_key

The variable key.

variable

The variable. All variable types that serialize() supports may be used: generally this means all types except for resources and some internal objects that cannot be serialized.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • shm_get_var() - Returns a variable from shared memory
  • shm_has_var() - Check whether a specific entry exists

shm_has_var
shm_remove_var
Semaphore İşlevleri


Removes a variable from shared memory

shm_put_var
shm_remove
Semaphore İşlevleri
PHP Manual

shm_remove_var

(PHP 4, PHP 5, PHP 7)

shm_remove_var — Removes a variable from shared memory

Açıklama

bool shm_remove_var ( resource $shm_identifier , int $variable_key )

Removes a variable with a given variable_key and frees the occupied memory.

Değiştirgeler

shm_identifier

The shared memory identifier as returned by shm_attach()

variable_key

The variable key.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • shm_remove() - Removes shared memory from Unix systems

shm_put_var
shm_remove
Semaphore İşlevleri


Removes shared memory from Unix systems

shm_remove_var
Shared Memory
Semaphore İşlevleri
PHP Manual

shm_remove

(PHP 4, PHP 5, PHP 7)

shm_remove — Removes shared memory from Unix systems

Açıklama

bool shm_remove ( resource $shm_identifier )

shm_remove() removes the shared memory shm_identifier. All data will be destroyed.

Değiştirgeler

shm_identifier

The shared memory identifier as returned by shm_attach()

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • shm_remove_var() - Removes a variable from shared memory

shm_remove_var
Shared Memory
Semaphore İşlevleri


Shared Memory

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
    • Basic usage
  • Shared Memory İşlevleri
    • shmop_close — Close shared memory block
    • shmop_delete — Delete shared memory block
    • shmop_open — Create or open shared memory block
    • shmop_read — Read data from shared memory block
    • shmop_size — Get size of shared memory block
    • shmop_write — Write data into shared memory block
shm_remove
Giriş
Süreç Denetim Eklentileri


Giriş

Shmop is an easy to use set of functions that allows PHP to read, write, create and delete Unix shared memory segments.

Bilginize: Versions of Windows previous to Windows 2000 do not support shared memory.

Shared Memory
Yapılandırma/Kurulum
Shared Memory


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Shared Memory


Kurulum

To use shmop you will need to compile PHP with the --enable-shmop parameter in your configure line.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Özkaynak Türleri

As of PHP 7.0.0 this extension defines the resource type shmop which is a handle to a shared memory block.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
Örnekler
Shared Memory


Örnekler

İçindekiler

  • Basic usage
Öntanımlı Sabitler
Basic usage
Shared Memory


Basic usage

Örnek 1 Shared Memory Operations Overview

<?php

// Create 100 byte shared memory block with system id of 0xff3
$shm_id = shmop_open(0xff3, "c", 0644, 100);
if (!$shm_id) {
    echo "Couldn't create shared memory segment\n";
}

// Get shared memory block's size
$shm_size = shmop_size($shm_id);
echo "SHM Block Size: " . $shm_size . " has been created.\n";

// Lets write a test string into shared memory
$shm_bytes_written = shmop_write($shm_id, "my shared memory block", 0);
if ($shm_bytes_written != strlen("my shared memory block")) {
    echo "Couldn't write the entire length of data\n";
}

// Now lets read the string back
$my_string = shmop_read($shm_id, 0, $shm_size);
if (!$my_string) {
    echo "Couldn't read from shared memory block\n";
}
echo "The data inside shared memory was: " . $my_string . "\n";

//Now lets delete the block and close the shared memory segment
if (!shmop_delete($shm_id)) {
    echo "Couldn't mark shared memory block for deletion.";
}
shmop_close($shm_id);

?>

Örnekler
Shared Memory İşlevleri
Örnekler


Shared Memory İşlevleri

İçindekiler

  • shmop_close — Close shared memory block
  • shmop_delete — Delete shared memory block
  • shmop_open — Create or open shared memory block
  • shmop_read — Read data from shared memory block
  • shmop_size — Get size of shared memory block
  • shmop_write — Write data into shared memory block
Basic usage
shmop_close
Shared Memory


Close shared memory block

Shared Memory İşlevleri
shmop_delete
Shared Memory İşlevleri
PHP Manual

shmop_close

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

shmop_close — Close shared memory block

Açıklama

void shmop_close ( resource $shmid )

shmop_close() is used to close a shared memory block.

Değiştirgeler

shmid

The shared memory block resource created by shmop_open()

Dönen Değerler

Hiçbir değer dönmez.

Sürüm Bilgisi

Sürüm: | Açıklama
7.0.0 | The type of shmid has been changed from int to resource.

Örnekler

Örnek 1 Closing shared memory block

<?php
shmop_close($shm_id);
?>

This example will close shared memory block identified by $shm_id.

Ayrıca Bakınız

  • shmop_open() - Create or open shared memory block

Shared Memory İşlevleri
shmop_delete
Shared Memory İşlevleri


Delete shared memory block

shmop_close
shmop_open
Shared Memory İşlevleri
PHP Manual

shmop_delete

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

shmop_delete — Delete shared memory block

Açıklama

bool shmop_delete ( resource $shmid )

shmop_delete() is used to delete a shared memory block.

Değiştirgeler

shmid

The shared memory block resource created by shmop_open()

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
7.0.0 | The type of shmid has been changed from int to resource.

Örnekler

Örnek 1 Deleting shared memory block

<?php
shmop_delete($shm_id);
?>

This example will delete shared memory block identified by $shm_id.

shmop_close
shmop_open
Shared Memory İşlevleri


Create or open shared memory block

shmop_delete
shmop_read
Shared Memory İşlevleri
PHP Manual

shmop_open

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

shmop_open — Create or open shared memory block

Açıklama

resource shmop_open ( int $key , string $flags , int $mode , int $size )

shmop_open() can create or open a shared memory block.

Değiştirgeler

key

System's id for the shared memory block. Can be passed as a decimal or hex.

flags

The flags that you can use:

  • "a" for access (sets SHM_RDONLY for shmat) use this flag when you need to open an existing shared memory segment for read only
  • "c" for create (sets IPC_CREATE) use this flag when you need to create a new shared memory segment or if a segment with the same key exists, try to open it for read and write
  • "w" for read & write access use this flag when you need to read and write to a shared memory segment, use this flag in most cases.
  • "n" create a new memory segment (sets IPC_CREATE|IPC_EXCL) use this flag when you want to create a new shared memory segment but if one already exists with the same flag, fail. This is useful for security purposes, using this you can prevent race condition exploits.

mode

The permissions that you wish to assign to your memory segment, those are the same as permission for a file. Permissions need to be passed in octal form, like for example 0644

size

The size of the shared memory block you wish to create in bytes

Bilginize:

Note: the 3rd and 4th should be entered as 0 if you are opening an existing memory segment.

Dönen Değerler

On success shmop_open() will return an resource that you can use to access the shared memory segment you've created. FALSE is returned on failure.

Sürüm Bilgisi

Sürüm: | Açıklama
7.0.0 | The return type of shmop_open() has been changed from int to resource.

Örnekler

Örnek 1 Create a new shared memory block

<?php
$shm_key = ftok(__FILE__, 't');
$shm_id = shmop_open($shm_key, "c", 0644, 100);
?>

This example opened a shared memory block with a system id returned by ftok().

Ayrıca Bakınız

  • shmop_close() - Close shared memory block
  • shmop_delete() - Delete shared memory block

shmop_delete
shmop_read
Shared Memory İşlevleri


Read data from shared memory block

shmop_open
shmop_size
Shared Memory İşlevleri
PHP Manual

shmop_read

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

shmop_read — Read data from shared memory block

Açıklama

string shmop_read ( resource $shmid , int $start , int $count )

shmop_read() will read a string from shared memory block.

Değiştirgeler

shmid

The shared memory block identifier created by shmop_open()

start

Offset from which to start reading

count

The number of bytes to read

Dönen Değerler

Returns the data başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
7.0.0 | The type of shmid has been changed from int to resource.

Örnekler

Örnek 1 Reading shared memory block

<?php
$shm_data = shmop_read($shm_id, 0, 50);
?>

This example will read 50 bytes from shared memory block and place the data inside $shm_data.

Ayrıca Bakınız

  • shmop_write() - Write data into shared memory block

shmop_open
shmop_size
Shared Memory İşlevleri


Get size of shared memory block

shmop_read
shmop_write
Shared Memory İşlevleri
PHP Manual

shmop_size

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

shmop_size — Get size of shared memory block

Açıklama

int shmop_size ( resource $shmid )

shmop_size() is used to get the size, in bytes of the shared memory block.

Değiştirgeler

shmid

The shared memory block identifier created by shmop_open()

Dönen Değerler

Returns an int, which represents the number of bytes the shared memory block occupies.

Sürüm Bilgisi

Sürüm: | Açıklama
7.0.0 | The type of shmid has been changed from int to resource.

Örnekler

Örnek 1 Getting the size of the shared memory block

<?php
$shm_size = shmop_size($shm_id);
?>

This example will put the size of shared memory block identified by $shm_id into $shm_size.

shmop_read
shmop_write
Shared Memory İşlevleri


Write data into shared memory block

shmop_size
Sync
Shared Memory İşlevleri
PHP Manual

shmop_write

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

shmop_write — Write data into shared memory block

Açıklama

int shmop_write ( resource $shmid , string $data , int $offset )

shmop_write() will write a string into shared memory block.

Değiştirgeler

shmid

The shared memory block identifier created by shmop_open()

data

A string to write into shared memory block

offset

Specifies where to start writing data inside the shared memory segment.

Dönen Değerler

The size of the written data, or FALSE on failure.

Sürüm Bilgisi

Sürüm: | Açıklama
7.0.0 | The type of shmid has been changed from int to resource.

Örnekler

Örnek 1 Writing to shared memory block

<?php
$shm_bytes_written = shmop_write($shm_id, $my_string, 0);
?>

This example will write data inside $my_string into shared memory block, $shm_bytes_written will contain the number of bytes written.

Ayrıca Bakınız

  • shmop_read() - Read data from shared memory block

shmop_size
Sync
Shared Memory İşlevleri


Sync

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • SyncMutex — The SyncMutex class
    • SyncMutex::__construct — Constructs a new SyncMutex object
    • SyncMutex::lock — Waits for an exclusive lock
    • SyncMutex::unlock — Unlocks the mutex
  • SyncSemaphore — The SyncSemaphore class
    • SyncSemaphore::__construct — Constructs a new SyncSemaphore object
    • SyncSemaphore::lock — Decreases the count of the semaphore or waits
    • SyncSemaphore::unlock — Increases the count of the semaphore
  • SyncEvent — The SyncEvent class
    • SyncEvent::__construct — Constructs a new SyncEvent object
    • SyncEvent::fire — Fires/sets the event
    • SyncEvent::reset — Resets a manual event
    • SyncEvent::wait — Waits for the event to be fired/set
  • SyncReaderWriter — The SyncReaderWriter class
    • SyncReaderWriter::__construct — Constructs a new SyncReaderWriter object
    • SyncReaderWriter::readlock — Waits for a read lock
    • SyncReaderWriter::readunlock — Releases a read lock
    • SyncReaderWriter::writelock — Waits for an exclusive write lock
    • SyncReaderWriter::writeunlock — Releases a write lock
  • SyncSharedMemory — The SyncSharedMemory class
    • SyncSharedMemory::__construct — Constructs a new SyncSharedMemory object
    • SyncSharedMemory::first — Check to see if the object is the first instance system-wide of named shared memory
    • SyncSharedMemory::read — Copy data from named shared memory
    • SyncSharedMemory::size — Returns the size of the named shared memory
    • SyncSharedMemory::write — Copy data to named shared memory
shmop_write
Giriş
Süreç Denetim Eklentileri


Giriş

The 'sync' extension introduces cross-platform synchonization objects into PHP. Named and unnamed Mutex, Semaphore, Event, Reader-Writer, and named Shared Memory objects provide OS-level synchronization on both POSIX (e.g. Linux) and Windows platforms.

Automatic cleanup of acquired synchronization objects takes place during extension teardown. This means that if PHP prematurely terminates a script (e.g. script execution time is exceeded), objects will not be left in an unknown state. The only exception to this is if PHP itself crashes (e.g. an internal buffer overflow).

Unnamed synchronization objects don't have a lot of use outside of a multithreaded scenario. Unnamed objects are more useful in conjunction with the pthreads PECL extension.

Bilginize:

Named objects require additional care to be used on all systems. If an object is instantiated with a specific set of parameters, it must always be instantiated with those parameters or the object will probably end up in an inconsistent state until the next reboot or a system administrator cleans up the mess.

Sync
Yapılandırma/Kurulum
Sync


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Sync


Gereksinimler

A system with support for POSIX shared memory (shm_open()) or running Windows.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/sync.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
SyncMutex
Sync


The SyncMutex class

(PECL sync >= 1.0.0)

Giriş

A cross-platform, native implementation of named and unnamed countable mutex objects.

A mutex is a mutual exclusion object that restricts access to a shared resource (e.g. a file) to a single instance. Countable mutexes acquire the mutex a single time and internally track the number of times the mutex is locked. The mutex is unlocked as soon as it goes out of scope or is unlocked the same number of times that it was locked.

Sınıf Sözdizimi

SyncMutex {
/* Yöntemler */
public __construct ([ string $name ] )
public bool lock ([ integer $wait = -1 ] )
public bool unlock ([ bool $all = false ] )
}

İçindekiler

  • SyncMutex::__construct — Constructs a new SyncMutex object
  • SyncMutex::lock — Waits for an exclusive lock
  • SyncMutex::unlock — Unlocks the mutex
Öntanımlı Sabitler
SyncMutex::__construct
Sync


Constructs a new SyncMutex object

SyncMutex
SyncMutex::lock
SyncMutex
PHP Manual

SyncMutex::__construct

(PECL sync >= 1.0.0)

SyncMutex::__construct — Constructs a new SyncMutex object

Açıklama

public SyncMutex::__construct ([ string $name ] )

Constructs a named or unnamed countable mutex.

Değiştirgeler

name

The name of the mutex if this is a named mutex object.

Bilginize:

If the name already exists, it must be able to be opened by the current user that the process is running as or an exception will be thrown with a meaningless error message.

Dönen Değerler

The new SyncMutex object. An exception is thrown if the mutex cannot be created or opened.

Örnekler

Örnek 1 SyncMutex::__construct() named mutex with lock timeout example

<?php
$mutex = new SyncMutex("UniqueName");

if (!$mutex->lock(3000))
{
    echo "Unable to lock mutex.";

    exit();
}

/* ... */

$mutex->unlock();
?>

Örnek 2 SyncMutex::__construct() unnamed mutex example

<?php
$mutex = new SyncMutex();

$mutex->lock();

/* ... */

$mutex->unlock();
?>

Ayrıca Bakınız

  • SyncMutex::lock() - Waits for an exclusive lock
  • SyncMutex::unlock() - Unlocks the mutex
SyncMutex
SyncMutex::lock
SyncMutex


Waits for an exclusive lock

SyncMutex::__construct
SyncMutex::unlock
SyncMutex
PHP Manual

SyncMutex::lock

(PECL sync >= 1.0.0)

SyncMutex::lock — Waits for an exclusive lock

Açıklama

public bool SyncMutex::lock ([ integer $wait = -1 ] )

Obtains an exclusive lock on a SyncMutex object. If the lock is already acquired, then this increments an internal counter.

Değiştirgeler

wait

The number of milliseconds to wait for the exclusive lock. A value of -1 is infinite.

Dönen Değerler

A boolean of TRUE if the lock was obtained, FALSE otherwise.

Örnekler

Örnek 1 SyncMutex::lock() example

<?php
$mutex = new SyncMutex("UniqueName");

if (!$mutex->lock(3000))
{
    echo "Unable to lock mutex.";

    exit();
}

/* ... */

$mutex->unlock();
?>

Ayrıca Bakınız

  • SyncMutex::unlock() - Unlocks the mutex
SyncMutex::__construct
SyncMutex::unlock
SyncMutex


Unlocks the mutex

SyncMutex::lock
SyncSemaphore
SyncMutex
PHP Manual

SyncMutex::unlock

(PECL sync >= 1.0.0)

SyncMutex::unlock — Unlocks the mutex

Açıklama

public bool SyncMutex::unlock ([ bool $all = false ] )

Decreases the internal counter of a SyncMutex object. When the internal counter reaches zero, the actual lock on the object is released.

Değiştirgeler

all

Specifies whether or not to set the internal counter to zero and therefore release the lock.

Dönen Değerler

A boolean of TRUE if the unlock operation was successful, FALSE otherwise.

Örnekler

Örnek 1 SyncMutex::unlock() example

<?php
$mutex = new SyncMutex("UniqueName");

$mutex->lock();

/* ... */

$mutex->unlock();
?>

Ayrıca Bakınız

  • SyncMutex::lock() - Waits for an exclusive lock
SyncMutex::lock
SyncSemaphore
SyncMutex


The SyncSemaphore class

(PECL sync >= 1.0.0)

Giriş

A cross-platform, native implementation of named and unnamed sempahore objects.

A semaphore restricts access to a limited resource to a limited number of instances. Semaphores differ from mutexes in that they can allow more than one instance to access a resource at one time while a mutex only allows one instance at a time.

Sınıf Sözdizimi

SyncSemaphore {
/* Yöntemler */
public __construct ([ string $name [, integer $initialval = 1 [, bool $autounlock = true ]]] )
public bool lock ([ integer $wait = -1 ] )
public bool unlock ([ integer &$prevcount ] )
}

İçindekiler

  • SyncSemaphore::__construct — Constructs a new SyncSemaphore object
  • SyncSemaphore::lock — Decreases the count of the semaphore or waits
  • SyncSemaphore::unlock — Increases the count of the semaphore
SyncMutex::unlock
SyncSemaphore::__construct
Sync


Constructs a new SyncSemaphore object

SyncSemaphore
SyncSemaphore::lock
SyncSemaphore
PHP Manual

SyncSemaphore::__construct

(PECL sync >= 1.0.0)

SyncSemaphore::__construct — Constructs a new SyncSemaphore object

Açıklama

public SyncSemaphore::__construct ([ string $name [, integer $initialval = 1 [, bool $autounlock = true ]]] )

Constructs a named or unnamed semaphore.

Değiştirgeler

name

The name of the semaphore if this is a named semaphore object.

Bilginize:

If the name already exists, it must be able to be opened by the current user that the process is running as or an exception will be thrown with a meaningless error message.

initialval

The initial value of the semaphore. This is the number of locks that may be obtained.

autounlock

Specifies whether or not to automatically unlock the semaphore at the conclusion of the PHP script.

Uyarı

If an object is: A named semaphore with an autounlock of FALSE, the object is locked, and the PHP script concludes before the object is unlocked, then the underlying semaphore will end up in an inconsistent state.

Dönen Değerler

The new SyncSemaphore object. An exception is thrown if the semaphore cannot be created or opened.

Örnekler

Örnek 1 SyncSemaphore::__construct() example

<?php
$semaphore = new SyncSemaphore("LimitedResource_2clients", 2);

if (!$semaphore->lock(3000))
{
    echo "Unable to lock semaphore.";

    exit();
}

/* ... */

$semaphore->unlock();
?>

Ayrıca Bakınız

  • SyncSemaphore::lock() - Decreases the count of the semaphore or waits
  • SyncSemaphore::unlock() - Increases the count of the semaphore
SyncSemaphore
SyncSemaphore::lock
SyncSemaphore


Decreases the count of the semaphore or waits

SyncSemaphore::__construct
SyncSemaphore::unlock
SyncSemaphore
PHP Manual

SyncSemaphore::lock

(PECL sync >= 1.0.0)

SyncSemaphore::lock — Decreases the count of the semaphore or waits

Açıklama

public bool SyncSemaphore::lock ([ integer $wait = -1 ] )

Decreases the count of a SyncSemaphore object or waits until the semaphore becomes non-zero.

Değiştirgeler

wait

The number of milliseconds to wait for the semaphore. A value of -1 is infinite.

Dönen Değerler

A boolean of TRUE if the lock operation was successful, FALSE otherwise.

Örnekler

Örnek 1 SyncSemaphore::lock() example

<?php
$semaphore = new SyncSemaphore("LimitedResource_2clients", 2);

if (!$semaphore->lock(3000))
{
    echo "Unable to lock semaphore.";

    exit();
}

/* ... */

$semaphore->unlock();
?>

Ayrıca Bakınız

  • SyncSemaphore::unlock() - Increases the count of the semaphore
SyncSemaphore::__construct
SyncSemaphore::unlock
SyncSemaphore


Increases the count of the semaphore

SyncSemaphore::lock
SyncEvent
SyncSemaphore
PHP Manual

SyncSemaphore::unlock

(PECL sync >= 1.0.0)

SyncSemaphore::unlock — Increases the count of the semaphore

Açıklama

public bool SyncSemaphore::unlock ([ integer &$prevcount ] )

Increases the count of a SyncSemaphore object.

Değiştirgeler

prevcount

Returns the previous count of the semaphore.

Dönen Değerler

A boolean of TRUE if the unlock operation was successful, FALSE otherwise.

Örnekler

Örnek 1 SyncSemaphore::unlock() example

<?php
$semaphore = new SyncSemaphore("LimitedResource_2clients", 2);

if (!$semaphore->lock(3000))
{
    echo "Unable to lock semaphore.";

    exit();
}

/* ... */

$semaphore->unlock();
?>

Ayrıca Bakınız

  • SyncSemaphore::lock() - Decreases the count of the semaphore or waits
SyncSemaphore::lock
SyncEvent
SyncSemaphore


The SyncEvent class

(PECL sync >= 1.0.0)

Giriş

A cross-platform, native implementation of named and unnamed event objects. Both automatic and manual event objects are supported.

An event object waits, without polling, for the object to be fired/set. One instance waits on the event object while another instance fires/sets the event. Event objects are useful wherever a long-running process would otherwise poll a resource (e.g. checking to see if uploaded data needs to be processed).

Sınıf Sözdizimi

SyncEvent {
/* Yöntemler */
public __construct ([ string $name [, bool $manual = false [, bool $prefire = false ]]] )
public bool fire ( void )
public bool reset ( void )
public bool wait ([ integer $wait = -1 ] )
}

İçindekiler

  • SyncEvent::__construct — Constructs a new SyncEvent object
  • SyncEvent::fire — Fires/sets the event
  • SyncEvent::reset — Resets a manual event
  • SyncEvent::wait — Waits for the event to be fired/set
SyncSemaphore::unlock
SyncEvent::__construct
Sync


Constructs a new SyncEvent object

SyncEvent
SyncEvent::fire
SyncEvent
PHP Manual

SyncEvent::__construct

(PECL sync >= 1.0.0)

SyncEvent::__construct — Constructs a new SyncEvent object

Açıklama

public SyncEvent::__construct ([ string $name [, bool $manual = false [, bool $prefire = false ]]] )

Constructs a named or unnamed event object.

Değiştirgeler

name

The name of the event if this is a named event object.

Bilginize:

If the name already exists, it must be able to be opened by the current user that the process is running as or an exception will be thrown with a meaningless error message.

manual

Specifies whether or not the event object must be reset manually.

Bilginize:

Manual reset event objects allow all waiting processes through until the object is reset.

prefire

Specifies whether or not to prefire (signal) the event object.

Bilginize:

Only has impact if the calling process/thread is the first to create the object.

Dönen Değerler

The new SyncEvent object. An exception is thrown if the event object cannot be created or opened.

Örnekler

Örnek 1 SyncEvent::__construct() example

<?php
// In a web application:
$event = new SyncEvent("GetAppReport");
$event->fire();

// In a cron job:
$event = new SyncEvent("GetAppReport");
$event->wait();
?>

Sürüm Bilgisi

Sürüm: | Açıklama
1.1.0 | Added prefire.

Ayrıca Bakınız

  • SyncEvent::fire() - Fires/sets the event
  • SyncEvent::reset() - Resets a manual event
  • SyncEvent::wait() - Waits for the event to be fired/set
SyncEvent
SyncEvent::fire
SyncEvent


Fires/sets the event

SyncEvent::__construct
SyncEvent::reset
SyncEvent
PHP Manual

SyncEvent::fire

(PECL sync >= 1.0.0)

SyncEvent::fire — Fires/sets the event

Açıklama

public bool SyncEvent::fire ( void )

Fires/sets a SyncEvent object. Lets multiple threads through that are waiting if the event object was created with a manual value of TRUE.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A boolean of TRUE if the event was fired, FALSE otherwise.

Örnekler

Örnek 1 SyncEvent::fire() example

<?php
// In a web application:
$event = new SyncEvent("GetAppReport");
$event->fire();

// In a cron job:
$event = new SyncEvent("GetAppReport");
$event->wait();
?>

Ayrıca Bakınız

  • SyncEvent::reset() - Resets a manual event
  • SyncEvent::wait() - Waits for the event to be fired/set
SyncEvent::__construct
SyncEvent::reset
SyncEvent


Resets a manual event

SyncEvent::fire
SyncEvent::wait
SyncEvent
PHP Manual

SyncEvent::reset

(PECL sync >= 1.0.0)

SyncEvent::reset — Resets a manual event

Açıklama

public bool SyncEvent::reset ( void )

Resets a SyncEvent object that has been fired/set. Only valid for manual event objects.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A boolean value of TRUE if the object was successfully reset, FALSE otherwise.

Örnekler

Örnek 1 SyncEvent::reset() example

<?php
// In a web application:
$event = new SyncEvent("DemoApplication", true);
$event->wait();

// In a cron job:
$event = new SyncEvent("DemoApplication", true);
$event->reset();
/* ... Do some maintenance task(s) ... */
$event->fire();
?>

Ayrıca Bakınız

  • SyncEvent::fire() - Fires/sets the event
  • SyncEvent::reset()
  • SyncEvent::wait() - Waits for the event to be fired/set
SyncEvent::fire
SyncEvent::wait
SyncEvent


Waits for the event to be fired/set

SyncEvent::reset
SyncReaderWriter
SyncEvent
PHP Manual

SyncEvent::wait

(PECL sync >= 1.0.0)

SyncEvent::wait — Waits for the event to be fired/set

Açıklama

public bool SyncEvent::wait ([ integer $wait = -1 ] )

Waits for the SyncEvent object to be fired.

Değiştirgeler

wait

The number of milliseconds to wait for the event to be fired. A value of -1 is infinite.

Dönen Değerler

A boolean of TRUE if the event was fired, FALSE otherwise.

Örnekler

Örnek 1 SyncEvent::wait() example

<?php
// In a web application:
$event = new SyncEvent("GetAppReport");
$event->fire();

// In a cron job:
$event = new SyncEvent("GetAppReport");
$event->wait();
?>

Ayrıca Bakınız

  • SyncEvent::fire() - Fires/sets the event
SyncEvent::reset
SyncReaderWriter
SyncEvent


The SyncReaderWriter class

(PECL sync >= 1.0.0)

Giriş

A cross-platform, native implementation of named and unnamed reader-writer objects.

A reader-writer object allows many readers or one writer to access a resource. This is an efficient solution for managing resources where access will primarily be read-only but exclusive write access is occasionally necessary.

Sınıf Sözdizimi

SyncReaderWriter {
/* Yöntemler */
public __construct ([ string $name [, bool $autounlock = true ]] )
public bool readlock ([ integer $wait = -1 ] )
public bool readunlock ( void )
public bool writelock ([ integer $wait = -1 ] )
public bool writeunlock ( void )
}

İçindekiler

  • SyncReaderWriter::__construct — Constructs a new SyncReaderWriter object
  • SyncReaderWriter::readlock — Waits for a read lock
  • SyncReaderWriter::readunlock — Releases a read lock
  • SyncReaderWriter::writelock — Waits for an exclusive write lock
  • SyncReaderWriter::writeunlock — Releases a write lock
SyncEvent::wait
SyncReaderWriter::__construct
Sync


Constructs a new SyncReaderWriter object

SyncReaderWriter
SyncReaderWriter::readlock
SyncReaderWriter
PHP Manual

SyncReaderWriter::__construct

(PECL sync >= 1.0.0)

SyncReaderWriter::__construct — Constructs a new SyncReaderWriter object

Açıklama

public SyncReaderWriter::__construct ([ string $name [, bool $autounlock = true ]] )

Constructs a named or unnamed reader-writer object.

Değiştirgeler

name

The name of the reader-writer if this is a named reader-writer object.

Bilginize:

If the name already exists, it must be able to be opened by the current user that the process is running as or an exception will be thrown with a meaningless error message.

autounlock

Specifies whether or not to automatically unlock the reader-writer at the conclusion of the PHP script.

Uyarı

If an object is: A named reader-writer with an autounlock of FALSE, the object is locked for either reading or writing, and the PHP script concludes before the object is unlocked, then the underlying objects will end up in an inconsistent state.

Dönen Değerler

The new SyncReaderWriter object. An exception is thrown if the reader-writer cannot be created or opened.

Örnekler

Örnek 1 SyncReaderWriter::__construct() example

<?php
$readwrite = new SyncReaderWriter("FileCacheLock");
$readwrite->readlock();
/* ... */
$readwrite->readunlock();

$readwrite->writelock();
/* ... */
$readwrite->writeunlock();
?>

Ayrıca Bakınız

  • SyncReaderWriter::readlock() - Waits for a read lock
  • SyncReaderWriter::readunlock() - Releases a read lock
  • SyncReaderWriter::writelock() - Waits for an exclusive write lock
  • SyncReaderWriter::writeunlock() - Releases a write lock
SyncReaderWriter
SyncReaderWriter::readlock
SyncReaderWriter


Waits for a read lock

SyncReaderWriter::__construct
SyncReaderWriter::readunlock
SyncReaderWriter
PHP Manual

SyncReaderWriter::readlock

(PECL sync >= 1.0.0)

SyncReaderWriter::readlock — Waits for a read lock

Açıklama

public bool SyncReaderWriter::readlock ([ integer $wait = -1 ] )

Obtains a read lock on a SyncReaderWriter object.

Değiştirgeler

wait

The number of milliseconds to wait for a lock. A value of -1 is infinite.

Dönen Değerler

A boolean of TRUE if the lock was obtained, FALSE otherwise.

Örnekler

Örnek 1 SyncReaderWriter::readlock() example

<?php
$readwrite = new SyncReaderWriter("FileCacheLock");
$readwrite->readlock();
/* ... */
$readwrite->readunlock();
?>

Ayrıca Bakınız

  • SyncReaderWriter::readunlock() - Releases a read lock
SyncReaderWriter::__construct
SyncReaderWriter::readunlock
SyncReaderWriter


Releases a read lock

SyncReaderWriter::readlock
SyncReaderWriter::writelock
SyncReaderWriter
PHP Manual

SyncReaderWriter::readunlock

(PECL sync >= 1.0.0)

SyncReaderWriter::readunlock — Releases a read lock

Açıklama

public bool SyncReaderWriter::readunlock ( void )

Releases a read lock on a SyncReaderWriter object.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A boolean of TRUE if the unlock operation was successful, FALSE otherwise.

Örnekler

Örnek 1 SyncReaderWriter::readunlock() example

<?php
$readwrite = new SyncReaderWriter("FileCacheLock");
$readwrite->readlock();
/* ... */
$readwrite->readunlock();
?>

Ayrıca Bakınız

  • SyncReaderWriter::readlock() - Waits for a read lock
SyncReaderWriter::readlock
SyncReaderWriter::writelock
SyncReaderWriter


Waits for an exclusive write lock

SyncReaderWriter::readunlock
SyncReaderWriter::writeunlock
SyncReaderWriter
PHP Manual

SyncReaderWriter::writelock

(PECL sync >= 1.0.0)

SyncReaderWriter::writelock — Waits for an exclusive write lock

Açıklama

public bool SyncReaderWriter::writelock ([ integer $wait = -1 ] )

Obtains an exclusive write lock on a SyncReaderWriter object.

Değiştirgeler

wait

The number of milliseconds to wait for a lock. A value of -1 is infinite.

Dönen Değerler

A boolean of TRUE if the lock was obtained, FALSE otherwise.

Örnekler

Örnek 1 SyncReaderWriter::writelock() example

<?php
$readwrite = new SyncReaderWriter("FileCacheLock");
$readwrite->writelock();
/* ... */
$readwrite->writeunlock();
?>

Ayrıca Bakınız

  • SyncReaderWriter::writeunlock() - Releases a write lock
SyncReaderWriter::readunlock
SyncReaderWriter::writeunlock
SyncReaderWriter


Releases a write lock

SyncReaderWriter::writelock
SyncSharedMemory
SyncReaderWriter
PHP Manual

SyncReaderWriter::writeunlock

(PECL sync >= 1.0.0)

SyncReaderWriter::writeunlock — Releases a write lock

Açıklama

public bool SyncReaderWriter::writeunlock ( void )

Releases a write lock on a SyncReaderWriter object.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A boolean of TRUE if the unlock operation was successful, FALSE otherwise.

Örnekler

Örnek 1 SyncReaderWriter::writeunlock() example

<?php
$readwrite = new SyncReaderWriter("FileCacheLock");
$readwrite->writelock();
/* ... */
$readwrite->writeunlock();
?>

Ayrıca Bakınız

  • SyncReaderWriter::writelock() - Waits for an exclusive write lock
SyncReaderWriter::writelock
SyncSharedMemory
SyncReaderWriter


The SyncSharedMemory class

(PECL sync >= 1.1.0)

Giriş

A cross-platform, native, consistent implementation of named shared memory objects.

Shared memory lets two separate processes communicate without the need for complex pipes or sockets. There are several integer-based shared memory implementations for PHP. Named shared memory is an alternative.

Synchronization objects (e.g. SyncMutex) are still required to protect most uses of shared memory.

Sınıf Sözdizimi

SyncSharedMemory {
/* Yöntemler */
public __construct ( string $name , integer $size )
public bool first ( void )
public read ([ integer $start = 0 [, integer $length ]] )
public bool size ( void )
public write ([ string $string [, integer $start = 0 ]] )
}

İçindekiler

  • SyncSharedMemory::__construct — Constructs a new SyncSharedMemory object
  • SyncSharedMemory::first — Check to see if the object is the first instance system-wide of named shared memory
  • SyncSharedMemory::read — Copy data from named shared memory
  • SyncSharedMemory::size — Returns the size of the named shared memory
  • SyncSharedMemory::write — Copy data to named shared memory
SyncReaderWriter::writeunlock
SyncSharedMemory::__construct
Sync


Constructs a new SyncSharedMemory object

SyncSharedMemory
SyncSharedMemory::first
SyncSharedMemory
PHP Manual

SyncSharedMemory::__construct

(PECL sync >= 1.1.0)

SyncSharedMemory::__construct — Constructs a new SyncSharedMemory object

Açıklama

public SyncSharedMemory::__construct ( string $name , integer $size )

Constructs a named shared memory object.

Değiştirgeler

name

The name of the shared memory object.

Bilginize:

If the name already exists, it must be able to be opened by the current user that the process is running as or an exception will be thrown with a meaningless error message.

size

The size, in bytes, of shared memory to reserve.

Bilginize:

The amount of memory cannot be resized later. Request sufficient storage up front.

Dönen Değerler

The new SyncSharedMemory object. An exception is thrown if the shared memory object cannot be created or opened.

Örnekler

Örnek 1 SyncSharedMemory::__construct() example

<?php
// You will probably need to protect shared memory with other synchronization objects.
// Shared memory goes away when the last reference to it disappears.
$mem = new SyncSharedMemory("AppReportName", 1024);
if ($mem->first())
{
    // Do first time initialization work here.
}

$result = $mem->write(json_encode(array("name" => "my_report.txt")));
?>

Ayrıca Bakınız

  • SyncSharedMemory::first() - Check to see if the object is the first instance system-wide of named shared memory
  • SyncSharedMemory::size() - Returns the size of the named shared memory
  • SyncSharedMemory::write() - Copy data to named shared memory
  • SyncSharedMemory::read() - Copy data from named shared memory
SyncSharedMemory
SyncSharedMemory::first
SyncSharedMemory


Check to see if the object is the first instance system-wide of named shared memory

SyncSharedMemory::__construct
SyncSharedMemory::read
SyncSharedMemory
PHP Manual

SyncSharedMemory::first

(PECL sync >= 1.1.0)

SyncSharedMemory::first — Check to see if the object is the first instance system-wide of named shared memory

Açıklama

public bool SyncSharedMemory::first ( void )

Retrieves the system-wide first instance status of a SyncSharedMemory object.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A boolean of TRUE if the object is the first instance system-wide, FALSE otherwise.

Örnekler

Örnek 1 SyncSharedMemory::first() example

<?php
$mem = new SyncSharedMemory("AppReportName", 1024);
if ($mem->first())
{
    // Do first time initialization work here.
}

var_dump($mem->first());

$mem2 = new SyncSharedMemory("AppReportName", 1024);

var_dump($mem2->first());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(true)
bool(false)

Ayrıca Bakınız

  • SyncSharedMemory::write() - Copy data to named shared memory
  • SyncSharedMemory::read() - Copy data from named shared memory
SyncSharedMemory::__construct
SyncSharedMemory::read
SyncSharedMemory


Copy data from named shared memory

SyncSharedMemory::first
SyncSharedMemory::size
SyncSharedMemory
PHP Manual

SyncSharedMemory::read

(PECL sync >= 1.1.0)

SyncSharedMemory::read — Copy data from named shared memory

Açıklama

public SyncSharedMemory::read ([ integer $start = 0 [, integer $length ]] )

Copies data from named shared memory.

Değiştirgeler

start

The start/offset, in bytes, to begin reading.

Bilginize:

If the value is negative, the starting position will begin at the specified number of bytes from the end of the shared memory segment.

length

The number of bytes to read.

Bilginize:

If unspecified, reading will stop at the end of the shared memory segment.

If the value is negative, reading will stop the specified number of bytes from the end of the shared memory segment.

Dönen Değerler

A string containing the data read from shared memory.

Örnekler

Örnek 1 SyncSharedMemory::__construct() example

<?php
// You will probably need to protect shared memory with other synchronization objects.
// Shared memory goes away when the last reference to it disappears.
$mem = new SyncSharedMemory("AppReportName", 1024);
if ($mem->first())
{
    // Do first time initialization work here.
}

$result = $mem->write("report.txt");

$result = $mem->read(3, -4);
var_dump($result);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(3) "ort"

Ayrıca Bakınız

  • SyncSharedMemory::__construct() - Constructs a new SyncSharedMemory object
  • SyncSharedMemory::first() - Check to see if the object is the first instance system-wide of named shared memory
  • SyncSharedMemory::write() - Copy data to named shared memory
  • SyncSharedMemory::read()
SyncSharedMemory::first
SyncSharedMemory::size
SyncSharedMemory


Returns the size of the named shared memory

SyncSharedMemory::read
SyncSharedMemory::write
SyncSharedMemory
PHP Manual

SyncSharedMemory::size

(PECL sync >= 1.1.0)

SyncSharedMemory::size — Returns the size of the named shared memory

Açıklama

public bool SyncSharedMemory::size ( void )

Retrieves the shared memory size of a SyncSharedMemory object.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

An integer containing the size of the shared memory. This will be the same size that was passed to the constructor.

Örnekler

Örnek 1 SyncSharedMemory::size() example

<?php
$mem = new SyncSharedMemory("AppReportName", 1024);
var_dump($mem->size());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(1024)

Ayrıca Bakınız

  • SyncSharedMemory::__construct() - Constructs a new SyncSharedMemory object
  • SyncSharedMemory::write() - Copy data to named shared memory
  • SyncSharedMemory::read() - Copy data from named shared memory
SyncSharedMemory::read
SyncSharedMemory::write
SyncSharedMemory


Copy data to named shared memory

SyncSharedMemory::size
Diğer Temel Eklentiler
SyncSharedMemory
PHP Manual

SyncSharedMemory::write

(PECL sync >= 1.1.0)

SyncSharedMemory::write — Copy data to named shared memory

Açıklama

public SyncSharedMemory::write ([ string $string [, integer $start = 0 ]] )

Copies data to named shared memory.

Değiştirgeler

string

The data to write to shared memoy.

Bilginize:

If the size of the data exceeds the size of the shared memory, the number of bytes written returned will be less than the length of the input.

start

The start/offset, in bytes, to begin writing.

Bilginize:

If the value is negative, the starting position will begin at the specified number of bytes from the end of the shared memory segment.

Dönen Değerler

An integer containing the number of bytes written to shared memory.

Örnekler

Örnek 1 SyncSharedMemory::write() example

<?php
// You will probably need to protect shared memory with other synchronization objects.
// Shared memory goes away when the last reference to it disappears.
$mem = new SyncSharedMemory("AppReportName", 1024);
if ($mem->first())
{
    // Do first time initialization work here.
}

$result = $mem->write("report.txt");
var_dump($result);

$result = $mem->write("report.txt", -3);
var_dump($result);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(10)
int(3)

Ayrıca Bakınız

  • SyncSharedMemory::__construct() - Constructs a new SyncSharedMemory object
  • SyncSharedMemory::first() - Check to see if the object is the first instance system-wide of named shared memory
  • SyncSharedMemory::write()
  • SyncSharedMemory::read() - Copy data from named shared memory
SyncSharedMemory::size
Diğer Temel Eklentiler
SyncSharedMemory


Diğer Temel Eklentiler

  • GeoIP — Geo IP Location
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • GeoIP İşlevleri
  • FANN — FANN (Fast Artificial Neural Network)
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • Fann İşlevleri
    • FANNConnection — The FANNConnection class
  • JSON — JavaScript Nesne Bildirimi
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • JSON İşlevleri
  • Judy — Judy Arrays
    • Giriş
    • Yapılandırma/Kurulum
    • Judy — The Judy class
    • Judy İşlevleri
  • Lua
    • Giriş
    • Yapılandırma/Kurulum
    • Lua — The Lua class
    • LuaClosure — The LuaClosure class
  • Muhtelif — Çeşitli İşlevler
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Çeşitli İşlevler
  • Parsekit
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Parsekit İşlevleri
  • SPL — Standard PHP Library (SPL)
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Datastructures
    • Iterators
    • Interfaces
    • Exceptions
    • SPL İşlevleri
    • File Handling
    • Miscellaneous Classes and Interfaces
  • SPL Types — SPL Type Handling
    • Giriş
    • Yapılandırma/Kurulum
    • SplType — The SplType class
    • SplInt — The SplInt class
    • SplFloat — The SplFloat class
    • SplEnum — The SplEnum class
    • SplBool — The SplBool class
    • SplString — The SplString class
  • Akımlar
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Akım Süzgeçleri
    • Akım Bağlamları
    • Akım Hataları
    • Örnekler
    • streamWrapper — streamWrapper sınıfı
    • Akım İşlevleri
  • Tidy
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • Tidy — Tidy sınıfı
    • TidyNode — TidyNode sınıfı
    • Tidy İşlevleri
  • Simgeleştirici
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • Simgeleştirici İşlevleri
  • URL'ler
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • URL İşlevleri
  • V8js — V8 Javascript Engine Integration
    • Giriş
    • Yapılandırma/Kurulum
    • Örnekler
    • V8Js — The V8Js class
    • V8JsException — The V8JsException class
  • Yaml — YAML Data Serialization
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • Callbacks
    • Yaml İşlevleri
  • Yaf — Yet Another Framework
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • Application Configuration
    • Yaf_Application — The Yaf_Application class
    • Yaf_Bootstrap_Abstract — The Yaf_Bootstrap_Abstract class
    • Yaf_Dispatcher — The Yaf_Dispatcher class
    • Yaf_Config_Abstract — The Yaf_Config_Abstract class
    • Yaf_Config_Ini — The Yaf_Config_Ini class
    • Yaf_Config_Simple — The Yaf_Config_Simple class
    • Yaf_Controller_Abstract — The Yaf_Controller_Abstract class
    • Yaf_Action_Abstract — The Yaf_Action_Abstract class
    • Yaf_View_Interface — The Yaf_View_Interface class
    • Yaf_View_Simple — The Yaf_View_Simple class
    • Yaf_Loader — The Yaf_Loader class
    • Yaf_Plugin_Abstract — The Yaf_Plugin_Abstract class
    • Yaf_Registry — The Yaf_Registry class
    • Yaf_Request_Abstract — The Yaf_Request_Abstract class
    • Yaf_Request_Http — The Yaf_Request_Http class
    • Yaf_Request_Simple — The Yaf_Request_Simple class
    • Yaf_Response_Abstract — The Yaf_Response_Abstract class
    • Yaf_Route_Interface — The Yaf_Route_Interface class
    • Yaf_Route_Map — The Yaf_Route_Map class
    • Yaf_Route_Regex — The Yaf_Route_Regex class
    • Yaf_Route_Rewrite — The Yaf_Route_Rewrite class
    • Yaf_Router — The Yaf_Router class
    • Yaf_Route_Simple — The Yaf_Route_Simple class
    • Yaf_Route_Static — The Yaf_Route_Static class
    • Yaf_Route_Supervar — The Yaf_Route_Supervar class
    • Yaf_Session — The Yaf_Session class
    • Yaf_Exception — The Yaf_Exception class
    • Yaf_Exception_TypeError — The Yaf_Exception_TypeError class
    • Yaf_Exception_StartupError — The Yaf_Exception_StartupError class
    • Yaf_Exception_DispatchFailed — The Yaf_Exception_DispatchFailed class
    • Yaf_Exception_RouterFailed — The Yaf_Exception_RouterFailed class
    • Yaf_Exception_LoadFailed — The Yaf_Exception_LoadFailed class
    • Yaf_Exception_LoadFailed_Module — The Yaf_Exception_LoadFailed_Module class
    • Yaf_Exception_LoadFailed_Controller — The Yaf_Exception_LoadFailed_Controller class
    • Yaf_Exception_LoadFailed_Action — The Yaf_Exception_LoadFailed_Action class
    • Yaf_Exception_LoadFailed_View — The Yaf_Exception_LoadFailed_View class
  • Taint
    • Giriş
    • Yapılandırma/Kurulum
    • More Details
    • Taint İşlevleri
SyncSharedMemory::write
GeoIP
İşlev Başvuru Kılavuzu


Geo IP Location

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • GeoIP İşlevleri
    • geoip_asnum_by_name — Get the Autonomous System Numbers (ASN)
    • geoip_continent_code_by_name — Get the two letter continent code
    • geoip_country_code_by_name — Get the two letter country code
    • geoip_country_code3_by_name — Get the three letter country code
    • geoip_country_name_by_name — Get the full country name
    • geoip_database_info — Get GeoIP Database information
    • geoip_db_avail — Determine if GeoIP Database is available
    • geoip_db_filename — Returns the filename of the corresponding GeoIP Database
    • geoip_db_get_all_info — Returns detailed information about all GeoIP database types
    • geoip_domain_by_name — Get the second level domain name
    • geoip_id_by_name — Get the Internet connection type
    • geoip_isp_by_name — Get the Internet Service Provider (ISP) name
    • geoip_netspeedcell_by_name — Get the Internet connection speed
    • geoip_org_by_name — Get the organization name
    • geoip_record_by_name — Returns the detailed City information found in the GeoIP Database
    • geoip_region_by_name — Get the country code and region
    • geoip_region_name_by_code — Returns the region name for some country and region code combo
    • geoip_setup_custom_directory — Set a custom directory for the GeoIP database.
    • geoip_time_zone_by_country_and_region — Returns the time zone for some country and region code combo
Diğer Temel Eklentiler
Giriş
Diğer Temel Eklentiler


Giriş

The GeoIP extension allows you to find the location of an IP address. City, State, Country, Longitude, Latitude, and other information as all, such as ISP and connection type can be obtained with the help of GeoIP.

GeoIP
Yapılandırma/Kurulum
GeoIP


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
GeoIP


Gereksinimler

This extension requires the GeoIP C library version 1.4.0 or higher to be installed. You can grab the latest version from » http://www.maxmind.com/app/c and compile it yourself.

By default, you will only have access to the Free GeoIP Country or GeoLite City databases. While this module can work with other types of database, you must buy a commercial license from » Maxmind.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu » PECL eklentisi PHP ile gelmez.

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/geoip.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

GeoIP Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
geoip.custom_directory | "" | PHP_INI_ALL |

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

geoip.custom_directory string

Empty by default, but can be set to force a different database path than the one compiled in the library.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

GEOIP_COUNTRY_EDITION (integer)
GEOIP_REGION_EDITION_REV0 (integer)
GEOIP_CITY_EDITION_REV0 (integer)
GEOIP_ORG_EDITION (integer)
GEOIP_ISP_EDITION (integer)
GEOIP_CITY_EDITION_REV1 (integer)
GEOIP_REGION_EDITION_REV1 (integer)
GEOIP_PROXY_EDITION (integer)
GEOIP_ASNUM_EDITION (integer)
GEOIP_NETSPEED_EDITION (integer)
GEOIP_DOMAIN_EDITION (integer)

The following constants are for net speed:

GEOIP_UNKNOWN_SPEED (integer)
GEOIP_DIALUP_SPEED (integer)
GEOIP_CABLEDSL_SPEED (integer)
GEOIP_CORPORATE_SPEED (integer)
Özkaynak Türleri
GeoIP İşlevleri
GeoIP


GeoIP İşlevleri

İçindekiler

  • geoip_asnum_by_name — Get the Autonomous System Numbers (ASN)
  • geoip_continent_code_by_name — Get the two letter continent code
  • geoip_country_code_by_name — Get the two letter country code
  • geoip_country_code3_by_name — Get the three letter country code
  • geoip_country_name_by_name — Get the full country name
  • geoip_database_info — Get GeoIP Database information
  • geoip_db_avail — Determine if GeoIP Database is available
  • geoip_db_filename — Returns the filename of the corresponding GeoIP Database
  • geoip_db_get_all_info — Returns detailed information about all GeoIP database types
  • geoip_domain_by_name — Get the second level domain name
  • geoip_id_by_name — Get the Internet connection type
  • geoip_isp_by_name — Get the Internet Service Provider (ISP) name
  • geoip_netspeedcell_by_name — Get the Internet connection speed
  • geoip_org_by_name — Get the organization name
  • geoip_record_by_name — Returns the detailed City information found in the GeoIP Database
  • geoip_region_by_name — Get the country code and region
  • geoip_region_name_by_code — Returns the region name for some country and region code combo
  • geoip_setup_custom_directory — Set a custom directory for the GeoIP database.
  • geoip_time_zone_by_country_and_region — Returns the time zone for some country and region code combo
Öntanımlı Sabitler
geoip_asnum_by_name
GeoIP


Get the Autonomous System Numbers (ASN)

GeoIP İşlevleri
geoip_continent_code_by_name
GeoIP İşlevleri
PHP Manual

geoip_asnum_by_name

(PECL geoip >= 1.1.0)

geoip_asnum_by_name — Get the Autonomous System Numbers (ASN)

Açıklama

string geoip_asnum_by_name ( string $hostname )

The geoip_asnum_by_name() function will return the Autonomous System Numbers (ASN) associated with an IP address.

Değiştirgeler

hostname

The hostname or IP address.

Dönen Değerler

Returns the ASN on success, or FALSE if the address cannot be found in the database.

Örnekler

Örnek 1 A geoip_asnum_by_name() example

This will output the ASN of the host www.example.com.

<?php
$asn = geoip_asnum_by_name('www.example.com');

if ($asn) {
    echo 'The ASN is: ' $asn;
}
?>

Yukarıdaki örneğin çıktısı:

The ASN is: AS15133 EdgeCast Networks, Inc

GeoIP İşlevleri
geoip_continent_code_by_name
GeoIP İşlevleri


Get the two letter continent code

geoip_asnum_by_name
geoip_country_code_by_name
GeoIP İşlevleri
PHP Manual

geoip_continent_code_by_name

(PECL geoip >= 1.0.3)

geoip_continent_code_by_name — Get the two letter continent code

Açıklama

string geoip_continent_code_by_name ( string $hostname )

The geoip_continent_code_by_name() function will return the two letter continent code corresponding to a hostname or an IP address.

Değiştirgeler

hostname

The hostname or IP address whose location is to be looked-up.

Dönen Değerler

Returns the two letter continent code on success, or FALSE if the address cannot be found in the database.

Continent codes
Code | Continent name
AF | Africa
AN | Antarctica
AS | Asia
EU | Europe
NA | North america
OC | Oceania
SA | South america

Örnekler

Örnek 1 A geoip_continent_code_by_name() example

This will print where the host example.com is located.

<?php
$continent = geoip_continent_code_by_name('www.example.com');
if ($continent) {
    echo 'This host is located in: ' . $continent;
}
?>

Yukarıdaki örneğin çıktısı:

 This host is located in: NA

Ayrıca Bakınız

  • geoip_country_code_by_name() - Get the two letter country code

geoip_asnum_by_name
geoip_country_code_by_name
GeoIP İşlevleri


Get the two letter country code

geoip_continent_code_by_name
geoip_country_code3_by_name
GeoIP İşlevleri
PHP Manual

geoip_country_code_by_name

(PECL geoip >= 0.2.0)

geoip_country_code_by_name — Get the two letter country code

Açıklama

string geoip_country_code_by_name ( string $hostname )

The geoip_country_code_by_name() function will return the two letter country code corresponding to a hostname or an IP address.

Değiştirgeler

hostname

The hostname or IP address whose location is to be looked-up.

Dönen Değerler

Returns the two letter ISO country code on success, or FALSE if the address cannot be found in the database.

Örnekler

Örnek 1 A geoip_country_code_by_name() example

This will print where the host example.com is located.

<?php
$country = geoip_country_code_by_name('www.example.com');
if ($country) {
    echo 'This host is located in: ' . $country;
}
?>

Yukarıdaki örneğin çıktısı:

This host is located in: US

Notlar

Dikkat

Please see » http://www.maxmind.com/en/iso3166 for a complete list of possible return values, including special codes.

Ayrıca Bakınız

  • geoip_country_code3_by_name() - Get the three letter country code
  • geoip_country_name_by_name() - Get the full country name

geoip_continent_code_by_name
geoip_country_code3_by_name
GeoIP İşlevleri


Get the three letter country code

geoip_country_code_by_name
geoip_country_name_by_name
GeoIP İşlevleri
PHP Manual

geoip_country_code3_by_name

(PECL geoip >= 0.2.0)

geoip_country_code3_by_name — Get the three letter country code

Açıklama

string geoip_country_code3_by_name ( string $hostname )

The geoip_country_code3_by_name() function will return the three letter country code corresponding to a hostname or an IP address.

Değiştirgeler

hostname

The hostname or IP address whose location is to be looked-up.

Dönen Değerler

Returns the three letter country code on success, or FALSE if the address cannot be found in the database.

Örnekler

Örnek 1 A geoip_country_code3_by_name() example

This will print where the host example.com is located.

<?php
$country = geoip_country_code3_by_name('www.example.com');
if ($country) {
    echo 'This host is located in: ' . $country;
}
?>

Yukarıdaki örneğin çıktısı:

This host is located in: USA

Ayrıca Bakınız

  • geoip_country_code_by_name() - Get the two letter country code
  • geoip_country_name_by_name() - Get the full country name

geoip_country_code_by_name
geoip_country_name_by_name
GeoIP İşlevleri


Get the full country name

geoip_country_code3_by_name
geoip_database_info
GeoIP İşlevleri
PHP Manual

geoip_country_name_by_name

(PECL geoip >= 0.2.0)

geoip_country_name_by_name — Get the full country name

Açıklama

string geoip_country_name_by_name ( string $hostname )

The geoip_country_name_by_name() function will return the full country name corresponding to a hostname or an IP address.

Değiştirgeler

hostname

The hostname or IP address whose location is to be looked-up.

Dönen Değerler

Returns the country name on success, or FALSE if the address cannot be found in the database.

Örnekler

Örnek 1 A geoip_country_name_by_name() example

This will print where the host example.com is located.

<?php
$country = geoip_country_name_by_name('www.example.com');
if ($country) {
    echo 'This host is located in: ' . $country;
}
?>

Yukarıdaki örneğin çıktısı:

 This host is located in: United States

Ayrıca Bakınız

  • geoip_country_code_by_name() - Get the two letter country code
  • geoip_country_code3_by_name() - Get the three letter country code

geoip_country_code3_by_name
geoip_database_info
GeoIP İşlevleri


Get GeoIP Database information

geoip_country_name_by_name
geoip_db_avail
GeoIP İşlevleri
PHP Manual

geoip_database_info

(PECL geoip >= 0.2.0)

geoip_database_info — Get GeoIP Database information

Açıklama

string geoip_database_info ([ int $database = GEOIP_COUNTRY_EDITION ] )

The geoip_database_info() function returns the corresponding GeoIP Database version as it is defined inside the binary file.

If this function is called without arguments, it returns the version of the GeoIP Free Country Edition.

Değiştirgeler

database

The database type as an integer. You can use the various constants defined with this extension (ie: GEOIP_*_EDITION).

Dönen Değerler

Returns the corresponding database version, or NULL on error.

Örnekler

Örnek 1 A geoip_database_info() example

This will output information regarding the database.

<?php
print geoip_database_info(GEOIP_COUNTRY_EDITION);
?>

Yukarıdaki örneğin çıktısı:

GEO-106FREE 20060801 Build 1 Copyright (c) 2006 MaxMind LLC All Rights Reserved

geoip_country_name_by_name
geoip_db_avail
GeoIP İşlevleri


Determine if GeoIP Database is available

geoip_database_info
geoip_db_filename
GeoIP İşlevleri
PHP Manual

geoip_db_avail

(PECL geoip >= 1.0.1)

geoip_db_avail — Determine if GeoIP Database is available

Açıklama

bool geoip_db_avail ( int $database )

The geoip_db_avail() function returns if the corresponding GeoIP Database is available and can be opened on disk.

It does not indicate if the file is a proper database, only if it is readable.

Değiştirgeler

database

The database type as an integer. You can use the various constants defined with this extension (ie: GEOIP_*_EDITION).

Dönen Değerler

Returns TRUE is database exists, FALSE if not found, or NULL on error.

Örnekler

Örnek 1 A geoip_db_avail() example

This will output the current database version string.

<?php

if (geoip_db_avail(GEOIP_COUNTRY_EDITION))
    print geoip_database_info(GEOIP_COUNTRY_EDITION);
?>

Yukarıdaki örneğin çıktısı:

GEO-106FREE 20080801 Build 1 Copyright (c) 2006 MaxMind LLC All Rights Reserved

geoip_database_info
geoip_db_filename
GeoIP İşlevleri


Returns the filename of the corresponding GeoIP Database

geoip_db_avail
geoip_db_get_all_info
GeoIP İşlevleri
PHP Manual

geoip_db_filename

(PECL geoip >= 1.0.1)

geoip_db_filename — Returns the filename of the corresponding GeoIP Database

Açıklama

string geoip_db_filename ( int $database )

The geoip_db_filename() function returns the filename of the corresponding GeoIP Database.

It does not indicate if the file exists or not on disk, only where the library is looking for the database.

Değiştirgeler

database

The database type as an integer. You can use the various constants defined with this extension (ie: GEOIP_*_EDITION).

Dönen Değerler

Returns the filename of the corresponding database, or NULL on error.

Örnekler

Örnek 1 A geoip_db_filename() example

This will output the filename of the corresponding database.

<?php

print geoip_db_filename(GEOIP_COUNTRY_EDITION);

?>

Yukarıdaki örneğin çıktısı:

/usr/share/GeoIP/GeoIP.dat

geoip_db_avail
geoip_db_get_all_info
GeoIP İşlevleri


Returns detailed information about all GeoIP database types

geoip_db_filename
geoip_domain_by_name
GeoIP İşlevleri
PHP Manual

geoip_db_get_all_info

(PECL geoip >= 1.0.1)

geoip_db_get_all_info — Returns detailed information about all GeoIP database types

Açıklama

array geoip_db_get_all_info ( void )

The geoip_db_get_all_info() function will return detailed information as a multi-dimensional array about all the GeoIP database types.

This function is available even if no databases are installed. It will simply list them as non-available.

The names of the different keys of the returning associative array are as follows:

  • "available" -- Boolean, indicate if DB is available (see geoip_db_avail())
  • "description" -- The database description
  • "filename" -- The database filename on disk (see geoip_db_filename())

Dönen Değerler

Returns the associative array.

Örnekler

Örnek 1 A geoip_db_get_all_info() example

This will print the array containing all the information.

<?php
$infos = geoip_db_get_all_info();
if (is_array($infos)) {
    var_dump($infos);
}
?>

Yukarıdaki örneğin çıktısı:

array(11) {
  [1]=>
  array(3) {
    ["available"]=>
    bool(true)
    ["description"]=>
    string(21) "GeoIP Country Edition"
    ["filename"]=>
    string(32) "/usr/share/GeoIP/GeoIP.dat"
  }

[ ... ]

  [11]=>
  array(3) {
    ["available"]=>
    bool(false)
    ["description"]=>
    string(25) "GeoIP Domain Name Edition"
    ["filename"]=>
    string(38) "/usr/share/GeoIP/GeoIPDomain.dat"
  }
}

Örnek 2 A geoip_db_get_all_info() example

You can use the various constants as keys to get only parts of the information.

<?php
$infos = geoip_db_get_all_info();
if ($infos[GEOIP_COUNTRY_EDITION]['available']) {
    echo $infos[GEOIP_COUNTRY_EDITION]['description'];
}
?>

Yukarıdaki örneğin çıktısı:

GeoIP Country Edition

geoip_db_filename
geoip_domain_by_name
GeoIP İşlevleri


Get the second level domain name

geoip_db_get_all_info
geoip_id_by_name
GeoIP İşlevleri
PHP Manual

geoip_domain_by_name

(PECL geoip >= 1.1.0)

geoip_domain_by_name — Get the second level domain name

Açıklama

string geoip_domain_by_name ( string $hostname )

The geoip_domain_by_name() function will return the second level domain names associated with a hostname or an IP address.

This function is currently only available to users who have bought a commercial GeoIP Domain Edition. A warning will be issued if the proper database cannot be located.

Değiştirgeler

hostname

The hostname or IP address.

Dönen Değerler

Returns the domain name on success, or FALSE if the address cannot be found in the database.

Örnekler

Örnek 1 A geoip_domain_by_name() example

This will output the domain associated with IP 61.106.139.1.

<?php
$domain = geoip_domain_by_name('61.106.139.1');

if ($domain) {
    echo 'The domain is: '. $domain;
}

?>

Yukarıdaki örneğin çıktısı:

The domain is: von.co.kr

geoip_db_get_all_info
geoip_id_by_name
GeoIP İşlevleri


Get the Internet connection type

geoip_domain_by_name
geoip_isp_by_name
GeoIP İşlevleri
PHP Manual

geoip_id_by_name

(PECL geoip >= 0.2.0)

geoip_id_by_name — Get the Internet connection type

Açıklama

int geoip_id_by_name ( string $hostname )

The geoip_id_by_name() function will return the Internet connection type corresponding to a hostname or an IP address.

The return value is numeric and can be compared to the following constants:

  • GEOIP_UNKNOWN_SPEED
  • GEOIP_DIALUP_SPEED
  • GEOIP_CABLEDSL_SPEED
  • GEOIP_CORPORATE_SPEED

Değiştirgeler

hostname

The hostname or IP address whose connection type is to be looked-up.

Dönen Değerler

Returns the connection type.

Örnekler

Örnek 1 A geoip_id_by_name() example

This will output the connection type of the host example.com.

<?php
$netspeed = geoip_id_by_name('www.example.com');

echo 'The connection type is ';

switch ($netspeed) {
    case GEOIP_DIALUP_SPEED:
        echo 'dial-up';
        break;
    case GEOIP_CABLEDSL_SPEED:
        echo 'cable or DSL';
        break;
    case GEOIP_CORPORATE_SPEED:
        echo 'corporate';
        break;
    case GEOIP_UNKNOWN_SPEED:
    default:
        echo 'unknown';
}
?>

Yukarıdaki örneğin çıktısı:

The connection type is corporate

geoip_domain_by_name
geoip_isp_by_name
GeoIP İşlevleri


Get the Internet Service Provider (ISP) name

geoip_id_by_name
geoip_netspeedcell_by_name
GeoIP İşlevleri
PHP Manual

geoip_isp_by_name

(PECL geoip >= 1.0.2)

geoip_isp_by_name — Get the Internet Service Provider (ISP) name

Açıklama

string geoip_isp_by_name ( string $hostname )

The geoip_isp_by_name() function will return the name of the Internet Service Provider (ISP) that an IP is assigned to.

This function is currently only available to users who have bought a commercial GeoIP ISP Edition. A warning will be issued if the proper database cannot be located.

Değiştirgeler

hostname

The hostname or IP address.

Dönen Değerler

Returns the ISP name on success, or FALSE if the address cannot be found in the database.

Örnekler

Örnek 1 A geoip_isp_by_name() example

This will print the ISP name of host example.com.

<?php
$isp = geoip_isp_by_name('www.example.com');
if ($isp) {
    echo 'This host IP is from ISP: ' . $isp;
}
?>

Yukarıdaki örneğin çıktısı:

This host IP is from ISP: ICANN c/o Internet Assigned Numbers Authority

geoip_id_by_name
geoip_netspeedcell_by_name
GeoIP İşlevleri


Get the Internet connection speed

geoip_isp_by_name
geoip_org_by_name
GeoIP İşlevleri
PHP Manual

geoip_netspeedcell_by_name

(PECL geoip >= 1.1.0)

geoip_netspeedcell_by_name — Get the Internet connection speed

Açıklama

string geoip_netspeedcell_by_name ( string $hostname )

The geoip_netspeedcell_by_name() function will return the Internet connection type and speed corresponding to a hostname or an IP address.

This function is only available if using GeoIP Library version 1.4.8 or newer.

This function is currently only available to users who have bought a commercial GeoIP NetSpeedCell Edition. A warning will be issued if the proper database cannot be located.

The return value is a string, common values are:

  • Cable/DSL
  • Dialup
  • Cellular
  • Corporate

Değiştirgeler

hostname

The hostname or IP address.

Dönen Değerler

Returns the connection speed on success, or FALSE if the address cannot be found in the database.

Örnekler

Örnek 1 A geoip_netspeedcell_by_name() example

This will output the connection speed of the host example.com.

<?php
$netspeed = geoip_netspeedcell_by_name('www.example.com');

if ($netspeed) {
    echo 'The connection type is: '. $netspeed;
}
?>

Yukarıdaki örneğin çıktısı:

The connection type is: Corporate

geoip_isp_by_name
geoip_org_by_name
GeoIP İşlevleri


Get the organization name

geoip_netspeedcell_by_name
geoip_record_by_name
GeoIP İşlevleri
PHP Manual

geoip_org_by_name

(PECL geoip >= 0.2.0)

geoip_org_by_name — Get the organization name

Açıklama

string geoip_org_by_name ( string $hostname )

The geoip_org_by_name() function will return the name of the organization that an IP is assigned to.

This function is currently only available to users who have bought a commercial GeoIP Organization, ISP or AS Edition. A warning will be issued if the proper database cannot be located.

Değiştirgeler

hostname

The hostname or IP address.

Dönen Değerler

Returns the organization name on success, or FALSE if the address cannot be found in the database.

Örnekler

Örnek 1 A geoip_org_by_name() example

This will print to whom the host example.com IP is allocated.

<?php
$org = geoip_org_by_name('www.example.com');
if ($org) {
    echo 'This host IP is allocated to: ' . $org;
}
?>

Yukarıdaki örneğin çıktısı:

This host IP is allocated to: ICANN c/o Internet Assigned Numbers Authority

geoip_netspeedcell_by_name
geoip_record_by_name
GeoIP İşlevleri


Returns the detailed City information found in the GeoIP Database

geoip_org_by_name
geoip_region_by_name
GeoIP İşlevleri
PHP Manual

geoip_record_by_name

(PECL geoip >= 0.2.0)

geoip_record_by_name — Returns the detailed City information found in the GeoIP Database

Açıklama

array geoip_record_by_name ( string $hostname )

The geoip_record_by_name() function will return the record information corresponding to a hostname or an IP address.

This function is available for both GeoLite City Edition and commercial GeoIP City Edition. A warning will be issued if the proper database cannot be located.

The names of the different keys of the returning associative array are as follows:

  • "continent_code" -- Two letter continent code (as of version 1.0.4 with libgeoip 1.4.3 or newer)
  • "country_code" -- Two letter country code (see geoip_country_code_by_name())
  • "country_code3" -- Three letter country code (see geoip_country_code3_by_name())
  • "country_name" -- The country name (see geoip_country_name_by_name())
  • "region" -- The region code (ex: CA for California)
  • "city" -- The city.
  • "postal_code" -- The Postal Code, FSA or Zip Code.
  • "latitude" -- The Latitude as signed double.
  • "longitude" -- The Longitude as signed double.
  • "dma_code" -- Designated Market Area code (USA and Canada only)
  • "area_code" -- The PSTN area code (ex: 212)

Değiştirgeler

hostname

The hostname or IP address whose record is to be looked-up.

Dönen Değerler

Returns the associative array on success, or FALSE if the address cannot be found in the database.

Sürüm Bilgisi

Sürüm: | Açıklama
1.0.4 | Adding the continent_code with GeoIP Library 1.4.3 or newer only
1.0.3 | Adding country_code3 and country_name

Örnekler

Örnek 1 A geoip_record_by_name() example

This will print the array containing the record of host example.com.

<?php
$record = geoip_record_by_name('www.example.com');
if ($record) {
    print_r($record);
}
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [continent_code] => NA
    [country_code] => US
    [country_code3] => USA
    [country_name] => United States
    [region] => CA
    [city] => Marina Del Rey
    [postal_code] =>
    [latitude] => 33.9776992798
    [longitude] => -118.435096741
    [dma_code] => 803
    [area_code] => 310
)

geoip_org_by_name
geoip_region_by_name
GeoIP İşlevleri


Get the country code and region

geoip_record_by_name
geoip_region_name_by_code
GeoIP İşlevleri
PHP Manual

geoip_region_by_name

(PECL geoip >= 0.2.0)

geoip_region_by_name — Get the country code and region

Açıklama

array geoip_region_by_name ( string $hostname )

The geoip_region_by_name() function will return the country and region corresponding to a hostname or an IP address.

This function is currently only available to users who have bought a commercial GeoIP Region Edition. A warning will be issued if the proper database cannot be located.

The names of the different keys of the returning associative array are as follows:

  • "country_code" -- Two letter country code (see geoip_country_code_by_name())
  • "region" -- The region code (ex: CA for California)

Değiştirgeler

hostname

The hostname or IP address whose region is to be looked-up.

Dönen Değerler

Returns the associative array on success, or FALSE if the address cannot be found in the database.

Örnekler

Örnek 1 A geoip_region_by_name() example

This will print the array containing the country code and region of the host example.com.

<?php
$region = geoip_region_by_name('www.example.com');
if ($region) {
    print_r($region);
}
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [country_code] => US
    [region] => CA
)

geoip_record_by_name
geoip_region_name_by_code
GeoIP İşlevleri


Returns the region name for some country and region code combo

geoip_region_by_name
geoip_setup_custom_directory
GeoIP İşlevleri
PHP Manual

geoip_region_name_by_code

(PECL geoip >= 1.0.4)

geoip_region_name_by_code — Returns the region name for some country and region code combo

Açıklama

string geoip_region_name_by_code ( string $country_code , string $region_code )

The geoip_region_name_by_code() function will return the region name corresponding to a country and region code combo.

In the United States, the region code corresponds to the two-letter abbreviation of each state. In Canada, the region code corresponds to the two-letter province or territory code as attributed by Canada Post.

For the rest of the world, GeoIP uses FIPS 10-4 codes to represent regions. You can check » http://www.maxmind.com/app/fips10_4 for a detailed list of FIPS 10-4 codes.

This function is always available if using GeoIP Library version 1.4.1 or newer. The data is taken directly from the GeoIP Library and not from any database.

Değiştirgeler

country_code

The two-letter country code (see geoip_country_code_by_name())

region_code

The two-letter (or digit) region code (see geoip_region_by_name())

Dönen Değerler

Returns the region name on success, or FALSE if the country and region code combo cannot be found.

Örnekler

Örnek 1 A geoip_region_name_by_code() example using region code for US/Canada

This will print the region name for country CA (Canada), region QC (Quebec).

<?php
$region = geoip_region_name_by_code('CA', 'QC');
if ($region) {
    echo 'Region name for CA/QC is: ' . $region;
}
?>

Yukarıdaki örneğin çıktısı:

Region name for CA/QC is: Quebec

Örnek 2 A geoip_region_name_by_code() example using FIPS codes

This will print the region name for country JP (Japan), region 01.

<?php
$region = geoip_region_name_by_code('JP', '01');
if ($region) {
    echo 'Region name for JP/01 is: ' . $region;
}
?>

Yukarıdaki örneğin çıktısı:

Region name for JP/01 is: Aichi

geoip_region_by_name
geoip_setup_custom_directory
GeoIP İşlevleri


Set a custom directory for the GeoIP database.

geoip_region_name_by_code
geoip_time_zone_by_country_and_region
GeoIP İşlevleri
PHP Manual

geoip_setup_custom_directory

(PECL geoip >= 1.1.0)

geoip_setup_custom_directory — Set a custom directory for the GeoIP database.

Açıklama

void geoip_setup_custom_directory ( string $path )

The geoip_setup_custom_directory() function will change the default directory of the GeoIP database. This is equivalent to changing geoip.custom_directory.

Değiştirgeler

path

The full path of where the GeoIP database is on disk.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 A geoip_setup_custom_directory() example

This will change the GeoIP default database path.

<?php

geoip_setup_custom_directory('/some/other/path');

print geoip_db_filename(GEOIP_COUNTRY_EDITION);

?>

Yukarıdaki örneğin çıktısı:

/some/other/path/GeoIP.dat

geoip_region_name_by_code
geoip_time_zone_by_country_and_region
GeoIP İşlevleri


Returns the time zone for some country and region code combo

geoip_setup_custom_directory
FANN
GeoIP İşlevleri
PHP Manual

geoip_time_zone_by_country_and_region

(PECL geoip >= 1.0.4)

geoip_time_zone_by_country_and_region — Returns the time zone for some country and region code combo

Açıklama

string geoip_time_zone_by_country_and_region ( string $country_code [, string $region_code ] )

The geoip_time_zone_by_country_and_region() function will return the time zone corresponding to a country and region code combo.

In the United States, the region code corresponds to the two-letter abbreviation of each state. In Canada, the region code corresponds to the two-letter province or territory code as attributed by Canada Post.

For the rest of the world, GeoIP uses FIPS 10-4 codes to represent regions. You can check » http://www.maxmind.com/app/fips10_4 for a detailed list of FIPS 10-4 codes.

This function is always available if using GeoIP Library version 1.4.1 or newer. The data is taken directly from the GeoIP Library and not from any database.

Değiştirgeler

country_code

The two-letter country code (see geoip_country_code_by_name())

region_code

The two-letter (or digit) region code (see geoip_region_by_name())

Dönen Değerler

Returns the time zone on success, or FALSE if the country and region code combo cannot be found.

Örnekler

Örnek 1 A geoip_time_zone_by_country_and_region() example using region code for US/Canada

This will print the time zone for country CA (Canada), region QC (Quebec).

<?php
$timezone = geoip_time_zone_by_country_and_region('CA', 'QC');
if ($timezone) {
    echo 'Time zone for CA/QC is: ' . $timezone;
}
?>

Yukarıdaki örneğin çıktısı:

Time zone for CA/QC is: America/Montreal

Örnek 2 A geoip_time_zone_by_country_and_region() example using FIPS codes

This will print the time zone for country JP (Japan), region 01 (Aichi).

<?php
$timezone = geoip_time_zone_by_country_and_region('JP', '01');
if ($timezone) {
    echo 'Time zone for JP/01 is: ' . $timezone;
}
?>

Yukarıdaki örneğin çıktısı:

Time zone for JP/01 is: Asia/Tokyo

geoip_setup_custom_directory
FANN
GeoIP İşlevleri


FANN (Fast Artificial Neural Network)

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
    • XOR training
  • Fann İşlevleri
    • fann_cascadetrain_on_data — Trains on an entire dataset, for a period of time using the Cascade2 training algorithm
    • fann_cascadetrain_on_file — Trains on an entire dataset read from file, for a period of time using the Cascade2 training algorithm.
    • fann_clear_scaling_params — Clears scaling parameters
    • fann_copy — Creates a copy of a fann structure
    • fann_create_from_file — Constructs a backpropagation neural network from a configuration file
    • fann_create_shortcut_array — Creates a standard backpropagation neural network which is not fully connectected and has shortcut connections
    • fann_create_shortcut — Creates a standard backpropagation neural network which is not fully connectected and has shortcut connections
    • fann_create_sparse_array — Creates a standard backpropagation neural network, which is not fully connected using an array of layer sizes
    • fann_create_sparse — Creates a standard backpropagation neural network, which is not fully connected
    • fann_create_standard_array — Creates a standard fully connected backpropagation neural network using an array of layer sizes
    • fann_create_standard — Creates a standard fully connected backpropagation neural network
    • fann_create_train_from_callback — Creates the training data struct from a user supplied function
    • fann_create_train — Creates an empty training data struct
    • fann_descale_input — Scale data in input vector after get it from ann based on previously calculated parameters
    • fann_descale_output — Scale data in output vector after get it from ann based on previously calculated parameters
    • fann_descale_train — Descale input and output data based on previously calculated parameters
    • fann_destroy_train — Destructs the training data
    • fann_destroy — Destroys the entire network and properly freeing all the associated memory
    • fann_duplicate_train_data — Returns an exact copy of a fann train data
    • fann_get_activation_function — Returns the activation function
    • fann_get_activation_steepness — Returns the activation steepness for supplied neuron and layer number
    • fann_get_bias_array — Get the number of bias in each layer in the network
    • fann_get_bit_fail_limit — Returns the bit fail limit used during training
    • fann_get_bit_fail — The number of fail bits
    • fann_get_cascade_activation_functions_count — Returns the number of cascade activation functions
    • fann_get_cascade_activation_functions — Returns the cascade activation functions
    • fann_get_cascade_activation_steepnesses_count — The number of activation steepnesses
    • fann_get_cascade_activation_steepnesses — Returns the cascade activation steepnesses
    • fann_get_cascade_candidate_change_fraction — Returns the cascade candidate change fraction
    • fann_get_cascade_candidate_limit — Return the candidate limit
    • fann_get_cascade_candidate_stagnation_epochs — Returns the number of cascade candidate stagnation epochs
    • fann_get_cascade_max_cand_epochs — Returns the maximum candidate epochs
    • fann_get_cascade_max_out_epochs — Returns the maximum out epochs
    • fann_get_cascade_min_cand_epochs — Returns the minimum candidate epochs
    • fann_get_cascade_min_out_epochs — Returns the minimum out epochs
    • fann_get_cascade_num_candidate_groups — Returns the number of candidate groups
    • fann_get_cascade_num_candidates — Returns the number of candidates used during training
    • fann_get_cascade_output_change_fraction — Returns the cascade output change fraction
    • fann_get_cascade_output_stagnation_epochs — Returns the number of cascade output stagnation epochs
    • fann_get_cascade_weight_multiplier — Returns the weight multiplier
    • fann_get_connection_array — Get connections in the network
    • fann_get_connection_rate — Get the connection rate used when the network was created
    • fann_get_errno — Returns the last error number
    • fann_get_errstr — Returns the last errstr
    • fann_get_layer_array — Get the number of neurons in each layer in the network
    • fann_get_learning_momentum — Returns the learning momentum
    • fann_get_learning_rate — Returns the learning rate
    • fann_get_MSE — Reads the mean square error from the network
    • fann_get_network_type — Get the type of neural network it was created as
    • fann_get_num_input — Get the number of input neurons
    • fann_get_num_layers — Get the number of layers in the neural network
    • fann_get_num_output — Get the number of output neurons
    • fann_get_quickprop_decay — Returns the decay which is a factor that weights should decrease in each iteration during quickprop training
    • fann_get_quickprop_mu — Returns the mu factor
    • fann_get_rprop_decrease_factor — Returns the increase factor used during RPROP training
    • fann_get_rprop_delta_max — Returns the maximum step-size
    • fann_get_rprop_delta_min — Returns the minimum step-size
    • fann_get_rprop_delta_zero — Returns the initial step-size
    • fann_get_rprop_increase_factor — Returns the increase factor used during RPROP training
    • fann_get_sarprop_step_error_shift — Returns the sarprop step error shift
    • fann_get_sarprop_step_error_threshold_factor — Returns the sarprop step error threshold factor
    • fann_get_sarprop_temperature — Returns the sarprop temperature
    • fann_get_sarprop_weight_decay_shift — Returns the sarprop weight decay shift
    • fann_get_total_connections — Get the total number of connections in the entire network
    • fann_get_total_neurons — Get the total number of neurons in the entire network
    • fann_get_train_error_function — Returns the error function used during training
    • fann_get_train_stop_function — Returns the stop function used during training
    • fann_get_training_algorithm — Returns the training algorithm
    • fann_init_weights — Initialize the weights using Widrow + Nguyen’s algorithm
    • fann_length_train_data — Returns the number of training patterns in the train data
    • fann_merge_train_data — Merges the train data
    • fann_num_input_train_data — Returns the number of inputs in each of the training patterns in the train data
    • fann_num_output_train_data — Returns the number of outputs in each of the training patterns in the train data
    • fann_print_error — Prints the error string
    • fann_randomize_weights — Give each connection a random weight between min_weight and max_weight
    • fann_read_train_from_file — Reads a file that stores training data
    • fann_reset_errno — Resets the last error number
    • fann_reset_errstr — Resets the last error string
    • fann_reset_MSE — Resets the mean square error from the network
    • fann_run — Will run input through the neural network
    • fann_save_train — Save the training structure to a file
    • fann_save — Saves the entire network to a configuration file
    • fann_scale_input_train_data — Scales the inputs in the training data to the specified range
    • fann_scale_input — Scale data in input vector before feed it to ann based on previously calculated parameters
    • fann_scale_output_train_data — Scales the outputs in the training data to the specified range
    • fann_scale_output — Scale data in output vector before feed it to ann based on previously calculated parameters
    • fann_scale_train_data — Scales the inputs and outputs in the training data to the specified range
    • fann_scale_train — Scale input and output data based on previously calculated parameters
    • fann_set_activation_function_hidden — Sets the activation function for all of the hidden layers
    • fann_set_activation_function_layer — Sets the activation function for all the neurons in the supplied layer.
    • fann_set_activation_function_output — Sets the activation function for the output layer
    • fann_set_activation_function — Sets the activation function for supplied neuron and layer
    • fann_set_activation_steepness_hidden — Sets the steepness of the activation steepness for all neurons in the all hidden layers
    • fann_set_activation_steepness_layer — Sets the activation steepness for all of the neurons in the supplied layer number
    • fann_set_activation_steepness_output — Sets the steepness of the activation steepness in the output layer
    • fann_set_activation_steepness — Sets the activation steepness for supplied neuron and layer number
    • fann_set_bit_fail_limit — Set the bit fail limit used during training
    • fann_set_callback — Sets the callback function for use during training
    • fann_set_cascade_activation_functions — Sets the array of cascade candidate activation functions
    • fann_set_cascade_activation_steepnesses — Sets the array of cascade candidate activation steepnesses
    • fann_set_cascade_candidate_change_fraction — Sets the cascade candidate change fraction
    • fann_set_cascade_candidate_limit — Sets the candidate limit
    • fann_set_cascade_candidate_stagnation_epochs — Sets the number of cascade candidate stagnation epochs
    • fann_set_cascade_max_cand_epochs — Sets the max candidate epochs
    • fann_set_cascade_max_out_epochs — Sets the maximum out epochs
    • fann_set_cascade_min_cand_epochs — Sets the min candidate epochs
    • fann_set_cascade_min_out_epochs — Sets the minimum out epochs
    • fann_set_cascade_num_candidate_groups — Sets the number of candidate groups
    • fann_set_cascade_output_change_fraction — Sets the cascade output change fraction
    • fann_set_cascade_output_stagnation_epochs — Sets the number of cascade output stagnation epochs
    • fann_set_cascade_weight_multiplier — Sets the weight multiplier
    • fann_set_error_log — Sets where the errors are logged to
    • fann_set_input_scaling_params — Calculate input scaling parameters for future use based on training data
    • fann_set_learning_momentum — Sets the learning momentum
    • fann_set_learning_rate — Sets the learning rate
    • fann_set_output_scaling_params — Calculate output scaling parameters for future use based on training data
    • fann_set_quickprop_decay — Sets the quickprop decay factor
    • fann_set_quickprop_mu — Sets the quickprop mu factor
    • fann_set_rprop_decrease_factor — Sets the decrease factor used during RPROP training
    • fann_set_rprop_delta_max — Sets the maximum step-size
    • fann_set_rprop_delta_min — Sets the minimum step-size
    • fann_set_rprop_delta_zero — Sets the initial step-size
    • fann_set_rprop_increase_factor — Sets the increase factor used during RPROP training
    • fann_set_sarprop_step_error_shift — Sets the sarprop step error shift
    • fann_set_sarprop_step_error_threshold_factor — Sets the sarprop step error threshold factor
    • fann_set_sarprop_temperature — Sets the sarprop temperature
    • fann_set_sarprop_weight_decay_shift — Sets the sarprop weight decay shift
    • fann_set_scaling_params — Calculate input and output scaling parameters for future use based on training data
    • fann_set_train_error_function — Sets the error function used during training
    • fann_set_train_stop_function — Sets the stop function used during training
    • fann_set_training_algorithm — Sets the training algorithm
    • fann_set_weight_array — Set connections in the network
    • fann_set_weight — Set a connection in the network
    • fann_shuffle_train_data — Shuffles training data, randomizing the order
    • fann_subset_train_data — Returns an copy of a subset of the train data
    • fann_test_data — Test a set of training data and calculates the MSE for the training data
    • fann_test — Test with a set of inputs, and a set of desired outputs
    • fann_train_epoch — Train one epoch with a set of training data
    • fann_train_on_data — Trains on an entire dataset for a period of time
    • fann_train_on_file — Trains on an entire dataset, which is read from file, for a period of time
    • fann_train — Train one iteration with a set of inputs, and a set of desired outputs
  • FANNConnection — The FANNConnection class
    • FANNConnection::__construct — The connection constructor
    • FANNConnection::getFromNeuron — Returns the postions of starting neuron.
    • FANNConnection::getToNeuron — Returns the postions of terminating neuron
    • FANNConnection::getWeight — Returns the connection weight
    • FANNConnection::setWeight — Sets the connections weight
geoip_time_zone_by_country_and_region
Giriş
Diğer Temel Eklentiler


Giriş

PHP binding for FANN (Fast Artificial Neural Network) Library which implements multilayer artificial neural networks with support for both fully connected and sparsely connected networks. It includes a framework for easy handling of training data sets. It is easy to use, versatile, well documented, and fast.

FANN
Yapılandırma/Kurulum
FANN


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
FANN


Gereksinimler

PHP >= 5.2.0 and libfann >= 2.1.0

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

The FANN PHP extension should work on all Linux systems.

  • FANN Library Installation
  • PECL Installation
  • Manual Installation

FANN Library Installation

Before you start installation make sure that libfann is installed on your system. It's part of the main repository in the most Linux distributions (search for fann). You need a development version.

If it is not installed, you need to install it first. Either download it from the » official site or get it from your distro repository. For example on Fedora:

$ sudo yum install fann-devel
or Ubuntu:

$ sudo apt-get install libfann-dev

If the library is re-installed manually, then all old library file should be removed before re-installing otherwise the old library version could be linked.

PECL Installation

This extension is available on PECL. The installation is very simple. Just run:

$ sudo pecl install fann

Manual Installation

For developers and people interested in the latest changes, you can compile the driver from the latest source code on » Github. Go to Github and click the "Download ZIP" button. Then run:

$ unzip php-fann-master.zip
$ cd php-fann-master
$ phpize
$ ./configure
$ make all
$ sudo make install

Make the following changes to php.ini:

  • Make sure the extension_dir variable is pointing to the directory containing fann.so. The build will display where it is installing the PHP driver with output that looks something like:

Installing '/usr/lib/php/extensions/no-debug-non-zts-20060613/fann.so'
    Make sure that it is the same as the PHP extension directory by runnning:

$ php -i | grep extension_dir
  extension_dir => /usr/lib/php/extensions/no-debug-non-zts-20060613 =>
                   /usr/lib/php/extensions/no-debug-non-zts-20060613
    If it's not, change the extension_dir in php.ini or move fann.so.

  • To load the extension on PHP startup, add a line:

extension=fann.so

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

Training algorithms
FANN_TRAIN_INCREMENTAL (integer)
Standard backpropagation algorithm, where the weights are updated after each training pattern. This means that the weights are updated many times during a single epoch. For this reason some problems, will train very fast with this algorithm, while other more advanced problems will not train very well.
FANN_TRAIN_BATCH (integer)
Standard backpropagation algorithm, where the weights are updated after calculating the mean square error for the whole training set. This means that the weights are only updated once during a epoch. For this reason some problems, will train slower with this algorithm. But since the mean square error is calculated more correctly than in incremental training, some problems will reach a better solutions with this algorithm.
FANN_TRAIN_RPROP (integer)
A more advanced batch training algorithm which achieves good results for many problems. The RPROP training algorithm is adaptive, and does therefore not use the learning_rate. Some other parameters can however be set to change the way the RPROP algorithm works, but it is only recommended for users with insight in how the RPROP training algorithm works. The RPROP training algorithm is described by [Riedmiller and Braun, 1993], but the actual learning algorithm used here is the iRPROP- training algorithm which is described by [Igel and Husken, 2000] which is an variety of the standard RPROP training algorithm.
FANN_TRAIN_QUICKPROP (integer)
A more advanced batch training algorithm which achieves good results for many problems. The quickprop training algorithm uses the learning_rate parameter along with other more advanced parameters, but it is only recommended to change these advanced parameters, for users with insight in how the quickprop training algorithm works. The quickprop training algorithm is described by [Fahlman, 1988].
FANN_TRAIN_SARPROP (integer)
Even more advance training algorithm. Only for version 2.2
Activation functions
FANN_LINEAR (integer)
Linear activation function.
FANN_THRESHOLD (integer)
Threshold activation function.
FANN_THRESHOLD_SYMMETRIC (integer)
Threshold activation function.
FANN_SIGMOID (integer)
Sigmoid activation function.
FANN_SIGMOID_STEPWISE (integer)
Stepwise linear approximation to sigmoid.
FANN_SIGMOID_SYMMETRIC (integer)
Symmetric sigmoid activation function, aka. tanh.
FANN_SIGMOID_SYMMETRIC_STEPWISE (integer)
Stepwise linear approximation to symmetric sigmoid
FANN_GAUSSIAN (integer)
Gaussian activation function.
FANN_GAUSSIAN_SYMMETRIC (integer)
Symmetric gaussian activation function.
FANN_GAUSSIAN_STEPWISE (integer)
Stepwise gaussian activation function.
FANN_ELLIOT (integer)
Fast (sigmoid like) activation function defined by David Elliott.
FANN_ELLIOT_SYMMETRIC (integer)
Fast (symmetric sigmoid like) activation function defined by David Elliott.
FANN_LINEAR_PIECE (integer)
Bounded linear activation function.
FANN_LINEAR_PIECE_SYMMETRIC (integer)
Bounded linear activation function.
FANN_SIN_SYMMETRIC (integer)
Periodical sinus activation function.
FANN_COS_SYMMETRIC (integer)
Periodical cosinus activation function.
FANN_SIN (integer)
Periodical sinus activation function.
FANN_COS (integer)
Periodical cosinus activation function.
Error function used during training
FANN_ERRORFUNC_LINEAR (integer)
Standard linear error function.
FANN_ERRORFUNC_TANH (integer)
Tanh error function, usually better but can require a lower learning rate. This error function agressively targets outputs that differ much from the desired, while not targetting outputs that only differ a little that much. This activation function is not recommended for cascade training and incremental training.
Stop criteria used during training
FANN_STOPFUNC_MSE (integer)
Stop criteria is Mean Square Error (MSE) value.
FANN_STOPFUNC_BIT (integer)
Stop criteria is number of bits that fail. The number of bits means the number of output neurons which differs more than the bit fail limit (see fann_get_bit_fail_limit, fann_set_bit_fail_limit). The bits are counted in all of the training data, so this number can be higher than the number of training data.
Definition of network types used by fann_get_network_type()
FANN_NETTYPE_LAYER (integer)
Each layer only has connections to the next layer.
FANN_NETTYPE_SHORTCUT (integer)
Each layer has connections to all following layers
Errors
FANN_E_NO_ERROR (integer)
No error.
FANN_E_CANT_OPEN_CONFIG_R (integer)
Unable to open configuration file for reading.
FANN_E_CANT_OPEN_CONFIG_W (integer)
Unable to open configuration file for writing.
FANN_E_WRONG_CONFIG_VERSION (integer)
Wrong version of configuration file.
FANN_E_CANT_READ_CONFIG (integer)
Error reading info from configuration file.
FANN_E_CANT_READ_NEURON (integer)
Error reading neuron info from configuration file.
FANN_E_CANT_READ_CONNECTIONS (integer)
Error reading connections from configuration file.
FANN_E_WRONG_NUM_CONNECTIONS (integer)
Number of connections not equal to the number expected.
FANN_E_CANT_OPEN_TD_W (integer)
Unable to open train data file for writing.
FANN_E_CANT_OPEN_TD_R (integer)
Unable to open train data file for reading.
FANN_E_CANT_READ_TD (integer)
Error reading training data from file.
FANN_E_CANT_ALLOCATE_MEM (integer)
Unable to allocate memory.
FANN_E_CANT_TRAIN_ACTIVATION (integer)
Unable to train with the selected activation function.
FANN_E_CANT_USE_ACTIVATION (integer)
Unable to use the selected activation function.
FANN_E_TRAIN_DATA_MISMATCH (integer)
Irreconcilable differences between two struct fann_train_data structures.
FANN_E_CANT_USE_TRAIN_ALG (integer)
Unable to use the selected training algorithm.
FANN_E_TRAIN_DATA_SUBSET (integer)
Trying to take subset which is not within the training set.
FANN_E_INDEX_OUT_OF_BOUND (integer)
Index is out of bound.
FANN_E_SCALE_NOT_PRESENT (integer)
Scaling parameters not present.
FANN_E_INPUT_NO_MATCH (integer)
The number of input neurons in the ann data do not match
FANN_E_OUTPUT_NO_MATCH (integer)
The number of output neurons in the ann and data do not match.

Özkaynak Türleri
Örnekler
FANN


Örnekler

İçindekiler

  • XOR training
Öntanımlı Sabitler
XOR training
FANN


XOR training

This example shows how to train data for XOR function

Örnek 1 xor.data file

4 2 1
-1 -1
-1
-1 1
1
1 -1
1
1 1
-1

Örnek 2 Simple train

<?php
$num_input = 2;
$num_output = 1;
$num_layers = 3;
$num_neurons_hidden = 3;
$desired_error = 0.001;
$max_epochs = 500000;
$epochs_between_reports = 1000;

$ann = fann_create_standard($num_layers, $num_input, $num_neurons_hidden, $num_output);

if ($ann) {
    fann_set_activation_function_hidden($ann, FANN_SIGMOID_SYMMETRIC);
    fann_set_activation_function_output($ann, FANN_SIGMOID_SYMMETRIC);

    $filename = dirname(__FILE__) . "/xor.data";
    if (fann_train_on_file($ann, $filename, $max_epochs, $epochs_between_reports, $desired_error))
        fann_save($ann, dirname(__FILE__) . "/xor_float.net");

    fann_destroy($ann);
}
?>

This example shows how to read and run data for XOR function

Örnek 3 Simple test

<?php
$train_file = (dirname(__FILE__) . "/xor_float.net");
if (!is_file($train_file))
    die("The file xor_float.net has not been created! Please run simple_train.php to generate it");

$ann = fann_create_from_file($train_file);
if (!$ann)
    die("ANN could not be created");

$input = array(-1, 1);
$calc_out = fann_run($ann, $input);
printf("xor test (%f,%f) -> %f\n", $input[0], $input[1], $calc_out[0]);
fann_destroy($ann);
?>

Örnekler
Fann İşlevleri
Örnekler


Fann İşlevleri

İçindekiler

  • fann_cascadetrain_on_data — Trains on an entire dataset, for a period of time using the Cascade2 training algorithm
  • fann_cascadetrain_on_file — Trains on an entire dataset read from file, for a period of time using the Cascade2 training algorithm.
  • fann_clear_scaling_params — Clears scaling parameters
  • fann_copy — Creates a copy of a fann structure
  • fann_create_from_file — Constructs a backpropagation neural network from a configuration file
  • fann_create_shortcut_array — Creates a standard backpropagation neural network which is not fully connectected and has shortcut connections
  • fann_create_shortcut — Creates a standard backpropagation neural network which is not fully connectected and has shortcut connections
  • fann_create_sparse_array — Creates a standard backpropagation neural network, which is not fully connected using an array of layer sizes
  • fann_create_sparse — Creates a standard backpropagation neural network, which is not fully connected
  • fann_create_standard_array — Creates a standard fully connected backpropagation neural network using an array of layer sizes
  • fann_create_standard — Creates a standard fully connected backpropagation neural network
  • fann_create_train_from_callback — Creates the training data struct from a user supplied function
  • fann_create_train — Creates an empty training data struct
  • fann_descale_input — Scale data in input vector after get it from ann based on previously calculated parameters
  • fann_descale_output — Scale data in output vector after get it from ann based on previously calculated parameters
  • fann_descale_train — Descale input and output data based on previously calculated parameters
  • fann_destroy_train — Destructs the training data
  • fann_destroy — Destroys the entire network and properly freeing all the associated memory
  • fann_duplicate_train_data — Returns an exact copy of a fann train data
  • fann_get_activation_function — Returns the activation function
  • fann_get_activation_steepness — Returns the activation steepness for supplied neuron and layer number
  • fann_get_bias_array — Get the number of bias in each layer in the network
  • fann_get_bit_fail_limit — Returns the bit fail limit used during training
  • fann_get_bit_fail — The number of fail bits
  • fann_get_cascade_activation_functions_count — Returns the number of cascade activation functions
  • fann_get_cascade_activation_functions — Returns the cascade activation functions
  • fann_get_cascade_activation_steepnesses_count — The number of activation steepnesses
  • fann_get_cascade_activation_steepnesses — Returns the cascade activation steepnesses
  • fann_get_cascade_candidate_change_fraction — Returns the cascade candidate change fraction
  • fann_get_cascade_candidate_limit — Return the candidate limit
  • fann_get_cascade_candidate_stagnation_epochs — Returns the number of cascade candidate stagnation epochs
  • fann_get_cascade_max_cand_epochs — Returns the maximum candidate epochs
  • fann_get_cascade_max_out_epochs — Returns the maximum out epochs
  • fann_get_cascade_min_cand_epochs — Returns the minimum candidate epochs
  • fann_get_cascade_min_out_epochs — Returns the minimum out epochs
  • fann_get_cascade_num_candidate_groups — Returns the number of candidate groups
  • fann_get_cascade_num_candidates — Returns the number of candidates used during training
  • fann_get_cascade_output_change_fraction — Returns the cascade output change fraction
  • fann_get_cascade_output_stagnation_epochs — Returns the number of cascade output stagnation epochs
  • fann_get_cascade_weight_multiplier — Returns the weight multiplier
  • fann_get_connection_array — Get connections in the network
  • fann_get_connection_rate — Get the connection rate used when the network was created
  • fann_get_errno — Returns the last error number
  • fann_get_errstr — Returns the last errstr
  • fann_get_layer_array — Get the number of neurons in each layer in the network
  • fann_get_learning_momentum — Returns the learning momentum
  • fann_get_learning_rate — Returns the learning rate
  • fann_get_MSE — Reads the mean square error from the network
  • fann_get_network_type — Get the type of neural network it was created as
  • fann_get_num_input — Get the number of input neurons
  • fann_get_num_layers — Get the number of layers in the neural network
  • fann_get_num_output — Get the number of output neurons
  • fann_get_quickprop_decay — Returns the decay which is a factor that weights should decrease in each iteration during quickprop training
  • fann_get_quickprop_mu — Returns the mu factor
  • fann_get_rprop_decrease_factor — Returns the increase factor used during RPROP training
  • fann_get_rprop_delta_max — Returns the maximum step-size
  • fann_get_rprop_delta_min — Returns the minimum step-size
  • fann_get_rprop_delta_zero — Returns the initial step-size
  • fann_get_rprop_increase_factor — Returns the increase factor used during RPROP training
  • fann_get_sarprop_step_error_shift — Returns the sarprop step error shift
  • fann_get_sarprop_step_error_threshold_factor — Returns the sarprop step error threshold factor
  • fann_get_sarprop_temperature — Returns the sarprop temperature
  • fann_get_sarprop_weight_decay_shift — Returns the sarprop weight decay shift
  • fann_get_total_connections — Get the total number of connections in the entire network
  • fann_get_total_neurons — Get the total number of neurons in the entire network
  • fann_get_train_error_function — Returns the error function used during training
  • fann_get_train_stop_function — Returns the stop function used during training
  • fann_get_training_algorithm — Returns the training algorithm
  • fann_init_weights — Initialize the weights using Widrow + Nguyen’s algorithm
  • fann_length_train_data — Returns the number of training patterns in the train data
  • fann_merge_train_data — Merges the train data
  • fann_num_input_train_data — Returns the number of inputs in each of the training patterns in the train data
  • fann_num_output_train_data — Returns the number of outputs in each of the training patterns in the train data
  • fann_print_error — Prints the error string
  • fann_randomize_weights — Give each connection a random weight between min_weight and max_weight
  • fann_read_train_from_file — Reads a file that stores training data
  • fann_reset_errno — Resets the last error number
  • fann_reset_errstr — Resets the last error string
  • fann_reset_MSE — Resets the mean square error from the network
  • fann_run — Will run input through the neural network
  • fann_save_train — Save the training structure to a file
  • fann_save — Saves the entire network to a configuration file
  • fann_scale_input_train_data — Scales the inputs in the training data to the specified range
  • fann_scale_input — Scale data in input vector before feed it to ann based on previously calculated parameters
  • fann_scale_output_train_data — Scales the outputs in the training data to the specified range
  • fann_scale_output — Scale data in output vector before feed it to ann based on previously calculated parameters
  • fann_scale_train_data — Scales the inputs and outputs in the training data to the specified range
  • fann_scale_train — Scale input and output data based on previously calculated parameters
  • fann_set_activation_function_hidden — Sets the activation function for all of the hidden layers
  • fann_set_activation_function_layer — Sets the activation function for all the neurons in the supplied layer.
  • fann_set_activation_function_output — Sets the activation function for the output layer
  • fann_set_activation_function — Sets the activation function for supplied neuron and layer
  • fann_set_activation_steepness_hidden — Sets the steepness of the activation steepness for all neurons in the all hidden layers
  • fann_set_activation_steepness_layer — Sets the activation steepness for all of the neurons in the supplied layer number
  • fann_set_activation_steepness_output — Sets the steepness of the activation steepness in the output layer
  • fann_set_activation_steepness — Sets the activation steepness for supplied neuron and layer number
  • fann_set_bit_fail_limit — Set the bit fail limit used during training
  • fann_set_callback — Sets the callback function for use during training
  • fann_set_cascade_activation_functions — Sets the array of cascade candidate activation functions
  • fann_set_cascade_activation_steepnesses — Sets the array of cascade candidate activation steepnesses
  • fann_set_cascade_candidate_change_fraction — Sets the cascade candidate change fraction
  • fann_set_cascade_candidate_limit — Sets the candidate limit
  • fann_set_cascade_candidate_stagnation_epochs — Sets the number of cascade candidate stagnation epochs
  • fann_set_cascade_max_cand_epochs — Sets the max candidate epochs
  • fann_set_cascade_max_out_epochs — Sets the maximum out epochs
  • fann_set_cascade_min_cand_epochs — Sets the min candidate epochs
  • fann_set_cascade_min_out_epochs — Sets the minimum out epochs
  • fann_set_cascade_num_candidate_groups — Sets the number of candidate groups
  • fann_set_cascade_output_change_fraction — Sets the cascade output change fraction
  • fann_set_cascade_output_stagnation_epochs — Sets the number of cascade output stagnation epochs
  • fann_set_cascade_weight_multiplier — Sets the weight multiplier
  • fann_set_error_log — Sets where the errors are logged to
  • fann_set_input_scaling_params — Calculate input scaling parameters for future use based on training data
  • fann_set_learning_momentum — Sets the learning momentum
  • fann_set_learning_rate — Sets the learning rate
  • fann_set_output_scaling_params — Calculate output scaling parameters for future use based on training data
  • fann_set_quickprop_decay — Sets the quickprop decay factor
  • fann_set_quickprop_mu — Sets the quickprop mu factor
  • fann_set_rprop_decrease_factor — Sets the decrease factor used during RPROP training
  • fann_set_rprop_delta_max — Sets the maximum step-size
  • fann_set_rprop_delta_min — Sets the minimum step-size
  • fann_set_rprop_delta_zero — Sets the initial step-size
  • fann_set_rprop_increase_factor — Sets the increase factor used during RPROP training
  • fann_set_sarprop_step_error_shift — Sets the sarprop step error shift
  • fann_set_sarprop_step_error_threshold_factor — Sets the sarprop step error threshold factor
  • fann_set_sarprop_temperature — Sets the sarprop temperature
  • fann_set_sarprop_weight_decay_shift — Sets the sarprop weight decay shift
  • fann_set_scaling_params — Calculate input and output scaling parameters for future use based on training data
  • fann_set_train_error_function — Sets the error function used during training
  • fann_set_train_stop_function — Sets the stop function used during training
  • fann_set_training_algorithm — Sets the training algorithm
  • fann_set_weight_array — Set connections in the network
  • fann_set_weight — Set a connection in the network
  • fann_shuffle_train_data — Shuffles training data, randomizing the order
  • fann_subset_train_data — Returns an copy of a subset of the train data
  • fann_test_data — Test a set of training data and calculates the MSE for the training data
  • fann_test — Test with a set of inputs, and a set of desired outputs
  • fann_train_epoch — Train one epoch with a set of training data
  • fann_train_on_data — Trains on an entire dataset for a period of time
  • fann_train_on_file — Trains on an entire dataset, which is read from file, for a period of time
  • fann_train — Train one iteration with a set of inputs, and a set of desired outputs
XOR training
fann_cascadetrain_on_data
FANN


Trains on an entire dataset, for a period of time using the Cascade2 training algorithm

Fann İşlevleri
fann_cascadetrain_on_file
Fann İşlevleri
PHP Manual

fann_cascadetrain_on_data

(PECL fann >= 1.0.0)

fann_cascadetrain_on_data — Trains on an entire dataset, for a period of time using the Cascade2 training algorithm

Açıklama

bool fann_cascadetrain_on_data ( resource $ann , resource $data , int $max_neurons , int $neurons_between_reports , float $desired_error )

The cascade output change fraction is a number between 0 and 1 determining how large a fraction the fann_get_MSE() value should change within fann_get_cascade_output_stagnation_epochs() during training of the output connections, in order for the training not to stagnate. If the training stagnates, the training of the output connections will be ended and new candidates will be prepared.

This training uses the parameters set using the fann_set_cascade_..., but it also uses another training algorithm as it's internal training algorithm. This algorithm can be set to either FANN_TRAIN_RPROP or FANN_TRAIN_QUICKPROP by fann_set_training_algorithm(), and the parameters set for these training algorithms will also affect the cascade training.

Değiştirgeler

ann

Neural network resource.

data

Neural network training data resource.

max_neurons

The maximum number of neurons to be added to neural network.

neurons_between_reports

The number of neurons between printing a status report. A value of zero means no reports should be printed.

desired_error

The desired fann_get_MSE() or fann_get_bit_fail(), depending on which stop function is chosen by fann_set_train_stop_function()

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_train_on_data() - Trains on an entire dataset for a period of time
  • fann_cascadetrain_on_file() - Trains on an entire dataset read from file, for a period of time using the Cascade2 training algorithm.

Fann İşlevleri
fann_cascadetrain_on_file
Fann İşlevleri


Trains on an entire dataset read from file, for a period of time using the Cascade2 training algorithm.

fann_cascadetrain_on_data
fann_clear_scaling_params
Fann İşlevleri
PHP Manual

fann_cascadetrain_on_file

(PECL fann >= 1.0.0)

fann_cascadetrain_on_file — Trains on an entire dataset read from file, for a period of time using the Cascade2 training algorithm.

Açıklama

bool fann_cascadetrain_on_file ( resource $ann , string $filename , int $max_neurons , int $neurons_between_reports , float $desired_error )

Does the same as fann_cascadetrain_on_data(), but reads the training data directly from a file.

Değiştirgeler

ann

Neural network resource.

filename

The maximum number of neurons to be added to neural network

max_neurons

The number of neurons between printing a status report to stdout. A value of zero means no reports should be printed.

neurons_between_reports

The number of neurons between printing a status report. A value of zero means no reports should be printed.

desired_error

The desired fann_get_MSE() or fann_get_bit_fail(), depending on which stop function is chosen by fann_set_train_stop_function().

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_train_on_data() - Trains on an entire dataset for a period of time
  • fann_cascadetrain_on_data() - Trains on an entire dataset, for a period of time using the Cascade2 training algorithm

fann_cascadetrain_on_data
fann_clear_scaling_params
Fann İşlevleri


Clears scaling parameters

fann_cascadetrain_on_file
fann_copy
Fann İşlevleri
PHP Manual

fann_clear_scaling_params

(PECL fann >= 1.0.0)

fann_clear_scaling_params — Clears scaling parameters

Açıklama

bool fann_clear_scaling_params ( resource $ann )

Clears scaling parameters.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

fann_cascadetrain_on_file
fann_copy
Fann İşlevleri


Creates a copy of a fann structure

fann_clear_scaling_params
fann_create_from_file
Fann İşlevleri
PHP Manual

fann_copy

(PECL fann >= 1.0.0)

fann_copy — Creates a copy of a fann structure

Açıklama

resource fann_copy ( resource $ann )

Creates a copy of a fann structure.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

Returns a copy of neural network resource on success, or FALSE on error

Ayrıca Bakınız

  • fann_test() - Test with a set of inputs, and a set of desired outputs

fann_clear_scaling_params
fann_create_from_file
Fann İşlevleri


Constructs a backpropagation neural network from a configuration file

fann_copy
fann_create_shortcut_array
Fann İşlevleri
PHP Manual

fann_create_from_file

(PECL fann >= 1.0.0)

fann_create_from_file — Constructs a backpropagation neural network from a configuration file

Açıklama

resource fann_create_from_file ( string $configuration_file )

Constructs a backpropagation neural network from a configuration file, which have been saved by fann_save().

Değiştirgeler

configuration_file

The configuration file path.

Dönen Değerler

Returns a neural network resource on success, or FALSE on error.

Ayrıca Bakınız

  • fann_save() - Saves the entire network to a configuration file

fann_copy
fann_create_shortcut_array
Fann İşlevleri


Creates a standard backpropagation neural network which is not fully connectected and has shortcut connections

fann_create_from_file
fann_create_shortcut
Fann İşlevleri
PHP Manual

fann_create_shortcut_array

(PECL fann >= 1.0.0)

fann_create_shortcut_array — Creates a standard backpropagation neural network which is not fully connectected and has shortcut connections

Açıklama

resource fann_create_shortcut_array ( int $num_layers , array $layers )

Creates a standard backpropagation neural network which is not fully connectected and has shortcut connections using an array of layers sizes.

Değiştirgeler

num_layers

The total number of layers including the input and the output layer.

layers

An array of layers sizes.

Dönen Değerler

Returns a neural network resource on success, or FALSE on error.

Ayrıca Bakınız

  • fann_create_shortcut() - Creates a standard backpropagation neural network which is not fully connectected and has shortcut connections
  • fann_create_sparse() - Creates a standard backpropagation neural network, which is not fully connected
  • fann_create_standard() - Creates a standard fully connected backpropagation neural network

fann_create_from_file
fann_create_shortcut
Fann İşlevleri


Creates a standard backpropagation neural network which is not fully connectected and has shortcut connections

fann_create_shortcut_array
fann_create_sparse_array
Fann İşlevleri
PHP Manual

fann_create_shortcut

(PECL fann >= 1.0.0)

fann_create_shortcut — Creates a standard backpropagation neural network which is not fully connectected and has shortcut connections

Açıklama

reference fann_create_shortcut ( int $num_layers , int $num_neurons1 , int $num_neurons2 [, int $... ] )

Creates a standard backpropagation neural network, which is not fully connected and which also has shortcut connections.

Shortcut connections are connections that skip layers. A fully connected network with shortcut connections, is a network where all neurons are connected to all neurons in later layers. Including direct connections from the input layer to the output layer.

Değiştirgeler

num_layers

The total number of layers including the input and the output layer.

num_neurons1

Number of neurons in the first layer.

num_neurons2

Number of neurons in the second layer.

...

Number of neurons in other layers.

Dönen Değerler

Returns a neural network resource on success, or FALSE on error.

Ayrıca Bakınız

  • fann_create_shortcut_array() - Creates a standard backpropagation neural network which is not fully connectected and has shortcut connections
  • fann_create_sparse() - Creates a standard backpropagation neural network, which is not fully connected
  • fann_create_standard() - Creates a standard fully connected backpropagation neural network

fann_create_shortcut_array
fann_create_sparse_array
Fann İşlevleri


Creates a standard backpropagation neural network, which is not fully connected using an array of layer sizes

fann_create_shortcut
fann_create_sparse
Fann İşlevleri
PHP Manual

fann_create_sparse_array

(PECL fann >= 1.0.0)

fann_create_sparse_array — Creates a standard backpropagation neural network, which is not fully connected using an array of layer sizes

Açıklama

ReturnType fann_create_sparse_array ( float $connection_rate , int $num_layers , array $layers )

Creates a standard backpropagation neural network, which is not fully connected using an array of layer sizes.

Değiştirgeler

connection_rate

The connection rate controls how many connections there will be in the network. If the connection rate is set to 1, the network will be fully connected, but if it is set to 0.5 only half of the connections will be set. A connection rate of 1 will yield the same result as fann_create_standard().

num_layers

The total number of layers including the input and the output layer.

layers

An array of layer sizes.

Dönen Değerler

Returns a neural network resource on success, or FALSE on error.

Ayrıca Bakınız

  • fann_create_sparse() - Creates a standard backpropagation neural network, which is not fully connected
  • fann_create_standard() - Creates a standard fully connected backpropagation neural network
  • fann_create_shortcut() - Creates a standard backpropagation neural network which is not fully connectected and has shortcut connections

fann_create_shortcut
fann_create_sparse
Fann İşlevleri


Creates a standard backpropagation neural network, which is not fully connected

fann_create_sparse_array
fann_create_standard_array
Fann İşlevleri
PHP Manual

fann_create_sparse

(PECL fann >= 1.0.0)

fann_create_sparse — Creates a standard backpropagation neural network, which is not fully connected

Açıklama

ReturnType fann_create_sparse ( float $connection_rate , int $num_layers , int $num_neurons1 , int $num_neurons2 [, int $... ] )

Creates a standard backpropagation neural network, which is not fully connected.

Değiştirgeler

connection_rate

The connection rate controls how many connections there will be in the network. If the connection rate is set to 1, the network will be fully connected, but if it is set to 0.5 only half of the connections will be set. A connection rate of 1 will yield the same result as fann_create_standard().

num_layers

The total number of layers including the input and the output layer.

num_neurons1

Number of neurons in the first layer.

num_neurons2

Number of neurons in the second layer.

...

Number of neurons in other layers.

Dönen Değerler

Returns a neural network resource on success, or FALSE on error.

Ayrıca Bakınız

  • fann_create_sparse_array() - Creates a standard backpropagation neural network, which is not fully connected using an array of layer sizes
  • fann_create_standard() - Creates a standard fully connected backpropagation neural network
  • fann_create_shortcut() - Creates a standard backpropagation neural network which is not fully connectected and has shortcut connections

fann_create_sparse_array
fann_create_standard_array
Fann İşlevleri


Creates a standard fully connected backpropagation neural network using an array of layer sizes

fann_create_sparse
fann_create_standard
Fann İşlevleri
PHP Manual

fann_create_standard_array

(PECL fann >= 1.0.0)

fann_create_standard_array — Creates a standard fully connected backpropagation neural network using an array of layer sizes

Açıklama

resource fann_create_standard_array ( int $num_layers , array $layers )

Creates a standard fully connected backpropagation neural network.

There will be a bias neuron in each layer (except the output layer), and this bias neuron will be connected to all neurons in the next layer. When running the network, the bias nodes always emits 1.

To destroy a neural network use the fann_destroy() function.

Değiştirgeler

num_layers

The total number of layers including the input and the output layer.

layers

An array of layer sizes.

Dönen Değerler

Returns a neural network resource on success, or FALSE on error.

Ayrıca Bakınız

  • fann_create_standard() - Creates a standard fully connected backpropagation neural network
  • fann_create_sparse() - Creates a standard backpropagation neural network, which is not fully connected
  • fann_create_shortcut() - Creates a standard backpropagation neural network which is not fully connectected and has shortcut connections

fann_create_sparse
fann_create_standard
Fann İşlevleri


Creates a standard fully connected backpropagation neural network

fann_create_standard_array
fann_create_train_from_callback
Fann İşlevleri
PHP Manual

fann_create_standard

(PECL fann >= 1.0.0)

fann_create_standard — Creates a standard fully connected backpropagation neural network

Açıklama

resource fann_create_standard ( int $num_layers , int $num_neurons1 , int $num_neurons2 [, int $... ] )

Creates a standard fully connected backpropagation neural network.

There will be a bias neuron in each layer (except the output layer), and this bias neuron will be connected to all neurons in the next layer. When running the network, the bias nodes always emits 1.

To destroy a neural network use the fann_destroy() function.

Değiştirgeler

num_layers

The total number of layers including the input and the output layer.

num_neurons1

Number of neurons in the first layer.

num_neurons2

Number of neurons in the second layer.

...

Number of neurons in other layers.

Dönen Değerler

Returns a neural network resource on success, or FALSE on error.

Ayrıca Bakınız

  • fann_create_standard_array() - Creates a standard fully connected backpropagation neural network using an array of layer sizes
  • fann_create_sparse() - Creates a standard backpropagation neural network, which is not fully connected
  • fann_create_shortcut() - Creates a standard backpropagation neural network which is not fully connectected and has shortcut connections

fann_create_standard_array
fann_create_train_from_callback
Fann İşlevleri


Creates the training data struct from a user supplied function

fann_create_standard
fann_create_train
Fann İşlevleri
PHP Manual

fann_create_train_from_callback

(PECL fann >= 1.0.0)

fann_create_train_from_callback — Creates the training data struct from a user supplied function

Açıklama

resource fann_create_train_from_callback ( int $num_data , int $num_input , int $num_output , callable $user_function )

Creates the training data struct from a user supplied function. As the training data are numerable (data 1, data 2...), the user must write a function that receives the number of the training data set (input, output) and returns the set.

Değiştirgeler

num_data

The number of training data

num_input

The number of inputs per training data

num_output

The number of ouputs per training data

user_function

The user supplied function with following parameters:

  • num - The number of the training data set
  • num_input - The number of inputs per training data
  • num_output - The number of ouputs per training data

The function should return an associative array with keys input and output and two array values of input and output.

Dönen Değerler

Returns a train data resource on success, or FALSE on error.

Örnekler

Örnek 1 fann_create_train_from_callback() example

<?php
function create_train_callback($num_data, $num_input, $num_output) {
    return array(
        "input" => array_fill(0, $num_input, 1),
        "output" => array_fill(0, $num_output, 1),
    );
}

$num_data = 3;
$num_input = 2;
$num_output = 1;
$train_data = fann_create_train_from_callback($num_data, $num_input, $num_output, "create_train_callback");
if ($train_data) {
    // Do something with $train_data
}
?>

Ayrıca Bakınız

  • fann_read_train_from_file() - Reads a file that stores training data
  • fann_train_on_data() - Trains on an entire dataset for a period of time
  • fann_destroy_train() - Destructs the training data
  • fann_save_train() - Save the training structure to a file

fann_create_standard
fann_create_train
Fann İşlevleri


Creates an empty training data struct

fann_create_train_from_callback
fann_descale_input
Fann İşlevleri
PHP Manual

fann_create_train

(PECL fann >= 1.0.0)

fann_create_train — Creates an empty training data struct

Açıklama

resource fann_create_train ( int $num_data , int $num_input , int $num_output )

Creates an empty training data struct.

Değiştirgeler

num_data

The number of training data

num_input

The number of inputs per training data

num_output

The number of ouputs per training data

Dönen Değerler

Returns a train data resource on success, or FALSE on error.

Ayrıca Bakınız

  • fann_read_train_from_file() - Reads a file that stores training data
  • fann_train_on_data() - Trains on an entire dataset for a period of time
  • fann_destroy_train() - Destructs the training data
  • fann_save_train() - Save the training structure to a file

fann_create_train_from_callback
fann_descale_input
Fann İşlevleri


Scale data in input vector after get it from ann based on previously calculated parameters

fann_create_train
fann_descale_output
Fann İşlevleri
PHP Manual

fann_descale_input

(PECL fann >= 1.0.0)

fann_descale_input — Scale data in input vector after get it from ann based on previously calculated parameters

Açıklama

bool fann_descale_input ( resource $ann , array $input_vector )

Scale data in input vector after get it from ann based on previously calculated parameters.

Değiştirgeler

ann

Neural network resource.

input_vector

Input vector that will be descaled

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_scale_input() - Scale data in input vector before feed it to ann based on previously calculated parameters
  • fann_descale_output() - Scale data in output vector after get it from ann based on previously calculated parameters

fann_create_train
fann_descale_output
Fann İşlevleri


Scale data in output vector after get it from ann based on previously calculated parameters

fann_descale_input
fann_descale_train
Fann İşlevleri
PHP Manual

fann_descale_output

(PECL fann >= 1.0.0)

fann_descale_output — Scale data in output vector after get it from ann based on previously calculated parameters

Açıklama

bool fann_descale_output ( resource $ann , array $output_vector )

Scale data in output vector after get it from ann based on previously calculated parameters.

Değiştirgeler

ann

Neural network resource.

output_vector

Output vector that will be descaled

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_scale_output() - Scale data in output vector before feed it to ann based on previously calculated parameters
  • fann_descale_input() - Scale data in input vector after get it from ann based on previously calculated parameters

fann_descale_input
fann_descale_train
Fann İşlevleri


Descale input and output data based on previously calculated parameters

fann_descale_output
fann_destroy_train
Fann İşlevleri
PHP Manual

fann_descale_train

(PECL fann >= 1.0.0)

fann_descale_train — Descale input and output data based on previously calculated parameters

Açıklama

bool fann_descale_train ( resource $ann , resource $train_data )

Descale input and output data based on previously calculated parameters.

Değiştirgeler

ann

Neural network resource.

train_data

Neural network training data resource.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_scale_train() - Scale input and output data based on previously calculated parameters
  • fann_set_scaling_params() - Calculate input and output scaling parameters for future use based on training data

fann_descale_output
fann_destroy_train
Fann İşlevleri


Destructs the training data

fann_descale_train
fann_destroy
Fann İşlevleri
PHP Manual

fann_destroy_train

(PECL fann >= 1.0.0)

fann_destroy_train — Destructs the training data

Açıklama

bool fann_destroy_train ( resource $train_data )

Destructs the training data

Değiştirgeler

train_data

Neural network training data resource.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

fann_descale_train
fann_destroy
Fann İşlevleri


Destroys the entire network and properly freeing all the associated memory

fann_destroy_train
fann_duplicate_train_data
Fann İşlevleri
PHP Manual

fann_destroy

(PECL fann >= 1.0.0)

fann_destroy — Destroys the entire network and properly freeing all the associated memory

Açıklama

bool fann_destroy ( resource $ann )

Destroys the entire network and properly freeing all the associated memory.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

fann_destroy_train
fann_duplicate_train_data
Fann İşlevleri


Returns an exact copy of a fann train data

fann_destroy
fann_get_activation_function
Fann İşlevleri
PHP Manual

fann_duplicate_train_data

(PECL fann >= 1.0.0)

fann_duplicate_train_data — Returns an exact copy of a fann train data

Açıklama

resource fann_duplicate_train_data ( resource $data )

Returns an exact copy of a fann train data resource.

Değiştirgeler

data

Neural network training data resource.

Dönen Değerler

Returns a train data resource on success, or FALSE on error.

fann_destroy
fann_get_activation_function
Fann İşlevleri


Returns the activation function

fann_duplicate_train_data
fann_get_activation_steepness
Fann İşlevleri
PHP Manual

fann_get_activation_function

(PECL fann >= 1.0.0)

fann_get_activation_function — Returns the activation function

Açıklama

int fann_get_activation_function ( resource $ann , int $layer , int $neuron )

Get the activation function for neuron number neuron in layer number layer, counting the input layer as layer 0.

It is not possible to get activation functions for the neurons in the input layer.

The return value is one of the activation functions constants.

Değiştirgeler

ann

Neural network resource.

layer

Layer number.

neuron

Neuron number.

Dönen Değerler

Learning functions constant or -1 if the neuron is not defined in the neural network, or FALSE on error.

Ayrıca Bakınız

  • fann_set_activation_function_layer() - Sets the activation function for all the neurons in the supplied layer.
  • fann_set_activation_function_hidden() - Sets the activation function for all of the hidden layers
  • fann_set_activation_function_output() - Sets the activation function for the output layer
  • fann_set_activation_steepness() - Sets the activation steepness for supplied neuron and layer number
  • fann_set_activation_function() - Sets the activation function for supplied neuron and layer

fann_duplicate_train_data
fann_get_activation_steepness
Fann İşlevleri


Returns the activation steepness for supplied neuron and layer number

fann_get_activation_function
fann_get_bias_array
Fann İşlevleri
PHP Manual

fann_get_activation_steepness

(PECL fann >= 1.0.0)

fann_get_activation_steepness — Returns the activation steepness for supplied neuron and layer number

Açıklama

float fann_get_activation_steepness ( resource $ann , int $layer , int $neuron )

Get the activation steepness for neuron number neuron in layer number layer, counting the input layer as layer 0.

It is not possible to get activation steepness for the neurons in the input layer.

The steepness of an activation function says something about how fast the activation function goes from the minimum to the maximum. A high value for the activation function will also give a more agressive training.

When training neural networks where the output values should be at the extremes (usually 0 and 1, depending on the activation function), a steep activation function can be used (e.g. 1.0).

The default activation steepness is 0.5.

Değiştirgeler

ann

Neural network resource.

layer

Layer number

neuron

Neuron number

Dönen Değerler

The activation steepness for the neuron or -1 if the neuron is not defined in the neural network, or FALSE on error.

Ayrıca Bakınız

  • fann_set_activation_function() - Sets the activation function for supplied neuron and layer
  • fann_set_activation_steepness_layer() - Sets the activation steepness for all of the neurons in the supplied layer number
  • fann_set_activation_steepness_hidden() - Sets the steepness of the activation steepness for all neurons in the all hidden layers
  • fann_set_activation_steepness_output() - Sets the steepness of the activation steepness in the output layer
  • fann_set_activation_steepness() - Sets the activation steepness for supplied neuron and layer number

fann_get_activation_function
fann_get_bias_array
Fann İşlevleri


Get the number of bias in each layer in the network

fann_get_activation_steepness
fann_get_bit_fail_limit
Fann İşlevleri
PHP Manual

fann_get_bias_array

(PECL fann >= 1.0.0)

fann_get_bias_array — Get the number of bias in each layer in the network

Açıklama

array fann_get_bias_array ( resource $ann )

Get the number of bias in each layer in the network.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

An array of numbers of bias in each layer

fann_get_activation_steepness
fann_get_bit_fail_limit
Fann İşlevleri


Returns the bit fail limit used during training

fann_get_bias_array
fann_get_bit_fail
Fann İşlevleri
PHP Manual

fann_get_bit_fail_limit

(PECL fann >= 1.0.0)

fann_get_bit_fail_limit — Returns the bit fail limit used during training

Açıklama

float fann_get_bit_fail_limit ( resource $ann )

Returns the bit fail limit used during training.

The bit fail limit is used during training where the stop function is set to FANN_STOPFUNC_BIT.

The limit is the maximum accepted difference between the desired output and the actual output during training. Each output that diverges more than this limit is counted as an error bit. This difference is divided by two when dealing with symmetric activation functions, so that symmetric and not symmetric activation functions can use the same limit.

The default bit fail limit is 0.35.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

The bit fail limit, or FALSE on error.

Ayrıca Bakınız

  • fann_set_bit_fail_limit() - Set the bit fail limit used during training

fann_get_bias_array
fann_get_bit_fail
Fann İşlevleri


The number of fail bits

fann_get_bit_fail_limit
fann_get_cascade_activation_functions_count
Fann İşlevleri
PHP Manual

fann_get_bit_fail

(PECL fann >= 1.0.0)

fann_get_bit_fail — The number of fail bits

Açıklama

int fann_get_bit_fail ( resource $ann )

The number of fail bits; means the number of output neurons which differ more than the bit fail limit (see fann_get_bit_fail_limit(), fann_set_bit_fail_limit()). The bits are counted in all of the training data, so this number can be higher than the number of training data.

This value is reset by fann_reset_MSE() and updated by all the same functions which also updates the MSE value (e.g. fann_test_data(), fann_train_epoch())

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

The number of bits fail, or FALSE on error.

Ayrıca Bakınız

  • fann_get_MSE() - Reads the mean square error from the network
  • fann_reset_MSE() - Resets the mean square error from the network
  • fann_test_data() - Test a set of training data and calculates the MSE for the training data
  • fann_train_epoch() - Train one epoch with a set of training data
  • fann_get_bit_fail_limit() - Returns the bit fail limit used during training
  • fann_set_bit_fail_limit() - Set the bit fail limit used during training

fann_get_bit_fail_limit
fann_get_cascade_activation_functions_count
Fann İşlevleri


Returns the number of cascade activation functions

fann_get_bit_fail
fann_get_cascade_activation_functions
Fann İşlevleri
PHP Manual

fann_get_cascade_activation_functions_count

(PECL fann >= 1.0.0)

fann_get_cascade_activation_functions_count — Returns the number of cascade activation functions

Açıklama

int fann_get_cascade_activation_functions_count ( resource $ann )

The number of activation functions in the fann_get_cascade_activation_functions() array.

The default number of activation functions is 6.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

The number of cascade activation functions, or FALSE on error.

Ayrıca Bakınız

  • fann_get_cascade_activation_functions() - Returns the cascade activation functions
  • fann_set_cascade_activation_functions() - Sets the array of cascade candidate activation functions

fann_get_bit_fail
fann_get_cascade_activation_functions
Fann İşlevleri


Returns the cascade activation functions

fann_get_cascade_activation_functions_count
fann_get_cascade_activation_steepnesses_count
Fann İşlevleri
PHP Manual

fann_get_cascade_activation_functions

(PECL fann >= 1.0.0)

fann_get_cascade_activation_functions — Returns the cascade activation functions

Açıklama

array fann_get_cascade_activation_functions ( resource $ann )

The cascade activation functions array is an array of the different activation functions used by the candidates

See fann_get_cascade_num_candidates() for a description of which candidate neurons will be generated by this array.

The default activation functions are FANN_SIGMOID, FANN_SIGMOID_SYMMETRIC, FANN_GAUSSIAN, FANN_GAUSSIAN_SYMMETRIC, FANN_ELLIOT, FANN_ELLIOT_SYMMETRIC.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

The cascade activation functions, or FALSE on error.

Ayrıca Bakınız

  • fann_get_cascade_activation_functions_count() - Returns the number of cascade activation functions
  • fann_set_cascade_activation_functions() - Sets the array of cascade candidate activation functions

fann_get_cascade_activation_functions_count
fann_get_cascade_activation_steepnesses_count
Fann İşlevleri


The number of activation steepnesses

fann_get_cascade_activation_functions
fann_get_cascade_activation_steepnesses
Fann İşlevleri
PHP Manual

fann_get_cascade_activation_steepnesses_count

(PECL fann >= 1.0.0)

fann_get_cascade_activation_steepnesses_count — The number of activation steepnesses

Açıklama

int fann_get_cascade_activation_steepnesses_count ( resource $ann )

The number of activation steepnesses in the fann_get_cascade_activation_functions() array.

The default number of activation steepnesses is 4.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

The number of activation steepnesses, or FALSE on error.

Ayrıca Bakınız

  • fann_get_cascade_activation_steepnesses() - Returns the cascade activation steepnesses
  • fann_set_cascade_activation_functions() - Sets the array of cascade candidate activation functions

fann_get_cascade_activation_functions
fann_get_cascade_activation_steepnesses
Fann İşlevleri


Returns the cascade activation steepnesses

fann_get_cascade_activation_steepnesses_count
fann_get_cascade_candidate_change_fraction
Fann İşlevleri
PHP Manual

fann_get_cascade_activation_steepnesses

(PECL fann >= 1.0.0)

fann_get_cascade_activation_steepnesses — Returns the cascade activation steepnesses

Açıklama

array fann_get_cascade_activation_steepnesses ( resource $ann )

The cascade activation steepnesses array is an array of the different activation functions used by the candidates.

See fann_get_cascade_num_candidates() for a description of which candidate neurons will be generated by this array.

The default activation steepnesses are {0.25, 0.50, 0.75, 1.00}.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

The cascade activation steepnesses, or FALSE on error.

Ayrıca Bakınız

  • fann_get_cascade_activation_steepnesses_count() - The number of activation steepnesses
  • fann_set_cascade_activation_steepnesses() - Sets the array of cascade candidate activation steepnesses

fann_get_cascade_activation_steepnesses_count
fann_get_cascade_candidate_change_fraction
Fann İşlevleri


Returns the cascade candidate change fraction

fann_get_cascade_activation_steepnesses
fann_get_cascade_candidate_limit
Fann İşlevleri
PHP Manual

fann_get_cascade_candidate_change_fraction

(PECL fann >= 1.0.0)

fann_get_cascade_candidate_change_fraction — Returns the cascade candidate change fraction

Açıklama

float fann_get_cascade_candidate_change_fraction ( resource $ann )

The cascade candidate change fraction is a number between 0 and 1 determining how large a fraction the fann_get_MSE() value should change within fann_get_cascade_candidate_stagnation_epochs() during training of the candidate neurons, in order for the training not to stagnate. If the training stagnates, the training of the candidate neurons will be ended and the best candidate will be selected.

It means that if the MSE does not change by a fraction of fann_get_cascade_candidate_change_fraction() during a period of fann_get_cascade_candidate_stagnation_epochs(), the training of the candidate neurons is stopped because the training has stagnated.

If the cascade candidate change fraction is low, the candidate neurons will be trained more and if the fraction is high they will be trained less.

The default cascade candidate change fraction is 0.01, which is equalent to a 1% change in MSE.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

The cascade candidate change fraction, or FALSE on error.

Ayrıca Bakınız

  • fann_set_cascade_candidate_change_fraction() - Sets the cascade candidate change fraction
  • fann_get_MSE() - Reads the mean square error from the network
  • fann_get_cascade_candidate_stagnation_epochs() - Returns the number of cascade candidate stagnation epochs

fann_get_cascade_activation_steepnesses
fann_get_cascade_candidate_limit
Fann İşlevleri


Return the candidate limit

fann_get_cascade_candidate_change_fraction
fann_get_cascade_candidate_stagnation_epochs
Fann İşlevleri
PHP Manual

fann_get_cascade_candidate_limit

(PECL fann >= 1.0.0)

fann_get_cascade_candidate_limit — Return the candidate limit

Açıklama

float fann_get_cascade_candidate_limit ( resource $ann )

The candidate limit is a limit for how much the candidate neuron may be trained. The limit is a limit on the proportion between the MSE and candidate score.

Set this to a lower value to avoid overfitting and to a higher if overfitting is not a problem.

The default candidate limit is 1000.0.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

The candidate limit, or FALSE on error.

Ayrıca Bakınız

  • fann_set_cascade_candidate_limit() - Sets the candidate limit

fann_get_cascade_candidate_change_fraction
fann_get_cascade_candidate_stagnation_epochs
Fann İşlevleri


Returns the number of cascade candidate stagnation epochs

fann_get_cascade_candidate_limit
fann_get_cascade_max_cand_epochs
Fann İşlevleri
PHP Manual

fann_get_cascade_candidate_stagnation_epochs

(PECL fann >= 1.0.0)

fann_get_cascade_candidate_stagnation_epochs — Returns the number of cascade candidate stagnation epochs

Açıklama

float fann_get_cascade_candidate_stagnation_epochs ( resource $ann )

The number of cascade candidate stagnation epochs determines the number of epochs training is allowed to continue without changing the MSE by a fraction of fann_get_cascade_candidate_change_fraction().

See more info about this parameter in fann_get_cascade_candidate_change_fraction().

The default number of cascade candidate stagnation epochs is 12.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

The number of cascade candidate stagnation epochs, or FALSE on error.

Ayrıca Bakınız

  • fann_set_cascade_candidate_stagnation_epochs() - Sets the number of cascade candidate stagnation epochs
  • fann_get_cascade_candidate_change_fraction() - Returns the cascade candidate change fraction

fann_get_cascade_candidate_limit
fann_get_cascade_max_cand_epochs
Fann İşlevleri


Returns the maximum candidate epochs

fann_get_cascade_candidate_stagnation_epochs
fann_get_cascade_max_out_epochs
Fann İşlevleri
PHP Manual

fann_get_cascade_max_cand_epochs

(PECL fann >= 1.0.0)

fann_get_cascade_max_cand_epochs — Returns the maximum candidate epochs

Açıklama

int fann_get_cascade_max_cand_epochs ( resource $ann )

The maximum candidate epochs determines the maximum number of epochs the input connections to the candidates may be trained before adding a new candidate neuron.

The default max candidate epochs is 150.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

The maximum candidate epochs, or FALSE on error.

Ayrıca Bakınız

  • fann_set_cascade_max_cand_epochs() - Sets the max candidate epochs

fann_get_cascade_candidate_stagnation_epochs
fann_get_cascade_max_out_epochs
Fann İşlevleri


Returns the maximum out epochs

fann_get_cascade_max_cand_epochs
fann_get_cascade_min_cand_epochs
Fann İşlevleri
PHP Manual

fann_get_cascade_max_out_epochs

(PECL fann >= 1.0.0)

fann_get_cascade_max_out_epochs — Returns the maximum out epochs

Açıklama

int fann_get_cascade_max_out_epochs ( resource $ann )

The maximum out epochs determines the maximum number of epochs the output connections may be trained after adding a new candidate neuron.

The default max out epochs is 150.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

The maximum out epochs, or FALSE on error.

Ayrıca Bakınız

  • fann_set_cascade_max_out_epochs() - Sets the maximum out epochs

fann_get_cascade_max_cand_epochs
fann_get_cascade_min_cand_epochs
Fann İşlevleri


Returns the minimum candidate epochs

fann_get_cascade_max_out_epochs
fann_get_cascade_min_out_epochs
Fann İşlevleri
PHP Manual

fann_get_cascade_min_cand_epochs

(PECL fann >= 1.0.0)

fann_get_cascade_min_cand_epochs — Returns the minimum candidate epochs

Açıklama

int fann_get_cascade_min_cand_epochs ( resource $ann )

The minimum candidate epochs determines the minimum number of epochs the input connections to the candidates may be trained before adding a new candidate neuron.

The default min candidate epochs is 50.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

The minimum candidate epochs, or FALSE on error.

Ayrıca Bakınız

  • fann_set_cascade_min_cand_epochs() - Sets the min candidate epochs

fann_get_cascade_max_out_epochs
fann_get_cascade_min_out_epochs
Fann İşlevleri


Returns the minimum out epochs

fann_get_cascade_min_cand_epochs
fann_get_cascade_num_candidate_groups
Fann İşlevleri
PHP Manual

fann_get_cascade_min_out_epochs

(PECL fann >= 1.0.0)

fann_get_cascade_min_out_epochs — Returns the minimum out epochs

Açıklama

int fann_get_cascade_min_out_epochs ( resource $ann )

The minimum out epochs determines the minimum number of epochs the output connections must be trained after adding a new candidate neuron.

The default min out epochs is 50.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

The minimum out epochs, or FALSE on error.

Ayrıca Bakınız

  • fann_set_cascade_min_out_epochs() - Sets the minimum out epochs

fann_get_cascade_min_cand_epochs
fann_get_cascade_num_candidate_groups
Fann İşlevleri


Returns the number of candidate groups

fann_get_cascade_min_out_epochs
fann_get_cascade_num_candidates
Fann İşlevleri
PHP Manual

fann_get_cascade_num_candidate_groups

(PECL fann >= 1.0.0)

fann_get_cascade_num_candidate_groups — Returns the number of candidate groups

Açıklama

int fann_get_cascade_num_candidate_groups ( resource $ann )

The number of candidate groups is the number of groups of identical candidates which will be used during training.

This number can be used to have more candidates without having to define new parameters for the candidates.

See fann_get_cascade_num_candidates() for a description of which candidate neurons will be generated by this parameter.

The default number of candidate groups is 2.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

The number of candidate groups, or FALSE on error.

Ayrıca Bakınız

  • fann_set_cascade_num_candidate_groups() - Sets the number of candidate groups

fann_get_cascade_min_out_epochs
fann_get_cascade_num_candidates
Fann İşlevleri


Returns the number of candidates used during training

fann_get_cascade_num_candidate_groups
fann_get_cascade_output_change_fraction
Fann İşlevleri
PHP Manual

fann_get_cascade_num_candidates

(PECL fann >= 1.0.0)

fann_get_cascade_num_candidates — Returns the number of candidates used during training

Açıklama

int fann_get_cascade_num_candidates ( resource $ann )

The number of candidates used during training (calculated by multiplying
fann_get_cascade_activation_functions_count(),
fann_get_cascade_activation_steepnesses_count() and
fann_get_cascade_num_candidate_groups()).

The actual candidates is defined by the fann_get_cascade_activation_functions() and fann_get_cascade_activation_steepnesses() arrays. These arrays define the activation functions and activation steepnesses used for the candidate neurons. If there are 2 activation functions in the activation function array and 3 steepnesses in the steepness array, then there will be 2x3=6 different candidates which will be trained. These 6 different candidates can be copied into several candidate groups, where the only difference between these groups is the initial weights. If the number of groups is set to 2, then the number of candidate neurons will be 2x3x2=12. The number of candidate groups is defined by fann_set_cascade_num_candidate_groups().

The default number of candidates is 6x4x2 = 48

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

The number of candidates used during training, or FALSE on error.

Ayrıca Bakınız

  • fann_get_cascade_activation_functions() - Returns the cascade activation functions
  • fann_get_cascade_activation_functions_count() - Returns the number of cascade activation functions
  • fann_get_cascade_activation_steepnesses() - Returns the cascade activation steepnesses
  • fann_get_cascade_activation_steepnesses_count() - The number of activation steepnesses
  • fann_get_cascade_num_candidate_groups() - Returns the number of candidate groups

fann_get_cascade_num_candidate_groups
fann_get_cascade_output_change_fraction
Fann İşlevleri


Returns the cascade output change fraction

fann_get_cascade_num_candidates
fann_get_cascade_output_stagnation_epochs
Fann İşlevleri
PHP Manual

fann_get_cascade_output_change_fraction

(PECL fann >= 1.0.0)

fann_get_cascade_output_change_fraction — Returns the cascade output change fraction

Açıklama

float fann_get_cascade_output_change_fraction ( resource $ann )

The cascade output change fraction is a number between 0 and 1 determining how large a fraction of the fann_get_MSE() value should change within fann_get_cascade_output_stagnation_epochs() during training of the output connections, in order for the training not to stagnate. If the training stagnates, the training of the output connections will be ended and new candidates will be prepared.

It means that if the MSE does not change by a fraction of fann_get_cascade_output_change_fraction() during a period of fann_get_cascade_output_stagnation_epochs(), the training of the output connections is stopped because the training has stagnated.

If the cascade output change fraction is low, the output connections will be trained more and if the fraction is high, they will be trained less.

The default cascade output change fraction is 0.01, which is equalent to a 1% change in MSE.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

The cascade output change fraction, or FALSE on error.

Ayrıca Bakınız

  • fann_set_cascade_output_change_fraction() - Sets the cascade output change fraction
  • fann_get_MSE() - Reads the mean square error from the network
  • fann_get_cascade_output_stagnation_epochs() - Returns the number of cascade output stagnation epochs

fann_get_cascade_num_candidates
fann_get_cascade_output_stagnation_epochs
Fann İşlevleri


Returns the number of cascade output stagnation epochs

fann_get_cascade_output_change_fraction
fann_get_cascade_weight_multiplier
Fann İşlevleri
PHP Manual

fann_get_cascade_output_stagnation_epochs

(PECL fann >= 1.0.0)

fann_get_cascade_output_stagnation_epochs — Returns the number of cascade output stagnation epochs

Açıklama

int fann_get_cascade_output_stagnation_epochs ( resource $ann )

The number of cascade output stagnation epochs determines the number of epochs training is allowed to continue without changing the MSE by a fraction of fann_get_cascade_output_change_fraction().

See more info about this parameter in fann_get_cascade_output_change_fraction().

The default number of cascade output stagnation epochs is 12.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

The number of cascade output stagnation epochs, or FALSE on error.

Ayrıca Bakınız

  • fann_set_cascade_output_stagnation_epochs() - Sets the number of cascade output stagnation epochs
  • fann_get_cascade_output_change_fraction() - Returns the cascade output change fraction

fann_get_cascade_output_change_fraction
fann_get_cascade_weight_multiplier
Fann İşlevleri


Returns the weight multiplier

fann_get_cascade_output_stagnation_epochs
fann_get_connection_array
Fann İşlevleri
PHP Manual

fann_get_cascade_weight_multiplier

(PECL fann >= 1.0.0)

fann_get_cascade_weight_multiplier — Returns the weight multiplier

Açıklama

float fann_get_cascade_weight_multiplier ( resource $ann )

The weight multiplier is a parameter which is used to multiply the weights from the candidate neuron before adding the neuron to the neural network. This parameter is usually between 0 and 1, and is used to make the training a bit less aggressive.

The default weight multiplier is 0.4.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

The weight multiplier, or FALSE on error.

Ayrıca Bakınız

  • fann_set_cascade_weight_multiplier() - Sets the weight multiplier

fann_get_cascade_output_stagnation_epochs
fann_get_connection_array
Fann İşlevleri


Get connections in the network

fann_get_cascade_weight_multiplier
fann_get_connection_rate
Fann İşlevleri
PHP Manual

fann_get_connection_array

(PECL fann >= 1.0.0)

fann_get_connection_array — Get connections in the network

Açıklama

array fann_get_connection_array ( resource $ann )

Get connections in the network.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

An array of connections in the network

fann_get_cascade_weight_multiplier
fann_get_connection_rate
Fann İşlevleri


Get the connection rate used when the network was created

fann_get_connection_array
fann_get_errno
Fann İşlevleri
PHP Manual

fann_get_connection_rate

(PECL fann >= 1.0.0)

fann_get_connection_rate — Get the connection rate used when the network was created

Açıklama

float fann_get_connection_rate ( resource $ann )

Get the connection rate used when the network was created.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

The connection rate used when the network was created, or FALSE on error.

fann_get_connection_array
fann_get_errno
Fann İşlevleri


Returns the last error number

fann_get_connection_rate
fann_get_errstr
Fann İşlevleri
PHP Manual

fann_get_errno

(PECL fann >= 1.0.0)

fann_get_errno — Returns the last error number

Açıklama

int fann_get_errno ( resource $errdat )

Returns the last error number.

Değiştirgeler

errdat

Either neural network resource or neural network trainining data resource.

Dönen Değerler

The error number, or FALSE on error.

Ayrıca Bakınız

  • fann_reset_errno() - Resets the last error number
  • fann_get_errstr() - Returns the last errstr

fann_get_connection_rate
fann_get_errstr
Fann İşlevleri


Returns the last errstr

fann_get_errno
fann_get_layer_array
Fann İşlevleri
PHP Manual

fann_get_errstr

(PECL fann >= 1.0.0)

fann_get_errstr — Returns the last errstr

Açıklama

string fann_get_errstr ( resource $errdat )

Returns the last errstr.

Değiştirgeler

errdat

Either neural network resource or neural network trainining data resource.

Dönen Değerler

The last error string, or FALSE on error.

Ayrıca Bakınız

  • fann_reset_errstr() - Resets the last error string
  • fann_get_errno() - Returns the last error number

fann_get_errno
fann_get_layer_array
Fann İşlevleri


Get the number of neurons in each layer in the network

fann_get_errstr
fann_get_learning_momentum
Fann İşlevleri
PHP Manual

fann_get_layer_array

(PECL fann >= 1.0.0)

fann_get_layer_array — Get the number of neurons in each layer in the network

Açıklama

array fann_get_layer_array ( resource $ann )

Get the number of neurons in each layer in the neural network.

Bias is not included so the layers match the fann_create functions.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

An array of numbers of neurons in each leayer

fann_get_errstr
fann_get_learning_momentum
Fann İşlevleri


Returns the learning momentum

fann_get_layer_array
fann_get_learning_rate
Fann İşlevleri
PHP Manual

fann_get_learning_momentum

(PECL fann >= 1.0.0)

fann_get_learning_momentum — Returns the learning momentum

Açıklama

float fann_get_learning_momentum ( resource $ann )

The learning momentum can be used to speed up FANN_TRAIN_INCREMENTAL training. A too high momentum will however not benefit training. Setting momentum to 0 will be the same as not using the momentum parameter. The recommended value of this parameter is between 0.0 and 1.0.

The default momentum is 0.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

The learning momentum, or FALSE on error.

Ayrıca Bakınız

  • fann_set_learning_momentum() - Sets the learning momentum
  • fann_set_training_algorithm() - Sets the training algorithm

fann_get_layer_array
fann_get_learning_rate
Fann İşlevleri


Returns the learning rate

fann_get_learning_momentum
fann_get_MSE
Fann İşlevleri
PHP Manual

fann_get_learning_rate

(PECL fann >= 1.0.0)

fann_get_learning_rate — Returns the learning rate

Açıklama

float fann_get_learning_rate ( resource $ann )

The learning rate is used to determine how aggressive training should be for some of the training algorithms (FANN_TRAIN_INCREMENTAL, FANN_TRAIN_BATCH, FANN_TRAIN_QUICKPROP). Do however note that it is not used in FANN_TRAIN_RPROP.

The default learning rate is 0.7.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

The learning rate, or FALSE on error.

Ayrıca Bakınız

  • fann_set_learning_rate() - Sets the learning rate
  • fann_set_training_algorithm() - Sets the training algorithm

fann_get_learning_momentum
fann_get_MSE
Fann İşlevleri


Reads the mean square error from the network

fann_get_learning_rate
fann_get_network_type
Fann İşlevleri
PHP Manual

fann_get_MSE

(PECL fann >= 1.0.0)

fann_get_MSE — Reads the mean square error from the network

Açıklama

float fann_get_MSE ( resource $ann )

Reads the mean square error from the network.

Reads the mean square error from the network. This value is calculated during training or testing and can therefore sometimes be a bit off if the weights have been changed since the last calculation of the value.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

The mean square error, or FALSE on error.

Ayrıca Bakınız

  • fann_test_data() - Test a set of training data and calculates the MSE for the training data

fann_get_learning_rate
fann_get_network_type
Fann İşlevleri


Get the type of neural network it was created as

fann_get_MSE
fann_get_num_input
Fann İşlevleri
PHP Manual

fann_get_network_type

(PECL fann >= 1.0.0)

fann_get_network_type — Get the type of neural network it was created as

Açıklama

int fann_get_network_type ( resource $ann )

Get the type of neural network it was created as.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

Network type constant, or FALSE on error.

fann_get_MSE
fann_get_num_input
Fann İşlevleri


Get the number of input neurons

fann_get_network_type
fann_get_num_layers
Fann İşlevleri
PHP Manual

fann_get_num_input

(PECL fann >= 1.0.0)

fann_get_num_input — Get the number of input neurons

Açıklama

int fann_get_num_input ( resource $ann )

Get the number of input neurons.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

Number of input neurons, or FALSE on error

fann_get_network_type
fann_get_num_layers
Fann İşlevleri


Get the number of layers in the neural network

fann_get_num_input
fann_get_num_output
Fann İşlevleri
PHP Manual

fann_get_num_layers

(PECL fann >= 1.0.0)

fann_get_num_layers — Get the number of layers in the neural network

Açıklama

int fann_get_num_layers ( resource $ann )

Get the number of layers in the neural network.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

The number of leayers in the neural network, or FALSE on error.

fann_get_num_input
fann_get_num_output
Fann İşlevleri


Get the number of output neurons

fann_get_num_layers
fann_get_quickprop_decay
Fann İşlevleri
PHP Manual

fann_get_num_output

(PECL fann >= 1.0.0)

fann_get_num_output — Get the number of output neurons

Açıklama

int fann_get_num_output ( resource $ann )

Get the number of output neurons.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

Number of output neurons, or FALSE on error

fann_get_num_layers
fann_get_quickprop_decay
Fann İşlevleri


Returns the decay which is a factor that weights should decrease in each iteration during quickprop training

fann_get_num_output
fann_get_quickprop_mu
Fann İşlevleri
PHP Manual

fann_get_quickprop_decay

(PECL fann >= 1.0.0)

fann_get_quickprop_decay — Returns the decay which is a factor that weights should decrease in each iteration during quickprop training

Açıklama

float fann_get_quickprop_decay ( resource $ann )

The decay is a small negative valued number which is a factor that the weights should decrease in each iteration during quickprop training. This is used to make sure that the weights do not become too high during training.

The default decay is -0.0001.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

The decay, or FALSE on error.

Ayrıca Bakınız

  • fann_set_quickprop_decay() - Sets the quickprop decay factor

fann_get_num_output
fann_get_quickprop_mu
Fann İşlevleri


Returns the mu factor

fann_get_quickprop_decay
fann_get_rprop_decrease_factor
Fann İşlevleri
PHP Manual

fann_get_quickprop_mu

(PECL fann >= 1.0.0)

fann_get_quickprop_mu — Returns the mu factor

Açıklama

float fann_get_quickprop_mu ( resource $ann )

The mu factor is used to increase and decrease the step-size during quickprop training. The mu factor should always be above 1, since it would otherwise decrease the step-size when it was suppose to increase it.

The default mu factor is 1.75.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

The mu factor, or FALSE on error.

Ayrıca Bakınız

  • fann_set_quickprop_mu() - Sets the quickprop mu factor

fann_get_quickprop_decay
fann_get_rprop_decrease_factor
Fann İşlevleri


Returns the increase factor used during RPROP training

fann_get_quickprop_mu
fann_get_rprop_delta_max
Fann İşlevleri
PHP Manual

fann_get_rprop_decrease_factor

(PECL fann >= 1.0.0)

fann_get_rprop_decrease_factor — Returns the increase factor used during RPROP training

Açıklama

float fann_get_rprop_decrease_factor ( resource $ann )

The decrease factor is a value smaller than 1, which is used to decrease the step-size during RPROP training.

The default decrease factor is 0.5.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

The decrease factor, or FALSE on error.

Ayrıca Bakınız

  • fann_set_rprop_decrease_factor() - Sets the decrease factor used during RPROP training

fann_get_quickprop_mu
fann_get_rprop_delta_max
Fann İşlevleri


Returns the maximum step-size

fann_get_rprop_decrease_factor
fann_get_rprop_delta_min
Fann İşlevleri
PHP Manual

fann_get_rprop_delta_max

(PECL fann >= 1.0.0)

fann_get_rprop_delta_max — Returns the maximum step-size

Açıklama

float fann_get_rprop_delta_max ( resource $ann )

The maximum step-size is a positive number determining how large the maximum step-size may be.

The default delta max is 50.0.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

The maximum step-size, or FALSE on error.

Ayrıca Bakınız

  • fann_set_rprop_delta_max() - Sets the maximum step-size
  • fann_get_rprop_delta_min() - Returns the minimum step-size

fann_get_rprop_decrease_factor
fann_get_rprop_delta_min
Fann İşlevleri


Returns the minimum step-size

fann_get_rprop_delta_max
fann_get_rprop_delta_zero
Fann İşlevleri
PHP Manual

fann_get_rprop_delta_min

(PECL fann >= 1.0.0)

fann_get_rprop_delta_min — Returns the minimum step-size

Açıklama

float fann_get_rprop_delta_min ( resource $ann )

The minimum step-size is a small positive number determining how small the minimum step-size may be.

The default value delta min is 0.0.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

The minimum step-size, or FALSE on error.

Ayrıca Bakınız

  • fann_set_rprop_delta_min() - Sets the minimum step-size

fann_get_rprop_delta_max
fann_get_rprop_delta_zero
Fann İşlevleri


Returns the initial step-size

fann_get_rprop_delta_min
fann_get_rprop_increase_factor
Fann İşlevleri
PHP Manual

fann_get_rprop_delta_zero

(PECL fann >= 1.0.0)

fann_get_rprop_delta_zero — Returns the initial step-size

Açıklama

ReturnType fann_get_rprop_delta_zero ( resource $ann )

The initial step-size is a positive number determining the initial step size.

The default delta zero is 0.1.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

The initial step-size, or FALSE on error.

Ayrıca Bakınız

  • fann_set_rprop_delta_zero() - Sets the initial step-size
  • fann_get_rprop_delta_min() - Returns the minimum step-size
  • fann_get_rprop_delta_max() - Returns the maximum step-size

fann_get_rprop_delta_min
fann_get_rprop_increase_factor
Fann İşlevleri


Returns the increase factor used during RPROP training

fann_get_rprop_delta_zero
fann_get_sarprop_step_error_shift
Fann İşlevleri
PHP Manual

fann_get_rprop_increase_factor

(PECL fann >= 1.0.0)

fann_get_rprop_increase_factor — Returns the increase factor used during RPROP training

Açıklama

float fann_get_rprop_increase_factor ( resource $ann )

The increase factor is a value larger than 1, which is used to increase the step-size during RPROP training.

The default increase factor is 1.2.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

The increase factor, or FALSE on error.

Ayrıca Bakınız

  • fann_set_rprop_increase_factor() - Sets the increase factor used during RPROP training

fann_get_rprop_delta_zero
fann_get_sarprop_step_error_shift
Fann İşlevleri


Returns the sarprop step error shift

fann_get_rprop_increase_factor
fann_get_sarprop_step_error_threshold_factor
Fann İşlevleri
PHP Manual

fann_get_sarprop_step_error_shift

(PECL fann >= 1.0.0)

fann_get_sarprop_step_error_shift — Returns the sarprop step error shift

Açıklama

float fann_get_sarprop_step_error_shift ( resource $ann )

Returns the sarprop step error shift.

The default step error shift is 1.385.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

The sarprop step error shift , or FALSE on error.

Ayrıca Bakınız

  • fann_set_sarprop_step_error_shift() - Sets the sarprop step error shift

fann_get_rprop_increase_factor
fann_get_sarprop_step_error_threshold_factor
Fann İşlevleri


Returns the sarprop step error threshold factor

fann_get_sarprop_step_error_shift
fann_get_sarprop_temperature
Fann İşlevleri
PHP Manual

fann_get_sarprop_step_error_threshold_factor

(PECL fann >= 1.0.0)

fann_get_sarprop_step_error_threshold_factor — Returns the sarprop step error threshold factor

Açıklama

float fann_get_sarprop_step_error_threshold_factor ( resource $ann )

The sarprop step error threshold factor.

The default factor is 0.1.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

The sarprop step error threshold factor, or FALSE on error.

Ayrıca Bakınız

  • fann_set_sarprop_step_error_threshold_factor() - Sets the sarprop step error threshold factor

fann_get_sarprop_step_error_shift
fann_get_sarprop_temperature
Fann İşlevleri


Returns the sarprop temperature

fann_get_sarprop_step_error_threshold_factor
fann_get_sarprop_weight_decay_shift
Fann İşlevleri
PHP Manual

fann_get_sarprop_temperature

(PECL fann >= 1.0.0)

fann_get_sarprop_temperature — Returns the sarprop temperature

Açıklama

float fann_get_sarprop_temperature ( resource $ann )

Returns the sarprop temperature.

The default temperature is 0.015.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

The sarprop temperature, or FALSE on error.

Ayrıca Bakınız

  • fann_set_sarprop_temperature() - Sets the sarprop temperature

fann_get_sarprop_step_error_threshold_factor
fann_get_sarprop_weight_decay_shift
Fann İşlevleri


Returns the sarprop weight decay shift

fann_get_sarprop_temperature
fann_get_total_connections
Fann İşlevleri
PHP Manual

fann_get_sarprop_weight_decay_shift

(PECL fann >= 1.0.0)

fann_get_sarprop_weight_decay_shift — Returns the sarprop weight decay shift

Açıklama

float fann_get_sarprop_weight_decay_shift ( resource $ann )

The sarprop weight decay shift.

The default delta max is -6.644.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

The sarprop weight decay shift, or FALSE on error.

Ayrıca Bakınız

  • fann_set_sarprop_weight_decay_shift() - Sets the sarprop weight decay shift

fann_get_sarprop_temperature
fann_get_total_connections
Fann İşlevleri


Get the total number of connections in the entire network

fann_get_sarprop_weight_decay_shift
fann_get_total_neurons
Fann İşlevleri
PHP Manual

fann_get_total_connections

(PECL fann >= 1.0.0)

fann_get_total_connections — Get the total number of connections in the entire network

Açıklama

int fann_get_total_connections ( resource $ann )

Get the total number of connections in the entire network.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

Total number of connections in the entire network, or FALSE on error

fann_get_sarprop_weight_decay_shift
fann_get_total_neurons
Fann İşlevleri


Get the total number of neurons in the entire network

fann_get_total_connections
fann_get_train_error_function
Fann İşlevleri
PHP Manual

fann_get_total_neurons

(PECL fann >= 1.0.0)

fann_get_total_neurons — Get the total number of neurons in the entire network

Açıklama

int fann_get_total_neurons ( resource $ann )

Get the total number of neurons in the entire network. This number does also include the bias neurons, so a 2-4-2 network has 2+4+2 +2(bias) = 10 neurons.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

Total number of neurons in the entire network, or FALSE on error.

fann_get_total_connections
fann_get_train_error_function
Fann İşlevleri


Returns the error function used during training

fann_get_total_neurons
fann_get_train_stop_function
Fann İşlevleri
PHP Manual

fann_get_train_error_function

(PECL fann >= 1.0.0)

fann_get_train_error_function — Returns the error function used during training

Açıklama

int fann_get_train_error_function ( resource $ann )

Returns the error function used during training.

The error functions are described further in error functions constants.

The default error function is FANN_ERRORFUNC_TANH.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

The error function constant, or FALSE on error.

Ayrıca Bakınız

  • fann_set_train_error_function() - Sets the error function used during training

fann_get_total_neurons
fann_get_train_stop_function
Fann İşlevleri


Returns the stop function used during training

fann_get_train_error_function
fann_get_training_algorithm
Fann İşlevleri
PHP Manual

fann_get_train_stop_function

(PECL fann >= 1.0.0)

fann_get_train_stop_function — Returns the stop function used during training

Açıklama

int fann_get_train_stop_function ( resource $ann )

Returns the stop function used during training.

The stop functions are described further in stop functions constants.

The default stop function is FANN_STOPFUNC_MSE.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

The stop function constant, or FALSE on error.

Ayrıca Bakınız

  • fann_set_train_stop_function() - Sets the stop function used during training

fann_get_train_error_function
fann_get_training_algorithm
Fann İşlevleri


Returns the training algorithm

fann_get_train_stop_function
fann_init_weights
Fann İşlevleri
PHP Manual

fann_get_training_algorithm

(PECL fann >= 1.0.0)

fann_get_training_algorithm — Returns the training algorithm

Açıklama

int fann_get_training_algorithm ( resource $ann )

Returns the training algorithm. This training algorithm is used by fann_train_on_data() and associated functions.

Note that this algorithm is also used during fann_cascadetrain_on_data(), although only FANN_TRAIN_RPROP and FANN_TRAIN_QUICKPROP is allowed during cascade training.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

Training algorithm constant, or FALSE on error.

Ayrıca Bakınız

  • fann_set_training_algorithm() - Sets the training algorithm

fann_get_train_stop_function
fann_init_weights
Fann İşlevleri


Initialize the weights using Widrow + Nguyen’s algorithm

fann_get_training_algorithm
fann_length_train_data
Fann İşlevleri
PHP Manual

fann_init_weights

(PECL fann >= 1.0.0)

fann_init_weights — Initialize the weights using Widrow + Nguyen's algorithm

Açıklama

bool fann_init_weights ( resource $ann , resource $train_data )

Initialize the weights using Widrow + Nguyen's algorithm.

This function behaves similarly to fann_randomize_weights(). It will use the algorithm developed by Derrick Nguyen and Bernard Widrow to set the weights in such a way as to speed up training. This technique is not always successful, and in some cases can be less efficient than a purely random initialization.

The algorithm requires access to the range of the input data (for example largest and smallest input), and therefore accepts a second argument, data, which is the training data that will be used to train the network.

Değiştirgeler

ann

Neural network resource.

train_data

Neural network training data resource.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_randomize_weights() - Give each connection a random weight between min_weight and max_weight
  • fann_read_train_from_file() - Reads a file that stores training data

fann_get_training_algorithm
fann_length_train_data
Fann İşlevleri


Returns the number of training patterns in the train data

fann_init_weights
fann_merge_train_data
Fann İşlevleri
PHP Manual

fann_length_train_data

(PECL fann >= 1.0.0)

fann_length_train_data — Returns the number of training patterns in the train data

Açıklama

int fann_length_train_data ( resource $data )

Returns the number of training patterns in the train data resource.

Değiştirgeler

data

Neural network training data resource.

Dönen Değerler

Number of elements in the train data resource, or FALSE on error.

fann_init_weights
fann_merge_train_data
Fann İşlevleri


Merges the train data

fann_length_train_data
fann_num_input_train_data
Fann İşlevleri
PHP Manual

fann_merge_train_data

(PECL fann >= 1.0.0)

fann_merge_train_data — Merges the train data

Açıklama

resource fann_merge_train_data ( resource $data1 , resource $data2 )

Merges the data from data1 and data2 into a new train data resource.

Değiştirgeler

data1

Neural network training data resource.

data2

Neural network training data resource.

Dönen Değerler

New merged train data resource, or FALSE on error.

fann_length_train_data
fann_num_input_train_data
Fann İşlevleri


Returns the number of inputs in each of the training patterns in the train data

fann_merge_train_data
fann_num_output_train_data
Fann İşlevleri
PHP Manual

fann_num_input_train_data

(PECL fann >= 1.0.0)

fann_num_input_train_data — Returns the number of inputs in each of the training patterns in the train data

Açıklama

int fann_num_input_train_data ( resource $data )

Returns the number of inputs in each of the training patterns in the train data resource.

Değiştirgeler

data

Neural network training data resource.

Dönen Değerler

The number of inputs, or FALSE on error.

Ayrıca Bakınız

  • fann_length_train_data() - Returns the number of training patterns in the train data
  • fann_num_output_train_data() - Returns the number of outputs in each of the training patterns in the train data

fann_merge_train_data
fann_num_output_train_data
Fann İşlevleri


Returns the number of outputs in each of the training patterns in the train data

fann_num_input_train_data
fann_print_error
Fann İşlevleri
PHP Manual

fann_num_output_train_data

(PECL fann >= 1.0.0)

fann_num_output_train_data — Returns the number of outputs in each of the training patterns in the train data

Açıklama

int fann_num_output_train_data ( resource $data )

Returns the number of outputs in each of the training patterns in the train data resource.

Değiştirgeler

data

Neural network training data resource.

Dönen Değerler

The number of outputs, or FALSE on error.

Ayrıca Bakınız

  • fann_length_train_data() - Returns the number of training patterns in the train data
  • fann_num_input_train_data() - Returns the number of inputs in each of the training patterns in the train data

fann_num_input_train_data
fann_print_error
Fann İşlevleri


Prints the error string

fann_num_output_train_data
fann_randomize_weights
Fann İşlevleri
PHP Manual

fann_print_error

(PECL fann >= 1.0.0)

fann_print_error — Prints the error string

Açıklama

void fann_print_error ( string $errdat )

Prints the error string.

Değiştirgeler

errdat

Either neural network resource or neural network trainining data resource.

Dönen Değerler

No value is returned.

Ayrıca Bakınız

  • fann_get_errstr() - Returns the last errstr

fann_num_output_train_data
fann_randomize_weights
Fann İşlevleri


Give each connection a random weight between min_weight and max_weight

fann_print_error
fann_read_train_from_file
Fann İşlevleri
PHP Manual

fann_randomize_weights

(PECL fann >= 1.0.0)

fann_randomize_weights — Give each connection a random weight between min_weight and max_weight

Açıklama

bool fann_randomize_weights ( resource $ann , float $min_weight , float $max_weight )

Give each connection a random weight between min_weight and max_weight

From the beginning the weights are random between -0.1 and 0.1.

Değiştirgeler

ann

Neural network resource.

min_weight

Minimum weight value

max_weight

Maximum weight value

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_init_weights() - Initialize the weights using Widrow + Nguyen’s algorithm

fann_print_error
fann_read_train_from_file
Fann İşlevleri


Reads a file that stores training data

fann_randomize_weights
fann_reset_errno
Fann İşlevleri
PHP Manual

fann_read_train_from_file

(PECL fann >= 1.0.0)

fann_read_train_from_file — Reads a file that stores training data

Açıklama

resource fann_read_train_from_file ( string $filename )

Reads a file that stores training data.

Değiştirgeler

filename

The input file in the following format:

num_train_data num_input num_output
inputdata seperated by space
outputdata seperated by space

.
.
.

inputdata seperated by space
outputdata seperated by space

Dönen Değerler

Returns a train data resource on success, or FALSE on error.

Örnekler

Örnek 1 fann_read_train_from_file() example

<?php
$train_data = fann_read_train_from_file("xor.data");
if ($train_data) {
    // Do something with $train_data for XOR function
}
?>

Contents of xor.data

4 2 1
-1 -1
-1
-1 1
1
1 -1
1
1 1
-1

Ayrıca Bakınız

  • fann_train_on_data() - Trains on an entire dataset for a period of time
  • fann_destroy_train() - Destructs the training data
  • fann_save_train() - Save the training structure to a file

fann_randomize_weights
fann_reset_errno
Fann İşlevleri


Resets the last error number

fann_read_train_from_file
fann_reset_errstr
Fann İşlevleri
PHP Manual

fann_reset_errno

(PECL fann >= 1.0.0)

fann_reset_errno — Resets the last error number

Açıklama

void fann_reset_errno ( resource $errdat )

Resets the last error number.

Değiştirgeler

errdat

Either neural network resource or neural network trainining data resource.

Dönen Değerler

No value is returned.

Ayrıca Bakınız

  • fann_get_errno() - Returns the last error number
  • fann_reset_errstr() - Resets the last error string

fann_read_train_from_file
fann_reset_errstr
Fann İşlevleri


Resets the last error string

fann_reset_errno
fann_reset_MSE
Fann İşlevleri
PHP Manual

fann_reset_errstr

(PECL fann >= 1.0.0)

fann_reset_errstr — Resets the last error string

Açıklama

void fann_reset_errstr ( resource $errdat )

Resets the last error string.

Değiştirgeler

errdat

Either neural network resource or neural network trainining data resource.

Dönen Değerler

No value is returned.

Ayrıca Bakınız

  • fann_get_errstr() - Returns the last errstr
  • fann_reset_errno() - Resets the last error number

fann_reset_errno
fann_reset_MSE
Fann İşlevleri


Resets the mean square error from the network

fann_reset_errstr
fann_run
Fann İşlevleri
PHP Manual

fann_reset_MSE

(PECL fann >= 1.0.0)

fann_reset_MSE — Resets the mean square error from the network

Açıklama

bool fann_reset_MSE ( string $ann )

Resets the mean square error from the network.

This function also resets the number of bits that fail.

Değiştirgeler

ann

Neural network resource.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_get_MSE() - Reads the mean square error from the network
  • fann_get_bit_fail() - The number of fail bits
  • fann_get_bit_fail_limit() - Returns the bit fail limit used during training

fann_reset_errstr
fann_run
Fann İşlevleri


Will run input through the neural network

fann_reset_MSE
fann_save_train
Fann İşlevleri
PHP Manual

fann_run

(PECL fann >= 1.0.0)

fann_run — Will run input through the neural network

Açıklama

array fann_run ( resource $ann , array $input )

Will run input through the neural network, returning an array of outputs, the number of which being equal to the number of neurons in the output layer.

Değiştirgeler

ann

Neural network resource.

input

Array of input values

Dönen Değerler

Array of output values, or FALSE on error

fann_reset_MSE
fann_save_train
Fann İşlevleri


Save the training structure to a file

fann_run
fann_save
Fann İşlevleri
PHP Manual

fann_save_train

(PECL fann >= 1.0.0)

fann_save_train — Save the training structure to a file

Açıklama

bool fann_save_train ( resource $data , string $file_name )

Save the training data to a file, with the format as specified in fann_read_train_from_file().

Değiştirgeler

data

Neural network training data resource.

file_name

The file name of the file where training data is saved to.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_read_train_from_file() - Reads a file that stores training data

fann_run
fann_save
Fann İşlevleri


Saves the entire network to a configuration file

fann_save_train
fann_scale_input_train_data
Fann İşlevleri
PHP Manual

fann_save

(PECL fann >= 1.0.0)

fann_save — Saves the entire network to a configuration file

Açıklama

bool fann_save ( resource $ann , string $configuration_file )

Saves the entire network to a configuration file.

The configuration file contains all information about the neural network and enables fann_create_from_file() to create an exact copy of the neural network and all of the parameters associated with the neural network.

These three parameters (fann_set_callback(), fann_set_error_log(), fann_set_user_data()) are NOT saved to the file because they cannot safely be ported to a different location. Also temporary parameters generated during training like fann_get_MSE() is not saved.

Değiştirgeler

ann

Neural network resource.

configuration_file

The configuration file path.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_create_from_file() - Constructs a backpropagation neural network from a configuration file

fann_save_train
fann_scale_input_train_data
Fann İşlevleri


Scales the inputs in the training data to the specified range

fann_save
fann_scale_input
Fann İşlevleri
PHP Manual

fann_scale_input_train_data

(PECL fann >= 1.0.0)

fann_scale_input_train_data — Scales the inputs in the training data to the specified range

Açıklama

bool fann_scale_input_train_data ( resource $train_data , float $new_min , float $new_max )

Scales the inputs in the training data to the specified range.

Değiştirgeler

train_data

Neural network training data resource.

new_min

New minimum after scaling inputs in training data.

new_max

New maximum after scaling inputs in training data.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_scale_output_train_data() - Scales the outputs in the training data to the specified range
  • fann_scale_train_data() - Scales the inputs and outputs in the training data to the specified range

fann_save
fann_scale_input
Fann İşlevleri


Scale data in input vector before feed it to ann based on previously calculated parameters

fann_scale_input_train_data
fann_scale_output_train_data
Fann İşlevleri
PHP Manual

fann_scale_input

(PECL fann >= 1.0.0)

fann_scale_input — Scale data in input vector before feed it to ann based on previously calculated parameters

Açıklama

bool fann_scale_input ( resource $ann , array $input_vector )

Scale data in input vector before feed it to ann based on previously calculated parameters.

Değiştirgeler

ann

Neural network resource.

input_vector

Input vector that will be scaled

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_descale_input() - Scale data in input vector after get it from ann based on previously calculated parameters
  • fann_scale_output() - Scale data in output vector before feed it to ann based on previously calculated parameters

fann_scale_input_train_data
fann_scale_output_train_data
Fann İşlevleri


Scales the outputs in the training data to the specified range

fann_scale_input
fann_scale_output
Fann İşlevleri
PHP Manual

fann_scale_output_train_data

(PECL fann >= 1.0.0)

fann_scale_output_train_data — Scales the outputs in the training data to the specified range

Açıklama

bool fann_scale_output_train_data ( resource $train_data , float $new_min , float $new_max )

Scales the outputs in the training data to the specified range.

Değiştirgeler

train_data

Neural network training data resource.

new_min

New minimum after scaling outputs in training data.

new_max

New maximum after scaling outputs in training data.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_scale_input_train_data() - Scales the inputs in the training data to the specified range
  • fann_scale_train_data() - Scales the inputs and outputs in the training data to the specified range

fann_scale_input
fann_scale_output
Fann İşlevleri


Scale data in output vector before feed it to ann based on previously calculated parameters

fann_scale_output_train_data
fann_scale_train_data
Fann İşlevleri
PHP Manual

fann_scale_output

(PECL fann >= 1.0.0)

fann_scale_output — Scale data in output vector before feed it to ann based on previously calculated parameters

Açıklama

bool fann_scale_output ( resource $ann , array $output_vector )

Scale data in output vector before feed it to ann based on previously calculated parameters.

Değiştirgeler

ann

Neural network resource.

output_vector

Output vector that will be scaled

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_descale_output() - Scale data in output vector after get it from ann based on previously calculated parameters
  • fann_scale_input() - Scale data in input vector before feed it to ann based on previously calculated parameters

fann_scale_output_train_data
fann_scale_train_data
Fann İşlevleri


Scales the inputs and outputs in the training data to the specified range

fann_scale_output
fann_scale_train
Fann İşlevleri
PHP Manual

fann_scale_train_data

(PECL fann >= 1.0.0)

fann_scale_train_data — Scales the inputs and outputs in the training data to the specified range

Açıklama

bool fann_scale_train_data ( resource $train_data , float $new_min , float $new_max )

Scales the inputs and outputs in the training data to the specified range.

Değiştirgeler

train_data

Neural network training data resource.

new_min

New minimum after scaling inputs and outputs in training data.

new_max

New maximum after scaling inputs and outputs in training data.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_scale_output_train_data() - Scales the outputs in the training data to the specified range
  • fann_scale_input_train_data() - Scales the inputs in the training data to the specified range

fann_scale_output
fann_scale_train
Fann İşlevleri


Scale input and output data based on previously calculated parameters

fann_scale_train_data
fann_set_activation_function_hidden
Fann İşlevleri
PHP Manual

fann_scale_train

(PECL fann >= 1.0.0)

fann_scale_train — Scale input and output data based on previously calculated parameters

Açıklama

bool fann_scale_train ( resource $ann , resource $train_data )

Scale input and output data based on previously calculated parameters.

Değiştirgeler

ann

Neural network resource.

train_data

Neural network training data resource.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_descale_train() - Descale input and output data based on previously calculated parameters
  • fann_set_scaling_params() - Calculate input and output scaling parameters for future use based on training data

fann_scale_train_data
fann_set_activation_function_hidden
Fann İşlevleri


Sets the activation function for all of the hidden layers

fann_scale_train
fann_set_activation_function_layer
Fann İşlevleri
PHP Manual

fann_set_activation_function_hidden

(PECL fann >= 1.0.0)

fann_set_activation_function_hidden — Sets the activation function for all of the hidden layers

Açıklama

bool fann_set_activation_function_hidden ( resource $ann , int $activation_function )

Sets the activation function for all of the hidden layers.

Değiştirgeler

ann

Neural network resource.

activation_function

The activation functions constant.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_set_activation_function() - Sets the activation function for supplied neuron and layer
  • fann_set_activation_function_layer() - Sets the activation function for all the neurons in the supplied layer.
  • fann_set_activation_function_output() - Sets the activation function for the output layer
  • fann_set_activation_steepness() - Sets the activation steepness for supplied neuron and layer number

fann_scale_train
fann_set_activation_function_layer
Fann İşlevleri


Sets the activation function for all the neurons in the supplied layer.

fann_set_activation_function_hidden
fann_set_activation_function_output
Fann İşlevleri
PHP Manual

fann_set_activation_function_layer

(PECL fann >= 1.0.0)

fann_set_activation_function_layer — Sets the activation function for all the neurons in the supplied layer.

Açıklama

bool fann_set_activation_function_layer ( resource $ann , int $activation_function , int $layer )

Set the activation function for all the neurons in the layer number layer, counting the input layer as layer 0.

It is not possible to set activation functions for the neurons in the input layer.

Değiştirgeler

ann

Neural network resource.

activation_function

The activation functions constant.

layer

Layer number.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_set_activation_function() - Sets the activation function for supplied neuron and layer
  • fann_set_activation_function_hidden() - Sets the activation function for all of the hidden layers
  • fann_set_activation_function_output() - Sets the activation function for the output layer
  • fann_set_activation_steepness() - Sets the activation steepness for supplied neuron and layer number

fann_set_activation_function_hidden
fann_set_activation_function_output
Fann İşlevleri


Sets the activation function for the output layer

fann_set_activation_function_layer
fann_set_activation_function
Fann İşlevleri
PHP Manual

fann_set_activation_function_output

(PECL fann >= 1.0.0)

fann_set_activation_function_output — Sets the activation function for the output layer

Açıklama

bool fann_set_activation_function_output ( resource $ann , int $activation_function )

Sets the activation function for the output layer.

Değiştirgeler

ann

Neural network resource.

activation_function

The activation functions constant.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_set_activation_function() - Sets the activation function for supplied neuron and layer
  • fann_set_activation_function_layer() - Sets the activation function for all the neurons in the supplied layer.
  • fann_set_activation_function_hidden() - Sets the activation function for all of the hidden layers
  • fann_set_activation_steepness() - Sets the activation steepness for supplied neuron and layer number

fann_set_activation_function_layer
fann_set_activation_function
Fann İşlevleri


Sets the activation function for supplied neuron and layer

fann_set_activation_function_output
fann_set_activation_steepness_hidden
Fann İşlevleri
PHP Manual

fann_set_activation_function

(PECL fann >= 1.0.0)

fann_set_activation_function — Sets the activation function for supplied neuron and layer

Açıklama

bool fann_set_activation_function ( resource $ann , int $activation_function , int $layer , int $neuron )

Set the activation function for neuron number neuron in layer number layer, counting the input layer as layer 0.

It is not possible to set activation functions for the neurons in the input layer.

When choosing an activation function it is important to note that the activation functions have different range. FANN_SIGMOID is e.g. in the 0 - 1 range while FANN_SIGMOID_SYMMETRIC is in the -1 - 1 range and FANN_LINEAR is unbound.

The supplied activation_function value must be one of the activation functions constants.

The return value is one of the activation functions constants.

Değiştirgeler

ann

Neural network resource.

activation_function

The activation functions constant.

layer

Layer number.

neuron

Neuron number.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_set_activation_function_layer() - Sets the activation function for all the neurons in the supplied layer.
  • fann_set_activation_function_hidden() - Sets the activation function for all of the hidden layers
  • fann_set_activation_function_output() - Sets the activation function for the output layer
  • fann_set_activation_steepness() - Sets the activation steepness for supplied neuron and layer number
  • fann_get_activation_function() - Returns the activation function

fann_set_activation_function_output
fann_set_activation_steepness_hidden
Fann İşlevleri


Sets the steepness of the activation steepness for all neurons in the all hidden layers

fann_set_activation_function
fann_set_activation_steepness_layer
Fann İşlevleri
PHP Manual

fann_set_activation_steepness_hidden

(PECL fann >= 1.0.0)

fann_set_activation_steepness_hidden — Sets the steepness of the activation steepness for all neurons in the all hidden layers

Açıklama

bool fann_set_activation_steepness_hidden ( resource $ann , float $activation_steepness )

Sets the steepness of the activation steepness for all neurons in the all hidden layers.

Değiştirgeler

ann

Neural network resource.

activation_steepness

The activation steepness.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_set_activation_steepness() - Sets the activation steepness for supplied neuron and layer number
  • fann_set_activation_steepness_layer() - Sets the activation steepness for all of the neurons in the supplied layer number
  • fann_set_activation_steepness_output() - Sets the steepness of the activation steepness in the output layer
  • fann_get_activation_steepness() - Returns the activation steepness for supplied neuron and layer number
  • fann_set_activation_function() - Sets the activation function for supplied neuron and layer

fann_set_activation_function
fann_set_activation_steepness_layer
Fann İşlevleri


Sets the activation steepness for all of the neurons in the supplied layer number

fann_set_activation_steepness_hidden
fann_set_activation_steepness_output
Fann İşlevleri
PHP Manual

fann_set_activation_steepness_layer

(PECL fann >= 1.0.0)

fann_set_activation_steepness_layer — Sets the activation steepness for all of the neurons in the supplied layer number

Açıklama

bool fann_set_activation_steepness_layer ( resource $ann , float $activation_steepness , int $layer )

Set the activation steepness for all of the neurons in layer number layer, counting the input layer as layer 0.

It is not possible to set activation steepness for the neurons in the input layer.

Değiştirgeler

ann

Neural network resource.

activation_steepness

The activation steepness.

layer

Layer number.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_set_activation_steepness() - Sets the activation steepness for supplied neuron and layer number
  • fann_set_activation_steepness_hidden() - Sets the steepness of the activation steepness for all neurons in the all hidden layers
  • fann_set_activation_steepness_output() - Sets the steepness of the activation steepness in the output layer
  • fann_get_activation_steepness() - Returns the activation steepness for supplied neuron and layer number
  • fann_set_activation_function() - Sets the activation function for supplied neuron and layer

fann_set_activation_steepness_hidden
fann_set_activation_steepness_output
Fann İşlevleri


Sets the steepness of the activation steepness in the output layer

fann_set_activation_steepness_layer
fann_set_activation_steepness
Fann İşlevleri
PHP Manual

fann_set_activation_steepness_output

(PECL fann >= 1.0.0)

fann_set_activation_steepness_output — Sets the steepness of the activation steepness in the output layer

Açıklama

bool fann_set_activation_steepness_output ( resource $ann , float $activation_steepness )

Sets the steepness of the activation steepness in the output layer.

Değiştirgeler

ann

Neural network resource.

activation_steepness

The activation steepness.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_set_activation_steepness() - Sets the activation steepness for supplied neuron and layer number
  • fann_set_activation_steepness_layer() - Sets the activation steepness for all of the neurons in the supplied layer number
  • fann_set_activation_steepness_hidden() - Sets the steepness of the activation steepness for all neurons in the all hidden layers
  • fann_get_activation_steepness() - Returns the activation steepness for supplied neuron and layer number
  • fann_set_activation_function() - Sets the activation function for supplied neuron and layer

fann_set_activation_steepness_layer
fann_set_activation_steepness
Fann İşlevleri


Sets the activation steepness for supplied neuron and layer number

fann_set_activation_steepness_output
fann_set_bit_fail_limit
Fann İşlevleri
PHP Manual

fann_set_activation_steepness

(PECL fann >= 1.0.0)

fann_set_activation_steepness — Sets the activation steepness for supplied neuron and layer number

Açıklama

bool fann_set_activation_steepness ( resource $ann , float $activation_steepness , int $layer , int $neuron )

Set the activation steepness for neuron number neuron in layer number layer, counting the input layer as layer 0.

It is not possible to set activation steepness for the neurons in the input layer.

The steepness of an activation function says something about how fast the activation function goes from the minimum to the maximum. A high value for the activation function will also give a more agressive training.

When training neural networks where the output values should be at the extremes (usually 0 and 1, depending on the activation function), a steep activation function can be used (e.g. 1.0).

The default activation steepness is 0.5.

Değiştirgeler

ann

Neural network resource.

activation_steepness

The activation steepness.

layer

Layer number.

neuron

Neuron number.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_set_activation_steepness_layer() - Sets the activation steepness for all of the neurons in the supplied layer number
  • fann_set_activation_steepness_hidden() - Sets the steepness of the activation steepness for all neurons in the all hidden layers
  • fann_set_activation_steepness_output() - Sets the steepness of the activation steepness in the output layer
  • fann_get_activation_steepness() - Returns the activation steepness for supplied neuron and layer number
  • fann_set_activation_function() - Sets the activation function for supplied neuron and layer

fann_set_activation_steepness_output
fann_set_bit_fail_limit
Fann İşlevleri


Set the bit fail limit used during training

fann_set_activation_steepness
fann_set_callback
Fann İşlevleri
PHP Manual

fann_set_bit_fail_limit

(PECL fann >= 1.0.0)

fann_set_bit_fail_limit — Set the bit fail limit used during training

Açıklama

bool fann_set_bit_fail_limit ( resource $ann , float $bit_fail_limit )

Set the bit fail limit used during training.

Değiştirgeler

ann

Neural network resource.

bit_fail_limit

The bit fail limit.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_get_bit_fail_limit() - Returns the bit fail limit used during training

fann_set_activation_steepness
fann_set_callback
Fann İşlevleri


Sets the callback function for use during training

fann_set_bit_fail_limit
fann_set_cascade_activation_functions
Fann İşlevleri
PHP Manual

fann_set_callback

(PECL fann >= 1.0.0)

fann_set_callback — Sets the callback function for use during training

Açıklama

bool fann_set_callback ( resource $ann , collable $callback )

Sets the callback function for use during training. It means that it is called from fann_train_on_data() or fann_train_on_file().

Değiştirgeler

ann

Neural network resource.

callback

The supplied callback function takes following parameters:

  • ann - The neural network resource
  • train - The train data resource or NULL if called from fann_train_on_file()
  • max_epochs - The maximum number of epochs the training should continue
  • epochs_between_reports - The number of epochs between calling this function
  • desired_error - The desired fann_get_MSE() or fann_get_bit_fail(), depending on the stop function chosen by fann_set_train_stop_function()
  • epochs - The current epoch

The callback should return TRUE. If it returns FALSE, the training will terminate.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_train_on_data() - Trains on an entire dataset for a period of time
  • fann_train_on_file() - Trains on an entire dataset, which is read from file, for a period of time

fann_set_bit_fail_limit
fann_set_cascade_activation_functions
Fann İşlevleri


Sets the array of cascade candidate activation functions

fann_set_callback
fann_set_cascade_activation_steepnesses
Fann İşlevleri
PHP Manual

fann_set_cascade_activation_functions

(PECL fann >= 1.0.0)

fann_set_cascade_activation_functions — Sets the array of cascade candidate activation functions

Açıklama

bool fann_set_cascade_activation_functions ( resource $ann , array $cascade_activation_functions )

Sets the array of cascade candidate activation functions.

See fann_get_cascade_num_candidates() for a description of which candidate neurons will be generated by this array.

Değiştirgeler

ann

Neural network resource.

cascade_activation_functions

The array of cascade candidate activation functions.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_get_cascade_activation_functions_count() - Returns the number of cascade activation functions
  • fann_set_cascade_activation_functions()

fann_set_callback
fann_set_cascade_activation_steepnesses
Fann İşlevleri


Sets the array of cascade candidate activation steepnesses

fann_set_cascade_activation_functions
fann_set_cascade_candidate_change_fraction
Fann İşlevleri
PHP Manual

fann_set_cascade_activation_steepnesses

(PECL fann >= 1.0.0)

fann_set_cascade_activation_steepnesses — Sets the array of cascade candidate activation steepnesses

Açıklama

bool fann_set_cascade_activation_steepnesses ( resource $ann , array $cascade_activation_steepnesses_count )

Sets the array of cascade candidate activation steepnesses.

See fann_get_cascade_num_candidates() for a description of which candidate neurons will be generated by this array.

Değiştirgeler

ann

Neural network resource.

cascade_activation_steepnesses_count

The array of cascade candidate activation steepnesses.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_get_cascade_activation_steepnesses() - Returns the cascade activation steepnesses
  • fann_get_cascade_activation_steepnesses_count() - The number of activation steepnesses

fann_set_cascade_activation_functions
fann_set_cascade_candidate_change_fraction
Fann İşlevleri


Sets the cascade candidate change fraction

fann_set_cascade_activation_steepnesses
fann_set_cascade_candidate_limit
Fann İşlevleri
PHP Manual

fann_set_cascade_candidate_change_fraction

(PECL fann >= 1.0.0)

fann_set_cascade_candidate_change_fraction — Sets the cascade candidate change fraction

Açıklama

bool fann_set_cascade_candidate_change_fraction ( resource $ann , float $cascade_candidate_change_fraction )

Sets the cascade candidate change fraction.

Değiştirgeler

ann

Neural network resource.

cascade_candidate_change_fraction

The cascade candidate change fraction.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_get_cascade_candidate_change_fraction() - Returns the cascade candidate change fraction

fann_set_cascade_activation_steepnesses
fann_set_cascade_candidate_limit
Fann İşlevleri


Sets the candidate limit

fann_set_cascade_candidate_change_fraction
fann_set_cascade_candidate_stagnation_epochs
Fann İşlevleri
PHP Manual

fann_set_cascade_candidate_limit

(PECL fann >= 1.0.0)

fann_set_cascade_candidate_limit — Sets the candidate limit

Açıklama

bool fann_set_cascade_candidate_limit ( resource $ann , float $cascade_candidate_limit )

Sets the candidate limit.

Değiştirgeler

ann

Neural network resource.

cascade_candidate_limit

The candidate limit.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_get_cascade_candidate_limit() - Return the candidate limit

fann_set_cascade_candidate_change_fraction
fann_set_cascade_candidate_stagnation_epochs
Fann İşlevleri


Sets the number of cascade candidate stagnation epochs

fann_set_cascade_candidate_limit
fann_set_cascade_max_cand_epochs
Fann İşlevleri
PHP Manual

fann_set_cascade_candidate_stagnation_epochs

(PECL fann >= 1.0.0)

fann_set_cascade_candidate_stagnation_epochs — Sets the number of cascade candidate stagnation epochs

Açıklama

bool fann_set_cascade_candidate_stagnation_epochs ( resource $ann , int $cascade_candidate_stagnation_epochs )

Sets the number of cascade candidate stagnation epochs.

Değiştirgeler

ann

Neural network resource.

cascade_candidate_stagnation_epochs

The number of cascade candidate stagnation epochs.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_get_cascade_candidate_stagnation_epochs() - Returns the number of cascade candidate stagnation epochs

fann_set_cascade_candidate_limit
fann_set_cascade_max_cand_epochs
Fann İşlevleri


Sets the max candidate epochs

fann_set_cascade_candidate_stagnation_epochs
fann_set_cascade_max_out_epochs
Fann İşlevleri
PHP Manual

fann_set_cascade_max_cand_epochs

(PECL fann >= 1.0.0)

fann_set_cascade_max_cand_epochs — Sets the max candidate epochs

Açıklama

bool fann_set_cascade_max_cand_epochs ( resource $ann , int $cascade_max_cand_epochs )

Sets the max candidate epochs.

Değiştirgeler

ann

Neural network resource.

cascade_max_cand_epochs

The max candidate epochs.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_get_cascade_max_cand_epochs() - Returns the maximum candidate epochs

fann_set_cascade_candidate_stagnation_epochs
fann_set_cascade_max_out_epochs
Fann İşlevleri


Sets the maximum out epochs

fann_set_cascade_max_cand_epochs
fann_set_cascade_min_cand_epochs
Fann İşlevleri
PHP Manual

fann_set_cascade_max_out_epochs

(PECL fann >= 1.0.0)

fann_set_cascade_max_out_epochs — Sets the maximum out epochs

Açıklama

bool fann_set_cascade_max_out_epochs ( resource $ann , int $cascade_max_out_epochs )

Sets the maximum out epochs.

Değiştirgeler

ann

Neural network resource.

cascade_max_out_epochs

The maximum out epochs.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_get_cascade_max_out_epochs() - Returns the maximum out epochs

fann_set_cascade_max_cand_epochs
fann_set_cascade_min_cand_epochs
Fann İşlevleri


Sets the min candidate epochs

fann_set_cascade_max_out_epochs
fann_set_cascade_min_out_epochs
Fann İşlevleri
PHP Manual

fann_set_cascade_min_cand_epochs

(PECL fann >= 1.0.0)

fann_set_cascade_min_cand_epochs — Sets the min candidate epochs

Açıklama

bool fann_set_cascade_min_cand_epochs ( resource $ann , int $cascade_min_cand_epochs )

Sets the min candidate epochs.

Değiştirgeler

ann

Neural network resource.

cascade_min_cand_epochs

The minimum candidate epochs.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_get_cascade_min_cand_epochs() - Returns the minimum candidate epochs

fann_set_cascade_max_out_epochs
fann_set_cascade_min_out_epochs
Fann İşlevleri


Sets the minimum out epochs

fann_set_cascade_min_cand_epochs
fann_set_cascade_num_candidate_groups
Fann İşlevleri
PHP Manual

fann_set_cascade_min_out_epochs

(PECL fann >= 1.0.0)

fann_set_cascade_min_out_epochs — Sets the minimum out epochs

Açıklama

bool fann_set_cascade_min_out_epochs ( resource $ann , int $cascade_min_out_epochs )

Sets the minimum out epochs.

Değiştirgeler

ann

Neural network resource.

cascade_min_out_epochs

The minimum out epochs.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_get_cascade_min_out_epochs() - Returns the minimum out epochs

fann_set_cascade_min_cand_epochs
fann_set_cascade_num_candidate_groups
Fann İşlevleri


Sets the number of candidate groups

fann_set_cascade_min_out_epochs
fann_set_cascade_output_change_fraction
Fann İşlevleri
PHP Manual

fann_set_cascade_num_candidate_groups

(PECL fann >= 1.0.0)

fann_set_cascade_num_candidate_groups — Sets the number of candidate groups

Açıklama

bool fann_set_cascade_num_candidate_groups ( resource $ann , int $cascade_num_candidate_groups )

Sets the number of candidate groups.

Değiştirgeler

ann

Neural network resource.

cascade_num_candidate_groups

The number of candidate groups.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_get_cascade_num_candidate_groups() - Returns the number of candidate groups

fann_set_cascade_min_out_epochs
fann_set_cascade_output_change_fraction
Fann İşlevleri


Sets the cascade output change fraction

fann_set_cascade_num_candidate_groups
fann_set_cascade_output_stagnation_epochs
Fann İşlevleri
PHP Manual

fann_set_cascade_output_change_fraction

(PECL fann >= 1.0.0)

fann_set_cascade_output_change_fraction — Sets the cascade output change fraction

Açıklama

bool fann_set_cascade_output_change_fraction ( resource $ann , float $cascade_output_change_fraction )

Sets the cascade output change fraction.

Değiştirgeler

ann

Neural network resource.

cascade_output_change_fraction

The cascade output change fraction.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_get_cascade_output_change_fraction() - Returns the cascade output change fraction

fann_set_cascade_num_candidate_groups
fann_set_cascade_output_stagnation_epochs
Fann İşlevleri


Sets the number of cascade output stagnation epochs

fann_set_cascade_output_change_fraction
fann_set_cascade_weight_multiplier
Fann İşlevleri
PHP Manual

fann_set_cascade_output_stagnation_epochs

(PECL fann >= 1.0.0)

fann_set_cascade_output_stagnation_epochs — Sets the number of cascade output stagnation epochs

Açıklama

bool fann_set_cascade_output_stagnation_epochs ( resource $ann , int $cascade_output_stagnation_epochs )

Sets the number of cascade output stagnation epochs.

Değiştirgeler

ann

Neural network resource.

cascade_output_stagnation_epochs

The number of cascade output stagnation epochs.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_get_cascade_output_stagnation_epochs() - Returns the number of cascade output stagnation epochs

fann_set_cascade_output_change_fraction
fann_set_cascade_weight_multiplier
Fann İşlevleri


Sets the weight multiplier

fann_set_cascade_output_stagnation_epochs
fann_set_error_log
Fann İşlevleri
PHP Manual

fann_set_cascade_weight_multiplier

(PECL fann >= 1.0.0)

fann_set_cascade_weight_multiplier — Sets the weight multiplier

Açıklama

bool fann_set_cascade_weight_multiplier ( resource $ann , float $cascade_weight_multiplier )

Sets the weight multiplier.

Değiştirgeler

ann

Neural network resource.

cascade_weight_multiplier

The weight multiplier.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_get_cascade_weight_multiplier() - Returns the weight multiplier

fann_set_cascade_output_stagnation_epochs
fann_set_error_log
Fann İşlevleri


Sets where the errors are logged to

fann_set_cascade_weight_multiplier
fann_set_input_scaling_params
Fann İşlevleri
PHP Manual

fann_set_error_log

(PECL fann >= 1.0.0)

fann_set_error_log — Sets where the errors are logged to

Açıklama

void fann_set_error_log ( resource $errdat , string $log_file )

Sets where the errors are logged to.

Değiştirgeler

errdat

Either neural network resource or neural network trainining data resource.

log_file

The log file path.

Dönen Değerler

No value is returned.

fann_set_cascade_weight_multiplier
fann_set_input_scaling_params
Fann İşlevleri


Calculate input scaling parameters for future use based on training data

fann_set_error_log
fann_set_learning_momentum
Fann İşlevleri
PHP Manual

fann_set_input_scaling_params

(PECL fann >= 1.0.0)

fann_set_input_scaling_params — Calculate input scaling parameters for future use based on training data

Açıklama

bool fann_set_input_scaling_params ( resource $ann , resource $train_data , float $new_input_min , float $new_input_max )

Calculate input scaling parameters for future use based on training data.

Değiştirgeler

ann

Neural network resource.

train_data

Neural network training data resource.

new_input_min

The desired lower bound in input data after scaling (not strictly followed)

new_input_max

The desired upper bound in input data after scaling (not strictly followed)

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_set_output_scaling_params() - Calculate output scaling parameters for future use based on training data

fann_set_error_log
fann_set_learning_momentum
Fann İşlevleri


Sets the learning momentum

fann_set_input_scaling_params
fann_set_learning_rate
Fann İşlevleri
PHP Manual

fann_set_learning_momentum

(PECL fann >= 1.0.0)

fann_set_learning_momentum — Sets the learning momentum

Açıklama

bool fann_set_learning_momentum ( resource $ann , float $learning_momentum )

Sets the learning momentum.

More info available in fann_get_learning_momentum().

Değiştirgeler

ann

Neural network resource.

learning_momentum

The learning momentum.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_get_learning_momentum() - Returns the learning momentum
  • fann_set_training_algorithm() - Sets the training algorithm

fann_set_input_scaling_params
fann_set_learning_rate
Fann İşlevleri


Sets the learning rate

fann_set_learning_momentum
fann_set_output_scaling_params
Fann İşlevleri
PHP Manual

fann_set_learning_rate

(PECL fann >= 1.0.0)

fann_set_learning_rate — Sets the learning rate

Açıklama

bool fann_set_learning_rate ( resource $ann , float $learning_rate )

Sets the learning rate.

More info available in fann_get_learning_rate().

Değiştirgeler

ann

Neural network resource.

learning_rate

The learning rate.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_get_learning_rate() - Returns the learning rate
  • fann_set_training_algorithm() - Sets the training algorithm

fann_set_learning_momentum
fann_set_output_scaling_params
Fann İşlevleri


Calculate output scaling parameters for future use based on training data

fann_set_learning_rate
fann_set_quickprop_decay
Fann İşlevleri
PHP Manual

fann_set_output_scaling_params

(PECL fann >= 1.0.0)

fann_set_output_scaling_params — Calculate output scaling parameters for future use based on training data

Açıklama

bool fann_set_output_scaling_params ( resource $ann , resource $train_data , float $new_output_min , float $new_output_max )

Calculate output scaling parameters for future use based on training data.

Değiştirgeler

ann

Neural network resource.

train_data

Neural network training data resource.

new_output_min

The desired lower bound in output data after scaling (not strictly followed)

new_output_max

The desired upper bound in output data after scaling (not strictly followed)

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_set_input_scaling_params() - Calculate input scaling parameters for future use based on training data

fann_set_learning_rate
fann_set_quickprop_decay
Fann İşlevleri


Sets the quickprop decay factor

fann_set_output_scaling_params
fann_set_quickprop_mu
Fann İşlevleri
PHP Manual

fann_set_quickprop_decay

(PECL fann >= 1.0.0)

fann_set_quickprop_decay — Sets the quickprop decay factor

Açıklama

bool fann_set_quickprop_decay ( resource $ann , float $quickprop_decay )

Sets the quickprop decay factor.

Değiştirgeler

ann

Neural network resource.

quickprop_decay

The quickprop decay factor.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_get_quickprop_decay() - Returns the decay which is a factor that weights should decrease in each iteration during quickprop training

fann_set_output_scaling_params
fann_set_quickprop_mu
Fann İşlevleri


Sets the quickprop mu factor

fann_set_quickprop_decay
fann_set_rprop_decrease_factor
Fann İşlevleri
PHP Manual

fann_set_quickprop_mu

(PECL fann >= 1.0.0)

fann_set_quickprop_mu — Sets the quickprop mu factor

Açıklama

bool fann_set_quickprop_mu ( resource $ann , float $quickprop_mu )

Sets the quickprop mu factor.

Değiştirgeler

ann

Neural network resource.

quickprop_mu

The mu factor.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_get_quickprop_mu() - Returns the mu factor

fann_set_quickprop_decay
fann_set_rprop_decrease_factor
Fann İşlevleri


Sets the decrease factor used during RPROP training

fann_set_quickprop_mu
fann_set_rprop_delta_max
Fann İşlevleri
PHP Manual

fann_set_rprop_decrease_factor

(PECL fann >= 1.0.0)

fann_set_rprop_decrease_factor — Sets the decrease factor used during RPROP training

Açıklama

bool fann_set_rprop_decrease_factor ( resource $ann , float $rprop_decrease_factor )

Sets the decrease factor used during RPROP training.

Değiştirgeler

ann

Neural network resource.

rprop_decrease_factor

The decrease factor.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_get_rprop_decrease_factor() - Returns the increase factor used during RPROP training

fann_set_quickprop_mu
fann_set_rprop_delta_max
Fann İşlevleri


Sets the maximum step-size

fann_set_rprop_decrease_factor
fann_set_rprop_delta_min
Fann İşlevleri
PHP Manual

fann_set_rprop_delta_max

(PECL fann >= 1.0.0)

fann_set_rprop_delta_max — Sets the maximum step-size

Açıklama

bool fann_set_rprop_delta_max ( resource $ann , float $rprop_delta_max )

The maximum step-size is a positive number determining how large the maximum step-size may be.

Değiştirgeler

ann

Neural network resource.

rprop_delta_max

The maximum step-size.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_get_rprop_delta_max() - Returns the maximum step-size
  • fann_get_rprop_delta_min() - Returns the minimum step-size

fann_set_rprop_decrease_factor
fann_set_rprop_delta_min
Fann İşlevleri


Sets the minimum step-size

fann_set_rprop_delta_max
fann_set_rprop_delta_zero
Fann İşlevleri
PHP Manual

fann_set_rprop_delta_min

(PECL fann >= 1.0.0)

fann_set_rprop_delta_min — Sets the minimum step-size

Açıklama

bool fann_set_rprop_delta_min ( resource $ann , float $rprop_delta_min )

The minimum step-size is a small positive number determining how small the minimum step-size may be.

Değiştirgeler

ann

Neural network resource.

rprop_delta_min

The minimum step-size.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_get_rprop_delta_min() - Returns the minimum step-size

fann_set_rprop_delta_max
fann_set_rprop_delta_zero
Fann İşlevleri


Sets the initial step-size

fann_set_rprop_delta_min
fann_set_rprop_increase_factor
Fann İşlevleri
PHP Manual

fann_set_rprop_delta_zero

(PECL fann >= 1.0.0)

fann_set_rprop_delta_zero — Sets the initial step-size

Açıklama

bool fann_set_rprop_delta_zero ( resource $ann , float $rprop_delta_zero )

The initial step-size is a positive number determining the initial step size.

Değiştirgeler

ann

Neural network resource.

rprop_delta_zero

The initial step-size.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_get_rprop_delta_zero() - Returns the initial step-size
  • fann_get_rprop_delta_min() - Returns the minimum step-size
  • fann_get_rprop_delta_max() - Returns the maximum step-size

fann_set_rprop_delta_min
fann_set_rprop_increase_factor
Fann İşlevleri


Sets the increase factor used during RPROP training

fann_set_rprop_delta_zero
fann_set_sarprop_step_error_shift
Fann İşlevleri
PHP Manual

fann_set_rprop_increase_factor

(PECL fann >= 1.0.0)

fann_set_rprop_increase_factor — Sets the increase factor used during RPROP training

Açıklama

bool fann_set_rprop_increase_factor ( resource $ann , float $rprop_increase_factor )

Sets the increase factor used during RPROP training.

Değiştirgeler

ann

Neural network resource.

rprop_increase_factor

The increase factor.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_get_rprop_increase_factor() - Returns the increase factor used during RPROP training

fann_set_rprop_delta_zero
fann_set_sarprop_step_error_shift
Fann İşlevleri


Sets the sarprop step error shift

fann_set_rprop_increase_factor
fann_set_sarprop_step_error_threshold_factor
Fann İşlevleri
PHP Manual

fann_set_sarprop_step_error_shift

(PECL fann >= 1.0.0)

fann_set_sarprop_step_error_shift — Sets the sarprop step error shift

Açıklama

bool fann_set_sarprop_step_error_shift ( resource $ann , float $sarprop_step_error_shift )

Sets the sarprop step error shift.

Değiştirgeler

ann

Neural network resource.

sarprop_step_error_shift

The sarprop step error shift.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_get_sarprop_step_error_shift() - Returns the sarprop step error shift

fann_set_rprop_increase_factor
fann_set_sarprop_step_error_threshold_factor
Fann İşlevleri


Sets the sarprop step error threshold factor

fann_set_sarprop_step_error_shift
fann_set_sarprop_temperature
Fann İşlevleri
PHP Manual

fann_set_sarprop_step_error_threshold_factor

(PECL fann >= 1.0.0)

fann_set_sarprop_step_error_threshold_factor — Sets the sarprop step error threshold factor

Açıklama

bool fann_set_sarprop_step_error_threshold_factor ( resource $ann , float $sarprop_step_error_threshold_factor )

Sets the sarprop step error threshold factor.

Değiştirgeler

ann

Neural network resource.

sarprop_step_error_threshold_factor

The sarprop step error threshold factor.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_get_sarprop_step_error_threshold_factor() - Returns the sarprop step error threshold factor

fann_set_sarprop_step_error_shift
fann_set_sarprop_temperature
Fann İşlevleri


Sets the sarprop temperature

fann_set_sarprop_step_error_threshold_factor
fann_set_sarprop_weight_decay_shift
Fann İşlevleri
PHP Manual

fann_set_sarprop_temperature

(PECL fann >= 1.0.0)

fann_set_sarprop_temperature — Sets the sarprop temperature

Açıklama

bool fann_set_sarprop_temperature ( resource $ann , float $sarprop_temperature )

Sets the sarprop temperature.

Değiştirgeler

ann

Neural network resource.

sarprop_temperature

The sarprop temperature.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_get_sarprop_temperature() - Returns the sarprop temperature

fann_set_sarprop_step_error_threshold_factor
fann_set_sarprop_weight_decay_shift
Fann İşlevleri


Sets the sarprop weight decay shift

fann_set_sarprop_temperature
fann_set_scaling_params
Fann İşlevleri
PHP Manual

fann_set_sarprop_weight_decay_shift

(PECL fann >= 1.0.0)

fann_set_sarprop_weight_decay_shift — Sets the sarprop weight decay shift

Açıklama

bool fann_set_sarprop_weight_decay_shift ( resource $ann , float $sarprop_weight_decay_shift )

Sets the sarprop weight decay shift.

Değiştirgeler

ann

Neural network resource.

sarprop_weight_decay_shift

The sarprop weight decay shift.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_get_sarprop_weight_decay_shift() - Returns the sarprop weight decay shift

fann_set_sarprop_temperature
fann_set_scaling_params
Fann İşlevleri


Calculate input and output scaling parameters for future use based on training data

fann_set_sarprop_weight_decay_shift
fann_set_train_error_function
Fann İşlevleri
PHP Manual

fann_set_scaling_params

(PECL fann >= 1.0.0)

fann_set_scaling_params — Calculate input and output scaling parameters for future use based on training data

Açıklama

bool fann_set_scaling_params ( resource $ann , resource $train_data , float $new_input_min , float $new_input_max , float $new_output_min , float $new_output_max )

Calculate input and output scaling parameters for future use based on training data.

Değiştirgeler

ann

Neural network resource.

train_data

Neural network training data resource.

new_input_min

The desired lower bound in input data after scaling (not strictly followed)

new_input_max

The desired upper bound in input data after scaling (not strictly followed)

new_output_min

The desired lower bound in output data after scaling (not strictly followed)

new_output_max

The desired upper bound in output data after scaling (not strictly followed)

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_set_input_scaling_params() - Calculate input scaling parameters for future use based on training data
  • fann_set_output_scaling_params() - Calculate output scaling parameters for future use based on training data

fann_set_sarprop_weight_decay_shift
fann_set_train_error_function
Fann İşlevleri


Sets the error function used during training

fann_set_scaling_params
fann_set_train_stop_function
Fann İşlevleri
PHP Manual

fann_set_train_error_function

(PECL fann >= 1.0.0)

fann_set_train_error_function — Sets the error function used during training

Açıklama

bool fann_set_train_error_function ( resource $ann , int $error_function )

Sets the error function used during training.

The error functions are described further in error functions constants.

Değiştirgeler

ann

Neural network resource.

error_function

The error function constant

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_get_train_error_function() - Returns the error function used during training

fann_set_scaling_params
fann_set_train_stop_function
Fann İşlevleri


Sets the stop function used during training

fann_set_train_error_function
fann_set_training_algorithm
Fann İşlevleri
PHP Manual

fann_set_train_stop_function

(PECL fann >= 1.0.0)

fann_set_train_stop_function — Sets the stop function used during training

Açıklama

bool fann_set_train_stop_function ( resource $ann , int $stop_function )

Sets the stop function used during training.

The stop functions are described further in stop functions constants.

Değiştirgeler

ann

Neural network resource.

stop_function

The stop function constant.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_get_train_stop_function() - Returns the stop function used during training

fann_set_train_error_function
fann_set_training_algorithm
Fann İşlevleri


Sets the training algorithm

fann_set_train_stop_function
fann_set_weight_array
Fann İşlevleri
PHP Manual

fann_set_training_algorithm

(PECL fann >= 1.0.0)

fann_set_training_algorithm — Sets the training algorithm

Açıklama

bool fann_set_training_algorithm ( resource $ann , int $training_algorithm )

Sets the training algorithm.

More info available in fann_get_training_algorithm().

Değiştirgeler

ann

Neural network resource.

training_algorithm

Training algorithm constant

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_get_training_algorithm() - Returns the training algorithm

fann_set_train_stop_function
fann_set_weight_array
Fann İşlevleri


Set connections in the network

fann_set_training_algorithm
fann_set_weight
Fann İşlevleri
PHP Manual

fann_set_weight_array

(PECL fann >= 1.0.0)

fann_set_weight_array — Set connections in the network

Açıklama

bool fann_set_weight_array ( resource $ann , array $connections )

Set connections in the network.

Only the weights can be changed, connections and weights are ignored if they do not already exist in the network.

Değiştirgeler

ann

Neural network resource.

connections

An array of FANNConnection objects

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

fann_set_training_algorithm
fann_set_weight
Fann İşlevleri


Set a connection in the network

fann_set_weight_array
fann_shuffle_train_data
Fann İşlevleri
PHP Manual

fann_set_weight

(PECL fann >= 1.0.0)

fann_set_weight — Set a connection in the network

Açıklama

bool fann_set_weight ( resource $ann , int $from_neuron , int $to_neuron , float $weight )

Set a connections in the network.

Değiştirgeler

ann

Neural network resource.

from_neuron

The neuron where the connection starts

to_neuron

The neuron where the connection ends

weight

Connection weight

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

fann_set_weight_array
fann_shuffle_train_data
Fann İşlevleri


Shuffles training data, randomizing the order

fann_set_weight
fann_subset_train_data
Fann İşlevleri
PHP Manual

fann_shuffle_train_data

(PECL fann >= 1.0.0)

fann_shuffle_train_data — Shuffles training data, randomizing the order

Açıklama

bool fann_shuffle_train_data ( resource $train_data )

Shuffles training data, randomizing the order. This is recommended for incremental training, while it have no influence during batch training.

Değiştirgeler

train_data

Neural network training data resource.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

fann_set_weight
fann_subset_train_data
Fann İşlevleri


Returns an copy of a subset of the train data

fann_shuffle_train_data
fann_test_data
Fann İşlevleri
PHP Manual

fann_subset_train_data

(PECL fann >= 1.0.0)

fann_subset_train_data — Returns an copy of a subset of the train data

Açıklama

resource fann_subset_train_data ( resource $data , int $pos , int $length )

Returns an copy of a subset of the train data resource, starting at position pos and length elements forward.

The fann_subset_train_data(train_data, 0, fann_length_train_data(train_data)) do the same as fann_duplicate_train_data()

Değiştirgeler

data

Neural network training data resource.

pos

Starting position.

length

The number of copied elements.

Dönen Değerler

Returns a train data resource on success, or FALSE on error.

Ayrıca Bakınız

  • fann_duplicate_train_data() - Returns an exact copy of a fann train data

fann_shuffle_train_data
fann_test_data
Fann İşlevleri


Test a set of training data and calculates the MSE for the training data

fann_subset_train_data
fann_test
Fann İşlevleri
PHP Manual

fann_test_data

(PECL fann >= 1.0.0)

fann_test_data — Test a set of training data and calculates the MSE for the training data

Açıklama

float fann_test_data ( resource $ann , resource $data )

Test a set of training data and calculates the MSE for the training data.

This function updates the MSE and the bit fail values.

Değiştirgeler

ann

Neural network resource.

data

Neural network training data resource.

Dönen Değerler

The updated MSE, or FALSE on error.

Ayrıca Bakınız

  • fann_train_on_data() - Trains on an entire dataset for a period of time
  • fann_train_epoch() - Train one epoch with a set of training data
  • fann_get_bit_fail() - The number of fail bits
  • fann_get_MSE() - Reads the mean square error from the network
  • fann_set_training_algorithm() - Sets the training algorithm

fann_subset_train_data
fann_test
Fann İşlevleri


Test with a set of inputs, and a set of desired outputs

fann_test_data
fann_train_epoch
Fann İşlevleri
PHP Manual

fann_test

(PECL fann >= 1.0.0)

fann_test — Test with a set of inputs, and a set of desired outputs

Açıklama

bool fann_test ( resource $ann , array $input , array $desired_output )

Test with a set of inputs, and a set of desired outputs. This operation updates the mean square error, but does not change the network in any way.

Değiştirgeler

ann

Neural network resource.

input

An array of inputs. This array must be exactly fann_get_num_input() long.

desired_output

An array of desired outputs. This array must be exactly fann_get_num_output() long.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_test_data() - Test a set of training data and calculates the MSE for the training data
  • fann_train() - Train one iteration with a set of inputs, and a set of desired outputs
  • fann_get_num_input() - Get the number of input neurons
  • fann_get_num_output() - Get the number of output neurons

fann_test_data
fann_train_epoch
Fann İşlevleri


Train one epoch with a set of training data

fann_test
fann_train_on_data
Fann İşlevleri
PHP Manual

fann_train_epoch

(PECL fann >= 1.0.0)

fann_train_epoch — Train one epoch with a set of training data

Açıklama

float fann_train_epoch ( resource $ann , resource $data )

Train one epoch with the training data stored in data. One epoch is where all of the training data is considered exactly once.

This function returns the MSE error as it is calculated either before or during the actual training. This is not the actual MSE after the training epoch, but since calculating this will require to go through the entire training set once more. It is more than adequate to use this value during training.

The training algorithm used by this function is chosen by fann_set_training_algorithm() function.

Değiştirgeler

ann

Neural network resource.

data

Neural network training data resource.

Dönen Değerler

The MSE, or FALSE on error.

Ayrıca Bakınız

  • fann_train_on_data() - Trains on an entire dataset for a period of time
  • fann_test_data() - Test a set of training data and calculates the MSE for the training data
  • fann_get_MSE() - Reads the mean square error from the network
  • fann_set_training_algorithm() - Sets the training algorithm

fann_test
fann_train_on_data
Fann İşlevleri


Trains on an entire dataset for a period of time

fann_train_epoch
fann_train_on_file
Fann İşlevleri
PHP Manual

fann_train_on_data

(PECL fann >= 1.0.0)

fann_train_on_data — Trains on an entire dataset for a period of time

Açıklama

bool fann_train_on_data ( resource $ann , resource $data , int $max_epochs , int $epochs_between_reports , float $desired_error )

Trains on an entire dataset for a period of time.

This training uses the training algorithm chosen by fann_set_training_algorithm() and the parameters set for these training algorithms.

Değiştirgeler

ann

Neural network resource.

data

Neural network training data resource.

max_epochs

The maximum number of epochs the training should continue

epochs_between_reports

The number of epochs between calling a callback function. A value of zero means that user function is not called.

desired_error

The desired fann_get_MSE() or fann_get_bit_fail(), depending on the stop function chosen by fann_set_train_stop_function()

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_train_on_file() - Trains on an entire dataset, which is read from file, for a period of time
  • fann_train_epoch() - Train one epoch with a set of training data
  • fann_get_bit_fail() - The number of fail bits
  • fann_get_MSE() - Reads the mean square error from the network
  • fann_set_train_stop_function() - Sets the stop function used during training
  • fann_set_training_algorithm() - Sets the training algorithm
  • fann_set_callback() - Sets the callback function for use during training

fann_train_epoch
fann_train_on_file
Fann İşlevleri


Trains on an entire dataset, which is read from file, for a period of time

fann_train_on_data
fann_train
Fann İşlevleri
PHP Manual

fann_train_on_file

(PECL fann >= 1.0.0)

fann_train_on_file — Trains on an entire dataset, which is read from file, for a period of time

Açıklama

bool fann_train_on_file ( resource $ann , string $filename , int $max_epochs , int $epochs_between_reports , float $desired_error )

Trains on an entire dataset, which is read from file, for a period of time.

This training uses the training algorithm chosen by fann_set_training_algorithm() and the parameters set for these training algorithms.

Değiştirgeler

ann

Neural network resource.

filename

The file containing train data

max_epochs

The maximum number of epochs the training should continue

epochs_between_reports

The number of epochs between calling a user function. A value of zero means that user function is not called.

desired_error

The desired fann_get_MSE() or fann_get_bit_fail(), depending on the stop function chosen by fann_set_train_stop_function()

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_train_on_data() - Trains on an entire dataset for a period of time
  • fann_train_epoch() - Train one epoch with a set of training data
  • fann_get_bit_fail() - The number of fail bits
  • fann_get_MSE() - Reads the mean square error from the network
  • fann_set_train_stop_function() - Sets the stop function used during training
  • fann_set_training_algorithm() - Sets the training algorithm
  • fann_set_callback() - Sets the callback function for use during training

fann_train_on_data
fann_train
Fann İşlevleri


Train one iteration with a set of inputs, and a set of desired outputs

fann_train_on_file
FANNConnection
Fann İşlevleri
PHP Manual

fann_train

(PECL fann >= 1.0.0)

fann_train — Train one iteration with a set of inputs, and a set of desired outputs

Açıklama

bool fann_train ( resource $ann , array $input , array $desired_output )

Train one iteration with a set of inputs, and a set of desired outputs. This training is always incremental training, since only one pattern is presented.

Değiştirgeler

ann

Neural network resource.

input

An array of inputs. This array must be exactly fann_get_num_input() long.

desired_output

An array of desired outputs. This array must be exactly fann_get_num_output() long.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

Ayrıca Bakınız

  • fann_train_on_data() - Trains on an entire dataset for a period of time
  • fann_train_epoch() - Train one epoch with a set of training data
  • fann_get_num_input() - Get the number of input neurons
  • fann_get_num_output() - Get the number of output neurons

fann_train_on_file
FANNConnection
Fann İşlevleri


The FANNConnection class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

FANNConnection is used for the neural network connection. The objects of this class are used in fann_get_connection_array() and fann_set_weight_array().

Sınıf Sözdizimi

FANNConnection {
/* Özellikler */
public $from_neuron ;
public $to_neuron ;
public $weight ;
/* Yöntemler */
public __construct ( int $from_neuron , int $to_neuron , float $weight )
public int getFromNeuron ( void )
public int getToNeuron ( void )
public void getWeight ( void )
public bool setWeight ( float $weight )
}

Özellikler

from_neuron

The neuron where the connection starts.

to_neuron

The neuron where the connection ends.

weight

The weight of the connection.

İçindekiler

  • FANNConnection::__construct — The connection constructor
  • FANNConnection::getFromNeuron — Returns the postions of starting neuron.
  • FANNConnection::getToNeuron — Returns the postions of terminating neuron
  • FANNConnection::getWeight — Returns the connection weight
  • FANNConnection::setWeight — Sets the connections weight
fann_train
FANNConnection::__construct
FANN


The connection constructor

FANNConnection
FANNConnection::getFromNeuron
FANNConnection
PHP Manual

FANNConnection::__construct

(PECL fann >= 1.0.0)

FANNConnection::__construct — The connection constructor

Açıklama

public FANNConnection::__construct ( int $from_neuron , int $to_neuron , float $weight )

Create new connection and initialize its params. After creating the connection, only weight can be changed.

Değiştirgeler

from_neuron

The postion number of starting neuron.

to_neuron

The postion number of terminating neuron.

weight

The connection weight value.

FANNConnection
FANNConnection::getFromNeuron
FANNConnection


Returns the postions of starting neuron.

FANNConnection::__construct
FANNConnection::getToNeuron
FANNConnection
PHP Manual

FANNConnection::getFromNeuron

(PECL fann >= 1.0.0)

FANNConnection::getFromNeuron — Returns the postions of starting neuron.

Açıklama

public int FANNConnection::getFromNeuron ( void )

Returns the postions of starting neuron.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The postions of starting neuron.

FANNConnection::__construct
FANNConnection::getToNeuron
FANNConnection


Returns the postions of terminating neuron

FANNConnection::getFromNeuron
FANNConnection::getWeight
FANNConnection
PHP Manual

FANNConnection::getToNeuron

(PECL fann >= 1.0.0)

FANNConnection::getToNeuron — Returns the postions of terminating neuron

Açıklama

public int FANNConnection::getToNeuron ( void )

Returns the postions of terminating neuron.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The postions of terminating neuron.

FANNConnection::getFromNeuron
FANNConnection::getWeight
FANNConnection


Returns the connection weight

FANNConnection::getToNeuron
FANNConnection::setWeight
FANNConnection
PHP Manual

FANNConnection::getWeight

(PECL fann >= 1.0.0)

FANNConnection::getWeight — Returns the connection weight

Açıklama

public void FANNConnection::getWeight ( void )

Returns the connection weight.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The connection weight.

FANNConnection::getToNeuron
FANNConnection::setWeight
FANNConnection


Sets the connections weight

FANNConnection::getWeight
JSON
FANNConnection
PHP Manual

FANNConnection::setWeight

(PECL fann >= 1.0.0)

FANNConnection::setWeight — Sets the connections weight

Açıklama

public bool FANNConnection::setWeight ( float $weight )

Sets the connection weight.

This method is different than fann_set_weight(). It does not update the weight value in the network. The network value is updated only after calling fann_set_weight_array().

Değiştirgeler

weight

The connection weight.

Dönen Değerler

Returns TRUE on success, or FALSE otherwise.

FANNConnection::getWeight
JSON
FANNConnection


JavaScript Nesne Bildirimi

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • JSON İşlevleri
    • json_decode — Bir JSON dizgesini çözümler.
    • json_encode — Değerin JSON karşılığını verir.
    • json_last_error_msg — Returns the error string of the last json_encode() or json_decode() call
    • json_last_error — Oluşan son hatayı döndürür.
FANNConnection::setWeight
Giriş
Diğer Temel Eklentiler


Giriş

Bu eklenti JavaScript Nesne Bildirimini (» JavaScript Object Notation (JSON) gerçeklemektedir. Eklenti kodu Douglas Crockford tarafından JSON_checker işlenerek geliştirilmiştir.

JSON
Yapılandırma/Kurulum
JSON


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
JSON


Gereksinimler

Bu işlevleri kullanmak için hiçbir şey kurmaya gerek yoktur; PHP çekirdeğinin parçasıdırlar.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

PHP 5.2.0 sürümü itibariyle, JSON eklentisi paketlenmiş ve derlenmiş haliyle PHP'de öntanımlı olarak gelmektedir.

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/json

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

Aşağıdaki hata türü sabitleri, json_last_error() tarafından döndürülmektedir.

JSON_ERROR_NONE (integer)
Hata bulunamadı. PHP 5.3.0 sürümünden itibaren kullanılabilir.
JSON_ERROR_DEPTH (integer)
Azami yığın boyutu aşıldı. PHP 5.3.0 sürümünden itibaren kullanılabilir.
JSON_ERROR_STATE_MISMATCH (integer)
Kiplerin eşleşmemesi veya alttan taşma hatalarında oluşur. PHP 5.3.0 sürümünden itibaren kullanılabilir.
JSON_ERROR_CTRL_CHAR (integer)
Denetim karakteri hatası, muhtemelen yanlış kodlanmış. PHP 5.3.0 sürümünden itibaren kullanılabilir.
JSON_ERROR_SYNTAX (integer)
Sözdizimi hatası. PHP 5.3.0 sürümünden itibaren kullanılabilir.
JSON_ERROR_UTF8 (integer)
UTF-8 karakter kodlama hatası, muhtemelen yanlış kodlanmış. PHP 5.3.3 itibariyle geçerli bir sabit.
JSON_ERROR_RECURSION (integer)

json_encode() işlevine iç içe başvurular içeren nesne veya dizi aktarılmış. JSON_PARTIAL_OUTPUT_ON_ERROR seçeneği belirtilirse iç içe başvuruların bulunduğu yerlere NULL yerleştirilir.

PHP 5.5.0 sürümünden itibaren kullanılabilir.

JSON_ERROR_INF_OR_NAN (integer)

json_encode() işlevine NAN veya INF içeren bir değer aktarılmış. JSON_PARTIAL_OUTPUT_ON_ERROR seçeneği belirtilirse bu özel sayıların yerine 0yerleştirilir.

PHP 5.5.0 sürümünden itibaren kullanılabilir.

JSON_ERROR_UNSUPPORTED_TYPE (integer)

json_encode() işlevine desteklenmeyen türde (resource gibi) bir değer aktarılmış. JSON_PARTIAL_OUTPUT_ON_ERROR seçeneği belirtilirse desteklenmeyen değerin yerine NULL yerleştirilir.

PHP 5.5.0 sürümünden itibaren kullanılabilir.

Aşağıdaki sabitler json_encode() altında birleştirilebilir.

JSON_HEX_TAG (integer)
Bütün < ve > karakterleri \u003C ve \u003E karakterlerine dönüştürülürler. PHP 5.3.0 sürümünden itibaren kullanılabilir.
JSON_HEX_AMP (integer)
Bütün & karakterleri \u0026 karakterlerine dönüştürülürler. PHP 5.3.0 sürümünden itibaren kullanılabilir.
JSON_HEX_APOS (integer)
Bütün ' karakterleri \u0027 karakterlerine dönüştürülürler. PHP 5.3.0 sürümünden itibaren kullanılabilir.
JSON_HEX_QUOT (integer)
Bütün " karakterleri \u0022 dönüştürülürler. PHP 5.3.0 sürümünden itibaren kullanılabilir.
JSON_FORCE_OBJECT (integer)
İlişkisel olmayan dizi kullanıldığında çıktıları dizi yerine nesne olmaktadır. Özellikle dizi boş ve çıktı nesne olarak bekleniyorsa çok kullanışlıdır. PHP 5.3.0 sürümünden itibaren kullanılabilir.
JSON_NUMERIC_CHECK (integer)
Sayısal dizgileri sayı olarak ele alınır. PHP 5.3.3 sürümünden itibaren kullanılabilir.
JSON_BIGINT_AS_STRING (integer)
Büyük tamsayılar özgün dizgi değerleriyle ele alınır. PHP 5.4.0 sürümünden itibaren kullanılabilir.
JSON_PRETTY_PRINT (integer)
Dönen veriyi biçimlemek için boşluk karakteri kullanılır. PHP 5.4.0 sürümünden itibaren kullanılabilir.
JSON_UNESCAPED_SLASHES (integer)
/ öncelenmez. PHP 5.4.0 sürümünden itibaren kullanılabilir.
JSON_UNESCAPED_UNICODE (integer)
Çokbaytlı Unicode karakteri sayısal değerleriyle kodlar. (\uXXXX biçimi öntanımlıdır). PHP 5.4.0 sürümünden itibaren kullanılabilir.
Özkaynak Türleri
JSON İşlevleri
JSON


JSON İşlevleri

İçindekiler

  • json_decode — Bir JSON dizgesini çözümler.
  • json_encode — Değerin JSON karşılığını verir.
  • json_last_error_msg — Returns the error string of the last json_encode() or json_decode() call
  • json_last_error — Oluşan son hatayı döndürür.
Öntanımlı Sabitler
json_decode
JSON


Bir JSON dizgesini çözümler.

JSON İşlevleri
json_encode
JSON İşlevleri
PHP Manual

json_decode

(PHP 5 >= 5.2.0, PECL json >= 1.2.0, PHP 7)

json_decode — Bir JSON dizgesini çözümler.

Açıklama

mixed json_decode ( string $json [, bool $assoc = false [, int $depth = 512 ]] )

Kodlanmış bir JSON dizgesini çözümler ve PHP değişkenine çevirir.

Değiştirgeler

json

Deşifre edilmiş json dizgesi.

assoc

TRUE olduğu zaman nesneler bir ilişkisel diziye dönüştürülür.

depth

Kullanıcı tarafından belirtilen özyineleme derinliği.

Dönen Değerler

json ile şifrelenmiş değerler geriye PHP ye uygun veri türü olarak dönerler. Veriler doğru, yanlış ve boş(büyük-küçük harf duyarsız) şekilde sırasıyla TRUE, FALSE ve NULL olarak dönerler. Dönen değer NULL ise json çözülememiş ya da şifreleme verilen özyineleme derinliğinden daha fazladır.

Örnekler

Örnek 1 - json_decode() örnekleri

<?php
$json = '{"a":1,"b":2,"c":3,"d":4,"e":5}';

var_dump(json_decode($json));
var_dump(json_decode($json, true));

?>

Yukarıdaki örneğin çıktısı:

object(stdClass)#1 (5) {
    ["a"] => int(1)
    ["b"] => int(2)
    ["c"] => int(3)
    ["d"] => int(4)
    ["e"] => int(5)
}

array(5) {
    ["a"] => int(1)
    ["b"] => int(2)
    ["c"] => int(3)
    ["d"] => int(4)
    ["e"] => int(5)
}

Örnek 2 - Diğer örnek

<?php

$json = '{"foo-bar": 12345}';

$obj = json_decode($json);
print $obj->{'foo-bar'}; // 12345

?>

Örnek 3 - json_decode() kullanırken yapılan genel bir hata.

<?php

// Aşağıdaki dizgeler JavaScript de geçerli olmasına karşın JSON da geçerli değildir.

// isim ve değerler çift tırnak içine alınmalıdır.
// tek tırnak geçerli değildir.
$bad_json = "{ 'bar': 'baz' }";
json_decode($bad_json); // boş

// isim çift tırnak içine alınmalıdır.
$bad_json = '{ bar: "baz" }';
json_decode($bad_json); // boş

// sonda kalan virgüle izin verilmez
$bad_json = '{ bar: "baz", }';
json_decode($bad_json); // boş

?>

Örnek 4 - depth hataları

<?php
// Encode the data.
$json = json_encode(
    array(
        1 => array(
            'English' => array(
                'One',
                'January'
            ),
            'French' => array(
                'Une',
                'Janvier'
            )
        )
    )
);

// Define the errors.
$json_errors = array(
    JSON_ERROR_NONE => 'Hata bulunamadı',
    JSON_ERROR_DEPTH => 'Azami yığın boyutu aşıldı',
    JSON_ERROR_CTRL_CHAR => 'Kontrol karakteri hatası, muhtemelen yanlış şifrelenmiş',
    JSON_ERROR_SYNTAX => 'Sözdizimi hatası',
);

// Farklı derinlikteki hataları gösterir.
foreach(range(4, 3, -1) as $depth) {
    var_dump(json_decode($json, True, $depth));
    echo 'Son hata : ', $json_errors[json_last_error()], PHP_EOL, PHP_EOL;
    }
?>

Yukarıdaki örneğin çıktısı:

array(1) {
  [1]=>
  array(2) {
    ["English"]=>
    array(2) {
      [0]=>
      string(3) "One"
      [1]=>
      string(7) "January"
    }
    ["French"]=>
    array(2) {
      [0]=>
      string(3) "Une"
      [1]=>
      string(7) "Janvier"
    }
  }
}
Son hata : Hata bulunamadı

NULL
Son hata : Azami yığın boyutu aşıldı

Notlar

Bilginize:

JSON sınıfı JavaScript değildir, ancak JavaScript'in alt kümesidir.

Bilginize:

Bir hatayı çözmek ve hatanın tam niteliği belirlemek için json_last_error() kullanılabilir.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | İsteğe bağlı depth(derinlik) eklendi. Öntanımlı özyineleme derinliği 128 ile 512 arasına yükseltildi.
5.2.3 | Gruplama/iç içe koyma limiti 20 ile 128 arasına yükseltildi.

Ayrıca Bakınız

  • json_encode() - Değerin JSON karşılığını verir.
  • json_last_error() - Oluşan son hatayı döndürür.

JSON İşlevleri
json_encode
JSON İşlevleri


Değerin JSON karşılığını verir.

json_decode
json_last_error_msg
JSON İşlevleri
PHP Manual

json_encode

(PHP 5 >= 5.2.0, PECL json >= 1.2.0, PHP 7)

json_encode — Değerin JSON karşılığını verir.

Açıklama

string json_encode ( mixed $deger [, int $secenekler = 0 ] )

value(değer)'in JSON karşılığını içeren bir dizge döndürür.

Değiştirgeler

deger

eger kaynağa göre beklenen şekilde şifrelenir.

Bu işlev sadece UTF-8 ile şifrelenmiş verilerde çalışır.

secenekler

Oluşturulabilen bit maske tipleri JSON_HEX_QUOT, JSON_HEX_TAG, JSON_HEX_AMP, JSON_HEX_APOS, JSON_FORCE_OBJECT.

Dönen Değerler

Başarıyla kodlanmış JSON dizgesi döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | secenekler değiştirgesi eklendi.
5.2.1 | JSON şifrelemesini destekleyen temel veri türleri eklendi.

Örnekler

Örnek 1 - json_encode() örneği

<?php
$arr = array ('a'=>1,'b'=>2,'c'=>3,'d'=>4,'e'=>5);

echo json_encode($arr);
?>

Yukarıdaki örneğin çıktısı:

{"a":1,"b":2,"c":3,"d":4,"e":5}

Örnek 2 - json_encode() işlevinin tüm seçeneklerini gösteren bir örnek

<?php
$a = array('<foo>',"'bar'",'"baz"','&blong&');

echo "Normal: ", json_encode($a), "\n";
echo "Tags: ",   json_encode($a,JSON_HEX_TAG), "\n";
echo "Apos: ",   json_encode($a,JSON_HEX_APOS), "\n";
echo "Quot: ",   json_encode($a,JSON_HEX_QUOT), "\n";
echo "Amp: ",    json_encode($a,JSON_HEX_AMP), "\n";
echo "All: ",    json_encode($a,JSON_HEX_TAG|JSON_HEX_APOS|JSON_HEX_QUOT|JSON_HEX_AMP), "\n\n";

$b = array();

echo "Empty array output as array: ", json_encode($b), "\n";
echo "Empty array output as object: ", json_encode($b, JSON_FORCE_OBJECT), "\n\n";

$c = array(array(1,2,3));

echo "Non-associative array output as array: ", json_encode($c), "\n";
echo "Non-associative array output as object: ", json_encode($c, JSON_FORCE_OBJECT), "\n\n";
?>

Yukarıdaki örneğin çıktısı:

Normal: ["<foo>","'bar'","\"baz\"","&blong&"]
Tags: ["\u003Cfoo\u003E","'bar'","\"baz\"","&blong&"]
Apos: ["<foo>","\u0027bar\u0027","\"baz\"","&blong&"]
Quot: ["<foo>","'bar'","\u0022baz\u0022","&blong&"]
Amp: ["<foo>","'bar'","\"baz\"","\u0026blong\u0026"]
All: ["\u003Cfoo\u003E","\u0027bar\u0027","\u0022baz\u0022","\u0026blong\u0026"]

Empty array output as array: []
Empty array output as object: {}

Non-associative array output as array: [[1,2,3]]
Non-associative array output as object: {"0":{"0":1,"1":2,"2":3}}

Ayrıca Bakınız

  • json_decode() - Bir JSON dizgesini çözümler.

json_decode
json_last_error_msg
JSON İşlevleri


Returns the error string of the last json_encode() or json_decode() call

json_encode
json_last_error
JSON İşlevleri
PHP Manual

json_last_error_msg

(PHP 5 >= 5.5.0, PHP 7)

json_last_error_msg — Returns the error string of the last json_encode() or json_decode() call

Açıklama

string json_last_error_msg ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the error message on success, "No Error" if no error has occurred, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • json_last_error() - Oluşan son hatayı döndürür.

json_encode
json_last_error
JSON İşlevleri


Oluşan son hatayı döndürür.

json_last_error_msg
Judy
JSON İşlevleri
PHP Manual

json_last_error

(PHP 5 >= 5.3.0, PHP 7)

json_last_error — Oluşan son hatayı döndürür.

Açıklama

int json_last_error ( void )

Son JSON çözümleyicisi tarafından (varsa) oluşan son hatayı döndürür.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Tamsayı döndürür, ve değeri aşağıdaki sabitler olabilir:

JSON hata kodları
Sabit | Anlamı | Geçerlilik
JSON_ERROR_NONE | Hata bulunamadı |
JSON_ERROR_DEPTH | Azami yığın derinliği aşıldı |
JSON_ERROR_CTRL_CHAR | Denetim karakteri hatası, muhtemelen yanlış kodlanmış |
JSON_ERROR_SYNTAX | Sözdizimi hatası |
JSON_ERROR_UTF8 | UTF-8 karakter kodlama hatası, muhtemelen yanlış kodlanmış | PHP 5.3.1

Örnekler

Örnek 1 json_last_error() örneği

<?php
// Geçerli json dizgesi
$json[] = '{"Organization": "PHP Documentation Team"}';

// Geçersiz json dizgesi sözdizimi hatasına sebep
// olur, bu durumda biz tırnak için ' yerine "
// kullanırız
$json[] = "{'Organization': 'PHP Documentation Team'}";

foreach($json as $string)
{
    echo 'Decoding: ' . $string;
    json_decode($string);

    switch(json_last_error())
    {
        case JSON_ERROR_DEPTH:
            echo ' - Azami yığın derinliği aşıldı';
        break;
        case JSON_ERROR_CTRL_CHAR:
            echo ' - Beklenmeyen kontol karakteri bulundu';
        break;
        case JSON_ERROR_SYNTAX:
            echo ' - Sözdizimi hatası, kusurlu JSON';
        break;
        case JSON_ERROR_NONE:
            echo ' - Hatasız';
        break;
    }

    echo PHP_EOL;
}
?>

Yukarıdaki örneğin çıktısı:

Decoding: {"Organization": "PHP Documentation Team"} - Hatasız
Decoding: {'Organization': 'PHP Documentation Team'} - Sözdizimi hatası, kusurlu JSON

Ayrıca Bakınız

  • json_decode() - Bir JSON dizgesini çözümler.

json_last_error_msg
Judy
JSON İşlevleri


Judy Arrays

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Judy — The Judy class
    • Judy::byCount — Locate the Nth index present in the Judy array
    • Judy::__construct — Construct a new Judy object
    • Judy::count — Count the number of elements in the Judy array
    • Judy::__destruct — Destruct a Judy object
    • Judy::first — Search for the first index in the Judy array
    • Judy::firstEmpty — Search for the first absent index in the Judy array
    • Judy::free — Free the entire Judy array
    • Judy::getType — Return the type of the current Judy array
    • Judy::last — Search for the last index in the Judy array
    • Judy::lastEmpty — Search for the last absent index in the Judy array
    • Judy::memoryUsage — Return the memory used by the Judy array
    • Judy::next — Search for the next index in the Judy array
    • Judy::nextEmpty — Search for the next absent index in the Judy array
    • Judy::offsetExists — Whether a offset exists
    • Judy::offsetGet — Offset to retrieve
    • Judy::offsetSet — Offset to set
    • Judy::offsetUnset — Offset to unset
    • Judy::prev — Search for the previous index in the Judy array
    • Judy::prevEmpty — Search for the previous absent index in the Judy array
    • Judy::size — Return the size of the current Judy array
  • Judy İşlevleri
    • judy_type — Return the type of a Judy array
    • judy_version — Return or print the current PHP Judy version
json_last_error
Giriş
Diğer Temel Eklentiler


Giriş

PHP Judy is a PECL extension for the » Judy C library implementing dynamic sparse arrays.

A Judy array is a complex but very fast associative array data structure for storing and looking up values using integer or string keys. Unlike normal arrays, Judy arrays may be sparse; that is, they may have large ranges of unassigned indices.

A Judy array consumes memory only when populated yet can grow to take advantage of all available memory. Judy's key benefits are: scalability, performance, memory efficiency, and ease of use. Judy arrays are designed to grow without tuning into the peta-element range, scaling near O(log-base-256) -- 1 more RAM access at 256 X population.

Judy
Yapılandırma/Kurulum
Judy


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Judy


Gereksinimler

This extension require the » Judy C library.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu » PECL eklentisi PHP ile gelmez.

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/judy

Installation on Linux Systems

From sources

Download and install » libJudy, then :

     phpize
     ./configure --with-judy[=DIR]
     make
     make test
     make install

Ubuntu/Debian

libJudy can be installed with apt-get :

    apt-get install libjudydebian1 libjudy-dev
Then by installing the Judy extension from PECL or from the sources.

Installation on Windows Systems

Download » libJudy, then extract the sources and open the Visual Studio command prompt and navigate to the source directory. Then execute :

build
This creates "Judy.lib", copy this into the php-sdk library folder and name it "libJudy.lib" Then copy the include file "judy.h" into the php-sdk includes folder.

Next, the PHP Judy extension can be installed from PECL or from the sources by extracting the pecl/judy into your build folder where the build scripts will be able to pick it up, e.g.:

    C:\php\pecl\judy\
If your source of PHP is located in:
    C:\php\src\
The rest of the steps is pretty straight forward, like any other external extension:
    buildconf
    configure --with-judy=shared
    nmake

Installation on Mac OS X

Download and install » libJudy. Then install the Judy extension from PECL or from the sources.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Özkaynak Türleri

Bu eklentinin tanımlı hiçbir özkaynak türü yoktur.

Çalışma Anı Yapılandırması
Judy
Yapılandırma/Kurulum


The Judy class

(PECL judy >= 0.1.1)

Giriş

The Judy class implements the ArrayAccess interface and the Iterator interface. This class, once instantiated, can be accessed like a PHP array.

A PHP Judy object (or Judy Array) can be one of the following type :

  • Judy::BITSET
  • Judy::INT_TO_INT
  • Judy::INT_TO_MIXED
  • Judy::STRING_TO_INT
  • Judy::STRING_TO_MIXED

Örnek 1 Judy array example

<?php
    $judy = new Judy(Judy::INT_TO_MIXED);
    $judy[1] = "one";
    $judy[2] = array('a', 'b', 'c');
    $judy[3] = new Judy(Judy::BITSET);
?>

Sınıf Sözdizimi

Judy implements ArrayAccess , Iterator {
/* Constants */
const integer BITSET = 1 ;
const integer INT_TO_INT = 2 ;
const integer INT_TO_MIXED = 3 ;
const integer STRING_TO_INT = 4 ;
const integer STRING_TO_MIXED = 5 ;
/* Yöntemler */
public int byCount ( int $nth_index )
public __construct ( int $judy_type )
public int count ([ int $index_start = 0 [, int $index_end = -1 ]] )
public void __destruct ( void )
public mixed first ([ mixed $index ] )
public int firstEmpty ([ mixed $index = 0 ] )
public int free ( void )
public int getType ( void )
public void last ([ string $index ] )
public int lastEmpty ([ int $index = -1 ] )
public int memoryUsage ( void )
public mixed next ( mixed $index )
public int nextEmpty ( int $index )
public bool offsetExists ( mixed $offset )
public mixed offsetGet ( mixed $offset )
public bool offsetSet ( mixed $offset , mixed $value )
public bool offsetUnset ( mixed $offset )
public mixed prev ( mixed $index )
public int prevEmpty ( mixed $index )
public void size ( void )
}

Öntanımlı Sabitler

Judy::BITSET

Define the Judy Array as a Bitset with keys as Integer and Values as a Boolean

Judy::INT_TO_INT

Define the Judy Array with key/values as Integer, and Integer only.

Judy::INT_TO_MIXED

Define the Judy Array with keys as Integer and Values of any type.

Judy::STRING_TO_INT

Define the Judy Array with keys as a String and Values as Integer, and Integer only.

Judy::STRING_TO_MIXED

Define the Judy Array with keys as a String and Values of any type.

İçindekiler

  • Judy::byCount — Locate the Nth index present in the Judy array
  • Judy::__construct — Construct a new Judy object
  • Judy::count — Count the number of elements in the Judy array
  • Judy::__destruct — Destruct a Judy object
  • Judy::first — Search for the first index in the Judy array
  • Judy::firstEmpty — Search for the first absent index in the Judy array
  • Judy::free — Free the entire Judy array
  • Judy::getType — Return the type of the current Judy array
  • Judy::last — Search for the last index in the Judy array
  • Judy::lastEmpty — Search for the last absent index in the Judy array
  • Judy::memoryUsage — Return the memory used by the Judy array
  • Judy::next — Search for the next index in the Judy array
  • Judy::nextEmpty — Search for the next absent index in the Judy array
  • Judy::offsetExists — Whether a offset exists
  • Judy::offsetGet — Offset to retrieve
  • Judy::offsetSet — Offset to set
  • Judy::offsetUnset — Offset to unset
  • Judy::prev — Search for the previous index in the Judy array
  • Judy::prevEmpty — Search for the previous absent index in the Judy array
  • Judy::size — Return the size of the current Judy array
Özkaynak Türleri
Judy::byCount
Judy


Locate the Nth index present in the Judy array

Judy
Judy::__construct
Judy
PHP Manual

Judy::byCount

(PECL judy >= 0.1.1)

Judy::byCount — Locate the Nth index present in the Judy array

Açıklama

public int Judy::byCount ( int $nth_index )

Locate the Nth index present in the Judy array.

Değiştirgeler

nth_index

Nth index to return. If nth_index equal 1, then it will return the first index in the array.

Dönen Değerler

Return the index at the given Nth position.

Judy
Judy::__construct
Judy


Construct a new Judy object

Judy::byCount
Judy::count
Judy
PHP Manual

Judy::__construct

(PECL judy >= 0.1.1)

Judy::__construct — Construct a new Judy object

Açıklama

public Judy::__construct ( int $judy_type )

Construct a new Judy object. A Judy object can be accessed like a PHP Array.

Değiştirgeler

judy_type

The Judy type to be used.

Dönen Değerler

Return the new Judy instance.

Judy::byCount
Judy::count
Judy


Count the number of elements in the Judy array

Judy::__construct
Judy::__destruct
Judy
PHP Manual

Judy::count

(PECL judy >= 0.1.1)

Judy::count — Count the number of elements in the Judy array

Açıklama

public int Judy::count ([ int $index_start = 0 [, int $index_end = -1 ]] )

Count the number of elements in the Judy array.

Değiştirgeler

index_start

Start counting from the given index. Default is first index.

index_end

Stop counting when reaching this index. Default is last index.

Dönen Değerler

Return the number of elements.

Judy::__construct
Judy::__destruct
Judy


Destruct a Judy object

Judy::count
Judy::first
Judy
PHP Manual

Judy::__destruct

(PECL judy >= 0.1.1)

Judy::__destruct — Destruct a Judy object

Açıklama

public void Judy::__destruct ( void )

Destruct a Judy object.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Judy::count
Judy::first
Judy


Search for the first index in the Judy array

Judy::__destruct
Judy::firstEmpty
Judy
PHP Manual

Judy::first

(PECL judy >= 0.1.1)

Judy::first — Search for the first index in the Judy array

Açıklama

public mixed Judy::first ([ mixed $index ] )

Search (inclusive) for the first index present that is equal to or greater than the passed Index.

Değiştirgeler

index

The index can be an integer or a string corresponding to the index where to start the search.

Dönen Değerler

Return the corresponding index in the array.

Judy::__destruct
Judy::firstEmpty
Judy


Search for the first absent index in the Judy array

Judy::first
Judy::free
Judy
PHP Manual

Judy::firstEmpty

(PECL judy >= 0.1.1)

Judy::firstEmpty — Search for the first absent index in the Judy array

Açıklama

public int Judy::firstEmpty ([ mixed $index = 0 ] )

Search (inclusive) for the first absent index that is equal to or greater than the passed Index.

Değiştirgeler

index

The index can be an integer or a string corresponding to the index where to start the search.

Dönen Değerler

Return the corresponding index in the array.

Judy::first
Judy::free
Judy


Free the entire Judy array

Judy::firstEmpty
Judy::getType
Judy
PHP Manual

Judy::free

(PECL judy >= 0.1.1)

Judy::free — Free the entire Judy array

Açıklama

public int Judy::free ( void )

Free the entire Judy array.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Judy::firstEmpty
Judy::getType
Judy


Return the type of the current Judy array

Judy::free
Judy::last
Judy
PHP Manual

Judy::getType

(PECL judy >= 0.1.1)

Judy::getType — Return the type of the current Judy array

Açıklama

public int Judy::getType ( void )

Return an integer corresponding to the Judy type of the current object.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Return an integer corresponding to a Judy type.

Judy::free
Judy::last
Judy


Search for the last index in the Judy array

Judy::getType
Judy::lastEmpty
Judy
PHP Manual

Judy::last

(PECL judy >= 0.1.1)

Judy::last — Search for the last index in the Judy array

Açıklama

public void Judy::last ([ string $index ] )

Search (inclusive) for the last index present that is equal to or less than the passed Index.

Değiştirgeler

index

The index can be an integer or a string corresponding to the index where to start the search.

Dönen Değerler

Return the corresponding index in the array.

Judy::getType
Judy::lastEmpty
Judy


Search for the last absent index in the Judy array

Judy::last
Judy::memoryUsage
Judy
PHP Manual

Judy::lastEmpty

(PECL judy >= 0.1.1)

Judy::lastEmpty — Search for the last absent index in the Judy array

Açıklama

public int Judy::lastEmpty ([ int $index = -1 ] )

Search (inclusive) for the last absent index that is equal to or less than the passed Index.

Değiştirgeler

index

The index can be an integer or a string corresponding to the index where to start the search.

Dönen Değerler

Return the corresponding index in the array.

Judy::last
Judy::memoryUsage
Judy


Return the memory used by the Judy array

Judy::lastEmpty
Judy::next
Judy
PHP Manual

Judy::memoryUsage

(PECL judy >= 0.1.1)

Judy::memoryUsage — Return the memory used by the Judy array

Açıklama

public int Judy::memoryUsage ( void )

Return the memory used by the Judy array.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Return the memory used in bytes.

Judy::lastEmpty
Judy::next
Judy


Search for the next index in the Judy array

Judy::memoryUsage
Judy::nextEmpty
Judy
PHP Manual

Judy::next

(PECL judy >= 0.1.1)

Judy::next — Search for the next index in the Judy array

Açıklama

public mixed Judy::next ( mixed $index )

Search (exclusive) for the next index present that is greater than the passed Index.

Değiştirgeler

index

The index can be an integer or a string corresponding to the index where to start the search.

Dönen Değerler

Return the corresponding index in the array.

Judy::memoryUsage
Judy::nextEmpty
Judy


Search for the next absent index in the Judy array

Judy::next
Judy::offsetExists
Judy
PHP Manual

Judy::nextEmpty

(PECL judy >= 0.1.1)

Judy::nextEmpty — Search for the next absent index in the Judy array

Açıklama

public int Judy::nextEmpty ( int $index )

Search (exclusive) for the next absent index that is greater than the passed Index.

Değiştirgeler

index

The index can be an integer or a string corresponding to the index where to start the search.

Dönen Değerler

Return the corresponding index in the array.

Judy::next
Judy::offsetExists
Judy


Whether a offset exists

Judy::nextEmpty
Judy::offsetGet
Judy
PHP Manual

Judy::offsetExists

(PECL judy >= 0.1.1)

Judy::offsetExists — Whether a offset exists

Açıklama

public bool Judy::offsetExists ( mixed $offset )

Whether or not an offset exists.

Değiştirgeler

offset

An offset to check for.

Dönen Değerler

Returns TRUE on success or FALSE on failure.

Judy::nextEmpty
Judy::offsetGet
Judy


Offset to retrieve

Judy::offsetExists
Judy::offsetSet
Judy
PHP Manual

Judy::offsetGet

(PECL judy >= 0.1.1)

Judy::offsetGet — Offset to retrieve

Açıklama

public mixed Judy::offsetGet ( mixed $offset )

Returns the value at specified offset.

Değiştirgeler

offset

The offset to retrieve.

Dönen Değerler

Can return all value types.

Judy::offsetExists
Judy::offsetSet
Judy


Offset to set

Judy::offsetGet
Judy::offsetUnset
Judy
PHP Manual

Judy::offsetSet

(PECL judy >= 0.1.1)

Judy::offsetSet — Offset to set

Açıklama

public bool Judy::offsetSet ( mixed $offset , mixed $value )

Assigns a value to the specified offset.

Değiştirgeler

offset

The offset to assign the value to.

value

The value to set.

Dönen Değerler

No value is returned.

Judy::offsetGet
Judy::offsetUnset
Judy


Offset to unset

Judy::offsetSet
Judy::prev
Judy
PHP Manual

Judy::offsetUnset

(PECL judy >= 0.1.1)

Judy::offsetUnset — Offset to unset

Açıklama

public bool Judy::offsetUnset ( mixed $offset )

Unsets an offset.

Değiştirgeler

offset

The offset to unset.

Dönen Değerler

No value is returned.

Judy::offsetSet
Judy::prev
Judy


Search for the previous index in the Judy array

Judy::offsetUnset
Judy::prevEmpty
Judy
PHP Manual

Judy::prev

(PECL judy >= 0.1.1)

Judy::prev — Search for the previous index in the Judy array

Açıklama

public mixed Judy::prev ( mixed $index )

Search (exclusive) for the previous index present that is less than the passed Index.

Değiştirgeler

index

The index can be an integer or a string corresponding to the index where to start the search.

Dönen Değerler

Return the corresponding index in the array.

Judy::offsetUnset
Judy::prevEmpty
Judy


Search for the previous absent index in the Judy array

Judy::prev
Judy::size
Judy
PHP Manual

Judy::prevEmpty

(PECL judy >= 0.1.1)

Judy::prevEmpty — Search for the previous absent index in the Judy array

Açıklama

public int Judy::prevEmpty ( mixed $index )

Search (exclusive) for the previous index absent that is less than the passed Index.

Değiştirgeler

index

The index can be an integer or a string corresponding to the index where to start the search.

Dönen Değerler

Return the corresponding index in the array.

Judy::prev
Judy::size
Judy


Return the size of the current Judy array

Judy::prevEmpty
Judy İşlevleri
Judy
PHP Manual

Judy::size

(PECL judy >= 0.1.1)

Judy::size — Return the size of the current Judy array

Açıklama

public void Judy::size ( void )

This method is an alias of Judy::count.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Return an integer.

Judy::prevEmpty
Judy İşlevleri
Judy


Judy İşlevleri

İçindekiler

  • judy_type — Return the type of a Judy array
  • judy_version — Return or print the current PHP Judy version
Judy::size
judy_type
Judy


Return the type of a Judy array

Judy İşlevleri
judy_version
Judy İşlevleri
PHP Manual

judy_type

(PECL judy >= 0.1.1)

judy_type — Return the type of a Judy array

Açıklama

int judy_type ( Judy $array )

judy_type() return an integer corresponding to the Judy type of the specified Judy array.

Değiştirgeler

array

The Judy Array to test.

Dönen Değerler

Return an integer corresponding to a Judy type.

Judy İşlevleri
judy_version
Judy İşlevleri


Return or print the current PHP Judy version

judy_type
Lua
Judy İşlevleri
PHP Manual

judy_version

(PECL judy >= 0.1.1)

judy_version — Return or print the current PHP Judy version

Açıklama

string judy_version ( void )

Return a string of the PHP Judy version. If the return value is not used, the string will be printed.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Return a string of the PHP Judy version.

judy_type
Lua
Judy İşlevleri


Lua

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Lua — The Lua class
    • Lua::assign — Assign a PHP variable to Lua
    • Lua::call — Call Lua functions
    • Lua::__construct — Lua constructor
    • Lua::eval — Evaluate a string as Lua code
    • Lua::getVersion — The getversion purpose
    • Lua::include — Parse a Lua script file
    • Lua::registerCallback — Register a PHP function to Lua
  • LuaClosure — The LuaClosure class
    • LuaClosure::__invoke — invoke luaclosure
judy_version
Giriş
Diğer Temel Eklentiler


Giriş

"Lua is a powerful, fast, light-weight, embeddable scripting language." This extension embeds the lua interpreter and offers an OO-API to lua variables and functions.

Lua
Yapılandırma/Kurulum
Lua


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Lua


Gereksinimler

To use this extension, you will need Lua installed, available on the » Lua homepage

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu » PECL eklentisi PHP ile gelmez.

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/lua.

Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Özkaynak Türleri

Bu eklentinin tanımlı hiçbir özkaynak türü yoktur.

Çalışma Anı Yapılandırması
Lua
Yapılandırma/Kurulum


The Lua class

(PECL lua >=0.9.0)

Giriş

Sınıf Sözdizimi

Lua {
/* Constants */
const string LUA_VERSION = Lua 5.1.4 ;
/* Yöntemler */
public mixed assign ( string $name , string $value )
public mixed call ( callable $lua_func [, array $args [, int $use_self = 0 ]] )
public mixed __call ( callable $lua_func [, array $args [, int $use_self = 0 ]] )
public __construct ( string $lua_script_file = NULL )
public mixed eval ( string $statements )
public string getVersion ( void )
public mixed include ( string $file )
public mixed registerCallback ( string $name , callable $function )
}

Öntanımlı Sabitler

Lua::LUA_VERSION

İçindekiler

  • Lua::assign — Assign a PHP variable to Lua
  • Lua::call — Call Lua functions
  • Lua::__construct — Lua constructor
  • Lua::eval — Evaluate a string as Lua code
  • Lua::getVersion — The getversion purpose
  • Lua::include — Parse a Lua script file
  • Lua::registerCallback — Register a PHP function to Lua
Özkaynak Türleri
Lua::assign
Lua


Assign a PHP variable to Lua

Lua
Lua::call
Lua
PHP Manual

Lua::assign

(PECL lua >=0.9.0)

Lua::assign — Assign a PHP variable to Lua

Açıklama

public mixed Lua::assign ( string $name , string $value )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

name

value

Dönen Değerler

Returns $this or NULL on failure.

Örnekler

Örnek 1 Lua::assign()example

<?php
$lua = new Lua();
$lua->assign("php_var", array(1=>1, 2, 3)); //lua table index begin with 1
$lua->eval(<<<CODE
    print(php_var);
CODE
);
?>

Yukarıdaki örneğin çıktısı:

Array
 (
     [1] => 1
     [2] => 2
     [3] => 3
 )
Lua
Lua::call
Lua


Call Lua functions

Lua::assign
Lua::__construct
Lua
PHP Manual

Lua::call

Lua::__call

(PECL lua >=0.9.0)

Lua::call -- Lua::__call — Call Lua functions

Açıklama

public mixed Lua::call ( callable $lua_func [, array $args [, int $use_self = 0 ]] )
public mixed Lua::__call ( callable $lua_func [, array $args [, int $use_self = 0 ]] )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

lua_func

Function name in lua

args

Arguments passed to the Lua function

use_self

Whether to use self

Dönen Değerler

Returns result of the called function, NULL for wrong arguments or FALSE on other failure.

Örnekler

Örnek 1 Lua::call()example

<?php
$lua = new Lua();
$lua->eval(<<<CODE
    function dummy(foo, bar)
        print(foo, ",", bar)
    end
CODE
);
$lua->call("dummy", array("Lua", "geiliable\n"));
$lua->dummy("Lua", "geiliable"); // __call()
var_dump($lua->call(array("table", "concat"), array(array(1=>1, 2=>2, 3=>3), "-")));
?>

Yukarıdaki örneğin çıktısı:

Lua,geiliable
Lua,geiliable
string(5) "1-2-3"

Ayrıca Bakınız

  • __call()
Lua::assign
Lua::__construct
Lua


Lua constructor

Lua::call
Lua::eval
Lua
PHP Manual

Lua::__construct

(PECL lua >=0.9.0)

Lua::__construct — Lua constructor

Açıklama

public Lua::__construct ( string $lua_script_file = NULL )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

lua_script_file

Dönen Değerler

Lua::call
Lua::eval
Lua


Evaluate a string as Lua code

Lua::__construct
Lua::getVersion
Lua
PHP Manual

Lua::eval

(PECL lua >=0.9.0)

Lua::eval — Evaluate a string as Lua code

Açıklama

public mixed Lua::eval ( string $statements )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

statements

Dönen Değerler

Returns result of evaled code, NULL for wrong arguments or FALSE on other failure.

Örnekler

Örnek 1 Lua::eval()example

<?php
$lua = new Lua();
$lua->eval(<<<CODE
    print(2);
CODE
);
?>

Yukarıdaki örneğin çıktısı:

2
Lua::__construct
Lua::getVersion
Lua


The getversion purpose

Lua::eval
Lua::include
Lua
PHP Manual

Lua::getVersion

(PECL lua >=0.9.0)

Lua::getVersion — The getversion purpose

Açıklama

public string Lua::getVersion ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns Lua::LUA_VERSION.

Lua::eval
Lua::include
Lua


Parse a Lua script file

Lua::getVersion
Lua::registerCallback
Lua
PHP Manual

Lua::include

(PECL lua >=0.9.0)

Lua::include — Parse a Lua script file

Açıklama

public mixed Lua::include ( string $file )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

file

Dönen Değerler

Returns result of included code, NULL for wrong arguments or FALSE on other failure.

Lua::getVersion
Lua::registerCallback
Lua


Register a PHP function to Lua

Lua::include
LuaClosure
Lua
PHP Manual

Lua::registerCallback

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Lua::registerCallback — Register a PHP function to Lua

Açıklama

public mixed Lua::registerCallback ( string $name , callable $function )

Register a PHP function to Lua as a function named "$name"

Değiştirgeler

name

function

A valid PHP function callback

Dönen Değerler

Returns $this, NULL for wrong arguments or FALSE on other failure.

Örnekler

Örnek 1 Lua::registerCallback()example

<?php
$lua = new Lua();
$lua->registerCallback("echo", "var_dump");
$lua->eval(<<<CODE
    echo({1, 2, 3});
CODE
);
?>

Yukarıdaki örneğin çıktısı:

array(3) {
  [1]=>
  float(1)
  [2]=>
  float(2)
  [3]=>
  float(3)
}
Lua::include
LuaClosure
Lua


The LuaClosure class

(PECL lua >=0.9.0)

Giriş

LuaClosure is a wrapper class for LUA_TFUNCTION which could be return from calling to Lua function.

Sınıf Sözdizimi

LuaClosure {
/* Yöntemler */
public void __invoke ( mixed $arg [, mixed $... ] )
}

İçindekiler

  • LuaClosure::__invoke — invoke luaclosure
Lua::registerCallback
LuaClosure::__invoke
Lua


invoke luaclosure

LuaClosure
Muhtelif
LuaClosure
PHP Manual

LuaClosure::__invoke

(PECL lua >=0.9.0)

LuaClosure::__invoke — invoke luaclosure

Açıklama

public void LuaClosure::__invoke ( mixed $arg [, mixed $... ] )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

arg

...

Dönen Değerler

Örnekler

Örnek 1 LuaClosure::__invoke()example

<?php
$lua = new Lua();
$closure = $lua->eval(<<<CODE
    return (function ()
        print("hello world")
    end)
CODE
);

$lua->call($closure);
/* after PHP 5.3 */
$closure();
?>

Yukarıdaki örneğin çıktısı:

hello worldhello world
LuaClosure
Muhtelif
LuaClosure


Çeşitli İşlevler

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Çeşitli İşlevler
    • connection_aborted — İstemcinin bağlantıyı terkedip terketmediğine bakar
    • connection_status — Bağlantı durumu bit maskesini döndürür
    • constant — Bir sabitin değerini döndürür
    • define — Bir isimli sabit tanımlar
    • defined — Belirtilen isimli sabit tanımlı mı diye bakar
    • die — exit işlevinin eşdeğeri
    • eval — Bir dizgeyi bir PHP kodu olarak yorumlar
    • exit — Bir ileti çıktılayıp çalışmakta olan betiği sonlandırır
    • get_browser — Kullanıcının tarayıcısının neler yapabildiğini söyler
    • __halt_compiler — Derleyicinin çalışmasını durdurur
    • highlight_file — Bir dosyadaki sözdizimini vurgular
    • highlight_string — Bir dizgedeki söz dizimini vurgular
    • ignore_user_abort — Bir istemci bağlantıyı terkettiğinde betiğin sonlandırılıp sonlandırılmayacağını belirler
    • pack — Veriyi bir ikil dizge halinde paketler
    • php_check_syntax — Belirtilen (veya çalışan) dosyanın PHP sözdizimini denetler
    • php_strip_whitespace — Boşlukları ve açıklamaları ayıklanmış kaynak kodla döner
    • show_source — highlight_file işlevinin takma adıdır
    • sleep — Çalışmayı geciktirir
    • sys_getloadavg — Ortalama sistem yükünü döndürür
    • time_nanosleep — Çalışmayı saniye ve nanosaniye cinsinden geciktirir
    • time_sleep_until — Belirtilen zamana kadar betiği uyutur
    • uniqid — Eşsiz bir kimlik dizgesi üretir
    • unpack — Paketlenmiş bir ikil dizgeden verileri ayrıştırır
    • usleep — Çalışmayı mikrosaniye cinsinden geciktirir
LuaClosure::__invoke
Giriş
Diğer Temel Eklentiler


Giriş

Başka hiçbir sınıfa dahil edilemeyen işlevlere burada yer verilmiştir.

Muhtelif
Yapılandırma/Kurulum
Muhtelif


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Muhtelif


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Çeşitli Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişiklik Yeri | Sürüm Bilgisi
ignore_user_abort | "0" | PHP_INI_ALL |
highlight.string | "#DD0000" | PHP_INI_ALL |
highlight.comment | "#FF8000" | PHP_INI_ALL |
highlight.keyword | "#007700" | PHP_INI_ALL |
highlight.bg | "#FFFFFF" | PHP_INI_ALL | PHP 6.0.0'da kaldırıldı.
highlight.default | "#0000BB" | PHP_INI_ALL |
highlight.html | "#000000" | PHP_INI_ALL |
browscap | NULL | PHP_INI_SYSTEM |
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

ignore_user_abort boolean

FALSE öntanımlıdır. TRUE atanırsa istemci bağlantıyı terkettiğinde betikler sonlandırılmaz.

Ayrıca bakınız: ignore_user_abort().

highlight.bg string
highlight.comment string
highlight.default string
highlight.html string
highlight.keyword string
highlight.string string

Sözdizimi Vurgulama kipinde kullanılan renkler. <font color="??????"> olarak belirtilebilecek her değer kabul edilir.

browscap string

Tarayıcı yeteneklerinin konumu ve ismi. Ayrıca bakınız: get_browser().

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

CONNECTION_ABORTED (integer)
CONNECTION_NORMAL (integer)
CONNECTION_TIMEOUT (integer)
__COMPILER_HALT_OFFSET__ (integer)
PHP 5.1'de eklendi.
Özkaynak Türleri
Çeşitli İşlevler
Muhtelif


Çeşitli İşlevler

İçindekiler

  • connection_aborted — İstemcinin bağlantıyı terkedip terketmediğine bakar
  • connection_status — Bağlantı durumu bit maskesini döndürür
  • constant — Bir sabitin değerini döndürür
  • define — Bir isimli sabit tanımlar
  • defined — Belirtilen isimli sabit tanımlı mı diye bakar
  • die — exit işlevinin eşdeğeri
  • eval — Bir dizgeyi bir PHP kodu olarak yorumlar
  • exit — Bir ileti çıktılayıp çalışmakta olan betiği sonlandırır
  • get_browser — Kullanıcının tarayıcısının neler yapabildiğini söyler
  • __halt_compiler — Derleyicinin çalışmasını durdurur
  • highlight_file — Bir dosyadaki sözdizimini vurgular
  • highlight_string — Bir dizgedeki söz dizimini vurgular
  • ignore_user_abort — Bir istemci bağlantıyı terkettiğinde betiğin sonlandırılıp sonlandırılmayacağını belirler
  • pack — Veriyi bir ikil dizge halinde paketler
  • php_check_syntax — Belirtilen (veya çalışan) dosyanın PHP sözdizimini denetler
  • php_strip_whitespace — Boşlukları ve açıklamaları ayıklanmış kaynak kodla döner
  • show_source — highlight_file işlevinin takma adıdır
  • sleep — Çalışmayı geciktirir
  • sys_getloadavg — Ortalama sistem yükünü döndürür
  • time_nanosleep — Çalışmayı saniye ve nanosaniye cinsinden geciktirir
  • time_sleep_until — Belirtilen zamana kadar betiği uyutur
  • uniqid — Eşsiz bir kimlik dizgesi üretir
  • unpack — Paketlenmiş bir ikil dizgeden verileri ayrıştırır
  • usleep — Çalışmayı mikrosaniye cinsinden geciktirir
Öntanımlı Sabitler
connection_aborted
Muhtelif


İstemcinin bağlantıyı terkedip terketmediğine bakar

Çeşitli İşlevler
connection_status
Çeşitli İşlevler
PHP Manual

connection_aborted

(PHP 4, PHP 5, PHP 7)

connection_aborted — İstemcinin bağlantıyı terkedip terketmediğine bakar

Açıklama

int connection_aborted ( void )

İstemcinin bağlantıyı terkedip terketmediğine bakar.

Dönen Değerler

İstemci bağlantıyı terketmişse 1 yoksa 0 döner.

Ayrıca Bakınız

  • connection_status() - Bağlantı durumu bit maskesini döndürür
  • ignore_user_abort() - Bir istemci bağlantıyı terkettiğinde betiğin sonlandırılıp sonlandırılmayacağını belirler
  • PHP'nin bağlantıları nasıl yönettiği Bağlantı yönetimi sayfasında ayrıntılı olarak açıklanmıştır.

Çeşitli İşlevler
connection_status
Çeşitli İşlevler


Bağlantı durumu bit maskesini döndürür

connection_aborted
constant
Çeşitli İşlevler
PHP Manual

connection_status

(PHP 4, PHP 5, PHP 7)

connection_status — Bağlantı durumu bit maskesini döndürür

Açıklama

int connection_status ( void )

Bağlantı durumu bit maskesini döndürür.

Dönen Değerler

Bağlantı durumu bit maskesini döndürür. Bağlantı durumunu saptamak için CONNECTION_XXX sabitlerini bitsel işleçlerle ayrıştırın.

Ayrıca Bakınız

  • connection_aborted() - İstemcinin bağlantıyı terkedip terketmediğine bakar
  • ignore_user_abort() - Bir istemci bağlantıyı terkettiğinde betiğin sonlandırılıp sonlandırılmayacağını belirler
  • PHP'nin bağlantıları nasıl yönettiği Bağlantı yönetimi sayfasında ayrıntılı olarak açıklanmıştır.

connection_aborted
constant
Çeşitli İşlevler


Bir sabitin değerini döndürür

connection_status
define
Çeşitli İşlevler
PHP Manual

constant

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

constant — Bir sabitin değerini döndürür

Açıklama

mixed constant ( string $isim )

isim ile ismi belirtilen sabitin değerini döndürür.

constant() işlevi ismini bilmediğiniz (bir değişkende saklanmış veya bir işlevden dönmüş) bir sabitin değerini döndürmek için kullanılabilir.

Bu işlev ayrıca, sınıf sabitleri ile de çalışır.

Değiştirgeler

isim

Sabitin ismi.

Dönen Değerler

Sabit tanımlı değilse NULL, aksi takdirde sabitin değeri döner.

Örnekler

Örnek 1 - constant() örneği

<?php

define("MAXSIZE", 100);

echo MAXSIZE;
echo constant("MAXSIZE"); // Önceki satırla aynı.

interface bar {
    const test = 'foobar!';
}

class foo {
    const test = 'foobar!';
}

$const = 'test';

var_dump(constant('bar::'. $const)); // string(7) "foobar!"
var_dump(constant('foo::'. $const)); // string(7) "foobar!"

?>

Ayrıca Bakınız

  • define() - Bir isimli sabit tanımlar
  • defined() - Belirtilen isimli sabit tanımlı mı diye bakar
  • Sabitler bölümü

connection_status
define
Çeşitli İşlevler


Bir isimli sabit tanımlar

constant
defined
Çeşitli İşlevler
PHP Manual

define

(PHP 4, PHP 5, PHP 7)

define — Bir isimli sabit tanımlar

Açıklama

bool define ( string $isim , mixed $değer [, bool $harf_büyüklüğüne_duyarsız = false ] )

Çalışma sırasında bir isimli sabit tanımlamaya yarar.

Değiştirgeler

isim

Sabitin ismi.

değer

Sabitin değeri. Sadece sayıl ve null değerlere izin verilir. Sayıl değerler, integer, float, string veya boolean türünde değerlerdir. resource türünde sabitler tanımlamak mümkün ise de beklenmedik davranışlara yol açacağından bu önerilmez.

harf_büyüklüğüne_duyarsız

TRUE belirtilirse, tanımlanan sabitin ismi harf büyüklüğüne duyarsız olarak tanımlanır. Öntanımlı davranış harf büyüklüğüne duyarlıdır; yani SABiT ve Sabit farklı sabitler olarak ele alınır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Sabit tanımlamak

<?php
define("CONSTANT", "Hello world.");
echo CONSTANT; // çıktısı: "Hello world."
echo Constant; // çıktısı: "Constant" Ayrıca bir uyarı çıktılanır.

define("GREETING", "Hello you.", true);
echo GREETING; // çıktısı: "Hello you."
echo Greeting; // çıktısı: "Hello you."

?>

Ayrıca Bakınız

  • defined() - Belirtilen isimli sabit tanımlı mı diye bakar
  • constant() - Bir sabitin değerini döndürür
  • Sabitler bölümü

constant
defined
Çeşitli İşlevler


Belirtilen isimli sabit tanımlı mı diye bakar

define
die
Çeşitli İşlevler
PHP Manual

defined

(PHP 4, PHP 5, PHP 7)

defined — Belirtilen isimli sabit tanımlı mı diye bakar

Açıklama

bool defined ( string $isim )

Belirtilen isimli sabit tanımlıysa TRUE döndürür.

Bilginize:

Bir değişkenin tanımlı olup olmadığını görmek için isset() kullanın. defined() sadece sabitlere bakar. Bir işlevin varlığına bakmak için function_exists() kullanın.

Değiştirgeler

isim

Sabitin ismi.

Dönen Değerler

isim ile ismi belirtilen sabit tanımlıysa TRUE değilse FALSE döner.

Örnekler

Örnek 1 - Sabitlerin tanımlılığını sınamak

<?php
/* Kullanılan tırnağın türü önemlidir. */
if (defined('TEST')) {
    echo TEST;
}
?>

Ayrıca Bakınız

  • define() - Bir isimli sabit tanımlar
  • constant() - Bir sabitin değerini döndürür
  • get_defined_constants() - Tüm sabitlerin isimlerini ve değerlerini içeren bir ilişkisel dizi döndürür
  • function_exists() - Eğer işlev tanımlanmış ise TRUE döndürür
  • Sabitler bölümü

define
die
Çeşitli İşlevler


exit işlevinin eşdeğeri

defined
eval
Çeşitli İşlevler
PHP Manual

die

(PHP 4, PHP 5, PHP 7)

die — exit() işlevinin eşdeğeri

Açıklama

Bir dil oluşumu olup exit() işlevine eşdeğerdir.

defined
eval
Çeşitli İşlevler


Bir dizgeyi bir PHP kodu olarak yorumlar

die
exit
Çeşitli İşlevler
PHP Manual

eval

(PHP 4, PHP 5, PHP 7)

eval — Bir dizgeyi bir PHP kodu olarak yorumlar

Açıklama

mixed eval ( string $kod_dizgesi )

kod_dizgesi ile belirtilen dizgeyi bir PHP kodu olarak yorumlar. Kodları diğer her şeyin yanında, veritabanının bir metin alanında tutmak ve bu kodları gerektiğinde çalıştırmak için çok kullanışlıdır.

eval() işlevini kullanırken hatırda tutulması gereken bazı durumlar vardır: Aktarılan dizgenin PHP kodu olarak geçerli olması gerekir; deyimleri sonlandıran noktalı virgüller bu dahildir, yoksa eval() işlevinden sonraki satırda yorumlayıcı devreden çıkmaz. Ayrıca, kod_dizgesi içindeki öncelemlerin düzgün bir biçimde yapılmış olması gerekir. HTML ve PHP kodlarını karışık kullanmak isterseniz PHP kipinden çıkmak için PHP'nin kapama etiketini kullanabilirsiniz.

Ayrıca, eval() altında kullanılan değişkenlerin değerleriyle birlikte ana betikte geçerli kalacağını aklınızdan çıkarmayın.

Değiştirgeler

kod_dizgesi

Yorumlanacak PHP kodlarını içeren dizge. kod_dizgesi PHP açılış etiketlerini içermemelidir.

Dizge içindeki bir return deyimi dizgenin yorumlanmasını, anında durdurur.

Dönen Değerler

Kod dizgesi içinde bir return bulunmadıkça eval() daima NULL döndürür. return ile bir değer döndürülmesi durumunda bu değeri döndürür. Belirtilen dizgede bir çözümleme hatası saptanırsa eval() FALSE döndürür ve çalışma dosyadaki sonraki deyimden normal olarak devam eder. eval() işlevinin yorumladığı kodlardaki bir hatayı set_error_handler() kullanarak döndürmek mümkün değildir.

Örnekler

Örnek 1 - eval() örneği

<?php
$dizge = 'Gülhane';
$isim = 'çınar';
$metin = 'Burası $dizge parkı ve ben bir $isim ağacıyım.';
echo $metin. "\n";
eval("\$metin = \"$metin\";");
echo $metin. "\n";
?>

Yukarıdaki örneğin çıktısı:

Burası $dizge parkı ve ben bir $isim ağacıyım.
Burası Gülhane parkı ve ben bir çınar ağacıyım.

Notlar

Bilginize: Bu bir işlev değil, dil oluşumu olduğundan değişken işlevler kullanılarak çağrılamaz.

İpucu

Sonuçlarını doğrudan tarayıcıya çıktılayan her şey gibi, çıktı denetleme işlevleri bu işlevin de çıktısını yakalamak ve (örneğin) string türünde saklamak için kullanılabilir.

Bilginize:

Yorumlanan kodda ölümcül bir hata varsa betiğin tamamı durdurulur.

Ayrıca Bakınız

  • call_user_func() - İlk değiştirgede belirtilen kullanıcı işlevini çağırır

die
exit
Çeşitli İşlevler


Bir ileti çıktılayıp çalışmakta olan betiği sonlandırır

eval
get_browser
Çeşitli İşlevler
PHP Manual

exit

(PHP 4, PHP 5, PHP 7)

exit — Bir ileti çıktılayıp çalışmakta olan betiği sonlandırır

Açıklama

void exit ([ string $durum ] )
void exit ( int $durum )

Betiğin çalışmasını bitirir.

Değiştirgeler

durum

durum bir dizge ise işlev betiği sonlandırmadan önce bu dizgeyi basar.

status bir tamsayı ise bu değer çıkış durumu olarak kullanılır. Çıkış durumları 0..254 arasında olmalıdır. Çıkış durumu 255 PHP'nin kendi kullanımına ayrılmış olup kullanılmamalıdır. Durum 0, betiğin işini başarıyla yerine getirdiği anlamına gelir.

Bilginize: PHP >= 4.2.0 sürümlerinde durum tamsayı ise bu sayı basılmaz.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 - exit() örneği

<?php

$filename = '/dosya/yolu/veri/dosyası';
$file = fopen($filename, 'r')
    or exit("($filename) dosyası açılamadı");

?>

Örnek 2 - Çıkış durumu örneği

<?php

// Betik normal olarak sonlansın
exit;
exit();
exit(0);

// Bir hata koduyla sonlansın
exit(1);
exit(0376); // sekizlik

?>

Notlar

Bilginize: Bu bir işlev değil, dil oluşumu olduğundan değişken işlevler kullanılarak çağrılamaz.

Bilginize:

Bu bir dil oluşumu olup die() ile eşdeğerdir.

Ayrıca Bakınız

  • register_shutdown_function() - Betiğin işi bittiğinde çalıştırılacak işlevi tanımlar

eval
get_browser
Çeşitli İşlevler


Kullanıcının tarayıcısının neler yapabildiğini söyler

exit
__halt_compiler
Çeşitli İşlevler
PHP Manual

get_browser

(PHP 4, PHP 5, PHP 7)

get_browser — Kullanıcının tarayıcısının neler yapabildiğini söyler

Açıklama

mixed get_browser ([ string $tarayıcı [, bool $dizi_döndür = false ]] )

Kullanıcının tarayıcısının neler yapabildiğini, tarayıcılar için bilgi dosyası olan browscap.ini dosyasına bakarak saptamaya çalışır.

Değiştirgeler

tarayıcı

Araştırılacak tarayıcı. Öntanımlı olarak HTTP User-Agent başlığındaki değer kullanılır. Ancak bu değiştirgede değer aktararak başka bir tarayıcının bilgi dosyasına bakabilirsiniz.

Bu değiştirgede NULL değer aktarabilirsiniz.

dizi_döndür

TRUE atandığı takdirde, bu işlev bir nesne yerine bir dizi döndürür.

Dönen Değerler

Döndürülen nesne veya dizi, tarayıcının sürüm numarası, kimlik dizgesi, gibi bilgilerin yanında, çerçeveleri, çerezleri, JavaScript'leri kabul edip etmediği gibi bilgiller TRUE/FALSE değerleriyle içerilir.

cookies değeri, kullanıcının çerezleri kabul edip etmediğini değil, tarayıcının çerez kabul edebilme yeteneğini gösterir. Kullanıcının çerez kabul edip etmediğini anlamanın tek yolu setcookie() ile bir çerez gönderip sonra bu çerezin tarayıcıdaki değerini öğrenmeye çalışmaktır.

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.2 | İsteğe bağlı dizi_döndür değiştirgesi eklendi.

Örnekler

Örnek 1 Kullanıcının tarayıcısı ile ilgili tüm bilginin listelenmesi

<?php
echo $_SERVER['HTTP_USER_AGENT'] . "\n\n";

$browser = get_browser(null, true);
print_r($browser);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

Array
(
    [browser_name_regex] => ^mozilla/5\.0 (windows; .; windows nt 5\.1;
    .*rv:.*) gecko/.* firefox/0\.9.*$
    [browser_name_pattern] => Mozilla/5.0 (Windows; ?; Windows NT 5.1; *rv:*)
    Gecko/* Firefox/0.9*
    [parent] => Firefox 0.9
    [platform] => WinXP
    [browser] => Firefox
    [version] => 0.9
    [majorver] => 0
    [minorver] => 9
    [cssversion] => 2
    [frames] => 1
    [iframes] => 1
    [tables] => 1
    [cookies] => 1
    [backgroundsounds] =>
    [vbscript] =>
    [javascript] => 1
    [javaapplets] => 1
    [activexcontrols] =>
    [cdf] =>
    [aol] =>
    [beta] => 1
    [win16] =>
    [crawler] =>
    [stripper] =>
    [wap] =>
    [netclr] =>
)

Notlar

Bilginize:

Bu işlevin doğru çalışabilmesi için php.ini içindeki browscap yapılandırma yönergesinde, sisteminizdeki browscap.ini dosyasının yerinin doğru belirtilmiş olması gerekir.

browscap.ini dosyası PHP ile birlikte gelmez, fakat güncel dosyayı » php_browscap.ini olarak indirebiliriniz.

browscap.ini dosyası bir çok tarayıcı hakkında bilgi içerir. Veritabanını güncel tutmak için kullanıcı güncellemeleri kullanılır. Dosyanın biçemi, kendi içinde açıklanmıştır.

exit
__halt_compiler
Çeşitli İşlevler


Derleyicinin çalışmasını durdurur

get_browser
highlight_file
Çeşitli İşlevler
PHP Manual

__halt_compiler

(PHP 5 >= 5.1.0, PHP 7)

__halt_compiler — Derleyicinin çalışmasını durdurur

Açıklama

void __halt_compiler ( void )

Derleyicinin çalışmasını durdurur. PHP betiklerine kurulum dosyaları gibi verileri gömmek için kullanışlıdır.

Veri başlangıç baytının konumu __COMPILER_HALT_OFFSET__ sabitiye belirtilebilir. Bu sabit sadece dosyada bir __halt_compiler() işlevi varsa tanımlıdır.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 - __halt_compiler() örneği

<?php

// Bu betiği açalım
$fp = fopen(__FILE__, 'r');

// Dosya göstericiyi verinin başladığı yere konumlayalım
fseek($fp, __COMPILER_HALT_OFFSET__);

// Çıktılayalım
var_dump(stream_get_contents($fp));

// Betiğin çalışmasını durduralım
__halt_compiler();

Notlar

Bilginize:

__halt_compiler() işlevi betiğin sadece en dış etki alanında kullanılabilir.

get_browser
highlight_file
Çeşitli İşlevler


Bir dosyadaki sözdizimini vurgular

__halt_compiler
highlight_string
Çeşitli İşlevler
PHP Manual

highlight_file

(PHP 4, PHP 5, PHP 7)

highlight_file — Bir dosyadaki sözdizimini vurgular

Açıklama

mixed highlight_file ( string $dosya [, bool $döndür = false ] )

PHP'nin yerleşik söz dizimi vurgulayıcısında tanımlanmış renkler kullanılarak belirtilen dosya içindeki PHP koduna söz dizimi vurgulaması yapılıp sonuç ya döndürülür ya da basılır.

Çoğu sunucu, phps uzantısına sahip dosyalara özdevinimli olarak vurgulama uygulayacak şekilde yapılandırılır. Örneğin, misal.phps dosyası çalıştırılmak yerine içerdiği PHP kodları, vurgulanarak gösterilir. Bunu sunucunuda etkinleştirmek isterseniz httpd.conf dosyanıza şu satırı ekleyiniz:

AddType application/x-httpd-php-source .phps

Değiştirgeler

dosya

Vurgulanacak PHP kodunu içeren dosyanın yolu.

döndür

Vurgulanmış dizgeyi çıktılamak yerine döndürmesini isterseniz bu değiştirgeyle işleve TRUE aktarın.

Dönen Değerler

döndür değiştirgesi TRUE ise, elde edilen dizge basılmaz, sadece döndürülür. Aksi takdirde, işlem başarılı olmuşsa TRUE yoksa FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
4.2.1 | İşlev artık safe_mode ve open_basedir yönergelerinden etkileniyor.
4.2.0 | döndür değiştirgesi eklendi.

Notlar

Dikkat

highlight_file() işlevini kullanırken, parola ve benzeri güvenlik riski ortaya çıkarabilecek bilgilerin istemdışı olarak ifşa edilmemesi konusunda dikkatli olmalısınız.

Bilginize:

Bu işlev bu değiştirge ile bir dahili çıktı tamponu kullanır, dolayısıyla ob_start() geriçağırım işlevinin içinde kullanılamaz.

Ayrıca Bakınız

  • highlight_string() - Bir dizgedeki söz dizimini vurgular

__halt_compiler
highlight_string
Çeşitli İşlevler


Bir dizgedeki söz dizimini vurgular

highlight_file
ignore_user_abort
Çeşitli İşlevler
PHP Manual

highlight_string

(PHP 4, PHP 5, PHP 7)

highlight_string — Bir dizgedeki söz dizimini vurgular

Açıklama

mixed highlight_string ( string $dizge [, bool $döndür = false ] )

PHP'nin yerleşik söz dizimi vurgulayıcısında tanımlanmış renkler kullanılarak belirtilen PHP koduna söz dizimi vurgulaması yapılıp sonuç ya döndürülür ya da basılır.

Değiştirgeler

dizge

Vurgulanacak PHP kodunu içeren dizge. Bir açılış etiketi içermek zorundadır.

döndür

Vurgulanmış dizgeyi çıktılamak yerine döndürmesini isterseniz bu değiştirgeyle işleve TRUE aktarın.

Dönen Değerler

döndür değiştirgesi TRUE ise, elde edilen dizge basılmaz, sadece döndürülür. Aksi takdirde, işlem başarılı olmuşsa TRUE yoksa FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
4.2.0 | döndür değiştirgesi eklendi.

Örnekler

Örnek 1 - highlight_string() örneği

<?php
highlight_string('<?php phpinfo(); ?>');
?>

Örneğin PHP 4'teki çıktısı:

<code><font color="#000000">
<font color="#0000BB">&lt;?php phpinfo</font>
<font color="#007700">();</font>
<font color="#0000BB">?&gt;</font>
</font>
</code>

Örneğin PHP 5'teki çıktısı:

<code><span style="color: #000000">
<span style="color: #0000BB">&lt;?php phpinfo</span>
<span style="color: #007700">(); </span>
<span style="color: #0000BB">?&gt;</span>
</span>
</code>

Notlar

Bilginize:

Bu işlev bu değiştirge ile bir dahili çıktı tamponu kullanır, dolayısıyla ob_start() geriçağırım işlevinin içinde kullanılamaz.

Ayrıca Bakınız

  • highlight_file() - Bir dosyadaki sözdizimini vurgular

highlight_file
ignore_user_abort
Çeşitli İşlevler


Bir istemci bağlantıyı terkettiğinde betiğin sonlandırılıp sonlandırılmayacağını belirler

highlight_string
pack
Çeşitli İşlevler
PHP Manual

ignore_user_abort

(PHP 4, PHP 5, PHP 7)

ignore_user_abort — Bir istemci bağlantıyı terkettiğinde betiğin sonlandırılıp sonlandırılmayacağını belirler

Açıklama

int ignore_user_abort ([ string $değer ] )

Bir istemci bağlantıyı terkettiğinde betiğin sonlandırılıp sonlandırılmayacağını belirler.

Değiştirgeler

değer

Bu değiştirge belirtilmişse değiştirge değeri ignore_user_abort yönergesinin değeri olarak kullanılır. Değiştirge belirtilmemişse, işlev sadece önceki değeri (değiştirmeden) döndürür.

Dönen Değerler

Önceki değeri bir tamsayı olarak döndürür.

Örnekler

Örnek 1 - ignore_user_abort() örneği

<?php
// Kullanıcının bağlantıyı terketmesini yok sayıp
// betiği ilelebet çalıştır
ignore_user_abort(true);
set_time_limit(0);

echo 'PHP'de bağlantı varlığı sınanıyor';

// Sonsuz bir döngü çalıştırıp sayfadaki bir düğmeye
// veya tarayıcının "dur" düğmesine tıklanmasını bekleyelim
while(1)
{
  // Bağlantı kesilmişse döngüden çık
  if(connection_status() != CONNECTION_NORMAL)
  {
    break;
  }

  // 10 saniye bekle
  sleep(10);
}

// Buraya gelinmişse döngü içindeyken bir düğmeye tıklanmış demektir.

// Bu durumda burada bir günlük kaydı veya
// artık tarayıcıya bağlı olmayan bazı işlemleri yapabiliriz.
?>

Notlar

PHP, istemciye bir bilgi göndermeye çalışana kadar kullanıcının bağlantıyı terkettiğini bilemez. Basitçe bir echo deyimi kullanımı bu bilginin gönderildiğini garanti etmez. Daha fazla bilgi için flush() işlevine bakınız.

Ayrıca Bakınız

  • connection_aborted() - İstemcinin bağlantıyı terkedip terketmediğine bakar
  • connection_status() - Bağlantı durumu bit maskesini döndürür
  • PHP'nin bağlantıları nasıl yönettiği Bağlantı yönetimi sayfasında ayrıntılı olarak açıklanmıştır.

highlight_string
pack
Çeşitli İşlevler


Veriyi bir ikil dizge halinde paketler

ignore_user_abort
php_check_syntax
Çeşitli İşlevler
PHP Manual

pack

(PHP 4, PHP 5, PHP 7)

pack — Veriyi bir ikil dizge halinde paketler

Açıklama

string pack ( string $biçem [, mixed $değiştirgeler [, mixed $... ]] )

Belirtilen değiştirgeleri belirtilen biçem biçeminde bir ikil bir dizge olarak paketler.

Anafikir Perl'den alınmış olup, tüm biçemleme kodları Perl'deki gibi çalışır. Ancak, biçemleme türleri aynı değildir, örneğin "u" biçemi Perl'de yoktur.

Şuna dikkat edin: İşaretli ve işaretsiz değerler arasındaki ayrım sadece unpack() işlevini etkiler. pack() işlevi her ikisi için de aynı sonuçları üretir.

Ayrıca, şuna da dikkat edin: PHP, işaretli değerleri makineye bağımlı tamsayı değerler olarak saklar. Eğer float türünde tam hassasiyetle saklanamayacak kadar büyük bir işaretsiz tamsayı verirseniz istenmeyen sonuçlar alabilirsiniz.

Değiştirgeler

biçem

biçem dzgesi isteğe bağlı bir yineleme değiştirgesi ile öncelenmiş biçem kodlarından oluşur. Yineleme değiştirgesi bir tamsayı değer veya girdi verisinin sonuna kadar yineleme belirten bir * olabilir. a, A, h, H için yineleme sayısı, bir veri değiştirgesinden kaç karakter alındığını belirtir. @ için yineleme sayısı ise, sonraki verinin konacağı mutlak konumu belirtir. Bunlar dışında kalan herşey için yineleme sayısı, sonuçlanan ikil dizgede paketlenmek üzere kaç tane veri argümanın toplanacağını belirtir.

Şimdilik gerçeklenmiş biçemler:

pack() biçem karakterleri
Kod | Açıklama
a | NUL-dolgulu dizge
A | BOŞLUK dolgulu dizge
h | Onaltılık dizge, küçük dörtlü önce gelir
H | Onaltılık dizge, büyük dörtlü önce gelir
c | işaretli bayt
C | işaretsiz bayt
s | İşaretli kısa tamsayı (daima 16 bit olup, makine bayt sıralamasındadır)
S | İşaretsiz kısa tamsayı (daima 16 bit olup, makine bayt sıralamasındadır)
n | İşaretsiz kısa tamsayı (daima 16 bit olup, en kıymetli bayt baştadır)
v | İşaretsiz kısa tamsayı (daima 16 bit olup, en kıymetsiz bayt baştadır)
i | İşaretli tamsayı (boyut ve bayt sıralaması makineye bağlıdır)
I | İşaretsiz tamsayı (boyut ve bayt sıralaması makineye bağlıdır)
l | İşaretli uzun tamsayı (daima 32 bit olup, makine bayt sıralamasındadır)
L | İşaretsiz uzun tamsayı (daima 32 bit olup, makine bayt sıralamasındadır)
N | İşaretsiz uzun tamsayı (daima 32 bit olup, en kıymetli bayt baştadır)
V | İşaretsiz uzun tamsayı (daima 32 bit olup, en kıymetsiz bayt baştadır)
f | Tek hassasiyetli gerçek sayı - float (boyut ve gösterim makineye bağlıdır)
d | Çift hassasiyetli gerçek sayı - double (boyut ve gösterim makineye bağlıdır)
x | NUL bayt (0. karakter)
X | Bir baytlık yedek
@ Bir mutlak konuma kadar NUL dolgu

değiştirgeler

Dönen Değerler

Veriyi içeren bir ikil dizge döner.

Örnekler

Örnek 1 - pack() örneği

<?php
$ikilveri = pack("nvc*", 0x1234, 0x5678, 65, 66);
?>

Elde edilen ikil dizge 6 bayt uzunlukta olur ve sırayla 0x12, 0x34, 0x78, 0x56, 0x41, 0x42 baytlarını içerir.

Ayrıca Bakınız

  • unpack() - Paketlenmiş bir ikil dizgeden verileri ayrıştırır

ignore_user_abort
php_check_syntax
Çeşitli İşlevler


Belirtilen (veya çalışan) dosyanın PHP sözdizimini denetler

pack
php_strip_whitespace
Çeşitli İşlevler
PHP Manual

php_check_syntax

(PHP 5 <= 5.0.4)

php_check_syntax — Belirtilen (veya çalışan) dosyanın PHP sözdizimini denetler

Açıklama

bool php_check_syntax ( string $betik [, string &$hata_iletisi ] )

Belirtilen betik dosyasını söz dizimini hatalarını bulmak için tarar.

Belirtilen betik dosyasının çalıştırılması (fakat sonuçların çıktılanmaması) dışında Komut satırından php -l komutunun verilmesine eşdeğerdir.

Örneğin, betik dosyasında tanımlanmış bir işlev varsa, bu işlev php_check_syntax() işlevinin çalıştırdığı betikte kullanılabilir olacaktır, fakat betik çıktısı engellenecektir.

Bilginize:

Teknik sebeplerle, bu işlevin kullanımı önerilmemeke olup PHP'den kaldırılmıştır. Bu işlevi kullanmak yerine komut satırından php -l birbetik.php komutunu veriniz.

Değiştirgeler

betik

Söz dizimi sınanacak dosyanın yolu.

hata_iletisi

Bu değiştirgede bir dizge belirtilmişse, sözdizimi denetimi tarafından üretilen hata iletisine bu dizge dahil edilir. hata_iletisi iletisi gönderimli olarak aktarılır.

Dönen Değerler

Sözdizimi denetiminde hata bulunamamışsa TRUE, hata bulunmuşsa veya betik dosyası açılamamışsa FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.5 | Bu işlev PHP'den kaldırıldı.
5.0.3 | php_check_syntax() işlevinden sonra yapılan bir exit() çağrısı parçalanma arızası ile sonuçlanmaktadır.
5.0.1 | hata_iletisi gönderimli olarak aktarılmaya başlandı.

Örnekler

php -l birbetik.php

Yukarıdaki örnek şuna benzer bir çıktı üretir:

PHP Parse error: unexpected T_STRING in /tmp/birbetik.php on line 81

Ayrıca Bakınız

  • include - include
  • is_readable() - Bir dosyanın mevcut ve okunabilir olup olmadığını söyler

pack
php_strip_whitespace
Çeşitli İşlevler


Boşlukları ve açıklamaları ayıklanmış kaynak kodla döner

php_check_syntax
show_source
Çeşitli İşlevler
PHP Manual

php_strip_whitespace

(PHP 5, PHP 7)

php_strip_whitespace — Boşlukları ve açıklamaları ayıklanmış kaynak kodla döner

Açıklama

string php_strip_whitespace ( string $dosya )

Dosya ismi dosya değiştirgesi ile belirtilen PHP kaynak kodundan PHP açıklamalarını ve boş alanları çıkarıp sonucu döndürür. Açıklama miktarının asıl PHP koduna oranını tespit etmek için yararlıdır. Bu işlec PHP komut satırında php -w kullanımına eşdeğerdir.

Değiştirgeler

dosya

PHP dosyasının yolu.

Dönen Değerler

İşlev başarılı olursa ayıklanmış kaynak kodunu, aksi takdirde boş bir dizge döndürür.

Bilginize:

Bu işlev PHP 5.0.1'de açıklandığı gibi çalışır. Evvelce sadece boş bir dizge döndürürdü. Bu hatayla ilgili daha fazla bilgi edinmek ve evvelki davranışını öğrenmek için » #29606 numaralı hata raporuna bakınız.

Örnekler

Örnek 1 - php_strip_whitespace() örneği

<?php
// Bu bir PHP açıklaması

/*
 * Başka bir PHP açıklaması
 */

echo        php_strip_whitespace(__FILE__);
// Satırsonu karakterleri de boşluklardan sayılıp kaldırılır
hepsi_bu_kadar();
?>

Yukarıdaki örneğin çıktısı:

<?php
 echo php_strip_whitespace(__FILE__); hepsi_bu_kadar(); ?>

Farkettiyseniz, PHP açıklamalarının yanında boşluklar ve ilk echo deyiminden sonraki satırsonu karakterleri de ayıklandı.

php_check_syntax
show_source
Çeşitli İşlevler


highlight_file işlevinin takma adıdır

php_strip_whitespace
sleep
Çeşitli İşlevler
PHP Manual

show_source

(PHP 4, PHP 5, PHP 7)

show_source — highlight_file() işlevinin takma adıdır

Açıklama

Bu işlev highlight_file() işlevinin takma adıdır.

php_strip_whitespace
sleep
Çeşitli İşlevler


Çalışmayı geciktirir

show_source
sys_getloadavg
Çeşitli İşlevler
PHP Manual

sleep

(PHP 4, PHP 5, PHP 7)

sleep — Çalışmayı geciktirir

Açıklama

int sleep ( int $süre )

Betiğin çalışmasını süre saniye geciktirir.

Değiştirgeler

süre

İşlemsiz geçecek saniye cinsinden süre.

Dönen Değerler

Başarı durumunda 0 (sıfır), hata durumunda FALSE döner. Eğer çağrı bir sinyal ile kesilirse sleep() kalan süreyi döndürür.

Hatalar/İstisnalar

Eğer süre olarak negatif bir değer belirtilirse işlev bir E_WARNING üretir.

Örnekler

Örnek 1 - sleep() örneği

<?php

// şimdiki zaman
echo date('h:i:s') . "\n";

// Betik 10 saniye uyusun
sleep(10);

// uyandı !
echo date('h:i:s') . "\n";

?>

Örnek ilk çıktıyla ikinci çıktı araında 10 saniye bekler.

05:31:23
05:31:33

Ayrıca Bakınız

  • usleep() - Çalışmayı mikrosaniye cinsinden geciktirir
  • time_nanosleep() - Çalışmayı saniye ve nanosaniye cinsinden geciktirir
  • time_sleep_until() - Belirtilen zamana kadar betiği uyutur
  • set_time_limit() - Azami çalıştırma süresini sınırlar

show_source
sys_getloadavg
Çeşitli İşlevler


Ortalama sistem yükünü döndürür

sleep
time_nanosleep
Çeşitli İşlevler
PHP Manual

sys_getloadavg

(PHP 5 >= 5.1.3, PHP 7)

sys_getloadavg — Ortalama sistem yükünü döndürür

Açıklama

array sys_getloadavg ( void )

Son 1., 5. ve 15. dakikada ölçülen ortalama sistem yükünü (sistemde çalışmakta olan süreç sayısını) gösteren üç değer döndürür.

Dönen Değerler

Son 1., 5. ve 15. dakikada alınan örnekleri içeren bir dizi döndürür.

Örnekler

Örnek 1 - sys_getloadavg() örneği

<?php
$load = sys_getloadavg();
if ($load[0] > 80) {
    header('HTTP/1.1 503 Too busy, try again later');
    die('Sunucu çok meşgul. Lütfen daha sonra tekrar deneyin.');
}
?>

Notlar

Bilginize: Bu işlev Windows sistemlerinde çalışmaz.

sleep
time_nanosleep
Çeşitli İşlevler


Çalışmayı saniye ve nanosaniye cinsinden geciktirir

sys_getloadavg
time_sleep_until
Çeşitli İşlevler
PHP Manual

time_nanosleep

(PHP 5, PHP 7)

time_nanosleep — Çalışmayı saniye ve nanosaniye cinsinden geciktirir

Açıklama

mixed time_nanosleep ( int $süre , int $nanosüre )

Betiğin çalışmasını süre saniye ve nanosüre nanosaniye kadar bekletir.

Değiştirgeler

süre

Beklenecek saniye sayısını belirten bir pozitif tamsayı.

nanosüre

Saniyenin milyarda birlerini belirten bir pozitif tamsayı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Eğer gecikme bir sinyalle kesilirse şu bileşenlere sahip bir ilişkisel dizi döner:

  • seconds - Kalan sürenin saniye sayısı.
  • nanoseconds - Son saniyeden kalan nanosaniye sayısı.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | Bu işlev artık Windows sistemler üzerinde de çalışıyor.

Örnekler

Örnek 1 - time_nanosleep() örneği

<?php
// Dikkat! Bu beklendiği gibi çalışamazsa bir dizi döndürür
if (time_nanosleep(0, 500000000)) {
    echo "Yarım saniyeliğine uyundu.\n";
}

// Bu daha iyidir:
if (time_nanosleep(0, 500000000) === true) {
    echo "Yarım saniyeliğine uyundu.\n";
}

// Bu ise en iyisidir:
$nano = time_nanosleep(2, 100000);

if ($nano === true) {
    echo "2 saniye, 100 milisaniyeliğine uyundu.\n";
} elseif ($nano === false) {
    echo "Uyku kaçtı.\n";
} elseif (is_array($nano)) {
    $seconds = $nano['seconds'];
    $nanoseconds = $nano['nanoseconds'];
    echo "Gecikme bir sinyalle kesildi.\n";
    echo "Kalan süre: $seconds saniye, $nanoseconds nanosaniye.";
}
?>

Ayrıca Bakınız

  • sleep() - Çalışmayı geciktirir
  • usleep() - Çalışmayı mikrosaniye cinsinden geciktirir
  • time_sleep_until() - Belirtilen zamana kadar betiği uyutur
  • set_time_limit() - Azami çalıştırma süresini sınırlar

sys_getloadavg
time_sleep_until
Çeşitli İşlevler


Belirtilen zamana kadar betiği uyutur

time_nanosleep
uniqid
Çeşitli İşlevler
PHP Manual

time_sleep_until

(PHP 5 >= 5.1.0, PHP 7)

time_sleep_until — Belirtilen zamana kadar betiği uyutur

Açıklama

bool time_sleep_until ( float $zaman_damgası )

Unix zaman_damgası ile belirtilen zamana kadar betiği uyutur.

Değiştirgeler

zaman_damgası

Betiğin uyanacağı zaman.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | Bu işlev artık Windows sistemler üzerinde de çalışıyor.

Hatalar/İstisnalar

Belirtilen zaman_damgası geçmişte ise işlev bir E_WARNING üretir.

Örnekler

Örnek 1 - time_sleep_until() örneği

<?php

// false döndürüp bir uyarı üretir
var_dump(time_sleep_until(time()-1));

// Sadece hızlı bilgisayarlarda çalışır; 0.2 saniye uyutur.
var_dump(time_sleep_until(microtime(true)+0.2));

?>

Notlar

Bilginize: Alınan tüm sinyaller betiğin uyanmasına sebep olur.

Ayrıca Bakınız

  • sleep() - Çalışmayı geciktirir
  • usleep() - Çalışmayı mikrosaniye cinsinden geciktirir
  • time_nanosleep() - Çalışmayı saniye ve nanosaniye cinsinden geciktirir
  • set_time_limit() - Azami çalıştırma süresini sınırlar

time_nanosleep
uniqid
Çeşitli İşlevler


Eşsiz bir kimlik dizgesi üretir

time_sleep_until
unpack
Çeşitli İşlevler
PHP Manual

uniqid

(PHP 4, PHP 5, PHP 7)

uniqid — Eşsiz bir kimlik dizgesi üretir

Açıklama

string uniqid ([ string $önek = "" [, bool $döküntü_üret = false ]] )

Mikrosaniye cinsinden geçerli zamana dayalı olarak belirtilen önek ile eşsiz bir kimlik dizgesi üretir.

Değiştirgeler

önek

Bu değiştirge, farklı konaklar üzerinde aynı anda üretilen kimliklerin farklılaştırılmasında yararlı olabilir.

Boş bir önek belirtildiğinde 13 karakterlik bir dizge elde edilir. Eğer, döküntü_üret değiştirgesinde TRUE belirtilmişse üretilen dizge 23 karakter uzunluğunda olur.

döküntü_üret

TRUE belirtildiği takdirde elde edilen dizgenin daha da eşsiz olmasını sağlamak üzere dizgenin sonuna (birleşik doğrusal benzeşimsel üreteç kullanılarak) rasgele üretilmiş karakterler eklenir.

Dönen Değerler

Eşsiz bir kimlik dizgesi döner.

Örnekler

Ağ üzerindeki bir kullanıcıya vermek için eşsiz bir dizgeye ihtiyacınız olursa (oturum çerezleri gibi) bunu şu şekilde üretmenizi öneririz:

Bu örnek, tahmin edilmesi oldukça güçleştirilmiş 32 karakterlik (128 bitlik bir onaltılık sayı) bir kimlik dizgesi üretir.

Örnek 1 - uniqid() örneği

<?php
// önek yok.
// Sadece PHP 5 ve sonraki sürümlerde çalışır
$token = md5(uniqid());

// daha iyisi; tahmini güçleştirelim
$better_token = md5(uniqid(mt_rand(), true));
?>

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.0 | önek seçimlik oldu.
4.3.1 | 114 karakterlik sınırla önek değiştirgesi devreye girdi.

Notlar

Bilginize:

Bu işlevin Cygwin altında çalışması için döküntü_üret TRUE olmalıdır.

time_sleep_until
unpack
Çeşitli İşlevler


Paketlenmiş bir ikil dizgeden verileri ayrıştırır

uniqid
usleep
Çeşitli İşlevler
PHP Manual

unpack

(PHP 4, PHP 5, PHP 7)

unpack — Paketlenmiş bir ikil dizgeden verileri ayrıştırır

Açıklama

array unpack ( string $biçem , string $veri )

Paketlenmiş bir ikil dizgeden veriyi belirtilen biçem dizgesine göre bir diziye çıkarır.

unpack() çıkardığı veriyi bir ilişkisel dizide saklaması bakımından Perl'dekinden biraz faklı çalışır. Bunu sağlamak için biçem kodları farklı isimlendirilir ve bir bölü çizgisi / ile ayrılırlar.

Değiştirgeler

biçem

Biçem kodlarının açıklamaları için pack() işlevine bakınız.

veri

Paketlenmiş veri.

Dönen Değerler

İkil dizgeden ayrıştırılan verileri içeren bir ilişkisel dizi döner.

Örnekler

Örnek 1 - unpack() örneği

<?php
$array = unpack("c2chars/nint", $binarydata);
?>

Elde edilen dizi "chars1", "chars2" and "int" elemanlarını içerir.

Notlar

Dikkat

PHP dahili olarak tamsayı değerleri işaretli olarak sakladığından, büyükçe bir işaretsiz uzun tamsayıyı ayrıştırmak isterseniz, PHP negatif sayıları da aynı boyutta sakladığından elde edilen değer, biçem dizgesinde işaretsiz olduğunu belirtseniz bile, negatif bir sayı olacaktır.

Ayrıca Bakınız

  • pack() - Veriyi bir ikil dizge halinde paketler

uniqid
usleep
Çeşitli İşlevler


Çalışmayı mikrosaniye cinsinden geciktirir

unpack
Parsekit
Çeşitli İşlevler
PHP Manual

usleep

(PHP 4, PHP 5, PHP 7)

usleep — Çalışmayı mikrosaniye cinsinden geciktirir

Açıklama

void usleep ( int $süre )

Betiğin çalışmasını süre mikrosaniye geciktirir.

Değiştirgeler

süre

İşlemsiz geçecek mikrosaniye cinsinden süre. 1 mikro saniye saniyenin milyonda biridir.

Dönen Değerler

Hiçbir değer dönmez.

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.0 | Bu işlev artık Windows sistemler üzerinde de çalışıyor.

Örnekler

Örnek 1 - usleep() örneği

<?php

// Şimdiki zaman
echo date('h:i:s') . "\n";

// 2 saniye bekle
usleep(2000000);

// geri gel!
echo date('h:i:s') . "\n";

?>

Yukarıdaki örneğin çıktısı:

11:13:28
11:13:30

Ayrıca Bakınız

  • sleep() - Çalışmayı geciktirir
  • time_nanosleep() - Çalışmayı saniye ve nanosaniye cinsinden geciktirir
  • time_sleep_until() - Belirtilen zamana kadar betiği uyutur
  • set_time_limit() - Azami çalıştırma süresini sınırlar

unpack
Parsekit
Çeşitli İşlevler


Parsekit

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Parsekit İşlevleri
    • parsekit_compile_file — Compile a PHP file and return the resulting op array
    • parsekit_compile_string — Compile a string of PHP code and return the resulting op array
    • parsekit_func_arginfo — Return information regarding function argument(s)
usleep
Giriş
Diğer Temel Eklentiler


Giriş

These functions allow runtime analysis of opcodes compiled from PHP scripts.

Parsekit
Yapılandırma/Kurulum
Parsekit


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Parsekit


Kurulum

Bu » PECL eklentisi PHP ile gelmez.

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/parsekit.

Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

PARSEKIT_QUIET (int)
Return full detail, but without unnecessary NULL entries.
PARSEKIT_SIMPLE (int)
Return shorthand opcode notation.
PARSEKIT_EXTENDED_VALUE (int)
Opnode Flag
PARSEKIT_RESULT_CONST (int)
Opnode Flag
PARSEKIT_RESULT_EA_TYPE (int)
Opnode Flag
PARSEKIT_RESULT_JMP_ADDR (int)
Opnode Flag
PARSEKIT_RESULT_OPARRAY (int)
Opnode Flag
PARSEKIT_RESULT_OPLINE (int)
Opnode Flag
PARSEKIT_RESULT_VAR (int)
Opnode Flag
PARSEKIT_USAGE_UNKNOWN (int)
Opnode Flag
PARSEKIT_ZEND_INTERNAL_CLASS (int)
Class Type
PARSEKIT_ZEND_USER_CLASS (int)
Class Type
PARSEKIT_ZEND_EVAL_CODE (int)
Function Type
PARSEKIT_ZEND_INTERNAL_FUNCTION (int)
Function Type
PARSEKIT_ZEND_OVERLOADED_FUNCTION (int)
Function Type
PARSEKIT_ZEND_OVERLOADED_FUNCTION_TEMPORARY (int) PHP >= 5.0.0
Function Type
PARSEKIT_ZEND_USER_FUNCTION (int)
Function Type
PARSEKIT_IS_CONST (int)
Node Type
PARSEKIT_IS_TMP_VAR (int)
Node Type
PARSEKIT_IS_UNUSED (int)
Node Type
PARSEKIT_IS_VAR (int)
Node Type
PARSEKIT_ZEND_ADD (int)
Opcode
PARSEKIT_ZEND_ADD_ARRAY_ELEMENT (int)
Opcode
PARSEKIT_ZEND_ADD_CHAR (int)
Opcode
PARSEKIT_ZEND_ADD_INTERFACE (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_ADD_STRING (int)
Opcode
PARSEKIT_ZEND_ADD_VAR (int)
Opcode
PARSEKIT_ZEND_ASSIGN (int)
Opcode
PARSEKIT_ZEND_ASSIGN_ADD (int)
Opcode
PARSEKIT_ZEND_ASSIGN_BW_AND (int)
Opcode
PARSEKIT_ZEND_ASSIGN_BW_OR (int)
Opcode
PARSEKIT_ZEND_ASSIGN_BW_XOR (int)
Opcode
PARSEKIT_ZEND_ASSIGN_CONCAT (int)
Opcode
PARSEKIT_ZEND_ASSIGN_DIM (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_ASSIGN_DIV (int)
Opcode
PARSEKIT_ZEND_ASSIGN_MOD (int)
Opcode
PARSEKIT_ZEND_ASSIGN_MUL (int)
Opcode
PARSEKIT_ZEND_ASSIGN_OBJ (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_ASSIGN_REF (int)
Opcode
PARSEKIT_ZEND_ASSIGN_SL (int)
Opcode
PARSEKIT_ZEND_ASSIGN_SR (int)
Opcode
PARSEKIT_ZEND_ASSIGN_SUB (int)
Opcode
PARSEKIT_ZEND_BEGIN_SILENCE (int)
Opcode
PARSEKIT_ZEND_BOOL (int)
Opcode
PARSEKIT_ZEND_BOOL_NOT (int)
Opcode
PARSEKIT_ZEND_BOOL_XOR (int)
Opcode
PARSEKIT_ZEND_BRK (int)
Opcode
PARSEKIT_ZEND_BW_AND (int)
Opcode
PARSEKIT_ZEND_BW_NOT (int)
Opcode
PARSEKIT_ZEND_BW_OR (int)
Opcode
PARSEKIT_ZEND_BW_XOR (int)
Opcode
PARSEKIT_ZEND_CASE (int)
Opcode
PARSEKIT_ZEND_CAST (int)
Opcode
PARSEKIT_ZEND_CATCH (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_CLONE (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_CONCAT (int)
Opcode
PARSEKIT_ZEND_CONT (int)
Opcode
PARSEKIT_ZEND_DECLARE_CLASS (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_DECLARE_FUNCTION (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_DECLARE_INHERITED_CLASS (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_DIV (int)
Opcode
PARSEKIT_ZEND_DO_FCALL (int)
Opcode
PARSEKIT_ZEND_DO_FCALL_BY_NAME (int)
Opcode
PARSEKIT_ZEND_ECHO (int)
Opcode
PARSEKIT_ZEND_END_SILENCE (int)
Opcode
PARSEKIT_ZEND_EXIT (int)
Opcode
PARSEKIT_ZEND_EXT_FCALL_BEGIN (int)
Opcode
PARSEKIT_ZEND_EXT_FCALL_END (int)
Opcode
PARSEKIT_ZEND_EXT_NOP (int)
Opcode
PARSEKIT_ZEND_EXT_STMT (int)
Opcode
PARSEKIT_ZEND_FETCH_CLASS (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_FETCH_CONSTANT (int)
Opcode
PARSEKIT_ZEND_FETCH_DIM_FUNC_ARG (int)
Opcode
PARSEKIT_ZEND_FETCH_DIM_IS (int)
Opcode
PARSEKIT_ZEND_FETCH_DIM_R (int)
Opcode
PARSEKIT_ZEND_FETCH_DIM_RW (int)
Opcode
PARSEKIT_ZEND_FETCH_DIM_TMP_VAR (int)
Opcode
PARSEKIT_ZEND_FETCH_DIM_UNSET (int)
Opcode
PARSEKIT_ZEND_FETCH_DIM_W (int)
Opcode
PARSEKIT_ZEND_FETCH_FUNC_ARG (int)
Opcode
PARSEKIT_ZEND_FETCH_IS (int)
Opcode
PARSEKIT_ZEND_FETCH_OBJ_FUNC_ARG (int)
Opcode
PARSEKIT_ZEND_FETCH_OBJ_IS (int)
Opcode
PARSEKIT_ZEND_FETCH_OBJ_R (int)
Opcode
PARSEKIT_ZEND_FETCH_OBJ_RW (int)
Opcode
PARSEKIT_ZEND_FETCH_OBJ_UNSET (int)
Opcode
PARSEKIT_ZEND_FETCH_OBJ_W (int)
Opcode
PARSEKIT_ZEND_FETCH_R (int)
Opcode
PARSEKIT_ZEND_FETCH_RW (int)
Opcode
PARSEKIT_ZEND_FETCH_UNSET (int)
Opcode
PARSEKIT_ZEND_FETCH_W (int)
Opcode
PARSEKIT_ZEND_FE_FETCH (int)
Opcode
PARSEKIT_ZEND_FE_RESET (int)
Opcode
PARSEKIT_ZEND_FREE (int)
Opcode
PARSEKIT_ZEND_HANDLE_EXCEPTION (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_IMPORT_CLASS (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_IMPORT_CONST (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_IMPORT_FUNCTION (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_INCLUDE_OR_EVAL (int)
Opcode
PARSEKIT_ZEND_INIT_ARRAY (int)
Opcode
PARSEKIT_ZEND_INIT_CTOR_CALL (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_INIT_FCALL_BY_NAME (int)
Opcode
PARSEKIT_ZEND_INIT_METHOD_CALL (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_INIT_STATIC_METHOD_CALL (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_INIT_STRING (int)
Opcode
PARSEKIT_ZEND_INSTANCEOF (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_ISSET_ISEMPTY (int) PHP < 5.0.0
Opcode
PARSEKIT_ZEND_ISSET_ISEMPTY_DIM_OBJ (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_ISSET_ISEMPTY_PROP_OBJ (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_ISSET_ISEMPTY_VAR (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_IS_EQUAL (int)
Opcode
PARSEKIT_ZEND_IS_IDENTICAL (int)
Opcode
PARSEKIT_ZEND_IS_NOT_EQUAL (int)
Opcode
PARSEKIT_ZEND_IS_NOT_IDENTICAL (int)
Opcode
PARSEKIT_ZEND_IS_SMALLER (int)
Opcode
PARSEKIT_ZEND_IS_SMALLER_OR_EQUAL (int)
Opcode
PARSEKIT_ZEND_JMP (int)
Opcode
PARSEKIT_ZEND_JMPNZ (int)
Opcode
PARSEKIT_ZEND_JMPNZ_EX (int)
Opcode
PARSEKIT_ZEND_JMPZ (int)
Opcode
PARSEKIT_ZEND_JMPZNZ (int)
Opcode
PARSEKIT_ZEND_JMPZ_EX (int)
Opcode
PARSEKIT_ZEND_JMP_NO_CTOR (int)
Opcode
PARSEKIT_ZEND_MOD (int)
Opcode
PARSEKIT_ZEND_MUL (int)
Opcode
PARSEKIT_ZEND_NEW (int)
Opcode
PARSEKIT_ZEND_NOP (int)
Opcode
PARSEKIT_ZEND_OP_DATA (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_POST_DEC (int)
Opcode
PARSEKIT_ZEND_POST_DEC_OBJ (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_POST_INC (int)
Opcode
PARSEKIT_ZEND_POST_INC_OBJ (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_PRE_DEC (int)
Opcode
PARSEKIT_ZEND_PRE_DEC_OBJ (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_PRE_INC (int)
Opcode
PARSEKIT_ZEND_PRE_INC_OBJ (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_PRINT (int)
Opcode
PARSEKIT_ZEND_QM_ASSIGN (int)
Opcode
PARSEKIT_ZEND_RAISE_ABSTRACT_ERROR (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_RECV (int)
Opcode
PARSEKIT_ZEND_RECV_INIT (int)
Opcode
PARSEKIT_ZEND_RETURN (int)
Opcode
PARSEKIT_ZEND_SEND_REF (int)
Opcode
PARSEKIT_ZEND_SEND_VAL (int)
Opcode
PARSEKIT_ZEND_SEND_VAR (int)
Opcode
PARSEKIT_ZEND_SEND_VAR_NO_REF (int)
Opcode
PARSEKIT_ZEND_SL (int)
Opcode
PARSEKIT_ZEND_SR (int)
Opcode
PARSEKIT_ZEND_SUB (int)
Opcode
PARSEKIT_ZEND_SWITCH_FREE (int)
Opcode
PARSEKIT_ZEND_THROW (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_TICKS (int)
Opcode
PARSEKIT_ZEND_UNSET_DIM_OBJ (int)
Opcode
PARSEKIT_ZEND_UNSET_VAR (int)
Opcode
PARSEKIT_ZEND_VERIFY_ABSTRACT_CLASS (int) PHP >= 5.0.0
Opcode

Özkaynak Türleri
Parsekit İşlevleri
Parsekit


Parsekit İşlevleri

İçindekiler

  • parsekit_compile_file — Compile a PHP file and return the resulting op array
  • parsekit_compile_string — Compile a string of PHP code and return the resulting op array
  • parsekit_func_arginfo — Return information regarding function argument(s)
Öntanımlı Sabitler
parsekit_compile_file
Parsekit


Compile a PHP file and return the resulting op array

Parsekit İşlevleri
parsekit_compile_string
Parsekit İşlevleri
PHP Manual

parsekit_compile_file

(PECL parsekit >= 0.2.0)

parsekit_compile_file — Compile a PHP file and return the resulting op array

Açıklama

array parsekit_compile_file ( string $filename [, array &$errors [, int $options = PARSEKIT_QUIET ]] )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Değiştirgeler

filename

A string containing the name of the file to compile. Similar to the argument to include.

errors

A 2D hash of errors (including fatal errors) encountered during compilation. Returned by reference.

options

One of either PARSEKIT_QUIET or PARSEKIT_SIMPLE. To produce varying degrees of verbosity in the returned output.

Dönen Değerler

Returns a complex multi-layer array structure as detailed below.

Örnekler

Örnek 1 parsekit_compile_file() example

<?php
var_dump(parsekit_compile_file('hello_world.php', $errors, PARSEKIT_SIMPLE));
?>

Yukarıdaki örneğin çıktısı:

array(5) {
  [0]=>
  string(37) "ZEND_ECHO UNUSED 'Hello World' UNUSED"
  [1]=>
  string(30) "ZEND_RETURN UNUSED NULL UNUSED"
  [2]=>
  string(42) "ZEND_HANDLE_EXCEPTION UNUSED UNUSED UNUSED"
  ["function_table"]=>
  NULL
  ["class_table"]=>
  NULL
}

Ayrıca Bakınız

  • parsekit_compile_string() - Compile a string of PHP code and return the resulting op array

Parsekit İşlevleri
parsekit_compile_string
Parsekit İşlevleri


Compile a string of PHP code and return the resulting op array

parsekit_compile_file
parsekit_func_arginfo
Parsekit İşlevleri
PHP Manual

parsekit_compile_string

(PECL parsekit >= 0.2.0)

parsekit_compile_string — Compile a string of PHP code and return the resulting op array

Açıklama

array parsekit_compile_string ( string $phpcode [, array &$errors [, int $options = PARSEKIT_QUIET ]] )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Değiştirgeler

phpcode

A string containing phpcode. Similar to the argument to eval().

errors

A 2D hash of errors (including fatal errors) encountered during compilation. Returned by reference.

options

One of either PARSEKIT_QUIET or PARSEKIT_SIMPLE. To produce varying degrees of verbosity in the returned output.

Dönen Değerler

Returns a complex multi-layer array structure as detailed below.

Örnekler

Örnek 1 parsekit_compile_string() example

<?php
  $ops = parsekit_compile_string('
echo "Foo\n";
', $errors, PARSEKIT_QUIET);

  var_dump($ops);
?>

Yukarıdaki örneğin çıktısı:

array(20) {
  ["type"]=>
  int(4)
  ["type_name"]=>
  string(14) "ZEND_EVAL_CODE"
  ["fn_flags"]=>
  int(0)
  ["num_args"]=>
  int(0)
  ["required_num_args"]=>
  int(0)
  ["pass_rest_by_reference"]=>
  bool(false)
  ["uses_this"]=>
  bool(false)
  ["line_start"]=>
  int(0)
  ["line_end"]=>
  int(0)
  ["return_reference"]=>
  bool(false)
  ["refcount"]=>
  int(1)
  ["last"]=>
  int(3)
  ["size"]=>
  int(3)
  ["T"]=>
  int(0)
  ["last_brk_cont"]=>
  int(0)
  ["current_brk_cont"]=>
  int(-1)
  ["backpatch_count"]=>
  int(0)
  ["done_pass_two"]=>
  bool(true)
  ["filename"]=>
  string(17) "Parsekit Compiler"
  ["opcodes"]=>
  array(3) {
    [8594800]=>
    array(5) {
      ["opcode"]=>
      int(40)
      ["opcode_name"]=>
      string(9) "ZEND_ECHO"
      ["flags"]=>
      int(768)
      ["op1"]=>
      array(3) {
        ["type"]=>
        int(1)
        ["type_name"]=>
        string(8) "IS_CONST"
        ["constant"]=>
        &string(4) "Foo
"
      }
      ["lineno"]=>
      int(2)
    }
    ["859484C"]=>
    array(6) {
      ["opcode"]=>
      int(62)
      ["opcode_name"]=>
      string(11) "ZEND_RETURN"
      ["flags"]=>
      int(16777984)
      ["op1"]=>
      array(3) {
        ["type"]=>
        int(1)
        ["type_name"]=>
        string(8) "IS_CONST"
        ["constant"]=>
        &NULL
      }
      ["extended_value"]=>
      int(0)
      ["lineno"]=>
      int(3)
    }
    [8594898]=>
    array(4) {
      ["opcode"]=>
      int(149)
      ["opcode_name"]=>
      string(21) "ZEND_HANDLE_EXCEPTION"
      ["flags"]=>
      int(0)
      ["lineno"]=>
      int(3)
    }
  }
}

Ayrıca Bakınız

  • parsekit_compile_file() - Compile a PHP file and return the resulting op array

parsekit_compile_file
parsekit_func_arginfo
Parsekit İşlevleri


Return information regarding function argument(s)

parsekit_compile_string
SPL
Parsekit İşlevleri
PHP Manual

parsekit_func_arginfo

(PECL parsekit >= 0.3.0)

parsekit_func_arginfo — Return information regarding function argument(s)

Açıklama

array parsekit_func_arginfo ( mixed $function )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Değiştirgeler

function

A string describing a function, or an array describing a class/method.

Dönen Değerler

Returns an array containing argument information.

Örnekler

Örnek 1 parsekit_func_arginfo() example

<?php
function foo($bar, stdClass $baz, &$bomb, $bling = false) {
}

var_dump(parsekit_func_arginfo('foo'));
?>

Yukarıdaki örneğin çıktısı:

array(4) {
  [0]=>
  array(3) {
    ["name"]=>
    string(3) "bar"
    ["allow_null"]=>
    bool(true)
    ["pass_by_reference"]=>
    bool(false)
  }
  [1]=>
  array(4) {
    ["name"]=>
    string(3) "baz"
    ["class_name"]=>
    string(8) "stdClass"
    ["allow_null"]=>
    bool(false)
    ["pass_by_reference"]=>
    bool(false)
  }
  [2]=>
  array(3) {
    ["name"]=>
    string(4) "bomb"
    ["allow_null"]=>
    bool(true)
    ["pass_by_reference"]=>
    bool(true)
  }
  [3]=>
  array(3) {
    ["name"]=>
    string(5) "bling"
    ["allow_null"]=>
    bool(true)
    ["pass_by_reference"]=>
    bool(false)
  }
}

parsekit_compile_string
SPL
Parsekit İşlevleri


Standard PHP Library (SPL)

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Datastructures
    • SplDoublyLinkedList — The SplDoublyLinkedList class
    • SplStack — The SplStack class
    • SplQueue — The SplQueue class
    • SplHeap — The SplHeap class
    • SplMaxHeap — The SplMaxHeap class
    • SplMinHeap — The SplMinHeap class
    • SplPriorityQueue — The SplPriorityQueue class
    • SplFixedArray — The SplFixedArray class
    • SplObjectStorage — The SplObjectStorage class
  • Iterators
    • AppendIterator — The AppendIterator class
    • ArrayIterator — The ArrayIterator class
    • CachingIterator — The CachingIterator class
    • CallbackFilterIterator — The CallbackFilterIterator class
    • DirectoryIterator — The DirectoryIterator class
    • EmptyIterator — The EmptyIterator class
    • FilesystemIterator — The FilesystemIterator class
    • FilterIterator — The FilterIterator class
    • GlobIterator — The GlobIterator class
    • InfiniteIterator — The InfiniteIterator class
    • IteratorIterator — The IteratorIterator class
    • LimitIterator — The LimitIterator class
    • MultipleIterator — The MultipleIterator class
    • NoRewindIterator — The NoRewindIterator class
    • ParentIterator — The ParentIterator class
    • RecursiveArrayIterator — The RecursiveArrayIterator class
    • RecursiveCachingIterator — The RecursiveCachingIterator class
    • RecursiveCallbackFilterIterator — The RecursiveCallbackFilterIterator class
    • RecursiveDirectoryIterator — The RecursiveDirectoryIterator class
    • RecursiveFilterIterator — The RecursiveFilterIterator class
    • RecursiveIteratorIterator — The RecursiveIteratorIterator class
    • RecursiveRegexIterator — The RecursiveRegexIterator class
    • RecursiveTreeIterator — The RecursiveTreeIterator class
    • RegexIterator — The RegexIterator class
  • Interfaces
    • Countable — The Countable interface
    • OuterIterator — The OuterIterator interface
    • RecursiveIterator — The RecursiveIterator interface
    • SeekableIterator — The SeekableIterator interface
  • Exceptions
    • BadFunctionCallException — The BadFunctionCallException class
    • BadMethodCallException — The BadMethodCallException class
    • DomainException — The DomainException class
    • InvalidArgumentException — The InvalidArgumentException class
    • LengthException — The LengthException class
    • LogicException — The LogicException class
    • OutOfBoundsException — The OutOfBoundsException class
    • OutOfRangeException — The OutOfRangeException class
    • OverflowException — The OverflowException class
    • RangeException — The RangeException class
    • RuntimeException — The RuntimeException class
    • UnderflowException — The UnderflowException class
    • UnexpectedValueException — The UnexpectedValueException class
  • SPL İşlevleri
    • class_implements — Return the interfaces which are implemented by the given class or interface
    • class_parents — Return the parent classes of the given class
    • class_uses — Return the traits used by the given class
    • iterator_apply — Call a function for every element in an iterator
    • iterator_count — Count the elements in an iterator
    • iterator_to_array — Copy the iterator into an array
    • spl_autoload_call — Try all registered __autoload() function to load the requested class
    • spl_autoload_extensions — Register and return default file extensions for spl_autoload
    • spl_autoload_functions — Return all registered __autoload() functions
    • spl_autoload_register — Register given function as __autoload() implementation
    • spl_autoload_unregister — Unregister given function as __autoload() implementation
    • spl_autoload — Default implementation for __autoload()
    • spl_classes — Return available SPL classes
    • spl_object_hash — Return hash id for given object
  • File Handling
    • SplFileInfo — The SplFileInfo class
    • SplFileObject — The SplFileObject class
    • SplTempFileObject — The SplTempFileObject class
  • Miscellaneous Classes and Interfaces
    • ArrayObject — The ArrayObject class
    • SplObserver — The SplObserver interface
    • SplSubject — The SplSubject interface
parsekit_func_arginfo
Giriş
Diğer Temel Eklentiler


Giriş

The Standard PHP Library (SPL) is a collection of interfaces and classes that are meant to solve common problems.

No external libraries are needed to build this extension and it is available and compiled by default in PHP 5.0.0.

SPL provides a set of standard datastructure, a set of iterators to traverse over objects, a set of interfaces, a set of standard Exceptions, a number of classes to work with files and it provides a set of functions like spl_autoload_register()

SPL
Yapılandırma/Kurulum
SPL


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
SPL


Kurulum

This extension is available and compiled by default in PHP 5.0.0.

Bilginize:

As of PHP 5.3.0 this extension can no longer be disabled and is therefore always available.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

Uyarı

SPL uses class constants since PHP 5.1. Prior releases use global constants in the form RIT_LEAVES_ONLY.

Özkaynak Türleri
Datastructures
SPL


Datastructures

İçindekiler

  • SplDoublyLinkedList
  • SplStack
  • SplQueue
  • SplHeap
  • SplMaxHeap
  • SplMinHeap
  • SplPriorityQueue
  • SplFixedArray
  • SplObjectStorage

SPL provides a set of standard datastructures. They are grouped here by their underlying implementation which usually defines their general field of application.

Doubly Linked Lists

A Doubly Linked List (DLL) is a list of nodes linked in both directions to each other. Iterator's operations, access to both ends, addition or removal of nodes have a cost of O(1) when the underlying structure is a DLL. It hence provides a decent implementation for stacks and queues.

  • SplDoublyLinkedList
    • SplStack
    • SplQueue

Heaps

Heaps are tree-like structures that follow the heap-property: each node is greater than or equal to its children, when compared using the implemented compare method which is global to the heap.

  • SplHeap
    • SplMaxHeap
    • SplMinHeap
  • SplPriorityQueue

Arrays

Arrays are structures that store the data in a continuous way, accessible via indexes. Don't confuse them with PHP arrays: PHP arrays are in fact implemented as ordered hashtables.

  • SplFixedArray

Map

A map is a datastructure holding key-value pairs. PHP arrays can be seen as maps from integers/strings to values. SPL provides a map from objects to data. This map can also be used as an object set.

  • SplObjectStorage
Öntanımlı Sabitler
SplDoublyLinkedList
SPL


The SplDoublyLinkedList class

(PHP 5 >= 5.3.0, PHP 7)

Giriş

The SplDoublyLinkedList class provides the main functionalities of a doubly linked list.

Sınıf Sözdizimi

SplDoublyLinkedList implements Iterator , ArrayAccess , Countable {
/* Yöntemler */
public __construct ( void )
public void add ( mixed $index , mixed $newval )
public mixed bottom ( void )
public int count ( void )
public mixed current ( void )
public int getIteratorMode ( void )
public bool isEmpty ( void )
public mixed key ( void )
public void next ( void )
public bool offsetExists ( mixed $index )
public mixed offsetGet ( mixed $index )
public void offsetSet ( mixed $index , mixed $newval )
public void offsetUnset ( mixed $index )
public mixed pop ( void )
public void prev ( void )
public void push ( mixed $value )
public void rewind ( void )
public string serialize ( void )
public void setIteratorMode ( int $mode )
public mixed shift ( void )
public mixed top ( void )
public void unserialize ( string $serialized )
public void unshift ( mixed $value )
public bool valid ( void )
}

İçindekiler

  • SplDoublyLinkedList::add — Add/insert a new value at the specified index
  • SplDoublyLinkedList::bottom — Peeks at the node from the beginning of the doubly linked list
  • SplDoublyLinkedList::__construct — Constructs a new doubly linked list
  • SplDoublyLinkedList::count — Counts the number of elements in the doubly linked list.
  • SplDoublyLinkedList::current — Return current array entry
  • SplDoublyLinkedList::getIteratorMode — Returns the mode of iteration
  • SplDoublyLinkedList::isEmpty — Checks whether the doubly linked list is empty.
  • SplDoublyLinkedList::key — Return current node index
  • SplDoublyLinkedList::next — Move to next entry
  • SplDoublyLinkedList::offsetExists — Returns whether the requested $index exists
  • SplDoublyLinkedList::offsetGet — Returns the value at the specified $index
  • SplDoublyLinkedList::offsetSet — Sets the value at the specified $index to $newval
  • SplDoublyLinkedList::offsetUnset — Unsets the value at the specified $index
  • SplDoublyLinkedList::pop — Pops a node from the end of the doubly linked list
  • SplDoublyLinkedList::prev — Move to previous entry
  • SplDoublyLinkedList::push — Pushes an element at the end of the doubly linked list
  • SplDoublyLinkedList::rewind — Rewind iterator back to the start
  • SplDoublyLinkedList::serialize — Serializes the storage
  • SplDoublyLinkedList::setIteratorMode — Sets the mode of iteration
  • SplDoublyLinkedList::shift — Shifts a node from the beginning of the doubly linked list
  • SplDoublyLinkedList::top — Peeks at the node from the end of the doubly linked list
  • SplDoublyLinkedList::unserialize — Unserializes the storage
  • SplDoublyLinkedList::unshift — Prepends the doubly linked list with an element
  • SplDoublyLinkedList::valid — Check whether the doubly linked list contains more nodes
Datastructures
SplDoublyLinkedList::add
Datastructures


Add/insert a new value at the specified index

SplDoublyLinkedList
SplDoublyLinkedList::bottom
SplDoublyLinkedList
PHP Manual

SplDoublyLinkedList::add

(PHP 5 >= 5.5.0, PHP 7)

SplDoublyLinkedList::add — Add/insert a new value at the specified index

Açıklama

public void SplDoublyLinkedList::add ( mixed $index , mixed $newval )

Insert the value newval at the specified index, shuffling the previous value at that index (and all subsequent values) up through the list.

Değiştirgeler

index

The index where the new value is to be inserted.

newval

The new value for the index.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

Throws OutOfRangeException when index is out of bounds or when index cannot be parsed as an integer.

SplDoublyLinkedList
SplDoublyLinkedList::bottom
SplDoublyLinkedList


Peeks at the node from the beginning of the doubly linked list

SplDoublyLinkedList::add
SplDoublyLinkedList::__construct
SplDoublyLinkedList
PHP Manual

SplDoublyLinkedList::bottom

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::bottom — Peeks at the node from the beginning of the doubly linked list

Açıklama

public mixed SplDoublyLinkedList::bottom ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The value of the first node.

Hatalar/İstisnalar

Throws RuntimeException when the data-structure is empty.

SplDoublyLinkedList::add
SplDoublyLinkedList::__construct
SplDoublyLinkedList


Constructs a new doubly linked list

SplDoublyLinkedList::bottom
SplDoublyLinkedList::count
SplDoublyLinkedList
PHP Manual

SplDoublyLinkedList::__construct

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::__construct — Constructs a new doubly linked list

Açıklama

public SplDoublyLinkedList::__construct ( void )

This constructs a new empty doubly linked list.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 SplDoublyLinkedList::__construct() example

<?php
$dll = new SplDoublyLinkedList();

$dll->push(2);
$dll->push(3);
$dll->unshift(5);

var_dump($dll);
?>

Yukarıdaki örneğin çıktısı:

object(SplDoublyLinkedList)#1 (2) {
  ["flags":"SplDoublyLinkedList":private]=>
  int(0)
  ["dllist":"SplDoublyLinkedList":private]=>
  array(3) {
    [0]=>
    int(5)
    [1]=>
    int(2)
    [2]=>
    int(3)
  }
}

SplDoublyLinkedList::bottom
SplDoublyLinkedList::count
SplDoublyLinkedList


Counts the number of elements in the doubly linked list.

SplDoublyLinkedList::__construct
SplDoublyLinkedList::current
SplDoublyLinkedList
PHP Manual

SplDoublyLinkedList::count

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::count — Counts the number of elements in the doubly linked list.

Açıklama

public int SplDoublyLinkedList::count ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the number of elements in the doubly linked list.

SplDoublyLinkedList::__construct
SplDoublyLinkedList::current
SplDoublyLinkedList


Return current array entry

SplDoublyLinkedList::count
SplDoublyLinkedList::getIteratorMode
SplDoublyLinkedList
PHP Manual

SplDoublyLinkedList::current

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::current — Return current array entry

Açıklama

public mixed SplDoublyLinkedList::current ( void )

Get the current doubly linked list node.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current node value.

SplDoublyLinkedList::count
SplDoublyLinkedList::getIteratorMode
SplDoublyLinkedList


Returns the mode of iteration

SplDoublyLinkedList::current
SplDoublyLinkedList::isEmpty
SplDoublyLinkedList
PHP Manual

SplDoublyLinkedList::getIteratorMode

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::getIteratorMode — Returns the mode of iteration

Açıklama

public int SplDoublyLinkedList::getIteratorMode ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the different modes and flags that affect the iteration.

SplDoublyLinkedList::current
SplDoublyLinkedList::isEmpty
SplDoublyLinkedList


Checks whether the doubly linked list is empty.

SplDoublyLinkedList::getIteratorMode
SplDoublyLinkedList::key
SplDoublyLinkedList
PHP Manual

SplDoublyLinkedList::isEmpty

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::isEmpty — Checks whether the doubly linked list is empty.

Açıklama

public bool SplDoublyLinkedList::isEmpty ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns whether the doubly linked list is empty.

SplDoublyLinkedList::getIteratorMode
SplDoublyLinkedList::key
SplDoublyLinkedList


Return current node index

SplDoublyLinkedList::isEmpty
SplDoublyLinkedList::next
SplDoublyLinkedList
PHP Manual

SplDoublyLinkedList::key

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::key — Return current node index

Açıklama

public mixed SplDoublyLinkedList::key ( void )

This function returns the current node index

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current node index.

SplDoublyLinkedList::isEmpty
SplDoublyLinkedList::next
SplDoublyLinkedList


Move to next entry

SplDoublyLinkedList::key
SplDoublyLinkedList::offsetExists
SplDoublyLinkedList
PHP Manual

SplDoublyLinkedList::next

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::next — Move to next entry

Açıklama

public void SplDoublyLinkedList::next ( void )

Move the iterator to the next node.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

SplDoublyLinkedList::key
SplDoublyLinkedList::offsetExists
SplDoublyLinkedList


Returns whether the requested $index exists

SplDoublyLinkedList::next
SplDoublyLinkedList::offsetGet
SplDoublyLinkedList
PHP Manual

SplDoublyLinkedList::offsetExists

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::offsetExists — Returns whether the requested $index exists

Açıklama

public bool SplDoublyLinkedList::offsetExists ( mixed $index )

Değiştirgeler

index

The index being checked.

Dönen Değerler

TRUE if the requested index exists, otherwise FALSE

SplDoublyLinkedList::next
SplDoublyLinkedList::offsetGet
SplDoublyLinkedList


Returns the value at the specified $index

SplDoublyLinkedList::offsetExists
SplDoublyLinkedList::offsetSet
SplDoublyLinkedList
PHP Manual

SplDoublyLinkedList::offsetGet

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::offsetGet — Returns the value at the specified $index

Açıklama

public mixed SplDoublyLinkedList::offsetGet ( mixed $index )

Değiştirgeler

index

The index with the value.

Dönen Değerler

The value at the specified index.

Hatalar/İstisnalar

Throws OutOfRangeException when index is out of bounds or when index cannot be parsed as an integer.

SplDoublyLinkedList::offsetExists
SplDoublyLinkedList::offsetSet
SplDoublyLinkedList


Sets the value at the specified $index to $newval

SplDoublyLinkedList::offsetGet
SplDoublyLinkedList::offsetUnset
SplDoublyLinkedList
PHP Manual

SplDoublyLinkedList::offsetSet

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::offsetSet — Sets the value at the specified $index to $newval

Açıklama

public void SplDoublyLinkedList::offsetSet ( mixed $index , mixed $newval )

Sets the value at the specified index to newval.

Değiştirgeler

index

The index being set.

newval

The new value for the index.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

Throws OutOfRangeException when index is out of bounds or when index cannot be parsed as an integer.

SplDoublyLinkedList::offsetGet
SplDoublyLinkedList::offsetUnset
SplDoublyLinkedList


Unsets the value at the specified $index

SplDoublyLinkedList::offsetSet
SplDoublyLinkedList::pop
SplDoublyLinkedList
PHP Manual

SplDoublyLinkedList::offsetUnset

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::offsetUnset — Unsets the value at the specified $index

Açıklama

public void SplDoublyLinkedList::offsetUnset ( mixed $index )

Unsets the value at the specified index.

Değiştirgeler

index

The index being unset.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

Throws OutOfRangeException when index is out of bounds or when index cannot be parsed as an integer.

SplDoublyLinkedList::offsetSet
SplDoublyLinkedList::pop
SplDoublyLinkedList


Pops a node from the end of the doubly linked list

SplDoublyLinkedList::offsetUnset
SplDoublyLinkedList::prev
SplDoublyLinkedList
PHP Manual

SplDoublyLinkedList::pop

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::pop — Pops a node from the end of the doubly linked list

Açıklama

public mixed SplDoublyLinkedList::pop ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The value of the popped node.

Hatalar/İstisnalar

Throws RuntimeException when the data-structure is empty.

SplDoublyLinkedList::offsetUnset
SplDoublyLinkedList::prev
SplDoublyLinkedList


Move to previous entry

SplDoublyLinkedList::pop
SplDoublyLinkedList::push
SplDoublyLinkedList
PHP Manual

SplDoublyLinkedList::prev

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::prev — Move to previous entry

Açıklama

public void SplDoublyLinkedList::prev ( void )

Move the iterator to the previous node.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

SplDoublyLinkedList::pop
SplDoublyLinkedList::push
SplDoublyLinkedList


Pushes an element at the end of the doubly linked list

SplDoublyLinkedList::prev
SplDoublyLinkedList::rewind
SplDoublyLinkedList
PHP Manual

SplDoublyLinkedList::push

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::push — Pushes an element at the end of the doubly linked list

Açıklama

public void SplDoublyLinkedList::push ( mixed $value )

Pushes value at the end of the doubly linked list.

Değiştirgeler

value

The value to push.

Dönen Değerler

Hiçbir değer dönmez.

SplDoublyLinkedList::prev
SplDoublyLinkedList::rewind
SplDoublyLinkedList


Rewind iterator back to the start

SplDoublyLinkedList::push
SplDoublyLinkedList::serialize
SplDoublyLinkedList
PHP Manual

SplDoublyLinkedList::rewind

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::rewind — Rewind iterator back to the start

Açıklama

public void SplDoublyLinkedList::rewind ( void )

This rewinds the iterator to the beginning.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

SplDoublyLinkedList::push
SplDoublyLinkedList::serialize
SplDoublyLinkedList


Serializes the storage

SplDoublyLinkedList::rewind
SplDoublyLinkedList::setIteratorMode
SplDoublyLinkedList
PHP Manual

SplDoublyLinkedList::serialize

(PHP 5 >= 5.4.0, PHP 7)

SplDoublyLinkedList::serialize — Serializes the storage

Açıklama

public string SplDoublyLinkedList::serialize ( void )

Serializes the storage.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The serialized string.

Ayrıca Bakınız

  • SplDoublyLinkedList::unserialize() - Unserializes the storage

SplDoublyLinkedList::rewind
SplDoublyLinkedList::setIteratorMode
SplDoublyLinkedList


Sets the mode of iteration

SplDoublyLinkedList::serialize
SplDoublyLinkedList::shift
SplDoublyLinkedList
PHP Manual

SplDoublyLinkedList::setIteratorMode

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::setIteratorMode — Sets the mode of iteration

Açıklama

public void SplDoublyLinkedList::setIteratorMode ( int $mode )

Değiştirgeler

mode

There are two orthogonal sets of modes that can be set:

  • The direction of the iteration (either one or the other):
    • SplDoublyLinkedList::IT_MODE_LIFO (Stack style)
    • SplDoublyLinkedList::IT_MODE_FIFO (Queue style)
  • The behavior of the iterator (either one or the other):
    • SplDoublyLinkedList::IT_MODE_DELETE (Elements are deleted by the iterator)
    • SplDoublyLinkedList::IT_MODE_KEEP (Elements are traversed by the iterator)

The default mode is: SplDoublyLinkedList::IT_MODE_FIFO | SplDoublyLinkedList::IT_MODE_KEEP

Dönen Değerler

Hiçbir değer dönmez.

SplDoublyLinkedList::serialize
SplDoublyLinkedList::shift
SplDoublyLinkedList


Shifts a node from the beginning of the doubly linked list

SplDoublyLinkedList::setIteratorMode
SplDoublyLinkedList::top
SplDoublyLinkedList
PHP Manual

SplDoublyLinkedList::shift

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::shift — Shifts a node from the beginning of the doubly linked list

Açıklama

public mixed SplDoublyLinkedList::shift ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The value of the shifted node.

Hatalar/İstisnalar

Throws RuntimeException when the data-structure is empty.

SplDoublyLinkedList::setIteratorMode
SplDoublyLinkedList::top
SplDoublyLinkedList


Peeks at the node from the end of the doubly linked list

SplDoublyLinkedList::shift
SplDoublyLinkedList::unserialize
SplDoublyLinkedList
PHP Manual

SplDoublyLinkedList::top

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::top — Peeks at the node from the end of the doubly linked list

Açıklama

public mixed SplDoublyLinkedList::top ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The value of the last node.

Hatalar/İstisnalar

Throws RuntimeException when the data-structure is empty.

SplDoublyLinkedList::shift
SplDoublyLinkedList::unserialize
SplDoublyLinkedList


Unserializes the storage

SplDoublyLinkedList::top
SplDoublyLinkedList::unshift
SplDoublyLinkedList
PHP Manual

SplDoublyLinkedList::unserialize

(PHP 5 >= 5.4.0, PHP 7)

SplDoublyLinkedList::unserialize — Unserializes the storage

Açıklama

public void SplDoublyLinkedList::unserialize ( string $serialized )

Unserializes the storage, from SplDoublyLinkedList::serialize().

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

serialized

The serialized string.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SplDoublyLinkedList::serialize() - Serializes the storage

SplDoublyLinkedList::top
SplDoublyLinkedList::unshift
SplDoublyLinkedList


Prepends the doubly linked list with an element

SplDoublyLinkedList::unserialize
SplDoublyLinkedList::valid
SplDoublyLinkedList
PHP Manual

SplDoublyLinkedList::unshift

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::unshift — Prepends the doubly linked list with an element

Açıklama

public void SplDoublyLinkedList::unshift ( mixed $value )

Prepends value at the beginning of the doubly linked list.

Değiştirgeler

value

The value to unshift.

Dönen Değerler

Hiçbir değer dönmez.

SplDoublyLinkedList::unserialize
SplDoublyLinkedList::valid
SplDoublyLinkedList


Check whether the doubly linked list contains more nodes

SplDoublyLinkedList::unshift
SplStack
SplDoublyLinkedList
PHP Manual

SplDoublyLinkedList::valid

(PHP 5 >= 5.3.0, PHP 7)

SplDoublyLinkedList::valid — Check whether the doubly linked list contains more nodes

Açıklama

public bool SplDoublyLinkedList::valid ( void )

Checks if the doubly linked list contains any more nodes.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the doubly linked list contains any more nodes, FALSE otherwise.

SplDoublyLinkedList::unshift
SplStack
SplDoublyLinkedList


The SplStack class

(PHP 5 >= 5.3.0, PHP 7)

Giriş

The SplStack class provides the main functionalities of a stack implemented using a doubly linked list.

Sınıf Sözdizimi

SplStack extends SplDoublyLinkedList implements Iterator , ArrayAccess , Countable {
/* Yöntemler */
__construct ( void )
void setIteratorMode ( int $mode )
/* Miras alınan yöntemler */
public void SplDoublyLinkedList::add ( mixed $index , mixed $newval )
public mixed SplDoublyLinkedList::bottom ( void )
public int SplDoublyLinkedList::count ( void )
public mixed SplDoublyLinkedList::current ( void )
public int SplDoublyLinkedList::getIteratorMode ( void )
public bool SplDoublyLinkedList::isEmpty ( void )
public mixed SplDoublyLinkedList::key ( void )
public void SplDoublyLinkedList::next ( void )
public bool SplDoublyLinkedList::offsetExists ( mixed $index )
public mixed SplDoublyLinkedList::offsetGet ( mixed $index )
public void SplDoublyLinkedList::offsetSet ( mixed $index , mixed $newval )
public void SplDoublyLinkedList::offsetUnset ( mixed $index )
public mixed SplDoublyLinkedList::pop ( void )
public void SplDoublyLinkedList::prev ( void )
public void SplDoublyLinkedList::push ( mixed $value )
public void SplDoublyLinkedList::rewind ( void )
public string SplDoublyLinkedList::serialize ( void )
public void SplDoublyLinkedList::setIteratorMode ( int $mode )
public mixed SplDoublyLinkedList::shift ( void )
public mixed SplDoublyLinkedList::top ( void )
public void SplDoublyLinkedList::unserialize ( string $serialized )
public void SplDoublyLinkedList::unshift ( mixed $value )
public bool SplDoublyLinkedList::valid ( void )
}

İçindekiler

  • SplStack::__construct — Constructs a new stack implemented using a doubly linked list
  • SplStack::setIteratorMode — Sets the mode of iteration
SplDoublyLinkedList::valid
SplStack::__construct
Datastructures


Constructs a new stack implemented using a doubly linked list

SplStack
SplStack::setIteratorMode
SplStack
PHP Manual

SplStack::__construct

(PHP 5 >= 5.3.0, PHP 7)

SplStack::__construct — Constructs a new stack implemented using a doubly linked list

Açıklama

SplStack::__construct ( void )

This constructs a new empty stack.

Bilginize:

This method automatically sets the iterator mode to SplDoublyLinkedList::IT_MODE_LIFO.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 SplStack::__construct() example

<?php
$q = new SplStack();

$q[] = 1;
$q[] = 2;
$q[] = 3;

foreach ($q as $elem)  {
 echo $elem."\n";
}
?>

Yukarıdaki örneğin çıktısı:

3
2
1

SplStack
SplStack::setIteratorMode
SplStack


Sets the mode of iteration

SplStack::__construct
SplQueue
SplStack
PHP Manual

SplStack::setIteratorMode

(PHP 5 >= 5.3.0, PHP 7)

SplStack::setIteratorMode — Sets the mode of iteration

Açıklama

void SplStack::setIteratorMode ( int $mode )

Değiştirgeler

mode

There is only one iteration parameter you can modify.

  • The behavior of the iterator (either one or the other):
    • SplDoublyLinkedList::IT_MODE_DELETE (Elements are deleted by the iterator)
    • SplDoublyLinkedList::IT_MODE_KEEP (Elements are traversed by the iterator)

The default mode is 0x2 : SplDoublyLinkedList::IT_MODE_LIFO | SplDoublyLinkedList::IT_MODE_KEEP

Uyarı

The direction of iteration can no longer be changed for SplStacks. Trying to do so will result in a RuntimeException being thrown.

Dönen Değerler

Hiçbir değer dönmez.

SplStack::__construct
SplQueue
SplStack


The SplQueue class

(PHP 5 >= 5.3.0, PHP 7)

Giriş

The SplQueue class provides the main functionalities of a queue implemented using a doubly linked list.

Sınıf Sözdizimi

SplQueue extends SplDoublyLinkedList implements Iterator , ArrayAccess , Countable {
/* Yöntemler */
__construct ( void )
mixed dequeue ( void )
void enqueue ( mixed $value )
void setIteratorMode ( int $mode )
/* Miras alınan yöntemler */
public void SplDoublyLinkedList::add ( mixed $index , mixed $newval )
public mixed SplDoublyLinkedList::bottom ( void )
public int SplDoublyLinkedList::count ( void )
public mixed SplDoublyLinkedList::current ( void )
public int SplDoublyLinkedList::getIteratorMode ( void )
public bool SplDoublyLinkedList::isEmpty ( void )
public mixed SplDoublyLinkedList::key ( void )
public void SplDoublyLinkedList::next ( void )
public bool SplDoublyLinkedList::offsetExists ( mixed $index )
public mixed SplDoublyLinkedList::offsetGet ( mixed $index )
public void SplDoublyLinkedList::offsetSet ( mixed $index , mixed $newval )
public void SplDoublyLinkedList::offsetUnset ( mixed $index )
public mixed SplDoublyLinkedList::pop ( void )
public void SplDoublyLinkedList::prev ( void )
public void SplDoublyLinkedList::push ( mixed $value )
public void SplDoublyLinkedList::rewind ( void )
public string SplDoublyLinkedList::serialize ( void )
public void SplDoublyLinkedList::setIteratorMode ( int $mode )
public mixed SplDoublyLinkedList::shift ( void )
public mixed SplDoublyLinkedList::top ( void )
public void SplDoublyLinkedList::unserialize ( string $serialized )
public void SplDoublyLinkedList::unshift ( mixed $value )
public bool SplDoublyLinkedList::valid ( void )
}

İçindekiler

  • SplQueue::__construct — Constructs a new queue implemented using a doubly linked list
  • SplQueue::dequeue — Dequeues a node from the queue
  • SplQueue::enqueue — Adds an element to the queue.
  • SplQueue::setIteratorMode — Sets the mode of iteration
SplStack::setIteratorMode
SplQueue::__construct
Datastructures


Constructs a new queue implemented using a doubly linked list

SplQueue
SplQueue::dequeue
SplQueue
PHP Manual

SplQueue::__construct

(PHP 5 >= 5.3.0, PHP 7)

SplQueue::__construct — Constructs a new queue implemented using a doubly linked list

Açıklama

SplQueue::__construct ( void )

This constructs a new empty queue.

Bilginize:

This method automatically sets the iterator mode to SplDoublyLinkedList::IT_MODE_FIFO.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 SplQueue::__construct() example

<?php
$q = new SplQueue();

$q[] = 1;
$q[] = 2;
$q[] = 3;

foreach ($q as $elem)  {
 echo $elem."\n";
}
?>

Yukarıdaki örneğin çıktısı:

1
2
3

Örnek 2 Efficiently handling tasks with SplQueue

<?php
$q = new SplQueue();
$q->setIteratorMode(SplQueue::IT_MODE_DELETE);

// ... enqueue some tasks on the queue ...

// process them
foreach ($q as $task) {
    // ... process $task ...

    // add new tasks on the queue
    $q[] = $newTask;
    // ...
}
?>

SplQueue
SplQueue::dequeue
SplQueue


Dequeues a node from the queue

SplQueue::__construct
SplQueue::enqueue
SplQueue
PHP Manual

SplQueue::dequeue

(PHP 5 >= 5.3.0, PHP 7)

SplQueue::dequeue — Dequeues a node from the queue

Açıklama

mixed SplQueue::dequeue ( void )

Dequeues value from the top of the queue.

Bilginize:

SplQueue::dequeue() is an alias of SplDoublyLinkedList::shift().

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The value of the dequeued node.

SplQueue::__construct
SplQueue::enqueue
SplQueue


Adds an element to the queue.

SplQueue::dequeue
SplQueue::setIteratorMode
SplQueue
PHP Manual

SplQueue::enqueue

(PHP 5 >= 5.3.0, PHP 7)

SplQueue::enqueue — Adds an element to the queue.

Açıklama

void SplQueue::enqueue ( mixed $value )

Enqueues value at the end of the queue.

Bilginize:

SplQueue::enqueue() is an alias of SplDoublyLinkedList::push().

Değiştirgeler

value

The value to enqueue.

Dönen Değerler

Hiçbir değer dönmez.

SplQueue::dequeue
SplQueue::setIteratorMode
SplQueue


Sets the mode of iteration

SplQueue::enqueue
SplHeap
SplQueue
PHP Manual

SplQueue::setIteratorMode

(PHP 5 >= 5.3.0, PHP 7)

SplQueue::setIteratorMode — Sets the mode of iteration

Açıklama

void SplQueue::setIteratorMode ( int $mode )

Değiştirgeler

mode

There is only one iteration parameter you can modify.

  • The behavior of the iterator (either one or the other):
    • SplDoublyLinkedList::IT_MODE_DELETE (Elements are deleted by the iterator)
    • SplDoublyLinkedList::IT_MODE_KEEP (Elements are traversed by the iterator)

The default mode is: SplDoublyLinkedList::IT_MODE_FIFO | SplDoublyLinkedList::IT_MODE_KEEP

Uyarı

The direction of iteration can not be changed for SplQueues, it is always SplDoublyLinkedList::IT_MODE_FIFO.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

Throws a RuntimeException on trying to change the direction of iteration by using SplDoublyLinkedList::IT_MODE_LIFO.

SplQueue::enqueue
SplHeap
SplQueue


The SplHeap class

(PHP 5 >= 5.3.0, PHP 7)

Giriş

The SplHeap class provides the main functionalities of a Heap.

Sınıf Sözdizimi

abstract SplHeap implements Iterator , Countable {
/* Yöntemler */
public __construct ( void )
abstract protected int compare ( mixed $value1 , mixed $value2 )
public int count ( void )
public mixed current ( void )
public mixed extract ( void )
public void insert ( mixed $value )
public bool isEmpty ( void )
public mixed key ( void )
public void next ( void )
public void recoverFromCorruption ( void )
public void rewind ( void )
public mixed top ( void )
public bool valid ( void )
}

İçindekiler

  • SplHeap::compare — Compare elements in order to place them correctly in the heap while sifting up.
  • SplHeap::__construct — Constructs a new empty heap
  • SplHeap::count — Counts the number of elements in the heap.
  • SplHeap::current — Return current node pointed by the iterator
  • SplHeap::extract — Extracts a node from top of the heap and sift up.
  • SplHeap::insert — Inserts an element in the heap by sifting it up.
  • SplHeap::isEmpty — Checks whether the heap is empty.
  • SplHeap::key — Return current node index
  • SplHeap::next — Move to the next node
  • SplHeap::recoverFromCorruption — Recover from the corrupted state and allow further actions on the heap.
  • SplHeap::rewind — Rewind iterator back to the start (no-op)
  • SplHeap::top — Peeks at the node from the top of the heap
  • SplHeap::valid — Check whether the heap contains more nodes
SplQueue::setIteratorMode
SplHeap::compare
Datastructures


Compare elements in order to place them correctly in the heap while sifting up.

SplHeap
SplHeap::__construct
SplHeap
PHP Manual

SplHeap::compare

(PHP 5 >= 5.3.0, PHP 7)

SplHeap::compare — Compare elements in order to place them correctly in the heap while sifting up.

Açıklama

abstract protected int SplHeap::compare ( mixed $value1 , mixed $value2 )

Compare value1 with value2.

Uyarı

Throwing exceptions in SplHeap::compare() can corrupt the Heap and place it in a blocked state. You can unblock it by calling SplHeap::recoverFromCorruption(). However, some elements might not be placed correctly and it may hence break the heap-property.

Değiştirgeler

value1

The value of the first node being compared.

value2

The value of the second node being compared.

Dönen Değerler

Result of the comparison, positive integer if value1 is greater than value2, 0 if they are equal, negative integer otherwise.

Bilginize:

Having multiple elements with the same value in a Heap is not recommended. They will end up in an arbitrary relative position.

SplHeap
SplHeap::__construct
SplHeap


Constructs a new empty heap

SplHeap::compare
SplHeap::count
SplHeap
PHP Manual

SplHeap::__construct

(PHP 5 >= 5.3.0, PHP 7)

SplHeap::__construct — Constructs a new empty heap

Açıklama

public SplHeap::__construct ( void )

This constructs a new empty heap.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

SplHeap::compare
SplHeap::count
SplHeap


Counts the number of elements in the heap.

SplHeap::__construct
SplHeap::current
SplHeap
PHP Manual

SplHeap::count

(PHP 5 >= 5.3.0, PHP 7)

SplHeap::count — Counts the number of elements in the heap.

Açıklama

public int SplHeap::count ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the number of elements in the heap.

SplHeap::__construct
SplHeap::current
SplHeap


Return current node pointed by the iterator

SplHeap::count
SplHeap::extract
SplHeap
PHP Manual

SplHeap::current

(PHP 5 >= 5.3.0, PHP 7)

SplHeap::current — Return current node pointed by the iterator

Açıklama

public mixed SplHeap::current ( void )

Get the current datastructure node.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current node value.

SplHeap::count
SplHeap::extract
SplHeap


Extracts a node from top of the heap and sift up.

SplHeap::current
SplHeap::insert
SplHeap
PHP Manual

SplHeap::extract

(PHP 5 >= 5.3.0, PHP 7)

SplHeap::extract — Extracts a node from top of the heap and sift up.

Açıklama

public mixed SplHeap::extract ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The value of the extracted node.

Hatalar/İstisnalar

Throws RuntimeException when the data-structure is empty.

SplHeap::current
SplHeap::insert
SplHeap


Inserts an element in the heap by sifting it up.

SplHeap::extract
SplHeap::isEmpty
SplHeap
PHP Manual

SplHeap::insert

(PHP 5 >= 5.3.0, PHP 7)

SplHeap::insert — Inserts an element in the heap by sifting it up.

Açıklama

public void SplHeap::insert ( mixed $value )

Insert value in the heap.

Değiştirgeler

value

The value to insert.

Dönen Değerler

Hiçbir değer dönmez.

SplHeap::extract
SplHeap::isEmpty
SplHeap


Checks whether the heap is empty.

SplHeap::insert
SplHeap::key
SplHeap
PHP Manual

SplHeap::isEmpty

(PHP 5 >= 5.3.0, PHP 7)

SplHeap::isEmpty — Checks whether the heap is empty.

Açıklama

public bool SplHeap::isEmpty ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns whether the heap is empty.

SplHeap::insert
SplHeap::key
SplHeap


Return current node index

SplHeap::isEmpty
SplHeap::next
SplHeap
PHP Manual

SplHeap::key

(PHP 5 >= 5.3.0, PHP 7)

SplHeap::key — Return current node index

Açıklama

public mixed SplHeap::key ( void )

This function returns the current node index

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current node index.

SplHeap::isEmpty
SplHeap::next
SplHeap


Move to the next node

SplHeap::key
SplHeap::recoverFromCorruption
SplHeap
PHP Manual

SplHeap::next

(PHP 5 >= 5.3.0, PHP 7)

SplHeap::next — Move to the next node

Açıklama

public void SplHeap::next ( void )

Move to the next node. This will delete the top node of the heap.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

SplHeap::key
SplHeap::recoverFromCorruption
SplHeap


Recover from the corrupted state and allow further actions on the heap.

SplHeap::next
SplHeap::rewind
SplHeap
PHP Manual

SplHeap::recoverFromCorruption

(PHP 5 >= 5.3.0, PHP 7)

SplHeap::recoverFromCorruption — Recover from the corrupted state and allow further actions on the heap.

Açıklama

public void SplHeap::recoverFromCorruption ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

SplHeap::next
SplHeap::rewind
SplHeap


Rewind iterator back to the start (no-op)

SplHeap::recoverFromCorruption
SplHeap::top
SplHeap
PHP Manual

SplHeap::rewind

(PHP 5 >= 5.3.0, PHP 7)

SplHeap::rewind — Rewind iterator back to the start (no-op)

Açıklama

public void SplHeap::rewind ( void )

This rewinds the iterator to the beginning. This is a no-op for heaps as the iterator is virtual and in fact never moves from the top of the heap.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

SplHeap::recoverFromCorruption
SplHeap::top
SplHeap


Peeks at the node from the top of the heap

SplHeap::rewind
SplHeap::valid
SplHeap
PHP Manual

SplHeap::top

(PHP 5 >= 5.3.0, PHP 7)

SplHeap::top — Peeks at the node from the top of the heap

Açıklama

public mixed SplHeap::top ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The value of the node on the top.

Hatalar/İstisnalar

Throws RuntimeException when the data-structure is empty.

SplHeap::rewind
SplHeap::valid
SplHeap


Check whether the heap contains more nodes

SplHeap::top
SplMaxHeap
SplHeap
PHP Manual

SplHeap::valid

(PHP 5 >= 5.3.0, PHP 7)

SplHeap::valid — Check whether the heap contains more nodes

Açıklama

public bool SplHeap::valid ( void )

Checks if the heap contains any more nodes.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the heap contains any more nodes, FALSE otherwise.

SplHeap::top
SplMaxHeap
SplHeap


The SplMaxHeap class

(PHP 5 >= 5.3.0, PHP 7)

Giriş

The SplMaxHeap class provides the main functionalities of a heap, keeping the maximum on the top.

Sınıf Sözdizimi

SplMaxHeap extends SplHeap implements Iterator , Countable {
/* Yöntemler */
protected int compare ( mixed $value1 , mixed $value2 )
/* Miras alınan yöntemler */
abstract protected int SplHeap::compare ( mixed $value1 , mixed $value2 )
public int SplHeap::count ( void )
public mixed SplHeap::current ( void )
public mixed SplHeap::extract ( void )
public void SplHeap::insert ( mixed $value )
public bool SplHeap::isEmpty ( void )
public mixed SplHeap::key ( void )
public void SplHeap::next ( void )
public void SplHeap::recoverFromCorruption ( void )
public void SplHeap::rewind ( void )
public mixed SplHeap::top ( void )
public bool SplHeap::valid ( void )
}

İçindekiler

  • SplMaxHeap::compare — Compare elements in order to place them correctly in the heap while sifting up.
SplHeap::valid
SplMaxHeap::compare
Datastructures


Compare elements in order to place them correctly in the heap while sifting up.

SplMaxHeap
SplMinHeap
SplMaxHeap
PHP Manual

SplMaxHeap::compare

(PHP 5 >= 5.3.0, PHP 7)

SplMaxHeap::compare — Compare elements in order to place them correctly in the heap while sifting up.

Açıklama

protected int SplMaxHeap::compare ( mixed $value1 , mixed $value2 )

Compare value1 with value2.

Değiştirgeler

value1

The value of the first node being compared.

value2

The value of the second node being compared.

Dönen Değerler

Result of the comparison, positive integer if value1 is greater than value2, 0 if they are equal, negative integer otherwise.

Bilginize:

Having multiple elements with the same value in a Heap is not recommended. They will end up in an arbitrary relative position.

SplMaxHeap
SplMinHeap
SplMaxHeap


The SplMinHeap class

(PHP 5 >= 5.3.0, PHP 7)

Giriş

The SplMinHeap class provides the main functionalities of a heap, keeping the minimum on the top.

Sınıf Sözdizimi

SplMinHeap extends SplHeap implements Iterator , Countable {
/* Yöntemler */
protected int compare ( mixed $value1 , mixed $value2 )
/* Miras alınan yöntemler */
abstract protected int SplHeap::compare ( mixed $value1 , mixed $value2 )
public int SplHeap::count ( void )
public mixed SplHeap::current ( void )
public mixed SplHeap::extract ( void )
public void SplHeap::insert ( mixed $value )
public bool SplHeap::isEmpty ( void )
public mixed SplHeap::key ( void )
public void SplHeap::next ( void )
public void SplHeap::recoverFromCorruption ( void )
public void SplHeap::rewind ( void )
public mixed SplHeap::top ( void )
public bool SplHeap::valid ( void )
}

İçindekiler

  • SplMinHeap::compare — Compare elements in order to place them correctly in the heap while sifting up.
SplMaxHeap::compare
SplMinHeap::compare
Datastructures


Compare elements in order to place them correctly in the heap while sifting up.

SplMinHeap
SplPriorityQueue
SplMinHeap
PHP Manual

SplMinHeap::compare

(PHP 5 >= 5.3.0, PHP 7)

SplMinHeap::compare — Compare elements in order to place them correctly in the heap while sifting up.

Açıklama

protected int SplMinHeap::compare ( mixed $value1 , mixed $value2 )

Compare value1 with value2.

Değiştirgeler

value1

The value of the first node being compared.

value2

The value of the second node being compared.

Dönen Değerler

Result of the comparison, positive integer if value1 is lower than value2, 0 if they are equal, negative integer otherwise.

Bilginize:

Having multiple elements with the same value in a Heap is not recommended. They will end up in an arbitrary relative position.

SplMinHeap
SplPriorityQueue
SplMinHeap


The SplPriorityQueue class

(PHP 5 >= 5.3.0, PHP 7)

Giriş

The SplPriorityQueue class provides the main functionalities of a prioritized queue, implemented using a max heap.

Sınıf Sözdizimi

SplPriorityQueue implements Iterator , Countable {
/* Yöntemler */
public __construct ( void )
public int compare ( mixed $priority1 , mixed $priority2 )
public int count ( void )
public mixed current ( void )
public mixed extract ( void )
public void insert ( mixed $value , mixed $priority )
public bool isEmpty ( void )
public mixed key ( void )
public void next ( void )
public void recoverFromCorruption ( void )
public void rewind ( void )
public void setExtractFlags ( int $flags )
public mixed top ( void )
public bool valid ( void )
}

İçindekiler

  • SplPriorityQueue::compare — Compare priorities in order to place elements correctly in the heap while sifting up.
  • SplPriorityQueue::__construct — Constructs a new empty queue
  • SplPriorityQueue::count — Counts the number of elements in the queue.
  • SplPriorityQueue::current — Return current node pointed by the iterator
  • SplPriorityQueue::extract — Extracts a node from top of the heap and shift up.
  • SplPriorityQueue::insert — Inserts an element in the queue by sifting it up.
  • SplPriorityQueue::isEmpty — Checks whether the queue is empty.
  • SplPriorityQueue::key — Return current node index
  • SplPriorityQueue::next — Move to the next node
  • SplPriorityQueue::recoverFromCorruption — Recover from the corrupted state and allow further actions on the queue.
  • SplPriorityQueue::rewind — Rewind iterator back to the start (no-op)
  • SplPriorityQueue::setExtractFlags — Sets the mode of extraction
  • SplPriorityQueue::top — Peeks at the node from the top of the queue
  • SplPriorityQueue::valid — Check whether the queue contains more nodes
SplMinHeap::compare
SplPriorityQueue::compare
Datastructures


Compare priorities in order to place elements correctly in the heap while sifting up.

SplPriorityQueue
SplPriorityQueue::__construct
SplPriorityQueue
PHP Manual

SplPriorityQueue::compare

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::compare — Compare priorities in order to place elements correctly in the heap while sifting up.

Açıklama

public int SplPriorityQueue::compare ( mixed $priority1 , mixed $priority2 )

Compare priority1 with priority2.

Değiştirgeler

priority1

The priority of the first node being compared.

priority2

The priority of the second node being compared.

Dönen Değerler

Result of the comparison, positive integer if priority1 is greater than priority2, 0 if they are equal, negative integer otherwise.

Bilginize:

Multiple elements with the same priority will get dequeued in no particular order.

SplPriorityQueue
SplPriorityQueue::__construct
SplPriorityQueue


Constructs a new empty queue

SplPriorityQueue::compare
SplPriorityQueue::count
SplPriorityQueue
PHP Manual

SplPriorityQueue::__construct

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::__construct — Constructs a new empty queue

Açıklama

public SplPriorityQueue::__construct ( void )

This constructs a new empty queue.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

SplPriorityQueue::compare
SplPriorityQueue::count
SplPriorityQueue


Counts the number of elements in the queue.

SplPriorityQueue::__construct
SplPriorityQueue::current
SplPriorityQueue
PHP Manual

SplPriorityQueue::count

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::count — Counts the number of elements in the queue.

Açıklama

public int SplPriorityQueue::count ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the number of elements in the queue.

SplPriorityQueue::__construct
SplPriorityQueue::current
SplPriorityQueue


Return current node pointed by the iterator

SplPriorityQueue::count
SplPriorityQueue::extract
SplPriorityQueue
PHP Manual

SplPriorityQueue::current

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::current — Return current node pointed by the iterator

Açıklama

public mixed SplPriorityQueue::current ( void )

Get the current datastructure node.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The value or priority (or both) of the current node, depending on the extract flag.

SplPriorityQueue::count
SplPriorityQueue::extract
SplPriorityQueue


Extracts a node from top of the heap and shift up.

SplPriorityQueue::current
SplPriorityQueue::insert
SplPriorityQueue
PHP Manual

SplPriorityQueue::extract

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::extract — Extracts a node from top of the heap and shift up.

Açıklama

public mixed SplPriorityQueue::extract ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The value or priority (or both) of the extracted node, depending on the extract flag.

SplPriorityQueue::current
SplPriorityQueue::insert
SplPriorityQueue


Inserts an element in the queue by sifting it up.

SplPriorityQueue::extract
SplPriorityQueue::isEmpty
SplPriorityQueue
PHP Manual

SplPriorityQueue::insert

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::insert — Inserts an element in the queue by sifting it up.

Açıklama

public void SplPriorityQueue::insert ( mixed $value , mixed $priority )

Insert value with the priority priority in the queue.

Değiştirgeler

value

The value to insert.

priority

The associated priority.

Dönen Değerler

Hiçbir değer dönmez.

SplPriorityQueue::extract
SplPriorityQueue::isEmpty
SplPriorityQueue


Checks whether the queue is empty.

SplPriorityQueue::insert
SplPriorityQueue::key
SplPriorityQueue
PHP Manual

SplPriorityQueue::isEmpty

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::isEmpty — Checks whether the queue is empty.

Açıklama

public bool SplPriorityQueue::isEmpty ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns whether the queue is empty.

SplPriorityQueue::insert
SplPriorityQueue::key
SplPriorityQueue


Return current node index

SplPriorityQueue::isEmpty
SplPriorityQueue::next
SplPriorityQueue
PHP Manual

SplPriorityQueue::key

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::key — Return current node index

Açıklama

public mixed SplPriorityQueue::key ( void )

This function returns the current node index

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current node index.

SplPriorityQueue::isEmpty
SplPriorityQueue::next
SplPriorityQueue


Move to the next node

SplPriorityQueue::key
SplPriorityQueue::recoverFromCorruption
SplPriorityQueue
PHP Manual

SplPriorityQueue::next

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::next — Move to the next node

Açıklama

public void SplPriorityQueue::next ( void )

Extracts the top node from the queue.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

SplPriorityQueue::key
SplPriorityQueue::recoverFromCorruption
SplPriorityQueue


Recover from the corrupted state and allow further actions on the queue.

SplPriorityQueue::next
SplPriorityQueue::rewind
SplPriorityQueue
PHP Manual

SplPriorityQueue::recoverFromCorruption

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::recoverFromCorruption — Recover from the corrupted state and allow further actions on the queue.

Açıklama

public void SplPriorityQueue::recoverFromCorruption ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

SplPriorityQueue::next
SplPriorityQueue::rewind
SplPriorityQueue


Rewind iterator back to the start (no-op)

SplPriorityQueue::recoverFromCorruption
SplPriorityQueue::setExtractFlags
SplPriorityQueue
PHP Manual

SplPriorityQueue::rewind

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::rewind — Rewind iterator back to the start (no-op)

Açıklama

public void SplPriorityQueue::rewind ( void )

This rewinds the iterator to the beginning. This is a no-op for heaps as the iterator is virtual and in fact never moves from the top of the heap.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

SplPriorityQueue::recoverFromCorruption
SplPriorityQueue::setExtractFlags
SplPriorityQueue


Sets the mode of extraction

SplPriorityQueue::rewind
SplPriorityQueue::top
SplPriorityQueue
PHP Manual

SplPriorityQueue::setExtractFlags

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::setExtractFlags — Sets the mode of extraction

Açıklama

public void SplPriorityQueue::setExtractFlags ( int $flags )

Değiştirgeler

flags

Defines what is extracted by SplPriorityQueue::current(),
SplPriorityQueue::top() and
SplPriorityQueue::extract().

  • SplPriorityQueue::EXTR_DATA (0x00000001): Extract the data
  • SplPriorityQueue::EXTR_PRIORITY (0x00000002): Extract the priority
  • SplPriorityQueue::EXTR_BOTH (0x00000003): Extract an array containing both

The default mode is SplPriorityQueue::EXTR_DATA.

Dönen Değerler

Hiçbir değer dönmez.

SplPriorityQueue::rewind
SplPriorityQueue::top
SplPriorityQueue


Peeks at the node from the top of the queue

SplPriorityQueue::setExtractFlags
SplPriorityQueue::valid
SplPriorityQueue
PHP Manual

SplPriorityQueue::top

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::top — Peeks at the node from the top of the queue

Açıklama

public mixed SplPriorityQueue::top ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The value or priority (or both) of the top node, depending on the extract flag.

SplPriorityQueue::setExtractFlags
SplPriorityQueue::valid
SplPriorityQueue


Check whether the queue contains more nodes

SplPriorityQueue::top
SplFixedArray
SplPriorityQueue
PHP Manual

SplPriorityQueue::valid

(PHP 5 >= 5.3.0, PHP 7)

SplPriorityQueue::valid — Check whether the queue contains more nodes

Açıklama

public bool SplPriorityQueue::valid ( void )

Checks if the queue contains any more nodes.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the queue contains any more nodes, FALSE otherwise.

SplPriorityQueue::top
SplFixedArray
SplPriorityQueue


The SplFixedArray class

(PHP 5 >= 5.3.0, PHP 7)

Giriş

The SplFixedArray class provides the main functionalities of array. The main differences between a SplFixedArray and a normal PHP array is that the SplFixedArray is of fixed length and allows only integers within the range as indexes. The advantage is that it allows a faster array implementation.

Sınıf Sözdizimi

SplFixedArray implements Iterator , ArrayAccess , Countable {
/* Yöntemler */
public __construct ([ int $size = 0 ] )
public int count ( void )
public mixed current ( void )
public static SplFixedArray fromArray ( array $array [, bool $save_indexes = true ] )
public int getSize ( void )
public int key ( void )
public void next ( void )
public bool offsetExists ( int $index )
public mixed offsetGet ( int $index )
public void offsetSet ( int $index , mixed $newval )
public void offsetUnset ( int $index )
public void rewind ( void )
public int setSize ( int $size )
public array toArray ( void )
public bool valid ( void )
public void __wakeup ( void )
}

Örnekler

Örnek 1 SplFixedArray usage example

<?php
// Initialize the array with a fixed length
$array = new SplFixedArray(5);

$array[1] = 2;
$array[4] = "foo";

var_dump($array[0]); // NULL
var_dump($array[1]); // int(2)

var_dump($array["4"]); // string(3) "foo"

// Increase the size of the array to 10
$array->setSize(10);

$array[9] = "asdf";

// Shrink the array to a size of 2
$array->setSize(2);

// The following lines throw a RuntimeException: Index invalid or out of range
try {
    var_dump($array["non-numeric"]);
} catch(RuntimeException $re) {
    echo "RuntimeException: ".$re->getMessage()."\n";
}

try {
    var_dump($array[-1]);
} catch(RuntimeException $re) {
    echo "RuntimeException: ".$re->getMessage()."\n";
}

try {
    var_dump($array[5]);
} catch(RuntimeException $re) {
    echo "RuntimeException: ".$re->getMessage()."\n";
}
?>

Yukarıdaki örneğin çıktısı:

NULL
int(2)
string(3) "foo"
RuntimeException: Index invalid or out of range
RuntimeException: Index invalid or out of range
RuntimeException: Index invalid or out of range

İçindekiler

  • SplFixedArray::__construct — Constructs a new fixed array
  • SplFixedArray::count — Returns the size of the array
  • SplFixedArray::current — Return current array entry
  • SplFixedArray::fromArray — Import a PHP array in a SplFixedArray instance
  • SplFixedArray::getSize — Gets the size of the array
  • SplFixedArray::key — Return current array index
  • SplFixedArray::next — Move to next entry
  • SplFixedArray::offsetExists — Returns whether the requested index exists
  • SplFixedArray::offsetGet — Returns the value at the specified index
  • SplFixedArray::offsetSet — Sets a new value at a specified index
  • SplFixedArray::offsetUnset — Unsets the value at the specified $index
  • SplFixedArray::rewind — Rewind iterator back to the start
  • SplFixedArray::setSize — Change the size of an array
  • SplFixedArray::toArray — Returns a PHP array from the fixed array
  • SplFixedArray::valid — Check whether the array contains more elements
  • SplFixedArray::__wakeup — Reinitialises the array after being unserialised
SplPriorityQueue::valid
SplFixedArray::__construct
Datastructures


Constructs a new fixed array

SplFixedArray
SplFixedArray::count
SplFixedArray
PHP Manual

SplFixedArray::__construct

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::__construct — Constructs a new fixed array

Açıklama

public SplFixedArray::__construct ([ int $size = 0 ] )

Initializes a fixed array with a number of NULL values equal to size.

Değiştirgeler

size

The size of the fixed array. This expects a number between 0 and PHP_INT_MAX.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

Throws InvalidArgumentException when size is a negative number.

Raises E_WARNING when size cannot be parsed as a number.

Örnekler

Örnek 1 SplFixedArray::__construct() example

<?php
$array = new SplFixedArray(5);

$array[1] = 2;
$array[4] = "foo";

foreach($array as $v) {
  var_dump($v);
}
?>

Yukarıdaki örneğin çıktısı:

NULL
int(2)
NULL
NULL
string(3) "foo"

SplFixedArray
SplFixedArray::count
SplFixedArray


Returns the size of the array

SplFixedArray::__construct
SplFixedArray::current
SplFixedArray
PHP Manual

SplFixedArray::count

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::count — Returns the size of the array

Açıklama

public int SplFixedArray::count ( void )

Returns the size of the array.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the size of the array.

Örnekler

Örnek 1 SplFixedArray::count() example

<?php
$array = new SplFixedArray(5);
echo $array->count() . "\n";
echo count($array) . "\n";
?>

Yukarıdaki örneğin çıktısı:

5
5

Notlar

Bilginize:

This method is functionally equivalent to SplFixedArray::getSize().

Bilginize:

The count of elements is always equal to the set size because all values are initially initialized with NULL.

Ayrıca Bakınız

  • SplFixedArray::getSize() - Gets the size of the array
SplFixedArray::__construct
SplFixedArray::current
SplFixedArray


Return current array entry

SplFixedArray::count
SplFixedArray::fromArray
SplFixedArray
PHP Manual

SplFixedArray::current

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::current — Return current array entry

Açıklama

public mixed SplFixedArray::current ( void )

Get the current array element.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current element value.

Hatalar/İstisnalar

Throws RuntimeException when the internal array pointer points to an invalid index or is out of bounds.

SplFixedArray::count
SplFixedArray::fromArray
SplFixedArray


Import a PHP array in a SplFixedArray instance

SplFixedArray::current
SplFixedArray::getSize
SplFixedArray
PHP Manual

SplFixedArray::fromArray

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::fromArray — Import a PHP array in a SplFixedArray instance

Açıklama

public static SplFixedArray SplFixedArray::fromArray ( array $array [, bool $save_indexes = true ] )

Import the PHP array array in a new SplFixedArray instance

Değiştirgeler

array

The array to import.

save_indexes

Try to save the numeric indexes used in the original array.

Dönen Değerler

Returns an instance of SplFixedArray containing the array content.

Örnekler

Örnek 1 SplFixedArray::fromArray() example

<?php
$fa = SplFixedArray::fromArray(array(1 => 1, 0 => 2, 3 => 3));

var_dump($fa);

$fa = SplFixedArray::fromArray(array(1 => 1, 0 => 2, 3 => 3), false);

var_dump($fa);
?>

Yukarıdaki örneğin çıktısı:

object(SplFixedArray)#1 (4) {
  [0]=>
  int(2)
  [1]=>
  int(1)
  [2]=>
  NULL
  [3]=>
  int(3)
}
object(SplFixedArray)#2 (3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}

SplFixedArray::current
SplFixedArray::getSize
SplFixedArray


Gets the size of the array

SplFixedArray::fromArray
SplFixedArray::key
SplFixedArray
PHP Manual

SplFixedArray::getSize

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::getSize — Gets the size of the array

Açıklama

public int SplFixedArray::getSize ( void )

Gets the size of the array.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the size of the array, as an integer.

Örnekler

Örnek 1 SplFixedArray::getSize() example

<?php
$array = new SplFixedArray(5);
echo $array->getSize()."\n";
$array->setSize(10);
echo $array->getSize()."\n";
?>

Yukarıdaki örneğin çıktısı:

5
10

Notlar

Bilginize:

This method is functionally equivalent to SplFixedArray::count()

Ayrıca Bakınız

  • SplFixedArray::count() - Returns the size of the array
SplFixedArray::fromArray
SplFixedArray::key
SplFixedArray


Return current array index

SplFixedArray::getSize
SplFixedArray::next
SplFixedArray
PHP Manual

SplFixedArray::key

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::key — Return current array index

Açıklama

public int SplFixedArray::key ( void )

Returns the current array index.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current array index.

SplFixedArray::getSize
SplFixedArray::next
SplFixedArray


Move to next entry

SplFixedArray::key
SplFixedArray::offsetExists
SplFixedArray
PHP Manual

SplFixedArray::next

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::next — Move to next entry

Açıklama

public void SplFixedArray::next ( void )

Move the iterator to the next array entry.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

SplFixedArray::key
SplFixedArray::offsetExists
SplFixedArray


Returns whether the requested index exists

SplFixedArray::next
SplFixedArray::offsetGet
SplFixedArray
PHP Manual

SplFixedArray::offsetExists

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::offsetExists — Returns whether the requested index exists

Açıklama

public bool SplFixedArray::offsetExists ( int $index )

Checks whether the requested index index exists.

Değiştirgeler

index

The index being checked.

Dönen Değerler

TRUE if the requested index exists, otherwise FALSE

SplFixedArray::next
SplFixedArray::offsetGet
SplFixedArray


Returns the value at the specified index

SplFixedArray::offsetExists
SplFixedArray::offsetSet
SplFixedArray
PHP Manual

SplFixedArray::offsetGet

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::offsetGet — Returns the value at the specified index

Açıklama

public mixed SplFixedArray::offsetGet ( int $index )

Returns the value at the index index.

Değiştirgeler

index

The index with the value.

Dönen Değerler

The value at the specified index.

Hatalar/İstisnalar

Throws RuntimeException when index is outside the defined size of the array or when index cannot be parsed as an integer.

SplFixedArray::offsetExists
SplFixedArray::offsetSet
SplFixedArray


Sets a new value at a specified index

SplFixedArray::offsetGet
SplFixedArray::offsetUnset
SplFixedArray
PHP Manual

SplFixedArray::offsetSet

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::offsetSet — Sets a new value at a specified index

Açıklama

public void SplFixedArray::offsetSet ( int $index , mixed $newval )

Sets the value at the specified index to newval.

Değiştirgeler

index

The index being set.

newval

The new value for the index.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

Throws RuntimeException when index is outside the defined size of the array or when index cannot be parsed as an integer.

SplFixedArray::offsetGet
SplFixedArray::offsetUnset
SplFixedArray


Unsets the value at the specified $index

SplFixedArray::offsetSet
SplFixedArray::rewind
SplFixedArray
PHP Manual

SplFixedArray::offsetUnset

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::offsetUnset — Unsets the value at the specified $index

Açıklama

public void SplFixedArray::offsetUnset ( int $index )

Unsets the value at the specified index.

Değiştirgeler

index

The index being unset.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

Throws RuntimeException when index is outside the defined size of the array or when index cannot be parsed as an integer.

SplFixedArray::offsetSet
SplFixedArray::rewind
SplFixedArray


Rewind iterator back to the start

SplFixedArray::offsetUnset
SplFixedArray::setSize
SplFixedArray
PHP Manual

SplFixedArray::rewind

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::rewind — Rewind iterator back to the start

Açıklama

public void SplFixedArray::rewind ( void )

Rewinds the iterator to the beginning.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

SplFixedArray::offsetUnset
SplFixedArray::setSize
SplFixedArray


Change the size of an array

SplFixedArray::rewind
SplFixedArray::toArray
SplFixedArray
PHP Manual

SplFixedArray::setSize

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::setSize — Change the size of an array

Açıklama

public int SplFixedArray::setSize ( int $size )

Change the size of an array to the new size of size. If size is less than the current array size, any values after the new size will be discarded. If size is greater than the current array size, the array will be padded with NULL values.

Değiştirgeler

size

The new array size. This should be a value between 0 and PHP_INT_MAX.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

Throws InvalidArgumentException when size is less than zero.

Raises E_WARNING when size cannot be used as a number.

Örnekler

Örnek 1 SplFixedArray::setSize() example

<?php
   $array = new SplFixedArray(5);
   echo $array->getSize()."\n";
   $array->setSize(10);
   echo $array->getSize()."\n";
?>

Yukarıdaki örneğin çıktısı:

5
10

SplFixedArray::rewind
SplFixedArray::toArray
SplFixedArray


Returns a PHP array from the fixed array

SplFixedArray::setSize
SplFixedArray::valid
SplFixedArray
PHP Manual

SplFixedArray::toArray

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::toArray — Returns a PHP array from the fixed array

Açıklama

public array SplFixedArray::toArray ( void )

Returns a PHP array from the fixed array.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a PHP array, similar to the fixed array.

Örnekler

Örnek 1 SplFixedArray::toArray() example

<?php
$fa = new SplFixedArray(3);
$fa[0] = 0;
$fa[2] = 2;
var_dump($fa->toArray());
?>

Yukarıdaki örneğin çıktısı:

array(3) {
  [0]=>
  int(0)
  [1]=>
  NULL
  [2]=>
  int(2)
}

SplFixedArray::setSize
SplFixedArray::valid
SplFixedArray


Check whether the array contains more elements

SplFixedArray::toArray
SplFixedArray::__wakeup
SplFixedArray
PHP Manual

SplFixedArray::valid

(PHP 5 >= 5.3.0, PHP 7)

SplFixedArray::valid — Check whether the array contains more elements

Açıklama

public bool SplFixedArray::valid ( void )

Checks if the array contains any more elements.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the array contains any more elements, FALSE otherwise.

SplFixedArray::toArray
SplFixedArray::__wakeup
SplFixedArray


Reinitialises the array after being unserialised

SplFixedArray::valid
SplObjectStorage
SplFixedArray
PHP Manual

SplFixedArray::__wakeup

(PHP 5 >= 5.5.0, PHP 7)

SplFixedArray::__wakeup — Reinitialises the array after being unserialised

Açıklama

public void SplFixedArray::__wakeup ( void )

Reinitialises the array after being unserialised.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

SplFixedArray::valid
SplObjectStorage
SplFixedArray


The SplObjectStorage class

(PHP 5 >= 5.3.0, PHP 7)

Giriş

The SplObjectStorage class provides a map from objects to data or, by ignoring data, an object set. This dual purpose can be useful in many cases involving the need to uniquely identify objects.

Sınıf Sözdizimi

SplObjectStorage implements Countable , Iterator , Serializable , ArrayAccess {
/* Yöntemler */
public void addAll ( SplObjectStorage $storage )
public void attach ( object $object [, mixed $data = NULL ] )
public bool contains ( object $object )
public int count ( void )
public object current ( void )
public void detach ( object $object )
public string getHash ( object $object )
public mixed getInfo ( void )
public int key ( void )
public void next ( void )
public bool offsetExists ( object $object )
public mixed offsetGet ( object $object )
public void offsetSet ( object $object [, mixed $data = NULL ] )
public void offsetUnset ( object $object )
public void removeAll ( SplObjectStorage $storage )
public void removeAllExcept ( SplObjectStorage $storage )
public void rewind ( void )
public string serialize ( void )
public void setInfo ( mixed $data )
public void unserialize ( string $serialized )
public bool valid ( void )
}

Örnekler

Örnek 1 SplObjectStorage as a set

<?php
// As an object set
$s = new SplObjectStorage();

$o1 = new StdClass;
$o2 = new StdClass;
$o3 = new StdClass;

$s->attach($o1);
$s->attach($o2);

var_dump($s->contains($o1));
var_dump($s->contains($o2));
var_dump($s->contains($o3));

$s->detach($o2);

var_dump($s->contains($o1));
var_dump($s->contains($o2));
var_dump($s->contains($o3));
?>

Yukarıdaki örneğin çıktısı:

bool(true)
bool(true)
bool(false)
bool(true)
bool(false)
bool(false)

Örnek 2 SplObjectStorage as a map

<?php
// As a map from objects to data
$s = new SplObjectStorage();

$o1 = new StdClass;
$o2 = new StdClass;
$o3 = new StdClass;

$s[$o1] = "data for object 1";
$s[$o2] = array(1,2,3);

if (isset($s[$o2])) {
    var_dump($s[$o2]);
}
?>

Yukarıdaki örneğin çıktısı:

array(3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}

İçindekiler

  • SplObjectStorage::addAll — Adds all objects from another storage
  • SplObjectStorage::attach — Adds an object in the storage
  • SplObjectStorage::contains — Checks if the storage contains a specific object
  • SplObjectStorage::count — Returns the number of objects in the storage
  • SplObjectStorage::current — Returns the current storage entry
  • SplObjectStorage::detach — Removes an object from the storage
  • SplObjectStorage::getHash — Calculate a unique identifier for the contained objects
  • SplObjectStorage::getInfo — Returns the data associated with the current iterator entry
  • SplObjectStorage::key — Returns the index at which the iterator currently is
  • SplObjectStorage::next — Move to the next entry
  • SplObjectStorage::offsetExists — Checks whether an object exists in the storage
  • SplObjectStorage::offsetGet — Returns the data associated with an object
  • SplObjectStorage::offsetSet — Associates data to an object in the storage
  • SplObjectStorage::offsetUnset — Removes an object from the storage
  • SplObjectStorage::removeAll — Removes objects contained in another storage from the current storage
  • SplObjectStorage::removeAllExcept — Removes all objects except for those contained in another storage from the current storage
  • SplObjectStorage::rewind — Rewind the iterator to the first storage element
  • SplObjectStorage::serialize — Serializes the storage
  • SplObjectStorage::setInfo — Sets the data associated with the current iterator entry
  • SplObjectStorage::unserialize — Unserializes a storage from its string representation
  • SplObjectStorage::valid — Returns if the current iterator entry is valid
SplFixedArray::__wakeup
SplObjectStorage::addAll
Datastructures


Adds all objects from another storage

SplObjectStorage
SplObjectStorage::attach
SplObjectStorage
PHP Manual

SplObjectStorage::addAll

(PHP 5 >= 5.3.0, PHP 7)

SplObjectStorage::addAll — Adds all objects from another storage

Açıklama

public void SplObjectStorage::addAll ( SplObjectStorage $storage )

Adds all objects-data pairs from a different storage in the current storage.

Değiştirgeler

storage

The storage you want to import.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 SplObjectStorage::addAll() example

<?php
$o = new StdClass;
$a = new SplObjectStorage();
$a[$o] = "hello";

$b = new SplObjectStorage();
$b->addAll($a);
echo $b[$o]."\n";
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

hello

Ayrıca Bakınız

  • SplObjectStorage::removeAll() - Removes objects contained in another storage from the current storage

SplObjectStorage
SplObjectStorage::attach
SplObjectStorage


Adds an object in the storage

SplObjectStorage::addAll
SplObjectStorage::contains
SplObjectStorage
PHP Manual

SplObjectStorage::attach

(PHP 5 >= 5.1.0, PHP 7)

SplObjectStorage::attach — Adds an object in the storage

Açıklama

public void SplObjectStorage::attach ( object $object [, mixed $data = NULL ] )

Adds an object inside the storage, and optionally associate it to some data.

Değiştirgeler

object

The object to add.

data

The data to associate with the object.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 SplObjectStorage::attach() example

<?php
$o1 = new StdClass;
$o2 = new StdClass;
$s = new SplObjectStorage();
$s->attach($o1); // similar to $s[$o1] = NULL;
$s->attach($o2, "hello"); // similar to $s[$o2] = "hello";

var_dump($s[$o1]);
var_dump($s[$o2]);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

NULL
string(5) "hello"

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | Added the data parameter.

Ayrıca Bakınız

  • SplObjectStorage::detach() - Removes an object from the storage
  • SplObjectStorage::offsetSet() - Associates data to an object in the storage

SplObjectStorage::addAll
SplObjectStorage::contains
SplObjectStorage


Checks if the storage contains a specific object

SplObjectStorage::attach
SplObjectStorage::count
SplObjectStorage
PHP Manual

SplObjectStorage::contains

(PHP 5 >= 5.1.0, PHP 7)

SplObjectStorage::contains — Checks if the storage contains a specific object

Açıklama

public bool SplObjectStorage::contains ( object $object )

Checks if the storage contains the object provided.

Değiştirgeler

object

The object to look for.

Dönen Değerler

Returns TRUE if the object is in the storage, FALSE otherwise.

Örnekler

Örnek 1 SplObjectStorage::contains() example

<?php
$o1 = new StdClass;
$o2 = new StdClass;

$s = new SplObjectStorage();

$s[$o1] = "hello";
var_dump($s->contains($o1));
var_dump($s->contains($o2));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(true)
bool(false)

Ayrıca Bakınız

  • SplObjectStorage::offsetExists() - Checks whether an object exists in the storage

SplObjectStorage::attach
SplObjectStorage::count
SplObjectStorage


Returns the number of objects in the storage

SplObjectStorage::contains
SplObjectStorage::current
SplObjectStorage
PHP Manual

SplObjectStorage::count

(PHP 5 >= 5.1.0, PHP 7)

SplObjectStorage::count — Returns the number of objects in the storage

Açıklama

public int SplObjectStorage::count ( void )

Counts the number of objects in the storage.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The number of objects in the storage.

Örnekler

Örnek 1 SplObjectStorage::count() example

<?php
$s = new SplObjectStorage();
$o1 = new StdClass;
$o2 = new StdClass;

$s->attach($o1);
$s->attach($o2);
$s->attach($o1);
var_dump($s->count());
var_dump(count($s));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(2)
int(2)

Ayrıca Bakınız

  • SplObjectStorage::attach() - Adds an object in the storage
  • SplObjectStorage::detach() - Removes an object from the storage

SplObjectStorage::contains
SplObjectStorage::current
SplObjectStorage


Returns the current storage entry

SplObjectStorage::count
SplObjectStorage::detach
SplObjectStorage
PHP Manual

SplObjectStorage::current

(PHP 5 >= 5.1.0, PHP 7)

SplObjectStorage::current — Returns the current storage entry

Açıklama

public object SplObjectStorage::current ( void )

Returns the current storage entry.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The object at the current iterator position.

Örnekler

Örnek 1 SplObjectStorage::current() example

<?php
$s = new SplObjectStorage();

$o1 = new StdClass;
$o2 = new StdClass;

$s->attach($o1, "d1");
$s->attach($o2, "d2");

$s->rewind();
while($s->valid()) {
    $index  = $s->key();
    $object = $s->current(); // similar to current($s)
    $data   = $s->getInfo();

    var_dump($object);
    var_dump($data);
    $s->next();
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(stdClass)#2 (0) {
}
string(2) "d1"
object(stdClass)#3 (0) {
}
string(2) "d2"

Ayrıca Bakınız

  • SplObjectStorage::rewind() - Rewind the iterator to the first storage element
  • SplObjectStorage::key() - Returns the index at which the iterator currently is
  • SplObjectStorage::next() - Move to the next entry
  • SplObjectStorage::valid() - Returns if the current iterator entry is valid
  • SplObjectStorage::getInfo() - Returns the data associated with the current iterator entry

SplObjectStorage::count
SplObjectStorage::detach
SplObjectStorage


Removes an object from the storage

SplObjectStorage::current
SplObjectStorage::getHash
SplObjectStorage
PHP Manual

SplObjectStorage::detach

(PHP 5 >= 5.1.0, PHP 7)

SplObjectStorage::detach — Removes an object from the storage

Açıklama

public void SplObjectStorage::detach ( object $object )

Removes the object from the storage.

Değiştirgeler

object

The object to remove.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 SplObjectStorage::detach() example

<?php
$o = new StdClass;
$s = new SplObjectStorage();
$s->attach($o);
var_dump(count($s));
$s->detach($o);
var_dump(count($s));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(1)
int(0)

Ayrıca Bakınız

  • SplObjectStorage::attach() - Adds an object in the storage
  • SplObjectStorage::removeAll() - Removes objects contained in another storage from the current storage

SplObjectStorage::current
SplObjectStorage::getHash
SplObjectStorage


Calculate a unique identifier for the contained objects

SplObjectStorage::detach
SplObjectStorage::getInfo
SplObjectStorage
PHP Manual

SplObjectStorage::getHash

(PHP 5 >= 5.4.0, PHP 7)

SplObjectStorage::getHash — Calculate a unique identifier for the contained objects

Açıklama

public string SplObjectStorage::getHash ( object $object )

This method calculates an identifier for the objects added to an SplObjectStorage object.

The implementation in SplObjectStorage returns the same value as spl_object_hash().

The storage object will never contain more than one object with the same identifier. As such, it can be used to implement a set (a collection of unique values) where the quality of an object being unique is determined by the value returned by this function being unique.

Değiştirgeler

object

The object whose identifier is to be calculated.

Dönen Değerler

A string with the calculated identifier.

Hatalar/İstisnalar

A RuntimeException is thrown when the returned value is not a string.

Örnekler

Örnek 1 SplObjectStorage::getHash() example

<?php
class OneSpecimenPerClassStorage extends SplObjectStorage {
    public function getHash($o) {
        return get_class($o);
    }
}
class A {}

$s = new OneSpecimenPerClassStorage;
$o1 = new stdClass;
$o2 = new stdClass;
$o3 = new A;

$s[$o1] = 1;
//$o2 is considered equal to $o1 so the value is replaced
$s[$o2] = 2;
$s[$o3] = 3;

//these are considered equal to the objects before
//so they can be used to access the values stored under them
$p1 = new stdClass;
$p2 = new A;
echo $s[$p1], "\n";
echo $s[$p2], "\n";
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

2
3

Ayrıca Bakınız

  • spl_object_hash() - Return hash id for given object

SplObjectStorage::detach
SplObjectStorage::getInfo
SplObjectStorage


Returns the data associated with the current iterator entry

SplObjectStorage::getHash
SplObjectStorage::key
SplObjectStorage
PHP Manual

SplObjectStorage::getInfo

(PHP 5 >= 5.3.0, PHP 7)

SplObjectStorage::getInfo — Returns the data associated with the current iterator entry

Açıklama

public mixed SplObjectStorage::getInfo ( void )

Returns the data, or info, associated with the object pointed by the current iterator position.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The data associated with the current iterator position.

Örnekler

Örnek 1 SplObjectStorage::getInfo() example

<?php
$s = new SplObjectStorage();

$o1 = new StdClass;
$o2 = new StdClass;

$s->attach($o1, "d1");
$s->attach($o2, "d2");

$s->rewind();
while($s->valid()) {
    $index  = $s->key();
    $object = $s->current(); // similar to current($s)
    $data   = $s->getInfo();

    var_dump($object);
    var_dump($data);
    $s->next();
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(stdClass)#2 (0) {
}
string(2) "d1"
object(stdClass)#3 (0) {
}
string(2) "d2"

Ayrıca Bakınız

  • SplObjectStorage::current() - Returns the current storage entry
  • SplObjectStorage::rewind() - Rewind the iterator to the first storage element
  • SplObjectStorage::key() - Returns the index at which the iterator currently is
  • SplObjectStorage::next() - Move to the next entry
  • SplObjectStorage::valid() - Returns if the current iterator entry is valid
  • SplObjectStorage::setInfo() - Sets the data associated with the current iterator entry

SplObjectStorage::getHash
SplObjectStorage::key
SplObjectStorage


Returns the index at which the iterator currently is

SplObjectStorage::getInfo
SplObjectStorage::next
SplObjectStorage
PHP Manual

SplObjectStorage::key

(PHP 5 >= 5.1.0, PHP 7)

SplObjectStorage::key — Returns the index at which the iterator currently is

Açıklama

public int SplObjectStorage::key ( void )

Returns the index at which the iterator currently is.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The index corresponding to the position of the iterator.

Örnekler

Örnek 1 SplObjectStorage::key() example

<?php
$s = new SplObjectStorage();

$o1 = new StdClass;
$o2 = new StdClass;

$s->attach($o1, "d1");
$s->attach($o2, "d2");

$s->rewind();
while($s->valid()) {
    $index  = $s->key();
    $object = $s->current(); // similar to current($s)

    var_dump($index);
    var_dump($object);
    $s->next();
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(0)
object(stdClass)#2 (0) {
}
int(1)
object(stdClass)#3 (0) {
}

Ayrıca Bakınız

  • SplObjectStorage::rewind() - Rewind the iterator to the first storage element
  • SplObjectStorage::current() - Returns the current storage entry
  • SplObjectStorage::next() - Move to the next entry
  • SplObjectStorage::valid() - Returns if the current iterator entry is valid

SplObjectStorage::getInfo
SplObjectStorage::next
SplObjectStorage


Move to the next entry

SplObjectStorage::key
SplObjectStorage::offsetExists
SplObjectStorage
PHP Manual

SplObjectStorage::next

(PHP 5 >= 5.1.0, PHP 7)

SplObjectStorage::next — Move to the next entry

Açıklama

public void SplObjectStorage::next ( void )

Moves the iterator to the next object in the storage.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 SplObjectStorage::next() example

<?php
$s = new SplObjectStorage();

$o1 = new StdClass;
$o2 = new StdClass;

$s->attach($o1, "d1");
$s->attach($o2, "d2");

$s->rewind();
while($s->valid()) {
    $index  = $s->key();
    $object = $s->current(); // similar to current($s)

    var_dump($index);
    var_dump($object);
    $s->next();
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(0)
object(stdClass)#2 (0) {
}
int(1)
object(stdClass)#3 (0) {
}

Ayrıca Bakınız

  • SPLObjectStorage::rewind() - Rewind the iterator to the first storage element

SplObjectStorage::key
SplObjectStorage::offsetExists
SplObjectStorage


Checks whether an object exists in the storage

SplObjectStorage::next
SplObjectStorage::offsetGet
SplObjectStorage
PHP Manual

SplObjectStorage::offsetExists

(PHP 5 >= 5.3.0, PHP 7)

SplObjectStorage::offsetExists — Checks whether an object exists in the storage

Açıklama

public bool SplObjectStorage::offsetExists ( object $object )

Checks whether an object exists in the storage.

Bilginize:

SplObjectStorage::offsetExists() is an alias of SplObjectStorage::contains().

Değiştirgeler

object

The object to look for.

Dönen Değerler

Returns TRUE if the object exists in the storage, and FALSE otherwise.

Örnekler

Örnek 1 SplObjectStorage::offsetExists() example

<?php
$s = new SplObjectStorage;
$o1 = new StdClass;
$o2 = new StdClass;

$s->attach($o1);

var_dump($s->offsetExists($o1)); // Similar to isset($s[$o1])
var_dump($s->offsetExists($o2)); // Similar to isset($s[$o2])
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(true)
bool(false)

Ayrıca Bakınız

  • SplObjectStorage::offsetSet() - Associates data to an object in the storage
  • SplObjectStorage::offsetGet() - Returns the data associated with an object
  • SplObjectStorage::offsetUnset() - Removes an object from the storage

SplObjectStorage::next
SplObjectStorage::offsetGet
SplObjectStorage


Returns the data associated with an object

SplObjectStorage::offsetExists
SplObjectStorage::offsetSet
SplObjectStorage
PHP Manual

SplObjectStorage::offsetGet

(PHP 5 >= 5.3.0, PHP 7)

SplObjectStorage::offsetGet — Returns the data associated with an object

Açıklama

public mixed SplObjectStorage::offsetGet ( object $object )

Returns the data associated with an object in the storage.

Değiştirgeler

object

The object to look for.

Dönen Değerler

The data previously associated with the object in the storage.

Hatalar/İstisnalar

Throws UnexpectedValueException when object could not be found.

Örnekler

Örnek 1 SplObjectStorage::offsetGet() example

<?php
$s = new SplObjectStorage;

$o1 = new StdClass;
$o2 = new StdClass;

$s[$o1] = "hello";
$s->attach($o2);

var_dump($s->offsetGet($o1)); // Similar to $s[$o1]
var_dump($s->offsetGet($o2)); // Similar to $s[$o2]
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(5) "hello"
NULL

Ayrıca Bakınız

  • SplObjectStorage::offsetSet() - Associates data to an object in the storage
  • SplObjectStorage::offsetExists() - Checks whether an object exists in the storage
  • SplObjectStorage::offsetUnset() - Removes an object from the storage

SplObjectStorage::offsetExists
SplObjectStorage::offsetSet
SplObjectStorage


Associates data to an object in the storage

SplObjectStorage::offsetGet
SplObjectStorage::offsetUnset
SplObjectStorage
PHP Manual

SplObjectStorage::offsetSet

(PHP 5 >= 5.3.0, PHP 7)

SplObjectStorage::offsetSet — Associates data to an object in the storage

Açıklama

public void SplObjectStorage::offsetSet ( object $object [, mixed $data = NULL ] )

Associate data to an object in the storage.

Bilginize:

SplObjectStorage::offsetSet() is an alias of SplObjectStorage::attach().

Değiştirgeler

object

The object to associate data with.

data

The data to associate with the object.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 SplObjectStorage::offsetSet() example

<?php
$s = new SplObjectStorage;

$o1 = new StdClass;

$s->offsetSet($o1, "hello"); // Similar to $s[$o1] = "hello";

var_dump($s[$o1]);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(5) "hello"

Ayrıca Bakınız

  • SplObjectStorage::attach() - Adds an object in the storage
  • SplObjectStorage::offsetGet() - Returns the data associated with an object
  • SplObjectStorage::offsetExists() - Checks whether an object exists in the storage
  • SplObjectStorage::offsetUnset() - Removes an object from the storage

SplObjectStorage::offsetGet
SplObjectStorage::offsetUnset
SplObjectStorage


Removes an object from the storage

SplObjectStorage::offsetSet
SplObjectStorage::removeAll
SplObjectStorage
PHP Manual

SplObjectStorage::offsetUnset

(PHP 5 >= 5.3.0, PHP 7)

SplObjectStorage::offsetUnset — Removes an object from the storage

Açıklama

public void SplObjectStorage::offsetUnset ( object $object )

Removes an object from the storage.

Bilginize:

SplObjectStorage::offsetUnset() is an alias of SplObjectStorage::detach().

Değiştirgeler

object

The object to remove.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 SplObjectStorage::offsetUnset() example

<?php
$o = new StdClass;
$s = new SplObjectStorage();
$s->attach($o);
var_dump(count($s));
$s->offsetUnset($o); // Similar to unset($s[$o])
var_dump(count($s));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(1)
int(0)

Ayrıca Bakınız

  • SplObjectStorage::offsetGet() - Returns the data associated with an object
  • SplObjectStorage::offsetSet() - Associates data to an object in the storage
  • SplObjectStorage::offsetExists() - Checks whether an object exists in the storage

SplObjectStorage::offsetSet
SplObjectStorage::removeAll
SplObjectStorage


Removes objects contained in another storage from the current storage

SplObjectStorage::offsetUnset
SplObjectStorage::removeAllExcept
SplObjectStorage
PHP Manual

SplObjectStorage::removeAll

(PHP 5 >= 5.3.0, PHP 7)

SplObjectStorage::removeAll — Removes objects contained in another storage from the current storage

Açıklama

public void SplObjectStorage::removeAll ( SplObjectStorage $storage )

Removes objects contained in another storage from the current storage.

Değiştirgeler

storage

The storage containing the elements to remove.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 SplObjectStorage::removeAll() example

<?php
$o1 = new StdClass;
$o2 = new StdClass;
$a = new SplObjectStorage();
$a[$o1] = "foo";

$b = new SplObjectStorage();
$b[$o1] = "bar";
$b[$o2] = "gee";

var_dump(count($b));
$b->removeAll($a);
var_dump(count($b));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(2)
int(1)

Ayrıca Bakınız

  • SplObjectStorage::addAll() - Adds all objects from another storage

SplObjectStorage::offsetUnset
SplObjectStorage::removeAllExcept
SplObjectStorage


Removes all objects except for those contained in another storage from the current storage

SplObjectStorage::removeAll
SplObjectStorage::rewind
SplObjectStorage
PHP Manual

SplObjectStorage::removeAllExcept

(PHP 5 >= 5.3.6, PHP 7)

SplObjectStorage::removeAllExcept — Removes all objects except for those contained in another storage from the current storage

Açıklama

public void SplObjectStorage::removeAllExcept ( SplObjectStorage $storage )

Removes all objects except for those contained in another storage from the current storage.

Değiştirgeler

storage

The storage containing the elements to retain in the current storage.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 SplObjectStorage::removeAllExcept() example

<?php
$a = (object) 'a';
$b = (object) 'b';
$c = (object) 'c';

$foo = new SplObjectStorage;
$foo->attach($a);
$foo->attach($b);

$bar = new SplObjectStorage;
$bar->attach($b);
$bar->attach($c);

$foo->removeAllExcept($bar);
var_dump($foo->contains($a));
var_dump($foo->contains($b));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(false)
bool(true)

SplObjectStorage::removeAll
SplObjectStorage::rewind
SplObjectStorage


Rewind the iterator to the first storage element

SplObjectStorage::removeAllExcept
SplObjectStorage::serialize
SplObjectStorage
PHP Manual

SplObjectStorage::rewind

(PHP 5 >= 5.1.0, PHP 7)

SplObjectStorage::rewind — Rewind the iterator to the first storage element

Açıklama

public void SplObjectStorage::rewind ( void )

Rewind the iterator to the first storage element.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 SplObjectStorage::rewind() example

<?php
$s = new SplObjectStorage();

$o1 = new StdClass;
$o2 = new StdClass;

$s->attach($o1, "d1");
$s->attach($o2, "d2");

$s->rewind();
while($s->valid()) {
    $index  = $s->key();
    $object = $s->current(); // similar to current($s)
    $data   = $s->getInfo();

    var_dump($object);
    var_dump($data);
    $s->next();
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(1)
int(0)

Ayrıca Bakınız

  • SplObjectStorage::next() - Move to the next entry

SplObjectStorage::removeAllExcept
SplObjectStorage::serialize
SplObjectStorage


Serializes the storage

SplObjectStorage::rewind
SplObjectStorage::setInfo
SplObjectStorage
PHP Manual

SplObjectStorage::serialize

(PHP 5 >= 5.2.2, PHP 7)

SplObjectStorage::serialize — Serializes the storage

Açıklama

public string SplObjectStorage::serialize ( void )

Returns a string representation of the storage.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A string representing the storage.

Örnekler

Örnek 1 SplObjectStorage::serialize() example

<?php
$s = new SplObjectStorage;
$o = new StdClass;
$s[$o] = "data";

echo $s->serialize()."\n";
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

x:i:1;O:8:"stdClass":0:{},s:4:"data";;m:a:0:{}

Ayrıca Bakınız

  • SplObjectStorage::unserialize() - Unserializes a storage from its string representation

SplObjectStorage::rewind
SplObjectStorage::setInfo
SplObjectStorage


Sets the data associated with the current iterator entry

SplObjectStorage::serialize
SplObjectStorage::unserialize
SplObjectStorage
PHP Manual

SplObjectStorage::setInfo

(PHP 5 >= 5.3.0, PHP 7)

SplObjectStorage::setInfo — Sets the data associated with the current iterator entry

Açıklama

public void SplObjectStorage::setInfo ( mixed $data )

Associates data, or info, with the object currently pointed to by the iterator.

Değiştirgeler

data

The data to associate with the current iterator entry.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 SplObjectStorage::setInfo() example

<?php
$s = new SplObjectStorage();

$o1 = new StdClass;
$o2 = new StdClass;

$s->attach($o1, "d1");
$s->attach($o2, "d2");

$s->rewind();
while($s->valid()) {
    $s->setInfo("new");
    $s->next();
}
var_dump($s[$o1]);
var_dump($s[$o2]);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(3) "new"
string(3) "new"

Ayrıca Bakınız

  • SplObjectStorage::current() - Returns the current storage entry
  • SplObjectStorage::rewind() - Rewind the iterator to the first storage element
  • SplObjectStorage::key() - Returns the index at which the iterator currently is
  • SplObjectStorage::next() - Move to the next entry
  • SplObjectStorage::valid() - Returns if the current iterator entry is valid
  • SplObjectStorage::getInfo() - Returns the data associated with the current iterator entry

SplObjectStorage::serialize
SplObjectStorage::unserialize
SplObjectStorage


Unserializes a storage from its string representation

SplObjectStorage::setInfo
SplObjectStorage::valid
SplObjectStorage
PHP Manual

SplObjectStorage::unserialize

(PHP 5 >= 5.2.2, PHP 7)

SplObjectStorage::unserialize — Unserializes a storage from its string representation

Açıklama

public void SplObjectStorage::unserialize ( string $serialized )

Unserializes storage entries and attach them to the current storage.

Değiştirgeler

serialized

The serialized representation of a storage.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 SplObjectStorage::unserialize() example

<?php
$s1 = new SplObjectStorage;
$s2 = new SplObjectStorage;
$o = new StdClass;
$s1[$o] = "data";

$s2->unserialize($s1->serialize());

var_dump(count($s2));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(1)

Ayrıca Bakınız

  • SplObjectStorage::serialize() - Serializes the storage

SplObjectStorage::setInfo
SplObjectStorage::valid
SplObjectStorage


Returns if the current iterator entry is valid

SplObjectStorage::unserialize
Iterators
SplObjectStorage
PHP Manual

SplObjectStorage::valid

(PHP 5 >= 5.1.0, PHP 7)

SplObjectStorage::valid — Returns if the current iterator entry is valid

Açıklama

public bool SplObjectStorage::valid ( void )

Returns if the current iterator entry is valid.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the iterator entry is valid, FALSE otherwise.

Örnekler

Örnek 1 SplObjectStorage::valid() example

<?php
$s = new SplObjectStorage();

$o1 = new StdClass;
$o2 = new StdClass;

$s->attach($o1, "d1");
$s->attach($o2, "d2");

$s->rewind();
while($s->valid()) {
    echo $s->key()."\n";
    $s->next();
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

0
1

Ayrıca Bakınız

  • SplObjectStorage::current() - Returns the current storage entry
  • SplObjectStorage::getInfo() - Returns the data associated with the current iterator entry

SplObjectStorage::unserialize
Iterators
SplObjectStorage


Iterators

İçindekiler

  • AppendIterator
  • ArrayIterator
  • CachingIterator
  • CallbackFilterIterator
  • DirectoryIterator
  • EmptyIterator
  • FilesystemIterator
  • FilterIterator
  • GlobIterator
  • InfiniteIterator
  • IteratorIterator
  • LimitIterator
  • MultipleIterator
  • NoRewindIterator
  • ParentIterator
  • RecursiveArrayIterator
  • RecursiveCachingIterator
  • RecursiveCallbackFilterIterator
  • RecursiveDirectoryIterator
  • RecursiveFilterIterator
  • RecursiveIteratorIterator
  • RecursiveRegexIterator
  • RecursiveTreeIterator
  • RegexIterator

SPL provides a set of iterators to traverse over objects.

SPL Iterators Class Tree

  • ArrayIterator
    • RecursiveArrayIterator
  • EmptyIterator
  • IteratorIterator
    • AppendIterator
    • CachingIterator
      • RecursiveCachingIterator
    • FilterIterator
      • CallbackFilterIterator
        • RecursiveCallbackFilterIterator
      • RecursiveFilterIterator
        • ParentIterator
      • RegexIterator
        • RecursiveRegexIterator
    • InfiniteIterator
    • LimitIterator
    • NoRewindIterator
  • MultipleIterator
  • RecursiveIteratorIterator
    • RecursiveTreeIterator
  • DirectoryIterator (extends SplFileInfo)
    • FilesystemIterator
      • GlobIterator
      • RecursiveDirectoryIterator
SplObjectStorage::valid
AppendIterator
SPL


The AppendIterator class

(PHP 5 >= 5.1.0, PHP 7)

Giriş

An Iterator that iterates over several iterators one after the other.

Sınıf Sözdizimi

AppendIterator extends IteratorIterator implements OuterIterator {
/* Yöntemler */
public __construct ( void )
public void append ( Iterator $iterator )
public mixed current ( void )
public ArrayIterator getArrayIterator ( void )
public Iterator getInnerIterator ( void )
public int getIteratorIndex ( void )
public scalar key ( void )
public void next ( void )
public void rewind ( void )
public bool valid ( void )
/* Miras alınan yöntemler */
public IteratorIterator::__construct ( Traversable $iterator )
public mixed IteratorIterator::current ( void )
public Traversable IteratorIterator::getInnerIterator ( void )
public scalar IteratorIterator::key ( void )
public void IteratorIterator::next ( void )
public void IteratorIterator::rewind ( void )
public bool IteratorIterator::valid ( void )
}

İçindekiler

  • AppendIterator::append — Appends an iterator
  • AppendIterator::__construct — Constructs an AppendIterator
  • AppendIterator::current — Gets the current value
  • AppendIterator::getArrayIterator — Gets the ArrayIterator
  • AppendIterator::getInnerIterator — Gets the inner iterator
  • AppendIterator::getIteratorIndex — Gets an index of iterators
  • AppendIterator::key — Gets the current key
  • AppendIterator::next — Moves to the next element
  • AppendIterator::rewind — Rewinds the Iterator
  • AppendIterator::valid — Checks validity of the current element
Iterators
AppendIterator::append
Iterators


Appends an iterator

AppendIterator
AppendIterator::__construct
AppendIterator
PHP Manual

AppendIterator::append

(PHP 5 >= 5.1.0, PHP 7)

AppendIterator::append — Appends an iterator

Açıklama

public void AppendIterator::append ( Iterator $iterator )

Appends an iterator.

Değiştirgeler

iterator

The iterator to append.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 AppendIterator::append() example

<?php
$array_a = new ArrayIterator(array('a', 'b', 'c'));
$array_b = new ArrayIterator(array('d', 'e', 'f'));

$iterator = new AppendIterator;
$iterator->append($array_a);
$iterator->append($array_b);

foreach ($iterator as $current) {
    echo $current;
}
?>

Yukarıdaki örneğin çıktısı:

abcdef

Ayrıca Bakınız

  • AppendIterator::__construct() - Constructs an AppendIterator

AppendIterator
AppendIterator::__construct
AppendIterator


Constructs an AppendIterator

AppendIterator::append
AppendIterator::current
AppendIterator
PHP Manual

AppendIterator::__construct

(PHP 5 >= 5.1.0, PHP 7)

AppendIterator::__construct — Constructs an AppendIterator

Açıklama

public AppendIterator::__construct ( void )

Constructs an AppendIterator.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Iterating AppendIterator with foreach

<?php
$pizzas   = new ArrayIterator(array('Margarita', 'Siciliana', 'Hawaii'));
$toppings = new ArrayIterator(array('Cheese', 'Anchovies', 'Olives', 'Pineapple', 'Ham'));

$appendIterator = new AppendIterator;
$appendIterator->append($pizzas);
$appendIterator->append($toppings);

foreach ($appendIterator as $key => $item) {
    echo $key . ' => ' . $item . PHP_EOL;
}
?>

Yukarıdaki örneğin çıktısı:

0 => Margarita
1 => Siciliana
2 => Hawaii
0 => Cheese
1 => Anchovies
2 => Olives
3 => Pineapple
4 => Ham

Örnek 2 Iterating AppendIterator with the AppendIterator API

<?php
$pizzas   = new ArrayIterator(array('Margarita', 'Siciliana', 'Hawaii'));
$toppings = new ArrayIterator(array('Cheese', 'Anchovies', 'Olives', 'Pineapple', 'Ham'));

$appendIterator = new AppendIterator;
$appendIterator->append($pizzas);
$appendIterator->append($toppings);

while ($appendIterator->valid()) {
    printf(
        '%s => %s => %s%s',
        $appendIterator->getIteratorIndex(),
        $appendIterator->key(),
        $appendIterator->current(),
        PHP_EOL
    );
    $appendIterator->next();
}
?>

Yukarıdaki örneğin çıktısı:

0 => 0 => Margarita
0 => 1 => Siciliana
0 => 2 => Hawaii
1 => 0 => Cheese
1 => 1 => Anchovies
1 => 2 => Olives
1 => 3 => Pineapple
1 => 4 => Ham

Notlar

Dikkat

When using iterator_to_array() to copy the values of the AppendIterator into an array, you have to set the optional use_key argument to FALSE. When use_key is not FALSE any keys reoccuring in inner iterators will get overwritten in the returned array. There is no way to preserve the original keys.

Ayrıca Bakınız

  • AppendIterator::append() - Appends an iterator

AppendIterator::append
AppendIterator::current
AppendIterator


Gets the current value

AppendIterator::__construct
AppendIterator::getArrayIterator
AppendIterator
PHP Manual

AppendIterator::current

(PHP 5 >= 5.1.0, PHP 7)

AppendIterator::current — Gets the current value

Açıklama

public mixed AppendIterator::current ( void )

Gets the current value.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current value if it is valid or NULL otherwise.

Ayrıca Bakınız

  • Iterator::current() - O anki elemanı döndürür
  • AppendIterator::key() - Gets the current key
  • AppendIterator::valid() - Checks validity of the current element
  • AppendIterator::next() - Moves to the next element
  • AppendIterator::rewind() - Rewinds the Iterator

AppendIterator::__construct
AppendIterator::getArrayIterator
AppendIterator


Gets the ArrayIterator

AppendIterator::current
AppendIterator::getInnerIterator
AppendIterator
PHP Manual

AppendIterator::getArrayIterator

(PHP 5 >= 5.1.0, PHP 7)

AppendIterator::getArrayIterator — Gets the ArrayIterator

Açıklama

public ArrayIterator AppendIterator::getArrayIterator ( void )

This method gets the ArrayIterator that is used to store the iterators added with AppendIterator::append().

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an ArrayIterator containing the appended iterators.

Ayrıca Bakınız

  • AppendIterator::getInnerIterator() - Gets the inner iterator

AppendIterator::current
AppendIterator::getInnerIterator
AppendIterator


Gets the inner iterator

AppendIterator::getArrayIterator
AppendIterator::getIteratorIndex
AppendIterator
PHP Manual

AppendIterator::getInnerIterator

(PHP 5 >= 5.1.0, PHP 7)

AppendIterator::getInnerIterator — Gets the inner iterator

Açıklama

public Iterator AppendIterator::getInnerIterator ( void )

This method returns the current inner iterator.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current inner iterator, or NULL if there is not one.

Örnekler

Örnek 1 AppendIterator::getInnerIterator() example

<?php
$array_a = new ArrayIterator(array('a' => 'aardwolf', 'b' => 'bear', 'c' => 'capybara'));
$array_b = new RegexIterator($array_a, '/^[ac]/');

$iterator = new AppendIterator;
$iterator->append($array_a);
$iterator->append($array_b);

foreach ($iterator as $current) {
    $inner = $iterator->getInnerIterator();
    if ($inner instanceOf RegexIterator) {
        echo 'Filtered: ';
    } else {
        echo 'Original: ';
    }
    echo $current . PHP_EOL;
}
?>

Yukarıdaki örneğin çıktısı:

Original: aardwolf
Original: bear
Original: capybara
Filtered: aardwolf
Filtered: capybara

Ayrıca Bakınız

  • AppendIterator::getIteratorIndex() - Gets an index of iterators

AppendIterator::getArrayIterator
AppendIterator::getIteratorIndex
AppendIterator


Gets an index of iterators

AppendIterator::getInnerIterator
AppendIterator::key
AppendIterator
PHP Manual

AppendIterator::getIteratorIndex

(PHP 5 >= 5.1.0, PHP 7)

AppendIterator::getIteratorIndex — Gets an index of iterators

Açıklama

public int AppendIterator::getIteratorIndex ( void )

Gets the index of the current inner iterator.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an integer, which is the zero-based index of the current inner iterator.

Örnekler

Örnek 1 AppendIterator.getIteratorIndex() basic example

<?php
$array_a = new ArrayIterator(array('a' => 'aardwolf', 'b' => 'bear', 'c' => 'capybara'));
$array_b = new ArrayIterator(array('apple', 'orange', 'lemon'));

$iterator = new AppendIterator;
$iterator->append($array_a);
$iterator->append($array_b);

foreach ($iterator as $key => $current) {
    echo $iterator->getIteratorIndex() . '  ' . $key . ' ' . $current . PHP_EOL;
}
?>

Yukarıdaki örneğin çıktısı:

0  a aardwolf
0  b bear
0  c capybara
1  0 apple
1  1 orange
1  2 lemon

Ayrıca Bakınız

  • AppendIterator::getInnerIterator() - Gets the inner iterator
  • AppendIterator::getArrayIterator() - Gets the ArrayIterator

AppendIterator::getInnerIterator
AppendIterator::key
AppendIterator


Gets the current key

AppendIterator::getIteratorIndex
AppendIterator::next
AppendIterator
PHP Manual

AppendIterator::key

(PHP 5 >= 5.1.0, PHP 7)

AppendIterator::key — Gets the current key

Açıklama

public scalar AppendIterator::key ( void )

Get the current key.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current key if it is valid or NULL otherwise.

Örnekler

Örnek 1 AppendIterator::key() basic example

<?php
$array_a = new ArrayIterator(array('a' => 'aardwolf', 'b' => 'bear', 'c' => 'capybara'));
$array_b = new ArrayIterator(array('apple', 'orange', 'lemon'));

$iterator = new AppendIterator;
$iterator->append($array_a);
$iterator->append($array_b);

// Manual iteration
$iterator->rewind();
while ($iterator->valid()) {
    echo $iterator->key() . ' ' . $iterator->current() . PHP_EOL;
    $iterator->next();
}

echo PHP_EOL;

// With foreach
foreach ($iterator as $key => $current) {
    echo $key . ' ' . $current . PHP_EOL;
}
?>

Yukarıdaki örneğin çıktısı:

a aardwolf
b bear
c capybara
0 apple
1 orange
2 lemon

a aardwolf
b bear
c capybara
0 apple
1 orange
2 lemon

Ayrıca Bakınız

  • Iterator::key() - O anki elemanın anahtarını döndürür
  • AppendIterator::current() - Gets the current value
  • AppendIterator::valid() - Checks validity of the current element
  • AppendIterator::next() - Moves to the next element
  • AppendIterator::rewind() - Rewinds the Iterator

AppendIterator::getIteratorIndex
AppendIterator::next
AppendIterator


Moves to the next element

AppendIterator::key
AppendIterator::rewind
AppendIterator
PHP Manual

AppendIterator::next

(PHP 5 >= 5.1.0, PHP 7)

AppendIterator::next — Moves to the next element

Açıklama

public void AppendIterator::next ( void )

Moves to the next element. If this means to another Iterator then it rewinds that Iterator.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • Iterator::next() - Konumu sonraki elemana ilerletir
  • AppendIterator::current() - Gets the current value
  • AppendIterator::key() - Gets the current key
  • AppendIterator::valid() - Checks validity of the current element
  • AppendIterator::rewind() - Rewinds the Iterator

AppendIterator::key
AppendIterator::rewind
AppendIterator


Rewinds the Iterator

AppendIterator::next
AppendIterator::valid
AppendIterator
PHP Manual

AppendIterator::rewind

(PHP 5 >= 5.1.0, PHP 7)

AppendIterator::rewind — Rewinds the Iterator

Açıklama

public void AppendIterator::rewind ( void )

Rewind to the first element of the first inner Iterator.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • Iterator::rewind() - Yineleyiciyi ilk elemana konumlandırır
  • AppendIterator::current() - Gets the current value
  • AppendIterator::key() - Gets the current key
  • AppendIterator::next() - Moves to the next element
  • AppendIterator::valid() - Checks validity of the current element

AppendIterator::next
AppendIterator::valid
AppendIterator


Checks validity of the current element

AppendIterator::rewind
ArrayIterator
AppendIterator
PHP Manual

AppendIterator::valid

(PHP 5 >= 5.1.0, PHP 7)

AppendIterator::valid — Checks validity of the current element

Açıklama

public bool AppendIterator::valid ( void )

Checks validity of the current element.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the current iteration is valid, FALSE otherwise.

Ayrıca Bakınız

  • AppendIterator::current() - Gets the current value
  • AppendIterator::key() - Gets the current key
  • AppendIterator::next() - Moves to the next element
  • AppendIterator::rewind() - Rewinds the Iterator

AppendIterator::rewind
ArrayIterator
AppendIterator


The ArrayIterator class

(PHP 5, PHP 7)

Giriş

This iterator allows to unset and modify values and keys while iterating over Arrays and Objects.

When you want to iterate over the same array multiple times you need to instantiate ArrayObject and let it create ArrayIterator instances that refer to it either by using foreach or by calling its getIterator() method manually.

Sınıf Sözdizimi

ArrayIterator implements ArrayAccess , SeekableIterator , Countable , Serializable {
/* Yöntemler */
public void append ( mixed $value )
public void asort ( void )
public __construct ([ mixed $array = array() [, int $flags = 0 ]] )
public int count ( void )
public mixed current ( void )
public array getArrayCopy ( void )
public void getFlags ( void )
public mixed key ( void )
public void ksort ( void )
public void natcasesort ( void )
public void natsort ( void )
public void next ( void )
public void offsetExists ( string $index )
public mixed offsetGet ( string $index )
public void offsetSet ( string $index , string $newval )
public void offsetUnset ( string $index )
public void rewind ( void )
public void seek ( int $position )
public string serialize ( void )
public void setFlags ( string $flags )
public void uasort ( string $cmp_function )
public void uksort ( string $cmp_function )
public string unserialize ( string $serialized )
public bool valid ( void )
}

İçindekiler

  • ArrayIterator::append — Append an element
  • ArrayIterator::asort — Sort array by values
  • ArrayIterator::__construct — Construct an ArrayIterator
  • ArrayIterator::count — Count elements
  • ArrayIterator::current — Return current array entry
  • ArrayIterator::getArrayCopy — Get array copy
  • ArrayIterator::getFlags — Get flags
  • ArrayIterator::key — Return current array key
  • ArrayIterator::ksort — Sort array by keys
  • ArrayIterator::natcasesort — Sort an array naturally, case insensitive
  • ArrayIterator::natsort — Sort an array naturally
  • ArrayIterator::next — Move to next entry
  • ArrayIterator::offsetExists — Check if offset exists
  • ArrayIterator::offsetGet — Get value for an offset
  • ArrayIterator::offsetSet — Set value for an offset
  • ArrayIterator::offsetUnset — Unset value for an offset
  • ArrayIterator::rewind — Rewind array back to the start
  • ArrayIterator::seek — Seek to position
  • ArrayIterator::serialize — Serialize
  • ArrayIterator::setFlags — Set behaviour flags
  • ArrayIterator::uasort — User defined sort
  • ArrayIterator::uksort — User defined sort
  • ArrayIterator::unserialize — Unserialize
  • ArrayIterator::valid — Check whether array contains more entries
AppendIterator::valid
ArrayIterator::append
Iterators


Append an element

ArrayIterator
ArrayIterator::asort
ArrayIterator
PHP Manual

ArrayIterator::append

(PHP 5 >= 5.0.0, PHP 7)

ArrayIterator::append — Append an element

Açıklama

public void ArrayIterator::append ( mixed $value )

Appends value as the last element.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

value

The value to append.

Dönen Değerler

Hiçbir değer dönmez.

Notlar

Bilginize:

This method cannot be called when the ArrayIterator refers to an object.

Ayrıca Bakınız

  • ArrayIterator::next() - Move to next entry

ArrayIterator
ArrayIterator::asort
ArrayIterator


Sort array by values

ArrayIterator::append
ArrayIterator::__construct
ArrayIterator
PHP Manual

ArrayIterator::asort

(PHP 5 >= 5.2.0, PHP 7)

ArrayIterator::asort — Sort array by values

Açıklama

public void ArrayIterator::asort ( void )

Sorts an array by values.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • ArrayIterator::ksort() - Sort array by keys
  • ArrayIterator::natcasesort() - Sort an array naturally, case insensitive
  • ArrayIterator::natsort() - Sort an array naturally

ArrayIterator::append
ArrayIterator::__construct
ArrayIterator


Construct an ArrayIterator

ArrayIterator::asort
ArrayIterator::count
ArrayIterator
PHP Manual

ArrayIterator::__construct

(PHP 5 >= 5.0.0, PHP 7)

ArrayIterator::__construct — Construct an ArrayIterator

Açıklama

public ArrayIterator::__construct ([ mixed $array = array() [, int $flags = 0 ]] )

Constructs an ArrayIterator object.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

array

The array or object to be iterated on.

flags

Flags to control the behaviour of the ArrayIterator object. See ArrayIterator::setFlags().

Dönen Değerler

An ArrayIterator object.

Hatalar/İstisnalar

ArrayIterator::__construct() throws an InvalidArgumentException if anything besides an array or an object is given.

Ayrıca Bakınız

  • ArrayIterator::getArrayCopy() - Get array copy

ArrayIterator::asort
ArrayIterator::count
ArrayIterator


Count elements

ArrayIterator::__construct
ArrayIterator::current
ArrayIterator
PHP Manual

ArrayIterator::count

(PHP 5 >= 5.0.0, PHP 7)

ArrayIterator::count — Count elements

Açıklama

public int ArrayIterator::count ( void )

Gets the number of elements in the array, or the number of public properties in the object.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The number of elements or public properties in the associated array or object, respectively.

Ayrıca Bakınız

  • ArrayIterator::getFlags() - Get flags

ArrayIterator::__construct
ArrayIterator::current
ArrayIterator


Return current array entry

ArrayIterator::count
ArrayIterator::getArrayCopy
ArrayIterator
PHP Manual

ArrayIterator::current

(PHP 5 >= 5.0.0, PHP 7)

ArrayIterator::current — Return current array entry

Açıklama

public mixed ArrayIterator::current ( void )

Get the current array entry.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current array entry.

Örnekler

Örnek 1 ArrayIterator::current() example

<?php
$array = array('1' => 'one',
               '2' => 'two',
               '3' => 'three');

$arrayobject = new ArrayObject($array);

for($iterator = $arrayobject->getIterator();
    $iterator->valid();
    $iterator->next()) {

    echo $iterator->key() . ' => ' . $iterator->current() . "\n";
}
?>

Yukarıdaki örneğin çıktısı:

1 => one
2 => two
3 => three

ArrayIterator::count
ArrayIterator::getArrayCopy
ArrayIterator


Get array copy

ArrayIterator::current
ArrayIterator::getFlags
ArrayIterator
PHP Manual

ArrayIterator::getArrayCopy

(PHP 5 >= 5.0.0, PHP 7)

ArrayIterator::getArrayCopy — Get array copy

Açıklama

public array ArrayIterator::getArrayCopy ( void )

Get a copy of an array.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A copy of the array, or array of public properties if ArrayIterator refers to an object.

Ayrıca Bakınız

  • ArrayIterator::valid() - Check whether array contains more entries

ArrayIterator::current
ArrayIterator::getFlags
ArrayIterator


Get flags

ArrayIterator::getArrayCopy
ArrayIterator::key
ArrayIterator
PHP Manual

ArrayIterator::getFlags

(PHP 5 >= 5.1.0, PHP 7)

ArrayIterator::getFlags — Get flags

Açıklama

public void ArrayIterator::getFlags ( void )

Get the current flags.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current flags.

Ayrıca Bakınız

  • ArrayIterator::valid() - Check whether array contains more entries

ArrayIterator::getArrayCopy
ArrayIterator::key
ArrayIterator


Return current array key

ArrayIterator::getFlags
ArrayIterator::ksort
ArrayIterator
PHP Manual

ArrayIterator::key

(PHP 5 >= 5.0.0, PHP 7)

ArrayIterator::key — Return current array key

Açıklama

public mixed ArrayIterator::key ( void )

This function returns the current array key

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current array key.

Örnekler

Örnek 1 ArrayIterator::key() example

<?php
$array = array('key' => 'value');

$arrayobject = new ArrayObject($array);
$iterator = $arrayobject->getIterator();

echo $iterator->key(); //key
?>

ArrayIterator::getFlags
ArrayIterator::ksort
ArrayIterator


Sort array by keys

ArrayIterator::key
ArrayIterator::natcasesort
ArrayIterator
PHP Manual

ArrayIterator::ksort

(PHP 5 >= 5.2.0, PHP 7)

ArrayIterator::ksort — Sort array by keys

Açıklama

public void ArrayIterator::ksort ( void )

Sorts an array by the keys.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • ArrayIterator::asort() - Sort array by values
  • ArrayIterator::natcasesort() - Sort an array naturally, case insensitive
  • ArrayIterator::natsort() - Sort an array naturally

ArrayIterator::key
ArrayIterator::natcasesort
ArrayIterator


Sort an array naturally, case insensitive

ArrayIterator::ksort
ArrayIterator::natsort
ArrayIterator
PHP Manual

ArrayIterator::natcasesort

(PHP 5 >= 5.2.0, PHP 7)

ArrayIterator::natcasesort — Sort an array naturally, case insensitive

Açıklama

public void ArrayIterator::natcasesort ( void )

Sort the entries by values using a case insensitive "natural order" algorithm.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • ArrayIterator::asort() - Sort array by values
  • ArrayIterator::ksort() - Sort array by keys
  • ArrayIterator::natsort() - Sort an array naturally
  • natcasesort() - Bir diziyi harf büyüklüğüne duyarsız "doğal sıralama" algoritmasıyla sıralar

ArrayIterator::ksort
ArrayIterator::natsort
ArrayIterator


Sort an array naturally

ArrayIterator::natcasesort
ArrayIterator::next
ArrayIterator
PHP Manual

ArrayIterator::natsort

(PHP 5 >= 5.2.0, PHP 7)

ArrayIterator::natsort — Sort an array naturally

Açıklama

public void ArrayIterator::natsort ( void )

Sort the entries by values using "natural order" algorithm.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • ArrayIterator::asort() - Sort array by values
  • ArrayIterator::ksort() - Sort array by keys
  • ArrayIterator::natcasesort() - Sort an array naturally, case insensitive
  • natsort() - Bir diziyi "doğal sıralama" algoritmasıyla sıralar

ArrayIterator::natcasesort
ArrayIterator::next
ArrayIterator


Move to next entry

ArrayIterator::natsort
ArrayIterator::offsetExists
ArrayIterator
PHP Manual

ArrayIterator::next

(PHP 5 >= 5.0.0, PHP 7)

ArrayIterator::next — Move to next entry

Açıklama

public void ArrayIterator::next ( void )

The iterator to the next entry.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 ArrayIterator::next() example

<?php
$arrayobject = new ArrayObject();

$arrayobject[] = 'zero';
$arrayobject[] = 'one';

$iterator = $arrayobject->getIterator();

while($iterator->valid()) {
    echo $iterator->key() . ' => ' . $iterator->current() . "\n";

    $iterator->next();
}
?>

Yukarıdaki örneğin çıktısı:

0 => zero
1 => one

ArrayIterator::natsort
ArrayIterator::offsetExists
ArrayIterator


Check if offset exists

ArrayIterator::next
ArrayIterator::offsetGet
ArrayIterator
PHP Manual

ArrayIterator::offsetExists

(PHP 5 >= 5.0.0, PHP 7)

ArrayIterator::offsetExists — Check if offset exists

Açıklama

public void ArrayIterator::offsetExists ( string $index )

Checks if the offset exists.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

index

The offset being checked.

Dönen Değerler

TRUE if the offset exists, otherwise FALSE

Ayrıca Bakınız

  • ArrayIterator::valid() - Check whether array contains more entries

ArrayIterator::next
ArrayIterator::offsetGet
ArrayIterator


Get value for an offset

ArrayIterator::offsetExists
ArrayIterator::offsetSet
ArrayIterator
PHP Manual

ArrayIterator::offsetGet

(PHP 5 >= 5.0.0, PHP 7)

ArrayIterator::offsetGet — Get value for an offset

Açıklama

public mixed ArrayIterator::offsetGet ( string $index )

Gets the value from the provided offset.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

index

The offset to get the value from.

Dönen Değerler

The value at offset index.

Ayrıca Bakınız

  • ArrayIterator::offsetSet() - Set value for an offset
  • ArrayIterator::offsetUnset() - Unset value for an offset

ArrayIterator::offsetExists
ArrayIterator::offsetSet
ArrayIterator


Set value for an offset

ArrayIterator::offsetGet
ArrayIterator::offsetUnset
ArrayIterator
PHP Manual

ArrayIterator::offsetSet

(PHP 5 >= 5.0.0, PHP 7)

ArrayIterator::offsetSet — Set value for an offset

Açıklama

public void ArrayIterator::offsetSet ( string $index , string $newval )

Sets a value for a given offset.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

index

The index to set for.

newval

The new value to store at the index.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • ArrayIterator::offsetGet() - Get value for an offset
  • ArrayIterator::offsetUnset() - Unset value for an offset

ArrayIterator::offsetGet
ArrayIterator::offsetUnset
ArrayIterator


Unset value for an offset

ArrayIterator::offsetSet
ArrayIterator::rewind
ArrayIterator
PHP Manual

ArrayIterator::offsetUnset

(PHP 5 >= 5.0.0, PHP 7)

ArrayIterator::offsetUnset — Unset value for an offset

Açıklama

public void ArrayIterator::offsetUnset ( string $index )

Unsets a value for an offset.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

index

The offset to unset.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • ArrayIterator::offsetGet() - Get value for an offset
  • ArrayIterator::offsetSet() - Set value for an offset

ArrayIterator::offsetSet
ArrayIterator::rewind
ArrayIterator


Rewind array back to the start

ArrayIterator::offsetUnset
ArrayIterator::seek
ArrayIterator
PHP Manual

ArrayIterator::rewind

(PHP 5 >= 5.0.0, PHP 7)

ArrayIterator::rewind — Rewind array back to the start

Açıklama

public void ArrayIterator::rewind ( void )

This rewinds the iterator to the beginning.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 ArrayIterator::rewind() example

<?php
$arrayobject = new ArrayObject();

$arrayobject[] = 'zero';
$arrayobject[] = 'one';
$arrayobject[] = 'two';

$iterator = $arrayobject->getIterator();

$iterator->next();
echo $iterator->key(); //1

$iterator->rewind(); //rewinding to the begining
echo $iterator->key(); //0
?>

ArrayIterator::offsetUnset
ArrayIterator::seek
ArrayIterator


Seek to position

ArrayIterator::rewind
ArrayIterator::serialize
ArrayIterator
PHP Manual

ArrayIterator::seek

(PHP 5 >= 5.0.0, PHP 7)

ArrayIterator::seek — Seek to position

Açıklama

public void ArrayIterator::seek ( int $position )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

position

The position to seek to.

Dönen Değerler

Hiçbir değer dönmez.

ArrayIterator::rewind
ArrayIterator::serialize
ArrayIterator


Serialize

ArrayIterator::seek
ArrayIterator::setFlags
ArrayIterator
PHP Manual

ArrayIterator::serialize

(PHP 5 >= 5.3.0, PHP 7)

ArrayIterator::serialize — Serialize

Açıklama

public string ArrayIterator::serialize ( void )

Serialize.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The serialized ArrayIterator.

Ayrıca Bakınız

  • ArrayIterator::unserialize() - Unserialize

ArrayIterator::seek
ArrayIterator::setFlags
ArrayIterator


Set behaviour flags

ArrayIterator::serialize
ArrayIterator::uasort
ArrayIterator
PHP Manual

ArrayIterator::setFlags

(PHP 5 >= 5.1.0, PHP 7)

ArrayIterator::setFlags — Set behaviour flags

Açıklama

public void ArrayIterator::setFlags ( string $flags )

Sets behaviour flags.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

flags

A bitmask as follows:

  • 0 = Properties of the object have their normal functionality when accessed as list (var_dump, foreach, etc.).
  • 1 = Array indices can be accessed as properties in read/write.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • ArrayIterator::getFlags() - Get flags

ArrayIterator::serialize
ArrayIterator::uasort
ArrayIterator


User defined sort

ArrayIterator::setFlags
ArrayIterator::uksort
ArrayIterator
PHP Manual

ArrayIterator::uasort

(PHP 5 >= 5.2.0, PHP 7)

ArrayIterator::uasort — User defined sort

Açıklama

public void ArrayIterator::uasort ( string $cmp_function )

Sort the entries by values using user defined function.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

cmp_function

The compare function used for the sort.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • ArrayIterator::uksort() - User defined sort
  • usort() - Bir diziyi kullanıcı tanımlı bir işlev kullanarak değerlerine göre sıralar

ArrayIterator::setFlags
ArrayIterator::uksort
ArrayIterator


User defined sort

ArrayIterator::uasort
ArrayIterator::unserialize
ArrayIterator
PHP Manual

ArrayIterator::uksort

(PHP 5 >= 5.2.0, PHP 7)

ArrayIterator::uksort — User defined sort

Açıklama

public void ArrayIterator::uksort ( string $cmp_function )

Sort the entries by key using user defined function.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

cmp_function

The compare function used for the sort.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • ArrayIterator::uasort() - User defined sort
  • uksort() - Bir diziyi kullanıcı tanımlı bir işlev kullanarak anahtarlarına göre sıralar

ArrayIterator::uasort
ArrayIterator::unserialize
ArrayIterator


Unserialize

ArrayIterator::uksort
ArrayIterator::valid
ArrayIterator
PHP Manual

ArrayIterator::unserialize

(PHP 5 >= 5.3.0, PHP 7)

ArrayIterator::unserialize — Unserialize

Açıklama

public string ArrayIterator::unserialize ( string $serialized )

Unserialize.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

serialized

The serialized ArrayIterator object to be unserialized.

Dönen Değerler

The ArrayIterator.

Ayrıca Bakınız

  • ArrayIterator::serialize() - Serialize

ArrayIterator::uksort
ArrayIterator::valid
ArrayIterator


Check whether array contains more entries

ArrayIterator::unserialize
CachingIterator
ArrayIterator
PHP Manual

ArrayIterator::valid

(PHP 5 >= 5.0.0, PHP 7)

ArrayIterator::valid — Check whether array contains more entries

Açıklama

public bool ArrayIterator::valid ( void )

Checks if the array contains any more entries.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the iterator is valid, otherwise FALSE

Örnekler

Örnek 1 ArrayIterator::valid() example

<?php
$array = array('1' => 'one');

$arrayobject = new ArrayObject($array);
$iterator = $arrayobject->getIterator();

var_dump($iterator->valid()); //bool(true)

$iterator->next(); // advance to the next item

//bool(false) because there is only one array element
var_dump($iterator->valid());
?>

ArrayIterator::unserialize
CachingIterator
ArrayIterator


The CachingIterator class

(PHP 5, PHP 7)

Giriş

This object supports cached iteration over another iterator.

Sınıf Sözdizimi

CachingIterator extends IteratorIterator implements OuterIterator , ArrayAccess , Countable {
/* Sabitler */
const integer CALL_TOSTRING = 1 ;
const integer CATCH_GET_CHILD = 16 ;
const integer TOSTRING_USE_KEY = 2 ;
const integer TOSTRING_USE_CURRENT = 4 ;
const integer TOSTRING_USE_INNER = 8 ;
const integer FULL_CACHE = 256 ;
/* Yöntemler */
public __construct ( Iterator $iterator [, int $flags = self::CALL_TOSTRING ] )
public int count ( void )
public void current ( void )
public array getCache ( void )
public int getFlags ( void )
public Iterator getInnerIterator ( void )
public void hasNext ( void )
public scalar key ( void )
public void next ( void )
public void offsetExists ( string $index )
public void offsetGet ( string $index )
public void offsetSet ( string $index , string $newval )
public void offsetUnset ( string $index )
public void rewind ( void )
public void setFlags ( int $flags )
public void __toString ( void )
public void valid ( void )
}

Öntanımlı Sabitler

CachingIterator::CALL_TOSTRING

Convert every element to string.

CachingIterator::CATCH_GET_CHILD

Don't throw exception in accessing children.

CachingIterator::TOSTRING_USE_KEY

Use key for conversion to string.

CachingIterator::TOSTRING_USE_CURRENT

Use current for conversion to string.

CachingIterator::TOSTRING_USE_INNER

Use inner for conversion to string.

CachingIterator::FULL_CACHE

Cache all read data.

İçindekiler

  • CachingIterator::__construct — Construct a new CachingIterator object for the iterator.
  • CachingIterator::count — The number of elements in the iterator
  • CachingIterator::current — Return the current element
  • CachingIterator::getCache — Retrieve the contents of the cache
  • CachingIterator::getFlags — Get flags used
  • CachingIterator::getInnerIterator — Returns the inner iterator
  • CachingIterator::hasNext — Check whether the inner iterator has a valid next element
  • CachingIterator::key — Return the key for the current element
  • CachingIterator::next — Move the iterator forward
  • CachingIterator::offsetExists — The offsetExists purpose
  • CachingIterator::offsetGet — The offsetGet purpose
  • CachingIterator::offsetSet — The offsetSet purpose
  • CachingIterator::offsetUnset — The offsetUnset purpose
  • CachingIterator::rewind — Rewind the iterator
  • CachingIterator::setFlags — The setFlags purpose
  • CachingIterator::__toString — Return the string representation of the current element
  • CachingIterator::valid — Check whether the current element is valid
ArrayIterator::valid
CachingIterator::__construct
Iterators


Construct a new CachingIterator object for the iterator.

CachingIterator
CachingIterator::count
CachingIterator
PHP Manual

CachingIterator::__construct

(PHP 5, PHP 7)

CachingIterator::__construct — Construct a new CachingIterator object for the iterator.

Açıklama

public CachingIterator::__construct ( Iterator $iterator [, int $flags = self::CALL_TOSTRING ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

iterator

Iterator to cache

flags

Bitmask of flags.

CachingIterator
CachingIterator::count
CachingIterator


The number of elements in the iterator

CachingIterator::__construct
CachingIterator::current
CachingIterator
PHP Manual

CachingIterator::count

(PHP 5 >= 5.2.2, PHP 7)

CachingIterator::count — The number of elements in the iterator

Açıklama

public int CachingIterator::count ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

May return the number of elements in the iterator.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The count of the elements iterated over.

CachingIterator::__construct
CachingIterator::current
CachingIterator


Return the current element

CachingIterator::count
CachingIterator::getCache
CachingIterator
PHP Manual

CachingIterator::current

(PHP 5, PHP 7)

CachingIterator::current — Return the current element

Açıklama

public void CachingIterator::current ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

May return the current element in the iteration.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Mixed

Ayrıca Bakınız

  • Iterator::current() - O anki elemanı döndürür

CachingIterator::count
CachingIterator::getCache
CachingIterator


Retrieve the contents of the cache

CachingIterator::current
CachingIterator::getFlags
CachingIterator
PHP Manual

CachingIterator::getCache

(PHP 5 >= 5.2.0, PHP 7)

CachingIterator::getCache — Retrieve the contents of the cache

Açıklama

public array CachingIterator::getCache ( void )

Retrieve the contents of the cache.

Bilginize:

The CachingIterator::FULL_CACHE flag must be being used.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

An array containing the cache items.

Hatalar/İstisnalar

Throws a BadMethodCallException when the CachingIterator::FULL_CACHE flag is not being used.

Örnekler

Örnek 1 CachingIterator::getCache() example

<?php
$iterator = new ArrayIterator(array(1, 2, 3));
$cache    = new CachingIterator($iterator, CachingIterator::FULL_CACHE);

$cache->next();
$cache->next();
var_dump($cache->getCache());

$cache->next();
var_dump($cache->getCache());
?>

Yukarıdaki örneğin çıktısı:

array(2) {
  [0]=>
  int(1)
  [1]=>
  int(2)
}
array(3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}

CachingIterator::current
CachingIterator::getFlags
CachingIterator


Get flags used

CachingIterator::getCache
CachingIterator::getInnerIterator
CachingIterator
PHP Manual

CachingIterator::getFlags

(PHP 5 >= 5.2.0, PHP 7)

CachingIterator::getFlags — Get flags used

Açıklama

public int CachingIterator::getFlags ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Get the bitmask of the flags used for this CachingIterator instance.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Description...

CachingIterator::getCache
CachingIterator::getInnerIterator
CachingIterator


Returns the inner iterator

CachingIterator::getFlags
CachingIterator::hasNext
CachingIterator
PHP Manual

CachingIterator::getInnerIterator

(PHP 5, PHP 7)

CachingIterator::getInnerIterator — Returns the inner iterator

Açıklama

public Iterator CachingIterator::getInnerIterator ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Returns the iterator sent to the constructor.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an object implementing the Iterator interface.

CachingIterator::getFlags
CachingIterator::hasNext
CachingIterator


Check whether the inner iterator has a valid next element

CachingIterator::getInnerIterator
CachingIterator::key
CachingIterator
PHP Manual

CachingIterator::hasNext

(PHP 5, PHP 7)

CachingIterator::hasNext — Check whether the inner iterator has a valid next element

Açıklama

public void CachingIterator::hasNext ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

CachingIterator::getInnerIterator
CachingIterator::key
CachingIterator


Return the key for the current element

CachingIterator::hasNext
CachingIterator::next
CachingIterator
PHP Manual

CachingIterator::key

(PHP 5, PHP 7)

CachingIterator::key — Return the key for the current element

Açıklama

public scalar CachingIterator::key ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

This method may return a key for the current element.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

CachingIterator::hasNext
CachingIterator::next
CachingIterator


Move the iterator forward

CachingIterator::key
CachingIterator::offsetExists
CachingIterator
PHP Manual

CachingIterator::next

(PHP 5, PHP 7)

CachingIterator::next — Move the iterator forward

Açıklama

public void CachingIterator::next ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Move the iterator forward.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

CachingIterator::key
CachingIterator::offsetExists
CachingIterator


The offsetExists purpose

CachingIterator::next
CachingIterator::offsetGet
CachingIterator
PHP Manual

CachingIterator::offsetExists

(PHP 5 >= 5.2.0, PHP 7)

CachingIterator::offsetExists — The offsetExists purpose

Açıklama

public void CachingIterator::offsetExists ( string $index )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

index

The index being checked.

Dönen Değerler

Returns TRUE if an entry referenced by the offset exists, FALSE otherwise.

CachingIterator::next
CachingIterator::offsetGet
CachingIterator


The offsetGet purpose

CachingIterator::offsetExists
CachingIterator::offsetSet
CachingIterator
PHP Manual

CachingIterator::offsetGet

(PHP 5 >= 5.2.0, PHP 7)

CachingIterator::offsetGet — The offsetGet purpose

Açıklama

public void CachingIterator::offsetGet ( string $index )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

index

Description...

Dönen Değerler

Description...

CachingIterator::offsetExists
CachingIterator::offsetSet
CachingIterator


The offsetSet purpose

CachingIterator::offsetGet
CachingIterator::offsetUnset
CachingIterator
PHP Manual

CachingIterator::offsetSet

(PHP 5 >= 5.2.0, PHP 7)

CachingIterator::offsetSet — The offsetSet purpose

Açıklama

public void CachingIterator::offsetSet ( string $index , string $newval )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

index

The index of the element to be set.

newval

The new value for the index.

Dönen Değerler

Hiçbir değer dönmez.

CachingIterator::offsetGet
CachingIterator::offsetUnset
CachingIterator


The offsetUnset purpose

CachingIterator::offsetSet
CachingIterator::rewind
CachingIterator
PHP Manual

CachingIterator::offsetUnset

(PHP 5 >= 5.2.0, PHP 7)

CachingIterator::offsetUnset — The offsetUnset purpose

Açıklama

public void CachingIterator::offsetUnset ( string $index )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

index

The index of the element to be unset.

Dönen Değerler

Hiçbir değer dönmez.

CachingIterator::offsetSet
CachingIterator::rewind
CachingIterator


Rewind the iterator

CachingIterator::offsetUnset
CachingIterator::setFlags
CachingIterator
PHP Manual

CachingIterator::rewind

(PHP 5, PHP 7)

CachingIterator::rewind — Rewind the iterator

Açıklama

public void CachingIterator::rewind ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Rewind the iterator.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

CachingIterator::offsetUnset
CachingIterator::setFlags
CachingIterator


The setFlags purpose

CachingIterator::rewind
CachingIterator::__toString
CachingIterator
PHP Manual

CachingIterator::setFlags

(PHP 5 >= 5.2.0, PHP 7)

CachingIterator::setFlags — The setFlags purpose

Açıklama

public void CachingIterator::setFlags ( int $flags )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Set the flags for the CachingIterator object.

Değiştirgeler

flags

Bitmask of the flags to set.

Dönen Değerler

Hiçbir değer dönmez.

CachingIterator::rewind
CachingIterator::__toString
CachingIterator


Return the string representation of the current element

CachingIterator::setFlags
CachingIterator::valid
CachingIterator
PHP Manual

CachingIterator::__toString

(PHP 5, PHP 7)

CachingIterator::__toString — Return the string representation of the current element

Açıklama

public void CachingIterator::__toString ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Get the string representation of the current element.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The string representation of the current element.

CachingIterator::setFlags
CachingIterator::valid
CachingIterator


Check whether the current element is valid

CachingIterator::__toString
CallbackFilterIterator
CachingIterator
PHP Manual

CachingIterator::valid

(PHP 5, PHP 7)

CachingIterator::valid — Check whether the current element is valid

Açıklama

public void CachingIterator::valid ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Check whether the current element is valid.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

CachingIterator::__toString
CallbackFilterIterator
CachingIterator


The CallbackFilterIterator class

(PHP 5 >= 5.4.0, PHP 7)

Giriş

Sınıf Sözdizimi

CallbackFilterIterator extends FilterIterator implements OuterIterator {
/* Yöntemler */
public __construct ( Iterator $iterator , callable $callback )
public string accept ( void )
/* Miras alınan yöntemler */
public abstract bool FilterIterator::accept ( void )
public FilterIterator::__construct ( Iterator $iterator )
public mixed FilterIterator::current ( void )
public Iterator FilterIterator::getInnerIterator ( void )
public mixed FilterIterator::key ( void )
public void FilterIterator::next ( void )
public void FilterIterator::rewind ( void )
public bool FilterIterator::valid ( void )
}

Örnekler

The callback should accept up to three arguments: the current item, the current key and the iterator, respectively.

Örnek 1 Available callback arguments

<?php

/**
 * Callback for CallbackFilterIterator
 *
 * @param $current   Current item's value
 * @param $key       Current item's key
 * @param $iterator  Iterator being filtered
 * @return boolean   TRUE to accept the current item, FALSE otherwise
 */
function my_callback($current, $key, $iterator) {
    // Your filtering code here
}

?>

Any callable may be used; such as a string containing a function name, an array for a method, or an anonymous function.

Örnek 2 Callback basic examples

<?php

$dir = new FilesystemIterator(__DIR__);

// Filter large files ( > 100MB)
function is_large_file($current) {
    return $current->isFile() && $current->getSize() > 104857600;
}
$large_files = new CallbackFilterIterator($dir, 'is_large_file');

// Filter directories
$files = new CallbackFilterIterator($dir, function ($current, $key, $iterator) {
    return $current->isDir() && ! $iterator->isDot();
});

?>

İçindekiler

  • CallbackFilterIterator::accept — Calls the callback with the current value, the current key and the inner iterator as arguments
  • CallbackFilterIterator::__construct — Create a filtered iterator from another iterator
CachingIterator::valid
CallbackFilterIterator::accept
Iterators


Calls the callback with the current value, the current key and the inner iterator as arguments

CallbackFilterIterator
CallbackFilterIterator::__construct
CallbackFilterIterator
PHP Manual

CallbackFilterIterator::accept

(PHP 5 >= 5.4.0, PHP 7)

CallbackFilterIterator::accept — Calls the callback with the current value, the current key and the inner iterator as arguments

Açıklama

public string CallbackFilterIterator::accept ( void )

This method calls the callback with the current value, current key and the inner iterator.

The callback is expected to return TRUE if the current item is to be accepted, or FALSE otherwise.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE to accept the current item, or FALSE otherwise.

Ayrıca Bakınız

  • CallbackFilterIterator Examples
  • CallbackFilterIterator::__construct() - Create a filtered iterator from another iterator

CallbackFilterIterator
CallbackFilterIterator::__construct
CallbackFilterIterator


Create a filtered iterator from another iterator

CallbackFilterIterator::accept
DirectoryIterator
CallbackFilterIterator
PHP Manual

CallbackFilterIterator::__construct

(PHP 5 >= 5.4.0, PHP 7)

CallbackFilterIterator::__construct — Create a filtered iterator from another iterator

Açıklama

public CallbackFilterIterator::__construct ( Iterator $iterator , callable $callback )

Creates a filtered iterator using the callback to determine which items are accepted or rejected.

Değiştirgeler

iterator

The iterator to be filtered.

callback

The callback, which should return TRUE to accept the current item or FALSE otherwise. See Examples.

May be any valid callable value.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • CallbackFilterIterator Examples
  • CallbackFilterIterator::accept() - Calls the callback with the current value, the current key and the inner iterator as arguments

CallbackFilterIterator::accept
DirectoryIterator
CallbackFilterIterator


The DirectoryIterator class

(PHP 5, PHP 7)

Giriş

The DirectoryIterator class provides a simple interface for viewing the contents of filesystem directories.

Sınıf Sözdizimi

DirectoryIterator extends SplFileInfo implements SeekableIterator {
/* Yöntemler */
public __construct ( string $path )
public DirectoryIterator current ( void )
public int getATime ( void )
public string getBasename ([ string $suffix ] )
public int getCTime ( void )
public string getExtension ( void )
public string getFilename ( void )
public int getGroup ( void )
public int getInode ( void )
public int getMTime ( void )
public int getOwner ( void )
public string getPath ( void )
public string getPathname ( void )
public int getPerms ( void )
public int getSize ( void )
public string getType ( void )
public bool isDir ( void )
public bool isDot ( void )
public bool isExecutable ( void )
public bool isFile ( void )
public bool isLink ( void )
public bool isReadable ( void )
public bool isWritable ( void )
public string key ( void )
public void next ( void )
public void rewind ( void )
public void seek ( int $position )
public string __toString ( void )
public bool valid ( void )
}

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.2 | DirectoryIterator extends SplFileInfo.

İçindekiler

  • DirectoryIterator::__construct — Constructs a new directory iterator from a path
  • DirectoryIterator::current — Return the current DirectoryIterator item.
  • DirectoryIterator::getATime — Get last access time of the current DirectoryIterator item
  • DirectoryIterator::getBasename — Get base name of current DirectoryIterator item.
  • DirectoryIterator::getCTime — Get inode change time of the current DirectoryIterator item
  • DirectoryIterator::getExtension — Gets the file extension
  • DirectoryIterator::getFilename — Return file name of current DirectoryIterator item.
  • DirectoryIterator::getGroup — Get group for the current DirectoryIterator item
  • DirectoryIterator::getInode — Get inode for the current DirectoryIterator item
  • DirectoryIterator::getMTime — Get last modification time of current DirectoryIterator item
  • DirectoryIterator::getOwner — Get owner of current DirectoryIterator item
  • DirectoryIterator::getPath — Get path of current Iterator item without filename
  • DirectoryIterator::getPathname — Return path and file name of current DirectoryIterator item
  • DirectoryIterator::getPerms — Get the permissions of current DirectoryIterator item
  • DirectoryIterator::getSize — Get size of current DirectoryIterator item
  • DirectoryIterator::getType — Determine the type of the current DirectoryIterator item
  • DirectoryIterator::isDir — Determine if current DirectoryIterator item is a directory
  • DirectoryIterator::isDot — Determine if current DirectoryIterator item is '.' or '..'
  • DirectoryIterator::isExecutable — Determine if current DirectoryIterator item is executable
  • DirectoryIterator::isFile — Determine if current DirectoryIterator item is a regular file
  • DirectoryIterator::isLink — Determine if current DirectoryIterator item is a symbolic link
  • DirectoryIterator::isReadable — Determine if current DirectoryIterator item can be read
  • DirectoryIterator::isWritable — Determine if current DirectoryIterator item can be written to
  • DirectoryIterator::key — Return the key for the current DirectoryIterator item
  • DirectoryIterator::next — Move forward to next DirectoryIterator item
  • DirectoryIterator::rewind — Rewind the DirectoryIterator back to the start
  • DirectoryIterator::seek — Seek to a DirectoryIterator item
  • DirectoryIterator::__toString — Get file name as a string
  • DirectoryIterator::valid — Check whether current DirectoryIterator position is a valid file
CallbackFilterIterator::__construct
DirectoryIterator::__construct
Iterators


Constructs a new directory iterator from a path

DirectoryIterator
DirectoryIterator::current
DirectoryIterator
PHP Manual

DirectoryIterator::__construct

(PHP 5, PHP 7)

DirectoryIterator::__construct — Constructs a new directory iterator from a path

Açıklama

public DirectoryIterator::__construct ( string $path )

Constructs a new directory iterator from a path.

Değiştirgeler

path

The path of the directory to traverse.

Hatalar/İstisnalar

Throws an UnexpectedValueException if the path cannot be opened.

Throws a RuntimeException if the path is an empty string.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | Throws UnexpectedValueException if the path cannot be opened.
5.1.3 | Throws RuntimeException if the path is an empty string.
5.1.0 | Throws RuntimeException on error. Previously, threw Exception.

Örnekler

Örnek 1 A DirectoryIterator::__construct() example

This example will list the contents of the directory containing the script.

<?php
$dir = new DirectoryIterator(dirname(__FILE__));
foreach ($dir as $fileinfo) {
    if (!$fileinfo->isDot()) {
        var_dump($fileinfo->getFilename());
    }
}
?>

Ayrıca Bakınız

  • SplFileInfo
  • Iterator

DirectoryIterator
DirectoryIterator::current
DirectoryIterator


Return the current DirectoryIterator item.

DirectoryIterator::__construct
DirectoryIterator::getATime
DirectoryIterator
PHP Manual

DirectoryIterator::current

(PHP 5, PHP 7)

DirectoryIterator::current — Return the current DirectoryIterator item.

Açıklama

public DirectoryIterator DirectoryIterator::current ( void )

Get the current DirectoryIterator item.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current DirectoryIterator item.

Örnekler

Örnek 1 A DirectoryIterator::current() example

This example will list the contents of the directory containing the script.

<?php
$iterator = new DirectoryIterator(__DIR__);
while($iterator->valid()) {
    $file = $iterator->current();
    echo $iterator->key() . " => " . $file->getFilename() . "\n";
    $iterator->next();
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

0 => .
1 => ..
2 => apple.jpg
3 => banana.jpg
4 => index.php
5 => pear.jpg

Ayrıca Bakınız

  • DirectoryIterator::key() - Return the key for the current DirectoryIterator item
  • DirectoryIterator::next() - Move forward to next DirectoryIterator item
  • DirectoryIterator::rewind() - Rewind the DirectoryIterator back to the start
  • DirectoryIterator::valid() - Check whether current DirectoryIterator position is a valid file
  • Iterator::current() - O anki elemanı döndürür

DirectoryIterator::__construct
DirectoryIterator::getATime
DirectoryIterator


Get last access time of the current DirectoryIterator item

DirectoryIterator::current
DirectoryIterator::getBasename
DirectoryIterator
PHP Manual

DirectoryIterator::getATime

(PHP 5, PHP 7)

DirectoryIterator::getATime — Get last access time of the current DirectoryIterator item

Açıklama

public int DirectoryIterator::getATime ( void )

Get the last access time of the current DirectoryIterator item.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the time the file was last accessed, as a Unix timestamp.

Örnekler

Örnek 1 A DirectoryIterator::getATime() example

Displays a list of the files in the directory of the script and their last access times.

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
foreach ($iterator as $fileinfo) {
    if ($fileinfo->isFile()) {
        echo $fileinfo->getFilename() . " " . $fileinfo->getATime() . "\n";
    }
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

apple.jpg 1240047118
banana.jpg 1240065176
index.php 1240047208
pear.jpg 12240047979

Ayrıca Bakınız

  • DirectoryIterator::getCTime() - Get inode change time of the current DirectoryIterator item
  • DirectoryIterator::getMTime() - Get last modification time of current DirectoryIterator item
  • fileatime() - Dosyaya son erişim zamanını döndürür

DirectoryIterator::current
DirectoryIterator::getBasename
DirectoryIterator


Get base name of current DirectoryIterator item.

DirectoryIterator::getATime
DirectoryIterator::getCTime
DirectoryIterator
PHP Manual

DirectoryIterator::getBasename

(PHP 5 >= 5.2.2, PHP 7)

DirectoryIterator::getBasename — Get base name of current DirectoryIterator item.

Açıklama

public string DirectoryIterator::getBasename ([ string $suffix ] )

Get the base name of the current DirectoryIterator item.

Değiştirgeler

suffix

If the base name ends in suffix, this will be cut.

Dönen Değerler

The base name of the current DirectoryIterator item.

Örnekler

Örnek 1 A DirectoryIterator::getBasename() example

This example will list the full base name and the base name with suffix .jpg removed for the files in the directory containing the script.

<?php
$dir = new DirectoryIterator(dirname(__FILE__));
foreach ($dir as $fileinfo) {
    if ($fileinfo->isFile()) {
        echo $fileinfo->getBasename() . "\n";
        echo $fileinfo->getBasename('.jpg') . "\n";
    }
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

apple.jpg
apple
banana.jpg
banana
index.php
index.php
pear.jpg
pear

Ayrıca Bakınız

  • DirectoryIterator::getFilename() - Return file name of current DirectoryIterator item.
  • DirectoryIterator::getPath() - Get path of current Iterator item without filename
  • DirectoryIterator::getPathname() - Return path and file name of current DirectoryIterator item
  • basename() - Dosya yolunun dosya ismi bileşenini döndürür
  • pathinfo() - Bir dosya yolu hakkında bilgi döndürür

DirectoryIterator::getATime
DirectoryIterator::getCTime
DirectoryIterator


Get inode change time of the current DirectoryIterator item

DirectoryIterator::getBasename
DirectoryIterator::getExtension
DirectoryIterator
PHP Manual

DirectoryIterator::getCTime

(PHP 5, PHP 7)

DirectoryIterator::getCTime — Get inode change time of the current DirectoryIterator item

Açıklama

public int DirectoryIterator::getCTime ( void )

Get the inode change time for the current DirectoryIterator item.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the last change time of the file, as a Unix timestamp.

Örnekler

Örnek 1 DirectoryIterator::getCTime() example

This example displays the file name and last change time of the files in the directory containing the script.

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
foreach ($iterator as $fileinfo) {
    if ($fileinfo->isFile()) {
        echo $fileinfo->getFilename() . " changed at " . $fileinfo->getCTime() . "\n";
    }
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

apple.jpg changed at 1240398312
banana.jpg changed at 1238605440
index.php changed at 1240398935
pear.jpg changed at 1237423740

Ayrıca Bakınız

  • DirectoryIterator::getATime() - Get last access time of the current DirectoryIterator item
  • DirectoryIterator::getMTime() - Get last modification time of current DirectoryIterator item
  • filectime() - Dosyanın dosya düğümü değişiklik zamanını döndürür

DirectoryIterator::getBasename
DirectoryIterator::getExtension
DirectoryIterator


Gets the file extension

DirectoryIterator::getCTime
DirectoryIterator::getFilename
DirectoryIterator
PHP Manual

DirectoryIterator::getExtension

(PHP 5 >= 5.3.6, PHP 7)

DirectoryIterator::getExtension — Gets the file extension

Açıklama

public string DirectoryIterator::getExtension ( void )

Retrieves the file extension.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a string containing the file extension, or an empty string if the file has no extension.

Örnekler

Örnek 1 DirectoryIterator::getExtension() example

<?php

$directory = new DirectoryIterator(__DIR__);
foreach ($directory as $fileinfo) {
    if ($fileinfo->isFile()) {
        echo $fileinfo->getExtension() . "\n";
    }
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

php
txt
jpg
gz

Notlar

Bilginize:

This method is only available as of PHP 5.3.6. Another way of getting the extension is to use the pathinfo() function.

<?php
$extension = pathinfo($fileinfo->getFilename(), PATHINFO_EXTENSION);
?>

Ayrıca Bakınız

  • DirectoryIterator::getFilename() - Return file name of current DirectoryIterator item.
  • DirectoryIterator::getBasename() - Get base name of current DirectoryIterator item.
  • pathinfo() - Bir dosya yolu hakkında bilgi döndürür
DirectoryIterator::getCTime
DirectoryIterator::getFilename
DirectoryIterator


Return file name of current DirectoryIterator item.

DirectoryIterator::getExtension
DirectoryIterator::getGroup
DirectoryIterator
PHP Manual

DirectoryIterator::getFilename

(PHP 5, PHP 7)

DirectoryIterator::getFilename — Return file name of current DirectoryIterator item.

Açıklama

public string DirectoryIterator::getFilename ( void )

Get the file name of the current DirectoryIterator item.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the file name of the current DirectoryIterator item.

Örnekler

Örnek 1 A DirectoryIterator::getFilename() example

This example will list the contents of the directory containing the script.

<?php
$dir = new DirectoryIterator(dirname(__FILE__));
foreach ($dir as $fileinfo) {
    echo $fileinfo->getFilename() . "\n";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

.
..
apple.jpg
banana.jpg
index.php
pear.jpg

Ayrıca Bakınız

  • DirectoryIterator::getBasename() - Get base name of current DirectoryIterator item.
  • DirectoryIterator::getPath() - Get path of current Iterator item without filename
  • DirectoryIterator::getPathname() - Return path and file name of current DirectoryIterator item
  • pathinfo() - Bir dosya yolu hakkında bilgi döndürür

DirectoryIterator::getExtension
DirectoryIterator::getGroup
DirectoryIterator


Get group for the current DirectoryIterator item

DirectoryIterator::getFilename
DirectoryIterator::getInode
DirectoryIterator
PHP Manual

DirectoryIterator::getGroup

(PHP 5, PHP 7)

DirectoryIterator::getGroup — Get group for the current DirectoryIterator item

Açıklama

public int DirectoryIterator::getGroup ( void )

Get the group id of the file.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the group id of the current DirectoryIterator item in numerical format.

Örnekler

Örnek 1 DirectoryIterator::getGroup() example

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
$groupid  = $iterator->getGroup();
echo 'Directory belongs to group id ' . $groupid . "\n";
print_r(posix_getgrgid($groupid));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Directory belongs to group id 42
Array
(
    [name]    => toons
    [passwd]  => x
    [members] => Array
        (
            [0] => tom
            [1] => jerry
        )
    [gid]     => 42
)

Ayrıca Bakınız

  • DirectoryIterator::getiNode() - Get inode for the current DirectoryIterator item
  • DirectoryIterator::getOwner() - Get owner of current DirectoryIterator item
  • DirectoryIterator::getPerms() - Get the permissions of current DirectoryIterator item
  • filegroup() - Dosyanın sahibi olan grubu döndürür
  • posix_getgrgid() - Grup kimliği belirtilen grup hakkında bilgi verir

DirectoryIterator::getFilename
DirectoryIterator::getInode
DirectoryIterator


Get inode for the current DirectoryIterator item

DirectoryIterator::getGroup
DirectoryIterator::getMTime
DirectoryIterator
PHP Manual

DirectoryIterator::getInode

(PHP 5, PHP 7)

DirectoryIterator::getInode — Get inode for the current DirectoryIterator item

Açıklama

public int DirectoryIterator::getInode ( void )

Get the inode number for the current DirectoryIterator item.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the inode number for the file.

Örnekler

Örnek 1 DirectoryIterator::getInode() example

This example displays the inode number for the directory containing the script.

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
echo $iterator->getInode();
?>

Ayrıca Bakınız

  • DirectoryIterator::getGroup() - Get group for the current DirectoryIterator item
  • DirectoryIterator::getOwner() - Get owner of current DirectoryIterator item
  • DirectoryIterator::getPerms() - Get the permissions of current DirectoryIterator item
  • fileinode() - Dosyanın düğüm numarasını döndürür

DirectoryIterator::getGroup
DirectoryIterator::getMTime
DirectoryIterator


Get last modification time of current DirectoryIterator item

DirectoryIterator::getInode
DirectoryIterator::getOwner
DirectoryIterator
PHP Manual

DirectoryIterator::getMTime

(PHP 5, PHP 7)

DirectoryIterator::getMTime — Get last modification time of current DirectoryIterator item

Açıklama

public int DirectoryIterator::getMTime ( void )

Get the last modification time of the current DirectoryIterator item, as a Unix timestamp.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The last modification time of the file, as a Unix timestamp.

Örnekler

Örnek 1 A DirectoryIterator::getMTime() example

Displays a list of the files in the directory of the script and their last modified times.

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
foreach ($iterator as $fileinfo) {
    if ($fileinfo->isFile()) {
        echo $fileinfo->getFilename() . " " . $fileinfo->getMTime() . "\n";
    }
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

apple.jpg 1240047118
banana.jpg 1240065176
index.php 1240047208
pear.jpg 12240047979

Ayrıca Bakınız

  • DirectoryIterator::getATime() - Get last access time of the current DirectoryIterator item
  • DirectoryIterator::getCTime() - Get inode change time of the current DirectoryIterator item
  • filemtime() - Dosyanın değişiklik zamanını döndürür

DirectoryIterator::getInode
DirectoryIterator::getOwner
DirectoryIterator


Get owner of current DirectoryIterator item

DirectoryIterator::getMTime
DirectoryIterator::getPath
DirectoryIterator
PHP Manual

DirectoryIterator::getOwner

(PHP 5, PHP 7)

DirectoryIterator::getOwner — Get owner of current DirectoryIterator item

Açıklama

public int DirectoryIterator::getOwner ( void )

Get the owner of the current DirectoryIterator item, in numerical format.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The file owner of the file, in numerical format.

Örnekler

Örnek 1 DirectoryIterator::getOwner() example

This example displays the owner of the directory which contains the script.

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
print_r(posix_getpwuid($iterator->getOwner()));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [name] => tom
    [passwd] => x
    [uid] => 501
    [gid] => 42
    [gecos] => Tom Cat
    [dir] => /home/tom
    [shell] => /bin/bash
)

Ayrıca Bakınız

  • DirectoryIterator::getGroup() - Get group for the current DirectoryIterator item
  • DirectoryIterator::getiNode() - Get inode for the current DirectoryIterator item
  • DirectoryIterator::getPerms() - Get the permissions of current DirectoryIterator item
  • posix_getpwuid() - Kullanıcı kimliği belirtilen kullanıcı hakkında bilgi döndürür

DirectoryIterator::getMTime
DirectoryIterator::getPath
DirectoryIterator


Get path of current Iterator item without filename

DirectoryIterator::getOwner
DirectoryIterator::getPathname
DirectoryIterator
PHP Manual

DirectoryIterator::getPath

(PHP 5, PHP 7)

DirectoryIterator::getPath — Get path of current Iterator item without filename

Açıklama

public string DirectoryIterator::getPath ( void )

Get the path to the current DirectoryIterator item.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the path to the file, omitting the file name and any trailing slash.

Örnekler

Örnek 1 DirectoryIterator::getPath() example

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
echo $iterator->getPath();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

/home/examples/public_html

Ayrıca Bakınız

  • DirectoryIterator::getBasename() - Get base name of current DirectoryIterator item.
  • DirectoryIterator::getFilename() - Return file name of current DirectoryIterator item.
  • DirectoryIterator::getPathname() - Return path and file name of current DirectoryIterator item
  • pathinfo() - Bir dosya yolu hakkında bilgi döndürür

DirectoryIterator::getOwner
DirectoryIterator::getPathname
DirectoryIterator


Return path and file name of current DirectoryIterator item

DirectoryIterator::getPath
DirectoryIterator::getPerms
DirectoryIterator
PHP Manual

DirectoryIterator::getPathname

(PHP 5, PHP 7)

DirectoryIterator::getPathname — Return path and file name of current DirectoryIterator item

Açıklama

public string DirectoryIterator::getPathname ( void )

Get the path and file name of the current file.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the path and file name of current file. Directories do not have a trailing slash.

Örnekler

Örnek 1 DirectoryIterator::getPathname() example

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
foreach ($iterator as $fileinfo) {
    echo $fileinfo->getPathname() . "\n";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

/home/examples/.
/home/examples/..
/home/examples/apple.jpg
/home/examples/banana.jpg
/home/examples/getpathname.php
/home/examples/pear.jpg

Ayrıca Bakınız

  • DirectoryIterator::getBasename() - Get base name of current DirectoryIterator item.
  • DirectoryIterator::getFilename() - Return file name of current DirectoryIterator item.
  • DirectoryIterator::getPath() - Get path of current Iterator item without filename
  • pathinfo() - Bir dosya yolu hakkında bilgi döndürür

DirectoryIterator::getPath
DirectoryIterator::getPerms
DirectoryIterator


Get the permissions of current DirectoryIterator item

DirectoryIterator::getPathname
DirectoryIterator::getSize
DirectoryIterator
PHP Manual

DirectoryIterator::getPerms

(PHP 5, PHP 7)

DirectoryIterator::getPerms — Get the permissions of current DirectoryIterator item

Açıklama

public int DirectoryIterator::getPerms ( void )

Get the permissions of the current DirectoryIterator item.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the permissions of the file, as a decimal integer.

Örnekler

Örnek 1 DirectoryIterator::getPerms() example

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
foreach ($iterator as $fileinfo) {
    if (!$fileinfo->isDot()) {
        $octal_perms = substr(sprintf('%o', $fileinfo->getPerms()), -4);
        echo $fileinfo->getFilename() . " " . $octal_perms . "\n";
    }
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

apple.jpg 0644
banana.jpg 0644
index.php 0744
pear.jpg 0644

Ayrıca Bakınız

  • DirectoryIterator::isExecutable() - Determine if current DirectoryIterator item is executable
  • DirectoryIterator::isReadable() - Determine if current DirectoryIterator item can be read
  • DirectoryIterator::isWritable() - Determine if current DirectoryIterator item can be written to

DirectoryIterator::getPathname
DirectoryIterator::getSize
DirectoryIterator


Get size of current DirectoryIterator item

DirectoryIterator::getPerms
DirectoryIterator::getType
DirectoryIterator
PHP Manual

DirectoryIterator::getSize

(PHP 5, PHP 7)

DirectoryIterator::getSize — Get size of current DirectoryIterator item

Açıklama

public int DirectoryIterator::getSize ( void )

Get the file size for the current DirectoryIterator item.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the size of the file, in bytes.

Örnekler

Örnek 1 DirectoryIterator::getSize() example

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
foreach ($iterator as $fileinfo) {
    if ($fileinfo->isFile()) {
        echo $fileinfo->getFilename() . " " . $fileinfo->getSize() . "\n";
    }
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

apple.jpg 15385
banana.jpg 15190
example.php 170
pear.jpg 34406

Ayrıca Bakınız

  • filesize() - Dosya uzunluğunu döndürür

DirectoryIterator::getPerms
DirectoryIterator::getType
DirectoryIterator


Determine the type of the current DirectoryIterator item

DirectoryIterator::getSize
DirectoryIterator::isDir
DirectoryIterator
PHP Manual

DirectoryIterator::getType

(PHP 5, PHP 7)

DirectoryIterator::getType — Determine the type of the current DirectoryIterator item

Açıklama

public string DirectoryIterator::getType ( void )

Determines which file type the current DirectoryIterator item belongs to. One of file, link, or dir.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a string representing the type of the file. May be one of file, link, or dir.

Örnekler

Örnek 1 DirectoryIterator::getType() example

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
foreach ($iterator as $fileinfo) {
    echo $fileinfo->getFilename() . " " . $fileinfo->getType() . "\n";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

. dir
.. dir
apple.jpg file
banana.jpg file
example.php file
pear.jpg file

Ayrıca Bakınız

  • DirectoryIterator::isDir() - Determine if current DirectoryIterator item is a directory
  • DirectoryIterator::isDot() - Determine if current DirectoryIterator item is '.' or '..'
  • DirectoryIterator::isFile() - Determine if current DirectoryIterator item is a regular file
  • DirectoryIterator::isLink() - Determine if current DirectoryIterator item is a symbolic link

DirectoryIterator::getSize
DirectoryIterator::isDir
DirectoryIterator


Determine if current DirectoryIterator item is a directory

DirectoryIterator::getType
DirectoryIterator::isDot
DirectoryIterator
PHP Manual

DirectoryIterator::isDir

(PHP 5, PHP 7)

DirectoryIterator::isDir — Determine if current DirectoryIterator item is a directory

Açıklama

public bool DirectoryIterator::isDir ( void )

Determines if the current DirectoryIterator item is a directory.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if it is a directory, otherwise FALSE

Örnekler

Örnek 1 DirectoryIterator::isDir() example

This example lists the directories within the directory of the current script.

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
foreach ($iterator as $fileinfo) {
    if ($fileinfo->isDir()) {
        echo $fileinfo->getFilename() . "\n";
    }
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

.
..
apples
bananas
pears

Ayrıca Bakınız

  • DirectoryIterator::getType() - Determine the type of the current DirectoryIterator item
  • DirectoryIterator::isDot() - Determine if current DirectoryIterator item is '.' or '..'
  • DirectoryIterator::isFile() - Determine if current DirectoryIterator item is a regular file
  • DirectoryIterator::isLink() - Determine if current DirectoryIterator item is a symbolic link

DirectoryIterator::getType
DirectoryIterator::isDot
DirectoryIterator


Determine if current DirectoryIterator item is '.' or '..'

DirectoryIterator::isDir
DirectoryIterator::isExecutable
DirectoryIterator
PHP Manual

DirectoryIterator::isDot

(PHP 5, PHP 7)

DirectoryIterator::isDot — Determine if current DirectoryIterator item is '.' or '..'

Açıklama

public bool DirectoryIterator::isDot ( void )

Determines if the current DirectoryIterator item is a directory and either . or ...

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

TRUE if the entry is . or .., otherwise FALSE

Örnekler

Örnek 1 A DirectoryIterator::isDot() example

This example will list all files, omitting the . and .. entries.

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
foreach ($iterator as $fileinfo) {
    if (!$fileinfo->isDot()) {
        echo $fileinfo->getFilename() . "\n";
    }
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

apple.jpg
banana.jpg
example.php
pears.jpg

Ayrıca Bakınız

  • DirectoryIterator::getType() - Determine the type of the current DirectoryIterator item
  • DirectoryIterator::isDir() - Determine if current DirectoryIterator item is a directory
  • DirectoryIterator::isFile() - Determine if current DirectoryIterator item is a regular file
  • DirectoryIterator::isLink() - Determine if current DirectoryIterator item is a symbolic link

DirectoryIterator::isDir
DirectoryIterator::isExecutable
DirectoryIterator


Determine if current DirectoryIterator item is executable

DirectoryIterator::isDot
DirectoryIterator::isFile
DirectoryIterator
PHP Manual

DirectoryIterator::isExecutable

(PHP 5, PHP 7)

DirectoryIterator::isExecutable — Determine if current DirectoryIterator item is executable

Açıklama

public bool DirectoryIterator::isExecutable ( void )

Determines if the current DirectoryIterator item is executable.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the entry is executable, otherwise FALSE

Örnekler

Örnek 1 DirectoryIterator::isExecutable() example

This example lists files in the directory containing the script which are executable.

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
foreach ($iterator as $fileinfo) {
    if ($fileinfo->isExecutable()) {
        echo $fileinfo->getFilename() . "\n";
    }
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

example.php
myscript.sh

Ayrıca Bakınız

  • DirectoryIterator::isReadable() - Determine if current DirectoryIterator item can be read
  • DirectoryIterator::isWritable() - Determine if current DirectoryIterator item can be written to
  • DirectoryIterator::getPerms() - Get the permissions of current DirectoryIterator item

DirectoryIterator::isDot
DirectoryIterator::isFile
DirectoryIterator


Determine if current DirectoryIterator item is a regular file

DirectoryIterator::isExecutable
DirectoryIterator::isLink
DirectoryIterator
PHP Manual

DirectoryIterator::isFile

(PHP 5, PHP 7)

DirectoryIterator::isFile — Determine if current DirectoryIterator item is a regular file

Açıklama

public bool DirectoryIterator::isFile ( void )

Determines if the current DirectoryIterator item is a regular file.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the file exists and is a regular file (not a link or dir), otherwise FALSE

Örnekler

Örnek 1 DirectoryIterator::isFile() example

This example will list all regular files in the directory containing the script.

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
foreach ($iterator as $fileinfo) {
    if ($fileinfo->isFile()) {
        echo $fileinfo->getFilename() . "\n";
    }
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

apple.jpg
banana.jpg
example.php
pears.jpg

Ayrıca Bakınız

  • DirectoryIterator::getType() - Determine the type of the current DirectoryIterator item
  • DirectoryIterator::isDir() - Determine if current DirectoryIterator item is a directory
  • DirectoryIterator::isDot() - Determine if current DirectoryIterator item is '.' or '..'
  • DirectoryIterator::isLink() - Determine if current DirectoryIterator item is a symbolic link

DirectoryIterator::isExecutable
DirectoryIterator::isLink
DirectoryIterator


Determine if current DirectoryIterator item is a symbolic link

DirectoryIterator::isFile
DirectoryIterator::isReadable
DirectoryIterator
PHP Manual

DirectoryIterator::isLink

(PHP 5, PHP 7)

DirectoryIterator::isLink — Determine if current DirectoryIterator item is a symbolic link

Açıklama

public bool DirectoryIterator::isLink ( void )

Determines if the current DirectoryIterator item is a symbolic link.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the item is a symbolic link, otherwise FALSE

Örnekler

Örnek 1 A DirectoryIterator::isLink() example

This example contains a recursive function for removing a directory tree.

<?php
/**
 * This function will recursively delete all files in the given path, without
 * following symlinks.
 *
 * @param string $path Path to the directory to remove.
 */
function removeDir($path) {
    $dir = new DirectoryIterator($path);
    foreach ($dir as $fileinfo) {
        if ($fileinfo->isFile() || $fileinfo->isLink()) {
            unlink($fileinfo->getPathName());
        } elseif (!$fileinfo->isDot() && $fileinfo->isDir()) {
            removeDir($fileinfo->getPathName());
        }
    }
    rmdir($path);
}

removeDir('foo');
?>

Ayrıca Bakınız

  • DirectoryIterator::getType() - Determine the type of the current DirectoryIterator item
  • DirectoryIterator::isDir() - Determine if current DirectoryIterator item is a directory
  • DirectoryIterator::isDot() - Determine if current DirectoryIterator item is '.' or '..'
  • DirectoryIterator::isFile() - Determine if current DirectoryIterator item is a regular file

DirectoryIterator::isFile
DirectoryIterator::isReadable
DirectoryIterator


Determine if current DirectoryIterator item can be read

DirectoryIterator::isLink
DirectoryIterator::isWritable
DirectoryIterator
PHP Manual

DirectoryIterator::isReadable

(PHP 5, PHP 7)

DirectoryIterator::isReadable — Determine if current DirectoryIterator item can be read

Açıklama

public bool DirectoryIterator::isReadable ( void )

Determines if the current DirectoryIterator item is readable.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the file is readable, otherwise FALSE

Örnekler

Örnek 1 DirectoryIterator::isReadable() example

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
foreach ($iterator as $fileinfo) {
    if ($fileinfo->isReadable()) {
        echo $fileinfo->getFilename() . "\n";
    }
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

apple.jpg
banana.jpg
example.php
pears.jpg

Ayrıca Bakınız

  • DirectoryIterator::isExecutable() - Determine if current DirectoryIterator item is executable
  • DirectoryIterator::isWritable() - Determine if current DirectoryIterator item can be written to
  • DirectoryIterator::getPerms() - Get the permissions of current DirectoryIterator item

DirectoryIterator::isLink
DirectoryIterator::isWritable
DirectoryIterator


Determine if current DirectoryIterator item can be written to

DirectoryIterator::isReadable
DirectoryIterator::key
DirectoryIterator
PHP Manual

DirectoryIterator::isWritable

(PHP 5, PHP 7)

DirectoryIterator::isWritable — Determine if current DirectoryIterator item can be written to

Açıklama

public bool DirectoryIterator::isWritable ( void )

Determines if the current DirectoryIterator item is writable.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the file/directory is writable, otherwise FALSE

Örnekler

Örnek 1 DirectoryIterator::isWritable() example

This example lists the files and directories which can be opened for writing in the directory containing the script.

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
foreach ($iterator as $fileinfo) {
    if ($fileinfo->isWritable()) {
        echo $fileinfo->getFilename() . "\n";
    }
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

apples.txt
bananas.html
pears

Ayrıca Bakınız

  • DirectoryIterator::getPerms() - Get the permissions of current DirectoryIterator item
  • DirectoryIterator::isExecutable() - Determine if current DirectoryIterator item is executable
  • DirectoryIterator::isReadable() - Determine if current DirectoryIterator item can be read

DirectoryIterator::isReadable
DirectoryIterator::key
DirectoryIterator


Return the key for the current DirectoryIterator item

DirectoryIterator::isWritable
DirectoryIterator::next
DirectoryIterator
PHP Manual

DirectoryIterator::key

(PHP 5, PHP 7)

DirectoryIterator::key — Return the key for the current DirectoryIterator item

Açıklama

public string DirectoryIterator::key ( void )

Get the key for the current DirectoryIterator item.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The key for the current DirectoryIterator item.

Örnekler

Örnek 1 A DirectoryIterator::key() example

<?php
$dir = new DirectoryIterator(dirname(__FILE__));
foreach ($dir as $fileinfo) {
    if (!$fileinfo->isDot()) {
        echo $fileinfo->key() . " => " . $fileinfo->getFilename() . "\n";
    }
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

0 => apple.jpg
1 => banana.jpg
2 => index.php
3 => pear.jpg

Ayrıca Bakınız

  • DirectoryIterator::current() - Return the current DirectoryIterator item.
  • DirectoryIterator::next() - Move forward to next DirectoryIterator item
  • DirectoryIterator::rewind() - Rewind the DirectoryIterator back to the start
  • DirectoryIterator::valid() - Check whether current DirectoryIterator position is a valid file
  • Iterator::key() - O anki elemanın anahtarını döndürür

DirectoryIterator::isWritable
DirectoryIterator::next
DirectoryIterator


Move forward to next DirectoryIterator item

DirectoryIterator::key
DirectoryIterator::rewind
DirectoryIterator
PHP Manual

DirectoryIterator::next

(PHP 5, PHP 7)

DirectoryIterator::next — Move forward to next DirectoryIterator item

Açıklama

public void DirectoryIterator::next ( void )

Move forward to the next DirectoryIterator item.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 DirectoryIterator::next() example

List the contents of a directory using a while loop.

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
while($iterator->valid()) {
    echo $iterator->getFilename() . "\n";
    $iterator->next();
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

.
..
apple.jpg
banana.jpg
index.php
pear.jpg

Ayrıca Bakınız

  • DirectoryIterator::current() - Return the current DirectoryIterator item.
  • DirectoryIterator::key() - Return the key for the current DirectoryIterator item
  • DirectoryIterator::rewind() - Rewind the DirectoryIterator back to the start
  • DirectoryIterator::valid() - Check whether current DirectoryIterator position is a valid file
  • Iterator::next() - Konumu sonraki elemana ilerletir

DirectoryIterator::key
DirectoryIterator::rewind
DirectoryIterator


Rewind the DirectoryIterator back to the start

DirectoryIterator::next
DirectoryIterator::seek
DirectoryIterator
PHP Manual

DirectoryIterator::rewind

(PHP 5, PHP 7)

DirectoryIterator::rewind — Rewind the DirectoryIterator back to the start

Açıklama

public void DirectoryIterator::rewind ( void )

Rewind the DirectoryIterator back to the start.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 DirectoryIterator::rewind() example

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));

$iterator->next();
echo $iterator->key(); //1

$iterator->rewind(); //rewinding to the beginning
echo $iterator->key(); //0
?>

Ayrıca Bakınız

  • DirectoryIterator::current() - Return the current DirectoryIterator item.
  • DirectoryIterator::key() - Return the key for the current DirectoryIterator item
  • DirectoryIterator::next() - Move forward to next DirectoryIterator item
  • DirectoryIterator::valid() - Check whether current DirectoryIterator position is a valid file
  • Iterator::rewind() - Yineleyiciyi ilk elemana konumlandırır

DirectoryIterator::next
DirectoryIterator::seek
DirectoryIterator


Seek to a DirectoryIterator item

DirectoryIterator::rewind
DirectoryIterator::__toString
DirectoryIterator
PHP Manual

DirectoryIterator::seek

(PHP 5 >= 5.3.0, PHP 7)

DirectoryIterator::seek — Seek to a DirectoryIterator item

Açıklama

public void DirectoryIterator::seek ( int $position )

Seek to a given position in the DirectoryIterator.

Değiştirgeler

position

The zero-based numeric position to seek to.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 DirectoryIterator::seek() example

Seek to the fourth item in the directory containing the script. The first two are usually . and ..

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));
$iterator->seek(3);
if ($iterator->valid()) {
    echo $iterator->getFilename();
} else {
    echo 'No file at position 3';
}
?>

Ayrıca Bakınız

  • DirectoryIterator::rewind() - Rewind the DirectoryIterator back to the start
  • DirectoryIterator::next() - Move forward to next DirectoryIterator item
  • SeekableIterator::seek() - Seeks to a position

DirectoryIterator::rewind
DirectoryIterator::__toString
DirectoryIterator


Get file name as a string

DirectoryIterator::seek
DirectoryIterator::valid
DirectoryIterator
PHP Manual

DirectoryIterator::__toString

(PHP 5, PHP 7)

DirectoryIterator::__toString — Get file name as a string

Açıklama

public string DirectoryIterator::__toString ( void )

Get the file name of the current DirectoryIterator item.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the file name of the current DirectoryIterator item.

Örnekler

Örnek 1 A DirectoryIterator::__toString() example

This example will list the contents of the directory containing the script.

<?php
$dir = new DirectoryIterator(dirname(__FILE__));
foreach ($dir as $fileinfo) {
    echo $fileinfo;
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

.
..
apple.jpg
banana.jpg
index.php
pear.jpg

Ayrıca Bakınız

  • DirectoryIterator::getFilename() - Return file name of current DirectoryIterator item.
  • The __toString() magic method

DirectoryIterator::seek
DirectoryIterator::valid
DirectoryIterator


Check whether current DirectoryIterator position is a valid file

DirectoryIterator::__toString
EmptyIterator
DirectoryIterator
PHP Manual

DirectoryIterator::valid

(PHP 5, PHP 7)

DirectoryIterator::valid — Check whether current DirectoryIterator position is a valid file

Açıklama

public bool DirectoryIterator::valid ( void )

Check whether current DirectoryIterator position is a valid file.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the position is valid, otherwise FALSE

Örnekler

Örnek 1 A DirectoryIterator::valid() example

<?php
$iterator = new DirectoryIterator(dirname(__FILE__));

// Loop to end of iterator
while($iterator->valid()) {
    $iterator->next();
}

$iterator->valid(); // FALSE
$iterator->rewind();
$iterator->valid(); // TRUE

?>

Ayrıca Bakınız

  • DirectoryIterator::current() - Return the current DirectoryIterator item.
  • DirectoryIterator::key() - Return the key for the current DirectoryIterator item
  • DirectoryIterator::next() - Move forward to next DirectoryIterator item
  • DirectoryIterator::rewind() - Rewind the DirectoryIterator back to the start
  • Iterator::valid() - O anki konum geçerli mi diye bakar

DirectoryIterator::__toString
EmptyIterator
DirectoryIterator


The EmptyIterator class

(PHP 5 >= 5.1.0, PHP 7)

Giriş

The EmptyIterator class for an empty iterator.

Sınıf Sözdizimi

EmptyIterator implements Iterator {
/* Yöntemler */
public mixed current ( void )
public scalar key ( void )
public void next ( void )
public void rewind ( void )
public bool valid ( void )
}

İçindekiler

  • EmptyIterator::current — The current() method
  • EmptyIterator::key — The key() method
  • EmptyIterator::next — The next() method
  • EmptyIterator::rewind — The rewind() method
  • EmptyIterator::valid — The valid() method
DirectoryIterator::valid
EmptyIterator::current
Iterators


The current() method

EmptyIterator
EmptyIterator::key
EmptyIterator
PHP Manual

EmptyIterator::current

(PHP 5 >= 5.1.0, PHP 7)

EmptyIterator::current — The current() method

Açıklama

public mixed EmptyIterator::current ( void )

This function must not be called. It throws an exception upon access.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Hatalar/İstisnalar

Throws an Exception if called.

Dönen Değerler

Hiçbir değer dönmez.

EmptyIterator
EmptyIterator::key
EmptyIterator


The key() method

EmptyIterator::current
EmptyIterator::next
EmptyIterator
PHP Manual

EmptyIterator::key

(PHP 5 >= 5.1.0, PHP 7)

EmptyIterator::key — The key() method

Açıklama

public scalar EmptyIterator::key ( void )

This function must not be called. It throws an exception upon access.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Hatalar/İstisnalar

Throws an Exception if called.

Dönen Değerler

Hiçbir değer dönmez.

EmptyIterator::current
EmptyIterator::next
EmptyIterator


The next() method

EmptyIterator::key
EmptyIterator::rewind
EmptyIterator
PHP Manual

EmptyIterator::next

(PHP 5 >= 5.1.0, PHP 7)

EmptyIterator::next — The next() method

Açıklama

public void EmptyIterator::next ( void )

No operation, nothing to do.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

EmptyIterator::key
EmptyIterator::rewind
EmptyIterator


The rewind() method

EmptyIterator::next
EmptyIterator::valid
EmptyIterator
PHP Manual

EmptyIterator::rewind

(PHP 5 >= 5.1.0, PHP 7)

EmptyIterator::rewind — The rewind() method

Açıklama

public void EmptyIterator::rewind ( void )

No operation, nothing to do.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

EmptyIterator::next
EmptyIterator::valid
EmptyIterator


The valid() method

EmptyIterator::rewind
FilesystemIterator
EmptyIterator
PHP Manual

EmptyIterator::valid

(PHP 5 >= 5.1.0, PHP 7)

EmptyIterator::valid — The valid() method

Açıklama

public bool EmptyIterator::valid ( void )

The EmptyIterator valid() method.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

FALSE

EmptyIterator::rewind
FilesystemIterator
EmptyIterator


The FilesystemIterator class

(PHP 5 >= 5.3.0, PHP 7)

Giriş

The Filesystem iterator

Sınıf Sözdizimi

FilesystemIterator extends DirectoryIterator implements SeekableIterator {
/* Sabitler */
const integer CURRENT_AS_PATHNAME = 32 ;
const integer CURRENT_AS_FILEINFO = 0 ;
const integer CURRENT_AS_SELF = 16 ;
const integer CURRENT_MODE_MASK = 240 ;
const integer KEY_AS_PATHNAME = 0 ;
const integer KEY_AS_FILENAME = 256 ;
const integer FOLLOW_SYMLINKS = 512 ;
const integer KEY_MODE_MASK = 3840 ;
const integer NEW_CURRENT_AND_KEY = 256 ;
const integer SKIP_DOTS = 4096 ;
const integer UNIX_PATHS = 8192 ;
/* Yöntemler */
public __construct ( string $path [, int $flags = FilesystemIterator::KEY_AS_PATHNAME | FilesystemIterator::CURRENT_AS_FILEINFO | FilesystemIterator::SKIP_DOTS ] )
public mixed current ( void )
public int getFlags ( void )
public string key ( void )
public void next ( void )
public void rewind ( void )
public void setFlags ([ int $flags ] )
/* Miras alınan yöntemler */
public DirectoryIterator DirectoryIterator::current ( void )
public int DirectoryIterator::getATime ( void )
public string DirectoryIterator::getBasename ([ string $suffix ] )
public int DirectoryIterator::getCTime ( void )
public string DirectoryIterator::getExtension ( void )
public string DirectoryIterator::getFilename ( void )
public int DirectoryIterator::getGroup ( void )
public int DirectoryIterator::getInode ( void )
public int DirectoryIterator::getMTime ( void )
public int DirectoryIterator::getOwner ( void )
public string DirectoryIterator::getPath ( void )
public string DirectoryIterator::getPathname ( void )
public int DirectoryIterator::getPerms ( void )
public int DirectoryIterator::getSize ( void )
public string DirectoryIterator::getType ( void )
public bool DirectoryIterator::isDir ( void )
public bool DirectoryIterator::isDot ( void )
public bool DirectoryIterator::isExecutable ( void )
public bool DirectoryIterator::isFile ( void )
public bool DirectoryIterator::isLink ( void )
public bool DirectoryIterator::isReadable ( void )
public bool DirectoryIterator::isWritable ( void )
public string DirectoryIterator::key ( void )
public void DirectoryIterator::next ( void )
public void DirectoryIterator::rewind ( void )
public void DirectoryIterator::seek ( int $position )
public string DirectoryIterator::__toString ( void )
public bool DirectoryIterator::valid ( void )
}

Öntanımlı Sabitler

FilesystemIterator::CURRENT_AS_PATHNAME

Makes FilesystemIterator::current() return the pathname.

FilesystemIterator::CURRENT_AS_FILEINFO

Makes FilesystemIterator::current() return an SplFileInfo instance.

FilesystemIterator::CURRENT_AS_SELF

Makes FilesystemIterator::current() return $this (the FilesystemIterator).

FilesystemIterator::CURRENT_MODE_MASK

Masks FilesystemIterator::current()

FilesystemIterator::KEY_AS_PATHNAME

Makes FilesystemIterator::key() return the pathname.

FilesystemIterator::KEY_AS_FILENAME

Makes FilesystemIterator::key() return the filename.

FilesystemIterator::FOLLOW_SYMLINKS

Makes RecursiveDirectoryIterator::hasChildren() follow symlinks.

FilesystemIterator::KEY_MODE_MASK

Masks FilesystemIterator::key()

FilesystemIterator::NEW_CURRENT_AND_KEY

Same as FilesystemIterator::KEY_AS_FILENAME | FilesystemIterator::CURRENT_AS_FILEINFO.

FilesystemIterator::SKIP_DOTS

Skips dot files (. and ..).

FilesystemIterator::UNIX_PATHS

Makes paths use Unix-style forward slash irrespective of system default. Note that the path that is passed to the constructor is not modified.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.1 | Added FilesystemIterator::FOLLOW_SYMLINKS

İçindekiler

  • FilesystemIterator::__construct — Constructs a new filesystem iterator
  • FilesystemIterator::current — The current file
  • FilesystemIterator::getFlags — Get the handling flags
  • FilesystemIterator::key — Retrieve the key for the current file
  • FilesystemIterator::next — Move to the next file
  • FilesystemIterator::rewind — Rewinds back to the beginning
  • FilesystemIterator::setFlags — Sets handling flags
EmptyIterator::valid
FilesystemIterator::__construct
Iterators


Constructs a new filesystem iterator

FilesystemIterator
FilesystemIterator::current
FilesystemIterator
PHP Manual

FilesystemIterator::__construct

(PHP 5 >= 5.3.0, PHP 7)

FilesystemIterator::__construct — Constructs a new filesystem iterator

Açıklama

public FilesystemIterator::__construct ( string $path [, int $flags = FilesystemIterator::KEY_AS_PATHNAME | FilesystemIterator::CURRENT_AS_FILEINFO | FilesystemIterator::SKIP_DOTS ] )

Constructs a new filesystem iterator from the path.

Değiştirgeler

path

The path of the filesystem item to be iterated over.

flags

Flags may be provided which will affect the behavior of some methods. A list of the flags can found under FilesystemIterator predefined constants. They can also be set later with FilesystemIterator::setFlags()

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

Throws an UnexpectedValueException if the path cannot be found.

Örnekler

Örnek 1 FilesystemIterator::__construct() example

<?php
$it = new FilesystemIterator(dirname(__FILE__));
foreach ($it as $fileinfo) {
    echo $fileinfo->getFilename() . "\n";
}
?>

Yukarıdaki örneğin çıktısı:

apples.jpg
banana.jpg
example.php

Ayrıca Bakınız

  • FilesystemIterator::setFlags() - Sets handling flags
  • DirectoryIterator::__construct() - Constructs a new directory iterator from a path

FilesystemIterator
FilesystemIterator::current
FilesystemIterator


The current file

FilesystemIterator::__construct
FilesystemIterator::getFlags
FilesystemIterator
PHP Manual

FilesystemIterator::current

(PHP 5 >= 5.3.0, PHP 7)

FilesystemIterator::current — The current file

Açıklama

public mixed FilesystemIterator::current ( void )

Get file information of the current element.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The filename, file information, or $this depending on the set flags. See the FilesystemIterator constants.

Örnekler

Örnek 1 FilesystemIterator::current() example

This example will list the contents of the directory containing the script.

<?php
$iterator = new FilesystemIterator(__DIR__, FilesystemIterator::CURRENT_AS_PATHNAME);
foreach ($iterator as $fileinfo) {
    echo $iterator->current() . "\n";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

/www/examples/apple.jpg
/www/examples/banana.jpg
/www/examples/example.php

Ayrıca Bakınız

  • FilesystemIterator constants
  • DirectoryIterator::current() - Return the current DirectoryIterator item.
  • DirectoryIterator::getFileName() - Return file name of current DirectoryIterator item.

FilesystemIterator::__construct
FilesystemIterator::getFlags
FilesystemIterator


Get the handling flags

FilesystemIterator::current
FilesystemIterator::key
FilesystemIterator
PHP Manual

FilesystemIterator::getFlags

(PHP 5 >= 5.3.0, PHP 7)

FilesystemIterator::getFlags — Get the handling flags

Açıklama

public int FilesystemIterator::getFlags ( void )

Gets the handling flags, as set in FilesystemIterator::__construct() or FilesystemIterator::setFlags().

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The integer value of the set flags.

Ayrıca Bakınız

  • FilesystemIterator::__construct() - Constructs a new filesystem iterator
  • FilesystemIterator::setFlags() - Sets handling flags

FilesystemIterator::current
FilesystemIterator::key
FilesystemIterator


Retrieve the key for the current file

FilesystemIterator::getFlags
FilesystemIterator::next
FilesystemIterator
PHP Manual

FilesystemIterator::key

(PHP 5 >= 5.3.0, PHP 7)

FilesystemIterator::key — Retrieve the key for the current file

Açıklama

public string FilesystemIterator::key ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the pathname or filename depending on the set flags. See the FilesystemIterator constants.

Örnekler

Örnek 1 FilesystemIterator::key() example

This example will list the contents of the directory containing the script.

<?php
$iterator = new FilesystemIterator(dirname(__FILE__), FilesystemIterator::KEY_AS_FILENAME);
foreach ($iterator as $fileinfo) {
    echo $iterator->key() . "\n";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

apple.jpg
banana.jpg
example.php

Ayrıca Bakınız

  • FilesystemIterator constants
  • DirectoryIterator::key() - Return the key for the current DirectoryIterator item
  • DirectoryIterator::getFilename() - Return file name of current DirectoryIterator item.
  • DirectoryIterator::getPathname() - Return path and file name of current DirectoryIterator item

FilesystemIterator::getFlags
FilesystemIterator::next
FilesystemIterator


Move to the next file

FilesystemIterator::key
FilesystemIterator::rewind
FilesystemIterator
PHP Manual

FilesystemIterator::next

(PHP 5 >= 5.3.0, PHP 7)

FilesystemIterator::next — Move to the next file

Açıklama

public void FilesystemIterator::next ( void )

Move to the next file.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 FilesystemIterator::next() example

List the contents of a directory using a while loop.

<?php
$iterator = new FilesystemIterator(dirname(__FILE__));
while($iterator->valid()) {
    echo $iterator->getFilename() . "\n";
    $iterator->next();
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

apple.jpg
banana.jpg
example.php

Ayrıca Bakınız

  • DirectoryIterator::next() - Move forward to next DirectoryIterator item

FilesystemIterator::key
FilesystemIterator::rewind
FilesystemIterator


Rewinds back to the beginning

FilesystemIterator::next
FilesystemIterator::setFlags
FilesystemIterator
PHP Manual

FilesystemIterator::rewind

(PHP 5 >= 5.3.0, PHP 7)

FilesystemIterator::rewind — Rewinds back to the beginning

Açıklama

public void FilesystemIterator::rewind ( void )

Rewinds the directory back to the start.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 FilesystemIterator::rewind() example

<?php
$iterator = new FilesystemIterator(dirname(__FILE__), FilesystemIterator::KEY_AS_FILENAME);

echo $iterator->key() . "\n";

$iterator->next();
echo $iterator->key() . "\n";

$iterator->rewind();
echo $iterator->key() . "\n";
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

apple.jpg
banana.jpg
apple.jpg

Ayrıca Bakınız

  • DirectoryIterator::rewind() - Rewind the DirectoryIterator back to the start

FilesystemIterator::next
FilesystemIterator::setFlags
FilesystemIterator


Sets handling flags

FilesystemIterator::rewind
FilterIterator
FilesystemIterator
PHP Manual

FilesystemIterator::setFlags

(PHP 5 >= 5.3.0, PHP 7)

FilesystemIterator::setFlags — Sets handling flags

Açıklama

public void FilesystemIterator::setFlags ([ int $flags ] )

Sets handling flags.

Değiştirgeler

flags

The handling flags to set. See the FilesystemIterator constants.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 FilesystemIterator::key() example

This example demonstrates the difference between the FilesystemIterator::KEY_AS_PATHNAME and FilesystemIterator::KEY_AS_FILENAME flags.

<?php
$iterator = new FilesystemIterator(dirname(__FILE__), FilesystemIterator::KEY_AS_PATHNAME);
echo "Key as Pathname:\n";
foreach ($iterator as $key => $fileinfo) {
    echo $key . "\n";
}

$iterator->setFlags(FilesystemIterator::KEY_AS_FILENAME);
echo "\nKey as Filename:\n";
foreach ($iterator as $key => $fileinfo) {
    echo $key . "\n";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Key as Pathname:
/www/examples/apple.jpg
/www/examples/banana.jpg
/www/examples/example.php

Key as Filename:
apple.jpg
banana.jpg
example.php

Ayrıca Bakınız

  • FilesystemIterator::__construct() - Constructs a new filesystem iterator
  • FilesystemIterator::getFlags() - Get the handling flags

FilesystemIterator::rewind
FilterIterator
FilesystemIterator


The FilterIterator class

(PHP 5 >= 5.1.0, PHP 7)

Giriş

This abstract iterator filters out unwanted values. This class should be extended to implement custom iterator filters. The FilterIterator::accept() must be implemented in the subclass.

Sınıf Sözdizimi

abstract FilterIterator extends IteratorIterator implements OuterIterator {
/* Yöntemler */
public abstract bool accept ( void )
public __construct ( Iterator $iterator )
public mixed current ( void )
public Iterator getInnerIterator ( void )
public mixed key ( void )
public void next ( void )
public void rewind ( void )
public bool valid ( void )
}

İçindekiler

  • FilterIterator::accept — Check whether the current element of the iterator is acceptable
  • FilterIterator::__construct — Construct a filterIterator
  • FilterIterator::current — Get the current element value
  • FilterIterator::getInnerIterator — Get the inner iterator
  • FilterIterator::key — Get the current key
  • FilterIterator::next — Move the iterator forward
  • FilterIterator::rewind — Rewind the iterator
  • FilterIterator::valid — Check whether the current element is valid
FilesystemIterator::setFlags
FilterIterator::accept
Iterators


Check whether the current element of the iterator is acceptable

FilterIterator
FilterIterator::__construct
FilterIterator
PHP Manual

FilterIterator::accept

(PHP 5 >= 5.1.0, PHP 7)

FilterIterator::accept — Check whether the current element of the iterator is acceptable

Açıklama

public abstract bool FilterIterator::accept ( void )

Returns whether the current element of the iterator is acceptable through this filter.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

TRUE if the current element is acceptable, otherwise FALSE.

Örnekler

Örnek 1 FilterIterator::accept() example

<?php
// This iterator filters all values with less than 10 characters
class LengthFilterIterator extends FilterIterator {

    public function accept() {
        // Only accept strings with a length of 10 and greater
        return strlen(parent::current()) >= 10;
    }

}

$arrayIterator = new ArrayIterator(array('test1', 'more than 10 characters'));
$lengthFilter = new LengthFilterIterator($arrayIterator);

foreach ($lengthFilter as $value) {
    echo $value . "\n";
}
?>

Yukarıdaki örneğin çıktısı:

more than 10 characters

FilterIterator
FilterIterator::__construct
FilterIterator


Construct a filterIterator

FilterIterator::accept
FilterIterator::current
FilterIterator
PHP Manual

FilterIterator::__construct

(PHP 5 >= 5.1.0, PHP 7)

FilterIterator::__construct — Construct a filterIterator

Açıklama

public FilterIterator::__construct ( Iterator $iterator )

Constructs a new FilterIterator, which consists of a passed in iterator with filters applied to it.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

iterator

The iterator that is being filtered.

Dönen Değerler

The FilterIterator.

Ayrıca Bakınız

  • LimitIterator::__construct() - Construct a LimitIterator

FilterIterator::accept
FilterIterator::current
FilterIterator


Get the current element value

FilterIterator::__construct
FilterIterator::getInnerIterator
FilterIterator
PHP Manual

FilterIterator::current

(PHP 5 >= 5.1.0, PHP 7)

FilterIterator::current — Get the current element value

Açıklama

public mixed FilterIterator::current ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Get the current element value.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current element value.

Ayrıca Bakınız

  • FilterIterator::key() - Get the current key
  • FilterIterator::next() - Move the iterator forward

FilterIterator::__construct
FilterIterator::getInnerIterator
FilterIterator


Get the inner iterator

FilterIterator::current
FilterIterator::key
FilterIterator
PHP Manual

FilterIterator::getInnerIterator

(PHP 5 >= 5.1.0, PHP 7)

FilterIterator::getInnerIterator — Get the inner iterator

Açıklama

public Iterator FilterIterator::getInnerIterator ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Get the inner iterator.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The inner iterator.

FilterIterator::current
FilterIterator::key
FilterIterator


Get the current key

FilterIterator::getInnerIterator
FilterIterator::next
FilterIterator
PHP Manual

FilterIterator::key

(PHP 5 >= 5.1.0, PHP 7)

FilterIterator::key — Get the current key

Açıklama

public mixed FilterIterator::key ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Get the current key.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current key.

Ayrıca Bakınız

  • FilterIterator::next() - Move the iterator forward
  • FilterIterator::current() - Get the current element value

FilterIterator::getInnerIterator
FilterIterator::next
FilterIterator


Move the iterator forward

FilterIterator::key
FilterIterator::rewind
FilterIterator
PHP Manual

FilterIterator::next

(PHP 5 >= 5.1.0, PHP 7)

FilterIterator::next — Move the iterator forward

Açıklama

public void FilterIterator::next ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Move the iterator forward.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • FilterIterator::current() - Get the current element value
  • FilterIterator::next()

FilterIterator::key
FilterIterator::rewind
FilterIterator


Rewind the iterator

FilterIterator::next
FilterIterator::valid
FilterIterator
PHP Manual

FilterIterator::rewind

(PHP 5 >= 5.1.0, PHP 7)

FilterIterator::rewind — Rewind the iterator

Açıklama

public void FilterIterator::rewind ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Rewind the iterator.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • FilterIterator::current() - Get the current element value
  • FilterIterator::key() - Get the current key
  • FilterIterator::next() - Move the iterator forward

FilterIterator::next
FilterIterator::valid
FilterIterator


Check whether the current element is valid

FilterIterator::rewind
GlobIterator
FilterIterator
PHP Manual

FilterIterator::valid

(PHP 5 >= 5.1.0, PHP 7)

FilterIterator::valid — Check whether the current element is valid

Açıklama

public bool FilterIterator::valid ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Checks whether the current element is valid.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

TRUE if the current element is valid, otherwise FALSE

FilterIterator::rewind
GlobIterator
FilterIterator


The GlobIterator class

(PHP 5 >= 5.3.0, PHP 7)

Giriş

Iterates through a file system in a similar fashion to glob().

Sınıf Sözdizimi

GlobIterator extends FilesystemIterator implements SeekableIterator , Countable {
/* Yöntemler */
public __construct ( string $path [, int $flags = FilesystemIterator::KEY_AS_PATHNAME | FilesystemIterator::CURRENT_AS_FILEINFO ] )
public int count ( void )
/* Miras alınan yöntemler */
public FilesystemIterator::__construct ( string $path [, int $flags = FilesystemIterator::KEY_AS_PATHNAME | FilesystemIterator::CURRENT_AS_FILEINFO | FilesystemIterator::SKIP_DOTS ] )
public mixed FilesystemIterator::current ( void )
public int FilesystemIterator::getFlags ( void )
public string FilesystemIterator::key ( void )
public void FilesystemIterator::next ( void )
public void FilesystemIterator::rewind ( void )
public void FilesystemIterator::setFlags ([ int $flags ] )
}

İçindekiler

  • GlobIterator::__construct — Construct a directory using glob
  • GlobIterator::count — Get the number of directories and files
FilterIterator::valid
GlobIterator::__construct
Iterators


Construct a directory using glob

GlobIterator
GlobIterator::count
GlobIterator
PHP Manual

GlobIterator::__construct

(PHP 5 >= 5.3.0, PHP 7)

GlobIterator::__construct — Construct a directory using glob

Açıklama

public GlobIterator::__construct ( string $path [, int $flags = FilesystemIterator::KEY_AS_PATHNAME | FilesystemIterator::CURRENT_AS_FILEINFO ] )

Constructs a new directory iterator from a glob expression.

Değiştirgeler

path

The path of the directory.

flags

Option flags, the flags may be a bitmask of the FilesystemIterator constants.

Örnekler

Örnek 1 GlobIterator example

<?php
$iterator = new GlobIterator('*.dll', FilesystemIterator::KEY_AS_FILENAME);

if (!$iterator->count()) {
    echo 'No matches';
} else {
    $n = 0;

    printf("Matched %d item(s)\r\n", $iterator->count());

    foreach ($iterator as $item) {
        printf("[%d] %s\r\n", ++$n, $iterator->key());
    }
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Matched 2 item(s)
[1] php5ts.dll
[2] php_gd2.dll

Ayrıca Bakınız

  • DirectoryIterator::__construct() - Constructs a new directory iterator from a path
  • GlobIterator::count() - Get the number of directories and files
  • glob() - Bir kalıpla eşleşen dosya yollarını bulur

GlobIterator
GlobIterator::count
GlobIterator


Get the number of directories and files

GlobIterator::__construct
InfiniteIterator
GlobIterator
PHP Manual

GlobIterator::count

(PHP 5 >= 5.3.0, PHP 7)

GlobIterator::count — Get the number of directories and files

Açıklama

public int GlobIterator::count ( void )

Gets the number of directories and files found by the glob expression.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The number of returned directories and files, as an integer.

Örnekler

Örnek 1 GlobIterator::count() example

<?php
$iterator = new GlobIterator('*.xml');

printf("Matched %d item(s)\r\n", $iterator->count());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Matched 8 item(s)

Ayrıca Bakınız

  • GlobIterator::__construct() - Construct a directory using glob
  • count() - Bir dizideki eleman sayısını veya bir nesnedeki özellik sayısını döndürür
  • glob() - Bir kalıpla eşleşen dosya yollarını bulur

GlobIterator::__construct
InfiniteIterator
GlobIterator


The InfiniteIterator class

(PHP 5 >= 5.1.0, PHP 7)

Giriş

The InfiniteIterator allows one to infinitely iterate over an iterator without having to manually rewind the iterator upon reaching its end.

Sınıf Sözdizimi

InfiniteIterator extends IteratorIterator implements OuterIterator {
/* Yöntemler */
public __construct ( Iterator $iterator )
public void next ( void )
/* Miras alınan yöntemler */
public IteratorIterator::__construct ( Traversable $iterator )
public mixed IteratorIterator::current ( void )
public Traversable IteratorIterator::getInnerIterator ( void )
public scalar IteratorIterator::key ( void )
public void IteratorIterator::next ( void )
public void IteratorIterator::rewind ( void )
public bool IteratorIterator::valid ( void )
}

İçindekiler

  • InfiniteIterator::__construct — Constructs an InfiniteIterator
  • InfiniteIterator::next — Moves the inner Iterator forward or rewinds it
GlobIterator::count
InfiniteIterator::__construct
Iterators


Constructs an InfiniteIterator

InfiniteIterator
InfiniteIterator::next
InfiniteIterator
PHP Manual

InfiniteIterator::__construct

(PHP 5 >= 5.1.0, PHP 7)

InfiniteIterator::__construct — Constructs an InfiniteIterator

Açıklama

public InfiniteIterator::__construct ( Iterator $iterator )

Constructs an InfiniteIterator from an Iterator.

Değiştirgeler

iterator

The iterator to infinitely iterate over.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

Throws an E_RECOVERABLE_ERROR if the iterator parameter is not an Iterator.

Örnekler

Örnek 1 InfiniteIterator::__construct() example

<?php
$arrayit  = new ArrayIterator(array('cat','dog'));
$infinite = new InfiniteIterator($arrayit);
$limit    = new LimitIterator($infinite, 0, 7);
foreach($limit as $value)
{
    echo "$value\n";
}
?>

Yukarıdaki örneğin çıktısı:

cat
dog
cat
dog
cat
dog
cat

Ayrıca Bakınız

  • InfiniteIterator::next() - Moves the inner Iterator forward or rewinds it

InfiniteIterator
InfiniteIterator::next
InfiniteIterator


Moves the inner Iterator forward or rewinds it

InfiniteIterator::__construct
IteratorIterator
InfiniteIterator
PHP Manual

InfiniteIterator::next

(PHP 5 >= 5.1.0, PHP 7)

InfiniteIterator::next — Moves the inner Iterator forward or rewinds it

Açıklama

public void InfiniteIterator::next ( void )

Moves the inner Iterator forward to its next element if there is one, otherwise rewinds the inner Iterator back to the beginning.

Bilginize:

Even an InfiniteIterator stops if its inner Iterator is empty.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • InfiniteIterator::__construct() - Constructs an InfiniteIterator

InfiniteIterator::__construct
IteratorIterator
InfiniteIterator


The IteratorIterator class

(PHP 5 >= 5.1.0, PHP 7)

Giriş

This iterator wrapper allows the conversion of anything that is Traversable into an Iterator. It is important to understand that most classes that do not implement Iterators have reasons as most likely they do not allow the full Iterator feature set. If so, techniques should be provided to prevent misuse, otherwise expect exceptions or fatal errors.

Sınıf Sözdizimi

IteratorIterator implements OuterIterator {
/* Yöntemler */
public __construct ( Traversable $iterator )
public mixed current ( void )
public Traversable getInnerIterator ( void )
public scalar key ( void )
public void next ( void )
public void rewind ( void )
public bool valid ( void )
}

Notlar

Bilginize:

This class permits access to methods of the inner iterator via the __call magic method.

İçindekiler

  • IteratorIterator::__construct — Create an iterator from anything that is traversable
  • IteratorIterator::current — Get the current value
  • IteratorIterator::getInnerIterator — Get the inner iterator
  • IteratorIterator::key — Get the key of the current element
  • IteratorIterator::next — Forward to the next element
  • IteratorIterator::rewind — Rewind to the first element
  • IteratorIterator::valid — Checks if the iterator is valid
InfiniteIterator::next
IteratorIterator::__construct
Iterators


Create an iterator from anything that is traversable

IteratorIterator
IteratorIterator::current
IteratorIterator
PHP Manual

IteratorIterator::__construct

(PHP 5 >= 5.1.0, PHP 7)

IteratorIterator::__construct — Create an iterator from anything that is traversable

Açıklama

public IteratorIterator::__construct ( Traversable $iterator )

Creates an iterator from anything that is traversable.

Değiştirgeler

iterator

The traversable iterator.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • Traversable

IteratorIterator
IteratorIterator::current
IteratorIterator


Get the current value

IteratorIterator::__construct
IteratorIterator::getInnerIterator
IteratorIterator
PHP Manual

IteratorIterator::current

(PHP 5 >= 5.1.0, PHP 7)

IteratorIterator::current — Get the current value

Açıklama

public mixed IteratorIterator::current ( void )

Get the value of the current element.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The value of the current element.

Ayrıca Bakınız

  • IteratorIterator::key() - Get the key of the current element

IteratorIterator::__construct
IteratorIterator::getInnerIterator
IteratorIterator


Get the inner iterator

IteratorIterator::current
IteratorIterator::key
IteratorIterator
PHP Manual

IteratorIterator::getInnerIterator

(PHP 5 >= 5.1.0, PHP 7)

IteratorIterator::getInnerIterator — Get the inner iterator

Açıklama

public Traversable IteratorIterator::getInnerIterator ( void )

Get the inner iterator.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The inner iterator as passed to IteratorIterator::__construct().

Ayrıca Bakınız

  • Iterator
  • OuterIterator

IteratorIterator::current
IteratorIterator::key
IteratorIterator


Get the key of the current element

IteratorIterator::getInnerIterator
IteratorIterator::next
IteratorIterator
PHP Manual

IteratorIterator::key

(PHP 5 >= 5.1.0, PHP 7)

IteratorIterator::key — Get the key of the current element

Açıklama

public scalar IteratorIterator::key ( void )

Get the key of the current element.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The key of the current element.

Ayrıca Bakınız

  • IteratorIterator::current() - Get the current value

IteratorIterator::getInnerIterator
IteratorIterator::next
IteratorIterator


Forward to the next element

IteratorIterator::key
IteratorIterator::rewind
IteratorIterator
PHP Manual

IteratorIterator::next

(PHP 5 >= 5.1.0, PHP 7)

IteratorIterator::next — Forward to the next element

Açıklama

public void IteratorIterator::next ( void )

Forward to the next element.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • IteratorIterator::rewind() - Rewind to the first element
  • IteratorIterator::valid() - Checks if the iterator is valid

IteratorIterator::key
IteratorIterator::rewind
IteratorIterator


Rewind to the first element

IteratorIterator::next
IteratorIterator::valid
IteratorIterator
PHP Manual

IteratorIterator::rewind

(PHP 5 >= 5.1.0, PHP 7)

IteratorIterator::rewind — Rewind to the first element

Açıklama

public void IteratorIterator::rewind ( void )

Rewinds to the first element.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • IteratorIterator::next() - Forward to the next element
  • IteratorIterator::valid() - Checks if the iterator is valid

IteratorIterator::next
IteratorIterator::valid
IteratorIterator


Checks if the iterator is valid

IteratorIterator::rewind
LimitIterator
IteratorIterator
PHP Manual

IteratorIterator::valid

(PHP 5 >= 5.1.0, PHP 7)

IteratorIterator::valid — Checks if the iterator is valid

Açıklama

public bool IteratorIterator::valid ( void )

Checks if the iterator is valid.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the iterator is valid, otherwise FALSE

Ayrıca Bakınız

  • iterator_count() - Count the elements in an iterator
  • IteratorIterator::current() - Get the current value

IteratorIterator::rewind
LimitIterator
IteratorIterator


The LimitIterator class

(PHP 5 >= 5.1.0, PHP 7)

Giriş

The LimitIterator class allows iteration over a limited subset of items in an Iterator.

Sınıf Sözdizimi

LimitIterator extends IteratorIterator implements OuterIterator {
/* Yöntemler */
public __construct ( Iterator $iterator [, int $offset = 0 [, int $count = -1 ]] )
public mixed current ( void )
public Iterator getInnerIterator ( void )
public int getPosition ( void )
public mixed key ( void )
public void next ( void )
public void rewind ( void )
public int seek ( int $position )
public bool valid ( void )
}

Örnekler

Örnek 1 LimitIterator usage example

<?php

// Create an iterator to be limited
$fruits = new ArrayIterator(array(
    'apple',
    'banana',
    'cherry',
    'damson',
    'elderberry'
));

// Loop over first three fruits only
foreach (new LimitIterator($fruits, 0, 3) as $fruit) {
    var_dump($fruit);
}

echo "\n";

// Loop from third fruit until the end
// Note: offset starts from zero for apple
foreach (new LimitIterator($fruits, 2) as $fruit) {
    var_dump($fruit);
}

?>

Yukarıdaki örneğin çıktısı:

string(5) "apple"
string(6) "banana"
string(6) "cherry"

string(6) "cherry"
string(6) "damson"
string(10) "elderberry"

İçindekiler

  • LimitIterator::__construct — Construct a LimitIterator
  • LimitIterator::current — Get current element
  • LimitIterator::getInnerIterator — Get inner iterator
  • LimitIterator::getPosition — Return the current position
  • LimitIterator::key — Get current key
  • LimitIterator::next — Move the iterator forward
  • LimitIterator::rewind — Rewind the iterator to the specified starting offset
  • LimitIterator::seek — Seek to the given position
  • LimitIterator::valid — Check whether the current element is valid
IteratorIterator::valid
LimitIterator::__construct
Iterators


Construct a LimitIterator

LimitIterator
LimitIterator::current
LimitIterator
PHP Manual

LimitIterator::__construct

(PHP 5 >= 5.1.0, PHP 7)

LimitIterator::__construct — Construct a LimitIterator

Açıklama

public LimitIterator::__construct ( Iterator $iterator [, int $offset = 0 [, int $count = -1 ]] )

Constructs a new LimitIterator from an iterator with a given starting offset and maximum count.

Değiştirgeler

iterator

The Iterator to limit.

offset

Optional offset of the limit.

count

Optional count of the limit.

Dönen Değerler

The new LimitIterator.

Hatalar/İstisnalar

Throws an OutOfRangeException if the offset is less than 0 or the count is less than -1.

Örnekler

Örnek 1 LimitIterator::__construct() example

<?php
$ait = new ArrayIterator(array('a', 'b', 'c', 'd', 'e'));
$lit = new LimitIterator($ait, 1, 3);
foreach ($lit as $value) {
    echo $value . "\n";
}
?>

Yukarıdaki örneğin çıktısı:

b
c
d

Ayrıca Bakınız

  • LimitIterator examples

LimitIterator
LimitIterator::current
LimitIterator


Get current element

LimitIterator::__construct
LimitIterator::getInnerIterator
LimitIterator
PHP Manual

LimitIterator::current

(PHP 5 >= 5.1.0, PHP 7)

LimitIterator::current — Get current element

Açıklama

public mixed LimitIterator::current ( void )

Gets the current element of the inner Iterator.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the current element or NULL if there is none.

Ayrıca Bakınız

  • LimitIterator::key() - Get current key
  • LimitIterator::next() - Move the iterator forward
  • LimitIterator::rewind() - Rewind the iterator to the specified starting offset
  • LimitIterator::seek() - Seek to the given position
  • LimitIterator::valid() - Check whether the current element is valid

LimitIterator::__construct
LimitIterator::getInnerIterator
LimitIterator


Get inner iterator

LimitIterator::current
LimitIterator::getPosition
LimitIterator
PHP Manual

LimitIterator::getInnerIterator

(PHP 5 >= 5.1.0, PHP 7)

LimitIterator::getInnerIterator — Get inner iterator

Açıklama

public Iterator LimitIterator::getInnerIterator ( void )

Gets the inner Iterator.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The inner iterator passed to LimitIterator::__construct().

Ayrıca Bakınız

  • LimitIterator::__construct() - Construct a LimitIterator
  • IteratorIterator::getInnerIterator() - Get the inner iterator

LimitIterator::current
LimitIterator::getPosition
LimitIterator


Return the current position

LimitIterator::getInnerIterator
LimitIterator::key
LimitIterator
PHP Manual

LimitIterator::getPosition

(PHP 5 >= 5.1.0, PHP 7)

LimitIterator::getPosition — Return the current position

Açıklama

public int LimitIterator::getPosition ( void )

Gets the current zero-based position of the inner Iterator.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current position.

Örnekler

Örnek 1 LimitIterator::getPosition() example

<?php
$fruits = array(
    'a' => 'apple',
    'b' => 'banana',
    'c' => 'cherry',
    'd' => 'damson',
    'e' => 'elderberry'
);
$array_it = new ArrayIterator($fruits);
$limit_it = new LimitIterator($array_it, 2, 3);
foreach ($limit_it as $item) {
    echo $limit_it->getPosition() . ' ' . $item . "\n";
}
?>

Yukarıdaki örneğin çıktısı:

2 cherry
3 damson
4 elderberry

Ayrıca Bakınız

  • FilterIterator::key() - Get the current key

LimitIterator::getInnerIterator
LimitIterator::key
LimitIterator


Get current key

LimitIterator::getPosition
LimitIterator::next
LimitIterator
PHP Manual

LimitIterator::key

(PHP 5 >= 5.1.0, PHP 7)

LimitIterator::key — Get current key

Açıklama

public mixed LimitIterator::key ( void )

Gets the key for the current item in the inner Iterator.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the key for the current item.

Ayrıca Bakınız

  • LimitIterator::getPosition() - Return the current position
  • LimitIterator::current() - Get current element
  • LimitIterator::next() - Move the iterator forward
  • LimitIterator::rewind() - Rewind the iterator to the specified starting offset
  • LimitIterator::seek() - Seek to the given position
  • LimitIterator::valid() - Check whether the current element is valid

LimitIterator::getPosition
LimitIterator::next
LimitIterator


Move the iterator forward

LimitIterator::key
LimitIterator::rewind
LimitIterator
PHP Manual

LimitIterator::next

(PHP 5 >= 5.1.0, PHP 7)

LimitIterator::next — Move the iterator forward

Açıklama

public void LimitIterator::next ( void )

Moves the iterator forward.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • LimitIterator::current() - Get current element
  • LimitIterator::key() - Get current key
  • LimitIterator::rewind() - Rewind the iterator to the specified starting offset
  • LimitIterator::seek() - Seek to the given position
  • LimitIterator::valid() - Check whether the current element is valid

LimitIterator::key
LimitIterator::rewind
LimitIterator


Rewind the iterator to the specified starting offset

LimitIterator::next
LimitIterator::seek
LimitIterator
PHP Manual

LimitIterator::rewind

(PHP 5 >= 5.1.0, PHP 7)

LimitIterator::rewind — Rewind the iterator to the specified starting offset

Açıklama

public void LimitIterator::rewind ( void )

Rewinds the iterator to the starting offset specified in LimitIterator::__construct().

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • LimitIterator::current() - Get current element
  • LimitIterator::key() - Get current key
  • LimitIterator::next() - Move the iterator forward
  • LimitIterator::seek() - Seek to the given position
  • LimitIterator::valid() - Check whether the current element is valid

LimitIterator::next
LimitIterator::seek
LimitIterator


Seek to the given position

LimitIterator::rewind
LimitIterator::valid
LimitIterator
PHP Manual

LimitIterator::seek

(PHP 5 >= 5.1.0, PHP 7)

LimitIterator::seek — Seek to the given position

Açıklama

public int LimitIterator::seek ( int $position )

Moves the iterator to the offset specified by position.

Değiştirgeler

position

The position to seek to.

Dönen Değerler

Returns the offset position after seeking.

Hatalar/İstisnalar

Throws an OutOfBoundsException if the position is outside of the limits specified in LimitIterator::__construct().

Ayrıca Bakınız

  • LimitIterator::current() - Get current element
  • LimitIterator::key() - Get current key
  • LimitIterator::rewind() - Rewind the iterator to the specified starting offset
  • LimitIterator::next() - Move the iterator forward
  • LimitIterator::valid() - Check whether the current element is valid

LimitIterator::rewind
LimitIterator::valid
LimitIterator


Check whether the current element is valid

LimitIterator::seek
MultipleIterator
LimitIterator
PHP Manual

LimitIterator::valid

(PHP 5 >= 5.1.0, PHP 7)

LimitIterator::valid — Check whether the current element is valid

Açıklama

public bool LimitIterator::valid ( void )

Checks whether the current element is valid.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • LimitIterator::current() - Get current element
  • LimitIterator::key() - Get current key
  • LimitIterator::rewind() - Rewind the iterator to the specified starting offset
  • LimitIterator::next() - Move the iterator forward
  • LimitIterator::seek() - Seek to the given position

LimitIterator::seek
MultipleIterator
LimitIterator


The MultipleIterator class

(PHP 5 >= 5.3.0, PHP 7)

Giriş

An Iterator that sequentially iterates over all attached iterators

Sınıf Sözdizimi

MultipleIterator implements Iterator {
/* Sabitler */
const integer MIT_NEED_ANY = 0 ;
const integer MIT_NEED_ALL = 1 ;
const integer MIT_KEYS_NUMERIC = 0 ;
const integer MIT_KEYS_ASSOC = 2 ;
/* Yöntemler */
public __construct ([ int $flags = MultipleIterator::MIT_NEED_ALL|MultipleIterator::MIT_KEYS_NUMERIC ] )
public void attachIterator ( Iterator $iterator [, string $infos ] )
public bool containsIterator ( Iterator $iterator )
public int countIterators ( void )
public array current ( void )
public void detachIterator ( Iterator $iterator )
public int getFlags ( void )
public array key ( void )
public void next ( void )
public void rewind ( void )
public void setFlags ( int $flags )
public bool valid ( void )
}

Öntanımlı Sabitler

MultipleIterator::MIT_NEED_ANY

Do not require all sub iterators to be valid in iteration.

MultipleIterator::MIT_NEED_ALL

Require all sub iterators to be valid in iteration.

MultipleIterator::MIT_KEYS_NUMERIC

Keys are created from the sub iterators position.

MultipleIterator::MIT_KEYS_ASSOC

Keys are created from sub iterators associated information.

İçindekiler

  • MultipleIterator::attachIterator — Attaches iterator information
  • MultipleIterator::__construct — Constructs a new MultipleIterator
  • MultipleIterator::containsIterator — Checks if an iterator is attached
  • MultipleIterator::countIterators — Gets the number of attached iterator instances
  • MultipleIterator::current — Gets the registered iterator instances
  • MultipleIterator::detachIterator — Detaches an iterator
  • MultipleIterator::getFlags — Gets the flag information
  • MultipleIterator::key — Gets the registered iterator instances
  • MultipleIterator::next — Moves all attached iterator instances forward
  • MultipleIterator::rewind — Rewinds all attached iterator instances
  • MultipleIterator::setFlags — Sets flags
  • MultipleIterator::valid — Checks the validity of sub iterators
LimitIterator::valid
MultipleIterator::attachIterator
Iterators


Attaches iterator information

MultipleIterator
MultipleIterator::__construct
MultipleIterator
PHP Manual

MultipleIterator::attachIterator

(PHP 5 >= 5.3.0, PHP 7)

MultipleIterator::attachIterator — Attaches iterator information

Açıklama

public void MultipleIterator::attachIterator ( Iterator $iterator [, string $infos ] )

Attaches iterator information.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

iterator

The new iterator to attach.

infos

The associative information for the Iterator, which must be an integer, a string, or NULL.

Dönen Değerler

Description...

Hatalar/İstisnalar

An IllegalValueException if the iterator parameter is invalid, or if infos is already associated information.

Ayrıca Bakınız

  • MultipleIterator::__construct() - Constructs a new MultipleIterator

MultipleIterator
MultipleIterator::__construct
MultipleIterator


Constructs a new MultipleIterator

MultipleIterator::attachIterator
MultipleIterator::containsIterator
MultipleIterator
PHP Manual

MultipleIterator::__construct

(PHP 5 >= 5.3.0, PHP 7)

MultipleIterator::__construct — Constructs a new MultipleIterator

Açıklama

public MultipleIterator::__construct ([ int $flags = MultipleIterator::MIT_NEED_ALL|MultipleIterator::MIT_KEYS_NUMERIC ] )

Construct a new MultipleIterator.

Değiştirgeler

flags

The flags to set, according to the Flag Constants.

  • MultipleIterator::MIT_NEED_ALL or MultipleIterator::MIT_NEED_ANY
  • MultipleIterator::MIT_KEYS_NUMERIC or MultipleIterator::MIT_KEYS_ASSOC

Defaults to MultipleIterator::MIT_NEED_ALL|MultipleIterator::MIT_KEYS_NUMERIC.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Iterating a MultipleIterator

<?php
$people = new ArrayIterator(array('John', 'Jane', 'Jack', 'Judy'));
$roles  = new ArrayIterator(array('Developer', 'Scrum Master', 'Project Owner'));

$team = new MultipleIterator($flags);
$team->attachIterator($people, 'person');
$team->attachIterator($roles, 'role');

foreach ($team as $member) {
    print_r($member);
}
?>

Output with $flags = MIT_NEED_ALL|MIT_KEYS_NUMERIC

Array
(
    [0] => John
    [1] => Developer
)
Array
(
    [0] => Jane
    [1] => Scrum Master
)
Array
(
    [0] => Jack
    [1] => Project Owner
)

Output with $flags = MIT_NEED_ANY|MIT_KEYS_NUMERIC

Array
(
    [0] => John
    [1] => Developer
)
Array
(
    [0] => Jane
    [1] => Scrum Master
)
Array
(
    [0] => Jack
    [1] => Project Owner
)
Array
(
    [0] => Judy
    [1] =>
)

Output with $flags = MIT_NEED_ALL|MIT_KEYS_ASSOC

Array
(
    [person] => John
    [role] => Developer
)
Array
(
    [person] => Jane
    [role] => Scrum Master
)
Array
(
    [person] => Jack
    [role] => Project Owner
)

Output with $flags = MIT_NEED_ANY|MIT_KEYS_ASSOC

Array
(
    [person] => John
    [role] => Developer
)
Array
(
    [person] => Jane
    [role] => Scrum Master
)
Array
(
    [person] => Jack
    [role] => Project Owner
)
Array
(
    [person] => Judy
    [role] =>
)

Ayrıca Bakınız

  • Flag Constants
  • MultipleIterator::valid() - Checks the validity of sub iterators

MultipleIterator::attachIterator
MultipleIterator::containsIterator
MultipleIterator


Checks if an iterator is attached

MultipleIterator::__construct
MultipleIterator::countIterators
MultipleIterator
PHP Manual

MultipleIterator::containsIterator

(PHP 5 >= 5.3.0, PHP 7)

MultipleIterator::containsIterator — Checks if an iterator is attached

Açıklama

public bool MultipleIterator::containsIterator ( Iterator $iterator )

Checks if an iterator is attached or not.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

iterator

The iterator to check.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • MultipleIterator::valid() - Checks the validity of sub iterators

MultipleIterator::__construct
MultipleIterator::countIterators
MultipleIterator


Gets the number of attached iterator instances

MultipleIterator::containsIterator
MultipleIterator::current
MultipleIterator
PHP Manual

MultipleIterator::countIterators

(PHP 5 >= 5.3.0, PHP 7)

MultipleIterator::countIterators — Gets the number of attached iterator instances

Açıklama

public int MultipleIterator::countIterators ( void )

Gets the number of attached iterator instances.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The number of attached iterator instances (as an integer).

Ayrıca Bakınız

  • MultipleIterator::containsIterator() - Checks if an iterator is attached

MultipleIterator::containsIterator
MultipleIterator::current
MultipleIterator


Gets the registered iterator instances

MultipleIterator::countIterators
MultipleIterator::detachIterator
MultipleIterator
PHP Manual

MultipleIterator::current

(PHP 5 >= 5.3.0, PHP 7)

MultipleIterator::current — Gets the registered iterator instances

Açıklama

public array MultipleIterator::current ( void )

Get the registered iterator instances current() result.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

An array containing the current values of each attached iterator, or FALSE if no iterators are attached.

Hatalar/İstisnalar

A RuntimeException if mode MIT_NEED_ALL is set and at least one attached iterator is not valid. Or an IllegalValueException if a key is NULL and MIT_KEYS_ASSOC is set.

Ayrıca Bakınız

  • MultipleIterator::valid() - Checks the validity of sub iterators

MultipleIterator::countIterators
MultipleIterator::detachIterator
MultipleIterator


Detaches an iterator

MultipleIterator::current
MultipleIterator::getFlags
MultipleIterator
PHP Manual

MultipleIterator::detachIterator

(PHP 5 >= 5.3.0, PHP 7)

MultipleIterator::detachIterator — Detaches an iterator

Açıklama

public void MultipleIterator::detachIterator ( Iterator $iterator )

Detaches an iterator.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

iterator

The iterator to detach.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • MultipleIterator::attachIterator() - Attaches iterator information

MultipleIterator::current
MultipleIterator::getFlags
MultipleIterator


Gets the flag information

MultipleIterator::detachIterator
MultipleIterator::key
MultipleIterator
PHP Manual

MultipleIterator::getFlags

(PHP 5 >= 5.3.0, PHP 7)

MultipleIterator::getFlags — Gets the flag information

Açıklama

public int MultipleIterator::getFlags ( void )

Gets information about the flags.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Information about the flags, as an integer.

Ayrıca Bakınız

  • Flag Constants
  • MultipleIterator::__construct() - Constructs a new MultipleIterator
  • MultipleIterator::setFlags() - Sets flags

MultipleIterator::detachIterator
MultipleIterator::key
MultipleIterator


Gets the registered iterator instances

MultipleIterator::getFlags
MultipleIterator::next
MultipleIterator
PHP Manual

MultipleIterator::key

(PHP 5 >= 5.3.0, PHP 7)

MultipleIterator::key — Gets the registered iterator instances

Açıklama

public array MultipleIterator::key ( void )

Get the registered iterator instances key() result.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

An array of all registered iterator instances, or FALSE if no sub iterator is attached.

Hatalar/İstisnalar

A LogicException if mode MIT_NEED_ALL is set, and at least one attached iterator is not valid.

Calling this method from foreach triggers warning "Illegal type returned".

Ayrıca Bakınız

  • MultipleIterator::current() - Gets the registered iterator instances

MultipleIterator::getFlags
MultipleIterator::next
MultipleIterator


Moves all attached iterator instances forward

MultipleIterator::key
MultipleIterator::rewind
MultipleIterator
PHP Manual

MultipleIterator::next

(PHP 5 >= 5.3.0, PHP 7)

MultipleIterator::next — Moves all attached iterator instances forward

Açıklama

public void MultipleIterator::next ( void )

Moves all attached iterator instances forward.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • MultipleIterator::rewind() - Rewinds all attached iterator instances

MultipleIterator::key
MultipleIterator::rewind
MultipleIterator


Rewinds all attached iterator instances

MultipleIterator::next
MultipleIterator::setFlags
MultipleIterator
PHP Manual

MultipleIterator::rewind

(PHP 5 >= 5.3.0, PHP 7)

MultipleIterator::rewind — Rewinds all attached iterator instances

Açıklama

public void MultipleIterator::rewind ( void )

Rewinds all attached iterator instances.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • MultipleIterator::next() - Moves all attached iterator instances forward

MultipleIterator::next
MultipleIterator::setFlags
MultipleIterator


Sets flags

MultipleIterator::rewind
MultipleIterator::valid
MultipleIterator
PHP Manual

MultipleIterator::setFlags

(PHP 5 >= 5.3.0, PHP 7)

MultipleIterator::setFlags — Sets flags

Açıklama

public void MultipleIterator::setFlags ( int $flags )

Sets flags.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

flags

The flags to set, according to the Flag Constants

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • Flag Constants
  • MultipleIterator::__construct() - Constructs a new MultipleIterator
  • MultipleIterator::getFlags() - Gets the flag information

MultipleIterator::rewind
MultipleIterator::valid
MultipleIterator


Checks the validity of sub iterators

MultipleIterator::setFlags
NoRewindIterator
MultipleIterator
PHP Manual

MultipleIterator::valid

(PHP 5 >= 5.3.0, PHP 7)

MultipleIterator::valid — Checks the validity of sub iterators

Açıklama

public bool MultipleIterator::valid ( void )

Checks the validity of sub iterators.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if one or all sub iterators are valid depending on flags, otherwise FALSE

Ayrıca Bakınız

  • MultipleIterator::__construct() - Constructs a new MultipleIterator

MultipleIterator::setFlags
NoRewindIterator
MultipleIterator


The NoRewindIterator class

(PHP 5 >= 5.1.0, PHP 7)

Giriş

This iterator cannot be rewound.

Sınıf Sözdizimi

NoRewindIterator extends IteratorIterator {
/* Yöntemler */
public __construct ( Iterator $iterator )
public mixed current ( void )
public iterator getInnerIterator ( void )
public mixed key ( void )
public void next ( void )
public void rewind ( void )
public bool valid ( void )
/* Miras alınan yöntemler */
public IteratorIterator::__construct ( Traversable $iterator )
public mixed IteratorIterator::current ( void )
public Traversable IteratorIterator::getInnerIterator ( void )
public scalar IteratorIterator::key ( void )
public void IteratorIterator::next ( void )
public void IteratorIterator::rewind ( void )
public bool IteratorIterator::valid ( void )
}

İçindekiler

  • NoRewindIterator::__construct — Construct a NoRewindIterator
  • NoRewindIterator::current — Get the current value
  • NoRewindIterator::getInnerIterator — Get the inner iterator
  • NoRewindIterator::key — Get the current key
  • NoRewindIterator::next — Forward to the next element
  • NoRewindIterator::rewind — Prevents the rewind operation on the inner iterator.
  • NoRewindIterator::valid — Validates the iterator
MultipleIterator::valid
NoRewindIterator::__construct
Iterators


Construct a NoRewindIterator

NoRewindIterator
NoRewindIterator::current
NoRewindIterator
PHP Manual

NoRewindIterator::__construct

(PHP 5 >= 5.1.0, PHP 7)

NoRewindIterator::__construct — Construct a NoRewindIterator

Açıklama

public NoRewindIterator::__construct ( Iterator $iterator )

Constructs a NoRewindIterator.

Değiştirgeler

iterator

The iterator being used.

Dönen Değerler

A NoRewindIterator() based on the passed in iterator.

Örnekler

Örnek 1 NoRewindIterator::__construct() example

The second loop does not output because the iterator is only used once, as it does not rewind.

<?php
$fruit = array('apple', 'banana', 'cranberry');

$arr = new ArrayObject($fruit);
$it  = new NoRewindIterator($arr->getIterator());

echo "Fruit A:\n";
foreach( $it as $item ) {
    echo $item . "\n";
}

echo "Fruit B:\n";
foreach( $it as $item ) {
    echo $item . "\n";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Fruit A:
apple
banana
cranberry
Fruit B:

Ayrıca Bakınız

  • NoRewindIterator::valid() - Validates the iterator

NoRewindIterator
NoRewindIterator::current
NoRewindIterator


Get the current value

NoRewindIterator::__construct
NoRewindIterator::getInnerIterator
NoRewindIterator
PHP Manual

NoRewindIterator::current

(PHP 5 >= 5.1.0, PHP 7)

NoRewindIterator::current — Get the current value

Açıklama

public mixed NoRewindIterator::current ( void )

Gets the current value.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current value.

Ayrıca Bakınız

  • NoRewindIterator::key() - Get the current key

NoRewindIterator::__construct
NoRewindIterator::getInnerIterator
NoRewindIterator


Get the inner iterator

NoRewindIterator::current
NoRewindIterator::key
NoRewindIterator
PHP Manual

NoRewindIterator::getInnerIterator

(PHP 5 >= 5.1.0, PHP 7)

NoRewindIterator::getInnerIterator — Get the inner iterator

Açıklama

public iterator NoRewindIterator::getInnerIterator ( void )

Gets the inner iterator, that was passed in to NoRewindIterator.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The inner iterator, as passed to NoRewindIterator::__construct().

Ayrıca Bakınız

  • NoRewindIterator::valid() - Validates the iterator

NoRewindIterator::current
NoRewindIterator::key
NoRewindIterator


Get the current key

NoRewindIterator::getInnerIterator
NoRewindIterator::next
NoRewindIterator
PHP Manual

NoRewindIterator::key

(PHP 5 >= 5.1.0, PHP 7)

NoRewindIterator::key — Get the current key

Açıklama

public mixed NoRewindIterator::key ( void )

Gets the current key.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current key.

Ayrıca Bakınız

  • NoRewindIterator::next() - Forward to the next element

NoRewindIterator::getInnerIterator
NoRewindIterator::next
NoRewindIterator


Forward to the next element

NoRewindIterator::key
NoRewindIterator::rewind
NoRewindIterator
PHP Manual

NoRewindIterator::next

(PHP 5 >= 5.1.0, PHP 7)

NoRewindIterator::next — Forward to the next element

Açıklama

public void NoRewindIterator::next ( void )

Forwards to the next element.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • NoRewindIterator::rewind() - Prevents the rewind operation on the inner iterator.

NoRewindIterator::key
NoRewindIterator::rewind
NoRewindIterator


Prevents the rewind operation on the inner iterator.

NoRewindIterator::next
NoRewindIterator::valid
NoRewindIterator
PHP Manual

NoRewindIterator::rewind

(PHP 5 >= 5.1.0, PHP 7)

NoRewindIterator::rewind — Prevents the rewind operation on the inner iterator.

Açıklama

public void NoRewindIterator::rewind ( void )

Prevents the rewind operation on the inner iterator.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 NoRewindIterator::rewind() example

This example demonstrates that calling rewind on a NoRewindIterator object has no effect.

<?php
$fruits = array("lemon", "orange", "apple", "pear");

$noRewindIterator = new NoRewindIterator(new ArrayIterator($fruits));

echo $noRewindIterator->current() . "\n";
$noRewindIterator->next();
// now rewind the iterator (nothing should happen)
$noRewindIterator->rewind();
echo $noRewindIterator->current() . "\n";
?>

Yukarıdaki örneğin çıktısı:

lemon
orange

NoRewindIterator::next
NoRewindIterator::valid
NoRewindIterator


Validates the iterator

NoRewindIterator::rewind
ParentIterator
NoRewindIterator
PHP Manual

NoRewindIterator::valid

(PHP 5 >= 5.1.0, PHP 7)

NoRewindIterator::valid — Validates the iterator

Açıklama

public bool NoRewindIterator::valid ( void )

Checks whether the iterator is valid.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • NoRewindIterator::getInnerIterator() - Get the inner iterator

NoRewindIterator::rewind
ParentIterator
NoRewindIterator


The ParentIterator class

(PHP 5 >= 5.1.0, PHP 7)

Giriş

This extended FilterIterator allows a recursive iteration using RecursiveIteratorIterator that only shows those elements which have children.

Sınıf Sözdizimi

ParentIterator extends RecursiveFilterIterator implements RecursiveIterator , OuterIterator {
/* Yöntemler */
public bool accept ( void )
public __construct ( RecursiveIterator $iterator )
public ParentIterator getChildren ( void )
public bool hasChildren ( void )
public void next ( void )
public void rewind ( void )
}

İçindekiler

  • ParentIterator::accept — Determines acceptability
  • ParentIterator::__construct — Constructs a ParentIterator
  • ParentIterator::getChildren — Return the inner iterator's children contained in a ParentIterator
  • ParentIterator::hasChildren — Check whether the inner iterator's current element has children
  • ParentIterator::next — Move the iterator forward
  • ParentIterator::rewind — Rewind the iterator
NoRewindIterator::valid
ParentIterator::accept
Iterators


Determines acceptability

ParentIterator
ParentIterator::__construct
ParentIterator
PHP Manual

ParentIterator::accept

(PHP 5 >= 5.1.0, PHP 7)

ParentIterator::accept — Determines acceptability

Açıklama

public bool ParentIterator::accept ( void )

Determines if the current element has children.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

TRUE if the current element is acceptable, otherwise FALSE.

Ayrıca Bakınız

  • ParentIterator::hasChildren() - Check whether the inner iterator's current element has children
  • FilterIterator::accept() - Check whether the current element of the iterator is acceptable

ParentIterator
ParentIterator::__construct
ParentIterator


Constructs a ParentIterator

ParentIterator::accept
ParentIterator::getChildren
ParentIterator
PHP Manual

ParentIterator::__construct

(PHP 5 >= 5.1.0, PHP 7)

ParentIterator::__construct — Constructs a ParentIterator

Açıklama

public ParentIterator::__construct ( RecursiveIterator $iterator )

Constructs a ParentIterator on an iterator.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

iterator

The iterator being constructed upon.

Dönen Değerler

The ParentIterator.

ParentIterator::accept
ParentIterator::getChildren
ParentIterator


Return the inner iterator's children contained in a ParentIterator

ParentIterator::__construct
ParentIterator::hasChildren
ParentIterator
PHP Manual

ParentIterator::getChildren

(PHP 5 >= 5.1.0, PHP 7)

ParentIterator::getChildren — Return the inner iterator's children contained in a ParentIterator

Açıklama

public ParentIterator ParentIterator::getChildren ( void )

Get the inner iterator's children contained in a ParentIterator.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

An object.

ParentIterator::__construct
ParentIterator::hasChildren
ParentIterator


Check whether the inner iterator's current element has children

ParentIterator::getChildren
ParentIterator::next
ParentIterator
PHP Manual

ParentIterator::hasChildren

(PHP 5 >= 5.1.0, PHP 7)

ParentIterator::hasChildren — Check whether the inner iterator's current element has children

Açıklama

public bool ParentIterator::hasChildren ( void )

Check whether the inner iterator's current element has children.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

ParentIterator::getChildren
ParentIterator::next
ParentIterator


Move the iterator forward

ParentIterator::hasChildren
ParentIterator::rewind
ParentIterator
PHP Manual

ParentIterator::next

(PHP 5 >= 5.1.0, PHP 7)

ParentIterator::next — Move the iterator forward

Açıklama

public void ParentIterator::next ( void )

Moves the iterator forward.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

ParentIterator::hasChildren
ParentIterator::rewind
ParentIterator


Rewind the iterator

ParentIterator::next
RecursiveArrayIterator
ParentIterator
PHP Manual

ParentIterator::rewind

(PHP 5 >= 5.1.0, PHP 7)

ParentIterator::rewind — Rewind the iterator

Açıklama

public void ParentIterator::rewind ( void )

Rewinds the iterator.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

ParentIterator::next
RecursiveArrayIterator
ParentIterator


The RecursiveArrayIterator class

(PHP 5 >= 5.1.0, PHP 7)

Giriş

This iterator allows to unset and modify values and keys while iterating over Arrays and Objects in the same way as the ArrayIterator. Additionally it is possible to iterate over the current iterator entry.

Sınıf Sözdizimi

RecursiveArrayIterator extends ArrayIterator implements RecursiveIterator {
/* Sabitler */
const integer CHILD_ARRAYS_ONLY = 4 ;
/* Yöntemler */
public RecursiveArrayIterator getChildren ( void )
public bool hasChildren ( void )
/* Inherits */
public void ArrayIterator::append ( mixed $value )
public void ArrayIterator::asort ( void )
public ArrayIterator::__construct ([ mixed $array = array() [, int $flags = 0 ]] )
public int ArrayIterator::count ( void )
public mixed ArrayIterator::current ( void )
public array ArrayIterator::getArrayCopy ( void )
public void ArrayIterator::getFlags ( void )
public mixed ArrayIterator::key ( void )
public void ArrayIterator::ksort ( void )
public void ArrayIterator::natcasesort ( void )
public void ArrayIterator::natsort ( void )
public void ArrayIterator::next ( void )
public void ArrayIterator::offsetExists ( string $index )
public mixed ArrayIterator::offsetGet ( string $index )
public void ArrayIterator::offsetSet ( string $index , string $newval )
public void ArrayIterator::offsetUnset ( string $index )
public void ArrayIterator::rewind ( void )
public void ArrayIterator::seek ( int $position )
public string ArrayIterator::serialize ( void )
public void ArrayIterator::setFlags ( string $flags )
public void ArrayIterator::uasort ( string $cmp_function )
public void ArrayIterator::uksort ( string $cmp_function )
public string ArrayIterator::unserialize ( string $serialized )
public bool ArrayIterator::valid ( void )
}

Öntanımlı Sabitler

RecursiveArrayIterator Flags

RecursiveArrayIterator::CHILD_ARRAYS_ONLY

Treat only arrays (not objects) as having children for recursive iteration.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | CHILD_ARRAYS_ONLY flag was added.

İçindekiler

  • RecursiveArrayIterator::getChildren — Returns an iterator for the current entry if it is an array or an object.
  • RecursiveArrayIterator::hasChildren — Returns whether current entry is an array or an object.
ParentIterator::rewind
RecursiveArrayIterator::getChildren
Iterators


Returns an iterator for the current entry if it is an array or an object.

RecursiveArrayIterator
RecursiveArrayIterator::hasChildren
RecursiveArrayIterator
PHP Manual

RecursiveArrayIterator::getChildren

(PHP 5 >= 5.1.0, PHP 7)

RecursiveArrayIterator::getChildren — Returns an iterator for the current entry if it is an array or an object.

Açıklama

public RecursiveArrayIterator RecursiveArrayIterator::getChildren ( void )

Returns an iterator for the current iterator entry.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

An iterator for the current entry, if it is an array or object.

Hatalar/İstisnalar

An InvalidArgumentException will be thrown if the current entry does not contain an array or an object.

Örnekler

Örnek 1 RecursiveArrayIterator::getChildren() example

<?php
$fruits = array("a" => "lemon", "b" => "orange", array("a" => "apple", "p" => "pear"));

$iterator = new RecursiveArrayIterator($fruits);

while ($iterator->valid()) {

    if ($iterator->hasChildren()) {
        // print all children
        foreach ($iterator->getChildren() as $key => $value) {
            echo $key . ' : ' . $value . "\n";
        }
    } else {
        echo "No children.\n";
    }

    $iterator->next();
}
?>

Yukarıdaki örneğin çıktısı:

No children.
No children.
a : apple
p : pear

Ayrıca Bakınız

  • RecursiveArrayIterator::hasChildren() - Returns whether current entry is an array or an object.

RecursiveArrayIterator
RecursiveArrayIterator::hasChildren
RecursiveArrayIterator


Returns whether current entry is an array or an object.

RecursiveArrayIterator::getChildren
RecursiveCachingIterator
RecursiveArrayIterator
PHP Manual

RecursiveArrayIterator::hasChildren

(PHP 5 >= 5.1.0, PHP 7)

RecursiveArrayIterator::hasChildren — Returns whether current entry is an array or an object.

Açıklama

public bool RecursiveArrayIterator::hasChildren ( void )

Returns whether current entry is an array or an object for which an iterator can be obtained via RecursiveArrayIterator::getChildren().

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the current entry is an array or an object, otherwise FALSE is returned.

Örnekler

Örnek 1 RecursiveArrayIterator::hasChildren() example

<?php
$fruits = array("a" => "lemon", "b" => "orange", array("a" => "apple", "p" => "pear"));

$iterator = new RecursiveArrayIterator($fruits);

while ($iterator->valid()) {

    // Check if there are children
    if ($iterator->hasChildren()) {
        // print all children
        foreach ($iterator->getChildren() as $key => $value) {
            echo $key . ' : ' . $value . "\n";
        }
    } else {
        echo "No children.\n";
    }

    $iterator->next();
}
?>

Yukarıdaki örneğin çıktısı:

No children.
No children.
a : apple
p : pear

Ayrıca Bakınız

  • RecursiveArrayIterator::getChildren() - Returns an iterator for the current entry if it is an array or an object.

RecursiveArrayIterator::getChildren
RecursiveCachingIterator
RecursiveArrayIterator


The RecursiveCachingIterator class

(PHP 5 >= 5.1.0, PHP 7)

Giriş

...

Sınıf Sözdizimi

RecursiveCachingIterator extends CachingIterator implements Countable , ArrayAccess , OuterIterator , RecursiveIterator {
/* Yöntemler */
public __construct ( Iterator $iterator [, string $flags = self::CALL_TOSTRING ] )
public RecursiveCachingIterator getChildren ( void )
public bool hasChildren ( void )
/* Inherits */
public CachingIterator::__construct ( Iterator $iterator [, int $flags = self::CALL_TOSTRING ] )
public int CachingIterator::count ( void )
public void CachingIterator::current ( void )
public array CachingIterator::getCache ( void )
public int CachingIterator::getFlags ( void )
public Iterator CachingIterator::getInnerIterator ( void )
public void CachingIterator::hasNext ( void )
public scalar CachingIterator::key ( void )
public void CachingIterator::next ( void )
public void CachingIterator::offsetExists ( string $index )
public void CachingIterator::offsetGet ( string $index )
public void CachingIterator::offsetSet ( string $index , string $newval )
public void CachingIterator::offsetUnset ( string $index )
public void CachingIterator::rewind ( void )
public void CachingIterator::setFlags ( int $flags )
public void CachingIterator::__toString ( void )
public void CachingIterator::valid ( void )
}

İçindekiler

  • RecursiveCachingIterator::__construct — Construct
  • RecursiveCachingIterator::getChildren — Return the inner iterator's children as a RecursiveCachingIterator
  • RecursiveCachingIterator::hasChildren — Check whether the current element of the inner iterator has children
RecursiveArrayIterator::hasChildren
RecursiveCachingIterator::__construct
Iterators


Construct

RecursiveCachingIterator
RecursiveCachingIterator::getChildren
RecursiveCachingIterator
PHP Manual

RecursiveCachingIterator::__construct

(PHP 5 >= 5.1.0, PHP 7)

RecursiveCachingIterator::__construct — Construct

Açıklama

public RecursiveCachingIterator::__construct ( Iterator $iterator [, string $flags = self::CALL_TOSTRING ] )

Constructs a new RecursiveCachingIterator, which consists of a passed in iterator.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

iterator

The iterator being used.

flags

The flags. Use CALL_TOSTRING to call RecursiveCachingIterator::__toString() for every element (the default), and/or CATCH_GET_CHILD to catch exceptions when trying to get children.

Dönen Değerler

The RecursiveCachingIterator.

Ayrıca Bakınız

  • CachingIterator::__construct() - Construct a new CachingIterator object for the iterator.

RecursiveCachingIterator
RecursiveCachingIterator::getChildren
RecursiveCachingIterator


Return the inner iterator's children as a RecursiveCachingIterator

RecursiveCachingIterator::__construct
RecursiveCachingIterator::hasChildren
RecursiveCachingIterator
PHP Manual

RecursiveCachingIterator::getChildren

(PHP 5 >= 5.1.0, PHP 7)

RecursiveCachingIterator::getChildren — Return the inner iterator's children as a RecursiveCachingIterator

Açıklama

public RecursiveCachingIterator RecursiveCachingIterator::getChildren ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The inner iterator's children, as a RecursiveCachingIterator.

RecursiveCachingIterator::__construct
RecursiveCachingIterator::hasChildren
RecursiveCachingIterator


Check whether the current element of the inner iterator has children

RecursiveCachingIterator::getChildren
RecursiveCallbackFilterIterator
RecursiveCachingIterator
PHP Manual

RecursiveCachingIterator::hasChildren

(PHP 5 >= 5.1.0, PHP 7)

RecursiveCachingIterator::hasChildren — Check whether the current element of the inner iterator has children

Açıklama

public bool RecursiveCachingIterator::hasChildren ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

TRUE if the inner iterator has children, otherwise FALSE

RecursiveCachingIterator::getChildren
RecursiveCallbackFilterIterator
RecursiveCachingIterator


The RecursiveCallbackFilterIterator class

(PHP 5 >= 5.4.0, PHP 7)

Giriş

Sınıf Sözdizimi

RecursiveCallbackFilterIterator extends CallbackFilterIterator implements OuterIterator , RecursiveIterator {
/* Yöntemler */
public __construct ( RecursiveIterator $iterator , string $callback )
public RecursiveCallbackFilterIterator getChildren ( void )
public bool hasChildren ( void )
/* Miras alınan yöntemler */
public string CallbackFilterIterator::accept ( void )
}

Örnekler

The callback should accept up to three arguments: the current item, the current key and the iterator, respectively.

Örnek 1 Available callback arguments

<?php

/**
 * Callback for RecursiveCallbackFilterIterator
 *
 * @param $current   Current item's value
 * @param $key       Current item's key
 * @param $iterator  Iterator being filtered
 * @return boolean   TRUE to accept the current item, FALSE otherwise
 */
function my_callback($current, $key, $iterator) {
    // Your filtering code here
}

?>

Filtering a recursive iterator generally involves two conditions. The first is that, to allow recursion, the callback function should return TRUE if the current iterator item has children. The second is the normal filter condition, such as a file size or extension check as in the example below.

Örnek 2 Recursive callback basic example

<?php

$dir = new RecursiveDirectoryIterator(__DIR__);

// Filter large files ( > 100MB)
$files = new RecursiveCallbackFilterIterator($dir, function ($current, $key, $iterator) {
    // Allow recursion
    if ($iterator->hasChildren()) {
        return TRUE;
    }
    // Check for large file
    if ($current->isFile() && $current->getSize() > 104857600) {
        return TRUE;
    }
    return FALSE;
});

foreach (new RecursiveIteratorIterator($files) as $file) {
    echo $file->getPathname() . PHP_EOL;
}

?>

İçindekiler

  • RecursiveCallbackFilterIterator::__construct — Create a RecursiveCallbackFilterIterator from a RecursiveIterator
  • RecursiveCallbackFilterIterator::getChildren — Return the inner iterator's children contained in a RecursiveCallbackFilterIterator
  • RecursiveCallbackFilterIterator::hasChildren — Check whether the inner iterator's current element has children
RecursiveCachingIterator::hasChildren
RecursiveCallbackFilterIterator::__construct
Iterators


Create a RecursiveCallbackFilterIterator from a RecursiveIterator

RecursiveCallbackFilterIterator
RecursiveCallbackFilterIterator::getChildren
RecursiveCallbackFilterIterator
PHP Manual

RecursiveCallbackFilterIterator::__construct

(PHP 5 >= 5.4.0, PHP 7)

RecursiveCallbackFilterIterator::__construct — Create a RecursiveCallbackFilterIterator from a RecursiveIterator

Açıklama

public RecursiveCallbackFilterIterator::__construct ( RecursiveIterator $iterator , string $callback )

Creates a filtered iterator from a RecursiveIterator using the callback to determine which items are accepted or rejected.

Değiştirgeler

iterator

The recursive iterator to be filtered.

callback

The callback, which should return TRUE to accept the current item or FALSE otherwise. See Examples.

May be any valid callable value.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • RecursiveCallbackFilterIterator Examples
  • RecursiveCallbackFilterIterator::getChildren() - Return the inner iterator's children contained in a RecursiveCallbackFilterIterator
  • RecursiveCallbackFilteriterator::hasChildren() - Check whether the inner iterator's current element has children

RecursiveCallbackFilterIterator
RecursiveCallbackFilterIterator::getChildren
RecursiveCallbackFilterIterator


Return the inner iterator's children contained in a RecursiveCallbackFilterIterator

RecursiveCallbackFilterIterator::__construct
RecursiveCallbackFilterIterator::hasChildren
RecursiveCallbackFilterIterator
PHP Manual

RecursiveCallbackFilterIterator::getChildren

(PHP 5 >= 5.4.0, PHP 7)

RecursiveCallbackFilterIterator::getChildren — Return the inner iterator's children contained in a RecursiveCallbackFilterIterator

Açıklama

public RecursiveCallbackFilterIterator RecursiveCallbackFilterIterator::getChildren ( void )

Fetches the filtered children of the inner iterator.

RecursiveCallbackFilterIterator::hasChildren() should be used to determine if there are children to be fetched.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a RecursiveCallbackFilterIterator containing the children.

Ayrıca Bakınız

  • RecursiveCallbackFilterIterator Examples
  • RecursiveCallbackFilterIterator::__construct() - Create a RecursiveCallbackFilterIterator from a RecursiveIterator
  • RecursiveCallbackFilteriterator::hasChildren() - Check whether the inner iterator's current element has children

RecursiveCallbackFilterIterator::__construct
RecursiveCallbackFilterIterator::hasChildren
RecursiveCallbackFilterIterator


Check whether the inner iterator's current element has children

RecursiveCallbackFilterIterator::getChildren
RecursiveDirectoryIterator
RecursiveCallbackFilterIterator
PHP Manual

RecursiveCallbackFilterIterator::hasChildren

(PHP 5 >= 5.4.0, PHP 7)

RecursiveCallbackFilterIterator::hasChildren — Check whether the inner iterator's current element has children

Açıklama

public bool RecursiveCallbackFilterIterator::hasChildren ( void )

Returns TRUE if the current element has children, FALSE otherwise.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the current element has children, FALSE otherwise.

Örnekler

Örnek 1 RecursiveCallbackFilterIterator::hasChildren() basic usage

<?php

$dir = new RecursiveDirectoryIterator(__DIR__);

// Recursively iterate over XML files
$files = new RecursiveCallbackFilterIterator($dir, function ($current, $key, $iterator) {
    // Allow recursion into directories
    if ($iterator->hasChildren()) {
        return TRUE;
    }
    // Check for XML file
    if (!strcasecmp($current->getExtension(), 'xml')) {
        return TRUE;
    }
    return FALSE;
});

?>

Ayrıca Bakınız

  • RecursiveCallbackFilterIterator Examples
  • RecursiveCallbackFilterIterator::__construct() - Create a RecursiveCallbackFilterIterator from a RecursiveIterator
  • RecursiveCallbackFilteriterator::getChildren() - Return the inner iterator's children contained in a RecursiveCallbackFilterIterator

RecursiveCallbackFilterIterator::getChildren
RecursiveDirectoryIterator
RecursiveCallbackFilterIterator


The RecursiveDirectoryIterator class

(PHP 5, PHP 7)

Giriş

The RecursiveDirectoryIterator provides an interface for iterating recursively over filesystem directories.

Sınıf Sözdizimi

RecursiveDirectoryIterator extends FilesystemIterator implements SeekableIterator , RecursiveIterator {
/* Yöntemler */
public __construct ( string $path [, int $flags = FilesystemIterator::KEY_AS_PATHNAME | FilesystemIterator::CURRENT_AS_FILEINFO ] )
public mixed getChildren ( void )
public string getSubPath ( void )
public string getSubPathname ( void )
public bool hasChildren ([ bool $allow_links = false ] )
public string key ( void )
public void next ( void )
public void rewind ( void )
/* Inherits */
public FilesystemIterator::__construct ( string $path [, int $flags = FilesystemIterator::KEY_AS_PATHNAME | FilesystemIterator::CURRENT_AS_FILEINFO | FilesystemIterator::SKIP_DOTS ] )
public mixed FilesystemIterator::current ( void )
public int FilesystemIterator::getFlags ( void )
public string FilesystemIterator::key ( void )
public void FilesystemIterator::next ( void )
public void FilesystemIterator::rewind ( void )
public void FilesystemIterator::setFlags ([ int $flags ] )
}

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | The FilesystemIterator was introduced as the parent class. Previously, the parent was the DirectoryIterator.
5.3.0 | Implements SeekableIterator.
5.2.11, 5.3.1 | Added RecursiveDirectoryIterator::FOLLOW_SYMLINKS

İçindekiler

  • RecursiveDirectoryIterator::__construct — Constructs a RecursiveDirectoryIterator
  • RecursiveDirectoryIterator::getChildren — Returns an iterator for the current entry if it is a directory
  • RecursiveDirectoryIterator::getSubPath — Get sub path
  • RecursiveDirectoryIterator::getSubPathname — Get sub path and name
  • RecursiveDirectoryIterator::hasChildren — Returns whether current entry is a directory and not '.' or '..'
  • RecursiveDirectoryIterator::key — Return path and filename of current dir entry
  • RecursiveDirectoryIterator::next — Move to next entry
  • RecursiveDirectoryIterator::rewind — Rewind dir back to the start
RecursiveCallbackFilterIterator::hasChildren
RecursiveDirectoryIterator::__construct
Iterators


Constructs a RecursiveDirectoryIterator

RecursiveDirectoryIterator
RecursiveDirectoryIterator::getChildren
RecursiveDirectoryIterator
PHP Manual

RecursiveDirectoryIterator::__construct

(PHP 5 >= 5.1.2, PHP 7)

RecursiveDirectoryIterator::__construct — Constructs a RecursiveDirectoryIterator

Açıklama

public RecursiveDirectoryIterator::__construct ( string $path [, int $flags = FilesystemIterator::KEY_AS_PATHNAME | FilesystemIterator::CURRENT_AS_FILEINFO ] )

Constructs a RecursiveDirectoryIterator() for the provided path.

Değiştirgeler

path

The path of the directory to be iterated over.

flags

Flags may be provided which will affect the behavior of some methods. A list of the flags can found under FilesystemIterator predefined constants. They can also be set later with FilesystemIterator::setFlags().

Dönen Değerler

Returns the newly created RecursiveDirectoryIterator.

Hatalar/İstisnalar

Throws an UnexpectedValueException if the path cannot be found or is not a directory.

Örnekler

Örnek 1 RecursiveDirectoryIterator example

<?php

$directory = '/tmp';

$it = new RecursiveIteratorIterator(new RecursiveDirectoryIterator($directory));

$it->rewind();
while($it->valid()) {

    if (!$it->isDot()) {
        echo 'SubPathName: ' . $it->getSubPathName() . "\n";
        echo 'SubPath:     ' . $it->getSubPath() . "\n";
        echo 'Key:         ' . $it->key() . "\n\n";
    }

    $it->next();
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

SubPathName: fruit/apple.xml
SubPath:     fruit
Key:         /tmp/fruit/apple.xml

SubPathName: stuff.xml
SubPath:
Key:         /tmp/stuff.xml

SubPathName: veggies/carrot.xml
SubPath:     veggies
Key:         /tmp/veggies/carrot.xml

Ayrıca Bakınız

  • FilesystemIterator::__construct() - Constructs a new filesystem iterator
  • RecursiveIteratorIterator::__construct() - Construct a RecursiveIteratorIterator
  • FilesystemIterator predefined constants

RecursiveDirectoryIterator
RecursiveDirectoryIterator::getChildren
RecursiveDirectoryIterator


Returns an iterator for the current entry if it is a directory

RecursiveDirectoryIterator::__construct
RecursiveDirectoryIterator::getSubPath
RecursiveDirectoryIterator
PHP Manual

RecursiveDirectoryIterator::getChildren

(PHP 5 >= 5.1.0, PHP 7)

RecursiveDirectoryIterator::getChildren — Returns an iterator for the current entry if it is a directory

Açıklama

public mixed RecursiveDirectoryIterator::getChildren ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The filename, file information, or $this depending on the set flags. See the FilesystemIterator constants.

RecursiveDirectoryIterator::__construct
RecursiveDirectoryIterator::getSubPath
RecursiveDirectoryIterator


Get sub path

RecursiveDirectoryIterator::getChildren
RecursiveDirectoryIterator::getSubPathname
RecursiveDirectoryIterator
PHP Manual

RecursiveDirectoryIterator::getSubPath

(PHP 5 >= 5.1.0, PHP 7)

RecursiveDirectoryIterator::getSubPath — Get sub path

Açıklama

public string RecursiveDirectoryIterator::getSubPath ( void )

Gets the sub path.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The sub path (sub directory).

Ayrıca Bakınız

  • RecursiveDirectoryIterator::getSubPathName() - Get sub path and name
  • RecursiveDirectoryIterator::key() - Return path and filename of current dir entry

RecursiveDirectoryIterator::getChildren
RecursiveDirectoryIterator::getSubPathname
RecursiveDirectoryIterator


Get sub path and name

RecursiveDirectoryIterator::getSubPath
RecursiveDirectoryIterator::hasChildren
RecursiveDirectoryIterator
PHP Manual

RecursiveDirectoryIterator::getSubPathname

(PHP 5 >= 5.1.0, PHP 7)

RecursiveDirectoryIterator::getSubPathname — Get sub path and name

Açıklama

public string RecursiveDirectoryIterator::getSubPathname ( void )

Gets the sub path and filename.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The sub path (sub directory) and filename.

Ayrıca Bakınız

  • RecursiveDirectoryIterator::getSubPath() - Get sub path
  • RecursiveDirectoryIterator::key() - Return path and filename of current dir entry

RecursiveDirectoryIterator::getSubPath
RecursiveDirectoryIterator::hasChildren
RecursiveDirectoryIterator


Returns whether current entry is a directory and not '.' or '..'

RecursiveDirectoryIterator::getSubPathname
RecursiveDirectoryIterator::key
RecursiveDirectoryIterator
PHP Manual

RecursiveDirectoryIterator::hasChildren

(PHP 5, PHP 7)

RecursiveDirectoryIterator::hasChildren — Returns whether current entry is a directory and not '.' or '..'

Açıklama

public bool RecursiveDirectoryIterator::hasChildren ([ bool $allow_links = false ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

allow_links

Dönen Değerler

Returns whether the current entry is a directory, but not '.' or '..'

RecursiveDirectoryIterator::getSubPathname
RecursiveDirectoryIterator::key
RecursiveDirectoryIterator


Return path and filename of current dir entry

RecursiveDirectoryIterator::hasChildren
RecursiveDirectoryIterator::next
RecursiveDirectoryIterator
PHP Manual

RecursiveDirectoryIterator::key

(PHP 5, PHP 7)

RecursiveDirectoryIterator::key — Return path and filename of current dir entry

Açıklama

public string RecursiveDirectoryIterator::key ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The path and filename of the current dir entry.

RecursiveDirectoryIterator::hasChildren
RecursiveDirectoryIterator::next
RecursiveDirectoryIterator


Move to next entry

RecursiveDirectoryIterator::key
RecursiveDirectoryIterator::rewind
RecursiveDirectoryIterator
PHP Manual

RecursiveDirectoryIterator::next

(PHP 5, PHP 7)

RecursiveDirectoryIterator::next — Move to next entry

Açıklama

public void RecursiveDirectoryIterator::next ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

RecursiveDirectoryIterator::key
RecursiveDirectoryIterator::rewind
RecursiveDirectoryIterator


Rewind dir back to the start

RecursiveDirectoryIterator::next
RecursiveFilterIterator
RecursiveDirectoryIterator
PHP Manual

RecursiveDirectoryIterator::rewind

(PHP 5, PHP 7)

RecursiveDirectoryIterator::rewind — Rewind dir back to the start

Açıklama

public void RecursiveDirectoryIterator::rewind ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

RecursiveDirectoryIterator::next
RecursiveFilterIterator
RecursiveDirectoryIterator


The RecursiveFilterIterator class

(PHP 5 >= 5.1.0, PHP 7)

Giriş

This abstract iterator filters out unwanted values for a RecursiveIterator. This class should be extended to implement custom filters. The RecursiveFilterIterator::accept() must be implemented in the subclass.

Sınıf Sözdizimi

abstract RecursiveFilterIterator extends FilterIterator implements OuterIterator , RecursiveIterator {
/* Yöntemler */
public __construct ( RecursiveIterator $iterator )
public RecursiveFilterIterator getChildren ( void )
public bool hasChildren ( void )
/* Miras alınan yöntemler */
public abstract bool FilterIterator::accept ( void )
public FilterIterator::__construct ( Iterator $iterator )
public mixed FilterIterator::current ( void )
public Iterator FilterIterator::getInnerIterator ( void )
public mixed FilterIterator::key ( void )
public void FilterIterator::next ( void )
public void FilterIterator::rewind ( void )
public bool FilterIterator::valid ( void )
}

İçindekiler

  • RecursiveFilterIterator::__construct — Create a RecursiveFilterIterator from a RecursiveIterator
  • RecursiveFilterIterator::getChildren — Return the inner iterator's children contained in a RecursiveFilterIterator
  • RecursiveFilterIterator::hasChildren — Check whether the inner iterator's current element has children
RecursiveDirectoryIterator::rewind
RecursiveFilterIterator::__construct
Iterators


Create a RecursiveFilterIterator from a RecursiveIterator

RecursiveFilterIterator
RecursiveFilterIterator::getChildren
RecursiveFilterIterator
PHP Manual

RecursiveFilterIterator::__construct

(PHP 5 >= 5.1.0, PHP 7)

RecursiveFilterIterator::__construct — Create a RecursiveFilterIterator from a RecursiveIterator

Açıklama

public RecursiveFilterIterator::__construct ( RecursiveIterator $iterator )

Create a RecursiveFilterIterator from a RecursiveIterator.

Değiştirgeler

iterator

The RecursiveIterator to be filtered.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Basic RecursiveFilterIterator() example

<?php
class TestsOnlyFilter extends RecursiveFilterIterator {
    public function accept() {
        // Accept the current item if we can recurse into it
        // or it is a value starting with "test"
        return $this->hasChildren() || (strpos($this->current(), "test") !== FALSE);
    }
}

$array    = array("test1", array("taste2", "test3", "test4"), "test5");
$iterator = new RecursiveArrayIterator($array);
$filter   = new TestsOnlyFilter($iterator);

foreach(new RecursiveIteratorIterator($filter) as $key => $value)
{
    echo $value . "\n";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

test1
test3
test4
test5

Örnek 2 RecursiveFilterIterator() example

<?php
class StartsWithFilter extends RecursiveFilterIterator {

    protected $word;

    public function __construct(RecursiveIterator $rit, $word) {
        $this->word = $word;
        parent::__construct($rit);
    }

    public function accept() {
        return $this->hasChildren() OR strpos($this->current(), $this->word) === 0;
    }

    public function getChildren() {
        return new self($this->getInnerIterator()->getChildren(), $this->word);
    }
}

$array    = array("test1", array("taste2", "test3", "test4"), "test5");
$iterator = new RecursiveArrayIterator($array);
$filter   = new StartsWithFilter($iterator, "test");

foreach(new RecursiveIteratorIterator($filter) as $key => $value)
{
    echo $value . "\n";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

test1
test3
test4
test5

Ayrıca Bakınız

  • RecursiveFilterIterator::getChildren() - Return the inner iterator's children contained in a RecursiveFilterIterator
  • RecursiveFilterIterator::hasChildren() - Check whether the inner iterator's current element has children
  • FilterIterator::accept() - Check whether the current element of the iterator is acceptable

RecursiveFilterIterator
RecursiveFilterIterator::getChildren
RecursiveFilterIterator


Return the inner iterator's children contained in a RecursiveFilterIterator

RecursiveFilterIterator::__construct
RecursiveFilterIterator::hasChildren
RecursiveFilterIterator
PHP Manual

RecursiveFilterIterator::getChildren

(PHP 5 >= 5.1.0, PHP 7)

RecursiveFilterIterator::getChildren — Return the inner iterator's children contained in a RecursiveFilterIterator

Açıklama

public RecursiveFilterIterator RecursiveFilterIterator::getChildren ( void )

Return the inner iterator's children contained in a RecursiveFilterIterator.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a RecursiveFilterIterator containing the inner iterator's children.

Ayrıca Bakınız

  • RecursiveFilterIterator::hasChildren() - Check whether the inner iterator's current element has children
  • RecursiveIterator::getChildren() - Returns an iterator for the current entry.

RecursiveFilterIterator::__construct
RecursiveFilterIterator::hasChildren
RecursiveFilterIterator


Check whether the inner iterator's current element has children

RecursiveFilterIterator::getChildren
RecursiveIteratorIterator
RecursiveFilterIterator
PHP Manual

RecursiveFilterIterator::hasChildren

(PHP 5 >= 5.1.0, PHP 7)

RecursiveFilterIterator::hasChildren — Check whether the inner iterator's current element has children

Açıklama

public bool RecursiveFilterIterator::hasChildren ( void )

Check whether the inner iterator's current element has children.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

TRUE if the inner iterator has children, otherwise FALSE

Ayrıca Bakınız

  • RecursiveFilterIterator::getChildren() - Return the inner iterator's children contained in a RecursiveFilterIterator
  • RecursiveIterator::hasChildren() - Returns if an iterator can be created fot the current entry.

RecursiveFilterIterator::getChildren
RecursiveIteratorIterator
RecursiveFilterIterator


The RecursiveIteratorIterator class

(PHP 5, PHP 7)

Giriş

Can be used to iterate through recursive iterators.

Sınıf Sözdizimi

RecursiveIteratorIterator implements OuterIterator {
/* Constants */
const integer LEAVES_ONLY = 0 ;
const integer SELF_FIRST = 1 ;
const integer CHILD_FIRST = 2 ;
const integer CATCH_GET_CHILD = 16 ;
/* Yöntemler */
public void beginChildren ( void )
public void beginIteration ( void )
public RecursiveIterator callGetChildren ( void )
public bool callHasChildren ( void )
public __construct ( Traversable $iterator [, int $mode = RecursiveIteratorIterator::LEAVES_ONLY [, int $flags = 0 ]] )
public mixed current ( void )
public void endChildren ( void )
public void endIteration ( void )
public int getDepth ( void )
public iterator getInnerIterator ( void )
public mixed getMaxDepth ( void )
public RecursiveIterator getSubIterator ([ int $level ] )
public mixed key ( void )
public void next ( void )
public void nextElement ( void )
public void rewind ( void )
public void setMaxDepth ([ string $max_depth = -1 ] )
public bool valid ( void )
/* Miras alınan yöntemler */
public Iterator OuterIterator::getInnerIterator ( void )
}

Öntanımlı Sabitler

RecursiveIteratorIterator::LEAVES_ONLY

RecursiveIteratorIterator::SELF_FIRST

RecursiveIteratorIterator::CHILD_FIRST

RecursiveIteratorIterator::CATCH_GET_CHILD

İçindekiler

  • RecursiveIteratorIterator::beginChildren — Begin children
  • RecursiveIteratorIterator::beginIteration — Begin Iteration
  • RecursiveIteratorIterator::callGetChildren — Get children
  • RecursiveIteratorIterator::callHasChildren — Has children
  • RecursiveIteratorIterator::__construct — Construct a RecursiveIteratorIterator
  • RecursiveIteratorIterator::current — Access the current element value
  • RecursiveIteratorIterator::endChildren — End children
  • RecursiveIteratorIterator::endIteration — End Iteration
  • RecursiveIteratorIterator::getDepth — Get the current depth of the recursive iteration
  • RecursiveIteratorIterator::getInnerIterator — Get inner iterator
  • RecursiveIteratorIterator::getMaxDepth — Get max depth
  • RecursiveIteratorIterator::getSubIterator — The current active sub iterator
  • RecursiveIteratorIterator::key — Access the current key
  • RecursiveIteratorIterator::next — Move forward to the next element
  • RecursiveIteratorIterator::nextElement — Next element
  • RecursiveIteratorIterator::rewind — Rewind the iterator to the first element of the top level inner iterator
  • RecursiveIteratorIterator::setMaxDepth — Set max depth
  • RecursiveIteratorIterator::valid — Check whether the current position is valid
RecursiveFilterIterator::hasChildren
RecursiveIteratorIterator::beginChildren
Iterators


Begin children

RecursiveIteratorIterator
RecursiveIteratorIterator::beginIteration
RecursiveIteratorIterator
PHP Manual

RecursiveIteratorIterator::beginChildren

(PHP 5 >= 5.1.0, PHP 7)

RecursiveIteratorIterator::beginChildren — Begin children

Açıklama

public void RecursiveIteratorIterator::beginChildren ( void )

Is called after calling RecursiveIteratorIterator::getChildren(), and its associated RecursiveIteratorIterator::rewind().

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

RecursiveIteratorIterator
RecursiveIteratorIterator::beginIteration
RecursiveIteratorIterator


Begin Iteration

RecursiveIteratorIterator::beginChildren
RecursiveIteratorIterator::callGetChildren
RecursiveIteratorIterator
PHP Manual

RecursiveIteratorIterator::beginIteration

(PHP 5 >= 5.1.0, PHP 7)

RecursiveIteratorIterator::beginIteration — Begin Iteration

Açıklama

public void RecursiveIteratorIterator::beginIteration ( void )

Called when iteration begins (after the first RecursiveIteratorIterator::rewind() call.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

RecursiveIteratorIterator::beginChildren
RecursiveIteratorIterator::callGetChildren
RecursiveIteratorIterator


Get children

RecursiveIteratorIterator::beginIteration
RecursiveIteratorIterator::callHasChildren
RecursiveIteratorIterator
PHP Manual

RecursiveIteratorIterator::callGetChildren

(PHP 5 >= 5.1.0, PHP 7)

RecursiveIteratorIterator::callGetChildren — Get children

Açıklama

public RecursiveIterator RecursiveIteratorIterator::callGetChildren ( void )

Get children of the current element.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A RecursiveIterator().

RecursiveIteratorIterator::beginIteration
RecursiveIteratorIterator::callHasChildren
RecursiveIteratorIterator


Has children

RecursiveIteratorIterator::callGetChildren
RecursiveIteratorIterator::__construct
RecursiveIteratorIterator
PHP Manual

RecursiveIteratorIterator::callHasChildren

(PHP 5 >= 5.1.0, PHP 7)

RecursiveIteratorIterator::callHasChildren — Has children

Açıklama

public bool RecursiveIteratorIterator::callHasChildren ( void )

Called for each element to test whether it has children.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

TRUE if the element has children, otherwise FALSE

RecursiveIteratorIterator::callGetChildren
RecursiveIteratorIterator::__construct
RecursiveIteratorIterator


Construct a RecursiveIteratorIterator

RecursiveIteratorIterator::callHasChildren
RecursiveIteratorIterator::current
RecursiveIteratorIterator
PHP Manual

RecursiveIteratorIterator::__construct

(PHP 5 >= 5.1.3, PHP 7)

RecursiveIteratorIterator::__construct — Construct a RecursiveIteratorIterator

Açıklama

public RecursiveIteratorIterator::__construct ( Traversable $iterator [, int $mode = RecursiveIteratorIterator::LEAVES_ONLY [, int $flags = 0 ]] )

Creates a RecursiveIteratorIterator from a RecursiveIterator.

Değiştirgeler

iterator

The iterator being constructed from. Either a RecursiveIterator or IteratorAggregate.

mode

Optional mode. Possible values are

  • RecursiveIteratorIterator::LEAVES_ONLY - The default. Lists only leaves in iteration.
  • RecursiveIteratorIterator::SELF_FIRST - Lists leaves and parents in iteration with parents coming first.
  • RecursiveIteratorIterator::CHILD_FIRST - Lists leaves and parents in iteration with leaves coming first.

flags

Optional flag. Possible values are RecursiveIteratorIterator::CATCH_GET_CHILD which will then ignore exceptions thrown in calls to RecursiveIteratorIterator::getChildren().

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Iterating a RecursiveIteratorIterator

<?php
$array = array(
    array(
        array(
            array(
                'leaf-0-0-0-0',
                'leaf-0-0-0-1'
            ),
            'leaf-0-0-0'
        ),
        array(
            array(
                'leaf-0-1-0-0',
                'leaf-0-1-0-1'
            ),
            'leaf-0-1-0'
        ),
        'leaf-0-0'
    )
);

$iterator = new RecursiveIteratorIterator(
    new RecursiveArrayIterator($array),
    $mode
);
foreach ($iterator as $key => $leaf) {
    echo "$key => $leaf", PHP_EOL;
}
?>

Output with $mode = RecursiveIteratorIterator::LEAVES_ONLY

0 => leaf-0-0-0-0
1 => leaf-0-0-0-1
0 => leaf-0-0-0
0 => leaf-0-1-0-0
1 => leaf-0-1-0-1
0 => leaf-0-1-0
0 => leaf-0-0

Output with $mode = RecursiveIteratorIterator::SELF_FIRST

0 => Array
0 => Array
0 => Array
0 => leaf-0-0-0-0
1 => leaf-0-0-0-1
1 => leaf-0-0-0
1 => Array
0 => Array
0 => leaf-0-1-0-0
1 => leaf-0-1-0-1
1 => leaf-0-1-0
2 => leaf-0-0

Output with $mode = RecursiveIteratorIterator::CHILD_FIRST

0 => leaf-0-0-0-0
1 => leaf-0-0-0-1
0 => Array
1 => leaf-0-0-0
0 => Array
0 => leaf-0-1-0-0
1 => leaf-0-1-0-1
0 => Array
1 => leaf-0-1-0
1 => Array
2 => leaf-0-0
0 => Array

RecursiveIteratorIterator::callHasChildren
RecursiveIteratorIterator::current
RecursiveIteratorIterator


Access the current element value

RecursiveIteratorIterator::__construct
RecursiveIteratorIterator::endChildren
RecursiveIteratorIterator
PHP Manual

RecursiveIteratorIterator::current

(PHP 5, PHP 7)

RecursiveIteratorIterator::current — Access the current element value

Açıklama

public mixed RecursiveIteratorIterator::current ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current elements value.

RecursiveIteratorIterator::__construct
RecursiveIteratorIterator::endChildren
RecursiveIteratorIterator


End children

RecursiveIteratorIterator::current
RecursiveIteratorIterator::endIteration
RecursiveIteratorIterator
PHP Manual

RecursiveIteratorIterator::endChildren

(PHP 5 >= 5.1.0, PHP 7)

RecursiveIteratorIterator::endChildren — End children

Açıklama

public void RecursiveIteratorIterator::endChildren ( void )

Called when end recursing one level.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

RecursiveIteratorIterator::current
RecursiveIteratorIterator::endIteration
RecursiveIteratorIterator


End Iteration

RecursiveIteratorIterator::endChildren
RecursiveIteratorIterator::getDepth
RecursiveIteratorIterator
PHP Manual

RecursiveIteratorIterator::endIteration

(PHP 5 >= 5.1.0, PHP 7)

RecursiveIteratorIterator::endIteration — End Iteration

Açıklama

public void RecursiveIteratorIterator::endIteration ( void )

Called when the iteration ends (when RecursiveIteratorIterator::valid() first returns FALSE.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

RecursiveIteratorIterator::endChildren
RecursiveIteratorIterator::getDepth
RecursiveIteratorIterator


Get the current depth of the recursive iteration

RecursiveIteratorIterator::endIteration
RecursiveIteratorIterator::getInnerIterator
RecursiveIteratorIterator
PHP Manual

RecursiveIteratorIterator::getDepth

(PHP 5, PHP 7)

RecursiveIteratorIterator::getDepth — Get the current depth of the recursive iteration

Açıklama

public int RecursiveIteratorIterator::getDepth ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current depth of the recursive iteration.

RecursiveIteratorIterator::endIteration
RecursiveIteratorIterator::getInnerIterator
RecursiveIteratorIterator


Get inner iterator

RecursiveIteratorIterator::getDepth
RecursiveIteratorIterator::getMaxDepth
RecursiveIteratorIterator
PHP Manual

RecursiveIteratorIterator::getInnerIterator

(PHP 5 >= 5.1.0, PHP 7)

RecursiveIteratorIterator::getInnerIterator — Get inner iterator

Açıklama

public iterator RecursiveIteratorIterator::getInnerIterator ( void )

Gets the current active sub iterator.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current active sub iterator.

RecursiveIteratorIterator::getDepth
RecursiveIteratorIterator::getMaxDepth
RecursiveIteratorIterator


Get max depth

RecursiveIteratorIterator::getInnerIterator
RecursiveIteratorIterator::getSubIterator
RecursiveIteratorIterator
PHP Manual

RecursiveIteratorIterator::getMaxDepth

(PHP 5 >= 5.1.0, PHP 7)

RecursiveIteratorIterator::getMaxDepth — Get max depth

Açıklama

public mixed RecursiveIteratorIterator::getMaxDepth ( void )

Gets the maximum allowable depth.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The maximum accepted depth, or FALSE if any depth is allowed.

Ayrıca Bakınız

  • RecursiveIteratorIterator::setMaxDepth() - Set max depth

RecursiveIteratorIterator::getInnerIterator
RecursiveIteratorIterator::getSubIterator
RecursiveIteratorIterator


The current active sub iterator

RecursiveIteratorIterator::getMaxDepth
RecursiveIteratorIterator::key
RecursiveIteratorIterator
PHP Manual

RecursiveIteratorIterator::getSubIterator

(PHP 5, PHP 7)

RecursiveIteratorIterator::getSubIterator — The current active sub iterator

Açıklama

public RecursiveIterator RecursiveIteratorIterator::getSubIterator ([ int $level ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

level

Dönen Değerler

The current active sub iterator.

RecursiveIteratorIterator::getMaxDepth
RecursiveIteratorIterator::key
RecursiveIteratorIterator


Access the current key

RecursiveIteratorIterator::getSubIterator
RecursiveIteratorIterator::next
RecursiveIteratorIterator
PHP Manual

RecursiveIteratorIterator::key

(PHP 5, PHP 7)

RecursiveIteratorIterator::key — Access the current key

Açıklama

public mixed RecursiveIteratorIterator::key ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current key.

RecursiveIteratorIterator::getSubIterator
RecursiveIteratorIterator::next
RecursiveIteratorIterator


Move forward to the next element

RecursiveIteratorIterator::key
RecursiveIteratorIterator::nextElement
RecursiveIteratorIterator
PHP Manual

RecursiveIteratorIterator::next

(PHP 5, PHP 7)

RecursiveIteratorIterator::next — Move forward to the next element

Açıklama

public void RecursiveIteratorIterator::next ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

RecursiveIteratorIterator::key
RecursiveIteratorIterator::nextElement
RecursiveIteratorIterator


Next element

RecursiveIteratorIterator::next
RecursiveIteratorIterator::rewind
RecursiveIteratorIterator
PHP Manual

RecursiveIteratorIterator::nextElement

(PHP 5 >= 5.1.0, PHP 7)

RecursiveIteratorIterator::nextElement — Next element

Açıklama

public void RecursiveIteratorIterator::nextElement ( void )

Called when the next element is available.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

RecursiveIteratorIterator::next
RecursiveIteratorIterator::rewind
RecursiveIteratorIterator


Rewind the iterator to the first element of the top level inner iterator

RecursiveIteratorIterator::nextElement
RecursiveIteratorIterator::setMaxDepth
RecursiveIteratorIterator
PHP Manual

RecursiveIteratorIterator::rewind

(PHP 5, PHP 7)

RecursiveIteratorIterator::rewind — Rewind the iterator to the first element of the top level inner iterator

Açıklama

public void RecursiveIteratorIterator::rewind ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

RecursiveIteratorIterator::nextElement
RecursiveIteratorIterator::setMaxDepth
RecursiveIteratorIterator


Set max depth

RecursiveIteratorIterator::rewind
RecursiveIteratorIterator::valid
RecursiveIteratorIterator
PHP Manual

RecursiveIteratorIterator::setMaxDepth

(PHP 5 >= 5.1.0, PHP 7)

RecursiveIteratorIterator::setMaxDepth — Set max depth

Açıklama

public void RecursiveIteratorIterator::setMaxDepth ([ string $max_depth = -1 ] )

Set the maximum allowed depth.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

max_depth

The maximum allowed depth. -1 is used for any depth.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

Emits an Exception if max_depth is less than -1.

RecursiveIteratorIterator::rewind
RecursiveIteratorIterator::valid
RecursiveIteratorIterator


Check whether the current position is valid

RecursiveIteratorIterator::setMaxDepth
RecursiveRegexIterator
RecursiveIteratorIterator
PHP Manual

RecursiveIteratorIterator::valid

(PHP 5, PHP 7)

RecursiveIteratorIterator::valid — Check whether the current position is valid

Açıklama

public bool RecursiveIteratorIterator::valid ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

TRUE if the current position is valid, otherwise FALSE

RecursiveIteratorIterator::setMaxDepth
RecursiveRegexIterator
RecursiveIteratorIterator


The RecursiveRegexIterator class

(PHP 5 >= 5.2.0, PHP 7)

Giriş

This recursive iterator can filter another recursive iterator via a regular expression.

Sınıf Sözdizimi

RecursiveRegexIterator extends RegexIterator implements RecursiveIterator {
/* Yöntemler */
public __construct ( RecursiveIterator $iterator , string $regex [, int $mode = self::MATCH [, int $flags = 0 [, int $preg_flags = 0 ]]] )
public RecursiveRegexIterator getChildren ( void )
public bool hasChildren ( void )
/* Miras alınan yöntemler */
public RecursiveIterator RecursiveIterator::getChildren ( void )
public bool RecursiveIterator::hasChildren ( void )
public bool RegexIterator::accept ( void )
public int RegexIterator::getFlags ( void )
public int RegexIterator::getMode ( void )
public int RegexIterator::getPregFlags ( void )
public string RegexIterator::getRegex ( void )
public void RegexIterator::setFlags ( int $flags )
public void RegexIterator::setMode ( int $mode )
public void RegexIterator::setPregFlags ( int $preg_flags )
}

İçindekiler

  • RecursiveRegexIterator::__construct — Creates a new RecursiveRegexIterator.
  • RecursiveRegexIterator::getChildren — Returns an iterator for the current entry.
  • RecursiveRegexIterator::hasChildren — Returns whether an iterator can be obtained for the current entry.
RecursiveIteratorIterator::valid
RecursiveRegexIterator::__construct
Iterators


Creates a new RecursiveRegexIterator.

RecursiveRegexIterator
RecursiveRegexIterator::getChildren
RecursiveRegexIterator
PHP Manual

RecursiveRegexIterator::__construct

(PHP 5 >= 5.2.0, PHP 7)

RecursiveRegexIterator::__construct — Creates a new RecursiveRegexIterator.

Açıklama

public RecursiveRegexIterator::__construct ( RecursiveIterator $iterator , string $regex [, int $mode = self::MATCH [, int $flags = 0 [, int $preg_flags = 0 ]]] )

Creates a new regular expression iterator.

Değiştirgeler

iterator

The recursive iterator to apply this regex filter to.

regex

The regular expression to match.

mode

Operation mode, see RegexIterator::setMode() for a list of modes.

flags

Special flags, see RegexIterator::setFlags() for a list of available flags.

preg_flags

The regular expression flags. These flags depend on the operation mode parameter:

RegexIterator preg_flags
operation mode | available flags
RecursiveRegexIterator::ALL_MATCHES | See preg_match_all().
RecursiveRegexIterator::GET_MATCH | See preg_match().
RecursiveRegexIterator::MATCH | See preg_match().
RecursiveRegexIterator::REPLACE | none.
RecursiveRegexIterator::SPLIT | See preg_split().

Örnekler

Örnek 1 RecursiveRegexIterator::__construct() example

Creates a new RegexIterator that filters all strings that start with 'test'.

<?php
$rArrayIterator = new RecursiveArrayIterator(array('test1', array('tet3', 'test4', 'test5')));
$rRegexIterator = new RecursiveRegexIterator($rArrayIterator, '/^test/',
    RecursiveRegexIterator::ALL_MATCHES);

foreach ($rRegexIterator as $key1 => $value1) {

    if ($rRegexIterator->hasChildren()) {

        // print all children
        echo "Children: ";
        foreach ($rRegexIterator->getChildren() as $key => $value) {
            echo $value . " ";
        }
        echo "\n";
    } else {
        echo "No children\n";
    }

}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

No children
Children: test4 test5

Ayrıca Bakınız

  • preg_match() - Bir düzenli ifadeyi eşleştirmeye çalışır
  • preg_match_all() - Kapsamlı bir düzenli ifade eşleştirmesi yapar
  • preg_replace() - Düzenli ifadeye göre dizgede değişiklik yapar
  • preg_split() - Dizgeyi düzenli ifadeye göre böler

RecursiveRegexIterator
RecursiveRegexIterator::getChildren
RecursiveRegexIterator


Returns an iterator for the current entry.

RecursiveRegexIterator::__construct
RecursiveRegexIterator::hasChildren
RecursiveRegexIterator
PHP Manual

RecursiveRegexIterator::getChildren

(PHP 5 >= 5.2.0, PHP 7)

RecursiveRegexIterator::getChildren — Returns an iterator for the current entry.

Açıklama

public RecursiveRegexIterator RecursiveRegexIterator::getChildren ( void )

Returns an iterator for the current iterator entry.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

An iterator for the current entry, if it can be iterated over by the inner iterator.

Hatalar/İstisnalar

An InvalidArgumentException will be thrown if the current entry does not contain a value that can be iterated over by the inner iterator.

Örnekler

Örnek 1 RecursiveRegexIterator::getChildren() example

<?php
$rArrayIterator = new RecursiveArrayIterator(array('test1', array('tet3', 'test4', 'test5')));
$rRegexIterator = new RecursiveRegexIterator($rArrayIterator, '/^test/',
    RecursiveRegexIterator::ALL_MATCHES);

foreach ($rRegexIterator as $key1 => $value1) {

    if ($rRegexIterator->hasChildren()) {

        // print all children
        echo "Children: ";
        foreach ($rRegexIterator->getChildren() as $key => $value) {
            echo $value . " ";
        }
        echo "\n";
    } else {
        echo "No children\n";
    }

}
?>

Yukarıdaki örneğin çıktısı:

No children
Children: test4 test5

Ayrıca Bakınız

  • RecursiveRegexIterator::hasChildren() - Returns whether an iterator can be obtained for the current entry.

RecursiveRegexIterator::__construct
RecursiveRegexIterator::hasChildren
RecursiveRegexIterator


Returns whether an iterator can be obtained for the current entry.

RecursiveRegexIterator::getChildren
RecursiveTreeIterator
RecursiveRegexIterator
PHP Manual

RecursiveRegexIterator::hasChildren

(PHP 5 >= 5.2.0, PHP 7)

RecursiveRegexIterator::hasChildren — Returns whether an iterator can be obtained for the current entry.

Açıklama

public bool RecursiveRegexIterator::hasChildren ( void )

Returns whether an iterator can be obtained for the current entry. This iterator can be obtained via RecursiveRegexIterator::getChildren().

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if an iterator can be obtained for the current entry, otherwise returns FALSE.

Örnekler

Örnek 1 RecursiveRegexIterator::hasChildren() example

<?php
$rArrayIterator = new RecursiveArrayIterator(array('test1', array('tet3', 'test4', 'test5')));
$rRegexIterator = new RecursiveRegexIterator($rArrayIterator, '/^test/',
    RecursiveRegexIterator::ALL_MATCHES);

foreach ($rRegexIterator as $value) {
    var_dump($rRegexIterator->hasChildren());
}
?>

Yukarıdaki örneğin çıktısı:

bool(false)
bool(true)

Ayrıca Bakınız

  • RecursiveRegexIterator::getChildren() - Returns an iterator for the current entry.

RecursiveRegexIterator::getChildren
RecursiveTreeIterator
RecursiveRegexIterator


The RecursiveTreeIterator class

(PHP 5 >= 5.3.0, PHP 7)

Giriş

Allows iterating over a RecursiveIterator to generate an ASCII graphic tree.

Sınıf Sözdizimi

RecursiveTreeIterator extends RecursiveIteratorIterator implements OuterIterator {
/* Sabitler */
const integer BYPASS_CURRENT = 4 ;
const integer BYPASS_KEY = 8 ;
const integer PREFIX_LEFT = 0 ;
const integer PREFIX_MID_HAS_NEXT = 1 ;
const integer PREFIX_MID_LAST = 2 ;
const integer PREFIX_END_HAS_NEXT = 3 ;
const integer PREFIX_END_LAST = 4 ;
const integer PREFIX_RIGHT = 5 ;
/* Yöntemler */
public void beginChildren ( void )
public RecursiveIterator beginIteration ( void )
public RecursiveIterator callGetChildren ( void )
public bool callHasChildren ( void )
public __construct ( RecursiveIterator|IteratorAggregate $it [, int $flags = RecursiveTreeIterator::BYPASS_KEY [, int $cit_flags = CachingIterator::CATCH_GET_CHILD [, int $mode = RecursiveIteratorIterator::SELF_FIRST ]]] )
public string current ( void )
public void endChildren ( void )
public void endIteration ( void )
public string getEntry ( void )
public void getPostfix ( void )
public string getPrefix ( void )
public string key ( void )
public void next ( void )
public void nextElement ( void )
public void rewind ( void )
public void setPrefixPart ( int $part , string $value )
public bool valid ( void )
/* Miras alınan yöntemler */
public void RecursiveIteratorIterator::beginChildren ( void )
public void RecursiveIteratorIterator::beginIteration ( void )
public RecursiveIterator RecursiveIteratorIterator::callGetChildren ( void )
public bool RecursiveIteratorIterator::callHasChildren ( void )
public RecursiveIteratorIterator::__construct ( Traversable $iterator [, int $mode = RecursiveIteratorIterator::LEAVES_ONLY [, int $flags = 0 ]] )
public mixed RecursiveIteratorIterator::current ( void )
public void RecursiveIteratorIterator::endChildren ( void )
public void RecursiveIteratorIterator::endIteration ( void )
public int RecursiveIteratorIterator::getDepth ( void )
public iterator RecursiveIteratorIterator::getInnerIterator ( void )
public mixed RecursiveIteratorIterator::getMaxDepth ( void )
public RecursiveIterator RecursiveIteratorIterator::getSubIterator ([ int $level ] )
public mixed RecursiveIteratorIterator::key ( void )
public void RecursiveIteratorIterator::next ( void )
public void RecursiveIteratorIterator::nextElement ( void )
public void RecursiveIteratorIterator::rewind ( void )
public void RecursiveIteratorIterator::setMaxDepth ([ string $max_depth = -1 ] )
public bool RecursiveIteratorIterator::valid ( void )
}

Öntanımlı Sabitler

RecursiveTreeIterator::BYPASS_CURRENT

RecursiveTreeIterator::BYPASS_KEY

RecursiveTreeIterator::PREFIX_LEFT

RecursiveTreeIterator::PREFIX_MID_HAS_NEXT

RecursiveTreeIterator::PREFIX_MID_LAST

RecursiveTreeIterator::PREFIX_END_HAS_NEXT

RecursiveTreeIterator::PREFIX_END_LAST

RecursiveTreeIterator::PREFIX_RIGHT

İçindekiler

  • RecursiveTreeIterator::beginChildren — Begin children
  • RecursiveTreeIterator::beginIteration — Begin iteration
  • RecursiveTreeIterator::callGetChildren — Get children
  • RecursiveTreeIterator::callHasChildren — Has children
  • RecursiveTreeIterator::__construct — Construct a RecursiveTreeIterator
  • RecursiveTreeIterator::current — Get current element
  • RecursiveTreeIterator::endChildren — End children
  • RecursiveTreeIterator::endIteration — End iteration
  • RecursiveTreeIterator::getEntry — Get current entry
  • RecursiveTreeIterator::getPostfix — Get the postfix
  • RecursiveTreeIterator::getPrefix — Get the prefix
  • RecursiveTreeIterator::key — Get the key of the current element
  • RecursiveTreeIterator::next — Move to next element
  • RecursiveTreeIterator::nextElement — Next element
  • RecursiveTreeIterator::rewind — Rewind iterator
  • RecursiveTreeIterator::setPrefixPart — Set a part of the prefix
  • RecursiveTreeIterator::valid — Check validity
RecursiveRegexIterator::hasChildren
RecursiveTreeIterator::beginChildren
Iterators


Begin children

RecursiveTreeIterator
RecursiveTreeIterator::beginIteration
RecursiveTreeIterator
PHP Manual

RecursiveTreeIterator::beginChildren

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::beginChildren — Begin children

Açıklama

public void RecursiveTreeIterator::beginChildren ( void )

Called when recursing one level down.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

RecursiveTreeIterator
RecursiveTreeIterator::beginIteration
RecursiveTreeIterator


Begin iteration

RecursiveTreeIterator::beginChildren
RecursiveTreeIterator::callGetChildren
RecursiveTreeIterator
PHP Manual

RecursiveTreeIterator::beginIteration

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::beginIteration — Begin iteration

Açıklama

public RecursiveIterator RecursiveTreeIterator::beginIteration ( void )

Called when iteration begins (after the first RecursiveTreeIterator::rewind() call).

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A RecursiveIterator.

RecursiveTreeIterator::beginChildren
RecursiveTreeIterator::callGetChildren
RecursiveTreeIterator


Get children

RecursiveTreeIterator::beginIteration
RecursiveTreeIterator::callHasChildren
RecursiveTreeIterator
PHP Manual

RecursiveTreeIterator::callGetChildren

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::callGetChildren — Get children

Açıklama

public RecursiveIterator RecursiveTreeIterator::callGetChildren ( void )

Gets children of the current element.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A RecursiveIterator.

RecursiveTreeIterator::beginIteration
RecursiveTreeIterator::callHasChildren
RecursiveTreeIterator


Has children

RecursiveTreeIterator::callGetChildren
RecursiveTreeIterator::__construct
RecursiveTreeIterator
PHP Manual

RecursiveTreeIterator::callHasChildren

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::callHasChildren — Has children

Açıklama

public bool RecursiveTreeIterator::callHasChildren ( void )

Called for each element to test whether it has children.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

TRUE if there are children, otherwise FALSE

RecursiveTreeIterator::callGetChildren
RecursiveTreeIterator::__construct
RecursiveTreeIterator


Construct a RecursiveTreeIterator

RecursiveTreeIterator::callHasChildren
RecursiveTreeIterator::current
RecursiveTreeIterator
PHP Manual

RecursiveTreeIterator::__construct

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::__construct — Construct a RecursiveTreeIterator

Açıklama

 public RecursiveTreeIterator::__construct
  ( RecursiveIterator|IteratorAggregate $it
 [, int $flags = RecursiveTreeIterator::BYPASS_KEY
 [, int $cit_flags = CachingIterator::CATCH_GET_CHILD
 [, int $mode = RecursiveIteratorIterator::SELF_FIRST
]]] )

Constructs a new RecursiveTreeIterator from the supplied recursive iterator.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

it

The RecursiveIterator or IteratorAggregate to iterate over.

flags

Flags may be provided which will affect the behavior of some methods. A list of the flags can found under RecursiveTreeIterator predefined constants.

caching_it_flags

Flags to affect the behavior of the RecursiveCachingIterator used internally.

mode

Flags to affect the behavior of the RecursiveIteratorIterator used internally.

Dönen Değerler

Hiçbir değer dönmez.

RecursiveTreeIterator::callHasChildren
RecursiveTreeIterator::current
RecursiveTreeIterator


Get current element

RecursiveTreeIterator::__construct
RecursiveTreeIterator::endChildren
RecursiveTreeIterator
PHP Manual

RecursiveTreeIterator::current

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::current — Get current element

Açıklama

public string RecursiveTreeIterator::current ( void )

Gets the current element prefixed and postfixed.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the current element prefixed and postfixed.

RecursiveTreeIterator::__construct
RecursiveTreeIterator::endChildren
RecursiveTreeIterator


End children

RecursiveTreeIterator::current
RecursiveTreeIterator::endIteration
RecursiveTreeIterator
PHP Manual

RecursiveTreeIterator::endChildren

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::endChildren — End children

Açıklama

public void RecursiveTreeIterator::endChildren ( void )

Called when end recursing one level.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

RecursiveTreeIterator::current
RecursiveTreeIterator::endIteration
RecursiveTreeIterator


End iteration

RecursiveTreeIterator::endChildren
RecursiveTreeIterator::getEntry
RecursiveTreeIterator
PHP Manual

RecursiveTreeIterator::endIteration

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::endIteration — End iteration

Açıklama

public void RecursiveTreeIterator::endIteration ( void )

Called when the iteration ends (when RecursiveTreeIterator::valid() first returns FALSE)

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

RecursiveTreeIterator::endChildren
RecursiveTreeIterator::getEntry
RecursiveTreeIterator


Get current entry

RecursiveTreeIterator::endIteration
RecursiveTreeIterator::getPostfix
RecursiveTreeIterator
PHP Manual

RecursiveTreeIterator::getEntry

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::getEntry — Get current entry

Açıklama

public string RecursiveTreeIterator::getEntry ( void )

Gets the part of the tree built for the current element.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the part of the tree built for the current element.

RecursiveTreeIterator::endIteration
RecursiveTreeIterator::getPostfix
RecursiveTreeIterator


Get the postfix

RecursiveTreeIterator::getEntry
RecursiveTreeIterator::getPrefix
RecursiveTreeIterator
PHP Manual

RecursiveTreeIterator::getPostfix

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::getPostfix — Get the postfix

Açıklama

public void RecursiveTreeIterator::getPostfix ( void )

Gets the string to place after the current element.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the string to place after the current element.

RecursiveTreeIterator::getEntry
RecursiveTreeIterator::getPrefix
RecursiveTreeIterator


Get the prefix

RecursiveTreeIterator::getPostfix
RecursiveTreeIterator::key
RecursiveTreeIterator
PHP Manual

RecursiveTreeIterator::getPrefix

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::getPrefix — Get the prefix

Açıklama

public string RecursiveTreeIterator::getPrefix ( void )

Gets the string to place in front of current element

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the string to place in front of current element

RecursiveTreeIterator::getPostfix
RecursiveTreeIterator::key
RecursiveTreeIterator


Get the key of the current element

RecursiveTreeIterator::getPrefix
RecursiveTreeIterator::next
RecursiveTreeIterator
PHP Manual

RecursiveTreeIterator::key

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::key — Get the key of the current element

Açıklama

public string RecursiveTreeIterator::key ( void )

Gets the current key prefixed and postfixed.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the current key prefixed and postfixed.

RecursiveTreeIterator::getPrefix
RecursiveTreeIterator::next
RecursiveTreeIterator


Move to next element

RecursiveTreeIterator::key
RecursiveTreeIterator::nextElement
RecursiveTreeIterator
PHP Manual

RecursiveTreeIterator::next

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::next — Move to next element

Açıklama

public void RecursiveTreeIterator::next ( void )

Moves forward to the next element.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

RecursiveTreeIterator::key
RecursiveTreeIterator::nextElement
RecursiveTreeIterator


Next element

RecursiveTreeIterator::next
RecursiveTreeIterator::rewind
RecursiveTreeIterator
PHP Manual

RecursiveTreeIterator::nextElement

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::nextElement — Next element

Açıklama

public void RecursiveTreeIterator::nextElement ( void )

Called when the next element is available.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

RecursiveTreeIterator::next
RecursiveTreeIterator::rewind
RecursiveTreeIterator


Rewind iterator

RecursiveTreeIterator::nextElement
RecursiveTreeIterator::setPrefixPart
RecursiveTreeIterator
PHP Manual

RecursiveTreeIterator::rewind

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::rewind — Rewind iterator

Açıklama

public void RecursiveTreeIterator::rewind ( void )

Rewinds the iterator to the first element of the top level inner iterator.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

RecursiveTreeIterator::nextElement
RecursiveTreeIterator::setPrefixPart
RecursiveTreeIterator


Set a part of the prefix

RecursiveTreeIterator::rewind
RecursiveTreeIterator::valid
RecursiveTreeIterator
PHP Manual

RecursiveTreeIterator::setPrefixPart

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::setPrefixPart — Set a part of the prefix

Açıklama

public void RecursiveTreeIterator::setPrefixPart ( int $part , string $value )

Sets a part of the prefix used in the graphic tree.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

part

One of the RecursiveTreeIterator::PREFIX_* constants.

value

The value to assign to the part of the prefix specified in part.

Dönen Değerler

Hiçbir değer dönmez.

RecursiveTreeIterator::rewind
RecursiveTreeIterator::valid
RecursiveTreeIterator


Check validity

RecursiveTreeIterator::setPrefixPart
RegexIterator
RecursiveTreeIterator
PHP Manual

RecursiveTreeIterator::valid

(PHP 5 >= 5.3.0, PHP 7)

RecursiveTreeIterator::valid — Check validity

Açıklama

public bool RecursiveTreeIterator::valid ( void )

Check whether the current position is valid.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

TRUE if the current position is valid, otherwise FALSE

RecursiveTreeIterator::setPrefixPart
RegexIterator
RecursiveTreeIterator


The RegexIterator class

(PHP 5 >= 5.2.0, PHP 7)

Giriş

This iterator can be used to filter another iterator based on a regular expression.

Sınıf Sözdizimi

RegexIterator extends FilterIterator {
/* Sabitler */
const integer MATCH = 0 ;
const integer GET_MATCH = 1 ;
const integer ALL_MATCHES = 2 ;
const integer SPLIT = 3 ;
const integer REPLACE = 4 ;
const integer USE_KEY = 1 ;
/* Yöntemler */
public __construct ( Iterator $iterator , string $regex [, int $mode = self::MATCH [, int $flags = 0 [, int $preg_flags = 0 ]]] )
public bool accept ( void )
public int getFlags ( void )
public int getMode ( void )
public int getPregFlags ( void )
public string getRegex ( void )
public void setFlags ( int $flags )
public void setMode ( int $mode )
public void setPregFlags ( int $preg_flags )
/* Miras alınan yöntemler */
public abstract bool FilterIterator::accept ( void )
public FilterIterator::__construct ( Iterator $iterator )
public mixed FilterIterator::current ( void )
public Iterator FilterIterator::getInnerIterator ( void )
public mixed FilterIterator::key ( void )
public void FilterIterator::next ( void )
public void FilterIterator::rewind ( void )
public bool FilterIterator::valid ( void )
}

Öntanımlı Sabitler

RegexIterator operation modes

RegexIterator::ALL_MATCHES

Return all matches for the current entry (see preg_match_all()).

RegexIterator::GET_MATCH

Return the first match for the current entry (see preg_match()).

RegexIterator::MATCH

Only execute match (filter) for the current entry (see preg_match()).

RegexIterator::REPLACE

Replace the current entry (see preg_replace(); Not fully implemented yet)

RegexIterator::SPLIT

Returns the split values for the current entry (see preg_split()).

RegexIterator Flags

RegexIterator::USE_KEY

Special flag: Match the entry key instead of the entry value.

İçindekiler

  • RegexIterator::accept — Get accept status
  • RegexIterator::__construct — Create a new RegexIterator
  • RegexIterator::getFlags — Get flags
  • RegexIterator::getMode — Returns operation mode.
  • RegexIterator::getPregFlags — Returns the regular expression flags.
  • RegexIterator::getRegex — Returns current regular expression
  • RegexIterator::setFlags — Sets the flags.
  • RegexIterator::setMode — Sets the operation mode.
  • RegexIterator::setPregFlags — Sets the regular expression flags.
RecursiveTreeIterator::valid
RegexIterator::accept
Iterators


Get accept status

RegexIterator
RegexIterator::__construct
RegexIterator
PHP Manual

RegexIterator::accept

(PHP 5 >= 5.2.0, PHP 7)

RegexIterator::accept — Get accept status

Açıklama

public bool RegexIterator::accept ( void )

Matches (string) RegexIterator::current()
(or RegexIterator::key() if the
RegexIterator::USE_KEY flag is set)
against the regular expression.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

TRUE if a match, FALSE otherwise.

Örnekler

Örnek 1 RegexIterator::accept() example

This example shows that only items matching the regular expression are accepted.

<?php
$names = new ArrayIterator(array('Ann', 'Bob', 'Charlie', 'David'));
$filter = new RegexIterator($names, '/^[B-D]/');
foreach ($filter as $name) {
    echo $name . PHP_EOL;
}
?>

Yukarıdaki örneğin çıktısı:

Bob
Charlie
David

Ayrıca Bakınız

  • RegexIterator constants
  • RegexIterator::setFlags() - Sets the flags.

RegexIterator
RegexIterator::__construct
RegexIterator


Create a new RegexIterator

RegexIterator::accept
RegexIterator::getFlags
RegexIterator
PHP Manual

RegexIterator::__construct

(PHP 5 >= 5.2.0, PHP 7)

RegexIterator::__construct — Create a new RegexIterator

Açıklama

public RegexIterator::__construct ( Iterator $iterator , string $regex [, int $mode = self::MATCH [, int $flags = 0 [, int $preg_flags = 0 ]]] )

Create a new RegexIterator which filters an Iterator using a regular expression.

Değiştirgeler

iterator

The iterator to apply this regex filter to.

regex

The regular expression to match.

mode

Operation mode, see RegexIterator::setMode() for a list of modes.

flags

Special flags, see RegexIterator::setFlags() for a list of available flags.

preg_flags

The regular expression flags. These flags depend on the operation mode parameter:

RegexIterator preg_flags
operation mode | available flags
RegexIterator::ALL_MATCHES | See preg_match_all().
RegexIterator::GET_MATCH | See preg_match().
RegexIterator::MATCH | See preg_match().
RegexIterator::REPLACE | none.
RegexIterator::SPLIT | See preg_split().

Hatalar/İstisnalar

Throws an InvalidArgumentException if the regex argument is invalid.

Örnekler

Örnek 1 RegexIterator::__construct() example

Creates a new RegexIterator that filters all strings that start with 'test'.

<?php
$arrayIterator = new ArrayIterator(array('test 1', 'another test', 'test 123'));
$regexIterator = new RegexIterator($arrayIterator, '/^test/');

foreach ($regexIterator as $value) {
    echo $value . "\n";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

test 1
test 123

Ayrıca Bakınız

  • preg_match() - Bir düzenli ifadeyi eşleştirmeye çalışır
  • preg_match_all() - Kapsamlı bir düzenli ifade eşleştirmesi yapar
  • preg_replace() - Düzenli ifadeye göre dizgede değişiklik yapar
  • preg_split() - Dizgeyi düzenli ifadeye göre böler

RegexIterator::accept
RegexIterator::getFlags
RegexIterator


Get flags

RegexIterator::__construct
RegexIterator::getMode
RegexIterator
PHP Manual

RegexIterator::getFlags

(PHP 5 >= 5.2.0, PHP 7)

RegexIterator::getFlags — Get flags

Açıklama

public int RegexIterator::getFlags ( void )

Returns the flags, see RegexIterator::setFlags() for a list of available flags.

Dönen Değerler

Returns the set flags.

Örnekler

Örnek 1 RegexIterator::getFlags() example

<?php

$test = array ('str1' => 'test 1', 'teststr2' => 'another test', 'str3' => 'test 123');

$arrayIterator = new ArrayIterator($test);
$regexIterator = new RegexIterator($arrayIterator, '/^test/');
$regexIterator->setFlags(RegexIterator::USE_KEY);

if ($regexIterator->getFlags() & RegexIterator::USE_KEY) {
    echo 'Filtering based on the array keys.';
} else {
    echo 'Filtering based on the array values.';
}
?>

Yukarıdaki örneğin çıktısı:

Filtering based on the array keys.

Ayrıca Bakınız

  • RegexIterator::setFlags() - Sets the flags.

RegexIterator::__construct
RegexIterator::getMode
RegexIterator


Returns operation mode.

RegexIterator::getFlags
RegexIterator::getPregFlags
RegexIterator
PHP Manual

RegexIterator::getMode

(PHP 5 >= 5.2.0, PHP 7)

RegexIterator::getMode — Returns operation mode.

Açıklama

public int RegexIterator::getMode ( void )

Returns the operation mode, see RegexIterator::setMode() for the list of operation modes.

Dönen Değerler

Returns the operation mode.

Örnekler

Örnek 1 RegexIterator::getMode() example

<?php

$test = array ('str1' => 'test 1', 'teststr2' => 'another test', 'str3' => 'test 123');

$arrayIterator = new ArrayIterator($test);
$regexIterator = new RegexIterator($arrayIterator, '/^[a-z]+/', RegexIterator::GET_MATCH);

$mode = $regexIterator->getMode();
if ($mode & RegexIterator::GET_MATCH) {
    echo 'Getting the match for each item.';
} elseif ($mode & RegexIterator::ALL_MATCHES) {
    echo 'Getting all matches for each item.';
} elseif ($mode & RegexIterator::MATCH) {
    echo 'Getting each item if it matches.';
} elseif ($mode & RegexIterator::SPLIT) {
    echo 'Getting split pieces of each.';
}
?>

Yukarıdaki örneğin çıktısı:

Getting the match for each item.

Ayrıca Bakınız

  • RegexIterator::setMode() - Sets the operation mode.

RegexIterator::getFlags
RegexIterator::getPregFlags
RegexIterator


Returns the regular expression flags.

RegexIterator::getMode
RegexIterator::getRegex
RegexIterator
PHP Manual

RegexIterator::getPregFlags

(PHP 5 >= 5.2.0, PHP 7)

RegexIterator::getPregFlags — Returns the regular expression flags.

Açıklama

public int RegexIterator::getPregFlags ( void )

Returns the regular expression flags, see RegexIterator::__construct() for the list of flags.

Dönen Değerler

Returns a bitmask of the regular expression flags.

Örnekler

Örnek 1 RegexIterator::getPregFlags() example

<?php

$test = array ('str1' => 'test 1', 'teststr2' => 'another test', 'str3' => 'test 123');

$arrayIterator = new ArrayIterator($test);
$regexIterator = new RegexIterator($arrayIterator, '/\s/', RegexIterator::SPLIT);
$regexIterator->setPregFlags(PREG_SPLIT_NO_EMPTY | PREG_SPLIT_OFFSET_CAPTURE);

if ($regexIterator->getPregFlags() & PREG_SPLIT_NO_EMPTY) {
    echo 'Ignoring empty pieces';
} else {
    echo 'Not ignoring empty pieces';
}

?>

Yukarıdaki örneğin çıktısı:

Ignoring empty pieces

Ayrıca Bakınız

  • RegexIterator::setPregFlags() - Sets the regular expression flags.

RegexIterator::getMode
RegexIterator::getRegex
RegexIterator


Returns current regular expression

RegexIterator::getPregFlags
RegexIterator::setFlags
RegexIterator
PHP Manual

RegexIterator::getRegex

(PHP 5 >= 5.4.0, PHP 7)

RegexIterator::getRegex — Returns current regular expression

Açıklama

public string RegexIterator::getRegex ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

RegexIterator::getPregFlags
RegexIterator::setFlags
RegexIterator


Sets the flags.

RegexIterator::getRegex
RegexIterator::setMode
RegexIterator
PHP Manual

RegexIterator::setFlags

(PHP 5 >= 5.2.0, PHP 7)

RegexIterator::setFlags — Sets the flags.

Açıklama

public void RegexIterator::setFlags ( int $flags )

Sets the flags.

Değiştirgeler

flags

The flags to set, a bitmask of class constants.

The available flags are listed below. The actual meanings of these flags are described in the predefined constants.

RegexIterator flags
value | constant
1 | RegexIterator::USE_KEY

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 RegexIterator::setFlags() example

Creates a new RegexIterator that filters all entries whose key starts with 'test'.

<?php
$test = array ('str1' => 'test 1', 'teststr2' => 'another test', 'str3' => 'test 123');

$arrayIterator = new ArrayIterator($test);
$regexIterator = new RegexIterator($arrayIterator, '/^test/');
$regexIterator->setFlags(RegexIterator::USE_KEY);

foreach ($regexIterator as $key => $value) {
    echo $key . ' => ' . $value . "\n";
}
?>

Yukarıdaki örneğin çıktısı:

teststr2 => another test

Ayrıca Bakınız

  • RegexIterator::getFlags() - Get flags

RegexIterator::getRegex
RegexIterator::setMode
RegexIterator


Sets the operation mode.

RegexIterator::setFlags
RegexIterator::setPregFlags
RegexIterator
PHP Manual

RegexIterator::setMode

(PHP 5 >= 5.2.0, PHP 7)

RegexIterator::setMode — Sets the operation mode.

Açıklama

public void RegexIterator::setMode ( int $mode )

Sets the operation mode.

Değiştirgeler

mode

The operation mode.

The available modes are listed below. The actual meanings of these modes are described in the predefined constants.

RegexIterator modes
value | constant
0 | RegexIterator::MATCH
1 | RegexIterator::GET_MATCH
2 | RegexIterator::ALL_MATCHES
3 | RegexIterator::SPLIT
4 | RegexIterator::REPLACE

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 RegexIterator::setMode() example

<?php
$test = array ('str1' => 'test 1', 'test str2' => 'another test', 'str3' => 'test 123');

$arrayIterator = new ArrayIterator($test);
// Filter everything that starts with 'test ' followed by one or more numbers.
$regexIterator = new RegexIterator($arrayIterator, '/^test (\d+)/');
// Operation mode: Replace actual value with the matches
$regexIterator->setMode(RegexIterator::GET_MATCH);

foreach ($regexIterator as $key => $value) {
    // print out the matched number(s)
    echo $key . ' => ' . $value[1] . PHP_EOL;
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

str1 => 1
str3 => 123

Ayrıca Bakınız

  • RegexIterator::getMode() - Returns operation mode.

RegexIterator::setFlags
RegexIterator::setPregFlags
RegexIterator


Sets the regular expression flags.

RegexIterator::setMode
Interfaces
RegexIterator
PHP Manual

RegexIterator::setPregFlags

(PHP 5 >= 5.2.0, PHP 7)

RegexIterator::setPregFlags — Sets the regular expression flags.

Açıklama

public void RegexIterator::setPregFlags ( int $preg_flags )

Sets the regular expression flags.

Değiştirgeler

preg_flags

The regular expression flags. See RegexIterator::__construct() for an overview of available flags.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 RegexIterator::setPregFlags() example

Creates a new RegexIterator that filters all entries with where the array key starts with 'test'.

<?php
$test = array ('test 1', 'another test', 'test 123');

$arrayIterator = new ArrayIterator($test);
$regexIterator = new RegexIterator($arrayIterator, '/^test/', RegexIterator::GET_MATCH);

$regexIterator->setPregFlags(PREG_OFFSET_CAPTURE);

foreach ($regexIterator as $key => $value) {
    var_dump($value);
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(1) {
  [0]=>
  array(2) {
    [0]=>
    string(4) "test"
    [1]=>
    int(0)
  }
}
array(1) {
  [0]=>
  array(2) {
    [0]=>
    string(4) "test"
    [1]=>
    int(0)
  }
}

Ayrıca Bakınız

  • RegexIterator::getPregFlags() - Returns the regular expression flags.

RegexIterator::setMode
Interfaces
RegexIterator


Interfaces

İçindekiler

  • Countable
  • OuterIterator
  • RecursiveIterator
  • SeekableIterator

SPL provides a set of interfaces.

See also the Öntanımlı Arayüzler ve Sınıflar

Interface list

  • Countable
  • OuterIterator
  • RecursiveIterator
  • SeekableIterator
  • SplObserver
  • SplSubject
RegexIterator::setPregFlags
Countable
SPL


The Countable interface

(PHP 5 >= 5.1.0, PHP 7)

Giriş

Classes implementing Countable can be used with the count() function.

Arayüz Sözdizimi

Countable {
/* Yöntemler */
abstract public int count ( void )
}

İçindekiler

  • Countable::count — Count elements of an object
Interfaces
Countable::count
Interfaces


Count elements of an object

Countable
OuterIterator
Countable
PHP Manual

Countable::count

(PHP 5 >= 5.1.0, PHP 7)

Countable::count — Count elements of an object

Açıklama

abstract public int Countable::count ( void )

This method is executed when using the count() function on an object implementing Countable.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The custom count as an integer.

Bilginize:

The return value is cast to an integer.

Örnekler

Örnek 1 Countable::count() example

<?php
class myCounter implements Countable {
    private $count = 0;
    public function count() {
        return ++$this->count;
    }
}

$counter = new myCounter;

for($i=0; $i<10; ++$i) {
    echo "I have been count()ed " . count($counter) . " times\n";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

I have been count()ed 1 times
I have been count()ed 2 times
I have been count()ed 3 times
I have been count()ed 4 times
I have been count()ed 5 times
I have been count()ed 6 times
I have been count()ed 7 times
I have been count()ed 8 times
I have been count()ed 9 times
I have been count()ed 10 times

Countable
OuterIterator
Countable


The OuterIterator interface

(PHP 5 >= 5.1.0, PHP 7)

Giriş

Classes implementing OuterIterator can be used to iterate over iterators.

Arayüz Sözdizimi

OuterIterator extends Iterator {
/* Yöntemler */
public Iterator getInnerIterator ( void )
/* Miras alınan yöntemler */
abstract public mixed Iterator::current ( void )
abstract public scalar Iterator::key ( void )
abstract public void Iterator::next ( void )
abstract public void Iterator::rewind ( void )
abstract public boolean Iterator::valid ( void )
}

İçindekiler

  • OuterIterator::getInnerIterator — Returns the inner iterator for the current entry.
Countable::count
OuterIterator::getInnerIterator
Interfaces


Returns the inner iterator for the current entry.

OuterIterator
RecursiveIterator
OuterIterator
PHP Manual

OuterIterator::getInnerIterator

(PHP 5 >= 5.1.0, PHP 7)

OuterIterator::getInnerIterator — Returns the inner iterator for the current entry.

Açıklama

public Iterator OuterIterator::getInnerIterator ( void )

Returns the inner iterator for the current iterator entry.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The inner iterator for the current entry.

OuterIterator
RecursiveIterator
OuterIterator


The RecursiveIterator interface

(PHP 5 >= 5.1.0, PHP 7)

Giriş

Classes implementing RecursiveIterator can be used to iterate over iterators recursively.

Arayüz Sözdizimi

RecursiveIterator extends Iterator {
/* Yöntemler */
public RecursiveIterator getChildren ( void )
public bool hasChildren ( void )
/* Miras alınan yöntemler */
abstract public mixed Iterator::current ( void )
abstract public scalar Iterator::key ( void )
abstract public void Iterator::next ( void )
abstract public void Iterator::rewind ( void )
abstract public boolean Iterator::valid ( void )
}

İçindekiler

  • RecursiveIterator::getChildren — Returns an iterator for the current entry.
  • RecursiveIterator::hasChildren — Returns if an iterator can be created fot the current entry.
OuterIterator::getInnerIterator
RecursiveIterator::getChildren
Interfaces


Returns an iterator for the current entry.

RecursiveIterator
RecursiveIterator::hasChildren
RecursiveIterator
PHP Manual

RecursiveIterator::getChildren

(PHP 5 >= 5.1.0, PHP 7)

RecursiveIterator::getChildren — Returns an iterator for the current entry.

Açıklama

public RecursiveIterator RecursiveIterator::getChildren ( void )

Returns an iterator for the current iterator entry.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

An iterator for the current entry.

Ayrıca Bakınız

  • RecursiveIterator::hasChildren() - Returns if an iterator can be created fot the current entry.

RecursiveIterator
RecursiveIterator::hasChildren
RecursiveIterator


Returns if an iterator can be created fot the current entry.

RecursiveIterator::getChildren
SeekableIterator
RecursiveIterator
PHP Manual

RecursiveIterator::hasChildren

(PHP 5 >= 5.1.0, PHP 7)

RecursiveIterator::hasChildren — Returns if an iterator can be created fot the current entry.

Açıklama

public bool RecursiveIterator::hasChildren ( void )

Returns if an iterator can be created for the current entry. RecursiveIterator::getChildren().

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the current entry can be iterated over, otherwise returns FALSE.

Ayrıca Bakınız

  • RecursiveIterator::getChildren() - Returns an iterator for the current entry.

RecursiveIterator::getChildren
SeekableIterator
RecursiveIterator


The SeekableIterator interface

(PHP 5 >= 5.1.0, PHP 7)

Giriş

The Seekable iterator.

Arayüz Sözdizimi

SeekableIterator extends Iterator {
/* Yöntemler */
abstract public void seek ( int $position )
/* Miras alınan yöntemler */
abstract public mixed Iterator::current ( void )
abstract public scalar Iterator::key ( void )
abstract public void Iterator::next ( void )
abstract public void Iterator::rewind ( void )
abstract public boolean Iterator::valid ( void )
}

Örnek 1 Basic usage

This example demonstrates creating a custom SeekableIterator, seeking to a position and handling an invalid position.

<?php
class MySeekableIterator implements SeekableIterator {

    private $position;

    private $array = array(
        "first element",
        "second element",
        "third element",
        "fourth element"
    );

    /* Method required for SeekableIterator interface */

    public function seek($position) {
      if (!isset($this->array[$position])) {
          throw new OutOfBoundsException("invalid seek position ($position)");
      }

      $this->position = $position;
    }

    /* Methods required for Iterator interface */

    public function rewind() {
        $this->position = 0;
    }

    public function current() {
        return $this->array[$this->position];
    }

    public function key() {
        return $this->position;
    }

    public function next() {
        ++$this->position;
    }

    public function valid() {
        return isset($this->array[$this->position]);
    }
}

try {

    $it = new MySeekableIterator;
    echo $it->current(), "\n";

    $it->seek(2);
    echo $it->current(), "\n";

    $it->seek(1);
    echo $it->current(), "\n";

    $it->seek(10);

} catch (OutOfBoundsException $e) {
    echo $e->getMessage();
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

first element
third element
second element
invalid seek position (10)

İçindekiler

  • SeekableIterator::seek — Seeks to a position
RecursiveIterator::hasChildren
SeekableIterator::seek
Interfaces


Seeks to a position

SeekableIterator
Exceptions
SeekableIterator
PHP Manual

SeekableIterator::seek

(PHP 5 >= 5.1.0, PHP 7)

SeekableIterator::seek — Seeks to a position

Açıklama

abstract public void SeekableIterator::seek ( int $position )

Seeks to a given position in the iterator.

Değiştirgeler

position

The position to seek to.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

Implementations should throw an OutOfBoundsException if the position is not seekable.

Örnekler

Örnek 1 SeekableIterator::seek() example

Seek to the item at position 3 in the iterator (ArrayIterator implements SeekableIterator).

<?php
$array = array("apple", "banana", "cherry", "damson", "elderberry");
$iterator = new ArrayIterator($array);
$iterator->seek(3);
echo $iterator->current();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

damson

Ayrıca Bakınız

  • SeekableIterator
  • Iterator

SeekableIterator
Exceptions
SeekableIterator


Exceptions

İçindekiler

  • BadFunctionCallException
  • BadMethodCallException
  • DomainException
  • InvalidArgumentException
  • LengthException
  • LogicException
  • OutOfBoundsException
  • OutOfRangeException
  • OverflowException
  • RangeException
  • RuntimeException
  • UnderflowException
  • UnexpectedValueException

SPL provides a set of standard Exceptions.

See also the Öntanımlı İstisnalar

SPL Exceptions Class Tree

  • LogicException (extends Exception)
    • BadFunctionCallException
      • BadMethodCallException
    • DomainException
    • InvalidArgumentException
    • LengthException
    • OutOfRangeException
  • RuntimeException (extends Exception)
    • OutOfBoundsException
    • OverflowException
    • RangeException
    • UnderflowException
    • UnexpectedValueException
SeekableIterator::seek
BadFunctionCallException
SPL


The BadFunctionCallException class

(PHP 5 >= 5.1.0, PHP 7)

Giriş

Exception thrown if a callback refers to an undefined function or if some arguments are missing.

Sınıf Sözdizimi

BadFunctionCallException extends LogicException {
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}
Exceptions
BadMethodCallException
Exceptions


The BadMethodCallException class

(PHP 5 >= 5.1.0, PHP 7)

Giriş

Exception thrown if a callback refers to an undefined method or if some arguments are missing.

Sınıf Sözdizimi

BadMethodCallException extends BadFunctionCallException {
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}
BadFunctionCallException
DomainException
Exceptions


The DomainException class

(PHP 5 >= 5.1.0, PHP 7)

Giriş

Exception thrown if a value does not adhere to a defined valid data domain.

Sınıf Sözdizimi

DomainException extends LogicException {
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}
BadMethodCallException
InvalidArgumentException
Exceptions


The InvalidArgumentException class

(PHP 5 >= 5.1.0, PHP 7)

Giriş

Exception thrown if an argument is not of the expected type.

Sınıf Sözdizimi

InvalidArgumentException extends LogicException {
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}
DomainException
LengthException
Exceptions


The LengthException class

(PHP 5 >= 5.1.0, PHP 7)

Giriş

Exception thrown if a length is invalid.

Sınıf Sözdizimi

LengthException extends LogicException {
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}
InvalidArgumentException
LogicException
Exceptions


The LogicException class

(PHP 5 >= 5.1.0, PHP 7)

Giriş

Exception that represents error in the program logic. This kind of exception should lead directly to a fix in your code.

Sınıf Sözdizimi

LogicException extends Exception {
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}
LengthException
OutOfBoundsException
Exceptions


The OutOfBoundsException class

(PHP 5 >= 5.1.0, PHP 7)

Giriş

Exception thrown if a value is not a valid key. This represents errors that cannot be detected at compile time.

Sınıf Sözdizimi

OutOfBoundsException extends RuntimeException {
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}
LogicException
OutOfRangeException
Exceptions


The OutOfRangeException class

(PHP 5 >= 5.1.0, PHP 7)

Giriş

Exception thrown when an illegal index was requested. This represents errors that should be detected at compile time.

Sınıf Sözdizimi

OutOfRangeException extends LogicException {
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}
OutOfBoundsException
OverflowException
Exceptions


The OverflowException class

(PHP 5 >= 5.1.0, PHP 7)

Giriş

Exception thrown when adding an element to a full container.

Sınıf Sözdizimi

OverflowException extends RuntimeException {
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}
OutOfRangeException
RangeException
Exceptions


The RangeException class

(PHP 5 >= 5.1.0, PHP 7)

Giriş

Exception thrown to indicate range errors during program execution. Normally this means there was an arithmetic error other than under/overflow. This is the runtime version of DomainException.

Sınıf Sözdizimi

RangeException extends RuntimeException {
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}
OverflowException
RuntimeException
Exceptions


The RuntimeException class

(PHP 5 >= 5.1.0, PHP 7)

Giriş

Exception thrown if an error which can only be found on runtime occurs.

Sınıf Sözdizimi

RuntimeException extends Exception {
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}
RangeException
UnderflowException
Exceptions


The UnderflowException class

(PHP 5 >= 5.1.0, PHP 7)

Giriş

Exception thrown when performing an invalid operation on an empty container, such as removing an element.

Sınıf Sözdizimi

UnderflowException extends RuntimeException {
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}
RuntimeException
UnexpectedValueException
Exceptions


The UnexpectedValueException class

(PHP 5 >= 5.1.0, PHP 7)

Giriş

Exception thrown if a value does not match with a set of values. Typically this happens when a function calls another function and expects the return value to be of a certain type or value not including arithmetic or buffer related errors.

Sınıf Sözdizimi

UnexpectedValueException extends RuntimeException {
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}
UnderflowException
SPL İşlevleri
Exceptions


SPL İşlevleri

İçindekiler

  • class_implements — Return the interfaces which are implemented by the given class or interface
  • class_parents — Return the parent classes of the given class
  • class_uses — Return the traits used by the given class
  • iterator_apply — Call a function for every element in an iterator
  • iterator_count — Count the elements in an iterator
  • iterator_to_array — Copy the iterator into an array
  • spl_autoload_call — Try all registered __autoload() function to load the requested class
  • spl_autoload_extensions — Register and return default file extensions for spl_autoload
  • spl_autoload_functions — Return all registered __autoload() functions
  • spl_autoload_register — Register given function as __autoload() implementation
  • spl_autoload_unregister — Unregister given function as __autoload() implementation
  • spl_autoload — Default implementation for __autoload()
  • spl_classes — Return available SPL classes
  • spl_object_hash — Return hash id for given object
UnexpectedValueException
class_implements
SPL


Return the interfaces which are implemented by the given class or interface

SPL İşlevleri
class_parents
SPL İşlevleri
PHP Manual

class_implements

(PHP 5 >= 5.1.0, PHP 7)

class_implements — Return the interfaces which are implemented by the given class or interface

Açıklama

array class_implements ( mixed $class [, bool $autoload = true ] )

This function returns an array with the names of the interfaces that the given class and its parents implement.

Değiştirgeler

class

An object (class instance) or a string (class or interface name).

autoload

Whether to allow this function to load the class automatically through the __autoload() magic method.

Dönen Değerler

An array on success, or FALSE on error.

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.0 | Added the option to pass the class parameter as a string. Added the autoload parameter.

Örnekler

Örnek 1 class_implements() example

<?php

interface foo { }
class bar implements foo {}

print_r(class_implements(new bar));

// since PHP 5.1.0 you may also specify the parameter as a string
print_r(class_implements('bar'));

function __autoload($class_name) {
   require_once $class_name . '.php';
}

// use __autoload to load the 'not_loaded' class
print_r(class_implements('not_loaded', true));

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [foo] => foo
)

Array
(
    [interface_of_not_loaded] => interface_of_not_loaded
)

Ayrıca Bakınız

  • class_parents() - Return the parent classes of the given class
  • get_declared_interfaces() - Bildirilmiş tüm arayüzleri bir dizi olarak döndürür

SPL İşlevleri
class_parents
SPL İşlevleri


Return the parent classes of the given class

class_implements
class_uses
SPL İşlevleri
PHP Manual

class_parents

(PHP 5 >= 5.1.0, PHP 7)

class_parents — Return the parent classes of the given class

Açıklama

array class_parents ( mixed $class [, bool $autoload = true ] )

This function returns an array with the name of the parent classes of the given class.

Değiştirgeler

class

An object (class instance) or a string (class name).

autoload

Whether to allow this function to load the class automatically through the __autoload() magic method.

Dönen Değerler

An array on success, or FALSE on error.

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.0 | Added the option to pass the class parameter as a string. Added the autoload parameter.

Örnekler

Örnek 1 class_parents() example

<?php

class foo { }
class bar extends foo {}

print_r(class_parents(new bar));

// since PHP 5.1.0 you may also specify the parameter as a string
print_r(class_parents('bar'));

function __autoload($class_name) {
   require_once $class_name . '.php';
}

// use __autoload to load the 'not_loaded' class
print_r(class_parents('not_loaded', true));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [foo] => foo
)

Array
(
    [parent_of_not_loaded] => parent_of_not_loaded
)

Ayrıca Bakınız

  • class_implements() - Return the interfaces which are implemented by the given class or interface

class_implements
class_uses
SPL İşlevleri


Return the traits used by the given class

class_parents
iterator_apply
SPL İşlevleri
PHP Manual

class_uses

(PHP 5 >= 5.4.0, PHP 7)

class_uses — Return the traits used by the given class

Açıklama

array class_uses ( mixed $class [, bool $autoload = true ] )

This function returns an array with the names of the traits that the given class uses. This does however not include any traits used by a parent class.

Değiştirgeler

class

An object (class instance) or a string (class name).

autoload

Whether to allow this function to load the class automatically through the __autoload() magic method.

Dönen Değerler

An array on success, or FALSE on error.

Örnekler

Örnek 1 class_uses() example

<?php

trait foo { }
class bar {
  use foo;
}

print_r(class_uses(new bar));

print_r(class_uses('bar'));

function __autoload($class_name) {
   require_once $class_name . '.php';
}

// use __autoload to load the 'not_loaded' class
print_r(class_uses('not_loaded', true));

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [foo] => foo
)

Array
(
    [foo] => foo
)

Array
(
    [trait_of_not_loaded] => trait_of_not_loaded
)

Ayrıca Bakınız

  • class_parents() - Return the parent classes of the given class
  • get_declared_traits() - Returns an array of all declared traits

class_parents
iterator_apply
SPL İşlevleri


Call a function for every element in an iterator

class_uses
iterator_count
SPL İşlevleri
PHP Manual

iterator_apply

(PHP 5 >= 5.1.0, PHP 7)

iterator_apply — Call a function for every element in an iterator

Açıklama

int iterator_apply ( Traversable $iterator , callable $function [, array $args ] )

Calls a function for every element in an iterator.

Değiştirgeler

iterator

The class to iterate over.

function

The callback function to call on every element.

Bilginize: The function must return TRUE in order to continue iterating over the iterator.

args

Arguments to pass to the callback function.

Dönen Değerler

Returns the iteration count.

Örnekler

Örnek 1 iterator_apply() example

<?php
function print_caps(Iterator $iterator) {
    echo strtoupper($iterator->current()) . "\n";
    return TRUE;
}

$it = new ArrayIterator(array("Apples", "Bananas", "Cherries"));
iterator_apply($it, "print_caps", array($it));
?>

Yukarıdaki örneğin çıktısı:

APPLES
BANANAS
CHERRIES

Ayrıca Bakınız

  • array_walk() - Bir dizinin her üyesine kullanıcı tanımlı bir işlevi uygular

class_uses
iterator_count
SPL İşlevleri


Count the elements in an iterator

iterator_apply
iterator_to_array
SPL İşlevleri
PHP Manual

iterator_count

(PHP 5 >= 5.1.0, PHP 7)

iterator_count — Count the elements in an iterator

Açıklama

int iterator_count ( Traversable $iterator )

Count the elements in an iterator. iterator_count() is not guaranteed to retain the current position of the iterator.

Değiştirgeler

iterator

The iterator being counted.

Dönen Değerler

The number of elements in iterator.

Örnekler

Örnek 1 iterator_count() example

<?php
$iterator = new ArrayIterator(array('recipe'=>'pancakes', 'egg', 'milk', 'flour'));
var_dump(iterator_count($iterator));
?>

Yukarıdaki örneğin çıktısı:

int(4)

Örnek 2 iterator_count() modifies position

<?php
$iterator = new ArrayIterator(['one', 'two', 'three']);
var_dump($iterator->current());
var_dump(iterator_count($iterator));
var_dump($iterator->current());
?>

Yukarıdaki örneğin çıktısı:

string(3) "one"
int(3)
NULL

Örnek 3 iterator_count() in foreach loops

<?php
$iterator = new ArrayIterator(['one', 'two', 'three']);
foreach ($iterator as $key => $value) {
    echo "$key: $value (", iterator_count($iterator), ")\n";
}?>

Yukarıdaki örneğin çıktısı:

0: one (3)

iterator_apply
iterator_to_array
SPL İşlevleri


Copy the iterator into an array

iterator_count
spl_autoload_call
SPL İşlevleri
PHP Manual

iterator_to_array

(PHP 5 >= 5.1.0, PHP 7)

iterator_to_array — Copy the iterator into an array

Açıklama

array iterator_to_array ( Traversable $iterator [, bool $use_keys = true ] )

Copy the elements of an iterator into an array.

Değiştirgeler

iterator

The iterator being copied.

use_keys

Whether to use the iterator element keys as index.

In PHP 5.5 and later, if a key is an array or object, a warning will be generated. NULL keys will be converted to an empty string, double keys will be truncated to their integer counterpart, resource keys will generate a warning and be converted to their resource ID, and boolean keys will be converted to integers.

Bilginize:

If this parameter is not set or set to TRUE, duplicate keys will be overwritten. The last value with a given key will be in the returned array. Set this paramater to FALSE to get all the values in any case.

Dönen Değerler

An array containing the elements of the iterator.

Sürüm Bilgisi

Sürüm: | Açıklama
5.5.0 | iterator_to_array() gained support for key types other than integer and string when the use_keys parameter is enabled.
5.2.1 | The use_keys parameter was added.

Örnekler

Örnek 1 iterator_to_array() example

<?php
$iterator = new ArrayIterator(array('recipe'=>'pancakes', 'egg', 'milk', 'flour'));
var_dump(iterator_to_array($iterator, true));
var_dump(iterator_to_array($iterator, false));
?>

Yukarıdaki örneğin çıktısı:

array(4) {
  ["recipe"]=>
  string(8) "pancakes"
  [0]=>
  string(3) "egg"
  [1]=>
  string(4) "milk"
  [2]=>
  string(5) "flour"
}
array(4) {
  [0]=>
  string(8) "pancakes"
  [1]=>
  string(3) "egg"
  [2]=>
  string(4) "milk"
  [3]=>
  string(5) "flour"
}

iterator_count
spl_autoload_call
SPL İşlevleri


Try all registered __autoload() function to load the requested class

iterator_to_array
spl_autoload_extensions
SPL İşlevleri
PHP Manual

spl_autoload_call

(PHP 5 >= 5.1.2, PHP 7)

spl_autoload_call — Try all registered __autoload() function to load the requested class

Açıklama

void spl_autoload_call ( string $class_name )

This function can be used to manually search for a class or interface using the registered __autoload functions.

Değiştirgeler

class_name

The class name being searched.

Dönen Değerler

Hiçbir değer dönmez.

iterator_to_array
spl_autoload_extensions
SPL İşlevleri


Register and return default file extensions for spl_autoload

spl_autoload_call
spl_autoload_functions
SPL İşlevleri
PHP Manual

spl_autoload_extensions

(PHP 5 >= 5.1.2, PHP 7)

spl_autoload_extensions — Register and return default file extensions for spl_autoload

Açıklama

string spl_autoload_extensions ([ string $file_extensions ] )

This function can modify and check the file extensions that the built in __autoload() fallback function spl_autoload() will be using.

Değiştirgeler

file_extensions

When calling without an argument, it simply returns the current list of extensions each separated by comma. To modify the list of file extensions, simply invoke the functions with the new list of file extensions to use in a single string with each extensions separated by comma.

Dönen Değerler

A comma delimited list of default file extensions for spl_autoload().

spl_autoload_call
spl_autoload_functions
SPL İşlevleri


Return all registered __autoload() functions

spl_autoload_extensions
spl_autoload_register
SPL İşlevleri
PHP Manual

spl_autoload_functions

(PHP 5 >= 5.1.2, PHP 7)

spl_autoload_functions — Return all registered __autoload() functions

Açıklama

array spl_autoload_functions ( void )

Get all registered __autoload() functions.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

An array of all registered __autoload functions. If the autoload queue is not activated then the return value is FALSE. If no function is registered the return value will be an empty array.

spl_autoload_extensions
spl_autoload_register
SPL İşlevleri


Register given function as __autoload() implementation

spl_autoload_functions
spl_autoload_unregister
SPL İşlevleri
PHP Manual

spl_autoload_register

(PHP 5 >= 5.1.2, PHP 7)

spl_autoload_register — Register given function as __autoload() implementation

Açıklama

bool spl_autoload_register ([ callable $autoload_function [, bool $throw = true [, bool $prepend = false ]]] )

Register a function with the spl provided __autoload queue. If the queue is not yet activated it will be activated.

If your code has an existing __autoload() function then this function must be explicitly registered on the __autoload queue. This is because spl_autoload_register() will effectively replace the engine cache for the __autoload() function by either spl_autoload() or spl_autoload_call().

If there must be multiple autoload functions, spl_autoload_register() allows for this. It effectively creates a queue of autoload functions, and runs through each of them in the order they are defined. By contrast, __autoload() may only be defined once.

Değiştirgeler

autoload_function

The autoload function being registered. If no parameter is provided, then the default implementation of spl_autoload() will be registered.

throw

This parameter specifies whether spl_autoload_register() should throw exceptions when the autoload_function cannot be registered.

prepend

If true, spl_autoload_register() will prepend the autoloader on the autoload queue instead of appending it.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | Namespaces support was introduced.
5.3.0 | The prepend parameter was added.

Örnekler

Örnek 1 spl_autoload_register() as a replacement for an __autoload() function

<?php

// function __autoload($class) {
//     include 'classes/' . $class . '.class.php';
// }

function my_autoloader($class) {
    include 'classes/' . $class . '.class.php';
}

spl_autoload_register('my_autoloader');

// Or, using an anonymous function as of PHP 5.3.0
spl_autoload_register(function ($class) {
    include 'classes/' . $class . '.class.php';
});

?>

Örnek 2 spl_autoload_register() example where the class is not loaded

<?php

namespace Foobar;

class Foo {
    static public function test($name) {
        print '[['. $name .']]';
    }
}

spl_autoload_register(__NAMESPACE__ .'\Foo::test'); // As of PHP 5.3.0

new InexistentClass;

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

[[Foobar\InexistentClass]]
Fatal error: Class 'Foobar\InexistentClass' not found in ...

Ayrıca Bakınız

  • __autoload() - Attempt to load undefined class

spl_autoload_functions
spl_autoload_unregister
SPL İşlevleri


Unregister given function as __autoload() implementation

spl_autoload_register
spl_autoload
SPL İşlevleri
PHP Manual

spl_autoload_unregister

(PHP 5 >= 5.1.2, PHP 7)

spl_autoload_unregister — Unregister given function as __autoload() implementation

Açıklama

bool spl_autoload_unregister ( mixed $autoload_function )

Removes a function from the autoload queue. If the queue is activated and empty after removing the given function then it will be deactivated.

When this function results in the queue being deactivated, any __autoload function that previously existed will not be reactivated.

Değiştirgeler

autoload_function

The autoload function being unregistered.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

spl_autoload_register
spl_autoload
SPL İşlevleri


Default implementation for __autoload()

spl_autoload_unregister
spl_classes
SPL İşlevleri
PHP Manual

spl_autoload

(PHP 5 >= 5.1.2, PHP 7)

spl_autoload — Default implementation for __autoload()

Açıklama

void spl_autoload ( string $class_name [, string $file_extensions = spl_autoload_extensions() ] )

This function is intended to be used as a default implementation for __autoload(). If nothing else is specified and spl_autoload_register() is called without any parameters then this function will be used for any later call to __autoload().

Değiştirgeler

class_name

The lowercased name of the class (and namespace) being instantiated.

file_extensions

By default it checks all include paths to contain filenames built up by the lowercase class name appended by the filename extensions .inc and .php.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

Throws LogicException when the class is not found and there are no other autoloaders registered.

spl_autoload_unregister
spl_classes
SPL İşlevleri


Return available SPL classes

spl_autoload
spl_object_hash
SPL İşlevleri
PHP Manual

spl_classes

(PHP 5, PHP 7)

spl_classes — Return available SPL classes

Açıklama

array spl_classes ( void )

This function returns an array with the current available SPL classes.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array containing the currently available SPL classes.

Örnekler

Örnek 1 spl_classes() example

<?php

print_r(spl_classes());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [ArrayObject] => ArrayObject
    [ArrayIterator] => ArrayIterator
    [CachingIterator] => CachingIterator
    [RecursiveCachingIterator] => RecursiveCachingIterator
    [DirectoryIterator] => DirectoryIterator
    [FilterIterator] => FilterIterator
    [LimitIterator] => LimitIterator
    [ParentIterator] => ParentIterator
    [RecursiveDirectoryIterator] => RecursiveDirectoryIterator
    [RecursiveIterator] => RecursiveIterator
    [RecursiveIteratorIterator] => RecursiveIteratorIterator
    [SeekableIterator] => SeekableIterator
    [SimpleXMLIterator] => SimpleXMLIterator
)

spl_autoload
spl_object_hash
SPL İşlevleri


Return hash id for given object

spl_classes
File Handling
SPL İşlevleri
PHP Manual

spl_object_hash

(PHP 5 >= 5.2.0, PHP 7)

spl_object_hash — Return hash id for given object

Açıklama

string spl_object_hash ( object $obj )

This function returns a unique identifier for the object. This id can be used as a hash key for storing objects, or for identifying an object, as long as the object is not destroyed. Once the object is destroyed, its hash may be reused for other objects.

Değiştirgeler

object

Any object.

Dönen Değerler

A string that is unique for each currently existing object and is always the same for each object.

Örnekler

Örnek 1 A spl_object_hash() example

<?php
$id = spl_object_hash($object);
$storage[$id] = $object;
?>

Notlar

Bilginize:

When an object is destroyed, its hash may be reused for other objects.

spl_classes
File Handling
SPL İşlevleri


File Handling

İçindekiler

  • SplFileInfo
  • SplFileObject
  • SplTempFileObject

SPL provides a number of classes to work with files.

spl_object_hash
SplFileInfo
SPL


The SplFileInfo class

(PHP 5 >= 5.1.2, PHP 7)

Giriş

The SplFileInfo class offers a high-level object oriented interface to information for an individual file.

Sınıf Sözdizimi

SplFileInfo {
/* Yöntemler */
public __construct ( string $file_name )
public int getATime ( void )
public string getBasename ([ string $suffix ] )
public int getCTime ( void )
public string getExtension ( void )
public SplFileInfo getFileInfo ([ string $class_name ] )
public string getFilename ( void )
public int getGroup ( void )
public int getInode ( void )
public string getLinkTarget ( void )
public int getMTime ( void )
public int getOwner ( void )
public string getPath ( void )
public SplFileInfo getPathInfo ([ string $class_name ] )
public string getPathname ( void )
public int getPerms ( void )
public string getRealPath ( void )
public int getSize ( void )
public string getType ( void )
public bool isDir ( void )
public bool isExecutable ( void )
public bool isFile ( void )
public bool isLink ( void )
public bool isReadable ( void )
public bool isWritable ( void )
public SplFileObject openFile ([ string $open_mode = "r" [, bool $use_include_path = false [, resource $context = NULL ]]] )
public void setFileClass ([ string $class_name = "SplFileObject" ] )
public void setInfoClass ([ string $class_name = "SplFileInfo" ] )
public void __toString ( void )
}

İçindekiler

  • SplFileInfo::__construct — Construct a new SplFileInfo object
  • SplFileInfo::getATime — Gets last access time of the file
  • SplFileInfo::getBasename — Gets the base name of the file
  • SplFileInfo::getCTime — Gets the inode change time
  • SplFileInfo::getExtension — Gets the file extension
  • SplFileInfo::getFileInfo — Gets an SplFileInfo object for the file
  • SplFileInfo::getFilename — Gets the filename
  • SplFileInfo::getGroup — Gets the file group
  • SplFileInfo::getInode — Gets the inode for the file
  • SplFileInfo::getLinkTarget — Gets the target of a link
  • SplFileInfo::getMTime — Gets the last modified time
  • SplFileInfo::getOwner — Gets the owner of the file
  • SplFileInfo::getPath — Gets the path without filename
  • SplFileInfo::getPathInfo — Gets an SplFileInfo object for the path
  • SplFileInfo::getPathname — Gets the path to the file
  • SplFileInfo::getPerms — Gets file permissions
  • SplFileInfo::getRealPath — Gets absolute path to file
  • SplFileInfo::getSize — Gets file size
  • SplFileInfo::getType — Gets file type
  • SplFileInfo::isDir — Tells if the file is a directory
  • SplFileInfo::isExecutable — Tells if the file is executable
  • SplFileInfo::isFile — Tells if the object references a regular file
  • SplFileInfo::isLink — Tells if the file is a link
  • SplFileInfo::isReadable — Tells if file is readable
  • SplFileInfo::isWritable — Tells if the entry is writable
  • SplFileInfo::openFile — Gets an SplFileObject object for the file
  • SplFileInfo::setFileClass — Sets the class used with SplFileInfo::openFile
  • SplFileInfo::setInfoClass — Sets the class used with SplFileInfo::getFileInfo and SplFileInfo::getPathInfo
  • SplFileInfo::__toString — Returns the path to the file as a string
File Handling
SplFileInfo::__construct
File Handling


Construct a new SplFileInfo object

SplFileInfo
SplFileInfo::getATime
SplFileInfo
PHP Manual

SplFileInfo::__construct

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::__construct — Construct a new SplFileInfo object

Açıklama

public SplFileInfo::__construct ( string $file_name )

Creates a new SplFileInfo object for the file_name specified. The file does not need to exist, or be readable.

Değiştirgeler

file_name

Path to the file.

Örnekler

Örnek 1 SplFileInfo::__construct() example

<?php
$info = new SplFileInfo('example.php');
if ($info->isFile()) {
    echo $info->getRealPath();
}
?>

SplFileInfo
SplFileInfo::getATime
SplFileInfo


Gets last access time of the file

SplFileInfo::__construct
SplFileInfo::getBasename
SplFileInfo
PHP Manual

SplFileInfo::getATime

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::getATime — Gets last access time of the file

Açıklama

public int SplFileInfo::getATime ( void )

Gets the last access time for the file.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the time the file was last accessed.

Hatalar/İstisnalar

Throws RunTimeException on error.

Ayrıca Bakınız

  • fileatime() - Dosyaya son erişim zamanını döndürür

SplFileInfo::__construct
SplFileInfo::getBasename
SplFileInfo


Gets the base name of the file

SplFileInfo::getATime
SplFileInfo::getCTime
SplFileInfo
PHP Manual

SplFileInfo::getBasename

(PHP 5 >= 5.2.2, PHP 7)

SplFileInfo::getBasename — Gets the base name of the file

Açıklama

public string SplFileInfo::getBasename ([ string $suffix ] )

This method returns the base name of the file, directory, or link without path info.

Değiştirgeler

suffix

Optional suffix to omit from the base name returned.

Dönen Değerler

Returns the base name without path information.

Örnekler

Örnek 1 SplFileInfo::getBasename() example

<?php
$info = new SplFileInfo('file.txt');
var_dump($info->getBasename());

$info = new SplFileInfo('/path/to/file.txt');
var_dump($info->getBasename());

$info = new SplFileInfo('/path/to/file.txt');
var_dump($info->getBasename('.txt'));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(8) "file.txt"
string(8) "file.txt"
string(4) "file"

Ayrıca Bakınız

  • SplFileInfo::getFilename() - Gets the filename

SplFileInfo::getATime
SplFileInfo::getCTime
SplFileInfo


Gets the inode change time

SplFileInfo::getBasename
SplFileInfo::getExtension
SplFileInfo
PHP Manual

SplFileInfo::getCTime

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::getCTime — Gets the inode change time

Açıklama

public int SplFileInfo::getCTime ( void )

Returns the inode change time for the file. The time returned is a Unix timestamp.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The last change time, in a Unix timestamp.

Hatalar/İstisnalar

Throws RunTimeException on error.

Örnekler

Örnek 1 SplFileInfo::getCTime() example

<?php
$info = new SplFileInfo(__FILE__);
echo 'Last changed at ' . date('g:i a', $info->getCTime());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Last changed at 1:49 pm

Ayrıca Bakınız

  • filectime() - Dosyanın dosya düğümü değişiklik zamanını döndürür

SplFileInfo::getBasename
SplFileInfo::getExtension
SplFileInfo


Gets the file extension

SplFileInfo::getCTime
SplFileInfo::getFileInfo
SplFileInfo
PHP Manual

SplFileInfo::getExtension

(PHP 5 >= 5.3.6, PHP 7)

SplFileInfo::getExtension — Gets the file extension

Açıklama

public string SplFileInfo::getExtension ( void )

Retrieves the file extension.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a string containing the file extension, or an empty string if the file has no extension.

Örnekler

Örnek 1 SplFileInfo::getExtension() example

<?php

$info = new SplFileInfo('foo.txt');
var_dump($info->getExtension());

$info = new SplFileInfo('photo.jpg');
var_dump($info->getExtension());

$info = new SplFileInfo('something.tar.gz');
var_dump($info->getExtension());

?>

Yukarıdaki örneğin çıktısı:

string(3) "txt"
string(3) "jpg"
string(2) "gz"

Notlar

Bilginize:

This method is only available as of PHP 5.3.6. Another way of getting the extension is to use the pathinfo() function.

<?php
$extension = pathinfo($info->getFilename(), PATHINFO_EXTENSION);
?>

Ayrıca Bakınız

  • SplFileInfo::getFilename() - Gets the filename
  • SplFileInfo::getBasename() - Gets the base name of the file
  • pathinfo() - Bir dosya yolu hakkında bilgi döndürür
SplFileInfo::getCTime
SplFileInfo::getFileInfo
SplFileInfo


Gets an SplFileInfo object for the file

SplFileInfo::getExtension
SplFileInfo::getFilename
SplFileInfo
PHP Manual

SplFileInfo::getFileInfo

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::getFileInfo — Gets an SplFileInfo object for the file

Açıklama

public SplFileInfo SplFileInfo::getFileInfo ([ string $class_name ] )

This method gets an SplFileInfo object for the referenced file.

Değiştirgeler

class_name

Name of an SplFileInfo derived class to use.

Dönen Değerler

An SplFileInfo object created for the file.

Ayrıca Bakınız

  • SplFileInfo::setInfoClass() - Sets the class used with SplFileInfo::getFileInfo and SplFileInfo::getPathInfo

SplFileInfo::getExtension
SplFileInfo::getFilename
SplFileInfo


Gets the filename

SplFileInfo::getFileInfo
SplFileInfo::getGroup
SplFileInfo
PHP Manual

SplFileInfo::getFilename

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::getFilename — Gets the filename

Açıklama

public string SplFileInfo::getFilename ( void )

Gets the filename without any path information.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The filename.

Örnekler

Örnek 1 SplFileInfo::getFilename() example

<?php
$info = new SplFileInfo('foo.txt');
var_dump($info->getFilename());

$info = new SplFileInfo('/path/to/foo.txt');
var_dump($info->getFilename());

$info = new SplFileInfo('http://www.php.net/');
var_dump($info->getFilename());

$info = new SplFileInfo('http://www.php.net/svn.php');
var_dump($info->getFilename());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(7) "foo.txt"
string(7) "foo.txt"
string(0) ""
string(7) "svn.php"

Ayrıca Bakınız

  • SplFileInfo::getBasename() - Gets the base name of the file

SplFileInfo::getFileInfo
SplFileInfo::getGroup
SplFileInfo


Gets the file group

SplFileInfo::getFilename
SplFileInfo::getInode
SplFileInfo
PHP Manual

SplFileInfo::getGroup

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::getGroup — Gets the file group

Açıklama

public int SplFileInfo::getGroup ( void )

Gets the file group. The group ID is returned in numerical format.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The group id in numerical format.

Hatalar/İstisnalar

Throws RuntimeException on error.

Örnekler

Örnek 1 SplFileInfo::getGroup() example

<?php
$info = new SplFileInfo(__FILE__);
print_r(posix_getgrgid($info->getGroup()));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ayrıca Bakınız

  • posix_getgrgid() - Grup kimliği belirtilen grup hakkında bilgi verir

SplFileInfo::getFilename
SplFileInfo::getInode
SplFileInfo


Gets the inode for the file

SplFileInfo::getGroup
SplFileInfo::getLinkTarget
SplFileInfo
PHP Manual

SplFileInfo::getInode

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::getInode — Gets the inode for the file

Açıklama

public int SplFileInfo::getInode ( void )

Gets the inode number for the filesystem object.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the inode number for the filesystem object.

Hatalar/İstisnalar

Throws RuntimeException on error.

Ayrıca Bakınız

  • fileinode() - Dosyanın düğüm numarasını döndürür

SplFileInfo::getGroup
SplFileInfo::getLinkTarget
SplFileInfo


Gets the target of a link

SplFileInfo::getInode
SplFileInfo::getMTime
SplFileInfo
PHP Manual

SplFileInfo::getLinkTarget

(PHP 5 >= 5.2.2, PHP 7)

SplFileInfo::getLinkTarget — Gets the target of a link

Açıklama

public string SplFileInfo::getLinkTarget ( void )

Gets the target of a filesystem link.

Bilginize:

The target may not be the real path on the filesystem. Use SplFileInfo::getRealPath() to determine the true path on the filesystem.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the target of the filesystem link.

Hatalar/İstisnalar

Throws RuntimeException on error.

Örnekler

Örnek 1 SplFileInfo::getLinkTarget() example

<?php
$info = new SplFileInfo('/Users/bbieber/workspace');
if ($info->isLink()) {
    var_dump($info->getLinkTarget());
    var_dump($info->getRealPath());
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(19) "Documents/workspace"
string(34) "/Users/bbieber/Documents/workspace"

Ayrıca Bakınız

  • SplFileInfo::isLink() - Tells if the file is a link
  • SplFileInfo::getRealPath() - Gets absolute path to file

SplFileInfo::getInode
SplFileInfo::getMTime
SplFileInfo


Gets the last modified time

SplFileInfo::getLinkTarget
SplFileInfo::getOwner
SplFileInfo
PHP Manual

SplFileInfo::getMTime

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::getMTime — Gets the last modified time

Açıklama

public int SplFileInfo::getMTime ( void )

Returns the time when the contents of the file were changed. The time returned is a Unix timestamp.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the last modified time for the file, in a Unix timestamp.

Ayrıca Bakınız

  • filemtime() - Dosyanın değişiklik zamanını döndürür

SplFileInfo::getLinkTarget
SplFileInfo::getOwner
SplFileInfo


Gets the owner of the file

SplFileInfo::getMTime
SplFileInfo::getPath
SplFileInfo
PHP Manual

SplFileInfo::getOwner

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::getOwner — Gets the owner of the file

Açıklama

public int SplFileInfo::getOwner ( void )

Gets the file owner. The owner ID is returned in numerical format.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The owner id in numerical format.

Hatalar/İstisnalar

Throws RuntimeException on error.

Örnekler

Örnek 1 SplFileInfo::getOwner() example

<?php
$info = new SplFileInfo('file.txt');
print_r(posix_getpwuid($info->getOwner()));
?>

Ayrıca Bakınız

  • posix_getpwuid() - Kullanıcı kimliği belirtilen kullanıcı hakkında bilgi döndürür
  • SplFileInfo::getGroup() - Gets the file group

SplFileInfo::getMTime
SplFileInfo::getPath
SplFileInfo


Gets the path without filename

SplFileInfo::getOwner
SplFileInfo::getPathInfo
SplFileInfo
PHP Manual

SplFileInfo::getPath

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::getPath — Gets the path without filename

Açıklama

public string SplFileInfo::getPath ( void )

Returns the path to the file, omitting the filename and any trailing slash.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the path to the file.

Örnekler

Örnek 1 SplFileInfo::getPath() example

<?php
$info = new SplFileInfo('/usr/bin/php');
var_dump($info->getPath());

$info = new SplFileInfo('/usr/');
var_dump($info->getPath());?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(8) "/usr/bin"
string(4) "/usr"

Ayrıca Bakınız

  • SplFileInfo::getRealPath() - Gets absolute path to file
  • SplFileInfo::getFilename() - Gets the filename
  • SplFileInfo::getPathInfo() - Gets an SplFileInfo object for the path

SplFileInfo::getOwner
SplFileInfo::getPathInfo
SplFileInfo


Gets an SplFileInfo object for the path

SplFileInfo::getPath
SplFileInfo::getPathname
SplFileInfo
PHP Manual

SplFileInfo::getPathInfo

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::getPathInfo — Gets an SplFileInfo object for the path

Açıklama

public SplFileInfo SplFileInfo::getPathInfo ([ string $class_name ] )

Gets an SplFileInfo object for the parent of the current file.

Değiştirgeler

class_name

Name of an SplFileInfo derived class to use.

Dönen Değerler

Returns an SplFileInfo object for the parent path of the file.

Örnekler

Örnek 1 SplFileInfo::getPathInfo() example

<?php
$info = new SplFileInfo('/usr/bin/php');
$parent_info = $info->getPathInfo();
var_dump($parent_info->getRealPath());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(8) "/usr/bin"

Ayrıca Bakınız

  • SplFileInfo::setInfoClass() - Sets the class used with SplFileInfo::getFileInfo and SplFileInfo::getPathInfo

SplFileInfo::getPath
SplFileInfo::getPathname
SplFileInfo


Gets the path to the file

SplFileInfo::getPathInfo
SplFileInfo::getPerms
SplFileInfo
PHP Manual

SplFileInfo::getPathname

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::getPathname — Gets the path to the file

Açıklama

public string SplFileInfo::getPathname ( void )

Returns the path to the file.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The path to the file.

Örnekler

Örnek 1 SplFileInfo::getPathname() example

<?php
$info = new SplFileInfo('/usr/bin/php');
var_dump($info->getPathname());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(12) "/usr/bin/php"

Ayrıca Bakınız

  • SplFileInfo::getRealPath() - Gets absolute path to file

SplFileInfo::getPathInfo
SplFileInfo::getPerms
SplFileInfo


Gets file permissions

SplFileInfo::getPathname
SplFileInfo::getRealPath
SplFileInfo
PHP Manual

SplFileInfo::getPerms

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::getPerms — Gets file permissions

Açıklama

public int SplFileInfo::getPerms ( void )

Gets the file permissions for the file.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the file permissions.

Örnekler

Örnek 1 SplFileInfo::getPerms() example

<?php
$info = new SplFileInfo('/tmp');
echo substr(sprintf('%o', $info->getPerms()), -4);

$info = new SplFileInfo(__FILE__);
echo substr(sprintf('%o', $info->getPerms()), -4);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

1777
0644

SplFileInfo::getPathname
SplFileInfo::getRealPath
SplFileInfo


Gets absolute path to file

SplFileInfo::getPerms
SplFileInfo::getSize
SplFileInfo
PHP Manual

SplFileInfo::getRealPath

(PHP 5 >= 5.2.2, PHP 7)

SplFileInfo::getRealPath — Gets absolute path to file

Açıklama

public string SplFileInfo::getRealPath ( void )

This method expands all symbolic links, resolves relative references and returns the real path to the file.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the path to the file, or FALSE if the file does not exist.

Örnekler

Örnek 1 SplFileInfo::getRealPath() example

<?php
$info = new SplFileInfo('/..//./../../'.__FILE__);
var_dump($info->getRealPath());

$info = new SplFileInfo('/tmp');
var_dump($info->getRealPath());

$info = new SplFileInfo('/I/Do/Not/Exist');
var_dump($info->getRealPath());

$info = new SplFileInfo("");
var_dump($info->getRealPath());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(28) "/private/tmp/phptempfile.php"
string(12) "/private/tmp"
bool(false)
string(12) "/private/tmp"

Ayrıca Bakınız

  • SplFileInfo::isLink() - Tells if the file is a link
  • realpath() - Normalleştirilmiş mutlak dosya yolunu döndürür

SplFileInfo::getPerms
SplFileInfo::getSize
SplFileInfo


Gets file size

SplFileInfo::getRealPath
SplFileInfo::getType
SplFileInfo
PHP Manual

SplFileInfo::getSize

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::getSize — Gets file size

Açıklama

public int SplFileInfo::getSize ( void )

Returns the filesize in bytes for the file referenced.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The filesize in bytes.

Hatalar/İstisnalar

A RuntimeException will be thrown if the file does not exist or an error occurs.

Ayrıca Bakınız

  • filesize() - Dosya uzunluğunu döndürür

SplFileInfo::getRealPath
SplFileInfo::getType
SplFileInfo


Gets file type

SplFileInfo::getSize
SplFileInfo::isDir
SplFileInfo
PHP Manual

SplFileInfo::getType

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::getType — Gets file type

Açıklama

public string SplFileInfo::getType ( void )

Returns the type of the file referenced.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A string representing the type of the entry. May be one of file, link, or dir

Hatalar/İstisnalar

Throws a RuntimeException on error.

Örnekler

Örnek 1 SplFileInfo::getType() example

<?php

$info = new SplFileInfo(__FILE__);
echo $info->getType().PHP_EOL;

$info = new SplFileInfo(dirname(__FILE__));
echo $info->getType();

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

file
dir

SplFileInfo::getSize
SplFileInfo::isDir
SplFileInfo


Tells if the file is a directory

SplFileInfo::getType
SplFileInfo::isExecutable
SplFileInfo
PHP Manual

SplFileInfo::isDir

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::isDir — Tells if the file is a directory

Açıklama

public bool SplFileInfo::isDir ( void )

This method can be used to determine if the file is a directory.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if a directory, FALSE otherwise.

Örnekler

Örnek 1 SplFileInfo::isDir() example

<?php
$d = new SplFileInfo(dirname(__FILE__));
var_dump($d->isDir());

$d = new SplFileInfo(__FILE__);
var_dump($d->isDir());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(true)
bool(false)

SplFileInfo::getType
SplFileInfo::isExecutable
SplFileInfo


Tells if the file is executable

SplFileInfo::isDir
SplFileInfo::isFile
SplFileInfo
PHP Manual

SplFileInfo::isExecutable

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::isExecutable — Tells if the file is executable

Açıklama

public bool SplFileInfo::isExecutable ( void )

Checks if the file is executable.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if executable, FALSE otherwise.

Örnekler

Örnek 1 SplFileInfo::isExecutable() example

<?php
$info = new SplFileInfo('/usr/bin/php');
var_dump($info->isExecutable());

$info = new SplFileInfo('/usr/bin');
var_dump($info->isExecutable());

$info = new SplFileInfo('foo');
var_dump($info->isExecutable());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(true)
bool(true)
bool(false)

SplFileInfo::isDir
SplFileInfo::isFile
SplFileInfo


Tells if the object references a regular file

SplFileInfo::isExecutable
SplFileInfo::isLink
SplFileInfo
PHP Manual

SplFileInfo::isFile

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::isFile — Tells if the object references a regular file

Açıklama

public bool SplFileInfo::isFile ( void )

Checks if the file referenced by this SplFileInfo object exists and is a regular file.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the file exists and is a regular file (not a link), FALSE otherwise.

Örnekler

Örnek 1 SplFileInfo::isFile() example

<?php
$info = new SplFileInfo(__FILE__);
var_dump($info->isFile());

$info = new SplFileInfo(dirname(__FILE__));
var_dump($info->isFile());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(true)
bool(false)

SplFileInfo::isExecutable
SplFileInfo::isLink
SplFileInfo


Tells if the file is a link

SplFileInfo::isFile
SplFileInfo::isReadable
SplFileInfo
PHP Manual

SplFileInfo::isLink

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::isLink — Tells if the file is a link

Açıklama

public bool SplFileInfo::isLink ( void )

Use this method to check if the file referenced by the SplFileInfo object is a link.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the file is a link, FALSE otherwise.

Örnekler

Örnek 1 SplFileInfo::isLink() example

<?php
$info = new SplFileInfo('/path/to/symlink');
if ($info->isLink()) {
    echo 'The real path is '.$info->getRealPath();
}
?>

Ayrıca Bakınız

  • SplFileInfo::getRealPath() - Gets absolute path to file

SplFileInfo::isFile
SplFileInfo::isReadable
SplFileInfo


Tells if file is readable

SplFileInfo::isLink
SplFileInfo::isWritable
SplFileInfo
PHP Manual

SplFileInfo::isReadable

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::isReadable — Tells if file is readable

Açıklama

public bool SplFileInfo::isReadable ( void )

Check if the file is readable.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if readable, FALSE otherwise.

Örnekler

Örnek 1 SplFileInfo::isReadable() example

<?php
$info = new SplFileInfo(__FILE__);
var_dump($info->isReadable());

$info = new SplFileInfo('foo');
var_dump($info->isReadable());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(true)
bool(false)

SplFileInfo::isLink
SplFileInfo::isWritable
SplFileInfo


Tells if the entry is writable

SplFileInfo::isReadable
SplFileInfo::openFile
SplFileInfo
PHP Manual

SplFileInfo::isWritable

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::isWritable — Tells if the entry is writable

Açıklama

public bool SplFileInfo::isWritable ( void )

Checks if the current entry is writable.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if writable, FALSE otherwise;

SplFileInfo::isReadable
SplFileInfo::openFile
SplFileInfo


Gets an SplFileObject object for the file

SplFileInfo::isWritable
SplFileInfo::setFileClass
SplFileInfo
PHP Manual

SplFileInfo::openFile

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::openFile — Gets an SplFileObject object for the file

Açıklama

public SplFileObject SplFileInfo::openFile ([ string $open_mode = "r" [, bool $use_include_path = false [, resource $context = NULL ]]] )

Creates an SplFileObject object of the file. This is useful because SplFileObject contains additional methods for manipulating the file whereas SplFileInfo is only useful for gaining information, like whether the file is writable.

Değiştirgeler

open_mode

The mode for opening the file. See the fopen() documentation for descriptions of possible modes. The default is read only.

use_include_path

TRUE atandığı takdirde, dosya ayrıca include_path yönergesinde belirtilen yollarda da aranır.

context

Bağlamlar ile ilgili ayrıntılı bilgi edinmek için kılavuzun Bağlam seçenekleri ve değiştirgeleri bölümüne bakınız.

Dönen Değerler

The opened file as an SplFileObject object.

Hatalar/İstisnalar

A RuntimeException if the file cannot be opened (e.g. insufficient access rights).

Örnekler

Örnek 1 SplFileInfo::openFile() example

<?php
$fileinfo = new SplFileInfo('/tmp/foo.txt');

if ($fileinfo->isWritable()) {

    $fileobj = $fileinfo->openFile('a');

    $fileobj->fwrite("appended this sample text");
}
?>

Ayrıca Bakınız

  • SplFileObject
  • stream_context_create() - Bir akım bağlamı oluşturur
  • fopen() - Bir dosya veya URL'yi açar

SplFileInfo::isWritable
SplFileInfo::setFileClass
SplFileInfo


Sets the class used with SplFileInfo::openFile

SplFileInfo::openFile
SplFileInfo::setInfoClass
SplFileInfo
PHP Manual

SplFileInfo::setFileClass

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::setFileClass — Sets the class used with SplFileInfo::openFile()

Açıklama

public void SplFileInfo::setFileClass ([ string $class_name = "SplFileObject" ] )

Use this method to set a custom class which will be used when SplFileInfo::openFile() is called. The class name passed to this method must be SplFileObject or a class derived from SplFileObject.

Değiştirgeler

class_name

The class name to use when SplFileInfo::openFile() is called.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 SplFileInfo::setFileClass() example

<?php
// Create a class extending SplFileObject
class MyFoo extends SplFileObject {}

$info = new SplFileInfo(__FILE__);
// Set the class to use
$info->setFileClass('MyFoo');
var_dump($info->openFile());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(MyFoo)#2 (0) { }

Ayrıca Bakınız

  • SplFileInfo::openFile() - Gets an SplFileObject object for the file

SplFileInfo::openFile
SplFileInfo::setInfoClass
SplFileInfo


Sets the class used with SplFileInfo::getFileInfo and SplFileInfo::getPathInfo

SplFileInfo::setFileClass
SplFileInfo::__toString
SplFileInfo
PHP Manual

SplFileInfo::setInfoClass

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::setInfoClass — Sets the class used with SplFileInfo::getFileInfo() and SplFileInfo::getPathInfo()

Açıklama

public void SplFileInfo::setInfoClass ([ string $class_name = "SplFileInfo" ] )

Use this method to set a custom class which will be used when SplFileInfo::getFileInfo() and SplFileInfo::getPathInfo() are called. The class name passed to this method must be SplFileInfo or a class derived from SplFileInfo.

Değiştirgeler

class_name

The class name to use when SplFileInfo::getFileInfo() and SplFileInfo::getPathInfo() are called.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 SplFileInfo::setFileClass() example

<?php
// Define a class which extends SplFileInfo
class MyFoo extends SplFileInfo {}

$info = new SplFileInfo('foo');
// Set the class name to use
$info->setInfoClass('MyFoo');
var_dump($info->getFileInfo());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(MyFoo)#2 (0) { }

Ayrıca Bakınız

  • SplFileInfo::getFileInfo() - Gets an SplFileInfo object for the file

SplFileInfo::setFileClass
SplFileInfo::__toString
SplFileInfo


Returns the path to the file as a string

SplFileInfo::setInfoClass
SplFileObject
SplFileInfo
PHP Manual

SplFileInfo::__toString

(PHP 5 >= 5.1.2, PHP 7)

SplFileInfo::__toString — Returns the path to the file as a string

Açıklama

public void SplFileInfo::__toString ( void )

This method will return the file name of the referenced file.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the path to the file.

Örnekler

Örnek 1 SplFileInfo::__toString() example

<?php
$info = new SplFileInfo('foo');
var_dump($info->__toString());
echo $info.PHP_EOL;

$info = new SplFileInfo('/usr/bin/php');
var_dump($info->__toString());
echo $info.PHP_EOL;
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(3) "foo"
foo
string(12) "/usr/bin/php"
/usr/bin/php

SplFileInfo::setInfoClass
SplFileObject
SplFileInfo


The SplFileObject class

(PHP 5 >= 5.1.0, PHP 7)

Giriş

The SplFileObject class offers an object oriented interface for a file.

Sınıf Sözdizimi

SplFileObject extends SplFileInfo implements RecursiveIterator , SeekableIterator {
/* Sabitler */
const integer DROP_NEW_LINE = 1 ;
const integer READ_AHEAD = 2 ;
const integer SKIP_EMPTY = 4 ;
const integer READ_CSV = 8 ;
/* Yöntemler */
public string|array current ( void )
public bool eof ( void )
public bool fflush ( void )
public string fgetc ( void )
 public array fgetcsv
  ([ string $delimiter = ","
 [, string $enclosure = "\""
 [, string $escape = "\\"
]]] )
public string fgets ( void )
public string fgetss ([ string $allowable_tags ] )
public bool flock ( int $operation [, int &$wouldblock ] )
public int fpassthru ( void )
public int fputcsv ( array $fields [, string $delimiter = "," [, string $enclosure = '"' [, string $escape = "\" ]]] )
public string fread ( int $length )
public mixed fscanf ( string $format [, mixed &$... ] )
public int fseek ( int $offset [, int $whence = SEEK_SET ] )
public array fstat ( void )
public int ftell ( void )
public bool ftruncate ( int $size )
public int fwrite ( string $str [, int $length ] )
public void getChildren ( void )
public array getCsvControl ( void )
public int getFlags ( void )
public int getMaxLineLen ( void )
public bool hasChildren ( void )
public int key ( void )
public void next ( void )
public void rewind ( void )
public void seek ( int $line_pos )
 public void setCsvControl
  ([ string $delimiter = ","
 [, string $enclosure = "\""
 [, string $escape = "\\"
]]] )
public void setFlags ( int $flags )
public void setMaxLineLen ( int $max_len )
public void __toString ( void )
public bool valid ( void )
/* Miras alınan yöntemler */
public SplFileInfo::__construct ( string $file_name )
public int SplFileInfo::getATime ( void )
public string SplFileInfo::getBasename ([ string $suffix ] )
public int SplFileInfo::getCTime ( void )
public string SplFileInfo::getExtension ( void )
public SplFileInfo SplFileInfo::getFileInfo ([ string $class_name ] )
public string SplFileInfo::getFilename ( void )
public int SplFileInfo::getGroup ( void )
public int SplFileInfo::getInode ( void )
public string SplFileInfo::getLinkTarget ( void )
public int SplFileInfo::getMTime ( void )
public int SplFileInfo::getOwner ( void )
public string SplFileInfo::getPath ( void )
public SplFileInfo SplFileInfo::getPathInfo ([ string $class_name ] )
public string SplFileInfo::getPathname ( void )
public int SplFileInfo::getPerms ( void )
public string SplFileInfo::getRealPath ( void )
public int SplFileInfo::getSize ( void )
public string SplFileInfo::getType ( void )
public bool SplFileInfo::isDir ( void )
public bool SplFileInfo::isExecutable ( void )
public bool SplFileInfo::isFile ( void )
public bool SplFileInfo::isLink ( void )
public bool SplFileInfo::isReadable ( void )
public bool SplFileInfo::isWritable ( void )
public SplFileObject SplFileInfo::openFile ([ string $open_mode = "r" [, bool $use_include_path = false [, resource $context = NULL ]]] )
public void SplFileInfo::setFileClass ([ string $class_name = "SplFileObject" ] )
public void SplFileInfo::setInfoClass ([ string $class_name = "SplFileInfo" ] )
public void SplFileInfo::__toString ( void )
}

Öntanımlı Sabitler

SplFileObject::DROP_NEW_LINE

Drop newlines at the end of a line.

SplFileObject::READ_AHEAD

Read on rewind/next.

SplFileObject::SKIP_EMPTY

Skips empty lines in the file. This requires the READ_AHEAD flag be enabled, to work as expected.

SplFileObject::READ_CSV

Read lines as CSV rows.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.9 | SplFileObject::SKIP_EMPTY value changed to 4. Previously, value was 6.

İçindekiler

  • SplFileObject::__construct — Construct a new file object.
  • SplFileObject::current — Retrieve current line of file
  • SplFileObject::eof — Reached end of file
  • SplFileObject::fflush — Flushes the output to the file
  • SplFileObject::fgetc — Gets character from file
  • SplFileObject::fgetcsv — Gets line from file and parse as CSV fields
  • SplFileObject::fgets — Gets line from file
  • SplFileObject::fgetss — Gets line from file and strip HTML tags
  • SplFileObject::flock — Portable file locking
  • SplFileObject::fpassthru — Output all remaining data on a file pointer
  • SplFileObject::fputcsv — Write a field array as a CSV line
  • SplFileObject::fread — Read from file
  • SplFileObject::fscanf — Parses input from file according to a format
  • SplFileObject::fseek — Seek to a position
  • SplFileObject::fstat — Gets information about the file
  • SplFileObject::ftell — Return current file position
  • SplFileObject::ftruncate — Truncates the file to a given length
  • SplFileObject::fwrite — Write to file
  • SplFileObject::getChildren — No purpose
  • SplFileObject::getCsvControl — Get the delimiter, enclosure and escape character for CSV
  • SplFileObject::getCurrentLine — Alias of SplFileObject::fgets
  • SplFileObject::getFlags — Gets flags for the SplFileObject
  • SplFileObject::getMaxLineLen — Get maximum line length
  • SplFileObject::hasChildren — SplFileObject does not have children
  • SplFileObject::key — Get line number
  • SplFileObject::next — Read next line
  • SplFileObject::rewind — Rewind the file to the first line
  • SplFileObject::seek — Seek to specified line
  • SplFileObject::setCsvControl — Set the delimiter, enclosure and escape character for CSV
  • SplFileObject::setFlags — Sets flags for the SplFileObject
  • SplFileObject::setMaxLineLen — Set maximum line length
  • SplFileObject::__toString — Alias of SplFileObject::current
  • SplFileObject::valid — Not at EOF
SplFileInfo::__toString
SplFileObject::__construct
File Handling


Construct a new file object.

SplFileObject
SplFileObject::current
SplFileObject
PHP Manual

SplFileObject::__construct

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::__construct — Construct a new file object.

Açıklama

public SplFileObject::__construct ( string $filename [, string $open_mode = "r" [, bool $use_include_path = false [, resource $context ]]] )

Construct a new file object.

Değiştirgeler

filename

The file to read.

İpucu

fopen sarmalayıcıları etkin kılınmışsa bu işlevde dosya ismi olarak bir URL belirtebilirsiniz. Dosya isminin nasıl belirtilebileceği hakkında bilgi edinmek için fopen() işlevine bakınız. Sarmalayıcıların neler yapabildiği, kullanım bilgileri ve bunlar tarafından kullanılan öntanımlı değişkenler hakkında bilgi edinmek için ise Supported Protocols and Wrappers bölümüne bakınız.

open_mode

The mode in which to open the file. See fopen() for a list of allowed modes.

use_include_path

Whether to search in the include_path for filename.

context

A valid context resource created with stream_context_create().

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

Throws a RuntimeException if the filename cannot be opened.

Örnekler

Örnek 1 SplFileObject::__construct() example

This example opens the current file and iterates over its contents line by line.

<?php
$file = new SplFileObject(__FILE__);
foreach ($file as $line_num => $line) {
    echo "Line $line_num is $line";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Line 0 is <?php
Line 1 is $file = new SplFileObject(__FILE__);
Line 2 is foreach ($file as $line_num => $line) {
Line 3 is     echo "Line $line_num is $line";
Line 4 is }
Line 5 is ?>

Ayrıca Bakınız

  • SplFileInfo::openFile() - Gets an SplFileObject object for the file
  • fopen() - Bir dosya veya URL'yi açar

SplFileObject
SplFileObject::current
SplFileObject


Retrieve current line of file

SplFileObject::__construct
SplFileObject::eof
SplFileObject
PHP Manual

SplFileObject::current

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::current — Retrieve current line of file

Açıklama

public string|array SplFileObject::current ( void )

Retrieves the current line of the file.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Retrieves the current line of the file. If the SplFileObject::READ_CSV flag is set, this method returns an array containing the current line parsed as CSV data.

Örnekler

Örnek 1 SplFileObject::current() example

<?php
$file = new SplFileObject(__FILE__);
foreach ($file as $k => $line) {
   echo ($file->key() + 1) . ': ' . $file->current();
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

1: <?php
2: $file = new SplFileObject(__FILE__);
3: foreach ($file as $line) {
4:     echo ($file->key() + 1) . ': ' . $file->current();
5: }
6: ?>

Ayrıca Bakınız

  • SplFileObject::key() - Get line number
  • SplFileObject::seek() - Seek to specified line
  • SplFileObject::next() - Read next line
  • SplFileObject::rewind() - Rewind the file to the first line
  • SplFileObject::valid() - Not at EOF

SplFileObject::__construct
SplFileObject::eof
SplFileObject


Reached end of file

SplFileObject::current
SplFileObject::fflush
SplFileObject
PHP Manual

SplFileObject::eof

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::eof — Reached end of file

Açıklama

public bool SplFileObject::eof ( void )

Determine whether the end of file has been reached

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if file is at EOF, FALSE otherwise.

Örnekler

Örnek 1 SplFileObject::eof() example

<?php
$file = new SplFileObject("fruits.txt");
while ( ! $file->eof()) {
    echo $file->fgets();
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

apple
banana
cherry
date
elderberry

Ayrıca Bakınız

  • SplFileObject::valid() - Not at EOF
  • feof() - Bir dosya tanıtıcısı üzerinde konum dosya sonunda mı diye bakar

SplFileObject::current
SplFileObject::fflush
SplFileObject


Flushes the output to the file

SplFileObject::eof
SplFileObject::fgetc
SplFileObject
PHP Manual

SplFileObject::fflush

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::fflush — Flushes the output to the file

Açıklama

public bool SplFileObject::fflush ( void )

Forces a write of all buffered output to the file.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 SplFileObject::fflush() example

<?php
$file = new SplFileObject('misc.txt', 'r+');
$file->rewind();
$file->fwrite("Foo");
$file->fflush();
$file->ftruncate($file->ftell());
?>

Ayrıca Bakınız

  • SplFileObject::fwrite() - Write to file

SplFileObject::eof
SplFileObject::fgetc
SplFileObject


Gets character from file

SplFileObject::fflush
SplFileObject::fgetcsv
SplFileObject
PHP Manual

SplFileObject::fgetc

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::fgetc — Gets character from file

Açıklama

public string SplFileObject::fgetc ( void )

Gets a character from the file.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a string containing a single character read from the file or FALSE on EOF.

Uyarı

Bu işlev mantıksal FALSE değeriyle dönebileceği gibi FALSE olarak değerlendirilebilecek mantıksal olmayan bir değerle de dönebilir. Bu konuda daha fazla bilgi edinmek için Mantıksal Değerler bölümüne bakabilirsiniz. Bu işlevden dönen değeri sınamak için === işlecini kullanınız.

Örnekler

Örnek 1 SplFileObject::fgetc() example

<?php
$file = new SplFileObject('file.txt');
while (false !== ($char = $file->fgetc())) {
    echo "$char\n";
}
?>

Ayrıca Bakınız

  • SplFileObject::fgets() - Gets line from file

SplFileObject::fflush
SplFileObject::fgetcsv
SplFileObject


Gets line from file and parse as CSV fields

SplFileObject::fgetc
SplFileObject::fgets
SplFileObject
PHP Manual

SplFileObject::fgetcsv

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::fgetcsv — Gets line from file and parse as CSV fields

Açıklama

 public array SplFileObject::fgetcsv
  ([ string $delimiter = ","
 [, string $enclosure = "\""
 [, string $escape = "\\"
]]] )

Gets a line from the file which is in CSV format and returns an array containing the fields read.

Değiştirgeler

delimiter

The field delimiter (one character only). Defaults as a comma or the value set using SplFileObject::setCsvControl().

enclosure

The field enclosure character (one character only). Defaults as a double quotation mark or the value set using SplFileObject::setCsvControl().

escape

The escape character (one character only). Defaults as a backslash (\) or the value set using SplFileObject::setCsvControl().

Dönen Değerler

Returns an indexed array containing the fields read, or FALSE on error.

Bilginize:

A blank line in a CSV file will be returned as an array comprising a single NULL field unless using SplFileObject::SKIP_EMPTY | SplFileObject::DROP_NEW_LINE, in which case empty lines are skipped.

Örnekler

Örnek 1 SplFileObject::fgetcsv() example

<?php
$file = new SplFileObject("data.csv");
while (!$file->eof()) {
    var_dump($file->fgetcsv());
}
?>

Örnek 2 SplFileObject::READ_CSV example

<?php
$file = new SplFileObject("animals.csv");
$file->setFlags(SplFileObject::READ_CSV);
foreach ($file as $row) {
    list($animal, $class, $legs) = $row;
    printf("A %s is a %s with %d legs\n", $animal, $class, $legs);
}
?>

Contents of animals.csv

crocodile,reptile,4
dolphin,mammal,0
duck,bird,2
koala,mammal,4
salmon,fish,0

Yukarıdaki örnek şuna benzer bir çıktı üretir:

A crocodile is a reptile with 4 legs
A dolphin is a mammal with 0 legs
A duck is a bird with 2 legs
A koala is a mammal with 4 legs
A salmon is a fish with 0 legs

Ayrıca Bakınız

  • SplFileObject::setCsvControl() - Set the delimiter, enclosure and escape character for CSV
  • SplFileObject::setFlags() - Sets flags for the SplFileObject
  • SplFileObject::READ_CSV
  • SplFileObject::current() - Retrieve current line of file

SplFileObject::fgetc
SplFileObject::fgets
SplFileObject


Gets line from file

SplFileObject::fgetcsv
SplFileObject::fgetss
SplFileObject
PHP Manual

SplFileObject::fgets

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::fgets — Gets line from file

Açıklama

public string SplFileObject::fgets ( void )

Gets a line from the file.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a string containing the next line from the file, or FALSE on error.

Hatalar/İstisnalar

Throws a RuntimeException if the file cannot be read.

Örnekler

Örnek 1 SplFileObject::fgets() example

This example simply outputs the contents of file.txt line-by-line.

<?php
$file = new SplFileObject("file.txt");
while (!$file->eof()) {
    echo $file->fgets();
}
?>

Ayrıca Bakınız

  • fgets() - Dosya tanıtıcısından bir satır döndürür
  • SplFileObject::fgetss() - Gets line from file and strip HTML tags
  • SplFileObject::fgetc() - Gets character from file
  • SplFileObject::current() - Retrieve current line of file

SplFileObject::fgetcsv
SplFileObject::fgetss
SplFileObject


Gets line from file and strip HTML tags

SplFileObject::fgets
SplFileObject::flock
SplFileObject
PHP Manual

SplFileObject::fgetss

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::fgetss — Gets line from file and strip HTML tags

Açıklama

public string SplFileObject::fgetss ([ string $allowable_tags ] )

Identical to SplFileObject::fgets(), except that SplFileObject::fgetss() attempts to strip any HTML and PHP tags from the text it reads.

Değiştirgeler

allowable_tags

Optional parameter to specify tags which should not be stripped.

Dönen Değerler

Returns a string containing the next line of the file with HTML and PHP code stripped, or FALSE on error.

Örnekler

Örnek 1 SplFileObject::fgetss() example

<?php
$str = <<<EOD
<html><body>
 <p>Welcome! Today is the <?php echo(date('jS')); ?> of <?= date('F'); ?>.</p>
</body></html>
Text outside of the HTML block.
EOD;
file_put_contents("sample.php", $str);

$file = new SplFileObject("sample.php");
while (!$file->eof()) {
    echo $file->fgetss();
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

 Welcome! Today is the  of .

Text outside of the HTML block.

Ayrıca Bakınız

  • fgetss() - Dosya tanıtıcısından bir satırı HTML etiketlerinden arındırarak döndürür
  • SplFileObject::fgets() - Gets line from file
  • SplFileObject::fgetc() - Gets character from file
  • SplFileObject::current() - Retrieve current line of file

SplFileObject::fgets
SplFileObject::flock
SplFileObject


Portable file locking

SplFileObject::fgetss
SplFileObject::fpassthru
SplFileObject
PHP Manual

SplFileObject::flock

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::flock — Portable file locking

Açıklama

public bool SplFileObject::flock ( int $operation [, int &$wouldblock ] )

Locks or unlocks the file in the same portable way as flock().

Değiştirgeler

operation

operation is one of the following:

  • LOCK_SH to acquire a shared lock (reader).
  • LOCK_EX to acquire an exclusive lock (writer).
  • LOCK_UN to release a lock (shared or exclusive).
  • LOCK_NB to not block while locking (not supported on Windows).

wouldblock

Set to TRUE if the lock would block (EWOULDBLOCK errno condition).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 SplFileObject::flock() example

<?php
$file = new SplFileObject("/tmp/lock.txt", "w");
if ($file->flock(LOCK_EX)) { // do an exclusive lock
    $file->ftruncate(0);     // truncate file
    $file->fwrite("Write something here\n");
    $file->flock(LOCK_UN);   // release the lock
} else {
    echo "Couldn't get the lock!";
}
?>

Ayrıca Bakınız

  • flock() - Taşınabilir tavsiye niteliğinde dosya kilitleme

SplFileObject::fgetss
SplFileObject::fpassthru
SplFileObject


Output all remaining data on a file pointer

SplFileObject::flock
SplFileObject::fputcsv
SplFileObject
PHP Manual

SplFileObject::fpassthru

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::fpassthru — Output all remaining data on a file pointer

Açıklama

public int SplFileObject::fpassthru ( void )

Reads to EOF on the given file pointer from the current position and writes the results to the output buffer.

You may need to call SplFileObject::rewind() to reset the file pointer to the beginning of the file if you have already written data to the file.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the number of characters read from handle and passed through to the output.

Örnekler

Örnek 1 SplFileObject::fpassthru() example

<?php

// Open the file in binary mode
$file = new SplFileObject("./img/ok.png", "rb");

// Send the right headers
header("Content-Type: image/png");
header("Content-Length: " . $file->getSize());

// Dump the picture and end script
$file->fpassthru();
exit;

?>

Ayrıca Bakınız

  • fpassthru() - Bir dosya tanıtıcısında kalan verinin tamamını çıktılar

SplFileObject::flock
SplFileObject::fputcsv
SplFileObject


Write a field array as a CSV line

SplFileObject::fpassthru
SplFileObject::fread
SplFileObject
PHP Manual

SplFileObject::fputcsv

(PHP 5 >= 5.4.0, PHP 7)

SplFileObject::fputcsv — Write a field array as a CSV line

Açıklama

 public int SplFileObject::fputcsv
  ( array $fields
 [, string $delimiter = ","
 [, string $enclosure = '"'
 [, string $escape = "\"
]]] )

Writes the fields array to the file as a CSV line.

Değiştirgeler

fields

An array of values.

delimiter

The optional delimiter parameter sets the field delimiter (one character only).

enclosure

The optional enclosure parameter sets the field enclosure (one character only).

escape

The optional escape parameter sets the escape character (one character only).

Dönen Değerler

Returns the length of the written string başarısızlık durumunda FALSE döner.

Returns FALSE, and does not write the CSV line to the file, if the delimiter or enclosure parameter is not a single character.

Hatalar/İstisnalar

An E_WARNING level error is issued if the delimiter or enclosure parameter is not a single character.

Sürüm Bilgisi

Sürüm: | Açıklama
5.5.21, 5.6.5 | Added the escape parameter.

Örnekler

Örnek 1 SplFileObject::fputcsv() example

<?php

$list = array (
    array('aaa', 'bbb', 'ccc', 'dddd'),
    array('123', '456', '789'),
    array('"aaa"', '"bbb"')
);

$file = new SplFileObject('file.csv', 'w');

foreach ($list as $fields) {
    $file->fputcsv($fields);
}

?>

The above example will write the following to file.csv:

aaa,bbb,ccc,dddd
123,456,789
"""aaa""","""bbb"""

Ayrıca Bakınız

  • fputcsv() - Satırı CSV olarak biçemler ve dosya tanıtıcısına yazar
  • SplFileObject::fgetcsv() - Gets line from file and parse as CSV fields

SplFileObject::fpassthru
SplFileObject::fread
SplFileObject


Read from file

SplFileObject::fputcsv
SplFileObject::fscanf
SplFileObject
PHP Manual

SplFileObject::fread

(PHP 5 >= 5.5.11, PHP 7)

SplFileObject::fread — Read from file

Açıklama

public string SplFileObject::fread ( int $length )

Reads the given number of bytes from the file.

Değiştirgeler

length

The number of bytes to read.

Dönen Değerler

Returns the string read from the file başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 SplFileObject::fread() example

<?php
// Get contents of a file into a string
$filename = "/usr/local/something.txt";
$file = new SplFileObject($filename, "r");
$contents = $file->fread($file->getSize());
?>

Notlar

Bilginize:

Note that SplFileObject::fread() reads from the current position of the file pointer. Use SplFileObject::ftell() to find the current position of the pointer and SplFileObject::rewind() (or SplFileObject::fseek()) to rewind the pointer position.

Ayrıca Bakınız

  • fread() - Dosyayı ikil kipte okur

SplFileObject::fputcsv
SplFileObject::fscanf
SplFileObject


Parses input from file according to a format

SplFileObject::fread
SplFileObject::fseek
SplFileObject
PHP Manual

SplFileObject::fscanf

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::fscanf — Parses input from file according to a format

Açıklama

public mixed SplFileObject::fscanf ( string $format [, mixed &$... ] )

Reads a line from the file and interprets it according to the specified format, which is described in the documentation for sprintf().

Any whitespace in the format string matches any whitespace in the line from the file. This means that even a tab \t in the format string can match a single space character in the input stream.

Değiştirgeler

format

The specified format as described in the sprintf() documentation.

...

The optional assigned values.

Dönen Değerler

If only one parameter is passed to this method, the values parsed will be returned as an array. Otherwise, if optional parameters are passed, the function will return the number of assigned values. The optional parameters must be passed by reference.

Örnekler

Örnek 1 SplFileObject::fscanf() example

<?php
$file = new SplFileObject("misc.txt");
while ($userinfo = $file->fscanf("%s %s %s")) {
    list ($name, $profession, $countrycode) = $userinfo;
    // Do something with $name $profession $countrycode
}
?>

Contents of users.txt

javier   argonaut    pe
hiroshi  sculptor    jp
robert   slacker     us
luigi    florist     it

Ayrıca Bakınız

  • fscanf() - Bir dosyadaki girdiyi belli bir biçeme göre çözümler

SplFileObject::fread
SplFileObject::fseek
SplFileObject


Seek to a position

SplFileObject::fscanf
SplFileObject::fstat
SplFileObject
PHP Manual

SplFileObject::fseek

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::fseek — Seek to a position

Açıklama

public int SplFileObject::fseek ( int $offset [, int $whence = SEEK_SET ] )

Seek to a position in the file measured in bytes from the beginning of the file, obtained by adding offset to the position specified by whence.

Değiştirgeler

offset

The offset. A negative value can be used to move backwards through the file which is useful when SEEK_END is used as the whence value.

whence

whence values are:

  • SEEK_SET - Set position equal to offset bytes.
  • SEEK_CUR - Set position to current location plus offset.
  • SEEK_END - Set position to end-of-file plus offset.

If whence is not specified, it is assumed to be SEEK_SET.

Dönen Değerler

Returns 0 if the seek was successful, -1 otherwise. Note that seeking past EOF is not considered an error.

Örnekler

Örnek 1 SplFileObject::fseek() example

<?php
$file = new SplFileObject("somefile.txt");

// Read first line
$data = $file->fgets();

// Move back to the beginning of the file
// Same as $file->rewind();
$file->fseek(0);
?>

Ayrıca Bakınız

  • fseek() - Dosya tanıtıcısında konumu bir yerden başka bir yere taşır

SplFileObject::fscanf
SplFileObject::fstat
SplFileObject


Gets information about the file

SplFileObject::fseek
SplFileObject::ftell
SplFileObject
PHP Manual

SplFileObject::fstat

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::fstat — Gets information about the file

Açıklama

public array SplFileObject::fstat ( void )

Gathers the statistics of the file. Behaves identically to fstat().

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array with the statistics of the file; the format of the array is described in detail on the stat() manual page.

Örnekler

Örnek 1 SplFileObject::fstat() example

<?php
$file = new SplFileObject("/etc/passwd");
$stat = $file->fstat();

// Print only the associative part
print_r(array_slice($stat, 13));

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [dev] => 771
    [ino] => 488704
    [mode] => 33188
    [nlink] => 1
    [uid] => 0
    [gid] => 0
    [rdev] => 0
    [size] => 1114
    [atime] => 1061067181
    [mtime] => 1056136526
    [ctime] => 1056136526
    [blksize] => 4096
    [blocks] => 8
)

Ayrıca Bakınız

  • fstat() - Bir açık dosya tanıtıcısı kullanarak bir dosya hakkında bilgi döndürür
  • stat() - Bir dosya hakkında bilgi döndürür

SplFileObject::fseek
SplFileObject::ftell
SplFileObject


Return current file position

SplFileObject::fstat
SplFileObject::ftruncate
SplFileObject
PHP Manual

SplFileObject::ftell

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::ftell — Return current file position

Açıklama

public int SplFileObject::ftell ( void )

Returns the position of the file pointer which represents the current offset in the file stream.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the position of the file pointer as an integer, or FALSE on error.

Örnekler

Örnek 1 SplFileObject::ftell() example

<?php
$file = new SplFileObject("/etc/passwd");

// Read first line
$data = $file->fgets();

// Where are we?
echo $file->ftell();
?>

Ayrıca Bakınız

  • ftell() - Dosya okuma/yazma konumlayıcının mevcut konumu ile döner

SplFileObject::fstat
SplFileObject::ftruncate
SplFileObject


Truncates the file to a given length

SplFileObject::ftell
SplFileObject::fwrite
SplFileObject
PHP Manual

SplFileObject::ftruncate

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::ftruncate — Truncates the file to a given length

Açıklama

public bool SplFileObject::ftruncate ( int $size )

Truncates the file to size bytes.

Değiştirgeler

size

The size to truncate to.

Bilginize:

If size is larger than the file it is extended with null bytes.

If size is smaller than the file, the extra data will be lost.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 SplFileObject::ftruncate() example

<?php
// Create file containing "Hello World!"
$file = new SplFileObject("/tmp/ftruncate", "w+");
$file->fwrite("Hello World!");

// Truncate to 5 bytes
$file->ftruncate(5);

// Rewind and read data
$file->rewind();
echo $file->fgets();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Hello

Ayrıca Bakınız

  • ftruncate() - Bir dosyayı belli bir uzunlukta budar

SplFileObject::ftell
SplFileObject::fwrite
SplFileObject


Write to file

SplFileObject::ftruncate
SplFileObject::getChildren
SplFileObject
PHP Manual

SplFileObject::fwrite

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::fwrite — Write to file

Açıklama

public int SplFileObject::fwrite ( string $str [, int $length ] )

Writes the contents of string to the file

Değiştirgeler

str

The string to be written to the file.

length

If the length argument is given, writing will stop after length bytes have been written or the end of string is reached, whichever comes first.

Dönen Değerler

Returns the number of bytes written, or NULL on error.

Örnekler

Örnek 1 SplFileObject::fwrite() example

<?php
$file = new SplFileObject("fwrite.txt", "w");
$written = $file->fwrite("12345");
echo "Wrote $written bytes to file";
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Wrote 5 bytes to file

Ayrıca Bakınız

  • fwrite() - Dosyaya ikil kipte yazar

SplFileObject::ftruncate
SplFileObject::getChildren
SplFileObject


No purpose

SplFileObject::fwrite
SplFileObject::getCsvControl
SplFileObject
PHP Manual

SplFileObject::getChildren

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::getChildren — No purpose

Açıklama

public void SplFileObject::getChildren ( void )

An SplFileObject does not have children so this method returns NULL.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • RecursiveIterator::getChildren() - Returns an iterator for the current entry.

SplFileObject::fwrite
SplFileObject::getCsvControl
SplFileObject


Get the delimiter, enclosure and escape character for CSV

SplFileObject::getChildren
SplFileObject::getCurrentLine
SplFileObject
PHP Manual

SplFileObject::getCsvControl

(PHP 5 >= 5.2.0, PHP 7)

SplFileObject::getCsvControl — Get the delimiter, enclosure and escape character for CSV

Açıklama

public array SplFileObject::getCsvControl ( void )

Gets the delimiter, enclosure and escape character used for parsing CSV fields.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an indexed array containing the delimiter, enclosure and escape character.

Sürüm Bilgisi

Sürüm: | Açıklama
5.6.25, 7.0.10 | Added the escape character to the returned array.

Örnekler

Örnek 1 SplFileObject::getCsvControl() example

<?php
$file = new SplFileObject("data.txt");
print_r($file->getCsvControl());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [0] => ,
    [1] => "
    [2] => \
)

Ayrıca Bakınız

  • SplFileObject::setCsvControl() - Set the delimiter, enclosure and escape character for CSV
  • SplFileObject::fgetcsv() - Gets line from file and parse as CSV fields

SplFileObject::getChildren
SplFileObject::getCurrentLine
SplFileObject


Alias of SplFileObject::fgets

SplFileObject::getCsvControl
SplFileObject::getFlags
SplFileObject
PHP Manual

SplFileObject::getCurrentLine

(PHP 5 >= 5.1.2, PHP 7)

SplFileObject::getCurrentLine — Alias of SplFileObject::fgets()

Açıklama

This method is an alias of SplFileObject::fgets().

SplFileObject::getCsvControl
SplFileObject::getFlags
SplFileObject


Gets flags for the SplFileObject

SplFileObject::getCurrentLine
SplFileObject::getMaxLineLen
SplFileObject
PHP Manual

SplFileObject::getFlags

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::getFlags — Gets flags for the SplFileObject

Açıklama

public int SplFileObject::getFlags ( void )

Gets the flags set for an instance of SplFileObject as an integer.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an integer representing the flags.

Örnekler

Örnek 1 SplFileObject::getFlags() example

<?php
$file = new SplFileObject(__FILE__, "r");

if ($file->getFlags() & SplFileObject::SKIP_EMPTY) {
    echo "Skipping empty lines\n";
} else {
    echo "Not skipping empty lines\n";
}

$file->setFlags(SplFileObject::SKIP_EMPTY);

if ($file->getFlags() & SplFileObject::SKIP_EMPTY) {
    echo "Skipping empty lines\n";
} else {
    echo "Not skipping empty lines\n";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Not skipping empty lines
Skipping empty lines

Ayrıca Bakınız

  • SplFileObject::setFlags() - Sets flags for the SplFileObject

SplFileObject::getCurrentLine
SplFileObject::getMaxLineLen
SplFileObject


Get maximum line length

SplFileObject::getFlags
SplFileObject::hasChildren
SplFileObject
PHP Manual

SplFileObject::getMaxLineLen

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::getMaxLineLen — Get maximum line length

Açıklama

public int SplFileObject::getMaxLineLen ( void )

Gets the maximum line length as set by SplFileObject::setMaxLineLen().

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the maximum line length if one has been set with SplFileObject::setMaxLineLen(), default is 0.

Örnekler

Örnek 1 SplFileObject::getMaxLineLen() example

<?php
$file = new SplFileObject("file.txt");
var_dump($file->getMaxLineLen());

$file->setMaxLineLen(20);
var_dump($file->getMaxLineLen());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(0)
int(20)

Ayrıca Bakınız

  • Classname::Method()

SplFileObject::getFlags
SplFileObject::hasChildren
SplFileObject


SplFileObject does not have children

SplFileObject::getMaxLineLen
SplFileObject::key
SplFileObject
PHP Manual

SplFileObject::hasChildren

(PHP 5 >= 5.1.2, PHP 7)

SplFileObject::hasChildren — SplFileObject does not have children

Açıklama

public bool SplFileObject::hasChildren ( void )

An SplFileObject does not have children so this method always return FALSE.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns FALSE

Ayrıca Bakınız

  • RecursiveIterator::hasChildren() - Returns if an iterator can be created fot the current entry.

SplFileObject::getMaxLineLen
SplFileObject::key
SplFileObject


Get line number

SplFileObject::hasChildren
SplFileObject::next
SplFileObject
PHP Manual

SplFileObject::key

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::key — Get line number

Açıklama

public int SplFileObject::key ( void )

Gets the current line number.

Bilginize:

This number may not reflect the actual line number in the file if SplFileObject::setMaxLineLen() is used to read fixed lengths of the file.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the current line number.

Örnekler

Örnek 1 SplFileObject::key() example

<?php
$file = new SplFileObject("lipsum.txt");
foreach ($file as $line) {
    echo $file->key() . ". " . $line;
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

0. Lorem ipsum dolor sit amet, consectetur adipiscing elit.
1. Duis nec sapien felis, ac sodales nisl.
2. Lorem ipsum dolor sit amet, consectetur adipiscing elit.

Örnek 2 SplFileObject::key() example with SplFileObject::setMaxLineLen()

<?php
$file = new SplFileObject("lipsum.txt");
$file->setMaxLineLen(20);
foreach ($file as $line) {
    echo $file->key() . ". " . $line . "\n";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

0. Lorem ipsum dolor s
1. it amet, consectetu
2. r adipiscing elit.
3.

4. Duis nec sapien fel
5. is, ac sodales nisl
6. .

7. Lorem ipsum dolor s
8. it amet, consectetu
9. r adipiscing elit.

Ayrıca Bakınız

  • SplFileObject::current() - Retrieve current line of file
  • SplFileObject::seek() - Seek to specified line
  • SplFileObject::next() - Read next line
  • SplFileObject::rewind() - Rewind the file to the first line
  • SplFileObject::valid() - Not at EOF

SplFileObject::hasChildren
SplFileObject::next
SplFileObject


Read next line

SplFileObject::key
SplFileObject::rewind
SplFileObject
PHP Manual

SplFileObject::next

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::next — Read next line

Açıklama

public void SplFileObject::next ( void )

Moves ahead to the next line in the file.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 SplFileObject::next() example

<?php
// Read through file line by line
$file = new SplFileObject("misc.txt");
while (!$file->eof()) {
    echo $file->current();
    $file->next();
}
?>

Ayrıca Bakınız

  • SplFileObject::current() - Retrieve current line of file
  • SplFileObject::key() - Get line number
  • SplFileObject::seek() - Seek to specified line
  • SplFileObject::rewind() - Rewind the file to the first line
  • SplFileObject::valid() - Not at EOF

SplFileObject::key
SplFileObject::rewind
SplFileObject


Rewind the file to the first line

SplFileObject::next
SplFileObject::seek
SplFileObject
PHP Manual

SplFileObject::rewind

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::rewind — Rewind the file to the first line

Açıklama

public void SplFileObject::rewind ( void )

Rewinds the file back to the first line.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

Throws a RuntimeException if cannot be rewound.

Örnekler

Örnek 1 SplFileObject::rewind() example

<?php
$file = new SplFileObject("misc.txt");

// Loop over whole file
foreach ($file as $line) { }

// Rewind to first line
$file->rewind();

// Output first line
echo $file->current();
?>

Ayrıca Bakınız

  • SplFileObject::current() - Retrieve current line of file
  • SplFileObject::key() - Get line number
  • SplFileObject::seek() - Seek to specified line
  • SplFileObject::next() - Read next line
  • SplFileObject::valid() - Not at EOF

SplFileObject::next
SplFileObject::seek
SplFileObject


Seek to specified line

SplFileObject::rewind
SplFileObject::setCsvControl
SplFileObject
PHP Manual

SplFileObject::seek

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::seek — Seek to specified line

Açıklama

public void SplFileObject::seek ( int $line_pos )

Seek to specified line in the file.

Değiştirgeler

line_pos

The zero-based line number to seek to.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

Throws a LogicException if the line_pos is negative.

Örnekler

Örnek 1 SplFileObject::seek() example

This example outputs the third line of the script which is found at position 2.

<?php
$file = new SplFileObject(__FILE__);
$file->seek(2);
echo $file->current();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

$file->seek(2);

Ayrıca Bakınız

  • SplFileObject::current() - Retrieve current line of file
  • SplFileObject::key() - Get line number
  • SplFileObject::next() - Read next line
  • SplFileObject::rewind() - Rewind the file to the first line
  • SplFileObject::valid() - Not at EOF

SplFileObject::rewind
SplFileObject::setCsvControl
SplFileObject


Set the delimiter, enclosure and escape character for CSV

SplFileObject::seek
SplFileObject::setFlags
SplFileObject
PHP Manual

SplFileObject::setCsvControl

(PHP 5 >= 5.2.0, PHP 7)

SplFileObject::setCsvControl — Set the delimiter, enclosure and escape character for CSV

Açıklama

 public void SplFileObject::setCsvControl
  ([ string $delimiter = ","
 [, string $enclosure = "\""
 [, string $escape = "\\"
]]] )

Sets the delimiter, enclosure and escape character for parsing CSV fields.

Değiştirgeler

delimiter

The field delimiter (one character only).

enclosure

The field enclosure character (one character only).

escape

The field escape character (one character only).

Dönen Değerler

Hiçbir değer dönmez.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | Added the escape parameter.

Örnekler

Örnek 1 SplFileObject::setCsvControl() example

<?php
$file = new SplFileObject("data.csv");
$file->setFlags(SplFileObject::READ_CSV);
$file->setCsvControl('|');
foreach ($file as $row) {
    list ($fruit, $quantity) = $row;
    // Do something with values
}
?>

Contents of data.csv

<?php
apples|20
bananas|14
cherries|87
?>

Ayrıca Bakınız

  • SplFileObject::getCsvControl() - Get the delimiter, enclosure and escape character for CSV
  • SplFileObject::fgetcsv() - Gets line from file and parse as CSV fields

SplFileObject::seek
SplFileObject::setFlags
SplFileObject


Sets flags for the SplFileObject

SplFileObject::setCsvControl
SplFileObject::setMaxLineLen
SplFileObject
PHP Manual

SplFileObject::setFlags

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::setFlags — Sets flags for the SplFileObject

Açıklama

public void SplFileObject::setFlags ( int $flags )

Sets the flags to be used by the SplFileObject.

Değiştirgeler

flags

Bit mask of the flags to set. See SplFileObject constants for the available flags.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 SplFileObject::setFlags() example

<?php
$file = new SplFileObject("data.csv");
$file->setFlags(SplFileObject::READ_CSV);
foreach ($file as $fields) {
    var_dump($fields);
}
?>

Ayrıca Bakınız

  • SplFileObject::getFlags() - Gets flags for the SplFileObject

SplFileObject::setCsvControl
SplFileObject::setMaxLineLen
SplFileObject


Set maximum line length

SplFileObject::setFlags
SplFileObject::__toString
SplFileObject
PHP Manual

SplFileObject::setMaxLineLen

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::setMaxLineLen — Set maximum line length

Açıklama

public void SplFileObject::setMaxLineLen ( int $max_len )

Sets the maximum length of a line to be read.

Değiştirgeler

max_len

The maximum length of a line.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

Throws DomainException when max_len is less than zero.

Örnekler

Örnek 1 SplFileObject::setMaxLineLen() example

<?php
$file = new SplFileObject("lipsum.txt");
$file->setMaxLineLen(20);
foreach ($file as $line) {
    echo $line . "\n";
}
?>

Contents of lipsum.txt

Lorem ipsum dolor sit amet, consectetur adipiscing elit.
Duis nec sapien felis, ac sodales nisl.
Nulla vitae magna vitae purus aliquet consequat.

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Lorem ipsum dolor s
it amet, consectetu
r adipiscing elit.

Duis nec sapien fel
is, ac sodales nisl
.

Nulla vitae magna v
itae purus aliquet
consequat.

Ayrıca Bakınız

  • Classname::Method()

SplFileObject::setFlags
SplFileObject::__toString
SplFileObject


Alias of SplFileObject::current

SplFileObject::setMaxLineLen
SplFileObject::valid
SplFileObject
PHP Manual

SplFileObject::__toString

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::__toString — Alias of SplFileObject::current()

Açıklama

public void SplFileObject::__toString ( void )

This method is an alias of SplFileObject::current().

SplFileObject::setMaxLineLen
SplFileObject::valid
SplFileObject


Not at EOF

SplFileObject::__toString
SplTempFileObject
SplFileObject
PHP Manual

SplFileObject::valid

(PHP 5 >= 5.1.0, PHP 7)

SplFileObject::valid — Not at EOF

Açıklama

public bool SplFileObject::valid ( void )

Check whether EOF has been reached.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if not reached EOF, FALSE otherwise.

Örnekler

Örnek 1 SplFileObject::valid() example

<?php
// Loop over a file, line by line
$file = new SplFileObject("file.txt");
while ($file->valid()) {
    echo $file->fgets();
}
?>

Ayrıca Bakınız

  • SplFileObject::current() - Retrieve current line of file
  • SplFileObject::key() - Get line number
  • SplFileObject::seek() - Seek to specified line
  • SplFileObject::next() - Read next line
  • SplFileObject::rewind() - Rewind the file to the first line

SplFileObject::__toString
SplTempFileObject
SplFileObject


The SplTempFileObject class

(PHP 5 >= 5.1.2, PHP 7)

Giriş

The SplTempFileObject class offers an object oriented interface for a temporary file.

Sınıf Sözdizimi

SplTempFileObject extends SplFileObject implements SeekableIterator , RecursiveIterator {
/* Yöntemler */
public __construct ([ int $max_memory ] )
/* Miras alınan yöntemler */
public string|array SplFileObject::current ( void )
public bool SplFileObject::eof ( void )
public bool SplFileObject::fflush ( void )
public string SplFileObject::fgetc ( void )
 public array SplFileObject::fgetcsv
  ([ string $delimiter = ","
 [, string $enclosure = "\""
 [, string $escape = "\\"
]]] )
public string SplFileObject::fgets ( void )
public string SplFileObject::fgetss ([ string $allowable_tags ] )
public bool SplFileObject::flock ( int $operation [, int &$wouldblock ] )
public int SplFileObject::fpassthru ( void )
 public int SplFileObject::fputcsv
  ( array $fields
 [, string $delimiter = ","
 [, string $enclosure = '"'
 [, string $escape = "\"
]]] )
public string SplFileObject::fread ( int $length )
public mixed SplFileObject::fscanf ( string $format [, mixed &$... ] )
public int SplFileObject::fseek ( int $offset [, int $whence = SEEK_SET ] )
public array SplFileObject::fstat ( void )
public int SplFileObject::ftell ( void )
public bool SplFileObject::ftruncate ( int $size )
public int SplFileObject::fwrite ( string $str [, int $length ] )
public void SplFileObject::getChildren ( void )
public array SplFileObject::getCsvControl ( void )
public int SplFileObject::getFlags ( void )
public int SplFileObject::getMaxLineLen ( void )
public bool SplFileObject::hasChildren ( void )
public int SplFileObject::key ( void )
public void SplFileObject::next ( void )
public void SplFileObject::rewind ( void )
public void SplFileObject::seek ( int $line_pos )
 public void SplFileObject::setCsvControl
  ([ string $delimiter = ","
 [, string $enclosure = "\""
 [, string $escape = "\\"
]]] )
public void SplFileObject::setFlags ( int $flags )
public void SplFileObject::setMaxLineLen ( int $max_len )
public void SplFileObject::__toString ( void )
public bool SplFileObject::valid ( void )
}

İçindekiler

  • SplTempFileObject::__construct — Construct a new temporary file object
SplFileObject::valid
SplTempFileObject::__construct
File Handling


Construct a new temporary file object

SplTempFileObject
Miscellaneous Classes and Interfaces
SplTempFileObject
PHP Manual

SplTempFileObject::__construct

(PHP 5 >= 5.1.2, PHP 7)

SplTempFileObject::__construct — Construct a new temporary file object

Açıklama

public SplTempFileObject::__construct ([ int $max_memory ] )

Construct a new temporary file object.

Değiştirgeler

max_memory

The maximum amount of memory (in bytes, default is 2 MB) for the temporary file to use. If the temporary file exceeds this size, it will be moved to a file in the system's temp directory.

If max_memory is negative, only memory will be used. If max_memory is zero, no memory will be used.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

Throws a RuntimeException if an error occurs.

Örnekler

Örnek 1 SplTempFileObject() example

This example writes a temporary file in memory which can be written to and read from.

<?php
$temp = new SplTempFileObject();
$temp->fwrite("This is the first line\n");
$temp->fwrite("And this is the second.\n");
echo "Written " . $temp->ftell() . " bytes to temporary file.\n\n";

// Rewind and read what was written
$temp->rewind();
foreach ($temp as $line) {
    echo $line;
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Written 47 bytes to temporary file.

This is the first line
And this is the second.

Ayrıca Bakınız

  • SplFileObject
  • PHP input/output streams (for php://temp and php://memory)

SplTempFileObject
Miscellaneous Classes and Interfaces
SplTempFileObject


Miscellaneous Classes and Interfaces

İçindekiler

  • ArrayObject
  • SplObserver
  • SplSubject

Classes and interfaces which do not fit into the other SPL categories.

SplTempFileObject::__construct
ArrayObject
SPL


The ArrayObject class

(PHP 5, PHP 7)

Giriş

This class allows objects to work as arrays.

Sınıf Sözdizimi

ArrayObject implements IteratorAggregate , ArrayAccess , Serializable , Countable {
/* Sabitler */
const integer STD_PROP_LIST = 1 ;
const integer ARRAY_AS_PROPS = 2 ;
/* Yöntemler */
public __construct ([ mixed $input = [] [, int $flags = 0 [, string $iterator_class = "ArrayIterator" ]]] )
public void append ( mixed $value )
public void asort ( void )
public int count ( void )
public array exchangeArray ( mixed $input )
public array getArrayCopy ( void )
public int getFlags ( void )
public ArrayIterator getIterator ( void )
public string getIteratorClass ( void )
public void ksort ( void )
public void natcasesort ( void )
public void natsort ( void )
public bool offsetExists ( mixed $index )
public mixed offsetGet ( mixed $index )
public void offsetSet ( mixed $index , mixed $newval )
public void offsetUnset ( mixed $index )
public string serialize ( void )
public void setFlags ( int $flags )
public void setIteratorClass ( string $iterator_class )
public void uasort ( callable $cmp_function )
public void uksort ( callable $cmp_function )
public void unserialize ( string $serialized )
}

Öntanımlı Sabitler

ArrayObject Flags

ArrayObject::STD_PROP_LIST

Properties of the object have their normal functionality when accessed as list (var_dump, foreach, etc.).

ArrayObject::ARRAY_AS_PROPS

Entries can be accessed as properties (read and write).

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | Implements Serializable.

İçindekiler

  • ArrayObject::append — Appends the value
  • ArrayObject::asort — Sort the entries by value
  • ArrayObject::__construct — Construct a new array object
  • ArrayObject::count — Get the number of public properties in the ArrayObject
  • ArrayObject::exchangeArray — Exchange the array for another one.
  • ArrayObject::getArrayCopy — Creates a copy of the ArrayObject.
  • ArrayObject::getFlags — Gets the behavior flags.
  • ArrayObject::getIterator — Create a new iterator from an ArrayObject instance
  • ArrayObject::getIteratorClass — Gets the iterator classname for the ArrayObject.
  • ArrayObject::ksort — Sort the entries by key
  • ArrayObject::natcasesort — Sort an array using a case insensitive "natural order" algorithm
  • ArrayObject::natsort — Sort entries using a "natural order" algorithm
  • ArrayObject::offsetExists — Returns whether the requested index exists
  • ArrayObject::offsetGet — Returns the value at the specified index
  • ArrayObject::offsetSet — Sets the value at the specified index to newval
  • ArrayObject::offsetUnset — Unsets the value at the specified index
  • ArrayObject::serialize — Serialize an ArrayObject
  • ArrayObject::setFlags — Sets the behavior flags.
  • ArrayObject::setIteratorClass — Sets the iterator classname for the ArrayObject.
  • ArrayObject::uasort — Sort the entries with a user-defined comparison function and maintain key association
  • ArrayObject::uksort — Sort the entries by keys using a user-defined comparison function
  • ArrayObject::unserialize — Unserialize an ArrayObject
Miscellaneous Classes and Interfaces
ArrayObject::append
Miscellaneous Classes and Interfaces


Appends the value

ArrayObject
ArrayObject::asort
ArrayObject
PHP Manual

ArrayObject::append

(PHP 5 >= 5.0.0, PHP 7)

ArrayObject::append — Appends the value

Açıklama

public void ArrayObject::append ( mixed $value )

Appends a new value as the last element.

Bilginize:

This method cannot be called when the ArrayObject was constructed from an object. Use ArrayObject::offsetSet() instead.

Değiştirgeler

value

The value being appended.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 ArrayObject::append() example

<?php
$arrayobj = new ArrayObject(array('first','second','third'));
$arrayobj->append('fourth');
$arrayobj->append(array('five', 'six'));
var_dump($arrayobj);
?>

Yukarıdaki örneğin çıktısı:

object(ArrayObject)#1 (5) {
  [0]=>
  string(5) "first"
  [1]=>
  string(6) "second"
  [2]=>
  string(5) "third"
  [3]=>
  string(6) "fourth"
  [4]=>
  array(2) {
    [0]=>
    string(4) "five"
    [1]=>
    string(3) "six"
  }
}

Ayrıca Bakınız

  • ArrayObject::offsetSet() - Sets the value at the specified index to newval

ArrayObject
ArrayObject::asort
ArrayObject


Sort the entries by value

ArrayObject::append
ArrayObject::__construct
ArrayObject
PHP Manual

ArrayObject::asort

(PHP 5 >= 5.2.0, PHP 7)

ArrayObject::asort — Sort the entries by value

Açıklama

public void ArrayObject::asort ( void )

Sorts the entries such that the keys maintain their correlation with the entries they are associated with. This is used mainly when sorting associative arrays where the actual element order is significant.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 ArrayObject::asort() example

<?php
$fruits = array("d" => "lemon", "a" => "orange", "b" => "banana", "c" => "apple");
$fruitArrayObject = new ArrayObject($fruits);
$fruitArrayObject->asort();

foreach ($fruitArrayObject as $key => $val) {
    echo "$key = $val\n";
}
?>

Yukarıdaki örneğin çıktısı:

c = apple
b = banana
d = lemon
a = orange

The fruits have been sorted in alphabetical order, and the key associated with each entry has been maintained.

Ayrıca Bakınız

  • ArrayObject::ksort() - Sort the entries by key
  • ArrayObject::natsort() - Sort entries using a "natural order" algorithm
  • ArrayObject::natcasesort() - Sort an array using a case insensitive "natural order" algorithm
  • ArrayObject::uasort() - Sort the entries with a user-defined comparison function and maintain key association
  • ArrayObject::uksort() - Sort the entries by keys using a user-defined comparison function

ArrayObject::append
ArrayObject::__construct
ArrayObject


Construct a new array object

ArrayObject::asort
ArrayObject::count
ArrayObject
PHP Manual

ArrayObject::__construct

(PHP 5 >= 5.0.0, PHP 7)

ArrayObject::__construct — Construct a new array object

Açıklama

public ArrayObject::__construct ([ mixed $input = [] [, int $flags = 0 [, string $iterator_class = "ArrayIterator" ]]] )

This constructs a new array object.

Değiştirgeler

input

The input parameter accepts an array or an Object.

flags

Flags to control the behaviour of the ArrayObject object. See ArrayObject::setFlags().

iterator_class

Specify the class that will be used for iteration of the ArrayObject object.

Dönen Değerler

Returns an ArrayObject object on success.

Hatalar/İstisnalar

Throws InvalidArgumentException when:

  • input is not an array or object
  • flags is not an integer
  • iterator_class is not an object that implements Iterator

Örnekler

Örnek 1 ArrayObject::__construct() example

<?php
$array = array('1' => 'one',
               '2' => 'two',
               '3' => 'three');

$arrayobject = new ArrayObject($array);

var_dump($arrayobject);
?>

Yukarıdaki örneğin çıktısı:

object(ArrayObject)#1 (3) {
  [1]=>
  string(3) "one"
  [2]=>
  string(3) "two"
  [3]=>
  string(5) "three"
}

Ayrıca Bakınız

  • ArrayObject::setflags() - Sets the behavior flags.

ArrayObject::asort
ArrayObject::count
ArrayObject


Get the number of public properties in the ArrayObject

ArrayObject::__construct
ArrayObject::exchangeArray
ArrayObject
PHP Manual

ArrayObject::count

(PHP 5 >= 5.0.0, PHP 7)

ArrayObject::count — Get the number of public properties in the ArrayObject

Açıklama

public int ArrayObject::count ( void )

Get the number of public properties in the ArrayObject.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The number of public properties in the ArrayObject.

Bilginize:

When the ArrayObject is constructed from an array all properties are public.

Örnekler

Örnek 1 ArrayObject::count() example

<?php
class Example {
    public $public = 'prop:public';
    private $prv   = 'prop:private';
    protected $prt = 'prop:protected';
}

$arrayobj = new ArrayObject(new Example());
var_dump($arrayobj->count());

$arrayobj = new ArrayObject(array('first','second','third'));
var_dump($arrayobj->count());
?>

Yukarıdaki örneğin çıktısı:

int(1)
int(3)

ArrayObject::__construct
ArrayObject::exchangeArray
ArrayObject


Exchange the array for another one.

ArrayObject::count
ArrayObject::getArrayCopy
ArrayObject
PHP Manual

ArrayObject::exchangeArray

(PHP 5 >= 5.1.0, PHP 7)

ArrayObject::exchangeArray — Exchange the array for another one.

Açıklama

public array ArrayObject::exchangeArray ( mixed $input )

Exchange the current array with another array or object.

Değiştirgeler

input

The new array or object to exchange with the current array.

Dönen Değerler

Returns the old array.

Örnekler

Örnek 1 ArrayObject::exchangeArray() example

<?php
// Array of available fruits
$fruits = array("lemons" => 1, "oranges" => 4, "bananas" => 5, "apples" => 10);
// Array of locations in Europe
$locations = array('Amsterdam', 'Paris', 'London');

$fruitsArrayObject = new ArrayObject($fruits);

// Now exchange fruits for locations
$old = $fruitsArrayObject->exchangeArray($locations);
print_r($old);
print_r($fruitsArrayObject);

?>

Yukarıdaki örneğin çıktısı:

Array
(
    [lemons] => 1
    [oranges] => 4
    [bananas] => 5
    [apples] => 10
)
ArrayObject Object
(
    [0] => Amsterdam
    [1] => Paris
    [2] => London
)

ArrayObject::count
ArrayObject::getArrayCopy
ArrayObject


Creates a copy of the ArrayObject.

ArrayObject::exchangeArray
ArrayObject::getFlags
ArrayObject
PHP Manual

ArrayObject::getArrayCopy

(PHP 5 >= 5.0.0, PHP 7)

ArrayObject::getArrayCopy — Creates a copy of the ArrayObject.

Açıklama

public array ArrayObject::getArrayCopy ( void )

Exports the ArrayObject to an array.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a copy of the array. When the ArrayObject refers to an object an array of the public properties of that object will be returned.

Örnekler

Örnek 1 ArrayObject::getArrayCopy() example

<?php
// Array of available fruits
$fruits = array("lemons" => 1, "oranges" => 4, "bananas" => 5, "apples" => 10);

$fruitsArrayObject = new ArrayObject($fruits);
$fruitsArrayObject['pears'] = 4;

// create a copy of the array
$copy = $fruitsArrayObject->getArrayCopy();
print_r($copy);

?>

Yukarıdaki örneğin çıktısı:

Array
(
    [lemons] => 1
    [oranges] => 4
    [bananas] => 5
    [apples] => 10
    [pears] => 4
)

ArrayObject::exchangeArray
ArrayObject::getFlags
ArrayObject


Gets the behavior flags.

ArrayObject::getArrayCopy
ArrayObject::getIterator
ArrayObject
PHP Manual

ArrayObject::getFlags

(PHP 5 >= 5.1.0, PHP 7)

ArrayObject::getFlags — Gets the behavior flags.

Açıklama

public int ArrayObject::getFlags ( void )

Gets the behavior flags of the ArrayObject. See the ArrayObject::setFlags method for a list of the available flags.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the behavior flags of the ArrayObject.

Örnekler

Örnek 1 ArrayObject::getFlags() example

<?php
// Array of available fruits
$fruits = array("lemons" => 1, "oranges" => 4, "bananas" => 5, "apples" => 10);

$fruitsArrayObject = new ArrayObject($fruits);

// Get the current flags
$flags = $fruitsArrayObject->getFlags();
var_dump($flags);

// Set new flags
$fruitsArrayObject->setFlags(ArrayObject::ARRAY_AS_PROPS);

// Get the new flags
$flags = $fruitsArrayObject->getFlags();
var_dump($flags);
?>

Yukarıdaki örneğin çıktısı:

int(0)
int(2)

Ayrıca Bakınız

  • The ArrayObject::setFlags method

ArrayObject::getArrayCopy
ArrayObject::getIterator
ArrayObject


Create a new iterator from an ArrayObject instance

ArrayObject::getFlags
ArrayObject::getIteratorClass
ArrayObject
PHP Manual

ArrayObject::getIterator

(PHP 5 >= 5.0.0, PHP 7)

ArrayObject::getIterator — Create a new iterator from an ArrayObject instance

Açıklama

public ArrayIterator ArrayObject::getIterator ( void )

Create a new iterator from an ArrayObject instance.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

An iterator from an ArrayObject.

Örnekler

Örnek 1 ArrayObject::getIterator() example

<?php
$array = array('1' => 'one',
               '2' => 'two',
               '3' => 'three');

$arrayobject = new ArrayObject($array);

$iterator = $arrayobject->getIterator();

while($iterator->valid()) {
    echo $iterator->key() . ' => ' . $iterator->current() . "\n";

    $iterator->next();
}
?>

Yukarıdaki örneğin çıktısı:

1 => one
2 => two
3 => three

ArrayObject::getFlags
ArrayObject::getIteratorClass
ArrayObject


Gets the iterator classname for the ArrayObject.

ArrayObject::getIterator
ArrayObject::ksort
ArrayObject
PHP Manual

ArrayObject::getIteratorClass

(PHP 5 >= 5.1.0, PHP 7)

ArrayObject::getIteratorClass — Gets the iterator classname for the ArrayObject.

Açıklama

public string ArrayObject::getIteratorClass ( void )

Gets the class name of the array iterator that is used by ArrayObject::getIterator().

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the iterator class name that is used to iterate over this object.

Örnekler

Örnek 1 ArrayObject::getIteratorClass() example

<?php
// Custom ArrayIterator (inherits from ArrayIterator)
class MyArrayIterator extends ArrayIterator {
    // custom implementation
}

// Array of available fruits
$fruits = array("lemons" => 1, "oranges" => 4, "bananas" => 5, "apples" => 10);

$fruitsArrayObject = new ArrayObject($fruits);

// Get the current class name
$className = $fruitsArrayObject->getIteratorClass();
var_dump($className);

// Set new classname
$fruitsArrayObject->setIteratorClass('MyArrayIterator');

// Get the new iterator classname
$className = $fruitsArrayObject->getIteratorClass();
var_dump($className);
?>

Yukarıdaki örneğin çıktısı:

string(13) "ArrayIterator"
string(15) "MyArrayIterator"

Ayrıca Bakınız

  • The ArrayObject::setIteratorClass method

ArrayObject::getIterator
ArrayObject::ksort
ArrayObject


Sort the entries by key

ArrayObject::getIteratorClass
ArrayObject::natcasesort
ArrayObject
PHP Manual

ArrayObject::ksort

(PHP 5 >= 5.2.0, PHP 7)

ArrayObject::ksort — Sort the entries by key

Açıklama

public void ArrayObject::ksort ( void )

Sorts the entries by key, maintaining key to entry correlations. This is useful mainly for associative arrays.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 ArrayObject::ksort() example

<?php
$fruits = array("d" => "lemon", "a" => "orange", "b" => "banana", "c" => "apple");
$fruitArrayObject = new ArrayObject($fruits);
$fruitArrayObject->ksort();

foreach ($fruitArrayObject as $key => $val) {
    echo "$key = $val\n";
}
 ?>

Yukarıdaki örneğin çıktısı:

a = orange
b = banana
c = apple
d = lemon

Ayrıca Bakınız

  • ArrayObject::asort() - Sort the entries by value
  • ArrayObject::natsort() - Sort entries using a "natural order" algorithm
  • ArrayObject::natcasesort() - Sort an array using a case insensitive "natural order" algorithm
  • ArrayObject::uasort() - Sort the entries with a user-defined comparison function and maintain key association
  • ArrayObject::uksort() - Sort the entries by keys using a user-defined comparison function

ArrayObject::getIteratorClass
ArrayObject::natcasesort
ArrayObject


Sort an array using a case insensitive "natural order" algorithm

ArrayObject::ksort
ArrayObject::natsort
ArrayObject
PHP Manual

ArrayObject::natcasesort

(PHP 5 >= 5.2.0, PHP 7)

ArrayObject::natcasesort — Sort an array using a case insensitive "natural order" algorithm

Açıklama

public void ArrayObject::natcasesort ( void )

This method is a case insensitive version of ArrayObject::natsort.

This method implements a sort algorithm that orders alphanumeric strings in the way a human being would while maintaining key/value associations. This is described as a "natural ordering".

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 ArrayObject::natcasesort() example

<?php
$array = array('IMG0.png', 'img12.png', 'img10.png', 'img2.png', 'img1.png', 'IMG3.png');

$arr1 = new ArrayObject($array);
$arr2 = clone $arr1;

$arr1->asort();
echo "Standard sorting\n";
print_r($arr1);

$arr2->natcasesort();
echo "\nNatural order sorting (case-insensitive)\n";
print_r($arr2);
?>

Yukarıdaki örneğin çıktısı:

Standard sorting
ArrayObject Object
(
    [0] => IMG0.png
    [5] => IMG3.png
    [4] => img1.png
    [2] => img10.png
    [1] => img12.png
    [3] => img2.png
)

Natural order sorting (case-insensitive)
ArrayObject Object
(
    [0] => IMG0.png
    [4] => img1.png
    [3] => img2.png
    [5] => IMG3.png
    [2] => img10.png
    [1] => img12.png
)

For more information see: Martin Pool's » Natural Order String Comparison page.

Ayrıca Bakınız

  • ArrayObject::asort() - Sort the entries by value
  • ArrayObject::ksort() - Sort the entries by key
  • ArrayObject::natsort() - Sort entries using a "natural order" algorithm
  • ArrayObject::uasort() - Sort the entries with a user-defined comparison function and maintain key association
  • ArrayObject::uksort() - Sort the entries by keys using a user-defined comparison function

ArrayObject::ksort
ArrayObject::natsort
ArrayObject


Sort entries using a "natural order" algorithm

ArrayObject::natcasesort
ArrayObject::offsetExists
ArrayObject
PHP Manual

ArrayObject::natsort

(PHP 5 >= 5.2.0, PHP 7)

ArrayObject::natsort — Sort entries using a "natural order" algorithm

Açıklama

public void ArrayObject::natsort ( void )

This method implements a sort algorithm that orders alphanumeric strings in the way a human being would while maintaining key/value associations. This is described as a "natural ordering". An example of the difference between this algorithm and the regular computer string sorting algorithms (used in ArrayObject::asort) method can be seen in the example below.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 ArrayObject::natsort() example

<?php
$array = array("img12.png", "img10.png", "img2.png", "img1.png");

$arr1 = new ArrayObject($array);
$arr2 = clone $arr1;

$arr1->asort();
echo "Standard sorting\n";
print_r($arr1);

$arr2->natsort();
echo "\nNatural order sorting\n";
print_r($arr2);
?>

Yukarıdaki örneğin çıktısı:

Standard sorting
ArrayObject Object
(
    [3] => img1.png
    [1] => img10.png
    [0] => img12.png
    [2] => img2.png
)

Natural order sorting
ArrayObject Object
(
    [3] => img1.png
    [2] => img2.png
    [1] => img10.png
    [0] => img12.png
)

For more information see: Martin Pool's » Natural Order String Comparison page.

Ayrıca Bakınız

  • ArrayObject::asort() - Sort the entries by value
  • ArrayObject::ksort() - Sort the entries by key
  • ArrayObject::natcasesort() - Sort an array using a case insensitive "natural order" algorithm
  • ArrayObject::uasort() - Sort the entries with a user-defined comparison function and maintain key association
  • ArrayObject::uksort() - Sort the entries by keys using a user-defined comparison function

ArrayObject::natcasesort
ArrayObject::offsetExists
ArrayObject


Returns whether the requested index exists

ArrayObject::natsort
ArrayObject::offsetGet
ArrayObject
PHP Manual

ArrayObject::offsetExists

(PHP 5 >= 5.0.0, PHP 7)

ArrayObject::offsetExists — Returns whether the requested index exists

Açıklama

public bool ArrayObject::offsetExists ( mixed $index )

Değiştirgeler

index

The index being checked.

Dönen Değerler

TRUE if the requested index exists, otherwise FALSE

Örnekler

Örnek 1 ArrayObject::offsetExists() example

<?php
$arrayobj = new ArrayObject(array('zero', 'one', 'example'=>'e.g.'));
var_dump($arrayobj->offsetExists(1));
var_dump($arrayobj->offsetExists('example'));
var_dump($arrayobj->offsetExists('notfound'));
?>

Yukarıdaki örneğin çıktısı:

bool(true)
bool(true)
bool(false)

ArrayObject::natsort
ArrayObject::offsetGet
ArrayObject


Returns the value at the specified index

ArrayObject::offsetExists
ArrayObject::offsetSet
ArrayObject
PHP Manual

ArrayObject::offsetGet

(PHP 5 >= 5.0.0, PHP 7)

ArrayObject::offsetGet — Returns the value at the specified index

Açıklama

public mixed ArrayObject::offsetGet ( mixed $index )

Değiştirgeler

index

The index with the value.

Dönen Değerler

The value at the specified index or NULL.

Hatalar/İstisnalar

Produces an E_NOTICE error message when the specified index does not exist.

Örnekler

Örnek 1 ArrayObject::offsetGet() example

<?php
$arrayobj = new ArrayObject(array('zero', 7, 'example'=>'e.g.'));
var_dump($arrayobj->offsetGet(1));
var_dump($arrayobj->offsetGet('example'));
var_dump($arrayobj->offsetExists('notfound'));
?>

Yukarıdaki örneğin çıktısı:

int(7)
string(4) "e.g."
bool(false)

ArrayObject::offsetExists
ArrayObject::offsetSet
ArrayObject


Sets the value at the specified index to newval

ArrayObject::offsetGet
ArrayObject::offsetUnset
ArrayObject
PHP Manual

ArrayObject::offsetSet

(PHP 5 >= 5.0.0, PHP 7)

ArrayObject::offsetSet — Sets the value at the specified index to newval

Açıklama

public void ArrayObject::offsetSet ( mixed $index , mixed $newval )

Sets the value at the specified index to newval.

Değiştirgeler

index

The index being set.

newval

The new value for the index.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 ArrayObject::offsetSet() example

<?php
class Example {
    public $property = 'prop:public';
}
$arrayobj = new ArrayObject(new Example());
$arrayobj->offsetSet(4, 'four');
$arrayobj->offsetSet('group', array('g1', 'g2'));
var_dump($arrayobj);

$arrayobj = new ArrayObject(array('zero','one'));
$arrayobj->offsetSet(null, 'last');
var_dump($arrayobj);
?>

Yukarıdaki örneğin çıktısı:

object(ArrayObject)#1 (3) {
  ["property"]=>
  string(11) "prop:public"
  [4]=>
  string(4) "four"
  ["group"]=>
  array(2) {
    [0]=>
    string(2) "g1"
    [1]=>
    string(2) "g2"
  }
}
object(ArrayObject)#3 (3) {
  [0]=>
  string(4) "zero"
  [1]=>
  string(3) "one"
  [2]=>
  string(4) "last"
}

Ayrıca Bakınız

  • ArrayObject::append() - Appends the value

ArrayObject::offsetGet
ArrayObject::offsetUnset
ArrayObject


Unsets the value at the specified index

ArrayObject::offsetSet
ArrayObject::serialize
ArrayObject
PHP Manual

ArrayObject::offsetUnset

(PHP 5 >= 5.0.0, PHP 7)

ArrayObject::offsetUnset — Unsets the value at the specified index

Açıklama

public void ArrayObject::offsetUnset ( mixed $index )

Unsets the value at the specified index.

Değiştirgeler

index

The index being unset.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 ArrayObject::offsetUnset() example

<?php
$arrayobj = new ArrayObject(array(0=>'zero',2=>'two'));
$arrayobj->offsetUnset(2);
var_dump($arrayobj);
?>

Yukarıdaki örneğin çıktısı:

object(ArrayObject)#1 (1) {
  [0]=>
  string(4) "zero"
}

ArrayObject::offsetSet
ArrayObject::serialize
ArrayObject


Serialize an ArrayObject

ArrayObject::offsetUnset
ArrayObject::setFlags
ArrayObject
PHP Manual

ArrayObject::serialize

(PHP 5 >= 5.3.0, PHP 7)

ArrayObject::serialize — Serialize an ArrayObject

Açıklama

public string ArrayObject::serialize ( void )

Serializes an ArrayObject.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The serialized representation of the ArrayObject.

Örnekler

Örnek 1 ArrayObject::serialize() example

<?php
$o = new ArrayObject();

$s1 = serialize($o);
$s2 = $o->serialize();

var_dump($s1);
var_dump($s2);
?>

Yukarıdaki örneğin çıktısı:

string(45) "C:11:"ArrayObject":21:{x:i:0;a:0:{};m:a:0:{}}"
string(21) "x:i:0;a:0:{};m:a:0:{}"

Ayrıca Bakınız

  • ArrayObject::unserialize() - Unserialize an ArrayObject
  • serialize() - Bir değerin saklanabilir bir gösterimini üretir
  • Serializing Objects

ArrayObject::offsetUnset
ArrayObject::setFlags
ArrayObject


Sets the behavior flags.

ArrayObject::serialize
ArrayObject::setIteratorClass
ArrayObject
PHP Manual

ArrayObject::setFlags

(PHP 5 >= 5.1.0, PHP 7)

ArrayObject::setFlags — Sets the behavior flags.

Açıklama

public void ArrayObject::setFlags ( int $flags )

Set the flags that change the behavior of the ArrayObject.

Değiştirgeler

flags

The new ArrayObject behavior. It takes on either a bitmask, or named constants. Using named constants is strongly encouraged to ensure compatibility for future versions.

The available behavior flags are listed below. The actual meanings of these flags are described in the predefined constants.

ArrayObject behavior flags
value | constant
1 | ArrayObject::STD_PROP_LIST
2 | ArrayObject::ARRAY_AS_PROPS

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 ArrayObject::setFlags() example

<?php
// Array of available fruits
$fruits = array("lemons" => 1, "oranges" => 4, "bananas" => 5, "apples" => 10);

$fruitsArrayObject = new ArrayObject($fruits);

// Try to use array key as property
var_dump($fruitsArrayObject->lemons);
// Set the flag so that the array keys can be used as properties of the ArrayObject
$fruitsArrayObject->setFlags(ArrayObject::ARRAY_AS_PROPS);
// Try it again
var_dump($fruitsArrayObject->lemons);
?>

Yukarıdaki örneğin çıktısı:

NULL
int(1)

ArrayObject::serialize
ArrayObject::setIteratorClass
ArrayObject


Sets the iterator classname for the ArrayObject.

ArrayObject::setFlags
ArrayObject::uasort
ArrayObject
PHP Manual

ArrayObject::setIteratorClass

(PHP 5 >= 5.1.0, PHP 7)

ArrayObject::setIteratorClass — Sets the iterator classname for the ArrayObject.

Açıklama

public void ArrayObject::setIteratorClass ( string $iterator_class )

Sets the classname of the array iterator that is used by ArrayObject::getIterator().

Değiştirgeler

iterator_class

The classname of the array iterator to use when iterating over this object.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 ArrayObject::setIteratorClass() example

<?php
// Custom ArrayIterator (inherits from ArrayIterator)
class MyArrayIterator extends ArrayIterator {
    // custom implementation
}

// Array of available fruits
$fruits = array("lemons" => 1, "oranges" => 4, "bananas" => 5, "apples" => 10);

$fruitsArrayObject = new ArrayObject($fruits);

// Set the iterator classname to the newly
$fruitsArrayObject->setIteratorClass('MyArrayIterator');
print_r($fruitsArrayObject->getIterator());

?>

Yukarıdaki örneğin çıktısı:

MyArrayIterator Object
(
    [lemons] => 1
    [oranges] => 4
    [bananas] => 5
    [apples] => 10
)

ArrayObject::setFlags
ArrayObject::uasort
ArrayObject


Sort the entries with a user-defined comparison function and maintain key association

ArrayObject::setIteratorClass
ArrayObject::uksort
ArrayObject
PHP Manual

ArrayObject::uasort

(PHP 5 >= 5.2.0, PHP 7)

ArrayObject::uasort — Sort the entries with a user-defined comparison function and maintain key association

Açıklama

public void ArrayObject::uasort ( callable $cmp_function )

This function sorts the entries such that keys maintain their correlation with the entry that they are associated with, using a user-defined comparison function.

This is used mainly when sorting associative arrays where the actual element order is significant.

Değiştirgeler

cmp_function

Function cmp_function should accept two parameters which will be filled by pairs of entries. The comparison function must return an integer less than, equal to, or greater than zero if the first argument is considered to be respectively less than, equal to, or greater than the second.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 ArrayObject::uasort() example

<?php
// Comparison function
function cmp($a, $b) {
    if ($a == $b) {
        return 0;
    }
    return ($a < $b) ? -1 : 1;
}

// Array to be sorted
$array = array('a' => 4, 'b' => 8, 'c' => -1, 'd' => -9, 'e' => 2, 'f' => 5, 'g' => 3, 'h' => -4);
$arrayObject = new ArrayObject($array);
print_r($arrayObject);

// Sort and print the resulting array
$arrayObject->uasort('cmp');
print_r($arrayObject);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [a] => 4
    [b] => 8
    [c] => -1
    [d] => -9
    [e] => 2
    [f] => 5
    [g] => 3
    [h] => -4
)
Array
(
    [d] => -9
    [h] => -4
    [c] => -1
    [e] => 2
    [g] => 3
    [a] => 4
    [f] => 5
    [b] => 8
)

Ayrıca Bakınız

  • ArrayObject::asort() - Sort the entries by value
  • ArrayObject::ksort() - Sort the entries by key
  • ArrayObject::natsort() - Sort entries using a "natural order" algorithm
  • ArrayObject::natcasesort() - Sort an array using a case insensitive "natural order" algorithm
  • ArrayObject::uksort() - Sort the entries by keys using a user-defined comparison function

ArrayObject::setIteratorClass
ArrayObject::uksort
ArrayObject


Sort the entries by keys using a user-defined comparison function

ArrayObject::uasort
ArrayObject::unserialize
ArrayObject
PHP Manual

ArrayObject::uksort

(PHP 5 >= 5.2.0, PHP 7)

ArrayObject::uksort — Sort the entries by keys using a user-defined comparison function

Açıklama

public void ArrayObject::uksort ( callable $cmp_function )

This function sorts the keys of the entries using a user-supplied comparison function. The key to entry correlations will be maintained.

Değiştirgeler

cmp_function

The callback comparison function.

Function cmp_function should accept two parameters which will be filled by pairs of entry keys. The comparison function must return an integer less than, equal to, or greater than zero if the first argument is considered to be respectively less than, equal to, or greater than the second.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 ArrayObject::uksort() example

<?php
function cmp($a, $b) {
    $a = preg_replace('@^(a|an|the) @', '', $a);
    $b = preg_replace('@^(a|an|the) @', '', $b);
    return strcasecmp($a, $b);
}

$array = array("John" => 1, "the Earth" => 2, "an apple" => 3, "a banana" => 4);
$arrayObject = new ArrayObject($array);
$arrayObject->uksort('cmp');

foreach ($arrayObject as $key => $value) {
    echo "$key: $value\n";
}
?>

Yukarıdaki örneğin çıktısı:

an apple: 3
a banana: 4
the Earth: 2
John: 1

Ayrıca Bakınız

  • ArrayObject::asort() - Sort the entries by value
  • ArrayObject::ksort() - Sort the entries by key
  • ArrayObject::natsort() - Sort entries using a "natural order" algorithm
  • ArrayObject::natcasesort() - Sort an array using a case insensitive "natural order" algorithm
  • ArrayObject::uasort() - Sort the entries with a user-defined comparison function and maintain key association

ArrayObject::uasort
ArrayObject::unserialize
ArrayObject


Unserialize an ArrayObject

ArrayObject::uksort
SplObserver
ArrayObject
PHP Manual

ArrayObject::unserialize

(PHP 5 >= 5.3.0, PHP 7)

ArrayObject::unserialize — Unserialize an ArrayObject

Açıklama

public void ArrayObject::unserialize ( string $serialized )

Unserializes a serialized ArrayObject.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

serialized

The serialized ArrayObject.

Dönen Değerler

The unserialized ArrayObject.

Ayrıca Bakınız

  • ArrayIterator::serialize() - Serialize
  • unserialize() - Bir PHP değerini saklanmış gösteriminden oluşturur
  • Serializing Objects

ArrayObject::uksort
SplObserver
ArrayObject


The SplObserver interface

(PHP 5 >= 5.1.0, PHP 7)

Giriş

The SplObserver interface is used alongside SplSubject to implement the Observer Design Pattern.

Arayüz Sözdizimi

SplObserver {
/* Yöntemler */
abstract public void update ( SplSubject $subject )
}

İçindekiler

  • SplObserver::update — Receive update from subject
ArrayObject::unserialize
SplObserver::update
Miscellaneous Classes and Interfaces


Receive update from subject

SplObserver
SplSubject
SplObserver
PHP Manual

SplObserver::update

(PHP 5 >= 5.1.0, PHP 7)

SplObserver::update — Receive update from subject

Açıklama

abstract public void SplObserver::update ( SplSubject $subject )

This method is called when any SplSubject to which the observer is attached calls SplSubject::notify().

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

subject

The SplSubject notifying the observer of an update.

Dönen Değerler

Hiçbir değer dönmez.

SplObserver
SplSubject
SplObserver


The SplSubject interface

(PHP 5 >= 5.1.0, PHP 7)

Giriş

The SplSubject interface is used alongside SplObserver to implement the Observer Design Pattern.

Arayüz Sözdizimi

SplSubject {
/* Yöntemler */
abstract public void attach ( SplObserver $observer )
abstract public void detach ( SplObserver $observer )
abstract public void notify ( void )
}

İçindekiler

  • SplSubject::attach — Attach an SplObserver
  • SplSubject::detach — Detach an observer
  • SplSubject::notify — Notify an observer
SplObserver::update
SplSubject::attach
Miscellaneous Classes and Interfaces


Attach an SplObserver

SplSubject
SplSubject::detach
SplSubject
PHP Manual

SplSubject::attach

(PHP 5 >= 5.1.0, PHP 7)

SplSubject::attach — Attach an SplObserver

Açıklama

abstract public void SplSubject::attach ( SplObserver $observer )

Attaches an SplObserver so that it can be notified of updates.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

observer

The SplObserver to attach.

Dönen Değerler

Hiçbir değer dönmez.

SplSubject
SplSubject::detach
SplSubject


Detach an observer

SplSubject::attach
SplSubject::notify
SplSubject
PHP Manual

SplSubject::detach

(PHP 5 >= 5.1.0, PHP 7)

SplSubject::detach — Detach an observer

Açıklama

abstract public void SplSubject::detach ( SplObserver $observer )

Detaches an observer from the subject to no longer notify it of updates.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

observer

The SplObserver to detach.

Dönen Değerler

Hiçbir değer dönmez.

SplSubject::attach
SplSubject::notify
SplSubject


Notify an observer

SplSubject::detach
SPL Types
SplSubject
PHP Manual

SplSubject::notify

(PHP 5 >= 5.1.0, PHP 7)

SplSubject::notify — Notify an observer

Açıklama

abstract public void SplSubject::notify ( void )

Notifies all attached observers.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

SplSubject::detach
SPL Types
SplSubject


SPL Type Handling

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • SplType — The SplType class
    • SplType::__construct — Creates a new value of some type
  • SplInt — The SplInt class
  • SplFloat — The SplFloat class
  • SplEnum — The SplEnum class
    • SplEnum::getConstList — Returns all consts (possible values) as an array.
  • SplBool — The SplBool class
  • SplString — The SplString class
SplSubject::notify
Giriş
Diğer Temel Eklentiler


Giriş

This extension aims at helping people making PHP a stronger typed language and can be a good alternative to scalar type hinting. It provides different typehandling classes as such as integer, float, bool, enum and string

Uyarı

Bu eklenti DENEYSELDİR. Bu eklentinin davranışı, işlev isimleri ve tüm belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu eklentiyi kullanmayın.

SPL Types
Yapılandırma/Kurulum
SPL Types


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
SPL Types


Kurulum

Bu » PECL eklentisi PHP ile gelmez.

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/SPL_Types.

Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Özkaynak Türleri

Bu eklentinin tanımlı hiçbir özkaynak türü yoktur.

Çalışma Anı Yapılandırması
SplType
Yapılandırma/Kurulum


The SplType class

(PECL spl_types >= 0.1.0)

Giriş

Parent class for all SPL types.

Sınıf Sözdizimi

abstract SplType {
/* Constants */
const NULL __default = null ;
/* Yöntemler */
__construct ([ mixed $initial_value [, bool $strict ]] )
}

Öntanımlı Sabitler

SplType::__default

İçindekiler

  • SplType::__construct — Creates a new value of some type
Özkaynak Türleri
SplType::__construct
SPL Types


Creates a new value of some type

SplType
SplInt
SplType
PHP Manual

SplType::__construct

(PECL spl_types >= 0.1.0)

SplType::__construct — Creates a new value of some type

Açıklama

SplType::__construct ([ mixed $initial_value [, bool $strict ]] )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

initial_value

Type and default value depends on the extension class.

strict

Whether to set the object's sctrictness.

Hatalar/İstisnalar

Throws an UnexpectedValueException if incompatible type is given.

SplType
SplInt
SplType


The SplInt class

(PECL spl_types >= 0.1.0)

Giriş

The SplInt class is used to enforce strong typing of the integer type.

Sınıf Sözdizimi

SplInt extends SplType {
/* Constants */
const integer __default = 0 ;
/* Miras alınan yöntemler */
SplType::__construct ([ mixed $initial_value [, bool $strict ]] )
}

Öntanımlı Sabitler

SplInt::__default

Örnekler

Örnek 1 SplInt usage example

<?php
$int = new SplInt(94);

try {
    $int = 'Try to cast a string value for fun';
} catch (UnexpectedValueException $uve) {
    echo $uve->getMessage() . PHP_EOL;
}

echo $int . PHP_EOL;
?>

Yukarıdaki örneğin çıktısı:

Value not an integer
94

SplType::__construct
SplFloat
SPL Types


The SplFloat class

(PECL spl_types >= 0.1.0)

Giriş

The SplFloat class is used to enforce strong typing of the float type.

Sınıf Sözdizimi

SplFloat extends SplType {
/* Constants */
const float __default = 0 ;
/* Miras alınan yöntemler */
SplType::__construct ([ mixed $initial_value [, bool $strict ]] )
}

Öntanımlı Sabitler

SplFloat::__default

Örnekler

Örnek 1 SplFloat usage example

<?php
$float = new SplFloat(3.154);
$newFloat = new SplFloat(3);

try {
    $float = 'Try to cast a string value for fun';
} catch (UnexpectedValueException $uve) {
    echo $uve->getMessage() . PHP_EOL;
}

echo $float . PHP_EOL;
echo $newFloat . PHP_EOL;
?>

Yukarıdaki örneğin çıktısı:

Value not a float
3.154
3

SplInt
SplEnum
SPL Types


The SplEnum class

(PECL spl_types >= 0.1.0)

Giriş

SplEnum gives the ability to emulate and create enumeration objects natively in PHP.

Sınıf Sözdizimi

SplEnum extends SplType {
/* Constants */
const NULL __default = null ;
/* Yöntemler */
public array getConstList ([ bool $include_default = false ] )
/* Miras alınan yöntemler */
SplType::__construct ([ mixed $initial_value [, bool $strict ]] )
}

Öntanımlı Sabitler

SplEnum::__default

Örnekler

Örnek 1 SplEnum usage example

<?php
class Month extends SplEnum {
    const __default = self::January;

    const January = 1;
    const February = 2;
    const March = 3;
    const April = 4;
    const May = 5;
    const June = 6;
    const July = 7;
    const August = 8;
    const September = 9;
    const October = 10;
    const November = 11;
    const December = 12;
}

echo new Month(Month::June) . PHP_EOL;

try {
    new Month(13);
} catch (UnexpectedValueException $uve) {
    echo $uve->getMessage() . PHP_EOL;
}
?>

Yukarıdaki örneğin çıktısı:

6
Value not a const in enum Month

İçindekiler

  • SplEnum::getConstList — Returns all consts (possible values) as an array.
SplFloat
SplEnum::getConstList
SPL Types


Returns all consts (possible values) as an array.

SplEnum
SplBool
SplEnum
PHP Manual

SplEnum::getConstList

(PECL spl_types >= 0.1.0)

SplEnum::getConstList — Returns all consts (possible values) as an array.

Açıklama

public array SplEnum::getConstList ([ bool $include_default = false ] )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

include_default

Whether to include __default property.

Dönen Değerler

Örnekler

Örnek 1 SplEnum::getConstList() example

<?php
$bool = new SplBool;
var_dump($bool->getConstList(true));
?>

Yukarıdaki örneğin çıktısı:

array(3) {
  ["__default"]=>
  bool(false)
  ["false"]=>
  bool(false)
  ["true"]=>
  bool(true)
}

SplEnum
SplBool
SplEnum


The SplBool class

(PECL spl_types >= 0.1.0)

Giriş

The SplBool class is used to enforce strong typing of the bool type.

Sınıf Sözdizimi

SplBool extends SplEnum {
/* Constants */
const boolean __default = false ;
const boolean false = false ;
const boolean true = true ;
/* Miras alınan yöntemler */
public array SplEnum::getConstList ([ bool $include_default = false ] )
}

Öntanımlı Sabitler

SplBool::__default

SplBool::false

SplBool::true

Örnekler

Örnek 1 SplBool usage example

<?php
$true = new SplBool(true);
if ($true) {
    echo "TRUE\n";
}

$false = new SplBool;
if ($false) {
    echo "FALSE\n";
}
?>

Yukarıdaki örneğin çıktısı:

TRUE

SplEnum::getConstList
SplString
SPL Types


The SplString class

(PECL spl_types >= 0.1.0)

Giriş

The SplString class is used to enforce strong typing of the string type.

Sınıf Sözdizimi

SplString extends SplType {
/* Constants */
const string __default = '' ;
/* Miras alınan yöntemler */
SplType::__construct ([ mixed $initial_value [, bool $strict ]] )
}

Öntanımlı Sabitler

SplString::__default

Örnekler

Örnek 1 SplString usage example

<?php
$string = new SplString("Testing");

try {
    $string = array();
} catch (UnexpectedValueException $uve) {
    echo $uve->getMessage() . PHP_EOL;
}

var_dump($string);
echo $string; // Outputs "Testing"
?>

Yukarıdaki örneğin çıktısı:

Value not a string
object(SplString)#1 (1) {
  ["__default"]=>
  string(7) "Testing"
}
Testing

SplBool
Akımlar
SPL Types


Akımlar

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Akım Sınıfları
  • Öntanımlı Sabitler
  • Akım Süzgeçleri
  • Akım Bağlamları
  • Akım Hataları
  • Örnekler
    • Akım Sarmalayıcı olarak örnek bir sınıf tanımı
  • streamWrapper — streamWrapper sınıfı
    • streamWrapper::__construct — Yeni bir akım sarmalayıcı oluşturur
    • streamWrapper::__destruct — Destructs an existing stream wrapper
    • streamWrapper::dir_closedir — Dizin tanıtıcısını kapatır
    • streamWrapper::dir_opendir — Dizin tanıtıcısı açar
    • streamWrapper::dir_readdir — Dizinden bir girdi okur
    • streamWrapper::dir_rewinddir — Dizin tanıtıcısını dizin başlangıcına konumlar
    • streamWrapper::mkdir — Bir dizin oluşturur
    • streamWrapper::rename — Bir dosya veya dizinin ismini değiştirir
    • streamWrapper::rmdir — Bir dizini siler
    • streamWrapper::stream_cast — Temel özkaynağı döndürür
    • streamWrapper::stream_close — Bir özkaynağı kapatır
    • streamWrapper::stream_eof — Dosya göstericisinin dosya sonunda olup olmadığına bakar
    • streamWrapper::stream_flush — Çıktıyı boşaltır
    • streamWrapper::stream_lock — Tavsiye niteliğinde dosya kilitleme
    • streamWrapper::stream_metadata — Change stream metadata
    • streamWrapper::stream_open — Bir dosya veya URL açar
    • streamWrapper::stream_read — Akımdan veri okur
    • streamWrapper::stream_seek — Akım üzerinde belli bir konuma gidilir
    • streamWrapper::stream_set_option — Akım seçeneklerini değiştirir
    • streamWrapper::stream_stat — Bir dosya özkaynağı hakkında bilgi döndürür
    • streamWrapper::stream_tell — Bir akımdan geçerli konumu döndürür
    • streamWrapper::stream_truncate — Truncate stream
    • streamWrapper::stream_write — Akıma yazar
    • streamWrapper::unlink — Bir dosyayı siler
    • streamWrapper::url_stat — Bir dosya hakkında bilgi döndürür
  • Akım İşlevleri
    • set_socket_blocking — Takma Adı: stream_set_blocking
    • stream_bucket_append — Zincirin sonuna bir biriktirici ekler
    • stream_bucket_make_writeable — Üzerinde işlem yapmak için zincirden bir biriktirici nesnesi döndürür
    • stream_bucket_new — Geçerli akımda kullanmak için yeni bir biriktirici oluşturur
    • stream_bucket_prepend — Zincirin önüne bir biriktirici ekler
    • stream_context_create — Bir akım bağlamı oluşturur
    • stream_context_get_default — Öntanımlı akım bağlamını döndürür
    • stream_context_get_options — Bir akım/sarmalayıcı/bağlam için atanmış seçenekleri döndürür
    • stream_context_get_params — Bir bağlamın değiştirgelerini döndürür
    • stream_context_set_default — Akımları içeren öntanımlı bağlamı tanımlar
    • stream_context_set_option — Bir akım/sarmalayıcı/bağlam için bir seçenek tanımlar
    • stream_context_set_params — Bir akım/sarmalayıcı/bağlam için değiştirgeleri tanımlar
    • stream_copy_to_stream — Veriyi bir akımdan diğerine kopyalar
    • stream_encoding — Akımı kodlayacak karakter kümesini belirler
    • stream_filter_append — Süzgeç zincirinin sonuna bir süzgeç ekler
    • stream_filter_prepend — Süzgeç zincirinin başına bir süzgeç ekler
    • stream_filter_register — Kullanıcı tanımlı bir akım süzgecini etkin kılar
    • stream_filter_remove — Akımdan bir süzgeci kaldırır
    • stream_get_contents — Akımdan kalanı bir dizgeye okur
    • stream_get_filters — Etkin süzgeçlerin listesini döndürür
    • stream_get_line — Akımdan belirtilen ayraca kadar bir satır döndürür
    • stream_get_meta_data — Akımdan başlıkları/meta verileri döndürür
    • stream_get_transports — Etkin soket aktarımlarının listesini döndürür
    • stream_get_wrappers — Etkin akımların listesini döndürür
    • stream_is_local — Akım, bir yerel akımsa TRUE döner
    • stream_notification_callback — notification bağlam değiştirgesi için bir geri çağırım işlevi
    • stream_register_wrapper — stream_wrapper_register işlevinin takma adıdır
    • stream_resolve_include_path — Bir göreli yol ile yapılacak fopen çağrısıyla açılacak dosyayı belirler
    • stream_select — Belirtilen akım dizisi üzerinde belirtilen zaman aşımı ile select() sistem çağrısının eşdeğeri olarak çalışır
    • stream_set_blocking — Akımın engelleme kipini ayarlar
    • stream_set_chunk_size — Set the stream chunk size
    • stream_set_read_buffer — Set read file buffering on the given stream
    • stream_set_timeout — Akımın zaman aşımı süresini ayarlar
    • stream_set_write_buffer — Dosya tamponunu ayarlar
    • stream_socket_accept — stream_socket_server ile oluşturulmuş bir soketten bağlantı kabul eder
    • stream_socket_client — Bir Genel Ağ veya Unix alan soketi bağlantısı açar
    • stream_socket_enable_crypto — Bağlı bir soket üzerinde şifrelemeyi açıp kapatır
    • stream_socket_get_name — Yerel veya uzak soketin ismini döndürür
    • stream_socket_pair — Soket akımlarınca ayırt edilebilen bir bağlantı çifti oluşturur
    • stream_socket_recvfrom — Bağlı olsun ya da olmasın bir soketten veri alır
    • stream_socket_sendto — Bir sokete bağlı olsun ya da olmasın, bir ileti gönderir
    • stream_socket_server — Bir Genel Ağ veya Unix alan sunucusu soketi oluşturur
    • stream_socket_shutdown — Çift yönlü bağlantıyı kapatır
    • stream_supports_lock — Akımın kilitlemeyi destekleyip desteklemediğine bakar
    • stream_wrapper_register — Bir PHP sınıfı olarak gerçeklenmiş bir URL sarmalayıcısını etkin kılar
    • stream_wrapper_restore — İptal edilmiş yerleşik bir sarmalayıcıyı tekrar etkin kılar
    • stream_wrapper_unregister — Bir URL sarmalayıcısını iptal eder
SplString
Giriş
Diğer Temel Eklentiler


Giriş

Akımlar, ortak bir işlev ve kullanım kümesini paylaşan dosya, ağ, veri sıkıştırması ve bunlarla ilgili diğer işlemleri genelleştirmenin bir yolu olarak PHP 4.3.0 ile devreye girmiştir. En basit tanımıyla, bir akım akışkan bir davranış gösteren bir özkaynak nesnesidir. Yani, akımlar doğrusal anlamda okunup yazılabilir ve akım içindeki keyfi konumlara gitmek (fseek()) mümkün olabilir.

Bir sarmalayıcı, akıma belli bir protokolü veya kodlamayı nasıl ele alacağını söyleyen bir koddur. Örneğin, http sarmalayıcısı bir URL'nin, bir uzak sunucudaki bir dosya için nasıl, bir HTTP/1.0 isteğine dönüştürüleceğini bilir. PHP'de öntanımlı olarak, bir çok yerleşik sarmalayıcı vardır (bak: Supported Protocols and Wrappers). Ayrıca, stream_wrapper_register() işlevi kullanılarak veya Akımlarla Çalışmak bölümündeki programlama arayüzünü kullanarak bir eklenti üzerinden doğrudan doğruya özel sarmalayıcılar eklenebilir. PHP'ye her çeşit sarmalayıcı eklenebileceğinden bunlarla yapılabileceklerin bir sınırı yoktur. Kurulumunuzda desteklenen sarmalayıcıların tam bir listesini edinmek için stream_get_wrappers() işlevini kullanın.

Bir akıma şöyle başvurulur: şema://hedef

  • şema (string) - Kullanılacak sarmalayıcının ismidir. file, http, https, ftp, ftps, compress.zlib, compress.bz2 ve php bu sarmalayıcılardan bazılarıdır. PHP'de yerleşik olarak bulunan sarmalayıcıların listesini Supported Protocols and Wrappers altında bulabilirsiniz. Hiçbir sarmalayıcı belirtilmediği takdirde işlev öntanımlısı (genellikle file://) kullanılır.
  • hedef - Kullanılan sarmalayıcıya bağlıdır. Dosya sistemi ile ilgili sarmalayıcılar için genellikle istenen dosyanın bulunduğu dosya yolu ve dosyanın isminden oluşur. Ağ ile ilgili sarmalayıcılarda ise bir konak ismine eklenen bir dosya yolu kullanılır. Yerleşik sarmalayıcıların hedefleri ile ilgili açıklamalar için Supported Protocols and Wrappers bölümüne bakınız.

Bilginize:

PHP kaynak kodunda akımların kullanımı hakkında bilgi edinmek için PHP Eklenti Yazarları için Akım Arayüzü bölümüne bakınız.

Akımlar
Yapılandırma/Kurulum
Akımlar


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Akım Sınıfları
Giriş
Gereksinimler
Akımlar


Kurulum

Akımlar, 4.3.0 sürümünden itibaren PHP'nin ayrılmaz parçasıdır. Akımları etkinleştirmek için ek bir işlem yapmaya gerek yoktur.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu eklentinin php.ini'de tanımlı yapılandırma yönergesi yoktur.

Kurulum
Akım Sınıfları
Yapılandırma/Kurulum


Akım Sınıfları

Kullanıcı tasarımı sarmalayıcılar, bu kılavuzda bulunan sınıf tanımları kullanılarak stream_wrapper_register() işleviyle tanımlanıbilir.

php_user_filter sınıfı, kullanıcı tanımlı süzgeçlerle kullanmak için öntanımlı ve soyut bir temel sınıftır. Kullanıcı tanımlı süzgeçler ile ilgili daha ayrıntılı bilgi edinmek için stream_filter_register()işlevine bakınız.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

Sabit | Açıklama
STREAM_FILTER_READ * | Belirtilen süzgecin sadece okuma amacıyla kullanılacağını belirtmek için stream_filter_append() ve stream_filter_prepend() işlevi ile kullanılır.
STREAM_FILTER_WRITE * | Belirtilen süzgecin sadece yazma amacıyla kullanılacağını belirtmek için stream_filter_append() ve stream_filter_prepend() işlevi ile kullanılır.
STREAM_FILTER_ALL * | STREAM_FILTER_READ | STREAM_FILTER_WRITE ifadesine eşdeğerdir.
PSFS_PASS_ON * | Kullanıcı tanımlı süzgecin veriyi başarıyla işleyip biriktirici zincirini $out değiştirgesine yerleştirdiğini belirten donüş kodu.
PSFS_FEED_ME * | Kullanıcı tanımlı süzgecin veriyi başarıyla işlediğini fakat döndürülecek veri olmadığını belirten dönüş kodu.
PSFS_ERR_FATAL * | Kullanıcı tanımlı süzgecin kurtarılamayacak bir hata tespit ettiğini ve devam edilemeyeceğini belirten dönüş kodu.
PSFS_FLAG_NORMAL | Normal okuma/yazma işlemi.
PSFS_FLAG_FLUSH_INC | Arttırımlı boşaltım.
PSFS_FLAG_FLUSH_CLOSE | Kapatmadan önce son boşaltım.
STREAM_USE_PATH | Akımın include_path kullanacağını belirten seçenek.
STREAM_REPORT_ERRORS | Akım açılırken, trigger_error() ile hata oluşturmaktan sarmalayıcının sorumlu olduğunu belirten seçenek. Bu seçeneği belirtmedikçe bir hata oluşturamazsınız.
STREAM_CLIENT_ASYNC_CONNECT * | Eşzamansız istemci soketi açar. Bu seçenek stream_socket_client() işlevinde STREAM_CLIENT_CONNECT seçeneği ile birlikte kullanılmalıdır.
STREAM_CLIENT_CONNECT * | İstemci soketi bağlantısı açar. Bu seçenek stream_socket_client() işlevinde kullanılır.
STREAM_CLIENT_PERSISTENT * | stream_socket_client() ile açılmış istemci soketinin sayfa yüklemeleri arasında kalıcı olacağını belirten seçenek.
STREAM_SERVER_BIND * | stream_socket_server() ile oluşturulmuş bir akımın belirtilen hedefe bağlanacağını belirten seçenek. Sunucu soketlerinin bu seçeneği daima içermesi gerekir.
STREAM_SERVER_LISTEN * | stream_socket_server() ile bir akım oluşturulup soket üzerinde dinlemeyi başlatmak için STREAM_SERVER_BIND seçeneğinin kullanılacağını belirten seçenek. Bağlantılı aktarımların (TCP gibi) bu seçeneği kullanması gerekir, yoksa sunucu soketi etkin kılınmaz. Bu seçeneğin bağlantısız aktarımlarla (UDP gibi) kullanımı bir hataya yol açar.
STREAM_NOTIFY_RESOLVE * | Akım için çözümlenecek bir uzak adresin gerektiğini yoksa çözümlemenin başarısız olacağını belirten seçenek. Ayrıca bakınız: stream_notification_callback().
STREAM_NOTIFY_CONNECT | Bir harici özkaynak ile bağlantı kurulduğunu belirtir.
STREAM_NOTIFY_AUTH_REQUIRED | Belirtilen özkaynağa erişim için kimlik doğrulaması gerektiğini belirtir. Genellikle STREAM_NOTIFY_SEVERITY_ERR önem derecesi ile kullanılır. stream_notification_callback() işlevinin önem değiştirgesine bakınız.
STREAM_NOTIFY_MIME_TYPE_IS | Saptanan türün açıklaması için kullanılan ileti'nin ilişkilendirileceği özkaynağın MIME türü.
STREAM_NOTIFY_FILE_SIZE_IS | Saptanan özkaynağın boyutu.
STREAM_NOTIFY_REDIRECTED | Akımı başka bir yere yönlendirecek harici özkaynak. stream_notification_callback() işlevinin ileti değiştirgesine bakınız.
STREAM_NOTIFY_PROGRESS | Geçerli akımın bayt_sayısını aktarmakta olduğunu ve azami_bayt_sayısı'nı da aktarabileceğini belirtir. stream_notification_callback() işlevine bakınız.
STREAM_NOTIFY_COMPLETED * | Akımda artık veri kalmadığını belirtir.
STREAM_NOTIFY_FAILURE | Akımda soysal bir hata oluştuğunu belirtir. Ayrıntılar için stream_notification_callback() işlevinin ileti ve ileti_kodu değiştirgelerine bakınız.
STREAM_NOTIFY_AUTH_RESULT | Kimlik doğrulamasının (başarılı ya da başarısız) tamamlandığını belirtir.
STREAM_NOTIFY_SEVERITY_INFO | Normal, herhangi bir hatayla ilgili olmayan bildirim.
STREAM_NOTIFY_SEVERITY_WARN | Hata önemli değildir. İşleme devam edilebilir.
STREAM_NOTIFY_SEVERITY_ERR | Önemli bir hata oluştu. İşleme devam edilemiyor.
STREAM_IPPROTO_ICMP + | Bir ICMP soketi sağlanır.
STREAM_IPPROTO_IP + | Bir IP soketi sağlanır.
STREAM_IPPROTO_RAW + | Bir ham (RAW) soket sağlanır.
STREAM_IPPROTO_TCP + | Bir TCP soketi sağlanır.
STREAM_IPPROTO_UDP + | Bir UDP soketi sağlanır.
STREAM_PF_INET + | Genel Ağ Protokolünün 4. sürümü (IPv4).
STREAM_PF_INET6 + | Genel Ağ Protokolünün 6. sürümü (IPv6).
STREAM_PF_UNIX + | Unix sisteminin dahili protokolleri.
STREAM_SOCK_DGRAM + | Bağlantısız aktarımlar (UDP gibi) için verikatarları sağlanır.
STREAM_SOCK_RAW + | Dahili ağ protokollerine ve arayüzlerine erişmek için bir ham soket sağlanır. Genellikle bu tür soketleri sadece root kullanıcısı kullanabilir.
STREAM_SOCK_RDM + | Bir RDM (Reliably-delivered messages - Güvenle teslim edilmiş iletiler) soketi sağlanır.
STREAM_SOCK_SEQPACKET + | Sıralı bir paket akımı soketi sağlanır.
STREAM_SOCK_STREAM + | Band dışı veri aktarım mekanizmaları (TCP gibi) ile sıralı, iki yönlü bayt akımları sağlanır.
STREAM_SHUT_RD | İlgili alımları iptal etmek için stream_socket_shutdown() ile kullanılır. PHP 5.2.1'de eklendi.
STREAM_SHUT_WR | İlgili aktarımları iptal etmek için stream_socket_shutdown() ile kullanılır. PHP 5.2.1'de eklendi.
STREAM_SHUT_RDWR | İlgili aktarımları ve alımları iptal etmek için stream_socket_shutdown() ile kullanılır. PHP 5.2.1'de eklendi.
STREAM_CAST_FOR_SELECT | streamWrapper::stream_cast() yöntemini stream_select() çağırdığında cast_as değiştirgesinin değeri.
STREAM_CAST_AS_STREAM | streamWrapper::stream_cast() yöntemini stream_select() dışında işlevler tarafından çağrılırken cast_as değiştirgesinin değeri.

Bilginize: * ile imlenmiş sabitler sadece PHP 5.0.0'dan itibaren kullanılabilir.

Bilginize: + ile imlenmiş sabitler sadece PHP 5.1.0'dan itibaren stream_socket_pair() ile kullanılabilir. Bu sabitlerin bazılarının sisteminizde kullanılamayabileceğini lütfen aklınızdan çıkarmayın.

Akım Sınıfları
Akım Süzgeçleri
Akımlar


Akım Süzgeçleri

Bir süzgeç, bir akımdan veri okurken veya veri yazarken veri üzerinde son işlemleri uygulayan bir kod parçasıdır. Bir akıma birden fazla süzgeç uygulanabilir. Bir PHP betiğinde özel süzgeçler stream_filter_register() işleviyle veya Akımlarla Çalışmak bölümündeki programlama arayüzünü kullanarak bir eklenti olarak tanımlanabilir. Kullanılabilir süzgeçlerin tam listesini stream_get_filters() işleviyle alabilirsiniz.

Öntanımlı Sabitler
Akım Bağlamları
Akımlar


Akım Bağlamları

Bir bağlam, bir akımın davranışlarını geliştirmek ve değiştirmek için kullanılan bir değiştirgeler ve sarmalayıcıya özgü seçenekler kümesidir. Bağlamlar, stream_context_create() işlevi kullanılarak oluşturulabilir ve dosya sistemiyle ilgili pek çok akım oluşturma işlevine (fopen(), file(), file_get_contents() gibi) aktarılabilir.

Seçenekler, stream_context_create() işlevi çağrılırken veya sonradan stream_context_set_option() işlevi ile oluşturulabilir. Sarmalayıcıya özgü seçeneklerin listesini Bağlam seçenekleri ve değiştirgeleri bölümünde bulabilirsiniz.

Değiştirgeler, stream_context_set_params() işlevi kullanılarak bağlamlar için belirtilebilir.

Akım Süzgeçleri
Akım Hataları
Akımlar


Akım Hataları

Bir dosya veya soketle ilgili bir işlevle olduğu gibi, bir akım üzerindeki bir işlem de çok çeşitli sebeplerle başarısız olabilir (Uzak bir konağa bağlanılamayabilir, bir dosya bulunamayabilir, vb.). Akımla ilgili bir çağrı, istenen akım çalışan sistem tarafından tanınmadığından da başarısız olabilir. PHP kurulumunuzda kullanılabilecek sarmalayıcıların listesini bir dizi olarak stream_get_wrappers() işlevini kullanarak alabilirsiniz. PHP'nin çoğu yerleşik işlevinde olduğu gibi bir başarısızlık halinde hatanın doğasını açıklayan bir E_WARNING iletisi üretilir.

Akım Bağlamları
Örnekler
Akımlar


Örnekler

İçindekiler

  • Akım Sarmalayıcı olarak örnek bir sınıf tanımı

Örnek 1 - Çok sayıda kaynaktan veri almak için file_get_contents() kullanımı

<?php
/* Yerel dosyayı /home/bar dizininden okuyalım */
$localfile = file_get_contents("/home/bar/foo.txt");

/* FILE sarmalayıcı kullanımı dışında yukarıdakine eşdeğerdir */
$localfile = file_get_contents("file:///home/bar/foo.txt");

/* Uzak dosyayı HTTP kullaranak www.example.com'dan okur */
$httpfile  = file_get_contents("http://www.example.com/foo.txt");

/* Uzak dosyayı HTTPS kullaranak www.example.com'dan okur */
$httpsfile = file_get_contents("https://www.example.com/foo.txt");

/* Uzak dosyayı FTP kullaranak ftp.example.com'dan okur */
$ftpfile   = file_get_contents("ftp://user:pass@ftp.example.com/foo.txt");

/* Uzak dosyayı FTPS kullaranak ftp.example.com'dan okur */
$ftpsfile  = file_get_contents("ftps://user:pass@ftp.example.com/foo.txt");
?>

Örnek 2 - Bir HTTPS sunucusundan bir POST isteği yapmak

<?php
/* Post isteğini https://secure.example.com/form_action.php adresine gönderelim
 * Dosyada "foo" and "bar" isimli form elemanları olsun.
 */

$sock = fsockopen("ssl://secure.example.com", 443, $errno, $errstr, 30);
if (!$sock) die("$errstr ($errno)\n");

$data = "foo=" . urlencode("Value for Foo") . "&bar=" . urlencode("Value for Bar");

fwrite($sock, "POST /form_action.php HTTP/1.0\r\n");
fwrite($sock, "Host: secure.example.com\r\n");
fwrite($sock, "Content-type: application/x-www-form-urlencoded\r\n");
fwrite($sock, "Content-length: " . strlen($data) . "\r\n");
fwrite($sock, "Accept: */*\r\n");
fwrite($sock, "\r\n");
fwrite($sock, "$data\r\n");
fwrite($sock, "\r\n");

$headers = "";
while ($str = trim(fgets($sock, 4096)))
$headers .= "$str\n";

echo "\n";

$body = "";
while (!feof($sock))
$body .= fgets($sock, 4096);

fclose($sock);
?>

Örnek 3 - Sıkıştırılmış bir dosyaya veri yazmak

<?php
/* Bir dizge içeren sıkıştırılmış bir dosya oluşturalım.
 * Dosya, compress.zlib akımı kullanılarak veya
 * komut satırından 'gzip -d foo-bar.txt.gz' kullanılarak
 * kodlaması açılıp okunabilir.
 */
$fp = fopen("compress.zlib://foo-bar.txt.gz", "wb");
if (!$fp) die("Dosya oluşturulamadı.");

fwrite($fp, "Bu bir denemedir.\n");

fclose($fp);
?>

Akım Hataları
Akım Sarmalayıcı olarak örnek bir sınıf tanımı
Akımlar


Akım Sarmalayıcı olarak örnek bir sınıf tanımı

Aşağıdaki örnekte, fread() gibi standart dosya sistemi akım işlevlerini kullanarak bir küresel değişkene okuma/yazma erişimini mümkün kılan bir var:// sarmalayıcısı gerçeklenmiştir. $GLOBALS["foo"] değişkenine veri yazma ve okuma işlemleri için "var://foo" URL'si kullanılacaktır.

Örnek 1 - Küresel değişkenlere veri okuyup yazan bir akım

<?php

class VariableStream {
  var $position;
  var $varname;

  function stream_open($path, $mode, $options, &$opened_path)
  {
    $url = parse_url($path);
    $this->varname = $url["host"];
    $this->position = 0;

    return true;
  }

  function stream_read($count)
  {
    $ret = substr($GLOBALS[$this->varname], $this->position, $count);
    $this->position += strlen($ret);
    return $ret;
  }

  function stream_write($data)
  {
    $left = substr($GLOBALS[$this->varname], 0, $this->position);
    $right = substr($GLOBALS[$this->varname], $this->position + strlen($data));
    $GLOBALS[$this->varname] = $left . $data . $right;
    $this->position += strlen($data);
    return strlen($data);
  }

  function stream_tell()
  {
    return $this->position;
  }

  function stream_eof()
  {
    return $this->position >= strlen($GLOBALS[$this->varname]);
  }

  function stream_seek($offset, $whence)
  {
    switch ($whence) {
      case SEEK_SET:
        if ($offset < strlen($GLOBALS[$this->varname]) && $offset >= 0) {
          $this->position = $offset;
          return true;
        } else {
          return false;
        }
        break;

      case SEEK_CUR:
        if ($offset >= 0) {
          $this->position += $offset;
          return true;
        } else {
          return false;
        }
        break;

      case SEEK_END:
        if (strlen($GLOBALS[$this->varname]) + $offset >= 0) {
          $this->position = strlen($GLOBALS[$this->varname]) + $offset;
          return true;
        } else {
          return false;
        }
        break;

      default:
        return false;
    }
  }
}

stream_wrapper_register("var", "VariableStream")
    or die("Failed to register protocol");

$myvar = "";

$fp = fopen("var://myvar", "r+");

fwrite($fp, "line1\n");
fwrite($fp, "line2\n");
fwrite($fp, "line3\n");

rewind($fp);
while (!feof($fp)) {
    echo fgets($fp);
}
fclose($fp);
var_dump($myvar);

?>

Yukarıdaki örneğin çıktısı:

line1
line2
line3
string(18) "line1
line2
line3
"

Örnekler
streamWrapper
Örnekler


streamWrapper sınıfı

streamWrapper

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

Diğer dosya sistemi işlevleriyle (fopen(), fread() gibi) kullanmak için kendi sarmalayıcılarınızı gerçeklemenizi sağlar.

Bilginize:

Bu, gerçek bir sınıf değildir, kendi protokolünüzü tanımlayabilmeniz için türünün bir örneğidir.

Bilginize:

Yöntemlerin burada açıklanan yollar dışında yollarla gerçeklenmesi istenmeyen davranışlara yol açabilir.

Bu protokol ile ilişkili bir akım işlevi bu protokole erişmek istediği anda bu sınıfın bir örneği oluşturulur.

Sınıf Sözdizimi

streamWrapper {
/* Özellikler */
public resource $context ;
/* Yöntemler */
__construct ( void )
__destruct ( void )
public bool dir_closedir ( void )
public bool dir_opendir ( string $url , int $seçenekler )
public string dir_readdir ( void )
public bool dir_rewinddir ( void )
public bool mkdir ( string $url , int $kip , int $seçenekler )
public bool rename ( string $eskisi , string $yenisi )
public bool rmdir ( string $url , int $seçenekler )
public resource stream_cast ( int $cast_as )
public void stream_close ( void )
public bool stream_eof ( void )
public bool stream_flush ( void )
public bool stream_lock ( mode $işlem )
public bool stream_metadata ( string $path , int $option , mixed $value )
public bool stream_open ( string $url , string $kip , int $seçenekler , string &$açık_yol )
public string stream_read ( int $sayı )
public bool stream_seek ( int $başlangıç , int $nereden = SEEK_SET )
public bool stream_set_option ( int $seçenek , int $arg1 , int $arg2 )
public array stream_stat ( void )
public int stream_tell ( void )
public bool stream_truncate ( int $new_size )
public int stream_write ( string $veri )
public bool unlink ( string $dosya )
public array url_stat ( string $dosya , int $seçenekler )
}

Özellikler

resource context

Çağrıcı işleve hiçbir bağlam aktarılmamışsa NULL, aksi takdirde geçerli bağlam.

Bağlamı çözümlemek için stream_context_get_options() işlevini kullanın.

Bilginize:

Bu özellik public olmalıdır, böylece PHP özelliği asıl bağlam özkaynağından oluşturabilir.

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.0 | context özelliği eklendi.

Ayrıca Bakınız

  • Akım Sarmalayıcı olarak örnek bir sınıf tanımı
  • stream_wrapper_register()
  • stream_wrapper_unregister()
  • stream_wrapper_restore()

İçindekiler

  • streamWrapper::__construct — Yeni bir akım sarmalayıcı oluşturur
  • streamWrapper::__destruct — Destructs an existing stream wrapper
  • streamWrapper::dir_closedir — Dizin tanıtıcısını kapatır
  • streamWrapper::dir_opendir — Dizin tanıtıcısı açar
  • streamWrapper::dir_readdir — Dizinden bir girdi okur
  • streamWrapper::dir_rewinddir — Dizin tanıtıcısını dizin başlangıcına konumlar
  • streamWrapper::mkdir — Bir dizin oluşturur
  • streamWrapper::rename — Bir dosya veya dizinin ismini değiştirir
  • streamWrapper::rmdir — Bir dizini siler
  • streamWrapper::stream_cast — Temel özkaynağı döndürür
  • streamWrapper::stream_close — Bir özkaynağı kapatır
  • streamWrapper::stream_eof — Dosya göstericisinin dosya sonunda olup olmadığına bakar
  • streamWrapper::stream_flush — Çıktıyı boşaltır
  • streamWrapper::stream_lock — Tavsiye niteliğinde dosya kilitleme
  • streamWrapper::stream_metadata — Change stream metadata
  • streamWrapper::stream_open — Bir dosya veya URL açar
  • streamWrapper::stream_read — Akımdan veri okur
  • streamWrapper::stream_seek — Akım üzerinde belli bir konuma gidilir
  • streamWrapper::stream_set_option — Akım seçeneklerini değiştirir
  • streamWrapper::stream_stat — Bir dosya özkaynağı hakkında bilgi döndürür
  • streamWrapper::stream_tell — Bir akımdan geçerli konumu döndürür
  • streamWrapper::stream_truncate — Truncate stream
  • streamWrapper::stream_write — Akıma yazar
  • streamWrapper::unlink — Bir dosyayı siler
  • streamWrapper::url_stat — Bir dosya hakkında bilgi döndürür
Akım Sarmalayıcı olarak örnek bir sınıf tanımı
streamWrapper::__construct
Akımlar


Yeni bir akım sarmalayıcı oluşturur

streamWrapper
streamWrapper::__destruct
streamWrapper
PHP Manual

streamWrapper::__construct

(PHP 4 >= 4.3.2, PHP 5, PHP 7)

streamWrapper::__construct — Yeni bir akım sarmalayıcı oluşturur

Açıklama

streamWrapper::__construct ( void )

Akım sarmalayıcı açılırken streamWrapper::stream_open() yönteminden önce çağrılır.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

streamWrapper
streamWrapper::__destruct
streamWrapper


Destructs an existing stream wrapper

streamWrapper::__construct
streamWrapper::dir_closedir
streamWrapper
PHP Manual

streamWrapper::__destruct

(PHP 4 >= 4.3.2, PHP 5, PHP 7)

streamWrapper::__destruct — Destructs an existing stream wrapper

Açıklama

streamWrapper::__destruct ( void )

Called when closing the stream wrapper, right before streamWrapper::stream_flush().

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

streamWrapper::__construct
streamWrapper::dir_closedir
streamWrapper


Dizin tanıtıcısını kapatır

streamWrapper::__destruct
streamWrapper::dir_opendir
streamWrapper
PHP Manual

streamWrapper::dir_closedir

(PHP 4 >= 4.3.2, PHP 5, PHP 7)

streamWrapper::dir_closedir — Dizin tanıtıcısını kapatır

Açıklama

public bool streamWrapper::dir_closedir ( void )

Bu yöntem closedir() işlevine yanıtta çağrılır.

Dizin akımının açılışı ve kullanımı sırasında ayrılmış veya kilitlenmiş bütün özkaynaklar serbest bırakılmalıdır.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • closedir() - Dizin tanıtıcısını kapatır
  • streamWrapper::dir_opendir() - Dizin tanıtıcısı açar

streamWrapper::__destruct
streamWrapper::dir_opendir
streamWrapper


Dizin tanıtıcısı açar

streamWrapper::dir_closedir
streamWrapper::dir_readdir
streamWrapper
PHP Manual

streamWrapper::dir_opendir

(PHP 4 >= 4.3.2, PHP 5, PHP 7)

streamWrapper::dir_opendir — Dizin tanıtıcısı açar

Açıklama

public bool streamWrapper::dir_opendir ( string $url , int $seçenekler )

Bu yöntem opendir() işlevine yanıtta çağrılır.

Değiştirgeler

url

opendir() işlevine aktarılacak URL.

Bilginize:

URL parse_url() ile parçalarına ayrılmış olabilir.

seçenekler

safe_mode'un etkin olup olmadığı (0x04).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • opendir() - Belirtilen dizin için bir tanıtıcı döndürür
  • streamWrapper::dir_closedir() - Dizin tanıtıcısını kapatır
  • parse_url() - Bir URL'yi bileşenlerine ayırır

streamWrapper::dir_closedir
streamWrapper::dir_readdir
streamWrapper


Dizinden bir girdi okur

streamWrapper::dir_opendir
streamWrapper::dir_rewinddir
streamWrapper
PHP Manual

streamWrapper::dir_readdir

(PHP 4 >= 4.3.2, PHP 5, PHP 7)

streamWrapper::dir_readdir — Dizinden bir girdi okur

Açıklama

public string streamWrapper::dir_readdir ( void )

Bu yöntem readdir() işlevine yanıtta çağrılır.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Varsa sonraki dosya ismini, yoksa FALSE döndürmelidir.

Bilginize:

Dönen değer string türüne dönüştürülür.

Hatalar/İstisnalar

Bu yöntem çağrısı başarısız olursa (gerçeklenmeme sorunu gibi) bir E_WARNING iletisi çıktılar.

Örnekler

Örnek 1 - Tar arşivindeki dosyaları listelemek

<?php
class streamWrapper {
    protected $fp;

    public function dir_opendir($path, $options) {
        $url = parse_url($path);

        $path = $url["host"] . $url["path"];

        if (!is_readable($path)) {
            trigger_error("$path okunamıyor", E_USER_NOTICE);
            return false;
        }
        if (!is_file($path)) {
            trigger_error("$path bir dosya değil", E_USER_NOTICE);
            return false;
        }

        $this->fp = fopen($path, "rb");
        return true;
    }

    public function dir_readdir() {
        // Bu girdi için başlığı çıkart
        $header = fread($this->fp, 512);
        $data = unpack("a100filename/a8mode/a8uid/a8gid/a12size/a12mtime",
                       $header);

        // Dosya ismini ve dosya boyunu kırpalım
        $filename    = trim($data["filename"]);

        // Dosya yık mu? Arşivin sonunda mıyız?
        if (!$filename) {
            return false;
        }

        $octal_bytes = trim($data["size"]);
        // Dosya boyu sekiz tabanında tanımlı
        $bytes = octdec($octal_bytes);

        // tar dosya boylarını 512 baytın katlarına
        // yuvarlar (sıfırlarla doldurur)
        $rest = $bytes % 512;
        if ($rest > 0) {
            $bytes += 512 - $rest;
        }

        // Dosya üzerinde ilerleyelim
        fseek($this->fp, $bytes, SEEK_CUR);

        return $filename;
    }

    public function dir_closedir() {
        return fclose($this->fp);
    }

    public function dir_rewinddir() {
        return fseek($this->fp, 0, SEEK_SET);
    }
}

stream_wrapper_register("tar", "streamWrapper");
$handle = opendir("tar://example.tar");
while (false !== ($file = readdir($handle))) {
    var_dump($file);
}

echo "Al baştan..\n";
rewind($handle);
var_dump(readdir($handle));

closedir($handle);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(13) "construct.xml"
string(16) "dir-closedir.xml"
string(15) "dir-opendir.xml"
string(15) "dir-readdir.xml"
string(17) "dir-rewinddir.xml"
string(9) "mkdir.xml"
string(10) "rename.xml"
string(9) "rmdir.xml"
string(15) "stream-cast.xml"
string(16) "stream-close.xml"
string(14) "stream-eof.xml"
string(16) "stream-flush.xml"
string(15) "stream-lock.xml"
string(15) "stream-open.xml"
string(15) "stream-read.xml"
string(15) "stream-seek.xml"
string(21) "stream-set-option.xml"
string(15) "stream-stat.xml"
string(15) "stream-tell.xml"
string(16) "stream-write.xml"
string(10) "unlink.xml"
string(12) "url-stat.xml"
Al baştan..
string(13) "construct.xml"

Ayrıca Bakınız

  • readdir() - Dizinden bir girdinin ismini okur

streamWrapper::dir_opendir
streamWrapper::dir_rewinddir
streamWrapper


Dizin tanıtıcısını dizin başlangıcına konumlar

streamWrapper::dir_readdir
streamWrapper::mkdir
streamWrapper
PHP Manual

streamWrapper::dir_rewinddir

(PHP 4 >= 4.3.2, PHP 5, PHP 7)

streamWrapper::dir_rewinddir — Dizin tanıtıcısını dizin başlangıcına konumlar

Açıklama

public bool streamWrapper::dir_rewinddir ( void )

Bu yöntem rewinddir() işlevine yanıtta çağrılır.

streamWrapper::dir_readdir() tarafından üretilen çıktı sıfırlanmalıdır. Yani, streamWrapper::dir_readdir() yöntemine yapılan sonraki çağrı streamWrapper::dir_opendir() tarafından döndürülen konumdaki ilk girdiyi döndürmelidir.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • rewinddir() - Dizin tanıtıcısını dizin başlangıcına konumlar
  • streamWrapper::dir_readdir() - Dizinden bir girdi okur

streamWrapper::dir_readdir
streamWrapper::mkdir
streamWrapper


Bir dizin oluşturur

streamWrapper::dir_rewinddir
streamWrapper::rename
streamWrapper
PHP Manual

streamWrapper::mkdir

(PHP 5, PHP 7)

streamWrapper::mkdir — Bir dizin oluşturur

Açıklama

public bool streamWrapper::mkdir ( string $url , int $kip , int $seçenekler )

Bu yöntem mkdir() işlevine yanıtta çağrılır.

Bilginize:

Sarmalayıcı dizin oluşturmayı desteklemiyorsa uygun bir hata iletisi döndürmek adına bu yöntem tanımlanmamalıdır.

Değiştirgeler

url

Oluşturulacak dizin.

kip

mkdir() işlevine aktarılacak değer.

seçenekler

STREAM_MKDIR_RECURSIVE gibi değerlerden oluşan bir bit maskesi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

Bu yöntem çağrısı başarısız olursa (gerçeklenmeme sorunu gibi) bir E_WARNING iletisi çıktılar.

Notlar

Bilginize:

streamWrapper::$context özelliği, çağıran işleve geçerli bir bağlam aktarılırsa güncellenir.

Ayrıca Bakınız

  • mkdir() - Dizin oluşturur
  • streamwrapper::rmdir() - Bir dizini siler

streamWrapper::dir_rewinddir
streamWrapper::rename
streamWrapper


Bir dosya veya dizinin ismini değiştirir

streamWrapper::mkdir
streamWrapper::rmdir
streamWrapper
PHP Manual

streamWrapper::rename

(PHP 5, PHP 7)

streamWrapper::rename — Bir dosya veya dizinin ismini değiştirir

Açıklama

public bool streamWrapper::rename ( string $eskisi , string $yenisi )

Bu yöntem rename() işlevine yanıtta çağrılır.

Dosya veya dizin isminin eskisini yenisi ile değiştirmeye çalışmalıdır.

Bilginize:

Sarmalayıcı dizin oluşturmayı desteklemiyorsa uygun bir hata iletisi döndürmek adına bu yöntem tanımlanmamalıdır.

Değiştirgeler

eskisi

Mevcut dosyanın URL'si.

yenisi

Dosyanın yeni URL'si.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

Bu yöntem çağrısı başarısız olursa (gerçeklenmeme sorunu gibi) bir E_WARNING iletisi çıktılar.

Notlar

Bilginize:

streamWrapper::$context özelliği, çağıran işleve geçerli bir bağlam aktarılırsa güncellenir.

Ayrıca Bakınız

  • rename() - Bir dosya veya dizinin ismini değiştirir

streamWrapper::mkdir
streamWrapper::rmdir
streamWrapper


Bir dizini siler

streamWrapper::rename
streamWrapper::stream_cast
streamWrapper
PHP Manual

streamWrapper::rmdir

(PHP 5, PHP 7)

streamWrapper::rmdir — Bir dizini siler

Açıklama

public bool streamWrapper::rmdir ( string $url , int $seçenekler )

Bu yöntem rmdir() işlevine yanıtta çağrılır.

Bilginize:

Sarmalayıcı dizin oluşturmayı desteklemiyorsa uygun bir hata iletisi döndürmek adına bu yöntem tanımlanmamalıdır.

Değiştirgeler

url

Silinecek dizinin URL'si.

seçenekler

STREAM_MKDIR_RECURSIVE gibi değerlerin bit maskesi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

Bu yöntem çağrısı başarısız olursa (gerçeklenmeme sorunu gibi) bir E_WARNING iletisi çıktılar.

Notlar

Bilginize:

streamWrapper::$context özelliği, çağıran işleve geçerli bir bağlam aktarılırsa güncellenir.

Ayrıca Bakınız

  • rmdir() - Dizin siler
  • streamwrapper::mkdir() - Bir dizin oluşturur
  • streamwrapper::unlink() - Bir dosyayı siler

streamWrapper::rename
streamWrapper::stream_cast
streamWrapper


Temel özkaynağı döndürür

streamWrapper::rmdir
streamWrapper::stream_close
streamWrapper
PHP Manual

streamWrapper::stream_cast

(PHP 5 >= 5.3.0, PHP 7)

streamWrapper::stream_cast — Temel özkaynağı döndürür

Açıklama

public resource streamWrapper::stream_cast ( int $cast_as )

Bu yöntem stream_select() işlevine yanıtta çağrılır.

Değiştirgeler

cast_as

stream_cast()'ı stream_select() çağırıyorsa STREAM_CAST_FOR_SELECT veya stream_cast() başka kullanımlar için çağrılıyorsa STREAM_CAST_AS_STREAM olabilir.

Dönen Değerler

Ya sarmalayıcı tarafından kullanılan temel akım özkaynağı ya da FALSE dönmelidir.

Ayrıca Bakınız

  • stream_select() - Belirtilen akım dizisi üzerinde belirtilen zaman aşımı ile select() sistem çağrısının eşdeğeri olarak çalışır

streamWrapper::rmdir
streamWrapper::stream_close
streamWrapper


Bir özkaynağı kapatır

streamWrapper::stream_cast
streamWrapper::stream_eof
streamWrapper
PHP Manual

streamWrapper::stream_close

(PHP 4 >= 4.3.2, PHP 5, PHP 7)

streamWrapper::stream_close — Bir özkaynağı kapatır

Açıklama

public void streamWrapper::stream_close ( void )

Bu yöntem, fclose() işlevine yanıtta çağrılır.

Sarmalayıcı tarafından ayrılmış veya kilitlenmiş tüm özkaynaklar serbest bırakılmalıdır.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • fclose() - Açık bir dosya tanıtıcısını kapatır
  • streamWrapper::dir_closedir() - Dizin tanıtıcısını kapatır

streamWrapper::stream_cast
streamWrapper::stream_eof
streamWrapper


Dosya göstericisinin dosya sonunda olup olmadığına bakar

streamWrapper::stream_close
streamWrapper::stream_flush
streamWrapper
PHP Manual

streamWrapper::stream_eof

(PHP 4 >= 4.3.2, PHP 5, PHP 7)

streamWrapper::stream_eof — Dosya göstericisinin dosya sonunda olup olmadığına bakar

Açıklama

public bool streamWrapper::stream_eof ( void )

Bu yöntem, feof() işlevine yanıtta çağrılır.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Oku/yaz konumu akımın sonundaysa ve okunacak başka veri kalmamışsa TRUE yoksa FALSE dönmelidir.

Ayrıca Bakınız

  • feof() - Bir dosya tanıtıcısı üzerinde konum dosya sonunda mı diye bakar

streamWrapper::stream_close
streamWrapper::stream_flush
streamWrapper


Çıktıyı boşaltır

streamWrapper::stream_eof
streamWrapper::stream_lock
streamWrapper
PHP Manual

streamWrapper::stream_flush

(PHP 4 >= 4.3.2, PHP 5, PHP 7)

streamWrapper::stream_flush — Çıktıyı boşaltır

Açıklama

public bool streamWrapper::stream_flush ( void )

Bu yöntem fflush() işlevine yanıtta çağrılır.

Akımınızda veri önbellekliyse ve henüz bir saklama alanına yerleştirmediyseniz bunu yapmanın tam sırasıdır.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Önbellekli veri başarıyla bir saklama alanına aktarılmışsa veya saklanacak bir veri yoksa TRUE dönmesi gerekir. Veri saklanamamışsa FALSE dönmelidir.

Notlar

Bilginize:

Yöntem gerçeklenmemişse FALSE döndüğü varsayılır.

Ayrıca Bakınız

  • fflush() - Çıktıyı bir dosyaya boşaltır

streamWrapper::stream_eof
streamWrapper::stream_lock
streamWrapper


Tavsiye niteliğinde dosya kilitleme

streamWrapper::stream_flush
streamWrapper::stream_metadata
streamWrapper
PHP Manual

streamWrapper::stream_lock

(PHP 5, PHP 7)

streamWrapper::stream_lock — Tavsiye niteliğinde dosya kilitleme

Açıklama

public bool streamWrapper::stream_lock ( mode $işlem )

Bu yöntem, akım kapatılırken (LOCK_UN) flock(), file_put_contents() (seçenekler LOCK_EX içeriyorsa) ve stream_set_blocking() işlevine yanıtta çağrılır

Değiştirgeler

işlem

işlem şunlardan biri olabilir:

  • Paylaşımlı bir kilit (okuyucu) edinmek için LOCK_SH.
  • Ayrıcalıklı bir kilit (yazıcı) edinmek için LOCK_EX
  • Bir kilidi (paylaşımlı ya da ayrıcalıklı) serbest bırakmak için LOCK_UN.
  • Kilitlerken flock() engellenmesin isterseniz LOCK_NB (Windows'ta desteklenmez).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

Bu yöntem başarısız olursa (örneğin, gerçeklenmemişse) bir E_WARNING çıktılanır.

Ayrıca Bakınız

  • stream_set_blocking() - Akımın engelleme kipini ayarlar
  • flock() - Taşınabilir tavsiye niteliğinde dosya kilitleme

streamWrapper::stream_flush
streamWrapper::stream_metadata
streamWrapper


Change stream metadata

streamWrapper::stream_lock
streamWrapper::stream_open
streamWrapper
PHP Manual

streamWrapper::stream_metadata

(PHP 5 >= 5.4.0, PHP 7)

streamWrapper::stream_metadata — Change stream metadata

Açıklama

public bool streamWrapper::stream_metadata ( string $path , int $option , mixed $value )

This method is called to set metadata on the stream. It is called when one of the following functions is called on a stream URL:

  • touch()
  • chmod()
  • chown()
  • chgrp()
Please note that some of these operations may not be available on your system.

Değiştirgeler

path

The file path or URL to set metadata. Note that in the case of a URL, it must be a :// delimited URL. Other URL forms are not supported.

option

One of:

  • STREAM_META_TOUCH (The method was called in response to touch())
  • STREAM_META_OWNER_NAME (The method was called in response to chown() with string parameter)
  • STREAM_META_OWNER (The method was called in response to chown())
  • STREAM_META_GROUP_NAME (The method was called in response to chgrp())
  • STREAM_META_GROUP (The method was called in response to chgrp())
  • STREAM_META_ACCESS (The method was called in response to chmod())

value

If option is

  • STREAM_META_TOUCH: Array consisting of two arguments of the touch() function.
  • STREAM_META_OWNER_NAME or STREAM_META_GROUP_NAME: The name of the owner user/group as string.
  • STREAM_META_OWNER or STREAM_META_GROUP: The value owner user/group argument as integer.
  • STREAM_META_ACCESS: The argument of the chmod() as integer.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. If option is not implemented, FALSE should be returned.

Ayrıca Bakınız

  • touch() - Dosyanın erişim ve değişiklik zamanını ayarlar
  • chmod() - Dosya kipini değiştirir
  • chown() - Dosyanın sahibini değiştirir
  • chgrp() - Dosya grubunu değiştirir

streamWrapper::stream_lock
streamWrapper::stream_open
streamWrapper


Bir dosya veya URL açar

streamWrapper::stream_metadata
streamWrapper::stream_read
streamWrapper
PHP Manual

streamWrapper::stream_open

(PHP 4 >= 4.3.2, PHP 5, PHP 7)

streamWrapper::stream_open — Bir dosya veya URL açar

Açıklama

public bool streamWrapper::stream_open ( string $url , string $kip , int $seçenekler , string &$açık_yol )

Bu yöntem sarmalayıcı ilklendirilirdikten hemen sonra çağrılır (örneğin, fopen() ve file_get_contents() tarafından).

Değiştirgeler

url

Özgün işleve aktarılacak URL belirtilir.

Bilginize:

URL, parse_url() ile parçalarına ayrılmış olabilir. Sadece :// ile ayrılmış URL'ler destenlenmektedir. : ve :/ teknik olarak URL'ler için geçerli olmakla birlikte bunlar desteklenmemektedir.

kip

Dosyayı açma amacını belirten kip; ayrıntılar için fopen() işlevine bakınız.

Bilginize:

Belirtilen kip'in url için geçerli olup olmadığına bakmayı unutmayın.

seçenekler

Akım arayüzü tarafından atanmış ek seçenekler aşağıdaki değerlerin birleşiminden oluşan bir bit maskesi olarak belirtilir:

Seçenek | Açıklama
STREAM_USE_PATH | url göreli ise özkaynak include_path kullanılarak aranır.
STREAM_REPORT_ERRORS | Bu seçenek belirtilmişse akımın açılışı sırasında trigger_error() kullanarak hatayı raporlamak sizin sorumluluğunuzdadır. Belirtilmemişse herhangi bir hata oluşturamazsınız.

açık_yol

seçenekler değiştirgesine STREAM_USE_PATH atanmış ve url başarıyla açılmışsa açık_yol değiştirgesine açılan dosya veya özkaynağın tam yolunun yerleştirilmesi gerekir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

Bu yöntem çağrısı başarısız olursa (gerçeklenmeme sorunu gibi) bir E_WARNING iletisi çıktılar.

Notlar

Bilginize:

streamWrapper::$context özelliği, çağıran işleve geçerli bir bağlam aktarılırsa güncellenir.

Ayrıca Bakınız

  • fopen() - Bir dosya veya URL'yi açar
  • parse_url() - Bir URL'yi bileşenlerine ayırır

streamWrapper::stream_metadata
streamWrapper::stream_read
streamWrapper


Akımdan veri okur

streamWrapper::stream_open
streamWrapper::stream_seek
streamWrapper
PHP Manual

streamWrapper::stream_read

(PHP 4 >= 4.3.2, PHP 5, PHP 7)

streamWrapper::stream_read — Akımdan veri okur

Açıklama

public string streamWrapper::stream_read ( int $sayı )

Bu yöntem fread() ve fgets() işlevine yanıtta çağrılır.

Bilginize:

Başarıyla okunan bayt sayısına göre akımdaki konumlayıcıyı güncellemeyi unutmayın.

Değiştirgeler

sayı

Geçerli konumdan okunacak bayt sayısı.

Dönen Değerler

Akımda sayı bayttan daha az bayt varsa, olan döndürülür. Hiç veri yoksa ya FALSE ya da boş bir dizge dönmelidir.

Hatalar/İstisnalar

Bu yöntem çağrısı başarısız olursa (gerçeklenmeme sorunu gibi) bir E_WARNING iletisi çıktılar.

Bilginize:

Dönen değer sayı bayttan daha uzunsa bir E_WARNING çıktılanır ve fazlalık veri kaybedilir.

Notlar

Bilginize:

Dosya sonuna ulaşılıp ulaşılmadığını görmek için streamWrapper::stream_read() çağrısının hemen ardından streamWrapper::stream_eof() çağrılır. Yöntem gerçeklenmemişse dosya sonuna ulaşıldığı varsayılır.

Ayrıca Bakınız

  • fread() - Dosyayı ikil kipte okur
  • fgets() - Dosya tanıtıcısından bir satır döndürür

streamWrapper::stream_open
streamWrapper::stream_seek
streamWrapper


Akım üzerinde belli bir konuma gidilir

streamWrapper::stream_read
streamWrapper::stream_set_option
streamWrapper
PHP Manual

streamWrapper::stream_seek

(PHP 4 >= 4.3.2, PHP 5, PHP 7)

streamWrapper::stream_seek — Akım üzerinde belli bir konuma gidilir

Açıklama

public bool streamWrapper::stream_seek ( int $başlangıç , int $nereden = SEEK_SET )

Bu yöntem fseek() işlevine yanıtta çağrılır.

Akımın oku/yaz konumu başlangıç ve nereden değiştirgelerine göre güncellenmelidir.

Değiştirgeler

başlangıç

Gidilecek akım başlangıcı.

nereden

Olası değerler:

  • SEEK_SET - Konum, başlangıç'ıncı bayta ayarlanır.
  • SEEK_CUR - Konum başlangıç artı mevcut konum olarak ayarlanır.
  • SEEK_END - Konum başlangıç artı dosyasonu olarak ayarlanır.

Dönen Değerler

Konuma gidilebilmişse TRUE yoksa FALSE dönmelidir.

Notlar

Bilginize:

Gerçeklenmemişse dönüş değerinin FALSE olduğu varsayılır.

Bilginize:

Başarı durumunda,
streamWrapper::stream_tell() yöntemi, doğrudan
streamWrapper::stream_seek() yönteminden sonra
çağrılır. Eğer streamWrapper::stream_tell()
başarısız olursa çağrıcı işlevin dönüş değeri FALSE olur.

Ayrıca Bakınız

  • fseek() - Dosya tanıtıcısında konumu bir yerden başka bir yere taşır

streamWrapper::stream_read
streamWrapper::stream_set_option
streamWrapper


Akım seçeneklerini değiştirir

streamWrapper::stream_seek
streamWrapper::stream_stat
streamWrapper
PHP Manual

streamWrapper::stream_set_option

(PHP 5 >= 5.3.0, PHP 7)

streamWrapper::stream_set_option — Akım seçeneklerini değiştirir

Açıklama

public bool streamWrapper::stream_set_option ( int $seçenek , int $arg1 , int $arg2 )

Bu yöntem akıma seçenek atamak için çağrılır.

Değiştirgeler

seçenek

Şunlardan biri olmalıdır:

  • STREAM_OPTION_BLOCKING (Yöntem stream_set_blocking() işlevine yanıtta çağrılmış)
  • STREAM_OPTION_READ_TIMEOUT (Yöntem stream_set_timeout() işlevine yanıtta çağrılmış)
  • STREAM_OPTION_WRITE_BUFFER (Yöntem stream_set_write_buffer() işlevine yanıtta çağrılmış)

arg1

seçenek değerine göre:

  • STREAM_OPTION_BLOCKING: İstenen engelleme kipi (engelleniyorsa 1, engellenmiyorsa 0).
  • STREAM_OPTION_READ_TIMEOUT: Saniye cinsinden zama aşımı.
  • STREAM_OPTION_WRITE_BUFFER: Tamponlama kipi (STREAM_BUFFER_NONE veya STREAM_BUFFER_FULL).

arg2

seçenek değerine göre:

  • STREAM_OPTION_BLOCKING: Bu seçenek atanmaz.
  • STREAM_OPTION_READ_TIMEOUT: Mikrosaniye cinsinden zaman aşımı.
  • STREAM_OPTION_WRITE_BUFFER: İstenen tampon boyutu.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. seçenek gerçeklenmezse FALSE dönmelidir.

Ayrıca Bakınız

  • stream_set_blocking() - Akımın engelleme kipini ayarlar
  • stream_set_timeout() - Akımın zaman aşımı süresini ayarlar
  • stream_set_write_buffer() - Dosya tamponunu ayarlar

streamWrapper::stream_seek
streamWrapper::stream_stat
streamWrapper


Bir dosya özkaynağı hakkında bilgi döndürür

streamWrapper::stream_set_option
streamWrapper::stream_tell
streamWrapper
PHP Manual

streamWrapper::stream_stat

(PHP 4 >= 4.3.2, PHP 5, PHP 7)

streamWrapper::stream_stat — Bir dosya özkaynağı hakkında bilgi döndürür

Açıklama

public array streamWrapper::stream_stat ( void )

Bu yöntem fstat() işlevine yanıtta çağrılır.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

stat() işlevine bakınız.

Hatalar/İstisnalar

Bu yöntem çağrısı başarısız olursa (gerçeklenmeme sorunu gibi) bir E_WARNING iletisi çıktılar.

Ayrıca Bakınız

  • stat() - Bir dosya hakkında bilgi döndürür
  • streamwrapper::url_stat() - Bir dosya hakkında bilgi döndürür

streamWrapper::stream_set_option
streamWrapper::stream_tell
streamWrapper


Bir akımdan geçerli konumu döndürür

streamWrapper::stream_stat
streamWrapper::stream_truncate
streamWrapper
PHP Manual

streamWrapper::stream_tell

(PHP 4 >= 4.3.2, PHP 5, PHP 7)

streamWrapper::stream_tell — Bir akımdan geçerli konumu döndürür

Açıklama

public int streamWrapper::stream_tell ( void )

Bu yöntem ftell() işlevine yanıtta çağrılır.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Akımdaki geçerli konumu döndürmesi gerekir.

Ayrıca Bakınız

  • ftell() - Dosya okuma/yazma konumlayıcının mevcut konumu ile döner

streamWrapper::stream_stat
streamWrapper::stream_truncate
streamWrapper


Truncate stream

streamWrapper::stream_tell
streamWrapper::stream_write
streamWrapper
PHP Manual

streamWrapper::stream_truncate

(PHP 5 >= 5.4.0, PHP 7)

streamWrapper::stream_truncate — Truncate stream

Açıklama

public bool streamWrapper::stream_truncate ( int $new_size )

Will respond to truncation, e.g., through ftruncate().

Değiştirgeler

new_size

The new size.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ftruncate() - Bir dosyayı belli bir uzunlukta budar

streamWrapper::stream_tell
streamWrapper::stream_write
streamWrapper


Akıma yazar

streamWrapper::stream_truncate
streamWrapper::unlink
streamWrapper
PHP Manual

streamWrapper::stream_write

(PHP 4 >= 4.3.2, PHP 5, PHP 7)

streamWrapper::stream_write — Akıma yazar

Açıklama

public int streamWrapper::stream_write ( string $veri )

Bu yöntem fwrite() işlevine yanıt olarak çağrılır.

Bilginize:

Başarıyla yazılan bayt sayısına göre akımdaki konumlayıcıyı güncellemeyi unutmayın.

Değiştirgeler

veri

Sarmalayıcının akımına yazılacak veri.

Bilginize:

Akımda yeteri kadar yer yoksa olduğu kadarına yazılır.

Dönen Değerler

Akımda başarıyla saklanan bayt sayısı döner. 0 dönmüşse hiçbir veri saklanamamış demektir.

Hatalar/İstisnalar

Bu yöntem çağrısı başarısız olursa (gerçeklenmeme sorunu gibi) bir E_WARNING iletisi çıktılar.

Bilginize:

Dönen değer veri uzunluğundan büyükse bir E_WARNING çıktılanır ve dönüş değeri bu uzunluğa düşürülür.

Ayrıca Bakınız

  • fwrite() - Dosyaya ikil kipte yazar

streamWrapper::stream_truncate
streamWrapper::unlink
streamWrapper


Bir dosyayı siler

streamWrapper::stream_write
streamWrapper::url_stat
streamWrapper
PHP Manual

streamWrapper::unlink

(PHP 5, PHP 7)

streamWrapper::unlink — Bir dosyayı siler

Açıklama

public bool streamWrapper::unlink ( string $dosya )

Bu yöntem unlink() işlevine yanıt olarak çağrılır.

Bilginize:

Sarmalayıcı dosya silmeyi desteklemiyorsa uygun bir hata iletisi döndürmek adına bu yöntem tanımlanmamalıdır.

Değiştirgeler

dosya

Silinecek dosyanın yolu (URL'si).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

Bu yöntem çağrısı başarısız olursa (gerçeklenmeme sorunu gibi) bir E_WARNING iletisi çıktılar.

Notlar

Bilginize:

streamWrapper::$context özelliği, çağıran işleve geçerli bir bağlam aktarılırsa güncellenir.

Ayrıca Bakınız

  • unlink() - Bir dosyayı siler
  • streamWrapper::rmdir() - Bir dizini siler

streamWrapper::stream_write
streamWrapper::url_stat
streamWrapper


Bir dosya hakkında bilgi döndürür

streamWrapper::unlink
Akım İşlevleri
streamWrapper
PHP Manual

streamWrapper::url_stat

(PHP 4 >= 4.3.2, PHP 5, PHP 7)

streamWrapper::url_stat — Bir dosya hakkında bilgi döndürür

Açıklama

public array streamWrapper::url_stat ( string $dosya , int $seçenekler )

Bu yöntem stat() ile ilgili aşağıdaki gibi işlevlere bir yanıt olarak çağrılır:

  • chmod() (sadece safe_mode etkinse)
  • copy()
  • fileperms()
  • fileinode()
  • filesize()
  • fileowner()
  • filegroup()
  • fileatime()
  • filemtime()
  • filectime()
  • filetype()
  • is_writable()
  • is_readable()
  • is_executable()
  • is_file()
  • is_dir()
  • is_link()
  • file_exists()
  • lstat()
  • stat()
  • SplFileInfo::getPerms()
  • SplFileInfo::getInode()
  • SplFileInfo::getSize()
  • SplFileInfo::getOwner()
  • SplFileInfo::getGroup()
  • SplFileInfo::getATime()
  • SplFileInfo::getMTime()
  • SplFileInfo::getCTime()
  • SplFileInfo::getType()
  • SplFileInfo::isWritable()
  • SplFileInfo::isReadable()
  • SplFileInfo::isExecutable()
  • SplFileInfo::isFile()
  • SplFileInfo::isDir()
  • SplFileInfo::isLink()
  • RecursiveDirectoryIterator::hasChildren()

Değiştirgeler

dosya

Hakkında bilgi döndürülecek dosyanın yolu veya URL'si. Bir URL belirtilmesi durumunda URL ayracı olarak :// kullanılmalıdır. Diğer URL biçimleri desteklenmemektedir.

seçenekler

Akım arayüzü tarafından atanan ek seçeneklerden oluşur. Aşağıdaki değerlerin birleşiminden oluşan bit maskesidir.

Seçenek | Açıklama
STREAM_URL_STAT_LINK | Başka özkaynaklarla ilintilenme yeteneği olan özkaynaklar için (örneğin, bir HTTP konumuna yönlendirme veya bir dosya sistemi sembolik bağı). Bu seçenek sadece döndürülen bağın kendisi hakkında bilgi döndürür, bağın hedefi hakkında değil. Bu seçenek, lstat(), is_link() veya filetype() çağrılarına yanıtta atanır.
STREAM_URL_STAT_QUIET | Bu seçenek atanmışsa sarmalayıcı herhangi bir hata oluşturamayacaktır. Atanmamışsa, URL'nin durumlanması sırasında trigger_error() işlevini kullanarak hataları raporlamaktan siz sorumlu olursunuz.

Dönen Değerler

stat() işlevinin yaptığı gibi olabildiğince çok eleman dönmelidir. Bilinmeyen veya elverişli olmayan değerler uygun bir değere (genellikle 0) ayarlanmalıdır.

Hatalar/İstisnalar

Bu yöntem çağrısı başarısız olursa (gerçeklenmeme sorunu gibi) bir E_WARNING iletisi çıktılar.

Notlar

Bilginize:

streamWrapper::$context özelliği, çağıran işleve geçerli bir bağlam aktarılırsa güncellenir.

Ayrıca Bakınız

  • stat() - Bir dosya hakkında bilgi döndürür
  • streamwrapper::stream_stat() - Bir dosya özkaynağı hakkında bilgi döndürür

streamWrapper::unlink
Akım İşlevleri
streamWrapper


Akım İşlevleri

İçindekiler

  • set_socket_blocking — Takma Adı: stream_set_blocking
  • stream_bucket_append — Zincirin sonuna bir biriktirici ekler
  • stream_bucket_make_writeable — Üzerinde işlem yapmak için zincirden bir biriktirici nesnesi döndürür
  • stream_bucket_new — Geçerli akımda kullanmak için yeni bir biriktirici oluşturur
  • stream_bucket_prepend — Zincirin önüne bir biriktirici ekler
  • stream_context_create — Bir akım bağlamı oluşturur
  • stream_context_get_default — Öntanımlı akım bağlamını döndürür
  • stream_context_get_options — Bir akım/sarmalayıcı/bağlam için atanmış seçenekleri döndürür
  • stream_context_get_params — Bir bağlamın değiştirgelerini döndürür
  • stream_context_set_default — Akımları içeren öntanımlı bağlamı tanımlar
  • stream_context_set_option — Bir akım/sarmalayıcı/bağlam için bir seçenek tanımlar
  • stream_context_set_params — Bir akım/sarmalayıcı/bağlam için değiştirgeleri tanımlar
  • stream_copy_to_stream — Veriyi bir akımdan diğerine kopyalar
  • stream_encoding — Akımı kodlayacak karakter kümesini belirler
  • stream_filter_append — Süzgeç zincirinin sonuna bir süzgeç ekler
  • stream_filter_prepend — Süzgeç zincirinin başına bir süzgeç ekler
  • stream_filter_register — Kullanıcı tanımlı bir akım süzgecini etkin kılar
  • stream_filter_remove — Akımdan bir süzgeci kaldırır
  • stream_get_contents — Akımdan kalanı bir dizgeye okur
  • stream_get_filters — Etkin süzgeçlerin listesini döndürür
  • stream_get_line — Akımdan belirtilen ayraca kadar bir satır döndürür
  • stream_get_meta_data — Akımdan başlıkları/meta verileri döndürür
  • stream_get_transports — Etkin soket aktarımlarının listesini döndürür
  • stream_get_wrappers — Etkin akımların listesini döndürür
  • stream_is_local — Akım, bir yerel akımsa TRUE döner
  • stream_notification_callback — notification bağlam değiştirgesi için bir geri çağırım işlevi
  • stream_register_wrapper — stream_wrapper_register işlevinin takma adıdır
  • stream_resolve_include_path — Bir göreli yol ile yapılacak fopen çağrısıyla açılacak dosyayı belirler
  • stream_select — Belirtilen akım dizisi üzerinde belirtilen zaman aşımı ile select() sistem çağrısının eşdeğeri olarak çalışır
  • stream_set_blocking — Akımın engelleme kipini ayarlar
  • stream_set_chunk_size — Set the stream chunk size
  • stream_set_read_buffer — Set read file buffering on the given stream
  • stream_set_timeout — Akımın zaman aşımı süresini ayarlar
  • stream_set_write_buffer — Dosya tamponunu ayarlar
  • stream_socket_accept — stream_socket_server ile oluşturulmuş bir soketten bağlantı kabul eder
  • stream_socket_client — Bir Genel Ağ veya Unix alan soketi bağlantısı açar
  • stream_socket_enable_crypto — Bağlı bir soket üzerinde şifrelemeyi açıp kapatır
  • stream_socket_get_name — Yerel veya uzak soketin ismini döndürür
  • stream_socket_pair — Soket akımlarınca ayırt edilebilen bir bağlantı çifti oluşturur
  • stream_socket_recvfrom — Bağlı olsun ya da olmasın bir soketten veri alır
  • stream_socket_sendto — Bir sokete bağlı olsun ya da olmasın, bir ileti gönderir
  • stream_socket_server — Bir Genel Ağ veya Unix alan sunucusu soketi oluşturur
  • stream_socket_shutdown — Çift yönlü bağlantıyı kapatır
  • stream_supports_lock — Akımın kilitlemeyi destekleyip desteklemediğine bakar
  • stream_wrapper_register — Bir PHP sınıfı olarak gerçeklenmiş bir URL sarmalayıcısını etkin kılar
  • stream_wrapper_restore — İptal edilmiş yerleşik bir sarmalayıcıyı tekrar etkin kılar
  • stream_wrapper_unregister — Bir URL sarmalayıcısını iptal eder
streamWrapper::url_stat
set_socket_blocking
Akımlar


Takma Adı: stream_set_blocking

Akım İşlevleri
stream_bucket_append
Akım İşlevleri
PHP Manual

set_socket_blocking

(PHP 4, PHP 5)

set_socket_blocking — Takma Adı: stream_set_blocking()

Uyarı

Bu takma adın kullanımı PHP 5.3.0 itibariyle ÖNERİLMEMEKTE olup PHP 7.0.0'da tamamen KALDIRILMIŞTIR.

Açıklama

Bu işlev şu işlevin takma adıdır: stream_set_blocking()

Akım İşlevleri
stream_bucket_append
Akım İşlevleri


Zincirin sonuna bir biriktirici ekler

set_socket_blocking
stream_bucket_make_writeable
Akım İşlevleri
PHP Manual

stream_bucket_append

(PHP 5, PHP 7)

stream_bucket_append — Zincirin sonuna bir biriktirici ekler

Açıklama

void stream_bucket_append ( resource $zincir , resource $biriktirici )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

set_socket_blocking
stream_bucket_make_writeable
Akım İşlevleri


Üzerinde işlem yapmak için zincirden bir biriktirici nesnesi döndürür

stream_bucket_append
stream_bucket_new
Akım İşlevleri
PHP Manual

stream_bucket_make_writeable

(PHP 5, PHP 7)

stream_bucket_make_writeable — Üzerinde işlem yapmak için zincirden bir biriktirici nesnesi döndürür

Açıklama

object stream_bucket_make_writeable ( resource $zincir )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

stream_bucket_append
stream_bucket_new
Akım İşlevleri


Geçerli akımda kullanmak için yeni bir biriktirici oluşturur

stream_bucket_make_writeable
stream_bucket_prepend
Akım İşlevleri
PHP Manual

stream_bucket_new

(PHP 5, PHP 7)

stream_bucket_new — Geçerli akımda kullanmak için yeni bir biriktirici oluşturur

Açıklama

object stream_bucket_new ( resource $akım , string $tampon )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

stream_bucket_make_writeable
stream_bucket_prepend
Akım İşlevleri


Zincirin önüne bir biriktirici ekler

stream_bucket_new
stream_context_create
Akım İşlevleri
PHP Manual

stream_bucket_prepend

(PHP 5, PHP 7)

stream_bucket_prepend — Zincirin önüne bir biriktirici ekler

Açıklama

void stream_bucket_prepend ( resource $zincir , resource $biriktirici )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

stream_bucket_new
stream_context_create
Akım İşlevleri


Bir akım bağlamı oluşturur

stream_bucket_prepend
stream_context_get_default
Akım İşlevleri
PHP Manual

stream_context_create

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

stream_context_create — Bir akım bağlamı oluşturur

Açıklama

resource stream_context_create ([ array $seçenekler [, array $değiştirgeler ]] )

Belirtilen seçenekler ile bir akım bağlamı oluşturup bağlam özkaynağını döndürür.

Değiştirgeler

seçenekler

seçenekler dizisi, üyeleri $seçenekler['sarmalayıcı']['seçenek'] = $değer olan bir ilişkisel dizi olmalıdır.

Öntanımlı değer boş bir dizidir.

değiştirgeler

değiştirgeler dizisi üyeleri $değiştirgeler['değiştirge_adı'] = "değer"; olan bir ilişkisel dizi olmalıdır. Standart akım değiştirgelerinin listesi için Bağlam değiştirgeleri bölümüne bakınız.

Dönen Değerler

Akım bağlamı özkaynağı.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | Seçimlik değiştirgeler değiştirgesi eklendi.

Örnekler

Örnek 1 - stream_context_create() örneği

<?php
$opts = array(
  'http'=>array(
    'method'=>"GET",
    'header'=>"Accept-language: en\r\n" .
              "Cookie: foo=bar\r\n"
  )
);

$context = stream_context_create($opts);

/* Yukarıdaki başlıklarla www.example.com'a bir HTTP isteği gönderelim */
$fp = fopen('http://www.example.com', 'r', false, $context);
fpassthru($fp);
fclose($fp);
?>

Ayrıca Bakınız

  • stream_context_set_option() - Bir akım/sarmalayıcı/bağlam için bir seçenek tanımlar
  • Supported Protocols and Wrappers
  • Bağlam seçenekleri ve değiştirgeleri
stream_bucket_prepend
stream_context_get_default
Akım İşlevleri


Öntanımlı akım bağlamını döndürür

stream_context_create
stream_context_get_options
Akım İşlevleri
PHP Manual

stream_context_get_default

(PHP 5 >= 5.1.0, PHP 7)

stream_context_get_default — Öntanımlı akım bağlamını döndürür

Açıklama

resource stream_context_get_default ([ array $seçenekler ] )

Bir bağlam değiştirgesi olmadan çağrılan (fopen(), file_get_contents() gibi) dosya işlevlerinde kullanılmak üzere öntanımlanmış akım bağlamını döndürür. Öntanımlı bağlam için seçenekler bu işlevle de tanımlanabilmektedir. Sözdizimi stream_context_create() ile aynıdır.

Değiştirgeler

seçenekler
seçenekler dizisi, üyeleri $seçenekler['sarmalayıcı']['seçenek'] = $değer olan bir ilişkisel dizi olmalıdır.

Bilginize:

PHP 5.3.0'dan itibaren, stream_context_set_default() işlevi öntanımlı bağlamı ayarlamak için de kullanılabilmektedir.

Dönen Değerler

Bir bağlam özkaynağı.

Örnekler

Örnek 1 - stream_context_get_default() örneği

<?php
$default_opts = array(
  'http'=>array(
    'method'=>"GET",
    'header'=>"Accept-language: en\r\n" .
              "Cookie: foo=bar",
    'proxy'=>"tcp://10.54.1.39:8000"
  )
);

$alternate_opts = array(
  'http'=>array(
    'method'=>"POST",
    'header'=>"Content-type: application/x-www-form-urlencoded\r\n" .
              "Content-length: " . strlen("baz=bomb"),
    'content'=>"baz=bomb"
  )
);

$default = stream_context_get_default($default_opts);
$alternate = stream_context_create($alternate_opts);

/* www.example.com için $default_opts ile belirtilen bağlam
 * seçeneklerini kullanarak 10.54.1.39'daki vekil sunucuya
 * normal bir GET isteği gönderelim.
 */
readfile('http://www.example.com');

/* $alternate_opts ile belirtilen bağlam seçeneklerini
 * kullanarak www.example.com'a doğrudan bir POST isteği
 * gönderelim.
 */
readfile('http://www.example.com', false, $alternate);

?>

Ayrıca Bakınız

  • stream_context_create() - Bir akım bağlamı oluşturur
  • Supported Protocols and Wrappers

stream_context_create
stream_context_get_options
Akım İşlevleri


Bir akım/sarmalayıcı/bağlam için atanmış seçenekleri döndürür

stream_context_get_default
stream_context_get_params
Akım İşlevleri
PHP Manual

stream_context_get_options

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

stream_context_get_options — Bir akım/sarmalayıcı/bağlam için atanmış seçenekleri döndürür

Açıklama

array stream_context_get_options ( resource $akım_veya_bağlam )

Belirtilen akım veya bağlam için atanmış seçenekleri döndürür.

Değiştirgeler

akım_veya_bağlam

Seçenekleri döndürülecek akım veya bağlam özkaynağı.

Dönen Değerler

Seçenekleri içeren bir ilişkisel dizi döner.

Örnekler

Örnek 1 - stream_context_get_options() örneği

<?php
$params = array("method" => "POST");

stream_context_get_default(array("http" => $params));

var_dump(stream_context_get_options(stream_context_get_default()));

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(1) {
  ["http"]=>
  array(1) {
    ["method"]=>
    string(4) "POST"
  }
}

stream_context_get_default
stream_context_get_params
Akım İşlevleri


Bir bağlamın değiştirgelerini döndürür

stream_context_get_options
stream_context_set_default
Akım İşlevleri
PHP Manual

stream_context_get_params

(PHP 5 >= 5.3.0, PHP 7)

stream_context_get_params — Bir bağlamın değiştirgelerini döndürür

Açıklama

array stream_context_get_params ( resource $akım_veya_bağlam )

Belirtilen akım veya bağlamın değiştirgelerini ve seçeneklerini döndürür.

Değiştirgeler

akım_veya_bağlam

Bir akım veya bağlam özkaynağı.

Dönen Değerler

Tüm bağlam seçeneklerini ve değiştirgelerini içeren bir ilişkisel dizi döner.

Örnekler

Örnek 1 - stream_context_get_params() örneği

Temel kullanım örneği

<?php
$ctx = stream_context_create();
$params = array("notification" => "stream_notification_callback");
stream_context_set_params($ctx, $params);

var_dump(stream_context_get_params($ctx));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(2) {
  ["notification"]=>
  string(28) "stream_notification_callback"
  ["options"]=>
  array(0) {
  }
}

Ayrıca Bakınız

  • stream_context_set_option() - Bir akım/sarmalayıcı/bağlam için bir seçenek tanımlar
  • stream_context_get_options() - Bir akım/sarmalayıcı/bağlam için atanmış seçenekleri döndürür
  • stream_context_set_params() - Bir akım/sarmalayıcı/bağlam için değiştirgeleri tanımlar

stream_context_get_options
stream_context_set_default
Akım İşlevleri


Akımları içeren öntanımlı bağlamı tanımlar

stream_context_get_params
stream_context_set_option
Akım İşlevleri
PHP Manual

stream_context_set_default

(PHP 5 >= 5.3.0, PHP 7)

stream_context_set_default — Akımları içeren öntanımlı bağlamı tanımlar

Açıklama

resource stream_context_set_default ( array $seçenekler )

Bir bağlam değiştirgesi olmadan çağrılan (fopen(), file_get_contents() gibi) dosya işlevlerinde kullanılmak üzere öntanımlı akım bağlamını tanımlar. Sözdizimi stream_context_create() ile aynıdır.

Değiştirgeler

seçenekler

Öntanımlı bağlam için atanacak seçenekler.

Bilginize:

seçenekler dizisi, üyeleri $seçenekler['sarmalayıcı']['seçenek'] = $değer olan bir ilişkisel dizi olmalıdır.

Dönen Değerler

Öntanımlı akım bağlamı özkaynağı ile döner.

Örnekler

Örnek 1 - stream_context_set_default() örneği

<?php
$default_opts = array(
  'http'=>array(
    'method'=>"GET",
    'header'=>"Accept-language: en\r\n" .
              "Cookie: foo=bar",
    'proxy'=>"tcp://10.54.1.39:8000"
  )
);

$default = stream_context_set_default($default_opts);

/* www.example.com için $default_opts ile belirtilen bağlam
 * seçeneklerini kullanarak 10.54.1.39'daki vekil sunucuya
 * normal bir GET isteği gönderelim.
 */
readfile('http://www.example.com');
?>

Ayrıca Bakınız

  • stream_context_create() - Bir akım bağlamı oluşturur
  • stream_context_get_default() - Öntanımlı akım bağlamını döndürür
  • Supported Protocols and Wrappers

stream_context_get_params
stream_context_set_option
Akım İşlevleri


Bir akım/sarmalayıcı/bağlam için bir seçenek tanımlar

stream_context_set_default
stream_context_set_params
Akım İşlevleri
PHP Manual

stream_context_set_option

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

stream_context_set_option — Bir akım/sarmalayıcı/bağlam için bir seçenek tanımlar

Açıklama

bool stream_context_set_option ( resource $akım_veya_bağlam , string $sarmalayıcı , string $seçenek , mixed $değer )
bool stream_context_set_option ( resource $akım_veya_bağlam , array $seçenekler )

Belirtilen bağlam için bir seçenek tanımlar. sarmalayıcı seçenek'ine değer atar.

Değiştirgeler

akım_veya_bağlam

Seçenekleri uygulanacağı akım veya bağlam özkaynağı.

seçenekler

Öntanımlı bağlam için atanacak seçenekler.

Bilginize:

seçenekler dizisi üyeleri $seçenekler['seçenek_adı'] = "değer"; olan bir ilişkisel dizi olmalıdır.

Ayrıca bakınız: Bağlam seçenekleri ve değiştirgeleri.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

stream_context_set_default
stream_context_set_params
Akım İşlevleri


Bir akım/sarmalayıcı/bağlam için değiştirgeleri tanımlar

stream_context_set_option
stream_copy_to_stream
Akım İşlevleri
PHP Manual

stream_context_set_params

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

stream_context_set_params — Bir akım/sarmalayıcı/bağlam için değiştirgeleri tanımlar

Açıklama

bool stream_context_set_params ( resource $akım_veya_bağlam , array $değiştirgeler )

Belirtilen bağlamın değiştirgelerini tanımlar.

Değiştirgeler

akım_veya_bağlam

Değiştirgelerin uygulanacağı akım veya bağlam özkaynağı.

değiştirgeler

Tanımlanacak değiştirgeleri içeren dizi.

Bilginize:

değiştirgeler dizisi üyeleri $değiştirgeler['değiştirge_adı'] = "değer"; olan bir ilişkisel dizi olmalıdır.

Desteklenen değiştirgeler

Değiştirgeler | Açıklama
notification | Bir akım, bir bildirimi her tetiklediğinde çağrılacak kullanıcı tanımlı geriçağırım işlevinin ismi.
options | Bağlam seçenekleri ve değiştirgeleri kapsamında seçenekleri içeren dizi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

stream_context_set_option
stream_copy_to_stream
Akım İşlevleri


Veriyi bir akımdan diğerine kopyalar

stream_context_set_params
stream_encoding
Akım İşlevleri
PHP Manual

stream_copy_to_stream

(PHP 5, PHP 7)

stream_copy_to_stream — Veriyi bir akımdan diğerine kopyalar

Açıklama

int stream_copy_to_stream ( resource $kaynak , resource $hedef [, int $uzunluk = -1 [, int $başlangıç = 0 ]] )

Mevcut konumdan (belirtilmişse başlangıç konumundan) itibaren en fazla uzunluk baytlık veriyi kaynak akımdan hedef akıma kopyalar. uzunluk belirtilmezse akımda kalan verinin tamamı kopyalanır

Değiştirgeler

kaynak

Kaynak akım.

hedef

Hedef akım.

uzunluk

Kopyalanacak azami bayt sayısı.

başlangıç

Kopyalanacak verinin başlangıç konumu.

Dönen Değerler

Kopyalanan toplam bayt sayısını döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.0 | başlangıç değiştirgesi eklendi.

Örnekler

Örnek 1 - stream_copy_to_stream() örneği

<?php
$src = fopen('http://www.example.com', 'r');
$dest1 = fopen('ilk1k.txt', 'w');
$dest2 = fopen('kalan.txt', 'w');

echo stream_copy_to_stream($src, $dest1, 1024) .
        " bayt ilk1k.txt dosyasına kopyalandı\n";
echo stream_copy_to_stream($src, $dest2) .
        " bayt kalan.txt dosyasına kopyalandı\n";

?>

Ayrıca Bakınız

  • copy() - Dosya kopyalar

stream_context_set_params
stream_encoding
Akım İşlevleri


Akımı kodlayacak karakter kümesini belirler

stream_copy_to_stream
stream_filter_append
Akım İşlevleri
PHP Manual

stream_encoding

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

stream_encoding — Akımı kodlayacak karakter kümesini belirler

Açıklama

bool stream_encoding ( resource $akım [, string $karküm ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

stream_copy_to_stream
stream_filter_append
Akım İşlevleri


Süzgeç zincirinin sonuna bir süzgeç ekler

stream_encoding
stream_filter_prepend
Akım İşlevleri
PHP Manual

stream_filter_append

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

stream_filter_append — Süzgeç zincirinin sonuna bir süzgeç ekler

Açıklama

resource stream_filter_append ( resource $akım , string $süzgeç [, int $oku_yaz [, mixed $değiştirgeler ]] )

akım akımına ekli süzgeç zincirinin sonuna süzgeç isimli süzgeci ekler.

Değiştirgeler

akım

Hedef akım.

süzgeç

Süzgeç ismi.

read_write

stream_filter_append() işlevi öntanımlı olarak, dosya okumak için (r veya r+ kipi) açılmışsa süzgeci okuma süzgeci zincirine ekler. Eğer dosya yazmak için (w, a veya w+, a+ kipi) açılmışsa, süzgeç yazma süzgeci zincirine de eklenir. Bu davranışı geçersiz kılmak için değiştirgeye STREAM_FILTER_READ, STREAM_FILTER_WRITE ve/veya STREAM_FILTER_ALL sabitleri de aktarılabilir.

değiştirgeler

Süzgeç, belirtilen değiştirgeler ile listenin sonuna eklenir ve akım işlemlerinde son çağrılan süzgeç olur. Süzgeci listenin başına eklemek için stream_filter_prepend() işlevini kullanın.

Dönen Değerler

stream_filter_remove() çağrısına aktarılmak üzere bir özkaynak döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.0 | PHP 5.1.0 öncesinde, bu işlev başarı durumunda TRUE yoksa FALSE döndürürdü.

Örnekler

Örnek 1 - Süzgeçlerin uygulanacağı yerin belirlenmesi

<?php
/* Okumak ve yazmak için bir dosya açalım */
$fp = fopen('test.txt', 'w+');

/* ROT13 süzgecini yazma zincirine ekleyelim
   fakat okuma zincirine eklemeyelim */
stream_filter_append($fp, "string.rot13", STREAM_FILTER_WRITE);

/* ROT13 ile dönüştürülmek üzere dosyaya bir şeyler yazalım */
fwrite($fp, "This is a test\n");

/* Dosyanın başına dönelim */
rewind($fp);

/* Dosya içeriğini okuyalım.
 * Süzgeç okuma zincirine de uygulanmış
 * olsaydı metni eski durumuna dönüştürülmüş
 * olarak görecektik.  */
fpassthru($fp);

fclose($fp);

/* Beklenen çıktı
   ---------------

Guvf vf n grfg

 */
?>

Notlar

Bilginize: Özel (kullanıcı) süzgeçlerini kullanırken
İstenen kullanıcı süzgecini süzgeç olarak tanıtmak için ilk olarak stream_filter_register() çağrılmalıdır.

Bilginize: Henüz okunmamış veri dahili tamponlarda tutulurken akım verisi özkaynaklardan (hem yerel hem de uzak) büyük kümeler halinde okunur. Süzgeç zincirinin sonuna yeni bir süzgeç eklendiğinde, dahili tamponlardaki işlenmiş veriler yeni süzgeçten de geçirilir. Bu davranış, yeni süzgeci zincirin başına ekleyen stream_filter_prepend() işlevinden bu yönüyle farklıdır.

Bilginize: Bir süzgeç hem okuma hem de yazma amacıyla eklendiğinde iki örneği oluşturulur. Her iki süzgeç özkaynağını ayırmak için stream_filter_append() işlevi STREAM_FILTER_READ ve STREAM_FILTER_WRITE ile ayrı ayrı çağrılmalıdır.

Ayrıca Bakınız

  • stream_filter_register() - Kullanıcı tanımlı bir akım süzgecini etkin kılar
  • stream_filter_prepend() - Süzgeç zincirinin başına bir süzgeç ekler
  • stream_get_filters() - Etkin süzgeçlerin listesini döndürür
stream_encoding
stream_filter_prepend
Akım İşlevleri


Süzgeç zincirinin başına bir süzgeç ekler

stream_filter_append
stream_filter_register
Akım İşlevleri
PHP Manual

stream_filter_prepend

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

stream_filter_prepend — Süzgeç zincirinin başına bir süzgeç ekler

Açıklama

resource stream_filter_prepend ( resource $akım , string $süzgeç [, int $oku_yaz [, mixed $değiştirgeler ]] )

akım akımına ekli süzgeçler listesine süzgeç isimli süzgeci ekler.

Değiştirgeler

akım

Hedef akım.

süzgeç

Eklenecek süzgecin ismi.

oku_yaz

stream_filter_prepend() işlevi öntanımlı olarak, dosya okumak için (r veya r+ kipi) açılmışsa süzgeci okuma süzgeci zincirine ekler. Eğer dosya yazmak için (w, a veya w+, a+ kipi) açılmışsa, süzgeç yazma süzgeci zincirine de eklenir. Bu davranışı geçersiz kılmak için değiştirgeye STREAM_FILTER_READ, STREAM_FILTER_WRITE ve/veya STREAM_FILTER_ALL sabitleri de aktarılabilir. Bu değiştirgenin kullanıldığı bir örneği stream_filter_append() işlevinde görebilirsiniz.

değiştirgeler

Süzgeç, belirtilen değiştirgeler ile listenin başlangıcına eklenir ve akım işlemlerinde ilk çağrılan süzgeç olur. Süzgeci listenin sonuna eklemek için stream_filter_append() işlevini kullanın.

Dönen Değerler

stream_filter_remove() çağrısına aktarılmak üzere bir özkaynak döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.0 | PHP 5.1.0 öncesinde, bu işlev başarı durumunda TRUE yoksa FALSE döndürürdü.

Notlar

Bilginize: Özel (kullanıcı) süzgeçlerini kullanırken
İstenen kullanıcı süzgecini süzgeç olarak tanıtmak için ilk olarak stream_filter_register() çağrılmalıdır.

Bilginize: Henüz okunmamış veri dahili tamponlarda tutulurken akım verisi özkaynaklardan (hem yerel hem de uzak) büyük kümeler halinde okunur. Süzgeç zincirinin başına yeni bir süzgeç eklendiğinde, dahili tamponlardaki süzgeçlerden geçirilmemiş veriler yeni süzgeçten geçirilecektir ancak evvelce diğer süzgeçlerden geçirilmiş veriler yeni süzgeçten geçirilmeyecektir. Bu davranış,yeni süzgeci zincirin sonuna ekleyen stream_filter_append() işlevinden bu yönüyle farklıdır.

Bilginize: Bir süzgeç hem okuma hem de yazma amacıyla eklendiğinde iki örneği oluşturulur. Her iki süzgeç özkaynağını ayırmak için stream_filter_prepend() işlevi STREAM_FILTER_READ ve STREAM_FILTER_WRITE ile ayrı ayrı çağrılmalıdır.

Ayrıca Bakınız

  • stream_filter_register() - Kullanıcı tanımlı bir akım süzgecini etkin kılar
  • stream_filter_append() - Süzgeç zincirinin sonuna bir süzgeç ekler
stream_filter_append
stream_filter_register
Akım İşlevleri


Kullanıcı tanımlı bir akım süzgecini etkin kılar

stream_filter_prepend
stream_filter_remove
Akım İşlevleri
PHP Manual

stream_filter_register

(PHP 5, PHP 7)

stream_filter_register — Kullanıcı tanımlı bir akım süzgecini etkin kılar

Açıklama

bool stream_filter_register ( string $süzgeç , string $sınıf )

stream_filter_register() işlevi dosya sistemi işlevleriyle (fopen(), fread() gibi) kullanılmak üzere kendi süzgecinizi tanımlamanıza izin verir.

Değiştirgeler

süzgeç

Süzgecin ismi.

sınıf

Bir süzgeci gerçeklemek için, php_user_filter'in bir uzantısı olarak, aşağıda belirtilen üye işlevlerle bir sınıf tanımlamanız gerekir. Süzgecinizin ekli olduğu akım üzerinde okuma ve yazma işlemleri yaparken, PHP tüm veriyi süzgecinizden (ve akıma ekli diğer süzgeçlerden) geçirerek verinin istendiği gibi değiştirilmesini sağlar. Yöntemleri tamamen aşağıda belirtildiği gibi gerçeklemeniz gerekir. Başka türlü yaparsanız süzgecin ne yapacağı belli olmaz.

int filter ( resource $in , resource $out , int &$consumed , bool $closing )

Bu yöntem, süzgecin ekli olduğu akım üzerinde yapılan her okuma veya yazma (fread() veya fwrite() gibi) işleminde çağrılır. in değiştirgesi, süzülecek verinin içerdiği bir veya daha fazla sayıda biriktirici nesneden oluşan biriktirici kümesi'ni gösteren bir özkaynaktır. out değiştirgesi, değiştirilen biriktiricilerin konulduğu biriktirici kümesi'ni gösteren bir özkaynaktır. consumed değiştirgesi, süzgecinizce okunan ve değiştirilen veri uzunluğu kadar artmalı ve göreli olarak aktarılmalıdır. Çoğu durumda consumed değeri her $biriktirici için $biriktirici->datalen kadar arttılırılır. Eğer akım kapama sürecindeyse (dolayısıyla bu, süzgeç zincirindeki son geçiştir) closing değiştirgesine TRUE atanmalıdır. filter() yöntemi işini bitirdiğinde şu üç değerden birini döndürmelidir:

Dönüş Değeri | Anlamı
PSFS_PASS_ON | Süzgeç veriyi başarıyla işleyip biriktirici kümesi'ni out değiştirgesine yerleştirdi.
PSFS_FEED_ME | Süzgeç işini tamamladı ancak, döndürülecek bir veri yok. Akımdan veya önceki süzgeçten daha fazla veri gerekiyor.
PSFS_ERR_FATAL (öntanımlı) | Süzgeç kurtarılamayacak bir hata tespit etti; devam edilemiyor.

bool onCreate ( void )
Bu yöntem süzgeç sınıfının bir nesne olarak örneklenmesi sırasında çağrılır. Süzgeciniz herhangi bir özkaynak ayıracaksa (bir tampon gibi) bunun yapılacağı yer burasıdır. Yöntem başarılı olduğunda TRUE aksi takdirde FALSE döndürmelidir Süzgeciniz ilk örneklendiğinde ve süzgeciniz->onCreate() çağrıldığında, aşağıdaki tabloda gösterilen özellikler kullanılabilir olmalıdır:

Özellik | İçeriği
süzgeciniz->filtername | Örneklenen süzgecin ismini içeren dizge. Süzgeçler farklı isimlerle veya dosya ismi kalıplarıyla kayıt altına alınabilirler. Bu özellik kullanılacak ismi belirlemek için kullanılır.
süzgeciniz->params | params değiştirgesinin içeriği stream_filter_append() veya stream_filter_prepend() işlevine aktarılır.
süzgeciniz->stream | Süzülecek akım özkaynağı. Sadece closing değiştirgesine FALSE atanmışken yapılan filter() çağrılarında kullanılabilir.

void onClose ( void )

Bu yöntem süzgeç kapanırken çağrılır (genellikle, akım da bu sırada kapanır) ve flush yöntem çağrısından sonra çalıştırılır. onCreate() çağrısı ile oluşturulan veya ayrılan özkaynaklar varsa bunların elden çıkarılacağı veya serbest bırakılacağı yer burasıdır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

süzgeç zaten tanımlı bir süzgeçse FALSE döner.

Örnekler

Örnek 1 - foo-bar.txt akımında büyük harfe dönüşüm süzgeci

Aşağıdaki örnekte, foo-bar.txt akımında okunup yazılan tüm harfleri büyük harfe çeviren strtoupper isimli bir süzgeç gerçeklenmektedir.

<?php

/* Kendi süzgecimizi tanımlayalım */
class strtoupper_filter extends php_user_filter {
  function filter($in, $out, &$consumed, $closing)
  {
    while ($bucket = stream_bucket_make_writeable($in)) {
      $bucket->data = strtoupper($bucket->data);
      $consumed += $bucket->datalen;
      stream_bucket_append($out, $bucket);
    }
    return PSFS_PASS_ON;
  }
}

/* Süzgecimizi PHP'ye tanıtalım */
stream_filter_register("strtoupper", "strtoupper_filter")
    or die("Süzgecin tanıtımı başarısız oldu");

$fp = fopen("foo-bar.txt", "w");

/* Süzgeci açık akıma ekleyelim  */
stream_filter_append($fp, "strtoupper");

fwrite($fp, "Line1\n");
fwrite($fp, "Word - 2\n");
fwrite($fp, "Easy As 123\n");

fclose($fp);

/* İçeriği tekrar okuyalım */
readfile("foo-bar.txt");

?>

Yukarıdaki örneğin çıktısı:

LINE1
WORD - 2
EASY AS 123

Örnek 2 - Çok sayıda süzgeç ismiyle eşleşen soysal bir süzgeç sınıfının tanıtımı

<?php

/* Kendi süzgeç sınıfımızı tanımlayalım */
class string_filter extends php_user_filter {
  var $mode;

  function filter($in, $out, &$consumed, $closing)
  {
    while ($bucket = stream_bucket_make_writeable($in)) {
      if ($this->mode == 1) {
        $bucket->data = strtoupper($bucket->data);
      } elseif ($this->mode == 0) {
        $bucket->data = strtolower($bucket->data);
      }

      $consumed += $bucket->datalen;
      stream_bucket_append($out, $bucket);
    }
    return PSFS_PASS_ON;
  }

  function onCreate()
  {
    if ($this->filtername == 'str.toupper') {
      $this->mode = 1;
    } elseif ($this->filtername == 'str.tolower') {
      $this->mode = 0;
    } else {
      /* PHP'nin başka str.* süzgeçlerine bakması için
         başarısızlığı raporluyoruz */
      return false;
    }

    return true;
  }
}

/*Süzgecimizi PHP'ye tanıtalım */
stream_filter_register("str.*", "string_filter")
    or die("Süzgeç tanıtılamadı");

$fp = fopen("foo-bar.txt", "w");

/* Süzgeci açık akıma ekleyelim.
   Burada str.tolower süzgecini de ekleyebilirdik. */
stream_filter_append($fp, "str.toupper");

fwrite($fp, "Line1\n");
fwrite($fp, "Word - 2\n");
fwrite($fp, "Easy As 123\n");

fclose($fp);

/* İçeriği tekrar okuyalım */
readfile("foo-bar.txt");
?>

Yukarıdaki örneğin çıktısı:

LINE1
WORD - 2
EASY AS 123

Ayrıca Bakınız

  • stream_wrapper_register() - Bir PHP sınıfı olarak gerçeklenmiş bir URL sarmalayıcısını etkin kılar
  • stream_filter_append() - Süzgeç zincirinin sonuna bir süzgeç ekler
  • stream_filter_prepend() - Süzgeç zincirinin başına bir süzgeç ekler

stream_filter_prepend
stream_filter_remove
Akım İşlevleri


Akımdan bir süzgeci kaldırır

stream_filter_register
stream_get_contents
Akım İşlevleri
PHP Manual

stream_filter_remove

(PHP 5 >= 5.1.0, PHP 7)

stream_filter_remove — Akımdan bir süzgeci kaldırır

Açıklama

bool stream_filter_remove ( resource $süzgeç )

stream_filter_prepend() veya stream_filter_append() ile akıma eklenmiş bir akım süzgecini kaldırır. Süzgecin dahili tamponunda kalan veriler silinmeden önce tampon sonraki süzgece boşaltılır.

Değiştirgeler

süzgeç

Kaldırılacak akım süzgeci.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Bir akımın devingen olarak süzülmesi

<?php
/* Okuma ve yazma amacıyla bir dosya açalım */
$fp = fopen("test.txt", "rw");

$rot13_filter = stream_filter_append($fp, "string.rot13", STREAM_FILTER_WRITE);
fwrite($fp, "This is ");
stream_filter_remove($rot13_filter);
fwrite($fp, "a test\n");

rewind($fp);
fpassthru($fp);
fclose($fp);

?>

Yukarıdaki örneğin çıktısı:

Guvf vf a test

Ayrıca Bakınız

  • stream_filter_register() - Kullanıcı tanımlı bir akım süzgecini etkin kılar
  • stream_filter_append() - Süzgeç zincirinin sonuna bir süzgeç ekler
  • stream_filter_prepend() - Süzgeç zincirinin başına bir süzgeç ekler

stream_filter_register
stream_get_contents
Akım İşlevleri


Akımdan kalanı bir dizgeye okur

stream_filter_remove
stream_get_filters
Akım İşlevleri
PHP Manual

stream_get_contents

(PHP 5, PHP 7)

stream_get_contents — Akımdan kalanı bir dizgeye okur

Açıklama

string stream_get_contents ( resource $akım [, int $uzunluk = -1 [, int $konum = 0 ]] )

Evvelce açılmış bir akımla çalışması ve belirtilen akım'da kalan içeriğin konum'dan itibaren uzunluk bayta kadar kısmını döndürmesi dışında file_get_contents() işlevi gibidir.

Değiştirgeler

akım

fopen() gibi bir işlevden döndürülmüş bir akım özkaynağı.

uzunluk

Okunacak azami bayt sayısı. Öntanımlı değer -1 olup tamponda kalan tüm baytların okunacağı anlamına gelir.

konum

Okuma işlemine başlamadan önce gösterici buraya konumlanır.

Dönen Değerler

Başarısızlık durumunda FALSE aksi takdirde bir dizge döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.0 | konum değiştirgesi eklendi.

Örnekler

Örnek 1 - stream_get_contents() örneği

<?php

if ($stream = fopen('http://www.example.com', 'r')) {
    // 10. bayttan itibaren tüm sayfayı basalım
    echo stream_get_contents($stream, -1, 10);

    fclose($stream);
}

if ($stream = fopen('http://www.example.net', 'r')) {
    // İlk 5 baytı basalım
    echo stream_get_contents($stream, 5);

    fclose($stream);
}

?>

Notlar

Bilginize: Bu işlev ikil dosyalarla çalışırken dosya içeriğini değiştirmez.

Ayrıca Bakınız

  • fgets() - Dosya tanıtıcısından bir satır döndürür
  • fread() - Dosyayı ikil kipte okur
  • fpassthru() - Bir dosya tanıtıcısında kalan verinin tamamını çıktılar

stream_filter_remove
stream_get_filters
Akım İşlevleri


Etkin süzgeçlerin listesini döndürür

stream_get_contents
stream_get_line
Akım İşlevleri
PHP Manual

stream_get_filters

(PHP 5, PHP 7)

stream_get_filters — Etkin süzgeçlerin listesini döndürür

Açıklama

array stream_get_filters ( void )

Kurulu sistemdeki kullanılabilir süzgeçlerin listesini döndürür.

Dönen Değerler

Kurulu sistemdeki kullanılabilir süzgeçlerin isimlerini içeren indisli bir dizi döndürür.

Örnekler

Örnek 1 - stream_get_filters() örneği

<?php
$streamlist = stream_get_filters();
print_r($streamlist);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [0] => string.rot13
    [1] => string.toupper
    [2] => string.tolower
    [3] => string.strip_tags
    [4] => convert.*
    [5] => consumed
    [6] => bzip2.*
    [7] => convert.iconv.*
    [8] => zlib.*
    [9] => http.*
)

Ayrıca Bakınız

  • stream_filter_register() - Kullanıcı tanımlı bir akım süzgecini etkin kılar
  • stream_get_wrappers() - Etkin akımların listesini döndürür
stream_get_contents
stream_get_line
Akım İşlevleri


Akımdan belirtilen ayraca kadar bir satır döndürür

stream_get_filters
stream_get_meta_data
Akım İşlevleri
PHP Manual

stream_get_line

(PHP 5, PHP 7)

stream_get_line — Akımdan belirtilen ayraca kadar bir satır döndürür

Açıklama

string stream_get_line ( resource $akım , int $uzunluk [, string $ayraç ] )

Belirtilen akım'dan bir satır döndürür.

uzunluk baytlık veya daha önceyse ayraç karakterine veya dosya sonuna kadar okunan bayt sayısı uzunlukta bir dizge döndürür. Dönen dizge ayraç karakterini içermez.

Standart \n, \r, \r\n satır sonu ayraçlarından farklı ayraçlara izin vermesi ve dönen dizgenin bu ayracı içermemesi dışında fgets() işlevi gibidir.

Değiştirgeler

akım

Geçerli bir dosya tanıtıcısı.

uzunluk

Akımdan okunacak baytların sayısı.

ayraç

Okumanın duracağı karakter.

Dönen Değerler

En fazla uzunluk baytlık bir dizge döner.

Bir hata oluşursa FALSE döner.

Ayrıca Bakınız

  • fread() - Dosyayı ikil kipte okur
  • fgets() - Dosya tanıtıcısından bir satır döndürür
  • fgetc() - Dosya tanıtıcısından bir karakter döndürür
stream_get_filters
stream_get_meta_data
Akım İşlevleri


Akımdan başlıkları/meta verileri döndürür

stream_get_line
stream_get_transports
Akım İşlevleri
PHP Manual

stream_get_meta_data

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

stream_get_meta_data — Akımdan başlıkları/meta verileri döndürür

Açıklama

array stream_get_meta_data ( resource $akım )

Belirtilen akım hakkında bilgi döndürür.

Değiştirgeler

akım

fopen(), fsockopen() veya pfsockopen() tarafından oluşturulmuş bir akım.

Dönen Değerler

Elde edilen dizi şu elemanları içerir:

  • timed_out (bool) - Son fread() veya fgets() çağrısında veri beklerken akım zaman aşımına uğramışsa TRUE olur.

  • blocked (bool) - Akım engellenen kipteyse TRUE olur. Bakınız: stream_set_blocking().

  • eof (bool) - Dosya sonuna ulaşılmışsa TRUE olur. Okunmamış baytların sayısı (unread_bytes) sıfırdan farklı olsa bile soket akımları için bu üyenin değeri TRUE olabilir. Okunacak başka veri kalıp kalmadığını öğrenmek için bu üyenin değerine bakmak yerine feof() işlevini kullanın.

  • unread_bytes (int) - PHP'nin dahili tamponunda kalan bayt sayısı.

    Bilginize: Bu değeri bir betikte kullanmamalısınız.

  • stream_type (string) - Akımın alt yapısını açıklayan bir yafta.

  • wrapper_type (string) - Akımın üzerine yerleştiği protokol sarmalayıcı gerçeklenimini açıklayan yafta. Sarmalayıcılar hakkında ayrıntılı bilgi edinmek için Supported Protocols and Wrappers bölümüne bakınız.

  • wrapper_data (mixed) - Akıma ekli veriye özgü sarmalayıcı türü. Sarmalayıcılar ve sarmaladıkları veriler hakkında ayrıntılı bilgi edinmek için Supported Protocols and Wrappers bölümüne bakınız.

  • filters (array) - Bu akım üzerinde etkili süzgeçlerin isimlerini içeren bir dizi. Süzgeçler hakkında ayrıntılı bilgi edinmek için Kullanılabilir Süzgeçlerin Listesi bölümüne bakınız.

  • mode (string) - Akım için gereken erişim türü (fopen() sayfasındaki kipler tablosuna bakınız)

  • seekable (bool) - Akım konumlanabilir türdeyse TRUE olur.

  • uri (string) - Akımla ilişkili dosya veya dosya yolu.

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.0 | Dönen diziye mode, seekable ve uri girdiliri eklendi.
4.3.0 | Dönen diziye stream_type, wrapper_type, wrapper_data ve filters girdileri eklendi.
4.3.0 | socket_get_status() bu işleve takma ad oldu. PHP 4.3.0 öncesinde, sadece soketlere dayalı akımlarda ilk dört elemanı döndürmek için kullanılırdı.

Örnekler

Örnek 1 - stream_get_meta_data() örneği

<?php
$url = 'http://www.example.com/';

if (!$fp = fopen($url, 'r')) {
    trigger_error("URL ($url) açılamadı", E_USER_ERROR);
}

$meta = stream_get_meta_data($fp);

print_r($meta);

fclose($fp);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [wrapper_data] => Array
        (
            [0] => HTTP/1.1 200 OK
            [1] => Server: Apache/2.2.3 (Red Hat)
            [2] => Last-Modified: Tue, 15 Nov 2005 13:24:10 GMT
            [3] => ETag: "b300b4-1b6-4059a80bfd280"
            [4] => Accept-Ranges: bytes
            [5] => Content-Type: text/html; CHARSET=Windows-1254
            [6] => Set-Cookie: FOO=BAR; expires=Fri, 21-Dec-2012 12:00:00 GMT; path=/; domain=.example.com
            [6] => Connection: close
            [7] => Date: Fri, 16 Oct 2009 12:00:00 GMT
            [8] => Age: 1164
            [9] => Content-Length: 438
        )

    [wrapper_type] => http
    [stream_type] => tcp_socket/ssl
    [mode] => r
    [unread_bytes] => 438
    [seekable] =>
    [uri] => http://www.example.com/
    [timed_out] =>
    [blocked] => 1
    [eof] =>
)

Notlar

Bilginize:

Bu işlev, Soket eklentisi ile oluşturulan soketlerde çalışmaz.

Ayrıca Bakınız

  • get_headers() - Bir HTTP isteğine sunucunun verdiği yanıtta gönderilen tüm başlıkları döndürür
  • $http_response_header

stream_get_line
stream_get_transports
Akım İşlevleri


Etkin soket aktarımlarının listesini döndürür

stream_get_meta_data
stream_get_wrappers
Akım İşlevleri
PHP Manual

stream_get_transports

(PHP 5, PHP 7)

stream_get_transports — Etkin soket aktarımlarının listesini döndürür

Açıklama

array stream_get_transports ( void )

Kurulu sistemdeki kullanılabilir soket aktarımlarının listesini döndürür.

Dönen Değerler

Kurulu sistemdeki kullanılabilir soket aktarımlarının isimlerini içeren indisli bir dizi döndürür.

Örnekler

Örnek 1 - stream_get_transports() örneği

<?php
$xportlist = stream_get_transports();
print_r($xportlist);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [0] => tcp
    [1] => udp
    [2] => unix
    [3] => udg
    [4] => ssl
    [5] => sslv3
    [6] => sslv2
    [7] => tls
)

Ayrıca Bakınız

  • stream_get_filters() - Etkin süzgeçlerin listesini döndürür
  • stream_get_wrappers() - Etkin akımların listesini döndürür
stream_get_meta_data
stream_get_wrappers
Akım İşlevleri


Etkin akımların listesini döndürür

stream_get_transports
stream_is_local
Akım İşlevleri
PHP Manual

stream_get_wrappers

(PHP 5, PHP 7)

stream_get_wrappers — Etkin akımların listesini döndürür

Açıklama

array stream_get_wrappers ( void )

Kurulu sistemdeki kullanılabilir akımların listesini döndürür.

Dönen Değerler

Kurulu sistemdeki kullanılabilir akımların listesini içeren indisli bir dizi döndürür.

Örnekler

Örnek 1 - stream_get_wrappers() örneği

<?php
print_r(stream_get_wrappers());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [0] => zip
    [1] => php
    [2] => file
    [3] => glob
    [4] => data
    [5] => http
    [6] => ftp
    [7] => compress.bzip2
    [8] => https
    [9] => ftps
    [10] => compress.zlib
    [11] => phar
)

Örnek 2 - Bir akım sarmalayıcının varlığının sınanması

<?php
// bzip2 akım sarmalayıcısı var mıymış, bir bakalım
if (in_array('compress.bzip2', stream_get_wrappers())) {
    echo 'compress.bzip2:// desteği var.';
} else {
    echo 'compress.bzip2:// desteği yok.';
}
?>

Ayrıca Bakınız

  • stream_wrapper_register() - Bir PHP sınıfı olarak gerçeklenmiş bir URL sarmalayıcısını etkin kılar
stream_get_transports
stream_is_local
Akım İşlevleri


Akım, bir yerel akımsa TRUE döner

stream_get_wrappers
stream_notification_callback
Akım İşlevleri
PHP Manual

stream_is_local

(PHP 5 >= 5.2.4, PHP 7)

stream_is_local — Akım, bir yerel akımsa TRUE döner

Açıklama

bool stream_is_local ( mixed $akım_veya_url )

akım_veya_url ile belirtilen URL veya akım bir yerel akımsa TRUE döner.

Değiştirgeler

akım_veya_url

Sınanacak akım özkaynağı veya URL.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - stream_is_local() örneği

Basit bir kullanım örneği.

<?php
var_dump(stream_is_local("http://example.com"));
var_dump(stream_is_local("/etc"));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(false)
bool(true)

stream_get_wrappers
stream_notification_callback
Akım İşlevleri


notification bağlam değiştirgesi için bir geri çağırım işlevi

stream_is_local
stream_register_wrapper
Akım İşlevleri
PHP Manual

stream_notification_callback

(PHP 5 >= 5.2.0, PHP 7)

stream_notification_callback — notification bağlam değiştirgesi için bir geri çağırım işlevi

Açıklama

void stream_notification_callback ( int $bildirim_kodu , int $önem , string $ileti , int $ileti_kodu , int $bayt_sayısı , int $azami_bayt_sayısı )

Bir olay sırasında çağrılmak üzere notification bağlam değiştirgesi tarafından kullanılan bir geriçağırım işlevi.

Bilginize:

Bu gerçek bir işlev olmayıp, kullanacağınız işlevin bir örneği olarak tasarlanmıştır.

Değiştirgeler

bildirim_kodu

STREAM_NOTIFY_* bildirim sabitlerinden biri.

önem

STREAM_NOTIFY_SEVERITY_* bildirim sabitlerinden biri.

ileti

Olayı açıklayan bir ileti.

ileti_kodu

Olay için kullanılabilecek açıklayıcı bir ileti kodu.

Bu değerin anlamı kullanılacak sarmalayıcıya bağlıdır.

bayt_sayısı

Uygulanabilirse, aktarılacak baytların sayısı.

azami_bayt_sayısı

Uygulanabilirse, aktarılacak baytların azami sayısı.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 - stream_notification_callback() örneği

<?php
function stream_notification_callback($bildirim_kodu, $önem, $ileti,
                      $ileti_kodu, $bayt_sayısı, $azami_bayt_sayısı) {

    switch($bildirim_kodu) {
        case STREAM_NOTIFY_RESOLVE:
        case STREAM_NOTIFY_AUTH_REQUIRED:
        case STREAM_NOTIFY_COMPLETED:
        case STREAM_NOTIFY_FAILURE:
        case STREAM_NOTIFY_AUTH_RESULT:
            var_dump($bildirim_kodu, $önem, $ileti, $ileti_kodu,
                     $bayt_sayısı, $azami_bayt_sayısı);
            /* yoksay */
            break;

        case STREAM_NOTIFY_REDIRECTED:
            echo "Yönlendirildiği yer: ", $ileti;
            break;

        case STREAM_NOTIFY_CONNECT:
            echo "Bağlandı...";
            break;

        case STREAM_NOTIFY_FILE_SIZE_IS:
            echo "Alınan dosya boyu: ", $azami_bayt_sayısı;
            break;

        case STREAM_NOTIFY_MIME_TYPE_IS:
            echo "Bulunan MIME türü: ", $ileti;
            break;

        case STREAM_NOTIFY_PROGRESS:
            echo "Biraz işlem yapılıp, ", $bayt_sayısı, " bayt indirildi";
            break;
    }
    echo "\n";
}

$ctx = stream_context_create(null, array("notification" => "stream_notification_callback"));

file_get_contents("http://php.net/contact", false, $ctx);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Bağlandı...
Bulunan MIME türü: text/html; CHARSET=Windows-1254
Yönlendirildiği yer: http://no.php.net/contact
Bağlandı...
Alınan dosya boyu: 0
Bulunan MIME türü: text/html; CHARSET=Windows-1254
Yönlendirildiği yer: http://no.php.net/contact.php
Bağlandı...
Alınan dosya boyu: 4589
Bulunan MIME türü: text/html;CHARSET=Windows-1254
Biraz işlem yapılıp, 0 bayt indirildi
Biraz işlem yapılıp, 0 bayt indirildi
Biraz işlem yapılıp, 0 bayt indirildi
Biraz işlem yapılıp, 1440 bayt indirildi
Biraz işlem yapılıp, 2880 bayt indirildi
Biraz işlem yapılıp, 4320 bayt indirildi
Biraz işlem yapılıp, 5760 bayt indirildi
Biraz işlem yapılıp, 6381 bayt indirildi
Biraz işlem yapılıp, 7002 bayt indirildi

Örnek 2 - Komut satırı istemcisi için basit bir ilerleme çubuğu

<?php
function usage($argv) {
    echo Kullanım:\n";
    printf("\tphp %s <http://example.com/file> <yereldosya>\n", $argv[0]);
    exit(1);
}

function stream_notification_callback($bildirim_kodu, $önem, $ileti,
                      $ileti_kodu, $bayt_sayısı, $azami_bayt_sayısı) {
    static $dosyaboyu = null;

    switch($bildirim_kodu) {
    case STREAM_NOTIFY_RESOLVE:
    case STREAM_NOTIFY_AUTH_REQUIRED:
    case STREAM_NOTIFY_COMPLETED:
    case STREAM_NOTIFY_FAILURE:
    case STREAM_NOTIFY_AUTH_RESULT:
        /* yoksay */
        break;

    case STREAM_NOTIFY_REDIRECTED:
        echo "Yönlendirildiği yer: ", $ileti, "\n";
        break;

    case STREAM_NOTIFY_CONNECT:
        echo "Bağlandı...\n";
        break;

    case STREAM_NOTIFY_FILE_SIZE_IS:
        $dosyaboyu = $azami_bayt_sayısı;
        echo "Dosya uzunluğu: ", $dosyaboyu, "\n";
        break;

    case STREAM_NOTIFY_MIME_TYPE_IS:
        echo "MIME türü: ", $ileti, "\n";
        break;

    case STREAM_NOTIFY_PROGRESS:
        if ($bayt_sayısı > 0) {
            if (!isset($dosyaboyu)) {
                printf("\rDosya uzunluğu bilinmiyor... %2d kb alındı..",
                      $bayt_sayısı/1024);
            } else {
                $length = (int)(($bayt_sayısı/$dosyaboyu)*100);
                printf("\r[%-100s] %%%d (%2d/%2d kb)", str_repeat("=",
                $length). ">", $length, ($bayt_sayısı/1024), $dosyaboyu/1024);
            }
        }
        break;
    }
}

isset($argv[1], $argv[2]) or usage($argv);

$ctx = stream_context_create(null,
          array("notification" => "stream_notification_callback"));

$fp = fopen($argv[1], "r", false, $ctx);
if (is_resource($fp) && file_put_contents($argv[2], $fp)) {
    echo "\nBitti!\n";
    exit(0);
}

$err = error_get_last();
echo "\nHataaaa..\n", $err["message"], "\n";
exit(1);
?>

Yukarıdaki örneği şu komutla çalıştıralım: php -n fetch.php http://no2.php.net/get/php-5-LATEST.tar.bz2/from/this/mirror php-latest.tar.bz2. Çıktı şöyle olacaktır:

Bağlandı...
MIME türü: text/html; CHARSET=Windows-1254
Yönlendirildiği yer: http://no2.php.net/distributions/php-5.2.5.tar.bz2
Bağlandı...
Dosya uzunluğu: 7773024
MIME türü: application/octet-stream
[===============>                       ] %40 (3076/7590 kb)

Ayrıca Bakınız

  • Bağlam değiştirgeleri

stream_is_local
stream_register_wrapper
Akım İşlevleri


stream_wrapper_register işlevinin takma adıdır

stream_notification_callback
stream_resolve_include_path
Akım İşlevleri
PHP Manual

stream_register_wrapper

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

stream_register_wrapper — stream_wrapper_register() işlevinin takma adıdır

Açıklama

Bu işlev stream_wrapper_register() işlevinin takma adıdır.

stream_notification_callback
stream_resolve_include_path
Akım İşlevleri


Bir göreli yol ile yapılacak fopen çağrısıyla açılacak dosyayı belirler

stream_register_wrapper
stream_select
Akım İşlevleri
PHP Manual

stream_resolve_include_path

(PHP 5 >= 5.3.2, PHP 7)

stream_resolve_include_path — Bir göreli yol ile yapılacak fopen() çağrısıyla açılacak dosyayı belirler

Açıklama

string stream_resolve_include_path ( string $dosya [, resource $bağlam ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

stream_register_wrapper
stream_select
Akım İşlevleri


Belirtilen akım dizisi üzerinde belirtilen zaman aşımı ile select() sistem çağrısının eşdeğeri olarak çalışır

stream_resolve_include_path
stream_set_blocking
Akım İşlevleri
PHP Manual

stream_select

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

stream_select — Belirtilen akım dizisi üzerinde belirtilen zaman aşımı ile select() sistem çağrısının eşdeğeri olarak çalışır

Açıklama

int stream_select ( array &$oku , array &$yaz , array &$dış , int $saniye [, int $mikrosaniye = 0 ] )

stream_select() işlevi akımları diziler halinde kabul eder ve durumları değişinceye kadar bekler. Akımlar üzerinde işlem yapması dışında socket_select() işlevinin benzeridir.

Değiştirgeler

oku

oku dizisindeki akımlar için veri okunabilir hale gelene kadar beklenir (daha doğrusu, okumanın engellenmediğini görene kadar - özellikle de akım özkaynağının dosya sonunda olduğu, fread() işlevinin sıfır uzunlukta bir dizge döndürdüğü duruma kadar).

yaz

yaz dizisindeki akımlar için yazmanın engellenmediği görülene kadar beklenir.

dış

dış dizisindeki akımlar için yüksek öncelikli istisnai ("band dışı") veri gelinceye kadar beklenir.

Bilginize:

stream_select() dönerken oku, yaz ve hariç dizilerinde akım özkaynaklarının değişen durumlarını belirten değişklikler yapılır.

stream_select() işlevine bu dizilerin hepsini aktarmak zorunda değilsiniz. Kullanmayacağınız dizileri ya boş bırakın ya da dizi yerine NULL belirtin. Ayrıca, bu dizilerin gönderimli aktarıldıklarını ve stream_select() dönerken bunlarda değişiklik yapılacağını da unutmayın.
saniye

Son iki değiştirgenin toplamı stream_select() işlevinin dönmeden önce bekleyebileceği zaman aşımı süresini belirler. Bu değiştirgelerin ikisine de 0 belirtilirse stream_select() veri için beklemeden akımların durum bilgisiyle hemen dönecektir.

saniye değiştirgesinde NULL belirtilirse stream_select(), izlediği akımlardan birinde bir olay vuku bulana kadar (veya sistem çağrısı bir sinyal ile durdurulana kadar), gerekirse sonsuza kadar engellenebilir.

Uyarı

Zaman aşımı olarak 0 belirtilmesi akımların anlık durumlarının dönmesini sağlar. Ancak, işlevi sıfır zaman aşımı ile bir döngüye sokmak çok fazla işlemci zamanı harcanacağından iyi bir fikir değildir.

Bir kaç saniyelik bir zaman aşımı belirtmek ve bu arada diğer denetimleri ve işlemleri yapmak daha iyidir. 200000 mikrosaniyelik bir zaman aşımı betiğinizin işlemci kullanımını düşürmenize yardımcı olacaktır.

Zaman aşımı değerinin beklenecek azami süreyi belirttiğini unutmayın. stream_select() işlevi istenen akımlar kullanıma hazır olunca, sürenin bitmesini beklemeden dönecektir.

mikrosaniye

saniye değiştirgesinin açıklamasına bakınız.

Dönen Değerler

stream_select() işlevi başarı durumunda değişikliğe uğrayan akımların sayısını döndürür. Hiçbir olay vuku bulmadan zaman aşımı dolmuşsa işlev 0 döndürebilir. Bir hata durumunda işlev FALSE döndürür ve bir uyarı çıktılanır (sistem çağrısı bir sinyal ile kesilince de bu olur).

Örnekler

Örnek 1 - stream_select() örneği

Bu örnekte $oku1 ve $oku2 akımlarına okumak için bir veri gelmiş mi diye bakılmaktadır. Zaman aşımı değeri 0 olduğundan işlev beklemeden dönmektedir.

<?php
/* Oku dizisini hazırlayalım */
$oku = array($oku1, $oku2);
$yaz = NULL;
$dış = NULL;
if (false === ($değişen_akım_sayısı = stream_select($oku, $yaz, $dış, 0))) {
    /* Hata durumunda yapılacaklar */
} elseif ($değişen_akım_sayısı > 0) {
    /* Akımların en azından birinde değişiklik olmuş  */
}
?>

Notlar

Bilginize:

Zend motorunun sınırlamalarından dolayı, gönderimli aktarılan bir değiştirgeye doğrudan NULL belirtmek mümkün değildir. Bu nedenle NULL değerini doğrudan değil, bir değişken veya bir ifade üzerinden belirtin:

<?php
$d = NULL;
stream_select($o, $y, $d, 0);
?>

Bilginize:

Hat durumlarını sınarken === işlecini kullanmanız gerektiğini unutmayın. Çünkü işlev 0 döndürdüğünde == işleci bunu TRUE olarak değerlendirir. Örnek:

<?php
$d = NULL;
if (false === stream_select($o, $y, $d, 0)) {
    echo "stream_select() başarısız oldu\n";
}
?>

Bilginize:

Bir akıma okuma/yazma işlemi yapıyorsanız işlemek istediğiniz verinin tamamını işleme sokabileceğiniz gibi bir kanıya kapılmayın. Bazen ilk baytta işlem duruverir.

Bilginize:

Windows uyumluluğu: Windows 98 altında, proc_open() işlevinden dönen bir boru üzerinde stream_select() kullanımı veri kaybına sebep olabilir.

Windows altında, proc_open() işlevinden dönen dosya tanıtıcıları üzerinde stream_select() kullanımı başarısız olabilir ve FALSE dönebilir.

Ayrıca Bakınız

  • stream_set_blocking() - Akımın engelleme kipini ayarlar
stream_resolve_include_path
stream_set_blocking
Akım İşlevleri


Akımın engelleme kipini ayarlar

stream_select
stream_set_chunk_size
Akım İşlevleri
PHP Manual

stream_set_blocking

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

stream_set_blocking — Akımın engelleme kipini ayarlar

Açıklama

bool stream_set_blocking ( resource $akım , int $kip )

Belirtilen akım'ın engelleme kipini ayarlar.

Bu işlev, engellenmeyen kipi destekleyen her akımla çalışır (şimdilik, normal dosyalar ve soket akımları).

Değiştirgeler

akım

Dosya tanıtıcı.

kip

0 belirtilirse engellenmeyen kipe, 1 belirtilirse engellenen kipe geçilir. Bu, fgets() ve fread() gibi akımdan okuma yapan işlevleri etkiler. Engellenmeyen kipte bir fgets() çağrısı hemen dönerken, engellenen kipte akımdan veriyi alana kadar bekler.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.0 | PHP 4.3.0 öncesinde bu işlev sadece soketlere dayalı akımlarla çalışırdı.

Notlar

Bilginize:

Bu işlevin ismi başta set_socket_blocking() idi, sonradan socket_set_blocking() oldu, fakat artık bu isimlerin kullanımı önerilmiyor.

Ayrıca Bakınız

  • stream_select() - Belirtilen akım dizisi üzerinde belirtilen zaman aşımı ile select() sistem çağrısının eşdeğeri olarak çalışır
stream_select
stream_set_chunk_size
Akım İşlevleri


Set the stream chunk size

stream_set_blocking
stream_set_read_buffer
Akım İşlevleri
PHP Manual

stream_set_chunk_size

(PHP 5 >= 5.4.0, PHP 7)

stream_set_chunk_size — Set the stream chunk size

Açıklama

int stream_set_chunk_size ( resource $fp , int $chunk_size )

Set the stream chunk size.

Değiştirgeler

fp

The target stream.

chunk_size

The desired new chunk size.

Dönen Değerler

Returns the previous chunk size on success.

Will return FALSE if chunk_size is less than 1 or greater than PHP_INT_MAX.

Hatalar/İstisnalar

Will emit an E_WARNING level error if chunk_size is less than 1 or greater than PHP_INT_MAX.

stream_set_blocking
stream_set_read_buffer
Akım İşlevleri


Set read file buffering on the given stream

stream_set_chunk_size
stream_set_timeout
Akım İşlevleri
PHP Manual

stream_set_read_buffer

(PHP 5 >= 5.3.3, PHP 7)

stream_set_read_buffer — Set read file buffering on the given stream

Açıklama

int stream_set_read_buffer ( resource $stream , int $buffer )

Sets the read buffer. It's the equivalent of stream_set_write_buffer(), but for read operations.

Değiştirgeler

stream

The file pointer.

buffer

The number of bytes to buffer. If buffer is 0 then read operations are unbuffered. This ensures that all reads with fread() are completed before other processes are allowed to read from that input stream.

Dönen Değerler

Returns 0 on success, or another value if the request cannot be honored.

Ayrıca Bakınız

  • stream_set_write_buffer() - Dosya tamponunu ayarlar
stream_set_chunk_size
stream_set_timeout
Akım İşlevleri


Akımın zaman aşımı süresini ayarlar

stream_set_read_buffer
stream_set_write_buffer
Akım İşlevleri
PHP Manual

stream_set_timeout

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

stream_set_timeout — Akımın zaman aşımı süresini ayarlar

Açıklama

bool stream_set_timeout ( resource $akım , int $saniye [, int $mikrosaniye = 0 ] )

Belirtilen akım'ın zaman aşımı süresini saniye ve mikrosaniye toplamına ayarlar.

Akım zaman aşımına uğrarsa stream_get_meta_data() işlevi tarafından döndürülen dizinin 'timed_out' anahtarına TRUE atanır, fakat herhangi bir hata veya uyarı üretilmez.

Değiştirgeler

akım

Hedef akım.

saniye

Zaman aşımı süresinin saniye sayısı.

mikrosaniye

Zaman aşımı süresinin son saniyesinden sonraki mikrosaniyelerin sayısı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.0 | PHP 4.3'ten itibaren bu işlev (hemen hemen) her çeşit akımla çalışabilmektedir. PHP 4.3'te soketlere dayalı akımlar, PHP çekirdeği tarafından desteklenen tek akım türü olmakla beraber diğer eklentilerdeki akımlar bu işlevi destekleyebiliyordu.

Örnekler

Örnek 1 - stream_set_timeout() örneği

<?php
$fp = fsockopen("www.example.com", 80);
if (!$fp) {
    echo "Dosya açılamadı\n";
} else {

    fwrite($fp, "GET / HTTP/1.0\r\n\r\n");
    stream_set_timeout($fp, 2);
    $res = fread($fp, 2000);

    $info = stream_get_meta_data($fp);
    fclose($fp);

    if ($info['timed_out']) {
        echo 'Bağlantı zaman aşımına uğradı!';
    } else {
        echo $res;
    }

}
?>

Notlar

Bilginize:

Bu işlev, stream_socket_recvfrom() gibi ileri düzey işlemler için çalışmaz. Onlar için zaman aşımını stream_select() işlevi ile ayarlayın.

Bu işlevin ismi başta set_socket_timeout() idi, sonra socket_set_timeout() oldu, fakat artık bu isimlerin kullanımı önerilmiyor.

Ayrıca Bakınız

  • fsockopen() - Bir internet veya Unix alan soketi bağlantısı açar
  • fopen() - Bir dosya veya URL'yi açar
stream_set_read_buffer
stream_set_write_buffer
Akım İşlevleri


Dosya tamponunu ayarlar

stream_set_timeout
stream_socket_accept
Akım İşlevleri
PHP Manual

stream_set_write_buffer

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

stream_set_write_buffer — Dosya tamponunu ayarlar

Açıklama

int stream_set_write_buffer ( resource $akım , int $tampon )

akım üzerinde yazma işlemleri için tampon baytlık tamponu etkin kılar.

Normalde fwrite() tamponu 8K'lıktır. Yani, aynı çıktı akımına (dosyaya) yazmak isteyen iki süreç varsa her biri diğerini 8K'lık veri yazana kadar bekler.

Değiştirgeler

akım

Dosya tanıtıcısı.

tampon

Tamponun bayt sayısı. 0 belirtilirse yazma işlemleri tamponsuz yapılır. Böylece, çıktı akımına dığer süreçlerin yazmasına izin vermeden önce fwrite() ile yapılan tüm yazma işlemlerinin tamamlanması sağlanır.

Dönen Değerler

İstek yerine getirilememişse EOF, işlem başarılmışsa 0 döner.

Örnekler

Örnek 1 - stream_set_write_buffer() örneği

Aşağıdaki örnekte stream_set_write_buffer() işlevinin bir tamponsuz akım oluşturmak için kullanımı gösterilmiştir.

<?php
$dt = fopen($file, "w");
if ($dt) {
  stream_set_write_buffer($dt, 0);
  fwrite($dt, $output);
  fclose($dt);
}
?>

Ayrıca Bakınız

  • fopen() - Bir dosya veya URL'yi açar
  • fwrite() - Dosyaya ikil kipte yazar
stream_set_timeout
stream_socket_accept
Akım İşlevleri


stream_socket_server ile oluşturulmuş bir soketten bağlantı kabul eder

stream_set_write_buffer
stream_socket_client
Akım İşlevleri
PHP Manual

stream_socket_accept

(PHP 5, PHP 7)

stream_socket_accept — stream_socket_server() ile oluşturulmuş bir soketten bağlantı kabul eder

Açıklama

resource stream_socket_accept ( resource $sunucu_soketi [, float $süre = ini_get("default_socket_timeout") [, string &$hedef ]] )

Evvelden stream_socket_server() ile oluşturulmuş bir soketten bağlantı kabul eder.

Değiştirgeler

süre

Öntanımlı soket kabul zaman aşımını geçersiz kılar. Zaman saniye cinsinden belirtilir.

hedef

Seçilen aktarıma dahil edilmişse ve kullanılabilirse bağlanacak istemcinin ismi (adresi).

Bilginize:

stream_socket_get_name() kullanarak daha sonra da saptanabilir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

Uyarı

Bu işlev UDP sunucu soketleri ile kullanılmamalıdır. Yerine, stream_socket_recvfrom() ve stream_socket_sendto() kullanın.

Ayrıca Bakınız

  • stream_socket_server() - Bir Genel Ağ veya Unix alan sunucusu soketi oluşturur
  • stream_socket_get_name() - Yerel veya uzak soketin ismini döndürür
  • stream_set_blocking() - Akımın engelleme kipini ayarlar
  • stream_set_timeout() - Akımın zaman aşımı süresini ayarlar
  • fgets() - Dosya tanıtıcısından bir satır döndürür
  • fgetss() - Dosya tanıtıcısından bir satırı HTML etiketlerinden arındırarak döndürür
  • fwrite() - Dosyaya ikil kipte yazar
  • fclose() - Açık bir dosya tanıtıcısını kapatır
  • feof() - Bir dosya tanıtıcısı üzerinde konum dosya sonunda mı diye bakar
  • cURL İşlevleri

stream_set_write_buffer
stream_socket_client
Akım İşlevleri


Bir Genel Ağ veya Unix alan soketi bağlantısı açar

stream_socket_accept
stream_socket_enable_crypto
Akım İşlevleri
PHP Manual

stream_socket_client

(PHP 5, PHP 7)

stream_socket_client — Bir Genel Ağ veya Unix alan soketi bağlantısı açar

Açıklama

resource stream_socket_client ( string $uzak_soket [, int &$hatanum [, string &$ileti [, float $süre = ini_get("default_socket_timeout") [, int $seçenekler = STREAM_CLIENT_CONNECT [, resource $bağlam ]]]]] )

uzak_soket ile belirtilen hedefe bir akım veya verikatarı bağlantısı açar. Oluşturulacak soketin türü standart URL biçemi kullanılarak belirtilir: şema://hedef. TCP ve UDP gibi Genel Ağ Alanı soketleri (AF_INET) için, uzak_soket'in hedef parçası bir konak ismi veya IP adresinden sonra gelen bir ikinokta imi ve bir port numarasından oluşur. Unix alan soketleri için hedef parçası ise dosya sistemi üstündeki bir soket dosyasını göstermelidir.

Bilginize:

Akım öntanımlı olarak engellenebilen türde açılır. stream_set_blocking() işlevini kullanarak engellenmeyen kipe geçebilirsiniz.

Değiştirgeler

uzak_soket

Bağlanılacak soketin adresi.

hatanum

Bağlantı başarısız olursa sistem seviyesindeki hatanın numarası bu değiştirgeye atanır.

ileti

Bağlantı başarısız olursa sistem seviyesindeki hatanın açıklaması bu değiştirgeye atanır.

süre

connect() sistem çağrısının zaman aşımına uğrayacağı saniye sayısı.

Bilginize: Bu değiştirge sadece eşzamansız bağlantı yapılmaya çalışılmıyorsa uygulanır.

Bilginize:

Soket üzerinde veri okumak veya yazmak için zaman aşımı, sokete bağlantı yapılırken uygulanacak şekilde sadece stream_set_timeout() tarafından belirlenir.

seçenekler

Bağlantı seçeneklerinin birleşimi olarak bir bit maskesi. Geçerli bağlantı seçenekleri: STREAM_CLIENT_CONNECT (öntanımlı), STREAM_CLIENT_ASYNC_CONNECT ve STREAM_CLIENT_PERSISTENT.

bağlam

stream_context_create() ile oluşturulmuş geçerli bir bağlam özkaynağı.

Dönen Değerler

Başarısızlık durumunda FALSE, aksi takdirde fgets(), fgetss(), fwrite(), fclose() ve feof() gibi diğer dosya işlevleri ile kullanılmak üzere bir akım özkaynağı döner.

Hatalar/İstisnalar

Seçimlik hatanum ve ileti değiştirgeleri belirtilmişse, bunlara socket(), bind() ve listen() sistem çağrılarında oluşan sistem seviyesindeki hatanın bilgisi atanır. Eğer hatanum değiştirgesinde 0 döndüğünde işlev FALSE döndürmüşse hata, bind() çağrısından önce oluşmuş demektir. Bu sorunla çoğunlukla soketin ilklendirilmesi sırasında karşılaşılır. hatanum ve ileti değiştirgelerinin daima gönderimli aktarıldıklarına dikkat ediniz.

Örnekler

Örnek 1 - stream_socket_client() örneği

<?php
$fp = stream_socket_client("tcp://www.example.com:80", $errno, $errstr, 30);
if (!$fp) {
    echo "$errstr ($errno)<br />\n";
} else {
    fwrite($fp, "GET / HTTP/1.0\r\nHost: www.example.com\r\nAccept: */*\r\n\r\n");
    while (!feof($fp)) {
        echo fgets($fp, 1024);
    }
    fclose($fp);
}
?>

Örnek 2 - UDP bağlantı kullanımı

localhost üzerindeki "daytime" (port 13) UDP hizmetinden tarih ve saati öğrenmek.

<?php
$fp = stream_socket_client("udp://127.0.0.1:13", $errno, $errstr);
if (!$fp) {
    echo "HATA: $errno - $errstr<br />\n";
} else {
    fwrite($fp, "\n");
    echo fread($fp, 26);
    fclose($fp);
}
?>

Notlar

Uyarı

UDP soketler bazen, uzak konağa erişilemediği halde hata vermeksizin açılmış gibi görünür. Hata sadece bağlantıya veri okuyup yazmaya çalıştığında ortaya çıkar. Bunun sebebi UDP'nin bir bağlantısız protokol olmasıdır. Bağlantısız protokollerde işletim sistemi, asıl veri alınıncaya veya gönderilinceye kadar sokete bir bağlantı oluşturmaya çalışmaz.

Bilginize: Bir sayısal IPv6 adresi (fe80::1 gibi) belirtirken port numarasıda belirtmek isterseniz IP adresini köşeli ayraçlar arasına almalısınız. Örnek: tcp://[fe80::1]:80.

Bilginize:

Platforma bağlı olarak, Unix alan soketleri mevcut olmayabilir. Kullanılabilecek aktarım çeşitlerinin listesi stream_get_transports() işlevi ile alınabilir. Yerleşik aktarım türlerinin tam listesini Desteklenen Soket Aktarımlarının Listesi sayfasında bulabilirsiniz.

Ayrıca Bakınız

  • stream_socket_server() - Bir Genel Ağ veya Unix alan sunucusu soketi oluşturur
  • stream_set_blocking() - Akımın engelleme kipini ayarlar
  • stream_set_timeout() - Akımın zaman aşımı süresini ayarlar
  • stream_select() - Belirtilen akım dizisi üzerinde belirtilen zaman aşımı ile select() sistem çağrısının eşdeğeri olarak çalışır
  • fgets() - Dosya tanıtıcısından bir satır döndürür
  • fgetss() - Dosya tanıtıcısından bir satırı HTML etiketlerinden arındırarak döndürür
  • fwrite() - Dosyaya ikil kipte yazar
  • fclose() - Açık bir dosya tanıtıcısını kapatır
  • feof() - Bir dosya tanıtıcısı üzerinde konum dosya sonunda mı diye bakar
  • cURL İşlevleri

stream_socket_accept
stream_socket_enable_crypto
Akım İşlevleri


Bağlı bir soket üzerinde şifrelemeyi açıp kapatır

stream_socket_client
stream_socket_get_name
Akım İşlevleri
PHP Manual

stream_socket_enable_crypto

(PHP 5 >= 5.1.0, PHP 7)

stream_socket_enable_crypto — Bağlı bir soket üzerinde şifrelemeyi açıp kapatır

Açıklama

mixed stream_socket_enable_crypto ( resource $akım , bool $etkin [, int $şifre_türü [, resource $oturum_akımı ]] )

Akım üzerinde şifreleme yapılıp yapılmayacağını belirler.

Şifreleme ile ilgili ayarlar bir kere etkin olunca, etkin değiştirgesine TRUE veya FALSE belirterek devingen olarak şifrelemenin yapılıp yapılmayacağını belirleyebilirsiniz.

Değiştirgeler

akım

Akım özkaynağı.

etkin

TRUE belirtilirse akım üzerinde şifreleme yapılır, FALSE belirtilirse yapılmaz.

şifre_türü

Akım üzerinde etkin kılınacak şifreleme yöntemini belirler. Geçerli yöntemler:

  • STREAM_CRYPTO_METHOD_SSLv2_CLIENT
  • STREAM_CRYPTO_METHOD_SSLv3_CLIENT
  • STREAM_CRYPTO_METHOD_SSLv23_CLIENT
  • STREAM_CRYPTO_METHOD_TLS_CLIENT
  • STREAM_CRYPTO_METHOD_SSLv2_SERVER
  • STREAM_CRYPTO_METHOD_SSLv3_SERVER
  • STREAM_CRYPTO_METHOD_SSLv23_SERVER
  • STREAM_CRYPTO_METHOD_TLS_SERVER

oturum_akımı

oturum_akımı akımındaki ayarlarla akımı tohumlar.

Dönen Değerler

Başarı durumunda TRUE, uzlaşılamazsa FALSE, yeterli veri yoksa ve tekrar denemeniz gerekiyorsa 0 döner (sadece engellenmeyen soketlerde).

Örnekler

Örnek 1 - stream_socket_enable_crypto() örneği

<?php
$fp = stream_socket_client("tcp://myproto.example.com:31337", $errno, $errstr, 30);
if (!$fp) {
    die("Bağlantı kurulamadı: $errstr ($errno)");
}

/* Oturum açma aşaması için şifrelemeyi etkin kılalım */
stream_socket_enable_crypto($fp, true, STREAM_CRYPTO_METHOD_SSLv23_CLIENT);
fwrite($fp, "USER god\r\n");
fwrite($fp, "PASS secret\r\n");

/* Artık şifrelemeye ihtiyaç kalmadı */
stream_socket_enable_crypto($fp, false);

while ($motd = fgets($fp)) {
    echo $motd;
}

fclose($fp);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ayrıca Bakınız

  • OpenSSL İşlevleri
    •

  • Desteklenen Soket Aktarımlarının Listesi
    •

stream_socket_client

stream_socket_get_name

Akım İşlevleri


Yerel veya uzak soketin ismini döndürür

stream_socket_enable_crypto
stream_socket_pair
Akım İşlevleri
PHP Manual

stream_socket_get_name

(PHP 5, PHP 7)

stream_socket_get_name — Yerel veya uzak soketin ismini döndürür

Açıklama

string stream_socket_get_name ( resource $soket , bool $uzak )

Belrtilen soket bağlantısının yerel veya uzak ismini döndürür.

Değiştirgeler

soket

İsmi öğrenilecek soket özkaynağı.

uzak

TRUE belirtilirse uzak soket ismi, FALSE belirtilirse yerel soket ismi döner.

Dönen Değerler

Soket ismi.

Ayrıca Bakınız

  • stream_socket_accept() - stream_socket_server ile oluşturulmuş bir soketten bağlantı kabul eder

stream_socket_enable_crypto
stream_socket_pair
Akım İşlevleri


Soket akımlarınca ayırt edilebilen bir bağlantı çifti oluşturur

stream_socket_get_name
stream_socket_recvfrom
Akım İşlevleri
PHP Manual

stream_socket_pair

(PHP 5 >= 5.1.0, PHP 7)

stream_socket_pair — Soket akımlarınca ayırt edilebilen bir bağlantı çifti oluşturur

Açıklama

array stream_socket_pair ( int $alan , int $tür , int $protokol )

stream_socket_pair() işlevi, soket akımlarınca ayırt edilebilen bir bağlantı çifti oluşturur. Bu işlev genellikle süreçler arası iletişimde kullanılır.

Değiştirgeler

alan

Kullanılacak protokol ailesi: STREAM_PF_INET, STREAM_PF_INET6 veya STREAM_PF_UNIX

tür

Kullanılacak iletişim türü: STREAM_SOCK_DGRAM, STREAM_SOCK_RAW, STREAM_SOCK_RDM, STREAM_SOCK_SEQPACKET veya STREAM_SOCK_STREAM

protokol

Kullanılacak protokol: STREAM_IPPROTO_ICMP, STREAM_IPPROTO_IP, STREAM_IPPROTO_RAW, STREAM_IPPROTO_TCP veya STREAM_IPPROTO_UDP

Bilginize: Bu sabitlerle ilgili açıklamalar için Akım sabitleri listesine bakınız.

Dönen Değerler

Başarısızlık durumunda FALSE. aksi takdirde iki soket özkaynağı içerem bir dizi döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | Bu işlev artık Windows üzerinde de kullanılabiliyor.

Örnekler

Örnek 1 - stream_socket_pair() örneği

Süreçler arası iletişimde stream_socket_pair() işlevinin kullanılımını gösteren bir örnek:

<?php

$sockets = stream_socket_pair(STREAM_PF_UNIX, STREAM_SOCK_STREAM, STREAM_IPPROTO_IP);
$pid     = pcntl_fork();

if ($pid == -1) {
     die('süreç çatallanamadı');

} else if ($pid) {
     /* ebeveyn */
    fclose($sockets[0]);

    fwrite($sockets[1], "child PID: $pid\n");
    echo fgets($sockets[1]);

    fclose($sockets[1]);

} else {
    /* çocuk */
    fclose($sockets[1]);

    fwrite($sockets[0], "alt süreçten bir ileti var\n");
    echo fgets($sockets[0]);

    fclose($sockets[0]);
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

child PID: 1378
alt süreçten bir ileti var

stream_socket_get_name
stream_socket_recvfrom
Akım İşlevleri


Bağlı olsun ya da olmasın bir soketten veri alır

stream_socket_pair
stream_socket_sendto
Akım İşlevleri
PHP Manual

stream_socket_recvfrom

(PHP 5, PHP 7)

stream_socket_recvfrom — Bağlı olsun ya da olmasın bir soketten veri alır

Açıklama

string stream_socket_recvfrom ( resource $soket , int $uzunluk [, int $seçenekler = 0 [, string &$adres ]] )

stream_socket_recvfrom() işlevi uzak bir soketten uzunluk baytlık veri alır.

Değiştirgeler

soket

Uzak soket.

uzunluk

soket'tan alınacak bayt sayısı.

seçenekler

seçenekler şunların bir birleşimi olarak belirtilebilir:

seçenekler için olası değerler
STREAM_OOB | Band dışı veri alınır.
STREAM_PEEK | Veri soketten alınır fakat tampon okunmamış bırakılır. Sonraki fread() veya stream_socket_recvfrom() çağrıları aynı veriyi görür.

adres

Belirtildiği takdirde uzak soketin adresi olarak ele alınır.

Dönen Değerler

Okunan veriyi dizge olarak döndürür.

Örnekler

Örnek 1 - stream_socket_recvfrom() örneği

<?php
/* localhost üzerinde 1234 portuna bir sunucu soketi açalım */
$server = stream_socket_server('tcp://127.0.0.1:1234');

/* Bir bağlantı kabul edelim */
$socket = stream_socket_accept($server);

/* Band dışı veri olarak bir paket yakalayalım (MTU boyutu 1500 olsun) */
echo "Alınan band dışı veri: '" .
      stream_socket_recvfrom($socket, 1500, STREAM_OOB) . "'\n";

/* Normal band dışı veriye bir göz atalım ama okunmamış bırakalım */
echo "Veri: '" . stream_socket_recvfrom($socket, 1500, STREAM_PEEK) . "'\n";

/* Aynı paketi tekrar alalım ama bu sefer tampondan silelim */
echo "Veri: '" . stream_socket_recvfrom($socket, 1500) . "'\n";

/* Portu kapatalım */
fclose($socket);
fclose($server);
?>

Notlar

Bilginize:

uzunluk bayttan daha uzun bir veri alınırsa, verinin alındığı soketin türüne bağlı olarak (UDP gibi) fazla baytlar iptal edilebilir.

Bilginize:

Sokete dayalı akımlar üzerindeki
stream_socket_recvfrom() çağrıları, tamponlu akım
işlevlerinden (fread() veya
stream_get_line() gibi) sonra, veriyi soketten akım
tamponunu devreden çıkararak doğrudan doğruya okur.

Ayrıca Bakınız

  • stream_socket_sendto() - Bir sokete bağlı olsun ya da olmasın, bir ileti gönderir
  • stream_socket_client() - Bir Genel Ağ veya Unix alan soketi bağlantısı açar
  • stream_socket_server() - Bir Genel Ağ veya Unix alan sunucusu soketi oluşturur
stream_socket_pair
stream_socket_sendto
Akım İşlevleri


Bir sokete bağlı olsun ya da olmasın, bir ileti gönderir

stream_socket_recvfrom
stream_socket_server
Akım İşlevleri
PHP Manual

stream_socket_sendto

(PHP 5, PHP 7)

stream_socket_sendto — Bir sokete bağlı olsun ya da olmasın, bir ileti gönderir

Açıklama

int stream_socket_sendto ( resource $soket , string $veri [, int $seçenekler = 0 [, string $adres ]] )

soket üzerinden belirtilen veriyi gönderir.

Değiştirgeler

soket

Verinini gönderileceği soket.

veri

Gönderilecek veri.

seçenekler

seçenekler değeri aşağıdakilerin bir birleşimi olabilir:

seçenekler değiştirgesi için olası değerler
STREAM_OOB Band-dışı veri gönderir.

adres

Bu değiştirgede bir adres belirtilmezse soket akımı oluşturulurken belirtilen adres kullanılır.

Bir adres belirtilecekse IPv4 notkalı dördül (veya IPv6) adres belirtilmelidir.

Dönen Değerler

Sonuçlanan kod bir tamsayı olarak döner.

Örnekler

Örnek 1 - stream_socket_sendto() örneği

<?php
/* localhost üzerinde 1234 portunu açalım */
$socket = stream_socket_client('tcp://127.0.0.1:1234');

/* Alışılmış kanallardan sıradan bir veri gönderelim. */
fwrite($socket, "Normal veri aktarımı.");

/* Band dışı olarak biraz daha veri gönderelim. */
stream_socket_sendto($socket, "Band Dışı Veri.", STREAM_OOB);

/* Portu kapatalım */
fclose($socket);
?>

Ayrıca Bakınız

  • stream_socket_recvfrom() - Bağlı olsun ya da olmasın bir soketten veri alır
  • stream_socket_client() - Bir Genel Ağ veya Unix alan soketi bağlantısı açar
  • stream_socket_server() - Bir Genel Ağ veya Unix alan sunucusu soketi oluşturur
stream_socket_recvfrom
stream_socket_server
Akım İşlevleri


Bir Genel Ağ veya Unix alan sunucusu soketi oluşturur

stream_socket_sendto
stream_socket_shutdown
Akım İşlevleri
PHP Manual

stream_socket_server

(PHP 5, PHP 7)

stream_socket_server — Bir Genel Ağ veya Unix alan sunucusu soketi oluşturur

Açıklama

resource stream_socket_server ( string $yerel_soket [, int &$hatanum [, string &$ileti [, int $seçenekler = STREAM_SERVER_BIND | STREAM_SERVER_LISTEN [, resource $bağlam ]]]] )

Belirtilen yerel_soket üzerinde bir akım veya verikatarı soketi oluşturur.

Bu işlev, stream_socket_accept() kullanarak veri kabul etmek üzere bir soket oluşturmaktan başka bir şey yapmaz.

Değiştirgeler

yerel_soket

Oluşturulacak soketin türü standart URL biçemi kullanılarak belirtilir: şema://hedef.

TCP ve UDP gibi Genel Ağ Alanı soketleri (AF_INET) için, uzak_soket'in hedef parçası bir konak ismi veya IP adresinden sonra gelen bir ikinokta imi ve bir port numarasından oluşur. Unix alan soketleri için hedef parçası ise dosya sistemi üstündeki bir soket dosyasını göstermelidir.

Platforma bağlı olarak, Unix alan soketleri mevcut olmayabilir. Kullanılabilecek aktarım çeşitlerinin listesi stream_get_transports() işlevi ile alınabilir. Yerleşik aktarım türlerinin tam listesini Desteklenen Soket Aktarımlarının Listesi sayfasında bulabilirsiniz.

hatanum

Seçimlik hatanum ve ileti değiştirgeleri belirtilmişse, bunlara socket(), bind() ve listen() sistem çağrılarında oluşan sistem seviyesindeki hatanın bilgisi atanır. Eğer hatanum değiştirgesinde 0 döndüğünde işlev FALSE döndürmüşse hata, bind() çağrısından önce oluşmuş demektir. Bu sorunla çoğunlukla soketin ilklendirilmesi sırasında karşılaşılır. hatanum ve ileti değiştirgelerinin daima gönderimli aktarıldıklarına dikkat ediniz.

ileti

hatanum değiştirgesinin açıklamasına bakınız.

seçenekler

Soket oluşturma seçeneklerinden oluşan bir bit maskesi. Öntanımlı değer: STREAM_SERVER_BIND | STREAM_SERVER_LISTEN.

Bilginize:

UDP soketleri için, bu değiştirgeyle STREAM_SERVER_BIND değerini aktarmalısınız.

bağlam

stream_context_create() ile oluşturulmuş geçerli bir bağlam özkaynağı.

Dönen Değerler

Bir hata durumunda FALSE, aksi takdirde oluşturulan soketi döndürür.

Örnekler

Örnek 1 - TCP sunucu soketlerinin kullanımı

<?php
$socket = stream_socket_server("tcp://0.0.0.0:8000", $errno, $errstr);
if (!$socket) {
  echo "$errstr ($errno)<br />\n";
} else {
  while ($conn = stream_socket_accept($socket)) {
    fwrite($conn, 'Yerel zaman: ' . date('n/j/Y g:i a') . "\n");
    fclose($conn);
  }
  fclose($socket);
}
?>

Aşağıdaki örnekte, stream_socket_client() işleviyle ilgili örneklerden birinde yapılan bir zaman sorgusuna bir zaman sunucusunun yanıt vermesi için neler yapıldığı gösterilmiştir.

Bilginize: Çoğu sistem, 1024'ten küçük portları oluşturmak için root yetkisine ihtiyaç duyar.

Örnek 2 - UDP sunucu soketlerinin kullanımı

<?php
$socket = stream_socket_server("udp://127.0.0.1:1113", $errno, $errstr, STREAM_SERVER_BIND);
if (!$socket) {
    die("$errstr ($errno)");
}

do {
    $pkt = stream_socket_recvfrom($socket, 1, 0, $peer);
    echo "$peer\n";
    stream_socket_sendto($socket, date("D M j H:i:s Y\r\n"), 0, $peer);
} while ($pkt !== false);

?>

Notlar

Bilginize: Bir sayısal IPv6 adresi (fe80::1 gibi) belirtirken port numarasıda belirtmek isterseniz IP adresini köşeli ayraçlar arasına almalısınız. Örnek: tcp://[fe80::1]:80.

Ayrıca Bakınız

  • stream_socket_client() - Bir Genel Ağ veya Unix alan soketi bağlantısı açar
  • stream_set_blocking() - Akımın engelleme kipini ayarlar
  • stream_set_timeout() - Akımın zaman aşımı süresini ayarlar
  • fgets() - Dosya tanıtıcısından bir satır döndürür
  • fgetss() - Dosya tanıtıcısından bir satırı HTML etiketlerinden arındırarak döndürür
  • fwrite() - Dosyaya ikil kipte yazar
  • fclose() - Açık bir dosya tanıtıcısını kapatır
  • feof() - Bir dosya tanıtıcısı üzerinde konum dosya sonunda mı diye bakar
  • Curl eklentisi
stream_socket_sendto
stream_socket_shutdown
Akım İşlevleri


Çift yönlü bağlantıyı kapatır

stream_socket_server
stream_supports_lock
Akım İşlevleri
PHP Manual

stream_socket_shutdown

(PHP 5 >= 5.2.1, PHP 7)

stream_socket_shutdown — Çift yönlü bağlantıyı kapatır

Açıklama

bool stream_socket_shutdown ( resource $akım , int $nasıl )

Bir çift yönlü bağlantıyı tamamen veya kısmen kapatır.

Değiştirgeler

akım

stream_socket_client() gibi bir işlevle açılmış bir akım.

nasıl

Şu sabitlerden biri olabilir: STREAM_SHUT_RD (okumayı kapatır), STREAM_SHUT_WR (yazmayı kapatır) veya STREAM_SHUT_RDWR (hem okumayı hem de yazmayı kapatır).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - stream_socket_shutdown() örneği

<?php

$server = stream_socket_server('tcp://127.0.0.1:1337');
$client = stream_socket_client('tcp://127.0.0.1:1337');

var_dump(fputs($client, "hello"));

stream_socket_shutdown($client, STREAM_SHUT_WR);
var_dump(fputs($client, "hello")); // çalışmaz

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(5)

Notice: fputs(): send of 5 bytes failed with errno=32 Broken pipe in
test.php on line 9
int(0)

Ayrıca Bakınız

  • fclose() - Açık bir dosya tanıtıcısını kapatır

stream_socket_server
stream_supports_lock
Akım İşlevleri


Akımın kilitlemeyi destekleyip desteklemediğine bakar

stream_socket_shutdown
stream_wrapper_register
Akım İşlevleri
PHP Manual

stream_supports_lock

(PHP 5 >= 5.3.0, PHP 7)

stream_supports_lock — Akımın kilitlemeyi destekleyip desteklemediğine bakar

Açıklama

bool stream_supports_lock ( resource $akım )

Akımın flock() üzerinden kilitlemeyi destekleyip desteklemediğine bakar.

Değiştirgeler

akım

Sınanacak akım.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • flock() - Taşınabilir tavsiye niteliğinde dosya kilitleme

stream_socket_shutdown
stream_wrapper_register
Akım İşlevleri


Bir PHP sınıfı olarak gerçeklenmiş bir URL sarmalayıcısını etkin kılar

stream_supports_lock
stream_wrapper_restore
Akım İşlevleri
PHP Manual

stream_wrapper_register

(PHP 4 >= 4.3.2, PHP 5, PHP 7)

stream_wrapper_register — Bir PHP sınıfı olarak gerçeklenmiş bir URL sarmalayıcısını etkin kılar

Açıklama

bool stream_wrapper_register ( string $protokol , string $sınıf [, int $seçenekler = 0 ] )

Dosya sistemi işlevleri (fopen(), fread() vb. gibi) ile kullanmak için kendi akım ve sarmalayıcılarınızı gerçeklemenizi sağlar.

Değiştirgeler

protokol

Etkin olacak sarmalayıcının ismi.

sınıf

protokol'ü gerçekleyen sınıfın ismi.

seçenekler

protokol bir URL protokolü ise STREAM_IS_URL olmalıdır. Öntanımlı değer 0 olup, yerel akıma karşılıktır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

protokol sarmalayıcısı zaten varsa FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.2.4 | seçenekler değiştirgesi eklendi.

Örnekler

Örnek 1 - Bir akım sarmalayıcının etkin kılınması

<?php
$existed = in_array("var", stream_get_wrappers());
if ($existed) {
    stream_wrapper_unregister("var");
}
stream_wrapper_register("var", "VariableStream");
$myvar = "";

$fp = fopen("var://myvar", "r+");

fwrite($fp, "line1\n");
fwrite($fp, "line2\n");
fwrite($fp, "line3\n");

rewind($fp);
while (!feof($fp)) {
    echo fgets($fp);
}
fclose($fp);
var_dump($myvar);

if ($existed) {
    stream_wrapper_restore("var");
}

?>

Yukarıdaki örneğin çıktısı:

line1
line2
line3
string(18) "line1
line2
line3
"

Ayrıca Bakınız

  • streamWrapper örnek sınıfı
  • Akım Sarmalayıcı olarak örnek bir sınıf tanımı
  • stream_wrapper_unregister() - Bir URL sarmalayıcısını iptal eder
  • stream_wrapper_restore() - İptal edilmiş yerleşik bir sarmalayıcıyı tekrar etkin kılar
  • stream_get_wrappers() - Etkin akımların listesini döndürür

stream_supports_lock
stream_wrapper_restore
Akım İşlevleri


İptal edilmiş yerleşik bir sarmalayıcıyı tekrar etkin kılar

stream_wrapper_register
stream_wrapper_unregister
Akım İşlevleri
PHP Manual

stream_wrapper_restore

(PHP 5 >= 5.1.0, PHP 7)

stream_wrapper_restore — İptal edilmiş yerleşik bir sarmalayıcıyı tekrar etkin kılar

Açıklama

bool stream_wrapper_restore ( string $protokol )

stream_wrapper_unregister() işlevi ile iptal edilmiş yerleşik bir sarmalayıcı tekrar etkin kılar.

Değiştirgeler

protokol

Etkin kılınacak yerleşik sarmalayıcı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

stream_wrapper_register
stream_wrapper_unregister
Akım İşlevleri


Bir URL sarmalayıcısını iptal eder

stream_wrapper_restore
Tidy
Akım İşlevleri
PHP Manual

stream_wrapper_unregister

(PHP 5 >= 5.1.0, PHP 7)

stream_wrapper_unregister — Bir URL sarmalayıcısını iptal eder

Açıklama

bool stream_wrapper_unregister ( string $protokol )

Tanımlı bir akım sarmalayıcısını iptal eder. İptal edilen bir sarmalayıcının yerine stream_wrapper_register() işlevi ile kullanıcı tanımlı bir sarmalayıcı koyabileceğiniz gibi stream_wrapper_restore() işlevi ile tekrar etkin kılabilirsiniz.

Değiştirgeler

protokol

İptal edilecek sarmalayıcı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

stream_wrapper_restore
Tidy
Akım İşlevleri


Tidy

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
    • Örnekler
  • Tidy — Tidy sınıfı
    • tidy::body — Çözümleme ağacının <body> etiketiyle başlayan tidyNode nesnesini döndürür
    • tidy::cleanRepair — Çözümlenen imlenim üzerinde bakım ve onarım yapar
    • tidy::__construct — Yeni bir tidy nesnesi oluşturur
    • tidy::diagnose — Çözümlenen veya onarılan imlenim üzerinde tanılama yapar
    • tidy::$errorBuffer — Return warnings and errors which occurred parsing the specified document
    • tidy::getConfig — Geçerli Tidy yapılandırmasını döndürür
    • tidy::htmlver — Belgenin algılanan HTML sürümünü döndürür
    • tidy::getOpt — Belirtilen yapılandırma seçeneğinin değerini döndürür
    • tidy::getoptdoc — Belirtilen seçenekle ilgili belgeyi döndürür
    • tidy::getRelease — Tidy kütüphanesinin dağıtım tarihini döndürür
    • tidy::getStatus — Belgenin durumunu döndürür
    • tidy::head — Çözümleme ağacının <head> etiketiyle başlayan tidyNode nesnesini döndürür
    • tidy::html — Çözümleme ağacının <html> etiketiyle başlayan tidyNode nesnesini döndürür
    • tidy::isXhtml — Belge bir XHTML belge mi diye bakar
    • tidy::isXml — Belge salt bir XML (HTML/XHTML değil) belge mi diye bakar
    • tidy::parseFile — Belirtilen URI veya dosyadaki imlenimi çözümler
    • tidy::parseString — Bir dizge olarak belirtilen bir belgeyi çözümler
    • tidy::repairFile — Bir dosyayı onarıp bir dizge olarak döndürür
    • tidy::repairString — Seçimlik bir yapılandırma dosyasını kullanarak bir dizgeyi onarır
    • tidy::root — Çözümleme ağacının kökünü temsil eden bir tidyNode nesnesi döndürür
  • TidyNode — TidyNode sınıfı
    • tidyNode::getParent — Geçerli düğümün ebeveynini döndürür
    • tidyNode::hasChildren — Düğümün çocukları olup olmadığına bakar
    • tidyNode::hasSiblings — Düğümün kardeşleri olup olmadığına bakar
    • tidyNode::isAsp — Düğümün bir ASP düğümü olup olmadığına bakar
    • tidyNode::isComment — Düğüm bir açıklama düğümü mü diye bakar
    • tidyNode::isHtml — Düğümün bir HTML belge parçası olup olmadığına bakar
    • tidyNode::isJste — Düğümün bir JSTE düğümü olup olmadığına bakar
    • tidyNode::isPhp — Düğümün bir PHP düğümü olup olmadığına bakar
    • tidyNode::isText — Düğümün bir metin düğümü olup olmadığına bakar
  • Tidy İşlevleri
    • ob_tidyhandler — Tampon onarımı için ob_start geriçağırım işlevi
    • tidy_access_count — Belgede saptanan Tidy erişilebilirlik uyarılarının sayısını döndürür
    • tidy_config_count — Belgede saptanan Tidy yapılandırma hatalarının sayısını döndürür
    • tidy_error_count — Belgede saptanan Tidy hatalarının sayısını döndürür
    • tidy_get_output — Çözümlenen Tidy imlenimini bir dizge olarak döndürür
    • tidy_load_config — Bir Tidy yapılandırma dosyasını belirtilen kodlama ile yükler
    • tidy_reset_config — Tidy yapılandırmasını öntanımlı değerlere ayarlar
    • tidy_save_config — Geçerli ayarları belirtilen dosyaya kaydeder
    • tidy_set_encoding — Çözümlenecek imlenim için girdi/çıktı karakter kodlamasını belirler
    • tidy_setopt — Belgenin yapılandırma seçeneklerini günceller
    • tidy_warning_count — Belgede saptanan Tidy uyarılarının sayısını döndürür
stream_wrapper_unregister
Giriş
Diğer Temel Eklentiler


Giriş

Tidy eklentisi, Tidy HTML bakım ve onarım aracı için bir arayüzdür. HTML belgelerin temizliği ve değiştirilmesine ek olarak belge ağacında hareket edebilmenizi de sağlar.

Tidy
Yapılandırma/Kurulum
Tidy


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Tidy


Gereksinimler

Tidy'yi kullanmak için sisteminizde libtidy kurulu olmalıdır. Libtidy, » http://tidy.sourceforge.net/ adresindeki tidy sitesinden edinilebilir.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Tidy PHP 4.3.x ve PHP 5 için » http://pecl.php.net/package/tidy adresinden bir PECL eklentisi olarak temin edilebilir.

Bilginize:

Tidy 1.0, PHP 4.3.x için, Tidy 2.0 ise PHP 5 içindir.

*nix benzeri işletim sisteminizde » PEAR kurulu ise tidy eklentisini şu komutla kurabilirsiniz: pecl install tidy.

Bunun yanında tidy'yi bir tar.gz paketi olarak indirip kendiniz de kurabilirsiniz:

Örnek 1 - PHP 4.3.x'te tidy kurulumu

gunzip tidy-xxx.tgz
tar -xvf tidy-xxx.tar
cd tidy-xxx
phpize
./configure && make && make install

PHP 5'te yapacağınız tek şey PHP'yi --with-tidy seçeneği ile derlemektir.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Tidy Yapılandırma Yönergeleri
İsim | Öntanımlı Değeri | Değişiklik Yeri | Sürüm Bilgisi
tidy.default_config | "" | PHP_INI_SYSTEM | PHP 5.0.0'dan beri kullanılabilmektedir.
tidy.clean_output | "0" | PHP_INI_USER | PHP 5'te PHP_INI_PERDIR. PHP 5.0.0'dan beri kullanılabilmektedir.
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

tidy.default_config string

Tidy yapılandırma dosyasının öntanımlı yolu

tidy.clean_output boolean

Tidy tarafından çıktı onarımını açıp kapar.

Uyarı

Devingen resimler gibi HTML dışı içerik üretiyorsanız tidy.clean_output yönergesini etkinleştirmeyin.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

Her TIDY_TAG_XXX sabiti bir HTML etiketine karşılıktır. Örneğin, TIDY_TAG_A bir "<a href="XX">link</a>" etiketini ifade eder. Her TIDY_ATTR_XXX sabiti ise bir HTML özniteliğine karşılıktır. Örneğin, TIDY_ATTR_HREF önceki örnekteki href özniteliğine karşı düşecekti.

Şu sabitler tanımlıdır:

tidy etiket sabitleri
sabit
TIDY_TAG_UNKNOWN
TIDY_TAG_A
TIDY_TAG_ABBR
TIDY_TAG_ACRONYM
TIDY_TAG_ALIGN
TIDY_TAG_APPLET
TIDY_TAG_AREA
TIDY_TAG_B
TIDY_TAG_BASE
TIDY_TAG_BASEFONT
TIDY_TAG_BDO
TIDY_TAG_BGSOUND
TIDY_TAG_BIG
TIDY_TAG_BLINK
TIDY_TAG_BLOCKQUOTE
TIDY_TAG_BODY
TIDY_TAG_BR
TIDY_TAG_BUTTON
TIDY_TAG_CAPTION
TIDY_TAG_CENTER
TIDY_TAG_CITE
TIDY_TAG_CODE
TIDY_TAG_COL
TIDY_TAG_COLGROUP
TIDY_TAG_COMMENT
TIDY_TAG_DD
TIDY_TAG_DEL
TIDY_TAG_DFN
TIDY_TAG_DIR
TIDY_TAG_DIV
TIDY_TAG_DL
TIDY_TAG_DT
TIDY_TAG_EM
TIDY_TAG_EMBED
TIDY_TAG_FIELDSET
TIDY_TAG_FONT
TIDY_TAG_FORM
TIDY_TAG_FRAME
TIDY_TAG_FRAMESET
TIDY_TAG_H1
TIDY_TAG_H2
TIDY_TAG_H3
TIDY_TAG_H4
TIDY_TAG_H5
TIDY_TAG_H6
TIDY_TAG_HEAD
TIDY_TAG_HR
TIDY_TAG_HTML
TIDY_TAG_I
TIDY_TAG_IFRAME
TIDY_TAG_ILAYER
TIDY_TAG_IMG
TIDY_TAG_INPUT
TIDY_TAG_INS
TIDY_TAG_ISINDEX
TIDY_TAG_KBD
TIDY_TAG_KEYGEN
TIDY_TAG_LABEL
TIDY_TAG_LAYER
TIDY_TAG_LEGEND
TIDY_TAG_LI
TIDY_TAG_LINK
TIDY_TAG_LISTING
TIDY_TAG_MAP
TIDY_TAG_MARQUEE
TIDY_TAG_MENU
TIDY_TAG_META
TIDY_TAG_MULTICOL
TIDY_TAG_NOBR
TIDY_TAG_NOEMBED
TIDY_TAG_NOFRAMES
TIDY_TAG_NOLAYER
TIDY_TAG_NOSAVE
TIDY_TAG_NOSCRIPT
TIDY_TAG_OBJECT
TIDY_TAG_OL
TIDY_TAG_OPTGROUP
TIDY_TAG_OPTION
TIDY_TAG_P
TIDY_TAG_PARAM
TIDY_TAG_PLAINTEXT
TIDY_TAG_PRE
TIDY_TAG_Q
TIDY_TAG_RP
TIDY_TAG_RT
TIDY_TAG_RTC
TIDY_TAG_RUBY
TIDY_TAG_S
TIDY_TAG_SAMP
TIDY_TAG_SCRIPT
TIDY_TAG_SELECT
TIDY_TAG_SERVER
TIDY_TAG_SERVLET
TIDY_TAG_SMALL
TIDY_TAG_SPACER
TIDY_TAG_SPAN
TIDY_TAG_STRIKE
TIDY_TAG_STRONG
TIDY_TAG_STYLE
TIDY_TAG_SUB
TIDY_TAG_TABLE
TIDY_TAG_TBODY
TIDY_TAG_TD
TIDY_TAG_TEXTAREA
TIDY_TAG_TFOOT
TIDY_TAG_TH
TIDY_TAG_THEAD
TIDY_TAG_TITLE
TIDY_TAG_TR
TIDY_TAG_TR
TIDY_TAG_TT
TIDY_TAG_U
TIDY_TAG_UL
TIDY_TAG_VAR
TIDY_TAG_WBR
TIDY_TAG_XMP

tidy öznitelik sabitleri
sabit
TIDY_ATTR_UNKNOWN
TIDY_ATTR_ABBR
TIDY_ATTR_ACCEPT
TIDY_ATTR_ACCEPT_CHARSET
TIDY_ATTR_ACCESSKEY
TIDY_ATTR_ACTION
TIDY_ATTR_ADD_DATE
TIDY_ATTR_ALIGN
TIDY_ATTR_ALINK
TIDY_ATTR_ALT
TIDY_ATTR_ARCHIVE
TIDY_ATTR_AXIS
TIDY_ATTR_BACKGROUND
TIDY_ATTR_BGCOLOR
TIDY_ATTR_BGPROPERTIES
TIDY_ATTR_BORDER
TIDY_ATTR_BORDERCOLOR
TIDY_ATTR_BOTTOMMARGIN
TIDY_ATTR_CELLPADDING
TIDY_ATTR_CELLSPACING
TIDY_ATTR_CHAR
TIDY_ATTR_CHAROFF
TIDY_ATTR_CHARSET
TIDY_ATTR_CHECKED
TIDY_ATTR_CITE
TIDY_ATTR_CLASS
TIDY_ATTR_CLASSID
TIDY_ATTR_CLEAR
TIDY_ATTR_CODE
TIDY_ATTR_CODEBASE
TIDY_ATTR_CODETYPE
TIDY_ATTR_COLOR
TIDY_ATTR_COLS
TIDY_ATTR_COLSPAN
TIDY_ATTR_COMPACT
TIDY_ATTR_CONTENT
TIDY_ATTR_COORDS
TIDY_ATTR_DATA
TIDY_ATTR_DATAFLD
TIDY_ATTR_DATAPAGESIZE
TIDY_ATTR_DATASRC
TIDY_ATTR_DATETIME
TIDY_ATTR_DECLARE
TIDY_ATTR_DEFER
TIDY_ATTR_DIR
TIDY_ATTR_DISABLED
TIDY_ATTR_ENCODING
TIDY_ATTR_ENCTYPE
TIDY_ATTR_FACE
TIDY_ATTR_FOR
TIDY_ATTR_FRAME
TIDY_ATTR_FRAMEBORDER
TIDY_ATTR_FRAMESPACING
TIDY_ATTR_GRIDX
TIDY_ATTR_GRIDY
TIDY_ATTR_HEADERS
TIDY_ATTR_HEIGHT
TIDY_ATTR_HREF
TIDY_ATTR_HREFLANG
TIDY_ATTR_HSPACE
TIDY_ATTR_HTTP_EQUIV
TIDY_ATTR_ID
TIDY_ATTR_ISMAP
TIDY_ATTR_LABEL
TIDY_ATTR_LANG
TIDY_ATTR_LANGUAGE
TIDY_ATTR_LAST_MODIFIED
TIDY_ATTR_LAST_VISIT
TIDY_ATTR_LEFTMARGIN
TIDY_ATTR_LINK
TIDY_ATTR_LONGDESC
TIDY_ATTR_LOWSRC
TIDY_ATTR_MARGINHEIGHT
TIDY_ATTR_MARGINWIDTH
TIDY_ATTR_MAXLENGTH
TIDY_ATTR_MEDIA
TIDY_ATTR_METHOD
TIDY_ATTR_MULTIPLE
TIDY_ATTR_NAME
TIDY_ATTR_NOHREF
TIDY_ATTR_NORESIZE
TIDY_ATTR_NOSHADE
TIDY_ATTR_NOWRAP
TIDY_ATTR_OBJECT
TIDY_ATTR_OnAFTERUPDATE
TIDY_ATTR_OnBEFOREUNLOAD
TIDY_ATTR_OnBEFOREUPDATE
TIDY_ATTR_OnBLUR
TIDY_ATTR_OnCHANGE
TIDY_ATTR_OnCLICK
TIDY_ATTR_OnDATAAVAILABLE
TIDY_ATTR_OnDATASETCHANGED
TIDY_ATTR_OnDATASETCOMPLETE
TIDY_ATTR_OnDBLCLICK
TIDY_ATTR_OnERRORUPDATE
TIDY_ATTR_OnFOCUS
TIDY_ATTR_OnKEYDOWN
TIDY_ATTR_OnKEYPRESS
TIDY_ATTR_OnKEYUP
TIDY_ATTR_OnLOAD
TIDY_ATTR_OnMOUSEDOWN
TIDY_ATTR_OnMOUSEMOVE
TIDY_ATTR_OnMOUSEOUT
TIDY_ATTR_OnMOUSEOVER
TIDY_ATTR_OnMOUSEUP
TIDY_ATTR_OnRESET
TIDY_ATTR_OnROWENTER
TIDY_ATTR_OnROWEXIT
TIDY_ATTR_OnSELECT
TIDY_ATTR_OnSUBMIT
TIDY_ATTR_OnUNLOAD
TIDY_ATTR_PROFILE
TIDY_ATTR_PROMPT
TIDY_ATTR_RBSPAN
TIDY_ATTR_READONLY
TIDY_ATTR_REL
TIDY_ATTR_REV
TIDY_ATTR_RIGHTMARGIN
TIDY_ATTR_ROWS
TIDY_ATTR_ROWSPAN
TIDY_ATTR_RULES
TIDY_ATTR_SCHEME
TIDY_ATTR_SCOPE
TIDY_ATTR_SCROLLING
TIDY_ATTR_SELECTED
TIDY_ATTR_SHAPE
TIDY_ATTR_SHOWGRID
TIDY_ATTR_SHOWGRIDX
TIDY_ATTR_SHOWGRIDY
TIDY_ATTR_SIZE
TIDY_ATTR_SPAN
TIDY_ATTR_SRC
TIDY_ATTR_STANDBY
TIDY_ATTR_START
TIDY_ATTR_STYLE
TIDY_ATTR_SUMMARY
TIDY_ATTR_TABINDEX
TIDY_ATTR_TARGET
TIDY_ATTR_TEXT
TIDY_ATTR_TITLE
TIDY_ATTR_TOPMARGIN
TIDY_ATTR_TYPE
TIDY_ATTR_USEMAP
TIDY_ATTR_VALIGN
TIDY_ATTR_VALUE
TIDY_ATTR_VALUETYPE
TIDY_ATTR_VERSION
TIDY_ATTR_VLINK
TIDY_ATTR_VSPACE
TIDY_ATTR_WIDTH
TIDY_ATTR_WRAP
TIDY_ATTR_XML_LANG
TIDY_ATTR_XML_SPACE
TIDY_ATTR_XMLNS

tidy düğüm türü sabitleri
sabit | açıklama
TIDY_NODETYPE_ROOT | kök düğüm
TIDY_NODETYPE_DOCTYPE | belge türü
TIDY_NODETYPE_COMMENT | HTML açıklaması
TIDY_NODETYPE_PROCINS | İşlem komutu
TIDY_NODETYPE_TEXT | Metin
TIDY_NODETYPE_START | Başlangıç etiketi
TIDY_NODETYPE_END | Bitiş etiketi
TIDY_NODETYPE_STARTEND | Boş etiket
TIDY_NODETYPE_CDATA | CDATA
TIDY_NODETYPE_SECTION | XML bölümü
TIDY_NODETYPE_ASP | ASP kodu
TIDY_NODETYPE_JSTE | JSTE kodu
TIDY_NODETYPE_PHP | PHP kodu
TIDY_NODETYPE_XMLDECL | XML bildirimi

Özkaynak Türleri
Örnekler
Tidy


Örnekler
Tidy
PHP Manual

Örnekler

İçindekiler

  • Örnekler
Öntanımlı Sabitler
Örnekler
Tidy


Örnekler
Tidy
Örnekler
PHP Manual

Örnekler

Basit bir tidy kullanım örneği.

Örnek 1 - Temel Tidy Kullanımı

<?php
ob_start();
?>
<html>Bir HTML belge</html>
<?php
$html = ob_get_clean();

// Yapılandırmayı belirtelim
$config = array(
           'indent'         => true,
           'output-xhtml'   => true,
           'wrap'           => 200);

// Tidy tarafı
$tidy = new tidy;
$tidy->parseString($html, $config, 'utf8');
$tidy->cleanRepair();

// Çıktılayalım
echo $tidy;
?>

Örnekler
Tidy
Örnekler
PHP Manual


Tidy sınıfı

(PHP 5, PHP 7, PECL tidy >= 0.5.2)

Giriş

Tidy tarafından saptandığı haliyle bir HTML dosyasındaki bir HTML düğümü.

Sınıf Sözdizimi

Tidy {
/* Özellikler */
/* Yöntemler */
tidyNode tidy_get_body ( tidy $nesne )
bool tidy_clean_repair ( tidy $nesne )
tidy tidy::__construct ([ string $dosya [, mixed $ayarlar [, string $kodlama [, bool $include_path_kullan ]]]] )
bool tidy_diagnose ( tidy $nesne )
string tidy_get_error_buffer ( tidy $tidy )
array tidy_get_config ( tidy $nesne )
int tidy_get_html_ver ( tidy $nesne )
mixed tidy_getopt ( tidy $nesne , string $seçenek )
string tidy_get_opt_doc ( tidy $nesne , string $seçenek )
string tidy_get_release ( void )
int tidy_get_status ( tidy $nesne )
tidyNode tidy_get_head ( tidy $nesne )
tidyNode tidy_get_html ( tidy $nesne )
bool tidy_is_xhtml ( tidy $nesne )
bool tidy_is_xml ( tidy $nesne )
tidy tidy_parse_file ( string $dosya [, mixed $ayarlar [, string $kodlama [, bool $include_path_kullan = false ]]] )
tidy tidy_parse_string ( string $girdi [, mixed $ayarlar [, string $kodlama ]] )
string tidy_repair_file ( string $dosya [, mixed $ayarlar [, string $kodlama [, bool $include_path_kullan = false ]]] )
string tidy_repair_string ( string $veri [, mixed $ayarlar [, string $kodlama ]] )
tidyNode tidy::root ( void )
}

Özellikler

errorBuffer

TidyLib'en dönen son hata veya uyarı.

İçindekiler

  • tidy::body — Çözümleme ağacının <body> etiketiyle başlayan tidyNode nesnesini döndürür
  • tidy::cleanRepair — Çözümlenen imlenim üzerinde bakım ve onarım yapar
  • tidy::__construct — Yeni bir tidy nesnesi oluşturur
  • tidy::diagnose — Çözümlenen veya onarılan imlenim üzerinde tanılama yapar
  • tidy::$errorBuffer — Return warnings and errors which occurred parsing the specified document
  • tidy::getConfig — Geçerli Tidy yapılandırmasını döndürür
  • tidy::htmlver — Belgenin algılanan HTML sürümünü döndürür
  • tidy::getOpt — Belirtilen yapılandırma seçeneğinin değerini döndürür
  • tidy::getoptdoc — Belirtilen seçenekle ilgili belgeyi döndürür
  • tidy::getRelease — Tidy kütüphanesinin dağıtım tarihini döndürür
  • tidy::getStatus — Belgenin durumunu döndürür
  • tidy::head — Çözümleme ağacının <head> etiketiyle başlayan tidyNode nesnesini döndürür
  • tidy::html — Çözümleme ağacının <html> etiketiyle başlayan tidyNode nesnesini döndürür
  • tidy::isXhtml — Belge bir XHTML belge mi diye bakar
  • tidy::isXml — Belge salt bir XML (HTML/XHTML değil) belge mi diye bakar
  • tidy::parseFile — Belirtilen URI veya dosyadaki imlenimi çözümler
  • tidy::parseString — Bir dizge olarak belirtilen bir belgeyi çözümler
  • tidy::repairFile — Bir dosyayı onarıp bir dizge olarak döndürür
  • tidy::repairString — Seçimlik bir yapılandırma dosyasını kullanarak bir dizgeyi onarır
  • tidy::root — Çözümleme ağacının kökünü temsil eden bir tidyNode nesnesi döndürür
Örnekler
tidy::body
Tidy


Çözümleme ağacının <body> etiketiyle başlayan tidyNode nesnesini döndürür

Tidy
tidy::cleanRepair
Tidy
PHP Manual

tidy::body

tidy_get_body

(PHP 5, PHP 7, PECL tidy 0.5.2-1.0)

tidy::body -- tidy_get_body — Çözümleme ağacının <body> etiketiyle başlayan tidyNode nesnesini döndürür

Açıklama

Yordamsal kullanım

tidyNode tidy_get_body ( tidy $nesne )

Nesne yönelimli kullanım

tidyNode tidy::body ( void )

Çözümleme ağacının <body> etiketiyle başlayan tidyNode nesnesini döndürür

Değiştirgeler

nesne

Tidy nesnesi.

Dönen Değerler

Bir tidyNode nesnesi döner.

Uyarı

Bu işlevi henüz Tidylib gerçeklemediğinden şimdilik daima 0 döndürmektedir.

Örnekler

Örnek 1 - tidy::getBody() örneği

<?php
$html = '
<html>
  <head>
    <title>test</title>
  </head>
  <body>
    <p>paragraph</p>
  </body>
</html>';

$tidy = tidy_parse_string($html);

$body = $tidy->Body();
echo $body->value;
?>

Yukarıdaki örneğin çıktısı:

<body>
<p>paragraph</p>
</body>

Notlar

Bilginize: Bu işlev sadece Zend Motoru 2 (PHP >= 5.0.0) ile kullanılabilir.

Ayrıca Bakınız

  • tidy::head() - Çözümleme ağacının <head> etiketiyle başlayan tidyNode nesnesini döndürür
  • tidy::html() - Çözümleme ağacının <html> etiketiyle başlayan tidyNode nesnesini döndürür
Tidy
tidy::cleanRepair
Tidy


Çözümlenen imlenim üzerinde bakım ve onarım yapar

tidy::body
tidy::__construct
Tidy
PHP Manual

tidy::cleanRepair

tidy_clean_repair

(PHP 5, PHP 7, PECL tidy >= 0.5.2)

tidy::cleanRepair -- tidy_clean_repair — Çözümlenen imlenim üzerinde bakım ve onarım yapar

Açıklama

Yordamsal kullanım

bool tidy_clean_repair ( tidy $nesne )

Nesne yönelimli kullanım

bool tidy::cleanRepair ( void )

Belirtilen nesne üzerinde bakım ve onarım yapar.

Değiştirgeler

nesne

Tidy nesnesi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - tidy::cleanrepair() örneği

<?php
$html = '<p>test</I>';

$tidy = tidy_parse_string($html);
$tidy->cleanRepair();

echo $tidy;
?>

Yukarıdaki örneğin çıktısı:

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 3.2//EN">
<html>
<head>
<title></title>
</head>
<body>
<p>test</p>
</body>
</html>

Ayrıca Bakınız

  • tidy::repairFile() - Bir dosyayı onarıp bir dizge olarak döndürür
  • tidy::repairString() - Seçimlik bir yapılandırma dosyasını kullanarak bir dizgeyi onarır
tidy::body
tidy::__construct
Tidy


Yeni bir tidy nesnesi oluşturur

tidy::cleanRepair
tidy::diagnose
Tidy
PHP Manual

tidy::__construct

(PHP 5, PHP 7, PECL tidy >= 0.5.2)

tidy::__construct — Yeni bir tidy nesnesi oluşturur

Açıklama

tidy tidy::__construct ([ string $dosya [, mixed $ayarlar [, string $kodlama [, bool $include_path_kullan ]]]] )

Yeni bir tidy nesnesi oluşturur.

Değiştirgeler

dosya

Bu değiştirge belirtilmişse, işlev tidy::parseFile() işlevi gibi davranarak dosyayı okuyup nesneyi bu içerikten ilklendirir.

ayarlar

Bir dizge veya bir dizi olarak belirtilebilir. Dizge verildiği takdirde yapılandırma dosyasının ismi olarak ele alınır. Dizi olarak verildiğinde ise dizinin yapılandırma seçeneklerini içerdiği varsayılır.

Seçeneklerin açıklamaları için » http://tidy.sourceforge.net/docs/quickref.html adresine bakınız.

kodlama

Belge girdi çıktı kodlaması belirtilir. Olası değerler: ascii, latin0, latin1, raw, utf8, iso2022, mac, win1252, ibm858, utf16, utf16le, utf16be, big5 ve shiftjis.

include_path_kullan

Dosya include_path yönergesinde belirtilen yollarda aranır.

Dönen Değerler

Yeni tidy nesnesi.

Örnekler

Örnek 1 - tidy::__construct() örneği

<?php

$html = <<< HTML

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head><title>title</title></head>
<body>
<p>paragraph <bt />
text</p>
</body></html>

HTML;

$tidy = new tidy();
$tidy->ParseString($html);

$tidy->cleanRepair();

if ($tidy->errorBuffer) {
    echo "Saptanan hatalar:\n";
    echo $tidy->errorBuffer;
}

?>

Yukarıdaki örneğin çıktısı:

Saptanan hatalar:
line 8 column 14 - Error: <bt> is not recognized!
line 8 column 14 - Warning: discarding unexpected <bt>

Ayrıca Bakınız

  • tidy::parseFile() - Belirtilen URI veya dosyadaki imlenimi çözümler
  • tidy::parseString() - Bir dizge olarak belirtilen bir belgeyi çözümler
tidy::cleanRepair
tidy::diagnose
Tidy


Çözümlenen veya onarılan imlenim üzerinde tanılama yapar

tidy::__construct
tidy::$errorBuffer
Tidy
PHP Manual

tidy::diagnose

tidy_diagnose

(PHP 5, PHP 7, PECL tidy >= 0.5.2)

tidy::diagnose -- tidy_diagnose — Çözümlenen veya onarılan imlenim üzerinde tanılama yapar

Açıklama

Yordamsal kullanım

bool tidy_diagnose ( tidy $nesne )

Nesne yönelimli kullanım

bool tidy::diagnose ( void )

Belirtilen nesne'ye, hata tamponundaki belge hakkında bazı bilgiler ekleyerek tanılama uygular.

Değiştirgeler

nesne

Tidy nesnesi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - tidy::diagnose() örneği

<?php

$html = <<< HTML
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

<p>paragraph</p>
HTML;

$tidy = tidy_parse_string($html);
$tidy->cleanRepair();

// İki çıktı arasındaki farka dikkat edin
echo $tidy->errorBuffer . "\n";

$tidy->diagnose();
echo $tidy->errorBuffer;

?>

Yukarıdaki örneğin çıktısı:

line 4 column 1 - Warning: <p> isn't allowed in <head> elements
line 4 column 1 - Warning: inserting missing 'title' element
line 4 column 1 - Warning: <p> isn't allowed in <head> elements
line 4 column 1 - Warning: inserting missing 'title' element
Info: Doctype given is "-//W3C//DTD XHTML 1.0 Strict//EN"
Info: Document content looks like XHTML 1.0 Strict
2 warnings, 0 errors were found!

Ayrıca Bakınız

  • tidy::errorBuffer()
tidy::__construct
tidy::$errorBuffer
Tidy


Return warnings and errors which occurred parsing the specified document

tidy::diagnose
tidy::getConfig
Tidy
PHP Manual

tidy::$errorBuffer

tidy_get_error_buffer

(PHP 5, PHP 7, PECL tidy >= 0.5.2)

tidy::$errorBuffer -- tidy_get_error_buffer — Return warnings and errors which occurred parsing the specified document

Açıklama

Nesne yönelimli kullanım (property):

string $tidy->errorBuffer;

Yordamsal kullanım:

string tidy_get_error_buffer ( tidy $tidy )

Returns warnings and errors which occurred parsing the specified document.

Değiştirgeler

tidy

Tidy nesnesi.

Dönen Değerler

Returns the error buffer as a string.

Örnekler

Örnek 1 tidy_get_error_buffer() example

<?php
$html = '<p>paragraph</p>';

$tidy = tidy_parse_string($html);

echo tidy_get_error_buffer($tidy);
/* or in OO: */
echo $tidy->errorBuffer;
?>

Yukarıdaki örneğin çıktısı:

line 1 column 1 - Warning: missing <!DOCTYPE> declaration
line 1 column 1 - Warning: inserting missing 'title' element

Ayrıca Bakınız

  • tidy_access_count() - Belgede saptanan Tidy erişilebilirlik uyarılarının sayısını döndürür
  • tidy_error_count() - Belgede saptanan Tidy hatalarının sayısını döndürür
  • tidy_warning_count() - Belgede saptanan Tidy uyarılarının sayısını döndürür
tidy::diagnose
tidy::getConfig
Tidy


Geçerli Tidy yapılandırmasını döndürür

tidy::$errorBuffer
tidy::htmlver
Tidy
PHP Manual

tidy::getConfig

tidy_get_config

(PHP 5, PHP 7, PECL tidy >= 0.7.0)

tidy::getConfig -- tidy_get_config — Geçerli Tidy yapılandırmasını döndürür

Açıklama

Yordamsal kullanım

array tidy_get_config ( tidy $nesne )

Nesne yönelimli kullanım

array tidy::getConfig ( void )

Belirtilen Tidy nesne'sinin yapılandırma seçeneklerini bir dizi içinde döndürür.

Değiştirgeler

nesne

Tidy nesnesi.

Dönen Değerler

Yapılandırma seçeneklerini içeren bir dizi döndürür.

Seçeneklerin açıklamaları için » http://tidy.sourceforge.net/docs/quickref.html adresine bakınız.

Örnekler

Örnek 1 - tidy::getConfig() örneği

<?php
$html = '<p>deneme</p>';
$config = array('indent' => TRUE,
                'output-xhtml' => TRUE,
                'wrap' => 200);

$tidy = tidy_parse_string($html, $config);

print_r($tidy->getConfig());
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [indent-spaces] => 2
    [wrap] => 200
    [tab-size] => 8
    [char-encoding] => 1
    [input-encoding] => 3
    [output-encoding] => 1
    [newline] => 1
    [doctype-mode] => 1
    [doctype] =>
    [repeated-attributes] => 1
    [alt-text] =>
    [slide-style] =>
    [error-file] =>
    [output-file] =>
    [write-back] =>
    [markup] => 1
    [show-warnings] => 1
    [quiet] =>
    [indent] => 1
    [hide-endtags] =>
    [input-xml] =>
    [output-xml] => 1
    [output-xhtml] => 1
    [output-html] =>
    [add-xml-decl] =>
    [uppercase-tags] =>
    [uppercase-attributes] =>
    [bare] =>
    [clean] =>
    [logical-emphasis] =>
    [drop-proprietary-attributes] =>
    [drop-font-tags] =>
    [drop-empty-paras] => 1
    [fix-bad-comments] => 1
    [break-before-br] =>
    [split] =>
    [numeric-entities] =>
    [quote-marks] =>
    [quote-nbsp] => 1
    [quote-ampersand] => 1
    [wrap-attributes] =>
    [wrap-script-literals] =>
    [wrap-sections] => 1
    [wrap-asp] => 1
    [wrap-jste] => 1
    [wrap-php] => 1
    [fix-backslash] => 1
    [indent-attributes] =>
    [assume-xml-procins] =>
    [add-xml-space] =>
    [enclose-text] =>
    [enclose-block-text] =>
    [keep-time] =>
    [word-2000] =>
    [tidy-mark] =>
    [gnu-emacs] =>
    [gnu-emacs-file] =>
    [literal-attributes] =>
    [show-body-only] =>
    [fix-uri] => 1
    [lower-literals] => 1
    [hide-comments] =>
    [indent-cdata] =>
    [force-output] => 1
    [show-errors] => 6
    [ascii-chars] => 1
    [join-classes] =>
    [join-styles] => 1
    [escape-cdata] =>
    [language] =>
    [ncr] => 1
    [output-bom] => 2
    [replace-color] =>
    [css-prefix] =>
    [new-inline-tags] =>
    [new-blocklevel-tags] =>
    [new-empty-tags] =>
    [new-pre-tags] =>
    [accessibility-check] => 0
    [vertical-space] =>
    [punctuation-wrap] =>
    [merge-divs] => 1
)

Ayrıca Bakınız

  • tidy_reset_config() - Tidy yapılandırmasını öntanımlı değerlere ayarlar
  • tidy_save_config() - Geçerli ayarları belirtilen dosyaya kaydeder
tidy::$errorBuffer
tidy::htmlver
Tidy


Belgenin algılanan HTML sürümünü döndürür

tidy::getConfig
tidy::getOpt
Tidy
PHP Manual

tidy::htmlver

tidy_get_html_ver

(PHP 5, PHP 7, PECL tidy >= 0.5.2)

tidy::htmlver -- tidy_get_html_ver — Belgenin algılanan HTML sürümünü döndürür

Açıklama

Yordamsal kullanım

int tidy_get_html_ver ( tidy $nesne )

Nesne yönelimli kullanım

int tidy::getHtmlVer ( void )

Belgenin algılanan HTML sürümünü döndürür.

Değiştirgeler

nesne

Tidy nesnesi.

Dönen Değerler

Algılanan HTML sürüm numarasını döndürür.

Uyarı

Bu işlevi henüz Tidylib gerçeklemediğinden şimdilik daima 0 döndürmektedir.

tidy::getConfig
tidy::getOpt
Tidy


Belirtilen yapılandırma seçeneğinin değerini döndürür

tidy::htmlver
tidy::getoptdoc
Tidy
PHP Manual

tidy::getOpt

tidy_getopt

(PHP 5, PHP 7, PECL tidy >= 0.5.2)

tidy::getOpt -- tidy_getopt — Belirtilen yapılandırma seçeneğinin değerini döndürür

Açıklama

Yordamsal kullanım

mixed tidy_getopt ( tidy $nesne , string $seçenek )

Nesne yönelimli kullanım

mixed tidy::getOpt ( string $seçenek )

Belirtilen seçenek ile ilgili değeri döndürür.

Değiştirgeler

nesne

Tidy nesnesi.

seçenek

Seçeneklerin açıklamaları için » http://tidy.sourceforge.net/docs/quickref.html adresine bakınız.

Dönen Değerler

Belirtilen seçenek ile ilgili değeri döndürür. Dönüş türü seçeneğe göre değişir.

Örnekler

Örnek 1 - tidy_getopt() örneği

<?php

$html ='<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 3.2//EN">
<html><head><title>Başlık</title></head>
<body>

<p><img src="img.png"></p>

</body></html>';

$config = array('accessibility-check' => 3,
                'alt-text' => 'bir metin');

$tidy = new tidy();
$tidy->parseString($html, $config);

var_dump($tidy->getOpt('accessibility-check')); //integer
var_dump($tidy->getOpt('lower-literals')); //boolean
var_dump($tidy->getOpt('alt-text')); //string

?>

Yukarıdaki örneğin çıktısı:

int(3)
bool(true)
string(9) "bir metin"

tidy::htmlver
tidy::getoptdoc
Tidy


Belirtilen seçenekle ilgili belgeyi döndürür

tidy::getOpt
tidy::getRelease
Tidy
PHP Manual

tidy::getoptdoc

tidy_get_opt_doc

(PHP 5 >= 5.1.0, PHP 7)

tidy::getoptdoc -- tidy_get_opt_doc — Belirtilen seçenekle ilgili belgeyi döndürür

Açıklama

Yordamsal kullanım

string tidy_get_opt_doc ( tidy $nesne , string $seçenek )

Nesne yönelimli kullanım

string tidy::getOptDoc ( string $seçenek )

Belirtilen seçenekle ilgili belgeyi döndürür

Bilginize:

Bu işlevin kullanılabilmesi için en azından 25 Nisan 2005 tarihli libtidy gerekir.

Değiştirgeler

nesne

Tidy nesnesi.

seçenek

Seçenek ismi.

Dönen Değerler

Seçenek ve belgesi varsa bir dizge, yoksa FALSE döndürür.

Örnekler

Örnek 1 - Tüm seçeneklerin belgelerini ve öntanımlı değerlerini almak

<?php

$tidy = new tidy;
$config = $tidy->getConfig();

ksort($config);

foreach ($config as $opt => $val) {

    if (!$doc = $tidy->getOptDoc($opt))
        $doc = 'no documentation available!';

    $val = ($tidy->getOpt($opt) === true)  ? 'true'  : $val;
    $val = ($tidy->getOpt($opt) === false) ? 'false' : $val;

    echo "<p><b>$opt</b> (Öntanımlı değeri: '$val')<br />".
         "$doc</p><hr />\n";
}

?>

Ayrıca Bakınız

  • tidy::getconfig() - Geçerli Tidy yapılandırmasını döndürür
  • tidy::getopt() - Belirtilen yapılandırma seçeneğinin değerini döndürür

tidy::getOpt
tidy::getRelease
Tidy


Tidy kütüphanesinin dağıtım tarihini döndürür

tidy::getoptdoc
tidy::getStatus
Tidy
PHP Manual

tidy::getRelease

tidy_get_release

(PHP 5, PHP 7, PECL tidy >= 0.5.2)

tidy::getRelease -- tidy_get_release — Tidy kütüphanesinin dağıtım tarihini döndürür

Açıklama

Yordamsal kullanım

string tidy_get_release ( void )

Nesne yönelimli kullanım

string tidy::getRelease ( void )

Tidy kütüphanesinin dağıtım tarihini döndürür.

Dönen Değerler

Tidy kütüphanesinin dağıtım tarihini bir dizge olarak döndürür.

tidy::getoptdoc
tidy::getStatus
Tidy


Belgenin durumunu döndürür

tidy::getRelease
tidy::head
Tidy
PHP Manual

tidy::getStatus

tidy_get_status

(PHP 5, PHP 7, PECL tidy >= 0.5.2)

tidy::getStatus -- tidy_get_status — Belgenin durumunu döndürür

Açıklama

Yordamsal kullanım

int tidy_get_status ( tidy $nesne )

Nesne yönelimli kullanım

int tidy::getStatus ( void )

nesne ile belirtilen belgenin durumunu döndürür.

Değiştirgeler

nesne

Tidy nesnesi.

Dönen Değerler

Bir hata veya uyarı oluşmamışsa 0, uyarılar veya erişilebilirlik hataları için 1, hatalar için 2 döner.

Örnekler

Örnek 1 - tidy::getStatus() örneği

<?php
$html = '<p>paragraf</i>';
$tidy = new tidy();
$tidy->parseString($html);

$tidy2 = new tidy();
$html2 = '<bogus>deneme</bogus>';
$tidy2->parseString($html2);

echo $tidy->getStatus(); //1

echo $tidy2->getStatus(); //2
?>

tidy::getRelease
tidy::head
Tidy


Çözümleme ağacının <head> etiketiyle başlayan tidyNode nesnesini döndürür

tidy::getStatus
tidy::html
Tidy
PHP Manual

tidy::head

tidy_get_head

(PHP 5, PHP 7, PECL tidy 0.5.2-1.0.0)

tidy::head -- tidy_get_head — Çözümleme ağacının <head> etiketiyle başlayan tidyNode nesnesini döndürür

Açıklama

Yordamsal kullanım

tidyNode tidy_get_head ( tidy $nesne )

Nesne yönelimli kullanım

tidyNode tidy::head ( void )

Çözümleme ağacının <head> etiketiyle başlayan tidyNode nesnesini döndürü

Değiştirgeler

nesne

Tidy nesnesi.

Dönen Değerler

Bir tidyNode nesnesi döner.

Örnekler

Örnek 1 - tidy::head() örneği

<?php
$html = '
<html>
  <head>
    <title>deneme</title>
  </head>
  <body>
    <p>paragraf</p>
  </body>
</html>';

$tidy = tidy_parse_string($html);

$head = $tidy->head();
echo $head->value;
?>

Yukarıdaki örneğin çıktısı:

<head>
<title>deneme</title>
</head>

Notlar

Bilginize: Bu işlev sadece Zend Motoru 2 (PHP >= 5.0.0) ile kullanılabilir.

Ayrıca Bakınız

  • tidy::body() - Çözümleme ağacının <body> etiketiyle başlayan tidyNode nesnesini döndürür
  • tidy::html() - Çözümleme ağacının <html> etiketiyle başlayan tidyNode nesnesini döndürür
tidy::getStatus
tidy::html
Tidy


Çözümleme ağacının <html> etiketiyle başlayan tidyNode nesnesini döndürür

tidy::head
tidy::isXhtml
Tidy
PHP Manual

tidy::html

tidy_get_html

(PHP 5, PHP 7, PECL tidy 0.5.2-1.0.0)

tidy::html -- tidy_get_html — Çözümleme ağacının <html> etiketiyle başlayan tidyNode nesnesini döndürür

Açıklama

Yordamsal kullanım

tidyNode tidy_get_html ( tidy $nesne )

Nesne yönelimli kullanım

tidyNode tidy::html ( void )

Çözümleme ağacının <html> etiketiyle başlayan tidyNode nesnesini döndürür.

Değiştirgeler

nesne

Tidy nesnesi.

Dönen Değerler

Bir tidyNode nesnesi döner.

Örnekler

Örnek 1 - tidy::html() örneği

<?php
$html = '
<html>
  <head>
    <title>deneme</title>
  </head>
  <body>
    <p>paragraf</p>
  </body>
</html>';

$tidy = tidy_parse_string($html);

$html = $tidy->html();
echo $html->value;
?>

Yukarıdaki örneğin çıktısı:

<html>
<head>
<title>deneme</title>
</head>
<body>
<p>paragraf</p>
</body>
</html>

Notlar

Bilginize: Bu işlev sadece Zend Motoru 2 (PHP >= 5.0.0) ile kullanılabilir.

Ayrıca Bakınız

  • tidy::body() - Çözümleme ağacının <body> etiketiyle başlayan tidyNode nesnesini döndürür
  • tidy::head() - Çözümleme ağacının <head> etiketiyle başlayan tidyNode nesnesini döndürür
tidy::head
tidy::isXhtml
Tidy


Belge bir XHTML belge mi diye bakar

tidy::html
tidy::isXml
Tidy
PHP Manual

tidy::isXhtml

tidy_is_xhtml

(PHP 5, PHP 7, PECL tidy >= 0.5.2)

tidy::isXhtml -- tidy_is_xhtml — Belge bir XHTML belge mi diye bakar

Açıklama

Yordamsal kullanım

bool tidy_is_xhtml ( tidy $nesne )

Nesne yönelimli kullanım

bool tidy::isXhtml ( void )

Belge bir XHTML belge ise TRUE döner.

Değiştirgeler

nesne

Tidy nesnesi.

Dönen Değerler

Belge bir XHTML belge ise TRUE yoksa FALSE döner.

Uyarı

Bu işlevi henüz Tidylib gerçeklemediğinden şimdilik daima FALSE döndürmektedir.

tidy::html
tidy::isXml
Tidy


Belge salt bir XML (HTML/XHTML değil) belge mi diye bakar

tidy::isXhtml
tidy::parseFile
Tidy
PHP Manual

tidy::isXml

tidy_is_xml

(PHP 5, PHP 7, PECL tidy >= 0.5.2)

tidy::isXml -- tidy_is_xml — Belge salt bir XML (HTML/XHTML değil) belge mi diye bakar

Açıklama

Yordamsal kullanım

bool tidy_is_xml ( tidy $nesne )

Nesne yönelimli kullanım

bool tidy::isXml ( void )

Belge salt bir XML (HTML/XHTML değil) belge ise TRUE döner.

Değiştirgeler

nesne

Tidy nesnesi.

Dönen Değerler

Belge salt bir XML (HTML/XHTML değil) belge ise TRUE, yoksa FALSE döner.

Uyarı

Bu işlevi henüz Tidylib gerçeklemediğinden şimdilik daima FALSE döndürmektedir.

tidy::isXhtml
tidy::parseFile
Tidy


Belirtilen URI veya dosyadaki imlenimi çözümler

tidy::isXml
tidy::parseString
Tidy
PHP Manual

tidy::parseFile

tidy_parse_file

(PHP 5, PHP 7, PECL tidy >= 0.5.2)

tidy::parseFile -- tidy_parse_file — Belirtilen URI veya dosyadaki imlenimi çözümler

Açıklama

Yordamsal kullanım

tidy tidy_parse_file ( string $dosya [, mixed $ayarlar [, string $kodlama [, bool $include_path_kullan = false ]]] )

Nesne yönelimli kullanım

bool tidy::parseFile ( string $dosya [, mixed $ayarlar [, string $kodlama [, bool $include_path_kullan = false ]]] )

Belirtilen dosyayı çözümler.

Değiştirgeler

dosya

Bu değiştirge belirtilmişse, işlev dosyayı okuyup nesneyi bu içerikten ilklendirir.

ayarlar

Bir dizge veya bir dizi olarak belirtilebilir. Dizge verildiği takdirde yapılandırma dosyasının ismi olarak ele alınır. Dizi olarak verildiğinde ise dizinin yapılandırma seçeneklerini içerdiği varsayılır.

Seçeneklerin açıklamaları için » http://tidy.sourceforge.net/docs/quickref.html adresine bakınız.

kodlama

Belge girdi çıktı kodlaması belirtilir. Olası değerler: ascii, latin0, latin1, raw, utf8, iso2022, mac, win1252, ibm858, utf16, utf16le, utf16be, big5 ve shiftjis.

include_path_kullan

Dosya include_path yönergesinde belirtilen yollarda aranır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - tidy::parseFile() örneği

<?php
$tidy = new tidy();
$tidy->parseFile('file.html');

$tidy->cleanRepair();

if(!empty($tidy->errorBuffer)) {
    echo "Oluşan hata veya uyarılar:\n";
    echo $tidy->errorBuffer;
}
?>

Notlar

Bilginize: Seçimlik ayarlar ve kodlama değiştirgeleri Tidy 2.0'da eklendi.

Ayrıca Bakınız

  • tidy::parsestring() - Bir dizge olarak belirtilen bir belgeyi çözümler
  • tidy::repairfile() - Bir dosyayı onarıp bir dizge olarak döndürür
  • tidy::repairstring() - Seçimlik bir yapılandırma dosyasını kullanarak bir dizgeyi onarır
tidy::isXml
tidy::parseString
Tidy


Bir dizge olarak belirtilen bir belgeyi çözümler

tidy::parseFile
tidy::repairFile
Tidy
PHP Manual

tidy::parseString

tidy_parse_string

(PHP 5, PHP 7, PECL tidy >= 0.5.2)

tidy::parseString -- tidy_parse_string — Bir dizge olarak belirtilen bir belgeyi çözümler

Açıklama

Yordamsal kullanım

tidy tidy_parse_string ( string $girdi [, mixed $ayarlar [, string $kodlama ]] )

Nesne yönelimli kullanım

bool tidy::parseString ( string $girdi [, mixed $ayarlar [, string $kodlama ]] )

Bir dizge olarak belirtilen bir belgeyi çözümler.

Değiştirgeler

girdi

Çözümlenecek veri.

ayarlar

Bir dizge veya bir dizi olarak belirtilebilir. Dizge verildiği takdirde yapılandırma dosyasının ismi olarak ele alınır. Dizi olarak verildiğinde ise dizinin yapılandırma seçeneklerini içerdiği varsayılır.

Seçeneklerin açıklamaları için » http://tidy.sourceforge.net/docs/quickref.html adresine bakınız.

kodlama

Belge girdi çıktı kodlaması belirtilir. Olası değerler: ascii, latin0, latin1, raw, utf8, iso2022, mac, win1252, ibm858, utf16, utf16le, utf16be, big5 ve shiftjis.

Dönen Değerler

Yeni bir tidy nesnesi döner.

Örnekler

Örnek 1 - tidy::parseString() örneği

<?php
ob_start();
?>

<html>
  <head>
   <title>deneme</title>
  </head>
  <body>
   <p>hatalı <br>başka bir satır</i>
  </body>
</html>

<?php

$buffer = ob_get_clean();
$config = array('indent' => TRUE,
                'output-xhtml' => TRUE,
                'wrap' => 200);

$tidy = tidy_parse_string($buffer, $config, 'UTF8');

$tidy->cleanRepair();
echo $tidy;
?>

Yukarıdaki örneğin çıktısı:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
  <head>
    <title>
      deneme
    </title>
  </head>
  <body>
    <p>
      hatalı<br />
      başka bir satır
    </p>
  </body>
</html>

Notlar

Bilginize: Seçimlik ayarlar ve kodlama değiştirgeleri Tidy 2.0'da eklendi.

Ayrıca Bakınız

  • tidy::parseFile() - Belirtilen URI veya dosyadaki imlenimi çözümler
  • tidy::repairFile() - Bir dosyayı onarıp bir dizge olarak döndürür
  • tidy::repairString() - Seçimlik bir yapılandırma dosyasını kullanarak bir dizgeyi onarır
tidy::parseFile
tidy::repairFile
Tidy


Bir dosyayı onarıp bir dizge olarak döndürür

tidy::parseString
tidy::repairString
Tidy
PHP Manual

tidy::repairFile

tidy_repair_file

(PHP 5, PHP 7, PECL tidy >= 0.7.0)

tidy::repairFile -- tidy_repair_file — Bir dosyayı onarıp bir dizge olarak döndürür

Açıklama

Yordamsal kullanım

string tidy_repair_file ( string $dosya [, mixed $ayarlar [, string $kodlama [, bool $include_path_kullan = false ]]] )

Nesne yönelimli kullanım

string tidy::repairFile ( string $dosya [, mixed $ayarlar [, string $kodlama [, bool $include_path_kullan = false ]]] )

Bir dosyayı onarıp bir dizge olarak döndürür.

Değiştirgeler

dosya

Onarılacak dosya.

ayarlar

Bir dizge veya bir dizi olarak belirtilebilir. Dizge verildiği takdirde yapılandırma dosyasının ismi olarak ele alınır. Dizi olarak verildiğinde ise dizinin yapılandırma seçeneklerini içerdiği varsayılır.

Seçeneklerin açıklamaları için » http://tidy.sourceforge.net/docs/quickref.html adresine bakınız.

kodlama

Belge girdi çıktı kodlaması belirtilir. Olası değerler: ascii, latin0, latin1, raw, utf8, iso2022, mac, win1252, ibm858, utf16, utf16le, utf16be, big5 ve shiftjis.

include_path_kullan

Dosya include_path yönergesinde belirtilen yollarda aranır.

Dönen Değerler

Onarılmış dosya içeriğini bir dizge olarak döndürür.

Örnekler

Örnek 1 - tidy::repairFile() örneği

<?php
$file = 'file.html';

$tidy = new tidy();
$repaired = $tidy->repairfile($file);
rename($file, $file . '.bak');

file_put_contents($file, $repaired);
?>

Notlar

Bilginize: Seçimlik ayarlar ve kodlama değiştirgeleri Tidy 2.0'da eklendi.

Ayrıca Bakınız

  • tidy::parseFile() - Belirtilen URI veya dosyadaki imlenimi çözümler
  • tidy::parseString() - Bir dizge olarak belirtilen bir belgeyi çözümler
  • tidy::repairString() - Seçimlik bir yapılandırma dosyasını kullanarak bir dizgeyi onarır
tidy::parseString
tidy::repairString
Tidy


Seçimlik bir yapılandırma dosyasını kullanarak bir dizgeyi onarır

tidy::repairFile
tidy::root
Tidy
PHP Manual

tidy::repairString

tidy_repair_string

(PHP 5, PHP 7, PECL tidy >= 0.7.0)

tidy::repairString -- tidy_repair_string — Seçimlik bir yapılandırma dosyasını kullanarak bir dizgeyi onarır

Açıklama

Yordamsal kullanım

string tidy_repair_string ( string $veri [, mixed $ayarlar [, string $kodlama ]] )

Nesne yönelimli kullanım

string tidy::repairString ( string $veri [, mixed $ayarlar [, string $kodlama ]] )

Belirtilen veri dizgesini onarır.

Değiştirgeler

veri

Onarılacak veri.

ayarlar

Bir dizge veya bir dizi olarak belirtilebilir. Dizge verildiği takdirde yapılandırma dosyasının ismi olarak ele alınır. Dizi olarak verildiğinde ise dizinin yapılandırma seçeneklerini içerdiği varsayılır.

Seçeneklerin açıklamaları için » http://tidy.sourceforge.net/docs/quickref.html adresine bakınız.

kodlama

Belge girdi çıktı kodlaması belirtilir. Olası değerler: ascii, latin0, latin1, raw, utf8, iso2022, mac, win1252, ibm858, utf16, utf16le, utf16be, big5 ve shiftjis.

Dönen Değerler

Onarılan dizge.

Örnekler

Örnek 1 - tidy::repairString() örneği

<?php
ob_start();
?>

<html>
  <head>
    <title>deneme</title>
  </head>
  <body>
    <p>hata</i>
  </body>
</html>

<?php

$buffer = ob_get_clean();
$tidy = new tidy();
$clean = $tidy->repairString($buffer);

echo $clean;
?>

Yukarıdaki örneğin çıktısı:

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 3.2//EN">
<html>
<head>
<title>deneme</title>
</head>
<body>
<p>hata</p>
</body>
</html>

Notlar

Bilginize: Seçimlik ayarlar ve kodlama değiştirgeleri Tidy 2.0'da eklendi.

Ayrıca Bakınız

  • tidy::parseFile() - Belirtilen URI veya dosyadaki imlenimi çözümler
  • tidy::parseString() - Bir dizge olarak belirtilen bir belgeyi çözümler
  • tidy::repairFile() - Bir dosyayı onarıp bir dizge olarak döndürür
tidy::repairFile
tidy::root
Tidy


Çözümleme ağacının kökünü temsil eden bir tidyNode nesnesi döndürür

tidy::repairString
TidyNode
Tidy
PHP Manual

tidy::root

tidy_get_root

(PHP 5, PHP 7, PECL tidy 0.5.2-1.0.0)

tidy::root -- tidy_get_root — Çözümleme ağacının kökünü temsil eden bir tidyNode nesnesi döndürür

Açıklama

Nesne yönelimli kullanım

tidyNode tidy::root ( void )

Yordamsal kullanım

tidyNode tidy_get_root ( tidy $nesne )

Çözümleme ağacının kökünü temsil eden bir tidyNode nesnesi döndürür.

Değiştirgeler

nesne

Tidy nesnesi.

Dönen Değerler

Bir tidyNode nesnesi döner.

Örnekler

Örnek 1 - tidy::root() örneği

<?php

$html = <<< HTML
<html><body>

<p>paragraf</p>
<br/>

</body></html>
HTML;

$tidy = tidy_parse_string($html);
dump_nodes($tidy->root(), 1);

function dump_nodes($node, $indent) {

    if($node->hasChildren()) {
        foreach($node->child as $child) {
            echo str_repeat('.', $indent*2) .
                ($child->name ? $child->name : '"'.$child->value.'"'). "\n";
            dump_nodes($child, $indent+1);
        }
    }
}
?>

Yukarıdaki örneğin çıktısı:

..html
....head
......title
....body
......p
........"paragraf"
......br

Notlar

Bilginize: Bu işlev sadece Zend Motoru 2 (PHP >= 5.0.0) ile kullanılabilir.

tidy::repairString
TidyNode
Tidy


TidyNode sınıfı

(PHP 5 >= 5.0.1, PHP 7)

Giriş

Tidy tarafından saptandığı haliyle bir HTML dosyasındaki bir HTML düğümü.

Sınıf Sözdizimi

TidyNode {
/* Özellikler */
/* Yöntemler */
tidyNode tidyNode::getParent ( void )
bool tidyNode::hasChildren ( void )
bool tidyNode::hasSiblings ( void )
bool tidyNode::isAsp ( void )
bool tidyNode::isComment ( void )
bool tidyNode::isHtml ( void )
bool tidyNode::isJste ( void )
bool tidyNode::isPhp ( void )
bool tidyNode::isText ( void )
}

Özellikler

value

Çevreleyen etiketler dahil, düğümün HTML gösterimi.

name

HTML düğümünün ismi

type

Etiketin türü (TIDY_NODETYPE_PHPgibi bir sabit)

line

Dosyada etiketin bulunduğu satırın numarası.

column

Dosyada etiketin bulunduğu sütunun numarası.

proprietary

Müseccel bir etiket olup olmadığını belirler

id

Etiketin ID'si (TIDY_TAG_FRAME gibi bir sabit)

attribute

Geçerli düğümün öznitelik isimlerini anahtar olarak içeren bir dizge dizisi.

child

Geçerli düğümün çocuklarından oluşan bir TidyNode dizisi.

Sürüm: | Açıklama
5.1.0 | line, column ve proprietary eklendi.

İçindekiler

  • tidyNode::getParent — Geçerli düğümün ebeveynini döndürür
  • tidyNode::hasChildren — Düğümün çocukları olup olmadığına bakar
  • tidyNode::hasSiblings — Düğümün kardeşleri olup olmadığına bakar
  • tidyNode::isAsp — Düğümün bir ASP düğümü olup olmadığına bakar
  • tidyNode::isComment — Düğüm bir açıklama düğümü mü diye bakar
  • tidyNode::isHtml — Düğümün bir HTML belge parçası olup olmadığına bakar
  • tidyNode::isJste — Düğümün bir JSTE düğümü olup olmadığına bakar
  • tidyNode::isPhp — Düğümün bir PHP düğümü olup olmadığına bakar
  • tidyNode::isText — Düğümün bir metin düğümü olup olmadığına bakar
tidy::root
tidyNode::getParent
Tidy


Geçerli düğümün ebeveynini döndürür

TidyNode
tidyNode::hasChildren
TidyNode
PHP Manual

tidyNode::getParent

(PHP 5 >= 5.2.2, PHP 7)

tidyNode::getParent — Geçerli düğümün ebeveynini döndürür

Açıklama

tidyNode tidyNode::getParent ( void )

Geçerli düğümün ebeveynini döndürür.

Örnekler

Örnek 1 - tidyNode::getParent() örneği

<?php

$html = <<< HTML
<html><head>
<?php echo '<title>title</title>'; ?>
<#
  /* JSTE kodu */
  alert('Merhaba Dünya');
#>
 </head>
 <body>
 Merhaba Dünya
 </body>
</html>

HTML;

$tidy = tidy_parse_string($html);
$num = 0;

$node = $tidy->html()->child[0]->child[0];

var_dump($node->getparent()->name);
?>

Yukarıdaki örneğin çıktısı:

string(4) "head"

Dönen Değerler

Düğümün bir ebeveyni varsa bir tidyNode nesnesi, aksi takdirde NULL döner.

TidyNode
tidyNode::hasChildren
TidyNode


Düğümün çocukları olup olmadığına bakar

tidyNode::getParent
tidyNode::hasSiblings
TidyNode
PHP Manual

tidyNode::hasChildren

(PHP 5 >= 5.0.1, PHP 7)

tidyNode::hasChildren — Düğümün çocukları olup olmadığına bakar

Açıklama

bool tidyNode::hasChildren ( void )

Düğümün çocukları var mı diye bakar.

Dönen Değerler

Düğümün çocukları varsa TRUE yoksa FALSE döner.

Örnekler

Örnek 1 - tidyNode::hasChildren() örneği

<?php

$html = <<< HTML
<html><head>
<?php echo '<title>Başlık</title>'; ?>
<#
  /* JSTE kodu */
  alert('Merhaba Dünya');
#>
</head>
<body>

<?php
  // PHP code
  echo 'merhaba dünya!';
?>

<%
  /* ASP kodu */
  response.write("Merhaba Dünya!")
%>

<!-- Açıklamalar -->
Merhaba Dünya
</body></html>
HTML dışı
HTML;

$tidy = tidy_parse_string($html);
$num = 0;

// HEAD etiketi
var_dump($tidy->html()->child[0]->hasChildren());

// HEAD etiketi içindeki PHP etiketi
var_dump($tidy->html()->child[0]->child[0]->hasChildren());

?>

Yukarıdaki örneğin çıktısı:

bool(true)
bool(false)

Notlar

Bilginize:

PHP 4/Tidy 1'de işlevin adı tidy_node::has_children() idi.

tidyNode::getParent
tidyNode::hasSiblings
TidyNode


Düğümün kardeşleri olup olmadığına bakar

tidyNode::hasChildren
tidyNode::isAsp
TidyNode
PHP Manual

tidyNode::hasSiblings

(PHP 5 >= 5.0.1, PHP 7)

tidyNode::hasSiblings — Düğümün kardeşleri olup olmadığına bakar

Açıklama

bool tidyNode::hasSiblings ( void )

Düğümün kardeşleri var mı diye bakar.

Dönen Değerler

Düğümün kardeşleri varsa TRUE yoksa FALSE döner.

Örnekler

Örnek 1 - tidyNode::hasSiblings() örneği

<?php

$html = <<< HTML
<html><head>
<?php echo '<title>Başlık</title>'; ?>
<#
  /* JSTE kodu */
  alert('Merhaba Dünya');
#>
</head>
<body>

<?php
  // PHP code
  echo 'merhaba dünya!';
?>

<%
  /* ASP kodu */
  response.write("Merhaba Dünya!")
%>

<!-- Açıklamalar -->
Merhaba Dünya
</body></html>
HTML dışı
HTML;

$tidy = tidy_parse_string($html);
$num = 0;

// HTML etiketi
var_dump($tidy->html()->hasSiblings());

// HEAD etiketi
var_dump($tidy->html()->child[0]->hasSiblings());

?>

Yukarıdaki örneğin çıktısı:

bool(false)
bool(true)

Notlar

Bilginize:

PHP 4/Tidy 1'de işlevin ismi tidy_node::has_siblings() idi.

tidyNode::hasChildren
tidyNode::isAsp
TidyNode


Düğümün bir ASP düğümü olup olmadığına bakar

tidyNode::hasSiblings
tidyNode::isComment
TidyNode
PHP Manual

tidyNode::isAsp

(PHP 5 >= 5.0.1, PHP 7)

tidyNode::isAsp — Düğümün bir ASP düğümü olup olmadığına bakar

Açıklama

bool tidyNode::isAsp ( void )

Düğüm bir ASP düğümü mü diye bakar.

Dönen Değerler

Düğüm bir ASP düğümü ise TRUE değilse FALSE döner.

Örnekler

Örnek 1 - Karışık bir HTML belgeden ASP kodunu çıkarmak

<?php

$html = <<< HTML
<html><head>
<?php echo '<title>Başlık</title>'; ?>
<#
  /* JSTE kodu */
  alert('Merhaba Dünya');
#>
</head>
<body>

<?php
  // PHP code
  echo 'merhaba dünya!';
?>

<%
  /* ASP kodu */
  response.write("Merhaba Dünya!")
%>

<!-- Açıklamalar -->
Merhaba Dünya
</body></html>
HTML dışı
HTML;

$tidy = tidy_parse_string($html);
$num = 0;

get_nodes($tidy->html(), 'asp');

function get_nodes($node, $node_type) {

    // Düğüm istenen türde mi?
    if($node->{"is$node_type"}()) {
        echo "\n\n# $node_type node #" . ++$GLOBALS['num'] . "\n";
        echo $node->value;
    }

    // Düğümün çocukları var mı?
    if($node->hasChildren()) {
        foreach($node->child as $child) {
            get_nodes($child, $node_type);
        }
    }
}

?>

Yukarıdaki örneğin çıktısı:

# asp node #1
<%
  /* ASP kodu */
  response.write("Merhaba Dünya!")
%>

Notlar

Bilginize:

PHP 4/Tidy 1'de işlevin ismi tidy_node::is_asp() idi.

tidyNode::hasSiblings
tidyNode::isComment
TidyNode


Düğüm bir açıklama düğümü mü diye bakar

tidyNode::isAsp
tidyNode::isHtml
TidyNode
PHP Manual

tidyNode::isComment

(PHP 5 >= 5.0.1, PHP 7)

tidyNode::isComment — Düğüm bir açıklama düğümü mü diye bakar

Açıklama

bool tidyNode::isComment ( void )

Düğümün bir açıklama düğümü olup olmadığına bakar.

Dönen Değerler

Düğüm bir açıklama düğümü ise TRUE değilse FALSE döner.

Örnekler

Örnek 1 - Karışık bir HTML belgeden açıklamaları çıkarmak

<?php

$html = <<< HTML
<html><head>
<?php echo '<title>Başlık</title>'; ?>
<#
  /* JSTE kodu */
  alert('Merhaba Dünya');
#>
</head>
<body>

<?php
  // PHP code
  echo 'merhaba dünya!';
?>

<%
  /* ASP kodu */
  response.write("Merhaba Dünya!")
%>

<!-- Açıklamalar -->
Merhaba Dünya
</body></html>
HTML dışı
HTML;

$tidy = tidy_parse_string($html);
$num = 0;

get_nodes($tidy->html(), 'comment');

function get_nodes($node, $node_type) {

    // Düğüm istenen türde mi?
    if($node->{"is$node_type"}()) {
        echo "\n\n# $node_type node #" . ++$GLOBALS['num'] . "\n";
        echo $node->value;
    }

    // Düğümün çocukları var mı?
    if($node->hasChildren()) {
        foreach($node->child as $child) {
            get_nodes($child, $node_type);
        }
    }
}

?>

Yukarıdaki örneğin çıktısı:

# jste node #1
<#
  /* JSTE todu */
  alert('Merhaba Dünya');
#>

/*
var_dump($tidy->html()->child[0]->hasChildren());
var_dump($tidy->html()->child[0]->child[0]->hasChildren());
*/

Notlar

Bilginize:

PHP 4/Tidy 1'de işlevin ismi tidy_node::is_comment() idi.

tidyNode::isAsp
tidyNode::isHtml
TidyNode


Düğümün bir HTML belge parçası olup olmadığına bakar

tidyNode::isComment
tidyNode::isJste
TidyNode
PHP Manual

tidyNode::isHtml

(PHP 5 >= 5.0.1, PHP 7)

tidyNode::isHtml — Düğümün bir HTML belge parçası olup olmadığına bakar

Açıklama

bool tidyNode::isHtml ( void )

Düğümün bir HTML belge parçası olup olmadığına bakar.

Dönen Değerler

Düğüm bir HTML belge parçası ise TRUE değilse FALSE döner.

Örnekler

Örnek 1 - Karışık bir HTML belgeden HTML kodunu çıkarmak

<?php

$html = <<< HTML
<html><head>
<?php echo '<title>Başlık</title>'; ?>
<#
  /* JSTE kodu */
  alert('Merhaba Dünya');
#>
</head>
<body>

<?php
  // PHP code
  echo 'merhaba dünya!';
?>

<%
  /* ASP kodu */
  response.write("Merhaba Dünya!")
%>

<!-- Açıklamalar -->
Merhaba Dünya
</body></html>
HTML dışı
HTML;

$tidy = tidy_parse_string($html);
$num = 0;

get_nodes($tidy->html(), 'text');

function get_nodes($node, $node_type) {
    // Düğüm istenen türde mi?
    if($node->{"is$node_type"}()) {
        echo "\n\n# $node_type node #" . ++$GLOBALS['num'] . "\n";
        echo $node->value;
    }

    // Düğümün çocukları var mı?
    if($node->hasChildren()) {
        foreach($node->child as $child) {
            get_nodes($child, $node_type);
        }
    }
}

?>

Yukarıdaki örneğin çıktısı:

# html node #1
<html>
<head>
<?php echo '<title>Başlık</title>'; ?><#
  /* JSTE kodu */
  alert('Merhaba Dünya');
#>
<title></title>
</head>
<body>
<?php
  // PHP code
  echo 'hello world!';
?><%
  /* ASP code */
  response.write("Merhaba Dünya!")
%><!-- Açıklamalar -->
Merhaba Dünya HTML dışı
</body>
</html>

# html node #2
<head>
<?php echo '<title>Başlık</title>'; ?><#
  /* JSTE kodu */
  alert('Merhaba Dünya');
#>
<title></title>
</head>

# html node #3
<?php echo '<title>Başlık</title>'; ?>

# html node #4
<#
  /* JSTE kodu */
  alert('Merhaba Dünya');
#>

# html node #5
<title></title>

# html node #6
<body>
<?php
  // PHP kodu
  echo 'merhaba dünya!';
?><%
  /* ASP kodu */
  response.write("Merhaba Dünya!")
%><!-- Comments -->
Merhaba Dünya HTML dışı
</body>

# html node #7
<?php
  // PHP kodu
  echo 'merhaba dünya!';
?>

# html node #8
<%
  /* ASP kodu */
  response.write("Merhaba Dünya!")
%>

# html node #9
<!-- Açıklamalar -->

# html node #10
Merhaba Dünya

# html node #11
HTML dışı

Notlar

Bilginize:

PHP 4/Tidy 1'de işlevin ismi tidy_node::is_html() idi.

tidyNode::isComment
tidyNode::isJste
TidyNode


Düğümün bir JSTE düğümü olup olmadığına bakar

tidyNode::isHtml
tidyNode::isPhp
TidyNode
PHP Manual

tidyNode::isJste

(PHP 5 >= 5.0.1, PHP 7)

tidyNode::isJste — Düğümün bir JSTE düğümü olup olmadığına bakar

Açıklama

bool tidyNode::isJste ( void )

Düğümün bir JSTE düğümü olup olmadığına bakar.

Dönen Değerler

Düğüm bir JSTE düğümü ise TRUE değilse FALSE döner.

Örnekler

Örnek 1 - Karışık bir HTML belgeden JSTE kodunu çıkarmak

<?php

$html = <<< HTML
<html><head>
<?php echo '<title>title</title>'; ?>
<#
  /* JSTE kodu */
  alert('Merhaba Dünya');
#>
</head>
<body>

<?php
  // PHP code
  echo 'merhaba dünya!';
?>

<%
  /* ASP kodu */
  response.write("Merhaba Dünya!")
%>

<!-- Açıklamalar -->
Merhaba Dünya
</body></html>
HTML dışı
HTML;

$tidy = tidy_parse_string($html);
$num = 0;

get_nodes($tidy->html(), 'text');

function get_nodes($node, $node_type) {

    // Düğüm istenen türde mi?
    if($node->{"is$node_type"}()) {
        echo "\n\n# $node_type node #" . ++$GLOBALS['num'] . "\n";
        echo $node->value;
    }

    // Düğümün çocukları var mı?
    if($node->hasChildren()) {
        foreach($node->child as $child) {
            get_nodes($child, $node_type);
        }
    }
}

?>

Yukarıdaki örneğin çıktısı:

# jste node #1
<#
  /* JSTE kodu */
  alert('Merhaba Dünya');
#>

/*
var_dump($tidy->html()->child[0]->hasChildren());
var_dump($tidy->html()->child[0]->child[0]->hasChildren());
*/

Notlar

Bilginize:

PHP 4/Tidy 1'de işlevin ismi tidy_node::is_jste() idi.

tidyNode::isHtml
tidyNode::isPhp
TidyNode


Düğümün bir PHP düğümü olup olmadığına bakar

tidyNode::isJste
tidyNode::isText
TidyNode
PHP Manual

tidyNode::isPhp

(PHP 5 >= 5.0.1, PHP 7)

tidyNode::isPhp — Düğümün bir PHP düğümü olup olmadığına bakar

Açıklama

bool tidyNode::isPhp ( void )

Düğümün bir PHP düğümü olup olmadığına bakar.

Dönen Değerler

Düğüm bir PHP düğümü ise TRUE değilse FALSE döner.

Örnekler

Örnek 1 - Karışık bir HTML belgeden PHP kodunu çıkarmak

<?php

$html = <<< HTML
<html><head>
<?php echo '<title>title</title>'; ?>
<#
  /* JSTE kodu */
  alert('Merhaba Dünya');
#>
</head>
<body>

<?php
  // PHP code
  echo 'merhaba dünya!';
?>

<%
  /* ASP kodu */
  response.write("Merhaba Dünya!")
%>

<!-- Açıklamalar -->
Merhaba Dünya
</body></html>
HTML dışı
HTML;

$tidy = tidy_parse_string($html);
$num = 0;

get_nodes($tidy->html(), 'php');

function get_nodes($node, $node_type) {

    // Düğüm istenen türde mi?
    if($node->{"is$node_type"}()) {
        echo "\n\n# $node_type node #" . ++$GLOBALS['num'] . "\n";
        echo $node->value;
    }

    // Düğümün çocukları var mı?
    if($node->hasChildren()) {
        foreach($node->child as $child) {
            get_nodes($child, $node_type);
        }
    }
}

?>

Yukarıdaki örneğin çıktısı:

# php node #1
<?php echo '<title>title</title>'; ?>

# php node #2
<?php
  // PHP kodu
  echo 'merhaba dünya!';
?>

Notlar

Bilginize:

PHP 4/Tidy 1'de işlevin ismi tidy_node::is_php() idi.

tidyNode::isJste
tidyNode::isText
TidyNode


Düğümün bir metin düğümü olup olmadığına bakar

tidyNode::isPhp
Tidy İşlevleri
TidyNode
PHP Manual

tidyNode::isText

(PHP 5 >= 5.0.1, PHP 7)

tidyNode::isText — Düğümün bir metin düğümü olup olmadığına bakar

Açıklama

bool tidyNode::isText ( void )

Düğümün (herhangi bir imlenim içermeyen) bir metin düğümü olup olmadığına bakar.

Dönen Değerler

Düğüm, bir metin düğümü ise TRUE değilse FALSE döner.

Örnekler

Örnek 1 - Karışık bir HTML belgeden metni çıkarmak

<?php

$html = <<< HTML
<html><head>
<?php echo '<title>title</title>'; ?>
<#
  /* JSTE kodu */
  alert('Merhaba Dünya');
#>
</head>
<body>

<?php
  // PHP code
  echo 'merhaba dünya!';
?>

<%
  /* ASP kodu */
  response.write("Merhaba Dünya!")
%>

<!-- Açıklamalar -->
Merhaba Dünya
</body></html>
HTML dışı
HTML;

$tidy = tidy_parse_string($html);
$num = 0;

get_nodes($tidy->html(), 'text');

function get_nodes($node, $node_type) {

    // Düğüm istenen türde mi?
    if($node->{"is$node_type"}()) {
        echo "\n\n# $node_type node #" . ++$GLOBALS['num'] . "\n";
        echo $node->value;
    }

    // Düğümün çocukları var mı?
    if($node->hasChildren()) {
        foreach($node->child as $child) {
            get_nodes($child, $node_type);
        }
    }
}

?>

Yukarıdaki örneğin çıktısı:

# text node #1
Merhaba Dünya

# text node #2
HTML dışı

Notlar

Bilginize:

PHP 4/Tidy 1'de işlevin adı tidy_node::is_text() idi.

tidyNode::isPhp
Tidy İşlevleri
TidyNode


Tidy İşlevleri

İçindekiler

  • ob_tidyhandler — Tampon onarımı için ob_start geriçağırım işlevi
  • tidy_access_count — Belgede saptanan Tidy erişilebilirlik uyarılarının sayısını döndürür
  • tidy_config_count — Belgede saptanan Tidy yapılandırma hatalarının sayısını döndürür
  • tidy_error_count — Belgede saptanan Tidy hatalarının sayısını döndürür
  • tidy_get_output — Çözümlenen Tidy imlenimini bir dizge olarak döndürür
  • tidy_load_config — Bir Tidy yapılandırma dosyasını belirtilen kodlama ile yükler
  • tidy_reset_config — Tidy yapılandırmasını öntanımlı değerlere ayarlar
  • tidy_save_config — Geçerli ayarları belirtilen dosyaya kaydeder
  • tidy_set_encoding — Çözümlenecek imlenim için girdi/çıktı karakter kodlamasını belirler
  • tidy_setopt — Belgenin yapılandırma seçeneklerini günceller
  • tidy_warning_count — Belgede saptanan Tidy uyarılarının sayısını döndürür
tidyNode::isText
ob_tidyhandler
Tidy


Tampon onarımı için ob_start geriçağırım işlevi

Tidy İşlevleri
tidy_access_count
Tidy İşlevleri
PHP Manual

ob_tidyhandler

(PHP 5, PHP 7)

ob_tidyhandler — Tampon onarımı için ob_start() geriçağırım işlevi

Açıklama

string ob_tidyhandler ( string $tampon [, int $kip ] )

Tampon onarımı için ob_start() geriçağırım işlevi.

Değiştirgeler

tampon

Tampon.

kip

Tamponun kipi.

Dönen Değerler

Onarılmış tamponu içeren bir dizge döner.

Örnekler

Örnek 1 - ob_tidyhandler() örneği

<?php
ob_start('ob_tidyhandler');

echo '<p>test</i>';
?>

Yukarıdaki örneğin çıktısı:

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 3.2//EN">
<html>
<head>
<title></title>
</head>
<body>
<p>test</p>
</body>
</html>

Ayrıca Bakınız

  • ob_start() - Çıktı tamponlamasını başlatır

Tidy İşlevleri
tidy_access_count
Tidy İşlevleri


Belgede saptanan Tidy erişilebilirlik uyarılarının sayısını döndürür

ob_tidyhandler
tidy_config_count
Tidy İşlevleri
PHP Manual

tidy_access_count

(PHP 5, PHP 7, PECL tidy >= 0.5.2)

tidy_access_count — Belgede saptanan Tidy erişilebilirlik uyarılarının sayısını döndürür

Açıklama

int tidy_access_count ( tidy $nesne )

Belgede saptanan Tidy erişilebilirlik uyarılarının sayısını döndürür.

Değiştirgeler

nesne

Tidy nesnesi.

Dönen Değerler

Uyarı sayısı döner.

Örnekler

Örnek 1 - tidy_access_count() örneği

<?php

$html ='<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 3.2//EN">
<html><head><title>Title</title></head>
<body>

<p><img src="img.png"></p>

</body></html>';

// erişilebilirlik sınama seviyesi 1, 2 veya 3 olabilir
$config = array('accessibility-check' => 3);

$tidy = new tidy();
$tidy->parseString($html, $config);
$tidy->cleanRepair();

/* Bu çağrıyı yapmayı asla unutma! */
$tidy->diagnose();

echo tidy_access_count($tidy); //5

?>

Notlar

Bilginize:

TidyLib tasarımından ötürü, tidy_access_count()
çağrısından önce bir tidy_diagnose() çağrısı
yapmalısınız yoksa tidy_access_count() daima
0 döndürür. Ayrıca,
accessibility-check seçeneğini de etkin kılmalısınız.

Ayrıca Bakınız

  • tidy_error_count() - Belgede saptanan Tidy hatalarının sayısını döndürür
  • tidy_warning_count() - Belgede saptanan Tidy uyarılarının sayısını döndürür

ob_tidyhandler
tidy_config_count
Tidy İşlevleri


Belgede saptanan Tidy yapılandırma hatalarının sayısını döndürür

tidy_access_count
tidy_error_count
Tidy İşlevleri
PHP Manual

tidy_config_count

(PHP 5, PHP 7, PECL tidy >= 0.5.2)

tidy_config_count — Belgede saptanan Tidy yapılandırma hatalarının sayısını döndürür

Açıklama

int tidy_config_count ( tidy $object )

Belgede saptanan Tidy yapılandırma hatalarının sayısını döndürür.

Değiştirgeler

nesne

Tidy nesnesi.

Dönen Değerler

Hata sayısı döner.

Örnekler

Örnek 1 - tidy_config_count() örneği

<?php
$html = '<p>test</I>';

$config = array('doctype' => 'bogus');

$tidy = tidy_parse_string($html, $config);

/* 'bogus' geçerli bir belge türü olmadığından 1 çıktılar */
echo tidy_config_count($tidy);
?>

tidy_access_count
tidy_error_count
Tidy İşlevleri


Belgede saptanan Tidy hatalarının sayısını döndürür

tidy_config_count
tidy_get_output
Tidy İşlevleri
PHP Manual

tidy_error_count

(PHP 5, PHP 7, PECL tidy >= 0.5.2)

tidy_error_count — Belgede saptanan Tidy hatalarının sayısını döndürür

Açıklama

int tidy_error_count ( tidy $nesne )

Belgede saptanan Tidy hatalarının sayısını döndürür.

Değiştirgeler

nesne

Tidy nesnesi.

Dönen Değerler

Hata sayısı döner.

Örnekler

Örnek 1 - tidy_error_count() örneği

<?php
$html = '<p>test</i>
<bogustag>bogus</bogustag>';

$tidy = tidy_parse_string($html);

echo tidy_error_count($tidy) . "\n"; //1

echo $tidy->errorBuffer;
?>

Yukarıdaki örneğin çıktısı:

1
line 1 column 1 - Warning: missing <!DOCTYPE> declaration
line 1 column 8 - Warning: discarding unexpected </i>
line 2 column 1 - Error: <bogustag> is not recognized!
line 2 column 1 - Warning: discarding unexpected <bogustag>
line 2 column 16 - Warning: discarding unexpected </bogustag>
line 1 column 1 - Warning: inserting missing 'title' element

Ayrıca Bakınız

  • tidy_access_count() - Belgede saptanan Tidy erişilebilirlik uyarılarının sayısını döndürür
  • tidy_warning_count() - Belgede saptanan Tidy uyarılarının sayısını döndürür
tidy_config_count
tidy_get_output
Tidy İşlevleri


Çözümlenen Tidy imlenimini bir dizge olarak döndürür

tidy_error_count
tidy_load_config
Tidy İşlevleri
PHP Manual

tidy_get_output

(PHP 5, PHP 7, PECL tidy >= 0.5.2)

tidy_get_output — Çözümlenen Tidy imlenimini bir dizge olarak döndürür

Açıklama

string tidy_get_output ( tidy $object )

Çözümlenen Tidy imlenimini bir dizge olarak döndürür.

Değiştirgeler

nesne

Tidy nesnesi.

Dönen Değerler

Çözümlenen Tidy imlenimini içeren bir dizge döner

Örnekler

Örnek 1 - tidy_get_output() örneği

<?php

$html = '<p>paragraph</i>';
$tidy = tidy_parse_string($html);

$tidy->cleanRepair();

echo tidy_get_output($tidy);
?>

Yukarıdaki örneğin çıktısı:

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 3.2//EN">
<html>
<head>
<title></title>
</head>
<body>
<p>paragraph</p>
</body>
</html>

tidy_error_count
tidy_load_config
Tidy İşlevleri


Bir Tidy yapılandırma dosyasını belirtilen kodlama ile yükler

tidy_get_output
tidy_reset_config
Tidy İşlevleri
PHP Manual

tidy_load_config

(PECL tidy >= 0.5.2)

tidy_load_config — Bir Tidy yapılandırma dosyasını belirtilen kodlama ile yükler

Açıklama

void tidy_load_config ( string $dosya , string $kodlama )

Bir Tidy yapılandırma dosyasını belirtilen kodlama ile yükler.

Değiştirgeler

dosya

Yapılandırma dosyasının yolu.

kodlama

Belge girdi/çıktı kodlaması belirtilir. Olası değerler: ascii, latin0, latin1, raw, utf8, iso2022, mac, win1252, ibm858, utf16, utf16le, utf16be, big5 ve shiftjis.

Dönen Değerler

Hiçbir değer dönmez.

Notlar

Bilginize: Bu işlev sadece Tidy 1.0 ile kullanılabilir. Tidy 2.0'dan itibaren kullanımı önerilmemekte olup bu nedenle de kaldırılmıştır.

tidy_get_output
tidy_reset_config
Tidy İşlevleri


Tidy yapılandırmasını öntanımlı değerlere ayarlar

tidy_load_config
tidy_save_config
Tidy İşlevleri
PHP Manual

tidy_reset_config

(PECL tidy >= 0.7.0)

tidy_reset_config — Tidy yapılandırmasını öntanımlı değerlere ayarlar

Açıklama

bool tidy_reset_config ( void )

Tidy yapılandırmasını öntanımlı değerlere ayarlar.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

Bilginize: Bu işlev sadece Tidy 1.0 ile kullanılabilir. Tidy 2.0'dan itibaren kullanımı önerilmemekte olup bu nedenle de kaldırılmıştır.

tidy_load_config
tidy_save_config
Tidy İşlevleri


Geçerli ayarları belirtilen dosyaya kaydeder

tidy_reset_config
tidy_set_encoding
Tidy İşlevleri
PHP Manual

tidy_save_config

(PECL tidy >= 0.5.2)

tidy_save_config — Geçerli ayarları belirtilen dosyaya kaydeder

Açıklama

bool tidy_save_config ( string $dosya )

Geçerli ayarları belirtilen dosyaya kaydeder. Dosyaya sadece öntanımlı olmayan değerler yazılır.

Değiştirgeler

dosya

Yapılandırma dosyasının yolu.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

Bilginize: Bu işlev sadece Tidy 1.0 ile kullanılabilir. Tidy 2.0'dan itibaren kullanımı önerilmemekte olup bu nedenle de kaldırılmıştır.

Ayrıca Bakınız

  • tidy_get_config() - Geçerli Tidy yapılandırmasını döndürür
  • tidy_getopt() - Belirtilen yapılandırma seçeneğinin değerini döndürür
  • tidy_reset_config() - Tidy yapılandırmasını öntanımlı değerlere ayarlar
  • tidy_setopt() - Belgenin yapılandırma seçeneklerini günceller

tidy_reset_config
tidy_set_encoding
Tidy İşlevleri


Çözümlenecek imlenim için girdi/çıktı karakter kodlamasını belirler

tidy_save_config
tidy_setopt
Tidy İşlevleri
PHP Manual

tidy_set_encoding

(PECL tidy >= 0.5.2)

tidy_set_encoding — Çözümlenecek imlenim için girdi/çıktı karakter kodlamasını belirler

Açıklama

bool tidy_set_encoding ( string $encoding )

Çözümlenecek belge için girdi/çıktı karakter kodlamasını belirler.

Değiştirgeler

kodlama

Belge girdi/çıktı kodlaması belirtilir. Olası değerler: ascii, latin0, latin1, raw, utf8, iso2022, mac, win1252, ibm858, utf16, utf16le, utf16be, big5 ve shiftjis.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

Bilginize: Bu işlev sadece Tidy 1.0 ile kullanılabilir. Tidy 2.0'dan itibaren kullanımı önerilmemekte olup bu nedenle de kaldırılmıştır.

tidy_save_config
tidy_setopt
Tidy İşlevleri


Belgenin yapılandırma seçeneklerini günceller

tidy_set_encoding
tidy_warning_count
Tidy İşlevleri
PHP Manual

tidy_setopt

(PECL tidy >= 0.5.2)

tidy_setopt — Belgenin yapılandırma seçeneklerini günceller

Açıklama

bool tidy_setopt ( string $seçenek , mixed $değer )

Belgenin seçenek seçeneğinin değerini değer ile günceller.

Değiştirgeler

seçenek

Tidy seçenek ismi. Yapılandırma seçeneklerinin açıklamalarını » http://tidy.sourceforge.net/docs/quickref.html adresinde bulabilirsiniz.

değer

Seçeneğin yeni değeri.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - tidy_setopt() örneği

<?php
$html = '<p>test</i>';

$tidy = tidy_parse_string($html);

tidy_setopt('indent', FALSE);
?>

Notlar

Bilginize: Bu işlev sadece Tidy 1.0 ile kullanılabilir. Tidy 2.0'dan itibaren kullanımı önerilmemekte olup bu nedenle de kaldırılmıştır.

Ayrıca Bakınız

  • tidy_getopt() - Belirtilen yapılandırma seçeneğinin değerini döndürür
  • tidy_get_config() - Geçerli Tidy yapılandırmasını döndürür
  • tidy_reset_config() - Tidy yapılandırmasını öntanımlı değerlere ayarlar
  • tidy_save_config() - Geçerli ayarları belirtilen dosyaya kaydeder
tidy_set_encoding
tidy_warning_count
Tidy İşlevleri


Belgede saptanan Tidy uyarılarının sayısını döndürür

tidy_setopt
Simgeleştirici
Tidy İşlevleri
PHP Manual

tidy_warning_count

(PHP 5, PHP 7, PECL tidy >= 0.5.2)

tidy_warning_count — Belgede saptanan Tidy uyarılarının sayısını döndürür

Açıklama

int tidy_warning_count ( tidy $nesne )

Belgede saptanan Tidy uyarılarının sayısını döndürür.

Değiştirgeler

nesne

Tidy nesnesi.

Dönen Değerler

Uyarı sayısı.

Örnekler

Örnek 1 - tidy_warning_count() örneği

<?php
$html = '<p>test</i>
<bogustag>bogus</bogustag>';

$tidy = tidy_parse_string($html);

echo tidy_error_count($tidy) . "\n"; //1
echo tidy_warning_count($tidy) . "\n"; //5
?>

Ayrıca Bakınız

  • tidy_error_count() - Belgede saptanan Tidy hatalarının sayısını döndürür
  • tidy_access_count() - Belgede saptanan Tidy erişilebilirlik uyarılarının sayısını döndürür

tidy_setopt
Simgeleştirici
Tidy İşlevleri


Simgeleştirici

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
  • Simgeleştirici İşlevleri
    • token_get_all — Belirtilen kaynağı PHP dizgeciklerine ayırır
    • token_name — Belirtilen PHP dizgeciğinin simgesel ismini döndürür
tidy_warning_count
Giriş
Diğer Temel Eklentiler


Giriş

Simgeleştirici işlevler Zend Motoru içinde gömülü PHP simgeleştiricisine bir arayüzdür. Bu işlevleri kullanarak, sözdizimsel seviyede dil belirtimiyle uğraşmadan kendi PHP kaynak çözümleyicinizi veya değişiklik araçlarınızı yazabilirsiniz.

Ayrıca bakınız: Çözümleyici Dizgeciklerinin Listesi.

Simgeleştirici
Yapılandırma/Kurulum
Simgeleştirici


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Simgeleştirici


Kurulum

PHP 4.3.0'dan itibaren bu işlevler öntanımlı olarak etkindir. Daha eski sürümler için PHP'yi --enable-tokenizer seçeneği ile yapılandırıp derlemelisiniz. Simgeleştirici desteğini --disable-tokenizer seçeneği ile iptal edebilirsiniz.

PHP'nin Windows sürümünde bu eklenti yerleşik olarak gelmektedir. Bu işlevleri Windows'ta kullanmak için herhangi bir eklenti kurmanıza gerek yoktur.

Bilginize: PHP 4.3.0'dan beri yerleşik simgeleştirici desteği vardır.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Eklenti ya PHP içinde derlenir ya da çalışma anında devingen olarak yüklenir. Dizgecikler sabitler halinde Çözümleyici Dizgeciklerinin Listesi sayfasında listelenmiştir.

Özkaynak Türleri
Örnekler
Simgeleştirici


Örnekler

Burada simgeleştiriciyi kullanan basit PHP betiğine yer verilmişir. Betik bir PHP dosyasını okumakta, açıklamaları ayıklayıp salt PHP kodunu çıktılamaktadır.

Örnek 1 - Açıklamaları simgeleştirici ile ayıklamak

<?php
/*
* T_ML_COMMENT PHP 5'te yoktur.
* Aşağıdaki üç satırda geriye uyumluluğu
* korumak adına tanımlanmıştır.
*
* Sonraki iki satır sadece PHP 5'e özgü
* T_DOC_COMMENT'i tanımlar. PHP 4 için
* T_ML_COMMENT'i de gözönüne alacağız.
*/
if (!defined('T_ML_COMMENT')) {
   define('T_ML_COMMENT', T_COMMENT);
} else {
   define('T_DOC_COMMENT', T_ML_COMMENT);
}

$source = file_get_contents('example.php');
$tokens = token_get_all($source);

foreach ($tokens as $token) {
   if (is_string($token)) {
       // basit tek karakterlik dizgecik
       echo $token;
   } else {
       // dizgecik dizisi
       list($id, $text) = $token;

       switch ($id) {
           case T_COMMENT:
           case T_ML_COMMENT: // Bunu
           case T_DOC_COMMENT: // ve bunu
               // açıklamalar için işlem yapmamak için tanımladık
               break;

           default:
               // Kalan herşey "olduğu gibi" çıktılanacak
               echo $text;
               break;
       }
   }
}
?>
Öntanımlı Sabitler
Simgeleştirici İşlevleri
Simgeleştirici


Simgeleştirici İşlevleri

İçindekiler

  • token_get_all — Belirtilen kaynağı PHP dizgeciklerine ayırır
  • token_name — Belirtilen PHP dizgeciğinin simgesel ismini döndürür
Örnekler
token_get_all
Simgeleştirici


Belirtilen kaynağı PHP dizgeciklerine ayırır

Simgeleştirici İşlevleri
token_name
Simgeleştirici İşlevleri
PHP Manual

token_get_all

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

token_get_all — Belirtilen kaynağı PHP dizgeciklerine ayırır

Açıklama

array token_get_all ( string $kaynak )

Belirtilen kaynak dizgesi, Zend motorunun sözdizimsel tarayıcısı kullanılarak PHP dil dizgeciklerine çözümlenir.

Dizgeciklerin listesi için Çözümleyici Dizgeciklerinin Listesi sayfasına bakınız veya bir dizgecik değerini dizgesel gösterimine dönüştürmek için token_name() işlevini kullanınız.

Değiştirgeler

kaynak

Çözümlenecek PHP kaynak kodu.

Dönen Değerler

Dizgecik betimleyicilerinden oluşan bir dizi. Her dizgecik betimleyicisi ya tek bir karakterden (;, ., >, ! gibi) oluşur ya da üç elemanlı bir diziden; 0. elemanda dizgecik indisi, 1. elemanda özgün dizgeciğin dizgesel içeriği ve 2. elemanda satır numarası bulunur.

Örnekler

Örnek 1 - token_get_all() örnekleri

<?php
$tokens = token_get_all('<?php echo; ?>');
    /* => array(
             array(T_OPEN_TAG, '<?php'),
             array(T_ECHO, 'echo'),
             ';',
             array(T_CLOSE_TAG, '?>') ); */

/* Aşağıdaki örnekte dizge beklendiği gibi
   T_COMMENT (PHP <5'te' T_ML_COMMENT) olarak değil
   T_INLINE_HTML olarak çözümlenmektedir. Bunun sebebi
   sağlanan kodda hiçbir ama/kapama etiketinin bulunmayışıdır.
   Bu, normal bir dosyada <?php ?> etiketlerinin dışına
   bir açıklama koymaya eşdeğerdir. */
$tokens = token_get_all('/* açıklama */');
    // => array(array(T_INLINE_HTML, '/* comment */'));
?>

Sürüm Bilgisi

Sürüm: | Açıklama
5.2.2 | Satır numaraları 2. elemanda dönmeye başladı.

Simgeleştirici İşlevleri
token_name
Simgeleştirici İşlevleri


Belirtilen PHP dizgeciğinin simgesel ismini döndürür

token_get_all
URL'ler
Simgeleştirici İşlevleri
PHP Manual

token_name

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

token_name — Belirtilen PHP dizgeciğinin simgesel ismini döndürür

Açıklama

string token_name ( int $dizgecik )

Belirtilen PHP dizgecik değerine ilişkin simgesel ismi döndürür.

Değiştirgeler

dizgecik

Dizgecik değeri.

Dönen Değerler

Belirtilen dizgecik değerinin simgesel ismini döndürür. Dönen isim, eşleşen dizgecik sabitinin ismidir.

Örnekler

Örnek 1 - token_name() örneği

<?php
// 260 değeri, T_REQUIRE dizgeciğinin dizgecik değeridir
echo token_name(260);        // -> "T_REQUIRE"

// Bir dizgecik sabiti kendi ismiyle eşleşir
echo token_name(T_FUNCTION); // -> "T_FUNCTION"
?>

Ayrıca Bakınız

  • Çözümleyici Dizgeciklerinin Listesi

token_get_all
URL'ler
Simgeleştirici İşlevleri


URL'ler

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • URL İşlevleri
    • base64_decode — MIME base64 ile kodlanmış verinin kodunu açar
    • base64_encode — Veriye MIME base64 kodlaması uygular
    • get_headers — Bir HTTP isteğine sunucunun verdiği yanıtta gönderilen tüm başlıkları döndürür
    • get_meta_tags — Bir HTML dosyanın meta etiketlerindeki öznitelikleri çıkarıp bir dizi olarak döndürür
    • http_build_query — URL kodlamalı sorgu dizgesi üretir
    • parse_url — Bir URL'yi bileşenlerine ayırır
    • rawurldecode — URL kodlamalı dizgenin kodlamasını kaldırır
    • rawurlencode — RFC 1738'e uygun URL kodlaması yapar
    • urldecode — URL kodlamalı dizgenin kodlamasını çözer
    • urlencode — Dizgeye URL kodlaması uygular
token_name
Giriş
Diğer Temel Eklentiler


Giriş

URL dizgeleri ile çalışma: kodlama, kod açma ve çözümleme.

URL'ler
Yapılandırma/Kurulum
URL'ler


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
URL'ler


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

Burada parse_url() işlevi ile kullanılan sabitlere yer verilmiştir. Bunlar PHP 5.1.2'den beri kullanılabilmektedir.

PHP_URL_SCHEME (integer)
PHP_URL_HOST (integer)
PHP_URL_PORT (integer)
PHP_URL_USER (integer)
PHP_URL_PASS (integer)
PHP_URL_PATH (integer)
PHP_URL_QUERY (integer)
PHP_URL_FRAGMENT (integer)
Özkaynak Türleri
URL İşlevleri
URL'ler


URL İşlevleri

İçindekiler

  • base64_decode — MIME base64 ile kodlanmış verinin kodunu açar
  • base64_encode — Veriye MIME base64 kodlaması uygular
  • get_headers — Bir HTTP isteğine sunucunun verdiği yanıtta gönderilen tüm başlıkları döndürür
  • get_meta_tags — Bir HTML dosyanın meta etiketlerindeki öznitelikleri çıkarıp bir dizi olarak döndürür
  • http_build_query — URL kodlamalı sorgu dizgesi üretir
  • parse_url — Bir URL'yi bileşenlerine ayırır
  • rawurldecode — URL kodlamalı dizgenin kodlamasını kaldırır
  • rawurlencode — RFC 1738'e uygun URL kodlaması yapar
  • urldecode — URL kodlamalı dizgenin kodlamasını çözer
  • urlencode — Dizgeye URL kodlaması uygular
Öntanımlı Sabitler
base64_decode
URL'ler


MIME base64 ile kodlanmış verinin kodunu açar

URL İşlevleri
base64_encode
URL İşlevleri
PHP Manual

base64_decode

(PHP 4, PHP 5, PHP 7)

base64_decode — MIME base64 ile kodlanmış verinin kodunu açar

Açıklama

string base64_decode ( string $veri [, bool $titiz = false ] )

MIME base64 ile kodlanmış veri'nin kodlamasını kaldırır.

Değiştirgeler

veri

Kodlaması kaldırılacak veri.

titiz

Girdi base64 karakterleri dışında karakterler içeriyorsa işlev FALSE döndürür.

Dönen Değerler

Başarısızlık durumunda FALSE aksi takdirde özgün veriyi döndürür. Dönen veri ikil olabilir.

Sürüm Bilgisi

Sürüm: | Açıklama
5.2.0 | titiz değiştirgesi eklendi.

Örnekler

Örnek 1 - base64_decode() örneği

<?php
$dizge = 'QnUgZGl6Z2Uga29kbGFubcSxxZ8gb2xhY2FrLg==';
echo base64_decode($dizge);
?>

Yukarıdaki örneğin çıktısı:

Bu dizge kodlanmış olacak.

Ayrıca Bakınız

  • base64_encode() - Veriye MIME base64 kodlaması uygular
  • » RFC 2045 bölüm 6.8

URL İşlevleri
base64_encode
URL İşlevleri


Veriye MIME base64 kodlaması uygular

base64_decode
get_headers
URL İşlevleri
PHP Manual

base64_encode

(PHP 4, PHP 5, PHP 7)

base64_encode — Veriye MIME base64 kodlaması uygular

Açıklama

string base64_encode ( string $veri )

Belirtilen veri'ye base64 kodlaması uygular.

Bu kodlama eposta gövdeleri gibi 8 bitlik olamayan aktarım katmanları üzerinden ikil verileri aktarabilmek için tasarlanmıştır.

Base64 kodlu veri, özgün veriden %33 daha fazla yer kaplar.

Değiştirgeler

veri

Kodlanacak veri.

Dönen Değerler

Kodlanmış veri bir dizge olarak döner.

Örnekler

Örnek 1 - base64_encode() örneği

<?php
$dizge = 'Bu dizge kodlanmış olacak.';
echo base64_encode($dizge);
?>

Yukarıdaki örneğin çıktısı:

QnUgZGl6Z2Uga29kbGFubcSxxZ8gb2xhY2FrLg==

Ayrıca Bakınız

  • base64_decode() - MIME base64 ile kodlanmış verinin kodunu açar
  • chunk_split() - Bir dizgeyi daha küçük parçalara ayırır
  • convert_uuencode() - Bir dizgeyi uuencode algoritmasıyla kodlar
  • » RFC 2045 bölüm 6.8

base64_decode
get_headers
URL İşlevleri


Bir HTTP isteğine sunucunun verdiği yanıtta gönderilen tüm başlıkları döndürür

base64_encode
get_meta_tags
URL İşlevleri
PHP Manual

get_headers

(PHP 5, PHP 7)

get_headers — Bir HTTP isteğine sunucunun verdiği yanıtta gönderilen tüm başlıkları döndürür

Açıklama

array get_headers ( string $url [, int $biçemle = 0 ] )

get_headers() işlevi, bir HTTP isteğine sunucunun verdiği yanıtta gönderilen tüm başlıkları bir dizi içinde döndürür.

Değiştirgeler

url

Hedef URL.

biçemle

İsteğe bağlı biçem değiştirgesinde sıfırdan farklı bir değer belirtilirse get_headers() yanıtı çözümleyip başlıkları dizinin anahtarları haline getirir.

Dönen Değerler

Başarısızlık durumunda FALSE, aksi takdirde başlıkları içeren indisli veya ilişkisel bir dizi döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.3 | Bu işlev artık stream_context_get_default() işlevi tarafından atanan/değiştirilebilen öntanımlı akım bağlamını kullanmaktadır.

Örnekler

Örnek 1 - get_headers() örneği

<?php
$url = 'http://www.example.com';

print_r(get_headers($url));

print_r(get_headers($url, 1));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [0] => HTTP/1.1 200 OK
    [1] => Date: Sat, 29 May 2004 12:28:13 GMT
    [2] => Server: Apache/1.3.27 (Unix)  (Red-Hat/Linux)
    [3] => Last-Modified: Wed, 08 Jan 2003 23:11:55 GMT
    [4] => ETag: "3f80f-1b6-3e1cb03b"
    [5] => Accept-Ranges: bytes
    [6] => Content-Length: 438
    [7] => Connection: close
    [8] => Content-Type: text/html
)

Array
(
    [0] => HTTP/1.1 200 OK
    [Date] => Sat, 29 May 2004 12:28:14 GMT
    [Server] => Apache/1.3.27 (Unix)  (Red-Hat/Linux)
    [Last-Modified] => Wed, 08 Jan 2003 23:11:55 GMT
    [ETag] => "3f80f-1b6-3e1cb03b"
    [Accept-Ranges] => bytes
    [Content-Length] => 438
    [Connection] => close
    [Content-Type] => text/html
)

base64_encode
get_meta_tags
URL İşlevleri


Bir HTML dosyanın meta etiketlerindeki öznitelikleri çıkarıp bir dizi olarak döndürür

get_headers
http_build_query
URL İşlevleri
PHP Manual

get_meta_tags

(PHP 4, PHP 5, PHP 7)

get_meta_tags — Bir HTML dosyanın meta etiketlerindeki öznitelikleri çıkarıp bir dizi olarak döndürür

Açıklama

array get_meta_tags ( string $dosya [, bool $include_path_kullan = false ] )

Belirtilen dosya dosyasını açar ve <meta> etiketlerini satır satır çözümler. Çözümleme </head> etiketine rastlanıncaya kadar sürer.

Değiştirgeler

dosya

HTML dosyasının yolu. Bu bir yerel dosya olabileceği gibi bir URL de olabilir.

Örnek 1 - get_meta_tags() bunları çözümler

<meta name="author" content="name">
<meta name="keywords" content="php documentation">
<meta name="DESCRIPTION" content="a php manual">
<meta name="geo.position" content="49.33;-86.59">
</head> <!-- çözümleme burada biter -->
(Satır sonlarına dikkat edin - PHP çözümleme için platforma özgü bir işlev kullanır, bu bakımdan bir Mac dosyası Unix üzerinde çalışmaz.)

include_path_kullan

Bu değiştirgeye TRUE belirtildiği takdirde, PHP HTML dosyayı include_path yönergesinde belirtilen yollarda arar. Bu, sadece yerel dosyalar için geçerlidir; URL'lerde kullanılmaz.

Dönen Değerler

Bütün meta etiketlerinden ayrıştırılan öznitelikleri içeren bir dizi döner.

name özniteliğinin değerinin anahtar; content özniteliğinin değerinin değer olduğu elemanlardan oluşan bir dizi döner. Böylece standart dizi işlevleri ile bu dizi elemanları üzerinde tek tek işlem yapabilirsiniz. name özniteliğinin içindeki özel karakterlerin yerlerine birer '_' konur ve kalan harfler küçük harfe dönüştürülür. Aynı name özniteliğine sahip iki meta etiketi varsa sadece sonuncusu döner.

Sürüm Bilgisi

Sürüm: | Açıklama
4.0.5 | Tırnak içine alınmamış öznitelik değerleri için destek sağlandı.

Örnekler

Örnek 2 - get_meta_tags() örneği

<?php
// Aşağıdaki özniteliklerin index.php dosyasından geldiği varsayılmıştır
$tags = get_meta_tags('http://www.example.com/');

// Anahtarların küçük harfe dönüştürüleceğini unutmayın.
// Ayrıca, anahtar içindeki noktalar _ ile değiştirilir.
echo $tags['author'];       // isim
echo $tags['keywords'];     // php belgeleri
echo $tags['description'];  // php kılavuzu
echo $tags['geo_position']; // 49.33;-86.59
?>

Ayrıca Bakınız

  • htmlentities() - Dönüştürülebilecek tüm karakterleri HTML öğeleri haline getirir
  • urlencode() - Dizgeye URL kodlaması uygular

get_headers
http_build_query
URL İşlevleri


URL kodlamalı sorgu dizgesi üretir

get_meta_tags
parse_url
URL İşlevleri
PHP Manual

http_build_query

(PHP 5, PHP 7)

http_build_query — URL kodlamalı sorgu dizgesi üretir

Açıklama

string http_build_query ( array $form_verisi [, string $sayısal_önek [, string $ayraç ]] )

Belirtilen ilişkisel (veya indisli) diziden bir URL kodlamalı dizge üretir.

Değiştirgeler

form_verisi

Özellikleri içeren bir dizi veya nesne belirtilebilir.

Belirtilen dizi tek boyutlu bir dizi olabileceği gibi çok boyutlu iç içe diziler içeren bir dizi de olabilir.

sayısal_önek

Temel dizide sayısal indisler kullanılmışsa sayısal indislerin her birinin önüne bu değiştirgede belirtilen değer getirilir ve bu sadece temel dizinin indislerine uygulanır.

Bunun böyle yapılmasının sebebi, verinin daha sonra PHP veya başka bir CGI uygulaması tarafından URL kodlaması çözüldüğünde elde geçerli (meşru) değişken isimleri kalmasını sağlamaktır.

ayraç

Bu değiştirgede bir ayraç belirtilmezse değiştirge ayracı olarak arg_separator.output yönergesinde belirtilen ayraç kullanılır.

Dönen Değerler

URL kodlamalı bir dizge döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.2 | ayraç değiştirgesi eklendi.
5.1.3 | Köşeli ayraçlar öncelendi.

Örnekler

Örnek 1 - http_build_query() basit kullanımı

<?php
$data = array('foo'=>'bar',
              'baz'=>'boom',
              'cow'=>'milk',
              'php'=>'hypertext processor');

echo http_build_query($data);
    // foo=bar&baz=boom&cow=milk&php=hypertext+processor
echo http_build_query($data, '', '&amp;');
    // foo=bar&amp;baz=boom&amp;cow=milk&amp;php=hypertext+processor

?>

Örnek 2 - Sayısal indisli elemanlarla http_build_query()

<?php
$data = array('foo', 'bar', 'baz', 'boom',
              'cow' => 'milk',
              'php' =>'hypertext processor');

echo http_build_query($data) . "\n";
echo http_build_query($data, 'myvar_');
?>

Yukarıdaki örneğin çıktısı:

0=foo&1=bar&2=baz&3=boom&cow=milk&php=hypertext+processor
myvar_0=foo&myvar_1=bar&myvar_2=baz&myvar_3=boom&cow=milk&php=hypertext+processor

Örnek 3 - http_build_query() ve çok boyutlu diziler

<?php
$data = array('user'=>array('name'=>'Bob Smith',
                            'age'=>47,
                            'sex'=>'M',
                            'dob'=>'5/12/1956'),
              'pastimes'=>array('golf', 'opera', 'poker', 'rap'),
              'children'=>array('bobby'=>array('age'=>12,
                                               'sex'=>'M'),
                                'sally'=>array('age'=>8,
                                               'sex'=>'F')),
              'CEO');

echo http_build_query($data, 'flags_');
?>

Örneğin çıktısı: (okunabilirlik için satır katlanmıştır)

user%5Bname%5D=Bob+Smith&user%5Bage%5D=47&user%5Bsex%5D=M&
user%5Bdob%5D=5%2F12%2F1956&pastimes%5B0%5D=golf&pastimes%5B1%5D=opera&
pastimes%5B2%5D=poker&pastimes%5B3%5D=rap&children%5Bbobby%5D%5Bage%5D=12&
children%5Bbobby%5D%5Bsex%5D=M&children%5Bsally%5D%5Bage%5D=8&
children%5Bsally%5D%5Bsex%5D=F&flags_0=CEO

Bilginize:

Sadece, temel dizi içindeki sayısal indisli "CEO" elemanı bir önek alır. Alt dizilerdeki diğer sayısal indislerin meşru değişken ismi olabilmesi için bir dizge ile öncelenmeleri gerekmez.

Örnek 4 - http_build_query() ve bir nesne

<?php
class myClass {
    var $foo;
    var $baz;

    function myClass() {
        $this->foo = 'bar';
        $this->baz = 'boom';
    }
}

$data = new myClass();

echo http_build_query($data); // foo=bar&baz=boom

?>

Ayrıca Bakınız

  • parse_str() - Dizge içindeki değişkenleri çözümler
  • parse_url() - Bir URL'yi bileşenlerine ayırır
  • urlencode() - Dizgeye URL kodlaması uygular
  • array_walk() - Bir dizinin her üyesine kullanıcı tanımlı bir işlevi uygular

get_meta_tags
parse_url
URL İşlevleri


Bir URL'yi bileşenlerine ayırır

http_build_query
rawurldecode
URL İşlevleri
PHP Manual

parse_url

(PHP 4, PHP 5, PHP 7)

parse_url — Bir URL'yi bileşenlerine ayırır

Açıklama

mixed parse_url ( string $url [, int $bileşen = -1 ] )

Bu işlev belirtilen URL'yi bileşenlerine ayırıp, bunları bir ilişkisel dizi içinde döndürür.

Bu işlev, bir URL doğrulayıcı olarak kullanılmamalıdır. Yaptığı sadece URL'yi aşağıda belirtilen parçalara ayırmaktır. URL'ler kısmi olarak da kabul edilir. İşlev bunları en doğru şekilde bileşenlerine ayırmaya çalışır.

Değiştirgeler

url

Ayrıştırılacak URL. Geçersiz karakterlerin yerine _ konur.

bileşen

Belli bir URL bileşenini dizge olarak döndürmek isterseniz bu değiştirgede şu sabitlerden birini belirtin: PHP_URL_SCHEME, PHP_URL_HOST, PHP_URL_PORT, PHP_URL_USER, PHP_URL_PASS, PHP_URL_PATH, PHP_URL_QUERY, PHP_URL_FRAGMENT.

Dönen Değerler

Tehlikeli şekilde bozulmuş URL'lerde parse_url() FALSE döndürebilir ve bir E_WARNING çıktılayabilir. Aksi takdirde, şu bileşenleri bir ilişkisel dizi olarak döndürür (en az biri):

  • scheme - http:// gibi
  • host - konak ismi
  • port - port
  • user - kullanıcı
  • pass - parola
  • path - dosya yolu
  • query - sorgu; bir soru (?) iminden sonra.
  • fragment - örgü; # iminden sonra

bileşen değiştirgesinde bir sabit belirtilmişse bir dizi yerine bir dizge döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.2 | bileşen değiştirgesi eklendi.

Örnekler

Örnek 1 - parse_url() örneği

<?php
$url = 'http://username:password@hostname/path?arg=value#anchor';

print_r(parse_url($url));

echo parse_url($url, PHP_URL_PATH);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [scheme] => http
    [host] => hostname
    [user] => username
    [pass] => password
    [path] => /path
    [query] => arg=value
    [fragment] => anchor
)
/path

Notlar

Bilginize:

Bu işlev göreli URL'lerle çalışmaz.

Bilginize:

Bu işlev URI'leri değil, özellikle URL'leri ayrıştırmak için tasarlanmıştır. Ancak, PHP'nin geriye uyumluluğu için file:// şeması için istisnai bir durum olarak file:/// şemasına da izin verilir. Bunun dışındaki şemalar için bu uygulama geçersizdir.

Ayrıca Bakınız

  • pathinfo() - Bir dosya yolu hakkında bilgi döndürür
  • parse_str() - Dizge içindeki değişkenleri çözümler
  • http_build_query() - URL kodlamalı sorgu dizgesi üretir
  • http_build_url()
  • dirname() - Belirtilen dosya yolunun dizin bileşenini döndürür
  • basename() - Dosya yolunun dosya ismi bileşenini döndürür

http_build_query
rawurldecode
URL İşlevleri


URL kodlamalı dizgenin kodlamasını kaldırır

parse_url
rawurlencode
URL İşlevleri
PHP Manual

rawurldecode

(PHP 4, PHP 5, PHP 7)

rawurldecode — URL kodlamalı dizgenin kodlamasını kaldırır

Açıklama

string rawurldecode ( string $dizge )

Belirtilen dizge içindeki %## dizilimlerinin yerine karşılığı olan karakterleri yerleştirerek dizgenin kodlamasını kaldırır.

Değiştirgeler

dizge

Kodlaması kaldırılacak URL.

Dönen Değerler

Kodlaması kaldırılmış URL'yi bir dizge olarak döndürür.

Örnekler

Örnek 1 - rawurldecode() örneği

<?php

echo rawurldecode('foo%20bar%40baz'); // foo bar@baz

?>

Notlar

Bilginize:

rawurldecode() işlevi, urldecode() işlevinden farklı olarak artı (+) imlerini boşluklara dönüştürmez.

Ayrıca Bakınız

  • rawurlencode() - RFC 1738'e uygun URL kodlaması yapar
  • urldecode() - URL kodlamalı dizgenin kodlamasını çözer
  • urlencode() - Dizgeye URL kodlaması uygular

parse_url
rawurlencode
URL İşlevleri


RFC 1738'e uygun URL kodlaması yapar

rawurldecode
urldecode
URL İşlevleri
PHP Manual

rawurlencode

(PHP 4, PHP 5, PHP 7)

rawurlencode — RFC 1738'e uygun URL kodlaması yapar

Açıklama

string rawurlencode ( string $dizge )

Belirtilen dizgeye » RFC 1738'e uygun URL kodlaması uygular.

Değiştirgeler

dizge

Kodlanacak URL.

Dönen Değerler

Belirtilen dizge içindeki karakterlerden, -_. dışındaki abecesayısal olmayan tüm karakterlerin yüzde (%) imiyle öncelenmiş iki onaltılık rakamla değiştirildiği bir kodlama uygulanmış bir dizge döndürür. Bu kodlama, » RFC 1738'de açıklanan kodlama olup, bazı karakterlerin URL ayracı olarak yorumlanmasını önlemek ve (bazı eposta sistemlerinde) URL'lerin aktarım ortamında karakter dönüşümleri ile bozunmaya uğramaması için kullanılır.

Örnekler

Örnek 1 - Bir FTP URL'sinde parola belirtmek

<?php
echo '<a href="ftp://user:', rawurlencode('foo @+%/'),
     '@ftp.example.com/x.txt">';
?>

Yukarıdaki örneğin çıktısı:

<a href="ftp://user:foo%20%40%2B%25%2F@ftp.example.com/x.txt">

Bilgiyi URL'nin PATH_INFO bileşeninde aktarırsanız:

Örnek 2 - Başka bir rawurlencode() örneği

<?php
echo '<a href="http://example.com/department_list_script/',
    rawurlencode('sales and marketing/Miami'), '">';
?>

Yukarıdaki örneğin çıktısı:

<a href="http://example.com/department_list_script/sales%20and%20marketing%2FMiami">

Ayrıca Bakınız

  • rawurldecode() - URL kodlamalı dizgenin kodlamasını kaldırır
  • urldecode() - URL kodlamalı dizgenin kodlamasını çözer
  • urlencode() - Dizgeye URL kodlaması uygular
  • » RFC 1738

rawurldecode
urldecode
URL İşlevleri


URL kodlamalı dizgenin kodlamasını çözer

rawurlencode
urlencode
URL İşlevleri
PHP Manual

urldecode

(PHP 4, PHP 5, PHP 7)

urldecode — URL kodlamalı dizgenin kodlamasını çözer

Açıklama

string urldecode ( string $dizge )

Belirtilen dizge içindeki %## dizilimlerinin yerine karşılığı olan karakterleri yerleştirerek dizgenin kodlamasını kaldırır. Artı işaretleri ('+') birer boşluk karateri olarak çözümlenir.

Değiştirgeler

dizge

Kodlaması kaldırılacak dizge.

Dönen Değerler

Kodlanmamış dizge döner.

Örnekler

Örnek 1 - urldecode() örneği

<?php
$a = explode('&', $QUERY_STRING);
$i = 0;
while ($i < count($a)) {
    $b = split('=', $a[$i]);
    echo htmlspecialchars(urldecode($b[0])), ' değiştirgesinin değeri: ',
         htmlspecialchars(urldecode($b[1])), "<br />\n";
    $i++;
}
?>

Notlar

Uyarı

$_GET ve $_REQUEST süper küreselleri zaten kodlanmış değildir. $_GET veya $_REQUEST içindeki bir elemana urldecode() uygulamak beklenmedik ve tehlikeli sonuçlar verebilir.

Ayrıca Bakınız

  • urlencode() - Dizgeye URL kodlaması uygular
  • rawurlencode() - RFC 1738'e uygun URL kodlaması yapar
  • rawurldecode() - URL kodlamalı dizgenin kodlamasını kaldırır

rawurlencode
urlencode
URL İşlevleri


Dizgeye URL kodlaması uygular

urldecode
V8js
URL İşlevleri
PHP Manual

urlencode

(PHP 4, PHP 5, PHP 7)

urlencode — Dizgeye URL kodlaması uygular

Açıklama

string urlencode ( string $dizge )

Değişkenleri sonraki sayfaya aktarmak için bir URL'nin parçası olarak bir sorgu dizgesinde kullanılmak üzere bir dizgeyi kodlar.

Değiştirgeler

dizge

Kodlanacak dizge.

Dönen Değerler

Belirtilen dizge içindeki karakterlerden, -_. dışındaki abecesayısal olmayan tüm karakterlerin yüzde (%) imiyle öncelenmiş iki onaltılık rakamla; boşlukların ise artı (+) imi ile değiştirildiği bir kodlama uygulanmış bir dizge döndürür. Bir HTML formundan gönderilen veriye de aynı kodlama uygulanır ve bu yolla elde edilen dizgenin biçemi application/x-www-form-urlencoded ortam türü olarak bilinir. Bu biçem, tarihsel sebeplerle boşlukların artı (+) imi ile kodlanmasıyla » RFC 1738 kodlamasından farklıdır (rawurlencode() işlevine bakınız).

Örnekler

Örnek 1 - urlencode() örneği

<?php
echo '<a href="mycgi?foo=', urlencode($userinput), '">';
?>

Örnek 2 - urlencode() ve htmlentities() örneği

<?php
$query_string = 'foo=' . urlencode($foo) . '&bar=' . urlencode($bar);
echo '<a href="mycgi?' . htmlentities($query_string) . '">';
?>

Notlar

Bilginize:

HTML öğeleri olarak ele alınabilecek değişken isimlerine karşı dikkatli olun. &amp, &copy and &pound gibi şeyler tarayıcı tarafından çözümlenir ve istenen değişken ismi yerine bu HTML öğesi kullanılır. Bu, W3C'nin yıllardır söyleye geldiği zorluklardan biridir. Bakınız: » http://www.w3.org/TR/html4/appendix/notes.html#h-B.2.2.

PHP, değiştirge ayracının, W3C'nin önerdiği noktalı virgül olarak değiştirilmesini arg_separator.output php.ini yönergesi üzerinden destekler. Maalesef, çoğu tarayıcı form verisini noktalı virgül ayraçlı biçemde göndermemektedir. Daha taşınabilir bir yol, değiştirge ayracı olarak & yerine &amp; kullanmaktır. Bunu sağlamak için PHP'nin arg_separator.output yönergesinde değişiklik yapmanız gerekmez. Yönergenin değerini & olarak bırakın, fakat URL'lerinizi htmlentities() veya htmlspecialchars() ile kodlayın.

Ayrıca Bakınız

  • urldecode() - URL kodlamalı dizgenin kodlamasını çözer
  • htmlentities() - Dönüştürülebilecek tüm karakterleri HTML öğeleri haline getirir
  • rawurlencode() - RFC 1738'e uygun URL kodlaması yapar
  • rawurldecode() - URL kodlamalı dizgenin kodlamasını kaldırır

urldecode
V8js
URL İşlevleri


V8 Javascript Engine Integration

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Örnekler
  • V8Js — The V8Js class
    • V8Js::__construct — Construct a new V8Js object
    • V8Js::executeString — Execute a string as Javascript code
    • V8Js::getExtensions — Return an array of registered extensions
    • V8Js::getPendingException — Return pending uncaught Javascript exception
    • V8Js::registerExtension — Register Javascript extensions for V8Js
  • V8JsException — The V8JsException class
    • V8JsException::getJsFileName — The getJsFileName purpose
    • V8JsException::getJsLineNumber — The getJsLineNumber purpose
    • V8JsException::getJsSourceLine — The getJsSourceLine purpose
    • V8JsException::getJsTrace — The getJsTrace purpose
urlencode
Giriş
Diğer Temel Eklentiler


Giriş

This extension embeds the » V8 Javascript Engine into PHP.

V8js
Yapılandırma/Kurulum
V8js


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
V8js


Gereksinimler

PHP 5.3.3+ and V8 library and headers installed in proper paths.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/v8js

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

V8js Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
v8js.max_disposed_contexts | 25 | PHP_INI_ALL |
v8js.flags |  | PHP_INI_ALL |

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

v8js.max_disposed_contexts integer

Sets limit for disposed contexts before forcing V8 to do garbage collection.

v8js.flags string

Sets V8 command line flags. The list of available flags can be obtained in CLI mode by setting this parameter to --help. Example:

$ php -r 'ini_set("v8js.flags", "--help"); new V8Js;' | less

Bilginize:

For these flags to be effective in runtime the ini_set() call has to be done before any V8Js objects are instantiated!

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Örnekler

Basic usage

Örnek 1 Basic Javascript execution

<?php

$v8 = new V8Js();

/* basic.js */
$JS = <<< EOT
len = print('Hello' + ' ' + 'World!' + "\\n");
len;
EOT;

try {
  var_dump($v8->executeString($JS, 'basic.js'));
} catch (V8JsException $e) {
  var_dump($e);
}

?>

Yukarıdaki örneğin çıktısı:

Hello World!
int(13)
Özkaynak Türleri
V8Js
V8js


The V8Js class

(PECL v8js >= 0.1.0)

Giriş

This is the core class for V8Js extension. Each instance created from this class has own context in which all JavaScript is compiled and executed.

See V8Js::__construct() for more information.

Sınıf Sözdizimi

V8Js {
/* Constants */
const string V8_VERSION ;
const integer FLAG_NONE = 1 ;
const integer FLAG_FORCE_ARRAY = 2 ;
/* Methods */
public __construct ([ string $object_name = "PHP" [, array $variables = array() [, array $extensions = array() [, bool $report_uncaught_exceptions = TRUE ]]]] )
public mixed executeString ( string $script [, string $identifier = "V8Js::executeString()" [, int $flags = V8Js::FLAG_NONE ]] )
public static array getExtensions ( void )
public V8JsException getPendingException ( void )
public static bool registerExtension ( string $extension_name , string $script [, array $dependencies = array() [, bool $auto_enable = FALSE ]] )
}

Öntanımlı Sabitler

V8Js::V8_VERSION

The V8 Javascript Engine version.

V8Js::FLAG_NONE

No flags.

V8Js::FLAG_FORCE_ARRAY

Forces all JS objects to be associative arrays in PHP.

İçindekiler

  • V8Js::__construct — Construct a new V8Js object
  • V8Js::executeString — Execute a string as Javascript code
  • V8Js::getExtensions — Return an array of registered extensions
  • V8Js::getPendingException — Return pending uncaught Javascript exception
  • V8Js::registerExtension — Register Javascript extensions for V8Js
Örnekler
V8Js::__construct
V8js


Construct a new V8Js object

V8Js
V8Js::executeString
V8Js
PHP Manual

V8Js::__construct

(PECL v8js >= 0.1.0)

V8Js::__construct — Construct a new V8Js object

Açıklama

 public V8Js::__construct
  ([ string $object_name = "PHP"
 [, array $variables = array()
 [, array $extensions = array()
 [, bool $report_uncaught_exceptions = TRUE
]]]] )

Constructs a new V8Js object.

Değiştirgeler

object_name

The name of the object passed to Javascript.

variables

Map of PHP variables that will be available in Javascript. Must be an associative array in format array("name-for-js" => "name-of-php-variable"). Defaults to empty array.

extensions

List of extensions registered using V8Js::registerExtension() which should be available in the Javascript context of the created V8Js object.

Bilginize:

Extensions registered to be enabled automatically do not need to be listed in this array. Also if an extension has dependencies, those dependencies can be omitted as well. Defaults to empty array.

report_uncaught_exceptions

Controls whether uncaught Javascript exceptions are reported immediately or not. Defaults to TRUE. If set to FALSE the uncaught exception can be accessed using V8Js::getPendingException().

Dönen Değerler

Returns a new V8Js context object.

V8Js
V8Js::executeString
V8Js


Execute a string as Javascript code

V8Js::__construct
V8Js::getExtensions
V8Js
PHP Manual

V8Js::executeString

(PECL v8js >= 0.1.0)

V8Js::executeString — Execute a string as Javascript code

Açıklama

public mixed V8Js::executeString ( string $script [, string $identifier = "V8Js::executeString()" [, int $flags = V8Js::FLAG_NONE ]] )

Compiles and executes the string passed with script as Javascript code.

Değiştirgeler

script

The code string to be executed.

identifier

Identifier string for the executed code. Used for debugging.

flags

Execution flags. This value must be one of the V8Js::FLAG_* constants, defaulting to V8Js::FLAG_NONE.

  • V8Js::FLAG_NONE: no flags

  • V8Js::FLAG_FORCE_ARRAY: forces all Javascript objects passed to PHP to be associative arrays

Dönen Değerler

Returns the last variable instantiated in the Javascript code converted to matching PHP variable type.

V8Js::__construct
V8Js::getExtensions
V8Js


Return an array of registered extensions

V8Js::executeString
V8Js::getPendingException
V8Js
PHP Manual

V8Js::getExtensions

(PECL v8js >= 0.1.0)

V8Js::getExtensions — Return an array of registered extensions

Açıklama

public static array V8Js::getExtensions ( void )

This function returns array of Javascript extensions registered using V8Js::registerExtension().

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array of registered extensions or an empty array if there are none.

V8Js::executeString
V8Js::getPendingException
V8Js


Return pending uncaught Javascript exception

V8Js::getExtensions
V8Js::registerExtension
V8Js
PHP Manual

V8Js::getPendingException

(PECL v8js >= 0.1.0)

V8Js::getPendingException — Return pending uncaught Javascript exception

Açıklama

public V8JsException V8Js::getPendingException ( void )

Returns any pending uncaught Javascript exception as V8JsException left from earlier V8Js::executeString() call(s).

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Either V8JsException or NULL.

V8Js::getExtensions
V8Js::registerExtension
V8Js


Register Javascript extensions for V8Js

V8Js::getPendingException
V8JsException
V8Js
PHP Manual

V8Js::registerExtension

(PECL v8js >= 0.1.0)

V8Js::registerExtension — Register Javascript extensions for V8Js

Açıklama

public static bool V8Js::registerExtension ( string $extension_name , string $script [, array $dependencies = array() [, bool $auto_enable = FALSE ]] )

Registers passed Javascript script as extension to be used in V8Js contexts.

Değiştirgeler

extension_name

Name of the extension to be registered.

script

The Javascript code to be registered.

dependencies

Array of extension names the extension to be registered depends on. Any such extension is enabled automatically when this extension is loaded.

Bilginize:

All extensions, including the dependencies, must be registered before any V8Js are created which use them.

auto_enable

If set to TRUE, the extension will be enabled automatically in all V8Js contexts.

Dönen Değerler

Returns TRUE if extension was registered successfully, FALSE otherwise.

V8Js::getPendingException
V8JsException
V8Js


The V8JsException class

(PECL v8js >= 0.1.0)

Giriş

Sınıf Sözdizimi

V8JsException extends Exception {
/* Özellikler */
protected $JsFileName ;
protected $JsLineNumber ;
protected $JsSourceLine ;
protected $JsTrace ;
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Yöntemler */
final public string getJsFileName ( void )
final public int getJsLineNumber ( void )
final public string getJsSourceLine ( void )
final public string getJsTrace ( void )
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}

Özellikler

JsFileName

JsLineNumber

JsSourceLine

JsTrace

İçindekiler

  • V8JsException::getJsFileName — The getJsFileName purpose
  • V8JsException::getJsLineNumber — The getJsLineNumber purpose
  • V8JsException::getJsSourceLine — The getJsSourceLine purpose
  • V8JsException::getJsTrace — The getJsTrace purpose
V8Js::registerExtension
V8JsException::getJsFileName
V8js


The getJsFileName purpose

V8JsException
V8JsException::getJsLineNumber
V8JsException
PHP Manual

V8JsException::getJsFileName

(PECL v8js >= 0.1.0)

V8JsException::getJsFileName — The getJsFileName purpose

Açıklama

final public string V8JsException::getJsFileName ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

V8JsException
V8JsException::getJsLineNumber
V8JsException


The getJsLineNumber purpose

V8JsException::getJsFileName
V8JsException::getJsSourceLine
V8JsException
PHP Manual

V8JsException::getJsLineNumber

(PECL v8js >= 0.1.0)

V8JsException::getJsLineNumber — The getJsLineNumber purpose

Açıklama

final public int V8JsException::getJsLineNumber ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

V8JsException::getJsFileName
V8JsException::getJsSourceLine
V8JsException


The getJsSourceLine purpose

V8JsException::getJsLineNumber
V8JsException::getJsTrace
V8JsException
PHP Manual

V8JsException::getJsSourceLine

(PECL v8js >= 0.1.0)

V8JsException::getJsSourceLine — The getJsSourceLine purpose

Açıklama

final public string V8JsException::getJsSourceLine ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

V8JsException::getJsLineNumber
V8JsException::getJsTrace
V8JsException


The getJsTrace purpose

V8JsException::getJsSourceLine
Yaml
V8JsException
PHP Manual

V8JsException::getJsTrace

(PECL v8js >= 0.1.0)

V8JsException::getJsTrace — The getJsTrace purpose

Açıklama

final public string V8JsException::getJsTrace ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

V8JsException::getJsSourceLine
Yaml
V8JsException


YAML Data Serialization

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
  • Callbacks
    • Parse callbacks
    • Emit callbacks
  • Yaml İşlevleri
    • yaml_emit_file — Send the YAML representation of a value to a file
    • yaml_emit — Returns the YAML representation of a value
    • yaml_parse_file — Parse a YAML stream from a file
    • yaml_parse_url — Parse a Yaml stream from a URL
    • yaml_parse — Parse a YAML stream
V8JsException::getJsTrace
Giriş
Diğer Temel Eklentiler


Giriş

This extension implements the » YAML Ain't Markup Language (YAML) data serialization standard. Parsing and emiting are handled by the » LibYAML library.

Yaml
Yapılandırma/Kurulum
Yaml


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Yaml


Gereksinimler

This extension requires the » LibYAML C library version 0.1.0 or higher to be installed.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu » PECL eklentisi PHP ile gelmez.

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/yaml.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Yaml Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
yaml.decode_binary | 0 | PHP_INI_ALL |
yaml.decode_php | 1 | PHP_INI_ALL |
yaml.decode_timestamp | 0 | PHP_INI_ALL |
yaml.output_canonical | 0 | PHP_INI_ALL |
yaml.output_indent | 2 | PHP_INI_ALL |
yaml.output_width | 80 | PHP_INI_ALL |

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

yaml.decode_binary boolean

Off by default, but can be set to on to cause base64 binary encoded entities which have the explicit tag "tag:yaml.org,2002:binary" to be decoded.

yaml.decode_php boolean

On by default, but can be set to off to prevent serialized php objects which have the explicit tag "!php/object" from being unserialized.

yaml.decode_timestamp integer

Controls the decoding of both implicit and explict "tag:yaml.org,2002:timestamp" scalars in the YAML document stream. The default setting of 0 will not apply any decoding. A setting of 1 will use strtotime() to parse the timestamp value as a Unix timestamp. A setting of 2 will use date_create() to parse the timestamp value as DateTime object.

yaml.output_canonical boolean

Off by default, but can be set to on to cause canonical form output.

yaml.output_indent integer

Number of spaces to indent sections. Value should be between 1 and 10.

yaml.output_width integer

Set the preferred line width. -1 means unlimited.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

Scalar entity styles usable by yaml_parse() callback methods.
YAML_ANY_SCALAR_STYLE (integer)
YAML_PLAIN_SCALAR_STYLE (integer)
YAML_SINGLE_QUOTED_SCALAR_STYLE (integer)
YAML_DOUBLE_QUOTED_SCALAR_STYLE (integer)
YAML_LITERAL_SCALAR_STYLE (integer)
YAML_FOLDED_SCALAR_STYLE (integer)
Common tags usable by yaml_parse() callback methods.
YAML_NULL_TAG (string)
"tag:yaml.org,2002:null"
YAML_BOOL_TAG (string)
"tag:yaml.org,2002:bool"
YAML_STR_TAG (string)
"tag:yaml.org,2002:str"
YAML_INT_TAG (string)
"tag:yaml.org,2002:int"
YAML_FLOAT_TAG (string)
"tag:yaml.org,2002:float"
YAML_TIMESTAMP_TAG (string)
"tag:yaml.org,2002:timestamp"
YAML_SEQ_TAG (string)
"tag:yaml.org,2002:seq"
YAML_MAP_TAG (string)
"tag:yaml.org,2002:map"
YAML_PHP_TAG (string)
"!php/object"
Encoding types for yaml_emit()
YAML_ANY_ENCODING (integer)
Let the emitter choose an encoding.
YAML_UTF8_ENCODING (integer)
Encode as UTF8.
YAML_UTF16LE_ENCODING (integer)
Encode as UTF16LE.
YAML_UTF16BE_ENCODING (integer)
Encode as UTF16BE.
Linebreak types for yaml_emit()
YAML_ANY_BREAK (integer)
Let emitter choose linebreak character.
YAML_CR_BREAK (integer)
Use \r as break character (Mac style).
YAML_LN_BREAK (integer)
Use \n as break character (Unix style).
YAML_CRLN_BREAK (integer)
Use \r\n as break character (DOS style).
Özkaynak Türleri
Örnekler
Yaml


Örnekler

Örnek 1 Yaml Example

<?php
$addr = array(
    "given" => "Chris",
    "family"=> "Dumars",
    "address"=> array(
        "lines"=> "458 Walkman Dr.
        Suite #292",
        "city"=> "Royal Oak",
        "state"=> "MI",
        "postal"=> 48046,
      ),
  );
$invoice = array (
    "invoice"=> 34843,
    "date"=> "2001-01-23",
    "bill-to"=> $addr,
    "ship-to"=> $addr,
    "product"=> array(
        array(
            "sku"=> "BL394D",
            "quantity"=> 4,
            "description"=> "Basketball",
            "price"=> 450,
          ),
        array(
            "sku"=> "BL4438H",
            "quantity"=> 1,
            "description"=> "Super Hoop",
            "price"=> 2392,
          ),
      ),
    "tax"=> 251.42,
    "total"=> 4443.52,
    "comments"=> "Late afternoon is best. Backup contact is Nancy Billsmer @ 338-4338.",
    );

// generate a YAML representation of the invoice
$yaml = yaml_emit($invoice);
var_dump($yaml);

// convert the YAML back into a PHP variable
$parsed = yaml_parse($yaml);

// check that roundtrip conversion produced an equivalent structure
var_dump($parsed == $invoice);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(631) "---
invoice: 34843
date: "2001-01-23"
bill-to:
  given: Chris
  family: Dumars
  address:
    lines: |-
      458 Walkman Dr.
              Suite #292
    city: Royal Oak
    state: MI
    postal: 48046
ship-to:
  given: Chris
  family: Dumars
  address:
    lines: |-
      458 Walkman Dr.
              Suite #292
    city: Royal Oak
    state: MI
    postal: 48046
product:
- sku: BL394D
  quantity: 4
  description: Basketball
  price: 450
- sku: BL4438H
  quantity: 1
  description: Super Hoop
  price: 2392
tax: 251.420000
total: 4443.520000
comments: Late afternoon is best. Backup contact is Nancy Billsmer @ 338-4338.
...
"
bool(true)
Öntanımlı Sabitler
Callbacks
Yaml


Callbacks

İçindekiler

  • Parse callbacks
  • Emit callbacks
Örnekler
Parse callbacks
Yaml


Parse callbacks

Parse callbacks are invoked by yaml_parse(), yaml_parse_file() or yaml_parse_url() functions when a registered YAML tag is encountered. The callback is passed the tagged entity's value, the tag, and flags indicating the scalar entity style. The callback must return the data that the YAML parser should emit for this entity.

Örnek 1 Parse callback example

<?php
/**
 * Parsing callback for yaml tag.
 * @param mixed $value Data from yaml file
 * @param string $tag Tag that triggered callback
 * @param int $flags Scalar entity style (see YAML_*_SCALAR_STYLE)
 * @return mixed Value that YAML parser should emit for the given value
 */
function tag_callback ($value, $tag, $flags) {
  var_dump(func_get_args()); // debugging
  return "Hello {$value}";
}

$yaml = <<<YAML
greeting: !example/hello World
YAML;

$result = yaml_parse($yaml, 0, $ndocs, array(
    '!example/hello' => 'tag_callback',
  ));

var_dump($result);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(3) {
  [0]=>
  string(5) "World"
  [1]=>
  string(14) "!example/hello"
  [2]=>
  int(1)
}
array(1) {
  ["greeting"]=>
  string(11) "Hello World"
}
Callbacks
Emit callbacks
Callbacks


Emit callbacks

Emit callbacks are invoked when an instance of a registered class is emitted by yaml_emit() or yaml_emit_file(). The callback is passed the object to be emitted. The callback must return an array having two keys: "tag" and "data". The value associated with the "tag" key must be a string to be used as the YAML tag in the output. The value associated with the "data" key will be encoded as YAML and emitted in place of the intercepted object.

Örnek 1 Emit callback example

<?php
class EmitExample {
  public $data;    // data may be in any pecl/yaml suitable type

  public function __construct ($d) {
    $this->data = $d;
  }

  /**
   * Yaml emit callback function, referred on yaml_emit call by class name.
   *
   * Expected to return an array with 2 values:
   *   - 'tag': custom tag for this serialization
   *   - 'data': value to convert to yaml (array, string, bool, number)
   *
   * @param object $obj Object to be emitted
   * @return array Tag and surrogate data to emit
   */
  public static function yamlEmit (EmitExample $obj) {
    return array(
      'tag' => '!example/emit',
      'data' => $obj->data,
    );
  }
}

$emit_callbacks = array(
  'EmitExample' => array('EmitExample', 'yamlEmit')
);

$t = new EmitExample(array('a','b','c'));
$yaml = yaml_emit(
  array(
    'example' => $t,
  ),
  YAML_ANY_ENCODING,
  YAML_ANY_BREAK,
  $emit_callbacks
);
var_dump($yaml);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(43) "---
example: !example/emit
- a
- b
- c
...
"
Parse callbacks
Yaml İşlevleri
Callbacks


Yaml İşlevleri

İçindekiler

  • yaml_emit_file — Send the YAML representation of a value to a file
  • yaml_emit — Returns the YAML representation of a value
  • yaml_parse_file — Parse a YAML stream from a file
  • yaml_parse_url — Parse a Yaml stream from a URL
  • yaml_parse — Parse a YAML stream
Emit callbacks
yaml_emit_file
Yaml


Send the YAML representation of a value to a file

Yaml İşlevleri
yaml_emit
Yaml İşlevleri
PHP Manual

yaml_emit_file

(PECL yaml >= 0.5.0)

yaml_emit_file — Send the YAML representation of a value to a file

Açıklama

bool yaml_emit_file ( string $filename , mixed $data [, int $encoding = YAML_ANY_ENCODING [, int $linebreak = YAML_ANY_BREAK [, array $callbacks = null ]]] )

Generate a YAML representation of the provided data in the filename.

Değiştirgeler

filename

Path to the file.

data

The data being encoded. Can be any type except a resource.

encoding

Output character encoding chosen from YAML_ANY_ENCODING, YAML_UTF8_ENCODING, YAML_UTF16LE_ENCODING, YAML_UTF16BE_ENCODING.

linebreak

Output linebreak style chosen from YAML_ANY_BREAK, YAML_CR_BREAK, YAML_LN_BREAK, YAML_CRLN_BREAK.

callbacks

Content handlers for emitting YAML nodes. Associative array of classname => callable mappings. See emit callbacks for more details.

Dönen Değerler

Returns TRUE on success.

Sürüm Bilgisi

Sürüm: | Açıklama
1.1.0 | The callbacks parameter was added.

Ayrıca Bakınız

  • yaml_emit() - Returns the YAML representation of a value
  • yaml_parse() - Parse a YAML stream

Yaml İşlevleri
yaml_emit
Yaml İşlevleri


Returns the YAML representation of a value

yaml_emit_file
yaml_parse_file
Yaml İşlevleri
PHP Manual

yaml_emit

(PECL yaml >= 0.5.0)

yaml_emit — Returns the YAML representation of a value

Açıklama

string yaml_emit ( mixed $data [, int $encoding = YAML_ANY_ENCODING [, int $linebreak = YAML_ANY_BREAK [, array $callbacks = null ]]] )

Generate a YAML representation of the provided data.

Değiştirgeler

data

The data being encoded. Can be any type except a resource.

encoding

Output character encoding chosen from YAML_ANY_ENCODING, YAML_UTF8_ENCODING, YAML_UTF16LE_ENCODING, YAML_UTF16BE_ENCODING.

linebreak

Output linebreak style chosen from YAML_ANY_BREAK, YAML_CR_BREAK, YAML_LN_BREAK, YAML_CRLN_BREAK.

callbacks

Content handlers for emitting YAML nodes. Associative array of classname => callable mappings. See emit callbacks for more details.

Dönen Değerler

Returns a YAML encoded string on success.

Sürüm Bilgisi

Sürüm: | Açıklama
1.1.0 | The callbacks parameter was added.

Örnekler

Örnek 1 yaml_emit() example

<?php
$addr = array(
    "given" => "Chris",
    "family"=> "Dumars",
    "address"=> array(
        "lines"=> "458 Walkman Dr.
        Suite #292",
        "city"=> "Royal Oak",
        "state"=> "MI",
        "postal"=> 48046,
      ),
  );
$invoice = array (
    "invoice"=> 34843,
    "date"=> 980208000,
    "bill-to"=> $addr,
    "ship-to"=> $addr,
    "product"=> array(
        array(
            "sku"=> "BL394D",
            "quantity"=> 4,
            "description"=> "Basketball",
            "price"=> 450,
          ),
        array(
            "sku"=> "BL4438H",
            "quantity"=> 1,
            "description"=> "Super Hoop",
            "price"=> 2392,
          ),
      ),
    "tax"=> 251.42,
    "total"=> 4443.52,
    "comments"=> "Late afternoon is best. Backup contact is Nancy Billsmer @ 338-4338.",
  );
var_dump(yaml_emit($invoice));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(628) "---
invoice: 34843
date: 980208000
bill-to:
  given: Chris
  family: Dumars
  address:
    lines: |-
      458 Walkman Dr.
              Suite #292
    city: Royal Oak
    state: MI
    postal: 48046
ship-to:
  given: Chris
  family: Dumars
  address:
    lines: |-
      458 Walkman Dr.
              Suite #292
    city: Royal Oak
    state: MI
    postal: 48046
product:
- sku: BL394D
  quantity: 4
  description: Basketball
  price: 450
- sku: BL4438H
  quantity: 1
  description: Super Hoop
  price: 2392
tax: 251.420000
total: 4443.520000
comments: Late afternoon is best. Backup contact is Nancy Billsmer @ 338-4338.
...
"

Ayrıca Bakınız

  • yaml_emit_file() - Send the YAML representation of a value to a file
  • yaml_parse() - Parse a YAML stream

yaml_emit_file
yaml_parse_file
Yaml İşlevleri


Parse a YAML stream from a file

yaml_emit
yaml_parse_url
Yaml İşlevleri
PHP Manual

yaml_parse_file

(PECL yaml >= 0.4.0)

yaml_parse_file — Parse a YAML stream from a file

Açıklama

mixed yaml_parse_file ( string $filename [, int $pos = 0 [, int &$ndocs [, array $callbacks = null ]]] )

Convert all or part of a YAML document stream read from a file to a PHP variable.

Değiştirgeler

filename

Path to the file.

pos

Document to extract from stream (-1 for all documents, 0 for first document, ...).

ndocs

If ndocs is provided, then it is filled with the number of documents found in stream.

callbacks

Content handlers for YAML nodes. Associative array of YAML tag => callable mappings. See parse callbacks for more details.

Dönen Değerler

Returns the value encoded in input in appropriate PHP type başarısızlık durumunda FALSE döner. If pos is -1 an array will be returned with one entry for each document found in the stream.

Notlar

Uyarı

Processing untrusted user input with yaml_parse_file() is dangerous if the use of unserialize() is enabled for nodes using the !php/object tag. This behavior can be disabled by using the yaml.decode_php ini setting.

Ayrıca Bakınız

  • yaml_parse() - Parse a YAML stream
  • yaml_parse_url() - Parse a Yaml stream from a URL
  • yaml_emit() - Returns the YAML representation of a value

yaml_emit
yaml_parse_url
Yaml İşlevleri


Parse a Yaml stream from a URL

yaml_parse_file
yaml_parse
Yaml İşlevleri
PHP Manual

yaml_parse_url

(PECL yaml >= 0.4.0)

yaml_parse_url — Parse a Yaml stream from a URL

Açıklama

mixed yaml_parse_url ( string $url [, int $pos = 0 [, int &$ndocs [, array $callbacks = null ]]] )

Convert all or part of a YAML document stream read from a URL to a PHP variable.

Değiştirgeler

url

url should be of the form "scheme://...". PHP will search for a protocol handler (also known as a wrapper) for that scheme. If no wrappers for that protocol are registered, PHP will emit a notice to help you track potential problems in your script and then continue as though filename specifies a regular file.

pos

Document to extract from stream (-1 for all documents, 0 for first document, ...).

ndocs

If ndocs is provided, then it is filled with the number of documents found in stream.

callbacks

Content handlers for YAML nodes. Associative array of YAML tag => callable mappings. See parse callbacks for more

Dönen Değerler

Returns the value encoded in input in appropriate PHP type başarısızlık durumunda FALSE döner. If pos is -1 an array will be returned with one entry for each document found in the stream.

Notlar

Uyarı

Processing untrusted user input with yaml_parse_url() is dangerous if the use of unserialize() is enabled for nodes using the !php/object tag. This behavior can be disabled by using the yaml.decode_php ini setting.

Ayrıca Bakınız

  • yaml_parse() - Parse a YAML stream
  • yaml_parse_file() - Parse a YAML stream from a file
  • yaml_emit() - Returns the YAML representation of a value

yaml_parse_file
yaml_parse
Yaml İşlevleri


Parse a YAML stream

yaml_parse_url
Yaf
Yaml İşlevleri
PHP Manual

yaml_parse

(PECL yaml >= 0.4.0)

yaml_parse — Parse a YAML stream

Açıklama

mixed yaml_parse ( string $input [, int $pos = 0 [, int &$ndocs [, array $callbacks = null ]]] )

Convert all or part of a YAML document stream to a PHP variable.

Değiştirgeler

input

The string to parse as a YAML document stream.

pos

Document to extract from stream (-1 for all documents, 0 for first document, ...).

ndocs

If ndocs is provided, then it is filled with the number of documents found in stream.

callbacks

Content handlers for YAML nodes. Associative array of YAML tag => callable mappings. See parse callbacks for more details.

Dönen Değerler

Returns the value encoded in input in appropriate PHP type başarısızlık durumunda FALSE döner. If pos is -1 an array will be returned with one entry for each document found in the stream.

Örnekler

Örnek 1 yaml_parse() example

<?php
$yaml = <<<EOD
---
invoice: 34843
date: "2001-01-23"
bill-to: &id001
  given: Chris
  family: Dumars
  address:
    lines: |-
      458 Walkman Dr.
              Suite #292
    city: Royal Oak
    state: MI
    postal: 48046
ship-to: *id001
product:
- sku: BL394D
  quantity: 4
  description: Basketball
  price: 450
- sku: BL4438H
  quantity: 1
  description: Super Hoop
  price: 2392
tax: 251.420000
total: 4443.520000
comments: Late afternoon is best. Backup contact is Nancy Billsmer @ 338-4338.
...
EOD;

$parsed = yaml_parse($yaml);
var_dump($parsed);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(8) {
  ["invoice"]=>
  int(34843)
  ["date"]=>
  string(10) "2001-01-23"
  ["bill-to"]=>
  &array(3) {
    ["given"]=>
    string(5) "Chris"
    ["family"]=>
    string(6) "Dumars"
    ["address"]=>
    array(4) {
      ["lines"]=>
      string(34) "458 Walkman Dr.
        Suite #292"
      ["city"]=>
      string(9) "Royal Oak"
      ["state"]=>
      string(2) "MI"
      ["postal"]=>
      int(48046)
    }
  }
  ["ship-to"]=>
  &array(3) {
    ["given"]=>
    string(5) "Chris"
    ["family"]=>
    string(6) "Dumars"
    ["address"]=>
    array(4) {
      ["lines"]=>
      string(34) "458 Walkman Dr.
        Suite #292"
      ["city"]=>
      string(9) "Royal Oak"
      ["state"]=>
      string(2) "MI"
      ["postal"]=>
      int(48046)
    }
  }
  ["product"]=>
  array(2) {
    [0]=>
    array(4) {
      ["sku"]=>
      string(6) "BL394D"
      ["quantity"]=>
      int(4)
      ["description"]=>
      string(10) "Basketball"
      ["price"]=>
      int(450)
    }
    [1]=>
    array(4) {
      ["sku"]=>
      string(7) "BL4438H"
      ["quantity"]=>
      int(1)
      ["description"]=>
      string(10) "Super Hoop"
      ["price"]=>
      int(2392)
    }
  }
  ["tax"]=>
  float(251.42)
  ["total"]=>
  float(4443.52)
  ["comments"]=>
  string(68) "Late afternoon is best. Backup contact is Nancy Billsmer @ 338-4338."
}

Notlar

Uyarı

Processing untrusted user input with yaml_parse() is dangerous if the use of unserialize() is enabled for nodes using the !php/object tag. This behavior can be disabled by using the yaml.decode_php ini setting.

Ayrıca Bakınız

  • yaml_parse_file() - Parse a YAML stream from a file
  • yaml_parse_url() - Parse a Yaml stream from a URL
  • yaml_emit() - Returns the YAML representation of a value

yaml_parse_url
Yaf
Yaml İşlevleri


Yet Another Framework

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
  • Application Configuration
  • Yaf_Application — The Yaf_Application class
    • Yaf_Application::app — Retrieve an Application instance
    • Yaf_Application::bootstrap — Call bootstrap
    • Yaf_Application::clearLastError — Clear the last error info
    • Yaf_Application::__clone — Yaf_Application can not be cloned
    • Yaf_Application::__construct — Yaf_Application constructor
    • Yaf_Application::__destruct — The __destruct purpose
    • Yaf_Application::environ — Retrive environ
    • Yaf_Application::execute — Execute a callback
    • Yaf_Application::getAppDirectory — Get the application directory
    • Yaf_Application::getConfig — Retrive the config instance
    • Yaf_Application::getDispatcher — Get Yaf_Dispatcher instance
    • Yaf_Application::getLastErrorMsg — Get message of the last occurred error
    • Yaf_Application::getLastErrorNo — Get code of last occurred error
    • Yaf_Application::getModules — Get defined module names
    • Yaf_Application::run — Start Yaf_Application
    • Yaf_Application::setAppDirectory — Change the application directory
    • Yaf_Application::__sleep — Yaf_Application can not be serialized
    • Yaf_Application::__wakeup — Yaf_Application can not be unserialized
  • Yaf_Bootstrap_Abstract — The Yaf_Bootstrap_Abstract class
  • Yaf_Dispatcher — The Yaf_Dispatcher class
    • Yaf_Dispatcher::autoRender — Switch on/off autorendering
    • Yaf_Dispatcher::catchException — Switch on/off exception catching
    • Yaf_Dispatcher::__clone — Yaf_Dispatcher can not be cloned
    • Yaf_Dispatcher::__construct — Yaf_Dispatcher constructor
    • Yaf_Dispatcher::disableView — Disable view rendering
    • Yaf_Dispatcher::dispatch — Dispatch a request
    • Yaf_Dispatcher::enableView — enable view rendering
    • Yaf_Dispatcher::flushInstantly — Switch on/off the instant flushing
    • Yaf_Dispatcher::getApplication — Retrive the application
    • Yaf_Dispatcher::getInstance — Retrive the dispatcher instance
    • Yaf_Dispatcher::getRequest — Retrive the request instance
    • Yaf_Dispatcher::getRouter — Retrive router instance
    • Yaf_Dispatcher::initView — Initialize view and return it
    • Yaf_Dispatcher::registerPlugin — Register a plugin
    • Yaf_Dispatcher::returnResponse — The returnResponse purpose
    • Yaf_Dispatcher::setDefaultAction — Change default action name
    • Yaf_Dispatcher::setDefaultController — Change default controller name
    • Yaf_Dispatcher::setDefaultModule — Change default module name
    • Yaf_Dispatcher::setErrorHandler — Set error handler
    • Yaf_Dispatcher::setRequest — The setRequest purpose
    • Yaf_Dispatcher::setView — Set a custom view engine
    • Yaf_Dispatcher::__sleep — Yaf_Dispatcher can not be serialized
    • Yaf_Dispatcher::throwException — Switch on/off exception throwing
    • Yaf_Dispatcher::__wakeup — Yaf_Dispatcher can not be unserialized
  • Yaf_Config_Abstract — The Yaf_Config_Abstract class
    • Yaf_Config_Abstract::get — Getter
    • Yaf_Config_Abstract::readonly — Find a config whether readonly
    • Yaf_Config_Abstract::set — Setter
    • Yaf_Config_Abstract::toArray — Cast to array
  • Yaf_Config_Ini — The Yaf_Config_Ini class
    • Yaf_Config_Ini::__construct — Yaf_Config_Ini constructor
    • Yaf_Config_Ini::count — The count purpose
    • Yaf_Config_Ini::current — The current purpose
    • Yaf_Config_Ini::__get — The __get purpose
    • Yaf_Config_Ini::__isset — The __isset purpose
    • Yaf_Config_Ini::key — The key purpose
    • Yaf_Config_Ini::next — The next purpose
    • Yaf_Config_Ini::offsetExists — The offsetExists purpose
    • Yaf_Config_Ini::offsetGet — The offsetGet purpose
    • Yaf_Config_Ini::offsetSet — The offsetSet purpose
    • Yaf_Config_Ini::offsetUnset — The offsetUnset purpose
    • Yaf_Config_Ini::readonly — The readonly purpose
    • Yaf_Config_Ini::rewind — The rewind purpose
    • Yaf_Config_Ini::__set — The __set purpose
    • Yaf_Config_Ini::toArray — Returns a PHP array
    • Yaf_Config_Ini::valid — The valid purpose
  • Yaf_Config_Simple — The Yaf_Config_Simple class
    • Yaf_Config_Simple::__construct — The __construct purpose
    • Yaf_Config_Simple::count — The count purpose
    • Yaf_Config_Simple::current — The current purpose
    • Yaf_Config_Simple::__get — The __get purpose
    • Yaf_Config_Simple::__isset — The __isset purpose
    • Yaf_Config_Simple::key — The key purpose
    • Yaf_Config_Simple::next — The next purpose
    • Yaf_Config_Simple::offsetExists — The offsetExists purpose
    • Yaf_Config_Simple::offsetGet — The offsetGet purpose
    • Yaf_Config_Simple::offsetSet — The offsetSet purpose
    • Yaf_Config_Simple::offsetUnset — The offsetUnset purpose
    • Yaf_Config_Simple::readonly — The readonly purpose
    • Yaf_Config_Simple::rewind — The rewind purpose
    • Yaf_Config_Simple::__set — The __set purpose
    • Yaf_Config_Simple::toArray — Returns a PHP array
    • Yaf_Config_Simple::valid — The valid purpose
  • Yaf_Controller_Abstract — The Yaf_Controller_Abstract class
    • Yaf_Controller_Abstract::__clone — Yaf_Controller_Abstract can not be cloned
    • Yaf_Controller_Abstract::__construct — Yaf_Controller_Abstract constructor
    • Yaf_Controller_Abstract::display — The display purpose
    • Yaf_Controller_Abstract::forward — foward to another action
    • Yaf_Controller_Abstract::getInvokeArg — The getInvokeArg purpose
    • Yaf_Controller_Abstract::getInvokeArgs — The getInvokeArgs purpose
    • Yaf_Controller_Abstract::getModuleName — Get module name
    • Yaf_Controller_Abstract::getRequest — Retrieve current request object
    • Yaf_Controller_Abstract::getResponse — Retrieve current response object
    • Yaf_Controller_Abstract::getView — Retrieve the view engine
    • Yaf_Controller_Abstract::getViewpath — The getViewpath purpose
    • Yaf_Controller_Abstract::init — Controller initializer
    • Yaf_Controller_Abstract::initView — The initView purpose
    • Yaf_Controller_Abstract::redirect — Redirect to a URL
    • Yaf_Controller_Abstract::render — Render view template
    • Yaf_Controller_Abstract::setViewpath — The setViewpath purpose
  • Yaf_Action_Abstract — The Yaf_Action_Abstract class
    • Yaf_Action_Abstract::execute — Action entry point
    • Yaf_Action_Abstract::getController — Retrieve controller object
  • Yaf_View_Interface — The Yaf_View_Interface class
    • Yaf_View_Interface::assign — Assign value to View engine
    • Yaf_View_Interface::display — Render and output a template
    • Yaf_View_Interface::getScriptPath — The getScriptPath purpose
    • Yaf_View_Interface::render — Render a template
    • Yaf_View_Interface::setScriptPath — The setScriptPath purpose
  • Yaf_View_Simple — The Yaf_View_Simple class
    • Yaf_View_Simple::assign — Assign values
    • Yaf_View_Simple::assignRef — The assignRef purpose
    • Yaf_View_Simple::clear — Clear Assigned values
    • Yaf_View_Simple::__construct — Constructor of Yaf_View_Simple
    • Yaf_View_Simple::display — Render and display
    • Yaf_View_Simple::eval — Render template
    • Yaf_View_Simple::__get — Retrieve assigned variable
    • Yaf_View_Simple::getScriptPath — Get templates directory
    • Yaf_View_Simple::__isset — The __isset purpose
    • Yaf_View_Simple::render — Render template
    • Yaf_View_Simple::__set — Set value to engine
    • Yaf_View_Simple::setScriptPath — Set tempaltes directory
  • Yaf_Loader — The Yaf_Loader class
    • Yaf_Loader::autoload — The autoload purpose
    • Yaf_Loader::clearLocalNamespace — The clearLocalNamespace purpose
    • Yaf_Loader::__clone — The __clone purpose
    • Yaf_Loader::__construct — The __construct purpose
    • Yaf_Loader::getInstance — The getInstance purpose
    • Yaf_Loader::getLibraryPath — get the library path
    • Yaf_Loader::getLocalNamespace — The getLocalNamespace purpose
    • Yaf_Loader::import — The import purpose
    • Yaf_Loader::isLocalName — The isLocalName purpose
    • Yaf_Loader::registerLocalNamespace — register local class prefix
    • Yaf_Loader::setLibraryPath — Change the library path
    • Yaf_Loader::__sleep — The __sleep purpose
    • Yaf_Loader::__wakeup — The __wakeup purpose
  • Yaf_Plugin_Abstract — The Yaf_Plugin_Abstract class
    • Yaf_Plugin_Abstract::dispatchLoopShutdown — The dispatchLoopShutdown purpose
    • Yaf_Plugin_Abstract::dispatchLoopStartup — The dispatchLoopStartup purpose
    • Yaf_Plugin_Abstract::postDispatch — The postDispatch purpose
    • Yaf_Plugin_Abstract::preDispatch — The preDispatch purpose
    • Yaf_Plugin_Abstract::preResponse — The preResponse purpose
    • Yaf_Plugin_Abstract::routerShutdown — The routerShutdown purpose
    • Yaf_Plugin_Abstract::routerStartup — RouterStartup hook
  • Yaf_Registry — The Yaf_Registry class
    • Yaf_Registry::__clone — The __clone purpose
    • Yaf_Registry::__construct — Yaf_Registry implements singleton
    • Yaf_Registry::del — Remove an item from registry
    • Yaf_Registry::get — Retrieve an item from registry
    • Yaf_Registry::has — Check whether an item exists
    • Yaf_Registry::set — Add an item into registry
  • Yaf_Request_Abstract — The Yaf_Request_Abstract class
    • Yaf_Request_Abstract::getActionName — The getActionName purpose
    • Yaf_Request_Abstract::getBaseUri — The getBaseUri purpose
    • Yaf_Request_Abstract::getControllerName — The getControllerName purpose
    • Yaf_Request_Abstract::getEnv — Retrieve ENV varialbe
    • Yaf_Request_Abstract::getException — The getException purpose
    • Yaf_Request_Abstract::getLanguage — The getLanguage purpose
    • Yaf_Request_Abstract::getMethod — The getMethod purpose
    • Yaf_Request_Abstract::getModuleName — The getModuleName purpose
    • Yaf_Request_Abstract::getParam — The getParam purpose
    • Yaf_Request_Abstract::getParams — The getParams purpose
    • Yaf_Request_Abstract::getRequestUri — The getRequestUri purpose
    • Yaf_Request_Abstract::getServer — Retrieve SERVER variable
    • Yaf_Request_Abstract::isCli — The isCli purpose
    • Yaf_Request_Abstract::isDispatched — The isDispatched purpose
    • Yaf_Request_Abstract::isGet — The isGet purpose
    • Yaf_Request_Abstract::isHead — The isHead purpose
    • Yaf_Request_Abstract::isOptions — The isOptions purpose
    • Yaf_Request_Abstract::isPost — The isPost purpose
    • Yaf_Request_Abstract::isPut — The isPut purpose
    • Yaf_Request_Abstract::isRouted — The isRouted purpose
    • Yaf_Request_Abstract::isXmlHttpRequest — The isXmlHttpRequest purpose
    • Yaf_Request_Abstract::setActionName — The setActionName purpose
    • Yaf_Request_Abstract::setBaseUri — set base URI
    • Yaf_Request_Abstract::setControllerName — The setControllerName purpose
    • Yaf_Request_Abstract::setDispatched — The setDispatched purpose
    • Yaf_Request_Abstract::setModuleName — The setModuleName purpose
    • Yaf_Request_Abstract::setParam — The setParam purpose
    • Yaf_Request_Abstract::setRequestUri — The setRequestUri purpose
    • Yaf_Request_Abstract::setRouted — The setRouted purpose
  • Yaf_Request_Http — The Yaf_Request_Http class
    • Yaf_Request_Http::__clone — The __clone purpose
    • Yaf_Request_Http::__construct — Constructor of Yaf_Request_Http
    • Yaf_Request_Http::get — Retrieve variable from client
    • Yaf_Request_Http::getCookie — Retrieve Cookie variable
    • Yaf_Request_Http::getFiles — The getFiles purpose
    • Yaf_Request_Http::getPost — Retrieve POST variable
    • Yaf_Request_Http::getQuery — Fetch a query parameter
    • Yaf_Request_Http::getRequest — The getRequest purpose
    • Yaf_Request_Http::isXmlHttpRequest — Whether a Ajax Request
  • Yaf_Request_Simple — The Yaf_Request_Simple class
    • Yaf_Request_Simple::__clone — The __clone purpose
    • Yaf_Request_Simple::__construct — Constructor of Yaf_Request_Simple
    • Yaf_Request_Simple::get — The get purpose
    • Yaf_Request_Simple::getCookie — The getCookie purpose
    • Yaf_Request_Simple::getFiles — The getFiles purpose
    • Yaf_Request_Simple::getPost — The getPost purpose
    • Yaf_Request_Simple::getQuery — The getQuery purpose
    • Yaf_Request_Simple::getRequest — The getRequest purpose
    • Yaf_Request_Simple::isXmlHttpRequest — The isXmlHttpRequest purpose
  • Yaf_Response_Abstract — The Yaf_Response_Abstract class
    • Yaf_Response_Abstract::appendBody — append to body
    • Yaf_Response_Abstract::clearBody — The clearBody purpose
    • Yaf_Response_Abstract::clearHeaders — The clearHeaders purpose
    • Yaf_Response_Abstract::__clone — The __clone purpose
    • Yaf_Response_Abstract::__construct — The __construct purpose
    • Yaf_Response_Abstract::__destruct — The __destruct purpose
    • Yaf_Response_Abstract::getBody — Retrieve a exists content
    • Yaf_Response_Abstract::getHeader — The getHeader purpose
    • Yaf_Response_Abstract::prependBody — The prependBody purpose
    • Yaf_Response_Abstract::response — send response
    • Yaf_Response_Abstract::setAllHeaders — The setAllHeaders purpose
    • Yaf_Response_Abstract::setBody — Set content to response
    • Yaf_Response_Abstract::setHeader — The setHeader purpose
    • Yaf_Response_Abstract::setRedirect — The setRedirect purpose
    • Yaf_Response_Abstract::__toString — The __toString purpose
  • Yaf_Route_Interface — The Yaf_Route_Interface class
    • Yaf_Route_Interface::assemble — assemble a request
    • Yaf_Route_Interface::route — route a request
  • Yaf_Route_Map — The Yaf_Route_Map class
    • Yaf_Route_Map::assemble — Assemble a url
    • Yaf_Route_Map::__construct — The __construct purpose
    • Yaf_Route_Map::route — The route purpose
  • Yaf_Route_Regex — The Yaf_Route_Regex class
    • Yaf_Route_Regex::assemble — Assemble a url
    • Yaf_Route_Regex::__construct — Yaf_Route_Regex constructor
    • Yaf_Route_Regex::route — The route purpose
  • Yaf_Route_Rewrite — The Yaf_Route_Rewrite class
    • Yaf_Route_Rewrite::assemble — Assemble a url
    • Yaf_Route_Rewrite::__construct — Yaf_Route_Rewrite constructor
    • Yaf_Route_Rewrite::route — The route purpose
  • Yaf_Router — The Yaf_Router class
    • Yaf_Router::addConfig — Add config-defined routes into Router
    • Yaf_Router::addRoute — Add new Route into Router
    • Yaf_Router::__construct — Yaf_Router constructor
    • Yaf_Router::getCurrentRoute — Get the effective route name
    • Yaf_Router::getRoute — Retrieve a route by name
    • Yaf_Router::getRoutes — Retrieve registered routes
    • Yaf_Router::route — The route purpose
  • Yaf_Route_Simple — The Yaf_Route_Simple class
    • Yaf_Route_Simple::assemble — Assemble a url
    • Yaf_Route_Simple::__construct — Yaf_Route_Simple constructor
    • Yaf_Route_Simple::route — Route a request
  • Yaf_Route_Static — The Yaf_Route_Static class
    • Yaf_Route_Static::assemble — Assemble a url
    • Yaf_Route_Static::match — The match purpose
    • Yaf_Route_Static::route — Route a request
  • Yaf_Route_Supervar — The Yaf_Route_Supervar class
    • Yaf_Route_Supervar::assemble — Assemble a url
    • Yaf_Route_Supervar::__construct — The __construct purpose
    • Yaf_Route_Supervar::route — The route purpose
  • Yaf_Session — The Yaf_Session class
    • Yaf_Session::__clone — The __clone purpose
    • Yaf_Session::__construct — Constructor of Yaf_Session
    • Yaf_Session::count — The count purpose
    • Yaf_Session::current — The current purpose
    • Yaf_Session::del — The del purpose
    • Yaf_Session::__get — The __get purpose
    • Yaf_Session::getInstance — The getInstance purpose
    • Yaf_Session::has — The has purpose
    • Yaf_Session::__isset — The __isset purpose
    • Yaf_Session::key — The key purpose
    • Yaf_Session::next — The next purpose
    • Yaf_Session::offsetExists — The offsetExists purpose
    • Yaf_Session::offsetGet — The offsetGet purpose
    • Yaf_Session::offsetSet — The offsetSet purpose
    • Yaf_Session::offsetUnset — The offsetUnset purpose
    • Yaf_Session::rewind — The rewind purpose
    • Yaf_Session::__set — The __set purpose
    • Yaf_Session::__sleep — The __sleep purpose
    • Yaf_Session::start — The start purpose
    • Yaf_Session::__unset — The __unset purpose
    • Yaf_Session::valid — The valid purpose
    • Yaf_Session::__wakeup — The __wakeup purpose
  • Yaf_Exception — The Yaf_Exception class
    • Yaf_Exception::__construct — The __construct purpose
    • Yaf_Exception::getPrevious — The getPrevious purpose
  • Yaf_Exception_TypeError — The Yaf_Exception_TypeError class
  • Yaf_Exception_StartupError — The Yaf_Exception_StartupError class
  • Yaf_Exception_DispatchFailed — The Yaf_Exception_DispatchFailed class
  • Yaf_Exception_RouterFailed — The Yaf_Exception_RouterFailed class
  • Yaf_Exception_LoadFailed — The Yaf_Exception_LoadFailed class
  • Yaf_Exception_LoadFailed_Module — The Yaf_Exception_LoadFailed_Module class
  • Yaf_Exception_LoadFailed_Controller — The Yaf_Exception_LoadFailed_Controller class
  • Yaf_Exception_LoadFailed_Action — The Yaf_Exception_LoadFailed_Action class
  • Yaf_Exception_LoadFailed_View — The Yaf_Exception_LoadFailed_View class
yaml_parse
Giriş
Diğer Temel Eklentiler


Giriş

The Yet Another Framework (Yaf) extension is a PHP framework that is used to develop web applications.

Yaf requires PHP 5.2.1 or greater. Earlier versions may not work.

A simple Yaf benchmark can be found at » Yaf Performance.

For a quick start guide, please refer to the Tutorials section.

Yaf
Yapılandırma/Kurulum
Yaf


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Yaf


Kurulum

Bu » PECL eklentisi PHP ile gelmez.

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/yaf.

Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Yaf Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
yaf.library |  | its PHP_INI_ALL value |
yaf.action_prefer | 0 | its PHP_INI_ALL value |
yaf.lowcase_path | 0 | its PHP_INI_ALL value |
yaf.use_spl_autoload | 0 | its PHP_INI_ALL value |
yaf.forward_limit | 5 | its PHP_INI_ALL value |
yaf.name_suffix | 1 | its PHP_INI_ALL value |
yaf.name_separator |  | its PHP_INI_ALL value |
yaf.cache_config | 0 | its PHP_INI_SYSTEM value |
yaf.environ | product | its PHP_INI_SYSTEM value |
yaf.use_namespace | 0 | its PHP_INI_ALL value |

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

yaf.library string

The global library path, Yaf_loader will search global library in this directory.

yaf.action_prefer integer

If there is only one part in PATH_INFO, should it consider as a controller or action.

If this configure On, it will be considered as a Action name.

yaf.lowcase_path integer

Whether lowercase all the path during the class autoloading.

yaf.use_spl_autoload integer

When this value is On, if Yaf_Loader can not find a class, it will return FALSE, then give chance to other auto load function to be called.

When this value is Off, if Yaf_Loader can not find a class, it will return TRUE, and make the class autoloading failed immediately.

Bilginize:

Yaf will register its loader during a instantiation of Yaf_Application, so any other auto loaders which is register before the instantiation will be called before Yaf_Loader::autoload().

When this value is Off(default), Yaf_Loader::autoload() will always return TRUE.

yaf.forward_limit integer

The max forward count, default is 5. that means you can have a max value of 5 in the forward stack.

This is a protection for prevent recursive Yaf_Controller_Abstract::forward().

yaf.name_suffix integer

When this On, Yaf_Loader will identify a class by it's suffix to decide whether it is a MVC Class.

When this Off, Yaf_Loader will look at the prefix of the class name.

yaf.name_separator string

When this is not empty, Yaf_Loader will identify the class suffix and string value of this.

For example, when this value is "_", Yaf_Loader will take Index_Controller as a Controller Class, IndexController as a normal class.

yaf.cache_config integer

If this is On, and in the meantime you are using ini config file as the parameter of Yaf_Application(), the compiling result of the ini config file will be cached in the PHP process.

Bilginize:

Yaf examine the mtime of the ini file, if it was changed since last compiling, Yaf will reload it.

Uyarı

Yaf use the ini file path as the cache entry key, so do use the absolute path in ini file path, otherwise there might be some conflicts if two application use the same relative path of ini config.

yaf.environ string

This value is "product" by default, used for Yaf to fetch the config section of a ini config file.

That is, if this value is "product", Yaf will use the section named "product" in the ini config file(the first parameter of the Yaf_Application) as the final config of the Yaf_Application.

yaf.use_namespace integer

Only works as of PHP 5.3, if this value is On, All classes of Yaf will named in namespace style.

For example:

Yaf_Route_Rewrite => \Yaf\Route\Rewrite
Yaf_Request_Http  => \Yaf\Request\Http
There is a exception, that is some classes like Yaf_Controller_Abstract. The last component is a keyword of PHP, could not be used as a class name, so for such classes:
Yaf_Controller_Abstract => \Yaf\Controller_Abstract
Yaf_Route_Static => \Yaf\Route_Static

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

YAF_VERSION (string)
YAF_ENVIRON (string)
YAF_ERR_STARTUP_FAILED (integer)
YAF_ERR_ROUTE_FAILED (integer)
YAF_ERR_DISPATCH_FAILED (integer)
YAF_ERR_AUTOLOAD_FAILED (integer)
YAF_ERR_NOTFOUND_MODULE (integer)
YAF_ERR_NOTFOUND_CONTROLLER (integer)
YAF_ERR_NOTFOUND_ACTION (integer)
YAF_ERR_NOTFOUND_VIEW (integer)
YAF_ERR_CALL_FAILED (integer)
YAF_ERR_TYPE_ERROR (integer)

Özkaynak Türleri
Örnekler
Yaf


Örnekler

Örnek 1 A classic Application directory layout

- index.php
- .htaccess
+ conf
  |- application.ini //application config
- application/
  - Bootstrap.php
  + controllers
     - Index.php //default controller
  + views
     |+ index
        - index.phtml //view template for default action
  + modules
  - library
  - models
  - plugins

Örnek 2 Entry

index.php in the top directory is the only way in of the application, you should rewrite all request to it(you can use .htaccess in Apache+php_mod)

<?php
define("APPLICATION_PATH",  dirname(__FILE__));

$app  = new Yaf_Application(APPLICATION_PATH . "/conf/application.ini");
$app->bootstrap() //call bootstrap methods defined in Bootstrap.php
 ->run();
?>

Örnek 3 Rewrite rule

#for apache (.htaccess)
RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule .* index.php

#for nginx
server {
  listen ****;
  server_name  domain.com;
  root   document_root;
  index  index.php index.html index.htm;

  if (!-e $request_filename) {
    rewrite ^/(.*)  /index.php/$1 last;
  }
}

#for lighttpd
$HTTP["host"] =~ "(www.)?domain.com$" {
  url.rewrite = (
     "^/(.+)/?$"  => "/index.php/$1",
  )
}

Örnek 4 Application config

[yaf]
;APPLICATION_PATH is the constant defined in index.php
application.directory=APPLICATION_PATH "/application/"

;product section inherit from yaf section
[product:yaf]
foo=bar

Örnek 5 Default controller

<?php
class IndexController extends Yaf_Controller_Abstract {
   /* default action */
   public function indexAction() {
       $this->_view->word = "hello world";
       //or
       // $this->getView()->word = "hello world";
   }
}
?>

Örnek 6 Default view template

<html>
 <head>
   <title>Hello World</title>
 </head>
 <body>
   <?php echo $word;?>
 </body>
</html>

Örnek 7 Run the Applicatioin

Yukarıdaki örnek şuna benzer bir çıktı üretir:

<html>
 <head>
   <title>Hello World</title>
 </head>
 <body>
   hello world
 </body>
</html>

Bilginize:

you can also generate above example by use Yaf codes generator, which could be found here yaf@github.

Öntanımlı Sabitler
Application Configuration
Yaf


Application Configuration

You should give an array of config or an ini config file(see Yaf_Config_Ini) path to Yaf_Application::__construct().

Yaf will merge the application configurations and user configurations automatically. The application configurations have prefix "yaf." or "application.". If both "yaf." and "application." exist, "application." will be accepted preferentially.

Örnek 1 An PHP array example

<?php
    $configs = array(
            "application" => array(
                "directory" => dirname(__FILE__),
                "dispatcher" => array(
                      "catchException" => 0,
                    ),
                "view" => array(
                       "ext" => "phtml",
                    ),
                ),
           );
    $app = new Yaf_Application($configs);
?>

Örnek 2 An ini file example

[yaf]
yaf.directory = APPLICATION_PATH "/appliation"
yaf.dispatcher.catchException = 0

[product : yaf]
; user configuration list here

Yaf Application Config
İsim | Öntanımlı | Sürüm Bilgisi
application.directory |  |
application.ext | "php" |
application.view.ext | "phtml" |
application.modules | "index" |
application.library | application.directory . "/library" |
application.library.directory | application.directory . "/library" |
application.library.namespace | "" |
application.bootstrap | application.directory . "/Bootstrap" . application.ext |
application.baseUri | "" |
application.dispatcher.defaultRoute |  |
application.dispatcher.throwException | 1 |
application.dispatcher.catchException | 0 |
application.dispatcher.defaultModule | "index" |
application.dispatcher.defaultController | "index" |
application.dispatcher.defaultAction | "index" |
application.system |  |

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

application.directory string

The directory of the application, that is the folder which contains the "controllers", "views", "models", "plugins" folders.

Bilginize:

This config entry is the only one which doesn't has a default value. You should always define it manually.

application.ext string

The file ext of the PHP script, used in class autoloading( Yaf_Loader).

application.view.ext string

The file ext of the view template scripts.

application.modules string

A comma-separated list of the registered modules, used in the route process, especially while there are more than three segments in the PATH_INFO,

Yaf need a way to find out whether the first segment is a module name or not.

application.library string

The local library directory, see Yaf_Loader and yaf.library.

Bilginize:

After Yaf 2.1.6, this config entry can be an array. The library path will try to use the items setted in application.library.directory

application.library.directory string

Alias of application.library. Introduced in Yaf 2.1.6

application.library.namespace string

A comma-separated prefix of local library namespace.

Introduced in Yaf 2.1.6

application.bootstrap string

A absolute path of the Bootstrap class script.

application.baseUri string

Used to remove a fixed prefix of request uri in route process. Take a example, comes a request with request uri "/prefix/controller/action". if you set application.baseUri to "/prefix", then only "/controller/action" will take as the PATH_INFO in route process.

In generally, there is no need to set this value.

application.dispatcher.throwException bool

If it set to On, Yaf will throw an exception while some error occurring. See also Yaf_Dispatcher::throwException().

application.dispatcher.catchException bool

If it set to On, Yaf will forward to Error controller/Action while there is an unhandled exception. See also Yaf_Dispatcher::catchException().

application.dispatcher.defaultRoute string

The default Route, if it is not specificed, Static route will be used as default. See: Yaf_Router::addRoute().

application.dispatcher.defaultModule string

The default module name, see also Yaf_Dispatcher::setDefaultModule().

application.dispatcher.defaultController string

The default controller name, see also Yaf_Dispatcher::setDefaultController().

application.dispatcher.defaultAction string

The default action name, see also Yaf_Dispatcher::setDefaultAction().

application.system string

Set yaf runtime configure in application.ini, like: application.system.lowcase_path

Bilginize:

only those PHP_INI_ALL configures can be set in this way

Örnekler
Yaf_Application
Yaf


The Yaf_Application class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

Yaf_Application provides a bootstrapping facility for applications which provides reusable resources, common- and module-based bootstrap classes and dependency checking.

Bilginize:

Yaf_Application implements the singleton pattern, and Yaf_Application can not be serialized or unserialized which will cause problem when you try to use PHPUnit to write some test case for Yaf.

You may use @backupGlobals annotation of PHPUnit to control the backup and restore operations for global variables. thus can solve this problem.

Sınıf Sözdizimi

final Yaf_Application {
/* Özellikler */
protected $config ;
protected $dispatcher ;
protected static $_app ;
protected $_modules ;
protected $_running ;
protected $_environ ;
/* Yöntemler */
public static void app ( void )
public void bootstrap ([ Yaf_Bootstrap_Abstract $bootstrap ] )
public Yaf_Application clearLastError ( void )
private void __clone ( void )
public __construct ( mixed $config [, string $envrion ] )
public void __destruct ( void )
public void environ ( void )
public void execute ( callable $entry , string $... )
public Yaf_Application getAppDirectory ( void )
public Yaf_Config_Abstract getConfig ( void )
public Yaf_Dispatcher getDispatcher ( void )
public string getLastErrorMsg ( void )
public int getLastErrorNo ( void )
public array getModules ( void )
public void run ( void )
public Yaf_Application setAppDirectory ( string $directory )
private void __sleep ( void )
private void __wakeup ( void )
}

Özellikler

config

dispatcher

_app

_modules

_running

_environ

İçindekiler

  • Yaf_Application::app — Retrieve an Application instance
  • Yaf_Application::bootstrap — Call bootstrap
  • Yaf_Application::clearLastError — Clear the last error info
  • Yaf_Application::__clone — Yaf_Application can not be cloned
  • Yaf_Application::__construct — Yaf_Application constructor
  • Yaf_Application::__destruct — The __destruct purpose
  • Yaf_Application::environ — Retrive environ
  • Yaf_Application::execute — Execute a callback
  • Yaf_Application::getAppDirectory — Get the application directory
  • Yaf_Application::getConfig — Retrive the config instance
  • Yaf_Application::getDispatcher — Get Yaf_Dispatcher instance
  • Yaf_Application::getLastErrorMsg — Get message of the last occurred error
  • Yaf_Application::getLastErrorNo — Get code of last occurred error
  • Yaf_Application::getModules — Get defined module names
  • Yaf_Application::run — Start Yaf_Application
  • Yaf_Application::setAppDirectory — Change the application directory
  • Yaf_Application::__sleep — Yaf_Application can not be serialized
  • Yaf_Application::__wakeup — Yaf_Application can not be unserialized
Application Configuration
Yaf_Application::app
Yaf


Retrieve an Application instance

Yaf_Application
Yaf_Application::bootstrap
Yaf_Application
PHP Manual

Yaf_Application::app

(Yaf >=1.0.0)

Yaf_Application::app — Retrieve an Application instance

Açıklama

public static void Yaf_Application::app ( void )

Retrieve the Yaf_Application instance. Alternatively, we also could use Yaf_Dispatcher::getApplication().

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A Yaf_Application instance, if no Yaf_Application was initialized before, NULL will be returned.

Ayrıca Bakınız

  • Yaf_Dispatcher::getApplication() - Retrive the application
Yaf_Application
Yaf_Application::bootstrap
Yaf_Application


Call bootstrap

Yaf_Application::app
Yaf_Application::clearLastError
Yaf_Application
PHP Manual

Yaf_Application::bootstrap

(Yaf >=1.0.0)

Yaf_Application::bootstrap — Call bootstrap

Açıklama

public void Yaf_Application::bootstrap ([ Yaf_Bootstrap_Abstract $bootstrap ] )

Run a Bootstrap, all the methods defined in the Bootstrap and named with prefix "_init" will be called according to their declaration order, if the parameter bootstrap is not supplied, Yaf will look for a Bootstrap under application.directory.

Değiştirgeler

bootstrap

A Yaf_Bootstrap_Abstract instance

Dönen Değerler

Yaf_Application instance

Örnekler

Örnek 1 A Bootstrap()example

<?php
/**
 * This file should be under the APPLICATION_PATH . "/application/"(which was defined in the config passed to Yaf_Application).
 * and named Bootstrap.php,  so the Yaf_Application can find it
 */
class Bootstrap extends Yaf_Bootstrap_Abstract {
    function _initConfig(Yaf_Dispatcher $dispatcher) {
        echo "1st called\n";
    }

    function _initPlugin($dispatcher) {
        echo "2nd called\n";
    }
}
?>

Örnek 2 Yaf_Application::bootstrap()example

<?php

defined('APPLICATION_PATH')                  // APPLICATION_PATH will be used in the ini config file
    || define('APPLICATION_PATH', __DIR__)); //__DIR__ was introduced after PHP 5.3

$application = new Yaf_Application(APPLICATION_PATH.'/conf/application.ini');
$application->bootstrap();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

1st called
2nd called

Ayrıca Bakınız

  • Yaf_Bootstrap_Abstract
Yaf_Application::app
Yaf_Application::clearLastError
Yaf_Application


Clear the last error info

Yaf_Application::bootstrap
Yaf_Application::__clone
Yaf_Application
PHP Manual

Yaf_Application::clearLastError

(Yaf >=2.1.2)

Yaf_Application::clearLastError — Clear the last error info

Açıklama

public Yaf_Application Yaf_Application::clearLastError ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Örnekler

Örnek 1 Yaf_Application::clearLastError()example

<?php
function error_handler($errno, $errstr, $errfile, $errline) {
   Yaf_Application::app()->clearLastError();
   var_dump(Yaf_Application::app()->getLastErrorNo());
}

$config = array(
 "application" => array(
   "directory" => "/tmp/notexists",
     "dispatcher" => array(
       "throwException" => 0, //trigger error instead of throw exception when error occure
      ),
  ),
);

$app = new Yaf_Application($config);
$app->getDispatcher()->setErrorHandler("error_handler", E_RECOVERABLE_ERROR);
$app->run();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(0)
Yaf_Application::bootstrap
Yaf_Application::__clone
Yaf_Application


Yaf_Application can not be cloned

Yaf_Application::clearLastError
Yaf_Application::__construct
Yaf_Application
PHP Manual

Yaf_Application::__clone

(Yaf >=1.0.0)

Yaf_Application::__clone — Yaf_Application can not be cloned

Açıklama

private void Yaf_Application::__clone ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Application::clearLastError
Yaf_Application::__construct
Yaf_Application


Yaf_Application constructor

Yaf_Application::__clone
Yaf_Application::__destruct
Yaf_Application
PHP Manual

Yaf_Application::__construct

(Yaf >=1.0.0)

Yaf_Application::__construct — Yaf_Application constructor

Açıklama

public Yaf_Application::__construct ( mixed $config [, string $envrion ] )

Instance a Yaf_Application.

Değiştirgeler

config

A ini config file path, or a config array

If is a ini config file, there should be a section named as the one defined by yaf.environ, which is "product" by default.

Bilginize:

If you use a ini configuration file as your applicatioin's config container. you would open the yaf.cache_config to improve performance.

And the config entry(and there default value) list blow:

Örnek 1 A ini config file example

[product]
;this one should alway be defined, and have no default value
application.directory=APPLICATION_PATH

;following configs have default value, you may no need to define them
application.library = APPLICATION_PATH . "/library"
application.dispatcher.throwException=1
application.dispatcher.catchException=1

application.baseUri=""

;the php script ext name
ap.ext=php

;the view template ext name
ap.view.ext=phtml

ap.dispatcher.defaultModuel=Index
ap.dispatcher.defaultController=Index
ap.dispatcher.defaultAction=index

;defined modules
ap.modules=Index

envrion

Which section will be loaded as the final config

Dönen Değerler

Örnekler

Örnek 2 Yaf_Application::__construct()example

<?php
defined('APPLICATION_PATH')                  // APPLICATION_PATH will be used in the ini config file
    || define('APPLICATION_PATH', __DIR__)); //__DIR__ was introduced after PHP 5.3

$application = new Yaf_Application(APPLICATION_PATH.'/conf/application.ini');
$application->bootstrap()->run();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Örnek 3 Yaf_Application::__construct()example

<?php
$config = array(
    "application" => array(
        "directory" => realpath(dirname(__FILE__)) . "/application",
    ),
);

/** Yaf_Application */
$application = new Yaf_Application($config);
$application->bootstrap()->run();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ayrıca Bakınız

  • Yaf_Config_Ini
    •

Yaf_Application::__clone

Yaf_Application::__destruct

Yaf_Application


The __destruct purpose

Yaf_Application::__construct
Yaf_Application::environ
Yaf_Application
PHP Manual

Yaf_Application::__destruct

(Yaf >=1.0.0)

Yaf_Application::__destruct — The __destruct purpose

Açıklama

public void Yaf_Application::__destruct ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Application::__construct
Yaf_Application::environ
Yaf_Application


Retrive environ

Yaf_Application::__destruct
Yaf_Application::execute
Yaf_Application
PHP Manual

Yaf_Application::environ

(Yaf >=1.0.0)

Yaf_Application::environ — Retrive environ

Açıklama

public void Yaf_Application::environ ( void )

Retrive environ which was defined in yaf.environ which has a default value "product".

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Örnekler

Örnek 1 Yaf_Application::environ()example

<?php
$config = array(
    "application" => array(
        "directory" => realpath(dirname(__FILE__)) . "/application",
    ),
);

/** Yaf_Application */
$application = new Yaf_Application($config);
print_r($application->environ());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

product
Yaf_Application::__destruct
Yaf_Application::execute
Yaf_Application


Execute a callback

Yaf_Application::environ
Yaf_Application::getAppDirectory
Yaf_Application
PHP Manual

Yaf_Application::execute

(Yaf >=1.0.0)

Yaf_Application::execute — Execute a callback

Açıklama

public void Yaf_Application::execute ( callable $entry , string $... )

This method is typically used to run Yaf_Application in a crontab work. Make the crontab work can also use the autoloader and Bootstrap mechanism.

Değiştirgeler

entry

a valid callback

...

parameters will pass to the callback

Dönen Değerler

Örnekler

Örnek 1 Yaf_Application::execute()example

<?php
function main($argc, $argv) {
}

$config = array(
    "application" => array(
        "directory" => realpath(dirname(__FILE__)) . "/application",
    ),
);

/** Yaf_Application */
$application = new Yaf_Application($config);
$application->execute("main", $argc,  $argv);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Yaf_Application::environ

Yaf_Application::getAppDirectory

Yaf_Application


Get the application directory

Yaf_Application::execute
Yaf_Application::getConfig
Yaf_Application
PHP Manual

Yaf_Application::getAppDirectory

(Yaf >=2.1.4)

Yaf_Application::getAppDirectory — Get the application directory

Açıklama

public Yaf_Application Yaf_Application::getAppDirectory ( void )

Değiştirgeler

directory

Dönen Değerler

Yaf_Application::execute
Yaf_Application::getConfig
Yaf_Application


Retrive the config instance

Yaf_Application::getAppDirectory
Yaf_Application::getDispatcher
Yaf_Application
PHP Manual

Yaf_Application::getConfig

(Yaf >=1.0.0)

Yaf_Application::getConfig — Retrive the config instance

Açıklama

public Yaf_Config_Abstract Yaf_Application::getConfig ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A Yaf_Config_Abstract instance

Örnekler

Örnek 1 Yaf_Application::getConfig()example

<?php
$config = array(
    "application" => array(
        "directory" => realpath(dirname(__FILE__)) . "/application",
    ),
);

/** Yaf_Application */
$application = new Yaf_Application($config);
print_r($application->getConfig());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Yaf_Config_Simple Object
(
    [_config:protected] => Array
        (
            [application] => Array
                (
                    [directory] => /home/laruence/local/www/htdocs/application
                )

        )

    [_readonly:protected] => 1
)
Yaf_Application::getAppDirectory
Yaf_Application::getDispatcher
Yaf_Application


Get Yaf_Dispatcher instance

Yaf_Application::getConfig
Yaf_Application::getLastErrorMsg
Yaf_Application
PHP Manual

Yaf_Application::getDispatcher

(Yaf >=1.0.0)

Yaf_Application::getDispatcher — Get Yaf_Dispatcher instance

Açıklama

public Yaf_Dispatcher Yaf_Application::getDispatcher ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Örnekler

Örnek 1 Yaf_Application::getDispatcher()example

<?php
$config = array(
    "application" => array(
        "directory" => realpath(dirname(__FILE__)) . "/application",
    ),
);

/** Yaf_Application */
$application = new Yaf_Application($config);
print_r($application->getDispatcher());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Yaf_Dispatcher Object
(
    [_router:protected] => Yaf_Router Object
        (
            [_routes:protected] => Array
                (
                    [_default] => Yaf_Route_Static Object
                        (
                        )

                )

            [_current:protected] =>
        )

    [_view:protected] =>
    [_request:protected] => Yaf_Request_Http Object
        (
            [module] =>
            [controller] =>
            [action] =>
            [method] => Cli
            [params:protected] => Array
                (
                )

            [language:protected] =>
            [_exception:protected] =>
            [_base_uri:protected] =>
            [uri:protected] =>
            [dispatched:protected] =>
            [routed:protected] =>
        )

    [_plugins:protected] => Array
        (
        )

    [_auto_render:protected] => 1
    [_return_response:protected] =>
    [_instantly_flush:protected] =>
    [_default_module:protected] => Index
    [_default_controller:protected] => Index
    [_default_action:protected] => index
    [_response] => Yaf_Response_Cli Object
        (
            [_header:protected] => Array
                (
                )

            [_body:protected] =>
            [_sendheader:protected] =>
        )

)
Yaf_Application::getConfig
Yaf_Application::getLastErrorMsg
Yaf_Application


Get message of the last occurred error

Yaf_Application::getDispatcher
Yaf_Application::getLastErrorNo
Yaf_Application
PHP Manual

Yaf_Application::getLastErrorMsg

(Yaf >=2.1.2)

Yaf_Application::getLastErrorMsg — Get message of the last occurred error

Açıklama

public string Yaf_Application::getLastErrorMsg ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Örnekler

Örnek 1 Yaf_Application::getLastErrorMsg()example

<?php
function error_handler($errno, $errstr, $errfile, $errline) {
   var_dump(Yaf_Application::app()->getLastErrorMsg());
}

$config = array(
 "application" => array(
   "directory" => "/tmp/notexists",
     "dispatcher" => array(
       "throwException" => 0, //trigger error instead of throw exception when error occure
      ),
  ),
);

$app = new Yaf_Application($config);
$app->getDispatcher()->setErrorHandler("error_handler", E_RECOVERABLE_ERROR);
$app->run();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(69) "Could not find controller script /tmp/notexists/controllers/Index.php"
Yaf_Application::getDispatcher
Yaf_Application::getLastErrorNo
Yaf_Application


Get code of last occurred error

Yaf_Application::getLastErrorMsg
Yaf_Application::getModules
Yaf_Application
PHP Manual

Yaf_Application::getLastErrorNo

(Yaf >=2.1.2)

Yaf_Application::getLastErrorNo — Get code of last occurred error

Açıklama

public int Yaf_Application::getLastErrorNo ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Örnekler

Örnek 1 Yaf_Application::getLastErrorNo()example

<?php
function error_handler($errno, $errstr, $errfile, $errline) {
   var_dump(Yaf_Application::app()->getLastErrorNo());
   var_dump(Yaf_Application::app()->getLastErrorNo() == YAF_ERR_NOTFOUND_CONTROLLER);
}

$config = array(
  "application" => array(
   "directory" => "/tmp/notexists",
     "dispatcher" => array(
       "throwException" => 0, //trigger error instead of throw exception when error occure
      ),
  ),
);

$app = new Yaf_Application($config);
$app->getDispatcher()->setErrorHandler("error_handler", E_RECOVERABLE_ERROR);
$app->run();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(516)
bool(true)
Yaf_Application::getLastErrorMsg
Yaf_Application::getModules
Yaf_Application


Get defined module names

Yaf_Application::getLastErrorNo
Yaf_Application::run
Yaf_Application
PHP Manual

Yaf_Application::getModules

(Yaf >=1.0.0)

Yaf_Application::getModules — Get defined module names

Açıklama

public array Yaf_Application::getModules ( void )

Get the modules list defined in config, if no one defined, there will always be a module named "Index".

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Örnekler

Örnek 1 Yaf_Application::getModules()example

<?php
$config = array(
    "application" => array(
        "directory" => realpath(dirname(__FILE__)) . "/application",
    ),
);

/** Yaf_Application */
$application = new Yaf_Application($config);
print_r($application->getModules());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [0] => Index
)
Yaf_Application::getLastErrorNo
Yaf_Application::run
Yaf_Application


Start Yaf_Application

Yaf_Application::getModules
Yaf_Application::setAppDirectory
Yaf_Application
PHP Manual

Yaf_Application::run

(Yaf >=1.0.0)

Yaf_Application::run — Start Yaf_Application

Açıklama

public void Yaf_Application::run ( void )

Run a Yaf_Application, let the Yaf_Application accept a request and route this request, dispatch to controller/action and render response. Finally, return the response to the client.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Application::getModules
Yaf_Application::setAppDirectory
Yaf_Application


Change the application directory

Yaf_Application::run
Yaf_Application::__sleep
Yaf_Application
PHP Manual

Yaf_Application::setAppDirectory

(Yaf >=2.1.4)

Yaf_Application::setAppDirectory — Change the application directory

Açıklama

public Yaf_Application Yaf_Application::setAppDirectory ( string $directory )

Değiştirgeler

directory

Dönen Değerler

Yaf_Application::run
Yaf_Application::__sleep
Yaf_Application


Yaf_Application can not be serialized

Yaf_Application::setAppDirectory
Yaf_Application::__wakeup
Yaf_Application
PHP Manual

Yaf_Application::__sleep

(Yaf >=1.0.0)

Yaf_Application::__sleep — Yaf_Application can not be serialized

Açıklama

private void Yaf_Application::__sleep ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Application::setAppDirectory
Yaf_Application::__wakeup
Yaf_Application


Yaf_Application can not be unserialized

Yaf_Application::__sleep
Yaf_Bootstrap_Abstract
Yaf_Application
PHP Manual

Yaf_Application::__wakeup

(Yaf >=1.0.0)

Yaf_Application::__wakeup — Yaf_Application can not be unserialized

Açıklama

private void Yaf_Application::__wakeup ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Application::__sleep
Yaf_Bootstrap_Abstract
Yaf_Application


The Yaf_Bootstrap_Abstract class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

Bootstrap is a mechanism used to do some intial config before a Application run.

User may define their own Bootstrap class by inheriting Yaf_Bootstrap_Abstract

Any method declared in Bootstrap class with leading "_init", will be called by Yaf_Application::bootstrap() one by one according to their defined order.

Örnekler

Örnek 1 Bootstrap example

<?php
   /* bootstrap class should be defined under ./application/Bootstrap.php */
   class Bootstrap extends Yaf_Bootstrap_Abstract {
        public function _initConfig(Yaf_Dispatcher $dispatcher) {
            var_dump(__METHOD__);
        }
        public function _initPlugin(Yaf_Dispatcher $dispatcher) {
            var_dump(__METHOD__);
        }
   }

   $config = array(
       "application" => array(
           "directory" => dirname(__FILE__) . "/application/",
       ),
   );

   $app = new Yaf_Application($config);
   $app->bootstrap();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(22) "Bootstrap::_initConfig"
string(22) "Bootstrap::_initPlugin"

Sınıf Sözdizimi

abstract Yaf_Bootstrap_Abstract {
/* Özellikler */
/* Yöntemler */
}
Yaf_Application::__wakeup
Yaf_Dispatcher
Yaf


The Yaf_Dispatcher class

(Yaf >=1.0.0)

Giriş

Yaf_Dispatcher purpose is to initialize the request environment, route the incoming request, and then dispatch any discovered actions; it aggregates any responses and returns them when the process is complete.

Yaf_Dispatcher also implements the Singleton pattern, meaning only a single instance of it may be available at any given time. This allows it to also act as a registry on which the other objects in the dispatch process may draw.

Sınıf Sözdizimi

final Yaf_Dispatcher {
/* Özellikler */
protected $_router ;
protected $_view ;
protected $_request ;
protected $_plugins ;
protected static $_instance ;
protected $_auto_render ;
protected $_return_response ;
protected $_instantly_flush ;
protected $_default_module ;
protected $_default_controller ;
protected $_default_action ;
/* Yöntemler */
public Yaf_Dispatcher autoRender ([ bool $flag ] )
public Yaf_Dispatcher catchException ([ bool $flag ] )
private void __clone ( void )
public __construct ( void )
public bool disableView ( void )
public Yaf_Response_Abstract dispatch ( Yaf_Request_Abstract $request )
public Yaf_Dispatcher enableView ( void )
public Yaf_Dispatcher flushInstantly ([ bool $flag ] )
public Yaf_Application getApplication ( void )
public static Yaf_Dispatcher getInstance ( void )
public Yaf_Request_Abstract getRequest ( void )
public Yaf_Router getRouter ( void )
public Yaf_View_Interface initView ( string $templates_dir [, array $options ] )
public Yaf_Dispatcher registerPlugin ( Yaf_Plugin_Abstract $plugin )
public Yaf_Dispatcher returnResponse ( bool $flag )
public Yaf_Dispatcher setDefaultAction ( string $action )
public Yaf_Dispatcher setDefaultController ( string $controller )
public Yaf_Dispatcher setDefaultModule ( string $module )
public Yaf_Dispatcher setErrorHandler ( call $callback , int $error_types )
public Yaf_Dispatcher setRequest ( Yaf_Request_Abstract $request )
public Yaf_Dispatcher setView ( Yaf_View_Interface $view )
private void __sleep ( void )
public Yaf_Dispatcher throwException ([ bool $flag ] )
private void __wakeup ( void )
}

Özellikler

_router

_view

_request

_plugins

_instance

_auto_render

_return_response

_instantly_flush

_default_module

_default_controller

_default_action

İçindekiler

  • Yaf_Dispatcher::autoRender — Switch on/off autorendering
  • Yaf_Dispatcher::catchException — Switch on/off exception catching
  • Yaf_Dispatcher::__clone — Yaf_Dispatcher can not be cloned
  • Yaf_Dispatcher::__construct — Yaf_Dispatcher constructor
  • Yaf_Dispatcher::disableView — Disable view rendering
  • Yaf_Dispatcher::dispatch — Dispatch a request
  • Yaf_Dispatcher::enableView — enable view rendering
  • Yaf_Dispatcher::flushInstantly — Switch on/off the instant flushing
  • Yaf_Dispatcher::getApplication — Retrive the application
  • Yaf_Dispatcher::getInstance — Retrive the dispatcher instance
  • Yaf_Dispatcher::getRequest — Retrive the request instance
  • Yaf_Dispatcher::getRouter — Retrive router instance
  • Yaf_Dispatcher::initView — Initialize view and return it
  • Yaf_Dispatcher::registerPlugin — Register a plugin
  • Yaf_Dispatcher::returnResponse — The returnResponse purpose
  • Yaf_Dispatcher::setDefaultAction — Change default action name
  • Yaf_Dispatcher::setDefaultController — Change default controller name
  • Yaf_Dispatcher::setDefaultModule — Change default module name
  • Yaf_Dispatcher::setErrorHandler — Set error handler
  • Yaf_Dispatcher::setRequest — The setRequest purpose
  • Yaf_Dispatcher::setView — Set a custom view engine
  • Yaf_Dispatcher::__sleep — Yaf_Dispatcher can not be serialized
  • Yaf_Dispatcher::throwException — Switch on/off exception throwing
  • Yaf_Dispatcher::__wakeup — Yaf_Dispatcher can not be unserialized
Yaf_Bootstrap_Abstract
Yaf_Dispatcher::autoRender
Yaf


Switch on/off autorendering

Yaf_Dispatcher
Yaf_Dispatcher::catchException
Yaf_Dispatcher
PHP Manual

Yaf_Dispatcher::autoRender

(Yaf >=1.0.0)

Yaf_Dispatcher::autoRender — Switch on/off autorendering

Açıklama

public Yaf_Dispatcher Yaf_Dispatcher::autoRender ([ bool $flag ] )

Yaf_Dispatcher will render automatically after dispatches a incoming request, you can prevent the rendering by calling this method with flag TRUE

Bilginize:

you can simply return FALSE in a action to prevent the auto-rendering of that action

Değiştirgeler

flag

bool

Bilginize:

since 2.2.0, if this parameter is not given, then the current state will be renturned

Dönen Değerler

Örnekler

Örnek 1 Yaf_Dispatcher::autoRender()example

<?php
class IndexController extends Yaf_Controller_Abstract {
     /* init method will be called as soon as a controller is initialized */
     public function init() {
         if ($this->getRequest()->isXmlHttpRequest()) {
             //do not call render for ajax request
             //we will outpu a json string
             Yaf_Dispatcher::getInstance()->autoRender(FALSE);
         }
     }

}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Yaf_Dispatcher

Yaf_Dispatcher::catchException

Yaf_Dispatcher


Switch on/off exception catching

Yaf_Dispatcher::autoRender
Yaf_Dispatcher::__clone
Yaf_Dispatcher
PHP Manual

Yaf_Dispatcher::catchException

(Yaf >=1.0.0)

Yaf_Dispatcher::catchException — Switch on/off exception catching

Açıklama

public Yaf_Dispatcher Yaf_Dispatcher::catchException ([ bool $flag ] )

While the application.dispatcher.throwException is On(you can also calling to Yaf_Dispatcher::throwException(TRUE)() to enable it), Yaf will throw Exception whe error occurrs instead of trigger error.

then if you enable Yaf_Dispatcher::catchException()(also can enabled by set application.dispatcher.catchException), all uncaught Exceptions will be caught by ErrorController::error if you have defined one.

Değiştirgeler

flag

bool

Dönen Değerler

Örnekler

Örnek 1 Yaf_Dispatcher::catchException()example

/* if you defined a ErrorController like following */
<?php
class ErrorController extends Yaf_Controller_Abstract {
     /**
      * you can also call to Yaf_Request_Abstract::getException to get the
      * un-caught exception.
      */
     public function errorAction($exception) {
        /* error occurs */
        switch ($exception->getCode()) {
            case YAF_ERR_NOTFOUND_MODULE:
            case YAF_ERR_NOTFOUND_CONTROLLER:
            case YAF_ERR_NOTFOUND_ACTION:
            case YAF_ERR_NOTFOUND_VIEW:
                echo 404, ":", $exception->getMessage();
                break;
            default :
                $message = $exception->getMessage();
                echo 0, ":", $exception->getMessage();
                break;
        }
     }
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

/* now if some error occur, assuming access a non-exists controller(or you can throw a exception yourself): */
404:Could not find controller script **/application/controllers/No-exists-controller.php

Ayrıca Bakınız

  • Yaf_Dispatcher::throwException() - Switch on/off exception throwing
  • Yaf_Dispatcher::setErrorHandler() - Set error handler
Yaf_Dispatcher::autoRender
Yaf_Dispatcher::__clone
Yaf_Dispatcher


Yaf_Dispatcher can not be cloned

Yaf_Dispatcher::catchException
Yaf_Dispatcher::__construct
Yaf_Dispatcher
PHP Manual

Yaf_Dispatcher::__clone

(Yaf >=1.0.0)

Yaf_Dispatcher::__clone — Yaf_Dispatcher can not be cloned

Açıklama

private void Yaf_Dispatcher::__clone ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Dispatcher::catchException
Yaf_Dispatcher::__construct
Yaf_Dispatcher


Yaf_Dispatcher constructor

Yaf_Dispatcher::__clone
Yaf_Dispatcher::disableView
Yaf_Dispatcher
PHP Manual

Yaf_Dispatcher::__construct

(Yaf >=1.0.0)

Yaf_Dispatcher::__construct — Yaf_Dispatcher constructor

Açıklama

public Yaf_Dispatcher::__construct ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Dispatcher::__clone
Yaf_Dispatcher::disableView
Yaf_Dispatcher


Disable view rendering

Yaf_Dispatcher::__construct
Yaf_Dispatcher::dispatch
Yaf_Dispatcher
PHP Manual

Yaf_Dispatcher::disableView

(Yaf >=1.0.0)

Yaf_Dispatcher::disableView — Disable view rendering

Açıklama

public bool Yaf_Dispatcher::disableView ( void )

disable view engine, used in some app that user will output by theirself

Bilginize:

you can simply return FALSE in a action to prevent the auto-rendering of that action

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Dispatcher::__construct
Yaf_Dispatcher::dispatch
Yaf_Dispatcher


Dispatch a request

Yaf_Dispatcher::disableView
Yaf_Dispatcher::enableView
Yaf_Dispatcher
PHP Manual

Yaf_Dispatcher::dispatch

(Yaf >=1.0.0)

Yaf_Dispatcher::dispatch — Dispatch a request

Açıklama

public Yaf_Response_Abstract Yaf_Dispatcher::dispatch ( Yaf_Request_Abstract $request )

This method does the heavy work of the Yaf_Dispatcher. It take a request object.

The dispatch process has three distinct events:

  • Routing
  • Dispatching
  • Response
Routing takes place exactly once, using the values in the request object when dispatch() is called. Dispatching takes place in a loop; a request may either indicate multiple actions to dispatch, or the controller or a plugin may reset the request object to force additional actions to dispatch(see Yaf_Plugin_Abstract. When all is done, the Yaf_Dispatcher returns a response.

Değiştirgeler

request

Dönen Değerler

Yaf_Dispatcher::disableView
Yaf_Dispatcher::enableView
Yaf_Dispatcher


enable view rendering

Yaf_Dispatcher::dispatch
Yaf_Dispatcher::flushInstantly
Yaf_Dispatcher
PHP Manual

Yaf_Dispatcher::enableView

(Yaf >=1.0.0)

Yaf_Dispatcher::enableView — enable view rendering

Açıklama

public Yaf_Dispatcher Yaf_Dispatcher::enableView ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Dispatcher::dispatch
Yaf_Dispatcher::flushInstantly
Yaf_Dispatcher


Switch on/off the instant flushing

Yaf_Dispatcher::enableView
Yaf_Dispatcher::getApplication
Yaf_Dispatcher
PHP Manual

Yaf_Dispatcher::flushInstantly

(Yaf >=1.0.0)

Yaf_Dispatcher::flushInstantly — Switch on/off the instant flushing

Açıklama

public Yaf_Dispatcher Yaf_Dispatcher::flushInstantly ([ bool $flag ] )

Değiştirgeler

flag

bool

Bilginize:

since 2.2.0, if this parameter is not given, then the current state will be renturned

Dönen Değerler

Yaf_Dispatcher::enableView
Yaf_Dispatcher::getApplication
Yaf_Dispatcher


Retrive the application

Yaf_Dispatcher::flushInstantly
Yaf_Dispatcher::getInstance
Yaf_Dispatcher
PHP Manual

Yaf_Dispatcher::getApplication

(Yaf >=1.0.0)

Yaf_Dispatcher::getApplication — Retrive the application

Açıklama

public Yaf_Application Yaf_Dispatcher::getApplication ( void )

Retrive the Yaf_Application instance. same as Yaf_Application::app().

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Ayrıca Bakınız

  • Yaf_Application::app() - Retrieve an Application instance
Yaf_Dispatcher::flushInstantly
Yaf_Dispatcher::getInstance
Yaf_Dispatcher


Retrive the dispatcher instance

Yaf_Dispatcher::getApplication
Yaf_Dispatcher::getRequest
Yaf_Dispatcher
PHP Manual

Yaf_Dispatcher::getInstance

(Yaf >=1.0.0)

Yaf_Dispatcher::getInstance — Retrive the dispatcher instance

Açıklama

public static Yaf_Dispatcher Yaf_Dispatcher::getInstance ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Dispatcher::getApplication
Yaf_Dispatcher::getRequest
Yaf_Dispatcher


Retrive the request instance

Yaf_Dispatcher::getInstance
Yaf_Dispatcher::getRouter
Yaf_Dispatcher
PHP Manual

Yaf_Dispatcher::getRequest

(Yaf >=1.0.0)

Yaf_Dispatcher::getRequest — Retrive the request instance

Açıklama

public Yaf_Request_Abstract Yaf_Dispatcher::getRequest ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Dispatcher::getInstance
Yaf_Dispatcher::getRouter
Yaf_Dispatcher


Retrive router instance

Yaf_Dispatcher::getRequest
Yaf_Dispatcher::initView
Yaf_Dispatcher
PHP Manual

Yaf_Dispatcher::getRouter

(Yaf >=1.0.0)

Yaf_Dispatcher::getRouter — Retrive router instance

Açıklama

public Yaf_Router Yaf_Dispatcher::getRouter ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Dispatcher::getRequest
Yaf_Dispatcher::initView
Yaf_Dispatcher


Initialize view and return it

Yaf_Dispatcher::getRouter
Yaf_Dispatcher::registerPlugin
Yaf_Dispatcher
PHP Manual

Yaf_Dispatcher::initView

(Yaf >=1.0.0)

Yaf_Dispatcher::initView — Initialize view and return it

Açıklama

public Yaf_View_Interface Yaf_Dispatcher::initView ( string $templates_dir [, array $options ] )

Değiştirgeler

templates_dir

options

Dönen Değerler

Yaf_Dispatcher::getRouter
Yaf_Dispatcher::registerPlugin
Yaf_Dispatcher


Register a plugin

Yaf_Dispatcher::initView
Yaf_Dispatcher::returnResponse
Yaf_Dispatcher
PHP Manual

Yaf_Dispatcher::registerPlugin

(Yaf >=1.0.0)

Yaf_Dispatcher::registerPlugin — Register a plugin

Açıklama

public Yaf_Dispatcher Yaf_Dispatcher::registerPlugin ( Yaf_Plugin_Abstract $plugin )

Register a plugin(see Yaf_Plugin_Abstract). Generally, we register plugins in Bootstrap(see Yaf_Bootstrap_Abstract).

Değiştirgeler

plugin

Dönen Değerler

Örnekler

Örnek 1 Yaf_Dispatcher::registerPlugin()example

<?php
class Bootstrap extends Yaf_Bootstrap_Abstract {
  public function _initPlugin(Yaf_Dispatcher $dispatcher) {
    /**
    * Yaf assumes plugin scripts under [application.directory] .  "/plugins"
    * for this case, it will be:
    * [application.directory] . "/plugins/" . "User" . [application.ext]
    */
    $user = new UserPlugin();
    $dispatcher->registerPlugin($user);
  }
}
?>

Ayrıca Bakınız

  • Yaf_Plugin_Abstract
  • Yaf_Bootstrap_Abstract
Yaf_Dispatcher::initView
Yaf_Dispatcher::returnResponse
Yaf_Dispatcher


The returnResponse purpose

Yaf_Dispatcher::registerPlugin
Yaf_Dispatcher::setDefaultAction
Yaf_Dispatcher
PHP Manual

Yaf_Dispatcher::returnResponse

(Yaf >=1.0.0)

Yaf_Dispatcher::returnResponse — The returnResponse purpose

Açıklama

public Yaf_Dispatcher Yaf_Dispatcher::returnResponse ( bool $flag )

Değiştirgeler

flag

Dönen Değerler

Yaf_Dispatcher::registerPlugin
Yaf_Dispatcher::setDefaultAction
Yaf_Dispatcher


Change default action name

Yaf_Dispatcher::returnResponse
Yaf_Dispatcher::setDefaultController
Yaf_Dispatcher
PHP Manual

Yaf_Dispatcher::setDefaultAction

(Yaf >=1.0.0)

Yaf_Dispatcher::setDefaultAction — Change default action name

Açıklama

public Yaf_Dispatcher Yaf_Dispatcher::setDefaultAction ( string $action )

Değiştirgeler

action

Dönen Değerler

Yaf_Dispatcher::returnResponse
Yaf_Dispatcher::setDefaultController
Yaf_Dispatcher


Change default controller name

Yaf_Dispatcher::setDefaultAction
Yaf_Dispatcher::setDefaultModule
Yaf_Dispatcher
PHP Manual

Yaf_Dispatcher::setDefaultController

(Yaf >=1.0.0)

Yaf_Dispatcher::setDefaultController — Change default controller name

Açıklama

public Yaf_Dispatcher Yaf_Dispatcher::setDefaultController ( string $controller )

Değiştirgeler

controller

Dönen Değerler

Yaf_Dispatcher::setDefaultAction
Yaf_Dispatcher::setDefaultModule
Yaf_Dispatcher


Change default module name

Yaf_Dispatcher::setDefaultController
Yaf_Dispatcher::setErrorHandler
Yaf_Dispatcher
PHP Manual

Yaf_Dispatcher::setDefaultModule

(Yaf >=1.0.0)

Yaf_Dispatcher::setDefaultModule — Change default module name

Açıklama

public Yaf_Dispatcher Yaf_Dispatcher::setDefaultModule ( string $module )

Değiştirgeler

module

Dönen Değerler

Yaf_Dispatcher::setDefaultController
Yaf_Dispatcher::setErrorHandler
Yaf_Dispatcher


Set error handler

Yaf_Dispatcher::setDefaultModule
Yaf_Dispatcher::setRequest
Yaf_Dispatcher
PHP Manual

Yaf_Dispatcher::setErrorHandler

(Yaf >=1.0.0)

Yaf_Dispatcher::setErrorHandler — Set error handler

Açıklama

public Yaf_Dispatcher Yaf_Dispatcher::setErrorHandler ( call $callback , int $error_types )

Set error handler for Yaf. when application.dispatcher.throwException is off, Yaf will trigger catchable error while unexpected errors occrred.

Thus, this error handler will be called while the error raise.

Değiştirgeler

callback

A callable callback

error_types

Dönen Değerler

Ayrıca Bakınız

  • Yaf_Dispatcher::throwException() - Switch on/off exception throwing
  • Yaf_Application::getLastErrorNo() - Get code of last occurred error
  • Yaf_Application::getLastErrorMsg() - Get message of the last occurred error
Yaf_Dispatcher::setDefaultModule
Yaf_Dispatcher::setRequest
Yaf_Dispatcher


The setRequest purpose

Yaf_Dispatcher::setErrorHandler
Yaf_Dispatcher::setView
Yaf_Dispatcher
PHP Manual

Yaf_Dispatcher::setRequest

(Yaf >=1.0.0)

Yaf_Dispatcher::setRequest — The setRequest purpose

Açıklama

public Yaf_Dispatcher Yaf_Dispatcher::setRequest ( Yaf_Request_Abstract $request )

Değiştirgeler

plugin

Dönen Değerler

Yaf_Dispatcher::setErrorHandler
Yaf_Dispatcher::setView
Yaf_Dispatcher


Set a custom view engine

Yaf_Dispatcher::setRequest
Yaf_Dispatcher::__sleep
Yaf_Dispatcher
PHP Manual

Yaf_Dispatcher::setView

(Yaf >=1.0.0)

Yaf_Dispatcher::setView — Set a custom view engine

Açıklama

public Yaf_Dispatcher Yaf_Dispatcher::setView ( Yaf_View_Interface $view )

This method proviods a solution for that if you want use a custom view engine instead of Yaf_View_Simple

Değiştirgeler

view

A Yaf_View_Interface instance

Dönen Değerler

Örnekler

Örnek 1 A custom View engine()example

<?php
require "/path/to/smarty/Smarty.class.php";

class Smarty_Adapter implements Yaf_View_Interface
{
    /**
     * Smarty object
     * @var Smarty
     */
    public $_smarty;

    /**
     * Constructor
     *
     * @param string $tmplPath
     * @param array $extraParams
     * @return void
     */
    public function __construct($tmplPath = null, $extraParams = array()) {
        $this->_smarty = new Smarty;

        if (null !== $tmplPath) {
            $this->setScriptPath($tmplPath);
        }

        foreach ($extraParams as $key => $value) {
            $this->_smarty->$key = $value;
        }
    }

    /**
     * Set the path to the templates
     *
     * @param string $path The directory to set as the path.
     * @return void
     */
    public function setScriptPath($path)
    {
        if (is_readable($path)) {
            $this->_smarty->template_dir = $path;
            return;
        }

        throw new Exception('Invalid path provided');
    }

    /**
     * Assign a variable to the template
     *
     * @param string $key The variable name.
     * @param mixed $val The variable value.
     * @return void
     */
    public function __set($key, $val)
    {
        $this->_smarty->assign($key, $val);
    }

    /**
     * Allows testing with empty() and isset() to work
     *
     * @param string $key
     * @return boolean
     */
    public function __isset($key)
    {
        return (null !== $this->_smarty->get_template_vars($key));
    }

    /**
     * Allows unset() on object properties to work
     *
     * @param string $key
     * @return void
     */
    public function __unset($key)
    {
        $this->_smarty->clear_assign($key);
    }

    /**
     * Assign variables to the template
     *
     * Allows setting a specific key to the specified value, OR passing
     * an array of key => value pairs to set en masse.
     *
     * @see __set()
     * @param string|array $spec The assignment strategy to use (key or
     * array of key => value pairs)
     * @param mixed $value (Optional) If assigning a named variable,
     * use this as the value.
     * @return void
     */
    public function assign($spec, $value = null) {
        if (is_array($spec)) {
            $this->_smarty->assign($spec);
            return;
        }

        $this->_smarty->assign($spec, $value);
    }

    /**
     * Clear all assigned variables
     *
     * Clears all variables assigned to Yaf_View either via
     * {@link assign()} or property overloading
     * ({@link __get()}/{@link __set()}).
     *
     * @return void
     */
    public function clearVars() {
        $this->_smarty->clear_all_assign();
    }

    /**
     * Processes a template and returns the output.
     *
     * @param string $name The template to process.
     * @return string The output.
     */
    public function render($name, $value = NULL) {
        return $this->_smarty->fetch($name);
    }

    public function display($name, $value = NULL) {
        echo $this->_smarty->fetch($name);
    }

}
?>

Örnek 2 Yaf_Dispatcher::setView()example

<?php
class Bootstrap extends Yaf_Bootstrap_Abstract {

    /**
     * there are some config for smarty in the config:
     *
     * smarty.left_delimiter   = "{{"
     * smarty.right_delimiter  = "}}"
     * smarty.template_dir     = APPLICATION_PATH "/views/scripts/"
     * smarty.compile_dir      = APPLICATION_PATH "/views/templates_c/"
     * smarty.cache_dir        = APPLICATION_PATH "/views/templates_d/"
     *
     */
    public function _initConfig() {
        $config = Yaf_Application::app()->getConfig();
        Yaf_Registry::set("config", $config);
    }

    public function _initLocalName() {
        /** we put class Smarty_Adapter under the local library directory */
        Yaf_Loader::getInstance()->registerLocalNamespace('Smarty');
    }

    public function _initSmarty(Yaf_Dispatcher $dispatcher) {
        $smarty = new Smarty_Adapter(null, Yaf_Registry::get("config")->get("smarty"));
        $dispatcher->setView($smarty);
        /* now the Smarty view engine become the default view engine of Yaf */
    }
}
?>

Ayrıca Bakınız

  • Yaf_View_Interface
  • Yaf_View_Simple
Yaf_Dispatcher::setRequest
Yaf_Dispatcher::__sleep
Yaf_Dispatcher


Yaf_Dispatcher can not be serialized

Yaf_Dispatcher::setView
Yaf_Dispatcher::throwException
Yaf_Dispatcher
PHP Manual

Yaf_Dispatcher::__sleep

(Yaf >=1.0.0)

Yaf_Dispatcher::__sleep — Yaf_Dispatcher can not be serialized

Açıklama

private void Yaf_Dispatcher::__sleep ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Dispatcher::setView
Yaf_Dispatcher::throwException
Yaf_Dispatcher


Switch on/off exception throwing

Yaf_Dispatcher::__sleep
Yaf_Dispatcher::__wakeup
Yaf_Dispatcher
PHP Manual

Yaf_Dispatcher::throwException

(Yaf >=1.0.0)

Yaf_Dispatcher::throwException — Switch on/off exception throwing

Açıklama

public Yaf_Dispatcher Yaf_Dispatcher::throwException ([ bool $flag ] )

Siwtch on/off exception throwing while unexpected error occurring. When this is on, Yaf will throwing exceptions instead of triggering catchable errors.

You can also use application.dispatcher.throwException to achieve the same purpose.

Değiştirgeler

flag

bool

Dönen Değerler

Örnekler

Örnek 1 Yaf_Dispatcher::throwexception()example

<?php

$config = array(
    'application' => array(
        'directory' => dirname(__FILE__),
    ),
);
$app = new Yaf_Application($config);

$app->getDispatcher()->throwException(true);

try {
    $app->run();
} catch (Yaf_Exception $e) {
    var_dump($e->getMessage());
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(59) "Could not find controller script /tmp/controllers/Index.php"

Örnek 2 Yaf_Dispatcher::throwexception()example

<?php

$config = array(
    'application' => array(
        'directory' => dirname(__FILE__),
    ),
);
$app = new Yaf_Application($config);

$app->getDispatcher()->throwException(false);

$app->run();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

PHP Catchable fatal error:  Yaf_Application::run(): Could not find controller script /tmp/controllers/Index.php in /tmp/1.php on line 12

Ayrıca Bakınız

  • Yaf_Dispatcher::catchException() - Switch on/off exception catching
  • Yaf_Exception
Yaf_Dispatcher::__sleep
Yaf_Dispatcher::__wakeup
Yaf_Dispatcher


Yaf_Dispatcher can not be unserialized

Yaf_Dispatcher::throwException
Yaf_Config_Abstract
Yaf_Dispatcher
PHP Manual

Yaf_Dispatcher::__wakeup

(Yaf >=1.0.0)

Yaf_Dispatcher::__wakeup — Yaf_Dispatcher can not be unserialized

Açıklama

private void Yaf_Dispatcher::__wakeup ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Dispatcher::throwException
Yaf_Config_Abstract
Yaf_Dispatcher


The Yaf_Config_Abstract class

(Yaf >=1.0.0)

Giriş

Sınıf Sözdizimi

abstract Yaf_Config_Abstract {
/* Özellikler */
protected $_config ;
protected $_readonly ;
/* Yöntemler */
abstract public mixed get ( string $name , mixed $value )
abstract public bool readonly ( void )
abstract public Yaf_Config_Abstract set ( void )
abstract public array toArray ( void )
}

Özellikler

_config

_readonly

İçindekiler

  • Yaf_Config_Abstract::get — Getter
  • Yaf_Config_Abstract::readonly — Find a config whether readonly
  • Yaf_Config_Abstract::set — Setter
  • Yaf_Config_Abstract::toArray — Cast to array
Yaf_Dispatcher::__wakeup
Yaf_Config_Abstract::get
Yaf


Getter

Yaf_Config_Abstract
Yaf_Config_Abstract::readonly
Yaf_Config_Abstract
PHP Manual

Yaf_Config_Abstract::get

(Yaf >=1.0.0)

Yaf_Config_Abstract::get — Getter

Açıklama

abstract public mixed Yaf_Config_Abstract::get ( string $name , mixed $value )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Config_Abstract
Yaf_Config_Abstract::readonly
Yaf_Config_Abstract


Find a config whether readonly

Yaf_Config_Abstract::get
Yaf_Config_Abstract::set
Yaf_Config_Abstract
PHP Manual

Yaf_Config_Abstract::readonly

(Yaf >=1.0.0)

Yaf_Config_Abstract::readonly — Find a config whether readonly

Açıklama

abstract public bool Yaf_Config_Abstract::readonly ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Config_Abstract::get
Yaf_Config_Abstract::set
Yaf_Config_Abstract


Setter

Yaf_Config_Abstract::readonly
Yaf_Config_Abstract::toArray
Yaf_Config_Abstract
PHP Manual

Yaf_Config_Abstract::set

(Yaf >=1.0.0)

Yaf_Config_Abstract::set — Setter

Açıklama

abstract public Yaf_Config_Abstract Yaf_Config_Abstract::set ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Config_Abstract::readonly
Yaf_Config_Abstract::toArray
Yaf_Config_Abstract


Cast to array

Yaf_Config_Abstract::set
Yaf_Config_Ini
Yaf_Config_Abstract
PHP Manual

Yaf_Config_Abstract::toArray

(Yaf >=1.0.0)

Yaf_Config_Abstract::toArray — Cast to array

Açıklama

abstract public array Yaf_Config_Abstract::toArray ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Config_Abstract::set
Yaf_Config_Ini
Yaf_Config_Abstract


The Yaf_Config_Ini class

(Yaf >=1.0.0)

Giriş

Yaf_Config_Ini enables developers to store configuration data in a familiar INI format and read them in the application by using nested object property syntax. The INI format is specialized to provide both the ability to have a hierarchy of configuration data keys and inheritance between configuration data sections. Configuration data hierarchies are supported by separating the keys with the dot or period character ("."). A section may extend or inherit from another section by following the section name with a colon character (":") and the name of the section from which data are to be inherited.

Bilginize:

Yaf_Config_Ini utilizes the » parse_ini_file() PHP function. Please review this documentation to be aware of its specific behaviors, which propagate to Yaf_Config_Ini, such as how the special values of "TRUE", "FALSE", "yes", "no", and "NULL" are handled.

Sınıf Sözdizimi

Yaf_Config_Ini extends Yaf_Config_Abstract implements Iterator , ArrayAccess , Countable {
/* Özellikler */
/* Yöntemler */
public __construct ( string $config_file [, string $section ] )
public void count ( void )
public void current ( void )
public void __get ([ string $name ] )
public void __isset ( string $name )
public void key ( void )
public void next ( void )
public void offsetExists ( string $name )
public void offsetGet ( string $name )
public void offsetSet ( string $name , string $value )
public void offsetUnset ( string $name )
public void readonly ( void )
public void rewind ( void )
public void __set ( string $name , mixed $value )
public array toArray ( void )
public void valid ( void )
/* Miras alınan yöntemler */
abstract public mixed Yaf_Config_Abstract::get ( string $name , mixed $value )
abstract public bool Yaf_Config_Abstract::readonly ( void )
abstract public Yaf_Config_Abstract Yaf_Config_Abstract::set ( void )
abstract public array Yaf_Config_Abstract::toArray ( void )
}

Özellikler

_config

_readonly

Örnekler

Örnek 1 Yaf_Config_Ini()example

This example illustrates a basic use of Yaf_Config_Ini for loading configuration data from an INI file. In this example there are configuration data for both a production system and for a staging system. Because the staging system configuration data are very similar to those for production, the staging section inherits from the production section. In this case, the decision is arbitrary and could have been written conversely, with the production section inheriting from the staging section, though this may not be the case for more complex situations. Suppose, then, that the following configuration data are contained in /path/to/config.ini:

; Production site configuration data
[production]
webhost                  = www.example.com
database.adapter         = pdo_mysql
database.params.host     = db.example.com
database.params.username = dbuser
database.params.password = secret
database.params.dbname   = dbname

; Staging site configuration data inherits from production and
; overrides values as necessary
[staging : production]
database.params.host     = dev.example.com
database.params.username = devuser
database.params.password = devsecret
<?php
$config = new Yaf_Config_Ini('/path/to/config.ini', 'staging');

var_dump($config->database->params->host);
var_dump($config->database->params->dbname);
var_dump($config->get("database.params.username"));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(15) "dev.example.com"
string(6) "dbname"
string(7) "devuser

İçindekiler

  • Yaf_Config_Ini::__construct — Yaf_Config_Ini constructor
  • Yaf_Config_Ini::count — The count purpose
  • Yaf_Config_Ini::current — The current purpose
  • Yaf_Config_Ini::__get — The __get purpose
  • Yaf_Config_Ini::__isset — The __isset purpose
  • Yaf_Config_Ini::key — The key purpose
  • Yaf_Config_Ini::next — The next purpose
  • Yaf_Config_Ini::offsetExists — The offsetExists purpose
  • Yaf_Config_Ini::offsetGet — The offsetGet purpose
  • Yaf_Config_Ini::offsetSet — The offsetSet purpose
  • Yaf_Config_Ini::offsetUnset — The offsetUnset purpose
  • Yaf_Config_Ini::readonly — The readonly purpose
  • Yaf_Config_Ini::rewind — The rewind purpose
  • Yaf_Config_Ini::__set — The __set purpose
  • Yaf_Config_Ini::toArray — Returns a PHP array
  • Yaf_Config_Ini::valid — The valid purpose
Yaf_Config_Abstract::toArray
Yaf_Config_Ini::__construct
Yaf


Yaf_Config_Ini constructor

Yaf_Config_Ini
Yaf_Config_Ini::count
Yaf_Config_Ini
PHP Manual

Yaf_Config_Ini::__construct

(Yaf >=1.0.0)

Yaf_Config_Ini::__construct — Yaf_Config_Ini constructor

Açıklama

public Yaf_Config_Ini::__construct ( string $config_file [, string $section ] )

Yaf_Config_Ini constructor

Değiştirgeler

config_file

path to an INI configure file

section

which section in that INI file you want to be parsed

Dönen Değerler

Yaf_Config_Ini
Yaf_Config_Ini::count
Yaf_Config_Ini


The count purpose

Yaf_Config_Ini::__construct
Yaf_Config_Ini::current
Yaf_Config_Ini
PHP Manual

Yaf_Config_Ini::count

(Yaf >=1.0.0)

Yaf_Config_Ini::count — The count purpose

Açıklama

public void Yaf_Config_Ini::count ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Config_Ini::__construct
Yaf_Config_Ini::current
Yaf_Config_Ini


The current purpose

Yaf_Config_Ini::count
Yaf_Config_Ini::__get
Yaf_Config_Ini
PHP Manual

Yaf_Config_Ini::current

(Yaf >=1.0.0)

Yaf_Config_Ini::current — The current purpose

Açıklama

public void Yaf_Config_Ini::current ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Config_Ini::count
Yaf_Config_Ini::__get
Yaf_Config_Ini


The __get purpose

Yaf_Config_Ini::current
Yaf_Config_Ini::__isset
Yaf_Config_Ini
PHP Manual

Yaf_Config_Ini::__get

(Yaf >=1.0.0)

Yaf_Config_Ini::__get — The __get purpose

Açıklama

public void Yaf_Config_Ini::__get ([ string $name ] )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

name

Dönen Değerler

Yaf_Config_Ini::current
Yaf_Config_Ini::__isset
Yaf_Config_Ini


The __isset purpose

Yaf_Config_Ini::__get
Yaf_Config_Ini::key
Yaf_Config_Ini
PHP Manual

Yaf_Config_Ini::__isset

(Yaf >=1.0.0)

Yaf_Config_Ini::__isset — The __isset purpose

Açıklama

public void Yaf_Config_Ini::__isset ( string $name )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

name

Dönen Değerler

Yaf_Config_Ini::__get
Yaf_Config_Ini::key
Yaf_Config_Ini


The key purpose

Yaf_Config_Ini::__isset
Yaf_Config_Ini::next
Yaf_Config_Ini
PHP Manual

Yaf_Config_Ini::key

(Yaf >=1.0.0)

Yaf_Config_Ini::key — The key purpose

Açıklama

public void Yaf_Config_Ini::key ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Config_Ini::__isset
Yaf_Config_Ini::next
Yaf_Config_Ini


The next purpose

Yaf_Config_Ini::key
Yaf_Config_Ini::offsetExists
Yaf_Config_Ini
PHP Manual

Yaf_Config_Ini::next

(Yaf >=1.0.0)

Yaf_Config_Ini::next — The next purpose

Açıklama

public void Yaf_Config_Ini::next ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Config_Ini::key
Yaf_Config_Ini::offsetExists
Yaf_Config_Ini


The offsetExists purpose

Yaf_Config_Ini::next
Yaf_Config_Ini::offsetGet
Yaf_Config_Ini
PHP Manual

Yaf_Config_Ini::offsetExists

(Yaf >=1.0.0)

Yaf_Config_Ini::offsetExists — The offsetExists purpose

Açıklama

public void Yaf_Config_Ini::offsetExists ( string $name )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

name

Dönen Değerler

Yaf_Config_Ini::next
Yaf_Config_Ini::offsetGet
Yaf_Config_Ini


The offsetGet purpose

Yaf_Config_Ini::offsetExists
Yaf_Config_Ini::offsetSet
Yaf_Config_Ini
PHP Manual

Yaf_Config_Ini::offsetGet

(Yaf >=1.0.0)

Yaf_Config_Ini::offsetGet — The offsetGet purpose

Açıklama

public void Yaf_Config_Ini::offsetGet ( string $name )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

name

Dönen Değerler

Yaf_Config_Ini::offsetExists
Yaf_Config_Ini::offsetSet
Yaf_Config_Ini


The offsetSet purpose

Yaf_Config_Ini::offsetGet
Yaf_Config_Ini::offsetUnset
Yaf_Config_Ini
PHP Manual

Yaf_Config_Ini::offsetSet

(Yaf >=1.0.0)

Yaf_Config_Ini::offsetSet — The offsetSet purpose

Açıklama

public void Yaf_Config_Ini::offsetSet ( string $name , string $value )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

name

value

Dönen Değerler

Yaf_Config_Ini::offsetGet
Yaf_Config_Ini::offsetUnset
Yaf_Config_Ini


The offsetUnset purpose

Yaf_Config_Ini::offsetSet
Yaf_Config_Ini::readonly
Yaf_Config_Ini
PHP Manual

Yaf_Config_Ini::offsetUnset

(Yaf >=1.0.0)

Yaf_Config_Ini::offsetUnset — The offsetUnset purpose

Açıklama

public void Yaf_Config_Ini::offsetUnset ( string $name )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

name

Dönen Değerler

Yaf_Config_Ini::offsetSet
Yaf_Config_Ini::readonly
Yaf_Config_Ini


The readonly purpose

Yaf_Config_Ini::offsetUnset
Yaf_Config_Ini::rewind
Yaf_Config_Ini
PHP Manual

Yaf_Config_Ini::readonly

(Yaf >=1.0.0)

Yaf_Config_Ini::readonly — The readonly purpose

Açıklama

public void Yaf_Config_Ini::readonly ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Config_Ini::offsetUnset
Yaf_Config_Ini::rewind
Yaf_Config_Ini


The rewind purpose

Yaf_Config_Ini::readonly
Yaf_Config_Ini::__set
Yaf_Config_Ini
PHP Manual

Yaf_Config_Ini::rewind

(Yaf >=1.0.0)

Yaf_Config_Ini::rewind — The rewind purpose

Açıklama

public void Yaf_Config_Ini::rewind ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Config_Ini::readonly
Yaf_Config_Ini::__set
Yaf_Config_Ini


The __set purpose

Yaf_Config_Ini::rewind
Yaf_Config_Ini::toArray
Yaf_Config_Ini
PHP Manual

Yaf_Config_Ini::__set

(Yaf >=1.0.0)

Yaf_Config_Ini::__set — The __set purpose

Açıklama

public void Yaf_Config_Ini::__set ( string $name , mixed $value )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

name

value

Dönen Değerler

Yaf_Config_Ini::rewind
Yaf_Config_Ini::toArray
Yaf_Config_Ini


Returns a PHP array

Yaf_Config_Ini::__set
Yaf_Config_Ini::valid
Yaf_Config_Ini
PHP Manual

Yaf_Config_Ini::toArray

(Yaf >=1.0.0)

Yaf_Config_Ini::toArray — Returns a PHP array

Açıklama

public array Yaf_Config_Ini::toArray ( void )

Returns a PHP array from the Yaf_Config_Ini

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Config_Ini::__set
Yaf_Config_Ini::valid
Yaf_Config_Ini


The valid purpose

Yaf_Config_Ini::toArray
Yaf_Config_Simple
Yaf_Config_Ini
PHP Manual

Yaf_Config_Ini::valid

(Yaf >=1.0.0)

Yaf_Config_Ini::valid — The valid purpose

Açıklama

public void Yaf_Config_Ini::valid ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Config_Ini::toArray
Yaf_Config_Simple
Yaf_Config_Ini


The Yaf_Config_Simple class

(Yaf >=1.0.0)

Giriş

Sınıf Sözdizimi

Yaf_Config_Simple extends Yaf_Config_Abstract implements Iterator , ArrayAccess , Countable {
/* Özellikler */
protected $_readonly ;
/* Yöntemler */
public __construct ( string $config_file [, string $section ] )
public void count ( void )
public void current ( void )
public void __get ([ string $name ] )
public void __isset ( string $name )
public void key ( void )
public void next ( void )
public void offsetExists ( string $name )
public void offsetGet ( string $name )
public void offsetSet ( string $name , string $value )
public void offsetUnset ( string $name )
public void readonly ( void )
public void rewind ( void )
public void __set ( string $name , string $value )
public array toArray ( void )
public void valid ( void )
/* Miras alınan yöntemler */
abstract public mixed Yaf_Config_Abstract::get ( string $name , mixed $value )
abstract public bool Yaf_Config_Abstract::readonly ( void )
abstract public Yaf_Config_Abstract Yaf_Config_Abstract::set ( void )
abstract public array Yaf_Config_Abstract::toArray ( void )
}

Özellikler

_config

_readonly

İçindekiler

  • Yaf_Config_Simple::__construct — The __construct purpose
  • Yaf_Config_Simple::count — The count purpose
  • Yaf_Config_Simple::current — The current purpose
  • Yaf_Config_Simple::__get — The __get purpose
  • Yaf_Config_Simple::__isset — The __isset purpose
  • Yaf_Config_Simple::key — The key purpose
  • Yaf_Config_Simple::next — The next purpose
  • Yaf_Config_Simple::offsetExists — The offsetExists purpose
  • Yaf_Config_Simple::offsetGet — The offsetGet purpose
  • Yaf_Config_Simple::offsetSet — The offsetSet purpose
  • Yaf_Config_Simple::offsetUnset — The offsetUnset purpose
  • Yaf_Config_Simple::readonly — The readonly purpose
  • Yaf_Config_Simple::rewind — The rewind purpose
  • Yaf_Config_Simple::__set — The __set purpose
  • Yaf_Config_Simple::toArray — Returns a PHP array
  • Yaf_Config_Simple::valid — The valid purpose
Yaf_Config_Ini::valid
Yaf_Config_Simple::__construct
Yaf


The __construct purpose

Yaf_Config_Simple
Yaf_Config_Simple::count
Yaf_Config_Simple
PHP Manual

Yaf_Config_Simple::__construct

(Yaf >=1.0.0)

Yaf_Config_Simple::__construct — The __construct purpose

Açıklama

public Yaf_Config_Simple::__construct ( string $config_file [, string $section ] )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

config_file

section

Dönen Değerler

Yaf_Config_Simple
Yaf_Config_Simple::count
Yaf_Config_Simple


The count purpose

Yaf_Config_Simple::__construct
Yaf_Config_Simple::current
Yaf_Config_Simple
PHP Manual

Yaf_Config_Simple::count

(Yaf >=1.0.0)

Yaf_Config_Simple::count — The count purpose

Açıklama

public void Yaf_Config_Simple::count ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Config_Simple::__construct
Yaf_Config_Simple::current
Yaf_Config_Simple


The current purpose

Yaf_Config_Simple::count
Yaf_Config_Simple::__get
Yaf_Config_Simple
PHP Manual

Yaf_Config_Simple::current

(Yaf >=1.0.0)

Yaf_Config_Simple::current — The current purpose

Açıklama

public void Yaf_Config_Simple::current ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Config_Simple::count
Yaf_Config_Simple::__get
Yaf_Config_Simple


The __get purpose

Yaf_Config_Simple::current
Yaf_Config_Simple::__isset
Yaf_Config_Simple
PHP Manual

Yaf_Config_Simple::__get

(Yaf >=1.0.0)

Yaf_Config_Simple::__get — The __get purpose

Açıklama

public void Yaf_Config_Simple::__get ([ string $name ] )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

name

Dönen Değerler

Yaf_Config_Simple::current
Yaf_Config_Simple::__isset
Yaf_Config_Simple


The __isset purpose

Yaf_Config_Simple::__get
Yaf_Config_Simple::key
Yaf_Config_Simple
PHP Manual

Yaf_Config_Simple::__isset

(Yaf >=1.0.0)

Yaf_Config_Simple::__isset — The __isset purpose

Açıklama

public void Yaf_Config_Simple::__isset ( string $name )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

name

Dönen Değerler

Yaf_Config_Simple::__get
Yaf_Config_Simple::key
Yaf_Config_Simple


The key purpose

Yaf_Config_Simple::__isset
Yaf_Config_Simple::next
Yaf_Config_Simple
PHP Manual

Yaf_Config_Simple::key

(Yaf >=1.0.0)

Yaf_Config_Simple::key — The key purpose

Açıklama

public void Yaf_Config_Simple::key ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Config_Simple::__isset
Yaf_Config_Simple::next
Yaf_Config_Simple


The next purpose

Yaf_Config_Simple::key
Yaf_Config_Simple::offsetExists
Yaf_Config_Simple
PHP Manual

Yaf_Config_Simple::next

(Yaf >=1.0.0)

Yaf_Config_Simple::next — The next purpose

Açıklama

public void Yaf_Config_Simple::next ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Config_Simple::key
Yaf_Config_Simple::offsetExists
Yaf_Config_Simple


The offsetExists purpose

Yaf_Config_Simple::next
Yaf_Config_Simple::offsetGet
Yaf_Config_Simple
PHP Manual

Yaf_Config_Simple::offsetExists

(Yaf >=1.0.0)

Yaf_Config_Simple::offsetExists — The offsetExists purpose

Açıklama

public void Yaf_Config_Simple::offsetExists ( string $name )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

name

Dönen Değerler

Yaf_Config_Simple::next
Yaf_Config_Simple::offsetGet
Yaf_Config_Simple


The offsetGet purpose

Yaf_Config_Simple::offsetExists
Yaf_Config_Simple::offsetSet
Yaf_Config_Simple
PHP Manual

Yaf_Config_Simple::offsetGet

(Yaf >=1.0.0)

Yaf_Config_Simple::offsetGet — The offsetGet purpose

Açıklama

public void Yaf_Config_Simple::offsetGet ( string $name )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

name

Dönen Değerler

Yaf_Config_Simple::offsetExists
Yaf_Config_Simple::offsetSet
Yaf_Config_Simple


The offsetSet purpose

Yaf_Config_Simple::offsetGet
Yaf_Config_Simple::offsetUnset
Yaf_Config_Simple
PHP Manual

Yaf_Config_Simple::offsetSet

(Yaf >=1.0.0)

Yaf_Config_Simple::offsetSet — The offsetSet purpose

Açıklama

public void Yaf_Config_Simple::offsetSet ( string $name , string $value )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

name

value

Dönen Değerler

Yaf_Config_Simple::offsetGet
Yaf_Config_Simple::offsetUnset
Yaf_Config_Simple


The offsetUnset purpose

Yaf_Config_Simple::offsetSet
Yaf_Config_Simple::readonly
Yaf_Config_Simple
PHP Manual

Yaf_Config_Simple::offsetUnset

(Yaf >=1.0.0)

Yaf_Config_Simple::offsetUnset — The offsetUnset purpose

Açıklama

public void Yaf_Config_Simple::offsetUnset ( string $name )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

name

Dönen Değerler

Yaf_Config_Simple::offsetSet
Yaf_Config_Simple::readonly
Yaf_Config_Simple


The readonly purpose

Yaf_Config_Simple::offsetUnset
Yaf_Config_Simple::rewind
Yaf_Config_Simple
PHP Manual

Yaf_Config_Simple::readonly

(Yaf >=1.0.0)

Yaf_Config_Simple::readonly — The readonly purpose

Açıklama

public void Yaf_Config_Simple::readonly ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Config_Simple::offsetUnset
Yaf_Config_Simple::rewind
Yaf_Config_Simple


The rewind purpose

Yaf_Config_Simple::readonly
Yaf_Config_Simple::__set
Yaf_Config_Simple
PHP Manual

Yaf_Config_Simple::rewind

(Yaf >=1.0.0)

Yaf_Config_Simple::rewind — The rewind purpose

Açıklama

public void Yaf_Config_Simple::rewind ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Config_Simple::readonly
Yaf_Config_Simple::__set
Yaf_Config_Simple


The __set purpose

Yaf_Config_Simple::rewind
Yaf_Config_Simple::toArray
Yaf_Config_Simple
PHP Manual

Yaf_Config_Simple::__set

(Yaf >=1.0.0)

Yaf_Config_Simple::__set — The __set purpose

Açıklama

public void Yaf_Config_Simple::__set ( string $name , string $value )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

name

value

Dönen Değerler

Yaf_Config_Simple::rewind
Yaf_Config_Simple::toArray
Yaf_Config_Simple


Returns a PHP array

Yaf_Config_Simple::__set
Yaf_Config_Simple::valid
Yaf_Config_Simple
PHP Manual

Yaf_Config_Simple::toArray

(Yaf >=1.0.0)

Yaf_Config_Simple::toArray — Returns a PHP array

Açıklama

public array Yaf_Config_Simple::toArray ( void )

Returns a PHP array from the Yaf_Config_Simple

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Config_Simple::__set
Yaf_Config_Simple::valid
Yaf_Config_Simple


The valid purpose

Yaf_Config_Simple::toArray
Yaf_Controller_Abstract
Yaf_Config_Simple
PHP Manual

Yaf_Config_Simple::valid

(Yaf >=1.0.0)

Yaf_Config_Simple::valid — The valid purpose

Açıklama

public void Yaf_Config_Simple::valid ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Config_Simple::toArray
Yaf_Controller_Abstract
Yaf_Config_Simple


The Yaf_Controller_Abstract class

(Yaf >=1.0.0)

Giriş

Yaf_Controller_Abstract is the heart of Yaf's system. MVC stands for Model-View-Controller and is a design pattern targeted at separating application logic from display logic.

Every custom controller shall inherit Yaf_Controller_Abstract.

You will find that you can not define __construct function for your custom controller, thus, Yaf_Controller_Abstract provides a magic method: Yaf_Controller_Abstract::init().

If you have defined a init() method in your custom controller, it will be called as long as the controller was instantiated.

Action may have arguments, when a request coming, if there are the same name variable in the request parameters(see Yaf_Request_Abstract::getParam()) after routed, Yaf will pass them to the action method (see Yaf_Action_Abstract::execute()).

Bilginize:

These arguments are directly fetched without filtering, it should be carefully processed before use them.

Sınıf Sözdizimi

abstract Yaf_Controller_Abstract {
/* Özellikler */
public $actions ;
protected $_module ;
protected $_name ;
protected $_request ;
protected $_response ;
protected $_invoke_args ;
protected $_view ;
/* Yöntemler */
final private void __clone ( void )
final private __construct ( void )
protected bool display ( string $tpl [, array $parameters ] )
public void forward ( string $action [, array $paramters ] )
public void getInvokeArg ( string $name )
public void getInvokeArgs ( void )
public string getModuleName ( void )
public Yaf_Request_Abstract getRequest ( void )
public Yaf_Response_Abstract getResponse ( void )
public Yaf_View_Interface getView ( void )
public void getViewpath ( void )
public void init ( void )
public void initView ([ array $options ] )
public bool redirect ( string $url )
protected string render ( string $tpl [, array $parameters ] )
public void setViewpath ( string $view_directory )
}

Özellikler

actions

You can also define a action method in a separate PHP script by using this property and Yaf_Action_Abstract.

Örnek 1 define action in a separate file

<?php
class IndexController extends Yaf_Controller_Abstract {
    protected $actions = array(
        /** now dummyAction is defined in a separate file */
        "dummy" => "actions/Dummy_action.php",
    );

    /* action method may have arguments */
    public indexAction($name, $id) {
       /* $name and $id are unsafe raw data */
       assert($name == $this->getRequest()->getParam("name"));
       assert($id   == $this->_request->getParam("id"));
    }
}
?>

Örnek 2 Dummy_action.php

<?php
class DummyAction extends Yaf_Action_Abstract {
    /* a action class shall define this method  as the entry point */
    public execute() {
    }
}
?>

_module

module name

_name

controller name

_request

current request object

_response

current response object

_invoke_args

_view

view engine object

İçindekiler

  • Yaf_Controller_Abstract::__clone — Yaf_Controller_Abstract can not be cloned
  • Yaf_Controller_Abstract::__construct — Yaf_Controller_Abstract constructor
  • Yaf_Controller_Abstract::display — The display purpose
  • Yaf_Controller_Abstract::forward — foward to another action
  • Yaf_Controller_Abstract::getInvokeArg — The getInvokeArg purpose
  • Yaf_Controller_Abstract::getInvokeArgs — The getInvokeArgs purpose
  • Yaf_Controller_Abstract::getModuleName — Get module name
  • Yaf_Controller_Abstract::getRequest — Retrieve current request object
  • Yaf_Controller_Abstract::getResponse — Retrieve current response object
  • Yaf_Controller_Abstract::getView — Retrieve the view engine
  • Yaf_Controller_Abstract::getViewpath — The getViewpath purpose
  • Yaf_Controller_Abstract::init — Controller initializer
  • Yaf_Controller_Abstract::initView — The initView purpose
  • Yaf_Controller_Abstract::redirect — Redirect to a URL
  • Yaf_Controller_Abstract::render — Render view template
  • Yaf_Controller_Abstract::setViewpath — The setViewpath purpose
Yaf_Config_Simple::valid
Yaf_Controller_Abstract::__clone
Yaf


Yaf_Controller_Abstract can not be cloned

Yaf_Controller_Abstract
Yaf_Controller_Abstract::__construct
Yaf_Controller_Abstract
PHP Manual

Yaf_Controller_Abstract::__clone

(Yaf >=1.0.0)

Yaf_Controller_Abstract::__clone — Yaf_Controller_Abstract can not be cloned

Açıklama

final private void Yaf_Controller_Abstract::__clone ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Controller_Abstract
Yaf_Controller_Abstract::__construct
Yaf_Controller_Abstract


Yaf_Controller_Abstract constructor

Yaf_Controller_Abstract::__clone
Yaf_Controller_Abstract::display
Yaf_Controller_Abstract
PHP Manual

Yaf_Controller_Abstract::__construct

(Yaf >=1.0.0)

Yaf_Controller_Abstract::__construct — Yaf_Controller_Abstract constructor

Açıklama

final private Yaf_Controller_Abstract::__construct ( void )

Yaf_Controller_Abstract::__construct() is final, which means it can not be overridden. You may want to see Yaf_Controller_Abstract::init() instead.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Ayrıca Bakınız

  • Yaf_Controller_Abstract::init() - Controller initializer
Yaf_Controller_Abstract::__clone
Yaf_Controller_Abstract::display
Yaf_Controller_Abstract


The display purpose

Yaf_Controller_Abstract::__construct
Yaf_Controller_Abstract::forward
Yaf_Controller_Abstract
PHP Manual

Yaf_Controller_Abstract::display

(Yaf >=1.0.0)

Yaf_Controller_Abstract::display — The display purpose

Açıklama

protected bool Yaf_Controller_Abstract::display ( string $tpl [, array $parameters ] )

Değiştirgeler

tpl

parameters

Dönen Değerler

Yaf_Controller_Abstract::__construct
Yaf_Controller_Abstract::forward
Yaf_Controller_Abstract


foward to another action

Yaf_Controller_Abstract::display
Yaf_Controller_Abstract::getInvokeArg
Yaf_Controller_Abstract
PHP Manual

Yaf_Controller_Abstract::forward

(Yaf >=1.0.0)

Yaf_Controller_Abstract::forward — foward to another action

Açıklama

public void Yaf_Controller_Abstract::forward ( string $action [, array $paramters ] )
public void Yaf_Controller_Abstract::forward ( string $controller , string $action [, array $paramters ] )
public void Yaf_Controller_Abstract::forward ( string $module , string $controller , string $action [, array $paramters ] )

forward current execution process to other action.

Bilginize:

this method doesn't switch to the destination action immediately, it will take place after current flow finish.

Değiştirgeler

module

destination module name, if NULL was given, then default module name is assumed

controller

destination controller name

action

destination action name

paramters

calling arguments

Örnekler

Örnek 1 Yaf_Controller_Abstract::forward()example

<?php
class IndexController extends Yaf_Controller_Abstract
{
    public function indexAction(){
         $logined = $_SESSION["login"];
         if (!$logined) {
             $this->forward("login", array("from" => "Index")); // forward to login action
             return FALSE;  // this is important, this finish current working flow
                            // and tell the Yaf do not doing auto-render
         }

         // other processes
    }

    public function loginAction() {
         echo "login, redirected from ", $this->_request->getParam("from") , " action";
    }
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

   login, redirected from Index action

Dönen Değerler

return FALSE on failure

Ayrıca Bakınız

  • Yaf_Request_Abstrace::getParam()
Yaf_Controller_Abstract::display
Yaf_Controller_Abstract::getInvokeArg
Yaf_Controller_Abstract


The getInvokeArg purpose

Yaf_Controller_Abstract::forward
Yaf_Controller_Abstract::getInvokeArgs
Yaf_Controller_Abstract
PHP Manual

Yaf_Controller_Abstract::getInvokeArg

(Yaf >=1.0.0)

Yaf_Controller_Abstract::getInvokeArg — The getInvokeArg purpose

Açıklama

public void Yaf_Controller_Abstract::getInvokeArg ( string $name )

Değiştirgeler

name

Dönen Değerler

Yaf_Controller_Abstract::forward
Yaf_Controller_Abstract::getInvokeArgs
Yaf_Controller_Abstract


The getInvokeArgs purpose

Yaf_Controller_Abstract::getInvokeArg
Yaf_Controller_Abstract::getModuleName
Yaf_Controller_Abstract
PHP Manual

Yaf_Controller_Abstract::getInvokeArgs

(Yaf >=1.0.0)

Yaf_Controller_Abstract::getInvokeArgs — The getInvokeArgs purpose

Açıklama

public void Yaf_Controller_Abstract::getInvokeArgs ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Controller_Abstract::getInvokeArg
Yaf_Controller_Abstract::getModuleName
Yaf_Controller_Abstract


Get module name

Yaf_Controller_Abstract::getInvokeArgs
Yaf_Controller_Abstract::getRequest
Yaf_Controller_Abstract
PHP Manual

Yaf_Controller_Abstract::getModuleName

(Yaf >=1.0.0)

Yaf_Controller_Abstract::getModuleName — Get module name

Açıklama

public string Yaf_Controller_Abstract::getModuleName ( void )

get the controller's module name

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Controller_Abstract::getInvokeArgs
Yaf_Controller_Abstract::getRequest
Yaf_Controller_Abstract


Retrieve current request object

Yaf_Controller_Abstract::getModuleName
Yaf_Controller_Abstract::getResponse
Yaf_Controller_Abstract
PHP Manual

Yaf_Controller_Abstract::getRequest

(Yaf >=1.0.0)

Yaf_Controller_Abstract::getRequest — Retrieve current request object

Açıklama

public Yaf_Request_Abstract Yaf_Controller_Abstract::getRequest ( void )

retrieve current request object

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Request_Abstract instance

Yaf_Controller_Abstract::getModuleName
Yaf_Controller_Abstract::getResponse
Yaf_Controller_Abstract


Retrieve current response object

Yaf_Controller_Abstract::getRequest
Yaf_Controller_Abstract::getView
Yaf_Controller_Abstract
PHP Manual

Yaf_Controller_Abstract::getResponse

(Yaf >=1.0.0)

Yaf_Controller_Abstract::getResponse — Retrieve current response object

Açıklama

public Yaf_Response_Abstract Yaf_Controller_Abstract::getResponse ( void )

retrieve current response object

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Response_Abstract instance

Yaf_Controller_Abstract::getRequest
Yaf_Controller_Abstract::getView
Yaf_Controller_Abstract


Retrieve the view engine

Yaf_Controller_Abstract::getResponse
Yaf_Controller_Abstract::getViewpath
Yaf_Controller_Abstract
PHP Manual

Yaf_Controller_Abstract::getView

(Yaf >=1.0.0)

Yaf_Controller_Abstract::getView — Retrieve the view engine

Açıklama

public Yaf_View_Interface Yaf_Controller_Abstract::getView ( void )

retrieve view engine

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Controller_Abstract::getResponse
Yaf_Controller_Abstract::getViewpath
Yaf_Controller_Abstract


The getViewpath purpose

Yaf_Controller_Abstract::getView
Yaf_Controller_Abstract::init
Yaf_Controller_Abstract
PHP Manual

Yaf_Controller_Abstract::getViewpath

(Yaf >=1.0.0)

Yaf_Controller_Abstract::getViewpath — The getViewpath purpose

Açıklama

public void Yaf_Controller_Abstract::getViewpath ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Controller_Abstract::getView
Yaf_Controller_Abstract::init
Yaf_Controller_Abstract


Controller initializer

Yaf_Controller_Abstract::getViewpath
Yaf_Controller_Abstract::initView
Yaf_Controller_Abstract
PHP Manual

Yaf_Controller_Abstract::init

(Yaf >=1.0.0)

Yaf_Controller_Abstract::init — Controller initializer

Açıklama

public void Yaf_Controller_Abstract::init ( void )

Yaf_Controller_Abstract::__construct() is final, which means users can not override it. but users can define Yaf_Controller_Abstract::init(), which will be called after controller object is instantiated.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Ayrıca Bakınız

  • Yaf_Controller_Abstract::__construct() - Yaf_Controller_Abstract constructor
Yaf_Controller_Abstract::getViewpath
Yaf_Controller_Abstract::initView
Yaf_Controller_Abstract


The initView purpose

Yaf_Controller_Abstract::init
Yaf_Controller_Abstract::redirect
Yaf_Controller_Abstract
PHP Manual

Yaf_Controller_Abstract::initView

(Yaf >=1.0.0)

Yaf_Controller_Abstract::initView — The initView purpose

Açıklama

public void Yaf_Controller_Abstract::initView ([ array $options ] )

Değiştirgeler

options

Dönen Değerler

Yaf_Controller_Abstract::init
Yaf_Controller_Abstract::redirect
Yaf_Controller_Abstract


Redirect to a URL

Yaf_Controller_Abstract::initView
Yaf_Controller_Abstract::render
Yaf_Controller_Abstract
PHP Manual

Yaf_Controller_Abstract::redirect

(Yaf >=1.0.0)

Yaf_Controller_Abstract::redirect — Redirect to a URL

Açıklama

public bool Yaf_Controller_Abstract::redirect ( string $url )

redirect to a URL by sending a 302 header

Değiştirgeler

url

a location URL

Dönen Değerler

bool

Yaf_Controller_Abstract::initView
Yaf_Controller_Abstract::render
Yaf_Controller_Abstract


Render view template

Yaf_Controller_Abstract::redirect
Yaf_Controller_Abstract::setViewpath
Yaf_Controller_Abstract
PHP Manual

Yaf_Controller_Abstract::render

(Yaf >=1.0.0)

Yaf_Controller_Abstract::render — Render view template

Açıklama

protected string Yaf_Controller_Abstract::render ( string $tpl [, array $parameters ] )

Değiştirgeler

tpl

parameters

Dönen Değerler

Yaf_Controller_Abstract::redirect
Yaf_Controller_Abstract::setViewpath
Yaf_Controller_Abstract


The setViewpath purpose

Yaf_Controller_Abstract::render
Yaf_Action_Abstract
Yaf_Controller_Abstract
PHP Manual

Yaf_Controller_Abstract::setViewpath

(Yaf >=1.0.0)

Yaf_Controller_Abstract::setViewpath — The setViewpath purpose

Açıklama

public void Yaf_Controller_Abstract::setViewpath ( string $view_directory )

Değiştirgeler

view_directory

Dönen Değerler

Yaf_Controller_Abstract::render
Yaf_Action_Abstract
Yaf_Controller_Abstract


The Yaf_Action_Abstract class

(Yaf >=1.0.0)

Giriş

A action can be defined in a separate file in Yaf(see Yaf_Controller_Abstract). that is a action method can also be a Yaf_Action_Abstract class.

Since there should be a entry point which can be called by Yaf (as of PHP 5.3, there is a new magic method __invoke, but Yaf is not only works with PHP 5.3+, Yaf choose another magic method execute), you must implement the abstract method Yaf_Action_Abstract::execute() in your custom action class.

Sınıf Sözdizimi

Yaf_Action_Abstract extends Yaf_Controller_Abstract {
/* Özellikler */
protected $_controller ;
/* Yöntemler */
abstract publicmixed execute ([ mixed $arg [, mixed $... ]] )
publicYaf_Controller_Abstract getController ( void )
/* Miras alınan yöntemler */
final private void Yaf_Controller_Abstract::__clone ( void )
final private Yaf_Controller_Abstract::__construct ( void )
protected bool Yaf_Controller_Abstract::display ( string $tpl [, array $parameters ] )
public void Yaf_Controller_Abstract::forward ( string $action [, array $paramters ] )
public void Yaf_Controller_Abstract::getInvokeArg ( string $name )
public void Yaf_Controller_Abstract::getInvokeArgs ( void )
public string Yaf_Controller_Abstract::getModuleName ( void )
public Yaf_Request_Abstract Yaf_Controller_Abstract::getRequest ( void )
public Yaf_Response_Abstract Yaf_Controller_Abstract::getResponse ( void )
public Yaf_View_Interface Yaf_Controller_Abstract::getView ( void )
public void Yaf_Controller_Abstract::getViewpath ( void )
public void Yaf_Controller_Abstract::init ( void )
public void Yaf_Controller_Abstract::initView ([ array $options ] )
public bool Yaf_Controller_Abstract::redirect ( string $url )
protected string Yaf_Controller_Abstract::render ( string $tpl [, array $parameters ] )
public void Yaf_Controller_Abstract::setViewpath ( string $view_directory )
}

Özellikler

_module

_name

_request

_response

_invoke_args

_view

_controller

İçindekiler

  • Yaf_Action_Abstract::execute — Action entry point
  • Yaf_Action_Abstract::getController — Retrieve controller object
Yaf_Controller_Abstract::setViewpath
Yaf_Action_Abstract::execute
Yaf


Action entry point

Yaf_Action_Abstract
Yaf_Action_Abstract::getController
Yaf_Action_Abstract
PHP Manual

Yaf_Action_Abstract::execute

(Yaf >=1.0.0)

Yaf_Action_Abstract::execute — Action entry point

Açıklama

abstract publicmixed Yaf_Action_Abstract::execute ([ mixed $arg [, mixed $... ]] )

user should always define this method for a action, this is the entry point of an action. Yaf_Action_Abstract::execute() may have agruments.

Bilginize:

The value retrived from the request is not safe. you should do some filtering work before you use it.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Örnekler

Örnek 1 Yaf_Action_Abstract::execute()example

<?php
/**
 * A controller example
 */
class ProductController extends Yaf_Controller_Abstract {
      protected $actions = array(
          "index" => "actions/Index.php",
      );
}
?>

Örnek 2 Yaf_Action_Abstract::execute()example

<?php
/**
 * ListAction
 */
class ListAction extends Yaf_Action_Abstract {
     public function execute ($name, $id) {
         assert($name == $this->getRequest()->getParam("name"));
         assert($id   == $this->getRequest()->getParam("id"));
     }
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

/**
 * Now assuming we are using the Yaf_Route_Static route
 * for request: http://yourdomain/product/list/name/yaf/id/22
 * will result:
 */
 bool(true)
 bool(true)

Ayrıca Bakınız

Yaf_Action_Abstract
Yaf_Action_Abstract::getController
Yaf_Action_Abstract


Retrieve controller object

Yaf_Action_Abstract::execute
Yaf_View_Interface
Yaf_Action_Abstract
PHP Manual

Yaf_Action_Abstract::getController

(Yaf >=1.0.0)

Yaf_Action_Abstract::getController — Retrieve controller object

Açıklama

publicYaf_Controller_Abstract Yaf_Action_Abstract::getController ( void )

retrieve current controller object.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Controller_Abstract instance

Yaf_Action_Abstract::execute
Yaf_View_Interface
Yaf_Action_Abstract


The Yaf_View_Interface class

(Yaf >=1.0.0)

Giriş

Yaf provides a ability for developers to use coustom view engine instead of build-in engine which is Yaf_View_Simple. There is a example to explain how to do this, please see Yaf_Dispatcher::setView().

Sınıf Sözdizimi

Yaf_View_Interface {
/* Yöntemler */
abstract public bool assign ( string $name [, string $value ] )
abstract public bool display ( string $tpl [, array $tpl_vars ] )
abstract public void getScriptPath ( void )
abstract public string render ( string $tpl [, array $tpl_vars ] )
abstract public void setScriptPath ( string $template_dir )
}

İçindekiler

  • Yaf_View_Interface::assign — Assign value to View engine
  • Yaf_View_Interface::display — Render and output a template
  • Yaf_View_Interface::getScriptPath — The getScriptPath purpose
  • Yaf_View_Interface::render — Render a template
  • Yaf_View_Interface::setScriptPath — The setScriptPath purpose
Yaf_Action_Abstract::getController
Yaf_View_Interface::assign
Yaf


Assign value to View engine

Yaf_View_Interface
Yaf_View_Interface::display
Yaf_View_Interface
PHP Manual

Yaf_View_Interface::assign

(Yaf >=1.0.0)

Yaf_View_Interface::assign — Assign value to View engine

Açıklama

abstract public bool Yaf_View_Interface::assign ( string $name [, string $value ] )

Assigan values to View engine, then the value can access directly by name in template.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

name

value

Dönen Değerler

Yaf_View_Interface
Yaf_View_Interface::display
Yaf_View_Interface


Render and output a template

Yaf_View_Interface::assign
Yaf_View_Interface::getScriptPath
Yaf_View_Interface
PHP Manual

Yaf_View_Interface::display

(Yaf >=1.0.0)

Yaf_View_Interface::display — Render and output a template

Açıklama

abstract public bool Yaf_View_Interface::display ( string $tpl [, array $tpl_vars ] )

Render a template and output the result immediatly.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

tpl

tpl_vars

Dönen Değerler

Yaf_View_Interface::assign
Yaf_View_Interface::getScriptPath
Yaf_View_Interface


The getScriptPath purpose

Yaf_View_Interface::display
Yaf_View_Interface::render
Yaf_View_Interface
PHP Manual

Yaf_View_Interface::getScriptPath

(Yaf >=1.0.0)

Yaf_View_Interface::getScriptPath — The getScriptPath purpose

Açıklama

abstract public void Yaf_View_Interface::getScriptPath ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_View_Interface::display
Yaf_View_Interface::render
Yaf_View_Interface


Render a template

Yaf_View_Interface::getScriptPath
Yaf_View_Interface::setScriptPath
Yaf_View_Interface
PHP Manual

Yaf_View_Interface::render

(Yaf >=1.0.0)

Yaf_View_Interface::render — Render a template

Açıklama

abstract public string Yaf_View_Interface::render ( string $tpl [, array $tpl_vars ] )

Render a template and return the result.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

tpl

tpl_vars

Dönen Değerler

Yaf_View_Interface::getScriptPath
Yaf_View_Interface::setScriptPath
Yaf_View_Interface


The setScriptPath purpose

Yaf_View_Interface::render
Yaf_View_Simple
Yaf_View_Interface
PHP Manual

Yaf_View_Interface::setScriptPath

(Yaf >=1.0.0)

Yaf_View_Interface::setScriptPath — The setScriptPath purpose

Açıklama

abstract public void Yaf_View_Interface::setScriptPath ( string $template_dir )

Set the templates base directory, this is usually called by Yaf_Dispatcher

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

template_dir

A absolute path to the template directory, by default, Yaf_Dispatcher use application.directory . "/views" as this paramter.

Dönen Değerler

Yaf_View_Interface::render
Yaf_View_Simple
Yaf_View_Interface


The Yaf_View_Simple class

(Yaf >=1.0.0)

Giriş

Yaf_View_Simple is the built-in template engine in Yaf, it is a simple but fast template engine, and only support PHP script template.

Sınıf Sözdizimi

Yaf_View_Simple implements Yaf_View_Interface {
/* Özellikler */
protected $_tpl_vars ;
protected $_tpl_dir ;
/* Yöntemler */
public bool assign ( string $name [, mixed $value ] )
public bool assignRef ( string $name , mixed &$value )
public bool clear ([ string $name ] )
final public __construct ( string $template_dir [, array $options ] )
public bool display ( string $tpl [, array $tpl_vars ] )
public string eval ( string $tpl_content [, array $tpl_vars ] )
public void __get ([ string $name ] )
public string getScriptPath ( void )
public void __isset ( string $name )
public string render ( string $tpl [, array $tpl_vars ] )
public void __set ( string $name , mixed $value )
public bool setScriptPath ( string $template_dir )
}

Özellikler

_tpl_vars

_tpl_dir

İçindekiler

  • Yaf_View_Simple::assign — Assign values
  • Yaf_View_Simple::assignRef — The assignRef purpose
  • Yaf_View_Simple::clear — Clear Assigned values
  • Yaf_View_Simple::__construct — Constructor of Yaf_View_Simple
  • Yaf_View_Simple::display — Render and display
  • Yaf_View_Simple::eval — Render template
  • Yaf_View_Simple::__get — Retrieve assigned variable
  • Yaf_View_Simple::getScriptPath — Get templates directory
  • Yaf_View_Simple::__isset — The __isset purpose
  • Yaf_View_Simple::render — Render template
  • Yaf_View_Simple::__set — Set value to engine
  • Yaf_View_Simple::setScriptPath — Set tempaltes directory
Yaf_View_Interface::setScriptPath
Yaf_View_Simple::assign
Yaf


Assign values

Yaf_View_Simple
Yaf_View_Simple::assignRef
Yaf_View_Simple
PHP Manual

Yaf_View_Simple::assign

(Yaf >=1.0.0)

Yaf_View_Simple::assign — Assign values

Açıklama

public bool Yaf_View_Simple::assign ( string $name [, mixed $value ] )

assign variable to view engine

Değiştirgeler

name

A string or an array.

if is string, then the next argument $value is required.

value

mixed value

Dönen Değerler

Örnekler

Örnek 1 Yaf_View_Simple::assign()example

<?php
class IndexController extends Yaf_Controller_Abstract {
    public function indexAction() {
        $this->getView()->assign("foo", "bar");
        $this->_view->assign( array( "key" => "value", "name" => "value"));
    }
?>

Örnek 2 template()example

<html>
 <head>
  <title><?php echo $foo; ?></title>
 </head>
<body>
  <?php
    foreach ($this->_tpl_vars as $name => value) {
         echo $$name; // or echo $this->_tpl_vars[$name];
    }
  ?>
</body>
</html>

Ayrıca Bakınız

  • Yaf_View_Simple::assignRef() - The assignRef purpose
  • Yaf_View_Interface::clear()
  • Yaf_View_Simple::__set() - Set value to engine
Yaf_View_Simple
Yaf_View_Simple::assignRef
Yaf_View_Simple


The assignRef purpose

Yaf_View_Simple::assign
Yaf_View_Simple::clear
Yaf_View_Simple
PHP Manual

Yaf_View_Simple::assignRef

(Yaf >=1.0.0)

Yaf_View_Simple::assignRef — The assignRef purpose

Açıklama

public bool Yaf_View_Simple::assignRef ( string $name , mixed &$value )

unlike Yaf_View_Simple::assign(), this method assign a ref value to engine.

Değiştirgeler

name

A string name which will be used to access the value in the tempalte.

value

mixed value

Dönen Değerler

Örnekler

Örnek 1 Yaf_View_Simple::assignRef()example

<?php
class IndexController extends Yaf_Controller_Abstract {
    public function indexAction() {
        $value = "bar";
        $this->getView()->assign("foo", $value);

        /* plz note that there was a bug before Yaf 2.1.4,
         * which make following output "bar";
         */
        $dummy = $this->getView()->render("index/index.phtml");
        echo $value;

        //prevent the auto-render
        Yaf_Dispatcher::getInstance()->autoRender(FALSE);
    }
?>

Örnek 2 template()example

<html>
 <head>
  <title><?php echo $foo;  $foo = "changed"; ?></title>
 </head>
<body>
</body>
</html>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

/* access the index controller will result: */
changed

Ayrıca Bakınız

  • Yaf_View_Simple::assign() - Assign values
  • Yaf_View_Simple::__set() - Set value to engine
Yaf_View_Simple::assign
Yaf_View_Simple::clear
Yaf_View_Simple


Clear Assigned values

Yaf_View_Simple::assignRef
Yaf_View_Simple::__construct
Yaf_View_Simple
PHP Manual

Yaf_View_Simple::clear

(Yaf >=2.2.0)

Yaf_View_Simple::clear — Clear Assigned values

Açıklama

public bool Yaf_View_Simple::clear ([ string $name ] )

clear assigned variable

Değiştirgeler

name

assigned variable name

if empty, will clear all assigned variables

Dönen Değerler

Örnekler

Örnek 1 Yaf_View_Simple::clear()example

<?php
class IndexController extends Yaf_Controller_Abstract {
    public function indexAction() {
        $this->getView()->clear("foo")->clear("bar"); // clear "foo" and "bar"
        $this->_view->clear(); //clear all assigned variables
    }
?>

Ayrıca Bakınız

  • Yaf_View_Simple::assignRef() - The assignRef purpose
  • Yaf_View_Interface::assign() - Assign value to View engine
  • Yaf_View_Simple::__set() - Set value to engine
Yaf_View_Simple::assignRef
Yaf_View_Simple::__construct
Yaf_View_Simple


Constructor of Yaf_View_Simple

Yaf_View_Simple::clear
Yaf_View_Simple::display
Yaf_View_Simple
PHP Manual

Yaf_View_Simple::__construct

(Yaf >=1.0.0)

Yaf_View_Simple::__construct — Constructor of Yaf_View_Simple

Açıklama

final public Yaf_View_Simple::__construct ( string $template_dir [, array $options ] )

Değiştirgeler

template_dir

The base directory of the templates, by default, it is APPLICATOIN . "/views" for Yaf.

options

Options for the engine, as of Yaf 2.1.13, you can use short tag
      "<?=$var?>" in your template(regardless of "short_open_tag"),
      so comes a option named "short_tag",  you can switch this off
      to prevent use short_tag in template.

Örnekler

Örnek 1 Yaf_View_Simple::__constructor()example

<?php
   define ("TEMPLATE_DIRECTORY", APPLICATOIN_PATH . '/views');
   $view = new Yaf_View_Simple(TEMPLATE_DIRECTORY, array(
                           'short_tag' => false //doesn't allow use short tag in template
   ));
?>

Dönen Değerler

Yaf_View_Simple::clear
Yaf_View_Simple::display
Yaf_View_Simple


Render and display

Yaf_View_Simple::__construct
Yaf_View_Simple::eval
Yaf_View_Simple
PHP Manual

Yaf_View_Simple::display

(Yaf >=1.0.0)

Yaf_View_Simple::display — Render and display

Açıklama

public bool Yaf_View_Simple::display ( string $tpl [, array $tpl_vars ] )

Render a template and display the result instantly.

Değiştirgeler

tpl

tpl_vars

Dönen Değerler

Yaf_View_Simple::__construct
Yaf_View_Simple::eval
Yaf_View_Simple


Render template

Yaf_View_Simple::display
Yaf_View_Simple::__get
Yaf_View_Simple
PHP Manual

Yaf_View_Simple::eval

(Yaf >=2.2.0)

Yaf_View_Simple::eval — Render template

Açıklama

public string Yaf_View_Simple::eval ( string $tpl_content [, array $tpl_vars ] )

Render a string tempalte and return the result.

Değiştirgeler

tpl_content

string template

tpl_vars

Dönen Değerler

Yaf_View_Simple::display
Yaf_View_Simple::__get
Yaf_View_Simple


Retrieve assigned variable

Yaf_View_Simple::eval
Yaf_View_Simple::getScriptPath
Yaf_View_Simple
PHP Manual

Yaf_View_Simple::__get

(Yaf >=1.0.0)

Yaf_View_Simple::__get — Retrieve assigned variable

Açıklama

public void Yaf_View_Simple::__get ([ string $name ] )

Retrieve assigned varaiable

Bilginize:

parameter can be empty since 2.1.11

Değiştirgeler

name

the assigned variable name

if this is empty, all assigned variables will be returned

Dönen Değerler

Yaf_View_Simple::eval
Yaf_View_Simple::getScriptPath
Yaf_View_Simple


Get templates directory

Yaf_View_Simple::__get
Yaf_View_Simple::__isset
Yaf_View_Simple
PHP Manual

Yaf_View_Simple::getScriptPath

(Yaf >=1.0.0)

Yaf_View_Simple::getScriptPath — Get templates directory

Açıklama

public string Yaf_View_Simple::getScriptPath ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_View_Simple::__get
Yaf_View_Simple::__isset
Yaf_View_Simple


The __isset purpose

Yaf_View_Simple::getScriptPath
Yaf_View_Simple::render
Yaf_View_Simple
PHP Manual

Yaf_View_Simple::__isset

(Yaf >=1.0.0)

Yaf_View_Simple::__isset — The __isset purpose

Açıklama

public void Yaf_View_Simple::__isset ( string $name )

Değiştirgeler

name

Dönen Değerler

Yaf_View_Simple::getScriptPath
Yaf_View_Simple::render
Yaf_View_Simple


Render template

Yaf_View_Simple::__isset
Yaf_View_Simple::__set
Yaf_View_Simple
PHP Manual

Yaf_View_Simple::render

(Yaf >=1.0.0)

Yaf_View_Simple::render — Render template

Açıklama

public string Yaf_View_Simple::render ( string $tpl [, array $tpl_vars ] )

Render a template and return the result.

Değiştirgeler

tpl

tpl_vars

Dönen Değerler

Yaf_View_Simple::__isset
Yaf_View_Simple::__set
Yaf_View_Simple


Set value to engine

Yaf_View_Simple::render
Yaf_View_Simple::setScriptPath
Yaf_View_Simple
PHP Manual

Yaf_View_Simple::__set

(Yaf >=1.0.0)

Yaf_View_Simple::__set — Set value to engine

Açıklama

public void Yaf_View_Simple::__set ( string $name , mixed $value )

This is a alternative and easier way to Yaf_View_Simple::assign().

Değiştirgeler

name

A string value name.

value

Mixed value.

Dönen Değerler

Örnekler

Örnek 1 Yaf_View_Simple::__set()example

<?php
class IndexController extends Yaf_Controller_Abstract {
    public function indexAction() {
        $this->getView()->foo = "bar"; // same as assign("foo", "bar");
    }
?>

Ayrıca Bakınız

  • Yaf_View_Simple::assignRef() - The assignRef purpose
  • Yaf_View_Interface::assign() - Assign value to View engine
Yaf_View_Simple::render
Yaf_View_Simple::setScriptPath
Yaf_View_Simple


Set tempaltes directory

Yaf_View_Simple::__set
Yaf_Loader
Yaf_View_Simple
PHP Manual

Yaf_View_Simple::setScriptPath

(Yaf >=1.0.0)

Yaf_View_Simple::setScriptPath — Set tempaltes directory

Açıklama

public bool Yaf_View_Simple::setScriptPath ( string $template_dir )

Değiştirgeler

template_dir

Dönen Değerler

Yaf_View_Simple::__set
Yaf_Loader
Yaf_View_Simple


The Yaf_Loader class

(Yaf >=1.0.0)

Giriş

Yaf_Loader introduces a comprehensive autoloading solution for Yaf.

The first time an instance of Yaf_Application is retrieved, Yaf_Loader will instance a singleton, and registers itself with spl_autoload. You retrieve an instance using the Yaf_Loader::getInstance()

Yaf_Loader attempt to load a class only one shot, if failed, depend on yaf.use_spl_auload, if this config is On Yaf_Loader::autoload() will return FALSE, thus give the chance to other autoload function. if it is Off (by default), Yaf_Loader::autoload() will return TRUE, and more important is that a very usefull warning will be triggerd (very usefull to find out why a class could not be loaded).

Bilginize:

Please keep yaf.use_spl_autoload Off unless there is some library have their own autoload mechanism and impossible to rewrite it.

By default, Yaf_Loader assume all library (class defined script) store in the global library directory, which is defined in the php.ini(yaf.library).

If you want Yaf_Loader search some classes(libraries) in the local class directory(which is defined in application.ini, and by default, it is application.directory . "/library"), you should register the class prefix using the Yaf_Loader::registerLocalNameSpace()

Let's see some examples(assuming APPLICATION_PATH is application.directory):

Örnek 1 Config example

// Assuming the following configure in php.ini:
yaf.library = "/global_dir"

//Assuming the following configure in application.ini
application.library = APPLICATION_PATH "/library"
Assuming the following local name space registerd:

Örnek 2 Register localnamespace

<?php
class Bootstrap extends Yaf_Bootstrap_Abstract{
     public function _initLoader($dispatcher) {
          Yaf_Loader::getInstance()->registerLocalNameSpace(array("Foo", "Bar"));
     }
?>
Then the autoload examples:

Örnek 3 Load class example

class Foo_Bar_Test =>
  // APPLICATION_PATH/library/Foo/Bar/Test.php

class GLO_Name  =>
  // /global_dir/Glo/Name.php

class BarNon_Test
  // /global_dir/Barnon/Test.php
As of PHP 5.3, you can use namespace:

Örnek 4 Load namespace class example

class \Foo\Bar\Dummy =>
   // APPLICATION_PATH/library/Foo/Bar/Dummy.php

class \FooBar\Bar\Dummy =>
   // /global_dir/FooBar/Bar/Dummy.php

You may noticed that all the folder wth the first letter capitalized, you can make them lowercase by set yaf.lowcase_path = On in php.ini

Yaf_Loader is also designed to load the MVC classes, and the rule is:

Örnek 5 MVC class loading example

Controller Classes =>
// APPLICATION_PATH/controllers/

Model Classes =>
// APPLICATION_PATH/models/

Plugin Classes =>
// APPLICATION_PATH/plugins/
Yaf identify a class's suffix(this is by default, you can also change to the prefix by change the configure yaf.name_suffix) to decide whether it is a MVC class:

Örnek 6 MVC class distinctions

Controller Classes =>
    // ***Controller

Model Classes =>
    // ***Model

Plugin Classes =>
    // ***Plugin
some examples:

Örnek 7 MVC loading example

class IndexController
    // APPLICATION_PATH/controllers/Index.php

class DataModel =>
   // APPLICATION_PATH/models/Data.php

class DummyPlugin =>
  // APPLICATION_PATH/plugins/Dummy.php

class A_B_TestModel =>
  // APPLICATION_PATH/models/A/B/Test.php

Bilginize:

As of 2.1.18, Yaf supports Controllers autoloading for user script side, (which means the autoloading triggered by user php script, eg: access a controller static property in Bootstrap or Plugins), but autoloader only try to locate controller class script under the default module folder, which is "APPLICATION_PATH/controllers/".

also, the directory will be affected by yaf.lowcase_path.

Sınıf Sözdizimi

Yaf_Loader {
/* Özellikler */
protected $_local_ns ;
protected $_library ;
protected $_global_library ;
static $_instance ;
/* Yöntemler */
public void autoload ( void )
public void clearLocalNamespace ( void )
private void __clone ( void )
private __construct ( void )
public static void getInstance ( void )
public Yaf_Loader getLibraryPath ([ bool $is_global = false ] )
public void getLocalNamespace ( void )
public static void import ( void )
public void isLocalName ( void )
public void registerLocalNamespace ( mixed $prefix )
public Yaf_Loader setLibraryPath ( string $directory [, bool $is_global = false ] )
private void __sleep ( void )
private void __wakeup ( void )
}

Özellikler

_local_ns

_library

By default, this value is application.directory . "/library", you can change this either in the application.ini(application.library) or call to Yaf_Loader::setLibraryPath()

_global_library

_instance

İçindekiler

  • Yaf_Loader::autoload — The autoload purpose
  • Yaf_Loader::clearLocalNamespace — The clearLocalNamespace purpose
  • Yaf_Loader::__clone — The __clone purpose
  • Yaf_Loader::__construct — The __construct purpose
  • Yaf_Loader::getInstance — The getInstance purpose
  • Yaf_Loader::getLibraryPath — get the library path
  • Yaf_Loader::getLocalNamespace — The getLocalNamespace purpose
  • Yaf_Loader::import — The import purpose
  • Yaf_Loader::isLocalName — The isLocalName purpose
  • Yaf_Loader::registerLocalNamespace — register local class prefix
  • Yaf_Loader::setLibraryPath — Change the library path
  • Yaf_Loader::__sleep — The __sleep purpose
  • Yaf_Loader::__wakeup — The __wakeup purpose
Yaf_View_Simple::setScriptPath
Yaf_Loader::autoload
Yaf


The autoload purpose

Yaf_Loader
Yaf_Loader::clearLocalNamespace
Yaf_Loader
PHP Manual

Yaf_Loader::autoload

(Yaf >=1.0.0)

Yaf_Loader::autoload — The autoload purpose

Açıklama

public void Yaf_Loader::autoload ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Loader
Yaf_Loader::clearLocalNamespace
Yaf_Loader


The clearLocalNamespace purpose

Yaf_Loader::autoload
Yaf_Loader::__clone
Yaf_Loader
PHP Manual

Yaf_Loader::clearLocalNamespace

(Yaf >=1.0.0)

Yaf_Loader::clearLocalNamespace — The clearLocalNamespace purpose

Açıklama

public void Yaf_Loader::clearLocalNamespace ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Loader::autoload
Yaf_Loader::__clone
Yaf_Loader


The __clone purpose

Yaf_Loader::clearLocalNamespace
Yaf_Loader::__construct
Yaf_Loader
PHP Manual

Yaf_Loader::__clone

(Yaf >=1.0.0)

Yaf_Loader::__clone — The __clone purpose

Açıklama

private void Yaf_Loader::__clone ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Loader::clearLocalNamespace
Yaf_Loader::__construct
Yaf_Loader


The __construct purpose

Yaf_Loader::__clone
Yaf_Loader::getInstance
Yaf_Loader
PHP Manual

Yaf_Loader::__construct

(Yaf >=1.0.0)

Yaf_Loader::__construct — The __construct purpose

Açıklama

private Yaf_Loader::__construct ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Loader::__clone
Yaf_Loader::getInstance
Yaf_Loader


The getInstance purpose

Yaf_Loader::__construct
Yaf_Loader::getLibraryPath
Yaf_Loader
PHP Manual

Yaf_Loader::getInstance

(Yaf >=1.0.0)

Yaf_Loader::getInstance — The getInstance purpose

Açıklama

public static void Yaf_Loader::getInstance ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Loader::__construct
Yaf_Loader::getLibraryPath
Yaf_Loader


get the library path

Yaf_Loader::getInstance
Yaf_Loader::getLocalNamespace
Yaf_Loader
PHP Manual

Yaf_Loader::getLibraryPath

(Yaf >=2.1.4)

Yaf_Loader::getLibraryPath — get the library path

Açıklama

public Yaf_Loader Yaf_Loader::getLibraryPath ([ bool $is_global = false ] )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Loader::getInstance
Yaf_Loader::getLocalNamespace
Yaf_Loader


The getLocalNamespace purpose

Yaf_Loader::getLibraryPath
Yaf_Loader::import
Yaf_Loader
PHP Manual

Yaf_Loader::getLocalNamespace

(Yaf >=1.0.0)

Yaf_Loader::getLocalNamespace — The getLocalNamespace purpose

Açıklama

public void Yaf_Loader::getLocalNamespace ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Loader::getLibraryPath
Yaf_Loader::import
Yaf_Loader


The import purpose

Yaf_Loader::getLocalNamespace
Yaf_Loader::isLocalName
Yaf_Loader
PHP Manual

Yaf_Loader::import

(Yaf >=1.0.0)

Yaf_Loader::import — The import purpose

Açıklama

public static void Yaf_Loader::import ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Loader::getLocalNamespace
Yaf_Loader::isLocalName
Yaf_Loader


The isLocalName purpose

Yaf_Loader::import
Yaf_Loader::registerLocalNamespace
Yaf_Loader
PHP Manual

Yaf_Loader::isLocalName

(Yaf >=1.0.0)

Yaf_Loader::isLocalName — The isLocalName purpose

Açıklama

public void Yaf_Loader::isLocalName ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Loader::import
Yaf_Loader::registerLocalNamespace
Yaf_Loader


register local class prefix

Yaf_Loader::isLocalName
Yaf_Loader::setLibraryPath
Yaf_Loader
PHP Manual

Yaf_Loader::registerLocalNamespace

(Yaf >=1.0.0)

Yaf_Loader::registerLocalNamespace — register local class prefix

Açıklama

public void Yaf_Loader::registerLocalNamespace ( mixed $prefix )

Register local class prefix name, Yaf_Loader search classes in two library directories, the one is configured via application.library.directory(in application.ini) which is called local libraray directory; the other is configured via yaf.library (in php.ini) which is callled global library directory, since it can be shared by many applications in the same server.

When an autloading is trigger, Yaf_Loader will determine which library directory should be searched in by exame the prefix name of the missed classname. If the prefix name is registered as a localnamespack then look for it in local library directory, otherwise look for it in global library directory.

Bilginize:

If yaf.library is not configured, then the global library directory is assumed to be the local library directory. in that case, all autoloading will look for local library directory. But if you want your Yaf application be strong, then always register your own classes as local classes.

Değiştirgeler

prefix

a string or a array of class name prefix. all class prefix with these prefix will be loaded in local library path.

Dönen Değerler

bool

Örnekler

Örnek 1 Yaf_Loader::registerLocalNamespace()example

<?php
$loader = Yaf_Loader::getInstance('/local/library/', '/global/library');
$loader->registerLocalNamespace("Baidu");
$loader->registerLocalNamespace(array("Sina", "Weibo"));

$loader->autoload("Baidu_Name"); // search in '/local/library/'
$loader->autoload("Sina");       // search '/local/library/'
$loader->autoload("Global_Name");// search in '/global/library/'
$loader->autoload("Foo_Bar");    // search in '/global/library/'

?>
Yaf_Loader::isLocalName
Yaf_Loader::setLibraryPath
Yaf_Loader


Change the library path

Yaf_Loader::registerLocalNamespace
Yaf_Loader::__sleep
Yaf_Loader
PHP Manual

Yaf_Loader::setLibraryPath

(Yaf >=2.1.4)

Yaf_Loader::setLibraryPath — Change the library path

Açıklama

public Yaf_Loader Yaf_Loader::setLibraryPath ( string $directory [, bool $is_global = false ] )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Loader::registerLocalNamespace
Yaf_Loader::__sleep
Yaf_Loader


The __sleep purpose

Yaf_Loader::setLibraryPath
Yaf_Loader::__wakeup
Yaf_Loader
PHP Manual

Yaf_Loader::__sleep

(Yaf >=1.0.0)

Yaf_Loader::__sleep — The __sleep purpose

Açıklama

private void Yaf_Loader::__sleep ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Loader::setLibraryPath
Yaf_Loader::__wakeup
Yaf_Loader


The __wakeup purpose

Yaf_Loader::__sleep
Yaf_Plugin_Abstract
Yaf_Loader
PHP Manual

Yaf_Loader::__wakeup

(Yaf >=1.0.0)

Yaf_Loader::__wakeup — The __wakeup purpose

Açıklama

private void Yaf_Loader::__wakeup ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Loader::__sleep
Yaf_Plugin_Abstract
Yaf_Loader


The Yaf_Plugin_Abstract class

(Yaf >=1.0.0)

Giriş

Plugins allow for easy extensibility and customization of the framework.

Plugins are classes. The actual class definition will vary based on the component -- you may need to implement this interface, but the fact remains that the plugin is itself a class.

A plugin could be loaded into Yaf by using Yaf_Dispatcher::registerPlugin(), after registerd, All the methods which the plugin implemented according to this interface, will be called at the proper time.

Örnekler

Örnek 1 Plugin example

<?php
   /* bootstrap class should be defined under ./application/Bootstrap.php */
   class Bootstrap extends Yaf_Bootstrap_Abstract {
        public function _initPlugin(Yaf_Dispatcher $dispatcher) {
            /* register a plugin */
            $dispatcher->registerPlugin(new TestPlugin());
        }
   }

   /* plugin class should be placed under ./application/plugins/ */
   class TestPlugin extends Yaf_Plugin_Abstract {
        public function routerStartup(Yaf_Request_Abstract $request, Yaf_Response_Abstract $response) {
            /* before router
               in this hook,  user can do some url rewrite */
            var_dump("routerStartup");
        }
        public function routerShutdown(Yaf_Request_Abstract $request, Yaf_Response_Abstract $response) {
            /* router complete
               in this hook, user can do login check */
            var_dump("routerShutdown");
        }
        public function dispatchLoopStartup(Yaf_Request_Abstract $request, Yaf_Response_Abstract $response) {
            var_dump("dispatchLoopStartup");
        }
        public function preDispatch(Yaf_Request_Abstract $request, Yaf_Response_Abstract $response) {
            var_dump("preDispatch");
        }
        public function postDispatch(Yaf_Request_Abstract $request, Yaf_Response_Abstract $response) {
            var_dump("postDispatch");
        }
        public function dispatchLoopShutdown(Yaf_Request_Abstract $request, Yaf_Response_Abstract $response) {
            /* final hoook
               in this hook user can do loging or implement layout */
            var_dump("dispatchLoopShutdown");
        }
   }

   Class IndexController extends Yaf_Controller_Abstract {
        public function indexAction() {
            return FALSE; //prevent rendering
        }
   }

   $config = array(
       "application" => array(
           "directory" => dirname(__FILE__) . "/application/",
       ),
   );

   $app = new Yaf_Application($config);
   $app->bootstrap()->run();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(13) "routerStartup"
string(14) "routerShutdown"
string(19) "dispatchLoopStartup"
string(11) "preDispatch"
string(12) "postDispatch"
string(20) "dispatchLoopShutdown"

Sınıf Sözdizimi

Yaf_Plugin_Abstract {
/* Yöntemler */
public void dispatchLoopShutdown ( Yaf_Request_Abstract $request , Yaf_Response_Abstract $response )
public void dispatchLoopStartup ( Yaf_Request_Abstract $request , Yaf_Response_Abstract $response )
public void postDispatch ( Yaf_Request_Abstract $request , Yaf_Response_Abstract $response )
public void preDispatch ( Yaf_Request_Abstract $request , Yaf_Response_Abstract $response )
public void preResponse ( Yaf_Request_Abstract $request , Yaf_Response_Abstract $response )
public void routerShutdown ( Yaf_Request_Abstract $request , Yaf_Response_Abstract $response )
public void routerStartup ( Yaf_Request_Abstract $request , Yaf_Response_Abstract $response )
}

İçindekiler

  • Yaf_Plugin_Abstract::dispatchLoopShutdown — The dispatchLoopShutdown purpose
  • Yaf_Plugin_Abstract::dispatchLoopStartup — The dispatchLoopStartup purpose
  • Yaf_Plugin_Abstract::postDispatch — The postDispatch purpose
  • Yaf_Plugin_Abstract::preDispatch — The preDispatch purpose
  • Yaf_Plugin_Abstract::preResponse — The preResponse purpose
  • Yaf_Plugin_Abstract::routerShutdown — The routerShutdown purpose
  • Yaf_Plugin_Abstract::routerStartup — RouterStartup hook
Yaf_Loader::__wakeup
Yaf_Plugin_Abstract::dispatchLoopShutdown
Yaf


The dispatchLoopShutdown purpose

Yaf_Plugin_Abstract
Yaf_Plugin_Abstract::dispatchLoopStartup
Yaf_Plugin_Abstract
PHP Manual

Yaf_Plugin_Abstract::dispatchLoopShutdown

(Yaf >=1.0.0)

Yaf_Plugin_Abstract::dispatchLoopShutdown — The dispatchLoopShutdown purpose

Açıklama

public void Yaf_Plugin_Abstract::dispatchLoopShutdown ( Yaf_Request_Abstract $request , Yaf_Response_Abstract $response )

This is the latest hook in Yaf plugin hook system, if a custom plugin implement this method, then it will be called after the dispatch loop finished.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

request

response

Dönen Değerler

Ayrıca Bakınız

  • Yaf_Plugin_Abstract::routerStartup() - RouterStartup hook
  • Yaf_Plugin_Abstract::routerShutdown() - The routerShutdown purpose
  • Yaf_Plugin_Abstract::dispatchLoopStartup() - The dispatchLoopStartup purpose
  • Yaf_Plugin_Abstract::preDispatch() - The preDispatch purpose
  • Yaf_Plugin_Abstract::postDispatch() - The postDispatch purpose
Yaf_Plugin_Abstract
Yaf_Plugin_Abstract::dispatchLoopStartup
Yaf_Plugin_Abstract


The dispatchLoopStartup purpose

Yaf_Plugin_Abstract::dispatchLoopShutdown
Yaf_Plugin_Abstract::postDispatch
Yaf_Plugin_Abstract
PHP Manual

Yaf_Plugin_Abstract::dispatchLoopStartup

(Yaf >=1.0.0)

Yaf_Plugin_Abstract::dispatchLoopStartup — The dispatchLoopStartup purpose

Açıklama

public void Yaf_Plugin_Abstract::dispatchLoopStartup ( Yaf_Request_Abstract $request , Yaf_Response_Abstract $response )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

request

response

Dönen Değerler

Yaf_Plugin_Abstract::dispatchLoopShutdown
Yaf_Plugin_Abstract::postDispatch
Yaf_Plugin_Abstract


The postDispatch purpose

Yaf_Plugin_Abstract::dispatchLoopStartup
Yaf_Plugin_Abstract::preDispatch
Yaf_Plugin_Abstract
PHP Manual

Yaf_Plugin_Abstract::postDispatch

(Yaf >=1.0.0)

Yaf_Plugin_Abstract::postDispatch — The postDispatch purpose

Açıklama

public void Yaf_Plugin_Abstract::postDispatch ( Yaf_Request_Abstract $request , Yaf_Response_Abstract $response )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

request

response

Dönen Değerler

Yaf_Plugin_Abstract::dispatchLoopStartup
Yaf_Plugin_Abstract::preDispatch
Yaf_Plugin_Abstract


The preDispatch purpose

Yaf_Plugin_Abstract::postDispatch
Yaf_Plugin_Abstract::preResponse
Yaf_Plugin_Abstract
PHP Manual

Yaf_Plugin_Abstract::preDispatch

(Yaf >=1.0.0)

Yaf_Plugin_Abstract::preDispatch — The preDispatch purpose

Açıklama

public void Yaf_Plugin_Abstract::preDispatch ( Yaf_Request_Abstract $request , Yaf_Response_Abstract $response )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

request

response

Dönen Değerler

Yaf_Plugin_Abstract::postDispatch
Yaf_Plugin_Abstract::preResponse
Yaf_Plugin_Abstract


The preResponse purpose

Yaf_Plugin_Abstract::preDispatch
Yaf_Plugin_Abstract::routerShutdown
Yaf_Plugin_Abstract
PHP Manual

Yaf_Plugin_Abstract::preResponse

(Yaf >=1.0.0)

Yaf_Plugin_Abstract::preResponse — The preResponse purpose

Açıklama

public void Yaf_Plugin_Abstract::preResponse ( Yaf_Request_Abstract $request , Yaf_Response_Abstract $response )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

request

response

Dönen Değerler

Yaf_Plugin_Abstract::preDispatch
Yaf_Plugin_Abstract::routerShutdown
Yaf_Plugin_Abstract


The routerShutdown purpose

Yaf_Plugin_Abstract::preResponse
Yaf_Plugin_Abstract::routerStartup
Yaf_Plugin_Abstract
PHP Manual

Yaf_Plugin_Abstract::routerShutdown

(Yaf >=1.0.0)

Yaf_Plugin_Abstract::routerShutdown — The routerShutdown purpose

Açıklama

public void Yaf_Plugin_Abstract::routerShutdown ( Yaf_Request_Abstract $request , Yaf_Response_Abstract $response )

This hook will be trigged after the route process finished, this hook is usually used for login check.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

request

response

Dönen Değerler

Örnekler

Örnek 1 Yaf_Plugin_Abstract::routerShutdown()example

<?php
class UserInitPlugin extends Yaf_Plugin_Abstract {

    public function routerShutdown(Yaf_Request_Abstract $request, Yaf_Response_Abstract $response) {
        $controller = $request->getControllerName();

        /**
         * Use access controller is unecessary for APIs
         */
        if (in_array(strtolower($controller), array(
            'api',
        ))) {
            return TRUE;
        }

        if (Yaf_Session::getInstance()->has("login")) {
            return TRUE;
        }

        /* Use access check failed, need to login */
        $response->redirect("http://yourdomain.com/login/");
        return FALSE;
    }
?>

Ayrıca Bakınız

  • Yaf_Plugin_Abstract::routerStartup() - RouterStartup hook
  • Yaf_Plugin_Abstract::dispatchLoopStartup() - The dispatchLoopStartup purpose
  • Yaf_Plugin_Abstract::preDispatch() - The preDispatch purpose
  • Yaf_Plugin_Abstract::postDispatch() - The postDispatch purpose
  • Yaf_Plugin_Abstract::dispatchLoopShutdown() - The dispatchLoopShutdown purpose
Yaf_Plugin_Abstract::preResponse
Yaf_Plugin_Abstract::routerStartup
Yaf_Plugin_Abstract


RouterStartup hook

Yaf_Plugin_Abstract::routerShutdown
Yaf_Registry
Yaf_Plugin_Abstract
PHP Manual

Yaf_Plugin_Abstract::routerStartup

(Yaf >=1.0.0)

Yaf_Plugin_Abstract::routerStartup — RouterStartup hook

Açıklama

public void Yaf_Plugin_Abstract::routerStartup ( Yaf_Request_Abstract $request , Yaf_Response_Abstract $response )

This is the earliest hook in Yaf plugin hook system, if a custom plugin implement this method, then it will be called before routing a request.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

request

response

Dönen Değerler

Ayrıca Bakınız

  • Yaf_Plugin_Abstract::routerShutdown() - The routerShutdown purpose
  • Yaf_Plugin_Abstract::dispatchLoopStartup() - The dispatchLoopStartup purpose
  • Yaf_Plugin_Abstract::preDispatch() - The preDispatch purpose
  • Yaf_Plugin_Abstract::postDispatch() - The postDispatch purpose
  • Yaf_Plugin_Abstract::dispatchLoopShutdown() - The dispatchLoopShutdown purpose
Yaf_Plugin_Abstract::routerShutdown
Yaf_Registry
Yaf_Plugin_Abstract


The Yaf_Registry class

(Yaf >=1.0.0)

Giriş

All methods of Yaf_Registry declared as static, making it unversally accessible. This provides the ability to get or set any custom data from anyway in your code as necessary.

Sınıf Sözdizimi

Yaf_Registry {
/* Özellikler */
static $_instance ;
protected $_entries ;
/* Yöntemler */
private void __clone ( void )
private __construct ( void )
public static void del ( string $name )
public static mixed get ( string $name )
public static bool has ( string $name )
public static bool set ( string $name , string $value )
}

Özellikler

_instance

_entries

İçindekiler

  • Yaf_Registry::__clone — The __clone purpose
  • Yaf_Registry::__construct — Yaf_Registry implements singleton
  • Yaf_Registry::del — Remove an item from registry
  • Yaf_Registry::get — Retrieve an item from registry
  • Yaf_Registry::has — Check whether an item exists
  • Yaf_Registry::set — Add an item into registry
Yaf_Plugin_Abstract::routerStartup
Yaf_Registry::__clone
Yaf


The __clone purpose

Yaf_Registry
Yaf_Registry::__construct
Yaf_Registry
PHP Manual

Yaf_Registry::__clone

(Yaf >=1.0.0)

Yaf_Registry::__clone — The __clone purpose

Açıklama

private void Yaf_Registry::__clone ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Registry
Yaf_Registry::__construct
Yaf_Registry


Yaf_Registry implements singleton

Yaf_Registry::__clone
Yaf_Registry::del
Yaf_Registry
PHP Manual

Yaf_Registry::__construct

(Yaf >=1.0.0)

Yaf_Registry::__construct — Yaf_Registry implements singleton

Açıklama

private Yaf_Registry::__construct ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Registry::__clone
Yaf_Registry::del
Yaf_Registry


Remove an item from registry

Yaf_Registry::__construct
Yaf_Registry::get
Yaf_Registry
PHP Manual

Yaf_Registry::del

(Yaf >=1.0.0)

Yaf_Registry::del — Remove an item from registry

Açıklama

public static void Yaf_Registry::del ( string $name )

Remove an item from registry

Değiştirgeler

name

Dönen Değerler

Yaf_Registry::__construct
Yaf_Registry::get
Yaf_Registry


Retrieve an item from registry

Yaf_Registry::del
Yaf_Registry::has
Yaf_Registry
PHP Manual

Yaf_Registry::get

(Yaf >=1.0.0)

Yaf_Registry::get — Retrieve an item from registry

Açıklama

public static mixed Yaf_Registry::get ( string $name )

Retrieve an item from registry

Değiştirgeler

name

Dönen Değerler

Yaf_Registry::del
Yaf_Registry::has
Yaf_Registry


Check whether an item exists

Yaf_Registry::get
Yaf_Registry::set
Yaf_Registry
PHP Manual

Yaf_Registry::has

(Yaf >=1.0.0)

Yaf_Registry::has — Check whether an item exists

Açıklama

public static bool Yaf_Registry::has ( string $name )

Check whether an item exists

Değiştirgeler

name

Dönen Değerler

Yaf_Registry::get
Yaf_Registry::set
Yaf_Registry


Add an item into registry

Yaf_Registry::has
Yaf_Request_Abstract
Yaf_Registry
PHP Manual

Yaf_Registry::set

(Yaf >=1.0.0)

Yaf_Registry::set — Add an item into registry

Açıklama

public static bool Yaf_Registry::set ( string $name , string $value )

Add an item into registry

Değiştirgeler

name

value

Dönen Değerler

Yaf_Registry::has
Yaf_Request_Abstract
Yaf_Registry


The Yaf_Request_Abstract class

(Yaf >=1.0.0)

Giriş

Sınıf Sözdizimi

Yaf_Request_Abstract {
/* Constants */
const string SCHEME_HTTP = http ;
const string SCHEME_HTTPS = https ;
/* Özellikler */
public $module ;
public $controller ;
public $action ;
public $method ;
protected $params ;
protected $language ;
protected $_exception ;
protected $_base_uri ;
protected $uri ;
protected $dispatched ;
protected $routed ;
/* Yöntemler */
public void getActionName ( void )
public void getBaseUri ( void )
public void getControllerName ( void )
public void getEnv ( string $name [, string $default ] )
public void getException ( void )
public void getLanguage ( void )
public void getMethod ( void )
public void getModuleName ( void )
public void getParam ( string $name [, string $default ] )
public void getParams ( void )
public void getRequestUri ( void )
public void getServer ( string $name [, string $default ] )
public void isCli ( void )
public void isDispatched ( void )
public void isGet ( void )
public void isHead ( void )
public void isOptions ( void )
public void isPost ( void )
public void isPut ( void )
public void isRouted ( void )
public void isXmlHttpRequest ( void )
public void setActionName ( string $action )
public bool setBaseUri ( string $uir )
public void setControllerName ( string $controller )
public void setDispatched ( void )
public void setModuleName ( string $module )
public void setParam ( string $name [, string $value ] )
public void setRequestUri ( string $uir )
public void setRouted ([ string $flag ] )
}

Özellikler

module

controller

action

method

params

language

_exception

_base_uri

uri

dispatched

routed

Öntanımlı Sabitler

Yaf_Request_Abstract::SCHEME_HTTP

Yaf_Request_Abstract::SCHEME_HTTPS

İçindekiler

  • Yaf_Request_Abstract::getActionName — The getActionName purpose
  • Yaf_Request_Abstract::getBaseUri — The getBaseUri purpose
  • Yaf_Request_Abstract::getControllerName — The getControllerName purpose
  • Yaf_Request_Abstract::getEnv — Retrieve ENV varialbe
  • Yaf_Request_Abstract::getException — The getException purpose
  • Yaf_Request_Abstract::getLanguage — The getLanguage purpose
  • Yaf_Request_Abstract::getMethod — The getMethod purpose
  • Yaf_Request_Abstract::getModuleName — The getModuleName purpose
  • Yaf_Request_Abstract::getParam — The getParam purpose
  • Yaf_Request_Abstract::getParams — The getParams purpose
  • Yaf_Request_Abstract::getRequestUri — The getRequestUri purpose
  • Yaf_Request_Abstract::getServer — Retrieve SERVER variable
  • Yaf_Request_Abstract::isCli — The isCli purpose
  • Yaf_Request_Abstract::isDispatched — The isDispatched purpose
  • Yaf_Request_Abstract::isGet — The isGet purpose
  • Yaf_Request_Abstract::isHead — The isHead purpose
  • Yaf_Request_Abstract::isOptions — The isOptions purpose
  • Yaf_Request_Abstract::isPost — The isPost purpose
  • Yaf_Request_Abstract::isPut — The isPut purpose
  • Yaf_Request_Abstract::isRouted — The isRouted purpose
  • Yaf_Request_Abstract::isXmlHttpRequest — The isXmlHttpRequest purpose
  • Yaf_Request_Abstract::setActionName — The setActionName purpose
  • Yaf_Request_Abstract::setBaseUri — set base URI
  • Yaf_Request_Abstract::setControllerName — The setControllerName purpose
  • Yaf_Request_Abstract::setDispatched — The setDispatched purpose
  • Yaf_Request_Abstract::setModuleName — The setModuleName purpose
  • Yaf_Request_Abstract::setParam — The setParam purpose
  • Yaf_Request_Abstract::setRequestUri — The setRequestUri purpose
  • Yaf_Request_Abstract::setRouted — The setRouted purpose
Yaf_Registry::set
Yaf_Request_Abstract::getActionName
Yaf


The getActionName purpose

Yaf_Request_Abstract
Yaf_Request_Abstract::getBaseUri
Yaf_Request_Abstract
PHP Manual

Yaf_Request_Abstract::getActionName

(Yaf >=1.0.0)

Yaf_Request_Abstract::getActionName — The getActionName purpose

Açıklama

public void Yaf_Request_Abstract::getActionName ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Request_Abstract
Yaf_Request_Abstract::getBaseUri
Yaf_Request_Abstract


The getBaseUri purpose

Yaf_Request_Abstract::getActionName
Yaf_Request_Abstract::getControllerName
Yaf_Request_Abstract
PHP Manual

Yaf_Request_Abstract::getBaseUri

(Yaf >=1.0.0)

Yaf_Request_Abstract::getBaseUri — The getBaseUri purpose

Açıklama

public void Yaf_Request_Abstract::getBaseUri ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Request_Abstract::getActionName
Yaf_Request_Abstract::getControllerName
Yaf_Request_Abstract


The getControllerName purpose

Yaf_Request_Abstract::getBaseUri
Yaf_Request_Abstract::getEnv
Yaf_Request_Abstract
PHP Manual

Yaf_Request_Abstract::getControllerName

(Yaf >=1.0.0)

Yaf_Request_Abstract::getControllerName — The getControllerName purpose

Açıklama

public void Yaf_Request_Abstract::getControllerName ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Request_Abstract::getBaseUri
Yaf_Request_Abstract::getEnv
Yaf_Request_Abstract


Retrieve ENV varialbe

Yaf_Request_Abstract::getControllerName
Yaf_Request_Abstract::getException
Yaf_Request_Abstract
PHP Manual

Yaf_Request_Abstract::getEnv

(Yaf >=1.0.0)

Yaf_Request_Abstract::getEnv — Retrieve ENV varialbe

Açıklama

public void Yaf_Request_Abstract::getEnv ( string $name [, string $default ] )

Retrieve ENV variable

Değiştirgeler

name

the variable name

default

if this parameter is provide, this will be returned if the varialbe can not be found

Dönen Değerler

Ayrıca Bakınız

  • Yaf_Request_Abstract::getServer
  • Yaf_Request_Abstract::getParam
Yaf_Request_Abstract::getControllerName
Yaf_Request_Abstract::getException
Yaf_Request_Abstract


The getException purpose

Yaf_Request_Abstract::getEnv
Yaf_Request_Abstract::getLanguage
Yaf_Request_Abstract
PHP Manual

Yaf_Request_Abstract::getException

(Yaf >=1.0.0)

Yaf_Request_Abstract::getException — The getException purpose

Açıklama

public void Yaf_Request_Abstract::getException ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Request_Abstract::getEnv
Yaf_Request_Abstract::getLanguage
Yaf_Request_Abstract


The getLanguage purpose

Yaf_Request_Abstract::getException
Yaf_Request_Abstract::getMethod
Yaf_Request_Abstract
PHP Manual

Yaf_Request_Abstract::getLanguage

(Yaf >=1.0.0)

Yaf_Request_Abstract::getLanguage — The getLanguage purpose

Açıklama

public void Yaf_Request_Abstract::getLanguage ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Request_Abstract::getException
Yaf_Request_Abstract::getMethod
Yaf_Request_Abstract


The getMethod purpose

Yaf_Request_Abstract::getLanguage
Yaf_Request_Abstract::getModuleName
Yaf_Request_Abstract
PHP Manual

Yaf_Request_Abstract::getMethod

(Yaf >=1.0.0)

Yaf_Request_Abstract::getMethod — The getMethod purpose

Açıklama

public void Yaf_Request_Abstract::getMethod ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Request_Abstract::getLanguage
Yaf_Request_Abstract::getModuleName
Yaf_Request_Abstract


The getModuleName purpose

Yaf_Request_Abstract::getMethod
Yaf_Request_Abstract::getParam
Yaf_Request_Abstract
PHP Manual

Yaf_Request_Abstract::getModuleName

(Yaf >=1.0.0)

Yaf_Request_Abstract::getModuleName — The getModuleName purpose

Açıklama

public void Yaf_Request_Abstract::getModuleName ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Request_Abstract::getMethod
Yaf_Request_Abstract::getParam
Yaf_Request_Abstract


The getParam purpose

Yaf_Request_Abstract::getModuleName
Yaf_Request_Abstract::getParams
Yaf_Request_Abstract
PHP Manual

Yaf_Request_Abstract::getParam

(Yaf >=1.0.0)

Yaf_Request_Abstract::getParam — The getParam purpose

Açıklama

public void Yaf_Request_Abstract::getParam ( string $name [, string $default ] )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

name

default

Dönen Değerler

Yaf_Request_Abstract::getModuleName
Yaf_Request_Abstract::getParams
Yaf_Request_Abstract


The getParams purpose

Yaf_Request_Abstract::getParam
Yaf_Request_Abstract::getRequestUri
Yaf_Request_Abstract
PHP Manual

Yaf_Request_Abstract::getParams

(Yaf >=1.0.0)

Yaf_Request_Abstract::getParams — The getParams purpose

Açıklama

public void Yaf_Request_Abstract::getParams ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Request_Abstract::getParam
Yaf_Request_Abstract::getRequestUri
Yaf_Request_Abstract


The getRequestUri purpose

Yaf_Request_Abstract::getParams
Yaf_Request_Abstract::getServer
Yaf_Request_Abstract
PHP Manual

Yaf_Request_Abstract::getRequestUri

(Yaf >=1.0.0)

Yaf_Request_Abstract::getRequestUri — The getRequestUri purpose

Açıklama

public void Yaf_Request_Abstract::getRequestUri ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Request_Abstract::getParams
Yaf_Request_Abstract::getServer
Yaf_Request_Abstract


Retrieve SERVER variable

Yaf_Request_Abstract::getRequestUri
Yaf_Request_Abstract::isCli
Yaf_Request_Abstract
PHP Manual

Yaf_Request_Abstract::getServer

(Yaf >=1.0.0)

Yaf_Request_Abstract::getServer — Retrieve SERVER variable

Açıklama

public void Yaf_Request_Abstract::getServer ( string $name [, string $default ] )

Retrieve SERVER variable

Değiştirgeler

name

the variable name

default

if this parameter is provide, this will be returned if the variable can not be found

Dönen Değerler

Ayrıca Bakınız

  • Yaf_Request_Abstract::getParam
  • Yaf_Request_Abstract::getEnv
Yaf_Request_Abstract::getRequestUri
Yaf_Request_Abstract::isCli
Yaf_Request_Abstract


The isCli purpose

Yaf_Request_Abstract::getServer
Yaf_Request_Abstract::isDispatched
Yaf_Request_Abstract
PHP Manual

Yaf_Request_Abstract::isCli

(Yaf >=1.0.0)

Yaf_Request_Abstract::isCli — The isCli purpose

Açıklama

public void Yaf_Request_Abstract::isCli ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Request_Abstract::getServer
Yaf_Request_Abstract::isDispatched
Yaf_Request_Abstract


The isDispatched purpose

Yaf_Request_Abstract::isCli
Yaf_Request_Abstract::isGet
Yaf_Request_Abstract
PHP Manual

Yaf_Request_Abstract::isDispatched

(Yaf >=1.0.0)

Yaf_Request_Abstract::isDispatched — The isDispatched purpose

Açıklama

public void Yaf_Request_Abstract::isDispatched ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Request_Abstract::isCli
Yaf_Request_Abstract::isGet
Yaf_Request_Abstract


The isGet purpose

Yaf_Request_Abstract::isDispatched
Yaf_Request_Abstract::isHead
Yaf_Request_Abstract
PHP Manual

Yaf_Request_Abstract::isGet

(Yaf >=1.0.0)

Yaf_Request_Abstract::isGet — The isGet purpose

Açıklama

public void Yaf_Request_Abstract::isGet ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Request_Abstract::isDispatched
Yaf_Request_Abstract::isHead
Yaf_Request_Abstract


The isHead purpose

Yaf_Request_Abstract::isGet
Yaf_Request_Abstract::isOptions
Yaf_Request_Abstract
PHP Manual

Yaf_Request_Abstract::isHead

(Yaf >=1.0.0)

Yaf_Request_Abstract::isHead — The isHead purpose

Açıklama

public void Yaf_Request_Abstract::isHead ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Request_Abstract::isGet
Yaf_Request_Abstract::isOptions
Yaf_Request_Abstract


The isOptions purpose

Yaf_Request_Abstract::isHead
Yaf_Request_Abstract::isPost
Yaf_Request_Abstract
PHP Manual

Yaf_Request_Abstract::isOptions

(Yaf >=1.0.0)

Yaf_Request_Abstract::isOptions — The isOptions purpose

Açıklama

public void Yaf_Request_Abstract::isOptions ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Request_Abstract::isHead
Yaf_Request_Abstract::isPost
Yaf_Request_Abstract


The isPost purpose

Yaf_Request_Abstract::isOptions
Yaf_Request_Abstract::isPut
Yaf_Request_Abstract
PHP Manual

Yaf_Request_Abstract::isPost

(Yaf >=1.0.0)

Yaf_Request_Abstract::isPost — The isPost purpose

Açıklama

public void Yaf_Request_Abstract::isPost ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Request_Abstract::isOptions
Yaf_Request_Abstract::isPut
Yaf_Request_Abstract


The isPut purpose

Yaf_Request_Abstract::isPost
Yaf_Request_Abstract::isRouted
Yaf_Request_Abstract
PHP Manual

Yaf_Request_Abstract::isPut

(Yaf >=1.0.0)

Yaf_Request_Abstract::isPut — The isPut purpose

Açıklama

public void Yaf_Request_Abstract::isPut ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Request_Abstract::isPost
Yaf_Request_Abstract::isRouted
Yaf_Request_Abstract


The isRouted purpose

Yaf_Request_Abstract::isPut
Yaf_Request_Abstract::isXmlHttpRequest
Yaf_Request_Abstract
PHP Manual

Yaf_Request_Abstract::isRouted

(Yaf >=1.0.0)

Yaf_Request_Abstract::isRouted — The isRouted purpose

Açıklama

public void Yaf_Request_Abstract::isRouted ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Request_Abstract::isPut
Yaf_Request_Abstract::isXmlHttpRequest
Yaf_Request_Abstract


The isXmlHttpRequest purpose

Yaf_Request_Abstract::isRouted
Yaf_Request_Abstract::setActionName
Yaf_Request_Abstract
PHP Manual

Yaf_Request_Abstract::isXmlHttpRequest

(Yaf >=1.0.0)

Yaf_Request_Abstract::isXmlHttpRequest — The isXmlHttpRequest purpose

Açıklama

public void Yaf_Request_Abstract::isXmlHttpRequest ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Request_Abstract::isRouted
Yaf_Request_Abstract::setActionName
Yaf_Request_Abstract


The setActionName purpose

Yaf_Request_Abstract::isXmlHttpRequest
Yaf_Request_Abstract::setBaseUri
Yaf_Request_Abstract
PHP Manual

Yaf_Request_Abstract::setActionName

(Yaf >=1.0.0)

Yaf_Request_Abstract::setActionName — The setActionName purpose

Açıklama

public void Yaf_Request_Abstract::setActionName ( string $action )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

action

Dönen Değerler

Yaf_Request_Abstract::isXmlHttpRequest
Yaf_Request_Abstract::setBaseUri
Yaf_Request_Abstract


set base URI

Yaf_Request_Abstract::setActionName
Yaf_Request_Abstract::setControllerName
Yaf_Request_Abstract
PHP Manual

Yaf_Request_Abstract::setBaseUri

(Yaf >=1.0.0)

Yaf_Request_Abstract::setBaseUri — set base URI

Açıklama

public bool Yaf_Request_Abstract::setBaseUri ( string $uir )

Set base URI, base URI is used when doing routing, in routing phase request URI is used to route a request, while base URI is used to skip the leadding part(base URI) of request URI. That is, if comes a request with request URI a/b/c, then if you set base URI to "a/b", only "/c" will be used in routing phase.

Bilginize:

generally, you don't need to set this, Yaf will determine it automatically.

Değiştirgeler

uir

base URI

Dönen Değerler

bool

Yaf_Request_Abstract::setActionName
Yaf_Request_Abstract::setControllerName
Yaf_Request_Abstract


The setControllerName purpose

Yaf_Request_Abstract::setBaseUri
Yaf_Request_Abstract::setDispatched
Yaf_Request_Abstract
PHP Manual

Yaf_Request_Abstract::setControllerName

(Yaf >=1.0.0)

Yaf_Request_Abstract::setControllerName — The setControllerName purpose

Açıklama

public void Yaf_Request_Abstract::setControllerName ( string $controller )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

controller

Dönen Değerler

Yaf_Request_Abstract::setBaseUri
Yaf_Request_Abstract::setDispatched
Yaf_Request_Abstract


The setDispatched purpose

Yaf_Request_Abstract::setControllerName
Yaf_Request_Abstract::setModuleName
Yaf_Request_Abstract
PHP Manual

Yaf_Request_Abstract::setDispatched

(Yaf >=1.0.0)

Yaf_Request_Abstract::setDispatched — The setDispatched purpose

Açıklama

public void Yaf_Request_Abstract::setDispatched ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Request_Abstract::setControllerName
Yaf_Request_Abstract::setModuleName
Yaf_Request_Abstract


The setModuleName purpose

Yaf_Request_Abstract::setDispatched
Yaf_Request_Abstract::setParam
Yaf_Request_Abstract
PHP Manual

Yaf_Request_Abstract::setModuleName

(Yaf >=1.0.0)

Yaf_Request_Abstract::setModuleName — The setModuleName purpose

Açıklama

public void Yaf_Request_Abstract::setModuleName ( string $module )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

module

Dönen Değerler

Yaf_Request_Abstract::setDispatched
Yaf_Request_Abstract::setParam
Yaf_Request_Abstract


The setParam purpose

Yaf_Request_Abstract::setModuleName
Yaf_Request_Abstract::setRequestUri
Yaf_Request_Abstract
PHP Manual

Yaf_Request_Abstract::setParam

(Yaf >=1.0.0)

Yaf_Request_Abstract::setParam — The setParam purpose

Açıklama

public void Yaf_Request_Abstract::setParam ( string $name [, string $value ] )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

name

value

Dönen Değerler

Yaf_Request_Abstract::setModuleName
Yaf_Request_Abstract::setRequestUri
Yaf_Request_Abstract


The setRequestUri purpose

Yaf_Request_Abstract::setParam
Yaf_Request_Abstract::setRouted
Yaf_Request_Abstract
PHP Manual

Yaf_Request_Abstract::setRequestUri

(Yaf >=2.1.0)

Yaf_Request_Abstract::setRequestUri — The setRequestUri purpose

Açıklama

public void Yaf_Request_Abstract::setRequestUri ( string $uir )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

uir

Dönen Değerler

Yaf_Request_Abstract::setParam
Yaf_Request_Abstract::setRouted
Yaf_Request_Abstract


The setRouted purpose

Yaf_Request_Abstract::setRequestUri
Yaf_Request_Http
Yaf_Request_Abstract
PHP Manual

Yaf_Request_Abstract::setRouted

(Yaf >=1.0.0)

Yaf_Request_Abstract::setRouted — The setRouted purpose

Açıklama

public void Yaf_Request_Abstract::setRouted ([ string $flag ] )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

flag

Dönen Değerler

Yaf_Request_Abstract::setRequestUri
Yaf_Request_Http
Yaf_Request_Abstract


The Yaf_Request_Http class

(Yaf >=1.0.0)

Giriş

Any request from client is initialized as a Yaf_Request_Http. you can get the rquest infomations like, uri query and post parameters via methods of this class.

Bilginize:

For security, $_GET/$_POST are readonly in Yaf, which means if you set a value to these global variables, you can not get it from Yaf_Request_Http::getQurey() or Yaf_Request_Http::getPost().

But there do is some usage need such feature, like unit testing. thus Yaf can be built with --enable-yaf-debug, which will allow Yaf read the value user set via script.

in such case, Yaf will throw a E_STRICT warning to remind you about that: Strict Standards: you are running yaf in debug mode

Sınıf Sözdizimi

Yaf_Request_Http extends Yaf_Request_Abstract {
/* Özellikler */
/* Yöntemler */
private void __clone ( void )
public __construct ([ string $request_uri [, string $base_uri ]] )
public mixed get ( string $name [, string $default ] )
public mixed getCookie ( string $name [, string $default ] )
public void getFiles ( void )
public mixed getPost ( string $name [, string $default ] )
public mixed getQuery ( string $name [, string $default ] )
public void getRequest ( void )
public bool isXmlHttpRequest ( void )
/* Miras alınan yöntemler */
public void Yaf_Request_Abstract::getActionName ( void )
public void Yaf_Request_Abstract::getBaseUri ( void )
public void Yaf_Request_Abstract::getControllerName ( void )
public void Yaf_Request_Abstract::getEnv ( string $name [, string $default ] )
public void Yaf_Request_Abstract::getException ( void )
public void Yaf_Request_Abstract::getLanguage ( void )
public void Yaf_Request_Abstract::getMethod ( void )
public void Yaf_Request_Abstract::getModuleName ( void )
public void Yaf_Request_Abstract::getParam ( string $name [, string $default ] )
public void Yaf_Request_Abstract::getParams ( void )
public void Yaf_Request_Abstract::getRequestUri ( void )
public void Yaf_Request_Abstract::getServer ( string $name [, string $default ] )
public void Yaf_Request_Abstract::isCli ( void )
public void Yaf_Request_Abstract::isDispatched ( void )
public void Yaf_Request_Abstract::isGet ( void )
public void Yaf_Request_Abstract::isHead ( void )
public void Yaf_Request_Abstract::isOptions ( void )
public void Yaf_Request_Abstract::isPost ( void )
public void Yaf_Request_Abstract::isPut ( void )
public void Yaf_Request_Abstract::isRouted ( void )
public void Yaf_Request_Abstract::isXmlHttpRequest ( void )
public void Yaf_Request_Abstract::setActionName ( string $action )
public bool Yaf_Request_Abstract::setBaseUri ( string $uir )
public void Yaf_Request_Abstract::setControllerName ( string $controller )
public void Yaf_Request_Abstract::setDispatched ( void )
public void Yaf_Request_Abstract::setModuleName ( string $module )
public void Yaf_Request_Abstract::setParam ( string $name [, string $value ] )
public void Yaf_Request_Abstract::setRequestUri ( string $uir )
public void Yaf_Request_Abstract::setRouted ([ string $flag ] )
}

Özellikler

module

controller

action

method

params

language

_exception

_base_uri

uri

dispatched

routed

İçindekiler

  • Yaf_Request_Http::__clone — The __clone purpose
  • Yaf_Request_Http::__construct — Constructor of Yaf_Request_Http
  • Yaf_Request_Http::get — Retrieve variable from client
  • Yaf_Request_Http::getCookie — Retrieve Cookie variable
  • Yaf_Request_Http::getFiles — The getFiles purpose
  • Yaf_Request_Http::getPost — Retrieve POST variable
  • Yaf_Request_Http::getQuery — Fetch a query parameter
  • Yaf_Request_Http::getRequest — The getRequest purpose
  • Yaf_Request_Http::isXmlHttpRequest — Whether a Ajax Request
Yaf_Request_Abstract::setRouted
Yaf_Request_Http::__clone
Yaf


The __clone purpose

Yaf_Request_Http
Yaf_Request_Http::__construct
Yaf_Request_Http
PHP Manual

Yaf_Request_Http::__clone

(Yaf >=1.0.0)

Yaf_Request_Http::__clone — The __clone purpose

Açıklama

private void Yaf_Request_Http::__clone ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Request_Http
Yaf_Request_Http::__construct
Yaf_Request_Http


Constructor of Yaf_Request_Http

Yaf_Request_Http::__clone
Yaf_Request_Http::get
Yaf_Request_Http
PHP Manual

Yaf_Request_Http::__construct

(Yaf >=1.0.0)

Yaf_Request_Http::__construct — Constructor of Yaf_Request_Http

Açıklama

public Yaf_Request_Http::__construct ([ string $request_uri [, string $base_uri ]] )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Request_Http::__clone
Yaf_Request_Http::get
Yaf_Request_Http


Retrieve variable from client

Yaf_Request_Http::__construct
Yaf_Request_Http::getCookie
Yaf_Request_Http
PHP Manual

Yaf_Request_Http::get

(Yaf >=1.0.0)

Yaf_Request_Http::get — Retrieve variable from client

Açıklama

public mixed Yaf_Request_Http::get ( string $name [, string $default ] )

Retrieve variable from client, this method will search the name in request pramas, if the name is not found, then will search in POST, GET, Cookie, Server

Değiştirgeler

name

the variable name

default

if this parameter is provide, this will be returned if the varialbe can not be found

Dönen Değerler

Ayrıca Bakınız

  • Yaf_Request_Http::getQuery
  • Yaf_Request_Http::getPost
  • Yaf_Request_Http::getCookie
  • Yaf_Request_Http::getServer
  • Yaf_Request_Http::getParam
Yaf_Request_Http::__construct
Yaf_Request_Http::getCookie
Yaf_Request_Http


Retrieve Cookie variable

Yaf_Request_Http::get
Yaf_Request_Http::getFiles
Yaf_Request_Http
PHP Manual

Yaf_Request_Http::getCookie

(Yaf >=1.0.0)

Yaf_Request_Http::getCookie — Retrieve Cookie variable

Açıklama

public mixed Yaf_Request_Http::getCookie ( string $name [, string $default ] )

Retrieve Cookie variable

Değiştirgeler

name

the cookie name

default

if this parameter is provide, this will be returned if the cookie can not be found

Dönen Değerler

Ayrıca Bakınız

  • Yaf_Request_Http::get
  • Yaf_Request_Http::getQuery
  • Yaf_Request_Http::getPost
  • Yaf_Request_Http::getServer
  • Yaf_Request_Http::getParam
Yaf_Request_Http::get
Yaf_Request_Http::getFiles
Yaf_Request_Http


The getFiles purpose

Yaf_Request_Http::getCookie
Yaf_Request_Http::getPost
Yaf_Request_Http
PHP Manual

Yaf_Request_Http::getFiles

(Yaf >=1.0.0)

Yaf_Request_Http::getFiles — The getFiles purpose

Açıklama

public void Yaf_Request_Http::getFiles ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Request_Http::getCookie
Yaf_Request_Http::getPost
Yaf_Request_Http


Retrieve POST variable

Yaf_Request_Http::getFiles
Yaf_Request_Http::getQuery
Yaf_Request_Http
PHP Manual

Yaf_Request_Http::getPost

(Yaf >=1.0.0)

Yaf_Request_Http::getPost — Retrieve POST variable

Açıklama

public mixed Yaf_Request_Http::getPost ( string $name [, string $default ] )

Retrieve POST variable

Değiştirgeler

name

the variable name

default

if this parameter is provide, this will be returned if the varialbe can not be found

Dönen Değerler

Ayrıca Bakınız

  • Yaf_Request_Http::get
  • Yaf_Request_Http::getQuery
  • Yaf_Request_Http::getCookie
  • Yaf_Request_Http::getServer
  • Yaf_Request_Http::getParam
Yaf_Request_Http::getFiles
Yaf_Request_Http::getQuery
Yaf_Request_Http


Fetch a query parameter

Yaf_Request_Http::getPost
Yaf_Request_Http::getRequest
Yaf_Request_Http
PHP Manual

Yaf_Request_Http::getQuery

(Yaf >=1.0.0)

Yaf_Request_Http::getQuery — Fetch a query parameter

Açıklama

public mixed Yaf_Request_Http::getQuery ( string $name [, string $default ] )

Retrieve GET variable

Değiştirgeler

name

the variable name

default

if this parameter is provide, this will be returned if the variable can not be found

Dönen Değerler

Ayrıca Bakınız

  • Yaf_Request_Http::get
  • Yaf_Request_Http::getPost
  • Yaf_Request_Http::getCookie
  • Yaf_Request_Http::getServer
  • Yaf_Request_Http::getParam
Yaf_Request_Http::getPost
Yaf_Request_Http::getRequest
Yaf_Request_Http


The getRequest purpose

Yaf_Request_Http::getQuery
Yaf_Request_Http::isXmlHttpRequest
Yaf_Request_Http
PHP Manual

Yaf_Request_Http::getRequest

(Yaf >=1.0.0)

Yaf_Request_Http::getRequest — The getRequest purpose

Açıklama

public void Yaf_Request_Http::getRequest ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Request_Http::getQuery
Yaf_Request_Http::isXmlHttpRequest
Yaf_Request_Http


Whether a Ajax Request

Yaf_Request_Http::getRequest
Yaf_Request_Simple
Yaf_Request_Http
PHP Manual

Yaf_Request_Http::isXmlHttpRequest

(Yaf >=1.0.0)

Yaf_Request_Http::isXmlHttpRequest — Whether a Ajax Request

Açıklama

public bool Yaf_Request_Http::isXmlHttpRequest ( void )

Check the request whether it is a Ajax Request.

Bilginize:

This method depends on the request header: HTTP_X_REQUESTED_WITH, some Javascript library doesn't set this header while doing Ajax request

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Request_Http::getRequest
Yaf_Request_Simple
Yaf_Request_Http


The Yaf_Request_Simple class

(Yaf >=1.0.0)

Giriş

Yaf_Request_Simple is particularlly used for test puporse. ie. simulate some espacial request under CLI mode.

Sınıf Sözdizimi

Yaf_Request_Simple extends Yaf_Request_Abstract {
/* Constants */
const string SCHEME_HTTP = http ;
const string SCHEME_HTTPS = https ;
/* Özellikler */
/* Yöntemler */
private void __clone ( void )
public __construct ([ string $method [, string $module [, string $controller [, string $action [, array $params ]]]]] )
public void get ( void )
public void getCookie ( void )
public void getFiles ( void )
public void getPost ( void )
public void getQuery ( void )
public void getRequest ( void )
public void isXmlHttpRequest ( void )
/* Miras alınan yöntemler */
public void Yaf_Request_Abstract::getActionName ( void )
public void Yaf_Request_Abstract::getBaseUri ( void )
public void Yaf_Request_Abstract::getControllerName ( void )
public void Yaf_Request_Abstract::getEnv ( string $name [, string $default ] )
public void Yaf_Request_Abstract::getException ( void )
public void Yaf_Request_Abstract::getLanguage ( void )
public void Yaf_Request_Abstract::getMethod ( void )
public void Yaf_Request_Abstract::getModuleName ( void )
public void Yaf_Request_Abstract::getParam ( string $name [, string $default ] )
public void Yaf_Request_Abstract::getParams ( void )
public void Yaf_Request_Abstract::getRequestUri ( void )
public void Yaf_Request_Abstract::getServer ( string $name [, string $default ] )
public void Yaf_Request_Abstract::isCli ( void )
public void Yaf_Request_Abstract::isDispatched ( void )
public void Yaf_Request_Abstract::isGet ( void )
public void Yaf_Request_Abstract::isHead ( void )
public void Yaf_Request_Abstract::isOptions ( void )
public void Yaf_Request_Abstract::isPost ( void )
public void Yaf_Request_Abstract::isPut ( void )
public void Yaf_Request_Abstract::isRouted ( void )
public void Yaf_Request_Abstract::isXmlHttpRequest ( void )
public void Yaf_Request_Abstract::setActionName ( string $action )
public bool Yaf_Request_Abstract::setBaseUri ( string $uir )
public void Yaf_Request_Abstract::setControllerName ( string $controller )
public void Yaf_Request_Abstract::setDispatched ( void )
public void Yaf_Request_Abstract::setModuleName ( string $module )
public void Yaf_Request_Abstract::setParam ( string $name [, string $value ] )
public void Yaf_Request_Abstract::setRequestUri ( string $uir )
public void Yaf_Request_Abstract::setRouted ([ string $flag ] )
}

Özellikler

module

controller

action

method

params

language

_exception

_base_uri

uri

dispatched

routed

Öntanımlı Sabitler

Yaf_Request_Simple::SCHEME_HTTP

Yaf_Request_Simple::SCHEME_HTTPS

İçindekiler

  • Yaf_Request_Simple::__clone — The __clone purpose
  • Yaf_Request_Simple::__construct — Constructor of Yaf_Request_Simple
  • Yaf_Request_Simple::get — The get purpose
  • Yaf_Request_Simple::getCookie — The getCookie purpose
  • Yaf_Request_Simple::getFiles — The getFiles purpose
  • Yaf_Request_Simple::getPost — The getPost purpose
  • Yaf_Request_Simple::getQuery — The getQuery purpose
  • Yaf_Request_Simple::getRequest — The getRequest purpose
  • Yaf_Request_Simple::isXmlHttpRequest — The isXmlHttpRequest purpose
Yaf_Request_Http::isXmlHttpRequest
Yaf_Request_Simple::__clone
Yaf


The __clone purpose

Yaf_Request_Simple
Yaf_Request_Simple::__construct
Yaf_Request_Simple
PHP Manual

Yaf_Request_Simple::__clone

(Yaf >=1.0.0)

Yaf_Request_Simple::__clone — The __clone purpose

Açıklama

private void Yaf_Request_Simple::__clone ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Request_Simple
Yaf_Request_Simple::__construct
Yaf_Request_Simple


Constructor of Yaf_Request_Simple

Yaf_Request_Simple::__clone
Yaf_Request_Simple::get
Yaf_Request_Simple
PHP Manual

Yaf_Request_Simple::__construct

(Yaf >=1.0.0)

Yaf_Request_Simple::__construct — Constructor of Yaf_Request_Simple

Açıklama

public Yaf_Request_Simple::__construct ([ string $method [, string $module [, string $controller [, string $action [, array $params ]]]]] )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Request_Simple::__clone
Yaf_Request_Simple::get
Yaf_Request_Simple


The get purpose

Yaf_Request_Simple::__construct
Yaf_Request_Simple::getCookie
Yaf_Request_Simple
PHP Manual

Yaf_Request_Simple::get

(Yaf >=1.0.0)

Yaf_Request_Simple::get — The get purpose

Açıklama

public void Yaf_Request_Simple::get ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Request_Simple::__construct
Yaf_Request_Simple::getCookie
Yaf_Request_Simple


The getCookie purpose

Yaf_Request_Simple::get
Yaf_Request_Simple::getFiles
Yaf_Request_Simple
PHP Manual

Yaf_Request_Simple::getCookie

(Yaf >=1.0.0)

Yaf_Request_Simple::getCookie — The getCookie purpose

Açıklama

public void Yaf_Request_Simple::getCookie ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Request_Simple::get
Yaf_Request_Simple::getFiles
Yaf_Request_Simple


The getFiles purpose

Yaf_Request_Simple::getCookie
Yaf_Request_Simple::getPost
Yaf_Request_Simple
PHP Manual

Yaf_Request_Simple::getFiles

(Yaf >=1.0.0)

Yaf_Request_Simple::getFiles — The getFiles purpose

Açıklama

public void Yaf_Request_Simple::getFiles ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Request_Simple::getCookie
Yaf_Request_Simple::getPost
Yaf_Request_Simple


The getPost purpose

Yaf_Request_Simple::getFiles
Yaf_Request_Simple::getQuery
Yaf_Request_Simple
PHP Manual

Yaf_Request_Simple::getPost

(Yaf >=1.0.0)

Yaf_Request_Simple::getPost — The getPost purpose

Açıklama

public void Yaf_Request_Simple::getPost ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Request_Simple::getFiles
Yaf_Request_Simple::getQuery
Yaf_Request_Simple


The getQuery purpose

Yaf_Request_Simple::getPost
Yaf_Request_Simple::getRequest
Yaf_Request_Simple
PHP Manual

Yaf_Request_Simple::getQuery

(Yaf >=1.0.0)

Yaf_Request_Simple::getQuery — The getQuery purpose

Açıklama

public void Yaf_Request_Simple::getQuery ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Request_Simple::getPost
Yaf_Request_Simple::getRequest
Yaf_Request_Simple


The getRequest purpose

Yaf_Request_Simple::getQuery
Yaf_Request_Simple::isXmlHttpRequest
Yaf_Request_Simple
PHP Manual

Yaf_Request_Simple::getRequest

(Yaf >=1.0.0)

Yaf_Request_Simple::getRequest — The getRequest purpose

Açıklama

public void Yaf_Request_Simple::getRequest ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Request_Simple::getQuery
Yaf_Request_Simple::isXmlHttpRequest
Yaf_Request_Simple


The isXmlHttpRequest purpose

Yaf_Request_Simple::getRequest
Yaf_Response_Abstract
Yaf_Request_Simple
PHP Manual

Yaf_Request_Simple::isXmlHttpRequest

(Yaf >=1.0.0)

Yaf_Request_Simple::isXmlHttpRequest — The isXmlHttpRequest purpose

Açıklama

public void Yaf_Request_Simple::isXmlHttpRequest ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Request_Simple::getRequest
Yaf_Response_Abstract
Yaf_Request_Simple


The Yaf_Response_Abstract class

(Yaf >=1.0.0)

Giriş

Sınıf Sözdizimi

Yaf_Response_Abstract {
/* Constants */
const string DEFAULT_BODY = "content" ;
/* Özellikler */
protected $_header ;
protected $_body ;
protected $_sendheader ;
/* Yöntemler */
public bool appendBody ( string $content [, string $key ] )
public bool clearBody ([ string $key ] )
public void clearHeaders ( void )
private void __clone ( void )
public __construct ( void )
public void __destruct ( void )
public mixed getBody ([ string $key ] )
public void getHeader ( void )
public bool prependBody ( string $content [, string $key ] )
public void response ( void )
protected void setAllHeaders ( void )
public bool setBody ( string $content [, string $key ] )
public void setHeader ( void )
public void setRedirect ( void )
private void __toString ( void )
}

Özellikler

_header

_body

_sendheader

İçindekiler

  • Yaf_Response_Abstract::appendBody — append to body
  • Yaf_Response_Abstract::clearBody — The clearBody purpose
  • Yaf_Response_Abstract::clearHeaders — The clearHeaders purpose
  • Yaf_Response_Abstract::__clone — The __clone purpose
  • Yaf_Response_Abstract::__construct — The __construct purpose
  • Yaf_Response_Abstract::__destruct — The __destruct purpose
  • Yaf_Response_Abstract::getBody — Retrieve a exists content
  • Yaf_Response_Abstract::getHeader — The getHeader purpose
  • Yaf_Response_Abstract::prependBody — The prependBody purpose
  • Yaf_Response_Abstract::response — send response
  • Yaf_Response_Abstract::setAllHeaders — The setAllHeaders purpose
  • Yaf_Response_Abstract::setBody — Set content to response
  • Yaf_Response_Abstract::setHeader — The setHeader purpose
  • Yaf_Response_Abstract::setRedirect — The setRedirect purpose
  • Yaf_Response_Abstract::__toString — The __toString purpose
Yaf_Request_Simple::isXmlHttpRequest
Yaf_Response_Abstract::appendBody
Yaf


append to body

Yaf_Response_Abstract
Yaf_Response_Abstract::clearBody
Yaf_Response_Abstract
PHP Manual

Yaf_Response_Abstract::appendBody

(Yaf >=1.0.0)

Yaf_Response_Abstract::appendBody — append to body

Açıklama

public bool Yaf_Response_Abstract::appendBody ( string $content [, string $key ] )

append a content to a exists content block

Değiştirgeler

body

content string

key

the content key, you can set a content with a key, if you don't specific, then Yaf_Response_Abstract::DEFAULT_BODY will be used

Bilginize:

this parameter is introduced as of 2.2.0

Dönen Değerler

bool

Örnekler

Örnek 1 Yaf_Response_Abstract::appendBody()example

<?php
$response = new Yaf_Response_Http();

$response->setBody("Hello")->prependBody(" World");

echo $response;
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Hello World

Ayrıca Bakınız

  • Yaf_Config_Ini

Ayrıca Bakınız

  • Yaf_Response_Abstract::getBody() - Retrieve a exists content
  • Yaf_Response_Abstract::setBody() - Set content to response
  • Yaf_Response_Abstract::prependBody() - The prependBody purpose
  • Yaf_Response_Abstract::clearBody() - The clearBody purpose
Yaf_Response_Abstract
Yaf_Response_Abstract::clearBody
Yaf_Response_Abstract


The clearBody purpose

Yaf_Response_Abstract::appendBody
Yaf_Response_Abstract::clearHeaders
Yaf_Response_Abstract
PHP Manual

Yaf_Response_Abstract::clearBody

(Yaf >=1.0.0)

Yaf_Response_Abstract::clearBody — The clearBody purpose

Açıklama

public bool Yaf_Response_Abstract::clearBody ([ string $key ] )

Clear existsed content

Değiştirgeler

key

the content key, if you don't specific, then all contents will be cleared.

Bilginize:

this parameter is introduced as of 2.2.0

Dönen Değerler

Ayrıca Bakınız

  • Yaf_Response_Abstract::setBody() - Set content to response
  • Yaf_Response_Abstract::appendBody() - append to body
  • Yaf_Response_Abstract::prependBody() - The prependBody purpose
  • Yaf_Response_Abstract::getBody() - Retrieve a exists content
Yaf_Response_Abstract::appendBody
Yaf_Response_Abstract::clearHeaders
Yaf_Response_Abstract


The clearHeaders purpose

Yaf_Response_Abstract::clearBody
Yaf_Response_Abstract::__clone
Yaf_Response_Abstract
PHP Manual

Yaf_Response_Abstract::clearHeaders

(Yaf >=1.0.0)

Yaf_Response_Abstract::clearHeaders — The clearHeaders purpose

Açıklama

public void Yaf_Response_Abstract::clearHeaders ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Response_Abstract::clearBody
Yaf_Response_Abstract::__clone
Yaf_Response_Abstract


The __clone purpose

Yaf_Response_Abstract::clearHeaders
Yaf_Response_Abstract::__construct
Yaf_Response_Abstract
PHP Manual

Yaf_Response_Abstract::__clone

(Yaf >=1.0.0)

Yaf_Response_Abstract::__clone — The __clone purpose

Açıklama

private void Yaf_Response_Abstract::__clone ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Response_Abstract::clearHeaders
Yaf_Response_Abstract::__construct
Yaf_Response_Abstract


The __construct purpose

Yaf_Response_Abstract::__clone
Yaf_Response_Abstract::__destruct
Yaf_Response_Abstract
PHP Manual

Yaf_Response_Abstract::__construct

(Yaf >=1.0.0)

Yaf_Response_Abstract::__construct — The __construct purpose

Açıklama

public Yaf_Response_Abstract::__construct ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Response_Abstract::__clone
Yaf_Response_Abstract::__destruct
Yaf_Response_Abstract


The __destruct purpose

Yaf_Response_Abstract::__construct
Yaf_Response_Abstract::getBody
Yaf_Response_Abstract
PHP Manual

Yaf_Response_Abstract::__destruct

(Yaf >=1.0.0)

Yaf_Response_Abstract::__destruct — The __destruct purpose

Açıklama

public void Yaf_Response_Abstract::__destruct ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Response_Abstract::__construct
Yaf_Response_Abstract::getBody
Yaf_Response_Abstract


Retrieve a exists content

Yaf_Response_Abstract::__destruct
Yaf_Response_Abstract::getHeader
Yaf_Response_Abstract
PHP Manual

Yaf_Response_Abstract::getBody

(Yaf >=1.0.0)

Yaf_Response_Abstract::getBody — Retrieve a exists content

Açıklama

public mixed Yaf_Response_Abstract::getBody ([ string $key ] )

Retrieve a exists content

Değiştirgeler

key

the content key, if you don't specific, then Yaf_Response_Abstract::DEFAULT_BODY will be used. if you pass in a NULL, then all contents will be returned as a array

Bilginize:

this parameter is introduced as of 2.2.0

Dönen Değerler

Örnekler

Örnek 1 Yaf_Response_Abstract::getBody()example

<?php
$response = new Yaf_Response_Http();

$response->setBody("Hello")->setBody(" World", "footer");

var_dump($response->getBody()); //default
var_dump($response->getBody(Yaf_Response_Abstract::DEFAULT_BODY)); //same as above
var_dump($response->getBody("footer"));
var_dump($response->getBody(NULL)); //get all
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(5) "Hello"
string(5) "Hello"
string(6) " World"
array(2) {
  ["content"]=>
  string(5) "Hello"
  ["footer"]=>
  string(6) " World"
}

Ayrıca Bakınız

  • Yaf_Response_Abstract::setBody() - Set content to response
  • Yaf_Response_Abstract::appendBody() - append to body
  • Yaf_Response_Abstract::prependBody() - The prependBody purpose
  • Yaf_Response_Abstract::clearBody() - The clearBody purpose
Yaf_Response_Abstract::__destruct
Yaf_Response_Abstract::getHeader
Yaf_Response_Abstract


The getHeader purpose

Yaf_Response_Abstract::getBody
Yaf_Response_Abstract::prependBody
Yaf_Response_Abstract
PHP Manual

Yaf_Response_Abstract::getHeader

(Yaf >=1.0.0)

Yaf_Response_Abstract::getHeader — The getHeader purpose

Açıklama

public void Yaf_Response_Abstract::getHeader ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Response_Abstract::getBody
Yaf_Response_Abstract::prependBody
Yaf_Response_Abstract


The prependBody purpose

Yaf_Response_Abstract::getHeader
Yaf_Response_Abstract::response
Yaf_Response_Abstract
PHP Manual

Yaf_Response_Abstract::prependBody

(Yaf >=1.0.0)

Yaf_Response_Abstract::prependBody — The prependBody purpose

Açıklama

public bool Yaf_Response_Abstract::prependBody ( string $content [, string $key ] )

prepend a content to a exists content block

Değiştirgeler

body

content string

key

the content key, you can set a content with a key, if you don't specific, then Yaf_Response_Abstract::DEFAULT_BODY will be used

Bilginize:

this parameter is introduced as of 2.2.0

Dönen Değerler

bool

Örnekler

Örnek 1 Yaf_Response_Abstract::prependBody()example

<?php
$response = new Yaf_Response_Http();

$response->setBody("World")->prependBody("Hello ");

echo $response;
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Hello World

Ayrıca Bakınız

  • Yaf_Response_Abstract::getBody() - Retrieve a exists content
  • Yaf_Response_Abstract::setBody() - Set content to response
  • Yaf_Response_Abstract::appendBody() - append to body
  • Yaf_Response_Abstract::clearBody() - The clearBody purpose
Yaf_Response_Abstract::getHeader
Yaf_Response_Abstract::response
Yaf_Response_Abstract


send response

Yaf_Response_Abstract::prependBody
Yaf_Response_Abstract::setAllHeaders
Yaf_Response_Abstract
PHP Manual

Yaf_Response_Abstract::response

(Yaf >=1.0.0)

Yaf_Response_Abstract::response — send response

Açıklama

public void Yaf_Response_Abstract::response ( void )

send response

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Örnekler

Örnek 1 Yaf_Response_Abstract::response()example

<?php
$response = new Yaf_Response_Http();

$response->setBody("Hello")->setBody(" World", "footer");

$response->response();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Hello World

Ayrıca Bakınız

  • Yaf_Response_Abstract::setBody() - Set content to response
  • Yaf_Response_Abstract::clearBody() - The clearBody purpose
Yaf_Response_Abstract::prependBody
Yaf_Response_Abstract::setAllHeaders
Yaf_Response_Abstract


The setAllHeaders purpose

Yaf_Response_Abstract::response
Yaf_Response_Abstract::setBody
Yaf_Response_Abstract
PHP Manual

Yaf_Response_Abstract::setAllHeaders

(Yaf >=1.0.0)

Yaf_Response_Abstract::setAllHeaders — The setAllHeaders purpose

Açıklama

protected void Yaf_Response_Abstract::setAllHeaders ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Response_Abstract::response
Yaf_Response_Abstract::setBody
Yaf_Response_Abstract


Set content to response

Yaf_Response_Abstract::setAllHeaders
Yaf_Response_Abstract::setHeader
Yaf_Response_Abstract
PHP Manual

Yaf_Response_Abstract::setBody

(Yaf >=1.0.0)

Yaf_Response_Abstract::setBody — Set content to response

Açıklama

public bool Yaf_Response_Abstract::setBody ( string $content [, string $key ] )

Set content to response

Değiştirgeler

body

content string

key

the content key, you can set a content with a key, if you don't specific, then Yaf_Response_Abstract::DEFAULT_BODY will be used

Bilginize:

this parameter is introduced as of 2.2.0

Dönen Değerler

Örnekler

Örnek 1 Yaf_Response_Abstract::setBody()example

<?php
$response = new Yaf_Response_Http();

$response->setBody("Hello")->setBody(" World", "footer");

print_r($response);
echo $response;
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Yaf_Response_Http Object
(
    [_header:protected] => Array
        (
        )

    [_body:protected] => Array
        (
            [content] => Hello
            [footer] =>  World
        )

    [_sendheader:protected] => 1
    [_response_code:protected] => 200
)
Hello World

Ayrıca Bakınız

  • Yaf_Response_Abstract::getBody() - Retrieve a exists content
  • Yaf_Response_Abstract::appendBody() - append to body
  • Yaf_Response_Abstract::prependBody() - The prependBody purpose
  • Yaf_Response_Abstract::clearBody() - The clearBody purpose
Yaf_Response_Abstract::setAllHeaders
Yaf_Response_Abstract::setHeader
Yaf_Response_Abstract


The setHeader purpose

Yaf_Response_Abstract::setBody
Yaf_Response_Abstract::setRedirect
Yaf_Response_Abstract
PHP Manual

Yaf_Response_Abstract::setHeader

(Yaf >=1.0.0)

Yaf_Response_Abstract::setHeader — The setHeader purpose

Açıklama

public void Yaf_Response_Abstract::setHeader ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Response_Abstract::setBody
Yaf_Response_Abstract::setRedirect
Yaf_Response_Abstract


The setRedirect purpose

Yaf_Response_Abstract::setHeader
Yaf_Response_Abstract::__toString
Yaf_Response_Abstract
PHP Manual

Yaf_Response_Abstract::setRedirect

(Yaf >=1.0.0)

Yaf_Response_Abstract::setRedirect — The setRedirect purpose

Açıklama

public void Yaf_Response_Abstract::setRedirect ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Response_Abstract::setHeader
Yaf_Response_Abstract::__toString
Yaf_Response_Abstract


The __toString purpose

Yaf_Response_Abstract::setRedirect
Yaf_Route_Interface
Yaf_Response_Abstract
PHP Manual

Yaf_Response_Abstract::__toString

(Yaf >=1.0.0)

Yaf_Response_Abstract::__toString — The __toString purpose

Açıklama

private void Yaf_Response_Abstract::__toString ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Response_Abstract::setRedirect
Yaf_Route_Interface
Yaf_Response_Abstract


The Yaf_Route_Interface class

(Yaf >=1.0.0)

Giriş

Yaf_Route_Interface used for developer defined their custom route.

Sınıf Sözdizimi

Yaf_Route_Interface {
/* Yöntemler */
abstract public string assemble ( array $info [, array $query ] )
abstract public bool route ( Yaf_Request_Abstract $request )
}

İçindekiler

  • Yaf_Route_Interface::assemble — assemble a request
  • Yaf_Route_Interface::route — route a request
Yaf_Response_Abstract::__toString
Yaf_Route_Interface::assemble
Yaf


assemble a request

Yaf_Route_Interface
Yaf_Route_Interface::route
Yaf_Route_Interface
PHP Manual

Yaf_Route_Interface::assemble

(Yaf >=2.3.0)

Yaf_Route_Interface::assemble — assemble a request

Açıklama

abstract public string Yaf_Route_Interface::assemble ( array $info [, array $query ] )

this method returns a url according to the argument info, and append query strings to the url according to the argument query.

a route should implement this method according to its own route rules, and do a reverse progress.

Değiştirgeler

info

query

Dönen Değerler

Yaf_Route_Interface
Yaf_Route_Interface::route
Yaf_Route_Interface


route a request

Yaf_Route_Interface::assemble
Yaf_Route_Map
Yaf_Route_Interface
PHP Manual

Yaf_Route_Interface::route

(Yaf >=1.0.0)

Yaf_Route_Interface::route — route a request

Açıklama

abstract public bool Yaf_Route_Interface::route ( Yaf_Request_Abstract $request )

Yaf_Route_Interface::route() is the only method that a custom route should implement.

Bilginize:

since of 2.3.0, there is another method should also be implemented, see Yaf_Route_Interface::assemble().

if this method return TRUE, then the route process will be end. otherwise, Yaf_Router will call next route in the route stack to route request.

This method would set the route result to the parameter request, by
calling Yaf_Request_Abstract::setControllerName(),
Yaf_Request_Abstract::setActionName() and
Yaf_Request_Abstract::setModuleName().

This method should also call Yaf_Request_Abstract::setRouted() to make the request routed at last.

Değiştirgeler

request

A Yaf_Request_Abstract instance.

Dönen Değerler

Yaf_Route_Interface::assemble
Yaf_Route_Map
Yaf_Route_Interface


The Yaf_Route_Map class

(Yaf >=1.0.0)

Giriş

Yaf_Route_Map is a built-in route, it simply convert a URI endpoint (that part of the URI which comes after the base URI: see Yaf_Request_Abstract::setBaseUri()) to a controller name or action name(depends on the paramter passed to Yaf_Route_Map::__construct()) in following rule: A => controller A. A/B/C => controller A_B_C. A/B/C/D/E => controller A_B_C_D_E.

If the second parameter of Yaf_Route_Map::__construct() is specificed, then only the part before delimeter of URI will used to routing, the part after it is used to routing request parameters (see the example section of Yaf_Route_Map::__construct()).

Sınıf Sözdizimi

Yaf_Route_Map implements Yaf_Route_Interface {
/* Özellikler */
protected $_ctl_router ;
protected $_delimeter ;
/* Yöntemler */
public string assemble ( array $info [, array $query ] )
public __construct ([ string $controller_prefer = false [, string $delimiter = "" ]] )
public bool route ( Yaf_Request_Abstract $request )
}

Özellikler

_ctl_router

_delimeter

İçindekiler

  • Yaf_Route_Map::assemble — Assemble a url
  • Yaf_Route_Map::__construct — The __construct purpose
  • Yaf_Route_Map::route — The route purpose
Yaf_Route_Interface::route
Yaf_Route_Map::assemble
Yaf


Assemble a url

Yaf_Route_Map
Yaf_Route_Map::__construct
Yaf_Route_Map
PHP Manual

Yaf_Route_Map::assemble

(Yaf >=2.3.0)

Yaf_Route_Map::assemble — Assemble a url

Açıklama

public string Yaf_Route_Map::assemble ( array $info [, array $query ] )

Assemble a url.

Değiştirgeler

info

query

Örnekler

Örnek 1 Yaf_Route_Map::assemble()example

<?php

$router = new Yaf_Router();

$route  = new Yaf_Route_Map();

$router->addRoute("map", $route);

var_dump($router->getRoute('map')->assemble(
                        array(
                                ':c' => 'foo_bar'
                        ),
                        array(
                                'tkey1' => 'tval1',
                                'tkey2' => 'tval2'
                        )
                   )
);

$route = new Yaf_Route_Map(true, '_');
$router->addRoute("map", $route);

var_dump($router->getRoute('map')->assemble(
                        array(
                                ':a' => 'foo_bar'
                        ),
                        array(
                                'tkey1' => 'tval1',
                                'tkey2' => 'tval2'
                        )
                   )
);

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(%d) "/foo/bar?tkey1=tval1&tkey2=tval2"
string(%d) "/foo/bar/_/tkey1/tval1/tkey2/tval2"

Dönen Değerler

Yaf_Route_Map
Yaf_Route_Map::__construct
Yaf_Route_Map


The __construct purpose

Yaf_Route_Map::assemble
Yaf_Route_Map::route
Yaf_Route_Map
PHP Manual

Yaf_Route_Map::__construct

(Yaf >=1.0.0)

Yaf_Route_Map::__construct — The __construct purpose

Açıklama

public Yaf_Route_Map::__construct ([ string $controller_prefer = false [, string $delimiter = "" ]] )

Değiştirgeler

controller_prefer

Whether the result should considering as controller or action

delimiter

Dönen Değerler

Örnekler

Örnek 1 Yaf_Route_Map()example

<?php
   /**
    * Add a map route to Yaf_Router route stack
    */
    Yaf_Dispatcher::getInstance()->getRouter()->addRoute("name",
        new Yaf_Route_Map());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

/* for http://yourdomain.com/product/foo/bar
 * route will result in following values:
 */
array(
  "controller" => "product_foo_bar",
)

Örnek 2 Yaf_Route_Map()example

<?php
   /**
    * Add a map route to Yaf_Router route stack
    */
    Yaf_Dispatcher::getInstance()->getRouter()->addRoute("name",
        new Yaf_Route_Map(true, "_"));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

/* for http://yourdomain.com/user/list/_/foo/22
 * route will result in following values:
 */
array(
    "action" => "user_list",
)

/**
 * and request parameters:
 */
array(
  "foo"   => 22,
)

Örnek 3 Yaf_Route_Map()example

<?php
   /**
    * Add a map route to Yaf_Router route stack by calling addconfig
    */
    $config = array(
        "name" => array(
           "type"  => "map",         //Yaf_Route_Map route
           "controllerPrefer" => FALSE,
           "delimiter"        => "#!",
           ),
    );
    Yaf_Dispatcher::getInstance()->getRouter()->addConfig(
        new Yaf_Config_Simple($config));
?>

Ayrıca Bakınız

  • Yaf_Router::addRoute() - Add new Route into Router
  • Yaf_Route_Static
  • Yaf_Route_Supervar
  • Yaf_Route_Simple
  • Yaf_Route_Regex
  • Yaf_Route_Rewrite
Yaf_Route_Map::assemble
Yaf_Route_Map::route
Yaf_Route_Map


The route purpose

Yaf_Route_Map::__construct
Yaf_Route_Regex
Yaf_Route_Map
PHP Manual

Yaf_Route_Map::route

(Yaf >=1.0.0)

Yaf_Route_Map::route — The route purpose

Açıklama

public bool Yaf_Route_Map::route ( Yaf_Request_Abstract $request )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

request

Dönen Değerler

Yaf_Route_Map::__construct
Yaf_Route_Regex
Yaf_Route_Map


The Yaf_Route_Regex class

(Yaf >=1.0.0)

Giriş

Yaf_Route_Regex is the most flexible route among the Yaf built-in routes.

Sınıf Sözdizimi

Yaf_Route_Regex extends Yaf_Route_Interface implements Yaf_Route_Interface {
/* Özellikler */
protected $_route ;
protected $_default ;
protected $_maps ;
protected $_verify ;
/* Yöntemler */
public string assemble ( array $info [, array $query ] )
public __construct ( string $match , array $route [, array $map [, array $verify [, string $reverse ]]] )
public bool route ( Yaf_Request_Abstract $request )
/* Miras alınan yöntemler */
abstract public string Yaf_Route_Interface::assemble ( array $info [, array $query ] )
abstract public bool Yaf_Route_Interface::route ( Yaf_Request_Abstract $request )
}

Özellikler

_route

_default

_maps

_verify

İçindekiler

  • Yaf_Route_Regex::assemble — Assemble a url
  • Yaf_Route_Regex::__construct — Yaf_Route_Regex constructor
  • Yaf_Route_Regex::route — The route purpose
Yaf_Route_Map::route
Yaf_Route_Regex::assemble
Yaf


Assemble a url

Yaf_Route_Regex
Yaf_Route_Regex::__construct
Yaf_Route_Regex
PHP Manual

Yaf_Route_Regex::assemble

(Yaf >=2.3.0)

Yaf_Route_Regex::assemble — Assemble a url

Açıklama

public string Yaf_Route_Regex::assemble ( array $info [, array $query ] )

Assemble a url.

Değiştirgeler

info

query

Örnekler

Örnek 1 Yaf_Route_Regex::assemble()example

<?php

$router = new Yaf_Router();

$route  = new Yaf_Route_Regex(
            "#^/product/([^/]+)/([^/])+#",
            array(
                'controller' => "product",  //route to product controller,
                ),
            array(),
            array(),
            '/:m/:c/:a'
        );

$router->addRoute("regex", $route);

var_dump($router->getRoute('regex')->assemble(
            array(
                ':m' => 'module',
                ':c' => 'controller',
                ':a' => 'action'
                ),
            array(
                'tkey1' => 'tval1',
                'tkey2' =>
                'tval2'
                )
            )
        );

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(49) "/module/controller/action?tkey1=tval1&tkey2=tval2"

Dönen Değerler

Yaf_Route_Regex
Yaf_Route_Regex::__construct
Yaf_Route_Regex


Yaf_Route_Regex constructor

Yaf_Route_Regex::assemble
Yaf_Route_Regex::route
Yaf_Route_Regex
PHP Manual

Yaf_Route_Regex::__construct

(Yaf >=1.0.0)

Yaf_Route_Regex::__construct — Yaf_Route_Regex constructor

Açıklama

public Yaf_Route_Regex::__construct ( string $match , array $route [, array $map [, array $verify [, string $reverse ]]] )

Değiştirgeler

match

A complete Regex pattern, will be used to match a request uri, if doesn't matched, Yaf_Route_Regex will return FALSE.

route

When the match pattern matches the request uri, Yaf_Route_Regex will use this to decide which m/c/a to routed.

either of m/c/a in this array is optianl, if you don't assgian a specific value, it will be routed to default.

map

A array to assign name to the captrues in the match result.

verify

reverse

a string, used to assemble url, see Yaf_Route_Regex::assemble().

Bilginize:

this parameter is introduced in 2.3.0

Dönen Değerler

Örnekler

Örnek 1 Yaf_Route_Regex()example

<?php
   /**
    * Add a regex route to Yaf_Router route stack
    */
    Yaf_Dispatcher::getInstance()->getRouter()->addRoute("name",
        new Yaf_Route_Regex(
           "#^/product/([^/]+)/([^/])+#", //match request uri leading "/product"
           array(
               'controller' => "product",  //route to product controller,
           ),
           array(
              1 => "name",   // now you can call $request->getParam("name")
              2 => "id",     // to get the first captrue in the match pattern.
           )
        )
    );
?>

Örnek 2 Yaf_Route_Regex(as of 2.3.0)()example

<?php
   /**
    * Use match result as MVC name
    */
    Yaf_Dispatcher::getInstance()->getRouter()->addRoute("name",
        new Yaf_Route_Regex(
           "#^/product/([^/]+)/([^/])+#i", //match request uri leading "/product"
           array(
              'controller' => ":name", // route to :name, which is $1 in the match result as controller name
           ),
           array(
              1 => "name",   // now you can call $request->getParam("name")
              2 => "id",     // to get the first captrue in the match pattern.
           )
        )
    );
?>

Örnek 3 Yaf_Route_Regex and named capture ground(as of 2.3.0)()example

<?php
   /**
    * Use match result as MVC name
    */
    Yaf_Dispatcher::getInstance()->getRouter()->addRoute("name",
        new Yaf_Route_Regex(
           "#^/product/(?<name>[^/]+)/([^/])+#i", //match request uri leading "/product"
           array(
           'controller' => ":name", // route to :name,
                                    // which is named capture group 'name' in the match result as controller name
           ),
           array(
              2 => "id",     // to get the first captrue in the match pattern.
           )
        )
    );
?>

Örnek 4 Yaf_Route_Regex()example

<?php
   /**
    * Add a regex route to Yaf_Router route stack by calling addconfig
    */
    $config = array(
        "name" => array(
           "type"  => "regex",          //Yaf_Route_Regex route
           "match" => "#(.*)#",         //match arbitrary request uri
           "route" => array(
               'controller' => "product",  //route to product controller,
               'action'     => "dummy",    //route to dummy action
           ),
           "map" => array(
              1 => "uri",   // now you can call $request->getParam("uri")
           ),
        ),
    );
    Yaf_Dispatcher::getInstance()->getRouter()->addConfig(
        new Yaf_Config_Simple($config));
?>

Ayrıca Bakınız

  • Yaf_Router::addRoute() - Add new Route into Router
  • Yaf_Router::addConfig() - Add config-defined routes into Router
  • Yaf_Route_Static
  • Yaf_Route_Supervar
  • Yaf_Route_Simple
  • Yaf_Route_Rewrite
  • Yaf_Route_Map
Yaf_Route_Regex::assemble
Yaf_Route_Regex::route
Yaf_Route_Regex


The route purpose

Yaf_Route_Regex::__construct
Yaf_Route_Rewrite
Yaf_Route_Regex
PHP Manual

Yaf_Route_Regex::route

(Yaf >=1.0.0)

Yaf_Route_Regex::route — The route purpose

Açıklama

public bool Yaf_Route_Regex::route ( Yaf_Request_Abstract $request )

Route a incoming request.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

request

Dönen Değerler

If the pattern given by the first parameter of Yaf_Route_Regex::_construct() matche the request uri, return TRUE, otherwise return FALSE.

Yaf_Route_Regex::__construct
Yaf_Route_Rewrite
Yaf_Route_Regex


The Yaf_Route_Rewrite class

(Yaf >=1.0.0)

Giriş

For usage, please see the example section of Yaf_Route_Rewrite::__construct()

Sınıf Sözdizimi

Yaf_Route_Rewrite extends Yaf_Route_Interface implements Yaf_Route_Interface {
/* Özellikler */
protected $_route ;
protected $_default ;
protected $_verify ;
/* Yöntemler */
public string assemble ( array $info [, array $query ] )
public __construct ( string $match , array $route [, array $verify ] )
public bool route ( Yaf_Request_Abstract $request )
/* Miras alınan yöntemler */
abstract public string Yaf_Route_Interface::assemble ( array $info [, array $query ] )
abstract public bool Yaf_Route_Interface::route ( Yaf_Request_Abstract $request )
}

Özellikler

_route

_default

_verify

İçindekiler

  • Yaf_Route_Rewrite::assemble — Assemble a url
  • Yaf_Route_Rewrite::__construct — Yaf_Route_Rewrite constructor
  • Yaf_Route_Rewrite::route — The route purpose
Yaf_Route_Regex::route
Yaf_Route_Rewrite::assemble
Yaf


Assemble a url

Yaf_Route_Rewrite
Yaf_Route_Rewrite::__construct
Yaf_Route_Rewrite
PHP Manual

Yaf_Route_Rewrite::assemble

(Yaf >=2.3.0)

Yaf_Route_Rewrite::assemble — Assemble a url

Açıklama

public string Yaf_Route_Rewrite::assemble ( array $info [, array $query ] )

Assemble a url.

Değiştirgeler

info

query

Örnekler

Örnek 1 Yaf_Route_Rewrite::assemble()example

router = new Yaf_Router();

$route  = new Yaf_Route_Rewrite(
                "/product/:name/:id/*",
                array(
                        'controller' => "product",
                ),
                array()
);

$router->addRoute("rewrite", $route);

var_dump($router->getRoute('rewrite')->assemble(
                        array(
                                ':name' => 'foo',
                                ':id' => 'bar',
                                ':tmpkey1' => 'tmpval1'
                        ),
                        array(
                                'tkey1' => 'tval1',
                                'tkey2' => 'tval2'
                             )
                        )
);

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(57) "/product/foo/bar/tmpkey1/tmpval1/?tkey1=tval1&tkey2=tval2"

Dönen Değerler

Yaf_Route_Rewrite
Yaf_Route_Rewrite::__construct
Yaf_Route_Rewrite


Yaf_Route_Rewrite constructor

Yaf_Route_Rewrite::assemble
Yaf_Route_Rewrite::route
Yaf_Route_Rewrite
PHP Manual

Yaf_Route_Rewrite::__construct

(Yaf >=1.0.0)

Yaf_Route_Rewrite::__construct — Yaf_Route_Rewrite constructor

Açıklama

public Yaf_Route_Rewrite::__construct ( string $match , array $route [, array $verify ] )

Değiştirgeler

match

A pattern, will be used to match a request uri, if it doesn't match, Yaf_Route_Rewrite will return FALSE.

You can use :name style to name segments matched, and use * to match the rest of the URL segments.

route

When the match pattern matches the request uri, Yaf_Route_Rewrite will use this to decide which module/controller/action is the destination.

Either of module/controller/action in this array is optional, if you don't assign a specific value, it will be routed to default.

verify

Dönen Değerler

Örnekler

Örnek 1 Yaf_Route_Rewrite()example

<?php
   /**
    * Add a rewrite route to Yaf_Router route stack
    */
    Yaf_Dispatcher::getInstance()->getRouter()->addRoute("name",
        new Yaf_Route_rewrite(
           "/product/:name/:id/*", //match request uri leading "/product"
           array(
               'controller' => "product",  //route to product controller,
           ),
        )
    );
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

/* for http://yourdomain.com/product/foo/22/foo/bar
 * route will result in following values:
 */
array(
  "controller" => "product",
  "module"     => "index", //(default)
  "action"     => "index", //(default)
)

/**
 * and request parameters:
 */
array(
  "name" => "foo",
  "id"   => 22,
  "foo"  => bar
)

Örnek 2 Yaf_Route_Rewrite()example

<?php
   /**
    * Add a rewrite route to Yaf_Router route stack by calling addconfig
    */
    $config = array(
        "name" => array(
           "type"  => "rewrite",        //Yaf_Route_Rewrite route
           "match" => "/user-list/:id", //match only /user/list/?/
           "route" => array(
               'controller' => "user",  //route to user controller,
               'action'     => "list",  //route to list action
           ),
        ),
    );
    Yaf_Dispatcher::getInstance()->getRouter()->addConfig(
        new Yaf_Config_Simple($config));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

/* for http://yourdomain.com/user-list/22
 * route will result in following values:
 */
array(
  "controller" => "user",
  "action"     => "list",
  "module"     => "index", //(default)
)

/**
 * and request parameters:
 */
array(
  "id"   => 22,
)

Örnek 3 Yaf_Route_Rewrite(as of 2.3.0)()example

<?php
   /**
    * Add a rewrite route use match result as m/c/a name
    */
    $config = array(
        "name" => array(
           "type"  => "rewrite",
           "match" => "/user-list/:a/:id", //match only /user-list/*
           "route" => array(
               'controller' => "user",   //route to user controller,
               'action'     => ":a",     //route to :a action
           ),
        ),
    );
    Yaf_Dispatcher::getInstance()->getRouter()->addConfig(
        new Yaf_Config_Simple($config));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

/* for http://yourdomain.com/user-list/list/22
 * route will result in following values:
 */
array(
  "controller" => "user",
  "action"     => "list",
  "module"     => "index", //(default)
)

/**
 * and request parameters:
 */
array(
  "id"   => 22,
)

Ayrıca Bakınız

  • Yaf_Router::addRoute() - Add new Route into Router
  • Yaf_Router::addConfig() - Add config-defined routes into Router
  • Yaf_Route_Static
  • Yaf_Route_Supervar
  • Yaf_Route_Simple
  • Yaf_Route_Regex
  • Yaf_Route_Map
Yaf_Route_Rewrite::assemble
Yaf_Route_Rewrite::route
Yaf_Route_Rewrite


The route purpose

Yaf_Route_Rewrite::__construct
Yaf_Router
Yaf_Route_Rewrite
PHP Manual

Yaf_Route_Rewrite::route

(Yaf >=1.0.0)

Yaf_Route_Rewrite::route — The route purpose

Açıklama

public bool Yaf_Route_Rewrite::route ( Yaf_Request_Abstract $request )

Değiştirgeler

request

Dönen Değerler

Yaf_Route_Rewrite::__construct
Yaf_Router
Yaf_Route_Rewrite


The Yaf_Router class

(Yaf >=1.0.0)

Giriş

Yaf_Router is the standard framework router. Routing is the process of taking a URI endpoint (that part of the URI which comes after the base URI: see Yaf_Request_Abstract::setBaseUri()) and decomposing it into parameters to determine which module, controller, and action of that controller should receive the request. This values of the module, controller, action and other parameters are packaged into a Yaf_Request_Abstract object which is then processed by Yaf_Dispatcher. Routing occurs only once: when the request is initially received and before the first controller is dispatched. Yaf_Router is designed to allow for mod_rewrite-like functionality using pure PHP structures. It is very loosely based on Ruby on Rails routing and does not require any prior knowledge of webserver URL rewriting. It is designed to work with a single Apache mod_rewrite rule (one of):

Örnek 1 Rewrite rule for Apache

RewriteEngine on
RewriteRule !\.(js|ico|gif|jpg|png|css|html)$ index.php
or (preferred):

Örnek 2 Rewrite rule for Apache

RewriteEngine On
RewriteCond %{REQUEST_FILENAME} -s [OR]
RewriteCond %{REQUEST_FILENAME} -l [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^.*$ - [NC,L]
RewriteRule ^.*$ index.php [NC,L]
If using Lighttpd, the following rewrite rule is valid:

Örnek 3 Rewrite rule for Lighttpd

url.rewrite-once = (
  ".*\?(.*)$" => "/index.php?$1",
  ".*\.(js|ico|gif|jpg|png|css|html)$" => "$0",
  "" => "/index.php"
)
If using Nginx, use the following rewrite rule:

Örnek 4 Rewrite rule for Nginx

server {
  listen ****;
  server_name  yourdomain.com;
  root   document_root;
  index  index.php index.html;

  if (!-e $request_filename) {
    rewrite ^/(.*)  /index.php/$1 last;
  }
}

Default route

Yaf_Router comes preconfigured with a default route Yaf_Route_Static, which will match URIs in the shape of controller/action. Additionally, a module name may be specified as the first path element, allowing URIs of the form module/controller/action. Finally, it will also match any additional parameters appended to the URI by default - controller/action/var1/value1/var2/value2.

Bilginize:

Module name must be defined in config, considering application.module="Index,Foo,Bar", in this case, only index, foo and bar can be considerd as a module name. if doesn't config, there is only one module named "Index".

Some examples of how such routes are matched:

Örnek 5 Yaf_Route_Static(default route)example

// Assuming the following configure:
$conf = array(
   "application" => array(
      "modules" => "Index,Blog",
   ),
);

Controller only:
http://example/news
    controller == news
Action only(when defined yaf.action_prefer=1 in php.ini)
    action  == news

Invalid module maps to controller name:
http://example/foo
    controller == foo

Module + controller:
http://example/blog/archive
    module     == blog
    controller == archive

Module + controller + action:
http://example/blog/archive/list
    module     == blog
    controller == archive
    action     == list

Module + controller + action + params:
http://example/blog/archive/list/sort/alpha/date/desc
    module     == blog
    controller == archive
    action     == list
    sort       == alpha
    date       == desc

Sınıf Sözdizimi

Yaf_Router {
/* Özellikler */
protected $_routes ;
protected $_current ;
/* Yöntemler */
public bool addConfig ( Yaf_Config_Abstract $config )
public bool addRoute ( string $name , Yaf_Route_Abstract $route )
public __construct ( void )
public string getCurrentRoute ( void )
public Yaf_Route_Interface getRoute ( string $name )
public mixed getRoutes ( void )
public bool route ( Yaf_Request_Abstract $request )
}

Özellikler

_routes

registered routes stack

_current

after routing phase, this indicated the name of which route is used to route current request. you can get this name by Yaf_Router::getCurrentRoute().

İçindekiler

  • Yaf_Router::addConfig — Add config-defined routes into Router
  • Yaf_Router::addRoute — Add new Route into Router
  • Yaf_Router::__construct — Yaf_Router constructor
  • Yaf_Router::getCurrentRoute — Get the effective route name
  • Yaf_Router::getRoute — Retrieve a route by name
  • Yaf_Router::getRoutes — Retrieve registered routes
  • Yaf_Router::route — The route purpose
Yaf_Route_Rewrite::route
Yaf_Router::addConfig
Yaf


Add config-defined routes into Router

Yaf_Router
Yaf_Router::addRoute
Yaf_Router
PHP Manual

Yaf_Router::addConfig

(Yaf >=1.0.0)

Yaf_Router::addConfig — Add config-defined routes into Router

Açıklama

public bool Yaf_Router::addConfig ( Yaf_Config_Abstract $config )

Add routes defined by configs into Yaf_Router's route stack

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

An Yaf_Config_Abstract instance, which should contains one or more valid route configs

Örnekler

Örnek 1 application.ini()example

;the order is very important, the prior one will be called first

;a rewrite route match request /product/*/*
routes.route_name.type="rewrite"
routes.route_name.match="/product/:name/:value"
routes.route_name.route.controller=product
routes.route_name.route.action=info

;a regex route match request /list/*/*
routes.route_name1.type="regex"
routes.route_name1.match="#^list/([^/]*)/([^/]*)#"
routes.route_name1.route.controller=Index
routes.route_name1.route.action=action
routes.route_name1.map.1=name
routes.route_name1.map.2=value

;a simple route match /**?c=controller&a=action&m=module
routes.route_name2.type="simple"
routes.route_name2.controller=c
routes.route_name2.module=m
routes.route_name2.action=a

;a simple router match /**?r=PATH_INFO
routes.route_name3.type="supervar"
routes.route_name3.varname=r

;a map route match any request to controller
routes.route_name4.type="map"
routes.route_name4.controllerPrefer=TRUE
routes.route_namer.delimiter="#!"

Örnek 2 Yaf_Dispatcher::autoConfig()example

<?php
class Bootstrap extends Yaf_Bootstrap_Abstract{
    public function _initConfig() {
        $config = Yaf_Application::app()->getConfig();
        Yaf_Registry::set("config", $config);
    }

    public function _initRoute(Yaf_Dispatcher $dispatcher) {
        $router = $dispatcher->getRouter();
        /**
         * we can add some pre-defined routes in application.ini
         */
        $router->addConfig(Yaf_Registry::get("config")->routes);
    }
?>

Ayrıca Bakınız

  • Yaf_Router::addRoute() - Add new Route into Router
  • Yaf_Route_Static
  • Yaf_Route_Supervar
  • Yaf_Route_Simple
  • Yaf_Route_Regex
  • Yaf_Route_Rewrite
  • Yaf_Route_Map
Yaf_Router
Yaf_Router::addRoute
Yaf_Router


Add new Route into Router

Yaf_Router::addConfig
Yaf_Router::__construct
Yaf_Router
PHP Manual

Yaf_Router::addRoute

(Yaf >=1.0.0)

Yaf_Router::addRoute — Add new Route into Router

Açıklama

public bool Yaf_Router::addRoute ( string $name , Yaf_Route_Abstract $route )

defaultly, Yaf_Router using a Yaf_Route_Static as its defualt route. you can add new routes into router's route stack by calling this method.

the newer route will be called before the older(route stack), and if the newer router return TRUE, the router process will be end. otherwise, the older one will be called.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Örnekler

Örnek 1 Yaf_Dispatcher::autoRender()example

<?php
class Bootstrap extends Yaf_Bootstrap_Abstract{
    public function _initConfig() {
        $config = Yaf_Application::app()->getConfig();
        Yaf_Registry::set("config", $config);
    }

    public function _initRoute(Yaf_Dispatcher $dispatcher) {
        $router = $dispatcher->getRouter();
        /**
         * we can add some pre-defined routes in application.ini
         */
        $router->addConfig(Yaf_Registry::get("config")->routes);
        /**
         * add a Rewrite route, then for a request uri:
         * http://***/product/list/22/foo
         * will be matched by this route, and result:
         *
         *  [module] =>
         *  [controller] => product
         *  [action] => info
         *  [method] => GET
         *  [params:protected] => Array
         *      (
         *          [id] => 22
         *          [name] => foo
         *      )
         *
         */
        $route  = new Yaf_Route_Rewrite(
            "/product/list/:id/:name",
            array(
                "controller" => "product",
                "action"     => "info",
            )
        );

        $router->addRoute('dummy', $route);
    }
?>

Ayrıca Bakınız

  • Yaf_Router::addConfig() - Add config-defined routes into Router
  • Yaf_Route_Static
  • Yaf_Route_Supervar
  • Yaf_Route_Simple
  • Yaf_Route_Regex
  • Yaf_Route_Rewrite
  • Yaf_Route_Map
Yaf_Router::addConfig
Yaf_Router::__construct
Yaf_Router


Yaf_Router constructor

Yaf_Router::addRoute
Yaf_Router::getCurrentRoute
Yaf_Router
PHP Manual

Yaf_Router::__construct

(Yaf >=1.0.0)

Yaf_Router::__construct — Yaf_Router constructor

Açıklama

public Yaf_Router::__construct ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Router::addRoute
Yaf_Router::getCurrentRoute
Yaf_Router


Get the effective route name

Yaf_Router::__construct
Yaf_Router::getRoute
Yaf_Router
PHP Manual

Yaf_Router::getCurrentRoute

(Yaf >=1.0.0)

Yaf_Router::getCurrentRoute — Get the effective route name

Açıklama

public string Yaf_Router::getCurrentRoute ( void )

Get the name of the route which is effective in the route process.

Bilginize:

You should call this method after the route process finished, since before that, this method will always return NULL.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

String, the name of the effective route.

Örnekler

Örnek 1 Register some routes in Bootstrap

<?php
class Bootstrap extends Yaf_Bootstrap_Abstract{
    public function _initConfig() {
        $config = Yaf_Application::app()->getConfig();
        Yaf_Registry::set("config", $config);
    }

    public function _initRoute(Yaf_Dispatcher $dispatcher) {
        $router = $dispatcher->getRouter();
        $rewrite_route  = new Yaf_Route_Rewrite(
            "/product/list/:page",
            array(
                "controller" => "product",
                "action"     => "list",
            )
        );

        $regex_route  = new Yaf_Route_Rewrite(
            "#^/product/info/(\d+)",
            array(
                "controller" => "product",
                "action"     => "info",
            )
        );

        $router->addRoute('rewrite', $rewrite_route)->addRoute('regex', $regex_route);
    }

    /**
     * register plugin
     */
    public function __initPlugins(Yaf_Dispatcher $dispatcher) {
        $dispatcher->registerPlugin(new DummyPlugin());
    }
?>

Örnek 2 plugin Dummy.php (under application.directory/plugins)

<?php
class DummyPlugin extends Yaf_Plugin_Abstract {

    public function routerShutdown(Yaf_Request_Abstract $request, Yaf_Response_Abstract $response) {
         var_dump(Yaf_Dispatcher::getInstance()->getRouter()->getCurrentRoute());
    }
?>
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

/* for http://yourdomain.com/product/list/1
 * DummyPlugin will output:
 */
string(7) "rewrite"

/* for http://yourdomain.com/product/info/34
 * DummyPlugin will output:
 */
string(5) "regex"

/* for other request URI
 * DummyPlugin will output:
 */
string(8) "_default"

Ayrıca Bakınız

  • Yaf_Bootstrap_Abstract
  • Yaf_Plugin_Abstract
  • Yaf_Router::addRoute() - Add new Route into Router
Yaf_Router::__construct
Yaf_Router::getRoute
Yaf_Router


Retrieve a route by name

Yaf_Router::getCurrentRoute
Yaf_Router::getRoutes
Yaf_Router
PHP Manual

Yaf_Router::getRoute

(Yaf >=1.0.0)

Yaf_Router::getRoute — Retrieve a route by name

Açıklama

public Yaf_Route_Interface Yaf_Router::getRoute ( string $name )

Retrieve a route by name, see also Yaf_Router::getCurrentRoute()

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Ayrıca Bakınız

  • Yaf_Bootstrap_Abstract
  • Yaf_Plugin_Abstract
  • Yaf_Router::addRoute() - Add new Route into Router
  • Yaf_Router::getCurrentRoute() - Get the effective route name
Yaf_Router::getCurrentRoute
Yaf_Router::getRoutes
Yaf_Router


Retrieve registered routes

Yaf_Router::getRoute
Yaf_Router::route
Yaf_Router
PHP Manual

Yaf_Router::getRoutes

(Yaf >=1.0.0)

Yaf_Router::getRoutes — Retrieve registered routes

Açıklama

public mixed Yaf_Router::getRoutes ( void )

Retrieve registered routes

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Router::getRoute
Yaf_Router::route
Yaf_Router


The route purpose

Yaf_Router::getRoutes
Yaf_Route_Simple
Yaf_Router
PHP Manual

Yaf_Router::route

(Yaf >=1.0.0)

Yaf_Router::route — The route purpose

Açıklama

public bool Yaf_Router::route ( Yaf_Request_Abstract $request )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Router::getRoutes
Yaf_Route_Simple
Yaf_Router


The Yaf_Route_Simple class

(Yaf >=1.0.0)

Giriş

Yaf_Route_Simple will match the query string, and find the route info.

all you need to do is tell Yaf_Route_Simple what key in the $_GET is module, what key is controller, and what key is action.

Yaf_Route_Simple::route() will always return TRUE, so it is important put Yaf_Route_Simple in the front of the Route stack, otherwise all the other routes will not be called.

Sınıf Sözdizimi

Yaf_Route_Simple implements Yaf_Route_Interface {
/* Özellikler */
protected $controller ;
protected $module ;
protected $action ;
/* Yöntemler */
public string assemble ( array $info [, array $query ] )
public __construct ( string $module_name , string $controller_name , string $action_name )
public bool route ( Yaf_Request_Abstract $request )
}

Özellikler

controller

module

action

İçindekiler

  • Yaf_Route_Simple::assemble — Assemble a url
  • Yaf_Route_Simple::__construct — Yaf_Route_Simple constructor
  • Yaf_Route_Simple::route — Route a request
Yaf_Router::route
Yaf_Route_Simple::assemble
Yaf


Assemble a url

Yaf_Route_Simple
Yaf_Route_Simple::__construct
Yaf_Route_Simple
PHP Manual

Yaf_Route_Simple::assemble

(Yaf >=2.3.0)

Yaf_Route_Simple::assemble — Assemble a url

Açıklama

public string Yaf_Route_Simple::assemble ( array $info [, array $query ] )

Assemble a url.

Değiştirgeler

info

query

Örnekler

Örnek 1 Yaf_Route_Simple::assemble()example

<?php

$router = new Yaf_Router();

$route  = new Yaf_Route_Simple('m', 'c', 'a');

$router->addRoute("simple", $route);

var_dump($router->getRoute('simple')->assemble(
            array(
                ':a' => 'yafaction',
                'tkey' => 'tval',
                ':c' => 'yafcontroller',
                ':m' => 'yafmodule'
                ),
            array(
                'tkey1' => 'tval1',
                'tkey2' => 'tval2'
                )
            ));

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(64) "?m=yafmodule&c=yafcontroller&a=yafaction&tkey1=tval1&tkey2=tval2"

Dönen Değerler

Yaf_Route_Simple
Yaf_Route_Simple::__construct
Yaf_Route_Simple


Yaf_Route_Simple constructor

Yaf_Route_Simple::assemble
Yaf_Route_Simple::route
Yaf_Route_Simple
PHP Manual

Yaf_Route_Simple::__construct

(Yaf >=1.0.0)

Yaf_Route_Simple::__construct — Yaf_Route_Simple constructor

Açıklama

public Yaf_Route_Simple::__construct ( string $module_name , string $controller_name , string $action_name )

Yaf_Route_Simple will get route info from query string. and the parameters of this constructor will used as keys while searching for the route info in $_GET.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

module_name

The key name of the module info.

controller_name

the key name of the controller info.

action_name

the key name of the action info.

Dönen Değerler

Always return TRUE.

Örnekler

Örnek 1 Yaf_Route_Simple::route()example

<?php
   $route = new Yaf_Route_Simple("m", "controller", "act");
   Yaf_Router::getInstance()->addRoute("simple", $route);
?>

Örnek 2 Yaf_Route_Simple::route()example

Request: http://yourdomain.com/path/?controller=a&act=b
=> module = default(index), controller = a, action = b

Request: http://yourdomain.com/path
=> module = default(index), controller = default(index), action = default(index)

Ayrıca Bakınız

  • Yaf_Route_Supervar::route() - The route purpose
  • Yaf_Route_Static::route() - Route a request
  • Yaf_Route_Regex::route() - The route purpose
  • Yaf_Route_Rewrite::route() - The route purpose
  • Yaf_Route_Map::route() - The route purpose
Yaf_Route_Simple::assemble
Yaf_Route_Simple::route
Yaf_Route_Simple


Route a request

Yaf_Route_Simple::__construct
Yaf_Route_Static
Yaf_Route_Simple
PHP Manual

Yaf_Route_Simple::route

(Yaf >=1.0.0)

Yaf_Route_Simple::route — Route a request

Açıklama

public bool Yaf_Route_Simple::route ( Yaf_Request_Abstract $request )

see Yaf_Route_Simple::__construct()

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

request

Dönen Değerler

always be TRUE

Ayrıca Bakınız

  • Yaf_Route_Supervar::route() - The route purpose
  • Yaf_Route_Static::route() - Route a request
  • Yaf_Route_Regex::route() - The route purpose
  • Yaf_Route_Rewrite::route() - The route purpose
  • Yaf_Route_Map::route() - The route purpose
Yaf_Route_Simple::__construct
Yaf_Route_Static
Yaf_Route_Simple


The Yaf_Route_Static class

(Yaf >=1.0.0)

Giriş

Defaultly, Yaf_Router only have a Yaf_Route_Static as its default route.

And Yaf_Route_Static is designed to handle the 80% requirement.

please *NOTE* that it is unecessary to instance a Yaf_Route_Static, also unecesary to add it into Yaf_Router's routes stack, since there is always be one in Yaf_Router's routes stack, and always be called at the last time.

Sınıf Sözdizimi

Yaf_Route_Static implements Yaf_Router {
/* Yöntemler */
public string assemble ( array $info [, array $query ] )
public void match ( string $uri )
public bool route ( Yaf_Request_Abstract $request )
}

İçindekiler

  • Yaf_Route_Static::assemble — Assemble a url
  • Yaf_Route_Static::match — The match purpose
  • Yaf_Route_Static::route — Route a request
Yaf_Route_Simple::route
Yaf_Route_Static::assemble
Yaf


Assemble a url

Yaf_Route_Static
Yaf_Route_Static::match
Yaf_Route_Static
PHP Manual

Yaf_Route_Static::assemble

(Yaf >=2.3.0)

Yaf_Route_Static::assemble — Assemble a url

Açıklama

public string Yaf_Route_Static::assemble ( array $info [, array $query ] )

Assemble a url.

Değiştirgeler

info

query

Örnekler

Örnek 1 Yaf_Route_Static::assemble()example

<?php

$router = new Yaf_Router();

$route  = new Yaf_Route_Static();

$router->addRoute("static", $route);

var_dump($router->getRoute('static')->assemble(
            array(
                ':a' => 'yafaction',
                'tkey' => 'tval',
                ':c' => 'yafcontroller',
                ':m' => 'yafmodule'
            ),
        )
);

var_dump($router->getRoute('static')->assemble(
            array(
                ':a' => 'yafaction',
                'tkey' => 'tval',
                ':c' => 'yafcontroller',
                ':m' => 'yafmodule'
            ),
            array(
                'tkey1' => 'tval1',
                'tkey2' => 'tval2'
            )
        )
);

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(%d) "/yafmodule/yafcontroller/yafaction"
string(%d) "/yafmodule/yafcontroller/yafaction?tkey1=tval1&tkey2=tval2"

Dönen Değerler

Yaf_Route_Static
Yaf_Route_Static::match
Yaf_Route_Static


The match purpose

Yaf_Route_Static::assemble
Yaf_Route_Static::route
Yaf_Route_Static
PHP Manual

Yaf_Route_Static::match

(Yaf >=1.0.0)

Yaf_Route_Static::match — The match purpose

Açıklama

public void Yaf_Route_Static::match ( string $uri )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

uri

Dönen Değerler

Yaf_Route_Static::assemble
Yaf_Route_Static::route
Yaf_Route_Static


Route a request

Yaf_Route_Static::match
Yaf_Route_Supervar
Yaf_Route_Static
PHP Manual

Yaf_Route_Static::route

(Yaf >=1.0.0)

Yaf_Route_Static::route — Route a request

Açıklama

public bool Yaf_Route_Static::route ( Yaf_Request_Abstract $request )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

request

Dönen Değerler

always be TRUE

Örnekler

Örnek 1 Yaf_Route_Static::route()example

// assuming there is only one module defined:Index
Request: http://yourdomain.com/a/b
=> module = index, controller=a, action=b

//assuming ap.action_prefer = On
Request: http://yourdomain.com/b
=> module = default(index), controller = default(index), action = b

//assuming ap.action_prefer = Off
Request: http://yourdomain.com/b
=> module = default(index), controller = b, action = default(index)

Request: http://yourdomain.com/a/b/foo/bar/test/a/id/4
=> module = default(index), controller = a, action = b, request parameters: foo = bar, test = a, id = 4

Ayrıca Bakınız

  • Yaf_Route_Supervar::route() - The route purpose
  • Yaf_Route_Simple::route() - Route a request
  • Yaf_Route_Regex::route() - The route purpose
  • Yaf_Route_Rewrite::route() - The route purpose
  • Yaf_Route_Map::route() - The route purpose
Yaf_Route_Static::match
Yaf_Route_Supervar
Yaf_Route_Static


The Yaf_Route_Supervar class

(Yaf >=1.0.0)

Giriş

Sınıf Sözdizimi

Yaf_Route_Supervar implements Yaf_Route_Interface {
/* Özellikler */
protected $_var_name ;
/* Yöntemler */
public string assemble ( array $info [, array $query ] )
public __construct ( string $supervar_name )
public bool route ( Yaf_Request_Abstract $request )
}

Özellikler

_var_name

İçindekiler

  • Yaf_Route_Supervar::assemble — Assemble a url
  • Yaf_Route_Supervar::__construct — The __construct purpose
  • Yaf_Route_Supervar::route — The route purpose
Yaf_Route_Static::route
Yaf_Route_Supervar::assemble
Yaf


Assemble a url

Yaf_Route_Supervar
Yaf_Route_Supervar::__construct
Yaf_Route_Supervar
PHP Manual

Yaf_Route_Supervar::assemble

(Yaf >=2.3.0)

Yaf_Route_Supervar::assemble — Assemble a url

Açıklama

public string Yaf_Route_Supervar::assemble ( array $info [, array $query ] )

Assemble a url.

Değiştirgeler

info

query

Örnekler

Örnek 1 Yaf_Route_Supervar::assemble()example

<?php

$router = new Yaf_Router();

$route  = new Yaf_Route_Supervar('r');

$router->addRoute("supervar", $route);

var_dump($router->getRoute('supervar')->assemble(
        array(
              ':a' => 'yafaction',
              'tkey' => 'tval',
              ':c' => 'yafcontroller',
              ':m' => 'yafmodule'
        ),
        array(
              'tkey1' => 'tval1',
              'tkey2' => 'tval2'
        )
));

try {
var_dump($router->getRoute('supervar')->assemble(
        array(
              ':a' => 'yafaction',
              'tkey' => 'tval',
              ':m' => 'yafmodule'
        ),
        array(
              'tkey1' => 'tval1',
              'tkey2' => 'tval2',
              1 => array(),
        )
));
} catch (Exception $e) {
    var_dump($e->getMessage());
}

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(%d) "?r=/yafmodule/yafcontroller/yafaction&tkey1=tval1&tkey2=tval2"
string(%d) "You need to specify the controller by ':c'"

Dönen Değerler

Yaf_Route_Supervar
Yaf_Route_Supervar::__construct
Yaf_Route_Supervar


The __construct purpose

Yaf_Route_Supervar::assemble
Yaf_Route_Supervar::route
Yaf_Route_Supervar
PHP Manual

Yaf_Route_Supervar::__construct

(Yaf >=1.0.0)

Yaf_Route_Supervar::__construct — The __construct purpose

Açıklama

public Yaf_Route_Supervar::__construct ( string $supervar_name )

Yaf_Route_Supervar is similar with Yaf_Route_Static, the difference is Yaf_Route_Supervar will look for path info in query string, and the parameter supervar_name is the key.

Değiştirgeler

supervar_name

The name of key.

Dönen Değerler

Örnekler

Örnek 1 Yaf_Route_Supervar()example

<?php
   /**
    * Add a supervar route to Yaf_Router route stack
    */
    Yaf_Dispatcher::getInstance()->getRouter()->addRoute("name",
        new Yaf_Route_Supervar("r"));
    );
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

/** for request: http://yourdomain.com/xx/oo/?r=/ctr/act/var/value
  * will result in following:
  */
  array (
    "module"   => index(default),
    "controller" => ctr,
    "action"     => act,
    "params"     => array(
          "var" => value,
     )
  )

Ayrıca Bakınız

  • Yaf_Router::addRoute() - Add new Route into Router
  • Yaf_Router::addConfig() - Add config-defined routes into Router
  • Yaf_Route_Static
  • Yaf_Route_Regex
  • Yaf_Route_Simple
  • Yaf_Route_Rewrite
  • Yaf_Route_Map
Yaf_Route_Supervar::assemble
Yaf_Route_Supervar::route
Yaf_Route_Supervar


The route purpose

Yaf_Route_Supervar::__construct
Yaf_Session
Yaf_Route_Supervar
PHP Manual

Yaf_Route_Supervar::route

(Yaf >=1.0.0)

Yaf_Route_Supervar::route — The route purpose

Açıklama

public bool Yaf_Route_Supervar::route ( Yaf_Request_Abstract $request )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

request

Dönen Değerler

If there is a key(which was defined in Yaf_Route_Supervar::__construct()) in $_GET, return TRUE. otherwise return FALSE.

Yaf_Route_Supervar::__construct
Yaf_Session
Yaf_Route_Supervar


The Yaf_Session class

(Yaf >=1.0.0)

Giriş

Sınıf Sözdizimi

Yaf_Session implements Iterator , ArrayAccess , Countable {
/* Özellikler */
protected static $_instance ;
protected $_session ;
protected $_started ;
/* Yöntemler */
private void __clone ( void )
private __construct ( void )
public void count ( void )
public void current ( void )
public void del ( string $name )
public void __get ( string $name )
public static void getInstance ( void )
public void has ( string $name )
public void __isset ( string $name )
public void key ( void )
public void next ( void )
public void offsetExists ( string $name )
public void offsetGet ( string $name )
public void offsetSet ( string $name , string $value )
public void offsetUnset ( string $name )
public void rewind ( void )
public void __set ( string $name , string $value )
private void __sleep ( void )
public void start ( void )
public void __unset ( string $name )
public void valid ( void )
private void __wakeup ( void )
}

Özellikler

_instance

_session

_started

İçindekiler

  • Yaf_Session::__clone — The __clone purpose
  • Yaf_Session::__construct — Constructor of Yaf_Session
  • Yaf_Session::count — The count purpose
  • Yaf_Session::current — The current purpose
  • Yaf_Session::del — The del purpose
  • Yaf_Session::__get — The __get purpose
  • Yaf_Session::getInstance — The getInstance purpose
  • Yaf_Session::has — The has purpose
  • Yaf_Session::__isset — The __isset purpose
  • Yaf_Session::key — The key purpose
  • Yaf_Session::next — The next purpose
  • Yaf_Session::offsetExists — The offsetExists purpose
  • Yaf_Session::offsetGet — The offsetGet purpose
  • Yaf_Session::offsetSet — The offsetSet purpose
  • Yaf_Session::offsetUnset — The offsetUnset purpose
  • Yaf_Session::rewind — The rewind purpose
  • Yaf_Session::__set — The __set purpose
  • Yaf_Session::__sleep — The __sleep purpose
  • Yaf_Session::start — The start purpose
  • Yaf_Session::__unset — The __unset purpose
  • Yaf_Session::valid — The valid purpose
  • Yaf_Session::__wakeup — The __wakeup purpose
Yaf_Route_Supervar::route
Yaf_Session::__clone
Yaf


The __clone purpose

Yaf_Session
Yaf_Session::__construct
Yaf_Session
PHP Manual

Yaf_Session::__clone

(Yaf >=1.0.0)

Yaf_Session::__clone — The __clone purpose

Açıklama

private void Yaf_Session::__clone ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Session
Yaf_Session::__construct
Yaf_Session


Constructor of Yaf_Session

Yaf_Session::__clone
Yaf_Session::count
Yaf_Session
PHP Manual

Yaf_Session::__construct

(Yaf >=1.0.0)

Yaf_Session::__construct — Constructor of Yaf_Session

Açıklama

private Yaf_Session::__construct ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Session::__clone
Yaf_Session::count
Yaf_Session


The count purpose

Yaf_Session::__construct
Yaf_Session::current
Yaf_Session
PHP Manual

Yaf_Session::count

(Yaf >=1.0.0)

Yaf_Session::count — The count purpose

Açıklama

public void Yaf_Session::count ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Session::__construct
Yaf_Session::current
Yaf_Session


The current purpose

Yaf_Session::count
Yaf_Session::del
Yaf_Session
PHP Manual

Yaf_Session::current

(Yaf >=1.0.0)

Yaf_Session::current — The current purpose

Açıklama

public void Yaf_Session::current ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Session::count
Yaf_Session::del
Yaf_Session


The del purpose

Yaf_Session::current
Yaf_Session::__get
Yaf_Session
PHP Manual

Yaf_Session::del

(Yaf >=1.0.0)

Yaf_Session::del — The del purpose

Açıklama

public void Yaf_Session::del ( string $name )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

name

Dönen Değerler

Yaf_Session::current
Yaf_Session::__get
Yaf_Session


The __get purpose

Yaf_Session::del
Yaf_Session::getInstance
Yaf_Session
PHP Manual

Yaf_Session::__get

(Yaf >=1.0.0)

Yaf_Session::__get — The __get purpose

Açıklama

public void Yaf_Session::__get ( string $name )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

name

Dönen Değerler

Yaf_Session::del
Yaf_Session::getInstance
Yaf_Session


The getInstance purpose

Yaf_Session::__get
Yaf_Session::has
Yaf_Session
PHP Manual

Yaf_Session::getInstance

(Yaf >=1.0.0)

Yaf_Session::getInstance — The getInstance purpose

Açıklama

public static void Yaf_Session::getInstance ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Session::__get
Yaf_Session::has
Yaf_Session


The has purpose

Yaf_Session::getInstance
Yaf_Session::__isset
Yaf_Session
PHP Manual

Yaf_Session::has

(Yaf >=1.0.0)

Yaf_Session::has — The has purpose

Açıklama

public void Yaf_Session::has ( string $name )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

name

Dönen Değerler

Yaf_Session::getInstance
Yaf_Session::__isset
Yaf_Session


The __isset purpose

Yaf_Session::has
Yaf_Session::key
Yaf_Session
PHP Manual

Yaf_Session::__isset

(Yaf >=1.0.0)

Yaf_Session::__isset — The __isset purpose

Açıklama

public void Yaf_Session::__isset ( string $name )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

name

Dönen Değerler

Yaf_Session::has
Yaf_Session::key
Yaf_Session


The key purpose

Yaf_Session::__isset
Yaf_Session::next
Yaf_Session
PHP Manual

Yaf_Session::key

(Yaf >=1.0.0)

Yaf_Session::key — The key purpose

Açıklama

public void Yaf_Session::key ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Session::__isset
Yaf_Session::next
Yaf_Session


The next purpose

Yaf_Session::key
Yaf_Session::offsetExists
Yaf_Session
PHP Manual

Yaf_Session::next

(Yaf >=1.0.0)

Yaf_Session::next — The next purpose

Açıklama

public void Yaf_Session::next ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Session::key
Yaf_Session::offsetExists
Yaf_Session


The offsetExists purpose

Yaf_Session::next
Yaf_Session::offsetGet
Yaf_Session
PHP Manual

Yaf_Session::offsetExists

(Yaf >=1.0.0)

Yaf_Session::offsetExists — The offsetExists purpose

Açıklama

public void Yaf_Session::offsetExists ( string $name )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

name

Dönen Değerler

Yaf_Session::next
Yaf_Session::offsetGet
Yaf_Session


The offsetGet purpose

Yaf_Session::offsetExists
Yaf_Session::offsetSet
Yaf_Session
PHP Manual

Yaf_Session::offsetGet

(Yaf >=1.0.0)

Yaf_Session::offsetGet — The offsetGet purpose

Açıklama

public void Yaf_Session::offsetGet ( string $name )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

name

Dönen Değerler

Yaf_Session::offsetExists
Yaf_Session::offsetSet
Yaf_Session


The offsetSet purpose

Yaf_Session::offsetGet
Yaf_Session::offsetUnset
Yaf_Session
PHP Manual

Yaf_Session::offsetSet

(Yaf >=1.0.0)

Yaf_Session::offsetSet — The offsetSet purpose

Açıklama

public void Yaf_Session::offsetSet ( string $name , string $value )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

name

value

Dönen Değerler

Yaf_Session::offsetGet
Yaf_Session::offsetUnset
Yaf_Session


The offsetUnset purpose

Yaf_Session::offsetSet
Yaf_Session::rewind
Yaf_Session
PHP Manual

Yaf_Session::offsetUnset

(Yaf >=1.0.0)

Yaf_Session::offsetUnset — The offsetUnset purpose

Açıklama

public void Yaf_Session::offsetUnset ( string $name )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

name

Dönen Değerler

Yaf_Session::offsetSet
Yaf_Session::rewind
Yaf_Session


The rewind purpose

Yaf_Session::offsetUnset
Yaf_Session::__set
Yaf_Session
PHP Manual

Yaf_Session::rewind

(Yaf >=1.0.0)

Yaf_Session::rewind — The rewind purpose

Açıklama

public void Yaf_Session::rewind ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Session::offsetUnset
Yaf_Session::__set
Yaf_Session


The __set purpose

Yaf_Session::rewind
Yaf_Session::__sleep
Yaf_Session
PHP Manual

Yaf_Session::__set

(Yaf >=1.0.0)

Yaf_Session::__set — The __set purpose

Açıklama

public void Yaf_Session::__set ( string $name , string $value )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

name

value

Dönen Değerler

Yaf_Session::rewind
Yaf_Session::__sleep
Yaf_Session


The __sleep purpose

Yaf_Session::__set
Yaf_Session::start
Yaf_Session
PHP Manual

Yaf_Session::__sleep

(Yaf >=1.0.0)

Yaf_Session::__sleep — The __sleep purpose

Açıklama

private void Yaf_Session::__sleep ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Session::__set
Yaf_Session::start
Yaf_Session


The start purpose

Yaf_Session::__sleep
Yaf_Session::__unset
Yaf_Session
PHP Manual

Yaf_Session::start

(Yaf >=1.0.0)

Yaf_Session::start — The start purpose

Açıklama

public void Yaf_Session::start ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Session::__sleep
Yaf_Session::__unset
Yaf_Session


The __unset purpose

Yaf_Session::start
Yaf_Session::valid
Yaf_Session
PHP Manual

Yaf_Session::__unset

(Yaf >=1.0.0)

Yaf_Session::__unset — The __unset purpose

Açıklama

public void Yaf_Session::__unset ( string $name )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

name

Dönen Değerler

Yaf_Session::start
Yaf_Session::valid
Yaf_Session


The valid purpose

Yaf_Session::__unset
Yaf_Session::__wakeup
Yaf_Session
PHP Manual

Yaf_Session::valid

(Yaf >=1.0.0)

Yaf_Session::valid — The valid purpose

Açıklama

public void Yaf_Session::valid ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Session::__unset
Yaf_Session::__wakeup
Yaf_Session


The __wakeup purpose

Yaf_Session::valid
Yaf_Exception
Yaf_Session
PHP Manual

Yaf_Session::__wakeup

(Yaf >=1.0.0)

Yaf_Session::__wakeup — The __wakeup purpose

Açıklama

private void Yaf_Session::__wakeup ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Session::valid
Yaf_Exception
Yaf_Session


The Yaf_Exception class

(Yaf >=1.0.0)

Giriş

Sınıf Sözdizimi

Yaf_Exception extends Exception {
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Yöntemler */
public __construct ( void )
public void getPrevious ( void )
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}

İçindekiler

  • Yaf_Exception::__construct — The __construct purpose
  • Yaf_Exception::getPrevious — The getPrevious purpose
Yaf_Session::__wakeup
Yaf_Exception::__construct
Yaf


The __construct purpose

Yaf_Exception
Yaf_Exception::getPrevious
Yaf_Exception
PHP Manual

Yaf_Exception::__construct

(Yaf >=1.0.0)

Yaf_Exception::__construct — The __construct purpose

Açıklama

public Yaf_Exception::__construct ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Exception
Yaf_Exception::getPrevious
Yaf_Exception


The getPrevious purpose

Yaf_Exception::__construct
Yaf_Exception_TypeError
Yaf_Exception
PHP Manual

Yaf_Exception::getPrevious

(Yaf >=1.0.0)

Yaf_Exception::getPrevious — The getPrevious purpose

Açıklama

public void Yaf_Exception::getPrevious ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yaf_Exception::__construct
Yaf_Exception_TypeError
Yaf_Exception


The Yaf_Exception_TypeError class

(Yaf >=1.0.0)

Giriş

Sınıf Sözdizimi

Yaf_Exception_TypeError extends Yaf_Exception {
/* Özellikler */
/* Yöntemler */
/* Miras alınan yöntemler */
public Yaf_Exception::__construct ( void )
public void Yaf_Exception::getPrevious ( void )
}
Yaf_Exception::getPrevious
Yaf_Exception_StartupError
Yaf


The Yaf_Exception_StartupError class

(Yaf >=1.0.0)

Giriş

Sınıf Sözdizimi

Yaf_Exception_StartupError extends Yaf_Exception {
/* Özellikler */
/* Yöntemler */
/* Miras alınan yöntemler */
public Yaf_Exception::__construct ( void )
public void Yaf_Exception::getPrevious ( void )
}
Yaf_Exception_TypeError
Yaf_Exception_DispatchFailed
Yaf


The Yaf_Exception_DispatchFailed class

(Yaf >=1.0.0)

Giriş

Sınıf Sözdizimi

Yaf_Exception_DispatchFailed extends Yaf_Exception {
/* Özellikler */
/* Yöntemler */
/* Miras alınan yöntemler */
public Yaf_Exception::__construct ( void )
public void Yaf_Exception::getPrevious ( void )
}
Yaf_Exception_StartupError
Yaf_Exception_RouterFailed
Yaf


The Yaf_Exception_RouterFailed class

(Yaf >=1.0.0)

Giriş

Sınıf Sözdizimi

Yaf_Exception_RouterFailed extends Yaf_Exception {
/* Özellikler */
/* Yöntemler */
/* Miras alınan yöntemler */
public Yaf_Exception::__construct ( void )
public void Yaf_Exception::getPrevious ( void )
}
Yaf_Exception_DispatchFailed
Yaf_Exception_LoadFailed
Yaf


The Yaf_Exception_LoadFailed class

(Yaf >=1.0.0)

Giriş

Sınıf Sözdizimi

Yaf_Exception_LoadFailed extends Yaf_Exception {
/* Özellikler */
/* Yöntemler */
/* Miras alınan yöntemler */
public Yaf_Exception::__construct ( void )
public void Yaf_Exception::getPrevious ( void )
}
Yaf_Exception_RouterFailed
Yaf_Exception_LoadFailed_Module
Yaf


The Yaf_Exception_LoadFailed_Module class

(Yaf >=1.0.0)

Giriş

Sınıf Sözdizimi

Yaf_Exception_LoadFailed_Module extends Yaf_Exception_LoadFailed {
/* Özellikler */
/* Yöntemler */
/* Miras alınan yöntemler */
public Yaf_Exception::__construct ( void )
public void Yaf_Exception::getPrevious ( void )
}
Yaf_Exception_LoadFailed
Yaf_Exception_LoadFailed_Controller
Yaf


The Yaf_Exception_LoadFailed_Controller class

(Yaf >=1.0.0)

Giriş

Sınıf Sözdizimi

Yaf_Exception_LoadFailed_Controller extends Yaf_Exception_LoadFailed {
/* Özellikler */
/* Yöntemler */
/* Miras alınan yöntemler */
public Yaf_Exception::__construct ( void )
public void Yaf_Exception::getPrevious ( void )
}
Yaf_Exception_LoadFailed_Module
Yaf_Exception_LoadFailed_Action
Yaf


The Yaf_Exception_LoadFailed_Action class

(Yaf >=1.0.0)

Giriş

Sınıf Sözdizimi

Yaf_Exception_LoadFailed_Action extends Yaf_Exception_LoadFailed {
/* Özellikler */
/* Yöntemler */
/* Miras alınan yöntemler */
public Yaf_Exception::__construct ( void )
public void Yaf_Exception::getPrevious ( void )
}
Yaf_Exception_LoadFailed_Controller
Yaf_Exception_LoadFailed_View
Yaf


The Yaf_Exception_LoadFailed_View class

(Yaf >=1.0.0)

Giriş

Sınıf Sözdizimi

Yaf_Exception_LoadFailed_View extends Yaf_Exception_LoadFailed {
/* Özellikler */
/* Yöntemler */
/* Miras alınan yöntemler */
public Yaf_Exception::__construct ( void )
public void Yaf_Exception::getPrevious ( void )
}
Yaf_Exception_LoadFailed_Action
Taint
Yaf


Taint

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • More Details
    • Functions and Statements which will spread the tainted mark of a tainted string
    • Functions and statements which will check tainted string
    • Functions which untaint the tainted string
  • Taint İşlevleri
    • is_tainted — Checks whether a string is tainted
    • taint — Taint a string
    • untaint — Untaint strings
Yaf_Exception_LoadFailed_View
Giriş
Diğer Temel Eklentiler


Giriş

Taint is an extension, which is used for detecting XSS codes(tainted string). And also can be used to spot sql injection vulnerabilities, and shell inject, etc.

When taint is enabled, if you pass a tainted string (comes from $_GET, $_POST or $_COOKIE) to some functions, taint will warn you about that.

Örnek 1 Taint()example

<?php
$a = trim($_GET['a']);

$file_name = '/tmp' .  $a;
$output    = "Welcome, {$a} !!!";
$var       = "output";
$sql       = "Select *  from " . $a;
$sql      .= "ooxx";

echo $output;

print $$var;

include($file_name);

mysql_query($sql);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Warning: main() [function.echo]: Attempt to echo a string that might be tainted

Warning: main() [function.echo]: Attempt to print a string that might be tainted

Warning: include() [function.include]: File path contains data that might be tainted

Warning: mysql_query() [function.mysql-query]: SQL statement contains data that might be tainted
Taint
Yapılandırma/Kurulum
Taint


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Taint


Kurulum

Bu » PECL eklentisi PHP ile gelmez.

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/taint.

Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Taint Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
taint.enable | 0 | its PHP_INI_SYS value |
taint.error_level | E_WARNING | its PHP_INI_ALL value |

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

taint.enable integer

Whether enable the taint.

taint.error_level integer

the error type which taint will report as when taint find a tainted string.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Özkaynak Türleri

Bu eklentinin tanımlı hiçbir özkaynak türü yoktur.

Çalışma Anı Yapılandırması
More Details
Yapılandırma/Kurulum


More Details

İçindekiler

  • Functions and Statements which will spread the tainted mark of a tainted string
  • Functions and statements which will check tainted string
  • Functions which untaint the tainted string
Özkaynak Türleri
Functions and Statements which will spread the tainted mark of a tainted string
Taint


Functions and Statements which will spread the tainted mark of a tainted string

Function/Statement | Since
= (assign) | 0.1.0
. (concat) | 0.1.0
"{$var}" (variable substitution) | 0.1.0
.= (assign concat) | 0.1.0
strval | 0.3.0
explode | 0.3.0
implode | 0.3.0
sprintf | 0.3.0
vsprintf | 0.3.0
trim | 0.4.0
rtrim | 0.4.0
ltrim | 0.4.0

More Details
Functions and statements which will check tainted string
More Details


Functions and statements which will check tainted string

Function/Statement | Since
Basic statments
eval | 0.1.0
include/include_once | 0.1.0
require/require_once | 0.1.0
Outputing Functions
echo | 0.1.0
print | 0.1.0
printf | 0.1.0
file_put_contents | 0.1.0
File System Functions
fopen | 0.2.0
opendir | 0.2.0
basename | 0.2.0
dirname | 0.2.0
file | 0.2.0
pathinfo | 0.2.0
Database relevant Functions
mysql_query | 0.2.0
mysqli_query/MySQLi::query | 0.2.0
sqlite_query/SqliteDataBase::query | 0.3.0
sqlite_single_query/SqliteDataBase::singleQuery | 0.3.0
oci_parse | 0.3.0
PDO::query | 0.3.0
PDO::prepare | 0.3.0
Command Line relevant Functions
system | 0.1.0
exec | 0.1.0
proc_open | 0.1.0
passthru | 0.1.0
shell_exec | 0.3.0

Functions and Statements which will spread the tainted mark of a tainted string
Functions which untaint the tainted string
More Details


Functions which untaint the tainted string

Function | Since
addslashes | 0.1.0
addcslashes | 0.1.0
htmlspecialchars | 0.1.0
htmlentities | 0.1.0
escapeshellcmd | 0.1.0
mysql_escape_string | 0.1.0
mysql_real_escape_string | 0.1.0
mysqli_escape_string/MySQLi::escape_string | 0.1.0
mysqli_real_escape_string/MySQLi::real_escape_string | 0.1.0
sqlite_escape_string/SqliteDataBase::escapeString | 0.3.0
PDO::quote | 0.3.0

Functions and statements which will check tainted string
Taint İşlevleri
More Details


Taint İşlevleri

İçindekiler

  • is_tainted — Checks whether a string is tainted
  • taint — Taint a string
  • untaint — Untaint strings
Functions which untaint the tainted string
is_tainted
Taint


Checks whether a string is tainted

Taint İşlevleri
taint
Taint İşlevleri
PHP Manual

is_tainted

(PECL taint >=0.1.0)

is_tainted — Checks whether a string is tainted

Açıklama

bool is_tainted ( string $string )

Checks whether a string is tainted

Değiştirgeler

string

Dönen Değerler

Return TRUE if the string is tainted, FALSE otherwise.

Taint İşlevleri
taint
Taint İşlevleri


Taint a string

is_tainted
untaint
Taint İşlevleri
PHP Manual

taint

(PECL taint >=0.1.0)

taint — Taint a string

Açıklama

bool taint ( string &$string [, string $... ] )

Make a string tainted. This is used for testing purpose only.

Değiştirgeler

string

...

Dönen Değerler

Return TRUE if the transformation is done. Always return TRUE if the taint extension is not enabled.

is_tainted
untaint
Taint İşlevleri


Untaint strings

taint
Diğer Hizmetler
Taint İşlevleri
PHP Manual

untaint

(PECL taint >=0.1.0)

untaint — Untaint strings

Açıklama

bool untaint ( string &$string [, string $... ] )

Untaint strings

Değiştirgeler

string

...

Dönen Değerler

taint
Diğer Hizmetler
Taint İşlevleri


Diğer Hizmetler

  • chdb — Constant hash database
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • chdb — The chdb class
    • chdb İşlevleri
  • cURL — İstemci URL Kütüphanesi
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • cURL İşlevleri
    • CURLFile — The CURLFile class
  • Event
    • Giriş
    • Yapılandırma/Kurulum
    • Örnekler
    • Event flags
    • About event persistence
    • Event callbacks
    • Constructing signal events
    • Event — The Event class
    • EventBase — The EventBase class
    • EventBuffer — The EventBuffer class
    • EventBufferEvent — The EventBufferEvent class
    • About buffer event callbacks
    • EventConfig — The EventConfig class
    • EventDnsBase — The EventDnsBase class
    • EventHttp — The EventHttp class
    • EventHttpConnection — The EventHttpConnection class
    • EventHttpRequest — The EventHttpRequest class
    • EventListener — The EventListener class
    • EventSslContext — The EventSslContext class
    • EventUtil — The EventUtil class
  • FAM — File Alteration Monitor
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • FAM İşlevleri
  • FTP
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • FTP İşlevleri
  • Gearman
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • GearmanClient — The GearmanClient class
    • GearmanJob — The GearmanJob class
    • GearmanTask — The GearmanTask class
    • GearmanWorker — The GearmanWorker class
    • GearmanException — The GearmanException class
  • Gopher — Net Gopher
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • Gopher İşlevleri
  • Gupnp
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • Gupnp İşlevleri
  • Hyperwave API
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Integration with Apache
    • Hyperwave API İşlevleri
  • LDAP — Lightweight Directory Access Protocol
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Using the PHP LDAP calls
    • Örnekler
    • LDAP İşlevleri
  • Memcache
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • Memcache — The Memcache class
    • Memcache İşlevleri
  • Memcached
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Expiration Times
    • Callbacks
    • Sessions support
    • Memcached — The Memcached class
    • MemcachedException — The MemcachedException class
  • mqseries
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • mqseries İşlevleri
  • Ağ
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Ağ İşlevleri
  • RRD — RRDtool
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • RRD İşlevleri
    • RRDCreator — The RRDCreator class
    • RRDGraph — The RRDGraph class
    • RRDUpdater — The RRDUpdater class
  • SAM — Simple Asynchronous Messaging
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • SAM İşlevleri
  • SNMP
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • SNMP İşlevleri
    • SNMP — The SNMP class
    • SNMPException — The SNMPException class
  • Soketler
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • Soket Hataları
    • Soket İşlevleri
  • SSH2 — Güvenli Kabuk 2
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • SSH2 İşlevleri
  • Stomp — Stomp Client
    • Giriş
    • Yapılandırma/Kurulum
    • Örnekler
    • Stomp İşlevleri
    • Stomp — The Stomp class
    • StompFrame — The StompFrame class
    • StompException — The StompException class
  • SVM — Support Vector Machine
    • Giriş
    • Yapılandırma/Kurulum
    • Örnekler
    • SVM — The SVM class
    • SVMModel — The SVMModel class
  • SVN — Subversion
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • SVN İşlevleri
  • TCP — TCP Sarmalayıcıları
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • TCP İşlevleri
  • Varnish
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • VarnishAdmin — The VarnishAdmin class
    • VarnishStat — The VarnishStat class
    • VarnishLog — The VarnishLog class
  • YAZ
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • YAZ İşlevleri
  • YP/NIS
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • YP/NIS İşlevleri
  • 0MQ messaging — ZMQ
    • Giriş
    • Yapılandırma/Kurulum
    • ZMQ — The ZMQ class
    • ZMQContext — The ZMQContext class
    • ZMQSocket — The ZMQSocket class
    • ZMQPoll — The ZMQPoll class
    • ZMQDevice — The ZMQDevice class
  • ZooKeeper
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • ZooKeeper — The ZooKeeper class
untaint
chdb
İşlev Başvuru Kılavuzu


Constant hash database

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
  • chdb — The chdb class
    • chdb::__construct — Creates a chdb instance
    • chdb::get — Gets the value associated with a key
  • chdb İşlevleri
    • chdb_create — Creates a chdb file
Diğer Hizmetler
Giriş
Diğer Hizmetler


Giriş

CHDB (constant hash database) is a fast key-value database for constant data, realized by using a memory-mapped file and thus providing the following functionalities:

  • Extremely fast initial load, regardless of the size of the database.

  • Only the pages of the file which are actually used are loaded from the disk.

  • Once a page is loaded it is shared across multiple processes.

  • Loaded pages are cached across multiple requests and even process recycling.

A typical use of CHDB is as a faster alternative to defining many PHP constants.

CHDB is internally implemented as a hash-table using a » perfect hashing function, thus guaranteeing worst case O(1) lookup time.

chdb
Yapılandırma/Kurulum
chdb


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
chdb


Gereksinimler

This module uses » cmph (version 0.9) for providing the » perfect hashing function.

cmph 0.9 is required to install this module.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/chdb

» cmph (version 0.9) is required for installing this extension. If cmph is installed in a non-standard directory, use the --with-libcmph-dir=DIR switch, where DIR is the cmph install prefix.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
Örnekler
chdb


Örnekler

Örnek 1 Creating a chdb file

<?php

$data = array(
    'key1' => 'value1',
    'key2' => 'value2',
    // ...
);
chdb_create('data.chdb', $data);

?>

The above example will generate a chdb file named data.chdb and containing the key-value pairs defined in $data.

Örnek 2 Loading and looking up a chdb file

<?php

$chdb = new chdb('data.chdb');
$value1 = $chdb->get('key1');
$value2 = $chdb->get('key2');

echo $value1, PHP_EOL;
echo $value2, PHP_EOL;

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

value1
value2
Öntanımlı Sabitler
chdb
chdb


The chdb class

(PECL chdb >= 0.1.0)

Giriş

Represents a loaded chdb file.

Sınıf Sözdizimi

chdb {
/* Methods */
public __construct ( string $pathname )
public string get ( string $key )
}

İçindekiler

  • chdb::__construct — Creates a chdb instance
  • chdb::get — Gets the value associated with a key
Örnekler
chdb::__construct
chdb


Creates a chdb instance

chdb
chdb::get
chdb
PHP Manual

chdb::__construct

(PECL chdb >= 0.1.0)

chdb::__construct — Creates a chdb instance

Açıklama

public chdb::__construct ( string $pathname )

Loads a chdb file, by mapping it into memory.

Bilginize:

While some validity checks are performed on the specified file, they are mostly there to avoid the possibility of common mistakes (for example, loading a file which is not a chdb database, or that is somehow incompatible with the current system). A maliciously crafted chdb file can thus be dangerous if loaded, so chdb files should be trusted and treated with the same security protections used for PHP shared libraries.

Değiştirgeler

pathname

The name of the file to load.

Hatalar/İstisnalar

Throws an exception in case the chdb file hasn't been successfully loaded.

Bilginize:

A valid chdb file might fail to load in case it was created on an architecture with a different endianness, with a different version of chdb, or if the file is too big to be mapped into memory (mostly in case of huge files and 32-bit architectures). In these cases the load will fail by throwing an exception, but otherwise not performing any illegal operation.

chdb
chdb::get
chdb


Gets the value associated with a key

chdb::__construct
chdb İşlevleri
chdb
PHP Manual

chdb::get

(PECL chdb >= 0.1.0)

chdb::get — Gets the value associated with a key

Açıklama

public string chdb::get ( string $key )

Gets the value associated with a key from a chdb database.

Değiştirgeler

key

The key for which to get the value.

Dönen Değerler

Returns a string containing the value associated with the given key, or NULL if not found.

Örnekler

Örnek 1 chdb::get() example

<?php

$data = array(
    'key1' => 'value1',
    'key2' => 'value2',
    // ...
);
chdb_create('data.chdb', $data);

$chdb = new chdb('data.chdb');
$value1 = $chdb->get('key1');
$value2 = $chdb->get('key2');

echo $value1, PHP_EOL;
echo $value2, PHP_EOL;

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

value1
value2
chdb::__construct
chdb İşlevleri
chdb


chdb İşlevleri

İçindekiler

  • chdb_create — Creates a chdb file
chdb::get
chdb_create
chdb


Creates a chdb file

chdb İşlevleri
cURL
chdb İşlevleri
PHP Manual

chdb_create

(PECL chdb >= 0.1.0)

chdb_create — Creates a chdb file

Açıklama

bool chdb_create ( string $pathname , array $data )

chdb_create() creates a chdb file containing the specified key-value pairs.

Bilginize:

chdb files are not portable across little-endian and big-endian environments. Except for that, they are portable across different architectures. Also compatibility across different versions of chdb is not guaranteed.

Değiştirgeler

pathname

The name of the file to create.

If a file with the same name already exists, it is overwritten.

data

An array containing the key-value pairs to store in the chdb file.

Keys and values are converted to strings before being written to the file, as chdb only support the string type. Note that binary strings are supported as well, both as keys and values.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

Throws an exception in case the chdb file hasn't been successfully created.

Örnekler

Örnek 1 chdb_create() example

<?php

$data = array(
    'key1' => 'value1',
    'key2' => 'value2',
    // ...
);
chdb_create('data.chdb', $data);

?>

The above example will generate a chdb file named data.chdb and containing the key-value pairs defined in $data.

chdb İşlevleri
cURL
chdb İşlevleri


İstemci URL Kütüphanesi

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
    • Örnekler
  • cURL İşlevleri
    • curl_close — cURL oturumunu sonlandırır
    • curl_copy_handle — Bir cURL tanıtıcısını tüm tercihleriyle kopyalar
    • curl_errno — Belirtilen oturumdaki son hatanın kodunu döndürür
    • curl_error — Belirtilen oturumdaki son hatayı içeren bir dizge döndürür
    • curl_escape — URL encodes the given string
    • curl_exec — Bir cURL oturumunu işleme sokar
    • curl_file_create — Create a CURLFile object
    • curl_getinfo — Belli bir oturum ile ilgili bilgi döndürür
    • curl_init — Bir cURL oturumunu ilklendirir
    • curl_multi_add_handle — Tekil cURL tanıtıcısını çoklu cURL tanıtıcısına ekler
    • curl_multi_close — Çoklu tanıtıcıyı kapatır
    • curl_multi_exec — Geçerli cURL tanıtıcısının alt bağlantılarını çalıştırır
    • curl_multi_getcontent — CURLOPT_RETURNTRANSFER etkinse bir cURL tanıtıcısının içeriği döner
    • curl_multi_info_read — Geçerli oturum hakkında bilgi döndürür
    • curl_multi_init — Yeni bir çoklu cURL tanıtıcısı döndürür
    • curl_multi_remove_handle — Bir tekil tanıtıcıyı bir çoklu tanıtıcıdan siler
    • curl_multi_select — Çoklu cURL bağlantısında bir etkinlik olsun diye bekler
    • curl_multi_setopt — Set an option for the cURL multi handle
    • curl_multi_strerror — Return string describing error code
    • curl_pause — Pause and unpause a connection
    • curl_reset — Reset all options of a libcurl session handle
    • curl_setopt_array — Belirtilen cURL oturumuna çok sayıda seçenek atar
    • curl_setopt — Bir cURL aktarım seçeneği tanımlar
    • curl_share_close — Close a cURL share handle
    • curl_share_init — Initialize a cURL share handle
    • curl_share_setopt — Set an option for a cURL share handle.
    • curl_strerror — Return string describing the given error code
    • curl_unescape — Decodes the given URL encoded string
    • curl_version — cURL sürüm bilgilerini döndürür
  • CURLFile — The CURLFile class
    • CURLFile::__construct — Create a CURLFile object
    • CURLFile::getFilename — Get file name
    • CURLFile::getMimeType — Get MIME type
    • CURLFile::getPostFilename — Get file name for POST
    • CURLFile::setMimeType — Set MIME type
    • CURLFile::setPostFilename — Set file name for POST
    • CURLFile::__wakeup — Unserialization handler
chdb_create
Giriş
Diğer Hizmetler


Giriş

PHP, Daniel Stenberg tarafından yazılan libcurl kütüphanesini destekler. libcurl kütüphanesi farklı türdeki sunuculara bağlanmaya ve farklı protokollerle iletişim kurmaya yarar. libcurl, şimdilik http, https, ftp, gopher, telnet, dict, file ve ldap protokollerini desteklemektedir. Ayrıca, HTTPS sertifikalarını, HTTP POST, HTTP PUT, FTP karşıya yüklemesini (PHP'nin ftp eklentisiyle de yapılabilmektedir), HTTP form karşıya yüklemesini, vekilleri, çerezleri ve kullanıcılı ve parolalı kimlik doğrulamasını da desteklemektedir.

Bu işlevler PHP 4.0.2 sürümünde eklenmiştir.

cURL
Yapılandırma/Kurulum
cURL


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
cURL


Gereksinimler

PHP'nin cURL işlevlerini kullanabilmek için sisteminizde » libcurl paketinin 7.10.5 veya üstü sürümlerinin kurulu olması gerekir.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

PHP'nin cURL desteğini kullanmak için PHP'yi --with-curl[=DiZiN] seçeneği ile yapılandırarak derlemelisiniz. Buradaki DiZiN lib ve include dizinlerini içeren dizindir. include dizini altında easy.h ve curl.h dosyalarını içeren bir curl dizini bulunmalıdır. Ayrıca, lib dizininde bir libcurl.a dosyası bulunmalıdır. PHP 4.3.0'dan itibaren PHP'yi URL akımları için cURL'u kullanmak üzere yapılandırmak için --with-curlwrappers derleme seçeneğini kullanabilirsiniz.

Bilginize: Win32 Kullanıcılarının dikkatine
Bu eklentiyi Windows ortamında etkin kılmak için libeay32.dll ve ssleay32.dll dosyalarına PATH ortam değişkeni üzerinden erişilebilmek gerekir. cURL sitesindeki libcurl.dll dosyasına ihtiyacınız olmayacaktır.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

cURL Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
curl.cainfo | NULL | PHP_INI_SYSTEM | PHP 5.3.7 ve sonrasında kullanılabilir.
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

curl.cainfo string

CURLOPT_CAINFO seçeneği için öntanımlı değerdir. Mutlak bir yol olarak bu gereklidir

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Özkaynak Türleri

Bu eklenti iki özkaynak türü tanımlar: cURL tanıtıcısı ve çoklu cURL tanıtıcısı.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

Bu sabitlerin kullanımı ve açıklamaları için curl_setopt() ve curl_getinfo() işlevlerinin belgelerine bakınız.

CURLOPT_AUTOREFERER (integer)
PHP 5.1.0'dan beri kullanılabilmektedir.
CURLOPT_COOKIESESSION (integer)
PHP 5.1.0'dan beri kullanılabilmektedir.
CURLOPT_DNS_USE_GLOBAL_CACHE (integer)
CURLOPT_DNS_CACHE_TIMEOUT (integer)
CURLOPT_FTP_SSL (integer)
PHP 5.2.0'dan beri kullanılabilmektedir.
CURLFTPSSL_TRY (integer)
PHP 5.2.0'dan beri kullanılabilmektedir.
CURLFTPSSL_ALL (integer)
PHP 5.2.0'dan beri kullanılabilmektedir.
CURLFTPSSL_CONTROL (integer)
PHP 5.2.0'dan beri kullanılabilmektedir.
CURLFTPSSL_NONE (integer)
PHP 5.2.0'dan beri kullanılabilmektedir.
CURLOPT_PRIVATE (integer)
PHP 5.2.4'ten beri kullanılabilmektedir.
CURLOPT_FTPSSLAUTH (integer)
PHP 5.1.0'dan beri kullanılabilmektedir.
CURLOPT_PORT (integer)
CURLOPT_FILE (integer)
CURLOPT_INFILE (integer)
CURLOPT_INFILESIZE (integer)
CURLOPT_URL (integer)
CURLOPT_PROXY (integer)
CURLOPT_VERBOSE (integer)
CURLOPT_HEADER (integer)
CURLOPT_HTTPHEADER (integer)
CURLOPT_NOPROGRESS (integer)
CURLOPT_NOBODY (integer)
CURLOPT_FAILONERROR (integer)
CURLOPT_UPLOAD (integer)
CURLOPT_POST (integer)
CURLOPT_FTPLISTONLY (integer)
CURLOPT_FTPAPPEND (integer)
CURLOPT_FTP_CREATE_MISSING_DIRS (integer)
CURLOPT_NETRC (integer)
CURLOPT_FOLLOWLOCATION (integer)
open_basedir veya safe_mode etkin olduğu takdirde bu sabit kullanılamaz.
CURLOPT_FTPASCII (integer)
CURLOPT_PUT (integer)
CURLOPT_MUTE (integer)
CURLOPT_USERPWD (integer)
CURLOPT_PROXYUSERPWD (integer)
CURLOPT_RANGE (integer)
CURLOPT_TIMEOUT (integer)
CURLOPT_TIMEOUT_MS (integer)
CURLOPT_TCP_NODELAY (integer)
PHP 5.2.1'den beri kullanılabilmektedir.
CURLOPT_POSTFIELDS (integer)
CURLOPT_PROGRESSFUNCTION (integer)
PHP 5.3.0 ve sonrasında mevcuttur.
CURLOPT_REFERER (integer)
CURLOPT_USERAGENT (integer)
CURLOPT_FTPPORT (integer)
CURLOPT_FTP_USE_EPSV (integer)
CURLOPT_LOW_SPEED_LIMIT (integer)
CURLOPT_LOW_SPEED_TIME (integer)
CURLOPT_RESUME_FROM (integer)
CURLOPT_COOKIE (integer)
CURLOPT_SSLCERT (integer)
CURLOPT_SSLCERTPASSWD (integer)
CURLOPT_WRITEHEADER (integer)
CURLOPT_SSL_VERIFYHOST (integer)
CURLOPT_COOKIEFILE (integer)
CURLOPT_SSLVERSION (integer)
CURLOPT_TIMECONDITION (integer)
CURLOPT_TIMEVALUE (integer)
CURLOPT_CUSTOMREQUEST (integer)
CURLOPT_STDERR (integer)
CURLOPT_TRANSFERTEXT (integer)
CURLOPT_RETURNTRANSFER (integer)
CURLOPT_QUOTE (integer)
CURLOPT_POSTQUOTE (integer)
CURLOPT_INTERFACE (integer)
CURLOPT_KRB4LEVEL (integer)
CURLOPT_HTTPPROXYTUNNEL (integer)
CURLOPT_FILETIME (integer)
CURLOPT_WRITEFUNCTION (integer)
CURLOPT_READFUNCTION (integer)
CURLOPT_PASSWDFUNCTION (integer)
CURLOPT_HEADERFUNCTION (integer)
CURLOPT_MAXREDIRS (integer)
CURLOPT_MAXCONNECTS (integer)
CURLOPT_CLOSEPOLICY (integer)
CURLOPT_FRESH_CONNECT (integer)
CURLOPT_FORBID_REUSE (integer)
CURLOPT_RANDOM_FILE (integer)
CURLOPT_EGDSOCKET (integer)
CURLOPT_CONNECTTIMEOUT (integer)
CURLOPT_CONNECTTIMEOUT_MS (integer)
CURLOPT_SSL_VERIFYPEER (integer)
CURLOPT_CAINFO (integer)
CURLOPT_CAPATH (integer)
CURLOPT_COOKIEJAR (integer)
CURLOPT_SSL_CIPHER_LIST (integer)
CURLOPT_BINARYTRANSFER (integer)
CURLOPT_NOSIGNAL (integer)
CURLOPT_PROXYTYPE (integer)
CURLOPT_BUFFERSIZE (integer)
CURLOPT_HTTPGET (integer)
CURLOPT_HTTP_VERSION (integer)
CURLOPT_SSLKEY (integer)
CURLOPT_SSLKEYTYPE (integer)
CURLOPT_SSLKEYPASSWD (integer)
CURLOPT_SSLENGINE (integer)
CURLOPT_SSLENGINE_DEFAULT (integer)
CURLOPT_SSLCERTTYPE (integer)
CURLOPT_CRLF (integer)
CURLOPT_ENCODING (integer)
CURLOPT_PROXYPORT (integer)
CURLOPT_UNRESTRICTED_AUTH (integer)
CURLOPT_FTP_USE_EPRT (integer)
CURLOPT_HTTP200ALIASES (integer)
CURLOPT_HTTPAUTH (integer)
CURLAUTH_BASIC (integer)
CURLAUTH_DIGEST (integer)
CURLAUTH_GSSNEGOTIATE (integer)
CURLAUTH_NTLM (integer)
CURLAUTH_ANY (integer)
CURLAUTH_ANYSAFE (integer)
CURLOPT_PROXYAUTH (integer)
CURLCLOSEPOLICY_LEAST_RECENTLY_USED (integer)
CURLCLOSEPOLICY_LEAST_TRAFFIC (integer)
CURLCLOSEPOLICY_SLOWEST (integer)
CURLCLOSEPOLICY_CALLBACK (integer)
CURLCLOSEPOLICY_OLDEST (integer)
CURLINFO_PRIVATE (integer)
PHP 5.2.4'ten beri kullanılabilmektedir.
CURLINFO_EFFECTIVE_URL (integer)
CURLINFO_HTTP_CODE (integer)
CURLINFO_HEADER_OUT (integer)
PHP 5.1.3'ten beri kullanılabilmektedir.
CURLINFO_HEADER_SIZE (integer)
CURLINFO_REQUEST_SIZE (integer)
CURLINFO_TOTAL_TIME (integer)
CURLINFO_NAMELOOKUP_TIME (integer)
CURLINFO_CONNECT_TIME (integer)
CURLINFO_PRETRANSFER_TIME (integer)
CURLINFO_SIZE_UPLOAD (integer)
CURLINFO_SIZE_DOWNLOAD (integer)
CURLINFO_SPEED_DOWNLOAD (integer)
CURLINFO_SPEED_UPLOAD (integer)
CURLINFO_FILETIME (integer)
CURLINFO_SSL_VERIFYRESULT (integer)
CURLINFO_CONTENT_LENGTH_DOWNLOAD (integer)
CURLINFO_CONTENT_LENGTH_UPLOAD (integer)
CURLINFO_STARTTRANSFER_TIME (integer)
CURLINFO_CONTENT_TYPE (integer)
CURLINFO_REDIRECT_TIME (integer)
CURLINFO_REDIRECT_COUNT (integer)
CURL_TIMECOND_IFMODSINCE (integer)
CURL_TIMECOND_IFUNMODSINCE (integer)
CURL_TIMECOND_LASTMOD (integer)
CURL_VERSION_IPV6 (integer)
CURL_VERSION_KERBEROS4 (integer)
CURL_VERSION_SSL (integer)
CURL_VERSION_LIBZ (integer)
CURLVERSION_NOW (integer)
CURLE_OK (integer)
CURLE_UNSUPPORTED_PROTOCOL (integer)
CURLE_FAILED_INIT (integer)
CURLE_URL_MALFORMAT (integer)
CURLE_URL_MALFORMAT_USER (integer)
CURLE_COULDNT_RESOLVE_PROXY (integer)
CURLE_COULDNT_RESOLVE_HOST (integer)
CURLE_COULDNT_CONNECT (integer)
CURLE_FTP_WEIRD_SERVER_REPLY (integer)
CURLE_FTP_ACCESS_DENIED (integer)
CURLE_FTP_USER_PASSWORD_INCORRECT (integer)
CURLE_FTP_WEIRD_PASS_REPLY (integer)
CURLE_FTP_WEIRD_USER_REPLY (integer)
CURLE_FTP_WEIRD_PASV_REPLY (integer)
CURLE_FTP_WEIRD_227_FORMAT (integer)
CURLE_FTP_CANT_GET_HOST (integer)
CURLE_FTP_CANT_RECONNECT (integer)
CURLE_FTP_COULDNT_SET_BINARY (integer)
CURLE_PARTIAL_FILE (integer)
CURLE_FTP_COULDNT_RETR_FILE (integer)
CURLE_FTP_WRITE_ERROR (integer)
CURLE_FTP_QUOTE_ERROR (integer)
CURLE_HTTP_NOT_FOUND (integer)
CURLE_WRITE_ERROR (integer)
CURLE_MALFORMAT_USER (integer)
CURLE_FTP_COULDNT_STOR_FILE (integer)
CURLE_READ_ERROR (integer)
CURLE_OUT_OF_MEMORY (integer)
CURLE_OPERATION_TIMEOUTED (integer)
CURLE_FTP_COULDNT_SET_ASCII (integer)
CURLE_FTP_PORT_FAILED (integer)
CURLE_FTP_COULDNT_USE_REST (integer)
CURLE_FTP_COULDNT_GET_SIZE (integer)
CURLE_HTTP_RANGE_ERROR (integer)
CURLE_HTTP_POST_ERROR (integer)
CURLE_SSL_CONNECT_ERROR (integer)
CURLE_FTP_BAD_DOWNLOAD_RESUME (integer)
CURLE_FILE_COULDNT_READ_FILE (integer)
CURLE_LDAP_CANNOT_BIND (integer)
CURLE_LDAP_SEARCH_FAILED (integer)
CURLE_LIBRARY_NOT_FOUND (integer)
CURLE_FUNCTION_NOT_FOUND (integer)
CURLE_ABORTED_BY_CALLBACK (integer)
CURLE_BAD_FUNCTION_ARGUMENT (integer)
CURLE_BAD_CALLING_ORDER (integer)
CURLE_HTTP_PORT_FAILED (integer)
CURLE_BAD_PASSWORD_ENTERED (integer)
CURLE_TOO_MANY_REDIRECTS (integer)
CURLE_UNKNOWN_TELNET_OPTION (integer)
CURLE_TELNET_OPTION_SYNTAX (integer)
CURLE_OBSOLETE (integer)
CURLE_SSL_PEER_CERTIFICATE (integer)
CURLE_GOT_NOTHING (integer)
CURLE_SSL_ENGINE_NOTFOUND (integer)
CURLE_SSL_ENGINE_SETFAILED (integer)
CURLE_SEND_ERROR (integer)
CURLE_RECV_ERROR (integer)
CURLE_SHARE_IN_USE (integer)
CURLE_SSL_CERTPROBLEM (integer)
CURLE_SSL_CIPHER (integer)
CURLE_SSL_CACERT (integer)
CURLE_BAD_CONTENT_ENCODING (integer)
CURLE_LDAP_INVALID_URL (integer)
CURLE_FILESIZE_EXCEEDED (integer)
CURLE_FTP_SSL_FAILED (integer)
CURLFTPAUTH_DEFAULT (integer)
PHP 5.1.0'dan beri kullanılabilmektedir.
CURLFTPAUTH_SSL (integer)
PHP 5.1.0'dan beri kullanılabilmektedir.
CURLFTPAUTH_TLS (integer)
PHP 5.1.0'dan beri kullanılabilmektedir.
CURLPROXY_HTTP (integer)
CURLPROXY_SOCKS5 (integer)
CURL_NETRC_OPTIONAL (integer)
CURL_NETRC_IGNORED (integer)
CURL_NETRC_REQUIRED (integer)
CURL_HTTP_VERSION_NONE (integer)
CURL_HTTP_VERSION_1_0 (integer)
CURL_HTTP_VERSION_1_1 (integer)
CURLM_CALL_MULTI_PERFORM (integer)
CURLM_OK (integer)
CURLM_BAD_HANDLE (integer)
CURLM_BAD_EASY_HANDLE (integer)
CURLM_OUT_OF_MEMORY (integer)
CURLM_INTERNAL_ERROR (integer)
CURLMSG_DONE (integer)
Özkaynak Türleri
Örnekler
cURL


Örnekler
cURL
PHP Manual

Örnekler

İçindekiler

  • Örnekler
Öntanımlı Sabitler
Örnekler
cURL


Örnekler
cURL İşlevleri
Örnekler
PHP Manual

Örnekler

PHP'yi cURL desteğiyle derlediyseniz cURL işlevlerini kullanmaya başlayabilirsiniz. cURL işlevlerinin kullanım amacı ve sırası, ana hatlarıyla, curl_init() işlevini kullanarak bir cURL oturumu başlatıp, aktarımın tüm seçeneklerini curl_setopt() ile belirledikten sonra oturumu curl_exec() ile çalıştırıp işiniz bitince curl_close() ile oturumu sonlandırmak şeklindedir. Burada, example.com ana sayfasını bir dosyaya aktarmak amacıyla cURL işlevlerinin kullanımı örneklenmiştir:

Örnek 1 - example.com ana sayfasını bir dosyaya aktarmak amacıyla cURL işlevlerinin kullanımı

<?php

$ch = curl_init("http://www.example.com/");
$fp = fopen("example_homepage.txt", "w");

curl_setopt($ch, CURLOPT_FILE, $fp);
curl_setopt($ch, CURLOPT_HEADER, 0);

curl_exec($ch);
curl_close($ch);
fclose($fp);
?>

Örnekler
cURL İşlevleri
Örnekler
PHP Manual


cURL İşlevleri

İçindekiler

  • curl_close — cURL oturumunu sonlandırır
  • curl_copy_handle — Bir cURL tanıtıcısını tüm tercihleriyle kopyalar
  • curl_errno — Belirtilen oturumdaki son hatanın kodunu döndürür
  • curl_error — Belirtilen oturumdaki son hatayı içeren bir dizge döndürür
  • curl_escape — URL encodes the given string
  • curl_exec — Bir cURL oturumunu işleme sokar
  • curl_file_create — Create a CURLFile object
  • curl_getinfo — Belli bir oturum ile ilgili bilgi döndürür
  • curl_init — Bir cURL oturumunu ilklendirir
  • curl_multi_add_handle — Tekil cURL tanıtıcısını çoklu cURL tanıtıcısına ekler
  • curl_multi_close — Çoklu tanıtıcıyı kapatır
  • curl_multi_exec — Geçerli cURL tanıtıcısının alt bağlantılarını çalıştırır
  • curl_multi_getcontent — CURLOPT_RETURNTRANSFER etkinse bir cURL tanıtıcısının içeriği döner
  • curl_multi_info_read — Geçerli oturum hakkında bilgi döndürür
  • curl_multi_init — Yeni bir çoklu cURL tanıtıcısı döndürür
  • curl_multi_remove_handle — Bir tekil tanıtıcıyı bir çoklu tanıtıcıdan siler
  • curl_multi_select — Çoklu cURL bağlantısında bir etkinlik olsun diye bekler
  • curl_multi_setopt — Set an option for the cURL multi handle
  • curl_multi_strerror — Return string describing error code
  • curl_pause — Pause and unpause a connection
  • curl_reset — Reset all options of a libcurl session handle
  • curl_setopt_array — Belirtilen cURL oturumuna çok sayıda seçenek atar
  • curl_setopt — Bir cURL aktarım seçeneği tanımlar
  • curl_share_close — Close a cURL share handle
  • curl_share_init — Initialize a cURL share handle
  • curl_share_setopt — Set an option for a cURL share handle.
  • curl_strerror — Return string describing the given error code
  • curl_unescape — Decodes the given URL encoded string
  • curl_version — cURL sürüm bilgilerini döndürür
Örnekler
curl_close
cURL


cURL oturumunu sonlandırır

cURL İşlevleri
curl_copy_handle
cURL İşlevleri
PHP Manual

curl_close

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

curl_close — cURL oturumunu sonlandırır

Açıklama

void curl_close ( resource $ct )

cURL oturumunu sonlandırır ve ayrılmış özkaynakları serbest bırakır. Ayrıca, cURL tanıtıcısı ct silinir.

Değiştirgeler

ct

curl_init() işlevinden dönen bir cURL tanıtıcısı.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 - Yeni bir cURL oturumunun ilklendirilmesi ve bir HTML sayfasının alınması

<?php
// Yeni bir cURL tanıtıcısı oluşturalım
$ct = curl_init();

// URL'yi ve ilgili seçenekleri belirleyelim
curl_setopt($ct, CURLOPT_URL, "http://www.example.com/");
curl_setopt($ct, CURLOPT_HEADER, 0);

// URL'yi tarayıcıya aktaralım
curl_exec($ct);

// cURL tanıtıcısını kapatıp sistem özkaynaklarını serbest bırakalım
curl_close($ct);
?>

Ayrıca Bakınız

  • curl_init() - Bir cURL oturumunu ilklendirir
  • curl_multi_close() - Çoklu tanıtıcıyı kapatır

cURL İşlevleri
curl_copy_handle
cURL İşlevleri


Bir cURL tanıtıcısını tüm tercihleriyle kopyalar

curl_close
curl_errno
cURL İşlevleri
PHP Manual

curl_copy_handle

(PHP 5, PHP 7)

curl_copy_handle — Bir cURL tanıtıcısını tüm tercihleriyle kopyalar

Açıklama

resource curl_copy_handle ( resource $ct )

Bir cURL tanıtıcısını tercihlerini koruyarak kopyalar.

Değiştirgeler

ct

curl_init() işlevinden dönen bir cURL tanıtıcısı.

Dönen Değerler

Yeni bir cURL tanıtıcısı döner.

Örnekler

Örnek 1 - Bir cURL tanıtıcısının kopyalanması

<?php
// Yeni bir cURL özkaynağı oluşturalım
$ct = curl_init();

// URL'yi ve ilgili seçenekleri belirtelim
curl_setopt($ct, CURLOPT_URL, 'http://www.example.com/');
curl_setopt($ct, CURLOPT_HEADER, 0);

// tanıtıcıyı kopyalayalım
$ch2 = curl_copy_handle($ct);

// URL'yi tarayıcıya aktaralım
curl_exec($ct2);

// cURL özkaynaklarını kapatıp sistem özkaynaklarını serbest bırakalım
curl_close($ct2);
curl_close($ct);
?>

curl_close
curl_errno
cURL İşlevleri


Belirtilen oturumdaki son hatanın kodunu döndürür

curl_copy_handle
curl_error
cURL İşlevleri
PHP Manual

curl_errno

(PHP 4 >= 4.0.3, PHP 5, PHP 7)

curl_errno — Belirtilen oturumdaki son hatanın kodunu döndürür

Açıklama

int curl_errno ( resource $ct )

Belirtilen oturumdaki son hatanın numarasını döndürür.

Değiştirgeler

ct

curl_init() işlevinden dönen bir cURL tanıtıcısı.

Dönen Değerler

Bir hata yoksa 0, varsa hatanın kodunu döndürür.

Örnekler

Örnek 1 - curl_errno() örneği

<?php
// Olmayan bir yer için bir cURL tanıtıcısı oluşturalım
$ct = curl_init('http://404.php.net/');
curl_setopt($ct, CURLOPT_RETURNTRANSFER, true);

if(curl_exec($ct) === false)
{
  echo 'Curl hatası: ' . curl_error($ct);
}

// Tanıtıcıyı kapatalım
curl_close($ct);
?>

Ayrıca Bakınız

  • curl_error() - Belirtilen oturumdaki son hatayı içeren bir dizge döndürür
  • » Curl hata kodları

curl_copy_handle
curl_error
cURL İşlevleri


Belirtilen oturumdaki son hatayı içeren bir dizge döndürür

curl_errno
curl_escape
cURL İşlevleri
PHP Manual

curl_error

(PHP 4 >= 4.0.3, PHP 5, PHP 7)

curl_error — Belirtilen oturumdaki son hatayı içeren bir dizge döndürür

Açıklama

string curl_error ( resource $ct )

Belirtilen oturumdaki son hataya ilişkin bir dizge döndürür.

Değiştirgeler

ct

curl_init() işlevinden dönen bir cURL tanıtıcısı.

Dönen Değerler

Bir hata yoksa boş bir dizge, bir hata varsa hata dizgesini döndürür.

Örnekler

Örnek 1 - curl_error() örneği

<?php
// Olmayan bir yer için bir cURL tanıtıcısı oluşturalım
$ct = curl_init('http://404.php.net/');
curl_setopt($ct, CURLOPT_RETURNTRANSFER, true);

if(curl_exec($ct) === false)
{
    echo 'Curl hatası: ' . curl_error($ct);
}
else
{
    echo 'İşlem hatasız tamamlandı';
}

// Tanıtıcıyı kapatalım
curl_close($ct);
?>

Ayrıca Bakınız

  • curl_errno() - Belirtilen oturumdaki son hatanın kodunu döndürür
  • » Curl hata kodları

curl_errno
curl_escape
cURL İşlevleri


URL encodes the given string

curl_error
curl_exec
cURL İşlevleri
PHP Manual

curl_escape

(PHP 5 >= 5.5.0, PHP 7)

curl_escape — URL encodes the given string

Açıklama

string curl_escape ( resource $ch , string $str )

This function URL encodes the given string according to » RFC 3986.

Değiştirgeler

ct

curl_init() işlevinden dönen bir cURL tanıtıcısı.

str

The string to be encoded.

Dönen Değerler

Returns escaped string başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 curl_escape() example

<?php
// Create a curl handle
$ch = curl_init();

// Escape a string used as a GET parameter
$location = curl_escape($ch, 'Hofbräuhaus / München');
// Result: Hofbr%C3%A4uhaus%20%2F%20M%C3%BCnchen

// Compose an URL with the escaped string
$url = "http://example.com/add_location.php?location={$location}";
// Result: http://example.com/add_location.php?location=Hofbr%C3%A4uhaus%20%2F%20M%C3%BCnchen

// Send HTTP request and close the handle
curl_setopt($ch, CURLOPT_URL, $url);
curl_setopt($ch, CURLOPT_RETURNTRANSFER, true);
curl_exec($ch);
curl_close($ch);
?>

Ayrıca Bakınız

  • curl_unescape() - Decodes the given URL encoded string
  • urlencode() - Dizgeye URL kodlaması uygular
  • rawurlencode() - RFC 1738'e uygun URL kodlaması yapar
  • » RFC 3986

curl_error
curl_exec
cURL İşlevleri


Bir cURL oturumunu işleme sokar

curl_escape
curl_file_create
cURL İşlevleri
PHP Manual

curl_exec

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

curl_exec — Bir cURL oturumunu işleme sokar

Açıklama

mixed curl_exec ( resource $ct )

Belirtilen cURL oturumunu işleme sokar.

Bu işlev cURL oturumu ilklendirildikten ve oturumun tüm seçenekleri belirlendikten sonra çağrılmalıdır.

Değiştirgeler

ct

curl_init() işlevinden dönen bir cURL tanıtıcısı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. Ancak, CURLOPT_RETURNTRANSFER seçeneği atanmışsa, başarı durumunda sonucu yoksa FALSE döndürür.

Örnekler

Örnek 1 - Yeni bir cURL oturumunun ilklendirilmesi ve bir HTML sayfasının alınması

<?php
// Yeni bir cURL özkaynağı oluşturalım
$ct = curl_init();

// URL'yi ve ilgili seçenekleri belirtelim
curl_setopt($ch, CURLOPT_URL, "http://www.example.com/");
curl_setopt($ch, CURLOPT_HEADER, 0);

// URL'yi tarayıcıya aktaralım
curl_exec($ct);

// cURL özkaynağını kapatıp sistem özkaynaklarını serbest bırakalım
curl_close($ct);
?>

Ayrıca Bakınız

  • curl_multi_exec() - Geçerli cURL tanıtıcısının alt bağlantılarını çalıştırır

curl_escape
curl_file_create
cURL İşlevleri


Create a CURLFile object

curl_exec
curl_getinfo
cURL İşlevleri
PHP Manual

curl_file_create

(PHP 5 >= 5.5.0, PHP 7)

curl_file_create — Create a CURLFile object

Açıklama

Bu işlev şu işlevin takma adıdır: CURLFile::__construct()

curl_exec
curl_getinfo
cURL İşlevleri


Belli bir oturum ile ilgili bilgi döndürür

curl_file_create
curl_init
cURL İşlevleri
PHP Manual

curl_getinfo

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

curl_getinfo — Belli bir oturum ile ilgili bilgi döndürür

Açıklama

mixed curl_getinfo ( resource $ct [, int $seçenek = 0 ] )

Belirtilen tanıtıcı ile ilgili son aktarım hakkında bilgi verir.

Değiştirgeler

ct

curl_init() işlevinden dönen bir cURL tanıtıcısı.

seçenek

Şu sabitlerden biri olabilir:

  • CURLINFO_EFFECTIVE_URL - Etkin son URL.
  • CURLINFO_HTTP_CODE - Alınan son HTTP kodu.
  • CURLINFO_FILETIME - Belgenin karşıdan alınma süresi; -1 ise süre bilirmiyor demektir.
  • CURLINFO_TOTAL_TIME - Saniye cinsinden son aktarımın toplam süresi.
  • CURLINFO_NAMELOOKUP_TIME - Saniye cinsinden isim çözümlenene kadar geçen süre.
  • CURLINFO_CONNECT_TIME - Saniye cinsinden bağlantı kurulana kadar geçen süre.
  • CURLINFO_PRETRANSFER_TIME - Saniye cinsinden başlangıçtan aktarım başlayana kadar geçen süre.
  • CURLINFO_STARTTRANSFER_TIME - Saniye cinsinden ilk bayt aktarılana kadar geçen süre.
  • CURLINFO_REDIRECT_TIME - Saniye cinsinden son aktarım başlayana kadar tüm yönlendirme adımlarının süresi.
  • CURLINFO_SIZE_UPLOAD - Karşıya yüklenen toplam bayt sayısı.
  • CURLINFO_SIZE_DOWNLOAD - İndirilen toplam bayt sayısı.
  • CURLINFO_SPEED_DOWNLOAD - Ortalama indirme hızı.
  • CURLINFO_SPEED_UPLOAD - Ortalama karşıya yükleme hızı.
  • CURLINFO_HEADER_SIZE - Alınan tüm başlıkların toplam boyutu.
  • CURLINFO_HEADER_OUT - Gönderilen istek dizgesi.
  • CURLINFO_REQUEST_SIZE - Toplam istek boyutu; şimdilik sadece HTTP istekleri için.
  • CURLINFO_SSL_VERIFYRESULT - CURLOPT_SSL_VERIFYPEER atanarak istenen SSL sertifikalarının doğrulanmasının sonucu.
  • CURLINFO_CONTENT_LENGTH_DOWNLOAD - Content-Length: başlığından okunan indirilen içerik uzunluğu.
  • CURLINFO_CONTENT_LENGTH_UPLOAD - Belirtilen karşıya yükleme boyutu.
  • CURLINFO_CONTENT_TYPE - İndirilen nesnenin Content-Type: başlığının değeri; NULL değeri sunucunun geçerli bir Content-Type: başlığı göndermediği anlamına gelir.

Dönen Değerler

seçenek belirtilirse, seçeneğin değeri bir dizge olarak döndürülür. Aksi takdirde aşağıdaki elemanları içeren bir dizi döner:

  • "url"
  • "content_type"
  • "http_code"
  • "header_size"
  • "request_size"
  • "filetime"
  • "ssl_verify_result"
  • "redirect_count"
  • "total_time"
  • "namelookup_time"
  • "connect_time"
  • "pretransfer_time"
  • "size_upload"
  • "size_download"
  • "speed_download"
  • "speed_upload"
  • "download_content_length"
  • "upload_content_length"
  • "starttransfer_time"
  • "redirect_time"

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.3 | CURLINFO_HEADER_OUT devreye girdi.

Örnekler

Örnek 1 - curl_getinfo() örneği

<?php
// Yeni bir tanıtıcı oluşturalım
$ch = curl_init('http://www.yahoo.com/');

// Çalıştıralım
curl_exec($ch);

// Bir hata var mı bakalım
if(!curl_errno($ch))
{
 $info = curl_getinfo($ch);

 echo 'İsteğin' . $info['url'] . ' adresine gönderilmesi ' .
       $info['total_time'] . ' saniye sürdü';
}

// Tanıtıcıyı kapatalım
curl_close($ch);
?>

curl_file_create
curl_init
cURL İşlevleri


Bir cURL oturumunu ilklendirir

curl_getinfo
curl_multi_add_handle
cURL İşlevleri
PHP Manual

curl_init

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

curl_init — Bir cURL oturumunu ilklendirir

Açıklama

resource curl_init ([ string $url = NULL ] )

Yeni bir oturumu ilklendirip curl_setopt(), curl_exec() ve curl_close() işlevleriyle kullanmak için bir cURL tanıtıcısı döndürür.

Değiştirgeler

url

Belirtilmişse, değer CURLOPT_URL seçeneğine atanır. Bu seçeneğe curl_setopt() işleviyle de değer atayabilirsiniz.

Dönen Değerler

Başarı durumunda bir cURL tanıtıcısı yoksa FALSE döner.

Örnekler

Örnek 1 - Yeni bir cURL oturumunun ilklendirilmesi ve bir HTML sayfasının alınması

<?php
// Yeni bir cURL özkaynağı oluşturalım
$ct = curl_init();

// URL'yi ve ilgili seçenekleri belirtelim
curl_setopt($ct, CURLOPT_URL, "http://www.example.com/");
curl_setopt($ct, CURLOPT_HEADER, 0);

// URL'yi tarayıcıya aktaralım
curl_exec($ct);

// cURL özkaynağını kapatıp sistem özkaynaklarını serbest bırakalım
curl_close($ct);
?>

Ayrıca Bakınız

  • curl_close() - cURL oturumunu sonlandırır
  • curl_multi_init() - Yeni bir çoklu cURL tanıtıcısı döndürür

curl_getinfo
curl_multi_add_handle
cURL İşlevleri


Tekil cURL tanıtıcısını çoklu cURL tanıtıcısına ekler

curl_init
curl_multi_close
cURL İşlevleri
PHP Manual

curl_multi_add_handle

(PHP 5, PHP 7)

curl_multi_add_handle — Tekil cURL tanıtıcısını çoklu cURL tanıtıcısına ekler

Açıklama

int curl_multi_add_handle ( resource $cct , resource $ct )

ct tanıtıcısını cct tanıtıcısına ekler.

Değiştirgeler

cct

curl_multi_init() işlevinden dönen çoklu cURL tanıtıcısı.

ct

curl_init() işlevinden dönen bir cURL tanıtıcısı.

Dönen Değerler

Başarı durumunda 0, hata oluşursa CURLM_XXX sabitlerinden biri döner.

Örnekler

Örnek 1 - curl_multi_add_handle() örneği

Bu örnekte iki cURL tanıtıcısı oluşturulmakta, bunlar çoklu tanıtıcıya eklenerek birlikte çalıştırılmaktadır.

<?php
/// Tekil cURL özkaynaklarını oluşturalım
$ct1 = curl_init();
$ct2 = curl_init();

// URL'yi ve ilgili seçenekleri belirtelim
curl_setopt($ct1, CURLOPT_URL, "http://lxr.php.net/");
curl_setopt($ct1, CURLOPT_HEADER, 0);
curl_setopt($ct2, CURLOPT_URL, "http://www.php.net/");
curl_setopt($ct2, CURLOPT_HEADER, 0);

// Çokul cURL özkaynağını oluşturalım
$cct = curl_multi_init();

// Tekil tanıtıcıları çoklu tanıtıcıya ekleyelim
curl_multi_add_handle($cct,$ct1);
curl_multi_add_handle($cct,$ct2);

$running=null;
// tanıtıcıları çalıştıralım
do {
    curl_multi_exec($mh,$running);
} while ($running > 0)

// tanıtıcıları kapatalım
curl_multi_remove_handle($cct, $ct1);
curl_multi_remove_handle($cct, $ct2);
curl_multi_close($cct);

?>

Ayrıca Bakınız

  • curl_multi_remove_handle() - Bir tekil tanıtıcıyı bir çoklu tanıtıcıdan siler
  • curl_multi_init() - Yeni bir çoklu cURL tanıtıcısı döndürür
  • curl_init() - Bir cURL oturumunu ilklendirir

curl_init
curl_multi_close
cURL İşlevleri


Çoklu tanıtıcıyı kapatır

curl_multi_add_handle
curl_multi_exec
cURL İşlevleri
PHP Manual

curl_multi_close

(PHP 5, PHP 7)

curl_multi_close — Çoklu tanıtıcıyı kapatır

Açıklama

void curl_multi_close ( resource $cct )

Çoklu cURL tanıtıcısını kapatır.

Değiştirgeler

cct

curl_multi_init() işlevinden dönen çoklu cURL tanıtıcısı.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 - curl_multi_close() örneği

Bu örnekte iki cURL tanıtıcısı oluşturulmakta, bunlar çoklu tanıtıcıya eklenerek birlikte çalıştırılmaktadır.

<?php
/// Tekil cURL özkaynaklarını oluşturalım
$ct1 = curl_init();
$ct2 = curl_init();

// URL'yi ve ilgili seçenekleri belirtelim
curl_setopt($ct1, CURLOPT_URL, "http://lxr.php.net/");
curl_setopt($ct1, CURLOPT_HEADER, 0);
curl_setopt($ct2, CURLOPT_URL, "http://www.php.net/");
curl_setopt($ct2, CURLOPT_HEADER, 0);

// Çokul cURL özkaynağını oluşturalım
$cct = curl_multi_init();

// Tekil tanıtıcıları çoklu tanıtıcıya ekleyelim
curl_multi_add_handle($cct,$ct1);
curl_multi_add_handle($cct,$ct2);

$running=null;
// tanıtıcıları çalıştıralım
do {
    curl_multi_exec($mh,$running);
} while ($running > 0)

// tanıtıcıları kapatalım
curl_multi_remove_handle($cct, $ct1);
curl_multi_remove_handle($cct, $ct2);
curl_multi_close($cct);

?>

Ayrıca Bakınız

  • curl_multi_init() - Yeni bir çoklu cURL tanıtıcısı döndürür
  • curl_close() - cURL oturumunu sonlandırır

curl_multi_add_handle
curl_multi_exec
cURL İşlevleri


Geçerli cURL tanıtıcısının alt bağlantılarını çalıştırır

curl_multi_close
curl_multi_getcontent
cURL İşlevleri
PHP Manual

curl_multi_exec

(PHP 5, PHP 7)

curl_multi_exec — Geçerli cURL tanıtıcısının alt bağlantılarını çalıştırır

Açıklama

int curl_multi_exec ( resource $cct , int &$hala_çalışıyor )

Yığıttaki her tanıtıcıyı işleme sokar. Bir tanıtıcının okuma veya yazma ihtiyacı olsa da olmasa da bu yöntem çağrılabilir.

Değiştirgeler

cct

curl_multi_init() işlevinden dönen çoklu cURL tanıtıcısı.

hala_çalışıyor

İşlemin hala sürüp sürmediğini belirten bir seçeneğe gönderimdir.

Dönen Değerler

Bir cURL sabiti döner.

Bilginize:

Hatalar sadece çoklu tanıtıcı ile ilgilidir. Bu işlev CURLM_OK döndürse bile tekil oturumların bazılarında bazı sorunlar oluşmuş olabilir.

Örnekler

Örnek 1 - curl_multi_exec() örneği

Bu örnekte iki cURL tanıtıcısı oluşturulmakta, bunlar çoklu tanıtıcıya eklenerek birlikte çalıştırılmaktadır.

<?php
// Tekil cURL özkaynaklarını oluşturalım
$ct1 = curl_init();
$ct2 = curl_init();

// URL'yi ve ilgili seçenekleri belirtelim
curl_setopt($ct1, CURLOPT_URL, "http://lxr.php.net/");
curl_setopt($ct1, CURLOPT_HEADER, 0);
curl_setopt($ct2, CURLOPT_URL, "http://www.php.net/");
curl_setopt($ct2, CURLOPT_HEADER, 0);

// Çokul cURL özkaynağını oluşturalım
$cct = curl_multi_init();

// Tekil tanıtıcıları çoklu tanıtıcıya ekleyelim
curl_multi_add_handle($cct,$ct1);
curl_multi_add_handle($cct,$ct2);

$active = null;
// Tanıtıcıları çalıştıralım
do {
    $mrc = curl_multi_exec($cct, $active);
} while ($mrc == CURLM_CALL_MULTI_PERFORM);

while ($active && $mrc == CURLM_OK) {
    if (curl_multi_select($cct) != -1) {
        do {
            $mrc = curl_multi_exec($cct, $active);
        } while ($mrc == CURLM_CALL_MULTI_PERFORM);
    }
}

// tanıtıcıları kapatalım
curl_multi_remove_handle($cct, $ct1);
curl_multi_remove_handle($cct, $ct2);
curl_multi_close($cct);

?>

Ayrıca Bakınız

  • curl_multi_init() - Yeni bir çoklu cURL tanıtıcısı döndürür
  • curl_exec() - Bir cURL oturumunu işleme sokar

curl_multi_close
curl_multi_getcontent
cURL İşlevleri


CURLOPT_RETURNTRANSFER etkinse bir cURL tanıtıcısının içeriği döner

curl_multi_exec
curl_multi_info_read
cURL İşlevleri
PHP Manual

curl_multi_getcontent

(PHP 5, PHP 7)

curl_multi_getcontent — CURLOPT_RETURNTRANSFER etkinse bir cURL tanıtıcısının içeriği döner

Açıklama

string curl_multi_getcontent ( resource $ct )

Belirtilen tanıtıcı için CURLOPT_RETURNTRANSFER seçeneği etkinse tanıtıcının içeriğini bir dizge olarak döndürür.

Değiştirgeler

ct

curl_init() işlevinden dönen bir cURL tanıtıcısı.

Dönen Değerler

cURL tanıtıcısının içeriği bir dizge olarak döner.

Ayrıca Bakınız

  • curl_multi_init() - Yeni bir çoklu cURL tanıtıcısı döndürür

curl_multi_exec
curl_multi_info_read
cURL İşlevleri


Geçerli oturum hakkında bilgi döndürür

curl_multi_getcontent
curl_multi_init
cURL İşlevleri
PHP Manual

curl_multi_info_read

(PHP 5, PHP 7)

curl_multi_info_read — Geçerli oturum hakkında bilgi döndürür

Açıklama

array curl_multi_info_read ( resource $cct [, int &$iletiler = NULL ] )

Çoklu tanıtıcıyı aktarımlardan dönen bilgi veya iletiler bakımından sorgular. İletiler aktarımdaki veya aktarım tamamlandığı andaki bir hata kodu gibi bir bilgi içerebilir.

Bu işleve yapılan her yeni çağrı FALSE dönmedikçe yeni bir sonuç döndürür. FALSE alınacak bilgi kalmadığı anlamına gelir. iletiler değiştirgesi işlev çağrısından sonra kalan iletilerin sayısını içerir.

Uyarı

Dönen özkaynağın gösterdiği veri curl_multi_remove_handle() çağrılana kadar yaşamaz.

Değiştirgeler

cct

curl_multi_init() işlevinden dönen çoklu cURL tanıtıcısı.

iletiler

Kuyrukta bekleyen iletilerin sayısı.

Dönen Değerler

Başarı durumunda ileti için bir ilişkili dizi yoksa FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.2.0 | iletiler değiştirgesi eklendi.

Ayrıca Bakınız

  • curl_multi_init() - Yeni bir çoklu cURL tanıtıcısı döndürür

curl_multi_getcontent
curl_multi_init
cURL İşlevleri


Yeni bir çoklu cURL tanıtıcısı döndürür

curl_multi_info_read
curl_multi_remove_handle
cURL İşlevleri
PHP Manual

curl_multi_init

(PHP 5, PHP 7)

curl_multi_init — Yeni bir çoklu cURL tanıtıcısı döndürür

Açıklama

resource curl_multi_init ( void )

Çok sayıda cURL tanıtıcısının aynı anda işlem görmesini sağlar.

Değiştirgeler

cct

curl_multi_init() işlevinden dönen çoklu cURL tanıtıcısı.

Dönen Değerler

Başarı durumunda bir çoklu-cURL tanıtıcısı yoksa FALSE döner.

Örnekler

Örnek 1 - curl_multi_init() örneği

Bu örnekte iki cURL tanıtıcısı oluşturulup bir çoklu tanıtıcıya eklenip bu ikisi birlikte çalıştırılmaktadır.

<?php
// iki cURL özkaynağı oluşturalım
$ct1 = curl_init();
$ct2 = curl_init();

// URL'yi ve ilgili seçenekleri belirtelim
curl_setopt($ct1, CURLOPT_URL, "http://www.example.com/");
curl_setopt($ct1, CURLOPT_HEADER, 0);
curl_setopt($ct2, CURLOPT_URL, "http://www.php.net/");
curl_setopt($ct2, CURLOPT_HEADER, 0);

// çoklu cURL tanıtıcısını oluşturalım
$cct = curl_multi_init();

// iki tanıtıcıyı buna ekleyelim
curl_multi_add_handle($cct,$ct1);
curl_multi_add_handle($cct,$ct2);

$running=null;
// tanıtıcıları çalıştıralım
do {
    curl_multi_exec($cct,$running);
} while ($running > 0);

// tanıtıcıları kapatalım
curl_multi_remove_handle($cct, $ct1);
curl_multi_remove_handle($cct, $ct2);
curl_multi_close($cct);

?>

Ayrıca Bakınız

  • curl_init() - Bir cURL oturumunu ilklendirir
  • curl_multi_close() - Çoklu tanıtıcıyı kapatır

curl_multi_info_read
curl_multi_remove_handle
cURL İşlevleri


Bir tekil tanıtıcıyı bir çoklu tanıtıcıdan siler

curl_multi_init
curl_multi_select
cURL İşlevleri
PHP Manual

curl_multi_remove_handle

(PHP 5, PHP 7)

curl_multi_remove_handle — Bir tekil tanıtıcıyı bir çoklu tanıtıcıdan siler

Açıklama

int curl_multi_remove_handle ( resource $cct , resource $ct )

Belirtilen ct tanıtıcısını cct tanıtıcısından siler. ct tanıtıcı silindikten sonra bile curl_exec() işlevinde kullanılabilir. Kullanımdaki bir tanıtıcının silinmesi sürmekte olan tüm aktarımların etkin olarak çökmesine sebep olur.

Değiştirgeler

cct

curl_multi_init() işlevinden dönen çoklu cURL tanıtıcısı.

ct

curl_init() işlevinden dönen bir cURL tanıtıcısı.

Dönen Değerler

Başarı durumunda bir cURL tanıtıcısı yoksa FALSE döner.

Ayrıca Bakınız

  • curl_init() - Bir cURL oturumunu ilklendirir
  • curl_multi_init() - Yeni bir çoklu cURL tanıtıcısı döndürür
  • curl_multi_add_handle() - Tekil cURL tanıtıcısını çoklu cURL tanıtıcısına ekler

curl_multi_init
curl_multi_select
cURL İşlevleri


Çoklu cURL bağlantısında bir etkinlik olsun diye bekler

curl_multi_remove_handle
curl_multi_setopt
cURL İşlevleri
PHP Manual

curl_multi_select

(PHP 5, PHP 7)

curl_multi_select — Çoklu cURL bağlantısında bir etkinlik olsun diye bekler

Açıklama

int curl_multi_select ( resource $cct [, float $zamanaşımı = 1.0 ] )

Çoklu cURL bağlantısında bir etkinlik olsun diye bekler.

Değiştirgeler

cct

curl_multi_init() işlevinden dönen çoklu cURL tanıtıcısı.

zamanaşımı

Yanıt için beklenecek azami süre.

Dönen Değerler

Başarı durumunda tanıtıcı sayısını, select sistem çağrısından kaynaklanan bir zaman aşımı veya bir başarısızlık durumunda ise -1 döndürür.

Ayrıca Bakınız

  • curl_multi_init() - Yeni bir çoklu cURL tanıtıcısı döndürür

curl_multi_remove_handle
curl_multi_setopt
cURL İşlevleri


Set an option for the cURL multi handle

curl_multi_select
curl_multi_strerror
cURL İşlevleri
PHP Manual

curl_multi_setopt

(PHP 5 >= 5.5.0, PHP 7)

curl_multi_setopt — Set an option for the cURL multi handle

Açıklama

bool curl_multi_setopt ( resource $mh , int $option , mixed $value )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

mh

option

One of the CURLMOPT_* constants.

value

The value to be set on option.

value should be an int for the following values of the option parameter:

Option | Set value to
CURLMOPT_PIPELINING | Pass 1 to enable or 0 to disable. Enabling pipelining on a multi handle will make it attempt to perform HTTP Pipelining as far as possible for transfers using this handle. This means that if you add a second request that can use an already existing connection, the second request will be "piped" on the same connection. As of cURL 7.43.0 you can also pass 2 to try to multiplex the new transfer over an existing HTTP/2 connection if possible. Instead of integer literals, you can also use the CURLPIPE_* constants if available.
CURLMOPT_MAXCONNECTS | Pass a number that will be used as the maximum amount of simultaneously open connections that libcurl may cache. By default the size will be enlarged to fit four times the number of handles added via curl_multi_add_handle(). When the cache is full, curl closes the oldest one in the cache to prevent the number of open connections from increasing.
CURLMOPT_CHUNK_LENGTH_PENALTY_SIZE | Pass a number that specifies the chunk length threshold for pipelining in bytes.
CURLMOPT_CONTENT_LENGTH_PENALTY_SIZE | Pass a number that specifies the size threshold for pipelining penalty in bytes.
CURLMOPT_MAX_HOST_CONNECTIONS | Pass a number that specifies the maximum number of connections to a single host.
CURLMOPT_MAX_PIPELINE_LENGTH | Pass a number that specifies the maximum number of requests in a pipeline.
CURLMOPT_MAX_TOTAL_CONNECTIONS | Pass a number that specifies the maximum number of simultaneously open connections.
CURLMOPT_PUSHFUNCTION Pass a callable that will be registered to handle server pushes and should have the following signature:
int pushfunction ( resource $parent_ch , resource $pushed_ch , array $headers )
parent_ch

The parent cURL handle (the request the client made).

pushed_ch

A new cURL handle for the pushed request.

headers

The push promise headers.

The push function is supposed to return either CURL_PUSH_OK if it can handle the push, or CURL_PUSH_DENY to reject it.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
7.1.0 | Introduced CURLMOPT_PUSHFUNCTION.
7.0.7 | Introduced CURLMOPT_CHUNK_LENGTH_PENALTY_SIZE, CURLMOPT_CONTENT_LENGTH_PENALTY_SIZE, CURLMOPT_MAX_HOST_CONNECTIONS, CURLMOPT_MAX_PIPELINE_LENGTH and CURLMOPT_MAX_TOTAL_CONNECTIONS.

curl_multi_select
curl_multi_strerror
cURL İşlevleri


Return string describing error code

curl_multi_setopt
curl_pause
cURL İşlevleri
PHP Manual

curl_multi_strerror

(PHP 5 >= 5.5.0, PHP 7)

curl_multi_strerror — Return string describing error code

Açıklama

string curl_multi_strerror ( int $errornum )

Returns a text error message describing the given CURLM error code.

Değiştirgeler

errornum

One of the » CURLM error codes constants.

Dönen Değerler

Returns error string for valid error code, NULL otherwise.

Örnekler

Örnek 1 curl_multi_strerror() example

<?php
// Create cURL handles
$ch1 = curl_init("http://example.com"/);
$ch2 = curl_init("http://php.net/");

// Create a cURL multi handle
$mh = curl_multi_init();

// Add the handles to the multi handle
curl_multi_add_handle($mh, $ch1);
curl_multi_add_handle($mh, $ch2);

// Execute the multi handle
do {
    $status = curl_multi_exec($mh, $active);
    // Check for errors
    if($status > 0) {
        // Display error message
        echo "ERROR!\n " . curl_multi_strerror($status);
    }
} while ($status === CURLM_CALL_MULTI_PERFORM || $active);
?>

Ayrıca Bakınız

  • curl_strerror() - Return string describing the given error code
  • » cURL error codes

curl_multi_setopt
curl_pause
cURL İşlevleri


Pause and unpause a connection

curl_multi_strerror
curl_reset
cURL İşlevleri
PHP Manual

curl_pause

(PHP 5 >= 5.5.0, PHP 7)

curl_pause — Pause and unpause a connection

Açıklama

int curl_pause ( resource $ch , int $bitmask )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

ct

curl_init() işlevinden dönen bir cURL tanıtıcısı.

bitmask

One of CURLPAUSE_* constants.

Dönen Değerler

Returns an error code (CURLE_OK for no error).

curl_multi_strerror
curl_reset
cURL İşlevleri


Reset all options of a libcurl session handle

curl_pause
curl_setopt_array
cURL İşlevleri
PHP Manual

curl_reset

(PHP 5 >= 5.5.0, PHP 7)

curl_reset — Reset all options of a libcurl session handle

Açıklama

void curl_reset ( resource $ch )

This function re-initializes all options set on the given cURL handle to the default values.

Değiştirgeler

ct

curl_init() işlevinden dönen bir cURL tanıtıcısı.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 curl_reset() example

<?php
// Create a curl handle
$ch = curl_init();

// Set CURLOPT_USERAGENT option
curl_setopt($ch, CURLOPT_USERAGENT, "My test user-agent");

// Reset all previously set options
curl_reset($ch);

// Send HTTP request
curl_setopt($ch, CURLOPT_URL, 'http://example.com/');
curl_exec($ch); // the previously set user-agent will be not sent, it has been reset by curl_reset

// Close the handle
curl_close($ch);
?>

Notlar

Bilginize:

curl_reset() also resets the URL given as the curl_init() parameter.

Ayrıca Bakınız

  • curl_setopt() - Bir cURL aktarım seçeneği tanımlar

curl_pause
curl_setopt_array
cURL İşlevleri


Belirtilen cURL oturumuna çok sayıda seçenek atar

curl_reset
curl_setopt
cURL İşlevleri
PHP Manual

curl_setopt_array

(PHP 5 >= 5.1.3, PHP 7)

curl_setopt_array — Belirtilen cURL oturumuna çok sayıda seçenek atar

Açıklama

bool curl_setopt_array ( resource $ct , array $seçenekler )

Belirtilen cURL oturumuna çok sayıda seçenek atar. curl_setopt() işlevini defalarca kullanmak yerine çok sayıda seçeneği bir kerede atamak için yararlıdır.

Değiştirgeler

ct

curl_init() işlevinden dönen bir cURL tanıtıcısı.

seçenekler

Atanacak seçenekleri ve değerlerini içeren dizi. Ahahtarlar geçerli curl_setopt() sabitleri veya bunların sayısal eşdeğerleri olmalıdır.

Dönen Değerler

Belirtilen seçeneklerin tümü atanabilmişe TRUE döner. Bir seçenek başarıyla atanamazsa diğer seçenekler atanmaksızın işlev FALSE ile döner.

Örnekler

Örnek 1 - Yeni bir cURL oturumunun ilklendirilmesi ve bir HTML sayfasının alınması

<?php
// Yeni bir cURL özkaynağı oluşturalım
$ct = curl_init();

// URL'yi ve ilgili seçenekleri belirtelim
$options = array(CURLOPT_URL => 'http://www.example.com/',
                 CURLOPT_HEADER => false
                );

curl_setopt_array($ct, $options);

// URL'yi tarayıcıya aktaralım
curl_exec($ct);

// cURL özkaynağını kapatıp sistem özkaynaklarını serbest bırakalım
curl_close($ct);
?>

PHP 5.1.4 öncesinde bu işlev şöyle taklit edilebilirdi:

Örnek 2 - curl_setopt_array() için kendi gerçeklenimimiz

<?php
if (!function_exists('curl_setopt_array')) {
   function curl_setopt_array(&$ch, $curl_options)
   {
       foreach ($curl_options as $option => $value) {
           if (!curl_setopt($ch, $option, $value)) {
               return false;
           }
       }
       return true;
   }
}
?>

Notlar

Bilginize:

curl_setopt() işlevinde olduğu gibi, CURLOPT_POSTFIELDS seçeneğine bir dizinin aktarılması verinin multipart/form-data olarak kodlanmasına, bir URL kodlu dizge atanması ise verinin application/x-www-form-urlencoded olarak kodlanmasına sebep olur.

Ayrıca Bakınız

  • curl_setopt() - Bir cURL aktarım seçeneği tanımlar

curl_reset
curl_setopt
cURL İşlevleri


Bir cURL aktarım seçeneği tanımlar

curl_setopt_array
curl_share_close
cURL İşlevleri
PHP Manual

curl_setopt

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

curl_setopt — Bir cURL aktarım seçeneği tanımlar

Açıklama

bool curl_setopt ( resource $ct , int $seçenek , mixed $değer )

Belirtilen cURL oturum tanıtıcısı üzerinde bir seçenek tanımlar.

Değiştirgeler

ct

curl_init() işlevinden dönen bir cURL tanıtıcısı.

seçenek

Atanacak CURLOPT_XXX seçeneği.

değer

Atanacak seçenek değeri.

değer değiştirgesine aşağıdaki seçenek'ler için bir mantıksal değer atanmalıdır:

Seçenek | Atanacak değer | Ek bilgi
CURLOPT_AUTOREFERER | Bir Location: yönlendirmesini izleyen bir isteğin Referer: başlığının özdevinimli olarak atanması için TRUE olmalıdır.
CURLOPT_BINARYTRANSFER | CURLOPT_RETURNTRANSFER kullanıldığında ham çıktı dönmesi için TRUE olmalıdır.
CURLOPT_COOKIESESSION | Oturumu yeni bir çerez oturumu olarak imlemek için TRUE olmalıdır. libcurl'un önceki oturumdan yüklenecek oturum çerezlerini yoksaymasına sebep olur. Öntanımlı olarak libcurl, oturum çerezi olup olmadıklarına bakmaksızın tüm çerezleri daima saklar ve yükler. Oturum çerezleri için belli bir zaman aşımı yoktur ve atandıkları oturum boyunca etkindirler.
CURLOPT_CRLF | Aktarım sırasında Unix satırsonlarını CRLF satırsonlarına dönüştürmek için TRUE olmalıdır.
CURLOPT_DNS_USE_GLOBAL_CACHE | Küresel DNS önbelleğini kullanmak için TRUE olmalıdır. Bu seçenek evreler bakımından güvenli değildir ve öntanımlı olarak etkindir.
CURLOPT_FAILONERROR | Dönen HTTP kodunun 400'e eşit veya büyük olması durumunda sessiz kalmak için TRUE olmalıdır. Öntanımlı davranış kodu yok sayıp sayfayı normal olarak döndürmektir.
CURLOPT_FILETIME | Uzak belgenin değişiklik tarihi alınmaya çalışılacaksa TRUE olmalıdır. Bu değer, curl_getinfo() ile CURLINFO_FILETIME seçeneği kullanılarak alınabilir.
CURLOPT_FOLLOWLOCATION | HTTP başlığının bir parçası olarak sunucunun gönderdiği "Location: " başlığını izlemek için TRUE olmalıdır. Bu izleme, CURLOPT_MAXREDIRS tanımlanmadıkça ardışıktır, yani PHP gönderilen tüm "Location: " başlıklarını izleyecektir.
CURLOPT_FORBID_REUSE | İşlem bittiğinde yeniden kullanım için havuzlanmaksızın ve beklemeksizin bağlantının mutlaka kapatılması için TRUE olmalıdır.
CURLOPT_FRESH_CONNECT | Önbellektekini kullanmaksızın yeni bir bağlantı açmak için TRUE olmalıdır.
CURLOPT_FTP_USE_EPRT | Etkin FTP indirmeleri yapılırken EPRT (ve LPRT) kullanmak için TRUE olmalıdır. EPRT ve LPRT'yi iptal edip sadece PORT kullanmak için FALSE kullanın.
CURLOPT_FTP_USE_EPSV | PASV'ye dönmeden önce FTP aktarımı için önce EPSV komutunu denemek için TRUE olmalıdır.
CURLOPT_FTPAPPEND | Uzak dosyanın üzerine yazmak yerine sonuna ekleme yapmak için TRUE olmalıdır.
CURLOPT_FTPASCII | CURLOPT_TRANSFERTEXT için takma addır; onun yerine bunu kullanın.
CURLOPT_FTPLISTONLY | Sadece FTP dizinindeki isimler listelenecekse TRUE olmalıdır.
CURLOPT_HEADER | Çıktıda başlık bulunması için TRUE olmalıdır.
CURLOPT_HTTPGET | HTTP istek yönteminin GET olması için TRUE olmalıdır. GET öntanımlı olduğundan bu sadece istek yöntemi değiştiğinde işe yarar.
CURLOPT_HTTPPROXYTUNNEL | Belirtilen HTTP vekili üzerinden tünel kullanılacaksa TRUE olmalıdır.
CURLOPT_MUTE | cURL işlevleriyle ilgili olarak tamamen sessiz kalınması için TRUE olmalıdır.
CURLOPT_NETRC | Bağlantı kurulan uzak site için kullanıcı adını ve parolasını bulmak amacıyla ~/.netrc dosyasına bakılmasını sağlamak için TRUE olmalıdır.
CURLOPT_NOBODY | Çıktıdaki gövdeyi dışlamak için TRUE olmalıdır. Ardından istek yöntemi HEAD yapılır. Bunu FALSE olarak değiştirmek yöntemi GET yapmaz.
CURLOPT_NOPROGRESS

cURL aktarımının gelişim göstergesini kapatmak için TRUE olmalıdır.

Bilginize:

PHP bu seçeneğe öntanımlı olarak TRUE atar. Bu sadece hata ayıklama amacıyla değiştirlmelidir.

CURLOPT_NOSIGNAL | PHP sürecine bir sinyal gönderilmesine sebep olan cURL işlevlerini yoksaymak için TRUE olmalıdır. Çok evreli SAPI'lerde, öntanımlı olarak böyledir; dolayısıyla zaman aşımı seçenekleri hala kullanılabilir olur. | cURL 7.10'da eklendi.
CURLOPT_POST | Normal bir HTTP POST yapmak için TRUE olmalıdır. Bu, HTML formlarında sıklıkla kullanılan normal application/x-www-form-urlencoded çeşididir.
CURLOPT_PUT | Bir dosyaya HTTP PUT yapmak için TRUE olmalıdır. Bu dosya CURLOPT_INFILE ve CURLOPT_INFILESIZE ile atanmalıdır.
CURLOPT_RETURNTRANSFER | Aktarımı doğrudan çıktılamak yerine bir dizge olarak curl_exec() işlevinden döndürmek için TRUE olmalıdır.
CURLOPT_SSL_VERIFYPEER | cURL'un eş sertifikasını doğrulamayı durdurması için FALSE olmalıdır. Doğrulayıcı diğer sertifikalar CURLOPT_CAINFO seçeneği ile belirtilebileceği gibi CURLOPT_CAPATH seçeneği ile bir sertifika dizini de belirtilebilir. Ayrıca, CURLOPT_SSL_VERIFYHOST seçeneği de TRUE veya FALSE olabilir (öntanımlı olarak 2 olan CURLOPT_SSL_VERIFYPEER iptal edilmişse). | cURL 7.10 itibariyle öntanımlı olarak TRUE'dur.
CURLOPT_TRANSFERTEXT | FTP aktarımlarında ASCII kip kullanmak için TRUE olmalıdır. LDAP için veri, HTML yerine salt metin olarak alınır. Windows sistemlerinde, STDOUT'a ikil kip atanmaz.
CURLOPT_UNRESTRICTED_AUTH | (CURLOPT_FOLLOWLOCATION kullanarak) Location: yönlendirmelerini izlerken konut ismi değişse bile, kullanıcı ve parola gönderimini sağlamak için TRUE olmalıdır.
CURLOPT_UPLOAD | Karşıya yüklemeye hazır olmak için TRUE olmalıdır.
CURLOPT_VERBOSE | Ayrıntılı bilgi çıktılanması için TRUE olmalıdır. Çıktıyı standart hataya veya CURLOPT_STDERR kullanarak belirtilen dosyaya yazar.

değer değiştirgesine aşağıdaki seçenek'ler için bir tamsayı atanmalıdır:

Seçenek | Atanacak değer | Ek bilgi
CURLOPT_BUFFERSIZE | Okuma için kullanılacak tamponun boyutu. Ancak, bu isteğin yerine getirileceğinin bir garantisi yoktur. | cURL 7.10'da eklendi.
CURLOPT_CLOSEPOLICY | CURLCLOSEPOLICY_LEAST_RECENTLY_USED veya CURLCLOSEPOLICY_OLDEST olabilir. Bunlardan başka CURLCLOSEPOLICY_ önekli üç sabit daha vardır, ancak, bunlar cURL tarafından henüz desteklenmemektedir.
CURLOPT_CONNECTTIMEOUT | Saniye cinsinden bağlantının deneneceği süre. Bağlantının sonsuza kadar beklenmesi için 0 kullanın.
CURLOPT_CONNECTTIMEOUT_MS | Milisaniye cinsinden bağlantının deneneceği süre. Bağlantının sonsuza kadar beklenmesi için 0 kullanın. | cURL 7.16.2'de eklendi. PHP 5.2.3'ten beri kullanılabilmektedir.
CURLOPT_DNS_CACHE_TIMEOUT | Saniye cinsinden DNS girdilerinin bellekte kalma süresi. Bu seçeneğin öntanımlı değeri 120 saniyedir.
CURLOPT_FTPSSLAUTH | FTP kimlik doğrulama yöntemi (etkinse): CURLFTPAUTH_SSL (önce SSL denenir), CURLFTPAUTH_TLS (önce TLS denenir) veya CURLFTPAUTH_DEFAULT (cURL karar verir). | cURL 7.12.2'de eklendi.
CURLOPT_HTTP_VERSION | CURL_HTTP_VERSION_NONE (öntanımlı olup hangi sürümün kullanılacağına CURL karar verir), CURL_HTTP_VERSION_1_0 (HTTP/1.0 zorlanır), veya CURL_HTTP_VERSION_1_1 (HTTP/1.1 zorlanır).
CURLOPT_HTTPAUTH

HTTP kimlik doğrulama yöntem(ler)i: CURLAUTH_BASIC, CURLAUTH_DIGEST, CURLAUTH_GSSNEGOTIATE, CURLAUTH_NTLM, CURLAUTH_ANY ve CURLAUTH_ANYSAFE.

Birden fazla yöntem belirtilecekse sabitler arasında bitsel VEYA işleci kullanılabilir. Bu takdirde, cURL belirtilen yöntemlerden hangisinin sunucu tarafından en iyi desteklendiğini saptamaya çalışır ve onu kullanır.

CURLAUTH_ANY sabiti CURLAUTH_BASIC | CURLAUTH_DIGEST | CURLAUTH_GSSNEGOTIATE | CURLAUTH_NTLM ifadesi için bir kısaltmadır.

CURLAUTH_ANYSAFE sabiti CURLAUTH_DIGEST | CURLAUTH_GSSNEGOTIATE | CURLAUTH_NTLM ifadesi için bir kısaltmadır.

CURLOPT_INFILESIZE | Dosya karşıya yüklenirken dosyanın bayt cinsinden tahmini boyutu.
CURLOPT_LOW_SPEED_LIMIT | PHP'nin aktarımın çok yavaş olduğunu varsayarak çıkması için, CURLOPT_LOW_SPEED_TIME saniye süresince aktarımın altında kalacağı, saniyedeki bayt sayısı olarak aktarım hızı.
CURLOPT_LOW_SPEED_TIME | PHP'nin aktarımın çok yavaş olduğunu varsayarak çıkması için, aktarım hızının CURLOPT_LOW_SPEED_LIMIT'in altında kalacağı, saniye cinsinden aktarım süresi.
CURLOPT_MAXCONNECTS | İzin verilen kalıcı bağlantıların azami sayısı. Bu sınıra ulaşıldığında hangi bağlantının kapatılacağını saptamak için CURLOPT_CLOSEPOLICY kullanılır.
CURLOPT_MAXREDIRS | İzlenecek HTTP yönlendirmelerinin azami sayısı. CURLOPT_FOLLOWLOCATION ile birlikte kullanılır.
CURLOPT_PORT | Bağlantı için kullanılacak ikincil port numarası.
CURLOPT_PROTOCOLS

CURLPROTO_* değerlerinden oluşan bir bit maskesi. libcurl'un aktarımda kullanabileceği protokolleri belirler. Bu seçenek, kurulu libcurl'un geniş bir protokol çeşidini desteklemesini gerektirir. Seçenekle bu protokollerin bir alt kümesi belirtilebilir. libcurl öntanımlı olarak, desteklediği tüm protokolleri kabul edecektir. Ayrıca, CURLOPT_REDIR_PROTOCOLS seçeneğine de bakınız.

Olası protokol seçenekleri: CURLPROTO_HTTP, CURLPROTO_HTTPS, CURLPROTO_FTP, CURLPROTO_FTPS, CURLPROTO_SCP, CURLPROTO_SFTP, CURLPROTO_TELNET, CURLPROTO_LDAP, CURLPROTO_LDAPS, CURLPROTO_DICT, CURLPROTO_FILE, CURLPROTO_TFTP, CURLPROTO_ALL

cURL 7.19.4'te eklendi.
CURLOPT_PROXYAUTH | Vekil bağlantı için kullanılacak HTTP kimlik doğrulama yöntem(ler)i. CURLOPT_HTTPAUTH seçeneğindeki bit maskesi kullanılır. Vekil kimlik doğrulaması için şimdilik sadece CURLAUTH_BASIC ve CURLAUTH_NTLM desteklenmektedir. | cURL 7.10.7'de eklendi.
CURLOPT_PROXYPORT | Bağlanılacak vekil port numarası. Port numarası CURLOPT_PROXY ile de atanabilir.
CURLOPT_PROXYTYPE | CURLPROXY_HTTP (öntanımlı) veya CURLPROXY_SOCKS5 olabilir. | cURL 7.10'da eklendi.
CURLOPT_REDIR_PROTOCOLS | CURLPROTO_* değerlerinden oluşan bir bit maskesi. CURLOPT_FOLLOWLOCATION etkin olduğu takdirde, bir yönlendirme izlenirken libcurl'un aktarımda kullanacağı protokoller belirtilir. Bu seçenek, yönlendirmelerde aktarımın belli protokollerle sınırlanmasına imkan verir. libcurl öntanımlı olarak FILE ve SCP haricinde tüm protokollere izin verir. Bu davranış, izlemelerde tüm protokollerin koşulsuz olarak desteklendiği 7.19.4 öncesi sürümlerden farklıdır. Protokol sabitleri için CURLOPT_PROTOCOLS seçeneğine de bakınız. | cURL 7.19.4'te eklendi.
CURLOPT_RESUME_FROM | Bayt cinsinden aktarımın devam ettirileceği konum.
CURLOPT_SSL_VERIFYHOST | SSL eş sertifikasında ortak bir ismin varlığına bakılması için 1 olmalıdır. Ortak bir ismin varlığının yanında sağlanan konak ismi ile eşleşmenin de aranması için 2 olmalıdır.
CURLOPT_SSLVERSION | Kullanılacak SSL sürümü (2 veya 3). Öntanımlı olarak PHP bunu kendi saptamaya çalışırsa da bazı durumlarda bunun elle belirtilmesi gerekir.
CURLOPT_TIMECONDITION | CURLOPT_TIMEVALUE değerinin nasıl ele alınacağı belirtilir. Sayfayı sadece, CURLOPT_TIMEVALUE ile belirtilen süre içinde değiştirilmediği takdirde döndürmek için CURL_TIMECOND_IFMODSINCE kullanın. Sayfa değişmişse, CURLOPT_HEADER seçeneğinin TRUE olduğu varsayımıyla "304 Not Modified" (304 değişiklik yok) başlığı döndürülür. Bu davranışı ters çevirmek için CURL_TIMECOND_IFUNMODSINCE kullanın. CURL_TIMECOND_IFMODSINCE öntanımlıdır.
CURLOPT_TIMEOUT | cURL işlevlerinin çalışmasına izin verilecek azami saniye sayısı.
CURLOPT_TIMEOUT_MS | cURL işlevlerinin çalışmasına izin verilecek azami milisaniye sayısı. | cURL 7.16.2'de eklendi. PHP 5.2.3'ten beri kullanılabilmektedir.
CURLOPT_TIMEVALUE | 1 Ocak 1970'den beri geçen saniye sayısı. Bu değer CURLOPT_TIMECONDITION tarafından kullanılır. CURL_TIMECOND_IFMODSINCE öntanımlıdır.

değer değiştirgesine aşağıdaki seçenek'ler için bir dizge atanmalıdır:

Seçenek | Atanacak değer | Ek bilgi
CURLOPT_CAINFO | Eşle doğrulanacak bir veya daha fazla sertifikanın tutulduğu dosyanın ismi. Bu sadece CURLOPT_SSL_VERIFYPEER ile birlikte kullanıldığında anlamlıdır.
CURLOPT_CAPATH | Çok sayıda CA sertifikasının tutulduğu dizinin yolu. CURLOPT_SSL_VERIFYPEER seçeneğiyle birlikte kullanılır.
CURLOPT_COOKIE | HTTP isteğinde kullanılacak "Cookie: " başlığının içeriği. Bir noktalı virgülden sonra gelen bir boşlukla ayrılarak çok sayıda çerez belirtilebilir ("meyve=elma; renk=turkuaz" gibi).
CURLOPT_COOKIEFILE | Çerez verisini içeren dosyanın adı. Çerez dosyası Netscape biçeminde veya bir dosyaya dökümlenmiş salt HTTP tarzı başlıklar biçeminde olabilir.
CURLOPT_COOKIEJAR | Bağlantı kapandığında tüm dahili çerezlerin kaydedileceği dosyanın ismi.
CURLOPT_CUSTOMREQUEST

Bir HTTP isteği yaparken "GET" veya "HEAD" yerine kullanılacak özel istek yöntemi. "DELETE" veya biraz daha çapraşık HTTP istekleri yapmak için kullanışlıdır. Geçerli değerlerin bazıları: "GET", "POST", "CONNECT"; yani, istek satırının tamamını buraya girmeyin. Örneğin, "GET /index.html HTTP/1.0\r\n\r\n" girdisi yanlış olacaktır.

Bilginize:

Belirteceğiniz istek yöntemini sunucunun desteklediğinden emin olmadan bir şey belirtmeyin.

CURLOPT_EGDSOCKET | Bozunum değerlerini toplama uygulamasına bir dosya ismi belirtmesi dışında CURLOPT_RANDOM_FILE gibidir.
CURLOPT_ENCODING | "Accept-Encoding: " başlığının içeriği. Yanıtın kodlanmasını sağlar. Desteklenen kodlamalar: "identity", "deflate" ve "gzip". Boş bir dizge "" belirtilirse desteklenen tüm kodlamaları içeren bir başlık gönderilir. | cURL 7.10'da eklendi.
CURLOPT_FTPPORT | FTP "POST" komutu için kullanılacak IP adresini almakta kullanılacak değer. "POST" komutu, uzak sunucunun bizim belirttiğimiz IP adresine bağlanmasını söyler. Dizge bir IP adresi içerebileceği gibi bir konakismi, (Unix altında) bir ağ arayüzü adı veya sistemin öntanımlı IP adresinin kullanılacağı anlamında '-' olabilir.
CURLOPT_INTERFACE | Kullanılacak giden ağ arayüzünün ismi. Bir ağ arabirimi ismi, bir IP adresi veya bir konak ismi olabilir.
CURLOPT_KRB4LEVEL | KRB4 (Kerberos 4) güvenlik seviyesi. Geçerli değerler (en güçsüzden en güçlüye doğru): "clear", "safe", "confidential", "private".. Dizge bunlardan biri değilse "private" kullanılır. Bu seçeneğe NULL atanması KRB4 güvenliğini iptal eder. Şimdilik KRB4 güvenliği sadece FTP aktarımlarında çalışmaktadır.
CURLOPT_POSTFIELDS | Bir HTTP "POST" işleminde gönderilecek verinin tamamı. Bir dosya göndermek için dosya ismini başına @ koyarak tam yoluyla belirtin. 'para1=val1&para2=val2&...' benzeri kodlanmış bir dizge veya alan isimlerinin anahtar, değerlerinin değer olarak yer aldığı bir dizi belirtilebilir. değer bir dizi ise Content-Type başlığına multipart/form-data atanır.
CURLOPT_PROXY | İstekleri tünelleyecek HTTP vekili.
CURLOPT_PROXYUSERPWD | Vekil bağlantısı için kullanılacak kullanıcı adı ve parola; "[kullanıcı]:[parola]" biçeminde belirtilir.
CURLOPT_RANDOM_FILE | SSL için rasgele sayı üretecini tohumlamakta kullanılacak dosya ismi.
CURLOPT_RANGE | X ve Y isteğe bağlı olmak üzere "X-Y" biçeminde alınacak veri aralığı. HTTP aktarımları, "X-Y,N-M" biçeminde virgüllerle ayrılmış olarak çok sayıda aralığı destekler.
CURLOPT_REFERER | Bir HTTP isteğinde kullanılacak "Referer: " başlığının içeriği.
CURLOPT_SSL_CIPHER_LIST | SSL için kullanılacak şifrelerin listesi. Örneğin, RC4-SHA ve TLSv1 geçerli şifre listeleridir.
CURLOPT_SSLCERT | PEM biçemli sertifikayı içeren dosyanın ismi.
CURLOPT_SSLCERTPASSWD | CURLOPT_SSLCERT sertifikasını kullanmak için gereken parola.
CURLOPT_SSLCERTTYPE | Sertifika biçemi. Desteklenen biçemler: "PEM" (öntanımlı), "DER" ve "ENG". | cURL 7.9.3'te eklendi.
CURLOPT_SSLENGINE | CURLOPT_SSLKEY ile belirtilmiş gizli SSL anahtarının şifreleme motoru için betimleyici.
CURLOPT_SSLENGINE_DEFAULT | Bakışımsız şifreleme işlemleri için kullanılan şifreleme motoru için betimleyici.
CURLOPT_SSLKEY | Gizli SSL anahtarını içeren dosyanın ismi.
CURLOPT_SSLKEYPASSWD

CURLOPT_SSLKEY ile belirtilen gizli SSL anahtarını kullanmak için gereken gizli parola.

Bilginize:

Bu seçenekle belirtilen parolayı yetkisiz kişilerin okumaması için PHP betiğini güvenilir bir yerde tutmaya çalışın.

CURLOPT_SSLKEYTYPE | CURLOPT_SSLKEYile belirtilen gizli SSL anahtarının anahtar türü. Desteklenen anahtar türleri: "PEM" (öntanımlı), "DER", ve "ENG".
CURLOPT_URL | İçeriği alınacak URL. Oturumu curl_init() ile ilklendirirken de belirtilebilir.
CURLOPT_USERAGENT | HTTP isteğinde kullanılacak "User-Agent: "başlığının içeriği.
CURLOPT_USERPWD | Bağlantı için kullanılmak üzere "[kullanıcı]:[parola]" biçeminde kullanıcı adı ve parola.

değer değiştirgesine aşağıdaki seçenek'ler için bir dizi atanmalıdır:

Seçenek | Atanacak değer | Ek bilgi
CURLOPT_HTTP200ALIASES | Hata değil geçerli yanıtlar olarak ele alınmak üzere HTTP 200 yanıtlarını içeren bir dizi. | cURL 7.10.3'te eklendi.
CURLOPT_HTTPHEADER | HTTP başlık alanlarını içeren bir dizi.
CURLOPT_POSTQUOTE | FTP isteği yapıldıktan sonra sunucu üzerinde çalıştırılacak komutları içeren bir dizi.
CURLOPT_QUOTE | FTP isteği yapılmadan önce sunucu üzerinde çalıştırılacak komutları içeren bir dizi.

değer değiştirgesine aşağıdaki seçenek'ler için (örneğin fopen() kullanarak) bir akım özkaynağı atanmalıdır:

Seçenek | Atanacak değer | Ek bilgi
CURLOPT_FILE | Aktarımın yazılacağı dosya. STDOUT (tarayıcı penceresi) öntanımlıdır.
CURLOPT_INFILE | Karşıya yükleme sırasında aktarımın okuyacağı dosya.
CURLOPT_STDERR | Çıktı hatalarının gönderileceği STDERR yerine kullanılacak dosya.
CURLOPT_WRITEHEADER | Aktarımın başlık bölümünün yazılacağı dosya.

değer değiştirgesine aşağıdaki seçenek'ler için bir geriçağırım işlevinin adı atanmalıdır:

Seçenek | Atanacak değer | Ek bilgi
CURLOPT_HEADERFUNCTION | İki değiştirgeli bir geriçağırım işlevinin ismi. Değiştirgelerin ilki bir cURL özkaynağı, ikincisi ise başlık verisinin yazılacağı bir dizge olmalıdır. Başlık verisi bu geriçağırım işlevi kullanılırken yazılmalıdır. İşlevin dönüş değeri yazılan bayt sayısı olmalıdır.
CURLOPT_PASSWDFUNCTION | Üç değiştirgeli bir geriçağırım işlevinin ismi. Değiştirgelerin ilki bir cURL özkaynağı, ikincisi parola istemi belirten bir dizge, üçüncüsü ise parolanın azami uzunluğu olmalıdır. İşlevin dönüş değeri parolayı içeren bir dizge olmalıdır.
CURLOPT_PROGRESSFUNCTION | Geriçağırım işlevinin üç değiştirge aldığı durumda geriçağırım işlevinin ismi. Değiştirgelerin ilki bir cURL özkaynağı, ikincisi bir dosya tanıtıcısı, üçüncüsü ise uzunluk olmalıdır. İşlevin dönüş değeri veriyi içeren bir dizge olmalıdır.
CURLOPT_READFUNCTION | İki değiştirgeli bir geriçağırım işlevinin ismi. Değiştirgelerin ilki bir cURL özkaynağı, ikincisi ise okunacak veriyi iceren bir dizge olmalıdır. Veri bu geriçağırım işlevi kullanılarak okunmalıdır. İşlevin dönüş değeri okunan bayt sayısı olmalıdır. Dosya sonunun bildirmek için ise 0 dönmelidir.
CURLOPT_WRITEFUNCTION | İki değiştirgeli bir geriçağırım işlevinin ismi. Değiştirgelerin ilki bir cURL özkaynağı, ikincisi ise yazılacak veriyi içeren bir dizge olmalıdır. Veri bu geriçağırım işlevi kullanılarak yazılmalıdır. İşlevin dönüş değeri yazılan bayt sayısı olmalıdır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.2.10 | CURLOPT_PROTOCOLS ve CURLOPT_REDIR_PROTOCOLS kullanılabilir oldu.
5.1.0 | CURLOPT_AUTOREFERER, CURLOPT_BINARYTRANSFER, CURLOPT_FTPSSLAUTH, CURLOPT_AUTOREFERER, CURLOPT_PROXYAUTH ve CURLOPT_TIMECONDITION kullanılabilir oldu.
5.0.0 | CURLOPT_FTP_USE_EPRT, CURLOPT_NOSIGNAL, CURLOPT_UNRESTRICTED_AUTH, CURLOPT_BUFFERSIZE, CURLOPT_HTTPAUTH, CURLOPT_PROXYPORT, CURLOPT_PROXYTYPE, CURLOPT_SSLCERTTYPE ve CURLOPT_HTTP200ALIASES kullanılabilir oldu.

Örnekler

Örnek 1 - Yeni bir cURL oturumunun ilklendirilmesi ve bir HTML sayfasının alınması

<?php
// Yeni bir cURL özkaynağı oluşturalım
$ct = curl_init();

// URL'yi ve ilgili seçenekleri belirtelim
curl_setopt($ct, CURLOPT_URL, "http://www.example.com/");
curl_setopt($ct, CURLOPT_HEADER, false);

// URL'yi tarayıcıya aktaralım
curl_exec($ct);

// cURL özkaynağını kapatıp sistem özkaynaklarını serbest bırakalım
curl_close($ct);
?>

Örnek 2 - Karşıya dosya yüklemek

<?php

/* http://localhost/upload.php:
print_r($_POST);
print_r($_FILES);
*/

$ch = curl_init();

$data = array('name' => 'Foo', 'file' => '@/home/user/test.png');

curl_setopt($ch, CURLOPT_URL, 'http://localhost/upload.php');
curl_setopt($ch, CURLOPT_POST, 1);
curl_setopt($ch, CURLOPT_POSTFIELDS, $data);

curl_exec($ch);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [name] => Foo
)
Array
(
    [file] => Array
        (
            [name] => test.png
            [type] => image/png
            [tmp_name] => /tmp/phpcpjNeQ
            [error] => 0
            [size] => 279
        )

)

Notlar

Bilginize:

CURLOPT_POSTFIELDS seçeneğine bir dizinin aktarılması verinin multipart/form-data olarak kodlanmasına, bir URL kodlu dizge atanması ise verinin application/x-www-form-urlencoded olarak kodlanmasına sebep olur.

Ayrıca Bakınız

  • curl_setopt_array() - Belirtilen cURL oturumuna çok sayıda seçenek atar

curl_setopt_array
curl_share_close
cURL İşlevleri


Close a cURL share handle

curl_setopt
curl_share_init
cURL İşlevleri
PHP Manual

curl_share_close

(PHP 5 >= 5.5.0, PHP 7)

curl_share_close — Close a cURL share handle

Açıklama

void curl_share_close ( resource $sh )

Closes a cURL share handle and frees all resources.

Değiştirgeler

sh

A cURL share handle returned by curl_share_init()

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 curl_share_setopt() example

This example will create a cURL share handle, add two cURL handles to it, and then run them with cookie data sharing.

<?php
// Create cURL share handle and set it to share cookie data
$sh = curl_share_init();
curl_share_setopt($sh, CURLSHOPT_SHARE, CURL_LOCK_DATA_COOKIE);

// Initialize the first cURL handle and assign the share handle to it
$ch1 = curl_init("http://example.com/");
curl_setopt($ch1, CURLOPT_SHARE, $sh);

// Execute the first cURL handle
curl_exec($ch1);

// Initialize the second cURL handle and assign the share handle to it
$ch2 = curl_init("http://php.net/");
curl_setopt($ch2, CURLOPT_SHARE, $sh);

// Execute the second cURL handle
//  all cookies from $ch1 handle are shared with $ch2 handle
curl_exec($ch2);

// Close the cURL share handle
curl_share_close($sh);

// Close the cURL handles
curl_close($ch1);
curl_close($ch2);
?>

Ayrıca Bakınız

  • curl_share_init() - Initialize a cURL share handle

curl_setopt
curl_share_init
cURL İşlevleri


Initialize a cURL share handle

curl_share_close
curl_share_setopt
cURL İşlevleri
PHP Manual

curl_share_init

(PHP 5 >= 5.5.0, PHP 7)

curl_share_init — Initialize a cURL share handle

Açıklama

resource curl_share_init ( void )

Allows to share data between cURL handles.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns resource of type "cURL Share Handle".

Örnekler

Örnek 1 curl_share_init() example

This example will create a cURL share handle, add two cURL handles to it, and then run them with cookie data sharing.

<?php
// Create cURL share handle and set it to share cookie data
$sh = curl_share_init();
curl_share_setopt($sh, CURLSHOPT_SHARE, CURL_LOCK_DATA_COOKIE);

// Initialize the first cURL handle and assign the share handle to it
$ch1 = curl_init("http://example.com/");
curl_setopt($ch1, CURLOPT_SHARE, $sh);

// Execute the first cURL handle
curl_exec($ch1);

// Initialize the second cURL handle and assign the share handle to it
$ch2 = curl_init("http://php.net/");
curl_setopt($ch2, CURLOPT_SHARE, $sh);

// Execute the second cURL handle
//  all cookies from $ch1 handle are shared with $ch2 handle
curl_exec($ch2);

// Close the cURL share handle
curl_share_close($sh);

// Close the cURL handles
curl_close($ch1);
curl_close($ch2);
?>

Ayrıca Bakınız

  • curl_share_setopt() - Set an option for a cURL share handle.
  • curl_share_close() - Close a cURL share handle

curl_share_close
curl_share_setopt
cURL İşlevleri


Set an option for a cURL share handle.

curl_share_init
curl_strerror
cURL İşlevleri
PHP Manual

curl_share_setopt

(PHP 5 >= 5.5.0, PHP 7)

curl_share_setopt — Set an option for a cURL share handle.

Açıklama

bool curl_share_setopt ( resource $sh , int $option , string $value )

Sets an option on the given cURL share handle.

Değiştirgeler

sh

A cURL share handle returned by curl_share_init().

option

Option | Description
CURLSHOPT_SHARE | Specifies a type of data that should be shared.
CURLSHOPT_UNSHARE | Specifies a type of data that will be no longer shared.

value

Value | Description
CURL_LOCK_DATA_COOKIE | Shares cookie data.
CURL_LOCK_DATA_DNS | Shares DNS cache. Note that when you use cURL multi handles, all handles added to the same multi handle will share DNS cache by default.
CURL_LOCK_DATA_SSL_SESSION | Shares SSL session IDs, reducing the time spent on the SSL handshake when reconnecting to the same server. Note that SSL session IDs are reused within the same handle by default.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 curl_share_setopt() example

This example will create a cURL share handle, add two cURL handles to it, and then run them with cookie data sharing.

<?php
// Create cURL share handle and set it to share cookie data
$sh = curl_share_init();
curl_share_setopt($sh, CURLSHOPT_SHARE, CURL_LOCK_DATA_COOKIE);

// Initialize the first cURL handle and assign the share handle to it
$ch1 = curl_init("http://example.com/");
curl_setopt($ch1, CURLOPT_SHARE, $sh);

// Execute the first cURL handle
curl_exec($ch1);

// Initialize the second cURL handle and assign the share handle to it
$ch2 = curl_init("http://php.net/");
curl_setopt($ch2, CURLOPT_SHARE, $sh);

// Execute the second cURL handle
//  all cookies from $ch1 handle are shared with $ch2 handle
curl_exec($ch2);

// Close the cURL share handle
curl_share_close($sh);

// Close the cURL handles
curl_close($ch1);
curl_close($ch2);
?>

curl_share_init
curl_strerror
cURL İşlevleri


Return string describing the given error code

curl_share_setopt
curl_unescape
cURL İşlevleri
PHP Manual

curl_strerror

(PHP 5 >= 5.5.0, PHP 7)

curl_strerror — Return string describing the given error code

Açıklama

string curl_strerror ( int $errornum )

Returns a text error message describing the given error code.

Değiştirgeler

errornum

One of the » cURL error codes constants.

Dönen Değerler

Returns error description or NULL for invalid error code.

Örnekler

Örnek 1 curl_errno() example

<?php
// Create a curl handle with a mispelled protocol in URL
$ch = curl_init("htp://example.com/");

// Send request
curl_exec($ch);

// Check for errors and display the error message
if($errno = curl_errno($ch)) {
    $error_message = curl_strerror($errno);
    echo "cURL error ({$errno}):\n {$error_message}";
}

// Close the handle
curl_close($ch);
?>

Yukarıdaki örneğin çıktısı:

cURL error (1):
 Unsupported protocol

Ayrıca Bakınız

  • curl_errno() - Belirtilen oturumdaki son hatanın kodunu döndürür
  • curl_error() - Belirtilen oturumdaki son hatayı içeren bir dizge döndürür
  • » Curl error codes

curl_share_setopt
curl_unescape
cURL İşlevleri


Decodes the given URL encoded string

curl_strerror
curl_version
cURL İşlevleri
PHP Manual

curl_unescape

(PHP 5 >= 5.5.0, PHP 7)

curl_unescape — Decodes the given URL encoded string

Açıklama

string curl_unescape ( resource $ch , string $str )

This function decodes the given URL encoded string.

Değiştirgeler

ct

curl_init() işlevinden dönen bir cURL tanıtıcısı.

str

The URL encoded string to be decoded.

Dönen Değerler

Returns decoded string başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 curl_escape() example

<?php
// Create a curl handle
$ch = curl_init('http://example.com/redirect.php');

// Send HTTP request and follow redirections
curl_setopt($ch, CURLOPT_FOLLOWLOCATION, 1);
curl_exec($ch);

// Get the last effective URL
$effective_url = curl_getinfo($ch, CURLINFO_EFFECTIVE_URL);
// ie. "http://example.com/show_location.php?loc=M%C3%BCnchen"

// Decode the URL
$effective_url_decoded = curl_unescape($ch, $effective_url);
// "http://example.com/show_location.php?loc=München"

// Close the handle
curl_close($ch);
?>

Notlar

Bilginize:

curl_unescape() does not decode plus symbols (+) into spaces. urldecode() does.

Ayrıca Bakınız

  • curl_escape() - URL encodes the given string
  • urlencode() - Dizgeye URL kodlaması uygular
  • urldecode() - URL kodlamalı dizgenin kodlamasını çözer
  • rawurlencode() - RFC 1738'e uygun URL kodlaması yapar
  • rawurldecode() - URL kodlamalı dizgenin kodlamasını kaldırır

curl_strerror
curl_version
cURL İşlevleri


cURL sürüm bilgilerini döndürür

curl_unescape
CURLFile
cURL İşlevleri
PHP Manual

curl_version

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

curl_version — cURL sürüm bilgilerini döndürür

Açıklama

array curl_version ([ int $dönem = CURLVERSION_NOW ] )

cURL sürümü hakkında bilgi döndürür.

Değiştirgeler

dönem

Dönen Değerler

Aşağıdaki elemanları içeren bir ilişkisel dizi döner:

Anahtar ismi | Değer açıklaması
version_number | 24 bitlik cURL sürüm numarası
version | Bir dizge olarak cURL sürüm numarası
ssl_version_number | 24 bitlik OpenSSL sürüm numarası
ssl_version | Bir dizge olarak OpenSSL sürüm numarası
libz_version | Bir dizge olarak zlib sürüm numarası
host | cURL'nin kurulu olduğu konut hakkında bilgi
age |
features | CURL_VERSION_XXX sabitlerinden oluşan bir bit maskesi
protocols | cURL tarafından desteklenen protokol isimlerini içeren bir dizi

Örnekler

Örnek 1 - curl_version() örneği

Bu örnekte, curl_version() ile döndürülen 'features' bit maskesini kullanarak mevcut cURL kurulumuyla hangi özelliklerin kullanılabileceğine bakılmaktadır.

<?php
// cURL sürüm dizisini alalım
$sürüm = curl_version();

// cURL kurulumundaki özellikleri
// bu bit maskesinden öğreneceğiz
$bitmaskesi = Array(
            'CURL_VERSION_IPV6',
            'URL_VERSION_KERBEROS4',
            'CURL_VERSION_SSL',
            'CURL_VERSION_LIBZ'
            );

foreach($bitmaskesi as $özellik)
{
    echo $özellik . ($sürüm['features'] & constant($özellik) ?
                   ' kullanılabilir' : ' kullanılamaz');
    echo PHP_EOL;
}
?>

curl_unescape
CURLFile
cURL İşlevleri


The CURLFile class

(PHP 5 >= 5.5.0, PHP 7)

Giriş

CURLFile should be used to upload a file with CURLOPT_POSTFIELDS.

Sınıf Sözdizimi

CURLFile {
/* Özellikler */
public $name ;
public $mime ;
public $postname ;
/* Yöntemler */
public __construct ( string $filename [, string $mimetype [, string $postname ]] )
public string getFilename ( void )
public string getMimeType ( void )
public string getPostFilename ( void )
public void setMimeType ( string $mime )
public void setPostFilename ( string $postname )
public void __wakeup ( void )
}

Özellikler

name

Name of the file to be uploaded.

mime

MIME type of the file (default is application/octet-stream).

postname

The name of the file in the upload data (defaults to the name property).

Ayrıca Bakınız

  • curl_setopt()

İçindekiler

  • CURLFile::__construct — Create a CURLFile object
  • CURLFile::getFilename — Get file name
  • CURLFile::getMimeType — Get MIME type
  • CURLFile::getPostFilename — Get file name for POST
  • CURLFile::setMimeType — Set MIME type
  • CURLFile::setPostFilename — Set file name for POST
  • CURLFile::__wakeup — Unserialization handler
curl_version
CURLFile::__construct
cURL


Create a CURLFile object

CURLFile
CURLFile::getFilename
CURLFile
PHP Manual

CURLFile::__construct

curl_file_create

(PHP 5 >= 5.5.0, PHP 7)

CURLFile::__construct -- curl_file_create — Create a CURLFile object

Açıklama

Nesne yönelimli kullanım

public CURLFile::__construct ( string $filename [, string $mimetype [, string $postname ]] )

Yordamsal kullanım

CURLFile curl_file_create ( string $filename [, string $mimetype [, string $postname ]] )

Creates a CURLFile object, used to upload a file with CURLOPT_POSTFIELDS.

Değiştirgeler

filename

Path to the file which will be uploaded.

mimetype

Mimetype of the file.

postname

Name of the file to be used in the upload data.

Dönen Değerler

Returns a CURLFile object.

Örnekler

Örnek 1 CURLFile::__construct() example

Nesne yönelimli kullanım

<?php
/* http://example.com/upload.php:
<?php var_dump($_FILES); ?>
*/

// Create a cURL handle
$ch = curl_init('http://example.com/upload.php');

// Create a CURLFile object
$cfile = new CURLFile('cats.jpg','image/jpeg','test_name');

// Assign POST data
$data = array('test_file' => $cfile);
curl_setopt($ch, CURLOPT_POST,1);
curl_setopt($ch, CURLOPT_POSTFIELDS, $data);

// Execute the handle
curl_exec($ch);
?>

Yordamsal kullanım

<?php
/* http://example.com/upload.php:
<?php var_dump($_FILES); ?>
*/

// Create a cURL handle
$ch = curl_init('http://example.com/upload.php');

// Create a CURLFile object
$cfile = curl_file_create('cats.jpg','image/jpeg','test_name');

// Assign POST data
$data = array('test_file' => $cfile);
curl_setopt($ch, CURLOPT_POST,1);
curl_setopt($ch, CURLOPT_POSTFIELDS, $data);

// Execute the handle
curl_exec($ch);
?>

Yukarıdaki örneğin çıktısı:

array(1) {
  ["test_file"]=>
  array(5) {
    ["name"]=>
    string(9) "test_name"
    ["type"]=>
    string(10) "image/jpeg"
    ["tmp_name"]=>
    string(14) "/tmp/phpPC9Kbx"
    ["error"]=>
    int(0)
    ["size"]=>
    int(46334)
  }
}

Ayrıca Bakınız

  • curl_setopt() - Bir cURL aktarım seçeneği tanımlar

CURLFile
CURLFile::getFilename
CURLFile


Get file name

CURLFile::__construct
CURLFile::getMimeType
CURLFile
PHP Manual

CURLFile::getFilename

(PHP 5 >= 5.5.0, PHP 7)

CURLFile::getFilename — Get file name

Açıklama

public string CURLFile::getFilename ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns file name.

CURLFile::__construct
CURLFile::getMimeType
CURLFile


Get MIME type

CURLFile::getFilename
CURLFile::getPostFilename
CURLFile
PHP Manual

CURLFile::getMimeType

(PHP 5 >= 5.5.0, PHP 7)

CURLFile::getMimeType — Get MIME type

Açıklama

public string CURLFile::getMimeType ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns MIME type.

CURLFile::getFilename
CURLFile::getPostFilename
CURLFile


Get file name for POST

CURLFile::getMimeType
CURLFile::setMimeType
CURLFile
PHP Manual

CURLFile::getPostFilename

(PHP 5 >= 5.5.0, PHP 7)

CURLFile::getPostFilename — Get file name for POST

Açıklama

public string CURLFile::getPostFilename ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns file name for POST.

CURLFile::getMimeType
CURLFile::setMimeType
CURLFile


Set MIME type

CURLFile::getPostFilename
CURLFile::setPostFilename
CURLFile
PHP Manual

CURLFile::setMimeType

(PHP 5 >= 5.5.0, PHP 7)

CURLFile::setMimeType — Set MIME type

Açıklama

public void CURLFile::setMimeType ( string $mime )

Değiştirgeler

mime

MIME type to be used in POST data.

Dönen Değerler

Hiçbir değer dönmez.

CURLFile::getPostFilename
CURLFile::setPostFilename
CURLFile


Set file name for POST

CURLFile::setMimeType
CURLFile::__wakeup
CURLFile
PHP Manual

CURLFile::setPostFilename

(PHP 5 >= 5.5.0, PHP 7)

CURLFile::setPostFilename — Set file name for POST

Açıklama

public void CURLFile::setPostFilename ( string $postname )

Değiştirgeler

postname

Filename to be used in POST data.

Dönen Değerler

Hiçbir değer dönmez.

CURLFile::setMimeType
CURLFile::__wakeup
CURLFile


Unserialization handler

CURLFile::setPostFilename
Event
CURLFile
PHP Manual

CURLFile::__wakeup

(PHP 5 >= 5.5.0, PHP 7)

CURLFile::__wakeup — Unserialization handler

Açıklama

public void CURLFile::__wakeup ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

CURLFile is not serializable.

CURLFile::setPostFilename
Event
CURLFile


Event

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Örnekler
  • Event flags
  • About event persistence
  • Event callbacks
  • Constructing signal events
  • Event — The Event class
    • Event::add — Makes event pending
    • Event::addSignal — Makes signal event pending
    • Event::addTimer — Makes timer event pending
    • Event::__construct — Constructs Event object
    • Event::del — Makes event non-pending
    • Event::delSignal — Makes signal event non-pending
    • Event::delTimer — Makes timer event non-pending
    • Event::free — Make event non-pending and free resources allocated for this event.
    • Event::getSupportedMethods — Returns array with of the names of the methods supported in this version of Libevent
    • Event::pending — Detects whether event is pending or scheduled
    • Event::set — Re-configures event
    • Event::setPriority — Set event priority
    • Event::setTimer — Re-configures timer event
    • Event::signal — Constructs signal event object
    • Event::timer — Constructs timer event object
  • EventBase — The EventBase class
    • EventBase::__construct — Constructs EventBase object
    • EventBase::dispatch — Dispatch pending events
    • EventBase::exit — Stop dispatching events
    • EventBase::free — Free resources allocated for this event base
    • EventBase::getFeatures — Returns bitmask of features supported
    • EventBase::getMethod — Returns event method in use
    • EventBase::getTimeOfDayCached — Returns the current event base time
    • EventBase::gotExit — Checks if the event loop was told to exit
    • EventBase::gotStop — Checks if the event loop was told to exit
    • EventBase::loop — Dispatch pending events
    • EventBase::priorityInit — Sets number of priorities per event base
    • EventBase::reInit — Re-initialize event base(after a fork).
    • EventBase::stop — Tells event_base to stop dispatching events
  • EventBuffer — The EventBuffer class
    • EventBuffer::add — Append data to the end of an event buffer
    • EventBuffer::addBuffer — Move all data from a buffer provided to the current instance of EventBuffer
    • EventBuffer::appendFrom — Moves the specified number of bytes from a source buffer to the end of the current buffer
    • EventBuffer::__construct — Constructs EventBuffer object
    • EventBuffer::copyout — Copies out specified number of bytes from the front of the buffer
    • EventBuffer::drain — Removes specified number of bytes from the front of the buffer without copying it anywhere
    • EventBuffer::enableLocking — Açıklama
    • EventBuffer::expand — Reserves space in buffer
    • EventBuffer::freeze — Prevent calls that modify an event buffer from succeeding
    • EventBuffer::lock — Acquires a lock on buffer
    • EventBuffer::prepend — Prepend data to the front of the buffer
    • EventBuffer::prependBuffer — Moves all data from source buffer to the front of current buffer
    • EventBuffer::pullup — Linearizes data within buffer and returns it's contents as a string
    • EventBuffer::read — Read data from an evbuffer and drain the bytes read
    • EventBuffer::readFrom — Read data from a file onto the end of the buffer
    • EventBuffer::readLine — Extracts a line from the front of the buffer
    • EventBuffer::search — Scans the buffer for an occurrence of a string
    • EventBuffer::searchEol — Scans the buffer for an occurrence of an end of line
    • EventBuffer::substr — Substracts a portion of the buffer data
    • EventBuffer::unfreeze — Re-enable calls that modify an event buffer
    • EventBuffer::unlock — Releases lock acquired by EventBuffer::lock
    • EventBuffer::write — Write contents of the buffer to a file or socket
  • EventBufferEvent — The EventBufferEvent class
    • EventBufferEvent::close — Closes file descriptor associated with the current buffer event
    • EventBufferEvent::connect — Connect buffer event's file descriptor to given address or UNIX socket
    • EventBufferEvent::connectHost — Connects to a hostname with optionally asyncronous DNS resolving
    • EventBufferEvent::__construct — Constructs EventBufferEvent object
    • EventBufferEvent::createPair — Creates two buffer events connected to each other
    • EventBufferEvent::disable — Disable events read, write, or both on a buffer event.
    • EventBufferEvent::enable — Enable events read, write, or both on a buffer event.
    • EventBufferEvent::free — Free a buffer event
    • EventBufferEvent::getDnsErrorString — Returns string describing the last failed DNS lookup attempt
    • EventBufferEvent::getEnabled — Returns bitmask of events currently enabled on the buffer event
    • EventBufferEvent::getInput — Returns underlying input buffer associated with current buffer event
    • EventBufferEvent::getOutput — Returns underlying output buffer associated with current buffer event
    • EventBufferEvent::read — Read buffer's data
    • EventBufferEvent::readBuffer — Drains the entire contents of the input buffer and places them into buf
    • EventBufferEvent::setCallbacks — Assigns read, write and event(status) callbacks
    • EventBufferEvent::setPriority — Assign a priority to a bufferevent
    • EventBufferEvent::setTimeouts — Set the read and write timeout for a buffer event
    • EventBufferEvent::setWatermark — Adjusts read and/or write watermarks
    • EventBufferEvent::sslError — Returns most recent OpenSSL error reported on the buffer event
    • EventBufferEvent::sslFilter — Create a new SSL buffer event to send its data over another buffer event
    • EventBufferEvent::sslGetCipherInfo — Returns a textual description of the cipher.
    • EventBufferEvent::sslGetCipherName — Returns the current cipher name of the SSL connection.
    • EventBufferEvent::sslGetCipherVersion — Returns version of cipher used by current SSL connection.
    • EventBufferEvent::sslGetProtocol — Returns the name of the protocol used for current SSL connection.
    • EventBufferEvent::sslRenegotiate — Tells a bufferevent to begin SSL renegotiation.
    • EventBufferEvent::sslSocket — Creates a new SSL buffer event to send its data over an SSL on a socket
    • EventBufferEvent::write — Adds data to a buffer event's output buffer
    • EventBufferEvent::writeBuffer — Adds contents of the entire buffer to a buffer event's output buffer
  • About buffer event callbacks
  • EventConfig — The EventConfig class
    • EventConfig::avoidMethod — Tells libevent to avoid specific event method
    • EventConfig::__construct — Constructs EventConfig object
    • EventConfig::requireFeatures — Enters a required event method feature that the application demands
    • EventConfig::setMaxDispatchInterval — Prevents priority inversion
  • EventDnsBase — The EventDnsBase class
    • EventDnsBase::addNameserverIp — Adds a nameserver to the DNS base
    • EventDnsBase::addSearch — Adds a domain to the list of search domains
    • EventDnsBase::clearSearch — Removes all current search suffixes
    • EventDnsBase::__construct — Constructs EventDnsBase object
    • EventDnsBase::countNameservers — Gets the number of configured nameservers
    • EventDnsBase::loadHosts — Loads a hosts file (in the same format as /etc/hosts) from hosts file
    • EventDnsBase::parseResolvConf — Scans the resolv.conf-formatted file
    • EventDnsBase::setOption — Set the value of a configuration option
    • EventDnsBase::setSearchNdots — Set the 'ndots' parameter for searches
  • EventHttp — The EventHttp class
    • EventHttp::accept — Makes an HTTP server accept connections on the specified socket stream or resource
    • EventHttp::addServerAlias — Adds a server alias to the HTTP server object
    • EventHttp::bind — Binds an HTTP server on the specified address and port
    • EventHttp::__construct — Constructs EventHttp object(the HTTP server)
    • EventHttp::removeServerAlias — Removes server alias
    • EventHttp::setAllowedMethods — Sets the what HTTP methods are supported in requests accepted by this server, and passed to user callbacks
    • EventHttp::setCallback — Sets a callback for specified URI
    • EventHttp::setDefaultCallback — Sets default callback to handle requests that are not caught by specific callbacks
    • EventHttp::setMaxBodySize — Sets maximum request body size
    • EventHttp::setMaxHeadersSize — Sets maximum HTTP header size
    • EventHttp::setTimeout — Sets the timeout for an HTTP request
  • EventHttpConnection — The EventHttpConnection class
    • EventHttpConnection::__construct — Constructs EventHttpConnection object
    • EventHttpConnection::getBase — Returns event base associated with the connection
    • EventHttpConnection::getPeer — Gets the remote address and port associated with the connection
    • EventHttpConnection::makeRequest — Makes an HTTP request over the specified connection
    • EventHttpConnection::setCloseCallback — Set callback for connection close
    • EventHttpConnection::setLocalAddress — Sets the IP address from which HTTP connections are made
    • EventHttpConnection::setLocalPort — Sets the local port from which connections are made
    • EventHttpConnection::setMaxBodySize — Sets maximum body size for the connection
    • EventHttpConnection::setMaxHeadersSize — Sets maximum header size
    • EventHttpConnection::setRetries — Sets the retry limit for the connection
    • EventHttpConnection::setTimeout — Sets the timeout for the connection
  • EventHttpRequest — The EventHttpRequest class
    • EventHttpRequest::addHeader — Adds an HTTP header to the headers of the request
    • EventHttpRequest::cancel — Cancels a pending HTTP request
    • EventHttpRequest::clearHeaders — Removes all output headers from the header list of the request
    • EventHttpRequest::closeConnection — Closes associated HTTP connection
    • EventHttpRequest::__construct — Constructs EventHttpRequest object
    • EventHttpRequest::findHeader — Finds the value belonging a header
    • EventHttpRequest::free — Frees the object and removes associated events
    • EventHttpRequest::getBufferEvent — Returns EventBufferEvent object
    • EventHttpRequest::getCommand — Returns the request command(method)
    • EventHttpRequest::getConnection — Returns EventHttpConnection object
    • EventHttpRequest::getHost — Returns the request host
    • EventHttpRequest::getInputBuffer — Returns the input buffer
    • EventHttpRequest::getInputHeaders — Returns associative array of the input headers
    • EventHttpRequest::getOutputBuffer — Returns the output buffer of the request
    • EventHttpRequest::getOutputHeaders — Returns associative array of the output headers
    • EventHttpRequest::getResponseCode — Returns the response code
    • EventHttpRequest::getUri — Returns the request URI
    • EventHttpRequest::removeHeader — Removes an HTTP header from the headers of the request
    • EventHttpRequest::sendError — Send an HTML error message to the client
    • EventHttpRequest::sendReply — Send an HTML reply to the client
    • EventHttpRequest::sendReplyChunk — Send another data chunk as part of an ongoing chunked reply
    • EventHttpRequest::sendReplyEnd — Complete a chunked reply, freeing the request as appropriate
    • EventHttpRequest::sendReplyStart — Initiate a chunked reply
  • EventListener — The EventListener class
    • EventListener::__construct — Creates new connection listener associated with an event base
    • EventListener::disable — Disables an event connect listener object
    • EventListener::enable — Enables an event connect listener object
    • EventListener::getBase — Returns event base associated with the event listener
    • EventListener::getSocketName — Retreives the current address to which the listener's socket is bound.
    • EventListener::setCallback — The setCallback purpose
    • EventListener::setErrorCallback — Set event listener's error callback
  • EventSslContext — The EventSslContext class
    • EventSslContext::__construct — Constructs an OpenSSL context for use with Event classes
  • EventUtil — The EventUtil class
    • EventUtil::__construct — The abstract constructor
    • EventUtil::getLastSocketErrno — Returns the most recent socket error number
    • EventUtil::getLastSocketError — Returns the most recent socket error
    • EventUtil::getSocketFd — Returns numeric file descriptor of a socket, or stream
    • EventUtil::getSocketName — Retreives the current address to which the socket is bound.
    • EventUtil::setSocketOption — Sets socket options
    • EventUtil::sslRandPoll — Generates entropy by means of OpenSSL's RAND_poll()
CURLFile::__wakeup
Giriş
Diğer Hizmetler


Giriş

This is an extension to efficiently schedule I/O, time and signal based events using the best I/O notification mechanism available for specific platform. This is a port of libevent to the PHP infrastructure.

Bilginize:

Note, Windows support introduced in event-1.9.0 .

Version 1.0.0 introduces new object-oriented API (breaking backwards compatibility), and support of libevent 2+ including HTTP, DNS, OpenSSL and the event listener.

Bilginize:

Note, event-1.0.0 and greater is not compatible with previous versions.

Event
Yapılandırma/Kurulum
Event


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Event


Gereksinimler

This extension requires » libevent library. Most modern distributions provide packages for libevent.

OpenSSL features require » OpenSSL library.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu » PECL eklentisi PHP ile gelmez.

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/event .

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Örnekler

Örnek 1 Simple HTTP client

<?php
// Read callback
function readcb($bev, $base) {
    //$input = $bev->input; //$bev->getInput();

    //$pos = $input->search("TTP");
    $pos = $bev->input->search("TTP");

    while (($n = $bev->input->remove($buf, 1024)) > 0) {
        echo $buf;
    }
}

// Event callback
function eventcb($bev, $events, $base) {
    if ($events & EventBufferEvent::CONNECTED) {
        echo "Connected.\n";
    } elseif ($events & (EventBufferEvent::ERROR | EventBufferEvent::EOF)) {
        if ($events & EventBufferEvent::ERROR) {
            echo "DNS error: ", $bev->getDnsErrorString(), PHP_EOL;
        }

        echo "Closing\n";
        $base->exit();
        exit("Done\n");
    }
}

if ($argc != 3) {
    echo <<<EOS
Trivial HTTP 0.x client
Syntax: php {$argv[0]} [hostname] [resource]
Example: php {$argv[0]} www.google.com /

EOS;
    exit();
}

$base = new EventBase();

$dns_base = new EventDnsBase($base, TRUE); // We'll use async DNS resolving
if (!$dns_base) {
    exit("Failed to init DNS Base\n");
}

$bev = new EventBufferEvent($base, /* use internal socket */ NULL,
    EventBufferEvent::OPT_CLOSE_ON_FREE | EventBufferEvent::OPT_DEFER_CALLBACKS,
    "readcb", /* writecb */ NULL, "eventcb"
);
if (!$bev) {
    exit("Failed creating bufferevent socket\n");
}

//$bev->setCallbacks("readcb", /* writecb */ NULL, "eventcb", $base);
$bev->enable(Event::READ | Event::WRITE);

$output = $bev->output; //$bev->getOutput();
if (!$output->add(
    "GET {$argv[2]} HTTP/1.0\r\n".
    "Host: {$argv[1]}\r\n".
    "Connection: Close\r\n\r\n"
)) {
    exit("Failed adding request to output buffer\n");
}

if (!$bev->connectHost($dns_base, $argv[1], 80, EventUtil::AF_UNSPEC)) {
    exit("Can't connect to host {$argv[1]}\n");
}

$base->dispatch();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Connected.
HTTP/1.1 301 Moved Permanently
Date: Fri, 01 Mar 2013 18:47:48 GMT
Location: http://www.google.co.uk/
Content-Type: text/html; CHARSET=Windows-1254
Cache-Control: public, max-age=2592000
Server: gws
Content-Length: 221
X-XSS-Protection: 1; mode=block
X-Frame-Options: SAMEORIGIN
Age: 133438
Expires: Sat, 30 Mar 2013 05:39:28 GMT
Connection: close

<HTML><HEAD><meta http-equiv="content-type" content="text/html;CHARSET=Windows-1254">
<TITLE>301 Moved</TITLE></HEAD><BODY>
<H1>301 Moved</H1>
The document has moved
<A HREF="http://www.google.co.uk/">here</A>.
</BODY></HTML>
Closing
Done

Örnek 2 HTTP client using asynchronous DNS resolver

<?php
/*
 * 1. Connect to 127.0.0.1 at port 80
 * by means of EventBufferEvent::connect().
 *
 * 2. Request /index.cphp via HTTP/1.0
 * using the output buffer.
 *
 * 3. Asyncronously read the response and print it to stdout.
 */

// Read callback
function readcb($bev, $base) {
    $input = $bev->getInput();

    while (($n = $input->remove($buf, 1024)) > 0) {
        echo $buf;
    }
}

// Event callback
function eventcb($bev, $events, $base) {
    if ($events & EventBufferEvent::CONNECTED) {
        echo "Connected.\n";
    } elseif ($events & (EventBufferEvent::ERROR | EventBufferEvent::EOF)) {
        if ($events & EventBufferEvent::ERROR) {
            echo "DNS error: ", $bev->getDnsErrorString(), PHP_EOL;
        }

        echo "Closing\n";
        $base->exit();
        exit("Done\n");
    }
}

$base = new EventBase();

echo "step 1\n";
$bev = new EventBufferEvent($base, /* use internal socket */ NULL,
    EventBufferEvent::OPT_CLOSE_ON_FREE | EventBufferEvent::OPT_DEFER_CALLBACKS);
if (!$bev) {
    exit("Failed creating bufferevent socket\n");
}

echo "step 2\n";
$bev->setCallbacks("readcb", /* writecb */ NULL, "eventcb", $base);
$bev->enable(Event::READ | Event::WRITE);

echo "step 3\n";
// Send request
$output = $bev->getOutput();
if (!$output->add(
    "GET /index.cphp HTTP/1.0\r\n".
    "Connection: Close\r\n\r\n"
)) {
    exit("Failed adding request to output buffer\n");
}

/* Connect to the host syncronously.
We know the IP, and don't need to resolve DNS. */
if (!$bev->connect("127.0.0.1:80")) {
    exit("Can't connect to host\n");
}

// Dispatch pending events
$base->dispatch();
?>

Örnek 3 Echo server

<?php
/*
 * Simple echo server based on libevent's connection listener.
 *
 * Usage:
 * 1) In one terminal window run:
 *
 * $ php listener.php 9881
 *
 * 2) In another terminal window open up connection, e.g.:
 *
 * $ nc 127.0.0.1 9881
 *
 * 3) start typing. The server should repeat the input.
 */

class MyListenerConnection {
    private $bev, $base;

    public function __destruct() {
        $this->bev->free();
    }

    public function __construct($base, $fd) {
        $this->base = $base;

        $this->bev = new EventBufferEvent($base, $fd, EventBufferEvent::OPT_CLOSE_ON_FREE);

        $this->bev->setCallbacks(array($this, "echoReadCallback"), NULL,
            array($this, "echoEventCallback"), NULL);

        if (!$this->bev->enable(Event::READ)) {
            echo "Failed to enable READ\n";
            return;
        }
    }

    public function echoReadCallback($bev, $ctx) {
        // Copy all the data from the input buffer to the output buffer

        // Variant #1
        $bev->output->addBuffer($bev->input);

        /* Variant #2 */
        /*
        $input    = $bev->getInput();
        $output = $bev->getOutput();
        $output->addBuffer($input);
        */
    }

    public function echoEventCallback($bev, $events, $ctx) {
        if ($events & EventBufferEvent::ERROR) {
            echo "Error from bufferevent\n";
        }

        if ($events & (EventBufferEvent::EOF | EventBufferEvent::ERROR)) {
            //$bev->free();
            $this->__destruct();
        }
    }
}

class MyListener {
    public $base,
        $listener,
        $socket;
    private $conn = array();

    public function __destruct() {
        foreach ($this->conn as &$c) $c = NULL;
    }

    public function __construct($port) {
        $this->base = new EventBase();
        if (!$this->base) {
            echo "Couldn't open event base";
            exit(1);
        }

        // Variant #1
        /*
        $this->socket = socket_create(AF_INET, SOCK_STREAM, SOL_TCP);
        if (!socket_bind($this->socket, '0.0.0.0', $port)) {
            echo "Unable to bind socket\n";
            exit(1);
        }
        $this->listener = new EventListener($this->base,
            array($this, "acceptConnCallback"), $this->base,
            EventListener::OPT_CLOSE_ON_FREE | EventListener::OPT_REUSEABLE,
            -1, $this->socket);
         */

        // Variant #2
         $this->listener = new EventListener($this->base,
             array($this, "acceptConnCallback"), $this->base,
             EventListener::OPT_CLOSE_ON_FREE | EventListener::OPT_REUSEABLE, -1,
             "0.0.0.0:$port");

        if (!$this->listener) {
            echo "Couldn't create listener";
            exit(1);
        }

        $this->listener->setErrorCallback(array($this, "accept_error_cb"));
    }

    public function dispatch() {
        $this->base->dispatch();
    }

    // This callback is invoked when there is data to read on $bev
    public function acceptConnCallback($listener, $fd, $address, $ctx) {
        // We got a new connection! Set up a bufferevent for it. */
        $base = $this->base;
        $this->conn[] = new MyListenerConnection($base, $fd);
    }

    public function accept_error_cb($listener, $ctx) {
        $base = $this->base;

        fprintf(STDERR, "Got an error %d (%s) on the listener. "
            ."Shutting down.\n",
            EventUtil::getLastSocketErrno(),
            EventUtil::getLastSocketError());

        $base->exit(NULL);
    }
}

$port = 9808;

if ($argc > 1) {
    $port = (int) $argv[1];
}
if ($port <= 0 || $port > 65535) {
    exit("Invalid port");
}

$l = new MyListener($port);
$l->dispatch();
?>

Örnek 4 SSL echo server

<?php
/*
 * SSL echo server
 *
 * To test:
 * 1) Run:
 * $ php examples/ssl-echo-server/server.php 9998
 *
 * 2) in another terminal window run:
 * $ socat - SSL:127.0.0.1:9998,verify=1,cafile=examples/ssl-echo-server/cert.pem
 */

class MySslEchoServer {
    public $port,
        $base,
        $bev,
        $listener,
        $ctx;

    function __construct ($port, $host = "127.0.0.1") {
        $this->port = $port;
        $this->ctx = $this->init_ssl();
        if (!$this->ctx) {
            exit("Failed creating SSL context\n");
        }

        $this->base = new EventBase();
        if (!$this->base) {
            exit("Couldn't open event base\n");
        }

        $this->listener = new EventListener($this->base,
            array($this, "ssl_accept_cb"), $this->ctx,
            EventListener::OPT_CLOSE_ON_FREE | EventListener::OPT_REUSEABLE,
            -1, "$host:$port");
        if (!$this->listener) {
            exit("Couldn't create listener\n");
        }

        $this->listener->setErrorCallback(array($this, "accept_error_cb"));
    }
    function dispatch() {
        $this->base->dispatch();
    }

    // This callback is invoked when there is data to read on $bev.
    function ssl_read_cb($bev, $ctx) {
        $in = $bev->input; //$bev->getInput();

        printf("Received %zu bytes\n", $in->length);
        printf("----- data ----\n");
        printf("%ld:\t%s\n", (int) $in->length, $in->pullup(-1));

        $bev->writeBuffer($in);
    }

    // This callback is invoked when some even occurs on the event listener,
    // e.g. connection closed, or an error occured
    function ssl_event_cb($bev, $events, $ctx) {
        if ($events & EventBufferEvent::ERROR) {
            // Fetch errors from the SSL error stack
            while ($err = $bev->sslError()) {
                fprintf(STDERR, "Bufferevent error %s.\n", $err);
            }
        }

        if ($events & (EventBufferEvent::EOF | EventBufferEvent::ERROR)) {
            $bev->free();
        }
    }

    // This callback is invoked when a client accepts new connection
    function ssl_accept_cb($listener, $fd, $address, $ctx) {
        // We got a new connection! Set up a bufferevent for it.
        $this->bev = EventBufferEvent::sslSocket($this->base, $fd, $this->ctx,
            EventBufferEvent::SSL_ACCEPTING, EventBufferEvent::OPT_CLOSE_ON_FREE);

        if (!$this->bev) {
            echo "Failed creating ssl buffer\n";
            $this->base->exit(NULL);
            exit(1);
        }

        $this->bev->enable(Event::READ);
        $this->bev->setCallbacks(array($this, "ssl_read_cb"), NULL,
            array($this, "ssl_event_cb"), NULL);
    }

    // This callback is invoked when we failed to setup new connection for a client
    function accept_error_cb($listener, $ctx) {
        fprintf(STDERR, "Got an error %d (%s) on the listener. "
            ."Shutting down.\n",
            EventUtil::getLastSocketErrno(),
            EventUtil::getLastSocketError());

        $this->base->exit(NULL);
    }

    // Initialize SSL structures, create an EventSslContext
    // Optionally create self-signed certificates
    function init_ssl() {
        // We *must* have entropy. Otherwise there's no point to crypto.
        if (!EventUtil::sslRandPoll()) {
            exit("EventUtil::sslRandPoll failed\n");
        }

        $local_cert = __DIR__."/cert.pem";
        $local_pk   = __DIR__."/privkey.pem";

        if (!file_exists($local_cert) || !file_exists($local_pk)) {
            echo "Couldn't read $local_cert or $local_pk file.  To generate a key\n",
                "and self-signed certificate, run:\n",
                "  openssl genrsa -out $local_pk 2048\n",
                "  openssl req -new -key $local_pk -out cert.req\n",
                "  openssl x509 -req -days 365 -in cert.req -signkey $local_pk -out $local_cert\n";

            return FALSE;
        }

        $ctx = new EventSslContext(EventSslContext::SSLv3_SERVER_METHOD, array (
             EventSslContext::OPT_LOCAL_CERT  => $local_cert,
             EventSslContext::OPT_LOCAL_PK    => $local_pk,
             //EventSslContext::OPT_PASSPHRASE  => "echo server",
             EventSslContext::OPT_VERIFY_PEER => true,
             EventSslContext::OPT_ALLOW_SELF_SIGNED => false,
        ));

        return $ctx;
    }
}

// Allow to override the port
$port = 9999;
if ($argc > 1) {
    $port = (int) $argv[1];
}
if ($port <= 0 || $port > 65535) {
    exit("Invalid port\n");
}

$l = new MySslEchoServer($port);
$l->dispatch();
?>

Örnek 5 Signal handler

<?php
/*
Launch it in a terminal window:

$ php examples/signal.php

In another terminal window find out the pid and send SIGTERM, e.g.:

$ ps aux | grep examp
ruslan    3976  0.2  0.0 139896 11256 pts/1    S+   10:25   0:00 php examples/signal.php
ruslan    3978  0.0  0.0   9572   864 pts/2    S+   10:26   0:00 grep --color=auto examp
$ kill -TERM 3976

At the first terminal window you should catch the following:

Caught signal 15
*/
class MyEventSignal {
    private $base;

    function __construct($base) {
        $this->base = $base;
    }

    function eventSighandler($no, $c) {
        echo "Caught signal $no\n";
        event_base_loopexit($c->base);
    }
}

$base = event_base_new();
$c    = new MyEventSignal($base);
$no   = SIGTERM;
$ev   = evsignal_new($base, $no, array($c,'eventSighandler'), $c);

evsignal_add($ev);

event_base_loop($base);
?>

Örnek 6 Use libevent's loop to process requests of `eio' extension

<?php
// Callback for eio_nop()
function my_nop_cb($d, $r) {
    echo "step 6\n";
}

$dir = "/tmp/abc-eio-temp";
if (file_exists($dir)) {
    rmdir($dir);
}

echo "step 1\n";

$base = new EventBase();

echo "step 2\n";

eio_init();

eio_mkdir($dir, 0750, EIO_PRI_DEFAULT, "my_nop_cb");

$event = new Event($base, eio_get_event_stream(),
    Event::READ | Event::PERSIST, function ($fd, $events, $base) {
    echo "step 5\n";

    while (eio_nreqs()) {
        eio_poll();
    }

    $base->stop();
}, $base);

echo "step 3\n";

$event->add();

echo "step 4\n";

$base->dispatch();

echo "Done\n";
?>

Örnek 7 Miscellaneous

<?php
/* {{{ Config & supported stuff */
echo "Supported methods:\n";
foreach (Event::getSupportedMethods() as $m) {
    echo $m, PHP_EOL;
}

// Avoiding "select" method
$cfg = new EventConfig();
if ($cfg->avoidMethod("select")) {
    echo "`select' method avoided\n";
}

// Create event_base associated with the config
$base = new EventBase($cfg);
echo "Event method used: ", $base->getMethod(), PHP_EOL;

echo "Features:\n";
$features = $base->getFeatures();
($features & EventConfig::FEATURE_ET) and print("ET - edge-triggered IO\n");
($features & EventConfig::FEATURE_O1) and print("O1 - O(1) operation for adding/deletting events\n");
($features & EventConfig::FEATURE_FDS) and print("FDS - arbitrary file descriptor types, and not just sockets\n");

// Require FDS feature
if ($cfg->requireFeatures(EventConfig::FEATURE_FDS)) {
    echo "FDS feature is now requried\n";

    $base = new EventBase($cfg);
    ($base->getFeatures() & EventConfig::FEATURE_FDS)
        and print("FDS - arbitrary file descriptor types, and not just sockets\n");
}
/* }}} */

/* {{{ Base */
$base = new EventBase();
$event = new Event($base, STDIN, Event::READ | Event::PERSIST, function ($fd, $events, $arg) {
    static $max_iterations = 0;

    if (++$max_iterations >= 5) {
        /* exit after 5 iterations with timeout of 2.33 seconds */
        echo "Stopping...\n";
        $arg[0]->exit(2.33);
    }

    echo fgets($fd);
}, array (&$base));

$event->add();
$base->loop();
/* Base }}} */
?>

Örnek 8 Simple HTTP server

<?php
/*
 * Simple HTTP server.
 *
 * To test it:
 * 1) Run it on a port of your choice, e.g.:
 * $ php examples/http.php 8010
 * 2) In another terminal connect to some address on this port
 * and make GET or POST request(others are turned off here), e.g.:
 * $ nc -t 127.0.0.1 8010
 * POST /about HTTP/1.0
 * Content-Type: text/plain
 * Content-Length: 4
 * Connection: close
 * (press Enter)
 *
 * It will output
 * a=12
 * HTTP/1.0 200 OK
 * Content-Type: text/html; charset=ISO-8859-1
 * Connection: close
 *
 * $ nc -t 127.0.0.1 8010
 * GET /dump HTTP/1.0
 * Content-Type: text/plain
 * Content-Encoding: UTF-8
 * Connection: close
 * (press Enter)
 *
 * It will output:
 * HTTP/1.0 200 OK
 * Content-Type: text/html; charset=ISO-8859-1
 * Connection: close
 * (press Enter)
 *
 * $ nc -t 127.0.0.1 8010
 * GET /unknown HTTP/1.0
 * Connection: close
 *
 * It will output:
 * HTTP/1.0 200 OK
 * Content-Type: text/html; charset=ISO-8859-1
 * Connection: close
 *
 * 3) See what the server outputs on the previous terminal window.
 */

function _http_dump($req, $data) {
    static $counter      = 0;
    static $max_requests = 2;

    if (++$counter >= $max_requests)  {
        echo "Counter reached max requests $max_requests. Exiting\n";
        exit();
    }

    echo __METHOD__, " called\n";
    echo "request:"; var_dump($req);
    echo "data:"; var_dump($data);

    echo "\n===== DUMP =====\n";
    echo "Command:", $req->getCommand(), PHP_EOL;
    echo "URI:", $req->getUri(), PHP_EOL;
    echo "Input headers:"; var_dump($req->getInputHeaders());
    echo "Output headers:"; var_dump($req->getOutputHeaders());

    echo "\n >> Sending reply ...";
    $req->sendReply(200, "OK");
    echo "OK\n";

    echo "\n >> Reading input buffer ...\n";
    $buf = $req->getInputBuffer();
    while ($s = $buf->readLine(EventBuffer::EOL_ANY)) {
        echo $s, PHP_EOL;
    }
    echo "No more data in the buffer\n";
}

function _http_about($req) {
    echo __METHOD__, PHP_EOL;
    echo "URI: ", $req->getUri(), PHP_EOL;
    echo "\n >> Sending reply ...";
    $req->sendReply(200, "OK");
    echo "OK\n";
}

function _http_default($req, $data) {
    echo __METHOD__, PHP_EOL;
    echo "URI: ", $req->getUri(), PHP_EOL;
    echo "\n >> Sending reply ...";
    $req->sendReply(200, "OK");
    echo "OK\n";
}

$port = 8010;
if ($argc > 1) {
    $port = (int) $argv[1];
}
if ($port <= 0 || $port > 65535) {
    exit("Invalid port");
}

$base = new EventBase();
$http = new EventHttp($base);
$http->setAllowedMethods(EventHttpRequest::CMD_GET | EventHttpRequest::CMD_POST);

$http->setCallback("/dump", "_http_dump", array(4, 8));
$http->setCallback("/about", "_http_about");
$http->setDefaultCallback("_http_default", "custom data value");

$http->bind("0.0.0.0", 8010);
$base->loop();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

a=12
HTTP/1.0 200 OK
Content-Type: text/html; charset=ISO-8859-1
Connection: close

HTTP/1.0 200 OK
Content-Type: text/html; charset=ISO-8859-1
Connection: close
(press Enter)

HTTP/1.0 200 OK
Content-Type: text/html; charset=ISO-8859-1
Connection: close

Örnek 9 Simple HTTPS server

<?php
/*
 * Simple HTTPS server.
 *
 * 1) Run the server: `php examples/https.php 9999`
 * 2) Test it: `php examples/ssl-connection.php 9999`
 */

function _http_dump($req, $data) {
    static $counter      = 0;
    static $max_requests = 200;

    if (++$counter >= $max_requests)  {
        echo "Counter reached max requests $max_requests. Exiting\n";
        exit();
    }

    echo __METHOD__, " called\n";
    echo "request:"; var_dump($req);
    echo "data:"; var_dump($data);

    echo "\n===== DUMP =====\n";
    echo "Command:", $req->getCommand(), PHP_EOL;
    echo "URI:", $req->getUri(), PHP_EOL;
    echo "Input headers:"; var_dump($req->getInputHeaders());
    echo "Output headers:"; var_dump($req->getOutputHeaders());

    echo "\n >> Sending reply ...";
    $req->sendReply(200, "OK");
    echo "OK\n";

    $buf = $req->getInputBuffer();
    echo "\n >> Reading input buffer (", $buf->length, ") ...\n";
    while ($s = $buf->read(1024)) {
        echo $s;
    }
    echo "\nNo more data in the buffer\n";
}

function _http_about($req) {
    echo __METHOD__, PHP_EOL;
    echo "URI: ", $req->getUri(), PHP_EOL;
    echo "\n >> Sending reply ...";
    $req->sendReply(200, "OK");
    echo "OK\n";
}

function _http_default($req, $data) {
    echo __METHOD__, PHP_EOL;
    echo "URI: ", $req->getUri(), PHP_EOL;
    echo "\n >> Sending reply ...";
    $req->sendReply(200, "OK");
    echo "OK\n";
}

function _http_400($req) {
    $req->sendError(400);
}

function _init_ssl() {
    $local_cert = __DIR__."/ssl-echo-server/cert.pem";
    $local_pk   = __DIR__."/ssl-echo-server/privkey.pem";

    $ctx = new EventSslContext(EventSslContext::SSLv3_SERVER_METHOD, array (
        EventSslContext::OPT_LOCAL_CERT  => $local_cert,
        EventSslContext::OPT_LOCAL_PK    => $local_pk,
        //EventSslContext::OPT_PASSPHRASE  => "test",
        EventSslContext::OPT_ALLOW_SELF_SIGNED => true,
    ));

    return $ctx;
}

$port = 9999;
if ($argc > 1) {
    $port = (int) $argv[1];
}
if ($port <= 0 || $port > 65535) {
    exit("Invalid port");
}
$ip = '0.0.0.0';

$base = new EventBase();
$ctx  = _init_ssl();
$http = new EventHttp($base, $ctx);
$http->setAllowedMethods(EventHttpRequest::CMD_GET | EventHttpRequest::CMD_POST);

$http->setCallback("/dump", "_http_dump", array(4, 8));
$http->setCallback("/about", "_http_about");
$http->setCallback("/err400", "_http_400");
$http->setDefaultCallback("_http_default", "custom data value");

$http->bind($ip, $port);
$base->dispatch();

Örnek 10 OpenSSL connection

<?php
/*
 * Sample OpenSSL client.
 *
 * Usage:
 * 1) Launch a server, e.g.:
 * $ php examples/https.php 9999
 *
 * 2) Launch the client in another terminal:
 * $ php examples/ssl-connection.php 9999
 */

function _request_handler($req, $base) {
    echo __FUNCTION__, PHP_EOL;

    if (is_null($req)) {
        echo "Timed out\n";
    } else {
        $response_code = $req->getResponseCode();

        if ($response_code == 0) {
            echo "Connection refused\n";
        } elseif ($response_code != 200) {
            echo "Unexpected response: $response_code\n";
        } else {
            echo "Success: $response_code\n";
            $buf = $req->getInputBuffer();
            echo "Body:\n";
            while ($s = $buf->readLine(EventBuffer::EOL_ANY)) {
                echo $s, PHP_EOL;
            }
        }
    }

    $base->exit(NULL);
}

function _init_ssl() {
    $ctx = new EventSslContext(EventSslContext::SSLv3_CLIENT_METHOD, array ());

    return $ctx;
}

// Allow to override the port
$port = 9999;
if ($argc > 1) {
    $port = (int) $argv[1];
}
if ($port <= 0 || $port > 65535) {
    exit("Invalid port\n");
}
$host = '127.0.0.1';

$ctx = _init_ssl();
if (!$ctx) {
    trigger_error("Failed creating SSL context", E_USER_ERROR);
}

$base = new EventBase();
if (!$base) {
    trigger_error("Failed to initialize event base", E_USER_ERROR);
}

$conn = new EventHttpConnection($base, NULL, $host, $port, $ctx);
$conn->setTimeout(50);

$req = new EventHttpRequest("_request_handler", $base);
$req->addHeader("Host", $host, EventHttpRequest::OUTPUT_HEADER);
$buf = $req->getOutputBuffer();
$buf->add("<html>HTML TEST</html>");
//$req->addHeader("Content-Length", $buf->length, EventHttpRequest::OUTPUT_HEADER);
//$req->addHeader("Connection", "close", EventHttpRequest::OUTPUT_HEADER);
$conn->makeRequest($req, EventHttpRequest::CMD_POST, "/dump");

$base->dispatch();
echo "END\n";
?>

Örnek 11 EventHttpConnection::makeRequest() example

<?php
function _request_handler($req, $base) {
    echo __FUNCTION__, PHP_EOL;

    if (is_null($req)) {
        echo "Timed out\n";
    } else {
        $response_code = $req->getResponseCode();

        if ($response_code == 0) {
            echo "Connection refused\n";
        } elseif ($response_code != 200) {
            echo "Unexpected response: $response_code\n";
        } else {
            echo "Success: $response_code\n";
            $buf = $req->getInputBuffer();
            echo "Body:\n";
            while ($s = $buf->readLine(EventBuffer::EOL_ANY)) {
                echo $s, PHP_EOL;
            }
        }
    }

    $base->exit(NULL);
}

$address = "127.0.0.1";
$port = 80;

$base = new EventBase();
$conn = new EventHttpConnection($base, NULL, $address, $port);
$conn->setTimeout(5);
$req = new EventHttpRequest("_request_handler", $base);

$req->addHeader("Host", $address, EventHttpRequest::OUTPUT_HEADER);
$req->addHeader("Content-Length", "0", EventHttpRequest::OUTPUT_HEADER);
$conn->makeRequest($req, EventHttpRequest::CMD_GET, "/index.cphp");

$base->loop();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

_request_handler
Success: 200
Body:
PHP, date:
2013-03-13T20:27:52+05:00

Örnek 12 Connection listener based on a UNIX domain socket

<?php
/*
 * Simple echo server based on libevent's connection listener.
 *
 * Usage:
 * 1) In one terminal window run:
 *
 * $ php unix-domain-listener.php [path-to-socket]
 *
 * 2) In another terminal window open up connection
 * to the socket, e.g.:
 *
 * $ socat - GOPEN:/tmp/1.sock
 *
 * 3) Start typing. The server should repeat the input.
 */

class MyListenerConnection {
    private $bev, $base;

    public function __destruct() {
        if ($this->bev) {
            $this->bev->free();
        }
    }

    public function __construct($base, $fd) {
        $this->base = $base;

        $this->bev = new EventBufferEvent($base, $fd, EventBufferEvent::OPT_CLOSE_ON_FREE);

        $this->bev->setCallbacks(array($this, "echoReadCallback"), NULL,
            array($this, "echoEventCallback"), NULL);

        if (!$this->bev->enable(Event::READ)) {
            echo "Failed to enable READ\n";
            return;
        }
    }

    public function echoReadCallback($bev, $ctx) {
        // Copy all the data from the input buffer to the output buffer
        $bev->output->addBuffer($bev->input);
    }

    public function echoEventCallback($bev, $events, $ctx) {
        if ($events & EventBufferEvent::ERROR) {
            echo "Error from bufferevent\n";
        }

        if ($events & (EventBufferEvent::EOF | EventBufferEvent::ERROR)) {
            $bev->free();
            $bev = NULL;
        }
    }
}

class MyListener {
    public $base,
        $listener,
        $socket;
    private $conn = array();

    public function __destruct() {
        foreach ($this->conn as &$c) $c = NULL;
    }

    public function __construct($sock_path) {
        $this->base = new EventBase();
        if (!$this->base) {
            echo "Couldn't open event base";
            exit(1);
        }

        if (file_exists($sock_path)) {
            unlink($sock_path);
        }

         $this->listener = new EventListener($this->base,
             array($this, "acceptConnCallback"), $this->base,
             EventListener::OPT_CLOSE_ON_FREE | EventListener::OPT_REUSEABLE, -1,
             "unix:$sock_path");

        if (!$this->listener) {
            trigger_error("Couldn't create listener", E_USER_ERROR);
        }

        $this->listener->setErrorCallback(array($this, "accept_error_cb"));
    }

    public function dispatch() {
        $this->base->dispatch();
    }

    // This callback is invoked when there is data to read on $bev
    public function acceptConnCallback($listener, $fd, $address, $ctx) {
        // We got a new connection! Set up a bufferevent for it. */
        $base = $this->base;
        $this->conn[] = new MyListenerConnection($base, $fd);
    }

    public function accept_error_cb($listener, $ctx) {
        $base = $this->base;

        fprintf(STDERR, "Got an error %d (%s) on the listener. "
            ."Shutting down.\n",
            EventUtil::getLastSocketErrno(),
            EventUtil::getLastSocketError());

        $base->exit(NULL);
    }
}

if ($argc <= 1) {
    exit("Socket path is not provided\n");
}
$sock_path = $argv[1];

$l = new MyListener($sock_path);
$l->dispatch();
?>

Örnek 13 Simple SMTP server

<?php
 /*
 * Author: Andrew Rose <hello at andrewrose dot co dot uk>
 *
 * Usage:
 * 1) Prepare cert.pem certificate and privkey.pem private key files.
 * 2) Launch the server script
 * 3) Open TLS connection, e.g.:
 *      $ openssl s_client -connect localhost:25 -starttls smtp -crlf
 * 4) Start testing the commands listed in `cmd` method below.
 */

class Handler {
    public $domainName = FALSE;
    public $connections = [];
    public $buffers = [];
    public $maxRead = 256000;

    public function __construct() {
        $this->ctx = new EventSslContext(EventSslContext::SSLv3_SERVER_METHOD, [
            EventSslContext::OPT_LOCAL_CERT  => 'cert.pem',
            EventSslContext::OPT_LOCAL_PK    => 'privkey.pem',
            //EventSslContext::OPT_PASSPHRASE  => '',
            EventSslContext::OPT_VERIFY_PEER => false, // change to true with authentic cert
            EventSslContext::OPT_ALLOW_SELF_SIGNED => true // change to false with authentic cert
        ]);

        $this->base = new EventBase();
        if (!$this->base) {
            exit("Couldn't open event base\n");
        }

        if (!$this->listener = new EventListener($this->base,
            [$this, 'ev_accept'],
            $this->ctx,
            EventListener::OPT_CLOSE_ON_FREE | EventListener::OPT_REUSEABLE,
            -1,
            '0.0.0.0:25'))
        {
            exit("Couldn't create listener\n");
        }

        $this->listener->setErrorCallback([$this, 'ev_error']);
        $this->base->dispatch();
    }

    public function ev_accept($listener, $fd, $address, $ctx) {
        static $id = 0;
        $id += 1;

        $this->connections[$id]['clientData'] = '';
        $this->connections[$id]['cnx'] = new EventBufferEvent($this->base, $fd,
            EventBufferEvent::OPT_CLOSE_ON_FREE);

        if (!$this->connections[$id]['cnx']) {
            echo "Failed creating buffer\n";
            $this->base->exit(NULL);
            exit(1);
        }

        $this->connections[$id]['cnx']->setCallbacks([$this, "ev_read"], NULL,
            [$this, 'ev_error'], $id);
        $this->connections[$id]['cnx']->enable(Event::READ | Event::WRITE);

        $this->ev_write($id, '220 '.$this->domainName." wazzzap?\r\n");
    }

    function ev_error($listener, $ctx) {
        $errno = EventUtil::getLastSocketErrno();

        fprintf(STDERR, "Got an error %d (%s) on the listener. Shutting down.\n",
            $errno, EventUtil::getLastSocketError());

        if ($errno != 0) {
            $this->base->exit(NULL);
            exit();
        }
    }

    public function ev_close($id) {
        $this->connections[$id]['cnx']->disable(Event::READ | Event::WRITE);
        unset($this->connections[$id]);
    }

    protected function ev_write($id, $string) {
        echo 'S('.$id.'): '.$string;
        $this->connections[$id]['cnx']->write($string);
    }

    public function ev_read($buffer, $id) {
        while($buffer->input->length > 0) {
            $this->connections[$id]['clientData'] .= $buffer->input->read($this->maxRead);
            $clientDataLen = strlen($this->connections[$id]['clientData']);

            if($this->connections[$id]['clientData'][$clientDataLen-1] == "\n"
                && $this->connections[$id]['clientData'][$clientDataLen-2] == "\r")
            {
                // remove the trailing \r\n
                $line = substr($this->connections[$id]['clientData'], 0,
                    strlen($this->connections[$id]['clientData']) - 2);

                $this->connections[$id]['clientData'] = '';
                $this->cmd($buffer, $id, $line);
            }
        }
    }

    protected function cmd($buffer, $id, $line) {
        switch ($line) {
            case strncmp('EHLO ', $line, 4):
                $this->ev_write($id, "250-STARTTLS\r\n");
                $this->ev_write($id, "250 OK ehlo\r\n");
                break;

            case strncmp('HELO ', $line, 4):
                $this->ev_write($id, "250-STARTTLS\r\n");
                $this->ev_write($id, "250 OK helo\r\n");
                break;

            case strncmp('QUIT', $line, 3):
                $this->ev_write($id, "250 OK quit\r\n");
                $this->ev_close($id);
                break;

            case strncmp('STARTTLS', $line, 3):
                $this->ev_write($id, "220 Ready to start TLS\r\n");
                $this->connections[$id]['cnx'] = EventBufferEvent::sslFilter($this->base,
                    $this->connections[$id]['cnx'], $this->ctx,
                    EventBufferEvent::SSL_ACCEPTING,
                    EventBufferEvent::OPT_CLOSE_ON_FREE);
                $this->connections[$id]['cnx']->setCallbacks([$this, "ev_read"], NULL, [$this, 'ev_error'], $id);
                $this->connections[$id]['cnx']->enable(Event::READ | Event::WRITE);
                break;

            default:
                echo 'unknown command: '.$line."\n";
                break;
        }
    }
}

new Handler();
Özkaynak Türleri
Event flags
Event


Event flags

Event::READ This flag indicates an event that becomes active when the provided file descriptor (usually a stream resource, or socket) is ready for reading.

Event::WRITE flag indicates an event that becomes active when the provided file descriptor (usually a stream resource, or socket) is ready for writing.

Event::SIGNAL used to implement signal detection. See "Constructing signal events" below.

Event::TIMEOUT indicates an event that becomes active after a timeout elapses. The Event::TIMEOUT flag is ignored when constructing an event: one can either set a timeout when event is added , or not. It is set in the $what argument to the callback function when a timeout has occurred.

See also » Fast portable non-blocking network programming with Libevent, Working with events, Event flags

Örnekler
About event persistence
Event


About event persistence

By default, whenever a pending event becomes active (because its file descriptor is ready to read or write, or because its timeout expires), it becomes non-pending right before its callback is executed. Thus, to make the event pending again one may call Event::add() on it again from inside the callback function.

If the Event::PERSIST flag is set on an event, however, the event is persistent . This means that event remains pending even when its callback is activated. Event::del() method can be called to make it non-pending.

The timeout on a persistent event resets whenever the event's callback runs. Thus, if one has an event with flags Event::READ | Event::PERSIST and a timeout of five seconds, the event will become active:

  1. Whenever the socket or file descriptor is ready for reading.

  2. Whenever five seconds have passed since the event last became active.

See also » Fast portable non-blocking network programming with Libevent, About Event Persistence

Event flags
Event callbacks
Event


Event callbacks

If a callback is registered for an event, it will be called when the event becomes active. To associate a callback with event one can pass a callable to either Event::__construct() , or Event::set() , or one of the factory methods like Event::timer() .

An event callback should match the following prototype:

void callback ([ mixed $fd = NULL [, int $what [, mixed $arg = NULL ]]] )

fd

The file descriptor, stream resource or socket associated with the event. For signal event fd is equal to the signal number.

what

Bit mask of all events triggered.

arg

User custom data.

Event::timer() expects the callback to match the following prototype:

void callback ([ mixed $arg = NULL ] )

arg

User custom data.

Event::signal() expects the callback to match the following prototype:

void callback ([ int $signum [, mixed $arg = NULL ]] )

signum

The number of the triggered signal(e.g. SIGTERM ).

arg

User custom data.

About event persistence
Constructing signal events
Event


Constructing signal events

Event can also watch for POSIX-style signals. To construct a handler for a signal, use Event::__construct() constructor with Event::SIGNAL flag, or Event::signal() factory method.

Örnek 1 Handling SIGTERM signal

<?php
/*
Launch it in a terminal window:

$ php examples/signal.php

In another terminal window find out the pid and send SIGTERM, e.g.:

$ ps aux | grep examp
ruslan    3976  0.2  0.0 139896 11256 pts/1    S+   10:25   0:00 php examples/signal.php
ruslan    3978  0.0  0.0   9572   864 pts/2    S+   10:26   0:00 grep --color=auto examp
$ kill -TERM 3976

At the first terminal window you should catch the following:

Caught signal 15
*/
class MyEventSignal {
    private $base, $ev;

    public function __construct($base) {
        $this->base = $base;
        $this->ev = Event::signal($base, SIGTERM, array($this, 'eventSighandler'));
        $this->ev->add();
    }

    public function eventSighandler($no, $c) {
        echo "Caught signal $no\n";
        $this->base->exit();
    }
}

$base = new EventBase();
$c    = new MyEventSignal($base);

$base->loop();
?>

Note that signal callbacks are run in the event loop after the signal occurs, so it is safe for them to call functions that you are not supposed to call from a regular POSIX signal handler.

See also » Fast portable non-blocking network programming with Libevent, Constructing Signal Events .

Event callbacks
Event
Event


The Event class

(PECL event >= 1.2.6-beta)

Giriş

Event class represents and event firing on a file descriptor being ready to read from or write to; a file descriptor becoming ready to read from or write to(edge-triggered I/O only); a timeout expiring; a signal occuring; a user-triggered event.

Every event is associated with EventBase . However, event will never fire until it is added (via Event::add() ). An added event remains in pending state until the registered event occurs, thus turning it to active state. To handle events user may register a callback which is called when event becomes active. If event is configured persistent , it remains pending. If it is not persistent, it stops being pending when it's callback runs. Event::del() method deletes event, thus making it non-pending. By means of Event::add() method it could be added again.

Sınıf Sözdizimi

final Event {
/* Constants */
const integer ET = 32 ;
const integer PERSIST = 16 ;
const integer READ = 2 ;
const integer WRITE = 4 ;
const integer SIGNAL = 8 ;
const integer TIMEOUT = 1 ;
/* Özellikler */
public readonly bool $pending ;
/* Yöntemler */
public bool add ([ double $timeout ] )
public bool addSignal ([ double $timeout ] )
public bool addTimer ([ double $timeout ] )
public __construct ( EventBase $base , mixed $fd , int $what , callable $cb [, mixed $arg = NULL ] )
public bool del ( void )
public bool delSignal ( void )
public bool delTimer ( void )
public void free ( void )
public static array getSupportedMethods ( void )
public bool pending ( int $flags )
public bool set ( EventBase $base , mixed $fd [, int $what [, callable $cb [, mixed $arg ]]] )
public bool setPriority ( int $priority )
public bool setTimer ( EventBase $base , callable $cb [, mixed $arg ] )
public static Event signal ( EventBase $base , int $signum , callable $cb [, mixed $arg ] )
public static Event timer ( EventBase $base , callable $cb [, mixed $arg ] )
}

Özellikler

pending

Whether event is pending. See About event persistence .

Öntanımlı Sabitler

Event::ET

Indicates that the event should be edge-triggered, if the underlying event base backend supports edge-triggered events. This affects the semantics of Event::READ and Event::WRITE .

Event::PERSIST

Indicates that the event is persistent. See About event persistence .

Event::READ

This flag indicates an event that becomes active when the provided file descriptor(usually a stream resource, or socket) is ready for reading.

Event::WRITE

This flag indicates an event that becomes active when the provided file descriptor(usually a stream resource, or socket) is ready for reading.

Event::SIGNAL

Used to implement signal detection. See "Constructing signal events" below.

Event::TIMEOUT

This flag indicates an event that becomes active after a timeout elapses.

The Event::TIMEOUT flag is ignored when constructing an event: one can either set a timeout when event is added , or not. It is set in the $what argument to the callback function when a timeout has occurred.

İçindekiler

  • Event::add — Makes event pending
  • Event::addSignal — Makes signal event pending
  • Event::addTimer — Makes timer event pending
  • Event::__construct — Constructs Event object
  • Event::del — Makes event non-pending
  • Event::delSignal — Makes signal event non-pending
  • Event::delTimer — Makes timer event non-pending
  • Event::free — Make event non-pending and free resources allocated for this event.
  • Event::getSupportedMethods — Returns array with of the names of the methods supported in this version of Libevent
  • Event::pending — Detects whether event is pending or scheduled
  • Event::set — Re-configures event
  • Event::setPriority — Set event priority
  • Event::setTimer — Re-configures timer event
  • Event::signal — Constructs signal event object
  • Event::timer — Constructs timer event object
Constructing signal events
Event::add
Event


Makes event pending

Event
Event::addSignal
Event
PHP Manual

Event::add

(PECL libevent >= 0.0.1)

Event::add — Makes event pending

Açıklama

public bool Event::add ([ double $timeout ] )

Marks event pending. Non-pending event will never occur, and the event callback will never be called. In conjuction with Event::del() an event could be re-scheduled by user at any time.

If Event::add() is called on an already pending event, libevent will leave it pending and re-schedule it with the given timeout(if specified). If in this case timeout is not specified, Event::add() has no effect.

Değiştirgeler

timeout

Timeout in seconds.

Dönen Değerler

Returns TRUE on success. Otherwise FALSE

Ayrıca Bakınız

  • Event::addSignal() - Makes signal event pending
  • Event::addTimer() - Makes timer event pending
  • Event::del() - Makes event non-pending
Event
Event::addSignal
Event


Makes signal event pending

Event::add
Event::addTimer
Event
PHP Manual

Event::addSignal

(PECL event >= 1.2.6-beta)

Event::addSignal — Makes signal event pending

Açıklama

public bool Event::addSignal ([ double $timeout ] )

Event::addSignal() is an alias of Event::add()

Örnekler

Örnek 1 Event::addSignal() example

<?php
/*
Launch it in a terminal window:

$ php examples/signal.php

In another terminal window find out the pid and send SIGTERM, e.g.:

$ ps aux | grep examp
ruslan    3976  0.2  0.0 139896 11256 pts/1    S+   10:25   0:00 php examples/signal.php
ruslan    3978  0.0  0.0   9572   864 pts/2    S+   10:26   0:00 grep --color=auto examp
$ kill -TERM 3976

At the first terminal window you should catch the following:

Caught signal 15
*/
class MyEventSignal {
    private $base, $ev;

    public function __construct($base) {
        $this->base = $base;
        $this->ev = Event::signal($base, SIGTERM, array($this, 'eventSighandler'));
        $this->ev->addSignal();
    }

    public function eventSighandler($no, $c) {
        echo "Caught signal $no\n";
        $this->base->exit();
    }
}

$base = new EventBase();
$c    = new MyEventSignal($base);

$base->loop();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Caught signal 15

Ayrıca Bakınız

  • Event::add() - Makes event pending
  • Event::del() - Makes event non-pending
  • Event::delSignal() - Makes signal event non-pending
  • Event::signal() - Constructs signal event object
Event::add
Event::addTimer
Event


Makes timer event pending

Event::addSignal
Event::__construct
Event
PHP Manual

Event::addTimer

(PECL event >= 1.2.6-beta)

Event::addTimer — Makes timer event pending

Açıklama

public bool Event::addTimer ([ double $timeout ] )

Event::addTimer() is an alias of Event::add()

Dönen Değerler

Örnekler

Örnek 1 Event::addTimer() example

<?php
$base = new EventBase();
$n = 2;
$e = Event::timer($base, function($n) use (&$e) {
    echo "$n seconds elapsed\n";
    $e->delTimer();
}, $n);
$e->addTimer($n);
$base->loop();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

2 seconds elapsed

Ayrıca Bakınız

  • Event::add() - Makes event pending
  • Event::del() - Makes event non-pending
  • Event::delTimer() - Makes timer event non-pending
Event::addSignal
Event::__construct
Event


Constructs Event object

Event::addTimer
Event::del
Event
PHP Manual

Event::__construct

(PECL event >= 1.2.6-beta)

Event::__construct — Constructs Event object

Açıklama

public Event::__construct ( EventBase $base , mixed $fd , int $what , callable $cb [, mixed $arg = NULL ] )

Constructs Event object.

Değiştirgeler

base

The event base to associate with.

fd

stream resource, socket resource, or numeric file descriptor. For timer events pass -1 . For signal events pass the signal number, e.g. SIGHUP .

what

Event flags. See Event flags .

cb

The event callback. See Event callbacks .

arg

Custom data. If specified, it will be passed to the callback when event triggers.

Dönen Değerler

Returns Event object.

Ayrıca Bakınız

  • Event::signal() - Constructs signal event object
  • Event::timer() - Constructs timer event object
Event::addTimer
Event::del
Event


Makes event non-pending

Event::__construct
Event::delSignal
Event
PHP Manual

Event::del

(PECL libevent >= 0.0.1)

Event::del — Makes event non-pending

Açıklama

public bool Event::del ( void )

Removes an event from the set of monitored events, i.e. makes it non-pending.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE on success. Otherwise FALSE

Ayrıca Bakınız

  • Event::add() - Makes event pending
Event::__construct
Event::delSignal
Event


Makes signal event non-pending

Event::del
Event::delTimer
Event
PHP Manual

Event::delSignal

(PECL event >= 1.2.6-beta)

Event::delSignal — Makes signal event non-pending

Açıklama

public bool Event::delSignal ( void )

Event::delSignal() is an alias of Event::del()

Ayrıca Bakınız

  • Event::del() - Makes event non-pending
Event::del
Event::delTimer
Event


Makes timer event non-pending

Event::delSignal
Event::free
Event
PHP Manual

Event::delTimer

(PECL event >= 1.2.6-beta)

Event::delTimer — Makes timer event non-pending

Açıklama

public bool Event::delTimer ( void )

Event::delTimer() is an alias of Event::del() .

Ayrıca Bakınız

  • Event::del() - Makes event non-pending
Event::delSignal
Event::free
Event


Make event non-pending and free resources allocated for this event.

Event::delTimer
Event::getSupportedMethods
Event
PHP Manual

Event::free

(PECL libevent >= 0.0.1)

Event::free — Make event non-pending and free resources allocated for this event.

Açıklama

public void Event::free ( void )

Removes event from the list of events monitored by libevent, and free resources allocated for the event.

Uyarı

The Event::free() method currently doesn't destruct the object itself. To destruct the object completely call unset() , or assign NULL.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • Event::__construct() - Constructs Event object
Event::delTimer
Event::getSupportedMethods
Event


Returns array with of the names of the methods supported in this version of Libevent

Event::free
Event::pending
Event
PHP Manual

Event::getSupportedMethods

(PECL event >= 1.2.6-beta)

Event::getSupportedMethods — Returns array with of the names of the methods supported in this version of Libevent

Açıklama

public static array Event::getSupportedMethods ( void )

Returns array with of the names of the methods(backends) supported in this version of Libevent.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns array.

Ayrıca Bakınız

  • EventConfig
Event::free
Event::pending
Event


Detects whether event is pending or scheduled

Event::getSupportedMethods
Event::set
Event
PHP Manual

Event::pending

(PECL event >= 1.2.6-beta)

Event::pending — Detects whether event is pending or scheduled

Açıklama

public bool Event::pending ( int $flags )

Detects whether event is pending or scheduled

Değiştirgeler

flags

One of, or a composition of the following constants: Event::READ , Event::WRITE , Event::TIMEOUT , Event::SIGNAL .

Dönen Değerler

Returns TRUE if event is pending or scheduled. Otherwise FALSE.

Event::getSupportedMethods
Event::set
Event


Re-configures event

Event::pending
Event::setPriority
Event
PHP Manual

Event::set

(PECL libevent >= 0.0.1)

Event::set — Re-configures event

Açıklama

public bool Event::set ( EventBase $base , mixed $fd [, int $what [, callable $cb [, mixed $arg ]]] )

Re-configures event. Note, this function doesn't invoke obsolete libevent's event_set. It calls event_assign instead.

Değiştirgeler

base

The event base to associate the event with.

fd

A stream, socket resource, or numeric file descriptor; for signal events pass -1 .

what

See Event flags .

cb

The event callback. See Event callbacks .

arg

Custom data associated with the event. It will be passed to the callback when the event becomes active.

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

Event::pending
Event::setPriority
Event


Set event priority

Event::set
Event::setTimer
Event
PHP Manual

Event::setPriority

(PECL event >= 1.2.6-beta)

Event::setPriority — Set event priority

Açıklama

public bool Event::setPriority ( int $priority )

Set event priority.

Değiştirgeler

priority

The event priority.

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

Event::set
Event::setTimer
Event


Re-configures timer event

Event::setPriority
Event::signal
Event
PHP Manual

Event::setTimer

(PECL event >= 1.2.6-beta)

Event::setTimer — Re-configures timer event

Açıklama

public bool Event::setTimer ( EventBase $base , callable $cb [, mixed $arg ] )

Re-configures timer event. Note, this function doesn't invoke obsolete libevent's event_set . It calls event_assign instead.

Değiştirgeler

base

The event base to associate with.

cb

The timer event callback. See Event callbacks .

arg

Custom data. If specified, it will be passed to the callback when event triggers.

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

Ayrıca Bakınız

  • Event::__construct() - Constructs Event object
  • Event::timer() - Constructs timer event object
Event::setPriority
Event::signal
Event


Constructs signal event object

Event::setTimer
Event::timer
Event
PHP Manual

Event::signal

(PECL event >= 1.2.6-beta)

Event::signal — Constructs signal event object

Açıklama

public static Event Event::signal ( EventBase $base , int $signum , callable $cb [, mixed $arg ] )

Constructs signal event object. This is a straightforward method to create a signal event. Note, the generic Event::__construct() method can contruct signal event objects too.

Değiştirgeler

base

The associated event base object.

signum

The signal number.

cb

The signal event callback. See Event callbacks .

arg

Custom data. If specified, it will be passed to the callback when event triggers.

Dönen Değerler

Returns Event object on success. Otherwise FALSE.

Ayrıca Bakınız

  • Constructing signal events
Event::setTimer
Event::timer
Event


Constructs timer event object

Event::signal
EventBase
Event
PHP Manual

Event::timer

(PECL event >= 1.2.6-beta)

Event::timer — Constructs timer event object

Açıklama

public static Event Event::timer ( EventBase $base , callable $cb [, mixed $arg ] )

Constructs timer event object. This is a straightforward method to create a timer event. Note, the generic Event::__construct() method can contruct signal event objects too.

Değiştirgeler

base

The associated event base object.

cb

The signal event callback. See Event callbacks .

arg

Custom data. If specified, it will be passed to the callback when event triggers.

Dönen Değerler

Returns Event object on success. Otherwise FALSE.

Event::signal
EventBase
Event


The EventBase class

(PECL event >= 1.2.6-beta)

Giriş

EventBase class represents libevent's event base structure. It holds a set of events and can poll to determine which events are active.

Each event base has a method , or a backend that it uses to determine which events are ready. The recognized methods are: select , poll , epoll , kqueue , devpoll , evport and win32 .

To configure event base to use, or avoid specific backend EventConfig class can be used.

Uyarı

Do NOT destroy the EventBase object as long as resources of the associated Event objects are not released. Otherwise, it will lead to unpredictable results!

Sınıf Sözdizimi

final EventBase {
/* Constants */
const integer LOOP_ONCE = 1 ;
const integer LOOP_NONBLOCK = 2 ;
const integer NOLOCK = 1 ;
const integer STARTUP_IOCP = 4 ;
const integer NO_CACHE_TIME = 8 ;
const integer EPOLL_USE_CHANGELIST = 16 ;
/* Yöntemler */
public __construct ([ EventConfig $cfg ] )
public void dispatch ( void )
public bool exit ([ double $timeout ] )
public void free ( void )
public int getFeatures ( void )
public string getMethod ( void )
public double getTimeOfDayCached ( void )
public bool gotExit ( void )
public bool gotStop ( void )
public bool loop ([ int $flags ] )
public bool priorityInit ( int $n_priorities )
public bool reInit ( void )
public bool stop ( void )
}

Öntanımlı Sabitler

EventBase::LOOP_ONCE

Flag used with EventBase::loop() method which means: "block until libevent has an active event, then exit once all active events have had their callbacks run".

EventBase::LOOP_NONBLOCK

Flag used with EventBase::loop() method which means: "do not block: see which events are ready now, run the callbacks of the highest-priority ones, then exit".

EventBase::NOLOCK

Configuration flag. Do not allocate a lock for the event base, even if we have locking set up".

EventBase::STARTUP_IOCP

Windows-only configuration flag. Enables the IOCP dispatcher at startup.

EventBase::NO_CACHE_TIME

Configuration flag. Instead of checking the current time every time the event loop is ready to run timeout callbacks, check after each timeout callback.

EventBase::EPOLL_USE_CHANGELIST

If we are using the epoll backend, this flag says that it is safe to use Libevent's internal change-list code to batch up adds and deletes in order to try to do as few syscalls as possible.

Setting this flag can make code run faster, but it may trigger a Linux bug: it is not safe to use this flag if one has any fds cloned by dup(), or its variants. Doing so will produce strange and hard-to-diagnose bugs.

This flag can also be activated by settnig the EVENT_EPOLL_USE_CHANGELIST environment variable.

This flag has no effect if one winds up using a backend other than epoll .

İçindekiler

  • EventBase::__construct — Constructs EventBase object
  • EventBase::dispatch — Dispatch pending events
  • EventBase::exit — Stop dispatching events
  • EventBase::free — Free resources allocated for this event base
  • EventBase::getFeatures — Returns bitmask of features supported
  • EventBase::getMethod — Returns event method in use
  • EventBase::getTimeOfDayCached — Returns the current event base time
  • EventBase::gotExit — Checks if the event loop was told to exit
  • EventBase::gotStop — Checks if the event loop was told to exit
  • EventBase::loop — Dispatch pending events
  • EventBase::priorityInit — Sets number of priorities per event base
  • EventBase::reInit — Re-initialize event base(after a fork).
  • EventBase::stop — Tells event_base to stop dispatching events
Event::timer
EventBase::__construct
Event


Constructs EventBase object

EventBase
EventBase::dispatch
EventBase
PHP Manual

EventBase::__construct

(PECL event >= 1.2.6-beta)

EventBase::__construct — Constructs EventBase object

Açıklama

public EventBase::__construct ([ EventConfig $cfg ] )

Constructs EventBase object

Değiştirgeler

cfg

Optional EventConfig object.

Dönen Değerler

Returns EventBase object.

Ayrıca Bakınız

  • EventConfig
EventBase
EventBase::dispatch
EventBase


Dispatch pending events

EventBase::__construct
EventBase::exit
EventBase
PHP Manual

EventBase::dispatch

(PECL event >= 1.2.6-beta)

EventBase::dispatch — Dispatch pending events

Açıklama

public void EventBase::dispatch ( void )

Wait for events to become active, and run their callbacks. The same as EventBase::loop() with no flags set.

Uyarı

Do NOT destroy the EventBase object as long as resources of the associated Event objects are not released. Otherwise, it will lead to unpredictable results!

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

Ayrıca Bakınız

  • EventBase::loop() - Dispatch pending events
EventBase::__construct
EventBase::exit
EventBase


Stop dispatching events

EventBase::dispatch
EventBase::free
EventBase
PHP Manual

EventBase::exit

(PECL event >= 1.2.6-beta)

EventBase::exit — Stop dispatching events

Açıklama

public bool EventBase::exit ([ double $timeout ] )

Tells event base to stop optionally after given number of seconds.

Değiştirgeler

timeout

Optional number of seconds after which the event base should stop dispatching events.

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

Ayrıca Bakınız

  • EventBase::stop() - Tells event_base to stop dispatching events
EventBase::dispatch
EventBase::free
EventBase


Free resources allocated for this event base

EventBase::exit
EventBase::getFeatures
EventBase
PHP Manual

EventBase::free

(PECL event >= 1.10.0)

EventBase::free — Free resources allocated for this event base

Açıklama

public void EventBase::free ( void )

Deallocates resources allocated by libevent for the EventBase object.

Uyarı

The EventBase::free() method doesn't destruct the object itself. To destruct the object completely call unset() , or assign NULL.

This method does not deallocate or detach any of the events that are currently associated with the EventBase object, or close any of their sockets - beware.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • EventBase::__construct() - Constructs EventBase object
EventBase::exit
EventBase::getFeatures
EventBase


Returns bitmask of features supported

EventBase::free
EventBase::getMethod
EventBase
PHP Manual

EventBase::getFeatures

(PECL event >= 1.2.6-beta)

EventBase::getFeatures — Returns bitmask of features supported

Açıklama

public int EventBase::getFeatures ( void )

Returns bitmask of features supported.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns integer representing a bitmask of supported features. See EventConfig::FEATURE_* constants .

Örnekler

Örnek 1 EventBase::getFeatures() example

<?php
// Avoiding "select" method
$cfg = new EventConfig();
if ($cfg->avoidMethod("select")) {
    echo "`select' method avoided\n";
}

$base = new EventBase($cfg);

echo "Features:\n";
$features = $base->getFeatures();
($features & EventConfig::FEATURE_ET) and print("ET - edge-triggered IO\n");
($features & EventConfig::FEATURE_O1) and print("O1 - O(1) operation for adding/deletting events\n");
($features & EventConfig::FEATURE_FDS) and print("FDS - arbitrary file descriptor types, and not just sockets\n");
?>

Ayrıca Bakınız

  • EventBase::getMethod() - Returns event method in use
  • EventConfig
EventBase::free
EventBase::getMethod
EventBase


Returns event method in use

EventBase::getFeatures
EventBase::getTimeOfDayCached
EventBase
PHP Manual

EventBase::getMethod

(PECL event >= 1.2.6-beta)

EventBase::getMethod — Returns event method in use

Açıklama

public string EventBase::getMethod ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

String representing used event method(backend).

Örnekler

Örnek 1 EventBase::getMethod() example

<?php
$cfg = new EventConfig();
if ($cfg->avoidMethod("select")) {
    echo "`select' method avoided\n";
}

// Create event_base associated with the config
$base = new EventBase($cfg);
echo "Event method used: ", $base->getMethod(), PHP_EOL;

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

`select' method avoided
Event method used: epoll

Ayrıca Bakınız

  • EventBase::getFeatures() - Returns bitmask of features supported
EventBase::getFeatures
EventBase::getTimeOfDayCached
EventBase


Returns the current event base time

EventBase::getMethod
EventBase::gotExit
EventBase
PHP Manual

EventBase::getTimeOfDayCached

(PECL event >= 1.2.6-beta)

EventBase::getTimeOfDayCached — Returns the current event base time

Açıklama

public double EventBase::getTimeOfDayCached ( void )

On success returns the current time(as returned by gettimeofday() ), looking at the cached value in base if possible, and calling gettimeofday() or clock_gettime() as appropriate if there is no cached time.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the current event base time. On failure returns NULL.

EventBase::getMethod
EventBase::gotExit
EventBase


Checks if the event loop was told to exit

EventBase::getTimeOfDayCached
EventBase::gotStop
EventBase
PHP Manual

EventBase::gotExit

(PECL event >= 1.2.6-beta)

EventBase::gotExit — Checks if the event loop was told to exit

Açıklama

public bool EventBase::gotExit ( void )

Checks if the event loop was told to exit by EventBase::exit() .

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE, event loop was told to exit by EventBase::exit() . Otherwise FALSE.

Ayrıca Bakınız

  • EventBase::exit() - Stop dispatching events
  • EventBase::stop() - Tells event_base to stop dispatching events
  • EventBase::gotStop() - Checks if the event loop was told to exit
EventBase::getTimeOfDayCached
EventBase::gotStop
EventBase


Checks if the event loop was told to exit

EventBase::gotExit
EventBase::loop
EventBase
PHP Manual

EventBase::gotStop

(PECL event >= 1.2.6-beta)

EventBase::gotStop — Checks if the event loop was told to exit

Açıklama

public bool EventBase::gotStop ( void )

Checks if the event loop was told to exit by EventBase::stop() .

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE, event loop was told to stop by EventBase::stop() . Otherwise FALSE.

Ayrıca Bakınız

  • EventBase::exit() - Stop dispatching events
  • EventBase::stop() - Tells event_base to stop dispatching events
  • EventBase::gotExit() - Checks if the event loop was told to exit
EventBase::gotExit
EventBase::loop
EventBase


Dispatch pending events

EventBase::gotStop
EventBase::priorityInit
EventBase
PHP Manual

EventBase::loop

(PECL event >= 1.2.6-beta)

EventBase::loop — Dispatch pending events

Açıklama

public bool EventBase::loop ([ int $flags ] )

Wait for events to become active, and run their callbacks.

Uyarı

Do NOT destroy the EventBase object as long as resources of the associated Event objects are not released. Otherwise, it will lead to unpredictable results!

Değiştirgeler

flags

Optional flags. One of EventBase::LOOP_* constants. See EventBase constants .

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

Ayrıca Bakınız

  • EventBase::dispatch() - Dispatch pending events
EventBase::gotStop
EventBase::priorityInit
EventBase


Sets number of priorities per event base

EventBase::loop
EventBase::reInit
EventBase
PHP Manual

EventBase::priorityInit

(PECL event >= 1.2.6-beta)

EventBase::priorityInit — Sets number of priorities per event base

Açıklama

public bool EventBase::priorityInit ( int $n_priorities )

Sets number of priorities per event base.

Değiştirgeler

n_priorities

The number of priorities per event base.

Dönen Değerler

Returns TRUE on success, otherwise FALSE.

Ayrıca Bakınız

  • Event::setPriority() - Set event priority
EventBase::loop
EventBase::reInit
EventBase


Re-initialize event base(after a fork).

EventBase::priorityInit
EventBase::stop
EventBase
PHP Manual

EventBase::reInit

(PECL event >= 1.2.6-beta)

EventBase::reInit — Re-initialize event base(after a fork).

Açıklama

public bool EventBase::reInit ( void )

Re-initialize event base. Should be called after a fork.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

EventBase::priorityInit
EventBase::stop
EventBase


Tells event_base to stop dispatching events

EventBase::reInit
EventBuffer
EventBase
PHP Manual

EventBase::stop

(PECL event >= 1.2.6-beta)

EventBase::stop — Tells event_base to stop dispatching events

Açıklama

public bool EventBase::stop ( void )

Tells event_base to stop dispatching events

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

Ayrıca Bakınız

  • EventBase::exit() - Stop dispatching events
  • EventBase::gotStop() - Checks if the event loop was told to exit
EventBase::reInit
EventBuffer
EventBase


The EventBuffer class

(PECL event >= 1.5.0)

Giriş

EventBuffer represents Libevent's "evbuffer", an utility functionality for buffered I/O.

Event buffers are meant to be generally useful for doing the "buffer" part of buffered network I/O.

Sınıf Sözdizimi

EventBuffer {
/* Constants */
const integer EOL_ANY = 0 ;
const integer EOL_CRLF = 1 ;
const integer EOL_CRLF_STRICT = 2 ;
const integer EOL_LF = 3 ;
const integer PTR_SET = 0 ;
const integer PTR_ADD = 1 ;
/* Özellikler */
public readonly int $length ;
public readonly int $contiguous_space ;
/* Yöntemler */
public bool add ( string $data )
public bool addBuffer ( EventBuffer $buf )
public int appendFrom ( EventBuffer $buf , int $len )
public __construct ( void )
public int copyout ( string &$data , int $max_bytes )
public bool drain ( int $len )
public void enableLocking ( void )
public bool expand ( int $len )
public bool freeze ( bool $at_front )
public void lock ( void )
public bool prepend ( string $data )
public bool prependBuffer ( EventBuffer $buf )
public string pullup ( int $size )
public string read ( int $max_bytes )
public int read ( mixed $fd , int $howmuch )
public string readLine ( int $eol_style )
public mixed search ( string $what [, int $start = -1 [, int $end = -1 ]] )
public mixed searchEol ([ int $start = -1 [, int $eol_style = EventBuffer::EOL_ANY ]] )
public string substr ( int $start [, int $length ] )
public bool unfreeze ( bool $at_front )
public bool unlock ( void )
public int write ( mixed $fd [, int $howmuch ] )
}

Özellikler

length

The number of bytes stored in an event buffer.

contiguous_space

The number of bytes stored contiguously at the front of the buffer. The bytes in a buffer may be stored in multiple separate chunks of memory; the property returns the number of bytes currently stored in the first chunk.

Öntanımlı Sabitler

EventBuffer::EOL_ANY

The end of line is any sequence of any number of carriage return and linefeed characters. This format is not very useful; it exists mainly for backward compatibility.

EventBuffer::EOL_CRLF

The end of the line is an optional carriage return, followed by a linefeed. (In other words, it is either a "\r\n" or a "\n" .) This format is useful in parsing text-based Internet protocols, since the standards generally prescribe a "\r\n" line-terminator, but nonconformant clients sometimes say just "\n" .

EventBuffer::EOL_CRLF_STRICT

The end of a line is a single carriage return, followed by a single linefeed. (This is also known as "\r\n" . The ASCII values are 0x0D 0x0A ).

EventBuffer::EOL_LF

The end of a line is a single linefeed character. (This is also known as "\n" . It is ASCII value is 0x0A .)

EventBuffer::PTR_SET

Flag used as argument of EventBuffer::setPosition() method. If this flag specified, the position pointer is moved to an absolute position within the buffer.

EventBuffer::PTR_ADD

The same as EventBuffer::PTR_SET , except this flag causes EventBuffer::setPosition() method to move position forward up to the specified number of bytes(instead of setting absolute position).

İçindekiler

  • EventBuffer::add — Append data to the end of an event buffer
  • EventBuffer::addBuffer — Move all data from a buffer provided to the current instance of EventBuffer
  • EventBuffer::appendFrom — Moves the specified number of bytes from a source buffer to the end of the current buffer
  • EventBuffer::__construct — Constructs EventBuffer object
  • EventBuffer::copyout — Copies out specified number of bytes from the front of the buffer
  • EventBuffer::drain — Removes specified number of bytes from the front of the buffer without copying it anywhere
  • EventBuffer::enableLocking — Açıklama
  • EventBuffer::expand — Reserves space in buffer
  • EventBuffer::freeze — Prevent calls that modify an event buffer from succeeding
  • EventBuffer::lock — Acquires a lock on buffer
  • EventBuffer::prepend — Prepend data to the front of the buffer
  • EventBuffer::prependBuffer — Moves all data from source buffer to the front of current buffer
  • EventBuffer::pullup — Linearizes data within buffer and returns it's contents as a string
  • EventBuffer::read — Read data from an evbuffer and drain the bytes read
  • EventBuffer::readFrom — Read data from a file onto the end of the buffer
  • EventBuffer::readLine — Extracts a line from the front of the buffer
  • EventBuffer::search — Scans the buffer for an occurrence of a string
  • EventBuffer::searchEol — Scans the buffer for an occurrence of an end of line
  • EventBuffer::substr — Substracts a portion of the buffer data
  • EventBuffer::unfreeze — Re-enable calls that modify an event buffer
  • EventBuffer::unlock — Releases lock acquired by EventBuffer::lock
  • EventBuffer::write — Write contents of the buffer to a file or socket
EventBase::stop
EventBuffer::add
Event


Append data to the end of an event buffer

EventBuffer
EventBuffer::addBuffer
EventBuffer
PHP Manual

EventBuffer::add

(PECL event >= 1.2.6-beta)

EventBuffer::add — Append data to the end of an event buffer

Açıklama

public bool EventBuffer::add ( string $data )

Append data to the end of an event buffer.

Değiştirgeler

data

String to be appended to the end of the buffer.

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

Ayrıca Bakınız

  • EventBuffer::addBuffer() - Move all data from a buffer provided to the current instance of EventBuffer
EventBuffer
EventBuffer::addBuffer
EventBuffer


Move all data from a buffer provided to the current instance of EventBuffer

EventBuffer::add
EventBuffer::appendFrom
EventBuffer
PHP Manual

EventBuffer::addBuffer

(PECL event >= 1.2.6-beta)

EventBuffer::addBuffer — Move all data from a buffer provided to the current instance of EventBuffer

Açıklama

public bool EventBuffer::addBuffer ( EventBuffer $buf )

Move all data from the buffer provided in buf parameter to the end of current EventBuffer . This is a destructive add. The data from one buffer moves into the other buffer. However, no unnecessary memory copies occur.

Değiştirgeler

buf

The source EventBuffer object.

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

Ayrıca Bakınız

  • EventBuffer::add() - Append data to the end of an event buffer
EventBuffer::add
EventBuffer::appendFrom
EventBuffer


Moves the specified number of bytes from a source buffer to the end of the current buffer

EventBuffer::addBuffer
EventBuffer::__construct
EventBuffer
PHP Manual

EventBuffer::appendFrom

(PECL event >= 1.6.0)

EventBuffer::appendFrom — Moves the specified number of bytes from a source buffer to the end of the current buffer

Açıklama

public int EventBuffer::appendFrom ( EventBuffer $buf , int $len )

Moves the specified number of bytes from a source buffer to the end of the current buffer. If there are fewer number of bytes, it moves all the bytes available from the source buffer.

Değiştirgeler

buf

Source buffer.

len

Dönen Değerler

Returns the number of bytes read.

Sürüm Bilgisi

Sürüm: | Açıklama
1.6.0 | Renamed EventBuffer::appendFrom()(the old method name) to EventBuffer::appendFrom().

Ayrıca Bakınız

  • EventBuffer::copyout() - Copies out specified number of bytes from the front of the buffer
  • EventBuffer::drain() - Removes specified number of bytes from the front of the buffer without copying it anywhere
  • EventBuffer::pullup() - Linearizes data within buffer and returns it's contents as a string
  • EventBuffer::readLine() - Extracts a line from the front of the buffer
  • EventBuffer::read() - Read data from an evbuffer and drain the bytes read
EventBuffer::addBuffer
EventBuffer::__construct
EventBuffer


Constructs EventBuffer object

EventBuffer::appendFrom
EventBuffer::copyout
EventBuffer
PHP Manual

EventBuffer::__construct

(PECL event >= 1.2.6-beta)

EventBuffer::__construct — Constructs EventBuffer object

Açıklama

public EventBuffer::__construct ( void )

Constructs EventBuffer object

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns EventBuffer object.

EventBuffer::appendFrom
EventBuffer::copyout
EventBuffer


Copies out specified number of bytes from the front of the buffer

EventBuffer::__construct
EventBuffer::drain
EventBuffer
PHP Manual

EventBuffer::copyout

(PECL event >= 1.2.6-beta)

EventBuffer::copyout — Copies out specified number of bytes from the front of the buffer

Açıklama

public int EventBuffer::copyout ( string &$data , int $max_bytes )

Behaves just like EventBuffer::read() , but does not drain any data from the buffer. I.e. it copies the first max_bytes bytes from the front of the buffer into data . If there are fewer than max_bytes bytes available, the function copies all the bytes there are.

Değiştirgeler

data

Output string.

max_bytes

The number of bytes to copy.

Dönen Değerler

Returns the number of bytes copied, or -1 on failure.

Ayrıca Bakınız

  • EventBuffer::read() - Read data from an evbuffer and drain the bytes read
  • EventBuffer::appendFrom() - Moves the specified number of bytes from a source buffer to the end of the current buffer
EventBuffer::__construct
EventBuffer::drain
EventBuffer


Removes specified number of bytes from the front of the buffer without copying it anywhere

EventBuffer::copyout
EventBuffer::enableLocking
EventBuffer
PHP Manual

EventBuffer::drain

(PECL event >= 1.2.6-beta)

EventBuffer::drain — Removes specified number of bytes from the front of the buffer without copying it anywhere

Açıklama

public bool EventBuffer::drain ( int $len )

Behaves as EventBuffer::read() , except that it does not copy the data: it just removes it from the front of the buffer.

Değiştirgeler

len

The number of bytes to remove from the buffer.

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

Ayrıca Bakınız

  • EventBuffer::read() - Read data from an evbuffer and drain the bytes read
  • EventBuffer::appendFrom() - Moves the specified number of bytes from a source buffer to the end of the current buffer
EventBuffer::copyout
EventBuffer::enableLocking
EventBuffer


EventBuffer::drain
EventBuffer::expand
EventBuffer
PHP Manual

EventBuffer::enableLocking

(PECL event >= 1.2.6-beta)

EventBuffer::enableLocking —

Açıklama

public void EventBuffer::enableLocking ( void )

Enable locking on an EventBuffer so that it can safely be used by multiple threads at the same time. When locking is enabled, the lock will be held when callbacks are invoked. This could result in deadlock if you aren't careful. Plan accordingly!

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • » Evbuffers and Thread-safety
EventBuffer::drain
EventBuffer::expand
EventBuffer


Reserves space in buffer

EventBuffer::enableLocking
EventBuffer::freeze
EventBuffer
PHP Manual

EventBuffer::expand

(PECL event >= 1.2.6-beta)

EventBuffer::expand — Reserves space in buffer

Açıklama

public bool EventBuffer::expand ( int $len )

Alters the last chunk of memory in the buffer, or adds a new chunk, such that the buffer is now large enough to contain len bytes without any further allocations.

Değiştirgeler

len

The number of bytes to reserve for the buffer

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

EventBuffer::enableLocking
EventBuffer::freeze
EventBuffer


Prevent calls that modify an event buffer from succeeding

EventBuffer::expand
EventBuffer::lock
EventBuffer
PHP Manual

EventBuffer::freeze

(PECL event >= 1.2.6-beta)

EventBuffer::freeze — Prevent calls that modify an event buffer from succeeding

Açıklama

public bool EventBuffer::freeze ( bool $at_front )

Prevent calls that modify an event buffer from succeeding

Değiştirgeler

at_front

Whether to disable changes to the front or end of the buffer.

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

Ayrıca Bakınız

  • EventBuffer::unfreeze() - Re-enable calls that modify an event buffer
EventBuffer::expand
EventBuffer::lock
EventBuffer


Acquires a lock on buffer

EventBuffer::freeze
EventBuffer::prepend
EventBuffer
PHP Manual

EventBuffer::lock

(PECL event >= 1.2.6-beta)

EventBuffer::lock — Acquires a lock on buffer

Açıklama

public void EventBuffer::lock ( void )

Acquires a lock on buffer. Can be used in pair with EventBuffer::unlock() to make a set of operations atomic, i.e. thread-safe. Note, it is not needed to lock buffers for individual operations. When locking is enabled(see EventBuffer::enableLocking() ), individual operations on event buffers are already atomic.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • EventBuffer::unlock() - Releases lock acquired by EventBuffer::lock
EventBuffer::freeze
EventBuffer::prepend
EventBuffer


Prepend data to the front of the buffer

EventBuffer::lock
EventBuffer::prependBuffer
EventBuffer
PHP Manual

EventBuffer::prepend

(PECL event >= 1.2.6-beta)

EventBuffer::prepend — Prepend data to the front of the buffer

Açıklama

public bool EventBuffer::prepend ( string $data )

Prepend data to the front of the buffer.

Değiştirgeler

data

String to be prepended to the front of the buffer.

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

Ayrıca Bakınız

  • EventBuffer::prependBuffer() - Moves all data from source buffer to the front of current buffer
  • EventBuffer::add() - Append data to the end of an event buffer
  • EventBuffer::addBuffer() - Move all data from a buffer provided to the current instance of EventBuffer
EventBuffer::lock
EventBuffer::prependBuffer
EventBuffer


Moves all data from source buffer to the front of current buffer

EventBuffer::prepend
EventBuffer::pullup
EventBuffer
PHP Manual

EventBuffer::prependBuffer

(PECL event >= 1.2.6-beta)

EventBuffer::prependBuffer — Moves all data from source buffer to the front of current buffer

Açıklama

public bool EventBuffer::prependBuffer ( EventBuffer $buf )

Behaves as EventBuffer::addBuffer() , except that it moves data to the front of the buffer.

Değiştirgeler

buf

Source buffer.

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

Ayrıca Bakınız

  • EventBuffer::add() - Append data to the end of an event buffer
  • EventBuffer::addBuffer() - Move all data from a buffer provided to the current instance of EventBuffer
  • EventBuffer::prepend() - Prepend data to the front of the buffer
EventBuffer::prepend
EventBuffer::pullup
EventBuffer


Linearizes data within buffer and returns it's contents as a string

EventBuffer::prependBuffer
EventBuffer::read
EventBuffer
PHP Manual

EventBuffer::pullup

(PECL event >= 1.2.6-beta)

EventBuffer::pullup — Linearizes data within buffer and returns it's contents as a string

Açıklama

public string EventBuffer::pullup ( int $size )

"Linearizes" the first size bytes of the buffer, copying or moving them as needed to ensure that they are all contiguous and occupying the same chunk of memory. If size is negative, the function linearizes the entire buffer.

Uyarı

Calling EventBuffer::pullup() with a large size can be quite slow, since it potentially needs to copy the entire buffer's contents.

Değiştirgeler

size

The number of bytes required to be contiguous within the buffer.

Dönen Değerler

If size is greater than the number of bytes in the buffer, the function returns NULL. Otherwise, EventBuffer::pullup() returns string.

Ayrıca Bakınız

  • EventBuffer::copyout() - Copies out specified number of bytes from the front of the buffer
  • EventBuffer::drain() - Removes specified number of bytes from the front of the buffer without copying it anywhere
  • EventBuffer::read() - Read data from an evbuffer and drain the bytes read
  • EventBuffer::readLine() - Extracts a line from the front of the buffer
  • EventBuffer::appendFrom() - Moves the specified number of bytes from a source buffer to the end of the current buffer
EventBuffer::prependBuffer
EventBuffer::read
EventBuffer


Read data from an evbuffer and drain the bytes read

EventBuffer::pullup
EventBuffer::readFrom
EventBuffer
PHP Manual

EventBuffer::read

(PECL event >= 1.6.0)

EventBuffer::read — Read data from an evbuffer and drain the bytes read

Açıklama

public string EventBuffer::read ( int $max_bytes )

Read the first max_bytes from the buffer and drain the bytes read. If more max_bytes are requested than are available in the buffer, it only extracts as many bytes as available.

Değiştirgeler

max_bytes

Maxmimum number of bytes to read from the buffer.

Dönen Değerler

Returns string read, or FALSE on failure.

Sürüm Bilgisi

Sürüm: | Açıklama
1.6.0 | Renamed EventBuffer::read()(the old method name) to EventBuffer::read(). EventBuffer::read() now takes only max_bytes argument; returns string instead of integer.

Ayrıca Bakınız

  • EventBuffer::copyout() - Copies out specified number of bytes from the front of the buffer
  • EventBuffer::drain() - Removes specified number of bytes from the front of the buffer without copying it anywhere
  • EventBuffer::pullup() - Linearizes data within buffer and returns it's contents as a string
  • EventBuffer::readLine() - Extracts a line from the front of the buffer
  • EventBuffer::appendFrom() - Moves the specified number of bytes from a source buffer to the end of the current buffer
EventBuffer::pullup
EventBuffer::readFrom
EventBuffer


Read data from a file onto the end of the buffer

EventBuffer::read
EventBuffer::readLine
EventBuffer
PHP Manual

EventBuffer::readFrom

(PECL event >= 1.7.0)

EventBuffer::readFrom — Read data from a file onto the end of the buffer

Açıklama

public int EventBuffer::read ( mixed $fd , int $howmuch )

Read data from the file specified by fd onto the end of the buffer.

Değiştirgeler

fd

Socket resource, stream, or numeric file descriptor.

howmuch

Maxmimum number of bytes to read.

Dönen Değerler

Returns the number of bytes read, or FALSE on failure.

Ayrıca Bakınız

  • EventBuffer::copyout() - Copies out specified number of bytes from the front of the buffer
  • EventBuffer::drain() - Removes specified number of bytes from the front of the buffer without copying it anywhere
  • EventBuffer::pullup() - Linearizes data within buffer and returns it's contents as a string
  • EventBuffer::readLine() - Extracts a line from the front of the buffer
  • EventBuffer::appendFrom() - Moves the specified number of bytes from a source buffer to the end of the current buffer
EventBuffer::read
EventBuffer::readLine
EventBuffer


Extracts a line from the front of the buffer

EventBuffer::readFrom
EventBuffer::search
EventBuffer
PHP Manual

EventBuffer::readLine

(PECL event >= 1.2.6-beta)

EventBuffer::readLine — Extracts a line from the front of the buffer

Açıklama

public string EventBuffer::readLine ( int $eol_style )

Extracts a line from the front of the buffer and returns it in a newly allocated string. If there is not a whole line to read, the function returns NULL. The line terminator is not included in the copied string.

Değiştirgeler

eol_style

One of EventBuffer:EOL_* constants .

Dönen Değerler

On success returns the line read from the buffer, otherwise NULL.

Ayrıca Bakınız

  • EventBuffer::copyout() - Copies out specified number of bytes from the front of the buffer
  • EventBuffer::drain() - Removes specified number of bytes from the front of the buffer without copying it anywhere
  • EventBuffer::pullup() - Linearizes data within buffer and returns it's contents as a string
  • EventBuffer::read() - Read data from an evbuffer and drain the bytes read
  • EventBuffer::appendFrom() - Moves the specified number of bytes from a source buffer to the end of the current buffer
EventBuffer::readFrom
EventBuffer::search
EventBuffer


Scans the buffer for an occurrence of a string

EventBuffer::readLine
EventBuffer::searchEol
EventBuffer
PHP Manual

EventBuffer::search

(PECL event >= 1.2.6-beta)

EventBuffer::search — Scans the buffer for an occurrence of a string

Açıklama

public mixed EventBuffer::search ( string $what [, int $start = -1 [, int $end = -1 ]] )

Scans the buffer for an occurrence of the string what . It returns numeric position of the string, or FALSE if the string was not found.

If the start argument is provided, it points to the position at which the search should begin; otherwise, the search is performed from the start of the string. If end argument provided, the search is performed between start and end buffer positions.

Değiştirgeler

what

String to search.

start

Start search position.

end

End search position.

Dönen Değerler

Returns numeric position of the first occurance of the string in the buffer, or FALSE if string is not found.

Uyarı

Bu işlev mantıksal FALSE değeriyle dönebileceği gibi FALSE olarak değerlendirilebilecek mantıksal olmayan bir değerle de dönebilir. Bu konuda daha fazla bilgi edinmek için Mantıksal Değerler bölümüne bakabilirsiniz. Bu işlevden dönen değeri sınamak için === işlecini kullanınız.

Örnekler

Örnek 1 EventBuffer::search() example

<?php
// Count total occurances of 'str' in 'buf'
function count_instances($buf, $str) {
    $total = 0;
    $p     = 0;
    $i     = 0;

    while (1) {
        $p = $buf->search($str, $p);
        if ($p === FALSE) {
            break;
        }
        ++$total;
        ++$p;
    }

    return $total;
}

$buf = new EventBuffer();
$buf->add("Some string within a string inside another string");
var_dump(count_instances($buf, "str"));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(3)

Ayrıca Bakınız

  • EventBuffer::searchEol() - Scans the buffer for an occurrence of an end of line
EventBuffer::readLine
EventBuffer::searchEol
EventBuffer


Scans the buffer for an occurrence of an end of line

EventBuffer::search
EventBuffer::substr
EventBuffer
PHP Manual

EventBuffer::searchEol

(PECL event >= 1.5.0)

EventBuffer::searchEol — Scans the buffer for an occurrence of an end of line

Açıklama

public mixed EventBuffer::searchEol ([ int $start = -1 [, int $eol_style = EventBuffer::EOL_ANY ]] )

Scans the buffer for an occurrence of an end of line specified by eol_style parameter . It returns numeric position of the string, or FALSE if the string was not found.

If the start argument is provided, it represents the position at which the search should begin; otherwise, the search is performed from the start of the string. If end argument provided, the search is performed between start and end buffer positions.

Değiştirgeler

start

Start search position.

eol_style

One of EventBuffer:EOL_* constants .

Dönen Değerler

Returns numeric position of the first occurance of end-of-line symbol in the buffer, or FALSE if not found.

Uyarı

Bu işlev mantıksal FALSE değeriyle dönebileceği gibi FALSE olarak değerlendirilebilecek mantıksal olmayan bir değerle de dönebilir. Bu konuda daha fazla bilgi edinmek için Mantıksal Değerler bölümüne bakabilirsiniz. Bu işlevden dönen değeri sınamak için === işlecini kullanınız.

Ayrıca Bakınız

  • EventBuffer::search() - Scans the buffer for an occurrence of a string
EventBuffer::search
EventBuffer::substr
EventBuffer


Substracts a portion of the buffer data

EventBuffer::searchEol
EventBuffer::unfreeze
EventBuffer
PHP Manual

EventBuffer::substr

(PECL event >= 1.6.0)

EventBuffer::substr — Substracts a portion of the buffer data

Açıklama

public string EventBuffer::substr ( int $start [, int $length ] )

Substracts up to length bytes of the buffer data beginning at start position.

Değiştirgeler

start

The start position of data to be substracted.

length

Maximum number of bytes to substract.

Dönen Değerler

Returns the data substracted as a string on success, or FALSE on failure.

Ayrıca Bakınız

  • EventBuffer::read() - Read data from an evbuffer and drain the bytes read
EventBuffer::searchEol
EventBuffer::unfreeze
EventBuffer


Re-enable calls that modify an event buffer

EventBuffer::substr
EventBuffer::unlock
EventBuffer
PHP Manual

EventBuffer::unfreeze

(PECL event >= 1.2.6-beta)

EventBuffer::unfreeze — Re-enable calls that modify an event buffer

Açıklama

public bool EventBuffer::unfreeze ( bool $at_front )

Re-enable calls that modify an event buffer.

Değiştirgeler

at_front

Whether to enable events at the front or at the end of the buffer.

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

Ayrıca Bakınız

  • EventBuffer::freeze() - Prevent calls that modify an event buffer from succeeding
EventBuffer::substr
EventBuffer::unlock
EventBuffer


Releases lock acquired by EventBuffer::lock

EventBuffer::unfreeze
EventBuffer::write
EventBuffer
PHP Manual

EventBuffer::unlock

(PECL event >= 1.2.6-beta)

EventBuffer::unlock — Releases lock acquired by EventBuffer::lock

Açıklama

public bool EventBuffer::unlock ( void )

Releases lock acquired by EventBuffer::lock() .

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

Ayrıca Bakınız

  • EventBuffer::lock() - Acquires a lock on buffer
EventBuffer::unfreeze
EventBuffer::write
EventBuffer


Write contents of the buffer to a file or socket

EventBuffer::unlock
EventBufferEvent
EventBuffer
PHP Manual

EventBuffer::write

(PECL event >= 1.6.0)

EventBuffer::write — Write contents of the buffer to a file or socket

Açıklama

public int EventBuffer::write ( mixed $fd [, int $howmuch ] )

Write contents of the buffer to a file descriptor. The buffer will be drained after the bytes have been successfully written.

Değiştirgeler

fd

Socket resource, stream or numeric file descriptor associated normally associated with a socket.

howmuch

The maximum number of bytes to write.

Dönen Değerler

Returns the number of bytes written, or FALSE on error.

Ayrıca Bakınız

  • EventBuffer::read() - Read data from an evbuffer and drain the bytes read
EventBuffer::unlock
EventBufferEvent
EventBuffer


The EventBufferEvent class

(PECL event >= 1.2.6-beta)

Giriş

Represents Libevent's buffer event.

Usually an application wants to perform some amount of data buffering in addition to just responding to events. When we want to write data, for example, the usual pattern looks like:

  1. Decide that we want to write some data to a connection; put that data in a buffer.

  2. Wait for the connection to become writable

  3. Write as much of the data as we can

  4. Remember how much we wrote, and if we still have more data to write, wait for the connection to become writable again.

This buffered I/O pattern is common enough that Libevent provides a generic mechanism for it. A "buffer event" consists of an underlying transport (like a socket), a read buffer, and a write buffer. Instead of regular events, which give callbacks when the underlying transport is ready to be read or written, a buffer event invokes its user-supplied callbacks when it has read or written enough data.

Sınıf Sözdizimi

final EventBufferEvent {
/* Constants */
const integer READING = 1 ;
const integer WRITING = 2 ;
const integer EOF = 16 ;
const integer ERROR = 32 ;
const integer TIMEOUT = 64 ;
const integer CONNECTED = 128 ;
const integer OPT_CLOSE_ON_FREE = 1 ;
const integer OPT_THREADSAFE = 2 ;
const integer OPT_DEFER_CALLBACKS = 4 ;
const integer OPT_UNLOCK_CALLBACKS = 8 ;
const integer SSL_OPEN = 0 ;
const integer SSL_CONNECTING = 1 ;
const integer SSL_ACCEPTING = 2 ;
/* Özellikler */
public integer $fd ;
public integer $priority ;
public readonly EventBuffer $input ;
public readonly EventBuffer $output ;
/* Yöntemler */
public void close ( void )
public bool connect ( string $addr )
public bool connectHost ( EventDnsBase $dns_base , string $hostname , int $port [, int $family = EventUtil::AF_UNSPEC ] )
public __construct ( EventBase $base [, mixed $socket = NULL [, int $options = 0 [, callable $readcb = NULL [, callable $writecb = NULL [, callable $eventcb = NULL ]]]]] )
public static array createPair ( EventBase $base [, int $options = 0 ] )
public bool disable ( int $events )
public bool enable ( int $events )
public void free ( void )
public string getDnsErrorString ( void )
public int getEnabled ( void )
public EventBuffer getInput ( void )
public EventBuffer getOutput ( void )
public string read ( int $size )
public bool readBuffer ( EventBuffer $buf )
public void setCallbacks ( callable $readcb , callable $writecb , callable $eventcb [, string $arg ] )
public bool setPriority ( int $priority )
public bool setTimeouts ( float $timeout_read , float $timeout_write )
public void setWatermark ( int $events , int $lowmark , int $highmark )
public string sslError ( void )
public static EventBufferEvent sslFilter ( EventBase $base , EventBufferEvent $underlying , EventSslContext $ctx , int $state [, int $options = 0 ] )
public string sslGetCipherInfo ( void )
public string sslGetCipherName ( void )
public string sslGetCipherVersion ( void )
public string sslGetProtocol ( void )
public void sslRenegotiate ( void )
public static EventBufferEvent sslSocket ( EventBase $base , mixed $socket , EventSslContext $ctx , int $state [, int $options ] )
public bool write ( string $data )
public bool writeBuffer ( EventBuffer $buf )
}

Özellikler

fd

Numeric file descriptor associated with the buffer event. Normally represents a bound socket. Equals to NULL, if there is no file descriptor(socket) associated with the buffer event.

priority

The priority of the events used to implement the buffer event.

input

Underlying input buffer object( EventBuffer )

output

Underlying output buffer object( EventBuffer )

Öntanımlı Sabitler

EventBufferEvent::READING

An event occured during a read operation on the bufferevent. See the other flags for which event it was.

EventBufferEvent::WRITING

An event occured during a write operation on the bufferevent. See the other flags for which event it was.

EventBufferEvent::EOF

Got an end-of-file indication on the buffer event.

EventBufferEvent::ERROR

An error occurred during a bufferevent operation. For more information on what the error was, call EventUtil::getLastSocketErrno() and/or EventUtil::getLastSocketError() .

EventBufferEvent::TIMEOUT

EventBufferEvent::CONNECTED

Finished a requested connection on the bufferevent.

EventBufferEvent::OPT_CLOSE_ON_FREE

When the buffer event is freed, close the underlying transport. This will close an underlying socket, free an underlying buffer event, etc.

EventBufferEvent::OPT_THREADSAFE

Automatically allocate locks for the bufferevent, so that it's safe to use from multiple threads.

EventBufferEvent::OPT_DEFER_CALLBACKS

When this flag is set, the bufferevent defers all of its callbacks. See » Fast portable non-blocking network programming with Libevent, Deferred callbacks .

EventBufferEvent::OPT_UNLOCK_CALLBACKS

By default, when the bufferevent is set up to be threadsafe, the buffer event's locks are held whenever the any user-provided callback is invoked. Setting this option makes Libevent release the buffer event's lock when it's invoking the callbacks.

EventBufferEvent::SSL_OPEN

The SSL handshake is done

EventBufferEvent::SSL_CONNECTING

SSL is currently performing negotiation as a client

EventBufferEvent::SSL_ACCEPTING

SSL is currently performing negotiation as a server

İçindekiler

  • EventBufferEvent::close — Closes file descriptor associated with the current buffer event
  • EventBufferEvent::connect — Connect buffer event's file descriptor to given address or UNIX socket
  • EventBufferEvent::connectHost — Connects to a hostname with optionally asyncronous DNS resolving
  • EventBufferEvent::__construct — Constructs EventBufferEvent object
  • EventBufferEvent::createPair — Creates two buffer events connected to each other
  • EventBufferEvent::disable — Disable events read, write, or both on a buffer event.
  • EventBufferEvent::enable — Enable events read, write, or both on a buffer event.
  • EventBufferEvent::free — Free a buffer event
  • EventBufferEvent::getDnsErrorString — Returns string describing the last failed DNS lookup attempt
  • EventBufferEvent::getEnabled — Returns bitmask of events currently enabled on the buffer event
  • EventBufferEvent::getInput — Returns underlying input buffer associated with current buffer event
  • EventBufferEvent::getOutput — Returns underlying output buffer associated with current buffer event
  • EventBufferEvent::read — Read buffer's data
  • EventBufferEvent::readBuffer — Drains the entire contents of the input buffer and places them into buf
  • EventBufferEvent::setCallbacks — Assigns read, write and event(status) callbacks
  • EventBufferEvent::setPriority — Assign a priority to a bufferevent
  • EventBufferEvent::setTimeouts — Set the read and write timeout for a buffer event
  • EventBufferEvent::setWatermark — Adjusts read and/or write watermarks
  • EventBufferEvent::sslError — Returns most recent OpenSSL error reported on the buffer event
  • EventBufferEvent::sslFilter — Create a new SSL buffer event to send its data over another buffer event
  • EventBufferEvent::sslGetCipherInfo — Returns a textual description of the cipher.
  • EventBufferEvent::sslGetCipherName — Returns the current cipher name of the SSL connection.
  • EventBufferEvent::sslGetCipherVersion — Returns version of cipher used by current SSL connection.
  • EventBufferEvent::sslGetProtocol — Returns the name of the protocol used for current SSL connection.
  • EventBufferEvent::sslRenegotiate — Tells a bufferevent to begin SSL renegotiation.
  • EventBufferEvent::sslSocket — Creates a new SSL buffer event to send its data over an SSL on a socket
  • EventBufferEvent::write — Adds data to a buffer event's output buffer
  • EventBufferEvent::writeBuffer — Adds contents of the entire buffer to a buffer event's output buffer
EventBuffer::write
EventBufferEvent::close
Event


Closes file descriptor associated with the current buffer event

EventBufferEvent
EventBufferEvent::connect
EventBufferEvent
PHP Manual

EventBufferEvent::close

(PECL event >= 1.10.0)

EventBufferEvent::close — Closes file descriptor associated with the current buffer event

Açıklama

public void EventBufferEvent::close ( void )

Closes file descriptor associated with the current buffer event.

This method may be used in cases when the EventBufferEvent::OPT_CLOSE_ON_FREE option is not appropriate.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

EventBufferEvent
EventBufferEvent::connect
EventBufferEvent


Connect buffer event's file descriptor to given address or UNIX socket

EventBufferEvent::close
EventBufferEvent::connectHost
EventBufferEvent
PHP Manual

EventBufferEvent::connect

(PECL event >= 1.2.6-beta)

EventBufferEvent::connect — Connect buffer event's file descriptor to given address or UNIX socket

Açıklama

public bool EventBufferEvent::connect ( string $addr )

Connect buffer event's file descriptor to given address(optionally with port), or a UNIX domain socket.

If socket is not assigned to the buffer event, this function allocates a new socket and makes it non-blocking internally.

To resolve DNS names(asyncronously), use EventBufferEvent::connectHost() method.

Değiştirgeler

addr

Should contain an IP address with optional port number, or a path to UNIX domain socket. Recognized formats are:

[IPv6Address]:port
[IPv6Address]
IPv6Address
IPv4Address:port
IPv4Address
unix:path
Note, 'unix:' prefix is currently not case sensitive.

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

Örnekler

Örnek 1 EventBufferEvent::connect() example

<?php
/*
 * 1. Connect to 127.0.0.1 at port 80
 * by means of EventBufferEvent::connect().
 *
 * 2. Request /index.cphp via HTTP/1.0
 * using the output buffer.
 *
 * 3. Asyncronously read the response and print it to stdout.
 */

/* Read callback */
function readcb($bev, $base) {
    $input = $bev->getInput();

    while (($n = $input->remove($buf, 1024)) > 0) {
        echo $buf;
    }
}

/* Event callback */
function eventcb($bev, $events, $base) {
    if ($events & EventBufferEvent::CONNECTED) {
        echo "Connected.\n";
    } elseif ($events & (EventBufferEvent::ERROR | EventBufferEvent::EOF)) {
        if ($events & EventBufferEvent::ERROR) {
            echo "DNS error: ", $bev->getDnsErrorString(), PHP_EOL;
        }

        echo "Closing\n";
        $base->exit();
        exit("Done\n");
    }
}

$base = new EventBase();

echo "step 1\n";
$bev = new EventBufferEvent($base, /* use internal socket */ NULL,
    EventBufferEvent::OPT_CLOSE_ON_FREE | EventBufferEvent::OPT_DEFER_CALLBACKS);
if (!$bev) {
    exit("Failed creating bufferevent socket\n");
}

echo "step 2\n";
$bev->setCallbacks("readcb", /* writecb */ NULL, "eventcb", $base);
$bev->enable(Event::READ | Event::WRITE);

echo "step 3\n";
/* Send request */
$output = $bev->getOutput();
if (!$output->add(
    "GET /index.cphp HTTP/1.0\r\n".
    "Connection: Close\r\n\r\n"
)) {
    exit("Failed adding request to output buffer\n");
}

/* Connect to the host syncronously.
 * We know the IP, and don't need to resolve DNS. */
if (!$bev->connect("127.0.0.1:80")) {
    exit("Can't connect to host\n");
}

/* Dispatch pending events */
$base->dispatch();

Yukarıdaki örnek şuna benzer bir çıktı üretir:

step 1
step 2
step 3
Connected.
HTTP/1.1 200 OK
Server: nginx/1.2.6
Date: Sat, 09 Mar 2013 10:06:58 GMT
Content-Type: text/html; CHARSET=Windows-1254
Connection: close
X-Powered-By: PHP/5.4.11--pl2-gentoo

sdfsdfsf
Closing
Done

Örnek 2 Connect to UNIX domain socket which presumably is served by a server, read response from the server and output it to the console

<?php
class MyUnixSocketClient {
    private $base, $bev;

    function __construct($base, $sock_path) {
        $this->base = $base;
        $this->bev = new EventBufferEvent($base, NULL, EventBufferEvent::OPT_CLOSE_ON_FREE,
            array ($this, "read_cb"), NULL, array ($this, "event_cb"));

        if (!$this->bev->connect("unix:$sock_path")) {
            trigger_error("Failed to connect to socket `$sock_path'", E_USER_ERROR);
        }

        $this->bev->enable(Event::READ);
    }

    function __destruct() {
        if ($this->bev) {
            $this->bev->free();
            $this->bev = NULL;
        }
    }

    function dispatch() {
        $this->base->dispatch();
    }

    function read_cb($bev, $unused) {
        $in = $bev->input;

        printf("Received %ld bytes\n", $in->length);
        printf("----- data ----\n");
        printf("%ld:\t%s\n", (int) $in->length, $in->pullup(-1));

        $this->bev->free();
        $this->bev = NULL;
        $this->base->exit(NULL);
    }

    function event_cb($bev, $events, $unused) {
        if ($events & EventBufferEvent::ERROR) {
            echo "Error from bufferevent\n";
        }

        if ($events & (EventBufferEvent::EOF | EventBufferEvent::ERROR)) {
            $bev->free();
            $bev = NULL;
        } elseif ($events & EventBufferEvent::CONNECTED) {
            $bev->output->add("test\n");
        }
    }
}

if ($argc <= 1) {
    exit("Socket path is not provided\n");
}
$sock_path = $argv[1];

$base = new EventBase();
$cl = new MyUnixSocketClient($base, $sock_path);
$cl->dispatch();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Received 5 bytes
----- data ----
5:  test

Ayrıca Bakınız

  • EventBufferEvent::connectHost() - Connects to a hostname with optionally asyncronous DNS resolving
EventBufferEvent::close
EventBufferEvent::connectHost
EventBufferEvent


Connects to a hostname with optionally asyncronous DNS resolving

EventBufferEvent::connect
EventBufferEvent::__construct
EventBufferEvent
PHP Manual

EventBufferEvent::connectHost

(PECL event >= 1.2.6-beta)

EventBufferEvent::connectHost — Connects to a hostname with optionally asyncronous DNS resolving

Açıklama

public bool EventBufferEvent::connectHost ( EventDnsBase $dns_base , string $hostname , int $port [, int $family = EventUtil::AF_UNSPEC ] )

Resolves the DNS name hostname, looking for addresses of type family ( EventUtil::AF_* constants). If the name resolution fails, it invokes the event callback with an error event. If it succeeds, it launches a connection attempt just as EventBufferEvent::connect() would.

dns_base is optional. May be NULL, or an object created with EventDnsBase::__construct() . For asyncronous hostname resolving pass a valid event dns base resource. Otherwise the hostname resolving will block.

Bilginize:

EventDnsBase is available only if Event configured --with-event-extra ( event_extra library, libevent protocol-specific functionality support including HTTP, DNS, and RPC ).

Bilginize:

EventBufferEvent::connectHost() requires libevent-2.0.3-alpha or greater.

Değiştirgeler

dns_base

Object of EventDnsBase in case if DNS is to be resolved asyncronously. Otherwise NULL.

hostname

Hostname to connect to. Recognized formats are:

www.example.com (hostname)
 1.2.3.4 (ipv4address)
 ::1 (ipv6address)
[::1] ([ipv6address])

port

Port number

family

Address family. EventUtil::AF_UNSPEC , EventUtil::AF_INET , or EventUtil::AF_INET6 . See EventUtil constants .

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

Örnekler

Örnek 1 EventBufferEvent::connectHost() example

<?php
/* Read callback */
function readcb($bev, $base) {
    //$input = $bev->input; //$bev->getInput();

    //$pos = $input->search("TTP");
    $pos = $bev->input->search("TTP");

    while (($n = $bev->input->remove($buf, 1024)) > 0) {
        echo $buf;
    }
}

/* Event callback */
function eventcb($bev, $events, $base) {
    if ($events & EventBufferEvent::CONNECTED) {
        echo "Connected.\n";
    } elseif ($events & (EventBufferEvent::ERROR | EventBufferEvent::EOF)) {
        if ($events & EventBufferEvent::ERROR) {
            echo "DNS error: ", $bev->getDnsErrorString(), PHP_EOL;
        }

        echo "Closing\n";
        $base->exit();
        exit("Done\n");
    }
}

$base = new EventBase();

$dns_base = new EventDnsBase($base, TRUE); // We'll use async DNS resolving
if (!$dns_base) {
    exit("Failed to init DNS Base\n");
}

$bev = new EventBufferEvent($base, /* use internal socket */ NULL,
    EventBufferEvent::OPT_CLOSE_ON_FREE | EventBufferEvent::OPT_DEFER_CALLBACKS,
    "readcb", /* writecb */ NULL, "eventcb", $base
);
if (!$bev) {
    exit("Failed creating bufferevent socket\n");
}

//$bev->setCallbacks("readcb", /* writecb */ NULL, "eventcb", $base);
$bev->enable(Event::READ | Event::WRITE);

$output = $bev->output; //$bev->getOutput();
if (!$output->add(
    "GET {$argv[2]} HTTP/1.0\r\n".
    "Host: {$argv[1]}\r\n".
    "Connection: Close\r\n\r\n"
)) {
    exit("Failed adding request to output buffer\n");
}

if (!$bev->connectHost($dns_base, $argv[1], 80, EventUtil::AF_UNSPEC)) {
    exit("Can't connect to host {$argv[1]}\n");
}

$base->dispatch();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Connected.
HTTP/1.0 301 Moved Permanently
Location: http://www.google.co.uk/
Content-Type: text/html; CHARSET=Windows-1254
Date: Sat, 09 Mar 2013 12:21:19 GMT
Expires: Mon, 08 Apr 2013 12:21:19 GMT
Cache-Control: public, max-age=2592000
Server: gws
Content-Length: 221
X-XSS-Protection: 1; mode=block
X-Frame-Options: SAMEORIGIN

<HTML><HEAD><meta http-equiv="content-type" content="text/html;CHARSET=Windows-1254">
<TITLE>301 Moved</TITLE></HEAD><BODY>
<H1>301 Moved</H1>
The document has moved
<A HREF="http://www.google.co.uk/">here</A>.
</BODY></HTML>
Closing
Done

Ayrıca Bakınız

  • EventBufferEvent::connect() - Connect buffer event's file descriptor to given address or UNIX socket
EventBufferEvent::connect
EventBufferEvent::__construct
EventBufferEvent


Constructs EventBufferEvent object

EventBufferEvent::connectHost
EventBufferEvent::createPair
EventBufferEvent
PHP Manual

EventBufferEvent::__construct

(PECL event >= 1.2.6-beta)

EventBufferEvent::__construct — Constructs EventBufferEvent object

Açıklama

public EventBufferEvent::__construct ( EventBase $base [, mixed $socket = NULL [, int $options = 0 [, callable $readcb = NULL [, callable $writecb = NULL [, callable $eventcb = NULL ]]]]] )

Create a buffer event on a socket, stream or a file descriptor. Passing NULL to socket means that the socket should be created later, e.g. by means of EventBufferEvent::connect() .

Değiştirgeler

base

Event base that should be associated with the new buffer event.

socket

May be created as a stream(not necessarily by means of sockets extension)

options

One of EventBufferEvent::OPT_* constants , or 0 .

readcb

Read event callback. See About buffer event callbacks .

writecb

Write event callback. See About buffer event callbacks .

eventcb

Status-change event callback. See About buffer event callbacks .

arg

A variable that will be passed to all the callbacks.

Dönen Değerler

Returns buffer event resource optionally associated with socket resource. */

Ayrıca Bakınız

  • EventBufferEvent::sslFilter() - Create a new SSL buffer event to send its data over another buffer event
  • EventBufferEvent::sslSocket() - Creates a new SSL buffer event to send its data over an SSL on a socket
EventBufferEvent::connectHost
EventBufferEvent::createPair
EventBufferEvent


Creates two buffer events connected to each other

EventBufferEvent::__construct
EventBufferEvent::disable
EventBufferEvent
PHP Manual

EventBufferEvent::createPair

(PECL event >= 1.2.6-beta)

EventBufferEvent::createPair — Creates two buffer events connected to each other

Açıklama

public static array EventBufferEvent::createPair ( EventBase $base [, int $options = 0 ] )

Returns array of two EventBufferEvent objects connected to each other. All the usual options are supported, except for EventBufferEvent::OPT_CLOSE_ON_FREE , which has no effect, and EventBufferEvent::OPT_DEFER_CALLBACKS , which is always on.

Değiştirgeler

base

Associated event base

options

EventBufferEvent::OPT_* constants combined with bitwise OR operator.

Dönen Değerler

Returns array of two EventBufferEvent objects connected to each other.

Sürüm Bilgisi

Sürüm: | Açıklama
1.9.0 | Method made static.

EventBufferEvent::__construct
EventBufferEvent::disable
EventBufferEvent


Disable events read, write, or both on a buffer event.

EventBufferEvent::createPair
EventBufferEvent::enable
EventBufferEvent
PHP Manual

EventBufferEvent::disable

(PECL event >= 1.2.6-beta)

EventBufferEvent::disable — Disable events read, write, or both on a buffer event.

Açıklama

public bool EventBufferEvent::disable ( int $events )

Disable events Event::READ , Event::WRITE , or Event::READ | Event::WRITE on a buffer event.

Değiştirgeler

events

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

Ayrıca Bakınız

  • EventBufferEvent::enable() - Enable events read, write, or both on a buffer event.
EventBufferEvent::createPair
EventBufferEvent::enable
EventBufferEvent


Enable events read, write, or both on a buffer event.

EventBufferEvent::disable
EventBufferEvent::free
EventBufferEvent
PHP Manual

EventBufferEvent::enable

(PECL event >= 1.2.6-beta)

EventBufferEvent::enable — Enable events read, write, or both on a buffer event.

Açıklama

public bool EventBufferEvent::enable ( int $events )

Enable events Event::READ , Event::WRITE , or Event::READ | Event::WRITE on a buffer event.

Değiştirgeler

events

Event::READ , Event::WRITE , or Event::READ | Event::WRITE on a buffer event.

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

Ayrıca Bakınız

  • EventBufferEvent::disable() - Disable events read, write, or both on a buffer event.
EventBufferEvent::disable
EventBufferEvent::free
EventBufferEvent


Free a buffer event

EventBufferEvent::enable
EventBufferEvent::getDnsErrorString
EventBufferEvent
PHP Manual

EventBufferEvent::free

(PECL event >= 1.2.6-beta)

EventBufferEvent::free — Free a buffer event

Açıklama

public void EventBufferEvent::free ( void )

Free resources allocated by buffer event.

Usually there is no need to call this method, since normally it is done within internal object destructors. However, sometimes we have a long-time script allocating lots of instances, or a script with a heavy memory usage, where we need to free resources as soon as possible. In such cases EventBufferEvent::free() may be used to protect the script against running up to the memory_limit .

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

EventBufferEvent::enable
EventBufferEvent::getDnsErrorString
EventBufferEvent


Returns string describing the last failed DNS lookup attempt

EventBufferEvent::free
EventBufferEvent::getEnabled
EventBufferEvent
PHP Manual

EventBufferEvent::getDnsErrorString

(PECL event >= 1.2.6-beta)

EventBufferEvent::getDnsErrorString — Returns string describing the last failed DNS lookup attempt

Açıklama

public string EventBufferEvent::getDnsErrorString ( void )

Returns string describing the last failed DNS lookup attempt made by EventBufferEvent::connectHost() , or an empty string, if there is no DNS error detected.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a string describing DNS lookup error, or an empty string for no error.

Ayrıca Bakınız

  • EventBufferEvent::connectHost() - Connects to a hostname with optionally asyncronous DNS resolving
EventBufferEvent::free
EventBufferEvent::getEnabled
EventBufferEvent


Returns bitmask of events currently enabled on the buffer event

EventBufferEvent::getDnsErrorString
EventBufferEvent::getInput
EventBufferEvent
PHP Manual

EventBufferEvent::getEnabled

(PECL event >= 1.2.6-beta)

EventBufferEvent::getEnabled — Returns bitmask of events currently enabled on the buffer event

Açıklama

public int EventBufferEvent::getEnabled ( void )

Returns bitmask of events currently enabled on the buffer event

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns integer representing a bitmask of events currently enabled on the buffer event

Ayrıca Bakınız

  • EventBufferEvent::enable() - Enable events read, write, or both on a buffer event.
  • EventBufferEvent::disable() - Disable events read, write, or both on a buffer event.
EventBufferEvent::getDnsErrorString
EventBufferEvent::getInput
EventBufferEvent


Returns underlying input buffer associated with current buffer event

EventBufferEvent::getEnabled
EventBufferEvent::getOutput
EventBufferEvent
PHP Manual

EventBufferEvent::getInput

(PECL event >= 1.2.6-beta)

EventBufferEvent::getInput — Returns underlying input buffer associated with current buffer event

Açıklama

public EventBuffer EventBufferEvent::getInput ( void )

Returns underlying input buffer associated with current buffer event. An input buffer is a storage for data to read.

Note, there is also input property of EventBufferEvent class.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns instance of EventBuffer input buffer associated with current buffer event.

Örnekler

Örnek 1 Buffer event's read callback

<?php
function readcb($bev, $base) {
    $input = $bev->input; //$bev->getInput();

    while (($n = $input->remove($buf, 1024)) > 0) {
        echo $buf;
    }
}
?>

Ayrıca Bakınız

  • EventBufferEvent::getOutput() - Returns underlying output buffer associated with current buffer event
EventBufferEvent::getEnabled
EventBufferEvent::getOutput
EventBufferEvent


Returns underlying output buffer associated with current buffer event

EventBufferEvent::getInput
EventBufferEvent::read
EventBufferEvent
PHP Manual

EventBufferEvent::getOutput

(PECL event >= 1.2.6-beta)

EventBufferEvent::getOutput — Returns underlying output buffer associated with current buffer event

Açıklama

public EventBuffer EventBufferEvent::getOutput ( void )

Returns underlying output buffer associated with current buffer event. An output buffer is a storage for data to be written.

Note, there is also output property of EventBufferEvent class.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns instance of EventBuffer output buffer associated with current buffer event.

Örnekler

Örnek 1 EventBufferEvent::getOutput() example

<?php
$base = new EventBase();

$dns_base = new EventDnsBase($base, TRUE); // Use async DNS resolving
if (!$dns_base) {
    exit("Failed to init DNS Base\n");
}

$bev = new EventBufferEvent($base, /* use internal socket */ NULL,
    EventBufferEvent::OPT_CLOSE_ON_FREE | EventBufferEvent::OPT_DEFER_CALLBACKS,
    "readcb", /* writecb */ NULL, "eventcb", $base
);
if (!$bev) {
    exit("Failed creating bufferevent socket\n");
}

$bev->enable(Event::READ | Event::WRITE);

$output = $bev->getOutput();
if (!$output->add(
    "GET {$argv[2]} HTTP/1.0\r\n".
    "Host: {$argv[1]}\r\n".
    "Connection: Close\r\n\r\n"
)) {
    exit("Failed adding request to output buffer\n");
}

/* ... */
?>

Ayrıca Bakınız

  • EventBufferEvent::getInput() - Returns underlying input buffer associated with current buffer event
EventBufferEvent::getInput
EventBufferEvent::read
EventBufferEvent


Read buffer's data

EventBufferEvent::getOutput
EventBufferEvent::readBuffer
EventBufferEvent
PHP Manual

EventBufferEvent::read

(PECL event >= 1.2.6-beta)

EventBufferEvent::read — Read buffer's data

Açıklama

public string EventBufferEvent::read ( int $size )

Removes up to size bytes from the input buffer. Returns a string of data read from the input buffer.

Değiştirgeler

size

Maximum number of bytes to read

Dönen Değerler

Returns string of data read from the input buffer.

Ayrıca Bakınız

  • EventBufferEvent::readBuffer() - Drains the entire contents of the input buffer and places them into buf
EventBufferEvent::getOutput
EventBufferEvent::readBuffer
EventBufferEvent


Drains the entire contents of the input buffer and places them into buf

EventBufferEvent::read
EventBufferEvent::setCallbacks
EventBufferEvent
PHP Manual

EventBufferEvent::readBuffer

(PECL event >= 1.2.6-beta)

EventBufferEvent::readBuffer — Drains the entire contents of the input buffer and places them into buf

Açıklama

public bool EventBufferEvent::readBuffer ( EventBuffer $buf )

Drains the entire contents of the input buffer and places them into buf .

Değiştirgeler

buf

Target buffer

Dönen Değerler

Returns TRUE on success; Otherwise FALSE.

Ayrıca Bakınız

  • EventBufferEvent::read() - Read buffer's data
EventBufferEvent::read
EventBufferEvent::setCallbacks
EventBufferEvent


Assigns read, write and event(status) callbacks

EventBufferEvent::readBuffer
EventBufferEvent::setPriority
EventBufferEvent
PHP Manual

EventBufferEvent::setCallbacks

(PECL event >= 1.2.6-beta)

EventBufferEvent::setCallbacks — Assigns read, write and event(status) callbacks

Açıklama

public void EventBufferEvent::setCallbacks ( callable $readcb , callable $writecb , callable $eventcb [, string $arg ] )

Assigns read, write and event(status) callbacks.

Değiştirgeler

readcb

Read event callback. See About buffer event callbacks .

writecb

Write event callback. See About buffer event callbacks .

eventcb

Status-change event callback. See About buffer event callbacks .

arg

A variable that will be passed to all the callbacks.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • EventBufferEvent::__construct() - Constructs EventBufferEvent object
EventBufferEvent::readBuffer
EventBufferEvent::setPriority
EventBufferEvent


Assign a priority to a bufferevent

EventBufferEvent::setCallbacks
EventBufferEvent::setTimeouts
EventBufferEvent
PHP Manual

EventBufferEvent::setPriority

(PECL event >= 1.2.6-beta)

EventBufferEvent::setPriority — Assign a priority to a bufferevent

Açıklama

public bool EventBufferEvent::setPriority ( int $priority )

Assign a priority to a bufferevent

Uyarı

Only supported for socket buffer events

Değiştirgeler

priority

Priority value.

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

EventBufferEvent::setCallbacks
EventBufferEvent::setTimeouts
EventBufferEvent


Set the read and write timeout for a buffer event

EventBufferEvent::setPriority
EventBufferEvent::setWatermark
EventBufferEvent
PHP Manual

EventBufferEvent::setTimeouts

(PECL event >= 1.2.6-beta)

EventBufferEvent::setTimeouts — Set the read and write timeout for a buffer event

Açıklama

public bool EventBufferEvent::setTimeouts ( float $timeout_read , float $timeout_write )

Set the read and write timeout for a buffer event

Değiştirgeler

timeout_read

Read timeout

timeout_write

Write timeout

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

EventBufferEvent::setPriority
EventBufferEvent::setWatermark
EventBufferEvent


Adjusts read and/or write watermarks

EventBufferEvent::setTimeouts
EventBufferEvent::sslError
EventBufferEvent
PHP Manual

EventBufferEvent::setWatermark

(PECL event >= 1.2.6-beta)

EventBufferEvent::setWatermark — Adjusts read and/or write watermarks

Açıklama

public void EventBufferEvent::setWatermark ( int $events , int $lowmark , int $highmark )

Adjusts the read watermarks, the write watermarks , or both, of a single buffer event.

A buffer event watermark is an edge, a value specifying number of bytes to be read or written before callback is invoked. By default every read/write event triggers a callback invokation. See » Fast portable non-blocking network programming with Libevent: Callbacks and watermarks

Değiştirgeler

events

Bitmask of Event::READ , Event::WRITE , or both.

lowmark

Minimum watermark value.

highmark

Maximum watermark value. 0 means "unlimited".

Dönen Değerler

Hiçbir değer dönmez.

EventBufferEvent::setTimeouts
EventBufferEvent::sslError
EventBufferEvent


Returns most recent OpenSSL error reported on the buffer event

EventBufferEvent::setWatermark
EventBufferEvent::sslFilter
EventBufferEvent
PHP Manual

EventBufferEvent::sslError

(PECL event >= 1.2.6-beta)

EventBufferEvent::sslError — Returns most recent OpenSSL error reported on the buffer event

Açıklama

public string EventBufferEvent::sslError ( void )

Returns most recent OpenSSL error reported on the buffer event.

Bilginize:

This function is available only if Event is compiled with OpenSSL support.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns OpenSSL error string reported on the buffer event, or FALSE, if there is no more error to return.

Örnekler

Örnek 1 EventBufferEvent::sslError() example

<?php
// This callback is invoked when some even occurs on the event listener,
// e.g. connection closed, or an error occured
function ssl_event_cb($bev, $events, $ctx) {
    if ($events & EventBufferEvent::ERROR) {
        // Fetch errors from the SSL error stack
        while ($err = $bev->sslError()) {
            fprintf(STDERR, "Bufferevent error %s.\n", $err);
        }
    }

    if ($events & (EventBufferEvent::EOF | EventBufferEvent::ERROR)) {
        $bev->free();
    }
}
?>

Ayrıca Bakınız

  • EventBufferEvent::sslRenegotiate() - Tells a bufferevent to begin SSL renegotiation.
EventBufferEvent::setWatermark
EventBufferEvent::sslFilter
EventBufferEvent


Create a new SSL buffer event to send its data over another buffer event

EventBufferEvent::sslError
EventBufferEvent::sslGetCipherInfo
EventBufferEvent
PHP Manual

EventBufferEvent::sslFilter

(PECL event >= 1.2.6-beta)

EventBufferEvent::sslFilter — Create a new SSL buffer event to send its data over another buffer event

Açıklama

public static EventBufferEvent EventBufferEvent::sslFilter ( EventBase $base , EventBufferEvent $underlying , EventSslContext $ctx , int $state [, int $options = 0 ] )

Create a new SSL buffer event to send its data over another buffer event

Bilginize:

This function is available only if Event is compiled with OpenSSL support.

Değiştirgeler

base

Associated event base.

underlying

A socket buffer event to use for this SSL.

ctx

Object of EventSslContext class.

state

The current state of SSL connection: EventBufferEvent::SSL_OPEN , EventBufferEvent::SSL_ACCEPTING or EventBufferEvent::SSL_CONNECTING .

options

One or more buffer event options.

Dönen Değerler

Returns a new SSL EventBufferEvent object.

Örnekler

Örnek 1 Simple SMTP server

<?php
 /*
 * Author: Andrew Rose <hello at andrewrose dot co dot uk>
 *
 * Usage:
 * 1) Prepare cert.pem certificate and privkey.pem private key files.
 * 2) Launch the server script
 * 3) Open TLS connection, e.g.:
 *      $ openssl s_client -connect localhost:25 -starttls smtp -crlf
 * 4) Start testing the commands listed in `cmd` method below.
 */

class Handler {
    public $domainName = FALSE;
    public $connections = [];
    public $buffers = [];
    public $maxRead = 256000;

    public function __construct() {
        $this->ctx = new EventSslContext(EventSslContext::SSLv3_SERVER_METHOD, [
            EventSslContext::OPT_LOCAL_CERT  => 'cert.pem',
            EventSslContext::OPT_LOCAL_PK    => 'privkey.pem',
            //EventSslContext::OPT_PASSPHRASE  => '',
            EventSslContext::OPT_VERIFY_PEER => false, // change to true with authentic cert
            EventSslContext::OPT_ALLOW_SELF_SIGNED => true // change to false with authentic cert
        ]);

        $this->base = new EventBase();
        if (!$this->base) {
            exit("Couldn't open event base\n");
        }

        if (!$this->listener = new EventListener($this->base,
            [$this, 'ev_accept'],
            $this->ctx,
            EventListener::OPT_CLOSE_ON_FREE | EventListener::OPT_REUSEABLE,
            -1,
            '0.0.0.0:25'))
        {
            exit("Couldn't create listener\n");
        }

        $this->listener->setErrorCallback([$this, 'ev_error']);
        $this->base->dispatch();
    }

    public function ev_accept($listener, $fd, $address, $ctx) {
        static $id = 0;
        $id += 1;

        $this->connections[$id]['clientData'] = '';
        $this->connections[$id]['cnx'] = new EventBufferEvent($this->base, $fd,
            EventBufferEvent::OPT_CLOSE_ON_FREE);

        if (!$this->connections[$id]['cnx']) {
            echo "Failed creating buffer\n";
            $this->base->exit(NULL);
            exit(1);
        }

        $this->connections[$id]['cnx']->setCallbacks([$this, "ev_read"], NULL,
            [$this, 'ev_error'], $id);
        $this->connections[$id]['cnx']->enable(Event::READ | Event::WRITE);

        $this->ev_write($id, '220 '.$this->domainName." wazzzap?\r\n");
    }

    function ev_error($listener, $ctx) {
        $errno = EventUtil::getLastSocketErrno();

        fprintf(STDERR, "Got an error %d (%s) on the listener. Shutting down.\n",
            $errno, EventUtil::getLastSocketError());

        if ($errno != 0) {
            $this->base->exit(NULL);
            exit();
        }
    }

    public function ev_close($id) {
        $this->connections[$id]['cnx']->disable(Event::READ | Event::WRITE);
        unset($this->connections[$id]);
    }

    protected function ev_write($id, $string) {
        echo 'S('.$id.'): '.$string;
        $this->connections[$id]['cnx']->write($string);
    }

    public function ev_read($buffer, $id) {
        while($buffer->input->length > 0) {
            $this->connections[$id]['clientData'] .= $buffer->input->read($this->maxRead);
            $clientDataLen = strlen($this->connections[$id]['clientData']);

            if($this->connections[$id]['clientData'][$clientDataLen-1] == "\n"
                && $this->connections[$id]['clientData'][$clientDataLen-2] == "\r")
            {
                // remove the trailing \r\n
                $line = substr($this->connections[$id]['clientData'], 0,
                    strlen($this->connections[$id]['clientData']) - 2);

                $this->connections[$id]['clientData'] = '';
                $this->cmd($buffer, $id, $line);
            }
        }
    }

    protected function cmd($buffer, $id, $line) {
        switch ($line) {
            case strncmp('EHLO ', $line, 4):
                $this->ev_write($id, "250-STARTTLS\r\n");
                $this->ev_write($id, "250 OK ehlo\r\n");
                break;

            case strncmp('HELO ', $line, 4):
                $this->ev_write($id, "250-STARTTLS\r\n");
                $this->ev_write($id, "250 OK helo\r\n");
                break;

            case strncmp('QUIT', $line, 3):
                $this->ev_write($id, "250 OK quit\r\n");
                $this->ev_close($id);
                break;

            case strncmp('STARTTLS', $line, 3):
                $this->ev_write($id, "220 Ready to start TLS\r\n");
                $this->connections[$id]['cnx'] = EventBufferEvent::sslFilter($this->base,
                    $this->connections[$id]['cnx'], $this->ctx,
                    EventBufferEvent::SSL_ACCEPTING,
                    EventBufferEvent::OPT_CLOSE_ON_FREE);
                $this->connections[$id]['cnx']->setCallbacks([$this, "ev_read"], NULL, [$this, 'ev_error'], $id);
                $this->connections[$id]['cnx']->enable(Event::READ | Event::WRITE);
                break;

            default:
                echo 'unknown command: '.$line."\n";
                break;
        }
    }
}

new Handler();

Ayrıca Bakınız

  • EventBufferEvent::sslSocket() - Creates a new SSL buffer event to send its data over an SSL on a socket
EventBufferEvent::sslError
EventBufferEvent::sslGetCipherInfo
EventBufferEvent


Returns a textual description of the cipher.

EventBufferEvent::sslFilter
EventBufferEvent::sslGetCipherName
EventBufferEvent
PHP Manual

EventBufferEvent::sslGetCipherInfo

(PECL event >= 1.10.0)

EventBufferEvent::sslGetCipherInfo — Returns a textual description of the cipher.

Açıklama

public string EventBufferEvent::sslGetCipherInfo ( void )

Retrieves description of the current cipher by means of the SSL_CIPHER_description SSL API function (see SSL_CIPHER_get_name(3) man page).

Bilginize:

This function is available only if Event is compiled with OpenSSL support.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a textual description of the cipher on success, or FALSE on error.

EventBufferEvent::sslFilter
EventBufferEvent::sslGetCipherName
EventBufferEvent


Returns the current cipher name of the SSL connection.

EventBufferEvent::sslGetCipherInfo
EventBufferEvent::sslGetCipherVersion
EventBufferEvent
PHP Manual

EventBufferEvent::sslGetCipherName

(PECL event >= 1.10.0)

EventBufferEvent::sslGetCipherName — Returns the current cipher name of the SSL connection.

Açıklama

public string EventBufferEvent::sslGetCipherName ( void )

Retrieves name of cipher used by current SSL connection.

Bilginize:

This function is available only if Event is compiled with OpenSSL support.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the current cipher name of the SSL connection, or FALSE on error.

EventBufferEvent::sslGetCipherInfo
EventBufferEvent::sslGetCipherVersion
EventBufferEvent


Returns version of cipher used by current SSL connection.

EventBufferEvent::sslGetCipherName
EventBufferEvent::sslGetProtocol
EventBufferEvent
PHP Manual

EventBufferEvent::sslGetCipherVersion

(PECL event >= 1.10.0)

EventBufferEvent::sslGetCipherVersion — Returns version of cipher used by current SSL connection.

Açıklama

public string EventBufferEvent::sslGetCipherVersion ( void )

Retrieves version of cipher used by current SSL connection.

Bilginize:

This function is available only if Event is compiled with OpenSSL support.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the current cipher version of the SSL connection, or FALSE on error.

EventBufferEvent::sslGetCipherName
EventBufferEvent::sslGetProtocol
EventBufferEvent


Returns the name of the protocol used for current SSL connection.

EventBufferEvent::sslGetCipherVersion
EventBufferEvent::sslRenegotiate
EventBufferEvent
PHP Manual

EventBufferEvent::sslGetProtocol

(PECL event >= 1.10.0)

EventBufferEvent::sslGetProtocol — Returns the name of the protocol used for current SSL connection.

Açıklama

public string EventBufferEvent::sslGetProtocol ( void )

Returns the name of the protocol used for current SSL connection.

Bilginize:

This function is available only if Event is compiled with OpenSSL support.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the name of the protocol used for current SSL connection.

EventBufferEvent::sslGetCipherVersion
EventBufferEvent::sslRenegotiate
EventBufferEvent


Tells a bufferevent to begin SSL renegotiation.

EventBufferEvent::sslGetProtocol
EventBufferEvent::sslSocket
EventBufferEvent
PHP Manual

EventBufferEvent::sslRenegotiate

(PECL event >= 1.2.6-beta)

EventBufferEvent::sslRenegotiate — Tells a bufferevent to begin SSL renegotiation.

Açıklama

public void EventBufferEvent::sslRenegotiate ( void )

Tells a bufferevent to begin SSL renegotiation.

Uyarı

Calling this function tells the SSL to renegotiate, and the buffer event to invoke appropriate callbacks. This is an advanced topic; this should be generally avoided unless one really knows what he/she does, especially since many SSL versions have had known security issues related to renegotiation.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

EventBufferEvent::sslGetProtocol
EventBufferEvent::sslSocket
EventBufferEvent


Creates a new SSL buffer event to send its data over an SSL on a socket

EventBufferEvent::sslRenegotiate
EventBufferEvent::write
EventBufferEvent
PHP Manual

EventBufferEvent::sslSocket

(PECL event >= 1.2.6-beta)

EventBufferEvent::sslSocket — Creates a new SSL buffer event to send its data over an SSL on a socket

Açıklama

public static EventBufferEvent EventBufferEvent::sslSocket ( EventBase $base , mixed $socket , EventSslContext $ctx , int $state [, int $options ] )

Creates a new SSL buffer event to send its data over an SSL on a socket.

Değiştirgeler

base

Associated event base.

socket

Socket to use for this SSL. Can be stream or socket resource, numeric file descriptor, or NULL. If socket is NULL, it is assumed that the file descriptor for the socket will be assigned later, for instance, by means of EventBufferEvent::connectHost() method.

ctx

Object of EventSslContext class.

state

The current state of SSL connection: EventBufferEvent::SSL_OPEN , EventBufferEvent::SSL_ACCEPTING or EventBufferEvent::SSL_CONNECTING .

options

The buffer event options.

Dönen Değerler

Returns EventBufferEvent object.

Ayrıca Bakınız

  • EventBufferEvent::sslFilter() - Create a new SSL buffer event to send its data over another buffer event
EventBufferEvent::sslRenegotiate
EventBufferEvent::write
EventBufferEvent


Adds data to a buffer event's output buffer

EventBufferEvent::sslSocket
EventBufferEvent::writeBuffer
EventBufferEvent
PHP Manual

EventBufferEvent::write

(PECL event >= 1.2.6-beta)

EventBufferEvent::write — Adds data to a buffer event's output buffer

Açıklama

public bool EventBufferEvent::write ( string $data )

Adds data to a buffer event's output buffer

Değiştirgeler

data

Data to be added to the underlying buffer.

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

Ayrıca Bakınız

  • EventBufferEvent::writeBuffer() - Adds contents of the entire buffer to a buffer event's output buffer
EventBufferEvent::sslSocket
EventBufferEvent::writeBuffer
EventBufferEvent


Adds contents of the entire buffer to a buffer event's output buffer

EventBufferEvent::write
About buffer event callbacks
EventBufferEvent
PHP Manual

EventBufferEvent::writeBuffer

(PECL event >= 1.2.6-beta)

EventBufferEvent::writeBuffer — Adds contents of the entire buffer to a buffer event's output buffer

Açıklama

public bool EventBufferEvent::writeBuffer ( EventBuffer $buf )

Adds contents of the entire buffer to a buffer event's output buffer

Değiştirgeler

buf

Source EventBuffer object.

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

Ayrıca Bakınız

  • EventBufferEvent::write() - Adds data to a buffer event's output buffer
EventBufferEvent::write
About buffer event callbacks
EventBufferEvent


About buffer event callbacks

An object of EventBufferEvent class represents a buffer event . The asynchronous nature of I/O performed by Libevent implies that a socket(or other kind of file descriptor) is not always available. Event invokes corresponding callbacks when the resource becomes available for reading or writing, or when some event occurs(e.g. error, "end of line" etc.).

Read and write callbacks should match the following prototype:

void callback ([ EventBufferEvent $bev = NULL [, mixed $arg = NULL ]] )

bev

Associated EventBufferEvent object.

arg

Custom variable attached to all callbacks via EventBufferEvent::__construct() , or EventBufferEvent::setCallbacks() .

Event callback should match the following prototype:

void callback ([ EventBufferEvent $bev = NULL [, int $events = 0 [, mixed $arg = NULL ]]] )

bev

Associated EventBufferEvent object.

events

Bit mask of events: EventBufferEvent::READING , EventBufferEvent::WRITING , EventBufferEvent::EOL , EventBufferEvent::ERROR and EventBufferEvent::TIMEOUT . See EventBufferEvent constants

arg

Custom variable attached to all callbacks via EventBufferEvent::__construct() , or EventBufferEvent::setCallbacks() .

EventBufferEvent::writeBuffer
EventConfig
Event


The EventConfig class

(PECL event >= 1.2.6-beta)

Giriş

Represents configuration structure which could be used in construction of the EventBase .

Sınıf Sözdizimi

final EventConfig {
/* Constants */
const integer FEATURE_ET = 1 ;
const integer FEATURE_O1 = 2 ;
const integer FEATURE_FDS = 4 ;
/* Yöntemler */
public bool avoidMethod ( string $method )
public __construct ( void )
public bool requireFeatures ( int $feature )
public void setMaxDispatchInterval ( int $max_interval , int $max_callbacks , int $min_priority )
}

Öntanımlı Sabitler

EventConfig::FEATURE_ET

Requires a backend method that supports edge-triggered I/O.

EventConfig::FEATURE_O1

Requires a backend method where adding or deleting a single event, or having a single event become active, is an O(1) operation.

EventConfig::FEATURE_FDS

Requires a backend method that can support arbitrary file descriptor types, and not just sockets.

İçindekiler

  • EventConfig::avoidMethod — Tells libevent to avoid specific event method
  • EventConfig::__construct — Constructs EventConfig object
  • EventConfig::requireFeatures — Enters a required event method feature that the application demands
  • EventConfig::setMaxDispatchInterval — Prevents priority inversion
About buffer event callbacks
EventConfig::avoidMethod
Event


Tells libevent to avoid specific event method

EventConfig
EventConfig::__construct
EventConfig
PHP Manual

EventConfig::avoidMethod

(PECL event >= 1.2.6-beta)

EventConfig::avoidMethod — Tells libevent to avoid specific event method

Açıklama

public bool EventConfig::avoidMethod ( string $method )

Tells libevent to avoid specific event method(backend). See » Creating an event base .

Değiştirgeler

method

The backend method to avoid. See EventConfig constants .

Dönen Değerler

Returns TRUE on success, otherwise FALSE.

Örnekler

Örnek 1 EventConfig::avoidMethod() example

<?php
$cfg = new EventConfig();
if ($cfg->avoidMethod("select")) {
    echo "`select' method avoided\n";
}
?>

Ayrıca Bakınız

  • EventBase::__construct() - Constructs EventBase object
EventConfig
EventConfig::__construct
EventConfig


Constructs EventConfig object

EventConfig::avoidMethod
EventConfig::requireFeatures
EventConfig
PHP Manual

EventConfig::__construct

(PECL event >= 1.2.6-beta)

EventConfig::__construct — Constructs EventConfig object

Açıklama

public EventConfig::__construct ( void )

Constructs EventConfig object which could be passed to EventBase::__construct() constructor.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns EventConfig object.

Örnekler

Örnek 1 EventConfig::__construct() example

<?php
// Avoiding "select" method
$cfg = new EventConfig();
if ($cfg->avoidMethod("select")) {
    echo "`select' method avoided\n";
}

// Create event_base associated with the config
$base = new EventBase($cfg);

/* Now $base is configured to avoid select backend(method) */
?>

Ayrıca Bakınız

  • EventBase::__construct() - Constructs EventBase object
EventConfig::avoidMethod
EventConfig::requireFeatures
EventConfig


Enters a required event method feature that the application demands

EventConfig::__construct
EventConfig::setMaxDispatchInterval
EventConfig
PHP Manual

EventConfig::requireFeatures

(PECL event >= 1.2.6-beta)

EventConfig::requireFeatures — Enters a required event method feature that the application demands

Açıklama

public bool EventConfig::requireFeatures ( int $feature )

Enters a required event method feature that the application demands

Değiştirgeler

feature

Bitmask of required features. See EventConfig::FEATURE_* constants

Dönen Değerler

Örnekler

Örnek 1 EventConfig::requireFeatures() example

<?php
$cfg = new EventConfig();

// Create event_base associated with the config
$base = new EventBase($cfg);

// Require FDS feature
if ($cfg->requireFeatures(EventConfig::FEATURE_FDS)) {
    echo "FDS feature is now requried\n";

    $base = new EventBase($cfg);
    ($base->getFeatures() & EventConfig::FEATURE_FDS)
        and print("FDS - arbitrary file descriptor types, and not just sockets\n");
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

FDS feature is now requried
FDS - arbitrary file descriptor types, and not just sockets

Ayrıca Bakınız

  • EventBase::getFeatures() - Returns bitmask of features supported
EventConfig::__construct
EventConfig::setMaxDispatchInterval
EventConfig


Prevents priority inversion

EventConfig::requireFeatures
EventDnsBase
EventConfig
PHP Manual

EventConfig::setMaxDispatchInterval

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

EventConfig::setMaxDispatchInterval — Prevents priority inversion

Açıklama

public void EventConfig::setMaxDispatchInterval ( int $max_interval , int $max_callbacks , int $min_priority )

Prevents priority inversion by limiting how many low-priority event callbacks can be invoked before checking for more high-priority events.

Bilginize:

Available since libevent 2.1.0-alpha .

Değiştirgeler

max_interval

An interval after which Libevent should stop running callbacks and check for more events, or 0 , if there should be no such interval.

max_callbacks

A number of callbacks after which Libevent should stop running callbacks and check for more events, or -1 , if there should be no such limit.

min_priority

A priority below which max_interval and max_callbacks should not be enforced. If this is set to 0 , they are enforced for events of every priority; if it's set to 1 , they're enforced for events of priority 1 and above, and so on.

Dönen Değerler

Returns TRUE on success, otherwise FALSE.

EventConfig::requireFeatures
EventDnsBase
EventConfig


The EventDnsBase class

(PECL event >= 1.2.6-beta)

Giriş

Represents Libevent's DNS base structure. Used to resolve DNS asyncronously, parse configuration files like resolv.conf etc.

Sınıf Sözdizimi

final EventDnsBase {
/* Constants */
const integer OPTION_SEARCH = 1 ;
const integer OPTION_NAMESERVERS = 2 ;
const integer OPTION_MISC = 4 ;
const integer OPTION_HOSTSFILE = 8 ;
const integer OPTIONS_ALL = 15 ;
/* Yöntemler */
public bool addNameserverIp ( string $ip )
public void addSearch ( string $domain )
public void clearSearch ( void )
public __construct ( EventBase $base , bool $initialize )
public int countNameservers ( void )
public bool loadHosts ( string $hosts )
public bool parseResolvConf ( int $flags , string $filename )
public bool setOption ( string $option , string $value )
public bool setSearchNdots ( int $ndots )
}

Öntanımlı Sabitler

EventDnsBase::OPTION_SEARCH

Tells to read the domain and search fields from the resolv.conf file and the ndots option, and use them to decide which domains(if any) to search for hostnames that aren't fully-qualified.

EventDnsBase::OPTION_NAMESERVERS

Tells to learn the nameservers from the resolv.conf file.

EventDnsBase::OPTION_MISC

EventDnsBase::OPTION_HOSTSFILE

Tells to read a list of hosts from /etc/hosts as part of loading the resolv.conf file.

EventDnsBase::OPTIONS_ALL

Tells to learn as much as it can from the resolv.conf file.

İçindekiler

  • EventDnsBase::addNameserverIp — Adds a nameserver to the DNS base
  • EventDnsBase::addSearch — Adds a domain to the list of search domains
  • EventDnsBase::clearSearch — Removes all current search suffixes
  • EventDnsBase::__construct — Constructs EventDnsBase object
  • EventDnsBase::countNameservers — Gets the number of configured nameservers
  • EventDnsBase::loadHosts — Loads a hosts file (in the same format as /etc/hosts) from hosts file
  • EventDnsBase::parseResolvConf — Scans the resolv.conf-formatted file
  • EventDnsBase::setOption — Set the value of a configuration option
  • EventDnsBase::setSearchNdots — Set the 'ndots' parameter for searches
EventConfig::setMaxDispatchInterval
EventDnsBase::addNameserverIp
Event


Adds a nameserver to the DNS base

EventDnsBase
EventDnsBase::addSearch
EventDnsBase
PHP Manual

EventDnsBase::addNameserverIp

(PECL event >= 1.2.6-beta)

EventDnsBase::addNameserverIp — Adds a nameserver to the DNS base

Açıklama

public bool EventDnsBase::addNameserverIp ( string $ip )

Adds a nameserver to the evdns_base.

Değiştirgeler

ip

The nameserver string, either as an IPv4 address, an IPv6 address, an IPv4 address with a port ( IPv4:Port ), or an IPv6 address with a port ( [IPv6]:Port ).

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

EventDnsBase
EventDnsBase::addSearch
EventDnsBase


Adds a domain to the list of search domains

EventDnsBase::addNameserverIp
EventDnsBase::clearSearch
EventDnsBase
PHP Manual

EventDnsBase::addSearch

(PECL event >= 1.2.6-beta)

EventDnsBase::addSearch — Adds a domain to the list of search domains

Açıklama

public void EventDnsBase::addSearch ( string $domain )

Adds a domain to the list of search domains

Değiştirgeler

domain

Search domain.

Dönen Değerler

Hiçbir değer dönmez.

EventDnsBase::addNameserverIp
EventDnsBase::clearSearch
EventDnsBase


Removes all current search suffixes

EventDnsBase::addSearch
EventDnsBase::__construct
EventDnsBase
PHP Manual

EventDnsBase::clearSearch

(PECL event >= 1.2.6-beta)

EventDnsBase::clearSearch — Removes all current search suffixes

Açıklama

public void EventDnsBase::clearSearch ( void )

Removes all current search suffixes from the DNS base; the EventDnsBase::addSearch() function adds a suffix.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • EventDnsBase::addSearch() - Adds a domain to the list of search domains
EventDnsBase::addSearch
EventDnsBase::__construct
EventDnsBase


Constructs EventDnsBase object

EventDnsBase::clearSearch
EventDnsBase::countNameservers
EventDnsBase
PHP Manual

EventDnsBase::__construct

(PECL event >= 1.2.6-beta)

EventDnsBase::__construct — Constructs EventDnsBase object

Açıklama

public EventDnsBase::__construct ( EventBase $base , bool $initialize )

Constructs EventDnsBase object.

Değiştirgeler

base

Event base.

initialize

If the initialize argument is TRUE, it tries to configure the DNS base sensibly given your operating system's default. Otherwise, it leaves the event DNS base empty, with no nameservers or options configured. In the latter case DNS base should be configured manually, e.g. with EventDnsBase::parseResolvConf() .

Dönen Değerler

Returns EventDnsBase object.

EventDnsBase::clearSearch
EventDnsBase::countNameservers
EventDnsBase


Gets the number of configured nameservers

EventDnsBase::__construct
EventDnsBase::loadHosts
EventDnsBase
PHP Manual

EventDnsBase::countNameservers

(PECL event >= 1.2.6-beta)

EventDnsBase::countNameservers — Gets the number of configured nameservers

Açıklama

public int EventDnsBase::countNameservers ( void )

Gets the number of configured nameservers

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the number of configured nameservers(not necessarily the number of running nameservers). This is useful for double-checking whether our calls to the various nameserver configuration functions have been successful.

EventDnsBase::__construct
EventDnsBase::loadHosts
EventDnsBase


Loads a hosts file (in the same format as /etc/hosts) from hosts file

EventDnsBase::countNameservers
EventDnsBase::parseResolvConf
EventDnsBase
PHP Manual

EventDnsBase::loadHosts

(PECL event >= 1.2.6-beta)

EventDnsBase::loadHosts — Loads a hosts file (in the same format as /etc/hosts) from hosts file

Açıklama

public bool EventDnsBase::loadHosts ( string $hosts )

Loads a hosts file (in the same format as /etc/hosts ) from hosts file.

Değiştirgeler

hosts

Path to the hosts' file.

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

EventDnsBase::countNameservers
EventDnsBase::parseResolvConf
EventDnsBase


Scans the resolv.conf-formatted file

EventDnsBase::loadHosts
EventDnsBase::setOption
EventDnsBase
PHP Manual

EventDnsBase::parseResolvConf

(PECL event >= 1.2.6-beta)

EventDnsBase::parseResolvConf — Scans the resolv.conf-formatted file

Açıklama

public bool EventDnsBase::parseResolvConf ( int $flags , string $filename )

Scans the resolv.conf-formatted file stored in filename, and read in all the options from it that are listed in flags

Değiştirgeler

flags

Determines what information is parsed from the resolv.conf file. See the man page for resolv.conf for the format of this file.

The following directives are not parsed from the file: sortlist, rotate, no-check-names, inet6, debug .

If this function encounters an error, the possible return values are:

  • 1 = failed to open file
  • 2 = failed to stat file
  • 3 = file too large
  • 4 = out of memory
  • 5 = short read from file
  • 6 = no nameservers listed in the file

filename

Path to resolv.conf file.

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

EventDnsBase::loadHosts
EventDnsBase::setOption
EventDnsBase


Set the value of a configuration option

EventDnsBase::parseResolvConf
EventDnsBase::setSearchNdots
EventDnsBase
PHP Manual

EventDnsBase::setOption

(PECL event >= 1.2.6-beta)

EventDnsBase::setOption — Set the value of a configuration option

Açıklama

public bool EventDnsBase::setOption ( string $option , string $value )

Set the value of a configuration option.

Değiştirgeler

option

The currently available configuration options are: "ndots" , "timeout" , "max-timeouts" , "max-inflight" , and "attempts" .

value

Option value.

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

EventDnsBase::parseResolvConf
EventDnsBase::setSearchNdots
EventDnsBase


Set the 'ndots' parameter for searches

EventDnsBase::setOption
EventHttp
EventDnsBase
PHP Manual

EventDnsBase::setSearchNdots

(PECL event >= 1.2.6-beta)

EventDnsBase::setSearchNdots — Set the 'ndots' parameter for searches

Açıklama

public bool EventDnsBase::setSearchNdots ( int $ndots )

Set the 'ndots' parameter for searches. Sets the number of dots which, when found in a name, causes the first query to be without any search domain.

Değiştirgeler

ndots

The number of dots.

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

EventDnsBase::setOption
EventHttp
EventDnsBase


The EventHttp class

(PECL event >= 1.4.0-beta)

Giriş

Represents HTTP server.

Sınıf Sözdizimi

final EventHttp {
/* Yöntemler */
public bool accept ( mixed $socket )
public bool addServerAlias ( string $alias )
public void bind ( string $address , int $port )
public __construct ( EventBase $base [, EventSslContext $ctx = NULL ] )
public bool removeServerAlias ( string $alias )
public void setAllowedMethods ( int $methods )
public void setCallback ( string $path , string $cb [, string $arg ] )
public void setDefaultCallback ( string $cb [, string $arg ] )
public void setMaxBodySize ( int $value )
public void setMaxHeadersSize ( int $value )
public void setTimeout ( int $value )
}

İçindekiler

  • EventHttp::accept — Makes an HTTP server accept connections on the specified socket stream or resource
  • EventHttp::addServerAlias — Adds a server alias to the HTTP server object
  • EventHttp::bind — Binds an HTTP server on the specified address and port
  • EventHttp::__construct — Constructs EventHttp object(the HTTP server)
  • EventHttp::removeServerAlias — Removes server alias
  • EventHttp::setAllowedMethods — Sets the what HTTP methods are supported in requests accepted by this server, and passed to user callbacks
  • EventHttp::setCallback — Sets a callback for specified URI
  • EventHttp::setDefaultCallback — Sets default callback to handle requests that are not caught by specific callbacks
  • EventHttp::setMaxBodySize — Sets maximum request body size
  • EventHttp::setMaxHeadersSize — Sets maximum HTTP header size
  • EventHttp::setTimeout — Sets the timeout for an HTTP request
EventDnsBase::setSearchNdots
EventHttp::accept
Event


Makes an HTTP server accept connections on the specified socket stream or resource

EventHttp
EventHttp::addServerAlias
EventHttp
PHP Manual

EventHttp::accept

(PECL event >= 1.2.6-beta)

EventHttp::accept — Makes an HTTP server accept connections on the specified socket stream or resource

Açıklama

public bool EventHttp::accept ( mixed $socket )

Makes an HTTP server accept connections on the specified socket stream or resource. The socket should be ready to accept connections.

Can be called multiple times to accept connections on different sockets.

Bilginize:

To bind a socket, listen , and accept connections on the socket in s single call use EventHttp::bind() . EventHttp::accept() is needed only if one already has a socket ready to accept connections.

Değiştirgeler

socket

Socket resource, stream or numeric file descriptor representing a socket ready to accept connections.

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

Örnekler

Örnek 1 EventHttp::accept() example

<?php
$base = new EventBase();
$http = new EventHttp($base);

$addresses = array (
     8091 => "127.0.0.1",
     8092 => "127.0.0.2",
);
$i = 0;

$socket = array();

foreach ($addresses as $port => $ip) {
    echo $ip, " ", $port, PHP_EOL;
    $socket[$i] = socket_create(AF_INET, SOCK_STREAM, SOL_TCP);
    if (!socket_bind($socket[$i], $ip, $port)) {
        exit("socket_bind failed\n");
    }
    socket_listen($socket[$i], 0);
    socket_set_nonblock($socket[$i]);

    if (!$http->accept($socket[$i])) {
        echo "Accept failed\n";
        exit(1);
    }

    ++$i;
}

$http->setCallback("/some-page", function() {
 echo "(some-page)\n";
    echo "URI: ", $req->getUri(), PHP_EOL;
    $req->sendReply(200, "OK");
    echo "OK\n";
});

$http->setDefaultCallback(function($req) {
    echo "URI: ", $req->getUri(), PHP_EOL;
    $req->sendReply(200, "OK");
    echo "OK\n";
});

$signal = Event::signal($base, SIGINT, function () use ($base) {
    echo "Caught SIGINT. Stopping...\n";
    $base->stop();
});
$signal->add();

$base->dispatch();
echo "END\n";
// We didn't close sockets, since Libevent already sets
// CLOSE_ON_FREE and CLOSE_ON_EXEC flags on the file
// descriptor associated with the sockets.
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Client:
$ nc 127.0.0.1 8091
GET /about HTTP/1.0
Connection: close

HTTP/1.0 200 OK
Content-Type: text/html; charset=ISO-8859-1
Connection: close

Server:
127.0.0.1 8091
127.0.0.2 8092
URI: /about
OK

Ayrıca Bakınız

  • EventHttp::bind() - Binds an HTTP server on the specified address and port
EventHttp
EventHttp::addServerAlias
EventHttp


Adds a server alias to the HTTP server object

EventHttp::accept
EventHttp::bind
EventHttp
PHP Manual

EventHttp::addServerAlias

(PECL event >= 1.4.0-beta)

EventHttp::addServerAlias — Adds a server alias to the HTTP server object

Açıklama

public bool EventHttp::addServerAlias ( string $alias )

Adds a server alias to the HTTP server object.

Değiştirgeler

alias

The alias to add.

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

Örnekler

Örnek 1 EventHttp::addServerAlias() example

<?php
$base = new EventBase();
$http = new EventHttp($base);

$socket = socket_create(AF_INET, SOCK_STREAM, SOL_TCP);

if (!$http->bind("127.0.0.1", 8088)) {
    exit("bind(1) failed\n");
};

if (!$http->addServerAlias("local.net")) {
    exit("Failed to add server alias\n");
}

$http->setCallback("/about", function($req) {
    echo "URI: ", $req->getUri(), PHP_EOL;
    $req->sendReply(200, "OK");
});
$base->dispatch();
?>

Ayrıca Bakınız

  • EventHttp::removeServerAlias() - Removes server alias
EventHttp::accept
EventHttp::bind
EventHttp


Binds an HTTP server on the specified address and port

EventHttp::addServerAlias
EventHttp::__construct
EventHttp
PHP Manual

EventHttp::bind

(PECL event >= 1.2.6-beta)

EventHttp::bind — Binds an HTTP server on the specified address and port

Açıklama

public void EventHttp::bind ( string $address , int $port )

Binds an HTTP server on the specified address and port.

Can be called multiple times to bind the same HTTP server to multiple different ports.

Değiştirgeler

address

A string containing the IP address to listen(2) on.

port

The port number to listen on.

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

Örnekler

Örnek 1 EventHttp::bind() example

<?php
$base = new EventBase();
$http = new EventHttp($base);

$socket = socket_create(AF_INET, SOCK_STREAM, SOL_TCP);

if (!$http->bind("127.0.0.1", 8088)) {
    exit("bind(1) failed\n");
};
if (!$http->bind("127.0.0.1", 8089)) {
    exit("bind(2) failed\n");
};

$http->setCallback("/about", function($req) {
    echo "URI: ", $req->getUri(), PHP_EOL;
    $req->sendReply(200, "OK");
    echo "OK\n";
});

$base->dispatch();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Client:

$ nc 127.0.0.1 8088
GET /about HTTP/1.0
Connection: close

HTTP/1.0 200 OK
Content-Type: text/html; charset=ISO-8859-1
Connection: close

$ nc 127.0.0.1 8089
GET /unknown HTTP/1.0
Connection: close

HTTP/1.1 404 Not Found
Content-Type: text/html
Date: Wed, 13 Mar 2013 04:14:41 GMT
Content-Length: 149
Connection: close

<html><head><title>404 Not Found</title></head><body><h1>Not Found</h1><p>The requested URL /unknown was not found on this server.</p></body></html>

Server:
URI: /about
OK

Ayrıca Bakınız

  • EventHttp::accept() - Makes an HTTP server accept connections on the specified socket stream or resource
EventHttp::addServerAlias
EventHttp::__construct
EventHttp


Constructs EventHttp object(the HTTP server)

EventHttp::bind
EventHttp::removeServerAlias
EventHttp
PHP Manual

EventHttp::__construct

(PECL event >= 1.2.6-beta)

EventHttp::__construct — Constructs EventHttp object(the HTTP server)

Açıklama

public EventHttp::__construct ( EventBase $base [, EventSslContext $ctx = NULL ] )

Constructs the HTTP server object.

Değiştirgeler

base

Associated event base.

ctx

EventSslContext class object. Turns plain HTTP server into HTTPS server. It means that if ctx is configured correctly, then the underlying buffer events will be based on OpenSSL sockets. Thus, all traffic will pass through the SSL or TLS.

Bilginize:

This parameter is available only if Event is compiled with OpenSSL support and only with Libevent 2.1.0-alpha and higher.

Dönen Değerler

Returns EventHttp object.

Sürüm Bilgisi

Sürüm: | Açıklama
1.9.0 | OpenSSL support (ctx) added.

Örnekler

Örnek 1 Simple HTTP server

<?php
/*
 * Simple HTTP server.
 *
 * To test it:
 * 1) Run it on a port of your choice, e.g.:
 * $ php examples/http.php 8010
 * 2) In another terminal connect to some address on this port
 * and make GET or POST request(others are turned off here), e.g.:
 * $ nc -t 127.0.0.1 8010
 * POST /about HTTP/1.0
 * Content-Type: text/plain
 * Content-Length: 4
 * Connection: close
 * (press Enter)
 *
 * It will output
 * a=12
 * HTTP/1.0 200 OK
 * Content-Type: text/html; charset=ISO-8859-1
 * Connection: close
 *
 * $ nc -t 127.0.0.1 8010
 * GET /dump HTTP/1.0
 * Content-Type: text/plain
 * Content-Encoding: UTF-8
 * Connection: close
 * (press Enter)
 *
 * It will output:
 * HTTP/1.0 200 OK
 * Content-Type: text/html; charset=ISO-8859-1
 * Connection: close
 * (press Enter)
 *
 * $ nc -t 127.0.0.1 8010
 * GET /unknown HTTP/1.0
 * Connection: close
 *
 * It will output:
 * HTTP/1.0 200 OK
 * Content-Type: text/html; charset=ISO-8859-1
 * Connection: close
 *
 * 3) See what the server outputs on the previous terminal window.
 */

function _http_dump($req, $data) {
    static $counter      = 0;
    static $max_requests = 2;

    if (++$counter >= $max_requests)  {
        echo "Counter reached max requests $max_requests. Exiting\n";
        exit();
    }

    echo __METHOD__, " called\n";
    echo "request:"; var_dump($req);
    echo "data:"; var_dump($data);

    echo "\n===== DUMP =====\n";
    echo "Command:", $req->getCommand(), PHP_EOL;
    echo "URI:", $req->getUri(), PHP_EOL;
    echo "Input headers:"; var_dump($req->getInputHeaders());
    echo "Output headers:"; var_dump($req->getOutputHeaders());

    echo "\n >> Sending reply ...";
    $req->sendReply(200, "OK");
    echo "OK\n";

    echo "\n >> Reading input buffer ...\n";
    $buf = $req->getInputBuffer();
    while ($s = $buf->readLine(EventBuffer::EOL_ANY)) {
        echo $s, PHP_EOL;
    }
    echo "No more data in the buffer\n";
}

function _http_about($req) {
    echo __METHOD__, PHP_EOL;
    echo "URI: ", $req->getUri(), PHP_EOL;
    echo "\n >> Sending reply ...";
    $req->sendReply(200, "OK");
    echo "OK\n";
}

function _http_default($req, $data) {
    echo __METHOD__, PHP_EOL;
    echo "URI: ", $req->getUri(), PHP_EOL;
    echo "\n >> Sending reply ...";
    $req->sendReply(200, "OK");
    echo "OK\n";
}

$port = 8010;
if ($argc > 1) {
    $port = (int) $argv[1];
}
if ($port <= 0 || $port > 65535) {
    exit("Invalid port");
}

$base = new EventBase();
$http = new EventHttp($base);
$http->setAllowedMethods(EventHttpRequest::CMD_GET | EventHttpRequest::CMD_POST);

$http->setCallback("/dump", "_http_dump", array(4, 8));
$http->setCallback("/about", "_http_about");
$http->setDefaultCallback("_http_default", "custom data value");

$http->bind("0.0.0.0", 8010);
$base->loop();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

a=12
HTTP/1.0 200 OK
Content-Type: text/html; charset=ISO-8859-1
Connection: close

HTTP/1.0 200 OK
Content-Type: text/html; charset=ISO-8859-1
Connection: close
(press Enter)

HTTP/1.0 200 OK
Content-Type: text/html; charset=ISO-8859-1
Connection: close
EventHttp::bind
EventHttp::removeServerAlias
EventHttp


Removes server alias

EventHttp::__construct
EventHttp::setAllowedMethods
EventHttp
PHP Manual

EventHttp::removeServerAlias

(PECL event >= 1.4.0-beta)

EventHttp::removeServerAlias — Removes server alias

Açıklama

public bool EventHttp::removeServerAlias ( string $alias )

Removes server alias added with EventHttp::addServerAlias()

Değiştirgeler

alias

The alias to remove.

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

Ayrıca Bakınız

  • EventHttp::addServerAlias() - Adds a server alias to the HTTP server object
EventHttp::__construct
EventHttp::setAllowedMethods
EventHttp


Sets the what HTTP methods are supported in requests accepted by this server, and passed to user callbacks

EventHttp::removeServerAlias
EventHttp::setCallback
EventHttp
PHP Manual

EventHttp::setAllowedMethods

(PECL event >= 1.4.0-beta)

EventHttp::setAllowedMethods — Sets the what HTTP methods are supported in requests accepted by this server, and passed to user callbacks

Açıklama

public void EventHttp::setAllowedMethods ( int $methods )

Sets the what HTTP methods are supported in requests accepted by this server, and passed to user callbacks

If not supported they will generate a "405 Method not allowed" response.

By default this includes the following methods: GET , POST , HEAD , PUT , DELETE . See EventHttpRequest::CMD_* constants.

Değiştirgeler

methods

A bit mask of EventHttpRequest::CMD_* constants .

Dönen Değerler

Hiçbir değer dönmez.

EventHttp::removeServerAlias
EventHttp::setCallback
EventHttp


Sets a callback for specified URI

EventHttp::setAllowedMethods
EventHttp::setDefaultCallback
EventHttp
PHP Manual

EventHttp::setCallback

(PECL event >= 1.4.0-beta)

EventHttp::setCallback — Sets a callback for specified URI

Açıklama

public void EventHttp::setCallback ( string $path , string $cb [, string $arg ] )

Sets a callback for specified URI.

Değiştirgeler

path

The path for which to invoke the callback.

cb

The callback callable that gets invoked on requested path . It should match the following prototype:

void callback ([ EventHttpRequest $req = NULL [, mixed $arg = NULL ]] )

req

EventHttpRequest object.

arg

Custom data.

arg

Custom data.

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

Örnekler

Örnek 1 EventHttp::setCallback() example

<?php
/*
 * Simple HTTP server.
 *
 * To test it:
 * 1) Run it on a port of your choice, e.g.:
 * $ php examples/http.php 8010
 * 2) In another terminal connect to some address on this port
 * and make GET or POST request(others are turned off here), e.g.:
 * $ nc -t 127.0.0.1 8010
 * POST /about HTTP/1.0
 * Content-Type: text/plain
 * Content-Length: 4
 * Connection: close
 * (press Enter)
 *
 * It will output
 * a=12
 * HTTP/1.0 200 OK
 * Content-Type: text/html; charset=ISO-8859-1
 * Connection: close
 *
 * 3) See what the server outputs on the previous terminal window.
 */

function _http_dump($req, $data) {
    static $counter      = 0;
    static $max_requests = 2;

    if (++$counter >= $max_requests)  {
        echo "Counter reached max requests $max_requests. Exiting\n";
        exit();
    }

    echo __METHOD__, " called\n";
    echo "request:"; var_dump($req);
    echo "data:"; var_dump($data);

    echo "\n===== DUMP =====\n";
    echo "Command:", $req->getCommand(), PHP_EOL;
    echo "URI:", $req->getUri(), PHP_EOL;
    echo "Input headers:"; var_dump($req->getInputHeaders());
    echo "Output headers:"; var_dump($req->getOutputHeaders());

    echo "\n >> Sending reply ...";
    $req->sendReply(200, "OK");
    echo "OK\n";

    echo "\n >> Reading input buffer ...\n";
    $buf = $req->getInputBuffer();
    while ($s = $buf->readLine(EventBuffer::EOL_ANY)) {
        echo $s, PHP_EOL;
    }
    echo "No more data in the buffer\n";
}

function _http_about($req) {
    echo __METHOD__, PHP_EOL;
    echo "URI: ", $req->getUri(), PHP_EOL;
    echo "\n >> Sending reply ...";
    $req->sendReply(200, "OK");
    echo "OK\n";
}

function _http_default($req, $data) {
    echo __METHOD__, PHP_EOL;
    echo "URI: ", $req->getUri(), PHP_EOL;
    echo "\n >> Sending reply ...";
    $req->sendReply(200, "OK");
    echo "OK\n";
}

$port = 8010;
if ($argc > 1) {
    $port = (int) $argv[1];
}
if ($port <= 0 || $port > 65535) {
    exit("Invalid port");
}

$base = new EventBase();
$http = new EventHttp($base);
$http->setAllowedMethods(EventHttpRequest::CMD_GET | EventHttpRequest::CMD_POST);

$http->setCallback("/dump", "_http_dump", array(4, 8));
$http->setCallback("/about", "_http_about");
$http->setDefaultCallback("_http_default", "custom data value");

$http->bind("0.0.0.0", 8010);
$base->loop();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

a=12
HTTP/1.0 200 OK
Content-Type: text/html; charset=ISO-8859-1
Connection: close

Ayrıca Bakınız

  • EventHttp::setDefaultCallback() - Sets default callback to handle requests that are not caught by specific callbacks
EventHttp::setAllowedMethods
EventHttp::setDefaultCallback
EventHttp


Sets default callback to handle requests that are not caught by specific callbacks

EventHttp::setCallback
EventHttp::setMaxBodySize
EventHttp
PHP Manual

EventHttp::setDefaultCallback

(PECL event >= 1.4.0-beta)

EventHttp::setDefaultCallback — Sets default callback to handle requests that are not caught by specific callbacks

Açıklama

public void EventHttp::setDefaultCallback ( string $cb [, string $arg ] )

Sets default callback to handle requests that are not caught by specific callbacks

Değiştirgeler

cb

The callback callable . It should match the following prototype:

void callback ([ EventHttpRequest $req = NULL [, mixed $arg = NULL ]] )

req

EventHttpRequest object.

arg

Custom data.

arg

User custom data passed to the callback.

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

Örnekler

Örnek 1 EventHttp::setDefaultCallback() example

<?php
$base = new EventBase();
$http = new EventHttp($base);

$socket = socket_create(AF_INET, SOCK_STREAM, SOL_TCP);

if (!$http->bind("127.0.0.1", 8088)) {
    exit("bind(1) failed\n");
};

$http->setDefaultCallback(function($req) {
    echo "URI: ", $req->getUri(), PHP_EOL;
    $req->sendReply(200, "OK");
});

$base->dispatch();
?>

Ayrıca Bakınız

  • EventHttp::setCallback() - Sets a callback for specified URI
EventHttp::setCallback
EventHttp::setMaxBodySize
EventHttp


Sets maximum request body size

EventHttp::setDefaultCallback
EventHttp::setMaxHeadersSize
EventHttp
PHP Manual

EventHttp::setMaxBodySize

(PECL event >= 1.4.0-beta)

EventHttp::setMaxBodySize — Sets maximum request body size

Açıklama

public void EventHttp::setMaxBodySize ( int $value )

Sets maximum request body size.

Değiştirgeler

value

The body size in bytes.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • EventHttp::setMaxHeadersSize() - Sets maximum HTTP header size
EventHttp::setDefaultCallback
EventHttp::setMaxHeadersSize
EventHttp


Sets maximum HTTP header size

EventHttp::setMaxBodySize
EventHttp::setTimeout
EventHttp
PHP Manual

EventHttp::setMaxHeadersSize

(PECL event >= 1.4.0-beta)

EventHttp::setMaxHeadersSize — Sets maximum HTTP header size

Açıklama

public void EventHttp::setMaxHeadersSize ( int $value )

Sets maximum HTTP header size.

Değiştirgeler

value

The header size in bytes.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • EventHttp::setMaxHeadersSize()
EventHttp::setMaxBodySize
EventHttp::setTimeout
EventHttp


Sets the timeout for an HTTP request

EventHttp::setMaxHeadersSize
EventHttpConnection
EventHttp
PHP Manual

EventHttp::setTimeout

(PECL event >= 1.4.0-beta)

EventHttp::setTimeout — Sets the timeout for an HTTP request

Açıklama

public void EventHttp::setTimeout ( int $value )

Sets the timeout for an HTTP request.

Değiştirgeler

value

The timeout in seconds.

Dönen Değerler

Hiçbir değer dönmez.

EventHttp::setMaxHeadersSize
EventHttpConnection
EventHttp


The EventHttpConnection class

(PECL event >= 1.4.0-beta)

Giriş

Represents an HTTP connection.

Sınıf Sözdizimi

EventHttpConnection {
/* Yöntemler */
public __construct ( EventBase $base , EventDnsBase $dns_base , string $address , int $port [, EventSslContext $ctx = NULL ] )
public EventBase getBase ( void )
public void getPeer ( string &$address , int &$port )
public bool makeRequest ( EventHttpRequest $req , int $type , string $uri )
public void setCloseCallback ( callable $callback [, mixed $data ] )
public void setLocalAddress ( string $address )
public void setLocalPort ( int $port )
public void setMaxBodySize ( string $max_size )
public void setMaxHeadersSize ( string $max_size )
public void setRetries ( int $retries )
public void setTimeout ( int $timeout )
}

İçindekiler

  • EventHttpConnection::__construct — Constructs EventHttpConnection object
  • EventHttpConnection::getBase — Returns event base associated with the connection
  • EventHttpConnection::getPeer — Gets the remote address and port associated with the connection
  • EventHttpConnection::makeRequest — Makes an HTTP request over the specified connection
  • EventHttpConnection::setCloseCallback — Set callback for connection close
  • EventHttpConnection::setLocalAddress — Sets the IP address from which HTTP connections are made
  • EventHttpConnection::setLocalPort — Sets the local port from which connections are made
  • EventHttpConnection::setMaxBodySize — Sets maximum body size for the connection
  • EventHttpConnection::setMaxHeadersSize — Sets maximum header size
  • EventHttpConnection::setRetries — Sets the retry limit for the connection
  • EventHttpConnection::setTimeout — Sets the timeout for the connection
EventHttp::setTimeout
EventHttpConnection::__construct
Event


Constructs EventHttpConnection object

EventHttpConnection
EventHttpConnection::getBase
EventHttpConnection
PHP Manual

EventHttpConnection::__construct

(PECL event >= 1.2.6-beta)

EventHttpConnection::__construct — Constructs EventHttpConnection object

Açıklama

public EventHttpConnection::__construct ( EventBase $base , EventDnsBase $dns_base , string $address , int $port [, EventSslContext $ctx = NULL ] )

Constructs EventHttpConnection object.

Değiştirgeler

base

Associated event base.

dns_base

If dns_base is NULL, hostname resolution will block.

address

The address to connect to.

port

The port to connect to.

ctx

EventSslContext class object. Enables OpenSSL.

Bilginize:

This parameter is available only if Event is compiled with OpenSSL support and only with Libevent 2.1.0-alpha and higher.

Dönen Değerler

Returns EventHttpConnection object.

Sürüm Bilgisi

Sürüm: | Açıklama
1.9.0 | OpenSSL support (ctx) added.

EventHttpConnection
EventHttpConnection::getBase
EventHttpConnection


Returns event base associated with the connection

EventHttpConnection::__construct
EventHttpConnection::getPeer
EventHttpConnection
PHP Manual

EventHttpConnection::getBase

(PECL event >= 1.2.6-beta)

EventHttpConnection::getBase — Returns event base associated with the connection

Açıklama

public EventBase EventHttpConnection::getBase ( void )

Returns event base associated with the connection.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

On success returns EventBase object associated with the connection. Otherwise FALSE.

EventHttpConnection::__construct
EventHttpConnection::getPeer
EventHttpConnection


Gets the remote address and port associated with the connection

EventHttpConnection::getBase
EventHttpConnection::makeRequest
EventHttpConnection
PHP Manual

EventHttpConnection::getPeer

(PECL event >= 1.2.6-beta)

EventHttpConnection::getPeer — Gets the remote address and port associated with the connection

Açıklama

public void EventHttpConnection::getPeer ( string &$address , int &$port )

Gets the remote address and port associated with the connection

Değiştirgeler

address

Address of the peer.

port

Port of the peer.

Dönen Değerler

Hiçbir değer dönmez.

EventHttpConnection::getBase
EventHttpConnection::makeRequest
EventHttpConnection


Makes an HTTP request over the specified connection

EventHttpConnection::getPeer
EventHttpConnection::setCloseCallback
EventHttpConnection
PHP Manual

EventHttpConnection::makeRequest

(PECL event >= 1.4.0-beta)

EventHttpConnection::makeRequest — Makes an HTTP request over the specified connection

Açıklama

public bool EventHttpConnection::makeRequest ( EventHttpRequest $req , int $type , string $uri )

Makes an HTTP request over the specified connection. type is one of EventHttpRequest::CMD_* constants.

Değiştirgeler

req

The connection object over which to send the request.

type

One of EventHttpRequest::CMD_* constants .

uri

The URI associated with the request.

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

Örnekler

Örnek 1 EventHttpConnection::makeRequest() example

<?php
function _request_handler($req, $base) {
    echo __FUNCTION__, PHP_EOL;

    if (is_null($req)) {
        echo "Timed out\n";
    } else {
        $response_code = $req->getResponseCode();

        if ($response_code == 0) {
            echo "Connection refused\n";
        } elseif ($response_code != 200) {
            echo "Unexpected response: $response_code\n";
        } else {
            echo "Success: $response_code\n";
            $buf = $req->getInputBuffer();
            echo "Body:\n";
            while ($s = $buf->readLine(EventBuffer::EOL_ANY)) {
                echo $s, PHP_EOL;
            }
        }
    }

    $base->exit(NULL);
}

$address = "127.0.0.1";
$port = 80;

$base = new EventBase();
$conn = new EventHttpConnection($base, NULL, $address, $port);
$conn->setTimeout(5);
$req = new EventHttpRequest("_request_handler", $base);

$req->addHeader("Host", $address, EventHttpRequest::OUTPUT_HEADER);
$req->addHeader("Content-Length", "0", EventHttpRequest::OUTPUT_HEADER);
$conn->makeRequest($req, EventHttpRequest::CMD_GET, "/index.cphp");

$base->loop();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

_request_handler
Success: 200
Body:
PHP, date:
2013-03-13T20:27:52+05:00

Ayrıca Bakınız

  • EventHttpRequest::addHeader() - Adds an HTTP header to the headers of the request
EventHttpConnection::getPeer
EventHttpConnection::setCloseCallback
EventHttpConnection


Set callback for connection close

EventHttpConnection::makeRequest
EventHttpConnection::setLocalAddress
EventHttpConnection
PHP Manual

EventHttpConnection::setCloseCallback

(PECL event >= 1.8.0)

EventHttpConnection::setCloseCallback — Set callback for connection close

Açıklama

public void EventHttpConnection::setCloseCallback ( callable $callback [, mixed $data ] )

Sets callback for connection close.

Değiştirgeler

callback

Callback which is called when connection is closed. Should match the following prototype:

void callback ([ EventHttpConnection $conn = NULL [, mixed $arg = NULL ]] )

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 EventHttpConnection::setCloseCallback() example

<?php
/*
 * Setting up close-connection callback
 *
 * The script handles closed connections using HTTP API.
 *
 * Usage:
 * 1) Launch the server:
 * $ php examples/http_closecb.php 4242
 *
 * 2) Launch a client in another terminal. Telnet-like
 * session should look like the following:
 *
 * $ nc -t 127.0.0.1 4242
 * GET / HTTP/1.0
 * Connection: close
 *
 * The server will output something similar to the following:
 *
 * HTTP/1.0 200 OK
 * Content-Type: multipart/x-mixed-replace;boundary=boundarydonotcross
 * Connection: close
 *
 * <html>
 *
 * 3) Terminate the client connection abruptly,
 * i.e. kill the process, or just press Ctrl-C.
 *
 * 4) Check if the server called _close_callback.
 * The script should output "_close_callback" string to standard output.
 *
 * 5) Check if the server's process has no orphaned connections,
 * e.g. with `lsof` utility.
 */

function _close_callback($conn)
{
    echo __FUNCTION__, PHP_EOL;
}

function _http_default($req, $dummy)
{
    $conn = $req->getConnection();
    $conn->setCloseCallback('_close_callback', NULL);

    /*
    By enabling Event::READ we protect the server against unclosed conections.
    This is a peculiarity of Libevent. The library disables Event::READ events
     on this connection, and the server is not notified about terminated
    connections.

    So each time client terminates connection abruptly, we get an orphaned
    connection. For instance, the following is a part of `lsof -p $PID | grep TCP`
    command after client has terminated connection:

    57-php     15057 ruslan  6u  unix 0xffff8802fb59c780   0t0  125187 socket
    58:php     15057 ruslan  7u  IPv4             125189   0t0     TCP *:4242 (LISTEN)
    59:php     15057 ruslan  8u  IPv4             124342   0t0     TCP localhost:4242->localhost:37375 (CLOSE_WAIT)

    where $PID is our process ID.

    The following block of code fixes such kind of orphaned connections.
     */
    $bev = $req->getBufferEvent();
    $bev->enable(Event::READ);
    // We have to free it explicitly. See
EventHttpRequest::getConnection()
$bev->free(); // we have to free it explicitly

    $req->addHeader(
        'Content-Type',
        'multipart/x-mixed-replace;boundary=boundarydonotcross',
        EventHttpRequest::OUTPUT_HEADER
    );

    $buf = new EventBuffer();
    $buf->add('<html>');

    $req->sendReply(200, "OK");
    $req->sendReplyChunk($buf);
}

$port = 4242;
if ($argc > 1) {
    $port = (int) $argv[1];
}
if ($port <= 0 || $port > 65535) {
    exit("Invalid port");
}

$base = new EventBase();
$http = new EventHttp($base);

$http->setDefaultCallback("_http_default", NULL);
$http->bind("0.0.0.0", $port);
$base->loop();

?>
EventHttpConnection::makeRequest
EventHttpConnection::setLocalAddress
EventHttpConnection


Sets the IP address from which HTTP connections are made

EventHttpConnection::setCloseCallback
EventHttpConnection::setLocalPort
EventHttpConnection
PHP Manual

EventHttpConnection::setLocalAddress

(PECL event >= 1.2.6-beta)

EventHttpConnection::setLocalAddress — Sets the IP address from which HTTP connections are made

Açıklama

public void EventHttpConnection::setLocalAddress ( string $address )

Sets the IP address from which http connections are made.

Değiştirgeler

address

The IP address from which HTTP connections are made.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • EventHttpConnection::setLocalPort() - Sets the local port from which connections are made
EventHttpConnection::setCloseCallback
EventHttpConnection::setLocalPort
EventHttpConnection


Sets the local port from which connections are made

EventHttpConnection::setLocalAddress
EventHttpConnection::setMaxBodySize
EventHttpConnection
PHP Manual

EventHttpConnection::setLocalPort

(PECL event >= 1.2.6-beta)

EventHttpConnection::setLocalPort — Sets the local port from which connections are made

Açıklama

public void EventHttpConnection::setLocalPort ( int $port )

Sets the local port from which connections are made.

Değiştirgeler

port

The port number.

Dönen Değerler

Ayrıca Bakınız

  • EventHttpConnection::setLocalAddress() - Sets the IP address from which HTTP connections are made
EventHttpConnection::setLocalAddress
EventHttpConnection::setMaxBodySize
EventHttpConnection


Sets maximum body size for the connection

EventHttpConnection::setLocalPort
EventHttpConnection::setMaxHeadersSize
EventHttpConnection
PHP Manual

EventHttpConnection::setMaxBodySize

(PECL event >= 1.2.6-beta)

EventHttpConnection::setMaxBodySize — Sets maximum body size for the connection

Açıklama

public void EventHttpConnection::setMaxBodySize ( string $max_size )

Sets maximum body size for the connection.

Değiştirgeler

max_size

The maximum body size in bytes.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • EventHttpConnection::setMaxHeadersSize() - Sets maximum header size
EventHttpConnection::setLocalPort
EventHttpConnection::setMaxHeadersSize
EventHttpConnection


Sets maximum header size

EventHttpConnection::setMaxBodySize
EventHttpConnection::setRetries
EventHttpConnection
PHP Manual

EventHttpConnection::setMaxHeadersSize

(PECL event >= 1.2.6-beta)

EventHttpConnection::setMaxHeadersSize — Sets maximum header size

Açıklama

public void EventHttpConnection::setMaxHeadersSize ( string $max_size )

Sets maximum header size for the connection.

Değiştirgeler

max_size

The maximum header size in bytes.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • EventHttpConnection::setMaxBodySize() - Sets maximum body size for the connection
EventHttpConnection::setMaxBodySize
EventHttpConnection::setRetries
EventHttpConnection


Sets the retry limit for the connection

EventHttpConnection::setMaxHeadersSize
EventHttpConnection::setTimeout
EventHttpConnection
PHP Manual

EventHttpConnection::setRetries

(PECL event >= 1.2.6-beta)

EventHttpConnection::setRetries — Sets the retry limit for the connection

Açıklama

public void EventHttpConnection::setRetries ( int $retries )

Sets the retry limit for the connection

Değiştirgeler

retries

The retry limit. -1 means infinity.

Dönen Değerler

Hiçbir değer dönmez.

EventHttpConnection::setMaxHeadersSize
EventHttpConnection::setTimeout
EventHttpConnection


Sets the timeout for the connection

EventHttpConnection::setRetries
EventHttpRequest
EventHttpConnection
PHP Manual

EventHttpConnection::setTimeout

(PECL event >= 1.2.6-beta)

EventHttpConnection::setTimeout — Sets the timeout for the connection

Açıklama

public void EventHttpConnection::setTimeout ( int $timeout )

Sets the timeout for the connection

Değiştirgeler

timeout

Timeout in seconds.

Dönen Değerler

Hiçbir değer dönmez.

EventHttpConnection::setRetries
EventHttpRequest
EventHttpConnection


The EventHttpRequest class

(PECL event >= 1.4.0-beta)

Giriş

Represents an HTTP request.

Sınıf Sözdizimi

EventHttpRequest {
/* Constants */
const integer CMD_GET = 1 ;
const integer CMD_POST = 2 ;
const integer CMD_HEAD = 4 ;
const integer CMD_PUT = 8 ;
const integer CMD_DELETE = 16 ;
const integer CMD_OPTIONS = 32 ;
const integer CMD_TRACE = 64 ;
const integer CMD_CONNECT = 128 ;
const integer CMD_PATCH = 256 ;
const integer INPUT_HEADER = 1 ;
const integer OUTPUT_HEADER = 2 ;
/* Yöntemler */
public bool addHeader ( string $key , string $value , int $type )
public void cancel ( void )
public void clearHeaders ( void )
public void closeConnection ( void )
public __construct ( callable $callback [, mixed $data = NULL ] )
public void findHeader ( string $key , string $type )
public void free ( void )
public EventBufferEvent closeConnection ( void )
public void getCommand ( void )
public EventHttpConnection closeConnection ( void )
public string getHost ( void )
public EventBuffer getInputBuffer ( void )
public array getInputHeaders ( void )
public EventBuffer getOutputBuffer ( void )
public void getOutputHeaders ( void )
public int getResponseCode ( void )
public string getUri ( void )
public void removeHeader ( string $key , string $type )
public void sendError ( int $error [, string $reason = NULL ] )
public void sendReply ( int $code , string $reason [, EventBuffer $buf ] )
public void sendReplyChunk ( EventBuffer $buf )
public void sendReplyEnd ( void )
public void sendReplyStart ( int $code , string $reason )
}

Öntanımlı Sabitler

EventHttpRequest::CMD_GET

GET method(command)

EventHttpRequest::CMD_POST

POST method(command)

EventHttpRequest::CMD_HEAD

HEAD method(command)

EventHttpRequest::CMD_PUT

PUT method(command)

EventHttpRequest::CMD_DELETE

DELETE command(method)

EventHttpRequest::CMD_OPTIONS

OPTIONS method(command)

EventHttpRequest::CMD_TRACE

TRACE method(command)

EventHttpRequest::CMD_CONNECT

CONNECT method(command)

EventHttpRequest::CMD_PATCH

PATCH method(command)

EventHttpRequest::INPUT_HEADER

Request input header type.

EventHttpRequest::OUTPUT_HEADER

Request output header type.

İçindekiler

  • EventHttpRequest::addHeader — Adds an HTTP header to the headers of the request
  • EventHttpRequest::cancel — Cancels a pending HTTP request
  • EventHttpRequest::clearHeaders — Removes all output headers from the header list of the request
  • EventHttpRequest::closeConnection — Closes associated HTTP connection
  • EventHttpRequest::__construct — Constructs EventHttpRequest object
  • EventHttpRequest::findHeader — Finds the value belonging a header
  • EventHttpRequest::free — Frees the object and removes associated events
  • EventHttpRequest::getBufferEvent — Returns EventBufferEvent object
  • EventHttpRequest::getCommand — Returns the request command(method)
  • EventHttpRequest::getConnection — Returns EventHttpConnection object
  • EventHttpRequest::getHost — Returns the request host
  • EventHttpRequest::getInputBuffer — Returns the input buffer
  • EventHttpRequest::getInputHeaders — Returns associative array of the input headers
  • EventHttpRequest::getOutputBuffer — Returns the output buffer of the request
  • EventHttpRequest::getOutputHeaders — Returns associative array of the output headers
  • EventHttpRequest::getResponseCode — Returns the response code
  • EventHttpRequest::getUri — Returns the request URI
  • EventHttpRequest::removeHeader — Removes an HTTP header from the headers of the request
  • EventHttpRequest::sendError — Send an HTML error message to the client
  • EventHttpRequest::sendReply — Send an HTML reply to the client
  • EventHttpRequest::sendReplyChunk — Send another data chunk as part of an ongoing chunked reply
  • EventHttpRequest::sendReplyEnd — Complete a chunked reply, freeing the request as appropriate
  • EventHttpRequest::sendReplyStart — Initiate a chunked reply
EventHttpConnection::setTimeout
EventHttpRequest::addHeader
Event


Adds an HTTP header to the headers of the request

EventHttpRequest
EventHttpRequest::cancel
EventHttpRequest
PHP Manual

EventHttpRequest::addHeader

(PECL event >= 1.4.0-beta)

EventHttpRequest::addHeader — Adds an HTTP header to the headers of the request

Açıklama

public bool EventHttpRequest::addHeader ( string $key , string $value , int $type )

Adds an HTTP header to the headers of the request.

Değiştirgeler

key

Header name.

value

Header value.

type

One of EventHttpRequest::*_HEADER constants .

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

Ayrıca Bakınız

  • EventHttpRequest::removeHeader() - Removes an HTTP header from the headers of the request
EventHttpRequest
EventHttpRequest::cancel
EventHttpRequest


Cancels a pending HTTP request

EventHttpRequest::addHeader
EventHttpRequest::clearHeaders
EventHttpRequest
PHP Manual

EventHttpRequest::cancel

(PECL event >= 1.4.0-beta)

EventHttpRequest::cancel — Cancels a pending HTTP request

Açıklama

public void EventHttpRequest::cancel ( void )

Cancels a pending HTTP request.

Cancels an ongoing HTTP request. The callback associated with this request is not executed and the request object is freed. If the request is currently being processed, e.g. it is ongoing, the corresponding EventHttpConnection object is going to get reset.

A request cannot be canceled if its callback has executed already. A request may be canceled reentrantly from its chunked callback.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

EventHttpRequest::addHeader
EventHttpRequest::clearHeaders
EventHttpRequest


Removes all output headers from the header list of the request

EventHttpRequest::cancel
EventHttpRequest::closeConnection
EventHttpRequest
PHP Manual

EventHttpRequest::clearHeaders

(PECL event >= 1.4.0-beta)

EventHttpRequest::clearHeaders — Removes all output headers from the header list of the request

Açıklama

public void EventHttpRequest::clearHeaders ( void )

Removes all output headers from the header list of the request.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • EventHttpRequest::addHeader() - Adds an HTTP header to the headers of the request
EventHttpRequest::cancel
EventHttpRequest::closeConnection
EventHttpRequest


Closes associated HTTP connection

EventHttpRequest::clearHeaders
EventHttpRequest::__construct
EventHttpRequest
PHP Manual

EventHttpRequest::closeConnection

(PECL event >= 1.8.0)

EventHttpRequest::closeConnection — Closes associated HTTP connection

Açıklama

public void EventHttpRequest::closeConnection ( void )

Closes HTTP connection associated with the request.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

EventHttpRequest::clearHeaders
EventHttpRequest::__construct
EventHttpRequest


Constructs EventHttpRequest object

EventHttpRequest::closeConnection
EventHttpRequest::findHeader
EventHttpRequest
PHP Manual

EventHttpRequest::__construct

(PECL event >= 1.4.0-beta)

EventHttpRequest::__construct — Constructs EventHttpRequest object

Açıklama

public EventHttpRequest::__construct ( callable $callback [, mixed $data = NULL ] )

Constructs EventHttpRequest object.

Değiştirgeler

callback

Gets invoked on requesting path. Should match the following prototype:

void callback ([ EventHttpRequest $req = NULL [, mixed $arg = NULL ]] )
data

User custom data passed to the callback.

Dönen Değerler

Returns EventHttpRequest object.

Örnekler

Örnek 1 EventHttpRequest::__construct() example

<?php

function _request_handler($req, $base) {
    echo __FUNCTION__, PHP_EOL;

    if (is_null($req)) {
        echo "Timed out\n";
    } else {
        $response_code = $req->getResponseCode();

        if ($response_code == 0) {
            echo "Connection refused\n";
        } elseif ($response_code != 200) {
            echo "Unexpected response: $response_code\n";
        } else {
            echo "Success: $response_code\n";
            $buf = $req->getInputBuffer();
            echo "Body:\n";
            while ($s = $buf->readLine(EventBuffer::EOL_ANY)) {
                echo $s, PHP_EOL;
            }
        }
    }

    $base->exit(NULL);
}

$address = "127.0.0.1";
$port = 80;

$base = new EventBase();
$conn = new EventHttpConnection($base, NULL, $address, $port);
$conn->setTimeout(5);
$req = new EventHttpRequest("_request_handler", $base);

$req->addHeader("Host", $address, EventHttpRequest::OUTPUT_HEADER);
$req->addHeader("Content-Length", "0", EventHttpRequest::OUTPUT_HEADER);
$conn->makeRequest($req, EventHttpRequest::CMD_GET, "/index.cphp");

$base->loop();
?>

Ayrıca Bakınız

  • EventHttpRequest::cancel() - Cancels a pending HTTP request
  • EventHttpRequest::addHeader() - Adds an HTTP header to the headers of the request
EventHttpRequest::closeConnection
EventHttpRequest::findHeader
EventHttpRequest


Finds the value belonging a header

EventHttpRequest::__construct
EventHttpRequest::free
EventHttpRequest
PHP Manual

EventHttpRequest::findHeader

(PECL event >= 1.4.0-beta)

EventHttpRequest::findHeader — Finds the value belonging a header

Açıklama

public void EventHttpRequest::findHeader ( string $key , string $type )

Finds the value belonging a header.

Değiştirgeler

key

The header name.

type

One of EventHttpRequest::*_HEADER constants .

Dönen Değerler

Returns NULL if header not found.

Ayrıca Bakınız

  • EventHttpRequest::addHeader() - Adds an HTTP header to the headers of the request
EventHttpRequest::__construct
EventHttpRequest::free
EventHttpRequest


Frees the object and removes associated events

EventHttpRequest::findHeader
EventHttpRequest::getBufferEvent
EventHttpRequest
PHP Manual

EventHttpRequest::free

(PECL event >= 1.4.0-beta)

EventHttpRequest::free — Frees the object and removes associated events

Açıklama

public void EventHttpRequest::free ( void )

Frees the object and removes associated events.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

EventHttpRequest::findHeader
EventHttpRequest::getBufferEvent
EventHttpRequest


Returns EventBufferEvent object

EventHttpRequest::free
EventHttpRequest::getCommand
EventHttpRequest
PHP Manual

EventHttpRequest::getBufferEvent

(PECL event >= 1.8.0)

EventHttpRequest::getBufferEvent — Returns EventBufferEvent object

Açıklama

public EventBufferEvent EventHttpRequest::closeConnection ( void )

Returns EventBufferEvent object which represents buffer event that the connection is using.

Uyarı

The reference counter of the returned object will be incremented by one to protect internal structures against premature destruction when the method is called from a user callback. So the EventBufferEvent object should be freed explicitly with EventBufferEvent::free() method. Otherwise memory will leak.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns EventBufferEvent object.

Ayrıca Bakınız

  • EventHttpRequest::getConnection() - Returns EventHttpConnection object
EventHttpRequest::free
EventHttpRequest::getCommand
EventHttpRequest


Returns the request command(method)

EventHttpRequest::getBufferEvent
EventHttpRequest::getConnection
EventHttpRequest
PHP Manual

EventHttpRequest::getCommand

(PECL event >= 1.4.0-beta)

EventHttpRequest::getCommand — Returns the request command(method)

Açıklama

public void EventHttpRequest::getCommand ( void )

Returns the request command, one of EventHttpRequest::CMD_* constants.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the request command, one of EventHttpRequest::CMD_* constants.

EventHttpRequest::getBufferEvent
EventHttpRequest::getConnection
EventHttpRequest


Returns EventHttpConnection object

EventHttpRequest::getCommand
EventHttpRequest::getHost
EventHttpRequest
PHP Manual

EventHttpRequest::getConnection

(PECL event >= 1.8.0)

EventHttpRequest::getConnection — Returns EventHttpConnection object

Açıklama

public EventHttpConnection EventHttpRequest::closeConnection ( void )

Returns EventHttpConnection object which represents HTTP connection associated with the request.

Uyarı

Libevent API allows HTTP request objects to be not bound to any HTTP connection. Therefore we can't unambiguously associate EventHttpRequest with EventHttpConnection . Thus, we construct EventHttpConnection object on-the-fly. Having no information about the event base, DNS base and connection-close callback, we just leave these fields unset.

EventHttpRequest::getConnection() method is usually useful when we need to set up a callback on connection close. See EventHttpConnection::setCloseCallback() .

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns EventHttpConnection object.

Ayrıca Bakınız

  • EventHttpConnection::setCloseCallback() - Set callback for connection close
  • EventHttpRequest::getBufferEvent() - Returns EventBufferEvent object
EventHttpRequest::getCommand
EventHttpRequest::getHost
EventHttpRequest


Returns the request host

EventHttpRequest::getConnection
EventHttpRequest::getInputBuffer
EventHttpRequest
PHP Manual

EventHttpRequest::getHost

(PECL event >= 1.4.0-beta)

EventHttpRequest::getHost — Returns the request host

Açıklama

public string EventHttpRequest::getHost ( void )

Returns the request host.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the request host.

Ayrıca Bakınız

  • EventHttpRequest::getUri() - Returns the request URI
  • EventHttpRequest::getCommand() - Returns the request command(method)
EventHttpRequest::getConnection
EventHttpRequest::getInputBuffer
EventHttpRequest


Returns the input buffer

EventHttpRequest::getHost
EventHttpRequest::getInputHeaders
EventHttpRequest
PHP Manual

EventHttpRequest::getInputBuffer

(PECL event >= 1.4.0-beta)

EventHttpRequest::getInputBuffer — Returns the input buffer

Açıklama

public EventBuffer EventHttpRequest::getInputBuffer ( void )

Returns the input buffer.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the input buffer.

Ayrıca Bakınız

  • EventHttpRequest::getOutputBuffer() - Returns the output buffer of the request
EventHttpRequest::getHost
EventHttpRequest::getInputHeaders
EventHttpRequest


Returns associative array of the input headers

EventHttpRequest::getInputBuffer
EventHttpRequest::getOutputBuffer
EventHttpRequest
PHP Manual

EventHttpRequest::getInputHeaders

(PECL event >= 1.4.0-beta)

EventHttpRequest::getInputHeaders — Returns associative array of the input headers

Açıklama

public array EventHttpRequest::getInputHeaders ( void )

Returns associative array of the input headers.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns associative array of the input headers.

Ayrıca Bakınız

  • EventHttpRequest::getOutputHeaders() - Returns associative array of the output headers
EventHttpRequest::getInputBuffer
EventHttpRequest::getOutputBuffer
EventHttpRequest


Returns the output buffer of the request

EventHttpRequest::getInputHeaders
EventHttpRequest::getOutputHeaders
EventHttpRequest
PHP Manual

EventHttpRequest::getOutputBuffer

(PECL event >= 1.4.0-beta)

EventHttpRequest::getOutputBuffer — Returns the output buffer of the request

Açıklama

public EventBuffer EventHttpRequest::getOutputBuffer ( void )

Returns the output buffer of the request.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the output buffer of the request.

Ayrıca Bakınız

  • EventHttpRequest::getInputBuffer() - Returns the input buffer
EventHttpRequest::getInputHeaders
EventHttpRequest::getOutputHeaders
EventHttpRequest


Returns associative array of the output headers

EventHttpRequest::getOutputBuffer
EventHttpRequest::getResponseCode
EventHttpRequest
PHP Manual

EventHttpRequest::getOutputHeaders

(PECL event >= 1.4.0-beta)

EventHttpRequest::getOutputHeaders — Returns associative array of the output headers

Açıklama

public void EventHttpRequest::getOutputHeaders ( void )

Returns associative array of the output headers.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Ayrıca Bakınız

  • EventHttpRequest::getInputHeaders() - Returns associative array of the input headers
EventHttpRequest::getOutputBuffer
EventHttpRequest::getResponseCode
EventHttpRequest


Returns the response code

EventHttpRequest::getOutputHeaders
EventHttpRequest::getUri
EventHttpRequest
PHP Manual

EventHttpRequest::getResponseCode

(PECL event >= 1.4.0-beta)

EventHttpRequest::getResponseCode — Returns the response code

Açıklama

public int EventHttpRequest::getResponseCode ( void )

Returns the response code.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the response code of the request.

Ayrıca Bakınız

  • EventHttpRequest::getCommand() - Returns the request command(method)
  • EventHttpRequest::getHost() - Returns the request host
  • EventHttpRequest::getUri() - Returns the request URI
EventHttpRequest::getOutputHeaders
EventHttpRequest::getUri
EventHttpRequest


Returns the request URI

EventHttpRequest::getResponseCode
EventHttpRequest::removeHeader
EventHttpRequest
PHP Manual

EventHttpRequest::getUri

(PECL event >= 1.4.0-beta)

EventHttpRequest::getUri — Returns the request URI

Açıklama

public string EventHttpRequest::getUri ( void )

Returns the request URI

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the request URI

Ayrıca Bakınız

  • EventHttpRequest::getCommand() - Returns the request command(method)
  • EventHttpRequest::getHost() - Returns the request host
  • EventHttpRequest::getResponseCode() - Returns the response code
EventHttpRequest::getResponseCode
EventHttpRequest::removeHeader
EventHttpRequest


Removes an HTTP header from the headers of the request

EventHttpRequest::getUri
EventHttpRequest::sendError
EventHttpRequest
PHP Manual

EventHttpRequest::removeHeader

(PECL event >= 1.4.0-beta)

EventHttpRequest::removeHeader — Removes an HTTP header from the headers of the request

Açıklama

public void EventHttpRequest::removeHeader ( string $key , string $type )

Removes an HTTP header from the headers of the request.

Değiştirgeler

key

The header name.

type

type is one of EventHttpRequest::*_HEADER constants.

Dönen Değerler

Removes an HTTP header from the headers of the request.

Ayrıca Bakınız

  • EventHttpRequest::addHeader() - Adds an HTTP header to the headers of the request
EventHttpRequest::getUri
EventHttpRequest::sendError
EventHttpRequest


Send an HTML error message to the client

EventHttpRequest::removeHeader
EventHttpRequest::sendReply
EventHttpRequest
PHP Manual

EventHttpRequest::sendError

(PECL event >= 1.4.0-beta)

EventHttpRequest::sendError — Send an HTML error message to the client

Açıklama

public void EventHttpRequest::sendError ( int $error [, string $reason = NULL ] )

Send an HTML error message to the client.

Değiştirgeler

error

The HTTP error code.

reason

A brief explanation ofthe error. If NULL, the standard meaning of the error code will be used.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 EventHttpRequest::sendError() example

<?php
function _http_400($req) {
    $req->sendError(400);
}

$base = new EventBase();
$http = new EventHttp($base);

$http->setCallback("/err400", "_http_400");

$http->bind("0.0.0.0", 8010);
$base->loop();
?>

Ayrıca Bakınız

  • EventHttpRequest::sendReply() - Send an HTML reply to the client
EventHttpRequest::removeHeader
EventHttpRequest::sendReply
EventHttpRequest


Send an HTML reply to the client

EventHttpRequest::sendError
EventHttpRequest::sendReplyChunk
EventHttpRequest
PHP Manual

EventHttpRequest::sendReply

(PECL event >= 1.4.0-beta)

EventHttpRequest::sendReply — Send an HTML reply to the client

Açıklama

public void EventHttpRequest::sendReply ( int $code , string $reason [, EventBuffer $buf ] )

Send an HTML reply to the client. The body of the reply consists of data in optional buf parameter.

Değiştirgeler

code

The HTTP response code to send.

reason

A brief message to send with the response code.

buf

The body of the response.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • EventHttpRequest::sendError() - Send an HTML error message to the client
  • EventHttpRequest::sendReplyChunk() - Send another data chunk as part of an ongoing chunked reply
EventHttpRequest::sendError
EventHttpRequest::sendReplyChunk
EventHttpRequest


Send another data chunk as part of an ongoing chunked reply

EventHttpRequest::sendReply
EventHttpRequest::sendReplyEnd
EventHttpRequest
PHP Manual

EventHttpRequest::sendReplyChunk

(PECL event >= 1.4.0-beta)

EventHttpRequest::sendReplyChunk — Send another data chunk as part of an ongoing chunked reply

Açıklama

public void EventHttpRequest::sendReplyChunk ( EventBuffer $buf )

Send another data chunk as part of an ongoing chunked reply. After calling this method buf will be empty.

Değiştirgeler

buf

The data chunk to send as part of the reply.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • EventHttpRequest::sendReplyStart() - Initiate a chunked reply
  • EventHttpRequest::sendReplyEnd() - Complete a chunked reply, freeing the request as appropriate
EventHttpRequest::sendReply
EventHttpRequest::sendReplyEnd
EventHttpRequest


Complete a chunked reply, freeing the request as appropriate

EventHttpRequest::sendReplyChunk
EventHttpRequest::sendReplyStart
EventHttpRequest
PHP Manual

EventHttpRequest::sendReplyEnd

(PECL event >= 1.4.0-beta)

EventHttpRequest::sendReplyEnd — Complete a chunked reply, freeing the request as appropriate

Açıklama

public void EventHttpRequest::sendReplyEnd ( void )

Complete a chunked reply, freeing the request as appropriate.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • EventHttpRequest::sendReplyStart() - Initiate a chunked reply
  • EventHttpRequest::sendReplyChunk() - Send another data chunk as part of an ongoing chunked reply
EventHttpRequest::sendReplyChunk
EventHttpRequest::sendReplyStart
EventHttpRequest


Initiate a chunked reply

EventHttpRequest::sendReplyEnd
EventListener
EventHttpRequest
PHP Manual

EventHttpRequest::sendReplyStart

(PECL event >= 1.4.0-beta)

EventHttpRequest::sendReplyStart — Initiate a chunked reply

Açıklama

public void EventHttpRequest::sendReplyStart ( int $code , string $reason )

Initiate a reply that uses Transfer-Encoding chunked .

This allows the caller to stream the reply back to the client and is useful when either not all of the reply data is immediately available or when sending very large replies.

The caller needs to supply data chunks with EventHttpRequest::sendReplyChunk() and complete the reply by calling EventHttpRequest::sendReplyEnd() .

Değiştirgeler

code

The HTTP response code to send.

reason

A brief message to send with the response code.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • EventHttpRequest::sendReplyChunk() - Send another data chunk as part of an ongoing chunked reply
  • EventHttpRequest::sendReplyEnd() - Complete a chunked reply, freeing the request as appropriate
EventHttpRequest::sendReplyEnd
EventListener
EventHttpRequest


The EventListener class

(PECL event >= 1.5.0)

Giriş

Represents a connection listener.

Sınıf Sözdizimi

final EventListener {
/* Constants */
const integer OPT_LEAVE_SOCKETS_BLOCKING = 1 ;
const integer OPT_CLOSE_ON_FREE = 2 ;
const integer OPT_CLOSE_ON_EXEC = 4 ;
const integer OPT_REUSEABLE = 8 ;
const integer OPT_THREADSAFE = 16 ;
/* Özellikler */
public readonly int $fd ;
/* Yöntemler */
public __construct ( EventBase $base , callable $cb , mixed $data , int $flags , int $backlog , mixed $target )
public bool disable ( void )
public bool enable ( void )
public void getBase ( void )
public static bool getSocketName ( string &$address [, mixed &$port ] )
public void setCallback ( callable $cb [, mixed $arg = NULL ] )
public void setErrorCallback ( string $cb )
}

Özellikler

fd

Numeric file descriptor of the underlying socket. (Added in event-1.6.0 .)

Öntanımlı Sabitler

EventListener::OPT_LEAVE_SOCKETS_BLOCKING

By default Libevent turns underlying file descriptors, or sockets, to non-blocking mode. This flag tells to leave them non-blocking.

EventListener::OPT_CLOSE_ON_FREE

If this option is set, the connection listener closes its underlying socket when the EventListener object is freed.

EventListener::OPT_CLOSE_ON_EXEC

If this option is set, the connection listener sets the close-on-exec flag on the underlying listener socket. See platform documentation for fcntl and FD_CLOEXEC for more information.

EventListener::OPT_REUSEABLE

By default on some platforms, once a listener socket is closed, no other socket can bind to the same port until a while has passed. Setting this option makes Libevent mark the socket as reusable, so that once it is closed, another socket can be opened to listen on the same port.

EventListener::OPT_THREADSAFE

Allocate locks for the listener, so that it's safe to use it from multiple threads.

İçindekiler

  • EventListener::__construct — Creates new connection listener associated with an event base
  • EventListener::disable — Disables an event connect listener object
  • EventListener::enable — Enables an event connect listener object
  • EventListener::getBase — Returns event base associated with the event listener
  • EventListener::getSocketName — Retreives the current address to which the listener's socket is bound.
  • EventListener::setCallback — The setCallback purpose
  • EventListener::setErrorCallback — Set event listener's error callback
EventHttpRequest::sendReplyStart
EventListener::__construct
Event


Creates new connection listener associated with an event base

EventListener
EventListener::disable
EventListener
PHP Manual

EventListener::__construct

(PECL event >= 1.2.6-beta)

EventListener::__construct — Creates new connection listener associated with an event base

Açıklama

public EventListener::__construct ( EventBase $base , callable $cb , mixed $data , int $flags , int $backlog , mixed $target )

Creates new connection listener associated with an event base.

Değiştirgeler

base

Associated event base.

cb

A callable that will be invoked when new connection received.

data

Custom user data attached to cb .

flags

Bit mask of EventListener::OPT_* constants. See EventListener constants .

backlog

Controls the maximum number of pending connections that the network stack should allow to wait in a not-yet-accepted state at any time; see documentation for your system's listen function for more details. If backlog is negative, Libevent tries to pick a good value for the backlog ; if it is zero, Event assumes that listen is already called on the socket( target )

target

May be string, socket resource, or a stream associated with a socket. In case if target is a string, the string will be parsed as network address. It will be interpreted as a UNIX domain socket path, if prefixed with 'unix:' , e.g. 'unix:/tmp/my.sock' .

Dönen Değerler

Returns EventListener object representing the event connection listener.

Sürüm Bilgisi

Sürüm: | Açıklama
1.5.0 | UNIX domain sockets' support added.

Örnekler

Örnek 1 EventListener::__construct() example

<?php
/*
 * Simple echo server based on libevent's connection listener.
 *
 * Usage:
 * 1) In one terminal window run:
 *
 * $ php listener.php 9881
 *
 * 2) In another terminal window open up connection, e.g.:
 *
 * $ nc 127.0.0.1 9881
 *
 * 3) start typing. The server should repeat the input.
 */

class MyListenerConnection {
    private $bev, $base;

    public function __destruct() {
        $this->bev->free();
    }

    public function __construct($base, $fd) {
        $this->base = $base;

        $this->bev = new EventBufferEvent($base, $fd, EventBufferEvent::OPT_CLOSE_ON_FREE);

        $this->bev->setCallbacks(array($this, "echoReadCallback"), NULL,
            array($this, "echoEventCallback"), NULL);

        if (!$this->bev->enable(Event::READ)) {
            echo "Failed to enable READ\n";
            return;
        }
    }

    public function echoReadCallback($bev, $ctx) {
        // Copy all the data from the input buffer to the output buffer

        // Variant #1
        $bev->output->addBuffer($bev->input);

        /* Variant #2 */
        /*
        $input    = $bev->getInput();
        $output = $bev->getOutput();
        $output->addBuffer($input);
        */
    }

    public function echoEventCallback($bev, $events, $ctx) {
        if ($events & EventBufferEvent::ERROR) {
            echo "Error from bufferevent\n";
        }

        if ($events & (EventBufferEvent::EOF | EventBufferEvent::ERROR)) {
            //$bev->free();
            $this->__destruct();
        }
    }
}

class MyListener {
    public $base,
        $listener,
        $socket;
    private $conn = array();

    public function __destruct() {
        foreach ($this->conn as &$c) $c = NULL;
    }

    public function __construct($port) {
        $this->base = new EventBase();
        if (!$this->base) {
            echo "Couldn't open event base";
            exit(1);
        }

        // Variant #1
        /*
        $this->socket = socket_create(AF_INET, SOCK_STREAM, SOL_TCP);
        if (!socket_bind($this->socket, '0.0.0.0', $port)) {
            echo "Unable to bind socket\n";
            exit(1);
        }
        $this->listener = new EventListener($this->base,
            array($this, "acceptConnCallback"), $this->base,
            EventListener::OPT_CLOSE_ON_FREE | EventListener::OPT_REUSEABLE,
            -1, $this->socket);
         */

        // Variant #2
         $this->listener = new EventListener($this->base,
             array($this, "acceptConnCallback"), $this->base,
             EventListener::OPT_CLOSE_ON_FREE | EventListener::OPT_REUSEABLE, -1,
             "0.0.0.0:$port");

        if (!$this->listener) {
            echo "Couldn't create listener";
            exit(1);
        }

        $this->listener->setErrorCallback(array($this, "accept_error_cb"));
    }

    public function dispatch() {
        $this->base->dispatch();
    }

    // This callback is invoked when there is data to read on $bev
    public function acceptConnCallback($listener, $fd, $address, $ctx) {
        // We got a new connection! Set up a bufferevent for it. */
        $base = $this->base;
        $this->conn[] = new MyListenerConnection($base, $fd);
    }

    public function accept_error_cb($listener, $ctx) {
        $base = $this->base;

        fprintf(STDERR, "Got an error %d (%s) on the listener. "
            ."Shutting down.\n",
            EventUtil::getLastSocketErrno(),
            EventUtil::getLastSocketError());

        $base->exit(NULL);
    }
}

$port = 9808;

if ($argc > 1) {
    $port = (int) $argv[1];
}
if ($port <= 0 || $port > 65535) {
    exit("Invalid port");
}

$l = new MyListener($port);
$l->dispatch();
?>
EventListener
EventListener::disable
EventListener


Disables an event connect listener object

EventListener::__construct
EventListener::enable
EventListener
PHP Manual

EventListener::disable

(PECL event >= 1.2.6-beta)

EventListener::disable — Disables an event connect listener object

Açıklama

public bool EventListener::disable ( void )

Disables an event connect listener object

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

Ayrıca Bakınız

  • EventListener::enable() - Enables an event connect listener object
EventListener::__construct
EventListener::enable
EventListener


Enables an event connect listener object

EventListener::disable
EventListener::getBase
EventListener
PHP Manual

EventListener::enable

(PECL event >= 1.2.6-beta)

EventListener::enable — Enables an event connect listener object

Açıklama

public bool EventListener::enable ( void )

Enables an event connect listener object

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

Ayrıca Bakınız

  • EventListener::disable() - Disables an event connect listener object
EventListener::disable
EventListener::getBase
EventListener


Returns event base associated with the event listener

EventListener::enable
EventListener::getSocketName
EventListener
PHP Manual

EventListener::getBase

(PECL event >= 1.2.6-beta)

EventListener::getBase — Returns event base associated with the event listener

Açıklama

public void EventListener::getBase ( void )

Returns event base associated with the event listener.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns event base associated with the event listener.

EventListener::enable
EventListener::getSocketName
EventListener


Retreives the current address to which the listener's socket is bound.

EventListener::getBase
EventListener::setCallback
EventListener
PHP Manual

EventListener::getSocketName

(PECL event >= 1.5.0)

EventListener::getSocketName — Retreives the current address to which the listener's socket is bound.

Açıklama

public static bool EventListener::getSocketName ( string &$address [, mixed &$port ] )

Retreives the current address to which the listener's socket is bound.

Değiştirgeler

address

Output parameter. IP-address depending on the socket address family.

port

Output parameter. The port the socket is bound to.

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

EventListener::getBase
EventListener::setCallback
EventListener


The setCallback purpose

EventListener::getSocketName
EventListener::setErrorCallback
EventListener
PHP Manual

EventListener::setCallback

(PECL event >= 1.2.6-beta)

EventListener::setCallback — The setCallback purpose

Açıklama

public void EventListener::setCallback ( callable $cb [, mixed $arg = NULL ] )

Adjust event connect listener's callback and optionally the callback argument.

Değiştirgeler

cb

The new callback for new connections. Ignored if NULL.

Should match the following prototype:

void callback ([ EventListener $listener = NULL [, mixed $fd = NULL [, array $address = NULL [, mixed $arg = NULL ]]]] )

listener

The EventListener object.

fd

The file descriptor or a resource associated with the listener.

address

Array of two elements: IP address and the server port.

arg

User custom data attached to the callback.

arg

Custom user data attached to the callback. Ignored if NULL.

Dönen Değerler

Hiçbir değer dönmez.

EventListener::getSocketName
EventListener::setErrorCallback
EventListener


Set event listener's error callback

EventListener::setCallback
EventSslContext
EventListener
PHP Manual

EventListener::setErrorCallback

(PECL event >= 1.2.6-beta)

EventListener::setErrorCallback — Set event listener's error callback

Açıklama

public void EventListener::setErrorCallback ( string $cb )

Set event listener's error callback

Değiştirgeler

cb

The error callback. Should match the following prototype:

void callback ([ EventListener $listener = NULL [, mixed $data = NULL ]] )

listener

The EventListener object.

data

User custom data attached to the callback.

Dönen Değerler

Ayrıca Bakınız

  • EventListener::setCallback() - The setCallback purpose
EventListener::setCallback
EventSslContext
EventListener


The EventSslContext class

(PECL event >= 1.2.6-beta)

Giriş

Represents SSL_CTX structure. Provides methods and properties to configure the SSL context.

Sınıf Sözdizimi

final EventSslContext {
/* Constants */
const integer SSLv2_CLIENT_METHOD = 1 ;
const integer SSLv3_CLIENT_METHOD = 2 ;
const integer SSLv23_CLIENT_METHOD = 3 ;
const integer TLS_CLIENT_METHOD = 4 ;
const integer SSLv2_SERVER_METHOD = 5 ;
const integer SSLv3_SERVER_METHOD = 6 ;
const integer SSLv23_SERVER_METHOD = 7 ;
const integer TLS_SERVER_METHOD = 8 ;
const integer OPT_LOCAL_CERT = 1 ;
const integer OPT_LOCAL_PK = 2 ;
const integer OPT_PASSPHRASE = 3 ;
const integer OPT_CA_FILE = 4 ;
const integer OPT_CA_PATH = 5 ;
const integer OPT_ALLOW_SELF_SIGNED = 6 ;
const integer OPT_VERIFY_PEER = 7 ;
const integer OPT_VERIFY_DEPTH = 8 ;
const integer OPT_CIPHERS = 9 ;
/* Özellikler */
public string $local_cert ;
public string $local_pk ;
/* Yöntemler */
public __construct ( string $method , string $options )
}

Özellikler

local_cert

Path to local certificate file on filesystem. It must be a PEM-encoded file which contains certificate. It can optionally contain the certificate chain of issuers.

local_pk

Path to local private key file

Öntanımlı Sabitler

EventSslContext::SSLv2_CLIENT_METHOD

SSLv2 client method. See SSL_CTX_new(3) man page.

EventSslContext::SSLv3_CLIENT_METHOD

SSLv3 client method. See SSL_CTX_new(3) man page.

EventSslContext::SSLv23_CLIENT_METHOD

SSLv23 client method. See SSL_CTX_new(3) man page.

EventSslContext::TLS_CLIENT_METHOD

TLS client method. See SSL_CTX_new(3) man page.

EventSslContext::SSLv2_SERVER_METHOD

SSLv2 server method. See SSL_CTX_new(3) man page.

EventSslContext::SSLv3_SERVER_METHOD

SSLv3 server method. See SSL_CTX_new(3) man page.

EventSslContext::SSLv23_SERVER_METHOD

SSLv23 server method. See SSL_CTX_new(3) man page.

EventSslContext::TLS_SERVER_METHOD

TLS server method. See SSL_CTX_new(3) man page.

EventSslContext::OPT_LOCAL_CERT

Key for an item of the options' array used in EventSslContext::__construct() . The option points to path of local certificate.

EventSslContext::OPT_LOCAL_PK

Key for an item of the options' array used in EventSslContext::__construct() . The option points to path of the private key.

EventSslContext::OPT_PASSPHRASE

Key for an item of the options' array used in EventSslContext::__construct() . Represents passphrase of the certificate.

EventSslContext::OPT_CA_FILE

Key for an item of the options' array used in EventSslContext::__construct() . Represents path of the certificate authority file.

EventSslContext::OPT_CA_PATH

Key for an item of the options' array used in EventSslContext::__construct() . Represents path where the certificate authority file should be searched for.

EventSslContext::OPT_ALLOW_SELF_SIGNED

Key for an item of the options' array used in EventSslContext::__construct() . Represents option that allows self-signed certificates.

EventSslContext::OPT_VERIFY_PEER

Key for an item of the options' array used in EventSslContext::__construct() . Represents option that tells Event to verify peer.

EventSslContext::OPT_VERIFY_DEPTH

Key for an item of the options' array used in EventSslContext::__construct() . Represents maximum depth for the certificate chain verification that shall be allowed for the SSL context.

EventSslContext::OPT_CIPHERS

Key for an item of the options' array used in EventSslContext::__construct() . Represents the cipher list for the SSL context.

İçindekiler

  • EventSslContext::__construct — Constructs an OpenSSL context for use with Event classes
EventListener::setErrorCallback
EventSslContext::__construct
Event


Constructs an OpenSSL context for use with Event classes

EventSslContext
EventUtil
EventSslContext
PHP Manual

EventSslContext::__construct

(PECL event >= 1.2.6-beta)

EventSslContext::__construct — Constructs an OpenSSL context for use with Event classes

Açıklama

public EventSslContext::__construct ( string $method , string $options )

Creates SSL context holding pointer to SSL_CTX (see the system manual).

Değiştirgeler

method

One of EventSslContext::*_METHOD constants .

options

Associative array of SSL context options One of EventSslContext::OPT_* constants .

Dönen Değerler

Returns EventSslContext object.

Örnekler

Örnek 1 EventSslContext::__construct() example

<?php
$ctx = new EventSslContext(EventSslContext::SSLv3_SERVER_METHOD, array(
     EventSslContext::OPT_LOCAL_CERT        => $local_cert,
     EventSslContext::OPT_LOCAL_PK          => $local_pk,
     EventSslContext::OPT_PASSPHRASE        => "echo server",
     EventSslContext::OPT_VERIFY_PEER       => true,
     EventSslContext::OPT_ALLOW_SELF_SIGNED => false,
));
?>
EventSslContext
EventUtil
EventSslContext


The EventUtil class

(PECL event >= 1.5.0)

Giriş

EventUtil is a singleton with supplimentary methods and constants.

Sınıf Sözdizimi

final EventUtil {
/* Constants */
const integer AF_INET = 2 ;
const integer AF_INET6 = 10 ;
const integer AF_UNSPEC = 0 ;
const integer LIBEVENT_VERSION_NUMBER = 33559808 ;
const integer SO_DEBUG = 1 ;
const integer SO_REUSEADDR = 2 ;
const integer SO_KEEPALIVE = 9 ;
const integer SO_DONTROUTE = 5 ;
const integer SO_LINGER = 13 ;
const integer SO_BROADCAST = 6 ;
const integer SO_OOBINLINE = 10 ;
const integer SO_SNDBUF = 7 ;
const integer SO_RCVBUF = 8 ;
const integer SO_SNDLOWAT = 19 ;
const integer SO_RCVLOWAT = 18 ;
const integer SO_SNDTIMEO = 21 ;
const integer SO_RCVTIMEO = 20 ;
const integer SO_TYPE = 3 ;
const integer SO_ERROR = 4 ;
const integer SOL_SOCKET = 1 ;
const integer SOL_TCP = 6 ;
const integer SOL_UDP = 17 ;
const integer IPPROTO_IP = 0 ;
const integer IPPROTO_IPV6 = 41 ;
/* Yöntemler */
abstract public __construct ( void )
public static int getLastSocketErrno ([ mixed $socket = NULL ] )
public static string getLastSocketError ([ mixed $socket ] )
public static int getSocketFd ( mixed $socket )
public static bool getSocketName ( mixed $socket , string &$address [, mixed &$port ] )
public static bool setSocketOption ( mixed $socket , int $level , int $optname , mixed $optval )
public static void sslRandPoll ( void )
}

Öntanımlı Sabitler

EventUtil::AF_INET

IPv4 address family

EventUtil::AF_INET6

IPv6 address family

EventUtil::AF_UNSPEC

Unspecified IP address family

EventUtil::SO_DEBUG

Socket option. Enable socket debugging. Only allowed for processes with the CAP_NET_ADMIN capability or an effective user ID of 0 . (Added in event-1.6.0.)

EventUtil::SO_REUSEADDR

Socket option. Indicates that the rules used in validating addresses supplied in a bind(2) call should allow reuse of local addresses. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SO_KEEPALIVE

Socket option. Enable sending of keep-alive messages on connection-oriented sockets. Expects an integer boolean flag. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SO_DONTROUTE

Socket option. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SO_LINGER

Socket option. When enabled, a close(2) or shutdown(2) will not return until all queued messages for the socket have been successfully sent or the linger timeout has been reached. Otherwise, the call returns immediately and the closing is done in the background. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SO_BROADCAST

Socket option. Reports whether transmission of broadcast messages is supported. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SO_OOBINLINE

Socket option. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SO_SNDBUF

Socket option. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SO_RCVBUF

Socket option. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SO_SNDLOWAT

Socket option. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SO_RCVLOWAT

Socket option. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SO_SNDTIMEO

Socket option. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SO_RCVTIMEO

Socket option. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SO_TYPE

Socket option. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SO_ERROR

Socket option. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SOL_SOCKET

Socket option level. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SOL_TCP

Socket option level. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::SOL_UDP

Socket option level. See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::IPPROTO_IP

See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::IPPROTO_IPV6

See the socket(7) manual page. (Added in event-1.6.0.)

EventUtil::LIBEVENT_VERSION_NUMBER

Libevent' version number at the time when Event extension had been compiled with the library.

İçindekiler

  • EventUtil::__construct — The abstract constructor
  • EventUtil::getLastSocketErrno — Returns the most recent socket error number
  • EventUtil::getLastSocketError — Returns the most recent socket error
  • EventUtil::getSocketFd — Returns numeric file descriptor of a socket, or stream
  • EventUtil::getSocketName — Retreives the current address to which the socket is bound.
  • EventUtil::setSocketOption — Sets socket options
  • EventUtil::sslRandPoll — Generates entropy by means of OpenSSL's RAND_poll()
EventSslContext::__construct
EventUtil::__construct
Event


The abstract constructor

EventUtil
EventUtil::getLastSocketErrno
EventUtil
PHP Manual

EventUtil::__construct

(PECL event >= 1.2.6-beta)

EventUtil::__construct — The abstract constructor

Açıklama

abstract public EventUtil::__construct ( void )

EventUtil is a singleton. Therefore the constructor is abstract, and it is impossible to create objects based on this class.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

EventUtil
EventUtil::getLastSocketErrno
EventUtil


Returns the most recent socket error number

EventUtil::__construct
EventUtil::getLastSocketError
EventUtil
PHP Manual

EventUtil::getLastSocketErrno

(PECL event >= 1.2.6-beta)

EventUtil::getLastSocketErrno — Returns the most recent socket error number

Açıklama

public static int EventUtil::getLastSocketErrno ([ mixed $socket = NULL ] )

Returns the most recent socket error number( errno ).

Değiştirgeler

socket

Socket resource, stream or a file descriptor of a socket.

Dönen Değerler

Returns the most recent socket error number( errno ).

Ayrıca Bakınız

  • EventUtil::getLastSocketError() - Returns the most recent socket error
EventUtil::__construct
EventUtil::getLastSocketError
EventUtil


Returns the most recent socket error

EventUtil::getLastSocketErrno
EventUtil::getSocketFd
EventUtil
PHP Manual

EventUtil::getLastSocketError

(PECL event >= 1.2.6-beta)

EventUtil::getLastSocketError — Returns the most recent socket error

Açıklama

public static string EventUtil::getLastSocketError ([ mixed $socket ] )

Returns the most recent socket error.

Değiştirgeler

socket

Socket resource, stream or a file descriptor of a socket.

Dönen Değerler

Returns the most recent socket error.

Ayrıca Bakınız

  • EventUtil::getLastSocketErrno() - Returns the most recent socket error number
EventUtil::getLastSocketErrno
EventUtil::getSocketFd
EventUtil


Returns numeric file descriptor of a socket, or stream

EventUtil::getLastSocketError
EventUtil::getSocketName
EventUtil
PHP Manual

EventUtil::getSocketFd

(PECL event >= 1.7.0)

EventUtil::getSocketFd — Returns numeric file descriptor of a socket, or stream

Açıklama

public static int EventUtil::getSocketFd ( mixed $socket )

Returns numeric file descriptor of a socket or stream specified by socket argument just like the Event extension does it internally for all methods accepting socket resource or stream.

Değiştirgeler

socket

Socket resource or stream.

Dönen Değerler

Returns TRUE on success. Otherwise FALSE. EventUtil::getSocketFd() returns FALSE in case if it is whether failed to recognize the type of the underlying file, or detected that the file descriptor associated with socket is not valid.

EventUtil::getLastSocketError
EventUtil::getSocketName
EventUtil


Retreives the current address to which the socket is bound.

EventUtil::getSocketFd
EventUtil::setSocketOption
EventUtil
PHP Manual

EventUtil::getSocketName

(PECL event >= 1.5.0)

EventUtil::getSocketName — Retreives the current address to which the socket is bound.

Açıklama

public static bool EventUtil::getSocketName ( mixed $socket , string &$address [, mixed &$port ] )

Retreives the current address to which the socket is bound.

Değiştirgeler

socket

Socket resource, stream or a file descriptor of a socket.

address

Output parameter. IP-address, or the UNIX domain socket path depending on the socket address family.

port

Output parameter. The port the socket is bound to. Has no meaning for UNIX domain sockets.

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

EventUtil::getSocketFd
EventUtil::setSocketOption
EventUtil


Sets socket options

EventUtil::getSocketName
EventUtil::sslRandPoll
EventUtil
PHP Manual

EventUtil::setSocketOption

(PECL event >= 1.6.0)

EventUtil::setSocketOption — Sets socket options

Açıklama

public static bool EventUtil::setSocketOption ( mixed $socket , int $level , int $optname , mixed $optval )

Sets socket options.

Değiştirgeler

socket

Socket resource, stream, or numeric file descriptor associated with the socket.

level

One of EventUtil::SOL_* constants. Specifies the protocol level at which the option resides. For example, to retrieve options at the socket level, a level parameter of EventUtil::SOL_SOCKET would be used. Other levels, such as TCP, can be used by specifying the protocol number of that level. Protocol numbers can be found by using the getprotobyname() function. See EventUtil constants .

optname

Option name(type). Has the same meaning as corresponding parameter of socket_get_option() function. See EventUtil constants .

optval

Accepts the same values as optval parameter of the socket_get_option() function.

Dönen Değerler

Returns TRUE on success. Otherwise FALSE.

Ayrıca Bakınız

  • socket_get_option() - Soketle ilgili bir seçeneğin değerini döndürür
  • socket_set_option() - Soketle ilgili seçenekleri belirler
EventUtil::getSocketName
EventUtil::sslRandPoll
EventUtil


Generates entropy by means of OpenSSL's RAND_poll()

EventUtil::setSocketOption
FAM
EventUtil
PHP Manual

EventUtil::sslRandPoll

(PECL event >= 1.2.6-beta)

EventUtil::sslRandPoll — Generates entropy by means of OpenSSL's RAND_poll()

Açıklama

public static void EventUtil::sslRandPoll ( void )

Generates entropy by means of OpenSSL's RAND_poll() (see the system manual).

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

EventUtil::setSocketOption
FAM
EventUtil


File Alteration Monitor

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • FAM İşlevleri
    • fam_cancel_monitor — Terminate monitoring
    • fam_close — Close FAM connection
    • fam_monitor_collection — Monitor a collection of files in a directory for changes
    • fam_monitor_directory — Monitor a directory for changes
    • fam_monitor_file — Monitor a regular file for changes
    • fam_next_event — Get next pending FAM event
    • fam_open — Open connection to FAM daemon
    • fam_pending — Check for pending FAM events
    • fam_resume_monitor — Resume suspended monitoring
    • fam_suspend_monitor — Temporarily suspend monitoring
EventUtil::sslRandPoll
Giriş
Diğer Hizmetler


Giriş

FAM monitors files and directories, notifying interested applications of changes. More information about FAM is available at » http://oss.sgi.com/projects/fam/.

A PHP script may specify a list of files for FAM to monitor using the functions provided by this extension.

The FAM process is started when the first connection from any application to it is opened. It exits after all connections to it have been closed.

Bilginize:

Bu eklenti » PECL deposuna taşınmış olup şu sürümden itibaren PHP kaynak paketinde dağıtılmamaktatır: PHP 5.1.0.

Bilginize: Bu eklenti Windows sistemlerinde çalışmaz.

FAM
Yapılandırma/Kurulum
FAM


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
FAM


Gereksinimler

This extension uses the functions of the » FAM library, developed by SGI. Therefore you have to download and install the FAM library.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu eklentinin geliştirmesi durmuştur. Ancak, kaynak kodunu PECL SVN deposunda bulabilirsiniz. Yeri: » http://svn.php.net/viewvc/pecl/fam.

Bu eklenti » PECL deposuna taşınmış olup şu sürümden itibaren PHP kaynak paketinde dağıtılmamaktatır: PHP 5.1.0

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Özkaynak Türleri

There are two resource types used in the FAM module. The first one is the connection to the FAM service returned by fam_open(), the second a monitoring resource returned by the fam_monitor_XXX functions.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

FAM event constants
Constant | Description
FAMChanged (integer) | Some value which can be obtained with fstat(1) changed for a file or directory.
FAMDeleted (integer) | A file or directory was deleted or renamed.
FAMStartExecuting (integer) | An executable file started executing.
FAMStopExecuting (integer) | An executable file that was running finished.
FAMCreated (integer) | A file was created in a directory.
FAMMoved (integer) | This event never occurs.
FAMAcknowledge (integer) | An event in response to fam_cancel_monitor().
FAMExists (integer) | An event upon request to monitor a file or directory. When a directory is monitored, an event for that directory and every file contained in that directory is issued.
FAMEndExist (integer) | Event after the last FAMEExists event.
Özkaynak Türleri
FAM İşlevleri
FAM


FAM İşlevleri

İçindekiler

  • fam_cancel_monitor — Terminate monitoring
  • fam_close — Close FAM connection
  • fam_monitor_collection — Monitor a collection of files in a directory for changes
  • fam_monitor_directory — Monitor a directory for changes
  • fam_monitor_file — Monitor a regular file for changes
  • fam_next_event — Get next pending FAM event
  • fam_open — Open connection to FAM daemon
  • fam_pending — Check for pending FAM events
  • fam_resume_monitor — Resume suspended monitoring
  • fam_suspend_monitor — Temporarily suspend monitoring
Öntanımlı Sabitler
fam_cancel_monitor
FAM


Terminate monitoring

FAM İşlevleri
fam_close
FAM İşlevleri
PHP Manual

fam_cancel_monitor

(PHP 5 <= 5.0.5)

fam_cancel_monitor — Terminate monitoring

Açıklama

bool fam_cancel_monitor ( resource $fam , resource $fam_monitor )

Terminates monitoring on a resource.

In addition an FAMAcknowledge event occurs.

Değiştirgeler

fam

A resource representing a connection to the FAM service returned by fam_open()

fam_monitor

A resource returned by one of the fam_monitor_XXX functions

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • fam_monitor_file() - Monitor a regular file for changes
  • fam_monitor_directory() - Monitor a directory for changes
  • fam_monitor_collection() - Monitor a collection of files in a directory for changes
  • fam_suspend_monitor() - Temporarily suspend monitoring

FAM İşlevleri
fam_close
FAM İşlevleri


Close FAM connection

fam_cancel_monitor
fam_monitor_collection
FAM İşlevleri
PHP Manual

fam_close

(PHP 5 <= 5.0.5)

fam_close — Close FAM connection

Açıklama

void fam_close ( resource $fam )

Closes a connection to the FAM service.

Değiştirgeler

fam

A resource representing a connection to the FAM service returned by fam_open()

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • fam_monitor_open()

fam_cancel_monitor
fam_monitor_collection
FAM İşlevleri


Monitor a collection of files in a directory for changes

fam_close
fam_monitor_directory
FAM İşlevleri
PHP Manual

fam_monitor_collection

(PHP 5 <= 5.0.5)

fam_monitor_collection — Monitor a collection of files in a directory for changes

Açıklama

resource fam_monitor_collection ( resource $fam , string $dirname , int $depth , string $mask )

Requests monitoring for a collection of files within a directory.

A FAM event will be generated whenever the status of the files change. The possible event codes are described in detail in the constants part of this section.

Değiştirgeler

fam

A resource representing a connection to the FAM service returned by fam_open()

dirname

Directory path to the monitored files

depth

The maximum search depth starting from this directory

mask

A shell pattern mask restricting the file names to look for

Dönen Değerler

Returns a monitoring resource or FALSE on errors.

Ayrıca Bakınız

  • fam_monitor_file() - Monitor a regular file for changes
  • fam_monitor_directory() - Monitor a directory for changes
  • fam_cancel_monitor() - Terminate monitoring
  • fam_suspend_monitor() - Temporarily suspend monitoring
  • fam_resume_monitor() - Resume suspended monitoring

fam_close
fam_monitor_directory
FAM İşlevleri


Monitor a directory for changes

fam_monitor_collection
fam_monitor_file
FAM İşlevleri
PHP Manual

fam_monitor_directory

(PHP 5 <= 5.0.5)

fam_monitor_directory — Monitor a directory for changes

Açıklama

resource fam_monitor_directory ( resource $fam , string $dirname )

Requests monitoring for a directory and all contained files.

A FAM event will be generated whenever the status of the directory (i.e. the result of function stat() on that directory) or its content (i.e. the results of readdir()) changes.

The possible event codes are described in detail in the constants part of this section.

Değiştirgeler

fam

A resource representing a connection to the FAM service returned by fam_open()

dirname

Path to the monitored directory

Dönen Değerler

Returns a monitoring resource or FALSE on errors.

Ayrıca Bakınız

  • fam_monitor_file() - Monitor a regular file for changes
  • fam_monitor_collection() - Monitor a collection of files in a directory for changes
  • fam_cancel_monitor() - Terminate monitoring
  • fam_suspend_monitor() - Temporarily suspend monitoring
  • fam_resume_monitor() - Resume suspended monitoring

fam_monitor_collection
fam_monitor_file
FAM İşlevleri


Monitor a regular file for changes

fam_monitor_directory
fam_next_event
FAM İşlevleri
PHP Manual

fam_monitor_file

(PHP 5 <= 5.0.5)

fam_monitor_file — Monitor a regular file for changes

Açıklama

resource fam_monitor_file ( resource $fam , string $filename )

Requests monitoring for a single file. A FAM event will be generated whenever the file status changes (i.e. the result of function stat() on that file).

The possible event codes are described in detail in the constants part of this section.

Değiştirgeler

fam

A resource representing a connection to the FAM service returned by fam_open()

filename

Path to the monitored file

Dönen Değerler

Returns a monitoring resource or FALSE on errors.

Ayrıca Bakınız

  • fam_monitor_directory() - Monitor a directory for changes
  • fam_monitor_collection() - Monitor a collection of files in a directory for changes
  • fam_cancel_monitor() - Terminate monitoring
  • fam_suspend_monitor() - Temporarily suspend monitoring
  • fam_resume_monitor() - Resume suspended monitoring

fam_monitor_directory
fam_next_event
FAM İşlevleri


Get next pending FAM event

fam_monitor_file
fam_open
FAM İşlevleri
PHP Manual

fam_next_event

(PHP 5 <= 5.0.5)

fam_next_event — Get next pending FAM event

Açıklama

array fam_next_event ( resource $fam )

Returns the next pending FAM event.

The function will block until an event is available which can be checked for using fam_pending().

Değiştirgeler

fam

A resource representing a connection to the FAM service returned by fam_open()

Dönen Değerler

Returns an array that contains a FAM event code in the 'code' element, the path of the file this event applies to in the 'filename' element and optionally a hostname in the 'hostname' element.

The possible event codes are described in detail in the constants part of this section.

Ayrıca Bakınız

  • fam_pending() - Check for pending FAM events

fam_monitor_file
fam_open
FAM İşlevleri


Open connection to FAM daemon

fam_next_event
fam_pending
FAM İşlevleri
PHP Manual

fam_open

(PHP 5 <= 5.0.5)

fam_open — Open connection to FAM daemon

Açıklama

resource fam_open ([ string $appname ] )

Opens a connection to the FAM service daemon.

Değiştirgeler

appname

A string identifying the application for logging reasons

Dönen Değerler

Returns a resource representing a connection to the FAM service on success or FALSE on errors.

Ayrıca Bakınız

  • fam_close() - Close FAM connection

fam_next_event
fam_pending
FAM İşlevleri


Check for pending FAM events

fam_open
fam_resume_monitor
FAM İşlevleri
PHP Manual

fam_pending

(PHP 5 <= 5.0.5)

fam_pending — Check for pending FAM events

Açıklama

int fam_pending ( resource $fam )

Checks for pending FAM events.

Değiştirgeler

fam

A resource representing a connection to the FAM service returned by fam_open()

Dönen Değerler

Returns non-zero if events are available to be fetched using fam_next_event(), zero otherwise.

Ayrıca Bakınız

  • fam_next_event() - Get next pending FAM event

fam_open
fam_resume_monitor
FAM İşlevleri


Resume suspended monitoring

fam_pending
fam_suspend_monitor
FAM İşlevleri
PHP Manual

fam_resume_monitor

(PHP 5 <= 5.0.5)

fam_resume_monitor — Resume suspended monitoring

Açıklama

bool fam_resume_monitor ( resource $fam , resource $fam_monitor )

Resumes monitoring of a resource previously suspended using fam_suspend_monitor().

Değiştirgeler

fam

A resource representing a connection to the FAM service returned by fam_open()

fam_monitor

A resource returned by one of the fam_monitor_XXX functions

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • fam_suspend_monitor() - Temporarily suspend monitoring

fam_pending
fam_suspend_monitor
FAM İşlevleri


Temporarily suspend monitoring

fam_resume_monitor
FTP
FAM İşlevleri
PHP Manual

fam_suspend_monitor

(PHP 5 <= 5.0.5)

fam_suspend_monitor — Temporarily suspend monitoring

Açıklama

bool fam_suspend_monitor ( resource $fam , resource $fam_monitor )

fam_suspend_monitor() temporarily suspend monitoring of a resource.

Monitoring can later be continued using fam_resume_monitor() without the need of requesting a complete new monitor.

Değiştirgeler

fam

A resource representing a connection to the FAM service returned by fam_open()

fam_monitor

A resource returned by one of the fam_monitor_XXX functions

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • fam_cancel_monitor() - Terminate monitoring
  • fam_resume_monitor() - Resume suspended monitoring

fam_resume_monitor
FTP
FAM İşlevleri


FTP

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
    • FTP örneği
  • FTP İşlevleri
    • ftp_alloc — Karşıya dosya yüklemek için bir FTP sunucusuna yer ayırma isteği yapar
    • ftp_cdup — Üst dizine geçer
    • ftp_chdir — FTP sunucusundaki çalışma dizinini değiştirir
    • ftp_chmod — FTP üzerinden bir dosyanın erişim izinlerini değiştirir
    • ftp_close — Bir FTP bağlantısını kapatır
    • ftp_connect — Bir FTP bağlantısı açar
    • ftp_delete — Belirtilen dosyayı FTP sunucusundan siler
    • ftp_exec — FTP sunucusunda bir komut çalıştırma isteği yapar
    • ftp_fget — FTP sunucusundan dosyayı indirip bir dosya tanıtıcısına yazar
    • ftp_fput — FTP sunucusuna dosya tanıtıcısı belirtilen dosyayı yükler
    • ftp_get_option — Bir çalışma anı seçeneğinin değerini döndürür
    • ftp_get — FTP sunucusundan bir dosya indirir
    • ftp_login — FTP bağlantısında kullanıcı oturumu açar
    • ftp_mdtm — Belirtilen dosyanın son değişiklik zamanını döndürür
    • ftp_mkdir — FTP sunucusunda bir dizin oluşturur
    • ftp_nb_continue — Dosya alımını/gönderimini (engellenmeyen kipte) kaldığı yerden devam ettirir
    • ftp_nb_fget — FTP sunucusundan dosyayı (engellenmeyen kipte) indirip bir dosya tanıtıcısına yazar
    • ftp_nb_fput — FTP sunucusuna (engellenmeyen kipte) dosya yüklemek için bir dosya tanıtıcısı kullanır
    • ftp_nb_get — FTP sunucusundan (engellenmeyen kipte) bir dosya indirir
    • ftp_nb_put — Bir dosyayı FTP sunucusuna (engellenmeyen kipte) yükler
    • ftp_nlist — Belirtilen dizindeki dosyaların listesini döndürür
    • ftp_pasv — Edilgen kipi açıp kapar
    • ftp_put — FTP sunucusuna bir dosya yükler
    • ftp_pwd — Çalışılan dizinin ismini döndürür
    • ftp_quit — ftp_close işlevinin takma adıdır
    • ftp_raw — Bir FTP sunucusuna bir komut gönderir
    • ftp_rawlist — Belirtilen dizindeki dosyaların ayrıntılı bir listesini döndürür
    • ftp_rename — FTP sunucusundaki bir dosya veya dizinin adını değiştirir
    • ftp_rmdir — Bir dizini siler
    • ftp_set_option — Çalışma anı seçeneklerini belirler
    • ftp_site — Sunucuya bir SITE komutu gönderir
    • ftp_size — FTP sunucusundaki bir dosyanın boyunu döndürür
    • ftp_ssl_connect — Güvenli bir SSL-FTP bağlantısı açar
    • ftp_systype — Uzak FTP sunucusunun sistem türü tanıtıcısını döndürür
fam_suspend_monitor
Giriş
Diğer Hizmetler


Giriş

Bu eklentideki işlevler Dosya Aktarım Protokolü (FTP) denen ve » http://www.faqs.org/rfcs/rfc959 ile bir internet standardı haline gelen dosya sunucularının kullandığı ünlü protokolün istemci tarafını gerçekler. Bu eklenti, bir FTP sunucusuna erişirken çalışan betiğe geniş çapta bir denetim imkanı sunar. İsteğiniz sadece bir FTP sunucusundan dosya okumak veya sunucuya dosya yüklemekse, daha basit ve sezgisel bir arayüz sağlayan ftp:// sarmalayıcısını dosya sistemi işlevleri ile kullanmanız yeterli olacaktır.

FTP
Yapılandırma/Kurulum
FTP


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
FTP


Kurulum

PHP yapılandırmanızla FTP işlevlerini kullanabilmek için PHP'yi --enable-ftp seçeneğiyle derlemelisiniz.

PHP'nin Windows sürümünde bu eklenti yerleşik olarak gelmektedir. Bu işlevleri Windows'ta kullanmak için herhangi bir eklenti kurmanıza gerek yoktur.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Özkaynak Türleri

Bu eklenti, ftp_connect() veya ftp_ssl_connect() işlevi tarafından döndürülen ve ftp bağlantısı için bağlantı tanıtıcısı olarak kullanılan bir özkaynağa sahiptir.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

FTP_ASCII (integer)

FTP_TEXT (integer)

FTP_BINARY (integer)

FTP_IMAGE (integer)

FTP_TIMEOUT_SEC (integer)

Bilgi için ftp_set_option() işlevine bakın.

Aşağıdaki sabitler PHP 4.3.0'dan itibaren kullanılabilmektedir.

FTP_AUTOSEEK (integer)

Bilgi için ftp_set_option() işlevine bakın.

FTP_AUTORESUME (integer)

GET ve PUT istekleri için başlangıç ve devam konumları özdevinimli olarak belirlenir (sadece FTP_AUTOSEEK etkinken çalışır.)

FTP_FAILED (integer)

Eşzamansız aktarım başarısız oldu.

FTP_FINISHED (integer)

Eşzamansız aktarım tamamlandı.

FTP_MOREDATA (integer)

Eşzamansız aktarım hala etkin.

Özkaynak Türleri
Örnekler
FTP


Örnekler

İçindekiler

  • FTP örneği
Öntanımlı Sabitler
FTP örneği
FTP


FTP örneği

Örnek 1 - FTP örneği

<?php
// Bağlantıyı kuralım
$bt = ftp_connect($ftp_sunucu);

// kullanıcı adı ve parola ile oturum açalım
$bağlantı = ftp_login($bt, $ftpci, $ftpci_parolası);

// bağlantıyı sınayalım
if ((!$bt) || (!$bağlantı)) {
  echo "FTP bağlantısı kurulamadı!";
  echo "$ftpci için $ftp_sunucu sunucusuna bağlanmaya çalışılıyordu.";
  exit;
  } else {
      echo "$ftpci için $ftp_sunucu sunucusuna bağlantı kuruldu.";
  }

// Dosyayı sunucuya yükleyelim
$yükleme = ftp_put($bt, $hedef, $kaynak, FTP_BINARY);

// Duruma bakalım
if (!$yükleme) {
    echo "FTP dosya yüklemesi başarısız oldu!";
  } else {
    echo "$kaynak dosyası $ftp_sunucu sunucusuna ";
    echo "$hedef dosyası olarak yüklendi.";
  }

// FTP akımını kapatalım
ftp_close($bt);
?>

Örnekler
FTP İşlevleri
Örnekler


FTP İşlevleri

İçindekiler

  • ftp_alloc — Karşıya dosya yüklemek için bir FTP sunucusuna yer ayırma isteği yapar
  • ftp_cdup — Üst dizine geçer
  • ftp_chdir — FTP sunucusundaki çalışma dizinini değiştirir
  • ftp_chmod — FTP üzerinden bir dosyanın erişim izinlerini değiştirir
  • ftp_close — Bir FTP bağlantısını kapatır
  • ftp_connect — Bir FTP bağlantısı açar
  • ftp_delete — Belirtilen dosyayı FTP sunucusundan siler
  • ftp_exec — FTP sunucusunda bir komut çalıştırma isteği yapar
  • ftp_fget — FTP sunucusundan dosyayı indirip bir dosya tanıtıcısına yazar
  • ftp_fput — FTP sunucusuna dosya tanıtıcısı belirtilen dosyayı yükler
  • ftp_get_option — Bir çalışma anı seçeneğinin değerini döndürür
  • ftp_get — FTP sunucusundan bir dosya indirir
  • ftp_login — FTP bağlantısında kullanıcı oturumu açar
  • ftp_mdtm — Belirtilen dosyanın son değişiklik zamanını döndürür
  • ftp_mkdir — FTP sunucusunda bir dizin oluşturur
  • ftp_nb_continue — Dosya alımını/gönderimini (engellenmeyen kipte) kaldığı yerden devam ettirir
  • ftp_nb_fget — FTP sunucusundan dosyayı (engellenmeyen kipte) indirip bir dosya tanıtıcısına yazar
  • ftp_nb_fput — FTP sunucusuna (engellenmeyen kipte) dosya yüklemek için bir dosya tanıtıcısı kullanır
  • ftp_nb_get — FTP sunucusundan (engellenmeyen kipte) bir dosya indirir
  • ftp_nb_put — Bir dosyayı FTP sunucusuna (engellenmeyen kipte) yükler
  • ftp_nlist — Belirtilen dizindeki dosyaların listesini döndürür
  • ftp_pasv — Edilgen kipi açıp kapar
  • ftp_put — FTP sunucusuna bir dosya yükler
  • ftp_pwd — Çalışılan dizinin ismini döndürür
  • ftp_quit — ftp_close işlevinin takma adıdır
  • ftp_raw — Bir FTP sunucusuna bir komut gönderir
  • ftp_rawlist — Belirtilen dizindeki dosyaların ayrıntılı bir listesini döndürür
  • ftp_rename — FTP sunucusundaki bir dosya veya dizinin adını değiştirir
  • ftp_rmdir — Bir dizini siler
  • ftp_set_option — Çalışma anı seçeneklerini belirler
  • ftp_site — Sunucuya bir SITE komutu gönderir
  • ftp_size — FTP sunucusundaki bir dosyanın boyunu döndürür
  • ftp_ssl_connect — Güvenli bir SSL-FTP bağlantısı açar
  • ftp_systype — Uzak FTP sunucusunun sistem türü tanıtıcısını döndürür
FTP örneği
ftp_alloc
FTP


Karşıya dosya yüklemek için bir FTP sunucusuna yer ayırma isteği yapar

FTP İşlevleri
ftp_cdup
FTP İşlevleri
PHP Manual

ftp_alloc

(PHP 5, PHP 7)

ftp_alloc — Karşıya dosya yüklemek için bir FTP sunucusuna yer ayırma isteği yapar

Açıklama

bool ftp_alloc ( resource $ftp_akımı , int $dosyaboyu [, string &$sonuç ] )

Yüklenecek dosyaya yer ayırmasi için FTP sunucusuna bir ALLO komutu gönderir.

Bilginize:

Her FTP sunucusu bu komutu desteklemez. Bu sunucular komutun desteklenmediğini veya önceden yer ayırmanın gerekmediğini ve istemcinin işleme devam ederse sorun çıkmayacağını belirten bir başarısızlık kodu (FALSE) döndürebilir. Bu bakımdan, açıkça yer ayırmayı gerektiren sunucuları hesaba katarak bu işlevi de kullanmakta yarar vardır.

Değiştirgeler

ftp_akımı

FTP bağlantısının bağlantı tanıtıcısı.

dosyaboyu

Ayrılacak bayt sayısı.

sonuç

Değiştirge belirtildiği takdirde sunucunun yanıtıyla ilgili ileti bu değiştirgeye yerleştirilir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - ftp_alloc() örneği

<?php

$file = "/home/user/myfile";

// Sunucuya bağlanalım
$conn_id = ftp_connect('ftp.example.com');
$login_result = ftp_login($conn_id, 'anonymous', 'user@example.com');

if (ftp_alloc($conn_id, filesize($file), $result)) {
  echo "Sunucuda yer ayrıldı. $file gönderiliyor.\n";
  ftp_put($conn_id, '/incomming/myfile', $file, FTP_BINARY);
} else {
  echo "Sunucuda yer ayrılamadı. Sunucunun yanıtı: $result\n";
}

ftp_close($conn_id);

?>

Ayrıca Bakınız

  • ftp_put() - FTP sunucusuna bir dosya yükler
  • ftp_fput() - FTP sunucusuna dosya tanıtıcısı belirtilen dosyayı yükler

FTP İşlevleri
ftp_cdup
FTP İşlevleri


Üst dizine geçer

ftp_alloc
ftp_chdir
FTP İşlevleri
PHP Manual

ftp_cdup

(PHP 4, PHP 5, PHP 7)

ftp_cdup — Üst dizine geçer

Açıklama

bool ftp_cdup ( resource $ftp_akımı )

Üst dizine geçer.

Değiştirgeler

ftp_akımı

FTP bağlantısının bağlantı tanıtıcısı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - ftp_cdup() örneği

<?php

// Temel SSL bağlantısını kuralım
$conn_id = ftp_ssl_connect($ftp_server);

// kullanıcı adı ve parola ile oturum açalım
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// çalışma dizinini html yapalım
ftp_chdir($conn_id, 'html');

echo ftp_pwd($conn_id); // /html

// üst dizine dönelim
if (ftp_cdup($conn_id)) {
  echo "Üst dizine sorunsuzca dönüldü\n";
} else {
  echo "Üst dizine dönülemedi\n";
}

echo ftp_pwd($conn_id); // /

ftp_close($conn_id);
?>

Ayrıca Bakınız

  • ftp_chdir() - FTP sunucusundaki çalışma dizinini değiştirir
  • ftp_pwd() - Çalışılan dizinin ismini döndürür

ftp_alloc
ftp_chdir
FTP İşlevleri


FTP sunucusundaki çalışma dizinini değiştirir

ftp_cdup
ftp_chmod
FTP İşlevleri
PHP Manual

ftp_chdir

(PHP 4, PHP 5, PHP 7)

ftp_chdir — FTP sunucusundaki çalışma dizinini değiştirir

Açıklama

bool ftp_chdir ( resource $ftp_akımı , string $dizin )

FTP sunucusundaki çalışma dizinini dizin olarak değiştirir.

Değiştirgeler

ftp_akımı

FTP bağlantısının bağlantı tanıtıcısı.

dizin

Yeni çalışma dizini.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. Dizin değişikliği yapılamazsa PHP bunun için bir uyarı çıktılar.

Örnekler

Örnek 1 - ftp_chdir() örneği

<?php

// Temel SSL bağlantısını kuralım
$conn_id = ftp_ssl_connect($ftp_server);

// kullanıcı adı ve parola ile oturum açalım
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// bağlantıyı sınayalım
if ((!$conn_id) || (!$login_result)) {
    die("FTP bağlantısı kurulamadı!");
}

echo "Çalışma dizini: " . ftp_pwd($conn_id) . "\n";

// Başka bir dizine geçmeyi deneyelim
if (ftp_chdir($conn_id, "somedir")) {
    echo "Yeni çalışma dizini: " . ftp_pwd($conn_id) . "\n";
} else {
    echo "Yeni dizine geçilemedi\n";
}

// bağlantıyı kapatalım
ftp_close($conn_id);
?>

Ayrıca Bakınız

  • ftp_cdup() - Üst dizine geçer
  • ftp_pwd() - Çalışılan dizinin ismini döndürür

ftp_cdup
ftp_chmod
FTP İşlevleri


FTP üzerinden bir dosyanın erişim izinlerini değiştirir

ftp_chdir
ftp_close
FTP İşlevleri
PHP Manual

ftp_chmod

(PHP 5, PHP 7)

ftp_chmod — FTP üzerinden bir dosyanın erişim izinlerini değiştirir

Açıklama

int ftp_chmod ( resource $ftp_akımı , int $kip , string $dosya )

dosya ile belirtilen dosyanın erişim izinlerini kip yapar.

Değiştirgeler

ftp_akımı

FTP bağlantısının bağlantı tanıtıcısı.

kip

Sekizlik bir değer olarak erişim izinleri.

dosya

Dosyanın FTP sunucusundaki yolu.

Dönen Değerler

Hata durumunda FALSE yoksa yeni dosya erişim izinleri döner.

Örnekler

Örnek 1 - ftp_chmod() örneği

<?php
$dosya = 'public_html/index.php';

// Temel SSL bağlantısını kuralım
$conn_id = ftp_ssl_connect($ftp_server);

// kullanıcı adı ve parola ile oturum açalım
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// $dosya dosyasının erişim izinlerini 644 yapalım
if (ftp_chmod($conn_id, 0644, $dosya) !== false) {
 echo "$dosya için erişim izni 644 yapıldı\n";
} else {
 echo "$dosya için erişim izinleri değiştirilemedi\n";
}

// bağlantıyı kapatalım
ftp_close($conn_id);
?>

Ayrıca Bakınız

  • chmod() - Dosya kipini değiştirir

ftp_chdir
ftp_close
FTP İşlevleri


Bir FTP bağlantısını kapatır

ftp_chmod
ftp_connect
FTP İşlevleri
PHP Manual

ftp_close

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

ftp_close — Bir FTP bağlantısını kapatır

Açıklama

bool ftp_close ( resource $ftp_akımı )

ftp_akımı ile belirtilen FTP bağlantısını kapatır ve buna ayrılan özkaynağı serbest bırakır.

Bilginize:

Bu işlevi çağırdıktan sonra artık FTP bağlantısını kullanamaz ama ftp_connect() ile yeni bir tane oluşturabilirsiniz.

Değiştirgeler

ftp_akımı

FTP bağlantısının bağlantı tanıtıcısı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - ftp_close() örneği

<?php

// temel bağlantıyı kuralım
$conn_id = ftp_connect($ftp_server);

// Kullanıcı adı ve parola ile oturum açalım
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// çalışma dizininin ismini basalım
echo ftp_pwd($conn_id); // /

// bağlantıyı kapatalım
ftp_close($conn_id);
?>

Ayrıca Bakınız

  • ftp_connect() - Bir FTP bağlantısı açar

ftp_chmod
ftp_connect
FTP İşlevleri


Bir FTP bağlantısı açar

ftp_close
ftp_delete
FTP İşlevleri
PHP Manual

ftp_connect

(PHP 4, PHP 5, PHP 7)

ftp_connect — Bir FTP bağlantısı açar

Açıklama

resource ftp_connect ( string $adres [, int $port = 21 [, int $zamanaşımı = 90 ]] )

ftp_connect() işlevi belirtilen adresteki FTP sunucusuna bağlantı kurar.

Değiştirgeler

adres

FTP sunucusunun adresi.Bu dizgenin bir bölü çizgisi ile bitirilmemesi ve ftp:// ile öncelenmemesi gerekir.

port

Bu değiştirge normal portun dışında bir port belirtmek için kullanılır. Verilmezse veya 0 belirtilirse öntanımlı FTP portu olan 21 kullanılır.

zamanaşımı

Bu değiştirgede her türlü ağ işlemi için zaman aşımı belirtilir. Belirtilmezse 90 saniye öntanımlı değerdir. Bu zaman aşımını istediğiniz zaman ftp_set_option() ile değiştirebilir ve ftp_get_option() ile sorgulayabilirsiniz.

Dönen Değerler

Hata durumunda FALSE yoksa bir FTP akımı döner.

Örnekler

Örnek 1 - ftp_connect() örneği

<?php

$ftp_server = "ftp.example.com";

// Bağlantıyı kuralım
$conn_id = ftp_connect($ftp_server) or die(
              "$ftp_server adresine bağlantı kurulamadı");

?>

Sürüm Bilgisi

Sürüm: | Açıklama
4.2.0 | zamanaşımı değiştirgesi eklendi.

Ayrıca Bakınız

  • ftp_close() - Bir FTP bağlantısını kapatır
  • ftp_ssl_connect() - Güvenli bir SSL-FTP bağlantısı açar

ftp_close
ftp_delete
FTP İşlevleri


Belirtilen dosyayı FTP sunucusundan siler

ftp_connect
ftp_exec
FTP İşlevleri
PHP Manual

ftp_delete

(PHP 4, PHP 5, PHP 7)

ftp_delete — Belirtilen dosyayı FTP sunucusundan siler

Açıklama

bool ftp_delete ( resource $ftp_akımı , string $dosya )

ftp_delete() işlevi dosya ile belirtilen dosyayı FTP sunucusundan siler.

Değiştirgeler

ftp_akımı

FTP bağlantısının bağlantı tanıtıcısı.

dosya

Silinecek dosyanın yolu.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - ftp_delete() örneği

<?php
$dosya = 'public_html/old.txt';

// temel bağlantıyı kuralım
$conn_id = ftp_connect($ftp_server);

// Kullanıcı adı ve parola ile oturum açalım
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// $dosya dosyasını silmeyi deneyelim
if (ftp_delete($conn_id, $dosya)) {
 echo "$dosya sorunsuzca silindi\n";
} else {
 echo "$dosya silinemedi\n";
}

// bağlantıyı kapatalım
ftp_close($conn_id);
?>

ftp_connect
ftp_exec
FTP İşlevleri


FTP sunucusunda bir komut çalıştırma isteği yapar

ftp_delete
ftp_fget
FTP İşlevleri
PHP Manual

ftp_exec

(PHP 4 >= 4.0.3, PHP 5, PHP 7)

ftp_exec — FTP sunucusunda bir komut çalıştırma isteği yapar

Açıklama

bool ftp_exec ( resource $ftp_akımı , string $komut )

FTP sunucusuna belirtilen SITE EXEC komutu için istek gönderir.

Değiştirgeler

ftp_akımı

FTP bağlantısının bağlantı tanıtıcısı.

komut

Çalıştırılacak komut.

Dönen Değerler

İşlem başarılı olursa (sunucu yanıt kodu 200 ise) TRUE olmazsa FALSE döner.

Örnekler

Örnek 1 - ftp_exec() örneği

<?php

// değişken ilklendirmesi
$komut = 'ls -al >files.txt';

// temel bağlantıyı kuralım
$conn_id = ftp_connect($ftp_server);

// Kullanıcı adı ve parola ile oturum açalım
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// komutu çalıştıralım
if (ftp_exec($conn_id, $komut)) {
    echo "$komut sorunsuzca çalıştırıldı\n";
} else {
    echo "$komut çalıştırılamadı\n";
}

// bağlantıyı kapatalım
ftp_close($conn_id);

?>

Ayrıca Bakınız

  • ftp_raw() - Bir FTP sunucusuna bir komut gönderir

ftp_delete
ftp_fget
FTP İşlevleri


FTP sunucusundan dosyayı indirip bir dosya tanıtıcısına yazar

ftp_exec
ftp_fput
FTP İşlevleri
PHP Manual

ftp_fget

(PHP 4, PHP 5, PHP 7)

ftp_fget — FTP sunucusundan dosyayı indirip bir dosya tanıtıcısına yazar

Açıklama

bool ftp_fget ( resource $ftp_akımı , resource $dt , string $uzak_dosya , int $kip [, int $devam_yeri = 0 ] )

ftp_fget() işlevi FTP sunucusundan dosyayı indirirken veriyi açık bir dosya tanıtıcısına yazar.

Değiştirgeler

ftp_akımı

FTP bağlantısının bağlantı tanıtıcısı.

dt

Verinin saklanacağı açık dosya tanıtıcısı.

uzak_dosya

Dosyanın FTP sunucusundaki yolu.

kip

Aktarım kipi. FTP_ASCII veya FTP_BINARY olabilir.

devam_yeri

İndirmenin başlatılacağı bayt konumu.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - ftp_fget() örneği

<?php

// dosyaları hazırlayalım
$uzak = 'somefile.txt';
$yerel = 'localfile.txt';

// Yazmak için bir dosya açalım
$dt = fopen($yerel, 'w');

// temel bağlantıyı kuralım
$conn_id = ftp_connect($ftp_server);

// Kullanıcı adı ve parola ile oturum açalım
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// $uzak dosyasını indirip $dt tanıtıcısına yazmayı deneyelim
if (ftp_fget($conn_id, $dt, $uzak, FTP_ASCII, 0)) {
 echo "$yerel dosyasına başarıyla yazıldı\n";
} else {
 echo "$uzak dosyası $yerel dosyasına yazılırken bir hata oluştu\n";
}

// bağlantıyı ve dosya tanıtıcısını kapatalım
ftp_close($conn_id);
fclose($dt);
?>

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.0 | devam_yeri değiştirgesi eklendi.

Ayrıca Bakınız

  • ftp_get() - FTP sunucusundan bir dosya indirir
  • ftp_nb_get() - FTP sunucusundan (engellenmeyen kipte) bir dosya indirir
  • ftp_nb_fget() - FTP sunucusundan dosyayı (engellenmeyen kipte) indirip bir dosya tanıtıcısına yazar

ftp_exec
ftp_fput
FTP İşlevleri


FTP sunucusuna dosya tanıtıcısı belirtilen dosyayı yükler

ftp_fget
ftp_get_option
FTP İşlevleri
PHP Manual

ftp_fput

(PHP 4, PHP 5, PHP 7)

ftp_fput — FTP sunucusuna dosya tanıtıcısı belirtilen dosyayı yükler

Açıklama

bool ftp_fput ( resource $ftp_akımı , string $uzak_dosa , resource $dt , int $mode [, int $başlama_yeri = 0 ] )

ftp_fput() işlevi FTP sunucusuna dosya yüklerken dt ile belirtilen dosya tanıtıcısı kullanır.

Değiştirgeler

ftp_akımı

FTP bağlantısının bağlantı tanıtıcısı.

uzak_dosa

Dosyanın FTP sunucusundaki yolu.

dt

Yerel dosyanın açık dosya tanıtıcısı. Okuma işlemi dosyanın sonuna gelindiğinde durur.

kip

Aktarım kipi. FTP_ASCII veya FTP_BINARY olabilir.

başlama_yeri

Yüklemenin başlatılacağı bayt konumu.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - ftp_fput() örneği

<?php

// Okumak için bir dosya açalım
$file = 'somefile.txt';
$fp = fopen($file, 'r');

// temel bağlantıyı kuralım
$conn_id = ftp_connect($ftp_server);

// Kullanıcı adı ve parola ile oturum açalım
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// yüklemeyi başlatalım
if (ftp_fput($conn_id, $file, $fp, FTP_ASCII)) {
    echo "$file sorunsuzca yüklendi.\n";
} else {
    echo "$file yüklenirken bir sorun çıktı.\n";
}

// bağlantıyı ve dosya tanıtıcısını kapatalım
ftp_close($conn_id);
fclose($fp);

?>

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.0 | başlama_yeri değiştirgesi eklendi.

Ayrıca Bakınız

  • ftp_put() - FTP sunucusuna bir dosya yükler
  • ftp_nb_fput() - FTP sunucusuna (engellenmeyen kipte) dosya yüklemek için bir dosya tanıtıcısı kullanır
  • ftp_nb_put() - Bir dosyayı FTP sunucusuna (engellenmeyen kipte) yükler

ftp_fget
ftp_get_option
FTP İşlevleri


Bir çalışma anı seçeneğinin değerini döndürür

ftp_fput
ftp_get
FTP İşlevleri
PHP Manual

ftp_get_option

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

ftp_get_option — Bir çalışma anı seçeneğinin değerini döndürür

Açıklama

mixed ftp_get_option ( resource $ftp_akımı , int $seçenek )

seçenek seçeneğinin belirtilen FTP akımı ile ilgili değerini döndürür.

Değiştirgeler

ftp_akımı

FTP bağlantısının bağlantı tanıtıcısı.

seçenek

Şimdilik aşağıdaki seçenekler desteklenmektedir:

Desteklenen çalışma anı FTP seçenekleri
FTP_TIMEOUT_SEC | Ağ ile ilgili işlevlerde kullanılan zaman aşımını döndürür.
FTP_AUTOSEEK | Etkin olduğunda, devam_yeri veya başlama_yeri değiştirgeli bir GET veya PUT isteğinde dosya içinde önce belirtilen konum aranır. Seçenek etkinse TRUE değilse FALSE döner.

Dönen Değerler

Hata durumunda FALSE döner ve bir uyarı çıktılanır yoksa seçeneğin değeri döner.

Örnekler

Örnek 1 - ftp_get_option() örneği

<?php
// Belirtilen FTP akımının ağ zaman aşımını öğrenelim
$timeout = ftp_get_option($conn_id, FTP_TIMEOUT_SEC);
?>

Ayrıca Bakınız

  • ftp_set_option() - Çalışma anı seçeneklerini belirler

ftp_fput
ftp_get
FTP İşlevleri


FTP sunucusundan bir dosya indirir

ftp_get_option
ftp_login
FTP İşlevleri
PHP Manual

ftp_get

(PHP 4, PHP 5, PHP 7)

ftp_get — FTP sunucusundan bir dosya indirir

Açıklama

bool ftp_get ( resource $ftp_akımı , string $yerel_dosya , string $uzak_dosya , int $kip [, int $devam_yeri = 0 ] )

FTP sunucusundan bir dosya indirip bir yerel dosyaya kaydeder.

Değiştirgeler

ftp_akımı

FTP bağlantısının bağlantı tanıtıcısı.

yerel_dosya

Yerel dosyanın yolu (dosya varsa üzerine yazılır).

uzak_dosya

FTP sunucusundaki dosyanın yolu.

kip

Aktarım kipi. FTP_ASCII veya FTP_BINARY olabilir.

devam_yeri

İndirmenin başlatılacağı bayt konumu.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - ftp_get() örneği

<?php

// değişkenleri tanımlayalım
$local_file = 'local.zip';
$server_file = 'server.zip';

// temel bağlantıyı kuralım
$conn_id = ftp_connect($ftp_server);

// Kullanıcı adı ve parola ile oturum açalım
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// $server_file dosyasını indirip $local_file dosyasına yazalım
if (ftp_get($conn_id, $local_file, $server_file, FTP_BINARY)) {
    echo "$local_file başarıyla kaydedildi.\n";
} else {
    echo "Bir sorun çıktı\n";
}

// bağlantıyı kapatalım
ftp_close($conn_id);

?>

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.0 | devam_yeri değiştirgesi eklendi.

Ayrıca Bakınız

  • ftp_pasv() - Edilgen kipi açıp kapar
  • ftp_fget() - FTP sunucusundan dosyayı indirip bir dosya tanıtıcısına yazar
  • ftp_nb_get() - FTP sunucusundan (engellenmeyen kipte) bir dosya indirir
  • ftp_nb_fget() - FTP sunucusundan dosyayı (engellenmeyen kipte) indirip bir dosya tanıtıcısına yazar

ftp_get_option
ftp_login
FTP İşlevleri


FTP bağlantısında kullanıcı oturumu açar

ftp_get
ftp_mdtm
FTP İşlevleri
PHP Manual

ftp_login

(PHP 4, PHP 5, PHP 7)

ftp_login — FTP bağlantısında kullanıcı oturumu açar

Açıklama

bool ftp_login ( resource $ftp_akımı , string $kullanıcı , string $parola )

Belirtilen FTP akımı üzerinde belirtilen kullanıcı için bir oturum açar.

Değiştirgeler

ftp_akımı

FTP bağlantısının bağlantı tanıtıcısı.

kullanıcı

Kullanıcı adı (FTP komutu: USER).

parola

Parola (FTP komutu: PASS).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. Oturum açılamazsa PHP bir uyarı çıktılar.

Örnekler

Örnek 1 - ftp_login() örneği

<?php

$ftp_server = "ftp.example.com";
$ftp_user = "foo";
$ftp_pass = "bar";

// bağlantıyı kuralım
$conn_id = ftp_connect($ftp_server) or die(
             "$ftp_server sunucusuna bağlantı kurulamadı");

// oturum açmayı deneyelim
if (@ftp_login($conn_id, $ftp_user, $ftp_pass)) {
    echo "$ftp_user@$ftp_server oturumu açıldı\n";
} else {
    echo "$ftp_user için oturum açılamadı\n";
}

// bağlantıyı kapatalım
ftp_close($conn_id);
?>

ftp_get
ftp_mdtm
FTP İşlevleri


Belirtilen dosyanın son değişiklik zamanını döndürür

ftp_login
ftp_mkdir
FTP İşlevleri
PHP Manual

ftp_mdtm

(PHP 4, PHP 5, PHP 7)

ftp_mdtm — Belirtilen dosyanın son değişiklik zamanını döndürür

Açıklama

int ftp_mdtm ( resource $ftp_akımı , string $uzak_dosya )

FTP sunucusundaki uzak_dosya dosyasının son değişiklik zamanını döndürür.

Bilginize:

Her sunucu bu özelliği desteklemez!

Bilginize:

ftp_mdtm() işlevi dizinler için işlem yapmaz.

Değiştirgeler

ftp_akımı

FTP bağlantısının bağlantı tanıtıcısı.

uzak_dosya

Son değişiklik zamanı sorgulanacak dosya.

Dönen Değerler

Hata durumunda -1 yoksa belirtilen dosyanın son değişiklik zamanını bir Unix zaman damgası olarak döndürür.

Örnekler

Örnek 1 - ftp_mdtm() örneği

<?php

$file = 'somefile.txt';

// temel bağlantıyı kuralım
$conn_id = ftp_connect($ftp_server);

// Kullanıcı adı ve parola ile oturum açalım
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

//  son değişiklik zamanına bakalım
$buff = ftp_mdtm($conn_id, $file);

if ($buff != -1) {
    // somefile.txt dosyasının son değişiklik zamanı: March 26 2003 14:16:41.
    echo "$file dosyasının son değişiklik zamanı: " .
          date("F d Y H:i:s.", $buff);
} else {
    echo "Dosyanın son değişiklik zamanı saptanamadı.";
}

// bağlantıyı kapatalım
ftp_close($conn_id);

?>

ftp_login
ftp_mkdir
FTP İşlevleri


FTP sunucusunda bir dizin oluşturur

ftp_mdtm
ftp_nb_continue
FTP İşlevleri
PHP Manual

ftp_mkdir

(PHP 4, PHP 5, PHP 7)

ftp_mkdir — FTP sunucusunda bir dizin oluşturur

Açıklama

string ftp_mkdir ( resource $ftp_akımı , string $dizin )

FTP sunucusunda belirtilen dizini oluşturur.

Değiştirgeler

ftp_akımı

FTP bağlantısının bağlantı tanıtıcısı.

dizin

Oluşturulacak dizinin ismi.

Dönen Değerler

Hata durumunda FALSE yoksa oluşturulan dizinin ismi döner.

Örnekler

Örnek 1 - ftp_mkdir() örneği

<?php

$dir = 'www';

// temel bağlantıyı kuralım
$conn_id = ftp_connect($ftp_server);

// Kullanıcı adı ve parola ile oturum açalım
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// $dir dizinini oluşturmayı deneyelim
if (ftp_mkdir($conn_id, $dir)) {
 echo "$dir sorunsuzca oluşturuldu.\n";
} else {
 echo "$dir oluşturulurken bir sorun çıktı.\n";
}

// bağlantıyı kapatalım
ftp_close($conn_id);
?>

Ayrıca Bakınız

  • ftp_rmdir() - Bir dizini siler

ftp_mdtm
ftp_nb_continue
FTP İşlevleri


Dosya alımını/gönderimini (engellenmeyen kipte) kaldığı yerden devam ettirir

ftp_mkdir
ftp_nb_fget
FTP İşlevleri
PHP Manual

ftp_nb_continue

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

ftp_nb_continue — Dosya alımını/gönderimini (engellenmeyen kipte) kaldığı yerden devam ettirir

Açıklama

int ftp_nb_continue ( resource $ftp_akımı )

Dosya alımını/gönderimini kaldığı yerden devam ettirir.

Değiştirgeler

ftp_akımı

FTP bağlantısının bağlantı tanıtıcısı.

Dönen Değerler

FTP_FAILED veya FTP_FINISHED ya da FTP_MOREDATA döner.

Örnekler

Örnek 1 - ftp_nb_continue() örneği

<?php

// İndirmeyi başlatalım
$ret = ftp_nb_get($my_connection, "test", "README", FTP_BINARY);
while ($ret == FTP_MOREDATA) {

   // İndirmeye devam...
   $ret = ftp_nb_continue($my_connection);
}
if ($ret != FTP_FINISHED) {
   echo "Dosya indirilirken bir hata oluştu...";
   exit(1);
}
?>

ftp_mkdir
ftp_nb_fget
FTP İşlevleri


FTP sunucusundan dosyayı (engellenmeyen kipte) indirip bir dosya tanıtıcısına yazar

ftp_nb_continue
ftp_nb_fput
FTP İşlevleri
PHP Manual

ftp_nb_fget

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

ftp_nb_fget — FTP sunucusundan dosyayı (engellenmeyen kipte) indirip bir dosya tanıtıcısına yazar

Açıklama

int ftp_nb_fget ( resource $ftp_akımı , resource $dt , string $uzak_dosya , int $kip [, int $devam_yeri = 0 ] )

ftp_nb_fget() işlevi FTP sunucusundan dosyayı indirirken veriyi açık bir dosya tanıtıcısına yazar.

Bu işlevin ftp_get() işlevinden farkı bu işlevin dosyayı eşzamansız olarak indirmesidir. Yani indirme işlemi sırasında başka işlemler yapabilirsiniz.

Değiştirgeler

ftp_akımı

FTP bağlantısının bağlantı tanıtıcısı.

dt

Verinin saklanacağı açık dosya tanıtıcısı.

uzak_dosya

Dosyanın FTP sunucusundaki yolu.

kip

Aktarım kipi. FTP_ASCII veya FTP_BINARY olabilir.

devam_yeri

Dönen Değerler

FTP_FAILED veya FTP_FINISHED ya da FTP_MOREDATA döner.

Örnekler

Örnek 1 - ftp_nb_fget() örneği

<?php

// Yazmak için bir dosya açalım
$file = 'index.php';
$fp = fopen($file, 'w');

$conn_id = ftp_connect($ftp_server);

$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// İndirmeyi başlatalım
$ret = ftp_nb_fget($conn_id, $fp, $file, FTP_BINARY);
while ($ret == FTP_MOREDATA) {

   // Başka şeyler yapalım
   echo ".";

   // İndirmeye devam...
   $ret = ftp_nb_continue($conn_id);
}
if ($ret != FTP_FINISHED) {
   echo "Dosya indirilirken bir hata oluştu...";
   exit(1);
}

// dosya tanıtıcısını kapatalım
fclose($fp);
?>

Ayrıca Bakınız

  • ftp_nb_get() - FTP sunucusundan (engellenmeyen kipte) bir dosya indirir
  • ftp_nb_continue() - Dosya alımını/gönderimini (engellenmeyen kipte) kaldığı yerden devam ettirir
  • ftp_fget() - FTP sunucusundan dosyayı indirip bir dosya tanıtıcısına yazar
  • ftp_get() - FTP sunucusundan bir dosya indirir

ftp_nb_continue
ftp_nb_fput
FTP İşlevleri


FTP sunucusuna (engellenmeyen kipte) dosya yüklemek için bir dosya tanıtıcısı kullanır

ftp_nb_fget
ftp_nb_get
FTP İşlevleri
PHP Manual

ftp_nb_fput

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

ftp_nb_fput — FTP sunucusuna (engellenmeyen kipte) dosya yüklemek için bir dosya tanıtıcısı kullanır

Açıklama

int ftp_nb_fput ( resource $ftp_akımı , string $uzak_dosya , resource $dt , int $kip [, int $başlama_yeri = 0 ] )

ftp_nb_fput() işlevi FTP sunucusuna dosya yüklerken dt ile belirtilen dosya tanıtıcısı kullanır.

Bu işlevin ftp_put() işlevinden farkı bu işlevin dosyayı eşzamansız olarak yüklemesidir. Yani yükleme işlemi sırasında başka işlemler yapabilirsiniz.

Değiştirgeler

ftp_akımı

FTP bağlantısının bağlantı tanıtıcısı.

uzak_dosya

Dosyanın FTP sunucusundaki yolu.

dt

Yerel dosyanın açık dosya tanıtıcısı. Okuma işlemi dosyanın sonuna gelindiğinde durur.

kip

Aktarım kipi. FTP_ASCII veya FTP_BINARY olabilir.

başlama_yeri

Dönen Değerler

FTP_FAILED veya FTP_FINISHED ya da FTP_MOREDATA döner.

Örnekler

Örnek 1 - ftp_nb_fput() örneği

<?php

$file = 'index.php';

$fp = fopen($file, 'r');

$conn_id = ftp_connect($ftp_server);

$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// yüklemeyi başlatalım
$ret = ftp_nb_fput($conn_id, $file, $fp, FTP_BINARY);
while ($ret == FTP_MOREDATA) {

   // Başka şeyler yapalım
   echo ".";

   // Yüklemeye devam...
   $ret = ftp_nb_continue($conn_id);
}
if ($ret != FTP_FINISHED) {
   echo "Dosya yüklenirken bir hata oluştu...";
   exit(1);
}

fclose($fp);
?>

Ayrıca Bakınız

  • ftp_nb_put() - Bir dosyayı FTP sunucusuna (engellenmeyen kipte) yükler
  • ftp_nb_continue() - Dosya alımını/gönderimini (engellenmeyen kipte) kaldığı yerden devam ettirir
  • ftp_put() - FTP sunucusuna bir dosya yükler
  • ftp_fput() - FTP sunucusuna dosya tanıtıcısı belirtilen dosyayı yükler

ftp_nb_fget
ftp_nb_get
FTP İşlevleri


FTP sunucusundan (engellenmeyen kipte) bir dosya indirir

ftp_nb_fput
ftp_nb_put
FTP İşlevleri
PHP Manual

ftp_nb_get

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

ftp_nb_get — FTP sunucusundan (engellenmeyen kipte) bir dosya indirir

Açıklama

int ftp_nb_get ( resource $ftp_akımı , string $yerel_dosya , string $uzak_dosya , int $kip [, int $devam_yeri = 0 ] )

ftp_nb_get() işlevi FTP sunucusundan uzak_dosya dosyasını alır, yerel dosya sistemine yerel_dosya adıyla kaydeder.

Bu işlevin ftp_get() işlevinden farkı bu işlevin dosyayı eşzamansız olarak indirmesidir. Yani indirme işlemi sırasında başka işlemler yapabilirsiniz.

Değiştirgeler

ftp_akımı

FTP bağlantısının bağlantı tanıtıcısı.

yerel_dosya

Yerel dosyanın yolu (dosya varsa üzerine yazılır).

uzak_dosya

Dosyanın FTP sunucusundaki yolu.

kip

Aktarım kipi. FTP_ASCII veya FTP_BINARY olabilir.

devam_yeri

Dönen Değerler

FTP_FAILED veya FTP_FINISHED ya da FTP_MOREDATA döner.

Örnekler

Örnek 1 - ftp_nb_get() örneği

<?php

// İndirmeyi başlatalım
$ret = ftp_nb_get($my_connection, "test", "README", FTP_BINARY);
while ($ret == FTP_MOREDATA) {

   // Başka bir şeyler yapalım
   echo ".";

   // İndirmeye devam...
   $ret = ftp_nb_continue($my_connection);
}
if ($ret != FTP_FINISHED) {
   echo "Dosya indirilirken bir hata oluştu...";
   exit(1);
}
?>

Örnek 2 - ftp_nb_get() ile indirmeyi devam ettirmek

<?php

// İndirmeyi tekrar başlatalım
$ret = ftp_nb_get($my_connection, "test", "README", FTP_BINARY,
                      filesize("test"));
// VEYA: $ret = ftp_nb_get($my_connection, "test", "README",
//                           FTP_BINARY, FTP_AUTORESUME);
while ($ret == FTP_MOREDATA) {

   // Başka şeyler yapalım
   echo ".";

   // İndirmeye devam...
   $ret = ftp_nb_continue($my_connection);
}
if ($ret != FTP_FINISHED) {
   echo "Dosya indirilirken bir hata oluştu.....";
   exit(1);
}
?>

Örnek 3 - ftp_nb_get() ile indirmeyi yeni bir dosyanın 100. baytından sürdürmek

<?php

// Özdevinimli konumlamayı kapatalım
ftp_set_option($my_connection, FTP_AUTOSEEK, false);

// İndirmeyi başlatalım
$ret = ftp_nb_get($my_connection, "yenidosya", "BENiOKU", FTP_BINARY, 100);
while ($ret == FTP_MOREDATA) {

   /* ... */

   // İndirmeye devam...
   $ret = ftp_nb_continue($my_connection);
}
?>

Yukarıdaki örnekte, yenidosya, FTP sunucusundaki BENiOKU dosyasından 100 bayt kısa olacaktır. Bunun sebebi indirmenin 100. bayttan başlatılmış olmasıdır. Eğer FTP_AUTOSEEK seçeneğine FALSE atamasaydık yenidosya dosyasının ilk 100 baytı '\0' karakterleriyle doldurulacaktı.

Ayrıca Bakınız

  • ftp_nb_fget() - FTP sunucusundan dosyayı (engellenmeyen kipte) indirip bir dosya tanıtıcısına yazar
  • ftp_nb_continue() - Dosya alımını/gönderimini (engellenmeyen kipte) kaldığı yerden devam ettirir
  • ftp_fget() - FTP sunucusundan dosyayı indirip bir dosya tanıtıcısına yazar
  • ftp_get() - FTP sunucusundan bir dosya indirir

ftp_nb_fput
ftp_nb_put
FTP İşlevleri


Bir dosyayı FTP sunucusuna (engellenmeyen kipte) yükler

ftp_nb_get
ftp_nlist
FTP İşlevleri
PHP Manual

ftp_nb_put

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

ftp_nb_put — Bir dosyayı FTP sunucusuna (engellenmeyen kipte) yükler

Açıklama

int ftp_nb_put ( resource $ftp_akımı , string $uzak_dosya , string $yerel_dosya , int $kip [, int $başlama_yeri = 0 ] )

Belirtilen yerel_dosya dosyasını FTP sunucusuna uzak_dosya olarak yükler.

Bu işlevin ftp_put() işlevinden farkı bu işlevin dosyayı eşzamansız olarak yüklemesidir. Yani yükleme işlemi sırasında başka işlemler yapabilirsiniz.

Değiştirgeler

ftp_akımı

FTP bağlantısının bağlantı tanıtıcısı.

uzak_dosya

FTP sunucundaki dosya yolu.

yerel_dosya

Yerel dosya yolu.

kip

Aktarım kipi. FTP_ASCII veya FTP_BINARY olabilir.

başlama_yeri

Dönen Değerler

FTP_FAILED veya FTP_FINISHED ya da FTP_MOREDATA döner.

Örnekler

Örnek 1 - ftp_nb_put() örneği

<?php

// Yüklemeyi başlatalım
$ret = ftp_nb_put($my_connection, "test.remote", "test.local", FTP_BINARY);
while ($ret == FTP_MOREDATA) {

   // Başka birşeyler yapalım
   echo ".";

   // Yüklemeye devam...
   $ret = ftp_nb_continue($my_connection);
}
if ($ret != FTP_FINISHED) {
   echo "Dosya yüklenirken bir hata oluştu...";
   exit(1);
}
?>

Örnek 2 - ftp_nb_put() ile yüklemeyi devam ettirmek

<?php

// Yüklemeyi tekrar başlatalım
$ret = ftp_nb_put($my_connection, "test.remote", "test.local",
                      FTP_BINARY, ftp_size("test.remote"));
// VEYA: $ret = ftp_nb_put($my_connection, "test.remote", "test.local",
//                           FTP_BINARY, FTP_AUTORESUME);

while ($ret == FTP_MOREDATA) {

   // Başka birşeyler yapalım
   echo ".";

   // Yüklemeye devam...
   $ret = ftp_nb_continue($my_connection);
}
if ($ret != FTP_FINISHED) {
   echo "Dosya yüklenirken bir hata oluştu...";
   exit(1);
}
?>

Ayrıca Bakınız

  • ftp_nb_fput() - FTP sunucusuna (engellenmeyen kipte) dosya yüklemek için bir dosya tanıtıcısı kullanır
  • ftp_nb_continue() - Dosya alımını/gönderimini (engellenmeyen kipte) kaldığı yerden devam ettirir
  • ftp_put() - FTP sunucusuna bir dosya yükler
  • ftp_fput() - FTP sunucusuna dosya tanıtıcısı belirtilen dosyayı yükler

ftp_nb_get
ftp_nlist
FTP İşlevleri


Belirtilen dizindeki dosyaların listesini döndürür

ftp_nb_put
ftp_pasv
FTP İşlevleri
PHP Manual

ftp_nlist

(PHP 4, PHP 5, PHP 7)

ftp_nlist — Belirtilen dizindeki dosyaların listesini döndürür

Açıklama

array ftp_nlist ( resource $ftp_akımı , string $dizin )

Değiştirgeler

ftp_akımı

FTP bağlantısının bağlantı tanıtıcısı.

dizin

İçereği listelenecek dizin. Bu değiştirge öncelenmez. Dolayısıyla boşluk ve diğer karakterleri içeren dosya isimleri gibi şeyler sözkonusu olabilir.

Dönen Değerler

Hata durumunda FALSE yoksa belirtilen dizindeki dosya isimlerinden oluşan bir dizi döner.

Örnekler

Örnek 1 - ftp_nlist() örneği

<?php

// FTP sunucusuna bağlanalım
$conn = ftp_connect('ftp.example.com');
if (!$conn) die('ftp.example.com ile bağlantı kurulamadı');

// kullanıcı adı ve parola ile oturum açalım
$login_result = ftp_login($conn, $ftp_user_name, $ftp_user_pass);

// çalıştığımız dizinin içeriğini alalım
$içerik = ftp_nlist($conn, ".");

// $içerik çıktısı
var_dump($içerik);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(3) {
  [0]=>
  string(11) "public_html"
  [1]=>
  string(10) "public_ftp"
  [2]=>
  string(3) "www"

Ayrıca Bakınız

  • ftp_rawlist() - Belirtilen dizindeki dosyaların ayrıntılı bir listesini döndürür

ftp_nb_put
ftp_pasv
FTP İşlevleri


Edilgen kipi açıp kapar

ftp_nlist
ftp_put
FTP İşlevleri
PHP Manual

ftp_pasv

(PHP 4, PHP 5, PHP 7)

ftp_pasv — Edilgen kipi açıp kapar

Açıklama

bool ftp_pasv ( resource $ftp_akımı , bool $edilgen )

ftp_pasv() işlevi edilgen kipi açar ve kapar. Edilgen kipte veri bağlantıları sunucu tarafından değil istemci tarafından başlatılır. İstemci bir güvenlik duvarı arkasındaysa bu gerekli olabilir.

ftp_pasv() işlevini başarılı bir kullanıcı oturumu açma işleminden sonra kullanmalısınız yoksa başarısız olacaktır.

Değiştirgeler

ftp_akımı

FTP bağlantısının bağlantı tanıtıcısı.

edilgen

TRUE belirtilirse edilgen kipe geçilir, FALSE belirtilirse edilgen kipten çıkılır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - ftp_pasv() örneği

<?php
$yerel = 'somefile.txt';
$uzak = 'readme.txt';

// FTP sunucusuna bağlanalım
$conn = ftp_connect('ftp.example.com');
if (!$conn) die('ftp.example.com ile bağlantı kurulamadı');

// kullanıcı adı ve parola ile oturum açalım
$login_result = ftp_login($conn, $ftp_user_name, $ftp_user_pass);

// Edilgen kipe geçelim
ftp_pasv($conn, true);

// Karşıya bir dosya yükleyelim
if (ftp_put($conn, $uzak, $yerel, FTP_ASCII)) {
 echo "$yerel karşıya sorunsuzca yüklendi\n";
} else {
 echo "$yerel karşıya yüklenirken bir sorun çıktı\n";
}

// bağlantıyı kapatalım
ftp_close($conn);
?>

ftp_nlist
ftp_put
FTP İşlevleri


FTP sunucusuna bir dosya yükler

ftp_pasv
ftp_pwd
FTP İşlevleri
PHP Manual

ftp_put

(PHP 4, PHP 5, PHP 7)

ftp_put — FTP sunucusuna bir dosya yükler

Açıklama

bool ftp_put ( resource $ftp_akımı , string $uzak_dosya , string $yerel_dosya , int $kip [, int $başlama_yeri = 0 ] )

Belirtilen yerel_dosya dosyasını FTP sunucusuna uzak_dosya olarak yükler.

Değiştirgeler

ftp_akımı

FTP bağlantısının bağlantı tanıtıcısı.

uzak_dosya

FTP sunucundaki dosya yolu.

yerel_dosya

Yerel dosya yolu.

kip

Aktarım kipi. FTP_ASCII veya FTP_BINARY olabilir.

başlama_yeri

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - ftp_put() örneği

<?php
$yerel = 'somefile.txt';
$uzak = 'readme.txt';

// FTP sunucusuna bağlanalım
$conn = ftp_connect('ftp.example.com');
if (!$conn) die('ftp.example.com ile bağlantı kurulamadı');

// kullanıcı adı ve parola ile oturum açalım
$login_result = ftp_login($conn, $ftp_user_name, $ftp_user_pass);

// karşıya bir dosya yükleyelim
if (ftp_put($conn, $uzak, $yerel, FTP_ASCII)) {
 echo "$yerel sorunsuzca karşıya yüklendi\n";
} else {
 echo "$yerel karşıya yüklenirken bir sorun çıktı\n";
}

// bağlantıyı kapatalım
ftp_close($conn);
?>

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.0 | başlama_yeri değiştirgesi eklendi.

Ayrıca Bakınız

  • ftp_pasv() - Edilgen kipi açıp kapar
  • ftp_fput() - FTP sunucusuna dosya tanıtıcısı belirtilen dosyayı yükler
  • ftp_nb_fput() - FTP sunucusuna (engellenmeyen kipte) dosya yüklemek için bir dosya tanıtıcısı kullanır
  • ftp_nb_put() - Bir dosyayı FTP sunucusuna (engellenmeyen kipte) yükler

ftp_pasv
ftp_pwd
FTP İşlevleri


Çalışılan dizinin ismini döndürür

ftp_put
ftp_quit
FTP İşlevleri
PHP Manual

ftp_pwd

(PHP 4, PHP 5, PHP 7)

ftp_pwd — Çalışılan dizinin ismini döndürür

Açıklama

string ftp_pwd ( resource $ftp_akımı )

Değiştirgeler

ftp_akımı

FTP bağlantısının bağlantı tanıtıcısı.

Dönen Değerler

Hata durumunda FALSE yoksa çalışılan dizinin ismini döndürür.

Örnekler

Örnek 1 - ftp_pwd() örneği

<?php

// FTP sunucusuna bağlanalım
$conn = ftp_connect('ftp.example.com');
if (!$conn) die('ftp.example.com ile bağlantı kurulamadı');

// kullanıcı adı ve parola ile oturum açalım
$login_result = ftp_login($conn, $ftp_user_name, $ftp_user_pass);

// public_html dizinine geçelim
ftp_chdir($conn, 'public_html');

// dizinin adını basalım
echo ftp_pwd($conn); // /public_html

// bağlantıyı kapatalım
ftp_close($conn);
?>

Ayrıca Bakınız

  • ftp_chdir() - FTP sunucusundaki çalışma dizinini değiştirir
  • ftp_cdup() - Üst dizine geçer

ftp_put
ftp_quit
FTP İşlevleri


ftp_close işlevinin takma adıdır

ftp_pwd
ftp_raw
FTP İşlevleri
PHP Manual

ftp_quit

(PHP 4, PHP 5, PHP 7)

ftp_quit — ftp_close() işlevinin takma adıdır

Açıklama

Bu işlev, ftp_close() işlevinin takma adıdır.

ftp_pwd
ftp_raw
FTP İşlevleri


Bir FTP sunucusuna bir komut gönderir

ftp_quit
ftp_rawlist
FTP İşlevleri
PHP Manual

ftp_raw

(PHP 5, PHP 7)

ftp_raw — Bir FTP sunucusuna bir komut gönderir

Açıklama

array ftp_raw ( resource $ftp_akımı , string $komut )

Bir FTP sunucusuna komut komutunu gönderir.

Değiştirgeler

ftp_akımı

FTP bağlantısının bağlantı tanıtıcısı.

komut

Çalıştırılacak komut.

Dönen Değerler

Sunucunun komuta yanıtını bir dizi içinde döndürür. Yanıt dizgelerine herhangi bir işlem yapılmaz ve işlev komutun başarılı olup olmadığıyla ilgilenmez.

Örnekler

Örnek 1 - Bir FTP sunucusuna ftp_raw() kullanarak el yordamıyla oturum açmak

<?php
$fp = ftp_connect("ftp.example.com");

/* Komut şu işlev ile aynı işi yapacak:
   ftp_login($fp, "birey", "parola"); */
ftp_raw($fp, "USER birey");
ftp_raw($fp, "PASS parola");
?>

Ayrıca Bakınız

  • ftp_exec() - FTP sunucusunda bir komut çalıştırma isteği yapar

ftp_quit
ftp_rawlist
FTP İşlevleri


Belirtilen dizindeki dosyaların ayrıntılı bir listesini döndürür

ftp_raw
ftp_rename
FTP İşlevleri
PHP Manual

ftp_rawlist

(PHP 4, PHP 5, PHP 7)

ftp_rawlist — Belirtilen dizindeki dosyaların ayrıntılı bir listesini döndürür

Açıklama

array ftp_rawlist ( resource $ftp_akımı , string $dizin [, bool $ardışık = false ] )

ftp_rawlist() işlevi FTP LIST komutunu çalıştırıp sonuçları bir dizi içinde döndürür.

Değiştirgeler

ftp_akımı

FTP bağlantısının bağlantı tanıtıcısı.

dizin

İçeriği listelenecek dizinin yolu.

ardışık

TRUE belirtilirse LIST -R komutu çalıştırılır ve listeleme için alt dizinlere inilir.

Dönen Değerler

Elemanları komuta verilen yanıt metninin bir satırına karşılık gelen bir dizi döner.

Çıktı herhangi bir şekilde çözümlenmez. ftp_systype() işleviyle döndürülen sistem türü betimleyicisi sonuçların nasıl yorumlanacağına karar vermek için yararlı olabilir.

Örnekler

Örnek 1 - ftp_rawlist() örneği

<?php

// FTP sunucusuna bağlanalım
$conn = ftp_connect('ftp.example.com');
if (!$conn) die('ftp.example.com ile bağlantı kurulamadı');

// kullanıcı adı ve parola ile oturum açalım
$login_result = ftp_login($conn, $ftp_user_name, $ftp_user_pass);

// / için dosya listesini alalım
$buff = ftp_rawlist($conn, '/');

// bağlantıyı kapatalım
ftp_close($conn);

// tamponu çıktılayalım
var_dump($buff);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(3) {
  [0]=>
  string(65) "drwxr-x---   3 foo foo 4096 Jul 12 12:16 public_ftp"
  [1]=>
  string(66) "drwxr-x---  15 foo foo 4096 Nov  3 21:31 public_html"
  [2]=>
  string(73) "lrwxrwxrwx   1 foo foo   11 Jul 12 12:16 www -> public_html"
}

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.0 | ardışık değiştirgesi eklendi.

Ayrıca Bakınız

  • ftp_nlist() - Belirtilen dizindeki dosyaların listesini döndürür

ftp_raw
ftp_rename
FTP İşlevleri


FTP sunucusundaki bir dosya veya dizinin adını değiştirir

ftp_rawlist
ftp_rmdir
FTP İşlevleri
PHP Manual

ftp_rename

(PHP 4, PHP 5, PHP 7)

ftp_rename — FTP sunucusundaki bir dosya veya dizinin adını değiştirir

Açıklama

bool ftp_rename ( resource $ftp_akımı , string $eskisi , string $yenisi )

ftp_rename() işlevi, FTP sunucusundaki belirtilen dosya veya dizinin adını değiştirir.

Değiştirgeler

ftp_akımı

FTP bağlantısının bağlantı tanıtıcısı.

eskisi

Eski dosya/dizin ismi.

yenisi

Yeni dosya/dizin ismi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - ftp_rename() örneği

<?php
$eskisi = 'somefile.txt.bak';
$yenisi = 'somefile.txt';

// Temel bağlantıyı kuralım
$conn_id = ftp_connect($ftp_server);

// kullanıcı adı ve parola ile oturum açalım
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// Dosya ismini $yenisi yapalım
if (ftp_rename($conn_id, $eskisi, $yenisi)) {
 echo "$eskisi dosyasının ismi $yenisi olarak değiştirildi\n";
} else {
 echo "$eskisi dosyasını ismi $yenisi ile değiştirilirken bir sorun çıktı\n";
}

// bağlantıyı kapatalım
ftp_close($conn_id);
?>

ftp_rawlist
ftp_rmdir
FTP İşlevleri


Bir dizini siler

ftp_rename
ftp_set_option
FTP İşlevleri
PHP Manual

ftp_rmdir

(PHP 4, PHP 5, PHP 7)

ftp_rmdir — Bir dizini siler

Açıklama

bool ftp_rmdir ( resource $ftp_akımı , string $dizin )

Belirtilen dizin FTP sunucusundan silinir.

Değiştirgeler

ftp_akımı

FTP bağlantısının bağlantı tanıtıcısı.

dizin

Silinecek dizin. Mutlak bir yol olarak veya boş bir dizin için göreli bir yol olarak belirtilebilir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - ftp_rmdir() örneği

<?php

$dir = 'www/';

// Temel bağlantıyı kuralım
$conn_id = ftp_connect($ftp_server);

// kullanıcı adı ve parola ile oturum açalım
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// $dir dizinini silmeye çalışalım
if (ftp_rmdir($conn_id, $dir)) {
    echo "$dir sorunsuz silindi\n";
} else {
    echo "$dir silinirken bir sorun çıktı\n";
}

ftp_close($conn_id);

?>

Ayrıca Bakınız

  • ftp_mkdir() - FTP sunucusunda bir dizin oluşturur

ftp_rename
ftp_set_option
FTP İşlevleri


Çalışma anı seçeneklerini belirler

ftp_rmdir
ftp_site
FTP İşlevleri
PHP Manual

ftp_set_option

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

ftp_set_option — Çalışma anı seçeneklerini belirler

Açıklama

bool ftp_set_option ( resource $ftp_akımı , int $seçenek , mixed $değer )

Belirtilen FTP akımı ile ilgili seçenekleri belirler.

Değiştirgeler

ftp_akımı

FTP bağlantısının bağlantı tanıtıcısı.

seçenek

Şimdilik desteklenen seçenekler:

Desteklenen çalışma anı FTP seçenekleri
FTP_TIMEOUT_SEC | Ağ ile ilgili işlevlerde kullanılan zaman aşımını değiştirir. değer sıfırdan büyük bir tamsayı olmalıdır. Öntanımlı zaman aşımı 90 saniyedir.
FTP_AUTOSEEK | Etkin olduğunda, devam_yeri veya başlama_yeri değiştirgeli bir GET veya PUT isteğinde dosya içinde önce belirtilen konum aranır. Bu seçenek öntanımlı olarak etkindir.

değer

Bu değiştirgenin değeri seçenekler değiştirgesine göre değişir.

Dönen Değerler

Seçenek tanımlanabilmişse TRUE yoksa FALSE döner. Belirtilen seçenek desteklenmiyorsa veya belirtilen değer seçenek için uygun değilse bir uyarı verilir.

Örnekler

Örnek 1 - ftp_set_option() örneği

<?php
// Ağ zaman aşımını 10 saniye yapalım
ftp_set_option($conn_id, FTP_TIMEOUT_SEC, 10);
?>

Ayrıca Bakınız

  • ftp_get_option() - Bir çalışma anı seçeneğinin değerini döndürür

ftp_rmdir
ftp_site
FTP İşlevleri


Sunucuya bir SITE komutu gönderir

ftp_set_option
ftp_size
FTP İşlevleri
PHP Manual

ftp_site

(PHP 4, PHP 5, PHP 7)

ftp_site — Sunucuya bir SITE komutu gönderir

Açıklama

bool ftp_site ( resource $ftp_stream , string $komut )

ftp_site() işlevi FTP sunucusuna belrtilen SITE komutunu gönderir.

SITE komutları standart değildir ve sunucudan sunucuya değişiklik gösterir. Dosya izinleri, sahip ve grubu gibi şeyleri öğrenmek için yararlıdır.

Değiştirgeler

ftp_akımı

FTP bağlantısının bağlantı tanıtıcısı.

komut

Bir SITE komutu. Bu değiştirge öncelenmez. Dolayısıyla boşluk ve diğer karakterleri içeren dosya isimleri gibi şeyler sözkonusu olabilir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Bir FTP sunucusuna bir SITE komutu göndermek

<?php
// FTP sunucusuna bağlanalım
$conn = ftp_connect('ftp.example.com');
if (!$conn) die('ftp.example.com ile bağlantı kurulamadı');

// kullanıcı adı ve parola ile oturum açalım
if (!ftp_login($conn, 'user', 'pass')) die(
    'ftp.example.com üzerinde oturum açılamadı');

// Komut: "SITE CHMOD 0600 /home/user/privatefile"
if (ftp_site($conn, 'CHMOD 0600 /home/user/privatefile')) {
   echo "Komut çalıştırma işlemi başarılı oldu.\n";
} else {
   die('Komut çalıştırılamadı.');
}
?>

Ayrıca Bakınız

  • ftp_raw() - Bir FTP sunucusuna bir komut gönderir

ftp_set_option
ftp_size
FTP İşlevleri


FTP sunucusundaki bir dosyanın boyunu döndürür

ftp_site
ftp_ssl_connect
FTP İşlevleri
PHP Manual

ftp_size

(PHP 4, PHP 5, PHP 7)

ftp_size — FTP sunucusundaki bir dosyanın boyunu döndürür

Açıklama

int ftp_size ( resource $ftp_akımı , string $uzak_dosya )

ftp_size() işlevi uzak_dosya ile belirtilen dosyanın boyunu bayt cinsinden döndürür.

Bilginize:

Bazı sunucular bu özelliği desteklemez.

Değiştirgeler

ftp_akımı

FTP bağlantısının bağlantı tanıtıcısı.

uzak_dosya

Uzak dosya.

Dönen Değerler

Hata durumunda -1, yoksa dosyanın boyunu döndürür.

Örnekler

Örnek 1 - ftp_size() örneği

<?php

$dosya = 'birdosya.txt';

// Temel bağlantıyı kuralım
$conn_id = ftp_connect($ftp_server);

// kullanıcı adı ve parola ile oturum açalım
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// $dosya'nın uzunluğunu öğrenelim
$res = ftp_size($conn_id, $dosya);

if ($res != -1) {
    echo "$dosya $res baytlık";
} else {
    echo "dosya uzunluğu bilinmiyor";
}

// bağlantıyı kapatalım
ftp_close($conn_id);

?>

Ayrıca Bakınız

  • ftp_rawlist() - Belirtilen dizindeki dosyaların ayrıntılı bir listesini döndürür

ftp_site
ftp_ssl_connect
FTP İşlevleri


Güvenli bir SSL-FTP bağlantısı açar

ftp_size
ftp_systype
FTP İşlevleri
PHP Manual

ftp_ssl_connect

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

ftp_ssl_connect — Güvenli bir SSL-FTP bağlantısı açar

Açıklama

resource ftp_ssl_connect ( string $adres [, int $port = 21 [, int $zamanaşımı = 90 ]] )

adres adresindeki sunucuya bir SSL-FTP bağlantısı açar.

Bilginize: Bu işlev neden Windows'ta yok?

ftp_ssl_connect() işlevinin kullanılabilmesi için FTP ve OpenSSL eklentilerinin ikisinin de PHP içinde derlenmiş olması gerekir. Yani Windows için resmi derlenmiş PHP dağıtımlarında bu işlev tanımlı değildir. Bu işlevi Windows'ta kullanabilmek için PHP çalıştırılabilirlerini kendiniz derlemelisiniz.

Bilginize:

ftp_ssl_connect() işlevi sFTP ile kullanmak için tasarlanmamıştır. PHP ile sFTP kullanmak için ssh2_sftp() işlevine bakınız.

Değiştirgeler

adres

FTP sunucusunun adresi. Bu dizgenin bir bölü çizgisi ile bitirilmemesi ve ftp:// ile öncelenmemesi gerekir.

port

Bu değiştirge normal portun dışında bir port belirtmek için kullanılır. Verilmezse veya 0 belirtilirse öntanımlı FTP portu olan 21 kullanılır.

zamanaşımı

Bu değiştirgede her türlü ağ işlemi için zaman aşımı belirtilir. Belirtilmezse 90 saniye öntanımlı değerdir. Bu zaman aşımını istediğiniz zaman ftp_set_option() ile değiştirebilir ve ftp_get_option() ile sorgulayabilirsiniz.

Dönen Değerler

Hata durumunda FALSE yoksa bir SSL-FTP akımı döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.2.2 | Bu işlev artık SSL bağlantısı kullanamadığı zaman SSL'siz bir bağlantı kurmak yerine FALSE ile dönüyor.

Örnekler

Örnek 1 - ftp_ssl_connect() örneği

<?php

// Temel SSL bağlantısını kuralım
$conn_id = ftp_ssl_connect($ftp_server);

// kullanıcı adı ve parola ile oturum açalım
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

echo ftp_pwd($conn_id); // /

// bağlantıyı kapatalım
ftp_close($conn_id);
?>

Ayrıca Bakınız

  • ftp_connect() - Bir FTP bağlantısı açar

ftp_size
ftp_systype
FTP İşlevleri


Uzak FTP sunucusunun sistem türü tanıtıcısını döndürür

ftp_ssl_connect
Gearman
FTP İşlevleri
PHP Manual

ftp_systype

(PHP 4, PHP 5, PHP 7)

ftp_systype — Uzak FTP sunucusunun sistem türü tanıtıcısını döndürür

Açıklama

string ftp_systype ( resource $ftp_akımı )

Uzak FTP sunucusunun sistem türü tanıtıcısını döndürür.

Değiştirgeler

ftp_akımı

FTP bağlantısının bağlantı tanıtıcısı.

Dönen Değerler

Hata durumunda FALSE yoksa uzar sistemin türünü döndürür.

Örnekler

Örnek 1 - ftp_systype() örneği

<?php

// ftp bağlantısı
$ftp = ftp_connect('ftp.example.com');
ftp_login($ftp, 'user', 'password');

// sistem türünü öğrenelim
if ($type = ftp_systype($ftp)) {
    echo "Example.com $type takviyelidir.\n";
} else {
    echo "Sistem türü bulunumadı";
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Example.com UNIX takviyelidir.

ftp_ssl_connect
Gearman
FTP İşlevleri


Gearman

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
    • Basic usage
    • Basic Gearman client and worker, background
    • Basic Gearman client and worker, submitting tasks
  • GearmanClient — The GearmanClient class
    • GearmanClient::addOptions — Add client options
    • GearmanClient::addServer — Add a job server to the client
    • GearmanClient::addServers — Add a list of job servers to the client
    • GearmanClient::addTask — Add a task to be run in parallel
    • GearmanClient::addTaskBackground — Add a background task to be run in parallel
    • GearmanClient::addTaskHigh — Add a high priority task to run in parallel
    • GearmanClient::addTaskHighBackground — Add a high priority background task to be run in parallel
    • GearmanClient::addTaskLow — Add a low priority task to run in parallel
    • GearmanClient::addTaskLowBackground — Add a low priority background task to be run in parallel
    • GearmanClient::addTaskStatus — Add a task to get status
    • GearmanClient::clearCallbacks — Clear all task callback functions
    • GearmanClient::clone — Create a copy of a GearmanClient object
    • GearmanClient::__construct — Create a GearmanClient instance
    • GearmanClient::context — Get the application context
    • GearmanClient::data — Get the application data (deprecated)
    • GearmanClient::do — Run a single task and return a result [deprecated]
    • GearmanClient::doBackground — Run a task in the background
    • GearmanClient::doHigh — Run a single high priority task
    • GearmanClient::doHighBackground — Run a high priority task in the background
    • GearmanClient::doJobHandle — Get the job handle for the running task
    • GearmanClient::doLow — Run a single low priority task
    • GearmanClient::doLowBackground — Run a low priority task in the background
    • GearmanClient::doNormal — Run a single task and return a result
    • GearmanClient::doStatus — Get the status for the running task
    • GearmanClient::echo — Send data to all job servers to see if they echo it back [deprecated]
    • GearmanClient::error — Returns an error string for the last error encountered.
    • GearmanClient::getErrno — Get an errno value
    • GearmanClient::jobStatus — Get the status of a background job
    • GearmanClient::ping — Send data to all job servers to see if they echo it back
    • GearmanClient::removeOptions — Remove client options
    • GearmanClient::returnCode — Get the last Gearman return code
    • GearmanClient::runTasks — Run a list of tasks in parallel
    • GearmanClient::setClientCallback — Callback function when there is a data packet for a task (deprecated)
    • GearmanClient::setCompleteCallback — Set a function to be called on task completion
    • GearmanClient::setContext — Set application context
    • GearmanClient::setCreatedCallback — Set a callback for when a task is queued
    • GearmanClient::setData — Set application data (deprecated)
    • GearmanClient::setDataCallback — Callback function when there is a data packet for a task
    • GearmanClient::setExceptionCallback — Set a callback for worker exceptions
    • GearmanClient::setFailCallback — Set callback for job failure
    • GearmanClient::setOptions — Set client options
    • GearmanClient::setStatusCallback — Set a callback for collecting task status
    • GearmanClient::setTimeout — Set socket I/O activity timeout
    • GearmanClient::setWarningCallback — Set a callback for worker warnings
    • GearmanClient::setWorkloadCallback — Set a callback for accepting incremental data updates
    • GearmanClient::timeout — Get current socket I/O activity timeout value
  • GearmanJob — The GearmanJob class
    • GearmanJob::complete — Send the result and complete status (deprecated)
    • GearmanJob::__construct — Create a GearmanJob instance
    • GearmanJob::data — Send data for a running job (deprecated)
    • GearmanJob::exception — Send exception for running job (deprecated)
    • GearmanJob::fail — Send fail status (deprecated)
    • GearmanJob::functionName — Get function name
    • GearmanJob::handle — Get the job handle
    • GearmanJob::returnCode — Get last return code
    • GearmanJob::sendComplete — Send the result and complete status
    • GearmanJob::sendData — Send data for a running job
    • GearmanJob::sendException — Send exception for running job (exception)
    • GearmanJob::sendFail — Send fail status
    • GearmanJob::sendStatus — Send status
    • GearmanJob::sendWarning — Send a warning
    • GearmanJob::setReturn — Set a return value
    • GearmanJob::status — Send status (deprecated)
    • GearmanJob::unique — Get the unique identifier
    • GearmanJob::warning — Send a warning (deprecated)
    • GearmanJob::workload — Get workload
    • GearmanJob::workloadSize — Get size of work load
  • GearmanTask — The GearmanTask class
    • GearmanTask::__construct — Create a GearmanTask instance
    • GearmanTask::create — Create a task (deprecated)
    • GearmanTask::data — Get data returned for a task
    • GearmanTask::dataSize — Get the size of returned data
    • GearmanTask::function — Get associated function name (deprecated)
    • GearmanTask::functionName — Get associated function name
    • GearmanTask::isKnown — Determine if task is known
    • GearmanTask::isRunning — Test whether the task is currently running
    • GearmanTask::jobHandle — Get the job handle
    • GearmanTask::recvData — Read work or result data into a buffer for a task
    • GearmanTask::returnCode — Get the last return code
    • GearmanTask::sendData — Send data for a task (deprecated)
    • GearmanTask::sendWorkload — Send data for a task
    • GearmanTask::taskDenominator — Get completion percentage denominator
    • GearmanTask::taskNumerator — Get completion percentage numerator
    • GearmanTask::unique — Get the unique identifier for a task
    • GearmanTask::uuid — Get the unique identifier for a task (deprecated)
  • GearmanWorker — The GearmanWorker class
    • GearmanWorker::addFunction — Register and add callback function
    • GearmanWorker::addOptions — Add worker options
    • GearmanWorker::addServer — Add a job server
    • GearmanWorker::addServers — Add job servers
    • GearmanWorker::clone — Create a copy of the worker
    • GearmanWorker::__construct — Create a GearmanWorker instance
    • GearmanWorker::echo — Test job server response
    • GearmanWorker::error — Get the last error encountered
    • GearmanWorker::getErrno — Get errno
    • GearmanWorker::options — Get worker options
    • GearmanWorker::register — Register a function with the job server
    • GearmanWorker::removeOptions — Remove worker options
    • GearmanWorker::returnCode — Get last Gearman return code
    • GearmanWorker::setId — Give the worker an identifier so it can be tracked when asking gearmand for the list of available workers.
    • GearmanWorker::setOptions — Set worker options
    • GearmanWorker::setTimeout — Set socket I/O activity timeout
    • GearmanWorker::timeout — Get socket I/O activity timeout
    • GearmanWorker::unregister — Unregister a function name with the job servers
    • GearmanWorker::unregisterAll — Unregister all function names with the job servers
    • GearmanWorker::wait — Wait for activity from one of the job servers
    • GearmanWorker::work — Wait for and perform jobs
  • GearmanException — The GearmanException class
ftp_systype
Giriş
Diğer Hizmetler


Giriş

» Gearman is a generic application framework for farming out work to multiple machines or processes. It allows applications to complete tasks in parallel, to load balance processing, and to call functions between languages. The framework can be used in a variety of applications, from high-availability web sites to the transport of database replication events.

This extension provides classes for writing Gearman clients and workers.

Gearman
Yapılandırma/Kurulum
Gearman


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Gearman


Gereksinimler

This extension requires the » libgearman, » libevent and » uuid libraries, and a running Gearman server.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/gearman

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

Return values. Always check GearmanClient::error() or GearmanWorker() for a string error, as it may contain more details:

GEARMAN_SUCCESS (integer)
Whatever action was taken was successful.
GEARMAN_IO_WAIT (integer)
When in non-blocking mode, an event is hit that would have blocked.
GEARMAN_ERRNO (integer)
A system error. Check GearmanClient::errno() or GearmanWorker::errno() for the system error code that was returned.
GEARMAN_NO_ACTIVE_FDS (integer)
GearmanClient::wait() or GearmanWorker() was called with no connections.
GEARMAN_UNEXPECTED_PACKET (integer)
Indicates something going very wrong in gearmand. Applies only to GearmanWorker.
GEARMAN_GETADDRINFO (integer)
DNS resolution failed (invalid host, port, etc).
GEARMAN_NO_SERVERS (integer)
Did not call GearmanClient::addServer() before submitting jobs or tasks.
GEARMAN_LOST_CONNECTION (integer)
Lost a connection during a request.
GEARMAN_MEMORY_ALLOCATION_FAILURE (integer)
Memory allocation failed (ran out of memory).
GEARMAN_SERVER_ERROR (integer)
Something went wrong in the Gearman server and it could not handle the request gracefully.
GEARMAN_WORK_DATA (integer)
Notice return code obtained with GearmanClient::returnCode() when using GearmanClient::do(). Sent to update the client with data from a running job. A worker uses this when it needs to send updates, send partial results, or flush data during long running jobs.
GEARMAN_WORK_WARNING (integer)
Notice return code obtained with GearmanClient::returnCode() when using GearmanClient::do(). Updates the client with a warning. The behavior is just like GEARMAN_WORK_DATA, but should be treated as a warning instead of normal response data.
GEARMAN_WORK_STATUS (integer)
Notice return code obtained with GearmanClient::returnCode() when using GearmanClient::do(). Sent to update the status of a long running job. Use GearmanClient::doStatus() to obtain the percentage complete of the task.
GEARMAN_WORK_EXCEPTION (integer)
Notice return code obtained with GearmanClient::returnCode() when using GearmanClient::do(). Indicates that a job failed with a given exception.
GEARMAN_WORK_FAIL (integer)
Notice return code obtained with GearmanClient::returnCode() when using GearmanClient::do(). Indicates that the job failed.
GEARMAN_COULD_NOT_CONNECT (integer)
Failed to connect to servers.
GEARMAN_INVALID_FUNCTION_NAME (integer)
Trying to register a function name of NULL or using the callback interface without specifying callbacks.
GEARMAN_INVALID_WORKER_FUNCTION (integer)
Trying to register a function with a NULL callback function.
GEARMAN_NO_REGISTERED_FUNCTIONS (integer)
When a worker gets a job for a function it did not register.
GEARMAN_NO_JOBS (integer)
For a non-blocking worker, when GearmanWorker::work() does not have any active jobs.
GEARMAN_ECHO_DATA_CORRUPTION (integer)
After GearmanClient::echo() or GearmanWorker::echo() the data returned doesn't match the data sent.
GEARMAN_NEED_WORKLOAD_FN (integer)
When the client opted to stream the workload of a task, but did not specify a workload callback function.
GEARMAN_PAUSE (integer)
For the non-blocking client task interface, can be returned from the task callback to "pause" the call and return from GearmanClient::runTasks(). Call GearmanClient::runTasks() again to continue.
GEARMAN_UNKNOWN_STATE (integer)
Internal client/worker state error.
GEARMAN_SEND_BUFFER_TOO_SMALL (integer)
Internal error: trying to flush more data in one atomic chunk than is possible due to hard-coded buffer sizes.
GEARMAN_TIMEOUT (integer)
Hit the timeout limit set by the client/worker.

GearmanClient options:

GEARMAN_CLIENT_GENERATE_UNIQUE (integer)
Generate a unique id (UUID) for each task.
GEARMAN_CLIENT_NON_BLOCKING (integer)
Run the cient in a non-blocking mode.
GEARMAN_CLIENT_UNBUFFERED_RESULT (integer)
Allow the client to read data in chunks rather than have the library buffer the entire data result and pass that back.
GEARMAN_CLIENT_FREE_TASKS (integer)
Automatically free task objects once they are complete. This is the default setting in this extension to prevent memory leaks.

GearmanWorker options:

GEARMAN_WORKER_NON_BLOCKING (integer)
Run the worker in non-blocking mode.
GEARMAN_WORKER_GRAB_UNIQ (integer)
Return the client assigned unique ID in addition to the job handle.

Base Gearman configuration:

GEARMAN_DEFAULT_TCP_HOST (string)
GEARMAN_DEFAULT_TCP_PORT (integer)
GEARMAN_DEFAULT_SOCKET_TIMEOUT (integer)
GEARMAN_DEFAULT_SOCKET_SEND_SIZE (integer)
GEARMAN_DEFAULT_SOCKET_RECV_SIZE (integer)
GEARMAN_MAX_ERROR_SIZE (integer)
GEARMAN_PACKET_HEADER_SIZE (integer)
GEARMAN_JOB_HANDLE_SIZE (integer)
GEARMAN_OPTION_SIZE (integer)
GEARMAN_UNIQUE_SIZE (integer)
GEARMAN_MAX_COMMAND_ARGS (integer)
GEARMAN_ARGS_BUFFER_SIZE (integer)
GEARMAN_SEND_BUFFER_SIZE (integer)
GEARMAN_RECV_BUFFER_SIZE (integer)
GEARMAN_WORKER_WAIT_TIMEOUT (integer)

Özkaynak Türleri
Örnekler
Gearman


Örnekler

İçindekiler

  • Basic usage
  • Basic Gearman client and worker, background
  • Basic Gearman client and worker, submitting tasks
Öntanımlı Sabitler
Basic usage
Gearman


Basic usage

Örnek 1 Basic Gearman client and worker

This example shows a very simple client and worker. The client sends a string to the job server, and the worker reverses the string and sends it back. The job is performed synchronously.

<?php

# Create our client object.
$gmclient= new GearmanClient();

# Add default server (localhost).
$gmclient->addServer();

echo "Sending job\n";

# Send reverse job
do
{
  $result = $gmclient->doNormal("reverse", "Hello!");

  # Check for various return packets and errors.
  switch($gmclient->returnCode())
  {
    case GEARMAN_WORK_DATA:
      echo "Data: $result\n";
      break;
    case GEARMAN_WORK_STATUS:
      list($numerator, $denominator)= $gmclient->doStatus();
      echo "Status: $numerator/$denominator complete\n";
      break;
    case GEARMAN_WORK_FAIL:
      echo "Failed\n";
      exit;
    case GEARMAN_SUCCESS:
      echo "Success: $result\n";
      break;
    default:
      echo "RET: " . $gmclient->returnCode() . "\n";
      exit;
  }
}
while($gmclient->returnCode() != GEARMAN_SUCCESS);

?>
<?php

echo "Starting\n";

# Create our worker object.
$gmworker= new GearmanWorker();

# Add default server (localhost).
$gmworker->addServer();

# Register function "reverse" with the server. Change the worker function to
# "reverse_fn_fast" for a faster worker with no output.
$gmworker->addFunction("reverse", "reverse_fn");

print "Waiting for job...\n";
while($gmworker->work())
{
  if ($gmworker->returnCode() != GEARMAN_SUCCESS)
  {
    echo "return_code: " . $gmworker->returnCode() . "\n";
    break;
  }
}

function reverse_fn($job)
{
  echo "Received job: " . $job->handle() . "\n";

  $workload = $job->workload();
  $workload_size = $job->workloadSize();

  echo "Workload: $workload ($workload_size)\n";

  # This status loop is not needed, just showing how it works
  for ($x= 0; $x < $workload_size; $x++)
  {
    echo "Sending status: " . ($x + 1) . "/$workload_size complete\n";
    $job->sendStatus($x, $workload_size);
    sleep(1);
  }

  $result= strrev($workload);
  echo "Result: $result\n";

  # Return what we want to send back to the client.
  return $result;
}

# A much simpler and less verbose version of the above function would be:
function reverse_fn_fast($job)
{
  return strrev($job->workload());
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

% php reverse_worker.php
Starting
Waiting for job...
Received job: H:foo.local:36
Workload: Hello! (6)
Sending status: 1/6 complete
Sending status: 2/6 complete
Sending status: 3/6 complete
Sending status: 4/6 complete
Sending status: 5/6 complete
Sending status: 6/6 complete
Result: !olleH

% php reverse_client.php
Starting
Sending job
Status: 1/6 complete
Status: 2/6 complete
Status: 3/6 complete
Status: 4/6 complete
Status: 5/6 complete
Status: 6/6 complete
Success: !olleH

Örnekler
Basic Gearman client and worker, background
Örnekler


Basic Gearman client and worker, background

Örnek 1 Basic Gearman client and worker, background

This example shows a very simple client and worker. The client sends a string to the job server as a background job, and the worker reverses the string. Note that since the work is performed asynchronously, the client does not wait for the job to complete and exits (and hence the client never receives the results).

<?php

# create our client object
$gmclient= new GearmanClient();

# add the default server (localhost)
$gmclient->addServer();

# run reverse client in the background
$job_handle = $gmclient->doBackground("reverse", "this is a test");

if ($gmclient->returnCode() != GEARMAN_SUCCESS)
{
  echo "bad return code\n";
  exit;
}

echo "done!\n";

?>
<?php

echo "Starting\n";

# Create our worker object.
$gmworker= new GearmanWorker();

# Add default server (localhost).
$gmworker->addServer();

# Register function "reverse" with the server. Change the worker function to
# "reverse_fn_fast" for a faster worker with no output.
$gmworker->addFunction("reverse", "reverse_fn");

print "Waiting for job...\n";
while($gmworker->work())
{
  if ($gmworker->returnCode() != GEARMAN_SUCCESS)
  {
    echo "return_code: " . $gmworker->returnCode() . "\n";
    break;
  }
}

function reverse_fn($job)
{
  echo "Received job: " . $job->handle() . "\n";

  $workload = $job->workload();
  $workload_size = $job->workloadSize();

  echo "Workload: $workload ($workload_size)\n";

  # This status loop is not needed, just showing how it works
  for ($x= 0; $x < $workload_size; $x++)
  {
    echo "Sending status: " . ($x + 1) . "/$workload_size complete\n";
    $job->sendStatus($x, $workload_size);
    sleep(1);
  }

  $result= strrev($workload);
  echo "Result: $result\n";

  # Return what we want to send back to the client.
  return $result;
}

# A much simpler and less verbose version of the above function would be:
function reverse_fn_fast($job)
{
  return strrev($job->workload());
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

% php reverse_worker.php
Starting
Waiting for job...
Received job: H:foo.local:41
Workload: this is a test (14)
1/14 complete
2/14 complete
3/14 complete
4/14 complete
5/14 complete
6/14 complete
7/14 complete
8/14 complete
9/14 complete
10/14 complete
11/14 complete
12/14 complete
13/14 complete
14/14 complete
Result: tset a si siht

% php reverse_client_bg.php
done!

Basic usage
Basic Gearman client and worker, submitting tasks
Örnekler


Basic Gearman client and worker, submitting tasks

Örnek 1 Basic Gearman client and worker, submitting tasks

In this example, the basic reverse client extended to run two tasks in parallel. The reverse worker is unchanged except to add sending of data back during processing.

<?php

# create the gearman client
$gmc= new GearmanClient();

# add the default server (localhost)
$gmc->addServer();

# register some callbacks
$gmc->setCreatedCallback("reverse_created");
$gmc->setDataCallback("reverse_data");
$gmc->setStatusCallback("reverse_status");
$gmc->setCompleteCallback("reverse_complete");
$gmc->setFailCallback("reverse_fail");

# set some arbitrary application data
$data['foo'] = 'bar';

# add two tasks
$task= $gmc->addTask("reverse", "foo", $data);
$task2= $gmc->addTaskLow("reverse", "bar", NULL);

# run the tasks in parallel (assuming multiple workers)
if (! $gmc->runTasks())
{
    echo "ERROR " . $gmc->error() . "\n";
    exit;
}

echo "DONE\n";

function reverse_created($task)
{
    echo "CREATED: " . $task->jobHandle() . "\n";
}

function reverse_status($task)
{
    echo "STATUS: " . $task->jobHandle() . " - " . $task->taskNumerator() .
         "/" . $task->taskDenominator() . "\n";
}

function reverse_complete($task)
{
    echo "COMPLETE: " . $task->jobHandle() . ", " . $task->data() . "\n";
}

function reverse_fail($task)
{
    echo "FAILED: " . $task->jobHandle() . "\n";
}

function reverse_data($task)
{
    echo "DATA: " . $task->data() . "\n";
}

?>
<?php

echo "Starting\n";

# Create our worker object.
$gmworker= new GearmanWorker();

# Add default server (localhost).
$gmworker->addServer();

# Register function "reverse" with the server. Change the worker function to
# "reverse_fn_fast" for a faster worker with no output.
$gmworker->addFunction("reverse", "reverse_fn");

print "Waiting for job...\n";
while($gmworker->work())
{
  if ($gmworker->returnCode() != GEARMAN_SUCCESS)
  {
    echo "return_code: " . $gmworker->returnCode() . "\n";
    break;
  }
}

function reverse_fn($job)
{
  echo "Received job: " . $job->handle() . "\n";

  $workload = $job->workload();
  $workload_size = $job->workloadSize();

  echo "Workload: $workload ($workload_size)\n";

  # This status loop is not needed, just showing how it works
  for ($x= 0; $x < $workload_size; $x++)
  {
    echo "Sending status: " . ($x + 1) . "/$workload_size complete\n";
    $job->sendStatus($x+1, $workload_size);
    $job->sendData(substr($workload, $x, 1));
    sleep(1);
  }

  $result= strrev($workload);
  echo "Result: $result\n";

  # Return what we want to send back to the client.
  return $result;
}

# A much simpler and less verbose version of the above function would be:
function reverse_fn_fast($job)
{
  return strrev($job->workload());
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

% php reverse_worker.php
Starting
Waiting for job...
Received job: H:foo.local:45
Workload: foo (3)
1/3 complete
2/3 complete
3/3 complete
Result: oof
Received job: H:foo.local:44
Workload: bar (3)
1/3 complete
2/3 complete
3/3 complete
Result: rab

% php reverse_client_task.php
CREATED: H:foo.local:44
CREATED: H:foo.local:45
STATUS: H:foo.local:45 - 1/3
DATA: f
STATUS: H:foo.local:45 - 2/3
DATA: o
STATUS: H:foo.local:45 - 3/3
DATA: o
COMPLETE: H:foo.local:45, oof
STATUS: H:foo.local:44 - 1/3
DATA: b
STATUS: H:foo.local:44 - 2/3
DATA: a
STATUS: H:foo.local:44 - 3/3
DATA: r
COMPLETE: H:foo.local:44, rab
DONE

Basic Gearman client and worker, background
GearmanClient
Örnekler


The GearmanClient class

(PECL gearman >= 0.5.0)

Giriş

Represents a class for connecting to a Gearman job server and making requests to perform some function on provided data. The function performed must be one registered by a Gearman worker and the data passed is opaque to the job server.

Sınıf Sözdizimi

GearmanClient {
/* Yöntemler */
public bool addOptions ( int $options )
public bool addServer ([ string $host = 127.0.0.1 [, int $port = 4730 ]] )
public bool addServers ([ string $servers = 127.0.0.1:4730 ] )
public GearmanTask addTask ( string $function_name , string $workload [, mixed &$context [, string $unique ]] )
public GearmanTask addTaskBackground ( string $function_name , string $workload [, mixed &$context [, string $unique ]] )
public GearmanTask addTaskHigh ( string $function_name , string $workload [, mixed &$context [, string $unique ]] )
public GearmanTask addTaskHighBackground ( string $function_name , string $workload [, mixed &$context [, string $unique ]] )
public GearmanTask addTaskLow ( string $function_name , string $workload [, mixed &$context [, string $unique ]] )
public GearmanTask addTaskLowBackground ( string $function_name , string $workload [, mixed &$context [, string $unique ]] )
public GearmanTask addTaskStatus ( string $job_handle [, string &$context ] )
public bool clearCallbacks ( void )
public GearmanClient clone ( void )
public __construct ( void )
public string context ( void )
public string data ( void )
public string do ( string $function_name , string $workload [, string $unique ] )
public string doBackground ( string $function_name , string $workload [, string $unique ] )
public string doHigh ( string $function_name , string $workload [, string $unique ] )
public string doHighBackground ( string $function_name , string $workload [, string $unique ] )
public string doJobHandle ( void )
public string doLow ( string $function_name , string $workload [, string $unique ] )
public string doLowBackground ( string $function_name , string $workload [, string $unique ] )
public string doNormal ( string $function_name , string $workload [, string $unique ] )
public array doStatus ( void )
public bool echo ( string $workload )
public string error ( void )
public int getErrno ( void )
public array jobStatus ( string $job_handle )
public bool ping ( string $workload )
public bool removeOptions ( int $options )
public int returnCode ( void )
public bool runTasks ( void )
public void setClientCallback ( callable $callback )
public bool setCompleteCallback ( callable $callback )
public bool setContext ( string $context )
public bool setCreatedCallback ( string $callback )
public bool setData ( string $data )
public bool setDataCallback ( callable $callback )
public bool setExceptionCallback ( callable $callback )
public bool setFailCallback ( callable $callback )
public bool setOptions ( int $options )
public bool setStatusCallback ( callable $callback )
public bool setTimeout ( int $timeout )
public bool setWarningCallback ( callable $callback )
public bool setWorkloadCallback ( callable $callback )
public int timeout ( void )
}

İçindekiler

  • GearmanClient::addOptions — Add client options
  • GearmanClient::addServer — Add a job server to the client
  • GearmanClient::addServers — Add a list of job servers to the client
  • GearmanClient::addTask — Add a task to be run in parallel
  • GearmanClient::addTaskBackground — Add a background task to be run in parallel
  • GearmanClient::addTaskHigh — Add a high priority task to run in parallel
  • GearmanClient::addTaskHighBackground — Add a high priority background task to be run in parallel
  • GearmanClient::addTaskLow — Add a low priority task to run in parallel
  • GearmanClient::addTaskLowBackground — Add a low priority background task to be run in parallel
  • GearmanClient::addTaskStatus — Add a task to get status
  • GearmanClient::clearCallbacks — Clear all task callback functions
  • GearmanClient::clone — Create a copy of a GearmanClient object
  • GearmanClient::__construct — Create a GearmanClient instance
  • GearmanClient::context — Get the application context
  • GearmanClient::data — Get the application data (deprecated)
  • GearmanClient::do — Run a single task and return a result [deprecated]
  • GearmanClient::doBackground — Run a task in the background
  • GearmanClient::doHigh — Run a single high priority task
  • GearmanClient::doHighBackground — Run a high priority task in the background
  • GearmanClient::doJobHandle — Get the job handle for the running task
  • GearmanClient::doLow — Run a single low priority task
  • GearmanClient::doLowBackground — Run a low priority task in the background
  • GearmanClient::doNormal — Run a single task and return a result
  • GearmanClient::doStatus — Get the status for the running task
  • GearmanClient::echo — Send data to all job servers to see if they echo it back [deprecated]
  • GearmanClient::error — Returns an error string for the last error encountered.
  • GearmanClient::getErrno — Get an errno value
  • GearmanClient::jobStatus — Get the status of a background job
  • GearmanClient::ping — Send data to all job servers to see if they echo it back
  • GearmanClient::removeOptions — Remove client options
  • GearmanClient::returnCode — Get the last Gearman return code
  • GearmanClient::runTasks — Run a list of tasks in parallel
  • GearmanClient::setClientCallback — Callback function when there is a data packet for a task (deprecated)
  • GearmanClient::setCompleteCallback — Set a function to be called on task completion
  • GearmanClient::setContext — Set application context
  • GearmanClient::setCreatedCallback — Set a callback for when a task is queued
  • GearmanClient::setData — Set application data (deprecated)
  • GearmanClient::setDataCallback — Callback function when there is a data packet for a task
  • GearmanClient::setExceptionCallback — Set a callback for worker exceptions
  • GearmanClient::setFailCallback — Set callback for job failure
  • GearmanClient::setOptions — Set client options
  • GearmanClient::setStatusCallback — Set a callback for collecting task status
  • GearmanClient::setTimeout — Set socket I/O activity timeout
  • GearmanClient::setWarningCallback — Set a callback for worker warnings
  • GearmanClient::setWorkloadCallback — Set a callback for accepting incremental data updates
  • GearmanClient::timeout — Get current socket I/O activity timeout value
Basic Gearman client and worker, submitting tasks
GearmanClient::addOptions
Gearman


Add client options

GearmanClient
GearmanClient::addServer
GearmanClient
PHP Manual

GearmanClient::addOptions

(PECL gearman >= 0.6.0)

GearmanClient::addOptions — Add client options

Açıklama

public bool GearmanClient::addOptions ( int $options )

Adds one or more options to those already set.

Değiştirgeler

options

The options to add. One of the following constants, or a combination of them using the bitwise OR operator ("|"): GEARMAN_CLIENT_GENERATE_UNIQUE, GEARMAN_CLIENT_NON_BLOCKING, GEARMAN_CLIENT_UNBUFFERED_RESULT or GEARMAN_CLIENT_FREE_TASKS.

Dönen Değerler

Always returns TRUE.

GearmanClient
GearmanClient::addServer
GearmanClient


Add a job server to the client

GearmanClient::addOptions
GearmanClient::addServers
GearmanClient
PHP Manual

GearmanClient::addServer

(PECL gearman >= 0.5.0)

GearmanClient::addServer — Add a job server to the client

Açıklama

public bool GearmanClient::addServer ([ string $host = 127.0.0.1 [, int $port = 4730 ]] )

Adds a job server to a list of servers that can be used to run a task. No socket I/O happens here; the server is simply added to the list.

Değiştirgeler

host

The job server host name.

port

The job server port.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Adding two job servers

<?php

# Create our client object.
$gmclient= new GearmanClient();

# Add two job servers, the first on the default 4730 port
$gmclient->addServer("10.0.0.1");
$gmclient->addServer("10.0.0.2", 7003);

?>

Ayrıca Bakınız

  • GearmanClient::addServers() - Add a list of job servers to the client

GearmanClient::addOptions
GearmanClient::addServers
GearmanClient


Add a list of job servers to the client

GearmanClient::addServer
GearmanClient::addTask
GearmanClient
PHP Manual

GearmanClient::addServers

(PECL gearman >= 0.5.0)

GearmanClient::addServers — Add a list of job servers to the client

Açıklama

public bool GearmanClient::addServers ([ string $servers = 127.0.0.1:4730 ] )

Adds a list of job servers that can be used to run a task. No socket I/O happens here; the servers are simply added to the full list of servers.

Değiştirgeler

servers

A comma-separated list of servers, each server specified in the format 'host:port'.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Add two job servers

<?php

# Create our client object.
$gmclient= new GearmanClient();

# Add multiple job servers, the first on the default 4730 port
$gmclient->addServers("10.0.0.1,10.0.0.2:7003");

?>

Ayrıca Bakınız

  • GearmanClient::addServer() - Add a job server to the client

GearmanClient::addServer
GearmanClient::addTask
GearmanClient


Add a task to be run in parallel

GearmanClient::addServers
GearmanClient::addTaskBackground
GearmanClient
PHP Manual

GearmanClient::addTask

(PECL gearman >= 0.5.0)

GearmanClient::addTask — Add a task to be run in parallel

Açıklama

public GearmanTask GearmanClient::addTask ( string $function_name , string $workload [, mixed &$context [, string $unique ]] )

Adds a task to be run in parallel with other tasks. Call this method for all the tasks to be run in parallel, then call GearmanClient::runTasks() to perform the work. Note that enough workers need to be available for the tasks to all run in parallel.

Değiştirgeler

function_name

A registered function the worker is to execute

workload

Serialized data to be processed

context

Application context to associate with a task

unique

A unique ID used to identify a particular task

Dönen Değerler

A GearmanTask object or FALSE if the task could not be added.

Örnekler

Örnek 1 Basic submission of two tasks

<?php

# Create our gearman client
$gmclient= new GearmanClient();

# add the default job server
$gmclient->addServer();

# set a function to be called when the work is complete
$gmclient->setCompleteCallback("complete");

# add a task to perform the "reverse" function on the string "Hello World!"
$gmclient->addTask("reverse", "Hello World!", null, "1");

# add another task to perform the "reverse" function on the string "!dlroW olleH"
$gmclient->addTask("reverse", "!dlroW olleH", null, "2");

# run the tasks
$gmclient->runTasks();

function complete($task)
{
  print "COMPLETE: " . $task->unique() . ", " . $task->data() . "\n";
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

COMPLETE: 2, Hello World!
COMPLETE: 1, !dlroW olleH

Örnek 2 Basic submission of two tasks with passing application context

<?php

$client = new GearmanClient();
$client->addServer();

# set a function to be called when the work is complete
$client->setCompleteCallback("reverse_complete");

# Add some tasks for a placeholder of where to put the results
$results = array();
$client->addTask("reverse", "Hello World!", &$results, "t1");
$client->addTask("reverse", "!dlroW olleH", &$results, "t2");

$client->runTasks();

# The results should now be filled in from the callbacks
foreach ($results as $id => $result)
   echo $id . ": " . $result['handle'] . ", " . $result['data'] . "\n";

function reverse_complete($task, $results)
{
   $results[$task->unique()] = array("handle"=>$task->jobHandle(), "data"=>$task->data());
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

t2: H.foo:21, Hello World!
t1: H:foo:22, !dlroW olleH

Ayrıca Bakınız

  • GearmanClient::addTaskHigh() - Add a high priority task to run in parallel
  • GearmanClient::addTaskLow() - Add a low priority task to run in parallel
  • GearmanClient::addTaskBackground() - Add a background task to be run in parallel
  • GearmanClient::addTaskHighBackground() - Add a high priority background task to be run in parallel
  • GearmanClient::addTaskLowBackground() - Add a low priority background task to be run in parallel
  • GearmanClient::runTasks() - Run a list of tasks in parallel

GearmanClient::addServers
GearmanClient::addTaskBackground
GearmanClient


Add a background task to be run in parallel

GearmanClient::addTask
GearmanClient::addTaskHigh
GearmanClient
PHP Manual

GearmanClient::addTaskBackground

(PECL gearman >= 0.5.0)

GearmanClient::addTaskBackground — Add a background task to be run in parallel

Açıklama

public GearmanTask GearmanClient::addTaskBackground ( string $function_name , string $workload [, mixed &$context [, string $unique ]] )

Adds a background task to be run in parallel with other tasks. Call this method for all the tasks to be run in parallel, then call GearmanClient::runTasks() to perform the work.

Değiştirgeler

function_name

A registered function the worker is to execute

workload

Serialized data to be processed

context

Application context to associate with a task

unique

A unique ID used to identify a particular task

Dönen Değerler

A GearmanTask object or FALSE if the task could not be added.

Örnekler

Örnek 1 Two tasks, one background and one not

This example illustrates the difference between running a background task and a normal task. The client adds two tasks to execute the same function, but one is added with addTaskBackground(). A callback is set so that progress of the job can be tracked. A simple worker with an artificial delay reports on the job progress and the client picks this up through the callback. Two workers are run for this example. Note that the background task does not show in the client output.

<?php

# The client script

# create our gearman client
$gmc= new GearmanClient();

# add the default job server
$gmc->addServer();

# set a couple of callbacks so we can track progress
$gmc->setCompleteCallback("reverse_complete");
$gmc->setStatusCallback("reverse_status");

# add a task for the "reverse" function
$task= $gmc->addTask("reverse", "Hello World!", null, "1");

# add another task, but this one to run in the background
$task= $gmc->addTaskBackground("reverse", "!dlroW olleH", null, "2");

if (! $gmc->runTasks())
{
    echo "ERROR " . $gmc->error() . "\n";
    exit;
}

echo "DONE\n";

function reverse_status($task)
{
    echo "STATUS: " . $task->unique() . ", " . $task->jobHandle() . " - " . $task->taskNumerator() .
         "/" . $task->taskDenominator() . "\n";
}

function reverse_complete($task)
{
    echo "COMPLETE: " . $task->unique() . ", " . $task->data() . "\n";
}

?>
<?php

# The worker script

echo "Starting\n";

# Create our worker object.
$gmworker= new GearmanWorker();

# Add default server (localhost).
$gmworker->addServer();

# Register function "reverse" with the server.
$gmworker->addFunction("reverse", "reverse_fn");

print "Waiting for job...\n";
while($gmworker->work())
{
  if ($gmworker->returnCode() != GEARMAN_SUCCESS)
  {
    echo "return_code: " . $gmworker->returnCode() . "\n";
    break;
  }
}

function reverse_fn($job)
{
  echo "Received job: " . $job->handle() . "\n";

  $workload = $job->workload();
  $workload_size = $job->workloadSize();

  echo "Workload: $workload ($workload_size)\n";

  # This status loop is not needed, just showing how it works
  for ($x= 0; $x < $workload_size; $x++)
  {
    echo "Sending status: " . ($x + 1) . "/$workload_size complete\n";
    $job->sendStatus($x+1, $workload_size);
    $job->sendData(substr($workload, $x, 1));
    sleep(1);
  }

  $result= strrev($workload);
  echo "Result: $result\n";

  # Return what we want to send back to the client.
  return $result;
}

?>

Worker output for two workers running:

Received job: H:foo.local:65
Workload: !dlroW olleH (12)
1/12 complete
Received job: H:foo.local:66
Workload: Hello World! (12)
Sending status: 1/12 complete
Sending status: 2/12 complete
Sending status: 2/12 complete
Sending status: 3/12 complete
Sending status: 3/12 complete
Sending status: 4/12 complete
Sending status: 4/12 complete
Sending status: 5/12 complete
Sending status: 5/12 complete
Sending status: 6/12 complete
Sending status: 6/12 complete
Sending status: 7/12 complete
Sending status: 7/12 complete
Sending status: 8/12 complete
Sending status: 8/12 complete
Sending status: 9/12 complete
Sending status: 9/12 complete
Sending status: 10/12 complete
Sending status: 10/12 complete
Sending status: 11/12 complete
Sending status: 11/12 complete
Sending status: 12/12 complete
Sending status: 12/12 complete
Result: !dlroW olleH
Result: Hello World!

Client output:

STATUS: 1, H:foo.local:66 - 1/12
STATUS: 1, H:foo.local:66 - 2/12
STATUS: 1, H:foo.local:66 - 3/12
STATUS: 1, H:foo.local:66 - 4/12
STATUS: 1, H:foo.local:66 - 5/12
STATUS: 1, H:foo.local:66 - 6/12
STATUS: 1, H:foo.local:66 - 7/12
STATUS: 1, H:foo.local:66 - 8/12
STATUS: 1, H:foo.local:66 - 9/12
STATUS: 1, H:foo.local:66 - 10/12
STATUS: 1, H:foo.local:66 - 11/12
STATUS: 1, H:foo.local:66 - 12/12
COMPLETE: 1, !dlroW olleH
DONE

Ayrıca Bakınız

  • GearmanClient::addTask() - Add a task to be run in parallel
  • GearmanClient::addTaskHigh() - Add a high priority task to run in parallel
  • GearmanClient::addTaskLow() - Add a low priority task to run in parallel
  • GearmanClient::addTaskHighBackground() - Add a high priority background task to be run in parallel
  • GearmanClient::addTaskLowBackground() - Add a low priority background task to be run in parallel
  • GearmanClient::runTasks() - Run a list of tasks in parallel

GearmanClient::addTask
GearmanClient::addTaskHigh
GearmanClient


Add a high priority task to run in parallel

GearmanClient::addTaskBackground
GearmanClient::addTaskHighBackground
GearmanClient
PHP Manual

GearmanClient::addTaskHigh

(PECL gearman >= 0.5.0)

GearmanClient::addTaskHigh — Add a high priority task to run in parallel

Açıklama

public GearmanTask GearmanClient::addTaskHigh ( string $function_name , string $workload [, mixed &$context [, string $unique ]] )

Adds a high priority task to be run in parallel with other tasks. Call this method for all the high priority tasks to be run in parallel, then call GearmanClient::runTasks() to perform the work. Tasks with a high priority will be selected from the queue before those of normal or low priority.

Değiştirgeler

function_name

A registered function the worker is to execute

workload

Serialized data to be processed

context

Application context to associate with a task

unique

A unique ID used to identify a particular task

Dönen Değerler

A GearmanTask object or FALSE if the task could not be added.

Örnekler

Örnek 1 A high priority task along with two normal tasks

A high priority task is included among two other tasks. A single worker is available, so that tasks are run one at a time, with the high priority task run first.

<?php

# create the gearman client
$gmc= new GearmanClient();

# add the default job server
$gmc->addServer();

# set the callback for when the job is complete
$gmc->setCompleteCallback("reverse_complete");

# add tasks, one of which is high priority
$task= $gmc->addTask("reverse", "Hello World!", null, "1");
$task= $gmc->addTaskHigh("reverse", "!dlroW olleH", null, "2");
$task= $gmc->addTask("reverse", "Hello World!", null, "3");

if (! $gmc->runTasks())
{
    echo "ERROR " . $gmc->error() . "\n";
    exit;
}
echo "DONE\n";

function reverse_complete($task)
{
    echo "COMPLETE: " . $task->unique() . ", " . $task->data() . "\n";
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

COMPLETE: 2, Hello World!
COMPLETE: 3, !dlroW olleH
COMPLETE: 1, !dlroW olleH
DONE

Ayrıca Bakınız

  • GearmanClient::addTask() - Add a task to be run in parallel
  • GearmanClient::addTaskLow() - Add a low priority task to run in parallel
  • GearmanClient::addTaskBackground() - Add a background task to be run in parallel
  • GearmanClient::addTaskHighBackground() - Add a high priority background task to be run in parallel
  • GearmanClient::addTaskLowBackground() - Add a low priority background task to be run in parallel
  • GearmanClient::runTasks() - Run a list of tasks in parallel

GearmanClient::addTaskBackground
GearmanClient::addTaskHighBackground
GearmanClient


Add a high priority background task to be run in parallel

GearmanClient::addTaskHigh
GearmanClient::addTaskLow
GearmanClient
PHP Manual

GearmanClient::addTaskHighBackground

(PECL gearman >= 0.5.0)

GearmanClient::addTaskHighBackground — Add a high priority background task to be run in parallel

Açıklama

public GearmanTask GearmanClient::addTaskHighBackground ( string $function_name , string $workload [, mixed &$context [, string $unique ]] )

Adds a high priority background task to be run in parallel with other tasks. Call this method for all the tasks to be run in parallel, then call GearmanClient::runTasks() to perform the work. Tasks with a high priority will be selected from the queue before those of normal or low priority.

Değiştirgeler

function_name

A registered function the worker is to execute

workload

Serialized data to be processed

context

Application context to associate with a task

unique

A unique ID used to identify a particular task

Dönen Değerler

A GearmanTask object or FALSE if the task could not be added.

Ayrıca Bakınız

  • GearmanClient::addTask() - Add a task to be run in parallel
  • GearmanClient::addTaskHigh() - Add a high priority task to run in parallel
  • GearmanClient::addTaskLow() - Add a low priority task to run in parallel
  • GearmanClient::addTaskBackground() - Add a background task to be run in parallel
  • GearmanClient::addTaskLowBackground() - Add a low priority background task to be run in parallel
  • GearmanClient::runTasks() - Run a list of tasks in parallel

GearmanClient::addTaskHigh
GearmanClient::addTaskLow
GearmanClient


Add a low priority task to run in parallel

GearmanClient::addTaskHighBackground
GearmanClient::addTaskLowBackground
GearmanClient
PHP Manual

GearmanClient::addTaskLow

(PECL gearman >= 0.5.0)

GearmanClient::addTaskLow — Add a low priority task to run in parallel

Açıklama

public GearmanTask GearmanClient::addTaskLow ( string $function_name , string $workload [, mixed &$context [, string $unique ]] )

Adds a low priority background task to be run in parallel with other tasks. Call this method for all the tasks to be run in parallel, then call GearmanClient::runTasks() to perform the work. Tasks with a low priority will be selected from the queue after those of normal or low priority.

Değiştirgeler

function_name

A registered function the worker is to execute

workload

Serialized data to be processed

context

Application context to associate with a task

unique

A unique ID used to identify a particular task

Dönen Değerler

A GearmanTask object or FALSE if the task could not be added.

Örnekler

Örnek 1 A low priority task along with two normal tasks

A low priority task is included among two other tasks. A single worker is available, so that tasks are run one at a time, with the low priority task run last.

<?php

# create the gearman client
$gmc= new GearmanClient();

# add the default job server
$gmc->addServer();

# set the callback for when the job is complete
$gmc->setCompleteCallback("reverse_complete");

# add tasks, one of which is low priority
$task= $gmc->addTask("reverse", "Hello World!", null, "1");
$task= $gmc->addTaskLow("reverse", "!dlroW olleH", null, "2");
$task= $gmc->addTask("reverse", "Hello World!", null, "3");

if (! $gmc->runTasks())
{
    echo "ERROR " . $gmc->error() . "\n";
    exit;
}
echo "DONE\n";

function reverse_complete($task)
{
    echo "COMPLETE: " . $task->unique() . ", " . $task->data() . "\n";
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

COMPLETE: 3, !dlroW olleH
COMPLETE: 1, !dlroW olleH
COMPLETE: 2, Hello World!
DONE

Ayrıca Bakınız

  • GearmanClient::addTask() - Add a task to be run in parallel
  • GearmanClient::addTaskHigh() - Add a high priority task to run in parallel
  • GearmanClient::addTaskBackground() - Add a background task to be run in parallel
  • GearmanClient::addTaskHighBackground() - Add a high priority background task to be run in parallel
  • GearmanClient::addTaskLowBackground() - Add a low priority background task to be run in parallel
  • GearmanClient::runTasks() - Run a list of tasks in parallel

GearmanClient::addTaskHighBackground
GearmanClient::addTaskLowBackground
GearmanClient


Add a low priority background task to be run in parallel

GearmanClient::addTaskLow
GearmanClient::addTaskStatus
GearmanClient
PHP Manual

GearmanClient::addTaskLowBackground

(PECL gearman >= 0.5.0)

GearmanClient::addTaskLowBackground — Add a low priority background task to be run in parallel

Açıklama

public GearmanTask GearmanClient::addTaskLowBackground ( string $function_name , string $workload [, mixed &$context [, string $unique ]] )

Adds a low priority background task to be run in parallel with other tasks. Call this method for all the tasks to be run in parallel, then call GearmanClient::runTasks() to perform the work. Tasks with a low priority will be selected from the queue after those of normal or high priority.

Değiştirgeler

function_name

A registered function the worker is to execute

workload

Serialized data to be processed

context

Application context to associate with a task

unique

A unique ID used to identify a particular task

Dönen Değerler

A GearmanTask object or FALSE if the task could not be added.

Ayrıca Bakınız

  • GearmanClient::addTask() - Add a task to be run in parallel
  • GearmanClient::addTaskHigh() - Add a high priority task to run in parallel
  • GearmanClient::addTaskLow() - Add a low priority task to run in parallel
  • GearmanClient::addTaskBackground() - Add a background task to be run in parallel
  • GearmanClient::addTaskHighBackground() - Add a high priority background task to be run in parallel
  • GearmanClient::runTasks() - Run a list of tasks in parallel

GearmanClient::addTaskLow
GearmanClient::addTaskStatus
GearmanClient


Add a task to get status

GearmanClient::addTaskLowBackground
GearmanClient::clearCallbacks
GearmanClient
PHP Manual

GearmanClient::addTaskStatus

(PECL gearman >= 0.5.0)

GearmanClient::addTaskStatus — Add a task to get status

Açıklama

public GearmanTask GearmanClient::addTaskStatus ( string $job_handle [, string &$context ] )

Used to request status information from the Gearman server, which will call the specified status callback (set using GearmanClient::setStatusCallback()).

Değiştirgeler

job_handle

The job handle for the task to get status for

context

Data to be passed to the status callback, generally a reference to an array or object

Dönen Değerler

A GearmanTask object.

Örnekler

Örnek 1 Monitor completion of multiple background tasks

An artificial delay is introduced in the worker in this example to simulate a long running process. There is only one worker running for this example.

<?php

/* create our object */
$gmclient= new GearmanClient();

/* add the default server */
$gmclient->addServer();

/* start some background jobs and save the handles */
$handles = array();
$handles[0] = $gmclient->doBackground("reverse", "Hello World!");
$handles[1] = $gmclient->doBackground("reverse", "!dlroW olleH");

$gmclient->setStatusCallback("reverse_status");

/* Poll the server to see when those background jobs finish; */
/* a better method would be to use event callbacks */
do
{
   /* Use the context variable to track how many tasks have completed */
   $done = 0;
   $gmclient->addTaskStatus($handles[0], &$done);
   $gmclient->addTaskStatus($handles[1], &$done);
   $gmclient->runTasks();
   echo "Done: $done\n";
   sleep(1);
}
while ($done != 2);

function reverse_status($task, $done)
{
   if (!$task->isKnown())
      $done++;
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Done: 0
Done: 0
Done: 0
Done: 0
Done: 0
Done: 0
Done: 0
Done: 0
Done: 0
Done: 0
Done: 0
Done: 0
Done: 1
Done: 1
Done: 1
Done: 1
Done: 1
Done: 1
Done: 1
Done: 1
Done: 1
Done: 1
Done: 1
Done: 1
Done: 2

Ayrıca Bakınız

  • GearmanClient::setStatusCallback() - Set a callback for collecting task status

GearmanClient::addTaskLowBackground
GearmanClient::clearCallbacks
GearmanClient


Clear all task callback functions

GearmanClient::addTaskStatus
GearmanClient::clone
GearmanClient
PHP Manual

GearmanClient::clearCallbacks

(PECL gearman >= 0.5.0)

GearmanClient::clearCallbacks — Clear all task callback functions

Açıklama

public bool GearmanClient::clearCallbacks ( void )

Clears all the task callback functions that have previously been set.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Always returns TRUE.

Ayrıca Bakınız

  • GearmanClient::setDataCallback() - Callback function when there is a data packet for a task
  • GearmanClient::setCompleteCallback() - Set a function to be called on task completion
  • GearmanClient::setCreatedCallback() - Set a callback for when a task is queued
  • GearmanClient::setExceptionCallback() - Set a callback for worker exceptions
  • GearmanClient::setFailCallback() - Set callback for job failure
  • GearmanClient::setStatusCallback() - Set a callback for collecting task status
  • GearmanClient::setWarningCallback() - Set a callback for worker warnings
  • GearmanClient::setWorkloadCallback() - Set a callback for accepting incremental data updates

GearmanClient::addTaskStatus
GearmanClient::clone
GearmanClient


Create a copy of a GearmanClient object

GearmanClient::clearCallbacks
GearmanClient::__construct
GearmanClient
PHP Manual

GearmanClient::clone

(PECL gearman >= 0.5.0)

GearmanClient::clone — Create a copy of a GearmanClient object

Açıklama

public GearmanClient GearmanClient::clone ( void )

Creates a copy of a GearmanClient object.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A GearmanClient on success, FALSE on failure.

GearmanClient::clearCallbacks
GearmanClient::__construct
GearmanClient


Create a GearmanClient instance

GearmanClient::clone
GearmanClient::context
GearmanClient
PHP Manual

GearmanClient::__construct

(PECL gearman >= 0.5.0)

GearmanClient::__construct — Create a GearmanClient instance

Açıklama

public GearmanClient::__construct ( void )

Creates a GearmanClient instance representing a client that connects to the job server and submits tasks to complete.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A GearmanClient object.

Ayrıca Bakınız

  • GearmanClient::clone() - Create a copy of a GearmanClient object

GearmanClient::clone
GearmanClient::context
GearmanClient


Get the application context

GearmanClient::__construct
GearmanClient::data
GearmanClient
PHP Manual

GearmanClient::context

(PECL gearman >= 0.6.0)

GearmanClient::context — Get the application context

Açıklama

public string GearmanClient::context ( void )

Get the application context previously set with GearmanClient::setContext().

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The same context data structure set with GearmanClient::setContext()

Ayrıca Bakınız

  • GearmanClient::setContext() - Set application context

GearmanClient::__construct
GearmanClient::data
GearmanClient


Get the application data (deprecated)

GearmanClient::context
GearmanClient::do
GearmanClient
PHP Manual

GearmanClient::data

(PECL gearman <= 0.5.0)

GearmanClient::data — Get the application data (deprecated)

Açıklama

public string GearmanClient::data ( void )

Get the application data previously set with GearmanClient::setData().

Bilginize:

This method was replaced by GearmanClient::setContext() in the 0.6.0 release of the Gearman extension.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The same string data set with GearmanClient::setData()

Ayrıca Bakınız

  • GearmanClient::setData() - Set application data (deprecated)

GearmanClient::context
GearmanClient::do
GearmanClient


Run a single task and return a result [deprecated]

GearmanClient::data
GearmanClient::doBackground
GearmanClient
PHP Manual

GearmanClient::do

(PECL gearman >= 0.5.0)

GearmanClient::do — Run a single task and return a result [deprecated]

Açıklama

public string GearmanClient::do ( string $function_name , string $workload [, string $unique ] )

The GearmanClient::do() method is deprecated as of pecl/gearman 1.0.0. Use GearmanClient::doNormal().

Değiştirgeler

function_name

A registered function the worker is to execute

workload

Serialized data to be processed

unique

A unique ID used to identify a particular task

Dönen Değerler

A string representing the results of running a task.

Örnekler

Örnek 1 Simple job submission with immediate return

<?php

# Client code

echo "Starting\n";

# Create our client object.
$gmclient= new GearmanClient();

# Add default server (localhost).
$gmclient->addServer();

echo "Sending job\n";

$result = $gmclient->doNormal("reverse", "Hello!");

echo "Success: $result\n";

?>
<?php

echo "Starting\n";

# Create our worker object.
$gmworker= new GearmanWorker();

# Add default server (localhost).
$gmworker->addServer();

# Register function "reverse" with the server. Change the worker function to
# "reverse_fn_fast" for a faster worker with no output.
$gmworker->addFunction("reverse", "reverse_fn");

print "Waiting for job...\n";
while($gmworker->work())
{
  if ($gmworker->returnCode() != GEARMAN_SUCCESS)
  {
    echo "return_code: " . $gmworker->returnCode() . "\n";
    break;
  }
}

function reverse_fn($job)
{
  return strrev($job->workload());
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Starting
Sending job
Success: !olleH

Örnek 2 Submitting a job and retrieving incremental status

A job is submitted and the script loops to retrieve status information. The worker has an artificial delay which results in a long running job and sends status and data as processing occurs. Each subsequent call to GearmanClient::do() produces status information on the running job.

<?php

# Client code

# Create our client object.
$gmclient= new GearmanClient();

# Add default server (localhost).
$gmclient->addServer();

echo "Sending job\n";

# Send reverse job
do
{
  $result = $gmclient->doNormal("reverse", "Hello!");
  # Check for various return packets and errors.

  switch($gmclient->returnCode())
  {
    case GEARMAN_WORK_DATA:
      echo "Data: $result\n";
      break;
    case GEARMAN_WORK_STATUS:
      list($numerator, $denominator)= $gmclient->doStatus();
      echo "Status: $numerator/$denominator complete\n";
      break;
    case GEARMAN_WORK_FAIL:
      echo "Failed\n";
      exit;
    case GEARMAN_SUCCESS:
      break;
    default:
      echo "RET: " . $gmclient->returnCode() . "\n";
      echo "Error: " . $gmclient->error() . "\n";
      echo "Errno: " . $gmclient->getErrno() . "\n";
      exit;
  }
}
while($gmclient->returnCode() != GEARMAN_SUCCESS);

echo "Success: $result\n";

?>
<?php

# Worker code

echo "Starting\n";

# Create our worker object.
$gmworker= new GearmanWorker();

# Add default server (localhost).
$gmworker->addServer();

# Register function "reverse" with the server.
$gmworker->addFunction("reverse", "reverse_fn");

print "Waiting for job...\n";
while($gmworker->work())
{
  if ($gmworker->returnCode() != GEARMAN_SUCCESS)
  {
    echo "return_code: " . $gmworker->returnCode() . "\n";
    break;
  }
}

function reverse_fn($job)
{
  echo "Received job: " . $job->handle() . "\n";

  $workload = $job->workload();
  $workload_size = $job->workloadSize();

  echo "Workload: $workload ($workload_size)\n";

  # This status loop is not needed, just showing how it works
  for ($x= 0; $x < $workload_size; $x++)
  {
    echo "Sending status: " + $x + 1 . "/$workload_size complete\n";
    $job->sendStatus($x+1, $workload_size);
    $job->sendData(substr($workload, $x, 1));
    sleep(1);
  }

  $result= strrev($workload);
  echo "Result: $result\n";

  # Return what we want to send back to the client.
  return $result;
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Worker output:

Starting
Waiting for job...
Received job: H:foo.local:106
Workload: Hello! (6)
1/6 complete
2/6 complete
3/6 complete
4/6 complete
5/6 complete
6/6 complete
Result: !olleH

Client output:

Starting
Sending job
Status: 1/6 complete
Data: H
Status: 2/6 complete
Data: e
Status: 3/6 complete
Data: l
Status: 4/6 complete
Data: l
Status: 5/6 complete
Data: o
Status: 6/6 complete
Data: !
Success: !olleH

Ayrıca Bakınız

  • GearmanClient::doHigh() - Run a single high priority task
  • GearmanClient::doLow() - Run a single low priority task
  • GearmanClient::doBackground() - Run a task in the background
  • GearmanClient::doHighBackground() - Run a high priority task in the background
  • GearmanClient::doLowBackground() - Run a low priority task in the background

GearmanClient::data
GearmanClient::doBackground
GearmanClient


Run a task in the background

GearmanClient::do
GearmanClient::doHigh
GearmanClient
PHP Manual

GearmanClient::doBackground

(PECL gearman >= 0.5.0)

GearmanClient::doBackground — Run a task in the background

Açıklama

public string GearmanClient::doBackground ( string $function_name , string $workload [, string $unique ] )

Runs a task in the background, returning a job handle which can be used to get the status of the running task.

Değiştirgeler

function_name

A registered function the worker is to execute

workload

Serialized data to be processed

unique

A unique ID used to identify a particular task

Dönen Değerler

The job handle for the submitted task.

Örnekler

Örnek 1 Submit and monitor a background job

The worker in this example has an artificial delay introduced to mimic a long running job. The client script periodically checks the status of the running job.

<?php

/* create our object */
$gmclient= new GearmanClient();

/* add the default server */
$gmclient->addServer();

/* run reverse client */
$job_handle = $gmclient->doBackground("reverse", "this is a test");

if ($gmclient->returnCode() != GEARMAN_SUCCESS)
{
  echo "bad return code\n";
  exit;
}

$done = false;
do
{
   sleep(3);
   $stat = $gmclient->jobStatus($job_handle);
   if (!$stat[0]) // the job is known so it is not done
      $done = true;
   echo "Running: " . ($stat[1] ? "true" : "false") . ", numerator: " . $stat[2] . ", denomintor: " . $stat[3] . "\n";
}
while(!$done);

echo "done!\n";

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Running: true, numerator: 3, denomintor: 14
Running: true, numerator: 6, denomintor: 14
Running: true, numerator: 9, denomintor: 14
Running: true, numerator: 12, denomintor: 14
Running: false, numerator: 0, denomintor: 0
done!

Ayrıca Bakınız

  • GearmanClient::doNormal() - Run a single task and return a result
  • GearmanClient::doHigh() - Run a single high priority task
  • GearmanClient::doLow() - Run a single low priority task
  • GearmanClient::doHighBackground() - Run a high priority task in the background
  • GearmanClient::doLowBackground() - Run a low priority task in the background

GearmanClient::do
GearmanClient::doHigh
GearmanClient


Run a single high priority task

GearmanClient::doBackground
GearmanClient::doHighBackground
GearmanClient
PHP Manual

GearmanClient::doHigh

(PECL gearman >= 0.5.0)

GearmanClient::doHigh — Run a single high priority task

Açıklama

public string GearmanClient::doHigh ( string $function_name , string $workload [, string $unique ] )

Runs a single high priority task and returns a string representation of the result. It is up to the GearmanClient and GearmanWorker to agree on the format of the result. High priority tasks will get precedence over normal and low priority tasks in the job queue.

Değiştirgeler

function_name

A registered function the worker is to execute

workload

Serialized data to be processed

unique

A unique ID used to identify a particular task

Dönen Değerler

A string representing the results of running a task.

Ayrıca Bakınız

  • GearmanClient::doNormal() - Run a single task and return a result
  • GearmanClient::doLow() - Run a single low priority task
  • GearmanClient::doBackground() - Run a task in the background
  • GearmanClient::doHighBackground() - Run a high priority task in the background
  • GearmanClient::doLowBackground() - Run a low priority task in the background

GearmanClient::doBackground
GearmanClient::doHighBackground
GearmanClient


Run a high priority task in the background

GearmanClient::doHigh
GearmanClient::doJobHandle
GearmanClient
PHP Manual

GearmanClient::doHighBackground

(PECL gearman >= 0.5.0)

GearmanClient::doHighBackground — Run a high priority task in the background

Açıklama

public string GearmanClient::doHighBackground ( string $function_name , string $workload [, string $unique ] )

Runs a high priority task in the background, returning a job handle which can be used to get the status of the running task. High priority tasks take precedence over normal and low priority tasks in the job queue.

Değiştirgeler

function_name

A registered function the worker is to execute

workload

Serialized data to be processed

unique

A unique ID used to identify a particular task

Dönen Değerler

The job handle for the submitted task.

Ayrıca Bakınız

  • GearmanClient::doNormal() - Run a single task and return a result
  • GearmanClient::doHigh() - Run a single high priority task
  • GearmanClient::doLow() - Run a single low priority task
  • GearmanClient::doBackground() - Run a task in the background
  • GearmanClient::doLowBackground() - Run a low priority task in the background

GearmanClient::doHigh
GearmanClient::doJobHandle
GearmanClient


Get the job handle for the running task

GearmanClient::doHighBackground
GearmanClient::doLow
GearmanClient
PHP Manual

GearmanClient::doJobHandle

(PECL gearman >= 0.5.0)

GearmanClient::doJobHandle — Get the job handle for the running task

Açıklama

public string GearmanClient::doJobHandle ( void )

Gets that job handle for a running task. This should be used between repeated GearmanClient::doNormal() calls. The job handle can then be used to get information on the task.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The job handle for the running task.

Ayrıca Bakınız

  • GearmanClient::jobStatus() - Get the status of a background job

GearmanClient::doHighBackground
GearmanClient::doLow
GearmanClient


Run a single low priority task

GearmanClient::doJobHandle
GearmanClient::doLowBackground
GearmanClient
PHP Manual

GearmanClient::doLow

(PECL gearman >= 0.5.0)

GearmanClient::doLow — Run a single low priority task

Açıklama

public string GearmanClient::doLow ( string $function_name , string $workload [, string $unique ] )

Runs a single low priority task and returns a string representation of the result. It is up to the GearmanClient and GearmanWorker to agree on the format of the result. Normal and high priority tasks will get precedence over low priority tasks in the job queue.

Değiştirgeler

function_name

A registered function the worker is to execute

workload

Serialized data to be processed

unique

A unique ID used to identify a particular task

Dönen Değerler

A string representing the results of running a task.

Ayrıca Bakınız

  • GearmanClient::doNormal() - Run a single task and return a result
  • GearmanClient::doHigh() - Run a single high priority task
  • GearmanClient::doBackground() - Run a task in the background
  • GearmanClient::doHighBackground() - Run a high priority task in the background
  • GearmanClient::doLowBackground() - Run a low priority task in the background

GearmanClient::doJobHandle
GearmanClient::doLowBackground
GearmanClient


Run a low priority task in the background

GearmanClient::doLow
GearmanClient::doNormal
GearmanClient
PHP Manual

GearmanClient::doLowBackground

(PECL gearman >= 0.5.0)

GearmanClient::doLowBackground — Run a low priority task in the background

Açıklama

public string GearmanClient::doLowBackground ( string $function_name , string $workload [, string $unique ] )

Runs a low priority task in the background, returning a job handle which can be used to get the status of the running task. Normal and high priority tasks take precedence over low priority tasks in the job queue.

Değiştirgeler

function_name

A registered function the worker is to execute

workload

Serialized data to be processed

unique

A unique ID used to identify a particular task

Dönen Değerler

The job handle for the submitted task.

Ayrıca Bakınız

  • GearmanClient::doNormal() - Run a single task and return a result
  • GearmanClient::doHigh() - Run a single high priority task
  • GearmanClient::doLow() - Run a single low priority task
  • GearmanClient::doBackground() - Run a task in the background
  • GearmanClient::doHighBackground() - Run a high priority task in the background

GearmanClient::doLow
GearmanClient::doNormal
GearmanClient


Run a single task and return a result

GearmanClient::doLowBackground
GearmanClient::doStatus
GearmanClient
PHP Manual

GearmanClient::doNormal

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

GearmanClient::doNormal — Run a single task and return a result

Açıklama

public string GearmanClient::doNormal ( string $function_name , string $workload [, string $unique ] )

Runs a single task and returns a string representation of the result. It is up to the GearmanClient and GearmanWorker to agree on the format of the result.

Değiştirgeler

function_name

A registered function the worker is to execute

workload

Serialized data to be processed

unique

A unique ID used to identify a particular task

Dönen Değerler

A string representing the results of running a task.

Örnekler

Örnek 1 Simple job submission with immediate return

<?php

?>
<?php

# Client code

echo "Starting\n";

# Create our client object.
$gmclient= new GearmanClient();

# Add default server (localhost).
$gmclient->addServer();

echo "Sending job\n";

$result = $gmclient->doNormal("reverse", "Hello!");

echo "Success: $result\n";

?>
<?php

echo "Starting\n";

# Create our worker object.
$gmworker= new GearmanWorker();

# Add default server (localhost).
$gmworker->addServer();

# Register function "reverse" with the server. Change the worker function to
# "reverse_fn_fast" for a faster worker with no output.
$gmworker->addFunction("reverse", "reverse_fn");

print "Waiting for job...\n";
while($gmworker->work())
{
  if ($gmworker->returnCode() != GEARMAN_SUCCESS)
  {
    echo "return_code: " . $gmworker->returnCode() . "\n";
    break;
  }
}

function reverse_fn($job)
{
  return strrev($job->workload());
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Starting
Sending job
Success: !olleH

Örnek 2 Submitting a job and retrieving incremental status

A job is submitted and the script loops to retrieve status information. The worker has an artificial delay which results in a long running job and sends status and data as processing occurs. Each subsequent call to GearmanClient::doNormal() produces status information on the running job.

<?php

# Client code

# Create our client object.
$gmclient= new GearmanClient();

# Add default server (localhost).
$gmclient->addServer();

echo "Sending job\n";

# Send reverse job
do
{
  $result = $gmclient->doNormal("reverse", "Hello!");
  # Check for various return packets and errors.

  switch($gmclient->returnCode())
  {
    case GEARMAN_WORK_DATA:
      echo "Data: $result\n";
      break;
    case GEARMAN_WORK_STATUS:
      list($numerator, $denominator)= $gmclient->doStatus();
      echo "Status: $numerator/$denominator complete\n";
      break;
    case GEARMAN_WORK_FAIL:
      echo "Failed\n";
      exit;
    case GEARMAN_SUCCESS:
      break;
    default:
      echo "RET: " . $gmclient->returnCode() . "\n";
      echo "Error: " . $gmclient->error() . "\n";
      echo "Errno: " . $gmclient->getErrno() . "\n";
      exit;
  }
}
while($gmclient->returnCode() != GEARMAN_SUCCESS);

echo "Success: $result\n";

?>
<?php

# Worker code

echo "Starting\n";

# Create our worker object.
$gmworker= new GearmanWorker();

# Add default server (localhost).
$gmworker->addServer();

# Register function "reverse" with the server.
$gmworker->addFunction("reverse", "reverse_fn");

print "Waiting for job...\n";
while($gmworker->work())
{
  if ($gmworker->returnCode() != GEARMAN_SUCCESS)
  {
    echo "return_code: " . $gmworker->returnCode() . "\n";
    break;
  }
}

function reverse_fn($job)
{
  echo "Received job: " . $job->handle() . "\n";

  $workload = $job->workload();
  $workload_size = $job->workloadSize();

  echo "Workload: $workload ($workload_size)\n";

  # This status loop is not needed, just showing how it works
  for ($x= 0; $x < $workload_size; $x++)
  {
    echo "Sending status: " + $x + 1 . "/$workload_size complete\n";
    $job->sendStatus($x+1, $workload_size);
    $job->sendData(substr($workload, $x, 1));
    sleep(1);
  }

  $result= strrev($workload);
  echo "Result: $result\n";

  # Return what we want to send back to the client.
  return $result;
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Worker output:

Starting
Waiting for job...
Received job: H:foo.local:106
Workload: Hello! (6)
1/6 complete
2/6 complete
3/6 complete
4/6 complete
5/6 complete
6/6 complete
Result: !olleH

Client output:

Starting
Sending job
Status: 1/6 complete
Data: H
Status: 2/6 complete
Data: e
Status: 3/6 complete
Data: l
Status: 4/6 complete
Data: l
Status: 5/6 complete
Data: o
Status: 6/6 complete
Data: !
Success: !olleH

Ayrıca Bakınız

  • GearmanClient::doHigh() - Run a single high priority task
  • GearmanClient::doLow() - Run a single low priority task
  • GearmanClient::doBackground() - Run a task in the background
  • GearmanClient::doHighBackground() - Run a high priority task in the background
  • GearmanClient::doLowBackground() - Run a low priority task in the background

GearmanClient::doLowBackground
GearmanClient::doStatus
GearmanClient


Get the status for the running task

GearmanClient::doNormal
GearmanClient::echo
GearmanClient
PHP Manual

GearmanClient::doStatus

(PECL gearman >= 0.5.0)

GearmanClient::doStatus — Get the status for the running task

Açıklama

public array GearmanClient::doStatus ( void )

Returns the status for the running task. This should be used between repeated GearmanClient::doNormal() calls.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

An array representing the percentage completion given as a fraction, with the first element the numerator and the second element the denomintor.

Örnekler

Örnek 1 Get the status of a long running job

The worker in this example has an artificial delay added during processing of the string to be reversed. After each delay it calls GearmanJob::status() which the client then picks up.

<?php

echo "Starting\n";

# Create our client object.
$gmclient= new GearmanClient();

# Add default server (localhost).
$gmclient->addServer();

echo "Sending job\n";

# Send reverse job
do
{
  $result = $gmclient->doNormal("reverse", "Hello!");

  # Check for various return packets and errors.
  switch($gmclient->returnCode())
  {
    case GEARMAN_WORK_DATA:
      break;
    case GEARMAN_WORK_STATUS:
      # get the current job status
      list($numerator, $denominator)= $gmclient->doStatus();
      echo "Status: $numerator/$denominator complete\n";
      break;
    case GEARMAN_WORK_FAIL:
      echo "Failed\n";
      exit;
    case GEARMAN_SUCCESS:
      break;
    default:
      echo "RET: " . $gmclient->returnCode() . "\n";
      exit;
  }
}
while($gmclient->returnCode() != GEARMAN_SUCCESS);

echo "Success: $result\n";

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Starting
Sending job
Status: 1/6 complete
Status: 2/6 complete
Status: 3/6 complete
Status: 4/6 complete
Status: 5/6 complete
Status: 6/6 complete
Success: !olleH

Ayrıca Bakınız

  • GearmanClient::doNormal() - Run a single task and return a result
  • GearmanJob::status() - Send status (deprecated)

GearmanClient::doNormal
GearmanClient::echo
GearmanClient


Send data to all job servers to see if they echo it back [deprecated]

GearmanClient::doStatus
GearmanClient::error
GearmanClient
PHP Manual

GearmanClient::echo

(PECL gearman >= 0.5.0)

GearmanClient::echo — Send data to all job servers to see if they echo it back [deprecated]

Açıklama

public bool GearmanClient::echo ( string $workload )

The GearmanClient::echo() method is deprecated as of pecl/gearman 1.0.0. Use GearmanClient::ping().

Değiştirgeler

workload

Some arbitrary serialized data to be echo back

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

GearmanClient::doStatus
GearmanClient::error
GearmanClient


Returns an error string for the last error encountered.

GearmanClient::echo
GearmanClient::getErrno
GearmanClient
PHP Manual

GearmanClient::error

(PECL gearman >= 0.5.0)

GearmanClient::error — Returns an error string for the last error encountered.

Açıklama

public string GearmanClient::error ( void )

Returns an error string for the last error encountered.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A human readable error string.

Ayrıca Bakınız

  • GearmanClient::getErrno() - Get an errno value

GearmanClient::echo
GearmanClient::getErrno
GearmanClient


Get an errno value

GearmanClient::error
GearmanClient::jobStatus
GearmanClient
PHP Manual

GearmanClient::getErrno

(PECL gearman >= 0.5.0)

GearmanClient::getErrno — Get an errno value

Açıklama

public int GearmanClient::getErrno ( void )

Value of errno in the case of a GEARMAN_ERRNO return value.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A valid Gearman errno.

Ayrıca Bakınız

  • GearmanClient::error() - Returns an error string for the last error encountered.

GearmanClient::error
GearmanClient::jobStatus
GearmanClient


Get the status of a background job

GearmanClient::getErrno
GearmanClient::ping
GearmanClient
PHP Manual

GearmanClient::jobStatus

gearman_job_status

(PECL gearman >= 0.5.0)

GearmanClient::jobStatus -- gearman_job_status — Get the status of a background job

Açıklama

Nesne yönelimli kullanım (method):

public array GearmanClient::jobStatus ( string $job_handle )

Gets the status for a background job given a job handle. The status information will specify whether the job is known, whether the job is currently running, and the percentage completion.

Değiştirgeler

job_handle

The job handle assigned by the Gearman server

Dönen Değerler

An array containing status information for the job corresponding to the supplied job handle. The first array element is a boolean indicating whether the job is even known, the second is a boolean indicating whether the job is still running, and the third and fourth elements correspond to the numerator and denominator of the fractional completion percentage, respectively.

Örnekler

Örnek 1 Monitor the status of a long running background job

<?php

/* create our object */
$gmclient= new GearmanClient();

/* add the default server */
$gmclient->addServer();

/* run reverse client */
$job_handle = $gmclient->doBackground("reverse", "this is a test");

if ($gmclient->returnCode() != GEARMAN_SUCCESS)
{
  echo "bad return code\n";
  exit;
}

$done = false;
do
{
   sleep(3);
   $stat = $gmclient->jobStatus($job_handle);
   if (!$stat[0]) // the job is known so it is not done
      $done = true;
   echo "Running: " . ($stat[1] ? "true" : "false") . ", numerator: " . $stat[2] . ", denomintor: " . $stat[3] . "\n";
}
while(!$done);

echo "done!\n";

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Running: true, numerator: 3, denomintor: 14
Running: true, numerator: 6, denomintor: 14
Running: true, numerator: 9, denomintor: 14
Running: true, numerator: 12, denomintor: 14
Running: false, numerator: 0, denomintor: 0
done!

Ayrıca Bakınız

  • GearmanClient::doStatus() - Get the status for the running task

GearmanClient::getErrno
GearmanClient::ping
GearmanClient


Send data to all job servers to see if they echo it back

GearmanClient::jobStatus
GearmanClient::removeOptions
GearmanClient
PHP Manual

GearmanClient::ping

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

GearmanClient::ping — Send data to all job servers to see if they echo it back

Açıklama

public bool GearmanClient::ping ( string $workload )

Sends some arbitrary data to all job servers to see if they echo it back. The data sent is not used or processed in any other way. Primarily used for testing and debugging.

Değiştirgeler

workload

Some arbitrary serialized data to be echo back

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

GearmanClient::jobStatus
GearmanClient::removeOptions
GearmanClient


Remove client options

GearmanClient::ping
GearmanClient::returnCode
GearmanClient
PHP Manual

GearmanClient::removeOptions

(PECL gearman >= 0.6.0)

GearmanClient::removeOptions — Remove client options

Açıklama

public bool GearmanClient::removeOptions ( int $options )

Removes (unsets) one or more options.

Değiştirgeler

options

The options to be removed (unset)

Dönen Değerler

Always returns TRUE.

GearmanClient::ping
GearmanClient::returnCode
GearmanClient


Get the last Gearman return code

GearmanClient::removeOptions
GearmanClient::runTasks
GearmanClient
PHP Manual

GearmanClient::returnCode

(PECL gearman >= 0.5.0)

GearmanClient::returnCode — Get the last Gearman return code

Açıklama

public int GearmanClient::returnCode ( void )

Returns the last Gearman return code.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A valid Gearman return code.

GearmanClient::removeOptions
GearmanClient::runTasks
GearmanClient


Run a list of tasks in parallel

GearmanClient::returnCode
GearmanClient::setClientCallback
GearmanClient
PHP Manual

GearmanClient::runTasks

(PECL gearman >= 0.5.0)

GearmanClient::runTasks — Run a list of tasks in parallel

Açıklama

public bool GearmanClient::runTasks ( void )

For a set of tasks previously added with GearmanClient::addTask(), GearmanClient::addTaskHigh(), GearmanClient::addTaskLow(), GearmanClient::addTaskBackground(), GearmanClient::addTaskHighBackground(), or GearmanClient::addTaskLowBackground(), this call starts running the tasks in parallel.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • GearmanClient::addTask() - Add a task to be run in parallel

GearmanClient::returnCode
GearmanClient::setClientCallback
GearmanClient


Callback function when there is a data packet for a task (deprecated)

GearmanClient::runTasks
GearmanClient::setCompleteCallback
GearmanClient
PHP Manual

GearmanClient::setClientCallback

(PECL gearman <= 0.5.0)

GearmanClient::setClientCallback — Callback function when there is a data packet for a task (deprecated)

Açıklama

public void GearmanClient::setClientCallback ( callable $callback )

Sets the callback function for accepting data packets for a task. The callback function should take a single argument, a GearmanTask object.

Bilginize:

This method has been replaced by GearmanClient::setDataCallback() in the 0.6.0 release of the Gearman extension.

Değiştirgeler

callback

A function or method to call

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • GearmanClient::setCompleteCallback() - Set a function to be called on task completion
  • GearmanClient::setCreatedCallback() - Set a callback for when a task is queued
  • GearmanClient::setDataCallback() - Callback function when there is a data packet for a task
  • GearmanClient::setExceptionCallback() - Set a callback for worker exceptions
  • GearmanClient::setFailCallback() - Set callback for job failure
  • GearmanClient::setStatusCallback() - Set a callback for collecting task status
  • GearmanClient::setWarningCallback() - Set a callback for worker warnings
  • GearmanClient::setWorkloadCallback() - Set a callback for accepting incremental data updates

GearmanClient::runTasks
GearmanClient::setCompleteCallback
GearmanClient


Set a function to be called on task completion

GearmanClient::setClientCallback
GearmanClient::setContext
GearmanClient
PHP Manual

GearmanClient::setCompleteCallback

(PECL gearman >= 0.5.0)

GearmanClient::setCompleteCallback — Set a function to be called on task completion

Açıklama

public bool GearmanClient::setCompleteCallback ( callable $callback )

Use to set a function to be called when a GearmanTask is completed, or when GearmanJob::sendComplete() is invoked by a worker (whichever happens first).

This callback executes only when executing a GearmanTask using GearmanClient::runTasks(). It is not used for individual jobs.

Değiştirgeler

callback

A function to be called

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • GearmanClient::setDataCallback() - Callback function when there is a data packet for a task
  • GearmanClient::setCreatedCallback() - Set a callback for when a task is queued
  • GearmanClient::setExceptionCallback() - Set a callback for worker exceptions
  • GearmanClient::setFailCallback() - Set callback for job failure
  • GearmanClient::setStatusCallback() - Set a callback for collecting task status
  • GearmanClient::setWarningCallback() - Set a callback for worker warnings
  • GearmanClient::setWorkloadCallback() - Set a callback for accepting incremental data updates

GearmanClient::setClientCallback
GearmanClient::setContext
GearmanClient


Set application context

GearmanClient::setCompleteCallback
GearmanClient::setCreatedCallback
GearmanClient
PHP Manual

GearmanClient::setContext

(PECL gearman >= 0.6.0)

GearmanClient::setContext — Set application context

Açıklama

public bool GearmanClient::setContext ( string $context )

Sets an arbitrary string to provide application context that can later be retrieved by GearmanClient::context().

Değiştirgeler

context

Arbitrary context data

Dönen Değerler

Always returns TRUE.

Ayrıca Bakınız

  • GearmanClient::context() - Get the application context

GearmanClient::setCompleteCallback
GearmanClient::setCreatedCallback
GearmanClient


Set a callback for when a task is queued

GearmanClient::setContext
GearmanClient::setData
GearmanClient
PHP Manual

GearmanClient::setCreatedCallback

(PECL gearman >= 0.5.0)

GearmanClient::setCreatedCallback — Set a callback for when a task is queued

Açıklama

public bool GearmanClient::setCreatedCallback ( string $callback )

Sets a function to be called when a task is received and queued by the Gearman job server. The callback should accept a single argument, a GearmanTask oject.

Değiştirgeler

callback

A function to call

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • GearmanClient::setDataCallback() - Callback function when there is a data packet for a task
  • GearmanClient::setCompleteCallback() - Set a function to be called on task completion
  • GearmanClient::setExceptionCallback() - Set a callback for worker exceptions
  • GearmanClient::setFailCallback() - Set callback for job failure
  • GearmanClient::setStatusCallback() - Set a callback for collecting task status
  • GearmanClient::setWarningCallback() - Set a callback for worker warnings
  • GearmanClient::setWorkloadCallback() - Set a callback for accepting incremental data updates

GearmanClient::setContext
GearmanClient::setData
GearmanClient


Set application data (deprecated)

GearmanClient::setCreatedCallback
GearmanClient::setDataCallback
GearmanClient
PHP Manual

GearmanClient::setData

(PECL gearman <= 0.5.0)

GearmanClient::setData — Set application data (deprecated)

Açıklama

public bool GearmanClient::setData ( string $data )

Sets some arbitrary application data that can later be retrieved by GearmanClient::data().

Bilginize:

This method has been replaced by GearmanCient::setContext() in the 0.6.0 release of the Gearman extension.

Değiştirgeler

data

Dönen Değerler

Always returns TRUE.

Ayrıca Bakınız

  • GearmanClient::data() - Get the application data (deprecated)

GearmanClient::setCreatedCallback
GearmanClient::setDataCallback
GearmanClient


Callback function when there is a data packet for a task

GearmanClient::setData
GearmanClient::setExceptionCallback
GearmanClient
PHP Manual

GearmanClient::setDataCallback

(PECL gearman >= 0.6.0)

GearmanClient::setDataCallback — Callback function when there is a data packet for a task

Açıklama

public bool GearmanClient::setDataCallback ( callable $callback )

Sets the callback function for accepting data packets for a task. The callback function should take a single argument, a GearmanTask object.

Değiştirgeler

callback

A function or method to call

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • GearmanClient::setCompleteCallback() - Set a function to be called on task completion
  • GearmanClient::setCreatedCallback() - Set a callback for when a task is queued
  • GearmanClient::setExceptionCallback() - Set a callback for worker exceptions
  • GearmanClient::setFailCallback() - Set callback for job failure
  • GearmanClient::setStatusCallback() - Set a callback for collecting task status
  • GearmanClient::setWarningCallback() - Set a callback for worker warnings
  • GearmanClient::setWorkloadCallback() - Set a callback for accepting incremental data updates

GearmanClient::setData
GearmanClient::setExceptionCallback
GearmanClient


Set a callback for worker exceptions

GearmanClient::setDataCallback
GearmanClient::setFailCallback
GearmanClient
PHP Manual

GearmanClient::setExceptionCallback

(PECL gearman >= 0.5.0)

GearmanClient::setExceptionCallback — Set a callback for worker exceptions

Açıklama

public bool GearmanClient::setExceptionCallback ( callable $callback )

Specifies a function to call when a worker for a task sends an exception.

Değiştirgeler

callback

Function to call when the worker throws an exception

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • GearmanClient::setDataCallback() - Callback function when there is a data packet for a task
  • GearmanClient::setCompleteCallback() - Set a function to be called on task completion
  • GearmanClient::setCreatedCallback() - Set a callback for when a task is queued
  • GearmanClient::setFailCallback() - Set callback for job failure
  • GearmanClient::setStatusCallback() - Set a callback for collecting task status
  • GearmanClient::setWarningCallback() - Set a callback for worker warnings
  • GearmanClient::setWorkloadCallback() - Set a callback for accepting incremental data updates

GearmanClient::setDataCallback
GearmanClient::setFailCallback
GearmanClient


Set callback for job failure

GearmanClient::setExceptionCallback
GearmanClient::setOptions
GearmanClient
PHP Manual

GearmanClient::setFailCallback

(PECL gearman >= 0.5.0)

GearmanClient::setFailCallback — Set callback for job failure

Açıklama

public bool GearmanClient::setFailCallback ( callable $callback )

Sets the callback function to be used when a task does not complete successfully. The function should accept a single argument, a GearmanTask object.

Değiştirgeler

callback

A function to call

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • GearmanClient::setDataCallback() - Callback function when there is a data packet for a task
  • GearmanClient::setCompleteCallback() - Set a function to be called on task completion
  • GearmanClient::setCreatedCallback() - Set a callback for when a task is queued
  • GearmanClient::setExceptionCallback() - Set a callback for worker exceptions
  • GearmanClient::setStatusCallback() - Set a callback for collecting task status
  • GearmanClient::setWarningCallback() - Set a callback for worker warnings
  • GearmanClient::setWorkloadCallback() - Set a callback for accepting incremental data updates

GearmanClient::setExceptionCallback
GearmanClient::setOptions
GearmanClient


Set client options

GearmanClient::setFailCallback
GearmanClient::setStatusCallback
GearmanClient
PHP Manual

GearmanClient::setOptions

(PECL gearman >= 0.5.0)

GearmanClient::setOptions — Set client options

Açıklama

public bool GearmanClient::setOptions ( int $options )

Sets one or more client options.

Değiştirgeler

options

The options to be set

Dönen Değerler

Always returns TRUE.

GearmanClient::setFailCallback
GearmanClient::setStatusCallback
GearmanClient


Set a callback for collecting task status

GearmanClient::setOptions
GearmanClient::setTimeout
GearmanClient
PHP Manual

GearmanClient::setStatusCallback

(PECL gearman >= 0.5.0)

GearmanClient::setStatusCallback — Set a callback for collecting task status

Açıklama

public bool GearmanClient::setStatusCallback ( callable $callback )

Sets a callback function used for getting updated status information from a worker. The function should accept a single argument, a GearmanTask object.

Değiştirgeler

callback

A function to call

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • GearmanClient::setDataCallback() - Callback function when there is a data packet for a task
  • GearmanClient::setCompleteCallback() - Set a function to be called on task completion
  • GearmanClient::setCreatedCallback() - Set a callback for when a task is queued
  • GearmanClient::setExceptionCallback() - Set a callback for worker exceptions
  • GearmanClient::setFailCallback() - Set callback for job failure
  • GearmanClient::setWarningCallback() - Set a callback for worker warnings
  • GearmanClient::setWorkloadCallback() - Set a callback for accepting incremental data updates

GearmanClient::setOptions
GearmanClient::setTimeout
GearmanClient


Set socket I/O activity timeout

GearmanClient::setStatusCallback
GearmanClient::setWarningCallback
GearmanClient
PHP Manual

GearmanClient::setTimeout

(PECL gearman >= 0.6.0)

GearmanClient::setTimeout — Set socket I/O activity timeout

Açıklama

public bool GearmanClient::setTimeout ( int $timeout )

Sets the timeout for socket I/O activity.

Değiştirgeler

timeout

An interval of time in milliseconds

Dönen Değerler

Always returns TRUE.

GearmanClient::setStatusCallback
GearmanClient::setWarningCallback
GearmanClient


Set a callback for worker warnings

GearmanClient::setTimeout
GearmanClient::setWorkloadCallback
GearmanClient
PHP Manual

GearmanClient::setWarningCallback

(PECL gearman >= 0.5.0)

GearmanClient::setWarningCallback — Set a callback for worker warnings

Açıklama

public bool GearmanClient::setWarningCallback ( callable $callback )

Sets a function to be called when a worker sends a warning. The callback should accept a single argument, a GearmanTask object.

Değiştirgeler

callback

A function to call

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • GearmanClient::setDataCallback() - Callback function when there is a data packet for a task
  • GearmanClient::setCompleteCallback() - Set a function to be called on task completion
  • GearmanClient::setCreatedCallback() - Set a callback for when a task is queued
  • GearmanClient::setExceptionCallback() - Set a callback for worker exceptions
  • GearmanClient::setFailCallback() - Set callback for job failure
  • GearmanClient::setStatusCallback() - Set a callback for collecting task status
  • GearmanClient::setWorkloadCallback() - Set a callback for accepting incremental data updates

GearmanClient::setTimeout
GearmanClient::setWorkloadCallback
GearmanClient


Set a callback for accepting incremental data updates

GearmanClient::setWarningCallback
GearmanClient::timeout
GearmanClient
PHP Manual

GearmanClient::setWorkloadCallback

(PECL gearman >= 0.5.0)

GearmanClient::setWorkloadCallback — Set a callback for accepting incremental data updates

Açıklama

public bool GearmanClient::setWorkloadCallback ( callable $callback )

Sets a function to be called when a worker needs to send back data prior to job completion. A worker can do this when it needs to send updates, send partial results, or flush data during long running jobs. The callback should accept a single argument, a GearmanTask object.

Değiştirgeler

callback

A function to call

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • GearmanClient::setDataCallback() - Callback function when there is a data packet for a task
  • GearmanClient::setCompleteCallback() - Set a function to be called on task completion
  • GearmanClient::setCreatedCallback() - Set a callback for when a task is queued
  • GearmanClient::setExceptionCallback() - Set a callback for worker exceptions
  • GearmanClient::setFailCallback() - Set callback for job failure
  • GearmanClient::setStatusCallback() - Set a callback for collecting task status
  • GearmanClient::setWarningCallback() - Set a callback for worker warnings

GearmanClient::setWarningCallback
GearmanClient::timeout
GearmanClient


Get current socket I/O activity timeout value

GearmanClient::setWorkloadCallback
GearmanJob
GearmanClient
PHP Manual

GearmanClient::timeout

(PECL gearman >= 0.6.0)

GearmanClient::timeout — Get current socket I/O activity timeout value

Açıklama

public int GearmanClient::timeout ( void )

Returns the timeout in milliseconds to wait for I/O activity.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Timeout in milliseconds to wait for I/O activity. A negative value means an infinite timeout.

Ayrıca Bakınız

  • GearmanClient::setTimeout() - Set socket I/O activity timeout

GearmanClient::setWorkloadCallback
GearmanJob
GearmanClient


The GearmanJob class

(PECL gearman >= 0.5.0)

Giriş

Sınıf Sözdizimi

GearmanJob {
/* Yöntemler */
public bool complete ( string $result )
public __construct ( void )
public bool data ( string $data )
public bool exception ( string $exception )
public bool fail ( void )
public string functionName ( void )
public string handle ( void )
public int returnCode ( void )
public bool sendComplete ( string $result )
public bool sendData ( string $data )
public bool sendException ( string $exception )
public bool sendFail ( void )
public bool sendStatus ( int $numerator , int $denominator )
public bool sendWarning ( string $warning )
public bool setReturn ( int $gearman_return_t )
public bool status ( int $numerator , int $denominator )
public string unique ( void )
public bool warning ( string $warning )
public string workload ( void )
public int workloadSize ( void )
}

İçindekiler

  • GearmanJob::complete — Send the result and complete status (deprecated)
  • GearmanJob::__construct — Create a GearmanJob instance
  • GearmanJob::data — Send data for a running job (deprecated)
  • GearmanJob::exception — Send exception for running job (deprecated)
  • GearmanJob::fail — Send fail status (deprecated)
  • GearmanJob::functionName — Get function name
  • GearmanJob::handle — Get the job handle
  • GearmanJob::returnCode — Get last return code
  • GearmanJob::sendComplete — Send the result and complete status
  • GearmanJob::sendData — Send data for a running job
  • GearmanJob::sendException — Send exception for running job (exception)
  • GearmanJob::sendFail — Send fail status
  • GearmanJob::sendStatus — Send status
  • GearmanJob::sendWarning — Send a warning
  • GearmanJob::setReturn — Set a return value
  • GearmanJob::status — Send status (deprecated)
  • GearmanJob::unique — Get the unique identifier
  • GearmanJob::warning — Send a warning (deprecated)
  • GearmanJob::workload — Get workload
  • GearmanJob::workloadSize — Get size of work load
GearmanClient::timeout
GearmanJob::complete
Gearman


Send the result and complete status (deprecated)

GearmanJob
GearmanJob::__construct
GearmanJob
PHP Manual

GearmanJob::complete

(PECL gearman <= 0.5.0)

GearmanJob::complete — Send the result and complete status (deprecated)

Açıklama

public bool GearmanJob::complete ( string $result )

Sends result data and the complete status update for this job.

Bilginize:

This method has been replaced by GearmanJob::sendComplete() in the 0.6.0 release of the Gearman extension.

Değiştirgeler

result

Serialized result data.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • GearmanJob::sendFail() - Send fail status
  • GearmanJob::setReturn() - Set a return value

GearmanJob
GearmanJob::__construct
GearmanJob


Create a GearmanJob instance

GearmanJob::complete
GearmanJob::data
GearmanJob
PHP Manual

GearmanJob::__construct

(PECL gearman >= 0.5.0)

GearmanJob::__construct — Create a GearmanJob instance

Açıklama

public GearmanJob::__construct ( void )

Creates a GearmanJob instance representing a job the worker is to complete.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A GearmanJob object.

GearmanJob::complete
GearmanJob::data
GearmanJob


Send data for a running job (deprecated)

GearmanJob::__construct
GearmanJob::exception
GearmanJob
PHP Manual

GearmanJob::data

(PECL gearman <= 0.5.0)

GearmanJob::data — Send data for a running job (deprecated)

Açıklama

public bool GearmanJob::data ( string $data )

Sends data to the job server (and any listening clients) for this job.

Bilginize:

This method has been replaced by GearmanJob::sendData() in the 0.6.0 release of the Gearman extension.

Değiştirgeler

data

Arbitrary serialized data.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • GearmanJob::workload() - Get workload
  • GearmanTask::data() - Get data returned for a task

GearmanJob::__construct
GearmanJob::exception
GearmanJob


Send exception for running job (deprecated)

GearmanJob::data
GearmanJob::fail
GearmanJob
PHP Manual

GearmanJob::exception

(PECL gearman <= 0.5.0)

GearmanJob::exception — Send exception for running job (deprecated)

Açıklama

public bool GearmanJob::exception ( string $exception )

Sends the supplied exception when this job is running.

Bilginize:

This method has been replaced by GearmanJob::sendException() in the 0.6.0 release of the Gearman extension.

Değiştirgeler

exception

An exception description.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • GearmanJob::setReturn() - Set a return value
  • GearmanJob::sendStatus() - Send status
  • GearmanJob::sendWarning() - Send a warning

GearmanJob::data
GearmanJob::fail
GearmanJob


Send fail status (deprecated)

GearmanJob::exception
GearmanJob::functionName
GearmanJob
PHP Manual

GearmanJob::fail

(PECL gearman <= 0.5.0)

GearmanJob::fail — Send fail status (deprecated)

Açıklama

public bool GearmanJob::fail ( void )

Sends failure status for this job, indicating that the job failed in a known way (as opposed to failing due to a thrown exception).

Bilginize:

This method has been replaced by GearmanJob::sendFail() in the 0.6.0 release of the Gearman extension.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • GearmanJob::sendException() - Send exception for running job (exception)
  • GearmanJob::setReturn() - Set a return value
  • GearmanJob::sendStatus() - Send status
  • GearmanJob::sendWarning() - Send a warning

GearmanJob::exception
GearmanJob::functionName
GearmanJob


Get function name

GearmanJob::fail
GearmanJob::handle
GearmanJob
PHP Manual

GearmanJob::functionName

(PECL gearman >= 0.5.0)

GearmanJob::functionName — Get function name

Açıklama

public string GearmanJob::functionName ( void )

Returns the function name for this job. This is the function the work will execute to perform the job.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The name of a function.

Ayrıca Bakınız

  • GearmanTask::function() - Get associated function name (deprecated)

GearmanJob::fail
GearmanJob::handle
GearmanJob


Get the job handle

GearmanJob::functionName
GearmanJob::returnCode
GearmanJob
PHP Manual

GearmanJob::handle

(PECL gearman >= 0.5.0)

GearmanJob::handle — Get the job handle

Açıklama

public string GearmanJob::handle ( void )

Returns the opaque job handle assigned by the job server.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

An opaque job handle.

Ayrıca Bakınız

  • GearmanTask::jobHandle() - Get the job handle

GearmanJob::functionName
GearmanJob::returnCode
GearmanJob


Get last return code

GearmanJob::handle
GearmanJob::sendComplete
GearmanJob
PHP Manual

GearmanJob::returnCode

(PECL gearman >= 0.5.0)

GearmanJob::returnCode — Get last return code

Açıklama

public int GearmanJob::returnCode ( void )

Returns the last return code issued by the job server.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A valid Gearman return code.

Ayrıca Bakınız

  • GearmanTask::returnCode() - Get the last return code

GearmanJob::handle
GearmanJob::sendComplete
GearmanJob


Send the result and complete status

GearmanJob::returnCode
GearmanJob::sendData
GearmanJob
PHP Manual

GearmanJob::sendComplete

(PECL gearman >= 0.6.0)

GearmanJob::sendComplete — Send the result and complete status

Açıklama

public bool GearmanJob::sendComplete ( string $result )

Sends result data and the complete status update for this job.

Değiştirgeler

result

Serialized result data.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • GearmanJob::sendFail() - Send fail status
  • GearmanJob::setReturn() - Set a return value

GearmanJob::returnCode
GearmanJob::sendData
GearmanJob


Send data for a running job

GearmanJob::sendComplete
GearmanJob::sendException
GearmanJob
PHP Manual

GearmanJob::sendData

(PECL gearman >= 0.6.0)

GearmanJob::sendData — Send data for a running job

Açıklama

public bool GearmanJob::sendData ( string $data )

Sends data to the job server (and any listening clients) for this job.

Değiştirgeler

data

Arbitrary serialized data.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • GearmanJob::workload() - Get workload
  • GearmanTask::data() - Get data returned for a task

GearmanJob::sendComplete
GearmanJob::sendException
GearmanJob


Send exception for running job (exception)

GearmanJob::sendData
GearmanJob::sendFail
GearmanJob
PHP Manual

GearmanJob::sendException

(PECL gearman >= 0.6.0)

GearmanJob::sendException — Send exception for running job (exception)

Açıklama

public bool GearmanJob::sendException ( string $exception )

Sends the supplied exception when this job is running.

Değiştirgeler

exception

An exception description.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • GearmanJob::setReturn() - Set a return value
  • GearmanJob::sendStatus() - Send status
  • GearmanJob::sendWarning() - Send a warning

GearmanJob::sendData
GearmanJob::sendFail
GearmanJob


Send fail status

GearmanJob::sendException
GearmanJob::sendStatus
GearmanJob
PHP Manual

GearmanJob::sendFail

(PECL gearman >= 0.6.0)

GearmanJob::sendFail — Send fail status

Açıklama

public bool GearmanJob::sendFail ( void )

Sends failure status for this job, indicating that the job failed in a known way (as opposed to failing due to a thrown exception).

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • GearmanJob::sendException() - Send exception for running job (exception)
  • GearmanJob::setReturn() - Set a return value
  • GearmanJob::sendStatus() - Send status
  • GearmanJob::sendWarning() - Send a warning

GearmanJob::sendException
GearmanJob::sendStatus
GearmanJob


Send status

GearmanJob::sendFail
GearmanJob::sendWarning
GearmanJob
PHP Manual

GearmanJob::sendStatus

(PECL gearman >= 0.6.0)

GearmanJob::sendStatus — Send status

Açıklama

public bool GearmanJob::sendStatus ( int $numerator , int $denominator )

Sends status information to the job server and any listening clients. Use this to specify what percentage of the job has been completed.

Değiştirgeler

numerator

The numerator of the precentage completed expressed as a fraction.

denominator

The denominator of the precentage completed expressed as a fraction.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • GearmanClient::jobStatus() - Get the status of a background job
  • GearmanTask::taskDenominator() - Get completion percentage denominator
  • GearmanTask::taskNumerator() - Get completion percentage numerator

GearmanJob::sendFail
GearmanJob::sendWarning
GearmanJob


Send a warning

GearmanJob::sendStatus
GearmanJob::setReturn
GearmanJob
PHP Manual

GearmanJob::sendWarning

(PECL gearman >= 0.6.0)

GearmanJob::sendWarning — Send a warning

Açıklama

public bool GearmanJob::sendWarning ( string $warning )

Sends a warning for this job while it is running.

Değiştirgeler

warning

A warning message.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • GearmanJob::sendComplete() - Send the result and complete status
  • GearmanJob::sendException() - Send exception for running job (exception)
  • GearmanJob::sendFail() - Send fail status

GearmanJob::sendStatus
GearmanJob::setReturn
GearmanJob


Set a return value

GearmanJob::sendWarning
GearmanJob::status
GearmanJob
PHP Manual

GearmanJob::setReturn

(PECL gearman >= 0.5.0)

GearmanJob::setReturn — Set a return value

Açıklama

public bool GearmanJob::setReturn ( int $gearman_return_t )

Sets the return value for this job, indicates how the job completed.

Değiştirgeler

gearman_return_t

A valid Gearman return value.

Dönen Değerler

Description...

GearmanJob::sendWarning
GearmanJob::status
GearmanJob


Send status (deprecated)

GearmanJob::setReturn
GearmanJob::unique
GearmanJob
PHP Manual

GearmanJob::status

(PECL gearman <= 0.5.0)

GearmanJob::status — Send status (deprecated)

Açıklama

public bool GearmanJob::status ( int $numerator , int $denominator )

Sends status information to the job server and any listening clients. Use this to specify what percentage of the job has been completed.

Bilginize:

This method has been replaced by GearmanJob::sendStatus() in the 0.6.0 release of the Gearman extenstion.

Değiştirgeler

numerator

The numerator of the precentage completed expressed as a fraction.

denominator

The denominator of the precentage completed expressed as a fraction.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • GearmanClient::jobStatus() - Get the status of a background job
  • GearmanTask::taskDenominator() - Get completion percentage denominator
  • GearmanTask::taskNumerator() - Get completion percentage numerator

GearmanJob::setReturn
GearmanJob::unique
GearmanJob


Get the unique identifier

GearmanJob::status
GearmanJob::warning
GearmanJob
PHP Manual

GearmanJob::unique

(PECL gearman >= 0.5.0)

GearmanJob::unique — Get the unique identifier

Açıklama

public string GearmanJob::unique ( void )

Returns the unique identifiter for this job. The identifier is assigned by the client.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

An opaque unique identifier.

Ayrıca Bakınız

  • GearmanClient::do() - Run a single task and return a result [deprecated]
  • GearmanTask::uuid() - Get the unique identifier for a task (deprecated)

GearmanJob::status
GearmanJob::warning
GearmanJob


Send a warning (deprecated)

GearmanJob::unique
GearmanJob::workload
GearmanJob
PHP Manual

GearmanJob::warning

(PECL gearman <= 0.5.0)

GearmanJob::warning — Send a warning (deprecated)

Açıklama

public bool GearmanJob::warning ( string $warning )

Sends a warning for this job while it is running.

Bilginize:

This method has been replaced by GearmanJob::sendWarning() in the 0.6.0 release of the Gearman extension.

Değiştirgeler

warning

A warning messages.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • GearmanJob::sendComplete() - Send the result and complete status
  • GearmanJob::sendException() - Send exception for running job (exception)
  • GearmanJob::sendFail() - Send fail status

GearmanJob::unique
GearmanJob::workload
GearmanJob


Get workload

GearmanJob::warning
GearmanJob::workloadSize
GearmanJob
PHP Manual

GearmanJob::workload

(PECL gearman >= 0.5.0)

GearmanJob::workload — Get workload

Açıklama

public string GearmanJob::workload ( void )

Returns the workload for the job. This is serialized data that is to be processed by the worker.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Serialized data.

Ayrıca Bakınız

  • GearmanClient::do() - Run a single task and return a result [deprecated]
  • GearmanJob::workloadSize() - Get size of work load

GearmanJob::warning
GearmanJob::workloadSize
GearmanJob


Get size of work load

GearmanJob::workload
GearmanTask
GearmanJob
PHP Manual

GearmanJob::workloadSize

(PECL gearman >= 0.5.0)

GearmanJob::workloadSize — Get size of work load

Açıklama

public int GearmanJob::workloadSize ( void )

Returns the size of the job's work load (the data the worker is to process) in bytes.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The size in bytes.

Ayrıca Bakınız

  • GearmanJob::workload() - Get workload

GearmanJob::workload
GearmanTask
GearmanJob


The GearmanTask class

(PECL gearman >= 0.5.0)

Giriş

Sınıf Sözdizimi

GearmanTask {
/* Yöntemler */
public __construct ( void )
public GearmanTask create ( void )
public string data ( void )
public int dataSize ( void )
public string function ( void )
public string functionName ( void )
public bool isKnown ( void )
public bool isRunning ( void )
public string jobHandle ( void )
public array recvData ( int $data_len )
public int returnCode ( void )
public int sendData ( string $data )
public int sendWorkload ( string $data )
public int taskDenominator ( void )
public int taskNumerator ( void )
public string unique ( void )
public string uuid ( void )
}

İçindekiler

  • GearmanTask::__construct — Create a GearmanTask instance
  • GearmanTask::create — Create a task (deprecated)
  • GearmanTask::data — Get data returned for a task
  • GearmanTask::dataSize — Get the size of returned data
  • GearmanTask::function — Get associated function name (deprecated)
  • GearmanTask::functionName — Get associated function name
  • GearmanTask::isKnown — Determine if task is known
  • GearmanTask::isRunning — Test whether the task is currently running
  • GearmanTask::jobHandle — Get the job handle
  • GearmanTask::recvData — Read work or result data into a buffer for a task
  • GearmanTask::returnCode — Get the last return code
  • GearmanTask::sendData — Send data for a task (deprecated)
  • GearmanTask::sendWorkload — Send data for a task
  • GearmanTask::taskDenominator — Get completion percentage denominator
  • GearmanTask::taskNumerator — Get completion percentage numerator
  • GearmanTask::unique — Get the unique identifier for a task
  • GearmanTask::uuid — Get the unique identifier for a task (deprecated)
GearmanJob::workloadSize
GearmanTask::__construct
Gearman


Create a GearmanTask instance

GearmanTask
GearmanTask::create
GearmanTask
PHP Manual

GearmanTask::__construct

(PECL gearman >= 0.5.0)

GearmanTask::__construct — Create a GearmanTask instance

Açıklama

public GearmanTask::__construct ( void )

Creates a GearmanTask instance representing a task to be submitted to a job server.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A GearmanTask object.

GearmanTask
GearmanTask::create
GearmanTask


Create a task (deprecated)

GearmanTask::__construct
GearmanTask::data
GearmanTask
PHP Manual

GearmanTask::create

(PECL gearman <= 0.5.0)

GearmanTask::create — Create a task (deprecated)

Açıklama

public GearmanTask GearmanTask::create ( void )

Returns a new GearmanTask object.

Bilginize:

This method was removed in the 0.6.0 version of the Gearman extension.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A GearmanTask oject başarısızlık durumunda FALSE döner.

GearmanTask::__construct
GearmanTask::data
GearmanTask


Get data returned for a task

GearmanTask::create
GearmanTask::dataSize
GearmanTask
PHP Manual

GearmanTask::data

(PECL gearman >= 0.5.0)

GearmanTask::data — Get data returned for a task

Açıklama

public string GearmanTask::data ( void )

Returns data being returned for a task by a worker.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The serialized data, or FALSE if no data is present.

Ayrıca Bakınız

  • GearmanTask::dataSize() - Get the size of returned data

GearmanTask::create
GearmanTask::dataSize
GearmanTask


Get the size of returned data

GearmanTask::data
GearmanTask::function
GearmanTask
PHP Manual

GearmanTask::dataSize

(PECL gearman >= 0.5.0)

GearmanTask::dataSize — Get the size of returned data

Açıklama

public int GearmanTask::dataSize ( void )

Returns the size of the data being returned for a task.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The data size, or FALSE if there is no data.

Ayrıca Bakınız

  • GearmanTask::data() - Get data returned for a task

GearmanTask::data
GearmanTask::function
GearmanTask


Get associated function name (deprecated)

GearmanTask::dataSize
GearmanTask::functionName
GearmanTask
PHP Manual

GearmanTask::function

(PECL gearman <= 0.5.0)

GearmanTask::function — Get associated function name (deprecated)

Açıklama

public string GearmanTask::function ( void )

Returns the name of the function this task is associated with, i.e., the function the Gearman worker calls.

Bilginize:

This method has been replaced by GearmanTask::functionName() in the 0.6.0 release of the Gearman extension.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A function name.

GearmanTask::dataSize
GearmanTask::functionName
GearmanTask


Get associated function name

GearmanTask::function
GearmanTask::isKnown
GearmanTask
PHP Manual

GearmanTask::functionName

(PECL gearman >= 0.6.0)

GearmanTask::functionName — Get associated function name

Açıklama

public string GearmanTask::functionName ( void )

Returns the name of the function this task is associated with, i.e., the function the Gearman worker calls.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A function name.

GearmanTask::function
GearmanTask::isKnown
GearmanTask


Determine if task is known

GearmanTask::functionName
GearmanTask::isRunning
GearmanTask
PHP Manual

GearmanTask::isKnown

(PECL gearman >= 0.5.0)

GearmanTask::isKnown — Determine if task is known

Açıklama

public bool GearmanTask::isKnown ( void )

Gets the status information for whether or not this task is known to the job server.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

TRUE if the task is known, FALSE otherwise.

GearmanTask::functionName
GearmanTask::isRunning
GearmanTask


Test whether the task is currently running

GearmanTask::isKnown
GearmanTask::jobHandle
GearmanTask
PHP Manual

GearmanTask::isRunning

(PECL gearman >= 0.5.0)

GearmanTask::isRunning — Test whether the task is currently running

Açıklama

public bool GearmanTask::isRunning ( void )

Indicates whether or not this task is currently running.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

TRUE if the task is running, FALSE otherwise.

GearmanTask::isKnown
GearmanTask::jobHandle
GearmanTask


Get the job handle

GearmanTask::isRunning
GearmanTask::recvData
GearmanTask
PHP Manual

GearmanTask::jobHandle

gearman_job_handle

(PECL gearman >= 0.5.0)

GearmanTask::jobHandle -- gearman_job_handle — Get the job handle

Açıklama

public string GearmanTask::jobHandle ( void )

Returns the job handle for this task.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The opaque job handle.

Ayrıca Bakınız

  • GearmanClient::doJobHandle() - Get the job handle for the running task

GearmanTask::isRunning
GearmanTask::recvData
GearmanTask


Read work or result data into a buffer for a task

GearmanTask::jobHandle
GearmanTask::returnCode
GearmanTask
PHP Manual

GearmanTask::recvData

(PECL gearman >= 0.5.0)

GearmanTask::recvData — Read work or result data into a buffer for a task

Açıklama

public array GearmanTask::recvData ( int $data_len )

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Değiştirgeler

data_len

Length of data to be read.

Dönen Değerler

An array whose first element is the length of data read and the second is the data buffer. Returns FALSE if the read failed.

Ayrıca Bakınız

  • GearmanTask::sendData() - Send data for a task (deprecated)

GearmanTask::jobHandle
GearmanTask::returnCode
GearmanTask


Get the last return code

GearmanTask::recvData
GearmanTask::sendData
GearmanTask
PHP Manual

GearmanTask::returnCode

(PECL gearman >= 0.5.0)

GearmanTask::returnCode — Get the last return code

Açıklama

public int GearmanTask::returnCode ( void )

Returns the last Gearman return code for this task.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A valid Gearman return code.

Ayrıca Bakınız

  • GearmanClient::returnCode() - Get the last Gearman return code

GearmanTask::recvData
GearmanTask::sendData
GearmanTask


Send data for a task (deprecated)

GearmanTask::returnCode
GearmanTask::sendWorkload
GearmanTask
PHP Manual

GearmanTask::sendData

(PECL gearman <= 0.5.0)

GearmanTask::sendData — Send data for a task (deprecated)

Açıklama

public int GearmanTask::sendData ( string $data )

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Değiştirgeler

data

Data to send to the worker.

Dönen Değerler

The length of data sent, or FALSE if the send failed.

Ayrıca Bakınız

  • GearmanTask::recvData() - Read work or result data into a buffer for a task

GearmanTask::returnCode
GearmanTask::sendWorkload
GearmanTask


Send data for a task

GearmanTask::sendData
GearmanTask::taskDenominator
GearmanTask
PHP Manual

GearmanTask::sendWorkload

(PECL gearman >= 0.6.0)

GearmanTask::sendWorkload — Send data for a task

Açıklama

public int GearmanTask::sendWorkload ( string $data )

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Değiştirgeler

data

Data to send to the worker.

Dönen Değerler

The length of data sent, or FALSE if the send failed.

Ayrıca Bakınız

  • GearmanTask::recvData() - Read work or result data into a buffer for a task

GearmanTask::sendData
GearmanTask::taskDenominator
GearmanTask


Get completion percentage denominator

GearmanTask::sendWorkload
GearmanTask::taskNumerator
GearmanTask
PHP Manual

GearmanTask::taskDenominator

(PECL gearman >= 0.5.0)

GearmanTask::taskDenominator — Get completion percentage denominator

Açıklama

public int GearmanTask::taskDenominator ( void )

Returns the denominator of the percentage of the task that is complete expressed as a fraction.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A number between 0 and 100, or FALSE if cannot be determined.

Ayrıca Bakınız

  • GearmanTask::taskNumerator() - Get completion percentage numerator

GearmanTask::sendWorkload
GearmanTask::taskNumerator
GearmanTask


Get completion percentage numerator

GearmanTask::taskDenominator
GearmanTask::unique
GearmanTask
PHP Manual

GearmanTask::taskNumerator

(PECL gearman >= 0.5.0)

GearmanTask::taskNumerator — Get completion percentage numerator

Açıklama

public int GearmanTask::taskNumerator ( void )

Returns the numerator of the percentage of the task that is complete expressed as a fraction.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A number between 0 and 100, or FALSE if cannot be determined.

Ayrıca Bakınız

  • GearmanTask::taskDenominator() - Get completion percentage denominator

GearmanTask::taskDenominator
GearmanTask::unique
GearmanTask


Get the unique identifier for a task

GearmanTask::taskNumerator
GearmanTask::uuid
GearmanTask
PHP Manual

GearmanTask::unique

(PECL gearman >= 0.6.0)

GearmanTask::unique — Get the unique identifier for a task

Açıklama

public string GearmanTask::unique ( void )

Returns the unique identifier for this task. This is assigned by the GearmanClient, as opposed to the job handle which is set by the Gearman job server.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The unique identifier, or FALSE if no identifier is assigned.

Ayrıca Bakınız

  • GearmanClient::do() - Run a single task and return a result [deprecated]
  • GearmanClient::addTask() - Add a task to be run in parallel

GearmanTask::taskNumerator
GearmanTask::uuid
GearmanTask


Get the unique identifier for a task (deprecated)

GearmanTask::unique
GearmanWorker
GearmanTask
PHP Manual

GearmanTask::uuid

(PECL gearman <= 0.5.0)

GearmanTask::uuid — Get the unique identifier for a task (deprecated)

Açıklama

public string GearmanTask::uuid ( void )

Returns the unique identifier for this task. This is assigned by the GearmanClient, as opposed to the job handle which is set by the Gearman job server.

Bilginize:

This method has been replaced by GearmanTask::unique() in the 0.6.0 release of the Gearman extension.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The unique identifier, or FALSE if no identifier is assigned.

Ayrıca Bakınız

  • GearmanClient::do() - Run a single task and return a result [deprecated]
  • GearmanClient::addTask() - Add a task to be run in parallel

GearmanTask::unique
GearmanWorker
GearmanTask


The GearmanWorker class

(PECL gearman >= 0.5.0)

Giriş

Sınıf Sözdizimi

GearmanWorker {
/* Yöntemler */
public bool addFunction ( string $function_name , callable $function [, mixed &$context [, int $timeout ]] )
public bool addOptions ( int $option )
public bool addServer ([ string $host = 127.0.0.1 [, int $port = 4730 ]] )
public bool addServers ( string $servers = 127.0.0.1:4730 )
public void clone ( void )
public __construct ( void )
public bool echo ( string $workload )
public string error ( void )
public int getErrno ( void )
public int options ( void )
public bool register ( string $function_name [, int $timeout ] )
public bool removeOptions ( int $option )
public int returnCode ( void )
public bool setId ( string $id )
public bool setOptions ( int $option )
public bool setTimeout ( int $timeout )
public int timeout ( void )
public bool unregister ( string $function_name )
public bool unregisterAll ( void )
public bool wait ( void )
public bool work ( void )
}

İçindekiler

  • GearmanWorker::addFunction — Register and add callback function
  • GearmanWorker::addOptions — Add worker options
  • GearmanWorker::addServer — Add a job server
  • GearmanWorker::addServers — Add job servers
  • GearmanWorker::clone — Create a copy of the worker
  • GearmanWorker::__construct — Create a GearmanWorker instance
  • GearmanWorker::echo — Test job server response
  • GearmanWorker::error — Get the last error encountered
  • GearmanWorker::getErrno — Get errno
  • GearmanWorker::options — Get worker options
  • GearmanWorker::register — Register a function with the job server
  • GearmanWorker::removeOptions — Remove worker options
  • GearmanWorker::returnCode — Get last Gearman return code
  • GearmanWorker::setId — Give the worker an identifier so it can be tracked when asking gearmand for the list of available workers.
  • GearmanWorker::setOptions — Set worker options
  • GearmanWorker::setTimeout — Set socket I/O activity timeout
  • GearmanWorker::timeout — Get socket I/O activity timeout
  • GearmanWorker::unregister — Unregister a function name with the job servers
  • GearmanWorker::unregisterAll — Unregister all function names with the job servers
  • GearmanWorker::wait — Wait for activity from one of the job servers
  • GearmanWorker::work — Wait for and perform jobs
GearmanTask::uuid
GearmanWorker::addFunction
Gearman


Register and add callback function

GearmanWorker
GearmanWorker::addOptions
GearmanWorker
PHP Manual

GearmanWorker::addFunction

(PECL gearman >= 0.5.0)

GearmanWorker::addFunction — Register and add callback function

Açıklama

public bool GearmanWorker::addFunction ( string $function_name , callable $function [, mixed &$context [, int $timeout ]] )

Registers a function name with the job server and specifies a callback corresponding to that function. Optionally specify extra application context data to be used when the callback is called and a timeout.

Değiştirgeler

function_name

The name of a function to register with the job server

function

A callback that gets called when a job for the registered function name is submitted

context

A reference to arbitrary application context data that can be modified by the worker function

timeout

An interval of time in seconds

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Simple worker making use of extra application context data

<?php

# get a gearman worker
$worker= new GearmanWorker();

# add the default server (localhost)
$worker->addServer();

# define a variable to hold application data
$count= 0;

# add the "reverse" function
$worker->addFunction("reverse", "reverse_cb", $count);

# start the worker
while ($worker->work());

function reverse_cb($job, &$count)
{
  $count++;
  return "$count: " . strrev($job->workload());
}

?>

Running a client that submits two jobs for the reverse function would have output similar to the following:

1: olleh
2: dlrow

Ayrıca Bakınız

  • GearmanClient::do() - Run a single task and return a result [deprecated]

GearmanWorker
GearmanWorker::addOptions
GearmanWorker


Add worker options

GearmanWorker::addFunction
GearmanWorker::addServer
GearmanWorker
PHP Manual

GearmanWorker::addOptions

(PECL gearman >= 0.6.0)

GearmanWorker::addOptions — Add worker options

Açıklama

public bool GearmanWorker::addOptions ( int $option )

Adds one or more options to the options previously set.

Değiştirgeler

option

The options to be added

Dönen Değerler

Always returns TRUE.

Ayrıca Bakınız

  • GearmanWorker::options() - Get worker options
  • GearmanClient::setOptions() - Set client options
  • GearmanClient::removeOptions() - Remove client options

GearmanWorker::addFunction
GearmanWorker::addServer
GearmanWorker


Add a job server

GearmanWorker::addOptions
GearmanWorker::addServers
GearmanWorker
PHP Manual

GearmanWorker::addServer

(PECL gearman >= 0.5.0)

GearmanWorker::addServer — Add a job server

Açıklama

public bool GearmanWorker::addServer ([ string $host = 127.0.0.1 [, int $port = 4730 ]] )

Adds a job server to this worker. This goes into a list of servers than can be used to run jobs. No socket I/O happens here.

Değiştirgeler

host

The job server host name.

port

The job server port.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Add alternate Gearman servers

<?php
$worker= new GearmanWorker();
$worker->addServer("10.0.0.1");
$worker->addServer("10.0.0.2", 7003);
?>

Ayrıca Bakınız

  • GearmanWorker::addServers() - Add job servers

GearmanWorker::addOptions
GearmanWorker::addServers
GearmanWorker


Add job servers

GearmanWorker::addServer
GearmanWorker::clone
GearmanWorker
PHP Manual

GearmanWorker::addServers

(PECL gearman >= 0.5.0)

GearmanWorker::addServers — Add job servers

Açıklama

public bool GearmanWorker::addServers ( string $servers = 127.0.0.1:4730 )

Adds one or more job servers to this worker. These go into a list of servers that can be used to run jobs. No socket I/O happens here.

Değiştirgeler

servers

A comma separated list of job servers in the format host:port. If no port is specified, it defaults to 4730.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Add two job servers

<?php

$worker= new GearmanWorker();
$worker->addServers("10.0.0.1,10.0.0.2:7003");

?>

Ayrıca Bakınız

  • GearmanWorker::addServer() - Add a job server

GearmanWorker::addServer
GearmanWorker::clone
GearmanWorker


Create a copy of the worker

GearmanWorker::addServers
GearmanWorker::__construct
GearmanWorker
PHP Manual

GearmanWorker::clone

(PECL gearman >= 0.5.0)

GearmanWorker::clone — Create a copy of the worker

Açıklama

public void GearmanWorker::clone ( void )

Creates a copy of the worker.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A GearmanWorker object

GearmanWorker::addServers
GearmanWorker::__construct
GearmanWorker


Create a GearmanWorker instance

GearmanWorker::clone
GearmanWorker::echo
GearmanWorker
PHP Manual

GearmanWorker::__construct

(PECL gearman >= 0.5.0)

GearmanWorker::__construct — Create a GearmanWorker instance

Açıklama

public GearmanWorker::__construct ( void )

Creates a GearmanWorker instance representing a worker that connects to the job server and accepts tasks to run.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A GearmanWorker object

Ayrıca Bakınız

  • GearmanWorker::clone() - Create a copy of the worker

GearmanWorker::clone
GearmanWorker::echo
GearmanWorker


Test job server response

GearmanWorker::__construct
GearmanWorker::error
GearmanWorker
PHP Manual

GearmanWorker::echo

(PECL gearman >= 0.6.0)

GearmanWorker::echo — Test job server response

Açıklama

public bool GearmanWorker::echo ( string $workload )

Sends data to all job servers to see if they echo it back. This is a test function to see if job servers are responding properly.

Değiştirgeler

workload

Arbitrary serialized data

Dönen Değerler

Standard Gearman return value.

Ayrıca Bakınız

  • GearmanClient::echo() - Send data to all job servers to see if they echo it back [deprecated]

GearmanWorker::__construct
GearmanWorker::error
GearmanWorker


Get the last error encountered

GearmanWorker::echo
GearmanWorker::getErrno
GearmanWorker
PHP Manual

GearmanWorker::error

(PECL gearman >= 0.5.0)

GearmanWorker::error — Get the last error encountered

Açıklama

public string GearmanWorker::error ( void )

Returns an error string for the last error encountered.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

An error string.

Ayrıca Bakınız

  • GearmanWorker::getErrno() - Get errno

GearmanWorker::echo
GearmanWorker::getErrno
GearmanWorker


Get errno

GearmanWorker::error
GearmanWorker::options
GearmanWorker
PHP Manual

GearmanWorker::getErrno

(PECL gearman >= 0.5.0)

GearmanWorker::getErrno — Get errno

Açıklama

public int GearmanWorker::getErrno ( void )

Returns the value of errno in the case of a GEARMAN_ERRNO return value.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A valid errno.

Ayrıca Bakınız

  • GearmanWorker::error() - Get the last error encountered

GearmanWorker::error
GearmanWorker::options
GearmanWorker


Get worker options

GearmanWorker::getErrno
GearmanWorker::register
GearmanWorker
PHP Manual

GearmanWorker::options

(PECL gearman >= 0.6.0)

GearmanWorker::options — Get worker options

Açıklama

public int GearmanWorker::options ( void )

Gets the options previously set for the worker.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The options currently set for the worker.

Ayrıca Bakınız

  • GearmanWorker::setOptions() - Set worker options

GearmanWorker::getErrno
GearmanWorker::register
GearmanWorker


Register a function with the job server

GearmanWorker::options
GearmanWorker::removeOptions
GearmanWorker
PHP Manual

GearmanWorker::register

(PECL gearman >= 0.6.0)

GearmanWorker::register — Register a function with the job server

Açıklama

public bool GearmanWorker::register ( string $function_name [, int $timeout ] )

Registers a function name with the job server with an optional timeout. The timeout specifies how many seconds the server will wait before marking a job as failed. If the timeout is set to zero, there is no timeout.

Değiştirgeler

function_name

The name of a function to register with the job server

timeout

An interval of time in seconds

Dönen Değerler

A standard Gearman return value.

Ayrıca Bakınız

  • GearmanWorker::unregister() - Unregister a function name with the job servers
  • GearmanWorker::unregisterAll() - Unregister all function names with the job servers

GearmanWorker::options
GearmanWorker::removeOptions
GearmanWorker


Remove worker options

GearmanWorker::register
GearmanWorker::returnCode
GearmanWorker
PHP Manual

GearmanWorker::removeOptions

(PECL gearman >= 0.6.0)

GearmanWorker::removeOptions — Remove worker options

Açıklama

public bool GearmanWorker::removeOptions ( int $option )

Removes (unsets) one or more worker options.

Değiştirgeler

option

The options to be removed (unset)

Dönen Değerler

Always returns TRUE.

Ayrıca Bakınız

  • GearmanWorker::options() - Get worker options
  • GearmanWorker::setOptions() - Set worker options
  • GearmanWorker::addOptions() - Add worker options

GearmanWorker::register
GearmanWorker::returnCode
GearmanWorker


Get last Gearman return code

GearmanWorker::removeOptions
GearmanWorker::setId
GearmanWorker
PHP Manual

GearmanWorker::returnCode

(PECL gearman >= 0.5.0)

GearmanWorker::returnCode — Get last Gearman return code

Açıklama

public int GearmanWorker::returnCode ( void )

Returns the last Gearman return code.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A valid Gearman return code.

Ayrıca Bakınız

  • GearmanWorker::error() - Get the last error encountered
  • GearmanWorker::getErrno() - Get errno

GearmanWorker::removeOptions
GearmanWorker::setId
GearmanWorker


Give the worker an identifier so it can be tracked when asking gearmand for the list of available workers.

GearmanWorker::returnCode
GearmanWorker::setOptions
GearmanWorker
PHP Manual

GearmanWorker::setId

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

GearmanWorker::setId — Give the worker an identifier so it can be tracked when asking gearmand for the list of available workers.

Açıklama

public bool GearmanWorker::setId ( string $id )

Assigns the worker an identifier.

Değiştirgeler

id

A string identifier.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 GearmanWorker::setId() example

Set an identifier for a simple worker.

<?php
$worker= new GearmanWorker();
$worker->setId('test');
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Run the following command:
gearadmin --workers

Output:
30 ::3a3a:3361:3361:3a33%976303667 - : test
GearmanWorker::returnCode
GearmanWorker::setOptions
GearmanWorker


Set worker options

GearmanWorker::setId
GearmanWorker::setTimeout
GearmanWorker
PHP Manual

GearmanWorker::setOptions

(PECL gearman >= 0.5.0)

GearmanWorker::setOptions — Set worker options

Açıklama

public bool GearmanWorker::setOptions ( int $option )

Sets one or more options to the supplied value.

Değiştirgeler

option

The options to be set

Dönen Değerler

Always returns TRUE.

Ayrıca Bakınız

  • GearmanWorker::options() - Get worker options
  • GearmanWorker::addOptions() - Add worker options
  • GearmanWorker::removeOptions() - Remove worker options
  • GearmanClient::setOptions() - Set client options

GearmanWorker::setId
GearmanWorker::setTimeout
GearmanWorker


Set socket I/O activity timeout

GearmanWorker::setOptions
GearmanWorker::timeout
GearmanWorker
PHP Manual

GearmanWorker::setTimeout

(PECL gearman >= 0.6.0)

GearmanWorker::setTimeout — Set socket I/O activity timeout

Açıklama

public bool GearmanWorker::setTimeout ( int $timeout )

Sets the interval of time to wait for socket I/O activity.

Değiştirgeler

timeout

An interval of time in milliseconds. A negative value indicates an infinite timeout.

Dönen Değerler

Always returns TRUE.

Örnekler

Örnek 1 A simple worker with a 5 second timeout

<?php

echo "Starting\n";

# Create our worker object.
$gmworker= new GearmanWorker();

# Add default server (localhost).
$gmworker->addServer();

# Register function "reverse" with the server.
$gmworker->addFunction("reverse", "reverse_fn");

# Set the timeout to 5 seconds
$gmworker->setTimeout(5000);

echo "Waiting for job...\n";
while(@$gmworker->work() || $gmworker->returnCode() == GEARMAN_TIMEOUT)
{
  if ($gmworker->returnCode() == GEARMAN_TIMEOUT)
  {
    # Normally one would want to do something useful here ...
    echo "Timeout. Waiting for next job...\n";
    continue;
  }

  if ($gmworker->returnCode() != GEARMAN_SUCCESS)
  {
    echo "return_code: " . $gmworker->returnCode() . "\n";
    break;
  }
}

echo "Done\n";

function reverse_fn($job)
{
  return strrev($job->workload());
}

?>

Running the worker with no submitted jobs will generate output that looks like the following:

Starting
Waiting for job...
Timeout. Waiting for next job...
Timeout. Waiting for next job...
Timeout. Waiting for next job...

Ayrıca Bakınız

  • GearmanWorker::timeout() - Get socket I/O activity timeout

GearmanWorker::setOptions
GearmanWorker::timeout
GearmanWorker


Get socket I/O activity timeout

GearmanWorker::setTimeout
GearmanWorker::unregister
GearmanWorker
PHP Manual

GearmanWorker::timeout

(PECL gearman >= 0.6.0)

GearmanWorker::timeout — Get socket I/O activity timeout

Açıklama

public int GearmanWorker::timeout ( void )

Returns the current time to wait, in milliseconds, for socket I/O activity.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A time period is milliseconds. A negative value indicates an infinite timeout.

Ayrıca Bakınız

  • GearmanWorker::setTimeout() - Set socket I/O activity timeout

GearmanWorker::setTimeout
GearmanWorker::unregister
GearmanWorker


Unregister a function name with the job servers

GearmanWorker::timeout
GearmanWorker::unregisterAll
GearmanWorker
PHP Manual

GearmanWorker::unregister

(PECL gearman >= 0.6.0)

GearmanWorker::unregister — Unregister a function name with the job servers

Açıklama

public bool GearmanWorker::unregister ( string $function_name )

Unregisters a function name with the job servers ensuring that no more jobs (for that function) are sent to this worker.

Değiştirgeler

function_name

The name of a function to register with the job server

Dönen Değerler

A standard Gearman return value.

Ayrıca Bakınız

  • GearmanWorker::register() - Register a function with the job server
  • GearmanWorker::unregisterAll() - Unregister all function names with the job servers

GearmanWorker::timeout
GearmanWorker::unregisterAll
GearmanWorker


Unregister all function names with the job servers

GearmanWorker::unregister
GearmanWorker::wait
GearmanWorker
PHP Manual

GearmanWorker::unregisterAll

(PECL gearman >= 0.6.0)

GearmanWorker::unregisterAll — Unregister all function names with the job servers

Açıklama

public bool GearmanWorker::unregisterAll ( void )

Unregisters all previously registered functions, ensuring that no more jobs are sent to this worker.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A standard Gearman return value.

Ayrıca Bakınız

  • GearmanWorker::register() - Register a function with the job server
  • GearmanWorker::unregister() - Unregister a function name with the job servers

GearmanWorker::unregister
GearmanWorker::wait
GearmanWorker


Wait for activity from one of the job servers

GearmanWorker::unregisterAll
GearmanWorker::work
GearmanWorker
PHP Manual

GearmanWorker::wait

(PECL gearman >= 0.6.0)

GearmanWorker::wait — Wait for activity from one of the job servers

Açıklama

public bool GearmanWorker::wait ( void )

Causes the worker to wait for activity from one of the Gearman job servers when operating in non-blocking I/O mode. On failure, issues a E_WARNING with the last Gearman error encountered.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Running worker in non-blocking mode

<?php

echo "Starting\n";

# Create our worker object
$worker= new GearmanWorker();

# Make the worker non-blocking
$worker->addOptions(GEARMAN_WORKER_NON_BLOCKING);

# Add the default server (localhost, port 4730)
$worker->addServer();

# Add our reverse function
$worker->addFunction('reverse', 'reverse_fn');

# Try to grab a job
while (@$worker->work() ||
       $worker->returnCode() == GEARMAN_IO_WAIT ||
       $worker->returnCode() == GEARMAN_NO_JOBS)
{
  if ($worker->returnCode() == GEARMAN_SUCCESS)
    continue;

  echo "Waiting for next job...\n";
  if (!@$worker->wait())
  {
    if ($worker->returnCode() == GEARMAN_NO_ACTIVE_FDS)
    {
      # We are not connected to any servers, so wait a bit before
      # trying to reconnect.
      sleep(5);
      continue;
    }
    break;
  }
}

echo "Worker Error: " . $worker->error() . "\n";

function reverse_fn($job)
{
  return strrev($job->workload());
}

?>

Ayrıca Bakınız

  • GearmanWorker::work() - Wait for and perform jobs

GearmanWorker::unregisterAll
GearmanWorker::work
GearmanWorker


Wait for and perform jobs

GearmanWorker::wait
GearmanException
GearmanWorker
PHP Manual

GearmanWorker::work

(PECL gearman >= 0.5.0)

GearmanWorker::work — Wait for and perform jobs

Açıklama

public bool GearmanWorker::work ( void )

Waits for a job to be assigned and then calls the appropriate callback function. Issues an E_WARNING with the last Gearman error if the return code is not one of GEARMAN_SUCCESS, GEARMAN_IO_WAIT, or GEARMAN_WORK_FAIL.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 GearmanWorker::work() example

<?php

# create the worker
$worker = new GearmanWorker();

# add the default job server (localhost)
$worker->addServer();

# add the reverse function
$worker->addFunction("reverse", "my_reverse_function");

# start te worker listening for job submissions
while ($worker->work());

function my_reverse_function($job)
{
  return strrev($job->workload());
}

?>

Ayrıca Bakınız

  • GearmanWorker::addFunction() - Register and add callback function

GearmanWorker::wait
GearmanException
GearmanWorker


The GearmanException class

(PECL gearman >= 0.5.0)

Giriş

Sınıf Sözdizimi

GearmanException extends Exception {
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Yöntemler */
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}
GearmanWorker::work
Gopher
Gearman


Net Gopher

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
    • Basic Example
  • Gopher İşlevleri
    • gopher_parsedir — Translate a gopher formatted directory entry into an associative array.
GearmanException
Giriş
Diğer Hizmetler


Giriş

The gopher protocol, as defined by » RFC 1436, is generally considered the ancestor of the modern HTTP protocol. However, gopher was also intended to provide references to non-gopher resources including telnet, wais, nntp, and even http. This extension adds gopher support to PHP's URL Wrappers, and provides a helper function gopher_parsedir() to make sense of gopher formatted directory listings.

Gopher
Yapılandırma/Kurulum
Gopher


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Gopher


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/net_gopher

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

Net_Gopher constants
Constant | Value | Description
GOPHER_DOCUMENT | 0 | Standard text/plain document.
GOPHER_DIRECTORY | 1 | A resource containing a gopher formatted directory listing.
GOPHER_BINHEX | 4 | A BinHex encoded binary file.
GOPHER_DOSBINARY | 5 | A DOS formatted binary archive.
GOPHER_UUENCODED | 6 | A UUEncoded file.
GOPHER_BINARY | 9 | A generic binary file.
GOPHER_INFO | 255 | An Informational entry
GOPHER_HTTP | 254 | A reference to an HTTP resource.
GOPHER_UNKNOWN | -1 | An unrecognized entry.
Özkaynak Türleri
Örnekler
Gopher


Örnekler

İçindekiler

  • Basic Example
Öntanımlı Sabitler
Basic Example
Gopher


Basic Example

<?php
readfile("gopher://gopher.example.com/somedocument");
?>
Örnekler
Gopher İşlevleri
Örnekler


Gopher İşlevleri

İçindekiler

  • gopher_parsedir — Translate a gopher formatted directory entry into an associative array.
Basic Example
gopher_parsedir
Gopher


Translate a gopher formatted directory entry into an associative array.

Gopher İşlevleri
Gupnp
Gopher İşlevleri
PHP Manual

gopher_parsedir

(PECL net_gopher >= 0.1)

gopher_parsedir — Translate a gopher formatted directory entry into an associative array.

Açıklama

array gopher_parsedir ( string $dirent )

gopher_parsedir() parses a gopher formatted directory entry into an associative array.

While gopher returns text/plain documents for actual document requests. A request to a directory (such as /) will return specially encoded series of lines with each line being one directory entry or information line.

Değiştirgeler

dirent

The directory entry.

Dönen Değerler

Returns an associative array whose components are:

  • type - One of the GOPHER_XXX constants.
  • title - The name of the resource.
  • path - The path of the resource.
  • host - The domain name of the host that has this document (or directory).
  • port - The port at which to connect on host.

Upon failure, the additional data entry of the returned array will hold the parsed line.

Örnekler

Örnek 1 Hypothetical output from gopher://gopher.example.com/

0All about my gopher site.               /allabout.txt               gopher.example.com    70
9A picture of my cat.                    /pics/cat.png               gopher.example.com    70
1A collection of my writings.            /stories                    gopher.example.com    70
hThe HTTP version of this site.          URL:http://www.example.com  gopher.example.com    70
1Mirror of this site in Spain.           /                           gopher.ejemplo.co.es  70
iWelcome to my gopher site.                                          error.host            1
iPlease select one of the options above                              error.host            1
iSend complaints to /dev/null                                        error.host            1
iLong live gopher!                                                   error.host            1

In the example above, the root directory at gopher.example.com knows about one DOCUMENT identified by 0 located at gopher://gopher.example.com:70/allabout.txt. It also knows about two other directory (which have their own listing files) at gopher://gopher.exmaple.com:70/stories and at gopher://gopher.ejemplo.co.es:70/. In addition there is a binary file, a link to an HTTP url, and several informative lines.

By passing each line of the directory listing into gopher_parsedir(), an associative array is formed containing a parsed out version of the data.

Örnek 2 Using gopher_parsedir()

<?php
$directory = file("gopher://gopher.example.com");

foreach($directory as $dirent) {
    print_r(gopher_parsedir($dirent));
}
?>

Yukarıdaki örneğin çıktısı:

Array (
  [type] => 0
  [title] => All about my gopher site.
  [path] => /allabout.txt
  [host] => gopher.example.com
  [port] => 70
)
Array (
  [type] => 9
  [title] => A picture of my cat.
  [path] => /pics/cat.png
  [host] => gopher.example.com
  [port] => 70
)
Array (
  [type] => 1
  [title] => A collection of my writings.
  [path] => /stories
  [host] => gopher.example.com
  [port] => 70
)
Array (
  [type] => 254
  [title] => The HTTP version of this site.
  [path] => URL:http://www.example.com
  [host] => gopher.example.com
  [port] => 70
)
Array (
  [type] => 1
  [title] => Mirror of this site in Spain.
  [path] => /
  [host] => gopher.ejemplo.co.es
  [port] => 70
)
Array (
  [type] => 255
  [title] => Welcome to my gopher site.
  [path] =>
  [host] => error.host
  [port] => 1
)
Array (
  [type] => 255
  [title] => Please select one of the options above.
  [path] =>
  [host] => error.host
  [port] => 1
)
Array (
  [type] => 255
  [title] => Send complaints to /dev/null
  [path] =>
  [host] => error.host
  [port] => 1
)
Array (
  [type] => 255
  [title] => Long live gopher!
  [path] =>
  [host] => error.host
  [port] => 1
)

Gopher İşlevleri
Gupnp
Gopher İşlevleri


Gupnp

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
    • Browsing devices and services
    • Implementing the BinaryLight device
  • Gupnp İşlevleri
    • gupnp_context_get_host_ip — Get the IP address
    • gupnp_context_get_port — Get the port
    • gupnp_context_get_subscription_timeout — Get the event subscription timeout
    • gupnp_context_host_path — Start hosting
    • gupnp_context_new — Create a new context
    • gupnp_context_set_subscription_timeout — Sets the event subscription timeout
    • gupnp_context_timeout_add — Sets a function to be called at regular intervals
    • gupnp_context_unhost_path — Stop hosting
    • gupnp_control_point_browse_start — Start browsing
    • gupnp_control_point_browse_stop — Stop browsing
    • gupnp_control_point_callback_set — Set control point callback
    • gupnp_control_point_new — Create a new control point
    • gupnp_device_action_callback_set — Set device callback function
    • gupnp_device_info_get_service — Get the service with type
    • gupnp_device_info_get — Get info of root device
    • gupnp_root_device_get_available — Check whether root device is available
    • gupnp_root_device_get_relative_location — Get the relative location of root device.
    • gupnp_root_device_new — Create a new root device
    • gupnp_root_device_set_available — Set whether or not root_device is available
    • gupnp_root_device_start — Start main loop
    • gupnp_root_device_stop — Stop main loop
    • gupnp_service_action_get — Retrieves the specified action arguments
    • gupnp_service_action_return_error — Return error code
    • gupnp_service_action_return — Return successfully
    • gupnp_service_action_set — Sets the specified action return values
    • gupnp_service_freeze_notify — Freeze new notifications
    • gupnp_service_info_get_introspection — Get resource introspection of service
    • gupnp_service_info_get — Get full info of service
    • gupnp_service_introspection_get_state_variable — Returns the state variable data
    • gupnp_service_notify — Notifies listening clients
    • gupnp_service_proxy_action_get — Send action to the service and get value
    • gupnp_service_proxy_action_set — Send action to the service and set value
    • gupnp_service_proxy_add_notify — Sets up callback for variable change notification
    • gupnp_service_proxy_callback_set — Set service proxy callback for signal
    • gupnp_service_proxy_get_subscribed — Check whether subscription is valid to the service
    • gupnp_service_proxy_remove_notify — Cancels the variable change notification
    • gupnp_service_proxy_send_action — Send action with multiple parameters synchronously
    • gupnp_service_proxy_set_subscribed — (Un)subscribes to the service.
    • gupnp_service_thaw_notify — Sends out any pending notifications and stops queuing of new ones.
gopher_parsedir
Giriş
Diğer Hizmetler


Giriş

GUPnP is an object-oriented open source framework for creating UPnP devices and control points, written in C using GObject and libsoup. This extension wraps GUPnP and provides similar API. All sources and additional documentation can be obtained from the » official site

Gupnp
Yapılandırma/Kurulum
Gupnp


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Gupnp


Gereksinimler

In order to use PECL/Gupnp functions you need to install the » gUPnP library version 0.12.7 or greater. It also requires glib-2.0, gssdp-1.0, libsoup-2.4 or greater for all of them.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/gupnp

Bilginize: If ./configure is having trouble finding the libgupnp files (for example, it was installed into a custom prefix directory), use ./configure --with-gupnp=$PREFIX, where $PREFIX is installation prefix of libgupnp.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

GUPNP_TYPE_BOOLEAN (integer)
GUPNP_TYPE_INT (integer)
GUPNP_TYPE_LONG (integer)
GUPNP_TYPE_DOUBLE (integer)
GUPNP_TYPE_FLOAT (integer)
GUPNP_TYPE_STRING (integer)
GUPNP_SIGNAL_DEVICE_PROXY_AVAILABLE (integer)
GUPNP_SIGNAL_DEVICE_PROXY_UNAVAILABLE (integer)
GUPNP_SIGNAL_SERVICE_PROXY_AVAILABLE (integer)
GUPNP_SIGNAL_SERVICE_PROXY_UNAVAILABLE (integer)
GUPNP_SIGNAL_ACTION_INVOKED (integer)
GUPNP_SIGNAL_NOTIFY_FAILED (integer)
GUPNP_SIGNAL_SUBSCRIPTION_LOST (integer)
GUPNP_CONTROL_ERROR_INVALID_ACTION (integer)
GUPNP_CONTROL_ERROR_INVALID_ARGS (integer)
GUPNP_CONTROL_ERROR_OUT_OF_SYNC (integer)
GUPNP_CONTROL_ERROR_ACTION_FAILED (integer)

Özkaynak Türleri
Örnekler
Gupnp


Örnekler

İçindekiler

  • Browsing devices and services
  • Implementing the BinaryLight device
Öntanımlı Sabitler
Browsing devices and services
Gupnp


Browsing devices and services

This example shows how to obtain information about all devices and services. It starts an infinite loop (use CLI), and if any of available devices or services are found, the proper callback function will be invoked.

Örnek 1 Search for all UPnP devices and services.

<?php

/* Callback for available device */
function device_proxy_available_cb($proxy, $arg)
{
    $info = gupnp_device_info_get($proxy);

    $type = $info['device_type'];
    $location = $info['location'];

    printf("Device available:\n");
    printf("\ttype:     %s\n", $type);
    printf("\tlocation: %s\n", $location);
}

/* Callback for available service */
function service_proxy_available_cb($proxy, $arg)
{
    $info = gupnp_service_info_get($proxy);

    $type = $info['service_type'];
    $location = $info['location'];

    printf("Service available:\n");
    printf("\ttype:     %s\n", $type);
    printf("\tlocation: %s\n", $location);
}

/* Create the UPnP context */
$context = gupnp_context_new();
if (!$context) {
    printf("Error creating the GUPnP context\n");
    exit(-1);
}

/* We're interested in everything */
$cp = gupnp_control_point_new($context, "ssdp:all");

/* Set callbacks */
gupnp_control_point_callback_set($cp,
    GUPNP_SIGNAL_DEVICE_PROXY_AVAILABLE, 'device_proxy_available_cb');
gupnp_control_point_callback_set($cp,
    GUPNP_SIGNAL_SERVICE_PROXY_AVAILABLE, 'service_proxy_available_cb');

/* Start for browsing (infinite loop, hit Ctrl-C to interrupt) */
gupnp_control_point_browse_start($cp);

?>

Örnekler
Implementing the BinaryLight device
Örnekler


Implementing the BinaryLight device

This is an example of UPnP device/service, implementing the BinaryLight device and SwitchPower services to emulate a light switch.

The user interface was purposely simplified in order to show basic concepts and methods.

Örnek 1 Implementing light server

<?php

/* SetTarget */
function set_target_cb($service, $action, $arg)
{
    /* Get the new target value */
    $target = gupnp_service_action_get($action, 'NewTargetValue', GUPNP_TYPE_BOOLEAN);

    /* If the new target doesn't match the current status, change the status and
       emit a notification that the status has changed. */
    if ($target != $GLOBALS['status']) {
        $GLOBALS['status'] = $target;
        gupnp_service_notify($service, 'Status', GUPNP_TYPE_BOOLEAN, $GLOBALS['status']);
        printf("The light is now %s.\n", $GLOBALS['status'] ? "on" : "off");
    }

    /* Return success to the client */
    gupnp_service_action_return($action);
}

/* GetTarget */
function get_target_cb($service, $action, $arg)
{
    gupnp_service_action_set($action, 'RetTargetValue', GUPNP_TYPE_BOOLEAN, $GLOBALS['status']);
    gupnp_service_action_return($action);
}

/* GetStatus */
function get_status_cb($service, $action, $arg)
{
    gupnp_service_action_set($action, 'ResultStatus', GUPNP_TYPE_BOOLEAN, $GLOBALS['status']);
    gupnp_service_action_return($action);
}

/* By default the light is off */
$GLOBALS['status'] = false;
printf("The light is now %s.\n", $GLOBALS['status'] ? "on" : "off");

/* Create the UPnP context */
$context = gupnp_context_new();
if (!$context) {
    printf("Error creating the GUPnP context\n");
    exit(-1);
}

/* Host the directory that contains device and service description files */
gupnp_context_host_path($context, "./web", "");

/* Create root device */
$location = "/BinaryLight.xml";
$dev = gupnp_root_device_new($context, $location);
gupnp_root_device_set_available($dev, true);

/* Get the switch service from the root device */
$service_type = "urn:schemas-upnp-org:service:SwitchPower:1";
$service = gupnp_device_info_get_service($dev, $service_type);
if (!$service) {
    die("Cannot get SwitchPower1 service\n");
}

/* Set callback for action GetStatus */
gupnp_device_action_callback_set($service, GUPNP_SIGNAL_ACTION_INVOKED, "GetStatus",
    "get_status_cb", "action data, GetStatus");

/* Set callback for action GetTarget */
gupnp_device_action_callback_set($service, GUPNP_SIGNAL_ACTION_INVOKED, "GetTarget",
    "get_target_cb", "action data, GetTarget");

/* Set callback for action SetTarget */
gupnp_device_action_callback_set($service, GUPNP_SIGNAL_ACTION_INVOKED, "SetTarget",
    "set_target_cb", "action data, SetTarget");

/* Run the main loop */
gupnp_root_device_start($dev);

?>

Örnek 2 Implementing light client

<?php

function service_proxy_available_cb($proxy, $arg)
{
    $mode = $arg['mode'];

    printf("Set subscribed\n");
    gupnp_service_proxy_set_subscribed($proxy, true);

    /* Add notify if status will be changed */
    if (!gupnp_service_proxy_add_notify($proxy, "Status",
            GUPNP_TYPE_BOOLEAN, "status_changed_cb", NULL)) {
        printf("Failed to add notify\n");
    }

    if ($mode == 'TOGGLE') {
        /* We're toggling, so first fetch the current status */
        $target = gupnp_service_proxy_action_get($proxy, 'GetStatus', 'ResultStatus', GUPNP_TYPE_BOOLEAN);

        /* And then toggle it */
        $target = ! $target;
    } else {
        /* Mode is a boolean, so the target is the mode thanks to our well chosen
           enumeration values. */
        $target = ($mode == 'ON') ? true : false;
    }

    /* Set the target */
    if (!gupnp_service_proxy_action_set($proxy, 'SetTarget', 'NewTargetValue', $target, GUPNP_TYPE_BOOLEAN)) {
        printf("Cannot set switch\n");
    } else {
        printf("Set switch to %s.\n", $target ? "on" : "off");
    }

    /* Stop browsing */
    gupnp_control_point_browse_stop($arg['cp']);
}

function status_changed_cb($variable, $value, $arg)
{
    printf("Status has been changed\n");
    printf("\tvariable name: %s\n", $variable);
    printf("\tvalue: %s\n", (int)$value);
    printf("\n");
}

/* Check and parse command line arguments */
if (count($argv) != 2) {
    printf("Usage: light-client.php [on|off|toggle]\n");
    exit(-1);
}

if ($argv[1] == "on") {
    $mode = 'ON';
} elseif ($argv[1] == "off") {
    $mode = 'OFF';
} elseif ($argv[1] == "toggle") {
    $mode = 'TOGGLE';
} else {
    usage ();
    exit(-1);
}

/* Create the UPnP context */
$context = gupnp_context_new();
if (!$context) {
    printf("Error creating the GUPnP context\n");
    exit(-1);
}

/* Create the control point, searching for SwitchPower services */
$cp = gupnp_control_point_new ($context,
        "urn:schemas-upnp-org:service:SwitchPower:1");

/* Connect to the service-found callback */
$cb = "service_proxy_available_cb";
$arg = array('mode' => $mode, 'cp' => $cp);
gupnp_control_point_callback_set($cp, GUPNP_SIGNAL_SERVICE_PROXY_AVAILABLE, $cb, $arg);

/* Start for browsing */
gupnp_control_point_browse_start($cp);

?>

Browsing devices and services
Gupnp İşlevleri
Örnekler


Gupnp İşlevleri

İçindekiler

  • gupnp_context_get_host_ip — Get the IP address
  • gupnp_context_get_port — Get the port
  • gupnp_context_get_subscription_timeout — Get the event subscription timeout
  • gupnp_context_host_path — Start hosting
  • gupnp_context_new — Create a new context
  • gupnp_context_set_subscription_timeout — Sets the event subscription timeout
  • gupnp_context_timeout_add — Sets a function to be called at regular intervals
  • gupnp_context_unhost_path — Stop hosting
  • gupnp_control_point_browse_start — Start browsing
  • gupnp_control_point_browse_stop — Stop browsing
  • gupnp_control_point_callback_set — Set control point callback
  • gupnp_control_point_new — Create a new control point
  • gupnp_device_action_callback_set — Set device callback function
  • gupnp_device_info_get_service — Get the service with type
  • gupnp_device_info_get — Get info of root device
  • gupnp_root_device_get_available — Check whether root device is available
  • gupnp_root_device_get_relative_location — Get the relative location of root device.
  • gupnp_root_device_new — Create a new root device
  • gupnp_root_device_set_available — Set whether or not root_device is available
  • gupnp_root_device_start — Start main loop
  • gupnp_root_device_stop — Stop main loop
  • gupnp_service_action_get — Retrieves the specified action arguments
  • gupnp_service_action_return_error — Return error code
  • gupnp_service_action_return — Return successfully
  • gupnp_service_action_set — Sets the specified action return values
  • gupnp_service_freeze_notify — Freeze new notifications
  • gupnp_service_info_get_introspection — Get resource introspection of service
  • gupnp_service_info_get — Get full info of service
  • gupnp_service_introspection_get_state_variable — Returns the state variable data
  • gupnp_service_notify — Notifies listening clients
  • gupnp_service_proxy_action_get — Send action to the service and get value
  • gupnp_service_proxy_action_set — Send action to the service and set value
  • gupnp_service_proxy_add_notify — Sets up callback for variable change notification
  • gupnp_service_proxy_callback_set — Set service proxy callback for signal
  • gupnp_service_proxy_get_subscribed — Check whether subscription is valid to the service
  • gupnp_service_proxy_remove_notify — Cancels the variable change notification
  • gupnp_service_proxy_send_action — Send action with multiple parameters synchronously
  • gupnp_service_proxy_set_subscribed — (Un)subscribes to the service.
  • gupnp_service_thaw_notify — Sends out any pending notifications and stops queuing of new ones.
Implementing the BinaryLight device
gupnp_context_get_host_ip
Gupnp


Get the IP address

Gupnp İşlevleri
gupnp_context_get_port
Gupnp İşlevleri
PHP Manual

gupnp_context_get_host_ip

(PECL gupnp >= 0.1.0)

gupnp_context_get_host_ip — Get the IP address

Açıklama

string gupnp_context_get_host_ip ( resource $context )

Get the IP address we advertise ourselves as using.

Değiştirgeler

context

A context identifier, returned by gupnp_context_new().

Dönen Değerler

Returns the IP address for the current context and FALSE on error.

Örnekler

Örnek 1 Create new UPnP context and get IP address of the host

<?php

/* Create the UPnP context */
$context = gupnp_context_new();

if (!$context) {
 die("Error creating the GUPnP context\n");
}

/* Get IP address for the UPnP context */
$ip = gupnp_context_get_host_ip($context);
echo $ip;

?>

Ayrıca Bakınız

  • gupnp_context_new() - Create a new context
  • gupnp_context_get_port() - Get the port

Gupnp İşlevleri
gupnp_context_get_port
Gupnp İşlevleri


Get the port

gupnp_context_get_host_ip
gupnp_context_get_subscription_timeout
Gupnp İşlevleri
PHP Manual

gupnp_context_get_port

(PECL gupnp >= 0.1.0)

gupnp_context_get_port — Get the port

Açıklama

int gupnp_context_get_port ( resource $context )

Get the port that the SOAP server is running on.

Değiştirgeler

context

A context identifier, returned by gupnp_context_new().

Dönen Değerler

Returns the port number for the current context and FALSE on error.

Örnekler

Örnek 1 Create new UPnP context and get port number

<?php

/* Create the UPnP context */
$context = gupnp_context_new();

if (!$context) {
 die("Error creating the GUPnP context\n");
}

/* Get the port number for the UPnP context */
$port = gupnp_context_get_port($context);
echo $port;

?>

Ayrıca Bakınız

  • gupnp_context_new() - Create a new context
  • gupnp_context_get_host_ip() - Get the IP address

gupnp_context_get_host_ip
gupnp_context_get_subscription_timeout
Gupnp İşlevleri


Get the event subscription timeout

gupnp_context_get_port
gupnp_context_host_path
Gupnp İşlevleri
PHP Manual

gupnp_context_get_subscription_timeout

(PECL gupnp >= 0.1.0)

gupnp_context_get_subscription_timeout — Get the event subscription timeout

Açıklama

int gupnp_context_get_subscription_timeout ( resource $context )

Get the event subscription timeout (in seconds), or 0 meaning there is no timeout.

Değiştirgeler

context

A context identifier, returned by gupnp_context_new().

Dönen Değerler

The event subscription timeout in seconds.

Ayrıca Bakınız

  • gupnp_context_new() - Create a new context
  • gupnp_context_set_subscription_timeout() - Sets the event subscription timeout

gupnp_context_get_port
gupnp_context_host_path
Gupnp İşlevleri


Start hosting

gupnp_context_get_subscription_timeout
gupnp_context_new
Gupnp İşlevleri
PHP Manual

gupnp_context_host_path

(PECL gupnp >= 0.1.0)

gupnp_context_host_path — Start hosting

Açıklama

bool gupnp_context_host_path ( resource $context , string $local_path , string $server_path )

Start hosting local_path at server_path. Files with the path local_path.LOCALE (if they exist) will be served up when LOCALE is specified in the request's Accept-Language header.

Değiştirgeler

context

A context identifier, returned by gupnp_context_new().

local_path

Path to the local file or folder to be hosted.

server_path

Web server path where local_path should be hosted.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Create new UPnP context and set host path

<?php

/* Create the UPnP context */
$context = gupnp_context_new();

if (!$context) {
 die("Error creating the GUPnP context\n");
}

/* Host current directory */
gupnp_context_host_path($context, "./web", "");

?>

Ayrıca Bakınız

  • gupnp_context_new() - Create a new context
  • gupnp_context_unhost_path() - Stop hosting

gupnp_context_get_subscription_timeout
gupnp_context_new
Gupnp İşlevleri


Create a new context

gupnp_context_host_path
gupnp_context_set_subscription_timeout
Gupnp İşlevleri
PHP Manual

gupnp_context_new

(PECL gupnp >= 0.1.0)

gupnp_context_new — Create a new context

Açıklama

resource gupnp_context_new ([ string $host_ip [, int $port = 0 ]] )

Create a new context with the specified host_ip and port.

Değiştirgeler

host_ip

The local host's IP address, or NULL to use the IP address of the first non-loopback network interface.

port

Port to run on, or 0 if you don't care what port is used.

Dönen Değerler

A context identifier.

Örnekler

Örnek 1 Create new UPnP context

<?php

/* Create the UPnP context */
$context = gupnp_context_new();

if (!$context) {
 die("Error creating the GUPnP context\n");
}

?>

Hatalar/İstisnalar

Issues E_WARNING with unable to create context.

gupnp_context_host_path
gupnp_context_set_subscription_timeout
Gupnp İşlevleri


Sets the event subscription timeout

gupnp_context_new
gupnp_context_timeout_add
Gupnp İşlevleri
PHP Manual

gupnp_context_set_subscription_timeout

(PECL gupnp >= 0.1.0)

gupnp_context_set_subscription_timeout — Sets the event subscription timeout

Açıklama

void gupnp_context_set_subscription_timeout ( resource $context , int $timeout )

Sets the event subscription timeout (in seconds) to time out. Note that any client side subscriptions will automatically be renewed.

Değiştirgeler

context

A context identifier, returned by gupnp_context_new().

timeout

The event subscription timeout in seconds. Use 0 if you don't want subscriptions to time out.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • gupnp_context_new() - Create a new context
  • gupnp_context_get_subscription_timeout() - Get the event subscription timeout

gupnp_context_new
gupnp_context_timeout_add
Gupnp İşlevleri


Sets a function to be called at regular intervals

gupnp_context_set_subscription_timeout
gupnp_context_unhost_path
Gupnp İşlevleri
PHP Manual

gupnp_context_timeout_add

(PECL gupnp >= 0.1.0)

gupnp_context_timeout_add — Sets a function to be called at regular intervals

Açıklama

bool gupnp_context_timeout_add ( resource $context , int $timeout , mixed $callback [, mixed $arg ] )

Sets a function to be called at regular intervals.

Değiştirgeler

context

A context identifier, returned by gupnp_context_new().

timeout

A timeout in miliseconds.

callback

The callback function calling every timeout period of time. Typically, callback function takes on arg parameter.

arg

User data for callback.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Create new UPnP context and set callback

<?php

$user_data = "user data";

function timeout_cb($arg)
{
    printf("Call timeout_cb, user data: '%s'", $arg);
    return true;
}

/* Create the UPnP context */
$context = gupnp_context_new();

if (!$context) {
 die("Error creating the GUPnP context\n");
}

/* Create root device */
$dev = gupnp_root_device_new($context, "/devicedesc.xml");

/* Set callback for timeout */
gupnp_context_timeout_add($context, 5000, "timeout_cb", $user_data);

/* Run the main loop */
gupnp_root_device_start($dev);

?>

Hatalar/İstisnalar

Issues E_WARNING with not valid callback function.

Ayrıca Bakınız

  • gupnp_context_new() - Create a new context

gupnp_context_set_subscription_timeout
gupnp_context_unhost_path
Gupnp İşlevleri


Stop hosting

gupnp_context_timeout_add
gupnp_control_point_browse_start
Gupnp İşlevleri
PHP Manual

gupnp_context_unhost_path

(PECL gupnp >= 0.1.0)

gupnp_context_unhost_path — Stop hosting

Açıklama

bool gupnp_context_unhost_path ( resource $context , string $server_path )

Stop hosting the file or folder at server_path.

Değiştirgeler

context

A context identifier, returned by gupnp_context_new().

server_path

Web server path where the file or folder is hosted.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • gupnp_context_new() - Create a new context
  • gupnp_context_host_path() - Start hosting

gupnp_context_timeout_add
gupnp_control_point_browse_start
Gupnp İşlevleri


Start browsing

gupnp_context_unhost_path
gupnp_control_point_browse_stop
Gupnp İşlevleri
PHP Manual

gupnp_control_point_browse_start

(PECL gupnp >= 0.1.0)

gupnp_control_point_browse_start — Start browsing

Açıklama

bool gupnp_control_point_browse_start ( resource $cpoint )

Start the search and calls user-defined callback.

Değiştirgeler

cpoint

A control point identifier, returned by gupnp_control_point_new().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Create new UPnP context and start browsing

<?php

function device_proxy_available_cb($proxy, $arg)
{
    $info = gupnp_device_info_get($proxy);

    $type = $info['device_type'];
    $location = $info['location'];

    printf("Device available:\n");
    printf("type:     %s\n", $type);
    printf("location: %s\n", $location);
}

/* Create the UPnP context */
$context = gupnp_context_new();

if (!$context) {
 die("Error creating the GUPnP context\n");
}

/* We're interested in everything */
$cp = gupnp_control_point_new($context, "ssdp:all");

gupnp_control_point_callback_set($cp,
    GUPNP_SIGNAL_DEVICE_PROXY_AVAILABLE, 'device_proxy_available_cb');

/* Start for browsing */
gupnp_control_point_browse_start($cp);

?>

Ayrıca Bakınız

  • gupnp_control_point_new() - Create a new control point
  • gupnp_control_point_browse_stop() - Stop browsing

gupnp_context_unhost_path
gupnp_control_point_browse_stop
Gupnp İşlevleri


Stop browsing

gupnp_control_point_browse_start
gupnp_control_point_callback_set
Gupnp İşlevleri
PHP Manual

gupnp_control_point_browse_stop

(PECL gupnp >= 0.1.0)

gupnp_control_point_browse_stop — Stop browsing

Açıklama

bool gupnp_control_point_browse_stop ( resource $cpoint )

Stop the search and calls user-defined callback.

Değiştirgeler

cpoint

A control point identifier, returned by gupnp_control_point_new().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • gupnp_control_point_new() - Create a new control point
  • gupnp_control_point_browse_start() - Start browsing

gupnp_control_point_browse_start
gupnp_control_point_callback_set
Gupnp İşlevleri


Set control point callback

gupnp_control_point_browse_stop
gupnp_control_point_new
Gupnp İşlevleri
PHP Manual

gupnp_control_point_callback_set

(PECL gupnp >= 0.1.0)

gupnp_control_point_callback_set — Set control point callback

Açıklama

bool gupnp_control_point_callback_set ( resource $cpoint , int $signal , mixed $callback [, mixed $arg ] )

Set control point callback function for signal.

Değiştirgeler

cpoint

A control point identifier, returned by gupnp_control_point_new().

signal

The value of signal. Signal can be one of the following values:

GUPNP_SIGNAL_DEVICE_PROXY_AVAILABLE
Emitted whenever a new device has become available.
GUPNP_SIGNAL_DEVICE_PROXY_UNAVAILABLE
Emitted whenever a device is not available any more.
GUPNP_SIGNAL_SERVICE_PROXY_AVAILABLE
Emitted whenever a new service has become available.
GUPNP_SIGNAL_SERVICE_PROXY_UNAVAILABLE
Emitted whenever a service is not available any more.

callback

The callback function for the certain signal. Typically, callback function takes on two parameters. The proxy parameter's identifier being the first, and the arg second.

arg

User data for callback.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Create new UPnP context and start browsing

<?php

function device_proxy_available_cb($proxy, $arg)
{
    $info = gupnp_device_info_get($proxy);

    $type = $info['device_type'];
    $location = $info['location'];

    printf("Device available:\n");
    printf("type:     %s\n", $type);
    printf("location: %s\n", $location);
}

/* Create the UPnP context */
$context = gupnp_context_new();

if (!$context) {
 die("Error creating the GUPnP context\n");
}

/* We're interested in everything */
$cp = gupnp_control_point_new($context, "ssdp:all");

gupnp_control_point_callback_set($cp,
    GUPNP_SIGNAL_DEVICE_PROXY_AVAILABLE, 'device_proxy_available_cb');

/* Start for browsing */
gupnp_control_point_browse_start($cp);

?>

Hatalar/İstisnalar

Issues E_WARNING with not valid callback function.

Ayrıca Bakınız

  • gupnp_control_point_new() - Create a new control point
  • gupnp_control_point_browse_start() - Start browsing

gupnp_control_point_browse_stop
gupnp_control_point_new
Gupnp İşlevleri


Create a new control point

gupnp_control_point_callback_set
gupnp_device_action_callback_set
Gupnp İşlevleri
PHP Manual

gupnp_control_point_new

(PECL gupnp >= 0.1.0)

gupnp_control_point_new — Create a new control point

Açıklama

resource gupnp_control_point_new ( resource $context , string $target )

Create a new control point with the specified target.

Değiştirgeler

context

A context identifier, returned by gupnp_context_new().

target

The search target. target should be a service or device name, such as urn:schemas-upnp-org:service:WANIPConnection:1 or urn:schemas-upnp-org:device:MediaRenderer:1.

Dönen Değerler

A control point identifier.

gupnp_control_point_callback_set
gupnp_device_action_callback_set
Gupnp İşlevleri


Set device callback function

gupnp_control_point_new
gupnp_device_info_get_service
Gupnp İşlevleri
PHP Manual

gupnp_device_action_callback_set

(PECL gupnp >= 0.1.0)

gupnp_device_action_callback_set — Set device callback function

Açıklama

bool gupnp_device_action_callback_set ( resource $root_device , int $signal , string $action_name , mixed $callback [, mixed $arg ] )

Set device callback function for signal and action.

Değiştirgeler

root_device

A root device identifier, returned by gupnp_root_device_new().

signal

The value of signal. Signal can be one of the following values:

GUPNP_SIGNAL_ACTION_INVOKED
Emitted whenever an action is invoked. Handler should process action and must call either gupnp_service_action_return() or gupnp_service_action_return_error().
GUPNP_SIGNAL_NOTIFY_FAILED
Emitted whenever notification of a client fails.

action_name

The name of action.

callback

The callback function for the certain signal. Typically, callback function takes on three parameters. The service parameter's identifier being the first, action parameter's identifier (in case GUPNP_SIGNAL_ACTION_INVOKED signal) or error parameter's message (in case GUPNP_SIGNAL_NOTIFY_FAILED signal) being the second, and the arg is third.

arg

User data for callback.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

Issues E_WARNING either with not valid callback function or with not valid signal.

Ayrıca Bakınız

  • gupnp_root_device_new() - Create a new root device

gupnp_control_point_new
gupnp_device_info_get_service
Gupnp İşlevleri


Get the service with type

gupnp_device_action_callback_set
gupnp_device_info_get
Gupnp İşlevleri
PHP Manual

gupnp_device_info_get_service

(PECL gupnp >= 0.1.0)

gupnp_device_info_get_service — Get the service with type

Açıklama

resource gupnp_device_info_get_service ( resource $root_device , string $type )

Get the service with type or false if no such device was found.

Değiştirgeler

root_device

A root device identifier, returned by gupnp_root_device_new().

type

The type of the service to be retrieved.

Dönen Değerler

A service identifier.

Örnekler

Örnek 1 Create new UPnP context and get device info service

<?php

/* Create the UPnP context */
$context = gupnp_context_new();

if (!$context) {
 die("Error creating the GUPnP context\n");
}

/* Create root device */
$location = "/BinaryLight1.xml";
$dev = gupnp_root_device_new($context, $location);

/* Set root device is available */
gupnp_root_device_set_available($dev, true);

/* Get the switch service from the root device */
$service_type = "urn:schemas-upnp-org:service:SwitchPower:1";
$service = gupnp_device_info_get_service($dev, $service_type);
if (!$service) {
    die("Cannot get SwitchPower1 service\n");
}

?>

gupnp_device_action_callback_set
gupnp_device_info_get
Gupnp İşlevleri


Get info of root device

gupnp_device_info_get_service
gupnp_root_device_get_available
Gupnp İşlevleri
PHP Manual

gupnp_device_info_get

(PECL gupnp >= 0.1.0)

gupnp_device_info_get — Get info of root device

Açıklama

array gupnp_device_info_get ( resource $root_device )

Get info of root device.

Değiştirgeler

root_device

A root device identifier, returned by gupnp_root_device_new().

Dönen Değerler

Return array wich contains the information of the root device (like location, url, udn and etc).

gupnp_device_info_get_service
gupnp_root_device_get_available
Gupnp İşlevleri


Check whether root device is available

gupnp_device_info_get
gupnp_root_device_get_relative_location
Gupnp İşlevleri
PHP Manual

gupnp_root_device_get_available

(PECL gupnp >= 0.1.0)

gupnp_root_device_get_available — Check whether root device is available

Açıklama

bool gupnp_root_device_get_available ( resource $root_device )

Get whether or not root_device is available (announcing its presence).

Değiştirgeler

root_device

A root device identifier, returned by gupnp_root_device_new().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • gupnp_root_device_set_available() - Set whether or not root_device is available

gupnp_device_info_get
gupnp_root_device_get_relative_location
Gupnp İşlevleri


Get the relative location of root device.

gupnp_root_device_get_available
gupnp_root_device_new
Gupnp İşlevleri
PHP Manual

gupnp_root_device_get_relative_location

(PECL gupnp >= 0.1.0)

gupnp_root_device_get_relative_location — Get the relative location of root device.

Açıklama

string gupnp_root_device_get_relative_location ( resource $root_device )

Get the relative location of root device.

Değiştirgeler

root_device

A root device identifier, returned by gupnp_root_device_new().

Dönen Değerler

The relative location of root device

gupnp_root_device_get_available
gupnp_root_device_new
Gupnp İşlevleri


Create a new root device

gupnp_root_device_get_relative_location
gupnp_root_device_set_available
Gupnp İşlevleri
PHP Manual

gupnp_root_device_new

(PECL gupnp >= 0.1.0)

gupnp_root_device_new — Create a new root device

Açıklama

resource gupnp_root_device_new ( resource $context , string $location , string $description_dir )

Create a new root device, automatically downloading and parsing location.

Değiştirgeler

context

A context identifier, returned by gupnp_context_new().

location

Location of the description file for this device, relative to the HTTP root

Dönen Değerler

A root device identifier.

Örnekler

Örnek 1 Create new UPnP context and get device info service

<?php

/* Create the UPnP context */
$context = gupnp_context_new();

if (!$context) {
 die("Error creating the GUPnP context\n");
}

/* Create root device */
$location = "/BinaryLight1.xml";
$dev = gupnp_root_device_new($context, $location);

?>

Ayrıca Bakınız

  • gupnp_root_device_set_available() - Set whether or not root_device is available
  • gupnp_root_device_start() - Start main loop
  • gupnp_root_device_stop() - Stop main loop

gupnp_root_device_get_relative_location
gupnp_root_device_set_available
Gupnp İşlevleri


Set whether or not root_device is available

gupnp_root_device_new
gupnp_root_device_start
Gupnp İşlevleri
PHP Manual

gupnp_root_device_set_available

(PECL gupnp >= 0.1.0)

gupnp_root_device_set_available — Set whether or not root_device is available

Açıklama

bool gupnp_root_device_set_available ( resource $root_device , bool $available )

Controls whether or not root_device is available (announcing its presence).

Değiştirgeler

root_device

A root device identifier, returned by gupnp_root_device_new().

available

Set TRUE if root_device should be available.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • gupnp_root_device_get_available() - Check whether root device is available

gupnp_root_device_new
gupnp_root_device_start
Gupnp İşlevleri


Start main loop

gupnp_root_device_set_available
gupnp_root_device_stop
Gupnp İşlevleri
PHP Manual

gupnp_root_device_start

(PECL gupnp >= 0.1.0)

gupnp_root_device_start — Start main loop

Açıklama

bool gupnp_root_device_start ( resource $root_device )

Start root server's main loop.

Değiştirgeler

root_device

A root device identifier, returned by gupnp_root_device_new().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • gupnp_root_device_stop() - Stop main loop

gupnp_root_device_set_available
gupnp_root_device_stop
Gupnp İşlevleri


Stop main loop

gupnp_root_device_start
gupnp_service_action_get
Gupnp İşlevleri
PHP Manual

gupnp_root_device_stop

(PECL gupnp >= 0.1.0)

gupnp_root_device_stop — Stop main loop

Açıklama

bool gupnp_root_device_stop ( resource $root_device )

Stop root server's main loop.

Değiştirgeler

root_device

A root device identifier, returned by gupnp_root_device_new().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • gupnp_root_device_start() - Start main loop

gupnp_root_device_start
gupnp_service_action_get
Gupnp İşlevleri


Retrieves the specified action arguments

gupnp_root_device_stop
gupnp_service_action_return_error
Gupnp İşlevleri
PHP Manual

gupnp_service_action_get

(PECL gupnp >= 0.1.0)

gupnp_service_action_get — Retrieves the specified action arguments

Açıklama

mixed gupnp_service_action_get ( resource $action , string $name , int $type )

Retrieves the specified action arguments.

Değiştirgeler

action

A service action identifier.

name

The name of the variable to retrieve.

type

The type of the variable to retrieve. Type can be one of the following values:

GUPNP_TYPE_BOOLEAN
Type of the variable is boolean.
GUPNP_TYPE_INT
Type of the variable is integer.
GUPNP_TYPE_LONG
Type of the variable is long.
GUPNP_TYPE_DOUBLE
Type of the variable is double.
GUPNP_TYPE_FLOAT
Type of the variable is float.
GUPNP_TYPE_STRING
Type of the variable is string.

Dönen Değerler

The value of the variable.

Hatalar/İstisnalar

Issues E_WARNING with not correctly defined type of the variable.

Ayrıca Bakınız

  • gupnp_service_action_set() - Sets the specified action return values

gupnp_root_device_stop
gupnp_service_action_return_error
Gupnp İşlevleri


Return error code

gupnp_service_action_get
gupnp_service_action_return
Gupnp İşlevleri
PHP Manual

gupnp_service_action_return_error

(PECL gupnp >= 0.1.0)

gupnp_service_action_return_error — Return error code

Açıklama

bool gupnp_service_action_return_error ( resource $action , int $error_code [, string $error_description ] )

Return error code.

Değiştirgeler

action

A service action identifier.

error_code

The error code. Signal can be one of the following values or user defined:

GUPNP_CONTROL_ERROR_INVALID_ACTION
The action name was invalid.
GUPNP_CONTROL_ERROR_INVALID_ARGS
The action arguments were invalid.
GUPNP_CONTROL_ERROR_OUT_OF_SYNC
Out of sync (deprecated).
GUPNP_CONTROL_ERROR_ACTION_FAILED
The action failed.

error_description

The error description.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • gupnp_service_action_return() - Return successfully

gupnp_service_action_get
gupnp_service_action_return
Gupnp İşlevleri


Return successfully

gupnp_service_action_return_error
gupnp_service_action_set
Gupnp İşlevleri
PHP Manual

gupnp_service_action_return

(PECL gupnp >= 0.1.0)

gupnp_service_action_return — Return successfully

Açıklama

bool gupnp_service_action_return ( resource $action )

Return successfully.

Değiştirgeler

action

A service action identifier.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • gupnp_service_action_return_error() - Return error code

gupnp_service_action_return_error
gupnp_service_action_set
Gupnp İşlevleri


Sets the specified action return values

gupnp_service_action_return
gupnp_service_freeze_notify
Gupnp İşlevleri
PHP Manual

gupnp_service_action_set

(PECL gupnp >= 0.1.0)

gupnp_service_action_set — Sets the specified action return values

Açıklama

bool gupnp_service_action_set ( resource $action , string $name , int $type , mixed $value )

Sets the specified action return values.

Değiştirgeler

action

A service action identifier.

name

The name of the variable to retrieve.

type

The type of the variable to retrieve. Type can be one of the following values:

GUPNP_TYPE_BOOLEAN
Type of the variable is boolean.
GUPNP_TYPE_INT
Type of the variable is integer.
GUPNP_TYPE_LONG
Type of the variable is long.
GUPNP_TYPE_DOUBLE
Type of the variable is double.
GUPNP_TYPE_FLOAT
Type of the variable is float.
GUPNP_TYPE_STRING
Type of the variable is string.

value

The value of the variable to retrieve.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

Issues E_WARNING with neither not correctly defined type of the variable or the value is not corresponding to the defined type.

Ayrıca Bakınız

  • gupnp_service_action_get() - Retrieves the specified action arguments

gupnp_service_action_return
gupnp_service_freeze_notify
Gupnp İşlevleri


Freeze new notifications

gupnp_service_action_set
gupnp_service_info_get_introspection
Gupnp İşlevleri
PHP Manual

gupnp_service_freeze_notify

(PECL gupnp >= 0.1.0)

gupnp_service_freeze_notify — Freeze new notifications

Açıklama

bool gupnp_service_freeze_notify ( resource $service )

Causes new notifications to be queued up until gupnp_service_thaw_notify() is called.

Değiştirgeler

service

A service identifier.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • gupnp_service_notify() - Notifies listening clients
  • gupnp_service_thaw_notify() - Sends out any pending notifications and stops queuing of new ones.

gupnp_service_action_set
gupnp_service_info_get_introspection
Gupnp İşlevleri


Get resource introspection of service

gupnp_service_freeze_notify
gupnp_service_info_get
Gupnp İşlevleri
PHP Manual

gupnp_service_info_get_introspection

(PECL gupnp >= 0.1.0)

gupnp_service_info_get_introspection — Get resource introspection of service

Açıklama

mixed gupnp_service_info_get_introspection ( resource $proxy [, mixed $callback [, mixed $arg ]] )

Get resource introspection of service or register callback if corresponding parameter was passed.

Değiştirgeler

proxy

A service proxy identifier.

callback

The callback function to be called when introspection object is ready. Typically, callback function takes on three parameters. The introspection parameter's identifier being the first, error parameter's message being the second, and the arg is third.

arg

User data for callback.

Dönen Değerler

Return true if callback function was defined. Return introspection identifier if callback function was omited.

Hatalar/İstisnalar

Issues E_WARNING with not valid callback function.

gupnp_service_freeze_notify
gupnp_service_info_get
Gupnp İşlevleri


Get full info of service

gupnp_service_info_get_introspection
gupnp_service_introspection_get_state_variable
Gupnp İşlevleri
PHP Manual

gupnp_service_info_get

(PECL gupnp >= 0.1.0)

gupnp_service_info_get — Get full info of service

Açıklama

array gupnp_service_info_get ( resource $proxy )

Get full info of service.

Değiştirgeler

proxy

A service proxy identifier.

Dönen Değerler

Return array wich contains the information of the service (like location, url, udn and etc).

gupnp_service_info_get_introspection
gupnp_service_introspection_get_state_variable
Gupnp İşlevleri


Returns the state variable data

gupnp_service_info_get
gupnp_service_notify
Gupnp İşlevleri
PHP Manual

gupnp_service_introspection_get_state_variable

(PECL gupnp >= 0.1.0)

gupnp_service_introspection_get_state_variable — Returns the state variable data

Açıklama

array gupnp_service_introspection_get_state_variable ( resource $introspection , string $variable_name )

Returns the state variable data by the name variable_name in this service.

Değiştirgeler

introspection

A introspection identifier.

variable_name

The name of the variable to retreive.

Dönen Değerler

Return the state variable data or FALSE.

gupnp_service_info_get
gupnp_service_notify
Gupnp İşlevleri


Notifies listening clients

gupnp_service_introspection_get_state_variable
gupnp_service_proxy_action_get
Gupnp İşlevleri
PHP Manual

gupnp_service_notify

(PECL gupnp >= 0.1.0)

gupnp_service_notify — Notifies listening clients

Açıklama

bool gupnp_service_notify ( resource $service , string $name , int $type , mixed $value )

Notifies listening clients that the property have changed to the specified values.

Değiştirgeler

service

A service identifier.

name

The name of the variable.

type

The type of the variable. Type can be one of the following values:

GUPNP_TYPE_BOOLEAN
Type of the variable is boolean.
GUPNP_TYPE_INT
Type of the variable is integer.
GUPNP_TYPE_LONG
Type of the variable is long.
GUPNP_TYPE_DOUBLE
Type of the variable is double.
GUPNP_TYPE_FLOAT
Type of the variable is float.
GUPNP_TYPE_STRING
Type of the variable is string.

value

The value of the variable.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

Issues E_WARNING with either not correctly defined type of the variable or the value is not corresponding to the defined type.

Ayrıca Bakınız

  • gupnp_service_freeze_notify() - Freeze new notifications
  • gupnp_service_thaw_notify() - Sends out any pending notifications and stops queuing of new ones.

gupnp_service_introspection_get_state_variable
gupnp_service_proxy_action_get
Gupnp İşlevleri


Send action to the service and get value

gupnp_service_notify
gupnp_service_proxy_action_set
Gupnp İşlevleri
PHP Manual

gupnp_service_proxy_action_get

(PECL gupnp >= 0.1.0)

gupnp_service_proxy_action_get — Send action to the service and get value

Açıklama

mixed gupnp_service_proxy_action_get ( resource $proxy , string $action , string $name , int $type )

Send action with parameters to the service exposed by proxy synchronously and get value.

Değiştirgeler

proxy

A service proxy identifier.

action

An action.

name

The action name.

type

The type of the variable to retrieve. Type can be one of the following values:

GUPNP_TYPE_BOOLEAN
Type of the variable is boolean.
GUPNP_TYPE_INT
Type of the variable is integer.
GUPNP_TYPE_LONG
Type of the variable is long.
GUPNP_TYPE_DOUBLE
Type of the variable is double.
GUPNP_TYPE_FLOAT
Type of the variable is float.
GUPNP_TYPE_STRING
Type of the variable is string.

Dönen Değerler

Return value of the action.

Hatalar/İstisnalar

Issues E_WARNING with either not correctly defined type of the action or unable to send action.

Ayrıca Bakınız

  • gupnp_service_proxy_action_set() - Send action to the service and set value
  • gupnp_service_proxy_send_action() - Send action with multiple parameters synchronously

gupnp_service_notify
gupnp_service_proxy_action_set
Gupnp İşlevleri


Send action to the service and set value

gupnp_service_proxy_action_get
gupnp_service_proxy_add_notify
Gupnp İşlevleri
PHP Manual

gupnp_service_proxy_action_set

(PECL gupnp >= 0.1.0)

gupnp_service_proxy_action_set — Send action to the service and set value

Açıklama

bool gupnp_service_proxy_action_set ( resource $proxy , string $action , string $name , mixed $value , int $type )

Send action with parameters to the service exposed by proxy synchronously and set value.

Değiştirgeler

proxy

A service proxy identifier.

action

An action.

name

The action name.

value

The action value.

type

The type of the action. Type can be one of the following values:

GUPNP_TYPE_BOOLEAN
Type of the variable is boolean.
GUPNP_TYPE_INT
Type of the variable is integer.
GUPNP_TYPE_LONG
Type of the variable is long.
GUPNP_TYPE_DOUBLE
Type of the variable is double.
GUPNP_TYPE_FLOAT
Type of the variable is float.
GUPNP_TYPE_STRING
Type of the variable is string.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

Issues E_WARNING with either not correctly defined type of the action or unable to send action.

Ayrıca Bakınız

  • gupnp_service_proxy_action_get() - Send action to the service and get value
  • gupnp_service_proxy_send_action() - Send action with multiple parameters synchronously

gupnp_service_proxy_action_get
gupnp_service_proxy_add_notify
Gupnp İşlevleri


Sets up callback for variable change notification

gupnp_service_proxy_action_set
gupnp_service_proxy_callback_set
Gupnp İşlevleri
PHP Manual

gupnp_service_proxy_add_notify

(PECL gupnp >= 0.1.0)

gupnp_service_proxy_add_notify — Sets up callback for variable change notification

Açıklama

bool gupnp_service_proxy_add_notify ( resource $proxy , string $value , int $type , mixed $callback [, mixed $arg ] )

Sets up callback to be called whenever a change notification for variable is recieved.

Değiştirgeler

proxy

A service proxy identifier.

value

The variable to add notification for.

type

The type of the variable. Type can be one of the following values:

GUPNP_TYPE_BOOLEAN
Type of the variable is boolean.
GUPNP_TYPE_INT
Type of the variable is integer.
GUPNP_TYPE_LONG
Type of the variable is long.
GUPNP_TYPE_DOUBLE
Type of the variable is double.
GUPNP_TYPE_FLOAT
Type of the variable is float.
GUPNP_TYPE_STRING
Type of the variable is string.

callback

The callback to call when variable changes. Typically, callback function takes on three parameters. The variable parameter being the first, value parameter being the second, and the arg is third.

arg

User data for callback.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • gupnp_service_proxy_remove_notify() - Cancels the variable change notification

gupnp_service_proxy_action_set
gupnp_service_proxy_callback_set
Gupnp İşlevleri


Set service proxy callback for signal

gupnp_service_proxy_add_notify
gupnp_service_proxy_get_subscribed
Gupnp İşlevleri
PHP Manual

gupnp_service_proxy_callback_set

(PECL gupnp >= 0.1.0)

gupnp_service_proxy_callback_set — Set service proxy callback for signal

Açıklama

bool gupnp_service_proxy_callback_set ( resource $proxy , int $signal , mixed $callback [, mixed $arg ] )

Set service proxy callback for signal.

Değiştirgeler

proxy

A service proxy identifier.

signal

The value of signal.

GUPNP_SIGNAL_SUBSCRIPTION_LOST
Emitted whenever the subscription to this service has been lost due to an error condition.

callback

The callback function for the certain signal. Typically, callback function takes on two parameters. error parameter's message being the first, and the arg is second.

arg

User data for callback.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

Issues E_WARNING either with not valid callback function or with not valid signal.

gupnp_service_proxy_add_notify
gupnp_service_proxy_get_subscribed
Gupnp İşlevleri


Check whether subscription is valid to the service

gupnp_service_proxy_callback_set
gupnp_service_proxy_remove_notify
Gupnp İşlevleri
PHP Manual

gupnp_service_proxy_get_subscribed

(PECL gupnp >= 0.1.0)

gupnp_service_proxy_get_subscribed — Check whether subscription is valid to the service

Açıklama

bool gupnp_service_proxy_get_subscribed ( resource $proxy )

Check whether subscription is valid to the service.

Değiştirgeler

proxy

A service proxy identifier.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • gupnp_service_proxy_set_subscribed() - (Un)subscribes to the service.

gupnp_service_proxy_callback_set
gupnp_service_proxy_remove_notify
Gupnp İşlevleri


Cancels the variable change notification

gupnp_service_proxy_get_subscribed
gupnp_service_proxy_send_action
Gupnp İşlevleri
PHP Manual

gupnp_service_proxy_remove_notify

(PECL gupnp >= 0.1.0)

gupnp_service_proxy_remove_notify — Cancels the variable change notification

Açıklama

bool gupnp_service_proxy_remove_notify ( resource $proxy , string $value )

Cancels the variable change notification.

Değiştirgeler

proxy

A service proxy identifier.

value

The variable to add notification for.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • gupnp_service_proxy_add_notify() - Sets up callback for variable change notification

gupnp_service_proxy_get_subscribed
gupnp_service_proxy_send_action
Gupnp İşlevleri


Send action with multiple parameters synchronously

gupnp_service_proxy_remove_notify
gupnp_service_proxy_set_subscribed
Gupnp İşlevleri
PHP Manual

gupnp_service_proxy_send_action

(PECL gupnp >= 0.2.0)

gupnp_service_proxy_send_action — Send action with multiple parameters synchronously

Açıklama

array gupnp_service_proxy_send_action ( resource $proxy , string $action , array $in_params , array $out_params )

Send action with parameters in_params to the service exposed by proxy synchronously and return out_params with values or FALSE on error.

Değiştirgeler

proxy

A service proxy identifier.

action

An action.

in_params

An array of in parameters. Each entry in in_params is supposed to an array containing name, type and value of the parameters.

out_params

An array of out parameters. Each entry in out_params is supposed to an array containing name and type of the parameters.

Dönen Değerler

Return out_params array with values or FALSE on error.

Hatalar/İstisnalar

Issues E_WARNING with either not correctly defined in_params and out_params or unable to send action.

Ayrıca Bakınız

  • gupnp_service_proxy_action_get() - Send action to the service and get value
  • gupnp_service_proxy_action_set() - Send action to the service and set value

gupnp_service_proxy_remove_notify
gupnp_service_proxy_set_subscribed
Gupnp İşlevleri


(Un)subscribes to the service.

gupnp_service_proxy_send_action
gupnp_service_thaw_notify
Gupnp İşlevleri
PHP Manual

gupnp_service_proxy_set_subscribed

(PECL gupnp >= 0.1.0)

gupnp_service_proxy_set_subscribed — (Un)subscribes to the service.

Açıklama

bool gupnp_service_proxy_set_subscribed ( resource $proxy , bool $subscribed )

(Un)subscribes to the service.

Değiştirgeler

proxy

A service proxy identifier.

subscribed

Set TRUE to subscribe to this service.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • gupnp_service_proxy_get_subscribed() - Check whether subscription is valid to the service

gupnp_service_proxy_send_action
gupnp_service_thaw_notify
Gupnp İşlevleri


Sends out any pending notifications and stops queuing of new ones.

gupnp_service_proxy_set_subscribed
Hyperwave API
Gupnp İşlevleri
PHP Manual

gupnp_service_thaw_notify

(PECL gupnp >= 0.1.0)

gupnp_service_thaw_notify — Sends out any pending notifications and stops queuing of new ones.

Açıklama

bool gupnp_service_thaw_notify ( resource $service )

Sends out any pending notifications and stops queuing of new ones.

Değiştirgeler

service

A service identifier.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • gupnp_service_notify() - Notifies listening clients
  • gupnp_service_freeze_notify() - Freeze new notifications

gupnp_service_proxy_set_subscribed
Hyperwave API
Gupnp İşlevleri


Hyperwave API

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Integration with Apache
  • Hyperwave API İşlevleri
    • hw_api::checkin — Checks in an object
    • hw_api::checkout — Checks out an object
    • hw_api::children — Returns children of an object
    • hw_api::content — Returns content of an object
    • hw_api::copy — Copies physically
    • hw_api::dbstat — Returns statistics about database server
    • hw_api::dcstat — Returns statistics about document cache server
    • hw_api::dstanchors — Returns a list of all destination anchors
    • hw_api::dstofsrcanchor — Returns destination of a source anchor
    • hw_api::find — Search for objects
    • hw_api::ftstat — Returns statistics about fulltext server
    • hw_api::hwstat — Returns statistics about Hyperwave server
    • hw_api::identify — Log into Hyperwave Server
    • hw_api::info — Returns information about server configuration
    • hw_api::insert — Inserts a new object
    • hw_api::insertanchor — Inserts a new object of type anchor
    • hw_api::insertcollection — Inserts a new object of type collection
    • hw_api::insertdocument — Inserts a new object of type document
    • hw_api::link — Creates a link to an object
    • hw_api::lock — Locks an object
    • hw_api::move — Moves object between collections
    • hw_api::object — Retrieve attribute information
    • hw_api::objectbyanchor — Returns the object an anchor belongs to
    • hw_api::parents — Returns parents of an object
    • hw_api::remove — Delete an object
    • hw_api::replace — Replaces an object
    • hw_api::setcommittedversion — Commits version other than last version
    • hw_api::srcanchors — Returns a list of all source anchors
    • hw_api::srcsofdst — Returns source of a destination object
    • hw_api::unlock — Unlocks a locked object
    • hw_api::user — Returns the own user object
    • hw_api::userlist — Returns a list of all logged in users
    • hw_api_attribute::key — Returns key of the attribute
    • hw_api_attribute::langdepvalue — Returns value for a given language
    • hw_api_attribute::value — Returns value of the attribute
    • hw_api_attribute::values — Returns all values of the attribute
    • hw_api_content::mimetype — Returns mimetype
    • hw_api_content::read — Read content
    • hw_api_error::count — Returns number of reasons
    • hw_api_error::reason — Returns reason of error
    • hw_api_object::assign — Clones object
    • hw_api_object::attreditable — Checks whether an attribute is editable
    • hw_api_object::count — Returns number of attributes
    • hw_api_object::insert — Inserts new attribute
    • hw_api_object::remove — Removes attribute
    • hw_api_object::title — Returns the title attribute
    • hw_api_object::value — Returns value of attribute
    • hw_api_reason::description — Returns description of reason
    • hw_api_reason::type — Returns type of reason
    • hwapi_attribute_new — Creates instance of class hw_api_attribute
    • hwapi_content_new — Create new instance of class hw_api_content
    • hwapi_hgcsp — Returns object of class hw_api
    • hwapi_object_new — Creates a new instance of class hwapi_object_new
gupnp_service_thaw_notify
Giriş
Diğer Hizmetler


Giriş

Hyperwave has been developed at » IICM in Graz. It started with the name Hyper-G and changed to Hyperwave when it was commercialised (in 1996).

Hyperwave is not free software. The current version, 5.5, is available at » http://www.hyperwave.com/. A time limited version can be ordered for free (30 days).

Hyperwave is an information system similar to a database (HIS, Hyperwave Information Server). Its focus is the storage and management of documents. A document can be any possible piece of data that may as well be stored in file. Each document is accompanied by its object record. The object record contains meta data for the document. The meta data is a list of attributes which can be extended by the user. Certain attributes are always set by the Hyperwave server, other may be modified by the user.

Bilginize:

Bu eklenti » PECL deposuna taşınmış olup şu sürümden itibaren PHP kaynak paketinde dağıtılmamaktatır: PHP 5.2.0.

Hyperwave API
Yapılandırma/Kurulum
Hyperwave API


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Hyperwave API


Gereksinimler

Since 2001 there is a Hyperwave SDK available. It supports Java, JavaScript and C++. This PHP Extension is based on the C++ interface. In order to activate the hwapi support in PHP you will have to install the Hyperwave SDK first.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/hwapi.

Bu eklenti » PECL deposuna taşınmış olup şu sürümden itibaren PHP kaynak paketinde dağıtılmamaktatır: PHP 5.2.0

Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Hyperwave API configuration options
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
hwapi.allow_persistent | "0" | PHP_INI_SYSTEM |
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
Integration with Apache
Hyperwave API


Integration with Apache

The Hyperwave extension is best used when PHP is compiled as an Apache module. In such a case the underlying Hyperwave server can be hidden from users almost completely if Apache uses its rewriting engine. The following instructions will explain this.

Since PHP with Hyperwave support built into Apache is intended to replace the native Hyperwave solution based on Wavemaster, we will assume that the Apache server will only serve as a Hyperwave web interface for these examples. This is not necessary but it simplifies the configuration. The concept is quite simple. First of all you need a PHP script which evaluates the $_ENV['PATH_INFO'] variable and treats its value as the name of a Hyperwave object. Let's call this script 'Hyperwave'. The URL http://your.hostname/Hyperwave/name_of_object would than return the Hyperwave object with the name 'name_of_object'. Depending on the type of the object the script has to react accordingly. If it is a collection, it will probably return a list of children. If it is a document it will return the mime type and the content. A slight improvement can be achieved if the Apache rewriting engine is used. From the users point of view it would be more straight forward if the URL http://your.hostname/name_of_object would return the object. The rewriting rule is quite easy:

RewriteRule ^/(.*) /usr/local/apache/htdocs/HyperWave/$1 [L]
Now every URL relates to an object in the Hyperwave server. This causes a simple to solve problem. There is no way to execute a different script, e.g. for searching, than the 'Hyperwave' script. This can be fixed with another rewriting rule like the following:
RewriteRule ^/hw/(.*) /usr/local/apache/htdocs/hw/$1 [L]
This will reserve the directory /usr/local/apache/htdocs/hw for additional scripts and other files. Just make sure this rule is evaluated before the one above. There is just a little drawback: all Hyperwave objects whose name starts with 'hw/' will be shadowed. So, make sure you don't use such names. If you need more directories, e.g. for images just add more rules or place them all in one directory. Before you put those instructions, don't forget to turn on the rewriting engine with
RewriteEngine on
You will need scripts:
  • to return the object itself
  • to allow searching
  • to identify yourself
  • to set your profile
  • one for each additional function like to show the object attributes, to show information about users, to show the status of the server, etc.

As an alternative to the Rewrite Engine, you can also consider using the Apache ErrorDocument directive, but be aware, that ErrorDocument redirected pages cannot receive POST data.

Öntanımlı Sabitler
Hyperwave API İşlevleri
Hyperwave API


Integration with Apache
hw_api::checkin
Hyperwave API
PHP Manual

Hyperwave API İşlevleri

Integration with Apache

The integration with Apache and possible other servers has been described in the separate chapter.

Classes

The API provided by the HW_API extension is fully object oriented. It is very similar to the C++ interface of the Hyperwave SDK. It consist of the following classes.

  • HW_API
  • HW_API_Object
  • HW_API_Attribute
  • HW_API_Error
  • HW_API_Content
  • HW_API_Reason
Some basic classes like HW_API_String, HW_API_String_Array, etc., which exist in the Hyperwave SDK have not been implemented since PHP has powerful replacements for them.

Each class has certain method, whose names are identical to its counterparts in the Hyperwave SDK. Passing arguments to this function differs from all the other PHP extensions but is close to the C++ API of the HW SDK. Instead of passing several parameters they are all put into an associated array and passed as one parameter. The names of the keys are identical to those documented in the HW SDK. The common parameters are listed below. If other parameters are required they will be documented if needed.

  • objectIdentifier The name or id of an object, e.g. "rootcollection", "0x873A8768 0x00000002".
  • parentIdentifier The name or id of an object which is considered to be a parent.
  • object An instance of class HW_API_Object.
  • parameters An instance of class HW_API_Object.
  • version The version of an object.
  • mode An integer value determine the way an operation is executed.
  • attributeSelector Any array of strings, each containing a name of an attribute. This is used if you retrieve the object record and want to include certain attributes.
  • objectQuery A query to select certain object out of a list of objects. This is used to reduce the number of objects which was delivered by a function like hw_api::children() or hw_api::find().

Bilginize:

Methods returning boolean can return TRUE, FALSE or HW_API_Error object.

İçindekiler

  • hw_api::checkin — Checks in an object
  • hw_api::checkout — Checks out an object
  • hw_api::children — Returns children of an object
  • hw_api::content — Returns content of an object
  • hw_api::copy — Copies physically
  • hw_api::dbstat — Returns statistics about database server
  • hw_api::dcstat — Returns statistics about document cache server
  • hw_api::dstanchors — Returns a list of all destination anchors
  • hw_api::dstofsrcanchor — Returns destination of a source anchor
  • hw_api::find — Search for objects
  • hw_api::ftstat — Returns statistics about fulltext server
  • hw_api::hwstat — Returns statistics about Hyperwave server
  • hw_api::identify — Log into Hyperwave Server
  • hw_api::info — Returns information about server configuration
  • hw_api::insert — Inserts a new object
  • hw_api::insertanchor — Inserts a new object of type anchor
  • hw_api::insertcollection — Inserts a new object of type collection
  • hw_api::insertdocument — Inserts a new object of type document
  • hw_api::link — Creates a link to an object
  • hw_api::lock — Locks an object
  • hw_api::move — Moves object between collections
  • hw_api::object — Retrieve attribute information
  • hw_api::objectbyanchor — Returns the object an anchor belongs to
  • hw_api::parents — Returns parents of an object
  • hw_api::remove — Delete an object
  • hw_api::replace — Replaces an object
  • hw_api::setcommittedversion — Commits version other than last version
  • hw_api::srcanchors — Returns a list of all source anchors
  • hw_api::srcsofdst — Returns source of a destination object
  • hw_api::unlock — Unlocks a locked object
  • hw_api::user — Returns the own user object
  • hw_api::userlist — Returns a list of all logged in users
  • hw_api_attribute::key — Returns key of the attribute
  • hw_api_attribute::langdepvalue — Returns value for a given language
  • hw_api_attribute::value — Returns value of the attribute
  • hw_api_attribute::values — Returns all values of the attribute
  • hw_api_content::mimetype — Returns mimetype
  • hw_api_content::read — Read content
  • hw_api_error::count — Returns number of reasons
  • hw_api_error::reason — Returns reason of error
  • hw_api_object::assign — Clones object
  • hw_api_object::attreditable — Checks whether an attribute is editable
  • hw_api_object::count — Returns number of attributes
  • hw_api_object::insert — Inserts new attribute
  • hw_api_object::remove — Removes attribute
  • hw_api_object::title — Returns the title attribute
  • hw_api_object::value — Returns value of attribute
  • hw_api_reason::description — Returns description of reason
  • hw_api_reason::type — Returns type of reason
  • hwapi_attribute_new — Creates instance of class hw_api_attribute
  • hwapi_content_new — Create new instance of class hw_api_content
  • hwapi_hgcsp — Returns object of class hw_api
  • hwapi_object_new — Creates a new instance of class hwapi_object_new
Integration with Apache
hw_api::checkin
Hyperwave API


Checks in an object

Hyperwave API İşlevleri
hw_api::checkout
Hyperwave API İşlevleri
PHP Manual

hw_api::checkin

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api::checkin — Checks in an object

Açıklama

bool hw_api::checkin ( array $parameter )

This function checks in an object or a whole hierarchy of objects. The parameters array contains the required element 'objectIdentifier' and the optional element 'version', 'comment', 'mode' and 'objectQuery'. 'version' sets the version of the object. It consists of the major and minor version separated by a period. If the version is not set, the minor version is incremented. 'mode' can be one of the following values:

HW_API_CHECKIN_NORMAL
Checks in and commits the object. The object must be a document.
HW_API_CHECKIN_RECURSIVE
If the object to check in is a collection, all children will be checked in recursively if they are documents. Trying to check in a collection would result in an error.
HW_API_CHECKIN_FORCE_VERSION_CONTROL
Checks in an object even if it is not under version control.
HW_API_CHECKIN_REVERT_IF_NOT_CHANGED
Check if the new version is different from the last version. Unless this is the case the object will be checked in.
HW_API_CHECKIN_KEEP_TIME_MODIFIED
Keeps the time modified from the most recent object.
HW_API_CHECKIN_NO_AUTO_COMMIT
The object is not automatically committed on check-in.

Değiştirgeler

parameter

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • hw_api::checkout

Hyperwave API İşlevleri
hw_api::checkout
Hyperwave API İşlevleri


Checks out an object

hw_api::checkin
hw_api::children
Hyperwave API İşlevleri
PHP Manual

hw_api::checkout

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api::checkout — Checks out an object

Açıklama

bool hw_api::checkout ( array $parameter )

This function checks out an object or a whole hierarchy of objects.

Değiştirgeler

parameter

The parameters array contains the required element 'objectIdentifier' and the optional element 'version', 'mode' and 'objectQuery'. 'mode' can be one of the following values:

HW_API_CHECKIN_NORMAL
Checks out an object. The object must be a document.
HW_API_CHECKIN_RECURSIVE
If the object to check out is a collection, all children will be checked out recursively if they are documents. Trying to check out a collection would result in an error.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • hw_api::checkin

hw_api::checkin
hw_api::children
Hyperwave API İşlevleri


Returns children of an object

hw_api::checkout
hw_api::content
Hyperwave API İşlevleri
PHP Manual

hw_api::children

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api::children — Returns children of an object

Açıklama

array hw_api::children ( array $parameter )

Retrieves the children of a collection or the attributes of a document. The children can be further filtered by specifying an object query.

Değiştirgeler

parameter

The parameter array contains the required elements 'objectIdentifier' and the optional elements 'attributeSelector' and 'objectQuery'.

Dönen Değerler

The return value is an array of objects of type HW_API_Object or HW_API_Error.

Ayrıca Bakınız

  • hw_api::parents

hw_api::checkout
hw_api::content
Hyperwave API İşlevleri


Returns content of an object

hw_api::children
hw_api::copy
Hyperwave API İşlevleri
PHP Manual

hw_api::content

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api::content — Returns content of an object

Açıklama

HW_API_Content hw_api::content ( array $parameter )

This function returns the content of a document as an object of type hw_api_content.

Değiştirgeler

parameter

The parameter array contains the required elements 'objectidentifier' and the optional element 'mode'. The mode can be one of the constants HW_API_CONTENT_ALLLINKS, HW_API_CONTENT_REACHABLELINKS or HW_API_CONTENT_PLAIN.

HW_API_CONTENT_ALLLINKS means to insert all anchors even if the destination is not reachable.

HW_API_CONTENT_REACHABLELINKS tells this method to insert only reachable links and HW_API_CONTENT_PLAIN will lead to document without any links.

Dönen Değerler

Returns an instance of hw_api_content.

hw_api::children
hw_api::copy
Hyperwave API İşlevleri


Copies physically

hw_api::content
hw_api::dbstat
Hyperwave API İşlevleri
PHP Manual

hw_api::copy

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api::copy — Copies physically

Açıklama

hw_api_content hw_api::copy ( array $parameter )

This function will make a physical copy including the content if it exists and returns the new object or an error object.

Değiştirgeler

parameter

The parameter array contains the required elements 'objectIdentifier' and 'destinationParentIdentifier'. The optional parameter is 'attributeSelector'`

Dönen Değerler

Returns the copied object.

Ayrıca Bakınız

  • hw_api::move
  • hw_api::link

hw_api::content
hw_api::dbstat
Hyperwave API İşlevleri


Returns statistics about database server

hw_api::copy
hw_api::dcstat
Hyperwave API İşlevleri
PHP Manual

hw_api::dbstat

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api::dbstat — Returns statistics about database server

Açıklama

hw_api_object hw_api::dbstat ( array $parameter )

Returns statistics about database server.

Değiştirgeler

parameter

Dönen Değerler

Ayrıca Bakınız

  • hw_api::dcstat
  • hw_api::hwstat
  • hw_api::ftstat

hw_api::copy
hw_api::dcstat
Hyperwave API İşlevleri


Returns statistics about document cache server

hw_api::dbstat
hw_api::dstanchors
Hyperwave API İşlevleri
PHP Manual

hw_api::dcstat

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api::dcstat — Returns statistics about document cache server

Açıklama

hw_api_object hw_api::dcstat ( array $parameter )

Returns statistics about document cache server.

Değiştirgeler

parameter

Dönen Değerler

Ayrıca Bakınız

  • hw_api::dbstat
  • hw_api::hwstat
  • hw_api::ftstat

hw_api::dbstat
hw_api::dstanchors
Hyperwave API İşlevleri


Returns a list of all destination anchors

hw_api::dcstat
hw_api::dstofsrcanchor
Hyperwave API İşlevleri
PHP Manual

hw_api::dstanchors

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api::dstanchors — Returns a list of all destination anchors

Açıklama

array hw_api::dstanchors ( array $parameter )

Retrieves all destination anchors of an object.

Değiştirgeler

parameter

The parameter array contains the required element 'objectIdentifier' and the optional elements 'attributeSelector' and 'objectQuery'.

Dönen Değerler

Ayrıca Bakınız

  • hw_api::srcanchors

hw_api::dcstat
hw_api::dstofsrcanchor
Hyperwave API İşlevleri


Returns destination of a source anchor

hw_api::dstanchors
hw_api::find
Hyperwave API İşlevleri
PHP Manual

hw_api::dstofsrcanchor

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api::dstofsrcanchor — Returns destination of a source anchor

Açıklama

hw_api_object hw_api::dstofsrcanchor ( array $parameter )

Retrieves the destination object pointed by the specified source anchors. The destination object can either be a destination anchor or a whole document.

Değiştirgeler

parameter

The parameters array contains the required element 'objectIdentifier' and the optional element 'attributeSelector'.

Dönen Değerler

Ayrıca Bakınız

  • hw_api::srcanchors
  • hw_api::dstanchors
  • hw_api::objectbyanchor

hw_api::dstanchors
hw_api::find
Hyperwave API İşlevleri


Search for objects

hw_api::dstofsrcanchor
hw_api::ftstat
Hyperwave API İşlevleri
PHP Manual

hw_api::find

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api::find — Search for objects

Açıklama

array hw_api::find ( array $parameter )

This functions searches for objects either by executing a key or/and full text query. The found objects can further be filtered by an optional object query. They are sorted by their importance. The second search operation is relatively slow and its result can be limited to a certain number of hits. This allows to perform an incremental search, each returning just a subset of all found documents, starting at a given index.

Değiştirgeler

parameter

The parameter array contains the 'keyquery' or/and 'fulltextquery' depending on who you would like to search. Optional parameters are 'objectquery', 'scope', 'languages' and 'attributeselector'. In case of an incremental search the optional parameters 'startIndex', 'numberOfObjectsToGet' and 'exactMatchUnit' can be passed.

Dönen Değerler

hw_api::dstofsrcanchor
hw_api::ftstat
Hyperwave API İşlevleri


Returns statistics about fulltext server

hw_api::find
hw_api::hwstat
Hyperwave API İşlevleri
PHP Manual

hw_api::ftstat

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api::ftstat — Returns statistics about fulltext server

Açıklama

hw_api_object hw_api::ftstat ( array $parameter )

Returns statistics about fulltext server.

Değiştirgeler

parameter

Dönen Değerler

Ayrıca Bakınız

  • hw_api::dcstat
  • hw_api::dbstat
  • hw_api::hwstat

hw_api::find
hw_api::hwstat
Hyperwave API İşlevleri


Returns statistics about Hyperwave server

hw_api::ftstat
hw_api::identify
Hyperwave API İşlevleri
PHP Manual

hw_api::hwstat

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api::hwstat — Returns statistics about Hyperwave server

Açıklama

hw_api_object hw_api::hwstat ( array $parameter )

Returns statistics about Hyperwave server.

Değiştirgeler

parameter

Dönen Değerler

Ayrıca Bakınız

  • hw_api::dcstat
  • hw_api::dbstat
  • hw_api::ftstat

hw_api::ftstat
hw_api::identify
Hyperwave API İşlevleri


Log into Hyperwave Server

hw_api::hwstat
hw_api::info
Hyperwave API İşlevleri
PHP Manual

hw_api::identify

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api::identify — Log into Hyperwave Server

Açıklama

bool hw_api::identify ( array $parameter )

Logs into the Hyperwave Server.

Değiştirgeler

parameter

The parameter array must contain the elements 'username' and 'password'.

Dönen Değerler

Returns an object of typeHW_API_Error if identification failed or TRUE if it was successful.

hw_api::hwstat
hw_api::info
Hyperwave API İşlevleri


Returns information about server configuration

hw_api::identify
hw_api::insert
Hyperwave API İşlevleri
PHP Manual

hw_api::info

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api::info — Returns information about server configuration

Açıklama

array hw_api::info ( array $parameter )

Returns information about server configuration.

Değiştirgeler

parameter

Dönen Değerler

Ayrıca Bakınız

  • hw_api::dcstat
  • hw_api::dbstat
  • hw_api::ftstat
  • hw_api::hwstat

hw_api::identify
hw_api::insert
Hyperwave API İşlevleri


Inserts a new object

hw_api::info
hw_api::insertanchor
Hyperwave API İşlevleri
PHP Manual

hw_api::insert

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api::insert — Inserts a new object

Açıklama

hw_api_object hw_api::insert ( array $parameter )

Insert a new object. The object type can be user, group, document or anchor. Depending on the type other object attributes has to be set.

Değiştirgeler

parameter

The parameter array contains the required elements 'object' and 'content' (if the object is a document) and the optional parameters 'parameters', 'mode' and 'attributeSelector'. The 'object' must contain all attributes of the object. 'parameters' is an object as well holding further attributes like the destination (attribute key is 'Parent'). 'content' is the content of the document. 'mode' can be a combination of the following flags:

HW_API_INSERT_NORMAL
The object in inserted into the server.
HW_API_INSERT_FORCE_VERSION_CONTROL
HW_API_INSERT_AUTOMATIC_CHECKOUT
HW_API_INSERT_PLAIN
HW_API_INSERT_KEEP_TIME_MODIFIED
HW_API_INSERT_DELAY_INDEXING

Dönen Değerler

Ayrıca Bakınız

  • hw_api::replace

hw_api::info
hw_api::insertanchor
Hyperwave API İşlevleri


Inserts a new object of type anchor

hw_api::insert
hw_api::insertcollection
Hyperwave API İşlevleri
PHP Manual

hw_api::insertanchor

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api::insertanchor — Inserts a new object of type anchor

Açıklama

hw_api_object hw_api::insertanchor ( array $parameter )

This function is a shortcut for hwapi_insert(). It inserts an object of type anchor and sets some of the attributes required for an anchor.

Değiştirgeler

parameter

The parameter array contains the required elements 'object' and 'documentIdentifier' and the optional elements 'destinationIdentifier', 'parameter', 'hint' and 'attributeSelector'. The 'documentIdentifier' specifies the document where the anchor shall be inserted. The target of the anchor is set in 'destinationIdentifier' if it already exists. If the target does not exists the element 'hint' has to be set to the name of object which is supposed to be inserted later. Once it is inserted the anchor target is resolved automatically.

Dönen Değerler

Ayrıca Bakınız

  • hw_api::insert
  • hw_api::insertdocument
  • hw_api::insertcollection

hw_api::insert
hw_api::insertcollection
Hyperwave API İşlevleri


Inserts a new object of type collection

hw_api::insertanchor
hw_api::insertdocument
Hyperwave API İşlevleri
PHP Manual

hw_api::insertcollection

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api::insertcollection — Inserts a new object of type collection

Açıklama

hw_api_object hw_api::insertcollection ( array $parameter )

This function is a shortcut for hwapi_insert(). It inserts an object of type collection and sets some of the attributes required for a collection.

Değiştirgeler

parameter

The parameter array contains the required elements 'object' and 'parentIdentifier' and the optional elements 'parameter' and 'attributeSelector'. See hwapi_insert() for the meaning of each element.

Dönen Değerler

Ayrıca Bakınız

  • hw_api::insert
  • hw_api::insertdocument
  • hw_api::insertanchor

hw_api::insertanchor
hw_api::insertdocument
Hyperwave API İşlevleri


Inserts a new object of type document

hw_api::insertcollection
hw_api::link
Hyperwave API İşlevleri
PHP Manual

hw_api::insertdocument

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api::insertdocument — Inserts a new object of type document

Açıklama

hw_api_object hw_api::insertdocument ( array $parameter )

This function is a shortcut for hwapi_insert(). It inserts an object with content and sets some of the attributes required for a document.

Değiştirgeler

parameter

The parameter array contains the required elements 'object', 'parentIdentifier' and 'content' and the optional elements 'mode', 'parameter' and 'attributeSelector'.

See hwapi_insert() for the meaning of each element.

Dönen Değerler

Ayrıca Bakınız

  • hw_api::insert
  • hw_api::insertcollection
  • hw_api::insertanchor

hw_api::insertcollection
hw_api::link
Hyperwave API İşlevleri


Creates a link to an object

hw_api::insertdocument
hw_api::lock
Hyperwave API İşlevleri
PHP Manual

hw_api::link

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api::link — Creates a link to an object

Açıklama

bool hw_api::link ( array $parameter )

Creates a link to an object. Accessing this link is like accessing the object to links points to.

Değiştirgeler

parameter

The parameter array contains the required elements 'objectIdentifier' and 'destinationParentIdentifier'. 'destinationParentIdentifier' is the target collection.

Dönen Değerler

The function returns TRUE on success or an error object.

Ayrıca Bakınız

  • hw_api::copy

hw_api::insertdocument
hw_api::lock
Hyperwave API İşlevleri


Locks an object

hw_api::link
hw_api::move
Hyperwave API İşlevleri
PHP Manual

hw_api::lock

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api::lock — Locks an object

Açıklama

bool hw_api::lock ( array $parameter )

Locks an object for exclusive editing by the user calling this function. The object can be only unlocked by this user or the system user.

Değiştirgeler

parameter

The parameter array contains the required element 'objectIdentifier' and the optional parameters 'mode' and 'objectquery'.

'mode' determines how an object is locked. HW_API_LOCK_NORMAL means, an object is locked until it is unlocked. HW_API_LOCK_RECURSIVE is only valid for collection and locks all objects within the collection and possible subcollections. HW_API_LOCK_SESSION means, an object is locked only as long as the session is valid.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • hw_api::unlock

hw_api::link
hw_api::move
Hyperwave API İşlevleri


Moves object between collections

hw_api::lock
hw_api::object
Hyperwave API İşlevleri
PHP Manual

hw_api::move

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api::move — Moves object between collections

Açıklama

bool hw_api::move ( array $parameter )

Moves object between collections.

Değiştirgeler

parameter

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • hw_objrec2array()

hw_api::lock
hw_api::object
Hyperwave API İşlevleri


Retrieve attribute information

hw_api::move
hw_api::objectbyanchor
Hyperwave API İşlevleri
PHP Manual

hw_api::object

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api::object — Retrieve attribute information

Açıklama

hw_api_object hw_api::object ( array $parameter )

This function retrieves the attribute information of an object of any version. It will not return the document content.

Değiştirgeler

parameter

The parameter array contains the required elements 'objectIdentifier' and the optional elements 'attributeSelector' and 'version'.

Dönen Değerler

The returned object is an instance of class HW_API_Object on success or HW_API_Error if an error occurred.

Örnekler

This simple example retrieves an object and checks for errors.

Örnek 1 Retrieve an object

<?php
function handle_error($error)
{
  $reason = $error->reason(0);
  echo "Type: <b>";
  switch ($reason->type()) {
    case 0:
      echo "Error";
      break;
    case 1:
      echo "Warning";
      break;
    case 2:
      echo "Message";
      break;
  }
  echo "</b><br />\n";
  echo "Description: " . $reason->description("en") . "<br />\n";
}

function list_attr($obj)
{
  echo "<table>\n";
  $count = $obj->count();
  for ($i=0; $i<$count; $i++) {
    $attr = $obj->attribute($i);
    printf("<tr><td align=\"right\" bgcolor=\"#c0c0c0\"><b>%s</b></td><td bgcolor=\"#F0F0F0\">%s</td></tr>\n",
             $attr->key(), $attr->value());
  }
  echo "</table>\n";
}

$hwapi = hwapi_hgcsp($g_config[HOSTNAME]);
$parms = array("objectIdentifier"=>"rootcollection", "attributeSelector"=>array("Title", "Name", "DocumentType"));
$root = $hwapi->object($parms);
if (get_class($root) == "HW_API_Error") {
  handle_error($root);
  exit;
}
list_attr($root);
?>

Ayrıca Bakınız

  • hw_api::content

hw_api::move
hw_api::objectbyanchor
Hyperwave API İşlevleri


Returns the object an anchor belongs to

hw_api::object
hw_api::parents
Hyperwave API İşlevleri
PHP Manual

hw_api::objectbyanchor

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api::objectbyanchor — Returns the object an anchor belongs to

Açıklama

hw_api_object hw_api::objectbyanchor ( array $parameter )

This function retrieves an object the specified anchor belongs to.

Değiştirgeler

parameter

The parameter array contains the required element 'objectIdentifier' and the optional element 'attributeSelector'.

Dönen Değerler

Ayrıca Bakınız

  • hw_api::dstofsrcanchor
  • hw_api::srcanchors
  • hw_api::dstanchors

hw_api::object
hw_api::parents
Hyperwave API İşlevleri


Returns parents of an object

hw_api::objectbyanchor
hw_api::remove
Hyperwave API İşlevleri
PHP Manual

hw_api::parents

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api::parents — Returns parents of an object

Açıklama

array hw_api::parents ( array $parameter )

Retrieves the parents of an object. The parents can be further filtered by specifying an object query.

Değiştirgeler

parameter

The parameter array contains the required elements 'objectidentifier' and the optional elements 'attributeselector' and 'objectquery'.

Dönen Değerler

The return value is an array of objects of type HW_API_Object or HW_API_Error.

Ayrıca Bakınız

  • hw_api::children

hw_api::objectbyanchor
hw_api::remove
Hyperwave API İşlevleri


Delete an object

hw_api::parents
hw_api::replace
Hyperwave API İşlevleri
PHP Manual

hw_api::remove

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api::remove — Delete an object

Açıklama

bool hw_api::remove ( array $parameter )

Removes an object from the specified parent. Collections will be removed recursively.

Değiştirgeler

parameter

You can pass an optional object query to remove only those objects which match the query. An object will be deleted physically if it is the last instance.

The parameter array contains the required elements 'objectidentifier' and 'parentidentifier'. If you want to remove a user or group 'parentidentifier' can be skipped.

The optional parameter 'mode' determines how the deletion is performed. In normal mode the object will not be removed physically until all instances are removed. In physical mode all instances of the object will be deleted immediately. In removelinks mode all references to and from the objects will be deleted as well. In nonrecursive the deletion is not performed recursive. Removing a collection which is not empty will cause an error.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • hw_api::move

hw_api::parents
hw_api::replace
Hyperwave API İşlevleri


Replaces an object

hw_api::remove
hw_api::setcommittedversion
Hyperwave API İşlevleri
PHP Manual

hw_api::replace

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api::replace — Replaces an object

Açıklama

hw_api_object hw_api::replace ( array $parameter )

Replaces the attributes and the content of an object.

Değiştirgeler

parameter

The parameter array contains the required elements 'objectIdentifier' and 'object' and the optional parameters 'content', 'parameters', 'mode' and 'attributeSelector'. 'objectIdentifier' contains the object to be replaced. 'object' contains the new object. 'content' contains the new content. 'parameters' contain extra information for HTML documents. HTML_Language is the letter abbreviation of the language of the title. HTML_Base sets the base attribute of the HTML document.

'mode' can be a combination of the following flags:

HW_API_REPLACE_NORMAL
The object on the server is replace with the object passed.
HW_API_REPLACE_FORCE_VERSION_CONTROL
HW_API_REPLACE_AUTOMATIC_CHECKOUT
HW_API_REPLACE_AUTOMATIC_CHECKIN
HW_API_REPLACE_PLAIN
HW_API_REPLACE_REVERT_IF_NOT_CHANGED
HW_API_REPLACE_KEEP_TIME_MODIFIED

Dönen Değerler

Ayrıca Bakınız

  • hw_api::insert

hw_api::remove
hw_api::setcommittedversion
Hyperwave API İşlevleri


Commits version other than last version

hw_api::replace
hw_api::srcanchors
Hyperwave API İşlevleri
PHP Manual

hw_api::setcommittedversion

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api::setcommittedversion — Commits version other than last version

Açıklama

hw_api_object hw_api::setcommittedversion ( array $parameter )

Commits a version of a document. The committed version is the one which is visible to users with read access. By default the last version is the committed version.

Değiştirgeler

parameter

Dönen Değerler

Ayrıca Bakınız

  • hw_api::checkin
  • hw_api::checkout

hw_api::replace
hw_api::srcanchors
Hyperwave API İşlevleri


Returns a list of all source anchors

hw_api::setcommittedversion
hw_api::srcsofdst
Hyperwave API İşlevleri
PHP Manual

hw_api::srcanchors

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api::srcanchors — Returns a list of all source anchors

Açıklama

array hw_api::srcanchors ( array $parameter )

Retrieves all source anchors of an object.

Değiştirgeler

parameter

The parameter array contains the required element 'objectIdentifier' and the optional elements 'attributeSelector' and 'objectQuery'.

Dönen Değerler

Ayrıca Bakınız

  • hw_api::dstanchors

hw_api::setcommittedversion
hw_api::srcsofdst
Hyperwave API İşlevleri


Returns source of a destination object

hw_api::srcanchors
hw_api::unlock
Hyperwave API İşlevleri
PHP Manual

hw_api::srcsofdst

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api::srcsofdst — Returns source of a destination object

Açıklama

array hw_api::srcsofdst ( array $parameter )

Retrieves all the source anchors pointing to the specified destination. The destination object can either be a destination anchor or a whole document.

Değiştirgeler

parameter

The parameters array contains the required element 'objectIdentifier' and the optional element 'attributeSelector' and 'objectQuery'. The function returns an array of objects or an error.

Dönen Değerler

Ayrıca Bakınız

  • hw_api::dstofsrcanchor

hw_api::srcanchors
hw_api::unlock
Hyperwave API İşlevleri


Unlocks a locked object

hw_api::srcsofdst
hw_api::user
Hyperwave API İşlevleri
PHP Manual

hw_api::unlock

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api::unlock — Unlocks a locked object

Açıklama

bool hw_api::unlock ( array $parameter )

Unlocks a locked object. Only the user who has locked the object and the system user may unlock an object.

Değiştirgeler

parameter

The parameter array contains the required element 'objectIdentifier' and the optional parameters 'mode' and 'objectquery'. The meaning of 'mode' is the same as in function hwapi_lock().

Dönen Değerler

Returns TRUE on success or an object of class HW_API_Error.

Ayrıca Bakınız

  • hw_api::lock

hw_api::srcsofdst
hw_api::user
Hyperwave API İşlevleri


Returns the own user object

hw_api::unlock
hw_api::userlist
Hyperwave API İşlevleri
PHP Manual

hw_api::user

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api::user — Returns the own user object

Açıklama

hw_api_object hw_api::user ( array $parameter )

Returns the own user object.

Değiştirgeler

parameter

Dönen Değerler

Ayrıca Bakınız

  • hw_api::userlist

hw_api::unlock
hw_api::userlist
Hyperwave API İşlevleri


Returns a list of all logged in users

hw_api::user
hw_api_attribute::key
Hyperwave API İşlevleri
PHP Manual

hw_api::userlist

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api::userlist — Returns a list of all logged in users

Açıklama

array hw_api::userlist ( array $parameter )

Returns a list of all logged in users.

Değiştirgeler

parameter

Dönen Değerler

Ayrıca Bakınız

  • hw_api::user

hw_api::user
hw_api_attribute::key
Hyperwave API İşlevleri


Returns key of the attribute

hw_api::userlist
hw_api_attribute::langdepvalue
Hyperwave API İşlevleri
PHP Manual

hw_api_attribute::key

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api_attribute::key — Returns key of the attribute

Açıklama

string hw_api_attribute::key ( void )

Returns the name of the attribute.

Dönen Değerler

Returns the name of the attribute as a string.

Ayrıca Bakınız

  • hw_api_attribute::value

hw_api::userlist
hw_api_attribute::langdepvalue
Hyperwave API İşlevleri


Returns value for a given language

hw_api_attribute::key
hw_api_attribute::value
Hyperwave API İşlevleri
PHP Manual

hw_api_attribute::langdepvalue

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api_attribute::langdepvalue — Returns value for a given language

Açıklama

string hw_api_attribute::langdepvalue ( string $language )

Returns the value in the given language of the attribute.

Değiştirgeler

language

Dönen Değerler

Returns the value of the attribute as a string.

Ayrıca Bakınız

  • hw_api_attribute::value

hw_api_attribute::key
hw_api_attribute::value
Hyperwave API İşlevleri


Returns value of the attribute

hw_api_attribute::langdepvalue
hw_api_attribute::values
Hyperwave API İşlevleri
PHP Manual

hw_api_attribute::value

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api_attribute::value — Returns value of the attribute

Açıklama

string hw_api_attribute::value ( void )

Gets the value of the attribute.

Dönen Değerler

Returns the value, as a string.

Ayrıca Bakınız

  • hw_api_attribute::key
  • hw_api_attribute::values

hw_api_attribute::langdepvalue
hw_api_attribute::values
Hyperwave API İşlevleri


Returns all values of the attribute

hw_api_attribute::value
hw_api_content::mimetype
Hyperwave API İşlevleri
PHP Manual

hw_api_attribute::values

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api_attribute::values — Returns all values of the attribute

Açıklama

array hw_api_attribute::values ( void )

Gets all values of the attribute.

Dönen Değerler

Returns an array of attribute values.

Ayrıca Bakınız

  • hw_api_attribute::value

hw_api_attribute::value
hw_api_content::mimetype
Hyperwave API İşlevleri


Returns mimetype

hw_api_attribute::values
hw_api_content::read
Hyperwave API İşlevleri
PHP Manual

hw_api_content::mimetype

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api_content::mimetype — Returns mimetype

Açıklama

string hw_api_content::mimetype ( void )

Returns the mimetype of the content.

Dönen Değerler

Returns the mimetype as a string.

hw_api_attribute::values
hw_api_content::read
Hyperwave API İşlevleri


Read content

hw_api_content::mimetype
hw_api_error::count
Hyperwave API İşlevleri
PHP Manual

hw_api_content::read

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api_content::read — Read content

Açıklama

string hw_api_content::read ( string $buffer , int $len )

Reads len bytes from the content into the given buffer.

Değiştirgeler

buffer

len

Number of bytes to read.

Dönen Değerler

hw_api_content::mimetype
hw_api_error::count
Hyperwave API İşlevleri


Returns number of reasons

hw_api_content::read
hw_api_error::reason
Hyperwave API İşlevleri
PHP Manual

hw_api_error::count

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api_error::count — Returns number of reasons

Açıklama

int hw_api_error::count ( void )

Returns the number of error reasons.

Dönen Değerler

Returns the number of errors, as an integer.

Ayrıca Bakınız

  • hw_api_error::reason

hw_api_content::read
hw_api_error::reason
Hyperwave API İşlevleri


Returns reason of error

hw_api_error::count
hw_api_object::assign
Hyperwave API İşlevleri
PHP Manual

hw_api_error::reason

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api_error::reason — Returns reason of error

Açıklama

HW_API_Reason hw_api_error::reason ( void )

Returns the first error reason.

Dönen Değerler

Ayrıca Bakınız

  • hw_api_error::count

hw_api_error::count
hw_api_object::assign
Hyperwave API İşlevleri


Clones object

hw_api_error::reason
hw_api_object::attreditable
Hyperwave API İşlevleri
PHP Manual

hw_api_object::assign

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api_object::assign — Clones object

Açıklama

bool hw_api_object::assign ( array $parameter )

Clones the attributes of an object.

Değiştirgeler

parameter

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

hw_api_error::reason
hw_api_object::attreditable
Hyperwave API İşlevleri


Checks whether an attribute is editable

hw_api_object::assign
hw_api_object::count
Hyperwave API İşlevleri
PHP Manual

hw_api_object::attreditable

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api_object::attreditable — Checks whether an attribute is editable

Açıklama

bool hw_api_object::attreditable ( array $parameter )

Checks whether an attribute is editable.

Değiştirgeler

parameter

Dönen Değerler

Returns TRUE if the attribute is editable, FALSE otherwise.

hw_api_object::assign
hw_api_object::count
Hyperwave API İşlevleri


Returns number of attributes

hw_api_object::attreditable
hw_api_object::insert
Hyperwave API İşlevleri
PHP Manual

hw_api_object::count

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api_object::count — Returns number of attributes

Açıklama

int hw_api_object::count ( array $parameter )

Returns the number of attributes.

Değiştirgeler

parameter

Dönen Değerler

Returns the number as an integer.

hw_api_object::attreditable
hw_api_object::insert
Hyperwave API İşlevleri


Inserts new attribute

hw_api_object::count
hw_api_object::remove
Hyperwave API İşlevleri
PHP Manual

hw_api_object::insert

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api_object::insert — Inserts new attribute

Açıklama

bool hw_api_object::insert ( HW_API_Attribute $attribute )

Adds an attribute to the object.

Değiştirgeler

attribute

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • hw_api_object::remove

hw_api_object::count
hw_api_object::remove
Hyperwave API İşlevleri


Removes attribute

hw_api_object::insert
hw_api_object::title
Hyperwave API İşlevleri
PHP Manual

hw_api_object::remove

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api_object::remove — Removes attribute

Açıklama

bool hw_api_object::remove ( string $name )

Removes the attribute with the given name.

Değiştirgeler

name

The attribute name.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • hw_api_object::insert

hw_api_object::insert
hw_api_object::title
Hyperwave API İşlevleri


Returns the title attribute

hw_api_object::remove
hw_api_object::value
Hyperwave API İşlevleri
PHP Manual

hw_api_object::title

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api_object::title — Returns the title attribute

Açıklama

string hw_api_object::title ( array $parameter )

Returns the title attribute.

Değiştirgeler

parameter

Dönen Değerler

Returns the title as a string.

hw_api_object::remove
hw_api_object::value
Hyperwave API İşlevleri


Returns value of attribute

hw_api_object::title
hw_api_reason::description
Hyperwave API İşlevleri
PHP Manual

hw_api_object::value

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api_object::value — Returns value of attribute

Açıklama

string hw_api_object::value ( string $name )

Returns value of an attribute.

Değiştirgeler

name

The attribute name.

Dönen Değerler

Returns the value of the attribute with the given name or FALSE if an error occurred.

hw_api_object::title
hw_api_reason::description
Hyperwave API İşlevleri


Returns description of reason

hw_api_object::value
hw_api_reason::type
Hyperwave API İşlevleri
PHP Manual

hw_api_reason::description

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api_reason::description — Returns description of reason

Açıklama

string hw_api_reason::description ( void )

Returns the description of a reason

Dönen Değerler

Returns the description, as a string.

hw_api_object::value
hw_api_reason::type
Hyperwave API İşlevleri


Returns type of reason

hw_api_reason::description
hwapi_attribute_new
Hyperwave API İşlevleri
PHP Manual

hw_api_reason::type

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hw_api_reason::type — Returns type of reason

Açıklama

HW_API_Reason hw_api_reason::type ( void )

Returns the type of a reason.

Dönen Değerler

Returns an instance of HW_API_Reason.

hw_api_reason::description
hwapi_attribute_new
Hyperwave API İşlevleri


Creates instance of class hw_api_attribute

hw_api_reason::type
hwapi_content_new
Hyperwave API İşlevleri
PHP Manual

hwapi_attribute_new

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

hwapi_attribute_new — Creates instance of class hw_api_attribute

Açıklama

HW_API_Attribute hwapi_attribute_new ([ string $name [, string $value ]] )

Creates a new instance of hw_api_attribute with the given name and value.

Değiştirgeler

name

The attribute name.

value

The attribute value.

Dönen Değerler

Returns an instance of hw_api_attribute.

hw_api_reason::type
hwapi_content_new
Hyperwave API İşlevleri


Create new instance of class hw_api_content

hwapi_attribute_new
hwapi_hgcsp
Hyperwave API İşlevleri
PHP Manual

hwapi_content_new

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

hwapi_content_new — Create new instance of class hw_api_content

Açıklama

HW_API_Content hwapi_content_new ( string $content , string $mimetype )

Creates a new content object from the string content.

Değiştirgeler

content

mimetype

The mimetype for the contents.

Dönen Değerler

hwapi_attribute_new
hwapi_hgcsp
Hyperwave API İşlevleri


Returns object of class hw_api

hwapi_content_new
hwapi_object_new
Hyperwave API İşlevleri
PHP Manual

hwapi_hgcsp

(PHP 4, PHP 5 < 5.2.0, PECL hwapi SVN)

hwapi_hgcsp — Returns object of class hw_api

Açıklama

HW_API hwapi_hgcsp ( string $hostname [, int $port ] )

Opens a connection to the Hyperwave server on host hostname. The protocol used is HGCSP.

Değiştirgeler

hostname

The host name.

port

If you do not pass a port number, 418 is used.

Dönen Değerler

Returns an instance of HW_API.

hwapi_content_new
hwapi_object_new
Hyperwave API İşlevleri


Creates a new instance of class hwapi_object_new

hwapi_hgcsp
LDAP
Hyperwave API İşlevleri
PHP Manual

hwapi_object_new

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

hwapi_object_new — Creates a new instance of class hwapi_object_new

Açıklama

hw_api_object hwapi_object_new ( array $parameter )

Creates a new instance of the class hw_api_object.

Değiştirgeler

parameter

Dönen Değerler

Ayrıca Bakınız

  • hw_api::lock

hwapi_hgcsp
LDAP
Hyperwave API İşlevleri


Lightweight Directory Access Protocol

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Using the PHP LDAP calls
  • Örnekler
    • Basic usage
  • LDAP İşlevleri
    • ldap_8859_to_t61 — Translate 8859 characters to t61 characters
    • ldap_add — Add entries to LDAP directory
    • ldap_bind — Bind to LDAP directory
    • ldap_close — Takma Adı: ldap_unbind
    • ldap_compare — Compare value of attribute found in entry specified with DN
    • ldap_connect — Connect to an LDAP server
    • ldap_control_paged_result_response — Retrieve the LDAP pagination cookie
    • ldap_control_paged_result — Send LDAP pagination control
    • ldap_count_entries — Count the number of entries in a search
    • ldap_delete — Delete an entry from a directory
    • ldap_dn2ufn — Convert DN to User Friendly Naming format
    • ldap_err2str — Convert LDAP error number into string error message
    • ldap_errno — Return the LDAP error number of the last LDAP command
    • ldap_error — Return the LDAP error message of the last LDAP command
    • ldap_escape — Escape a string for use in an LDAP filter or DN
    • ldap_explode_dn — Splits DN into its component parts
    • ldap_first_attribute — Return first attribute
    • ldap_first_entry — Return first result id
    • ldap_first_reference — Return first reference
    • ldap_free_result — Free result memory
    • ldap_get_attributes — Get attributes from a search result entry
    • ldap_get_dn — Get the DN of a result entry
    • ldap_get_entries — Get all result entries
    • ldap_get_option — Get the current value for given option
    • ldap_get_values_len — Get all binary values from a result entry
    • ldap_get_values — Get all values from a result entry
    • ldap_list — Single-level search
    • ldap_mod_add — Add attribute values to current attributes
    • ldap_mod_del — Delete attribute values from current attributes
    • ldap_mod_replace — Replace attribute values with new ones
    • ldap_modify_batch — Batch and execute modifications on an LDAP entry
    • ldap_modify — Modify an LDAP entry
    • ldap_next_attribute — Get the next attribute in result
    • ldap_next_entry — Get next result entry
    • ldap_next_reference — Get next reference
    • ldap_parse_reference — Extract information from reference entry
    • ldap_parse_result — Extract information from result
    • ldap_read — Read an entry
    • ldap_rename — Modify the name of an entry
    • ldap_sasl_bind — Bind to LDAP directory using SASL
    • ldap_search — Search LDAP tree
    • ldap_set_option — Set the value of the given option
    • ldap_set_rebind_proc — Set a callback function to do re-binds on referral chasing
    • ldap_sort — Sort LDAP result entries on the client side
    • ldap_start_tls — Start TLS
    • ldap_t61_to_8859 — Translate t61 characters to 8859 characters
    • ldap_unbind — Unbind from LDAP directory
hwapi_object_new
Giriş
Diğer Hizmetler


Giriş

LDAP is the Lightweight Directory Access Protocol, and is a protocol used to access "Directory Servers". The Directory is a special kind of database that holds information in a tree structure.

The concept is similar to your hard disk directory structure, except that in this context, the root directory is "The world" and the first level subdirectories are "countries". Lower levels of the directory structure contain entries for companies, organisations or places, while yet lower still we find directory entries for people, and perhaps equipment or documents.

To refer to a file in a subdirectory on your hard disk, you might use something like:

   /usr/local/myapp/docs

The forwards slash marks each division in the reference, and the sequence is read from left to right.

The equivalent to the fully qualified file reference in LDAP is the "distinguished name", referred to simply as "dn". An example dn might be:

   cn=John Smith,ou=Accounts,o=My Company,c=US

The comma marks each division in the reference, and the sequence is read from right to left. You would read this dn as:

   country = US
   organization = My Company
   organizationalUnit = Accounts
   commonName = John Smith

In the same way as there are no hard rules about how you organise the directory structure of a hard disk, a directory server manager can set up any structure that is meaningful for the purpose. However, there are some conventions that are used. The message is that you can not write code to access a directory server unless you know something about its structure, any more than you can use a database without some knowledge of what is available.

Lots of information about LDAP can be found at

  • » Mozilla

  • » OpenLDAP Project

  • Internet Engineering Taskforce RFCs » 4510 through » 4519.

The Netscape SDK contains a helpful » Programmer's Guide in HTML format.

LDAP
Yapılandırma/Kurulum
LDAP


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
LDAP


Gereksinimler

You will need to get and compile LDAP client libraries from either » OpenLDAP or » Bind9.net in order to compile PHP with LDAP support. For PHP 5.6 or newer you will need OpenLDAP 2.4 or newer.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

LDAP support in PHP is not enabled by default. You will need to use the --with-ldap[=DIR] configuration option when compiling PHP to enable LDAP support. DIR is the LDAP base install directory. To enable SASL support, be sure --with-ldap-sasl[=DIR] is used, and that sasl.h exists on the system.

Bilginize: Note to Win32 Users

Bu eklentinin çalışabilmesi için bazı DLL dosyalarının bulunduğu yerlerin Windows sistem PATH'ında tanımlı olması gerekir. Bunun nasıl yapılacağı SSS altında "PHP dizinimi Windows'ta PATH'a nasıl eklerim" başlığı altında açıklanmıştır. Eklenti, DLL dosyaları PHP dizininden Windows system dizinine taşındığında da çalışırsa da (çünkü system dizini sistem PATH'ında zaten vardır) bu önerilmez. Bu eklentinin çalışabilmesi için bulunduğu dizine PATH üzerinden erişilebilinmesi gereken dosyanın ismi: libeay32.dll and ssleay32.dll

In order to use Oracle LDAP libraries, proper Oracle environment has to be set.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

LDAP configuration options
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
ldap.max_links | "-1" | PHP_INI_SYSTEM |
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

ldap.max_links integer

The maximum number of LDAP connections per process.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Özkaynak Türleri

Most LDAP functions operate on or return resources (e.g. ldap_connect() returns a positive LDAP link identifier required by most LDAP functions).

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

LDAP_DEREF_NEVER (integer)
LDAP_DEREF_SEARCHING (integer)
LDAP_DEREF_FINDING (integer)
LDAP_DEREF_ALWAYS (integer)
LDAP_OPT_DEREF (integer)
Specifies alternative rules for following aliases at the server.
LDAP_OPT_SIZELIMIT (integer)

Specifies the maximum number of entries that can be returned on a search operation.

Bilginize: The actual size limit for operations is also bounded by the server's configured maximum number of return entries. The lesser of these two settings is the actual size limit.

LDAP_OPT_TIMELIMIT (integer)
Specifies the number of seconds to wait for search results.

Bilginize: The actual time limit for operations is also bounded by the server's configured maximum time. The lesser of these two settings is the actual time limit.

LDAP_OPT_NETWORK_TIMEOUT (integer)
Option for ldap_set_option() to allow setting network timeout. (Available as of PHP 5.3.0)
LDAP_OPT_PROTOCOL_VERSION (integer)
Specifies the LDAP protocol to be used (V2 or V3).
LDAP_OPT_ERROR_NUMBER (integer)
LDAP_OPT_REFERRALS (integer)
Specifies whether to automatically follow referrals returned by the LDAP server.
LDAP_OPT_RESTART (integer)
LDAP_OPT_HOST_NAME (integer)
LDAP_OPT_ERROR_STRING (integer)
LDAP_OPT_DIAGNOSTIC_MESSAGE (integer)
LDAP_OPT_MATCHED_DN (integer)
LDAP_OPT_SERVER_CONTROLS (integer)
Specifies a default list of server controls to be sent with each request.
LDAP_OPT_CLIENT_CONTROLS (integer)
Specifies a default list of client controls to be processed with each request.
LDAP_OPT_DEBUG_LEVEL (integer)
Specifies a bitwise level for debug traces.
LDAP_OPT_X_KEEPALIVE_IDLE (integer)
Specifies the number of seconds a connection needs to remain idle before TCP starts sending keepalive probes.
LDAP_OPT_X_KEEPALIVE_PROBES (integer)
Specifies the maximum number of keepalive probes TCP should send before dropping the connection.
LDAP_OPT_X_KEEPALIVE_INTERVAL (integer)
Specifies the interval in seconds between individual keepalive probes.
LDAP_OPT_X_TLS_CACERTDIR (string)
Specifies the path of the directory containing CA certificates.
LDAP_OPT_X_TLS_CACERTFILE (string)
Specifies the full-path of the CA certificate file.
LDAP_OPT_X_TLS_CERTFILE (string)
Specifies the full-path of the certificate file.
LDAP_OPT_X_TLS_CIPHER_SUITE (string)
Specifies the allowed cipher suite.
LDAP_OPT_X_TLS_CRLCHECK (integer)
Specifies the CRL evaluation strategy. This must be one of: LDAP_OPT_X_TLS_CRL_NONE,LDAP_OPT_X_TLS_CRL_PEER, LDAP_OPT_X_TLS_CRL_ALL.

Bilginize: This option is only valid for OpenSSL.

LDAP_OPT_X_TLS_CRLFILE (string)
Specifies the full-path of the CRL file.

Bilginize: This option is only valid for GnuTLS.

LDAP_OPT_X_TLS_DHFILE (string)
Specifies the full-path of the file containing the parameters for Diffie-Hellman ephemeral key exchange.

Bilginize: This option is ignored by GnuTLS and Mozilla NSS.

LDAP_OPT_X_TLS_KEYFILE (string)
Specifies the full-path of the certificate key file.
LDAP_OPT_X_TLS_PROTOCOL_MIN (integer)
Specifies the minimum protocol version. This can be one of: LDAP_OPT_X_TLS_PROTOCOL_SSL2,LDAP_OPT_X_TLS_PROTOCOL_SSL3, LDAP_OPT_X_TLS_PROTOCOL_TLS1_0, LDAP_OPT_X_TLS_PROTOCOL_TLS1_1, LDAP_OPT_X_TLS_PROTOCOL_TLS1_2
LDAP_OPT_X_TLS_RANDOM_FILE (string)
LDAP_OPT_X_TLS_REQUIRE_CERT (integer)
Specifies the certificate checking checking strategy. This must be one of: LDAP_OPT_X_TLS_NEVER,LDAP_OPT_X_TLS_HARD, LDAP_OPT_X_TLS_DEMAND, LDAP_OPT_X_TLS_ALLOW, LDAP_OPT_X_TLS_TRY. (Available as of PHP 7.0.0)
GSLC_SSL_NO_AUTH (integer)
GSLC_SSL_ONEWAY_AUTH (integer)
GSLC_SSL_TWOWAY_AUTH (integer)
Özkaynak Türleri
Using the PHP LDAP calls
LDAP


Using the PHP LDAP calls

Before you can use the LDAP calls you will need to know ..

  • The name or address of the directory server you will use

  • The "base dn" of the server (the part of the world directory that is held on this server, which could be "o=My Company,c=US")

  • Whether you need a password to access the server (many servers will provide read access for an "anonymous bind" but require a password for anything else)

The typical sequence of LDAP calls you will make in an application will follow this pattern:

  ldap_connect()    // establish connection to server
     |
  ldap_bind()       // anonymous or authenticated "login"
     |
  do something like search or update the directory
  and display the results
     |
  ldap_close()      // "logout"

Öntanımlı Sabitler
Örnekler
LDAP


Örnekler

İçindekiler

  • Basic usage
Using the PHP LDAP calls
Basic usage
LDAP


Basic usage

Retrieve information for all entries where the surname starts with "S" from a directory server, displaying an extract with name and email address.

Örnek 1 LDAP search example

<?php
// basic sequence with LDAP is connect, bind, search, interpret search
// result, close connection

echo "<h3>LDAP query test</h3>";
echo "Connecting ...";
$ds=ldap_connect("localhost");  // must be a valid LDAP server!
echo "connect result is " . $ds . "<br />";

if ($ds) {
    echo "Binding ...";
    $r=ldap_bind($ds);     // this is an "anonymous" bind, typically
                           // read-only access
    echo "Bind result is " . $r . "<br />";

    echo "Searching for (sn=S*) ...";
    // Search surname entry
    $sr=ldap_search($ds, "o=My Company, c=US", "sn=S*");
    echo "Search result is " . $sr . "<br />";

    echo "Number of entries returned is " . ldap_count_entries($ds, $sr) . "<br />";

    echo "Getting entries ...<p>";
    $info = ldap_get_entries($ds, $sr);
    echo "Data for " . $info["count"] . " items returned:<p>";

    for ($i=0; $i<$info["count"]; $i++) {
        echo "dn is: " . $info[$i]["dn"] . "<br />";
        echo "first cn entry is: " . $info[$i]["cn"][0] . "<br />";
        echo "first email entry is: " . $info[$i]["mail"][0] . "<br /><hr />";
    }

    echo "Closing connection";
    ldap_close($ds);

} else {
    echo "<h4>Unable to connect to LDAP server</h4>";
}
?>
Örnekler
LDAP İşlevleri
Örnekler


LDAP İşlevleri

İçindekiler

  • ldap_8859_to_t61 — Translate 8859 characters to t61 characters
  • ldap_add — Add entries to LDAP directory
  • ldap_bind — Bind to LDAP directory
  • ldap_close — Takma Adı: ldap_unbind
  • ldap_compare — Compare value of attribute found in entry specified with DN
  • ldap_connect — Connect to an LDAP server
  • ldap_control_paged_result_response — Retrieve the LDAP pagination cookie
  • ldap_control_paged_result — Send LDAP pagination control
  • ldap_count_entries — Count the number of entries in a search
  • ldap_delete — Delete an entry from a directory
  • ldap_dn2ufn — Convert DN to User Friendly Naming format
  • ldap_err2str — Convert LDAP error number into string error message
  • ldap_errno — Return the LDAP error number of the last LDAP command
  • ldap_error — Return the LDAP error message of the last LDAP command
  • ldap_escape — Escape a string for use in an LDAP filter or DN
  • ldap_explode_dn — Splits DN into its component parts
  • ldap_first_attribute — Return first attribute
  • ldap_first_entry — Return first result id
  • ldap_first_reference — Return first reference
  • ldap_free_result — Free result memory
  • ldap_get_attributes — Get attributes from a search result entry
  • ldap_get_dn — Get the DN of a result entry
  • ldap_get_entries — Get all result entries
  • ldap_get_option — Get the current value for given option
  • ldap_get_values_len — Get all binary values from a result entry
  • ldap_get_values — Get all values from a result entry
  • ldap_list — Single-level search
  • ldap_mod_add — Add attribute values to current attributes
  • ldap_mod_del — Delete attribute values from current attributes
  • ldap_mod_replace — Replace attribute values with new ones
  • ldap_modify_batch — Batch and execute modifications on an LDAP entry
  • ldap_modify — Modify an LDAP entry
  • ldap_next_attribute — Get the next attribute in result
  • ldap_next_entry — Get next result entry
  • ldap_next_reference — Get next reference
  • ldap_parse_reference — Extract information from reference entry
  • ldap_parse_result — Extract information from result
  • ldap_read — Read an entry
  • ldap_rename — Modify the name of an entry
  • ldap_sasl_bind — Bind to LDAP directory using SASL
  • ldap_search — Search LDAP tree
  • ldap_set_option — Set the value of the given option
  • ldap_set_rebind_proc — Set a callback function to do re-binds on referral chasing
  • ldap_sort — Sort LDAP result entries on the client side
  • ldap_start_tls — Start TLS
  • ldap_t61_to_8859 — Translate t61 characters to 8859 characters
  • ldap_unbind — Unbind from LDAP directory
Basic usage
ldap_8859_to_t61
LDAP


Translate 8859 characters to t61 characters

LDAP İşlevleri
ldap_add
LDAP İşlevleri
PHP Manual

ldap_8859_to_t61

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

ldap_8859_to_t61 — Translate 8859 characters to t61 characters

Açıklama

string ldap_8859_to_t61 ( string $value )

Translate ISO-8859 characters to t61 characters.

This function is useful if you have to talk to a legacy LDAPv2 server.

Değiştirgeler

value

The text to be translated.

Dönen Değerler

Return the t61 translation of value.

Ayrıca Bakınız

  • ldap_t61_to_8859() - Translate t61 characters to 8859 characters

LDAP İşlevleri
ldap_add
LDAP İşlevleri


Add entries to LDAP directory

ldap_8859_to_t61
ldap_bind
LDAP İşlevleri
PHP Manual

ldap_add

(PHP 4, PHP 5, PHP 7)

ldap_add — Add entries to LDAP directory

Açıklama

bool ldap_add ( resource $link_identifier , string $dn , array $entry )

Add entries in the LDAP directory.

Değiştirgeler

link_identifier

An LDAP link identifier, returned by ldap_connect().

dn

The distinguished name of an LDAP entity.

entry

An array that specifies the information about the entry. The values in the entries are indexed by individual attributes. In case of multiple values for an attribute, they are indexed using integers starting with 0.

<?php
$entry["attribute1"] = "value";
$entry["attribute2"][0] = "value1";
$entry["attribute2"][1] = "value2";
?>

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Complete example with authenticated bind

<?php
$ds = ldap_connect("localhost");  // assuming the LDAP server is on this host

if ($ds) {
    // bind with appropriate dn to give update access
    $r = ldap_bind($ds, "cn=root, o=My Company, c=US", "secret");

    // prepare data
    $info["cn"] = "John Jones";
    $info["sn"] = "Jones";
    $info["objectclass"] = "person";

    // add data to directory
    $r = ldap_add($ds, "cn=John Jones, o=My Company, c=US", $info);

    ldap_close($ds);
} else {
    echo "Unable to connect to LDAP server";
}
?>

Notlar

Bilginize: Bu işlev ikil dosyalarla çalışırken dosya içeriğini değiştirmez.

Ayrıca Bakınız

  • ldap_delete() - Delete an entry from a directory

ldap_8859_to_t61
ldap_bind
LDAP İşlevleri


Bind to LDAP directory

ldap_add
ldap_close
LDAP İşlevleri
PHP Manual

ldap_bind

(PHP 4, PHP 5, PHP 7)

ldap_bind — Bind to LDAP directory

Açıklama

bool ldap_bind ( resource $link_identifier [, string $bind_rdn = NULL [, string $bind_password = NULL ]] )

Binds to the LDAP directory with specified RDN and password.

Değiştirgeler

link_identifier

An LDAP link identifier, returned by ldap_connect().

bind_rdn

bind_password

If bind_password is not specified or is empty, an anonymous bind is attempted. The bind_dn can also be left empty for an anonymous bind. This is defined in https://tools.ietf.org/html/rfc2251#section-4.2.2

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Using LDAP Bind

<?php

// using ldap bind
$ldaprdn  = 'uname';     // ldap rdn or dn
$ldappass = 'password';  // associated password

// connect to ldap server
$ldapconn = ldap_connect("ldap.example.com")
    or die("Could not connect to LDAP server.");

if ($ldapconn) {

    // binding to ldap server
    $ldapbind = ldap_bind($ldapconn, $ldaprdn, $ldappass);

    // verify binding
    if ($ldapbind) {
        echo "LDAP bind successful...";
    } else {
        echo "LDAP bind failed...";
    }

}

?>

Örnek 2 Using LDAP Bind Anonymously

<?php

//using ldap bind anonymously

// connect to ldap server
$ldapconn = ldap_connect("ldap.example.com")
    or die("Could not connect to LDAP server.");

if ($ldapconn) {

    // binding anonymously
    $ldapbind = ldap_bind($ldapconn);

    if ($ldapbind) {
        echo "LDAP bind anonymous successful...";
    } else {
        echo "LDAP bind anonymous failed...";
    }

}

?>

Ayrıca Bakınız

  • ldap_unbind() - Unbind from LDAP directory

ldap_add
ldap_close
LDAP İşlevleri


Takma Adı: ldap_unbind

ldap_bind
ldap_compare
LDAP İşlevleri
PHP Manual

ldap_close

(PHP 4, PHP 5, PHP 7)

ldap_close — Takma Adı: ldap_unbind()

Açıklama

Bu işlev şu işlevin takma adıdır: ldap_unbind().

ldap_bind
ldap_compare
LDAP İşlevleri


Compare value of attribute found in entry specified with DN

ldap_close
ldap_connect
LDAP İşlevleri
PHP Manual

ldap_compare

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

ldap_compare — Compare value of attribute found in entry specified with DN

Açıklama

mixed ldap_compare ( resource $link_identifier , string $dn , string $attribute , string $value )

Compare value of attribute with value of same attribute in an LDAP directory entry.

Değiştirgeler

link_identifier

An LDAP link identifier, returned by ldap_connect().

dn

The distinguished name of an LDAP entity.

attribute

The attribute name.

value

The compared value.

Dönen Değerler

Returns TRUE if value matches otherwise returns FALSE. Returns -1 on error.

Örnekler

The following example demonstrates how to check whether or not given password matches the one defined in DN specified entry.

Örnek 1 Complete example of password check

<?php

$ds=ldap_connect("localhost");  // assuming the LDAP server is on this host

if ($ds) {

    // bind
    if (ldap_bind($ds)) {

        // prepare data
        $dn = "cn=Matti Meikku, ou=My Unit, o=My Company, c=FI";
        $value = "secretpassword";
        $attr = "password";

        // compare value
        $r=ldap_compare($ds, $dn, $attr, $value);

        if ($r === -1) {
            echo "Error: " . ldap_error($ds);
        } elseif ($r === true) {
            echo "Password correct.";
        } elseif ($r === false) {
            echo "Wrong guess! Password incorrect.";
        }

    } else {
        echo "Unable to bind to LDAP server.";
    }

    ldap_close($ds);

} else {
    echo "Unable to connect to LDAP server.";
}
?>

Notlar

Uyarı

ldap_compare() can NOT be used to compare BINARY values!

ldap_close
ldap_connect
LDAP İşlevleri


Connect to an LDAP server

ldap_compare
ldap_control_paged_result_response
LDAP İşlevleri
PHP Manual

ldap_connect

(PHP 4, PHP 5, PHP 7)

ldap_connect — Connect to an LDAP server

Açıklama

resource ldap_connect ([ string $host = NULL [, int $port = 389 ]] )

Creates an LDAP link identifier and checks whether the given host and port are plausible.

Note: This function does not open a connection. It checks whether the given parameters are plausible and can be used to open a connection as soon as one is needed.

Değiştirgeler

host

This field supports using a hostname or, with OpenLDAP 2.x.x and later, a full LDAP URI of the form ldap://hostname:port or ldaps://hostname:port for SSL encryption.

You can also provide multiple LDAP-URIs separated by a space as one string

Note that hostname:port is not a supported LDAP URI as the schema is missing.

port

The port to connect to. Not used when using LDAP URIs.

Dönen Değerler

Returns a positive LDAP link identifier when the provided hostname/port combination or LDAP URI seems plausible. It's a syntactic check of the provided parameters but the server(s) will not be contacted! If the syntactic check fails it returns FALSE. When OpenLDAP 2.x.x is used, ldap_connect() will always return a resource as it does not actually connect but just initializes the connecting parameters. The actual connect happens with the next calls to ldap_* funcs, usually with ldap_bind().

If no arguments are specified then the link identifier of the already opened link will be returned.

Örnekler

Örnek 1 Example of connecting to LDAP server.

<?php

// LDAP variables
$ldaphost = "ldap.example.com";  // your ldap servers
$ldapport = 389;                 // your ldap server's port number

// Connecting to LDAP
$ldapconn = ldap_connect($ldaphost, $ldapport)
          or die("Could not connect to $ldaphost");

?>

Örnek 2 Example of connecting securely to LDAP server.

<?php

// make sure your host is the correct one
// that you issued your secure certificate to
$ldaphost = "ldaps://ldap.example.com/";

// Connecting to LDAP
$ldapconn = ldap_connect($ldaphost)
          or die("Could not connect to {$ldaphost}");

?>

Ayrıca Bakınız

  • ldap_bind() - Bind to LDAP directory

ldap_compare
ldap_control_paged_result_response
LDAP İşlevleri


Retrieve the LDAP pagination cookie

ldap_connect
ldap_control_paged_result
LDAP İşlevleri
PHP Manual

ldap_control_paged_result_response

(PHP 5 >= 5.4.0, PHP 7)

ldap_control_paged_result_response — Retrieve the LDAP pagination cookie

Açıklama

bool ldap_control_paged_result_response ( resource $link , resource $result [, string &$cookie [, int &$estimated ]] )

Retrieve the pagination information send by the server.

Değiştirgeler

link

An LDAP link identifier, returned by ldap_connect().

result

cookie

An opaque structure sent by the server.

estimated

The estimated number of entries to retrieve.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ldap_control_paged_result() - Send LDAP pagination control
  • » RFC2696 : LDAP Control Extension for Simple Paged Results Manipulation

ldap_connect
ldap_control_paged_result
LDAP İşlevleri


Send LDAP pagination control

ldap_control_paged_result_response
ldap_count_entries
LDAP İşlevleri
PHP Manual

ldap_control_paged_result

(PHP 5 >= 5.4.0, PHP 7)

ldap_control_paged_result — Send LDAP pagination control

Açıklama

bool ldap_control_paged_result ( resource $link , int $pagesize [, bool $iscritical = false [, string $cookie = "" ]] )

Enable LDAP pagination by sending the pagination control (page size, cookie...).

Değiştirgeler

link

An LDAP link identifier, returned by ldap_connect().

pagesize

The number of entries by page.

iscritical

Indicates whether the pagination is critical or not. If true and if the server doesn't support pagination, the search will return no result.

cookie

An opaque structure sent by the server (ldap_control_paged_result_response()).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

The example below show the retrieval of the first page of a search paginated with one entry by page.

Örnek 1 LDAP pagination

<?php
     // $ds is a valid link identifier (see ldap_connect)
     ldap_set_option($ds, LDAP_OPT_PROTOCOL_VERSION, 3);

     $dn        = 'ou=example,dc=org';
     $filter    = '(|(sn=Doe*)(givenname=John*))';
     $justthese = array('ou', 'sn', 'givenname', 'mail');

     // enable pagination with a page size of 1.
     ldap_control_paged_result($ds, 1);

     $sr = ldap_search($ds, $dn, $filter, $justthese);

     $info = ldap_get_entries($ds, $sr);

     echo $info['count'] . ' entries returned' . PHP_EOL;

The example below show the retrieval of all the result paginated with 100 entries by page.

Örnek 2 LDAP pagination

<?php
     // $ds is a valid link identifier (see ldap_connect)
     ldap_set_option($ds, LDAP_OPT_PROTOCOL_VERSION, 3);

     $dn        = 'ou=example,dc=org';
     $filter    = '(|(sn=Doe*)(givenname=John*))';
     $justthese = array('ou', 'sn', 'givenname', 'mail');

     // enable pagination with a page size of 100.
     $pageSize = 100;

     $cookie = '';
     do {
         ldap_control_paged_result($ds, $pageSize, true, $cookie);

         $result  = ldap_search($ds, $dn, $filter, $justthese);
         $entries = ldap_get_entries($ds, $result);

         foreach ($entries as $e) {
             echo $e['dn'] . PHP_EOL;
         }

         ldap_control_paged_result_response($ds, $result, $cookie);

     } while($cookie !== null && $cookie != '');

Notlar

Bilginize:

Pagination control is a LDAPv3 protocol feature.

Ayrıca Bakınız

  • ldap_control_paged_result_response() - Retrieve the LDAP pagination cookie
  • » RFC2696 : LDAP Control Extension for Simple Paged Results Manipulation

ldap_control_paged_result_response
ldap_count_entries
LDAP İşlevleri


Count the number of entries in a search

ldap_control_paged_result
ldap_delete
LDAP İşlevleri
PHP Manual

ldap_count_entries

(PHP 4, PHP 5, PHP 7)

ldap_count_entries — Count the number of entries in a search

Açıklama

int ldap_count_entries ( resource $link_identifier , resource $result_identifier )

Returns the number of entries stored in the result of previous search operations.

Değiştirgeler

link_identifier

An LDAP link identifier, returned by ldap_connect().

result_identifier

The internal LDAP result.

Dönen Değerler

Returns number of entries in the result or FALSE on error.

Örnekler

Örnek 1 ldap-count-entries() example

Retrieve number of entries in the result.

// $ds is a valid link identifier (see ldap_connect)

     $dn        = 'ou=example,dc=org';
     $filter    = '(|(sn=Doe*)(givenname=John*))';
     $justthese = array('ou', 'sn', 'givenname', 'mail');

     $sr = ldap_search($ds, $dn, $filter, $justthese);

     var_dump(ldap_count_entries($ds, $sr));

Yukarıdaki örnek şuna benzer bir çıktı üretir:

     int(1)

ldap_control_paged_result
ldap_delete
LDAP İşlevleri


Delete an entry from a directory

ldap_count_entries
ldap_dn2ufn
LDAP İşlevleri
PHP Manual

ldap_delete

(PHP 4, PHP 5, PHP 7)

ldap_delete — Delete an entry from a directory

Açıklama

bool ldap_delete ( resource $link_identifier , string $dn )

Deletes a particular entry in LDAP directory.

Değiştirgeler

link_identifier

An LDAP link identifier, returned by ldap_connect().

dn

The distinguished name of an LDAP entity.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ldap_add() - Add entries to LDAP directory

ldap_count_entries
ldap_dn2ufn
LDAP İşlevleri


Convert DN to User Friendly Naming format

ldap_delete
ldap_err2str
LDAP İşlevleri
PHP Manual

ldap_dn2ufn

(PHP 4, PHP 5, PHP 7)

ldap_dn2ufn — Convert DN to User Friendly Naming format

Açıklama

string ldap_dn2ufn ( string $dn )

Turns the specified dn, into a more user-friendly form, stripping off type names.

Değiştirgeler

dn

The distinguished name of an LDAP entity.

Dönen Değerler

Returns the user friendly name.

ldap_delete
ldap_err2str
LDAP İşlevleri


Convert LDAP error number into string error message

ldap_dn2ufn
ldap_errno
LDAP İşlevleri
PHP Manual

ldap_err2str

(PHP 4, PHP 5, PHP 7)

ldap_err2str — Convert LDAP error number into string error message

Açıklama

string ldap_err2str ( int $errno )

Returns the string error message explaining the error number errno. While LDAP errno numbers are standardized, different libraries return different or even localized textual error messages. Never check for a specific error message text, but always use an error number to check.

Değiştirgeler

errno

The error number.

Dönen Değerler

Returns the error message, as a string.

Örnekler

Örnek 1 Enumerating all LDAP error messages

<?php
  for ($i=0; $i<100; $i++) {
    printf("Error $i: %s<br />\n", ldap_err2str($i));
  }
?>

Ayrıca Bakınız

  • ldap_errno() - Return the LDAP error number of the last LDAP command
  • ldap_error() - Return the LDAP error message of the last LDAP command

ldap_dn2ufn
ldap_errno
LDAP İşlevleri


Return the LDAP error number of the last LDAP command

ldap_err2str
ldap_error
LDAP İşlevleri
PHP Manual

ldap_errno

(PHP 4, PHP 5, PHP 7)

ldap_errno — Return the LDAP error number of the last LDAP command

Açıklama

int ldap_errno ( resource $link_identifier )

Returns the standardized error number returned by the last LDAP command. This number can be converted into a textual error message using ldap_err2str().

Değiştirgeler

link_identifier

An LDAP link identifier, returned by ldap_connect().

Dönen Değerler

Return the LDAP error number of the last LDAP command for this link.

Örnekler

Unless you lower your warning level in your php.ini sufficiently or prefix your LDAP commands with @ (at) characters to suppress warning output, the errors generated will also show up in your HTML output.

Örnek 1 Generating and catching an error

<?php
// This example contains an error, which we will catch.
$ld = ldap_connect("localhost");
$bind = ldap_bind($ld);
// syntax error in filter expression (errno 87),
// must be "objectclass=*" to work.
$res =  @ldap_search($ld, "o=Myorg, c=DE", "objectclass");
if (!$res) {
    echo "LDAP-Errno: " . ldap_errno($ld) . "<br />\n";
    echo "LDAP-Error: " . ldap_error($ld) . "<br />\n";
    die("Argh!<br />\n");
}
$info = ldap_get_entries($ld, $res);
echo $info["count"] . " matching entries.<br />\n";
?>

Ayrıca Bakınız

  • ldap_err2str() - Convert LDAP error number into string error message
  • ldap_error() - Return the LDAP error message of the last LDAP command

ldap_err2str
ldap_error
LDAP İşlevleri


Return the LDAP error message of the last LDAP command

ldap_errno
ldap_escape
LDAP İşlevleri
PHP Manual

ldap_error

(PHP 4, PHP 5, PHP 7)

ldap_error — Return the LDAP error message of the last LDAP command

Açıklama

string ldap_error ( resource $link_identifier )

Returns the string error message explaining the error generated by the last LDAP command for the given link_identifier. While LDAP errno numbers are standardized, different libraries return different or even localized textual error messages. Never check for a specific error message text, but always use an error number to check.

Unless you lower your warning level in your php.ini sufficiently or prefix your LDAP commands with @ (at) characters to suppress warning output, the errors generated will also show up in your HTML output.

Değiştirgeler

link_identifier

An LDAP link identifier, returned by ldap_connect().

Dönen Değerler

Returns string error message.

Ayrıca Bakınız

  • ldap_err2str() - Convert LDAP error number into string error message
  • ldap_errno() - Return the LDAP error number of the last LDAP command

ldap_errno
ldap_escape
LDAP İşlevleri


Escape a string for use in an LDAP filter or DN

ldap_error
ldap_explode_dn
LDAP İşlevleri
PHP Manual

ldap_escape

(PHP 5 >= 5.6.0, PHP 7)

ldap_escape — Escape a string for use in an LDAP filter or DN

Açıklama

string ldap_escape ( string $value [, string $ignore [, int $flags ]] )

Escapes value for use in the context implied by flags.

Değiştirgeler

value

The value to escape.

ignore

Characters to ignore when escaping.

flags

The context the escaped string will be used in: LDAP_ESCAPE_FILTER for filters to be used with ldap_search(), or LDAP_ESCAPE_DN for DNs.

Dönen Değerler

Returns the escaped string.

ldap_error
ldap_explode_dn
LDAP İşlevleri


Splits DN into its component parts

ldap_escape
ldap_first_attribute
LDAP İşlevleri
PHP Manual

ldap_explode_dn

(PHP 4, PHP 5, PHP 7)

ldap_explode_dn — Splits DN into its component parts

Açıklama

array ldap_explode_dn ( string $dn , int $with_attrib )

Splits the DN returned by ldap_get_dn() and breaks it up into its component parts. Each part is known as Relative Distinguished Name, or RDN.

Değiştirgeler

dn

The distinguished name of an LDAP entity.

with_attrib

Used to request if the RDNs are returned with only values or their attributes as well. To get RDNs with the attributes (i.e. in attribute=value format) set with_attrib to 0 and to get only values set it to 1.

Dönen Değerler

Returns an array of all DN components, başarısızlık durumunda FALSE döner. The first element in the array has count key and represents the number of returned values, next elements are numerically indexed DN components.

ldap_escape
ldap_first_attribute
LDAP İşlevleri


Return first attribute

ldap_explode_dn
ldap_first_entry
LDAP İşlevleri
PHP Manual

ldap_first_attribute

(PHP 4, PHP 5, PHP 7)

ldap_first_attribute — Return first attribute

Açıklama

string ldap_first_attribute ( resource $link_identifier , resource $result_entry_identifier )

Gets the first attribute in the given entry. Remaining attributes are retrieved by calling ldap_next_attribute() successively.

Similar to reading entries, attributes are also read one by one from a particular entry.

Değiştirgeler

link_identifier

An LDAP link identifier, returned by ldap_connect().

result_entry_identifier

ber_identifier

ber_identifier is the identifier to internal memory location pointer. It is passed by reference. The same ber_identifier is passed to ldap_next_attribute() , which modifies that pointer.

Bilginize:

This parameter is no longer used as this is now handled automatically by PHP. For backwards compatibility PHP will not throw an error if this parameter is passed.

Dönen Değerler

Returns the first attribute in the entry on success and FALSE on error.

Sürüm Bilgisi

Sürüm: | Açıklama
5.2.4 | The ber_identifier was removed. This is now handled automatically by PHP.

Ayrıca Bakınız

  • ldap_next_attribute() - Get the next attribute in result
  • ldap_get_attributes() - Get attributes from a search result entry

ldap_explode_dn
ldap_first_entry
LDAP İşlevleri


Return first result id

ldap_first_attribute
ldap_first_reference
LDAP İşlevleri
PHP Manual

ldap_first_entry

(PHP 4, PHP 5, PHP 7)

ldap_first_entry — Return first result id

Açıklama

resource ldap_first_entry ( resource $link_identifier , resource $result_identifier )

Returns the entry identifier for first entry in the result. This entry identifier is then supplied to ldap_next_entry() routine to get successive entries from the result.

Entries in the LDAP result are read sequentially using the ldap_first_entry() and ldap_next_entry() functions.

Değiştirgeler

link_identifier

An LDAP link identifier, returned by ldap_connect().

result_identifier

Dönen Değerler

Returns the result entry identifier for the first entry on success and FALSE on error.

Ayrıca Bakınız

  • ldap_get_entries() - Get all result entries

ldap_first_attribute
ldap_first_reference
LDAP İşlevleri


Return first reference

ldap_first_entry
ldap_free_result
LDAP İşlevleri
PHP Manual

ldap_first_reference

(PHP 4 >= 4.0.5, PHP 5, PHP 7)

ldap_first_reference — Return first reference

Açıklama

resource ldap_first_reference ( resource $link , resource $result )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ldap_first_entry
ldap_free_result
LDAP İşlevleri


Free result memory

ldap_first_reference
ldap_get_attributes
LDAP İşlevleri
PHP Manual

ldap_free_result

(PHP 4, PHP 5, PHP 7)

ldap_free_result — Free result memory

Açıklama

bool ldap_free_result ( resource $result_identifier )

Frees up the memory allocated internally to store the result. All result memory will be automatically freed when the script terminates.

Typically all the memory allocated for the LDAP result gets freed at the end of the script. In case the script is making successive searches which return large result sets, ldap_free_result() could be called to keep the runtime memory usage by the script low.

Değiştirgeler

result_identifier

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

ldap_first_reference
ldap_get_attributes
LDAP İşlevleri


Get attributes from a search result entry

ldap_free_result
ldap_get_dn
LDAP İşlevleri
PHP Manual

ldap_get_attributes

(PHP 4, PHP 5, PHP 7)

ldap_get_attributes — Get attributes from a search result entry

Açıklama

array ldap_get_attributes ( resource $link_identifier , resource $result_entry_identifier )

Reads attributes and values from an entry in the search result.

Having located a specific entry in the directory, you can find out what information is held for that entry by using this call. You would use this call for an application which "browses" directory entries and/or where you do not know the structure of the directory entries. In many applications you will be searching for a specific attribute such as an email address or a surname, and won't care what other data is held.

return_value["count"] = number of attributes in the entry
return_value[0] = first attribute
return_value[n] = nth attribute

return_value["attribute"]["count"] = number of values for attribute
return_value["attribute"][0] = first value of the attribute
return_value["attribute"][i] = (i+1)th value of the attribute

Değiştirgeler

link_identifier

An LDAP link identifier, returned by ldap_connect().

result_entry_identifier

Dönen Değerler

Returns a complete entry information in a multi-dimensional array on success and FALSE on error.

Örnekler

Örnek 1 Show the list of attributes held for a particular directory entry

<?php
// $ds is the link identifier for the directory

// $sr is a valid search result from a prior call to
// one of the ldap directory search calls

$entry = ldap_first_entry($ds, $sr);

$attrs = ldap_get_attributes($ds, $entry);

echo $attrs["count"] . " attributes held for this entry:<p>";

for ($i=0; $i < $attrs["count"]; $i++) {
    echo $attrs[$i] . "<br />";
}
?>

Ayrıca Bakınız

  • ldap_first_attribute() - Return first attribute
  • ldap_next_attribute() - Get the next attribute in result

ldap_free_result
ldap_get_dn
LDAP İşlevleri


Get the DN of a result entry

ldap_get_attributes
ldap_get_entries
LDAP İşlevleri
PHP Manual

ldap_get_dn

(PHP 4, PHP 5, PHP 7)

ldap_get_dn — Get the DN of a result entry

Açıklama

string ldap_get_dn ( resource $link_identifier , resource $result_entry_identifier )

Finds out the DN of an entry in the result.

Değiştirgeler

link_identifier

An LDAP link identifier, returned by ldap_connect().

result_entry_identifier

Dönen Değerler

Returns the DN of the result entry and FALSE on error.

ldap_get_attributes
ldap_get_entries
LDAP İşlevleri


Get all result entries

ldap_get_dn
ldap_get_option
LDAP İşlevleri
PHP Manual

ldap_get_entries

(PHP 4, PHP 5, PHP 7)

ldap_get_entries — Get all result entries

Açıklama

array ldap_get_entries ( resource $link_identifier , resource $result_identifier )

Reads multiple entries from the given result, and then reading the attributes and multiple values.

Değiştirgeler

link_identifier

An LDAP link identifier, returned by ldap_connect().

result_identifier

Dönen Değerler

Returns a complete result information in a multi-dimensional array on success and FALSE on error.

The structure of the array is as follows. The attribute index is converted to lowercase. (Attributes are case-insensitive for directory servers, but not when used as array indices.)

return_value["count"] = number of entries in the result
return_value[0] : refers to the details of first entry

return_value[i]["dn"] =  DN of the ith entry in the result

return_value[i]["count"] = number of attributes in ith entry
return_value[i][j] = NAME of the jth attribute in the ith entry in the result

return_value[i]["attribute"]["count"] = number of values for
                                        attribute in ith entry
return_value[i]["attribute"][j] = jth value of attribute in ith entry

Ayrıca Bakınız

  • ldap_first_entry() - Return first result id
  • ldap_next_entry() - Get next result entry

ldap_get_dn
ldap_get_option
LDAP İşlevleri


Get the current value for given option

ldap_get_entries
ldap_get_values_len
LDAP İşlevleri
PHP Manual

ldap_get_option

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

ldap_get_option — Get the current value for given option

Açıklama

bool ldap_get_option ( resource $link_identifier , int $option , mixed &$retval )

Sets retval to the value of the specified option.

Değiştirgeler

link_identifier

An LDAP link identifier, returned by ldap_connect().

option

The parameter option can be one of:

Option | Type
LDAP_OPT_DEREF | integer
LDAP_OPT_SIZELIMIT | integer
LDAP_OPT_TIMELIMIT | integer
LDAP_OPT_NETWORK_TIMEOUT | integer
LDAP_OPT_PROTOCOL_VERSION | integer
LDAP_OPT_ERROR_NUMBER | integer
LDAP_OPT_REFERRALS | bool
LDAP_OPT_RESTART | bool
LDAP_OPT_HOST_NAME | string
LDAP_OPT_ERROR_STRING | string
LDAP_OPT_MATCHED_DN | string
LDAP_OPT_SERVER_CONTROLS | array
LDAP_OPT_CLIENT_CONTROLS | array
LDAP_OPT_X_KEEPALIVE_IDLE | int
LDAP_OPT_X_KEEPALIVE_PROBES | int
LDAP_OPT_X_KEEPALIVE_INTERVAL | int
LDAP_OPT_X_TLS_CACERTDIR | string
LDAP_OPT_X_TLS_CACERTFILE | string
LDAP_OPT_X_TLS_CERTFILE | string
LDAP_OPT_X_TLS_CIPHER_SUITE | string
LDAP_OPT_X_TLS_CRLCHECK | integer
LDAP_OPT_X_TLS_CRLFILE | string
LDAP_OPT_X_TLS_DHFILE | string
LDAP_OPT_X_TLS_KEYILE | string
LDAP_OPT_X_TLS_PACKAGE | string
LDAP_OPT_X_TLS_PROTOCOL_MIN | integer
LDAP_OPT_X_TLS_RANDOM_FILE | string
LDAP_OPT_X_TLS_REQUIRE_CERT | integer

retval

This will be set to the option value.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Check protocol version

<?php
// $ds is a valid link identifier for a directory server
if (ldap_get_option($ds, LDAP_OPT_PROTOCOL_VERSION, $version)) {
    echo "Using protocol version $version\n";
} else {
    echo "Unable to determine protocol version\n";
}
?>

Notlar

Bilginize:

This function is only available when using OpenLDAP 2.x.x OR Netscape Directory SDK x.x.

Ayrıca Bakınız

  • ldap_set_option() - Set the value of the given option

ldap_get_entries
ldap_get_values_len
LDAP İşlevleri


Get all binary values from a result entry

ldap_get_option
ldap_get_values
LDAP İşlevleri
PHP Manual

ldap_get_values_len

(PHP 4, PHP 5, PHP 7)

ldap_get_values_len — Get all binary values from a result entry

Açıklama

array ldap_get_values_len ( resource $link_identifier , resource $result_entry_identifier , string $attribute )

Reads all the values of the attribute in the entry in the result.

This function is used exactly like ldap_get_values() except that it handles binary data and not string data.

Değiştirgeler

link_identifier

An LDAP link identifier, returned by ldap_connect().

result_entry_identifier

attribute

Dönen Değerler

Returns an array of values for the attribute on success and FALSE on error. Individual values are accessed by integer index in the array. The first index is 0. The number of values can be found by indexing "count" in the resultant array.

Ayrıca Bakınız

  • ldap_get_values() - Get all values from a result entry

ldap_get_option
ldap_get_values
LDAP İşlevleri


Get all values from a result entry

ldap_get_values_len
ldap_list
LDAP İşlevleri
PHP Manual

ldap_get_values

(PHP 4, PHP 5, PHP 7)

ldap_get_values — Get all values from a result entry

Açıklama

array ldap_get_values ( resource $link_identifier , resource $result_entry_identifier , string $attribute )

Reads all the values of the attribute in the entry in the result.

This call needs a result_entry_identifier, so needs to be preceded by one of the ldap search calls and one of the calls to get an individual entry.

You application will either be hard coded to look for certain attributes (such as "surname" or "mail") or you will have to use the ldap_get_attributes() call to work out what attributes exist for a given entry.

Değiştirgeler

link_identifier

An LDAP link identifier, returned by ldap_connect().

result_entry_identifier

attribute

Dönen Değerler

Returns an array of values for the attribute on success and FALSE on error. The number of values can be found by indexing "count" in the resultant array. Individual values are accessed by integer index in the array. The first index is 0.

LDAP allows more than one entry for an attribute, so it can, for example, store a number of email addresses for one person's directory entry all labeled with the attribute "mail"

    return_value["count"] = number of values for attribute
    return_value[0] = first value of attribute
    return_value[i] = ith value of attribute

Örnekler

Örnek 1 List all values of the "mail" attribute for a directory entry

<?php
// $ds is a valid link identifier for a directory server

// $sr is a valid search result from a prior call to
//     one of the ldap directory search calls

// $entry is a valid entry identifier from a prior call to
//        one of the calls that returns a directory entry

$values = ldap_get_values($ds, $entry, "mail");

echo $values["count"] . " email addresses for this entry.<br />";

for ($i=0; $i < $values["count"]; $i++) {
    echo $values[$i] . "<br />";
}
?>

Ayrıca Bakınız

  • ldap_get_values_len() - Get all binary values from a result entry

ldap_get_values_len
ldap_list
LDAP İşlevleri


Single-level search

ldap_get_values
ldap_mod_add
LDAP İşlevleri
PHP Manual

ldap_list

(PHP 4, PHP 5, PHP 7)

ldap_list — Single-level search

Açıklama

resource ldap_list ( resource $link_identifier , string $base_dn , string $filter [, array $attributes [, int $attrsonly [, int $sizelimit [, int $timelimit [, int $deref ]]]]] )

Performs the search for a specified filter on the directory with the scope LDAP_SCOPE_ONELEVEL.

LDAP_SCOPE_ONELEVEL means that the search should only return information that is at the level immediately below the base_dn given in the call. (Equivalent to typing "ls" and getting a list of files and folders in the current working directory.)

Değiştirgeler

link_identifier

An LDAP link identifier, returned by ldap_connect().

base_dn

The base DN for the directory.

filter

attributes

An array of the required attributes, e.g. array("mail", "sn", "cn"). Note that the "dn" is always returned irrespective of which attributes types are requested.

Using this parameter is much more efficient than the default action (which is to return all attributes and their associated values). The use of this parameter should therefore be considered good practice.

attrsonly

Should be set to 1 if only attribute types are wanted. If set to 0 both attributes types and attribute values are fetched which is the default behaviour.

sizelimit

Enables you to limit the count of entries fetched. Setting this to 0 means no limit.

Bilginize:

This parameter can NOT override server-side preset sizelimit. You can set it lower though.

Some directory server hosts will be configured to return no more than a preset number of entries. If this occurs, the server will indicate that it has only returned a partial results set. This also occurs if you use this parameter to limit the count of fetched entries.

timelimit

Sets the number of seconds how long is spend on the search. Setting this to 0 means no limit.

Bilginize:

This parameter can NOT override server-side preset timelimit. You can set it lower though.

deref

Specifies how aliases should be handled during the search. It can be one of the following:

  • LDAP_DEREF_NEVER - (default) aliases are never dereferenced.
  • LDAP_DEREF_SEARCHING - aliases should be dereferenced during the search but not when locating the base object of the search.
  • LDAP_DEREF_FINDING - aliases should be dereferenced when locating the base object but not during the search.
  • LDAP_DEREF_ALWAYS - aliases should be dereferenced always.

Dönen Değerler

Returns a search result identifier or FALSE on error.

Sürüm Bilgisi

Sürüm: | Açıklama
4.0.5 | Parallel searches support was added. See ldap_search() for details.

Örnekler

Örnek 1 Produce a list of all organizational units of an organization

<?php
// $ds is a valid link identifier for a directory server

$basedn = "o=My Company, c=US";
$justthese = array("ou");

$sr = ldap_list($ds, $basedn, "ou=*", $justthese);

$info = ldap_get_entries($ds, $sr);

for ($i=0; $i < $info["count"]; $i++) {
    echo $info[$i]["ou"][0];
}
?>

Ayrıca Bakınız

  • ldap_search() - Search LDAP tree

ldap_get_values
ldap_mod_add
LDAP İşlevleri


Add attribute values to current attributes

ldap_list
ldap_mod_del
LDAP İşlevleri
PHP Manual

ldap_mod_add

(PHP 4, PHP 5, PHP 7)

ldap_mod_add — Add attribute values to current attributes

Açıklama

bool ldap_mod_add ( resource $link_identifier , string $dn , array $entry )

Adds one or more attributes to the specified dn. It performs the modification at the attribute level as opposed to the object level. Object-level additions are done by the ldap_add() function.

Değiştirgeler

link_identifier

An LDAP link identifier, returned by ldap_connect().

dn

The distinguished name of an LDAP entity.

entry

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

Bilginize: Bu işlev ikil dosyalarla çalışırken dosya içeriğini değiştirmez.

Ayrıca Bakınız

  • ldap_mod_del() - Delete attribute values from current attributes
  • ldap_mod_replace() - Replace attribute values with new ones

ldap_list
ldap_mod_del
LDAP İşlevleri


Delete attribute values from current attributes

ldap_mod_add
ldap_mod_replace
LDAP İşlevleri
PHP Manual

ldap_mod_del

(PHP 4, PHP 5, PHP 7)

ldap_mod_del — Delete attribute values from current attributes

Açıklama

bool ldap_mod_del ( resource $link_identifier , string $dn , array $entry )

Removes one or more attributes from the specified dn. It performs the modification at the attribute level as opposed to the object level. Object-level deletions are done by the ldap_delete() function.

Değiştirgeler

link_identifier

An LDAP link identifier, returned by ldap_connect().

dn

The distinguished name of an LDAP entity.

entry

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ldap_mod_add() - Add attribute values to current attributes
  • ldap_mod_replace() - Replace attribute values with new ones

ldap_mod_add
ldap_mod_replace
LDAP İşlevleri


Replace attribute values with new ones

ldap_mod_del
ldap_modify_batch
LDAP İşlevleri
PHP Manual

ldap_mod_replace

(PHP 4, PHP 5, PHP 7)

ldap_mod_replace — Replace attribute values with new ones

Açıklama

bool ldap_mod_replace ( resource $link_identifier , string $dn , array $entry )

Replaces one or more attributes from the specified dn. It performs the modification at the attribute level as opposed to the object level. Object-level modifications are done by the ldap_modify() function.

Değiştirgeler

link_identifier

An LDAP link identifier, returned by ldap_connect().

dn

The distinguished name of an LDAP entity.

entry

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

Bilginize: Bu işlev ikil dosyalarla çalışırken dosya içeriğini değiştirmez.

Ayrıca Bakınız

  • ldap_mod_del() - Delete attribute values from current attributes
  • ldap_mod_add() - Add attribute values to current attributes

ldap_mod_del
ldap_modify_batch
LDAP İşlevleri


Batch and execute modifications on an LDAP entry

ldap_mod_replace
ldap_modify
LDAP İşlevleri
PHP Manual

ldap_modify_batch

(PHP 5.4 >= 5.4.26, PHP 5.5 >= 5.5.10, PHP 5.6 >= 5.6.0, PHP 7)

ldap_modify_batch — Batch and execute modifications on an LDAP entry

Açıklama

bool ldap_modify_batch ( resource $link_identifier , string $dn , array $entry )

Modifies an existing entry in the LDAP directory. Allows detailed specification of the modifications to perform.

Değiştirgeler

link_identifier

An LDAP link identifier, returned by ldap_connect().

dn

The distinguished name of an LDAP entity.

entry

An array that specifies the modifications to make. Each entry in this array is an associative array with two or three keys: attrib maps to the name of the attribute to modify, modtype maps to the type of modification to perform, and (depending on the type of modification) values maps to an array of attribute values relevant to the modification.

Possible values for modtype include:

LDAP_MODIFY_BATCH_ADD

Each value specified through values is added (as an additional value) to the attribute named by attrib.

LDAP_MODIFY_BATCH_REMOVE

Each value specified through values is removed from the attribute named by attrib. Any value of the attribute not contained in the values array will remain untouched.

LDAP_MODIFY_BATCH_REMOVE_ALL

All values are removed from the attribute named by attrib. A values entry must not be provided.

LDAP_MODIFY_BATCH_REPLACE

All current values of the attribute named by attrib are replaced with the values specified through values.

Note that any value for attrib must be a string, any value for values must be an array of strings, and any value for modtype must be one of the LDAP_MODIFY_BATCH_* constants listed above.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Add a telephone number to a contact

<?php
$dn = "cn=John Smith,ou=Wizards,dc=example,dc=com";
$modifs = [
    [
        "attrib"  => "telephoneNumber",
        "modtype" => LDAP_MODIFY_BATCH_ADD,
        "values"  => ["+1 555 555 1717"],
    ],
];
ldap_modify_batch($connection, $dn, $modifs);
?>

Örnek 2 Rename a user

<?php
$dn = "cn=John Smith,ou=Wizards,dc=example,dc=com";
$modifs = [
    [
        "attrib"  => "sn",
        "modtype" => LDAP_MODIFY_BATCH_REPLACE,
        "values"  => ["Smith-Jones"],
    ],
    [
        "attrib"  => "givenName",
        "modtype" => LDAP_MODIFY_BATCH_REPLACE,
        "values"  => ["Jack"],
    ],
];
ldap_modify_batch($connection, $dn, $modifs);
ldap_rename($connection, $dn, "cn=Jack Smith-Jones", NULL, TRUE);
?>

Örnek 3 Add two e-mail addresses to a user

<?php
$dn = "cn=Jack Smith-Jones,ou=Wizards,dc=example,dc=com";
$modifs = [
    [
        "attrib"  => "mail",
        "modtype" => LDAP_MODIFY_BATCH_ADD,
        "values"  => [
            "jack.smith@example.com",
            "jack.smith-jones@example.com",
        ],
    ],
];
ldap_modify_batch($connection, $dn, $modifs);
?>

Örnek 4 Change a user's password

<?php
$dn = "cn=Jack Smith-Jones,ou=Wizards,dc=example,dc=com";
$modifs = [
    [
        "attrib"  => "userPassword",
        "modtype" => LDAP_MODIFY_BATCH_REMOVE,
        "values"  => ["Tr0ub4dor&3"],
    ],
    [
        "attrib"  => "userPassword",
        "modtype" => LDAP_MODIFY_BATCH_ADD,
        "values"  => ["correct horse battery staple"],
    ],
];
ldap_modify_batch($connection, $dn, $modifs);
?>

Örnek 5 Change a user's password (Active Directory)

<?php
function adifyPw($pw)
{
    return iconv("UTF-8", "UTF-16LE", '"' . $pw . '"');
}

$dn = "cn=Jack Smith-Jones,ou=Wizards,dc=ad,dc=example,dc=com";
$modifs = [
    [
        "attrib"  => "unicodePwd",
        "modtype" => LDAP_MODIFY_BATCH_REMOVE,
        "values"  => [adifyPw("Tr0ub4dor&3")],
    ],
    [
        "attrib"  => "unicodePwd",
        "modtype" => LDAP_MODIFY_BATCH_ADD,
        "values"  => [adifyPw("correct horse battery staple")],
    ],
];
ldap_modify_batch($connection, $dn, $modifs);

ldap_mod_replace
ldap_modify
LDAP İşlevleri


Modify an LDAP entry

ldap_modify_batch
ldap_next_attribute
LDAP İşlevleri
PHP Manual

ldap_modify

(PHP 4, PHP 5, PHP 7)

ldap_modify — Modify an LDAP entry

Açıklama

bool ldap_modify ( resource $link_identifier , string $dn , array $entry )

Modify the existing entries in the LDAP directory. The structure of the entry is same as in ldap_add().

Değiştirgeler

link_identifier

An LDAP link identifier, returned by ldap_connect().

dn

The distinguished name of an LDAP entity.

entry

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

Bilginize: Bu işlev ikil dosyalarla çalışırken dosya içeriğini değiştirmez.

Ayrıca Bakınız

  • ldap_rename() - Modify the name of an entry

ldap_modify_batch
ldap_next_attribute
LDAP İşlevleri


Get the next attribute in result

ldap_modify
ldap_next_entry
LDAP İşlevleri
PHP Manual

ldap_next_attribute

(PHP 4, PHP 5, PHP 7)

ldap_next_attribute — Get the next attribute in result

Açıklama

string ldap_next_attribute ( resource $link_identifier , resource $result_entry_identifier )

Retrieves the attributes in an entry. The first call to ldap_next_attribute() is made with the result_entry_identifier returned from ldap_first_attribute().

Değiştirgeler

link_identifier

An LDAP link identifier, returned by ldap_connect().

result_entry_identifier

ber_identifier

The internal state of the pointer is maintained by this parameter.

Bilginize:

This parameter is no longer used as this is now handled automatically by PHP. For backwards compatibility PHP will not throw an error if this parameter is passed.

Dönen Değerler

Returns the next attribute in an entry on success and FALSE on error.

Sürüm Bilgisi

Sürüm: | Açıklama
5.2.4 | The ber_identifier was removed. This is now handled automatically by PHP.

Ayrıca Bakınız

  • ldap_get_attributes() - Get attributes from a search result entry

ldap_modify
ldap_next_entry
LDAP İşlevleri


Get next result entry

ldap_next_attribute
ldap_next_reference
LDAP İşlevleri
PHP Manual

ldap_next_entry

(PHP 4, PHP 5, PHP 7)

ldap_next_entry — Get next result entry

Açıklama

resource ldap_next_entry ( resource $link_identifier , resource $result_entry_identifier )

Retrieve the entries stored in the result. Successive calls to the ldap_next_entry() return entries one by one till there are no more entries. The first call to ldap_next_entry() is made after the call to ldap_first_entry() with the result_entry_identifier as returned from the ldap_first_entry().

Değiştirgeler

link_identifier

An LDAP link identifier, returned by ldap_connect().

result_entry_identifier

Dönen Değerler

Returns entry identifier for the next entry in the result whose entries are being read starting with ldap_first_entry(). If there are no more entries in the result then it returns FALSE.

Ayrıca Bakınız

  • ldap_get_entries() - Get all result entries

ldap_next_attribute
ldap_next_reference
LDAP İşlevleri


Get next reference

ldap_next_entry
ldap_parse_reference
LDAP İşlevleri
PHP Manual

ldap_next_reference

(PHP 4 >= 4.0.5, PHP 5, PHP 7)

ldap_next_reference — Get next reference

Açıklama

resource ldap_next_reference ( resource $link , resource $entry )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ldap_next_entry
ldap_parse_reference
LDAP İşlevleri


Extract information from reference entry

ldap_next_reference
ldap_parse_result
LDAP İşlevleri
PHP Manual

ldap_parse_reference

(PHP 4 >= 4.0.5, PHP 5, PHP 7)

ldap_parse_reference — Extract information from reference entry

Açıklama

bool ldap_parse_reference ( resource $link , resource $entry , array &$referrals )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ldap_next_reference
ldap_parse_result
LDAP İşlevleri


Extract information from result

ldap_parse_reference
ldap_read
LDAP İşlevleri
PHP Manual

ldap_parse_result

(PHP 4 >= 4.0.5, PHP 5, PHP 7)

ldap_parse_result — Extract information from result

Açıklama

bool ldap_parse_result ( resource $link , resource $result , int &$errcode [, string &$matcheddn [, string &$errmsg [, array &$referrals ]]] )

Parses an LDAP search result.

Değiştirgeler

link

An LDAP link identifier, returned by ldap_connect().

result_identifier

An LDAP result resource, returned by ldap_list() or ldap_search().

errcode

A reference to a variable that will be set to the LDAP error code in the result, or 0 if no error occurred.

matcheddn

A reference to a variable that will be set to a matched DN if one was recognised within the request, otherwise it will be set to NULL.

errmsg

A reference to a variable that will be set to the LDAP error message in the result, or an empty string if no error occurred.

referrals

A reference to a variable that will be set to an array set to all of the referral strings in the result, or an empty array if no referrals were returned.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 ldap_parse_result() example

<?php
$result = ldap_search($link, "cn=userref,dc=my-domain,dc=com", "(cn=user*)");
$errcode = $dn = $errmsg = $refs =  null;
if (ldap_parse_result($link, $result, $errcode, $dn, $errmsg, $refs)) {
    // do something with $errcode, $dn, $errmsg and $refs
}
?>

ldap_parse_reference
ldap_read
LDAP İşlevleri


Read an entry

ldap_parse_result
ldap_rename
LDAP İşlevleri
PHP Manual

ldap_read

(PHP 4, PHP 5, PHP 7)

ldap_read — Read an entry

Açıklama

resource ldap_read ( resource $link_identifier , string $base_dn , string $filter [, array $attributes [, int $attrsonly [, int $sizelimit [, int $timelimit [, int $deref ]]]]] )

Performs the search for a specified filter on the directory with the scope LDAP_SCOPE_BASE. So it is equivalent to reading an entry from the directory.

Değiştirgeler

link_identifier

An LDAP link identifier, returned by ldap_connect().

base_dn

The base DN for the directory.

filter

An empty filter is not allowed. If you want to retrieve absolutely all information for this entry, use a filter of objectClass=*. If you know which entry types are used on the directory server, you might use an appropriate filter such as objectClass=inetOrgPerson.

attributes

An array of the required attributes, e.g. array("mail", "sn", "cn"). Note that the "dn" is always returned irrespective of which attributes types are requested.

Using this parameter is much more efficient than the default action (which is to return all attributes and their associated values). The use of this parameter should therefore be considered good practice.

attrsonly

Should be set to 1 if only attribute types are wanted. If set to 0 both attributes types and attribute values are fetched which is the default behaviour.

sizelimit

Enables you to limit the count of entries fetched. Setting this to 0 means no limit.

Bilginize:

This parameter can NOT override server-side preset sizelimit. You can set it lower though.

Some directory server hosts will be configured to return no more than a preset number of entries. If this occurs, the server will indicate that it has only returned a partial results set. This also occurs if you use this parameter to limit the count of fetched entries.

timelimit

Sets the number of seconds how long is spend on the search. Setting this to 0 means no limit.

Bilginize:

This parameter can NOT override server-side preset timelimit. You can set it lower though.

deref

Specifies how aliases should be handled during the search. It can be one of the following:

  • LDAP_DEREF_NEVER - (default) aliases are never dereferenced.
  • LDAP_DEREF_SEARCHING - aliases should be dereferenced during the search but not when locating the base object of the search.
  • LDAP_DEREF_FINDING - aliases should be dereferenced when locating the base object but not during the search.
  • LDAP_DEREF_ALWAYS - aliases should be dereferenced always.

Dönen Değerler

Returns a search result identifier or FALSE on error.

Sürüm Bilgisi

Sürüm: | Açıklama
4.0.5 | Parallel searches support was added. See ldap_search() for details.

ldap_parse_result
ldap_rename
LDAP İşlevleri


Modify the name of an entry

ldap_read
ldap_sasl_bind
LDAP İşlevleri
PHP Manual

ldap_rename

(PHP 4 >= 4.0.5, PHP 5, PHP 7)

ldap_rename — Modify the name of an entry

Açıklama

bool ldap_rename ( resource $link_identifier , string $dn , string $newrdn , string $newparent , bool $deleteoldrdn )

The entry specified by dn is renamed/moved.

Değiştirgeler

link_identifier

An LDAP link identifier, returned by ldap_connect().

dn

The distinguished name of an LDAP entity.

newrdn

The new RDN.

newparent

The new parent/superior entry.

deleteoldrdn

If TRUE the old RDN value(s) is removed, else the old RDN value(s) is retained as non-distinguished values of the entry.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

Bilginize:

This function currently only works with LDAPv3. You may have to use ldap_set_option() prior to binding to use LDAPv3. This function is only available when using OpenLDAP 2.x.x OR Netscape Directory SDK x.x.

Ayrıca Bakınız

  • ldap_modify() - Modify an LDAP entry

ldap_read
ldap_sasl_bind
LDAP İşlevleri


Bind to LDAP directory using SASL

ldap_rename
ldap_search
LDAP İşlevleri
PHP Manual

ldap_sasl_bind

(PHP 5, PHP 7)

ldap_sasl_bind — Bind to LDAP directory using SASL

Açıklama

bool ldap_sasl_bind ( resource $link [, string $binddn = NULL [, string $password = NULL [, string $sasl_mech = NULL [, string $sasl_realm = NULL [, string $sasl_authc_id = NULL [, string $sasl_authz_id = NULL [, string $props = NULL ]]]]]]] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

Bilginize: Requirement
ldap_sasl_bind() requires SASL support (sasl.h). Be sure --with-ldap-sasl is used when configuring PHP otherwise this function will be undefined.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.3 | Support on Windows was added.

ldap_rename
ldap_search
LDAP İşlevleri


Search LDAP tree

ldap_sasl_bind
ldap_set_option
LDAP İşlevleri
PHP Manual

ldap_search

(PHP 4, PHP 5, PHP 7)

ldap_search — Search LDAP tree

Açıklama

resource ldap_search ( resource $link_identifier , string $base_dn , string $filter [, array $attributes [, int $attrsonly [, int $sizelimit [, int $timelimit [, int $deref ]]]]] )

Performs the search for a specified filter on the directory with the scope of LDAP_SCOPE_SUBTREE. This is equivalent to searching the entire directory.

From 4.0.5 on it's also possible to do parallel searches. To do this you use an array of link identifiers, rather than a single identifier, as the first argument. If you don't want the same base DN and the same filter for all the searches, you can also use an array of base DNs and/or an array of filters. Those arrays must be of the same size as the link identifier array since the first entries of the arrays are used for one search, the second entries are used for another, and so on. When doing parallel searches an array of search result identifiers is returned, except in case of error, then the entry corresponding to the search will be FALSE. This is very much like the value normally returned, except that a result identifier is always returned when a search was made. There are some rare cases where the normal search returns FALSE while the parallel search returns an identifier.

Değiştirgeler

link_identifier

An LDAP link identifier, returned by ldap_connect().

base_dn

The base DN for the directory.

filter

The search filter can be simple or advanced, using boolean operators in the format described in the LDAP documentation (see the » Netscape Directory SDK or » RFC4515 for full information on filters).

attributes

An array of the required attributes, e.g. array("mail", "sn", "cn"). Note that the "dn" is always returned irrespective of which attributes types are requested.

Using this parameter is much more efficient than the default action (which is to return all attributes and their associated values). The use of this parameter should therefore be considered good practice.

attrsonly

Should be set to 1 if only attribute types are wanted. If set to 0 both attributes types and attribute values are fetched which is the default behaviour.

sizelimit

Enables you to limit the count of entries fetched. Setting this to 0 means no limit.

Bilginize:

This parameter can NOT override server-side preset sizelimit. You can set it lower though.

Some directory server hosts will be configured to return no more than a preset number of entries. If this occurs, the server will indicate that it has only returned a partial results set. This also occurs if you use this parameter to limit the count of fetched entries.

timelimit

Sets the number of seconds how long is spend on the search. Setting this to 0 means no limit.

Bilginize:

This parameter can NOT override server-side preset timelimit. You can set it lower though.

deref

Specifies how aliases should be handled during the search. It can be one of the following:

  • LDAP_DEREF_NEVER - (default) aliases are never dereferenced.
  • LDAP_DEREF_SEARCHING - aliases should be dereferenced during the search but not when locating the base object of the search.
  • LDAP_DEREF_FINDING - aliases should be dereferenced when locating the base object but not during the search.
  • LDAP_DEREF_ALWAYS - aliases should be dereferenced always.

Dönen Değerler

Returns a search result identifier or FALSE on error.

Örnekler

The example below retrieves the organizational unit, surname, given name and email address for all people in "My Company" where the surname or given name contains the substring $person. This example uses a boolean filter to tell the server to look for information in more than one attribute.

Örnek 1 LDAP search

<?php
// $ds is a valid link identifier for a directory server

// $person is all or part of a person's name, eg "Jo"

$dn = "o=My Company, c=US";
$filter="(|(sn=$person*)(givenname=$person*))";
$justthese = array("ou", "sn", "givenname", "mail");

$sr=ldap_search($ds, $dn, $filter, $justthese);

$info = ldap_get_entries($ds, $sr);

echo $info["count"]." entries returned\n";
?>

ldap_sasl_bind
ldap_set_option
LDAP İşlevleri


Set the value of the given option

ldap_search
ldap_set_rebind_proc
LDAP İşlevleri
PHP Manual

ldap_set_option

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

ldap_set_option — Set the value of the given option

Açıklama

bool ldap_set_option ( resource $link_identifier , int $option , mixed $newval )

Sets the value of the specified option to be newval.

Değiştirgeler

link_identifier

An LDAP link identifier, returned by ldap_connect().

option

The parameter option can be one of:

Option | Type | Available since
LDAP_OPT_DEREF | integer
LDAP_OPT_SIZELIMIT | integer
LDAP_OPT_TIMELIMIT | integer
LDAP_OPT_NETWORK_TIMEOUT | integer | PHP 5.3.0
LDAP_OPT_PROTOCOL_VERSION | integer
LDAP_OPT_ERROR_NUMBER | integer
LDAP_OPT_REFERRALS | bool
LDAP_OPT_RESTART | bool
LDAP_OPT_HOST_NAME | string
LDAP_OPT_ERROR_STRING | string
LDAP_OPT_DIAGNOSTIC_MESSAGE | string
LDAP_OPT_MATCHED_DN | string
LDAP_OPT_SERVER_CONTROLS | array
LDAP_OPT_CLIENT_CONTROLS | array
LDAP_OPT_X_KEEPALIVE_IDLE | int
LDAP_OPT_X_KEEPALIVE_PROBES | int
LDAP_OPT_X_KEEPALIVE_INTERVAL | int
LDAP_OPT_X_TLS_CACERTDIR | string
LDAP_OPT_X_TLS_CACERTFILE | string
LDAP_OPT_X_TLS_CERTFILE | string
LDAP_OPT_X_TLS_CIPHER_SUITE | string
LDAP_OPT_X_TLS_CRLCHECK | integer
LDAP_OPT_X_TLS_CRLFILE | string
LDAP_OPT_X_TLS_DHFILE | string
LDAP_OPT_X_TLS_KEYILE | string
LDAP_OPT_X_TLS_PROTOCOL_MIN | integer
LDAP_OPT_X_TLS_RANDOM_FILE | string
LDAP_OPT_X_TLS_REQUIRE_CERT | integer | PHP 7.1.0

LDAP_OPT_SERVER_CONTROLS and LDAP_OPT_CLIENT_CONTROLS require a list of controls, this means that the value must be an array of controls. A control consists of an oid identifying the control, an optional value, and an optional flag for criticality. In PHP a control is given by an array containing an element with the key oid and string value, and two optional elements. The optional elements are key value with string value and key iscritical with boolean value. iscritical defaults to FALSE if not supplied. See » draft-ietf-ldapext-ldap-c-api-xx.txt for details. See also the second example below.

newval

The new value for the specified option.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Set protocol version

<?php
// $ds is a valid link identifier for a directory server
if (ldap_set_option($ds, LDAP_OPT_PROTOCOL_VERSION, 3)) {
    echo "Using LDAPv3";
} else {
    echo "Failed to set protocol version to 3";
}
?>

Örnek 2 Set server controls

<?php
// $ds is a valid link identifier for a directory server
// control with no value
$ctrl1 = array("oid" => "1.2.752.58.10.1", "iscritical" => true);
// iscritical defaults to FALSE
$ctrl2 = array("oid" => "1.2.752.58.1.10", "value" => "magic");
// try to set both controls
if (!ldap_set_option($ds, LDAP_OPT_SERVER_CONTROLS, array($ctrl1, $ctrl2))) {
    echo "Failed to set server controls";
}
?>

Notlar

Bilginize:

This function is only available when using OpenLDAP 2.x.x OR Netscape Directory SDK x.x.

Ayrıca Bakınız

  • ldap_get_option() - Get the current value for given option

ldap_search
ldap_set_rebind_proc
LDAP İşlevleri


Set a callback function to do re-binds on referral chasing

ldap_set_option
ldap_sort
LDAP İşlevleri
PHP Manual

ldap_set_rebind_proc

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

ldap_set_rebind_proc — Set a callback function to do re-binds on referral chasing

Açıklama

bool ldap_set_rebind_proc ( resource $link , callable $callback )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ldap_set_option
ldap_sort
LDAP İşlevleri


Sort LDAP result entries on the client side

ldap_set_rebind_proc
ldap_start_tls
LDAP İşlevleri
PHP Manual

ldap_sort

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

ldap_sort — Sort LDAP result entries on the client side

Açıklama

bool ldap_sort ( resource $link , resource $result , string $sortfilter )

Sort the result of a LDAP search, returned by ldap_search().

As this function sorts the returned values on the client side it is possible that you might not get the expected results in case you reach the sizelimit either of the server or defined within ldap_search().

Uyarı

Bu işlevin kullanımı PHP 7.0.0 itibariyle ÖNERİLMEMEKTEDİR. Bu işleve kesinlikle güvenmemelisiniz.

Değiştirgeler

link

An LDAP link identifier, returned by ldap_connect().

result

An search result identifier, returned by ldap_search().

sortfilter

The attribute to use as a key in the sort.

Örnekler

Sorting the result of a search.

Örnek 1 LDAP sort

<?php
     // $ds is a valid link identifier (see ldap_connect)

     $dn        = 'ou=example,dc=org';
     $filter    = '(|(sn=Doe*)(givenname=John*))';
     $justthese = array('ou', 'sn', 'givenname', 'mail');

     $sr = ldap_search($ds, $dn, $filter, $justthese);

     // Sort
     ldap_sort($ds, $sr, 'sn');

     // Retrieving the data
     $info = ldap_get_entries($ds, $sr);

ldap_set_rebind_proc
ldap_start_tls
LDAP İşlevleri


Start TLS

ldap_sort
ldap_t61_to_8859
LDAP İşlevleri
PHP Manual

ldap_start_tls

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

ldap_start_tls — Start TLS

Açıklama

bool ldap_start_tls ( resource $link )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ldap_sort
ldap_t61_to_8859
LDAP İşlevleri


Translate t61 characters to 8859 characters

ldap_start_tls
ldap_unbind
LDAP İşlevleri
PHP Manual

ldap_t61_to_8859

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

ldap_t61_to_8859 — Translate t61 characters to 8859 characters

Açıklama

string ldap_t61_to_8859 ( string $value )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

ldap_start_tls
ldap_unbind
LDAP İşlevleri


Unbind from LDAP directory

ldap_t61_to_8859
Memcache
LDAP İşlevleri
PHP Manual

ldap_unbind

(PHP 4, PHP 5, PHP 7)

ldap_unbind — Unbind from LDAP directory

Açıklama

bool ldap_unbind ( resource $link_identifier )

Unbinds from the LDAP directory.

Değiştirgeler

link_identifier

An LDAP link identifier, returned by ldap_connect().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ldap_bind() - Bind to LDAP directory

ldap_t61_to_8859
Memcache
LDAP İşlevleri


Memcache

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
    • Basic usage
  • Memcache — The Memcache class
    • Memcache::add — Add an item to the server
    • Memcache::addServer — Add a memcached server to connection pool
    • Memcache::close — Close memcached server connection
    • Memcache::connect — Open memcached server connection
    • Memcache::decrement — Decrement item's value
    • Memcache::delete — Delete item from the server
    • Memcache::flush — Flush all existing items at the server
    • Memcache::get — Retrieve item from the server
    • Memcache::getExtendedStats — Get statistics from all servers in pool
    • Memcache::getServerStatus — Returns server status
    • Memcache::getStats — Get statistics of the server
    • Memcache::getVersion — Return version of the server
    • Memcache::increment — Increment item's value
    • Memcache::pconnect — Open memcached server persistent connection
    • Memcache::replace — Replace value of the existing item
    • Memcache::set — Store data at the server
    • Memcache::setCompressThreshold — Enable automatic compression of large values
    • Memcache::setServerParams — Changes server parameters and status at runtime
  • Memcache İşlevleri
    • memcache_debug — Turn debug output on/off
ldap_unbind
Giriş
Diğer Hizmetler


Giriş

Memcache module provides handy procedural and object oriented interface to memcached, highly effective caching daemon, which was especially designed to decrease database load in dynamic web applications.

The Memcache module also provides a session handler (memcache).

More information about memcached can be found at » http://www.memcached.org/.

Memcache
Yapılandırma/Kurulum
Memcache


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Memcache


Gereksinimler

This module uses functions of » zlib to support on-the-fly data compression. Zlib is required to install this module.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu » PECL eklentisi PHP ile gelmez. Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/memcache.

Bilginize:

It's possible to disable memcache session handler support. The 'pecl install' option prompts for this (default is enabled) however when compiling statically into PHP the --disable-memcache-session configure option may be used.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Memcache Configuration Options
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
memcache.allow_failover | "1" | PHP_INI_ALL | Available since memcache 2.0.2.
memcache.max_failover_attempts | "20" | PHP_INI_ALL | Available since memcache 2.1.0.
memcache.chunk_size | "8192" | PHP_INI_ALL | Available since memcache 2.0.2.
memcache.default_port | "11211" | PHP_INI_ALL | Available since memcache 2.0.2.
memcache.hash_strategy | "standard" | PHP_INI_ALL | Available since memcache 2.2.0.
memcache.hash_function | "crc32" | PHP_INI_ALL | Available since memcache 2.2.0.
session.save_handler | "files" | PHP_INI_ALL | Supported since memcache 2.1.2
session.save_path | "" | PHP_INI_ALL | Supported since memcache 2.1.2
memcache.protocol | ascii | >PHP_INI_ALL | Supported since memcache 3.0.0
memcache.redundancy | 1 | >PHP_INI_ALL | Supported since memcache 3.0.0
memcache.session_redundancy | 2 | >PHP_INI_ALL | Supported since memcache 3.0.0
memcache.compress_threshold | 20000 | >PHP_INI_ALL | Supported since memcache 3.0.3
memcache.lock_timeout | 15 | >PHP_INI_ALL | Supported since memcache 3.0.4
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

memcache.allow_failover boolean

Whether to transparently failover to other servers on errors.

memcache.max_failover_attempts integer

Defines how many servers to try when setting and getting data. Used only in conjunction with memcache.allow_failover.

memcache.chunk_size integer

Data will be transferred in chunks of this size, setting the value lower requires more network writes. Try increasing this value to 32768 if noticing otherwise inexplicable slowdowns.

memcache.default_port string

The default TCP port number to use when connecting to the memcached server if no other port is specified.

memcache.hash_strategy string

Controls which strategy to use when mapping keys to servers. Set this value to consistent to enable consistent hashing which allows servers to be added or removed from the pool without causing keys to be remapped. Setting this value to standard results in the old strategy being used.

memcache.hash_function string

Controls which hash function to apply when mapping keys to servers, crc32 uses the standard CRC32 hash while fnv uses FNV-1a.

session.save_handler string

Use memcache as a session handler by setting this value to memcache.

session.save_path string

Defines a comma separated of server urls to use for session storage, for example "tcp://host1:11211, tcp://host2:11211".

Each url may contain parameters which are applied to that server, they are the same as for the Memcache::addServer() method. For example "tcp://host1:11211?persistent=1&weight=1&timeout=1&retry_interval=15"

memcache.protocol string

memcache.redundancy integer

memcache.session_redundancy integer

memcache.compress_threshold integer

memcache.lock_timeout integer

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Özkaynak Türleri

There is only one resource type used in memcache module - it's the link identifier for a cache server connection.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Memcache Constants
Name | Description
MEMCACHE_COMPRESSED (integer) | Used to turn on-the-fly data compression on with Memcache::set(), Memcache::add() ve Memcache::replace().
MEMCACHE_HAVE_SESSION (integer) | 1 if this Memcache session handler is available, 0 otherwise.
MEMCACHE_USER1 (integer) | Used to turn user-defined application flag on with Memcache::set(), Memcache::add() ve Memcache::replace().
MEMCACHE_USER2 (integer) | Used to turn user-defined application flag on with Memcache::set(), Memcache::add() ve Memcache::replace().
MEMCACHE_USER3 (integer) | Used to turn user-defined application flag on with Memcache::set(), Memcache::add() ve Memcache::replace().
MEMCACHE_USER4 (integer) | Used to turn user-defined application flag on with Memcache::set(), Memcache::add() ve Memcache::replace().
Özkaynak Türleri
Örnekler
Memcache


Örnekler

İçindekiler

  • Basic usage
Öntanımlı Sabitler
Basic usage
Memcache


Basic usage

Örnek 1 memcache extension overview example

In this example, an object is being saved in the cache and then retrieved back. Object and other non-scalar types are serialized before saving, so it's impossible to store resources (i.e. connection identifiers and others) in the cache.

<?php

$memcache = new Memcache;
$memcache->connect('localhost', 11211) or die ("Could not connect");

$version = $memcache->getVersion();
echo "Server's version: ".$version."<br/>\n";

$tmp_object = new stdClass;
$tmp_object->str_attr = 'test';
$tmp_object->int_attr = 123;

$memcache->set('key', $tmp_object, false, 10) or die ("Failed to save data at the server");
echo "Store data in the cache (data will expire in 10 seconds)<br/>\n";

$get_result = $memcache->get('key');
echo "Data from the cache:<br/>\n";

var_dump($get_result);

?>

Örnek 2 Using memcache session handler

<?php

$session_save_path = "tcp://$host:$port?persistent=1&weight=2&timeout=2&retry_interval=10,  ,tcp://$host:$port  ";
ini_set('session.save_handler', 'memcache');
ini_set('session.save_path', $session_save_path);

?>

Örnekler
Memcache
Örnekler


The Memcache class

(PECL memcache >= 0.2.0)

Giriş

Represents a connection to a set of memcache servers.

Sınıf Sözdizimi

Memcache {
bool add ( string $key , mixed $var [, int $flag [, int $expire ]] )
bool addServer ( string $host [, int $port = 11211 [, bool $persistent [, int $weight [, int $timeout [, int $retry_interval [, bool $status [, callable $failure_callback [, int $timeoutms ]]]]]]]] )
bool close ( void )
bool connect ( string $host [, int $port [, int $timeout ]] )
int decrement ( string $key [, int $value = 1 ] )
bool delete ( string $key [, int $timeout = 0 ] )
bool flush ( void )
string get ( string $key [, int &$flags ] )
array getExtendedStats ([ string $type [, int $slabid [, int $limit = 100 ]]] )
int getServerStatus ( string $host [, int $port = 11211 ] )
array getStats ([ string $type [, int $slabid [, int $limit = 100 ]]] )
string getVersion ( void )
int increment ( string $key [, int $value = 1 ] )
mixed pconnect ( string $host [, int $port [, int $timeout ]] )
bool replace ( string $key , mixed $var [, int $flag [, int $expire ]] )
bool set ( string $key , mixed $var [, int $flag [, int $expire ]] )
bool setCompressThreshold ( int $threshold [, float $min_savings ] )
bool setServerParams ( string $host [, int $port = 11211 [, int $timeout [, int $retry_interval = false [, bool $status [, callable $failure_callback ]]]]] )
}

İçindekiler

  • Memcache::add — Add an item to the server
  • Memcache::addServer — Add a memcached server to connection pool
  • Memcache::close — Close memcached server connection
  • Memcache::connect — Open memcached server connection
  • Memcache::decrement — Decrement item's value
  • Memcache::delete — Delete item from the server
  • Memcache::flush — Flush all existing items at the server
  • Memcache::get — Retrieve item from the server
  • Memcache::getExtendedStats — Get statistics from all servers in pool
  • Memcache::getServerStatus — Returns server status
  • Memcache::getStats — Get statistics of the server
  • Memcache::getVersion — Return version of the server
  • Memcache::increment — Increment item's value
  • Memcache::pconnect — Open memcached server persistent connection
  • Memcache::replace — Replace value of the existing item
  • Memcache::set — Store data at the server
  • Memcache::setCompressThreshold — Enable automatic compression of large values
  • Memcache::setServerParams — Changes server parameters and status at runtime
Basic usage
Memcache::add
Memcache


Add an item to the server

Memcache
Memcache::addServer
Memcache
PHP Manual

Memcache::add

(PECL memcache >= 0.2.0)

Memcache::add — Add an item to the server

Açıklama

bool Memcache::add ( string $key , mixed $var [, int $flag [, int $expire ]] )

Memcache::add() stores variable var with key only if such key doesn't exist at the server yet. Also you can use memcache_add() function.

Değiştirgeler

key

The key that will be associated with the item.

var

The variable to store. Strings and integers are stored as is, other types are stored serialized.

flag

Use MEMCACHE_COMPRESSED to store the item compressed (uses zlib).

expire

Expiration time of the item. If it's equal to zero, the item will never expire. You can also use Unix timestamp or a number of seconds starting from current time, but in the latter case the number of seconds may not exceed 2592000 (30 days).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. Returns FALSE if such key already exist. For the rest Memcache::add() behaves similarly to Memcache::set().

Örnekler

Örnek 1 Memcache::add() example

<?php

$memcache_obj = memcache_connect("localhost", 11211);

/* procedural API */
memcache_add($memcache_obj, 'var_key', 'test variable', false, 30);

/* OO API */
$memcache_obj->add('var_key', 'test variable', false, 30);

?>

Ayrıca Bakınız

  • Memcache::set() - Store data at the server
  • Memcache::replace() - Replace value of the existing item

Memcache
Memcache::addServer
Memcache


Add a memcached server to connection pool

Memcache::add
Memcache::close
Memcache
PHP Manual

Memcache::addServer

(PECL memcache >= 2.0.0)

Memcache::addServer — Add a memcached server to connection pool

Açıklama

bool Memcache::addServer ( string $host [, int $port = 11211 [, bool $persistent [, int $weight [, int $timeout [, int $retry_interval [, bool $status [, callable $failure_callback [, int $timeoutms ]]]]]]]] )

Memcache::addServer() adds a server to the connection pool. You can also use the memcache_add_server() function.

When using this method (as opposed to Memcache::connect() and Memcache::pconnect()) the network connection is not established until actually needed. Thus there is no overhead in adding a large number of servers to the pool, even though they might not all be used.

Failover may occur at any stage in any of the methods, as long as other servers are available the request the user won't notice. Any kind of socket or Memcached server level errors (except out-of-memory) may trigger the failover. Normal client errors such as adding an existing key will not trigger a failover.

Bilginize:

This function has been added to Memcache version 2.0.0.

Değiştirgeler

host

Point to the host where memcached is listening for connections. This parameter may also specify other transports like unix:///path/to/memcached.sock to use UNIX domain sockets, in this case port must also be set to 0.

port

Point to the port where memcached is listening for connections. Set this parameter to 0 when using UNIX domain sockets.

Please note: port defaults to memcache.default_port if not specified. For this reason it is wise to specify the port explicitly in this method call.

persistent

Controls the use of a persistent connection. Default to TRUE.

weight

Number of buckets to create for this server which in turn control its probability of it being selected. The probability is relative to the total weight of all servers.

timeout

Value in seconds which will be used for connecting to the daemon. Think twice before changing the default value of 1 second - you can lose all the advantages of caching if your connection is too slow.

retry_interval

Controls how often a failed server will be retried, the default value is 15 seconds. Setting this parameter to -1 disables automatic retry. Neither this nor the persistent parameter has any effect when the extension is loaded dynamically via dl().

Each failed connection struct has its own timeout and before it has expired the struct will be skipped when selecting backends to serve a request. Once expired the connection will be successfully reconnected or marked as failed for another retry_interval seconds. The typical effect is that each web server child will retry the connection about every retry_interval seconds when serving a page.

status

Controls if the server should be flagged as online. Setting this parameter to FALSE and retry_interval to -1 allows a failed server to be kept in the pool so as not to affect the key distribution algorithm. Requests for this server will then failover or fail immediately depending on the memcache.allow_failover setting. Default to TRUE, meaning the server should be considered online.

failure_callback

Allows the user to specify a callback function to run upon encountering an error. The callback is run before failover is attempted. The function takes two parameters, the hostname and port of the failed server.

timeoutms

Notlar

Uyarı

When the port is unspecified, this method defaults to the value set of the PHP ini directive memcache.default_port If this value was changed elsewhere in your application it might lead to unexpected results: for this reason it is wise to always specify the port explicitly in this method call.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Memcache::addServer() example

<?php

/* OO API */

$memcache = new Memcache;
$memcache->addServer('memcache_host', 11211);
$memcache->addServer('memcache_host2', 11211);

/* procedural API */

$memcache_obj = memcache_connect('memcache_host', 11211);
memcache_add_server($memcache_obj, 'memcache_host2', 11211);

?>

Ayrıca Bakınız

  • Memcache::connect() - Open memcached server connection
  • Memcache::pconnect() - Open memcached server persistent connection
  • Memcache::close() - Close memcached server connection
  • Memcache::setServerParams() - Changes server parameters and status at runtime
  • Memcache::getServerStatus() - Returns server status

Memcache::add
Memcache::close
Memcache


Close memcached server connection

Memcache::addServer
Memcache::connect
Memcache
PHP Manual

Memcache::close

(PECL memcache >= 0.4.0)

Memcache::close — Close memcached server connection

Açıklama

bool Memcache::close ( void )

Memcache::close() closes connection to memcached server. This function doesn't close persistent connections, which are closed only during web-server shutdown/restart. Also you can use memcache_close() function.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Memcache::close() example

<?php

/* procedural API */
$memcache_obj = memcache_connect('memcache_host', 11211);
/*
do something here ..
*/
memcache_close($memcache_obj);

/* OO API */
$memcache_obj = new Memcache;
$memcache_obj->connect('memcache_host', 11211);
/*
do something here ..
*/
$memcache_obj->close();

?>

Ayrıca Bakınız

  • Memcache::connect() - Open memcached server connection
  • Memcache::pconnect() - Open memcached server persistent connection

Memcache::addServer
Memcache::connect
Memcache


Open memcached server connection

Memcache::close
Memcache::decrement
Memcache
PHP Manual

Memcache::connect

(PECL memcache >= 0.2.0)

Memcache::connect — Open memcached server connection

Açıklama

bool Memcache::connect ( string $host [, int $port [, int $timeout ]] )

Memcache::connect() establishes a connection to the memcached server. The connection, which was opened using Memcache::connect() will be automatically closed at the end of script execution. Also you can close it with Memcache::close(). Also you can use memcache_connect() function.

Değiştirgeler

host

Point to the host where memcached is listening for connections. This parameter may also specify other transports like unix:///path/to/memcached.sock to use UNIX domain sockets, in this case port must also be set to 0.

port

Point to the port where memcached is listening for connections. Set this parameter to 0 when using UNIX domain sockets.

Please note: port defaults to memcache.default_port if not specified. For this reason it is wise to specify the port explicitly in this method call.

timeout

Value in seconds which will be used for connecting to the daemon. Think twice before changing the default value of 1 second - you can lose all the advantages of caching if your connection is too slow.

Notlar

Uyarı

When the port is unspecified, this method defaults to the value set of the PHP ini directive memcache.default_port If this value was changed elsewhere in your application it might lead to unexpected results: for this reason it is wise to always specify the port explicitly in this method call.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Memcache::connect() example

<?php

/* procedural API */

$memcache_obj = memcache_connect('memcache_host', 11211);

/* OO API */

$memcache = new Memcache;
$memcache->connect('memcache_host', 11211);

?>

Ayrıca Bakınız

  • Memcache::pconnect() - Open memcached server persistent connection
  • Memcache::close() - Close memcached server connection

Memcache::close
Memcache::decrement
Memcache


Decrement item's value

Memcache::connect
Memcache::delete
Memcache
PHP Manual

Memcache::decrement

(PECL memcache >= 0.2.0)

Memcache::decrement — Decrement item's value

Açıklama

int Memcache::decrement ( string $key [, int $value = 1 ] )

Memcache::decrement() decrements value of the item by value. Similarly to Memcache::increment(), current value of the item is being converted to numerical and after that value is subtracted.

Bilginize:

New item's value will not be less than zero.

Bilginize:

Do not use Memcache::decrement() with item, which was stored compressed, because consequent call to Memcache::get() will fail.

Memcache::decrement() does not create an item if it didn't exist. Also you can use memcache_decrement() function.

Değiştirgeler

key

Key of the item do decrement.

value

Decrement the item by value.

Dönen Değerler

Returns item's new value on success başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Memcache::decrement() example

<?php

/* procedural API */
$memcache_obj = memcache_connect('memcache_host', 11211);
/* decrement item by 2 */
$new_value = memcache_decrement($memcache_obj, 'test_item', 2);

/* OO API */
$memcache_obj = new Memcache;
$memcache_obj->connect('memcache_host', 11211);
/* decrement item by 3 */
$new_value = $memcache_obj->decrement('test_item', 3);
?>

Ayrıca Bakınız

  • Memcache::increment() - Increment item's value
  • Memcache::replace() - Replace value of the existing item

Memcache::connect
Memcache::delete
Memcache


Delete item from the server

Memcache::decrement
Memcache::flush
Memcache
PHP Manual

Memcache::delete

(PECL memcache >= 0.2.0)

Memcache::delete — Delete item from the server

Açıklama

bool Memcache::delete ( string $key [, int $timeout = 0 ] )

Memcache::delete() deletes an item with the key.

Değiştirgeler

key

The key associated with the item to delete.

timeout

This deprecated parameter is not supported, and defaults to 0 seconds. Do not use this parameter.

Sürüm Bilgisi

Sürüm: | Açıklama
Unknown | It's not recommended to use the timeout parameter. The behavior differs between memcached versions, but setting to 0 is safe. Other values for this deprecated feature may cause the memcache delete to fail.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Memcache::delete() example

<?php

/* procedural API */
$memcache_obj = memcache_connect('memcache_host', 11211);

/* item will be deleted by the server */
memcache_delete($memcache_obj, 'key_to_delete');

/* OO API */
$memcache_obj = new Memcache;
$memcache_obj->connect('memcache_host', 11211);

$memcache_obj->delete('key_to_delete');

?>

Ayrıca Bakınız

  • Memcache::set() - Store data at the server
  • Memcache::replace() - Replace value of the existing item

Memcache::decrement
Memcache::flush
Memcache


Flush all existing items at the server

Memcache::delete
Memcache::get
Memcache
PHP Manual

Memcache::flush

(PECL memcache >= 1.0.0)

Memcache::flush — Flush all existing items at the server

Açıklama

bool Memcache::flush ( void )

Memcache::flush() immediately invalidates all existing items. Memcache::flush() doesn't actually free any resources, it only marks all the items as expired, so occupied memory will be overwritten by new items. Also you can use memcache_flush() function.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Memcache::flush() example

<?php

/* procedural API */
$memcache_obj = memcache_connect('memcache_host', 11211);

memcache_flush($memcache_obj);

/* OO API */

$memcache_obj = new Memcache;
$memcache_obj->connect('memcache_host', 11211);

$memcache_obj->flush();

?>

Memcache::delete
Memcache::get
Memcache


Retrieve item from the server

Memcache::flush
Memcache::getExtendedStats
Memcache
PHP Manual

Memcache::get

(PECL memcache >= 0.2.0)

Memcache::get — Retrieve item from the server

Açıklama

string Memcache::get ( string $key [, int &$flags ] )
array Memcache::get ( array $keys [, array &$flags ] )

Memcache::get() returns previously stored data of an item, if such key exists on the server at this moment.

You can pass array of keys to Memcache::get() to get array of values. The result array will contain only found key-value pairs.

Değiştirgeler

key

The key or array of keys to fetch.

flags

If present, flags fetched along with the values will be written to this parameter. These flags are the same as the ones given to for example Memcache::set(). The lowest byte of the int is reserved for pecl/memcache internal usage (e.g. to indicate compression and serialization status).

Dönen Değerler

Returns the value associated with the key or an array of found key-value pairs when key is an array. Returns FALSE on failure, key is not found or key is an empty array.

Örnekler

Örnek 1 Memcache::get() example

<?php

/* procedural API */
$memcache_obj = memcache_connect('memcache_host', 11211);
$var = memcache_get($memcache_obj, 'some_key');

/* OO API */
$memcache_obj = new Memcache;
$memcache_obj->connect('memcache_host', 11211);
$var = $memcache_obj->get('some_key');

/*
You also can use array of keys as a parameter.
If such item wasn't found at the server, the result
array simply will not include such key.
*/

/* procedural API */
$memcache_obj = memcache_connect('memcache_host', 11211);
$var = memcache_get($memcache_obj, Array('some_key', 'another_key'));

/* OO API */
$memcache_obj = new Memcache;
$memcache_obj->connect('memcache_host', 11211);
$var = $memcache_obj->get(Array('some_key', 'second_key'));

?>

Memcache::flush
Memcache::getExtendedStats
Memcache


Get statistics from all servers in pool

Memcache::get
Memcache::getServerStatus
Memcache
PHP Manual

Memcache::getExtendedStats

(PECL memcache >= 2.0.0)

Memcache::getExtendedStats — Get statistics from all servers in pool

Açıklama

array Memcache::getExtendedStats ([ string $type [, int $slabid [, int $limit = 100 ]]] )

Memcache::getExtendedStats() returns a two-dimensional associative array with server statistics. Array keys correspond to host:port of server and values contain the individual server statistics. A failed server will have its corresponding entry set to FALSE. You can also use the memcache_get_extended_stats() function.

Bilginize:

This function has been added to Memcache version 2.0.0.

Değiştirgeler

type

The type of statistics to fetch. Valid values are {reset, malloc, maps, cachedump, slabs, items, sizes}. According to the memcached protocol spec these additional arguments "are subject to change for the convenience of memcache developers".

slabid

Used in conjunction with type set to cachedump to identify the slab to dump from. The cachedump command ties up the server and is strictly to be used for debugging purposes.

limit

Used in conjunction with type set to cachedump to limit the number of entries to dump.

Uyarı

The cachedump stat type has been removed from the memcached daemon due to security reasons.

Dönen Değerler

Returns a two-dimensional associative array of server statistics or FALSE on failure.

Örnekler

Örnek 1 Memcache::getExtendedStats() example

<?php
    $memcache_obj = new Memcache;
    $memcache_obj->addServer('memcache_host', 11211);
    $memcache_obj->addServer('failed_host', 11211);

    $stats = $memcache_obj->getExtendedStats();
    print_r($stats);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [memcache_host:11211] => Array
        (
            [pid] => 3756
            [uptime] => 603011
            [time] => 1133810435
            [version] => 1.1.12
            [rusage_user] => 0.451931
            [rusage_system] => 0.634903
            [curr_items] => 2483
            [total_items] => 3079
            [bytes] => 2718136
            [curr_connections] => 2
            [total_connections] => 807
            [connection_structures] => 13
            [cmd_get] => 9748
            [cmd_set] => 3096
            [get_hits] => 5976
            [get_misses] => 3772
            [bytes_read] => 3448968
            [bytes_written] => 2318883
            [limit_maxbytes] => 33554432
        )

    [failed_host:11211] => false
)

Ayrıca Bakınız

  • Memcache::getVersion() - Return version of the server
  • Memcache::getStats() - Get statistics of the server

Memcache::get
Memcache::getServerStatus
Memcache


Returns server status

Memcache::getExtendedStats
Memcache::getStats
Memcache
PHP Manual

Memcache::getServerStatus

(PECL memcache >= 2.1.0)

Memcache::getServerStatus — Returns server status

Açıklama

int Memcache::getServerStatus ( string $host [, int $port = 11211 ] )

Memcache::getServerStatus() returns a the servers online/offline status. You can also use memcache_get_server_status() function.

Bilginize:

This function has been added to Memcache version 2.1.0.

Değiştirgeler

host

Point to the host where memcached is listening for connections.

port

Point to the port where memcached is listening for connections.

Dönen Değerler

Returns a the servers status. 0 if server is failed, non-zero otherwise

Örnekler

Örnek 1 Memcache::getServerStatus() example

<?php

/* OO API */
$memcache = new Memcache;
$memcache->addServer('memcache_host', 11211);
echo $memcache->getServerStatus('memcache_host', 11211);

/* procedural API */
$memcache = memcache_connect('memcache_host', 11211);
echo memcache_get_server_status($memcache, 'memcache_host', 11211);

?>

Ayrıca Bakınız

  • Memcache::addServer() - Add a memcached server to connection pool
  • Memcache::setServerParams() - Changes server parameters and status at runtime

Memcache::getExtendedStats
Memcache::getStats
Memcache


Get statistics of the server

Memcache::getServerStatus
Memcache::getVersion
Memcache
PHP Manual

Memcache::getStats

(PECL memcache >= 0.2.0)

Memcache::getStats — Get statistics of the server

Açıklama

array Memcache::getStats ([ string $type [, int $slabid [, int $limit = 100 ]]] )

Memcache::getStats() returns an associative array with server's statistics. Array keys correspond to stats parameters and values to parameter's values. Also you can use memcache_get_stats() function.

Değiştirgeler

type

The type of statistics to fetch. Valid values are {reset, malloc, maps, cachedump, slabs, items, sizes}. According to the memcached protocol spec these additional arguments "are subject to change for the convenience of memcache developers".

slabid

Used in conjunction with type set to cachedump to identify the slab to dump from. The cachedump command ties up the server and is strictly to be used for debugging purposes.

limit

Used in conjunction with type set to cachedump to limit the number of entries to dump.

Dönen Değerler

Returns an associative array of server statistics başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • Memcache::getVersion() - Return version of the server
  • Memcache::getExtendedStats() - Get statistics from all servers in pool

Memcache::getServerStatus
Memcache::getVersion
Memcache


Return version of the server

Memcache::getStats
Memcache::increment
Memcache
PHP Manual

Memcache::getVersion

(PECL memcache >= 0.2.0)

Memcache::getVersion — Return version of the server

Açıklama

string Memcache::getVersion ( void )

Memcache::getVersion() returns a string with server's version number. Also you can use memcache_get_version() function.

Dönen Değerler

Returns a string of server version number başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Memcache::getVersion() example

<?php

/* OO API */
$memcache = new Memcache;
$memcache->connect('memcache_host', 11211);
echo $memcache->getVersion();

/* procedural API */
$memcache = memcache_connect('memcache_host', 11211);
echo memcache_get_version($memcache);

?>

Ayrıca Bakınız

  • Memcache::getExtendedStats() - Get statistics from all servers in pool
  • Memcache::getStats() - Get statistics of the server

Memcache::getStats
Memcache::increment
Memcache


Increment item's value

Memcache::getVersion
Memcache::pconnect
Memcache
PHP Manual

Memcache::increment

(PECL memcache >= 0.2.0)

Memcache::increment — Increment item's value

Açıklama

int Memcache::increment ( string $key [, int $value = 1 ] )

Memcache::increment() increments value of an item by the specified value. If item specified by key was not numeric and cannot be converted to a number, it will change its value to value. Memcache::increment() does not create an item if it doesn't already exist.

Bilginize:

Do not use Memcache::increment() with items that have been stored compressed because subsequent calls to Memcache::get() will fail.

Also you can use memcache_increment() function.

Değiştirgeler

key

Key of the item to increment.

value

Increment the item by value.

Dönen Değerler

Returns new items value on success başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Memcache::increment() example

<?php

/* procedural API */
$memcache_obj = memcache_connect('memcache_host', 11211);
/* increment counter by 2 */
$current_value = memcache_increment($memcache_obj, 'counter', 2);

/* OO API */
$memcache_obj = new Memcache;
$memcache_obj->connect('memcache_host', 11211);
/* increment counter by 3 */
$current_value = $memcache_obj->increment('counter', 3);

?>

Ayrıca Bakınız

  • Memcache::decrement() - Decrement item's value
  • Memcache::replace() - Replace value of the existing item

Memcache::getVersion
Memcache::pconnect
Memcache


Open memcached server persistent connection

Memcache::increment
Memcache::replace
Memcache
PHP Manual

Memcache::pconnect

(PECL memcache >= 0.4.0)

Memcache::pconnect — Open memcached server persistent connection

Açıklama

mixed Memcache::pconnect ( string $host [, int $port [, int $timeout ]] )

Memcache::pconnect() is similar to Memcache::connect() with the difference, that the connection it establishes is persistent. This connection is not closed after the end of script execution and by Memcache::close() function. Also you can use memcache_pconnect() function.

Değiştirgeler

host

Point to the host where memcached is listening for connections. This parameter may also specify other transports like unix:///path/to/memcached.sock to use UNIX domain sockets, in this case port must also be set to 0.

port

Point to the port where memcached is listening for connections. Set this parameter to 0 when using UNIX domain sockets.

timeout

Value in seconds which will be used for connecting to the daemon. Think twice before changing the default value of 1 second - you can lose all the advantages of caching if your connection is too slow.

Dönen Değerler

Returns a Memcache object başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Memcache::pconnect() example

<?php

/* procedural API */
$memcache_obj = memcache_pconnect('memcache_host', 11211);

/* OO API */

$memcache_obj = new Memcache;
$memcache_obj->pconnect('memcache_host', 11211);

?>

Ayrıca Bakınız

  • Memcache::connect() - Open memcached server connection

Memcache::increment
Memcache::replace
Memcache


Replace value of the existing item

Memcache::pconnect
Memcache::set
Memcache
PHP Manual

Memcache::replace

(PECL memcache >= 0.2.0)

Memcache::replace — Replace value of the existing item

Açıklama

bool Memcache::replace ( string $key , mixed $var [, int $flag [, int $expire ]] )

Memcache::replace() should be used to replace value of
existing item with key. In case if item with such
key doesn't exists, Memcache::replace() returns
FALSE. For the rest Memcache::replace() behaves
similarly to Memcache::set().
Also you can use memcache_replace() function.

Değiştirgeler

key

The key that will be associated with the item.

var

The variable to store. Strings and integers are stored as is, other types are stored serialized.

flag

Use MEMCACHE_COMPRESSED to store the item compressed (uses zlib).

expire

Expiration time of the item. If it's equal to zero, the item will never expire. You can also use Unix timestamp or a number of seconds starting from current time, but in the latter case the number of seconds may not exceed 2592000 (30 days).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Memcache::replace() example

<?php

$memcache_obj = memcache_connect('memcache_host', 11211);

/* procedural API */
memcache_replace($memcache_obj, "test_key", "some variable", false, 30);

/* OO API */
$memcache_obj->replace("test_key", "some variable", false, 30);

?>

Ayrıca Bakınız

  • Memcache::set() - Store data at the server
  • Memcache::add() - Add an item to the server

Memcache::pconnect
Memcache::set
Memcache


Store data at the server

Memcache::replace
Memcache::setCompressThreshold
Memcache
PHP Manual

Memcache::set

(PECL memcache >= 0.2.0)

Memcache::set — Store data at the server

Açıklama

bool Memcache::set ( string $key , mixed $var [, int $flag [, int $expire ]] )

Memcache::set() stores an item var with key on the memcached server. Parameter expire is expiration time in seconds. If it's 0, the item never expires (but memcached server doesn't guarantee this item to be stored all the time, it could be deleted from the cache to make place for other items). You can use MEMCACHE_COMPRESSED constant as flag value if you want to use on-the-fly compression (uses zlib).

Bilginize:

Remember that resource variables (i.e. file and connection descriptors) cannot be stored in the cache, because they cannot be adequately represented in serialized state.

Also you can use memcache_set() function.

Değiştirgeler

key

The key that will be associated with the item.

var

The variable to store. Strings and integers are stored as is, other types are stored serialized.

flag

Use MEMCACHE_COMPRESSED to store the item compressed (uses zlib).

expire

Expiration time of the item. If it's equal to zero, the item will never expire. You can also use Unix timestamp or a number of seconds starting from current time, but in the latter case the number of seconds may not exceed 2592000 (30 days).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Memcache::set() example

<?php
/* procedural API */

/* connect to memcached server */
$memcache_obj = memcache_connect('memcache_host', 11211);

/*
set value of item with key 'var_key'
using 0 as flag value, compression is not used
expire time is 30 seconds
*/
memcache_set($memcache_obj, 'var_key', 'some variable', 0, 30);

echo memcache_get($memcache_obj, 'var_key');

?>

Örnek 2 Memcache::set() example

<?php
/* OO API */

$memcache_obj = new Memcache;

/* connect to memcached server */
$memcache_obj->connect('memcache_host', 11211);

/*
set value of item with key 'var_key', using on-the-fly compression
expire time is 50 seconds
*/
$memcache_obj->set('var_key', 'some really big variable', MEMCACHE_COMPRESSED, 50);

echo $memcache_obj->get('var_key');

?>

Ayrıca Bakınız

  • Memcache::add() - Add an item to the server
  • Memcache::replace() - Replace value of the existing item

Memcache::replace
Memcache::setCompressThreshold
Memcache


Enable automatic compression of large values

Memcache::set
Memcache::setServerParams
Memcache
PHP Manual

Memcache::setCompressThreshold

(PECL memcache >= 2.0.0)

Memcache::setCompressThreshold — Enable automatic compression of large values

Açıklama

bool Memcache::setCompressThreshold ( int $threshold [, float $min_savings ] )

Memcache::setCompressThreshold() enables automatic compression of large values. You can also use the memcache_set_compress_threshold() function.

Bilginize:

This function has been added to Memcache version 2.0.0.

Değiştirgeler

threshold

Controls the minimum value length before attempting to compress automatically.

min_saving

Specifies the minimum amount of savings to actually store the value compressed. The supplied value must be between 0 and 1. Default value is 0.2 giving a minimum 20% compression savings.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Memcache::setCompressThreshold() example

<?php

/* OO API */

$memcache_obj = new Memcache;
$memcache_obj->addServer('memcache_host', 11211);
$memcache_obj->setCompressThreshold(20000, 0.2);

/* procedural API */

$memcache_obj = memcache_connect('memcache_host', 11211);
memcache_set_compress_threshold($memcache_obj, 20000, 0.2);

?>

Memcache::set
Memcache::setServerParams
Memcache


Changes server parameters and status at runtime

Memcache::setCompressThreshold
Memcache İşlevleri
Memcache
PHP Manual

Memcache::setServerParams

(PECL memcache >= 2.1.0)

Memcache::setServerParams — Changes server parameters and status at runtime

Açıklama

bool Memcache::setServerParams ( string $host [, int $port = 11211 [, int $timeout [, int $retry_interval = false [, bool $status [, callable $failure_callback ]]]]] )

Memcache::setServerParams() changes server parameters at runtime. You can also use the memcache_set_server_params() function.

Bilginize:

This function has been added to Memcache version 2.1.0.

Değiştirgeler

host

Point to the host where memcached is listening for connections.

port

Point to the port where memcached is listening for connections.

timeout

Value in seconds which will be used for connecting to the daemon. Think twice before changing the default value of 1 second - you can lose all the advantages of caching if your connection is too slow.

retry_interval

Controls how often a failed server will be retried, the default value is 15 seconds. Setting this parameter to -1 disables automatic retry. Neither this nor the persistent parameter has any effect when the extension is loaded dynamically via dl().

status

Controls if the server should be flagged as online. Setting this parameter to FALSE and retry_interval to -1 allows a failed server to be kept in the pool so as not to affect the key distribution algorithm. Requests for this server will then failover or fail immediately depending on the memcache.allow_failover setting. Default to TRUE, meaning the server should be considered online.

failure_callback

Allows the user to specify a callback function to run upon encountering an error. The callback is run before failover is attempted. The function takes two parameters, the hostname and port of the failed server.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Memcache::setServerParams() example

<?php

function _callback_memcache_failure($host, $port) {
    print "memcache '$host:$port' failed";
}

/* OO API */

$memcache = new Memcache;

// Add the server in offline mode
$memcache->addServer('memcache_host', 11211, false, 1, 1, -1, false);

// Bring the server back online
$memcache->setServerParams('memcache_host', 11211, 1, 15, true, '_callback_memcache_failure');

/* procedural API */

$memcache_obj = memcache_connect('memcache_host', 11211);
memcache_set_server_params($memcache_obj, 'memcache_host', 11211, 1, 15, true, '_callback_memcache_failure');

?>

Ayrıca Bakınız

  • Memcache::addServer() - Add a memcached server to connection pool
  • Memcache::getServerStatus() - Returns server status

Memcache::setCompressThreshold
Memcache İşlevleri
Memcache


Memcache İşlevleri

İçindekiler

  • memcache_debug — Turn debug output on/off
Memcache::setServerParams
memcache_debug
Memcache


Turn debug output on/off

Memcache İşlevleri
Memcached
Memcache İşlevleri
PHP Manual

memcache_debug

(PECL memcache >= 0.2.0)

memcache_debug — Turn debug output on/off

Açıklama

bool memcache_debug ( bool $on_off )

memcache_debug() turns on debug output if parameter on_off is equal to TRUE and turns off if it's FALSE.

Bilginize:

memcache_debug() is accessible only if PHP was built with --enable-debug option and always returns TRUE in this case. Otherwise, this function has no effect and always returns FALSE.

Değiştirgeler

on_off

Turns debug output on if equals to TRUE. Turns debug output off if equals to FALSE.

Dönen Değerler

Returns TRUE if PHP was built with --enable-debug option, otherwise returns FALSE.

Memcache İşlevleri
Memcached
Memcache İşlevleri


Memcached

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Expiration Times
  • Callbacks
    • Result callbacks
    • Read-through cache callbacks
  • Sessions support
  • Memcached — The Memcached class
    • Memcached::add — Add an item under a new key
    • Memcached::addByKey — Add an item under a new key on a specific server
    • Memcached::addServer — Add a server to the server pool
    • Memcached::addServers — Add multiple servers to the server pool
    • Memcached::append — Append data to an existing item
    • Memcached::appendByKey — Append data to an existing item on a specific server
    • Memcached::cas — Compare and swap an item
    • Memcached::casByKey — Compare and swap an item on a specific server
    • Memcached::__construct — Create a Memcached instance
    • Memcached::decrement — Decrement numeric item's value
    • Memcached::decrementByKey — Decrement numeric item's value, stored on a specific server
    • Memcached::delete — Delete an item
    • Memcached::deleteByKey — Delete an item from a specific server
    • Memcached::deleteMulti — Delete multiple items
    • Memcached::deleteMultiByKey — Delete multiple items from a specific server
    • Memcached::fetch — Fetch the next result
    • Memcached::fetchAll — Fetch all the remaining results
    • Memcached::flush — Invalidate all items in the cache
    • Memcached::get — Retrieve an item
    • Memcached::getAllKeys — Gets the keys stored on all the servers
    • Memcached::getByKey — Retrieve an item from a specific server
    • Memcached::getDelayed — Request multiple items
    • Memcached::getDelayedByKey — Request multiple items from a specific server
    • Memcached::getMulti — Retrieve multiple items
    • Memcached::getMultiByKey — Retrieve multiple items from a specific server
    • Memcached::getOption — Retrieve a Memcached option value
    • Memcached::getResultCode — Return the result code of the last operation
    • Memcached::getResultMessage — Return the message describing the result of the last operation
    • Memcached::getServerByKey — Map a key to a server
    • Memcached::getServerList — Get the list of the servers in the pool
    • Memcached::getStats — Get server pool statistics
    • Memcached::getVersion — Get server pool version info
    • Memcached::increment — Increment numeric item's value
    • Memcached::incrementByKey — Increment numeric item's value, stored on a specific server
    • Memcached::isPersistent — Check if a persitent connection to memcache is being used
    • Memcached::isPristine — Check if the instance was recently created
    • Memcached::prepend — Prepend data to an existing item
    • Memcached::prependByKey — Prepend data to an existing item on a specific server
    • Memcached::quit — Close any open connections
    • Memcached::replace — Replace the item under an existing key
    • Memcached::replaceByKey — Replace the item under an existing key on a specific server
    • Memcached::resetServerList — Clears all servers from the server list
    • Memcached::set — Store an item
    • Memcached::setByKey — Store an item on a specific server
    • Memcached::setMulti — Store multiple items
    • Memcached::setMultiByKey — Store multiple items on a specific server
    • Memcached::setOption — Set a Memcached option
    • Memcached::setOptions — Set Memcached options
    • Memcached::setSaslAuthData — Set the credentials to use for authentication
    • Memcached::touch — Set a new expiration on an item
    • Memcached::touchByKey — Set a new expiration on an item on a specific server
  • MemcachedException — The MemcachedException class
memcache_debug
Giriş
Diğer Hizmetler


Giriş

» memcached is a high-performance, distributed memory object caching system, generic in nature, but intended for use in speeding up dynamic web applications by alleviating database load.

This extension uses the libmemcached library to provide an API for communicating with memcached servers. It also provides a session handler (memcached).

Information about libmemcached can be found at » http://libmemcached.org/libMemcached.html.

Memcached
Yapılandırma/Kurulum
Memcached


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Memcached


Gereksinimler

This extension requires » libmemcached client library (version 1.0.0 or greater). For SASL authentication support, libmemcached must be built with SASL enabled.

Since version 0.2.0, this extension requires PHP version 5.2.0 or higher.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/memcached.

If libmemcached is installed in a non-standard location, use --with-libmemcached-dir=DIR switch, where DIR is the libmemcached install prefix. This directory has to contain the include/libmemcached/memcached.h file.

Zlib is required for compression support. To specify non-standard installation of Zlib, use --with-zlib-dir=DIR switch, where DIR is the Zlib install prefix.

Session handler support is enabled by default. To disable it, use --disable-memcached-session switch.

SASL authentication support is disabled by default. To enable it, use --enable-memcached-sasl switch. This requires that libsasl2 has been installed and that libmemcached has been built with SASL support enabled.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Memcached Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
memcached.sess_locking | 1 | PHP_INI_ALL |
memcached.sess_consistent_hash | 0 | PHP_INI_ALL |
memcached.sess_binary | 0 | PHP_INI_ALL |
memcached.sess_lock_wait | 150000 | PHP_INI_ALL |
memcached.sess_prefix | memc.sess.key. | PHP_INI_ALL |
memcached.sess_number_of_replicas | 0 | PHP_INI_ALL |
memcached.sess_randomize_replica_read | 0 | PHP_INI_ALL |
memcached.sess_remove_failed | 0 | PHP_INI_ALL |
memcached.compression_type | fastlz | PHP_INI_ALL |
memcached.compression_factor | 1.3 | PHP_INI_ALL |
memcached.compression_threshold | 2000 | PHP_INI_ALL |
memcached.serializer | php | PHP_INI_ALL |
memcached.use_sasl | 0 | PHP_INI_SYSTEM |

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

memcached.sess_locking integer

Use session locking. Valid values: On, Off, the default is On.

memcached.sess_consistent_hash integer

Memcached session consistent hash mode. If set to On, consistent hashing is used for session handling. When consistent hashing is used, one can add or remove cache node(s) without messing up too much with existing keys. The default is Off.

memcached.sess_binary integer

Use memcached session binary mode. Libmemcached replicas only work if binary mode is enabled. The default is Off.

memcached.sess_lock_wait integer

Session spin lock retry wait time in microseconds. Be carefull when setting this value. Valid values are integers, where 0 is interpreted as the default value. Negative values result in a reduces locking to a try lock. The default is 150000.

memcached.sess_prefix string

Memcached session key prefix. Valid values are strings less than 219 bytes long. The default value is "memc.sess.key."

memcached.sess_number_of_replicas integer

The memcached session number of replicas.

memcached.sess_randomize_replica_read integer

Memcached session replica read randomize.

memcached.sess_remove_failed integer

Allow failed memcached server to automatically be removed.

memcached.compression_type string

Set the compression type, valid values are: fastlz, zlib. The default is fastlz.

memcached.compression_factor float

Compression factor. Store compressed value only if the compression factor (saving) exceeds the set limit. Store compressed if: plain_len > comp_len * factor. The default value is 1.3 (23% space saving).

memcached.compression_threshold integer

The compression threshold. Do not compress serialized values below this threshold. The default is 2000 bytes.

memcached.serializer string

Set the default serializer for new memcached objects. Valid values are: php, igbinary, json, json_array.

json

Standard php JSON encoding. This serializer is fast and compact but only works on UTF-8 encoded data and does not fully implement serializing. See the JSON extension.

json_array

As json, but decodes into arrays.

php

The standard PHP serializer.

igbinary

A binary serializer

The default is igbinary if available and php otherwise.

memcached.use_sasl integer

Use SASL authentication for connections. Valid values: On, Off. The default is Off.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

Memcached::OPT_COMPRESSION

Enables or disables payload compression. When enabled, item values longer than a certain threshold (currently 100 bytes) will be compressed during storage and decompressed during retrieval transparently.

Type: boolean, default: TRUE.

Memcached::OPT_SERIALIZER

Specifies the serializer to use for serializing non-scalar values. The valid serializers are Memcached::SERIALIZER_PHP or Memcached::SERIALIZER_IGBINARY. The latter is supported only when memcached is configured with --enable-memcached-igbinary option and the igbinary extension is loaded.

Type: integer, default: Memcached::SERIALIZER_PHP.

Memcached::SERIALIZER_PHP

The default PHP serializer.

Memcached::SERIALIZER_IGBINARY

The » igbinary serializer. Instead of textual representation it stores PHP data structures in a compact binary form, resulting in space and time gains.

Memcached::SERIALIZER_JSON

The JSON serializer. Requires PHP 5.2.10+.

Memcached::OPT_PREFIX_KEY

This can be used to create a "domain" for your item keys. The value specified here will be prefixed to each of the keys. It cannot be longer than 128 characters and will reduce the maximum available key size. The prefix is applied only to the item keys, not to the server keys.

Type: string, default: "".

Memcached::OPT_HASH

Specifies the hashing algorithm used for the item keys. The valid values are supplied via Memcached::HASH_* constants. Each hash algorithm has its advantages and its disadvantages. Go with the default if you don't know or don't care.

Type: integer, default: Memcached::HASH_DEFAULT

Memcached::HASH_DEFAULT

The default (Jenkins one-at-a-time) item key hashing algorithm.

Memcached::HASH_MD5

MD5 item key hashing algorithm.

Memcached::HASH_CRC

CRC item key hashing algorithm.

Memcached::HASH_FNV1_64

FNV1_64 item key hashing algorithm.

Memcached::HASH_FNV1A_64

FNV1_64A item key hashing algorithm.

Memcached::HASH_FNV1_32

FNV1_32 item key hashing algorithm.

Memcached::HASH_FNV1A_32

FNV1_32A item key hashing algorithm.

Memcached::HASH_HSIEH

Hsieh item key hashing algorithm.

Memcached::HASH_MURMUR

Murmur item key hashing algorithm.

Memcached::OPT_DISTRIBUTION

Specifies the method of distributing item keys to the servers. Currently supported methods are modulo and consistent hashing. Consistent hashing delivers better distribution and allows servers to be added to the cluster with minimal cache losses.

Type: integer, default: Memcached::DISTRIBUTION_MODULA.

Memcached::DISTRIBUTION_MODULA

Modulo-based key distribution algorithm.

Memcached::DISTRIBUTION_CONSISTENT

Consistent hashing key distribution algorithm (based on libketama).

Memcached::OPT_LIBKETAMA_COMPATIBLE

Enables or disables compatibility with libketama-like behavior. When enabled, the item key hashing algorithm is set to MD5 and distribution is set to be weighted consistent hashing distribution. This is useful because other libketama-based clients (Python, Ruby, etc.) with the same server configuration will be able to access the keys transparently.

Bilginize:

It is highly recommended to enable this option if you want to use consistent hashing, and it may be enabled by default in future releases.

Type: boolean, default: FALSE.

Memcached::OPT_BUFFER_WRITES

Enables or disables buffered I/O. Enabling buffered I/O causes storage commands to "buffer" instead of being sent. Any action that retrieves data causes this buffer to be sent to the remote connection. Quitting the connection or closing down the connection will also cause the buffered data to be pushed to the remote connection.

Type: boolean, default: FALSE.

Memcached::OPT_BINARY_PROTOCOL

Enable the use of the binary protocol. Please note that you cannot toggle this option on an open connection.

Type: boolean, default: FALSE.

Memcached::OPT_NO_BLOCK

Enables or disables asynchronous I/O. This is the fastest transport available for storage functions.

Type: boolean, default: FALSE.

Memcached::OPT_TCP_NODELAY

Enables or disables the no-delay feature for connecting sockets (may be faster in some environments).

Type: boolean, default: FALSE.

Memcached::OPT_SOCKET_SEND_SIZE

The maximum socket send buffer in bytes.

Type: integer, default: varies by platform/kernel configuration.

Memcached::OPT_SOCKET_RECV_SIZE

The maximum socket receive buffer in bytes.

Type: integer, default: varies by platform/kernel configuration.

Memcached::OPT_CONNECT_TIMEOUT

In non-blocking mode this set the value of the timeout during socket connection, in milliseconds.

Type: integer, default: 1000.

Memcached::OPT_RETRY_TIMEOUT

The amount of time, in seconds, to wait until retrying a failed connection attempt.

Type: integer, default: 0.

Memcached::OPT_SEND_TIMEOUT

Socket sending timeout, in microseconds. In cases where you cannot use non-blocking I/O this will allow you to still have timeouts on the sending of data.

Type: integer, default: 0.

Memcached::OPT_RECV_TIMEOUT

Socket reading timeout, in microseconds. In cases where you cannot use non-blocking I/O this will allow you to still have timeouts on the reading of data.

Type: integer, default: 0.

Memcached::OPT_POLL_TIMEOUT

Timeout for connection polling, in milliseconds.

Type: integer, default: 1000.

Memcached::OPT_CACHE_LOOKUPS

Enables or disables caching of DNS lookups.

Type: boolean, default: FALSE.

Memcached::OPT_SERVER_FAILURE_LIMIT

Specifies the failure limit for server connection attempts. The server will be removed after this many continuous connection failures.

Type: integer, default: 0.

Memcached::HAVE_IGBINARY

Indicates whether igbinary serializer support is available.

Type: boolean.

Memcached::HAVE_JSON

Indicates whether JSON serializer support is available.

Type: boolean.

Memcached::GET_PRESERVE_ORDER

A flag for Memcached::getMulti() and Memcached::getMultiByKey() to ensure that the keys are returned in the same order as they were requested in. Non-existing keys get a default value of NULL.

Memcached::RES_SUCCESS

The operation was successful.

Memcached::RES_FAILURE

The operation failed in some fashion.

Memcached::RES_HOST_LOOKUP_FAILURE

DNS lookup failed.

Memcached::RES_UNKNOWN_READ_FAILURE

Failed to read network data.

Memcached::RES_PROTOCOL_ERROR

Bad command in memcached protocol.

Memcached::RES_CLIENT_ERROR

Error on the client side.

Memcached::RES_SERVER_ERROR

Error on the server side.

Memcached::RES_WRITE_FAILURE

Failed to write network data.

Memcached::RES_DATA_EXISTS

Failed to do compare-and-swap: item you are trying to store has been modified since you last fetched it.

Memcached::RES_NOTSTORED

Item was not stored: but not because of an error. This normally means that either the condition for an "add" or a "replace" command wasn't met, or that the item is in a delete queue.

Memcached::RES_NOTFOUND

Item with this key was not found (with "get" operation or "cas" operations).

Memcached::RES_PARTIAL_READ

Partial network data read error.

Memcached::RES_SOME_ERRORS

Some errors occurred during multi-get.

Memcached::RES_NO_SERVERS

Server list is empty.

Memcached::RES_END

End of result set.

Memcached::RES_ERRNO

System error.

Memcached::RES_BUFFERED

The operation was buffered.

Memcached::RES_TIMEOUT

The operation timed out.

Memcached::RES_BAD_KEY_PROVIDED

Bad key.

Memcached::RES_CONNECTION_SOCKET_CREATE_FAILURE

Failed to create network socket.

Memcached::RES_PAYLOAD_FAILURE

Payload failure: could not compress/decompress or serialize/unserialize the value.

Özkaynak Türleri
Expiration Times
Memcached


Expiration Times

Some storage commands involve sending an expiration value (relative to an item or to an operation requested by the client) to the server. In all such cases, the actual value sent may either be Unix time (number of seconds since January 1, 1970, as an integer), or a number of seconds starting from current time. In the latter case, this number of seconds may not exceed 60*60*24*30 (number of seconds in 30 days); if the expiration value is larger than that, the server will consider it to be real Unix time value rather than an offset from current time.

If the expiration value is 0 (the default), the item never expires (although it may be deleted from the server to make place for other items).

Öntanımlı Sabitler
Callbacks
Memcached


Callbacks

İçindekiler

  • Result callbacks
  • Read-through cache callbacks
Expiration Times
Result callbacks
Memcached


Result callbacks

Result callbacks are invoked by Memcached::getDelayed() or Memcached::getDelayedBykey() methods for each item in the result set. The callback is passed the Memcached object and the array with the item information. The callback does not have to return anything.

Örnek 1 Result callback example

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);
$items = array(
    'key1' => 'value1',
    'key2' => 'value2',
    'key3' => 'value3'
);
$m->setMulti($items);
$m->getDelayed(array('key1', 'key3'), true, 'result_cb');

function result_cb($memc, $item)
{
    var_dump($item);
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(3) {
  ["key"]=>
  string(4) "key1"
  ["value"]=>
  string(6) "value1"
  ["cas"]=>
  float(49)
}
array(3) {
  ["key"]=>
  string(4) "key3"
  ["value"]=>
  string(6) "value3"
  ["cas"]=>
  float(50)
}
Callbacks
Read-through cache callbacks
Callbacks


Read-through cache callbacks

Read-through cache callbacks are invoked when an item cannot be retrieved from the server. The callback is passed the Memcached object, the requested key, and the by-reference value variable. The callback is responsible for setting the value and returning true or false. If the callback returns true, Memcached will store the populated value on the server and return it to the original calling function. Only Memcached::get() and Memcached::getByKey() support these callbacks, because the memcache protocol does not provide information on which keys were not found in the multi-key request.

Örnek 1 Read-through callback example

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

$profile_info = $m->get('user:'.$user_id, 'user_info_cb');

function user_info_cb($memc, $key, &$value)
{
    $user_id = substr($key, 5);
    /* lookup profile info in the DB */
    /* ... */
    $value = $profile_info;
    return true;
}
?>
Result callbacks
Sessions support
Callbacks


Sessions support

Memcached provides a custom session handler that can be used to store user sessions in memcache. A completely separate memcached instance is used for that internally, so you can use a different server pool if necessary. The session keys are stored under the prefix memc.sess.key., so be aware of this if you use the same server pool for sessions and generic caching.

session.save_handler string

Set to memcached to enable sessions support.

session.save_path string

Defines a comma separated of hostname:port entries to use for session server pool, for example "sess1:11211, sess2:11211".

Read-through cache callbacks
Memcached
Memcached


The Memcached class

(PECL memcached >= 0.1.0)

Giriş

Represents a connection to a set of memcached servers.

Sınıf Sözdizimi

Memcached {
public __construct ([ string $persistent_id ] )
public bool add ( string $key , mixed $value [, int $expiration ] )
public bool addByKey ( string $server_key , string $key , mixed $value [, int $expiration ] )
public bool addServer ( string $host , int $port [, int $weight = 0 ] )
public bool addServers ( array $servers )
public bool append ( string $key , string $value )
public bool appendByKey ( string $server_key , string $key , string $value )
public bool cas ( float $cas_token , string $key , mixed $value [, int $expiration ] )
public bool casByKey ( float $cas_token , string $server_key , string $key , mixed $value [, int $expiration ] )
public int decrement ( string $key [, int $offset = 1 [, int $initial_value = 0 [, int $expiry = 0 ]]] )
public int decrementByKey ( string $server_key , string $key [, int $offset = 1 [, int $initial_value = 0 [, int $expiry = 0 ]]] )
public bool delete ( string $key [, int $time = 0 ] )
public bool deleteByKey ( string $server_key , string $key [, int $time = 0 ] )
public array deleteMulti ( array $keys [, int $time = 0 ] )
public bool deleteMultiByKey ( string $server_key , array $keys [, int $time = 0 ] )
public array fetch ( void )
public array fetchAll ( void )
public bool flush ([ int $delay = 0 ] )
public mixed get ( string $key [, callable $cache_cb [, float &$cas_token ]] )
public array getAllKeys ( void )
public mixed getByKey ( string $server_key , string $key [, callable $cache_cb [, float &$cas_token ]] )
public bool getDelayed ( array $keys [, bool $with_cas [, callable $value_cb ]] )
public bool getDelayedByKey ( string $server_key , array $keys [, bool $with_cas [, callable $value_cb ]] )
public mixed getMulti ( array $keys [, array &$cas_tokens [, int $flags ]] )
public array getMultiByKey ( string $server_key , array $keys [, string &$cas_tokens [, int $flags ]] )
public mixed getOption ( int $option )
public int getResultCode ( void )
public string getResultMessage ( void )
public array getServerByKey ( string $server_key )
public array getServerList ( void )
public array getStats ( void )
public array getVersion ( void )
public int increment ( string $key [, int $offset = 1 [, int $initial_value = 0 [, int $expiry = 0 ]]] )
public int incrementByKey ( string $server_key , string $key [, int $offset = 1 [, int $initial_value = 0 [, int $expiry = 0 ]]] )
public bool isPersistent ( void )
public bool isPristine ( void )
public bool prepend ( string $key , string $value )
public bool prependByKey ( string $server_key , string $key , string $value )
public bool quit ( void )
public bool replace ( string $key , mixed $value [, int $expiration ] )
public bool replaceByKey ( string $server_key , string $key , mixed $value [, int $expiration ] )
public bool resetServerList ( void )
public bool set ( string $key , mixed $value [, int $expiration ] )
public bool setByKey ( string $server_key , string $key , mixed $value [, int $expiration ] )
public bool setMulti ( array $items [, int $expiration ] )
public bool setMultiByKey ( string $server_key , array $items [, int $expiration ] )
public bool setOption ( int $option , mixed $value )
public bool setOptions ( array $options )
public void setSaslAuthData ( string $username , string $password )
public bool touch ( string $key , int $expiration )
public bool touchByKey ( string $server_key , string $key , int $expiration )
}

İçindekiler

  • Memcached::add — Add an item under a new key
  • Memcached::addByKey — Add an item under a new key on a specific server
  • Memcached::addServer — Add a server to the server pool
  • Memcached::addServers — Add multiple servers to the server pool
  • Memcached::append — Append data to an existing item
  • Memcached::appendByKey — Append data to an existing item on a specific server
  • Memcached::cas — Compare and swap an item
  • Memcached::casByKey — Compare and swap an item on a specific server
  • Memcached::__construct — Create a Memcached instance
  • Memcached::decrement — Decrement numeric item's value
  • Memcached::decrementByKey — Decrement numeric item's value, stored on a specific server
  • Memcached::delete — Delete an item
  • Memcached::deleteByKey — Delete an item from a specific server
  • Memcached::deleteMulti — Delete multiple items
  • Memcached::deleteMultiByKey — Delete multiple items from a specific server
  • Memcached::fetch — Fetch the next result
  • Memcached::fetchAll — Fetch all the remaining results
  • Memcached::flush — Invalidate all items in the cache
  • Memcached::get — Retrieve an item
  • Memcached::getAllKeys — Gets the keys stored on all the servers
  • Memcached::getByKey — Retrieve an item from a specific server
  • Memcached::getDelayed — Request multiple items
  • Memcached::getDelayedByKey — Request multiple items from a specific server
  • Memcached::getMulti — Retrieve multiple items
  • Memcached::getMultiByKey — Retrieve multiple items from a specific server
  • Memcached::getOption — Retrieve a Memcached option value
  • Memcached::getResultCode — Return the result code of the last operation
  • Memcached::getResultMessage — Return the message describing the result of the last operation
  • Memcached::getServerByKey — Map a key to a server
  • Memcached::getServerList — Get the list of the servers in the pool
  • Memcached::getStats — Get server pool statistics
  • Memcached::getVersion — Get server pool version info
  • Memcached::increment — Increment numeric item's value
  • Memcached::incrementByKey — Increment numeric item's value, stored on a specific server
  • Memcached::isPersistent — Check if a persitent connection to memcache is being used
  • Memcached::isPristine — Check if the instance was recently created
  • Memcached::prepend — Prepend data to an existing item
  • Memcached::prependByKey — Prepend data to an existing item on a specific server
  • Memcached::quit — Close any open connections
  • Memcached::replace — Replace the item under an existing key
  • Memcached::replaceByKey — Replace the item under an existing key on a specific server
  • Memcached::resetServerList — Clears all servers from the server list
  • Memcached::set — Store an item
  • Memcached::setByKey — Store an item on a specific server
  • Memcached::setMulti — Store multiple items
  • Memcached::setMultiByKey — Store multiple items on a specific server
  • Memcached::setOption — Set a Memcached option
  • Memcached::setOptions — Set Memcached options
  • Memcached::setSaslAuthData — Set the credentials to use for authentication
  • Memcached::touch — Set a new expiration on an item
  • Memcached::touchByKey — Set a new expiration on an item on a specific server
Sessions support
Memcached::add
Memcached


Add an item under a new key

Memcached
Memcached::addByKey
Memcached
PHP Manual

Memcached::add

(PECL memcached >= 0.1.0)

Memcached::add — Add an item under a new key

Açıklama

public bool Memcached::add ( string $key , mixed $value [, int $expiration ] )

Memcached::add() is similar to Memcached::set(), but the operation fails if the key already exists on the server.

Değiştirgeler

key

Değerin saklanacağı anahtar.

value

Saklanacak değer.

expiration

Zaman aşımı, öntanımlı 0'dır. Daha ayrıntılı bilgi için Zaman aşımı süreleri bölümüne bakınız.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. The Memcached::getResultCode() will return Memcached::RES_NOTSTORED if the key already exists.

Ayrıca Bakınız

  • Memcached::addByKey() - Add an item under a new key on a specific server
  • Memcached::set() - Store an item
  • Memcached::replace() - Replace the item under an existing key

Memcached
Memcached::addByKey
Memcached


Add an item under a new key on a specific server

Memcached::add
Memcached::addServer
Memcached
PHP Manual

Memcached::addByKey

(PECL memcached >= 0.1.0)

Memcached::addByKey — Add an item under a new key on a specific server

Açıklama

public bool Memcached::addByKey ( string $server_key , string $key , mixed $value [, int $expiration ] )

Memcached::addByKey() is functionally equivalent to Memcached::add(), except that the free-form server_key can be used to map the key to a specific server. This is useful if you need to keep a bunch of related keys on a certain server.

Değiştirgeler

server_key

The key identifying the server to store the value on or retrieve it from. Instead of hashing on the actual key for the item, we hash on the server key when deciding which memcached server to talk to. This allows related items to be grouped together on a single server for efficiency with multi operations.

key

Değerin saklanacağı anahtar.

value

Saklanacak değer.

expiration

Zaman aşımı, öntanımlı 0'dır. Daha ayrıntılı bilgi için Zaman aşımı süreleri bölümüne bakınız.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. The Memcached::getResultCode() will return Memcached::RES_NOTSTORED if the key already exists.

Ayrıca Bakınız

  • Memcached::add() - Add an item under a new key
  • Memcached::set() - Store an item
  • Memcached::replace() - Replace the item under an existing key

Memcached::add
Memcached::addServer
Memcached


Add a server to the server pool

Memcached::addByKey
Memcached::addServers
Memcached
PHP Manual

Memcached::addServer

(PECL memcached >= 0.1.0)

Memcached::addServer — Add a server to the server pool

Açıklama

public bool Memcached::addServer ( string $host , int $port [, int $weight = 0 ] )

Memcached::addServer() adds the specified server to the server pool. No connection is established to the server at this time, but if you are using consistent key distribution option (via Memcached::DISTRIBUTION_CONSISTENT or Memcached::OPT_LIBKETAMA_COMPATIBLE), some of the internal data structures will have to be updated. Thus, if you need to add multiple servers, it is better to use Memcached::addServers() as the update then happens only once.

The same server may appear multiple times in the server pool, because no duplication checks are made. This is not advisable; instead, use the weight option to increase the selection weighting of this server.

Değiştirgeler

host

The hostname of the memcache server. If the hostname is invalid, data-related operations will set Memcached::RES_HOST_LOOKUP_FAILURE result code. As of version 2.0.0b1, this parameter may also specify the path of a unix socket filepath ex. /path/to/memcached.sock to use UNIX domain sockets, in this case port must also be set to 0.

port

The port on which memcache is running. Usually, this is 11211. As of version 2.0.0b1, set this parameter to 0 when using UNIX domain sockets.

weight

The weight of the server relative to the total weight of all the servers in the pool. This controls the probability of the server being selected for operations. This is used only with consistent distribution option and usually corresponds to the amount of memory available to memcache on that server.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Memcached::addServer() example

<?php
$m = new Memcached();

/* Add 2 servers, so that the second one
   is twice as likely to be selected. */
$m->addServer('mem1.domain.com', 11211, 33);
$m->addServer('mem2.domain.com', 11211, 67);
?>

Ayrıca Bakınız

  • Memcached::addServers() - Add multiple servers to the server pool
  • Memcached::resetServerList() - Clears all servers from the server list

Memcached::addByKey
Memcached::addServers
Memcached


Add multiple servers to the server pool

Memcached::addServer
Memcached::append
Memcached
PHP Manual

Memcached::addServers

(PECL memcached >= 0.1.1)

Memcached::addServers — Add multiple servers to the server pool

Açıklama

public bool Memcached::addServers ( array $servers )

Memcached::addServers() adds servers to the server pool. Each entry in servers is supposed to be an array containing hostname, port, and, optionally, weight of the server. No connection is established to the servers at this time.

The same server may appear multiple times in the server pool, because no duplication checks are made. This is not advisable; instead, use the weight option to increase the selection weighting of this server.

Değiştirgeler

array

Array of the servers to add to the pool.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Memcached::addServers() example

<?php
$m = new Memcached();

$servers = array(
    array('mem1.domain.com', 11211, 33),
    array('mem2.domain.com', 11211, 67)
);
$m->addServers($servers);
?>

Ayrıca Bakınız

  • Memcached::addServer() - Add a server to the server pool
  • Memcached::resetServerList() - Clears all servers from the server list

Memcached::addServer
Memcached::append
Memcached


Append data to an existing item

Memcached::addServers
Memcached::appendByKey
Memcached
PHP Manual

Memcached::append

(PECL memcached >= 0.1.0)

Memcached::append — Append data to an existing item

Açıklama

public bool Memcached::append ( string $key , string $value )

Memcached::append() appends the given value string to the value of an existing item. The reason that value is forced to be a string is that appending mixed types is not well-defined.

Bilginize:

If the Memcached::OPT_COMPRESSION is enabled, the operation will fail and a warning will be issued, because appending compressed data to a value that is potentially already compressed is not possible.

Değiştirgeler

key

Değerin saklanacağı anahtar.

value

The string to append.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. The Memcached::getResultCode() will return Memcached::RES_NOTSTORED if the key does not exist.

Örnekler

Örnek 1 Memcached::append() example

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);
$m->setOption(Memcached::OPT_COMPRESSION, false);

$m->set('foo', 'abc');
$m->append('foo', 'def');
var_dump($m->get('foo'));
?>

Yukarıdaki örneğin çıktısı:

string(6) "abcdef"

Ayrıca Bakınız

  • Memcached::appendByKey() - Append data to an existing item on a specific server
  • Memcached::prepend() - Prepend data to an existing item

Memcached::addServers
Memcached::appendByKey
Memcached


Append data to an existing item on a specific server

Memcached::append
Memcached::cas
Memcached
PHP Manual

Memcached::appendByKey

(PECL memcached >= 0.1.0)

Memcached::appendByKey — Append data to an existing item on a specific server

Açıklama

public bool Memcached::appendByKey ( string $server_key , string $key , string $value )

Memcached::appendByKey() is functionally equivalent to Memcached::append(), except that the free-form server_key can be used to map the key to a specific server.

Değiştirgeler

server_key

The key identifying the server to store the value on or retrieve it from. Instead of hashing on the actual key for the item, we hash on the server key when deciding which memcached server to talk to. This allows related items to be grouped together on a single server for efficiency with multi operations.

key

Değerin saklanacağı anahtar.

value

The string to append.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. The Memcached::getResultCode() will return Memcached::RES_NOTSTORED if the key does not exist.

Ayrıca Bakınız

  • Memcached::append() - Append data to an existing item
  • Memcached::prepend() - Prepend data to an existing item

Memcached::append
Memcached::cas
Memcached


Compare and swap an item

Memcached::appendByKey
Memcached::casByKey
Memcached
PHP Manual

Memcached::cas

(PECL memcached >= 0.1.0)

Memcached::cas — Compare and swap an item

Açıklama

public bool Memcached::cas ( float $cas_token , string $key , mixed $value [, int $expiration ] )

Memcached::cas() performs a "check and set" operation, so that the item will be stored only if no other client has updated it since it was last fetched by this client. The check is done via the cas_token parameter which is a unique 64-bit value assigned to the existing item by memcache. See the documentation for Memcached::get*() methods for how to obtain this token. Note that the token is represented as a double due to the limitations of PHP's integer space.

Değiştirgeler

cas_token

Unique value associated with the existing item. Generated by memcache.

key

Değerin saklanacağı anahtar.

value

Saklanacak değer.

expiration

Zaman aşımı, öntanımlı 0'dır. Daha ayrıntılı bilgi için Zaman aşımı süreleri bölümüne bakınız.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. The Memcached::getResultCode() will return Memcached::RES_DATA_EXISTS if the item you are trying to store has been modified since you last fetched it.

Örnekler

Örnek 1 Memcached::cas() example

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

do {
    /* fetch IP list and its token */
    $ips = $m->get('ip_block', null, $cas);
    /* if list doesn't exist yet, create it and do
       an atomic add which will fail if someone else already added it */
    if ($m->getResultCode() == Memcached::RES_NOTFOUND) {
        $ips = array($_SERVER['REMOTE_ADDR']);
        $m->add('ip_block', $ips);
    /* otherwise, add IP to the list and store via compare-and-swap
       with the token, which will fail if someone else updated the list */
    } else {
        $ips[] = $_SERVER['REMOTE_ADDR'];
        $m->cas($cas, 'ip_block', $ips);
    }
} while ($m->getResultCode() != Memcached::RES_SUCCESS);

?>

Ayrıca Bakınız

  • Memcached::casByKey() - Compare and swap an item on a specific server

Memcached::appendByKey
Memcached::casByKey
Memcached


Compare and swap an item on a specific server

Memcached::cas
Memcached::__construct
Memcached
PHP Manual

Memcached::casByKey

(PECL memcached >= 0.1.0)

Memcached::casByKey — Compare and swap an item on a specific server

Açıklama

public bool Memcached::casByKey ( float $cas_token , string $server_key , string $key , mixed $value [, int $expiration ] )

Memcached::casByKey() is functionally equivalent to Memcached::cas(), except that the free-form server_key can be used to map the key to a specific server. This is useful if you need to keep a bunch of related keys on a certain server.

Değiştirgeler

cas_token

Unique value associated with the existing item. Generated by memcache.

server_key

The key identifying the server to store the value on or retrieve it from. Instead of hashing on the actual key for the item, we hash on the server key when deciding which memcached server to talk to. This allows related items to be grouped together on a single server for efficiency with multi operations.

key

Değerin saklanacağı anahtar.

value

Saklanacak değer.

expiration

Zaman aşımı, öntanımlı 0'dır. Daha ayrıntılı bilgi için Zaman aşımı süreleri bölümüne bakınız.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. The Memcached::getResultCode() will return Memcached::RES_DATA_EXISTS if the item you are trying to store has been modified since you last fetched it.

Ayrıca Bakınız

  • Memcached::cas() - Compare and swap an item

Memcached::cas
Memcached::__construct
Memcached


Create a Memcached instance

Memcached::casByKey
Memcached::decrement
Memcached
PHP Manual

Memcached::__construct

(PECL memcached >= 0.1.0)

Memcached::__construct — Create a Memcached instance

Açıklama

public Memcached::__construct ([ string $persistent_id ] )

Creates a Memcached instance representing the connection to the memcache servers.

Değiştirgeler

persistent_id

By default the Memcached instances are destroyed at the end of the request. To create an instance that persists between requests, use persistent_id to specify a unique ID for the instance. All instances created with the same persistent_id will share the same connection.

Dönen Değerler

A Memcached object.

Örnekler

Örnek 1 Creating a Memcached object

<?php
/* Create a regular instance */
$m = new Memcached();
echo get_class($m);

/* Create a persistent instance */
$m2 = new Memcached('story_pool');
$m3 = new Memcached('story_pool');

/* now $m2 and $m3 share the same connection */
?>

Memcached::casByKey
Memcached::decrement
Memcached


Decrement numeric item's value

Memcached::__construct
Memcached::decrementByKey
Memcached
PHP Manual

Memcached::decrement

(PECL memcached >= 0.1.0)

Memcached::decrement — Decrement numeric item's value

Açıklama

public int Memcached::decrement ( string $key [, int $offset = 1 [, int $initial_value = 0 [, int $expiry = 0 ]]] )

Memcached::decrement() decrements a numeric item's value by the specified offset. If the item's value is not numeric, an error will result. If the operation would decrease the value below 0, the new value will be 0. Memcached::decrement() will set the item to the initial_value parameter if the key doesn't exist.

Değiştirgeler

key

The key of the item to decrement.

offset

The amount by which to decrement the item's value.

initial_value

The value to set the item to if it doesn't currently exist.

expiry

The expiry time to set on the item.

Dönen Değerler

Returns item's new value on success başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Memcached::decrement() example

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

$m->set('counter', 5);
$n = $m->decrement('counter');
var_dump($n);

$n = $m->decrement('counter', 10);
var_dump($n);

var_dump($m->get('counter'));

$m->set('counter', 'abc');
$n = $m->increment('counter');
// ^ will fail due to item value not being numeric
var_dump($n);
?>

Yukarıdaki örneğin çıktısı:

int(4)
int(0)
int(0)
bool(false)

Ayrıca Bakınız

  • Memcached::increment() - Increment numeric item's value
  • Memcached::incrementByKey() - Increment numeric item's value, stored on a specific server
  • Memcached::decrementByKey() - Decrement numeric item's value, stored on a specific server

Memcached::__construct
Memcached::decrementByKey
Memcached


Decrement numeric item's value, stored on a specific server

Memcached::decrement
Memcached::delete
Memcached
PHP Manual

Memcached::decrementByKey

(PECL memcached >= 2.0.0)

Memcached::decrementByKey — Decrement numeric item's value, stored on a specific server

Açıklama

public int Memcached::decrementByKey ( string $server_key , string $key [, int $offset = 1 [, int $initial_value = 0 [, int $expiry = 0 ]]] )

Memcached::decrementByKey() decrements a numeric item's value by the specified offset. If the item's value is not numeric, an error will result. If the operation would decrease the value below 0, the new value will be 0. Memcached::decrementByKey() will set the item to the initial_value parameter if the key doesn't exist.

Değiştirgeler

server_key

The key identifying the server to store the value on or retrieve it from. Instead of hashing on the actual key for the item, we hash on the server key when deciding which memcached server to talk to. This allows related items to be grouped together on a single server for efficiency with multi operations.

key

The key of the item to decrement.

offset

The amount by which to decrement the item's value.

initial_value

The value to set the item to if it doesn't currently exist.

expiry

The expiry time to set on the item.

Dönen Değerler

Returns item's new value on success başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • Memcached::decrement() - Decrement numeric item's value
  • Memcached::increment() - Increment numeric item's value
  • Memcached::incrementByKey() - Increment numeric item's value, stored on a specific server

Memcached::decrement
Memcached::delete
Memcached


Delete an item

Memcached::decrementByKey
Memcached::deleteByKey
Memcached
PHP Manual

Memcached::delete

(PECL memcached >= 0.1.0)

Memcached::delete — Delete an item

Açıklama

public bool Memcached::delete ( string $key [, int $time = 0 ] )

Memcached::delete() deletes the key from the server. The time parameter is the amount of time in seconds (or Unix time until which) the client wishes the server to refuse add and replace commands for this key. For this amount of time, the item is put into a delete queue, which means that it won't possible to retrieve it by the get command, but add and replace command with this key will also fail (the set command will succeed, however). After the time passes, the item is finally deleted from server memory. The parameter time defaults to 0 (which means that the item will be deleted immediately and further storage commands with this key will succeed).

Değiştirgeler

key

The key to be deleted.

time

The amount of time the server will wait to delete the item.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. The Memcached::getResultCode() will return Memcached::RES_NOTFOUND if the key does not exist.

Örnekler

Örnek 1 Memcached::delete() example

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

$m->delete('key1');
?>

Ayrıca Bakınız

  • Memcached::deleteByKey() - Delete an item from a specific server
  • Memcached::deleteMulti() - Delete multiple items

Memcached::decrementByKey
Memcached::deleteByKey
Memcached


Delete an item from a specific server

Memcached::delete
Memcached::deleteMulti
Memcached
PHP Manual

Memcached::deleteByKey

(PECL memcached >= 0.1.0)

Memcached::deleteByKey — Delete an item from a specific server

Açıklama

public bool Memcached::deleteByKey ( string $server_key , string $key [, int $time = 0 ] )

Memcached::deleteByKey() is functionally equivalent to Memcached::delete(), except that the free-form server_key can be used to map the key to a specific server.

Değiştirgeler

server_key

The key identifying the server to store the value on or retrieve it from. Instead of hashing on the actual key for the item, we hash on the server key when deciding which memcached server to talk to. This allows related items to be grouped together on a single server for efficiency with multi operations.

key

The key to be deleted.

time

The amount of time the server will wait to delete the item.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. The Memcached::getResultCode() will return Memcached::RES_NOTFOUND if the key does not exist.

Ayrıca Bakınız

  • Memcached::delete() - Delete an item
  • Memcached::deleteMulti() - Delete multiple items
  • Memcached::deleteMultiByKey() - Delete multiple items from a specific server

Memcached::delete
Memcached::deleteMulti
Memcached


Delete multiple items

Memcached::deleteByKey
Memcached::deleteMultiByKey
Memcached
PHP Manual

Memcached::deleteMulti

(PECL memcached >= 2.0.0)

Memcached::deleteMulti — Delete multiple items

Açıklama

public array Memcached::deleteMulti ( array $keys [, int $time = 0 ] )

Memcached::deleteMulti() deletes the array of keys from the server. The time parameter is the amount of time in seconds (or Unix time until which) the client wishes the server to refuse add and replace commands for these keys. For this amount of time, the item is put into a delete queue, which means that it won't be possible to retrieve it by the get command, but add and replace command with these keys will also fail (the set command will succeed, however). After the time passes, the item is finally deleted from server memory. The parameter time defaults to 0 (which means that the item will be deleted immediately and further storage commands with these keys will succeed).

Değiştirgeler

keys

The keys to be deleted.

time

The amount of time the server will wait to delete the items.

Dönen Değerler

Returns array indexed by keys and where values are indicating whether operation succeeded or not. The Memcached::getResultCode() will return Memcached::RES_NOTFOUND if the key does not exist.

Ayrıca Bakınız

  • Memcached::delete() - Delete an item
  • Memcached::deleteByKey() - Delete an item from a specific server
  • Memcached::deleteMultiByKey() - Delete multiple items from a specific server

Memcached::deleteByKey
Memcached::deleteMultiByKey
Memcached


Delete multiple items from a specific server

Memcached::deleteMulti
Memcached::fetch
Memcached
PHP Manual

Memcached::deleteMultiByKey

(PECL memcached >= 2.0.0)

Memcached::deleteMultiByKey — Delete multiple items from a specific server

Açıklama

public bool Memcached::deleteMultiByKey ( string $server_key , array $keys [, int $time = 0 ] )

Memcached::deleteMultiByKey() is functionally equivalent to Memcached::deleteMulti(), except that the free-form server_key can be used to map the keys to a specific server.

Değiştirgeler

server_key

The key identifying the server to store the value on or retrieve it from. Instead of hashing on the actual key for the item, we hash on the server key when deciding which memcached server to talk to. This allows related items to be grouped together on a single server for efficiency with multi operations.

keys

The keys to be deleted.

time

The amount of time the server will wait to delete the items.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. The Memcached::getResultCode() will return Memcached::RES_NOTFOUND if the key does not exist.

Ayrıca Bakınız

  • Memcached::delete() - Delete an item
  • Memcached::deleteByKey() - Delete an item from a specific server
  • Memcached::deleteMulti() - Delete multiple items

Memcached::deleteMulti
Memcached::fetch
Memcached


Fetch the next result

Memcached::deleteMultiByKey
Memcached::fetchAll
Memcached
PHP Manual

Memcached::fetch

(PECL memcached >= 0.1.0)

Memcached::fetch — Fetch the next result

Açıklama

public array Memcached::fetch ( void )

Memcached::fetch() retrieves the next result from the last request.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the next result or FALSE otherwise. The Memcached::getResultCode() will return Memcached::RES_END if result set is exhausted.

Örnekler

Örnek 1 Memcached::fetch() example

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

$m->set('int', 99);
$m->set('string', 'a simple string');
$m->set('array', array(11, 12));

$m->getDelayed(array('int', 'array'), true);
while ($result = $m->fetch()) {
    var_dump($result);
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(3) {
  ["key"]=>
  string(3) "int"
  "value"]=>
  int(99)
  ["cas"]=>
  float(2363)
}
array(3) {
  ["key"]=>
  string(5) "array"
  ["value"]=>
  array(2) {
    [0]=>
    int(11)
    [1]=>
    int(12)
  }
  ["cas"]=>
  float(2365)
}

Ayrıca Bakınız

  • Memcached::fetchAll() - Fetch all the remaining results
  • Memcached::getDelayed() - Request multiple items

Memcached::deleteMultiByKey
Memcached::fetchAll
Memcached


Fetch all the remaining results

Memcached::fetch
Memcached::flush
Memcached
PHP Manual

Memcached::fetchAll

(PECL memcached >= 0.1.0)

Memcached::fetchAll — Fetch all the remaining results

Açıklama

public array Memcached::fetchAll ( void )

Memcached::fetchAll() retrieves all the remaining results from the last request.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the results başarısızlık durumunda FALSE döner. Gerekirse Memcached::getResultCode() kullanın.

Örnekler

Örnek 1 Memcached::getDelayed() example

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

$m->set('int', 99);
$m->set('string', 'a simple string');
$m->set('array', array(11, 12));

$m->getDelayed(array('int', 'array'), true);
var_dump($m->fetchAll());
?>

Yukarıdaki örneğin çıktısı:

array(2) {
  [0]=>
  array(3) {
    ["key"]=>
    string(3) "int"
    ["value"]=>
    int(99)
    ["cas"]=>
    float(2363)
  }
  [1]=>
  array(3) {
    ["key"]=>
    string(5) "array"
    ["value"]=>
    array(2) {
      [0]=>
      int(11)
      [1]=>
      int(12)
    }
    ["cas"]=>
    float(2365)
  }
}

Ayrıca Bakınız

  • Memcached::fetch() - Fetch the next result
  • Memcached::getDelayed() - Request multiple items

Memcached::fetch
Memcached::flush
Memcached


Invalidate all items in the cache

Memcached::fetchAll
Memcached::get
Memcached
PHP Manual

Memcached::flush

(PECL memcached >= 0.1.0)

Memcached::flush — Invalidate all items in the cache

Açıklama

public bool Memcached::flush ([ int $delay = 0 ] )

Memcached::flush() invalidates all existing cache items immediately (by default) or after the delay specified. After invalidation none of the items will be returned in response to a retrieval command (unless it's stored again under the same key after Memcached::flush() has invalidated the items). The flush does not actually free all the memory taken up by the existing items; that will happen gradually as new items are stored.

Değiştirgeler

delay

Number of seconds to wait before invalidating the items.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. Gerekirse Memcached::getResultCode() kullanın.

Örnekler

Örnek 1 Memcached::flush() example

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

/* flush all items in 10 seconds */
$m->flush(10);
?>

Memcached::fetchAll
Memcached::get
Memcached


Retrieve an item

Memcached::flush
Memcached::getAllKeys
Memcached
PHP Manual

Memcached::get

(PECL memcached >= 0.1.0)

Memcached::get — Retrieve an item

Açıklama

public mixed Memcached::get ( string $key [, callable $cache_cb [, float &$cas_token ]] )

Memcached::get() returns the item that was previously stored under the key. If the item is found and cas_token variable is provided, it will contain the CAS token value for the item. See Memcached::cas() for how to use CAS tokens. Read-through caching callback may be specified via cache_cb parameter.

Değiştirgeler

key

The key of the item to retrieve.

cache_cb

Read-through caching callback or NULL.

cas_token

The variable to store the CAS token in.

Dönen Değerler

Returns the value stored in the cache or FALSE otherwise. The Memcached::getResultCode() will return Memcached::RES_NOTFOUND if the key does not exist.

Örnekler

Örnek 1 Memcached::get() example #1

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

$m->set('foo', 100);
var_dump($m->get('foo'));
?>

Yukarıdaki örneğin çıktısı:

int(100)

Örnek 2 Memcached::get() example #2

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

if (!($ip = $m->get('ip_block'))) {
    if ($m->getResultCode() == Memcached::RES_NOTFOUND) {
        $ip = array();
        $m->set('ip_block', $ip);
    } else {
        /* log error */
        /* ...       */
    }
}
?>

Ayrıca Bakınız

  • Memcached::getByKey() - Retrieve an item from a specific server
  • Memcached::getMulti() - Retrieve multiple items
  • Memcached::getDelayed() - Request multiple items

Memcached::flush
Memcached::getAllKeys
Memcached


Gets the keys stored on all the servers

Memcached::get
Memcached::getByKey
Memcached
PHP Manual

Memcached::getAllKeys

(PECL memcached >= 2.0.0)

Memcached::getAllKeys — Gets the keys stored on all the servers

Açıklama

public array Memcached::getAllKeys ( void )

Memcached::getAllKeys() queries each memcache server and retrieves an array of all keys stored on them at that point in time. This is not an atomic operation, so it isn't a truly consistent snapshot of the keys at point in time. As memcache doesn't guarantee to return all keys you also cannot assume that all keys have been returned.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the keys stored on all the servers on success başarısızlık durumunda FALSE döner.

Memcached::get
Memcached::getByKey
Memcached


Retrieve an item from a specific server

Memcached::getAllKeys
Memcached::getDelayed
Memcached
PHP Manual

Memcached::getByKey

(PECL memcached >= 0.1.0)

Memcached::getByKey — Retrieve an item from a specific server

Açıklama

public mixed Memcached::getByKey ( string $server_key , string $key [, callable $cache_cb [, float &$cas_token ]] )

Memcached::getByKey() is functionally equivalent to Memcached::get(), except that the free-form server_key can be used to map the key to a specific server.

Değiştirgeler

server_key

The key identifying the server to store the value on or retrieve it from. Instead of hashing on the actual key for the item, we hash on the server key when deciding which memcached server to talk to. This allows related items to be grouped together on a single server for efficiency with multi operations.

key

The key of the item to fetch.

cache_cb

Read-through caching callback or NULL

cas_token

The variable to store the CAS token in.

Dönen Değerler

Returns the value stored in the cache or FALSE otherwise. The Memcached::getResultCode() will return Memcached::RES_NOTFOUND if the key does not exist.

Ayrıca Bakınız

  • Memcached::get() - Retrieve an item
  • Memcached::getMulti() - Retrieve multiple items
  • Memcached::getDelayed() - Request multiple items

Memcached::getAllKeys
Memcached::getDelayed
Memcached


Request multiple items

Memcached::getByKey
Memcached::getDelayedByKey
Memcached
PHP Manual

Memcached::getDelayed

(PECL memcached >= 0.1.0)

Memcached::getDelayed — Request multiple items

Açıklama

public bool Memcached::getDelayed ( array $keys [, bool $with_cas [, callable $value_cb ]] )

Memcached::getDelayed() issues a request to memcache for multiple items the keys of which are specified in the keys array. The method does not wait for response and returns right away. When you are ready to collect the items, call either Memcached::fetch() or Memcached::fetchAll(). If with_cas is true, the CAS token values will also be requested.

Instead of fetching the results explicitly, you can specify a result callback via value_cb parameter.

Değiştirgeler

keys

Array of keys to request.

with_cas

Whether to request CAS token values also.

value_cb

The result callback or NULL.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. Gerekirse Memcached::getResultCode() kullanın.

Örnekler

Örnek 1 Memcached::getDelayed() example

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

$m->set('int', 99);
$m->set('string', 'a simple string');
$m->set('array', array(11, 12));

$m->getDelayed(array('int', 'array'), true);
var_dump($m->fetchAll());
?>

Yukarıdaki örneğin çıktısı:

array(2) {
  [0]=>
  array(3) {
    ["key"]=>
    string(3) "int"
    ["value"]=>
    int(99)
    ["cas"]=>
    float(2363)
  }
  [1]=>
  array(3) {
    ["key"]=>
    string(5) "array"
    ["value"]=>
    array(2) {
      [0]=>
      int(11)
      [1]=>
      int(12)
    }
    ["cas"]=>
    float(2365)
  }
}

Ayrıca Bakınız

  • Memcached::getDelayedByKey() - Request multiple items from a specific server
  • Memcached::fetch() - Fetch the next result
  • Memcached::fetchAll() - Fetch all the remaining results

Memcached::getByKey
Memcached::getDelayedByKey
Memcached


Request multiple items from a specific server

Memcached::getDelayed
Memcached::getMulti
Memcached
PHP Manual

Memcached::getDelayedByKey

(PECL memcached >= 0.1.0)

Memcached::getDelayedByKey — Request multiple items from a specific server

Açıklama

public bool Memcached::getDelayedByKey ( string $server_key , array $keys [, bool $with_cas [, callable $value_cb ]] )

Memcached::getDelayedByKey() is functionally equivalent to Memcached::getDelayed(), except that the free-form server_key can be used to map the keys to a specific server.

Değiştirgeler

server_key

The key identifying the server to store the value on or retrieve it from. Instead of hashing on the actual key for the item, we hash on the server key when deciding which memcached server to talk to. This allows related items to be grouped together on a single server for efficiency with multi operations.

keys

Array of keys to request.

with_cas

Whether to request CAS token values also.

value_cb

The result callback or NULL.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. Gerekirse Memcached::getResultCode() kullanın.

Ayrıca Bakınız

  • Memcached::getDelayed() - Request multiple items
  • Memcached::fetch() - Fetch the next result
  • Memcached::fetchAll() - Fetch all the remaining results

Memcached::getDelayed
Memcached::getMulti
Memcached


Retrieve multiple items

Memcached::getDelayedByKey
Memcached::getMultiByKey
Memcached
PHP Manual

Memcached::getMulti

(PECL memcached >= 0.1.0)

Memcached::getMulti — Retrieve multiple items

Açıklama

public mixed Memcached::getMulti ( array $keys [, array &$cas_tokens [, int $flags ]] )

Memcached::getMulti() is similar to Memcached::get(), but instead of a single key item, it retrieves multiple items the keys of which are specified in the keys array. If cas_tokens variable is provided, it is filled with the CAS token values for the found items.

Bilginize:

Unlike Memcached::get() it is not possible to specify a read-through cache callback for Memcached::getMulti(), because the memcache protocol does not provide information on which keys were not found in the multi-key request.

The flags parameter can be used to specify additional options for Memcached::getMulti(). Currently, the only available option is Memcached::GET_PRESERVE_ORDER that ensures that the keys are returned in the same order as they were requested in.

Değiştirgeler

keys

Array of keys to retrieve.

cas_tokens

The variable to store the CAS tokens for the found items.

flags

The flags for the get operation.

Dönen Değerler

Returns the array of found items başarısızlık durumunda FALSE döner. Gerekirse Memcached::getResultCode() kullanın.

Örnekler

Örnek 1 Memcached::getMulti() example

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

$items = array(
    'key1' => 'value1',
    'key2' => 'value2',
    'key3' => 'value3'
);
$m->setMulti($items);
$result = $m->getMulti(array('key1', 'key3', 'badkey'), $cas);
var_dump($result, $cas);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(2) {
  ["key1"]=>
  string(6) "value1"
  ["key3"]=>
  string(6) "value3"
}
array(2) {
  ["key1"]=>
  float(2360)
  ["key3"]=>
  float(2362)
}

Örnek 2 Memcached::GET_PRESERVE_ORDER example

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

$data = array(
    'foo' => 'foo-data',
    'bar' => 'bar-data',
    'baz' => 'baz-data',
    'lol' => 'lol-data',
    'kek' => 'kek-data',
);

$m->setMulti($data, 3600);

$null = null;
$keys = array_keys($data);
$keys[] = 'zoo';
$got = $m->getMulti($keys, $null, Memcached::GET_PRESERVE_ORDER);

foreach ($got as $k => $v) {
    echo "$k $v\n";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

foo foo-data
bar bar-data
baz baz-data
lol lol-data
kek kek-data
zoo

Ayrıca Bakınız

  • Memcached::getMultiByKey() - Retrieve multiple items from a specific server
  • Memcached::get() - Retrieve an item
  • Memcached::getDelayed() - Request multiple items

Memcached::getDelayedByKey
Memcached::getMultiByKey
Memcached


Retrieve multiple items from a specific server

Memcached::getMulti
Memcached::getOption
Memcached
PHP Manual

Memcached::getMultiByKey

(PECL memcached >= 0.1.0)

Memcached::getMultiByKey — Retrieve multiple items from a specific server

Açıklama

public array Memcached::getMultiByKey ( string $server_key , array $keys [, string &$cas_tokens [, int $flags ]] )

Memcached::getMultiByKey() is functionally equivalent to Memcached::getMulti(), except that the free-form server_key can be used to map the keys to a specific server.

Değiştirgeler

server_key

The key identifying the server to store the value on or retrieve it from. Instead of hashing on the actual key for the item, we hash on the server key when deciding which memcached server to talk to. This allows related items to be grouped together on a single server for efficiency with multi operations.

keys

Array of keys to retrieve.

cas_tokens

The variable to store the CAS tokens for the found items.

flags

The flags for the get operation.

Dönen Değerler

Returns the array of found items başarısızlık durumunda FALSE döner. Gerekirse Memcached::getResultCode() kullanın.

Ayrıca Bakınız

  • Memcached::getMulti() - Retrieve multiple items
  • Memcached::get() - Retrieve an item
  • Memcached::getDelayed() - Request multiple items

Memcached::getMulti
Memcached::getOption
Memcached


Retrieve a Memcached option value

Memcached::getMultiByKey
Memcached::getResultCode
Memcached
PHP Manual

Memcached::getOption

(PECL memcached >= 0.1.0)

Memcached::getOption — Retrieve a Memcached option value

Açıklama

public mixed Memcached::getOption ( int $option )

This method returns the value of a Memcached option. Some options correspond to the ones defined by libmemcached, and some are specific to the extension. See Memcached Constants for more information.

Değiştirgeler

option

One of the Memcached::OPT_* constants.

Dönen Değerler

Returns the value of the requested option, or FALSE on error.

Örnekler

Örnek 1 Retrieving Memcached options

<?php
$m = new Memcached();
var_dump($m->getOption(Memcached::OPT_COMPRESSION));
var_dump($m->getOption(Memcached::OPT_POLL_TIMEOUT));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(true)
int(1000)

Ayrıca Bakınız

  • Memcached::getOption()
  • Memcached::setOption() - Set a Memcached option
  • Memcached Constants

Memcached::getMultiByKey
Memcached::getResultCode
Memcached


Return the result code of the last operation

Memcached::getOption
Memcached::getResultMessage
Memcached
PHP Manual

Memcached::getResultCode

(PECL memcached >= 0.1.0)

Memcached::getResultCode — Return the result code of the last operation

Açıklama

public int Memcached::getResultCode ( void )

Memcached::getResultCode() returns one of the Memcached::RES_* constants that is the result of the last executed Memcached method.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Result code of the last Memcached operation.

Örnekler

Örnek 1 Memcached::getResultCode() example

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

$m->add('foo', 'bar');
if ($m->getResultCode() == Memcached::RES_NOTSTORED) {
    /* ... */
}
?>

Memcached::getOption
Memcached::getResultMessage
Memcached


Return the message describing the result of the last operation

Memcached::getResultCode
Memcached::getServerByKey
Memcached
PHP Manual

Memcached::getResultMessage

(PECL memcached >= 1.0.0)

Memcached::getResultMessage — Return the message describing the result of the last operation

Açıklama

public string Memcached::getResultMessage ( void )

Memcached::getResultMessage() returns a string that describes the result code of the last executed Memcached method.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Message describing the result of the last Memcached operation.

Örnekler

Örnek 1 Memcached::getResultMessage() example

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

$m->add('foo', 'bar'); // first time should succeed
$m->add('foo', 'bar');
echo $m->getResultMessage(),"\n";
?>

Yukarıdaki örneğin çıktısı:

NOT STORED

Memcached::getResultCode
Memcached::getServerByKey
Memcached


Map a key to a server

Memcached::getResultMessage
Memcached::getServerList
Memcached
PHP Manual

Memcached::getServerByKey

(PECL memcached >= 0.1.0)

Memcached::getServerByKey — Map a key to a server

Açıklama

public array Memcached::getServerByKey ( string $server_key )

Memcached::getServerByKey() returns the server that would be selected by a particular server_key in all the Memcached::*ByKey() operations.

Değiştirgeler

server_key

The key identifying the server to store the value on or retrieve it from. Instead of hashing on the actual key for the item, we hash on the server key when deciding which memcached server to talk to. This allows related items to be grouped together on a single server for efficiency with multi operations.

Dönen Değerler

Returns an array containing three keys of host, port, and weight on success or FALSE on failure. Gerekirse Memcached::getResultCode() kullanın.

Örnekler

Örnek 1 Memcached::getServerByKey() example

<?php
$m = new Memcached();
$m->addServers(array(
    array('mem1.domain.com', 11211, 40),
    array('mem2.domain.com', 11211, 40),
    array('mem3.domain.com', 11211, 20),
));

$m->setOption(Memcached::OPT_LIBKETAMA_COMPATIBLE, true);

var_dump($m->getServerByKey('user'));
var_dump($m->getServerByKey('log'));
var_dump($m->getServerByKey('ip'));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(3) {
  ["host"]=>
  string(15) "mem3.domain.com"
  ["port"]=>
  int(11211)
  ["weight"]=>
  int(20)
}
array(3) {
  ["host"]=>
  string(15) "mem2.domain.com"
  ["port"]=>
  int(11211)
  ["weight"]=>
  int(40)
}
array(3) {
  ["host"]=>
  string(15) "mem2.domain.com"
  ["port"]=>
  int(11211)
  ["weight"]=>
  int(40)
}

Memcached::getResultMessage
Memcached::getServerList
Memcached


Get the list of the servers in the pool

Memcached::getServerByKey
Memcached::getStats
Memcached
PHP Manual

Memcached::getServerList

(PECL memcached >= 0.1.0)

Memcached::getServerList — Get the list of the servers in the pool

Açıklama

public array Memcached::getServerList ( void )

Memcached::getServerList() returns the list of all servers that are in its server pool.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The list of all servers in the server pool.

Örnekler

Örnek 1 Memcached::getServerList() example

<?php
$m = new Memcached();
$m->addServers(array(
    array('mem1.domain.com', 11211, 20),
    array('mem2.domain.com', 11311, 80),
));
var_dump($m->getServerList());
?>

Yukarıdaki örneğin çıktısı:

array(2) {
  [0]=>
  array(3) {
    ["host"]=>
    string(15) "mem1.domain.com"
    ["port"]=>
    int(11211)
    ["weight"]=>
    int(20)
  }
  [1]=>
  array(3) {
    ["host"]=>
    string(15) "mem2.domain.com"
    ["port"]=>
    int(11311)
    ["weight"]=>
    int(80)
  }
}

Memcached::getServerByKey
Memcached::getStats
Memcached


Get server pool statistics

Memcached::getServerList
Memcached::getVersion
Memcached
PHP Manual

Memcached::getStats

(PECL memcached >= 0.1.0)

Memcached::getStats — Get server pool statistics

Açıklama

public array Memcached::getStats ( void )

Memcached::getStats() returns an array containing the state of all available memcache servers. See » memcache protocol specification for details on these statistics.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Array of server statistics, one entry per server.

Örnekler

Örnek 1 Memcached::getStats() example

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

print_r($m->getStats());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [localhost:11211] => Array
        (
            [pid] => 4933
            [uptime] => 786123
            [threads] => 1
            [time] => 1233868010
            [pointer_size] => 32
            [rusage_user_seconds] => 0
            [rusage_user_microseconds] => 140000
            [rusage_system_seconds] => 23
            [rusage_system_microseconds] => 210000
            [curr_items] => 145
            [total_items] => 2374
            [limit_maxbytes] => 67108864
            [curr_connections] => 2
            [total_connections] => 151
            [connection_structures] => 3
            [bytes] => 20345
            [cmd_get] => 213343
            [cmd_set] => 2381
            [get_hits] => 204223
            [get_misses] => 9120
            [evictions] => 0
            [bytes_read] => 9092476
            [bytes_written] => 15420512
            [version] => 1.2.6
        )

)

Memcached::getServerList
Memcached::getVersion
Memcached


Get server pool version info

Memcached::getStats
Memcached::increment
Memcached
PHP Manual

Memcached::getVersion

(PECL memcached >= 0.1.5)

Memcached::getVersion — Get server pool version info

Açıklama

public array Memcached::getVersion ( void )

Memcached::getVersion() returns an array containing the version info for all available memcache servers.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Array of server versions, one entry per server.

Örnekler

Örnek 1 Memcached::getVersion() example

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

print_r($m->getVersion());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [localhost:11211] => 1.2.6
)

Memcached::getStats
Memcached::increment
Memcached


Increment numeric item's value

Memcached::getVersion
Memcached::incrementByKey
Memcached
PHP Manual

Memcached::increment

(PECL memcached >= 0.1.0)

Memcached::increment — Increment numeric item's value

Açıklama

public int Memcached::increment ( string $key [, int $offset = 1 [, int $initial_value = 0 [, int $expiry = 0 ]]] )

Memcached::increment() increments a numeric item's value by the specified offset. If the item's value is not numeric, an error will result. Memcached::increment() will set the item to the initial_value parameter if the key doesn't exist.

Değiştirgeler

key

The key of the item to increment.

offset

The amount by which to increment the item's value.

initial_value

The value to set the item to if it doesn't currently exist.

expiry

The expiry time to set on the item.

Dönen Değerler

Returns new item's value on success başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Memcached::increment() example

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

$m->set('counter', 0);
$m->increment('counter');
$n = $m->increment('counter', 10);
var_dump($n);

$m->set('counter', 'abc');
$n = $m->increment('counter');
// ^ will fail due to item value not being numeric
var_dump($n);
?>

Yukarıdaki örneğin çıktısı:

int(11)
bool(false)

Ayrıca Bakınız

  • Memcached::decrement() - Decrement numeric item's value
  • Memcached::decrementByKey() - Decrement numeric item's value, stored on a specific server
  • Memcached::incrementByKey() - Increment numeric item's value, stored on a specific server

Memcached::getVersion
Memcached::incrementByKey
Memcached


Increment numeric item's value, stored on a specific server

Memcached::increment
Memcached::isPersistent
Memcached
PHP Manual

Memcached::incrementByKey

(PECL memcached >= 2.0.0)

Memcached::incrementByKey — Increment numeric item's value, stored on a specific server

Açıklama

public int Memcached::incrementByKey ( string $server_key , string $key [, int $offset = 1 [, int $initial_value = 0 [, int $expiry = 0 ]]] )

Memcached::incrementByKey() increments a numeric item's value by the specified offset. If the item's value is not numeric, an error will result. Memcached::incrementByKey() will set the item to the initial_value parameter if the key doesn't exist.

Değiştirgeler

server_key

The key identifying the server to store the value on or retrieve it from. Instead of hashing on the actual key for the item, we hash on the server key when deciding which memcached server to talk to. This allows related items to be grouped together on a single server for efficiency with multi operations.

key

The key of the item to increment.

offset

The amount by which to increment the item's value.

initial_value

The value to set the item to if it doesn't currently exist.

expiry

The expiry time to set on the item.

Dönen Değerler

Returns new item's value on success başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • Memcached::decrement() - Decrement numeric item's value
  • Memcached::decrementByKey() - Decrement numeric item's value, stored on a specific server
  • Memcached::increment() - Increment numeric item's value

Memcached::increment
Memcached::isPersistent
Memcached


Check if a persitent connection to memcache is being used

Memcached::incrementByKey
Memcached::isPristine
Memcached
PHP Manual

Memcached::isPersistent

(PECL memcached >= 2.0.0)

Memcached::isPersistent — Check if a persitent connection to memcache is being used

Açıklama

public bool Memcached::isPersistent ( void )

Memcached::isPersistent() checks if the connections to the memcache servers are persistent connections.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns true if Memcache instance uses a persistent connection, false otherwise.

Ayrıca Bakınız

  • Memcached::isPristine() - Check if the instance was recently created

Memcached::incrementByKey
Memcached::isPristine
Memcached


Check if the instance was recently created

Memcached::isPersistent
Memcached::prepend
Memcached
PHP Manual

Memcached::isPristine

(PECL memcached >= 2.0.0)

Memcached::isPristine — Check if the instance was recently created

Açıklama

public bool Memcached::isPristine ( void )

Memcached::isPristine() checks if the Memcache instance was recently created.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the true if instance is recently created, false otherwise.

Ayrıca Bakınız

  • Memcached::isPersistent() - Check if a persitent connection to memcache is being used

Memcached::isPersistent
Memcached::prepend
Memcached


Prepend data to an existing item

Memcached::isPristine
Memcached::prependByKey
Memcached
PHP Manual

Memcached::prepend

(PECL memcached >= 0.1.0)

Memcached::prepend — Prepend data to an existing item

Açıklama

public bool Memcached::prepend ( string $key , string $value )

Memcached::prepend() prepends the given value string to the value of an existing item. The reason that value is forced to be a string is that prepending mixed types is not well-defined.

Bilginize:

If the Memcached::OPT_COMPRESSION is enabled, the operation will fail and a warning will be issued, because prepending compressed data to a value that is potentially already compressed is not possible.

Değiştirgeler

key

The key of the item to prepend the data to.

value

The string to prepend.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. The Memcached::getResultCode() will return Memcached::RES_NOTSTORED if the key does not exist.

Örnekler

Örnek 1 Memcached::prepend() example

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);
$m->setOption(Memcached::OPT_COMPRESSION, false);

$m->set('foo', 'abc');
$m->prepend('foo', 'def');
var_dump($m->get('foo'));
?>

Yukarıdaki örneğin çıktısı:

string(6) "defabc"

Ayrıca Bakınız

  • Memcached::prependByKey() - Prepend data to an existing item on a specific server
  • Memcached::append() - Append data to an existing item

Memcached::isPristine
Memcached::prependByKey
Memcached


Prepend data to an existing item on a specific server

Memcached::prepend
Memcached::quit
Memcached
PHP Manual

Memcached::prependByKey

(PECL memcached >= 0.1.0)

Memcached::prependByKey — Prepend data to an existing item on a specific server

Açıklama

public bool Memcached::prependByKey ( string $server_key , string $key , string $value )

Memcached::prependByKey() is functionally equivalent to Memcached::prepend(), except that the free-form server_key can be used to map the key to a specific server.

Değiştirgeler

server_key

The key identifying the server to store the value on or retrieve it from. Instead of hashing on the actual key for the item, we hash on the server key when deciding which memcached server to talk to. This allows related items to be grouped together on a single server for efficiency with multi operations.

key

The key of the item to prepend the data to.

value

The string to prepend.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. The Memcached::getResultCode() will return Memcached::RES_NOTSTORED if the key does not exist.

Ayrıca Bakınız

  • Memcached::prepend() - Prepend data to an existing item
  • Memcached::append() - Append data to an existing item

Memcached::prepend
Memcached::quit
Memcached


Close any open connections

Memcached::prependByKey
Memcached::replace
Memcached
PHP Manual

Memcached::quit

(PECL memcached >= 2.0.0)

Memcached::quit — Close any open connections

Açıklama

public bool Memcached::quit ( void )

Memcached::quit() closes any open connections to the memcache servers.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Memcached::prependByKey
Memcached::replace
Memcached


Replace the item under an existing key

Memcached::quit
Memcached::replaceByKey
Memcached
PHP Manual

Memcached::replace

(PECL memcached >= 0.1.0)

Memcached::replace — Replace the item under an existing key

Açıklama

public bool Memcached::replace ( string $key , mixed $value [, int $expiration ] )

Memcached::replace() is similar to Memcached::set(), but the operation fails if the key does not exist on the server.

Değiştirgeler

key

Değerin saklanacağı anahtar.

value

Saklanacak değer.

expiration

Zaman aşımı, öntanımlı 0'dır. Daha ayrıntılı bilgi için Zaman aşımı süreleri bölümüne bakınız.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. The Memcached::getResultCode() will return Memcached::RES_NOTSTORED if the key does not exist.

Ayrıca Bakınız

  • Memcached::replaceByKey() - Replace the item under an existing key on a specific server
  • Memcached::set() - Store an item
  • Memcached::add() - Add an item under a new key

Memcached::quit
Memcached::replaceByKey
Memcached


Replace the item under an existing key on a specific server

Memcached::replace
Memcached::resetServerList
Memcached
PHP Manual

Memcached::replaceByKey

(PECL memcached >= 0.1.0)

Memcached::replaceByKey — Replace the item under an existing key on a specific server

Açıklama

public bool Memcached::replaceByKey ( string $server_key , string $key , mixed $value [, int $expiration ] )

Memcached::replaceByKey() is functionally equivalent to Memcached::replace(), except that the free-form server_key can be used to map the key to a specific server. This is useful if you need to keep a bunch of related keys on a certain server.

Değiştirgeler

server_key

The key identifying the server to store the value on or retrieve it from. Instead of hashing on the actual key for the item, we hash on the server key when deciding which memcached server to talk to. This allows related items to be grouped together on a single server for efficiency with multi operations.

key

Değerin saklanacağı anahtar.

value

Saklanacak değer.

expiration

Zaman aşımı, öntanımlı 0'dır. Daha ayrıntılı bilgi için Zaman aşımı süreleri bölümüne bakınız.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. The Memcached::getResultCode() will return Memcached::RES_NOTSTORED if the key does not exist.

Ayrıca Bakınız

  • Memcached::replace() - Replace the item under an existing key
  • Memcached::set() - Store an item
  • Memcached::add() - Add an item under a new key

Memcached::replace
Memcached::resetServerList
Memcached


Clears all servers from the server list

Memcached::replaceByKey
Memcached::set
Memcached
PHP Manual

Memcached::resetServerList

(PECL memcached >= 2.0.0)

Memcached::resetServerList — Clears all servers from the server list

Açıklama

public bool Memcached::resetServerList ( void )

Memcached::resetserverlist() removes all memcache servers from the known server list, reseting it back to empty.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • Memcached::addServer() - Add a server to the server pool
  • Memcached::addServers() - Add multiple servers to the server pool

Memcached::replaceByKey
Memcached::set
Memcached


Store an item

Memcached::resetServerList
Memcached::setByKey
Memcached
PHP Manual

Memcached::set

(PECL memcached >= 0.1.0)

Memcached::set — Store an item

Açıklama

public bool Memcached::set ( string $key , mixed $value [, int $expiration ] )

Memcached::set() stores the value on a memcache server under the specified key. The expiration parameter can be used to control when the value is considered expired.

The value can be any valid PHP type except for resources, because those cannot be represented in a serialized form. If the Memcached::OPT_COMPRESSION option is turned on, the serialized value will also be compressed before storage.

Değiştirgeler

key

Değerin saklanacağı anahtar.

value

Saklanacak değer.

expiration

Zaman aşımı, öntanımlı 0'dır. Daha ayrıntılı bilgi için Zaman aşımı süreleri bölümüne bakınız.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. Gerekirse Memcached::getResultCode() kullanın.

Örnekler

Örnek 1 Memcached::set() example

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

$m->set('int', 99);
$m->set('string', 'a simple string');
$m->set('array', array(11, 12));
/* expire 'object' key in 5 minutes */
$m->set('object', new stdclass, time() + 300);

var_dump($m->get('int'));
var_dump($m->get('string'));
var_dump($m->get('array'));
var_dump($m->get('object'));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(99)
string(15) "a simple string"
array(2) {
  [0]=>
  int(11)
  [1]=>
  int(12)
}
object(stdClass)#1 (0) {
}

Ayrıca Bakınız

  • Memcached::setByKey() - Store an item on a specific server
  • Memcached::add() - Add an item under a new key
  • Memcached::replace() - Replace the item under an existing key

Memcached::resetServerList
Memcached::setByKey
Memcached


Store an item on a specific server

Memcached::set
Memcached::setMulti
Memcached
PHP Manual

Memcached::setByKey

(PECL memcached >= 0.1.0)

Memcached::setByKey — Store an item on a specific server

Açıklama

public bool Memcached::setByKey ( string $server_key , string $key , mixed $value [, int $expiration ] )

Memcached::setByKey() is functionally equivalent to Memcached::set(), except that the free-form server_key can be used to map the key to a specific server. This is useful if you need to keep a bunch of related keys on a certain server.

Değiştirgeler

server_key

The key identifying the server to store the value on or retrieve it from. Instead of hashing on the actual key for the item, we hash on the server key when deciding which memcached server to talk to. This allows related items to be grouped together on a single server for efficiency with multi operations.

key

Değerin saklanacağı anahtar.

value

Saklanacak değer.

expiration

Zaman aşımı, öntanımlı 0'dır. Daha ayrıntılı bilgi için Zaman aşımı süreleri bölümüne bakınız.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. Gerekirse Memcached::getResultCode() kullanın.

Örnekler

Örnek 1 Memcached::setByKey() example

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

/* keep IP blocks on a certain server */
$m->setByKey('api-cache', 'block-ip:169.254.253.252', 1);
$m->setByKey('api-cache', 'block-ip:169.127.127.202', 1);
?>

Ayrıca Bakınız

  • Memcached::set() - Store an item

Memcached::set
Memcached::setMulti
Memcached


Store multiple items

Memcached::setByKey
Memcached::setMultiByKey
Memcached
PHP Manual

Memcached::setMulti

(PECL memcached >= 0.1.0)

Memcached::setMulti — Store multiple items

Açıklama

public bool Memcached::setMulti ( array $items [, int $expiration ] )

Memcached::setMulti() is similar to Memcached::set(), but instead of a single key/value item, it works on multiple items specified in items. The expiration time applies to all the items at once.

Değiştirgeler

items

Sunucuda saklanacak ilişkisel dizi.

expiration

Zaman aşımı, öntanımlı 0'dır. Daha ayrıntılı bilgi için Zaman aşımı süreleri bölümüne bakınız.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. Gerekirse Memcached::getResultCode() kullanın.

Örnekler

Örnek 1 Memcached::setMulti() example

<?php
$m = new Memcached();
$m->addServer('localhost', 11211);

$items = array(
    'key1' => 'value1',
    'key2' => 'value2',
    'key3' => 'value3'
);
$m->setMulti($items, time() + 300);
?>

Ayrıca Bakınız

  • Memcached::setMultiByKey() - Store multiple items on a specific server
  • Memcached::set() - Store an item

Memcached::setByKey
Memcached::setMultiByKey
Memcached


Store multiple items on a specific server

Memcached::setMulti
Memcached::setOption
Memcached
PHP Manual

Memcached::setMultiByKey

(PECL memcached >= 0.1.0)

Memcached::setMultiByKey — Store multiple items on a specific server

Açıklama

public bool Memcached::setMultiByKey ( string $server_key , array $items [, int $expiration ] )

Memcached::setMultiByKey() is functionally equivalent to Memcached::setMulti(), except that the free-form server_key can be used to map the keys from items to a specific server. This is useful if you need to keep a bunch of related keys on a certain server.

Değiştirgeler

server_key

The key identifying the server to store the value on or retrieve it from. Instead of hashing on the actual key for the item, we hash on the server key when deciding which memcached server to talk to. This allows related items to be grouped together on a single server for efficiency with multi operations.

items

Sunucuda saklanacak ilişkisel dizi.

expiration

Zaman aşımı, öntanımlı 0'dır. Daha ayrıntılı bilgi için Zaman aşımı süreleri bölümüne bakınız.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. Gerekirse Memcached::getResultCode() kullanın.

Ayrıca Bakınız

  • Memcached::setMulti() - Store multiple items
  • Memcached::set() - Store an item

Memcached::setMulti
Memcached::setOption
Memcached


Set a Memcached option

Memcached::setMultiByKey
Memcached::setOptions
Memcached
PHP Manual

Memcached::setOption

(PECL memcached >= 0.1.0)

Memcached::setOption — Set a Memcached option

Açıklama

public bool Memcached::setOption ( int $option , mixed $value )

This method sets the value of a Memcached option. Some options correspond to the ones defined by libmemcached, and some are specific to the extension. See Memcached Constants for more information.

The options listed below require values specified via constants.

  • Memcached::OPT_HASH requires Memcached::HASH_* values.

  • Memcached::OPT_DISTRIBUTION requires Memcached::DISTRIBUTION_* values.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Setting a Memcached option

<?php
$m = new Memcached();
var_dump($m->getOption(Memcached::OPT_HASH) == Memcached::HASH_DEFAULT);
$m->setOption(Memcached::OPT_HASH, Memcached::HASH_MURMUR);
$m->setOption(Memcached::OPT_PREFIX_KEY, "widgets");
echo "Prefix key is now: ", $m->getOption(Memcached::OPT_PREFIX_KEY), "\n";
?>

Yukarıdaki örneğin çıktısı:

bool(true)
Prefix key is now: widgets

Ayrıca Bakınız

  • Memcached::getOption() - Retrieve a Memcached option value
  • Memcached::setOptions() - Set Memcached options
  • Memcached Constants

Memcached::setMultiByKey
Memcached::setOptions
Memcached


Set Memcached options

Memcached::setOption
Memcached::setSaslAuthData
Memcached
PHP Manual

Memcached::setOptions

(PECL memcached >= 2.0.0)

Memcached::setOptions — Set Memcached options

Açıklama

public bool Memcached::setOptions ( array $options )

Memcached::setOptions() is a variation of the Memcached::setOption() that takes an array of options to be set.

Değiştirgeler

options

An associative array of options where the key is the option to set and the value is the new value for the option.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Setting Memcached options

<?php
$m = new Memcached();
var_dump($m->getOption(Memcached::OPT_HASH) == Memcached::HASH_DEFAULT);

$m->setOptions(array(Memcached::OPT_HASH => Memcached::HASH_MURMUR, Memcached::OPT_PREFIX_KEY => "widgets"));

var_dump($m->getOption(Memcached::OPT_HASH) == Memcached::HASH_DEFAULT);
echo "Prefix key is now: ", $m->getOption(Memcached::OPT_PREFIX_KEY), "\n";
?>

Yukarıdaki örneğin çıktısı:

bool(true)
bool(false)
Prefix key is now: widgets

Ayrıca Bakınız

  • Memcached::getOption() - Retrieve a Memcached option value
  • Memcached::setOption() - Set a Memcached option
  • Memcached Constants

Memcached::setOption
Memcached::setSaslAuthData
Memcached


Set the credentials to use for authentication

Memcached::setOptions
Memcached::touch
Memcached
PHP Manual

Memcached::setSaslAuthData

(PECL memcached >= 2.0.0)

Memcached::setSaslAuthData — Set the credentials to use for authentication

Açıklama

public void Memcached::setSaslAuthData ( string $username , string $password )

Memcached::setSaslAuthData() sets the username and password that should be used for SASL authentication with the memcache servers.

This method is only available when the memcached extension is built with SASL support. Please refer to Memcached setup for how to do this.

Değiştirgeler

username

The username to use for authentication.

password

The password to use for authentication.

Dönen Değerler

Hiçbir değer dönmez.

Memcached::setOptions
Memcached::touch
Memcached


Set a new expiration on an item

Memcached::setSaslAuthData
Memcached::touchByKey
Memcached
PHP Manual

Memcached::touch

(PECL memcached >= 2.0.0)

Memcached::touch — Set a new expiration on an item

Açıklama

public bool Memcached::touch ( string $key , int $expiration )

Memcached::touch() sets a new expiration value on the given key.

Değiştirgeler

key

Değerin saklanacağı anahtar.

expiration

Zaman aşımı, öntanımlı 0'dır. Daha ayrıntılı bilgi için Zaman aşımı süreleri bölümüne bakınız.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. Gerekirse Memcached::getResultCode() kullanın.

Ayrıca Bakınız

  • Memcached::touchByKey() - Set a new expiration on an item on a specific server

Memcached::setSaslAuthData
Memcached::touchByKey
Memcached


Set a new expiration on an item on a specific server

Memcached::touch
MemcachedException
Memcached
PHP Manual

Memcached::touchByKey

(PECL memcached >= 2.0.0)

Memcached::touchByKey — Set a new expiration on an item on a specific server

Açıklama

public bool Memcached::touchByKey ( string $server_key , string $key , int $expiration )

Memcached::touchByKey() is functionally equivalent to Memcached::touch(), except that the free-form server_key can be used to map the key to a specific server.

Değiştirgeler

server_key

The key identifying the server to store the value on or retrieve it from. Instead of hashing on the actual key for the item, we hash on the server key when deciding which memcached server to talk to. This allows related items to be grouped together on a single server for efficiency with multi operations.

key

Değerin saklanacağı anahtar.

expiration

Zaman aşımı, öntanımlı 0'dır. Daha ayrıntılı bilgi için Zaman aşımı süreleri bölümüne bakınız.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. Gerekirse Memcached::getResultCode() kullanın.

Ayrıca Bakınız

  • Memcached::touch() - Set a new expiration on an item

Memcached::touch
MemcachedException
Memcached


The MemcachedException class

(PECL memcached >= 0.1.0)

Giriş

Sınıf Sözdizimi

MemcachedException extends RuntimeException {
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}
Memcached::touchByKey
mqseries
Memcached


mqseries

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • mqseries İşlevleri
    • mqseries_back — MQSeries MQBACK
    • mqseries_begin — MQseries MQBEGIN
    • mqseries_close — MQSeries MQCLOSE
    • mqseries_cmit — MQSeries MQCMIT
    • mqseries_conn — MQSeries MQCONN
    • mqseries_connx — MQSeries MQCONNX
    • mqseries_disc — MQSeries MQDISC
    • mqseries_get — MQSeries MQGET
    • mqseries_inq — MQSeries MQINQ
    • mqseries_open — MQSeries MQOPEN
    • mqseries_put1 — MQSeries MQPUT1
    • mqseries_put — MQSeries MQPUT
    • mqseries_set — MQSeries MQSET
    • mqseries_strerror — Returns the error message corresponding to a result code (MQRC).
MemcachedException
Giriş
Diğer Hizmetler


Giriş

This extension aims to provide an interface for communicating with IBMs WebSphere MQ series Queue managers.

The interface mimics the C-API client interface of WebSphere MQ Series as close as possible. Using the same naming conventions and possibilities of the C-API. In order to understand the workings of this extension some level of understanding the C-API is required.

For MQ-options, MQ-structures, MQ-results etc. please read the WebSphere MQ Application Programming Guide and WebSphere MQ Application Programming Reference.

mqseries
Yapılandırma/Kurulum
mqseries


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
mqseries


Gereksinimler

A working IBM WebSphere MQ installation. If building the extension the SDK for IBM WebSphere MQ is also required.

Bilginize: Be aware that when running against a IBM WebSphere MQ Client installation some methods are not available. This is not a problem of the extension but just the way the WebSphere MQ Client Interface works.

Installation requirements on non windows platforms

Build the extension and put it in the PHP extension directory.

Installation requirements on Windows

No additional requirements.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu » PECL eklentisi PHP ile gelmez.

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/mqseries.

Bilginize: The official name of this extension is mqseries.

There are two ways to connect to a queue manager. These depend on the way the extension is compiled and linked.

  • First one and also the default one is using the mqic libraries. Compiling and linking the extension against these IBM WebSphere MQSeries libraries allows the extension to connect to the Queue manager using the client interface. Remote connections are possible this way.

  • The other way is to compile and link against the mqm libraries. Using these libraries it is possible to make use of the transaction management of a queue manager.

Currently selecting the libraries to use is done by changing the config.m4 file.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

There are no extra configuration parameters.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Özkaynak Türleri

This extension defines a connection and object_handle resources.

The mqseries_conn() and mqseries_connx() define the connectionn handles.

The mqseries_open() defines the object handle.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

For each WebSphere MQ Constant there is a mqseries counterpart.

For definitions and usage see the WebSphere MQ Application Programming Guide and WebSphere MQ Application Programming Reference red books.

The name of the mqseries counterpart is made by appending the WebSphere MQ constant with MQSERIES_, for example the CompletionCode constants are:

mqseries constants
PHP Constant | MQ Constant
MQSERIES_MQCC_OK | MQCC_OK
MQSERIES_MQCC_WARNING | MQCC_WARNING
MQSERIES_MQCC_FAILED | MQCC_FAILED
MQSERIES_MQCC_UNKNOWN | MQCC_UNKNOWN

Özkaynak Türleri
mqseries İşlevleri
mqseries


mqseries İşlevleri

İçindekiler

  • mqseries_back — MQSeries MQBACK
  • mqseries_begin — MQseries MQBEGIN
  • mqseries_close — MQSeries MQCLOSE
  • mqseries_cmit — MQSeries MQCMIT
  • mqseries_conn — MQSeries MQCONN
  • mqseries_connx — MQSeries MQCONNX
  • mqseries_disc — MQSeries MQDISC
  • mqseries_get — MQSeries MQGET
  • mqseries_inq — MQSeries MQINQ
  • mqseries_open — MQSeries MQOPEN
  • mqseries_put1 — MQSeries MQPUT1
  • mqseries_put — MQSeries MQPUT
  • mqseries_set — MQSeries MQSET
  • mqseries_strerror — Returns the error message corresponding to a result code (MQRC).
Öntanımlı Sabitler
mqseries_back
mqseries


MQSeries MQBACK

mqseries İşlevleri
mqseries_begin
mqseries İşlevleri
PHP Manual

mqseries_back

(PECL mqseries >= 0.10.0)

mqseries_back — MQSeries MQBACK

Açıklama

void mqseries_back ( resource $hconn , resource &$compCode , resource &$reason )

The mqseries_back() (MQBACK) call indicates to the queue manager that all the message gets and puts that have occurred since the last syncpoint are to be backed out. Messages put as part of a unit of work are deleted; messages retrieved as part of a unit of work are reinstated on the queue.

Using mqseries_back() only works in conjunction with mqseries_begin() and only function when connecting directly to a Queueu manager. Not via the mqclient interface.

Değiştirgeler

hConn

Connection handle.

This handle represents the connection to the queue manager.

compCode

Completion code.

reason

Reason code qualifying the compCode.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 mqseries_back() example

<?php
    mqseries_back($conn, $comp_code, $reason);

    if ($comp_code !== MQSERIES_MQCC_OK) {
        printf("CompCode:%d Reason:%d Text:%s<br>\n", $comp_code, $reason, mqseries_strerror($reason));
    }
?>

Notlar

Bilginize:

mqseries_back() will not function when using MQSeries Client to connect to a Queueu Manager.

Ayrıca Bakınız

  • mqseries_conn() - MQSeries MQCONN
  • mqseries_connx() - MQSeries MQCONNX
  • mqseries_begin() - MQseries MQBEGIN

mqseries İşlevleri
mqseries_begin
mqseries İşlevleri


MQseries MQBEGIN

mqseries_back
mqseries_close
mqseries İşlevleri
PHP Manual

mqseries_begin

(PECL mqseries >= 0.10.0)

mqseries_begin — MQseries MQBEGIN

Açıklama

void mqseries_begin ( resource $hconn , array $beginOptions , resource &$compCode , resource &$reason )

The mqseries_begin() (MQBEGIN) call begins a unit of work that is coordinated by the queue manager, and that may involve external resource managers.

Using mqseries_begin() starts the unit of work. Either mqseries_back() or mqseries_cmit() ends the unit of work.

Değiştirgeler

hConn

Connection handle.

This handle represents the connection to the queue manager.

compCode

Completion code.

reason

Reason code qualifying the compCode.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 mqseries_begin() example

<?php
    $mqbo = array();
    mqseries_begin( $conn,
                    $mqbo,
                    $comp_code,
                    $reason);
    if ($comp_code !== MQSERIES_MQCC_OK) {
        /* reason code 2121 is a warning for more information see MQSeries reference manual.*/
        if ($reason !== 2121) {
            printf("CompCode:%d Reason:%d Text:%s<br>\n", $comp_code, $reason, mqseries_strerror($reason));
        }
    }
?>

Notlar

Bilginize:

mqseries_begin() will not function when using MQSeries Client to connect to a Queueu Manager.

Ayrıca Bakınız

  • mqseries_conn() - MQSeries MQCONN
  • mqseries_connx() - MQSeries MQCONNX
  • mqseries_back() - MQSeries MQBACK
  • mqseries_cmit() - MQSeries MQCMIT

mqseries_back
mqseries_close
mqseries İşlevleri


MQSeries MQCLOSE

mqseries_begin
mqseries_cmit
mqseries İşlevleri
PHP Manual

mqseries_close

(PECL mqseries >= 0.10.0)

mqseries_close — MQSeries MQCLOSE

Açıklama

void mqseries_close ( resource $hconn , resource $hobj , int $options , resource &$compCode , resource &$reason )

The mqseries_close() (MQCLOSE) call relinquishes access to an object, and is the inverse of the mqseries_open() (MQOPEN) call.

Değiştirgeler

hConn

Connection handle.

This handle represents the connection to the queue manager.

hObj

Object handle.

This handle represents the object to be used.

options

compCode

Completion code.

reason

Reason code qualifying the compCode.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 mqseries_close() example

<?php
    mqseries_close($conn, $obj, MQSERIES_MQCO_NONE, $comp_code, $reason);
    if ($comp_code !== MQSERIES_MQCC_OK) {
        printf("close CompCode:%d Reason:%d Text:%s<br>\n", $comp_code, $reason, mqseries_strerror($reason));
    }
?>

Ayrıca Bakınız

  • mqseries_open() - MQSeries MQOPEN
  • mqseries_conn() - MQSeries MQCONN
  • mqseries_connx() - MQSeries MQCONNX

mqseries_begin
mqseries_cmit
mqseries İşlevleri


MQSeries MQCMIT

mqseries_close
mqseries_conn
mqseries İşlevleri
PHP Manual

mqseries_cmit

(PECL mqseries >= 0.10.0)

mqseries_cmit — MQSeries MQCMIT

Açıklama

void mqseries_cmit ( resource $hconn , resource &$compCode , resource &$reason )

The mqseries_cmit() (MQCMIT) call indicates to the queue manager that the application has reached a syncpoint, and that all of the message gets and puts that have occurred since the last syncpoint are to be made permanent. Messages put as part of a unit of work are made available to other applications; messages retrieved as part of a unit of work are deleted.

Değiştirgeler

hConn

Connection handle.

This handle represents the connection to the queue manager.

compCode

Completion code.

reason

Reason code qualifying the compCode.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 mqseries_cmit() example

<?php
    mqseries_cmit($conn, $comp_code, $reason);
    if ($comp_code !== MQSERIES_MQCC_OK) {
        printf("cmit CompCode:%d Reason:%d Text:%s<br>\n", $comp_code, $reason, mqseries_strerror($reason));
    }
?>

Notlar

Bilginize:

mqseries_back() will not function when using MQSeries Client to connect to a Queueu Manager.

Ayrıca Bakınız

  • mqseries_begin() - MQseries MQBEGIN
  • mqseries_back() - MQSeries MQBACK
  • mqseries_conn() - MQSeries MQCONN
  • mqseries_connx() - MQSeries MQCONNX

mqseries_close
mqseries_conn
mqseries İşlevleri


MQSeries MQCONN

mqseries_cmit
mqseries_connx
mqseries İşlevleri
PHP Manual

mqseries_conn

(PECL mqseries >= 0.10.0)

mqseries_conn — MQSeries MQCONN

Açıklama

void mqseries_conn ( string $qManagerName , resource &$hconn , resource &$compCode , resource &$reason )

The mqseries_conn() (MQCONN) call connects an application program to a queue manager. It provides a queue manager connection handle, which is used by the application on subsequent message queuing calls.

Değiştirgeler

qManagerName

Name of queue manager.

Name of the queue manager the application wishes to connect.

hConn

Connection handle.

This handle represents the connection to the queue manager.

compCode

Completion code.

reason

Reason code qualifying the compCode.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 mqseries_conn() example

<?php
    mqseries_conn('WMQ1', $conn, $comp_code, $reason);
    if ($comp_code !== MQSERIES_MQCC_OK) {
        printf("conn CompCode:%d Reason:%d Text:%s<br>\n", $comp_code, $reason, mqseries_strerror($reason));
        exit;
    }
?>

Ayrıca Bakınız

  • mqseries_disc() - MQSeries MQDISC

mqseries_cmit
mqseries_connx
mqseries İşlevleri


MQSeries MQCONNX

mqseries_conn
mqseries_disc
mqseries İşlevleri
PHP Manual

mqseries_connx

(PECL mqseries >= 0.10.0)

mqseries_connx — MQSeries MQCONNX

Açıklama

void mqseries_connx ( string $qManagerName , array &$connOptions , resource &$hconn , resource &$compCode , resource &$reason )

The mqseries_connx() (MQCONNX) call connects an application program to a queue manager. It provides a queue manager connection handle, which is used by the application on subsequent MQ calls.

The mqseries_connx() call is like the mqseries_conn() (MQCONN) call, except that MQCONNX allows options to be specified to control the way that the call works.

Değiştirgeler

qManagerName

Name of queue manager.

Name of the queue manager the application wishes to connect.

connOps

Options that control the action of function

See also the MQCNO structure.

hConn

Connection handle.

This handle represents the connection to the queue manager.

compCode

Completion code.

reason

Reason code qualifying the compCode.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 mqseries_connx() example

<?php
    $mqcno = array(
        'Version' => MQSERIES_MQCNO_VERSION_2,
        'Options' => MQSERIES_MQCNO_STANDARD_BINDING,
        'MQCD' => array('ChannelName' => 'MQNX9420.CLIENT',
        'ConnectionName' => 'localhost',
        'TransportType' => MQSERIES_MQXPT_TCP)
    );

    mqseries_connx('MQNX9420', $mqcno, $conn, $comp_code,$reason);
    if ($comp_code !== MQSERIES_MQCC_OK) {
        printf("Connx CompCode:%d Reason:%d Text:%s<br>\n", $comp_code, $reason, mqseries_strerror($reason));
        exit;
    }

?>

Örnek 2 mqseries_connx() example using SSL connection & OCSP Responder URL

<?php
    $mqcno = array(
        'Version' => 4, //MQCNO_VERSION_4
        'Options' => MQSERIES_MQCNO_STANDARD_BINDING,
        'MQCD' => array(
            'Version' => 7, //MQCD_VERSION_7
            'ConnectionName' => 'localhost',
            'TransportType' => MQSERIES_MQXPT_TCP,
            'ChannelName' => 'CONNECTIONCHANNEL',
            'SSLCipherSpec' => 'NULL_SHA'
        ),
        'MQSCO' => array(
            'KeyRepository' => '/var/mqm/qmgrs/QUEUEMGR/ssl/key', //Local path where the SSL key repository can be found
            'MQAIR' => array(
                'Version' => 2, //MQAIR_VERSION_2
                'AuthInfoType' => 2, //MQAIT_OCSP
                'OCSPResponderURL' => 'http://dummy.OCSP.responder'
            )
        )
    );

    mqseries_connx('QUEUEMGR', $mqcno, $conn, $comp_code,$reason);
    if ($comp_code !== MQSERIES_MQCC_OK) {
        printf("Connx CompCode:%d Reason:%d Text:%s<br>\n", $comp_code, $reason, mqseries_strerror($reason));
        exit;
    }

?>

Ayrıca Bakınız

  • mqseries_disc() - MQSeries MQDISC

mqseries_conn
mqseries_disc
mqseries İşlevleri


MQSeries MQDISC

mqseries_connx
mqseries_get
mqseries İşlevleri
PHP Manual

mqseries_disc

(PECL mqseries >= 0.10.0)

mqseries_disc — MQSeries MQDISC

Açıklama

void mqseries_disc ( resource $hconn , resource &$compCode , resource &$reason )

The mqseries_disc() (MQDISC) call breaks the connection between the queue manager and the application program, and is the inverse of the mqseries_conn() (MQCONN) or mqseries_connx() (MQCONNX) call.

Değiştirgeler

hConn

Connection handle.

This handle represents the connection to the queue manager.

compCode

Completion code.

reason

Reason code qualifying the compCode.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 mqseries_disc() example

<?php
    mqseries_disc($conn, $comp_code, $reason);
    if ($comp_code !== MQSERIES_MQCC_OK) {
        printf("disc CompCode:%d Reason:%d Text:%s<br>\n", $comp_code, $reason, mqseries_strerror($reason));
    }
?>

Ayrıca Bakınız

  • mqseries_conn() - MQSeries MQCONN
  • mqseries_connx() - MQSeries MQCONNX

mqseries_connx
mqseries_get
mqseries İşlevleri


MQSeries MQGET

mqseries_disc
mqseries_inq
mqseries İşlevleri
PHP Manual

mqseries_get

(PECL mqseries >= 0.10.0)

mqseries_get — MQSeries MQGET

Açıklama

void mqseries_get ( resource $hConn , resource $hObj , array &$md , array &$gmo , int &$bufferLength , string &$msg , int &$data_length , resource &$compCode , resource &$reason )

The mqseries_get() (MQGET) call retrieves a message from a local queue that has been opened using the mqseries_open() (MQOPEN) call

Değiştirgeler

hConn

Connection handle.

This handle represents the connection to the queue manager.

hObj

Object handle.

This handle represents the object to be used.

md

Message descriptor (MQMD).

gmo

Get message options (MQGMO).

bufferLength

Expected length of the result buffer

msg

Buffer holding the message that was retrieved from the object.

data_length

Actual buffer length

compCode

Completion code.

reason

Reason code qualifying the compCode.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 mqseries_get() example

<?php
// open connection to the queue manager
    mqseries_conn('WMQ1', $conn, $comp_code, $reason);
// $conn now hold the reference to the connection to the queue manager.

// open the connection to the testq queue
    mqseries_open(
                $conn,
                array('ObjectName' => 'TESTQ'),
                MQSERIES_MQOO_INPUT_AS_Q_DEF | MQSERIES_MQOO_FAIL_IF_QUIESCING | MQSERIES_MQOO_OUTPUT,
                $obj,
                $comp_code,
                $reason);
// $obj now holds the reference to the object (TESTQ)

// setup empty message descriptor.
    $mdg = array();
// setup get message options
    $gmo = array('Options' => MQSERIES_MQGMO_FAIL_IF_QUIESCING | MQSERIES_MQGMO_WAIT, 'WaitInterval' => 3000);

// get the message from the queueu
    mqseries_get($conn, $obj, $mdg, $gmo, 255, $msg, $data_length, $comp_code, $reason);
    if ($comp_code !== MQSERIES_MQCC_OK) {
        printf("GET CompCode:%d Reason:%d Text:%s<br>", $comp_code, $reason, mqseries_strerror($reason));
    }

// close the object reference $obj
    mqseries_close($conn, $obj, MQSERIES_MQCO_NONE, $comp_code, $reason);

// disconnect from the queue manager.
    mqseries_disc($conn, $comp_code, $reason);

?>

Ayrıca Bakınız

  • mqseries_conn() - MQSeries MQCONN
  • mqseries_connx() - MQSeries MQCONNX
  • mqseries_open() - MQSeries MQOPEN
  • mqseries_put() - MQSeries MQPUT

mqseries_disc
mqseries_inq
mqseries İşlevleri


MQSeries MQINQ

mqseries_get
mqseries_open
mqseries İşlevleri
PHP Manual

mqseries_inq

(PECL mqseries >= 0.10.0)

mqseries_inq — MQSeries MQINQ

Açıklama

void mqseries_inq ( resource $hconn , resource $hobj , int $selectorCount , array $selectors , int $intAttrCount , resource &$intAttr , int $charAttrLength , resource &$charAttr , resource &$compCode , resource &$reason )

The mqseries_inq() (MQINQ) call returns an array of integers and a set of character strings containing the attributes of an object.

Değiştirgeler

hConn

Connection handle.

This handle represents the connection to the queue manager.

hObj

Object handle.

This handle represents the object to be used.

selectorCount

Count of selectors.

selectors

Array of attribute selectors.

intAttrLength

Count of integer attributes.

intAttr

Array of integer attributes.

charAttrLength

Length of character attributes buffer.

charAttr

Character attributes.

compCode

Completion code.

reason

Reason code qualifying the compCode.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 mqseries_inq() example

<?php
    $int_attr = array();
    $char_attr = "";

    mqseries_inq($conn, $obj, 1, array(MQSERIES_MQCA_Q_MGR_NAME), 0, $int_attr, 48, $char_attr, $comp_code, $reason);

    if ($comp_code !== MQSERIES_MQCC_OK) {
        printf("INQ CompCode:%d Reason:%d Text:%s<br>\n", $comp_code, $reason, mqseries_strerror($reason));
    } else {
        echo "INQ QManager name result ".$char_attr."<br>\n";
    }
?>

Ayrıca Bakınız

  • mqseries_conn() - MQSeries MQCONN
  • mqseries_connx() - MQSeries MQCONNX
  • mqseries_open() - MQSeries MQOPEN

mqseries_get
mqseries_open
mqseries İşlevleri


MQSeries MQOPEN

mqseries_inq
mqseries_put1
mqseries İşlevleri
PHP Manual

mqseries_open

(PECL mqseries >= 0.10.0)

mqseries_open — MQSeries MQOPEN

Açıklama

void mqseries_open ( resource $hconn , array &$objDesc , int $option , resource &$hobj , resource &$compCode , resource &$reason )

The mqseries_open() (MQOPEN) call establishes access to an object.

Değiştirgeler

hConn

Connection handle.

This handle represents the connection to the queue manager.

objDesc

Object descriptor. (MQOD)

options

Options that control the action of the function.

hObj

Object handle.

This handle represents the object to be used.

compCode

Completion code.

reason

Reason code qualifying the compCode.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 mqseries_open() example

<?php
    $mqods = array('ObjectName' => 'TESTQ');
    mqseries_open(
                $conn,
                $mqods,
                MQSERIES_MQOO_INPUT_AS_Q_DEF | MQSERIES_MQOO_FAIL_IF_QUIESCING | MQSERIES_MQOO_OUTPUT,
                $obj,
                $comp_code,
                $reason);
    if ($comp_code !== MQSERIES_MQCC_OK) {
        printf("open CompCode:%d Reason:%d Text:%s<br>\n", $comp_code, $reason, mqseries_strerror($reason));
        exit;
    }
?>

Ayrıca Bakınız

  • mqseries_close() - MQSeries MQCLOSE

mqseries_inq
mqseries_put1
mqseries İşlevleri


MQSeries MQPUT1

mqseries_open
mqseries_put
mqseries İşlevleri
PHP Manual

mqseries_put1

(PECL mqseries >= 0.10.0)

mqseries_put1 — MQSeries MQPUT1

Açıklama

void mqseries_put1 ( resource $hconn , resource &$objDesc , resource &$msgDesc , resource &$pmo , string $buffer , resource &$compCode , resource &$reason )

The mqseries_put1() (MQPUT1) call puts one message on a queue. The queue need not be open.

You can use both the mqseries_put() and mqseries_put1() calls to put messages on a queue; which call to use depends on the circumstances. Use the mqseries_put() (MQPUT) call to place multiple messages on the same queue. Use the mqseries_put1() (MQPUT1) call to put only one message on a queue. This call encapsulates the MQOPEN, MQPUT, and MQCLOSE calls into a single call, minimizing the number of calls that must be issued.

Değiştirgeler

hConn

Connection handle.

This handle represents the connection to the queue manager.

objDesc

Object descriptor. (MQOD)

This is a structure which identifies the queue to which the message is added.

msgDesc

Message descriptor (MQMD).

pmo

Put message options (MQPMO).

compCode

Completion code.

reason

Reason code qualifying the compCode.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • mqseries_conn() - MQSeries MQCONN
  • mqseries_connx() - MQSeries MQCONNX
  • mqseries_open() - MQSeries MQOPEN
  • mqseries_get() - MQSeries MQGET

mqseries_open
mqseries_put
mqseries İşlevleri


MQSeries MQPUT

mqseries_put1
mqseries_set
mqseries İşlevleri
PHP Manual

mqseries_put

(PECL mqseries >= 0.10.0)

mqseries_put — MQSeries MQPUT

Açıklama

void mqseries_put ( resource $hConn , resource $hObj , array &$md , array &$pmo , string $message , resource &$compCode , resource &$reason )

The mqseries_put() (MQPUT) call puts a message on a queue or distribution list. The queue or distribution list must already be open.

Değiştirgeler

hConn

Connection handle.

This handle represents the connection to the queue manager.

hObj

Object handle.

This handle represents the object to be used.

md

Message descriptor (MQMD).

pmo

Put message options (MQPMO).

message

The actual message to put onto the queue.

compCode

Completion code.

reason

Reason code qualifying the compCode.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 mqseries_put() example

<?php
// open connection to the queue manager
    mqseries_conn('WMQ1', $conn, $comp_code, $reason);
// $conn now hold the reference to the connection to the queue manager.

// open the connectio to the testq queueu
    mqseries_open(
                $conn,
                array('ObjectName' => 'TESTQ'),
                MQSERIES_MQOO_INPUT_AS_Q_DEF | MQSERIES_MQOO_FAIL_IF_QUIESCING | MQSERIES_MQOO_OUTPUT,
                $obj,
                $comp_code,
                $reason);
// $obj now holds the reference to the object (TESTQ)

// setup the message descriptor array. Check MQSeries reference manuals.
    $md = array(
                'Version' => MQSERIES_MQMD_VERSION_1,
                'Expiry' => MQSERIES_MQEI_UNLIMITED,
                'Report' => MQSERIES_MQRO_NONE,
                'MsgType' => MQSERIES_MQMT_DATAGRAM,
                'Format' => MQSERIES_MQFMT_STRING,
                'Priority' => 1,
                'Persistence' => MQSERIES_MQPER_PERSISTENT);

// setup the put message options.
    $pmo = array('Options' => MQSERIES_MQPMO_NEW_MSG_ID|MQSERIES_MQPMO_SYNCPOINT);

// put the message 'Ping' on the queueu.
    mqseries_put($conn, $obj, $md, $pmo, 'Ping', $comp_code, $reason);

    if ($comp_code !== MQSERIES_MQCC_OK) {
        printf("put CompCode:%d Reason:%d Text:%s<br>\n", $comp_code, $reason, mqseries_strerror($reason));
    }

// close the object reference $obj
    mqseries_close($conn, $obj, MQSERIES_MQCO_NONE, $comp_code, $reason);

// disconnect from the queue manager.
    mqseries_disc($conn, $comp_code, $reason);

?>

Ayrıca Bakınız

  • mqseries_conn() - MQSeries MQCONN
  • mqseries_connx() - MQSeries MQCONNX
  • mqseries_open() - MQSeries MQOPEN
  • mqseries_get() - MQSeries MQGET

mqseries_put1
mqseries_set
mqseries İşlevleri


MQSeries MQSET

mqseries_put
mqseries_strerror
mqseries İşlevleri
PHP Manual

mqseries_set

(PECL mqseries >= 0.10.0)

mqseries_set — MQSeries MQSET

Açıklama

void mqseries_set ( resource $hConn , resource $hObj , int $selectorCount , array $selectors , int $intAttrCount , array $intAttrs , int $charAttrLength , array $charAttrs , resource &$compCode , resource &$reason )

The mqseries_set() (MQSET) call is used to change the attributes of an object represented by a handle. The object must be a queue.

Değiştirgeler

hConn

Connection handle.

This handle represents the connection to the queue manager.

hObj

Object handle.

This handle represents the object to be used.

selectorCount

Count of selectors.

selectors

Array of attribute selectors.

intAttrCount

Count of integer attributes.

intAttrs

Array of integer attributes.

charAttrLength

Length of character attributes buffer.

charAttrs

Character attributes.

compCode

Completion code.

reason

Reason code qualifying the compCode.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • mqseries_inq() - MQSeries MQINQ

mqseries_put
mqseries_strerror
mqseries İşlevleri


Returns the error message corresponding to a result code (MQRC).

mqseries_set
Ağ
mqseries İşlevleri
PHP Manual

mqseries_strerror

(PECL mqseries >= 0.10.0)

mqseries_strerror — Returns the error message corresponding to a result code (MQRC).

Açıklama

string mqseries_strerror ( int $reason )

mqseries_strerror() returns the message that correspond to the reason result code.

Değiştirgeler

reason

Reason code qualifying the compCode.

Dönen Değerler

string representation of the reason code message.

Örnekler

Örnek 1 mqseries_strerror() example

<?php
    if ($comp_code !== MQSERIES_MQCC_OK) {
        printf("open CompCode:%d Reason:%d Text:%s<br>\n", $comp_code, $reason, mqseries_strerror($reason));
        exit;
    }
?>

Yukarıdaki örneğin çıktısı:

Connx CompCode:2 Reason:2059 Text:Queue manager not available for connection.

mqseries_set
Ağ
mqseries İşlevleri


Ağ

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Ağ İşlevleri
    • checkdnsrr — Belirtilen bir konak adı veya IP adresi için DNS sorgusu yapar
    • closelog — Sistem günlükçüsü bağlantısını kapatır
    • define_syslog_variables — Syslog ile ilgili tüm değişkenleri ilklendirir
    • dns_check_record — checkdnsrr işlevinin takma adıdır
    • dns_get_mx — getmxrr işlevinin takma adıdır
    • dns_get_record — Belirtilen konak adı ile ilgili DNS Özkaynak Kayıtlarını getirir
    • fsockopen — Bir internet veya Unix alan soketi bağlantısı açar
    • gethostbyaddr — Belirtilen IP adresine çözümlenen konak ismini döndürür
    • gethostbyname — Belirtilen konak adına ait IPv4 adresini döndürür
    • gethostbynamel — Belirtilen konak adına ait IPv4 adreslerini döndürür
    • gethostname — Konak ismini döndürür
    • getmxrr — Belirtilen konak adı ile ilgili MX kaydını döndürür
    • getprotobyname — Protokol ismine karşılık düşen protokol numarasını verir
    • getprotobynumber — Protokol numarasına karşılık düşen protokol ismini verir
    • getservbyname — Belirtilen ağ hizmeti ve protokolle ilişkili port numarası ile döner
    • getservbyport — Belirtilen port ve protokolle ilgili ağ hizmeti ile döner
    • header_register_callback — Call a header function
    • header_remove — Remove previously set headers
    • header — Ham bir HTTP başlığı gönderir
    • headers_list — Gönderilmiş (veya gönderilmeye hazır) yanıt başlıklarının listesiyle döner
    • headers_sent — Başlıklar gönderilmiş mi, gönderilmişse nerede gönderilmiş diye bakar
    • http_response_code — Get or Set the HTTP response code
    • inet_ntop — Bir IP adresinin in_addr gösterimini insan okuyabilir gösterime dönüştürür
    • inet_pton — İnsan okuyabilir bir IP adresini in_addr gösterimine dönüştürür
    • ip2long — Noktalı IP adresi gösterimini içeren bir dizgeyi sayısal adrese dönüştürür
    • long2ip — Bir (IPv4) sayısal ağ adresini noktalı gösterimi içeren bir dizgeye dönüştürür
    • openlog — Sistem günlükçüsüne erişim için bağlantı açar
    • pfsockopen — Kalıcı bir internet veya Unix alan soketi bağlantısı açar
    • setcookie — Bir çerez gönderir
    • setrawcookie — Bir çerezi değerini URL kodlamasından geçirmeden gönderir
    • socket_get_status — Takma Adı: stream_get_meta_data
    • socket_set_blocking — Takma Adı: stream_set_blocking
    • socket_set_timeout — Takma Adı: stream_set_timeout
    • syslog — Bir sistem günlüğü iletisi üretir
mqseries_strerror
Giriş
Diğer Hizmetler


Giriş

Ağlarla ilgili çeşitli işlevler sağlar.

Ağ
Yapılandırma/Kurulum
Ağ


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Ağ


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Ağ Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişiklik yeri | Sürüm Bilgisi
define_syslog_variables | "0" | PHP_INI_ALL | PHP 5.3.0'dan beri kullanımı önerilmemekte olup PHP 6.0.0'da kaldırılmıştır.
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

define_syslog_variables boolean

Çeşitli syslog değişkenlerinin ($LOG_PID, $LOG_CRON gibi) tanımlanıp tanımlanmayacağını belirler. Başarım arttırma açısından off atamak iyi bir fikirdir. Bu değişkenleri çalışma anında define_syslog_variables() çağrısıyla tanımlayabilirsiniz.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Özkaynak Türleri

Bu eklenti fsockopen() ve pfsockopen() işlevlerince döndürülen bir dosya tanıtıcı özkaynağı tanımlar.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Aşağıdaki sabitler PHP çekirdeğinin parçası olarak daima kullanılabilir durumdadır.

openlog() seçenekleri
Sabit | Açıklama
LOG_CONS | Veriyi sistem günlüğüne gönderirken bir hata oluşursa doğrudan sistem konsoluna yaz.
LOG_NDELAY | Günlük kayıtçısına hemen bir bağlantı aç.
LOG_ODELAY | (öntanımlı) İlk ileti günlüğe kaydolana kadar bağlantı açılışını ertele.
LOG_NOWAIT |
LOG_PERROR | Günlük iletisini ayrıca standart hataya da yaz.
LOG_PID | Her iletide PID'i de içer
openlog() Oluşumları
Sabit | Açıklama
LOG_AUTH | Güvenlik/kimlik doğrulama iletileri (bu sabitin tanımlı olduğu sistemlerde yerine LOG_AUTHPRIV kulanın).
LOG_AUTHPRIV | Güvenlik/kimlik doğrulama iletileri (özel)
LOG_CRON | Zamanlama süreçleri (cron ve at)
LOG_DAEMON | Diğer sistem süreçleri
LOG_KERN | Sistem çekirdeği iletileri
LOG_LOCAL0 ... LOG_LOCAL7 | Yerel kullanım için ayrılmıştır. Bunlar Windows'ta hükümsüzdür.
LOG_LPR | Satır yazıcı alt sistemi
LOG_MAIL | eposta alt sistemi
LOG_NEWS | USENET haber grupları alt sistemi
LOG_SYSLOG | dahili olarak syslogd tarafından üretilen iletiler
LOG_USER | soysal kullanıcı seviyesi iletiler
LOG_UUCP | UUCP alt sistemi
syslog() Öncelikleri (azalan sırada)
Sabit | Açıklama
LOG_EMERG | sistem kullanışsız
LOG_ALERT | eylem hemen ele alınmalı
LOG_CRIT | hayati durumlar
LOG_ERR | hata durumları
LOG_WARNING | uyarı durumları
LOG_NOTICE | normal, fakat önemli durumlar
LOG_INFO | bilgilendirme iletisi
LOG_DEBUG | hata ayıklama iletileri
dns_get_record() seçenekleri
Sabit | Açıklama
DNS_A | IPv4 Adres Özkaynağı
DNS_MX | Posta Alışveriş Özkaynağı
DNS_CNAME | Takma Ad (Meşru Ad) Özkaynağı
DNS_NS | Yetkili İsim Sunucusu Özkaynağı
DNS_PTR | Gösterici Özkaynağı
DNS_HINFO | Konak Bilgi Özkaynağı (Bu değerlerin anlamları için IANA'nın » İşletim Sistemi İsimleri'ne bakınız.)
DNS_SOA | Yetki Başlangıcı Özkaynağı
DNS_TXT | Metin Özkaynağı
DNS_ANY | Herhangi bir Özkaynak Kaydı. Çoğu sistemde bu tüm özkaynak kayıtlarını döndürürse de hayati kullanımlarda buna güvenilmemelidir. Yerine DNS_ALL kullanmayı deneyin.
DNS_AAAA | IPv6 Adres Özkaynağı
DNS_ALL | Kullanılabilir her kayıt türü için isim sunucusunu yinelemeli olarak sorgula.
Özkaynak Türleri
Ağ İşlevleri
Ağ


Ağ İşlevleri

İçindekiler

  • checkdnsrr — Belirtilen bir konak adı veya IP adresi için DNS sorgusu yapar
  • closelog — Sistem günlükçüsü bağlantısını kapatır
  • define_syslog_variables — Syslog ile ilgili tüm değişkenleri ilklendirir
  • dns_check_record — checkdnsrr işlevinin takma adıdır
  • dns_get_mx — getmxrr işlevinin takma adıdır
  • dns_get_record — Belirtilen konak adı ile ilgili DNS Özkaynak Kayıtlarını getirir
  • fsockopen — Bir internet veya Unix alan soketi bağlantısı açar
  • gethostbyaddr — Belirtilen IP adresine çözümlenen konak ismini döndürür
  • gethostbyname — Belirtilen konak adına ait IPv4 adresini döndürür
  • gethostbynamel — Belirtilen konak adına ait IPv4 adreslerini döndürür
  • gethostname — Konak ismini döndürür
  • getmxrr — Belirtilen konak adı ile ilgili MX kaydını döndürür
  • getprotobyname — Protokol ismine karşılık düşen protokol numarasını verir
  • getprotobynumber — Protokol numarasına karşılık düşen protokol ismini verir
  • getservbyname — Belirtilen ağ hizmeti ve protokolle ilişkili port numarası ile döner
  • getservbyport — Belirtilen port ve protokolle ilgili ağ hizmeti ile döner
  • header_register_callback — Call a header function
  • header_remove — Remove previously set headers
  • header — Ham bir HTTP başlığı gönderir
  • headers_list — Gönderilmiş (veya gönderilmeye hazır) yanıt başlıklarının listesiyle döner
  • headers_sent — Başlıklar gönderilmiş mi, gönderilmişse nerede gönderilmiş diye bakar
  • http_response_code — Get or Set the HTTP response code
  • inet_ntop — Bir IP adresinin in_addr gösterimini insan okuyabilir gösterime dönüştürür
  • inet_pton — İnsan okuyabilir bir IP adresini in_addr gösterimine dönüştürür
  • ip2long — Noktalı IP adresi gösterimini içeren bir dizgeyi sayısal adrese dönüştürür
  • long2ip — Bir (IPv4) sayısal ağ adresini noktalı gösterimi içeren bir dizgeye dönüştürür
  • openlog — Sistem günlükçüsüne erişim için bağlantı açar
  • pfsockopen — Kalıcı bir internet veya Unix alan soketi bağlantısı açar
  • setcookie — Bir çerez gönderir
  • setrawcookie — Bir çerezi değerini URL kodlamasından geçirmeden gönderir
  • socket_get_status — Takma Adı: stream_get_meta_data
  • socket_set_blocking — Takma Adı: stream_set_blocking
  • socket_set_timeout — Takma Adı: stream_set_timeout
  • syslog — Bir sistem günlüğü iletisi üretir
Öntanımlı Sabitler
checkdnsrr
Ağ


Belirtilen bir konak adı veya IP adresi için DNS sorgusu yapar

Ağ İşlevleri
closelog
Ağ İşlevleri
PHP Manual

checkdnsrr

(PHP 4, PHP 5, PHP 7)

checkdnsrr — Belirtilen bir konak adı veya IP adresi için DNS sorgusu yapar

Açıklama

bool checkdnsrr ( string $konak [, string $tür ] )

konak ile ilgili tür türündeki kayıtlar için DNS sorgusu yapar.

Değiştirgeler

konak

konak noktalı sayısal gösterimli bir IP adresi veya bir konak ismi olabilir.

tür

tür değeri şunlardan biri olabilir: A, MX, NS, SOA, PTR, CNAME, AAAA, A6, SRV, NAPTR, TXT veya ANY. MX öntanımlıdır.

Dönen Değerler

Kayıtlar bulunduğu takdirde TRUE, hiç kayıt yoksa veya bir hata oluşmuşsa FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | İşlev Windows platformlarenda kullanılabilir oldu.
5.2.4 | TXT türü eklendi.
5.0.0 | AAAA türü eklendi.

Notlar

Bilginize:

Bu işlevin henüz gerçeklenmediği PHP sürümlerini çalıştıran Windows platformlarında » PEAR » Net_DNS sınıfını deneyin.

Ayrıca Bakınız

  • dns_get_record() - Belirtilen konak adı ile ilgili DNS Özkaynak Kayıtlarını getirir
  • getmxrr() - Belirtilen konak adı ile ilgili MX kaydını döndürür
  • gethostbyaddr() - Belirtilen IP adresine çözümlenen konak ismini döndürür
  • gethostbyname() - Belirtilen konak adına ait IPv4 adresini döndürür
  • gethostbynamel() - Belirtilen konak adına ait IPv4 adreslerini döndürür
  • named(8) kılavuz sayfası

Ağ İşlevleri
closelog
Ağ İşlevleri


Sistem günlükçüsü bağlantısını kapatır

checkdnsrr
define_syslog_variables
Ağ İşlevleri
PHP Manual

closelog

(PHP 4, PHP 5, PHP 7)

closelog — Sistem günlükçüsü bağlantısını kapatır

Açıklama

bool closelog ( void )

closelog() işlevi, sistem günlükçüsüne yazmak için kullanılan tanıtıcıyı kapatır. closelog() kullanımı isteğe bağlıdır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • syslog() - Bir sistem günlüğü iletisi üretir
  • openlog() - Sistem günlükçüsüne erişim için bağlantı açar

checkdnsrr
define_syslog_variables
Ağ İşlevleri


Syslog ile ilgili tüm değişkenleri ilklendirir

closelog
dns_check_record
Ağ İşlevleri
PHP Manual

define_syslog_variables

(PHP 4, PHP 5 < 5.4.0)

define_syslog_variables — Syslog ile ilgili tüm değişkenleri ilklendirir

Açıklama

void define_syslog_variables ( void )

Syslog işlevlerinde kullanılan tüm değişkenleri ilklendirir.

Dönen Değerler

Hiçbir değer dönmez.

Syslog değişkenleri
Değişken | Eşdeğer sabit | Anlamı | Ek bilgi
$LOG_EMERG | LOG_EMERG | Sistem kullanışsız |
$LOG_ALERT | LOG_ALERT | Eylem hemen ele alınmalı |
$LOG_CRIT | LOG_CRIT | Hayati durumlar |
$LOG_ERR | LOG_ERR | Hata durumları |
$LOG_WARNING | LOG_WARNING | Uyarı durumları |
$LOG_NOTICE | LOG_NOTICE | Normal, fakat önemli durumlar |
$LOG_INFO | LOG_INFO | Bilgilendirme iletisi |
$LOG_DEBUG | LOG_DEBUG | Hata ayıklama iletileri |
$LOG_KERN | LOG_KERN | Sistem çekirdeği iletileri |
$LOG_USER | LOG_USER | Soysal kullanıcı seviyesi iletiler |
$LOG_MAIL | LOG_MAIL | Eposta alt sistemi |
$LOG_DAEMON | LOG_DAEMON | Diğer sistem süreçleri |
$LOG_AUTH | LOG_AUTH | Güvenlik/kimlik doğrulama iletileri |
$LOG_SYSLOG | LOG_SYSLOG | Dahili olarak syslogd tarafından üretilen iletiler | Netware üzerinde kullanılmaz.
$LOG_LPR | LOG_LPR | Satır yazıcı alt sistemi |
$LOG_NEWS | LOG_NEWS | USENET haber grupları alt sistemi | HP-UX üzerinde kullanılmaz.
$LOG_CRON | LOG_CRON | Zamanlama süreçleri (cron ve at) | Bütün platformlarda kullanılabilir değildir.
$LOG_AUTHPRIV | LOG_AUTHPRIV | Güvenlik/kimlik doğrulama iletileri (özel) | AIX üzerinde kullanılmaz.
$LOG_LOCAL0 | LOG_LOCAL0 | Yerel kullanım için ayrılmıştır. | Windows ve Netware üzerinde kullanılmaz.
$LOG_LOCAL1 | LOG_LOCAL1 | Yerel kullanım için ayrılmıştır. | Windows ve Netware üzerinde kullanılmaz.
$LOG_LOCAL2 | LOG_LOCAL2 | Yerel kullanım için ayrılmıştır. | Windows ve Netware üzerinde kullanılmaz.
$LOG_LOCAL3 | LOG_LOCAL3 | Yerel kullanım için ayrılmıştır. | Windows ve Netware üzerinde kullanılmaz.
$LOG_LOCAL4 | LOG_LOCAL4 | Yerel kullanım için ayrılmıştır. | Windows ve Netware üzerinde kullanılmaz.
$LOG_LOCAL5 | LOG_LOCAL5 | Yerel kullanım için ayrılmıştır. | Windows ve Netware üzerinde kullanılmaz.
$LOG_LOCAL6 | LOG_LOCAL6 | Yerel kullanım için ayrılmıştır. | Windows ve Netware üzerinde kullanılmaz.
$LOG_LOCAL7 | LOG_LOCAL7 | Yerel kullanım için ayrılmıştır. | Windows ve Netware üzerinde kullanılmaz.
$LOG_PID | LOG_PID | Her iletide PID'i de içer. |
$LOG_CONS | LOG_CONS | Veriyi sistem günlüğüne gönderirken bir hata oluşursa doğrudan sistem konsoluna yaz. |
$LOG_ODELAY | LOG_ODELAY | İlk ileti günlüğe kaydolana kadar bağlantı açılışını ertele. |
$LOG_NDELAY | LOG_NDELAY | Günlük kayıtçısına hemen bir bağlantı aç. |
$LOG_NOWAIT | LOG_NOWAIT |  | BeOS üzerinde kullanılmaz.
$LOG_PERROR | LOG_PERROR | Günlük iletisini ayrıca standart hataya da yaz. | AIX üzerinde kullanılmaz.
Uyarı

Bu işlevin kullanımı PHP 5.3.0'dan beri ÖNERİLMEMEKTEDİR ve PHP 6.0.0'da tamamen KALDIRILMIŞTIR. Bu işleve kesinlikle güvenmemelisiniz.

Örnekler

Örnek 1 - define_syslog_variables() örneği

<?php
// Bakalım, syslog değişkenleri tanımlanmış mı?
if(!get_cfg_var('define_syslog_variables'))
{
    define_syslog_variables();
}

// Günlüğü açalım
openlog('', $LOG_ODELAY, $LOG_MAIL | $LOG_USER);

// Betiğin devamı ...
?>

Sürüm Bilgisi

Sürüm: | Açıklama
6.0.0 | İşlev PHP'den kaldırıldı.
5.3.0 | Bu işlev artık bir E_DEPRECATED uyarısı veriyor.

Ayrıca Bakınız

  • openlog() - Sistem günlükçüsüne erişim için bağlantı açar
  • syslog() - Bir sistem günlüğü iletisi üretir
  • closelog() - Sistem günlükçüsü bağlantısını kapatır

closelog
dns_check_record
Ağ İşlevleri


checkdnsrr işlevinin takma adıdır

define_syslog_variables
dns_get_mx
Ağ İşlevleri
PHP Manual

dns_check_record

(PHP 5, PHP 7)

dns_check_record — checkdnsrr() işlevinin takma adıdır

Açıklama

Bu işlev checkdnsrr() işlevinin takma adıdır.

define_syslog_variables
dns_get_mx
Ağ İşlevleri


getmxrr işlevinin takma adıdır

dns_check_record
dns_get_record
Ağ İşlevleri
PHP Manual

dns_get_mx

(PHP 5, PHP 7)

dns_get_mx — getmxrr() işlevinin takma adıdır

Açıklama

Bu işlev getmxrr() işlevinin takma adıdır.

dns_check_record
dns_get_record
Ağ İşlevleri


Belirtilen konak adı ile ilgili DNS Özkaynak Kayıtlarını getirir

dns_get_mx
fsockopen
Ağ İşlevleri
PHP Manual

dns_get_record

(PHP 5, PHP 7)

dns_get_record — Belirtilen konak adı ile ilgili DNS Özkaynak Kayıtlarını getirir

Açıklama

array dns_get_record ( string $konakadı [, int $tür = DNS_ANY [, array &$yetkili_enesler [, array &$ek_kayıtlar ]]] )

Belirtilen konakadı ile ilgili DNS Özkaynak Kayıtlarını (DNS-RR) getirir.

Değiştirgeler

konakadı

konakadı, "www.example.com" gibi geçerli bir konak adı olmalıdır. Ters DNS sorguları in-addr.arpa gösterimiyle üretilir, fakat gethostbyaddr() işlevi ters DNS sorguları için daha kullanışlıdır.

Bilginize:

DNS standartlarının amacı gereği, posta adresleri kullanıcı.konak biçiminde verilir (örneğin, hostmaster@example.com değil hostmaster.example.com). Sorgudan böyle bir değer aldıysanız, mail() gibi bir işlevde kullanmadan önce bunu normal eposta adresi haline getirmelisiniz.

tür

dns_get_record() öntanımlı olarak, konakadı ile ilgili bütün özkaynak kayıtlarını arayacaktır. Sorguyu belli kayıtlarla sınırlamak için isteğe bağlı tür değiştirgesini kullanabilirsiniz. tür olarak şunlardan biri belirtilebilir: DNS_A, DNS_CNAME, DNS_HINFO, DNS_MX, DNS_NS, DNS_PTR, DNS_SOA, DNS_TXT, DNS_AAAA, DNS_SRV, DNS_NAPTR, DNS_A6, DNS_ALL veya DNS_ANY. DNS_ANY öntanımlıdır.

Bilginize:

Çeşitli platformlarda libresolv başarımının dışmerkezliliğinden dolayı DNS_ANY her zaman bütün kayıtları döndürmez. Daha yavaş fakat daha güvenilir olan DNS_ALL tüm kayıtları toplayacaktır.

yetkili_enesler

Gönderimli aktarılır. Belirtilirse Yetkili Ad Sunucuları ile ilgili Özkaynak Kayıtları bu diziye yerleştirilir.

ek_kayıtlar

Gönderimli aktarılır. Belirtilirse Ek Kayıtlar ile ilgili Özkaynak Kayıtları bu diziye yerleştirilir.

Dönen Değerler

Bu işlev ilişkisel diziler içeren bir dizi ile döner. He ilişkisel dizi en azından aşağıdaki anahtarları mutlaka içerir:

Temel DNS öznitelikleri
Öznitelik | Anlamı
host | DNS isim alanındaki, ilişkili tüm verinin atfedildiği kayıt.
class | dns_get_record() daima sadece İnternet sınıfı kayıtları döndürdüğünden bu üyenin değeri daima IN'dir.
type | Kayıt türünü içeren dizge. Tür değerine bağlı olarak dizide ek öznitelikler bulunabilir. Aşağıdaki tabloya bakınız.
ttl | "Time To Live". Bu kayıt için kalan yaşam süresi. Bu değer, özgün ttl ile aynı değildir. Özgün ttl'den yetkili isim sunucu sorgulandığından beri geçen süre düşüldükten sonra kalan değerdir.

İlişkisel dizide 'type' anahtarına bağlı diğer anahtarlar
Tür | Ek Sütunlar
A | ip: Noktalı sayısal gösterimle bir IPv4 adresi.
MX | pri: Posta alıcısının önceliği. Düşük sayılar daha yüksek öncelik belirtir.
 | target: Posta alıcısının tamamen nitelenmiş alan adı. Ayrıca bakınız: dns_get_mx().
CNAME | target: Kaydın takma ad olduğu DNS isim alanındaki konumun tamamen nitelenmiş alan adı.
NS | target: Bu konak adı için yetkili olan isim sunucusunun tamamen nitelenmiş alan adı.
PTR | target: DNS isim alanında bu kayda işaret eden konum.
TXT | txt: Bu kayıtla ilişkili dizge türünde keyfi bir veri.
HINFO | cpu: Bu kaydın gösterdiği makinenin işlemcisi için IANA ismi.
 | os: Bu kaydın gösterdiği makinenin işletim sistemi için IANA ismi. Bu değerlerin anlamları için IANA'nın » İşletim Sistemi İsimleri belgesine bakınız.
SOA | mname: Özkaynak kaydının kaynaklandığı makinenin tamamen nitelenmiş alan adı.
 | rname: Bu alanın içerik yetkilisinin eposta adresi.
 | serial: İstenen alanın bu sürümünün sıra numarası.
 | refresh: Bu alanın uzak kopyaları güncellenirken ikincil isim sunucularının tazelenme süresi (saniye cinsinden).
 | retry: Tekrar bir tazeleme yapmadan önce beklenecek süre (saniye cinsinden).
 | expire: Başarısız bir tazelemenin ardından bölge verisinin uzak kopyalarını silmeden önce DNS sunucusunun bekleyeceği azami süre (saniye cinsinden).
 | minimum-ttl: Bir istemcinin sunucudan yeni bir çözünürlük isteği yapmadan önce mevcut DNS çözünürlüğünü kullanmaya devam edebileceği asgari süre (saniye cinsinden). Özkaynak kayıtlarının her biri kendi süresini belirleyerek bunu geçersiz kılabilir.
AAAA | ipv6: IPv6 adresi.
A6 (PHP >= 5.1.0) | masklen: chain ile belirtilen hedeften miras alınan uzunluk (bit cinsinden).
 | ipv6: chain'e katıştırılacak bu özel kayıt için adres.
 | chain: ipv6 verisi ile katıştırılacak ebeveyn kayıt.
SRV | pri: (Priority kısaltması) En düşük değerin önceliği en yüksektir.
 | weight: Ortak önceliklerin tercih sıralaması.
 | targets rasgele seçilmelidir. target ve port: İstenen hizmetin bulunabileceği konak adı ve port. Ek bilgi için » RFC 2782'ye bakınız.
NAPTR | order ve pref: Yukarıdaki pri ve weight ile eşdeğerdirler.
 | flags, services, regex ve replacement: » RFC 2915 tarafından tanımlanmış değiştirgelerdir.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | İşlev Windows platformlarında da kullanılabilir oldu.

Örnekler

Örnek 1 - dns_get_record() kullanımı

<?php
$result = dns_get_record("php.net");
print_r($result);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [0] => Array
        (
            [host] => php.net
            [type] => MX
            [pri] => 5
            [target] => pair2.php.net
            [class] => IN
            [ttl] => 6765
        )

    [1] => Array
        (
            [host] => php.net
            [type] => A
            [ip] => 64.246.30.37
            [class] => IN
            [ttl] => 8125
        )

)

Örnek 2 - dns_get_record() ve DNS_ANY kullanımı

MX kaydı çözümlendikten sonra normal olarak posta sunucusunun adresi istenir. dns_get_record() işlevi ayrıca, ilişkili kayıtları ek_kayıtlar dizisinde döndürür. Bunun yanında, yetkili_enesler dizisinde de yetkili isim sunucularının listesini döndürür.

<?php
/* php.net için "ANY" kayıt isteği yaparken
   isim sunucularının ve ek kayıtların listeleri için
   $yetkiliNS ve $ekkayıtlar dizilerini kullanalım */
 $yetkilins=array(); $ekler=array();
$sonuç = dns_get_record("php.net", DNS_ANY, $yetkilins, $ekler);
echo "Sonuç = ";
print_r($sonuç);
echo "Yetkili NS = ";
print_r($yetkilins);
echo "Ek Kayıtlar = ";
print_r($ekler);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Sonuç = Array
(
    [0] => Array
        (
            [host] => php.net
            [type] => MX
            [pri] => 5
            [target] => pair2.php.net
            [class] => IN
            [ttl] => 6765
        )

    [1] => Array
        (
            [host] => php.net
            [type] => A
            [ip] => 64.246.30.37
            [class] => IN
            [ttl] => 8125
        )

)
Yetkili NS = Array
(
    [0] => Array
        (
            [host] => php.net
            [type] => NS
            [target] => remote1.easydns.com
            [class] => IN
            [ttl] => 10722
        )

    [1] => Array
        (
            [host] => php.net
            [type] => NS
            [target] => remote2.easydns.com
            [class] => IN
            [ttl] => 10722
        )

    [2] => Array
        (
            [host] => php.net
            [type] => NS
            [target] => ns1.easydns.com
            [class] => IN
            [ttl] => 10722
        )

    [3] => Array
        (
            [host] => php.net
            [type] => NS
            [target] => ns2.easydns.com
            [class] => IN
            [ttl] => 10722
        )

)
Ek Kayıtlar = Array
(
    [0] => Array
        (
            [host] => pair2.php.net
            [type] => A
            [ip] => 216.92.131.5
            [class] => IN
            [ttl] => 6766
        )

    [1] => Array
        (
            [host] => remote1.easydns.com
            [type] => A
            [ip] => 64.39.29.212
            [class] => IN
            [ttl] => 100384
        )

    [2] => Array
        (
            [host] => remote2.easydns.com
            [type] => A
            [ip] => 212.100.224.80
            [class] => IN
            [ttl] => 81241
        )

    [3] => Array
        (
            [host] => ns1.easydns.com
            [type] => A
            [ip] => 216.220.40.243
            [class] => IN
            [ttl] => 81241
        )

    [4] => Array
        (
            [host] => ns2.easydns.com
            [type] => A
            [ip] => 216.220.40.244
            [class] => IN
            [ttl] => 81241
        )

)

Notlar

Bilginize:

Bu işlevin henüz gerçeklenmediği PHP sürümlerinin kullanıldığı Windows ve *BSD sistemlerinde de (Mac dahil) » PEAR » Net_DNS sınıfını deneyin.

Ayrıca Bakınız

  • dns_get_mx() - getmxrr işlevinin takma adıdır
  • dns_check_record() - checkdnsrr işlevinin takma adıdır

dns_get_mx
fsockopen
Ağ İşlevleri


Bir internet veya Unix alan soketi bağlantısı açar

dns_get_record
gethostbyaddr
Ağ İşlevleri
PHP Manual

fsockopen

(PHP 4, PHP 5, PHP 7)

fsockopen — Bir internet veya Unix alan soketi bağlantısı açar

Açıklama

resource fsockopen ( string $konakadı [, int $port = -1 [, int &$hatanum [, string &$hata_iletisi [, float $zaman_aşımı = ini_get("default_socket_timeout") ]]]] )

konakadı ile belirtilen kaynağa bir soket bağlantısı başlatır.

PHP, Desteklenen Soket Aktarımlarının Listesi bölümünde açıklanan internet ve Unix alanlarını destekler. Desteklenen aktarımların bir listesi ayrıca, stream_get_transports() işlevi kullanılarak da alınabilir.

Soket öntanımlı olarak engellenen kipte açılır. Engellenmeyen kipe geçmek için stream_set_blocking() işlevini kullanabilirsiniz.

Değiştirgeler

konakadı

Derleme sırasında OpenSSL desteği vermişseniz, uzak konağa TCP/IP üzerinden bir SSL veya TLS istemci bağlantısı açmak için konakadı belirtirken ssl:// veya tls:// önekini kullanabilirsiniz.

port

Port numarası.

hatanum

Bir değiştirge sağlanmışsa, sistem seviyesi connect() çağrısında oluşan sistem seviyesi hata numarası bu değiştirgeye yerleştirilir.

Eğer işlev FALSE değeriyle dönmüş ve hatanum değiştirgesinde 0 değeri varsa, connect() çağrısı öncesinde bir hata oluşmuş demektir. Bu sorun genellikle soketin ilklendirilmesi ile ilgilidir.

hata_iletisi

Bir dizge olarak hata iletisi.

zaman_aşımı

Saniye cinsinden bağlantı zaman aşımı.

Bilginize:

Verinin sokete yazılması/okunması ile ilgili bir zaman aşımını sadece bağlandığınız soket için belirtmek isterseniz, zaman_aşımı değiştirgesi olarak stream_set_timeout() işlevini kullanın.

Dönen Değerler

fsockopen(), diğer dosya işlevleriyle
(fgets(), fgetss(),
fwrite(), fclose() ve
feof() gibi) kullanmak üzere bir dosya tanıtıcısı ile
döner. Eğer çağrı başarısız olursa FALSE döner.

Hatalar/İstisnalar

konakadı geçerli bir alan adı değilse bir E_WARNING çıktılanır.

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.0 | Win32 için zaman_aşımı değiştirgesi eklendi.
4.3.0 | TCP/IP üzerinden SSL ve TLS desteği eklendi.
4.0.0 | UDP desteği eklendi.

Örnekler

Örnek 1 - fsockopen() örneği

<?php
$fp = fsockopen("mesela.dom", 80, $errno, $errstr, 30);
if (!$fp) {
    echo "$errstr ($errno)<br />\n";
} else {
    $out = "GET / HTTP/1.1\r\n";
    $out .= "Host: mesela.dom\r\n";
    $out .= "Connection: Close\r\n\r\n";
    fwrite($fp, $out);
    while (!feof($fp)) {
        echo fgets($fp, 128);
    }
    fclose($fp);
}
?>

Örnek 2 - UDP bağlantısı kullanımı

Aşağıdaki örnekte, makinenizdeki "daytime" (port 13) UDP hizmetini kullanarak tarih ve saati nasıl elde edeceğiniz gösterilmiştir:

<?php
$fp = fsockopen("udp://127.0.0.1", 13, $errno, $errstr);
if (!$fp) {
    echo "HATA: $errno - $errstr<br />\n";
} else {
    fwrite($fp, "\n");
    echo fread($fp, 26);
    fclose($fp);
}
?>

Notlar

Bilginize:

Platforma bağlı olarak Unix alanı veya isteğe bağlı bağlantı zaman aşımı kullanılamayabilir.

Uyarı

Uzak konak erişilebilir olmasa bile UDP soketler bazen hatasız açılmış gibi görünebilir. Hata sadece sokete okuma/yazma sırasında kendini gösterir. Bunun sebebi UDP'nin "bağlantısız" bir protokol olmasıdır. Yani, işletim sistemi gerçekten veri alana veya gönderene kadar sokete bir hat tahsis etmez.

Bilginize: Bir sayısal IPv6 adresi (fe80::1 gibi) belirtirken port numarasıda belirtmek isterseniz IP adresini köşeli ayraçlar arasına almalısınız. Örnek: tcp://[fe80::1]:80.

Ayrıca Bakınız

  • pfsockopen() - Kalıcı bir internet veya Unix alan soketi bağlantısı açar
  • stream_set_blocking() - Akımın engelleme kipini ayarlar
  • stream_set_timeout() - Akımın zaman aşımı süresini ayarlar
  • fgets() - Dosya tanıtıcısından bir satır döndürür
  • fgetss() - Dosya tanıtıcısından bir satırı HTML etiketlerinden arındırarak döndürür
  • fwrite() - Dosyaya ikil kipte yazar
  • fclose() - Açık bir dosya tanıtıcısını kapatır
  • feof() - Bir dosya tanıtıcısı üzerinde konum dosya sonunda mı diye bakar
  • Curl eklentisi

dns_get_record
gethostbyaddr
Ağ İşlevleri


Belirtilen IP adresine çözümlenen konak ismini döndürür

fsockopen
gethostbyname
Ağ İşlevleri
PHP Manual

gethostbyaddr

(PHP 4, PHP 5, PHP 7)

gethostbyaddr — Belirtilen IP adresine çözümlenen konak ismini döndürür

Açıklama

string gethostbyaddr ( string $ip_adresi )

ip_adresi belirtilen konak adıyla döner.

Değiştirgeler

ip_adresi

Konağın IP adresi.

Dönen Değerler

Başarısızlık durumunda ip_adresi ile aksi takdirde konak ismi ile döner.

Örnekler

Örnek 1 - gethostbyaddr() örnek

<?php
$hostname = gethostbyaddr($_SERVER['REMOTE_ADDR']);

echo $hostname;
?>

Ayrıca Bakınız

  • gethostbyname() - Belirtilen konak adına ait IPv4 adresini döndürür
  • gethostbynamel() - Belirtilen konak adına ait IPv4 adreslerini döndürür

fsockopen
gethostbyname
Ağ İşlevleri


Belirtilen konak adına ait IPv4 adresini döndürür

gethostbyaddr
gethostbynamel
Ağ İşlevleri
PHP Manual

gethostbyname

(PHP 4, PHP 5, PHP 7)

gethostbyname — Belirtilen konak adına ait IPv4 adresini döndürür

Açıklama

string gethostbyname ( string $konakadı )

Belirtilen konakadı'nın IPv4 adresini döndürür.

Değiştirgeler

konakadı

Konak adı.

Dönen Değerler

Başarı durumunda bir dizge olarak IPv4 adresiyle, aksi takdirde konakadı ile döner.

Örnekler

Örnek 1 - gethostbyname() örneği

<?php
$ip = gethostbyname('localhost');

echo $ip;
?>

Ayrıca Bakınız

  • gethostbyaddr() - Belirtilen IP adresine çözümlenen konak ismini döndürür
  • gethostbynamel() - Belirtilen konak adına ait IPv4 adreslerini döndürür
  • inet_pton() - İnsan okuyabilir bir IP adresini in_addr gösterimine dönüştürür
  • inet_ntop() - Bir IP adresinin in_addr gösterimini insan okuyabilir gösterime dönüştürür

gethostbyaddr
gethostbynamel
Ağ İşlevleri


Belirtilen konak adına ait IPv4 adreslerini döndürür

gethostbyname
gethostname
Ağ İşlevleri
PHP Manual

gethostbynamel

(PHP 4, PHP 5, PHP 7)

gethostbynamel — Belirtilen konak adına ait IPv4 adreslerini döndürür

Açıklama

array gethostbynamel ( string $konakadı )

Belirtilen konakadı'na çözümlenen IPv4 adreslerinin listesini döndürür.

Değiştirgeler

konakadı

Konak adı.

Dönen Değerler

konakadı çözümlenemezse FALSE, aksi takdirde IPv4 adreslerinin listesini döndürür.

Örnekler

Örnek 1 - gethostbynamel() örneği

<?php
$hosts = gethostbynamel('www.example.com');
print_r($hosts);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [0] => 208.77.188.166
)

Ayrıca Bakınız

  • gethostbyname() - Belirtilen konak adına ait IPv4 adresini döndürür
  • gethostbyaddr() - Belirtilen IP adresine çözümlenen konak ismini döndürür
  • checkdnsrr() - Belirtilen bir konak adı veya IP adresi için DNS sorgusu yapar
  • getmxrr() - Belirtilen konak adı ile ilgili MX kaydını döndürür
  • named(8) kılavuz sayfası

gethostbyname
gethostname
Ağ İşlevleri


Konak ismini döndürür

gethostbynamel
getmxrr
Ağ İşlevleri
PHP Manual

gethostname

(PHP >= 5.3.0)

gethostname — Konak ismini döndürür

Açıklama

string gethostname ( void )

gethostname() işlevi yerel makinenin standard konak ismini döndürür.

Dönen Değerler

Başarısızlık durumunda FALSE. aksi takdirde konak ismini bir dizge olarak döndürür.

Örnekler

Örnek 1 - gethostname() örneği

<?php
echo gethostname(); // çıktısı şu olabilir: posta
?>

Ayrıca Bakınız

  • gethostbyname() - Belirtilen konak adına ait IPv4 adresini döndürür

gethostbynamel
getmxrr
Ağ İşlevleri


Belirtilen konak adı ile ilgili MX kaydını döndürür

gethostname
getprotobyname
Ağ İşlevleri
PHP Manual

getmxrr

(PHP 4, PHP 5, PHP 7)

getmxrr — Belirtilen konak adı ile ilgili MX kaydını döndürür

Açıklama

bool getmxrr ( string $konakadı , array &$emiksler [, array &$önem ] )

Belirtilen konakadı için DNS'deki MX kaydını döndürür.

Değiştirgeler

konakadı

Ağ konak adı.

emiksler

Bulunan MX kayıtlarının yerleştirileceği dizi.

önem

MX konaklarının isteklere yanıt verme sırasını belirleyen bilginin yerleştirileceği dizi (seçimlik).

Dönen Değerler

Bir MX kaydı bulunmuşsa TRUE, bir kayıt yoksa veya bir hata oluşmuşsa FALSEdöner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | İşlev Windows platformlarında da kullanılabilir oldu.

Notlar

Bilginize:

Bu işlev adres doğrulamak amacıyla kullanılmamalıdır. Sadece DNS'de kayıtlı olan posta alıcıları döndürülür. Ancak, » RFC 2821'e göre konak adı için bir MX kaydı yoksa posta alıcısı olarak 0 önem derecesi ile konakadı'nın kullanılması gerekir.

Bilginize:

Bu işlevin henüz gerçeklenmediği PHP sürümlerini çalıştıran Windows platformlarında » PEAR » Net_DNS sınıfını deneyin.

Ayrıca Bakınız

  • checkdnsrr() - Belirtilen bir konak adı veya IP adresi için DNS sorgusu yapar
  • dns_get_record() - Belirtilen konak adı ile ilgili DNS Özkaynak Kayıtlarını getirir
  • gethostbyname() - Belirtilen konak adına ait IPv4 adresini döndürür
  • gethostbynamel() - Belirtilen konak adına ait IPv4 adreslerini döndürür
  • gethostbyaddr() - Belirtilen IP adresine çözümlenen konak ismini döndürür
  • named(8) veya host(1) kılavuz sayfası

gethostname
getprotobyname
Ağ İşlevleri


Protokol ismine karşılık düşen protokol numarasını verir

getmxrr
getprotobynumber
Ağ İşlevleri
PHP Manual

getprotobyname

(PHP 4, PHP 5, PHP 7)

getprotobyname — Protokol ismine karşılık düşen protokol numarasını verir

Açıklama

int getprotobyname ( string $ad )

getprotobyname() işlevi belirtilen protokol ad'ı için /etc/protocols dosyasındaki protokol numarasını döndürür.

Değiştirgeler

ad

Protokolün adı.

Dönen Değerler

Protokol ismini bulamazsa -1, aksi takdirde protokol numarası ile döner.

Örnekler

Örnek 1 - getprotobyname() örneği

<?php
$protokol = 'tcp';
$protnum = getprotobyname($protokol);
if ($protnum == -1) {
    echo 'Geçersiz protokol';
} else {
    echo 'Protokol #' . $protnum;
}
?>

Ayrıca Bakınız

  • getprotobynumber() - Protokol numarasına karşılık düşen protokol ismini verir

getmxrr
getprotobynumber
Ağ İşlevleri


Protokol numarasına karşılık düşen protokol ismini verir

getprotobyname
getservbyname
Ağ İşlevleri
PHP Manual

getprotobynumber

(PHP 4, PHP 5, PHP 7)

getprotobynumber — Protokol numarasına karşılık düşen protokol ismini verir

Açıklama

string getprotobynumber ( int $numara )

getprotobynumber() işlevi belirtilen protokol numara'sı için /etc/protocols dosyasındaki protokol ismini döndürür.

Değiştirgeler

numara

Protokol numarası.

Dönen Değerler

Protokol ismini bir dizge olarak döndürür.

Ayrıca Bakınız

  • getprotobyname() - Protokol ismine karşılık düşen protokol numarasını verir

getprotobyname
getservbyname
Ağ İşlevleri


Belirtilen ağ hizmeti ve protokolle ilişkili port numarası ile döner

getprotobynumber
getservbyport
Ağ İşlevleri
PHP Manual

getservbyname

(PHP 4, PHP 5, PHP 7)

getservbyname — Belirtilen ağ hizmeti ve protokolle ilişkili port numarası ile döner

Açıklama

int getservbyname ( string $hizmet , string $protokol )

getservbyname() işlevi, /etc/services dosyasında protokol için belirtilen hizmet ile ilişkili port numarasını döndürür.

Değiştirgeler

hizmet

Dizge olarak ağ hizmeti ismi.

protokol

protokol olarak "tcp" veya "udp" (küçük harflerle) belirtilebilir.

Dönen Değerler

hizmet veya protokol bulunamazsa, FALSE ile aksi takdirde port numarası ile döner.

Örnekler

Örnek 1 - getservbyname() örneği

<?php
$hizmetler = array('http', 'ftp', 'ssh', 'telnet', 'imap',
'smtp', 'nicname', 'gopher', 'finger', 'pop3', 'www');

foreach ($hizmetler as $hizmet) {
    $port = getservbyname($hizmet, 'tcp');
    echo $hizmet . ": " . $port . "<br />\n";
}
?>

Ayrıca Bakınız

  • getservbyport() - Belirtilen port ve protokolle ilgili ağ hizmeti ile döner
  • Port numaralarının tam listesi için: » http://www.iana.org/assignments/port-numbers

getprotobynumber
getservbyport
Ağ İşlevleri


Belirtilen port ve protokolle ilgili ağ hizmeti ile döner

getservbyname
header_register_callback
Ağ İşlevleri
PHP Manual

getservbyport

(PHP 4, PHP 5, PHP 7)

getservbyport — Belirtilen port ve protokolle ilgili ağ hizmeti ile döner

Açıklama

string getservbyport ( int $port , string $protokol )

getservbyport() işlevi belirtilen protokol için /etc/services dosyasında port ile ilişkilendirilmiş ağ hizmetini döndürür.

Değiştirgeler

port

Port numarası.

protokol

protokol olarak "tcp" veya "udp" (küçük harflerle) belirtilebilir.

Dönen Değerler

Ağ hizmetinin ismini bir dizge olarak döndürür.

Ayrıca Bakınız

  • getservbyname() - Belirtilen ağ hizmeti ve protokolle ilişkili port numarası ile döner

getservbyname
header_register_callback
Ağ İşlevleri


Call a header function

getservbyport
header_remove
Ağ İşlevleri
PHP Manual

header_register_callback

(PHP 5 >= 5.4.0, PHP 7)

header_register_callback — Call a header function

Açıklama

bool header_register_callback ( callable $callback )

Registers a function that will be called when PHP starts sending output.

The callback is executed just after PHP prepares all headers to be sent, and before any other output is sent, creating a window to manipulate the outgoing headers before being sent.

Değiştirgeler

callback

Function called just before the headers are sent. It gets no parameters and the return value is ignored.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 header_register_callback() example

<?php

header('Content-Type: text/plain');
header('X-Test: foo');

function foo() {
 foreach (headers_list() as $header) {
   if (strpos($header, 'X-Powered-By:') !== false) {
     header_remove('X-Powered-By');
   }
   header_remove('X-Test');
 }
}

$result = header_register_callback('foo');
echo "a";
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Content-Type: text/plain

a

Notlar

header_register_callback() is executed just as the headers are about to be sent out, so any output from this function can break output.

Bilginize:

Başlıklar sadece onları destekleyen bir SAPI kullanımdaysa erişilebilir ve çıktılanabilir olacaktır.

Ayrıca Bakınız

  • headers_list() - Gönderilmiş (veya gönderilmeye hazır) yanıt başlıklarının listesiyle döner
  • header_remove() - Remove previously set headers
  • header() - Ham bir HTTP başlığı gönderir
getservbyport
header_remove
Ağ İşlevleri


Remove previously set headers

header_register_callback
header
Ağ İşlevleri
PHP Manual

header_remove

(PHP 5 >= 5.3.0, PHP 7)

header_remove — Remove previously set headers

Açıklama

void header_remove ([ string $name ] )

Removes an HTTP header previously set using header().

Değiştirgeler

name

The header name to be removed.

Bilginize: This parameter is case-insensitive.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Unsetting specific header.

<?php
header("X-Foo: Bar");
header("X-Bar: Baz");
header_remove("X-Foo");
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

X-Bar: Baz

Örnek 2 Unsetting all previously set headers.

<?php
header("X-Foo: Bar");
header("X-Bar: Baz");
header_remove();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Notlar

Dikkat

    This function will remove all headers set by PHP,
    including cookies, session and the X-Powered-By headers.

Bilginize:

    Başlıklar sadece onları destekleyen bir SAPI kullanımdaysa erişilebilir ve
    çıktılanabilir olacaktır.

Ayrıca Bakınız

  • header() - Ham bir HTTP başlığı gönderir
    •

  • headers_sent() - Başlıklar gönderilmiş mi, gönderilmişse nerede gönderilmiş diye bakar
    •

header_register_callback

header

Ağ İşlevleri


Ham bir HTTP başlığı gönderir

header_remove
headers_list
Ağ İşlevleri
PHP Manual

header

(PHP 4, PHP 5, PHP 7)

header — Ham bir HTTP başlığı gönderir

Açıklama

void header ( string $dizge [, bool $değiştir = true [, int $http_yanıt_kodu ]] )

header() işlevi ham bir HTTP başlığı göndermek için kulanılır. HTTP başlıkları hakkında ayrıntılı bilgi edinmek için » HTTP/1.1 Belirtimi'ne bakınız.

header() işlevinin normal HTML etiketleri ve dosya veya PHP'deki boş satırlar dahil herhangi bir çıktıdan önce çağrılması gerektiğini unutmayınız. header() çağrısından önce sıkça yapılan hatalar: kodu include, require veya başka bir dosya okuma işlevi ile okumak; betik HTML'ye gömülüyse betiğin veya dosyanın başındaki boşluklar veya boş satırlar.

<html>
<?php
/* Bu bir hata verecektir.  header() çağrısından
 * önce hiçbir satırlar olmamalıydı. */
header('Location: http://localhost/');
?>

Değiştirgeler

dizge

Başlık dizgesi.

İki özel çağrı biçimi vardır. İlki, HTTP durum kodu gönderilirken kullanılır ve başlık "HTTP/" dizgesi ile başlar (harf büyüklüğüne duyarsız). Örneğin Apache'yi eksik dosyalarla ilgili sorunlar için (ErrorDocument yönergesi ile) bir PHP betiğini kullanacak şekilde yapılandırmışsanız betiğinizde uygun bir durum kodu üretmek için bu biçimi kullanabilirsiniz.

<?php
header("HTTP/1.0 404 Not Found");
?>

İkinci özel biçim "Location:" başlığıdır. Bu başlığın tarayıcıya geri gönderilmesinden başka, bir 201 veya 3xx durum kodu henüz atanmamışsa ayrıca bir REDIRECT (302) durum kodu da gönderilir.

<?php
header("Location: http://mesela.dom/"); /* Tarayıcıyı yönlendir */

/* Yönlendirme sonrası herhangi bir kodun çalıştırılmamasını sağlayalım. */
exit;
?>

değiştir

değiştir değiştirgesi isteğe bağlı olup, önceki bir başlığın mı değiştireceğini yoksa aynı türde ikinci bir başlık daha mı ekleneceğini belirtilir. Öntanımlı davranış mevcudu değiştirmektir. İşleve ikinci değiştirge olarak FALSE aktarırsanız aynı türde çok sayıda başlık bulunması için işlevi zorlamış olursunuz. Örnek:

<?php
header('WWW-Authenticate: Negotiate');
header('WWW-Authenticate: NTLM', false);
?>

http_yanıt_kodu

HTTP yanıt kodunun belirtilen değer olması için zorlanır.

Dönen Değerler

Hiçbir değer dönmez.

Sürüm Bilgisi

Sürüm: | Açıklama
4.4.2 ve 5.1.2 | Başlık yerleştirme saldırılarına karşı bir önlem olarak bu işlev artık bir kerede birden fazla başlık gönderilmesine izin vermemektedir.
4.3.0 | http_yanıt_kodu değiştirgesi eklendi.
4.0.4 | değiştir değiştirgesi eklendi.

Örnekler

Örnek 1 - İndirme söyleşisi

Kulanıcıyı, gönderdiğiniz veriyi (örneğin, bir PDF dosyası) kaydetmesi için uyarmak isterseniz, bir dosya ismi belirtmek ve tarayıcının bir dosya kayıt söyleşisi göstermesini sağlamak için » Content-Disposition başlığını kullanabilirsiniz.

<?php
// Bir PDF çıktılayacağız
header('Content-type: application/pdf');

// Dosya ismi indirilen.pdf olsun
header('Content-Disposition: attachment; filename="indirilen.pdf"');

// Okunacak PDF dosyası
readfile('original.pdf');
?>

Örnek 2 - Yönergelerin önbelleklenmesi

PHP betikleri çoğunlukla istemcinin tarayıcısı veya sunucuya aracılık eden vekiller tarafından önbelleğe alınmaması gereken devingen içerikler üretirler. Çoğu vekilin veya tarayıcının önbellekleme işlemini kapatmasını şöyle sağlayabilirsiniz:

<?php
header("Cache-Control: no-cache, must-revalidate"); // HTTP/1.1
header("Expires: Sat, 26 Jul 1997 05:00:00 GMT"); // Geçmişte bir tarih
?>

Bilginize:

Yukarıdaki başlıkların hiçbirini çıktılamadığınız halde sayfalarınız önbelleğe alınmıyor olabilir. Kullanıcının kendi tarayıcısının önbellekleme ile ilgili öntanımlı davranışını değiştirebileceği çok çeşitli seçenekleri olabilir. Yukarıdaki başlıkları göndererek bu tür olası ayarları geçersiz kılabilirsiniz.

Ayrıca, oturumları kullanırken önbellekleme ile ilgili doğru başlıkların özdevinimli olarak üretilmesi için session_cache_limiter() işlevini ve session.cache_limiter yapılandırma yönergesini kullanabilirsiniz.

Notlar

Bilginize:

PHP 4'ten itibaren, bu işlevi çağırmadan önce, tarayıcıya gönderilene kadar sunucuda bekletilmek üzere çıktıyı bir tampona yazabilirsiniz. Bu işlemi betiğinizden ob_start() ve ob_end_flush() işlevlerini çağırarak veya output_buffering yapılandırma yönergesini php.ini veya sunucu yapılandırma dosyalarında belirterek yapabilirsiniz.

Bilginize:

header() çağrısının ilk çağrı olup olmamasından bağımsız olarak istemciye ilk olarak daima HTTP durum başlığı satırı gönderilir. header() işlevini hiçbir HTTP başlığı gönderilmeden önce yeni bir durum satırı ile kullanırsanız bu durum satırını geçersiz kılabilirsiniz.

Bilginize:

Microsoft Internet Explorer 4.01'de bunun çalışmasını engelleyen bir hata vardır ve bundan kurtulmanın çaresi yoktur. Ayrıca, Microsoft Internet Explorer 5.5'te de böyle bir hata vardır. Fakat SP2'ye yükselterek bu sorundan kurtulmak mümkündür.

Bilginize: Eğer safe mode etkinse ve HTTP kimlik doğrulaması için WWW-Authenticate başlığını kullanıyorsanız başlığın realm alanına betiğin kullanıcı kimliği eklenecektir.

Bilginize:

HTTP/1.1, » Location: için değiştirge olarak bir mutlak URI belirtilmesini gerektirir (şema, konak ismi ve mutlak dosya yolu dahil), fakat bazı istemciler göreli URI'leri kabul ederler. Bir mutlak URI'yi bir göreli URI'ye dönüştürmek için örnekteki gibi $_SERVER['HTTP_HOST'], $_SERVER['PHP_SELF'] ve dirname() kullanabilirsiniz:

<?php
/* Bulunulan dizinde başka bir sayfaya yönlendirelim */
$konak  = $_SERVER['HTTP_HOST'];
$yol   = rtrim(dirname($_SERVER['PHP_SELF']), '/\\');
$ek = 'sayfam.php';
header("Location: http://$konak$yol/$ek");
exit;
?>

Bilginize:

Oturum kimliği, session.use_trans_sid etkin olsa bile Location başlığı ile aktarılmaz. SID sabiti kullanılarak elle aktarılmalıdır.

Ayrıca Bakınız

  • headers_sent() - Başlıklar gönderilmiş mi, gönderilmişse nerede gönderilmiş diye bakar
  • setcookie() - Bir çerez gönderir
  • HTTP kimlik doğrulaması bölümü

header_remove
headers_list
Ağ İşlevleri


Gönderilmiş (veya gönderilmeye hazır) yanıt başlıklarının listesiyle döner

header
headers_sent
Ağ İşlevleri
PHP Manual

headers_list

(PHP 5, PHP 7)

headers_list — Gönderilmiş (veya gönderilmeye hazır) yanıt başlıklarının listesiyle döner

Açıklama

array headers_list ( void )

headers_list() işlevi, tarayıcıya veya istemciye gönderilen başlıkların listesini döndürür. Bu başlıkların henüz gönderilip gönderilmediğini headers_sent() işleviyle öğrenebilirsiniz.

Dönen Değerler

Başlıkları içeren sayısal indisli bir dizi döndürür.

Örnekler

Örnek 1 - headers_list() kullanım örneği

<?php

/* setcookie() kendisi için bir yanıt başlığı ekler */
setcookie('foo', 'bar');

/* Özel bir yanıt başlığı tanımlayalım.
   Bunu çoğu istemci yok sayar. */
header("X-Sample-Test: foo");

/* Yanıtımız salt metin içerdiğini belirtelim */
header('Content-type: text/plain');

/* Hangi başlıklar gönderiliyor? */
var_dump(headers_list());

?>

Yukarıdaki örneğin çıktısı:

array(4) {
  [0]=>
  string(23) "X-Powered-By: PHP/5.1.3"
  [1]=>
  string(19) "Set-Cookie: foo=bar"
  [2]=>
  string(18) "X-Sample-Test: foo"
  [3]=>
  string(24) "Content-type: text/plain"
}

Ayrıca Bakınız

  • headers_sent() - Başlıklar gönderilmiş mi, gönderilmişse nerede gönderilmiş diye bakar
  • header() - Ham bir HTTP başlığı gönderir
  • setcookie() - Bir çerez gönderir
  • apache_response_headers() - Tüm HTTP yanıt başlıklarını alır

header
headers_sent
Ağ İşlevleri


Başlıklar gönderilmiş mi, gönderilmişse nerede gönderilmiş diye bakar

headers_list
http_response_code
Ağ İşlevleri
PHP Manual

headers_sent

(PHP 4, PHP 5, PHP 7)

headers_sent — Başlıklar gönderilmiş mi, gönderilmişse nerede gönderilmiş diye bakar

Açıklama

bool headers_sent ([ string &$dosya [, int &$satır ]] )

Başlıklar gönderilmiş mi, gönderilmişse nerede gönderilmiş diye bakar.

Tüm başlıklar gönderildikten sonra header() işlevini kullanarak daha fazla başlık satırı ekleyemezsiniz. Bu işlevi kullanarak HTTP başlıklarıyla ilgili hata iletilerinden en azından bazılarını engelleyebilirsiniz. Diğer bir seçenek de Çıktı Tamponlaması kullanmaktır.

Değiştirgeler

dosya

İsteğe bağlı dosya ve satır değiştirgeleri kullanılırsa, headers_sent() işlevi çıktının başlatılacağı PHP kaynak dosyası ismi ve satır numarasını dosya ve satır değiştirgelerine yerleştirir.

satır

Çıktının başlatılacağı satır numarası.

Dönen Değerler

Henüz hiçbir başlık gönderilmemişse headers_sent() işlevi FALSE ile döner, aksi takdirde TRUE döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.0 | Seçimlik dosya ve satır değiştirgeleri eklendi.

Örnekler

Örnek 1 - headers_sent() kullanım örnekleri

<?php

// Henüz hiçbir başlık gönderilmemişse bir tane gönder
if (!headers_sent()) {
    header('Location: http://mesela.dom/');
    exit;
}

// PHP 4.3.0'dan itibaren seçimlik dosya ve satır kullanımı örneği.
// $dosya ve $satır değiştirgelerinin daha sonra kullanılmak üzere
// aktarıldığına dikkat edin. Bunlara bir değer atamayın.
if (!headers_sent($dosya, $satır)) {
    header('Location: http://mesela.dom/');
    exit;

// Çoğunlukla burada bir hata alırsınız.
} else {

    echo "Başlıklar $dosya dosyasının $satır. satırında gönderilmiş.\n" .
          "Yönlendirme yapılamıyor, şimdilik <a " .
          "href=\"http://mesela.dom\">buraya tıklayınız</a>\n";
    exit;
}

?>

Ayrıca Bakınız

  • ob_start() - Çıktı tamponlamasını başlatır
  • trigger_error() - Kullanıcı seviyesinde bir hata/uyarı/bilgi iletisi üretir
  • headers_list() - Gönderilmiş (veya gönderilmeye hazır) yanıt başlıklarının listesiyle döner
  • Bu konuda daha ayrıntılı bilgi edinmek için header() - Ham bir HTTP başlığı gönderir belgesine bakınız.

headers_list
http_response_code
Ağ İşlevleri


Get or Set the HTTP response code

headers_sent
inet_ntop
Ağ İşlevleri
PHP Manual

http_response_code

(PHP 5 >= 5.4.0, PHP 7)

http_response_code — Get or Set the HTTP response code

Açıklama

mixed http_response_code ([ int $response_code ] )

Gets or sets the HTTP response status code.

Değiştirgeler

response_code

The optional response_code will set the response code.

Dönen Değerler

If response_code is provided, then the previous status code will be returned. If response_code is not provided, then the current status code will be returned. Both of these values will default to a 200 status code if used in a web server environment.

FALSE will be returned if response_code is not provided and it is not invoked in a web server environment (such as from a CLI application). TRUE will be returned if response_code is provided and it is not invoked in a web server environment (but only when no previous response status has been set).

Örnekler

Örnek 1 Using http_response_code() in a web server environment

<?php

// Get the current response code and set a new one
var_dump(http_response_code(404));

// Get the new response code
var_dump(http_response_code());
?>

Yukarıdaki örneğin çıktısı:

int(200)
int(404)

Örnek 2 Using http_response_code() in a CLI environment

<?php

// Get the current default response code
var_dump(http_response_code());

// Set a response code
var_dump(http_response_code(201));

// Get the new response code
var_dump(http_response_code());
?>

Yukarıdaki örneğin çıktısı:

bool(false)
bool(true)
int(201)

Ayrıca Bakınız

  • header() - Ham bir HTTP başlığı gönderir
  • headers_list() - Gönderilmiş (veya gönderilmeye hazır) yanıt başlıklarının listesiyle döner

headers_sent
inet_ntop
Ağ İşlevleri


Bir IP adresinin in_addr gösterimini insan okuyabilir gösterime dönüştürür

http_response_code
inet_pton
Ağ İşlevleri
PHP Manual

inet_ntop

(PHP 5 >= 5.1.0, PHP 7)

inet_ntop — Bir IP adresinin in_addr gösterimini insan okuyabilir gösterime dönüştürür

Açıklama

string inet_ntop ( string $in_addr )

Bu işlev 32 bitlik IPv4 veya (PHP, IPv6 desteğiyle derenmişse) 128 bitlik IPv6 adresini dizge gösterimli uygun bir adres ailesine dönüştürür.

Değiştirgeler

in_addr

Bir 32 bitlik IPv4 veya 128 bitlik IPv6 adresi

Dönen Değerler

Başarısızlık durumunda FALSE, aksi takdirde adresin dizge gösterimiyle döner.

Örnekler

Örnek 1 - inet_ntop() örneği

<?php
$ikil = chr(127) . chr(0) . chr(0) . chr(1);
$dizge = inet_ntop($packed);

/* Çıktısı: 127.0.0.1 */
echo $dizge;

$ikil = str_repeat(chr(0), 15) . chr(1);
$dizge = inet_ntop($packed);

/* Çıktısı: ::1 */
echo $dizge;
?>

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | İşlev Windows platformlarında da kullanılabilir hale geldi.

Ayrıca Bakınız

  • long2ip() - Bir (IPv4) sayısal ağ adresini noktalı gösterimi içeren bir dizgeye dönüştürür
  • ip2long() - Noktalı IP adresi gösterimini içeren bir dizgeyi sayısal adrese dönüştürür
  • inet_pton() - İnsan okuyabilir bir IP adresini in_addr gösterimine dönüştürür

http_response_code
inet_pton
Ağ İşlevleri


İnsan okuyabilir bir IP adresini in_addr gösterimine dönüştürür

inet_ntop
ip2long
Ağ İşlevleri
PHP Manual

inet_pton

(PHP 5 >= 5.1.0, PHP 7)

inet_pton — İnsan okuyabilir bir IP adresini in_addr gösterimine dönüştürür

Açıklama

string inet_pton ( string $ip_adresi )

Bu işlev, bir insan okuyabilir IPv4 veya (PHP, IPv6 desteğiyle derlenmişse) IPv6 adresini 32 veya 128 bitlik ikil yapılı bir adres ailesine dönüştürür.

Değiştirgeler

ip_adresi

Bir insan okuyabilir IPv4 veya IPv6 adresi.

Dönen Değerler

Belirtilen ip_adresi'nin in_addr gösterimiyle döner.

Örnekler

Örnek 1 - inet_pton() örneği

<?php
$in_addr = inet_pton('127.0.0.1');

$in6_addr = inet_pton('::1');
?>

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | İşlev Windows platformlarında da kullanılabilir hale geldi.

Ayrıca Bakınız

  • ip2long() - Noktalı IP adresi gösterimini içeren bir dizgeyi sayısal adrese dönüştürür
  • long2ip() - Bir (IPv4) sayısal ağ adresini noktalı gösterimi içeren bir dizgeye dönüştürür
  • inet_ntop() - Bir IP adresinin in_addr gösterimini insan okuyabilir gösterime dönüştürür

inet_ntop
ip2long
Ağ İşlevleri


Noktalı IP adresi gösterimini içeren bir dizgeyi sayısal adrese dönüştürür

inet_pton
long2ip
Ağ İşlevleri
PHP Manual

ip2long

(PHP 4, PHP 5, PHP 7)

ip2long — Noktalı IP adresi gösterimini içeren bir dizgeyi sayısal adrese dönüştürür

Açıklama

int ip2long ( string $ip_adresi )

ip2long() işlevi noktalı gösterimini kullanarak bir IPv4 sayısal ağ adresi oluşturur.

ip2long() işlevi ayrıca, tamamı belirtilmemiş IP adresleri ile de çalışır. Daha fazla bilgi için » http://publibn.boulder.ibm.com/doc_link/en_US/a_doc_lib/libs/commtrf2/inet_addr.htm adresine bakınız.

Değiştirgeler

ip_adresi

Noktalı gösterimle bir IPv4 adresi.

Dönen Değerler

Belirtilen ip_adresi geçirsizse FALSE, aksi takdirde IPv4 adresi ile döner

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.0 | Bu sürümden önce, ip2long() işlev başarısız olduğunda -1 döndürüyordu.

Örnekler

Örnek 1 - ip2long() Örneği

<?php
$ip = gethostbyname('localhost');
$out = "Bu adresler aynıdır:<br />\n";
$out .= 'http://localhost/, http://' . $ip . '/ ve http://' .
  sprintf("%u", ip2long($ip)) . "/<br />\n";
echo $out;
?>

Örnek 2 - Bir IP adresinin gösterilmesi

Bu örnekte, PHP4 ve PHP 5'te printf() işleviyle dönüştürülmüş bir adresin nasıl basılacağı gösterilmiştir:

<?php
$ip   = gethostbyname('mesela.dom');
$long = ip2long($ip);

if ($long == -1 || $long === FALSE) {
    echo 'IP geçersiz, tekrar deneyin';
} else {
    echo $ip   . "\n";           // 192.0.34.166
    echo $long . "\n";           // -1073732954
    printf("%u\n", ip2long($ip)); // 3221234342
}
?>

Örnek 3 - IP doğrulama

ip2long() işlevi IP doğrulaması amacıyla tek başına değil, long2ip() ile birlikte kullanılmalıdır:

<?php
// IP'ler geçerli mi, bakalım. Bunu yapmak için eksik belirtilmiş
// IP adreslerini düzgün IP adreslerine dönüştürelim.
$ip = long2ip(ip2long("127.0.0.1")); // "127.0.0.1"
$ip = long2ip(ip2long("10.0.0"));    // "10.0.0.0"
$ip = long2ip(ip2long("10.0.256"));  // "10.0.1.0"
?>

Notlar

Bilginize:

PHP'nin tamsayı türü işaretli tamsayı olduğundan ve çoğu IP adresi negatif tamsayılarla sonuçlanacağından işaretsiz IP adresinin dizge gösterimini elde etmek için sprintf() ve printf() işlevlerinde %u değiştiricisini kullanmalısınız.

Bilginize:

ip2long() işlevi PHP 5 <= 5.0.2 sürümlerinde 255.255.255.255 adresi için FALSE döndürmektedir. Bu, PHP 5.0.3 sürümünde (PHP 4'teki gibi) -1 döndürecek şekilde düzeltilmiştir.

Ayrıca Bakınız

  • long2ip() - Bir (IPv4) sayısal ağ adresini noktalı gösterimi içeren bir dizgeye dönüştürür
  • sprintf() - Biçemli bir dizge döndürür

inet_pton
long2ip
Ağ İşlevleri


Bir (IPv4) sayısal ağ adresini noktalı gösterimi içeren bir dizgeye dönüştürür

ip2long
openlog
Ağ İşlevleri
PHP Manual

long2ip

(PHP 4, PHP 5, PHP 7)

long2ip — Bir (IPv4) sayısal ağ adresini noktalı gösterimi içeren bir dizgeye dönüştürür

Açıklama

string long2ip ( string $özel_adres )

long2ip() işlevi özel adres gösteriminden standart noktalı gösterimle (aaa.bbb.ccc.ddd) bir ağ adresi oluşturur.

Değiştirgeler

özel_adres

Özel ağ adresi gösterimi.

Dönen Değerler

IP adresini bir dizge olarak döndürür.

Ayrıca Bakınız

  • ip2long() - Noktalı IP adresi gösterimini içeren bir dizgeyi sayısal adrese dönüştürür

ip2long
openlog
Ağ İşlevleri


Sistem günlükçüsüne erişim için bağlantı açar

long2ip
pfsockopen
Ağ İşlevleri
PHP Manual

openlog

(PHP 4, PHP 5, PHP 7)

openlog — Sistem günlükçüsüne erişim için bağlantı açar

Açıklama

bool openlog ( string $kimlik , int $seçenek , int $oluşum )

openlog() işlevi bir program için sistem günlükçüsüne bir bağlantı açar.

openlog() kullanımı isteğe bağlıdır. kimlik değiştirgesinin öntanımlı olarak FALSE olduğu durumda, gerektiği takdirde işlev, syslog() tarafından özdevinimli olarak çağrılacaktır.

Değiştirgeler

kimlik

kimlik dizgesi her iletiye eklenir.

seçenek

seçenek değiştirgesi, bir günlük iletisi üretilirken hangi günlük seçeneğinin kullanılacağını belirtmek için kullanılır.

openlog() seçenekleri
Sabit | Açıklama
LOG_CONS | Veriyi sistem günlüğüne gönderirken bir hata oluşursa doğrudan sistem konsoluna yaz.
LOG_NDELAY | Günlük kayıtçısına hemen bir bağlantı aç.
LOG_ODELAY | (öntanımlı) İlk ileti günlüğe kaydolana kadar bağlantı açılışını ertele.
LOG_PERROR | Günlük iletisini ayrıca standart hataya da yaz.
LOG_PID | Her iletide PID'i de içer
Bu seçeneklerin birden fazlasını belirtebilirsiniz. Çok sayıda seçenek belirtecekseniz bunları VEYAlamanız gerekir. Örneğin, hemen bir bağlantı aç, konsola yaz ve her iletiye PID'i dahil et demek için şunu kullanın: LOG_CONS | LOG_NDELAY | LOG_PID

oluşum

oluşum değiştirgesi, iletiyi günlüğe kaydedecek program türünü belirtmek için kullanılır. Bu sayede farklı oluşumlardan gelen iletilerin nasıl ele alınacağını (sisteminizin syslog yapılandırmasında) belirtebilirsiniz.

openlog() oluşumları
Sabit | Açıklama
LOG_AUTH | Güvenlik/kimlik doğrulama iletileri (bu sabitin tanımlı olduğu sistemlerde yerine LOG_AUTHPRIV kulanın).
LOG_AUTHPRIV | Güvenlik/kimlik doğrulama iletileri (özel)
LOG_CRON | Zamanlama süreçleri (cron ve at)
LOG_DAEMON | Diğer sistem süreçleri
LOG_KERN | Sistem çekirdeği iletileri
LOG_LOCAL0 ... LOG_LOCAL7 | Yerel kullanım için ayrılmıştır. Bunlar Windows'ta hükümsüzdür.
LOG_LPR | Satır yazıcı alt sistemi
LOG_MAIL | eposta alt sistemi
LOG_NEWS | USENET haber grupları alt sistemi
LOG_SYSLOG | dahili olarak syslogd tarafından üretilen iletiler
LOG_USER | soysal kullanıcı seviyesi iletiler
LOG_UUCP | UUCP alt sistemi

Bilginize:

LOG_USER sadece Windows işletim sistemlerinde geçerli bir günlük türüdür.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • syslog() - Bir sistem günlüğü iletisi üretir
  • closelog() - Sistem günlükçüsü bağlantısını kapatır

long2ip
pfsockopen
Ağ İşlevleri


Kalıcı bir internet veya Unix alan soketi bağlantısı açar

openlog
setcookie
Ağ İşlevleri
PHP Manual

pfsockopen

(PHP 4, PHP 5, PHP 7)

pfsockopen — Kalıcı bir internet veya Unix alan soketi bağlantısı açar

Açıklama

resource pfsockopen ( string $konakadı [, int $port = -1 [, int &$hatanum [, string &$hata_iletisi [, float $zaman_aşımı = ini_get("default_socket_timeout") ]]]] )

Betik işini bitirene kadar bağlantının kapatılmaması dışında fsockopen() işleviyle tamamen aynıdır. Yani, fsockopen() işlevinin kalıcı bağlantı açan sürümüdür.

Değiştirgeler

Değiştirge bilgisi için fsockopen() belgesine bakınız.

Ayrıca Bakınız

  • fsockopen() - Bir internet veya Unix alan soketi bağlantısı açar

openlog
setcookie
Ağ İşlevleri


Bir çerez gönderir

pfsockopen
setrawcookie
Ağ İşlevleri
PHP Manual

setcookie

(PHP 4, PHP 5, PHP 7)

setcookie — Bir çerez gönderir

Açıklama

bool setcookie ( string $isim [, string $değer = "" [, int $zaman_aşımı = 0 [, string $yol = "" [, string $alan = "" [, bool $güvenli = false [, bool $sadece_http = false ]]]]]] )

setcookie() işlevi, HTTP başlıklarının kalanıyla gönderilmek üzere bir çerez tanımlar. Diğer başlıklar gibi, çerezlerde betiğinizin herhangi bir çıktısından önce gönderilmelidir (bu bir protokol kısıtlamasıdır). Bu kısıtlama, bu işleve yapılacak çağrıların, <html> ve <head> etiketleri ve hatta her türlü boşluk karakteri çıktısından bile önce yer almasını gerektirir.

Çerezler bir kere atandı mı, artık $_COOKIE dizisi ile sonraki sayfa yüklemesinde erişilebilir olacaktır. Çerez değerleri ayrıca, $_REQUEST içinde de mevcut olabilir.

Değiştirgeler

setcookie() değiştirgelerinin her birinin nasıl çalıştığını hakkında bilgi edinmek için » RFC 6265'e bakınız.

isim

Çerezin ismi.

değer

Çerezin değeri. Bu değer istemcinin bilgisayarında saklanır. Bu bakımdan çerezlerde güvenlik ihlaline konu bilgiler saklamayın. isim değiştirgesinde 'çerezim' ismini kullandığınız varsayımıyla, bu çerezin değerini $_COOKIE['çerezim'] değişkeni ile alabilirsiniz.

zaman_aşımı

Çerezin zaman aşımına uğrama süresi. Değer bir Unix zaman damgasıdır. Başka bir deyişle time() işlevinden dönen değere çerezin zaman aşımına uğrayacağı süreyi saniye cinsinden eklemek suretiyle bulacağınız değerdir. Ayrıca, mktime() işlevini de kullanabilirsiniz. time()+60*60*24*30 ile çerez 30 gün sonra zaman aşımına uğrar. Burada 0 atanır veya birşey belirtilmezse, çerez oturumun sonunda (tarayıcı kapandığında) zaman aşımına uğrar.

Bilginize:

zaman_aşımı değiştirgesinin değer olarak bir Unix zaman damgası aldığını fark etmişsinizdir. Bu, başlıkta belirtilen Wdy, DD-Mon-YYYY HH:MM:SS GMT tarih biçeminin zıddı olup bu dönüşümü PHP dahili olarak yapar.

yol

Çerezin üzerinde etkin olacağı sunucudaki yol. '/' belirtilirse çerez alan'ın tamamında kullanılabilir olacaktır. Eğer '/foo/' belirtilirse, çerez sadece /foo/ dizininde ve /foo/bar/ gibi alt dizinlerde kullanılabilir olacaktır. Öntanımlı değer çerezin atandığı içinde bulunulan dizindir.

alan

Çerezin kullanılabileceği (alt)alan. Çerezi ('www.example.com' gibi) bir alt alan adında kullanılabilir yapmak onu tüm diğer alt alan adlarında da (w2.www.example.com gibi) kullanılabilir kılacaktır.için değer olarak '.mesela.dom' belirtmelisiniz. Çerezi tüm alt alan adlarında kullanılabilir yapmak için buraya alan adını (örneğimiz için ('example.com') yazın.

Eski tarayıcılar hala kullanımdan kalkmış olan ve alt alan adıyla eşleşme sağlamak için . ile başlatmayı gerektiren » RFC 2109'u gerçeklemektedir.

güvenli

Çerezin istemciye güvenli bir HTTPS bağlantısı üzerinden mi aktarılması gerektiğini belirtmek için kullanılır. TRUE belirtildiği takdirde, çerez sadece güvenli bağlantı mevcutsa gönderilecektir. Sunucu tarafında, bu çeşit çerezin sadece ($_SERVER["HTTPS"] ile ilgili) güvenli bağlantı üzerinden gönderilmesi kararı programcıya aittir.

sadece_http

TRUE olduğu takdirde çerez sadece HTTP protokolü üzerinden erişilebilir olacaktır. Yani çerez, JavaScript gibi betik dilleri tarafından erişilebilir olmayacaktır. Bu ayarlama, XSS saldırılarıyla kimlik hırsızlığı riskini etkin şekilde azaltmaya (tüm tarayıcılar tarafından desteklenmese de) yardımcı olabilir, fakat bu sava çoğunlukla itiraz edilir. Bu değiştirge PHP 5.2.0'da eklenmiştir. Değer olarak TRUE veya FALSE belirtilebilir.

Dönen Değerler

Bu işlev çağrılmadan önce yapılmış çıktı varsa setcookie() başarısız olup FALSE döndürür. setcookie() başarılı olduğu takdirde TRUE döndürür. Dönüş değeri, kullanıcının çerezi kabul ettiği ya da etmediği anlamına gelmez.

Örnekler

Çerez gönderimi ile ilgili bazı örnekler:

Örnek 1 - setcookie() gönderim örneği

<?php
$value = 'bir şeyler bir yerlere';

setcookie("TestCookie", $value);
setcookie("TestCookie", $value, time()+3600);  /* 1 saatliğine geçerli */
setcookie("TestCookie", $value, time()+3600, "/~rasmus/", "example.com", 1);
?>

Çerez gönderilirken çerez değerinin özdevinimli olarak URL kodlamasından geçirileceğine, alınırken ise bu kodlamanın yine özdevinimli olarak çözüleceğine ve yine aynı çerez ismine atanacağına dikkat ediniz. Bunu istemiyorsanız, PHP 5 kullanıyorsanız bu işlevin yerine setrawcookie() işlevini kullanabilirsiniz. Deneme çerezimizin bir betik içindeki değerini görmek için aşağıdaki örneklerden birini kullanabilirsiniz:

<?php
// Bağımsız bir çerez bas
echo $_COOKIE["TestCookie"];

// Tüm çerezleri görmek için başka bir yol
print_r($_COOKIE);
?>

Örnek 2 - setcookie() silme örneği

Bir çerezi silerken, tarayıcınızın yürürlükten kaldırma mekanizmasını tetikleyebilmek için, süre bitiminin geçmişte kalmasını sağlamanız gerekir. Önceki örnekte gönderilen çerezin nasıl silineceğini görelim:

<?php
// süre bitimini 1 saat önceye ayarlayalım
setcookie ("TestCookie", "", time() - 3600);
setcookie ("TestCookie", "", time() - 3600, "/~rasmus/", "example.com", 1);
?>

Örnek 3 - setcookie() ve diziler

Çerez ismini belirtirken dizi gösterimini kullanmak suretiyle çerez dizileri tanımlayabilirsiniz. Bu sayede dizi elemanı sayısı kadar çerez tanımlayabilirsiniz, fakat çerezleri betiğinizle aldığınızda değerlerin hepsi çerez isminde bir diziye yerleştirilirler:

<?php
// çerezleri tanımlayalım
setcookie("cookie[three]", "cookiethree");
setcookie("cookie[two]", "cookietwo");
setcookie("cookie[one]", "cookieone");

// sayfayı yeniden yükledikten sonra çerezler basalım
if (isset($_COOKIE['cookie'])) {
    foreach ($_COOKIE['cookie'] as $name => $value) {
        $name = htmlspecialchars($name);
        $value = htmlspecialchars($value);
        echo "$name : $value <br />\n";
    }
}
?>

Yukarıdaki örneğin çıktısı:

three : cookiethree
two : cookietwo
one : cookieone

Sürüm Bilgisi

Sürüm: | Açıklama
5.5.0 | Max-Age niteliği istemciye gönderilen Set-Cookie başlığında artık bulunmaktadır.
5.2.0 | sadece_http değiştirgesi eklendi.

Notlar

Bilginize:

PHP 4'ten itibaren, bu işlevi çağırmadan önce, tarayıcıya gönderilene kadar sunucuda bekletilmek üzere çıktıyı bir tampona yazabilirsiniz. Bu işlemi betiğinizden ob_start() ve ob_end_flush() işlevlerini çağırarak veya output_buffering yapılandırma yönergesini php.ini veya sunucu yapılandırma dosyalarında belirterek yapabilirsiniz.

Bilginize:

register_globals yönergesine on değeri atanmışsa çerez değerleri değişkenlere de atanabilir. Bu takdirde, yukarıdaki örnekte $TestCookie değişkeni mevcut olacaktır. Ancak böyle yapmak yerine $_COOKIE kullanılmasını öneriyoruz.

Bilinen Güçlükler:

  • Çerezler sonraki sayfada görünür olmak üzere atanırlar, dolayısıyla sonraki sayfa yüklenene kadar görünür olmazlar. Bir çerezin başarıyla tanımlanıp tanımlanmadığını anlayabilmek için çerez zaman aşımına uğramadan sonraki sayfa üzerinde çerezi denemelisiniz. Zaman aşımı süresini zaman_aşımı değiştirgesi ile belirtebilirsiniz. Bir çerezin varlığını sınamanın en kolay yolu print_r($_COOKIE); çağrısı yapmaktır.
  • Çerezler atandıkları sırada kullanılan değiştirgeler kullanılarak silinmelidir. değer değiştirgesinde bir boş dizge veya FALSE belirtir ve tüm diğer değiştirgelerin çerezi atarken kullandığınız değiştirgelerle aynı olmasını sağlarsanız, ismini belirttiğiniz çerez uzak istemciden silinir. Bu işlem dahili olarak çereze 'deleted' değeri atanarak ve zaman aşımı tarihi bir yıl önceye çekilerek gerçekleştirilir.
  • Bir çereze silmek amacıyla FALSE değeri atarken mantıksal değerler kullanmamalısınız. FALSE için 0, TRUE için 1 kullanın.
  • Çerez isimleri dizi isimleri olabilir. Böylece siz PHP betiğinizde bu çerezler için dizi kullanırken, kullanıcının sisteminde bunlar ayrı ayrı çerezler olarak saklanırlar. Tek bir çereze çok sayıda isim ve değer atamak için explode() işlevini kullanabilirsiniz. Güvenlik zafiyeti oluşturması nedeniyle bu işlem için serialize() işlevinin kullanılmasını önermiyoruz.

Peşpeşe pek çok setcookie() çağrısı yapılabilir.

Ayrıca Bakınız

  • header() - Ham bir HTTP başlığı gönderir
  • setrawcookie() - Bir çerezi değerini URL kodlamasından geçirmeden gönderir
  • Çerezler bölümü
  • » RFC 6265
  • » RFC 2109

pfsockopen
setrawcookie
Ağ İşlevleri


Bir çerezi değerini URL kodlamasından geçirmeden gönderir

setcookie
socket_get_status
Ağ İşlevleri
PHP Manual

setrawcookie

(PHP 5, PHP 7)

setrawcookie — Bir çerezi değerini URL kodlamasından geçirmeden gönderir

Açıklama

bool setrawcookie ( string $isim [, string $değer [, int $zaman_aşımı = 0 [, string $yol [, string $alan [, bool $güvenli = false [, bool $sadece_http = false ]]]]]] )

setrawcookie() işlevi, çerez değerini tarayıcıya gönderirken özdevinimli olarak URL kodlamasından geçirmemesi dışında setcookie() işlevine benzer.

Değiştirgeler

Değiştirge bilgileri için setcookie() belgesine bakınız.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.2.0 | sadece_http değiştirgesi eklendi.

Ayrıca Bakınız

  • setcookie() - Bir çerez gönderir

setcookie
socket_get_status
Ağ İşlevleri


Takma Adı: stream_get_meta_data

setrawcookie
socket_set_blocking
Ağ İşlevleri
PHP Manual

socket_get_status

(PHP 4, PHP 5, PHP 7)

socket_get_status — Takma Adı: stream_get_meta_data()

Açıklama

Bu işlev, stream_get_meta_data() işlevinin takma adıdır.

setrawcookie
socket_set_blocking
Ağ İşlevleri


Takma Adı: stream_set_blocking

socket_get_status
socket_set_timeout
Ağ İşlevleri
PHP Manual

socket_set_blocking

(PHP 4, PHP 5, PHP 7)

socket_set_blocking — Takma Adı: stream_set_blocking()

Açıklama

Bu işlev, stream_set_blocking() işlevinin takma adıdır.

socket_get_status
socket_set_timeout
Ağ İşlevleri


Takma Adı: stream_set_timeout

socket_set_blocking
syslog
Ağ İşlevleri
PHP Manual

socket_set_timeout

(PHP 4, PHP 5, PHP 7)

socket_set_timeout — Takma Adı: stream_set_timeout()

Açıklama

Bu işlev, stream_set_timeout() işlevinin takma adıdır.

socket_set_blocking
syslog
Ağ İşlevleri


Bir sistem günlüğü iletisi üretir

socket_set_timeout
RRD
Ağ İşlevleri
PHP Manual

syslog

(PHP 4, PHP 5, PHP 7)

syslog — Bir sistem günlüğü iletisi üretir

Açıklama

bool syslog ( int $öncelik , string $ileti )

syslog() işlevi sistem günlük yöneticisi tarafından dağıtılacak bir günlük iletisi üretir.

Kullanıcı tanımlı bir günlük eylemci tanımlamak için gerekli bilgileri syslog.conf (5) Unix kılavuz sayfasında bulabilirsiniz. Unix sistemlerindeki syslog oluşumları ve seçenekleri hakkında daha fazla bilgi için syslog (3) kılavuz sayfasına bakınız.

Değiştirgeler

öncelik

öncelik, oluşum ve düzeyin birleşimidir. Olası değerler:

syslog() Öncelikleri (azalan sırada)
Sabit | Açıklama
LOG_EMERG | sistem kullanışsız
LOG_ALERT | eylem hemen ele alınmalı
LOG_CRIT | hayati durum
LOG_ERR | hata durumları
LOG_WARNING | uyarı durumları
LOG_NOTICE | normal, fakat önemli durum
LOG_INFO | bilgilendirme iletisi
LOG_DEBUG | hata ayıklama iletisi

ileti

Gönderilecek ileti; mevcut errno değerine karşı düşen hata iletisi dizgesinin (strerror) yerleştirileceği %m karakterleri hariç.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - syslog() kullanımı

<?php
// syslog'u aç, süreç kimliğini dahil edip günlüğü ayrıca
// standart hataya gönder ve kullanıcı tanımlı günlük kayıt
// mekanizmasını kullan
openlog("Betik günlüğüm", LOG_PID | LOG_PERROR, LOG_LOCAL0);

// bazı kodlar

if (authorized_client()) {
    // bir şeyler yap
} else {
    // yetkisiz istemci!
    // olayı günlüğe kaydet
    $access = date("d/m/Y H:i:s");
    syslog(LOG_WARNING, "Yetkisiz istemci: ".
      $access." {$_SERVER['REMOTE_ADDR']} ({$_SERVER['HTTP_USER_AGENT']})");
}

closelog();
?>

Notlar

Windows NT'de, syslog hizmeti Event Log kullanılarak taklit edilir.

Bilginize:

openlog() işlevinin oluşum değiştirgesinin değerlerinden LOG_LOCAL0'dan LOG_LOCAL7'ye kadar olanlar Windows'ta geçersizdir.

Ayrıca Bakınız

  • openlog() - Sistem günlükçüsüne erişim için bağlantı açar
  • closelog() - Sistem günlükçüsü bağlantısını kapatır

socket_set_timeout
RRD
Ağ İşlevleri


RRDtool

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
    • Procedural PECL/rrd example
    • OOP PECL/rrd example
  • RRD İşlevleri
    • rrd_create — Creates rrd database file
    • rrd_error — Gets latest error message.
    • rrd_fetch — Fetch the data for graph as array.
    • rrd_first — Gets the timestamp of the first sample from rrd file.
    • rrd_graph — Creates image from a data.
    • rrd_info — Gets information about rrd file
    • rrd_last — Gets unix timestamp of the last sample.
    • rrd_lastupdate — Gets information about last updated data.
    • rrd_restore — Restores the RRD file from XML dump.
    • rrd_tune — Tunes some RRD database file header options.
    • rrd_update — Updates the RRD database.
    • rrd_version — Gets information about underlying rrdtool library
    • rrd_xport — Exports the information about RRD database.
    • rrdc_disconnect — Close any outstanding connection to rrd caching daemon
  • RRDCreator — The RRDCreator class
    • RRDCreator::addArchive — Adds RRA - archive of data values for each data source.
    • RRDCreator::addDataSource — Adds data source definition for RRD database.
    • RRDCreator::__construct — Creates new RRDCreator instance
    • RRDCreator::save — Saves the RRD database to a file
  • RRDGraph — The RRDGraph class
    • RRDGraph::__construct — Creates new RRDGraph instance
    • RRDGraph::save — Saves the result of query into image
    • RRDGraph::saveVerbose — Saves the RRD database query into image and returns the verbose information about generated graph.
    • RRDGraph::setOptions — Sets the options for rrd graph export
  • RRDUpdater — The RRDUpdater class
    • RRDUpdater::__construct — Creates new RRDUpdater instance
    • RRDUpdater::update — Update the RRD database file
syslog
Giriş
Diğer Hizmetler


Giriş

The PECL/rrd extension provides bindings to the RRDtool C library. RRDtool is the open source industry standard, high performance data logging and graphing system for time series data.

The RRDtool homepage is » http://www.mrtg.org/rrdtool/.

RRD
Yapılandırma/Kurulum
RRD


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
RRD


Gereksinimler

You need to install librrd first to be able to use PECL/rrd. Most common option is using of librrd-dev package from your favourite linux distro. PECL/rrd is tested with librrd 1.4.3, older or newer versions might or might not work for you. PECL/rrd installation is tested with PHP 5.3.2 or newer.

Uyarı

Librrd and hence extension itself aren't mostly thread safe. There are many global and shared states in librrd. It can be dangerous use this extension in multi threaded environments like Apache2 mpm worker. If there are many parallel requests, one request can change some global librrd state of other runnig requests.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/rrd.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
Örnekler
RRD


Örnekler

İçindekiler

  • Procedural PECL/rrd example
  • OOP PECL/rrd example
Öntanımlı Sabitler
Procedural PECL/rrd example
RRD


Procedural PECL/rrd example

Örnek 1 Procedural usage of rrd

<?php
$rrdFile = dirname(__FILE__) . "/speed.rrd";

//create rrd file
rrd_create($rrdFile,
 array(
  "--start",920804400,
  "DS:speed:COUNTER:600:U:U",
  "RRA:AVERAGE:0.5:1:24",
  "RRA:AVERAGE:0.5:6:10"
  )
);

//update rrd file
rrd_update($rrdFile,
 array(
  "920804700:12345",
  "920805000:12357"
  )
);

//graph output
rrd_graph(dirname(__FILE__) . "/speed.png",
 array(
  "--start", "920804400",
  "--end", "920808000",
  "--vertical-label", "m/s",
  "DEF:myspeed=$rrdFile:speed:AVERAGE",
  "CDEF:realspeed=myspeed,1000,*",
  "LINE2:realspeed#FF0000"
 )
);
?>

Örnekler
OOP PECL/rrd example
Örnekler


OOP PECL/rrd example

Örnek 1 OO usage of rrd

<?php
$rrdFile = dirname(__FILE__) . "/speed.rrd";
$outputPngFile = dirname(__FILE__) . "/speed.png";

$creator = new RRDCreator($rrdFile, "now -10d", 500);
$creator->addDataSource("speed:COUNTER:600:U:U");
$creator->addArchive("AVERAGE:0.5:1:24");
$creator->addArchive("AVERAGE:0.5:6:10");
$creator->save();

$updater = new RRDUpdater($rrdFile);
$updater->update(array("speed" => "12345"), "920804700");
$updater->update(array("speed" => "12357"), "920805000");

$graphObj = new RRDGraph($outputPngFile);
$graphObj->setOptions(
    array(
        "--start" => "920804400",
        "--end" => 920808000,
        "--vertical-label" => "m/s",
        "DEF:myspeed=$rrdFile:speed:AVERAGE",
        "CDEF:realspeed=myspeed,1000,*",
        "LINE2:realspeed#FF0000"
    )
);
$graphObj->save();
?>

Procedural PECL/rrd example
RRD İşlevleri
Örnekler


RRD İşlevleri

İçindekiler

  • rrd_create — Creates rrd database file
  • rrd_error — Gets latest error message.
  • rrd_fetch — Fetch the data for graph as array.
  • rrd_first — Gets the timestamp of the first sample from rrd file.
  • rrd_graph — Creates image from a data.
  • rrd_info — Gets information about rrd file
  • rrd_last — Gets unix timestamp of the last sample.
  • rrd_lastupdate — Gets information about last updated data.
  • rrd_restore — Restores the RRD file from XML dump.
  • rrd_tune — Tunes some RRD database file header options.
  • rrd_update — Updates the RRD database.
  • rrd_version — Gets information about underlying rrdtool library
  • rrd_xport — Exports the information about RRD database.
  • rrdc_disconnect — Close any outstanding connection to rrd caching daemon
OOP PECL/rrd example
rrd_create
RRD


Creates rrd database file

RRD İşlevleri
rrd_error
RRD İşlevleri
PHP Manual

rrd_create

(PECL rrd >= 0.9.0)

rrd_create — Creates rrd database file

Açıklama

bool rrd_create ( string $filename , array $options )

Creates the rdd database file.

Değiştirgeler

filename

Filename for newly created rrd file.

options

Options for rrd create - list of strings. See man page of rrd create for whole list of options.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

RRD İşlevleri
rrd_error
RRD İşlevleri


Gets latest error message.

rrd_create
rrd_fetch
RRD İşlevleri
PHP Manual

rrd_error

(PECL rrd >= 0.9.0)

rrd_error — Gets latest error message.

Açıklama

string rrd_error ( void )

Returns latest global rrd error message.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Latest error message.

rrd_create
rrd_fetch
RRD İşlevleri


Fetch the data for graph as array.

rrd_error
rrd_first
RRD İşlevleri
PHP Manual

rrd_fetch

(PECL rrd >= 0.9.0)

rrd_fetch — Fetch the data for graph as array.

Açıklama

array rrd_fetch ( string $filename , array $options )

Gets data for graph output from RRD database file as array. This function has same result as rrd_graph(), but fetched data are returned as array, no image file is created.

Değiştirgeler

filename

RRD database file name.

options

Array of options for resolution specification.

Dönen Değerler

Returns information about retrieved graph data.

rrd_error
rrd_first
RRD İşlevleri


Gets the timestamp of the first sample from rrd file.

rrd_fetch
rrd_graph
RRD İşlevleri
PHP Manual

rrd_first

(PECL rrd >= 0.9.0)

rrd_first — Gets the timestamp of the first sample from rrd file.

Açıklama

int rrd_first ( string $file [, int $raaindex = 0 ] )

Returns the first data sample from the specified RRA of the RRD file.

Değiştirgeler

file

RRD database file name.

raaindex

The index number of the RRA that is to be examined. Default value is 0.

Dönen Değerler

Integer number of unix timestamp, FALSE if some error occurs.

rrd_fetch
rrd_graph
RRD İşlevleri


Creates image from a data.

rrd_first
rrd_info
RRD İşlevleri
PHP Manual

rrd_graph

(PECL rrd >= 0.9.0)

rrd_graph — Creates image from a data.

Açıklama

array rrd_graph ( string $filename , array $options )

Creates image for a particular data from RRD file.

Değiştirgeler

filename

The filename to output the graph to. This will generally end in either .png, .svg or .eps, depending on the format you want to output.

options

Options for generating image. See man page of rrd graph for all possible options. All options (data definitions, variable defintions, etc.) are allowed.

Dönen Değerler

Array with information about generated image is returned, FALSE when error occurs.

rrd_first
rrd_info
RRD İşlevleri


Gets information about rrd file

rrd_graph
rrd_last
RRD İşlevleri
PHP Manual

rrd_info

(PECL rrd >= 0.9.0)

rrd_info — Gets information about rrd file

Açıklama

array rrd_info ( string $filename )

Returns information about particular RRD database file.

Değiştirgeler

file

RRD database file name.

Dönen Değerler

Array with information about requsted RRD file, FALSE when error occurs.

rrd_graph
rrd_last
RRD İşlevleri


Gets unix timestamp of the last sample.

rrd_info
rrd_lastupdate
RRD İşlevleri
PHP Manual

rrd_last

(PECL rrd >= 0.9.0)

rrd_last — Gets unix timestamp of the last sample.

Açıklama

int rrd_last ( string $filename )

Returns the UNIX timestamp of the most recent update of the RRD database.

Değiştirgeler

filename

RRD database file name.

Dönen Değerler

Integer as unix timestamp of the most recent data from the RRD database.

rrd_info
rrd_lastupdate
RRD İşlevleri


Gets information about last updated data.

rrd_last
rrd_restore
RRD İşlevleri
PHP Manual

rrd_lastupdate

(PECL rrd >= 0.9.0)

rrd_lastupdate — Gets information about last updated data.

Açıklama

array rrd_lastupdate ( string $filename )

Gets array of the UNIX timestamp and the values stored for each date in the most recent update of the RRD database file.

Değiştirgeler

file

RRD database file name.

Dönen Değerler

Array of information about last update, FALSE when error occurs.

rrd_last
rrd_restore
RRD İşlevleri


Restores the RRD file from XML dump.

rrd_lastupdate
rrd_tune
RRD İşlevleri
PHP Manual

rrd_restore

(PECL rrd >= 0.9.0)

rrd_restore — Restores the RRD file from XML dump.

Açıklama

bool rrd_restore ( string $xml_file , string $rrd_file [, array $options ] )

Restores the RRD file from the XML dump.

Değiştirgeler

xml_file

XML filename with the dump of the original RRD database file.

rrd_file

Restored RRD database file name.

options

Array of options for restoring. See man page for rrd restore.

Dönen Değerler

Returns TRUE on success, FALSE otherwise.

rrd_lastupdate
rrd_tune
RRD İşlevleri


Tunes some RRD database file header options.

rrd_restore
rrd_update
RRD İşlevleri
PHP Manual

rrd_tune

(PECL rrd >= 0.9.0)

rrd_tune — Tunes some RRD database file header options.

Açıklama

bool rrd_tune ( string $filename , array $options )

Change some options in the RRD dabase header file. E.g. renames the source for the data etc.

Değiştirgeler

filename

RRD database file name.

options

Options with RRD database file properties which will be changed. See rrd tune man page for details.

Dönen Değerler

Returns TRUE on success, FALSE otherwise.

rrd_restore
rrd_update
RRD İşlevleri


Updates the RRD database.

rrd_tune
rrd_version
RRD İşlevleri
PHP Manual

rrd_update

(PECL rrd >= 0.9.0)

rrd_update — Updates the RRD database.

Açıklama

bool rrd_update ( string $filename , array $options )

Updates the RRD database file. The input data is time interpolated according to the properties of the RRD database file.

Değiştirgeler

filename

RRD database file name. This database will be updated.

options

Options for updating the RRD database. This is list of strings. See man page of rrd update for whole list of options.

Dönen Değerler

Returns TRUE on success, FALSE when error occurs.

rrd_tune
rrd_version
RRD İşlevleri


Gets information about underlying rrdtool library

rrd_update
rrd_xport
RRD İşlevleri
PHP Manual

rrd_version

(PECL rrd >= 1.0.0)

rrd_version — Gets information about underlying rrdtool library

Açıklama

string rrd_version ( void )

Returns information about underlying rrdtool library.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

String with rrdtool version number e.g. "1.4.3".

rrd_update
rrd_xport
RRD İşlevleri


Exports the information about RRD database.

rrd_version
rrdc_disconnect
RRD İşlevleri
PHP Manual

rrd_xport

(PECL rrd >= 0.9.0)

rrd_xport — Exports the information about RRD database.

Açıklama

array rrd_xport ( array $options )

Exports the information about RRD database file. This data can be converted to XML file via user space PHP script and then restored back as RRD database file.

Değiştirgeler

options

Array of options for the export, see rrd xport man page.

Dönen Değerler

Array with information about RRD database file, FALSE when error occurs.

rrd_version
rrdc_disconnect
RRD İşlevleri


Close any outstanding connection to rrd caching daemon

rrd_xport
RRDCreator
RRD İşlevleri
PHP Manual

rrdc_disconnect

(PECL rrd >= 1.1.2)

rrdc_disconnect — Close any outstanding connection to rrd caching daemon

Açıklama

void rrdc_disconnect ( void )

Close any outstanding connection to rrd caching daemon.

This function is automatically called when the whole PHP process is terminated. It depends on used SAPI. For example, it's called automatically at the end of command line script.

It's up user whether he wants to call this function at the end of every request or otherwise.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

rrd_xport
RRDCreator
RRD İşlevleri


The RRDCreator class

(PECL rrd >= 0.9.0)

Giriş

Class for creation of RRD database file.

Sınıf Sözdizimi

RRDCreator {
/* Yöntemler */
public void addArchive ( string $description )
public void addDataSource ( string $description )
public __construct ( string $path [, string $startTime [, int $step = 0 ]] )
public bool save ( void )
}

İçindekiler

  • RRDCreator::addArchive — Adds RRA - archive of data values for each data source.
  • RRDCreator::addDataSource — Adds data source definition for RRD database.
  • RRDCreator::__construct — Creates new RRDCreator instance
  • RRDCreator::save — Saves the RRD database to a file
rrdc_disconnect
RRDCreator::addArchive
RRD


Adds RRA - archive of data values for each data source.

RRDCreator
RRDCreator::addDataSource
RRDCreator
PHP Manual

RRDCreator::addArchive

(PECL rrd >= 0.9.0)

RRDCreator::addArchive — Adds RRA - archive of data values for each data source.

Açıklama

public void RRDCreator::addArchive ( string $description )

Adds RRA definition by description of archive. Archive consists of a number of data values or statistics for each of the defined data-sources (DS). Data sources are defined by method RRDCreator::addDataSource(). You need call this method for each requested archive.

Değiştirgeler

description

Definition of archive - RRA. This has same format as RRA definition in rrd create command. See man page of rrd create for more details.

Dönen Değerler

Hiçbir değer dönmez.

RRDCreator
RRDCreator::addDataSource
RRDCreator


Adds data source definition for RRD database.

RRDCreator::addArchive
RRDCreator::__construct
RRDCreator
PHP Manual

RRDCreator::addDataSource

(PECL rrd >= 0.9.0)

RRDCreator::addDataSource — Adds data source definition for RRD database.

Açıklama

public void RRDCreator::addDataSource ( string $description )

RRD can accept input from several data sources (DS), e.g incoming and outgoing traffic. This method adds data source by description. You need call this method for each data source.

Değiştirgeler

description

Definition of data source - DS. This has same format as DS definition in rrd create command. See man page of rrd create for more details.

Dönen Değerler

Hiçbir değer dönmez.

RRDCreator::addArchive
RRDCreator::__construct
RRDCreator


Creates new RRDCreator instance

RRDCreator::addDataSource
RRDCreator::save
RRDCreator
PHP Manual

RRDCreator::__construct

(PECL rrd >= 0.9.0)

RRDCreator::__construct — Creates new RRDCreator instance

Açıklama

public RRDCreator::__construct ( string $path [, string $startTime [, int $step = 0 ]] )

Creates new RRDCreator instance.

Değiştirgeler

path

Path for newly created RRD database file.

startTime

Time for the first value in RRD database. Parameter supports all formats which are supported by rrd create call.

intstep

Base interval in seconds with which data will be fed into the RRD database.

Dönen Değerler

Hiçbir değer dönmez.

RRDCreator::addDataSource
RRDCreator::save
RRDCreator


Saves the RRD database to a file

RRDCreator::__construct
RRDGraph
RRDCreator
PHP Manual

RRDCreator::save

(PECL rrd >= 0.9.0)

RRDCreator::save — Saves the RRD database to a file

Açıklama

public bool RRDCreator::save ( void )

Saves the RRD database into file, which name is defined by RRDCreator::__construct().

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

RRDCreator::__construct
RRDGraph
RRDCreator


The RRDGraph class

(PECL rrd >= 0.9.0)

Giriş

Class for exporting data from RRD database to image file.

Sınıf Sözdizimi

RRDGraph {
/* Yöntemler */
public __construct ( string $path )
public array save ( void )
public array saveVerbose ( void )
public void setOptions ( array $options )
}

İçindekiler

  • RRDGraph::__construct — Creates new RRDGraph instance
  • RRDGraph::save — Saves the result of query into image
  • RRDGraph::saveVerbose — Saves the RRD database query into image and returns the verbose information about generated graph.
  • RRDGraph::setOptions — Sets the options for rrd graph export
RRDCreator::save
RRDGraph::__construct
RRD


Creates new RRDGraph instance

RRDGraph
RRDGraph::save
RRDGraph
PHP Manual

RRDGraph::__construct

(PECL rrd >= 0.9.0)

RRDGraph::__construct — Creates new RRDGraph instance

Açıklama

public RRDGraph::__construct ( string $path )

Creates new RRDGraph instance. This instance is responsible for rendering the result of RRD database query into image.

Değiştirgeler

path

Full path for the newly created image.

Dönen Değerler

Hiçbir değer dönmez.

RRDGraph
RRDGraph::save
RRDGraph


Saves the result of query into image

RRDGraph::__construct
RRDGraph::saveVerbose
RRDGraph
PHP Manual

RRDGraph::save

(PECL rrd >= 0.9.0)

RRDGraph::save — Saves the result of query into image

Açıklama

public array RRDGraph::save ( void )

Saves the result of RRD database query into image defined by RRDGraph::__construct().

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Array with information about generated image is returned, FALSE if error occurs.

RRDGraph::__construct
RRDGraph::saveVerbose
RRDGraph


Saves the RRD database query into image and returns the verbose information about generated graph.

RRDGraph::save
RRDGraph::setOptions
RRDGraph
PHP Manual

RRDGraph::saveVerbose

(PECL rrd >= 0.9.0)

RRDGraph::saveVerbose — Saves the RRD database query into image and returns the verbose information about generated graph.

Açıklama

public array RRDGraph::saveVerbose ( void )

Saves the RRD database query into image file defined by method RRDGraph::__construct() and returns the verbose information about generated graph, if "-" is used as image filename, image data are also returned in result array.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Array with detailed information about generated image is returned, optionally with image data, FALSE if error occurs.

RRDGraph::save
RRDGraph::setOptions
RRDGraph


Sets the options for rrd graph export

RRDGraph::saveVerbose
RRDUpdater
RRDGraph
PHP Manual

RRDGraph::setOptions

(PECL rrd >= 0.9.0)

RRDGraph::setOptions — Sets the options for rrd graph export

Açıklama

public void RRDGraph::setOptions ( array $options )

Değiştirgeler

options

List of options for the image generation from the RRD database file. It can be list of strings or list of strings with keys for better readability. Read the rrd graph man pages for list of available options.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 RRDGraph::setOptions() example

<?php
$graphObj->setOptions(array(
    "--start" => "920804400",
    "--end" => 920808000,
    "--vertical-label" => "m/s",
    "DEF:myspeed=$rrdFile:speed:AVERAGE",
    "CDEF:realspeed=myspeed,1000,*",
    "LINE2:realspeed#FF0000"
));
?>

Örnek 2 Set multiple color options

<?php
$graphObj->setOptions(array(
    "--start" => "920804400",
    "--end" => 920808000,
    "--vertical-label" => "m/s",
    "--color=BACK#00000000",
    "--color=GRID#00000000",
    "--color=MGRID#00000000",
    "DEF:myspeed=$rrdFile:speed:AVERAGE",
    "CDEF:realspeed=myspeed,1000,*",
    "LINE2:realspeed#FF0000"
));
?>

Don't use key value syntax for same rrd option. It looks more readable, but it doesn't work.

<?php
$graphObj->setOptions(array(
    "--color" => "BACK#00000000",
    "--color" => "GRID#00000000",
    "--color" => "MGRID#00000000"
));
?>

In nature of php it's same as

<?php
$graphObj->setOptions(array(
    "--color" => "MGRID#00000000"
));
?>

RRDGraph::saveVerbose
RRDUpdater
RRDGraph


The RRDUpdater class

(PECL rrd >= 0.9.0)

Giriş

Class for updating RDD database file.

Sınıf Sözdizimi

RRDUpdater {
/* Yöntemler */
public __construct ( string $path )
public bool update ( array $values [, string $time = time() ] )
}

İçindekiler

  • RRDUpdater::__construct — Creates new RRDUpdater instance
  • RRDUpdater::update — Update the RRD database file
RRDGraph::setOptions
RRDUpdater::__construct
RRD


Creates new RRDUpdater instance

RRDUpdater
RRDUpdater::update
RRDUpdater
PHP Manual

RRDUpdater::__construct

(PECL rrd >= 0.9.0)

RRDUpdater::__construct — Creates new RRDUpdater instance

Açıklama

public RRDUpdater::__construct ( string $path )

Creates new RRDUpdater instance. This instance is responsible for updating the RRD database file.

Değiştirgeler

path

Filesystem path for RRD database file, which will be updated.

Dönen Değerler

Hiçbir değer dönmez.

RRDUpdater
RRDUpdater::update
RRDUpdater


Update the RRD database file

RRDUpdater::__construct
SAM
RRDUpdater
PHP Manual

RRDUpdater::update

(PECL rrd >= 0.9.0)

RRDUpdater::update — Update the RRD database file

Açıklama

public bool RRDUpdater::update ( array $values [, string $time = time() ] )

Updates the RRD file defined via RRDUpdater::__construct(). The file is updated with a specific values.

Değiştirgeler

values

Data for update. Key is data source name.

time

Time value for updating the RRD with a particulat data. Default value is current time.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

Throws a Exception on error.

Örnekler

Örnek 1 RRDUpdater::update() examples

<?php
$updator = new RRDUpdater("speed.rrd");
//updates the data source "speed" with value "12411"
//for time defined by timestamp "920807700"
$updator->update(array("speed" => "12411"), "920807700");
?>

RRDUpdater::__construct
SAM
RRDUpdater


Simple Asynchronous Messaging

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
    • Connections
    • Messages
    • Messaging operations
    • Publish/Subscribe and subscriptions to topics
    • Error handling
  • SAM İşlevleri
    • SAMConnection::commit — Commits (completes) the current unit of work.
    • SAMConnection::connect — Establishes a connection to a Messaging Server
    • SAMConnection::__construct — Creates a new connection to a Messaging Server
    • SAMConnection::disconnect — Disconnects from a Messaging Server
    • SAMConnection::errno — Contains the unique numeric error code of the last executed SAM operation.
    • SAMConnection::error — Contains the text description of the last failed SAM operation.
    • SAMConnection::isConnected — Queries whether a connection is established to a Messaging Server
    • SAMConnection::peek — Read a message from a queue without removing it from the queue.
    • SAMConnection::peekAll — Read one or more messages from a queue without removing it from the queue.
    • SAMConnection::receive — Receive a message from a queue or subscription.
    • SAMConnection::remove — Remove a message from a queue.
    • SAMConnection::rollback — Cancels (rolls back) an in-flight unit of work.
    • SAMConnection::send — Send a message to a queue or publish an item to a topic.
    • SAMConnection::setDebug — Turn on or off additional debugging output.
    • SAMConnection::subscribe — Create a subscription to a specified topic.
    • SAMConnection::unsubscribe — Cancel a subscription to a specified topic.
    • SAMMessage::body — The body of the message.
    • SAMMessage::__construct — Creates a new Message object
    • SAMMessage::header — The header properties of the message.
RRDUpdater::update
Giriş
Diğer Hizmetler


Giriş

This extension provides access to the functionality of messaging and queueing systems, such as the IBM WebSphere MQSeries family of products, from PHP scripts. The interface is designed to make it extremely simple to do the more commonly required tasks such as deliver simple text messages to queues while still allowing skilled users to do more complex messaging operations. For many users the complexities of setting up numerous options can be simply ignored.

The SAM extension is a framework that provides a very simple API that can be used to access a number of messaging middleware systems. Currently the package includes built-in support for the MQTT (MQ Telemetry Transport) messaging protocol and support for the IBM Messaging and Queuing middleware products. SAM is designed to be readily extended to support other messaging systems and extension modules may be written in C or PHP.

SAM
Yapılandırma/Kurulum
SAM


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
SAM


Gereksinimler

The SAM extension interfaces to the IBM Messaging and Queuing middleware products using a set of libraries and some client side code referred to as XMS. This package is available as a free download in the guise of IBM support pack IA94. There is a description of this package and download links in the article » Introducing XMS - The IBM Message Service API.

If you intend to use SAM to access the Messaging and Queuing infrastructure within WebSphere MQ then you will also need to have installed a local MQ queue manager or installed the WebSphere MQ clients package. The clients package is freely available as a support pack (» MQC6).

If you are only aiming to experiment with sending messages to and from WebSphere Application Server queues using the WebSphere Platform Messaging protocol (WPM) then you do not need to install the MQC6 package.

After installing these packages you will need to ensure the XMS binary and, if you are using it, the MQ client bin directory are included in the PATH environment variable so that Apache and PHP can find the dependent .DLLs/libraries.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/sam.

The SAM framework and MQTT support can be built and used without any other prerequisites. Support for protocols other than MQTT is provided via a set of libraries and some client side code referred to as XMS.

If you only intend to use the built-in MQTT support then you can build and configure SAM as an extension or simply refer to php_sam.php with a require or require_once clause in your PHP script. In this case you need only install the code without building the extension using the pear installer:

pecl install -B SAM

Linux installation steps

The sam extension is supplied as a PECL module, which you should be able to download and install in one step as follows:

pecl install sam
(Depending on your php environment, you will probably need to be root to do this.)

Make sure that the module is loaded by PHP, by adding following line to php.ini:

extension=sam.so
If you intend to use the XMS support to access the IBM Messaging and Queuing family you must also enable the SAM XMS extension.
extension=sam_xms.so

If you cannot use the PEAR installer, you can download the extension and build it manually:

pear download sam          #downloads sam-<version>.tgz
tar -xzf sam-<version>.tgz
cd sam-<version>
phpize
./configure
make
make install               #you may need to be root for this step

To work with the very latest source, you'll need to extract it from SVN and build manually as above.

Windows installation steps

You will probably need to build the sam extension for Windows as there are only a limited range of pre-built binaries available from the SAM website. The extension can be built using the standard Windows extension build procedures.

You will need the PHP source tree for the version of PHP you wish to build the SAM extension against which you can obtain from php.net. This should be unpacked into a working directory of your choice.

You will also need the libraries and headers used by PHP extensions available from http://www.php.net/extra/win32build.zip and this should be unzipped so that is in your working directory.

You should have something like:

c:\php-build\-
              |
              |---php-5.0.5--|---build
              |              |---ext
              |              |--- ...
              |
              |---win32build--|---bin
                              |---include
                              |---lib

You will need a compiler such as the free version of Visual Studio C++ Express from the Microsoft web site. Also you need the Microsoft SDK Microsoft Windows Platform which again can be downloaded from the Microsoft web site.

Obtain the SAM extension source using pear (pecl download sam) or by using SVN and copy the files to a new "sam" directory under the "ext" directory in your PHP source tree.

To build the extension open a build environment window by going to the start

menu->all programs->microsoft platform SDK for windows->
open build environment window->windows 200 build environment->
set windows 2000 build environment (retail)

This should open a command prompt with all the environment variables set up to access the platform SDK etc. You then need to set the environment variables for Visual Studio by issuing the command vcvars32.bat in the window.

Change directory to your working directory e.g. cd c:\php-build. Then make sure the win32build tools are accessible by adding them to the PATH environment variable:

set PATH=..\win32build\bin;%PATH%

Run the buildconf.bat command. This should rebuild the configure.js file.

Run the cscript command with the appropriate options. To build just the SAM extension framework and MQTT support use:

cscript /nologo configure.js --with-sam
To build the SAM framework and the XMS support use:
cscript /nologo configure.js --with-sam --with-sam_xms="c:\program files\ibm\xms"

The additional parameter passed for sam_xms is the installation path to the XMS libraries and runtime that were installed as described under prerequisites at the top of this page.

You can specify whatever other cscript parameters you require to include or exclude items from the php build or select options.

Assuming all has gone well so far you can now finally run a make for the SAM framework!

nmake php_sam.dll
Also if you are using the XMS support you must make the sam_xms extensions:
nmake php_sam_xms.dll

If you have used Visual Studio 2005 to build the DLLs please see below for additional steps that must be carried out before proceeding further.

The DLLs created (php_sam.dll and optionally php_sam_xms.dll) can now be copied to the subdirectory appropriate for your PHP set-up. Make sure that the module(s) are loaded by PHP, by adding following line to php.ini:

extension=php_sam.dll
If you intend to use the XMS support to access the IBM Messaging and Queuing family you must also enable the SAM XMS extension.
extension=php_sam_xms.dll

Additional steps for Visual Studio 2005

If you build the SAM extension with the Microsoft Visual Studio 2005 compiler and tools you need to perform an additional step in the build process to ensure the php_sam.dll is able to link with the C runtime libraries at runtime. This step includes the dependancy manifest into the DLL. Switch to the directory where the php_sam.dll has been generated (usually Release_TS or Debug_TS below the php source directory) and issue the following magic incantation:

mt.exe -manifest php_sam.dll.manifest -outputresource:php_sam.dll;2
If you are using the XMS capabilities you will need to do the same with the SAM XMS DLL:
mt.exe -manifest php_sam_xms.dll.manifest -outputresource:php_sam_xms.dll;2

If you build the SAM extension using the compiler and libraries from Microsoft Visual Studio 2005 you will also need to ensure that the runtime components are installed on the system on which you intend to use SAM. This can be accomplished by installing Visual Studio 2005 or by using the freely distributable » runtime package.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Protocol support and mapping

The SAM framework can be extended to support other messaging protocols and connection mechanisms. To add support for a new protocol or connection library a support class has to be defined, either as a C extension or as a PHP script, and a "factory" script must be created. The support class must implement all the methods of the SAMConnection class though it should not inherit from SAMConnection. The factory script will be called by the SAM framework to create an instance of the implemented class. The way SAM chooses which factory to call is based on the protocol specified as the first parameter of the "connect" call.

By default the built-in MQTT support will be used if a connect call specifies a protocol of SAM_MQTT ("mqtt"), for any other protocol SAM will attempt to use the XMS support extension. To add support for additional protocols or to modify the default behavior entries may be added to php.ini in the [sam] section. The default mapping is equivalent to the following entries:

[sam]
sam.factory.mqtt=mqtt
sam.factory.wmq=xms
sam.factory.wmq:client=xms
sam.factory.wmq:bindings=xms
sam.factory.wpm=xms
sam.factory.rtt=xms
As can be seen from these examples the entries take the form of "sam.factory.pppp=xxx" where pppp is the protocol string specified on the connect call and xxx is a factory suffix. Note: SAM defines constants for these protocol strings such that SAM_WMQ=wmq, SAM_WPM=wpm, SAM_RTT=rtt, SAM_MQTT=mqtt, etc.

When identifying the support code to use on a connect call SAM looks up the protocol name in the php.ini entries and then invokes a factory script named sam_factory_xxx.php. If no entry is found the support will default to XMS.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

SAM_AUTO (string)
Automatic behaviour
SAM_BOOLEAN (string)
Type specifier used when setting properties on SAM_Message objects.
SAM_BUS (string)
Connect attribute used to set the name of the enterprise service bus to connect to.
SAM_BYTE (string)
Type specifier used when setting properties on SAM_Message objects.
SAM_BYTES (string)
Message body type descriptor.
SAM_CORRELID (string)
Attribute used on receive, send and remove requests to identify specific messages.
SAM_DELIVERYMODE (string)
Message header property.
SAM_DOUBLE (string)
Type specifier used when setting properties on SAM_Message objects.
SAM_ENDPOINTS (string)
Connect attribute used to define the possible endpoints to connect to.
SAM_FLOAT (string)
Type specifier used when setting properties on SAM_Message objects.
SAM_HOST (string)
Connect attribute used to set the hostname of the required messaging server.
SAM_INT (string)
Type specifier used when setting properties on SAM_Message objects.
SAM_LONG (string)
Type specifier used when setting properties on SAM_Message objects.
SAM_MANUAL (string)
Manual (script controlled) behaviour
SAM_MESSAGEID (string)
Attribute used on receive and remove requests to identify specific messages.
SAM_MQTT (string)
Connect protocol definition for selecting the MQTT (MQ Telemetry Transport) protocol.
SAM_MQTT_CLEANSTART (bool)
Optional connect option to indicate to an MQTT server that all previous connection data for this client should be removed and that subscriptions should be deleted when the client disconnects explicitly or unexpectedly.
SAM_NON_PERSISTENT (string)
Connect attribute value used to request messages are not made persistent on the messaging server.
SAM_PASSWORD (string)
Connect attribute used to define the password to be used for the user account being used to connect to a messaging server that requires authorisation for connections.
SAM_PERSISTENT (string)
Connect attribute value used to request messages are made persistent on the messaging server to protect against loss of messages in the event of failure.
SAM_PORT (string)
Connect attribute used to set the port number on which to communicate with the messaging server.
SAM_PRIORITY (string)
Option name used on send requests to specify a delivery priority value.
SAM_REPLY_TO (string)
Message property used to specify the queue identity on to which the script expects response or reply messages to be posted.
SAM_RTT (string)
Connect protocol definition for selecting the IBM Realtime Transport protocol for communication with a business integration messaging server.
SAM_STRING (string)
Type specifier used when setting properties on SAM_Message objects.
SAM_TARGETCHAIN (string)
Connection attribute used to set the required target chain identifier.
SAM_TEXT (string)
Message body type descriptor.
SAM_TIMETOLIVE (string)
Message send option name used to specify the length of time a message should be retained in milliseconds.
SAM_TRANSACTIONS (string)
Connection attribute used to set required transactional behaviour. May be set to SAM_AUTO (default) or SAM_MANUAL.
SAM_USERID (string)
Connect attribute used to define the account to being used to connect to a messaging server that requires authorisation for connections.
SAM_WAIT (string)
Receive property used to specify the wait timeout to be used when receiving a message from a queue or subscription.
SAM_WMQ (string)
Connect protocol definition for selecting the IBM WebSphere MQSeries protocol for communication with the desired messaging server.
SAM_WMQ_BINDINGS (string)
Connect protocol definition for selecting the IBM WebSphere MQSeries protocol for communication with a local messaging server.
SAM_WMQ_CLIENT (string)
Connect protocol definition for selecting the IBM WebSphere MQSeries protocol for communication with a remote messaging server.
SAM_WMQ_TARGET_CLIENT (string)
Option name used on send requests to specify the target client mode. This can either be default to 'jms' or 'mq'. The default is 'jms' which means an RFH2 header is sent with the message whereas the 'mq' setting means no RFH2 is included.
SAM_WPM (string)
Connect protocol definition for selecting the IBM WebSphere Platform Messaging protocol for communication with a WebSphere Application Server messaging server.
Özkaynak Türleri
Örnekler
SAM


Örnekler

İçindekiler

  • Connections
  • Messages
  • Messaging operations
  • Publish/Subscribe and subscriptions to topics
  • Error handling
Öntanımlı Sabitler
Connections
SAM


Connections

In order to perform any messaging and queueing functions a connection must be established with a messaging server by creating a SAMConnection object and calling its "connect" method, with a set of connection properties, to connect the PHP script to the messaging server. Until such time as the SAMConnection object is destroyed the connection will be maintained and available for use. All SAMConnection objects are destroyed when the PHP script exits.

A set of default properties may be used in connecting to a messaging server but as a minimum the PHP script must specify a protocol to be used.

Örnek 1 Creating a connection and connecting to a remote WebSphere MQSeries Messaging Server

<?php
$conn = new SAMConnection();
$conn->connect(SAM_WMQ, array(SAM_HOST => 'myhost.mycompany.com',
                              SAM_PORT => 1506,
                              SAM_BROKER => 'mybroker'));
?>

Örnek 2 Creating a connection and connecting to a remote WebSphere Application Server

<?php
$conn = new SAMConnection();
$conn->connect(SAM_WPM, array(SAM_ENDPOINTS => 'localhost:7278:BootstrapBasicMessaging',
                              SAM_BUS => 'Bus1',
                              SAM_TARGETCHAIN => 'InboundBasicMessaging'));
?>

Örnek 3 Creating a connection and connecting to an MQTT server

<?php
$conn = new SAMConnection();
$conn->connect(SAM_MQTT, array(SAM_HOST => 'myhost.mycompany.com',
                               SAM_PORT => 1883));
?>

Örnekler
Messages
Örnekler


Messages

Messages sent to and received from queues are represented by the SAMMessage object. The SAMMessage object encapsulates the body of the message (if one exists) and the header properties associated with the message. A SAMMessage object is either supplied as a parameter to a messaging operation or returned as a result.

Örnek 1 Creating a message with a simple text body

<?php
$msg = new SAMMessage('This is a simple text message');
?>

Messages may have header properties associated with them that provide control over the transport of the message or further information to the receiving application. By default message properties are delivered to the underlying messaging system as strings and in this case they may be set with the following simple syntax:

Örnek 2 Setting a text format property using the default syntax

<?php
$msg->header->myPropertyName = 'textData';
?>

If it is desired to pass type information an alternative syntax may be used where the value and the type hint are passed in an associative array:

Örnek 3 Setting a property using a type hint

<?php
$msg->header->myPropertyName = array(3.14159, SAM_FLOAT);
?>

Properties may also be extracted from the header of a message.

Örnek 4 Retrieving a property from a message header

<?php
$myProperty = $msg->header->myPropertyName;
?>

Connections
Messaging operations
Örnekler


Messaging operations

All messaging operations are performed through calls to methods on the connection object. To add a message to a queue the "send" method is used, to obtain a message from a queue the "receive" method is used. Other methods provide publish and subscribe functionality and control of transaction boundaries.

Örnek 1 Adding a message to a queue and receiving a response

<?php
$msg = new SAMMessage('This is a simple text message');
$msg->header->SAM_REPLY_TO = 'queue://receive/test';
$correlid = $conn->send('queue://send/test', $msg);

if (!$correlid) {
  // The Send failed!
  echo "Send failed ($conn->errno) $conn->error";
} else {
  $resp = $conn->receive('queue://receive/test', array(SAM_CORRELID => $correlid));
}
?>

Messages
Publish/Subscribe and subscriptions to topics
Örnekler


Publish/Subscribe and subscriptions to topics

SAM allows messages to be sent either to queues or, for WebSphere MQ and WPM, to publish/subscribe topics. A topic destination is specified to SAM in the usual way, i.e. in the form 'topic://fred', rather than the form 'queue://AQUEUE' used for point to point operation. To use publish/subscribe it is simply necessary to specify the correct broker name on the SAMConnect "connect" call and the desired topic in the destination argument to the SAMConnect "send" and "receive" calls. The PHP interface is otherwise identical to the point to point model.

By default, SAM creates non-durable subscriptions when using publish/subscribe. This means that if a client application is inactive when messages are published to a topic, then it will not receive them when it subsequently restarted. SAM does also allow durable subscriptions to be made to topics when using WPM or WebSphere MQ publish/subscribe. The purpose of these subscriptions is to allow data to be received by a client application even if that client was not active at the time the data was published.

Durable subscriptions are specified by using the SAMConnect "subscribe" call. This method takes the destination topic as an input parameter and returns a subscription identifier that may be used on subsequent "receive" calls. When the subscription is no longer required the SAMConnection "unsubscribe" method should be used to delete the subscription.

Örnek 1 Creating a durable subscription to a topic

<?php

$subName = $conn->subscribe('topic://A');

if (!$subName) {
   echo "Subscribe failed";
} else {
   # Subscribe was OK
   // ...
}
?>

Örnek 2 Subscribing to a topic using a WebSphere Platform Messaging (WPM) server

<?php
$conn = new SAMConnection();
// Note: For pub/sub on WPM, when connecting the name of a messaging engine
//   to hold the durable subscription (SAM_WPM_DUR_SUB_HOME) must be specified.
$conn->connect(SAM_WMQ, array(SAM_ENDPOINTS => 'localhost:7278:BootstrapBasicMessaging',
                              SAM_BUS => 'Bus1',
                              SAM_TARGETCHAIN => 'InboundBasicMessaging',
                              SAM_WPM_DUR_SUB_HOME => 'MyMachineNode01.server1-Bus1'));

$subName = $conn->subscribe('topic://A');

if (!$subName) {
   echo "Subscribe failed";
} else {
   # Subscribe was OK
   // ...
}
?>

Örnek 3 Receiving published data using a durable subscription

<?php

$msg = $conn->receive($subName);
if ($msg) {
   echo "Received a message OK";
} else {
   echo "The receive failed";
}

?>

Örnek 4 Deleting a durable subscription to a topic

<?php

if (!$conn->unsubscribe($subName)) {
   echo "Unsubscribe failed";
}

?>

Messaging operations
Error handling
Örnekler


Error handling

All SAMConnection methods that provide access to messaging operations return FALSE if an error occurred in processing the request. In addition the SAMConnection object has two properties, "errno" and "error", that provide respectively the error number and text description of the last error to occur on the connection.

Örnek 1 Handling an error from a method that returns no result

<?php
if (!$conn->commit()) {
    // The commit failed!
    echo "Commit failed ($conn->errno) $conn->error";
}
?>

Örnek 2 Handling an error from a method that returns a result

<?php
$correlid = $conn->send('queue://send/test', $msg);

if (!$correlid) {
  // The Send failed!
  echo "Send failed ($conn->errno) $conn->error";
} else {
  /* ... */
}
?>

Publish/Subscribe and subscriptions to topics
SAM İşlevleri
Örnekler


SAM İşlevleri

Öntanımlı Sınıflar

SAMConnection

Object representing a connection to a Messaging Server

Nesne Kurucu

  • new SAMConnection - construct a new connection object to allow connection to a messaging infrastructure.

Yöntemler

  • commit - a method that commits (successfully completes) an in-flight unit of work.

  • connect - a method that connects a PHP script to a messaging server.

  • disconnect - a method that disconnects a PHP script from a messaging server.

  • isConnected - a method that checks whether a PHP script is connected to a messaging server.

  • peek - a method that receives a message from a queue without removing it from the queue.

  • peekAll - a method that receives one or messages from a queue without removing them from the queue.

  • receive - a method that receives a message from a queue or subscription.

  • remove - a method that removes a message from a queue.

  • rollback - a method that cancels (rolls back) an in-flight unit of work.

  • send - a method that sends a message to a queue or posts to a topic

  • setDebug - a method that switches additional debugging output on or off

  • subscribe - a method that creates a subscription to one or more topics

  • unsubscribe - a method that destroys a subscription to one or more topics

Özellikler

  • errno - the numeric error code for the last encountered error on this connection. This property is set to 0 if the last operation was successful.

  • error - the text description for the last encountered error on this connection

SAMMessage

Object representing a message to be sent or received

Nesne Kurucu

  • new SAMMessage - construct a new message.

Özellikler

  • body - the body of the message.

  • header - the header properties of the message.

İçindekiler

  • SAMConnection::commit — Commits (completes) the current unit of work.
  • SAMConnection::connect — Establishes a connection to a Messaging Server
  • SAMConnection::__construct — Creates a new connection to a Messaging Server
  • SAMConnection::disconnect — Disconnects from a Messaging Server
  • SAMConnection::errno — Contains the unique numeric error code of the last executed SAM operation.
  • SAMConnection::error — Contains the text description of the last failed SAM operation.
  • SAMConnection::isConnected — Queries whether a connection is established to a Messaging Server
  • SAMConnection::peek — Read a message from a queue without removing it from the queue.
  • SAMConnection::peekAll — Read one or more messages from a queue without removing it from the queue.
  • SAMConnection::receive — Receive a message from a queue or subscription.
  • SAMConnection::remove — Remove a message from a queue.
  • SAMConnection::rollback — Cancels (rolls back) an in-flight unit of work.
  • SAMConnection::send — Send a message to a queue or publish an item to a topic.
  • SAMConnection::setDebug — Turn on or off additional debugging output.
  • SAMConnection::subscribe — Create a subscription to a specified topic.
  • SAMConnection::unsubscribe — Cancel a subscription to a specified topic.
  • SAMMessage::body — The body of the message.
  • SAMMessage::__construct — Creates a new Message object
  • SAMMessage::header — The header properties of the message.
Error handling
SAMConnection::commit
SAM


Commits (completes) the current unit of work.

SAM İşlevleri
SAMConnection::connect
SAM İşlevleri
PHP Manual

SAMConnection::commit

(PECL sam >= 0.1.0)

SAMConnection::commit — Commits (completes) the current unit of work.

Açıklama

bool SAMConnection::commit ( void )

Calling the "commit" method on a Connection object commits (completes) all in-flight transactions that are part of the current unit of work.

Dönen Değerler

This method returns FALSE if an error occurs.

Örnekler

Örnek 1 Committing the current unit of work

<?php
  if (!$conn->commit()) {
    // The commit failed!
    echo "Commit failed ($conn->errno) $conn->error";
  }
?>

Ayrıca Bakınız

  • SAMConnection::rollback

SAM İşlevleri
SAMConnection::connect
SAM İşlevleri


Establishes a connection to a Messaging Server

SAMConnection::commit
SAMConnection::__construct
SAM İşlevleri
PHP Manual

SAMConnection::connect

(PECL sam >= 0.1.0)

SAMConnection::connect — Establishes a connection to a Messaging Server

Açıklama

bool SAMConnection::connect ( string $protocol [, array $properties ] )

Calling the "connect" method on a SAMConnection object connects the PHP script to a messaging server. No messages can be sent or received until a connection is made.

Değiştirgeler

Dönen Değerler

This method returns FALSE if an error occurs.

Örnekler

Örnek 1 Creating a connection to a Messaging Server using the IBM MQSeries protocol (WMQ)

<?php

$conn->connect(SAM_WMQ, array(SAM_HOST => 'Myhost.myco.com', SAM_PORT => 1506, SAM_BROKER => 'MyBroker'));

?>

Örnek 2 Creating a connection with application transaction control and default host and port values

<?php

$conn->connect(SAM_WMQ, array(SAM_BROKER => 'MyBroker', SAM_TRANSACTIONS => SAM_MANUAL));

?>

Örnek 3 Creating a connection to a Messaging Server using the IBM WebSphere Platform Messaging protocol (WPM)

<?php

$conn->connect(SAM_WPM, array(SAM_ENDPOINTS => 'localhost:7278:BootstrapBasicMessaging',
                              SAM_BUS => 'Bus1', SAM_TARGETCHAIN => 'InboundBasicMessaging'));

?>

Ayrıca Bakınız

  • SAMConnection::isConnected
  • SAMConnection::disconnect

SAMConnection::commit
SAMConnection::__construct
SAM İşlevleri


Creates a new connection to a Messaging Server

SAMConnection::connect
SAMConnection::disconnect
SAM İşlevleri
PHP Manual

SAMConnection::__construct

(PECL sam >= 0.1.0)

SAMConnection::__construct — Creates a new connection to a Messaging Server

Açıklama

SAMConnection::__construct ( void )

Creates a new SAMConnection object.

Örnekler

Örnek 1 Creating a connection object and connecting to a Messaging Server

<?php

$conn = new SAMConnection();
$conn->connect(SAM_WMQ, array(SAM_HOST => localhost, SAM_PORT => 1414, SAM_BROKER => 'bull'));

?>

SAMConnection::connect
SAMConnection::disconnect
SAM İşlevleri


Disconnects from a Messaging Server

SAMConnection::__construct
SAMConnection::errno
SAM İşlevleri
PHP Manual

SAMConnection::disconnect

(PECL sam >= 0.1.0)

SAMConnection::disconnect — Disconnects from a Messaging Server

Açıklama

bool SAMConnection::disconnect ( void )

Calling the "disconnect" method on a SAMConnection object disconnects the PHP script from a messaging server. No messages can be sent or received after a connection has been disconnected.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Disconnecting from a Messaging Server

<?php

$conn->disconnect();

?>

Ayrıca Bakınız

  • SAMConnection::isConnected
  • SAMConnection::connect

SAMConnection::__construct
SAMConnection::errno
SAM İşlevleri


Contains the unique numeric error code of the last executed SAM operation.

SAMConnection::disconnect
SAMConnection::error
SAM İşlevleri
PHP Manual

SAMConnection::errno

(PECL sam >= 0.1.0)

SAMConnection::errno — Contains the unique numeric error code of the last executed SAM operation.

Description

int $SAMConnection->errno;

Contains the numeric error code of the last executed SAM operation on this connection. If the last operation completed successfully this property contains 0.

Dönen Değerler

An integer greater than zero indicates the last error type encountered on the connection. Zero indicates that the last operation on this connection completed successfully.

Örnekler

Örnek 1 Using the error number and description properties

<?php
$conn = new SAMConnection();
$conn->connect(SAM_WMQ, array(SAM_HOST => 'localhost', SAM_PORT => 1506));
$msg = new SAMMessage('This is a simple text item');
if (!$conn->send('topic://test', $msg)) {
    // The Send failed!
    echo "Send failed ($conn->errno) $conn->error";
}
?>

Ayrıca Bakınız

  • SAMConnection::error

SAMConnection::disconnect
SAMConnection::error
SAM İşlevleri


Contains the text description of the last failed SAM operation.

SAMConnection::errno
SAMConnection::isConnected
SAM İşlevleri
PHP Manual

SAMConnection::error

(PECL sam >= 0.1.0)

SAMConnection::error — Contains the text description of the last failed SAM operation.

Açıklama

string $SAMConnection->error;

Contains the text description of the last failed SAM operation on this connection. If the last operation completed successfully this property contains an empty string.

Dönen Değerler

A string containing the text description of the last error type encountered on the connection. An empty string indicates that the last operation on this connection completed successfully.

Örnekler

Örnek 1 Using the error number and description properties

<?php
$conn = new SAMConnection();
$conn->connect(SAM_WMQ, array(SAM_HOST => 'localhost', SAM_PORT => 1506));
$msg = new SAMMessage('This is a simple text item');
if (!$conn->send('topic://test', $msg)) {
    // The Send failed!
    echo "Send failed ($conn->errno) $conn->error";
}
?>

Ayrıca Bakınız

  • SAMConnection::errno

SAMConnection::errno
SAMConnection::isConnected
SAM İşlevleri


Queries whether a connection is established to a Messaging Server

SAMConnection::error
SAMConnection::peek
SAM İşlevleri
PHP Manual

SAMConnection::isConnected

(PECL sam >= 0.1.0)

SAMConnection::isConnected — Queries whether a connection is established to a Messaging Server

Açıklama

bool SAMConnection::isConnected ( void )

Calling the "isConnected" method on a Connection object will check whether the PHP script is connected to a messaging server. No messages can be sent or received unless a connection has been established with a Messaging server.

Dönen Değerler

This method returns TRUE if the SAMConnection object is successfully connected to a Messaging server or FALSE otherwise.

Örnekler

Örnek 1 Checking whether there us a connection to a Messaging Server

<?php

if ($conn->isConnected()) {
  echo 'Connection is active.';
} else {
  echo 'No active connection!';
}

?>

Ayrıca Bakınız

  • SAMConnection::disconnect
  • SAMConnection::connect

SAMConnection::error
SAMConnection::peek
SAM İşlevleri


Read a message from a queue without removing it from the queue.

SAMConnection::isConnected
SAMConnection::peekAll
SAM İşlevleri
PHP Manual

SAMConnection::peek

(PECL sam >= 0.1.0)

SAMConnection::peek — Read a message from a queue without removing it from the queue.

Açıklama

SAMMessage SAMConnection::peek ( string $target [, array $properties ] )

Değiştirgeler

target

The identity of the queue from which to peek the message.

properties

An optional associative array of properties describing other parameters to control the peek operation.

Property name | Possible values
SAM_CORRELID | This is the target correlation id string of the message. This would typically have been returned by a "send" request.
SAM_MESSAGEID | This is the message id string of the message which is to be peeked.

Dönen Değerler

This method returns a SAMMessage object or FALSE if an error occurs.

Örnekler

Örnek 1 Retrieve the next message from a queue without removing it

<?php
$msg = $conn->peek('queue://receive/test');

if (!$msg) {
  // The peek failed!
  echo "Peek failed ($conn->errno) $conn->error";
}
?>

Örnek 2 Retrieve a specific message from a queue without removing it from the queue

<?php

$msg = $conn->peek('queue://receive/test', array(SAM_MESSAGEID => $messageId));

?>

Ayrıca Bakınız

  • SAMConnection::peekAll

SAMConnection::isConnected
SAMConnection::peekAll
SAM İşlevleri


Read one or more messages from a queue without removing it from the queue.

SAMConnection::peek
SAMConnection::receive
SAM İşlevleri
PHP Manual

SAMConnection::peekAll

(PECL sam >= 0.2.0)

SAMConnection::peekAll — Read one or more messages from a queue without removing it from the queue.

Açıklama

array SAMConnection::peekAll ( string $target [, array $properties ] )

Değiştirgeler

target

The identity of the queue from which messages should be peeked.

properties

An optional associative array of properties describing other parameters to control the peek operation.

Property name | Possible values
SAM_CORRELID | This is the target correlation id string of messages to be peeked. This would typically have been returned by a "send" request.
SAM_MESSAGEID | This is the message id string of a message which is to be peeked.

Dönen Değerler

This method returns an array of SAMMessage objects or FALSE if an error occurs.

Örnekler

Örnek 1 Retrieve all messages in a queue without removing them

<?php
$msgArray = $conn->peekAll('queue://receive/test');
if ($msgArray) {
   foreach ( $msgArray as $key => $msg) {
       echo "Message $key: body = $msg->body\n";
   }
} else {
   echo "PeekAll failed ($conn->errno) $conn->error";
}
?>

Örnek 2 Retrieve all messages from a queue with a matching correlation id

<?php

   $msgArray = $conn->peekAll('queue://receive/test', array(SAM_CORRELID => $correlId ));
   if ($msgArray) {

      foreach ( $msgArray as $key => $msg) {
            echo "Message $key: body = $msg->body\n";
         }
   } else {
      echo "PeekAll failed ($conn->errno) $conn->error";
   }

?>

Ayrıca Bakınız

  • SAMConnection::peek

SAMConnection::peek
SAMConnection::receive
SAM İşlevleri


Receive a message from a queue or subscription.

SAMConnection::peekAll
SAMConnection::remove
SAM İşlevleri
PHP Manual

SAMConnection::receive

(PECL sam >= 0.1.0)

SAMConnection::receive — Receive a message from a queue or subscription.

Açıklama

SAMMessage SAMConnection::receive ( string $target [, array $properties ] )

Değiştirgeler

target

The identity of the queue, topic or subscription from which to receive the message.

properties

An optional associative array of properties describing other parameters to control the receive operation.

Property name | Possible values
SAM_CORRELID | Used to request selection of the message to receive based upon the correlation id string of the message.
SAM_MESSAGEID | Used to request selection of the message to receive based upon the message id string of the message.
SAM_WAIT | Timeout value in milliseconds to control how long the request should block waiting to receive a message before returning with a failure if no message is available on the queue or topic. The default value is 0 meaning wait indefinitely and should be used with caution as the request may wait until the overall PHP script processing time limit has expired if no message becomes available.

Dönen Değerler

This method returns a SAMMessage object or FALSE if an error occurs.

Örnekler

Örnek 1 Receiving a message from a queue

<?php
$msg = $conn->receive('queue://receive/test');

if (!$msg) {
  // The receive failed!
  echo "Receive failed ($conn->errno) $conn->error";
}
?>

Örnek 2 Receiving a message from a queue with options

In this example the SAM_CORRELID option is used to specify a correlation id string to be used to identify the message to receive. A wait timeout of 10 seconds is also specified.

<?php

$msg = $conn->receive('queue://receive/test', array(SAM_CORRELID => $token, SAM_WAIT => 10000));

?>

Örnek 3 Receiving a message from a subscription

In this example we show how to receive a message from a subscription id.

<?php
$msg = $conn->receive($subscriptionName);

if (!$msg) {
  // The receive failed!
  echo "Receive failed ($conn->errno) $conn->error";
}
?>

Please note that $subscriptionName is a subscription id returned from an earlier subscribe call.

Ayrıca Bakınız

  • SAMConnection::send

SAMConnection::peekAll
SAMConnection::remove
SAM İşlevleri


Remove a message from a queue.

SAMConnection::receive
SAMConnection::rollback
SAM İşlevleri
PHP Manual

SAMConnection::remove

(PECL sam >= 0.1.0)

SAMConnection::remove — Remove a message from a queue.

Açıklama

SAMMessage SAMConnection::remove ( string $target [, array $properties ] )

Removes a message from a queue.

Değiştirgeler

target

The identity of the queue from which to remove the message.

properties

An optional associative array of properties describing other parameters to control the remove operation.

Property name | Possible values
SAM_CORRELID | This is the target correlation id string of the message. This would typically have been returned by a "send" request.
SAM_MESSAGEID | This is the message id string of the message which is to be removed.

Dönen Değerler

This method returns FALSE if an error occurs.

Örnekler

Örnek 1 Removing a message from a queue by message id

<?php
if (!$conn->remove('queue://receive/test', array(SAM_MESSAGEID => $messageId))) {
  // The remove failed!
  echo "Remove failed ($conn->errno) $conn->error";
}
?>

SAMConnection::receive
SAMConnection::rollback
SAM İşlevleri


Cancels (rolls back) an in-flight unit of work.

SAMConnection::remove
SAMConnection::send
SAM İşlevleri
PHP Manual

SAMConnection::rollback

(PECL sam >= 0.1.0)

SAMConnection::rollback — Cancels (rolls back) an in-flight unit of work.

Açıklama

bool SAMConnection::rollback ( void )

Rolls back an in-flight unit of work.

Dönen Değerler

This method returns FALSE if an error occurs.

Örnekler

Örnek 1 Cancelling an in-flight unit of work

<?php
if (!$conn->rollback()) {
  // The rollback failed!
  echo "Rollback failed ($conn->errno) $conn->error";
}
?>

Ayrıca Bakınız

  • SAMConnection::commit

SAMConnection::remove
SAMConnection::send
SAM İşlevleri


Send a message to a queue or publish an item to a topic.

SAMConnection::rollback
SAMConnection::setDebug
SAM İşlevleri
PHP Manual

SAMConnection::send

(PECL sam >= 0.1.0)

SAMConnection::send — Send a message to a queue or publish an item to a topic.

Açıklama

string SAMConnection::send ( string $target , SAMMessage $msg [, array $properties ] )

The "send" method is used to send a message to a specific queue or to publish to a specific topic. The method returns a correlation id that can be used as a selector to identify reply or response messages when these are requested.

Değiştirgeler

target

If sending a message, the identity of the queue (queue://queuename) or if publishing to a topic the identity of the topic (topic://topicname) to which the message is to be delivered.

msg

The message to be sent or published.

properties

An optional associative array of properties describing other parameters to control the receive operation.

Property name | Possible values
SAM_DELIVERYMODE | Indicates whether the messaging server should ensure delivery or whether it is acceptable for messages to be lost in the case of system failures. The value of this property may be set to either SAM_PERSISTENT, to indicate that message loss is not acceptable, or SAM_NON_PERSISTENT, if message loss is acceptable. The resulting behaviour of the send will vary depending on the capabilities of the messaging server the PHP script is currently connected to. If the server does not support persistent messages and SAM_PERSISTENT is specified the send request will fail with an error indication showing the capability is not available.
SAM_PRIORITY | A numeric value between 0 and 9 indicating the desired message delivery priority. A priority value of 0 indicates the lowest priority while 9 indicates highest priority. If no priority is specified a default will be assigned which is dependent on the messaging server being used.
SAM_CORRELID | A string to be assigned as a correlation id for this message. If no value is given the messaging server may assign a value automatically.
SAM_TIMETOLIVE | A time in milliseconds indicating how long the messaging server should retain the message on a queue before discarding it. The default value is 0 indicating the message should be retained indefinitely.
SAM_WMQ_TARGET_CLIENT | This property is only valid when using WebSphere MQ and indicates whether or not an RFH2 header should be included with the message. This option may be set to either 'jms' or 'mq'. The default is 'jms' which means that an RFH2 header is included. If the value 'mq' is specified then no RFH2 is included with the message.

Dönen Değerler

A correlation id string that can be used in a subsequent receive call as a selector to obtain any reply or response that has been requested or FALSE if an error occurred.

Bilginize:

A correlation id will only be returned for a successful send to a queue destination (queue://xxxx) in which case it will reflect the message identity of the message on the queue. In the case of a send being used to publish data to a topic the return value will be TRUE as no correlation id is available for return.

Örnekler

Örnek 1 Send a message to a queue

<?php
$msg = new SAMMessage('This is a simple text message');
$correlId = $conn->send('queue://send/test', $msg);
if (!$correlId) {
    // The send failed!
    echo "Send failed ($conn->errno) $conn->error";
}

?>

Örnek 2 Publish a message to a topic

<?php
$msg = new SAMMessage('This is a simple text item');
if (!$conn->send('topic://test', $msg)) {
    // The Send failed!
    echo "Send failed ($conn->errno) $conn->error";
}
?>

Örnek 3 Send a request and receive a response

<?php
$msg = new SAMMessage('This is a simple text message');
$msg->header->SAM_REPLY_TO = 'queue://receive/test';
$correlid = $conn->send('queue://send/test', $msg);

if (!$correlid) {
    // The Send failed!
    echo "Send failed ($conn->errno) $conn->error";
} else {
    $resp = $conn->receive('queue://receive/test', array(SAM_CORRELID => $correlid));
}
?>

Ayrıca Bakınız

  • SAMConnection::receive

SAMConnection::rollback
SAMConnection::setDebug
SAM İşlevleri


Turn on or off additional debugging output.

SAMConnection::send
SAMConnection::subscribe
SAM İşlevleri
PHP Manual

SAMConnection::setDebug

(PECL sam >= 1.1.0)

SAMConnection::setDebug — Turn on or off additional debugging output.

Açıklama

The "setdebug" method is used to turn on or off additional debugging output. The SAM framework will provide method/function entry and exit trace data plus additional information. Protocol specific implementations also provide extra output.

void SAMConnection::setDebug ( bool $switch )

Değiştirgeler

switch

If this parameter is set to TRUE additional debugging output will be provided. If the value is set to FALSE output of additional information will be stopped.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Turn on debugging output

<?php
$conn->setdebug(TRUE);
?>

Örnek 2 Turn off debugging output

<?php
$conn->setdebug(FALSE);
?>

SAMConnection::send
SAMConnection::subscribe
SAM İşlevleri


Create a subscription to a specified topic.

SAMConnection::setDebug
SAMConnection::unsubscribe
SAM İşlevleri
PHP Manual

SAMConnection::subscribe

(PECL sam >= 0.1.0)

SAMConnection::subscribe — Create a subscription to a specified topic.

Açıklama

string SAMConnection::subscribe ( string $targetTopic )

The "subscribe" method is used to create a new subscription to a specified topic.

Değiştirgeler

targetTopic

The identity of the topic (topic://topicname) to subscribe to.

Dönen Değerler

A subscription identifier that can be used in a subsequent receive call as a selector to obtain any topic data or FALSE if an error occurred. The subscription identifier should be used in the receive call in place of the simple topic name.

Örnekler

Örnek 1 Subscribe to a topic

<?php
$subid = $conn->subscribe('topic://A');
if (!$subid) {
  // The subscribe failed!
  echo "Subscribe failed ($conn->errno) $conn->error";
}
?>

Ayrıca Bakınız

  • SAMConnection::unsubscribe

SAMConnection::setDebug
SAMConnection::unsubscribe
SAM İşlevleri


Cancel a subscription to a specified topic.

SAMConnection::subscribe
SAMMessage::body
SAM İşlevleri
PHP Manual

SAMConnection::unsubscribe

(PECL sam >= 0.1.0)

SAMConnection::unsubscribe — Cancel a subscription to a specified topic.

Açıklama

bool SAMConnection::unsubscribe ( string $subscriptionId [, string $targetTopic ] )

The "unsubscribe" method is used to delete an existing subscription to a specified topic.

Değiştirgeler

subscriptionId

The identifier of an existing subscription as returned by a call to the subscribe method.

Dönen Değerler

This method returns FALSE if an error occurs.

Örnekler

Örnek 1 Delete a subscription

<?php
if (!$conn->unsubscribe($subid)) {
    // The unsubscribe failed!
    echo "Unsubscribe failed ($conn->errno) $conn->error";
}
?>

Ayrıca Bakınız

  • SAMConnection::subscribe

SAMConnection::subscribe
SAMMessage::body
SAM İşlevleri


The body of the message.

SAMConnection::unsubscribe
SAMMessage::__construct
SAM İşlevleri
PHP Manual

SAMMessage::body

(PECL sam >= 0.1.0)

SAMMessage::body — The body of the message.

Açıklama

string $SAMMessage->body;

The "body" property contains the actual body of the message. It may not always be set.

Örnekler

Örnek 1 Setting a text string into the body of a message

<?php
$msg = new SAMMessage();
$msg->body = 'This is a simple message';

?>

Ayrıca Bakınız

  • SAMMessage::header

SAMConnection::unsubscribe
SAMMessage::__construct
SAM İşlevleri


Creates a new Message object

SAMMessage::body
SAMMessage::header
SAM İşlevleri
PHP Manual

SAMMessage::__construct

(PECL sam >= 0.1.0)

SAMMessage::__construct — Creates a new Message object

Açıklama

SAMMessage::__construct ([ mixed $body ] )

Creates a new SAMMessage object optionally specifying a message body.

Değiştirgeler

body

The optional body for the message.

Örnekler

Örnek 1 Creating a message

<?php

$msg = new SAMMessage();

?>

Örnek 2 Creating a message with a simple text payload

<?php

$msg = new SAMMessage('This is a simple text message');

?>

SAMMessage::body
SAMMessage::header
SAM İşlevleri


The header properties of the message.

SAMMessage::__construct
SNMP
SAM İşlevleri
PHP Manual

SAMMessage::header

(PECL sam >= 0.1.0)

SAMMessage::header — The header properties of the message.

Açıklama

object $SAMMessage->header;

The header property is a container for any system or user properties that area associated with the message.

Properties may be assigned by the sender of a message to control the way the messaging systems handles it or may be assigned by the messaging system itself to tell the recipient extra information about the message or the way in which it has been handled.

Some properties are understood by SAM in which case constants have been defined for them. The majority of properties however are ignored by the SAM implementation and simply passed through to the underlying messaging systems allowing the application to use messaging specific property names or to define its own "user" properties.

The SAM defined properties are as follows:

Property name | Possible values
SAM_MESSAGEID | When a message is received this field contains the unique identifier of the message as allocated by the underlying messaging system. When sending a message this field is ignored.
SAM_REPLY_TO | A string providing the identity of the queue on to which responses to this message should be posted.
SAM_TYPE

An indication of the type of message to be sent. The value may be SAM_TEXT indicating the contents of the message body is a text string, or SAM_BYTES indicating the contents of the message body are some application defined format.

The way in which this property is used may depend on the underlying messaging server. For instance a messaging server that supports the JMS (Java Message Service) specification may interpret this value and send messages of type "jms_text" and "jms_bytes". In addition, if the SAM_TYPE property is set to SAM_TEXT the data provided for the message body is expected to be a UTF8 encoded string.

When setting the values of properties it is often useful to give a hint as to the format in which the property should be delivered to the messaging system. By default property values are delivered as text and the following simple syntax may be used to set a value:

Örnek 1 Setting a text format property using the default syntax

<?php
$msg = new SAMMessage();

$msg->header->myPropertyName = 'textData';
?>

If it is desired to pass type information an alternative syntax may be used where the value and the type hint are passed in an associative array:

Örnek 2 Setting a text format property using a type hint

<?php
$msg = new SAMMessage();

$msg->header->myPropertyName = array('textData', SAM_STRING);
?>

When passing a type hint the type entry should be one of the SAM defined constant values as defined by the following table:

Constant | Type description
SAM_BOOLEAN | Any value passed will be interpreted as logical true or false. If the value cannot be interpreted as a PHP boolean value the value passed to the messaging system is undefined.
SAM_BYTE | An 8-bit signed integer value. SAM will attempt to convert the property value specified into a single byte value to pass to the messaging system. If a string value is passed an attempt will be made to interpret the string as a numeric value. If the numeric value cannot be expressed as an 8-bit signed binary value data may be lost in the conversion.
SAM_DOUBLE | A long floating point value. SAM will attempt to convert the property value specified into a floating point value with 15 digits of precision. If a string value is passed an attempt will be made to interpret the string as a numeric value. If the passed value cannot be expressed as a 15 digit floating point value data may be lost in the conversion.
SAM_FLOAT | A short floating point value. SAM will attempt to convert the property value specified into a floating point value with 7 digits of precision. If a string value is passed an attempt will be made to interpret the string as a numeric value. If the passed value cannot be expressed as a 7 digit floating point value data may be lost in the conversion.
SAM_INT | An 32-bit signed integer value. SAM will attempt to convert the property value specified into a 32-bit value to pass to the messaging system. If a string value is passed an attempt will be made to interpret the string as a numeric value. If the numeric value cannot be expressed as an 32-bit signed binary value data may be lost in the conversion.
SAM_LONG | An 64-bit signed integer value. SAM will attempt to convert the property value specified into a 64-bit value to pass to the messaging system. If a string value is passed an attempt will be made to interpret the string as a numeric value. If the numeric value cannot be expressed as an 64-bit signed binary value data may be lost in the conversion.
SAM_STRING | SAM will interpret the property value specified as a string and pass it to the messaging system accordingly.

Örnekler

Örnek 3 Setting properties as the sender of a message

<?php
$msg = new SAMMessage('This is a test message');

// defining SAM specific properties...
$msg->header->SAM_REPLY_TO = 'queue://test/replyQueue';

// defining arbitrary properties...
//
// a default string property
$msg->header->myStringProp1 = 'a string property';
// a string property with a type hint
$msg->header->myStringProp2 = array('another string property', SAM_STRING);

// a boolean property
$msg->header->myBoolProp = array(FALSE, SAM_BOOL);

// numeric format properties
$msg->header->myIntProp = array(32768, SAM_INT);
$msg->header->myLongProp = array(9876543, SAM_LONG);
$msg->header->myByteProp1 = array(123, SAM_BYTE);
$msg->header->myByteProp2 = array('12', SAM_BYTE);
$msg->header->myFloatProp = array(3.141592, SAM_FLOAT);
$msg->header->myDoubleProp = array(3.14159265358979, SAM_DOUBLE);
?>

Örnek 4 Retreiving property values from a message

<?php

// accessing an application specific property
$intProp = $msg->header->MyIntProp;

// accessing a messaging system specific property
$encoding = $msg->header->JMS_IBM_Msgtype;

?>

Ayrıca Bakınız

  • SAMMessage::body

SAMMessage::__construct
SNMP
SAM İşlevleri


SNMP

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • SNMP İşlevleri
    • snmp_get_quick_print — Fetches the current value of the UCD library's quick_print setting
    • snmp_get_valueretrieval — Return the method how the SNMP values will be returned
    • snmp_read_mib — Reads and parses a MIB file into the active MIB tree
    • snmp_set_enum_print — Return all values that are enums with their enum value instead of the raw integer
    • snmp_set_oid_numeric_print — Set the OID output format
    • snmp_set_oid_output_format — Set the OID output format
    • snmp_set_quick_print — Set the value of quick_print within the UCD SNMP library
    • snmp_set_valueretrieval — Specify the method how the SNMP values will be returned
    • snmp2_get — Fetch an SNMP object
    • snmp2_getnext — Fetch the SNMP object which follows the given object id
    • snmp2_real_walk — Return all objects including their respective object ID within the specified one
    • snmp2_set — Set the value of an SNMP object
    • snmp2_walk — Fetch all the SNMP objects from an agent
    • snmp3_get — Fetch an SNMP object
    • snmp3_getnext — Fetch the SNMP object which follows the given object id
    • snmp3_real_walk — Return all objects including their respective object ID within the specified one
    • snmp3_set — Set the value of an SNMP object
    • snmp3_walk — Fetch all the SNMP objects from an agent
    • snmpget — Fetch an SNMP object
    • snmpgetnext — Fetch the SNMP object which follows the given object id
    • snmprealwalk — Return all objects including their respective object ID within the specified one
    • snmpset — Set the value of an SNMP object
    • snmpwalk — Fetch all the SNMP objects from an agent
    • snmpwalkoid — Query for a tree of information about a network entity
  • SNMP — The SNMP class
    • SNMP::close — Close SNMP session
    • SNMP::__construct — Creates SNMP instance representing session to remote SNMP agent
    • SNMP::get — Fetch an SNMP object
    • SNMP::getErrno — Get last error code
    • SNMP::getError — Get last error message
    • SNMP::getnext — Fetch an SNMP object which follows the given object id
    • SNMP::set — Set the value of an SNMP object
    • SNMP::setSecurity — Configures security-related SNMPv3 session parameters
    • SNMP::walk — Fetch SNMP object subtree
  • SNMPException — The SNMPException class
SAMMessage::header
Giriş
Diğer Hizmetler


Giriş

The SNMP extension provides a very simple and easily usable toolset for managing remote devices via the Simple Network Management Protocol.

As it is a wrapper around the underlying Net-SNMP (or UCD-SNMP on older systems) library, all basic concepts are the same and the PHP functions change their behaviour depending on the Net-SNMP configuration files and environment variables.

Beginning with PHP 5.4, an OO API is available.

More information about Net-SNMP can be found at » http://www.net-snmp.org/

SNMP
Yapılandırma/Kurulum
SNMP


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
SNMP


Gereksinimler

In order to use the SNMP functions requires installation of the » Net-SNMP package. SNMPv3 functions available only when » OpenSSL package is installed too.

On Windows SNMP functions are only available on NT and not on Win95/98.

Beginning with PHP 5.4.0 Net-SNMP version 5.3+ is required for Unix installations and Net-SNMP version 5.4+ for Windows.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

PHP 5.3.0, 5.3.1 and 5.3.2 do not have SNMP support. SNMP support has been restored in PHP 5.3.3.

The Windows distribution of Net-SNMP contains support files for SNMP in the mibs directory. This directory should added to Windows' environment variables, as MIBDIRS, with the value being the full path to the mibs directory: e.g. c:\usr\mibs.

Important notes for PHP prior to 5.4.0: In order to use the UCD SNMP package, you need to define NO_ZEROLENGTH_COMMUNITY to 1 before compiling it. After configuring UCD SNMP, edit config.h or acconfig.h and search for NO_ZEROLENGTH_COMMUNITY. Uncomment the #define line. It should look like this afterwards:

#define NO_ZEROLENGTH_COMMUNITY 1
Now compile PHP --with-snmp[=DIR] .

If you see strange segmentation faults in combination with SNMP commands, you did not follow the above instructions. If you do not want to recompile UCD SNMP, you can compile PHP with the --enable-ucd-snmp-hack switch which will work around the misfeature.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

For the snmp_set_oid_output_format()
SNMP_OID_OUTPUT_SUFFIX (integer)
As of 5.4.0
SNMP_OID_OUTPUT_MODULE (integer)
As of 5.4.0
SNMP_OID_OUTPUT_FULL (integer)
As of 5.2.0
SNMP_OID_OUTPUT_NUMERIC (integer)
As of 5.2.0
SNMP_OID_OUTPUT_UCD (integer)
As of 5.4.0
SNMP_OID_OUTPUT_NONE (integer)
As of 5.4.0
For the snmp_set_valueretrieval()
SNMP_VALUE_LIBRARY (integer)
SNMP_VALUE_PLAIN (integer)
SNMP_VALUE_OBJECT (integer)
SNMP types as returned if SNMP_VALUE_OBJECT was used with snmp_set_valueretrieval()
SNMP_BIT_STR (integer)
SNMP_OCTET_STR (integer)
SNMP_OPAQUE (integer)
SNMP_NULL (integer)
SNMP_OBJECT_ID (integer)
SNMP_IPADDRESS (integer)
SNMP_COUNTER (integer)
SNMP_UNSIGNED (integer)
SNMP_TIMETICKS (integer)
SNMP_UINTEGER (integer)
SNMP_INTEGER (integer)
SNMP_COUNTER64 (integer)
Özkaynak Türleri
SNMP İşlevleri
SNMP


SNMP İşlevleri

İçindekiler

  • snmp_get_quick_print — Fetches the current value of the UCD library's quick_print setting
  • snmp_get_valueretrieval — Return the method how the SNMP values will be returned
  • snmp_read_mib — Reads and parses a MIB file into the active MIB tree
  • snmp_set_enum_print — Return all values that are enums with their enum value instead of the raw integer
  • snmp_set_oid_numeric_print — Set the OID output format
  • snmp_set_oid_output_format — Set the OID output format
  • snmp_set_quick_print — Set the value of quick_print within the UCD SNMP library
  • snmp_set_valueretrieval — Specify the method how the SNMP values will be returned
  • snmp2_get — Fetch an SNMP object
  • snmp2_getnext — Fetch the SNMP object which follows the given object id
  • snmp2_real_walk — Return all objects including their respective object ID within the specified one
  • snmp2_set — Set the value of an SNMP object
  • snmp2_walk — Fetch all the SNMP objects from an agent
  • snmp3_get — Fetch an SNMP object
  • snmp3_getnext — Fetch the SNMP object which follows the given object id
  • snmp3_real_walk — Return all objects including their respective object ID within the specified one
  • snmp3_set — Set the value of an SNMP object
  • snmp3_walk — Fetch all the SNMP objects from an agent
  • snmpget — Fetch an SNMP object
  • snmpgetnext — Fetch the SNMP object which follows the given object id
  • snmprealwalk — Return all objects including their respective object ID within the specified one
  • snmpset — Set the value of an SNMP object
  • snmpwalk — Fetch all the SNMP objects from an agent
  • snmpwalkoid — Query for a tree of information about a network entity
Öntanımlı Sabitler
snmp_get_quick_print
SNMP


Fetches the current value of the UCD library's quick_print setting

SNMP İşlevleri
snmp_get_valueretrieval
SNMP İşlevleri
PHP Manual

snmp_get_quick_print

(PHP 4, PHP 5, PHP 7)

snmp_get_quick_print — Fetches the current value of the UCD library's quick_print setting

Açıklama

bool snmp_get_quick_print ( void )

Returns the current value stored in the UCD Library for quick_print. quick_print is off by default.

Dönen Değerler

Returns TRUE if quick_print is on, FALSE otherwise.

Örnekler

Örnek 1 snmp_get_quick_print() example

<?php
$quickprint = snmp_get_quick_print();
?>

Ayrıca Bakınız

  • snmp_set_quick_print() - Set the value of quick_print within the UCD SNMP library for a full description of what quick_print does.

SNMP İşlevleri
snmp_get_valueretrieval
SNMP İşlevleri


Return the method how the SNMP values will be returned

snmp_get_quick_print
snmp_read_mib
SNMP İşlevleri
PHP Manual

snmp_get_valueretrieval

(PHP 4 >= 4.3.3, PHP 5, PHP 7)

snmp_get_valueretrieval — Return the method how the SNMP values will be returned

Açıklama

int snmp_get_valueretrieval ( void )

Dönen Değerler

OR-ed combitantion of constants ( SNMP_VALUE_LIBRARY or SNMP_VALUE_PLAIN ) with possible SNMP_VALUE_OBJECT set.

Örnekler

Örnek 1 Using snmp_get_valueretrieval

<?php
 $ret = snmpget('localhost', 'public', 'IF-MIB::ifName.1');
 if (snmp_get_valueretrieval() & SNMP_VALUE_OBJECT) {
   echo $ret->value;
 } else {
   echo $ret;
 }
?>

Ayrıca Bakınız

  • snmp_set_valueretrieval() - Specify the method how the SNMP values will be returned
  • Öntanımlı Sabitler

snmp_get_quick_print
snmp_read_mib
SNMP İşlevleri


Reads and parses a MIB file into the active MIB tree

snmp_get_valueretrieval
snmp_set_enum_print
SNMP İşlevleri
PHP Manual

snmp_read_mib

(PHP 5, PHP 7)

snmp_read_mib — Reads and parses a MIB file into the active MIB tree

Açıklama

bool snmp_read_mib ( string $filename )

This function is used to load additional, e.g. vendor specific, MIBs so that human readable OIDs like VENDOR-MIB::foo.1 instead of error prone numeric OIDs can be used.

The order in which the MIBs are loaded does matter as the underlying Net-SNMP libary will print warnings if referenced objects cannot be resolved.

Değiştirgeler

filename

The filename of the MIB.

Örnekler

Örnek 1 Using snmp_read_mib()

<?php
 print_r( snmprealwalk('localhost', 'public', '.1.3.6.1.2.1.2.3.4.5') );

 snmp_read_mib('./FOO-BAR-MIB.txt');
 print_r( snmprealwalk('localhost', 'public', 'FOO-BAR-MIB::someTable' );
?>

The above example is made up but the results would look like:

Array
(
    [iso.3.6.1.2.1.2.3.4.5.0] => Gauge32: 6
)
Array
(
    [FOO-BAR-MIB::someTable.0] => Gauge32: 6
)

snmp_get_valueretrieval
snmp_set_enum_print
SNMP İşlevleri


Return all values that are enums with their enum value instead of the raw integer

snmp_read_mib
snmp_set_oid_numeric_print
SNMP İşlevleri
PHP Manual

snmp_set_enum_print

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

snmp_set_enum_print — Return all values that are enums with their enum value instead of the raw integer

Açıklama

bool snmp_set_enum_print ( int $enum_print )

This function toggles if snmpwalk/snmpget etc. should automatically lookup enum values in the MIB and return them together with their human readable string.

Değiştirgeler

enum_print

As the value is interpreted as boolean by the Net-SNMP library, it can only be "0" or "1".

Örnekler

Örnek 1 Using snmp_set_enum_print()

<?php
 snmp_set_enum_print(0);
 echo snmpget('localhost', 'public', 'IF-MIB::ifOperStatus.3') . "\n";
 snmp_set_enum_print(1);
 echo snmpget('localhost', 'public', 'IF-MIB::ifOperStatus.3') . "\n";
?>

The above would return

 INTEGER: up(1)
 INTEGER: 1

Notlar

Bilginize:

snmp_set_enum_print() is only available when using the UCD SNMP library. This function is not available when using the Windows SNMP library.

snmp_read_mib
snmp_set_oid_numeric_print
SNMP İşlevleri


Set the OID output format

snmp_set_enum_print
snmp_set_oid_output_format
SNMP İşlevleri
PHP Manual

snmp_set_oid_numeric_print

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

snmp_set_oid_numeric_print — Set the OID output format

Açıklama

void snmp_set_oid_numeric_print ( int $oid_format )

Bu işlev şu işlevin takma adıdır: snmp_set_oid_output_format().

Sürüm Bilgisi

Sürüm: | Açıklama
5.2.0 | Since PHP 5.2.0.

Ayrıca Bakınız

  • snmp_set_oid_output_format() - Set the OID output format

snmp_set_enum_print
snmp_set_oid_output_format
SNMP İşlevleri


Set the OID output format

snmp_set_oid_numeric_print
snmp_set_quick_print
SNMP İşlevleri
PHP Manual

snmp_set_oid_output_format

(PHP 5 >= 5.2.0, PHP 7)

snmp_set_oid_output_format — Set the OID output format

Açıklama

bool snmp_set_oid_output_format ( int $oid_format = SNMP_OID_OUTPUT_MODULE )

snmp_set_oid_output_format() sets the output format to be full or numeric.

Değiştirgeler

oid_format
OID .1.3.6.1.2.1.1.3.0 representation for various oid_format values
SNMP_OID_OUTPUT_FULL | .iso.org.dod.internet.mgmt.mib-2.system.sysUpTime.sysUpTimeInstance
SNMP_OID_OUTPUT_NUMERIC | .1.3.6.1.2.1.1.3.0

Begining from PHP 5.4.0 four additional constants available:

SNMP_OID_OUTPUT_MODULE | DISMAN-EVENT-MIB::sysUpTimeInstance
SNMP_OID_OUTPUT_SUFFIX | sysUpTimeInstance
SNMP_OID_OUTPUT_UCD | system.sysUpTime.sysUpTimeInstance
SNMP_OID_OUTPUT_NONE | Undefined

Dönen Değerler

Hiçbir değer dönmez.

Notlar

Bilginize:

snmp_set_oid_output_format() is only available when using the UCD SNMP library. This function is not available when using the Windows SNMP library.

Örnekler

Örnek 1 Using snmprealwalk()

<?php

 snmp_read_mib("/usr/share/mibs/netsnmp/NET-SNMP-TC");

 // default or SNMP_OID_OUTPUT_MODULE in PHP >= 5.3.6
 print_r( snmprealwalk('localhost', 'public', 'RFC1213-MIB::sysObjectID') );

 snmp_set_oid_output_format(SNMP_OID_OUTPUT_NUMERIC);
 print_r( snmprealwalk('localhost', 'public', 'RFC1213-MIB::sysObjectID') );

 snmp_set_oid_output_format(SNMP_OID_OUTPUT_FULL);
 print_r( snmprealwalk('localhost', 'public', 'RFC1213-MIB::sysObjectID') );
?>

The above would output:

 Array
 (
    [RFC1213-MIB::sysObjectID.0] => OID: NET-SNMP-TC::linux
 )
 Array
 (
    [.1.3.6.1.2.1.1.2.0] => OID: .1.3.6.1.4.1.8072.3.2.10
 )
 Array
 (
    [.iso.org.dod.internet.mgmt.mib-2.system.sysObjectID.0] => OID: .iso.org.dod.internet.private.enterprises.netSnmp.netSnmpEnumerations.netSnmpAgentOIDs.linux
 )

snmp_set_oid_numeric_print
snmp_set_quick_print
SNMP İşlevleri


Set the value of quick_print within the UCD SNMP library

snmp_set_oid_output_format
snmp_set_valueretrieval
SNMP İşlevleri
PHP Manual

snmp_set_quick_print

(PHP 4, PHP 5, PHP 7)

snmp_set_quick_print — Set the value of quick_print within the UCD SNMP library

Açıklama

bool snmp_set_quick_print ( bool $quick_print )

Sets the value of quick_print within the UCD SNMP library. When this is set (1), the SNMP library will return 'quick printed' values. This means that just the value will be printed. When quick_print is not enabled (default) the UCD SNMP library prints extra information including the type of the value (i.e. IpAddress or OID). Additionally, if quick_print is not enabled, the library prints additional hex values for all strings of three characters or less.

By default the UCD SNMP library returns verbose values, quick_print is used to return only the value.

Currently strings are still returned with extra quotes, this will be corrected in a later release.

Değiştirgeler

quick_print

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Setting quick_print is often used when using the information returned rather than displaying it.

Örnek 1 Using snmp_set_quick_print()

<?php
snmp_set_quick_print(0);
$a = snmpget("127.0.0.1", "public", ".1.3.6.1.2.1.2.2.1.9.1");
echo "$a\n";
snmp_set_quick_print(1);
$a = snmpget("127.0.0.1", "public", ".1.3.6.1.2.1.2.2.1.9.1");
echo "$a\n";
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

'Timeticks: (0) 0:00:00.00'
'0:00:00.00'

Ayrıca Bakınız

  • snmp_get_quick_print() - Fetches the current value of the UCD library's quick_print setting

snmp_set_oid_output_format
snmp_set_valueretrieval
SNMP İşlevleri


Specify the method how the SNMP values will be returned

snmp_set_quick_print
snmp2_get
SNMP İşlevleri
PHP Manual

snmp_set_valueretrieval

(PHP 4 >= 4.3.3, PHP 5, PHP 7)

snmp_set_valueretrieval — Specify the method how the SNMP values will be returned

Açıklama

bool snmp_set_valueretrieval ( int $method = SNMP_VALUE_LIBRARY )

Değiştirgeler

method
types
SNMP_VALUE_LIBRARY | The return values will be as returned by the Net-SNMP library.
SNMP_VALUE_PLAIN | The return values will be the plain value without the SNMP type hint.
SNMP_VALUE_OBJECT | The return values will be objects with the properties "value" and "type", where the latter is one of the SNMP_OCTET_STR, SNMP_COUNTER etc. constants. The way "value" is returned is based on which one of constants SNMP_VALUE_LIBRARY, SNMP_VALUE_PLAIN is set.

Örnekler

Örnek 1 Using snmp_set_valueretrieval()

<?php
 snmp_set_valueretrieval(SNMP_VALUE_LIBRARY);
 $ret = snmpget('localhost', 'public', 'IF-MIB::ifName.1');
 // $ret = "STRING: lo"

 snmp_set_valueretrieval(SNMP_VALUE_PLAIN);
 $ret = snmpget('localhost', 'public', 'IF-MIB::ifName.1');
 // $ret = "lo";

 snmp_set_valueretrieval(SNMP_VALUE_OBJECT);
 $ret = snmpget('localhost', 'public', 'IF-MIB::ifName.1');
 // stdClass Object
 // (
 //   [type] => 4        <-- SNMP_OCTET_STR, see constants
 //   [value] => lo
 // )

 // PHP 5.4+ examples
 snmp_set_valueretrieval(SNMP_VALUE_OBJECT | SNMP_VALUE_PLAIN);
 $ret = snmpget('localhost', 'public', 'IF-MIB::ifName.1');
 // stdClass Object
 // (
 //   [type] => 4        <-- SNMP_OCTET_STR, see constants
 //   [value] => lo
 // )

 snmp_set_valueretrieval(SNMP_VALUE_OBJECT | SNMP_VALUE_LIBRARY);
 $ret = snmpget('localhost', 'public', 'IF-MIB::ifName.1');
 // stdClass Object
 // (
 //   [type] => 4        <-- SNMP_OCTET_STR, see constants
 //   [value] => STRING: lo
 // )

?>

Sürüm Bilgisi

Sürüm: | Açıklama
5.4.0 | Constants SNMP_VALUE_PLAIN or SNMP_VALUE_LIBRARY may be combined with SNMP_VALUE_OBJECT resulting different way of representing contents of value array element in return value of GET-function. If no SNMP_VALUE_{PLAIN,LIBRARY} constant is accompanying SNMP_VALUE_OBJECT, SNMP_VALUE_LIBRARY is used. Prior to 5.4.0 SNMP_VALUE_OBJECT effecively meant SNMP_VALUE_OBJECT|SNMP_VALUE_PLAIN.

Ayrıca Bakınız

  • snmp_get_valueretrieval() - Return the method how the SNMP values will be returned
  • Öntanımlı Sabitler

snmp_set_quick_print
snmp2_get
SNMP İşlevleri


Fetch an SNMP object

snmp_set_valueretrieval
snmp2_getnext
SNMP İşlevleri
PHP Manual

snmp2_get

(PHP 5 >= 5.2.0, PHP 7)

snmp2_get — Fetch an SNMP object

Açıklama

string snmp2_get ( string $host , string $community , string $object_id [, string $timeout = 1000000 [, string $retries = 5 ]] )

The snmp2_get() function is used to read the value of an SNMP object specified by the object_id.

Değiştirgeler

host

The SNMP agent.

community

The read community.

object_id

The SNMP object.

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

Dönen Değerler

Returns SNMP object value on success or FALSE on error.

Örnekler

Örnek 1 Using snmp2_get()

<?php
$syscontact = snmp2_get("127.0.0.1", "public", "system.SysContact.0");
?>

Ayrıca Bakınız

  • snmp2_set() - Set the value of an SNMP object

snmp_set_valueretrieval
snmp2_getnext
SNMP İşlevleri


Fetch the SNMP object which follows the given object id

snmp2_get
snmp2_real_walk
SNMP İşlevleri
PHP Manual

snmp2_getnext

(PHP >= 5.2.0)

snmp2_getnext — Fetch the SNMP object which follows the given object id

Açıklama

string snmp2_getnext ( string $host , string $community , string $object_id [, string $timeout = 1000000 [, string $retries = 5 ]] )

The snmp2_get_next() function is used to read the value of the SNMP object that follows the specified object_id.

Değiştirgeler

host

The hostname of the SNMP agent (server).

community

The read community.

object_id

The SNMP object id which precedes the wanted one.

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

Dönen Değerler

Returns SNMP object value on success or FALSE on error. In case of an error, an E_WARNING message is shown.

Örnekler

Örnek 1 Using snmp2_get_next()

<?php
$nameOfSecondInterface = snmp2_get_next('localhost', 'public', 'IF-MIB::ifName.1';
?>

Ayrıca Bakınız

  • snmp2_get() - Fetch an SNMP object
  • snmp2_walk() - Fetch all the SNMP objects from an agent

snmp2_get
snmp2_real_walk
SNMP İşlevleri


Return all objects including their respective object ID within the specified one

snmp2_getnext
snmp2_set
SNMP İşlevleri
PHP Manual

snmp2_real_walk

(PHP >= 5.2.0)

snmp2_real_walk — Return all objects including their respective object ID within the specified one

Açıklama

array snmp2_real_walk ( string $host , string $community , string $object_id [, string $timeout = 1000000 [, string $retries = 5 ]] )

The snmp2_real_walk() function is used to traverse over a number of SNMP objects starting from object_id and return not only their values but also their object ids.

Değiştirgeler

host

The hostname of the SNMP agent (server).

community

The read community.

object_id

The SNMP object id which precedes the wanted one.

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

Dönen Değerler

Returns an associative array of the SNMP object ids and their values on success or FALSE on error. In case of an error, an E_WARNING message is shown.

Örnekler

Örnek 1 Using snmp2_real_walk()

<?php
 print_r(snmp2_real_walk("localhost", "public", "IF-MIB::ifName"));
?>

The above will output something like:

    Array
      (
      [IF-MIB::ifName.1] => STRING: lo
      [IF-MIB::ifName.2] => STRING: eth0
      [IF-MIB::ifName.3] => STRING: eth2
      [IF-MIB::ifName.4] => STRING: sit0
      [IF-MIB::ifName.5] => STRING: sixxs
    )

Ayrıca Bakınız

  • snmp2_walk() - Fetch all the SNMP objects from an agent

snmp2_getnext
snmp2_set
SNMP İşlevleri


Set the value of an SNMP object

snmp2_real_walk
snmp2_walk
SNMP İşlevleri
PHP Manual

snmp2_set

(PHP >= 5.2.0)

snmp2_set — Set the value of an SNMP object

Açıklama

bool snmp2_set ( string $host , string $community , string $object_id , string $type , string $value [, string $timeout = 1000000 [, string $retries = 5 ]] )

snmp2_set() is used to set the value of an SNMP object specified by the object_id.

Değiştirgeler

host

The hostname of the SNMP agent (server).

community

The write community.

object_id

The SNMP object id.

type

The MIB defines the type of each object id. It has to be specified as a single character from the below list.

types
= The type is taken from the MIB
i | INTEGER
u | INTEGER
s | STRING
x | HEX STRING
d | DECIMAL STRING
n | NULLOBJ
o | OBJID
t | TIMETICKS
a | IPADDRESS
b | BITS

If OPAQUE_SPECIAL_TYPES was defined while compiling the SNMP library, the following are also valid:

types
U | unsigned int64
I | signed int64
F | float
D | double

Most of these will use the obvious corresponding ASN.1 type. 's', 'x', 'd' and 'b' are all different ways of specifying an OCTET STRING value, and the 'u' unsigned type is also used for handling Gauge32 values.

If the MIB-Files are loaded by into the MIB Tree with "snmp_read_mib" or by specifying it in the libsnmp config, '=' may be used as the type parameter for all object ids as the type can then be automatically read from the MIB.

Note that there are two ways to set a variable of the type BITS like e.g. "SYNTAX BITS {telnet(0), ftp(1), http(2), icmp(3), snmp(4), ssh(5), https(6)}":

  • Using type "b" and a list of bit numbers. This method is not recommended since GET query for the same OID would return e.g. 0xF8.
  • Using type "x" and a hex number but without(!) the usual "0x" prefix.

See examples section for more details.

value

The new value.

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

If the SNMP host rejects the data type, an E_WARNING message like "Warning: Error in packet. Reason: (badValue) The value given has the wrong type or length." is shown. If an unknown or invalid OID is specified the warning probably reads "Could not add variable".

Örnekler

Örnek 1 Using snmp2_set()

<?php
  snmp2_set("localhost", "public", "IF-MIB::ifAlias.3", "s", "foo");
?>

Örnek 2 Using snmp2_set() for setting BITS SNMP object id

<?php
  snmp2_set("localhost", "public", 'FOO-MIB::bar.42', 'b', '0 1 2 3 4');
// or
  snmp2_set("localhost", "public", 'FOO-MIB::bar.42', 'x', 'F0');
?>

Ayrıca Bakınız

  • snmp2_get() - Fetch an SNMP object

snmp2_real_walk
snmp2_walk
SNMP İşlevleri


Fetch all the SNMP objects from an agent

snmp2_set
snmp3_get
SNMP İşlevleri
PHP Manual

snmp2_walk

(PHP >= 5.2.0)

snmp2_walk — Fetch all the SNMP objects from an agent

Açıklama

array snmp2_walk ( string $host , string $community , string $object_id [, string $timeout = 1000000 [, string $retries = 5 ]] )

snmp2_walk() function is used to read all the values from an SNMP agent specified by the hostname.

Değiştirgeler

host

The SNMP agent (server).

community

The read community.

object_id

If NULL, object_id is taken as the root of the SNMP objects tree and all objects under that tree are returned as an array.

If object_id is specified, all the SNMP objects below that object_id are returned.

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

Dönen Değerler

Returns an array of SNMP object values starting from the object_id as root or FALSE on error.

Örnekler

Örnek 1 snm2_pwalk() Example

<?php
$a = snmp2_walk("127.0.0.1", "public", "");

foreach ($a as $val) {
    echo "$val\n";
}

?>

Above function call would return all the SNMP objects from the SNMP agent running on localhost. One can step through the values with a loop

Ayrıca Bakınız

  • snmp2_real_walk() - Return all objects including their respective object ID within the specified one

snmp2_set
snmp3_get
SNMP İşlevleri


Fetch an SNMP object

snmp2_walk
snmp3_getnext
SNMP İşlevleri
PHP Manual

snmp3_get

(PHP 4, PHP 5, PHP 7)

snmp3_get — Fetch an SNMP object

Açıklama

string snmp3_get ( string $host , string $sec_name , string $sec_level , string $auth_protocol , string $auth_passphrase , string $priv_protocol , string $priv_passphrase , string $object_id [, string $timeout = 1000000 [, string $retries = 5 ]] )

The snmp3_get() function is used to read the value of an SNMP object specified by the object_id.

Değiştirgeler

host

The hostname of the SNMP agent (server).

sec_name

the security name, usually some kind of username

sec_level

the security level (noAuthNoPriv|authNoPriv|authPriv)

auth_protocol

the authentication protocol (MD5 or SHA)

auth_passphrase

the authentication pass phrase

priv_protocol

the privacy protocol (DES or AES)

priv_passphrase

the privacy pass phrase

object_id

The SNMP object id.

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

Dönen Değerler

Returns SNMP object value on success or FALSE on error.

Örnekler

Örnek 1 Using snmp3_get()

<?php
$nameOfSecondInterface = snmp3_get('localhost', 'james', 'authPriv', 'SHA', 'secret007', 'AES', 'secret007', 'IF-MIB::ifName.2');
?>

Ayrıca Bakınız

  • snmp3_set() - Set the value of an SNMP object

snmp2_walk
snmp3_getnext
SNMP İşlevleri


Fetch the SNMP object which follows the given object id

snmp3_get
snmp3_real_walk
SNMP İşlevleri
PHP Manual

snmp3_getnext

(PHP 5, PHP 7)

snmp3_getnext — Fetch the SNMP object which follows the given object id

Açıklama

string snmp3_getnext ( string $host , string $sec_name , string $sec_level , string $auth_protocol , string $auth_passphrase , string $priv_protocol , string $priv_passphrase , string $object_id [, string $timeout = 1000000 [, string $retries = 5 ]] )

The snmp3_getnext() function is used to read the value of the SNMP object that follows the specified object_id.

Değiştirgeler

host

The hostname of the SNMP agent (server).

sec_name

the security name, usually some kind of username

sec_level

the security level (noAuthNoPriv|authNoPriv|authPriv)

auth_protocol

the authentication protocol (MD5 or SHA)

auth_passphrase

the authentication pass phrase

priv_protocol

the privacy protocol (DES or AES)

priv_passphrase

the privacy pass phrase

object_id

The SNMP object id.

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

Dönen Değerler

Returns SNMP object value on success or FALSE on error. In case of an error, an E_WARNING message is shown.

Örnekler

Örnek 1 Using snmp3_getnext()

<?php
$nameOfSecondInterface = snmp3_getnext('localhost', 'james', 'authPriv', 'SHA', 'secret007', 'AES', 'secret007', 'IF-MIB::ifName.1');
?>

Ayrıca Bakınız

  • snmp3_get() - Fetch an SNMP object
  • snmp3_walk() - Fetch all the SNMP objects from an agent

snmp3_get
snmp3_real_walk
SNMP İşlevleri


Return all objects including their respective object ID within the specified one

snmp3_getnext
snmp3_set
SNMP İşlevleri
PHP Manual

snmp3_real_walk

(PHP 4, PHP 5, PHP 7)

snmp3_real_walk — Return all objects including their respective object ID within the specified one

Açıklama

array snmp3_real_walk ( string $host , string $sec_name , string $sec_level , string $auth_protocol , string $auth_passphrase , string $priv_protocol , string $priv_passphrase , string $object_id [, string $timeout = 1000000 [, string $retries = 5 ]] )

The snmp3_real_walk() function is used to traverse over a number of SNMP objects starting from object_id and return not only their values but also their object ids.

Değiştirgeler

host

The hostname of the SNMP agent (server).

sec_name

the security name, usually some kind of username

sec_level

the security level (noAuthNoPriv|authNoPriv|authPriv)

auth_protocol

the authentication protocol (MD5 or SHA)

auth_passphrase

the authentication pass phrase

priv_protocol

the privacy protocol (DES or AES)

priv_passphrase

the privacy pass phrase

object_id

The SNMP object id.

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

Dönen Değerler

Returns an associative array of the SNMP object ids and their values on success or FALSE on error. In case of an error, an E_WARNING message is shown.

Örnekler

Örnek 1 Using snmp3_real_walk()

<?php
 var_export(snmp3_real_walk('localhost', 'james', 'authPriv', 'SHA', 'secret007', 'AES', 'secret007', 'IF-MIB::ifName'));
?>

The above will output something like:

array (
  'IF-MIB::ifName.1' => 'STRING: lo',
  'IF-MIB::ifName.2' => 'STRING: eth0',
  'IF-MIB::ifName.3' => 'STRING: eth2',
  'IF-MIB::ifName.4' => 'STRING: sit0',
  'IF-MIB::ifName.5' => 'STRING: sixxs',
)

Ayrıca Bakınız

  • snmpwalk() - Fetch all the SNMP objects from an agent

snmp3_getnext
snmp3_set
SNMP İşlevleri


Set the value of an SNMP object

snmp3_real_walk
snmp3_walk
SNMP İşlevleri
PHP Manual

snmp3_set

(PHP 4, PHP 5, PHP 7)

snmp3_set — Set the value of an SNMP object

Açıklama

bool snmp3_set ( string $host , string $sec_name , string $sec_level , string $auth_protocol , string $auth_passphrase , string $priv_protocol , string $priv_passphrase , string $object_id , string $type , string $value [, int $timeout = 1000000 [, int $retries = 5 ]] )

snmp3_set() is used to set the value of an SNMP object specified by the object_id.

Even if the security level does not use an auth or priv protocol/password valid values have to be specified.

Değiştirgeler

host

The hostname of the SNMP agent (server).

sec_name

the security name, usually some kind of username

sec_level

the security level (noAuthNoPriv|authNoPriv|authPriv)

auth_protocol

the authentication protocol (MD5 or SHA)

auth_passphrase

the authentication pass phrase

priv_protocol

the privacy protocol (DES or AES)

priv_passphrase

the privacy pass phrase

object_id

The SNMP object id.

type

The MIB defines the type of each object id. It has to be specified as a single character from the below list.

types
= The type is taken from the MIB
i | INTEGER
u | INTEGER
s | STRING
x | HEX STRING
d | DECIMAL STRING
n | NULLOBJ
o | OBJID
t | TIMETICKS
a | IPADDRESS
b | BITS

If OPAQUE_SPECIAL_TYPES was defined while compiling the SNMP library, the following are also valid:

types
U | unsigned int64
I | signed int64
F | float
D | double

Most of these will use the obvious corresponding ASN.1 type. 's', 'x', 'd' and 'b' are all different ways of specifying an OCTET STRING value, and the 'u' unsigned type is also used for handling Gauge32 values.

If the MIB-Files are loaded by into the MIB Tree with "snmp_read_mib" or by specifying it in the libsnmp config, '=' may be used as the type parameter for all object ids as the type can then be automatically read from the MIB.

Note that there are two ways to set a variable of the type BITS like e.g. "SYNTAX BITS {telnet(0), ftp(1), http(2), icmp(3), snmp(4), ssh(5), https(6)}":

  • Using type "b" and a list of bit numbers. This method is not recommended since GET query for the same OID would return e.g. 0xF8.
  • Using type "x" and a hex number but without(!) the usual "0x" prefix.

See examples section for more details.

value

The new value

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

If the SNMP host rejects the data type, an E_WARNING message like "Warning: Error in packet. Reason: (badValue) The value given has the wrong type or length." is shown. If an unknown or invalid OID is specified the warning probably reads "Could not add variable".

Örnekler

Örnek 1 Using snmp3_set()

<?php
  snmp3_set('localhost', 'james', 'authPriv', 'SHA', 'secret007', 'AES', 'secret007', 'IF-MIB::ifAlias.3', 's', "foo");
?>

Örnek 2 Using snmp3_set() for setting BITS SNMP object id

<?php
  snmp3_set('localhost', 'james', 'authPriv', 'SHA', 'secret007', 'AES', 'secret007', 'FOO-MIB::bar.42', 'b', '0 1 2 3 4');
// or
  snmp3_set('localhost', 'james', 'authPriv', 'SHA', 'secret007', 'AES', 'secret007', 'FOO-MIB::bar.42', 'x', 'F0');
?>
snmp3_real_walk
snmp3_walk
SNMP İşlevleri


Fetch all the SNMP objects from an agent

snmp3_set
snmpget
SNMP İşlevleri
PHP Manual

snmp3_walk

(PHP 4, PHP 5, PHP 7)

snmp3_walk — Fetch all the SNMP objects from an agent

Açıklama

array snmp3_walk ( string $host , string $sec_name , string $sec_level , string $auth_protocol , string $auth_passphrase , string $priv_protocol , string $priv_passphrase , string $object_id [, string $timeout = 1000000 [, string $retries = 5 ]] )

snmp3_walk() function is used to read all the values from an SNMP agent specified by the hostname.

Even if the security level does not use an auth or priv protocol/password valid values have to be specified.

Değiştirgeler

host

The hostname of the SNMP agent (server).

sec_name

the security name, usually some kind of username

sec_level

the security level (noAuthNoPriv|authNoPriv|authPriv)

auth_protocol

the authentication protocol (MD5 or SHA)

auth_passphrase

the authentication pass phrase

priv_protocol

the privacy protocol (DES or AES)

priv_passphrase

the privacy pass phrase

object_id

If NULL, object_id is taken as the root of the SNMP objects tree and all objects under that tree are returned as an array.

If object_id is specified, all the SNMP objects below that object_id are returned.

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

Dönen Değerler

Returns an array of SNMP object values starting from the object_id as root or FALSE on error.

Örnekler

Örnek 1 snmp3_walk() Example

<?php
$ret = snmp3_walk('localhost', 'james', 'authPriv', 'SHA', 'secret007', 'AES', 'secret007', 'IF-MIB::ifName');
var_export($ret);
?>

Above function call would return all the SNMP objects from the SNMP agent running on localhost:

array (
  0 => 'STRING: lo',
  1 => 'STRING: eth0',
  2 => 'STRING: eth2',
  3 => 'STRING: sit0',
  4 => 'STRING: sixxs',
)

Ayrıca Bakınız

  • snmp3_real_walk() - Return all objects including their respective object ID within the specified one

snmp3_set
snmpget
SNMP İşlevleri


Fetch an SNMP object

snmp3_walk
snmpgetnext
SNMP İşlevleri
PHP Manual

snmpget

(PHP 4, PHP 5, PHP 7)

snmpget — Fetch an SNMP object

Açıklama

string snmpget ( string $hostname , string $community , string $object_id [, int $timeout = 1000000 [, int $retries = 5 ]] )

The snmpget() function is used to read the value of an SNMP object specified by the object_id.

Değiştirgeler

hostname

The SNMP agent.

community

The read community.

object_id

The SNMP object.

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

Dönen Değerler

Returns SNMP object value on success or FALSE on error.

Örnekler

Örnek 1 Using snmpget()

<?php
$syscontact = snmpget("127.0.0.1", "public", "system.SysContact.0");
?>

Ayrıca Bakınız

  • snmpset() - Set the value of an SNMP object

snmp3_walk
snmpgetnext
SNMP İşlevleri


Fetch the SNMP object which follows the given object id

snmpget
snmprealwalk
SNMP İşlevleri
PHP Manual

snmpgetnext

(PHP 5, PHP 7)

snmpgetnext — Fetch the SNMP object which follows the given object id

Açıklama

string snmpgetnext ( string $host , string $community , string $object_id [, int $timeout = 1000000 [, int $retries = 5 ]] )

The snmpgetnext() function is used to read the value of the SNMP object that follows the specified object_id.

Değiştirgeler

host

The hostname of the SNMP agent (server).

community

The read community.

object_id

The SNMP object id which precedes the wanted one.

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

Dönen Değerler

Returns SNMP object value on success or FALSE on error. In case of an error, an E_WARNING message is shown.

Örnekler

Örnek 1 Using snmpgetnext()

<?php
$nameOfSecondInterface = snmpgetnetxt('localhost', 'public', 'IF-MIB::ifName.1';
?>

Ayrıca Bakınız

  • snmpget() - Fetch an SNMP object
  • snmpwalk() - Fetch all the SNMP objects from an agent

snmpget
snmprealwalk
SNMP İşlevleri


Return all objects including their respective object ID within the specified one

snmpgetnext
snmpset
SNMP İşlevleri
PHP Manual

snmprealwalk

(PHP 4, PHP 5, PHP 7)

snmprealwalk — Return all objects including their respective object ID within the specified one

Açıklama

array snmprealwalk ( string $host , string $community , string $object_id [, int $timeout = 1000000 [, int $retries = 5 ]] )

The snmprealwalk() function is used to traverse over a number of SNMP objects starting from object_id and return not only their values but also their object ids.

Değiştirgeler

host

The hostname of the SNMP agent (server).

community

The read community.

object_id

The SNMP object id which precedes the wanted one.

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

Dönen Değerler

Returns an associative array of the SNMP object ids and their values on success or FALSE on error. In case of an error, an E_WARNING message is shown.

Örnekler

Örnek 1 Using snmprealwalk()

<?php
 print_r(snmprealwalk("localhost", "public", "IF-MIB::ifName"));
?>

The above will output something like:

    Array
      (
      [IF-MIB::ifName.1] => STRING: lo
      [IF-MIB::ifName.2] => STRING: eth0
      [IF-MIB::ifName.3] => STRING: eth2
      [IF-MIB::ifName.4] => STRING: sit0
      [IF-MIB::ifName.5] => STRING: sixxs
    )

Ayrıca Bakınız

  • snmpwalk() - Fetch all the SNMP objects from an agent

snmpgetnext
snmpset
SNMP İşlevleri


Set the value of an SNMP object

snmprealwalk
snmpwalk
SNMP İşlevleri
PHP Manual

snmpset

(PHP 4, PHP 5, PHP 7)

snmpset — Set the value of an SNMP object

Açıklama

bool snmpset ( string $host , string $community , string $object_id , string $type , mixed $value [, int $timeout = 1000000 [, int $retries = 5 ]] )

snmpset() is used to set the value of an SNMP object specified by the object_id.

Değiştirgeler

host

The hostname of the SNMP agent (server).

community

The write community.

object_id

The SNMP object id.

type

The MIB defines the type of each object id. It has to be specified as a single character from the below list.

types
= The type is taken from the MIB
i | INTEGER
u | INTEGER
s | STRING
x | HEX STRING
d | DECIMAL STRING
n | NULLOBJ
o | OBJID
t | TIMETICKS
a | IPADDRESS
b | BITS

If OPAQUE_SPECIAL_TYPES was defined while compiling the SNMP library, the following are also valid:

types
U | unsigned int64
I | signed int64
F | float
D | double

Most of these will use the obvious corresponding ASN.1 type. 's', 'x', 'd' and 'b' are all different ways of specifying an OCTET STRING value, and the 'u' unsigned type is also used for handling Gauge32 values.

If the MIB-Files are loaded by into the MIB Tree with "snmp_read_mib" or by specifying it in the libsnmp config, '=' may be used as the type parameter for all object ids as the type can then be automatically read from the MIB.

Note that there are two ways to set a variable of the type BITS like e.g. "SYNTAX BITS {telnet(0), ftp(1), http(2), icmp(3), snmp(4), ssh(5), https(6)}":

  • Using type "b" and a list of bit numbers. This method is not recommended since GET query for the same OID would return e.g. 0xF8.
  • Using type "x" and a hex number but without(!) the usual "0x" prefix.

See examples section for more details.

value

The new value.

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

If the SNMP host rejects the data type, an E_WARNING message like "Warning: Error in packet. Reason: (badValue) The value given has the wrong type or length." is shown. If an unknown or invalid OID is specified the warning probably reads "Could not add variable".

Örnekler

Örnek 1 Using snmpset()

<?php
  snmpset("localhost", "public", "IF-MIB::ifAlias.3", "s", "foo");
?>

Örnek 2 Using snmpset() for setting BITS SNMP object id

<?php
  snmpset("localhost", "public", 'FOO-MIB::bar.42', 'b', '0 1 2 3 4');
// or
  snmpset("localhost", "public", 'FOO-MIB::bar.42', 'x', 'F0');
?>

Ayrıca Bakınız

  • snmpget() - Fetch an SNMP object

snmprealwalk
snmpwalk
SNMP İşlevleri


Fetch all the SNMP objects from an agent

snmpset
snmpwalkoid
SNMP İşlevleri
PHP Manual

snmpwalk

(PHP 4, PHP 5, PHP 7)

snmpwalk — Fetch all the SNMP objects from an agent

Açıklama

array snmpwalk ( string $hostname , string $community , string $object_id [, int $timeout = 1000000 [, int $retries = 5 ]] )

snmpwalk() function is used to read all the values from an SNMP agent specified by the hostname.

Değiştirgeler

hostname

The SNMP agent (server).

community

The read community.

object_id

If NULL, object_id is taken as the root of the SNMP objects tree and all objects under that tree are returned as an array.

If object_id is specified, all the SNMP objects below that object_id are returned.

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

Dönen Değerler

Returns an array of SNMP object values starting from the object_id as root or FALSE on error.

Örnekler

Örnek 1 snmpwalk() Example

<?php
$a = snmpwalk("127.0.0.1", "public", "");

foreach ($a as $val) {
    echo "$val\n";
}

?>

Above function call would return all the SNMP objects from the SNMP agent running on localhost. One can step through the values with a loop

Ayrıca Bakınız

  • snmprealwalk() - Return all objects including their respective object ID within the specified one

snmpset
snmpwalkoid
SNMP İşlevleri


Query for a tree of information about a network entity

snmpwalk
SNMP
SNMP İşlevleri
PHP Manual

snmpwalkoid

(PHP 4, PHP 5, PHP 7)

snmpwalkoid — Query for a tree of information about a network entity

Açıklama

array snmpwalkoid ( string $hostname , string $community , string $object_id [, int $timeout = 1000000 [, int $retries = 5 ]] )

snmpwalkoid() function is used to read all object ids and their respective values from an SNMP agent specified by hostname.

The existence of snmpwalkoid() and snmpwalk() has historical reasons. Both functions are provided for backward compatibility. Use snmprealwalk() instead.

Değiştirgeler

hostname

The SNMP agent.

community

The read community.

object_id

If NULL, object_id is taken as the root of the SNMP objects tree and all objects under that tree are returned as an array.

If object_id is specified, all the SNMP objects below that object_id are returned.

timeout

The number of microseconds until the first timeout.

retries

The number of times to retry if timeouts occur.

Dönen Değerler

Returns an associative array with object ids and their respective object value starting from the object_id as root or FALSE on error.

Örnekler

Örnek 1 snmpwalkoid() Example

<?php
$a = snmpwalkoid("127.0.0.1", "public", "");
for (reset($a); $i = key($a); next($a)) {
    echo "$i: $a[$i]<br />\n";
}
?>

Above function call would return all the SNMP objects from the SNMP agent running on localhost. One can step through the values with a loop

Ayrıca Bakınız

  • snmpwalk() - Fetch all the SNMP objects from an agent

snmpwalk
SNMP
SNMP İşlevleri


The SNMP class

(PHP 5 >= 5.4.0, PHP 7)

Giriş

Represents SNMP session.

Sınıf Sözdizimi

SNMP {
/* Özellikler */
public int $max_oids ;
public int $valueretrieval ;
public bool $quick_print ;
public bool $enum_print ;
public int $oid_output_format ;
public bool $oid_increasing_check ;
public int $exceptions_enabled ;
public array $info ;
/* Yöntemler */
public __construct ( int $version , string $hostname , string $community [, int $timeout = 1000000 [, int $retries = 5 ]] )
public bool close ( void )
public mixed get ( mixed $object_id [, bool $preserve_keys = false ] )
public int getErrno ( void )
public string getError ( void )
public mixed getnext ( mixed $object_id )
public bool set ( mixed $object_id , mixed $type , mixed $value )
public bool setSecurity ( string $sec_level [, string $auth_protocol = [, string $auth_passphrase = [, string $priv_protocol = [, string $priv_passphrase = [, string $contextName = [, string $contextEngineID = ]]]]]] )
public array walk ( string $object_id [, bool $suffix_as_key = FALSE [, int $max_repetitions [, int $non_repeaters ]]] )
/* Sabitler */
const integer ERRNO_NOERROR = 0 ;
const integer ERRNO_GENERIC = 2 ;
const integer ERRNO_TIMEOUT = 4 ;
const integer ERRNO_ERROR_IN_REPLY = 8 ;
const integer ERRNO_OID_NOT_INCREASING = 16 ;
const integer ERRNO_OID_PARSING_ERROR = 32 ;
const integer ERRNO_MULTIPLE_SET_QUERIES = 64 ;
const integer ERRNO_ANY = 126 ;
const integer VERSION_1 = 0 ;
const integer VERSION_2C = 1 ;
const integer VERSION_2c = 1 ;
const integer VERSION_3 = 3 ;
}

Özellikler

max_oids

Maximum OID per GET/SET/GETBULK request

valueretrieval

Controls the method how the SNMP values will be returned

SNMP_VALUE_LIBRARY | The return values will be as returned by the Net-SNMP library.
SNMP_VALUE_PLAIN | The return values will be the plain value without the SNMP type hint.
SNMP_VALUE_OBJECT | The return values will be objects with the properties "value" and "type", where the latter is one of the SNMP_OCTET_STR, SNMP_COUNTER etc. constants. The way "value" is returned is based on which one of SNMP_VALUE_LIBRARY, SNMP_VALUE_PLAIN is set
quick_print

Value of quick_print within the NET-SNMP library

Sets the value of quick_print within the NET-SNMP library. When this is set (1), the SNMP library will return 'quick printed' values. This means that just the value will be printed. When quick_print is not enabled (default) the UCD SNMP library prints extra information including the type of the value (i.e. IpAddress or OID). Additionally, if quick_print is not enabled, the library prints additional hex values for all strings of three characters or less.

enum_print

Controls the way enum values are printed

Parameter toggles if walk/get etc. should automatically lookup enum values in the MIB and return them together with their human readable string.

oid_output_format

Controls OID output format

OID .1.3.6.1.2.1.1.3.0 representation for various oid_output_format values
SNMP_OID_OUTPUT_FULL | .iso.org.dod.internet.mgmt.mib-2.system.sysUpTime.sysUpTimeInstance
SNMP_OID_OUTPUT_NUMERIC | .1.3.6.1.2.1.1.3.0
SNMP_OID_OUTPUT_MODULE | DISMAN-EVENT-MIB::sysUpTimeInstance
SNMP_OID_OUTPUT_SUFFIX | sysUpTimeInstance
SNMP_OID_OUTPUT_UCD | system.sysUpTime.sysUpTimeInstance
SNMP_OID_OUTPUT_NONE | Undefined
oid_increasing_check

Controls disabling check for increasing OID while walking OID tree

Some SNMP agents are known for returning OIDs out of order but can complete the walk anyway. Other agents return OIDs that are out of order and can cause SNMP::walk() to loop indefinitely until memory limit will be reached. PHP SNMP library by default performs OID increasing check and stops walking on OID tree when it detects possible loop with issuing warning about non-increasing OID faced. Set oid_increasing_check to FALSE to disable this check.

exceptions_enabled

Controls which failures will raise SNMPException instead of warning. Use bitwise OR'ed SNMP::ERRNO_* constants. By default all SNMP exceptions are disabled.

info

Read-only property with remote agent configuration: hostname, port, default timeout, default retries count

Öntanımlı Sabitler

SNMP Error Types

SNMP::ERRNO_NOERROR

No SNMP-specific error occurred.

SNMP::ERRNO_GENERIC

A generic SNMP error occurred.

SNMP::ERRNO_TIMEOUT

Request to SNMP agent timed out.

SNMP::ERRNO_ERROR_IN_REPLY

SNMP agent returned an error in reply.

SNMP::ERRNO_OID_NOT_INCREASING

SNMP agent faced OID cycling reporning non-increasing OID while executing (BULK)WALK command. This indicates bogus remote SNMP agent.

SNMP::ERRNO_OID_PARSING_ERROR

Library failed while parsing OID (and/or type for SET command). No queries has been made.

SNMP::ERRNO_MULTIPLE_SET_QUERIES

Library will use multiple queries for SET operation requested. That means that operation will be performed in a non-transaction manner and second or subsequent chunks may fail if a type or value failure will be faced.

SNMP::ERRNO_ANY

All SNMP::ERRNO_* codes bitwise OR'ed.

SNMP Protocol Versions

SNMP::VERSION_1

SNMP::VERSION_2C, SNMP::VERSION_2c

SNMP::VERSION_3

İçindekiler

  • SNMP::close — Close SNMP session
  • SNMP::__construct — Creates SNMP instance representing session to remote SNMP agent
  • SNMP::get — Fetch an SNMP object
  • SNMP::getErrno — Get last error code
  • SNMP::getError — Get last error message
  • SNMP::getnext — Fetch an SNMP object which follows the given object id
  • SNMP::set — Set the value of an SNMP object
  • SNMP::setSecurity — Configures security-related SNMPv3 session parameters
  • SNMP::walk — Fetch SNMP object subtree
snmpwalkoid
SNMP::close
SNMP


Close SNMP session

SNMP
SNMP::__construct
SNMP
PHP Manual

SNMP::close

(PHP 5 >= 5.4.0, PHP 7)

SNMP::close — Close SNMP session

Açıklama

public bool SNMP::close ( void )

Frees previously allocated SNMP session object.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 SNMP::close() example

<?php
  $session = new SNMP(SNMP::VERSION_1, "127.0.0.1", "public");
  # ...
  # get, walk, etc goes here
  # ...
  $session->close();
?>

Ayrıca Bakınız

  • SNMP::__construct() - Creates SNMP instance representing session to remote SNMP agent
SNMP
SNMP::__construct
SNMP


Creates SNMP instance representing session to remote SNMP agent

SNMP::close
SNMP::get
SNMP
PHP Manual

SNMP::__construct

(PHP 5 >= 5.4.0, PHP 7)

SNMP::__construct — Creates SNMP instance representing session to remote SNMP agent

Açıklama

public SNMP::__construct ( int $version , string $hostname , string $community [, int $timeout = 1000000 [, int $retries = 5 ]] )

The function description goes here.

Değiştirgeler

version

SNMP protocol version:
SNMP::VERSION_1,
SNMP::VERSION_2C,
SNMP::VERSION_3.

hostname

The SNMP agent. hostname may be suffixed with optional SNMP agent port after colon. IPv6 addresses must be enclosed in square brackets if used with port. If FQDN is used for hostname it will be resolved by php-snmp library, not by Net-SNMP engine. Usage of IPv6 addresses when specifying FQDN may be forced by enclosing FQDN into square brackets. Here it is some examples:

IPv4 with default port | 127.0.0.1
IPv6 with default port | ::1 or [::1]
IPv4 with specific port | 127.0.0.1:1161
IPv6 with specific port | [::1]:1161
FQDN with default port | host.domain
FQDN with specific port | host.domain:1161
FQDN with default port, force usage of IPv6 address | [host.domain]
FQDN with specific port, force usage of IPv6 address | [host.domain]:1161

community

The purpuse of community is SNMP version specific:

SNMP::VERSION_1 | SNMP community
SNMP::VERSION_2C | SNMP community
SNMP::VERSION_3 | SNMPv3 securityName
timeout

The number of microseconds until the first timeout.

retries

The number of retries in case timeout occurs.

Dönen Değerler

Returns SNMP object representing remote SNMP agent.

Hatalar/İstisnalar

SNMP::__construct() throws an exception when parameters count or types are wrong or unknown SNMP protocol version specified.

Örnekler

Örnek 1 Fetching sysLocation

<?php
  $session = new SNMP(SNMP::VERSION_1, "127.0.0.1", "public");
  $sysdescr = $session->get("sysDescr.0");
  echo "$sysdescr\n";
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

STRING: Test server

Ayrıca Bakınız

  • SNMP::close() - Close SNMP session
SNMP::close
SNMP::get
SNMP


Fetch an SNMP object

SNMP::__construct
SNMP::getErrno
SNMP
PHP Manual

SNMP::get

(PHP 5 >= 5.4.0, PHP 7)

SNMP::get — Fetch an SNMP object

Açıklama

public mixed SNMP::get ( mixed $object_id [, bool $preserve_keys = false ] )

Fetch an SNMP object specified in object_id using GET query.

Değiştirgeler

If object_id is a string, then SNMP::get() will return SNMP object as string. If object_id is a array, all requested SNMP objects will be returned as associative array of the SNMP object ids and their values.

object_id

The SNMP object (OID) or objects

preserve_keys

When object_id is a array and preserve_keys set to TRUE keys in results will be taken exactly as in object_id, otherwise SNMP::oid_output_format property is used to determinate the form of keys.

Dönen Değerler

Returns SNMP objects requested as string or array depending on object_id type or FALSE on error.

Hatalar/İstisnalar

This method do not throw any exceptions by default. To enable throwing an SNMPException exception when some of library errors occure user should set exceptions_enabled SNMP class parameter to corresponding value. See SNMP::$exceptions_enabled explanation for more details.

Örnekler

Örnek 1 Single SNMP object

Single SNMP object may be requested in two ways: as string resulting string return value or as single-element array with associative array as output.

<?php
  $session = new SNMP(SNMP::VERSION_1, "127.0.0.1", "public");
  $sysdescr = $session->get("sysDescr.0");
  echo "$sysdescr\n";
  $sysdescr = $session->get(array("sysDescr.0"));
  print_r($sysdescr);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

STRING: Test server
Array
(
    [SNMPv2-MIB::sysDescr.0] => STRING: Test server
)

Örnek 2 Multiple SNMP objects

$session = new SNMP(SNMP::VERSION_1, "127.0.0.1", "public");
  $results = $session->get(array("sysDescr.0", "sysName.0"));
  print_r($results);
  $session->close();

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [SNMPv2-MIB::sysDescr.0] => STRING: Test server
    [SNMPv2-MIB::sysName.0] => STRING: myhost.nodomain
)

Ayrıca Bakınız

  • SNMP::getErrno() - Get last error code
  • SNMP::getError() - Get last error message
SNMP::__construct
SNMP::getErrno
SNMP


Get last error code

SNMP::get
SNMP::getError
SNMP
PHP Manual

SNMP::getErrno

(PHP 5 >= 5.4.0, PHP 7)

SNMP::getErrno — Get last error code

Açıklama

public int SNMP::getErrno ( void )

Returns error code from last SNMP request.

Dönen Değerler

Returns one of SNMP error code values described in constants chapter.

Örnekler

Örnek 1 SNMP::getErrno() example

<?php
$session = new SNMP(SNMP::VERSION_2c, '127.0.0.1', 'boguscommunity');
var_dump(@$session->get('.1.3.6.1.2.1.1.1.0'));
var_dump($session->getErrno() == SNMP::ERRNO_TIMEOUT);
?>

Yukarıdaki örneğin çıktısı:

bool(false)
bool(true)

Ayrıca Bakınız

  • SNMP::getError() - Get last error message
SNMP::get
SNMP::getError
SNMP


Get last error message

SNMP::getErrno
SNMP::getnext
SNMP
PHP Manual

SNMP::getError

(PHP 5 >= 5.4.0, PHP 7)

SNMP::getError — Get last error message

Açıklama

public string SNMP::getError ( void )

Returns string with error from last SNMP request.

Dönen Değerler

String describing error from last SNMP request.

Örnekler

Örnek 1 SNMP::getError() example

<?php
$session = new SNMP(SNMP::VERSION_2c, '127.0.0.1', 'boguscommunity');
var_dump(@$session->get('.1.3.6.1.2.1.1.1.0'));
var_dump($session->getError());
?>

Yukarıdaki örneğin çıktısı:

bool(false)
string(26) "No response from 127.0.0.1"

Ayrıca Bakınız

  • SNMP::getErrno() - Get last error code
SNMP::getErrno
SNMP::getnext
SNMP


Fetch an SNMP object which follows the given object id

SNMP::getError
SNMP::set
SNMP
PHP Manual

SNMP::getnext

(PHP 5 >= 5.4.0, PHP 7)

SNMP::getnext — Fetch an SNMP object which follows the given object id

Açıklama

public mixed SNMP::getnext ( mixed $object_id )

Fetch an SNMP object that follows specified object_id.

Değiştirgeler

If object_id is a string, then SNMP::getnext() will return SNMP object as string. If object_id is a array, all requested SNMP objects will be returned as associative array of the SNMP object ids and their values.

object_id

The SNMP object (OID) or objects

Dönen Değerler

Returns SNMP objects requested as string or array depending on object_id type or FALSE on error.

Hatalar/İstisnalar

This method do not throw any exceptions by default. To enable throwing an SNMPException exception when some of library errors occure user should set exceptions_enabled SNMP class parameter to corresponding value. See SNMP::$exceptions_enabled explanation for more details.

Örnekler

Örnek 1 Single SNMP object

Single SNMP object may be requested in two ways: as string resulting string return value or as single-element array with associative array as output.

<?php
  $session = new SNMP(SNMP::VERSION_1, "127.0.0.1", "public");
  $nsysdescr = $session->getnext("sysDescr.0");
  echo "$nsysdescr\n";
  $nsysdescr = $session->getnext(array("sysDescr.0"));
  print_r($nsysdescr);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

OID: NET-SNMP-MIB::netSnmpAgentOIDs.8
Array
(
    [SNMPv2-MIB::sysObjectID.0] => OID: NET-SNMP-MIB::netSnmpAgentOIDs.8
)

Örnek 2 Miltiple SNMP objects

<?php
  $session = new SNMP(SNMP::VERSION_1, "127.0.0.1", "public");
  $results = $session->getnext(array("sysDescr.0", "sysName.0"));
  print_r($results);
  $session->close();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [SNMPv2-MIB::sysObjectID.0] => OID: NET-SNMP-MIB::netSnmpAgentOIDs.8
    [SNMPv2-MIB::sysLocation.0] => STRING: Nowhere
)

Ayrıca Bakınız

  • SNMP::getErrno() - Get last error code
  • SNMP::getError() - Get last error message
SNMP::getError
SNMP::set
SNMP


Set the value of an SNMP object

SNMP::getnext
SNMP::setSecurity
SNMP
PHP Manual

SNMP::set

(PHP 5 >= 5.4.0, PHP 7)

SNMP::set — Set the value of an SNMP object

Açıklama

public bool SNMP::set ( mixed $object_id , mixed $type , mixed $value )

Requests remote SNMP agent setting the value of one or more SNMP objects specified by the object_id.

Değiştirgeler

If object_id is string, both type and value must be string too. If object_id is array value must be equal-sized array containing corresponding values, type may be either string (it's value will be used for all object_id-value pairs) or equal-sized array with per-OID value. When any other parameters' combinations are used, a number of E_WARNING messages may be shown with detailed description.

object_id

The SNMP object id

When count of OIDs in object_id array is greater than max_oids object property set method will have to use multiple queries to perform requested value updates. In this case type and value checks are made per-chunk so second or subsequent requests may fail due to wrong type or value for OID requested. To mark this a warning is raised when count of OIDs in object_id array is greater than max_oids.

type

The MIB defines the type of each object id. It has to be specified as a single character from the below list.

types
= The type is taken from the MIB
i | INTEGER
u | INTEGER
s | STRING
x | HEX STRING
d | DECIMAL STRING
n | NULLOBJ
o | OBJID
t | TIMETICKS
a | IPADDRESS
b | BITS

If OPAQUE_SPECIAL_TYPES was defined while compiling the SNMP library, the following are also valid:

types
U | unsigned int64
I | signed int64
F | float
D | double

Most of these will use the obvious corresponding ASN.1 type. 's', 'x', 'd' and 'b' are all different ways of specifying an OCTET STRING value, and the 'u' unsigned type is also used for handling Gauge32 values.

If the MIB-Files are loaded by into the MIB Tree with "snmp_read_mib" or by specifying it in the libsnmp config, '=' may be used as the type parameter for all object ids as the type can then be automatically read from the MIB.

Note that there are two ways to set a variable of the type BITS like e.g. "SYNTAX BITS {telnet(0), ftp(1), http(2), icmp(3), snmp(4), ssh(5), https(6)}":

  • Using type "b" and a list of bit numbers. This method is not recommended since GET query for the same OID would return e.g. 0xF8.
  • Using type "x" and a hex number but without(!) the usual "0x" prefix.

See examples section for more details.

value

The new value.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

This method do not throw any exceptions by default. To enable throwing an SNMPException exception when some of library errors occure user should set exceptions_enabled SNMP class parameter to corresponding value. See SNMP::$exceptions_enabled explanation for more details.

Örnekler

Örnek 1 Set single SNMP object id

<?php
  $session = new SNMP(SNMP::VERSION_2C, "127.0.0.1", "private");
  $session->set('SNMPv2-MIB::sysContact.0', 's', "Nobody");
?>

Örnek 2 Set multiple values using single SNMP::set() call

<?php
  $session = new SNMP(SNMP::VERSION_2C, "127.0.0.1", "private");
  $session->set(array('SNMPv2-MIB::sysContact.0', 'SNMPv2-MIB::sysLocation.0'), array('s', 's'), array("Nobody", "Nowhere"));
// or
  $session->set(array('SNMPv2-MIB::sysContact.0', 'SNMPv2-MIB::sysLocation.0'), 's', array("Nobody", "Nowhere"));
?>

Örnek 3 Using SNMP::set() for setting BITS SNMP object id

<?php
  $session = new SNMP(SNMP::VERSION_2C, "127.0.0.1", "private");
  $session->set('FOO-MIB::bar.42', 'b', '0 1 2 3 4');
// or
  $session->set('FOO-MIB::bar.42', 'x', 'F0');
?>

Ayrıca Bakınız

  • SNMP::get() - Fetch an SNMP object

SNMP::getnext
SNMP::setSecurity
SNMP


Configures security-related SNMPv3 session parameters

SNMP::set
SNMP::walk
SNMP
PHP Manual

SNMP::setSecurity

(PHP 5 >= 5.4.0, PHP 7)

SNMP::setSecurity — Configures security-related SNMPv3 session parameters

Açıklama

public bool SNMP::setSecurity ( string $sec_level [, string $auth_protocol = [, string $auth_passphrase = [, string $priv_protocol = [, string $priv_passphrase = [, string $contextName = [, string $contextEngineID = ]]]]]] )

setSecurity configures security-related session parameters used in SNMP protocol version 3

Değiştirgeler

sec_level

the security level (noAuthNoPriv|authNoPriv|authPriv)

auth_protocol

the authentication protocol (MD5 or SHA)

auth_passphrase

the authentication pass phrase

priv_protocol

the privacy protocol (DES or AES)

priv_passphrase

the privacy pass phrase

contextName

the context name

contextEngineID

the context EngineID

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 SNMP::setSecurity() example

<?php
  $session = new SNMP(SNMP::VERSION_3, $hostname, $rwuser, $timeout, $retries);
  $session->setSecurity('authPriv', 'MD5', $auth_pass, 'AES', $priv_pass, '', 'aeeeff');
?>

Ayrıca Bakınız

  • SNMP::__construct() - Creates SNMP instance representing session to remote SNMP agent
SNMP::set
SNMP::walk
SNMP


Fetch SNMP object subtree

SNMP::setSecurity
SNMPException
SNMP
PHP Manual

SNMP::walk

(PHP 5 >= 5.4.0, PHP 7)

SNMP::walk — Fetch SNMP object subtree

Açıklama

public array SNMP::walk ( string $object_id [, bool $suffix_as_key = FALSE [, int $max_repetitions [, int $non_repeaters ]]] )

SNMP::walk() is used to read SNMP subtree rooted at specified object_id.

Değiştirgeler

object_id

Root of subtree to be fetched

suffix_as_key

By default full OID notation is used for keys in output array. If set to TRUE subtree prefix will be removed from keys leaving only suffix of object_id.

non_repeaters

This specifies the number of supplied variables that should not be iterated over. The default is to use this value from SNMP object.

max_repetitions

This specifies the maximum number of iterations over the repeating variables. The default is to use this value from SNMP object.

Dönen Değerler

Returns an associative array of the SNMP object ids and their values on success or FALSE on error. When a SNMP error occures SNMP::getErrno() and SNMP::getError() can be used for retrieving error number (specific to SNMP extension, see class constants) and error message respectively.

Hatalar/İstisnalar

This method do not throw any exceptions by default. To enable throwing an SNMPException exception when some of library errors occure user should set exceptions_enabled SNMP class parameter to corresponding value. See SNMP::$exceptions_enabled explanation for more details.

Örnekler

Örnek 1 SNMP::walk() example

<?php
  $session = new SNMP(SNMP::VERSION_1, "127.0.0.1", "public");
  $fulltree = $session->walk(".");
  print_r($fulltree);
  $session->close();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [SNMPv2-MIB::sysDescr.0] => STRING: Test server
    [SNMPv2-MIB::sysObjectID.0] => OID: NET-SNMP-MIB::netSnmpAgentOIDs.8
    [DISMAN-EVENT-MIB::sysUpTimeInstance] => Timeticks: (1150681750) 133 days, 4:20:17.50
    [SNMPv2-MIB::sysContact.0] => STRING: Nobody
    [SNMPv2-MIB::sysName.0] => STRING: server.localdomain
    ...
)

Örnek 2 suffix_as_key example

suffix_as_key may be used when merging multiple SNMP subtrees into one. This example maps interface names to their type.

<?php
  $session = new SNMP(SNMP::VERSION_1, "127.0.0.1", "public");
  $session->valueretrieval = SNMP_VALUE_PLAIN;
  $ifDescr = $session->walk(".1.3.6.1.2.1.2.2.1.2", TRUE);
  $session->valueretrieval = SNMP_VALUE_LIBRARY;
  $ifType = $session->walk(".1.3.6.1.2.1.2.2.1.3", TRUE);
  print_r($ifDescr);
  print_r($ifType);
  $result = array();
  foreach($ifDescr as $i => $n) {
    $result[$n] = $ifType[$i];
  }
  print_r($result);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [1] => igb0
    [2] => igb1
    [3] => ipfw0
    [4] => lo0
    [5] => lagg0
)
Array
(
    [1] => INTEGER: ieee8023adLag(161)
    [2] => INTEGER: ieee8023adLag(161)
    [3] => INTEGER: ethernetCsmacd(6)
    [4] => INTEGER: softwareLoopback(24)
    [5] => INTEGER: ethernetCsmacd(6)
)
Array
(
    [igb0] => INTEGER: ieee8023adLag(161)
    [igb1] => INTEGER: ieee8023adLag(161)
    [ipfw0] => INTEGER: ethernetCsmacd(6)
    [lo0] => INTEGER: softwareLoopback(24)
    [lagg0] => INTEGER: ethernetCsmacd(6)
)

Ayrıca Bakınız

  • SNMP::getErrno() - Get last error code
  • SNMP::getError() - Get last error message
SNMP::setSecurity
SNMPException
SNMP


The SNMPException class

(PHP 5 >= 5.4.0, PHP 7)

Giriş

Represents an error raised by SNMP. You should not throw a SNMPException from your own code. See Exceptions for more information about Exceptions in PHP.

Sınıf Sözdizimi

SNMPException extends RuntimeException {
/* Özellikler */
protected string $code ;
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}

Özellikler

code

SNMPlibrary error code. Use Exception::getCode() to access it.

SNMP::walk
Soketler
SNMP


Soketler

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
  • Soket Hataları
  • Soket İşlevleri
    • socket_accept — Soket üzerinden bağlantı kabul eder
    • socket_bind — Soketi bir isimle ilişkilendirir
    • socket_clear_error — Soket üzerindeki hatayı veya son hata kodunu siler
    • socket_close — Bir soket özkaynağını serbest bırakır
    • socket_cmsg_space — Calculate message buffer size
    • socket_connect — Soket üzerinde bir bağlantıyı ilklendirir
    • socket_create_listen — Bağlantı kabul etmek için port üzerinde bir soket açar
    • socket_create_pair — Ayrılması olanaksız bir soket çifti oluşturur ve bunları bir dizide saklar
    • socket_create — Bir soket oluşturur (iletişim için bir uç)
    • socket_get_option — Soketle ilgili bir seçeneğin değerini döndürür
    • socket_getopt — Takma Adı: socket_get_option
    • socket_getpeername — Belirtilen soketin yerel tarafını sorgulayıp soket türüne göre ya bir konak/port çifti ya da bir Unix dosya yolu döndürür
    • socket_getsockname — Belirtilen soketin yerel tarafını sorgulayıp soket türüne göre ya bir konak/port çifti ya da bir Unix dosya yolu döndürür
    • socket_import_stream — Import a stream
    • socket_last_error — Soket üzerindeki son hatanın kodunu döndürür
    • socket_listen — Bir soketi bağlantı kabul etmek için dinler
    • socket_read — Bir soketten belli sayıda bayta kadar okuma yapar
    • socket_recv — Bağlı bir soketten veri alır
    • socket_recvfrom — Bağlantılı olsun olmasın bir soketten veri alır
    • socket_recvmsg — Read a message
    • socket_select — Belirtilen soket dizileri üzerinde belirtilen zaman aşımı ile select() sistem çağrısını çalıştırır
    • socket_send — Bağlı bir sokete veri gönderir
    • socket_sendmsg — Send a message
    • socket_sendto — Bağlı olsun olmasın bir sokete ileti gönderir
    • socket_set_block — Soketi engelleme kipine sokar
    • socket_set_nonblock — Belirtilen dosya tanıtıcısı için beklememe kipini etkinleştirir
    • socket_set_option — Soketle ilgili seçenekleri belirler
    • socket_setopt — Takma Adı: socket_set_option
    • socket_shutdown — Bir soketi kapatır
    • socket_strerror — Bir soket hatasıyla ilgili açıklamayı döndürür
    • socket_write — Bir sokete yazar
SNMPException
Giriş
Diğer Hizmetler


Giriş

Soket eklentisi, BSD soketlerine dayalı soket iletişim işlevlerine düşük seviyeli bir arayüz olarak gerçeklenmiştir. Eklenti bir soket istemcisi olarak davranabildiği gibi bir soket sunucusu olarak davranabilmektedir.

Daha temel istemci tarafı soket arayüzü için
stream_socket_client(),
stream_socket_server(),
fsockopen() ve
pfsockopen() işlevlerine bakınız.

Bu işlevleri kullanırken dikkat etmeniz gereken husus, işlev isimleri olarak C kütüphanesindeki eşdeğerlerinin isimleri kullanılmış olsa da bildirimleri aynı değildir. Çelişkiye düşmemek için işlevlerin açıklamalarını okumayı unutmayın.

Soket programlamaya yabancı olanlar Unix kılavuz sayfalarından ve C'deki soket programlama ile ilgili öğreticilerden büyük ölçüde yararlanabilirler. Çoğu, bir kaç değişiklikle PHP'deki soket programlamaya uyarlanabilir. » Unix Soketleri için SSS iyi bir başlangıç olabilir.

Soketler
Yapılandırma/Kurulum
Soketler


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Soketler


Kurulum

Soket işlevleri PHP'nin bir parçası olarak derleme sırasında configure betiğine --enable-sockets seçeneğini belirterek etkinleştirilebilir.

Bilginize: IPv6 Desteği PHP 5.0.0 sürümünde eklendi.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Özkaynak Türleri

socket_accept(),
socket_create_listen() ve
socket_create() işlevleri soket özkaynakları döndürür.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

AF_UNIX (integer)
AF_INET (integer)
AF_INET6 (integer)
Sadece IPv6 desteği ile derlendiği takdirde kullanılabilir.
SOCK_STREAM (integer)
SOCK_DGRAM (integer)
SOCK_RAW (integer)
SOCK_SEQPACKET (integer)
SOCK_RDM (integer)
MSG_OOB (integer)
MSG_WAITALL (integer)
MSG_PEEK (integer)
MSG_DONTROUTE (integer)
MSG_EOR (integer)
Windows platformlarında kullanılamaz.
MSG_EOF (integer)
Windows platformlarında kullanılamaz.
SO_DEBUG (integer)
SO_REUSEADDR (integer)
SO_KEEPALIVE (integer)
SO_DONTROUTE (integer)
SO_LINGER (integer)
SO_BROADCAST (integer)
SO_OOBINLINE (integer)
SO_SNDBUF (integer)
SO_RCVBUF (integer)
SO_SNDLOWAT (integer)
SO_RCVLOWAT (integer)
SO_SNDTIMEO (integer)
SO_RCVTIMEO (integer)
SO_TYPE (integer)
SO_ERROR (integer)
TCP_NODELAY (integer)
Nagle TCP algoritmasını iptal etmek içindir. PHP 5.2.7'de eklendi.
SOL_SOCKET (integer)
PHP_NORMAL_READ (integer)
PHP_BINARY_READ (integer)
SOL_TCP (integer)
SOL_UDP (integer)

Aşağıdaki sabitler sadece Windows altında tanımlıdır.

SOCKET_EINTR (integer)
SOCKET_EBADF (integer)
SOCKET_EACCES (integer)
SOCKET_EFAULT (integer)
SOCKET_EINVAL (integer)
SOCKET_EMFILE (integer)
SOCKET_EWOULDBLOCK (integer)
SOCKET_EINPROGRESS (integer)
SOCKET_EALREADY (integer)
SOCKET_ENOTSOCK (integer)
SOCKET_EDESTADDRREQ (integer)
SOCKET_EMSGSIZE (integer)
SOCKET_EPROTOTYPE (integer)
SOCKET_ENOPROTOOPT (integer)
SOCKET_EPROTONOSUPPORT (integer)
SOCKET_ESOCKTNOSUPPORT (integer)
SOCKET_EOPNOTSUPP (integer)
SOCKET_EPFNOSUPPORT (integer)
SOCKET_EAFNOSUPPORT (integer)
SOCKET_EADDRINUSE (integer)
SOCKET_EADDRNOTAVAIL (integer)
SOCKET_ENETDOWN (integer)
SOCKET_ENETUNREACH (integer)
SOCKET_ENETRESET (integer)
SOCKET_ECONNABORTED (integer)
SOCKET_ECONNRESET (integer)
SOCKET_ENOBUFS (integer)
SOCKET_EISCONN (integer)
SOCKET_ENOTCONN (integer)
SOCKET_ESHUTDOWN (integer)
SOCKET_ETOOMYREFS (integer)
SOCKET_ETIMEDOUT (integer)
SOCKET_ECONNREFUSED (integer)
SOCKET_ELOOP (integer)
SOCKET_ENAMETOOLONG (integer)
SOCKET_EHOSTDOWN (integer)
SOCKET_EHOSTUNREACH (integer)
SOCKET_ENOTEMPTY (integer)
SOCKET_EPROCLIM (integer)
SOCKET_EUSERS (integer)
SOCKET_EDUOT (integer)
SOCKET_ESTALE (integer)
SOCKET_EREMOTE (integer)
SOCKET_EDISCON (integer)
SOCKET_SYSNOTREADY (integer)
SOCKET_VERNOTSUPPORTED (integer)
SOCKET_NOTINITIALISED (integer)
SOCKET_HOST_NOT_FOUND (integer)
SOCKET_TRY_AGAIN (integer)
SOCKET_NO_RECOVERY (integer)
SOCKET_NO_DATA (integer)
SOCKET_NO_ADDRESS (integer)

Aşağıdaki sabitler Unix ve türevlerinde kullanılabilir. Her sabit, platformda eşdeğeri tanımlıysa kullanılabilir.

SOCKET_EPERM (integer)
İşleme izin verilmez.
SOCKET_ENOENT (integer)
Böyle bir dosya veya dizin yok.
SOCKET_EINTR (integer)
Sistem çağrısı kesintiye uğratıldı.
SOCKET_EIO (integer)
I/O error.
SOCKET_ENXIO (integer)
Böyle bir aygıt veya adres yok.
SOCKET_E2BIG (integer)
Değiştirge listesi çok uzun.
SOCKET_EBADF (integer)
Dosya numarası hatalı.
SOCKET_EAGAIN (integer)
Tekrar dene.
SOCKET_ENOMEM (integer)
Bellek yetersiz.
SOCKET_EACCES (integer)
Erişim izni yok.
SOCKET_EFAULT (integer)
Adres hatalı.
SOCKET_ENOTBLK (integer)
Blok aygıtı gerekli.
SOCKET_EBUSY (integer)
Aygıt veya özkaynak meşgul.
SOCKET_EEXIST (integer)
Dosya var.
SOCKET_EXDEV (integer)
Çapraz aygıt bağlantısı.
SOCKET_ENODEV (integer)
Böyle bir aygıt yok.
SOCKET_ENOTDIR (integer)
Bir dizin değil.
SOCKET_EISDIR (integer)
Bir dizin.
SOCKET_EINVAL (integer)
Geçersiz değiştirge.
SOCKET_ENFILE (integer)
Dosya tablosunda taşma.
SOCKET_EMFILE (integer)
Çok fazla açık dosya var.
SOCKET_ENOTTY (integer)
Bir konsol değil.
SOCKET_ENOSPC (integer)
Aygıtta boş yer yok.
SOCKET_ESPIPE (integer)
Kuraldışı konumlama.
SOCKET_EROFS (integer)
Salt okunur dosya sistemi.
SOCKET_EMLINK (integer)
Çok fazla bağlantı.
SOCKET_EPIPE (integer)
Kırık boru.
SOCKET_ENAMETOOLONG (integer)
Dosya ismi çok uzun.
SOCKET_ENOLCK (integer)
Kullanılabilecek kayıt kilidi yok.
SOCKET_ENOSYS (integer)
İşlev gerçeklenmedi.
SOCKET_ENOTEMPTY (integer)
Dizin boş değil.
SOCKET_ELOOP (integer)
Çok fazla sembolik bağ saptandı.
SOCKET_EWOULDBLOCK (integer)
İşlem engellendi.
SOCKET_ENOMSG (integer)
İstenen türde ileti yok.
SOCKET_EIDRM (integer)
Tanıtıcı silindi.
SOCKET_ECHRNG (integer)
Kanal numarası kapsam dışı.
SOCKET_EL2NSYNC (integer)
2. seviye eşzamanlanmadı.
SOCKET_EL3HLT (integer)
3. seviye çöktü.
SOCKET_EL3RST (integer)
3. seviye sıfırlandı.
SOCKET_ELNRNG (integer)
Bağlantı numarası kapsam dışı.
SOCKET_EUNATCH (integer)
Protokol sürücüsü ekli değil.
SOCKET_ENOCSI (integer)
Kullanılabilir CSI yapısı yok.
SOCKET_EL2HLT (integer)
2. seviye çöktü.
SOCKET_EBADE (integer)
Alışveriş geçersiz.
SOCKET_EBADR (integer)
Geçersiz istek tanıtıcısı.
SOCKET_EXFULL (integer)
Aktarım dolu.
SOCKET_ENOANO (integer)
Düğüm tablosu dolu.
SOCKET_EBADRQC (integer)
İstek kodu geçersiz.
SOCKET_EBADSLT (integer)
Yuva geçersiz.
SOCKET_ENOSTR (integer)
Aygıt bir akım aygıtı değil.
SOCKET_ENODATA (integer)
Kullanılabilir veri yok.
SOCKET_ETIME (integer)
Zaman aşımı.
SOCKET_ENOSR (integer)
Akım özkaynakları yetersiz.
SOCKET_ENONET (integer)
Makine bir ağa bağlı değil.
SOCKET_EREMOTE (integer)
Nesne uzakta.
SOCKET_ENOLINK (integer)
Bağlantı koptu.
SOCKET_EADV (integer)
Dikkat çekme hatası.
SOCKET_ESRMNT (integer)
Srmount hatası.
SOCKET_ECOMM (integer)
Gönderimde iletişim hatası.
SOCKET_EPROTO (integer)
Protokol hatası.
SOCKET_EMULTIHOP (integer)
Çoklu sıçrama denendi.
SOCKET_EBADMSG (integer)
Bir veri iletisi değil.
SOCKET_ENOTUNIQ (integer)
İsim ağ üzerinde eşsiz değil.
SOCKET_EBADFD (integer)
Dosya tanıtıcısı hatalı durumda.
SOCKET_EREMCHG (integer)
Uzak adres değişti.
SOCKET_ERESTART (integer)
Engellenen sistem çağrısı yeniden başlatılmalı.
SOCKET_ESTRPIPE (integer)
Akım borulama hatası.
SOCKET_EUSERS (integer)
Kullanıcı sayısı çok fazla.
SOCKET_ENOTSOCK (integer)
Bir soket gerektiği halde belirtilen dosya bir soket değil.
SOCKET_EDESTADDRREQ (integer)
Sokete öntanımlı hedef adresi belirtilmemiş.
SOCKET_EMSGSIZE (integer)
İleti çok uzun.
SOCKET_EPROTOTYPE (integer)
İstenen protokol bu soket türünü desteklemiyor.
SOCKET_EPROTOOPT (integer)
Belirttiğiniz soket seçeneği soket tarafından kullanılmakta olan protokol için uygun değil.
SOCKET_EPROTONOSUPPORT (integer)
Soket istenen iletişim protokolünü desteklemiyor.
SOCKET_ESOCKTNOSUPPORT (integer)
Soket türü desteklenmiyor.
SOCKET_EOPNOTSUPP (integer)
İstediğiniz işlem desteklenmiyor. Sunucunun bu çağrı için hiçbir şey yapamayacağı genel bir durumu belirtir.
SOCKET_EPFNOSUPPORT (integer)
İstediğiniz soket iletişim protokolü ailesi desteklenmiyor.
SOCKET_EAFNOSUPPORT (integer)
Bir soket için belirtilmiş adres ailesi desteklenmiyor; adres ailesinin soket üzerinde kullanılan protokolle bağdaşmadığını belirtir.
SOCKET_ADDRINUSE (integer)
İstenen soket adresi kullanımda.
SOCKET_EADDRNOTAVAIL (integer)
İstenen soket adresi kullanıma uygun değil.
SOCKET_ENETDOWN (integer)
Ağ çökük olduğundan soket işlemi başarısız oldu.
SOCKET_ENETUNREACH (integer)
Uzak konağı içeren alt ağ erişilemez olduğundan soket işlemi başarısız oldu.
SOCKET_ENETRESET (integer)
Uzak konak çöktüğünden ağ bağlantısı sıfırlandı.
SOCKET_ECONNABORTED (integer)
Ağ bağlantısı yerel olarak sonlandırıldı.
SOCKET_ECONNRESET (integer)
Ağ bağlantısı yerel konağın denetimi dışında kapandı.
SOCKET_ENOBUFS (integer)
Çekirdeğin G/Ç tamponlarının hepsi kullanımda.
SOCKET_EISCONN (integer)
Zaten bağlı olan bir sokete bağlanmayı denediniz.
SOCKET_ENOTCONN (integer)
Soket hiçbir şeye bağlı değil. Veriyi hedefini belirtmeksizin bir soket üzerinden aktarmaya çalışırsanız bu hatayı alırsınız.
SOCKET_ESHUTDOWN (integer)
Soket zaten kapatılmış.
SOCKET_ETOOMANYREFS (integer)
Çok fazla başvuru: uçlar birbirine bağlanamıyor
SOCKET_ETIMEDOUT (integer)
Bir zamanaşımı belirtilmiş bir soket işlemine zamanaşımı süresinde bir yanıt gelmedi.
SOCKET_ECONNREFUSED (integer)
Bir uzak konak ağ bağlantısına izin vermedi.
SOCKET_EHOSTDOWN (integer)
İstenen ağ bağlantısındaki uzak konak çökük.
SOCKET_EHOSTUNREACH (integer)
İstenen ağ bağlantısındaki uzak konak erişilebilir değil.
SOCKET_EALREADY (integer)
Engellenmemesi öngörülmüş bir nesne üzerindeki işlem hala sürüyor.
SOCKET_EINPROGRESS (integer)
Engellenmemesi öngörülmüş bir nesne üzerinde başlatılmış bir işlem tamamlanmadı.
SOCKET_EISNAM (integer)
Bir isimli tür dosyası.
SOCKET_EREMOTEIO (integer)
Uzak G/Ç hatası.
SOCKET_EDQUOT (integer)
Kullanıcının disk kotası aşıldı.
SOCKET_ENOMEDIUM (integer)
Ortam bulunamadı.
SOCKET_EMEDIUMTYPE (integer)
Ortam türü yanlış.
Özkaynak Türleri
Örnekler
Soketler


Örnekler

Örnek 1 - Soket örneği: Basit bir TCP/IP sunucu

Bu örnekte basit bir raporlama sunucusu gösterilmiştir. adres ve port değişkenleri ayarlarınıza uygun olarak değiştirilip işleme sokulur. Sunucuya şöyle bir komutla bağlanabilirsiniz: telnet 192.168.1.53 10000 (buradaki adres ve port ayarlarınıza göre belirlenir). Yazdığınız herşey sunucu tarafında çıktılanır ve tekrar size gösterilir, Çıkmak için 'quit' girilir.

#!/usr/local/bin/php -q
<?php
error_reporting(E_ALL);

/* Betik sürekli bağlantı beklesin. */
set_time_limit(0);

/* Örtük çıktılama etkin olsun, böylece ne yaptğımızı görürüz. */
ob_implicit_flush();

$adres = '192.168.1.53';
$port = 10000;

if (($sock = socket_create(AF_INET, SOCK_STREAM, SOL_TCP)) === false) {
    echo "socket_create()  başarısız oldu: sebep: " .
          socket_strerror(socket_last_error()) . "\n";
}

if (socket_bind($sock, $adres, $port) === false) {
    echo "socket_bind()  başarısız oldu: sebep: " .
          socket_strerror(socket_last_error($sock)) . "\n";
}

if (socket_listen($sock, 5) === false) {
    echo "socket_listen()  başarısız oldu: sebep: " .
          socket_strerror(socket_last_error($sock)) . "\n";
}

do {
    if (($msgsock = socket_accept($sock)) === false) {
        echo "socket_accept()  başarısız oldu: sebep: " .
              socket_strerror(socket_last_error($sock)) . "\n";
        break;
    }
    /* Komutları gönder. */
    $msg = "\nPHP Deneme Sunucusuna Hoş Geldiniz.\n" .
        "Çıkmak için 'quit', sunucuyu kapatmak için " .
        "'shutdown' yazıp enter tuşuna basınız.\n";
    socket_write($msgsock, $msg, strlen($msg));

    do {
        if (false === ($buf = socket_read($msgsock, 2048, PHP_NORMAL_READ)))
        {
            echo "socket_read() başarısız oldu: sebep: " .
                  socket_strerror(socket_last_error($msgsock)) . "\n";
            break 2;
        }
        if (!$buf = trim($buf)) {
            continue;
        }
        if ($buf == 'quit') {
            break;
        }
        if ($buf == 'shutdown') {
            socket_close($msgsock);
            break 2;
        }
        $talkback = "Şunları yazdınız:'$buf'.\n";
        socket_write($msgsock, $talkback, strlen($talkback));
        echo "$buf\n";
    } while (true);
    socket_close($msgsock);
} while (true);

socket_close($sock);
?>

Örnek 2 - Soket örneği: Basit TCP/IP istemci

Örnekte tek atımlık basit bir HTTP istemcisi gösterilmiştir. Bir sayfaya bağlanır, bir HEAD isteği yapar, yanıtı gösterir ve çıkar.

<?php
error_reporting(E_ALL);

echo "<h2>TCP/IP bağlantısı</h2>\n";

/* WWW hizmeti için port isteyelim. */
$service_port = getservbyname('www', 'tcp');

/* Hedef konağın IP adresini alalım. */
$adres = gethostbyname('www.example.com');

/* Bir TCP/IP soketi oluşturalım. */
$socket = socket_create(AF_INET, SOCK_STREAM, SOL_TCP);
if ($socket === false) {
    echo "socket_create() başarısız oldu: sebep: " .
          socket_strerror(socket_last_error()) . "\n";
} else {
    echo "Tamam.\n";
}

echo "'$adres' adresine '$service_port' üzerinden bağlanmaya çalışılıyor...";
$result = socket_connect($socket, $adres, $service_port);
if ($result === false) {
    echo "socket_connect() başarısız oldu.\nSebep: ($result) " .
          socket_strerror(socket_last_error($socket)) . "\n";
} else {
    echo "Tamam.\n";
}

$in = "HEAD / HTTP/1.1\r\n";
$in .= "Host: www.example.com\r\n";
$in .= "Connection: Close\r\n\r\n";
$out = '';

echo "HTTP HEAD isteği gönderiliyor...";
socket_write($socket, $in, strlen($in));
echo "Tamam.\n";

echo "Alınan yanıt:\n\n";
while ($out = socket_read($socket, 2048)) {
    echo $out;
}

echo "Soket kapatılıyor...";
socket_close($socket);
echo "Tamam.\n\n";
?>

Öntanımlı Sabitler
Soket Hataları
Soketler


Soket Hataları

Soket eklentisi, güçlü BSD soketlerine faydalı bir arayüz olması için yazılmıştır. Dikkat edilirse bu işlevlerin hem Windows hem de Unix gerçeklenimlerinin gayet iyi çalışacağı görülür. Hemen tüm soket işlemleri olumsuz koşullarda başarısız olabilir, böyle bir durumda hatayı açıklayan bir E_WARNING iletisi çıktılanır. Bu bazan geliştiricinin isteği haricinde olur. Örneğin, bağlantı beklenmedik şekilde kesildiğinden socket_read() işlevi ister istemez bir E_WARNING iletisi çıktılar. Bu uyarıları @-işleci ile engellemek ve hata kodunu uygulama içinde socket_last_error() işleviyle yakalamak mümkündür. Böyle bir hata kodu ile ilgili hata iletisini socket_strerror() işleviyle alabilirsiniz. Daha ayrıntılı bilgi için bu işlevlerin açıklamalarına bakınız.

Bilginize:

Alınan hata iletilerinin dili geçerli yerele bağlı (LC_MESSAGES) olsa da soket eklentisi tarafından üretilen E_WARNING iletileri İngilizce'dir:

Warning - socket_bind() unable to bind address [98]: Adrese bağlanılamadı

Örnekler
Soket İşlevleri
Soketler


Soket İşlevleri

İçindekiler

  • socket_accept — Soket üzerinden bağlantı kabul eder
  • socket_bind — Soketi bir isimle ilişkilendirir
  • socket_clear_error — Soket üzerindeki hatayı veya son hata kodunu siler
  • socket_close — Bir soket özkaynağını serbest bırakır
  • socket_cmsg_space — Calculate message buffer size
  • socket_connect — Soket üzerinde bir bağlantıyı ilklendirir
  • socket_create_listen — Bağlantı kabul etmek için port üzerinde bir soket açar
  • socket_create_pair — Ayrılması olanaksız bir soket çifti oluşturur ve bunları bir dizide saklar
  • socket_create — Bir soket oluşturur (iletişim için bir uç)
  • socket_get_option — Soketle ilgili bir seçeneğin değerini döndürür
  • socket_getopt — Takma Adı: socket_get_option
  • socket_getpeername — Belirtilen soketin yerel tarafını sorgulayıp soket türüne göre ya bir konak/port çifti ya da bir Unix dosya yolu döndürür
  • socket_getsockname — Belirtilen soketin yerel tarafını sorgulayıp soket türüne göre ya bir konak/port çifti ya da bir Unix dosya yolu döndürür
  • socket_import_stream — Import a stream
  • socket_last_error — Soket üzerindeki son hatanın kodunu döndürür
  • socket_listen — Bir soketi bağlantı kabul etmek için dinler
  • socket_read — Bir soketten belli sayıda bayta kadar okuma yapar
  • socket_recv — Bağlı bir soketten veri alır
  • socket_recvfrom — Bağlantılı olsun olmasın bir soketten veri alır
  • socket_recvmsg — Read a message
  • socket_select — Belirtilen soket dizileri üzerinde belirtilen zaman aşımı ile select() sistem çağrısını çalıştırır
  • socket_send — Bağlı bir sokete veri gönderir
  • socket_sendmsg — Send a message
  • socket_sendto — Bağlı olsun olmasın bir sokete ileti gönderir
  • socket_set_block — Soketi engelleme kipine sokar
  • socket_set_nonblock — Belirtilen dosya tanıtıcısı için beklememe kipini etkinleştirir
  • socket_set_option — Soketle ilgili seçenekleri belirler
  • socket_setopt — Takma Adı: socket_set_option
  • socket_shutdown — Bir soketi kapatır
  • socket_strerror — Bir soket hatasıyla ilgili açıklamayı döndürür
  • socket_write — Bir sokete yazar
Soket Hataları
socket_accept
Soketler


Soket üzerinden bağlantı kabul eder

Soket İşlevleri
socket_bind
Soket İşlevleri
PHP Manual

socket_accept

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

socket_accept — Soket üzerinden bağlantı kabul eder

Açıklama

resource socket_accept ( resource $soket )

soket soketi socket_create() ile oluşturulup, socket_bind() kullanarak bir isimle ilişkilendirildikten sonra socket_listen() ile gelen bağlantılar dinlenmeye başlanır. Bu işlev böyle bir soket üzerinden gelen bağlantıları kabul etmek için kullanılır. Başarılı bir bağlantı, iletişim için kullanılacak yeni bir soket özkaynağının dönmesini sağlar. Soket kuyruğunda bekleyen çok sayıda bağlantı varsa socket_accept() bunlardan birinde veri hazır olana dek bekler. Soket socket_set_blocking() veya socket_set_nonblock() ile engellenmeyen kipe sokulmuşsa bu işlev FALSE döndürür.

socket_accept() tarafından döndürülen soket özkaynağı yeni bağlantılar kabul etmek için kullanılamaz. Bununla birlikte, soket ile belirtilen dinleme soketi açık olarak kalır ve defalarca kullanılabilir.

Değiştirgeler

soket

socket_create() ile oluşturulmuş geçerli bir soket özkaynağı.

Dönen Değerler

Bir hata durumunda FALSE yoksa yeni bir soket özkaynağı döner. Hata kodu socket_last_error() işlevi ile alınabilir. Bu hata kodunu socket_strerror() işlevine aktararak hatayı açıklayan dizgeyi alabilirsiniz.

Ayrıca Bakınız

  • socket_connect() - Soket üzerinde bir bağlantıyı ilklendirir
  • socket_listen() - Bir soketi bağlantı kabul etmek için dinler
  • socket_create() - Bir soket oluşturur (iletişim için bir uç)
  • socket_bind() - Soketi bir isimle ilişkilendirir
  • socket_strerror() - Bir soket hatasıyla ilgili açıklamayı döndürür

Soket İşlevleri
socket_bind
Soket İşlevleri


Soketi bir isimle ilişkilendirir

socket_accept
socket_clear_error
Soket İşlevleri
PHP Manual

socket_bind

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

socket_bind — Soketi bir isimle ilişkilendirir

Açıklama

bool socket_bind ( resource $soket , string $adres [, int $port = 0 ] )

Belirtilen socket'i adres'teki bir isimle ilişkilendirir. Bu işlem, socket_connect() veya socket_listen() işlevlerini kullanarak bir bağlantı oluşturulmadan önce yapılmalıdır.

Değiştirgeler

soket

socket_create() ile oluşturulmuş geçerli bir soket özkaynağı.

address

Soket, AF_INET türündeyse noktalı dördül gösterimle (127.0.0.1 gibi) geçerli bir IPv4 adresi, AF_INET6 türündeyse ve IPv6 desteği varsa geçerli bir IPv6 adresi (::1 gibi) olmalıdır.

Soket, AF_UNIX türündeyse Unix ailesinden bir soketin dosya yolu (/var/run/daemon.sock gibi) olmalıdır.

port (seçimlik)

Bu değiştirge sadece ve zorunlu olarak bir AF_INET veya AF_INET6 sokete bağlanırken gerekir ve bağlantının yapılacağı uzak konak üzerinde bir port belirtir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hata kodu socket_last_error() işlevi ile alınabilir. Bu hata kodunu socket_strerror() işlevine aktararak hatayı açıklayan dizgeyi alabilirsiniz.

Örnekler

Örnek 1 - Kaynak adresini belirtmek için socket_bind() kullanımı

<?php
// Yeni bir soket oluşturalım
$sock = socket_create(AF_INET, SOCK_STREAM, SOL_TCP);

// IP adreslerini makine sahibine göre tanımlayalım
$sourceips['kevin']    = '127.0.0.1';
$sourceips['madcoder'] = '127.0.0.2';

// Soketi kaynak adresiyle ilişkilendirelim
socket_bind($sock, $sourceips['madcoder']);

// Hedef adrese bağlanalım
socket_connect($sock, '127.0.0.1', 80);

// Veriyi gönderelim
$request = 'GET / HTTP/1.1' . "\r\n" .
           'Host: example.com' . "\r\n\r\n";
socket_write($sock, $request);

// Soketi kapatalım
socket_close($sock);

?>

Notlar

Bilginize:

Bu işlev socket_connect() işlevinden önce çağrılmalıdır.

Bilginize: Windows 9x/ME uyumluluk bilgisi:

Soketi makinenize ait olmayan bir adresle ilişkilendirmeye çalışırsanız socket_last_error() işlevi geçersiz bir hata kodu döndürebilir.

Ayrıca Bakınız

  • socket_connect() - Soket üzerinde bir bağlantıyı ilklendirir
  • socket_listen() - Bir soketi bağlantı kabul etmek için dinler
  • socket_create() - Bir soket oluşturur (iletişim için bir uç)
  • socket_last_error() - Soket üzerindeki son hatanın kodunu döndürür
  • socket_strerror() - Bir soket hatasıyla ilgili açıklamayı döndürür

socket_accept
socket_clear_error
Soket İşlevleri


Soket üzerindeki hatayı veya son hata kodunu siler

socket_bind
socket_close
Soket İşlevleri
PHP Manual

socket_clear_error

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

socket_clear_error — Soket üzerindeki hatayı veya son hata kodunu siler

Açıklama

void socket_clear_error ([ resource $soket ] )

Belirtildiği takdirde soket üzerindeki hata kodunu yoksa küresel son hata kodunu siler.

Bu işlevle doğrudan bir soket üzerindeki hata kodunu silebileceğiniz gibi eklentinin küresel son hata kodunu da silebilirsiniz. Bir uygulamanın belli bir bölümünde bir hata oluşup oluşmadığını saptamak için yararlıdır.

Değiştirgeler

soket

socket_create() ile oluşturulmuş geçerli bir soket özkaynağı.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • socket_last_error() - Soket üzerindeki son hatanın kodunu döndürür
  • socket_strerror() - Bir soket hatasıyla ilgili açıklamayı döndürür

socket_bind
socket_close
Soket İşlevleri


Bir soket özkaynağını serbest bırakır

socket_clear_error
socket_cmsg_space
Soket İşlevleri
PHP Manual

socket_close

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

socket_close — Bir soket özkaynağını serbest bırakır

Açıklama

void socket_close ( resource $socket )

Belirtilen soket özkaynağını kapatır. Bu işlev soketlere özgü olup başka türdeki özkaynakları kapatmakta kullanılamaz.

Değiştirgeler

soket

socket_create() veya socket_accept() ile oluşturulmuş geçerli bir soket özkaynağı.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • socket_bind() - Soketi bir isimle ilişkilendirir
  • socket_listen() - Bir soketi bağlantı kabul etmek için dinler
  • socket_create() - Bir soket oluşturur (iletişim için bir uç)
  • socket_strerror() - Bir soket hatasıyla ilgili açıklamayı döndürür

socket_clear_error
socket_cmsg_space
Soket İşlevleri


Calculate message buffer size

socket_close
socket_connect
Soket İşlevleri
PHP Manual

socket_cmsg_space

(PHP 5 >= 5.5.0, PHP 7)

socket_cmsg_space — Calculate message buffer size

Açıklama

int socket_cmsg_space ( int $level , int $type )

Calculates the size of the buffer that should be allocated for receiving the ancillary data.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

level

type

Dönen Değerler

Ayrıca Bakınız

  • socket_recvmsg() - Read a message
  • socket_sendmsg() - Send a message

socket_close
socket_connect
Soket İşlevleri


Soket üzerinde bir bağlantıyı ilklendirir

socket_cmsg_space
socket_create_listen
Soket İşlevleri
PHP Manual

socket_connect

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

socket_connect — Soket üzerinde bir bağlantıyı ilklendirir

Açıklama

bool socket_connect ( resource $soket , string $adres [, int $port = 0 ] )

Belirtilen soket üzerinde adres'e bir bağlantı başlatır.

Değiştirgeler

soket

socket_create() ile oluşturulmuş geçerli bir soket özkaynağı.

adres

Soket, AF_INET türündeyse noktalı dördül gösterimle (127.0.0.1 gibi) geçerli bir IPv4 adresi, AF_INET6 türündeyse ve IPv6 desteği varsa geçerli bir IPv6 adresi (::1 gibi) ya da AF_UNIX türündeyse Unix ailesinden bir soketin dosya yolu (/var/run/daemon.sock gibi) olmalıdır.

port

Bu değiştirge sadece ve zorunlu olarak bir AF_INET veya AF_INET6 sokete bağlanırken gerekir ve bağlantının yapılacağı uzak konak üzerinde bir port belirtir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. Hata kodu socket_last_error() işlevi ile alınabilir. Bu hata kodunu socket_strerror() işlevine aktararak hatayı açıklayan dizgeyi alabilirsiniz.

Bilginize:

Soket engellenmeyen türde ise bu işlev işlemin sürdüğünü belirten bir hatayla hata kodunu güncelleyerek FALSE döndürür.

Ayrıca Bakınız

  • socket_bind() - Soketi bir isimle ilişkilendirir
  • socket_listen() - Bir soketi bağlantı kabul etmek için dinler
  • socket_create() - Bir soket oluşturur (iletişim için bir uç)
  • socket_last_error() - Soket üzerindeki son hatanın kodunu döndürür
  • socket_strerror() - Bir soket hatasıyla ilgili açıklamayı döndürür

socket_cmsg_space
socket_create_listen
Soket İşlevleri


Bağlantı kabul etmek için port üzerinde bir soket açar

socket_connect
socket_create_pair
Soket İşlevleri
PHP Manual

socket_create_listen

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

socket_create_listen — Bağlantı kabul etmek için port üzerinde bir soket açar

Açıklama

resource socket_create_listen ( int $port [, int $kuyruk = 128 ] )

socket_create_listen() işlevi, yeni bağlantıları beklemek için belirtilen port üzerindeki tüm arabilirimleri dinleyen AF_INET türünde yeni bir soket özkaynağı oluşturur.

Bu işlev yeni bağlantı kabul etmek için sadece dinleme yapacak yeni bir soket oluşturmayı kolaylaştırmak için tasarlanmıştır.

Değiştirgeler

port

Tüm arabirimlerde dinlenecek port.

backlog

İşlem için kuyruğa alınacak azami gelen bağlantı sayısı. Bu değiştirgeye SOMAXCONN atanabilir. Daha fazla bilgi için socket_listen() işlevine bakınız.

Dönen Değerler

Hata durumunda FALSE, yoksa yeni bir soket özkaynağı döner. Hata kodu socket_last_error() işlevi ile alınabilir. Bu hata kodunu socket_strerror() işlevine aktararak hatayı açıklayan dizgeyi alabilirsiniz.

Notlar

Bilginize:

Sadece belli bir arabirimi dinleyecek bir soket oluşturmak isterseniz socket_create(), socket_bind() ve socket_listen() işlevlerini kullanın.

Ayrıca Bakınız

  • socket_create() - Bir soket oluşturur (iletişim için bir uç)
  • socket_create_pair() - Ayrılması olanaksız bir soket çifti oluşturur ve bunları bir dizide saklar
  • socket_bind() - Soketi bir isimle ilişkilendirir
  • socket_listen() - Bir soketi bağlantı kabul etmek için dinler
  • socket_last_error() - Soket üzerindeki son hatanın kodunu döndürür
  • socket_strerror() - Bir soket hatasıyla ilgili açıklamayı döndürür

socket_connect
socket_create_pair
Soket İşlevleri


Ayrılması olanaksız bir soket çifti oluşturur ve bunları bir dizide saklar

socket_create_listen
socket_create
Soket İşlevleri
PHP Manual

socket_create_pair

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

socket_create_pair — Ayrılması olanaksız bir soket çifti oluşturur ve bunları bir dizide saklar

Açıklama

bool socket_create_pair ( int $aile , int $tür , int $protokol , array &$dt )

socket_create_pair() iki tane bağlı ve ayrılması olanaksız soket oluşturur ve bunları dt dizisine yerleştirir. Bu işlev genellikle süreçler arası iletişim için kullanılır.

Değiştirgeler

domain

Soket tarafından kullanılacak protokol ailesi. Tam liste için socket_create() işlevine bakın.

tür

Soket tarafından kullanılacak iletişimin türü. Tam liste için socket_create() işlevine bakın.

protokol

Soketten dönen iletişimi kullanacak aileye özgü protokol. Bu değer protol ismi belirtilerek getprotobyname() ile alınabilir. İstenen protokol bir TCP veya UDP protokolü ise SOL_TCP veya SOL_UDP sabiti değer olarak kullanılabilir.

Desteklenen protokollerin listesi için socket_create() işlevine bakın.

dt

Soket çiftinin yerleştirileceği gönderimli dizi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | İşlev Windows platformlarında yeniden kullanılabilir oldu.
4.3.0 | İşlev bir hatadan dolayı Windows platformlarında kullanılamaz oldu.

Örnekler

Örnek 1 - socket_create_pair() örneği

<?php
$sockets = array();

/* Windows'ta AF_INET kullanmamız lazım */
$domain = (strtoupper(substr(PHP_OS, 0, 3)) == 'WIN' ? AF_INET : AF_UNIX);

/* Soket çiftini alalım */
if (socket_create_pair($domain, SOCK_STREAM, 0, $sockets) === false)
{
    echo "socket_create_pair başarısız oldu. Sebep: ".
          socket_strerror(socket_last_error());
}
/* Veri gönderip alalım */
if (socket_write($sockets[0], "ABCdnm123\n", strlen("ABCdnm123\n")) === false)
{
    echo "socket_write() başarısız oldu. Sebep: ".
          socket_strerror(socket_last_error($sockets[0]));
}
if (($data = socket_read($sockets[1], strlen("ABCdef123\n"),
    PHP_BINARY_READ)) === false)
{
    echo "socket_read() başarısız oldu. Sebep: ".
          socket_strerror(socket_last_error($sockets[1]));
}
var_dump($data);

/* Soketleri kapatalım */
socket_close($sockets[0]);
socket_close($sockets[1]);
?>

Örnek 2 -socket_create_pair() IPC örneği

<?php
$ary = array();
$dizgebir = 'Ebeveynin iletisi.';
$dizgeiki = 'Çocuğun iletisi.';

if (socket_create_pair(AF_UNIX, SOCK_STREAM, 0, $ary) === false)
{
    echo "socket_create_pair() başarısız oldu. Sebep: ".
          socket_strerror(socket_last_error());
}
$pid = pcntl_fork();
if ($pid == -1)
{
    echo 'Süreç çatallanamadı.';
}
elseif ($pid)
{
    /* ebeveyn */
    socket_close($ary[0]);
    if (socket_write($ary[1], $dizgebir, strlen($dizgebir)) === false)
    {
        echo "socket_write() başarısız oldu. Sebep: ".
              socket_strerror(socket_last_error($ary[1]));
    }
    if (socket_read($ary[1], strlen($dizgeiki), PHP_BINARY_READ) == $dizgeiki)
    {
        echo "$dizgeiki alındı\n";
    }
    socket_close($ary[1]);
}
else
{
    /* çocuk */
    socket_close($ary[1]);
    if (socket_write($ary[0], $dizgeiki, strlen($dizgeiki)) === false)
    {
        echo "socket_write() başarısız oldu. Sebep: ".
              socket_strerror(socket_last_error($ary[0]));
    }
    if (socket_read($ary[0], strlen($dizgebir), PHP_BINARY_READ) == $dizgebir)
    {
        echo "$dizgebir alındı\n";
    }
    socket_close($ary[0]);
}
?>

Ayrıca Bakınız

  • socket_create() - Bir soket oluşturur (iletişim için bir uç)
  • socket_create_listen() - Bağlantı kabul etmek için port üzerinde bir soket açar
  • socket_bind() - Soketi bir isimle ilişkilendirir
  • socket_listen() - Bir soketi bağlantı kabul etmek için dinler
  • socket_last_error() - Soket üzerindeki son hatanın kodunu döndürür
  • socket_strerror() - Bir soket hatasıyla ilgili açıklamayı döndürür

socket_create_listen
socket_create
Soket İşlevleri


Bir soket oluşturur (iletişim için bir uç)

socket_create_pair
socket_get_option
Soket İşlevleri
PHP Manual

socket_create

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

socket_create — Bir soket oluşturur (iletişim için bir uç)

Açıklama

resource socket_create ( int $aile , int $tür , int $protokol )

Bir soket özkaynağı döndürmenin yanında iletişim için uçlardan birini belirler. Normal bir ağ bağlantısı iki soketle yapılır. Biri istemci olurken diğeri sunucu olur.

Değiştirgeler

aile

Soket tarafından kullanılacak protokol ailesi.

Olası adres/protokol aileleri
Aile | Açıklama
AF_INET | IPv4 protokolleri. TCP ve UDP bu ailenin en bilinen üyeleridir.
AF_INET6 | IPv6 protokolleri. TCP ve UDP bu ailenin en bilinen üyeleridir.
AF_UNIX | Yerel iletişim protokolleri ailesi. Süreçler arası iletişimde yüksek verimlilik ve düşük maliyet sağlar.
tür

Soket tarafından kullanılacak iletişim türü.

Olası soket türleri
Tür | Açıklama
SOCK_STREAM | Sıralı, güvenilir, iki yönlü bağlantıya dayalı bayt akımları. Band dışı veri aktarım mekanizması da desteklenebilir. TCP protokolü bu soket türüne dayanır.
SOCK_DGRAM | Veri katarlarını destekler (bağlantısız, güvensiz, sabit uzunlukta iletiler). UDP protokolü bu soket türüne dayanır.
SOCK_SEQPACKET | Sabit uzunluklu veri katarları için sıralı, güvenilir, iki yönlü bağlantıya dayanan veri aktarımı; her okuma çağrısında paketin tamamını okuyacak bir istemci gerekir.
SOCK_RAW | Ham ağ protokolü erişimi sağlar. Bu özel soket türü elle bir protokol oluşturmak için kullanılabilir. Bu soketin bilinen bir kullanım da ICMP istekleridir (ping, traceroute komutları gibi).
SOCK_RDM | Sıralama garantisi olmayan güvenilir verikatarı katmanı sağlar. Çoğunlukla işletim sistemleri tarafından gerçeklenmez.
protokol

Soketten dönen iletişimi kullanacak aileye özgü protokol. Bu değer protol ismi belirtilerek getprotobyname() ile alınabilir. İstenen protokol bir TCP veya UDP protokolü ise SOL_TCP veya SOL_UDP sabiti değer olarak kullanılabilir.

Bilinen protokoller
İsim | Açıklama
icmp | Genel Ağ Denetim İletisi Protokolü esas olarak konaklar ve ağ geçitleri tarafından hataları verikatarı iletişimi ile raporlamak için kullanılır. ICMP uygulamalarının başlıcalarından biri de "ping" komutudur (günümüz işletim sistemlerinin hemen hepsinde vardır).
udp | Kullanıcı Verikatarı Protokolü bir bağlantısız, güvenilmez sabit uzuluklu kayıtların iletişiminde kullanılan bir protokoldür. Bu özelliklerinden dolayı UDP çok düşük bir protokol maliyetine sahiptir.
tcp | Aktarım Denetim Protokolü, güvenilir, bağlantılı, akım yönelimli, çift yönlü bir protokoldür. TCP tüm veri paketlerinin gönderildikleri sıra ile alınacağını garanti eder. Eğer yolda herhangi bir paket kaybolursa TCP, hedef tarafından alınıncaya kadar bu paketi tekrar tekrar yollar. Güvenilirlik ve başarım için TCP gerçeklenimi, ilgili verikatarı iletişim katmanının kaç sekizlikten oluşacağına kendi karar verir. Bu bakımdan, TCP uygulamaları kısmi kayıt aktarımı olasılığını dikkate almalıdır.

Dönen Değerler

Başarısızlık durumunda FALSE, aksi takdirde bir soket özkaynağı döndürür. Hata kodu socket_last_error() işlevi ile alınabilir. Bu hata kodunu socket_strerror() işlevine aktararak hatayı açıklayan dizgeyi alabilirsiniz.

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.0 | AF_INET6 sabiti eklendi.

Hatalar/İstisnalar

Geçersiz bir aile veya tür belirtilmişse, socket_create() bunlar için öntanımlı olarak AF_INET ve SOCK_STREAM değerleri belirtildiğini varsayar ve bu durumu bir E_WARNING iletisiyle bildirir.

Ayrıca Bakınız

  • socket_accept() - Soket üzerinden bağlantı kabul eder
  • socket_bind() - Soketi bir isimle ilişkilendirir
  • socket_connect() - Soket üzerinde bir bağlantıyı ilklendirir
  • socket_listen() - Bir soketi bağlantı kabul etmek için dinler
  • socket_last_error() - Soket üzerindeki son hatanın kodunu döndürür
  • socket_strerror() - Bir soket hatasıyla ilgili açıklamayı döndürür

socket_create_pair
socket_get_option
Soket İşlevleri


Soketle ilgili bir seçeneğin değerini döndürür

socket_create
socket_getopt
Soket İşlevleri
PHP Manual

socket_get_option

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

socket_get_option — Soketle ilgili bir seçeneğin değerini döndürür

Açıklama

mixed socket_get_option ( resource $soket , int $seviye , int $seçenek )

Belirtilen soket için ismi seçenek ile belirtilen seçeneğin değerini döndürür.

Değiştirgeler

soket

socket_create() veya socket_accept() ile oluşturulmuş geçerli bir soket özkaynağı.

seviye

Seçeneğin geçerli olacağı protokol seviyesi. Örneğin soket seviyesindeki seçenekleri almak için bu değiştirgede SOL_SOCKET kullanılabilirdi. TCP gibi diğer seviyeler, seviyenin protokol numarası belirtilerek kullanılabilir. Protokol numaralarını getprotobyname() işleviyle alabilirsiniz.

seçenek
Olası soket seçenekleri
Seçenek | Açıklama | Türü
SO_DEBUG | Hata ayıklama bilgilerinin kaydelip kaydedilmeyeceğini belirtir. | int
SO_BROADCAST | Yayın iletilerinin aktarılılp aktarılmayacağını belirtir. | int
SO_REUSEADDR | Yerel adresin yeniden kullanılabilir olup olmadığını belirtir. | int
SO_KEEPALIVE | Belirli aralıklarla ileti aktarımlarında bağlantının kalıcı olup olmayacağını belirtir. Eğer bağlı soket bu iletileri yanıtlamakta başarısız olursa bağlantı kopar ve sokete yazan sürece bir SIGPIPE sinyali gönderilir. | int
SO_LINGER

Veri mevcut olduğunda socket_close() işlevinin bekletilip bekletilmeyeceğini belirtir. Öntanımlı olarak soket kapatılacağı zaman gönderilmemiş tüm veri gönderilmeye çalışılır. Soketin bağlantı yönelimli olduğu durumda socket_close() karşı ucun alındısını bekler.

Eğer l_onoff sıfırdan farklı ve l_linger sıfırsa gönderilmemiş tüm veri iptal edilir ve soketin bağlantı yönelimli olması durumunda karşı uca bir RST (sıfırla) gönderilir.

Diğer taraftan, l_onoff ve l_linger'in ikisi de sıfırdan farklıysa tüm veri gönderilinceye veya l_linger ile belirtilen süre dolana kadar socket_close() bekletilir. Soket engellenmeyen kipte ise socket_close() başarısız olup bir hata döndürür.

array. Dizi iki anahtar içerir: l_onoff ve l_linger.
SO_OOBINLINE | Soketin band dışı veriyi hatta bırakıp bırakmayacağını belirtir. | int
SO_SNDBUF | Gönderim tamponunun boyunu belirtir. | int
SO_RCVBUF | Alım tamponunun boyunu belirtir. | int
SO_ERROR | Hata durumu hakkında bilgi verip hata kodunu siler. | int (socket_set_option() ile atanamayabilir.)
SO_TYPE | Soketin türünü belirtir (SOCK_STREAM gibi). | int (socket_set_option() ile atanamayabilir.)
SO_DONTROUTE | Giden iletilerin standart yönlendirme oluşumlarını es geçip geçmeyeceğini belirtir. | int
SO_RCVLOWAT | Soket girdi işlemlerinde işlenecek en küçük bayt sayısını belirtir. | int
SO_RCVTIMEO | Soket girdi işlemleri için zaman aşımı değerini belirtir. | array. Dizi iki anahtar içerir: Zaman aşımının saniye parçası sec, mikrosaniye parçası usec anahtarına konur.
SO_SNDTIMEO | Akış denetiminin veri gönderimini engellemesi nedeniyle bir çıktı işlevinin bekletileceği azami süreyi belirtir. | array. Dizi iki anahtar içerir: Zaman aşımının saniye parçası sec, mikrosaniye parçası usec anahtarına konur.
SO_SNDLOWAT | Soket çıktı işlemlerinde işlenecek en küçük bayt sayısını belirtir. | int
TCP_NODELAY | Nagle TCP algoritmasının iptal edilmiş olup olmadığını belirtir. | int

Dönen Değerler

Hata durumunda FALSE yoksa belirtilen seçeneğin değerini döndürür.

Örnekler

Örnek 1 - socket_get_option() örneği

<?php
$socket = socket_create_listen(1223);

$linger = array('l_linger' => 1, 'l_onoff' => 1);
socket_set_option($socket, SOL_SOCKET, SO_LINGER, $linger);

var_dump(socket_get_option($socket, SOL_SOCKET, SO_REUSEADDR));
?>

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.0 | İşleven ismi değişti. Evvelce socket_getopt() idi.

socket_create
socket_getopt
Soket İşlevleri


Takma Adı: socket_get_option

socket_get_option
socket_getpeername
Soket İşlevleri
PHP Manual

socket_getopt

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

socket_getopt — Takma Adı: socket_get_option()

Açıklama

Bu işlev şu işlevin takma adıdır: socket_get_option().

socket_get_option
socket_getpeername
Soket İşlevleri


Belirtilen soketin yerel tarafını sorgulayıp soket türüne göre ya bir konak/port çifti ya da bir Unix dosya yolu döndürür

socket_getopt
socket_getsockname
Soket İşlevleri
PHP Manual

socket_getpeername

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

socket_getpeername — Belirtilen soketin yerel tarafını sorgulayıp soket türüne göre ya bir konak/port çifti ya da bir Unix dosya yolu döndürür

Açıklama

bool socket_getpeername ( resource $soket , string &$adres [, int &$port ] )

Belirtilen soketin yerel tarafını sorgulayıp soket türüne göre ya bir konak/port çifti ya da bir Unix dosya yolu döndürür.

Değiştirgeler

soket

socket_create() veya socket_accept() ile oluşturulmuş geçerli bir soket özkaynağı.

adres

Belirtilen soket AF_INET veya AF_INET6 türündeyse socket_getsockname() işlevi, bu değiştirgede bir IP adresi (127.0.0.1 veya fe80::1 gibi) ve port değiştirgesinde de belirtilmişse ilgili port numarasını döndürür.

Belirtilen soket AF_UNIX türündeyse bu değiştirgede (/var/run/daemon.sock gibi) bir Unix dosya yolu döner.

port

Belirtilmişse ilgili port değeri bu değiştirgeye konur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. Soket AF_INET, AF_INET6 veya AF_UNIX türünde değilse işlev FALSE döndürebilir, ancak böyle bir durumda son soket hata kodu güncellenmez.

Notlar

Bilginize:

socket_getpeername() işlevi socket_connect() ile oluşturulan AF_UNIX soketlerle kullanılmamalıdır. Sadece socket_accept() ile oluşturulan soketler ve socket_bind() çağrısından sonra bir birincil sunucu soketi için anlamlı bir değer döner.

Ayrıca Bakınız

  • socket_getsockname() - Belirtilen soketin yerel tarafını sorgulayıp soket türüne göre ya bir konak/port çifti ya da bir Unix dosya yolu döndürür
  • socket_last_error() - Soket üzerindeki son hatanın kodunu döndürür
  • socket_strerror() - Bir soket hatasıyla ilgili açıklamayı döndürür

socket_getopt
socket_getsockname
Soket İşlevleri


Belirtilen soketin yerel tarafını sorgulayıp soket türüne göre ya bir konak/port çifti ya da bir Unix dosya yolu döndürür

socket_getpeername
socket_import_stream
Soket İşlevleri
PHP Manual

socket_getsockname

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

socket_getsockname — Belirtilen soketin yerel tarafını sorgulayıp soket türüne göre ya bir konak/port çifti ya da bir Unix dosya yolu döndürür

Açıklama

bool socket_getsockname ( resource $soket , string &$adres [, int &$port ] )

Bilginize: socket_getsockname() işlevi socket_connect() ile oluşturulan AF_UNIX soketlerle kullanılmamalıdır. Sadece socket_accept() ile oluşturulan soketler ve socket_bind() çağrısından sonra bir birincil sunucu soketi için anlamlı bir değer döner.

Değiştirgeler

soket

socket_create() veya socket_accept() ile oluşturulmuş geçerli bir soket özkaynağı.

adres

Belirtilen soket AF_INET veya AF_INET6 türündeyse socket_getsockname() işlevi, bu değiştirgede bir IP adresi (127.0.0.1 veya fe80::1 gibi) ve port değiştirgesinde de belirtilmişse ilgili port numarasını döndürür.

Belirtilen soket AF_UNIX türündeyse bu değiştirgede (/var/run/daemon.sock gibi) bir Unix dosya yolu döner.

port

Belirtilmişse ilgili port değeri bu değiştirgeye konur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. Soket AF_INET, AF_INET6 veya AF_UNIX türünde değilse işlev FALSE döndürebilir, ancak böyle bir durumda son soket hata kodu güncellenmez.

Ayrıca Bakınız

  • socket_getpeername() - Belirtilen soketin yerel tarafını sorgulayıp soket türüne göre ya bir konak/port çifti ya da bir Unix dosya yolu döndürür
  • socket_last_error() - Soket üzerindeki son hatanın kodunu döndürür
  • socket_strerror() - Bir soket hatasıyla ilgili açıklamayı döndürür

socket_getpeername
socket_import_stream
Soket İşlevleri


Import a stream

socket_getsockname
socket_last_error
Soket İşlevleri
PHP Manual

socket_import_stream

(PHP 5 >= 5.4.0, PHP 7)

socket_import_stream — Import a stream

Açıklama

resource socket_import_stream ( resource $stream )

Imports a stream that encapsulates a socket into a socket extension resource.

Değiştirgeler

stream

The stream resource to import.

Dönen Değerler

Returns FALSE or NULL on failure.

Örnekler

Örnek 1 socket_import_stream() example

<?php
$stream = stream_socket_server("udp://0.0.0.0:58380", $errno, $errstr, STREAM_SERVER_BIND);
$sock   = socket_import_stream($stream);
?>

Ayrıca Bakınız

  • stream_socket_server() - Bir Genel Ağ veya Unix alan sunucusu soketi oluşturur

socket_getsockname
socket_last_error
Soket İşlevleri


Soket üzerindeki son hatanın kodunu döndürür

socket_import_stream
socket_listen
Soket İşlevleri
PHP Manual

socket_last_error

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

socket_last_error — Soket üzerindeki son hatanın kodunu döndürür

Açıklama

int socket_last_error ([ resource $soket ] )

İşlev soket değiştirgesi belirtilerek kullanılırsa belirtilen soket üzerinde son oluşan hatanın kodu döndürülür. Bir soket belirtilmezse başarısız olan son işlemle ilgili hata numarası döner. İkincisi, bir hata durumunda bir soket döndürmeyen socket_create() ve belli bir soketle doğrudan ilişkili olmayan bir sebeple başarısız olabilen socket_select() gibi işlevler için yararlıdır. Elde edilen hata kodunu socket_strerror() işlevinde kullanarak hatanın açıklamasına içeren bir dizge almak mümkündür.

Değiştirgeler

soket

socket_create() ile oluşturulmuş geçerli bir soket özkaynağı.

Dönen Değerler

Bir soket hata kodu döner.

Örnekler

Örnek 1 - socket_last_error() örneği

<?php
$socket = @socket_create(AF_INET, SOCK_STREAM, SOL_TCP);

if ($socket === false) {
    $errorcode = socket_last_error();
    $errormsg = socket_strerror($errorcode);

    die("Soket oluşturulamadı: [$errorcode] $errormsg");
}
?>

Notlar

Bilginize:

socket_last_error() hata kodunu temizlemez, bunun için socket_clear_error() işlevini kullanın.

socket_import_stream
socket_listen
Soket İşlevleri


Bir soketi bağlantı kabul etmek için dinler

socket_last_error
socket_read
Soket İşlevleri
PHP Manual

socket_listen

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

socket_listen — Bir soketi bağlantı kabul etmek için dinler

Açıklama

bool socket_listen ( resource $soket [, int $kuyruk = 0 ] )

socket_create() ile bir soket oluşturulup socket_bind() işlevini kullanarak bir isimle ilişkilendirilince soket bir dinlenen soket haline gelir.

socket_listen() sadece SOCK_STREAM ve SOCK_SEQPACKET türündeki soketlere uygulanabilir.

Değiştirgeler

soket

socket_create() ile oluşturulmuş geçerli bir soket özkaynağı.

kuyruk

İşlem için kuyruğa alınacak azami gelen bağlantı sayısı. Dolmuş bir kuyruğa gelen bir bağlantı ya ECONNREFUSED belirten bir hata alır ya da ilgili protokol yeniden bağlanmayı destekliyorsa yineleme başarılı olacağından istek yok sayılır.

Bilginize:

kuyruk değiştirgesine atanacak değer çalışılan platforma büyük oranda bağımlıdır. Linux üzerinde kendiliğinden SOMAXCONN'a düşürülür. Win32 üzerinde SOMAXCONN atanırsa makul bir azami değer kullanımından ilgili hizmet sağlayıcı sorumludur. Windows üzerinde bu değer için standart bir yaklaşım yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. Hata kodu socket_last_error() işlevi ile alınabilir. Bu hata kodunu socket_strerror() işlevine aktararak hatayı açıklayan dizgeyi alabilirsiniz.

Ayrıca Bakınız

  • socket_accept() - Soket üzerinden bağlantı kabul eder
  • socket_bind() - Soketi bir isimle ilişkilendirir
  • socket_connect() - Soket üzerinde bir bağlantıyı ilklendirir
  • socket_create() - Bir soket oluşturur (iletişim için bir uç)
  • socket_strerror() - Bir soket hatasıyla ilgili açıklamayı döndürür

socket_last_error
socket_read
Soket İşlevleri


Bir soketten belli sayıda bayta kadar okuma yapar

socket_listen
socket_recv
Soket İşlevleri
PHP Manual

socket_read

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

socket_read — Bir soketten belli sayıda bayta kadar okuma yapar

Açıklama

string socket_read ( resource $soket , int $uzunluk [, int $tür = PHP_BINARY_READ ] )

socket_create() veya socket_accept() işleviyle oluşturulmuş soket özkaynağından veri okur.

Değiştirgeler

soket

socket_create() veya socket_accept() ile oluşturulmuş geçerli bir soket özkaynağı.

uzunluk

Okunacak azami bayt sayısını belirler. Belirtilmediği takdirde, okumayı bitirmek için tür değiştirgesine bağlı olarak \r, \n veya \0 kullanabilirsiniz (aşağıya bakınız).

tür

Belirtilmesi isteğe bağlı olup şu sabitlerden biri olabilir:

  • PHP_BINARY_READ (Öntanımlı) - Sistemin recv() işlevi kullanılır. İkil veri okumak için güvenlidir.
  • PHP_NORMAL_READ - Okuma \n veya \r karakterinde durur.

Dönen Değerler

Başarı durumunda veriyi bir dizge olarak döndürür, aksi takdirde FALSE ile döner. Hata kodu socket_last_error() işlevi ile alınabilir. Bu hata kodunu socket_strerror() işlevine aktararak hatayı açıklayan dizgeyi alabilirsiniz.

Bilginize:

socket_read() okunacak veri yoksa sıfır uzunlukta bir dizge ("") döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
4.1.0 | tür değiştirgesinin öntanımlı değeri PHP_NORMAL_READ iken PHP_BINARY_READ oldu.

Ayrıca Bakınız

  • socket_accept() - Soket üzerinden bağlantı kabul eder
  • socket_bind() - Soketi bir isimle ilişkilendirir
  • socket_connect() - Soket üzerinde bir bağlantıyı ilklendirir
  • socket_listen() - Bir soketi bağlantı kabul etmek için dinler
  • socket_last_error() - Soket üzerindeki son hatanın kodunu döndürür
  • socket_strerror() - Bir soket hatasıyla ilgili açıklamayı döndürür
  • socket_write() - Bir sokete yazar

socket_listen
socket_recv
Soket İşlevleri


Bağlı bir soketten veri alır

socket_read
socket_recvfrom
Soket İşlevleri
PHP Manual

socket_recv

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

socket_recv — Bağlı bir soketten veri alır

Açıklama

int socket_recv ( resource $soket , string &$tampon , int $uzunluk , int $seçenekler )

socket_recv() işlevi soket ile belirtilen soketten tampon içindeki uzunluk baytı okur. socket_recv() ayrıca, bağlantılı soketlerden veri toplama için de kullanılır. Buna ek olarak işlevin davranışlarında değişiklik yapmak için bir veya daha fazla sayıda seçenek belirtilebilir.

tampon gönderimli aktarılır, dolayısıyla işlevin değiştirgeleri arasında bir değişken olarak yer almalıdır. socket_recv() tarafından socket soketinden okunan veri tampon'a konarak döndürülür.

Değiştirgeler

socket

socket_create() ile oluşturulmuş geçerli bir soket özkaynağı.

tampon

Verinin alınacağı değişken burada belirtilir. Bir hata oluşursa, bağlantı kesilirse veya alınacak bir veri yoksa tampon içeriği olarak NULL atanır.

uzunluk

Okunacak azami bayt sayısını belirler.

seçenekler

Aşağıdaki seçeneklerin bitsel VEYAlanmış bir birleşimi.

Olası seçenekler
MSG_OOB | Band dışı veri gönderilir.
MSG_EOR | Bir kayıt imi belirtir. Gönderilen veri kaydın tamamlanmasını sağlar.
MSG_EOF | Soketin gönderici tarafı kapatılır ve gönderilen verinin sonuna bununla ilgili bir bildirim yerleştirilir. Gönderilen veri aktarımın tamamlanmasını sağlar.
MSG_DONTROUTE | Yönlendirme es geçilip doğrudan arabirim kullanılır.

Dönen Değerler

Bir hata oluşmuşsa FALSE yoksa alınan bayt sayısını döndürür. Oluşan hatanın kodu socket_last_error() ile açıklaması ise, elde edilen hata kodu socket_strerror() işlevine aktarılarak alınabilir.

Örnekler

Örnek 1 - socket_recv() örneği

Bu örnek, Örnekler arasında socket_recv() kullanan ilk örneğin yeniden yazılmışıdır.

<?php
error_reporting(E_ALL);

echo "<h2>TCP/IP Bağlantısı</h2>\n";

/* HTTP hizmeti için portu öğrenelim. */
$service_port = getservbyname('www', 'tcp');

/* Hedef konağın IP adresini alalım. */
$address = gethostbyname('www.example.com');

/* Bir TCP/IP soketi oluşturalım. */
$socket = socket_create(AF_INET, SOCK_STREAM, SOL_TCP);
if ($socket === false) {
    echo "socket_create() başısız oldu: sebep: " .
    socket_strerror(socket_last_error()) . "\n";
} else {
    echo "OK.\n";
}

echo "'$service_port' portundun '$address' adresine bağlanmaya çalışılıyor...";
$result = socket_connect($socket, $address, $service_port);
if ($result === false) {
    echo "socket_connect() başısız oldu:\nSebep: ($result) " .
    socket_strerror(socket_last_error($socket)) . "\n";
} else {
    echo "OK.\n";
}

$in = "HEAD / HTTP/1.1\r\n";
$in .= "Host: www.example.com\r\n";
$in .= "Connection: Close\r\n\r\n";
$out = '';

echo "HTTP HEAD isteğini gönderelim...";
socket_write($socket, $in, strlen($in));
echo "OK.\n";

echo "Yanıtı okuyalım:\n\n";
$buf = 'Bu bir veri tamponu verisidir.';
if (false !== ($bytes = socket_recv($socket, $buf, 2048, MSG_WAITALL))) {
    echo "Read $bytes bytes from socket_recv(). Closing socket...";
} else {
    echo "socket_recv() failed; reason: " .
    socket_strerror(socket_last_error($socket)) . "\n";
}
socket_close($socket);

echo $buf . "\n";
echo "OK.\n\n";
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

<h2>TCP/IP Bağlantısı</h2>
OK.
'80' portundan '208.77.188.166' adresine bağlanmaya çalışılıyor...OK.
HTTP HEAD isteği gönderiliyor...OK.
Okunan yanıt:

Soket kapatıyor...HTTP/1.1 200 OK
Date: Mon, 14 Sep 2009 08:56:36 GMT
Server: Apache/2.2.3 (Red Hat)
Last-Modified: Tue, 15 Nov 2005 13:24:10 GMT
ETag: "b80f4-1b6-80bfd280"
Accept-Ranges: bytes
Content-Length: 438
Connection: close
Content-Type: text/html; CHARSET=Windows-1254

OK.

socket_read
socket_recvfrom
Soket İşlevleri


Bağlantılı olsun olmasın bir soketten veri alır

socket_recv
socket_recvmsg
Soket İşlevleri
PHP Manual

socket_recvfrom

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

socket_recvfrom — Bağlantılı olsun olmasın bir soketten veri alır

Açıklama

int socket_recvfrom ( resource $soket , string &$tmmpon , int $uzunluk , int $seçenekler , string &$isim [, int &$port ] )

socket_recvfrom() işlevi belirtilen soket üzerinden tampon tamponundan uzunluk baytlık veriyi port. porttaki isim'den alır. İşlev bağlantılı (tcp) ve bağlantısız (udp) soketlerle çalışabilir. Ayrıca, bazı seçeneklerle işlevin davranışında değişiklik yapılabilir.

isim ve port gönderimli aktarılmalıdır. Soket bağlantı yönelimli değilse isim değiştirgesine uzak konağın IP adresi veya Unix soketinin dosya yolu atanacaktır. Soketin bağlantı yönelimli olması durumunda isim NULL'dur. Bunun yanında, soketin bir bağlantısız AF_INET veya AF_INET6 soket olması durumunda port uzak konağın port numarasını içerecektir.

Değiştirgeler

soket

socket_create() ile oluşturulmuş geçerli bir soket özkaynağı.

tampon

Alınan verinin yerleştirileceği tampon.

uzunluk

Uzak konaktan alınacak azami bayt sayısı.

seçenekler

Aşağıdaki değerlerin bitsel VEYAlanmış (|) bir birleşimi olabilir

Olası seçenekler
Seçenek | Açıklama
MSG_OOB | Band dışı veri işlenir.
MSG_PEEK | Veri alım kuyruğunun başlangıcından alınırken kuyruktan silinmez.
MSG_WAITALL | uzunluk bayt alınıncaya kadar soket baskılanır. Ancak, bir sinyal alınırsa veya uzak konak bağlantıyı keserse işlev daha az veriyle dönebilir.
MSG_DONTWAIT | İşlev bekleme kipinde olsa bile bu seçenek işlevin beklemeden dönmesine sebep olur.
isim

Soket AF_UNIX türündeyse dosya yolu, bağlantısız soketse uzak konağın IP adresi, bağlantı yönelimli bir soketse NULL'dur.

port

Sadece AF_INET ve AF_INET6 soketlere uygulanır ve verinin alındığı uzak portu belirtir. Soket bağlantı yönelimli ise port NULL olacaktır.

Dönen Değerler

socket_recvfrom() işlevi alınan bayt sayısını döndürür. Bir hata oluşmuşsa FALSE döner. Hata kodu socket_last_error() işlevi ile alınabilir. Bu hata kodunu socket_strerror() işlevine aktararak hatayı açıklayan dizgeyi alabilirsiniz.

Örnekler

Örnek 1 - socket_recvfrom() örneği

<?php
error_reporting(E_ALL | E_STRICT);

$socket = socket_create(AF_INET, SOCK_DGRAM, SOL_UDP);
socket_bind($socket, '127.0.0.1', 1223);

$from = '';
$port = 0;
socket_recvfrom($socket, $buf, 12, 0, $from, $port);

echo "$from adresinin $port. portundan $buf bayt alındı" . PHP_EOL;
?>

Bu örnek 127.0.0.1 adresindeki 1223. port üzerinde bir UDP portu oluşturup uzak konaktan alınacak 12 bayta kadar veriyi gösterir.

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.0 | socket_recvfrom() artık ikil olarak güvenli.

Ayrıca Bakınız

  • socket_recv() - Bağlı bir soketten veri alır
  • socket_send() - Bağlı bir sokete veri gönderir
  • socket_sendto() - Bağlı olsun olmasın bir sokete ileti gönderir
  • socket_create() - Bir soket oluşturur (iletişim için bir uç)

socket_recv
socket_recvmsg
Soket İşlevleri


Read a message

socket_recvfrom
socket_select
Soket İşlevleri
PHP Manual

socket_recvmsg

(PHP 5 >= 5.5.0, PHP 7)

socket_recvmsg — Read a message

Açıklama

int socket_recvmsg ( resource $socket , string $message [, int $flags ] )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

socket

message

flags

Dönen Değerler

Ayrıca Bakınız

  • socket_sendmsg() - Send a message
  • socket_cmsg_space() - Calculate message buffer size

socket_recvfrom
socket_select
Soket İşlevleri


Belirtilen soket dizileri üzerinde belirtilen zaman aşımı ile select() sistem çağrısını çalıştırır

socket_recvmsg
socket_send
Soket İşlevleri
PHP Manual

socket_select

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

socket_select — Belirtilen soket dizileri üzerinde belirtilen zaman aşımı ile select() sistem çağrısını çalıştırır

Açıklama

int socket_select ( array &$oku , array &$yaz , array &$diğer , int $tv_sec [, int $tv_usec = 0 ] )

socket_select() işlevi değiştirge olarak soket dizileri alır ve durumları değişinceye kadar bekler. Soket özkaynakları BSD soketlerinden kaynaklanan bir kabulle dosya tanıtıcıları olarak da bilinir. İşleve birbirinden bağımsız üç çeşit soket özkaynağı belirtilebilir.

Değiştirgeler

oku

Karakterlerin okunmaya hazır hale gelmesine kadar (başka bir deyişle, okumanın engellenmediği görülene kadar) dinlenecek soket özkaynakları dizisi. (Okunacak tek şeyin dosyasonu karakteri olduğu durumda socket_read() sıfır uzunlukta bir dizge ile döner.)

yaz

Yazmanın engellenmediği görülene kadar (soket yazmaya hazır hale gelene kadar) dinlenecek soket özkaynakları dizisi.

diğer

Bu dizideki soketler olağan dışı durumlara göre denetlenir.

tv_sec

Saniye cinsinden zaman aşımı. tv_sec ve tv_usec birlikte select() sistem çağrısının zamanaşımı değiştirgesini oluşturur. zamanaşımı, socket_select() dönmeden önce beklenecek azami süreyi belirler. tv_sec sıfır olabilir; bu durumda socket_select() beklemeden döner. Çağrı yinelemek için yararlıdır. tv_sec NULL olduğu takdirde (zaman aşımı yok), socket_select() sonsuza kadar bekleyebilir.

tv_usec

Mikrosaniye cinsinden zaman aşımı. Ayrıntılar için tv_sec değiştirgesine bakınız.

Uyarı

Dönüşte, soket özkaynaklarının durumlarını belirtmek için dizilerde değişiklik yapılır.

socket_select() işlevine üç diziyi de aktarmak zorunda değilsiniz. Kullanmadığınız dizileri boş bırakabilir veya bir dizi yerine NULL belirtebilirsiniz. Ayrıca, bu dizilerin gönderimli aktarılmaları gerektiğine de dikkat ediniz; socket_select() işlevi dönerken soket durumlarını yansıtacak şekilde bu dizilerde değişiklik yapar.

Bilginize:

Zend motorundaki bir sınırlamadan dolayı, bir işleve gönderimli aktarılması gereken bir değiştirge yerine işleve doğrudan NULL sabitini aktarmak mümkün değildir. Bu nedenle işleve değeri NULL olan geçici bir değişken veya son değeri bir değişken olan bir ifade aktarmalısınız:

Örnek 1 - socket_select() ile NULL kullanımı

<?php
$diger = NULL;
socket_select($oku, $yaz, $diger, 0);
?>

Dönen Değerler

Başarı durumunda socket_select(), değişiklik yapılan soketlerin sayısını döndürür. Eğer hiçbir değişiklik olmaksızın zaman aşımı dolmuşsa işlev 0 döndürür. Bir hata durumunda FALSE döner. Hata kodu socket_last_error() ile alınabilir.

Bilginize:

İşlev, 0 değerini anlamlı bir değer olarak döndürdüğünden == işleci ile yapılan bir sınama TRUE ile sonuçlanacağından hata durumunu sınarken === işlecini kullanmalısınız:

Örnek 2 - socket_select() sonucunu anlamak

<?php
$e = NULL;
if (false === socket_select($o, $y, $d, 0)) {
    echo "socket_select() başarısız oldu; sebep: " .
        socket_strerror(socket_last_error()) . "\n";
}
?>

Örnekler

Örnek 3 - socket_select() örneği

<?php
/* Oku dizisini hazırlayalım */
$oku   = array($soket1, $soket2);
$yaz  = NULL;
$diger = NULL;
$degisen_soket_sayısı = socket_select($oku, $yaz, $diger, 0);

if ($degisen_soket_sayısı === false) {
    /* Hata işlemleri */
} else if ($degisen_soket_sayısı > 0) {
    /* En azından bir sokette bir şeyler olmuş */
}
?>

Notlar

Bilginize:

Bazı soket gerçeklenimlerinin çok dikkatli olmayı gerektirdiğini bilmenizde yarar var. Bir kaç temel kural:

  • socket_select() işlevini daima zaman aşımsız kullanmaya çalışın. İşe yarar bir veri yoksa betiğiniz hiçbir işlem yapmamalıdır. Zaman aşımlarına bağımlı bir kod taşınabilir değildir ve hata ayıklamak çok zor olur.
  • socket_select() çağrısından sonra üzerinde hiçbir işlem yapmayacağınız soket özkaynaklarını hiçbir diziye eklemeyin. socket_select() döndükten sonra tüm soket özkaynaklarına mutlaka bakılmalıdır. Yazmaya hazır soketlere yazılmalı, okunmaya hazır soketler okunmalıdır.
  • Diziden dönen bir sokete oku veya yaz işlemi yapacaksanız verinin tamamını okumak veya yazmak zorunda değilsiniz. Sadece bir bayt okumaya veya yazmaya bile hazır olmalısınız.
  • Hemen tüm soket gerçeklenimlerinde diğer dizisindeki soketlerin band dışı verilerle ilgili olduğu varsayılır.

Ayrıca Bakınız

  • socket_read() - Bir soketten belli sayıda bayta kadar okuma yapar
  • socket_write() - Bir sokete yazar
  • socket_last_error() - Soket üzerindeki son hatanın kodunu döndürür
  • socket_strerror() - Bir soket hatasıyla ilgili açıklamayı döndürür

socket_recvmsg
socket_send
Soket İşlevleri


Bağlı bir sokete veri gönderir

socket_select
socket_sendmsg
Soket İşlevleri
PHP Manual

socket_send

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

socket_send — Bağlı bir sokete veri gönderir

Açıklama

int socket_send ( resource $soket , string $tampon , int $uzunluk , int $seçenekler )

socket_send() işlevi tampon tamponundaki verinin uzunluk baytını soket ile belirtilen sokete gönderir.

Değiştirgeler

soket

socket_create() veya socket_accept() ile oluşturulmuş geçerli bir soket özkaynağı.

tampon

Uzak konağa gönderilecek veriyi içeren tampon.

uzunluk

Uzak konağa gönderilecek bayt sayısı.

seçenekler

Aşağıdaki seçeneklerin bitsel VEYAlanmış bir birleşimi.

Olası seçenekler
MSG_OOB | Band dışı veri gönderilir.
MSG_EOR | Bir kayıt imi belirtir. Gönderilen veri kaydın tamamlanmasını sağlar.
MSG_EOF | Soketin gönderici tarafı kapatılır ve gönderilen verinin sonuna bununla ilgili bir bildirim yerleştirilir. Gönderilen veri aktarımın tamamlanmasını sağlar.
MSG_DONTROUTE | Yönlendirme es geçilip doğrudan arabirim kullanılır.

Dönen Değerler

Bir hata oluşursa FALSE yoksa gönderilen bayt sayısı döner.

Ayrıca Bakınız

  • socket_sendto() - Bağlı olsun olmasın bir sokete ileti gönderir

socket_select
socket_sendmsg
Soket İşlevleri


Send a message

socket_send
socket_sendto
Soket İşlevleri
PHP Manual

socket_sendmsg

(PHP 5 >= 5.5.0, PHP 7)

socket_sendmsg — Send a message

Açıklama

int socket_sendmsg ( resource $socket , array $message , int $flags )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

socket

message

flags

Dönen Değerler

Returns the number of bytes sent, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • socket_recvmsg() - Read a message
  • socket_cmsg_space() - Calculate message buffer size

socket_send
socket_sendto
Soket İşlevleri


Bağlı olsun olmasın bir sokete ileti gönderir

socket_sendmsg
socket_set_block
Soket İşlevleri
PHP Manual

socket_sendto

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

socket_sendto — Bağlı olsun olmasın bir sokete ileti gönderir

Açıklama

int socket_sendto ( resource $soket , string $tampon , int $uzunluk , int $seçenekler , string $adres [, int $port = 0 ] )

socket_sendto() işlevi tampon tamponundaki verinin uzunluk baytını soket üzerinden adres adresindeki port. porta gönderir.

Değiştirgeler

soket

socket_create() ile oluşturulmuş geçerli bir soket özkaynağı.

tampon

Veri bu tampondan gönderilir.

uzunluk

Gönderilecek bayt sayısı.

seçenekler

Aşağıdaki seçeneklerin bitsel VEYAlanmış bir birleşimi.

Olası seçenekler
MSG_OOB | Band dışı veri gönderilir.
MSG_EOR | Bir kayıt imi belirtir. Gönderilen veri kaydın tamamlanmasını sağlar.
MSG_EOF | Soketin gönderici tarafı kapatılır ve gönderilen verinin sonuna bununla ilgili bir bildirim yerleştirilir. Gönderilen veri aktarımın tamamlanmasını sağlar.
MSG_DONTROUTE | Yönlendirme es geçilip doğrudan arabirim kullanılır.

adres

Uzak konağın IP adresi.

port

Verinin gönderileceği uzak portun numarası.

Dönen Değerler

Bir hata oluşmuşsa FALSE, yoksa gönderilen bayt sayısı döner.

Örnekler

Örnek 1 - socket_sendto() örneği

<?php
    $sock = socket_create(AF_INET, SOCK_DGRAM, SOL_UDP);

    $msg = "Ping !";
    $len = strlen($msg);

    socket_sendto($sock, $msg, $len, 0, '127.0.0.1', 1223);
    socket_close($sock);
?>

Ayrıca Bakınız

  • socket_send() - Bağlı bir sokete veri gönderir

socket_sendmsg
socket_set_block
Soket İşlevleri


Soketi engelleme kipine sokar

socket_sendto
socket_set_nonblock
Soket İşlevleri
PHP Manual

socket_set_block

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

socket_set_block — Soketi engelleme kipine sokar

Açıklama

bool socket_set_block ( resource $soket )

Belirtilen soket üzerinden O_NONBLOCK seçeneğini kaldırır.

Bir engellenen soket üzerinde yapılan işlemler (bağlanma, kabul, alım, gönderim gibi) sırasında bir sinyal gelmedikçe, okunacak veri yoksa veya veri yazılamıyorsa betik işlem başlayana kadar bekler.

Değiştirgeler

soket

socket_create() veya socket_accept() ile oluşturulmuş geçerli bir soket özkaynağı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - socket_set_block() örneği

<?php
$socket = socket_create_listen(1223);
socket_set_block($socket);

socket_accept($socket);
?>

Bu örnekte, tüm arabirimlerin 1223. portunda bir dinleme soketi oluşturulmakta ve soket bekleme kipine (O_BLOCK) alınmaktadır. socket_accept() kabul edilecek bir bağlantı olana kadar bekleyecektir.

Ayrıca Bakınız

  • socket_set_nonblock() - Belirtilen dosya tanıtıcısı için beklememe kipini etkinleştirir
  • socket_set_option() - Soketle ilgili seçenekleri belirler

socket_sendto
socket_set_nonblock
Soket İşlevleri


Belirtilen dosya tanıtıcısı için beklememe kipini etkinleştirir

socket_set_block
socket_set_option
Soket İşlevleri
PHP Manual

socket_set_nonblock

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

socket_set_nonblock — Belirtilen dosya tanıtıcısı için beklememe kipini etkinleştirir

Açıklama

bool socket_set_nonblock ( resource $soket )

soket ile belirtilen sokete O_NONBLOCK seçeneğini atar (beklememe kipini etkin kılar; başka bir deyişle soketi engellenmeyen kipe sokar).

Bir engellenmeyen soket üzerinde yapılan işlemler (bağlanma, kabul, alım, gönderim gibi) sırasında bir sinyal gelmedikçe, okunacak veri yoksa veya veri yazılamıyorsa betik işlemin başlamasını beklemez ve böyle bir durumda ilgili işlev çağrısı (bu işlev değil) başarısız olur.

Değiştirgeler

soket

socket_create() veya socket_accept() ile oluşturulmuş geçerli bir soket özkaynağı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - socket_set_nonblock() örneği

<?php
$soket = socket_create_listen(1223);
socket_set_nonblock($soket);

socket_accept($soket);
?>

Bu örnekte, tüm arabirimlerin 1223. portunda bir dinleme soketi oluşturulmakta ve soket beklememe kipine (O_NONBLOCK) alınmaktadır. Bu anda bekleyen bir bağlantı yoksa socket_accept() bir zamanaşımı beklemeksizin başarısız olur.

Ayrıca Bakınız

  • socket_set_block() - Soketi engelleme kipine sokar
  • socket_set_option() - Soketle ilgili seçenekleri belirler

socket_set_block
socket_set_option
Soket İşlevleri


Soketle ilgili seçenekleri belirler

socket_set_nonblock
socket_setopt
Soket İşlevleri
PHP Manual

socket_set_option

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

socket_set_option — Soketle ilgili seçenekleri belirler

Açıklama

bool socket_set_option ( resource $soket , int $seviye , int $seçenek , mixed $değer )

Belirtilen soket'in seçenek seçeneğine belirtilen protokol seviye'si için değer değerini atar.

Değiştirgeler

soket

socket_create() veya socket_accept() ile oluşturulmuş geçerli bir soket özkaynağı.

seviye

Seçeneğin geçerli olacağı protokol seviyesi. Örneğin soket seviyesindeki seçenekleri almak için bu değiştirgede SOL_SOCKET kullanılabilirdi. TCP gibi diğer seviyeler, seviyenin protokol numarası belirtilerek kullanılabilir. Protokol numaralarını getprotobyname() işleviyle alabilirsiniz.

seçenek

socket_get_option() işleviyle alınan soket seçeneklerinden biri olmalıdır.

değer

Seçeneğin değeri.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - socket_set_option() örneği

<?php
$socket = socket_create(AF_INET, SOCK_STREAM, SOL_TCP);

if (!is_resource($socket)) {
    echo 'Soket oluşturulamadı: '.
          socket_strerror(socket_last_error()) . PHP_EOL;
}

if (!socket_set_option($socket, SOL_SOCKET, SO_REUSEADDR, 1)) {
    echo 'Sokete seçenek atanamadı: '.
          socket_strerror(socket_last_error()) . PHP_EOL;
}

if (!socket_bind($socket, '127.0.0.1', 1223)) {
    echo 'Sokete bağlanılamadı: '.
          socket_strerror(socket_last_error()) . PHP_EOL;
}

$rval = socket_get_option($socket, SOL_SOCKET, SO_REUSEADDR);

if ($rval === false) {
    echo 'Soket seçeneği alınamadı: '.
          socket_strerror(socket_last_error()) . PHP_EOL;
} else if ($rval !== 0) {
    echo 'Sokete SO_REUSEADDR atandı!' . PHP_EOL;
}
?>

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.0 | İşlevin ismi değişti. Eski ismi socket_setopt() idi.

socket_set_nonblock
socket_setopt
Soket İşlevleri


Takma Adı: socket_set_option

socket_set_option
socket_shutdown
Soket İşlevleri
PHP Manual

socket_setopt

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

socket_setopt — Takma Adı: socket_set_option()

Açıklama

Bu işlev şu işlevin takma adıdır: socket_set_option().

socket_set_option
socket_shutdown
Soket İşlevleri


Bir soketi kapatır

socket_setopt
socket_strerror
Soket İşlevleri
PHP Manual

socket_shutdown

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

socket_shutdown — Bir soketi kapatır

Açıklama

bool socket_shutdown ( resource $scket [, int $kip = 2 ] )

Gelen, giden veya tüm verilerin (öntanımlı) soket üzerinden gönderimini durdurur.

Değiştirgeler

soket

socket_create() ile oluşturulmuş geçerli bir soket özkaynağı.

kip

Aşağıdaki değerlerden biri olabilir:

Olası kip değerleri
0 | Soket okumaya kapatılır.
1 | Soket yazmaya kapatılır.
2 | Soket yazmaya ve okumaya kapatılır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

socket_setopt
socket_strerror
Soket İşlevleri


Bir soket hatasıyla ilgili açıklamayı döndürür

socket_shutdown
socket_write
Soket İşlevleri
PHP Manual

socket_strerror

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

socket_strerror — Bir soket hatasıyla ilgili açıklamayı döndürür

Açıklama

string socket_strerror ( int $hatanum )

socket_strerror() işlevi hatanum değiştirgesinde socket_last_error() işlevinden döndürülen bir hata kodunu alır ve bununla ilgili açıklamayı döndürür.

Bilginize:

Bu işlevle ilgili sistem iletileri yerele bağlı olarak (LC_MESSAGES) gösterilse de bu eklentinin ürettiği hata iletileri İngilizce'dir.

Değiştirgeler

hatanum

socket_last_error() işlevinden dönen bir hata numarası.

Dönen Değerler

hatanum ile ilgili hata iletisini döndürür.

Örnekler

Örnek 1 - socket_strerror() örneği

<?php
if (false == ($socket = @socket_create(AF_INET, SOCK_STREAM, SOL_TCP))) {
   echo "socket_create() başarısız oldu: Sebep: " .
          socket_strerror(socket_last_error()) . "\n";
}

if (false == (@socket_bind($socket, '127.0.0.1', 80))) {
   echo "socket_bind() başarısız oldu: Sebep: " .
          socket_strerror(socket_last_error($socket)) . "\n";
}
?>

Betiğin root yetkileriyle çalışmadığı varsayımıyla çıktı şöyle olurdu:

socket_bind() başarısız oldu: Sebep: Permission denied

Ayrıca Bakınız

  • socket_accept() - Soket üzerinden bağlantı kabul eder
  • socket_bind() - Soketi bir isimle ilişkilendirir
  • socket_connect() - Soket üzerinde bir bağlantıyı ilklendirir
  • socket_listen() - Bir soketi bağlantı kabul etmek için dinler
  • socket_create() - Bir soket oluşturur (iletişim için bir uç)

socket_shutdown
socket_write
Soket İşlevleri


Bir sokete yazar

socket_strerror
SSH2
Soket İşlevleri
PHP Manual

socket_write

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

socket_write — Bir sokete yazar

Açıklama

int socket_write ( resource $soket , string $tampon [, int $uzunluk = 0 ] )

Belirtilen tampon'u belirtilen soket'e yazar.

Değiştirgeler

soket

Tamponun yazılacağı soket.

tampon

Sokete yazılacak veri.

uzunluk

Belirtilmesi isteğe bağlı olup, sokete yazılacak bayt sayısını belirler. Tampon uzunluğundan büyükse tampon uzunluğundan fazlası yok sayılır.

Dönen Değerler

Bir hata oluşmuşsa FALSE yoksa sokete başarıyla yazılan bayt sayısı döner. Hata kodu socket_last_error() işleviyle alınabilir. Bu kod socket_strerror() işlevine aktarılarak hata açıklaması alınablir.

Bilginize:

Hiçbir baytın yazılmadığı anlamına gelen 0 dönüş değeri oldukça geçerli bir dönüş değeridir. Bu bakımdan FALSE değerini sınamak için === işlecini kullanmalısınız.

Notlar

Bilginize:

socket_write() işlevinin tampondaki tüm baytları yazması gerekli değildir. Ağ üzerindeki tamponlara ve benzerlerine bağlı olarak verinin belli bir miktarı hatta tampon çok daha büyük olsa bile sadece bir bayt yazılması bile başarılı bir işlem kabul edilir. Bu bakımdan yazılan bayt sayısını denetleyerek verinin kalanını aktarmayı unutmayın.

Ayrıca Bakınız

  • socket_accept() - Soket üzerinden bağlantı kabul eder
  • socket_bind() - Soketi bir isimle ilişkilendirir
  • socket_connect() - Soket üzerinde bir bağlantıyı ilklendirir
  • socket_listen() - Bir soketi bağlantı kabul etmek için dinler
  • socket_read() - Bir soketten belli sayıda bayta kadar okuma yapar
  • socket_strerror() - Bir soket hatasıyla ilgili açıklamayı döndürür

socket_strerror
SSH2
Soket İşlevleri


Güvenli Kabuk 2

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • SSH2 İşlevleri
    • ssh2_auth_agent — Authenticate over SSH using the ssh agent
    • ssh2_auth_hostbased_file — Bir genel konak anahtarı kullanarak kimlik doğrulaması yapar
    • ssh2_auth_none — "none" kimlik doğrulaması yapar
    • ssh2_auth_password — Parola kullanarak kimlik doğrulaması yapar
    • ssh2_auth_pubkey_file — Bir genel anahtar kullanarak kimlik doğrulaması yapar
    • ssh2_connect — Bir SSH sunucusuna bağlanır
    • ssh2_exec — Uzak sunucu üzerinde bir komut çalıştırır
    • ssh2_fetch_stream — Başka bir veri akımı döndürür
    • ssh2_fingerprint — Uzak sunucunu parmakizini döndürür
    • ssh2_methods_negotiated — Müzakere yöntemlerini listeler
    • ssh2_publickey_add — Yetkili bir genel anahtar ekler
    • ssh2_publickey_init — Genel anahtar alt sistemini ilklendirir
    • ssh2_publickey_list — Yetkili genel anahtarları listeler
    • ssh2_publickey_remove — Bir genel anahtarı siler
    • ssh2_scp_recv — SCP üzerinden bir dosya alır
    • ssh2_scp_send — SCP üzerinden bir dosya gönderir
    • ssh2_sftp_chmod — Changes file mode
    • ssh2_sftp_lstat — Uzak sunucudaki bir sembolik bağın durum bilgisini döndürür
    • ssh2_sftp_mkdir — Uzak konakta bir dizin oluşturur
    • ssh2_sftp_readlink — Bir sembolik bağın hedefini döndürür
    • ssh2_sftp_realpath — Belirtilen dosya yolu dizgesinden gerçek yolu elde eder
    • ssh2_sftp_rename — Bir uzak dosyanın ismini değiştirir
    • ssh2_sftp_rmdir — Karşıdan bir dizin siler
    • ssh2_sftp_stat — Uzak dosya sistemindeki bir dosyanın durum bilgisini döndürür
    • ssh2_sftp_symlink — Karşıda bir sembolik bağ oluşturur
    • ssh2_sftp_unlink — Bir dosyayı siler
    • ssh2_sftp — SFTP alt sistemini ilklendirir
    • ssh2_shell — Bir etkileşimli kabuk isteği yapar
    • ssh2_tunnel — Uzak bir sunucuya doğru bir tünel açar
socket_write
Giriş
Diğer Hizmetler


Giriş

Bu eklenti, aktarımı şifreleyerek uzak makinelerdeki kaynaklara güvenli bir erişim (kabuk, uzaktan çalıştırma, tünelleme, dosya aktarımı) sağlayan » libssh2 kütüphanesine bir arayüzdür.

SSH2
Yapılandırma/Kurulum
SSH2


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
SSH2


Gereksinimler

» OpenSSL ve » libssh2 kütüphanelerinin ve özellikle de geliştirme paketlerinin (openssl-dev gibi) kurulu olması gerekir.

Bilginize: Libssh2 kütüphanesinin 0.4 ve daha yeni sürümleri gerekli olup pecl/ssh2 eklentisinin yeni çıkacak sürümleri daha yenilerini gerektirebilir (dağıtım bilgilerine bakınız).

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/ssh2.

Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

SSH2_FINGERPRINT_MD5 (integer)
Konak anahtarının parmakizini bir MD5 özeti olarak istemek için ssh2_fingerprint() seçeneği.
SSH2_FINGERPRINT_SHA1 (integer)
Konak anahtarının parmakizini bir SHA1 özeti olarak istemek için ssh2_fingerprint() seçeneği.
SSH2_FINGERPRINT_HEX (integer)
Konak anahtarının parmakizini bir onaltılıklar dizgesi olarak istemek için ssh2_fingerprint() seçeneği.
SSH2_FINGERPRINT_RAW (integer)
Konak anahtarının parmakizini 8 bitlik karakterlerden oluşan bir ham dizge olarak istemek için ssh2_fingerprint() seçeneği.
SSH2_TERM_UNIT_CHARS (integer)
genişlik ve yükseklik değerlerini karakter boyutu olarak belirtmeyi sağlayan ssh2_shell() seçeneği.
SSH2_TERM_UNIT_PIXELS (integer)
genişlik ve yükseklik değerlerini piksel cinsinden belirtmeyi sağlayan ssh2_shell() seçeneği.
SSH2_DEFAULT_TERM_WIDTH (integer)
ssh2_shell() tarafından istenen öntanımlı uçbirim genişliği.
SSH2_DEFAULT_TERM_HEIGHT (integer)
ssh2_shell() tarafından istenen öntanımlı uçbirim yüksekliği.
SSH2_DEFAULT_TERM_UNIT (integer)
ssh2_shell() tarafından istenen öntanımlı uçbirim birimi.
SSH2_STREAM_STDIO (integer)
STDIO isteği yapmak için ssh2_fetch_stream() seçeneği.
SSH2_STREAM_STDERR (integer)
STDERR isteği yapmak için ssh2_fetch_stream() seçeneği.
SSH2_DEFAULT_TERMINAL (string)
ssh2_shell() tarafından istenen öntanımlı uçbirim türü (vt102, ansi, xterm, vanilla gibi).
Özkaynak Türleri
SSH2 İşlevleri
SSH2


SSH2 İşlevleri

İçindekiler

  • ssh2_auth_agent — Authenticate over SSH using the ssh agent
  • ssh2_auth_hostbased_file — Bir genel konak anahtarı kullanarak kimlik doğrulaması yapar
  • ssh2_auth_none — "none" kimlik doğrulaması yapar
  • ssh2_auth_password — Parola kullanarak kimlik doğrulaması yapar
  • ssh2_auth_pubkey_file — Bir genel anahtar kullanarak kimlik doğrulaması yapar
  • ssh2_connect — Bir SSH sunucusuna bağlanır
  • ssh2_exec — Uzak sunucu üzerinde bir komut çalıştırır
  • ssh2_fetch_stream — Başka bir veri akımı döndürür
  • ssh2_fingerprint — Uzak sunucunu parmakizini döndürür
  • ssh2_methods_negotiated — Müzakere yöntemlerini listeler
  • ssh2_publickey_add — Yetkili bir genel anahtar ekler
  • ssh2_publickey_init — Genel anahtar alt sistemini ilklendirir
  • ssh2_publickey_list — Yetkili genel anahtarları listeler
  • ssh2_publickey_remove — Bir genel anahtarı siler
  • ssh2_scp_recv — SCP üzerinden bir dosya alır
  • ssh2_scp_send — SCP üzerinden bir dosya gönderir
  • ssh2_sftp_chmod — Changes file mode
  • ssh2_sftp_lstat — Uzak sunucudaki bir sembolik bağın durum bilgisini döndürür
  • ssh2_sftp_mkdir — Uzak konakta bir dizin oluşturur
  • ssh2_sftp_readlink — Bir sembolik bağın hedefini döndürür
  • ssh2_sftp_realpath — Belirtilen dosya yolu dizgesinden gerçek yolu elde eder
  • ssh2_sftp_rename — Bir uzak dosyanın ismini değiştirir
  • ssh2_sftp_rmdir — Karşıdan bir dizin siler
  • ssh2_sftp_stat — Uzak dosya sistemindeki bir dosyanın durum bilgisini döndürür
  • ssh2_sftp_symlink — Karşıda bir sembolik bağ oluşturur
  • ssh2_sftp_unlink — Bir dosyayı siler
  • ssh2_sftp — SFTP alt sistemini ilklendirir
  • ssh2_shell — Bir etkileşimli kabuk isteği yapar
  • ssh2_tunnel — Uzak bir sunucuya doğru bir tünel açar
Öntanımlı Sabitler
ssh2_auth_agent
SSH2


Authenticate over SSH using the ssh agent

SSH2 İşlevleri
ssh2_auth_hostbased_file
SSH2 İşlevleri
PHP Manual

ssh2_auth_agent

(PECL ssh2 >= 0.12)

ssh2_auth_agent — Authenticate over SSH using the ssh agent

Açıklama

bool ssh2_auth_agent ( resource $session , string $username )

Authenticate over SSH using the ssh agent

Bilginize: The ssh2_auth_agent() function will only be available when the ssh2 extension is compiled with libssh >= 1.2.3.

Değiştirgeler

session

An SSH connection link identifier, obtained from a call to ssh2_connect().

username

Remote user name.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Authenticating with a ssh agent

<?php
$connection = ssh2_connect('shell.example.com', 22);

if (ssh2_auth_agent($connection, 'username')) {
  echo "Authentication Successful!\n";
} else {
  die('Authentication Failed...');
}
?>

SSH2 İşlevleri
ssh2_auth_hostbased_file
SSH2 İşlevleri


Bir genel konak anahtarı kullanarak kimlik doğrulaması yapar

ssh2_auth_agent
ssh2_auth_none
SSH2 İşlevleri
PHP Manual

ssh2_auth_hostbased_file

(PECL ssh2 >= 0.9.0)

ssh2_auth_hostbased_file — Bir genel konak anahtarı kullanarak kimlik doğrulaması yapar

Açıklama

bool ssh2_auth_hostbased_file ( resource $oturum , string $kullanıcı , string $konakadı , string $genel_anh_dosyası , string $gizli_anh_dosyası [, string $anh_parolası [, string $yerel_kullanıcı ]] )

Genel konak anahtarını bir dosyadan okuyarak kimlik doğrulaması yapar.

Değiştirgeler

oturum

ssh2_connect() ile sağlanan bir SSH bağlantı tanıtıcısı.

kullanıcı

konakadı

genel_anh_dosyası

gizli_anh_dosyası

anh_parolası

gizli_anh_dosyası için bir parola kullanılmışsa bu parola bu değiştirgede belirtilmelidir. (SSH oturum anahtarları genelde parolasız oluşturulur).

yerel_kullanıcı

Belirtilmezse yerine kullanıcı kullanılır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Genel konak anahtarlı kimlik doğrulama

<?php
baglanti = ssh2_connect('shell.example.com', 22, array('hostkey'=>'ssh-rsa'));

if (ssh2_auth_hostbased_file(baglanti, 'uzakbirey', 'myhost.example.com',
                             '/usr/local/etc/hostkey_rsa.pub',
                             '/usr/local/etc/hostkey_rsa', 'parola',
                             'yerelbirey')) {
  echo "Kimlik Doğrulaması Başarılı!\n";
} else {
  die('Kimlik Doğrulaması Başarısız...');
}
?>

Notlar

Bilginize:

ssh2_auth_hostbased_file() işlevi libssh2 >= 0.7 ve PHP/SSH2 >= 0.7 gerektirir.

ssh2_auth_agent
ssh2_auth_none
SSH2 İşlevleri


"none" kimlik doğrulaması yapar

ssh2_auth_hostbased_file
ssh2_auth_password
SSH2 İşlevleri
PHP Manual

ssh2_auth_none

(PECL ssh2 >= 0.9.0)

ssh2_auth_none — "none" kimlik doğrulaması yapar

Açıklama

mixed ssh2_auth_none ( resource $oturum , string $kullanıcı )

"none" kimlik doğrulaması genellikle (aslında daima) başarısız olur. Başarısızlıkla ilgili bildirimin bir parçası olarak bu işlev, kabul edilen kimlik doğrulama yöntemlerinin bir listesini döndürür.

Değiştirgeler

oturum

ssh2_connect() ile sağlanan bir SSH bağlantı tanıtıcısı.

kullanıcı

Uzak kullanıcı adı.

Dönen Değerler

Sunucu bir kimlik doğrulama yöntemi olarak "none" kabul ediyorsa TRUE etmiyorsa kabul edilen kimlik doğrulama yöntemlerini içeren bir dizi döner.

Örnekler

Örnek 1 - Kimlik doğrulama yöntemlerinin öğrenilmesi

<?php
$baglanti = ssh2_connect('shell.example.com', 22);

$yontemler = ssh2_auth_none($baglanti, 'birey');

if (in_array('password', $yontemler)) {
  echo "Sunucu parolalı kimlik doğrulamayı destekliyor.\n";
}
?>

ssh2_auth_hostbased_file
ssh2_auth_password
SSH2 İşlevleri


Parola kullanarak kimlik doğrulaması yapar

ssh2_auth_none
ssh2_auth_pubkey_file
SSH2 İşlevleri
PHP Manual

ssh2_auth_password

(PECL ssh2 >= 0.9.0)

ssh2_auth_password — Parola kullanarak kimlik doğrulaması yapar

Açıklama

bool ssh2_auth_password ( resource $oturum , string $kullanıcı , string $parola )

Düz parola kullanarak SSN üzerinden kimlik doğrulaması yapar.

Değiştirgeler

oturum

ssh2_connect() ile sağlanan bir SSH bağlantı tanıtıcısı.

kullanıcı

Uzak konaktaki kullanıcı ismi.

parola

kullanıcı için parola.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Parolalı kimlik doğrulama

<?php
$baglanti = ssh2_connect('shell.example.com', 22);

if (ssh2_auth_password($baglanti, 'birey', 'parola')) {
  echo "Kimlik Doğrulaması Başarılı!\n";
} else {
  die('Kimlik Doğrulaması Başarısız...');
}
?>

ssh2_auth_none
ssh2_auth_pubkey_file
SSH2 İşlevleri


Bir genel anahtar kullanarak kimlik doğrulaması yapar

ssh2_auth_password
ssh2_connect
SSH2 İşlevleri
PHP Manual

ssh2_auth_pubkey_file

(PECL ssh2 >= 0.9.0)

ssh2_auth_pubkey_file — Bir genel anahtar kullanarak kimlik doğrulaması yapar

Açıklama

bool ssh2_auth_pubkey_file ( resource $oturum , string $kullanıcı , string $genel_anh_dosyası , string $gizli_anh_dosyası [, string $anh_parolası ] )

Genel anahtarı bir dosyadan okuyarak kimlik doğrulaması yapar.

Değiştirgeler

oturum

ssh2_connect() ile sağlanan bir SSH bağlantı tanıtıcısı.

kullanıcı

genel_anh_dosyası

gizli_anh_dosyası

anh_parolası

gizli_anh_dosyası için bir parola kullanılmışsa bu parola bu değiştirgede belirtilmelidir. (SSH oturum anahtarları genelde parolasız oluşturulur).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Genel anahtarlı kimlik doğrulama

<?php
$baglanti = ssh2_connect('shell.example.com', 22,
              array('hostkey'=>'ssh-rsa'));

if (ssh2_auth_pubkey_file($baglanti, 'birey',
                          '/home/birey/.ssh/id_rsa.pub',
                          '/home/birey/.ssh/id_rsa', 'secret')) {
  echo "Genel anahtarlı kimlik doğrulama başarılı oldu\n";
} else {
  die('Genel anahtarlı kimlik doğrulama başarısız oldu');
}
?>

ssh2_auth_password
ssh2_connect
SSH2 İşlevleri


Bir SSH sunucusuna bağlanır

ssh2_auth_pubkey_file
ssh2_exec
SSH2 İşlevleri
PHP Manual

ssh2_connect

(PECL ssh2 >= 0.9.0)

ssh2_connect — Bir SSH sunucusuna bağlanır

Açıklama

resource ssh2_connect ( string $konak [, int $port = 22 [, array $yöntemler [, array $geriçağırımlar ]]] )

Bir uzak SSH sunucusuna bağlanıp bir bağlantı özkaynağı döndürür.

Bağlantı sağlanır sağlanmaz, istemcinin ssh2_fingerprint() işlevini kullanarak konak anahtarını ve ardından parola veya genel anahtarla kullanıcı kimliğini doğrulaması gerekir.

Değiştirgeler

konak

port

yöntemler

Aşağıda açıklanan dört değiştirgeden bazılarını içeren bir ilişkisel dizi.

Yöntemler
İndis | Anlamı | Desteklenen değerler*
kex | Anahtar müzakere yöntemlerinin listesi; tercih sırasına göre dizilmiş virgül ayraçlı bir listedir. | diffie-hellman-group1-sha1, diffie-hellman-group14-sha1 ve diffie-hellman-group-exchange-sha1
hostkey | Müzakere edilecek konak anahtarı yöntemlerinin listesi; tercih sırasına göre dizilmiş bir listedir. | ssh-rsa ve ssh-dss
client_to_server | İstemciden sunucuya gönderilen iletiler için şifreleme, sıkıştırma ve ileti kimlik doğrulaması kodu (MAC) ile igili yöntem tercihlerini içeren bir ilişkisel dizi.
server_to_client | Sunucudan istemciye gönderilen iletiler için şifreleme, sıkıştırma ve ileti kimlik doğrulaması kodu (MAC) ile igili yöntem tercihlerini içeren bir ilişkisel dizi.

* - Desteklenen değerler sisteminizdeki kütüphaneye bağlıdır. Daha ayrıntılı bilgi için » libssh2 belgelerine bakınız.

client_to_server ve server_to_client aşağıdaki değiştirgelerin tamamını veya bir kısmını içeren bir ilişkisel dizidir.
İndis | Anlamı | Desteklenen değerler*
crypt | Müzakere edilecek şifreleme yöntemleri; tercih sırasına göre dizilmiş virgül ayraçlı bir listedir. | rijndael-cbc@lysator.liu.se, aes256-cbc, aes192-cbc, aes128-cbc, 3des-cbc, blowfish-cbc, cast128-cbc, arcfour ve none**
comp | Müzakere edilecek sıkıştırma yöntemleri; tercih sırasına göre dizilmiş virgül ayraçlı bir listedir. | zlib ve none
mac | Müzakere edilecek MAC yöntemleri; tercih sırasına göre dizilmiş virgül ayraçlı bir listedir. | hmac-sha1, hmac-sha1-96, hmac-ripemd160, hmac-ripemd160@openssh.com ve none**

Bilginize: Crypt ve MAC yöntemi "none"

Güvenlik saikiyle, none değeri » libssh2 kütüphanesi tarafından iptal edilmiştir. Bu değeri etkin kılmak isterseniz kütüphaneyi derlerken uygun ./configure seçeneğini kullanmanız gerekir. Daha fazla bilgi için kütüphane belgelerine bakınız.

geriçağırımlar

Aşağıdaki değiştirgeleri içeren bir ilişkisel dizidir.

Geriçağırım değiştirgeleri
İndis | Anlamı | İşlev bildirimi
ignore | Bir SSH2_MSG_IGNORE paketi alındığında çağrılacak işlevin ismi. | void ignore_cb($ileti)
debug | Bir SSH2_MSG_DEBUG paketi alındığında çağrılacak işlevin ismi. | void debug_cb($ileti, $dil, $hep_göster)
macerror | Bir paket alındığında ileti kimlik doğrulaması başarısız olduğunda çağrılacak işlevin ismi. Eğer geri çağırım işlevi TRUE döndürürse uyuşmazlık görmezden gelinir, yoksa bağlantı sonlandırılır. | bool macerror_cb($packet)
disconnect | Bir SSH2_MSG_DISCONNECT paketi alındığında çağrılacak işlevin ismi. | void disconnect_cb($sebep, $ileti, $dil)

Dönen Değerler

Başarı durumunda bir özkaynak yoksa FALSE döner.

Örnekler

Örnek 1 - ssh2_connect() örneği

Paket gönderirken 3des-cbc, paket alırken güçlü aes şifremesi için zorlayan, hiçbir yönde sıkıştırma yapılmayan ve Group1 anahtar değişim yöntemini kullanan bir bağlantı açalım.

<?php
/* Sunucu bağlantıyı sonlandırırsa kullanıcıya bilgi verelim */
function my_ssh_disconnect($ebep, $ileti, $dil) {
  printf("Sunucu bağlantıyı kesti; sebep kodu ve ileti: [%d] %s\n",
         $sebep, $ileti);
}

$yontemler = array(
               'kex' => 'diffie-hellman-group1-sha1',
  'client_to_server' => array(
               'crypt' => '3des-cbc',
                'comp' => 'none'),
  'server_to_client' => array(
               'crypt' => 'aes256-cbc,aes192-cbc,aes128-cbc',
                'comp' => 'none'));

$islevler = array('disconnect' => 'my_ssh_disconnect');

$baglanti = ssh2_connect('shell.example.com', 22, $yontemler, $islevler);
if (!$baglanti) die('Bağlantı sağlanamadı');
?>

Ayrıca Bakınız

  • ssh2_fingerprint() - Uzak sunucunu parmakizini döndürür
  • ssh2_auth_none() - "none" kimlik doğrulaması yapar
  • ssh2_auth_password() - Parola kullanarak kimlik doğrulaması yapar
  • ssh2_auth_pubkey_file() - Bir genel anahtar kullanarak kimlik doğrulaması yapar

ssh2_auth_pubkey_file
ssh2_exec
SSH2 İşlevleri


Uzak sunucu üzerinde bir komut çalıştırır

ssh2_connect
ssh2_fetch_stream
SSH2 İşlevleri
PHP Manual

ssh2_exec

(PECL ssh2 >= 0.9.0)

ssh2_exec — Uzak sunucu üzerinde bir komut çalıştırır

Açıklama

resource ssh2_exec ( resource $oturum , string $komut [, string $pty [, array $ortam [, int $genişlik = 80 [, int $yükseklik = 25 [, int $enboy_türü = SSH2_TERM_UNIT_CHARS ]]]]] )

Uzak sunucu üzerinde bir komut çalıştırır ve bunun için bir kanal ayırır.

Değiştirgeler

oturum

ssh2_connect() ile sağlanan bir SSH bağlantı tanıtıcısı.

komut

pty

ortam

Hedef ortamda atanacak ortam değişkenlerini isim-değer çiftleri olarak içeren bir ilişkisel dizi.

genişlik

Sanal uçbirim genişliği.

yükseklik

Sanal uçbirim yüksekliği.

width_height_type

SSH2_TERM_UNIT_CHARS veya SSH2_TERM_UNIT_PIXELS olabilir.

Dönen Değerler

Başarısızlık durumunda FALSE, yoksa bir akım özkaynağı döndürür.

Örnekler

Örnek 1 - Karşıda bir komut çalıştırmak

<?php
$baglanti = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($baglanti, 'birey', 'parola');

$stream = ssh2_exec($baglanti, '/usr/local/bin/php -i');
?>

Ayrıca Bakınız

  • ssh2_connect() - Bir SSH sunucusuna bağlanır
  • ssh2_shell() - Bir etkileşimli kabuk isteği yapar
  • ssh2_tunnel() - Uzak bir sunucuya doğru bir tünel açar

ssh2_connect
ssh2_fetch_stream
SSH2 İşlevleri


Başka bir veri akımı döndürür

ssh2_exec
ssh2_fingerprint
SSH2 İşlevleri
PHP Manual

ssh2_fetch_stream

(PECL ssh2 >= 0.9.0)

ssh2_fetch_stream — Başka bir veri akımı döndürür

Açıklama

resource ssh2_fetch_stream ( resource $kanal , int $dt )

Bir SSH2 kanal akımı ile ilgili ikincil bir alt akım döndürür. SSH2 protokolü şimdilik tek bir alt akım tanımlamaktadır: standart hata (SSH2_STREAM_STDERR).

Değiştirgeler

kanal

dt

Bir SSH2 kanal akımı.

Dönen Değerler

İstenen akım özkaynağı ile döner.

Örnekler

Örnek 1 - Bir kabuk açıp kabukla ilgili standart hataya erişmek

<?php
$baglanti = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($baglanti, 'birey', 'parola');

$stdio_stream = ssh2_shell($baglanti);
$stderr_stream = ssh2_fetch_stream($stdio_stream, SSH2_STREAM_STDERR);
?>

Ayrıca Bakınız

  • ssh2_shell() - Bir etkileşimli kabuk isteği yapar
  • ssh2_exec() - Uzak sunucu üzerinde bir komut çalıştırır
  • ssh2_connect() - Bir SSH sunucusuna bağlanır

ssh2_exec
ssh2_fingerprint
SSH2 İşlevleri


Uzak sunucunu parmakizini döndürür

ssh2_fetch_stream
ssh2_methods_negotiated
SSH2 İşlevleri
PHP Manual

ssh2_fingerprint

(PECL ssh2 >= 0.9.0)

ssh2_fingerprint — Uzak sunucunu parmakizini döndürür

Açıklama

string ssh2_fingerprint ( resource $oturum [, int $seçenekler = SSH2_FINGERPRINT_MD5 | SSH2_FINGERPRINT_HEX ] )

Etkin oturumdan sunucunun konak anahtarı özetini döndürür.

Değiştirgeler

oturum

ssh2_connect() ile sağlanan bir SSH bağlantı tanıtıcısı.

seçenekler

SSH2_FINGERPRINT_MD5 veya SSH2_FINGERPRINT_SHA1 ile SSH2_FINGERPRINT_HEX veya SSH2_FINGERPRINT_RAW bitsel olarak VEYAlanabilir. SSH2_FINGERPRINT_MD5 | SSH2_FINGERPRINT_HEX öntanımlıdır.

Dönen Değerler

Konak anahtarı özetini bir dizge olarak döndürür.

Örnekler

Örnek 1 - Parmakizini karşılaştırmak

<?php
$bildik_konak = '6F89C2F0A719B30CC38ABDF90755F2E4';

$baglanti = ssh2_connect('shell.example.com', 22);

$parmakizi = ssh2_fingerprint($connection,
               SSH2_FINGERPRINT_MD5 | SSH2_FINGERPRINT_HEX);

if ($parmakizi != $bildik_konak) {
  die("ANAHTAR UYMADI!\n" .
      "Kimle dansediyoruz, acaba?!);
}
?>

ssh2_fetch_stream
ssh2_methods_negotiated
SSH2 İşlevleri


Müzakere yöntemlerini listeler

ssh2_fingerprint
ssh2_publickey_add
SSH2 İşlevleri
PHP Manual

ssh2_methods_negotiated

(PECL ssh2 >= 0.9.0)

ssh2_methods_negotiated — Müzakere yöntemlerini listeler

Açıklama

array ssh2_methods_negotiated ( resource $oturum )

Müzakere yöntemlerinin listesini döndürür.

Değiştirgeler

oturum

ssh2_connect() ile sağlanan bir SSH bağlantı tanıtıcısı.

Dönen Değerler

Örnekler

Örnek 1 - Müzakere yöntemlerini öğrenmek

<?php
$baglanti = ssh2_connect('shell.example.com', 22);
$yontemler = ssh2_methods_negotiated($baglanti);

echo "Şifreleme anahtarları ile ilgili müzakere yöntemleri: " .
     "{$methods['kex']}\n";
echo "Sunucu, {$methods['hostkey']} yönteminde şu parmak izi ile tanınır: " .
      ssh2_fingerprint($baglanti) . "\n";

echo "Sunucudan istenen paketler için şu yöntemler kullanılır:\n";
echo "\tCrypt: {$methods['client_to_server']['crypt']}\n";
echo "\tComp: {$methods['client_to_server']['comp']}\n";
echo "\tMAC: {$methods['client_to_server']['mac']}\n";

echo "İstemciden istenen paketler için şu yöntemler kullanılır:\n";
echo "\tCrypt: {$methods['server_to_client']['crypt']}\n";
echo "\tComp: {$methods['server_to_client']['comp']}\n";
echo "\tMAC: {$methods['server_to_client']['mac']}\n";

?>

Ayrıca Bakınız

  • ssh2_connect() - Bir SSH sunucusuna bağlanır

ssh2_fingerprint
ssh2_publickey_add
SSH2 İşlevleri


Yetkili bir genel anahtar ekler

ssh2_methods_negotiated
ssh2_publickey_init
SSH2 İşlevleri
PHP Manual

ssh2_publickey_add

(PECL ssh2 >= 0.10)

ssh2_publickey_add — Yetkili bir genel anahtar ekler

Açıklama

bool ssh2_publickey_add ( resource $özkaynak , string $algoritma , string $ikil_veri [, bool $üsteyaz = false [, array $öznitelikler ]] )

Bilginize: Genel anahtar alt sistemi, istemcinin oturum açtığı sunucudaki genel anahtarları yönetmek için kullanılır. Bir uzak sistemde genel anahtarlı kimlik doğrulaması yapmak için ssh2_auth_pubkey_file() işlevini kullanın.

Değiştirgeler

özkaynak

ssh2_publickey_init() tarafından döndürülen bir genel anahtar alt sistemi özkaynağı.

algoritma

Genel anahtarı oluşturmak için kullanılan algoritma (ssh-dss, ssh-rsa gibi).

ikil_veri

Ham ikil veri olarak genel anahtar.

üsteyaz

TRUE belirtildiği takdirde anahtar mevcut olsa bile üzerine yazılır.

öznitelikler

Anahtara atanacak öznitelikleri içeren bir ilişkisel dizi. Desteklenen özniteliklerin listesi için ietf-secsh-publickey- subsystem belgesine (bir arama motorundan) bakınız. Bir özniteliği zorunlu kılmak için isminin başına bir yıldız (*) ekleyin. Sunucu zorunlu imine sahip öznitelik isimlerini desteklemiyorsa ekleme işlemi başarısız olacaktır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - ssh2_publickey_add() örneği

<?php
$ssh2 = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($ssh2, 'jdoe', 'password');
$pkey = ssh2_publickey_init($ssh2);

$keyblob = base64_decode('
AAAAB3NzaC1yc2EAAAABIwAAAIEA5HVt6VqSGd5PTrLRdjNONxXH1tVFGn0
Bd26BF0aCP9qyJRlvdJ3j4WBeX4ZmrveGrjMgkseSYc4xZ26sDHwfL351xj
zaLpipu\BGRrw17mWVBhuCExo476ri5tQFzbTc54VEHYckxQ16CjSTibI5X
69GmnYC9PNqEYq/1TP+HF10=');

ssh2_publickey_add($pkey, 'ssh-rsa', $keyblob, false, array('comment'=>"John's Key"));
?>

Ayrıca Bakınız

  • ssh2_publickey_init() - Genel anahtar alt sistemini ilklendirir
  • ssh2_publickey_remove() - Bir genel anahtarı siler
  • ssh2_publickey_list() - Yetkili genel anahtarları listeler

ssh2_methods_negotiated
ssh2_publickey_init
SSH2 İşlevleri


Genel anahtar alt sistemini ilklendirir

ssh2_publickey_add
ssh2_publickey_list
SSH2 İşlevleri
PHP Manual

ssh2_publickey_init

(PECL ssh2 >= 0.10)

ssh2_publickey_init — Genel anahtar alt sistemini ilklendirir

Açıklama

resource ssh2_publickey_init ( resource $oturum )

Bağlı SSH2 sunucusundan genel anahtar alt sistemi isteği yapar.

Genel anahtar alt sistemi, bağlı ve kimliği doğrulanmış bir istemcinin hedef sunucuda saklanan genel anahtar listesini yönetebilmesini sağlar. Eğer uzak sunucu genel anahtar alt sistemini desteklemiyorsa işlev FALSE döndürür.

Değiştirgeler

oturum

ssh2_connect() ile sağlanan bir SSH bağlantı tanıtıcısı.

Dönen Değerler

Başarısızlık durumunda FALSE, aksi takdirde diğer ssh2_publickey_*() işlevleriyle kullanmak üzere bir SSH2 genel anahtar altsistemi özkaynağı döner.

Notlar

Bilginize: Genel anahtar alt sistemi, istemcinin oturum açtığı sunucudaki genel anahtarları yönetmek için kullanılır. Bir uzak sistemde genel anahtarlı kimlik doğrulaması yapmak için ssh2_auth_pubkey_file() işlevini kullanın.

Ayrıca Bakınız

  • ssh2_publickey_add() - Yetkili bir genel anahtar ekler
  • ssh2_publickey_remove() - Bir genel anahtarı siler
  • ssh2_publickey_list() - Yetkili genel anahtarları listeler

ssh2_publickey_add
ssh2_publickey_list
SSH2 İşlevleri


Yetkili genel anahtarları listeler

ssh2_publickey_init
ssh2_publickey_remove
SSH2 İşlevleri
PHP Manual

ssh2_publickey_list

(PECL ssh2 >= 0.10)

ssh2_publickey_list — Yetkili genel anahtarları listeler

Açıklama

array ssh2_publickey_list ( resource $özkaynak )

Yetkili genel anahtarları listeler.

Değiştirgeler

özkaynak

ssh2_publickey_init() tarafından döndürülen bir genel anahtar alt sistemi özkaynağı.

Dönen Değerler

Herbiri name, blob ve attrs elemanlarından oluşan bir ilişkisel dizi içeren elemanlardan oluşan sayısal indisli bir dizi döndürür.

Genel Anahtar Elemanları
Dizi anahtarı | Anlamı
name | Genel anahtarı oluşturmak için kullanılan algoritmanın ismi; ssh-dss veya ssh-rsa gibi.
blob | Genel anahtarın ham ikil verisi.
attrs | Genel anahtara atanmış öznitelikler. En bilineni, sadece 1. sürüm genel anahtarlı sunucular tarafından desteklenen comment özniteliği olup herhangi bir dizgeyi değer olarak alabilir.

Örnekler

Örnek 1 - ssh2_publickey_list() örneği

<?php
$ssh2 = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($ssh2, 'jdoe', 'secret');
$pkey = ssh2_publickey_init($ssh2);

$list = ssh2_publickey_list($pkey);

foreach($list as $key) {
  echo "Key: {$key['name']}\n";
  echo "Blob: " . chunk_split(base64_encode($key['blob']), 40, "\n") . "\n";
  echo "Comment: {$key['attrs']['comment']}\n\n";
}
?>

Yukarıdaki örneğin çıktısı:

Key: ssh-rsa
Blob: AAAAB3NzaC1yc2EAAAABIwAAAIEA5HVt6VqSGd5P
TrLRdjNONxXH1tVFGn0Bd26BF0aCP9qyJRlvdJ3j
4WBeX4ZmrveGrjMgkseSYc4xZ26sDHwfL351xjza
Lpipu\BGRrw17mWVBhuCExo476ri5tQFzbTc54VE
HYckxQ16CjSTibI5X69GmnYC9PNqEYq/1TP+HF10
Comment: John's Key

Key: ssh-rsa
Blob: AAAAB3NzaHVt6VqSGd5C1yc2EAAAABIwA232dnJA
AIEA5HVt6VqSGd5PTrLRdjNONxX/1TP+HF1HVt6V
qSGd50H1tVFGn0BB3NzaC1yc2EAd26BF0aCP9qyJ
RlvdJ3j4WBeX4ZmrveGrjMgkseSYc4xZ26HVt6Vq
SGd5sDHwfL351xjzaLpipu\BGB3NzaC1yc2EA/1T
Comment: Alice's Key

Notlar

Bilginize: Genel anahtar alt sistemi, istemcinin oturum açtığı sunucudaki genel anahtarları yönetmek için kullanılır. Bir uzak sistemde genel anahtarlı kimlik doğrulaması yapmak için ssh2_auth_pubkey_file() işlevini kullanın.

Ayrıca Bakınız

  • ssh2_publickey_init() - Genel anahtar alt sistemini ilklendirir
  • ssh2_publickey_add() - Yetkili bir genel anahtar ekler
  • ssh2_publickey_remove() - Bir genel anahtarı siler

ssh2_publickey_init
ssh2_publickey_remove
SSH2 İşlevleri


Bir genel anahtarı siler

ssh2_publickey_list
ssh2_scp_recv
SSH2 İşlevleri
PHP Manual

ssh2_publickey_remove

(PECL ssh2 >= 0.10)

ssh2_publickey_remove — Bir genel anahtarı siler

Açıklama

bool ssh2_publickey_remove ( resource $özkaynak , string $algoritma , string $ikil )

Yetkili genel anahtarlardan birini siler.

Değiştirgeler

özkaynak

ssh2_publickey_init() tarafından döndürülen bir genel anahtar alt sistemi özkaynağı.

algoritma

Genel anahtarı oluşturmak için kullanılan algoritma (ssh-dss, ssh-rsa gibi).

ikil

Ham ikil veri olarak genel anahtar.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

Bilginize: Genel anahtar alt sistemi, istemcinin oturum açtığı sunucudaki genel anahtarları yönetmek için kullanılır. Bir uzak sistemde genel anahtarlı kimlik doğrulaması yapmak için ssh2_auth_pubkey_file() işlevini kullanın.

Ayrıca Bakınız

  • ssh2_publickey_init() - Genel anahtar alt sistemini ilklendirir
  • ssh2_publickey_add() - Yetkili bir genel anahtar ekler
  • ssh2_publickey_list() - Yetkili genel anahtarları listeler

ssh2_publickey_list
ssh2_scp_recv
SSH2 İşlevleri


SCP üzerinden bir dosya alır

ssh2_publickey_remove
ssh2_scp_send
SSH2 İşlevleri
PHP Manual

ssh2_scp_recv

(PECL ssh2 >= 0.9.0)

ssh2_scp_recv — SCP üzerinden bir dosya alır

Açıklama

bool ssh2_scp_recv ( resource $oturum , string $uzak_dosya , string $yerel_dosya )

SCP protokolünü kullanarak uzak sunucunun dosya sistemindeki bir dosyayı yerel dosya sistemine kopyalar.

Değiştirgeler

oturum

ssh2_connect() ile sağlanan bir SSH bağlantı tanıtıcısı.

uzak_dosya

Uzak dosyanın yolu.

yerel_dosya

Yerel dosyanın yolu.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - SCP üzerinden dosya indirmek

<?php
$baglanti = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($baglanti, 'birey', 'parola');

ssh2_scp_recv($baglanti, '/uzak/dosya', '/yerel/dosya');
?>

Ayrıca Bakınız

  • ssh2_scp_send() - SCP üzerinden bir dosya gönderir
  • copy() - Dosya kopyalar

ssh2_publickey_remove
ssh2_scp_send
SSH2 İşlevleri


SCP üzerinden bir dosya gönderir

ssh2_scp_recv
ssh2_sftp_chmod
SSH2 İşlevleri
PHP Manual

ssh2_scp_send

(PECL ssh2 >= 0.9.0)

ssh2_scp_send — SCP üzerinden bir dosya gönderir

Açıklama

bool ssh2_scp_send ( resource $oturum , string $yerel_dosya , string $uzak_dosya [, int $kip = 0644 ] )

SCP protokolünü kullanarak bir yerel dosyayı uzak sunucunun dosya sistemine kopyalar.

Değiştirgeler

oturum

ssh2_connect() ile sağlanan bir SSH bağlantı tanıtıcısı.

yerel_dosya

Yerel dosyanın yolu.

uzak_dosya

Uzak dosyanın yolu.

kip

Dosya oluşturulurken atanacak erişim izinleri.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - SCP üzerinden karşıya dosya yükleme

<?php
$baglanti = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($baglanti, 'birey', 'parola');

ssh2_scp_send($baglanti, '/yerel/dosya', '/uzak/dosya', 0644);
?>

Ayrıca Bakınız

  • ssh2_scp_recv() - SCP üzerinden bir dosya alır
  • copy() - Dosya kopyalar

ssh2_scp_recv
ssh2_sftp_chmod
SSH2 İşlevleri


Changes file mode

ssh2_scp_send
ssh2_sftp_lstat
SSH2 İşlevleri
PHP Manual

ssh2_sftp_chmod

(PECL ssh2 >= 0.12)

ssh2_sftp_chmod — Changes file mode

Açıklama

bool ssh2_sftp_chmod ( resource $sftp , string $filename , int $mode )

Attempts to change the mode of the specified file to that given in mode.

Değiştirgeler

sftp

An SSH2 SFTP resource opened by ssh2_sftp().

filename

Path to the file.

mode

Permissions on the file. See the chmod() for more details on this parameter.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Changing the mode of a file on a remote server

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');
$sftp = ssh2_sftp($connection);

ssh2_sftp_chmod($sftp, '/somedir/somefile', 0755);
?>

Ayrıca Bakınız

  • chmod() - Dosya kipini değiştirir
  • ssh2_sftp() - SFTP alt sistemini ilklendirir
  • ssh2_connect() - Bir SSH sunucusuna bağlanır

ssh2_scp_send
ssh2_sftp_lstat
SSH2 İşlevleri


Uzak sunucudaki bir sembolik bağın durum bilgisini döndürür

ssh2_sftp_chmod
ssh2_sftp_mkdir
SSH2 İşlevleri
PHP Manual

ssh2_sftp_lstat

(PECL ssh2 >= 0.9.0)

ssh2_sftp_lstat — Uzak sunucudaki bir sembolik bağın durum bilgisini döndürür

Açıklama

array ssh2_sftp_lstat ( resource $sftp , string $bağ )

Uzak sunucudaki bir sembolik bağın (hedefinin değil) durum bilgisini döndürür.

Bu işlev, lstat() işlevini PHP5'teki ssh2.sftp:// sarmalayıcısı ile kullanmaya eşdeğer olup ikisi de aynı sonucu döndürür.

Değiştirgeler

sftp

ssh2_sftp() tarafından açılmış bir SSH2 SFTP özkaynağı.

bağ

Uzak sembolik bağın yolu.

Dönen Değerler

Dönen değerlerle ilgili ayrıntılı bilgi edinmek için stat() işlevinin açıklamasına bakınız.

Örnekler

Örnek 1 - SFTP üzerinden bir sembolik bağın durum bilgisini almak

<?php
$baglanti = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($baglanti, 'birey', 'parola');

$sftp = ssh2_sftp($baglanti);
$durum = ssh2_sftp_lstat($sftp, '/bir/yol/sembağ');

$dosyaboyu = $statinfo['size'];
$group = $statinfo['gid'];
$sahibi = $statinfo['uid'];
$eriszaman = $statinfo['atime'];
$degiszaman = $statinfo['mtime'];
$kip = $statinfo['mode'];
?>

Ayrıca Bakınız

  • ssh2_sftp_stat() - Uzak dosya sistemindeki bir dosyanın durum bilgisini döndürür
  • lstat() - Bir dosya veya sembolik bağ hakkında bilgi verir
  • stat() - Bir dosya hakkında bilgi döndürür

ssh2_sftp_chmod
ssh2_sftp_mkdir
SSH2 İşlevleri


Uzak konakta bir dizin oluşturur

ssh2_sftp_lstat
ssh2_sftp_readlink
SSH2 İşlevleri
PHP Manual

ssh2_sftp_mkdir

(PECL ssh2 >= 0.9.0)

ssh2_sftp_mkdir — Uzak konakta bir dizin oluşturur

Açıklama

bool ssh2_sftp_mkdir ( resource $sftp , string $dizin [, int $kip = 0777 [, bool $ardışık = false ]] )

Erişim izinleri olarak belirtilen kip'i kullanarak uzak sunucuda bir dizin oluşturur.

Bu işlev, mkdir() işlevini ssh2.sftp:// sarmalayıcısı ile kullanmaya eşdeğerdir.

Değiştirgeler

sftp

ssh2_sftp() tarafından açılmış bir SSH2 SFTP özkaynağı.

dizin

Oluşturulacak dizinin yolu.

kip

Yeni dizinin erişim izinleri.

ardışık

TRUE belirtilirse özdevinimli olarak dizin için gerekli üst dizinler de oluşturulur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Karşıda bir dizin oluşturmak

<?php
$baglanti = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($baglanti, 'birey', 'parola');
$sftp = ssh2_sftp($baglanti);

ssh2_sftp_mkdir($sftp, '/home/birey/yenidizin');
/* Veya:  mkdir("ssh2.sftp://$sftp/home/birey/yenidizin"); */
?>

Ayrıca Bakınız

  • mkdir() - Dizin oluşturur
  • ssh2_sftp_rmdir() - Karşıdan bir dizin siler

ssh2_sftp_lstat
ssh2_sftp_readlink
SSH2 İşlevleri


Bir sembolik bağın hedefini döndürür

ssh2_sftp_mkdir
ssh2_sftp_realpath
SSH2 İşlevleri
PHP Manual

ssh2_sftp_readlink

(PECL ssh2 >= 0.9.0)

ssh2_sftp_readlink — Bir sembolik bağın hedefini döndürür

Açıklama

string ssh2_sftp_readlink ( resource $sftp , string $bağ )

Bir sembolik bağın hedefini döndürür.

Değiştirgeler

sftp

ssh2_sftp() tarafından açılmış bir SSH2 SFTP özkaynağı.

bağ

Sembolik bağın yolu.

Dönen Değerler

Sembolik bağ'ın hedefini döndürür.

Örnekler

Örnek 1 - Bir sembolik bağı okumak

<?php
$baglanti = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($baglanti, 'birey', 'parola');
$sftp = ssh2_sftp($baglanti);

$hedef = ssh2_sftp_readlink($sftp, '/tmp/mysql.sock');
/* $hedef (örneğin): '/var/run/mysql.sock' */
?>

Ayrıca Bakınız

  • readlink() - Bir sembolik bağın hedefi ile döner
  • ssh2_sftp_symlink() - Karşıda bir sembolik bağ oluşturur

ssh2_sftp_mkdir
ssh2_sftp_realpath
SSH2 İşlevleri


Belirtilen dosya yolu dizgesinden gerçek yolu elde eder

ssh2_sftp_readlink
ssh2_sftp_rename
SSH2 İşlevleri
PHP Manual

ssh2_sftp_realpath

(PECL ssh2 >= 0.9.0)

ssh2_sftp_realpath — Belirtilen dosya yolu dizgesinden gerçek yolu elde eder

Açıklama

string ssh2_sftp_realpath ( resource $sftp , string $yol )

Belirtilen yoldizgesinden uzak sunucunun kök dizinine göre asıl yolu elde eder.

Değiştirgeler

sftp

ssh2_sftp() tarafından açılmış bir SSH2 SFTP özkaynağı.

yol

Dönen Değerler

Asıl yolu bir dizge olarak döndürür.

Örnekler

Örnek 1 - Bir dosya yolunun çözümlenmesi

<?php
$baglanti = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($baglanti, 'birey', 'parola');
$sftp = ssh2_sftp($baglanti);

$asilyol = ssh2_sftp_realpath($sftp, '/home/birey/../../../..//./usr/../etc/passwd');
/* $asilyol: '/etc/passwd' */
?>

Ayrıca Bakınız

  • realpath() - Normalleştirilmiş mutlak dosya yolunu döndürür
  • ssh2_sftp_symlink() - Karşıda bir sembolik bağ oluşturur
  • ssh2_sftp_readlink() - Bir sembolik bağın hedefini döndürür

ssh2_sftp_readlink
ssh2_sftp_rename
SSH2 İşlevleri


Bir uzak dosyanın ismini değiştirir

ssh2_sftp_realpath
ssh2_sftp_rmdir
SSH2 İşlevleri
PHP Manual

ssh2_sftp_rename

(PECL ssh2 >= 0.9.0)

ssh2_sftp_rename — Bir uzak dosyanın ismini değiştirir

Açıklama

bool ssh2_sftp_rename ( resource $sftp , string $eskisi , string $yenisi )

Uzak dosya sistemindeki bir dosyanın ismini değiştirir.

Değiştirgeler

sftp

ssh2_sftp() tarafından açılmış bir SSH2 SFTP özkaynağı.

eskisi

İsmi değiştirilecek dosyanın yolu.

yenisi

Dosyanın yeni ismi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - SFTP üzerinden bır dosyanın ismini değiştirmek

<?php
$baglanti = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($baglanti, 'birey', 'parola');
$sftp = ssh2_sftp($baglanti);

ssh2_sftp_rename($sftp, '/home/birey/eskisi', '/home/birey/yenisi);
?>

Ayrıca Bakınız

  • rename() - Bir dosya veya dizinin ismini değiştirir

ssh2_sftp_realpath
ssh2_sftp_rmdir
SSH2 İşlevleri


Karşıdan bir dizin siler

ssh2_sftp_rename
ssh2_sftp_stat
SSH2 İşlevleri
PHP Manual

ssh2_sftp_rmdir

(PECL ssh2 >= 0.9.0)

ssh2_sftp_rmdir — Karşıdan bir dizin siler

Açıklama

bool ssh2_sftp_rmdir ( resource $sftp , string $dizin )

Uzak dosya sunucusundan belirtilen dizini siler.

Bu işlev, rmdir() işlevi ile ssh2.sftp:// sarmalayıcısını kullanmaya eşdeğerdir.

Değiştirgeler

sftp

ssh2_sftp() tarafından açılmış bir SSH2 SFTP özkaynağı.

dizin

Silinecek dizinin yolu.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Uzak sunucudan bir dizini silmek

<?php
$baglanti = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($baglanti, 'birey', 'parola');
$sftp = ssh2_sftp($baglanti);

ssh2_sftp_rmdir($sftp, '/home/birey/bayat_dizin');
/* Veya:  rmdir("ssh2.sftp://$sftp/home/birey/bayat_dizin"); */
?>

Ayrıca Bakınız

  • rmdir() - Dizin siler
  • ssh2_sftp_mkdir() - Uzak konakta bir dizin oluşturur

ssh2_sftp_rename
ssh2_sftp_stat
SSH2 İşlevleri


Uzak dosya sistemindeki bir dosyanın durum bilgisini döndürür

ssh2_sftp_rmdir
ssh2_sftp_symlink
SSH2 İşlevleri
PHP Manual

ssh2_sftp_stat

(PECL ssh2 >= 0.9.0)

ssh2_sftp_stat — Uzak dosya sistemindeki bir dosyanın durum bilgisini döndürür

Açıklama

array ssh2_sftp_stat ( resource $sftp , string $dosya )

Bir sembolik bağın hedefindeki dosya sistemi üzerinde bulunan bir dosyanın durum bilgisini alır.

Bu işlev, stat() işlevini PHP5'teki ssh2.sftp:// sarmalayıcısı ile kullanmaya eşdeğer olup ikisi de aynı sonucu döndürür.

Değiştirgeler

sftp

ssh2_sftp() tarafından açılmış bir SSH2 SFTP özkaynağı.

dosya

Dönen Değerler

Dönen değerlerle ilgili ayrıntılı bilgi edinmek için stat() işlevinin açıklamasına bakınız.

Örnekler

Örnek 1 - SFTP üzerinden bir dosyanın durum bilgisini almak

<?php
$baglanti = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($baglanti, 'birey', 'parola');

$sftp = ssh2_sftp($baglanti);
$statinfo = ssh2_sftp_stat($sftp, '/bir/yol/dosya');

$dosyaboyu = $statinfo['size'];
$grup = $statinfo['gid'];
$sahibi = $statinfo['uid'];
$eriszaman = $statinfo['atime'];
$degiszaman = $statinfo['mtime'];
kip = $statinfo['mode'];
?>

Ayrıca Bakınız

  • ssh2_sftp_lstat() - Uzak sunucudaki bir sembolik bağın durum bilgisini döndürür
  • lstat() - Bir dosya veya sembolik bağ hakkında bilgi verir
  • stat() - Bir dosya hakkında bilgi döndürür

ssh2_sftp_rmdir
ssh2_sftp_symlink
SSH2 İşlevleri


Karşıda bir sembolik bağ oluşturur

ssh2_sftp_stat
ssh2_sftp_unlink
SSH2 İşlevleri
PHP Manual

ssh2_sftp_symlink

(PECL ssh2 >= 0.9.0)

ssh2_sftp_symlink — Karşıda bir sembolik bağ oluşturur

Açıklama

bool ssh2_sftp_symlink ( resource $sftp , string $hedef , string $bağ )

hedef ile belirtilen uzak dosya sistemine bağ isminde bir sembolik bağ oluşturur.

Değiştirgeler

sftp

ssh2_sftp() tarafından açılmış bir SSH2 SFTP özkaynağı.

hedef

Sembolik bağın hedefi.

bağ

Sembolik bağın ismi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Karşıya bir sembolik bağ oluşturmak

<?php
$baglanti = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($baglanti, 'birey', 'parola');
$sftp = ssh2_sftp($baglanti);

ssh2_sftp_symlink($sftp, '/var/run/mysql.sock', '/tmp/mysql.sock');
?>

Ayrıca Bakınız

  • ssh2_sftp_readlink() - Bir sembolik bağın hedefini döndürür
  • symlink() - Bir sembolik bağ oluşturur

ssh2_sftp_stat
ssh2_sftp_unlink
SSH2 İşlevleri


Bir dosyayı siler

ssh2_sftp_symlink
ssh2_sftp
SSH2 İşlevleri
PHP Manual

ssh2_sftp_unlink

(PECL ssh2 >= 0.9.0)

ssh2_sftp_unlink — Bir dosyayı siler

Açıklama

bool ssh2_sftp_unlink ( resource $sftp , string $dosya )

Uzak dosya sistemindeki bir dosyayı siler.

Değiştirgeler

sftp

ssh2_sftp() tarafından açılmış bir SSH2 SFTP özkaynağı.

dosya

Silinecek dosyanın yolu.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Karşıdan bir dosya silmek

<?php
$baglanti = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($baglanti, 'birey', 'parola');
$sftp = ssh2_sftp($baglanti);

ssh2_sftp_unlink($sftp, '/home/birey/bayat_dosya');
?>

Ayrıca Bakınız

  • unlink() - Bir dosyayı siler

ssh2_sftp_symlink
ssh2_sftp
SSH2 İşlevleri


SFTP alt sistemini ilklendirir

ssh2_sftp_unlink
ssh2_shell
SSH2 İşlevleri
PHP Manual

ssh2_sftp

(PECL ssh2 >= 0.9.0)

ssh2_sftp — SFTP alt sistemini ilklendirir

Açıklama

resource ssh2_sftp ( resource $oturum )

Bağlı bir SSH sunucusuna SFTP alt sistemi için bir istek yapar.

Değiştirgeler

oturum

ssh2_connect() ile sağlanan bir SSH bağlantı tanıtıcısı.

Dönen Değerler

Diğer ssh2_sftp_*() işlevleri ile ve ssh2.sftp:// fopen sarmalayıcısı ile kullanmak üzere bir SSH2 SFTP özkaynağı döndürür.

Örnekler

Örnek 1 - SFTP üzerinden bir dosya açmak

<?php
$baglanti = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($baglanti, 'kullanıcı', 'parola');

$sftp = ssh2_sftp($baglanti);

$akim = fopen("ssh2.sftp://$sftp/bir/yol/dosya", 'r');
?>

Ayrıca Bakınız

  • ssh2_scp_recv() - SCP üzerinden bir dosya alır
  • ssh2_scp_send() - SCP üzerinden bir dosya gönderir

ssh2_sftp_unlink
ssh2_shell
SSH2 İşlevleri


Bir etkileşimli kabuk isteği yapar

ssh2_sftp
ssh2_tunnel
SSH2 İşlevleri
PHP Manual

ssh2_shell

(PECL ssh2 >= 0.9.0)

ssh2_shell — Bir etkileşimli kabuk isteği yapar

Açıklama

resource ssh2_shell ( resource $oturum [, string $uçbirim_türü = "vanilla" [, array $ortam [, int $genişlik = 80 [, int $yükseklik = 25 [, int $enboy_türü = SSH2_TERM_UNIT_CHARS ]]]]] )

Uzak uçta bir kabuk açıp bir akımla ilişkilendirir.

Değiştirgeler

oturum

ssh2_connect() ile sağlanan bir SSH bağlantı tanıtıcısı.

uçbirim_türü

Hedef sistemin /etc/termcap dosyasındaki girdilerden biri olmalıdır. Belirtilmezse vanilla öntanımlıdır.

env

Hedef ortamında tanımlanacak ortam değişkenlerini isim-değer çiftleri olarak içeren bir ilişkisel dizi.

genişlik

Sanal uçbirim genişliği.

yükseklik

Sanal uçbirim yüksekliği.

enboy_türü

SSH2_TERM_UNIT_CHARS veya SSH2_TERM_UNIT_PIXELS olabilir.

Dönen Değerler

Örnekler

Örnek 1 - Bir kabuk oturumunun açılması

<?php
$baglanti = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($baglanti, 'kullanıcı', 'parola');

$akim = ssh2_shell($baglanti, 'vt102', null, 80, 24, SSH2_TERM_UNIT_CHARS);
?>

Ayrıca Bakınız

  • ssh2_exec() - Uzak sunucu üzerinde bir komut çalıştırır
  • ssh2_tunnel() - Uzak bir sunucuya doğru bir tünel açar
  • ssh2_fetch_stream() - Başka bir veri akımı döndürür

ssh2_sftp
ssh2_tunnel
SSH2 İşlevleri


Uzak bir sunucuya doğru bir tünel açar

ssh2_shell
Stomp
SSH2 İşlevleri
PHP Manual

ssh2_tunnel

(PECL ssh2 >= 0.9.0)

ssh2_tunnel — Uzak bir sunucuya doğru bir tünel açar

Açıklama

resource ssh2_tunnel ( resource $oturum , string $konak , int $port )

Bağlı bir SSH sunucusu üzerinden belirtilen konak ve porta bir soket akımı açar.

Değiştirgeler

oturum

ssh2_connect() ile sağlanan bir SSH bağlantı tanıtıcısı.

konak

port

Dönen Değerler

Örnekler

Örnek 1 - Belli bir konağa bir tünel açmak

<?php
$baglanti = ssh2_connect('shell.example.com', 22);
ssh2_auth_pubkey_file($baglanti, 'kullanıcı', 'id_dsa.pub', 'id_dsa');

$tunel = ssh2_tunnel($baglanti, '10.0.0.101', 12345);
?>

Ayrıca Bakınız

  • ssh2_connect() - Bir SSH sunucusuna bağlanır
  • fsockopen() - Bir internet veya Unix alan soketi bağlantısı açar

ssh2_shell
Stomp
SSH2 İşlevleri


Stomp Client

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Örnekler
  • Stomp İşlevleri
    • stomp_connect_error — Returns a string description of the last connect error
    • stomp_version — Gets the current stomp extension version
  • Stomp — The Stomp class
    • Stomp::abort — Rolls back a transaction in progress
    • Stomp::ack — Acknowledges consumption of a message
    • Stomp::begin — Starts a transaction
    • Stomp::commit — Commits a transaction in progress
    • Stomp::__construct — Opens a connection
    • Stomp::__destruct — Closes stomp connection
    • Stomp::error — Gets the last stomp error
    • Stomp::getReadTimeout — Gets read timeout
    • Stomp::getSessionId — Gets the current stomp session ID
    • Stomp::hasFrame — Indicates whether or not there is a frame ready to read
    • Stomp::readFrame — Reads the next frame
    • Stomp::send — Sends a message
    • Stomp::setReadTimeout — Sets read timeout
    • Stomp::subscribe — Registers to listen to a given destination
    • Stomp::unsubscribe — Removes an existing subscription
  • StompFrame — The StompFrame class
    • StompFrame::__construct — Constructor
  • StompException — The StompException class
    • StompException::getDetails — Get exception details
ssh2_tunnel
Giriş
Diğer Hizmetler


Giriş

This extension allows php applications to communicate with any Stomp compliant Message Brokers through easy object oriented and procedural interfaces. » Stomp official site

Stomp
Yapılandırma/Kurulum
Stomp


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Stomp


Gereksinimler

PECL/stomp requires PHP 5.2.2 or newer.

The » OpenSSL package >= 0.9.6 and the openssl extension may also be required to use stomp over SSL.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/stomp

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Stomp Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
stomp.default_broker | tcp://localhost:61613 | PHP_INI_ALL |
stomp.default_connection_timeout_sec | 2 | PHP_INI_ALL |
stomp.default_connection_timeout_usec | 0 | PHP_INI_ALL |
stomp.default_read_timeout_sec | 2 | PHP_INI_ALL |
stomp.default_read_timeout_usec | 0 | PHP_INI_ALL |

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

stomp.default_broker string

The default broker URI to use when connecting to the message broker if no other URI is specified.

stomp.default_connection_timeout_sec integer

The seconds part of the default connection timeout.

stomp.default_connection_timeout_usec integer

The microseconds part of the default connection timeout.

stomp.default_read_timeout_sec integer

The seconds part of the default reading timeout.

stomp.default_read_timeout_usec integer

The microseconds part of the default reading timeout.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Özkaynak Türleri

There is only one resource type used in the stomp extension - it's the link identifier for a stomp connection.

Çalışma Anı Yapılandırması
Örnekler
Yapılandırma/Kurulum


Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php

$queue  = '/queue/foo';
$msg    = 'bar';

/* connection */
try {
    $stomp = new Stomp('tcp://localhost:61613');
} catch(StompException $e) {
    die('Connection failed: ' . $e->getMessage());
}

/* send a message to the queue 'foo' */
$stomp->send($queue, $msg);

/* subscribe to messages from the queue 'foo' */
$stomp->subscribe($queue);

/* read a frame */
$frame = $stomp->readFrame();

if ($frame->body === $msg) {
    var_dump($frame);

    /* acknowledge that the frame was received */
    $stomp->ack($frame);
}

/* close connection */
unset($stomp);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(StompFrame)#2 (3) {
  ["command"]=>
  string(7) "MESSAGE"
  ["headers"]=>
  array(5) {
    ["message-id"]=>
    string(41) "ID:php.net-55293-1257226743606-4:2:-1:1:1"
    ["destination"]=>
    string(10) "/queue/foo"
    ["timestamp"]=>
    string(13) "1257226805828"
    ["expires"]=>
    string(1) "0"
    ["priority"]=>
    string(1) "0"
  }
  ["body"]=>
  string(3) "bar"
}

Örnek 2 Yordamsal kullanım

<?php

$queue  = '/queue/foo';
$msg    = 'bar';

/* connection */
$link = stomp_connect('ssl://localhost:61612');

/* check connection */
if (!$link) {
    die('Connection failed: ' . stomp_connect_error());
}

/* begin a transaction */
stomp_begin($link, 't1');

/* send a message to the queue 'foo' */
stomp_send($link, $queue, $msg, array('transaction' => 't1'));

/* commit a transaction */
stomp_commit($link, 't1');

/* subscribe to messages from the queue 'foo' */
stomp_subscribe($link, $queue);

/* read a frame */
$frame = stomp_read_frame($link);

if ($frame['body'] === $msg) {
    var_dump($frame);

    /* acknowledge that the frame was received */
    stomp_ack($link, $frame['headers']['message-id']);
}

/* close connection */
stomp_close($link);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(3) {
  ["command"]=>
  string(7) "MESSAGE"
  ["body"]=>
  string(3) "bar"
  ["headers"]=>
  array(6) {
    ["transaction"]=>
    string(2) "t1"
    ["message-id"]=>
    string(41) "ID:php.net-55293-1257226743606-4:3:-1:1:1"
    ["destination"]=>
    string(10) "/queue/foo"
    ["timestamp"]=>
    string(13) "1257227037059"
    ["expires"]=>
    string(1) "0"
    ["priority"]=>
    string(1) "0"
  }
}

Özkaynak Türleri
Stomp İşlevleri
Stomp


Stomp İşlevleri

İçindekiler

  • stomp_connect_error — Returns a string description of the last connect error
  • stomp_version — Gets the current stomp extension version
Örnekler
stomp_connect_error
Stomp


Returns a string description of the last connect error

Stomp İşlevleri
stomp_version
Stomp İşlevleri
PHP Manual

stomp_connect_error

(PECL stomp >= 0.3.0)

stomp_connect_error — Returns a string description of the last connect error

Açıklama

string stomp_connect_error ( void )

Returns a string description of the last connect error.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A string that describes the error, or NULL if no error occurred.

Örnekler

Örnek 1 stomp_connect_error() example

<?php
$link = stomp_connect('http://localhost:61613');

if(!$link) {
    die('Connection failed: ' . stomp_connect_error());
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Connection failed: Invalid Broker URI scheme

Stomp İşlevleri
stomp_version
Stomp İşlevleri


Gets the current stomp extension version

stomp_connect_error
Stomp
Stomp İşlevleri
PHP Manual

stomp_version

(PECL stomp >= 0.1.0)

stomp_version — Gets the current stomp extension version

Açıklama

string stomp_version ( void )

Returns a string containing the version of the current stomp extension.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

It returns the current stomp extension version

Örnekler

Örnek 1 stomp_version() example

<?php

var_dump(stomp_version());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(5) "0.2.0"

stomp_connect_error
Stomp
Stomp İşlevleri


The Stomp class

(PECL stomp >= 0.1.0)

Giriş

Represents a connection between PHP and a Stomp compliant Message Broker.

Sınıf Sözdizimi

Stomp {
/* Yöntemler */
public bool abort ( string $transaction_id [, array $headers ] )
public bool ack ( mixed $msg [, array $headers ] )
public bool begin ( string $transaction_id [, array $headers ] )
public bool commit ( string $transaction_id [, array $headers ] )
public __construct ([ string $broker = ini_get("stomp.default_broker_uri") [, string $username [, string $password [, array $headers ]]]] )
public bool __destruct ( void )
public string error ( void )
public array getReadTimeout ( void )
public string getSessionId ( void )
public bool hasFrame ( void )
public stompframe readFrame ([ string $class_name = "stompFrame" ] )
public bool send ( string $destination , mixed $msg [, array $headers ] )
public void setReadTimeout ( int $seconds [, int $microseconds ] )
public bool subscribe ( string $destination [, array $headers ] )
public bool unsubscribe ( string $destination [, array $headers ] )
}

İçindekiler

  • Stomp::abort — Rolls back a transaction in progress
  • Stomp::ack — Acknowledges consumption of a message
  • Stomp::begin — Starts a transaction
  • Stomp::commit — Commits a transaction in progress
  • Stomp::__construct — Opens a connection
  • Stomp::__destruct — Closes stomp connection
  • Stomp::error — Gets the last stomp error
  • Stomp::getReadTimeout — Gets read timeout
  • Stomp::getSessionId — Gets the current stomp session ID
  • Stomp::hasFrame — Indicates whether or not there is a frame ready to read
  • Stomp::readFrame — Reads the next frame
  • Stomp::send — Sends a message
  • Stomp::setReadTimeout — Sets read timeout
  • Stomp::subscribe — Registers to listen to a given destination
  • Stomp::unsubscribe — Removes an existing subscription
stomp_version
Stomp::abort
Stomp


Rolls back a transaction in progress

Stomp
Stomp::ack
Stomp
PHP Manual

Stomp::abort

stomp_abort

(PECL stomp >= 0.1.0)

Stomp::abort -- stomp_abort — Rolls back a transaction in progress

Açıklama

Nesne yönelimli kullanım (method):

public bool Stomp::abort ( string $transaction_id [, array $headers ] )

Yordamsal kullanım:

bool stomp_abort ( resource $link , string $transaction_id [, array $headers ] )

Rolls back a transaction in progress.

Değiştirgeler

link

Procedural style only: The stomp link identifier returned by stomp_connect().

transaction_id

The transaction to abort.

headers

Associative array containing the additional headers (example: receipt).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

İpucu

Stomp is inherently asynchronous. Synchronous communication can be implemented adding a receipt header. This will cause methods to not return anything until the server has acknowledged receipt of the message or until read timeout was reached.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php

/* connection */
try {
    $stomp = new Stomp('tcp://localhost:61613');
} catch(StompException $e) {
    die('Connection failed: ' . $e->getMessage());
}

/* begin a transaction */
$stomp->begin('t1');

/* send a message to the queue */
$stomp->send('/queue/foo', 'bar', array('transaction' => 't1'));

/* rollback */
$stomp->abort('t1');

/* close connection */
unset($stomp);
?>

Örnek 2 Yordamsal kullanım

<?php

/* connection */
$link = stomp_connect('tcp://localhost:61613');

/* check connection */
if (!$link) {
    die('Connection failed: ' . stomp_connect_error());
}

/* begin a transaction */
stomp_begin($link, 't1');

/* send a message to the queue 'foo' */
stomp_send($link, '/queue/foo', 'bar', array('transaction' => 't1'));

/* rollback */
stomp_abort($link, 't1');

/* close connection */
stomp_close($link);

?>

Stomp
Stomp::ack
Stomp


Acknowledges consumption of a message

Stomp::abort
Stomp::begin
Stomp
PHP Manual

Stomp::ack

stomp_ack

(PECL stomp >= 0.1.0)

Stomp::ack -- stomp_ack — Acknowledges consumption of a message

Açıklama

Nesne yönelimli kullanım (method):

public bool Stomp::ack ( mixed $msg [, array $headers ] )

Yordamsal kullanım:

bool stomp_ack ( resource $link , mixed $msg [, array $headers ] )

Acknowledges consumption of a message from a subscription using client acknowledgment.

Değiştirgeler

link

Procedural style only: The stomp link identifier returned by stomp_connect().

msg

The message/messageId to be acknowledged.

headers

Associative array containing the additional headers (example: receipt).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

Bilginize:

A transaction header may be specified, indicating that the message acknowledgment should be part of the named transaction.

İpucu

Stomp is inherently asynchronous. Synchronous communication can be implemented adding a receipt header. This will cause methods to not return anything until the server has acknowledged receipt of the message or until read timeout was reached.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php

$queue  = '/queue/foo';
$msg    = 'bar';

/* connection */
try {
    $stomp = new Stomp('tcp://localhost:61613');
} catch(StompException $e) {
    die('Connection failed: ' . $e->getMessage());
}

/* send a message to the queue 'foo' */
$stomp->send($queue, $msg);

/* subscribe to messages from the queue 'foo' */
$stomp->subscribe($queue);

/* read a frame */
$frame = $stomp->readFrame();

if ($frame->body === $msg) {
    /* acknowledge that the frame was received */
    $stomp->ack($frame);
}

/* remove the subscription */
$stomp->unsubscribe($queue);

/* close connection */
unset($stomp);

?>

Örnek 2 Yordamsal kullanım

<?php

$queue  = '/queue/foo';
$msg    = 'bar';

/* connection */
$link = stomp_connect('ssl://localhost:61612');

/* check connection */
if (!$link) {
    die('Connection failed: ' . stomp_connect_error());
}

/* begin a transaction */
stomp_begin($link, 't1');

/* send a message to the queue 'foo' */
stomp_send($link, $queue, $msg, array('transaction' => 't1'));

/* commit a transaction */
stomp_commit($link, 't1');

/* subscribe to messages from the queue 'foo' */
stomp_subscribe($link, $queue);

/* read a frame */
$frame = stomp_read_frame($link);

if ($frame['body'] === $msg) {
    /* acknowledge that the frame was received */
    stomp_ack($link, $frame['headers']['message-id']);
}

/* remove the subscription */
stomp_unsubscribe($link, $queue);

/* close connection */
stomp_close($link);

?>

Stomp::abort
Stomp::begin
Stomp


Starts a transaction

Stomp::ack
Stomp::commit
Stomp
PHP Manual

Stomp::begin

stomp_begin

(PECL stomp >= 0.1.0)

Stomp::begin -- stomp_begin — Starts a transaction

Açıklama

Nesne yönelimli kullanım (method):

public bool Stomp::begin ( string $transaction_id [, array $headers ] )

Yordamsal kullanım:

bool stomp_begin ( resource $link , string $transaction_id [, array $headers ] )

Starts a transaction.

Değiştirgeler

link

Procedural style only: The stomp link identifier returned by stomp_connect().

transaction_id

The transaction id.

headers

Associative array containing the additional headers (example: receipt).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

İpucu

Stomp is inherently asynchronous. Synchronous communication can be implemented adding a receipt header. This will cause methods to not return anything until the server has acknowledged receipt of the message or until read timeout was reached.

Örnekler

See stomp_commit() or stomp_abort().

Stomp::ack
Stomp::commit
Stomp


Commits a transaction in progress

Stomp::begin
Stomp::__construct
Stomp
PHP Manual

Stomp::commit

stomp_commit

(PECL stomp >= 0.1.0)

Stomp::commit -- stomp_commit — Commits a transaction in progress

Açıklama

Nesne yönelimli kullanım (method):

public bool Stomp::commit ( string $transaction_id [, array $headers ] )

Yordamsal kullanım:

bool stomp_commit ( resource $link , string $transaction_id [, array $headers ] )

Commits a transaction in progress.

Değiştirgeler

link

Procedural style only: The stomp link identifier returned by stomp_connect().

transaction_id

The transaction id.

headers

Associative array containing the additional headers (example: receipt).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

İpucu

Stomp is inherently asynchronous. Synchronous communication can be implemented adding a receipt header. This will cause methods to not return anything until the server has acknowledged receipt of the message or until read timeout was reached.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php

/* connection */
try {
    $stomp = new Stomp('tcp://localhost:61613');
} catch(StompException $e) {
    die('Connection failed: ' . $e->getMessage());
}

/* begin a transaction */
$stomp->begin('t1');

/* send a message to the queue */
$stomp->send('/queue/foo', 'bar', array('transaction' => 't1'));

/* commit */
$stomp->commit('t1');

/* close connection */
unset($stomp);

?>

Örnek 2 Yordamsal kullanım

<?php

/* connection */
$link = stomp_connect('tcp://localhost:61613');

/* check connection */
if (!$link) {
    die('Connection failed: ' . stomp_connect_error());
}

/* begin a transaction */
stomp_begin($link, 't1');

/* send a message to the queue 'foo' */
stomp_send($link, '/queue/foo', 'bar', array('transaction' => 't1'));

/* commit */
stomp_commit($link, 't1');

/* close connection */
stomp_close($link);

?>

Stomp::begin
Stomp::__construct
Stomp


Opens a connection

Stomp::commit
Stomp::__destruct
Stomp
PHP Manual

Stomp::__construct

stomp_connect

(PECL stomp >= 0.1.0)

Stomp::__construct -- stomp_connect — Opens a connection

Açıklama

Nesne yönelimli kullanım (constructor):

public Stomp::__construct ([ string $broker = ini_get("stomp.default_broker_uri") [, string $username [, string $password [, array $headers ]]]] )

Yordamsal kullanım:

resource stomp_connect ([ string $broker = ini_get("stomp.default_broker_uri") [, string $username [, string $password [, array $headers ]]]] )

Opens a connection to a stomp compliant Message Broker.

Değiştirgeler

broker

The broker URI

username

The username.

password

The password.

headers

Associative array containing the additional headers (example: receipt).

Dönen Değerler

Bilginize:

A transaction header may be specified, indicating that the message acknowledgment should be part of the named transaction.

Sürüm Bilgisi

Sürüm: | Açıklama
1.0.1 | The headers parameter was added

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php

/* connection */
try {
    $stomp = new Stomp('tcp://localhost:61613');
} catch(StompException $e) {
    die('Connection failed: ' . $e->getMessage());
}

/* close connection */
unset($stomp);

?>

Örnek 2 Yordamsal kullanım

<?php

/* connection */
$link = stomp_connect('ssl://localhost:61612');

/* check connection */
if (!$link) {
    die('Connection failed: ' . stomp_connect_error());
}

/* close connection */
stomp_close($link);

?>

Stomp::commit
Stomp::__destruct
Stomp


Closes stomp connection

Stomp::__construct
Stomp::error
Stomp
PHP Manual

Stomp::__destruct

stomp_close

(PECL stomp >= 0.1.0)

Stomp::__destruct -- stomp_close — Closes stomp connection

Açıklama

Nesne yönelimli kullanım (destructor):

public bool Stomp::__destruct ( void )

Yordamsal kullanım:

bool stomp_close ( resource $link )

Closes a previously opened connection.

Değiştirgeler

link

Procedural style only: The stomp link identifier returned by stomp_connect().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

See stomp_connect().

Stomp::__construct
Stomp::error
Stomp


Gets the last stomp error

Stomp::__destruct
Stomp::getReadTimeout
Stomp
PHP Manual

Stomp::error

stomp_error

(PECL stomp >= 0.1.0)

Stomp::error -- stomp_error — Gets the last stomp error

Açıklama

Nesne yönelimli kullanım (method):

public string Stomp::error ( void )

Yordamsal kullanım:

string stomp_error ( resource $link )

Gets the last stomp error.

Değiştirgeler

link

Procedural style only: The stomp link identifier returned by stomp_connect().

Dönen Değerler

Returns an error string or FALSE if no error occurred.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php

/* connection */
try {
    $stomp = new Stomp('tcp://localhost:61613');
} catch(StompException $e) {
    die('Connection failed: ' . $e->getMessage());
}

var_dump($stomp->error());

if (!$stomp->abort('unknown-transaction', array('receipt' => 'foo'))) {
    var_dump($stomp->error());
}

/* close connection */
unset($stomp);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(false)
string(43) "Invalid transaction id: unknown-transaction"

Örnek 2 Yordamsal kullanım

<?php

/* connection */
$link = stomp_connect('ssl://localhost:61612');

/* check connection */
if (!$link) {
    die('Connection failed: ' . stomp_connect_error());
}

var_dump(stomp_error($link));

if (!stomp_abort($link, 'unknown-transaction', array('receipt' => 'foo'))) {
    var_dump(stomp_error($link));
}

/* close connection */
stomp_close($link);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(false)
string(43) "Invalid transaction id: unknown-transaction"

Stomp::__destruct
Stomp::getReadTimeout
Stomp


Gets read timeout

Stomp::error
Stomp::getSessionId
Stomp
PHP Manual

Stomp::getReadTimeout

stomp_get_read_timeout

(PECL stomp >= 0.3.0)

Stomp::getReadTimeout -- stomp_get_read_timeout — Gets read timeout

Açıklama

Nesne yönelimli kullanım (method):

public array Stomp::getReadTimeout ( void )

Yordamsal kullanım:

array stomp_get_read_timeout ( resource $link )

Gets read timeout

Değiştirgeler

link

Procedural style only: The stomp link identifier returned by stomp_connect().

Dönen Değerler

Returns an array with 2 elements: sec and usec.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php

/* connection */
try {
    $stomp = new Stomp('tcp://localhost:61613');
} catch(StompException $e) {
    die('Connection failed: ' . $e->getMessage());
}

var_dump($stomp->getReadTimeout());

/* close connection */
unset($stomp);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(2) {
  ["sec"]=>
  int(2)
  ["usec"]=>
  int(0)
}

Örnek 2 Yordamsal kullanım

<?php

/* connection */
$link = stomp_connect('ssl://localhost:61612');

/* check connection */
if (!$link) {
    die('Connection failed: ' . stomp_connect_error());
}

var_dump(stomp_get_read_timeout($link));

/* close connection */
stomp_close($link);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(2) {
  ["sec"]=>
  int(2)
  ["usec"]=>
  int(0)
}

Stomp::error
Stomp::getSessionId
Stomp


Gets the current stomp session ID

Stomp::getReadTimeout
Stomp::hasFrame
Stomp
PHP Manual

Stomp::getSessionId

stomp_get_session_id

(PECL stomp >= 0.1.0)

Stomp::getSessionId -- stomp_get_session_id — Gets the current stomp session ID

Açıklama

Nesne yönelimli kullanım (method):

public string Stomp::getSessionId ( void )

Yordamsal kullanım:

string stomp_get_session_id ( resource $link )

Gets the current stomp session ID.

Değiştirgeler

link

Procedural style only: The stomp link identifier returned by stomp_connect().

Dönen Değerler

string session id on success başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php

/* connection */
try {
    $stomp = new Stomp('tcp://localhost:61613');
} catch(StompException $e) {
    die('Connection failed: ' . $e->getMessage());
}

var_dump($stomp->getSessionId());

/* close connection */
unset($stomp);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(35) "ID:php.net-52873-1257291895530-4:14"

Örnek 2 Yordamsal kullanım

<?php

/* connection */
$link = stomp_connect('ssl://localhost:61612');

/* check connection */
if (!$link) {
    die('Connection failed: ' . stomp_connect_error());
}

var_dump(stomp_get_session_id($link));

/* close connection */
stomp_close($link);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(35) "ID:php.net-52873-1257291895530-4:14"

Stomp::getReadTimeout
Stomp::hasFrame
Stomp


Indicates whether or not there is a frame ready to read

Stomp::getSessionId
Stomp::readFrame
Stomp
PHP Manual

Stomp::hasFrame

stomp_has_frame

(PECL stomp >= 0.1.0)

Stomp::hasFrame -- stomp_has_frame — Indicates whether or not there is a frame ready to read

Açıklama

Nesne yönelimli kullanım (method):

public bool Stomp::hasFrame ( void )

Yordamsal kullanım:

bool stomp_has_frame ( resource $link )

Indicates whether or not there is a frame ready to read.

Değiştirgeler

link

Procedural style only: The stomp link identifier returned by stomp_connect().

Dönen Değerler

Returns TRUE if a frame is ready to read, or FALSE otherwise.

Stomp::getSessionId
Stomp::readFrame
Stomp


Reads the next frame

Stomp::hasFrame
Stomp::send
Stomp
PHP Manual

Stomp::readFrame

stomp_read_frame

(PECL stomp >= 0.1.0)

Stomp::readFrame -- stomp_read_frame — Reads the next frame

Açıklama

Nesne yönelimli kullanım (method):

public stompframe Stomp::readFrame ([ string $class_name = "stompFrame" ] )

Yordamsal kullanım:

array stomp_read_frame ( resource $link )

Reads the next frame. It is possible to instantiate an object of a specific class, and pass parameters to that class's constructor.

Değiştirgeler

link

Procedural style only: The stomp link identifier returned by stomp_connect().

class_name

The name of the class to instantiate. If not specified, a stompFrame object is returned.

Dönen Değerler

Bilginize:

A transaction header may be specified, indicating that the message acknowledgment should be part of the named transaction.

Sürüm Bilgisi

Sürüm: | Açıklama
Stomp 0.4.0 | class_name parameter was added.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php

/* connection */
try {
    $stomp = new Stomp('tcp://localhost:61613');
} catch(StompException $e) {
    die('Connection failed: ' . $e->getMessage());
}

/* subscribe to messages from the queue 'foo' */
$stomp->subscribe('/queue/foo');

/* read a frame */
var_dump($stomp->readFrame());

/* close connection */
unset($stomp);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(StompFrame)#2 (3) {
  ["command"]=>
  string(7) "MESSAGE"
  ["headers"]=>
  array(5) {
    ["message-id"]=>
    string(41) "ID:php.net-55293-1257226743606-4:2:-1:1:1"
    ["destination"]=>
    string(10) "/queue/foo"
    ["timestamp"]=>
    string(13) "1257226805828"
    ["expires"]=>
    string(1) "0"
    ["priority"]=>
    string(1) "0"
  }
  ["body"]=>
  string(3) "bar"
}

Örnek 2 Yordamsal kullanım

<?php

/* connection */
$link = stomp_connect('ssl://localhost:61612');

/* check connection */
if (!$link) {
    die('Connection failed: ' . stomp_connect_error());
}

/* subscribe to messages from the queue 'foo' */
stomp_subscribe($link, '/queue/foo');

/* read a frame */
$frame = stomp_read_frame($link);

/* close connection */
stomp_close($link);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(3) {
  ["command"]=>
  string(7) "MESSAGE"
  ["body"]=>
  string(3) "bar"
  ["headers"]=>
  array(6) {
    ["transaction"]=>
    string(2) "t1"
    ["message-id"]=>
    string(41) "ID:php.net-55293-1257226743606-4:3:-1:1:1"
    ["destination"]=>
    string(10) "/queue/foo"
    ["timestamp"]=>
    string(13) "1257227037059"
    ["expires"]=>
    string(1) "0"
    ["priority"]=>
    string(1) "0"
  }
}

Stomp::hasFrame
Stomp::send
Stomp


Sends a message

Stomp::readFrame
Stomp::setReadTimeout
Stomp
PHP Manual

Stomp::send

stomp_send

(PECL stomp >= 0.1.0)

Stomp::send -- stomp_send — Sends a message

Açıklama

Nesne yönelimli kullanım (method):

public bool Stomp::send ( string $destination , mixed $msg [, array $headers ] )

Yordamsal kullanım:

bool stomp_send ( resource $link , string $destination , mixed $msg [, array $headers ] )

Sends a message to the Message Broker.

Değiştirgeler

link

Procedural style only: The stomp link identifier returned by stomp_connect().

destination

Where to send the message

msg

Message to send.

headers

Associative array containing the additional headers (example: receipt).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

Bilginize:

A transaction header may be specified, indicating that the message acknowledgment should be part of the named transaction.

İpucu

Stomp is inherently asynchronous. Synchronous communication can be implemented adding a receipt header. This will cause methods to not return anything until the server has acknowledged receipt of the message or until read timeout was reached.

Örnekler

See stomp_ack().

Stomp::readFrame
Stomp::setReadTimeout
Stomp


Sets read timeout

Stomp::send
Stomp::subscribe
Stomp
PHP Manual

Stomp::setReadTimeout

stomp_set_read_timeout

(PECL stomp >= 0.3.0)

Stomp::setReadTimeout -- stomp_set_read_timeout — Sets read timeout

Açıklama

Nesne yönelimli kullanım (method):

public void Stomp::setReadTimeout ( int $seconds [, int $microseconds ] )

Yordamsal kullanım:

void stomp_set_read_timeout ( resource $link , int $seconds [, int $microseconds ] )

Sets read timeout.

Değiştirgeler

link

Procedural style only: The stomp link identifier returned by stomp_connect().

seconds

The seconds part of the timeout to be set.

microseconds

The microseconds part of the timeout to be set.

Örnekler

Örnek 1 Nesne yönelimli kullanım

<?php

/* connection */
try {
    $stomp = new Stomp('tcp://localhost:61613');
} catch(StompException $e) {
    die('Connection failed: ' . $e->getMessage());
}

$stomp->setReadTimeout(10);

/* close connection */
unset($stomp);

?>

Örnek 2 Yordamsal kullanım

<?php

/* connection */
$link = stomp_connect('ssl://localhost:61612');

/* check connection */
if (!$link) {
    die('Connection failed: ' . stomp_connect_error());
}

stomp_set_read_timeout($link, 10);

/* close connection */
stomp_close($link);

?>

Stomp::send
Stomp::subscribe
Stomp


Registers to listen to a given destination

Stomp::setReadTimeout
Stomp::unsubscribe
Stomp
PHP Manual

Stomp::subscribe

stomp_subscribe

(PECL stomp >= 0.1.0)

Stomp::subscribe -- stomp_subscribe — Registers to listen to a given destination

Açıklama

Nesne yönelimli kullanım (method):

public bool Stomp::subscribe ( string $destination [, array $headers ] )

Yordamsal kullanım:

bool stomp_subscribe ( resource $link , string $destination [, array $headers ] )

Registers to listen to a given destination.

Değiştirgeler

link

Procedural style only: The stomp link identifier returned by stomp_connect().

destination

Destination to subscribe to.

headers

Associative array containing the additional headers (example: receipt).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

İpucu

Stomp is inherently asynchronous. Synchronous communication can be implemented adding a receipt header. This will cause methods to not return anything until the server has acknowledged receipt of the message or until read timeout was reached.

Örnekler

See stomp_ack().

Stomp::setReadTimeout
Stomp::unsubscribe
Stomp


Removes an existing subscription

Stomp::subscribe
StompFrame
Stomp
PHP Manual

Stomp::unsubscribe

stomp_unsubscribe

(PECL stomp >= 0.1.0)

Stomp::unsubscribe -- stomp_unsubscribe — Removes an existing subscription

Açıklama

Nesne yönelimli kullanım (method):

public bool Stomp::unsubscribe ( string $destination [, array $headers ] )

Yordamsal kullanım:

bool stomp_unsubscribe ( resource $link , string $destination [, array $headers ] )

Removes an existing subscription.

Değiştirgeler

link

Procedural style only: The stomp link identifier returned by stomp_connect().

destination

Subscription to remove.

headers

Associative array containing the additional headers (example: receipt).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

İpucu

Stomp is inherently asynchronous. Synchronous communication can be implemented adding a receipt header. This will cause methods to not return anything until the server has acknowledged receipt of the message or until read timeout was reached.

Örnekler

See stomp_ack().

Stomp::subscribe
StompFrame
Stomp


The StompFrame class

(PECL stomp >= 0.1.0)

Giriş

Represents a message which was sent or received from a Stomp compliant Message Broker.

Sınıf Sözdizimi

StompFrame {
/* Özellikler */
public $command ;
public $headers ;
public $body ;
/* Yöntemler */
__construct ([ string $command [, array $headers [, string $body ]]] )
}

Özellikler

command

Frame command.

headers

Frame headers (array).

body

Frame body.

İçindekiler

  • StompFrame::__construct — Constructor
Stomp::unsubscribe
StompFrame::__construct
Stomp


Constructor

StompFrame
StompException
StompFrame
PHP Manual

StompFrame::__construct

(PECL stomp >= 0.1.0)

StompFrame::__construct — Constructor

Açıklama

StompFrame::__construct ([ string $command [, array $headers [, string $body ]]] )

Constructor.

Değiştirgeler

command

Frame command

headers

Frame headers (array).

body

Frame body.

StompFrame
StompException
StompFrame


The StompException class

(PECL stomp >= 0.1.0)

Giriş

Represents an error raised by the stomp extension. See Exceptions for more information about Exceptions in PHP.

Sınıf Sözdizimi

StompException extends Exception {
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
/* Yöntemler */
public string getDetails ( void )
}

İçindekiler

  • StompException::getDetails — Get exception details
StompFrame::__construct
StompException::getDetails
Stomp


Get exception details

StompException
SVM
StompException
PHP Manual

StompException::getDetails

(PECL stomp >= 0.1.0)

StompException::getDetails — Get exception details

Açıklama

public string StompException::getDetails ( void )

Get exception details.

Dönen Değerler

string containing the error details.

StompException
SVM
StompException


Support Vector Machine

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Örnekler
  • SVM — The SVM class
    • SVM::__construct — Construct a new SVM object
    • SVM::crossvalidate — Test training params on subsets of the training data.
    • SVM::getOptions — Return the current training parameters
    • SVM::setOptions — Set training parameters
    • SVM::train — Create a SVMModel based on training data
  • SVMModel — The SVMModel class
    • SVMModel::checkProbabilityModel — Returns true if the model has probability information
    • SVMModel::__construct — Construct a new SVMModel
    • SVMModel::getLabels — Get the labels the model was trained on
    • SVMModel::getNrClass — Returns the number of classes the model was trained with
    • SVMModel::getSvmType — Get the SVM type the model was trained with
    • SVMModel::getSvrProbability — Get the sigma value for regression types
    • SVMModel::load — Load a saved SVM Model
    • SVMModel::predict_probability — Return class probabilities for previous unseen data
    • SVMModel::predict — Predict a value for previously unseen data
    • SVMModel::save — Save a model to a file
StompException::getDetails
Giriş
Diğer Hizmetler


Giriş

LibSVM is an efficient solver for SVM classification and regression problems. The svm extension wraps this in a PHP interface for easy use in PHP scripts.

SVM
Yapılandırma/Kurulum
SVM


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
SVM


Gereksinimler

Libsvm itself is required, and is available through some package management - libsvm-devel for RPM based system or libsvm-dev for Debian based ones. Alternatively it is available direct from the website. If installing from the » official website then some steps will need to be taken as the package does not install automatically. For example, assuming the latest version is 3.1:

wget http://www.csie.ntu.edu.tw/~cjlin/cgi-bin/libsvm.cgi?+http://www.csie.ntu.edu.tw/~cjlin/libsvm+tar.gz
tar xvzf libsvm-3.1.tar.gz
cd libsvm-3.1
make lib
cp libsvm.so.1 /usr/lib
ln -s libsvm.so.1 libsvm.so
ldconfig
ldconfig --print | grep libsvm

This last step should show libsvm is installed.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/svm

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Örnekler

The basic process is to define parameters, supply training data to generate a model on, then make predictions based on the model. There are a default set of parameters that should get some results with most any input, so we'll start by looking at the data.

Data is supplied in either a file, a stream, or as an array. If supplied in a file or a stream, it must contain one line per training example, which must be formatted as an integer class (usually 1 and -1) followed by a series of feature/value pairs, in increasing feature order. The features are integers, the values floats, usually scaled 0-1. For example:

-1 1:0.43 3:0.12 9284:0.2

In a document classification problem, say a spam checker, each line would represent a document. There would be two classes, -1 for spam, 1 for ham. Each feature would represent some word, and the value would represent that importance of that word to the document (perhaps the frequency count, with the total scaled to unit length). Features that were 0 (e.g. the word did not appear in the document at all) would simply not be included.

In array mode, the data must be passed as an array of arrays. Each sub-array must have the class as the first element, then key => value sets for the feature values pairs.

This data is passed to the SVM class's train function, which will return an SVM model is successful.

Once a model has been generated, it can be used to make predictions about previously unseen data. This can be passed as an array to the model's predict function, in the same format as before, but without the label. The response will be the class.

Models can be saved and restored as required, using the save and load functions, which both take a file location.

Örnek 1 Train from array

<?php
$data = array(
    array(-1, 1 => 0.43, 3 => 0.12, 9284 => 0.2),
    array(1, 1 => 0.22, 5 => 0.01, 94 => 0.11),
);

$svm = new SVM();
$model = $svm->train($data);

$data = array(1 => 0.43, 3 => 0.12, 9284 => 0.2);
$result = $model->predict($data);
var_dump($result);
$model->save('model.svm');
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(-1)

Örnek 2 Train from a file

<?php
$svm = new SVM();
$model = $svm->train("traindata.txt");
?>

Özkaynak Türleri
SVM
SVM


The SVM class

(PECL svm >= 0.1.0)

Giriş

Sınıf Sözdizimi

SVM {
/* Constants */
const integer C_SVC = 0 ;
const integer NU_SVC = 1 ;
const integer ONE_CLASS = 2 ;
const integer EPSILON_SVR = 3 ;
const integer NU_SVR = 4 ;
const integer KERNEL_LINEAR = 0 ;
const integer KERNEL_POLY = 1 ;
const integer KERNEL_RBF = 2 ;
const integer KERNEL_SIGMOID = 3 ;
const integer KERNEL_PRECOMPUTED = 4 ;
const integer OPT_TYPE = 101 ;
const integer OPT_KERNEL_TYPE = 102 ;
const integer OPT_DEGREE = 103 ;
const integer OPT_SHRINKING = 104 ;
const integer OPT_PROPABILITY = 105 ;
const integer OPT_GAMMA = 201 ;
const integer OPT_NU = 202 ;
const integer OPT_EPS = 203 ;
const integer OPT_P = 204 ;
const integer OPT_COEF_ZERO = 205 ;
const integer OPT_C = 206 ;
const integer OPT_CACHE_SIZE = 207 ;
/* Methods */
public __construct ( void )
public float svm::crossvalidate ( array $problem , int $number_of_folds )
public array getOptions ( void )
public bool setOptions ( array $params )
public SVMModel svm::train ( array $problem [, array $weights ] )
}

Öntanımlı Sabitler

SVM Constants

SVM::C_SVC

The basic C_SVC SVM type. The default, and a good starting point

SVM::NU_SVC

The NU_SVC type uses a different, more flexible, error weighting

SVM::ONE_CLASS

One class SVM type. Train just on a single class, using outliers as negative examples

SVM::EPSILON_SVR

A SVM type for regression (predicting a value rather than just a class)

SVM::NU_SVR

A NU style SVM regression type

SVM::KERNEL_LINEAR

A very simple kernel, can work well on large document classification problems

SVM::KERNEL_POLY

A polynomial kernel

SVM::KERNEL_RBF

The common Gaussian RBD kernel. Handles non-linear problems well and is a good default for classification

SVM::KERNEL_SIGMOID

A kernel based on the sigmoid function. Using this makes the SVM very similar to a two layer sigmoid based neural network

SVM::KERNEL_PRECOMPUTED

A precomputed kernel - currently unsupported.

SVM::OPT_TYPE

The options key for the SVM type

SVM::OPT_KERNEL_TYPE

The options key for the kernel type

SVM::OPT_DEGREE

SVM::OPT_SHRINKING

Training parameter, boolean, for whether to use the shrinking heuristics

SVM::OPT_PROBABILITY

Training parameter, boolean, for whether to collect and use probability estimates

SVM::OPT_GAMMA

Algorithm parameter for Poly, RBF and Sigmoid kernel types.

SVM::OPT_NU

The option key for the nu parameter, only used in the NU_ SVM types

SVM::OPT_EPS

The option key for the Epsilon parameter, used in epsilon regression

SVM::OPT_P

Training parameter used by Episilon SVR regression

SVM::OPT_COEF_ZERO

Algorithm parameter for poly and sigmoid kernels

SVM::OPT_C

The option for the cost parameter that controls tradeoff between errors and generality - effectively the penalty for misclassifying training examples.

SVM::OPT_CACHE_SIZE

Memory cache size, in MB

İçindekiler

  • SVM::__construct — Construct a new SVM object
  • SVM::crossvalidate — Test training params on subsets of the training data.
  • SVM::getOptions — Return the current training parameters
  • SVM::setOptions — Set training parameters
  • SVM::train — Create a SVMModel based on training data
Örnekler
SVM::__construct
SVM


Construct a new SVM object

SVM
SVM::crossvalidate
SVM
PHP Manual

SVM::__construct

(PECL svm >= 0.1.0)

SVM::__construct — Construct a new SVM object

Açıklama

public SVM::__construct ( void )

Constructs a new SVM object ready to accept training data.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Throws SVMException if the libsvm library could not be loaded

SVM
SVM::crossvalidate
SVM


Test training params on subsets of the training data.

SVM::__construct
SVM::getOptions
SVM
PHP Manual

SVM::crossvalidate

(PECL svm >= 0.1.0)

SVM::crossvalidate — Test training params on subsets of the training data.

Açıklama

public float svm::crossvalidate ( array $problem , int $number_of_folds )

Crossvalidate can be used to test the effectiveness of the current parameter set on a subset of the training data. Given a problem set and a n "folds", it separates the problem set into n subsets, and the repeatedly trains on one subset and tests on another. While the accuracy will generally be lower than a SVM trained on the enter data set, the accuracy score returned should be relatively useful, so it can be used to test different training parameters.

Değiştirgeler

problem

The problem data. This can either be in the form of an array, the URL of an SVMLight formatted file, or a stream to an opened SVMLight formatted datasource.

number_of_folds

The number of sets the data should be divided into and cross tested. A higher number means smaller training sets and less reliability. 5 is a good number to start with.

Dönen Değerler

The correct percentage, expressed as a floating point number from 0-1. In the case of NU_SVC or EPSILON_SVR kernels the mean squared error will returned instead.

Ayrıca Bakınız

  • SVM::train() - Create a SVMModel based on training data

SVM::__construct
SVM::getOptions
SVM


Return the current training parameters

SVM::crossvalidate
SVM::setOptions
SVM
PHP Manual

SVM::getOptions

(PECL svm >= 0.1.0)

SVM::getOptions — Return the current training parameters

Açıklama

public array SVM::getOptions ( void )

Retrieve an array containing the training parameters. The parameters will be keyed on the predefined SVM constants.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array of configuration settings.

SVM::crossvalidate
SVM::setOptions
SVM


Set training parameters

SVM::getOptions
SVM::train
SVM
PHP Manual

SVM::setOptions

(PECL svm >= 0.1.0)

SVM::setOptions — Set training parameters

Açıklama

public bool SVM::setOptions ( array $params )

Set one or more training parameters.

Değiştirgeler

params

An array of training parameters, keyed on the SVM constants.

Dönen Değerler

Return true on success, throws SVMException on error.

SVM::getOptions
SVM::train
SVM


Create a SVMModel based on training data

SVM::setOptions
SVMModel
SVM
PHP Manual

SVM::train

(PECL svm >= 0.1.0)

SVM::train — Create a SVMModel based on training data

Açıklama

public SVMModel svm::train ( array $problem [, array $weights ] )

Train a support vector machine based on the supplied training data.

Değiştirgeler

problem

The problem can be provided in three different ways. An array, where the data should start with the class label (usually 1 or -1) then followed by a sparse data set of dimension => data pairs. A URL to a file containing a SVM Light formatted problem, with the each line being a new training example, the start of each line containing the class (1, -1) then a series of tab separated data values shows as key:value. A opened stream pointing to a data source formatted as in the file above.

weights

Weights are an optional set of weighting parameters for the different classes, to help account for unbalanced training sets. For example, if the classes were 1 and -1, and -1 had significantly more example than one, the weight for -1 could be 0.5. Weights should be in the range 0-1.

Dönen Değerler

Returns an SVMModel that can be used to classify previously unseen data. Throws SVMException on error

SVM::setOptions
SVMModel
SVM


The SVMModel class

(PECL svm >= 0.1.0)

Giriş

The SVMModel is the end result of the training process. It can be used to classify previously unseen data.

Sınıf Sözdizimi

SVMModel {
/* Methods */
public bool checkProbabilityModel ( void )
public __construct ([ string $filename ] )
public array getLabels ( void )
public int getNrClass ( void )
public int getSvmType ( void )
public float getSvrProbability ( void )
public bool load ( string $filename )
public float predict_probability ( array $data )
public float predict ( array $data )
public bool save ( string $filename )
}

İçindekiler

  • SVMModel::checkProbabilityModel — Returns true if the model has probability information
  • SVMModel::__construct — Construct a new SVMModel
  • SVMModel::getLabels — Get the labels the model was trained on
  • SVMModel::getNrClass — Returns the number of classes the model was trained with
  • SVMModel::getSvmType — Get the SVM type the model was trained with
  • SVMModel::getSvrProbability — Get the sigma value for regression types
  • SVMModel::load — Load a saved SVM Model
  • SVMModel::predict_probability — Return class probabilities for previous unseen data
  • SVMModel::predict — Predict a value for previously unseen data
  • SVMModel::save — Save a model to a file
SVM::train
SVMModel::checkProbabilityModel
SVM


Returns true if the model has probability information

SVMModel
SVMModel::__construct
SVMModel
PHP Manual

SVMModel::checkProbabilityModel

(PECL svm >= 0.1.5)

SVMModel::checkProbabilityModel — Returns true if the model has probability information

Açıklama

public bool SVMModel::checkProbabilityModel ( void )

Returns true if the model contains probability information.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Return a boolean value

SVMModel
SVMModel::__construct
SVMModel


Construct a new SVMModel

SVMModel::checkProbabilityModel
SVMModel::getLabels
SVMModel
PHP Manual

SVMModel::__construct

(PECL svm >= 0.1.0)

SVMModel::__construct — Construct a new SVMModel

Açıklama

public SVMModel::__construct ([ string $filename ] )

Build a new SVMModel. Models will usually be created from the SVM::train function, but then saved models may be restored directly.

Değiştirgeler

filename

The filename for the saved model file this model should load.

Dönen Değerler

Throws SVMException on error

Ayrıca Bakınız

  • SVMModel::load() - Load a saved SVM Model

SVMModel::checkProbabilityModel
SVMModel::getLabels
SVMModel


Get the labels the model was trained on

SVMModel::__construct
SVMModel::getNrClass
SVMModel
PHP Manual

SVMModel::getLabels

(PECL svm >= 0.1.5)

SVMModel::getLabels — Get the labels the model was trained on

Açıklama

public array SVMModel::getLabels ( void )

Return an array of labels that the model was trained on. For regression and one class models an empty array is returned.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Return an array of labels

Ayrıca Bakınız

  • SVMModel::getNrClass() - Returns the number of classes the model was trained with

SVMModel::__construct
SVMModel::getNrClass
SVMModel


Returns the number of classes the model was trained with

SVMModel::getLabels
SVMModel::getSvmType
SVMModel
PHP Manual

SVMModel::getNrClass

(PECL svm >= 0.1.5)

SVMModel::getNrClass — Returns the number of classes the model was trained with

Açıklama

public int SVMModel::getNrClass ( void )

Returns the number of classes the model was trained with, will return 2 for one class and regression models.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Return an integer number of classes

SVMModel::getLabels
SVMModel::getSvmType
SVMModel


Get the SVM type the model was trained with

SVMModel::getNrClass
SVMModel::getSvrProbability
SVMModel
PHP Manual

SVMModel::getSvmType

(PECL svm >= 0.1.5)

SVMModel::getSvmType — Get the SVM type the model was trained with

Açıklama

public int SVMModel::getSvmType ( void )

Returns an integer value representing the type of the SVM model used, e.g SVM::C_SVC.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Return an integer SVM type

SVMModel::getNrClass
SVMModel::getSvrProbability
SVMModel


Get the sigma value for regression types

SVMModel::getSvmType
SVMModel::load
SVMModel
PHP Manual

SVMModel::getSvrProbability

(PECL svm >= 0.1.5)

SVMModel::getSvrProbability — Get the sigma value for regression types

Açıklama

public float SVMModel::getSvrProbability ( void )

For regression models, returns a sigma value. If there is no probability information or the model is not SVR, 0 is returned.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a sigma value

SVMModel::getSvmType
SVMModel::load
SVMModel


Load a saved SVM Model

SVMModel::getSvrProbability
SVMModel::predict_probability
SVMModel
PHP Manual

SVMModel::load

(PECL svm >= 0.1.00.1.0)

SVMModel::load — Load a saved SVM Model

Açıklama

public bool SVMModel::load ( string $filename )

Load a model file ready for classification or regression.

Değiştirgeler

filename

The filename of the model.

Dönen Değerler

Throws SVMException on error. Returns true on success.

Ayrıca Bakınız

  • SVMModel::save() - Save a model to a file

SVMModel::getSvrProbability
SVMModel::predict_probability
SVMModel


Return class probabilities for previous unseen data

SVMModel::load
SVMModel::predict
SVMModel
PHP Manual

SVMModel::predict_probability

(PECL svm >= 0.1.4)

SVMModel::predict_probability — Return class probabilities for previous unseen data

Açıklama

public float SVMModel::predict_probability ( array $data )

This function accepts an array of data and attempts to predict the class, as with the predict function. Additionally, however, this function returns an array of probabilities, one per class in the model, which represent the estimated chance of the data supplied being a member of that class. Requires that the model to be used has been trained with the probability parameter set to true.

Değiştirgeler

data

The array to be classified. This should be a series of key => value pairs in increasing key order, but not necessarily continuous.

probabilities

The supplied value will be filled with the probabilities. This will be either null, in the case of a model without probability information, or an array where the index is the class name and the value the predicted probability.

Dönen Değerler

Float the predicted value. This will be a class label in the case of classification, a real value in the case of regression. Throws SVMException on error

Ayrıca Bakınız

  • SVM::predict()

SVMModel::load
SVMModel::predict
SVMModel


Predict a value for previously unseen data

SVMModel::predict_probability
SVMModel::save
SVMModel
PHP Manual

SVMModel::predict

(PECL svm >= 0.1.0)

SVMModel::predict — Predict a value for previously unseen data

Açıklama

public float SVMModel::predict ( array $data )

This function accepts an array of data and attempts to predict the class or regression value based on the model extracted from previously trained data.

Değiştirgeler

data

The array to be classified. This should be a series of key => value pairs in increasing key order, but not necessarily continuous.

Dönen Değerler

Float the predicted value. This will be a class label in the case of classification, a real value in the case of regression. Throws SVMException on error

Ayrıca Bakınız

  • SVM::train() - Create a SVMModel based on training data

SVMModel::predict_probability
SVMModel::save
SVMModel


Save a model to a file

SVMModel::predict
SVN
SVMModel
PHP Manual

SVMModel::save

(PECL svm >= 0.1.0)

SVMModel::save — Save a model to a file

Açıklama

public bool SVMModel::save ( string $filename )

Save the model data to a file, for later use.

Değiştirgeler

filename

The file to save the model to.

Dönen Değerler

Throws SVMException on error. Returns true on success.

Ayrıca Bakınız

  • SVMModel::load() - Load a saved SVM Model

SVMModel::predict
SVN
SVMModel


Subversion

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • SVN İşlevleri
    • svn_add — Schedules the addition of an item in a working directory
    • svn_auth_get_parameter — Retrieves authentication parameter
    • svn_auth_set_parameter — Sets an authentication parameter
    • svn_blame — Get the SVN blame for a file
    • svn_cat — Returns the contents of a file in a repository
    • svn_checkout — Checks out a working copy from the repository
    • svn_cleanup — Recursively cleanup a working copy directory, finishing incomplete operations and removing locks
    • svn_client_version — Returns the version of the SVN client libraries
    • svn_commit — Sends changes from the local working copy to the repository
    • svn_delete — Delete items from a working copy or repository.
    • svn_diff — Recursively diffs two paths
    • svn_export — Export the contents of a SVN directory
    • svn_fs_abort_txn — Abort a transaction, returns true if everything is okay, false otherwise
    • svn_fs_apply_text — Creates and returns a stream that will be used to replace
    • svn_fs_begin_txn2 — Create a new transaction
    • svn_fs_change_node_prop — Return true if everything is ok, false otherwise
    • svn_fs_check_path — Determines what kind of item lives at path in a given repository fsroot
    • svn_fs_contents_changed — Return true if content is different, false otherwise
    • svn_fs_copy — Copies a file or a directory, returns true if all is ok, false otherwise
    • svn_fs_delete — Deletes a file or a directory, return true if all is ok, false otherwise
    • svn_fs_dir_entries — Enumerates the directory entries under path; returns a hash of dir names to file type
    • svn_fs_file_contents — Returns a stream to access the contents of a file from a given version of the fs
    • svn_fs_file_length — Returns the length of a file from a given version of the fs
    • svn_fs_is_dir — Return true if the path points to a directory, false otherwise
    • svn_fs_is_file — Return true if the path points to a file, false otherwise
    • svn_fs_make_dir — Creates a new empty directory, returns true if all is ok, false otherwise
    • svn_fs_make_file — Creates a new empty file, returns true if all is ok, false otherwise
    • svn_fs_node_created_rev — Returns the revision in which path under fsroot was created
    • svn_fs_node_prop — Returns the value of a property for a node
    • svn_fs_props_changed — Return true if props are different, false otherwise
    • svn_fs_revision_prop — Fetches the value of a named property
    • svn_fs_revision_root — Get a handle on a specific version of the repository root
    • svn_fs_txn_root — Creates and returns a transaction root
    • svn_fs_youngest_rev — Returns the number of the youngest revision in the filesystem
    • svn_import — Imports an unversioned path into a repository
    • svn_log — Returns the commit log messages of a repository URL
    • svn_ls — Returns list of directory contents in repository URL, optionally at revision number
    • svn_mkdir — Creates a directory in a working copy or repository
    • svn_repos_create — Create a new subversion repository at path
    • svn_repos_fs_begin_txn_for_commit — Create a new transaction
    • svn_repos_fs_commit_txn — Commits a transaction and returns the new revision
    • svn_repos_fs — Gets a handle on the filesystem for a repository
    • svn_repos_hotcopy — Make a hot-copy of the repos at repospath; copy it to destpath
    • svn_repos_open — Open a shared lock on a repository.
    • svn_repos_recover — Run recovery procedures on the repository located at path.
    • svn_revert — Revert changes to the working copy
    • svn_status — Returns the status of working copy files and directories
    • svn_update — Update working copy
SVMModel::save
Giriş
Diğer Hizmetler


Giriş

This extension implements PHP bindings for » Subversion (SVN), a version control system, allowing PHP scripts to communicate with SVN repositories and working copies without direct command line calls to the svn executable.

Uyarı

Bu eklenti DENEYSELDİR. Bu eklentinin davranışı, işlev isimleri ve tüm belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu eklentiyi kullanmayın.

SVN
Yapılandırma/Kurulum
SVN


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
SVN


Gereksinimler

The Subversion binaries are not necessary to use this extension. However, when compiling the extension, libsvn (the Subversion headers) must be available.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/svn

If ./configure is having trouble finding the SVN files (for example, Subversion was installed with a different prefix directory), use ./configure --with-svn=$USR_PATH to specify the directory where the include/subversion-1/ folder is located.

Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız.

Uyarı

If the extension is compiled against libsvn 1.3, functions that work with working copies will fail when used on working copies created by Subversion 1.4.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

SVN_REVISION_HEAD (integer)
Magic number (-1) specifying the HEAD revision
Constants usable with svn_auth_set_parameter()
SVN_AUTH_PARAM_DEFAULT_USERNAME (string)
Property for default username to use when performing basic authentication
SVN_AUTH_PARAM_DEFAULT_PASSWORD (string)
Property for default password to use when performing basic authentication
SVN_AUTH_PARAM_NON_INTERACTIVE (string)
SVN_AUTH_PARAM_DONT_STORE_PASSWORDS (string)
SVN_AUTH_PARAM_NO_AUTH_CACHE (string)
SVN_AUTH_PARAM_SSL_SERVER_FAILURES (string)
SVN_AUTH_PARAM_SSL_SERVER_CERT_INFO (string)
SVN_AUTH_PARAM_CONFIG (string)
SVN_AUTH_PARAM_SERVER_GROUP (string)
SVN_AUTH_PARAM_CONFIG_DIR (string)
PHP_SVN_AUTH_PARAM_IGNORE_SSL_VERIFY_ERRORS (string)
Custom property for ignoring SSL cert verification errors
Filesystem constants
SVN_FS_CONFIG_FS_TYPE (string)
Configuration key that determines filesystem type
SVN_FS_TYPE_BDB (string)
Filesystem is Berkeley-DB implementation
SVN_FS_TYPE_FSFS (string)
Filesystem is native-filesystem implementation
Reserved property constants
SVN_PROP_REVISION_DATE (string)
svn:date
SVN_PROP_REVISION_ORIG_DATE (string)
svn:original-date
SVN_PROP_REVISION_AUTHOR (string)
svn:author
SVN_PROP_REVISION_LOG (string)
svn:log
Working copy status constants
SVN_WC_STATUS_NONE (int)
Status does not exist
SVN_WC_STATUS_UNVERSIONED (int)
Item is not versioned in working copy
SVN_WC_STATUS_NORMAL (int)
Item exists, nothing else is happening
SVN_WC_STATUS_ADDED (int)
Item is scheduled for addition
SVN_WC_STATUS_MISSING (int)
Item is versioned but missing from the working copy
SVN_WC_STATUS_DELETED (int)
Item is scheduled for deletion
SVN_WC_STATUS_REPLACED (int)
Item was deleted and then re-added
SVN_WC_STATUS_MODIFIED (int)
Item (text or properties) was modified
SVN_WC_STATUS_MERGED (int)
Item's local modifications were merged with repository modifications
SVN_WC_STATUS_CONFLICTED (int)
Item's local modifications conflicted with repository modifications
SVN_WC_STATUS_IGNORED (int)
Item is unversioned but configured to be ignored
SVN_WC_STATUS_OBSTRUCTED (int)
Unversioned item is in the way of a versioned resource
SVN_WC_STATUS_EXTERNAL (int)
Unversioned path that is populated using svn:externals
SVN_WC_STATUS_INCOMPLETE (int)
Directory does not contain complete entries list
Node type constants
SVN_NODE_NONE (int)
Absent
SVN_NODE_FILE (int)
File
SVN_NODE_DIR (int)
Directory
SVN_NODE_UNKNOWN (int)
Something Subversion cannot identify
Özkaynak Türleri
SVN İşlevleri
SVN


SVN İşlevleri

İçindekiler

  • svn_add — Schedules the addition of an item in a working directory
  • svn_auth_get_parameter — Retrieves authentication parameter
  • svn_auth_set_parameter — Sets an authentication parameter
  • svn_blame — Get the SVN blame for a file
  • svn_cat — Returns the contents of a file in a repository
  • svn_checkout — Checks out a working copy from the repository
  • svn_cleanup — Recursively cleanup a working copy directory, finishing incomplete operations and removing locks
  • svn_client_version — Returns the version of the SVN client libraries
  • svn_commit — Sends changes from the local working copy to the repository
  • svn_delete — Delete items from a working copy or repository.
  • svn_diff — Recursively diffs two paths
  • svn_export — Export the contents of a SVN directory
  • svn_fs_abort_txn — Abort a transaction, returns true if everything is okay, false otherwise
  • svn_fs_apply_text — Creates and returns a stream that will be used to replace
  • svn_fs_begin_txn2 — Create a new transaction
  • svn_fs_change_node_prop — Return true if everything is ok, false otherwise
  • svn_fs_check_path — Determines what kind of item lives at path in a given repository fsroot
  • svn_fs_contents_changed — Return true if content is different, false otherwise
  • svn_fs_copy — Copies a file or a directory, returns true if all is ok, false otherwise
  • svn_fs_delete — Deletes a file or a directory, return true if all is ok, false otherwise
  • svn_fs_dir_entries — Enumerates the directory entries under path; returns a hash of dir names to file type
  • svn_fs_file_contents — Returns a stream to access the contents of a file from a given version of the fs
  • svn_fs_file_length — Returns the length of a file from a given version of the fs
  • svn_fs_is_dir — Return true if the path points to a directory, false otherwise
  • svn_fs_is_file — Return true if the path points to a file, false otherwise
  • svn_fs_make_dir — Creates a new empty directory, returns true if all is ok, false otherwise
  • svn_fs_make_file — Creates a new empty file, returns true if all is ok, false otherwise
  • svn_fs_node_created_rev — Returns the revision in which path under fsroot was created
  • svn_fs_node_prop — Returns the value of a property for a node
  • svn_fs_props_changed — Return true if props are different, false otherwise
  • svn_fs_revision_prop — Fetches the value of a named property
  • svn_fs_revision_root — Get a handle on a specific version of the repository root
  • svn_fs_txn_root — Creates and returns a transaction root
  • svn_fs_youngest_rev — Returns the number of the youngest revision in the filesystem
  • svn_import — Imports an unversioned path into a repository
  • svn_log — Returns the commit log messages of a repository URL
  • svn_ls — Returns list of directory contents in repository URL, optionally at revision number
  • svn_mkdir — Creates a directory in a working copy or repository
  • svn_repos_create — Create a new subversion repository at path
  • svn_repos_fs_begin_txn_for_commit — Create a new transaction
  • svn_repos_fs_commit_txn — Commits a transaction and returns the new revision
  • svn_repos_fs — Gets a handle on the filesystem for a repository
  • svn_repos_hotcopy — Make a hot-copy of the repos at repospath; copy it to destpath
  • svn_repos_open — Open a shared lock on a repository.
  • svn_repos_recover — Run recovery procedures on the repository located at path.
  • svn_revert — Revert changes to the working copy
  • svn_status — Returns the status of working copy files and directories
  • svn_update — Update working copy
Öntanımlı Sabitler
svn_add
SVN


Schedules the addition of an item in a working directory

SVN İşlevleri
svn_auth_get_parameter
SVN İşlevleri
PHP Manual

svn_add

(PECL svn >= 0.1.0)

svn_add — Schedules the addition of an item in a working directory

Açıklama

bool svn_add ( string $path [, bool $recursive = true [, bool $force = false ]] )

Adds the file, directory or symbolic link at path to the working directory. The item will be added to the repository the next time you call svn_commit() on the working copy.

Değiştirgeler

path

Path of item to add.

Bilginize: Relative paths will be resolved as if the current working directory was the one that contains the PHP binary. To use the calling script's working directory, use realpath() or dirname(__FILE__).

recursive

If item is directory, whether or not to recursively add all of its contents. Default is TRUE

force

If true, Subversion will recurse into already versioned directories in order to add unversioned files that may be hiding in those directories. Default is FALSE

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Örnekler

Örnek 1 svn_add() example

In a working directory where svn status returns:

$ svn status
?      foobar.txt

...this code:

<?php
svn_add('foobar.txt');
?>

...will schedule foobar.txt for addition into the repository.

Ayrıca Bakınız

  • » SVN documentation on svn add

SVN İşlevleri
svn_auth_get_parameter
SVN İşlevleri


Retrieves authentication parameter

svn_add
svn_auth_set_parameter
SVN İşlevleri
PHP Manual

svn_auth_get_parameter

(PECL svn >= 0.1.0)

svn_auth_get_parameter — Retrieves authentication parameter

Açıklama

string svn_auth_get_parameter ( string $key )

Retrieves authentication parameter at key. For a list of valid keys and their meanings, consult the authentication constants list.

Değiştirgeler

key

String key name. Use the authentication constants defined by this extension to specify a key.

Dönen Değerler

Returns the string value of the parameter at key; returns NULL if parameter does not exist.

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Ayrıca Bakınız

  • svn_auth_set_parameter() - Sets an authentication parameter
  • Authentication constants

svn_add
svn_auth_set_parameter
SVN İşlevleri


Sets an authentication parameter

svn_auth_get_parameter
svn_blame
SVN İşlevleri
PHP Manual

svn_auth_set_parameter

(PECL svn >= 0.1.0)

svn_auth_set_parameter — Sets an authentication parameter

Açıklama

void svn_auth_set_parameter ( string $key , string $value )

Sets authentication parameter at key to value. For a list of valid keys and their meanings, consult the authentication constants list.

Değiştirgeler

key

String key name. Use the authentication constants defined by this extension to specify a key.

value

String value to set to parameter at key. Format of value varies with the parameter.

Dönen Değerler

Hiçbir değer dönmez.

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Örnekler

Örnek 1 Default authentication example

This example configures SVN so that the default username to use is 'Bob' and the default password is 'abc123':

<?php
svn_auth_set_parameter(SVN_AUTH_PARAM_DEFAULT_USERNAME, 'Bob');
svn_auth_set_parameter(SVN_AUTH_PARAM_DEFAULT_PASSWORD, 'abc123');
?>

Ayrıca Bakınız

  • svn_auth_get_parameter() - Retrieves authentication parameter
  • Authentication constants

svn_auth_get_parameter
svn_blame
SVN İşlevleri


Get the SVN blame for a file

svn_auth_set_parameter
svn_cat
SVN İşlevleri
PHP Manual

svn_blame

(PECL svn >= 0.3.0)

svn_blame — Get the SVN blame for a file

Açıklama

array svn_blame ( string $repository_url [, int $revision_no = SVN_REVISION_HEAD ] )

Get the SVN blame of a file from a repository URL.

Değiştirgeler

repository_url

The repository URL.

revision_no

The revision number.

Dönen Değerler

An array of SVN blame information separated by line which includes the revision number, line number, line of code, author, and date.

Örnekler

Örnek 1 svn_blame() example

<?php
$svnurl = 'http://svn.example.org/svnroot/foo/trunk/index.php';

print_r( svn_blame($svnurl) );

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [0] = Array
          (
           [rev] = 1
           [line_no] = 1
           [line] = Hello World
           [author] = joesmith
           [date] = 2007-07-02T05:51:26.628396Z
          )
    [1] = Array
          ...

Ayrıca Bakınız

  • svn_diff() - Recursively diffs two paths
  • svn_logs()
  • svn_status() - Returns the status of working copy files and directories

svn_auth_set_parameter
svn_cat
SVN İşlevleri


Returns the contents of a file in a repository

svn_blame
svn_checkout
SVN İşlevleri
PHP Manual

svn_cat

(PECL svn >= 0.1.0)

svn_cat — Returns the contents of a file in a repository

Açıklama

string svn_cat ( string $repos_url [, int $revision_no ] )

Returns the contents of the URL repos_url to a file in the repository, optionally at revision number revision_no.

Değiştirgeler

repos_url

String URL path to item in a repository.

revision_no

Integer revision number of item to retrieve, default is the HEAD revision.

Dönen Değerler

Returns the string contents of the item from the repository on success, and FALSE on failure.

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Örnekler

Örnek 1 Basic example

This example retrieves the contents of a file at revision 28:

<?php
$contents = svn_cat('http://www.example.com/svnroot/calc/gui.c', 28)
?>

Ayrıca Bakınız

  • svn_list()
  • » SVN documentation on svn cat

svn_blame
svn_checkout
SVN İşlevleri


Checks out a working copy from the repository

svn_cat
svn_cleanup
SVN İşlevleri
PHP Manual

svn_checkout

(PECL svn >= 0.1.0)

svn_checkout — Checks out a working copy from the repository

Açıklama

bool svn_checkout ( string $repos , string $targetpath [, int $revision [, int $flags = 0 ]] )

Checks out a working copy from the repository at repos to targetpath at revision revision.

Değiştirgeler

repos

String URL path to directory in repository to check out.

targetpath

String local path to directory to check out in to

Bilginize: Relative paths will be resolved as if the current working directory was the one that contains the PHP binary. To use the calling script's working directory, use realpath() or dirname(__FILE__).

revision

Integer revision number of repository to check out. Default is HEAD, the most recent revision.

flags

Any combination of SVN_NON_RECURSIVE and SVN_IGNORE_EXTERNALS.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Örnekler

Örnek 1 Basic example

This example demonstrates how to check out a directory from a repository to a directory named calc:

<?php
svn_checkout('http://www.example.com/svnroot/calc/trunk', dirname(__FILE__) . '/calc');
?>

The dirname(__FILE__) call is necessary in order to convert the calc relative path into an absolute one. If calc exists, you can also use realpath() to retrieve an absolute path.

Ayrıca Bakınız

  • svn_add() - Schedules the addition of an item in a working directory
  • svn_commit() - Sends changes from the local working copy to the repository
  • svn_status() - Returns the status of working copy files and directories
  • svn_update() - Update working copy
  • » SVN documentation on svn checkout

svn_cat
svn_cleanup
SVN İşlevleri


Recursively cleanup a working copy directory, finishing incomplete operations and removing locks

svn_checkout
svn_client_version
SVN İşlevleri
PHP Manual

svn_cleanup

(PECL svn >= 0.1.0)

svn_cleanup — Recursively cleanup a working copy directory, finishing incomplete operations and removing locks

Açıklama

bool svn_cleanup ( string $workingdir )

Recursively cleanup working copy directory workingdir, finishing any incomplete operations and removing working copy locks. Use when a working copy is in limbo and needs to be usable again.

Değiştirgeler

workingdir

String path to local working directory to cleanup

Bilginize: Relative paths will be resolved as if the current working directory was the one that contains the PHP binary. To use the calling script's working directory, use realpath() or dirname(__FILE__).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Örnekler

Örnek 1 Basic example

This example demonstrates clean up of a working copy in a directory named help-me:

<?php
svn_cleanup(realpath('help-me'));
?>

The realpath() call is necessary due to SVN's quirky handling of relative paths.

Ayrıca Bakınız

  • update()
  • » SVN documentation on svn cleanup

svn_checkout
svn_client_version
SVN İşlevleri


Returns the version of the SVN client libraries

svn_cleanup
svn_commit
SVN İşlevleri
PHP Manual

svn_client_version

(PECL svn >= 0.1.0)

svn_client_version — Returns the version of the SVN client libraries

Açıklama

string svn_client_version ( void )

Returns the version of the SVN client libraries

Dönen Değerler

String version number, usually in form of x.y.z.

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Örnekler

Örnek 1 Basic example

<?php
echo svn_client_version();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

1.3.1

svn_cleanup
svn_commit
SVN İşlevleri


Sends changes from the local working copy to the repository

svn_client_version
svn_delete
SVN İşlevleri
PHP Manual

svn_commit

(PECL svn >= 0.1.0)

svn_commit — Sends changes from the local working copy to the repository

Açıklama

array svn_commit ( string $log , array $targets [, bool $recursive = true ] )

Commits changes made in the local working copy files enumerated in the targets array to the repository, with the log message log. Directories in the targets array will be recursively committed unless recursive is set to FALSE.

Bilginize: This function does not have any parameters for specifying authentication, so a username and password must be set using svn_auth_set_parameter()

Değiştirgeler

log

String log text to commit

targets

Array of local paths of files to be committed

Uyarı

This parameter must be an array, a string for a single target is not acceptable.

Bilginize: Relative paths will be resolved as if the current working directory was the one that contains the PHP binary. To use the calling script's working directory, use realpath() or dirname(__FILE__).

recursive

Boolean flag to disable recursive committing of directories in the targets array. Default is TRUE.

Dönen Değerler

Returns array in form of:

array(
    0 => integer revision number of commit
    1 => string ISO 8601 date and time of commit
    2 => name of committer
)

Returns FALSE on failure.

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Örnekler

Örnek 1 Basic example

This example commits the calculator directory to a repository, using the username Bob and the password abc123 (hopefully, his password is stronger):

<?php
svn_auth_set_parameter(SVN_AUTH_PARAM_DEFAULT_USERNAME, 'Bob');
svn_auth_set_parameter(SVN_AUTH_PARAM_DEFAULT_PASSWORD, 'abc123');
var_dump(svn_commit('Log message of Bob\'s commit', array(realpath('calculator'))));
?>

Yukarıdaki örneğin çıktısı:

array(
  0 => 1415,
  1 => '2007-05-26T01:44:28.453125Z',
  2 => 'Bob'
)

Ayrıca Bakınız

  • svn_auth_set_parameter() - Sets an authentication parameter
  • » SVN documentation on svn commit

svn_client_version
svn_delete
SVN İşlevleri


Delete items from a working copy or repository.

svn_commit
svn_diff
SVN İşlevleri
PHP Manual

svn_delete

(PECL svn >= 0.4.0)

svn_delete — Delete items from a working copy or repository.

Açıklama

bool svn_delete ( string $path [, bool $force = false ] )

Deletes the file, directory or symbolic link at path from the working directory. The item will be deleted from the repository the next time you call svn_commit() on the working copy.

Değiştirgeler

path

Path of item to delete.

Bilginize: Relative paths will be resolved as if the current working directory was the one that contains the PHP binary. To use the calling script's working directory, use realpath() or dirname(__FILE__).

force

If TRUE, the file will be deleted even if it has local modifications. Otherwise, local modifications will result in a failure. Default is FALSE

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Ayrıca Bakınız

  • » SVN documentation on svn delete

svn_commit
svn_diff
SVN İşlevleri


Recursively diffs two paths

svn_delete
svn_export
SVN İşlevleri
PHP Manual

svn_diff

(PECL svn >= 0.1.0)

svn_diff — Recursively diffs two paths

Açıklama

array svn_diff ( string $path1 , int $rev1 , string $path2 , int $rev2 )

Recursively diffs two paths, path1 and path2.

Bilginize:

This is not a general-purpose diff utility. Only local files that are versioned may be diffed: other files will fail.

Değiştirgeler

path1

First path to diff. This can be a URL to a file/directory in an SVN repository or a local file/directory path.

Bilginize: Relative paths will be resolved as if the current working directory was the one that contains the PHP binary. To use the calling script's working directory, use realpath() or dirname(__FILE__).

Uyarı

If a local file path has only backslashes and no forward slashes, this extension will fail to find the path. Always replace all backslashes with forward slashes when using this function.

rev1

First path's revision number. Use SVN_REVISION_HEAD to specify the most recent revision.

path2

Second path to diff. See path1 for description.

rev2

Second path's revision number. See rev1 for description.

Dönen Değerler

Returns an array-list consisting of two streams: the first is the diff output and the second contains error stream output. The streams can be read using fread(). Returns FALSE or NULL on error.

The diff output will, by default, be in the form of Subversion's custom unified diff format, but an » external diff engine may be used depending on Subversion's configuration.

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Örnekler

Örnek 1 Basic example

This example demonstrates the basic usage of this function, and the retrieval of contents from the stream:

<?php
list($diff, $errors) = svn_diff(
    'http://www.example.com/svnroot/trunk/foo', SVN_REVISION_HEAD,
    'http://www.example.com/svnroot/branches/dev/foo', SVN_REVISION_HEAD
);
if (!$diff) exit;
$contents = '';
while (!feof($diff)) {
  $contents .= fread($diff, 8192);
}
fclose($diff);
fclose($errors);
var_dump($contents);
?>

Yukarıdaki örneğin çıktısı:

Index: http://www.example.com/svnroot/trunk/foo
===================================================================
--- http://www.example.com/svnroot/trunk/foo        (.../foo) (revision 23)
+++ http://www.example.com/svnroot/branches/dev/foo (.../foo) (revision 27)
 // further diff output

Örnek 2 Diffing two revisions of a repository path

This example implements a wrapper function that allows a user to easily diff two revisions of the same item using an external repository path (the default syntax is somewhat verbose):

<?php
function svn_diff_same_item($path, $rev1, $rev2) {
    return svn_diff($path, $rev1, $path, $rev2);
}
?>

Örnek 3 Portably diffing two local files

This example implements a wrapper function that portably diffs two local files, compensating for the realpath() fix and the backslashes bug:

<?php
function svn_diff_local($path1, $rev1, $path2, $rev2) {
    $path1 = str_replace('\\', '/', realpath($path1));
    $path2 = str_replace('\\', '/', realpath($path2));
    return svn_diff($path1, $rev1, $path2, $rev2);
}
?>

Ayrıca Bakınız

  • » SVN documentation on svn diff

svn_delete
svn_export
SVN İşlevleri


Export the contents of a SVN directory

svn_diff
svn_fs_abort_txn
SVN İşlevleri
PHP Manual

svn_export

(PECL svn >= 0.3.0)

svn_export — Export the contents of a SVN directory

Açıklama

bool svn_export ( string $frompath , string $topath [, bool $working_copy = true [, int $revision_no = -1 ]] )

Export the contents of either a working copy or repository into a 'clean' directory.

Değiştirgeler

frompath

The path to the current repository.

topath

The path to the new repository.

working_copy

If TRUE, it will export uncommitted files from the working copy.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 svn_export() example

<?php
$working_dir     = '../';
$new_working_dir = '/home/user/devel/foo/trunk';

svn_export($working_dir, $new_working_dir);
?>

Ayrıca Bakınız

  • svn_import() - Imports an unversioned path into a repository

svn_diff
svn_fs_abort_txn
SVN İşlevleri


Abort a transaction, returns true if everything is okay, false otherwise

svn_export
svn_fs_apply_text
SVN İşlevleri
PHP Manual

svn_fs_abort_txn

(PECL svn >= 0.2.0)

svn_fs_abort_txn — Abort a transaction, returns true if everything is okay, false otherwise

Açıklama

bool svn_fs_abort_txn ( resource $txn )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Abort a transaction, returns true if everything is okay, false otherwise

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

svn_export
svn_fs_apply_text
SVN İşlevleri


Creates and returns a stream that will be used to replace

svn_fs_abort_txn
svn_fs_begin_txn2
SVN İşlevleri
PHP Manual

svn_fs_apply_text

(PECL svn >= 0.2.0)

svn_fs_apply_text — Creates and returns a stream that will be used to replace

Açıklama

resource svn_fs_apply_text ( resource $root , string $path )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Creates and returns a stream that will be used to replace

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

svn_fs_abort_txn
svn_fs_begin_txn2
SVN İşlevleri


Create a new transaction

svn_fs_apply_text
svn_fs_change_node_prop
SVN İşlevleri
PHP Manual

svn_fs_begin_txn2

(PECL svn >= 0.2.0)

svn_fs_begin_txn2 — Create a new transaction

Açıklama

resource svn_fs_begin_txn2 ( resource $repos , int $rev )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Create a new transaction

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

svn_fs_apply_text
svn_fs_change_node_prop
SVN İşlevleri


Return true if everything is ok, false otherwise

svn_fs_begin_txn2
svn_fs_check_path
SVN İşlevleri
PHP Manual

svn_fs_change_node_prop

(PECL svn >= 0.2.0)

svn_fs_change_node_prop — Return true if everything is ok, false otherwise

Açıklama

bool svn_fs_change_node_prop ( resource $root , string $path , string $name , string $value )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Return true if everything is ok, false otherwise

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

svn_fs_begin_txn2
svn_fs_check_path
SVN İşlevleri


Determines what kind of item lives at path in a given repository fsroot

svn_fs_change_node_prop
svn_fs_contents_changed
SVN İşlevleri
PHP Manual

svn_fs_check_path

(PECL svn >= 0.1.0)

svn_fs_check_path — Determines what kind of item lives at path in a given repository fsroot

Açıklama

int svn_fs_check_path ( resource $fsroot , string $path )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Determines what kind of item lives at path in a given repository fsroot

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

svn_fs_change_node_prop
svn_fs_contents_changed
SVN İşlevleri


Return true if content is different, false otherwise

svn_fs_check_path
svn_fs_copy
SVN İşlevleri
PHP Manual

svn_fs_contents_changed

(PECL svn >= 0.2.0)

svn_fs_contents_changed — Return true if content is different, false otherwise

Açıklama

bool svn_fs_contents_changed ( resource $root1 , string $path1 , resource $root2 , string $path2 )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Return true if content is different, false otherwise

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

svn_fs_check_path
svn_fs_copy
SVN İşlevleri


Copies a file or a directory, returns true if all is ok, false otherwise

svn_fs_contents_changed
svn_fs_delete
SVN İşlevleri
PHP Manual

svn_fs_copy

(PECL svn >= 0.2.0)

svn_fs_copy — Copies a file or a directory, returns true if all is ok, false otherwise

Açıklama

bool svn_fs_copy ( resource $from_root , string $from_path , resource $to_root , string $to_path )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Copies a file or a directory, returns true if all is ok, false otherwise

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

svn_fs_contents_changed
svn_fs_delete
SVN İşlevleri


Deletes a file or a directory, return true if all is ok, false otherwise

svn_fs_copy
svn_fs_dir_entries
SVN İşlevleri
PHP Manual

svn_fs_delete

(PECL svn >= 0.2.0)

svn_fs_delete — Deletes a file or a directory, return true if all is ok, false otherwise

Açıklama

bool svn_fs_delete ( resource $root , string $path )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Deletes a file or a directory, return true if all is ok, false otherwise

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

svn_fs_copy
svn_fs_dir_entries
SVN İşlevleri


Enumerates the directory entries under path; returns a hash of dir names to file type

svn_fs_delete
svn_fs_file_contents
SVN İşlevleri
PHP Manual

svn_fs_dir_entries

(PECL svn >= 0.1.0)

svn_fs_dir_entries — Enumerates the directory entries under path; returns a hash of dir names to file type

Açıklama

array svn_fs_dir_entries ( resource $fsroot , string $path )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Enumerates the directory entries under path; returns a hash of dir names to file type

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

svn_fs_delete
svn_fs_file_contents
SVN İşlevleri


Returns a stream to access the contents of a file from a given version of the fs

svn_fs_dir_entries
svn_fs_file_length
SVN İşlevleri
PHP Manual

svn_fs_file_contents

(PECL svn >= 0.1.0)

svn_fs_file_contents — Returns a stream to access the contents of a file from a given version of the fs

Açıklama

resource svn_fs_file_contents ( resource $fsroot , string $path )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Returns a stream to access the contents of a file from a given version of the fs

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

svn_fs_dir_entries
svn_fs_file_length
SVN İşlevleri


Returns the length of a file from a given version of the fs

svn_fs_file_contents
svn_fs_is_dir
SVN İşlevleri
PHP Manual

svn_fs_file_length

(PECL svn >= 0.1.0)

svn_fs_file_length — Returns the length of a file from a given version of the fs

Açıklama

int svn_fs_file_length ( resource $fsroot , string $path )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Returns the length of a file from a given version of the fs

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

svn_fs_file_contents
svn_fs_is_dir
SVN İşlevleri


Return true if the path points to a directory, false otherwise

svn_fs_file_length
svn_fs_is_file
SVN İşlevleri
PHP Manual

svn_fs_is_dir

(PECL svn >= 0.2.0)

svn_fs_is_dir — Return true if the path points to a directory, false otherwise

Açıklama

bool svn_fs_is_dir ( resource $root , string $path )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Return true if the path points to a directory, false otherwise

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

svn_fs_file_length
svn_fs_is_file
SVN İşlevleri


Return true if the path points to a file, false otherwise

svn_fs_is_dir
svn_fs_make_dir
SVN İşlevleri
PHP Manual

svn_fs_is_file

(PECL svn >= 0.2.0)

svn_fs_is_file — Return true if the path points to a file, false otherwise

Açıklama

bool svn_fs_is_file ( resource $root , string $path )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Return true if the path points to a file, false otherwise

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

svn_fs_is_dir
svn_fs_make_dir
SVN İşlevleri


Creates a new empty directory, returns true if all is ok, false otherwise

svn_fs_is_file
svn_fs_make_file
SVN İşlevleri
PHP Manual

svn_fs_make_dir

(PECL svn >= 0.2.0)

svn_fs_make_dir — Creates a new empty directory, returns true if all is ok, false otherwise

Açıklama

bool svn_fs_make_dir ( resource $root , string $path )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Creates a new empty directory, returns true if all is ok, false otherwise

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

svn_fs_is_file
svn_fs_make_file
SVN İşlevleri


Creates a new empty file, returns true if all is ok, false otherwise

svn_fs_make_dir
svn_fs_node_created_rev
SVN İşlevleri
PHP Manual

svn_fs_make_file

(PECL svn >= 0.2.0)

svn_fs_make_file — Creates a new empty file, returns true if all is ok, false otherwise

Açıklama

bool svn_fs_make_file ( resource $root , string $path )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Creates a new empty file, returns true if all is ok, false otherwise

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

svn_fs_make_dir
svn_fs_node_created_rev
SVN İşlevleri


Returns the revision in which path under fsroot was created

svn_fs_make_file
svn_fs_node_prop
SVN İşlevleri
PHP Manual

svn_fs_node_created_rev

(PECL svn >= 0.1.0)

svn_fs_node_created_rev — Returns the revision in which path under fsroot was created

Açıklama

int svn_fs_node_created_rev ( resource $fsroot , string $path )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Returns the revision in which path under fsroot was created

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

svn_fs_make_file
svn_fs_node_prop
SVN İşlevleri


Returns the value of a property for a node

svn_fs_node_created_rev
svn_fs_props_changed
SVN İşlevleri
PHP Manual

svn_fs_node_prop

(PECL svn >= 0.1.0)

svn_fs_node_prop — Returns the value of a property for a node

Açıklama

string svn_fs_node_prop ( resource $fsroot , string $path , string $propname )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Returns the value of a property for a node

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

svn_fs_node_created_rev
svn_fs_props_changed
SVN İşlevleri


Return true if props are different, false otherwise

svn_fs_node_prop
svn_fs_revision_prop
SVN İşlevleri
PHP Manual

svn_fs_props_changed

(PECL svn >= 0.2.0)

svn_fs_props_changed — Return true if props are different, false otherwise

Açıklama

bool svn_fs_props_changed ( resource $root1 , string $path1 , resource $root2 , string $path2 )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Return true if props are different, false otherwise

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

svn_fs_node_prop
svn_fs_revision_prop
SVN İşlevleri


Fetches the value of a named property

svn_fs_props_changed
svn_fs_revision_root
SVN İşlevleri
PHP Manual

svn_fs_revision_prop

(PECL svn >= 0.1.0)

svn_fs_revision_prop — Fetches the value of a named property

Açıklama

string svn_fs_revision_prop ( resource $fs , int $revnum , string $propname )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Fetches the value of a named property

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

svn_fs_props_changed
svn_fs_revision_root
SVN İşlevleri


Get a handle on a specific version of the repository root

svn_fs_revision_prop
svn_fs_txn_root
SVN İşlevleri
PHP Manual

svn_fs_revision_root

(PECL svn >= 0.1.0)

svn_fs_revision_root — Get a handle on a specific version of the repository root

Açıklama

resource svn_fs_revision_root ( resource $fs , int $revnum )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Get a handle on a specific version of the repository root

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

svn_fs_revision_prop
svn_fs_txn_root
SVN İşlevleri


Creates and returns a transaction root

svn_fs_revision_root
svn_fs_youngest_rev
SVN İşlevleri
PHP Manual

svn_fs_txn_root

(PECL svn >= 0.2.0)

svn_fs_txn_root — Creates and returns a transaction root

Açıklama

resource svn_fs_txn_root ( resource $txn )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Creates and returns a transaction root

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

svn_fs_revision_root
svn_fs_youngest_rev
SVN İşlevleri


Returns the number of the youngest revision in the filesystem

svn_fs_txn_root
svn_import
SVN İşlevleri
PHP Manual

svn_fs_youngest_rev

(PECL svn >= 0.1.0)

svn_fs_youngest_rev — Returns the number of the youngest revision in the filesystem

Açıklama

int svn_fs_youngest_rev ( resource $fs )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Returns the number of the youngest revision in the filesystem

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

svn_fs_txn_root
svn_import
SVN İşlevleri


Imports an unversioned path into a repository

svn_fs_youngest_rev
svn_log
SVN İşlevleri
PHP Manual

svn_import

(PECL svn >= 0.2.0)

svn_import — Imports an unversioned path into a repository

Açıklama

bool svn_import ( string $path , string $url , bool $nonrecursive )

Commits unversioned path into repository at url. If path is a directory and nonrecursive is FALSE, the directory will be imported recursively.

Değiştirgeler

path

Path of file or directory to import.

Bilginize: Relative paths will be resolved as if the current working directory was the one that contains the PHP binary. To use the calling script's working directory, use realpath() or dirname(__FILE__).

url

Repository URL to import into.

nonrecursive

Whether or not to refrain from recursively processing directories.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Örnekler

Örnek 1 Basic example

This example demonstrates a basic use-case of this function. To import a directory named new-files into the repository at http://www.example.com/svnroot/incoming/abc, use:

<?php
svn_import(realpath('new-files'), 'http://www.example.com/svnroot/incoming/abc', false);
?>

Ayrıca Bakınız

  • svn_add() - Schedules the addition of an item in a working directory
  • » SVN documentation for svn import

svn_fs_youngest_rev
svn_log
SVN İşlevleri


Returns the commit log messages of a repository URL

svn_import
svn_ls
SVN İşlevleri
PHP Manual

svn_log

(PECL svn >= 0.1.0)

svn_log — Returns the commit log messages of a repository URL

Açıklama

array svn_log ( string $repos_url [, int $start_revision [, int $end_revision [, int $limit = 0 [, int $flags = SVN_DISCOVER_CHANGED_PATHS | SVN_STOP_ON_COPY ]]]] )

svn_log() returns the complete history of the item at the repository URL repos_url, or the history of a specific revision if start_revision is set. This function is equivalent to svn log --verbose -r $start_revision $repos_url.

Değiştirgeler

repos_url

Repository URL of the item to retrieve log history from.

start_revision

Revision number of the first log to retrieve. Use SVN_REVISION_HEAD to retrieve the log from the most recent revision.

end_revision

Revision number of the last log to retrieve. Defaults to start_revision if specified or to SVN_REVISION_INITIAL otherwise.

limit

Number of logs to retrieve.

flags

Any combination of SVN_OMIT_MESSAGES, SVN_DISCOVER_CHANGED_PATHS and SVN_STOP_ON_COPY.

Dönen Değerler

On success, this function returns an array file listing in the format of:

[0] => Array, ordered most recent (highest) revision first
(
    [rev] => integer revision number
    [author] => string author name
    [msg] => string log message
    [date] => string date formatted per ISO 8601, i.e. date('c')
    [paths] => Array, describing changed files
        (
            [0] => Array
                (
                    [action] => string letter signifying change
                    [path] =>  absolute repository path of changed file
                )
            [1] => ...
        )
)
[1] => ...

Bilginize:

The output will always be a numerically indexed array of arrays, even when there are none or only one log message(s).

The value of action is a subset of the » status output in the first column, where possible values are:

Actions
Letter | Description
M | Item/props was modified
A | Item was added
D | Item was deleted
R | Item was replaced

If no changes were made to the item, an empty array is returned.

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Örnekler

Örnek 1 svn_log() example

<?php
print_r( svn_log('http://www.example.com/', 23) );
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [0] => Array
    (
        [rev] => 23
        [author] => 'joe'
        [msg] => 'Add cheese and salami to our sandwich.'
        [date] => '2007-04-06T16:00:27-04:00'
        [paths] => Array
            (
                [0] => Array
                    (
                        [action] => 'M'
                        [path] =>  '/sandwich.txt'
                    )
            )
    )
)

Ayrıca Bakınız

  • » SVN documentation on svn log

svn_import
svn_ls
SVN İşlevleri


Returns list of directory contents in repository URL, optionally at revision number

svn_log
svn_mkdir
SVN İşlevleri
PHP Manual

svn_ls

(PECL svn >= 0.1.0)

svn_ls — Returns list of directory contents in repository URL, optionally at revision number

Açıklama

array svn_ls ( string $repos_url [, int $revision_no = SVN_REVISION_HEAD [, bool $recurse = false [, bool $peg = false ]]] )

This function queries the repository URL and returns a list of files and directories, optionally from a specific revision. This is equivalent to svn list $repos_url[@$revision_no]

Bilginize:

This function does not work with working copies. repos_url must be a repository URL.

Değiştirgeler

url

URL of the repository, eg. http://www.example.com/svnroot. To access a local Subversion repository via filesystem, use the file URI scheme, eg. file:///home/user/svn-repos

revision

Integer revision number to retrieve listing of. When omitted, the HEAD revision is used.

recurse

Enables recursion.

Dönen Değerler

On success, this function returns an array file listing in the format of:

[0] => Array
    (
        [created_rev] => integer revision number of last edit
        [last_author] => string author name of last edit
        [size] => integer byte file size of file
        [time] => string date of last edit in form 'M d H:i'
                  or 'M d Y', depending on how old the file is
        [time_t] => integer unix timestamp of last edit
        [name] => name of file/directory
        [type] => type, can be 'file' or 'dir'
    )
[1] => ...

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Örnekler

Örnek 1 svn_ls() example

<?php
print_r( svn_ls('http://www.example.com/svnroot/') );
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [0] => Array
        (
            [created_rev] => 20
            [last_author] => Joe
            [size] => 0
            [time] => Apr 02 09:28
            [time_t] => 1175520529
            [name] => tags
            [type] => dir
        )
    [1] => Array
        (
            [created_rev] => 23
            [last_author] => Bob
            [size] => 0
            [time] => Apr 02 15:15
            [time_t] => 1175541322
            [name] => trunk
            [type] => dir
        )
)

Ayrıca Bakınız

  • » SVN documentation on svn list

svn_log
svn_mkdir
SVN İşlevleri


Creates a directory in a working copy or repository

svn_ls
svn_repos_create
SVN İşlevleri
PHP Manual

svn_mkdir

(PECL svn >= 0.4.0)

svn_mkdir — Creates a directory in a working copy or repository

Açıklama

bool svn_mkdir ( string $path [, string $log_message ] )

Creates a directory in a working copy or repository.

Değiştirgeler

path

The path to the working copy or repository.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • svn_add() - Schedules the addition of an item in a working directory
  • svn_copy()

svn_ls
svn_repos_create
SVN İşlevleri


Create a new subversion repository at path

svn_mkdir
svn_repos_fs_begin_txn_for_commit
SVN İşlevleri
PHP Manual

svn_repos_create

(PECL svn >= 0.1.0)

svn_repos_create — Create a new subversion repository at path

Açıklama

resource svn_repos_create ( string $path [, array $config [, array $fsconfig ]] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Create a new subversion repository at path

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

svn_mkdir
svn_repos_fs_begin_txn_for_commit
SVN İşlevleri


Create a new transaction

svn_repos_create
svn_repos_fs_commit_txn
SVN İşlevleri
PHP Manual

svn_repos_fs_begin_txn_for_commit

(PECL svn >= 0.2.0)

svn_repos_fs_begin_txn_for_commit — Create a new transaction

Açıklama

resource svn_repos_fs_begin_txn_for_commit ( resource $repos , int $rev , string $author , string $log_msg )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Create a new transaction

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

svn_repos_create
svn_repos_fs_commit_txn
SVN İşlevleri


Commits a transaction and returns the new revision

svn_repos_fs_begin_txn_for_commit
svn_repos_fs
SVN İşlevleri
PHP Manual

svn_repos_fs_commit_txn

(PECL svn >= 0.2.0)

svn_repos_fs_commit_txn — Commits a transaction and returns the new revision

Açıklama

int svn_repos_fs_commit_txn ( resource $txn )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Commits a transaction and returns the new revision

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

svn_repos_fs_begin_txn_for_commit
svn_repos_fs
SVN İşlevleri


Gets a handle on the filesystem for a repository

svn_repos_fs_commit_txn
svn_repos_hotcopy
SVN İşlevleri
PHP Manual

svn_repos_fs

(PECL svn >= 0.1.0)

svn_repos_fs — Gets a handle on the filesystem for a repository

Açıklama

resource svn_repos_fs ( resource $repos )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Gets a handle on the filesystem for a repository

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

svn_repos_fs_commit_txn
svn_repos_hotcopy
SVN İşlevleri


Make a hot-copy of the repos at repospath; copy it to destpath

svn_repos_fs
svn_repos_open
SVN İşlevleri
PHP Manual

svn_repos_hotcopy

(PECL svn >= 0.1.0)

svn_repos_hotcopy — Make a hot-copy of the repos at repospath; copy it to destpath

Açıklama

bool svn_repos_hotcopy ( string $repospath , string $destpath , bool $cleanlogs )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Make a hot-copy of the repos at repospath; copy it to destpath

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

svn_repos_fs
svn_repos_open
SVN İşlevleri


Open a shared lock on a repository.

svn_repos_hotcopy
svn_repos_recover
SVN İşlevleri
PHP Manual

svn_repos_open

(PECL svn >= 0.1.0)

svn_repos_open — Open a shared lock on a repository.

Açıklama

resource svn_repos_open ( string $path )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Open a shared lock on a repository.

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

svn_repos_hotcopy
svn_repos_recover
SVN İşlevleri


Run recovery procedures on the repository located at path.

svn_repos_open
svn_revert
SVN İşlevleri
PHP Manual

svn_repos_recover

(PECL svn >= 0.1.0)

svn_repos_recover — Run recovery procedures on the repository located at path.

Açıklama

bool svn_repos_recover ( string $path )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Run recovery procedures on the repository located at path.

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

svn_repos_open
svn_revert
SVN İşlevleri


Revert changes to the working copy

svn_repos_recover
svn_status
SVN İşlevleri
PHP Manual

svn_revert

(PECL svn >= 0.3.0)

svn_revert — Revert changes to the working copy

Açıklama

bool svn_revert ( string $path [, bool $recursive = false ] )

Revert any local changes to the path in a working copy.

Değiştirgeler

path

The path to the working repository.

recursive

Optionally make recursive changes.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • svn_delete() - Delete items from a working copy or repository.
  • svn_export() - Export the contents of a SVN directory

svn_repos_recover
svn_status
SVN İşlevleri


Returns the status of working copy files and directories

svn_revert
svn_update
SVN İşlevleri
PHP Manual

svn_status

(PECL svn >= 0.1.0)

svn_status — Returns the status of working copy files and directories

Açıklama

array svn_status ( string $path [, int $flags = 0 ] )

Returns the status of working copy files and directories, giving modifications, additions, deletions and other changes to items in the working copy.

Değiştirgeler

path

Local path to file or directory to retrieve status of.

Bilginize: Relative paths will be resolved as if the current working directory was the one that contains the PHP binary. To use the calling script's working directory, use realpath() or dirname(__FILE__).

flags

Any combination of SVN_NON_RECURSIVE, SVN_ALL (regardless of modification status), SVN_SHOW_UPDATES (entries will be added for items that are out-of-date), SVN_NO_IGNORE (disregard svn:ignore properties when scanning for new files) and SVN_IGNORE_EXTERNALS.

Dönen Değerler

Returns a numerically indexed array of associative arrays detailing the status of items in the repository:

Array (
    [0] => Array (
        // information on item
    )
    [1] => ...
)

The information on the item is an associative array that can contain the following keys:

path
String path to file/directory of this entry on local filesystem.
text_status
Status of item's text. Refer to status constants for possible values.
repos_text_status
Status of item's text in repository. Only accurate if update was set to TRUE. Refer to status constants for possible values.
prop_status
Status of item's properties. Refer to status constants for possible values.
repos_prop_status
Status of item's property in repository. Only accurate if update was set to TRUE. Refer to status constants for possible values.
locked
Whether or not the item is locked. (Only set if TRUE.)
copied
Whether or not the item was copied (scheduled for addition with history). (Only set if TRUE.)
switched
Whether or not the item was switched using the switch command. (Only set if TRUE)

These keys are only set if the item is versioned:

name
Base name of item in repository.
url
URL of item in repository.
repos
Base URL of repository.
revision
Integer revision of item in working copy.
kind
Type of item, i.e. file or directory. Refer to type constants for possible values.
schedule
Scheduled action for item, i.e. addition or deletion. Constants for these magic numbers are not available, they can be emulated by using:
<?php
if (!defined('svn_wc_schedule_normal')) {
    define('svn_wc_schedule_normal',  0); // nothing special
    define('svn_wc_schedule_add',     1); // item will be added
    define('svn_wc_schedule_delete',  2); // item will be deleted
    define('svn_wc_schedule_replace', 3); // item will be added and deleted
}
?>
deleted
Whether or not the item was deleted, but parent revision lags behind. (Only set if TRUE.)
absent
Whether or not the item is absent, that is, Subversion knows that there should be something there but there isn't. (Only set if TRUE.)
incomplete
Whether or not the entries file for a directory is incomplete. (Only set if TRUE.)
cmt_date
Integer Unix timestamp of last commit date. (Unaffected by update.)
cmt_rev
Integer revision of last commit. (Unaffected by update.)
cmt_author
String author of last commit. (Unaffected by update.)
prop_time
Integer Unix timestamp of last up-to-date time for properties
text_time
Integer Unix timestamp of last up-to-date time for text

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Örnekler

Örnek 1 Basic example

This example demonstrates a basic, theoretical usage of this function.

<?php
print_r(svn_status(realpath('wc')));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array (
    [0] => Array (
        [path] => /home/bob/wc/sandwich.txt
        [text_status] => 8 // item was modified
        [repos_text_status] => 1 // no information available, use update
        [prop_status] => 3 // no changes
        [repos_prop_status] => 1 // no information available, use update
        [name] => sandwich.txt
        [url] => http://www.example.com/svnroot/deli/trunk/sandwich.txt
        [repos] => http://www.example.com/svnroot/
        [revision] => 123
        [kind] => 1 // file
        [schedule] => 0 // no special actions scheduled
        [cmt_date] => 1165543135
        [cmt_rev] => 120
        [cmt_author] => Alice
        [prop_time] => 1180201728
        [text_time] => 1180201729
    )
)

Ayrıca Bakınız

  • svn_update() - Update working copy
  • svn_log() - Returns the commit log messages of a repository URL
  • » SVN documentation for svn status

svn_revert
svn_update
SVN İşlevleri


Update working copy

svn_status
TCP
SVN İşlevleri
PHP Manual

svn_update

(PECL svn >= 0.1.0)

svn_update — Update working copy

Açıklama

int svn_update ( string $path [, int $revno = SVN_REVISION_HEAD [, bool $recurse = true ]] )

Update working copy at path to revision revno. If recurse is true, directories will be recursively updated.

Değiştirgeler

path

Path to local working copy.

Bilginize: Relative paths will be resolved as if the current working directory was the one that contains the PHP binary. To use the calling script's working directory, use realpath() or dirname(__FILE__).

revno

Revision number to update to, default is SVN_REVISION_HEAD.

recurse

Whether or not to recursively update directories.

Dönen Değerler

Returns new revision number on success, returns FALSE on failure.

Notlar

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Örnekler

Örnek 1 Basic example

This example demonstrates basic usage of this function:

<?php
echo svn_update(realpath('working-copy'));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

234

Ayrıca Bakınız

  • svn_checkout() - Checks out a working copy from the repository
  • svn_commit() - Sends changes from the local working copy to the repository
  • » SVN documentation for svn update

svn_status
TCP
SVN İşlevleri


TCP Sarmalayıcıları

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • TCP İşlevleri
    • tcpwrap_check — Bir tcpwrap sınaması yapar
svn_update
Giriş
Diğer Hizmetler


Giriş

TCP sarmalayıcıları, uzak istemcinin belirtilen IP adresinden bağlanıp bağlanamayacağını sınamaya yarayan klasik bir Unix mekanizmasıdır.

TCP
Yapılandırma/Kurulum
TCP


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
TCP


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » PECL

Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
TCP İşlevleri
TCP


TCP İşlevleri

İçindekiler

  • tcpwrap_check — Bir tcpwrap sınaması yapar
Öntanımlı Sabitler
tcpwrap_check
TCP


Bir tcpwrap sınaması yapar

TCP İşlevleri
Varnish
TCP İşlevleri
PHP Manual

tcpwrap_check

(PECL tcpwrap >= 0.1.0)

tcpwrap_check — Bir tcpwrap sınaması yapar

Açıklama

bool tcpwrap_check ( string $süreç_adı , string $adres [, string $kullanıcı [, bool $dns_yok = false ]] )

Bu işlev, bir istemcinin belirtilen artalan uygulamasına erişimine izin verilip verilmediğini saptamak için /etc/hosts.allow ve /etc/hosts.deny dosyalarına bakar.

Değiştirgeler

daemon

Artalan uygulamasının adı.

adres

Uzak istemcinin adresi. Bir IP adresi veya bir alan adı belirtilebilir.

kullanıcı

İsteğe bağlı olarak kullanıcı adı.

dns_yok

adres olarak bir alan adı belirtilmişse IP adresini bulmak için DNS çözümlemesi yapılır. Bu değiştirgeye TRUE atanarak bu çözümlemenin yapılmaması sağlanabilir.

Dönen Değerler

Erişime izin verilmişse TRUE yoksa FALSE döner.

Örnekler

Örnek 1 - localhost'tan tüm bağlantıları yasaklamak

/etc/hosts.deny dosyanızın şu satırı içerdiğini varsayalım:

php: 127.0.0.1

Kodunuz da şöyle olsun:

<?php
if (!tcpwrap_check('php', $_SERVER['REMOTE_ADDR'])) {
  die('Burada istenmiyorsunuz!');
}
?>

Ayrıca Bakınız

Daha ayrıntılı bilgi için hosts_access(3) kılavuz sayfasına bakınız.

TCP İşlevleri
Varnish
TCP İşlevleri


Varnish

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
    • Basic VarnishAdmin usage
    • Basic VarnishStat usage
    • Basic VarnishLog usage
  • VarnishAdmin — The VarnishAdmin class
    • VarnishAdmin::auth — Authenticate on a varnish instance
    • VarnishAdmin::ban — Ban URLs using a VCL expression
    • VarnishAdmin::banUrl — Ban an URL using a VCL expression
    • VarnishAdmin::clearPanic — Clear varnish instance panic messages
    • VarnishAdmin::connect — Connect to a varnish instance administration interface
    • VarnishAdmin::__construct — VarnishAdmin constructor
    • VarnishAdmin::disconnect — Disconnect from a varnish instance administration interface
    • VarnishAdmin::getPanic — Get the last panic message on a varnish instance
    • VarnishAdmin::getParams — Fetch current varnish instance configuration parameters
    • VarnishAdmin::isRunning — Check if the varnish slave process is currently running
    • VarnishAdmin::setCompat — Set the class compat configuration param
    • VarnishAdmin::setHost — Set the class host configuration param
    • VarnishAdmin::setIdent — Set the class ident configuration param
    • VarnishAdmin::setParam — Set configuration param on the current varnish instance
    • VarnishAdmin::setPort — Set the class port configuration param
    • VarnishAdmin::setSecret — Set the class secret configuration param
    • VarnishAdmin::setTimeout — Set the class timeout configuration param
    • VarnishAdmin::start — Start varnish worker process
    • VarnishAdmin::stop — Stop varnish worker process
  • VarnishStat — The VarnishStat class
    • VarnishStat::__construct — VarnishStat constructor
    • VarnishStat::getSnapshot — Get the current varnish instance statistics snapshot
  • VarnishLog — The VarnishLog class
    • VarnishLog::__construct — Varnishlog constructor
    • VarnishLog::getLine — Get next log line
    • VarnishLog::getTagName — Get the log tag string representation by its index
tcpwrap_check
Giriş
Diğer Hizmetler


Giriş

Varnish Cache is an open source, state of the art web application accelerator. The extension makes it possible to interact with a running varnish instance through TCP socket or shared memory.

Varnish
Yapılandırma/Kurulum
Varnish


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Varnish


Gereksinimler

To use this extension, you will need Varnish Cache of the version >=3.0 installed, available on the » Varnish Cache homepage

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu » PECL eklentisi PHP ile gelmez.

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/varnish.

A DLL for this PECL extension is available under » http://windows.php.net/downloads/pecl/releases/varnish/.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

VARNISH_STATUS_SYNTAX (integer)
VARNISH_STATUS_UNKNOWN (integer)
VARNISH_STATUS_UNIMPL (integer)
VARNISH_STATUS_TOOFEW (integer)
VARNISH_STATUS_TOOMANY (integer)
VARNISH_STATUS_PARAM (integer)
VARNISH_STATUS_AUTH (integer)
VARNISH_STATUS_OK (integer)
VARNISH_STATUS_CANT (integer)
VARNISH_STATUS_COMMS (integer)
VARNISH_STATUS_CLOSE (integer)
VARNISH_CONFIG_IDENT (string)
VARNISH_CONFIG_HOST (string)
VARNISH_CONFIG_PORT (string)
VARNISH_CONFIG_TIMEOUT (string)
VARNISH_CONFIG_SECRET (string)
VARNISH_CONFIG_COMPAT (string)
VARNISH_COMPAT_2 (integer)
VARNISH_COMPAT_3 (integer)

Özkaynak Türleri
Örnekler
Varnish


Örnekler

İçindekiler

  • Basic VarnishAdmin usage
  • Basic VarnishStat usage
  • Basic VarnishLog usage
Öntanımlı Sabitler
Basic VarnishAdmin usage
Varnish


Basic VarnishAdmin usage

The example illustrates a simple usage of the ban functionality

Örnek 1 Ban an URL

<?php

$args = array(
    VARNISH_CONFIG_HOST    => "::1",
    VARNISH_CONFIG_PORT    => 6082,
    VARNISH_CONFIG_SECRET  => "5174826b-8595-4958-aa7a-0609632ad7ca",
    VARNISH_CONFIG_TIMEOUT => 300,
);

$va = new VarnishAdmin($args);

try {
    if(!$va->connect()) {
        throw new VarnishException("Connection failed\n");
    }
} catch (VarnishException $e) {
    echo $e->getMessage();
    exit(3);
}

try {
    if(!$va->auth()) {
        throw new VarnishException("Auth failed\n");
    }
} catch (VarnishException $e) {
    echo $e->getMessage();
    exit(3);
}

try {
    $status = $va->ban('req.url ~ "^/$"');
    if (VARNISH_STATUS_OK != $status) {
        throw new VarnishException("Ban method returned $status status\n");
    }
} catch (VarnishException $e) {
    echo $e->getMessage();
    exit(3);
}

exit(0);

?>
Örnekler
Basic VarnishStat usage
Örnekler


Basic VarnishStat usage

The example illustrates getting varnish statistic snapshot from shared memory

Örnek 1 Get statistic snapshot

<?php

$vs = new VarnishStat;

try {
    $data = $vs->getSnapshot();
} catch (VarnishException $e) {
    echo $e->getMessage();
    exit(3);
}

exit(0);
?>
Basic VarnishAdmin usage
Basic VarnishLog usage
Örnekler


Basic VarnishLog usage

The example illustrates reading varnish log lines from shared memory

Örnek 1 Read varnish shared memory log

<?php

$vl = new VarnishLog;
while(1) {
    $line = $vl->getLine();
    printf("%s %d %s", VarnishLog::getTagName($line['tag'], $line['id'],
    $line['data']);
}

exit(0);
?>
Basic VarnishStat usage
VarnishAdmin
Örnekler


The VarnishAdmin class

(PECL varnish >= 0.3)

Giriş

Sınıf Sözdizimi

VarnishAdmin {
/* Yöntemler */
public bool auth ( void )
public int ban ( string $vcl_regex )
public int banUrl ( string $vcl_regex )
public int clearPanic ( void )
public bool connect ( void )
public __construct ([ array $args ] )
public bool disconnect ( void )
public string getPanic ( void )
public array getParams ( void )
public bool isRunning ( void )
public void setCompat ( int $compat )
public void setHost ( string $host )
public void setIdent ( string $ident )
public int setParam ( string $name , string|integer $value )
public void setPort ( int $port )
public void setSecret ( string $secret )
public void setTimeout ( int $timeout )
public int start ( void )
public int stop ( void )
}

İçindekiler

  • VarnishAdmin::auth — Authenticate on a varnish instance
  • VarnishAdmin::ban — Ban URLs using a VCL expression
  • VarnishAdmin::banUrl — Ban an URL using a VCL expression
  • VarnishAdmin::clearPanic — Clear varnish instance panic messages
  • VarnishAdmin::connect — Connect to a varnish instance administration interface
  • VarnishAdmin::__construct — VarnishAdmin constructor
  • VarnishAdmin::disconnect — Disconnect from a varnish instance administration interface
  • VarnishAdmin::getPanic — Get the last panic message on a varnish instance
  • VarnishAdmin::getParams — Fetch current varnish instance configuration parameters
  • VarnishAdmin::isRunning — Check if the varnish slave process is currently running
  • VarnishAdmin::setCompat — Set the class compat configuration param
  • VarnishAdmin::setHost — Set the class host configuration param
  • VarnishAdmin::setIdent — Set the class ident configuration param
  • VarnishAdmin::setParam — Set configuration param on the current varnish instance
  • VarnishAdmin::setPort — Set the class port configuration param
  • VarnishAdmin::setSecret — Set the class secret configuration param
  • VarnishAdmin::setTimeout — Set the class timeout configuration param
  • VarnishAdmin::start — Start varnish worker process
  • VarnishAdmin::stop — Stop varnish worker process
Basic VarnishLog usage
VarnishAdmin::auth
Varnish


Authenticate on a varnish instance

VarnishAdmin
VarnishAdmin::ban
VarnishAdmin
PHP Manual

VarnishAdmin::auth

(PECL varnish >= 0.3)

VarnishAdmin::auth — Authenticate on a varnish instance

Açıklama

public bool VarnishAdmin::auth ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

VarnishAdmin
VarnishAdmin::ban
VarnishAdmin


Ban URLs using a VCL expression

VarnishAdmin::auth
VarnishAdmin::banUrl
VarnishAdmin
PHP Manual

VarnishAdmin::ban

(PECL varnish >= 0.3)

VarnishAdmin::ban — Ban URLs using a VCL expression

Açıklama

public int VarnishAdmin::ban ( string $vcl_regex )

Değiştirgeler

vcl_regex

Varnish VCL expression. It's based on the varnish ban command.

Dönen Değerler

Returns the varnish command status.

VarnishAdmin::auth
VarnishAdmin::banUrl
VarnishAdmin


Ban an URL using a VCL expression

VarnishAdmin::ban
VarnishAdmin::clearPanic
VarnishAdmin
PHP Manual

VarnishAdmin::banUrl

(PECL varnish >= 0.3)

VarnishAdmin::banUrl — Ban an URL using a VCL expression

Açıklama

public int VarnishAdmin::banUrl ( string $vcl_regex )

Değiştirgeler

vcl_regex

URL regular expression in PCRE compatible syntax. It's based on the ban.url varnish command.

Dönen Değerler

Returns the varnish command status.

VarnishAdmin::ban
VarnishAdmin::clearPanic
VarnishAdmin


Clear varnish instance panic messages

VarnishAdmin::banUrl
VarnishAdmin::connect
VarnishAdmin
PHP Manual

VarnishAdmin::clearPanic

(PECL varnish >= 0.4)

VarnishAdmin::clearPanic — Clear varnish instance panic messages

Açıklama

public int VarnishAdmin::clearPanic ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the varnish command status.

VarnishAdmin::banUrl
VarnishAdmin::connect
VarnishAdmin


Connect to a varnish instance administration interface

VarnishAdmin::clearPanic
VarnishAdmin::__construct
VarnishAdmin
PHP Manual

VarnishAdmin::connect

(PECL varnish >= 0.3)

VarnishAdmin::connect — Connect to a varnish instance administration interface

Açıklama

public bool VarnishAdmin::connect ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

VarnishAdmin::clearPanic
VarnishAdmin::__construct
VarnishAdmin


VarnishAdmin constructor

VarnishAdmin::connect
VarnishAdmin::disconnect
VarnishAdmin
PHP Manual

VarnishAdmin::__construct

(PECL varnish >= 0.3)

VarnishAdmin::__construct — VarnishAdmin constructor

Açıklama

public VarnishAdmin::__construct ([ array $args ] )

Değiştirgeler

args

Configuration arguments. The possible keys are:

VARNISH_CONFIG_IDENT - local varnish instance ident
VARNISH_CONFIG_HOST - varnish instance ip
VARNISH_CONFIG_PORT - varnish instance port
VARNISH_CONFIG_SECRET - varnish instance secret
VARNISH_CONFIG_TIMEOUT - connection read timeout
VARNISH_CONFIG_COMPAT - varnish major version compatibility

Dönen Değerler

Örnekler

Örnek 1 VarnishAdmin::__construct() example

<?php
    $args = array(
        VARNISH_CONFIG_HOST => "::1",
        VARNISH_CONFIG_PORT => 6082,
        VARNISH_CONFIG_SECRET => "5174826b-8595-4958-aa7a-0609632ad7ca",
        VARNISH_CONFIG_TIMEOUT => 300,
    );
    $va = new VarnishAdmin($args);
?>
VarnishAdmin::connect
VarnishAdmin::disconnect
VarnishAdmin


Disconnect from a varnish instance administration interface

VarnishAdmin::__construct
VarnishAdmin::getPanic
VarnishAdmin
PHP Manual

VarnishAdmin::disconnect

(PECL varnish >= 1.0.0)

VarnishAdmin::disconnect — Disconnect from a varnish instance administration interface

Açıklama

public bool VarnishAdmin::disconnect ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

VarnishAdmin::__construct
VarnishAdmin::getPanic
VarnishAdmin


Get the last panic message on a varnish instance

VarnishAdmin::disconnect
VarnishAdmin::getParams
VarnishAdmin
PHP Manual

VarnishAdmin::getPanic

(PECL varnish >= 0.4)

VarnishAdmin::getPanic — Get the last panic message on a varnish instance

Açıklama

public string VarnishAdmin::getPanic ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the last panic message on the current varnish instance.

VarnishAdmin::disconnect
VarnishAdmin::getParams
VarnishAdmin


Fetch current varnish instance configuration parameters

VarnishAdmin::getPanic
VarnishAdmin::isRunning
VarnishAdmin
PHP Manual

VarnishAdmin::getParams

(PECL varnish >= 0.4)

VarnishAdmin::getParams — Fetch current varnish instance configuration parameters

Açıklama

public array VarnishAdmin::getParams ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array with the varnish configuration parameters.

VarnishAdmin::getPanic
VarnishAdmin::isRunning
VarnishAdmin


Check if the varnish slave process is currently running

VarnishAdmin::getParams
VarnishAdmin::setCompat
VarnishAdmin
PHP Manual

VarnishAdmin::isRunning

(PECL varnish >= 0.3)

VarnishAdmin::isRunning — Check if the varnish slave process is currently running

Açıklama

public bool VarnishAdmin::isRunning ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

VarnishAdmin::getParams
VarnishAdmin::setCompat
VarnishAdmin


Set the class compat configuration param

VarnishAdmin::isRunning
VarnishAdmin::setHost
VarnishAdmin
PHP Manual

VarnishAdmin::setCompat

(PECL varnish >= 0.9.2)

VarnishAdmin::setCompat — Set the class compat configuration param

Açıklama

public void VarnishAdmin::setCompat ( int $compat )

Değiştirgeler

compat

Varnish compatibility option.

Dönen Değerler

VarnishAdmin::isRunning
VarnishAdmin::setHost
VarnishAdmin


Set the class host configuration param

VarnishAdmin::setCompat
VarnishAdmin::setIdent
VarnishAdmin
PHP Manual

VarnishAdmin::setHost

(PECL varnish >= 0.8)

VarnishAdmin::setHost — Set the class host configuration param

Açıklama

public void VarnishAdmin::setHost ( string $host )

Değiştirgeler

host

Connection host configuration parameter.

Dönen Değerler

VarnishAdmin::setCompat
VarnishAdmin::setIdent
VarnishAdmin


Set the class ident configuration param

VarnishAdmin::setHost
VarnishAdmin::setParam
VarnishAdmin
PHP Manual

VarnishAdmin::setIdent

(PECL varnish >= 0.8)

VarnishAdmin::setIdent — Set the class ident configuration param

Açıklama

public void VarnishAdmin::setIdent ( string $ident )

Değiştirgeler

ident

Connection ident configuration parameter.

Dönen Değerler

VarnishAdmin::setHost
VarnishAdmin::setParam
VarnishAdmin


Set configuration param on the current varnish instance

VarnishAdmin::setIdent
VarnishAdmin::setPort
VarnishAdmin
PHP Manual

VarnishAdmin::setParam

(PECL varnish >= 0.4)

VarnishAdmin::setParam — Set configuration param on the current varnish instance

Açıklama

public int VarnishAdmin::setParam ( string $name , string|integer $value )

Değiştirgeler

name

Varnish configuration param name.

value

Varnish configuration param value.

Dönen Değerler

Returns the varnish command status.

VarnishAdmin::setIdent
VarnishAdmin::setPort
VarnishAdmin


Set the class port configuration param

VarnishAdmin::setParam
VarnishAdmin::setSecret
VarnishAdmin
PHP Manual

VarnishAdmin::setPort

(PECL varnish >= 0.8)

VarnishAdmin::setPort — Set the class port configuration param

Açıklama

public void VarnishAdmin::setPort ( int $port )

Değiştirgeler

port

Connection port configuration parameter.

Dönen Değerler

VarnishAdmin::setParam
VarnishAdmin::setSecret
VarnishAdmin


Set the class secret configuration param

VarnishAdmin::setPort
VarnishAdmin::setTimeout
VarnishAdmin
PHP Manual

VarnishAdmin::setSecret

(PECL varnish >= 0.8)

VarnishAdmin::setSecret — Set the class secret configuration param

Açıklama

public void VarnishAdmin::setSecret ( string $secret )

Değiştirgeler

secret

Connection secret configuration parameter.

Dönen Değerler

VarnishAdmin::setPort
VarnishAdmin::setTimeout
VarnishAdmin


Set the class timeout configuration param

VarnishAdmin::setSecret
VarnishAdmin::start
VarnishAdmin
PHP Manual

VarnishAdmin::setTimeout

(PECL varnish >= 0.8)

VarnishAdmin::setTimeout — Set the class timeout configuration param

Açıklama

public void VarnishAdmin::setTimeout ( int $timeout )

Değiştirgeler

timeout

Connection timeout configuration parameter.

Dönen Değerler

VarnishAdmin::setSecret
VarnishAdmin::start
VarnishAdmin


Start varnish worker process

VarnishAdmin::setTimeout
VarnishAdmin::stop
VarnishAdmin
PHP Manual

VarnishAdmin::start

(PECL varnish >= 0.3)

VarnishAdmin::start — Start varnish worker process

Açıklama

public int VarnishAdmin::start ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the varnish command status.

VarnishAdmin::setTimeout
VarnishAdmin::stop
VarnishAdmin


Stop varnish worker process

VarnishAdmin::start
VarnishStat
VarnishAdmin
PHP Manual

VarnishAdmin::stop

(PECL varnish >= 0.3)

VarnishAdmin::stop — Stop varnish worker process

Açıklama

public int VarnishAdmin::stop ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the varnish command status.

VarnishAdmin::start
VarnishStat
VarnishAdmin


The VarnishStat class

(PECL varnish >= 0.3)

Giriş

Sınıf Sözdizimi

VarnishStat {
/* Yöntemler */
public __construct ([ array $args ] )
public array getSnapshot ( void )
}

İçindekiler

  • VarnishStat::__construct — VarnishStat constructor
  • VarnishStat::getSnapshot — Get the current varnish instance statistics snapshot
VarnishAdmin::stop
VarnishStat::__construct
Varnish


VarnishStat constructor

VarnishStat
VarnishStat::getSnapshot
VarnishStat
PHP Manual

VarnishStat::__construct

(PECL varnish >= 0.3)

VarnishStat::__construct — VarnishStat constructor

Açıklama

public VarnishStat::__construct ([ array $args ] )

Değiştirgeler

args

Configuration arguments. The possible keys are:

VARNISH_CONFIG_IDENT - local varnish instance ident path

Dönen Değerler

VarnishStat
VarnishStat::getSnapshot
VarnishStat


Get the current varnish instance statistics snapshot

VarnishStat::__construct
VarnishLog
VarnishStat
PHP Manual

VarnishStat::getSnapshot

(PECL varnish >= 0.3)

VarnishStat::getSnapshot — Get the current varnish instance statistics snapshot

Açıklama

public array VarnishStat::getSnapshot ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Array with the varnish statistic snapshot. The array keys are identical to that in the varnishstat tool.

VarnishStat::__construct
VarnishLog
VarnishStat


The VarnishLog class

(PECL varnish >= 0.6)

Giriş

Sınıf Sözdizimi

VarnishLog {
/* Constants */
const integer TAG_Debug = 0 ;
const integer TAG_Error = 1 ;
const integer TAG_CLI = 2 ;
const integer TAG_StatSess = 3 ;
const integer TAG_ReqEnd = 4 ;
const integer TAG_SessionOpen = 5 ;
const integer TAG_SessionClose = 6 ;
const integer TAG_BackendOpen = 7 ;
const integer TAG_BackendXID = 8 ;
const integer TAG_BackendReuse = 9 ;
const integer TAG_BackendClose = 10 ;
const integer TAG_HttpGarbage = 11 ;
const integer TAG_Backend = 12 ;
const integer TAG_Length = 13 ;
const integer TAG_FetchError = 14 ;
const integer TAG_RxRequest = 15 ;
const integer TAG_RxResponse = 16 ;
const integer TAG_RxStatus = 17 ;
const integer TAG_RxURL = 18 ;
const integer TAG_RxProtocol = 19 ;
const integer TAG_RxHeader = 20 ;
const integer TAG_TxRequest = 21 ;
const integer TAG_TxResponse = 22 ;
const integer TAG_TxStatus = 23 ;
const integer TAG_TxURL = 24 ;
const integer TAG_TxProtocol = 25 ;
const integer TAG_TxHeader = 26 ;
const integer TAG_ObjRequest = 27 ;
const integer TAG_ObjResponse = 28 ;
const integer TAG_ObjStatus = 29 ;
const integer TAG_ObjURL = 30 ;
const integer TAG_ObjProtocol = 31 ;
const integer TAG_ObjHeader = 32 ;
const integer TAG_LostHeader = 33 ;
const integer TAG_TTL = 34 ;
const integer TAG_Fetch_Body = 35 ;
const integer TAG_VCL_acl = 36 ;
const integer TAG_VCL_call = 37 ;
const integer TAG_VCL_trace = 38 ;
const integer TAG_VCL_return = 39 ;
const integer TAG_VCL_error = 40 ;
const integer TAG_ReqStart = 41 ;
const integer TAG_Hit = 42 ;
const integer TAG_HitPass = 43 ;
const integer TAG_ExpBan = 44 ;
const integer TAG_ExpKill = 45 ;
const integer TAG_WorkThread = 46 ;
const integer TAG_ESI_xmlerror = 47 ;
const integer TAG_Hash = 48 ;
const integer TAG_Backend_health = 49 ;
const integer TAG_VCL_Log = 50 ;
const integer TAG_Gzip = 51 ;
/* Yöntemler */
public __construct ([ array $args ] )
public array getLine ( void )
public static string getTagName ( int $index )
}

Öntanımlı Sabitler

VarnishLog::TAG_Debug

VarnishLog::TAG_Error

VarnishLog::TAG_CLI

VarnishLog::TAG_StatSess

VarnishLog::TAG_ReqEnd

VarnishLog::TAG_SessionOpen

VarnishLog::TAG_SessionClose

VarnishLog::TAG_BackendOpen

VarnishLog::TAG_BackendXID

VarnishLog::TAG_BackendReuse

VarnishLog::TAG_BackendClose

VarnishLog::TAG_HttpGarbage

VarnishLog::TAG_Backend

VarnishLog::TAG_Length

VarnishLog::TAG_FetchError

VarnishLog::TAG_RxRequest

VarnishLog::TAG_RxResponse

VarnishLog::TAG_RxStatus

VarnishLog::TAG_RxURL

VarnishLog::TAG_RxProtocol

VarnishLog::TAG_RxHeader

VarnishLog::TAG_TxRequest

VarnishLog::TAG_TxResponse

VarnishLog::TAG_TxStatus

VarnishLog::TAG_TxURL

VarnishLog::TAG_TxProtocol

VarnishLog::TAG_TxHeader

VarnishLog::TAG_ObjRequest

VarnishLog::TAG_ObjResponse

VarnishLog::TAG_ObjStatus

VarnishLog::TAG_ObjURL

VarnishLog::TAG_ObjProtocol

VarnishLog::TAG_ObjHeader

VarnishLog::TAG_LostHeader

VarnishLog::TAG_TTL

VarnishLog::TAG_Fetch_Body

VarnishLog::TAG_VCL_acl

VarnishLog::TAG_VCL_call

VarnishLog::TAG_VCL_trace

VarnishLog::TAG_VCL_return

VarnishLog::TAG_VCL_error

VarnishLog::TAG_ReqStart

VarnishLog::TAG_Hit

VarnishLog::TAG_HitPass

VarnishLog::TAG_ExpBan

VarnishLog::TAG_ExpKill

VarnishLog::TAG_WorkThread

VarnishLog::TAG_ESI_xmlerror

VarnishLog::TAG_Hash

VarnishLog::TAG_Backend_health

VarnishLog::TAG_VCL_Log

VarnishLog::TAG_Gzip

İçindekiler

  • VarnishLog::__construct — Varnishlog constructor
  • VarnishLog::getLine — Get next log line
  • VarnishLog::getTagName — Get the log tag string representation by its index
VarnishStat::getSnapshot
VarnishLog::__construct
Varnish


Varnishlog constructor

VarnishLog
VarnishLog::getLine
VarnishLog
PHP Manual

VarnishLog::__construct

(PECL varnish >= 0.6)

VarnishLog::__construct — Varnishlog constructor

Açıklama

public VarnishLog::__construct ([ array $args ] )

Değiştirgeler

args

Configuration arguments. The possible keys are:

VARNISH_CONFIG_IDENT - local varnish instance ident path

Dönen Değerler

VarnishLog
VarnishLog::getLine
VarnishLog


Get next log line

VarnishLog::__construct
VarnishLog::getTagName
VarnishLog
PHP Manual

VarnishLog::getLine

(PECL varnish >= 0.6)

VarnishLog::getLine — Get next log line

Açıklama

public array VarnishLog::getLine ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array with the log line data.

VarnishLog::__construct
VarnishLog::getTagName
VarnishLog


Get the log tag string representation by its index

VarnishLog::getLine
YAZ
VarnishLog
PHP Manual

VarnishLog::getTagName

(PECL varnish >= 0.6)

VarnishLog::getTagName — Get the log tag string representation by its index

Açıklama

public static string VarnishLog::getTagName ( int $index )

Değiştirgeler

index

Log tag index.

Dönen Değerler

Returns the log tag name as string.

VarnishLog::getLine
YAZ
VarnishLog


YAZ

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
  • YAZ İşlevleri
    • yaz_addinfo — Ek hata bilgisi döndürür
    • yaz_ccl_conf — CCL çözümleyecisini yapılandırır
    • yaz_ccl_parse — CCL çözümleyiciyi devreye sokar
    • yaz_close — YAZ bağlantısını kapatır
    • yaz_connect — Bir Z39.50 sunucusuna bir bağlantı düzenler
    • yaz_database — Bir oturum içindeki veritabanlarını belirler
    • yaz_element — Alım için eleman kümesi ismi tanımlar
    • yaz_errno — Hata numarasını döndürür
    • yaz_error — Hatanın açıklaması döner
    • yaz_es_result — Ek hizmetlerin sonucunu döndürür
    • yaz_es — Bir ek hizmet isteği (Extended Service Request) düzenler
    • yaz_get_option — Bir bağlantı seçeneğinin değerini döndürür
    • yaz_hits — Son arama ile eşleşenlerin sayısını döndürür
    • yaz_itemorder — Bir ILL-Request paketli Z39.50 Item Order için hazırlık yapar
    • yaz_present — Bir alım (Z39.50 present) düzenler
    • yaz_range — Edinilecek kayıtlar için bir aralık belirler
    • yaz_record — Bir kayıt döndürür
    • yaz_scan_result — Tarama sonucunu döndürür
    • yaz_scan — Bir tarama düzenler
    • yaz_schema — Alım için şema belirtir
    • yaz_search — Bir arama düzenler
    • yaz_set_option — Bağlantı ile ilgili seçenekleri belirler
    • yaz_sort — Sıralama kuralını belirler
    • yaz_syntax — Alım için tercih edilen kayıt sözdizimini belirler
    • yaz_wait — Z39.50 isteklerinin tamamlanmasını bekler
VarnishLog::getTagName
Giriş
Diğer Hizmetler


Giriş

Bu eklenti, » Z39.50 Bilgi Kazanım Protokolünü gerçekleyen YAZ araçları için bir PHP arayüzüdür. Bu eklenti ile Z39.50 sunucularını arayan veya tarayan bir Z39.50 istemcisini kolayca gerçekleyebilirsiniz.

Kullanımı oldukça kolay olduğundan bu modül, Z39.50'nin karmaşıklığından sizi korur. PHP'de bazı RDB arayüzleri tarafından kullanılanlara çok benzeyen durumsuz kalıcı bağlantıları desteklemektedir. Yani, oturumlar durumsuz olup kullanıcılarca paylaşılabilmektedir, böylece çoğu durumda bağlanma ve ilklendirme aşamalarındaki adımlar azaltılabilmektedir.

YAZ » http://www.indexdata.dk/yaz/ adresinden edinilebilir. Bu eklenti ile ilgili yeni bilgileri, örnek betikleri ve benzerlerini » http://www.indexdata.dk/phpyaz/ adresinde bulabilirsiniz.

Bilginize:

Bu eklenti » PECL deposuna taşınmış olup PHP 5.0.0'dan itibaren PHP kaynak paketinde dağıtılmamaktadır.

YAZ
Yapılandırma/Kurulum
YAZ


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
YAZ


Kurulum

YAZ'ı (ANSI/NISO Z39.50 desteği) temin edip kurun. YAZ, gerek kaynak paketi olarak gerekse önceden derlenmiş paketler halinde » YAZ arşivinden temin edilebilir. Debian GNU/Linux, Suse Linux, FreeBSD gibi sistemler, YAZ'ı kendi dağıtımlarının bir parçası olarak da dağıtmaktadırlar.

PHP 4 serileri için, YAZ eklentisi (YAZ'ın kendisi değil) PHP paketiyle gelmektedir. PHP'yi YAZ desteğiyle derlemek için derleme seçeneklerinize --with-yaz[=DiZiN] seçeneğini ekleyin.

Örnek 1 - Unix üzerinde YAZ destekli PHP 4 kurulumu

gunzip -c php-4.4.X.tar.gz|tar xf -
gunzip -c yaz-2.1.8.tar.gz|tar xf -
cd yaz-2.1.8
./configure --prefix=/usr
make
sudo make install
cd ../php-4.4.X.
./configure --with-yaz=/usr/bin
make
sudo make install

PHP 5 için, YAZ eklentisi » PECL'de bulunmakta ve bir paylaşımlı nesne veya dll olarak kurulabilmektedir. PEAR kurulu ise YAZ eklentisini indirip, derlemek ve kurmanın en kolay yolu pecl komutunu kullanmaktır.

Linux üzerine YAZ kurulumu

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/yaz

Windows üzerine YAZ kurulumu

Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız. php_yaz.dll dosyası yaz.dll'e bağımlıdır. yaz.dll dosyası PHP sitesindeki Win32 ZIP arşivinin bir parçasıdır. Ayrıca, Windows YAZ kurulumunun bir parçası olarak » YAZ WIN32 alanından temin edilebilir.

Uyarı

PHP 5.0.5 Win32 zip arşivi yaz.dll'in çok eski bir sürümünü içerir (1.9.1 < sürümleri 2.0.13 sürümünü gerektirir). Böyle bir durumda, daha yeni bir » YAZ WIN32 kurulumundaki bir yaz.dll dosyasını kullanın.

Windows'ta PHP dizinini PATH ortam değişkenine eklemeyi unutmayın. Böylece, yaz.dll sistem tarafından kolayca bulunabilecektir.

YAZ'ı bir paylaşımlı eklenti olarak kullanacaksanız, Unix üzerinde php.ini dosyanıza şu satırı ekleyin:

 extension=yaz.so

Windows'ta ise şunu ekleyin:

 extension=php_yaz.dll

Uyarı

IMAP, recode, YAZ ve Cyrus eklentileri, aynı dahili simgeleri paylaştıklarından birlikte kullanılamazlar. Bilgi: Yaz 2.0 ve sonrası bu sorundan etkilenmemektedir.

Bilginize:

Yukarıdaki sorun YAZ'ın 2.0 sürümünde çözümlenmiştir.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

YAZ yapılandırma seçenekleri
İsim | Öntanımlı | Değişiklik Yeri | Sürüm Bilgisi
yaz.max_links | "100" | PHP_INI_ALL | PHP 4.3.0'dan beri kullanılabilmektedir. PHP 5.0.0'da kaldırılmıştır.
yaz.log_file | NULL | PHP_INI_ALL | PHP 4.3.0'dan beri kullanılabilmektedir. PHP 5.0.0'da kaldırılmıştır.
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
Örnekler
YAZ


Örnekler

PHP/YAZ hedeflerle bağlantıların izini kaydeder. Bu bağlantılar bir özkaynakla temsil edilirler.

Aşağıdaki betikte, arayüzün paralel arama özelliği gösterilmiştir. Değiştirgesiz çağrıldığında bir sorgu formu basar; değiştirgeli çağrıldığında ise konut dizisinde belirtilen hedefleri araştırır.

Örnek 1 YAZ kullanarak paralel arama

<?php
$konut=$_REQUEST[konut];
$sorgu=$_REQUEST[sorgu];
$konut_sayısı = count($konut);
if (empty($sorgu) || count($konut) == 0) {
    echo '<form method="get">
    <input type="checkbox"
    name="konut[]" value="bagel.indexdata.dk/gils" />
        GILS test
    <input type="checkbox"
    name="konut[]" value="localhost:9999/Default" />
        local test
    <input type="checkbox" checked="checked"
    name="konut[]" value="z3950.loc.gov:7090/voyager" />
        Library of Congress
    <br />
    RPN sorgu:
    <input type="text" size="30" name="sorgu" />
    <input type="submit" name="action" value="Ara" />
    </form>
    ';
} else {
    echo 'Aranan hedef: ' . htmlspecialchars($sorgu) . '<br />';
    for ($i = 0; $i < $konut_sayısı; $i++) {
        $id[] = yaz_connect($konut[$i]);
        yaz_syntax($id[$i], "usmarc");
        yaz_range($id[$i], 1, 10);
        yaz_search($id[$i], "rpn", $sorgu);
    }
    yaz_wait();
    for ($i = 0; $i < $konut_sayısı; $i++) {
        echo '<hr />' . $konut[$i] . ':';
        $error = yaz_error($id[$i]);
        if (!empty($error)) {
            echo "Hata: $error";
        } else {
            $hits = yaz_hits($id[$i]);
            echo "Sonuç sayısı: $hits";
        }
        echo '<dl>';
        for ($p = 1; $p <= 10; $p++) {
            $rec = yaz_record($id[$i], $p, "string");
            if (empty($rec)) continue;
            echo "<dt><b>$p</b></dt><dd>";
            echo nl2br($rec);
            echo "</dd>";
        }
        echo '</dl>';
    }
}
?>

Öntanımlı Sabitler
YAZ İşlevleri
YAZ


YAZ İşlevleri

İçindekiler

  • yaz_addinfo — Ek hata bilgisi döndürür
  • yaz_ccl_conf — CCL çözümleyecisini yapılandırır
  • yaz_ccl_parse — CCL çözümleyiciyi devreye sokar
  • yaz_close — YAZ bağlantısını kapatır
  • yaz_connect — Bir Z39.50 sunucusuna bir bağlantı düzenler
  • yaz_database — Bir oturum içindeki veritabanlarını belirler
  • yaz_element — Alım için eleman kümesi ismi tanımlar
  • yaz_errno — Hata numarasını döndürür
  • yaz_error — Hatanın açıklaması döner
  • yaz_es_result — Ek hizmetlerin sonucunu döndürür
  • yaz_es — Bir ek hizmet isteği (Extended Service Request) düzenler
  • yaz_get_option — Bir bağlantı seçeneğinin değerini döndürür
  • yaz_hits — Son arama ile eşleşenlerin sayısını döndürür
  • yaz_itemorder — Bir ILL-Request paketli Z39.50 Item Order için hazırlık yapar
  • yaz_present — Bir alım (Z39.50 present) düzenler
  • yaz_range — Edinilecek kayıtlar için bir aralık belirler
  • yaz_record — Bir kayıt döndürür
  • yaz_scan_result — Tarama sonucunu döndürür
  • yaz_scan — Bir tarama düzenler
  • yaz_schema — Alım için şema belirtir
  • yaz_search — Bir arama düzenler
  • yaz_set_option — Bağlantı ile ilgili seçenekleri belirler
  • yaz_sort — Sıralama kuralını belirler
  • yaz_syntax — Alım için tercih edilen kayıt sözdizimini belirler
  • yaz_wait — Z39.50 isteklerinin tamamlanmasını bekler
Örnekler
yaz_addinfo
YAZ


Ek hata bilgisi döndürür

YAZ İşlevleri
yaz_ccl_conf
YAZ İşlevleri
PHP Manual

yaz_addinfo

(PHP 4 >= 4.0.1, PECL yaz >= 0.9.0)

yaz_addinfo — Ek hata bilgisi döndürür

Açıklama

string yaz_addinfo ( resource $id )

Sunucudaki son istek için ek hata bilgisi döndürür.

Bazı sunucularda bu işlev, yaz_error() işlevinin döndürdüğü dizgeyi döndürebilir.

Değiştirgeler

id

yaz_connect() tarafından döndürülmüş bağlantı özkaynağı.

Dönen Değerler

Son işlem başarılı olmuşsa veya sunucu tarafından ek bilgi sağlanmamışsa bir boş dizge, aksi takdirde ek hata bilgisini içeren bir dizge döner.

Ayrıca Bakınız

  • yaz_error() - Hatanın açıklaması döner
  • yaz_errno() - Hata numarasını döndürür

YAZ İşlevleri
yaz_ccl_conf
YAZ İşlevleri


CCL çözümleyecisini yapılandırır

yaz_addinfo
yaz_ccl_parse
YAZ İşlevleri
PHP Manual

yaz_ccl_conf

(PHP 4 >= 4.0.5, PECL yaz >= 0.9.0)

yaz_ccl_conf — CCL çözümleyecisini yapılandırır

Açıklama

void yaz_ccl_conf ( resource $id , array $ayarlar )

Bu işlev, bir sunucunun CCL sorgu çözümleyicisini, erişim noktası tanımlayıcıları (CCL niteleyicileri) ve bunların RPN karşılıkları ile yapılandırır.

Belli bir CCL sorgusunu RPN'ye eşlemek için bu işlevden sonra yaz_ccl_parse() işlevini çağırın.

Değiştirgeler

id

yaz_connect() tarafından döndürülmüş bağlantı özkaynağı.

ayarlar

Yapılandırma dizisi. Dizinin her anahtarı bir CCL alanının ismi olup, değerler, alanın RPN karşılığını belirten birer dizgedir.

Eşlem, öznitelik-değer çiftlerinden oluşan bir öznitelik türü listesidir. Öznitelik ile değer bir eşit imi (=) ile, çiftler ise boşlukla ayrılır.

» CCL sayfasında daha fazla bilgi bulabilirsiniz.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Aşağıdaki örnekte, CCL çözümleyicisi şu üç CCL alanını destekleyecek şekilde yapılandırılmaktadır: ti, au ve isbn. Her alan, kendi BIB-1 eşdeğeri ile eşleşir. $id bir bağlantı kimliğidir.

Örnek 1 - CCL yapılandırması

<?php
$fields = array(
  "ti" => "1=4",
  "au"   => "1=1",
  "isbn" => "1=7"
);
yaz_ccl_conf($id, $fields);
?>

Ayrıca Bakınız

  • yaz_ccl_parse() - CCL çözümleyiciyi devreye sokar

yaz_addinfo
yaz_ccl_parse
YAZ İşlevleri


CCL çözümleyiciyi devreye sokar

yaz_ccl_conf
yaz_close
YAZ İşlevleri
PHP Manual

yaz_ccl_parse

(PHP 4 >= 4.0.5, PECL yaz >= 0.9.0)

yaz_ccl_parse — CCL çözümleyiciyi devreye sokar

Açıklama

bool yaz_ccl_parse ( resource $id , string $sorgu , array &$sonuç )

Bu işlev bir CCL çözümleyici çalıştırmak için kullanılır. Bir arama yapmak için yaz_search() işlevine aktarmak üzere, belirtilen CCL BUL sorgusunu bir RPN sorgusuna dönüştürür.

Geçerli CCL alanlarını tanımlamak için bu işlevden önce bir yaz_ccl_conf() çağrısı yapılmalıdır.

Değiştirgeler

id

yaz_connect() tarafından döndürülmüş bağlantı özkaynağı.

sorgu

CCL BUL sorgusu.

sonuç

İşlev başarılı olduğu takdirde bu değiştirge, rpn anahtarı altında geçerli bir RPN sorgusu içeren bir dizidir.

Başarısızlık halinde, başarısızlığın sebebi üç anahtarlı bir dizi ile belirtilir. Anahtarlar:

  • errorcode - CCL hata kodu (integer).

  • errorstring - CCL hata dizgesi.

  • errorpos - Yaklaşık olarak sorgunun başarısız olduğu yer (karakterin konumu olarak bir tamsayı).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - CCL çözümlemesi

Aramayı CCL kullanarak yapmaya çalışacağız. Aşağıdaki örnekte, $ccl bir CCL sorgusudur.

<?php

yaz_ccl_conf($id, $fields);  // örnek için yaz_ccl_conf işlevine bakın
if (!yaz_ccl_parse($id, $ccl, &$cclresult)) {
    echo 'Hata: ' . $cclresult["errorstring"];
} else {
    $rpn = $cclresult["rpn"];
    yaz_search($id, "rpn", $rpn);
}
?>
yaz_ccl_conf
yaz_close
YAZ İşlevleri


YAZ bağlantısını kapatır

yaz_ccl_parse
yaz_connect
YAZ İşlevleri
PHP Manual

yaz_close

(PHP 4 >= 4.0.1, PECL yaz >= 0.9.0)

yaz_close — YAZ bağlantısını kapatır

Açıklama

bool yaz_close ( resource $id )

id ile belirtilen bağlantıyı kapatır.

Bilginize:

Bu işlev, sadece yaz_connect() ile persistent seçeneğine FALSE atanarak açılmış kalıcı olmayan bağlantıları kapatır.

Değiştirgeler

id

yaz_connect() tarafından döndürülmüş bağlantı özkaynağı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • yaz_connect() - Bir Z39.50 sunucusuna bir bağlantı düzenler

yaz_ccl_parse
yaz_connect
YAZ İşlevleri


Bir Z39.50 sunucusuna bir bağlantı düzenler

yaz_close
yaz_database
YAZ İşlevleri
PHP Manual

yaz_connect

(PHP 4 >= 4.0.1, PECL yaz >= 0.9.0)

yaz_connect — Bir Z39.50 sunucusuna bir bağlantı düzenler

Açıklama

mixed yaz_connect ( string $zurl [, mixed $seçenekler ] )

Bu işlev başarılı olduğu takdirde bir bağlantı özkaynağı, aksi takdirde 0 döndürür.

yaz_connect() işlevi bir Z39.50 sunucusuna bir bağlantı düzenler. Bu işlev engellenmez ve bir bağlanttı kurmaya çalışmaz; sadece, bir yaz_wait() çağrısı tarafından işleme konulmak üzere bir bağlantı için hazırlık yapar.

Bilginize:

» YAZ vekili özgürce kullanılabilecek bir Z39.50 vekilidir.

Değiştirgeler

zurl

konut[:port][/veritabanı] biçeminde bir dizge. port belirtilmezse 210 öntanımlıdır. veritabanı belirtilmezse yerine Default kullanılır.

seçenekler

Bir dizge olarak belirtilirse Z39.50 V2 kimlik doğrulama dizgesi (OpenAuth) olarak ele alınır.

Bir dizi belirtilirse dizi içeriği seçenekler olarak ele alınır. Olası seçenekler:

user

Kimlik doğrulamada kullanılacak kullanıcı ismi.

group

Kimlik doğrulamada kullanılacak grup ismi.

password

Kimlik doğrulamada kullanılacak parola.

cookie

Oturum çerezi (YAZ vekili).

proxy

Bağlantı vekili (YAZ vekili).

persistent

Mantıksal değer. TRUE ise bağlantı kalıcıdır, FALSE ise değildir. Öntanımlı olarak bağlantılar kalıcıdır.

Bilginize:

Bir kalıcı bağlantı açmışsanız, bağlantıyı sonradan bir yaz_close() çağrısı ile kapatamazsınız.

piggyback

Mantıksal değer. TRUE ise arama için sırtlama (piggyback) etkin olur, FALSE ise olmaz. Öntanımlı olarak sırtlama etkindir.

Sırtlamanın etkin kılınması daha verimli olup, kayıtların ilk alımında ağdaki gidip dönme süresinden kurtarır. Ancak bazı Z39.50 sunucuları sırtlamayı desteklemez veya eleman kümesi isimlerini yok sayar. Bu bakımdan bu seçenek etkin kılınmamalıdır.

charset

Z39.50 dili ve karater kümesi uzlaşımı için kullanılacak karakter kümesinin belirtildiği bir dizge. ISO-8859-1, UTF-8, UTF-16 gibi dizgeler belirtilebilir.

Çoğu Z39.50 sunucusu bu özelliği desteklemez (dolayısıyla yok sayılır). Çoğu sunucu da sorgular ve iletiler için ISO-8859-1 kodlamasını kullanır. MARC21/USMARC kayıtları bu seçenekten etkilenmez.

preferredMessageSize

Alım sırasında bir hedef tarafından döndürülen tüm kayıtların azami bayt sayısını belirten bir tamsayı. Daha fazla bilgi için » Z39.50 standardına bakınız.

Bilginize:

Bu seçenek, PECL YAZ 1.0.5 ve sonrasında desteklenmektedir.

maximumRecordSize

Alım sırasında bir hedef tarafından döndürülen tek bir kaydın azami bayt sayısını belirten bir tamsayı. Bu seçeneğe » Z39.50 standardında "Exceptional-record-size" olarak değinilmiştir.

Bilginize:

Bu seçenek, PECL YAZ 1.0.5 ve sonrasında desteklenmektedir.

Dönen Değerler

Hata oluşmuşsa FALSE yoksa bir bağlantı özkaynağı döner.

Sürüm Bilgisi

Sürüm: | Açıklama
4.1.0 | seçenekler değiştirgesi eklendi.

Ayrıca Bakınız

  • yaz_close() - YAZ bağlantısını kapatır

yaz_close
yaz_database
YAZ İşlevleri


Bir oturum içindeki veritabanlarını belirler

yaz_connect
yaz_element
YAZ İşlevleri
PHP Manual

yaz_database

(PHP 4 >= 4.0.6, PECL yaz >= 0.9.0)

yaz_database — Bir oturum içindeki veritabanlarını belirler

Açıklama

bool yaz_database ( resource $id , string $veritabanları )

Bu işlev, arama, alım, vb. için kullanılacak veritabanlarının belirtilmesini sağlamak suretiyle bir oturumdaki veritabanlarının (yaz_connect() çağrısında belirtilen veritabanlarını geçersiz kılarak) değiştirilmesini mümkün kılar.

Değiştirgeler

id

yaz_connect() tarafından döndürülmüş bağlantı özkaynağı.

veritabanları

Tek bir veritabanı veya + imleri ile ayrılmış çok sayıda veritabanı içeren bir dizge.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

yaz_connect
yaz_element
YAZ İşlevleri


Alım için eleman kümesi ismi tanımlar

yaz_database
yaz_errno
YAZ İşlevleri
PHP Manual

yaz_element

(PHP 4 >= 4.0.1, PECL yaz >= 0.9.0)

yaz_element — Alım için eleman kümesi ismi tanımlar

Açıklama

bool yaz_element ( resource $id , string $eleman_kümesi )

Bu işlev alım için eleman kümesi ismini tanımlar.

Bu işlevi, alınacak kayıtların eleman kümesi ismini belirtmek için yaz_search() veya yaz_present() işlevinden önce çağırın.

Bilginize:

İşlev etkisiz gibi görünürse yaz_connect() işlevindeki piggyback seçeneğinin açıklamasına bakınız.

Değiştirgeler

id

yaz_connect() tarafından döndürülmüş bağlantı özkaynağı.

eleman_kümesi

Çoğu sunucu (kayıtların tamamı için) F ve (özet kayıtları için) B'yi destekler.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

yaz_database
yaz_errno
YAZ İşlevleri


Hata numarasını döndürür

yaz_element
yaz_error
YAZ İşlevleri
PHP Manual

yaz_errno

(PHP 4 >= 4.0.1, PECL yaz >= 0.9.0)

yaz_errno — Hata numarasını döndürür

Açıklama

int yaz_errno ( resource $id )

id ile belirtilen son istekle ilgili sunucu hata numarasını döndürür.

yaz_errno() işlevi, her sunucu için ağ etkinliğinin ardından (yaz_wait() döndükten sonra), son işlemin (örneğin bir arama işleminin) başarılı olup olmadığını saptamak için çağrılmalıdır.

Değiştirgeler

id

yaz_connect() tarafından döndürülmüş bağlantı özkaynağı.

Dönen Değerler

Bir hata kodu döner. Hata kodu ya bir Z39.50 teşhis kodu (normalde bir Bib-1 teşhisidir) ya da PHP/YAZ'ın kendisi tarafından üretilen, "Bağlantı kurulamadı", "İlklendirme reddedildi" gibi, istemci taraflı bir hatanın kodu olmalıdır.

Ayrıca Bakınız

  • yaz_error() - Hatanın açıklaması döner
  • yaz_addinfo() - Ek hata bilgisi döndürür

yaz_element
yaz_error
YAZ İşlevleri


Hatanın açıklaması döner

yaz_errno
yaz_es_result
YAZ İşlevleri
PHP Manual

yaz_error

(PHP 4 >= 4.0.1, PECL yaz >= 0.9.0)

yaz_error — Hatanın açıklaması döner

Açıklama

string yaz_error ( resource $id )

yaz_error() işlevi, yaz_errno() ile döndürülen son hata numarasına karşılık olan İngilizce iletiyi döndürür.

Değiştirgeler

id

yaz_connect() tarafından döndürülmüş bağlantı özkaynağı.

Dönen Değerler

id ile belirtilen son istek için sunucu hata iletisini döndürür. Son istek başarılı olmuşsa boş bir dizge döner.

Ayrıca Bakınız

  • yaz_errno() - Hata numarasını döndürür
  • yaz_addinfo() - Ek hata bilgisi döndürür

yaz_errno
yaz_es_result
YAZ İşlevleri


Ek hizmetlerin sonucunu döndürür

yaz_error
yaz_es
YAZ İşlevleri
PHP Manual

yaz_es_result

(PHP 4 >= 4.2.0, PECL yaz >= 0.9.0)

yaz_es_result — Ek hizmetlerin sonucunu döndürür

Açıklama

array yaz_es_result ( resource $id )

Bu işlev, bir sunucudan gelen son ek hizmet sonucunu bir dizi içinde döndürür. Ek hizmet ya yaz_itemorder() ya da yaz_es() ile ilklendirilir.

Değiştirgeler

id

yaz_connect() tarafından döndürülmüş bağlantı özkaynağı.

Dönen Değerler

Sunucu tarafından üretilip gönderilen targetReference elemanını içeren bir dizi döner.

Ayrıca Bakınız

  • yaz_es() - Bir ek hizmet isteği (Extended Service Request) düzenler

yaz_error
yaz_es
YAZ İşlevleri


Bir ek hizmet isteği (Extended Service Request) düzenler

yaz_es_result
yaz_get_option
YAZ İşlevleri
PHP Manual

yaz_es

(PECL yaz >= 0.9.0)

yaz_es — Bir ek hizmet isteği (Extended Service Request) düzenler

Açıklama

void yaz_es ( resource $id , string $tür , array $değiştirgeler )

Bu işlev, bir ek hizmet isteği (Extended Service Request) düzenler. Ek hizmetler, Record Update, Item Order, veritabanı yönetimi, ve benzerleri gibi çeşitli Z39.50 oluşumlarından oluşan bir ailedir.

Bilginize:

Çoğu Z39.50 sunucusu ek hizmetleri desteklemez.

yaz_es() işlevi, bir ek hizmek isteği paketi oluşturur ve bunu bir işlem kuyruğuna yerleştirir. İstekleri sunucuya göndermek için yaz_wait() işlevini kullanın. yaz_wait() işini bitirdikten sonra ek hizmet işleminin sonucu bir yaz_es_result() çağrısı ile alınmalıdır.

Değiştirgeler

id

yaz_connect() tarafından döndürülmüş bağlantı özkaynağı.

tür

Ek hizmetin türünü belirten bir dizge:: itemorder (Item Order), create (Create Database), drop (Drop Database), commit (Commit Operation), update (Update Record), xmlupdate (XML Update). Her tür bir sonraki bölümde belirtilir.

değiştirgeler

Ek hizmet seçenekleri ile pakete özgü seçeneklerden oluşan bir dizi. Seçenekler, ZOOM C'nin C arayüzündekilere eşdeğerdir. Bakınız: » ZOOM Ek Hizmetleri.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 - Kayıt Güncelleme

<?php
$con = yaz_connect("myhost/database");
$args = array (
    "record" => "<gils><title>some title</title></gils>",
    "syntax" => "xml",
    "action" => "specialUpdate"
);
yaz_es($con, "update", $args);
yaz_wait();
$result = yaz_es_result($id);
?>

Ayrıca Bakınız

  • yaz_es_result() - Ek hizmetlerin sonucunu döndürür

yaz_es_result
yaz_get_option
YAZ İşlevleri


Bir bağlantı seçeneğinin değerini döndürür

yaz_es
yaz_hits
YAZ İşlevleri
PHP Manual

yaz_get_option

(PECL yaz >= 0.9.0)

yaz_get_option — Bir bağlantı seçeneğinin değerini döndürür

Açıklama

string yaz_get_option ( resource $id , string $isim )

isim ile belirtilen seçeneğin değerini döndürür.

Değiştirgeler

id

yaz_connect() tarafından döndürülmüş bağlantı özkaynağı.

isim

Seçeneğin ismi.

Dönen Değerler

Belirtilen seçenek tanımlı değilse boş bir dizge, aksi takdirde seçeneğin değerini döndürür.

Ayrıca Bakınız

  • Kullanılabilecek seçenek isimleri için: yaz_set_option() - Bağlantı ile ilgili seçenekleri belirler

yaz_es
yaz_hits
YAZ İşlevleri


Son arama ile eşleşenlerin sayısını döndürür

yaz_get_option
yaz_itemorder
YAZ İşlevleri
PHP Manual

yaz_hits

(PHP 4 >= 4.0.1, PECL yaz >= 0.9.0)

yaz_hits — Son arama ile eşleşenlerin sayısını döndürür

Açıklama

int yaz_hits ( resource $id [, array &$sonuçlar ] )

yaz_hits() işlevi, son arama ile eşleşenlerin sayısını döndürür.

Değiştirgeler

id

yaz_connect() tarafından döndürülmüş bağlantı özkaynağı.

sonuçlar

Arama sonuçlarının ayrıntılarını içeren dizi.

Dönen Değerler

Arama yapılmamışsa 0, aksi takdirde arama ile eşleşenlerin sayısını döndürür.

sonuçlar değiştirgesi belirtilmişse, Z39.50 sunucusu tarafından döndürülen bir arama yanıtının SearchResult-1 biçemli parçası belirtilen diziye yerleştirilir. SearchResult-1 biçemi, sorgunun çeşitli parçalarından (alt sorgular) elde edilmiş eşleşmelerin sayısı hakkında bilgi edinmek için kullanılabilir. Özellikle, bir sorgudan tek bir arama kuralı ile eşleşenlerin sayısını öğrenmek mümkündür. İlk alt sorgunun bilgileri $dizi[0]'a, ikincisi $dizi[1]'e, ve benzeri şeklinde gider.

sonuçlar dizisinin üyeleri
Eleman | Açıklama
id | Alt sorgu ID2 (string)
count | Sonuç sayısı (integer)
subquery.term | Alt sorgu kuralı (string)
interpretation.term | Yorumlanmış alt sorgu kuralı (string)
recommendation.term | Önerilen alt sorgu kuralı (string)

Bilginize:

SearchResult oluşumu PECL YAZ 1.0.5 vesonrası ile YAZ 2.1.9 ve sonrasını gerektirir.

Bilginize:

Çok az Z39.50 gerçeklenimi SearchResult oluşumunu destekler.

yaz_get_option
yaz_itemorder
YAZ İşlevleri


Bir ILL-Request paketli Z39.50 Item Order için hazırlık yapar

yaz_hits
yaz_present
YAZ İşlevleri
PHP Manual

yaz_itemorder

(PHP 4 >= 4.0.5, PECL yaz >= 0.9.0)

yaz_itemorder — Bir ILL-Request paketli Z39.50 Item Order için hazırlık yapar

Açıklama

void yaz_itemorder ( resource $id , array $değiştirgeler )

Bu işlev, Z39.50 Item Order Extended Service kullanımı için Profile kullanarak Transport ILL'ye bir Extended Services isteği hazırlar. Bu cümleyi anlayabilmek için » bu adrese ve » bu belirtime bakınız.

Değiştirgeler

id

yaz_connect() tarafından döndürülmüş bağlantı özkaynağı.

args

Gönderilecek Item Order isteği hakkında bilgi içeren bir ilişkisel dizi olmalıdır. Özetin anahtarı, ilgili ASN.1 yafta yolunun ismidir. Örneğin aşağıdaki ISBN Item-ID'si item-id,ISBN anahtarına sahiptir.

ILL-Request değiştirgeleri:

protocol-version-num
transaction-id,initial-requester-id,person-or-institution-symbol,person
transaction-id,initial-requester-id,person-or-institution-symbol,institution
transaction-id,initial-requester-id,name-of-person-or-institution,name-of-person
transaction-id,initial-requester-id,name-of-person-or-institution,name-of-institution
transaction-id,transaction-group-qualifier
transaction-id,transaction-qualifier
transaction-id,sub-transaction-qualifier
service-date-time,this,date
service-date-time,this,time
service-date-time,original,date
service-date-time,original,time
requester-id,person-or-institution-symbol,person
requester-id,person-or-institution-symbol,institution
requester-id,name-of-person-or-institution,name-of-person
requester-id,name-of-person-or-institution,name-of-institution
responder-id,person-or-institution-symbol,person
responder-id,person-or-institution-symbol,institution
responder-id,name-of-person-or-institution,name-of-person
responder-id,name-of-person-or-institution,name-of-institution
transaction-type
delivery-address,postal-address,name-of-person-or-institution,name-of-person
delivery-address,postal-address,name-of-person-or-institution,name-of-institution
delivery-address,postal-address,extended-postal-delivery-address
delivery-address,postal-address,street-and-number
delivery-address,postal-address,post-office-box
delivery-address,postal-address,city
delivery-address,postal-address,region
delivery-address,postal-address,country
delivery-address,postal-address,postal-code
delivery-address,electronic-address,telecom-service-identifier
delivery-address,electronic-address,telecom-service-addreess
billing-address,postal-address,name-of-person-or-institution,name-of-person
billing-address,postal-address,name-of-person-or-institution,name-of-institution
billing-address,postal-address,extended-postal-delivery-address
billing-address,postal-address,street-and-number
billing-address,postal-address,post-office-box
billing-address,postal-address,city
billing-address,postal-address,region
billing-address,postal-address,country
billing-address,postal-address,postal-code
billing-address,electronic-address,telecom-service-identifier
billing-address,electronic-address,telecom-service-addreess
ill-service-type
requester-optional-messages,can-send-RECEIVED
requester-optional-messages,can-send-RETURNED
requester-optional-messages,requester-SHIPPED
requester-optional-messages,requester-CHECKED-IN
search-type,level-of-service
search-type,need-before-date
search-type,expiry-date
search-type,expiry-flag
place-on-hold
client-id,client-name
client-id,client-status
client-id,client-identifier
item-id,item-type
item-id,call-number
item-id,author
item-id,title
item-id,sub-title
item-id,sponsoring-body
item-id,place-of-publication
item-id,publisher
item-id,series-title-number
item-id,volume-issue
item-id,edition
item-id,publication-date
item-id,publication-date-of-component
item-id,author-of-article
item-id,title-of-article
item-id,pagination
item-id,ISBN
item-id,ISSN
item-id,additional-no-letters
item-id,verification-reference-source
copyright-complicance
retry-flag
forward-flag
requester-note
forward-note

Extended Services Request paketinin ve ItemOrder paketinin parçası olan bir kaç değiştirge daha vardır:

package-name
user-id
contact-name
contact-phone
contact-email
itemorder-item

Dönen Değerler

Hiçbir değer dönmez.

yaz_hits
yaz_present
YAZ İşlevleri


Bir alım (Z39.50 present) düzenler

yaz_itemorder
yaz_range
YAZ İşlevleri
PHP Manual

yaz_present

(PHP 4 >= 4.0.5, PECL yaz >= 0.9.0)

yaz_present — Bir alım (Z39.50 present) düzenler

Açıklama

bool yaz_present ( resource $id )

Bu işlev başarılı bir aramanın ardından kayıtları alım için hazırlar.

Bu işlevden önce, alınacak kayıt aralığını belirleyen yaz_range() işlevi çağrılmalıdır.

Değiştirgeler

id

yaz_connect() tarafından döndürülmüş bağlantı özkaynağı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

yaz_itemorder
yaz_range
YAZ İşlevleri


Edinilecek kayıtlar için bir aralık belirler

yaz_present
yaz_record
YAZ İşlevleri
PHP Manual

yaz_range

(PHP 4 >= 4.0.1, PECL yaz >= 0.9.0)

yaz_range — Edinilecek kayıtlar için bir aralık belirler

Açıklama

void yaz_range ( resource $id , int $başlangıç , int $sayı )

Edinilecek kayıtlar için bir aralık belirler.

Bu işlevin yaz_search() veya yaz_present() işlevinden önce çağrılması gerekir.

Değiştirgeler

id

yaz_connect() tarafından döndürülmüş bağlantı özkaynağı.

başlangıç

Edinilecek ilk kaydın konumu. yaz_hits() için kayıt numaraları 1'den başlar.

sayı

Edinilecek kayıt sayısı.

Dönen Değerler

Hiçbir değer dönmez.

yaz_present
yaz_record
YAZ İşlevleri


Bir kayıt döndürür

yaz_range
yaz_scan_result
YAZ İşlevleri
PHP Manual

yaz_record

(PHP 4 >= 4.0.1, PECL yaz >= 0.9.0)

yaz_record — Bir kayıt döndürür

Açıklama

string yaz_record ( resource $id , int $konum , string $tür )

yaz_record() işlevi, geçerli sonuç kümesinin konum ile belirtilen konumundaki kaydı döndürür.

Değiştirgeler

id

yaz_connect() tarafından döndürülmüş bağlantı özkaynağı.

konum

Kaydın konumu. Sonuç kümesindeki kayıtların konumları 1, 2, ..., $sayı şeklinde olup $sayı, yaz_hits() işlevi tarafından döndürülen sonuç sayısıdır.

tür

Dönen kaydın biçimi belirtilir.

Bilginize:

Aslında, kayıtların Z39.50/SRW sunucusundan uygun biçemde dönmesini garanti etmekten sorumludur. tür sadece, istemci tarafında yer alacak bir uzlaşım belirtir (PHP/YAZ olarak).

Aktarım kaydının bir dizi veya dizgeye dönüşmesinin yanında, PHP/YAZ'ın kayda bir karakter kümesi dönüşümü de uygulaması mümkündür. USMARC/MARC21 için bu özellikle önerilir, çünkü bunlar tarayıcılar tarafından desteklenmeyen MARC-8 karakter kümesini kullanırlar. Dönüşüm belirtmek için şunu ekleyin: ; charset=kaynak, hedef. Burada kaynak kaydın özgün karakter kümesini, hedef ise PHP tarafından görülecek karakter kümesini belirtir.

string

Kayıt, basit gösterim için bir dizge olarak döndürülür. Bu kipte, tüm MARC kayıtları ISO2709 zorlukla okunabildiğinden satırlı biçeme dönüştürülür. XML kayıtları ve SUTRS özgün biçemleriyle döndürülür. GRS-1 ise satırlı fakat çirkin bir biçemde döndürülür.

Kaydın çabucak basit bir biçemde gösterilmesi gerektiğinde, hata ayıklamak için veya başka türlü göstermenin uygun olmadığı durumlarda bu biçem yararlıdır.

xml

Mümkünse kayıt bir XML dizge olarak döndürülür. Bu kipte tüm MARC kayıtları » MARCXML'e dönüştürülür. XML kayıtları ve SUTRS özgün biçemleriyle döndürülür. GRS-1 desteklenmez.

Bu biçem, MARC kayıtlarının MARCXML'e dönüştürülmesi dışında string biçemine benzer.

Bu biçem, kayıtların bir XML çözümleyici veya bir XSLT işlemcisi tarafından işleme sokulmasının gerektiği durumlarda yararlıdır.

raw

Kayıt, özgün biçemi korunarak bir dizge olarak döndürülür. Bu tür, MARC, XML ve SUTRS için yararlıdır. GRS-1 için işe yaramaz.

MARC kayıtları bir ISO2709 dizgesi olarak döndürülür. XML ve SUTRS ise dizge olarak döndürülür.

syntax

Kaydın sözdizimi ismi, USmarc, GRS-1, XML gibi bir dizge olarak döndürülür.

database

Kaydın ilişkili olduğu veritabanının ismi bir dizge olarak döndürülür.

array

Kayıt, GRS-1 yapısını yansıtan bir dizi olarak döndürülür. Bu tür, MARC ve GRS-1 için elverişlidir. XML ve SUTRS desteklenmez ve asıl kayıt XML veya SUTRS ise boş bir dizge döner.

Dönen dizi, GRS-1'in her dahili/uç düğümü ile ilişkili bir listeden oluşur. Her liste öğesi, ilk elemanı yol ve (varsa) veri olan bir alt listeden oluşur.

Yol öğesi, ağacın köküne göre ağaç bileşenlerinin listesini içeren bir dizgedir. Her bileşen (tür, değer) biçeminde bir yafta türü ve yafta değeri çiftinden oluşur.

Dizge yaftalar normalde 3. tür yaftaya karşılıktır. MARC bir dizi olarak da döndürülebilir (dahili olarak GRS-1'e dönüştürülür).

Dönen Değerler

Belirtilen konumda kayıt yoksa boş bir dizge, varsa kaydı döndürür.

Belirtilen konumda veritabanı kaydı yoksa boş bir dizge döner.

Örnekler

Örnek 1 - GRS-1 kaydı için bir dizi

GRS-1 kaydı şöyle olsun:

(4,52)Robert M. Pirsig
(4,70)
      (4,90)
            (2,7)Transworld Publishers, ltd.
Bu kayıt, kök seviyesinde iki düğüme sahiptir. Kök seviyesindeki düğümlerden ilkinin yaftası (4,52) [yafta türü: 4, yafta değeri: 52], verisi ise Robert M. Pirsig'dir; ikincisinin yaftası (4,70) olup (4,90) yaftalı tek elemanlı bir alt ağaç ve bu ağaç da (2,7) yaftalı ve Transworld Publishers, ltd. verili bir düğüm içermektedir.

Bu kaydın bulunduğu konum $p ise,

<?php

$ar = yaz_record($id, $p, "array");
print_r($ar);

?>
kodunun çıktısı şöyle olur:
Array
(
    [0] => Array
        (
            [0] => (4,52)
            [1] => Robert M. Pirsig
        )
    [1] => Array
        (
            [0] => (4,70)
        )
    [2] => Array
        (
            [0] => (4,70)(4,90)
        )
    [3] => Array
        (
            [0] => (4,70)(4,90)(2,7)
            [1] => Transworld Publishers, ltd.
        )
)

Örnek 2 - MARCXML ile çalışma

Aşağıdaki PHP betiği MARCXML olarak bir MARC21/USMARC kaydı döndürür. Özgün kayıt (çoğu XML çözümleyicinin bilmediği) marc-8 kodlu olduğundan (tüm XML çözümleyicilerin desteklediği) UTF-8'e dönüştürüyoruz.

<?php
$rec = yaz_record($id, $p, "xml; charset=marc-8,utf-8");
?>

$rec kaydı Sablotron XSLT işlemcisi tarafından şöyle işlenir:

<?php

$xslfile = 'display.xsl';
$processor = xslt_create();
$parms = array('/_xml' => $rec);
$res = xslt_process($processor, 'arg:/_xml', $xslfile, NULL, $parms);
xslt_free($processor);
$res = preg_replace("'</?html[^>]*>'", '', $res);
echo $res;

?>

PHP 5 için Sablotron XSLT yerine XSL eklentisi kullanılmalıdır.

yaz_range
yaz_scan_result
YAZ İşlevleri


Tarama sonucunu döndürür

yaz_record
yaz_scan
YAZ İşlevleri
PHP Manual

yaz_scan_result

(PHP 4 >= 4.0.5, PECL yaz >= 0.9.0)

yaz_scan_result — Tarama sonucunu döndürür

Açıklama

array yaz_scan_result ( resource $id [, array &$sonuç ] )

yaz_scan_result() işlevi son yaz_scan() çağrısı için sunucudan alınan tarama bilgilerini ve terimleri döndürür.

Değiştirgeler

id

yaz_connect() tarafından döndürülmüş bağlantı özkaynağı.

sonuç

Belirtildiği takdirde, tarama yanıtıyla alınan ek bilgiler bu diziye yerleştirilir. Dizinin anahtarları:

  • number - Dönen girdi sayısı.

  • stepsize - Adım boyu.

  • position - Terimin konumu.

  • status - Tarama durumu.

Dönen Değerler

N dönen terim sayısı olmak üzere (0..N-1) terimden oluşan bir dizi döner. Her eleman bir çift değerden oluşur. İlk değer terimi, ikincisi sonuç sayısını içerir.

yaz_record
yaz_scan
YAZ İşlevleri


Bir tarama düzenler

yaz_scan_result
yaz_schema
YAZ İşlevleri
PHP Manual

yaz_scan

(PHP 4 >= 4.0.5, PECL yaz >= 0.9.0)

yaz_scan — Bir tarama düzenler

Açıklama

void yaz_scan ( resource $id , string $tür , string $başlangıç [, array $seçenekler ] )

Bu işlev belirtilen bağlantı üzerinde bir Z39.50 tarama isteği (Scan Request) düzenler.

Tarama isteğini sunucuya gerçekten aktarmak ve tarama yanıtını almak için
yaz_wait() çağrısı yapılmalıdır.
yaz_wait() çağrısının tamamlanmasının ardından yanıtı
işlemek için yaz_error() ve
yaz_scan_result()çağrılır.

Değiştirgeler

id

yaz_connect() tarafından döndürülmüş bağlantı özkaynağı.

tür

Şimdilik sadece rpn türü desteklenmektedir.

startterm

Taramanın başlatılacağı terim.

Başlangıç teriminin biçimi tür değiştirgesiyle belirtilir.

Bu değiştirgenin sözdizimi yaz_search() işlevindeki RPN sorgusuna benzer. Sıfır veya daha fazla sayıda, tek terimli @attr ifadelerinden oluşur.

seçenekler

Belirtilmesi isteğe bağlı olan bu değiştirge ile tarama isteğinin davranışını belirleyen ek bilgiler belirtilir. Şimdilik seçenekler dizisinden üç anahtar okunmaktadır: number (istenen terim sayısı), position (terimin tercihli konumu) ve stepSize (tercih edilen adım boyu).

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 - Başlıkları tarayan PHP işlevi

<?php
function scan_titles($id, $başlangıç)
{
  yaz_scan($id, "rpn", "@attr 1=4 " . $başlangıç);
  yaz_wait();
  $errno = yaz_errno($id);
  if ($errno == 0) {
    $ar = yaz_scan_result($id, $seçenekler);
    echo 'Tarama bitti; ';
    foreach ($seçenekler as $anahtar => $değer) {
      echo "$anahtar = $değer &nbsp;";
    }
    echo '<br /><table>';
    while (list($anahtar, list($k, $terim, $tsayısı)) = each($ar)) {
      if (empty($k)) continue;
      echo "<tr><td>$terim</td><td>$tsayısı</td></tr>";
    }
    echo '</table>';
  } else {
    echo "Tarama başarısız oldu. Hata: " . yaz_error($id) . "<br />";
  }
}
?>

yaz_scan_result
yaz_schema
YAZ İşlevleri


Alım için şema belirtir

yaz_scan
yaz_search
YAZ İşlevleri
PHP Manual

yaz_schema

(PHP 4 >= 4.2.0, PECL yaz >= 0.9.0)

yaz_schema — Alım için şema belirtir

Açıklama

void yaz_schema ( resource $id , string $şema )

yaz_schema() işlevi alım için şema belirtir.

Bu işlev, yaz_search() veya yaz_present() işlevinden önce çağrılmalıdır.

Değiştirgeler

id

yaz_connect() tarafından döndürülmüş bağlantı özkaynağı.

şema

Ham noktalı gösterimle (1.2.840.10003.13.4 gibi) veya bilinen kayıtlı şemalardan biri (GILS-schema, Holdings, Zthes, ...) olarak belirtilmelidir.

Dönen Değerler

Hiçbir değer dönmez.

yaz_scan
yaz_search
YAZ İşlevleri


Bir arama düzenler

yaz_schema
yaz_set_option
YAZ İşlevleri
PHP Manual

yaz_search

(PHP 4 >= 4.0.1, PECL yaz >= 0.9.0)

yaz_search — Bir arama düzenler

Açıklama

bool yaz_search ( resource $id , string $tür , string $sorgu )

yaz_search() işlevi belirtilen bağlantı için bir arama düzenler.

yaz_connect() işlevi gibi bu işlev de engellenmeyen kipte çalışır ve yaz_wait() çağrısına hazırlık olarak bir arama işlemi düzenler.

Değiştirgeler

id

yaz_connect() tarafından döndürülmüş bağlantı özkaynağı.

tür

Sorgu türü - şimdilik sadece "rpn" desteklenmekte olup, bu durumda üçüncü değiştirge, önek sorgu gösteriminde bir Type-1 sorgusu belirtir.

sorgu

Z39.50 standardında tanımlandığı gibi Type-1 sorgusunun dizgesel gösterimi olarak RPN sorgusu. Sorgu dizgesi boşluklarla ayrılmış dizgeciklerden oluşur ve boşluk içeren dizgeciklerin tırnak içine alınması gerekir. @ (kuyruklu a) karakteri ile başlayan dizgecikler işleç olarak, diğerleri arama terimleri olarak ele alınır.

RPN İşleçleri
İfade Sözdizimi | Açıklama
@and sorgu1 sorgu2 | sorgu1 ve sorgu2'nin kesişimi
@or sorgu1 sorgu2 | sorgu1 ve sorgu2'nin birleşimi
@not sorgu1 sorgu2 | sorgu1 değildir sorgu2
@set isim | Sonuç kümesi gönderimi
@attrset küme sorgu | Sorgu için öznitelik kümesi belirtir. Bu ifadeye sadece tüm sorgunun en başında bir defalığına izin verilir.
@attr [küme] tür=değer sorgu | Sorguya özniteliği uygular. tür ve değer birer tamsayı olup öznitelik türünü ve değerini belirtir. küme ise kullanıldığı takdirde öznitelik kümesini belirtir.

Öznitelikler hakkında bilgi edinmek için » Z39.50 Maintenance Agency sitesine bakınız.

Bilginize:

Daha hoş bir gösterim isterseniz CCL çözümleyici - yaz_ccl_conf() ve yaz_ccl_parse() işlevlerini - kullanın.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Sorgu örnekleri - Aşağıdaki gibi basit ifadeleri aratabilirsiniz

computer
İçinde "computer" geçen belgelerle eşleşir. Hiçbir öznitelik belirtilmemiştir.

"knuth donald"
İçinde "knuth donald" geçen belgelerle eşleşir (sunucu deyim aramayı destekliyorsa).

@attr 1=1003 @attr 4=1 "knuth donald"
Aynı deyimi iki öznitelikle sorgular. İlk öznitelik 1. türde (Bib-1 kullanımı) olup özniteliğin değeri 1003'tür (Yazar). İkinci öznitelik 4. türde (veri yapısı) olup değeri 1'dir (cümle). Dolayısıyla bu ifade, yazarı Donald Knuth olan belgelerle eşleşir.

@and @or a b @not @or c d e
Açılımı:
(a or b) and ((c or d) not e)

Daha karmaşık bir örnek:

@attrset gils @and @attr 1=4 art @attr 1=2000 company
Sorgu bir bütün olarak GILS öznitelik kümesini kullanır. Dağıtımcı (GILS) olarak company ve başlık (GILS,BIB-1) olarak art içeren belgelerle eşleşir.

yaz_schema
yaz_set_option
YAZ İşlevleri


Bağlantı ile ilgili seçenekleri belirler

yaz_search
yaz_sort
YAZ İşlevleri
PHP Manual

yaz_set_option

(PECL yaz >= 0.9.0)

yaz_set_option — Bağlantı ile ilgili seçenekleri belirler

Açıklama

void yaz_set_option ( resource $id , string $isim , string $değer )
void yaz_set_option ( resource $id , array $seçenekler )

Belirtilen bağlantıya bir veya çok sayıda seçenek atar.

Değiştirgeler

id

yaz_connect() tarafından döndürülmüş bağlantı özkaynağı.

isim veya seçenekler

Bir dizge veya dizi belirtilebilir.

Bir dizge verilirse, atanacak seçeneğin ismi olarak ele alınır. Bu durumda seçenek değerini değer değiştirgesinde belirtmelisiniz.

Bir dizi verilirse, isim => değer çiftlerinden oluşan bir ilişkisel dizi olarak ele alınır.

PHP/YAZ Bağlantı Seçenekleri
İsim | Açıklama
implementationName | Sunucunun gerçeklenim ismi
implementationVersion | Sunucunun gerçeklenim sürümü
implementationId | Sunucunun gerçeklenim kimliği
schema | Alım şeması. Öntanımlı olarak bir şema kullanılmaz. Bu seçeneğin belirtilmesi yaz_schema() kullanımına eşdeğerdir.
preferredRecordSyntax | Alım için kayıt sözdizimi. Öntanımlı olarak bir sözdizimi kullanılmaz. Bu seçeneğin belirtilmesi yaz_syntax() kullanımına eşdeğerdir.
start | yaz_search() veya yaz_present() üzerinden alınacak ilk kaydın konumu. İlk kayıt için başlangıç konumu 0, ikincisinin 1'dir. Bu seçeneğin count seçeneği ile birlikte belirtilmesi, yaz_range() işlevinde kayıtların 1'den başlaması dışında yaz_range() kullanımına eşdeğerdir.
count | yaz_search() veya yaz_present() üzerinden alınabilecek azami kayıt sayısı.
elementSetName | Alım için eleman kümesi ismi. Bu seçeneğin belirtilmesi yaz_element() kullanımına eşdeğerdir.
değer

Tek bir seçenek belirtilmesi durumunda seçeneğin değeri. Önceki değiştirgede bir dizge belirtildiğinde kullanılır.

Dönen Değerler

Hiçbir değer dönmez.

yaz_search
yaz_sort
YAZ İşlevleri


Sıralama kuralını belirler

yaz_set_option
yaz_syntax
YAZ İşlevleri
PHP Manual

yaz_sort

(PHP 4 >= 4.0.7, PECL yaz >= 0.9.0)

yaz_sort — Sıralama kuralını belirler

Açıklama

void yaz_sort ( resource $id , string $kural )

Sıralama kuralını belirler ve Z39.50 Sort'u etkin kılar.

yaz_search() işlevinden önce çağırın; tek başına bir etkisi yoktur. yaz_search() ile birlikte kullanıldığında, bir arama yanıtı alındıktan sonra ve Z39.50 Present (yaz_present()) ile herhangi bir kayıt alınmadan önce bir Z39.50 Sort gönderilmesini sağlar.

Değiştirgeler

id

yaz_connect() tarafından döndürülmüş bağlantı özkaynağı.

kural

alan1 seçenekler1 alan2 seçenekler2 biçeminde bir dizge olup, alan1 ile sıralama için birincil öznitelikler, alan2 ile saniye sayısını, vb. belirtilir.

alan olarak, ya virgüllerle ayrılmış tür=değer çiftlerinden oluşan (1=4,2=1 gibi) bir öznitelik kümesi ya da bir kural dizgesi (title gibi) belirtilir. seçenekler olarak, boşluklarla ayrılarak aşağıdaki karakterler belirtilir:

Sıralama Seçenekleri
a

Artan sıralama

d

Azalan sıralama

i

Harf büyüklüğüne duyarsız sıralama

s

Harf büyüklüğüne duyarlı sıralama

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 - Sıralama kuralları

Başlıkları harf büyüklüğüne duyarsız olarak artan sırada sıralamak için kullanacağınız kural:

1=4 ia

İkincil olarak yazara göre sıralama yapılacaksa, harf büyüklüğüne duyarlı olarak artan sırada sıralamak için kullanacağınız kural:

1=4 ia 1=1003 sa

yaz_set_option
yaz_syntax
YAZ İşlevleri


Alım için tercih edilen kayıt sözdizimini belirler

yaz_sort
yaz_wait
YAZ İşlevleri
PHP Manual

yaz_syntax

(PHP 4 >= 4.0.1, PECL yaz >= 0.9.0)

yaz_syntax — Alım için tercih edilen kayıt sözdizimini belirler

Açıklama

void yaz_syntax ( resource $id , string $sözdizimi )

yaz_syntax() alım için tercih edilen kayıt sözdizimini belirler.

Bu işlev, yaz_search() veya yaz_present() işlevinden önce çağrılmalıdır.

Değiştirgeler

id

yaz_connect() tarafından döndürülmüş bağlantı özkaynağı.

sözdizimi

Sözdizimi, ham noktalı gösterimle (1.2.840.10003.5.10 gibi) veya bilinen kayıtlı sözdizimlerden biri (sutrs, usmarc, grs1, xml, ve benzerleri) olarak belirtilen bir nesne kimliği (OID) olmalıdır.

Dönen Değerler

Hiçbir değer dönmez.

yaz_sort
yaz_wait
YAZ İşlevleri


Z39.50 isteklerinin tamamlanmasını bekler

yaz_syntax
YP/NIS
YAZ İşlevleri
PHP Manual

yaz_wait

(PHP 4 >= 4.0.1, PECL yaz >= 0.9.0)

yaz_wait — Z39.50 isteklerinin tamamlanmasını bekler

Açıklama

mixed yaz_wait ([ array &$seçenekler ] )

yaz_connect(), yaz_search(),
yaz_present(), yaz_scan() ve
yaz_itemorder() işlevleri tarafından hazırlanmış askıdaki
istekler için ağda engellenmiş etkinliği gerçekleştirir.

yaz_wait() işlevi, tüm sunucular işlerini tamamladıktan veya (hata durumunda) bağlantıyı terkettikten sonra döner.

Değiştirgeler

seçenekler

Şu seçenekleri içeren bir ilişkisel dizi:

timeout

Saniye cinsinden zaman aşımı süresi. Sunucu bu süre içinde yanıt vermezse ölü kabul edilir ve yaz_wait() döner. Öntanımlı zaman aşımı süresi 15 saniyedir.

event

Mantıksal bir değer.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. event TRUE ise bir özkaynak, hata oluşmuşsa FALSE döner.

yaz_syntax
YP/NIS
YAZ İşlevleri


YP/NIS

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • YP/NIS İşlevleri
    • yp_all — Traverse the map and call a function on each entry
    • yp_cat — Return an array containing the entire map
    • yp_err_string — Returns the error string associated with the given error code
    • yp_errno — Returns the error code of the previous operation
    • yp_first — Returns the first key-value pair from the named map
    • yp_get_default_domain — Fetches the machine's default NIS domain
    • yp_master — Returns the machine name of the master NIS server for a map
    • yp_match — Returns the matched line
    • yp_next — Returns the next key-value pair in the named map
    • yp_order — Returns the order number for a map
yaz_wait
Giriş
Diğer Hizmetler


Giriş

NIS (formerly called Yellow Pages) allows network management of important administrative files (e.g. the password file). For more information refer to the NIS manpage and » The Linux NIS(YP)/NYS/NIS+ HOWTO. There is also a book called » Managing NFS and NIS by Hal Stern.

Bilginize:

Bu eklenti » PECL deposuna taşınmış olup şu sürümden itibaren PHP kaynak paketinde dağıtılmamaktatır: PHP 5.1.0.

Bilginize: Bu eklenti Windows sistemlerinde çalışmaz.

YP/NIS
Yapılandırma/Kurulum
YP/NIS


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
YP/NIS


Gereksinimler

None besides functions from standard Unix libraries which are always available (either libc or libnsl, configure will detect which one to use).

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu eklentinin geliştirmesi durmuştur. Ancak, kaynak kodunu PECL SVN deposunda bulabilirsiniz. Yeri: » http://svn.php.net/viewvc/pecl/yp

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

YPERR_ACCESS (integer)
access violation (this has only been added recently and is only available from PECL SVN for now)
YPERR_BADARGS (integer)
The function arguments are bad
YPERR_BADDB (integer)
YP database is bad
YPERR_BUSY (integer)
Database busy
YPERR_DOMAIN (integer)
cannot bind to server in this domain
YPERR_KEY (integer)
no such key in map
YPERR_MAP (integer)
no such map in server's domain
YPERR_NODOM (integer)
Local domain name not set
YPERR_NOMORE (integer)
No more records in map database
YPERR_PMAP (integer)
Can't communicate with portmapper
YPERR_RESRC (integer)
resource allocation failure
YPERR_RPC (integer)
RPC failure - domain has been unbound
YPERR_YPBIND (integer)
Can't communicate with ypbind
YPERR_YPERR (integer)
internal yp server or client error
YPERR_YPSERV (integer)
Can't communicate with ypserv
YPERR_VERS (integer)
YP version mismatch
Özkaynak Türleri
YP/NIS İşlevleri
YP/NIS


YP/NIS İşlevleri

İçindekiler

  • yp_all — Traverse the map and call a function on each entry
  • yp_cat — Return an array containing the entire map
  • yp_err_string — Returns the error string associated with the given error code
  • yp_errno — Returns the error code of the previous operation
  • yp_first — Returns the first key-value pair from the named map
  • yp_get_default_domain — Fetches the machine's default NIS domain
  • yp_master — Returns the machine name of the master NIS server for a map
  • yp_match — Returns the matched line
  • yp_next — Returns the next key-value pair in the named map
  • yp_order — Returns the order number for a map
Öntanımlı Sabitler
yp_all
YP/NIS


Traverse the map and call a function on each entry

YP/NIS İşlevleri
yp_cat
YP/NIS İşlevleri
PHP Manual

yp_all

(PHP 4 >= 4.0.6, PHP 5 <= 5.0.5)

yp_all — Traverse the map and call a function on each entry

Açıklama

void yp_all ( string $domain , string $map , string $callback )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

domain

The NIS domain name.

map

The NIS map.

callback

Dönen Değerler

Hiçbir değer dönmez.

YP/NIS İşlevleri
yp_cat
YP/NIS İşlevleri


Return an array containing the entire map

yp_all
yp_err_string
YP/NIS İşlevleri
PHP Manual

yp_cat

(PHP 4 >= 4.0.6, PHP 5 <= 5.0.5)

yp_cat — Return an array containing the entire map

Açıklama

array yp_cat ( string $domain , string $map )

Returns all map entries.

Değiştirgeler

domain

The NIS domain name.

map

The NIS map.

Dönen Değerler

Returns an array of all map entries, the maps key values as array indices and the maps entries as array data.

yp_all
yp_err_string
YP/NIS İşlevleri


Returns the error string associated with the given error code

yp_cat
yp_errno
YP/NIS İşlevleri
PHP Manual

yp_err_string

(PHP 4 >= 4.0.6, PHP 5 <= 5.0.5)

yp_err_string — Returns the error string associated with the given error code

Açıklama

string yp_err_string ( int $errorcode )

Returns the error message associated with the given error code. Useful to indicate what exactly went wrong.

Değiştirgeler

errorcode

The error code.

Dönen Değerler

Returns the error message, as a string.

Örnekler

Örnek 1 Example for NIS errors

<?php
echo "Error: " . yp_err_string(yp_errno());
?>

Ayrıca Bakınız

  • yp_errno() - Returns the error code of the previous operation

yp_cat
yp_errno
YP/NIS İşlevleri


Returns the error code of the previous operation

yp_err_string
yp_first
YP/NIS İşlevleri
PHP Manual

yp_errno

(PHP 4 >= 4.0.6, PHP 5 <= 5.0.5)

yp_errno — Returns the error code of the previous operation

Açıklama

int yp_errno ( void )

Returns the error code of the previous operation.

Dönen Değerler

Returns one of the YPERR_XXX error constants.

Ayrıca Bakınız

  • yp_err_string() - Returns the error string associated with the given error code

yp_err_string
yp_first
YP/NIS İşlevleri


Returns the first key-value pair from the named map

yp_errno
yp_get_default_domain
YP/NIS İşlevleri
PHP Manual

yp_first

(PHP 4, PHP 5 <= 5.0.5)

yp_first — Returns the first key-value pair from the named map

Açıklama

array yp_first ( string $domain , string $map )

Gets the first key-value pair from the named map in the named domain.

Değiştirgeler

domain

The NIS domain name.

map

The NIS map.

Dönen Değerler

Returns the first key-value pair as an array on success, or FALSE on errors.

Örnekler

Örnek 1 Example for the NIS first

<?php
$entry = yp_first($domain, "passwd.byname");

$key = key($entry);
$value = $entry[$key];

echo "First entry in this map has key " . $key . " and value " . $value;
?>

Ayrıca Bakınız

  • yp_next() - Returns the next key-value pair in the named map
  • yp_get_default_domain() - Fetches the machine's default NIS domain

yp_errno
yp_get_default_domain
YP/NIS İşlevleri


Fetches the machine's default NIS domain

yp_first
yp_master
YP/NIS İşlevleri
PHP Manual

yp_get_default_domain

(PHP 4, PHP 5 <= 5.0.5)

yp_get_default_domain — Fetches the machine's default NIS domain

Açıklama

string yp_get_default_domain ( void )

Returns the default domain of the node. Can be used as the domain parameter for successive NIS calls.

A NIS domain can be described a group of NIS maps. Every host that needs to look up information binds itself to a certain domain. Refer to the documents mentioned at the beginning for more detailed information.

Dönen Değerler

Returns the default domain of the node or FALSE. Can be used as the domain parameter for successive NIS calls.

Örnekler

Örnek 1 Example for the default domain

<?php
$domain = yp_get_default_domain();
echo "Default NIS domain is: " . $domain;
?>

yp_first
yp_master
YP/NIS İşlevleri


Returns the machine name of the master NIS server for a map

yp_get_default_domain
yp_match
YP/NIS İşlevleri
PHP Manual

yp_master

(PHP 4, PHP 5 <= 5.0.5)

yp_master — Returns the machine name of the master NIS server for a map

Açıklama

string yp_master ( string $domain , string $map )

Returns the machine name of the master NIS server for a map.

Değiştirgeler

domain

The NIS domain name.

map

The NIS map.

Dönen Değerler

Örnekler

Örnek 1 Example for the NIS master

<?php
$number = yp_master($domain, $mapname);
echo "Master for this map is: " . $master;
?>

Ayrıca Bakınız

  • yp_get_default_domain() - Fetches the machine's default NIS domain

yp_get_default_domain
yp_match
YP/NIS İşlevleri


Returns the matched line

yp_master
yp_next
YP/NIS İşlevleri
PHP Manual

yp_match

(PHP 4, PHP 5 <= 5.0.5)

yp_match — Returns the matched line

Açıklama

string yp_match ( string $domain , string $map , string $key )

Returns the value associated with the passed key out of the specified map.

Değiştirgeler

domain

The NIS domain name.

map

The NIS map.

key

This key must be exact.

Dönen Değerler

Returns the value, or FALSE on errors.

Örnekler

Örnek 1 Example for NIS match

<?php
$entry = yp_match($domain, "passwd.byname", "joe");
echo "Matched entry is: " . $entry;
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

joe:##joe:11111:100:Joe User:/home/j/joe:/usr/local/bin/bash

Ayrıca Bakınız

  • yp_get_default_domain() - Fetches the machine's default NIS domain

yp_master
yp_next
YP/NIS İşlevleri


Returns the next key-value pair in the named map

yp_match
yp_order
YP/NIS İşlevleri
PHP Manual

yp_next

(PHP 4, PHP 5 <= 5.0.5)

yp_next — Returns the next key-value pair in the named map

Açıklama

array yp_next ( string $domain , string $map , string $key )

Returns the next key-value pair in the named map after the specified key.

Değiştirgeler

domain

map

key

Dönen Değerler

Returns the next key-value pair as an array, or FALSE on errors.

Örnekler

Örnek 1 Example for NIS next

<?php
$entry = yp_next($domain, "passwd.byname", "joe");

if (!$entry) {
    echo "No more entries found\n";
    echo "<!--" . yp_errno() . ": " . yp_err_string() . "-->";
}

$key = key($entry);

echo "The next entry after joe has key " . $key
      . " and value " . $entry[$key];
?>

Ayrıca Bakınız

  • yp_first() - Returns the first key-value pair from the named map
  • yp_get_default_domain() - Fetches the machine's default NIS domain

yp_match
yp_order
YP/NIS İşlevleri


Returns the order number for a map

yp_next
0MQ messaging
YP/NIS İşlevleri
PHP Manual

yp_order

(PHP 4, PHP 5 <= 5.0.5)

yp_order — Returns the order number for a map

Açıklama

int yp_order ( string $domain , string $map )

Gets the order number for a map.

Değiştirgeler

domain

map

Dönen Değerler

Returns the order number for a map or FALSE on error.

Örnekler

Örnek 1 Example for the NIS order

<?php
    $number = yp_order($domain, $mapname);
    echo "Order number for this map is: " . $number;
?>

Ayrıca Bakınız

  • yp_get_default_domain() - Fetches the machine's default NIS domain

yp_next
0MQ messaging
YP/NIS İşlevleri


ZMQ

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
  • ZMQ — The ZMQ class
    • ZMQ::__construct — ZMQ constructor
  • ZMQContext — The ZMQContext class
    • ZMQContext::__construct — Construct a new ZMQContext object
    • ZMQContext::getOpt — Get context option
    • ZMQContext::getSocket — Create a new socket
    • ZMQContext::isPersistent — Whether the context is persistent
    • ZMQContext::setOpt — Set a socket option
  • ZMQSocket — The ZMQSocket class
    • ZMQSocket::bind — Bind the socket
    • ZMQSocket::connect — Connect the socket
    • ZMQSocket::__construct — Construct a new ZMQSocket
    • ZMQSocket::disconnect — Disconnect a socket
    • ZMQSocket::getEndpoints — Get list of endpoints
    • ZMQSocket::getPersistentId — Get the persistent id
    • ZMQSocket::getSocketType — Get the socket type
    • ZMQSocket::getSockOpt — Get socket option
    • ZMQSocket::isPersistent — Whether the socket is persistent
    • ZMQSocket::recv — Receives a message
    • ZMQSocket::recvMulti — Receives a multipart message
    • ZMQSocket::send — Sends a message
    • ZMQSocket::sendmulti — Sends a multipart message
    • ZMQSocket::setSockOpt — Set a socket option
    • ZMQSocket::unbind — Unbind the socket
  • ZMQPoll — The ZMQPoll class
    • ZMQPoll::add — Add item to the poll set
    • ZMQPoll::clear — Clear the poll set
    • ZMQPoll::count — Count items in the poll set
    • ZMQPoll::getLastErrors — Get poll errors
    • ZMQPoll::poll — Poll the items
    • ZMQPoll::remove — Remove item from poll set
  • ZMQDevice — The ZMQDevice class
    • ZMQDevice::__construct — Construct a new device
    • ZMQDevice::getIdleTimeout — Get the idle timeout
    • ZMQDevice::getTimerTimeout — Get the timer timeout
    • ZMQDevice::run — Run the new device
    • ZMQDevice::setIdleCallback — Set the idle callback function
    • ZMQDevice::setIdleTimeout — Set the idle timeout
    • ZMQDevice::setTimerCallback — Set the timer callback function
    • ZMQDevice::setTimerTimeout — Set the timer timeout
yp_order
Giriş
Diğer Hizmetler


Giriş

"ØMQ is a software library that lets you quickly design and implement a fast message-based application." --0MQ Website

For more information about 0MQ, see » http://zeromq.org/.

0MQ messaging
Yapılandırma/Kurulum
0MQ messaging


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
Giriş
Gereksinimler
0MQ messaging


Gereksinimler

ZMQ extension requires 0MQ version 2.0.7 or higher. 0MQ can be acquired from » http://zeromq.org/area:download.

Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/zmq

Yapılandırma/Kurulum
ZMQ
Yapılandırma/Kurulum


The ZMQ class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

Sınıf Sözdizimi

ZMQ {
/* Constants */
const integer SOCKET_PAIR ;
const integer SOCKET_PUB ;
const integer SOCKET_SUB ;
const integer SOCKET_REQ ;
const integer SOCKET_REP ;
const integer SOCKET_XREQ ;
const integer SOCKET_XREP ;
const integer SOCKET_PUSH ;
const integer SOCKET_PULL ;
const integer SOCKET_ROUTER ;
const integer SOCKET_DEALER ;
const integer SOCKET_XPUB ;
const integer SOCKET_XSUB ;
const integer SOCKET_STREAM ;
const integer SOCKOPT_HWM ;
const integer SOCKOPT_SNDHWM ;
const integer SOCKOPT_RCVHWM ;
const integer SOCKOPT_AFFINITY ;
const integer SOCKOPT_IDENTITY ;
const integer SOCKOPT_SUBSCRIBE ;
const integer SOCKOPT_UNSUBSCRIBE ;
const integer SOCKOPT_RATE ;
const integer SOCKOPT_RECOVERY_IVL ;
const integer SOCKOPT_RECONNECT_IVL ;
const integer SOCKOPT_RECONNECT_IVL_MAX ;
const integer SOCKOPT_MCAST_LOOP ;
const integer SOCKOPT_SNDBUF ;
const integer SOCKOPT_RCVBUF ;
const integer SOCKOPT_RCVMORE ;
const integer SOCKOPT_TYPE ;
const integer SOCKOPT_LINGER ;
const integer SOCKOPT_BACKLOG ;
const integer SOCKOPT_MAXMSGSIZE ;
const integer SOCKOPT_SNDTIMEO ;
const integer SOCKOPT_RCVTIMEO ;
const integer SOCKOPT_IPV4ONLY ;
const integer SOCKOPT_LAST_ENDPOINT ;
const integer SOCKOPT_TCP_KEEPALIVE_IDLE ;
const integer SOCKOPT_TCP_KEEPALIVE_CNT ;
const integer SOCKOPT_TCP_KEEPALIVE_INTVL ;
const integer SOCKOPT_TCP_ACCEPT_FILTER ;
const integer SOCKOPT_TCP_ACCEPT_FILTER ;
const integer SOCKOPT_DELAY_ATTACH_ON_CONNECT ;
const integer SOCKOPT_XPUB_VERBOSE ;
const integer SOCKOPT_ROUTER_RAW ;
const integer SOCKOPT_IPV6 ;
const integer CTXOPT_MAX_SOCKETS ;
const integer POLL_IN ;
const integer POLL_OUT ;
const integer MODE_NOBLOCK ;
const integer MODE_DONTWAIT ;
const integer MODE_SNDMORE ;
const integer ERR_INTERNAL ;
const integer ERR_EAGAIN ;
const integer ERR_ENOTSUP ;
const integer ERR_EFSM ;
const integer ERR_ETERM ;
/* Methods */
private__construct ( void )
}

Öntanımlı Sabitler

ZMQ Constant Types

ZMQ::SOCKET_PAIR

Exclusive pair pattern

ZMQ::SOCKET_PUB

Publisher socket

ZMQ::SOCKET_SUB

Subscriber socket

ZMQ::SOCKET_REQ

Request socket

ZMQ::SOCKET_REP

Reply socket

ZMQ::SOCKET_XREQ

Alias for SOCKET_DEALER

ZMQ::SOCKET_XREP

Alias for SOCKET_ROUTER

ZMQ::SOCKET_PUSH

Pipeline upstream push socket

ZMQ::SOCKET_PULL

Pipeline downstream pull socket

ZMQ::SOCKET_ROUTER

Extended REP socket that can route replies to requesters

ZMQ::SOCKET_DEALER

Extended REQ socket that load balances to all connected peers

ZMQ::SOCKET_XPUB

Similar to SOCKET_PUB, except you can receive subscriptions as messages. The subscription message is 0 (unsubscribe) or 1 (subscribe) followed by the topic.

ZMQ::SOCKET_XSUB

Similar to SOCKET_SUB, except you can send subscriptions as messages. See SOCKET_XPUB for format.

ZMQ::SOCKET_STREAM

Used to send and receive TCP data from a non-ØMQ peer. Available if compiled against ZeroMQ 4.x or higher (Value: integer).

ZMQ::SOCKOPT_HWM

The high water mark for inbound and outbound messages is a hard limit on the maximum number of outstanding messages ØMQ shall queue in memory for any single peer that the specified socket is communicating with. Setting this option on a socket will only affect connections made after the option has been set. On ZeroMQ 3.x this is a wrapper for setting both SNDHWM and RCVHWM. (Value: integer).

ZMQ::SOCKOPT_SNDHWM

The ZMQ_SNDHWM option shall set the high water mark for outbound messages on the specified socket. Available if compiled against ZeroMQ 3.x or higher (Value: integer).

ZMQ::SOCKOPT_RCVHWM

The ZMQ_SNDHWM option shall set the high water mark for inbound messages on the specified socket. Available if compiled against ZeroMQ 3.x or higher (Value: integer).

ZMQ::SOCKOPT_AFFINITY

Set I/O thread affinity (Value: integer)

ZMQ::SOCKOPT_IDENTITY

Set socket identity (Value: string)

ZMQ::SOCKOPT_SUBSCRIBE

Establish message filter. Valid for subscriber socket (Value: string)

ZMQ::SOCKOPT_UNSUBSCRIBE

Remove message filter. Valid for subscriber socket (Value: string)

ZMQ::SOCKOPT_RATE

Set rate for multicast sockets (pgm) (Value: integer >= 0)

ZMQ::SOCKOPT_RECOVERY_IVL

Set multicast recovery interval (Value: integer >= 0)

ZMQ::SOCKOPT_RECONNECT_IVL

Set the initial reconnection interval (Value: integer >= 0)

ZMQ::SOCKOPT_RECONNECT_IVL_MAX

Set the max reconnection interval (Value: integer >= 0)

ZMQ::SOCKOPT_MCAST_LOOP

Control multicast loopback (Value: integer >= 0)

ZMQ::SOCKOPT_SNDBUF

Set kernel transmit buffer size (Value: integer >= 0)

ZMQ::SOCKOPT_RCVBUF

Set kernel receive buffer size (Value: integer >= 0)

ZMQ::SOCKOPT_RCVMORE

Receive multi-part messages (Value: integer)

ZMQ::SOCKOPT_TYPE

Get the socket type. Valid for getSockOpt (Value: integer)

ZMQ::SOCKOPT_LINGER

The linger value of the socket. Specifies how long the socket blocks trying flush messages after it has been closed (Value: integer)

ZMQ::SOCKOPT_BACKLOG

The SOCKOPT_BACKLOG option shall set the maximum length of the queue of outstanding peer connections for the specified socket; this only applies to connection-oriented transports. (Value: integer)

ZMQ::SOCKOPT_MAXMSGSIZE

Limits the maximum size of the inbound message. Value -1 means no limit. Available if compiled against ZeroMQ 3.x or higher (Value: integer)

ZMQ::SOCKOPT_SNDTIMEO

Sets the timeout for send operation on the socket. Value -1 means no limit. Available if compiled against ZeroMQ 3.x or higher (Value: integer)

ZMQ::SOCKOPT_RCVTIMEO

Sets the timeout for receive operation on the socket. Value -1 means no limit. Available if compiled against ZeroMQ 3.x or higher (Value: integer)

ZMQ::SOCKOPT_IPV4ONLY

Disable IPV6 support if 1. Available if compiled against ZeroMQ 3.x (Value: integer)

ZMQ::SOCKOPT_LAST_ENDPOINT

Retrieve the last connected endpoint - for use with * wildcard ports. Available if compiled against ZeroMQ 3.x or higher (Value: string)

ZMQ::SOCKOPT_TCP_KEEPALIVE_IDLE

Idle time for TCP keepalive. Available if compiled against ZeroMQ 3.x or higher (Value: integer)

ZMQ::SOCKOPT_TCP_KEEPALIVE_CNT

Count time for TCP keepalive. Available if compiled against ZeroMQ 3.x or higher (Value: integer)

ZMQ::SOCKOPT_TCP_KEEPALIVE_INTVL

Interval for TCP keepalive. Available if compiled against ZeroMQ 3.x or higher (Value: integer)

ZMQ::SOCKOPT_DELAY_ATTACH_ON_CONNECT

Set a CIDR string to match against incoming TCP connections. Available if compiled against ZeroMQ 3.x or higher (Value: string)

ZMQ::SOCKOPT_TCP_ACCEPT_FILTER

Set a CIDR string to match against incoming TCP connections. Available if compiled against ZeroMQ 3.x or higher (Value: string)

ZMQ::SOCKOPT_XPUB_VERBOSE

Set the XPUB to receive an application message on each instance of a subscription. Available if compiled against ZeroMQ 3.x or higher (Value: string)

ZMQ::SOCKOPT_ROUTER_RAW

Sets the raw mode on the ROUTER, when set to 1. In raw mode when using tcp:// transport the socket will read and write without ZeroMQ framing. Available if compiled against ZeroMQ 4.0 or higher (Value: string)

ZMQ::SOCKOPT_IPV6

Enable IPV6. Available if compiled against ZeroMQ 4.0 or higher (Value: string)

ZMQ::CTXOPT_MAX_SOCKETS

The socket limit for this context. Available if compiled against ZeroMQ 3.x or higher (Value: integer)

ZMQ::POLL_IN

Poll for incoming data

ZMQ::POLL_OUT

Poll for outgoing data

ZMQ::MODE_NOBLOCK

Non-blocking operation. Deprecated, use ZMQ::MODE_DONTWAIT instead

ZMQ::MODE_DONTWAIT

Non-blocking operation

ZMQ::MODE_SNDMORE

Send multi-part message

ZMQ::DEVICE_FORWARDER

Forwarder device

ZMQ::DEVICE_QUEUE

Queue device

ZMQ::DEVICE_STREAMER

Streamer device

ZMQ::ERR_INTERNAL

ZMQ extension internal error

ZMQ::ERR_EAGAIN

Implies that the operation would block when ZMQ::MODE_DONTWAIT is used

ZMQ::ERR_ENOTSUP

The operation is not supported by the socket type

ZMQ::ERR_EFSM

The operation can not be executed because the socket is not in correct state

ZMQ::ERR_ETERM

The context has been terminated

İçindekiler

  • ZMQ::__construct — ZMQ constructor
Gereksinimler
ZMQ::__construct
0MQ messaging


ZMQ constructor

ZMQ
ZMQContext
ZMQ
PHP Manual

ZMQ::__construct

(PECL zmq >= 0.5.0)

ZMQ::__construct — ZMQ constructor

Açıklama

privateZMQ::__construct ( void )

Private constructor to prevent direct initialization. This class holds the constants for ZMQ extension.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

ZMQ
ZMQContext
ZMQ


The ZMQContext class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

Sınıf Sözdizimi

ZMQContext {
/* Methods */
__construct ([ integer $io_threads = 1 [, boolean $is_persistent = true ]] )
public mixed getOpt ( string $key )
public ZMQSocket getSocket ( integer $type [, string $persistent_id = null [, callback $on_new_socket = null ]] )
public boolean isPersistent ( void )
public ZMQContext setOpt ( integer $key , mixed $value )
}

İçindekiler

  • ZMQContext::__construct — Construct a new ZMQContext object
  • ZMQContext::getOpt — Get context option
  • ZMQContext::getSocket — Create a new socket
  • ZMQContext::isPersistent — Whether the context is persistent
  • ZMQContext::setOpt — Set a socket option
ZMQ::__construct
ZMQContext::__construct
0MQ messaging


Construct a new ZMQContext object

ZMQContext
ZMQContext::getOpt
ZMQContext
PHP Manual

ZMQContext::__construct

(PECL zmq >= 0.5.0)

ZMQContext::__construct — Construct a new ZMQContext object

Açıklama

ZMQContext::__construct ([ integer $io_threads = 1 [, boolean $is_persistent = true ]] )

Constructs a new ZMQ context. The context is used to initialize sockets. A persistent context is required to initialize persistent sockets.

Değiştirgeler

io_threads

Number of io-threads in the context.

is_persistent

Whether the context is persistent. Persistent context is stored over multiple requests and is a requirement for persistent sockets.

Örnekler

Örnek 1 A ZMQContext() example

Construct a new context and allocate request socket from it

<?php
/* Allocate a new context */
$context = new ZMQContext();

/* Create a new socket */
$socket = $context->getSocket(ZMQ::SOCKET_REQ, 'my sock');

/* Connect the socket */
$socket->connect("tcp://example.com:1234");

/* Send a request */
$socket->send("Hello there");

/* Receive back the response */
$message = $socket->recv();
?>

Dönen Değerler

Throws ZMQContextException if context initialization fails.

ZMQContext
ZMQContext::getOpt
ZMQContext


Get context option

ZMQContext::__construct
ZMQContext::getSocket
ZMQContext
PHP Manual

ZMQContext::getOpt

(PECL zmq >= 1.0.4)

ZMQContext::getOpt — Get context option

Açıklama

public mixed ZMQContext::getOpt ( string $key )

Returns the value of a context option.

Değiştirgeler

key

An integer representing the option. See the ZMQ::CTXOPT_* constants.

Dönen Değerler

Returns either a string or an integer depending on key. Throws ZMQContextException on error.

ZMQContext::__construct
ZMQContext::getSocket
ZMQContext


Create a new socket

ZMQContext::getOpt
ZMQContext::isPersistent
ZMQContext
PHP Manual

ZMQContext::getSocket

(PECL zmq >= 0.5.0)

ZMQContext::getSocket — Create a new socket

Açıklama

public ZMQSocket ZMQContext::getSocket ( integer $type [, string $persistent_id = null [, callback $on_new_socket = null ]] )

Shortcut for creating new sockets from the context. If the context is not persistent the persistent_id parameter is ignored and the socket falls back to being non-persistent. The on_new_socket is called only when a new underlying socket structure is created.

Değiştirgeler

type

ZMQ::SOCKET_* constant to specify socket type.

persistent_id

If persistent_id is specified the socket will be persisted over multiple requests.

on_new_socket

Callback function, which is executed when a new socket structure is created. This function does not get invoked if the underlying persistent connection is re-used. The callback takes ZMQSocket and persistent_id as two arguments.

Örnekler

Örnek 1 A ZMQContext() example

Basic usage

<?php
/* Allocate a new context */
$context = new ZMQContext();

/* Create a new socket */
$socket = $context->getSocket(ZMQ::SOCKET_REQ, 'my sock');

/* Connect the socket */
$socket->connect("tcp://example.com:1234");

/* Send a request */
$socket->send("Hello there");

/* Receive back the response */
$message = $socket->recv();
echo "Received message: {$message}\n";
?>

Dönen Değerler

Returns a ZMQSocket object on success. Throws ZMQSocketException on error.

ZMQContext::getOpt
ZMQContext::isPersistent
ZMQContext


Whether the context is persistent

ZMQContext::getSocket
ZMQContext::setOpt
ZMQContext
PHP Manual

ZMQContext::isPersistent

(PECL zmq >= 0.5.0)

ZMQContext::isPersistent — Whether the context is persistent

Açıklama

public boolean ZMQContext::isPersistent ( void )

Whether the context is persistent. Persistent context is needed for persistent connections as each socket is allocated from a context.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the context is persistent and FALSE if the context is non-persistent.

ZMQContext::getSocket
ZMQContext::setOpt
ZMQContext


Set a socket option

ZMQContext::isPersistent
ZMQSocket
ZMQContext
PHP Manual

ZMQContext::setOpt

(PECL zmq >= 1.0.4)

ZMQContext::setOpt — Set a socket option

Açıklama

public ZMQContext ZMQContext::setOpt ( integer $key , mixed $value )

Sets a ZMQ context option. The type of the value depends on the key. See ZMQ Constant Types for more information.

Değiştirgeler

key

One of the ZMQ::CTXOPT_* constants.

value

The value of the parameter.

Dönen Değerler

Returns the current object. Throws ZMQContextException on error.

ZMQContext::isPersistent
ZMQSocket
ZMQContext


The ZMQSocket class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

Sınıf Sözdizimi

ZMQSocket {
/* Methods */
public ZMQSocket bind ( string $dsn [, boolean $force = false ] )
public ZMQSocket connect ( string $dsn [, boolean $force = false ] )
__construct ( ZMQContext $context , int $type [, string $persistent_id = null [, callback $on_new_socket = null ]] )
public ZMQSocket disconnect ( string $dsn )
public array getEndpoints ( void )
public string getPersistentId ( void )
public integer getSocketType ( void )
public mixed getSockOpt ( string $key )
public boolean isPersistent ( void )
public string recv ([ integer $mode = 0 ] )
public string recvMulti ([ integer $mode = 0 ] )
public ZMQSocket send ( string $message [, integer $mode = 0 ] )
public ZMQSocket send ( array $message [, integer $mode = 0 ] )
public ZMQSocket setSockOpt ( integer $key , mixed $value )
public ZMQSocket unbind ( string $dsn )
}

İçindekiler

  • ZMQSocket::bind — Bind the socket
  • ZMQSocket::connect — Connect the socket
  • ZMQSocket::__construct — Construct a new ZMQSocket
  • ZMQSocket::disconnect — Disconnect a socket
  • ZMQSocket::getEndpoints — Get list of endpoints
  • ZMQSocket::getPersistentId — Get the persistent id
  • ZMQSocket::getSocketType — Get the socket type
  • ZMQSocket::getSockOpt — Get socket option
  • ZMQSocket::isPersistent — Whether the socket is persistent
  • ZMQSocket::recv — Receives a message
  • ZMQSocket::recvMulti — Receives a multipart message
  • ZMQSocket::send — Sends a message
  • ZMQSocket::sendmulti — Sends a multipart message
  • ZMQSocket::setSockOpt — Set a socket option
  • ZMQSocket::unbind — Unbind the socket
ZMQContext::setOpt
ZMQSocket::bind
0MQ messaging


Bind the socket

ZMQSocket
ZMQSocket::connect
ZMQSocket
PHP Manual

ZMQSocket::bind

(PECL zmq >= 0.5.0)

ZMQSocket::bind — Bind the socket

Açıklama

public ZMQSocket ZMQSocket::bind ( string $dsn [, boolean $force = false ] )

Bind the socket to an endpoint. The endpoint is defined in format transport://address where transport is one of the following: inproc, ipc, tcp, pgm or epgm.

Değiştirgeler

dsn

The bind dsn, for example transport://address.

force

Tries to bind even if the socket has already been bound to the given endpoint.

Dönen Değerler

Returns the current object. Throws ZMQSocketException on error.

ZMQSocket
ZMQSocket::connect
ZMQSocket


Connect the socket

ZMQSocket::bind
ZMQSocket::__construct
ZMQSocket
PHP Manual

ZMQSocket::connect

(PECL zmq >= 0.5.0)

ZMQSocket::connect — Connect the socket

Açıklama

public ZMQSocket ZMQSocket::connect ( string $dsn [, boolean $force = false ] )

Connect the socket to a remote endpoint. The endpoint is defined in format transport://address where transport is one of the following: inproc, ipc, tcp, pgm or epgm.

Değiştirgeler

dsn

The connect dsn, for example transport://address.

force

Tries to connect even if the socket has already been connected to given endpoint.

Örnekler

Örnek 1 A ZMQContext() example

Construct a new context and allocate request socket from it

<?php
/* Server hostname */
$dsn = "tcp://127.0.0.1:5555";

/* Create a socket */
$socket = new ZMQSocket(new ZMQContext(), ZMQ::SOCKET_REQ, 'my socket');

/* Get list of connected endpoints */
$endpoints = $socket->getEndpoints();

/* Check if the socket is connected */
if (!in_array($dsn, $endpoints['connect'])) {
    echo "<p>Connecting to $dsn</p>";
    $socket->connect($dsn);
} else {
    echo "<p>Already connected to $dsn</p>";
}

/* Send and receive */
$socket->send("Hello!");
$message = $socket->recv();

echo "<p>Server said: {$message}</p>";
?>

Dönen Değerler

Returns the current object. Throws ZMQSocketException on error.

ZMQSocket::bind
ZMQSocket::__construct
ZMQSocket


Construct a new ZMQSocket

ZMQSocket::connect
ZMQSocket::disconnect
ZMQSocket
PHP Manual

ZMQSocket::__construct

(PECL zmq >= 0.5.0)

ZMQSocket::__construct — Construct a new ZMQSocket

Açıklama

ZMQSocket::__construct ( ZMQContext $context , int $type [, string $persistent_id = null [, callback $on_new_socket = null ]] )

Constructs a ZMQSocket object. persistent_id parameter can be used to allocated a persistent socket. A persistent socket has to be allocated from a persistent context and it stays connected over multiple requests. The persistent_id parameter can be used to recall the same socket over multiple requests. The on_new_socket is called only when a new underlying socket structure is created.

Değiştirgeler

context

ZMQContext object.

type

The socket type. See ZMQ::SOCKET_* constants.

persistent_id

If persistent_id is specified the socket will be persisted over multiple requests. If context is not persistent the socket falls back to non-persistent mode.

on_new_socket

Callback function, which is executed when a new socket structure is created. This function does not get invoked if the underlying persistent connection is re-used.

Örnekler

Örnek 1 A ZMQSocket() example

Using callback the bind/connect socket

<?php

/*
  The socket is persistent so this function is called only on the
  first request to the script.
*/
function on_new_socket_cb(ZMQSocket $socket, $persistent_id = null)
{
    if ($persistent_id === 'server') {
        $socket->bind("tcp://localhost:12122");
    } else {
        $socket->connect("tcp://localhost:12122");
    }
}

/* Allocate a new context */
$context = new ZMQContext();

/* Create a new socket */
$socket = $context->getSocket(ZMQ::SOCKET_REP, 'server', 'on_new_socket_cb');

$message = $socket->recv();
echo "Received message: {$message}\n";
?>

The callback signature

Bilginize:

function on_new_socket_cb(ZMQSocket $socket, string $persistent_id = null);

Dönen Değerler

Throws ZMQSocketException on error.

ZMQSocket::connect
ZMQSocket::disconnect
ZMQSocket


Disconnect a socket

ZMQSocket::__construct
ZMQSocket::getEndpoints
ZMQSocket
PHP Manual

ZMQSocket::disconnect

(PECL zmq >= 1.0.4)

ZMQSocket::disconnect — Disconnect a socket

Açıklama

public ZMQSocket ZMQSocket::disconnect ( string $dsn )

Disconnect the socket from a previously connected remote endpoint. The endpoint is defined in format transport://address where transport is one of the following: inproc, ipc, tcp, pgm or epgm.

Değiştirgeler

dsn

The connect dsn, for example transport://address.

Dönen Değerler

Returns the current object. Throws ZMQSocketException on error.

ZMQSocket::__construct
ZMQSocket::getEndpoints
ZMQSocket


Get list of endpoints

ZMQSocket::disconnect
ZMQSocket::getPersistentId
ZMQSocket
PHP Manual

ZMQSocket::getEndpoints

(PECL zmq >= 0.5.0)

ZMQSocket::getEndpoints — Get list of endpoints

Açıklama

public array ZMQSocket::getEndpoints ( void )

Returns a list of endpoints where the socket is connected or bound to.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array containing elements 'bind' and 'connect'.

ZMQSocket::disconnect
ZMQSocket::getPersistentId
ZMQSocket


Get the persistent id

ZMQSocket::getEndpoints
ZMQSocket::getSocketType
ZMQSocket
PHP Manual

ZMQSocket::getPersistentId

(PECL zmq >= 0.5.0)

ZMQSocket::getPersistentId — Get the persistent id

Açıklama

public string ZMQSocket::getPersistentId ( void )

Returns the persistent id of the socket.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the persistent id string assigned of the object and NULL if socket is not persistent.

ZMQSocket::getEndpoints
ZMQSocket::getSocketType
ZMQSocket


Get the socket type

ZMQSocket::getPersistentId
ZMQSocket::getSockOpt
ZMQSocket
PHP Manual

ZMQSocket::getSocketType

(PECL zmq >= 0.5.0)

ZMQSocket::getSocketType — Get the socket type

Açıklama

public integer ZMQSocket::getSocketType ( void )

Gets the socket type.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an integer representing the socket type. The integer can be compared against ZMQ::SOCKET_* constants.

ZMQSocket::getPersistentId
ZMQSocket::getSockOpt
ZMQSocket


Get socket option

ZMQSocket::getSocketType
ZMQSocket::isPersistent
ZMQSocket
PHP Manual

ZMQSocket::getSockOpt

(PECL zmq >= 0.5.0)

ZMQSocket::getSockOpt — Get socket option

Açıklama

public mixed ZMQSocket::getSockOpt ( string $key )

Returns the value of a socket option.

Değiştirgeler

key

An integer representing the option. See the ZMQ::SOCKOPT_* constants.

Dönen Değerler

Returns either a string or an integer depending on key. Throws ZMQSocketException on error.

ZMQSocket::getSocketType
ZMQSocket::isPersistent
ZMQSocket


Whether the socket is persistent

ZMQSocket::getSockOpt
ZMQSocket::recv
ZMQSocket
PHP Manual

ZMQSocket::isPersistent

(PECL zmq >= 0.5.0)

ZMQSocket::isPersistent — Whether the socket is persistent

Açıklama

public boolean ZMQSocket::isPersistent ( void )

Check whether the socket is persistent.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a boolean based on whether the socket is persistent or not.

ZMQSocket::getSockOpt
ZMQSocket::recv
ZMQSocket


Receives a message

ZMQSocket::isPersistent
ZMQSocket::recvMulti
ZMQSocket
PHP Manual

ZMQSocket::recv

(PECL zmq >= 0.5.0)

ZMQSocket::recv — Receives a message

Açıklama

public string ZMQSocket::recv ([ integer $mode = 0 ] )

Receive a message from a socket. By default receiving will block until a message is available unless ZMQ::MODE_NOBLOCK flag is used. ZMQ::SOCKOPT_RCVMORE socket option can be used for receiving multi-part messages. See ZMQSocket::setSockOpt() for more information.

Değiştirgeler

mode

Pass mode flags to receive multipart messages or non-blocking operation. See ZMQ::MODE_* constants.

Örnekler

Örnek 1 A send/recv example

Non-blocking send / receive

<?php

/* Create new queue object, there needs to be a server at the other end */
$queue = new ZMQSocket(new ZMQContext(), ZMQ::SOCKET_REQ);
$queue->connect("tcp://127.0.0.1:5555");

/* Assign socket 1 to the queue, send and receive */
$retries = 5;
$sending = true;

/* Start a loop */
do {
    try {
        /* Try to send / receive */
        if ($sending) {
            echo "Sending message\n";
            $queue->send("This is a message", ZMQ::MODE_NOBLOCK);
            $sending = false;
        } else {
            echo "Got response: " . $queue->recv(ZMQ::MODE_NOBLOCK) . "\n";
            break;
        }
    } catch (ZMQSocketException $e) {
        /* EAGAIN means that the operation would have blocked, retry */
        if ($e->getCode() === ZMQ::ERR_EAGAIN) {
            echo " - Got EAGAIN, retrying ($retries)\n";
        } else {
            die(" - Error: " . $e->getMessage());
        }
    }
    /* Sleep a bit between operations */
    usleep(5);
} while (--$retries);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Sending message
 - Unable to execute operation, retrying (4)
Got response: This is a message

Dönen Değerler

Returns the message. Throws ZMQSocketException in error. If ZMQ::MODE_NOBLOCK is used and the operation would block boolean false shall be returned.

ZMQSocket::isPersistent
ZMQSocket::recvMulti
ZMQSocket


Receives a multipart message

ZMQSocket::recv
ZMQSocket::send
ZMQSocket
PHP Manual

ZMQSocket::recvMulti

(PECL zmq >= 0.8.0)

ZMQSocket::recvMulti — Receives a multipart message

Açıklama

public string ZMQSocket::recvMulti ([ integer $mode = 0 ] )

Receive an array multipart message from a socket. By default receiving will block until a message is available unless ZMQ::MODE_NOBLOCK flag is used.

Değiştirgeler

mode

Pass mode flags to receive multipart messages or non-blocking operation. See ZMQ::MODE_* constants.

Dönen Değerler

Returns the array of message parts. Throws ZMQSocketException in error. If ZMQ::MODE_NOBLOCK is used and the operation would block boolean false shall be returned.

ZMQSocket::recv
ZMQSocket::send
ZMQSocket


Sends a message

ZMQSocket::recvMulti
ZMQSocket::sendmulti
ZMQSocket
PHP Manual

ZMQSocket::send

(PECL zmq >= 0.5.0)

ZMQSocket::send — Sends a message

Açıklama

public ZMQSocket ZMQSocket::send ( string $message [, integer $mode = 0 ] )

Send a message using the socket. The operation can block unless ZMQ::MODE_NOBLOCK is used.

Değiştirgeler

message

The message to send.

mode

Pass mode flags to receive multipart messages or non-blocking operation. See ZMQ::MODE_* constants.

Dönen Değerler

Returns the current object. Throws ZMQSocketException on error. If ZMQ::MODE_NOBLOCK is used and the operation would block boolean false shall be returned.

ZMQSocket::recvMulti
ZMQSocket::sendmulti
ZMQSocket


Sends a multipart message

ZMQSocket::send
ZMQSocket::setSockOpt
ZMQSocket
PHP Manual

ZMQSocket::sendmulti

(PECL zmq >= 0.8.0)

ZMQSocket::sendmulti — Sends a multipart message

Açıklama

public ZMQSocket ZMQSocket::send ( array $message [, integer $mode = 0 ] )

Send a multipart message using the socket. The operation can block unless ZMQ::MODE_NOBLOCK is used.

Değiştirgeler

message

The message to send - an array of strings

mode

Pass mode flags to receive multipart messages or non-blocking operation. See ZMQ::MODE_* constants.

Dönen Değerler

Returns the current object. Throws ZMQSocketException on error. If ZMQ::MODE_NOBLOCK is used and the operation would block boolean false shall be returned.

ZMQSocket::send
ZMQSocket::setSockOpt
ZMQSocket


Set a socket option

ZMQSocket::sendmulti
ZMQSocket::unbind
ZMQSocket
PHP Manual

ZMQSocket::setSockOpt

(PECL zmq >= 0.5.0)

ZMQSocket::setSockOpt — Set a socket option

Açıklama

public ZMQSocket ZMQSocket::setSockOpt ( integer $key , mixed $value )

Sets a ZMQ socket option. The type of the value depends on the key. See ZMQ Constant Types for more information.

Değiştirgeler

key

One of the ZMQ::SOCKOPT_* constants.

value

The value of the parameter.

Dönen Değerler

Returns the current object. Throws ZMQSocketException on error.

ZMQSocket::sendmulti
ZMQSocket::unbind
ZMQSocket


Unbind the socket

ZMQSocket::setSockOpt
ZMQPoll
ZMQSocket
PHP Manual

ZMQSocket::unbind

(PECL zmq >= 1.0.4)

ZMQSocket::unbind — Unbind the socket

Açıklama

public ZMQSocket ZMQSocket::unbind ( string $dsn )

Unbind the socket from an endpoint. The endpoint is defined in format transport://address where transport is one of the following: inproc, ipc, tcp, pgm or epgm.

Değiştirgeler

dsn

The previously bound dsn, for example transport://address.

Dönen Değerler

Returns the current object. Throws ZMQSocketException on error.

ZMQSocket::setSockOpt
ZMQPoll
ZMQSocket


The ZMQPoll class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

Sınıf Sözdizimi

ZMQPoll {
/* Methods */
public string add ( mixed $entry , integer $type )
public ZMQPoll clear ( void )
public integer count ( void )
public array getLastErrors ( void )
public integer poll ( array &$readable , array &$writable [, integer $timeout = -1 ] )
public boolean remove ( mixed $item )
}

İçindekiler

  • ZMQPoll::add — Add item to the poll set
  • ZMQPoll::clear — Clear the poll set
  • ZMQPoll::count — Count items in the poll set
  • ZMQPoll::getLastErrors — Get poll errors
  • ZMQPoll::poll — Poll the items
  • ZMQPoll::remove — Remove item from poll set
ZMQSocket::unbind
ZMQPoll::add
0MQ messaging


Add item to the poll set

ZMQPoll
ZMQPoll::clear
ZMQPoll
PHP Manual

ZMQPoll::add

(PECL zmq >= 0.5.0)

ZMQPoll::add — Add item to the poll set

Açıklama

public string ZMQPoll::add ( mixed $entry , integer $type )

Adds a new item to the poll set and returns the internal id of the added item. The item can be removed from the poll set using the returned string id.

Değiştirgeler

entry

ZMQSocket object or a PHP stream resource

type

Defines what activity the socket is polled for. See ZMQ::POLL_IN and ZMQ::POLL_OUT constants.

Dönen Değerler

Returns a string id of the added item which can be later used to remove the item. Throws ZMQPollException on error.

ZMQPoll
ZMQPoll::clear
ZMQPoll


Clear the poll set

ZMQPoll::add
ZMQPoll::count
ZMQPoll
PHP Manual

ZMQPoll::clear

(PECL zmq >= 0.5.0)

ZMQPoll::clear — Clear the poll set

Açıklama

public ZMQPoll ZMQPoll::clear ( void )

Clears all elements from the poll set.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the current object.

ZMQPoll::add
ZMQPoll::count
ZMQPoll


Count items in the poll set

ZMQPoll::clear
ZMQPoll::getLastErrors
ZMQPoll
PHP Manual

ZMQPoll::count

(PECL zmq >= 0.5.0)

ZMQPoll::count — Count items in the poll set

Açıklama

public integer ZMQPoll::count ( void )

Count the items in the poll set.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an integer representing the amount of items in the poll set.

ZMQPoll::clear
ZMQPoll::getLastErrors
ZMQPoll


Get poll errors

ZMQPoll::count
ZMQPoll::poll
ZMQPoll
PHP Manual

ZMQPoll::getLastErrors

(PECL zmq >= 0.5.0)

ZMQPoll::getLastErrors — Get poll errors

Açıklama

public array ZMQPoll::getLastErrors ( void )

Returns the ids of the objects that had errors in the last poll.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array containing ids for the items that had errors in the last poll. Empty array is returned if there were no errors.

ZMQPoll::count
ZMQPoll::poll
ZMQPoll


Poll the items

ZMQPoll::getLastErrors
ZMQPoll::remove
ZMQPoll
PHP Manual

ZMQPoll::poll

(PECL zmq >= 0.5.0)

ZMQPoll::poll — Poll the items

Açıklama

public integer ZMQPoll::poll ( array &$readable , array &$writable [, integer $timeout = -1 ] )

Polls the items in the current poll set. The readable and writable items are returned in the readable and writable parameters. ZMQPoll::getLastErrors() can be used to check if there were errors.

Değiştirgeler

readable

Array where readable ZMQSockets/PHP streams are returned. The array will be cleared at the beginning of the operation.

writable

Array where writable ZMQSockets/PHP streams are returned. The array will be cleared at the beginning of the operation.

timeout

Timeout for the operation. -1 means that poll waits until at least one item has activity. Please note that starting from version 1.0.0 the poll timeout is defined in milliseconds, rather than microseconds.

Örnekler

Örnek 1 A ZMQPoll() example

Create a simple poll server

<?php

/* Create socket, request-reply pattern (reply socket) */
$context = new ZMQContext();
$server  = $context->getSocket(ZMQ::SOCKET_REP);

/* Bind to port 5555 on 127.0.0.1 */
$server->bind("tcp://127.0.0.1:5555");

/* Create new pollset for incoming/outgoing message */
$poll = new ZMQPoll();

/* Add the object and listen for poll in/out */
$id = $poll->add($server, ZMQ::POLL_IN | ZMQ::POLL_OUT);
echo "Added object with id " . $id . "\n";

/* Initialise readable and writable arrays */
$readable = array();
$writable = array();

while (true) {
   /* Amount of events retrieved */
   $events = 0;

   try {
       /* Poll until there is something to do */
       $events = $poll->poll($readable, $writable, -1);
       $errors = $poll->getLastErrors();

       if (count($errors) > 0) {
           foreach ($errors as $error) {
               echo "Error polling object " . $error . "\n";
           }
       }
   } catch (ZMQPollException $e) {
       echo "poll failed: " . $e->getMessage() . "\n";
   }

   if ($events > 0) {
       /* Loop through readable objects and recv messages */
       foreach ($readable as $r) {
           try {
               echo "Received message: " . $r->recv() . "\n";
           } catch (ZMQException $e) {
               echo "recv failed: " . $e->getMessage() . "\n";
           }
       }

       /* Loop through writable and send back messages */
       foreach ($writable as $w) {
           try {
               $w->send("Got it!");
           } catch (ZMQException $e) {
               echo "send failed: " . $e->getMessage() . "\n";
           }
       }
   }
}
?>

Dönen Değerler

Returns an integer representing amount of items with activity. Throws ZMQPollException on error.

ZMQPoll::getLastErrors
ZMQPoll::remove
ZMQPoll


Remove item from poll set

ZMQPoll::poll
ZMQDevice
ZMQPoll
PHP Manual

ZMQPoll::remove

(PECL zmq >= 0.5.0)

ZMQPoll::remove — Remove item from poll set

Açıklama

public boolean ZMQPoll::remove ( mixed $item )

Remove item from the poll set. The item parameter can be ZMQSocket object, a stream resource or the id returned from ZMQPoll::add() method.

Değiştirgeler

item

The ZMQSocket object, PHP stream or string id of the item.

Dönen Değerler

Returns true if the item was removed and false if the object with given id does not exist in the poll set.

ZMQPoll::poll
ZMQDevice
ZMQPoll


The ZMQDevice class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

Sınıf Sözdizimi

ZMQDevice {
/* Methods */
__construct ( ZMQSocket $frontend , ZMQSocket $backend [, ZMQSocket $listener ] )
public ZMQDevice getIdleTimeout ( void )
public ZMQDevice getTimerTimeout ( void )
public void run ( void )
public ZMQDevice setIdleCallback ( callable $cb_func , integer $timeout [, mixed $user_data ] )
public ZMQDevice setIdleTimeout ( integer $timeout )
public ZMQDevice setTimerCallback ( callable $cb_func , integer $timeout [, mixed $user_data ] )
public ZMQDevice setTimerTimeout ( integer $timeout )
}

İçindekiler

  • ZMQDevice::__construct — Construct a new device
  • ZMQDevice::getIdleTimeout — Get the idle timeout
  • ZMQDevice::getTimerTimeout — Get the timer timeout
  • ZMQDevice::run — Run the new device
  • ZMQDevice::setIdleCallback — Set the idle callback function
  • ZMQDevice::setIdleTimeout — Set the idle timeout
  • ZMQDevice::setTimerCallback — Set the timer callback function
  • ZMQDevice::setTimerTimeout — Set the timer timeout
ZMQPoll::remove
ZMQDevice::__construct
0MQ messaging


Construct a new device

ZMQDevice
ZMQDevice::getIdleTimeout
ZMQDevice
PHP Manual

ZMQDevice::__construct

(PECL zmq >= 0.5.0)

ZMQDevice::__construct — Construct a new device

Açıklama

ZMQDevice::__construct ( ZMQSocket $frontend , ZMQSocket $backend [, ZMQSocket $listener ] )

"ØMQ devices can do intermediation of addresses, services, queues, or any other abstraction you care to define above the message and socket layers." -- zguide

Değiştirgeler

frontend

Frontend parameter for the devices. Usually where there messages are coming.

backend

Backend parameter for the devices. Usually where there messages going to.

listener

Listener socket, which receives a copy of all messages going both directions. The type of this socket should be SUB, PULL or DEALER.

Dönen Değerler

Call to this method will prepare the device. Usually devices are very long running processes so running this method from interactive script is not recommended. This method throw ZMQDeviceException if the device cannot be started.

ZMQDevice
ZMQDevice::getIdleTimeout
ZMQDevice


Get the idle timeout

ZMQDevice::__construct
ZMQDevice::getTimerTimeout
ZMQDevice
PHP Manual

ZMQDevice::getIdleTimeout

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

ZMQDevice::getIdleTimeout — Get the idle timeout

Açıklama

public ZMQDevice ZMQDevice::getIdleTimeout ( void )

Gets the idle callback timeout value. Added in ZMQ extension version 1.1.0.

Dönen Değerler

This method returns the idle callback timeout value.

ZMQDevice::__construct
ZMQDevice::getTimerTimeout
ZMQDevice


Get the timer timeout

ZMQDevice::getIdleTimeout
ZMQDevice::run
ZMQDevice
PHP Manual

ZMQDevice::getTimerTimeout

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

ZMQDevice::getTimerTimeout — Get the timer timeout

Açıklama

public ZMQDevice ZMQDevice::getTimerTimeout ( void )

Gets the timer callback timeout value. Added in ZMQ extension version 1.1.0.

Dönen Değerler

This method returns the timer timeout value.

ZMQDevice::getIdleTimeout
ZMQDevice::run
ZMQDevice


Run the new device

ZMQDevice::getTimerTimeout
ZMQDevice::setIdleCallback
ZMQDevice
PHP Manual

ZMQDevice::run

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

ZMQDevice::run — Run the new device

Açıklama

public void ZMQDevice::run ( void )

Runs the device.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Call to this method will block until the device is running. It is not recommended that devices are used from interactive scripts. On failure this method will throw ZMQDeviceException.

ZMQDevice::getTimerTimeout
ZMQDevice::setIdleCallback
ZMQDevice


Set the idle callback function

ZMQDevice::run
ZMQDevice::setIdleTimeout
ZMQDevice
PHP Manual

ZMQDevice::setIdleCallback

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

ZMQDevice::setIdleCallback — Set the idle callback function

Açıklama

public ZMQDevice ZMQDevice::setIdleCallback ( callable $cb_func , integer $timeout [, mixed $user_data ] )

Sets the idle callback function. If idle timeout is defined the idle callback function shall be called if the internal poll loop times out without events. If the callback function returns false or a value that evaluates to false the device is stopped. The callback function signature is callback (mixed $user_data).

Değiştirgeler

cb_func

Callback function to invoke when the device is idle. Returning false or a value that evaluates to false from this function will cause the device to stop.

timeout

How often to invoke the idle callback in milliseconds. The idle callback is invoked periodically when there is no activity on the device. The timeout value guarantees that there is at least this amount of milliseconds between invocations of the callback function.

user_data

Additional data to pass to the callback function.

Dönen Değerler

On success this method returns the current object.

ZMQDevice::run
ZMQDevice::setIdleTimeout
ZMQDevice


Set the idle timeout

ZMQDevice::setIdleCallback
ZMQDevice::setTimerCallback
ZMQDevice
PHP Manual

ZMQDevice::setIdleTimeout

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

ZMQDevice::setIdleTimeout — Set the idle timeout

Açıklama

public ZMQDevice ZMQDevice::setIdleTimeout ( integer $timeout )

Sets the idle callback timeout value. The idle callback is invoked periodically when the device is idle.

Değiştirgeler

timeout

The idle callback timeout value.

Dönen Değerler

On success this method returns the current object.

ZMQDevice::setIdleCallback
ZMQDevice::setTimerCallback
ZMQDevice


Set the timer callback function

ZMQDevice::setIdleTimeout
ZMQDevice::setTimerTimeout
ZMQDevice
PHP Manual

ZMQDevice::setTimerCallback

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

ZMQDevice::setTimerCallback — Set the timer callback function

Açıklama

public ZMQDevice ZMQDevice::setTimerCallback ( callable $cb_func , integer $timeout [, mixed $user_data ] )

Sets the timer callback function. The timer callback will be invoked after timeout has passed. The difference between idle and timer callbacks are that idle callback is invoked only when the device is idle. The callback function signature is callback (mixed $user_data). Added in ZMQ extension version 1.1.0.

Değiştirgeler

cb_func

Callback function to invoke when the device is idle. Returning false or a value that evaluates to false from this function will cause the device to stop.

timeout

How often to invoke the idle callback in milliseconds. The idle callback is invoked periodically when there is no activity on the device. The timeout value guarantees that there is at least this amount of milliseconds between invocations of the callback function.

user_data

Additional data to pass to the callback function.

Dönen Değerler

On success this method returns the current object.

ZMQDevice::setIdleTimeout
ZMQDevice::setTimerTimeout
ZMQDevice


Set the timer timeout

ZMQDevice::setTimerCallback
ZooKeeper
ZMQDevice
PHP Manual

ZMQDevice::setTimerTimeout

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

ZMQDevice::setTimerTimeout — Set the timer timeout

Açıklama

public ZMQDevice ZMQDevice::setTimerTimeout ( integer $timeout )

Sets the timer callback timeout value. The timer callback is invoked periodically if it's set. Added in ZMQ extension version 1.1.0.

Değiştirgeler

timeout

The timer callback timeout value.

Dönen Değerler

On success this method returns the current object.

ZMQDevice::setTimerCallback
ZooKeeper
ZMQDevice


ZooKeeper

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • ZooKeeper — The ZooKeeper class
    • Zookeeper::addAuth — Specify application credentials.
    • Zookeeper::connect — Create a handle to used communicate with zookeeper.
    • Zookeeper::__construct — Create a handle to used communicate with zookeeper.
    • Zookeeper::create — Create a node synchronously.
    • Zookeeper::delete — Delete a node in zookeeper synchronously.
    • Zookeeper::exists — Checks the existence of a node in zookeeper synchronously.
    • Zookeeper::get — Gets the data associated with a node synchronously.
    • Zookeeper::getAcl — Gets the acl associated with a node synchronously.
    • Zookeeper::getClientId — return the client session id, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE)
    • Zookeeper::getRecvTimeout — Return the timeout for this session, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE). This value may change after a server re-connect.
    • Zookeeper::getState — Get the state of the zookeeper connection.
    • Zookeeper::isRecoverable — Checks if the current zookeeper connection state can be recovered.
    • Zookeeper::set — Sets the data associated with a node.
    • Zookeeper::setAcl — Sets the acl associated with a node synchronously.
    • Zookeeper::setDebugLevel — Sets the debugging level for the library.
    • Zookeeper::setDeterministicConnOrder — Enable/disable quorum endpoint order randomization.
    • Zookeeper::setLogStream — Sets the stream to be used by the library for logging.
    • Zookeeper::setWatcher — Set a watcher function.
ZMQDevice::setTimerTimeout
Giriş
Diğer Hizmetler


Giriş

This extension uses libzookeeper library to provide API for communicating with ZooKeeper service.

ZooKeeper is an Apache project that enables centralized service for maintaining configuration information, naming, providing distributed synchronization, and providing group services.

ZooKeeper
Yapılandırma/Kurulum
ZooKeeper


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
ZooKeeper


Gereksinimler

This extension requires » ZooKeeper C Binding (version 3.4.1 or greater). For more information, see » ZooKeeper Programmer's Guide.

This extension requires PHP version 5.2.0 or higher.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu » PECL eklentisi PHP ile gelmez.

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/zookeeper.

To enable zookeeper support, configure with --with-libzookeeper-dir=DIR . DIR is the install prefix of ZooKeeper C Binding, which must contain the include/zookeeper/zookeeper.h

Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Zookeeper Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Changelog
zookeeper.recv_timeout | 10000 | PHP_INI_ALL |
zookeeper.session_lock | 1 | PHP_INI_SYSTEM |
zookeeper.sess_lock_wait | 150000 | PHP_INI_ALL |
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

zookeeper.recv_timeout integer

Default the timeout for any ZooKeeper session.

zookeeper.session_lock integer

Enable PHP session locking.

zookeeper.sess_lock_wait integer

PHP Session spin lock retry wait time in microseconds. Be carefull when setting this value. Valid values are integers, where 0 is interpreted as the default value. Negative values result in a reduces locking to a try lock.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
ZooKeeper
ZooKeeper


Öntanımlı Sabitler
Zookeeper::addAuth
ZooKeeper
PHP Manual

The ZooKeeper class

(PECL zookeeper >= 0.1.0)

Giriş

Represents ZooKeeper session.

Sınıf Sözdizimi

Zookeeper {
/* Yöntemler */
public __construct ([ string $host = '' [, callable $watcher_cb = null [, int $recv_timeout = 10000 ]]] )
public bool addAuth ( string $scheme , string $cert [, callable $completion_cb = null ] )
public void connect ( string $host [, callable $watcher_cb = null [, int $recv_timeout = 10000 ]] )
public string create ( string $path , string $value , array $acls [, int $flags = null ] )
public bool delete ( string $path [, int $version = -1 ] )
public bool exists ( string $path [, callable $watcher_cb = null ] )
public string get ( string $path [, callable $watcher_cb = null [, array &$stat = null [, int $max_size = 0 ]]] )
public array getAcl ( string $path )
public int getClientId ( void )
public int getRecvTimeout ( void )
public int getState ( void )
public bool isRecoverable ( void )
public bool set ( string $path , string $value [, int $version = -1 [, array &$stat = null ]] )
public bool setAcl ( string $path , int $version , array $acl )
public static bool setDebugLevel ( int $logLevel )
public static bool setDeterministicConnOrder ( bool $yesOrNo )
public bool setLogStream ( resource $stream )
public bool setWatcher ( callable $watcher_cb )
/* Sabitler */
const integer PERM_READ = 1 ;
const integer PERM_WRITE = 2 ;
const integer PERM_CREATE = 4 ;
const integer PERM_DELETE = 8 ;
const integer PERM_ADMIN = 16 ;
const integer PERM_ALL = 31 ;
const integer LOG_LEVEL_ERROR = 1 ;
const integer LOG_LEVEL_WARN = 2 ;
const integer LOG_LEVEL_INFO = 3 ;
const integer LOG_LEVEL_DEBUG = 4 ;
const integer EXPIRED_SESSION_STATE = -112 ;
const integer AUTH_FAILED_STATE = -113 ;
const integer CONNECTING_STATE = 1 ;
const integer ASSOCIATING_STATE = 2 ;
const integer CONNECTED_STATE = 3 ;
const integer READONLY_STATE = 5 ;
const integer NOTCONNECTED_STATE = 999 ;
}

Öntanımlı Sabitler

ZooKeeper Permissions

Zookeeper::PERM_READ

Can read nodes value and list its children

Zookeeper::PERM_WRITE

Can set the nodes value

Zookeeper::PERM_CREATE

Can create children

Zookeeper::PERM_DELETE

Can delete children

Zookeeper::PERM_ADMIN

Can execute set_acl()

Zookeeper::PERM_ALL

All of the above flags ORd together

ZooKeeper Log Levels

Zookeeper::LOG_LEVEL_ERROR

Outputs only error mesages

Zookeeper::LOG_LEVEL_WARN

Outputs errors/warnings

Zookeeper::LOG_LEVEL_INFO

Outputs big action messages besides errors/warnings

Zookeeper::LOG_LEVEL_DEBUG

Outputs all

ZooKeeper States

Zookeeper::EXPIRED_SESSION_STATE

Connected but session expired

Zookeeper::AUTH_FAILED_STATE

Connected but auth failed

Zookeeper::CONNECTING_STATE

Connecting

Zookeeper::ASSOCIATING_STATE

Associating

Zookeeper::CONNECTED_STATE

Connected

Zookeeper::READONLY_STATE

TODO: help us improve this extension.

Zookeeper::NOTCONNECTED_STATE

Connection failed

İçindekiler

  • Zookeeper::addAuth — Specify application credentials.
  • Zookeeper::connect — Create a handle to used communicate with zookeeper.
  • Zookeeper::__construct — Create a handle to used communicate with zookeeper.
  • Zookeeper::create — Create a node synchronously.
  • Zookeeper::delete — Delete a node in zookeeper synchronously.
  • Zookeeper::exists — Checks the existence of a node in zookeeper synchronously.
  • Zookeeper::get — Gets the data associated with a node synchronously.
  • Zookeeper::getAcl — Gets the acl associated with a node synchronously.
  • Zookeeper::getClientId — return the client session id, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE)
  • Zookeeper::getRecvTimeout — Return the timeout for this session, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE). This value may change after a server re-connect.
  • Zookeeper::getState — Get the state of the zookeeper connection.
  • Zookeeper::isRecoverable — Checks if the current zookeeper connection state can be recovered.
  • Zookeeper::set — Sets the data associated with a node.
  • Zookeeper::setAcl — Sets the acl associated with a node synchronously.
  • Zookeeper::setDebugLevel — Sets the debugging level for the library.
  • Zookeeper::setDeterministicConnOrder — Enable/disable quorum endpoint order randomization.
  • Zookeeper::setLogStream — Sets the stream to be used by the library for logging.
  • Zookeeper::setWatcher — Set a watcher function.
Öntanımlı Sabitler
Zookeeper::addAuth
ZooKeeper


Specify application credentials.

ZooKeeper
Zookeeper::connect
ZooKeeper
PHP Manual

Zookeeper::addAuth

(PECL zookeeper >= 0.1.0)

Zookeeper::addAuth — Specify application credentials.

Açıklama

public bool Zookeeper::addAuth ( string $scheme , string $cert [, callable $completion_cb = null ] )

The application calls this function to specify its credentials for purposes of authentication. The server will use the security provider specified by the scheme parameter to authenticate the client connection. If the authentication request has failed: - the server connection is dropped. - the watcher is called with the ZOO_AUTH_FAILED_STATE value as the state parameter.

Değiştirgeler

scheme

The id of authentication scheme. Natively supported: "digest" password-based authentication

cert

Application credentials. The actual value depends on the scheme.

completion_cb

The routine to invoke when the request completes. One of the following result codes may be passed into the completion callback: - ZOK operation completed successfully - ZAUTHFAILED authentication failed

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

This method emits PHP error/warning when parameters count or types are wrong or operation fails.

Örnekler

Örnek 1 Zookeeper::addAuth() example

Add auth before requesting node value.

<?php
$zookeeper = new Zookeeper('locahost:2181');
$path = '/path/to/node';
$value = 'nodevalue';
$zookeeper->set($path, $value);

$zookeeper->addAuth('digest', 'user0:passwd0');
$r = $zookeeper->get($path);
if ($r)
  echo $r;
else
  echo 'ERR';
?>

Yukarıdaki örneğin çıktısı:

nodevalue

Ayrıca Bakınız

  • Zookeeper::create() - Create a node synchronously.
  • Zookeeper::setAcl() - Sets the acl associated with a node synchronously.
  • Zookeeper::getAcl() - Gets the acl associated with a node synchronously.
  • ZooKeeper States
ZooKeeper
Zookeeper::connect
ZooKeeper


Create a handle to used communicate with zookeeper.

Zookeeper::addAuth
Zookeeper::__construct
ZooKeeper
PHP Manual

Zookeeper::connect

(PECL zookeeper >= 0.2.0)

Zookeeper::connect — Create a handle to used communicate with zookeeper.

Açıklama

public void Zookeeper::connect ( string $host [, callable $watcher_cb = null [, int $recv_timeout = 10000 ]] )

This method creates a new handle and a zookeeper session that corresponds to that handle. Session establishment is asynchronous, meaning that the session should not be considered established until (and unless) an event of state ZOO_CONNECTED_STATE is received.

Değiştirgeler

host

Comma separated host:port pairs, each corresponding to a zk server. e.g. "127.0.0.1:3000,127.0.0.1:3001,127.0.0.1:3002"

watcher_cb

The global watcher callback function. When notifications are triggered this function will be invoked.

recv_timeout

The timeout for this session, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE).

Hatalar/İstisnalar

This method emits PHP error/warning when parameters count or types are wrong or could not init instance.

Ayrıca Bakınız

  • Zookeeper::__construct() - Create a handle to used communicate with zookeeper.
Zookeeper::addAuth
Zookeeper::__construct
ZooKeeper


Create a handle to used communicate with zookeeper.

Zookeeper::connect
Zookeeper::create
ZooKeeper
PHP Manual

Zookeeper::__construct

(PECL zookeeper >= 0.1.0)

Zookeeper::__construct — Create a handle to used communicate with zookeeper.

Açıklama

public Zookeeper::__construct ([ string $host = '' [, callable $watcher_cb = null [, int $recv_timeout = 10000 ]]] )

This method creates a new handle and a zookeeper session that corresponds to that handle. Session establishment is asynchronous, meaning that the session should not be considered established until (and unless) an event of state ZOO_CONNECTED_STATE is received.

Değiştirgeler

host

comma separated host:port pairs, each corresponding to a zk server. e.g. "127.0.0.1:3000,127.0.0.1:3001,127.0.0.1:3002"

watcher_cb

the global watcher callback function. When notifications are triggered this function will be invoked.

recv_timeout

the timeout for this session, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE).

Hatalar/İstisnalar

This method emits PHP error/warning when parameters count or types are wrong or could not init instance.

Ayrıca Bakınız

  • Zookeeper::connect() - Create a handle to used communicate with zookeeper.
Zookeeper::connect
Zookeeper::create
ZooKeeper


Create a node synchronously.

Zookeeper::__construct
Zookeeper::delete
ZooKeeper
PHP Manual

Zookeeper::create

(PECL zookeeper >= 0.1.0)

Zookeeper::create — Create a node synchronously.

Açıklama

public string Zookeeper::create ( string $path , string $value , array $acls [, int $flags = null ] )

This method will create a node in ZooKeeper. A node can only be created if it does not already exists. The Create Flags affect the creation of nodes. If ZOO_EPHEMERAL flag is set, the node will automatically get removed if the client session goes away. If the ZOO_SEQUENCE flag is set, a unique monotonically increasing sequence number is appended to the path name.

Değiştirgeler

path

The name of the node. Expressed as a file name with slashes separating ancestors of the node.

value

The data to be stored in the node.

acls

The initial ACL of the node. The ACL must not be null or empty.

flags

this parameter can be set to 0 for normal create or an OR of the Create Flags

Dönen Değerler

Returns the path of the new node (this might be different than the supplied path because of the ZOO_SEQUENCE flag) on success, and false on failure.

Hatalar/İstisnalar

This method emits PHP error/warning when parameters count or types are wrong or fail to create node.

Örnekler

Örnek 1 Zookeeper::create() example

Create a new node.

<?php
$zookeeper = new Zookeeper('locahost:2181');
$aclArray = array(
  array(
    'perms'  => Zookeeper::PERM_ALL,
    'scheme' => 'world',
    'id'     => 'anyone',
  )
);
$path = '/path/to/newnode';
$realPath = $zookeeper->create($path, null, $aclArray);
if ($realPath)
  echo $realPath;
else
  echo 'ERR';
?>

Yukarıdaki örneğin çıktısı:

/path/to/newnode

Ayrıca Bakınız

  • Zookeeper::delete() - Delete a node in zookeeper synchronously.
  • ZooKeeper Permissions
Zookeeper::__construct
Zookeeper::delete
ZooKeeper


Delete a node in zookeeper synchronously.

Zookeeper::create
Zookeeper::exists
ZooKeeper
PHP Manual

Zookeeper::delete

(PECL zookeeper >= 0.2.0)

Zookeeper::delete — Delete a node in zookeeper synchronously.

Açıklama

public bool Zookeeper::delete ( string $path [, int $version = -1 ] )

Değiştirgeler

path

The name of the node. Expressed as a file name with slashes separating ancestors of the node.

version

The expected version of the node. The function will fail if the actual version of the node does not match the expected version. If -1 is used the version check will not take place.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

This method emits PHP error/warning when parameters count or types are wrong or fail to delete node.

Örnekler

Örnek 1 Zookeeper::delete() example

Delete a existing node.

<?php
$zookeeper = new Zookeeper('locahost:2181');
$path = '/path/to/node';
$r = $zookeeper->delete($path);
if ($r)
  echo 'SUCCESS';
else
  echo 'ERR';
?>

Yukarıdaki örneğin çıktısı:

SUCCESS

Ayrıca Bakınız

  • Zookeeper::create() - Create a node synchronously.
Zookeeper::create
Zookeeper::exists
ZooKeeper


Checks the existence of a node in zookeeper synchronously.

Zookeeper::delete
Zookeeper::get
ZooKeeper
PHP Manual

Zookeeper::exists

(PECL zookeeper >= 0.1.0)

Zookeeper::exists — Checks the existence of a node in zookeeper synchronously.

Açıklama

public bool Zookeeper::exists ( string $path [, callable $watcher_cb = null ] )

Değiştirgeler

path

The name of the node. Expressed as a file name with slashes separating ancestors of the node.

watcher_cb

if nonzero, a watch will be set at the server to notify the client if the node changes. The watch will be set even if the node does not

Dönen Değerler

Returns true/false on success, and false on failure.

Hatalar/İstisnalar

This method emits PHP error/warning when parameters count or types are wrong or fail to check the existence of a node.

Örnekler

Örnek 1 Zookeeper::exists() example

Check the existence of a node.

<?php
$zookeeper = new Zookeeper('locahost:2181');
$path = '/path/to/node';
$r = $zookeeper->exists($path);
if ($r)
  echo 'EXISTS';
else
  echo 'N/A or ERR';
?>

Yukarıdaki örneğin çıktısı:

EXISTS

Ayrıca Bakınız

  • Zookeeper::get() - Gets the data associated with a node synchronously.
Zookeeper::delete
Zookeeper::get
ZooKeeper


Gets the data associated with a node synchronously.

Zookeeper::exists
Zookeeper::getAcl
ZooKeeper
PHP Manual

Zookeeper::get

(PECL zookeeper >= 0.1.0)

Zookeeper::get — Gets the data associated with a node synchronously.

Açıklama

public string Zookeeper::get ( string $path [, callable $watcher_cb = null [, array &$stat = null [, int $max_size = 0 ]]] )

Değiştirgeler

path

The name of the node. Expressed as a file name with slashes separating ancestors of the node.

watcher_cb

If nonzero, a watch will be set at the server to notify the client if the node changes.

stat

If not NULL, will hold the value of stat for the path on return.

max_size

Max size of the data. If 0 is used, this method will return the whole data.

Dönen Değerler

Returns the data on success, and false on failure.

Hatalar/İstisnalar

This method emits PHP error/warning when parameters count or types are wrong or fail to get value from node.

Örnekler

Örnek 1 Zookeeper::get() example

Get value from node.

<?php
$zookeeper = new Zookeeper('locahost:2181');
$path = '/path/to/node';
$value = 'nodevalue';
$zookeeper->set($path, $value);

$r = $zookeeper->get($path);
if ($r)
  echo $r;
else
  echo 'ERR';
?>

Yukarıdaki örneğin çıktısı:

nodevalue

Ayrıca Bakınız

  • Zookeeper::set() - Sets the data associated with a node.
Zookeeper::exists
Zookeeper::getAcl
ZooKeeper


Gets the acl associated with a node synchronously.

Zookeeper::get
Zookeeper::getClientId
ZooKeeper
PHP Manual

Zookeeper::getAcl

(PECL zookeeper >= 0.1.0)

Zookeeper::getAcl — Gets the acl associated with a node synchronously.

Açıklama

public array Zookeeper::getAcl ( string $path )

Değiştirgeler

path

The name of the node. Expressed as a file name with slashes separating ancestors of the node.

Dönen Değerler

Return acl array on success and false on failure.

Hatalar/İstisnalar

This method emits PHP error/warning when parameters count or types are wrong or fail to get ACL of a node.

Örnekler

Örnek 1 Zookeeper::getAcl() example

Get ACL of a node.

<?php
$zookeeper = new Zookeeper('locahost:2181');
$aclArray = array(
  array(
    'perms'  => Zookeeper::PERM_ALL,
    'scheme' => 'world',
    'id'     => 'anyone',
  )
);
$path = '/path/to/newnode';
$zookeeper->setAcl($path, $aclArray);

$r = $zookeeper->getAcl($path);
if ($r)
  var_dump($r);
else
  echo 'ERR';
?>

Yukarıdaki örneğin çıktısı:

array(1) {
  [0]=>
  array(3) {
    ["perms"]=>
    int(31)
    ["scheme"]=>
    string(5) "world"
    ["id"]=>
    string(6) "anyone"
  }
}

Ayrıca Bakınız

  • Zookeeper::create() - Create a node synchronously.
  • Zookeeper::setAcl() - Sets the acl associated with a node synchronously.
  • ZooKeeper Permissions
Zookeeper::get
Zookeeper::getClientId
ZooKeeper


return the client session id, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE)

Zookeeper::getAcl
Zookeeper::getRecvTimeout
ZooKeeper
PHP Manual

Zookeeper::getClientId

(PECL zookeeper >= 0.1.0)

Zookeeper::getClientId — return the client session id, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE)

Açıklama

public int Zookeeper::getClientId ( void )

Dönen Değerler

Returns the client session id on success, and false on failure.

Hatalar/İstisnalar

This method emits PHP error/warning when it could not get client session id.

Ayrıca Bakınız

  • Zookeeper::__construct() - Create a handle to used communicate with zookeeper.
  • Zookeeper::connect() - Create a handle to used communicate with zookeeper.
  • Zookeeper::getState() - Get the state of the zookeeper connection.
  • ZooKeeper States
Zookeeper::getAcl
Zookeeper::getRecvTimeout
ZooKeeper


Return the timeout for this session, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE). This value may change after a server re-connect.

Zookeeper::getClientId
Zookeeper::getState
ZooKeeper
PHP Manual

Zookeeper::getRecvTimeout

(PECL zookeeper >= 0.1.0)

Zookeeper::getRecvTimeout — Return the timeout for this session, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE). This value may change after a server re-connect.

Açıklama

public int Zookeeper::getRecvTimeout ( void )

Dönen Değerler

Returns the timeout for this session on success, and false on failure.

Hatalar/İstisnalar

This method emits PHP error/warning when operation fails.

Ayrıca Bakınız

  • Zookeeper::__construct() - Create a handle to used communicate with zookeeper.
  • Zookeeper::connect() - Create a handle to used communicate with zookeeper.
Zookeeper::getClientId
Zookeeper::getState
ZooKeeper


Get the state of the zookeeper connection.

Zookeeper::getRecvTimeout
Zookeeper::isRecoverable
ZooKeeper
PHP Manual

Zookeeper::getState

(PECL zookeeper >= 0.1.0)

Zookeeper::getState — Get the state of the zookeeper connection.

Açıklama

public int Zookeeper::getState ( void )

Dönen Değerler

Returns the state of zookeeper connection on success, and false on failure.

Hatalar/İstisnalar

This method emits PHP error/warning when it fails to get state of zookeeper connection.

Ayrıca Bakınız

  • Zookeeper::__construct() - Create a handle to used communicate with zookeeper.
  • Zookeeper::connect() - Create a handle to used communicate with zookeeper.
  • Zookeeper::getClientId() - return the client session id, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE)
  • ZooKeeper States
Zookeeper::getRecvTimeout
Zookeeper::isRecoverable
ZooKeeper


Checks if the current zookeeper connection state can be recovered.

Zookeeper::getState
Zookeeper::set
ZooKeeper
PHP Manual

Zookeeper::isRecoverable

(PECL zookeeper >= 0.1.0)

Zookeeper::isRecoverable — Checks if the current zookeeper connection state can be recovered.

Açıklama

public bool Zookeeper::isRecoverable ( void )

The application must close the zhandle and try to reconnect.

Dönen Değerler

Returns true/false on success, and false on failure.

Hatalar/İstisnalar

This method emits PHP error/warning when operation fails.

Ayrıca Bakınız

  • Zookeeper::__construct() - Create a handle to used communicate with zookeeper.
  • Zookeeper::connect() - Create a handle to used communicate with zookeeper.
  • Zookeeper::getClientId() - return the client session id, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE)
  • ZooKeeper States
Zookeeper::getState
Zookeeper::set
ZooKeeper


Sets the data associated with a node.

Zookeeper::isRecoverable
Zookeeper::setAcl
ZooKeeper
PHP Manual

Zookeeper::set

(PECL zookeeper >= 0.1.0)

Zookeeper::set — Sets the data associated with a node.

Açıklama

public bool Zookeeper::set ( string $path , string $value [, int $version = -1 [, array &$stat = null ]] )

Değiştirgeler

path

The name of the node. Expressed as a file name with slashes separating ancestors of the node.

value

The data to be stored in the node.

version

The expected version of the node. The function will fail if the actual version of the node does not match the expected version. If -1 is used the version check will not take place.

stat

If not NULL, will hold the value of stat for the path on return.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

This method emits PHP error/warning when parameters count or types are wrong or fail to save value to node.

Örnekler

Örnek 1 Zookeeper::set() example

Save value to node.

<?php
$zookeeper = new Zookeeper('locahost:2181');
$path = '/path/to/node';
$value = 'nodevalue';
$r = $zookeeper->set($path, $value);
if ($r)
  echo 'SUCCESS';
else
  echo 'ERR';
?>

Yukarıdaki örneğin çıktısı:

SUCCESS

Ayrıca Bakınız

  • Zookeeper::create() - Create a node synchronously.
  • Zookeeper::get() - Gets the data associated with a node synchronously.
Zookeeper::isRecoverable
Zookeeper::setAcl
ZooKeeper


Sets the acl associated with a node synchronously.

Zookeeper::set
Zookeeper::setDebugLevel
ZooKeeper
PHP Manual

Zookeeper::setAcl

(PECL zookeeper >= 0.1.0)

Zookeeper::setAcl — Sets the acl associated with a node synchronously.

Açıklama

public bool Zookeeper::setAcl ( string $path , int $version , array $acl )

Değiştirgeler

path

The name of the node. Expressed as a file name with slashes separating ancestors of the node.

version

The expected version of the path.

acl

The acl to be set on the path.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

This method emits PHP error/warning when parameters count or types are wrong or fail to set ACL for a node.

Örnekler

Örnek 1 Zookeeper::setAcl() example

Set ACL for a node.

<?php
$zookeeper = new Zookeeper('locahost:2181');
$aclArray = array(
  array(
    'perms'  => Zookeeper::PERM_ALL,
    'scheme' => 'world',
    'id'     => 'anyone',
  )
);
$path = '/path/to/newnode';
$zookeeper->setAcl($path, $aclArray);

$r = $zookeeper->getAcl($path);
if ($r)
  var_dump($r);
else
  echo 'ERR';
?>

Yukarıdaki örneğin çıktısı:

array(1) {
  [0]=>
  array(3) {
    ["perms"]=>
    int(31)
    ["scheme"]=>
    string(5) "world"
    ["id"]=>
    string(6) "anyone"
  }
}

Ayrıca Bakınız

  • Zookeeper::create() - Create a node synchronously.
  • Zookeeper::getAcl() - Gets the acl associated with a node synchronously.
  • ZooKeeper Permissions
Zookeeper::set
Zookeeper::setDebugLevel
ZooKeeper


Sets the debugging level for the library.

Zookeeper::setAcl
Zookeeper::setDeterministicConnOrder
ZooKeeper
PHP Manual

Zookeeper::setDebugLevel

(PECL zookeeper >= 0.1.0)

Zookeeper::setDebugLevel — Sets the debugging level for the library.

Açıklama

public static bool Zookeeper::setDebugLevel ( int $logLevel )

Değiştirgeler

logLevel

ZooKeeper log level constants.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

This method emits PHP error/warning when parameters count or types are wrong or fail to set debug level.

Örnekler

Örnek 1 Zookeeper::setDebugLevel() example

Set debugl level.

<?php
$r = Zookeeper::setDebugLevel(Zookeeper::LOG_LEVEL_WARN);
if ($r)
  echo 'SUCCESS';
else
  echo 'ERR';
?>
?>

Yukarıdaki örneğin çıktısı:

SUCCESS

Ayrıca Bakınız

  • ZooKeeper Log Levels
Zookeeper::setAcl
Zookeeper::setDeterministicConnOrder
ZooKeeper


Enable/disable quorum endpoint order randomization.

Zookeeper::setDebugLevel
Zookeeper::setLogStream
ZooKeeper
PHP Manual

Zookeeper::setDeterministicConnOrder

(PECL zookeeper >= 0.1.0)

Zookeeper::setDeterministicConnOrder — Enable/disable quorum endpoint order randomization.

Açıklama

public static bool Zookeeper::setDeterministicConnOrder ( bool $yesOrNo )

If passed a non-zero value, will make the client connect to quorum peers in the order as specified in the zookeeper_init() call. A zero value causes zookeeper_init() to permute the peer endpoints which is good for more even client connection distribution among the quorum peers.

Değiştirgeler

yesOrNo

Enable/disable quorum endpoint order randomization.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

This method emits PHP error/warning when parameters count or types are wrong or operation fails.

Notlar

Dikkat

Note: typically this method should NOT be used outside of testing.

Bilginize: Bu bir işlev değil, dil oluşumu olduğundan değişken işlevler kullanılarak çağrılamaz.

Uyarı

Bu işlev ikil dosyalarla çalışırken dosya içeriğini değiştirebilir.

Bilginize: register_globals için önemli bilgi

PHP 4.2.0'dan itibaren, register_globals yönergesinin öntanımlı değeri off olup PHP 6.0.0'dan itibaren tamamen kaldırılmıştır. PHP topluluğu, geliştiricilere, bu yönergeyi kullanmaktan vazgeçmelerini ve yerine süper küreselleri tercih etmelerini önermektedir.

Ayrıca Bakınız

  • Zookeeper::__construct() - Create a handle to used communicate with zookeeper.
  • Zookeeper::connect() - Create a handle to used communicate with zookeeper.
Zookeeper::setDebugLevel
Zookeeper::setLogStream
ZooKeeper


Sets the stream to be used by the library for logging.

Zookeeper::setDeterministicConnOrder
Zookeeper::setWatcher
ZooKeeper
PHP Manual

Zookeeper::setLogStream

(PECL zookeeper >= 0.1.0)

Zookeeper::setLogStream — Sets the stream to be used by the library for logging.

Açıklama

public bool Zookeeper::setLogStream ( resource $stream )

The zookeeper library uses stderr as its default log stream. Application must make sure the stream is writable. Passing in NULL resets the stream to its default value (stderr).

Değiştirgeler

stream

The stream to be used by the library for logging.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

This method emits PHP error/warning when parameters count or types are wrong or operation fails.

Ayrıca Bakınız

  • Zookeeper::setDebugLevel() - Sets the debugging level for the library.
Zookeeper::setDeterministicConnOrder
Zookeeper::setWatcher
ZooKeeper


Set a watcher function.

Zookeeper::setLogStream
Arama Motoru Eklentileri
ZooKeeper
PHP Manual

Zookeeper::setWatcher

(PECL zookeeper >= 0.1.0)

Zookeeper::setWatcher — Set a watcher function.

Açıklama

public bool Zookeeper::setWatcher ( callable $watcher_cb )

Değiştirgeler

watcher_cb

A watch will be set at the server to notify the client if the node changes.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

This method emits PHP error/warning when parameters count or types are wrong or fail to set watcher.

Ayrıca Bakınız

  • Zookeeper::exists() - Checks the existence of a node in zookeeper synchronously.
  • Zookeeper::get() - Gets the data associated with a node synchronously.
Zookeeper::setLogStream
Arama Motoru Eklentileri
ZooKeeper


Arama Motoru Eklentileri

  • mnoGoSearch
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • mnoGoSearch İşlevleri
  • Solr — Apache Solr
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Solr İşlevleri
    • Örnekler
    • SolrUtils — The SolrUtils class
    • SolrInputDocument — The SolrInputDocument class
    • SolrDocument — The SolrDocument class
    • SolrDocumentField — The SolrDocumentField class
    • SolrObject — The SolrObject class
    • SolrClient — The SolrClient class
    • SolrResponse — The SolrResponse class
    • SolrQueryResponse — The SolrQueryResponse class
    • SolrUpdateResponse — The SolrUpdateResponse class
    • SolrPingResponse — The SolrPingResponse class
    • SolrGenericResponse — The SolrGenericResponse class
    • SolrParams — The SolrParams class
    • SolrModifiableParams — The SolrModifiableParams class
    • SolrQuery — The SolrQuery class
    • SolrDisMaxQuery — The SolrDisMaxQuery class
    • SolrCollapseFunction — The SolrCollapseFunction class
    • SolrException — The SolrException class
    • SolrClientException — The SolrClientException class
    • SolrServerException — The SolrServerException class
    • SolrIllegalArgumentException — The SolrIllegalArgumentException class
    • SolrIllegalOperationException — The SolrIllegalOperationException class
    • SolrMissingMandatoryParameterException — The SolrMissingMandatoryParameterException class
  • Sphinx — Sphinx Client
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • SphinxClient — The SphinxClient class
  • Swish — Swish Indexing
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • Swish İşlevleri
Zookeeper::setWatcher
mnoGoSearch
İşlev Başvuru Kılavuzu


mnoGoSearch

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • mnoGoSearch İşlevleri
    • udm_add_search_limit — Add various search limits
    • udm_alloc_agent_array — Allocate mnoGoSearch session
    • udm_alloc_agent — Allocate mnoGoSearch session
    • udm_api_version — Get mnoGoSearch API version
    • udm_cat_list — Get all the categories on the same level with the current one
    • udm_cat_path — Get the path to the current category
    • udm_check_charset — Check if the given charset is known to mnogosearch
    • udm_clear_search_limits — Clear all mnoGoSearch search restrictions
    • udm_crc32 — Return CRC32 checksum of given string
    • udm_errno — Get mnoGoSearch error number
    • udm_error — Get mnoGoSearch error message
    • udm_find — Perform search
    • udm_free_agent — Free mnoGoSearch session
    • udm_free_ispell_data — Free memory allocated for ispell data
    • udm_free_res — Free mnoGoSearch result
    • udm_get_doc_count — Get total number of documents in database
    • udm_get_res_field — Fetch a result field
    • udm_get_res_param — Get mnoGoSearch result parameters
    • udm_hash32 — Return Hash32 checksum of given string
    • udm_load_ispell_data — Load ispell data
    • udm_set_agent_param — Set mnoGoSearch agent session parameters
Arama Motoru Eklentileri
Giriş
Arama Motoru Eklentileri


Giriş

These functions allow you to access the mnoGoSearch (former UdmSearch) free search engine. mnoGoSearch is a full-featured search engine software for intranet and internet servers, distributed under the GNU license. mnoGoSearch has a number of unique features, which makes it appropriate for a wide range of applications from search within your site to a specialized search system such as cooking recipes or newspaper search, FTP archive search, news articles search, etc. It offers full-text indexing and searching for HTML, PDF, and text documents. mnoGoSearch consists of two parts. The first is an indexing mechanism (indexer). The purpose of the indexer is to walk through HTTP, FTP, NEWS servers or local files, recursively grabbing all the documents and storing meta-data about that documents in an SQL database in a smart and effective manner. After every document is referenced by its corresponding URL, meta-data is collected by the indexer for later use in a search process. The search is performed via Web interface. C, CGI, PHP and Perl search front ends are included.

More information about mnoGoSearch can be found at » http://www.mnogosearch.org/.

Bilginize:

Bu eklenti » PECL deposuna taşınmış olup şu sürümden itibaren PHP kaynak paketinde dağıtılmamaktatır: PHP 5.1.0.

Bilginize: Bu eklenti Windows sistemlerinde çalışmaz.

mnoGoSearch
Yapılandırma/Kurulum
mnoGoSearch


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
mnoGoSearch


Gereksinimler

Download mnoGosearch from » http://www.mnogosearch.org/ and install it on your system. You need at least version 3.1.10 of mnoGoSearch installed to use these functions.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/mnogosearch.

Bu eklenti » PECL deposuna taşınmış olup şu sürümden itibaren PHP kaynak paketinde dağıtılmamaktatır: PHP 5.1.0

Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız.

Bilginize:

PHP contains built-in MySQL access library, which can be used to access MySQL. It is known that mnoGoSearch is not compatible with this built-in library and can work only with generic MySQL libraries. Thus, if you use mnoGoSearch with MySQL, during PHP configuration you have to indicate the directory of your MySQL installation, that was used during mnoGoSearch configuration, i.e. for example: --with-mnogosearch --with-mysql=/usr .

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

UDM_FIELD_URLID (integer)
UDM_FIELD_URL (integer)
UDM_FIELD_CONTENT (integer)
UDM_FIELD_TITLE (integer)
UDM_FIELD_KEYWORDS (integer)
UDM_FIELD_DESC (integer)
UDM_FIELD_DESCRIPTION (integer)
UDM_FIELD_TEXT (integer)
UDM_FIELD_SIZE (integer)
UDM_FIELD_RATING (integer)
UDM_FIELD_SCORE (integer)
UDM_FIELD_MODIFIED (integer)
UDM_FIELD_ORDER (integer)
UDM_FIELD_CRC (integer)
UDM_FIELD_CATEGORY (integer)
UDM_FIELD_LANG (integer)
UDM_FIELD_CHARSET (integer)
UDM_PARAM_PAGE_SIZE (integer)
UDM_PARAM_PAGE_NUM (integer)
UDM_PARAM_SEARCH_MODE (integer)
UDM_PARAM_CACHE_MODE (integer)
UDM_PARAM_TRACK_MODE (integer)
UDM_PARAM_PHRASE_MODE (integer)
UDM_PARAM_CHARSET (integer)
UDM_PARAM_LOCAL_CHARSET (integer)
UDM_PARAM_BROWSER_CHARSET (integer)
UDM_PARAM_STOPTABLE (integer)
UDM_PARAM_STOP_TABLE (integer)
UDM_PARAM_STOPFILE (integer)
UDM_PARAM_STOP_FILE (integer)
UDM_PARAM_WEIGHT_FACTOR (integer)
UDM_PARAM_WORD_MATCH (integer)
UDM_PARAM_MAX_WORD_LEN (integer)
UDM_PARAM_MAX_WORDLEN (integer)
UDM_PARAM_MIN_WORD_LEN (integer)
UDM_PARAM_MIN_WORDLEN (integer)
UDM_PARAM_ISPELL_PREFIXES (integer)
UDM_PARAM_ISPELL_PREFIX (integer)
UDM_PARAM_PREFIXES (integer)
UDM_PARAM_PREFIX (integer)
UDM_PARAM_CROSS_WORDS (integer)
UDM_PARAM_CROSSWORDS (integer)
UDM_PARAM_VARDIR (integer)
UDM_PARAM_DATADIR (integer)
UDM_PARAM_HLBEG (integer)
UDM_PARAM_HLEND (integer)
UDM_PARAM_SYNONYM (integer)
UDM_PARAM_SEARCHD (integer)
UDM_PARAM_QSTRING (integer)
UDM_PARAM_REMOTE_ADDR (integer)
UDM_LIMIT_CAT (integer)
UDM_LIMIT_URL (integer)
UDM_LIMIT_TAG (integer)
UDM_LIMIT_LANG (integer)
UDM_LIMIT_DATE (integer)
UDM_PARAM_FOUND (integer)
UDM_PARAM_NUM_ROWS (integer)
UDM_PARAM_WORDINFO (integer)
UDM_PARAM_WORD_INFO (integer)
UDM_PARAM_SEARCHTIME (integer)
UDM_PARAM_SEARCH_TIME (integer)
UDM_PARAM_FIRST_DOC (integer)
UDM_PARAM_LAST_DOC (integer)
UDM_MODE_ALL (integer)
UDM_MODE_ANY (integer)
UDM_MODE_BOOL (integer)
UDM_MODE_PHRASE (integer)
UDM_CACHE_ENABLED (integer)
UDM_CACHE_DISABLED (integer)
UDM_TRACK_ENABLED (integer)
UDM_TRACK_DISABLED (integer)
UDM_PHRASE_ENABLED (integer)
UDM_PHRASE_DISABLED (integer)
UDM_CROSS_WORDS_ENABLED (integer)
UDM_CROSSWORDS_ENABLED (integer)
UDM_CROSS_WORDS_DISABLED (integer)
UDM_CROSSWORDS_DISABLED (integer)
UDM_PREFIXES_ENABLED (integer)
UDM_PREFIX_ENABLED (integer)
UDM_ISPELL_PREFIXES_ENABLED (integer)
UDM_ISPELL_PREFIX_ENABLED (integer)
UDM_PREFIXES_DISABLED (integer)
UDM_PREFIX_DISABLED (integer)
UDM_ISPELL_PREFIXES_DISABLED (integer)
UDM_ISPELL_PREFIX_DISABLED (integer)
UDM_ISPELL_TYPE_AFFIX (integer)
UDM_ISPELL_TYPE_SPELL (integer)
UDM_ISPELL_TYPE_DB (integer)
UDM_ISPELL_TYPE_SERVER (integer)
UDM_MATCH_WORD (integer)
UDM_MATCH_BEGIN (integer)
UDM_MATCH_SUBSTR (integer)
UDM_MATCH_END (integer)
Özkaynak Türleri
mnoGoSearch İşlevleri
mnoGoSearch


mnoGoSearch İşlevleri

İçindekiler

  • udm_add_search_limit — Add various search limits
  • udm_alloc_agent_array — Allocate mnoGoSearch session
  • udm_alloc_agent — Allocate mnoGoSearch session
  • udm_api_version — Get mnoGoSearch API version
  • udm_cat_list — Get all the categories on the same level with the current one
  • udm_cat_path — Get the path to the current category
  • udm_check_charset — Check if the given charset is known to mnogosearch
  • udm_clear_search_limits — Clear all mnoGoSearch search restrictions
  • udm_crc32 — Return CRC32 checksum of given string
  • udm_errno — Get mnoGoSearch error number
  • udm_error — Get mnoGoSearch error message
  • udm_find — Perform search
  • udm_free_agent — Free mnoGoSearch session
  • udm_free_ispell_data — Free memory allocated for ispell data
  • udm_free_res — Free mnoGoSearch result
  • udm_get_doc_count — Get total number of documents in database
  • udm_get_res_field — Fetch a result field
  • udm_get_res_param — Get mnoGoSearch result parameters
  • udm_hash32 — Return Hash32 checksum of given string
  • udm_load_ispell_data — Load ispell data
  • udm_set_agent_param — Set mnoGoSearch agent session parameters
Öntanımlı Sabitler
udm_add_search_limit
mnoGoSearch


Add various search limits

mnoGoSearch İşlevleri
udm_alloc_agent_array
mnoGoSearch İşlevleri
PHP Manual

udm_add_search_limit

(PHP 4 >= 4.0.5, PHP 5 <= 5.0.5, PECL mnogosearch >= 1.0.0)

udm_add_search_limit — Add various search limits

Açıklama

bool udm_add_search_limit ( resource $agent , int $var , string $val )

udm_add_search_limit() adds search restrictions.

Değiştirgeler

agent

A link to Agent, received after call to udm_alloc_agent().

var

Defines the parameter, indicating limits. Possible var values:

  • UDM_LIMIT_URL - defines document URL limitations to limit the search through subsection of the database. It supports SQL % and _ LIKE wildcards, where % matches any number of characters, even zero characters, and _ matches exactly one character. E.g. http://www.example.___/catalog may stand for http://www.example.com/catalog and http://www.example.net/catalog.
  • UDM_LIMIT_TAG - defines site TAG limitations. In indexer-conf you can assign specific TAGs to various sites and parts of a site. Tags in mnoGoSearch 3.1.x are lines, that may contain metasymbols % and _. Metasymbols allow searching among groups of tags. E.g. there are links with tags ABCD and ABCE, and search restriction is by ABC_ - the search will be made among both of the tags.
  • UDM_LIMIT_LANG - defines document language limitations.
  • UDM_LIMIT_CAT - defines document category limitations. Categories are similar to tag feature, but nested. So you can have one category inside another and so on. You have to use two characters for each level. Use a hex number going from 0-F or a 36 base number going from 0-Z. Therefore a top-level category like 'Auto' would be 01. If it has a subcategory like 'Ford', then it would be 01 (the parent category) and then 'Ford' which we will give 01. Put those together and you get 0101. If 'Auto' had another subcategory named 'VW', then it's id would be 01 because it belongs to the 'Ford' category and then 02 because it's the next category. So it's id would be 0102. If VW had a sub category called 'Engine' then it's id would start at 01 again and it would get the 'VW' id 02 and 'Auto' id of 01, making it 010201. If you want to search for sites under that category then you pass it cat=010201 in the URL.

  • UDM_LIMIT_DATE - defines limitation by date the document was modified.

    Format of parameter value: a string with first character < or >, then with no space - date in unixtime format, for example:

    <?php
    udm_add_search_limit    ($udm, UDM_LIMIT_DATE, "&lt;908012006");
    ?>

    If > character is used, then the search will be restricted to those documents having a modification date greater than entered, if <, then smaller.

val

Defines the value of the current parameter.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

mnoGoSearch İşlevleri
udm_alloc_agent_array
mnoGoSearch İşlevleri


Allocate mnoGoSearch session

udm_add_search_limit
udm_alloc_agent
mnoGoSearch İşlevleri
PHP Manual

udm_alloc_agent_array

(PHP 4 >= 4.3.3, PHP 5 <= 5.0.5, PECL mnogosearch >= 1.0.0)

udm_alloc_agent_array — Allocate mnoGoSearch session

Açıklama

resource udm_alloc_agent_array ( array $databases )

udm_alloc_agent_array() will create an agent with multiple database connections.

Değiştirgeler

databases

The array databases must contain one database URL per element, analog to the first parameter of udm_alloc_agent().

Dönen Değerler

Returns a resource link identifier on success başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • udm_alloc_agent() - Allocate mnoGoSearch session

udm_add_search_limit
udm_alloc_agent
mnoGoSearch İşlevleri


Allocate mnoGoSearch session

udm_alloc_agent_array
udm_api_version
mnoGoSearch İşlevleri
PHP Manual

udm_alloc_agent

(PHP 4 >= 4.0.5, PHP 5 <= 5.0.5, PECL mnogosearch >= 1.0.0)

udm_alloc_agent — Allocate mnoGoSearch session

Açıklama

resource udm_alloc_agent ( string $dbaddr [, string $dbmode ] )

Allocate a mnoGoSearch session.

Değiştirgeler

dbaddr

dbaddr - URL-style database description, with options (type, host, database name, port, user and password) to connect to SQL database. Do not matter for built-in text files support. Format for dbaddr: DBType:[//[DBUser[:DBPass]@]DBHost[:DBPort]]/DBName/. Currently supported DBType values are: mysql, pgsql, msql, solid, mssql, oracle, and ibase. Actually, it does not matter for native libraries support, but ODBC users should specify one of the supported values. If your database type is not supported, you may use unknown instead.

dbmode

dbmode - You may select the SQL database mode of words storage. Possible values of dbmode are: single, multi, crc, or crc-multi. When single is specified, all words are stored in the same table. If multi is selected, words will be located in different tables depending of their lengths. "multi" mode is usually faster, but requires more tables in the database. If "crc" mode is selected, mnoGoSearch will store 32 bit integer word IDs calculated by CRC32 algorithm instead of words. This mode requires less disk space and it is faster comparing with "single" and "multi" modes. crc-multi uses the same storage structure with the "crc" mode, but also stores words in different tables depending on words lengths like in "multi" mode.

Bilginize:

dbaddr and dbmode must match those used during indexing.

Dönen Değerler

Returns a mnogosearch agent identifier on success, FALSE on failure. This function creates a session with database parameters.

Notlar

Bilginize:

In fact this function does not open a connection to the database and thus does not check the entered login and password. Establishing a connection to the database and login/password verification is done by udm_find().

udm_alloc_agent_array
udm_api_version
mnoGoSearch İşlevleri


Get mnoGoSearch API version

udm_alloc_agent
udm_cat_list
mnoGoSearch İşlevleri
PHP Manual

udm_api_version

(PHP 4 >= 4.0.5, PHP 5 <= 5.0.5, PECL mnogosearch >= 1.0.0)

udm_api_version — Get mnoGoSearch API version

Açıklama

int udm_api_version ( void )

Gets the mnoGoSearch API version.

This function allows the user to identify which API functions are available, e.g. udm_get_doc_count() function is only available in mnoGoSearch 3.1.11 or later.

Dönen Değerler

udm_api_version() returns the mnoGoSearch API version number. E.g. if mnoGoSearch 3.1.10 API is used, this function will return 30110.

Örnekler

Örnek 1 udm_api_version() example

<?php
if (udm_api_version() >= 30111) {
    echo  "Total number of URLs in database: " . udm_get_doc_count($udm) . "<br />\n";
}
?>

udm_alloc_agent
udm_cat_list
mnoGoSearch İşlevleri


Get all the categories on the same level with the current one

udm_api_version
udm_cat_path
mnoGoSearch İşlevleri
PHP Manual

udm_cat_list

(PHP 4 >= 4.0.6, PHP 5 <= 5.0.5, PECL mnogosearch >= 1.0.0)

udm_cat_list — Get all the categories on the same level with the current one

Açıklama

array udm_cat_list ( resource $agent , string $category )

Gets all the categories on the same level with the current one.

The function can be useful for developing categories tree browser.

Değiştirgeler

agent

A link to Agent, received after call to udm_alloc_agent().

category

Dönen Değerler

Returns an array listing all categories of the same level as the current category in the categories tree.

The returned array consists of pairs. Elements with even index numbers contain the category paths, odd elements contain the corresponding category names.

$array[0] will contain '020300'
  $array[1] will contain 'Audi'
  $array[2] will contain '020301'
  $array[3] will contain 'BMW'
  $array[4] will contain '020302'
  $array[5] will contain 'Opel'
  ...
 etc.

Örnekler

Following is an example of displaying links of the current level in format:

Audi
  BMW
  Opel
  ...

Örnek 1 udm_cat_list()example

<?php
 $cat_list_arr = udm_cat_list($udm_agent, $cat);
 $cat_list = '';
 for ($i=0; $i<count($cat_list_arr); $i+=2) {
    $path = $cat_list_arr[$i];
    $name = $cat_list_arr[$i+1];
    $cat_list .= "<a href=\"$_SERVER[PHP_SELF]?cat=$path\">$name</a><br />";
 }
?>

Ayrıca Bakınız

  • udm_cat_path() - Get the path to the current category

udm_api_version
udm_cat_path
mnoGoSearch İşlevleri


Get the path to the current category

udm_cat_list
udm_check_charset
mnoGoSearch İşlevleri
PHP Manual

udm_cat_path

(PHP 4 >= 4.0.6, PHP 5 <= 5.0.5, PECL mnogosearch >= 1.0.0)

udm_cat_path — Get the path to the current category

Açıklama

array udm_cat_path ( resource $agent , string $category )

Returns an array describing the path in the categories tree from the tree root to the current one, specified by category.

Değiştirgeler

agent

A link to Agent, received after call to udm_alloc_agent().

category

Dönen Değerler

The returned array consists of pairs. Elements with even index numbers contain the category paths, odd elements contain the corresponding category names.

For example, the call $array=udm_cat_path($agent, '02031D'); may return the following array:

 $array[0] will contain ''
 $array[1] will contain 'Root'
 $array[2] will contain '02'
 $array[3] will contain 'Sport'
 $array[4] will contain '0203'
 $array[5] will contain 'Auto'
 $array[4] will contain '02031D'
 $array[5] will contain 'Ferrari'

Örnekler

Örnek 1 Specifying path to the current category in the following format: '> Root > Sport > Auto > Ferrari'

<?php
  $cat_path_arr = udm_cat_path($udm_agent, $cat);
  $cat_path = '';
  for ($i=0; $i<count($cat_path_arr); $i+=2) {
    $path = $cat_path_arr[$i];
    $name = $cat_path_arr[$i+1];
    $cat_path .= " > <a href=\"$_SERVER[PHP_SELF]?cat=$path\">$name</a> ";
  }
?>

Ayrıca Bakınız

  • udm_cat_list() - Get all the categories on the same level with the current one

udm_cat_list
udm_check_charset
mnoGoSearch İşlevleri


Check if the given charset is known to mnogosearch

udm_cat_path
udm_clear_search_limits
mnoGoSearch İşlevleri
PHP Manual

udm_check_charset

(PHP 4 >= 4.2.0, PHP 5 <= 5.0.5, PECL mnogosearch >= 1.0.0)

udm_check_charset — Check if the given charset is known to mnogosearch

Açıklama

bool udm_check_charset ( resource $agent , string $charset )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

udm_cat_path
udm_clear_search_limits
mnoGoSearch İşlevleri


Clear all mnoGoSearch search restrictions

udm_check_charset
udm_crc32
mnoGoSearch İşlevleri
PHP Manual

udm_clear_search_limits

(PHP 4 >= 4.0.5, PHP 5 <= 5.0.5, PECL mnogosearch >= 1.0.0)

udm_clear_search_limits — Clear all mnoGoSearch search restrictions

Açıklama

bool udm_clear_search_limits ( resource $agent )

udm_clear_search_limits() resets defined search limitations.

Değiştirgeler

agent

A link to Agent, received after call to udm_alloc_agent().

Dönen Değerler

Returns TRUE.

Ayrıca Bakınız

  • udm_add_search_limit() - Add various search limits

udm_check_charset
udm_crc32
mnoGoSearch İşlevleri


Return CRC32 checksum of given string

udm_clear_search_limits
udm_errno
mnoGoSearch İşlevleri
PHP Manual

udm_crc32

(PHP 4 >= 4.2.0, PHP 5 <= 5.0.5, PECL mnogosearch >= 1.0.0)

udm_crc32 — Return CRC32 checksum of given string

Açıklama

int udm_crc32 ( resource $agent , string $str )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

udm_clear_search_limits
udm_errno
mnoGoSearch İşlevleri


Get mnoGoSearch error number

udm_crc32
udm_error
mnoGoSearch İşlevleri
PHP Manual

udm_errno

(PHP 4 >= 4.0.5, PHP 5 <= 5.0.5, PECL mnogosearch >= 1.0.0)

udm_errno — Get mnoGoSearch error number

Açıklama

int udm_errno ( resource $agent )

Receiving numeric agent error code.

Değiştirgeler

agent

A link to Agent, received after call to udm_alloc_agent().

Dönen Değerler

Returns the mnoGoSearch error number, zero if no error.

udm_crc32
udm_error
mnoGoSearch İşlevleri


Get mnoGoSearch error message

udm_errno
udm_find
mnoGoSearch İşlevleri
PHP Manual

udm_error

(PHP 4 >= 4.0.5, PHP 5 <= 5.0.5, PECL mnogosearch >= 1.0.0)

udm_error — Get mnoGoSearch error message

Açıklama

string udm_error ( resource $agent )

Gets the agent error message.

Değiştirgeler

agent

A link to Agent, received after call to udm_alloc_agent().

Dönen Değerler

udm_error() returns mnoGoSearch error message, empty string if no error.

udm_errno
udm_find
mnoGoSearch İşlevleri


Perform search

udm_error
udm_free_agent
mnoGoSearch İşlevleri
PHP Manual

udm_find

(PHP 4 >= 4.0.5, PHP 5 <= 5.0.5, PECL mnogosearch >= 1.0.0)

udm_find — Perform search

Açıklama

resource udm_find ( resource $agent , string $query )

Performs a search.

The search itself. The first argument - session, the next one - query itself. To find something just type words you want to find and press SUBMIT button. For example, "mysql odbc". You should not use quotes " in query, they are written here only to divide a query from other text. mnoGoSearch will find all documents that contain word "mysql" and/or word "odbc". Best documents having bigger weights will be displayed first. If you use search mode ALL, search will return documents that contain both (or more) words you entered. In case you use mode ANY, the search will return list of documents that contain any of the words you entered. If you want more advanced results you may use query language. You should select "bool" match mode in the search from.

Değiştirgeler

agent

A link to Agent, received after call to udm_alloc_agent().

query

mnoGoSearch understands the following boolean operators:

& - logical AND. For example, "mysql & odbc". mnoGoSearch will find any URLs that contain both "mysql" and "odbc".

| - logical OR. For example "mysql|odbc". mnoGoSearch will find any URLs, that contain word "mysql" or word "odbc".

~ - logical NOT. For example "mysql & ~odbc". mnoGoSearch will find URLs that contain word "mysql" and do not contain word "odbc" at the same time. Note that ~ just excludes given word from results. Query "~odbc" will find nothing!

() - group command to compose more complex queries. For example "(mysql | msql) & ~postgres". Query language is simple and powerful at the same time. Just consider query as usual boolean expression.

Dönen Değerler

Returns a result link identifier on success başarısızlık durumunda FALSE döner.

udm_error
udm_free_agent
mnoGoSearch İşlevleri


Free mnoGoSearch session

udm_find
udm_free_ispell_data
mnoGoSearch İşlevleri
PHP Manual

udm_free_agent

(PHP 4 >= 4.0.5, PHP 5 <= 5.0.5, PECL mnogosearch >= 1.0.0)

udm_free_agent — Free mnoGoSearch session

Açıklama

int udm_free_agent ( resource $agent )

Freeing up memory allocated for agent session.

Değiştirgeler

agent

A link to Agent, received after call to udm_alloc_agent().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

udm_find
udm_free_ispell_data
mnoGoSearch İşlevleri


Free memory allocated for ispell data

udm_free_agent
udm_free_res
mnoGoSearch İşlevleri
PHP Manual

udm_free_ispell_data

(PHP 4 >= 4.0.5, PHP 5 <= 5.0.5, PECL mnogosearch >= 1.0.0)

udm_free_ispell_data — Free memory allocated for ispell data

Açıklama

bool udm_free_ispell_data ( int $agent )

Frees the memory allocated for ispell data.

Değiştirgeler

agent

A link to Agent, received after call to udm_alloc_agent().

Dönen Değerler

udm_free_ispell_data() always returns TRUE.

Notlar

Bilginize:

This function is supported beginning from version 3.1.12 of mnoGoSearch and it does not do anything in previous versions.

udm_free_agent
udm_free_res
mnoGoSearch İşlevleri


Free mnoGoSearch result

udm_free_ispell_data
udm_get_doc_count
mnoGoSearch İşlevleri
PHP Manual

udm_free_res

(PHP 4 >= 4.0.5, PHP 5 <= 5.0.5, PECL mnogosearch >= 1.0.0)

udm_free_res — Free mnoGoSearch result

Açıklama

bool udm_free_res ( resource $res )

Freeing up memory allocated for results.

Değiştirgeler

res

A link to a result identifier, received after call to udm_find().

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

udm_free_ispell_data
udm_get_doc_count
mnoGoSearch İşlevleri


Get total number of documents in database

udm_free_res
udm_get_res_field
mnoGoSearch İşlevleri
PHP Manual

udm_get_doc_count

(PHP 4 >= 4.0.5, PHP 5 <= 5.0.5, PECL mnogosearch >= 1.0.0)

udm_get_doc_count — Get total number of documents in database

Açıklama

int udm_get_doc_count ( resource $agent )

udm_get_doc_count() returns the number of documents in the database.

Değiştirgeler

agent

A link to Agent, received after call to udm_alloc_agent().

Dönen Değerler

Returns the number of documents.

Notlar

Bilginize:

This function is supported only in mnoGoSearch 3.1.11 or later.

udm_free_res
udm_get_res_field
mnoGoSearch İşlevleri


Fetch a result field

udm_get_doc_count
udm_get_res_param
mnoGoSearch İşlevleri
PHP Manual

udm_get_res_field

(PHP 4 >= 4.0.5, PHP 5 <= 5.0.5, PECL mnogosearch >= 1.0.0)

udm_get_res_field — Fetch a result field

Açıklama

string udm_get_res_field ( resource $res , int $row , int $field )

Fetch a mnoGoSearch result field.

Değiştirgeler

res

res - a link to result identifier, received after call to udm_find().

row

row - the number of the link on the current page. May have values from 0 to UDM_PARAM_NUM_ROWS-1.

field

field - field identifier, may have the following values:

  • UDM_FIELD_URL - document URL field
  • UDM_FIELD_CONTENT - document Content-type field (for example, text/html).
  • UDM_FIELD_CATEGORY - document category field. Use udm_cat_path() to get full path to current category from the categories tree root. (This parameter is available only in PHP 4.0.6 or later).
  • UDM_FIELD_TITLE - document title field.
  • UDM_FIELD_KEYWORDS - document keywords field (from META KEYWORDS tag).
  • UDM_FIELD_DESC - document description field (from META DESCRIPTION tag).
  • UDM_FIELD_TEXT - document body text (the first couple of lines to give an idea of what the document is about).
  • UDM_FIELD_SIZE - document size.
  • UDM_FIELD_URLID - unique URL ID of the link.
  • UDM_FIELD_RATING - page rating (as calculated by mnoGoSearch).
  • UDM_FIELD_MODIFIED - last-modified field in unixtime format.
  • UDM_FIELD_ORDER - the number of the current document in set of found documents.
  • UDM_FIELD_CRC - document CRC.

Dönen Değerler

udm_get_res_field() returns result field value on success, FALSE on error.

udm_get_doc_count
udm_get_res_param
mnoGoSearch İşlevleri


Get mnoGoSearch result parameters

udm_get_res_field
udm_hash32
mnoGoSearch İşlevleri
PHP Manual

udm_get_res_param

(PHP 4 >= 4.0.5, PHP 5 <= 5.0.5, PECL mnogosearch >= 1.0.0)

udm_get_res_param — Get mnoGoSearch result parameters

Açıklama

string udm_get_res_param ( resource $res , int $param )

Gets the mnoGoSearch result parameters.

Değiştirgeler

res

res - a link to result identifier, received after call to udm_find().

param

param - parameter identifier, may have the following values:

  • UDM_PARAM_NUM_ROWS - number of received found links on the current page. It is equal to UDM_PARAM_PAGE_SIZE for all search pages, on the last page - the rest of links.
  • UDM_PARAM_FOUND - total number of results matching the query.
  • UDM_PARAM_WORDINFO - information on the words found. E.g. search for "a good book" will return "a: stopword, good:5637, book: 120"
  • UDM_PARAM_SEARCHTIME - search time in seconds.
  • UDM_PARAM_FIRST_DOC - the number of the first document displayed on current page.
  • UDM_PARAM_LAST_DOC - the number of the last document displayed on current page.

Dönen Değerler

udm_get_res_param() returns result parameter value on success, FALSE on error.

udm_get_res_field
udm_hash32
mnoGoSearch İşlevleri


Return Hash32 checksum of given string

udm_get_res_param
udm_load_ispell_data
mnoGoSearch İşlevleri
PHP Manual

udm_hash32

(PHP 4 >= 4.3.3, PHP 5 <= 5.0.5, PECL mnogosearch >= 1.0.0)

udm_hash32 — Return Hash32 checksum of given string

Açıklama

int udm_hash32 ( resource $agent , string $str )

udm_hash32() will take a string str and return a quite unique 32-bit hash number from it.

Değiştirgeler

agent

A link to Agent, received after call to udm_alloc_agent().

str

The input string.

Dönen Değerler

Returns a 32-bit hash number.

Ayrıca Bakınız

  • udm_alloc_agent() - Allocate mnoGoSearch session

udm_get_res_param
udm_load_ispell_data
mnoGoSearch İşlevleri


Load ispell data

udm_hash32
udm_set_agent_param
mnoGoSearch İşlevleri
PHP Manual

udm_load_ispell_data

(PHP 4 >= 4.0.5, PHP 5 <= 5.0.5, PECL mnogosearch >= 1.0.0)

udm_load_ispell_data — Load ispell data

Açıklama

bool udm_load_ispell_data ( resource $agent , int $var , string $val1 , string $val2 , int $flag )

udm_load_ispell_data() loads ispell data.

After using this function to free memory allocated for ispell data, please use udm_free_ispell_data(), even if you use UDM_ISPELL_TYPE_SERVER mode.

Değiştirgeler

agent

A link to Agent, received after call to udm_alloc_agent().

var

Indicates the source for ispell data. May have the following values:

  • UDM_ISPELL_TYPE_DB - indicates that ispell data should be loaded from SQL. In this case, parameters val1 and val2 are ignored and should be left blank. flag should be equal to 1.

    Bilginize:

    flag indicates that after loading ispell data from defined source it should be sorted (it is necessary for correct functioning of ispell). In case of loading ispell data from files there may be several calls to udm_load_ispell_data(), and there is no sense to sort data after every call, but only after the last one. Since in db mode all the data is loaded by one call, this parameter should have the value 1. In this mode in case of error, e.g. if ispell tables are absent, the function will return FALSE and code and error message will be accessible through udm_error() and udm_errno().

  • UDM_ISPELL_TYPE_AFFIX - indicates that ispell data should be loaded from file and initiates loading affixes file. In this case val1 defines double letter language code for which affixes are loaded, and val2 - file path. Please note, that if a relative path entered, the module looks for the file not in UDM_CONF_DIR, but in relation to current path, i.e. to the path where the script is executed. In case of error in this mode, e.g. if file is absent, the function will return FALSE, and an error message will be displayed. Error message text cannot be accessed through udm_error() and udm_errno(), since those functions can only return messages associated with SQL. Please, see flag parameter description in UDM_ISPELL_TYPE_DB.

    Örnek 1 udm_load_ispell_data() example

    <?php
    if ((! udm_load_ispell_data($udm, UDM_ISPELL_TYPE_AFFIX, 'en', '/opt/ispell/en.aff', 0)) ||
        (!     udm_load_ispell_data($udm, UDM_ISPELL_TYPE_AFFIX, 'ru', '/opt/ispell/ru.aff', 0)) ||
        (!     udm_load_ispell_data($udm, UDM_ISPELL_TYPE_SPELL, 'en', '/opt/ispell/en.dict', 0)) ||
        (!     udm_load_ispell_data($udm, UDM_ISPELL_TYPE_SPELL, 'ru', '/opt/ispell/ru.dict', 1))) {
        exit;
    }
    ?>

    Bilginize:

    flag is equal to 1 only in the last call.

  • UDM_ISPELL_TYPE_SPELL - indicates that ispell data should be loaded from file and initiates loading of ispell dictionary file. In this case val1 defines double letter language code for which affixes are loaded, and val2 - file path. Please note, that if a relative path entered, the module looks for the file not in UDM_CONF_DIR, but in relation to current path, i.e. to the path where the script is executed. In case of error in this mode, e.g. if file is absent, the function will return FALSE, and an error message will be displayed. Error message text cannot be accessed through udm_error() and udm_errno(), since those functions can only return messages associated with SQL. Please, see flag parameter description in UDM_ISPELL_TYPE_DB.

    <?php
    if ((! udm_load_ispell_data($udm, UDM_ISPELL_TYPE_AFFIX, 'en', '/opt/ispell/en.aff', 0)) ||
       (!     udm_load_ispell_data($udm, UDM_ISPELL_TYPE_AFFIX, 'ru', '/opt/ispell/ru.aff', 0)) ||
       (!     udm_load_ispell_data($udm, UDM_ISPELL_TYPE_SPELL, 'en', '/opt/ispell/en.dict', 0)) ||
       (!     udm_load_ispell_data($udm, UDM_ISPELL_TYPE_SPELL, 'ru', '/opt/ispell/ru.dict', 1))) {
     exit;
     }
    ?>

    Bilginize:

    flag is equal to 1 only in the last call.

  • UDM_ISPELL_TYPE_SERVER - enables spell server support. val1 parameter indicates address of the host running spell server. val2 ` is not used yet, but in future releases it is going to indicate number of port used by spell server. flag parameter in this case is not needed since ispell data is stored on spellserver already sorted.

    Spelld server reads spell-data from a separate configuration file (/usr/local/mnogosearch/etc/spelld.conf by default), sorts it and stores in memory. With clients server communicates in two ways: to indexer all the data is transferred (so that indexer starts faster), from search.cgi server receives word to normalize and then passes over to client (search.cgi) list of normalized word forms. This allows fastest, compared to db and text modes processing of search queries (by omitting loading and sorting all the spell data).

    udm_load_ispell_data() function in UDM_ISPELL_TYPE_SERVER mode does not actually load ispell data, but only defines server address. In fact, server is automatically used by udm_find() function when performing search. In case of errors, e.g. if spellserver is not running or invalid host indicated, there are no messages returned and ispell conversion does not work.

    Bilginize:

    This function is available in mnoGoSearch 3.1.12 or later.

    Example:
    <?php
    if (!udm_load_ispell_data($udm, UDM_ISPELL_TYPE_SERVER, '', '', 1)) {
        echo     "Error loading ispell data from server<br />\n";
        exit;
    }
    ?>

The fastest mode is UDM_ISPELL_TYPE_SERVER. UDM_ISPELL_TYPE_TEXT is slower and UDM_ISPELL_TYPE_DB is the slowest. The above pattern is TRUE for mnoGoSearch 3.1.10 - 3.1.11. It is planned to speed up DB mode in future versions and it is going to be faster than TEXT mode.

val1

val2

flag

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 2 udm_load_ispell_data() example

<?php
if (! udm_load_ispell_data($udm, UDM_ISPELL_TYPE_DB, '', '', 1)) {
  printf("Error #%d: '%s'\n", udm_errno($udm), udm_error($udm));
  exit;
}
?>

udm_hash32
udm_set_agent_param
mnoGoSearch İşlevleri


Set mnoGoSearch agent session parameters

udm_load_ispell_data
Solr
mnoGoSearch İşlevleri
PHP Manual

udm_set_agent_param

(PHP 4 >= 4.0.5, PHP 5 <= 5.0.5, PECL mnogosearch >= 1.0.0)

udm_set_agent_param — Set mnoGoSearch agent session parameters

Açıklama

bool udm_set_agent_param ( resource $agent , int $var , string $val )

Defines mnoGoSearch session parameters.

Değiştirgeler

agent

A link to Agent, received after call to udm_alloc_agent().

var

The following parameters and their values are available:

  • UDM_PARAM_PAGE_NUM - used to choose search results page number (results are returned by pages beginning from 0, with UDM_PARAM_PAGE_SIZE results per page).
  • UDM_PARAM_PAGE_SIZE - number of search results displayed on one page.
  • UDM_PARAM_SEARCH_MODE - search mode. The following values available: UDM_MODE_ALL - search for all words; UDM_MODE_ANY - search for any word; UDM_MODE_PHRASE - phrase search; UDM_MODE_BOOL - boolean search. See udm_find() for details on boolean search.
  • UDM_PARAM_CACHE_MODE - turns on or off search result cache mode. When enabled, the search engine will store search results to disk. In case a similar search is performed later, the engine will take results from the cache for faster performance. Available values: UDM_CACHE_ENABLED, UDM_CACHE_DISABLED.
  • UDM_PARAM_TRACK_MODE - turns on or off trackquery mode. Since version 3.1.2 mnoGoSearch has a query tracking support. Note that tracking is implemented in SQL version only and not available in built-in database. To use tracking, you have to create tables for tracking support. For MySQL, use create/mysql/track.txt. When doing a search, front-end uses those tables to store query words, a number of found documents and current Unix timestamp in seconds. Available values: UDM_TRACK_ENABLED, UDM_TRACK_DISABLED.
  • UDM_PARAM_PHRASE_MODE - defines whether index database using phrases ("phrase" parameter in indexer.conf). Possible values: UDM_PHRASE_ENABLED and UDM_PHRASE_DISABLED. Please note, that if phrase search is enabled (UDM_PHRASE_ENABLED), it is still possible to do search in any mode (ANY, ALL, BOOL or PHRASE). In 3.1.10 version of mnoGoSearch phrase search is supported only in sql and built-in database modes, while beginning with 3.1.11 phrases are supported in cachemode as well. Examples of phrase search: "Arizona desert" - This query returns all indexed documents that contain "Arizona desert" as a phrase. Notice that you need to put double quotes around the phrase
  • UDM_PARAM_CHARSET - defines local charset. Available values: set of charsets supported by mnoGoSearch, e.g. koi8-r, cp1251, ...
  • UDM_PARAM_STOPFILE - Defines name and path to stopwords file. (There is a small difference with mnoGoSearch - while in mnoGoSearch if relative path or no path entered, it looks for this file in relation to UDM_CONF_DIR, the module looks for the file in relation to current path, i.e. to the path where the PHP script is executed.)
  • UDM_PARAM_STOPTABLE - Load stop words from the given SQL table. You may use several StopwordTable commands. This command has no effect when compiled without SQL database support.
  • UDM_PARAM_WEIGHT_FACTOR - represents weight factors for specific document parts. Currently body, title, keywords, description, url are supported. To activate this feature please use degrees of 2 in *Weight commands of the indexer.conf. Let's imagine that we have these weights:
          URLWeight     1
      BodyWeight    2
      TitleWeight   4
      KeywordWeight 8
      DescWeight    16
    As far as indexer uses bit OR operation for word weights when some word presents several time in the same document, it is possible at search time to detect word appearance in different document parts. Word which appears only in the body will have 00000010 aggregate weight (in binary notation). Word used in all document parts will have 00011111 aggregate weight. This parameter's value is a string of hex digits ABCDE. Each digit is a factor for corresponding bit in word weight. For the given above weights configuration:
           E is a factor for weight 1  (URL Weight bit)
       D is a factor for weight 2  (BodyWeight bit)
       C is a factor for weight 4  (TitleWeight bit)
       B is a factor for weight 8  (KeywordWeight bit)
       A is a factor for weight 16 (DescWeight bit)
    Examples: UDM_PARAM_WEIGHT_FACTOR=00001 will search through URLs only. UDM_PARAM_WEIGHT_FACTOR=00100 will search through Titles only. UDM_PARAM_WEIGHT_FACTOR=11100 will search through Title,Keywords,Description but not through URL and Body. UDM_PARAM_WEIGHT_FACTOR=F9421 will search through:
            Description with factor 15  (F hex)
        Keywords with factor 9
        Title with factor  4
        Body with factor 2
        URL with factor 1
    If UDM_PARAM_WEIGHT_FACTOR variable is omitted, original weight value is taken to sort results. For a given above weight configuration it means that document description has a most big weight 16.
  • UDM_PARAM_WORD_MATCH - word match. You may use this parameter to choose word match type. This feature works only in "single" and "multi" modes using SQL based and built-in database. It does not work in cachemode and other modes since they use word CRC and do not support substring search. Available values: UDM_MATCH_BEGIN - word beginning match; UDM_MATCH_END - word ending match; UDM_MATCH_WORD - whole word match; UDM_MATCH_SUBSTR - word substring match.
  • UDM_PARAM_MIN_WORD_LEN - defines minimal word length. Any word shorter this limit is considered to be a stopword. Please note that this parameter value is inclusive, i.e. if UDM_PARAM_MIN_WORD_LEN=3, a word 3 characters long will not be considered a stopword, while a word 2 characters long will be. Default value is 1.
  • UDM_PARAM_ISPELL_PREFIXES - Possible values: UDM_PREFIXES_ENABLED and UDM_PREFIXES_DISABLED, that respectively enable or disable using prefixes. E.g. if a word "tested" is in search query, also words like "test", "testing", etc. Only suffixes are supported by default. Prefixes usually change word meanings, for example if somebody is searching for the word "tested" one hardly wants "untested" to be found. Prefixes support may also be found useful for site's spelling checking purposes. In order to enable ispell, you have to load ispell data with udm_load_ispell_data().
  • UDM_PARAM_CROSS_WORDS - enables or disables crosswords support. Possible values: UDM_CROSS_WORDS_ENABLED and UDM_CROSS_WORDS_DISABLED. The crosswords feature allows to assign words between <a href="xxx"> and </a> also to a document this link leads to. It works in SQL database mode and is not supported in built-in database and Cachemode.
  • UDM_PARAM_VARDIR - specifies a custom path to directory where indexer stores data when using built-in database and in cache mode. By default /var directory of mnoGoSearch installation is used. Can have only string values.

val

Sürüm Bilgisi

Sürüm: | Açıklama
4.1.0 | UDM_PARAM_VARDIR was added.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

Bilginize: Crosswords are supported only in mnoGoSearch 3.1.11 or later.

udm_load_ispell_data
Solr
mnoGoSearch İşlevleri


Apache Solr

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Solr İşlevleri
    • solr_get_version — Returns the current version of the Apache Solr extension
  • Örnekler
  • SolrUtils — The SolrUtils class
    • SolrUtils::digestXmlResponse — Parses an response XML string into a SolrObject
    • SolrUtils::escapeQueryChars — Escapes a lucene query string
    • SolrUtils::getSolrVersion — Returns the current version of the Solr extension
    • SolrUtils::queryPhrase — Prepares a phrase from an unescaped lucene string
  • SolrInputDocument — The SolrInputDocument class
    • SolrInputDocument::addChildDocument — Adds a child document for block indexing
    • SolrInputDocument::addChildDocuments — Adds an array of child documents
    • SolrInputDocument::addField — Adds a field to the document
    • SolrInputDocument::clear — Resets the input document
    • SolrInputDocument::__clone — Creates a copy of a SolrDocument
    • SolrInputDocument::__construct — Constructor
    • SolrInputDocument::deleteField — Removes a field from the document
    • SolrInputDocument::__destruct — Destructor
    • SolrInputDocument::fieldExists — Checks if a field exists
    • SolrInputDocument::getBoost — Retrieves the current boost value for the document
    • SolrInputDocument::getChildDocuments — Returns an array of child documents (SolrInputDocument)
    • SolrInputDocument::getChildDocumentsCount — Returns the number of child documents
    • SolrInputDocument::getField — Retrieves a field by name
    • SolrInputDocument::getFieldBoost — Retrieves the boost value for a particular field
    • SolrInputDocument::getFieldCount — Returns the number of fields in the document
    • SolrInputDocument::getFieldNames — Returns an array containing all the fields in the document
    • SolrInputDocument::hasChildDocuments — Returns true if the document has any child documents
    • SolrInputDocument::merge — Merges one input document into another
    • SolrInputDocument::reset — This is an alias of SolrInputDocument::clear
    • SolrInputDocument::setBoost — Sets the boost value for this document
    • SolrInputDocument::setFieldBoost — Sets the index-time boost value for a field
    • SolrInputDocument::sort — Sorts the fields within the document
    • SolrInputDocument::toArray — Returns an array representation of the input document
  • SolrDocument — The SolrDocument class
    • SolrDocument::addField — Adds a field to the document
    • SolrDocument::clear — Drops all the fields in the document
    • SolrDocument::__clone — Creates a copy of a SolrDocument object
    • SolrDocument::__construct — Constructor
    • SolrDocument::current — Retrieves the current field
    • SolrDocument::deleteField — Removes a field from the document
    • SolrDocument::__destruct — Destructor
    • SolrDocument::fieldExists — Checks if a field exists in the document
    • SolrDocument::__get — Access the field as a property
    • SolrDocument::getChildDocuments — Returns an array of child documents (SolrDocument)
    • SolrDocument::getChildDocumentsCount — Returns the number of child documents
    • SolrDocument::getField — Retrieves a field by name
    • SolrDocument::getFieldCount — Returns the number of fields in this document
    • SolrDocument::getFieldNames — Returns an array of fields names in the document
    • SolrDocument::getInputDocument — Returns a SolrInputDocument equivalent of the object
    • SolrDocument::hasChildDocuments — Checks whether the document has any child documents
    • SolrDocument::__isset — Checks if a field exists
    • SolrDocument::key — Retrieves the current key
    • SolrDocument::merge — Merges source to the current SolrDocument
    • SolrDocument::next — Moves the internal pointer to the next field
    • SolrDocument::offsetExists — Checks if a particular field exists
    • SolrDocument::offsetGet — Retrieves a field
    • SolrDocument::offsetSet — Adds a field to the document
    • SolrDocument::offsetUnset — Removes a field
    • SolrDocument::reset — This is an alias to SolrDocument::clear()
    • SolrDocument::rewind — Resets the internal pointer to the beginning
    • SolrDocument::serialize — Used for custom serialization
    • SolrDocument::__set — Adds another field to the document
    • SolrDocument::sort — Sorts the fields in the document
    • SolrDocument::toArray — Returns an array representation of the document
    • SolrDocument::unserialize — Custom serialization of SolrDocument objects
    • SolrDocument::__unset — Removes a field from the document
    • SolrDocument::valid — Checks if the current position internally is still valid
  • SolrDocumentField — The SolrDocumentField class
    • SolrDocumentField::__construct — Constructor
    • SolrDocumentField::__destruct — Destructor
  • SolrObject — The SolrObject class
    • SolrObject::__construct — Creates Solr object
    • SolrObject::__destruct — Destructor
    • SolrObject::getPropertyNames — Returns an array of all the names of the properties
    • SolrObject::offsetExists — Checks if the property exists
    • SolrObject::offsetGet — Used to retrieve a property
    • SolrObject::offsetSet — Sets the value for a property
    • SolrObject::offsetUnset — Unsets the value for the property
  • SolrClient — The SolrClient class
    • SolrClient::addDocument — Adds a document to the index
    • SolrClient::addDocuments — Adds a collection of SolrInputDocument instances to the index
    • SolrClient::commit — Finalizes all add/deletes made to the index
    • SolrClient::__construct — Constructor for the SolrClient object
    • SolrClient::deleteById — Delete by Id
    • SolrClient::deleteByIds — Deletes by Ids
    • SolrClient::deleteByQueries — Removes all documents matching any of the queries
    • SolrClient::deleteByQuery — Deletes all documents matching the given query
    • SolrClient::__destruct — Destructor for SolrClient
    • SolrClient::getById — Get Document By Id. Utilizes Solr Realtime Get (RTG).
    • SolrClient::getByIds — Get Documents by their Ids. Utilizes Solr Realtime Get (RTG).
    • SolrClient::getDebug — Returns the debug data for the last connection attempt
    • SolrClient::getOptions — Returns the client options set internally
    • SolrClient::optimize — Defragments the index
    • SolrClient::ping — Checks if Solr server is still up
    • SolrClient::query — Sends a query to the server
    • SolrClient::request — Sends a raw update request
    • SolrClient::rollback — Rollbacks all add/deletes made to the index since the last commit
    • SolrClient::setResponseWriter — Sets the response writer used to prepare the response from Solr
    • SolrClient::setServlet — Changes the specified servlet type to a new value
    • SolrClient::system — Retrieve Solr Server information
    • SolrClient::threads — Checks the threads status
  • SolrResponse — The SolrResponse class
    • SolrResponse::getDigestedResponse — Returns the XML response as serialized PHP data
    • SolrResponse::getHttpStatus — Returns the HTTP status of the response
    • SolrResponse::getHttpStatusMessage — Returns more details on the HTTP status
    • SolrResponse::getRawRequest — Returns the raw request sent to the Solr server
    • SolrResponse::getRawRequestHeaders — Returns the raw request headers sent to the Solr server
    • SolrResponse::getRawResponse — Returns the raw response from the server
    • SolrResponse::getRawResponseHeaders — Returns the raw response headers from the server
    • SolrResponse::getRequestUrl — Returns the full URL the request was sent to
    • SolrResponse::getResponse — Returns a SolrObject representing the XML response from the server
    • SolrResponse::setParseMode — Sets the parse mode
    • SolrResponse::success — Was the request a success
  • SolrQueryResponse — The SolrQueryResponse class
    • SolrQueryResponse::__construct — Constructor
    • SolrQueryResponse::__destruct — Destructor
  • SolrUpdateResponse — The SolrUpdateResponse class
    • SolrUpdateResponse::__construct — Constructor
    • SolrUpdateResponse::__destruct — Destructor
  • SolrPingResponse — The SolrPingResponse class
    • SolrPingResponse::__construct — Constructor
    • SolrPingResponse::__destruct — Destructor
    • SolrPingResponse::getResponse — Returns the response from the server
  • SolrGenericResponse — The SolrGenericResponse class
    • SolrGenericResponse::__construct — Constructor
    • SolrGenericResponse::__destruct — Destructor
  • SolrParams — The SolrParams class
    • SolrParams::add — This is an alias for SolrParams::addParam
    • SolrParams::addParam — Adds a parameter to the object
    • SolrParams::get — This is an alias for SolrParams::getParam
    • SolrParams::getParam — Returns a parameter value
    • SolrParams::getParams — Returns an array of non URL-encoded parameters
    • SolrParams::getPreparedParams — Returns an array of URL-encoded parameters
    • SolrParams::serialize — Used for custom serialization
    • SolrParams::set — An alias of SolrParams::setParam
    • SolrParams::setParam — Sets the parameter to the specified value
    • SolrParams::toString — Returns all the name-value pair parameters in the object
    • SolrParams::unserialize — Used for custom serialization
  • SolrModifiableParams — The SolrModifiableParams class
    • SolrModifiableParams::__construct — Constructor
    • SolrModifiableParams::__destruct — Destructor
  • SolrQuery — The SolrQuery class
    • SolrQuery::addExpandFilterQuery — Overrides main filter query, determines which documents to include in the main group.
    • SolrQuery::addExpandSortField — Orders the documents within the expanded groups (expand.sort parameter).
    • SolrQuery::addFacetDateField — Maps to facet.date
    • SolrQuery::addFacetDateOther — Adds another facet.date.other parameter
    • SolrQuery::addFacetField — Adds another field to the facet
    • SolrQuery::addFacetQuery — Adds a facet query
    • SolrQuery::addField — Specifies which fields to return in the result
    • SolrQuery::addFilterQuery — Specifies a filter query
    • SolrQuery::addGroupField — Add a field to be used to group results.
    • SolrQuery::addGroupFunction — Allows grouping results based on the unique values of a function query (group.func parameter).
    • SolrQuery::addGroupQuery — Allows grouping of documents that match the given query.
    • SolrQuery::addGroupSortField — Add a group sort field (group.sort parameter).
    • SolrQuery::addHighlightField — Maps to hl.fl
    • SolrQuery::addMltField — Sets a field to use for similarity
    • SolrQuery::addMltQueryField — Maps to mlt.qf
    • SolrQuery::addSortField — Used to control how the results should be sorted
    • SolrQuery::addStatsFacet — Requests a return of sub results for values within the given facet
    • SolrQuery::addStatsField — Maps to stats.field parameter
    • SolrQuery::collapse — Collapses the result set to a single document per group
    • SolrQuery::__construct — Constructor
    • SolrQuery::__destruct — Destructor
    • SolrQuery::getExpand — Returns true if group expanding is enabled
    • SolrQuery::getExpandFilterQueries — Returns the expand filter queries
    • SolrQuery::getExpandQuery — Returns the expand query expand.q parameter
    • SolrQuery::getExpandRows — Returns The number of rows to display in each group (expand.rows)
    • SolrQuery::getExpandSortFields — Returns an array of fields
    • SolrQuery::getFacet — Returns the value of the facet parameter
    • SolrQuery::getFacetDateEnd — Returns the value for the facet.date.end parameter
    • SolrQuery::getFacetDateFields — Returns all the facet.date fields
    • SolrQuery::getFacetDateGap — Returns the value of the facet.date.gap parameter
    • SolrQuery::getFacetDateHardEnd — Returns the value of the facet.date.hardend parameter
    • SolrQuery::getFacetDateOther — Returns the value for the facet.date.other parameter
    • SolrQuery::getFacetDateStart — Returns the lower bound for the first date range for all date faceting on this field
    • SolrQuery::getFacetFields — Returns all the facet fields
    • SolrQuery::getFacetLimit — Returns the maximum number of constraint counts that should be returned for the facet fields
    • SolrQuery::getFacetMethod — Returns the value of the facet.method parameter
    • SolrQuery::getFacetMinCount — Returns the minimum counts for facet fields should be included in the response
    • SolrQuery::getFacetMissing — Returns the current state of the facet.missing parameter
    • SolrQuery::getFacetOffset — Returns an offset into the list of constraints to be used for pagination
    • SolrQuery::getFacetPrefix — Returns the facet prefix
    • SolrQuery::getFacetQueries — Returns all the facet queries
    • SolrQuery::getFacetSort — Returns the facet sort type
    • SolrQuery::getFields — Returns the list of fields that will be returned in the response
    • SolrQuery::getFilterQueries — Returns an array of filter queries
    • SolrQuery::getGroup — Returns true if grouping is enabled
    • SolrQuery::getGroupCachePercent — Returns group cache percent value
    • SolrQuery::getGroupFacet — Returns the group.facet parameter value
    • SolrQuery::getGroupFields — Returns group fields (group.field parameter values)
    • SolrQuery::getGroupFormat — Returns the group.format value
    • SolrQuery::getGroupFunctions — Returns group functions (group.func parameter values)
    • SolrQuery::getGroupLimit — Returns the group.limit value
    • SolrQuery::getGroupMain — Returns the group.main value
    • SolrQuery::getGroupNGroups — Returns the group.ngroups value
    • SolrQuery::getGroupOffset — Returns the group.offset value
    • SolrQuery::getGroupQueries — Returns all the group.query parameter values
    • SolrQuery::getGroupSortFields — Returns the group.sort value
    • SolrQuery::getGroupTruncate — Returns the group.truncate value
    • SolrQuery::getHighlight — Returns the state of the hl parameter
    • SolrQuery::getHighlightAlternateField — Returns the highlight field to use as backup or default
    • SolrQuery::getHighlightFields — Returns all the fields that Solr should generate highlighted snippets for
    • SolrQuery::getHighlightFormatter — Returns the formatter for the highlighted output
    • SolrQuery::getHighlightFragmenter — Returns the text snippet generator for highlighted text
    • SolrQuery::getHighlightFragsize — Returns the number of characters of fragments to consider for highlighting
    • SolrQuery::getHighlightHighlightMultiTerm — Returns whether or not to enable highlighting for range/wildcard/fuzzy/prefix queries
    • SolrQuery::getHighlightMaxAlternateFieldLength — Returns the maximum number of characters of the field to return
    • SolrQuery::getHighlightMaxAnalyzedChars — Returns the maximum number of characters into a document to look for suitable snippets
    • SolrQuery::getHighlightMergeContiguous — Returns whether or not the collapse contiguous fragments into a single fragment
    • SolrQuery::getHighlightRegexMaxAnalyzedChars — Returns the maximum number of characters from a field when using the regex fragmenter
    • SolrQuery::getHighlightRegexPattern — Returns the regular expression for fragmenting
    • SolrQuery::getHighlightRegexSlop — Returns the deviation factor from the ideal fragment size
    • SolrQuery::getHighlightRequireFieldMatch — Returns if a field will only be highlighted if the query matched in this particular field
    • SolrQuery::getHighlightSimplePost — Returns the text which appears after a highlighted term
    • SolrQuery::getHighlightSimplePre — Returns the text which appears before a highlighted term
    • SolrQuery::getHighlightSnippets — Returns the maximum number of highlighted snippets to generate per field
    • SolrQuery::getHighlightUsePhraseHighlighter — Returns the state of the hl.usePhraseHighlighter parameter
    • SolrQuery::getMlt — Returns whether or not MoreLikeThis results should be enabled
    • SolrQuery::getMltBoost — Returns whether or not the query will be boosted by the interesting term relevance
    • SolrQuery::getMltCount — Returns the number of similar documents to return for each result
    • SolrQuery::getMltFields — Returns all the fields to use for similarity
    • SolrQuery::getMltMaxNumQueryTerms — Returns the maximum number of query terms that will be included in any generated query
    • SolrQuery::getMltMaxNumTokens — Returns the maximum number of tokens to parse in each document field that is not stored with TermVector support
    • SolrQuery::getMltMaxWordLength — Returns the maximum word length above which words will be ignored
    • SolrQuery::getMltMinDocFrequency — Returns the treshold frequency at which words will be ignored which do not occur in at least this many docs
    • SolrQuery::getMltMinTermFrequency — Returns the frequency below which terms will be ignored in the source document
    • SolrQuery::getMltMinWordLength — Returns the minimum word length below which words will be ignored
    • SolrQuery::getMltQueryFields — Returns the query fields and their boosts
    • SolrQuery::getQuery — Returns the main query
    • SolrQuery::getRows — Returns the maximum number of documents
    • SolrQuery::getSortFields — Returns all the sort fields
    • SolrQuery::getStart — Returns the offset in the complete result set
    • SolrQuery::getStats — Returns whether or not stats is enabled
    • SolrQuery::getStatsFacets — Returns all the stats facets that were set
    • SolrQuery::getStatsFields — Returns all the statistics fields
    • SolrQuery::getTerms — Returns whether or not the TermsComponent is enabled
    • SolrQuery::getTermsField — Returns the field from which the terms are retrieved
    • SolrQuery::getTermsIncludeLowerBound — Returns whether or not to include the lower bound in the result set
    • SolrQuery::getTermsIncludeUpperBound — Returns whether or not to include the upper bound term in the result set
    • SolrQuery::getTermsLimit — Returns the maximum number of terms Solr should return
    • SolrQuery::getTermsLowerBound — Returns the term to start at
    • SolrQuery::getTermsMaxCount — Returns the maximum document frequency
    • SolrQuery::getTermsMinCount — Returns the minimum document frequency to return in order to be included
    • SolrQuery::getTermsPrefix — Returns the term prefix
    • SolrQuery::getTermsReturnRaw — Whether or not to return raw characters
    • SolrQuery::getTermsSort — Returns an integer indicating how terms are sorted
    • SolrQuery::getTermsUpperBound — Returns the term to stop at
    • SolrQuery::getTimeAllowed — Returns the time in milliseconds allowed for the query to finish
    • SolrQuery::removeExpandFilterQuery — Removes an expand filter query
    • SolrQuery::removeExpandSortField — Removes an expand sort field from the expand.sort parameter.
    • SolrQuery::removeFacetDateField — Removes one of the facet date fields
    • SolrQuery::removeFacetDateOther — Removes one of the facet.date.other parameters
    • SolrQuery::removeFacetField — Removes one of the facet.date parameters
    • SolrQuery::removeFacetQuery — Removes one of the facet.query parameters
    • SolrQuery::removeField — Removes a field from the list of fields
    • SolrQuery::removeFilterQuery — Removes a filter query
    • SolrQuery::removeHighlightField — Removes one of the fields used for highlighting
    • SolrQuery::removeMltField — Removes one of the moreLikeThis fields
    • SolrQuery::removeMltQueryField — Removes one of the moreLikeThis query fields
    • SolrQuery::removeSortField — Removes one of the sort fields
    • SolrQuery::removeStatsFacet — Removes one of the stats.facet parameters
    • SolrQuery::removeStatsField — Removes one of the stats.field parameters
    • SolrQuery::setEchoHandler — Toggles the echoHandler parameter
    • SolrQuery::setEchoParams — Determines what kind of parameters to include in the response
    • SolrQuery::setExpand — Enables/Disables the Expand Component
    • SolrQuery::setExpandQuery — Sets the expand.q parameter
    • SolrQuery::setExpandRows — Sets the number of rows to display in each group (expand.rows). Server Default 5
    • SolrQuery::setExplainOther — Sets the explainOther common query parameter
    • SolrQuery::setFacet — Maps to the facet parameter. Enables or disables facetting
    • SolrQuery::setFacetDateEnd — Maps to facet.date.end
    • SolrQuery::setFacetDateGap — Maps to facet.date.gap
    • SolrQuery::setFacetDateHardEnd — Maps to facet.date.hardend
    • SolrQuery::setFacetDateStart — Maps to facet.date.start
    • SolrQuery::setFacetEnumCacheMinDefaultFrequency — Sets the minimum document frequency used for determining term count
    • SolrQuery::setFacetLimit — Maps to facet.limit
    • SolrQuery::setFacetMethod — Specifies the type of algorithm to use when faceting a field
    • SolrQuery::setFacetMinCount — Maps to facet.mincount
    • SolrQuery::setFacetMissing — Maps to facet.missing
    • SolrQuery::setFacetOffset — Sets the offset into the list of constraints to allow for pagination
    • SolrQuery::setFacetPrefix — Specifies a string prefix with which to limits the terms on which to facet
    • SolrQuery::setFacetSort — Determines the ordering of the facet field constraints
    • SolrQuery::setGroup — Enable/Disable result grouping (group parameter)
    • SolrQuery::setGroupCachePercent — Enables caching for result grouping
    • SolrQuery::setGroupFacet — Sets group.facet parameter
    • SolrQuery::setGroupFormat — Sets the group format, result structure (group.format parameter).
    • SolrQuery::setGroupLimit — Specifies the number of results to return for each group. The server default value is 1.
    • SolrQuery::setGroupMain — If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple.
    • SolrQuery::setGroupNGroups — If true, Solr includes the number of groups that have matched the query in the results.
    • SolrQuery::setGroupOffset — Sets the group.offset parameter.
    • SolrQuery::setGroupTruncate — If true, facet counts are based on the most relevant document of each group matching the query.
    • SolrQuery::setHighlight — Enables or disables highlighting
    • SolrQuery::setHighlightAlternateField — Specifies the backup field to use
    • SolrQuery::setHighlightFormatter — Specify a formatter for the highlight output
    • SolrQuery::setHighlightFragmenter — Sets a text snippet generator for highlighted text
    • SolrQuery::setHighlightFragsize — The size of fragments to consider for highlighting
    • SolrQuery::setHighlightHighlightMultiTerm — Use SpanScorer to highlight phrase terms
    • SolrQuery::setHighlightMaxAlternateFieldLength — Sets the maximum number of characters of the field to return
    • SolrQuery::setHighlightMaxAnalyzedChars — Specifies the number of characters into a document to look for suitable snippets
    • SolrQuery::setHighlightMergeContiguous — Whether or not to collapse contiguous fragments into a single fragment
    • SolrQuery::setHighlightRegexMaxAnalyzedChars — Specify the maximum number of characters to analyze
    • SolrQuery::setHighlightRegexPattern — Specify the regular expression for fragmenting
    • SolrQuery::setHighlightRegexSlop — Sets the factor by which the regex fragmenter can stray from the ideal fragment size
    • SolrQuery::setHighlightRequireFieldMatch — Require field matching during highlighting
    • SolrQuery::setHighlightSimplePost — Sets the text which appears after a highlighted term
    • SolrQuery::setHighlightSimplePre — Sets the text which appears before a highlighted term
    • SolrQuery::setHighlightSnippets — Sets the maximum number of highlighted snippets to generate per field
    • SolrQuery::setHighlightUsePhraseHighlighter — Whether to highlight phrase terms only when they appear within the query phrase
    • SolrQuery::setMlt — Enables or disables moreLikeThis
    • SolrQuery::setMltBoost — Set if the query will be boosted by the interesting term relevance
    • SolrQuery::setMltCount — Set the number of similar documents to return for each result
    • SolrQuery::setMltMaxNumQueryTerms — Sets the maximum number of query terms included
    • SolrQuery::setMltMaxNumTokens — Specifies the maximum number of tokens to parse
    • SolrQuery::setMltMaxWordLength — Sets the maximum word length
    • SolrQuery::setMltMinDocFrequency — Sets the mltMinDoc frequency
    • SolrQuery::setMltMinTermFrequency — Sets the frequency below which terms will be ignored in the source docs
    • SolrQuery::setMltMinWordLength — Sets the minimum word length
    • SolrQuery::setOmitHeader — Exclude the header from the returned results
    • SolrQuery::setQuery — Sets the search query
    • SolrQuery::setRows — Specifies the maximum number of rows to return in the result
    • SolrQuery::setShowDebugInfo — Flag to show debug information
    • SolrQuery::setStart — Specifies the number of rows to skip
    • SolrQuery::setStats — Enables or disables the Stats component
    • SolrQuery::setTerms — Enables or disables the TermsComponent
    • SolrQuery::setTermsField — Sets the name of the field to get the Terms from
    • SolrQuery::setTermsIncludeLowerBound — Include the lower bound term in the result set
    • SolrQuery::setTermsIncludeUpperBound — Include the upper bound term in the result set
    • SolrQuery::setTermsLimit — Sets the maximum number of terms to return
    • SolrQuery::setTermsLowerBound — Specifies the Term to start from
    • SolrQuery::setTermsMaxCount — Sets the maximum document frequency
    • SolrQuery::setTermsMinCount — Sets the minimum document frequency
    • SolrQuery::setTermsPrefix — Restrict matches to terms that start with the prefix
    • SolrQuery::setTermsReturnRaw — Return the raw characters of the indexed term
    • SolrQuery::setTermsSort — Specifies how to sort the returned terms
    • SolrQuery::setTermsUpperBound — Sets the term to stop at
    • SolrQuery::setTimeAllowed — The time allowed for search to finish
  • SolrDisMaxQuery — The SolrDisMaxQuery class
    • SolrDisMaxQuery::addBigramPhraseField — Adds a Phrase Bigram Field (pf2 parameter)
    • SolrDisMaxQuery::addBoostQuery — Adds a boost query field with value and optional boost (bq parameter)
    • SolrDisMaxQuery::addPhraseField — Adds a Phrase Field (pf parameter)
    • SolrDisMaxQuery::addQueryField — Add a query field with optional boost (qf parameter)
    • SolrDisMaxQuery::addTrigramPhraseField — Adds a Trigram Phrase Field (pf3 parameter)
    • SolrDisMaxQuery::addUserField — Adds a field to User Fields Parameter (uf)
    • SolrDisMaxQuery::__construct — Class Constructor
    • SolrDisMaxQuery::removeBigramPhraseField — Removes phrase bigram field (pf2 parameter)
    • SolrDisMaxQuery::removeBoostQuery — Removes a boost query partial by field name (bq)
    • SolrDisMaxQuery::removePhraseField — Removes a Phrase Field (pf parameter)
    • SolrDisMaxQuery::removeQueryField — Removes a Query Field (qf parameter)
    • SolrDisMaxQuery::removeTrigramPhraseField — Removes a Trigram Phrase Field (pf3 parameter)
    • SolrDisMaxQuery::removeUserField — Removes a field from The User Fields Parameter (uf)
    • SolrDisMaxQuery::setBigramPhraseFields — Sets Bigram Phrase Fields and their boosts (and slops) using pf2 parameter
    • SolrDisMaxQuery::setBigramPhraseSlop — Sets Bigram Phrase Slop (ps2 parameter)
    • SolrDisMaxQuery::setBoostFunction — Sets a Boost Function (bf parameter).
    • SolrDisMaxQuery::setBoostQuery — Directly Sets Boost Query Parameter (bq)
    • SolrDisMaxQuery::setMinimumMatch — Set Minimum "Should" Match (mm)
    • SolrDisMaxQuery::setPhraseFields — Sets Phrase Fields and their boosts (and slops) using pf2 parameter
    • SolrDisMaxQuery::setPhraseSlop — Sets the default slop on phrase queries (ps parameter)
    • SolrDisMaxQuery::setQueryAlt — Set Query Alternate (q.alt parameter)
    • SolrDisMaxQuery::setQueryPhraseSlop — specifies the amount of slop permitted on phrase queries explicitly included in the user's query string (qf parameter)
    • SolrDisMaxQuery::setTieBreaker — Sets Tie Breaker parameter (tie parameter)
    • SolrDisMaxQuery::setTrigramPhraseFields — Directly Sets Trigram Phrase Fields (pf3 parameter)
    • SolrDisMaxQuery::setTrigramPhraseSlop — Sets Trigram Phrase Slop (ps3 parameter)
    • SolrDisMaxQuery::setUserFields — Sets User Fields parameter (uf)
    • SolrDisMaxQuery::useDisMaxQueryParser — Switch QueryParser to be DisMax Query Parser
    • SolrDisMaxQuery::useEDisMaxQueryParser — Switch QueryParser to be EDisMax
  • SolrCollapseFunction — The SolrCollapseFunction class
    • SolrCollapseFunction::__construct — Constructor
    • SolrCollapseFunction::getField — Returns the field that is being collapsed on.
    • SolrCollapseFunction::getHint — Returns collapse hint
    • SolrCollapseFunction::getMax — Returns max parameter
    • SolrCollapseFunction::getMin — Returns min parameter
    • SolrCollapseFunction::getNullPolicy — Returns null policy
    • SolrCollapseFunction::getSize — Returns size parameter
    • SolrCollapseFunction::setField — Sets the field to collapse on
    • SolrCollapseFunction::setHint — Sets collapse hint
    • SolrCollapseFunction::setMax — Selects the group heads by the max value of a numeric field or function query.
    • SolrCollapseFunction::setMin — Sets the initial size of the collapse data structures when collapsing on a numeric field only
    • SolrCollapseFunction::setNullPolicy — Sets the NULL Policy
    • SolrCollapseFunction::setSize — Sets the initial size of the collapse data structures when collapsing on a numeric field only.
    • SolrCollapseFunction::__toString — Returns a string representing the constructed collapse function
  • SolrException — The SolrException class
    • SolrException::getInternalInfo — Returns internal information where the Exception was thrown
  • SolrClientException — The SolrClientException class
    • SolrClientException::getInternalInfo — Returns internal information where the Exception was thrown
  • SolrServerException — The SolrServerException class
    • SolrServerException::getInternalInfo — Returns internal information where the Exception was thrown
  • SolrIllegalArgumentException — The SolrIllegalArgumentException class
    • SolrIllegalArgumentException::getInternalInfo — Returns internal information where the Exception was thrown
  • SolrIllegalOperationException — The SolrIllegalOperationException class
    • SolrIllegalOperationException::getInternalInfo — Returns internal information where the Exception was thrown
  • SolrMissingMandatoryParameterException — The SolrMissingMandatoryParameterException class
udm_set_agent_param
Giriş
Arama Motoru Eklentileri


Giriş

The Solr extension allows you to communicate effectively with the Apache Solr Server in PHP.

The Solr extension is an extremely fast, light-weight, feature-rich library that allows PHP developers to communicate effectively with Solr server instances.

Versions 1.x of The PECL Extension supports Apache Solr Server 1.3-3.x

Versions 2.x of The PECL Extension supports Apache Solr Server 4.0+

There are built-in tools to add documents and make updates to the solr server.

It also contains tools that allows you to build advanced queries to the server when searching for documents.

Solr
Yapılandırma/Kurulum
Solr


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Solr


Gereksinimler

PHP version 5.2.11 or later is required.

The libxml and curl extensions must also be enabled for the Apache Solr extension to be available.

libxml2 2.6.31 or later is required.

libcurl 7.18.0 or later is also required.

The above library versions are required and attempting to hack the code to make it compile is strongly discouraged. It will fail, possibly with errors that could be hard to debug

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/solr.

For help and support, please visit the extension google group. » Apache Solr PHP Extension

Windows binaries (DLL files) for this PECL extension are available from the PECL website.

Bilginize:

The solr module can be compiled in debug mode by passing the --enable-solr-debug flag to configure

When building manually, be sure to include curl and libxml support within the build.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

SOLR_MAJOR_VERSION (integer)
SOLR_MINOR_VERSION (integer)
SOLR_PATCH_VERSION (integer)
SOLR_EXTENSION_VERSION (string)

Özkaynak Türleri
Solr İşlevleri
Solr


Solr İşlevleri

İçindekiler

  • solr_get_version — Returns the current version of the Apache Solr extension
Öntanımlı Sabitler
solr_get_version
Solr


Returns the current version of the Apache Solr extension

Solr İşlevleri
Örnekler
Solr İşlevleri
PHP Manual

solr_get_version

(PECL solr >= 0.9.1)

solr_get_version — Returns the current version of the Apache Solr extension

Açıklama

string solr_get_version ( void )

This function returns the current version of the extension as a string.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

It returns a string on success and FALSE on failure.

Hatalar/İstisnalar

This function throws no errors or exceptions.

Örnekler

Örnek 1 solr_get_version() example

<?php

$solr_version = solr_get_version();

print $solr_version;

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

0.9.6

Ayrıca Bakınız

  • SolrUtils::getSolrVersion() - Returns the current version of the Solr extension

Solr İşlevleri
Örnekler
Solr İşlevleri


Örnekler

Examples of how to use the Apache Solr extension in PHP

Örnek 1 Contents of the BootStrap file

<?php

/* Domain name of the Solr server */
define('SOLR_SERVER_HOSTNAME', 'solr.example.com');

/* Whether or not to run in secure mode */
define('SOLR_SECURE', true);

/* HTTP Port to connection */
define('SOLR_SERVER_PORT', ((SOLR_SECURE) ? 8443 : 8983));

/* HTTP Basic Authentication Username */
define('SOLR_SERVER_USERNAME', 'admin');

/* HTTP Basic Authentication password */
define('SOLR_SERVER_PASSWORD', 'changeit');

/* HTTP connection timeout */
/* This is maximum time in seconds allowed for the http data transfer operation. Default value is 30 seconds */
define('SOLR_SERVER_TIMEOUT', 10);

/* File name to a PEM-formatted private key + private certificate (concatenated in that order) */
define('SOLR_SSL_CERT', 'certs/combo.pem');

/* File name to a PEM-formatted private certificate only */
define('SOLR_SSL_CERT_ONLY', 'certs/solr.crt');

/* File name to a PEM-formatted private key */
define('SOLR_SSL_KEY', 'certs/solr.key');

/* Password for PEM-formatted private key file */
define('SOLR_SSL_KEYPASSWORD', 'StrongAndSecurePassword');

/* Name of file holding one or more CA certificates to verify peer with*/
define('SOLR_SSL_CAINFO', 'certs/cacert.crt');

/* Name of directory holding multiple CA certificates to verify peer with */
define('SOLR_SSL_CAPATH', 'certs/');

?>

Örnek 2 Adding a document to the index

<?php

include "bootstrap.php";

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$client = new SolrClient($options);

$doc = new SolrInputDocument();

$doc->addField('id', 334455);
$doc->addField('cat', 'Software');
$doc->addField('cat', 'Lucene');

$updateResponse = $client->addDocument($doc);

print_r($updateResponse->getResponse());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

SolrObject Object
(
    [responseHeader] => SolrObject Object
        (
            [status] => 0
            [QTime] => 446
        )

)

Örnek 3 Merging one document into another document

<?php

include "bootstrap.php";

$doc = new SolrDocument();

$second_doc = new SolrDocument();

$doc->addField('id', 1123);

$doc->features = "PHP Client Side";
$doc->features = "Fast development cycles";

$doc['cat'] = 'Software';
$doc['cat'] = 'Custom Search';
$doc->cat   = 'Information Technology';

$second_doc->addField('cat', 'Lucene Search');

$second_doc->merge($doc, true);

print_r($second_doc->toArray());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [document_boost] => 0
    [field_count] => 3
    [fields] => Array
        (
            [0] => SolrDocumentField Object
                (
                    [name] => cat
                    [boost] => 0
                    [values] => Array
                        (
                            [0] => Software
                            [1] => Custom Search
                            [2] => Information Technology
                        )

                )

            [1] => SolrDocumentField Object
                (
                    [name] => id
                    [boost] => 0
                    [values] => Array
                        (
                            [0] => 1123
                        )

                )

            [2] => SolrDocumentField Object
                (
                    [name] => features
                    [boost] => 0
                    [values] => Array
                        (
                            [0] => PHP Client Side
                            [1] => Fast development cycles
                        )

                )

        )

)

Örnek 4 Searching for documents - SolrObject responses

<?php

include "bootstrap.php";

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$client = new SolrClient($options);

$query = new SolrQuery();

$query->setQuery('lucene');

$query->setStart(0);

$query->setRows(50);

$query->addField('cat')->addField('features')->addField('id')->addField('timestamp');

$query_response = $client->query($query);

$response = $query_response->getResponse();

print_r($response);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

SolrObject Object
(
    [responseHeader] => SolrObject Object
        (
            [status] => 0
            [QTime] => 1
            [params] => SolrObject Object
                (
                    [wt] => xml
                    [rows] => 50
                    [start] => 0
                    [indent] => on
                    [q] => lucene
                    [fl] => cat,features,id,timestamp
                    [version] => 2.2
                )

        )

    [response] => SolrObject Object
        (
            [numFound] => 3
            [start] => 0
            [docs] => Array
                (
                    [0] => SolrObject Object
                        (
                            [cat] => Array
                                (
                                    [0] => Software
                                    [1] => Lucene
                                )

                            [id] => 334456
                        )

                    [1] => SolrObject Object
                        (
                            [cat] => Array
                                (
                                    [0] => Software
                                    [1] => Lucene
                                )

                            [id] => 334455
                        )

                    [2] => SolrObject Object
                        (
                            [cat] => Array
                                (
                                    [0] => software
                                    [1] => search
                                )

                            [features] => Array
                                (
                                    [0] => Advanced Full-Text Search Capabilities using Lucene
                                    [1] => Optimized for High Volume Web Traffic
                                    [2] => Standards Based Open Interfaces - XML and HTTP
                                    [3] => Comprehensive HTML Administration Interfaces
                                    [4] => Scalability - Efficient Replication to other Solr Search Servers
                                    [5] => Flexible and Adaptable with XML configuration and Schema
                                    [6] => Good unicode support: héllo (hello with an accent over the e)
                                )

                            [id] => SOLR1000
                            [timestamp] => 2009-09-04T20:38:55.906
                        )

                )

        )

)

Örnek 5 Searching for documents - SolrDocument responses

<?php

include "bootstrap.php";

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$client = new SolrClient($options);

$query = new SolrQuery();

$query->setQuery('lucene');

$query->setStart(0);

$query->setRows(50);

$query->addField('cat')->addField('features')->addField('id')->addField('timestamp');

$query_response = $client->query($query);

$query_response->setParseMode(SolrQueryResponse::PARSE_SOLR_DOC);

$response = $query_response->getResponse();

print_r($response);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

SolrObject Object
(
    [responseHeader] => SolrObject Object
        (
            [status] => 0
            [QTime] => 1
            [params] => SolrObject Object
                (
                    [wt] => xml
                    [rows] => 50
                    [start] => 0
                    [indent] => on
                    [q] => lucene
                    [fl] => cat,features,id,timestamp
                    [version] => 2.2
                )

        )

    [response] => SolrObject Object
        (
            [numFound] => 3
            [start] => 0
            [docs] => Array
                (
                    [0] => SolrDocument Object
                        (
                            [_hashtable_index:SolrDocument:private] => 19740
                        )

                    [1] => SolrDocument Object
                        (
                            [_hashtable_index:SolrDocument:private] => 25485
                        )

                    [2] => SolrDocument Object
                        (
                            [_hashtable_index:SolrDocument:private] => 25052
                        )

                )

        )

)

Örnek 6 Simple TermsComponent example - basic

<?php

include "bootstrap.php";

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$client = new SolrClient($options);

$query = new SolrQuery();

$query->setTerms(true);

$query->setTermsField('cat');

$updateResponse = $client->query($query);

print_r($updateResponse->getResponse());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

SolrObject Object
(
    [responseHeader] => SolrObject Object
        (
            [status] => 0
            [QTime] => 2
        )

    [terms] => SolrObject Object
        (
            [cat] => SolrObject Object
                (
                    [electronics] => 14
                    [Lucene] => 4
                    [Software] => 4
                    [memory] => 3
                    [card] => 2
                    [connector] => 2
                    [drive] => 2
                    [graphics] => 2
                    [hard] => 2
                    [monitor] => 2
                )

        )

)

Örnek 7 Simple TermsComponent example - using a prefix

<?php

include "bootstrap.php";

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$client = new SolrClient($options);

$query = new SolrQuery();

$query->setTerms(true);

/* Return only terms starting with $prefix */
$prefix = 'c';

$query->setTermsField('cat')->setTermsPrefix($prefix);

$updateResponse = $client->query($query);

print_r($updateResponse->getResponse());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

SolrObject Object
(
    [responseHeader] => SolrObject Object
        (
            [status] => 0
            [QTime] => 1
        )

    [terms] => SolrObject Object
        (
            [cat] => SolrObject Object
                (
                    [card] => 2
                    [connector] => 2
                    [camera] => 1
                    [copier] => 1
                )

        )

)

Örnek 8 Simple TermsComponent example - specifying a minimum frequency

<?php

include "bootstrap.php";

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$client = new SolrClient($options);

$query = new SolrQuery();

$query->setTerms(true);

/* Return only terms starting with $prefix */
$prefix = 'c';

/* Return only terms with a frequency of 2 or greater */
$min_frequency = 2;

$query->setTermsField('cat')->setTermsPrefix($prefix)->setTermsMinCount($min_frequency);

$updateResponse = $client->query($query);

print_r($updateResponse->getResponse());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

SolrObject Object
(
    [responseHeader] => SolrObject Object
        (
            [status] => 0
            [QTime] => 0
        )

    [terms] => SolrObject Object
        (
            [cat] => SolrObject Object
                (
                    [card] => 2
                    [connector] => 2
                )

        )

)

Örnek 9 Simple Facet Example

<?php

include "bootstrap.php";

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$client = new SolrClient($options);

$query = new SolrQuery('*:*');

$query->setFacet(true);

$query->addFacetField('cat')->addFacetField('name')->setFacetMinCount(2);

$updateResponse = $client->query($query);

$response_array = $updateResponse->getResponse();

$facet_data = $response_array->facet_counts->facet_fields;

print_r($facet_data);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

SolrObject Object
(
    [cat] => SolrObject Object
        (
            [electronics] => 14
            [memory] => 3
            [Lucene] => 2
            [Software] => 2
            [card] => 2
            [connector] => 2
            [drive] => 2
            [graphics] => 2
            [hard] => 2
            [monitor] => 2
            [search] => 2
            [software] => 2
        )

    [name] => SolrObject Object
        (
            [gb] => 6
            [1] => 3
            [184] => 3
            [2] => 3
            [3200] => 3
            [400] => 3
            [500] => 3
            [ddr] => 3
            [i] => 3
            [ipod] => 3
            [memori] => 3
            [pc] => 3
            [pin] => 3
            [pod] => 3
            [sdram] => 3
            [system] => 3
            [unbuff] => 3
            [canon] => 2
            [corsair] => 2
            [drive] => 2
            [hard] => 2
            [mb] => 2
            [n] => 2
            [power] => 2
            [retail] => 2
            [video] => 2
            [x] => 2
        )

)

Örnek 10 Simple Facet Example - with optional field override for mincount

<?php

include "bootstrap.php";

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$client = new SolrClient($options);

$query = new SolrQuery('*:*');

$query->setFacet(true);

$query->addFacetField('cat')->addFacetField('name')->setFacetMinCount(2)->setFacetMinCount(4, 'name');

$updateResponse = $client->query($query);

$response_array = $updateResponse->getResponse();

$facet_data = $response_array->facet_counts->facet_fields;

print_r($facet_data);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

SolrObject Object
(
    [cat] => SolrObject Object
        (
            [electronics] => 14
            [memory] => 3
            [Lucene] => 2
            [Software] => 2
            [card] => 2
            [connector] => 2
            [drive] => 2
            [graphics] => 2
            [hard] => 2
            [monitor] => 2
            [search] => 2
            [software] => 2
        )

    [name] => SolrObject Object
        (
            [gb] => 6
        )

)

Örnek 11 Facet Date Example

<?php

include "bootstrap.php";

$options = array
(
        'hostname' => SOLR_SERVER_HOSTNAME,
        'login'    => SOLR_SERVER_USERNAME,
        'password' => SOLR_SERVER_PASSWORD,
        'port'     => SOLR_SERVER_PORT,
);

$client = new SolrClient($options);

$query = new SolrQuery('*:*');

$query->setFacet(true);

$query->addFacetDateField('manufacturedate_dt');

$query->setFacetDateStart('2006-02-13T00:00:00Z');

$query->setFacetDateEnd('2012-02-13T00:00:00Z');

$query->setFacetDateGap('+1YEAR');

$query->setFacetDateHardEnd(1);

$query->addFacetDateOther('before');

$updateResponse = $client->query($query);

$response_array = $updateResponse->getResponse();

$facet_data = $response_array->facet_counts->facet_dates;

print_r($facet_data);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

SolrObject Object
(
    [manufacturedate_dt] => SolrObject Object
        (
            [2006-02-13T00:00:00Z] => 9
            [2007-02-13T00:00:00Z] => 0
            [2008-02-13T00:00:00Z] => 0
            [2009-02-13T00:00:00Z] => 0
            [2010-02-13T00:00:00Z] => 0
            [2011-02-13T00:00:00Z] => 0
            [gap] => +1YEAR
            [start] => 2006-02-13T00:00:00Z
            [end] => 2012-02-13T00:00:00Z
            [before] => 2
        )

)

Örnek 12 Connecting to SSL-Enabled Server

<?php

include "bootstrap.php";

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
    'timeout'  => SOLR_SERVER_TIMEOUT,
    'secure'   => SOLR_SECURE,
    'ssl_cert' => SOLR_SSL_CERT_ONLY,
    'ssl_key'  => SOLR_SSL_KEY,
    'ssl_keypassword' => SOLR_SSL_KEYPASSWORD,
    'ssl_cainfo' => SOLR_SSL_CAINFO,
);

$client = new SolrClient($options);

$query = new SolrQuery('*:*');

$query->setFacet(true);

$query->addFacetField('cat')->addFacetField('name')->setFacetMinCount(2)->setFacetMinCount(4, 'name');

$updateResponse = $client->query($query);

$response_array = $updateResponse->getResponse();

$facet_data = $response_array->facet_counts->facet_fields;

print_r($facet_data);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

SolrObject Object
(
    [cat] => SolrObject Object
        (
            [electronics] => 14
            [memory] => 3
            [Lucene] => 2
            [Software] => 2
            [card] => 2
            [connector] => 2
            [drive] => 2
            [graphics] => 2
            [hard] => 2
            [monitor] => 2
            [search] => 2
            [software] => 2
        )

    [name] => SolrObject Object
        (
            [gb] => 6
        )

)

Örnek 13 Collapsing a SolrQuery

<?php
include "bootstrap.php";

$options = array
(
        'hostname' => SOLR_SERVER_HOSTNAME,
        'login'    => SOLR_SERVER_USERNAME,
        'password' => SOLR_SERVER_PASSWORD,
        'port'     => SOLR_SERVER_PORT,
        'path'     => SOLR_SERVER_PATH
);

$client = new SolrClient($options);

$query = new SolrQuery('*:*');

$collapseFunction = new SolrCollapseFunction('manu_id_s');

$collapseFunction
->setSize(2)
->setNullPolicy(SolrCollapseFunction::NULLPOLICY_IGNORE);

$query
->collapse($collapseFunction)
->setRows(4);

$queryResponse = $client->query($query);

$response = $queryResponse->getResponse();

print_r($response);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

SolrObject Object
(
    [responseHeader] => SolrObject Object
        (
            [status] => 0
            [QTime] => 1
            [params] => SolrObject Object
                (
                    [q] => *:*
                    [indent] => on
                    [fq] => {!collapse field=manu_id_s size=2 nullPolicy=ignore}
                    [rows] => 4
                    [version] => 2.2
                    [wt] => xml
                )

        )

    [response] => SolrObject Object
        (
            [numFound] => 14
            [start] => 0
            [docs] => Array
                (
                    [0] => SolrObject Object
                        (
                            [id] => SP2514N
                            [name] => Array
                                (
                                    [0] => Samsung SpinPoint P120 SP2514N - hard drive - 250 GB - ATA-133
                                )

                            [manu] => Array
                                (
                                    [0] => Samsung Electronics Co. Ltd.
                                )

                            [manu_id_s] => samsung
                            [cat] => Array
                                (
                                    [0] => electronics
                                    [1] => hard drive
                                )

                            [features] => Array
                                (
                                    [0] => 7200RPM, 8MB cache, IDE Ultra ATA-133
                                    [1] => NoiseGuard, SilentSeek technology, Fluid Dynamic Bearing (FDB) motor
                                )

                            [price] => Array
                                (
                                    [0] => 92
                                )

                            [popularity] => Array
                                (
                                    [0] => 6
                                )

                            [inStock] => Array
                                (
                                    [0] => 1
                                )

                            [manufacturedate_dt] => 2006-02-13T15:26:37Z
                            [store] => Array
                                (
                                    [0] => 35.0752,-97.032
                                )

                            [_version_] => 1510294336412057600
                        )

                    [1] => SolrObject Object
                        (
                            [id] => 6H500F0
                            [name] => Array
                                (
                                    [0] => Maxtor DiamondMax 11 - hard drive - 500 GB - SATA-300
                                )

                            [manu] => Array
                                (
                                    [0] => Maxtor Corp.
                                )

                            [manu_id_s] => maxtor
                            [cat] => Array
                                (
                                    [0] => electronics
                                    [1] => hard drive
                                )

                            [features] => Array
                                (
                                    [0] => SATA 3.0Gb/s, NCQ
                                    [1] => 8.5ms seek
                                    [2] => 16MB cache
                                )

                            [price] => Array
                                (
                                    [0] => 350
                                )

                            [popularity] => Array
                                (
                                    [0] => 6
                                )

                            [inStock] => Array
                                (
                                    [0] => 1
                                )

                            [store] => Array
                                (
                                    [0] => 45.17614,-93.87341
                                )

                            [manufacturedate_dt] => 2006-02-13T15:26:37Z
                            [_version_] => 1510294336449806336
                        )

                    [2] => SolrObject Object
                        (
                            [id] => F8V7067-APL-KIT
                            [name] => Array
                                (
                                    [0] => Belkin Mobile Power Cord for iPod w/ Dock
                                )

                            [manu] => Array
                                (
                                    [0] => Belkin
                                )

                            [manu_id_s] => belkin
                            [cat] => Array
                                (
                                    [0] => electronics
                                    [1] => connector
                                )

                            [features] => Array
                                (
                                    [0] => car power adapter, white
                                )

                            [weight] => Array
                                (
                                    [0] => 4
                                )

                            [price] => Array
                                (
                                    [0] => 19.95
                                )

                            [popularity] => Array
                                (
                                    [0] => 1
                                )

                            [inStock] => Array
                                (
                                    [0] =>
                                )

                            [store] => Array
                                (
                                    [0] => 45.18014,-93.87741
                                )

                            [manufacturedate_dt] => 2005-08-01T16:30:25Z
                            [_version_] => 1510294336458194944
                        )

                    [3] => SolrObject Object
                        (
                            [id] => MA147LL/A
                            [name] => Array
                                (
                                    [0] => Apple 60 GB iPod with Video Playback Black
                                )

                            [manu] => Array
                                (
                                    [0] => Apple Computer Inc.
                                )

                            [manu_id_s] => apple
                            [cat] => Array
                                (
                                    [0] => electronics
                                    [1] => music
                                )

                            [features] => Array
                                (
                                    [0] => iTunes, Podcasts, Audiobooks
                                    [1] => Stores up to 15,000 songs, 25,000 photos, or 150 hours of video
                                    [2] => 2.5-inch, 320x240 color TFT LCD display with LED backlight
                                    [3] => Up to 20 hours of battery life
                                    [4] => Plays AAC, MP3, WAV, AIFF, Audible, Apple Lossless, H.264 video
                                    [5] => Notes, Calendar, Phone book, Hold button, Date display, Photo wallet, Built-in games, JPEG photo playback, Upgradeable firmware, USB 2.0 compatibility, Playback speed control, Rechargeable capability, Battery level indication
                                )

                            [includes] => Array
                                (
                                    [0] => earbud headphones, USB cable
                                )

                            [weight] => Array
                                (
                                    [0] => 5.5
                                )

                            [price] => Array
                                (
                                    [0] => 399
                                )

                            [popularity] => Array
                                (
                                    [0] => 10
                                )

                            [inStock] => Array
                                (
                                    [0] => 1
                                )

                            [store] => Array
                                (
                                    [0] => 37.7752,-100.0232
                                )

                            [manufacturedate_dt] => 2005-10-12T08:00:00Z
                            [_version_] => 1510294336562003968
                        )

                )

        )

)

Örnek 14 Solr Real Time Get (RTG) example SolrClient::getById()

<?php

include "bootstrap.php";

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
    'path'     => SOLR_SERVER_PATH
);

$client = new SolrClient($options);
$response = $client->getById('GB18030TEST');
print_r($response->getResponse());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

SolrObject Object
(
    [doc] => SolrObject Object
        (
            [id] => GB18030TEST
            [name] => Array
                (
                    [0] => Test with some GB18030 encoded characters
                )

            [features] => Array
                (
                    [0] => No accents here
                    [1] => ??????
                    [2] => This is a feature (translated)
                    [3] => ?????????
                    [4] => This document is very shiny (translated)
                )

            [price] => Array
                (
                    [0] => 0
                )

            [inStock] => Array
                (
                    [0] => 1
                )

            [_version_] => 1510294336239042560
        )

)
solr_get_version
SolrUtils
Solr


The SolrUtils class

(PECL solr >= 0.9.2)

Giriş

Contains utility methods for retrieving the current extension version and preparing query phrases.

Also contains method for escaping query strings and parsing XML responses.

Sınıf Sözdizimi

abstract SolrUtils {
/* Yöntemler */
public static SolrObject digestXmlResponse ( string $xmlresponse [, int $parse_mode = 0 ] )
public static string escapeQueryChars ( string $str )
public static string getSolrVersion ( void )
public static string queryPhrase ( string $str )
}

İçindekiler

  • SolrUtils::digestXmlResponse — Parses an response XML string into a SolrObject
  • SolrUtils::escapeQueryChars — Escapes a lucene query string
  • SolrUtils::getSolrVersion — Returns the current version of the Solr extension
  • SolrUtils::queryPhrase — Prepares a phrase from an unescaped lucene string
Örnekler
SolrUtils::digestXmlResponse
Solr


Parses an response XML string into a SolrObject

SolrUtils
SolrUtils::escapeQueryChars
SolrUtils
PHP Manual

SolrUtils::digestXmlResponse

(PECL solr >= 0.9.2)

SolrUtils::digestXmlResponse — Parses an response XML string into a SolrObject

Açıklama

public static SolrObject SolrUtils::digestXmlResponse ( string $xmlresponse [, int $parse_mode = 0 ] )

This method parses an response XML string from the Apache Solr server into a SolrObject. It throws a SolrException if there was an error.

Değiştirgeler

xmlresponse

The XML response string from the Solr server.

parse_mode

Use SolrResponse::PARSE_SOLR_OBJ or SolrResponse::PARSE_SOLR_DOC

Dönen Değerler

Returns the SolrObject representing the XML response.

If the parse_mode parameter is set to SolrResponse::PARSE_SOLR_OBJ Solr documents will be parses as SolrObject instances.

If it is set to SolrResponse::PARSE_SOLR_DOC, they will be parsed as SolrDocument instances.

SolrUtils
SolrUtils::escapeQueryChars
SolrUtils


Escapes a lucene query string

SolrUtils::digestXmlResponse
SolrUtils::getSolrVersion
SolrUtils
PHP Manual

SolrUtils::escapeQueryChars

(PECL solr >= 0.9.2)

SolrUtils::escapeQueryChars — Escapes a lucene query string

Açıklama

public static string SolrUtils::escapeQueryChars ( string $str )

Lucene supports escaping special characters that are part of the query syntax.

The current list special characters are:

+ - && || ! ( ) { } [ ] ^ " ~ * ? : \ /

These characters are part of the query syntax and must be escaped

Değiştirgeler

str

This is the query string to be escaped.

Dönen Değerler

Returns the escaped string başarısızlık durumunda FALSE döner.

SolrUtils::digestXmlResponse
SolrUtils::getSolrVersion
SolrUtils


Returns the current version of the Solr extension

SolrUtils::escapeQueryChars
SolrUtils::queryPhrase
SolrUtils
PHP Manual

SolrUtils::getSolrVersion

(PECL solr >= 0.9.2)

SolrUtils::getSolrVersion — Returns the current version of the Solr extension

Açıklama

public static string SolrUtils::getSolrVersion ( void )

Returns the current Solr version.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current version of the Apache Solr extension.

SolrUtils::escapeQueryChars
SolrUtils::queryPhrase
SolrUtils


Prepares a phrase from an unescaped lucene string

SolrUtils::getSolrVersion
SolrInputDocument
SolrUtils
PHP Manual

SolrUtils::queryPhrase

(PECL solr >= 0.9.2)

SolrUtils::queryPhrase — Prepares a phrase from an unescaped lucene string

Açıklama

public static string SolrUtils::queryPhrase ( string $str )

Prepares a phrase from an unescaped lucene string.

Değiştirgeler

str

The lucene phrase.

Dönen Değerler

Returns the phrase contained in double quotes.

SolrUtils::getSolrVersion
SolrInputDocument
SolrUtils


The SolrInputDocument class

(PECL solr >= 0.9.2)

Giriş

This class represents a Solr document that is about to be submitted to the Solr index.

Sınıf Sözdizimi

final SolrInputDocument {
/* Sabitler */
const integer SORT_DEFAULT = 1 ;
const integer SORT_ASC = 1 ;
const integer SORT_DESC = 2 ;
const integer SORT_FIELD_NAME = 1 ;
const integer SORT_FIELD_VALUE_COUNT = 2 ;
const integer SORT_FIELD_BOOST_VALUE = 4 ;
/* Yöntemler */
public void addChildDocument ( SolrInputDocument $child )
public void addChildDocuments ( array &$docs )
public bool addField ( string $fieldName , string $fieldValue [, float $fieldBoostValue = 0.0 ] )
public bool clear ( void )
public void __clone ( void )
public __construct ( void )
public bool deleteField ( string $fieldName )
public void __destruct ( void )
public bool fieldExists ( string $fieldName )
public float getBoost ( void )
public array getChildDocuments ( void )
public integer getChildDocumentsCount ( void )
public SolrDocumentField getField ( string $fieldName )
public float getFieldBoost ( string $fieldName )
public int getFieldCount ( void )
public array getFieldNames ( void )
public boolean hasChildDocuments ( void )
public bool merge ( SolrInputDocument $sourceDoc [, bool $overwrite = true ] )
public bool reset ( void )
public bool setBoost ( float $documentBoostValue )
public bool setFieldBoost ( string $fieldName , float $fieldBoostValue )
public bool sort ( int $sortOrderBy [, int $sortDirection = SolrInputDocument::SORT_ASC ] )
public array toArray ( void )
}

Öntanımlı Sabitler

SolrInputDocument Class Constants

SolrInputDocument::SORT_DEFAULT

Sorts the fields in ascending order.

SolrInputDocument::SORT_ASC

Sorts the fields in ascending order.

SolrInputDocument::SORT_DESC

Sorts the fields in descending order.

SolrInputDocument::SORT_FIELD_NAME

Sorts the fields by name

SolrInputDocument::SORT_FIELD_VALUE_COUNT

Sorts the fields by number of values.

SolrInputDocument::SORT_FIELD_BOOST_VALUE

Sorts the fields by boost value.

İçindekiler

  • SolrInputDocument::addChildDocument — Adds a child document for block indexing
  • SolrInputDocument::addChildDocuments — Adds an array of child documents
  • SolrInputDocument::addField — Adds a field to the document
  • SolrInputDocument::clear — Resets the input document
  • SolrInputDocument::__clone — Creates a copy of a SolrDocument
  • SolrInputDocument::__construct — Constructor
  • SolrInputDocument::deleteField — Removes a field from the document
  • SolrInputDocument::__destruct — Destructor
  • SolrInputDocument::fieldExists — Checks if a field exists
  • SolrInputDocument::getBoost — Retrieves the current boost value for the document
  • SolrInputDocument::getChildDocuments — Returns an array of child documents (SolrInputDocument)
  • SolrInputDocument::getChildDocumentsCount — Returns the number of child documents
  • SolrInputDocument::getField — Retrieves a field by name
  • SolrInputDocument::getFieldBoost — Retrieves the boost value for a particular field
  • SolrInputDocument::getFieldCount — Returns the number of fields in the document
  • SolrInputDocument::getFieldNames — Returns an array containing all the fields in the document
  • SolrInputDocument::hasChildDocuments — Returns true if the document has any child documents
  • SolrInputDocument::merge — Merges one input document into another
  • SolrInputDocument::reset — This is an alias of SolrInputDocument::clear
  • SolrInputDocument::setBoost — Sets the boost value for this document
  • SolrInputDocument::setFieldBoost — Sets the index-time boost value for a field
  • SolrInputDocument::sort — Sorts the fields within the document
  • SolrInputDocument::toArray — Returns an array representation of the input document
SolrUtils::queryPhrase
SolrInputDocument::addChildDocument
Solr


Adds a child document for block indexing

SolrInputDocument
SolrInputDocument::addChildDocuments
SolrInputDocument
PHP Manual

SolrInputDocument::addChildDocument

(PECL solr >= 2.3.0)

SolrInputDocument::addChildDocument — Adds a child document for block indexing

Açıklama

public void SolrInputDocument::addChildDocument ( SolrInputDocument $child )

Adds a child document to construct a document block with nested documents.

Değiştirgeler

child

A SolrInputDocument object.

Hatalar/İstisnalar

Throws SolrIllegalArgumentException on failure.

Throws SolrException on internal failure.

Dönen Değerler

Örnekler

Örnek 1 SolrInputDocument::addChildDocument() example

<?php

include "bootstrap.php";

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
    'path'     => SOLR_SERVER_STORE_PATH,
);

$client = new SolrClient($options);

$product = new SolrInputDocument();

$product->addField('id', 'P-BLACK');
$product->addField('cat', 'tshirt');
$product->addField('cat', 'polo');
$product->addField('content_type', 'product');

$small = new SolrInputDocument();
$small->addField('id', 'TS-BLK-S');
$small->addField('content_type', 'sku');
$small->addField('size', 'S');
$small->addField('inventory', 100);

$medium = new SolrInputDocument();
$medium->addField('id', 'TS-BLK-M');
$medium->addField('content_type', 'sku');
$medium->addField('size', 'M');
$medium->addField('inventory', 200);

$large = new SolrInputDocument();
$large->addField('id', 'TS-BLK-L');
$large->addField('content_type', 'sku');
$large->addField('size', 'L');
$large->addField('inventory', 300);

// add child documents
$product->addChildDocument($small);
$product->addChildDocument($medium);
$product->addChildDocument($large);

// add product document block to the index
$updateResponse = $client->addDocument(
        $product,
        true, // overwrite if the document exists
        10000 // commit within 10 seconds
);

print_r($updateResponse->getResponse());

Yukarıdaki örnek şuna benzer bir çıktı üretir:

SolrObject Object
(
    [responseHeader] => SolrObject Object
        (
            [status] => 0
            [QTime] => 5
        )
)

Ayrıca Bakınız

  • SolrInputDocument::addChildDocuments() - Adds an array of child documents
  • SolrInputDocument::hasChildDocuments() - Returns true if the document has any child documents
  • SolrInputDocument::getChildDocuments() - Returns an array of child documents (SolrInputDocument)
  • SolrInputDocument::getChildDocumentsCount() - Returns the number of child documents
SolrInputDocument
SolrInputDocument::addChildDocuments
SolrInputDocument


Adds an array of child documents

SolrInputDocument::addChildDocument
SolrInputDocument::addField
SolrInputDocument
PHP Manual

SolrInputDocument::addChildDocuments

(PECL solr >= 2.3.0)

SolrInputDocument::addChildDocuments — Adds an array of child documents

Açıklama

public void SolrInputDocument::addChildDocuments ( array &$docs )

Adds an array of child documents to the current input document.

Değiştirgeler

docs

An array of SolrInputDocument objects.

Hatalar/İstisnalar

Throws SolrIllegalArgumentException on failure.

Throws SolrException on internal failure.

Dönen Değerler

Örnekler

Örnek 1 SolrInputDocument::addChildDocuments() example

<?php

include "bootstrap.php";

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
    'path'     => SOLR_SERVER_STORE_PATH,
);

$client = new SolrClient($options);

$product = new SolrInputDocument();

$product->addField('id', 'P-BLACK');
$product->addField('cat', 'tshirt');
$product->addField('cat', 'polo');
$product->addField('content_type', 'product');

$small = new SolrInputDocument();
$small->addField('id', 'TS-BLK-S');
$small->addField('content_type', 'sku');
$small->addField('size', 'S');
$small->addField('inventory', 100);

$medium = new SolrInputDocument();
$medium->addField('id', 'TS-BLK-M');
$medium->addField('content_type', 'sku');
$medium->addField('size', 'M');
$medium->addField('inventory', 200);

$large = new SolrInputDocument();
$large->addField('id', 'TS-BLK-L');
$large->addField('content_type', 'sku');
$large->addField('size', 'L');
$large->addField('inventory', 300);

// add child documents
$skus = [$small, $medium, $large];
$product->addChildDocuments($skus);

// add the product document block to the index
$updateResponse = $client->addDocument(
        $product,
        true, // overwrite if the document exists
        10000 // commit within 10 seconds
);

print_r($updateResponse->getResponse());

Yukarıdaki örnek şuna benzer bir çıktı üretir:

SolrObject Object
(
    [responseHeader] => SolrObject Object
        (
            [status] => 0
            [QTime] => 5
        )
)

Ayrıca Bakınız

  • SolrInputDocument::addChildDocument() - Adds a child document for block indexing
  • SolrInputDocument::hasChildDocuments() - Returns true if the document has any child documents
  • SolrInputDocument::getChildDocuments() - Returns an array of child documents (SolrInputDocument)
  • SolrInputDocument::getChildDocumentsCount() - Returns the number of child documents
SolrInputDocument::addChildDocument
SolrInputDocument::addField
SolrInputDocument


Adds a field to the document

SolrInputDocument::addChildDocuments
SolrInputDocument::clear
SolrInputDocument
PHP Manual

SolrInputDocument::addField

(PECL solr >= 0.9.2)

SolrInputDocument::addField — Adds a field to the document

Açıklama

public bool SolrInputDocument::addField ( string $fieldName , string $fieldValue [, float $fieldBoostValue = 0.0 ] )

For multi-value fields, if a valid boost value is specified, the specified value will be multiplied by the current boost value for this field.

Değiştirgeler

fieldName

The name of the field

fieldValue

The value for the field.

fieldBoostValue

The index time boost for the field. Though this cannot be negative, you can still pass values less than 1.0 but they must be greater than zero.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

SolrInputDocument::addChildDocuments
SolrInputDocument::clear
SolrInputDocument


Resets the input document

SolrInputDocument::addField
SolrInputDocument::__clone
SolrInputDocument
PHP Manual

SolrInputDocument::clear

(PECL solr >= 0.9.2)

SolrInputDocument::clear — Resets the input document

Açıklama

public bool SolrInputDocument::clear ( void )

Resets the document by dropping all the fields and resets the document boost to zero.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

SolrInputDocument::addField
SolrInputDocument::__clone
SolrInputDocument


Creates a copy of a SolrDocument

SolrInputDocument::clear
SolrInputDocument::__construct
SolrInputDocument
PHP Manual

SolrInputDocument::__clone

(PECL solr >= 0.9.2)

SolrInputDocument::__clone — Creates a copy of a SolrDocument

Açıklama

public void SolrInputDocument::__clone ( void )

Should not be called directly. It is used to create a deep copy of a SolrInputDocument.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Creates a new SolrInputDocument instance.

SolrInputDocument::clear
SolrInputDocument::__construct
SolrInputDocument


Constructor

SolrInputDocument::__clone
SolrInputDocument::deleteField
SolrInputDocument
PHP Manual

SolrInputDocument::__construct

(PECL solr >= 0.9.2)

SolrInputDocument::__construct — Constructor

Açıklama

public SolrInputDocument::__construct ( void )

Constructor.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

None.

SolrInputDocument::__clone
SolrInputDocument::deleteField
SolrInputDocument


Removes a field from the document

SolrInputDocument::__construct
SolrInputDocument::__destruct
SolrInputDocument
PHP Manual

SolrInputDocument::deleteField

(PECL solr >= 0.9.2)

SolrInputDocument::deleteField — Removes a field from the document

Açıklama

public bool SolrInputDocument::deleteField ( string $fieldName )

Removes a field from the document.

Değiştirgeler

fieldName

The name of the field.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

SolrInputDocument::__construct
SolrInputDocument::__destruct
SolrInputDocument


Destructor

SolrInputDocument::deleteField
SolrInputDocument::fieldExists
SolrInputDocument
PHP Manual

SolrInputDocument::__destruct

(PECL solr >= 0.9.2)

SolrInputDocument::__destruct — Destructor

Açıklama

public void SolrInputDocument::__destruct ( void )

Destructor

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

None.

SolrInputDocument::deleteField
SolrInputDocument::fieldExists
SolrInputDocument


Checks if a field exists

SolrInputDocument::__destruct
SolrInputDocument::getBoost
SolrInputDocument
PHP Manual

SolrInputDocument::fieldExists

(PECL solr >= 0.9.2)

SolrInputDocument::fieldExists — Checks if a field exists

Açıklama

public bool SolrInputDocument::fieldExists ( string $fieldName )

Checks if a field exists

Değiştirgeler

fieldName

Name of the field.

Dönen Değerler

Returns TRUE if the field was found and FALSE if it was not found.

SolrInputDocument::__destruct
SolrInputDocument::getBoost
SolrInputDocument


Retrieves the current boost value for the document

SolrInputDocument::fieldExists
SolrInputDocument::getChildDocuments
SolrInputDocument
PHP Manual

SolrInputDocument::getBoost

(PECL solr >= 0.9.2)

SolrInputDocument::getBoost — Retrieves the current boost value for the document

Açıklama

public float SolrInputDocument::getBoost ( void )

Retrieves the current boost value for the document.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the boost value on success and FALSE on failure.

SolrInputDocument::fieldExists
SolrInputDocument::getChildDocuments
SolrInputDocument


Returns an array of child documents (SolrInputDocument)

SolrInputDocument::getBoost
SolrInputDocument::getChildDocumentsCount
SolrInputDocument
PHP Manual

SolrInputDocument::getChildDocuments

(PECL solr >= 2.3.0)

SolrInputDocument::getChildDocuments — Returns an array of child documents (SolrInputDocument)

Açıklama

public array SolrInputDocument::getChildDocuments ( void )

Returns an array of child documents (SolrInputDocument)

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Ayrıca Bakınız

  • SolrInputDocument::addChildDocument() - Adds a child document for block indexing
  • SolrInputDocument::addChildDocuments() - Adds an array of child documents
  • SolrInputDocument::hasChildDocuments() - Returns true if the document has any child documents
  • SolrInputDocument::getChildDocumentsCount() - Returns the number of child documents
SolrInputDocument::getBoost
SolrInputDocument::getChildDocumentsCount
SolrInputDocument


Returns the number of child documents

SolrInputDocument::getChildDocuments
SolrInputDocument::getField
SolrInputDocument
PHP Manual

SolrInputDocument::getChildDocumentsCount

(PECL solr >= 2.3.0)

SolrInputDocument::getChildDocumentsCount — Returns the number of child documents

Açıklama

public integer SolrInputDocument::getChildDocumentsCount ( void )

Returns the number of child documents

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Ayrıca Bakınız

  • SolrInputDocument::addChildDocument() - Adds a child document for block indexing
  • SolrInputDocument::addChildDocuments() - Adds an array of child documents
  • SolrInputDocument::hasChildDocuments() - Returns true if the document has any child documents
  • SolrInputDocument::getChildDocuments() - Returns an array of child documents (SolrInputDocument)
SolrInputDocument::getChildDocuments
SolrInputDocument::getField
SolrInputDocument


Retrieves a field by name

SolrInputDocument::getChildDocumentsCount
SolrInputDocument::getFieldBoost
SolrInputDocument
PHP Manual

SolrInputDocument::getField

(PECL solr >= 0.9.2)

SolrInputDocument::getField — Retrieves a field by name

Açıklama

public SolrDocumentField SolrInputDocument::getField ( string $fieldName )

Retrieves a field in the document.

Değiştirgeler

fieldName

The name of the field.

Dönen Değerler

Returns a SolrDocumentField object on success and FALSE on failure.

SolrInputDocument::getChildDocumentsCount
SolrInputDocument::getFieldBoost
SolrInputDocument


Retrieves the boost value for a particular field

SolrInputDocument::getField
SolrInputDocument::getFieldCount
SolrInputDocument
PHP Manual

SolrInputDocument::getFieldBoost

(PECL solr >= 0.9.2)

SolrInputDocument::getFieldBoost — Retrieves the boost value for a particular field

Açıklama

public float SolrInputDocument::getFieldBoost ( string $fieldName )

Retrieves the boost value for a particular field.

Değiştirgeler

fieldName

The name of the field.

Dönen Değerler

Returns the boost value for the field or FALSE if there was an error.

SolrInputDocument::getField
SolrInputDocument::getFieldCount
SolrInputDocument


Returns the number of fields in the document

SolrInputDocument::getFieldBoost
SolrInputDocument::getFieldNames
SolrInputDocument
PHP Manual

SolrInputDocument::getFieldCount

(PECL solr >= 0.9.2)

SolrInputDocument::getFieldCount — Returns the number of fields in the document

Açıklama

public int SolrInputDocument::getFieldCount ( void )

Returns the number of fields in the document.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an integer on success başarısızlık durumunda FALSE döner.

SolrInputDocument::getFieldBoost
SolrInputDocument::getFieldNames
SolrInputDocument


Returns an array containing all the fields in the document

SolrInputDocument::getFieldCount
SolrInputDocument::hasChildDocuments
SolrInputDocument
PHP Manual

SolrInputDocument::getFieldNames

(PECL solr >= 0.9.2)

SolrInputDocument::getFieldNames — Returns an array containing all the fields in the document

Açıklama

public array SolrInputDocument::getFieldNames ( void )

Returns an array containing all the fields in the document.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array on success and FALSE on failure.

SolrInputDocument::getFieldCount
SolrInputDocument::hasChildDocuments
SolrInputDocument


Returns true if the document has any child documents

SolrInputDocument::getFieldNames
SolrInputDocument::merge
SolrInputDocument
PHP Manual

SolrInputDocument::hasChildDocuments

(PECL solr >= 2.3.0)

SolrInputDocument::hasChildDocuments — Returns true if the document has any child documents

Açıklama

public boolean SolrInputDocument::hasChildDocuments ( void )

Checks whether the document has any child documents

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Ayrıca Bakınız

  • SolrInputDocument::addChildDocument() - Adds a child document for block indexing
  • SolrInputDocument::addChildDocuments() - Adds an array of child documents
  • SolrInputDocument::getChildDocuments() - Returns an array of child documents (SolrInputDocument)
  • SolrInputDocument::getChildDocumentsCount() - Returns the number of child documents
SolrInputDocument::getFieldNames
SolrInputDocument::merge
SolrInputDocument


Merges one input document into another

SolrInputDocument::hasChildDocuments
SolrInputDocument::reset
SolrInputDocument
PHP Manual

SolrInputDocument::merge

(PECL solr >= 0.9.2)

SolrInputDocument::merge — Merges one input document into another

Açıklama

public bool SolrInputDocument::merge ( SolrInputDocument $sourceDoc [, bool $overwrite = true ] )

Merges one input document into another.

Değiştirgeler

sourceDoc

The source document.

overwrite

If this is TRUE it will replace matching fields in the destination document.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. In the future, this will be modified to return the number of fields in the new document.

SolrInputDocument::hasChildDocuments
SolrInputDocument::reset
SolrInputDocument


This is an alias of SolrInputDocument::clear

SolrInputDocument::merge
SolrInputDocument::setBoost
SolrInputDocument
PHP Manual

SolrInputDocument::reset

(PECL solr >= 0.9.2)

SolrInputDocument::reset — This is an alias of SolrInputDocument::clear

Açıklama

public bool SolrInputDocument::reset ( void )

This is an alias of SolrInputDocument::clear

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

SolrInputDocument::merge
SolrInputDocument::setBoost
SolrInputDocument


Sets the boost value for this document

SolrInputDocument::reset
SolrInputDocument::setFieldBoost
SolrInputDocument
PHP Manual

SolrInputDocument::setBoost

(PECL solr >= 0.9.2)

SolrInputDocument::setBoost — Sets the boost value for this document

Açıklama

public bool SolrInputDocument::setBoost ( float $documentBoostValue )

Sets the boost value for this document.

Değiştirgeler

documentBoostValue

The index-time boost value for this document.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

SolrInputDocument::reset
SolrInputDocument::setFieldBoost
SolrInputDocument


Sets the index-time boost value for a field

SolrInputDocument::setBoost
SolrInputDocument::sort
SolrInputDocument
PHP Manual

SolrInputDocument::setFieldBoost

(PECL solr >= 0.9.2)

SolrInputDocument::setFieldBoost — Sets the index-time boost value for a field

Açıklama

public bool SolrInputDocument::setFieldBoost ( string $fieldName , float $fieldBoostValue )

Sets the index-time boost value for a field. This replaces the current boost value for this field.

Değiştirgeler

fieldName

The name of the field.

fieldBoostValue

The index time boost value.

SolrInputDocument::setBoost
SolrInputDocument::sort
SolrInputDocument


Sorts the fields within the document

SolrInputDocument::setFieldBoost
SolrInputDocument::toArray
SolrInputDocument
PHP Manual

SolrInputDocument::sort

(PECL solr >= 0.9.2)

SolrInputDocument::sort — Sorts the fields within the document

Açıklama

public bool SolrInputDocument::sort ( int $sortOrderBy [, int $sortDirection = SolrInputDocument::SORT_ASC ] )

The fields are rearranged according to the specified criteria and sort direction

   Fields can be sorted by boost values, field names and number of values.

   The $order_by parameter must be one of :

   * SolrInputDocument::SORT_FIELD_NAME
   * SolrInputDocument::SORT_FIELD_BOOST_VALUE
   * SolrInputDocument::SORT_FIELD_VALUE_COUNT

   The sort direction can be one of :

   * SolrInputDocument::SORT_DEFAULT
   * SolrInputDocument::SORT_ASC
   * SolrInputDocument::SORT_DESC

Değiştirgeler

sortOrderBy

The sort criteria

sortDirection

The sort direction

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

SolrInputDocument::setFieldBoost
SolrInputDocument::toArray
SolrInputDocument


Returns an array representation of the input document

SolrInputDocument::sort
SolrDocument
SolrInputDocument
PHP Manual

SolrInputDocument::toArray

(PECL solr >= 0.9.2)

SolrInputDocument::toArray — Returns an array representation of the input document

Açıklama

public array SolrInputDocument::toArray ( void )

Returns an array representation of the input document.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array containing the fields. It returns FALSE on failure.

SolrInputDocument::sort
SolrDocument
SolrInputDocument


The SolrDocument class

(PECL solr >= 0.9.2)

Giriş

Represents a Solr document retrieved from a query response.

Sınıf Sözdizimi

final SolrDocument implements ArrayAccess , Iterator , Serializable {
/* Sabitler */
const integer SORT_DEFAULT = 1 ;
const integer SORT_ASC = 1 ;
const integer SORT_DESC = 2 ;
const integer SORT_FIELD_NAME = 1 ;
const integer SORT_FIELD_VALUE_COUNT = 2 ;
const integer SORT_FIELD_BOOST_VALUE = 4 ;
/* Yöntemler */
public bool addField ( string $fieldName , string $fieldValue )
public bool clear ( void )
public void __clone ( void )
public __construct ( void )
public SolrDocumentField current ( void )
public bool deleteField ( string $fieldName )
public void __destruct ( void )
public bool fieldExists ( string $fieldName )
public SolrDocumentField __get ( string $fieldName )
public array getChildDocuments ( void )
public integer getChildDocumentsCount ( void )
public SolrDocumentField getField ( string $fieldName )
public int getFieldCount ( void )
public array getFieldNames ( void )
public SolrInputDocument getInputDocument ( void )
public bool hasChildDocuments ( void )
public bool __isset ( string $fieldName )
public string key ( void )
public bool merge ( SolrDocument $sourceDoc [, bool $overwrite = true ] )
public void next ( void )
public bool offsetExists ( string $fieldName )
public SolrDocumentField offsetGet ( string $fieldName )
public void offsetSet ( string $fieldName , string $fieldValue )
public void offsetUnset ( string $fieldName )
public bool reset ( void )
public void rewind ( void )
public string serialize ( void )
public bool __set ( string $fieldName , string $fieldValue )
public bool sort ( int $sortOrderBy [, int $sortDirection = SolrDocument::SORT_ASC ] )
public array toArray ( void )
public void unserialize ( string $serialized )
public bool __unset ( string $fieldName )
public bool valid ( void )
}

Öntanımlı Sabitler

SolrDocument::SORT_DEFAULT

Default mode for sorting fields within the document.

SolrDocument::SORT_ASC

Sorts the fields in ascending order

SolrDocument::SORT_DESC

Sorts the fields in descending order

SolrDocument::SORT_FIELD_NAME

Sorts the fields by field name.

SolrDocument::SORT_FIELD_VALUE_COUNT

Sorts the fields by number of values in each field.

SolrDocument::SORT_FIELD_BOOST_VALUE

Sorts the fields by thier boost values.

İçindekiler

  • SolrDocument::addField — Adds a field to the document
  • SolrDocument::clear — Drops all the fields in the document
  • SolrDocument::__clone — Creates a copy of a SolrDocument object
  • SolrDocument::__construct — Constructor
  • SolrDocument::current — Retrieves the current field
  • SolrDocument::deleteField — Removes a field from the document
  • SolrDocument::__destruct — Destructor
  • SolrDocument::fieldExists — Checks if a field exists in the document
  • SolrDocument::__get — Access the field as a property
  • SolrDocument::getChildDocuments — Returns an array of child documents (SolrDocument)
  • SolrDocument::getChildDocumentsCount — Returns the number of child documents
  • SolrDocument::getField — Retrieves a field by name
  • SolrDocument::getFieldCount — Returns the number of fields in this document
  • SolrDocument::getFieldNames — Returns an array of fields names in the document
  • SolrDocument::getInputDocument — Returns a SolrInputDocument equivalent of the object
  • SolrDocument::hasChildDocuments — Checks whether the document has any child documents
  • SolrDocument::__isset — Checks if a field exists
  • SolrDocument::key — Retrieves the current key
  • SolrDocument::merge — Merges source to the current SolrDocument
  • SolrDocument::next — Moves the internal pointer to the next field
  • SolrDocument::offsetExists — Checks if a particular field exists
  • SolrDocument::offsetGet — Retrieves a field
  • SolrDocument::offsetSet — Adds a field to the document
  • SolrDocument::offsetUnset — Removes a field
  • SolrDocument::reset — This is an alias to SolrDocument::clear()
  • SolrDocument::rewind — Resets the internal pointer to the beginning
  • SolrDocument::serialize — Used for custom serialization
  • SolrDocument::__set — Adds another field to the document
  • SolrDocument::sort — Sorts the fields in the document
  • SolrDocument::toArray — Returns an array representation of the document
  • SolrDocument::unserialize — Custom serialization of SolrDocument objects
  • SolrDocument::__unset — Removes a field from the document
  • SolrDocument::valid — Checks if the current position internally is still valid
SolrInputDocument::toArray
SolrDocument::addField
Solr


Adds a field to the document

SolrDocument
SolrDocument::clear
SolrDocument
PHP Manual

SolrDocument::addField

(PECL solr >= 0.9.2)

SolrDocument::addField — Adds a field to the document

Açıklama

public bool SolrDocument::addField ( string $fieldName , string $fieldValue )

This method adds a field to the SolrDocument instance.

Değiştirgeler

fieldName

The name of the field

fieldValue

The value of the field.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

SolrDocument
SolrDocument::clear
SolrDocument


Drops all the fields in the document

SolrDocument::addField
SolrDocument::__clone
SolrDocument
PHP Manual

SolrDocument::clear

(PECL solr >= 0.9.2)

SolrDocument::clear — Drops all the fields in the document

Açıklama

public bool SolrDocument::clear ( void )

Resets the current object. Discards all the fields and resets the document boost to zero.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

SolrDocument::addField
SolrDocument::__clone
SolrDocument


Creates a copy of a SolrDocument object

SolrDocument::clear
SolrDocument::__construct
SolrDocument
PHP Manual

SolrDocument::__clone

(PECL solr >= 0.9.2)

SolrDocument::__clone — Creates a copy of a SolrDocument object

Açıklama

public void SolrDocument::__clone ( void )

Creates a copy of a SolrDocument object. Not to be called directly.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

None.

SolrDocument::clear
SolrDocument::__construct
SolrDocument


Constructor

SolrDocument::__clone
SolrDocument::current
SolrDocument
PHP Manual

SolrDocument::__construct

(PECL solr >= 0.9.2)

SolrDocument::__construct — Constructor

Açıklama

public SolrDocument::__construct ( void )

Constructor for SolrDocument

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

SolrDocument::__clone
SolrDocument::current
SolrDocument


Retrieves the current field

SolrDocument::__construct
SolrDocument::deleteField
SolrDocument
PHP Manual

SolrDocument::current

(PECL solr >= 0.9.2)

SolrDocument::current — Retrieves the current field

Açıklama

public SolrDocumentField SolrDocument::current ( void )

Retrieves the current field

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the field

SolrDocument::__construct
SolrDocument::deleteField
SolrDocument


Removes a field from the document

SolrDocument::current
SolrDocument::__destruct
SolrDocument
PHP Manual

SolrDocument::deleteField

(PECL solr >= 0.9.2)

SolrDocument::deleteField — Removes a field from the document

Açıklama

public bool SolrDocument::deleteField ( string $fieldName )

Removes a field from the document.

Değiştirgeler

fieldName

Name of the field

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

SolrDocument::current
SolrDocument::__destruct
SolrDocument


Destructor

SolrDocument::deleteField
SolrDocument::fieldExists
SolrDocument
PHP Manual

SolrDocument::__destruct

(PECL solr >= 0.9.2)

SolrDocument::__destruct — Destructor

Açıklama

public void SolrDocument::__destruct ( void )

Destructor for SolrDocument.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

SolrDocument::deleteField
SolrDocument::fieldExists
SolrDocument


Checks if a field exists in the document

SolrDocument::__destruct
SolrDocument::__get
SolrDocument
PHP Manual

SolrDocument::fieldExists

(PECL solr >= 0.9.2)

SolrDocument::fieldExists — Checks if a field exists in the document

Açıklama

public bool SolrDocument::fieldExists ( string $fieldName )

Checks if the requested field as a valid fieldname in the document.

Değiştirgeler

fieldName

The name of the field.

Dönen Değerler

Returns TRUE if the field is present and FALSE if it does not.

SolrDocument::__destruct
SolrDocument::__get
SolrDocument


Access the field as a property

SolrDocument::fieldExists
SolrDocument::getChildDocuments
SolrDocument
PHP Manual

SolrDocument::__get

(PECL solr >= 0.9.2)

SolrDocument::__get — Access the field as a property

Açıklama

public SolrDocumentField SolrDocument::__get ( string $fieldName )

Magic method for accessing the field as a property.

Değiştirgeler

fieldName

The name of the field.

Dönen Değerler

Returns a SolrDocumentField instance.

SolrDocument::fieldExists
SolrDocument::getChildDocuments
SolrDocument


Returns an array of child documents (SolrDocument)

SolrDocument::__get
SolrDocument::getChildDocumentsCount
SolrDocument
PHP Manual

SolrDocument::getChildDocuments

(PECL solr >= 2.3.0)

SolrDocument::getChildDocuments — Returns an array of child documents (SolrDocument)

Açıklama

public array SolrDocument::getChildDocuments ( void )

Returns an array of child documents (SolrDocument)

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Ayrıca Bakınız

  • SolrDocument::hasChildDocuments() - Checks whether the document has any child documents
  • SolrDocument::getChildDocumentsCount() - Returns the number of child documents
SolrDocument::__get
SolrDocument::getChildDocumentsCount
SolrDocument


Returns the number of child documents

SolrDocument::getChildDocuments
SolrDocument::getField
SolrDocument
PHP Manual

SolrDocument::getChildDocumentsCount

(PECL solr >= 2.3.0)

SolrDocument::getChildDocumentsCount — Returns the number of child documents

Açıklama

public integer SolrDocument::getChildDocumentsCount ( void )

Returns the number of child documents

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Ayrıca Bakınız

  • SolrDocument::hasChildDocuments() - Checks whether the document has any child documents
  • SolrDocument::getChildDocuments() - Returns an array of child documents (SolrDocument)
SolrDocument::getChildDocuments
SolrDocument::getField
SolrDocument


Retrieves a field by name

SolrDocument::getChildDocumentsCount
SolrDocument::getFieldCount
SolrDocument
PHP Manual

SolrDocument::getField

(PECL solr >= 0.9.2)

SolrDocument::getField — Retrieves a field by name

Açıklama

public SolrDocumentField SolrDocument::getField ( string $fieldName )

Retrieves a field by name.

Değiştirgeler

fieldName

Name of the field.

Dönen Değerler

Returns a SolrDocumentField on success and FALSE on failure.

SolrDocument::getChildDocumentsCount
SolrDocument::getFieldCount
SolrDocument


Returns the number of fields in this document

SolrDocument::getField
SolrDocument::getFieldNames
SolrDocument
PHP Manual

SolrDocument::getFieldCount

(PECL solr >= 0.9.2)

SolrDocument::getFieldCount — Returns the number of fields in this document

Açıklama

public int SolrDocument::getFieldCount ( void )

Returns the number of fields in this document. Multi-value fields are only counted once.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an integer on success and FALSE on failure.

SolrDocument::getField
SolrDocument::getFieldNames
SolrDocument


Returns an array of fields names in the document

SolrDocument::getFieldCount
SolrDocument::getInputDocument
SolrDocument
PHP Manual

SolrDocument::getFieldNames

(PECL solr >= 0.9.2)

SolrDocument::getFieldNames — Returns an array of fields names in the document

Açıklama

public array SolrDocument::getFieldNames ( void )

Returns an array of fields names in the document.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array containing the names of the fields in this document.

SolrDocument::getFieldCount
SolrDocument::getInputDocument
SolrDocument


Returns a SolrInputDocument equivalent of the object

SolrDocument::getFieldNames
SolrDocument::hasChildDocuments
SolrDocument
PHP Manual

SolrDocument::getInputDocument

(PECL solr >= 0.9.2)

SolrDocument::getInputDocument — Returns a SolrInputDocument equivalent of the object

Açıklama

public SolrInputDocument SolrDocument::getInputDocument ( void )

Returns a SolrInputDocument equivalent of the object. This is useful if one wishes to resubmit/update a document retrieved from a query.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a SolrInputDocument on success and NULL on failure.

SolrDocument::getFieldNames
SolrDocument::hasChildDocuments
SolrDocument


Checks whether the document has any child documents

SolrDocument::getInputDocument
SolrDocument::__isset
SolrDocument
PHP Manual

SolrDocument::hasChildDocuments

(PECL solr >= 2.3.0)

SolrDocument::hasChildDocuments — Checks whether the document has any child documents

Açıklama

public bool SolrDocument::hasChildDocuments ( void )

Checks whether the document has any child documents

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Ayrıca Bakınız

  • SolrDocument::getChildDocuments() - Returns an array of child documents (SolrDocument)
  • SolrDocument::getChildDocumentsCount() - Returns the number of child documents
SolrDocument::getInputDocument
SolrDocument::__isset
SolrDocument


Checks if a field exists

SolrDocument::hasChildDocuments
SolrDocument::key
SolrDocument
PHP Manual

SolrDocument::__isset

(PECL solr >= 0.9.2)

SolrDocument::__isset — Checks if a field exists

Açıklama

public bool SolrDocument::__isset ( string $fieldName )

Checks if a field exists

Değiştirgeler

fieldName

Name of the field.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

SolrDocument::hasChildDocuments
SolrDocument::key
SolrDocument


Retrieves the current key

SolrDocument::__isset
SolrDocument::merge
SolrDocument
PHP Manual

SolrDocument::key

(PECL solr >= 0.9.2)

SolrDocument::key — Retrieves the current key

Açıklama

public string SolrDocument::key ( void )

Retrieves the current key.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the current key.

SolrDocument::__isset
SolrDocument::merge
SolrDocument


Merges source to the current SolrDocument

SolrDocument::key
SolrDocument::next
SolrDocument
PHP Manual

SolrDocument::merge

(PECL solr >= 0.9.2)

SolrDocument::merge — Merges source to the current SolrDocument

Açıklama

public bool SolrDocument::merge ( SolrDocument $sourceDoc [, bool $overwrite = true ] )

Merges source to the current SolrDocument.

Değiştirgeler

sourceDoc

The source document.

overwrite

If this is TRUE then fields with the same name in the destination document will be overwritten.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

SolrDocument::key
SolrDocument::next
SolrDocument


Moves the internal pointer to the next field

SolrDocument::merge
SolrDocument::offsetExists
SolrDocument
PHP Manual

SolrDocument::next

(PECL solr >= 0.9.2)

SolrDocument::next — Moves the internal pointer to the next field

Açıklama

public void SolrDocument::next ( void )

Moves the internal pointer to the next field.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

This method has no return value.

SolrDocument::merge
SolrDocument::offsetExists
SolrDocument


Checks if a particular field exists

SolrDocument::next
SolrDocument::offsetGet
SolrDocument
PHP Manual

SolrDocument::offsetExists

(PECL solr >= 0.9.2)

SolrDocument::offsetExists — Checks if a particular field exists

Açıklama

public bool SolrDocument::offsetExists ( string $fieldName )

Checks if a particular field exists. This is used when the object is treated as an array.

Değiştirgeler

fieldName

The name of the field.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

SolrDocument::next
SolrDocument::offsetGet
SolrDocument


Retrieves a field

SolrDocument::offsetExists
SolrDocument::offsetSet
SolrDocument
PHP Manual

SolrDocument::offsetGet

(PECL solr >= 0.9.2)

SolrDocument::offsetGet — Retrieves a field

Açıklama

public SolrDocumentField SolrDocument::offsetGet ( string $fieldName )

This is used to retrieve the field when the object is treated as an array.

Değiştirgeler

fieldName

The name of the field.

Dönen Değerler

Returns a SolrDocumentField object.

SolrDocument::offsetExists
SolrDocument::offsetSet
SolrDocument


Adds a field to the document

SolrDocument::offsetGet
SolrDocument::offsetUnset
SolrDocument
PHP Manual

SolrDocument::offsetSet

(PECL solr >= 0.9.2)

SolrDocument::offsetSet — Adds a field to the document

Açıklama

public void SolrDocument::offsetSet ( string $fieldName , string $fieldValue )

Used when the object is treated as an array to add a field to the document.

Değiştirgeler

fieldName

The name of the field.

fieldValue

The value for this field.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

SolrDocument::offsetGet
SolrDocument::offsetUnset
SolrDocument


Removes a field

SolrDocument::offsetSet
SolrDocument::reset
SolrDocument
PHP Manual

SolrDocument::offsetUnset

(PECL solr >= 0.9.2)

SolrDocument::offsetUnset — Removes a field

Açıklama

public void SolrDocument::offsetUnset ( string $fieldName )

Removes a field from the document.

Değiştirgeler

fieldName

The name of the field.

Dönen Değerler

No return value.

SolrDocument::offsetSet
SolrDocument::reset
SolrDocument


This is an alias to SolrDocument::clear()

SolrDocument::offsetUnset
SolrDocument::rewind
SolrDocument
PHP Manual

SolrDocument::reset

(PECL solr >= 0.9.2)

SolrDocument::reset — This is an alias to SolrDocument::clear()

Açıklama

public bool SolrDocument::reset ( void )

This is an alias to SolrDocument::clear()

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

SolrDocument::offsetUnset
SolrDocument::rewind
SolrDocument


Resets the internal pointer to the beginning

SolrDocument::reset
SolrDocument::serialize
SolrDocument
PHP Manual

SolrDocument::rewind

(PECL solr >= 0.9.2)

SolrDocument::rewind — Resets the internal pointer to the beginning

Açıklama

public void SolrDocument::rewind ( void )

Resets the internal pointer to the beginning.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

This method has no return value.

SolrDocument::reset
SolrDocument::serialize
SolrDocument


Used for custom serialization

SolrDocument::rewind
SolrDocument::__set
SolrDocument
PHP Manual

SolrDocument::serialize

(PECL solr >= 0.9.2)

SolrDocument::serialize — Used for custom serialization

Açıklama

public string SolrDocument::serialize ( void )

Used for custom serialization.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a string representing the serialized Solr document.

SolrDocument::rewind
SolrDocument::__set
SolrDocument


Adds another field to the document

SolrDocument::serialize
SolrDocument::sort
SolrDocument
PHP Manual

SolrDocument::__set

(PECL solr >= 0.9.2)

SolrDocument::__set — Adds another field to the document

Açıklama

public bool SolrDocument::__set ( string $fieldName , string $fieldValue )

Adds another field to the document. Used to set the fields as new properties.

Değiştirgeler

fieldName

Name of the field.

fieldValue

Field value.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

SolrDocument::serialize
SolrDocument::sort
SolrDocument


Sorts the fields in the document

SolrDocument::__set
SolrDocument::toArray
SolrDocument
PHP Manual

SolrDocument::sort

(PECL solr >= 0.9.2)

SolrDocument::sort — Sorts the fields in the document

Açıklama

public bool SolrDocument::sort ( int $sortOrderBy [, int $sortDirection = SolrDocument::SORT_ASC ] )

The fields are rearranged according to the specified criteria and sort direction

   Fields can be sorted by boost values, field names and number of values.

   The sortOrderBy parameter must be one of :

   * SolrDocument::SORT_FIELD_NAME
   * SolrDocument::SORT_FIELD_BOOST_VALUE
   * SolrDocument::SORT_FIELD_VALUE_COUNT

   The sortDirection can be one of :

   * SolrDocument::SORT_DEFAULT
   * SolrDocument::SORT_ASC
   * SolrDocument::SORT_DESC

   The default way is to sort in ascending order.

Değiştirgeler

sortOrderBy

The sort criteria.

sortDirection

The sort direction.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

SolrDocument::__set
SolrDocument::toArray
SolrDocument


Returns an array representation of the document

SolrDocument::sort
SolrDocument::unserialize
SolrDocument
PHP Manual

SolrDocument::toArray

(PECL solr >= 0.9.2)

SolrDocument::toArray — Returns an array representation of the document

Açıklama

public array SolrDocument::toArray ( void )

Returns an array representation of the document.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array representation of the document.

Örnekler

Örnek 1 SolrDocument::toArray() example

<?php

$doc = new SolrDocument();

$doc->addField('id', 1123);

$doc->features = "PHP Client Side";
$doc->features = "Fast development cycles";

$doc['cat'] = 'Software';
$doc['cat'] = 'Custom Search';
$doc->cat   = 'Information Technology';

print_r($doc->toArray());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [document_boost] => 0
    [field_count] => 3
    [fields] => Array
        (
            [0] => SolrDocumentField Object
                (
                    [name] => id
                    [boost] => 0
                    [values] => Array
                        (
                            [0] => 1123
                        )

                )

            [1] => SolrDocumentField Object
                (
                    [name] => features
                    [boost] => 0
                    [values] => Array
                        (
                            [0] => PHP Client Side
                            [1] => Fast development cycles
                        )

                )

            [2] => SolrDocumentField Object
                (
                    [name] => cat
                    [boost] => 0
                    [values] => Array
                        (
                            [0] => Software
                            [1] => Custom Search
                            [2] => Information Technology
                        )

                )

        )

)

SolrDocument::sort
SolrDocument::unserialize
SolrDocument


Custom serialization of SolrDocument objects

SolrDocument::toArray
SolrDocument::__unset
SolrDocument
PHP Manual

SolrDocument::unserialize

(PECL solr >= 0.9.2)

SolrDocument::unserialize — Custom serialization of SolrDocument objects

Açıklama

public void SolrDocument::unserialize ( string $serialized )

Custom serialization of SolrDocument objects

Değiştirgeler

serialized

An XML representation of the document.

Dönen Değerler

None.

SolrDocument::toArray
SolrDocument::__unset
SolrDocument


Removes a field from the document

SolrDocument::unserialize
SolrDocument::valid
SolrDocument
PHP Manual

SolrDocument::__unset

(PECL solr >= 0.9.2)

SolrDocument::__unset — Removes a field from the document

Açıklama

public bool SolrDocument::__unset ( string $fieldName )

Removes a field from the document when the field is access as an object property.

Değiştirgeler

fieldName

The name of the field.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

SolrDocument::unserialize
SolrDocument::valid
SolrDocument


Checks if the current position internally is still valid

SolrDocument::__unset
SolrDocumentField
SolrDocument
PHP Manual

SolrDocument::valid

(PECL solr >= 0.9.2)

SolrDocument::valid — Checks if the current position internally is still valid

Açıklama

public bool SolrDocument::valid ( void )

Checks if the current position internally is still valid. It is used during foreach operations.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE on success and FALSE if the current position is no longer valid.

SolrDocument::__unset
SolrDocumentField
SolrDocument


The SolrDocumentField class

(PECL solr >= 0.9.2)

Giriş

This represents a field in a Solr document. All its properties are read-only.

Sınıf Sözdizimi

final SolrDocumentField {
/* Özellikler */
readonly public string $name ;
readonly public float $boost ;
readonly public array $values ;
/* Yöntemler */
public __construct ( void )
public void __destruct ( void )
}

Özellikler

name

The name of the field.

boost

The boost value for the field

values

An array of values for this field

İçindekiler

  • SolrDocumentField::__construct — Constructor
  • SolrDocumentField::__destruct — Destructor
SolrDocument::valid
SolrDocumentField::__construct
Solr


Constructor

SolrDocumentField
SolrDocumentField::__destruct
SolrDocumentField
PHP Manual

SolrDocumentField::__construct

(PECL solr >= 0.9.2)

SolrDocumentField::__construct — Constructor

Açıklama

public SolrDocumentField::__construct ( void )

Constructor.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

None.

SolrDocumentField
SolrDocumentField::__destruct
SolrDocumentField


Destructor

SolrDocumentField::__construct
SolrObject
SolrDocumentField
PHP Manual

SolrDocumentField::__destruct

(PECL solr >= 0.9.2)

SolrDocumentField::__destruct — Destructor

Açıklama

public void SolrDocumentField::__destruct ( void )

Destructor.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

None.

SolrDocumentField::__construct
SolrObject
SolrDocumentField


The SolrObject class

(PECL solr >= 0.9.2)

Giriş

This is an object whose properties can also by accessed using the array syntax. All its properties are read-only.

Sınıf Sözdizimi

final SolrObject implements ArrayAccess {
/* Yöntemler */
public __construct ( void )
public void __destruct ( void )
public array getPropertyNames ( void )
public bool offsetExists ( string $property_name )
public mixed offsetGet ( string $property_name )
public void offsetSet ( string $property_name , string $property_value )
public void offsetUnset ( string $property_name )
}

İçindekiler

  • SolrObject::__construct — Creates Solr object
  • SolrObject::__destruct — Destructor
  • SolrObject::getPropertyNames — Returns an array of all the names of the properties
  • SolrObject::offsetExists — Checks if the property exists
  • SolrObject::offsetGet — Used to retrieve a property
  • SolrObject::offsetSet — Sets the value for a property
  • SolrObject::offsetUnset — Unsets the value for the property
SolrDocumentField::__destruct
SolrObject::__construct
Solr


Creates Solr object

SolrObject
SolrObject::__destruct
SolrObject
PHP Manual

SolrObject::__construct

(PECL solr >= 0.9.2)

SolrObject::__construct — Creates Solr object

Açıklama

public SolrObject::__construct ( void )

Creates Solr object.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

None

Örnekler

Örnek 1 SolrObject::__construct() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

SolrObject
SolrObject::__destruct
SolrObject


Destructor

SolrObject::__construct
SolrObject::getPropertyNames
SolrObject
PHP Manual

SolrObject::__destruct

(PECL solr >= 0.9.2)

SolrObject::__destruct — Destructor

Açıklama

public void SolrObject::__destruct ( void )

The destructor

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

None.

SolrObject::__construct
SolrObject::getPropertyNames
SolrObject


Returns an array of all the names of the properties

SolrObject::__destruct
SolrObject::offsetExists
SolrObject
PHP Manual

SolrObject::getPropertyNames

(PECL solr >= 0.9.2)

SolrObject::getPropertyNames — Returns an array of all the names of the properties

Açıklama

public array SolrObject::getPropertyNames ( void )

Returns an array of all the names of the properties

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array.

SolrObject::__destruct
SolrObject::offsetExists
SolrObject


Checks if the property exists

SolrObject::getPropertyNames
SolrObject::offsetGet
SolrObject
PHP Manual

SolrObject::offsetExists

(PECL solr >= 0.9.2)

SolrObject::offsetExists — Checks if the property exists

Açıklama

public bool SolrObject::offsetExists ( string $property_name )

Checks if the property exists. This is used when the object is treated as an array.

Değiştirgeler

property_name

The name of the property.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

SolrObject::getPropertyNames
SolrObject::offsetGet
SolrObject


Used to retrieve a property

SolrObject::offsetExists
SolrObject::offsetSet
SolrObject
PHP Manual

SolrObject::offsetGet

(PECL solr >= 0.9.2)

SolrObject::offsetGet — Used to retrieve a property

Açıklama

public mixed SolrObject::offsetGet ( string $property_name )

Used to get the value of a property. This is used when the object is treated as an array.

Değiştirgeler

property_name

Name of the property.

Dönen Değerler

Returns the property value.

SolrObject::offsetExists
SolrObject::offsetSet
SolrObject


Sets the value for a property

SolrObject::offsetGet
SolrObject::offsetUnset
SolrObject
PHP Manual

SolrObject::offsetSet

(PECL solr >= 0.9.2)

SolrObject::offsetSet — Sets the value for a property

Açıklama

public void SolrObject::offsetSet ( string $property_name , string $property_value )

Sets the value for a property. This is used when the object is treated as an array. This object is read-only. This should never be attempted.

Değiştirgeler

property_name

The name of the property.

property_value

The new value.

Dönen Değerler

None.

SolrObject::offsetGet
SolrObject::offsetUnset
SolrObject


Unsets the value for the property

SolrObject::offsetSet
SolrClient
SolrObject
PHP Manual

SolrObject::offsetUnset

(PECL solr >= 0.9.2)

SolrObject::offsetUnset — Unsets the value for the property

Açıklama

public void SolrObject::offsetUnset ( string $property_name )

Unsets the value for the property. This is used when the object is treated as an array. This object is read-only. This should never be attempted.

Değiştirgeler

property_name

The name of the property.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 SolrObject::offsetUnset() example

<?php
/* ... */
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

  • Classname::Method()

SolrObject::offsetSet
SolrClient
SolrObject


The SolrClient class

(PECL solr >= 0.9.2)

Giriş

Used to send requests to a Solr server. Currently, cloning and serialization of SolrClient instances is not supported.

Sınıf Sözdizimi

final SolrClient {
/* Sabitler */
const integer SEARCH_SERVLET_TYPE = 1 ;
const integer UPDATE_SERVLET_TYPE = 2 ;
const integer THREADS_SERVLET_TYPE = 4 ;
const integer PING_SERVLET_TYPE = 8 ;
const integer TERMS_SERVLET_TYPE = 16 ;
const integer SYSTEM_SERVLET_TYPE = 32 ;
const string DEFAULT_SEARCH_SERVLET = select ;
const string DEFAULT_UPDATE_SERVLET = update ;
const string DEFAULT_THREADS_SERVLET = admin/threads ;
const string DEFAULT_PING_SERVLET = admin/ping ;
const string DEFAULT_TERMS_SERVLET = terms ;
const string DEFAULT_SYSTEM_SERVLET = admin/system ;
/* Yöntemler */
public SolrUpdateResponse addDocument ( SolrInputDocument $doc [, bool $overwrite = true [, int $commitWithin = 0 ]] )
public void addDocuments ( array $docs [, bool $overwrite = true [, int $commitWithin = 0 ]] )
public SolrUpdateResponse commit ([ bool $softCommit = false [, bool $waitSearcher = true [, bool $expungeDeletes = false ]]] )
public __construct ( array $clientOptions )
public SolrUpdateResponse deleteById ( string $id )
public SolrUpdateResponse deleteByIds ( array $ids )
public SolrUpdateResponse deleteByQueries ( array $queries )
public SolrUpdateResponse deleteByQuery ( string $query )
public void __destruct ( void )
public SolrQueryResponse getById ( string $id )
public SolrQueryResponse getByIds ( array $ids )
public string getDebug ( void )
public array getOptions ( void )
public SolrUpdateResponse optimize ([ int $maxSegments = 1 [, bool $softCommit = true [, bool $waitSearcher = true ]]] )
public SolrPingResponse ping ( void )
public SolrQueryResponse query ( SolrParams $query )
public SolrUpdateResponse request ( string $raw_request )
public SolrUpdateResponse rollback ( void )
public void setResponseWriter ( string $responseWriter )
public bool setServlet ( int $type , string $value )
public void system ( void )
public void threads ( void )
}

Öntanımlı Sabitler

SolrClient::SEARCH_SERVLET_TYPE

Used when updating the search servlet.

SolrClient::UPDATE_SERVLET_TYPE

Used when updating the update servlet.

SolrClient::THREADS_SERVLET_TYPE

Used when updating the threads servlet.

SolrClient::PING_SERVLET_TYPE

Used when updating the ping servlet.

SolrClient::TERMS_SERVLET_TYPE

Used when updating the terms servlet.

SolrClient::SYSTEM_SERVLET_TYPE

Used when retrieving system information from the system servlet.

SolrClient::DEFAULT_SEARCH_SERVLET

This is the intial value for the search servlet.

SolrClient::DEFAULT_UPDATE_SERVLET

This is the intial value for the update servlet.

SolrClient::DEFAULT_THREADS_SERVLET

This is the intial value for the threads servlet.

SolrClient::DEFAULT_PING_SERVLET

This is the intial value for the ping servlet.

SolrClient::DEFAULT_TERMS_SERVLET

This is the intial value for the terms servlet used for the TermsComponent

SolrClient::DEFAULT_SYSTEM_SERVLET

This is the intial value for the system servlet used to obtain Solr Server information

İçindekiler

  • SolrClient::addDocument — Adds a document to the index
  • SolrClient::addDocuments — Adds a collection of SolrInputDocument instances to the index
  • SolrClient::commit — Finalizes all add/deletes made to the index
  • SolrClient::__construct — Constructor for the SolrClient object
  • SolrClient::deleteById — Delete by Id
  • SolrClient::deleteByIds — Deletes by Ids
  • SolrClient::deleteByQueries — Removes all documents matching any of the queries
  • SolrClient::deleteByQuery — Deletes all documents matching the given query
  • SolrClient::__destruct — Destructor for SolrClient
  • SolrClient::getById — Get Document By Id. Utilizes Solr Realtime Get (RTG).
  • SolrClient::getByIds — Get Documents by their Ids. Utilizes Solr Realtime Get (RTG).
  • SolrClient::getDebug — Returns the debug data for the last connection attempt
  • SolrClient::getOptions — Returns the client options set internally
  • SolrClient::optimize — Defragments the index
  • SolrClient::ping — Checks if Solr server is still up
  • SolrClient::query — Sends a query to the server
  • SolrClient::request — Sends a raw update request
  • SolrClient::rollback — Rollbacks all add/deletes made to the index since the last commit
  • SolrClient::setResponseWriter — Sets the response writer used to prepare the response from Solr
  • SolrClient::setServlet — Changes the specified servlet type to a new value
  • SolrClient::system — Retrieve Solr Server information
  • SolrClient::threads — Checks the threads status
SolrObject::offsetUnset
SolrClient::addDocument
Solr


Adds a document to the index

SolrClient
SolrClient::addDocuments
SolrClient
PHP Manual

SolrClient::addDocument

(PECL solr >= 0.9.2)

SolrClient::addDocument — Adds a document to the index

Açıklama

public SolrUpdateResponse SolrClient::addDocument ( SolrInputDocument $doc [, bool $overwrite = true [, int $commitWithin = 0 ]] )

This method adds a document to the index.

Değiştirgeler

doc

The SolrInputDocument instance.

overwrite

Whether to overwrite existing document or not. If FALSE there will be duplicates (several documents with the same ID).

Uyarı

PECL Solr < 2.0 $allowDups was used instead of $overwrite, which does the same functionality with exact opposite bool flag.

$allowDups = false is the same as $overwrite = true

commitWithin

Number of milliseconds within which to auto commit this document. Available since Solr 1.4 . Default (0) means disabled.

When this value specified, it leaves the control of when to do the commit to Solr itself, optimizing number of commits to a minimum while still fulfilling the update latency requirements, and Solr will automatically do a commit when the oldest add in the buffer is due.

Dönen Değerler

Returns a SolrUpdateResponse object or throws an Exception on failure.

Hatalar/İstisnalar

Throws SolrClientException if the client had failed, or there was a connection issue.

Throws SolrServerException if the Solr Server had failed to process the request.

Örnekler

Örnek 1 SolrClient::addDocument() example

<?php

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$client = new SolrClient($options);

$doc = new SolrInputDocument();

$doc->addField('id', 334455);
$doc->addField('cat', 'Software');
$doc->addField('cat', 'Lucene');

$updateResponse = $client->addDocument($doc);

// you will have to commit changes to be written if you didn't use $commitWithin
$client->commit();

print_r($updateResponse->getResponse());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

SolrObject Object
(
    [responseHeader] => SolrObject Object
        (
            [status] => 0
            [QTime] => 1
        )

)

Örnek 2 SolrClient::addDocument() example 2

<?php

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$client = new SolrClient($options);

$doc = new SolrInputDocument();

$doc->addField('id', 334455);
$doc->addField('cat', 'Software');
$doc->addField('cat', 'Lucene');

// No need to call commit() because $commitWithin is passed, so Solr Server will auto commit within 10 seconds
$updateResponse = $client->addDocument($doc, false, 10000);

print_r($updateResponse->getResponse());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

SolrObject Object
(
    [responseHeader] => SolrObject Object
        (
            [status] => 0
            [QTime] => 1
        )

)

Ayrıca Bakınız

  • SolrClient::addDocuments() - Adds a collection of SolrInputDocument instances to the index
  • SolrClient::commit() - Finalizes all add/deletes made to the index

SolrClient
SolrClient::addDocuments
SolrClient


Adds a collection of SolrInputDocument instances to the index

SolrClient::addDocument
SolrClient::commit
SolrClient
PHP Manual

SolrClient::addDocuments

(PECL solr >= 0.9.2)

SolrClient::addDocuments — Adds a collection of SolrInputDocument instances to the index

Açıklama

public void SolrClient::addDocuments ( array $docs [, bool $overwrite = true [, int $commitWithin = 0 ]] )

Adds a collection of documents to the index.

Değiştirgeler

docs

An array containing the collection of SolrInputDocument instances. This array must be an actual variable.

overwrite

Whether to overwrite existing documents or not. If FALSE there will be duplicates (several documents with the same ID).

Uyarı

PECL Solr < 2.0 $allowDups was used instead of $overwrite, which does the same functionality with exact opposite bool flag.

$allowDups = false is the same as $overwrite = true

commitWithin

Number of milliseconds within which to auto commit this document. Available since Solr 1.4 . Default (0) means disabled.

When this value specified, it leaves the control of when to do the commit to Solr itself, optimizing number of commits to a minimum while still fulfilling the update latency requirements, and Solr will automatically do a commit when the oldest add in the buffer is due.

Dönen Değerler

Returns a SolrUpdateResponse object or throws an exception on failure.

Hatalar/İstisnalar

Throws SolrClientException if the client had failed, or there was a connection issue.

Throws SolrServerException if the Solr Server had failed to process the request.

Örnekler

Örnek 1 SolrClient::addDocuments() example

<?php

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$client = new SolrClient($options);

$doc = new SolrInputDocument();

$doc->addField('id', 334455);
$doc->addField('cat', 'Software');
$doc->addField('cat', 'Lucene');

$doc2 = clone $doc;

$doc2->deleteField('id');
$doc2->addField('id', 334456);

$docs = array($doc, $doc2);

$updateResponse = $client->addDocuments($docs);

// no changes will be written to disk unless $commitWithin is passed or SolrClient::commit is called

print_r($updateResponse->getResponse());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

SolrObject Object
(
    [responseHeader] => SolrObject Object
        (
            [status] => 0
            [QTime] => 2
        )

)

Ayrıca Bakınız

  • SolrClient::addDocument() - Adds a document to the index
  • SolrClient::commit() - Finalizes all add/deletes made to the index

SolrClient::addDocument
SolrClient::commit
SolrClient


Finalizes all add/deletes made to the index

SolrClient::addDocuments
SolrClient::__construct
SolrClient
PHP Manual

SolrClient::commit

(PECL solr >= 0.9.2)

SolrClient::commit — Finalizes all add/deletes made to the index

Açıklama

public SolrUpdateResponse SolrClient::commit ([ bool $softCommit = false [, bool $waitSearcher = true [, bool $expungeDeletes = false ]]] )

This method finalizes all add/deletes made to the index.

Değiştirgeler

softCommit

This will refresh the 'view' of the index in a more performant manner, but without "on-disk" guarantees. (Solr4.0+)

A soft commit is much faster since it only makes index changes visible and does not fsync index files or write a new index descriptor. If the JVM crashes or there is a loss of power, changes that occurred after the last hard commit will be lost. Search collections that have near-real-time requirements (that want index changes to be quickly visible to searches) will want to soft commit often but hard commit less frequently.

waitSearcher

block until a new searcher is opened and registered as the main query searcher, making the changes visible.

expungeDeletes

Merge segments with deletes away. (Solr1.4+)

Dönen Değerler

Returns a SolrUpdateResponse object on success or throws an exception on failure.

Hatalar/İstisnalar

Throws SolrClientException if the client had failed, or there was a connection issue.

Throws SolrServerException if the Solr Server had failed to process the request.

Sürüm Bilgisi

Sürüm: | Açıklama
1.1.0, 2.0.0 | $maxSegments removed
2.0.0b | API Changed: SolrClient::commit ([ int $maxSegments = 0 [, bool $softCommit = false [, bool $waitSearcher = true[, bool $expungeDeletes = false ]]] )
0.9.2 | Signature: SolrClient::commit ([ int $maxSegments = 1 [, bool $waitFlush = true [, bool $waitSearcher = true ]]] ). $waitFlush: Block until index changes are flushed to disk.

Notlar

Uyarı

PECL Solr >= 2.0 only supports Solr Server >= 4.0

Ayrıca Bakınız

  • SolrClient::optimize() - Defragments the index
  • SolrClient::rollback() - Rollbacks all add/deletes made to the index since the last commit

SolrClient::addDocuments
SolrClient::__construct
SolrClient


Constructor for the SolrClient object

SolrClient::commit
SolrClient::deleteById
SolrClient
PHP Manual

SolrClient::__construct

(PECL solr >= 0.9.2)

SolrClient::__construct — Constructor for the SolrClient object

Açıklama

public SolrClient::__construct ( array $clientOptions )

Constructor for the SolrClient object

Değiştirgeler

clientOptions

This is an array containing one of the following keys :

- secure          (Boolean value indicating whether or not to connect in secure mode)
 - hostname        (The hostname for the Solr server)
 - port            (The port number)
 - path            (The path to solr)
 - wt              (The name of the response writer e.g. xml, json)
 - login           (The username used for HTTP Authentication, if any)
 - password        (The HTTP Authentication password)
 - proxy_host      (The hostname for the proxy server, if any)
 - proxy_port      (The proxy port)
 - proxy_login     (The proxy username)
 - proxy_password  (The proxy password)
 - timeout         (This is maximum time in seconds allowed for the http data transfer operation. Default is 30 seconds)
 - ssl_cert        (File name to a PEM-formatted file containing the private key + private certificate (concatenated in that order) )
 - ssl_key         (File name to a PEM-formatted private key file only)
 - ssl_keypassword (Password for private key)
 - ssl_cainfo      (Name of file holding one or more CA certificates to verify peer with)
 - ssl_capath      (Name of directory holding multiple CA certificates to verify peer with )

 Please note the if the ssl_cert file only contains the private certificate, you have to specify a separate ssl_key file

 The ssl_keypassword option is required if the ssl_cert or ssl_key options are set.

Hatalar/İstisnalar

Throws SolrIllegalArgumentException on failure.

Örnekler

Örnek 1 SolrClient::__construct() example

<?php

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
    'path'     => SOLR_PATH_TO_SOLR,
    'wt'       => 'xml',
);

$client = new SolrClient($options);

$doc = new SolrInputDocument();

$doc->addField('id', 334455);
$doc->addField('cat', 'Software');
$doc->addField('cat', 'Lucene');

$updateResponse = $client->addDocument($doc);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ayrıca Bakınız

  • SolrClient::getOptions() - Returns the client options set internally

SolrClient::commit
SolrClient::deleteById
SolrClient


Delete by Id

SolrClient::__construct
SolrClient::deleteByIds
SolrClient
PHP Manual

SolrClient::deleteById

(PECL solr >= 0.9.2)

SolrClient::deleteById — Delete by Id

Açıklama

public SolrUpdateResponse SolrClient::deleteById ( string $id )

Deletes the document with the specified ID. Where ID is the value of the uniqueKey field declared in the schema

Değiştirgeler

id

The value of the uniqueKey field declared in the schema

Dönen Değerler

Returns a SolrUpdateResponse on success and throws an exception on failure.

Hatalar/İstisnalar

Throws SolrClientException if the client had failed, or there was a connection issue.

Throws SolrServerException if the Solr Server had failed to process the request.

Ayrıca Bakınız

  • SolrClient::deleteByIds() - Deletes by Ids
  • SolrClient::deleteByQuery() - Deletes all documents matching the given query
  • SolrClient::deleteByQueries() - Removes all documents matching any of the queries

SolrClient::__construct
SolrClient::deleteByIds
SolrClient


Deletes by Ids

SolrClient::deleteById
SolrClient::deleteByQueries
SolrClient
PHP Manual

SolrClient::deleteByIds

(PECL solr >= 0.9.2)

SolrClient::deleteByIds — Deletes by Ids

Açıklama

public SolrUpdateResponse SolrClient::deleteByIds ( array $ids )

Deletes a collection of documents with the specified set of ids.

Değiştirgeler

ids

An array of IDs representing the uniqueKey field declared in the schema for each document to be deleted. This must be an actual php variable.

Dönen Değerler

Returns a SolrUpdateResponse on success and throws an exception on failure.

Hatalar/İstisnalar

Throws SolrClientException if the client had failed, or there was a connection issue.

Throws SolrServerException if the Solr Server had failed to process the request.

Ayrıca Bakınız

  • SolrClient::deleteById() - Delete by Id
  • SolrClient::deleteByQuery() - Deletes all documents matching the given query
  • SolrClient::deleteByQueries() - Removes all documents matching any of the queries

SolrClient::deleteById
SolrClient::deleteByQueries
SolrClient


Removes all documents matching any of the queries

SolrClient::deleteByIds
SolrClient::deleteByQuery
SolrClient
PHP Manual

SolrClient::deleteByQueries

(PECL solr >= 0.9.2)

SolrClient::deleteByQueries — Removes all documents matching any of the queries

Açıklama

public SolrUpdateResponse SolrClient::deleteByQueries ( array $queries )

Removes all documents matching any of the queries

Değiştirgeler

queries

The array of queries. This must be an actual php variable.

Dönen Değerler

Returns a SolrUpdateResponse on success and throws a SolrClientException on failure.

Hatalar/İstisnalar

Throws SolrClientException if the client had failed, or there was a connection issue.

Throws SolrServerException if the Solr Server had failed to process the request.

Ayrıca Bakınız

  • SolrClient::deleteById() - Delete by Id
  • SolrClient::deleteByIds() - Deletes by Ids
  • SolrClient::deleteByQuery() - Deletes all documents matching the given query

SolrClient::deleteByIds
SolrClient::deleteByQuery
SolrClient


Deletes all documents matching the given query

SolrClient::deleteByQueries
SolrClient::__destruct
SolrClient
PHP Manual

SolrClient::deleteByQuery

(PECL solr >= 0.9.2)

SolrClient::deleteByQuery — Deletes all documents matching the given query

Açıklama

public SolrUpdateResponse SolrClient::deleteByQuery ( string $query )

Deletes all documents matching the given query.

Değiştirgeler

query

The query

Dönen Değerler

Returns a SolrUpdateResponse on success and throws an exception on failure.

Hatalar/İstisnalar

Throws SolrClientException if the client had failed, or there was a connection issue.

Throws SolrServerException if the Solr Server had failed to process the request.

Örnekler

Örnek 1 SolrQuery::deleteByQuery() example

<?php

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$client = new SolrClient($options);

//This will erase the entire index
$client->deleteByQuery("*:*");
$client->commit();

?>

Ayrıca Bakınız

  • SolrClient::deleteById() - Delete by Id
  • SolrClient::deleteByIds() - Deletes by Ids
  • SolrClient::deleteByQueries() - Removes all documents matching any of the queries

SolrClient::deleteByQueries
SolrClient::__destruct
SolrClient


Destructor for SolrClient

SolrClient::deleteByQuery
SolrClient::getById
SolrClient
PHP Manual

SolrClient::__destruct

(PECL solr >= 0.9.2)

SolrClient::__destruct — Destructor for SolrClient

Açıklama

public void SolrClient::__destruct ( void )

Destructor

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Destructor for SolrClient

Ayrıca Bakınız

  • SolrClient::__construct() - Constructor for the SolrClient object

SolrClient::deleteByQuery
SolrClient::getById
SolrClient


Get Document By Id. Utilizes Solr Realtime Get (RTG).

SolrClient::__destruct
SolrClient::getByIds
SolrClient
PHP Manual

SolrClient::getById

(PECL solr >= 2.2.0)

SolrClient::getById — Get Document By Id. Utilizes Solr Realtime Get (RTG).

Açıklama

public SolrQueryResponse SolrClient::getById ( string $id )

Get Document By Id. Utilizes Solr Realtime Get (RTG).

Değiştirgeler

id

Document ID

Dönen Değerler

SolrQueryResponse

Örnekler

Örnek 1 SolrClient::getById() example

<?php

include "bootstrap.php";

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
    'path'     => SOLR_SERVER_PATH
);

$client = new SolrClient($options);
$response = $client->getById('GB18030TEST');
print_r($response->getResponse());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

SolrObject Object
(
    [doc] => SolrObject Object
        (
            [id] => GB18030TEST
            [name] => Array
                (
                    [0] => Test with some GB18030 encoded characters
                )

            [features] => Array
                (
                    [0] => No accents here
                    [1] => ??????
                    [2] => This is a feature (translated)
                    [3] => ?????????
                    [4] => This document is very shiny (translated)
                )

            [price] => Array
                (
                    [0] => 0
                )

            [inStock] => Array
                (
                    [0] => 1
                )

            [_version_] => 1510294336239042560
        )

)

Ayrıca Bakınız

  • SolrClient::getByIds() - Get Documents by their Ids. Utilizes Solr Realtime Get (RTG).
SolrClient::__destruct
SolrClient::getByIds
SolrClient


Get Documents by their Ids. Utilizes Solr Realtime Get (RTG).

SolrClient::getById
SolrClient::getDebug
SolrClient
PHP Manual

SolrClient::getByIds

(PECL solr >= 2.2.0)

SolrClient::getByIds — Get Documents by their Ids. Utilizes Solr Realtime Get (RTG).

Açıklama

public SolrQueryResponse SolrClient::getByIds ( array $ids )

Get Documents by their Ids. Utilizes Solr Realtime Get (RTG).

Değiştirgeler

ids

Document ids

Dönen Değerler

SolrQueryResponse

Örnekler

Örnek 1 SolrClient::getByIds() example

<?php

include "bootstrap.php";

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
    'path'     => SOLR_SERVER_PATH
);

$client = new SolrClient($options);
$response = $client->getByIds(['GB18030TEST', '6H500F0']);

print_r($response->getResponse());

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

SolrObject Object
(
    [response] => SolrObject Object
        (
            [numFound] => 2
            [start] => 0
            [docs] => Array
                (
                    [0] => SolrObject Object
                        (
                            [id] => GB18030TEST
                            [name] => Array
                                (
                                    [0] => Test with some GB18030 encoded characters
                                )

                            [features] => Array
                                (
                                    [0] => No accents here
                                    [1] => ??????
                                    [2] => This is a feature (translated)
                                    [3] => ?????????
                                    [4] => This document is very shiny (translated)
                                )

                            [price] => Array
                                (
                                    [0] => 0
                                )

                            [inStock] => Array
                                (
                                    [0] => 1
                                )

                            [_version_] => 1510294336239042560
                        )

                    [1] => SolrObject Object
                        (
                            [id] => 6H500F0
                            [name] => Array
                                (
                                    [0] => Maxtor DiamondMax 11 - hard drive - 500 GB - SATA-300
                                )

                            [manu] => Array
                                (
                                    [0] => Maxtor Corp.
                                )

                            [manu_id_s] => maxtor
                            [cat] => Array
                                (
                                    [0] => electronics
                                    [1] => hard drive
                                )

                            [features] => Array
                                (
                                    [0] => SATA 3.0Gb/s, NCQ
                                    [1] => 8.5ms seek
                                    [2] => 16MB cache
                                )

                            [price] => Array
                                (
                                    [0] => 350
                                )

                            [popularity] => Array
                                (
                                    [0] => 6
                                )

                            [inStock] => Array
                                (
                                    [0] => 1
                                )

                            [store] => Array
                                (
                                    [0] => 45.17614,-93.87341
                                )

                            [manufacturedate_dt] => 2006-02-13T15:26:37Z
                            [_version_] => 1510294336449806336
                        )

                )

        )

)

Ayrıca Bakınız

  • SolrClient::getById() - Get Document By Id. Utilizes Solr Realtime Get (RTG).
SolrClient::getById
SolrClient::getDebug
SolrClient


Returns the debug data for the last connection attempt

SolrClient::getByIds
SolrClient::getOptions
SolrClient
PHP Manual

SolrClient::getDebug

(PECL solr >= 0.9.7)

SolrClient::getDebug — Returns the debug data for the last connection attempt

Açıklama

public string SolrClient::getDebug ( void )

Returns the debug data for the last connection attempt

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a string on success and null if there is nothing to return.

SolrClient::getByIds
SolrClient::getOptions
SolrClient


Returns the client options set internally

SolrClient::getDebug
SolrClient::optimize
SolrClient
PHP Manual

SolrClient::getOptions

(PECL solr >= 0.9.6)

SolrClient::getOptions — Returns the client options set internally

Açıklama

public array SolrClient::getOptions ( void )

Returns the client options set internally. Very useful for debugging. The values returned are readonly and can only be set when the object is instantiated.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array containing all the options for the SolrClient object set internally.

Ayrıca Bakınız

  • SolrClient::__construct() - Constructor for the SolrClient object

SolrClient::getDebug
SolrClient::optimize
SolrClient


Defragments the index

SolrClient::getOptions
SolrClient::ping
SolrClient
PHP Manual

SolrClient::optimize

(PECL solr >= 0.9.2)

SolrClient::optimize — Defragments the index

Açıklama

public SolrUpdateResponse SolrClient::optimize ([ int $maxSegments = 1 [, bool $softCommit = true [, bool $waitSearcher = true ]]] )

Defragments the index for faster search performance.

Değiştirgeler

maxSegments

Optimizes down to at most this number of segments. Since Solr 1.3

softCommit

This will refresh the 'view' of the index in a more performant manner, but without "on-disk" guarantees. (Solr4.0+)

waitSearcher

Block until a new searcher is opened and registered as the main query searcher, making the changes visible.

Dönen Değerler

Returns a SolrUpdateResponse on success or throws an exception on failure.

Hatalar/İstisnalar

Throws SolrClientException if the client had failed, or there was a connection issue.

Throws SolrServerException if the Solr Server had failed to process the request.

Notlar

Uyarı

PECL Solr >= 2.0 only supports Solr Server >= 4.0

Prior to PECL Solr 2.0 this method used to accept these arguments "int $maxSegments, bool $waitFlush, bool $waitSearcher".

Ayrıca Bakınız

  • SolrClient::commit() - Finalizes all add/deletes made to the index
  • SolrClient::rollback() - Rollbacks all add/deletes made to the index since the last commit

SolrClient::getOptions
SolrClient::ping
SolrClient


Checks if Solr server is still up

SolrClient::optimize
SolrClient::query
SolrClient
PHP Manual

SolrClient::ping

(PECL solr >= 0.9.2)

SolrClient::ping — Checks if Solr server is still up

Açıklama

public SolrPingResponse SolrClient::ping ( void )

Checks if the Solr server is still alive. Sends a HEAD request to the Apache Solr server.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a SolrPingResponse object on success and throws an exception on failure.

Hatalar/İstisnalar

Throws SolrClientException if the client had failed, or there was a connection issue.

Throws SolrServerException if the Solr Server had failed to satisfy the request.

Örnekler

Örnek 1 SolrClient::ping() example

<?php
$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$client = new SolrClient($options);

$pingresponse = $client->ping();

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

SolrClient::optimize
SolrClient::query
SolrClient


Sends a query to the server

SolrClient::ping
SolrClient::request
SolrClient
PHP Manual

SolrClient::query

(PECL solr >= 0.9.2)

SolrClient::query — Sends a query to the server

Açıklama

public SolrQueryResponse SolrClient::query ( SolrParams $query )

Sends a query to the server.

Değiştirgeler

query

A SolrParams object. It is recommended to use SolrQuery for advanced queries.

Dönen Değerler

Returns a SolrQueryResponse object on success and throws an exception on failure.

Hatalar/İstisnalar

Throws SolrClientException if the client had failed, or there was a connection issue.

Throws SolrServerException if the Solr Server had failed to satisfy the query.

Örnekler

Örnek 1 SolrClient::query() example

<?php

$options = array
(
    'hostname' => 'localhost',
    'login'    => 'username',
    'password' => 'password',
    'port'     => '8983',
);

$client = new SolrClient($options);

$query = new SolrQuery();

$query->setQuery('lucene');

$query->setStart(0);

$query->setRows(50);

$query->addField('cat')->addField('features')->addField('id')->addField('timestamp');

$query_response = $client->query($query);

$response = $query_response->getResponse();

print_r($response);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

SolrObject Object
(
    [responseHeader] => SolrObject Object
        (
            [status] => 0
            [QTime] => 3
            [params] => SolrObject Object
                (
                    [fl] => cat,features,id,timestamp
                    [indent] => on
                    [start] => 0
                    [q] => lucene
                    [wt] => xml
                    [version] => 2.2
                    [rows] => 50
                )

        )

    [response] => SolrObject Object
        (
            [numFound] => 1
            [start] => 0
            [docs] => Array
                (
                    [0] => SolrObject Object
                        (
                            [id] => SOLR1000
                            [cat] => Array
                                (
                                    [0] => software
                                    [1] => search
                                )

                            [features] => Array
                                (
                                    [0] => Advanced Full-Text Search Capabilities using Lucene
                                    [1] => Optimized for High Volume Web Traffic
                                    [2] => Standards Based Open Interfaces - XML and HTTP
                                    [3] => Comprehensive HTML Administration Interfaces
                                    [4] => Scalability - Efficient Replication to other Solr Search Servers
                                    [5] => Flexible and Adaptable with XML configuration and Schema
                                    [6] => Good unicode support: héllo (hello with an accent over the e)
                                )

                        )

                )

        )

)

SolrClient::ping
SolrClient::request
SolrClient


Sends a raw update request

SolrClient::query
SolrClient::rollback
SolrClient
PHP Manual

SolrClient::request

(PECL solr >= 0.9.2)

SolrClient::request — Sends a raw update request

Açıklama

public SolrUpdateResponse SolrClient::request ( string $raw_request )

Sends a raw XML update request to the server

Değiştirgeler

raw_request

An XML string with the raw request to the server.

Dönen Değerler

Returns a SolrUpdateResponse on success. Throws an exception on failure.

Hatalar/İstisnalar

Throws SolrIllegalArgumentException if raw_request was an empty string

Throws SolrClientException if the client had failed, or there was a connection issue.

Throws SolrServerException if the Solr Server had failed to satisfy the query.

Örnekler

Örnek 1 SolrClient::request() example

<?php
$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$client = new SolrClient($options);

$update_response = $client->request("<commit/>");

$response = $update_response->getResponse();

print_r($response);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

SolrClient::query
SolrClient::rollback
SolrClient


Rollbacks all add/deletes made to the index since the last commit

SolrClient::request
SolrClient::setResponseWriter
SolrClient
PHP Manual

SolrClient::rollback

(PECL solr >= 0.9.2)

SolrClient::rollback — Rollbacks all add/deletes made to the index since the last commit

Açıklama

public SolrUpdateResponse SolrClient::rollback ( void )

Rollbacks all add/deletes made to the index since the last commit. It neither calls any event listeners nor creates a new searcher.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a SolrUpdateResponse on success or throws a SolrClientException on failure.

Ayrıca Bakınız

  • SolrClient::commit() - Finalizes all add/deletes made to the index
  • SolrClient::optimize() - Defragments the index

SolrClient::request
SolrClient::setResponseWriter
SolrClient


Sets the response writer used to prepare the response from Solr

SolrClient::rollback
SolrClient::setServlet
SolrClient
PHP Manual

SolrClient::setResponseWriter

(PECL solr >= 0.9.11)

SolrClient::setResponseWriter — Sets the response writer used to prepare the response from Solr

Açıklama

public void SolrClient::setResponseWriter ( string $responseWriter )

Sets the response writer used to prepare the response from Solr

Değiştirgeler

responseWriter

One of the following:

  • json
  • phps
  • xml

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 SolrClient::setResponseWriter() example

<?php

// This is my custom class for objects
class SolrClass
{
   public $_properties = array();

   public function __get($property_name) {

      if (property_exists($this, $property_name)) {

          return $this->$property_name;

      } else if (isset($_properties[$property_name])) {

          return $_properties[$property_name];
      }

      return null;
   }
}

$options = array
(
  'hostname' => 'localhost',
  'port' => 8983,
  'path' => '/solr/core1'
);

$client = new SolrClient($options);

$client->setResponseWriter("json");

//$response = $client->ping();

$query = new SolrQuery();

$query->setQuery("*:*");

$query->set("objectClassName", "SolrClass");

$query->set("objectPropertiesStorageMode", 1); // 0 for independent properties, 1 for combined

try
{

$response = $client->query($query);

$resp = $response->getResponse();

print_r($response);

print_r($resp);

} catch (Exception $e) {

print_r($e);

}

?>

SolrClient::rollback
SolrClient::setServlet
SolrClient


Changes the specified servlet type to a new value

SolrClient::setResponseWriter
SolrClient::system
SolrClient
PHP Manual

SolrClient::setServlet

(PECL solr >= 0.9.2)

SolrClient::setServlet — Changes the specified servlet type to a new value

Açıklama

public bool SolrClient::setServlet ( int $type , string $value )

Changes the specified servlet type to a new value

Değiştirgeler

type

One of the following :

- SolrClient::SEARCH_SERVLET_TYPE
 - SolrClient::UPDATE_SERVLET_TYPE
 - SolrClient::THREADS_SERVLET_TYPE
 - SolrClient::PING_SERVLET_TYPE
 - SolrClient::TERMS_SERVLET_TYPE

value

The new value for the servlet

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

SolrClient::setResponseWriter
SolrClient::system
SolrClient


Retrieve Solr Server information

SolrClient::setServlet
SolrClient::threads
SolrClient
PHP Manual

SolrClient::system

(PECL solr >= 2.0.0)

SolrClient::system — Retrieve Solr Server information

Açıklama

public void SolrClient::system ( void )

Retrieve Solr Server information

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a SolrGenericResponse object on success.

Hatalar/İstisnalar

Emits SolrClientException if the client failed, or there was a connection issue.

Emits SolrServerException if the Solr Server failed to satisfy the query.

SolrClient::setServlet
SolrClient::threads
SolrClient


Checks the threads status

SolrClient::system
SolrResponse
SolrClient
PHP Manual

SolrClient::threads

(PECL solr >= 0.9.2)

SolrClient::threads — Checks the threads status

Açıklama

public void SolrClient::threads ( void )

Checks the threads status

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a SolrGenericResponse object.

Hatalar/İstisnalar

Throws SolrClientException if the client failed, or there was a connection issue.

throws SolrServerException if the Solr Server failed to process the request.

SolrClient::system
SolrResponse
SolrClient


The SolrResponse class

(PECL solr >= 0.9.2)

Giriş

Represents a response from the Solr server.

Sınıf Sözdizimi

abstract SolrResponse {
/* Sabitler */
const integer PARSE_SOLR_OBJ = 0 ;
const integer PARSE_SOLR_DOC = 1 ;
/* Özellikler */
protected integer $http_status ;
protected integer $parser_mode ;
protected bool $success ;
protected string $http_status_message ;
protected string $http_request_url ;
protected string $http_raw_request_headers ;
protected string $http_raw_request ;
protected string $http_raw_response_headers ;
protected string $http_raw_response ;
protected string $http_digested_response ;
/* Yöntemler */
public string getDigestedResponse ( void )
public int getHttpStatus ( void )
public string getHttpStatusMessage ( void )
public string getRawRequest ( void )
public string getRawRequestHeaders ( void )
public string getRawResponse ( void )
public string getRawResponseHeaders ( void )
public string getRequestUrl ( void )
public SolrObject getResponse ( void )
public bool setParseMode ([ int $parser_mode = 0 ] )
public bool success ( void )
}

Özellikler

http_status

The http status of the response.

parser_mode

Whether to parse the solr documents as SolrObject or SolrDocument instances.

success

Was there an error during the request

http_status_message

Detailed message on http status

http_request_url

The request URL

http_raw_request_headers

A string of raw headers sent during the request.

http_raw_request

The raw request sent to the server

http_raw_response_headers

Response headers from the Solr server.

http_raw_response

The response message from the server.

http_digested_response

The response in PHP serialized format.

Öntanımlı Sabitler

SolrResponse Class Constants

SolrResponse::PARSE_SOLR_OBJ

Documents should be parsed as SolrObject instances

SolrResponse::PARSE_SOLR_DOC

Documents should be parsed as SolrDocument instances.

İçindekiler

  • SolrResponse::getDigestedResponse — Returns the XML response as serialized PHP data
  • SolrResponse::getHttpStatus — Returns the HTTP status of the response
  • SolrResponse::getHttpStatusMessage — Returns more details on the HTTP status
  • SolrResponse::getRawRequest — Returns the raw request sent to the Solr server
  • SolrResponse::getRawRequestHeaders — Returns the raw request headers sent to the Solr server
  • SolrResponse::getRawResponse — Returns the raw response from the server
  • SolrResponse::getRawResponseHeaders — Returns the raw response headers from the server
  • SolrResponse::getRequestUrl — Returns the full URL the request was sent to
  • SolrResponse::getResponse — Returns a SolrObject representing the XML response from the server
  • SolrResponse::setParseMode — Sets the parse mode
  • SolrResponse::success — Was the request a success
SolrClient::threads
SolrResponse::getDigestedResponse
Solr


Returns the XML response as serialized PHP data

SolrResponse
SolrResponse::getHttpStatus
SolrResponse
PHP Manual

SolrResponse::getDigestedResponse

(PECL solr >= 0.9.2)

SolrResponse::getDigestedResponse — Returns the XML response as serialized PHP data

Açıklama

public string SolrResponse::getDigestedResponse ( void )

Returns the XML response as serialized PHP data

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the XML response as serialized PHP data

SolrResponse
SolrResponse::getHttpStatus
SolrResponse


Returns the HTTP status of the response

SolrResponse::getDigestedResponse
SolrResponse::getHttpStatusMessage
SolrResponse
PHP Manual

SolrResponse::getHttpStatus

(PECL solr >= 0.9.2)

SolrResponse::getHttpStatus — Returns the HTTP status of the response

Açıklama

public int SolrResponse::getHttpStatus ( void )

Returns the HTTP status of the response.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the HTTP status of the response.

SolrResponse::getDigestedResponse
SolrResponse::getHttpStatusMessage
SolrResponse


Returns more details on the HTTP status

SolrResponse::getHttpStatus
SolrResponse::getRawRequest
SolrResponse
PHP Manual

SolrResponse::getHttpStatusMessage

(PECL solr >= 0.9.2)

SolrResponse::getHttpStatusMessage — Returns more details on the HTTP status

Açıklama

public string SolrResponse::getHttpStatusMessage ( void )

Returns more details on the HTTP status.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns more details on the HTTP status

SolrResponse::getHttpStatus
SolrResponse::getRawRequest
SolrResponse


Returns the raw request sent to the Solr server

SolrResponse::getHttpStatusMessage
SolrResponse::getRawRequestHeaders
SolrResponse
PHP Manual

SolrResponse::getRawRequest

(PECL solr >= 0.9.2)

SolrResponse::getRawRequest — Returns the raw request sent to the Solr server

Açıklama

public string SolrResponse::getRawRequest ( void )

Returns the raw request sent to the Solr server.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the raw request sent to the Solr server

SolrResponse::getHttpStatusMessage
SolrResponse::getRawRequestHeaders
SolrResponse


Returns the raw request headers sent to the Solr server

SolrResponse::getRawRequest
SolrResponse::getRawResponse
SolrResponse
PHP Manual

SolrResponse::getRawRequestHeaders

(PECL solr >= 0.9.2)

SolrResponse::getRawRequestHeaders — Returns the raw request headers sent to the Solr server

Açıklama

public string SolrResponse::getRawRequestHeaders ( void )

Returns the raw request headers sent to the Solr server.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the raw request headers sent to the Solr server

SolrResponse::getRawRequest
SolrResponse::getRawResponse
SolrResponse


Returns the raw response from the server

SolrResponse::getRawRequestHeaders
SolrResponse::getRawResponseHeaders
SolrResponse
PHP Manual

SolrResponse::getRawResponse

(PECL solr >= 0.9.2)

SolrResponse::getRawResponse — Returns the raw response from the server

Açıklama

public string SolrResponse::getRawResponse ( void )

Returns the raw response from the server.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the raw response from the server.

SolrResponse::getRawRequestHeaders
SolrResponse::getRawResponseHeaders
SolrResponse


Returns the raw response headers from the server

SolrResponse::getRawResponse
SolrResponse::getRequestUrl
SolrResponse
PHP Manual

SolrResponse::getRawResponseHeaders

(PECL solr >= 0.9.2)

SolrResponse::getRawResponseHeaders — Returns the raw response headers from the server

Açıklama

public string SolrResponse::getRawResponseHeaders ( void )

Returns the raw response headers from the server.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the raw response headers from the server.

SolrResponse::getRawResponse
SolrResponse::getRequestUrl
SolrResponse


Returns the full URL the request was sent to

SolrResponse::getRawResponseHeaders
SolrResponse::getResponse
SolrResponse
PHP Manual

SolrResponse::getRequestUrl

(PECL solr >= 0.9.2)

SolrResponse::getRequestUrl — Returns the full URL the request was sent to

Açıklama

public string SolrResponse::getRequestUrl ( void )

Returns the full URL the request was sent to.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the full URL the request was sent to

SolrResponse::getRawResponseHeaders
SolrResponse::getResponse
SolrResponse


Returns a SolrObject representing the XML response from the server

SolrResponse::getRequestUrl
SolrResponse::setParseMode
SolrResponse
PHP Manual

SolrResponse::getResponse

(PECL solr >= 0.9.2)

SolrResponse::getResponse — Returns a SolrObject representing the XML response from the server

Açıklama

public SolrObject SolrResponse::getResponse ( void )

Returns a SolrObject representing the XML response from the server.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a SolrObject representing the XML response from the server

SolrResponse::getRequestUrl
SolrResponse::setParseMode
SolrResponse


Sets the parse mode

SolrResponse::getResponse
SolrResponse::success
SolrResponse
PHP Manual

SolrResponse::setParseMode

(PECL solr >= 0.9.2)

SolrResponse::setParseMode — Sets the parse mode

Açıklama

public bool SolrResponse::setParseMode ([ int $parser_mode = 0 ] )

Sets the parse mode.

Değiştirgeler

parser_mode

SolrResponse::PARSE_SOLR_DOC parses documents in SolrDocument instances. SolrResponse::PARSE_SOLR_OBJ parses document into SolrObjects.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

SolrResponse::getResponse
SolrResponse::success
SolrResponse


Was the request a success

SolrResponse::setParseMode
SolrQueryResponse
SolrResponse
PHP Manual

SolrResponse::success

(PECL solr >= 0.9.2)

SolrResponse::success — Was the request a success

Açıklama

public bool SolrResponse::success ( void )

Used to check if the request to the server was successful.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if it was successful and FALSE if it was not.

SolrResponse::setParseMode
SolrQueryResponse
SolrResponse


The SolrQueryResponse class

(PECL solr >= 0.9.2)

Giriş

Represents a response to a query request.

Sınıf Sözdizimi

final SolrQueryResponse extends SolrResponse {
/* Sabitler */
const integer PARSE_SOLR_OBJ = 0 ;
const integer PARSE_SOLR_DOC = 1 ;
/* Miras alınan özellikler */
const integer SolrResponse::PARSE_SOLR_OBJ = 0 ;
const integer SolrResponse::PARSE_SOLR_DOC = 1 ;
protected integer $http_status ;
protected integer $parser_mode ;
protected bool $success ;
protected string $http_status_message ;
protected string $http_request_url ;
protected string $http_raw_request_headers ;
protected string $http_raw_request ;
protected string $http_raw_response_headers ;
protected string $http_raw_response ;
protected string $http_digested_response ;
/* Yöntemler */
public __construct ( void )
public void __destruct ( void )
/* Miras alınan yöntemler */
public string SolrResponse::getDigestedResponse ( void )
public int SolrResponse::getHttpStatus ( void )
public string SolrResponse::getHttpStatusMessage ( void )
public string SolrResponse::getRawRequest ( void )
public string SolrResponse::getRawRequestHeaders ( void )
public string SolrResponse::getRawResponse ( void )
public string SolrResponse::getRawResponseHeaders ( void )
public string SolrResponse::getRequestUrl ( void )
public SolrObject SolrResponse::getResponse ( void )
public bool SolrResponse::setParseMode ([ int $parser_mode = 0 ] )
public bool SolrResponse::success ( void )
}

Öntanımlı Sabitler

SolrQueryResponse Class constants

SolrQueryResponse::PARSE_SOLR_OBJ

Documents should be parsed as SolrObject instances

SolrQueryResponse::PARSE_SOLR_DOC

Documents should be parsed as SolrDocument instances.

İçindekiler

  • SolrQueryResponse::__construct — Constructor
  • SolrQueryResponse::__destruct — Destructor
SolrResponse::success
SolrQueryResponse::__construct
Solr


Constructor

SolrQueryResponse
SolrQueryResponse::__destruct
SolrQueryResponse
PHP Manual

SolrQueryResponse::__construct

(PECL solr >= 0.9.2)

SolrQueryResponse::__construct — Constructor

Açıklama

public SolrQueryResponse::__construct ( void )

Constructor

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

None

SolrQueryResponse
SolrQueryResponse::__destruct
SolrQueryResponse


Destructor

SolrQueryResponse::__construct
SolrUpdateResponse
SolrQueryResponse
PHP Manual

SolrQueryResponse::__destruct

(PECL solr >= 0.9.2)

SolrQueryResponse::__destruct — Destructor

Açıklama

public void SolrQueryResponse::__destruct ( void )

Destructor.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

None

SolrQueryResponse::__construct
SolrUpdateResponse
SolrQueryResponse


The SolrUpdateResponse class

(PECL solr >= 0.9.2)

Giriş

Represents a response to an update request.

Sınıf Sözdizimi

final SolrUpdateResponse extends SolrResponse {
/* Sabitler */
const integer PARSE_SOLR_OBJ = 0 ;
const integer PARSE_SOLR_DOC = 1 ;
/* Miras alınan özellikler */
const integer SolrResponse::PARSE_SOLR_OBJ = 0 ;
const integer SolrResponse::PARSE_SOLR_DOC = 1 ;
protected integer $http_status ;
protected integer $parser_mode ;
protected bool $success ;
protected string $http_status_message ;
protected string $http_request_url ;
protected string $http_raw_request_headers ;
protected string $http_raw_request ;
protected string $http_raw_response_headers ;
protected string $http_raw_response ;
protected string $http_digested_response ;
/* Yöntemler */
public __construct ( void )
public void __destruct ( void )
/* Miras alınan yöntemler */
public string SolrResponse::getDigestedResponse ( void )
public int SolrResponse::getHttpStatus ( void )
public string SolrResponse::getHttpStatusMessage ( void )
public string SolrResponse::getRawRequest ( void )
public string SolrResponse::getRawRequestHeaders ( void )
public string SolrResponse::getRawResponse ( void )
public string SolrResponse::getRawResponseHeaders ( void )
public string SolrResponse::getRequestUrl ( void )
public SolrObject SolrResponse::getResponse ( void )
public bool SolrResponse::setParseMode ([ int $parser_mode = 0 ] )
public bool SolrResponse::success ( void )
}

Öntanımlı Sabitler

SolrUpdateResponse Class Constants

SolrUpdateResponse::PARSE_SOLR_OBJ

Documents should be parsed as SolrObject instances

SolrUpdateResponse::PARSE_SOLR_DOC

Documents should be parsed as SolrDocument instances.

İçindekiler

  • SolrUpdateResponse::__construct — Constructor
  • SolrUpdateResponse::__destruct — Destructor
SolrQueryResponse::__destruct
SolrUpdateResponse::__construct
Solr


Constructor

SolrUpdateResponse
SolrUpdateResponse::__destruct
SolrUpdateResponse
PHP Manual

SolrUpdateResponse::__construct

(PECL solr >= 0.9.2)

SolrUpdateResponse::__construct — Constructor

Açıklama

public SolrUpdateResponse::__construct ( void )

Constructor

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

None

SolrUpdateResponse
SolrUpdateResponse::__destruct
SolrUpdateResponse


Destructor

SolrUpdateResponse::__construct
SolrPingResponse
SolrUpdateResponse
PHP Manual

SolrUpdateResponse::__destruct

(PECL solr >= 0.9.2)

SolrUpdateResponse::__destruct — Destructor

Açıklama

public void SolrUpdateResponse::__destruct ( void )

Destructor

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

None

SolrUpdateResponse::__construct
SolrPingResponse
SolrUpdateResponse


The SolrPingResponse class

(PECL solr >= 0.9.2)

Giriş

Represents a response to a ping request to the server

Sınıf Sözdizimi

final SolrPingResponse extends SolrResponse {
/* Sabitler */
const integer PARSE_SOLR_OBJ = 0 ;
const integer PARSE_SOLR_DOC = 1 ;
/* Özellikler */
/* Yöntemler */
public __construct ( void )
public void __destruct ( void )
public string getResponse ( void )
/* Miras alınan yöntemler */
public string SolrResponse::getDigestedResponse ( void )
public int SolrResponse::getHttpStatus ( void )
public string SolrResponse::getHttpStatusMessage ( void )
public string SolrResponse::getRawRequest ( void )
public string SolrResponse::getRawRequestHeaders ( void )
public string SolrResponse::getRawResponse ( void )
public string SolrResponse::getRawResponseHeaders ( void )
public string SolrResponse::getRequestUrl ( void )
public SolrObject SolrResponse::getResponse ( void )
public bool SolrResponse::setParseMode ([ int $parser_mode = 0 ] )
public bool SolrResponse::success ( void )
}

Özellikler

http_status

The http status of the response.

parser_mode

Whether to parse the solr documents as SolrObject or SolrDocument instances.

success

Was there an error during the request

http_status_message

Detailed message on http status

http_request_url

The request URL

http_raw_request_headers

A string of raw headers sent during the request

http_raw_request

The raw request sent to the server

http_raw_response_headers

Response headers from the Solr server

http_raw_response

The response message from the server

http_digested_response

The response in PHP serialized format.

Öntanımlı Sabitler

SolrPingResponse Class Constants

SolrPingResponse::PARSE_SOLR_OBJ

Documents should be parsed as SolrObject instances

SolrPingResponse::PARSE_SOLR_DOC

Documents should be parsed as SolrDocument instances.

İçindekiler

  • SolrPingResponse::__construct — Constructor
  • SolrPingResponse::__destruct — Destructor
  • SolrPingResponse::getResponse — Returns the response from the server
SolrUpdateResponse::__destruct
SolrPingResponse::__construct
Solr


Constructor

SolrPingResponse
SolrPingResponse::__destruct
SolrPingResponse
PHP Manual

SolrPingResponse::__construct

(PECL solr >= 0.9.2)

SolrPingResponse::__construct — Constructor

Açıklama

public SolrPingResponse::__construct ( void )

Constructor

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

None

SolrPingResponse
SolrPingResponse::__destruct
SolrPingResponse


Destructor

SolrPingResponse::__construct
SolrPingResponse::getResponse
SolrPingResponse
PHP Manual

SolrPingResponse::__destruct

(PECL solr >= 0.9.2)

SolrPingResponse::__destruct — Destructor

Açıklama

public void SolrPingResponse::__destruct ( void )

Destructor

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

None

SolrPingResponse::__construct
SolrPingResponse::getResponse
SolrPingResponse


Returns the response from the server

SolrPingResponse::__destruct
SolrGenericResponse
SolrPingResponse
PHP Manual

SolrPingResponse::getResponse

(PECL solr >= 0.9.2)

SolrPingResponse::getResponse — Returns the response from the server

Açıklama

public string SolrPingResponse::getResponse ( void )

Returns the response from the server. This should be empty because the request as a HEAD request.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an empty string.

SolrPingResponse::__destruct
SolrGenericResponse
SolrPingResponse


The SolrGenericResponse class

(PECL solr >= 0.9.2)

Giriş

Represents a response from the solr server.

Sınıf Sözdizimi

final SolrGenericResponse extends SolrResponse {
/* Sabitler */
const integer PARSE_SOLR_OBJ = 0 ;
const integer PARSE_SOLR_DOC = 1 ;
/* Miras alınan özellikler */
const integer SolrResponse::PARSE_SOLR_OBJ = 0 ;
const integer SolrResponse::PARSE_SOLR_DOC = 1 ;
protected integer $http_status ;
protected integer $parser_mode ;
protected bool $success ;
protected string $http_status_message ;
protected string $http_request_url ;
protected string $http_raw_request_headers ;
protected string $http_raw_request ;
protected string $http_raw_response_headers ;
protected string $http_raw_response ;
protected string $http_digested_response ;
/* Yöntemler */
public __construct ( void )
public void __destruct ( void )
/* Miras alınan yöntemler */
public string SolrResponse::getDigestedResponse ( void )
public int SolrResponse::getHttpStatus ( void )
public string SolrResponse::getHttpStatusMessage ( void )
public string SolrResponse::getRawRequest ( void )
public string SolrResponse::getRawRequestHeaders ( void )
public string SolrResponse::getRawResponse ( void )
public string SolrResponse::getRawResponseHeaders ( void )
public string SolrResponse::getRequestUrl ( void )
public SolrObject SolrResponse::getResponse ( void )
public bool SolrResponse::setParseMode ([ int $parser_mode = 0 ] )
public bool SolrResponse::success ( void )
}

Öntanımlı Sabitler

SolrGenericResponse Class constants

SolrGenericResponse::PARSE_SOLR_OBJ

Documents should be parsed as SolrObject instances

SolrGenericResponse::PARSE_SOLR_DOC

Documents should be parsed as SolrDocument instances.

İçindekiler

  • SolrGenericResponse::__construct — Constructor
  • SolrGenericResponse::__destruct — Destructor
SolrPingResponse::getResponse
SolrGenericResponse::__construct
Solr


Constructor

SolrGenericResponse
SolrGenericResponse::__destruct
SolrGenericResponse
PHP Manual

SolrGenericResponse::__construct

(PECL solr >= 0.9.2)

SolrGenericResponse::__construct — Constructor

Açıklama

public SolrGenericResponse::__construct ( void )

Constructor

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

None

SolrGenericResponse
SolrGenericResponse::__destruct
SolrGenericResponse


Destructor

SolrGenericResponse::__construct
SolrParams
SolrGenericResponse
PHP Manual

SolrGenericResponse::__destruct

(PECL solr >= 0.9.2)

SolrGenericResponse::__destruct — Destructor

Açıklama

public void SolrGenericResponse::__destruct ( void )

Destructor.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

None

SolrGenericResponse::__construct
SolrParams
SolrGenericResponse


The SolrParams class

(PECL solr >= 0.9.2)

Giriş

Represents a collection of name-value pairs sent to the Solr server during a request.

Sınıf Sözdizimi

abstract SolrParams implements Serializable {
/* Yöntemler */
final public SolrParams add ( string $name , string $value )
public SolrParams addParam ( string $name , string $value )
final public mixed get ( string $param_name )
final public mixed getParam ([ string $param_name ] )
final public array getParams ( void )
final public array getPreparedParams ( void )
final public string serialize ( void )
final public void set ( string $name , string $value )
public SolrParams setParam ( string $name , string $value )
final public string toString ([ bool $url_encode = false ] )
final public void unserialize ( string $serialized )
}

İçindekiler

  • SolrParams::add — This is an alias for SolrParams::addParam
  • SolrParams::addParam — Adds a parameter to the object
  • SolrParams::get — This is an alias for SolrParams::getParam
  • SolrParams::getParam — Returns a parameter value
  • SolrParams::getParams — Returns an array of non URL-encoded parameters
  • SolrParams::getPreparedParams — Returns an array of URL-encoded parameters
  • SolrParams::serialize — Used for custom serialization
  • SolrParams::set — An alias of SolrParams::setParam
  • SolrParams::setParam — Sets the parameter to the specified value
  • SolrParams::toString — Returns all the name-value pair parameters in the object
  • SolrParams::unserialize — Used for custom serialization
SolrGenericResponse::__destruct
SolrParams::add
Solr


This is an alias for SolrParams::addParam

SolrParams
SolrParams::addParam
SolrParams
PHP Manual

SolrParams::add

(PECL solr >= 0.9.2)

SolrParams::add — This is an alias for SolrParams::addParam

Açıklama

final public SolrParams SolrParams::add ( string $name , string $value )

This is an alias for SolrParams::addParam

Değiştirgeler

name

The name of the parameter

value

The value of the parameter

Dönen Değerler

Returns a SolrParams instance on success

SolrParams
SolrParams::addParam
SolrParams


Adds a parameter to the object

SolrParams::add
SolrParams::get
SolrParams
PHP Manual

SolrParams::addParam

(PECL solr >= 0.9.2)

SolrParams::addParam — Adds a parameter to the object

Açıklama

public SolrParams SolrParams::addParam ( string $name , string $value )

Adds a parameter to the object. This is used for parameters that can be specified multiple times.

Değiştirgeler

name

Name of parameter

value

Value of parameter

Dönen Değerler

Returns a SolrParam object on success and FALSE on failure.

SolrParams::add
SolrParams::get
SolrParams


This is an alias for SolrParams::getParam

SolrParams::addParam
SolrParams::getParam
SolrParams
PHP Manual

SolrParams::get

(PECL solr >= 0.9.2)

SolrParams::get — This is an alias for SolrParams::getParam

Açıklama

final public mixed SolrParams::get ( string $param_name )

This is an alias for SolrParams::getParam

Değiştirgeler

param_name

Then name of the parameter

Dönen Değerler

Returns an array or string depending on the type of parameter

SolrParams::addParam
SolrParams::getParam
SolrParams


Returns a parameter value

SolrParams::get
SolrParams::getParams
SolrParams
PHP Manual

SolrParams::getParam

(PECL solr >= 0.9.2)

SolrParams::getParam — Returns a parameter value

Açıklama

final public mixed SolrParams::getParam ([ string $param_name ] )

Returns a parameter with name param_name

Değiştirgeler

param_name

The name of the parameter

Dönen Değerler

Returns a string or an array depending on the type of the parameter

SolrParams::get
SolrParams::getParams
SolrParams


Returns an array of non URL-encoded parameters

SolrParams::getParam
SolrParams::getPreparedParams
SolrParams
PHP Manual

SolrParams::getParams

(PECL solr >= 0.9.2)

SolrParams::getParams — Returns an array of non URL-encoded parameters

Açıklama

final public array SolrParams::getParams ( void )

Returns an array of non URL-encoded parameters

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array of non URL-encoded parameters

SolrParams::getParam
SolrParams::getPreparedParams
SolrParams


Returns an array of URL-encoded parameters

SolrParams::getParams
SolrParams::serialize
SolrParams
PHP Manual

SolrParams::getPreparedParams

(PECL solr >= 0.9.2)

SolrParams::getPreparedParams — Returns an array of URL-encoded parameters

Açıklama

final public array SolrParams::getPreparedParams ( void )

Returns an array on URL-encoded parameters

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array on URL-encoded parameters

SolrParams::getParams
SolrParams::serialize
SolrParams


Used for custom serialization

SolrParams::getPreparedParams
SolrParams::set
SolrParams
PHP Manual

SolrParams::serialize

(PECL solr >= 0.9.2)

SolrParams::serialize — Used for custom serialization

Açıklama

final public string SolrParams::serialize ( void )

Used for custom serialization

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Used for custom serialization

SolrParams::getPreparedParams
SolrParams::set
SolrParams


An alias of SolrParams::setParam

SolrParams::serialize
SolrParams::setParam
SolrParams
PHP Manual

SolrParams::set

(PECL solr >= 0.9.2)

SolrParams::set — An alias of SolrParams::setParam

Açıklama

final public void SolrParams::set ( string $name , string $value )

An alias of SolrParams::setParam

Değiştirgeler

name

Then name of the parameter

value

The parameter value

Dönen Değerler

Returns an instance of the SolrParams object on success

SolrParams::serialize
SolrParams::setParam
SolrParams


Sets the parameter to the specified value

SolrParams::set
SolrParams::toString
SolrParams
PHP Manual

SolrParams::setParam

(PECL solr >= 0.9.2)

SolrParams::setParam — Sets the parameter to the specified value

Açıklama

public SolrParams SolrParams::setParam ( string $name , string $value )

Sets the query parameter to the specified value. This is used for parameters that can only be specified once. Subsequent calls with the same parameter name will override the existing value

Değiştirgeler

name

Name of the parameter

value

Value of the parameter

Dönen Değerler

Returns a SolrParam object on success and FALSE on value.

Örnekler

Örnek 1 SolrParams::setParam() example

<?php

$param = new SolrParams();

$param->setParam('q', 'solr')->setParam('rows', 2);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

SolrParams::set
SolrParams::toString
SolrParams


Returns all the name-value pair parameters in the object

SolrParams::setParam
SolrParams::unserialize
SolrParams
PHP Manual

SolrParams::toString

(PECL solr >= 0.9.2)

SolrParams::toString — Returns all the name-value pair parameters in the object

Açıklama

final public string SolrParams::toString ([ bool $url_encode = false ] )

Returns all the name-value pair parameters in the object

Değiştirgeler

url_encode

Whether to return URL-encoded values

Dönen Değerler

Returns a string on success and FALSE on failure.

SolrParams::setParam
SolrParams::unserialize
SolrParams


Used for custom serialization

SolrParams::toString
SolrModifiableParams
SolrParams
PHP Manual

SolrParams::unserialize

(PECL solr >= 0.9.2)

SolrParams::unserialize — Used for custom serialization

Açıklama

final public void SolrParams::unserialize ( string $serialized )

Used for custom serialization

Değiştirgeler

serialized

The serialized representation of the object

Dönen Değerler

None

SolrParams::toString
SolrModifiableParams
SolrParams


The SolrModifiableParams class

(PECL solr >= 0.9.2)

Giriş

Represents a collection of name-value pairs sent to the Solr server during a request.

Sınıf Sözdizimi

SolrModifiableParams extends SolrParams implements Serializable {
/* Yöntemler */
public __construct ( void )
public void __destruct ( void )
/* Miras alınan yöntemler */
final public SolrParams SolrParams::add ( string $name , string $value )
public SolrParams SolrParams::addParam ( string $name , string $value )
final public mixed SolrParams::get ( string $param_name )
final public mixed SolrParams::getParam ([ string $param_name ] )
final public array SolrParams::getParams ( void )
final public array SolrParams::getPreparedParams ( void )
final public string SolrParams::serialize ( void )
final public void SolrParams::set ( string $name , string $value )
public SolrParams SolrParams::setParam ( string $name , string $value )
final public string SolrParams::toString ([ bool $url_encode = false ] )
final public void SolrParams::unserialize ( string $serialized )
}

İçindekiler

  • SolrModifiableParams::__construct — Constructor
  • SolrModifiableParams::__destruct — Destructor
SolrParams::unserialize
SolrModifiableParams::__construct
Solr


Constructor

SolrModifiableParams
SolrModifiableParams::__destruct
SolrModifiableParams
PHP Manual

SolrModifiableParams::__construct

(PECL solr >= 0.9.2)

SolrModifiableParams::__construct — Constructor

Açıklama

public SolrModifiableParams::__construct ( void )

Constructor

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

None

SolrModifiableParams
SolrModifiableParams::__destruct
SolrModifiableParams


Destructor

SolrModifiableParams::__construct
SolrQuery
SolrModifiableParams
PHP Manual

SolrModifiableParams::__destruct

(PECL solr >= 0.9.2)

SolrModifiableParams::__destruct — Destructor

Açıklama

public void SolrModifiableParams::__destruct ( void )

Destructor

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

None

SolrModifiableParams::__construct
SolrQuery
SolrModifiableParams


The SolrQuery class

(PECL solr >= 0.9.2)

Giriş

Represents a collection of name-value pairs sent to the Solr server during a request.

Sınıf Sözdizimi

SolrQuery extends SolrModifiableParams implements Serializable {
/* Sabitler */
const integer ORDER_ASC = 0 ;
const integer ORDER_DESC = 1 ;
const integer FACET_SORT_INDEX = 0 ;
const integer FACET_SORT_COUNT = 1 ;
const integer TERMS_SORT_INDEX = 0 ;
const integer TERMS_SORT_COUNT = 1 ;
/* Özellikler */
/* Yöntemler */
public SolrQuery addExpandFilterQuery ( string $fq )
public SolrQuery addExpandSortField ( string $field [, string $order ] )
public SolrQuery addFacetDateField ( string $dateField )
public SolrQuery addFacetDateOther ( string $value [, string $field_override ] )
public SolrQuery addFacetField ( string $field )
public SolrQuery addFacetQuery ( string $facetQuery )
public SolrQuery addField ( string $field )
public SolrQuery addFilterQuery ( string $fq )
public SolrQuery addGroupField ( string $value )
public SolrQuery addGroupFunction ( string $value )
public SolrQuery addGroupQuery ( string $value )
public SolrQuery addGroupSortField ( string $field [, integer $order ] )
public SolrQuery addHighlightField ( string $field )
public SolrQuery addMltField ( string $field )
public SolrQuery addMltQueryField ( string $field , float $boost )
public SolrQuery addSortField ( string $field [, int $order = SolrQuery::ORDER_DESC ] )
public SolrQuery addStatsFacet ( string $field )
public SolrQuery addStatsField ( string $field )
public SolrQuery collapse ( SolrCollapseFunction $collapseFunction )
public __construct ([ string $q ] )
public void __destruct ( void )
public bool getExpand ( void )
public array getExpandFilterQueries ( void )
public array getExpandQuery ( void )
public integer getExpandRows ( void )
public array getExpandSortFields ( void )
public bool getFacet ( void )
public string getFacetDateEnd ([ string $field_override ] )
public array getFacetDateFields ( void )
public string getFacetDateGap ([ string $field_override ] )
public string getFacetDateHardEnd ([ string $field_override ] )
public array getFacetDateOther ([ string $field_override ] )
public string getFacetDateStart ([ string $field_override ] )
public array getFacetFields ( void )
public int getFacetLimit ([ string $field_override ] )
public string getFacetMethod ([ string $field_override ] )
public int getFacetMinCount ([ string $field_override ] )
public bool getFacetMissing ([ string $field_override ] )
public int getFacetOffset ([ string $field_override ] )
public string getFacetPrefix ([ string $field_override ] )
public array getFacetQueries ( void )
public int getFacetSort ([ string $field_override ] )
public array getFields ( void )
public array getFilterQueries ( void )
public bool getGroup ( void )
public integer getGroupCachePercent ( void )
public bool getGroupFacet ( void )
public array getGroupFields ( void )
public string getGroupFormat ( void )
public array getGroupFunctions ( void )
public integer getGroupLimit ( void )
public bool getGroupMain ( void )
public bool getGroupNGroups ( void )
public integer getGroupOffset ( void )
public array getGroupQueries ( void )
public array getGroupSortFields ( void )
public bool getGroupTruncate ( void )
public bool getHighlight ( void )
public string getHighlightAlternateField ([ string $field_override ] )
public array getHighlightFields ( void )
public string getHighlightFormatter ([ string $field_override ] )
public string getHighlightFragmenter ([ string $field_override ] )
public int getHighlightFragsize ([ string $field_override ] )
public bool getHighlightHighlightMultiTerm ( void )
public int getHighlightMaxAlternateFieldLength ([ string $field_override ] )
public int getHighlightMaxAnalyzedChars ( void )
public bool getHighlightMergeContiguous ([ string $field_override ] )
public int getHighlightRegexMaxAnalyzedChars ( void )
public string getHighlightRegexPattern ( void )
public float getHighlightRegexSlop ( void )
public bool getHighlightRequireFieldMatch ( void )
public string getHighlightSimplePost ([ string $field_override ] )
public string getHighlightSimplePre ([ string $field_override ] )
public int getHighlightSnippets ([ string $field_override ] )
public bool getHighlightUsePhraseHighlighter ( void )
public bool getMlt ( void )
public bool getMltBoost ( void )
public int getMltCount ( void )
public array getMltFields ( void )
public int getMltMaxNumQueryTerms ( void )
public int getMltMaxNumTokens ( void )
public int getMltMaxWordLength ( void )
public int getMltMinDocFrequency ( void )
public int getMltMinTermFrequency ( void )
public int getMltMinWordLength ( void )
public array getMltQueryFields ( void )
public string getQuery ( void )
public int getRows ( void )
public array getSortFields ( void )
public int getStart ( void )
public bool getStats ( void )
public array getStatsFacets ( void )
public array getStatsFields ( void )
public bool getTerms ( void )
public string getTermsField ( void )
public bool getTermsIncludeLowerBound ( void )
public bool getTermsIncludeUpperBound ( void )
public int getTermsLimit ( void )
public string getTermsLowerBound ( void )
public int getTermsMaxCount ( void )
public int getTermsMinCount ( void )
public string getTermsPrefix ( void )
public bool getTermsReturnRaw ( void )
public int getTermsSort ( void )
public string getTermsUpperBound ( void )
public int getTimeAllowed ( void )
public SolrQuery removeExpandFilterQuery ( string $fq )
public SolrQuery removeExpandSortField ( string $field )
public SolrQuery removeFacetDateField ( string $field )
public SolrQuery removeFacetDateOther ( string $value [, string $field_override ] )
public SolrQuery removeFacetField ( string $field )
public SolrQuery removeFacetQuery ( string $value )
public SolrQuery removeField ( string $field )
public SolrQuery removeFilterQuery ( string $fq )
public SolrQuery removeHighlightField ( string $field )
public SolrQuery removeMltField ( string $field )
public SolrQuery removeMltQueryField ( string $queryField )
public SolrQuery removeSortField ( string $field )
public SolrQuery removeStatsFacet ( string $value )
public SolrQuery removeStatsField ( string $field )
public SolrQuery setEchoHandler ( bool $flag )
public SolrQuery setEchoParams ( string $type )
public SolrQuery setExpand ( bool $value )
public SolrQuery setExpandQuery ( string $q )
public SolrQuery setExpandRows ( integer $value )
public SolrQuery setExplainOther ( string $query )
public SolrQuery setFacet ( bool $flag )
public SolrQuery setFacetDateEnd ( string $value [, string $field_override ] )
public SolrQuery setFacetDateGap ( string $value [, string $field_override ] )
public SolrQuery setFacetDateHardEnd ( bool $value [, string $field_override ] )
public SolrQuery setFacetDateStart ( string $value [, string $field_override ] )
public SolrQuery setFacetEnumCacheMinDefaultFrequency ( int $frequency [, string $field_override ] )
public SolrQuery setFacetLimit ( int $limit [, string $field_override ] )
public SolrQuery setFacetMethod ( string $method [, string $field_override ] )
public SolrQuery setFacetMinCount ( int $mincount [, string $field_override ] )
public SolrQuery setFacetMissing ( bool $flag [, string $field_override ] )
public SolrQuery setFacetOffset ( int $offset [, string $field_override ] )
public SolrQuery setFacetPrefix ( string $prefix [, string $field_override ] )
public SolrQuery setFacetSort ( int $facetSort [, string $field_override ] )
public SolrQuery setGroup ( bool $value )
public SolrQuery setGroupCachePercent ( integer $percent )
public SolrQuery setGroupFacet ( bool $value )
public SolrQuery setGroupFormat ( string $value )
public SolrQuery setGroupLimit ( integer $value )
public SolrQuery setGroupMain ( string $value )
public SolrQuery setGroupNGroups ( bool $value )
public SolrQuery setGroupOffset ( integer $value )
public SolrQuery setGroupTruncate ( bool $value )
public SolrQuery setHighlight ( bool $flag )
public SolrQuery setHighlightAlternateField ( string $field [, string $field_override ] )
public SolrQuery setHighlightFormatter ( string $formatter [, string $field_override ] )
public SolrQuery setHighlightFragmenter ( string $fragmenter [, string $field_override ] )
public SolrQuery setHighlightFragsize ( int $size [, string $field_override ] )
public SolrQuery setHighlightHighlightMultiTerm ( bool $flag )
public SolrQuery setHighlightMaxAlternateFieldLength ( int $fieldLength [, string $field_override ] )
public SolrQuery setHighlightMaxAnalyzedChars ( int $value )
public SolrQuery setHighlightMergeContiguous ( bool $flag [, string $field_override ] )
public SolrQuery setHighlightRegexMaxAnalyzedChars ( int $maxAnalyzedChars )
public SolrQuery setHighlightRegexPattern ( string $value )
public SolrQuery setHighlightRegexSlop ( float $factor )
public SolrQuery setHighlightRequireFieldMatch ( bool $flag )
public SolrQuery setHighlightSimplePost ( string $simplePost [, string $field_override ] )
public SolrQuery setHighlightSimplePre ( string $simplePre [, string $field_override ] )
public SolrQuery setHighlightSnippets ( int $value [, string $field_override ] )
public SolrQuery setHighlightUsePhraseHighlighter ( bool $flag )
public SolrQuery setMlt ( bool $flag )
public SolrQuery setMltBoost ( bool $flag )
public SolrQuery setMltCount ( int $count )
public SolrQuery setMltMaxNumQueryTerms ( int $value )
public SolrQuery setMltMaxNumTokens ( int $value )
public SolrQuery setMltMaxWordLength ( int $maxWordLength )
public SolrQuery setMltMinDocFrequency ( int $minDocFrequency )
public SolrQuery setMltMinTermFrequency ( int $minTermFrequency )
public SolrQuery setMltMinWordLength ( int $minWordLength )
public SolrQuery setOmitHeader ( bool $flag )
public SolrQuery setQuery ( string $query )
public SolrQuery setRows ( int $rows )
public SolrQuery setShowDebugInfo ( bool $flag )
public SolrQuery setStart ( int $start )
public SolrQuery setStats ( bool $flag )
public SolrQuery setTerms ( bool $flag )
public SolrQuery setTermsField ( string $fieldname )
public SolrQuery setTermsIncludeLowerBound ( bool $flag )
public SolrQuery setTermsIncludeUpperBound ( bool $flag )
public SolrQuery setTermsLimit ( int $limit )
public SolrQuery setTermsLowerBound ( string $lowerBound )
public SolrQuery setTermsMaxCount ( int $frequency )
public SolrQuery setTermsMinCount ( int $frequency )
public SolrQuery setTermsPrefix ( string $prefix )
public SolrQuery setTermsReturnRaw ( bool $flag )
public SolrQuery setTermsSort ( int $sortType )
public SolrQuery setTermsUpperBound ( string $upperBound )
public SolrQuery setTimeAllowed ( int $timeAllowed )
/* Miras alınan yöntemler */
public SolrModifiableParams::__construct ( void )
public void SolrModifiableParams::__destruct ( void )
}

Öntanımlı Sabitler

SolrQuery::ORDER_ASC

Used to specify that the sorting should be in acending order

SolrQuery::ORDER_DESC

Used to specify that the sorting should be in descending order

SolrQuery::FACET_SORT_INDEX

Used to specify that the facet should sort by index

SolrQuery::FACET_SORT_COUNT

Used to specify that the facet should sort by count

SolrQuery::TERMS_SORT_INDEX

Used in the TermsComponent

SolrQuery::TERMS_SORT_COUNT

Used in the TermsComponent

İçindekiler

  • SolrQuery::addExpandFilterQuery — Overrides main filter query, determines which documents to include in the main group.
  • SolrQuery::addExpandSortField — Orders the documents within the expanded groups (expand.sort parameter).
  • SolrQuery::addFacetDateField — Maps to facet.date
  • SolrQuery::addFacetDateOther — Adds another facet.date.other parameter
  • SolrQuery::addFacetField — Adds another field to the facet
  • SolrQuery::addFacetQuery — Adds a facet query
  • SolrQuery::addField — Specifies which fields to return in the result
  • SolrQuery::addFilterQuery — Specifies a filter query
  • SolrQuery::addGroupField — Add a field to be used to group results.
  • SolrQuery::addGroupFunction — Allows grouping results based on the unique values of a function query (group.func parameter).
  • SolrQuery::addGroupQuery — Allows grouping of documents that match the given query.
  • SolrQuery::addGroupSortField — Add a group sort field (group.sort parameter).
  • SolrQuery::addHighlightField — Maps to hl.fl
  • SolrQuery::addMltField — Sets a field to use for similarity
  • SolrQuery::addMltQueryField — Maps to mlt.qf
  • SolrQuery::addSortField — Used to control how the results should be sorted
  • SolrQuery::addStatsFacet — Requests a return of sub results for values within the given facet
  • SolrQuery::addStatsField — Maps to stats.field parameter
  • SolrQuery::collapse — Collapses the result set to a single document per group
  • SolrQuery::__construct — Constructor
  • SolrQuery::__destruct — Destructor
  • SolrQuery::getExpand — Returns true if group expanding is enabled
  • SolrQuery::getExpandFilterQueries — Returns the expand filter queries
  • SolrQuery::getExpandQuery — Returns the expand query expand.q parameter
  • SolrQuery::getExpandRows — Returns The number of rows to display in each group (expand.rows)
  • SolrQuery::getExpandSortFields — Returns an array of fields
  • SolrQuery::getFacet — Returns the value of the facet parameter
  • SolrQuery::getFacetDateEnd — Returns the value for the facet.date.end parameter
  • SolrQuery::getFacetDateFields — Returns all the facet.date fields
  • SolrQuery::getFacetDateGap — Returns the value of the facet.date.gap parameter
  • SolrQuery::getFacetDateHardEnd — Returns the value of the facet.date.hardend parameter
  • SolrQuery::getFacetDateOther — Returns the value for the facet.date.other parameter
  • SolrQuery::getFacetDateStart — Returns the lower bound for the first date range for all date faceting on this field
  • SolrQuery::getFacetFields — Returns all the facet fields
  • SolrQuery::getFacetLimit — Returns the maximum number of constraint counts that should be returned for the facet fields
  • SolrQuery::getFacetMethod — Returns the value of the facet.method parameter
  • SolrQuery::getFacetMinCount — Returns the minimum counts for facet fields should be included in the response
  • SolrQuery::getFacetMissing — Returns the current state of the facet.missing parameter
  • SolrQuery::getFacetOffset — Returns an offset into the list of constraints to be used for pagination
  • SolrQuery::getFacetPrefix — Returns the facet prefix
  • SolrQuery::getFacetQueries — Returns all the facet queries
  • SolrQuery::getFacetSort — Returns the facet sort type
  • SolrQuery::getFields — Returns the list of fields that will be returned in the response
  • SolrQuery::getFilterQueries — Returns an array of filter queries
  • SolrQuery::getGroup — Returns true if grouping is enabled
  • SolrQuery::getGroupCachePercent — Returns group cache percent value
  • SolrQuery::getGroupFacet — Returns the group.facet parameter value
  • SolrQuery::getGroupFields — Returns group fields (group.field parameter values)
  • SolrQuery::getGroupFormat — Returns the group.format value
  • SolrQuery::getGroupFunctions — Returns group functions (group.func parameter values)
  • SolrQuery::getGroupLimit — Returns the group.limit value
  • SolrQuery::getGroupMain — Returns the group.main value
  • SolrQuery::getGroupNGroups — Returns the group.ngroups value
  • SolrQuery::getGroupOffset — Returns the group.offset value
  • SolrQuery::getGroupQueries — Returns all the group.query parameter values
  • SolrQuery::getGroupSortFields — Returns the group.sort value
  • SolrQuery::getGroupTruncate — Returns the group.truncate value
  • SolrQuery::getHighlight — Returns the state of the hl parameter
  • SolrQuery::getHighlightAlternateField — Returns the highlight field to use as backup or default
  • SolrQuery::getHighlightFields — Returns all the fields that Solr should generate highlighted snippets for
  • SolrQuery::getHighlightFormatter — Returns the formatter for the highlighted output
  • SolrQuery::getHighlightFragmenter — Returns the text snippet generator for highlighted text
  • SolrQuery::getHighlightFragsize — Returns the number of characters of fragments to consider for highlighting
  • SolrQuery::getHighlightHighlightMultiTerm — Returns whether or not to enable highlighting for range/wildcard/fuzzy/prefix queries
  • SolrQuery::getHighlightMaxAlternateFieldLength — Returns the maximum number of characters of the field to return
  • SolrQuery::getHighlightMaxAnalyzedChars — Returns the maximum number of characters into a document to look for suitable snippets
  • SolrQuery::getHighlightMergeContiguous — Returns whether or not the collapse contiguous fragments into a single fragment
  • SolrQuery::getHighlightRegexMaxAnalyzedChars — Returns the maximum number of characters from a field when using the regex fragmenter
  • SolrQuery::getHighlightRegexPattern — Returns the regular expression for fragmenting
  • SolrQuery::getHighlightRegexSlop — Returns the deviation factor from the ideal fragment size
  • SolrQuery::getHighlightRequireFieldMatch — Returns if a field will only be highlighted if the query matched in this particular field
  • SolrQuery::getHighlightSimplePost — Returns the text which appears after a highlighted term
  • SolrQuery::getHighlightSimplePre — Returns the text which appears before a highlighted term
  • SolrQuery::getHighlightSnippets — Returns the maximum number of highlighted snippets to generate per field
  • SolrQuery::getHighlightUsePhraseHighlighter — Returns the state of the hl.usePhraseHighlighter parameter
  • SolrQuery::getMlt — Returns whether or not MoreLikeThis results should be enabled
  • SolrQuery::getMltBoost — Returns whether or not the query will be boosted by the interesting term relevance
  • SolrQuery::getMltCount — Returns the number of similar documents to return for each result
  • SolrQuery::getMltFields — Returns all the fields to use for similarity
  • SolrQuery::getMltMaxNumQueryTerms — Returns the maximum number of query terms that will be included in any generated query
  • SolrQuery::getMltMaxNumTokens — Returns the maximum number of tokens to parse in each document field that is not stored with TermVector support
  • SolrQuery::getMltMaxWordLength — Returns the maximum word length above which words will be ignored
  • SolrQuery::getMltMinDocFrequency — Returns the treshold frequency at which words will be ignored which do not occur in at least this many docs
  • SolrQuery::getMltMinTermFrequency — Returns the frequency below which terms will be ignored in the source document
  • SolrQuery::getMltMinWordLength — Returns the minimum word length below which words will be ignored
  • SolrQuery::getMltQueryFields — Returns the query fields and their boosts
  • SolrQuery::getQuery — Returns the main query
  • SolrQuery::getRows — Returns the maximum number of documents
  • SolrQuery::getSortFields — Returns all the sort fields
  • SolrQuery::getStart — Returns the offset in the complete result set
  • SolrQuery::getStats — Returns whether or not stats is enabled
  • SolrQuery::getStatsFacets — Returns all the stats facets that were set
  • SolrQuery::getStatsFields — Returns all the statistics fields
  • SolrQuery::getTerms — Returns whether or not the TermsComponent is enabled
  • SolrQuery::getTermsField — Returns the field from which the terms are retrieved
  • SolrQuery::getTermsIncludeLowerBound — Returns whether or not to include the lower bound in the result set
  • SolrQuery::getTermsIncludeUpperBound — Returns whether or not to include the upper bound term in the result set
  • SolrQuery::getTermsLimit — Returns the maximum number of terms Solr should return
  • SolrQuery::getTermsLowerBound — Returns the term to start at
  • SolrQuery::getTermsMaxCount — Returns the maximum document frequency
  • SolrQuery::getTermsMinCount — Returns the minimum document frequency to return in order to be included
  • SolrQuery::getTermsPrefix — Returns the term prefix
  • SolrQuery::getTermsReturnRaw — Whether or not to return raw characters
  • SolrQuery::getTermsSort — Returns an integer indicating how terms are sorted
  • SolrQuery::getTermsUpperBound — Returns the term to stop at
  • SolrQuery::getTimeAllowed — Returns the time in milliseconds allowed for the query to finish
  • SolrQuery::removeExpandFilterQuery — Removes an expand filter query
  • SolrQuery::removeExpandSortField — Removes an expand sort field from the expand.sort parameter.
  • SolrQuery::removeFacetDateField — Removes one of the facet date fields
  • SolrQuery::removeFacetDateOther — Removes one of the facet.date.other parameters
  • SolrQuery::removeFacetField — Removes one of the facet.date parameters
  • SolrQuery::removeFacetQuery — Removes one of the facet.query parameters
  • SolrQuery::removeField — Removes a field from the list of fields
  • SolrQuery::removeFilterQuery — Removes a filter query
  • SolrQuery::removeHighlightField — Removes one of the fields used for highlighting
  • SolrQuery::removeMltField — Removes one of the moreLikeThis fields
  • SolrQuery::removeMltQueryField — Removes one of the moreLikeThis query fields
  • SolrQuery::removeSortField — Removes one of the sort fields
  • SolrQuery::removeStatsFacet — Removes one of the stats.facet parameters
  • SolrQuery::removeStatsField — Removes one of the stats.field parameters
  • SolrQuery::setEchoHandler — Toggles the echoHandler parameter
  • SolrQuery::setEchoParams — Determines what kind of parameters to include in the response
  • SolrQuery::setExpand — Enables/Disables the Expand Component
  • SolrQuery::setExpandQuery — Sets the expand.q parameter
  • SolrQuery::setExpandRows — Sets the number of rows to display in each group (expand.rows). Server Default 5
  • SolrQuery::setExplainOther — Sets the explainOther common query parameter
  • SolrQuery::setFacet — Maps to the facet parameter. Enables or disables facetting
  • SolrQuery::setFacetDateEnd — Maps to facet.date.end
  • SolrQuery::setFacetDateGap — Maps to facet.date.gap
  • SolrQuery::setFacetDateHardEnd — Maps to facet.date.hardend
  • SolrQuery::setFacetDateStart — Maps to facet.date.start
  • SolrQuery::setFacetEnumCacheMinDefaultFrequency — Sets the minimum document frequency used for determining term count
  • SolrQuery::setFacetLimit — Maps to facet.limit
  • SolrQuery::setFacetMethod — Specifies the type of algorithm to use when faceting a field
  • SolrQuery::setFacetMinCount — Maps to facet.mincount
  • SolrQuery::setFacetMissing — Maps to facet.missing
  • SolrQuery::setFacetOffset — Sets the offset into the list of constraints to allow for pagination
  • SolrQuery::setFacetPrefix — Specifies a string prefix with which to limits the terms on which to facet
  • SolrQuery::setFacetSort — Determines the ordering of the facet field constraints
  • SolrQuery::setGroup — Enable/Disable result grouping (group parameter)
  • SolrQuery::setGroupCachePercent — Enables caching for result grouping
  • SolrQuery::setGroupFacet — Sets group.facet parameter
  • SolrQuery::setGroupFormat — Sets the group format, result structure (group.format parameter).
  • SolrQuery::setGroupLimit — Specifies the number of results to return for each group. The server default value is 1.
  • SolrQuery::setGroupMain — If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple.
  • SolrQuery::setGroupNGroups — If true, Solr includes the number of groups that have matched the query in the results.
  • SolrQuery::setGroupOffset — Sets the group.offset parameter.
  • SolrQuery::setGroupTruncate — If true, facet counts are based on the most relevant document of each group matching the query.
  • SolrQuery::setHighlight — Enables or disables highlighting
  • SolrQuery::setHighlightAlternateField — Specifies the backup field to use
  • SolrQuery::setHighlightFormatter — Specify a formatter for the highlight output
  • SolrQuery::setHighlightFragmenter — Sets a text snippet generator for highlighted text
  • SolrQuery::setHighlightFragsize — The size of fragments to consider for highlighting
  • SolrQuery::setHighlightHighlightMultiTerm — Use SpanScorer to highlight phrase terms
  • SolrQuery::setHighlightMaxAlternateFieldLength — Sets the maximum number of characters of the field to return
  • SolrQuery::setHighlightMaxAnalyzedChars — Specifies the number of characters into a document to look for suitable snippets
  • SolrQuery::setHighlightMergeContiguous — Whether or not to collapse contiguous fragments into a single fragment
  • SolrQuery::setHighlightRegexMaxAnalyzedChars — Specify the maximum number of characters to analyze
  • SolrQuery::setHighlightRegexPattern — Specify the regular expression for fragmenting
  • SolrQuery::setHighlightRegexSlop — Sets the factor by which the regex fragmenter can stray from the ideal fragment size
  • SolrQuery::setHighlightRequireFieldMatch — Require field matching during highlighting
  • SolrQuery::setHighlightSimplePost — Sets the text which appears after a highlighted term
  • SolrQuery::setHighlightSimplePre — Sets the text which appears before a highlighted term
  • SolrQuery::setHighlightSnippets — Sets the maximum number of highlighted snippets to generate per field
  • SolrQuery::setHighlightUsePhraseHighlighter — Whether to highlight phrase terms only when they appear within the query phrase
  • SolrQuery::setMlt — Enables or disables moreLikeThis
  • SolrQuery::setMltBoost — Set if the query will be boosted by the interesting term relevance
  • SolrQuery::setMltCount — Set the number of similar documents to return for each result
  • SolrQuery::setMltMaxNumQueryTerms — Sets the maximum number of query terms included
  • SolrQuery::setMltMaxNumTokens — Specifies the maximum number of tokens to parse
  • SolrQuery::setMltMaxWordLength — Sets the maximum word length
  • SolrQuery::setMltMinDocFrequency — Sets the mltMinDoc frequency
  • SolrQuery::setMltMinTermFrequency — Sets the frequency below which terms will be ignored in the source docs
  • SolrQuery::setMltMinWordLength — Sets the minimum word length
  • SolrQuery::setOmitHeader — Exclude the header from the returned results
  • SolrQuery::setQuery — Sets the search query
  • SolrQuery::setRows — Specifies the maximum number of rows to return in the result
  • SolrQuery::setShowDebugInfo — Flag to show debug information
  • SolrQuery::setStart — Specifies the number of rows to skip
  • SolrQuery::setStats — Enables or disables the Stats component
  • SolrQuery::setTerms — Enables or disables the TermsComponent
  • SolrQuery::setTermsField — Sets the name of the field to get the Terms from
  • SolrQuery::setTermsIncludeLowerBound — Include the lower bound term in the result set
  • SolrQuery::setTermsIncludeUpperBound — Include the upper bound term in the result set
  • SolrQuery::setTermsLimit — Sets the maximum number of terms to return
  • SolrQuery::setTermsLowerBound — Specifies the Term to start from
  • SolrQuery::setTermsMaxCount — Sets the maximum document frequency
  • SolrQuery::setTermsMinCount — Sets the minimum document frequency
  • SolrQuery::setTermsPrefix — Restrict matches to terms that start with the prefix
  • SolrQuery::setTermsReturnRaw — Return the raw characters of the indexed term
  • SolrQuery::setTermsSort — Specifies how to sort the returned terms
  • SolrQuery::setTermsUpperBound — Sets the term to stop at
  • SolrQuery::setTimeAllowed — The time allowed for search to finish
SolrModifiableParams::__destruct
SolrQuery::addExpandFilterQuery
Solr


Overrides main filter query, determines which documents to include in the main group.

SolrQuery
SolrQuery::addExpandSortField
SolrQuery
PHP Manual

SolrQuery::addExpandFilterQuery

(PECL solr >= 2.2.0)

SolrQuery::addExpandFilterQuery — Overrides main filter query, determines which documents to include in the main group.

Açıklama

public SolrQuery SolrQuery::addExpandFilterQuery ( string $fq )

Overrides main filter query, determines which documents to include in the main group.

Değiştirgeler

fq

Dönen Değerler

SolrQuery

Ayrıca Bakınız

  • SolrQuery::setExpand() - Enables/Disables the Expand Component
  • SolrQuery::addExpandSortField() - Orders the documents within the expanded groups (expand.sort parameter).
  • SolrQuery::removeExpandSortField() - Removes an expand sort field from the expand.sort parameter.
  • SolrQuery::setExpandRows() - Sets the number of rows to display in each group (expand.rows). Server Default 5
  • SolrQuery::setExpandQuery() - Sets the expand.q parameter
  • SolrQuery::removeExpandFilterQuery() - Removes an expand filter query
SolrQuery
SolrQuery::addExpandSortField
SolrQuery


Orders the documents within the expanded groups (expand.sort parameter).

SolrQuery::addExpandFilterQuery
SolrQuery::addFacetDateField
SolrQuery
PHP Manual

SolrQuery::addExpandSortField

(PECL solr >= 2.2.0)

SolrQuery::addExpandSortField — Orders the documents within the expanded groups (expand.sort parameter).

Açıklama

public SolrQuery SolrQuery::addExpandSortField ( string $field [, string $order ] )

Orders the documents within the expanded groups (expand.sort parameter).

Değiştirgeler

field

field name

order

Order ASC/DESC, utilizes SolrQuery::ORDER_* constants.

Default: SolrQuery::ORDER_DESC

Dönen Değerler

SolrQuery

Ayrıca Bakınız

  • SolrQuery::setExpand() - Enables/Disables the Expand Component
  • SolrQuery::removeExpandSortField() - Removes an expand sort field from the expand.sort parameter.
  • SolrQuery::setExpandRows() - Sets the number of rows to display in each group (expand.rows). Server Default 5
  • SolrQuery::setExpandQuery() - Sets the expand.q parameter
  • SolrQuery::addExpandFilterQuery() - Overrides main filter query, determines which documents to include in the main group.
  • SolrQuery::removeExpandFilterQuery() - Removes an expand filter query
SolrQuery::addExpandFilterQuery
SolrQuery::addFacetDateField
SolrQuery


Maps to facet.date

SolrQuery::addExpandSortField
SolrQuery::addFacetDateOther
SolrQuery
PHP Manual

SolrQuery::addFacetDateField

(PECL solr >= 0.9.2)

SolrQuery::addFacetDateField — Maps to facet.date

Açıklama

public SolrQuery SolrQuery::addFacetDateField ( string $dateField )

This method allows you to specify a field which should be treated as a facet.

It can be used multiple times with different field names to indicate multiple facet fields

Değiştirgeler

dateField

The name of the date field.

Dönen Değerler

Returns a SolrQuery object.

SolrQuery::addExpandSortField
SolrQuery::addFacetDateOther
SolrQuery


Adds another facet.date.other parameter

SolrQuery::addFacetDateField
SolrQuery::addFacetField
SolrQuery
PHP Manual

SolrQuery::addFacetDateOther

(PECL solr >= 0.9.2)

SolrQuery::addFacetDateOther — Adds another facet.date.other parameter

Açıklama

public SolrQuery SolrQuery::addFacetDateOther ( string $value [, string $field_override ] )

Sets the facet.date.other parameter. Accepts an optional field override

Değiştirgeler

value

The value to use.

field_override

The field name for the override.

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::addFacetDateField
SolrQuery::addFacetField
SolrQuery


Adds another field to the facet

SolrQuery::addFacetDateOther
SolrQuery::addFacetQuery
SolrQuery
PHP Manual

SolrQuery::addFacetField

(PECL solr >= 0.9.2)

SolrQuery::addFacetField — Adds another field to the facet

Açıklama

public SolrQuery SolrQuery::addFacetField ( string $field )

Adds another field to the facet

Değiştirgeler

field

The name of the field

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

Örnekler

Örnek 1 SolrQuery::addFacetField() example

<?php

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$client = new SolrClient($options);

$query = new SolrQuery();

$query->setQuery($query);

$query->addField('price')->addField('color');

$query->setFacet(true);

$query->addFacetField('price')->addFacetField('color');

$query_response = $client->query($query);

$response = $query_response->getResponse();

print_r($response['facet_counts']['facet_fields']);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

SolrObject Object
(
    [color] => SolrObject Object
        (
            [blue] => 20
            [green] => 100
        )

)

SolrQuery::addFacetDateOther
SolrQuery::addFacetQuery
SolrQuery


Adds a facet query

SolrQuery::addFacetField
SolrQuery::addField
SolrQuery
PHP Manual

SolrQuery::addFacetQuery

(PECL solr >= 0.9.2)

SolrQuery::addFacetQuery — Adds a facet query

Açıklama

public SolrQuery SolrQuery::addFacetQuery ( string $facetQuery )

Adds a facet query

Değiştirgeler

facetQuery

The facet query

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

Örnekler

Örnek 1 SolrQuery::addFacetField() example

<?php

$options = array
(
        'hostname' => SOLR_SERVER_HOSTNAME,
        'login'    => SOLR_SERVER_USERNAME,
        'password' => SOLR_SERVER_PASSWORD,
        'port'     => SOLR_SERVER_PORT,
);

$client = new SolrClient($options);

$query = new SolrQuery('*:*');

$query->setFacet(true);

$query->addFacetQuery('price:[* TO 500]')->addFacetQuery('price:[500 TO *]');

$query_response = $client->query($query);

$response = $query_response->getResponse();

print_r($response->facet_counts->facet_queries);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

SolrObject Object
(
    [price:[* TO 500]] => 14
    [price:[500 TO *]] => 2
)

SolrQuery::addFacetField
SolrQuery::addField
SolrQuery


Specifies which fields to return in the result

SolrQuery::addFacetQuery
SolrQuery::addFilterQuery
SolrQuery
PHP Manual

SolrQuery::addField

(PECL solr >= 0.9.2)

SolrQuery::addField — Specifies which fields to return in the result

Açıklama

public SolrQuery SolrQuery::addField ( string $field )

This method is used to used to specify a set of fields to return, thereby restricting the amount of data returned in the response.

It should be called multiple time, once for each field name.

Değiştirgeler

field

The name of the field

Dönen Değerler

Returns the current SolrQuery object

SolrQuery::addFacetQuery
SolrQuery::addFilterQuery
SolrQuery


Specifies a filter query

SolrQuery::addField
SolrQuery::addGroupField
SolrQuery
PHP Manual

SolrQuery::addFilterQuery

(PECL solr >= 0.9.2)

SolrQuery::addFilterQuery — Specifies a filter query

Açıklama

public SolrQuery SolrQuery::addFilterQuery ( string $fq )

Specifies a filter query

Değiştirgeler

fq

The filter query

Dönen Değerler

Returns the current SolrQuery object.

Örnekler

Örnek 1 SolrQuery::addFilterQuery() example

<?php

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
);

$client = new SolrClient($options);

$query = new SolrQuery();

$query->setQuery('*:*');

$query->addFilterQuery('color:blue,green');

$query_response = $client->query($query);

$response = $query_response->getResponse();

print_r($response['facet_counts']['facet_fields']);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

 &fq=color:blue,green

SolrQuery::addField
SolrQuery::addGroupField
SolrQuery


Add a field to be used to group results.

SolrQuery::addFilterQuery
SolrQuery::addGroupFunction
SolrQuery
PHP Manual

SolrQuery::addGroupField

(PECL solr >= 2.2.0)

SolrQuery::addGroupField — Add a field to be used to group results.

Açıklama

public SolrQuery SolrQuery::addGroupField ( string $value )

The name of the field by which to group results. The field must be single-valued, and either be indexed or a field type that has a value source and works in a function query, such as ExternalFileField. It must also be a string-based field, such as StrField or TextField Uses group.field parameter

Değiştirgeler

value

Ayrıca Bakınız

  • SolrQuery::setGroup() - Enable/Disable result grouping (group parameter)
  • SolrQuery::addGroupFunction() - Allows grouping results based on the unique values of a function query (group.func parameter).
  • SolrQuery::addGroupQuery() - Allows grouping of documents that match the given query.
  • SolrQuery::addGroupSortField() - Add a group sort field (group.sort parameter).
  • SolrQuery::setGroupFacet() - Sets group.facet parameter
  • SolrQuery::setGroupOffset() - Sets the group.offset parameter.
  • SolrQuery::setGroupLimit() - Specifies the number of results to return for each group. The server default value is 1.
  • SolrQuery::setGroupMain() - If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple.
  • SolrQuery::setGroupNGroups() - If true, Solr includes the number of groups that have matched the query in the results.
  • SolrQuery::setGroupTruncate() - If true, facet counts are based on the most relevant document of each group matching the query.
  • SolrQuery::setGroupFormat() - Sets the group format, result structure (group.format parameter).
  • SolrQuery::setGroupCachePercent() - Enables caching for result grouping
SolrQuery::addFilterQuery
SolrQuery::addGroupFunction
SolrQuery


Allows grouping results based on the unique values of a function query (group.func parameter).

SolrQuery::addGroupField
SolrQuery::addGroupQuery
SolrQuery
PHP Manual

SolrQuery::addGroupFunction

(PECL solr >= 2.2.0)

SolrQuery::addGroupFunction — Allows grouping results based on the unique values of a function query (group.func parameter).

Açıklama

public SolrQuery SolrQuery::addGroupFunction ( string $value )

Adds a group function (group.func parameter) Allows grouping results based on the unique values of a function query.

Değiştirgeler

value

Dönen Değerler

SolrQuery

Ayrıca Bakınız

  • SolrQuery::setGroup() - Enable/Disable result grouping (group parameter)
  • SolrQuery::addGroupField() - Add a field to be used to group results.
  • SolrQuery::addGroupQuery() - Allows grouping of documents that match the given query.
  • SolrQuery::addGroupSortField() - Add a group sort field (group.sort parameter).
  • SolrQuery::setGroupFacet() - Sets group.facet parameter
  • SolrQuery::setGroupOffset() - Sets the group.offset parameter.
  • SolrQuery::setGroupLimit() - Specifies the number of results to return for each group. The server default value is 1.
  • SolrQuery::setGroupMain() - If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple.
  • SolrQuery::setGroupNGroups() - If true, Solr includes the number of groups that have matched the query in the results.
  • SolrQuery::setGroupTruncate() - If true, facet counts are based on the most relevant document of each group matching the query.
  • SolrQuery::setGroupFormat() - Sets the group format, result structure (group.format parameter).
  • SolrQuery::setGroupCachePercent() - Enables caching for result grouping
SolrQuery::addGroupField
SolrQuery::addGroupQuery
SolrQuery


Allows grouping of documents that match the given query.

SolrQuery::addGroupFunction
SolrQuery::addGroupSortField
SolrQuery
PHP Manual

SolrQuery::addGroupQuery

(PECL solr >= 2.2.0)

SolrQuery::addGroupQuery — Allows grouping of documents that match the given query.

Açıklama

public SolrQuery SolrQuery::addGroupQuery ( string $value )

Allows grouping of documents that match the given query. Adds query to the group.query parameter

Değiştirgeler

value

Dönen Değerler

SolrQuery

Ayrıca Bakınız

  • SolrQuery::setGroup() - Enable/Disable result grouping (group parameter)
  • SolrQuery::addGroupField() - Add a field to be used to group results.
  • SolrQuery::addGroupFunction() - Allows grouping results based on the unique values of a function query (group.func parameter).
  • SolrQuery::addGroupSortField() - Add a group sort field (group.sort parameter).
  • SolrQuery::setGroupFacet() - Sets group.facet parameter
  • SolrQuery::setGroupOffset() - Sets the group.offset parameter.
  • SolrQuery::setGroupLimit() - Specifies the number of results to return for each group. The server default value is 1.
  • SolrQuery::setGroupMain() - If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple.
  • SolrQuery::setGroupNGroups() - If true, Solr includes the number of groups that have matched the query in the results.
  • SolrQuery::setGroupTruncate() - If true, facet counts are based on the most relevant document of each group matching the query.
  • SolrQuery::setGroupFormat() - Sets the group format, result structure (group.format parameter).
  • SolrQuery::setGroupCachePercent() - Enables caching for result grouping
SolrQuery::addGroupFunction
SolrQuery::addGroupSortField
SolrQuery


Add a group sort field (group.sort parameter).

SolrQuery::addGroupQuery
SolrQuery::addHighlightField
SolrQuery
PHP Manual

SolrQuery::addGroupSortField

(PECL solr >= 2.2.0)

SolrQuery::addGroupSortField — Add a group sort field (group.sort parameter).

Açıklama

public SolrQuery SolrQuery::addGroupSortField ( string $field [, integer $order ] )

Allow sorting group documents, using group sort field (group.sort parameter).

Değiştirgeler

field

Field name

order

Order ASC/DESC, utilizes SolrQuery::ORDER_* constants

Dönen Değerler

Örnekler

Örnek 1 SolrQuery::addGroupSortField() example

<?php

$solrQuery = new SolrQuery('*:*');
$solrQuery
    ->setGroup(true)
    ->addGroupSortField('price', SolrQuery::ORDER_ASC);

echo $solrQuery;
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

q=*:*&group=true&group.sort=price asc

Ayrıca Bakınız

  • SolrQuery::setGroup() - Enable/Disable result grouping (group parameter)
  • SolrQuery::addGroupField() - Add a field to be used to group results.
  • SolrQuery::addGroupFunction() - Allows grouping results based on the unique values of a function query (group.func parameter).
  • SolrQuery::addGroupQuery() - Allows grouping of documents that match the given query.
  • SolrQuery::setGroupFacet() - Sets group.facet parameter
  • SolrQuery::setGroupOffset() - Sets the group.offset parameter.
  • SolrQuery::setGroupLimit() - Specifies the number of results to return for each group. The server default value is 1.
  • SolrQuery::setGroupMain() - If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple.
  • SolrQuery::setGroupNGroups() - If true, Solr includes the number of groups that have matched the query in the results.
  • SolrQuery::setGroupTruncate() - If true, facet counts are based on the most relevant document of each group matching the query.
  • SolrQuery::setGroupFormat() - Sets the group format, result structure (group.format parameter).
  • SolrQuery::setGroupCachePercent() - Enables caching for result grouping
SolrQuery::addGroupQuery
SolrQuery::addHighlightField
SolrQuery


Maps to hl.fl

SolrQuery::addGroupSortField
SolrQuery::addMltField
SolrQuery
PHP Manual

SolrQuery::addHighlightField

(PECL solr >= 0.9.2)

SolrQuery::addHighlightField — Maps to hl.fl

Açıklama

public SolrQuery SolrQuery::addHighlightField ( string $field )

Maps to hl.fl. This is used to specify that highlighted snippets should be generated for a particular field

Değiştirgeler

field

Name of the field

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::addGroupSortField
SolrQuery::addMltField
SolrQuery


Sets a field to use for similarity

SolrQuery::addHighlightField
SolrQuery::addMltQueryField
SolrQuery
PHP Manual

SolrQuery::addMltField

(PECL solr >= 0.9.2)

SolrQuery::addMltField — Sets a field to use for similarity

Açıklama

public SolrQuery SolrQuery::addMltField ( string $field )

Maps to mlt.fl. It specifies that a field should be used for similarity.

Değiştirgeler

field

The name of the field

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::addHighlightField
SolrQuery::addMltQueryField
SolrQuery


Maps to mlt.qf

SolrQuery::addMltField
SolrQuery::addSortField
SolrQuery
PHP Manual

SolrQuery::addMltQueryField

(PECL solr >= 0.9.2)

SolrQuery::addMltQueryField — Maps to mlt.qf

Açıklama

public SolrQuery SolrQuery::addMltQueryField ( string $field , float $boost )

Maps to mlt.qf. It is used to specify query fields and their boosts

Değiştirgeler

field

The name of the field

boost

Its boost value

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::addMltField
SolrQuery::addSortField
SolrQuery


Used to control how the results should be sorted

SolrQuery::addMltQueryField
SolrQuery::addStatsFacet
SolrQuery
PHP Manual

SolrQuery::addSortField

(PECL solr >= 0.9.2)

SolrQuery::addSortField — Used to control how the results should be sorted

Açıklama

public SolrQuery SolrQuery::addSortField ( string $field [, int $order = SolrQuery::ORDER_DESC ] )

Used to control how the results should be sorted.

Değiştirgeler

field

The name of the field

order

The sort direction. This should be either SolrQuery::ORDER_ASC or SolrQuery::ORDER_DESC.

Dönen Değerler

Returns the current SolrQuery object.

SolrQuery::addMltQueryField
SolrQuery::addStatsFacet
SolrQuery


Requests a return of sub results for values within the given facet

SolrQuery::addSortField
SolrQuery::addStatsField
SolrQuery
PHP Manual

SolrQuery::addStatsFacet

(PECL solr >= 0.9.2)

SolrQuery::addStatsFacet — Requests a return of sub results for values within the given facet

Açıklama

public SolrQuery SolrQuery::addStatsFacet ( string $field )

Requests a return of sub results for values within the given facet. Maps to the stats.facet field

Değiştirgeler

field

The name of the field

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::addSortField
SolrQuery::addStatsField
SolrQuery


Maps to stats.field parameter

SolrQuery::addStatsFacet
SolrQuery::collapse
SolrQuery
PHP Manual

SolrQuery::addStatsField

(PECL solr >= 0.9.2)

SolrQuery::addStatsField — Maps to stats.field parameter

Açıklama

public SolrQuery SolrQuery::addStatsField ( string $field )

Maps to stats.field parameter This methods adds another stats.field parameter.

Değiştirgeler

field

The name of the field

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::addStatsFacet
SolrQuery::collapse
SolrQuery


Collapses the result set to a single document per group

SolrQuery::addStatsField
SolrQuery::__construct
SolrQuery
PHP Manual

SolrQuery::collapse

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

SolrQuery::collapse — Collapses the result set to a single document per group

Açıklama

public SolrQuery SolrQuery::collapse ( SolrCollapseFunction $collapseFunction )

Collapses the result set to a single document per group before it forwards the result set to the rest of the search components.

So all downstream components (faceting, highlighting, etc...) will work with the collapsed result set.

Değiştirgeler

collapseFunction

Dönen Değerler

Returns the current SolrQuery object

Örnekler

Örnek 1 SolrQuery::collapse() example

<?php

include "bootstrap.php";

$options = array
(
        'hostname' => SOLR_SERVER_HOSTNAME,
        'login'    => SOLR_SERVER_USERNAME,
        'password' => SOLR_SERVER_PASSWORD,
        'port'     => SOLR_SERVER_PORT,
        'path'     => SOLR_SERVER_PATH
);

$client = new SolrClient($options);

$query = new SolrQuery('*:*');

$collapseFunction = new SolrCollapseFunction('manu_id_s');

$collapseFunction
->setSize(2)
->setNullPolicy(SolrCollapseFunction::NULLPOLICY_IGNORE);

$query
->collapse($collapseFunction)
->setRows(4);

$queryResponse = $client->query($query);

$response = $queryResponse->getResponse();

print_r($response);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

SolrObject Object
(
    [responseHeader] => SolrObject Object
        (
            [status] => 0
            [QTime] => 1
            [params] => SolrObject Object
                (
                    [q] => *:*
                    [indent] => on
                    [fq] => {!collapse field=manu_id_s size=2 nullPolicy=ignore}
                    [rows] => 4
                    [version] => 2.2
                    [wt] => xml
                )

        )

    [response] => SolrObject Object
        (
            [numFound] => 14
            [start] => 0
            [docs] => Array
                (
                    [0] => SolrObject Object
                        (
                            [id] => SP2514N
                            [name] => Array
                                (
                                    [0] => Samsung SpinPoint P120 SP2514N - hard drive - 250 GB - ATA-133
                                )

                            [manu] => Array
                                (
                                    [0] => Samsung Electronics Co. Ltd.
                                )

                            [manu_id_s] => samsung
                            [cat] => Array
                                (
                                    [0] => electronics
                                    [1] => hard drive
                                )

                            [features] => Array
                                (
                                    [0] => 7200RPM, 8MB cache, IDE Ultra ATA-133
                                    [1] => NoiseGuard, SilentSeek technology, Fluid Dynamic Bearing (FDB) motor
                                )

                            [price] => Array
                                (
                                    [0] => 92
                                )

                            [popularity] => Array
                                (
                                    [0] => 6
                                )

                            [inStock] => Array
                                (
                                    [0] => 1
                                )

                            [manufacturedate_dt] => 2006-02-13T15:26:37Z
                            [store] => Array
                                (
                                    [0] => 35.0752,-97.032
                                )

                            [_version_] => 1510294336412057600
                        )

                    [1] => SolrObject Object
                        (
                            [id] => 6H500F0
                            [name] => Array
                                (
                                    [0] => Maxtor DiamondMax 11 - hard drive - 500 GB - SATA-300
                                )

                            [manu] => Array
                                (
                                    [0] => Maxtor Corp.
                                )

                            [manu_id_s] => maxtor
                            [cat] => Array
                                (
                                    [0] => electronics
                                    [1] => hard drive
                                )

                            [features] => Array
                                (
                                    [0] => SATA 3.0Gb/s, NCQ
                                    [1] => 8.5ms seek
                                    [2] => 16MB cache
                                )

                            [price] => Array
                                (
                                    [0] => 350
                                )

                            [popularity] => Array
                                (
                                    [0] => 6
                                )

                            [inStock] => Array
                                (
                                    [0] => 1
                                )

                            [store] => Array
                                (
                                    [0] => 45.17614,-93.87341
                                )

                            [manufacturedate_dt] => 2006-02-13T15:26:37Z
                            [_version_] => 1510294336449806336
                        )

                    [2] => SolrObject Object
                        (
                            [id] => F8V7067-APL-KIT
                            [name] => Array
                                (
                                    [0] => Belkin Mobile Power Cord for iPod w/ Dock
                                )

                            [manu] => Array
                                (
                                    [0] => Belkin
                                )

                            [manu_id_s] => belkin
                            [cat] => Array
                                (
                                    [0] => electronics
                                    [1] => connector
                                )

                            [features] => Array
                                (
                                    [0] => car power adapter, white
                                )

                            [weight] => Array
                                (
                                    [0] => 4
                                )

                            [price] => Array
                                (
                                    [0] => 19.95
                                )

                            [popularity] => Array
                                (
                                    [0] => 1
                                )

                            [inStock] => Array
                                (
                                    [0] =>
                                )

                            [store] => Array
                                (
                                    [0] => 45.18014,-93.87741
                                )

                            [manufacturedate_dt] => 2005-08-01T16:30:25Z
                            [_version_] => 1510294336458194944
                        )

                    [3] => SolrObject Object
                        (
                            [id] => MA147LL/A
                            [name] => Array
                                (
                                    [0] => Apple 60 GB iPod with Video Playback Black
                                )

                            [manu] => Array
                                (
                                    [0] => Apple Computer Inc.
                                )

                            [manu_id_s] => apple
                            [cat] => Array
                                (
                                    [0] => electronics
                                    [1] => music
                                )

                            [features] => Array
                                (
                                    [0] => iTunes, Podcasts, Audiobooks
                                    [1] => Stores up to 15,000 songs, 25,000 photos, or 150 hours of video
                                    [2] => 2.5-inch, 320x240 color TFT LCD display with LED backlight
                                    [3] => Up to 20 hours of battery life
                                    [4] => Plays AAC, MP3, WAV, AIFF, Audible, Apple Lossless, H.264 video
                                    [5] => Notes, Calendar, Phone book, Hold button, Date display, Photo wallet, Built-in games, JPEG photo playback, Upgradeable firmware, USB 2.0 compatibility, Playback speed control, Rechargeable capability, Battery level indication
                                )

                            [includes] => Array
                                (
                                    [0] => earbud headphones, USB cable
                                )

                            [weight] => Array
                                (
                                    [0] => 5.5
                                )

                            [price] => Array
                                (
                                    [0] => 399
                                )

                            [popularity] => Array
                                (
                                    [0] => 10
                                )

                            [inStock] => Array
                                (
                                    [0] => 1
                                )

                            [store] => Array
                                (
                                    [0] => 37.7752,-100.0232
                                )

                            [manufacturedate_dt] => 2005-10-12T08:00:00Z
                            [_version_] => 1510294336562003968
                        )

                )

        )

)
SolrQuery::addStatsField
SolrQuery::__construct
SolrQuery


Constructor

SolrQuery::collapse
SolrQuery::__destruct
SolrQuery
PHP Manual

SolrQuery::__construct

(PECL solr >= 0.9.2)

SolrQuery::__construct — Constructor

Açıklama

public SolrQuery::__construct ([ string $q ] )

Constructor.

Değiştirgeler

q

Optional search query

Dönen Değerler

None

Hatalar/İstisnalar

Emits SolrIllegalArgumentException in case of an invalid parameter was passed.

Sürüm Bilgisi

Sürüm: | Açıklama
2.0.0 | If q was invalid, then a SolrIllegalArgumentException is now thrown. Previously an error was emitted.

SolrQuery::collapse
SolrQuery::__destruct
SolrQuery


Destructor

SolrQuery::__construct
SolrQuery::getExpand
SolrQuery
PHP Manual

SolrQuery::__destruct

(PECL solr >= 0.9.2)

SolrQuery::__destruct — Destructor

Açıklama

public void SolrQuery::__destruct ( void )

Destructor

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

None.

SolrQuery::__construct
SolrQuery::getExpand
SolrQuery


Returns true if group expanding is enabled

SolrQuery::__destruct
SolrQuery::getExpandFilterQueries
SolrQuery
PHP Manual

SolrQuery::getExpand

(PECL solr >= 2.2.0)

SolrQuery::getExpand — Returns true if group expanding is enabled

Açıklama

public bool SolrQuery::getExpand ( void )

Returns TRUE if group expanding is enabled

SolrQuery::__destruct
SolrQuery::getExpandFilterQueries
SolrQuery


Returns the expand filter queries

SolrQuery::getExpand
SolrQuery::getExpandQuery
SolrQuery
PHP Manual

SolrQuery::getExpandFilterQueries

(PECL solr >= 2.2.0)

SolrQuery::getExpandFilterQueries — Returns the expand filter queries

Açıklama

public array SolrQuery::getExpandFilterQueries ( void )

Returns the expand filter queries

SolrQuery::getExpand
SolrQuery::getExpandQuery
SolrQuery


Returns the expand query expand.q parameter

SolrQuery::getExpandFilterQueries
SolrQuery::getExpandRows
SolrQuery
PHP Manual

SolrQuery::getExpandQuery

(PECL solr >= 2.2.0)

SolrQuery::getExpandQuery — Returns the expand query expand.q parameter

Açıklama

public array SolrQuery::getExpandQuery ( void )

Returns the expand query expand.q parameter

SolrQuery::getExpandFilterQueries
SolrQuery::getExpandRows
SolrQuery


Returns The number of rows to display in each group (expand.rows)

SolrQuery::getExpandQuery
SolrQuery::getExpandSortFields
SolrQuery
PHP Manual

SolrQuery::getExpandRows

(PECL solr >= 2.2.0)

SolrQuery::getExpandRows — Returns The number of rows to display in each group (expand.rows)

Açıklama

public integer SolrQuery::getExpandRows ( void )

Returns The number of rows to display in each group (expand.rows)

SolrQuery::getExpandQuery
SolrQuery::getExpandSortFields
SolrQuery


Returns an array of fields

SolrQuery::getExpandRows
SolrQuery::getFacet
SolrQuery
PHP Manual

SolrQuery::getExpandSortFields

(PECL solr >= 2.2.0)

SolrQuery::getExpandSortFields — Returns an array of fields

Açıklama

public array SolrQuery::getExpandSortFields ( void )

Returns an array of fields

SolrQuery::getExpandRows
SolrQuery::getFacet
SolrQuery


Returns the value of the facet parameter

SolrQuery::getExpandSortFields
SolrQuery::getFacetDateEnd
SolrQuery
PHP Manual

SolrQuery::getFacet

(PECL solr >= 0.9.2)

SolrQuery::getFacet — Returns the value of the facet parameter

Açıklama

public bool SolrQuery::getFacet ( void )

Returns the value of the facet parameter.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a boolean on success and NULL if not set

SolrQuery::getExpandSortFields
SolrQuery::getFacetDateEnd
SolrQuery


Returns the value for the facet.date.end parameter

SolrQuery::getFacet
SolrQuery::getFacetDateFields
SolrQuery
PHP Manual

SolrQuery::getFacetDateEnd

(PECL solr >= 0.9.2)

SolrQuery::getFacetDateEnd — Returns the value for the facet.date.end parameter

Açıklama

public string SolrQuery::getFacetDateEnd ([ string $field_override ] )

Returns the value for the facet.date.end parameter. This method accepts an optional field override

Değiştirgeler

field_override

The name of the field

Dönen Değerler

Returns a string on success and NULL if not set

SolrQuery::getFacet
SolrQuery::getFacetDateFields
SolrQuery


Returns all the facet.date fields

SolrQuery::getFacetDateEnd
SolrQuery::getFacetDateGap
SolrQuery
PHP Manual

SolrQuery::getFacetDateFields

(PECL solr >= 0.9.2)

SolrQuery::getFacetDateFields — Returns all the facet.date fields

Açıklama

public array SolrQuery::getFacetDateFields ( void )

Returns all the facet.date fields

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns all the facet.date fields as an array or NULL if none was set

SolrQuery::getFacetDateEnd
SolrQuery::getFacetDateGap
SolrQuery


Returns the value of the facet.date.gap parameter

SolrQuery::getFacetDateFields
SolrQuery::getFacetDateHardEnd
SolrQuery
PHP Manual

SolrQuery::getFacetDateGap

(PECL solr >= 0.9.2)

SolrQuery::getFacetDateGap — Returns the value of the facet.date.gap parameter

Açıklama

public string SolrQuery::getFacetDateGap ([ string $field_override ] )

Returns the value of the facet.date.gap parameter. It accepts an optional field override

Değiştirgeler

field_override

The name of the field

Dönen Değerler

Returns a string on success and NULL if not set

SolrQuery::getFacetDateFields
SolrQuery::getFacetDateHardEnd
SolrQuery


Returns the value of the facet.date.hardend parameter

SolrQuery::getFacetDateGap
SolrQuery::getFacetDateOther
SolrQuery
PHP Manual

SolrQuery::getFacetDateHardEnd

(PECL solr >= 0.9.2)

SolrQuery::getFacetDateHardEnd — Returns the value of the facet.date.hardend parameter

Açıklama

public string SolrQuery::getFacetDateHardEnd ([ string $field_override ] )

Returns the value of the facet.date.hardend parameter. Accepts an optional field override

Değiştirgeler

field_override

The name of the field

Dönen Değerler

Returns a string on success and NULL if not set

SolrQuery::getFacetDateGap
SolrQuery::getFacetDateOther
SolrQuery


Returns the value for the facet.date.other parameter

SolrQuery::getFacetDateHardEnd
SolrQuery::getFacetDateStart
SolrQuery
PHP Manual

SolrQuery::getFacetDateOther

(PECL solr >= 0.9.2)

SolrQuery::getFacetDateOther — Returns the value for the facet.date.other parameter

Açıklama

public array SolrQuery::getFacetDateOther ([ string $field_override ] )

Returns the value for the facet.date.other parameter. This method accepts an optional field override.

Değiştirgeler

field_override

The name of the field

Dönen Değerler

Returns a string on success and NULL if not set.

SolrQuery::getFacetDateHardEnd
SolrQuery::getFacetDateStart
SolrQuery


Returns the lower bound for the first date range for all date faceting on this field

SolrQuery::getFacetDateOther
SolrQuery::getFacetFields
SolrQuery
PHP Manual

SolrQuery::getFacetDateStart

(PECL solr >= 0.9.2)

SolrQuery::getFacetDateStart — Returns the lower bound for the first date range for all date faceting on this field

Açıklama

public string SolrQuery::getFacetDateStart ([ string $field_override ] )

Returns the lower bound for the first date range for all date faceting on this field. Accepts an optional field override

Değiştirgeler

field_override

The name of the field

Dönen Değerler

Returns a string on success and NULL if not set

SolrQuery::getFacetDateOther
SolrQuery::getFacetFields
SolrQuery


Returns all the facet fields

SolrQuery::getFacetDateStart
SolrQuery::getFacetLimit
SolrQuery
PHP Manual

SolrQuery::getFacetFields

(PECL solr >= 0.9.2)

SolrQuery::getFacetFields — Returns all the facet fields

Açıklama

public array SolrQuery::getFacetFields ( void )

Returns all the facet fields

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array of all the fields and NULL if none was set

SolrQuery::getFacetDateStart
SolrQuery::getFacetLimit
SolrQuery


Returns the maximum number of constraint counts that should be returned for the facet fields

SolrQuery::getFacetFields
SolrQuery::getFacetMethod
SolrQuery
PHP Manual

SolrQuery::getFacetLimit

(PECL solr >= 0.9.2)

SolrQuery::getFacetLimit — Returns the maximum number of constraint counts that should be returned for the facet fields

Açıklama

public int SolrQuery::getFacetLimit ([ string $field_override ] )

Returns the maximum number of constraint counts that should be returned for the facet fields. This method accepts an optional field override

Değiştirgeler

field_override

The name of the field to override for

Dönen Değerler

Returns an integer on success and NULL if not set

SolrQuery::getFacetFields
SolrQuery::getFacetMethod
SolrQuery


Returns the value of the facet.method parameter

SolrQuery::getFacetLimit
SolrQuery::getFacetMinCount
SolrQuery
PHP Manual

SolrQuery::getFacetMethod

(PECL solr >= 0.9.2)

SolrQuery::getFacetMethod — Returns the value of the facet.method parameter

Açıklama

public string SolrQuery::getFacetMethod ([ string $field_override ] )

Returns the value of the facet.method parameter. This accepts an optional field override.

Değiştirgeler

field_override

The name of the field

Dönen Değerler

Returns a string on success and NULL if not set

SolrQuery::getFacetLimit
SolrQuery::getFacetMinCount
SolrQuery


Returns the minimum counts for facet fields should be included in the response

SolrQuery::getFacetMethod
SolrQuery::getFacetMissing
SolrQuery
PHP Manual

SolrQuery::getFacetMinCount

(PECL solr >= 0.9.2)

SolrQuery::getFacetMinCount — Returns the minimum counts for facet fields should be included in the response

Açıklama

public int SolrQuery::getFacetMinCount ([ string $field_override ] )

Returns the minimum counts for facet fields should be included in the response. It accepts an optional field override

Değiştirgeler

field_override

The name of the field

Dönen Değerler

Returns an integer on success and NULL if not set

SolrQuery::getFacetMethod
SolrQuery::getFacetMissing
SolrQuery


Returns the current state of the facet.missing parameter

SolrQuery::getFacetMinCount
SolrQuery::getFacetOffset
SolrQuery
PHP Manual

SolrQuery::getFacetMissing

(PECL solr >= 0.9.2)

SolrQuery::getFacetMissing — Returns the current state of the facet.missing parameter

Açıklama

public bool SolrQuery::getFacetMissing ([ string $field_override ] )

Returns the current state of the facet.missing parameter. This accepts an optional field override

Değiştirgeler

field_override

The name of the field

Dönen Değerler

Returns a boolean on success and NULL if not set

SolrQuery::getFacetMinCount
SolrQuery::getFacetOffset
SolrQuery


Returns an offset into the list of constraints to be used for pagination

SolrQuery::getFacetMissing
SolrQuery::getFacetPrefix
SolrQuery
PHP Manual

SolrQuery::getFacetOffset

(PECL solr >= 0.9.2)

SolrQuery::getFacetOffset — Returns an offset into the list of constraints to be used for pagination

Açıklama

public int SolrQuery::getFacetOffset ([ string $field_override ] )

Returns an offset into the list of constraints to be used for pagination. Accepts an optional field override

Değiştirgeler

field_override

The name of the field to override for.

Dönen Değerler

Returns an integer on success and NULL if not set

SolrQuery::getFacetMissing
SolrQuery::getFacetPrefix
SolrQuery


Returns the facet prefix

SolrQuery::getFacetOffset
SolrQuery::getFacetQueries
SolrQuery
PHP Manual

SolrQuery::getFacetPrefix

(PECL solr >= 0.9.2)

SolrQuery::getFacetPrefix — Returns the facet prefix

Açıklama

public string SolrQuery::getFacetPrefix ([ string $field_override ] )

Returns the facet prefix

Değiştirgeler

field_override

The name of the field

Dönen Değerler

Returns a string on success and NULL if not set.

SolrQuery::getFacetOffset
SolrQuery::getFacetQueries
SolrQuery


Returns all the facet queries

SolrQuery::getFacetPrefix
SolrQuery::getFacetSort
SolrQuery
PHP Manual

SolrQuery::getFacetQueries

(PECL solr >= 0.9.2)

SolrQuery::getFacetQueries — Returns all the facet queries

Açıklama

public array SolrQuery::getFacetQueries ( void )

Returns all the facet queries

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array on success and NULL if not set.

SolrQuery::getFacetPrefix
SolrQuery::getFacetSort
SolrQuery


Returns the facet sort type

SolrQuery::getFacetQueries
SolrQuery::getFields
SolrQuery
PHP Manual

SolrQuery::getFacetSort

(PECL solr >= 0.9.2)

SolrQuery::getFacetSort — Returns the facet sort type

Açıklama

public int SolrQuery::getFacetSort ([ string $field_override ] )

Returns an integer (SolrQuery::FACET_SORT_INDEX or SolrQuery::FACET_SORT_COUNT)

Değiştirgeler

field_override

The name of the field

Dönen Değerler

Returns an integer (SolrQuery::FACET_SORT_INDEX or SolrQuery::FACET_SORT_COUNT) on success or NULL if not set.

SolrQuery::getFacetQueries
SolrQuery::getFields
SolrQuery


Returns the list of fields that will be returned in the response

SolrQuery::getFacetSort
SolrQuery::getFilterQueries
SolrQuery
PHP Manual

SolrQuery::getFields

(PECL solr >= 0.9.2)

SolrQuery::getFields — Returns the list of fields that will be returned in the response

Açıklama

public array SolrQuery::getFields ( void )

Returns the list of fields that will be returned in the response

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array on success and NULL if not set.

SolrQuery::getFacetSort
SolrQuery::getFilterQueries
SolrQuery


Returns an array of filter queries

SolrQuery::getFields
SolrQuery::getGroup
SolrQuery
PHP Manual

SolrQuery::getFilterQueries

(PECL solr >= 0.9.2)

SolrQuery::getFilterQueries — Returns an array of filter queries

Açıklama

public array SolrQuery::getFilterQueries ( void )

Returns an array of filter queries. These are queries that can be used to restrict the super set of documents that can be returned, without influencing score

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array on success and NULL if not set.

SolrQuery::getFields
SolrQuery::getGroup
SolrQuery


Returns true if grouping is enabled

SolrQuery::getFilterQueries
SolrQuery::getGroupCachePercent
SolrQuery
PHP Manual

SolrQuery::getGroup

(PECL solr >= 2.2.0)

SolrQuery::getGroup — Returns true if grouping is enabled

Açıklama

public bool SolrQuery::getGroup ( void )

Returns true if grouping is enabled

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Ayrıca Bakınız

  • SolrQuery::setGroup() - Enable/Disable result grouping (group parameter)
SolrQuery::getFilterQueries
SolrQuery::getGroupCachePercent
SolrQuery


Returns group cache percent value

SolrQuery::getGroup
SolrQuery::getGroupFacet
SolrQuery
PHP Manual

SolrQuery::getGroupCachePercent

(PECL solr >= 2.2.0)

SolrQuery::getGroupCachePercent — Returns group cache percent value

Açıklama

public integer SolrQuery::getGroupCachePercent ( void )

Returns group cache percent value

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Ayrıca Bakınız

  • SolrQuery::setGroupCachePercent() - Enables caching for result grouping
SolrQuery::getGroup
SolrQuery::getGroupFacet
SolrQuery


Returns the group.facet parameter value

SolrQuery::getGroupCachePercent
SolrQuery::getGroupFields
SolrQuery
PHP Manual

SolrQuery::getGroupFacet

(PECL solr >= 2.2.0)

SolrQuery::getGroupFacet — Returns the group.facet parameter value

Açıklama

public bool SolrQuery::getGroupFacet ( void )

Returns the group.facet parameter value

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Ayrıca Bakınız

  • SolrQuery::setGroupFacet() - Sets group.facet parameter
SolrQuery::getGroupCachePercent
SolrQuery::getGroupFields
SolrQuery


Returns group fields (group.field parameter values)

SolrQuery::getGroupFacet
SolrQuery::getGroupFormat
SolrQuery
PHP Manual

SolrQuery::getGroupFields

(PECL solr >= 2.2.0)

SolrQuery::getGroupFields — Returns group fields (group.field parameter values)

Açıklama

public array SolrQuery::getGroupFields ( void )

Returns group fields (group.field parameter values)

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Ayrıca Bakınız

  • SolrQuery::addGroupField() - Add a field to be used to group results.
SolrQuery::getGroupFacet
SolrQuery::getGroupFormat
SolrQuery


Returns the group.format value

SolrQuery::getGroupFields
SolrQuery::getGroupFunctions
SolrQuery
PHP Manual

SolrQuery::getGroupFormat

(PECL solr >= 2.2.0)

SolrQuery::getGroupFormat — Returns the group.format value

Açıklama

public string SolrQuery::getGroupFormat ( void )

Returns the group.format value

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Ayrıca Bakınız

  • SolrQuery::setGroupFormat() - Sets the group format, result structure (group.format parameter).
SolrQuery::getGroupFields
SolrQuery::getGroupFunctions
SolrQuery


Returns group functions (group.func parameter values)

SolrQuery::getGroupFormat
SolrQuery::getGroupLimit
SolrQuery
PHP Manual

SolrQuery::getGroupFunctions

(PECL solr >= 2.2.0)

SolrQuery::getGroupFunctions — Returns group functions (group.func parameter values)

Açıklama

public array SolrQuery::getGroupFunctions ( void )

Returns group functions (group.func parameter values)

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Ayrıca Bakınız

  • SolrQuery::addGroupFunction() - Allows grouping results based on the unique values of a function query (group.func parameter).
SolrQuery::getGroupFormat
SolrQuery::getGroupLimit
SolrQuery


Returns the group.limit value

SolrQuery::getGroupFunctions
SolrQuery::getGroupMain
SolrQuery
PHP Manual

SolrQuery::getGroupLimit

(PECL solr >= 2.2.0)

SolrQuery::getGroupLimit — Returns the group.limit value

Açıklama

public integer SolrQuery::getGroupLimit ( void )

Returns the group.limit value

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Ayrıca Bakınız

  • SolrQuery::setGroupLimit() - Specifies the number of results to return for each group. The server default value is 1.
SolrQuery::getGroupFunctions
SolrQuery::getGroupMain
SolrQuery


Returns the group.main value

SolrQuery::getGroupLimit
SolrQuery::getGroupNGroups
SolrQuery
PHP Manual

SolrQuery::getGroupMain

(PECL solr >= 2.2.0)

SolrQuery::getGroupMain — Returns the group.main value

Açıklama

public bool SolrQuery::getGroupMain ( void )

Returns the group.main value

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Ayrıca Bakınız

  • SolrQuery::setGroupMain() - If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple.
SolrQuery::getGroupLimit
SolrQuery::getGroupNGroups
SolrQuery


Returns the group.ngroups value

SolrQuery::getGroupMain
SolrQuery::getGroupOffset
SolrQuery
PHP Manual

SolrQuery::getGroupNGroups

(PECL solr >= 2.2.0)

SolrQuery::getGroupNGroups — Returns the group.ngroups value

Açıklama

public bool SolrQuery::getGroupNGroups ( void )

Returns the group.ngroups value

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Ayrıca Bakınız

  • SolrQuery::setGroupNGroups() - If true, Solr includes the number of groups that have matched the query in the results.
SolrQuery::getGroupMain
SolrQuery::getGroupOffset
SolrQuery


Returns the group.offset value

SolrQuery::getGroupNGroups
SolrQuery::getGroupQueries
SolrQuery
PHP Manual

SolrQuery::getGroupOffset

(PECL solr >= 2.2.0)

SolrQuery::getGroupOffset — Returns the group.offset value

Açıklama

public integer SolrQuery::getGroupOffset ( void )

Returns the group.offset value

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Ayrıca Bakınız

  • SolrQuery::setGroupOffset() - Sets the group.offset parameter.
SolrQuery::getGroupNGroups
SolrQuery::getGroupQueries
SolrQuery


Returns all the group.query parameter values

SolrQuery::getGroupOffset
SolrQuery::getGroupSortFields
SolrQuery
PHP Manual

SolrQuery::getGroupQueries

(PECL solr >= 2.2.0)

SolrQuery::getGroupQueries — Returns all the group.query parameter values

Açıklama

public array SolrQuery::getGroupQueries ( void )

Returns all the group.query parameter values

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

array

Ayrıca Bakınız

  • SolrQuery::addGroupQuery() - Allows grouping of documents that match the given query.
SolrQuery::getGroupOffset
SolrQuery::getGroupSortFields
SolrQuery


Returns the group.sort value

SolrQuery::getGroupQueries
SolrQuery::getGroupTruncate
SolrQuery
PHP Manual

SolrQuery::getGroupSortFields

(PECL solr >= 2.2.0)

SolrQuery::getGroupSortFields — Returns the group.sort value

Açıklama

public array SolrQuery::getGroupSortFields ( void )

Returns the group.sort value

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Ayrıca Bakınız

  • SolrQuery::addGroupSortField() - Add a group sort field (group.sort parameter).
SolrQuery::getGroupQueries
SolrQuery::getGroupTruncate
SolrQuery


Returns the group.truncate value

SolrQuery::getGroupSortFields
SolrQuery::getHighlight
SolrQuery
PHP Manual

SolrQuery::getGroupTruncate

(PECL solr >= 2.2.0)

SolrQuery::getGroupTruncate — Returns the group.truncate value

Açıklama

public bool SolrQuery::getGroupTruncate ( void )

Returns the group.truncate value

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Ayrıca Bakınız

  • SolrQuery::setGroupTruncate() - If true, facet counts are based on the most relevant document of each group matching the query.
SolrQuery::getGroupSortFields
SolrQuery::getHighlight
SolrQuery


Returns the state of the hl parameter

SolrQuery::getGroupTruncate
SolrQuery::getHighlightAlternateField
SolrQuery
PHP Manual

SolrQuery::getHighlight

(PECL solr >= 0.9.2)

SolrQuery::getHighlight — Returns the state of the hl parameter

Açıklama

public bool SolrQuery::getHighlight ( void )

Returns a boolean indicating whether or not to enable highlighted snippets to be generated in the query response.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a boolean on success and NULL if not set.

SolrQuery::getGroupTruncate
SolrQuery::getHighlightAlternateField
SolrQuery


Returns the highlight field to use as backup or default

SolrQuery::getHighlight
SolrQuery::getHighlightFields
SolrQuery
PHP Manual

SolrQuery::getHighlightAlternateField

(PECL solr >= 0.9.2)

SolrQuery::getHighlightAlternateField — Returns the highlight field to use as backup or default

Açıklama

public string SolrQuery::getHighlightAlternateField ([ string $field_override ] )

Returns the highlight field to use as backup or default. It accepts an optional override.

Değiştirgeler

field_override

The name of the field

Dönen Değerler

Returns a string on success and NULL if not set.

SolrQuery::getHighlight
SolrQuery::getHighlightFields
SolrQuery


Returns all the fields that Solr should generate highlighted snippets for

SolrQuery::getHighlightAlternateField
SolrQuery::getHighlightFormatter
SolrQuery
PHP Manual

SolrQuery::getHighlightFields

(PECL solr >= 0.9.2)

SolrQuery::getHighlightFields — Returns all the fields that Solr should generate highlighted snippets for

Açıklama

public array SolrQuery::getHighlightFields ( void )

Returns all the fields that Solr should generate highlighted snippets for

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array on success and NULL if not set.

SolrQuery::getHighlightAlternateField
SolrQuery::getHighlightFormatter
SolrQuery


Returns the formatter for the highlighted output

SolrQuery::getHighlightFields
SolrQuery::getHighlightFragmenter
SolrQuery
PHP Manual

SolrQuery::getHighlightFormatter

(PECL solr >= 0.9.2)

SolrQuery::getHighlightFormatter — Returns the formatter for the highlighted output

Açıklama

public string SolrQuery::getHighlightFormatter ([ string $field_override ] )

Returns the formatter for the highlighted output

Değiştirgeler

field_override

The name of the field

Dönen Değerler

Returns a string on success and NULL if not set.

SolrQuery::getHighlightFields
SolrQuery::getHighlightFragmenter
SolrQuery


Returns the text snippet generator for highlighted text

SolrQuery::getHighlightFormatter
SolrQuery::getHighlightFragsize
SolrQuery
PHP Manual

SolrQuery::getHighlightFragmenter

(PECL solr >= 0.9.2)

SolrQuery::getHighlightFragmenter — Returns the text snippet generator for highlighted text

Açıklama

public string SolrQuery::getHighlightFragmenter ([ string $field_override ] )

Returns the text snippet generator for highlighted text. Accepts an optional field override.

Değiştirgeler

field_override

The name of the field

Dönen Değerler

Returns a string on success and NULL if not set.

SolrQuery::getHighlightFormatter
SolrQuery::getHighlightFragsize
SolrQuery


Returns the number of characters of fragments to consider for highlighting

SolrQuery::getHighlightFragmenter
SolrQuery::getHighlightHighlightMultiTerm
SolrQuery
PHP Manual

SolrQuery::getHighlightFragsize

(PECL solr >= 0.9.2)

SolrQuery::getHighlightFragsize — Returns the number of characters of fragments to consider for highlighting

Açıklama

public int SolrQuery::getHighlightFragsize ([ string $field_override ] )

Returns the number of characters of fragments to consider for highlighting. Zero implies no fragmenting. The entire field should be used.

Değiştirgeler

field_override

The name of the field

Dönen Değerler

Returns an integer on success or NULL if not set.

SolrQuery::getHighlightFragmenter
SolrQuery::getHighlightHighlightMultiTerm
SolrQuery


Returns whether or not to enable highlighting for range/wildcard/fuzzy/prefix queries

SolrQuery::getHighlightFragsize
SolrQuery::getHighlightMaxAlternateFieldLength
SolrQuery
PHP Manual

SolrQuery::getHighlightHighlightMultiTerm

(PECL solr >= 0.9.2)

SolrQuery::getHighlightHighlightMultiTerm — Returns whether or not to enable highlighting for range/wildcard/fuzzy/prefix queries

Açıklama

public bool SolrQuery::getHighlightHighlightMultiTerm ( void )

Returns whether or not to enable highlighting for range/wildcard/fuzzy/prefix queries

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a boolean on success and NULL if not set.

SolrQuery::getHighlightFragsize
SolrQuery::getHighlightMaxAlternateFieldLength
SolrQuery


Returns the maximum number of characters of the field to return

SolrQuery::getHighlightHighlightMultiTerm
SolrQuery::getHighlightMaxAnalyzedChars
SolrQuery
PHP Manual

SolrQuery::getHighlightMaxAlternateFieldLength

(PECL solr >= 0.9.2)

SolrQuery::getHighlightMaxAlternateFieldLength — Returns the maximum number of characters of the field to return

Açıklama

public int SolrQuery::getHighlightMaxAlternateFieldLength ([ string $field_override ] )

Returns the maximum number of characters of the field to return

Değiştirgeler

field_override

The name of the field

Dönen Değerler

Returns an integer on success and NULL if not set.

SolrQuery::getHighlightHighlightMultiTerm
SolrQuery::getHighlightMaxAnalyzedChars
SolrQuery


Returns the maximum number of characters into a document to look for suitable snippets

SolrQuery::getHighlightMaxAlternateFieldLength
SolrQuery::getHighlightMergeContiguous
SolrQuery
PHP Manual

SolrQuery::getHighlightMaxAnalyzedChars

(PECL solr >= 0.9.2)

SolrQuery::getHighlightMaxAnalyzedChars — Returns the maximum number of characters into a document to look for suitable snippets

Açıklama

public int SolrQuery::getHighlightMaxAnalyzedChars ( void )

Returns the maximum number of characters into a document to look for suitable snippets

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an integer on success and NULL if not set.

SolrQuery::getHighlightMaxAlternateFieldLength
SolrQuery::getHighlightMergeContiguous
SolrQuery


Returns whether or not the collapse contiguous fragments into a single fragment

SolrQuery::getHighlightMaxAnalyzedChars
SolrQuery::getHighlightRegexMaxAnalyzedChars
SolrQuery
PHP Manual

SolrQuery::getHighlightMergeContiguous

(PECL solr >= 0.9.2)

SolrQuery::getHighlightMergeContiguous — Returns whether or not the collapse contiguous fragments into a single fragment

Açıklama

public bool SolrQuery::getHighlightMergeContiguous ([ string $field_override ] )

Returns whether or not the collapse contiguous fragments into a single fragment. Accepts an optional field override.

Değiştirgeler

field_override

The name of the field

Dönen Değerler

Returns a boolean on success and NULL if not set.

SolrQuery::getHighlightMaxAnalyzedChars
SolrQuery::getHighlightRegexMaxAnalyzedChars
SolrQuery


Returns the maximum number of characters from a field when using the regex fragmenter

SolrQuery::getHighlightMergeContiguous
SolrQuery::getHighlightRegexPattern
SolrQuery
PHP Manual

SolrQuery::getHighlightRegexMaxAnalyzedChars

(PECL solr >= 0.9.2)

SolrQuery::getHighlightRegexMaxAnalyzedChars — Returns the maximum number of characters from a field when using the regex fragmenter

Açıklama

public int SolrQuery::getHighlightRegexMaxAnalyzedChars ( void )

Returns the maximum number of characters from a field when using the regex fragmenter

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an integer on success and NULL if not set.

SolrQuery::getHighlightMergeContiguous
SolrQuery::getHighlightRegexPattern
SolrQuery


Returns the regular expression for fragmenting

SolrQuery::getHighlightRegexMaxAnalyzedChars
SolrQuery::getHighlightRegexSlop
SolrQuery
PHP Manual

SolrQuery::getHighlightRegexPattern

(PECL solr >= 0.9.2)

SolrQuery::getHighlightRegexPattern — Returns the regular expression for fragmenting

Açıklama

public string SolrQuery::getHighlightRegexPattern ( void )

Returns the regular expression used for fragmenting

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a string on success and NULL if not set.

SolrQuery::getHighlightRegexMaxAnalyzedChars
SolrQuery::getHighlightRegexSlop
SolrQuery


Returns the deviation factor from the ideal fragment size

SolrQuery::getHighlightRegexPattern
SolrQuery::getHighlightRequireFieldMatch
SolrQuery
PHP Manual

SolrQuery::getHighlightRegexSlop

(PECL solr >= 0.9.2)

SolrQuery::getHighlightRegexSlop — Returns the deviation factor from the ideal fragment size

Açıklama

public float SolrQuery::getHighlightRegexSlop ( void )

Returns the factor by which the regex fragmenter can deviate from the ideal fragment size to accomodate the regular expression

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a double on success and NULL if not set.

SolrQuery::getHighlightRegexPattern
SolrQuery::getHighlightRequireFieldMatch
SolrQuery


Returns if a field will only be highlighted if the query matched in this particular field

SolrQuery::getHighlightRegexSlop
SolrQuery::getHighlightSimplePost
SolrQuery
PHP Manual

SolrQuery::getHighlightRequireFieldMatch

(PECL solr >= 0.9.2)

SolrQuery::getHighlightRequireFieldMatch — Returns if a field will only be highlighted if the query matched in this particular field

Açıklama

public bool SolrQuery::getHighlightRequireFieldMatch ( void )

Returns if a field will only be highlighted if the query matched in this particular field.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a boolean on success and NULL if not set.

SolrQuery::getHighlightRegexSlop
SolrQuery::getHighlightSimplePost
SolrQuery


Returns the text which appears after a highlighted term

SolrQuery::getHighlightRequireFieldMatch
SolrQuery::getHighlightSimplePre
SolrQuery
PHP Manual

SolrQuery::getHighlightSimplePost

(PECL solr >= 0.9.2)

SolrQuery::getHighlightSimplePost — Returns the text which appears after a highlighted term

Açıklama

public string SolrQuery::getHighlightSimplePost ([ string $field_override ] )

Returns the text which appears after a highlighted term. Accepts an optional field override

Değiştirgeler

field_override

The name of the field

Dönen Değerler

Returns a string on success and NULL if not set.

SolrQuery::getHighlightRequireFieldMatch
SolrQuery::getHighlightSimplePre
SolrQuery


Returns the text which appears before a highlighted term

SolrQuery::getHighlightSimplePost
SolrQuery::getHighlightSnippets
SolrQuery
PHP Manual

SolrQuery::getHighlightSimplePre

(PECL solr >= 0.9.2)

SolrQuery::getHighlightSimplePre — Returns the text which appears before a highlighted term

Açıklama

public string SolrQuery::getHighlightSimplePre ([ string $field_override ] )

Returns the text which appears before a highlighted term. Accepts an optional field override

Değiştirgeler

field_override

The name of the field

Dönen Değerler

Returns a string on success and NULL if not set.

SolrQuery::getHighlightSimplePost
SolrQuery::getHighlightSnippets
SolrQuery


Returns the maximum number of highlighted snippets to generate per field

SolrQuery::getHighlightSimplePre
SolrQuery::getHighlightUsePhraseHighlighter
SolrQuery
PHP Manual

SolrQuery::getHighlightSnippets

(PECL solr >= 0.9.2)

SolrQuery::getHighlightSnippets — Returns the maximum number of highlighted snippets to generate per field

Açıklama

public int SolrQuery::getHighlightSnippets ([ string $field_override ] )

Returns the maximum number of highlighted snippets to generate per field. Accepts an optional field override

Değiştirgeler

field_override

The name of the field

Dönen Değerler

Returns an integer on success and NULL if not set.

SolrQuery::getHighlightSimplePre
SolrQuery::getHighlightUsePhraseHighlighter
SolrQuery


Returns the state of the hl.usePhraseHighlighter parameter

SolrQuery::getHighlightSnippets
SolrQuery::getMlt
SolrQuery
PHP Manual

SolrQuery::getHighlightUsePhraseHighlighter

(PECL solr >= 0.9.2)

SolrQuery::getHighlightUsePhraseHighlighter — Returns the state of the hl.usePhraseHighlighter parameter

Açıklama

public bool SolrQuery::getHighlightUsePhraseHighlighter ( void )

Returns whether or not to use SpanScorer to highlight phrase terms only when they appear within the query phrase in the document.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a boolean on success and NULL if not set.

SolrQuery::getHighlightSnippets
SolrQuery::getMlt
SolrQuery


Returns whether or not MoreLikeThis results should be enabled

SolrQuery::getHighlightUsePhraseHighlighter
SolrQuery::getMltBoost
SolrQuery
PHP Manual

SolrQuery::getMlt

(PECL solr >= 0.9.2)

SolrQuery::getMlt — Returns whether or not MoreLikeThis results should be enabled

Açıklama

public bool SolrQuery::getMlt ( void )

Returns whether or not MoreLikeThis results should be enabled

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a boolean on success and NULL if not set.

SolrQuery::getHighlightUsePhraseHighlighter
SolrQuery::getMltBoost
SolrQuery


Returns whether or not the query will be boosted by the interesting term relevance

SolrQuery::getMlt
SolrQuery::getMltCount
SolrQuery
PHP Manual

SolrQuery::getMltBoost

(PECL solr >= 0.9.2)

SolrQuery::getMltBoost — Returns whether or not the query will be boosted by the interesting term relevance

Açıklama

public bool SolrQuery::getMltBoost ( void )

Returns whether or not the query will be boosted by the interesting term relevance

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a boolean on success and NULL if not set.

SolrQuery::getMlt
SolrQuery::getMltCount
SolrQuery


Returns the number of similar documents to return for each result

SolrQuery::getMltBoost
SolrQuery::getMltFields
SolrQuery
PHP Manual

SolrQuery::getMltCount

(PECL solr >= 0.9.2)

SolrQuery::getMltCount — Returns the number of similar documents to return for each result

Açıklama

public int SolrQuery::getMltCount ( void )

Returns the number of similar documents to return for each result

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an integer on success and NULL if not set.

SolrQuery::getMltBoost
SolrQuery::getMltFields
SolrQuery


Returns all the fields to use for similarity

SolrQuery::getMltCount
SolrQuery::getMltMaxNumQueryTerms
SolrQuery
PHP Manual

SolrQuery::getMltFields

(PECL solr >= 0.9.2)

SolrQuery::getMltFields — Returns all the fields to use for similarity

Açıklama

public array SolrQuery::getMltFields ( void )

Returns all the fields to use for similarity

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array on success and NULL if not set.

SolrQuery::getMltCount
SolrQuery::getMltMaxNumQueryTerms
SolrQuery


Returns the maximum number of query terms that will be included in any generated query

SolrQuery::getMltFields
SolrQuery::getMltMaxNumTokens
SolrQuery
PHP Manual

SolrQuery::getMltMaxNumQueryTerms

(PECL solr >= 0.9.2)

SolrQuery::getMltMaxNumQueryTerms — Returns the maximum number of query terms that will be included in any generated query

Açıklama

public int SolrQuery::getMltMaxNumQueryTerms ( void )

Returns the maximum number of query terms that will be included in any generated query

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an integer on success and NULL if not set.

SolrQuery::getMltFields
SolrQuery::getMltMaxNumTokens
SolrQuery


Returns the maximum number of tokens to parse in each document field that is not stored with TermVector support

SolrQuery::getMltMaxNumQueryTerms
SolrQuery::getMltMaxWordLength
SolrQuery
PHP Manual

SolrQuery::getMltMaxNumTokens

(PECL solr >= 0.9.2)

SolrQuery::getMltMaxNumTokens — Returns the maximum number of tokens to parse in each document field that is not stored with TermVector support

Açıklama

public int SolrQuery::getMltMaxNumTokens ( void )

Returns the maximum number of tokens to parse in each document field that is not stored with TermVector support

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an integer on success and NULL if not set.

SolrQuery::getMltMaxNumQueryTerms
SolrQuery::getMltMaxWordLength
SolrQuery


Returns the maximum word length above which words will be ignored

SolrQuery::getMltMaxNumTokens
SolrQuery::getMltMinDocFrequency
SolrQuery
PHP Manual

SolrQuery::getMltMaxWordLength

(PECL solr >= 0.9.2)

SolrQuery::getMltMaxWordLength — Returns the maximum word length above which words will be ignored

Açıklama

public int SolrQuery::getMltMaxWordLength ( void )

Returns the maximum word length above which words will be ignored

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an integer on success and NULL if not set.

SolrQuery::getMltMaxNumTokens
SolrQuery::getMltMinDocFrequency
SolrQuery


Returns the treshold frequency at which words will be ignored which do not occur in at least this many docs

SolrQuery::getMltMaxWordLength
SolrQuery::getMltMinTermFrequency
SolrQuery
PHP Manual

SolrQuery::getMltMinDocFrequency

(PECL solr >= 0.9.2)

SolrQuery::getMltMinDocFrequency — Returns the treshold frequency at which words will be ignored which do not occur in at least this many docs

Açıklama

public int SolrQuery::getMltMinDocFrequency ( void )

Returns the treshold frequency at which words will be ignored which do not occur in at least this many docs

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an integer on success and NULL if not set.

SolrQuery::getMltMaxWordLength
SolrQuery::getMltMinTermFrequency
SolrQuery


Returns the frequency below which terms will be ignored in the source document

SolrQuery::getMltMinDocFrequency
SolrQuery::getMltMinWordLength
SolrQuery
PHP Manual

SolrQuery::getMltMinTermFrequency

(PECL solr >= 0.9.2)

SolrQuery::getMltMinTermFrequency — Returns the frequency below which terms will be ignored in the source document

Açıklama

public int SolrQuery::getMltMinTermFrequency ( void )

Returns the frequency below which terms will be ignored in the source document

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an integer on success and NULL if not set.

SolrQuery::getMltMinDocFrequency
SolrQuery::getMltMinWordLength
SolrQuery


Returns the minimum word length below which words will be ignored

SolrQuery::getMltMinTermFrequency
SolrQuery::getMltQueryFields
SolrQuery
PHP Manual

SolrQuery::getMltMinWordLength

(PECL solr >= 0.9.2)

SolrQuery::getMltMinWordLength — Returns the minimum word length below which words will be ignored

Açıklama

public int SolrQuery::getMltMinWordLength ( void )

Returns the minimum word length below which words will be ignored

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an integer on success and NULL if not set.

SolrQuery::getMltMinTermFrequency
SolrQuery::getMltQueryFields
SolrQuery


Returns the query fields and their boosts

SolrQuery::getMltMinWordLength
SolrQuery::getQuery
SolrQuery
PHP Manual

SolrQuery::getMltQueryFields

(PECL solr >= 0.9.2)

SolrQuery::getMltQueryFields — Returns the query fields and their boosts

Açıklama

public array SolrQuery::getMltQueryFields ( void )

Returns the query fields and their boosts

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array on success and NULL if not set.

SolrQuery::getMltMinWordLength
SolrQuery::getQuery
SolrQuery


Returns the main query

SolrQuery::getMltQueryFields
SolrQuery::getRows
SolrQuery
PHP Manual

SolrQuery::getQuery

(PECL solr >= 0.9.2)

SolrQuery::getQuery — Returns the main query

Açıklama

public string SolrQuery::getQuery ( void )

Returns the main search query

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a string on success and NULL if not set.

SolrQuery::getMltQueryFields
SolrQuery::getRows
SolrQuery


Returns the maximum number of documents

SolrQuery::getQuery
SolrQuery::getSortFields
SolrQuery
PHP Manual

SolrQuery::getRows

(PECL solr >= 0.9.2)

SolrQuery::getRows — Returns the maximum number of documents

Açıklama

public int SolrQuery::getRows ( void )

Returns the maximum number of documents from the complete result set to return to the client for every request

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an integer on success and NULL if not set.

SolrQuery::getQuery
SolrQuery::getSortFields
SolrQuery


Returns all the sort fields

SolrQuery::getRows
SolrQuery::getStart
SolrQuery
PHP Manual

SolrQuery::getSortFields

(PECL solr >= 0.9.2)

SolrQuery::getSortFields — Returns all the sort fields

Açıklama

public array SolrQuery::getSortFields ( void )

Returns all the sort fields

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array on success and NULL if none of the parameters was set.

SolrQuery::getRows
SolrQuery::getStart
SolrQuery


Returns the offset in the complete result set

SolrQuery::getSortFields
SolrQuery::getStats
SolrQuery
PHP Manual

SolrQuery::getStart

(PECL solr >= 0.9.2)

SolrQuery::getStart — Returns the offset in the complete result set

Açıklama

public int SolrQuery::getStart ( void )

Returns the offset in the complete result set for the queries where the set of returned documents should begin.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an integer on success and NULL if not set.

SolrQuery::getSortFields
SolrQuery::getStats
SolrQuery


Returns whether or not stats is enabled

SolrQuery::getStart
SolrQuery::getStatsFacets
SolrQuery
PHP Manual

SolrQuery::getStats

(PECL solr >= 0.9.2)

SolrQuery::getStats — Returns whether or not stats is enabled

Açıklama

public bool SolrQuery::getStats ( void )

Returns whether or not stats is enabled

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a boolean on success and NULL if not set.

SolrQuery::getStart
SolrQuery::getStatsFacets
SolrQuery


Returns all the stats facets that were set

SolrQuery::getStats
SolrQuery::getStatsFields
SolrQuery
PHP Manual

SolrQuery::getStatsFacets

(PECL solr >= 0.9.2)

SolrQuery::getStatsFacets — Returns all the stats facets that were set

Açıklama

public array SolrQuery::getStatsFacets ( void )

Returns all the stats facets that were set

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array on success and NULL if not set.

SolrQuery::getStats
SolrQuery::getStatsFields
SolrQuery


Returns all the statistics fields

SolrQuery::getStatsFacets
SolrQuery::getTerms
SolrQuery
PHP Manual

SolrQuery::getStatsFields

(PECL solr >= 0.9.2)

SolrQuery::getStatsFields — Returns all the statistics fields

Açıklama

public array SolrQuery::getStatsFields ( void )

Returns all the statistics fields

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array on success and NULL if not set.

SolrQuery::getStatsFacets
SolrQuery::getTerms
SolrQuery


Returns whether or not the TermsComponent is enabled

SolrQuery::getStatsFields
SolrQuery::getTermsField
SolrQuery
PHP Manual

SolrQuery::getTerms

(PECL solr >= 0.9.2)

SolrQuery::getTerms — Returns whether or not the TermsComponent is enabled

Açıklama

public bool SolrQuery::getTerms ( void )

Returns whether or not the TermsComponent is enabled

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a boolean on success and NULL if not set.

SolrQuery::getStatsFields
SolrQuery::getTermsField
SolrQuery


Returns the field from which the terms are retrieved

SolrQuery::getTerms
SolrQuery::getTermsIncludeLowerBound
SolrQuery
PHP Manual

SolrQuery::getTermsField

(PECL solr >= 0.9.2)

SolrQuery::getTermsField — Returns the field from which the terms are retrieved

Açıklama

public string SolrQuery::getTermsField ( void )

Returns the field from which the terms are retrieved

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a string on success and NULL if not set.

SolrQuery::getTerms
SolrQuery::getTermsIncludeLowerBound
SolrQuery


Returns whether or not to include the lower bound in the result set

SolrQuery::getTermsField
SolrQuery::getTermsIncludeUpperBound
SolrQuery
PHP Manual

SolrQuery::getTermsIncludeLowerBound

(PECL solr >= 0.9.2)

SolrQuery::getTermsIncludeLowerBound — Returns whether or not to include the lower bound in the result set

Açıklama

public bool SolrQuery::getTermsIncludeLowerBound ( void )

Returns whether or not to include the lower bound in the result set

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a boolean on success and NULL if not set.

SolrQuery::getTermsField
SolrQuery::getTermsIncludeUpperBound
SolrQuery


Returns whether or not to include the upper bound term in the result set

SolrQuery::getTermsIncludeLowerBound
SolrQuery::getTermsLimit
SolrQuery
PHP Manual

SolrQuery::getTermsIncludeUpperBound

(PECL solr >= 0.9.2)

SolrQuery::getTermsIncludeUpperBound — Returns whether or not to include the upper bound term in the result set

Açıklama

public bool SolrQuery::getTermsIncludeUpperBound ( void )

Returns whether or not to include the upper bound term in the result set

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a boolean on success and NULL if not set.

SolrQuery::getTermsIncludeLowerBound
SolrQuery::getTermsLimit
SolrQuery


Returns the maximum number of terms Solr should return

SolrQuery::getTermsIncludeUpperBound
SolrQuery::getTermsLowerBound
SolrQuery
PHP Manual

SolrQuery::getTermsLimit

(PECL solr >= 0.9.2)

SolrQuery::getTermsLimit — Returns the maximum number of terms Solr should return

Açıklama

public int SolrQuery::getTermsLimit ( void )

Returns the maximum number of terms Solr should return

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an integer on success and NULL if not set.

SolrQuery::getTermsIncludeUpperBound
SolrQuery::getTermsLowerBound
SolrQuery


Returns the term to start at

SolrQuery::getTermsLimit
SolrQuery::getTermsMaxCount
SolrQuery
PHP Manual

SolrQuery::getTermsLowerBound

(PECL solr >= 0.9.2)

SolrQuery::getTermsLowerBound — Returns the term to start at

Açıklama

public string SolrQuery::getTermsLowerBound ( void )

Returns the term to start at

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a string on success and NULL if not set.

SolrQuery::getTermsLimit
SolrQuery::getTermsMaxCount
SolrQuery


Returns the maximum document frequency

SolrQuery::getTermsLowerBound
SolrQuery::getTermsMinCount
SolrQuery
PHP Manual

SolrQuery::getTermsMaxCount

(PECL solr >= 0.9.2)

SolrQuery::getTermsMaxCount — Returns the maximum document frequency

Açıklama

public int SolrQuery::getTermsMaxCount ( void )

Returns the maximum document frequency

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an integer on success and NULL if not set.

SolrQuery::getTermsLowerBound
SolrQuery::getTermsMinCount
SolrQuery


Returns the minimum document frequency to return in order to be included

SolrQuery::getTermsMaxCount
SolrQuery::getTermsPrefix
SolrQuery
PHP Manual

SolrQuery::getTermsMinCount

(PECL solr >= 0.9.2)

SolrQuery::getTermsMinCount — Returns the minimum document frequency to return in order to be included

Açıklama

public int SolrQuery::getTermsMinCount ( void )

Returns the minimum document frequency to return in order to be included

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an integer on success and NULL if not set.

SolrQuery::getTermsMaxCount
SolrQuery::getTermsPrefix
SolrQuery


Returns the term prefix

SolrQuery::getTermsMinCount
SolrQuery::getTermsReturnRaw
SolrQuery
PHP Manual

SolrQuery::getTermsPrefix

(PECL solr >= 0.9.2)

SolrQuery::getTermsPrefix — Returns the term prefix

Açıklama

public string SolrQuery::getTermsPrefix ( void )

Returns the prefix to which matching terms must be restricted. This will restrict matches to only terms that start with the prefix

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a string on success and NULL if not set.

SolrQuery::getTermsMinCount
SolrQuery::getTermsReturnRaw
SolrQuery


Whether or not to return raw characters

SolrQuery::getTermsPrefix
SolrQuery::getTermsSort
SolrQuery
PHP Manual

SolrQuery::getTermsReturnRaw

(PECL solr >= 0.9.2)

SolrQuery::getTermsReturnRaw — Whether or not to return raw characters

Açıklama

public bool SolrQuery::getTermsReturnRaw ( void )

Returns a boolean indicating whether or not to return the raw characters of the indexed term, regardless of if it is human readable

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a boolean on success and NULL if not set.

SolrQuery::getTermsPrefix
SolrQuery::getTermsSort
SolrQuery


Returns an integer indicating how terms are sorted

SolrQuery::getTermsReturnRaw
SolrQuery::getTermsUpperBound
SolrQuery
PHP Manual

SolrQuery::getTermsSort

(PECL solr >= 0.9.2)

SolrQuery::getTermsSort — Returns an integer indicating how terms are sorted

Açıklama

public int SolrQuery::getTermsSort ( void )

SolrQuery::TERMS_SORT_INDEX indicates that the terms are returned by index order. SolrQuery::TERMS_SORT_COUNT implies that the terms are sorted by term frequency (highest count first)

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an integer on success and NULL if not set.

SolrQuery::getTermsReturnRaw
SolrQuery::getTermsUpperBound
SolrQuery


Returns the term to stop at

SolrQuery::getTermsSort
SolrQuery::getTimeAllowed
SolrQuery
PHP Manual

SolrQuery::getTermsUpperBound

(PECL solr >= 0.9.2)

SolrQuery::getTermsUpperBound — Returns the term to stop at

Açıklama

public string SolrQuery::getTermsUpperBound ( void )

Returns the term to stop at

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a string on success and NULL if not set.

SolrQuery::getTermsSort
SolrQuery::getTimeAllowed
SolrQuery


Returns the time in milliseconds allowed for the query to finish

SolrQuery::getTermsUpperBound
SolrQuery::removeExpandFilterQuery
SolrQuery
PHP Manual

SolrQuery::getTimeAllowed

(PECL solr >= 0.9.2)

SolrQuery::getTimeAllowed — Returns the time in milliseconds allowed for the query to finish

Açıklama

public int SolrQuery::getTimeAllowed ( void )

Returns the time in milliseconds allowed for the query to finish.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns and integer on success and NULL if it is not set.

SolrQuery::getTermsUpperBound
SolrQuery::removeExpandFilterQuery
SolrQuery


Removes an expand filter query

SolrQuery::getTimeAllowed
SolrQuery::removeExpandSortField
SolrQuery
PHP Manual

SolrQuery::removeExpandFilterQuery

(PECL solr >= 2.2.0)

SolrQuery::removeExpandFilterQuery — Removes an expand filter query

Açıklama

public SolrQuery SolrQuery::removeExpandFilterQuery ( string $fq )

Removes an expand filter query.

Değiştirgeler

fq

Dönen Değerler

SolrQuery

Ayrıca Bakınız

  • SolrQuery::setExpand() - Enables/Disables the Expand Component
  • SolrQuery::addExpandSortField() - Orders the documents within the expanded groups (expand.sort parameter).
  • SolrQuery::removeExpandSortField() - Removes an expand sort field from the expand.sort parameter.
  • SolrQuery::setExpandRows() - Sets the number of rows to display in each group (expand.rows). Server Default 5
  • SolrQuery::setExpandQuery() - Sets the expand.q parameter
  • SolrQuery::addExpandFilterQuery() - Overrides main filter query, determines which documents to include in the main group.
SolrQuery::getTimeAllowed
SolrQuery::removeExpandSortField
SolrQuery


Removes an expand sort field from the expand.sort parameter.

SolrQuery::removeExpandFilterQuery
SolrQuery::removeFacetDateField
SolrQuery
PHP Manual

SolrQuery::removeExpandSortField

(PECL solr >= 2.2.0)

SolrQuery::removeExpandSortField — Removes an expand sort field from the expand.sort parameter.

Açıklama

public SolrQuery SolrQuery::removeExpandSortField ( string $field )

Removes an expand sort field from the expand.sort parameter.

Değiştirgeler

field

field name

Dönen Değerler

SolrQuery

Ayrıca Bakınız

  • SolrQuery::setExpand() - Enables/Disables the Expand Component
  • SolrQuery::addExpandSortField() - Orders the documents within the expanded groups (expand.sort parameter).
  • SolrQuery::setExpandRows() - Sets the number of rows to display in each group (expand.rows). Server Default 5
  • SolrQuery::setExpandQuery() - Sets the expand.q parameter
  • SolrQuery::addExpandFilterQuery() - Overrides main filter query, determines which documents to include in the main group.
  • SolrQuery::removeExpandFilterQuery() - Removes an expand filter query
SolrQuery::removeExpandFilterQuery
SolrQuery::removeFacetDateField
SolrQuery


Removes one of the facet date fields

SolrQuery::removeExpandSortField
SolrQuery::removeFacetDateOther
SolrQuery
PHP Manual

SolrQuery::removeFacetDateField

(PECL solr >= 0.9.2)

SolrQuery::removeFacetDateField — Removes one of the facet date fields

Açıklama

public SolrQuery SolrQuery::removeFacetDateField ( string $field )

The name of the field

Değiştirgeler

field

The name of the date field to remove

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::removeExpandSortField
SolrQuery::removeFacetDateOther
SolrQuery


Removes one of the facet.date.other parameters

SolrQuery::removeFacetDateField
SolrQuery::removeFacetField
SolrQuery
PHP Manual

SolrQuery::removeFacetDateOther

(PECL solr >= 0.9.2)

SolrQuery::removeFacetDateOther — Removes one of the facet.date.other parameters

Açıklama

public SolrQuery SolrQuery::removeFacetDateOther ( string $value [, string $field_override ] )

Removes one of the facet.date.other parameters

Değiştirgeler

value

The value

field_override

The name of the field.

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::removeFacetDateField
SolrQuery::removeFacetField
SolrQuery


Removes one of the facet.date parameters

SolrQuery::removeFacetDateOther
SolrQuery::removeFacetQuery
SolrQuery
PHP Manual

SolrQuery::removeFacetField

(PECL solr >= 0.9.2)

SolrQuery::removeFacetField — Removes one of the facet.date parameters

Açıklama

public SolrQuery SolrQuery::removeFacetField ( string $field )

Removes one of the facet.date parameters

Değiştirgeler

field

The name of the field

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::removeFacetDateOther
SolrQuery::removeFacetQuery
SolrQuery


Removes one of the facet.query parameters

SolrQuery::removeFacetField
SolrQuery::removeField
SolrQuery
PHP Manual

SolrQuery::removeFacetQuery

(PECL solr >= 0.9.2)

SolrQuery::removeFacetQuery — Removes one of the facet.query parameters

Açıklama

public SolrQuery SolrQuery::removeFacetQuery ( string $value )

Removes one of the facet.query parameters.

Değiştirgeler

value

The value

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::removeFacetField
SolrQuery::removeField
SolrQuery


Removes a field from the list of fields

SolrQuery::removeFacetQuery
SolrQuery::removeFilterQuery
SolrQuery
PHP Manual

SolrQuery::removeField

(PECL solr >= 0.9.2)

SolrQuery::removeField — Removes a field from the list of fields

Açıklama

public SolrQuery SolrQuery::removeField ( string $field )

Removes a field from the list of fields

Değiştirgeler

field

Name of the field.

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::removeFacetQuery
SolrQuery::removeFilterQuery
SolrQuery


Removes a filter query

SolrQuery::removeField
SolrQuery::removeHighlightField
SolrQuery
PHP Manual

SolrQuery::removeFilterQuery

(PECL solr >= 0.9.2)

SolrQuery::removeFilterQuery — Removes a filter query

Açıklama

public SolrQuery SolrQuery::removeFilterQuery ( string $fq )

Removes a filter query.

Değiştirgeler

fq

The filter query to remove

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::removeField
SolrQuery::removeHighlightField
SolrQuery


Removes one of the fields used for highlighting

SolrQuery::removeFilterQuery
SolrQuery::removeMltField
SolrQuery
PHP Manual

SolrQuery::removeHighlightField

(PECL solr >= 0.9.2)

SolrQuery::removeHighlightField — Removes one of the fields used for highlighting

Açıklama

public SolrQuery SolrQuery::removeHighlightField ( string $field )

Removes one of the fields used for highlighting.

Değiştirgeler

field

The name of the field

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::removeFilterQuery
SolrQuery::removeMltField
SolrQuery


Removes one of the moreLikeThis fields

SolrQuery::removeHighlightField
SolrQuery::removeMltQueryField
SolrQuery
PHP Manual

SolrQuery::removeMltField

(PECL solr >= 0.9.2)

SolrQuery::removeMltField — Removes one of the moreLikeThis fields

Açıklama

public SolrQuery SolrQuery::removeMltField ( string $field )

Removes one of the moreLikeThis fields.

Değiştirgeler

field

Name of the field

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::removeHighlightField
SolrQuery::removeMltQueryField
SolrQuery


Removes one of the moreLikeThis query fields

SolrQuery::removeMltField
SolrQuery::removeSortField
SolrQuery
PHP Manual

SolrQuery::removeMltQueryField

(PECL solr >= 0.9.2)

SolrQuery::removeMltQueryField — Removes one of the moreLikeThis query fields

Açıklama

public SolrQuery SolrQuery::removeMltQueryField ( string $queryField )

Removes one of the moreLikeThis query fields.

Değiştirgeler

queryField

The query field

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::removeMltField
SolrQuery::removeSortField
SolrQuery


Removes one of the sort fields

SolrQuery::removeMltQueryField
SolrQuery::removeStatsFacet
SolrQuery
PHP Manual

SolrQuery::removeSortField

(PECL solr >= 0.9.2)

SolrQuery::removeSortField — Removes one of the sort fields

Açıklama

public SolrQuery SolrQuery::removeSortField ( string $field )

Removes one of the sort fields

Değiştirgeler

field

The name of the field

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::removeMltQueryField
SolrQuery::removeStatsFacet
SolrQuery


Removes one of the stats.facet parameters

SolrQuery::removeSortField
SolrQuery::removeStatsField
SolrQuery
PHP Manual

SolrQuery::removeStatsFacet

(PECL solr >= 0.9.2)

SolrQuery::removeStatsFacet — Removes one of the stats.facet parameters

Açıklama

public SolrQuery SolrQuery::removeStatsFacet ( string $value )

Removes one of the stats.facet parameters

Değiştirgeler

value

The value

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::removeSortField
SolrQuery::removeStatsField
SolrQuery


Removes one of the stats.field parameters

SolrQuery::removeStatsFacet
SolrQuery::setEchoHandler
SolrQuery
PHP Manual

SolrQuery::removeStatsField

(PECL solr >= 0.9.2)

SolrQuery::removeStatsField — Removes one of the stats.field parameters

Açıklama

public SolrQuery SolrQuery::removeStatsField ( string $field )

Removes one of the stats.field parameters

Değiştirgeler

field

The name of the field.

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::removeStatsFacet
SolrQuery::setEchoHandler
SolrQuery


Toggles the echoHandler parameter

SolrQuery::removeStatsField
SolrQuery::setEchoParams
SolrQuery
PHP Manual

SolrQuery::setEchoHandler

(PECL solr >= 0.9.2)

SolrQuery::setEchoHandler — Toggles the echoHandler parameter

Açıklama

public SolrQuery SolrQuery::setEchoHandler ( bool $flag )

If set to true, Solr places the name of the handle used in the response to the client for debugging purposes.

Değiştirgeler

flag

TRUE or FALSE

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::removeStatsField
SolrQuery::setEchoParams
SolrQuery


Determines what kind of parameters to include in the response

SolrQuery::setEchoHandler
SolrQuery::setExpand
SolrQuery
PHP Manual

SolrQuery::setEchoParams

(PECL solr >= 0.9.2)

SolrQuery::setEchoParams — Determines what kind of parameters to include in the response

Açıklama

public SolrQuery SolrQuery::setEchoParams ( string $type )

Instructs Solr what kinds of Request parameters should be included in the response for debugging purposes, legal values include:

- none - don't include any request parameters for debugging
- explicit - include the parameters explicitly specified by the client in the request
- all - include all parameters involved in this request, either specified explicitly by the client, or implicit because of the request handler configuration.

Değiştirgeler

type

The type of parameters to include

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setEchoHandler
SolrQuery::setExpand
SolrQuery


Enables/Disables the Expand Component

SolrQuery::setEchoParams
SolrQuery::setExpandQuery
SolrQuery
PHP Manual

SolrQuery::setExpand

(PECL solr >= 2.2.0)

SolrQuery::setExpand — Enables/Disables the Expand Component

Açıklama

public SolrQuery SolrQuery::setExpand ( bool $value )

Enables/Disables the Expand Component.

Değiştirgeler

value

Bool flag

Dönen Değerler

SolrQuery

Örnekler

Örnek 1 SolrQuery::setExpand() example

<?php

$query = new SolrQuery('lucene');

$query
    ->setExpand(true)
    ->setExpandRows(50)
    ->setExpandQuery('text:product')
    ->addExpandFilterQuery('manu:apple')
    ->addExpandFilterQuery('inStock:true')
    ->addExpandSortField('score', SolrQuery::ORDER_DESC)
    ->addExpandSortField('title', SolrQuery::ORDER_ASC);

echo $query.PHP_EOL;

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

q=lucene&expand=true&expand.rows=50&expand.q=text:product&expand.fq=manu:apple&expand.fq=inStock:true&expand.sort=score desc,title asc

Ayrıca Bakınız

  • SolrQuery::addExpandSortField() - Orders the documents within the expanded groups (expand.sort parameter).
  • SolrQuery::removeExpandSortField() - Removes an expand sort field from the expand.sort parameter.
  • SolrQuery::setExpandRows() - Sets the number of rows to display in each group (expand.rows). Server Default 5
  • SolrQuery::setExpandQuery() - Sets the expand.q parameter
  • SolrQuery::addExpandFilterQuery() - Overrides main filter query, determines which documents to include in the main group.
  • SolrQuery::removeExpandFilterQuery() - Removes an expand filter query
SolrQuery::setEchoParams
SolrQuery::setExpandQuery
SolrQuery


Sets the expand.q parameter

SolrQuery::setExpand
SolrQuery::setExpandRows
SolrQuery
PHP Manual

SolrQuery::setExpandQuery

(PECL solr >= 2.2.0)

SolrQuery::setExpandQuery — Sets the expand.q parameter

Açıklama

public SolrQuery SolrQuery::setExpandQuery ( string $q )

Sets the expand.q parameter.

Overrides the main q parameter, determines which documents to include in the main group.

Değiştirgeler

q

Dönen Değerler

SolrQuery

Ayrıca Bakınız

  • SolrQuery::setExpand() - Enables/Disables the Expand Component
  • SolrQuery::addExpandSortField() - Orders the documents within the expanded groups (expand.sort parameter).
  • SolrQuery::removeExpandSortField() - Removes an expand sort field from the expand.sort parameter.
  • SolrQuery::setExpandRows() - Sets the number of rows to display in each group (expand.rows). Server Default 5
  • SolrQuery::addExpandFilterQuery() - Overrides main filter query, determines which documents to include in the main group.
  • SolrQuery::removeExpandFilterQuery() - Removes an expand filter query
SolrQuery::setExpand
SolrQuery::setExpandRows
SolrQuery


Sets the number of rows to display in each group (expand.rows). Server Default 5

SolrQuery::setExpandQuery
SolrQuery::setExplainOther
SolrQuery
PHP Manual

SolrQuery::setExpandRows

(PECL solr >= 2.2.0)

SolrQuery::setExpandRows — Sets the number of rows to display in each group (expand.rows). Server Default 5

Açıklama

public SolrQuery SolrQuery::setExpandRows ( integer $value )

Sets the number of rows to display in each group (expand.rows). Server Default 5

Değiştirgeler

value

Dönen Değerler

SolrQuery

Ayrıca Bakınız

  • SolrQuery::setExpand() - Enables/Disables the Expand Component
  • SolrQuery::addExpandSortField() - Orders the documents within the expanded groups (expand.sort parameter).
  • SolrQuery::removeExpandSortField() - Removes an expand sort field from the expand.sort parameter.
  • SolrQuery::setExpandQuery() - Sets the expand.q parameter
  • SolrQuery::addExpandFilterQuery() - Overrides main filter query, determines which documents to include in the main group.
  • SolrQuery::removeExpandFilterQuery() - Removes an expand filter query
SolrQuery::setExpandQuery
SolrQuery::setExplainOther
SolrQuery


Sets the explainOther common query parameter

SolrQuery::setExpandRows
SolrQuery::setFacet
SolrQuery
PHP Manual

SolrQuery::setExplainOther

(PECL solr >= 0.9.2)

SolrQuery::setExplainOther — Sets the explainOther common query parameter

Açıklama

public SolrQuery SolrQuery::setExplainOther ( string $query )

Sets the explainOther common query parameter

Değiştirgeler

query

The Lucene query to identify a set of documents

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setExpandRows
SolrQuery::setFacet
SolrQuery


Maps to the facet parameter. Enables or disables facetting

SolrQuery::setExplainOther
SolrQuery::setFacetDateEnd
SolrQuery
PHP Manual

SolrQuery::setFacet

(PECL solr >= 0.9.2)

SolrQuery::setFacet — Maps to the facet parameter. Enables or disables facetting

Açıklama

public SolrQuery SolrQuery::setFacet ( bool $flag )

Enables or disables faceting.

Değiştirgeler

value

TRUE enables faceting and FALSE disables it.

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setExplainOther
SolrQuery::setFacetDateEnd
SolrQuery


Maps to facet.date.end

SolrQuery::setFacet
SolrQuery::setFacetDateGap
SolrQuery
PHP Manual

SolrQuery::setFacetDateEnd

(PECL solr >= 0.9.2)

SolrQuery::setFacetDateEnd — Maps to facet.date.end

Açıklama

public SolrQuery SolrQuery::setFacetDateEnd ( string $value [, string $field_override ] )

Maps to facet.date.end

Değiştirgeler

value

See facet.date.end

field_override

Name of the field

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setFacet
SolrQuery::setFacetDateGap
SolrQuery


Maps to facet.date.gap

SolrQuery::setFacetDateEnd
SolrQuery::setFacetDateHardEnd
SolrQuery
PHP Manual

SolrQuery::setFacetDateGap

(PECL solr >= 0.9.2)

SolrQuery::setFacetDateGap — Maps to facet.date.gap

Açıklama

public SolrQuery SolrQuery::setFacetDateGap ( string $value [, string $field_override ] )

Maps to facet.date.gap

Değiştirgeler

value

See facet.date.gap

field_override

The name of the field

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setFacetDateEnd
SolrQuery::setFacetDateHardEnd
SolrQuery


Maps to facet.date.hardend

SolrQuery::setFacetDateGap
SolrQuery::setFacetDateStart
SolrQuery
PHP Manual

SolrQuery::setFacetDateHardEnd

(PECL solr >= 0.9.2)

SolrQuery::setFacetDateHardEnd — Maps to facet.date.hardend

Açıklama

public SolrQuery SolrQuery::setFacetDateHardEnd ( bool $value [, string $field_override ] )

Maps to facet.date.hardend

Değiştirgeler

value

See facet.date.hardend

field_override

The name of the field

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setFacetDateGap
SolrQuery::setFacetDateStart
SolrQuery


Maps to facet.date.start

SolrQuery::setFacetDateHardEnd
SolrQuery::setFacetEnumCacheMinDefaultFrequency
SolrQuery
PHP Manual

SolrQuery::setFacetDateStart

(PECL solr >= 0.9.2)

SolrQuery::setFacetDateStart — Maps to facet.date.start

Açıklama

public SolrQuery SolrQuery::setFacetDateStart ( string $value [, string $field_override ] )

Maps to facet.date.start

Değiştirgeler

value

See facet.date.start

field_override

The name of the field.

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setFacetDateHardEnd
SolrQuery::setFacetEnumCacheMinDefaultFrequency
SolrQuery


Sets the minimum document frequency used for determining term count

SolrQuery::setFacetDateStart
SolrQuery::setFacetLimit
SolrQuery
PHP Manual

SolrQuery::setFacetEnumCacheMinDefaultFrequency

(PECL solr >= 0.9.2)

SolrQuery::setFacetEnumCacheMinDefaultFrequency — Sets the minimum document frequency used for determining term count

Açıklama

public SolrQuery SolrQuery::setFacetEnumCacheMinDefaultFrequency ( int $frequency [, string $field_override ] )

Sets the minimum document frequency used for determining term count

Değiştirgeler

value

The minimum frequency

field_override

The name of the field.

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setFacetDateStart
SolrQuery::setFacetLimit
SolrQuery


Maps to facet.limit

SolrQuery::setFacetEnumCacheMinDefaultFrequency
SolrQuery::setFacetMethod
SolrQuery
PHP Manual

SolrQuery::setFacetLimit

(PECL solr >= 0.9.2)

SolrQuery::setFacetLimit — Maps to facet.limit

Açıklama

public SolrQuery SolrQuery::setFacetLimit ( int $limit [, string $field_override ] )

Maps to facet.limit. Sets the maximum number of constraint counts that should be returned for the facet fields.

Değiştirgeler

limit

The maximum number of constraint counts

field_override

The name of the field.

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setFacetEnumCacheMinDefaultFrequency
SolrQuery::setFacetMethod
SolrQuery


Specifies the type of algorithm to use when faceting a field

SolrQuery::setFacetLimit
SolrQuery::setFacetMinCount
SolrQuery
PHP Manual

SolrQuery::setFacetMethod

(PECL solr >= 0.9.2)

SolrQuery::setFacetMethod — Specifies the type of algorithm to use when faceting a field

Açıklama

public SolrQuery SolrQuery::setFacetMethod ( string $method [, string $field_override ] )

Specifies the type of algorithm to use when faceting a field. This method accepts optional field override.

Değiştirgeler

method

The method to use.

field_override

The name of the field.

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setFacetLimit
SolrQuery::setFacetMinCount
SolrQuery


Maps to facet.mincount

SolrQuery::setFacetMethod
SolrQuery::setFacetMissing
SolrQuery
PHP Manual

SolrQuery::setFacetMinCount

(PECL solr >= 0.9.2)

SolrQuery::setFacetMinCount — Maps to facet.mincount

Açıklama

public SolrQuery SolrQuery::setFacetMinCount ( int $mincount [, string $field_override ] )

Sets the minimum counts for facet fields that should be included in the response

Değiştirgeler

mincount

The minimum count

field_override

The name of the field.

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setFacetMethod
SolrQuery::setFacetMissing
SolrQuery


Maps to facet.missing

SolrQuery::setFacetMinCount
SolrQuery::setFacetOffset
SolrQuery
PHP Manual

SolrQuery::setFacetMissing

(PECL solr >= 0.9.2)

SolrQuery::setFacetMissing — Maps to facet.missing

Açıklama

public SolrQuery SolrQuery::setFacetMissing ( bool $flag [, string $field_override ] )

Used to indicate that in addition to the Term-based constraints of a facet field, a count of all matching results which have no value for the field should be computed

Değiştirgeler

flag

TRUE turns this feature on. FALSE disables it.

field_override

The name of the field.

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setFacetMinCount
SolrQuery::setFacetOffset
SolrQuery


Sets the offset into the list of constraints to allow for pagination

SolrQuery::setFacetMissing
SolrQuery::setFacetPrefix
SolrQuery
PHP Manual

SolrQuery::setFacetOffset

(PECL solr >= 0.9.2)

SolrQuery::setFacetOffset — Sets the offset into the list of constraints to allow for pagination

Açıklama

public SolrQuery SolrQuery::setFacetOffset ( int $offset [, string $field_override ] )

Sets the offset into the list of constraints to allow for pagination.

Değiştirgeler

offset

The offset

field_override

The name of the field.

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setFacetMissing
SolrQuery::setFacetPrefix
SolrQuery


Specifies a string prefix with which to limits the terms on which to facet

SolrQuery::setFacetOffset
SolrQuery::setFacetSort
SolrQuery
PHP Manual

SolrQuery::setFacetPrefix

(PECL solr >= 0.9.2)

SolrQuery::setFacetPrefix — Specifies a string prefix with which to limits the terms on which to facet

Açıklama

public SolrQuery SolrQuery::setFacetPrefix ( string $prefix [, string $field_override ] )

Specifies a string prefix with which to limits the terms on which to facet.

Değiştirgeler

prefix

The prefix string

field_override

The name of the field.

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setFacetOffset
SolrQuery::setFacetSort
SolrQuery


Determines the ordering of the facet field constraints

SolrQuery::setFacetPrefix
SolrQuery::setGroup
SolrQuery
PHP Manual

SolrQuery::setFacetSort

(PECL solr >= 0.9.2)

SolrQuery::setFacetSort — Determines the ordering of the facet field constraints

Açıklama

public SolrQuery SolrQuery::setFacetSort ( int $facetSort [, string $field_override ] )

Determines the ordering of the facet field constraints

Değiştirgeler

facetSort

Use SolrQuery::FACET_SORT_INDEX for sorting by index order or SolrQuery::FACET_SORT_COUNT for sorting by count.

field_override

The name of the field.

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setFacetPrefix
SolrQuery::setGroup
SolrQuery


Enable/Disable result grouping (group parameter)

SolrQuery::setFacetSort
SolrQuery::setGroupCachePercent
SolrQuery
PHP Manual

SolrQuery::setGroup

(PECL solr >= 2.2.0)

SolrQuery::setGroup — Enable/Disable result grouping (group parameter)

Açıklama

public SolrQuery SolrQuery::setGroup ( bool $value )

Enable/Disable result grouping (group parameter)

Değiştirgeler

value

Dönen Değerler

Ayrıca Bakınız

  • SolrQuery::getGroup() - Returns true if grouping is enabled
  • SolrQuery::addGroupField() - Add a field to be used to group results.
  • SolrQuery::addGroupFunction() - Allows grouping results based on the unique values of a function query (group.func parameter).
  • SolrQuery::addGroupQuery() - Allows grouping of documents that match the given query.
  • SolrQuery::addGroupSortField() - Add a group sort field (group.sort parameter).
  • SolrQuery::setGroupFacet() - Sets group.facet parameter
  • SolrQuery::setGroupOffset() - Sets the group.offset parameter.
  • SolrQuery::setGroupLimit() - Specifies the number of results to return for each group. The server default value is 1.
  • SolrQuery::setGroupMain() - If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple.
  • SolrQuery::setGroupNGroups() - If true, Solr includes the number of groups that have matched the query in the results.
  • SolrQuery::setGroupTruncate() - If true, facet counts are based on the most relevant document of each group matching the query.
  • SolrQuery::setGroupFormat() - Sets the group format, result structure (group.format parameter).
  • SolrQuery::setGroupCachePercent() - Enables caching for result grouping
SolrQuery::setFacetSort
SolrQuery::setGroupCachePercent
SolrQuery


Enables caching for result grouping

SolrQuery::setGroup
SolrQuery::setGroupFacet
SolrQuery
PHP Manual

SolrQuery::setGroupCachePercent

(PECL solr >= 2.2.0)

SolrQuery::setGroupCachePercent — Enables caching for result grouping

Açıklama

public SolrQuery SolrQuery::setGroupCachePercent ( integer $percent )

Setting this parameter to a number greater than 0 enables caching for result grouping. Result Grouping executes two searches; this option caches the second search. The server default value is 0. Testing has shown that group caching only improves search time with Boolean, wildcard, and fuzzy queries. For simple queries like term or "match all" queries, group caching degrades performance. group.cache.percent parameter

Değiştirgeler

percent

Dönen Değerler

Hatalar/İstisnalar

Emits SolrIllegalArgumentException in case of an invalid parameter was passed.

Ayrıca Bakınız

  • SolrQuery::setGroup() - Enable/Disable result grouping (group parameter)
  • SolrQuery::addGroupField() - Add a field to be used to group results.
  • SolrQuery::addGroupFunction() - Allows grouping results based on the unique values of a function query (group.func parameter).
  • SolrQuery::addGroupQuery() - Allows grouping of documents that match the given query.
  • SolrQuery::addGroupSortField() - Add a group sort field (group.sort parameter).
  • SolrQuery::setGroupFacet() - Sets group.facet parameter
  • SolrQuery::setGroupOffset() - Sets the group.offset parameter.
  • SolrQuery::setGroupLimit() - Specifies the number of results to return for each group. The server default value is 1.
  • SolrQuery::setGroupMain() - If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple.
  • SolrQuery::setGroupNGroups() - If true, Solr includes the number of groups that have matched the query in the results.
  • SolrQuery::setGroupTruncate() - If true, facet counts are based on the most relevant document of each group matching the query.
  • SolrQuery::setGroupFormat() - Sets the group format, result structure (group.format parameter).
SolrQuery::setGroup
SolrQuery::setGroupFacet
SolrQuery


Sets group.facet parameter

SolrQuery::setGroupCachePercent
SolrQuery::setGroupFormat
SolrQuery
PHP Manual

SolrQuery::setGroupFacet

(PECL solr >= 2.2.0)

SolrQuery::setGroupFacet — Sets group.facet parameter

Açıklama

public SolrQuery SolrQuery::setGroupFacet ( bool $value )

Determines whether to compute grouped facets for the field facets specified in facet.field parameters. Grouped facets are computed based on the first specified group.

Değiştirgeler

value

Dönen Değerler

Ayrıca Bakınız

  • SolrQuery::setGroup() - Enable/Disable result grouping (group parameter)
  • SolrQuery::addGroupField() - Add a field to be used to group results.
  • SolrQuery::addGroupFunction() - Allows grouping results based on the unique values of a function query (group.func parameter).
  • SolrQuery::addGroupQuery() - Allows grouping of documents that match the given query.
  • SolrQuery::addGroupSortField() - Add a group sort field (group.sort parameter).
  • SolrQuery::setGroupOffset() - Sets the group.offset parameter.
  • SolrQuery::setGroupLimit() - Specifies the number of results to return for each group. The server default value is 1.
  • SolrQuery::setGroupMain() - If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple.
  • SolrQuery::setGroupNGroups() - If true, Solr includes the number of groups that have matched the query in the results.
  • SolrQuery::setGroupTruncate() - If true, facet counts are based on the most relevant document of each group matching the query.
  • SolrQuery::setGroupFormat() - Sets the group format, result structure (group.format parameter).
  • SolrQuery::setGroupCachePercent() - Enables caching for result grouping
SolrQuery::setGroupCachePercent
SolrQuery::setGroupFormat
SolrQuery


Sets the group format, result structure (group.format parameter).

SolrQuery::setGroupFacet
SolrQuery::setGroupLimit
SolrQuery
PHP Manual

SolrQuery::setGroupFormat

(PECL solr >= 2.2.0)

SolrQuery::setGroupFormat — Sets the group format, result structure (group.format parameter).

Açıklama

public SolrQuery SolrQuery::setGroupFormat ( string $value )

Sets the group.format parameter. If this parameter is set to simple, the grouped documents are presented in a single flat list, and the start and rows parameters affect the numbers of documents instead of groups. Accepts: grouped/simple

Değiştirgeler

value

Dönen Değerler

Ayrıca Bakınız

  • SolrQuery::setGroup() - Enable/Disable result grouping (group parameter)
  • SolrQuery::addGroupField() - Add a field to be used to group results.
  • SolrQuery::addGroupFunction() - Allows grouping results based on the unique values of a function query (group.func parameter).
  • SolrQuery::addGroupQuery() - Allows grouping of documents that match the given query.
  • SolrQuery::addGroupSortField() - Add a group sort field (group.sort parameter).
  • SolrQuery::setGroupFacet() - Sets group.facet parameter
  • SolrQuery::setGroupOffset() - Sets the group.offset parameter.
  • SolrQuery::setGroupLimit() - Specifies the number of results to return for each group. The server default value is 1.
  • SolrQuery::setGroupMain() - If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple.
  • SolrQuery::setGroupNGroups() - If true, Solr includes the number of groups that have matched the query in the results.
  • SolrQuery::setGroupTruncate() - If true, facet counts are based on the most relevant document of each group matching the query.
  • SolrQuery::setGroupCachePercent() - Enables caching for result grouping
SolrQuery::setGroupFacet
SolrQuery::setGroupLimit
SolrQuery


Specifies the number of results to return for each group. The server default value is 1.

SolrQuery::setGroupFormat
SolrQuery::setGroupMain
SolrQuery
PHP Manual

SolrQuery::setGroupLimit

(PECL solr >= 2.2.0)

SolrQuery::setGroupLimit — Specifies the number of results to return for each group. The server default value is 1.

Açıklama

public SolrQuery SolrQuery::setGroupLimit ( integer $value )

Specifies the number of results to return for each group. The server default value is 1.

Değiştirgeler

value

Dönen Değerler

Ayrıca Bakınız

  • SolrQuery::setGroup() - Enable/Disable result grouping (group parameter)
  • SolrQuery::addGroupField() - Add a field to be used to group results.
  • SolrQuery::addGroupFunction() - Allows grouping results based on the unique values of a function query (group.func parameter).
  • SolrQuery::addGroupQuery() - Allows grouping of documents that match the given query.
  • SolrQuery::addGroupSortField() - Add a group sort field (group.sort parameter).
  • SolrQuery::setGroupFacet() - Sets group.facet parameter
  • SolrQuery::setGroupOffset() - Sets the group.offset parameter.
  • SolrQuery::setGroupMain() - If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple.
  • SolrQuery::setGroupNGroups() - If true, Solr includes the number of groups that have matched the query in the results.
  • SolrQuery::setGroupTruncate() - If true, facet counts are based on the most relevant document of each group matching the query.
  • SolrQuery::setGroupFormat() - Sets the group format, result structure (group.format parameter).
  • SolrQuery::setGroupCachePercent() - Enables caching for result grouping
SolrQuery::setGroupFormat
SolrQuery::setGroupMain
SolrQuery


If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple.

SolrQuery::setGroupLimit
SolrQuery::setGroupNGroups
SolrQuery
PHP Manual

SolrQuery::setGroupMain

(PECL solr >= 2.2.0)

SolrQuery::setGroupMain — If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple.

Açıklama

public SolrQuery SolrQuery::setGroupMain ( string $value )

If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple.

Değiştirgeler

value

Dönen Değerler

Ayrıca Bakınız

Ayrıca Bakınız

  • SolrQuery::setGroup() - Enable/Disable result grouping (group parameter)
  • SolrQuery::addGroupField() - Add a field to be used to group results.
  • SolrQuery::addGroupFunction() - Allows grouping results based on the unique values of a function query (group.func parameter).
  • SolrQuery::addGroupQuery() - Allows grouping of documents that match the given query.
  • SolrQuery::addGroupSortField() - Add a group sort field (group.sort parameter).
  • SolrQuery::setGroupFacet() - Sets group.facet parameter
  • SolrQuery::setGroupOffset() - Sets the group.offset parameter.
  • SolrQuery::setGroupMain()
  • SolrQuery::setGroupNGroups() - If true, Solr includes the number of groups that have matched the query in the results.
  • SolrQuery::setGroupTruncate() - If true, facet counts are based on the most relevant document of each group matching the query.
  • SolrQuery::setGroupFormat() - Sets the group format, result structure (group.format parameter).
  • SolrQuery::setGroupCachePercent() - Enables caching for result grouping
SolrQuery::setGroupLimit
SolrQuery::setGroupNGroups
SolrQuery


If true, Solr includes the number of groups that have matched the query in the results.

SolrQuery::setGroupMain
SolrQuery::setGroupOffset
SolrQuery
PHP Manual

SolrQuery::setGroupNGroups

(PECL solr >= 2.2.0)

SolrQuery::setGroupNGroups — If true, Solr includes the number of groups that have matched the query in the results.

Açıklama

public SolrQuery SolrQuery::setGroupNGroups ( bool $value )

If true, Solr includes the number of groups that have matched the query in the results.

Değiştirgeler

value

Dönen Değerler

Ayrıca Bakınız

  • SolrQuery::setGroup() - Enable/Disable result grouping (group parameter)
  • SolrQuery::addGroupField() - Add a field to be used to group results.
  • SolrQuery::addGroupFunction() - Allows grouping results based on the unique values of a function query (group.func parameter).
  • SolrQuery::addGroupQuery() - Allows grouping of documents that match the given query.
  • SolrQuery::addGroupSortField() - Add a group sort field (group.sort parameter).
  • SolrQuery::setGroupFacet() - Sets group.facet parameter
  • SolrQuery::setGroupOffset() - Sets the group.offset parameter.
  • SolrQuery::setGroupLimit() - Specifies the number of results to return for each group. The server default value is 1.
  • SolrQuery::setGroupMain() - If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple.
  • SolrQuery::setGroupTruncate() - If true, facet counts are based on the most relevant document of each group matching the query.
  • SolrQuery::setGroupFormat() - Sets the group format, result structure (group.format parameter).
  • SolrQuery::setGroupCachePercent() - Enables caching for result grouping
SolrQuery::setGroupMain
SolrQuery::setGroupOffset
SolrQuery


Sets the group.offset parameter.

SolrQuery::setGroupNGroups
SolrQuery::setGroupTruncate
SolrQuery
PHP Manual

SolrQuery::setGroupOffset

(PECL solr >= 2.2.0)

SolrQuery::setGroupOffset — Sets the group.offset parameter.

Açıklama

public SolrQuery SolrQuery::setGroupOffset ( integer $value )

Sets the group.offset parameter.

Değiştirgeler

value

Dönen Değerler

Ayrıca Bakınız

  • SolrQuery::setGroup() - Enable/Disable result grouping (group parameter)
  • SolrQuery::addGroupField() - Add a field to be used to group results.
  • SolrQuery::addGroupFunction() - Allows grouping results based on the unique values of a function query (group.func parameter).
  • SolrQuery::addGroupQuery() - Allows grouping of documents that match the given query.
  • SolrQuery::addGroupSortField() - Add a group sort field (group.sort parameter).
  • SolrQuery::setGroupFacet() - Sets group.facet parameter
  • SolrQuery::setGroupLimit() - Specifies the number of results to return for each group. The server default value is 1.
  • SolrQuery::setGroupMain() - If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple.
  • SolrQuery::setGroupNGroups() - If true, Solr includes the number of groups that have matched the query in the results.
  • SolrQuery::setGroupTruncate() - If true, facet counts are based on the most relevant document of each group matching the query.
  • SolrQuery::setGroupFormat() - Sets the group format, result structure (group.format parameter).
  • SolrQuery::setGroupCachePercent() - Enables caching for result grouping
SolrQuery::setGroupNGroups
SolrQuery::setGroupTruncate
SolrQuery


If true, facet counts are based on the most relevant document of each group matching the query.

SolrQuery::setGroupOffset
SolrQuery::setHighlight
SolrQuery
PHP Manual

SolrQuery::setGroupTruncate

(PECL solr >= 2.2.0)

SolrQuery::setGroupTruncate — If true, facet counts are based on the most relevant document of each group matching the query.

Açıklama

public SolrQuery SolrQuery::setGroupTruncate ( bool $value )

If true, facet counts are based on the most relevant document of each group matching the query. The server default value is false. group.truncate parameter

Değiştirgeler

value

Dönen Değerler

Ayrıca Bakınız

  • SolrQuery::setGroup() - Enable/Disable result grouping (group parameter)
  • SolrQuery::addGroupField() - Add a field to be used to group results.
  • SolrQuery::addGroupFunction() - Allows grouping results based on the unique values of a function query (group.func parameter).
  • SolrQuery::addGroupQuery() - Allows grouping of documents that match the given query.
  • SolrQuery::addGroupSortField() - Add a group sort field (group.sort parameter).
  • SolrQuery::setGroupFacet() - Sets group.facet parameter
  • SolrQuery::setGroupOffset() - Sets the group.offset parameter.
  • SolrQuery::setGroupLimit() - Specifies the number of results to return for each group. The server default value is 1.
  • SolrQuery::setGroupMain() - If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple.
  • SolrQuery::setGroupNGroups() - If true, Solr includes the number of groups that have matched the query in the results.
  • SolrQuery::setGroupFormat() - Sets the group format, result structure (group.format parameter).
  • SolrQuery::setGroupCachePercent() - Enables caching for result grouping
SolrQuery::setGroupOffset
SolrQuery::setHighlight
SolrQuery


Enables or disables highlighting

SolrQuery::setGroupTruncate
SolrQuery::setHighlightAlternateField
SolrQuery
PHP Manual

SolrQuery::setHighlight

(PECL solr >= 0.9.2)

SolrQuery::setHighlight — Enables or disables highlighting

Açıklama

public SolrQuery SolrQuery::setHighlight ( bool $flag )

Setting it to TRUE enables highlighted snippets to be generated in the query response.

Setting it to FALSE disables highlighting

Değiştirgeler

flag

Enable or disable highlighting

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setGroupTruncate
SolrQuery::setHighlightAlternateField
SolrQuery


Specifies the backup field to use

SolrQuery::setHighlight
SolrQuery::setHighlightFormatter
SolrQuery
PHP Manual

SolrQuery::setHighlightAlternateField

(PECL solr >= 0.9.2)

SolrQuery::setHighlightAlternateField — Specifies the backup field to use

Açıklama

public SolrQuery SolrQuery::setHighlightAlternateField ( string $field [, string $field_override ] )

If a snippet cannot be generated because there were no matching terms, one can specify a field to use as the backup or default summary

Değiştirgeler

field

The name of the backup field

field_override

The name of the field we are overriding this setting for.

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setHighlight
SolrQuery::setHighlightFormatter
SolrQuery


Specify a formatter for the highlight output

SolrQuery::setHighlightAlternateField
SolrQuery::setHighlightFragmenter
SolrQuery
PHP Manual

SolrQuery::setHighlightFormatter

(PECL solr >= 0.9.2)

SolrQuery::setHighlightFormatter — Specify a formatter for the highlight output

Açıklama

public SolrQuery SolrQuery::setHighlightFormatter ( string $formatter [, string $field_override ] )

Specify a formatter for the highlight output.

Değiştirgeler

formatter

Currently the only legal value is "simple"

field_override

The name of the field.

SolrQuery::setHighlightAlternateField
SolrQuery::setHighlightFragmenter
SolrQuery


Sets a text snippet generator for highlighted text

SolrQuery::setHighlightFormatter
SolrQuery::setHighlightFragsize
SolrQuery
PHP Manual

SolrQuery::setHighlightFragmenter

(PECL solr >= 0.9.2)

SolrQuery::setHighlightFragmenter — Sets a text snippet generator for highlighted text

Açıklama

public SolrQuery SolrQuery::setHighlightFragmenter ( string $fragmenter [, string $field_override ] )

Specify a text snippet generator for highlighted text.

Değiştirgeler

fragmenter

The standard fragmenter is gap. Another option is regex, which tries to create fragments that resembles a certain regular expression

field_override

The name of the field.

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setHighlightFormatter
SolrQuery::setHighlightFragsize
SolrQuery


The size of fragments to consider for highlighting

SolrQuery::setHighlightFragmenter
SolrQuery::setHighlightHighlightMultiTerm
SolrQuery
PHP Manual

SolrQuery::setHighlightFragsize

(PECL solr >= 0.9.2)

SolrQuery::setHighlightFragsize — The size of fragments to consider for highlighting

Açıklama

public SolrQuery SolrQuery::setHighlightFragsize ( int $size [, string $field_override ] )

Sets the size, in characters, of fragments to consider for highlighting. "0" indicates that the whole field value should be used (no fragmenting).

Değiştirgeler

size

The size, in characters, of fragments to consider for highlighting

field_override

The name of the field.

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setHighlightFragmenter
SolrQuery::setHighlightHighlightMultiTerm
SolrQuery


Use SpanScorer to highlight phrase terms

SolrQuery::setHighlightFragsize
SolrQuery::setHighlightMaxAlternateFieldLength
SolrQuery
PHP Manual

SolrQuery::setHighlightHighlightMultiTerm

(PECL solr >= 0.9.2)

SolrQuery::setHighlightHighlightMultiTerm — Use SpanScorer to highlight phrase terms

Açıklama

public SolrQuery SolrQuery::setHighlightHighlightMultiTerm ( bool $flag )

Use SpanScorer to highlight phrase terms only when they appear within the query phrase in the document.

Değiştirgeler

flag

Whether or not to use SpanScorer to highlight phrase terms only when they appear within the query phrase in the document.

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setHighlightFragsize
SolrQuery::setHighlightMaxAlternateFieldLength
SolrQuery


Sets the maximum number of characters of the field to return

SolrQuery::setHighlightHighlightMultiTerm
SolrQuery::setHighlightMaxAnalyzedChars
SolrQuery
PHP Manual

SolrQuery::setHighlightMaxAlternateFieldLength

(PECL solr >= 0.9.2)

SolrQuery::setHighlightMaxAlternateFieldLength — Sets the maximum number of characters of the field to return

Açıklama

public SolrQuery SolrQuery::setHighlightMaxAlternateFieldLength ( int $fieldLength [, string $field_override ] )

If SolrQuery::setHighlightAlternateField() was passed the value TRUE, this parameter specifies the maximum number of characters of the field to return

Any value less than or equal to 0 means unlimited.

Değiştirgeler

fieldLength

The length of the field

field_override

The name of the field.

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setHighlightHighlightMultiTerm
SolrQuery::setHighlightMaxAnalyzedChars
SolrQuery


Specifies the number of characters into a document to look for suitable snippets

SolrQuery::setHighlightMaxAlternateFieldLength
SolrQuery::setHighlightMergeContiguous
SolrQuery
PHP Manual

SolrQuery::setHighlightMaxAnalyzedChars

(PECL solr >= 0.9.2)

SolrQuery::setHighlightMaxAnalyzedChars — Specifies the number of characters into a document to look for suitable snippets

Açıklama

public SolrQuery SolrQuery::setHighlightMaxAnalyzedChars ( int $value )

Specifies the number of characters into a document to look for suitable snippets

Değiştirgeler

value

The number of characters into a document to look for suitable snippets

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setHighlightMaxAlternateFieldLength
SolrQuery::setHighlightMergeContiguous
SolrQuery


Whether or not to collapse contiguous fragments into a single fragment

SolrQuery::setHighlightMaxAnalyzedChars
SolrQuery::setHighlightRegexMaxAnalyzedChars
SolrQuery
PHP Manual

SolrQuery::setHighlightMergeContiguous

(PECL solr >= 0.9.2)

SolrQuery::setHighlightMergeContiguous — Whether or not to collapse contiguous fragments into a single fragment

Açıklama

public SolrQuery SolrQuery::setHighlightMergeContiguous ( bool $flag [, string $field_override ] )

Whether or not to collapse contiguous fragments into a single fragment

Değiştirgeler

value

Whether or not to collapse contiguous fragments into a single fragment

field_override

The name of the field.

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setHighlightMaxAnalyzedChars
SolrQuery::setHighlightRegexMaxAnalyzedChars
SolrQuery


Specify the maximum number of characters to analyze

SolrQuery::setHighlightMergeContiguous
SolrQuery::setHighlightRegexPattern
SolrQuery
PHP Manual

SolrQuery::setHighlightRegexMaxAnalyzedChars

(PECL solr >= 0.9.2)

SolrQuery::setHighlightRegexMaxAnalyzedChars — Specify the maximum number of characters to analyze

Açıklama

public SolrQuery SolrQuery::setHighlightRegexMaxAnalyzedChars ( int $maxAnalyzedChars )

Specify the maximum number of characters to analyze from a field when using the regex fragmenter

Değiştirgeler

maxAnalyzedChars

The maximum number of characters to analyze from a field when using the regex fragmenter

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setHighlightMergeContiguous
SolrQuery::setHighlightRegexPattern
SolrQuery


Specify the regular expression for fragmenting

SolrQuery::setHighlightRegexMaxAnalyzedChars
SolrQuery::setHighlightRegexSlop
SolrQuery
PHP Manual

SolrQuery::setHighlightRegexPattern

(PECL solr >= 0.9.2)

SolrQuery::setHighlightRegexPattern — Specify the regular expression for fragmenting

Açıklama

public SolrQuery SolrQuery::setHighlightRegexPattern ( string $value )

Specifies the regular expression for fragmenting. This could be used to extract sentences

Değiştirgeler

value

The regular expression for fragmenting. This could be used to extract sentences

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setHighlightRegexMaxAnalyzedChars
SolrQuery::setHighlightRegexSlop
SolrQuery


Sets the factor by which the regex fragmenter can stray from the ideal fragment size

SolrQuery::setHighlightRegexPattern
SolrQuery::setHighlightRequireFieldMatch
SolrQuery
PHP Manual

SolrQuery::setHighlightRegexSlop

(PECL solr >= 0.9.2)

SolrQuery::setHighlightRegexSlop — Sets the factor by which the regex fragmenter can stray from the ideal fragment size

Açıklama

public SolrQuery SolrQuery::setHighlightRegexSlop ( float $factor )

The factor by which the regex fragmenter can stray from the ideal fragment size ( specfied by SolrQuery::setHighlightFragsize )to accommodate the regular expression

Değiştirgeler

factor

The factor by which the regex fragmenter can stray from the ideal fragment size

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setHighlightRegexPattern
SolrQuery::setHighlightRequireFieldMatch
SolrQuery


Require field matching during highlighting

SolrQuery::setHighlightRegexSlop
SolrQuery::setHighlightSimplePost
SolrQuery
PHP Manual

SolrQuery::setHighlightRequireFieldMatch

(PECL solr >= 0.9.2)

SolrQuery::setHighlightRequireFieldMatch — Require field matching during highlighting

Açıklama

public SolrQuery SolrQuery::setHighlightRequireFieldMatch ( bool $flag )

If TRUE, then a field will only be highlighted if the query matched in this particular field.

This will only work if SolrQuery::setHighlightUsePhraseHighlighter() was set to TRUE

Değiştirgeler

flag

TRUE or FALSE

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setHighlightRegexSlop
SolrQuery::setHighlightSimplePost
SolrQuery


Sets the text which appears after a highlighted term

SolrQuery::setHighlightRequireFieldMatch
SolrQuery::setHighlightSimplePre
SolrQuery
PHP Manual

SolrQuery::setHighlightSimplePost

(PECL solr >= 0.9.2)

SolrQuery::setHighlightSimplePost — Sets the text which appears after a highlighted term

Açıklama

public SolrQuery SolrQuery::setHighlightSimplePost ( string $simplePost [, string $field_override ] )

Sets the text which appears before a highlighted term

Değiştirgeler

simplePost

Sets the text which appears after a highlighted term

The default is </em>

field_override

The name of the field.

SolrQuery::setHighlightRequireFieldMatch
SolrQuery::setHighlightSimplePre
SolrQuery


Sets the text which appears before a highlighted term

SolrQuery::setHighlightSimplePost
SolrQuery::setHighlightSnippets
SolrQuery
PHP Manual

SolrQuery::setHighlightSimplePre

(PECL solr >= 0.9.2)

SolrQuery::setHighlightSimplePre — Sets the text which appears before a highlighted term

Açıklama

public SolrQuery SolrQuery::setHighlightSimplePre ( string $simplePre [, string $field_override ] )

Sets the text which appears before a highlighted term

The default is <em>

Değiştirgeler

simplePre

The text which appears before a highlighted term

field_override

The name of the field.

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setHighlightSimplePost
SolrQuery::setHighlightSnippets
SolrQuery


Sets the maximum number of highlighted snippets to generate per field

SolrQuery::setHighlightSimplePre
SolrQuery::setHighlightUsePhraseHighlighter
SolrQuery
PHP Manual

SolrQuery::setHighlightSnippets

(PECL solr >= 0.9.2)

SolrQuery::setHighlightSnippets — Sets the maximum number of highlighted snippets to generate per field

Açıklama

public SolrQuery SolrQuery::setHighlightSnippets ( int $value [, string $field_override ] )

Sets the maximum number of highlighted snippets to generate per field

Değiştirgeler

value

The maximum number of highlighted snippets to generate per field

field_override

The name of the field.

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setHighlightSimplePre
SolrQuery::setHighlightUsePhraseHighlighter
SolrQuery


Whether to highlight phrase terms only when they appear within the query phrase

SolrQuery::setHighlightSnippets
SolrQuery::setMlt
SolrQuery
PHP Manual

SolrQuery::setHighlightUsePhraseHighlighter

(PECL solr >= 0.9.2)

SolrQuery::setHighlightUsePhraseHighlighter — Whether to highlight phrase terms only when they appear within the query phrase

Açıklama

public SolrQuery SolrQuery::setHighlightUsePhraseHighlighter ( bool $flag )

Sets whether or not to use SpanScorer to highlight phrase terms only when they appear within the query phrase in the document

Değiştirgeler

value

Whether or not to use SpanScorer to highlight phrase terms only when they appear within the query phrase in the document

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setHighlightSnippets
SolrQuery::setMlt
SolrQuery


Enables or disables moreLikeThis

SolrQuery::setHighlightUsePhraseHighlighter
SolrQuery::setMltBoost
SolrQuery
PHP Manual

SolrQuery::setMlt

(PECL solr >= 0.9.2)

SolrQuery::setMlt — Enables or disables moreLikeThis

Açıklama

public SolrQuery SolrQuery::setMlt ( bool $flag )

Enables or disables moreLikeThis

Değiştirgeler

flag

TRUE enables it and FALSE turns it off.

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setHighlightUsePhraseHighlighter
SolrQuery::setMltBoost
SolrQuery


Set if the query will be boosted by the interesting term relevance

SolrQuery::setMlt
SolrQuery::setMltCount
SolrQuery
PHP Manual

SolrQuery::setMltBoost

(PECL solr >= 0.9.2)

SolrQuery::setMltBoost — Set if the query will be boosted by the interesting term relevance

Açıklama

public SolrQuery SolrQuery::setMltBoost ( bool $flag )

Set if the query will be boosted by the interesting term relevance

Değiştirgeler

value

Sets to TRUE or FALSE

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setMlt
SolrQuery::setMltCount
SolrQuery


Set the number of similar documents to return for each result

SolrQuery::setMltBoost
SolrQuery::setMltMaxNumQueryTerms
SolrQuery
PHP Manual

SolrQuery::setMltCount

(PECL solr >= 0.9.2)

SolrQuery::setMltCount — Set the number of similar documents to return for each result

Açıklama

public SolrQuery SolrQuery::setMltCount ( int $count )

Set the number of similar documents to return for each result

Değiştirgeler

count

The number of similar documents to return for each result

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setMltBoost
SolrQuery::setMltMaxNumQueryTerms
SolrQuery


Sets the maximum number of query terms included

SolrQuery::setMltCount
SolrQuery::setMltMaxNumTokens
SolrQuery
PHP Manual

SolrQuery::setMltMaxNumQueryTerms

(PECL solr >= 0.9.2)

SolrQuery::setMltMaxNumQueryTerms — Sets the maximum number of query terms included

Açıklama

public SolrQuery SolrQuery::setMltMaxNumQueryTerms ( int $value )

Sets the maximum number of query terms that will be included in any generated query.

Değiştirgeler

value

The maximum number of query terms that will be included in any generated query

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setMltCount
SolrQuery::setMltMaxNumTokens
SolrQuery


Specifies the maximum number of tokens to parse

SolrQuery::setMltMaxNumQueryTerms
SolrQuery::setMltMaxWordLength
SolrQuery
PHP Manual

SolrQuery::setMltMaxNumTokens

(PECL solr >= 0.9.2)

SolrQuery::setMltMaxNumTokens — Specifies the maximum number of tokens to parse

Açıklama

public SolrQuery SolrQuery::setMltMaxNumTokens ( int $value )

Specifies the maximum number of tokens to parse in each example doc field that is not stored with TermVector support.

Değiştirgeler

value

The maximum number of tokens to parse

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setMltMaxNumQueryTerms
SolrQuery::setMltMaxWordLength
SolrQuery


Sets the maximum word length

SolrQuery::setMltMaxNumTokens
SolrQuery::setMltMinDocFrequency
SolrQuery
PHP Manual

SolrQuery::setMltMaxWordLength

(PECL solr >= 0.9.2)

SolrQuery::setMltMaxWordLength — Sets the maximum word length

Açıklama

public SolrQuery SolrQuery::setMltMaxWordLength ( int $maxWordLength )

Sets the maximum word length above which words will be ignored.

Değiştirgeler

maxWordLength

The maximum word length above which words will be ignored

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setMltMaxNumTokens
SolrQuery::setMltMinDocFrequency
SolrQuery


Sets the mltMinDoc frequency

SolrQuery::setMltMaxWordLength
SolrQuery::setMltMinTermFrequency
SolrQuery
PHP Manual

SolrQuery::setMltMinDocFrequency

(PECL solr >= 0.9.2)

SolrQuery::setMltMinDocFrequency — Sets the mltMinDoc frequency

Açıklama

public SolrQuery SolrQuery::setMltMinDocFrequency ( int $minDocFrequency )

The frequency at which words will be ignored which do not occur in at least this many docs.

Değiştirgeler

minDocFrequency

Sets the frequency at which words will be ignored which do not occur in at least this many docs.

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setMltMaxWordLength
SolrQuery::setMltMinTermFrequency
SolrQuery


Sets the frequency below which terms will be ignored in the source docs

SolrQuery::setMltMinDocFrequency
SolrQuery::setMltMinWordLength
SolrQuery
PHP Manual

SolrQuery::setMltMinTermFrequency

(PECL solr >= 0.9.2)

SolrQuery::setMltMinTermFrequency — Sets the frequency below which terms will be ignored in the source docs

Açıklama

public SolrQuery SolrQuery::setMltMinTermFrequency ( int $minTermFrequency )

Sets the frequency below which terms will be ignored in the source docs

Değiştirgeler

minTermFrequency

The frequency below which terms will be ignored in the source docs

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setMltMinDocFrequency
SolrQuery::setMltMinWordLength
SolrQuery


Sets the minimum word length

SolrQuery::setMltMinTermFrequency
SolrQuery::setOmitHeader
SolrQuery
PHP Manual

SolrQuery::setMltMinWordLength

(PECL solr >= 0.9.2)

SolrQuery::setMltMinWordLength — Sets the minimum word length

Açıklama

public SolrQuery SolrQuery::setMltMinWordLength ( int $minWordLength )

Sets the minimum word length below which words will be ignored.

Değiştirgeler

minWordLength

The minimum word length below which words will be ignored

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setMltMinTermFrequency
SolrQuery::setOmitHeader
SolrQuery


Exclude the header from the returned results

SolrQuery::setMltMinWordLength
SolrQuery::setQuery
SolrQuery
PHP Manual

SolrQuery::setOmitHeader

(PECL solr >= 0.9.2)

SolrQuery::setOmitHeader — Exclude the header from the returned results

Açıklama

public SolrQuery SolrQuery::setOmitHeader ( bool $flag )

Exclude the header from the returned results.

Değiştirgeler

flag

TRUE excludes the header from the result.

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setMltMinWordLength
SolrQuery::setQuery
SolrQuery


Sets the search query

SolrQuery::setOmitHeader
SolrQuery::setRows
SolrQuery
PHP Manual

SolrQuery::setQuery

(PECL solr >= 0.9.2)

SolrQuery::setQuery — Sets the search query

Açıklama

public SolrQuery SolrQuery::setQuery ( string $query )

Sets the search query.

Değiştirgeler

query

The search query

Dönen Değerler

Returns the current SolrQuery object

SolrQuery::setOmitHeader
SolrQuery::setRows
SolrQuery


Specifies the maximum number of rows to return in the result

SolrQuery::setQuery
SolrQuery::setShowDebugInfo
SolrQuery
PHP Manual

SolrQuery::setRows

(PECL solr >= 0.9.2)

SolrQuery::setRows — Specifies the maximum number of rows to return in the result

Açıklama

public SolrQuery SolrQuery::setRows ( int $rows )

Specifies the maximum number of rows to return in the result

Değiştirgeler

rows

The maximum number of rows to return

Dönen Değerler

Returns the current SolrQuery object.

SolrQuery::setQuery
SolrQuery::setShowDebugInfo
SolrQuery


Flag to show debug information

SolrQuery::setRows
SolrQuery::setStart
SolrQuery
PHP Manual

SolrQuery::setShowDebugInfo

(PECL solr >= 0.9.2)

SolrQuery::setShowDebugInfo — Flag to show debug information

Açıklama

public SolrQuery SolrQuery::setShowDebugInfo ( bool $flag )

Whether to show debug info

Değiştirgeler

flag

Whether to show debug info. TRUE or FALSE

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setRows
SolrQuery::setStart
SolrQuery


Specifies the number of rows to skip

SolrQuery::setShowDebugInfo
SolrQuery::setStats
SolrQuery
PHP Manual

SolrQuery::setStart

(PECL solr >= 0.9.2)

SolrQuery::setStart — Specifies the number of rows to skip

Açıklama

public SolrQuery SolrQuery::setStart ( int $start )

Specifies the number of rows to skip. Useful in pagination of results.

Değiştirgeler

start

The number of rows to skip.

Dönen Değerler

Returns the current SolrQuery object.

SolrQuery::setShowDebugInfo
SolrQuery::setStats
SolrQuery


Enables or disables the Stats component

SolrQuery::setStart
SolrQuery::setTerms
SolrQuery
PHP Manual

SolrQuery::setStats

(PECL solr >= 0.9.2)

SolrQuery::setStats — Enables or disables the Stats component

Açıklama

public SolrQuery SolrQuery::setStats ( bool $flag )

Enables or disables the Stats component.

Değiştirgeler

flag

TRUE turns on the stats component and FALSE disables it.

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setStart
SolrQuery::setTerms
SolrQuery


Enables or disables the TermsComponent

SolrQuery::setStats
SolrQuery::setTermsField
SolrQuery
PHP Manual

SolrQuery::setTerms

(PECL solr >= 0.9.2)

SolrQuery::setTerms — Enables or disables the TermsComponent

Açıklama

public SolrQuery SolrQuery::setTerms ( bool $flag )

Enables or disables the TermsComponent

Değiştirgeler

flag

TRUE enables it. FALSE turns it off

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setStats
SolrQuery::setTermsField
SolrQuery


Sets the name of the field to get the Terms from

SolrQuery::setTerms
SolrQuery::setTermsIncludeLowerBound
SolrQuery
PHP Manual

SolrQuery::setTermsField

(PECL solr >= 0.9.2)

SolrQuery::setTermsField — Sets the name of the field to get the Terms from

Açıklama

public SolrQuery SolrQuery::setTermsField ( string $fieldname )

Sets the name of the field to get the terms from

Değiştirgeler

fieldname

The field name

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setTerms
SolrQuery::setTermsIncludeLowerBound
SolrQuery


Include the lower bound term in the result set

SolrQuery::setTermsField
SolrQuery::setTermsIncludeUpperBound
SolrQuery
PHP Manual

SolrQuery::setTermsIncludeLowerBound

(PECL solr >= 0.9.2)

SolrQuery::setTermsIncludeLowerBound — Include the lower bound term in the result set

Açıklama

public SolrQuery SolrQuery::setTermsIncludeLowerBound ( bool $flag )

Include the lower bound term in the result set.

Değiştirgeler

flag

Include the lower bound term in the result set

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setTermsField
SolrQuery::setTermsIncludeUpperBound
SolrQuery


Include the upper bound term in the result set

SolrQuery::setTermsIncludeLowerBound
SolrQuery::setTermsLimit
SolrQuery
PHP Manual

SolrQuery::setTermsIncludeUpperBound

(PECL solr >= 0.9.2)

SolrQuery::setTermsIncludeUpperBound — Include the upper bound term in the result set

Açıklama

public SolrQuery SolrQuery::setTermsIncludeUpperBound ( bool $flag )

Include the upper bound term in the result set.

Değiştirgeler

flag

TRUE or FALSE

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setTermsIncludeLowerBound
SolrQuery::setTermsLimit
SolrQuery


Sets the maximum number of terms to return

SolrQuery::setTermsIncludeUpperBound
SolrQuery::setTermsLowerBound
SolrQuery
PHP Manual

SolrQuery::setTermsLimit

(PECL solr >= 0.9.2)

SolrQuery::setTermsLimit — Sets the maximum number of terms to return

Açıklama

public SolrQuery SolrQuery::setTermsLimit ( int $limit )

Sets the maximum number of terms to return

Değiştirgeler

limit

The maximum number of terms to return. All the terms will be returned if the limit is negative.

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setTermsIncludeUpperBound
SolrQuery::setTermsLowerBound
SolrQuery


Specifies the Term to start from

SolrQuery::setTermsLimit
SolrQuery::setTermsMaxCount
SolrQuery
PHP Manual

SolrQuery::setTermsLowerBound

(PECL solr >= 0.9.2)

SolrQuery::setTermsLowerBound — Specifies the Term to start from

Açıklama

public SolrQuery SolrQuery::setTermsLowerBound ( string $lowerBound )

Specifies the Term to start from

Değiştirgeler

lowerBound

The lower bound Term

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setTermsLimit
SolrQuery::setTermsMaxCount
SolrQuery


Sets the maximum document frequency

SolrQuery::setTermsLowerBound
SolrQuery::setTermsMinCount
SolrQuery
PHP Manual

SolrQuery::setTermsMaxCount

(PECL solr >= 0.9.2)

SolrQuery::setTermsMaxCount — Sets the maximum document frequency

Açıklama

public SolrQuery SolrQuery::setTermsMaxCount ( int $frequency )

Sets the maximum document frequency.

Değiştirgeler

frequency

The maximum document frequency.

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setTermsLowerBound
SolrQuery::setTermsMinCount
SolrQuery


Sets the minimum document frequency

SolrQuery::setTermsMaxCount
SolrQuery::setTermsPrefix
SolrQuery
PHP Manual

SolrQuery::setTermsMinCount

(PECL solr >= 0.9.2)

SolrQuery::setTermsMinCount — Sets the minimum document frequency

Açıklama

public SolrQuery SolrQuery::setTermsMinCount ( int $frequency )

Sets the minimum doc frequency to return in order to be included

Değiştirgeler

frequency

The minimum frequency

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setTermsMaxCount
SolrQuery::setTermsPrefix
SolrQuery


Restrict matches to terms that start with the prefix

SolrQuery::setTermsMinCount
SolrQuery::setTermsReturnRaw
SolrQuery
PHP Manual

SolrQuery::setTermsPrefix

(PECL solr >= 0.9.2)

SolrQuery::setTermsPrefix — Restrict matches to terms that start with the prefix

Açıklama

public SolrQuery SolrQuery::setTermsPrefix ( string $prefix )

Restrict matches to terms that start with the prefix

Değiştirgeler

prefix

Restrict matches to terms that start with the prefix

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setTermsMinCount
SolrQuery::setTermsReturnRaw
SolrQuery


Return the raw characters of the indexed term

SolrQuery::setTermsPrefix
SolrQuery::setTermsSort
SolrQuery
PHP Manual

SolrQuery::setTermsReturnRaw

(PECL solr >= 0.9.2)

SolrQuery::setTermsReturnRaw — Return the raw characters of the indexed term

Açıklama

public SolrQuery SolrQuery::setTermsReturnRaw ( bool $flag )

If true, return the raw characters of the indexed term, regardless of if it is human readable

Değiştirgeler

value

TRUE or FALSE

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setTermsPrefix
SolrQuery::setTermsSort
SolrQuery


Specifies how to sort the returned terms

SolrQuery::setTermsReturnRaw
SolrQuery::setTermsUpperBound
SolrQuery
PHP Manual

SolrQuery::setTermsSort

(PECL solr >= 0.9.2)

SolrQuery::setTermsSort — Specifies how to sort the returned terms

Açıklama

public SolrQuery SolrQuery::setTermsSort ( int $sortType )

If SolrQuery::TERMS_SORT_COUNT, sorts the terms by the term frequency (highest count first). If SolrQuery::TERMS_SORT_INDEX, returns the terms in index order

Değiştirgeler

sortType

SolrQuery::TERMS_SORT_INDEX or SolrQuery::TERMS_SORT_COUNT

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setTermsReturnRaw
SolrQuery::setTermsUpperBound
SolrQuery


Sets the term to stop at

SolrQuery::setTermsSort
SolrQuery::setTimeAllowed
SolrQuery
PHP Manual

SolrQuery::setTermsUpperBound

(PECL solr >= 0.9.2)

SolrQuery::setTermsUpperBound — Sets the term to stop at

Açıklama

public SolrQuery SolrQuery::setTermsUpperBound ( string $upperBound )

Sets the term to stop at

Değiştirgeler

upperBound

The term to stop at

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setTermsSort
SolrQuery::setTimeAllowed
SolrQuery


The time allowed for search to finish

SolrQuery::setTermsUpperBound
SolrDisMaxQuery
SolrQuery
PHP Manual

SolrQuery::setTimeAllowed

(PECL solr >= 0.9.2)

SolrQuery::setTimeAllowed — The time allowed for search to finish

Açıklama

public SolrQuery SolrQuery::setTimeAllowed ( int $timeAllowed )

The time allowed for a search to finish. This value only applies to the search and not to requests in general. Time is in milliseconds. Values less than or equal to zero implies no time restriction. Partial results may be returned, if there are any.

Değiştirgeler

timeAllowed

The time allowed for a search to finish.

Dönen Değerler

Returns the current SolrQuery object, if the return value is used.

SolrQuery::setTermsUpperBound
SolrDisMaxQuery
SolrQuery


The SolrDisMaxQuery class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

Sınıf Sözdizimi

SolrDisMaxQuery extends SolrQuery implements Serializable {
/* Miras alınan özellikler */
const integer SolrQuery::ORDER_ASC = 0 ;
const integer SolrQuery::ORDER_DESC = 1 ;
const integer SolrQuery::FACET_SORT_INDEX = 0 ;
const integer SolrQuery::FACET_SORT_COUNT = 1 ;
const integer SolrQuery::TERMS_SORT_INDEX = 0 ;
const integer SolrQuery::TERMS_SORT_COUNT = 1 ;
/* Yöntemler */
public SolrDisMaxQuery addBigramPhraseField ( string $field , string $boost [, string $slop ] )
public SolrDisMaxQuery addBoostQuery ( string $field , string $value [, string $boost ] )
public SolrDisMaxQuery addPhraseField ( string $field , string $boost [, string $slop ] )
public SolrDisMaxQuery addQueryField ( string $field [, string $boost ] )
public SolrDisMaxQuery addTrigramPhraseField ( string $field , string $boost [, string $slop ] )
public SolrDisMaxQuery addUserField ( string $field )
public __construct ([ string $q ] )
public SolrDisMaxQuery removeBigramPhraseField ( string $field )
public SolrDisMaxQuery removeBoostQuery ( string $field )
public SolrDisMaxQuery removePhraseField ( string $field )
public SolrDisMaxQuery removeQueryField ( string $field )
public SolrDisMaxQuery removeTrigramPhraseField ( string $field )
public SolrDisMaxQuery removeUserField ( string $field )
public SolrDisMaxQuery setBigramPhraseFields ( string $fields )
public SolrDisMaxQuery setBigramPhraseSlop ( string $slop )
public SolrDisMaxQuery setBoostFunction ( string $function )
public SolrDisMaxQuery setBoostQuery ( string $q )
public SolrDisMaxQuery setMinimumMatch ( string $value )
public SolrDisMaxQuery setPhraseFields ( string $fields )
public SolrDisMaxQuery setPhraseSlop ( string $slop )
public SolrDisMaxQuery setQueryAlt ( string $q )
public SolrDisMaxQuery setQueryPhraseSlop ( string $slop )
public SolrDisMaxQuery setTieBreaker ( string $tieBreaker )
public SolrDisMaxQuery setTrigramPhraseFields ( string $fields )
public SolrDisMaxQuery setTrigramPhraseSlop ( string $slop )
public SolrDisMaxQuery setUserFields ( string $fields )
public SolrDisMaxQuery useDisMaxQueryParser ( void )
public SolrDisMaxQuery useEDisMaxQueryParser ( void )
/* Miras alınan yöntemler */
public SolrQuery SolrQuery::addExpandFilterQuery ( string $fq )
public SolrQuery SolrQuery::addExpandSortField ( string $field [, string $order ] )
public SolrQuery SolrQuery::addFacetDateField ( string $dateField )
public SolrQuery SolrQuery::addFacetDateOther ( string $value [, string $field_override ] )
public SolrQuery SolrQuery::addFacetField ( string $field )
public SolrQuery SolrQuery::addFacetQuery ( string $facetQuery )
public SolrQuery SolrQuery::addField ( string $field )
public SolrQuery SolrQuery::addFilterQuery ( string $fq )
public SolrQuery SolrQuery::addGroupField ( string $value )
public SolrQuery SolrQuery::addGroupFunction ( string $value )
public SolrQuery SolrQuery::addGroupQuery ( string $value )
public SolrQuery SolrQuery::addGroupSortField ( string $field [, integer $order ] )
public SolrQuery SolrQuery::addHighlightField ( string $field )
public SolrQuery SolrQuery::addMltField ( string $field )
public SolrQuery SolrQuery::addMltQueryField ( string $field , float $boost )
public SolrQuery SolrQuery::addSortField ( string $field [, int $order = SolrQuery::ORDER_DESC ] )
public SolrQuery SolrQuery::addStatsFacet ( string $field )
public SolrQuery SolrQuery::addStatsField ( string $field )
public SolrQuery SolrQuery::collapse ( SolrCollapseFunction $collapseFunction )
public SolrQuery::__construct ([ string $q ] )
public void SolrQuery::__destruct ( void )
public bool SolrQuery::getExpand ( void )
public array SolrQuery::getExpandFilterQueries ( void )
public array SolrQuery::getExpandQuery ( void )
public integer SolrQuery::getExpandRows ( void )
public array SolrQuery::getExpandSortFields ( void )
public bool SolrQuery::getFacet ( void )
public string SolrQuery::getFacetDateEnd ([ string $field_override ] )
public array SolrQuery::getFacetDateFields ( void )
public string SolrQuery::getFacetDateGap ([ string $field_override ] )
public string SolrQuery::getFacetDateHardEnd ([ string $field_override ] )
public array SolrQuery::getFacetDateOther ([ string $field_override ] )
public string SolrQuery::getFacetDateStart ([ string $field_override ] )
public array SolrQuery::getFacetFields ( void )
public int SolrQuery::getFacetLimit ([ string $field_override ] )
public string SolrQuery::getFacetMethod ([ string $field_override ] )
public int SolrQuery::getFacetMinCount ([ string $field_override ] )
public bool SolrQuery::getFacetMissing ([ string $field_override ] )
public int SolrQuery::getFacetOffset ([ string $field_override ] )
public string SolrQuery::getFacetPrefix ([ string $field_override ] )
public array SolrQuery::getFacetQueries ( void )
public int SolrQuery::getFacetSort ([ string $field_override ] )
public array SolrQuery::getFields ( void )
public array SolrQuery::getFilterQueries ( void )
public bool SolrQuery::getGroup ( void )
public integer SolrQuery::getGroupCachePercent ( void )
public bool SolrQuery::getGroupFacet ( void )
public array SolrQuery::getGroupFields ( void )
public string SolrQuery::getGroupFormat ( void )
public array SolrQuery::getGroupFunctions ( void )
public integer SolrQuery::getGroupLimit ( void )
public bool SolrQuery::getGroupMain ( void )
public bool SolrQuery::getGroupNGroups ( void )
public integer SolrQuery::getGroupOffset ( void )
public array SolrQuery::getGroupQueries ( void )
public array SolrQuery::getGroupSortFields ( void )
public bool SolrQuery::getGroupTruncate ( void )
public bool SolrQuery::getHighlight ( void )
public string SolrQuery::getHighlightAlternateField ([ string $field_override ] )
public array SolrQuery::getHighlightFields ( void )
public string SolrQuery::getHighlightFormatter ([ string $field_override ] )
public string SolrQuery::getHighlightFragmenter ([ string $field_override ] )
public int SolrQuery::getHighlightFragsize ([ string $field_override ] )
public bool SolrQuery::getHighlightHighlightMultiTerm ( void )
public int SolrQuery::getHighlightMaxAlternateFieldLength ([ string $field_override ] )
public int SolrQuery::getHighlightMaxAnalyzedChars ( void )
public bool SolrQuery::getHighlightMergeContiguous ([ string $field_override ] )
public int SolrQuery::getHighlightRegexMaxAnalyzedChars ( void )
public string SolrQuery::getHighlightRegexPattern ( void )
public float SolrQuery::getHighlightRegexSlop ( void )
public bool SolrQuery::getHighlightRequireFieldMatch ( void )
public string SolrQuery::getHighlightSimplePost ([ string $field_override ] )
public string SolrQuery::getHighlightSimplePre ([ string $field_override ] )
public int SolrQuery::getHighlightSnippets ([ string $field_override ] )
public bool SolrQuery::getHighlightUsePhraseHighlighter ( void )
public bool SolrQuery::getMlt ( void )
public bool SolrQuery::getMltBoost ( void )
public int SolrQuery::getMltCount ( void )
public array SolrQuery::getMltFields ( void )
public int SolrQuery::getMltMaxNumQueryTerms ( void )
public int SolrQuery::getMltMaxNumTokens ( void )
public int SolrQuery::getMltMaxWordLength ( void )
public int SolrQuery::getMltMinDocFrequency ( void )
public int SolrQuery::getMltMinTermFrequency ( void )
public int SolrQuery::getMltMinWordLength ( void )
public array SolrQuery::getMltQueryFields ( void )
public string SolrQuery::getQuery ( void )
public int SolrQuery::getRows ( void )
public array SolrQuery::getSortFields ( void )
public int SolrQuery::getStart ( void )
public bool SolrQuery::getStats ( void )
public array SolrQuery::getStatsFacets ( void )
public array SolrQuery::getStatsFields ( void )
public bool SolrQuery::getTerms ( void )
public string SolrQuery::getTermsField ( void )
public bool SolrQuery::getTermsIncludeLowerBound ( void )
public bool SolrQuery::getTermsIncludeUpperBound ( void )
public int SolrQuery::getTermsLimit ( void )
public string SolrQuery::getTermsLowerBound ( void )
public int SolrQuery::getTermsMaxCount ( void )
public int SolrQuery::getTermsMinCount ( void )
public string SolrQuery::getTermsPrefix ( void )
public bool SolrQuery::getTermsReturnRaw ( void )
public int SolrQuery::getTermsSort ( void )
public string SolrQuery::getTermsUpperBound ( void )
public int SolrQuery::getTimeAllowed ( void )
public SolrQuery SolrQuery::removeExpandFilterQuery ( string $fq )
public SolrQuery SolrQuery::removeExpandSortField ( string $field )
public SolrQuery SolrQuery::removeFacetDateField ( string $field )
public SolrQuery SolrQuery::removeFacetDateOther ( string $value [, string $field_override ] )
public SolrQuery SolrQuery::removeFacetField ( string $field )
public SolrQuery SolrQuery::removeFacetQuery ( string $value )
public SolrQuery SolrQuery::removeField ( string $field )
public SolrQuery SolrQuery::removeFilterQuery ( string $fq )
public SolrQuery SolrQuery::removeHighlightField ( string $field )
public SolrQuery SolrQuery::removeMltField ( string $field )
public SolrQuery SolrQuery::removeMltQueryField ( string $queryField )
public SolrQuery SolrQuery::removeSortField ( string $field )
public SolrQuery SolrQuery::removeStatsFacet ( string $value )
public SolrQuery SolrQuery::removeStatsField ( string $field )
public SolrQuery SolrQuery::setEchoHandler ( bool $flag )
public SolrQuery SolrQuery::setEchoParams ( string $type )
public SolrQuery SolrQuery::setExpand ( bool $value )
public SolrQuery SolrQuery::setExpandQuery ( string $q )
public SolrQuery SolrQuery::setExpandRows ( integer $value )
public SolrQuery SolrQuery::setExplainOther ( string $query )
public SolrQuery SolrQuery::setFacet ( bool $flag )
public SolrQuery SolrQuery::setFacetDateEnd ( string $value [, string $field_override ] )
public SolrQuery SolrQuery::setFacetDateGap ( string $value [, string $field_override ] )
public SolrQuery SolrQuery::setFacetDateHardEnd ( bool $value [, string $field_override ] )
public SolrQuery SolrQuery::setFacetDateStart ( string $value [, string $field_override ] )
public SolrQuery SolrQuery::setFacetEnumCacheMinDefaultFrequency ( int $frequency [, string $field_override ] )
public SolrQuery SolrQuery::setFacetLimit ( int $limit [, string $field_override ] )
public SolrQuery SolrQuery::setFacetMethod ( string $method [, string $field_override ] )
public SolrQuery SolrQuery::setFacetMinCount ( int $mincount [, string $field_override ] )
public SolrQuery SolrQuery::setFacetMissing ( bool $flag [, string $field_override ] )
public SolrQuery SolrQuery::setFacetOffset ( int $offset [, string $field_override ] )
public SolrQuery SolrQuery::setFacetPrefix ( string $prefix [, string $field_override ] )
public SolrQuery SolrQuery::setFacetSort ( int $facetSort [, string $field_override ] )
public SolrQuery SolrQuery::setGroup ( bool $value )
public SolrQuery SolrQuery::setGroupCachePercent ( integer $percent )
public SolrQuery SolrQuery::setGroupFacet ( bool $value )
public SolrQuery SolrQuery::setGroupFormat ( string $value )
public SolrQuery SolrQuery::setGroupLimit ( integer $value )
public SolrQuery SolrQuery::setGroupMain ( string $value )
public SolrQuery SolrQuery::setGroupNGroups ( bool $value )
public SolrQuery SolrQuery::setGroupOffset ( integer $value )
public SolrQuery SolrQuery::setGroupTruncate ( bool $value )
public SolrQuery SolrQuery::setHighlight ( bool $flag )
public SolrQuery SolrQuery::setHighlightAlternateField ( string $field [, string $field_override ] )
public SolrQuery SolrQuery::setHighlightFormatter ( string $formatter [, string $field_override ] )
public SolrQuery SolrQuery::setHighlightFragmenter ( string $fragmenter [, string $field_override ] )
public SolrQuery SolrQuery::setHighlightFragsize ( int $size [, string $field_override ] )
public SolrQuery SolrQuery::setHighlightHighlightMultiTerm ( bool $flag )
public SolrQuery SolrQuery::setHighlightMaxAlternateFieldLength ( int $fieldLength [, string $field_override ] )
public SolrQuery SolrQuery::setHighlightMaxAnalyzedChars ( int $value )
public SolrQuery SolrQuery::setHighlightMergeContiguous ( bool $flag [, string $field_override ] )
public SolrQuery SolrQuery::setHighlightRegexMaxAnalyzedChars ( int $maxAnalyzedChars )
public SolrQuery SolrQuery::setHighlightRegexPattern ( string $value )
public SolrQuery SolrQuery::setHighlightRegexSlop ( float $factor )
public SolrQuery SolrQuery::setHighlightRequireFieldMatch ( bool $flag )
public SolrQuery SolrQuery::setHighlightSimplePost ( string $simplePost [, string $field_override ] )
public SolrQuery SolrQuery::setHighlightSimplePre ( string $simplePre [, string $field_override ] )
public SolrQuery SolrQuery::setHighlightSnippets ( int $value [, string $field_override ] )
public SolrQuery SolrQuery::setHighlightUsePhraseHighlighter ( bool $flag )
public SolrQuery SolrQuery::setMlt ( bool $flag )
public SolrQuery SolrQuery::setMltBoost ( bool $flag )
public SolrQuery SolrQuery::setMltCount ( int $count )
public SolrQuery SolrQuery::setMltMaxNumQueryTerms ( int $value )
public SolrQuery SolrQuery::setMltMaxNumTokens ( int $value )
public SolrQuery SolrQuery::setMltMaxWordLength ( int $maxWordLength )
public SolrQuery SolrQuery::setMltMinDocFrequency ( int $minDocFrequency )
public SolrQuery SolrQuery::setMltMinTermFrequency ( int $minTermFrequency )
public SolrQuery SolrQuery::setMltMinWordLength ( int $minWordLength )
public SolrQuery SolrQuery::setOmitHeader ( bool $flag )
public SolrQuery SolrQuery::setQuery ( string $query )
public SolrQuery SolrQuery::setRows ( int $rows )
public SolrQuery SolrQuery::setShowDebugInfo ( bool $flag )
public SolrQuery SolrQuery::setStart ( int $start )
public SolrQuery SolrQuery::setStats ( bool $flag )
public SolrQuery SolrQuery::setTerms ( bool $flag )
public SolrQuery SolrQuery::setTermsField ( string $fieldname )
public SolrQuery SolrQuery::setTermsIncludeLowerBound ( bool $flag )
public SolrQuery SolrQuery::setTermsIncludeUpperBound ( bool $flag )
public SolrQuery SolrQuery::setTermsLimit ( int $limit )
public SolrQuery SolrQuery::setTermsLowerBound ( string $lowerBound )
public SolrQuery SolrQuery::setTermsMaxCount ( int $frequency )
public SolrQuery SolrQuery::setTermsMinCount ( int $frequency )
public SolrQuery SolrQuery::setTermsPrefix ( string $prefix )
public SolrQuery SolrQuery::setTermsReturnRaw ( bool $flag )
public SolrQuery SolrQuery::setTermsSort ( int $sortType )
public SolrQuery SolrQuery::setTermsUpperBound ( string $upperBound )
public SolrQuery SolrQuery::setTimeAllowed ( int $timeAllowed )
}

Öntanımlı Sabitler

SolrDisMaxQuery::ORDER_ASC

Used to specify that the sorting should be in acending order (Duplicated for easier migration)

SolrDisMaxQuery::ORDER_DESC

Used to specify that the sorting should be in descending order (Duplicated for easier migration)

SolrDisMaxQuery::FACET_SORT_INDEX

Used to specify that the facet should sort by index (Duplicated for easier migration)

SolrDisMaxQuery::FACET_SORT_COUNT

Used to specify that the facet should sort by count (Duplicated for easier migration)

SolrDisMaxQuery::TERMS_SORT_INDEX

Used in the TermsComponent (Duplicated for easier migration)

SolrDisMaxQuery::TERMS_SORT_COUNT

Used in the TermsComponent (Duplicated for easier migration)

İçindekiler

  • SolrDisMaxQuery::addBigramPhraseField — Adds a Phrase Bigram Field (pf2 parameter)
  • SolrDisMaxQuery::addBoostQuery — Adds a boost query field with value and optional boost (bq parameter)
  • SolrDisMaxQuery::addPhraseField — Adds a Phrase Field (pf parameter)
  • SolrDisMaxQuery::addQueryField — Add a query field with optional boost (qf parameter)
  • SolrDisMaxQuery::addTrigramPhraseField — Adds a Trigram Phrase Field (pf3 parameter)
  • SolrDisMaxQuery::addUserField — Adds a field to User Fields Parameter (uf)
  • SolrDisMaxQuery::__construct — Class Constructor
  • SolrDisMaxQuery::removeBigramPhraseField — Removes phrase bigram field (pf2 parameter)
  • SolrDisMaxQuery::removeBoostQuery — Removes a boost query partial by field name (bq)
  • SolrDisMaxQuery::removePhraseField — Removes a Phrase Field (pf parameter)
  • SolrDisMaxQuery::removeQueryField — Removes a Query Field (qf parameter)
  • SolrDisMaxQuery::removeTrigramPhraseField — Removes a Trigram Phrase Field (pf3 parameter)
  • SolrDisMaxQuery::removeUserField — Removes a field from The User Fields Parameter (uf)
  • SolrDisMaxQuery::setBigramPhraseFields — Sets Bigram Phrase Fields and their boosts (and slops) using pf2 parameter
  • SolrDisMaxQuery::setBigramPhraseSlop — Sets Bigram Phrase Slop (ps2 parameter)
  • SolrDisMaxQuery::setBoostFunction — Sets a Boost Function (bf parameter).
  • SolrDisMaxQuery::setBoostQuery — Directly Sets Boost Query Parameter (bq)
  • SolrDisMaxQuery::setMinimumMatch — Set Minimum "Should" Match (mm)
  • SolrDisMaxQuery::setPhraseFields — Sets Phrase Fields and their boosts (and slops) using pf2 parameter
  • SolrDisMaxQuery::setPhraseSlop — Sets the default slop on phrase queries (ps parameter)
  • SolrDisMaxQuery::setQueryAlt — Set Query Alternate (q.alt parameter)
  • SolrDisMaxQuery::setQueryPhraseSlop — specifies the amount of slop permitted on phrase queries explicitly included in the user's query string (qf parameter)
  • SolrDisMaxQuery::setTieBreaker — Sets Tie Breaker parameter (tie parameter)
  • SolrDisMaxQuery::setTrigramPhraseFields — Directly Sets Trigram Phrase Fields (pf3 parameter)
  • SolrDisMaxQuery::setTrigramPhraseSlop — Sets Trigram Phrase Slop (ps3 parameter)
  • SolrDisMaxQuery::setUserFields — Sets User Fields parameter (uf)
  • SolrDisMaxQuery::useDisMaxQueryParser — Switch QueryParser to be DisMax Query Parser
  • SolrDisMaxQuery::useEDisMaxQueryParser — Switch QueryParser to be EDisMax
SolrQuery::setTimeAllowed
SolrDisMaxQuery::addBigramPhraseField
Solr


Adds a Phrase Bigram Field (pf2 parameter)

SolrDisMaxQuery
SolrDisMaxQuery::addBoostQuery
SolrDisMaxQuery
PHP Manual

SolrDisMaxQuery::addBigramPhraseField

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

SolrDisMaxQuery::addBigramPhraseField — Adds a Phrase Bigram Field (pf2 parameter)

Açıklama

public SolrDisMaxQuery SolrDisMaxQuery::addBigramPhraseField ( string $field , string $boost [, string $slop ] )

Adds a Phrase Bigram Field (pf2 parameter) output format: field~slop^boost OR field^boost Slop is optional

Değiştirgeler

field

boost

slop

Dönen Değerler

SolrDisMaxQuery

Örnekler

Örnek 1 SolrDisMaxQuery::addBigramPhraseField() example

<?php

$dismaxQuery = new SolrDisMaxQuery("lucene");
$dismaxQuery
    ->addBigramPhraseField('cat', 2, 5.1)
    ->addBigramPhraseField('feature', 4.5)
;
echo $dismaxQuery;

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

q=lucene&defType=edismax&pf2=cat~5.1^2 feature^4.5

Ayrıca Bakınız

  • SolrDisMaxQuery::removeBigramPhraseField() - Removes phrase bigram field (pf2 parameter)
  • SolrDisMaxQuery::setBigramPhraseFields() - Sets Bigram Phrase Fields and their boosts (and slops) using pf2 parameter
  • SolrDisMaxQuery::setBigramPhraseSlop() - Sets Bigram Phrase Slop (ps2 parameter)
SolrDisMaxQuery
SolrDisMaxQuery::addBoostQuery
SolrDisMaxQuery


Adds a boost query field with value and optional boost (bq parameter)

SolrDisMaxQuery::addBigramPhraseField
SolrDisMaxQuery::addPhraseField
SolrDisMaxQuery
PHP Manual

SolrDisMaxQuery::addBoostQuery

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

SolrDisMaxQuery::addBoostQuery — Adds a boost query field with value and optional boost (bq parameter)

Açıklama

public SolrDisMaxQuery SolrDisMaxQuery::addBoostQuery ( string $field , string $value [, string $boost ] )

Adds a Boost Query field with value [and boost] (bq parameter)

Değiştirgeler

field

value

boost

Dönen Değerler

SolrDisMaxQuery

Örnekler

Örnek 1 SolrDisMaxQuery::addBoostQuery() example

<?php

$dismaxQuery = new SolrDisMaxQuery("lucene");
$dismaxQuery
    ->addBoostQuery('cat', 'clothing', 2)
    ->addBoostQuery('cat', 'electronics', 5.1)
;
echo $dismaxQuery.PHP_EOL;
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

q=lucene&defType=edismax&bq=cat:clothing^2 cat:electronics^5.1

Ayrıca Bakınız

  • SolrDisMaxQuery::removeBoostQuery() - Removes a boost query partial by field name (bq)
  • SolrDisMaxQuery::setBoostQuery() - Directly Sets Boost Query Parameter (bq)
SolrDisMaxQuery::addBigramPhraseField
SolrDisMaxQuery::addPhraseField
SolrDisMaxQuery


Adds a Phrase Field (pf parameter)

SolrDisMaxQuery::addBoostQuery
SolrDisMaxQuery::addQueryField
SolrDisMaxQuery
PHP Manual

SolrDisMaxQuery::addPhraseField

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

SolrDisMaxQuery::addPhraseField — Adds a Phrase Field (pf parameter)

Açıklama

public SolrDisMaxQuery SolrDisMaxQuery::addPhraseField ( string $field , string $boost [, string $slop ] )

Adds a Phrase Field (pf parameter)

Değiştirgeler

field

field name

boost

slop

Dönen Değerler

SolrDisMaxQuery

Örnekler

Örnek 1 SolrDisMaxQuery::addPhraseField() example

<?php
$dismaxQuery = new SolrDisMaxQuery("lucene");
$dismaxQuery
    ->addPhraseField('cat', 3, 1)
    ->addPhraseField('third', 4, 2)
    ->addPhraseField('source', 55)
;
echo $dismaxQuery;
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

q=lucene&defType=edismax&pf=cat~1^3 third~2^4 source^55

Ayrıca Bakınız

  • SolrDisMaxQuery::removePhraseField() - Removes a Phrase Field (pf parameter)
  • SolrDisMaxQuery::setPhraseFields() - Sets Phrase Fields and their boosts (and slops) using pf2 parameter
SolrDisMaxQuery::addBoostQuery
SolrDisMaxQuery::addQueryField
SolrDisMaxQuery


Add a query field with optional boost (qf parameter)

SolrDisMaxQuery::addPhraseField
SolrDisMaxQuery::addTrigramPhraseField
SolrDisMaxQuery
PHP Manual

SolrDisMaxQuery::addQueryField

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

SolrDisMaxQuery::addQueryField — Add a query field with optional boost (qf parameter)

Açıklama

public SolrDisMaxQuery SolrDisMaxQuery::addQueryField ( string $field [, string $boost ] )

Add a query field with optional boost (qf parameter)

Değiştirgeler

field

field name

boost

Boost value. Boosts documents with matching terms.

Dönen Değerler

SolrDisMaxQuery

Örnekler

Örnek 1 SolrDisMaxQuery::addQueryField() example

<?php

$dismaxQuery = new SolrDisMaxQuery("lucene");
$dismaxQuery
    ->addQueryField("location", 4)
    ->addQueryField("price")
    ->addQueryField("sku")
    ->addQueryField("title",3.4)
;
echo $dismaxQuery;

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

q=lucene&defType=edismax&qf=location^4 price sku title^3.4

Ayrıca Bakınız

  • SolrDisMaxQuery::removeQueryField() - Removes a Query Field (qf parameter)
SolrDisMaxQuery::addPhraseField
SolrDisMaxQuery::addTrigramPhraseField
SolrDisMaxQuery


Adds a Trigram Phrase Field (pf3 parameter)

SolrDisMaxQuery::addQueryField
SolrDisMaxQuery::addUserField
SolrDisMaxQuery
PHP Manual

SolrDisMaxQuery::addTrigramPhraseField

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

SolrDisMaxQuery::addTrigramPhraseField — Adds a Trigram Phrase Field (pf3 parameter)

Açıklama

public SolrDisMaxQuery SolrDisMaxQuery::addTrigramPhraseField ( string $field , string $boost [, string $slop ] )

Adds a Trigram Phrase Field (pf3 parameter)

Değiştirgeler

field

Field Name

boost

Field Boost

slop

Field Slop

Dönen Değerler

SolrDisMaxQuery

Örnekler

Örnek 1 SolrDisMaxQuery::addTrigramPhraseField() example

<?php

$dismaxQuery = new SolrDisMaxQuery('lucene');
$dismaxQuery
->addTrigramPhraseField('cat', 2, 5.1)
->addTrigramPhraseField('feature', 4.5)
;
echo $dismaxQuery.PHP_EOL;

?>

Yukarıdaki örneğin çıktısı:

q=lucene&defType=%s&pf3=cat~5.1^2 feature^4.5

Ayrıca Bakınız

  • SolrDisMaxQuery::removeTrigramPhraseField() - Removes a Trigram Phrase Field (pf3 parameter)
  • SolrDisMaxQuery::setTrigramPhraseFields() - Directly Sets Trigram Phrase Fields (pf3 parameter)
  • SolrDisMaxQuery::setTrigramPhraseSlop() - Sets Trigram Phrase Slop (ps3 parameter)
SolrDisMaxQuery::addQueryField
SolrDisMaxQuery::addUserField
SolrDisMaxQuery


Adds a field to User Fields Parameter (uf)

SolrDisMaxQuery::addTrigramPhraseField
SolrDisMaxQuery::__construct
SolrDisMaxQuery
PHP Manual

SolrDisMaxQuery::addUserField

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

SolrDisMaxQuery::addUserField — Adds a field to User Fields Parameter (uf)

Açıklama

public SolrDisMaxQuery SolrDisMaxQuery::addUserField ( string $field )

Adds a field to The User Fields Parameter (uf)

Değiştirgeler

field

Field Name

Dönen Değerler

SolrDisMaxQuery

Örnekler

Örnek 1 SolrDisMaxQuery::addUserField() example

<?php

$dismaxQuery = new SolrDisMaxQuery('lucene');
$dismaxQuery
->addUserField('cat')
->addUserField('text')
->addUserField('*_dt');

echo $dismaxQuery.PHP_EOL;

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

q=lucene&defType=edismax&uf=cat text *_dt

Ayrıca Bakınız

  • SolrDisMaxQuery::removeUserField() - Removes a field from The User Fields Parameter (uf)
  • SolrDisMaxQuery::setUserFields() - Sets User Fields parameter (uf)
SolrDisMaxQuery::addTrigramPhraseField
SolrDisMaxQuery::__construct
SolrDisMaxQuery


Class Constructor

SolrDisMaxQuery::addUserField
SolrDisMaxQuery::removeBigramPhraseField
SolrDisMaxQuery
PHP Manual

SolrDisMaxQuery::__construct

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

SolrDisMaxQuery::__construct — Class Constructor

Açıklama

public SolrDisMaxQuery::__construct ([ string $q ] )

Class constructor initializes the object and sets the q parameter if passed

Değiştirgeler

q

Search Query (q parameter)

Dönen Değerler

Hatalar/İstisnalar

Emits SolrIllegalArgumentException in case of an invalid parameter was passed.

Örnekler

Örnek 1 SolrDisMaxQuery::__construct() example

<?php

$dismaxQuery = new SolrDisMaxQuery('lucene');
echo $dismaxQuery;

?>

Yukarıdaki örneğin çıktısı:

q=lucene&defType=edismax

Ayrıca Bakınız

SolrDisMaxQuery::addUserField
SolrDisMaxQuery::removeBigramPhraseField
SolrDisMaxQuery


Removes phrase bigram field (pf2 parameter)

SolrDisMaxQuery::__construct
SolrDisMaxQuery::removeBoostQuery
SolrDisMaxQuery
PHP Manual

SolrDisMaxQuery::removeBigramPhraseField

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

SolrDisMaxQuery::removeBigramPhraseField — Removes phrase bigram field (pf2 parameter)

Açıklama

public SolrDisMaxQuery SolrDisMaxQuery::removeBigramPhraseField ( string $field )

Removes a Bigram Phrase Field (pf2 parameter) that was previously added using SolrDisMaxQuery::addBigramPhraseField()

Değiştirgeler

field

The Field Name

Dönen Değerler

SolrDisMaxQuery

Örnekler

Örnek 1 SolrDisMaxQuery::removeBigramPhraseField() example

<?php

$dismaxQuery = new SolrDisMaxQuery("lucene");
$dismaxQuery
    ->addBigramPhraseField('cat', 2, 5.1)
    ->addBigramPhraseField('feature', 4.5)
;
echo $dismaxQuery.PHP_EOL;

// remove cat from pf2
$dismaxQuery
    ->removeBigramPhraseField('cat');
echo $dismaxQuery.PHP_EOL;

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

q=lucene&defType=edismax&pf2=cat~5.1^2 feature^4.5
q=lucene&defType=edismax&pf2=feature^4.5

Ayrıca Bakınız

  • SolrDisMaxQuery::addBigramPhraseField() - Adds a Phrase Bigram Field (pf2 parameter)
  • SolrDisMaxQuery::setBigramPhraseFields() - Sets Bigram Phrase Fields and their boosts (and slops) using pf2 parameter
  • SolrDisMaxQuery::setBigramPhraseSlop() - Sets Bigram Phrase Slop (ps2 parameter)
SolrDisMaxQuery::__construct
SolrDisMaxQuery::removeBoostQuery
SolrDisMaxQuery


Removes a boost query partial by field name (bq)

SolrDisMaxQuery::removeBigramPhraseField
SolrDisMaxQuery::removePhraseField
SolrDisMaxQuery
PHP Manual

SolrDisMaxQuery::removeBoostQuery

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

SolrDisMaxQuery::removeBoostQuery — Removes a boost query partial by field name (bq)

Açıklama

public SolrDisMaxQuery SolrDisMaxQuery::removeBoostQuery ( string $field )

Removes a boost query partial from the existing query, only if SolrDisMaxQuery::addBoostQuery() was used.

Değiştirgeler

field

Field Name

Dönen Değerler

SolrDisMaxQuery

Örnekler

Örnek 1 SolrDisMaxQuery::removeBoostQuery() example

<?php

$dismaxQuery = new SolrDisMaxQuery("lucene");
$dismaxQuery
    ->addBoostQuery('cat', 'electronics', 5.1)
    ->addBoostQuery('cat', 'hard drive')
;
echo $dismaxQuery.PHP_EOL;
// now remove a query part with field 'cat'
$dismaxQuery
->removeBoostQuery('cat');
echo $dismaxQuery . PHP_EOL;

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

q=lucene&defType=edismax&bq=cat:electronics^5.1 cat:hard drive
q=lucene&defType=edismax&bq=cat:hard drive

Ayrıca Bakınız

  • SolrDisMaxQuery::addBoostQuery() - Adds a boost query field with value and optional boost (bq parameter)
  • SolrDisMaxQuery::setBoostQuery() - Directly Sets Boost Query Parameter (bq)
SolrDisMaxQuery::removeBigramPhraseField
SolrDisMaxQuery::removePhraseField
SolrDisMaxQuery


Removes a Phrase Field (pf parameter)

SolrDisMaxQuery::removeBoostQuery
SolrDisMaxQuery::removeQueryField
SolrDisMaxQuery
PHP Manual

SolrDisMaxQuery::removePhraseField

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

SolrDisMaxQuery::removePhraseField — Removes a Phrase Field (pf parameter)

Açıklama

public SolrDisMaxQuery SolrDisMaxQuery::removePhraseField ( string $field )

Removes a Phrase Field (pf parameter) that was previously added using SolrDisMaxQuery::addPhraseField

Değiştirgeler

field

Field Name

Dönen Değerler

SolrDisMaxQuery

Örnekler

Örnek 1 SolrDisMaxQuery::removePhraseField() example

<?php
$dismaxQuery = new SolrDisMaxQuery('lucene');
$dismaxQuery
    ->addPhraseField('first', 3, 1)
    ->addPhraseField('second', 4, 1)
    ->addPhraseField('cat', 55);
echo $dismaxQuery . PHP_EOL;
echo $dismaxQuery->removePhraseField('second');
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

q=lucene&defType=edismax&pf=first~1^3 second~1^4 cat^55
q=lucene&defType=edismax&pf=first~1^3 cat^55

Ayrıca Bakınız

  • SolrDisMaxQuery::addPhraseField() - Adds a Phrase Field (pf parameter)
  • SolrDisMaxQuery::setPhraseFields() - Sets Phrase Fields and their boosts (and slops) using pf2 parameter
SolrDisMaxQuery::removeBoostQuery
SolrDisMaxQuery::removeQueryField
SolrDisMaxQuery


Removes a Query Field (qf parameter)

SolrDisMaxQuery::removePhraseField
SolrDisMaxQuery::removeTrigramPhraseField
SolrDisMaxQuery
PHP Manual

SolrDisMaxQuery::removeQueryField

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

SolrDisMaxQuery::removeQueryField — Removes a Query Field (qf parameter)

Açıklama

public SolrDisMaxQuery SolrDisMaxQuery::removeQueryField ( string $field )

Removes a Query Field (qf parameter) from the field list added by SolrDisMaxQuery::addQueryField()

qf: When building DisjunctionMaxQueries from the user's query it specifies the fields to search in, and boosts for those fields.

Değiştirgeler

field

Field Name

Dönen Değerler

SolrDisMaxQuery

Örnekler

Örnek 1 SolrDisMaxQuery::removeQueryField() example

<?php

$dismaxQuery = new SolrDisMaxQuery('lucene');
$dismaxQuery
    ->addQueryField('first', 3)
    ->addQueryField('second', 0.2)
    ->addQueryField('cat');
echo $dismaxQuery . PHP_EOL;
// remove field 'second'
echo $dismaxQuery->removeQueryField('second');
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

q=lucene&defType=edismax&qf=first^3 second^0.2 cat
q=lucene&defType=edismax&qf=first^3 cat

Ayrıca Bakınız

  • SolrDisMaxQuery::addQueryField() - Add a query field with optional boost (qf parameter)
SolrDisMaxQuery::removePhraseField
SolrDisMaxQuery::removeTrigramPhraseField
SolrDisMaxQuery


Removes a Trigram Phrase Field (pf3 parameter)

SolrDisMaxQuery::removeQueryField
SolrDisMaxQuery::removeUserField
SolrDisMaxQuery
PHP Manual

SolrDisMaxQuery::removeTrigramPhraseField

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

SolrDisMaxQuery::removeTrigramPhraseField — Removes a Trigram Phrase Field (pf3 parameter)

Açıklama

public SolrDisMaxQuery SolrDisMaxQuery::removeTrigramPhraseField ( string $field )

Removes a Trigram Phrase Field (pf3 parameter)

Değiştirgeler

field

Field Name

Dönen Değerler

SolrDisMaxQuery

Örnekler

Örnek 1 SolrDisMaxQuery::removeTrigramPhraseField() example

<?php

$dismaxQuery = new SolrDisMaxQuery('lucene');
$dismaxQuery
->addTrigramPhraseField('cat', 2, 5.1)
->addTrigramPhraseField('feature', 4.5)
;
echo $dismaxQuery.PHP_EOL;
// reverse
$dismaxQuery
->removeTrigramPhraseField('cat');
echo $dismaxQuery.PHP_EOL;

?>

Yukarıdaki örneğin çıktısı:

q=lucene&defType=%s&pf3=cat~5.1^2 feature^4.5
q=lucene&defType=%s&pf3=feature^4.5

Ayrıca Bakınız

  • SolrDisMaxQuery::addTrigramPhraseField() - Adds a Trigram Phrase Field (pf3 parameter)
  • SolrDisMaxQuery::setTrigramPhraseFields() - Directly Sets Trigram Phrase Fields (pf3 parameter)
  • SolrDisMaxQuery::setTrigramPhraseSlop() - Sets Trigram Phrase Slop (ps3 parameter)
SolrDisMaxQuery::removeQueryField
SolrDisMaxQuery::removeUserField
SolrDisMaxQuery


Removes a field from The User Fields Parameter (uf)

SolrDisMaxQuery::removeTrigramPhraseField
SolrDisMaxQuery::setBigramPhraseFields
SolrDisMaxQuery
PHP Manual

SolrDisMaxQuery::removeUserField

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

SolrDisMaxQuery::removeUserField — Removes a field from The User Fields Parameter (uf)

Açıklama

public SolrDisMaxQuery SolrDisMaxQuery::removeUserField ( string $field )

Removes a field from The User Fields Parameter (uf)

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

field

Field Name

Dönen Değerler

SolrDisMaxQuery

Örnekler

Örnek 1 SolrDisMaxQuery::removeUserField() example

<?php

$dismaxQuery = new SolrDisMaxQuery('lucene');
$dismaxQuery
->addUserField('cat')
->addUserField('text')
->addUserField('*_dt')
;
echo $dismaxQuery.PHP_EOL;

// remove field named 'text'
$dismaxQuery
->removeUserField('text');
echo $dismaxQuery.PHP_EOL;

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

q=lucene&defType=%s&uf=cat text *_dt
q=lucene&defType=%s&uf=cat *_dt

Ayrıca Bakınız

  • SolrDisMaxQuery::addUserField() - Adds a field to User Fields Parameter (uf)
  • SolrDisMaxQuery::setUserFields() - Sets User Fields parameter (uf)
SolrDisMaxQuery::removeTrigramPhraseField
SolrDisMaxQuery::setBigramPhraseFields
SolrDisMaxQuery


Sets Bigram Phrase Fields and their boosts (and slops) using pf2 parameter

SolrDisMaxQuery::removeUserField
SolrDisMaxQuery::setBigramPhraseSlop
SolrDisMaxQuery
PHP Manual

SolrDisMaxQuery::setBigramPhraseFields

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

SolrDisMaxQuery::setBigramPhraseFields — Sets Bigram Phrase Fields and their boosts (and slops) using pf2 parameter

Açıklama

public SolrDisMaxQuery SolrDisMaxQuery::setBigramPhraseFields ( string $fields )

Sets Bigram Phrase Fields (pf2) and their boosts (and slops)

Değiştirgeler

fields

Fields boosts (slops)

Dönen Değerler

SolrDisMaxQuery

Örnekler

Örnek 1 SolrDisMaxQuery::setBigramPhraseFields() example

<?php
$dismaxQuery = new SolrDisMaxQuery("lucene");
$dismaxQuery->setBigramPhraseFields("cat~5.1^2 feature^4.5");
echo $dismaxQuery.PHP_EOL;

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

q=lucene&defType=edismax&pf2=cat~5.1^2 feature^4.5

Ayrıca Bakınız

  • SolrDisMaxQuery::setBigramPhraseSlop() - Sets Bigram Phrase Slop (ps2 parameter)
  • SolrDisMaxQuery::addBigramPhraseFields()
  • SolrDisMaxQuery::removeBigramPhraseField() - Removes phrase bigram field (pf2 parameter)
  • SolrDisMaxQuery::setTrigramPhraseFields() - Directly Sets Trigram Phrase Fields (pf3 parameter)
SolrDisMaxQuery::removeUserField
SolrDisMaxQuery::setBigramPhraseSlop
SolrDisMaxQuery


Sets Bigram Phrase Slop (ps2 parameter)

SolrDisMaxQuery::setBigramPhraseFields
SolrDisMaxQuery::setBoostFunction
SolrDisMaxQuery
PHP Manual

SolrDisMaxQuery::setBigramPhraseSlop

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

SolrDisMaxQuery::setBigramPhraseSlop — Sets Bigram Phrase Slop (ps2 parameter)

Açıklama

public SolrDisMaxQuery SolrDisMaxQuery::setBigramPhraseSlop ( string $slop )

Sets Bigram Phrase Slop (ps2 parameter). A default slop for Bigram phrase fields.

Değiştirgeler

slop

Dönen Değerler

SolrDisMaxQuery

Örnekler

Örnek 1 SolrDisMaxQuery::setBigramPhraseSlop() example

<?php

$dismaxQuery = new SolrDisMaxQuery('lucene');

$dismaxQuery->setBigramPhraseSlop(5);
echo $dismaxQuery.PHP_EOL;

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

q=lucene&defType=edismax&ps2=5

Ayrıca Bakınız

SolrDisMaxQuery::setBigramPhraseFields
SolrDisMaxQuery::setBoostFunction
SolrDisMaxQuery


Sets a Boost Function (bf parameter).

SolrDisMaxQuery::setBigramPhraseSlop
SolrDisMaxQuery::setBoostQuery
SolrDisMaxQuery
PHP Manual

SolrDisMaxQuery::setBoostFunction

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

SolrDisMaxQuery::setBoostFunction — Sets a Boost Function (bf parameter).

Açıklama

public SolrDisMaxQuery SolrDisMaxQuery::setBoostFunction ( string $function )

Sets Boost Function (bf parameter).

Functions (with optional boosts) that will be included in the user's query to influence the score. Any function supported natively by Solr can be used, along with a boost value. e.g.:

recip(rord(myfield),1,2,3)^1.5

Değiştirgeler

function

Dönen Değerler

SolrDisMaxQuery

Örnekler

Örnek 1 SolrDisMaxQuery::setBoostFunction() example

<?php

$dismaxQuery = new SolrDisMaxQuery('lucene');

$boostRecentDocsFunction = "recip(ms(NOW,mydatefield),3.16e-11,1,1)";
$dismaxQuery->setBoostFunction($boostRecentDocsFunction);

echo $dismaxQuery.PHP_EOL;

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

q=lucene&defType=edismax&bf=recip(ms(NOW,mydatefield),3.16e-11,1,1)

Ayrıca Bakınız

SolrDisMaxQuery::setBigramPhraseSlop
SolrDisMaxQuery::setBoostQuery
SolrDisMaxQuery


Directly Sets Boost Query Parameter (bq)

SolrDisMaxQuery::setBoostFunction
SolrDisMaxQuery::setMinimumMatch
SolrDisMaxQuery
PHP Manual

SolrDisMaxQuery::setBoostQuery

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

SolrDisMaxQuery::setBoostQuery — Directly Sets Boost Query Parameter (bq)

Açıklama

public SolrDisMaxQuery SolrDisMaxQuery::setBoostQuery ( string $q )

Sets Boost Query Parameter (bq)

Değiştirgeler

q

query

Dönen Değerler

SolrDisMaxQuery

Örnekler

Örnek 1 SolrDisMaxQuery::setBoostQuery() example

<?php
$dismaxQuery = new SolrDisMaxQuery("lucene");

$dismaxQuery->setBoostQuery('cat:electronics manu:local^2');
echo $dismaxQuery.PHP_EOL;
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

q=lucene&defType=edismax&bq=cat:electronics manu:local^2

Ayrıca Bakınız

  • SolrDisMaxQuery::addBoostQuery() - Adds a boost query field with value and optional boost (bq parameter)
  • SolrDisMaxQuery::removeBoostQuery() - Removes a boost query partial by field name (bq)
SolrDisMaxQuery::setBoostFunction
SolrDisMaxQuery::setMinimumMatch
SolrDisMaxQuery


Set Minimum "Should" Match (mm)

SolrDisMaxQuery::setBoostQuery
SolrDisMaxQuery::setPhraseFields
SolrDisMaxQuery
PHP Manual

SolrDisMaxQuery::setMinimumMatch

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

SolrDisMaxQuery::setMinimumMatch — Set Minimum "Should" Match (mm)

Açıklama

public SolrDisMaxQuery SolrDisMaxQuery::setMinimumMatch ( string $value )

Set Minimum "Should" Match parameter (mm). If the default query operator is AND then mm=100%, if the default query operator (q.op) is OR, then mm=0%.

Değiştirgeler

value

Minimum match value/expression

Dönen Değerler

SolrDisMaxQuery

Örnekler

Örnek 1 SolrDisMaxQuery::setMinimumMatch() example

<?php

$dismaxQuery = new SolrDisMaxQuery("lucene");
// 75% of the query clauses must match
$dismaxQuery->setMinimumMatch("75%");
echo $dismaxQuery . PHP_EOL;

?>

Yukarıdaki örneğin çıktısı:

q=lucene&defType=edismax&mm=75%
SolrDisMaxQuery::setBoostQuery
SolrDisMaxQuery::setPhraseFields
SolrDisMaxQuery


Sets Phrase Fields and their boosts (and slops) using pf2 parameter

SolrDisMaxQuery::setMinimumMatch
SolrDisMaxQuery::setPhraseSlop
SolrDisMaxQuery
PHP Manual

SolrDisMaxQuery::setPhraseFields

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

SolrDisMaxQuery::setPhraseFields — Sets Phrase Fields and their boosts (and slops) using pf2 parameter

Açıklama

public SolrDisMaxQuery SolrDisMaxQuery::setPhraseFields ( string $fields )

Sets Phrase Fields (pf) and their boosts (and slops)

Değiştirgeler

fields

Fields, boosts [, slops]

Dönen Değerler

SolrDisMaxQuery

Örnekler

Örnek 1 SolrDisMaxQuery::setPhraseFields() example

<?php
$dismaxQuery = new SolrDisMaxQuery("lucene");
$dismaxQuery->setPhraseFields("cat~5.1^2 feature^4.5");
echo $dismaxQuery.PHP_EOL;

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

q=lucene&defType=edismax&pf=cat~5.1^2 feature^4.5

Ayrıca Bakınız

  • SolrDisMaxQuery::addPhraseFields()
  • SolrDisMaxQuery::removePhraseField() - Removes a Phrase Field (pf parameter)
SolrDisMaxQuery::setMinimumMatch
SolrDisMaxQuery::setPhraseSlop
SolrDisMaxQuery


Sets the default slop on phrase queries (ps parameter)

SolrDisMaxQuery::setPhraseFields
SolrDisMaxQuery::setQueryAlt
SolrDisMaxQuery
PHP Manual

SolrDisMaxQuery::setPhraseSlop

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

SolrDisMaxQuery::setPhraseSlop — Sets the default slop on phrase queries (ps parameter)

Açıklama

public SolrDisMaxQuery SolrDisMaxQuery::setPhraseSlop ( string $slop )

Sets the default amount of slop on phrase queries built with "pf", "pf2" and/or "pf3" fields (affects boosting). "ps" parameter

Değiştirgeler

slop

Dönen Değerler

SolrDisMaxQuery

Örnekler

Örnek 1 SolrDisMaxQuery::setPhraseSlop() example

<?php

$dismaxQuery = new SolrDisMaxQuery('lucene');

$dismaxQuery->setPhraseSlop(4);
echo $dismaxQuery.PHP_EOL;

?>

Yukarıdaki örneğin çıktısı:

q=lucene&defType=edismax&ps=4

Ayrıca Bakınız

SolrDisMaxQuery::setPhraseFields
SolrDisMaxQuery::setQueryAlt
SolrDisMaxQuery


Set Query Alternate (q.alt parameter)

SolrDisMaxQuery::setPhraseSlop
SolrDisMaxQuery::setQueryPhraseSlop
SolrDisMaxQuery
PHP Manual

SolrDisMaxQuery::setQueryAlt

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

SolrDisMaxQuery::setQueryAlt — Set Query Alternate (q.alt parameter)

Açıklama

public SolrDisMaxQuery SolrDisMaxQuery::setQueryAlt ( string $q )

Set Query Alternate (q.alt parameter)

When the main q parameter is not specified or is blank. The q.alt parameter is used

Değiştirgeler

q

Query String

Dönen Değerler

SolrDisMaxQuery

Örnekler

Örnek 1 SolrDisMaxQuery::setQueryAlt() example

<?php

$dismaxQuery = new DisMaxQuery();
$dismaxQuery->setQueryAlt('*:*');

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

defType=edismax&q.alt=*:*&q=
SolrDisMaxQuery::setPhraseSlop
SolrDisMaxQuery::setQueryPhraseSlop
SolrDisMaxQuery


specifies the amount of slop permitted on phrase queries explicitly included in the user's query string (qf parameter)

SolrDisMaxQuery::setQueryAlt
SolrDisMaxQuery::setTieBreaker
SolrDisMaxQuery
PHP Manual

SolrDisMaxQuery::setQueryPhraseSlop

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

SolrDisMaxQuery::setQueryPhraseSlop — specifies the amount of slop permitted on phrase queries explicitly included in the user's query string (qf parameter)

Açıklama

public SolrDisMaxQuery SolrDisMaxQuery::setQueryPhraseSlop ( string $slop )

The Query Phrase Slop is the amount of slop permitted on phrase queries explicitly included in the user's query string with the qf parameter.

slop refers to the number of positions one token needs to be moved in relation to another token in order to match a phrase specified in a query.

Değiştirgeler

slop

Amount of slop

Dönen Değerler

SolrDisMaxQuery

Örnekler

Örnek 1 SolrDisMaxQuery::setQueryPhraseSlop() example

<?php

$dismaxQuery = new SolrDisMaxQuery();
$dismaxQuery->setQueryPhraseSlop(3);
echo $dismaxQuery;
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

defType=edismax&qs=3
SolrDisMaxQuery::setQueryAlt
SolrDisMaxQuery::setTieBreaker
SolrDisMaxQuery


Sets Tie Breaker parameter (tie parameter)

SolrDisMaxQuery::setQueryPhraseSlop
SolrDisMaxQuery::setTrigramPhraseFields
SolrDisMaxQuery
PHP Manual

SolrDisMaxQuery::setTieBreaker

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

SolrDisMaxQuery::setTieBreaker — Sets Tie Breaker parameter (tie parameter)

Açıklama

public SolrDisMaxQuery SolrDisMaxQuery::setTieBreaker ( string $tieBreaker )

Sets Tie Breaker parameter (tie parameter)

Değiştirgeler

tieBreaker

The tie parameter specifies a float value (which should be something much less than 1) to use as tiebreaker in DisMax queries.

Dönen Değerler

SolrDisMaxQuery

Örnekler

Örnek 1 SolrDisMaxQuery::setTieBreaker() example

<?php

$dismaxQuery = new SolrDisMaxQuery();
$dismaxQuery->setTieBreaker(0.1);

echo $dismaxQuery;

?>

Yukarıdaki örneğin çıktısı:

defType=edismax&tie=0.1
SolrDisMaxQuery::setQueryPhraseSlop
SolrDisMaxQuery::setTrigramPhraseFields
SolrDisMaxQuery


Directly Sets Trigram Phrase Fields (pf3 parameter)

SolrDisMaxQuery::setTieBreaker
SolrDisMaxQuery::setTrigramPhraseSlop
SolrDisMaxQuery
PHP Manual

SolrDisMaxQuery::setTrigramPhraseFields

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

SolrDisMaxQuery::setTrigramPhraseFields — Directly Sets Trigram Phrase Fields (pf3 parameter)

Açıklama

public SolrDisMaxQuery SolrDisMaxQuery::setTrigramPhraseFields ( string $fields )

Directly Sets Trigram Phrase Fields (pf3 parameter)

Değiştirgeler

fields

Trigram Phrase Fields

Dönen Değerler

SolrDisMaxQuery

Örnekler

Örnek 1 SolrDisMaxQuery::setTrigramPhraseFields() example

<?php

$dismaxQuery = new SolrDisMaxQuery('lucene');
$dismaxQuery->setTrigramPhraseFields('cat~5.1^2 feature^4.5');
echo $dismaxQuery.PHP_EOL;

?>

Yukarıdaki örneğin çıktısı:

q=lucene&defType=edismax&pf3=cat~5.1^2 feature^4.5

Ayrıca Bakınız

  • SolrDisMaxQuery::addTrigramPhraseField() - Adds a Trigram Phrase Field (pf3 parameter)
  • SolrDisMaxQuery::removeTrigramPhraseField() - Removes a Trigram Phrase Field (pf3 parameter)
  • SolrDisMaxQuery::setTrigramPhraseSlop() - Sets Trigram Phrase Slop (ps3 parameter)
SolrDisMaxQuery::setTieBreaker
SolrDisMaxQuery::setTrigramPhraseSlop
SolrDisMaxQuery


Sets Trigram Phrase Slop (ps3 parameter)

SolrDisMaxQuery::setTrigramPhraseFields
SolrDisMaxQuery::setUserFields
SolrDisMaxQuery
PHP Manual

SolrDisMaxQuery::setTrigramPhraseSlop

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

SolrDisMaxQuery::setTrigramPhraseSlop — Sets Trigram Phrase Slop (ps3 parameter)

Açıklama

public SolrDisMaxQuery SolrDisMaxQuery::setTrigramPhraseSlop ( string $slop )

Sets Trigram Phrase Slop (ps3 parameter)

Değiştirgeler

slop

Phrase slop

Dönen Değerler

SolrDisMaxQuery

Örnekler

Örnek 1 SolrDisMaxQuery::setTrigramPhraseSlop() example

<?php

$dismaxQuery = new SolrDisMaxQuery('lucene');
$dismaxQuery->setTrigramPhraseSlop(2);
echo $dismaxQuery.PHP_EOL;

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

q=lucene&defType=edismax&ps3=2

Ayrıca Bakınız

  • SolrDisMaxQuery::addTrigramPhraseField() - Adds a Trigram Phrase Field (pf3 parameter)
  • SolrDisMaxQuery::removeTrigramPhraseField() - Removes a Trigram Phrase Field (pf3 parameter)
  • SolrDisMaxQuery::setTrigramPhraseFields() - Directly Sets Trigram Phrase Fields (pf3 parameter)
SolrDisMaxQuery::setTrigramPhraseFields
SolrDisMaxQuery::setUserFields
SolrDisMaxQuery


Sets User Fields parameter (uf)

SolrDisMaxQuery::setTrigramPhraseSlop
SolrDisMaxQuery::useDisMaxQueryParser
SolrDisMaxQuery
PHP Manual

SolrDisMaxQuery::setUserFields

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

SolrDisMaxQuery::setUserFields — Sets User Fields parameter (uf)

Açıklama

public SolrDisMaxQuery SolrDisMaxQuery::setUserFields ( string $fields )

Sets User Fields parameter (uf)

User Fields: Specifies which schema fields the end user shall be allowed to query.

Değiştirgeler

fields

Fields names separated by space

This parameter supports wildcards.

Dönen Değerler

SolrDisMaxQuery

Örnekler

Örnek 1 SolrDisMaxQuery::setUserFields() example

<?php

$dismaxQuery = new SolrDisMaxQuery('lucene');
$dismaxQuery->setUserFields('field1 field2 *_txt');
echo $dismaxQuery.PHP_EOL;

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

q=lucene&defType=edismax&uf=field1 field2 *_txt

Ayrıca Bakınız

  • SolrDisMaxQuery::addUserField() - Adds a field to User Fields Parameter (uf)
  • SolrDisMaxQuery::removeUserField() - Removes a field from The User Fields Parameter (uf)
SolrDisMaxQuery::setTrigramPhraseSlop
SolrDisMaxQuery::useDisMaxQueryParser
SolrDisMaxQuery


Switch QueryParser to be DisMax Query Parser

SolrDisMaxQuery::setUserFields
SolrDisMaxQuery::useEDisMaxQueryParser
SolrDisMaxQuery
PHP Manual

SolrDisMaxQuery::useDisMaxQueryParser

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

SolrDisMaxQuery::useDisMaxQueryParser — Switch QueryParser to be DisMax Query Parser

Açıklama

public SolrDisMaxQuery SolrDisMaxQuery::useDisMaxQueryParser ( void )

Switch QueryParser to be DisMax Query Parser

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

SolrDisMaxQuery

Örnekler

Örnek 1 SolrDisMaxQuery::useDisMaxQueryParser() example

<?php

$dismaxQuery = new SolrDisMaxQuery();
$dismaxQuery->useDisMaxQueryParser();
echo $dismaxQuery;
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

defType=dismax

Ayrıca Bakınız

  • SolrDisMaxQuery::useDisMaxQueryParser()
SolrDisMaxQuery::setUserFields
SolrDisMaxQuery::useEDisMaxQueryParser
SolrDisMaxQuery


Switch QueryParser to be EDisMax

SolrDisMaxQuery::useDisMaxQueryParser
SolrCollapseFunction
SolrDisMaxQuery
PHP Manual

SolrDisMaxQuery::useEDisMaxQueryParser

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

SolrDisMaxQuery::useEDisMaxQueryParser — Switch QueryParser to be EDisMax

Açıklama

public SolrDisMaxQuery SolrDisMaxQuery::useEDisMaxQueryParser ( void )

Switch QueryParser to be EDisMax. By default the query builder uses edismax, if it was switched using SolrDisMaxQuery::useDisMaxQueryParser(), it can be switched back using this method.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

SolrDisMaxQuery

Örnekler

Örnek 1 SolrDisMaxQuery::useEDisMaxQueryParser() example

<?php

$dismaxQuery = new SolrDisMaxQuery();
$dismaxQuery->useEDisMaxQueryParser();
echo $dismaxQuery;

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

defType=edismax

Ayrıca Bakınız

SolrDisMaxQuery::useDisMaxQueryParser
SolrCollapseFunction
SolrDisMaxQuery


The SolrCollapseFunction class

(PECL solr >= 2.2.0)

Giriş

Sınıf Sözdizimi

SolrCollapseFunction {
/* Constants */
const string NULLPOLICY_IGNORE = ignore ;
const string NULLPOLICY_EXPAND = expand ;
const string NULLPOLICY_COLLAPSE = collapse ;
/* Yöntemler */
public __construct ([ string $field ] )
public string getField ( void )
public string getHint ( void )
public string getMax ( void )
public string getMin ( void )
public string getNullPolicy ( void )
public integer getSize ( void )
public SolrCollapseFunction setField ( string $fieldName )
public SolrCollapseFunction setHint ( string $hint )
public SolrCollapseFunction setMax ( string $max )
public SolrCollapseFunction setMin ( string $min )
public SolrCollapseFunction setNullPolicy ( string $nullPolicy )
public SolrCollapseFunction setSize ( integer $size )
public string __toString ( void )
}

Öntanımlı Sabitler

SolrCollapseFunction::NULLPOLICY_IGNORE

SolrCollapseFunction::NULLPOLICY_EXPAND

SolrCollapseFunction::NULLPOLICY_COLLAPSE

İçindekiler

  • SolrCollapseFunction::__construct — Constructor
  • SolrCollapseFunction::getField — Returns the field that is being collapsed on.
  • SolrCollapseFunction::getHint — Returns collapse hint
  • SolrCollapseFunction::getMax — Returns max parameter
  • SolrCollapseFunction::getMin — Returns min parameter
  • SolrCollapseFunction::getNullPolicy — Returns null policy
  • SolrCollapseFunction::getSize — Returns size parameter
  • SolrCollapseFunction::setField — Sets the field to collapse on
  • SolrCollapseFunction::setHint — Sets collapse hint
  • SolrCollapseFunction::setMax — Selects the group heads by the max value of a numeric field or function query.
  • SolrCollapseFunction::setMin — Sets the initial size of the collapse data structures when collapsing on a numeric field only
  • SolrCollapseFunction::setNullPolicy — Sets the NULL Policy
  • SolrCollapseFunction::setSize — Sets the initial size of the collapse data structures when collapsing on a numeric field only.
  • SolrCollapseFunction::__toString — Returns a string representing the constructed collapse function
SolrDisMaxQuery::useEDisMaxQueryParser
SolrCollapseFunction::__construct
Solr


Constructor

SolrCollapseFunction
SolrCollapseFunction::getField
SolrCollapseFunction
PHP Manual

SolrCollapseFunction::__construct

(PECL solr >= 2.2.0)

SolrCollapseFunction::__construct — Constructor

Açıklama

public SolrCollapseFunction::__construct ([ string $field ] )

Collapse Function constructor

Değiştirgeler

field

The field name to collapse on.

In order to collapse a result. The field type must be a single valued String, Int or Float.

Örnekler

Örnek 1 SolrCollapseFunction::__construct() example

<?php

include "bootstrap.php";

$options = array
(
    'hostname' => SOLR_SERVER_HOSTNAME,
    'login'    => SOLR_SERVER_USERNAME,
    'password' => SOLR_SERVER_PASSWORD,
    'port'     => SOLR_SERVER_PORT,
    'path'     => SOLR_SERVER_PATH
);

$client = new SolrClient($options);

$query = new SolrQuery('*:*');

$func = new SolrCollapseFunction('field_name');

$func->setMax('sum(cscore(),field(some_other_field))');
$func->setSize(100);
$func->setNullPolicy(SolrCollapseFunction::NULLPOLICY_EXPAND);

$query->collapse($func);

$queryResponse = $client->query($query);

$response = $queryResponse->getResponse();

print_r($response);

?>

Ayrıca Bakınız

  • SolrQuery::collapse() - Collapses the result set to a single document per group
SolrCollapseFunction
SolrCollapseFunction::getField
SolrCollapseFunction


Returns the field that is being collapsed on.

SolrCollapseFunction::__construct
SolrCollapseFunction::getHint
SolrCollapseFunction
PHP Manual

SolrCollapseFunction::getField

(PECL solr >= 2.2.0)

SolrCollapseFunction::getField — Returns the field that is being collapsed on.

Açıklama

public string SolrCollapseFunction::getField ( void )

Returns the field that is being collapsed on.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Ayrıca Bakınız

  • SolrCollapseFunction::setField() - Sets the field to collapse on
SolrCollapseFunction::__construct
SolrCollapseFunction::getHint
SolrCollapseFunction


Returns collapse hint

SolrCollapseFunction::getField
SolrCollapseFunction::getMax
SolrCollapseFunction
PHP Manual

SolrCollapseFunction::getHint

(PECL solr >= 2.2.0)

SolrCollapseFunction::getHint — Returns collapse hint

Açıklama

public string SolrCollapseFunction::getHint ( void )

Returns collapse hint

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Ayrıca Bakınız

  • SolrCollapseFunction::setHint() - Sets collapse hint
SolrCollapseFunction::getField
SolrCollapseFunction::getMax
SolrCollapseFunction


Returns max parameter

SolrCollapseFunction::getHint
SolrCollapseFunction::getMin
SolrCollapseFunction
PHP Manual

SolrCollapseFunction::getMax

(PECL solr >= 2.2.0)

SolrCollapseFunction::getMax — Returns max parameter

Açıklama

public string SolrCollapseFunction::getMax ( void )

Returns max parameter

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Ayrıca Bakınız

  • SolrCollapseFunction::setMax() - Selects the group heads by the max value of a numeric field or function query.
SolrCollapseFunction::getHint
SolrCollapseFunction::getMin
SolrCollapseFunction


Returns min parameter

SolrCollapseFunction::getMax
SolrCollapseFunction::getNullPolicy
SolrCollapseFunction
PHP Manual

SolrCollapseFunction::getMin

(PECL solr >= 2.2.0)

SolrCollapseFunction::getMin — Returns min parameter

Açıklama

public string SolrCollapseFunction::getMin ( void )

Returns min parameter

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Ayrıca Bakınız

  • SolrCollapseFunction::setMin() - Sets the initial size of the collapse data structures when collapsing on a numeric field only
SolrCollapseFunction::getMax
SolrCollapseFunction::getNullPolicy
SolrCollapseFunction


Returns null policy

SolrCollapseFunction::getMin
SolrCollapseFunction::getSize
SolrCollapseFunction
PHP Manual

SolrCollapseFunction::getNullPolicy

(PECL solr >= 2.2.0)

SolrCollapseFunction::getNullPolicy — Returns null policy

Açıklama

public string SolrCollapseFunction::getNullPolicy ( void )

Returns null policy used or null

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Ayrıca Bakınız

  • SolrCollapseFunction::setNullPolicy() - Sets the NULL Policy
SolrCollapseFunction::getMin
SolrCollapseFunction::getSize
SolrCollapseFunction


Returns size parameter

SolrCollapseFunction::getNullPolicy
SolrCollapseFunction::setField
SolrCollapseFunction
PHP Manual

SolrCollapseFunction::getSize

(PECL solr >= 2.2.0)

SolrCollapseFunction::getSize — Returns size parameter

Açıklama

public integer SolrCollapseFunction::getSize ( void )

Gets the initial size of the collapse data structures when collapsing on a numeric field only

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Ayrıca Bakınız

  • SolrCollapseFunction::setSize() - Sets the initial size of the collapse data structures when collapsing on a numeric field only.
SolrCollapseFunction::getNullPolicy
SolrCollapseFunction::setField
SolrCollapseFunction


Sets the field to collapse on

SolrCollapseFunction::getSize
SolrCollapseFunction::setHint
SolrCollapseFunction
PHP Manual

SolrCollapseFunction::setField

(PECL solr >= 2.2.0)

SolrCollapseFunction::setField — Sets the field to collapse on

Açıklama

public SolrCollapseFunction SolrCollapseFunction::setField ( string $fieldName )

The field name to collapse on. In order to collapse a result. The field type must be a single valued String, Int or Float.

Değiştirgeler

fieldName

Dönen Değerler

SolrCollapseFunction

SolrCollapseFunction::getSize
SolrCollapseFunction::setHint
SolrCollapseFunction


Sets collapse hint

SolrCollapseFunction::setField
SolrCollapseFunction::setMax
SolrCollapseFunction
PHP Manual

SolrCollapseFunction::setHint

(PECL solr >= 2.2.0)

SolrCollapseFunction::setHint — Sets collapse hint

Açıklama

public SolrCollapseFunction SolrCollapseFunction::setHint ( string $hint )

Sets collapse hint

Değiştirgeler

hint

Currently there is only one hint available "top_fc", which stands for top level FieldCache

Dönen Değerler

SolrCollapseFunction

Örnekler

Örnek 1 SolrCollapseFunction::setHint() example

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...
SolrCollapseFunction::setField
SolrCollapseFunction::setMax
SolrCollapseFunction


Selects the group heads by the max value of a numeric field or function query.

SolrCollapseFunction::setHint
SolrCollapseFunction::setMin
SolrCollapseFunction
PHP Manual

SolrCollapseFunction::setMax

(PECL solr >= 2.2.0)

SolrCollapseFunction::setMax — Selects the group heads by the max value of a numeric field or function query.

Açıklama

public SolrCollapseFunction SolrCollapseFunction::setMax ( string $max )

Selects the group heads by the max value of a numeric field or function query.

Değiştirgeler

max

Dönen Değerler

SolrCollapseFunction

Örnekler

Örnek 1 SolrCollapseFunction::setMax() example

<?php

$func = new SolrCollapseFunction('field_name');

$func->setMax('sum(cscore(),field(some_field))');

$query = new SolrQuery('*:*');

$query->collapse($func);

?>
SolrCollapseFunction::setHint
SolrCollapseFunction::setMin
SolrCollapseFunction


Sets the initial size of the collapse data structures when collapsing on a numeric field only

SolrCollapseFunction::setMax
SolrCollapseFunction::setNullPolicy
SolrCollapseFunction
PHP Manual

SolrCollapseFunction::setMin

(PECL solr >= 2.2.0)

SolrCollapseFunction::setMin — Sets the initial size of the collapse data structures when collapsing on a numeric field only

Açıklama

public SolrCollapseFunction SolrCollapseFunction::setMin ( string $min )

Sets the initial size of the collapse data structures when collapsing on a numeric field only

Değiştirgeler

min

Dönen Değerler

SolrCollapseFunction

SolrCollapseFunction::setMax
SolrCollapseFunction::setNullPolicy
SolrCollapseFunction


Sets the NULL Policy

SolrCollapseFunction::setMin
SolrCollapseFunction::setSize
SolrCollapseFunction
PHP Manual

SolrCollapseFunction::setNullPolicy

(PECL solr >= 2.2.0)

SolrCollapseFunction::setNullPolicy — Sets the NULL Policy

Açıklama

public SolrCollapseFunction SolrCollapseFunction::setNullPolicy ( string $nullPolicy )

Sets the NULL Policy. One of the 3 policies defined as class constants shall be passed. Accepts ignore, expand, or collapse policies.

Değiştirgeler

nullPolicy

Dönen Değerler

SolrCollapseFunction

SolrCollapseFunction::setMin
SolrCollapseFunction::setSize
SolrCollapseFunction


Sets the initial size of the collapse data structures when collapsing on a numeric field only.

SolrCollapseFunction::setNullPolicy
SolrCollapseFunction::__toString
SolrCollapseFunction
PHP Manual

SolrCollapseFunction::setSize

(PECL solr >= 2.2.0)

SolrCollapseFunction::setSize — Sets the initial size of the collapse data structures when collapsing on a numeric field only.

Açıklama

public SolrCollapseFunction SolrCollapseFunction::setSize ( integer $size )

Sets the initial size of the collapse data structures when collapsing on a numeric field only.

Değiştirgeler

size

Dönen Değerler

SolrCollapseFunction

SolrCollapseFunction::setNullPolicy
SolrCollapseFunction::__toString
SolrCollapseFunction


Returns a string representing the constructed collapse function

SolrCollapseFunction::setSize
SolrException
SolrCollapseFunction
PHP Manual

SolrCollapseFunction::__toString

(PECL solr >= 2.2.0)

SolrCollapseFunction::__toString — Returns a string representing the constructed collapse function

Açıklama

public string SolrCollapseFunction::__toString ( void )

Returns a string representing the constructed collapse function

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

SolrCollapseFunction::setSize
SolrException
SolrCollapseFunction


The SolrException class

(PECL solr >= 0.9.2)

Giriş

This is the base class for all exception thrown by the Solr extension classes.

Sınıf Sözdizimi

SolrException extends Exception {
/* Özellikler */
protected integer $sourceline ;
protected string $sourcefile ;
protected string $zif_name ;
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Yöntemler */
public array getInternalInfo ( void )
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}

Özellikler

sourceline

The line in c-space source file where exception was generated

sourcefile

The c-space source file where exception was generated

zif_name

The c-space function where exception was generated

İçindekiler

  • SolrException::getInternalInfo — Returns internal information where the Exception was thrown
SolrCollapseFunction::__toString
SolrException::getInternalInfo
Solr


Returns internal information where the Exception was thrown

SolrException
SolrClientException
SolrException
PHP Manual

SolrException::getInternalInfo

(PECL solr >= 0.9.2)

SolrException::getInternalInfo — Returns internal information where the Exception was thrown

Açıklama

public array SolrException::getInternalInfo ( void )

Returns internal information where the Exception was thrown.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array containing internal information where the error was thrown. Used only for debugging by extension developers.

SolrException
SolrClientException
SolrException


The SolrClientException class

(PECL solr >= 0.9.2)

Giriş

An exception thrown when there is an error while making a request to the server from the client.

Sınıf Sözdizimi

SolrClientException extends SolrException {
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
protected integer $sourceline ;
protected string $sourcefile ;
protected string $zif_name ;
/* Yöntemler */
public array getInternalInfo ( void )
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
public array SolrException::getInternalInfo ( void )
}

İçindekiler

  • SolrClientException::getInternalInfo — Returns internal information where the Exception was thrown
SolrException::getInternalInfo
SolrClientException::getInternalInfo
Solr


Returns internal information where the Exception was thrown

SolrClientException
SolrServerException
SolrClientException
PHP Manual

SolrClientException::getInternalInfo

(PECL solr >= 0.9.2)

SolrClientException::getInternalInfo — Returns internal information where the Exception was thrown

Açıklama

public array SolrClientException::getInternalInfo ( void )

Returns internal information where the Exception was thrown.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array containing internal information where the error was thrown. Used only for debugging by extension developers.

SolrClientException
SolrServerException
SolrClientException


The SolrServerException class

(PECL Solr >= 1.1.0, >=2.0.0)

Giriş

An exception thrown when there is an error produced by the Solr Server itself.

Sınıf Sözdizimi

SolrServerException extends SolrException {
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
protected integer $sourceline ;
protected string $sourcefile ;
protected string $zif_name ;
/* Yöntemler */
public array getInternalInfo ( void )
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
public array SolrException::getInternalInfo ( void )
}

İçindekiler

  • SolrServerException::getInternalInfo — Returns internal information where the Exception was thrown
SolrClientException::getInternalInfo
SolrServerException::getInternalInfo
Solr


Returns internal information where the Exception was thrown

SolrServerException
SolrIllegalArgumentException
SolrServerException
PHP Manual

SolrServerException::getInternalInfo

(PECL solr >= 1.1.0, >=2.0.0)

SolrServerException::getInternalInfo — Returns internal information where the Exception was thrown

Açıklama

public array SolrServerException::getInternalInfo ( void )

Returns internal information where the Exception was thrown.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array containing internal information where the error was thrown. Used only for debugging by extension developers.

SolrServerException
SolrIllegalArgumentException
SolrServerException


The SolrIllegalArgumentException class

(PECL solr >= 0.9.2)

Giriş

This object is thrown when an illeglal or invalid argument is passed to a method.

Sınıf Sözdizimi

SolrIllegalArgumentException extends SolrException {
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
protected integer $sourceline ;
protected string $sourcefile ;
protected string $zif_name ;
/* Yöntemler */
public array getInternalInfo ( void )
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
public array SolrException::getInternalInfo ( void )
}

İçindekiler

  • SolrIllegalArgumentException::getInternalInfo — Returns internal information where the Exception was thrown
SolrServerException::getInternalInfo
SolrIllegalArgumentException::getInternalInfo
Solr


Returns internal information where the Exception was thrown

SolrIllegalArgumentException
SolrIllegalOperationException
SolrIllegalArgumentException
PHP Manual

SolrIllegalArgumentException::getInternalInfo

(PECL solr >= 0.9.2)

SolrIllegalArgumentException::getInternalInfo — Returns internal information where the Exception was thrown

Açıklama

public array SolrIllegalArgumentException::getInternalInfo ( void )

Returns internal information where the Exception was thrown.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array containing internal information where the error was thrown. Used only for debugging by extension developers.

SolrIllegalArgumentException
SolrIllegalOperationException
SolrIllegalArgumentException


The SolrIllegalOperationException class

(PECL solr >= 0.9.2)

Giriş

This object is thrown when an illegal or unsupported operation is performed on an object.

Sınıf Sözdizimi

SolrIllegalOperationException extends SolrException {
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
protected integer $sourceline ;
protected string $sourcefile ;
protected string $zif_name ;
/* Yöntemler */
public array getInternalInfo ( void )
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
public array SolrException::getInternalInfo ( void )
}

İçindekiler

  • SolrIllegalOperationException::getInternalInfo — Returns internal information where the Exception was thrown
SolrIllegalArgumentException::getInternalInfo
SolrIllegalOperationException::getInternalInfo
Solr


Returns internal information where the Exception was thrown

SolrIllegalOperationException
SolrMissingMandatoryParameterException
SolrIllegalOperationException
PHP Manual

SolrIllegalOperationException::getInternalInfo

(PECL solr >= 0.9.2)

SolrIllegalOperationException::getInternalInfo — Returns internal information where the Exception was thrown

Açıklama

public array SolrIllegalOperationException::getInternalInfo ( void )

Returns internal information where the Exception was thrown.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array containing internal information where the error was thrown. Used only for debugging by extension developers.

SolrIllegalOperationException
SolrMissingMandatoryParameterException
SolrIllegalOperationException


The SolrMissingMandatoryParameterException class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

Sınıf Sözdizimi

SolrMissingMandatoryParameterException extends SolrException {
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
protected integer $sourceline ;
protected string $sourcefile ;
protected string $zif_name ;
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
public array SolrException::getInternalInfo ( void )
}
SolrIllegalOperationException::getInternalInfo
Sphinx
Solr


Sphinx Client

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
  • SphinxClient — The SphinxClient class
    • SphinxClient::addQuery — Add query to multi-query batch
    • SphinxClient::buildExcerpts — Build text snippets
    • SphinxClient::buildKeywords — Extract keywords from query
    • SphinxClient::close — Closes previously opened persistent connection
    • SphinxClient::__construct — Create a new SphinxClient object
    • SphinxClient::escapeString — Escape special characters
    • SphinxClient::getLastError — Get the last error message
    • SphinxClient::getLastWarning — Get the last warning
    • SphinxClient::open — Opens persistent connection to the server
    • SphinxClient::query — Execute search query
    • SphinxClient::resetFilters — Clear all filters
    • SphinxClient::resetGroupBy — Clear all group-by settings
    • SphinxClient::runQueries — Run a batch of search queries
    • SphinxClient::setArrayResult — Change the format of result set array
    • SphinxClient::setConnectTimeout — Set connection timeout
    • SphinxClient::setFieldWeights — Set field weights
    • SphinxClient::setFilter — Add new integer values set filter
    • SphinxClient::setFilterFloatRange — Add new float range filter
    • SphinxClient::setFilterRange — Add new integer range filter
    • SphinxClient::setGeoAnchor — Set anchor point for a geosphere distance calculations
    • SphinxClient::setGroupBy — Set grouping attribute
    • SphinxClient::setGroupDistinct — Set attribute name for per-group distinct values count calculations
    • SphinxClient::setIDRange — Set a range of accepted document IDs
    • SphinxClient::setIndexWeights — Set per-index weights
    • SphinxClient::setLimits — Set offset and limit of the result set
    • SphinxClient::setMatchMode — Set full-text query matching mode
    • SphinxClient::setMaxQueryTime — Set maximum query time
    • SphinxClient::setOverride — Sets temporary per-document attribute value overrides
    • SphinxClient::setRankingMode — Set ranking mode
    • SphinxClient::setRetries — Set retry count and delay
    • SphinxClient::setSelect — Set select clause
    • SphinxClient::setServer — Set searchd host and port
    • SphinxClient::setSortMode — Set matches sorting mode
    • SphinxClient::status — Queries searchd status
    • SphinxClient::updateAttributes — Update document attributes
SolrMissingMandatoryParameterException
Giriş
Arama Motoru Eklentileri


Giriş

This extension provides bindings for Sphinx search client library. Sphinx is a standalone search engine meant to provide fast, size-efficient and relevant fulltext search functions to other applications. Sphinx was specially designed to integrate well with SQL databases and scripting languages. Both Sphinx and its client library can be obtained from the » official site

Sphinx
Yapılandırma/Kurulum
Sphinx


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Sphinx


Gereksinimler

PECL/sphinx requires PHP 5.2.2 or newer.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/sphinx.

If the ./configure script generated by phpize is having trouble finding the libsphinxclient files (for example, it was installed into a custom prefix directory), use ./configure --with-sphinx=$PREFIX, where $PREFIX is installation prefix of libsphinxclient.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

SEARCHD_OK (integer)
SEARCHD_ERROR (integer)
SEARCHD_RETRY (integer)
SEARCHD_WARNING (integer)
SPH_MATCH_ALL (integer)
SPH_MATCH_ANY (integer)
SPH_MATCH_PHRASE (integer)
SPH_MATCH_BOOLEAN (integer)
SPH_MATCH_EXTENDED (integer)
SPH_MATCH_FULLSCAN (integer)
SPH_MATCH_EXTENDED2 (integer)
SPH_RANK_PROXIMITY_BM25 (integer)
SPH_RANK_BM25 (integer)
SPH_RANK_NONE (integer)
SPH_RANK_WORDCOUNT (integer)
SPH_SORT_RELEVANCE (integer)
SPH_SORT_ATTR_DESC (integer)
SPH_SORT_ATTR_ASC (integer)
SPH_SORT_TIME_SEGMENTS (integer)
SPH_SORT_EXTENDED (integer)
SPH_SORT_EXPR (integer)
SPH_FILTER_VALUES (integer)
SPH_FILTER_RANGE (integer)
SPH_FILTER_FLOATRANGE (integer)
SPH_ATTR_INTEGER (integer)
SPH_ATTR_TIMESTAMP (integer)
SPH_ATTR_ORDINAL (integer)
SPH_ATTR_BOOL (integer)
SPH_ATTR_FLOAT (integer)
SPH_ATTR_MULTI (integer)
SPH_GROUPBY_DAY (integer)
SPH_GROUPBY_WEEK (integer)
SPH_GROUPBY_MONTH (integer)
SPH_GROUPBY_YEAR (integer)
SPH_GROUPBY_ATTR (integer)
SPH_GROUPBY_ATTRPAIR (integer)

Özkaynak Türleri
Örnekler
Sphinx


Örnekler

Örnek 1 Basic usage example

<?php

$s = new SphinxClient;
$s->setServer("localhost", 6712);
$s->setMatchMode(SPH_MATCH_ANY);
$s->setMaxQueryTime(3);

$result = $s->query("test");

var_dump($result);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(10) {
  ["error"]=>
  string(0) ""
  ["warning"]=>
  string(0) ""
  ["status"]=>
  int(0)
  ["fields"]=>
  array(3) {
    [0]=>
    string(7) "subject"
    [1]=>
    string(4) "body"
    [2]=>
    string(6) "author"
  }
  ["attrs"]=>
  array(0) {
  }
  ["matches"]=>
  array(1) {
    [3]=>
    array(2) {
      ["weight"]=>
      int(1)
      ["attrs"]=>
      array(0) {
      }
    }
  }
  ["total"]=>
  int(1)
  ["total_found"]=>
  int(1)
  ["time"]=>
  float(0)
  ["words"]=>
  array(1) {
    ["to"]=>
    array(2) {
      ["docs"]=>
      int(1)
      ["hits"]=>
      int(1)
    }
  }
}
Öntanımlı Sabitler
SphinxClient
Sphinx


The SphinxClient class

(PECL sphinx >= 0.1.0)

Giriş

The SphinxClient class provides object-oriented interface to Sphinx.

Sınıf Sözdizimi

SphinxClient {
/* Yöntemler */
public int addQuery ( string $query [, string $index = "*" [, string $comment = "" ]] )
public array buildExcerpts ( array $docs , string $index , string $words [, array $opts ] )
public array buildKeywords ( string $query , string $index , bool $hits )
public bool close ( void )
public __construct ( void )
public string escapeString ( string $string )
public string getLastError ( void )
public string getLastWarning ( void )
public bool open ( void )
public array query ( string $query [, string $index = "*" [, string $comment = "" ]] )
public void resetFilters ( void )
public void resetGroupBy ( void )
public array runQueries ( void )
public bool setArrayResult ( bool $array_result = false )
public bool setConnectTimeout ( float $timeout )
public bool setFieldWeights ( array $weights )
public bool setFilter ( string $attribute , array $values [, bool $exclude = false ] )
public bool setFilterFloatRange ( string $attribute , float $min , float $max [, bool $exclude = false ] )
public bool setFilterRange ( string $attribute , int $min , int $max [, bool $exclude = false ] )
public bool setGeoAnchor ( string $attrlat , string $attrlong , float $latitude , float $longitude )
public bool setGroupBy ( string $attribute , int $func [, string $groupsort = "@group desc" ] )
public bool setGroupDistinct ( string $attribute )
public bool setIDRange ( int $min , int $max )
public bool setIndexWeights ( array $weights )
public bool setLimits ( int $offset , int $limit [, int $max_matches = 0 [, int $cutoff = 0 ]] )
public bool setMatchMode ( int $mode )
public bool setMaxQueryTime ( int $qtime )
public bool setOverride ( string $attribute , int $type , array $values )
public bool setRankingMode ( int $ranker )
public bool setRetries ( int $count [, int $delay = 0 ] )
public bool setSelect ( string $clause )
public bool setServer ( string $server , int $port )
public bool setSortMode ( int $mode [, string $sortby ] )
public array status ( void )
public int updateAttributes ( string $index , array $attributes , array $values [, bool $mva = false ] )
}

İçindekiler

  • SphinxClient::addQuery — Add query to multi-query batch
  • SphinxClient::buildExcerpts — Build text snippets
  • SphinxClient::buildKeywords — Extract keywords from query
  • SphinxClient::close — Closes previously opened persistent connection
  • SphinxClient::__construct — Create a new SphinxClient object
  • SphinxClient::escapeString — Escape special characters
  • SphinxClient::getLastError — Get the last error message
  • SphinxClient::getLastWarning — Get the last warning
  • SphinxClient::open — Opens persistent connection to the server
  • SphinxClient::query — Execute search query
  • SphinxClient::resetFilters — Clear all filters
  • SphinxClient::resetGroupBy — Clear all group-by settings
  • SphinxClient::runQueries — Run a batch of search queries
  • SphinxClient::setArrayResult — Change the format of result set array
  • SphinxClient::setConnectTimeout — Set connection timeout
  • SphinxClient::setFieldWeights — Set field weights
  • SphinxClient::setFilter — Add new integer values set filter
  • SphinxClient::setFilterFloatRange — Add new float range filter
  • SphinxClient::setFilterRange — Add new integer range filter
  • SphinxClient::setGeoAnchor — Set anchor point for a geosphere distance calculations
  • SphinxClient::setGroupBy — Set grouping attribute
  • SphinxClient::setGroupDistinct — Set attribute name for per-group distinct values count calculations
  • SphinxClient::setIDRange — Set a range of accepted document IDs
  • SphinxClient::setIndexWeights — Set per-index weights
  • SphinxClient::setLimits — Set offset and limit of the result set
  • SphinxClient::setMatchMode — Set full-text query matching mode
  • SphinxClient::setMaxQueryTime — Set maximum query time
  • SphinxClient::setOverride — Sets temporary per-document attribute value overrides
  • SphinxClient::setRankingMode — Set ranking mode
  • SphinxClient::setRetries — Set retry count and delay
  • SphinxClient::setSelect — Set select clause
  • SphinxClient::setServer — Set searchd host and port
  • SphinxClient::setSortMode — Set matches sorting mode
  • SphinxClient::status — Queries searchd status
  • SphinxClient::updateAttributes — Update document attributes
Örnekler
SphinxClient::addQuery
Sphinx


Add query to multi-query batch

SphinxClient
SphinxClient::buildExcerpts
SphinxClient
PHP Manual

SphinxClient::addQuery

(PECL sphinx >= 0.1.0)

SphinxClient::addQuery — Add query to multi-query batch

Açıklama

public int SphinxClient::addQuery ( string $query [, string $index = "*" [, string $comment = "" ]] )

Adds query with the current settings to multi-query batch. This method doesn't affect current settings (sorting, filtering, grouping etc.) in any way.

Değiştirgeler

query

Query string.

index

An index name (or names).

comment

Dönen Değerler

Returns an index in an array of results that will be returned by SphinxClient::runQueries call or false on error.

Ayrıca Bakınız

  • SphinxClient::runQueries
  • SphinxClient::query

SphinxClient
SphinxClient::buildExcerpts
SphinxClient


Build text snippets

SphinxClient::addQuery
SphinxClient::buildKeywords
SphinxClient
PHP Manual

SphinxClient::buildExcerpts

(PECL sphinx >= 0.1.0)

SphinxClient::buildExcerpts — Build text snippets

Açıklama

public array SphinxClient::buildExcerpts ( array $docs , string $index , string $words [, array $opts ] )

Connects to searchd, requests it to generate excerpts (snippets) from the given documents, and returns the results.

Değiştirgeler

docs

Array of strings with documents' contents.

index

Index name.

words

Keywords to highlight.

opts

Associative array of additional highlighting options (see below).

Highlighting options
Option | Description
"before_match" | A string to insert before a keyword match. Default is "<b>".
"after_match" | A string to insert after a keyword match. Default is "</b>".
"chunk_separator" | A string to insert between snippet chunks (passages). Default is " ... ".
"limit" | Maximum snippet size, in symbols (codepoints). Integer, default is 256.
"around" | How much words to pick around each matching keywords block. Integer, default is 5.
"exact_phrase" | Whether to highlight exact query phrase matches only instead of individual keywords. Boolean, default is FALSE.
"single_passage" | Whether to extract single best passage only. Boolean, default is FALSE.

Dönen Değerler

Returns array of snippets on success başarısızlık durumunda FALSE döner.

SphinxClient::addQuery
SphinxClient::buildKeywords
SphinxClient


Extract keywords from query

SphinxClient::buildExcerpts
SphinxClient::close
SphinxClient
PHP Manual

SphinxClient::buildKeywords

(PECL sphinx >= 0.1.0)

SphinxClient::buildKeywords — Extract keywords from query

Açıklama

public array SphinxClient::buildKeywords ( string $query , string $index , bool $hits )

Extracts keywords from query using tokenizer settings for the given index, optionally with per-keyword occurrence statistics.

Değiştirgeler

query

A query to extract keywords from.

index

An index to get tokenizing settings and keyword occurrence statistics from.

hits

A boolean flag to enable/disable keyword statistics generation.

Dönen Değerler

Returns an array of associative arrays with per-keyword information.

SphinxClient::buildExcerpts
SphinxClient::close
SphinxClient


Closes previously opened persistent connection

SphinxClient::buildKeywords
SphinxClient::__construct
SphinxClient
PHP Manual

SphinxClient::close

(PECL sphinx >= 1.0.3)

SphinxClient::close — Closes previously opened persistent connection

Açıklama

public bool SphinxClient::close ( void )

Closes previously opened persistent connection.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Sürüm Bilgisi

PECL/sphinx Sürüm: | Açıklama
1.0.3 | Added SphinxClient::close(), available only if compiled with libsphinxclient >= 0.9.9.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • SphinxClient::open

SphinxClient::buildKeywords
SphinxClient::__construct
SphinxClient


Create a new SphinxClient object

SphinxClient::close
SphinxClient::escapeString
SphinxClient
PHP Manual

SphinxClient::__construct

(PECL sphinx >= 0.1.0)

SphinxClient::__construct — Create a new SphinxClient object

Açıklama

public SphinxClient::__construct ( void )

Creates a new SphinxClient object.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

SphinxClient::close
SphinxClient::escapeString
SphinxClient


Escape special characters

SphinxClient::__construct
SphinxClient::getLastError
SphinxClient
PHP Manual

SphinxClient::escapeString

(PECL sphinx >= 0.1.0)

SphinxClient::escapeString — Escape special characters

Açıklama

public string SphinxClient::escapeString ( string $string )

Escapes characters that are treated as special operators by the query language parser.

Değiştirgeler

string

String to escape.

Dönen Değerler

Returns escaped string.

SphinxClient::__construct
SphinxClient::getLastError
SphinxClient


Get the last error message

SphinxClient::escapeString
SphinxClient::getLastWarning
SphinxClient
PHP Manual

SphinxClient::getLastError

(PECL sphinx >= 0.1.0)

SphinxClient::getLastError — Get the last error message

Açıklama

public string SphinxClient::getLastError ( void )

Returns string with the last error message. If there were no errors during the previous API call, empty string is returned. This method doesn't reset the error message, so you can safely call it several times.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the last error message or an empty string if there were no errors.

Ayrıca Bakınız

  • SphinxClient::getLastWarning

SphinxClient::escapeString
SphinxClient::getLastWarning
SphinxClient


Get the last warning

SphinxClient::getLastError
SphinxClient::open
SphinxClient
PHP Manual

SphinxClient::getLastWarning

(PECL sphinx >= 0.1.0)

SphinxClient::getLastWarning — Get the last warning

Açıklama

public string SphinxClient::getLastWarning ( void )

Returns last warning message. If there were no warnings during the previous API call, empty string is returned. This method doesn't reset the warning, so you can safely call it several times.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the last warning message or an empty string if there were no warnings.

Ayrıca Bakınız

  • SphinxClient::getLastError

SphinxClient::getLastError
SphinxClient::open
SphinxClient


Opens persistent connection to the server

SphinxClient::getLastWarning
SphinxClient::query
SphinxClient
PHP Manual

SphinxClient::open

(PECL sphinx >= 1.0.3)

SphinxClient::open — Opens persistent connection to the server

Açıklama

public bool SphinxClient::open ( void )

Opens persistent connection to the server.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Sürüm Bilgisi

PECL/sphinx Sürüm: | Açıklama
1.0.3 | Added SphinxClient::open(), available only if compiled with libsphinxclient >= 0.9.9.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • SphinxClient::close

SphinxClient::getLastWarning
SphinxClient::query
SphinxClient


Execute search query

SphinxClient::open
SphinxClient::resetFilters
SphinxClient
PHP Manual

SphinxClient::query

(PECL sphinx >= 0.1.0)

SphinxClient::query — Execute search query

Açıklama

public array SphinxClient::query ( string $query [, string $index = "*" [, string $comment = "" ]] )

Connects to searchd server, runs the given search query with the current settings, obtains and returns the result set.

Değiştirgeler

query

Query string.

index

An index name (or names).

comment

Dönen Değerler

On success, SphinxClient::query() returns a list of found matches and additional per-query statistics. The result set is a hash utilize other structures instead of hash) with the following keys and values:

Result set structure
Key | Value description
"matches" | An array with found document IDs as keys and their weight and attributes values as values
"total" | Total number of matches found and retrieved (depends on your settings)
"total_found" | Total number of found documents matching the query
"words" | An array with words (case-folded and stemmed) as keys and per-word statistics as values
"error" | Query error message reported by searchd
"warning" | Query warning reported by searchd

Ayrıca Bakınız

  • SphinxClient::runQueries
  • SphinxClient::addQuery

SphinxClient::open
SphinxClient::resetFilters
SphinxClient


Clear all filters

SphinxClient::query
SphinxClient::resetGroupBy
SphinxClient
PHP Manual

SphinxClient::resetFilters

(PECL sphinx >= 0.1.0)

SphinxClient::resetFilters — Clear all filters

Açıklama

public void SphinxClient::resetFilters ( void )

Clears all currently set filters. This call is normally required when using multi-queries. You might want to set different filters for different queries in the batch. To do that, you should call SphinxClient::resetFilters() and add new filters using the respective calls.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SphinxClient::resetGroupBy

SphinxClient::query
SphinxClient::resetGroupBy
SphinxClient


Clear all group-by settings

SphinxClient::resetFilters
SphinxClient::runQueries
SphinxClient
PHP Manual

SphinxClient::resetGroupBy

(PECL sphinx >= 0.1.0)

SphinxClient::resetGroupBy — Clear all group-by settings

Açıklama

public void SphinxClient::resetGroupBy ( void )

Clears all currently group-by settings, and disables group-by. This call is normally required only when using multi-queries.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SphinxClient::resetGroupBy

SphinxClient::resetFilters
SphinxClient::runQueries
SphinxClient


Run a batch of search queries

SphinxClient::resetGroupBy
SphinxClient::setArrayResult
SphinxClient
PHP Manual

SphinxClient::runQueries

(PECL sphinx >= 0.1.0)

SphinxClient::runQueries — Run a batch of search queries

Açıklama

public array SphinxClient::runQueries ( void )

Connects to searchd, runs a batch of all queries added using SphinxClient::addQuery, obtains and returns the result sets.

Dönen Değerler

Returns FALSE on failure and array of result sets on success.

Ayrıca Bakınız

  • SphinxClient::addQuery
  • SphinxClient::query

SphinxClient::resetGroupBy
SphinxClient::setArrayResult
SphinxClient


Change the format of result set array

SphinxClient::runQueries
SphinxClient::setConnectTimeout
SphinxClient
PHP Manual

SphinxClient::setArrayResult

(PECL sphinx >= 0.1.0)

SphinxClient::setArrayResult — Change the format of result set array

Açıklama

public bool SphinxClient::setArrayResult ( bool $array_result = false )

Controls the format of search results set arrays (whether matches should be returned as an array or a hash).

Değiştirgeler

array_result

If array_result is FALSE, matches are returned as a hash with document IDs as keys, and other information (weight, attributes) as values. If array_result is TRUE, matches are returned as a plain array with complete per-match information including document IDs.

Dönen Değerler

Always returns TRUE.

SphinxClient::runQueries
SphinxClient::setConnectTimeout
SphinxClient


Set connection timeout

SphinxClient::setArrayResult
SphinxClient::setFieldWeights
SphinxClient
PHP Manual

SphinxClient::setConnectTimeout

(PECL sphinx >= 0.1.0)

SphinxClient::setConnectTimeout — Set connection timeout

Açıklama

public bool SphinxClient::setConnectTimeout ( float $timeout )

Sets connection timeout (in seconds) for searchd connection.

Değiştirgeler

timeout

Timeout in seconds.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • SphinxClient::setMaxQueryTime

SphinxClient::setArrayResult
SphinxClient::setFieldWeights
SphinxClient


Set field weights

SphinxClient::setConnectTimeout
SphinxClient::setFilter
SphinxClient
PHP Manual

SphinxClient::setFieldWeights

(PECL sphinx >= 0.1.0)

SphinxClient::setFieldWeights — Set field weights

Açıklama

public bool SphinxClient::setFieldWeights ( array $weights )

Binds per-field weights by name.

Match ranking can be affected by per-field weights. See » Sphinx documentation for an explanation on how phrase proximity ranking is affected. This call lets you specify non-default weights for full-text fields.

The weights must be positive 32-bit integers, so be careful not to hit 32-bit integer maximum. The final weight is a 32-bit integer too. Default weight value is 1. Unknown field names are silently ignored.

Değiştirgeler

weights

Associative array of field names and field weights.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • SphinxClient::setIndexWeights

SphinxClient::setConnectTimeout
SphinxClient::setFilter
SphinxClient


Add new integer values set filter

SphinxClient::setFieldWeights
SphinxClient::setFilterFloatRange
SphinxClient
PHP Manual

SphinxClient::setFilter

(PECL sphinx >= 0.1.0)

SphinxClient::setFilter — Add new integer values set filter

Açıklama

public bool SphinxClient::setFilter ( string $attribute , array $values [, bool $exclude = false ] )

Adds new integer values set filter to the existing list of filters.

Değiştirgeler

attribute

An attribute name.

values

Plain array of integer values.

exclude

If set to TRUE, matching documents are excluded from the result set.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • SphinxClient::setFilterFloatRange
  • SphinxClient::setFilterRange
  • SphinxClient::resetFilters

SphinxClient::setFieldWeights
SphinxClient::setFilterFloatRange
SphinxClient


Add new float range filter

SphinxClient::setFilter
SphinxClient::setFilterRange
SphinxClient
PHP Manual

SphinxClient::setFilterFloatRange

(PECL sphinx >= 0.1.0)

SphinxClient::setFilterFloatRange — Add new float range filter

Açıklama

public bool SphinxClient::setFilterFloatRange ( string $attribute , float $min , float $max [, bool $exclude = false ] )

Adds new float range filter to the existing list of filters. Only those documents which have attribute value stored in the index between min and max (including values that are exactly equal to min or max) will be matched (or rejected, if exclude is TRUE).

Değiştirgeler

attribute

An attribute name.

min

Minimum value.

max

Maximum value.

exclude

If set to TRUE, matching documents are excluded from the result set.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • SphinxClient::setFilterRange
  • SphinxClient::setFilter
  • SphinxClient::resetFilters

SphinxClient::setFilter
SphinxClient::setFilterRange
SphinxClient


Add new integer range filter

SphinxClient::setFilterFloatRange
SphinxClient::setGeoAnchor
SphinxClient
PHP Manual

SphinxClient::setFilterRange

(PECL sphinx >= 0.1.0)

SphinxClient::setFilterRange — Add new integer range filter

Açıklama

public bool SphinxClient::setFilterRange ( string $attribute , int $min , int $max [, bool $exclude = false ] )

Adds new integer range filter to the existing list of filters. Only those documents which have attribute value stored in the index between min and max (including values that are exactly equal to min or max) will be matched (or rejected, if exclude is TRUE).

Değiştirgeler

attribute

An attribute name.

min

Minimum value.

max

Maximum value.

exclude

If set to TRUE, matching documents are excluded from the result set.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • SphinxClient::setFilterFloatRange
  • SphinxClient::setFilter
  • SphinxClient::resetFilters

SphinxClient::setFilterFloatRange
SphinxClient::setGeoAnchor
SphinxClient


Set anchor point for a geosphere distance calculations

SphinxClient::setFilterRange
SphinxClient::setGroupBy
SphinxClient
PHP Manual

SphinxClient::setGeoAnchor

(PECL sphinx >= 0.1.0)

SphinxClient::setGeoAnchor — Set anchor point for a geosphere distance calculations

Açıklama

public bool SphinxClient::setGeoAnchor ( string $attrlat , string $attrlong , float $latitude , float $longitude )

Sets anchor point for a geosphere distance (geodistance) calculations and enables them.

Once an anchor point is set, you can use magic "@geodist" attribute name in your filters and/or sorting expressions.

Değiştirgeler

attrlat

Name of a latitude attribute.

attrlong

Name of a longitude attribute.

latitude

Anchor latitude in radians.

longitude

Anchor longitude in radians.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • SphinxClient::setFilterFloatRange
  • SphinxClient::setFilterRange
  • SphinxClient::setFilter
  • SphinxClient::resetFilters

SphinxClient::setFilterRange
SphinxClient::setGroupBy
SphinxClient


Set grouping attribute

SphinxClient::setGeoAnchor
SphinxClient::setGroupDistinct
SphinxClient
PHP Manual

SphinxClient::setGroupBy

(PECL sphinx >= 0.1.0)

SphinxClient::setGroupBy — Set grouping attribute

Açıklama

public bool SphinxClient::setGroupBy ( string $attribute , int $func [, string $groupsort = "@group desc" ] )

Sets grouping attribute, function, and group sorting mode, and enables grouping.

Grouping feature is very similar to GROUP BY clause in SQL. Results produced by this function call are going to be the same as produced by the following pseudo code: SELECT ... GROUP BY $func($attribute) ORDER BY $groupsort.

Değiştirgeler

attribute

A string containing group-by attribute name.

func

Constant, which sets a function applied to the attribute value in order to compute group-by key.

groupsort

An optional clause controlling how the groups are sorted.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • SphinxClient::resetGroupBy
  • SphinxClient::setSortMode
  • SphinxClient::setGroupDistinct

SphinxClient::setGeoAnchor
SphinxClient::setGroupDistinct
SphinxClient


Set attribute name for per-group distinct values count calculations

SphinxClient::setGroupBy
SphinxClient::setIDRange
SphinxClient
PHP Manual

SphinxClient::setGroupDistinct

(PECL sphinx >= 0.1.0)

SphinxClient::setGroupDistinct — Set attribute name for per-group distinct values count calculations

Açıklama

public bool SphinxClient::setGroupDistinct ( string $attribute )

Sets attribute name for per-group distinct values count calculations. Only available for grouping queries. For each group, all values of attribute will be stored, then the amount of distinct values will be calculated and returned to the client. This feature is similar to COUNT(DISTINCT) clause in SQL.

Değiştirgeler

attribute

A string containing group-by attribute name.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • SphinxClient::setSortMode
  • SphinxClient::setGroupBy
  • SphinxClient::resetGroupBy

SphinxClient::setGroupBy
SphinxClient::setIDRange
SphinxClient


Set a range of accepted document IDs

SphinxClient::setGroupDistinct
SphinxClient::setIndexWeights
SphinxClient
PHP Manual

SphinxClient::setIDRange

(PECL sphinx >= 0.1.0)

SphinxClient::setIDRange — Set a range of accepted document IDs

Açıklama

public bool SphinxClient::setIDRange ( int $min , int $max )

Sets an accepted range of document IDs. Default range is from 0 to 0, i.e. no limit. Only those records that have document ID between min and max (including IDs exactly equal to min or max) will be matched.

Değiştirgeler

min

Minimum ID value.

max

Maximum ID value.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

SphinxClient::setGroupDistinct
SphinxClient::setIndexWeights
SphinxClient


Set per-index weights

SphinxClient::setIDRange
SphinxClient::setLimits
SphinxClient
PHP Manual

SphinxClient::setIndexWeights

(PECL sphinx >= 0.1.0)

SphinxClient::setIndexWeights — Set per-index weights

Açıklama

public bool SphinxClient::setIndexWeights ( array $weights )

Sets per-index weights and enables weighted summing of match weights across different indexes.

Değiştirgeler

weights

An associative array mapping string index names to integer weights. Default is empty array, i.e. weighting summing is disabled.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

SphinxClient::setIDRange
SphinxClient::setLimits
SphinxClient


Set offset and limit of the result set

SphinxClient::setIndexWeights
SphinxClient::setMatchMode
SphinxClient
PHP Manual

SphinxClient::setLimits

(PECL sphinx >= 0.1.0)

SphinxClient::setLimits — Set offset and limit of the result set

Açıklama

public bool SphinxClient::setLimits ( int $offset , int $limit [, int $max_matches = 0 [, int $cutoff = 0 ]] )

Sets offset into server-side result set and amount of matches to return to client starting from that offset (limit). Can additionally control maximum server-side result set size for current query (max_matches) and the threshold amount of matches to stop searching at (cutoff).

Değiştirgeler

offset

Result set offset.

limit

Amount of matches to return.

max_matches

Controls how much matches searchd will keep in RAM while searching.

cutoff

Used for advanced performance control. It tells searchd to forcibly stop search query once cutoff matches have been found and processed.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

SphinxClient::setIndexWeights
SphinxClient::setMatchMode
SphinxClient


Set full-text query matching mode

SphinxClient::setLimits
SphinxClient::setMaxQueryTime
SphinxClient
PHP Manual

SphinxClient::setMatchMode

(PECL sphinx >= 0.1.0)

SphinxClient::setMatchMode — Set full-text query matching mode

Açıklama

public bool SphinxClient::setMatchMode ( int $mode )

Sets full-text query matching mode. mode is one of the constants listed below.

Match modes
Constant | Description
SPH_MATCH_ALL | Match all query words (default mode).
SPH_MATCH_ANY | Match any of query words.
SPH_MATCH_PHRASE | Match query as a phrase, requiring perfect match.
SPH_MATCH_BOOLEAN | Match query as a boolean expression.
SPH_MATCH_EXTENDED | Match query as an expression in Sphinx internal query language.
SPH_MATCH_FULLSCAN | Enables fullscan.
SPH_MATCH_EXTENDED2 | The same as SPH_MATCH_EXTENDED plus ranking and quorum searching support.

Değiştirgeler

mode

Matching mode.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • SphinxClient::setRankingMode
  • SphinxClient::setSortMode

SphinxClient::setLimits
SphinxClient::setMaxQueryTime
SphinxClient


Set maximum query time

SphinxClient::setMatchMode
SphinxClient::setOverride
SphinxClient
PHP Manual

SphinxClient::setMaxQueryTime

(PECL sphinx >= 0.1.0)

SphinxClient::setMaxQueryTime — Set maximum query time

Açıklama

public bool SphinxClient::setMaxQueryTime ( int $qtime )

Sets maximum search query time.

Değiştirgeler

qtime

Maximum query time, in milliseconds. It must be a non-negative integer. Default value is 0, i.e. no limit.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

SphinxClient::setMatchMode
SphinxClient::setOverride
SphinxClient


Sets temporary per-document attribute value overrides

SphinxClient::setMaxQueryTime
SphinxClient::setRankingMode
SphinxClient
PHP Manual

SphinxClient::setOverride

(PECL sphinx >= 1.0.3)

SphinxClient::setOverride — Sets temporary per-document attribute value overrides

Açıklama

public bool SphinxClient::setOverride ( string $attribute , int $type , array $values )

Sets temporary (per-query) per-document attribute value overrides. Override feature lets you "temporary" update attribute values for some documents within a single query, leaving all other queries unaffected. This might be useful for personalized data

Değiştirgeler

attribute

An attribute name.

type

An attribute type. Only supports scalar attributes.

values

Array of attribute values that maps document IDs to overridden attribute values.

Sürüm Bilgisi

PECL/sphinx Sürüm: | Açıklama
1.0.3 | Added SphinxClient::setOverride(), available only if compiled with libsphinxclient >= 0.9.9.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

SphinxClient::setMaxQueryTime
SphinxClient::setRankingMode
SphinxClient


Set ranking mode

SphinxClient::setOverride
SphinxClient::setRetries
SphinxClient
PHP Manual

SphinxClient::setRankingMode

(PECL sphinx >= 0.1.0)

SphinxClient::setRankingMode — Set ranking mode

Açıklama

public bool SphinxClient::setRankingMode ( int $ranker )

Sets ranking mode. Only available in SPH_MATCH_EXTENDED2 matching mode.

Ranking modes
Constant | Description
SPH_RANK_PROXIMITY_BM25 | Default ranking mode which uses both proximity and BM25 ranking.
SPH_RANK_BM25 | Statistical ranking mode which uses BM25 ranking only (similar to most of other full-text engines). This mode is faster, but may result in worse quality on queries which contain more than 1 keyword.
SPH_RANK_NONE | Disables ranking. This mode is the fastest. It is essentially equivalent to boolean searching, a weight of 1 is assigned to all matches.

Değiştirgeler

ranker

Ranking mode.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • SphinxClient::setMatchMode

SphinxClient::setOverride
SphinxClient::setRetries
SphinxClient


Set retry count and delay

SphinxClient::setRankingMode
SphinxClient::setSelect
SphinxClient
PHP Manual

SphinxClient::setRetries

(PECL sphinx >= 0.1.0)

SphinxClient::setRetries — Set retry count and delay

Açıklama

public bool SphinxClient::setRetries ( int $count [, int $delay = 0 ] )

Sets distributed retry count and delay.

On temporary failures searchd will attempt up to count retries per agent. delay is the delay between the retries, in milliseconds. Retries are disabled by default. Note that this call will not make the API itself retry on temporary failure; it only tells searchd to do so.

Değiştirgeler

count

Number of retries.

delay

Delay between retries, in milliseconds.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

SphinxClient::setRankingMode
SphinxClient::setSelect
SphinxClient


Set select clause

SphinxClient::setRetries
SphinxClient::setServer
SphinxClient
PHP Manual

SphinxClient::setSelect

(PECL sphinx >= 1.0.1)

SphinxClient::setSelect — Set select clause

Açıklama

public bool SphinxClient::setSelect ( string $clause )

Sets the select clause, listing specific attributes to fetch, and expressions to compute and fetch.

Değiştirgeler

clause

SQL-like clause.

Sürüm Bilgisi

PECL/sphinx Sürüm: | Açıklama
1.0.1 | Added SphinxClient::setSelect(), available only if compiled with libsphinxclient >= 0.9.9.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

SphinxClient::setRetries
SphinxClient::setServer
SphinxClient


Set searchd host and port

SphinxClient::setSelect
SphinxClient::setSortMode
SphinxClient
PHP Manual

SphinxClient::setServer

(PECL sphinx >= 0.1.0)

SphinxClient::setServer — Set searchd host and port

Açıklama

public bool SphinxClient::setServer ( string $server , int $port )

Sets searchd host name and TCP port. All subsequent requests will use the new host and port settings. Default host and port are 'localhost' and 3312, respectively.

Değiştirgeler

server

IP or hostname.

port

Port number.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

SphinxClient::setSelect
SphinxClient::setSortMode
SphinxClient


Set matches sorting mode

SphinxClient::setServer
SphinxClient::status
SphinxClient
PHP Manual

SphinxClient::setSortMode

(PECL sphinx >= 0.1.0)

SphinxClient::setSortMode — Set matches sorting mode

Açıklama

public bool SphinxClient::setSortMode ( int $mode [, string $sortby ] )

Sets matches sorting mode. See available modes below.

Sorting modes
Constant | Description
SPH_SORT_RELEVANCE | Sort by relevance in descending order (best matches first).
SPH_SORT_ATTR_DESC | Sort by an attribute in descending order (bigger attribute values first).
SPH_SORT_ATTR_ASC | Sort by an attribute in ascending order (smaller attribute values first).
SPH_SORT_TIME_SEGMENTS | Sort by time segments (last hour/day/week/month) in descending order, and then by relevance in descending order.
SPH_SORT_EXTENDED | Sort by SQL-like combination of columns in ASC/DESC order.
SPH_SORT_EXPR | Sort by an arithmetic expression.

Değiştirgeler

mode

Sorting mode.

sortby

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • SphinxClient::setMatchMode
  • SphinxClient::setSortMode

SphinxClient::setServer
SphinxClient::status
SphinxClient


Queries searchd status

SphinxClient::setSortMode
SphinxClient::updateAttributes
SphinxClient
PHP Manual

SphinxClient::status

(PECL sphinx >= 1.0.3)

SphinxClient::status — Queries searchd status

Açıklama

public array SphinxClient::status ( void )

Queries searchd status, and returns an array of status variable name and value pairs.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Sürüm Bilgisi

PECL/sphinx Sürüm: | Açıklama
1.0.3 | Added SphinxClient::status(), available only if compiled with libsphinxclient >= 0.9.9.

Dönen Değerler

Returns an associative array of search server statistics başarısızlık durumunda FALSE döner.

SphinxClient::setSortMode
SphinxClient::updateAttributes
SphinxClient


Update document attributes

SphinxClient::status
Swish
SphinxClient
PHP Manual

SphinxClient::updateAttributes

(PECL sphinx >= 0.1.0)

SphinxClient::updateAttributes — Update document attributes

Açıklama

public int SphinxClient::updateAttributes ( string $index , array $attributes , array $values [, bool $mva = false ] )

Instantly updates given attribute values in given documents.

Değiştirgeler

index

Name of the index (or indexes) to be updated.

attributes

Array of attribute names, listing attributes that are updated.

values

Associative array containing document IDs as keys and array of attribute values as values.

Dönen Değerler

Returns number of actually updated documents (0 or more) on success, or FALSE on failure.

SphinxClient::status
Swish
SphinxClient


Swish Indexing

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
    • Basic usage
  • Swish İşlevleri
    • Swish::__construct — Construct a Swish object
    • Swish::getMetaList — Get the list of meta entries for the index
    • Swish::getPropertyList — Get the list of properties for the index
    • Swish::prepare — Prepare a search query
    • Swish::query — Execute a query and return results object
    • SwishResult::getMetaList — Get a list of meta entries
    • SwishResult::stem — Stems the given word
    • SwishResults::getParsedWords — Get an array of parsed words
    • SwishResults::getRemovedStopwords — Get an array of stopwords removed from the query
    • SwishResults::nextResult — Get the next search result
    • SwishResults::seekResult — Set current seek pointer to the given position
    • SwishSearch::execute — Execute the search and get the results
    • SwishSearch::resetLimit — Reset the search limits
    • SwishSearch::setLimit — Set the search limits
    • SwishSearch::setPhraseDelimiter — Set the phrase delimiter
    • SwishSearch::setSort — Set the sort order
    • SwishSearch::setStructure — Set the structure flag in the search object
SphinxClient::updateAttributes
Giriş
Arama Motoru Eklentileri


Giriş

The swish extension provides the bindings for Swish-e API. Swish-e stands for "Simple Web Indexing System for Humans - Enhanced" and is an open source system for indexing and search. Swish-e itself is licensed under GPL license, but uses a clause that allows applications to link against the library if every copy of the combined work is accompanied by the URL to Swish-e source code. Here it is: » http://swish-e.org.

Uyarı

Bu eklenti DENEYSELDİR. Bu eklentinin davranışı, işlev isimleri ve tüm belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu eklentiyi kullanmayın.

Swish
Yapılandırma/Kurulum
Swish


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Swish


Gereksinimler

PECL/swish requires PHP 5.1.3 or newer.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/swish.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

Swish::META_TYPE_UNDEF (integer)
Swish::META_TYPE_STRING (integer)
Swish::META_TYPE_ULONG (integer)
Swish::META_TYPE_DATE (integer)
Swish::IN_FILE_BIT (integer)
Swish::IN_TITLE_BIT (integer)
Swish::IN_HEAD_BIT (integer)
Swish::IN_BODY_BIT (integer)
Swish::IN_COMMENTS_BIT (integer)
Swish::IN_HEADER_BIT (integer)
Swish::IN_EMPHASIZED_BIT (integer)
Swish::IN_META_BIT (integer)
Swish::IN_FILE (integer)
Swish::IN_TITLE (integer)
Swish::IN_HEAD (integer)
Swish::IN_BODY (integer)
Swish::IN_COMMENTS (integer)
Swish::IN_HEADER (integer)
Swish::IN_EMPHASIZED (integer)
Swish::IN_META (integer)
Swish::IN_ALL (integer)
Özkaynak Türleri
Örnekler
Swish


Örnekler

İçindekiler

  • Basic usage
Öntanımlı Sabitler
Basic usage
Swish


Basic usage

Örnek 1 Basic search query

<?php

try {

    $swish = new Swish("index.swish-e");
    $results = $swish->query("test OR text");

    echo "Found ", $results->hits, " results\n";
    while ($result = $results->nextResult()) {
        var_dump($result);
        break; //break after the first result
    }

} catch (SwishException $e) {
    echo "Error: ", $e->getMessage(), "\n";
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Found 9 results
object(SwishResult)#3 (8) {
  ["swishreccount"]=>
  int(1)
  ["swishrank"]=>
  int(1000)
  ["swishfilenum"]=>
  int(10)
  ["swishdbfile"]=>
  string(13) "index.swish-e"
  ["swishdocpath"]=>
  string(23) "README.SUBMITTING_PATCH"
  ["swishtitle"]=>
  NULL
  ["swishdocsize"]=>
  int(4557)
  ["swishlastmodified"]=>
  int(1072136752)
}
Örnekler
Swish İşlevleri
Örnekler


Swish İşlevleri

İçindekiler

  • Swish::__construct — Construct a Swish object
  • Swish::getMetaList — Get the list of meta entries for the index
  • Swish::getPropertyList — Get the list of properties for the index
  • Swish::prepare — Prepare a search query
  • Swish::query — Execute a query and return results object
  • SwishResult::getMetaList — Get a list of meta entries
  • SwishResult::stem — Stems the given word
  • SwishResults::getParsedWords — Get an array of parsed words
  • SwishResults::getRemovedStopwords — Get an array of stopwords removed from the query
  • SwishResults::nextResult — Get the next search result
  • SwishResults::seekResult — Set current seek pointer to the given position
  • SwishSearch::execute — Execute the search and get the results
  • SwishSearch::resetLimit — Reset the search limits
  • SwishSearch::setLimit — Set the search limits
  • SwishSearch::setPhraseDelimiter — Set the phrase delimiter
  • SwishSearch::setSort — Set the sort order
  • SwishSearch::setStructure — Set the structure flag in the search object
Basic usage
Swish::__construct
Swish


Construct a Swish object

Swish İşlevleri
Swish::getMetaList
Swish İşlevleri
PHP Manual

Swish::__construct

(PECL swish >= 0.1.0)

Swish::__construct — Construct a Swish object

Açıklama

void Swish::__construct ( string $index_names )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Değiştirgeler

index_names

The list of index files separated by spaces.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

Throws SwishException on error.

Örnekler

Örnek 1 A Swish::__construct() example

<?php

try {
    $swish = new Swish("index1 index2");
} catch (SwishException $e) {
    echo $e->getMessage(), "\n";
}

foreach ($swish->indexes as $index) {
    var_dump($index["name"]);
    var_dump($index["headers"]["Total Words"]);
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(6) "index1"
int(1888)
string(6) "index2"
int(2429)

Swish İşlevleri
Swish::getMetaList
Swish İşlevleri


Get the list of meta entries for the index

Swish::__construct
Swish::getPropertyList
Swish İşlevleri
PHP Manual

Swish::getMetaList

(PECL swish >= 0.1.0)

Swish::getMetaList — Get the list of meta entries for the index

Açıklama

array Swish::getMetaList ( string $index_name )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Değiştirgeler

index_name

The name of the index file.

Dönen Değerler

Returns an array of meta entries for the given index.

Örnekler

Örnek 1 Basic Swish::getMetaList() example

<?php

try {

    $swish = new Swish("index.swish-e");
    var_dump($swish->getMetaList("index.swish-e"));

} catch (SwishException $e) {
    echo $e->getMessage(), "\n";
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(1) {
  [0]=>
  array(3) {
    ["Name"]=>
    string(12) "swishdefault"
    ["Type"]=>
    int(0)
    ["ID"]=>
    int(1)
  }
}

Swish::__construct
Swish::getPropertyList
Swish İşlevleri


Get the list of properties for the index

Swish::getMetaList
Swish::prepare
Swish İşlevleri
PHP Manual

Swish::getPropertyList

(PECL swish >= 0.1.0)

Swish::getPropertyList — Get the list of properties for the index

Açıklama

array Swish::getPropertyList ( string $index_name )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Değiştirgeler

index_name

The name of the index file.

Dönen Değerler

Returns an array of properties for the given index.

Örnekler

Örnek 1 Basic Swish::getPropertyList() example

<?php

try {

    $swish = new Swish("index.swish-e");
    $properties = $swish->getPropertyList("index.swish-e");
    foreach ($properties as $prop) {
        echo $prop["Name"],"\n";
    }

} catch (SwishException $e) {
    echo $e->getMessage(), "\n";
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

swishreccount
swishrank
swishfilenum
swishdbfile
swishdocpath
swishtitle
swishdocsize
swishlastmodified

Swish::getMetaList
Swish::prepare
Swish İşlevleri


Prepare a search query

Swish::getPropertyList
Swish::query
Swish İşlevleri
PHP Manual

Swish::prepare

(PECL swish >= 0.1.0)

Swish::prepare — Prepare a search query

Açıklama

object Swish::prepare ([ string $query ] )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Prepare and return a search object, which you can later use for unlimited number of queries.

Değiştirgeler

query

Optional query string. The query can be also set using SwishSearch::execute() method.

Dönen Değerler

Returns SwishSearch object.

Hatalar/İstisnalar

Throws SwishException on error.

Örnekler

Örnek 1 Basic Swish::prepare() example

<?php

try {

    $swish = new Swish("index.swish-e");
    $search = $swish->prepare("search query");
    $results = $search->execute();
    echo "Found: ", $results->hits, " hits\n";

    $results = $search->execute("new search");

    echo "Found: ", $results->hits, " hits\n";
} catch (SwishException $e) {
    echo $e->getMessage(), "\n";
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Found: 2 hits
Found: 5 hits

Swish::getPropertyList
Swish::query
Swish İşlevleri


Execute a query and return results object

Swish::prepare
SwishResult::getMetaList
Swish İşlevleri
PHP Manual

Swish::query

(PECL swish >= 0.1.0)

Swish::query — Execute a query and return results object

Açıklama

object Swish::query ( string $query )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

A quick method to execute a search with default parameters.

Değiştirgeler

query

Query string.

Dönen Değerler

Returns SwishResults object.

Hatalar/İstisnalar

Throws SwishException on error.

Örnekler

Örnek 1 Basic Swish::query() example

<?php

try {

    $swish = new Swish("index.swish-e");
    $results = $swish->query("test query");

    echo "Found: ", $results->hits, " hits\n";

} catch (SwishException $e) {
    echo $e->getMessage(), "\n";
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Found: 1 hits

Swish::prepare
SwishResult::getMetaList
Swish İşlevleri


Get a list of meta entries

Swish::query
SwishResult::stem
Swish İşlevleri
PHP Manual

SwishResult::getMetaList

(PECL swish >= 0.1.0)

SwishResult::getMetaList — Get a list of meta entries

Açıklama

array SwishResult::getMetaList ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Dönen Değerler

Returns the same array as swish::getmetalist(), but uses the index file from the result handle.

Swish::query
SwishResult::stem
Swish İşlevleri


Stems the given word

SwishResult::getMetaList
SwishResults::getParsedWords
Swish İşlevleri
PHP Manual

SwishResult::stem

(PECL swish >= 0.1.0)

SwishResult::stem — Stems the given word

Açıklama

array SwishResult::stem ( string $word )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Stems the word based on the fuzzy mode used during indexing. Each result object is linked with its index, so the results are based on this index.

Değiştirgeler

word

The word to stem.

Dönen Değerler

Returns array containing the stemmed word variants (usually just one).

Hatalar/İstisnalar

Throws SwishException on error.

Örnekler

Örnek 1 Basic SwishResult::stem() example

<?php

try {

    $swish = new Swish("ext/swish/tests/index.swish-e");
    $results = $swish->query("testing OR others");

    if ($result = $results->nextResult()) {
        var_dump($result->stem("testing")); //the results fully depend on the stemmer used in the index
        var_dump($result->stem("others"));
    }

} catch (SwishException $e) {
    echo "Error: ", $e->getMessage(), "\n";
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(1) {
  [0]=>
  string(4) "test"
}
array(1) {
  [0]=>
  string(5) "other"
}

SwishResult::getMetaList
SwishResults::getParsedWords
Swish İşlevleri


Get an array of parsed words

SwishResult::stem
SwishResults::getRemovedStopwords
Swish İşlevleri
PHP Manual

SwishResults::getParsedWords

(PECL swish >= 0.1.0)

SwishResults::getParsedWords — Get an array of parsed words

Açıklama

array SwishResults::getParsedWords ( string $index_name )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Değiştirgeler

indexi_name

The name of the index used to initialize Swish object.

Dönen Değerler

An array of parsed words with stopwords removed. The list of parsed words may be useful for highlighting search terms in the results.

Örnekler

Örnek 1 Basic SwishResults::getParsedWords() example

<?php

try {

    $swish = new Swish("index.swish-e");
    $results = $swish->query("'some characters' and numbers");

    var_dump($results->getParsedWords("index.swish-e"));
    var_dump($results->indexes[0]['parsed_words']); //same result in a different way

} catch (SwishException $e) {
    echo "Error: ", $e->getMessage(), "\n";
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(4) {
  [0]=>
  string(4) "some"
  [1]=>
  string(10) "characters"
  [2]=>
  string(3) "and"
  [3]=>
  string(7) "numbers"
}
array(4) {
  [0]=>
  string(4) "some"
  [1]=>
  string(10) "characters"
  [2]=>
  string(3) "and"
  [3]=>
  string(7) "numbers"
}

SwishResult::stem
SwishResults::getRemovedStopwords
Swish İşlevleri


Get an array of stopwords removed from the query

SwishResults::getParsedWords
SwishResults::nextResult
Swish İşlevleri
PHP Manual

SwishResults::getRemovedStopwords

(PECL swish >= 0.1.0)

SwishResults::getRemovedStopwords — Get an array of stopwords removed from the query

Açıklama

array SwishResults::getRemovedStopwords ( string $index_name )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Değiştirgeler

index_name

The name of the index used to initialize Swish object.

Dönen Değerler

Returns array of stopwords removed from the query.

SwishResults::getParsedWords
SwishResults::nextResult
Swish İşlevleri


Get the next search result

SwishResults::getRemovedStopwords
SwishResults::seekResult
Swish İşlevleri
PHP Manual

SwishResults::nextResult

(PECL swish >= 0.1.0)

SwishResults::nextResult — Get the next search result

Açıklama

object SwishResults::nextResult ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Dönen Değerler

Returns the next SwishResult object in the result set or FALSE if there are no more results available.

Örnekler

Örnek 1 Basic SwishResults::nextResult() example

<?php

try {

    $swish = new Swish("index.swish-e");
    $search = $swish->prepare();

    $results = $search->execute("lost");
    while($result = $results->nextResult()) {
        /* do something with the result object */
    }

} catch (SwishException $e) {
    echo $e->getMessage(), "\n";
}

?>

SwishResults::getRemovedStopwords
SwishResults::seekResult
Swish İşlevleri


Set current seek pointer to the given position

SwishResults::nextResult
SwishSearch::execute
Swish İşlevleri
PHP Manual

SwishResults::seekResult

(PECL swish >= 0.1.0)

SwishResults::seekResult — Set current seek pointer to the given position

Açıklama

int SwishResults::seekResult ( int $position )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Değiştirgeler

position

Zero-based position number. Cannot be less than zero.

Dönen Değerler

Returns new position value on success.

Hatalar/İstisnalar

Throws SwishException on error.

Örnekler

Örnek 1 Basic SwishResults::seekResult() example

<?php

try {

    $swish = new Swish("index.swish-e");
    $search = $swish->prepare();

    $results = $search->execute("lost");

    var_dump($results->seekResult(0)); //this will succeed
    var_dump($results->seekResult(100)); //this will fail

} catch (SwishException $e) {
    echo "Error: ", $e->getMessage(), "\n";
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(0)
Error: No more results

SwishResults::nextResult
SwishSearch::execute
Swish İşlevleri


Execute the search and get the results

SwishResults::seekResult
SwishSearch::resetLimit
Swish İşlevleri
PHP Manual

SwishSearch::execute

(PECL swish >= 0.1.0)

SwishSearch::execute — Execute the search and get the results

Açıklama

object SwishSearch::execute ([ string $query ] )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Searches the index file(s) based on the parameters set in the search object.

Değiştirgeler

query

The query string is an optional parameter, it can be also set using Swish::prepare() method. The query string is preserved between executions, so you can set it once, but execute the search multiple times.

Dönen Değerler

Returns SwishResults object.

Hatalar/İstisnalar

Throws SwishException on error.

Örnekler

Örnek 1 Basic SwishSearch::execute() example

<?php

try {

    $swish = new Swish("index.swish-e");
    $search = $swish->prepare();

    $results = $search->execute("query");
    echo "First query found: ", $results->hits, " hits\n";

    $results = $search->execute("new OR query");
    echo "Second query found: ", $results->hits, " hits\n";

} catch (SwishException $e) {
    echo $e->getMessage(), "\n";
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

First query found: 2 hits
Second query found: 12 hits

SwishResults::seekResult
SwishSearch::resetLimit
Swish İşlevleri


Reset the search limits

SwishSearch::execute
SwishSearch::setLimit
Swish İşlevleri
PHP Manual

SwishSearch::resetLimit

(PECL swish >= 0.1.0)

SwishSearch::resetLimit — Reset the search limits

Açıklama

void SwishSearch::resetLimit ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Reset the search limits previous set by SwishSearch::setLimit.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Basic SwishSearch::resetLimit() example

<?php

try {

    $swish = new Swish("index.swish-e");
    $search = $swish->prepare();

    $results = $search->execute("time");
    echo "First query found: ", $results->hits, " hits\n";

    $search->setLimit("swishdocsize", "3000", "6000"); //limit by document size, from 3000 to 6000 bytes
    $results = $search->execute("time");
    echo "Second query found: ", $results->hits, " hits\n";

    $search->resetLimit();
    $results = $search->execute("time");
    echo "Third query found: ", $results->hits, " hits\n";

} catch (SwishException $e) {
    echo $e->getMessage(), "\n";
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

First query found: 5 hits
Second query found: 2 hits
Third query found: 5 hits

SwishSearch::execute
SwishSearch::setLimit
Swish İşlevleri


Set the search limits

SwishSearch::resetLimit
SwishSearch::setPhraseDelimiter
Swish İşlevleri
PHP Manual

SwishSearch::setLimit

(PECL swish >= 0.1.0)

SwishSearch::setLimit — Set the search limits

Açıklama

void SwishSearch::setLimit ( string $property , string $low , string $high )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Değiştirgeler

property

Search result property name.

low

The lowest value of the property.

high

The highest value of the property.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

Throws SwishException on error.

Örnekler

Örnek 1 Basic SwishSearch::setLimit() example

<?php
try {

    $swish = new Swish("index.swish-e");
    $search = $swish->prepare();

    $results = $search->execute("time");
    echo "First query found: ", $results->hits, " hits\n";

    $i = 0;
    while($result = $results->nextResult()) {
        echo "Hit #", ++$i, " - ", $result->swishdocsize, " bytes\n";
    }

    $search->setLimit("swishdocsize", "3000", "6000"); //limit by document size, from 3000 to 6000 bytes
    $results = $search->execute("time");
    echo "Second query found: ", $results->hits, " hits\n";

    $i = 0;
    while($result = $results->nextResult()) {
        echo "Hit #", ++$i, " - ", $result->swishdocsize, " bytes\n";
    }

} catch (SwishException $e) {
    echo $e->getMessage(), "\n";
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

First query found: 5 hits
Hit #1 - 4261 bytes
Hit #2 - 37937 bytes
Hit #3 - 7126 bytes
Hit #4 - 15427 bytes
Hit #5 - 4768 bytes
Second query found: 2 hits
Hit #1 - 4261 bytes
Hit #2 - 4768 bytes

SwishSearch::resetLimit
SwishSearch::setPhraseDelimiter
Swish İşlevleri


Set the phrase delimiter

SwishSearch::setLimit
SwishSearch::setSort
Swish İşlevleri
PHP Manual

SwishSearch::setPhraseDelimiter

(PECL swish >= 0.1.0)

SwishSearch::setPhraseDelimiter — Set the phrase delimiter

Açıklama

void SwishSearch::setPhraseDelimiter ( string $delimiter )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Değiştirgeler

delimiter

Phrase delimiter character. The default delimiter is double-quotes.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Basic SwishSearch::setPhraseDelimiter() example

<?php

try {

    $swish = new Swish("index.swish-e");
    $search = $swish->prepare();

    $results = $search->execute('"every time"'); //looking for "every time"
    echo "First query found: ", $results->hits, " hits\n";

    $search->setPhraseDelimiter("'");
    $results = $search->execute("'every time'"); //the same query, but using different delimiter
    echo "Second query found: ", $results->hits, " hits\n";

    $search->setPhraseDelimiter('"');
    $results = $search->execute("'every time'"); //looking for "every" and "time"
    echo "Third query found: ", $results->hits, " hits\n";

    //let's look at parsed words
    var_dump($results->getParsedWords("index.swish-e"));

} catch (SwishException $e) {
    echo $e->getMessage(), "\n";
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

First query found: 1 hits
Second query found: 1 hits
Third query found: 2 hits
array(2) {
  [0]=>
  string(5) "every"
  [1]=>
  string(4) "time"
}

SwishSearch::setLimit
SwishSearch::setSort
Swish İşlevleri


Set the sort order

SwishSearch::setPhraseDelimiter
SwishSearch::setStructure
Swish İşlevleri
PHP Manual

SwishSearch::setSort

(PECL swish >= 0.1.0)

SwishSearch::setSort — Set the sort order

Açıklama

void SwishSearch::setSort ( string $sort )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Değiştirgeler

sort

Sort order of the results is a string containing name of a result property combined with sort direction ("asc" or "desc"). Examples: "swishrank desc", "swishdocpath asc", "swishtitle asc", "swishdocsize desc", "swishlastmodified desc" etc.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Basic SwishSearch::setSort() example

<?php

try {

    $swish = new Swish("index.swish-e");
    $search = $swish->prepare();

    $results = $search->execute("time");
    echo "First query found: ", $results->hits, " hits\n";

    $i = 0;
    while($result = $results->nextResult()) {
        echo "Hit #", ++$i, " - ", $result->swishdocsize, " bytes\n";
    }

    $search->setSort("swishdocsize desc"); //sort by document size
    $results = $search->execute("time");
    echo "Second query found: ", $results->hits, " hits\n";

    $i = 0;
    while($result = $results->nextResult()) {
        echo "Hit #", ++$i, " - ", $result->swishdocsize, " bytes\n";
    }

} catch (SwishException $e) {
    echo $e->getMessage(), "\n";
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

First query found: 5 hits
Hit #1 - 4261 bytes
Hit #2 - 37937 bytes
Hit #3 - 7126 bytes
Hit #4 - 15427 bytes
Hit #5 - 4768 bytes
Second query found: 5 hits
Hit #1 - 37937 bytes
Hit #2 - 15427 bytes
Hit #3 - 7126 bytes
Hit #4 - 4768 bytes
Hit #5 - 4261 bytes

SwishSearch::setPhraseDelimiter
SwishSearch::setStructure
Swish İşlevleri


Set the structure flag in the search object

SwishSearch::setSort
Sunuculara Özgü Eklentiler
Swish İşlevleri
PHP Manual

SwishSearch::setStructure

(PECL swish >= 0.1.0)

SwishSearch::setStructure — Set the structure flag in the search object

Açıklama

void SwishSearch::setStructure ( int $structure )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Değiştirgeler

structure

The structure flag a bitmask is used to limit search to certain parts of HTML documents (like title, meta, body etc.). Its possible values are listed below. To combine several values use bitwise OR operator, see example below.

  • Swish::IN_FILE

  • Swish::IN_TITLE

  • Swish::IN_HEAD

  • Swish::IN_BODY

  • Swish::IN_COMMENTS

  • Swish::IN_HEADER

  • Swish::IN_EMPHASIZED

  • Swish::IN_META

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Basic SwishSearch::setStructure() example

<?php

try {

    $swish = new Swish("index.swish-e");
    $search = $swish->prepare();

    $results = $search->execute("time");
    echo "First query found: ", $results->hits, " hits\n";

    $search->setStructure(Swish::IN_TITLE|Swish::IN_HEAD); //search in title and head
    $results = $search->execute("time");
    echo "Second query found: ", $results->hits, " hits\n";

    $search->setStructure(Swish::IN_ALL); //search in whole document, the default value
    $results = $search->execute("time");
    echo "Third query found: ", $results->hits, " hits\n";

} catch (SwishException $e) {
    echo $e->getMessage(), "\n";
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

First query found: 5 hits
Second query found: 0 hits
Third query found: 5 hits

SwishSearch::setSort
Sunuculara Özgü Eklentiler
Swish İşlevleri


Sunuculara Özgü Eklentiler

  • Apache
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Apache İşlevleri
  • FastCGI Process Manager
    • Giriş
    • Yapılandırma/Kurulum
    • FPM İşlevleri
  • IIS — IIS Administration
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • IIS İşlevleri
  • NSAPI
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • NSAPI İşlevleri
SwishSearch::setStructure
Apache
İşlev Başvuru Kılavuzu


Apache

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Apache İşlevleri
    • apache_child_terminate — Bu istekten sonra Apache sürecini sonlandırır
    • apache_get_modules — Yüklü Apache modüllerinin listesini verir
    • apache_get_version — Apache sürümünü getirir
    • apache_getenv — Bir Apache ortam değişkeninin değerini döndürür
    • apache_lookup_uri — Verilen URI için kısmi bir istekte bulunur ve hakkındaki tüm bilgileri döndürür
    • apache_note — Apache istek notlarını alır veya atar
    • apache_request_headers — Tüm HTTP istek başlıklarını alır
    • apache_reset_timeout — Apache yazma zamanlayıcısını sıfırlar
    • apache_response_headers — Tüm HTTP yanıt başlıklarını alır
    • apache_setenv — Bir Apache ortam değişkeni atar
    • getallheaders — Tüm HTTP istek başlıklarını getirir
    • virtual — Bir Apache alt isteği gerçekleştirir
Sunuculara Özgü Eklentiler
Giriş
Sunuculara Özgü Eklentiler


Giriş

Bu işlevler sadece PHP bir Apache modülü olarak çalışırken kullanılabilir.

Bilginize: PHP 4.3.2 ve sonrasında, Apache 1'in aksine Apache 2 altında PATH_TRANSLATED değişkeni artık atanmamaktadır. Apache 1'de aynı durumda aynı değer SCRIPT_FILENAME sunucu değişkenine atanmaktadır. Bunun böyle yapılmasının sebebi, PATH_TRANSLATED değişkenine sadece PATH_INFO tanımlı olduğu takdirde atama yapılmasını gerektiren CGI belirtimine uyumluluktur. Apache 2 kullanıcıları PATH_INFO değişkenini tanımlamak için httpd.conf dosyasına AcceptPathInfo = On satırını ekleyebilirler.

Apache
Yapılandırma/Kurulum
Apache


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Apache


Kurulum

Apache üzerine PHP kurulumu için Yapılandırma ve Kurulum bölümüne bakınız.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Apache PHP modülünün davranışları php.ini içindeki ayarlamalardan etkilenmektedir. php.ini içindeki ayarlar, sunucu yapılandırma dosyasındaki ya da yerel .htaccess dosyalarındaki php_flag ayarları ile geçersiz kılınabilir.

Örnek 1 - .htaccess kullanarak PHP yorumlamasının bir dizinde kapatılması

php_flag engine off

Apache yapılandırma seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
engine | "1" | PHP_INI_ALL | PHP 4.0.5 sürümünden beri kullanımda.
child_terminate | "0" | PHP_INI_ALL | PHP 4.0.5 sürümünden beri kullanımda.
last_modified | "0" | PHP_INI_ALL | PHP 4.0.5 sürümünden beri kullanımda.
xbithack | "0" | PHP_INI_ALL | PHP 4.0.5 sürümünden beri kullanımda.
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

engine boolean

PHP çözümlemesini açar veya kapatır. Bu yönerge PHP'nin Apache modülü sürümünde gerçekten işe yarayan tek şeydir. PHP çözümlemesini dizinler düzeyinde veya sanal konak düzeyinde açıp kapamak isteyen siteler tarafından kullanılır. httpd.conf dosyasının uygun yerlerine engine off yönergelerini yerleştirerek PHP iptal edilebilir veya etkin kılınabilir.

child_terminate boolean

İstek sonunda PHP betiklerinin çocuk sürecin sonlandırılmasını isteyip isteyemeyeceğini belirler. Ayrıca bakınız : apache_child_terminate().

last_modified boolean

PHP betiğinin son düzenlenme tarihini Last-Modified: istek başlığı ile gönderir.

xbithack boolean

PHP dosyalarının uzantılarına değil çalıştırılabilir bitine bakarak yorumlanmasını sağlar.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
Apache İşlevleri
Apache


Apache İşlevleri

İçindekiler

  • apache_child_terminate — Bu istekten sonra Apache sürecini sonlandırır
  • apache_get_modules — Yüklü Apache modüllerinin listesini verir
  • apache_get_version — Apache sürümünü getirir
  • apache_getenv — Bir Apache ortam değişkeninin değerini döndürür
  • apache_lookup_uri — Verilen URI için kısmi bir istekte bulunur ve hakkındaki tüm bilgileri döndürür
  • apache_note — Apache istek notlarını alır veya atar
  • apache_request_headers — Tüm HTTP istek başlıklarını alır
  • apache_reset_timeout — Apache yazma zamanlayıcısını sıfırlar
  • apache_response_headers — Tüm HTTP yanıt başlıklarını alır
  • apache_setenv — Bir Apache ortam değişkeni atar
  • getallheaders — Tüm HTTP istek başlıklarını getirir
  • virtual — Bir Apache alt isteği gerçekleştirir
Öntanımlı Sabitler
apache_child_terminate
Apache


Bu istekten sonra Apache sürecini sonlandırır

Apache İşlevleri
apache_get_modules
Apache İşlevleri
PHP Manual

apache_child_terminate

(PHP 4 >= 4.0.5, PHP 5, PHP 7)

apache_child_terminate — Bu istekten sonra Apache sürecini sonlandırır

Açıklama

bool apache_child_terminate ( void )

apache_child_terminate() işlevi PHP kodunun çalışması bittikten sonra geçerli PHP isteğini çalıştıran Apache sürecini sonlandırmak için kullanılır. Daha ziyade çok bellek tüketen ancak işlem bittikten sonra tükettiği belleği işletim sistemine geri veremeyen işlemleri yoketmek için kullanılabilir.

Dönen Değerler

PHP bir Apache 1 modülü olarak çalışıyorsa, Apache sürümü çok evreli değilse ve child_terminate PHP yönergesi etkinse (öntanımlı olarak etkin değildir) ise TRUE döndürür. Eğer bu koşullar sağlanmıyorsa E_WARNING seviyesinde bir hata ile birlikte FALSE döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
5.4.0 | Bu işlev FastCGI altında kullanılabilir hale geldi. Evvelce, sadece PHP bir Apache modülü olarak kurulduğu takdirde destekleniyordu.

Notlar

Bilginize: Bu işlev Windows sistemlerinde çalışmaz.

Ayrıca Bakınız

  • exit() - Bir ileti çıktılayıp çalışmakta olan betiği sonlandırır

Apache İşlevleri
apache_get_modules
Apache İşlevleri


Yüklü Apache modüllerinin listesini verir

apache_child_terminate
apache_get_version
Apache İşlevleri
PHP Manual

apache_get_modules

(PHP 4 >= 4.3.2, PHP 5, PHP 7)

apache_get_modules — Yüklü Apache modüllerinin listesini verir

Açıklama

array apache_get_modules ( void )

Yüklü Apache modüllerinin listesini verir.

Dönen Değerler

Yüklü Apache modülleri dizisi.

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.0 | Apache 1 ya da PHP Apache 2 filtre API'si kullanıldığında kullanılabilinir. Bundan önce sadece Apache 2 handler API'si kullanılırken kullanılabiliyordu.

Örnekler

Örnek 1 - apache_get_modules() örneği

<?php
print_r(apache_get_modules());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [0] => core
    [1] => http_core
    [2] => mod_so
    [3] => sapi_apache2
    [4] => mod_mime
    [5] => mod_rewrite
)

apache_child_terminate
apache_get_version
Apache İşlevleri


Apache sürümünü getirir

apache_get_modules
apache_getenv
Apache İşlevleri
PHP Manual

apache_get_version

(PHP 4 >= 4.3.2, PHP 5, PHP 7)

apache_get_version — Apache sürümünü getirir

Açıklama

string apache_get_version ( void )

Apache sürümünü getirir.

Dönen Değerler

Başarı halinde Apache sürümünü, aksi halde FALSE döndürür.

Örnekler

Örnek 1 - apache_get_version() örneği

<?php
$version = apache_get_version();
echo "$version\n";
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Apache/1.3.29 (Unix) PHP/4.3.4

Ayrıca Bakınız

  • phpinfo() - PHP'nin o anki durumu hakkında büyük miktarda bilgi çıktılar

apache_get_modules
apache_getenv
Apache İşlevleri


Bir Apache ortam değişkeninin değerini döndürür

apache_get_version
apache_lookup_uri
Apache İşlevleri
PHP Manual

apache_getenv

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

apache_getenv — Bir Apache ortam değişkeninin değerini döndürür

Açıklama

string apache_getenv ( string $değişken [, bool $tepe_seviye = false ] )

değişken değiştirgesiyle belirtilen Apache ortam değişkenini döndürür.

Bu işlev için Apache 2 gerekir. Aksi halde tanımsızdır.

Değiştirgeler

değişken

Apache ortam değişkeni

tepe_seviye

Tüm Apache katmanlarında kullanılabilen tepe seviye değişkenin alınıp alınmayacağını belirler.

Dönen Değerler

Başarı halinde Apache ortam değişkeninin değeri, aksi halde FALSE döner.

Örnekler

Örnek 1 - apache_getenv() örneği

Aşağıdaki örnek bir Apache ortam değişkeni olan SERVER_ADDR değişkeninin değerinin nasıl alınacağını göstermektedir.

<?php
$ret = apache_getenv("SERVER_ADDR");
echo $ret;
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

42.24.42.240

Ayrıca Bakınız

  • apache_sentenv()
  • getenv() - Bir ortam değişkeninin değerini döndürür
  • Süper Küreseller

apache_get_version
apache_lookup_uri
Apache İşlevleri


Verilen URI için kısmi bir istekte bulunur ve hakkındaki tüm bilgileri döndürür

apache_getenv
apache_note
Apache İşlevleri
PHP Manual

apache_lookup_uri

(PHP 4, PHP 5, PHP 7)

apache_lookup_uri — Verilen URI için kısmi bir istekte bulunur ve hakkındaki tüm bilgileri döndürür

Açıklama

object apache_lookup_uri ( string $dosya_adı )

Bir URI için kısmi istekte bulunur. Özkaynak hakkında önemli tüm bilgileri alır.

Bu işlev sadece PHP bir Apache modülü olarak veya Netscape/iPlanet/SunONE sunucularında ise NSAPI sunucu modülü olarak kuruluysa desteklenir.

Değiştirgeler

dosya_adı

İstenen dosyanın ismi (URI).

Dönen Değerler

URL bilgisiyle ilgili nesne. Nesnenin özellikleri

  • status
  • the_request
  • status_line
  • method
  • content_type
  • handler
  • uri
  • filename
  • path_info
  • args
  • boundary
  • no_cache
  • no_local_copy
  • allowed
  • send_bodyct
  • bytes_sent
  • byterange
  • clength
  • unparsed_uri
  • mtime
  • request_time

Örnekler

Örnek 1 - apache_lookup_uri() örneği

<?php
$info = apache_lookup_uri('index.php?var=value');
print_r($info);

if (file_exists($info->filename)) {
    echo 'dosya mevcut!';
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

stdClass Object
(
    [status] => 200
    [the_request] => GET /dir/file.php HTTP/1.1
    [method] => GET
    [mtime] => 0
    [clength] => 0
    [chunked] => 0
    [content_type] => application/x-httpd-php
    [no_cache] => 0
    [no_local_copy] => 1
    [unparsed_uri] => /dir/index.php?var=value
    [uri] => /dir/index.php
    [filename] => /home/htdocs/dir/index.php
    [args] => var=value
    [allowed] => 0
    [sent_bodyct] => 0
    [bytes_sent] => 0
    [request_time] => 1074282764
)
dosya mevcut!

apache_getenv
apache_note
Apache İşlevleri


Apache istek notlarını alır veya atar

apache_lookup_uri
apache_request_headers
Apache İşlevleri
PHP Manual

apache_note

(PHP 4, PHP 5, PHP 7)

apache_note — Apache istek notlarını alır veya atar

Açıklama

string apache_note ( string $not_adı [, string $not_değeri = "" ] )

Bu işlev Apache'nin table_get ve table_set işlevleri için bir sarmalayıcıdır. Bir istek sırasında var olan not tablosunu düzenler. Tablonun amacı Apache modüllerinin iletişimini sağlamaktır.

apache_note() işlevinin ana kullanım amacı aynı istek dahilinde bir modülden diğerine bilgi aktarmaktır.

Değiştirgeler

not_adı

Notun adı.

not_değeri

Notun değeri.

Dönen Değerler

Tek değiştirge ile çağrılırsa not_adı notunun o anki değerini döndürür. Eğer iki değiştirge ile çağrılırsa not_değeri değerini not_adı notuna atar ve not_adı notunun önceki değerini döndürür. Eğer işlem başarısız olursa FALSE döner.

Örnekler

Örnek 1 PHP ve Perl arasında bilgi aktarımı

<?php

apache_note('name', 'Fredrik Ekengren');

// Perl betiğini çağıralım
virtual("/perl/bir_betik.pl");

$result = apache_note("resultdata");
?>
# Apache istek nesnesini alalım
my $r = Apache->request()->main();

# Aktarılan veriyi alalım
my $name = $r->notes('name');

# bir takım işlemler...

# Sonucu PHP'ye geri aktaralım
$r->notes('resultdata', $result);

Örnek 2 - access.log dosyasındaki oturum değerleri

<?php

apache_note('sessionID', session_id());

?>
# "%{sessionID}n" can be used in the LogFormat directive

Ayrıca Bakınız

  • virtual() - Bir Apache alt isteği gerçekleştirir

apache_lookup_uri
apache_request_headers
Apache İşlevleri


Tüm HTTP istek başlıklarını alır

apache_note
apache_reset_timeout
Apache İşlevleri
PHP Manual

apache_request_headers

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

apache_request_headers — Tüm HTTP istek başlıklarını alır

Açıklama

array apache_request_headers ( void )

Geçerli istekteki HTTP istek başlıklarının tümünü alır.

Dönen Değerler

Başarı halinde mevcut isteğin tüm HTTP başlıklarını içeren bir ilişkili dizi döndürür; aksi halde FALSE döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
5.5.7 | Bu işlev CLI sunucusunda kullanılabilir hale geldi.
5.4.0 | Bu işlev FastCGI altında kullanılabilir hale geldi. Evvelce, sadece PHP bir Apache modülü olarak veya Netscape/iPlanet/SunONE sunucularında NSAPI sunucu modülü olarak kurulduğu takdirde destekleniyordu.

Örnekler

Örnek 1 - apache_request_headers() örneği

<?php
$headers = apache_request_headers();

foreach ($headers as $header => $value) {
    echo "$header: $value <br />\n";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Accept: */*
Accept-Language: en-us
Accept-Encoding: gzip, deflate
User-Agent: Mozilla/4.0
Host: www.example.com
Connection: Keep-Alive

Notlar

Bilginize:

PHP'yi bir Apache modülü olarak kullansanız da kullanmasanızda genel CGI değişkenlerini çevre değişkenlerini okuyarak da alabilirsiniz. Kullanılabilir ortam değişkenlerinin listesini almak için phpinfo() işlevini kullanabilirsiniz.

Ayrıca Bakınız

  • apache_response_headers() - Tüm HTTP yanıt başlıklarını alır

apache_note
apache_reset_timeout
Apache İşlevleri


Apache yazma zamanlayıcısını sıfırlar

apache_request_headers
apache_response_headers
Apache İşlevleri
PHP Manual

apache_reset_timeout

(PHP 5 >= 5.1.0, PHP 7)

apache_reset_timeout — Apache yazma zamanlayıcısını sıfırlar

Açıklama

bool apache_reset_timeout ( void )

apache_reset_timeout() öntanımlı değeri 300 saniye olan Apache yazma zamanlayıcısını sıfırlar. set_time_limit(0); ignore_user_abort(true) kullanılarak ve düzenli aralıklarla apache_reset_timeout() çağrıları yapılarak Apache kuramsal olarak sonsuza kadar çalışabilir.

Bu fonksiyon Apache 1 gerektirir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

Bilginize: Bu işlev, PHP güvenli kipte çalışırken iptal edilir.

Ayrıca Bakınız

  • set_time_limit() - Azami çalıştırma süresini sınırlar
  • ignore_user_abort() - Bir istemci bağlantıyı terkettiğinde betiğin sonlandırılıp sonlandırılmayacağını belirler

apache_request_headers
apache_response_headers
Apache İşlevleri


Tüm HTTP yanıt başlıklarını alır

apache_reset_timeout
apache_setenv
Apache İşlevleri
PHP Manual

apache_response_headers

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

apache_response_headers — Tüm HTTP yanıt başlıklarını alır

Açıklama

array apache_response_headers ( void )

Tüm HTTP yanıt başlıklarını alır.

Dönen Değerler

Başarı halinde Apache yanıt başlıklarını içeren bir dizi; aksi halde FALSE döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
5.5.7 | Bu işlev CLI sunucusunda kullanılabilir hale geldi.
5.4.0 | Bu işlev FastCGI altında kullanılabilir hale geldi. Evvelce, sadece PHP bir Apache modülü olarak veya Netscape/iPlanet/SunONE sunucularında NSAPI sunucu modülü olarak kurulduğu takdirde destekleniyordu.

Örnekler

Örnek 1 - apache_response_headers() örneği

<?php
print_r(apache_response_headers());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [Accept-Ranges] => bytes
    [X-Powered-By] => PHP/4.3.8
)

Ayrıca Bakınız

  • apache_request_headers() - Tüm HTTP istek başlıklarını alır
  • headers_sent() - Başlıklar gönderilmiş mi, gönderilmişse nerede gönderilmiş diye bakar
  • headers_list() - Gönderilmiş (veya gönderilmeye hazır) yanıt başlıklarının listesiyle döner

apache_reset_timeout
apache_setenv
Apache İşlevleri


Bir Apache ortam değişkeni atar

apache_response_headers
getallheaders
Apache İşlevleri
PHP Manual

apache_setenv

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

apache_setenv — Bir Apache ortam değişkeni atar

Açıklama

bool apache_setenv ( string $değişken , string $değer [, bool $tepe_seviye = false ] )

apache_setenv() işlevi değişken ile belirtilen Apache ortam değişkeninin değerini atar.

Bilginize:

Apache ortam değişkeni atanırken ilgili $_SERVER değişkeninde bir değişiklik olmaz.

Değiştirgeler

değişken

Atanmak istenen çevre değişkeni.

değer

değişken'in yeni değeri.

tepe_seviye

Değişkenin tüm Apache katmanlarına kullanılabilen tepe seviyeye atanıp atanmayacağını belirler.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - apache_setenv() ile bir Apache ortam değişkenini atamak

<?php
apache_setenv("EXAMPLE_VAR", "Örnek değer");
?>

Notlar

Bilginize:

apache_setenv() işlevi apache_getenv() işlevi ile ayrı sayfalar arasında veya PHP betiklerinde içerilmiş SSI sayfalarına (.shtml) aktarılacak değişkenlere değer atamak için eşleştirilebilir

Ayrıca Bakınız

  • apache_getenv() - Bir Apache ortam değişkeninin değerini döndürür

apache_response_headers
getallheaders
Apache İşlevleri


Tüm HTTP istek başlıklarını getirir

apache_setenv
virtual
Apache İşlevleri
PHP Manual

getallheaders

(PHP 4, PHP 5, PHP 7)

getallheaders — Tüm HTTP istek başlıklarını getirir

Açıklama

array getallheaders ( void )

Mevcut isteğe ait HTTP başlıklarının tümünü bir dizi olarak döndürür.

Bu işlev apache_request_headers() işlevine bir takma addır. Bu işleven nasıl çalıştığı hakkında ayrıntılı bilgi edinmek için apache_request_headers() işlevinin açıklamasına bakınız.

Dönen Değerler

Herşey yolunda gitmişse mevcut isteğe ait tüm HTTP başlıklarını içeren bir ilişkili dizi döndürür, aksi takdirde FALSE döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
5.5.7 | Bu işlev CLI sunucusunda kullanılabilir hale geldi.
5.4.0 | Bu işlev FastCGI altında kullanılabilir hale geldi. Evvelce, sadece PHP bir Apache modülü olarak veya Netscape/iPlanet/SunONE sunucularında NSAPI sunucu modülü olarak kurulduğu takdirde destekleniyordu.

Örnekler

Örnek 1 - getallheaders() örneği

<?php

foreach (getallheaders() as $başlık => $değer) {
    echo "$başlık: $değer\n";
}

?>

Ayrıca Bakınız

  • apache_response_headers() - Tüm HTTP yanıt başlıklarını alır

apache_setenv
virtual
Apache İşlevleri


Bir Apache alt isteği gerçekleştirir

getallheaders
FastCGI Process Manager
Apache İşlevleri
PHP Manual

virtual

(PHP 4, PHP 5, PHP 7)

virtual — Bir Apache alt isteği gerçekleştirir

Açıklama

bool virtual ( string $dosya_adı )

virtual() işlevi, mod_include'da ki <!--#include virtual...--> komutuna eşdeğer Apache'ye özgü bir işlevdir. Bir Apache alt isteği gerçekleştirir. Apache'ye CGI betikleri ya da .shtml dosyalarını veya Apache'nin yorumlamasını istediğiniz herhangi birşey için kullanışlıdır. CGI betiklerinin geçerli CGI başlıklarını üretmelerinin gerekliliğini unutmayınız. Betiğin en azından bir Content-type başlığı üretmesi gerekir.

Bir alt istek çalıştırmak için tüm tamponlar tarayıcıya boşaltılıp sonlandırılırlar ve bu arada bekleyen başlıklar da gönderilir.

Bu işlev sadece PHP bir Apache modülü olarak veya Netscape/iPlanet/SunONE sunucularında ise NSAPI sunucu modülü olarak kuruluysa desteklenir.

Değiştirgeler

dosya_adı

Apache virtual komutunun çalıştıracağı dosya.

Dönen Değerler

Başarı halinde virtual komutu çalıştırılır, hata halinde FALSE döndürür.

Örnekler

apache_note() işlevindeki örneği bakınız.

Notlar

Uyarı

Sorgu dizgisi dahil edilen dosyaya aktarılabilir, ancak $_GET değişkeni ana betikten kopyalanır ve sadece $_SERVER['QUERY_STRING'] değişkeni aktarılacak sorgu dizgisi ile doldurulur. Sorgu dizgesi sadece Apache 2 kullanılırken aktarılabilir. İstek yapılan dosya Apache'nin erişim günlüklerinde gösterilmez.

Bilginize:

İstek dosyasında atanan ortam değişkenleri çağrı betiğine görünür değildir.

Bilginize:

Bu işlev PHP dosyalarında kullanılabilirse de include veya require kullanmak daha iyidir.

Ayrıca Bakınız

  • apache_note() - Apache istek notlarını alır veya atar

getallheaders
FastCGI Process Manager
Apache İşlevleri


FastCGI Process Manager

  • Giriş
  • Yapılandırma/Kurulum
  • FPM İşlevleri
    • fastcgi_finish_request — Flushes all response data to the client
virtual
Giriş
Sunuculara Özgü Eklentiler


Giriş

FPM (FastCGI Process Manager) is an alternative PHP FastCGI implementation with some additional features (mostly) useful for heavy-loaded sites.

This SAPI is bundled with PHP 5.3.3 and later.

FastCGI Process Manager
Yapılandırma/Kurulum
FastCGI Process Manager


Yapılandırma/Kurulum

Information on installing and configuring FPM can be found in the installation and configuration section of the PHP manual.

Giriş
FPM İşlevleri
FastCGI Process Manager


FPM İşlevleri

İçindekiler

  • fastcgi_finish_request — Flushes all response data to the client
Yapılandırma/Kurulum
fastcgi_finish_request
FastCGI Process Manager


Flushes all response data to the client

FPM İşlevleri
IIS
FPM İşlevleri
PHP Manual

fastcgi_finish_request

(PHP 5 >= 5.3.3, PHP 7)

fastcgi_finish_request — Flushes all response data to the client

Açıklama

boolean fastcgi_finish_request ( void )

This function flushes all response data to the client and finishes the request. This allows for time consuming tasks to be performed without leaving the connection to the client open.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

FPM İşlevleri
IIS
FPM İşlevleri


IIS Administration

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • IIS İşlevleri
    • iis_add_server — Creates a new virtual web server
    • iis_get_dir_security — Gets Directory Security
    • iis_get_script_map — Gets script mapping on a virtual directory for a specific extension
    • iis_get_server_by_comment — Return the instance number associated with the Comment
    • iis_get_server_by_path — Return the instance number associated with the Path
    • iis_get_server_rights — Gets server rights
    • iis_get_service_state — Returns the state for the service defined by ServiceId
    • iis_remove_server — Removes the virtual web server indicated by ServerInstance
    • iis_set_app_settings — Creates application scope for a virtual directory
    • iis_set_dir_security — Sets Directory Security
    • iis_set_script_map — Sets script mapping on a virtual directory
    • iis_set_server_rights — Sets server rights
    • iis_start_server — Starts the virtual web server
    • iis_start_service — Starts the service defined by ServiceId
    • iis_stop_server — Stops the virtual web server
    • iis_stop_service — Stops the service defined by ServiceId
fastcgi_finish_request
Giriş
Sunuculara Özgü Eklentiler


Giriş

This extension is available for Win32 only. It provides functions to administrate Microsoft Internet Information Server (IIS). The extension includes function to create web sites and virtual directories as well as configuring security and script mapping.

IIS
Yapılandırma/Kurulum
IIS


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
IIS


Kurulum

Bu eklentinin geliştirmesi durmuştur. Ancak, kaynak kodunu PECL SVN deposunda bulabilirsiniz. Yeri: » http://svn.php.net/viewvc/pecl/iisfunc.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

IIS_READ (integer)
IIS_WRITE (integer)
IIS_EXECUTE (integer)
IIS_SCRIPT (integer)
IIS_ANONYMOUS (integer)
IIS_BASIC (integer)
IIS_NTLM (integer)
IIS_STARTING (integer)
IIS_STOPPED (integer)
IIS_PAUSED (integer)
IIS_RUNNING (integer)
Özkaynak Türleri
IIS İşlevleri
IIS


IIS İşlevleri

İçindekiler

  • iis_add_server — Creates a new virtual web server
  • iis_get_dir_security — Gets Directory Security
  • iis_get_script_map — Gets script mapping on a virtual directory for a specific extension
  • iis_get_server_by_comment — Return the instance number associated with the Comment
  • iis_get_server_by_path — Return the instance number associated with the Path
  • iis_get_server_rights — Gets server rights
  • iis_get_service_state — Returns the state for the service defined by ServiceId
  • iis_remove_server — Removes the virtual web server indicated by ServerInstance
  • iis_set_app_settings — Creates application scope for a virtual directory
  • iis_set_dir_security — Sets Directory Security
  • iis_set_script_map — Sets script mapping on a virtual directory
  • iis_set_server_rights — Sets server rights
  • iis_start_server — Starts the virtual web server
  • iis_start_service — Starts the service defined by ServiceId
  • iis_stop_server — Stops the virtual web server
  • iis_stop_service — Stops the service defined by ServiceId
Öntanımlı Sabitler
iis_add_server
IIS


Creates a new virtual web server

IIS İşlevleri
iis_get_dir_security
IIS İşlevleri
PHP Manual

iis_add_server

(PECL iisfunc SVN)

iis_add_server — Creates a new virtual web server

Açıklama

int iis_add_server ( string $path , string $comment , string $server_ip , int $port , string $host_name , int $rights , int $start_server )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

IIS İşlevleri
iis_get_dir_security
IIS İşlevleri


Gets Directory Security

iis_add_server
iis_get_script_map
IIS İşlevleri
PHP Manual

iis_get_dir_security

(PECL iisfunc SVN)

iis_get_dir_security — Gets Directory Security

Açıklama

int iis_get_dir_security ( int $server_instance , string $virtual_path )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

iis_add_server
iis_get_script_map
IIS İşlevleri


Gets script mapping on a virtual directory for a specific extension

iis_get_dir_security
iis_get_server_by_comment
IIS İşlevleri
PHP Manual

iis_get_script_map

(PECL iisfunc SVN)

iis_get_script_map — Gets script mapping on a virtual directory for a specific extension

Açıklama

string iis_get_script_map ( int $server_instance , string $virtual_path , string $script_extension )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

iis_get_dir_security
iis_get_server_by_comment
IIS İşlevleri


Return the instance number associated with the Comment

iis_get_script_map
iis_get_server_by_path
IIS İşlevleri
PHP Manual

iis_get_server_by_comment

(PECL iisfunc SVN)

iis_get_server_by_comment — Return the instance number associated with the Comment

Açıklama

int iis_get_server_by_comment ( string $comment )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

iis_get_script_map
iis_get_server_by_path
IIS İşlevleri


Return the instance number associated with the Path

iis_get_server_by_comment
iis_get_server_rights
IIS İşlevleri
PHP Manual

iis_get_server_by_path

(PECL iisfunc SVN)

iis_get_server_by_path — Return the instance number associated with the Path

Açıklama

int iis_get_server_by_path ( string $path )

Each virtual server in IIS is associated with an instance number. iis_get_server_by_path() finds the instance number from the actual path to the root directory.

Değiştirgeler

path

The path to the root directory

Dönen Değerler

Returns the server instance number.

iis_get_server_by_comment
iis_get_server_rights
IIS İşlevleri


Gets server rights

iis_get_server_by_path
iis_get_service_state
IIS İşlevleri
PHP Manual

iis_get_server_rights

(PECL iisfunc SVN)

iis_get_server_rights — Gets server rights

Açıklama

int iis_get_server_rights ( int $server_instance , string $virtual_path )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

iis_get_server_by_path
iis_get_service_state
IIS İşlevleri


Returns the state for the service defined by ServiceId

iis_get_server_rights
iis_remove_server
IIS İşlevleri
PHP Manual

iis_get_service_state

(PECL iisfunc SVN)

iis_get_service_state — Returns the state for the service defined by ServiceId

Açıklama

int iis_get_service_state ( string $service_id )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

iis_get_server_rights
iis_remove_server
IIS İşlevleri


Removes the virtual web server indicated by ServerInstance

iis_get_service_state
iis_set_app_settings
IIS İşlevleri
PHP Manual

iis_remove_server

(PECL iisfunc SVN)

iis_remove_server — Removes the virtual web server indicated by ServerInstance

Açıklama

int iis_remove_server ( int $server_instance )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

iis_get_service_state
iis_set_app_settings
IIS İşlevleri


Creates application scope for a virtual directory

iis_remove_server
iis_set_dir_security
IIS İşlevleri
PHP Manual

iis_set_app_settings

(PECL iisfunc SVN)

iis_set_app_settings — Creates application scope for a virtual directory

Açıklama

int iis_set_app_settings ( int $server_instance , string $virtual_path , string $application_scope )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

iis_remove_server
iis_set_dir_security
IIS İşlevleri


Sets Directory Security

iis_set_app_settings
iis_set_script_map
IIS İşlevleri
PHP Manual

iis_set_dir_security

(PECL iisfunc SVN)

iis_set_dir_security — Sets Directory Security

Açıklama

int iis_set_dir_security ( int $server_instance , string $virtual_path , int $directory_flags )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

iis_set_app_settings
iis_set_script_map
IIS İşlevleri


Sets script mapping on a virtual directory

iis_set_dir_security
iis_set_server_rights
IIS İşlevleri
PHP Manual

iis_set_script_map

(PECL iisfunc SVN)

iis_set_script_map — Sets script mapping on a virtual directory

Açıklama

int iis_set_script_map ( int $server_instance , string $virtual_path , string $script_extension , string $engine_path , int $allow_scripting )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

iis_set_dir_security
iis_set_server_rights
IIS İşlevleri


Sets server rights

iis_set_script_map
iis_start_server
IIS İşlevleri
PHP Manual

iis_set_server_rights

(PECL iisfunc SVN)

iis_set_server_rights — Sets server rights

Açıklama

int iis_set_server_rights ( int $server_instance , string $virtual_path , int $directory_flags )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

iis_set_script_map
iis_start_server
IIS İşlevleri


Starts the virtual web server

iis_set_server_rights
iis_start_service
IIS İşlevleri
PHP Manual

iis_start_server

(PECL iisfunc SVN)

iis_start_server — Starts the virtual web server

Açıklama

int iis_start_server ( int $server_instance )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

iis_set_server_rights
iis_start_service
IIS İşlevleri


Starts the service defined by ServiceId

iis_start_server
iis_stop_server
IIS İşlevleri
PHP Manual

iis_start_service

(PECL iisfunc SVN)

iis_start_service — Starts the service defined by ServiceId

Açıklama

int iis_start_service ( string $service_id )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

iis_start_server
iis_stop_server
IIS İşlevleri


Stops the virtual web server

iis_start_service
iis_stop_service
IIS İşlevleri
PHP Manual

iis_stop_server

(PECL iisfunc SVN)

iis_stop_server — Stops the virtual web server

Açıklama

int iis_stop_server ( int $server_instance )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

iis_start_service
iis_stop_service
IIS İşlevleri


Stops the service defined by ServiceId

iis_stop_server
NSAPI
IIS İşlevleri
PHP Manual

iis_stop_service

(PECL iisfunc SVN)

iis_stop_service — Stops the service defined by ServiceId

Açıklama

int iis_stop_service ( string $service_id )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

iis_stop_server
NSAPI
IIS İşlevleri


NSAPI

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • NSAPI İşlevleri
    • nsapi_request_headers — Fetch all HTTP request headers
    • nsapi_response_headers — Fetch all HTTP response headers
    • nsapi_virtual — Perform an NSAPI sub-request
iis_stop_service
Giriş
Sunuculara Özgü Eklentiler


Giriş

These functions are only available when running PHP as a NSAPI module in Netscape/iPlanet/Sun webservers.

NSAPI
Yapılandırma/Kurulum
NSAPI


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
NSAPI


Kurulum

For PHP installation on Netscape/iPlanet/Sun webservers see the NSAPI section (UNIX, Windows) in the installation chapter.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

The behaviour of the NSAPI PHP module is affected by settings in php.ini. Configuration settings from php.ini may be overridden by additional parameters to the php4_execute call in obj.conf

NSAPI configuration options
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
nsapi.read_timeout | "60" | PHP_INI_ALL | Available since PHP 4.3.3.
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

nsapi.read_timeout integer

Sets the time in seconds the plugin is waiting for POST data from the client.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
NSAPI İşlevleri
NSAPI


NSAPI İşlevleri

Ayrıca Bakınız

NSAPI implements a subset of the functions from the Apache module for maximum compatibility.

Apache functions implemented by NSAPI
Apache function (only as alias) | NSAPI function | Description
apache_request_headers() | nsapi_request_headers() | Fetch all HTTP request headers
apache_response_headers() | nsapi_response_headers() | Fetch all HTTP response headers
getallheaders() | nsapi_request_headers() | Fetch all HTTP request headers
virtual() | nsapi_virtual() | Make NSAPI sub-request

İçindekiler

  • nsapi_request_headers — Fetch all HTTP request headers
  • nsapi_response_headers — Fetch all HTTP response headers
  • nsapi_virtual — Perform an NSAPI sub-request
Öntanımlı Sabitler
nsapi_request_headers
NSAPI


Fetch all HTTP request headers

NSAPI İşlevleri
nsapi_response_headers
NSAPI İşlevleri
PHP Manual

nsapi_request_headers

(PHP 4 >= 4.3.3, PHP 5, PHP 7)

nsapi_request_headers — Fetch all HTTP request headers

Açıklama

array nsapi_request_headers ( void )

nsapi_request_headers() gets all the HTTP headers in the current request. This is only supported when PHP runs as a NSAPI module.

Bilginize:

Prior to PHP 4.3.3, getallheaders() was only available for the Apache servers. After PHP 4.3.3, getallheaders() is an alias for nsapi_request_headers() if you use the NSAPI module.

Bilginize:

You can also get at the value of the common CGI variables by reading them from the $_SERVER superglobal, which works whether or not you are using PHP as a NSAPI module.

Dönen Değerler

Returns an associative array with all the HTTP headers.

Örnekler

Örnek 1 nsapi_request_headers() example

<?php
$headers = nsapi_request_headers();

foreach ($headers as $header => $value) {
  echo "$header: $value <br />\n";
}
?>

NSAPI İşlevleri
nsapi_response_headers
NSAPI İşlevleri


Fetch all HTTP response headers

nsapi_request_headers
nsapi_virtual
NSAPI İşlevleri
PHP Manual

nsapi_response_headers

(PHP 4 >= 4.3.3, PHP 5, PHP 7)

nsapi_response_headers — Fetch all HTTP response headers

Açıklama

array nsapi_response_headers ( void )

Gets all the NSAPI response headers.

Dönen Değerler

Returns an associative array with all the NSAPI response headers.

Ayrıca Bakınız

  • nsapi_request_headers() - Fetch all HTTP request headers
  • headers_sent() - Başlıklar gönderilmiş mi, gönderilmişse nerede gönderilmiş diye bakar

nsapi_request_headers
nsapi_virtual
NSAPI İşlevleri


Perform an NSAPI sub-request

nsapi_response_headers
Oturum Eklentileri
NSAPI İşlevleri
PHP Manual

nsapi_virtual

(PHP 4 >= 4.3.3, PHP 5, PHP 7)

nsapi_virtual — Perform an NSAPI sub-request

Açıklama

bool nsapi_virtual ( string $uri )

nsapi_virtual() is an NSAPI-specific function which is equivalent to <!--#include virtual...--> in SSI (.shtml files). It does an NSAPI sub-request. It is useful for including CGI scripts or .shtml files, or anything else that you'd parse through webserver.

To run the sub-request, all buffers are terminated and flushed to the browser, pending headers are sent too.

You cannot make recursive requests with this function to other PHP scripts. If you want to include PHP scripts, use include or require.

Bilginize:

This function depends on a undocumented feature of the Netscape/iPlanet/Sun webservers. Use phpinfo() to determine if it is available. In the Unix environment it should always work, in Windows it depends on the name of a ns-httpdXX.dll file.

Read the note about subrequests in the NSAPI section (UNIX, Windows) if you experience this problem.

Değiştirgeler

uri

The URI of the script.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

nsapi_response_headers
Oturum Eklentileri
NSAPI İşlevleri


Oturum Eklentileri

  • Msession — Mohawk Software Session Handler Functions
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Msession İşlevleri
  • Oturumlar — Oturum Yönetim Sistemi
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • Session Upload Progress
    • Oturumlar ve Güvenlik
    • Oturum İşlevleri
    • SessionHandler — The SessionHandler class
    • SessionHandlerInterface — The SessionHandlerInterface class
  • Session PgSQL — PostgreSQL Session Save Handler
    • Giriş
    • Yapılandırma/Kurulum
    • Table definitions
    • Öntanımlı Sabitler
    • Session PgSQL İşlevleri
nsapi_virtual
Msession
İşlev Başvuru Kılavuzu


Mohawk Software Session Handler Functions

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Msession İşlevleri
    • msession_connect — Connect to msession server
    • msession_count — Get session count
    • msession_create — Create a session
    • msession_destroy — Destroy a session
    • msession_disconnect — Close connection to msession server
    • msession_find — Find all sessions with name and value
    • msession_get_array — Get array of msession variables
    • msession_get_data — Get data session unstructured data
    • msession_get — Get value from session
    • msession_inc — Increment value in session
    • msession_list — List all sessions
    • msession_listvar — List sessions with variable
    • msession_lock — Lock a session
    • msession_plugin — Call an escape function within the msession personality plugin
    • msession_randstr — Get random string
    • msession_set_array — Set msession variables from an array
    • msession_set_data — Set data session unstructured data
    • msession_set — Set value in session
    • msession_timeout — Set/get session timeout
    • msession_uniq — Get unique id
    • msession_unlock — Unlock a session
Oturum Eklentileri
Giriş
Oturum Eklentileri


Giriş

msession is an interface to a high speed session daemon which can run either locally or remotely. It is designed to provide consistent session management for a PHP web farm. More Information about msession and the session server software itself can be found at » http://www.mohawksoft.org/?q=node/8.

Bilginize: Bu eklenti Windows sistemlerinde çalışmaz.

Bilginize:

Bu eklenti » PECL deposuna taşınmış olup şu sürümden itibaren PHP kaynak paketinde dağıtılmamaktatır: PHP 5.1.3.

Msession
Yapılandırma/Kurulum
Msession


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Msession


Kurulum

Bu eklentinin geliştirmesi durmuştur. Ancak, kaynak kodunu PECL SVN deposunda bulabilirsiniz. Yeri: » http://svn.php.net/viewvc/pecl/msession.

Bu eklenti » PECL deposuna taşınmış olup şu sürümden itibaren PHP kaynak paketinde dağıtılmamaktatır: PHP 5.1.3

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
Msession İşlevleri
Msession


Msession İşlevleri

İçindekiler

  • msession_connect — Connect to msession server
  • msession_count — Get session count
  • msession_create — Create a session
  • msession_destroy — Destroy a session
  • msession_disconnect — Close connection to msession server
  • msession_find — Find all sessions with name and value
  • msession_get_array — Get array of msession variables
  • msession_get_data — Get data session unstructured data
  • msession_get — Get value from session
  • msession_inc — Increment value in session
  • msession_list — List all sessions
  • msession_listvar — List sessions with variable
  • msession_lock — Lock a session
  • msession_plugin — Call an escape function within the msession personality plugin
  • msession_randstr — Get random string
  • msession_set_array — Set msession variables from an array
  • msession_set_data — Set data session unstructured data
  • msession_set — Set value in session
  • msession_timeout — Set/get session timeout
  • msession_uniq — Get unique id
  • msession_unlock — Unlock a session
Öntanımlı Sabitler
msession_connect
Msession


Connect to msession server

Msession İşlevleri
msession_count
Msession İşlevleri
PHP Manual

msession_connect

(PHP 4 >= 4.2.0, PHP 5 <= 5.1.2)

msession_connect — Connect to msession server

Açıklama

bool msession_connect ( string $host , string $port )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Msession İşlevleri
msession_count
Msession İşlevleri


Get session count

msession_connect
msession_create
Msession İşlevleri
PHP Manual

msession_count

(PHP 4 >= 4.2.0, PHP 5 <= 5.1.2)

msession_count — Get session count

Açıklama

int msession_count ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

msession_connect
msession_create
Msession İşlevleri


Create a session

msession_count
msession_destroy
Msession İşlevleri
PHP Manual

msession_create

(PHP 4 >= 4.2.0, PHP 5 <= 5.1.2)

msession_create — Create a session

Açıklama

bool msession_create ( string $session [, string $classname [, string $data ]] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

msession_count
msession_destroy
Msession İşlevleri


Destroy a session

msession_create
msession_disconnect
Msession İşlevleri
PHP Manual

msession_destroy

(PHP 4 >= 4.2.0, PHP 5 <= 5.1.2)

msession_destroy — Destroy a session

Açıklama

bool msession_destroy ( string $name )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

msession_create
msession_disconnect
Msession İşlevleri


Close connection to msession server

msession_destroy
msession_find
Msession İşlevleri
PHP Manual

msession_disconnect

(PHP 4 >= 4.2.0, PHP 5 <= 5.1.2)

msession_disconnect — Close connection to msession server

Açıklama

void msession_disconnect ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

msession_destroy
msession_find
Msession İşlevleri


Find all sessions with name and value

msession_disconnect
msession_get_array
Msession İşlevleri
PHP Manual

msession_find

(PHP 4 >= 4.2.0, PHP 5 <= 5.1.2)

msession_find — Find all sessions with name and value

Açıklama

array msession_find ( string $name , string $value )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

msession_disconnect
msession_get_array
Msession İşlevleri


Get array of msession variables

msession_find
msession_get_data
Msession İşlevleri
PHP Manual

msession_get_array

(PHP 4 >= 4.2.0, PHP 5 <= 5.1.2)

msession_get_array — Get array of msession variables

Açıklama

array msession_get_array ( string $session )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

msession_find
msession_get_data
Msession İşlevleri


Get data session unstructured data

msession_get_array
msession_get
Msession İşlevleri
PHP Manual

msession_get_data

(PHP 4 >= 4.2.0, PHP 5 <= 5.1.2)

msession_get_data — Get data session unstructured data

Açıklama

string msession_get_data ( string $session )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

msession_get_array
msession_get
Msession İşlevleri


Get value from session

msession_get_data
msession_inc
Msession İşlevleri
PHP Manual

msession_get

(PHP 4 >= 4.2.0, PHP 5 <= 5.1.2)

msession_get — Get value from session

Açıklama

string msession_get ( string $session , string $name , string $value )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

msession_get_data
msession_inc
Msession İşlevleri


Increment value in session

msession_get
msession_list
Msession İşlevleri
PHP Manual

msession_inc

(PHP 4 >= 4.2.0, PHP 5 <= 5.1.2)

msession_inc — Increment value in session

Açıklama

string msession_inc ( string $session , string $name )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

msession_get
msession_list
Msession İşlevleri


List all sessions

msession_inc
msession_listvar
Msession İşlevleri
PHP Manual

msession_list

(PHP 4 >= 4.2.0, PHP 5 <= 5.1.2)

msession_list — List all sessions

Açıklama

array msession_list ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

msession_inc
msession_listvar
Msession İşlevleri


List sessions with variable

msession_list
msession_lock
Msession İşlevleri
PHP Manual

msession_listvar

(PHP 4 >= 4.2.0, PHP 5 <= 5.1.2)

msession_listvar — List sessions with variable

Açıklama

array msession_listvar ( string $name )

Used for searching sessions with common attributes.

Değiştirgeler

name

The name being searched.

Dönen Değerler

Returns an associative array of value/session for all sessions with a variable named name.

msession_list
msession_lock
Msession İşlevleri


Lock a session

msession_listvar
msession_plugin
Msession İşlevleri
PHP Manual

msession_lock

(PHP 4 >= 4.2.0, PHP 5 <= 5.1.2)

msession_lock — Lock a session

Açıklama

int msession_lock ( string $name )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

msession_listvar
msession_plugin
Msession İşlevleri


Call an escape function within the msession personality plugin

msession_lock
msession_randstr
Msession İşlevleri
PHP Manual

msession_plugin

(PHP 4 >= 4.2.0, PHP 5 <= 5.1.2)

msession_plugin — Call an escape function within the msession personality plugin

Açıklama

string msession_plugin ( string $session , string $val [, string $param ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

msession_lock
msession_randstr
Msession İşlevleri


Get random string

msession_plugin
msession_set_array
Msession İşlevleri
PHP Manual

msession_randstr

(PHP 4 >= 4.2.0, PHP 5 <= 5.1.2)

msession_randstr — Get random string

Açıklama

string msession_randstr ( int $param )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

msession_plugin
msession_set_array
Msession İşlevleri


Set msession variables from an array

msession_randstr
msession_set_data
Msession İşlevleri
PHP Manual

msession_set_array

(PHP 4 >= 4.2.0, PHP 5 <= 5.1.2)

msession_set_array — Set msession variables from an array

Açıklama

void msession_set_array ( string $session , array $tuples )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

msession_randstr
msession_set_data
Msession İşlevleri


Set data session unstructured data

msession_set_array
msession_set
Msession İşlevleri
PHP Manual

msession_set_data

(PHP 4 >= 4.2.0, PHP 5 <= 5.1.2)

msession_set_data — Set data session unstructured data

Açıklama

bool msession_set_data ( string $session , string $value )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

msession_set_array
msession_set
Msession İşlevleri


Set value in session

msession_set_data
msession_timeout
Msession İşlevleri
PHP Manual

msession_set

(PHP 4 >= 4.2.0, PHP 5 <= 5.1.2)

msession_set — Set value in session

Açıklama

bool msession_set ( string $session , string $name , string $value )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

msession_set_data
msession_timeout
Msession İşlevleri


Set/get session timeout

msession_set
msession_uniq
Msession İşlevleri
PHP Manual

msession_timeout

(PHP 4 >= 4.2.0, PHP 5 <= 5.1.2)

msession_timeout — Set/get session timeout

Açıklama

int msession_timeout ( string $session [, int $param ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

msession_set
msession_uniq
Msession İşlevleri


Get unique id

msession_timeout
msession_unlock
Msession İşlevleri
PHP Manual

msession_uniq

(PHP 4 >= 4.2.0, PHP 5 <= 5.1.2)

msession_uniq — Get unique id

Açıklama

string msession_uniq ( int $param [, string $classname [, string $data ]] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

msession_timeout
msession_unlock
Msession İşlevleri


Unlock a session

msession_uniq
Oturumlar
Msession İşlevleri
PHP Manual

msession_unlock

(PHP 4 >= 4.2.0, PHP 5 <= 5.1.2)

msession_unlock — Unlock a session

Açıklama

int msession_unlock ( string $session , int $key )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

msession_uniq
Oturumlar
Msession İşlevleri


Oturum Yönetim Sistemi

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
    • Oturum Kimliğinin Aktarımı
    • Özel Oturum Eylemcisi
  • Session Upload Progress
  • Oturumlar ve Güvenlik
  • Oturum İşlevleri
    • session_abort — Discard session array changes and finish session
    • session_cache_expire — Önbelleğe alınan oturumun ömrünü döndürür
    • session_cache_limiter — Geçerli önbellek sınırlayıcısını döndürür ve/veya tanımlar
    • session_commit — session_write_close işlevinin takma adıdır
    • session_create_id — Create new session id
    • session_decode — Oturum verisini bir dizgeden elde eder
    • session_destroy — Bir oturumla ilişkilendirilmiş tüm veriyi yokeder
    • session_encode — Geçerli oturum verisini bir dizge olarak kodlar
    • session_gc — Perform session data garbage collection
    • session_get_cookie_params — Oturum çerezi değiştirgelerini döndürür
    • session_id — Geçerli oturum kimliğini döndürür ve/veya tanımlar
    • session_is_registered — Bir küresel değişkenin oturumda kayıtlı olup olmadığına bakar
    • session_module_name — Geçerli oturum modülünü döndürür ve/veya tanımlar
    • session_name — Geçerli oturum ismini döndürür ve/veya tanımlar
    • session_regenerate_id — Geçerli oturum kimliğini yenisiyle değiştirir
    • session_register_shutdown — Session shutdown function
    • session_register — Geçerli oturuma bir veya daha fazla küresel değişkeni kaydeder
    • session_reset — Re-initialize session array with original values
    • session_save_path — Geçerli oturum kayıt yolunu tanımlar ve/veya döndürür
    • session_set_cookie_params — Oturum çerezi değiştirgelerini tanımlar
    • session_set_save_handler — Kullanıcı seviyesi oturum saklama işlevlerini bildirir
    • session_start — Oturum verisini ilklendirir
    • session_status — Returns the current session status
    • session_unregister — Geçerli oturumdaki bir küresel değişkeni kayıtdışı yapar
    • session_unset — Free all session variables
    • session_write_close — Oturum verisini yazıp oturumu kapatır
  • SessionHandler — The SessionHandler class
    • SessionHandler::close — Close the session
    • SessionHandler::create_sid — Return a new session ID
    • SessionHandler::destroy — Destroy a session
    • SessionHandler::gc — Cleanup old sessions
    • SessionHandler::open — Initialize session
    • SessionHandler::read — Read session data
    • SessionHandler::write — Write session data
  • SessionHandlerInterface — The SessionHandlerInterface class
    • SessionHandlerInterface::close — Close the session
    • SessionHandlerInterface::destroy — Destroy a session
    • SessionHandlerInterface::gc — Cleanup old sessions
    • SessionHandlerInterface::open — Initialize session
    • SessionHandlerInterface::read — Read session data
    • SessionHandlerInterface::write — Write session data
msession_unlock
Giriş
Oturum Eklentileri


Giriş

PHP'deki oturum desteği, belli bir veriyi sonraki erişimlerden korumak için kullanılır. Böylece daha özelleştirilmiş uygulamalar oluşturabilir ve sitenizin çekiciliğini arttırabilirsiniz.

Sitenize gelen her ziyaretçiye eşsiz bir kimlik atanır, buna oturum kimliği diyoruz. Bu kimlik istemci tarafında bir çerezde ya da doğrudan URL üzerinde saklanır.

Oturum desteği, $_SESSION dizisindeki istekler arasında veri saklamanızı sağlar. PHP özdevinimli olarak sizin tarafınızdan (session_start() üzerinden örtük olarak ya da session_register() üzerinden doğrudan) veya sitenize bir ziyaretçi geldiğinde karşı taraftan (session.auto_start 1 ise) istekle beraber oturuma özgü bir oturum kimliği gönderilip gönderilmediğine bakar. Gönderilmişse evvelce o oturum adına saklanmış ortam yeniden oluşturulur.

Dikkat

session.auto_start yönergesinin değeri On olduğu takdirde nesneleri oturumunuza sınıf tanımını yüklemek suretiyle koymak isterseniz bunu yapmanın tek yolu sınıf tanımını auto_prepend_file kullanarak yüklemektir. Aksi takdirde oturumunuza nesneleri koymak için nesnenizi önce serialize() ile dizgeleştirmek daha sonra unserialize() ile nesneleştirmek zorundasınız.

$_SESSION ve kayıtlı tüm değişkenler istek bittiğinde PHP tarafından session.serialize_handler yönergesinde belirtilen dizgeleştirme eylemcisi kullanılarak dahili olarak dizgeleştirilir. Oturuma kayıtlı değişkenlerden tanımsız olanlar tanımsız olarak imlenir. Sonraki erişimlerde kullanıcı bunları tanımlamadıça oturum modülü tarafından tanımsız olarak ele alınırlar.

Uyarı

Oturum verisi dizgeleştirildiğinden resource türündeki değişkenler oturumda saklanamaz.

Bilginize:

Oturumlarla çalışırken, bir değişken session_register() ile oturuma kaydedilinceye kadar veya $_SESSION süper küresel dizisine yeni bir anahtar ekleninceye kadar bir oturum kaydının oluşturulmayacağına dikkat ediniz. Oturumu session_start() ile başlatsanız bile bu durum değişmez.

Bilginize:

PHP 5.2.2'de devreye giren ve PHP 5.3.0 sürümünde kaldırılan henüz belgelenmemiş bir özellik sayesinde oturum dosyaları "/tmp" dizininde ("/tmp" izin verilen dosya yollarına doğrudan eklenmiş olmasa da open_basedir) ile etkin kılınmasa da) saklanabilmekteydi.

Oturumlar
Yapılandırma/Kurulum
Oturumlar


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Oturumlar


Gereksinimler

Bu eklentiyi derlemek için harici kütüphanelere gerek yoktur.

Bilginize:

Oturumu saklamak için, isterseniz, Ralf S. Engelschall tarafından geliştirilen paylaşımlı bellek ayırma (mm) yöntemini » indirip kurarak kullanabilirsiniz. Bu seçenek Windows platformlarında kullanılamaz. Yalnız şuna dikkat edin: mm'nin oturum saklama modülü, aynı oturumlara yapılan eşzamanlı erişimlerin düzgün olarak kilitleneceğini garanti etmemektedir. Bunun yerine, düzgün olarak kilitlenmesinden dolayı, dosya sistemine dayalı paylaşımlı bellek (Solaris/Linux üzerinde tmpfs veya BSD üzerinde /dev/md) kullanarak oturumları dosyalarda saklamak daha iyidir. Oturum verisi bellekte saklandığı takdirde HTTP sunucusu yeniden başlatılırken bu veriyi silmektetir.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Oturum desteği PHP'de öntanımlı olarak etkindir. PHP'yi oturum desteği olmadan derlemek isterseniz derleme sırasında configure betiğine --disable-session seçeneğini veriniz. Oturumların paylaşımlı bellek ayırma (mm) yöntemini kullanmasını isterseniz PHP'yi configure betiğine --with-mm[=DiZiN] seçeneğini belirterek derleyebilirsiniz.

PHP'nin Windows sürümünde bu eklenti yerleşik olarak gelmektedir. Bu işlevleri Windows'ta kullanmak için herhangi bir eklenti kurmanıza gerek yoktur.

Bilginize:

Öntanımlı olarak, belli bir oturumla ilgili tüm veri session.save_path php.ini yönergesi ile belirtilen dizindeki bir dosyada saklanır. Her oturum için, oturumla bir veri ilişkilendirilmemiş olsa bile bir dosya oluşturulur. Bunun böyle olmasının sebebi dosyanın henüz bir veri yazılmadan oturumla birlikte açılmış olmasıdır. Bu davranışın, dosya sistemindeki sınırlamalardan ve özel (örneğin bir veritabanı kullanan) bir oturum eylemcisinin veri saklanmayan oturumların izini sürmeme olasılığından dolayı bir yan etkisi de vardır.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Oturum Yapılandırma Yönergeleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
session.save_path | "" | PHP_INI_ALL |
session.name | "PHPSESSID" | PHP_INI_ALL |
session.save_handler | "files" | PHP_INI_ALL |
session.auto_start | "0" | PHP_INI_PERDIR |
session.gc_probability | "1" | PHP_INI_ALL |
session.gc_divisor | "100" | PHP_INI_ALL | PHP 4.3.2'den beri kullanılabilmektedir.
session.gc_maxlifetime | "1440" | PHP_INI_ALL |
session.serialize_handler | "php" | PHP_INI_ALL |
session.cookie_lifetime | "0" | PHP_INI_ALL |
session.cookie_path | "/" | PHP_INI_ALL |
session.cookie_domain | "" | PHP_INI_ALL |
session.cookie_secure | "" | PHP_INI_ALL | PHP 4.0.4'ten beri kullanılabilmektedir.
session.cookie_httponly | "" | PHP_INI_ALL | PHP 5.2.0'dan beri kullanılabilmektedir.
session.use_strict_mode | "0" | PHP_INI_ALL | PHP 5.5.2'den beri kullanılabilmektedir.
session.use_cookies | "1" | PHP_INI_ALL |
session.use_only_cookies | "1" | PHP_INI_ALL | PHP 4.3.0'dan beri kullanılabilmektedir.
session.referer_check | "" | PHP_INI_ALL |
session.entropy_file | "" | PHP_INI_ALL |
session.entropy_length | "0" | PHP_INI_ALL |
session.cache_limiter | "nocache" | PHP_INI_ALL |
session.cache_expire | "180" | PHP_INI_ALL |
session.use_trans_sid | "0" | PHP_INI_ALL | PHP <= 4.2.3'te PHP_INI_ALL. PHP < 5'te PHP_INI_PERDIR. PHP 4.0.3'ten beri kullanılabilmektedir.
session.bug_compat_42 | "1" | PHP_INI_ALL | PHP 4.3.0'dan beri kullanılabilmektedir. PHP 5.4.0'da kaldırılmıştır.
session.bug_compat_warn | "1" | PHP_INI_ALL | PHP 4.3.0'dan beri kullanılabilmektedir. PHP 5.4.0'da kaldırılmıştır.
session.hash_function | "0" | PHP_INI_ALL | PHP 5.0.0'dan beri kullanılabilmektedir.
session.hash_bits_per_character | "4" | PHP_INI_ALL | PHP 5.0.0'dan beri kullanılabilmektedir.
url_rewriter.tags | "a=href,area=href,frame=src,form=,fieldset=" | PHP_INI_ALL | PHP 4.0.4'ten beri kullanılabilmektedir.
session.upload_progress.enabled | "1" | PHP_INI_PERDIR | PHP 5.4.0'dan beri kullanılabilmektedir.
session.upload_progress.cleanup | "1" | PHP_INI_PERDIR | PHP 5.4.0'dan beri kullanılabilmektedir.
session.upload_progress.prefix | "upload_progress_" | PHP_INI_PERDIR | PHP 5.4.0'dan beri kullanılabilmektedir.
session.upload_progress.name | "PHP_SESSION_UPLOAD_PROGRESS" | PHP_INI_PERDIR | PHP 5.4.0'dan beri kullanılabilmektedir.
session.upload_progress.freq | "1%" | PHP_INI_PERDIR | PHP 5.4.0'dan beri kullanılabilmektedir.
session.upload_progress.min_freq | "1" | PHP_INI_PERDIR | PHP 5.4.0'dan beri kullanılabilmektedir.
session.lazy_write | "1" | PHP_INI_ALL | PHP 7.0.0'dan beri kullanılabilmektedir.
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Oturum yönetim sistemi, php.ini dosyanıza yerleştirebileceğiniz bazı yapılandırma yönergelerini destekler. Bu yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

session.save_handler string
session.save_handler yönergesi (kayıt sistemi), bir oturumla ilişkilendirilmiş veriyi saklamakta ve geri almakta nelerin kullanılacağını tanımlar. files (dosyalar) öntanımlı değerdir. Bazı eklentilerin kendi save_handler yönergeleri vardır; bunları kurulumunuzun phpinfo() çıktısında görebilirsiniz. Ayrıca bakınız: session_set_save_handler().
session.save_path string
session.save_path yönergesi session.save_handler yönergesinde belirtilen kayıt sistemine hangi değiştirgelerin aktarılacağını tanımlar. Öntanımlı kayıt sistemin (files) seçerseniz bu yönergenin değeri dosyaların oluşturulacağı dosya yolu olacaktır. Ayrıca bakınız: session_save_path().

Oturum dosyalarınızın yayılacağı dizin derinliğini belirlemekte kullanılmak üzere seçimlik bir N değiştirgesi vardır. Örneğin yönergeye '5;/tmp' değerini atarsanız, bir oturum dosyası şöyle bir konuma konabilir: /tmp/4/b/1/e/3/sess_4b1e384ad74619bd212e236e52a5a174If. N değiştirgesini kullanacaksanız bu dizinleri kullanmadan önce oluşturmuş olmalısınız. Bunu yapmak için ext/session altında mod_files.sh adında bir betik vardır (Windows için mod_files.bat). Ayrıca, N değiştirgesinin sıfırdan büyük bir değerle kullanılması durumunda özdevinimli bir çöp toplayıcının devreye gireceğine de dikkat ediniz; daha ayrıntılı bilgi için php.ini dosyanıza bakınız. Ayrıca, N değiştirgesini kullanmanız durumunda, noktalı virgül (;) ayracı php.ini dosyasında açıklamaları başlatmak için kullanıldığından yönergenin değerini tırnak içine almalısınız.

Dosya saklama modülü dosyaları öntanımlı olarak mode 600 kullanarak oluşturur. Bu öntanımlı değer seçimlik MODE ile değiştirilebilir: N;MODE;/path burada MODE dosya kipinin sekizlik tabanda gösterimidir. Dosya kipini bu yolla belirlemek sürecin umask'ını etkilemez.

Uyarı

Bu yönergeyi öntanımlı değeriyle bırakırsanız veya herkesin okuyabileceği bir dizin tanımlarsanız (öntanımlı olan /tmp gibi), diğer kullanıcılar bu dizindeki dosyaların listesini alarak oturum bilgilerini sunucu üzerinde kendi amaçları doğrultusunda kullanabilirler.

Dikkat

Dizin derinliğini belirlemekte kullanılan seçimlik N değiştirgesi yukarıda belirtildiği gibi kullanılırken 1 veya 2'den daha yüksek bir değer kullanımı büyük sayıda dizin gerektirmesindan dolayı bir çok site için uygun olmayacaktır; örneğin, 3 değeri dosya sistemi üzerinde 64^3 dizinin varolabileceğini öngörür, bu da çok sayıda dosya girdisi açılması ve büyük miktarda alanın boşa harcanması demektir.

Sadece, sitenizin 2'den büyük bir N değeri gerektirecek kadar büyük olması halinde 2'den büyük bir değer kullanabilirsiniz.

Bilginize: PHP'nin 4.3.6 sürümünden önce, Windows kullanıcılar bu değeri PHP'nin oturum işlevlerini kullanacağı sırada değiştirmek zorundaydılar. Geçerli bir dosya yolu olarak, örneğin c:/temp belirtilebilir.

session.name string
session.name yönergesi çerez ismi olarak kullanılacak oturum ismini belirler. İsim sadece abecesayısal karakterler içermelidir. PHPSESSID öntanımlıdır. Ayrıca bakınız: session_name().
session.auto_start boolean
session.auto_start yönergesi, bir oturumun özdevinimli olarak isteğin başlangıcında başlatılıp başlatılmayacağını belirler. Öntanımlı değer 0 olup, başlatılmaz.
session.serialize_handler string
session.serialize_handler yönergesi, veriyi dizgeleştirmek/nesneleştirmek için kullanılacak eylemcinin ismini belirler. Şimdilik sadece PHP dizgeleştirme biçemi (ismi: php_serialize), PHP'nin dahili biçemleri (php ve php_binary ismiyle) ve WDDX (wddx ismiyle) desteklenmektedir. PHP, WDDX desteği ile derlenmişse wddx bir seçenek haline gelir. php_serialize PHP 5.5.4 ve sonrasında kullanılabilir. php_serialize dahili olarak düz serialize/unserialize işlevini kullanır ve php ile php_binary'nin sahip olduğu sınırlamalardan azadedir. Daha eski digeleştirme eylemcileri $_SESSION içinde ne bir sayısal indis ne de özel karakterleri (| ve !) içeren bir dizge indisi saklayabilir. Betiğin durmasına yolaçan özel karakter hataları ve sayısal indislerden kaçınmak için php_serialize biçemini kullanın. php öntanımlıdır.
session.gc_probability integer
session.gc_probability yönergesi session.gc_divisor yönergesi ile birlikte gc (garbage collection) çöp toplayıcı yordamının başlatılma olasılığını yönetmek için kullanılır. Ayrıntılar için session.gc_divisor yönergesinin açıklamasına bakınız.
session.gc_divisor integer
session.gc_divisor yönergesi session.gc_probability yönergesi ile birlikte, her oturum ilklendirilişinde gc (garbage collection) çöp toplayıcı yordamının başlatılma olasılığını yönetmek için kullanılır. Olasılık, gc_probability/gc_divisor şeklinde hesaplanır. Örneğin, 1/100 oranının anlamı: Her istekte GC sürecinin başlatılma şansı %1'dir. session.gc_divisor yönergesinin öntanımlı değeri 100'dür.
session.gc_maxlifetime integer
session.gc_maxlifetime yönergesi verinin kaç saniye sonra 'çöp' olarak ele alınıp temizleneceğini belirler. Çöp toplayıcı oturum başlangıcında etkin olur (session.gc_probability ve session.gc_divisor yönergelerine bağlı olarak).

Bilginize:

Eğer session.gc_maxlifetime değeri olarak farklı betikler farklı değerler belirtiyorsa fakat oturum verisini saklamak için aynı yeri paylaşıyorlarsa verileri temizlemek için en küçük değere sahip betiğin değeri kullanılır. Bu durumda, bu yönerge session.save_path yönergesi ile birlikte kullanılmalıdır.

session.referer_check string
session.referer_check yöntemi, Her HTTP Referrer başlığında içerilmesini istediğiniz bir alt dizgeyi tanımlar. Referrer başlığı istemci tarafından bu alt dizge içerilmeden gönderilmişse gömülü oturum kimliği geçersiz olur. Yönergenin öntanımlı değeri boş dizgedir.
session.entropy_file string
session.entropy_file yönergesi, oturum kimliğinin oluşturulma sürecinde ek döküntü kaynağı olarak kullanılacak harici bir özkaynağa (bir dosyaya) bir yol belirtir. Çoğu Unix sisteminde kullanılan örnekler: /dev/random veya /dev/urandom. Bu özellik Windows'ta PHP 5.3.3'ten beri desteklenmektedir. session.entropy_length yönergesine sıfırdan farklı bir değer atamak PHP'nin Windows Random API'sini bir döküntü kaynağı olarak kullanmasını sağlayacaktır.

Bilginize: PHP 5.4.0 ve sonrasında session.entropy_file için /dev/urandom veya /dev/arandom öntanımlıdır (hangisi varsa). PHP 5.3.0'da bu yönergenin öntanımlı değeri boş dizge idi.

session.entropy_length integer
session.entropy_length yönergesi yukarıdaki yönergede belirtilen dosyadan okunacak baytların sayısını belirler. Öntanımlı değer 0'dir (hiç bayt okunmayacak).
session.use_strict_mode boolean
session.use_strict_mode modülün katı oturum kimliği kipini kullanıp kullanmayacağını belirler. Bu kip etkinse modül ilklendirilmemiş oturum kimliklerini kabul etmeyecektir. Tarayıcı tarafından ilklendirilmemiş bir oturum kimliği gönderilmişse, tarayıcıya yeni oturum kimliği gönderilir. Uygulamalar katı kipte oturum sabitlemesinden oturum benimsenmesi yoluyla korunur. 0(iptal) öntanımlıdır .
session.use_cookies boolean
session.use_cookies yönergesi modülün, oturum kimliğini istemci tarafında saklamak için çerezleri kullanıp kullanmayacağını belirler. Öntanımlı değer 1 olup çerezler kullanılır.
session.use_only_cookies boolean
session.use_only_cookies yönergesi modülün, oturum kimliğini istemci tarafında saklamak için sadece çerezlerin mi kullanılacağını belirler. Bu yönergeyi etkin kılarak oturum kimliklerinin URL'lerde aktarılmaması sağlamak suretiyle saldırıları önlemiş olursunuz. Bu yönerge PHP 4.3.0'da eklenmiştir. PHP 5.3.0'dan beri öntanımlı değer 1'dir (etkin).
session.cookie_lifetime integer
session.cookie_lifetime yönergesi tarayıcıya gönderilen çerezin ömrünü saniye cinsinden belirler. Öntanımlı olan 0 değerinin anlamı "tarayıcı kapatılıncaya kadar"dır. Ayrıca bakınız: session_get_cookie_params() ve session_set_cookie_params().

Bilginize:

Zaman aşımı zaman damgası sunucu zamanına göre belirlenir. Sunucu zamanının istemci zamanıyla aynı olma zorunluluğu yoktur.

session.cookie_path string
session.cookie_path yönergesi oturum çerezinin path anahtarını tanımlar. Bölü çizgisi / öntanımlıdır. Ayrıca bakınız: session_get_cookie_params() ve session_set_cookie_params().
session.cookie_domain string
session.cookie_domain yönergesi oturum çerezinin domain anahtarını tanımlar. Öntanımlı değer none olup, çerez belirtimine göre çerezi üreten sunucunun konak isminin kullanılacağı anlamına gelir. Ayrıca bakınız: session_get_cookie_params() ve session_set_cookie_params().
session.cookie_secure boolean
session.cookie_secure yönergesi oturum çerezinin secure anahtarını tanımlar. Öntanımlı olarak off olup anlamı: Çerezler sadece güvenli bağlantılar üzerinden gönderilmez. Bu yönerge PHP 4.0.4'te eklenmiştir. Ayrıca bakınız: session_get_cookie_params() ve session_set_cookie_params().
session.cookie_httponly boolean
session.cookie_httponly yönergesi oturum çerezinin httponly anahtarını tanımlar. Etkin olduğu takdirde çerezlere sadece HTTP protokolü üzerinden erişilebilir. Yani çerezlere JavaScript betik dilleriyle erişilemez. Bu ayar, (tüm tarayıcılar tarafından desteklenmiyor olsa da) özellikle XSS saldırılarıyla kimlik hırsızlığını önlemek için çok etkilidir.
session.cache_limiter string
session.cache_limiter yönergesi, oturum sayfaları için kullanılacak önbellek denetim yöntemini belirler. Şu değerlerden biri olabilir: nocache, private, private_no_expire ve public nocache öntanımlıdır. Bu değerlerin anlamları için session_cache_limiter() işlevinin belgesine de bakınız.
session.cache_expire integer
session.cache_expire yönergesi, önbelleğe alınan oturumlar için dakika cinsinden ömür (ttl) tanımlar. Önbellek sınırlayıcı yoksa bu ayar etkisizdir. 180 öntanımlı değerdir. Ayrıca bakınız: session_cache_expire().
session.use_trans_sid boolean
session.use_trans_sid yönergesi, şeffaf SID desteğinin etkin olup olmayacağını belirler. Öntanımlı değer 0 olup etkin değildir.

Bilginize: URL'ye dayalı oturum yönetiminin çerezlere dayalı oturum yönetimine göre daha fazla güvenlik riski vardır. Örneğin, kullanıcılar, etkin oturum kimliğini içeren bir URL'yi epostayla arkadaşlarına gönderebilir veya sık kullanılanlarına kaydedebilir; böylece bu kişiler sitenize hep aynı oturum kimliğiyle oturum açarlar.

session.bug_compat_42 boolean
PHP'nin 4.2.3 ve önceki sürümlerinde, belgelenmemiş bir hata vardı: register_globals ektin olmadığı halde bir oturum değişkeninin küresel etki alanında ilklendirilmesine izin verilirdi. PHP 4.3.0 ve sonrasında session.bug_compat_warn ektin olduğunda, bu özellik kullanılırsa bir uyarı verilmektedir. Bu özellik/hata bu yönergeye Off değeri atanarak iptal edilebilmektedir.
session.bug_compat_warn boolean
PHP'nin 4.2.3 ve önceki sürümlerinde, belgelenmemiş bir hata vardı: register_globals ektin olmadığı halde bir oturum değişkeninin küresel etki alanında ilklendirilmesine izin verilirdi. PHP 4.3.0 ve sonrasında bu yönerge session.bug_compat_42 yönergesi ile birlikte etkin kılındığında, bu özellik kullanılırsa bir uyarı verilmektedir.
session.hash_function mixed
session.hash_function yönergesi oturum kimliğinin üretilmesinde kullanılmak üzere bir ileti özeti algoritması belirtilmesini sağlar. '0' değeri MD5 (128 bitlik) algoritmasının, '1' ise SHA-1 (160 bitlik) algoritmasının kullanılmasını sağlar.

PHP 5.3.0'dan itibaren hash eklentisini (kullanılabilir durumdaysa) kullanarak sha512 veya whirlpool gibi algoritmalar belirtilebilmektedir. Desteklenen algoritmaların tam listesi hash_algos() işlevi ile edinilebilir

Bilginize:

Bu yönerge PHP 5'ten itibaren kullanılabilmektedir.

session.hash_bits_per_character integer
session.hash_bits_per_character yönergesi, ikil ileti özeti dizgesi okunur biçeme dönüştürülürken karakterlerin kaç bitle saklanacağını belirler. Olası değerler: '4' (0-9, a-f), '5' (0-9, a-v), '6' (0-9, a-z, A-Z, "-", ",").

Bilginize:

Bu yönerge PHP 5'ten itibaren kullanılabilmektedir.

url_rewriter.tags string
url_rewriter.tags yönergesi, şeffaf SID desteği etkin olduğunda oturum kimliğinin dahil edilmesi için hangi HTML etiketlerinin yeniden yazılacağını belirler. Öntanımlı değer: a=href,area=href,frame=src,input=src,form=fakeentry,fieldset=

Bilginize: Eğer tam HTML/XHTML uyumluluğu isterseniz, form girdisini silip form alanlarını sınırlamak için <fieldset> etiketlerini kullanın.

session.upload_progress.enabled boolean
Yükleme işleminin izlenmesini etkinleştirir. Öntanımlı olarak 1, yani etkindir.
session.upload_progress.cleanup boolean
Tüm POST verisi okunur okunmaz (yani, yükleme tamamlandığında) işlem bilgisi temizlenir. Öntanımlı olarak 1, yani etkindir.

Bilginize: Bu özelliğin daima etkin olması şiddetle önerilir.

session.upload_progress.prefix string
A prefix used for the upload progress key in the $_SESSION içinde yükleme işlemi anahtarı için kullanılacak önek. Bu önek, eşsiz bir indis elde ertmek için $_POST[ini_get("session.upload_progress.name")] değeriyle birleştirilir. "upload_progress_" öneki öntanımlıdır.
session.upload_progress.name string
İşlem bilgisini $_SESSION içinde saklamak için kullanılacak anahtar. Ayrıca bakınız: session.upload_progress.prefix. $_POST[ini_get("session.upload_progress.name")] değeri aktarılmammışsa veya kullanılabilir değilseyükleme işlemi kaydedilmez. "PHP_SESSION_UPLOAD_PROGRESS" öntanımlıdır.
session.upload_progress.freq mixed
Yükleme izleme bilgisinin ne sıklıkla güncelleneceğini tanımlar. Bayt cinsinden veya yüzde olarak belirtilebilir. Örneğin, yükleme izleme bilgisi her 100 baytta bir veya dosyanın her %1'i alındığında güncellenebilir. "1%" öntanımlıdır.
session.upload_progress.min_freq integer
Güncellemeler arasındaki asgari bekleme süresi (saniye cinsinden). "1" öntanımlıdır.
session.lazy_write boolean
session.lazy_write = 1 atandığında oturum verisi sadece değişirse yeniden yazılır. Bu öntanımlı değerdir ve etkindir.

register_globals yapılandıma yönergesi oturum değişkenlerinin nasıl saklanacağını ve eski haline getirileceğini belirler.

Yükleme işlemi, session.upload_progress.enabled etkin olmadıkça ve $_POST[ini_get("session.upload_progress.name")] değişkenine bir atama yapılmadıkça kaydedilmeyecektir. Daha ayrıntılı bilgi çin bakınız: Oturumda Yüklemelerin İzlenmesi

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

SID (string)
Oturum ismini ve kimliğini "isim=kimlik" biçiminde veya oturum kimliğinin bir oturum çerezinde saklanması durumunda boş bir dizge içeren sabit. Bu kimlik session_id() tarafından döndürülen kimliktir.
Özkaynak Türleri
Örnekler
Oturumlar


Örnekler

İçindekiler

  • Oturum Kimliğinin Aktarımı
  • Özel Oturum Eylemcisi
Öntanımlı Sabitler
Oturumlar


Örnekler
Oturum Kimliğinin Aktarımı
Örnekler
PHP Manual

Bilginize:

PHP 4.1.0'dan itibaren, $_SESSION değişkeni, $_POST, $_GET, $_REQUEST ve benzerleri gibi bir küresel değişken olarak kullanılabilmektedir. $HTTP_SESSION_VARS değişkeninin aksine $_SESSION daima küreseldir. Bu bakımdan, $_SESSION için global anahtar sözcüğünü kullanmanız gerekmez. Bu belgenin her yerde $_SESSION kullanılacak biçimde değiştirilmiş oluşuna dikkat ediniz. $HTTP_SESSION_VARS değişkenini tercih ederseniz $_SESSION yerine ikame edebilirsiniz. Ayrıca şuna dikkat edin: $_SESSION değişkenini kullanmaya başlamadan önce session_start() ile oturumunuzu başlatmanız gerekir.

$_SESSION ilişkisel dizisindeki anahtarlar için PHP'de değişken isimlerine uygulanan sınırlamalar geçerlidir. Yani, bunları bir rakam ile başlatamazsınız, bir harf veya altçizgi karakteri ile başlamalıdırlar. Bu konuda daha ayrıntılı bilgi edinmek için bu kılavuzun Değişkenler bölümüne bakınız.

Eğer register_globals etkin değilse, sadece $_SESSION küresel ilişkisel dizisinin üyeleri oturum değişkeni olarak kayıt altına alınabilir. Sağlanan oturum değişkenleri sadece $_SESSION dizisinin üyeleri olarak kullanılabilir.

Güvenliği ve kodun okunabilirliğini arttırmak için $_SESSION (veya PHP 4.0.6 ve öncesi ile $HTTP_SESSION_VARS) kullanımı önerilir. $_SESSION kullanıldığı takdirde, session_register(), session_unregister(), session_is_registered() işlevlerine ihtiyaç kalmaz. Oturum değişkenlerine diğer değişkenler gibi erişilir.

Örnek 1 - Bir değişkeni $_SESSION ile kayıt altına almak

<?php
session_start();
// PHP 4.0.6 ve öncesi ile $HTTP_SESSION_VARS kullanın
if (!isset($_SESSION['count'])) {
  $_SESSION['count'] = 0;
} else {
  $_SESSION['count']++;
}
?>

Örnek 2 - register_globals etkin değilken $_SESSION ile bir değişkeni tanımsız yapmak

<?php
session_start();
// PHP 4.0.6 ve öncesi ile $HTTP_SESSION_VARS kullanın
unset($_SESSION['count']);
?>

Dikkat

$_SESSION dizisinin tamamını unset($_SESSION) ile tanımsız YAPMAYIN. Bu işlem, oturum değişkenlerinin $_SESSION süper küreseli üzerinden kayıt altına alınmamasına sebep olacaktır.

Uyarı

Başka bir değişkene gönderimi tekrar tanımlı kılmanın bir yolu olmadığından oturum değişkenlerinde gönderimleri kullanamazsınız.

Eğer register_globals etkinse, her küresel değişken bir oturum değişkeni olarak kayıt altına alınabilir. Bir oturumun yeniden başlatılması ile bu değişkenler ilgili küresel değişkenlere geri yerleştirilecektir. PHP'nin hangi değişkenlerin oturum değişkeni olarak kaydedildiğini bilmesi gerektiğinden değişkenlerin session_register() işlevi ile kayıt altına alınması gerekir. Bundan kaçınmak için girdilere $_SESSION içinde değer atamanız yeterlidir.

Dikkat

PHP 4.3.0 öncesinde, $_SESSION kullanıyorsanız ve register_globals etkin değilse, session_register(), session_is_registered() ve session_unregister() işlevlerini kullanmayın. Güvenliği ve başarımı arttırmak için register_globals yönergesine daima Off değerini atayın.

register_globals etkinse, küresel değişkenler ve $_SESSION girdileri, özdevinimli olarak önceki oturumda kayıt altına alınmış değerlere gönderimli olurlar. Ancak, register_globals iptal edilip, değişken sadece $_SESSION tarafından kayıt altına alınmışsa küresel değişken sadece bir sonraki isteğe kadar geçerli kalacaktır.

PHP 4.2.3 ve öncesinde bir kusur vardır. Eğer yeni bir oturum değişkenini session_register() kullanarak kayıt altına alırsanız, küresel etki alanındaki girdi ve $_SESSION girdisi sonraki session_start() çağrısına kadar aynı değere gönderimli olmayacaklardır. Yani, session_register() ile kayıt altına alınmış küresel değişkende bir değişiklik yaparsanız $_SESSION girdisi bu değişikliği yansıtmayacaktır. Bu durum PHP 4.3.0'da da geçerlidir.

Örnekler
Oturum Kimliğinin Aktarımı
Örnekler


Oturum Kimliğinin Aktarımı

Bir oturum kimliğini yaymanın iki yolu vardır:

  • Çerezler
  • URL değiştirgesi

Oturum modülü her ikisini de destekler. Çerezler en uygunudur, fakat her zaman kullanmak mümkün olmadığından ikinci bir yöntem sağlıyoruz. İkinci yöntem, oturum kimliğini doğrudan URL'nin içine gömer.

PHP bağlantıları şeffaf olarak dönüştürme yeteneğine sahiptir. PHP 4.2.0 ve sonrasını kullanmıyorsanız, bunu PHP'yi derlerken kendinizin etkin kılması gerekir. Unix altında, configure betiğine --enable-trans-sid seçeneğini vermeniz gerekir. PHP bu seçenekle derlenmiş ve çalışma anında session.use_trans_sid yönergesi etkin kılınmışsa, göreli URI'ler özdevinimli olarak oturum kimliğini içerecek şekilde değiştirilirler.

Bilginize:

arg_separator.output php.ini yönergesi değiştirge ayracının değiştirilebilmesini sağlar. Tam XHTML uyumluluğu için yönergeye değer olarak &amp; belirtin.

Ayrıca, oturum başlatıldığında tanımlanan SID sabitini de kullanabilirsiniz. Eğer istemci uygun bir oturum çerezi göndermezse, SID sabiti oturum_ismi=oturum_kimliği değerini içerecektir. Aksi takdirde sabitin değeri bir boş dizge olur. Bu durumda, oturum kimliğini koşulsuz olarak URL'lerin içine gömebilirsiniz.

Aşağıdaki örnekte bir değişkenin nasıl oturum değişkeni haline getirildiği ve SID sabitiyle başka bir sayfaya nasıl bağlantı kurulduğu gösterilmiştir.

Örnek 1 - Tek bir kullanıcının sayfa erişimlerinin sayılması

<?php

session_start();

if (empty($_SESSION['count'])) {
 $_SESSION['count'] = 1;
} else {
 $_SESSION['count']++;
}
?>

<p>
Merhaba sayın ziyaretçi, bu sayfayı <?php echo $_SESSION['count']; ?>
kere ziyaret ettiniz.
</p>

<p>
Devam etmek için, <a href="nextpage.php?<?php echo htmlspecialchars(SID);
?>">buraya tıklayınız</a>.
</p>

XSS saldırılarından kaçınmak için URL'ye SID yerleştirilirken htmlspecialchars() kullanılabilir.

SID sabitini URL'ye yukarıdaki gibi yerleştirecekseniz, PHP'yi --enable-trans-sid seçeneğiyle derlemeniz gerekmez.

Bilginize:

Göreli olmayan URL'lerin harici siteleri işaret ettikleri varsayılır ve oturum kimliğinin başka bir sunucuya ifşa edilme riskine karşı SID bunlara yerleştirilmez.

Özel Oturum Eylemcisi
Örnekler


Özel Oturum Eylemcisi

Veritabanlarını saklama alanı olarak kullanmak için veya başka bir saklama yöntemi kullanmak için session_set_save_handler() işleviyle kullanıcı seviyesinde bir saklama işlevleri kümesi tanımlamanız gerekir.

Oturum Kimliğinin Aktarımı
Session Upload Progress
Örnekler


Session Upload Progress

When the session.upload_progress.enabled INI option is enabled, PHP will be able to track the upload progress of individual files being uploaded. This information isn't particularly useful for the actual upload request itself, but during the file upload an application can send a POST request to a separate endpoint (via XHR for example) to check the status.

The upload progress will be available in the $_SESSION superglobal when an upload is in progress, and when POSTing a variable of the same name as the session.upload_progress.name INI setting is set to. When PHP detects such POST requests, it will populate an array in the $_SESSION, where the index is a concatenated value of the session.upload_progress.prefix and session.upload_progress.name INI options. The key is typically retrieved by reading these INI settings, i.e.

<?php
$key = ini_get("session.upload_progress.prefix") . $_POST[ini_get("session.upload_progress.name")];
var_dump($_SESSION[$key]);
?>

It is also possible to cancel the currently in-progress file upload, by setting the $_SESSION[$key]["cancel_upload"] key to TRUE. When uploading multiple files in the same request, this will only cancel the currently in-progress file upload, and pending file uploads, but will not remove successfully completed uploads. When an upload is cancelled like this, the error key in $_FILES array will be set to UPLOAD_ERR_EXTENSION.

The session.upload_progress.freq and session.upload_progress.min_freq INI options control how frequent the upload progress information should be recalculated. With a reasonable amount for these two settings, the overhead of this feature is almost non-existent.

Örnek 1 Example information

Example of the structure of the progress upload array.

<form action="upload.php" method="POST" enctype="multipart/form-data">
 <input type="hidden" name="<?php echo ini_get("session.upload_progress.name"); ?>" value="123" />
 <input type="file" name="file1" />
 <input type="file" name="file2" />
 <input type="submit" />
</form>

The data stored in the session will look like this:

<?php
$_SESSION["upload_progress_123"] = array(
 "start_time" => 1234567890,   // The request time
 "content_length" => 57343257, // POST content length
 "bytes_processed" => 453489,  // Amount of bytes received and processed
 "done" => false,              // true when the POST handler has finished, successfully or not
 "files" => array(
  0 => array(
   "field_name" => "file1",       // Name of the <input/> field
   // The following 3 elements equals those in $_FILES
   "name" => "foo.avi",
   "tmp_name" => "/tmp/phpxxxxxx",
   "error" => 0,
   "done" => true,                // True when the POST handler has finished handling this file
   "start_time" => 1234567890,    // When this file has started to be processed
   "bytes_processed" => 57343250, // Number of bytes received and processed for this file
  ),
  // An other file, not finished uploading, in the same request
  1 => array(
   "field_name" => "file2",
   "name" => "bar.avi",
   "tmp_name" => NULL,
   "error" => 0,
   "done" => false,
   "start_time" => 1234567899,
   "bytes_processed" => 54554,
  ),
 )
);

Uyarı

The web server's request buffering has to be disabled for this to work properly, else PHP may see the file upload only once fully uploaded. Servers such as Nginx are known to buffer larger requests.

Özel Oturum Eylemcisi
Oturumlar ve Güvenlik
Oturumlar


Oturumlar ve Güvenlik

Dış bağlantı: » Oturum Tespiti

Oturum modülü bir oturumda sakladığınız verinin sadece oturumu oluşturduğunuz kullanıcı tarafından görüldüğünü garanti edemez. Oturumun bütünlüğünü etkin olarak korumak için oturumun önemine bağlı olarak ek tedbirler almanız gerekir.

Oturumlarınız tarafından taşınan verinin önemine ve konuşlandırdığınız ek korumalara bağlı olarak ki, bunun bir fiyatı vardır, kullanıcının rahatı azalır. Örneğin, kullanıcılarınızı basit sosyal mühendislik taktiklerinden korumak isterseniz session.use_only_cookies yönergesini etkin kılmanız gerekir. Bu durumda, çerezler kullanıcı tarafında koşulsuz olarak etkin kılınmalıdır yoksa oturum çalışmayacaktır.

Bir mevcut oturum kimliğinin üçüncü şahıslara ifşa edilmesinin çeşitli yolları vardır. İfşa edilmiş bir oturum kimliği, üçüncü tarafın o kimlik ile ilişkilendirilmiş tüm özkaynaklara erişmesini mümkün kılar. İlk olarak oturum kimliğini taşıyan URL'ler ifşa olur. Harici bir siteye bir bağ verirseniz oturum kimliğini içeren URL harici sitenin günlük kayıtlarına geçebilir. İkinci olarak, daha etkin bir saldırgan ağ trafiğini dinleyebilir. Eğer şifreleme yapılmıyorsa oturum kimlikleri ağ üzerinden salt metin olarak akacaktır. Bu noktada çözüm, sunucunuzun SSL bağlantılar kurmasını sağlamak ve bunu kullanıcılarınız için zorunlu kılmaktır.

Session Upload Progress
Oturum İşlevleri
Oturumlar


Oturum İşlevleri

İçindekiler

  • session_abort — Discard session array changes and finish session
  • session_cache_expire — Önbelleğe alınan oturumun ömrünü döndürür
  • session_cache_limiter — Geçerli önbellek sınırlayıcısını döndürür ve/veya tanımlar
  • session_commit — session_write_close işlevinin takma adıdır
  • session_create_id — Create new session id
  • session_decode — Oturum verisini bir dizgeden elde eder
  • session_destroy — Bir oturumla ilişkilendirilmiş tüm veriyi yokeder
  • session_encode — Geçerli oturum verisini bir dizge olarak kodlar
  • session_gc — Perform session data garbage collection
  • session_get_cookie_params — Oturum çerezi değiştirgelerini döndürür
  • session_id — Geçerli oturum kimliğini döndürür ve/veya tanımlar
  • session_is_registered — Bir küresel değişkenin oturumda kayıtlı olup olmadığına bakar
  • session_module_name — Geçerli oturum modülünü döndürür ve/veya tanımlar
  • session_name — Geçerli oturum ismini döndürür ve/veya tanımlar
  • session_regenerate_id — Geçerli oturum kimliğini yenisiyle değiştirir
  • session_register_shutdown — Session shutdown function
  • session_register — Geçerli oturuma bir veya daha fazla küresel değişkeni kaydeder
  • session_reset — Re-initialize session array with original values
  • session_save_path — Geçerli oturum kayıt yolunu tanımlar ve/veya döndürür
  • session_set_cookie_params — Oturum çerezi değiştirgelerini tanımlar
  • session_set_save_handler — Kullanıcı seviyesi oturum saklama işlevlerini bildirir
  • session_start — Oturum verisini ilklendirir
  • session_status — Returns the current session status
  • session_unregister — Geçerli oturumdaki bir küresel değişkeni kayıtdışı yapar
  • session_unset — Free all session variables
  • session_write_close — Oturum verisini yazıp oturumu kapatır
Oturumlar ve Güvenlik
session_abort
Oturumlar


Discard session array changes and finish session

Oturum İşlevleri
session_cache_expire
Oturum İşlevleri
PHP Manual

session_abort

(PHP 5 >= 5.6.0, PHP 7)

session_abort — Discard session array changes and finish session

Açıklama

void session_abort ( void )

session_abort() finishes session without saving data. Thus the original values in session data are kept.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • $_SESSION
  • The session.auto_start configuration directive
  • session_start() - Oturum verisini ilklendirir
  • session_reset() - Re-initialize session array with original values
  • session_commit() - session_write_close işlevinin takma adıdır

Oturum İşlevleri
session_cache_expire
Oturum İşlevleri


Önbelleğe alınan oturumun ömrünü döndürür

session_abort
session_cache_limiter
Oturum İşlevleri
PHP Manual

session_cache_expire

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

session_cache_expire — Önbelleğe alınan oturumun ömrünü döndürür

Açıklama

int session_cache_expire ([ string $yeni_önbellek_ömrü ] )

session_cache_expire() işlevi, session.cache_expire yönergesinin değerini döndürür.

Bu değer, isteğin başlangıcında session.cache_expire yönergesinin 180 dakikalık öntanımlı değeriyle sıfırlanır. Bu bakımdan her istek için session_start() çağrısından önce bir session_cache_expire() çağrısı yapmanız gerekir.

Değiştirgeler

yeni_önbellek_ömrü

Belirtilmişse önbellekli oturumun ömrü bu değere ayarlanır.

Bilginize: yeni_önbellek_ömrü değeri, sadece session.cache_limiter yönergesine nocache'den farklı bir değer atanmışsa eski değerle değiştirilir.

Dönen Değerler

session.cache_expire yönergesinin değerini dakika cinsinden döndürür. Öntanımlı değer 180 dakikadır.

Örnekler

Örnek 1 - session_cache_expire() örneği

<?php

/* önbellek sınırlayıcıya 'private' atayalım */

session_cache_limiter('private');
$cache_limiter = session_cache_limiter();

/* önbellek ömrünü 30 dakika yapalım */
session_cache_expire(30);
$ömür = session_cache_expire();

/* oturumu başlatalım */

session_start();

echo "Önbellek sınırlayıcıya $cache_limiter kipi atandı.<br />";
echo "Önbellekteki sayfalar $ömür dakika sonra zaman aşımına uğrayacak";
?>

Ayrıca Bakınız

  • session.cache_expire
  • session.cache_limiter
  • session_cache_limiter() - Geçerli önbellek sınırlayıcısını döndürür ve/veya tanımlar

session_abort
session_cache_limiter
Oturum İşlevleri


Geçerli önbellek sınırlayıcısını döndürür ve/veya tanımlar

session_cache_expire
session_commit
Oturum İşlevleri
PHP Manual

session_cache_limiter

(PHP 4 >= 4.0.3, PHP 5, PHP 7)

session_cache_limiter — Geçerli önbellek sınırlayıcısını döndürür ve/veya tanımlar

Açıklama

string session_cache_limiter ([ string $sınırlayıcı ] )

session_cache_limiter() işlevi, geçerli önbellek sınırlayıcısının ismini döndürür.

Önbellek sınırlayıcı, istemciye gönderilen HTTP önbellek denetim başlıklarını tanımlar. Bu başlıklar kuralları, istemci veya aracı vekiller tarafından önbelleğe alınmış sayfa içeriğine göre belirler. Önbellek sınırlayıcıya nocache atamak istemci/vekil önbelleklemesine izin vermez. public değeri, vekiller ve istemciler tarafından önbelleklemeye izin verir. private değeri ise, vekil önbelleklemesine izin vermezken istemcilerin içeriği önbelleklemesine izin verir.

private kipinde, istemciye gönderilmiş bir Expire başlığı, Mozilla dahil, bazı tarayıcıların kafasını karıştırır. private_no_expire kipi sayesinde bu sorundan kaçınmak mümkündür. Bu kipte, istemciye Expire başlığı asla gönderilmez.

İstek başlangıcında, önbellek sınırlayıcı session.cache_limiter yönergesinin öntanımlı değerine ayarlanır. Bu bakımdan her istek için session_start() çağrısından önce bir session_cache_limiter() çağrısı yapmanız gerekir.

Değiştirgeler

sınırlayıcı

Belirtildiği takdirde, geçerli önbellek sınırlayıcı ismi yeni değerle değiştirilir.

Olası değerler
Değer Gönderilen başlıklar
public
Expires: (sometime in the future, according session.cache_expires)
Cache-Control: public, max-age=(sometime in the future, according to session.cache_expire
Last-Modified: (the timestamp of when the session was last saved)
private_no_expire
Cache-Control: private, max-age=(session.cache_expire in the future), pre-check=(session.cache_expire in the future)
Last-Modified: (the timestamp of when the session was last saved)
private
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: private, max-age=(session.cache_expire in the future), pre-check=(session.cache_expire in the future)
Last-Modified: (the timestamp of when the session was last saved)
nocache
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Pragma: no-cache

Dönen Değerler

Geçerli önbellek sınırlayıcısının ismini döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
4.2.0 | private_no_expire kipi eklendi.

Örnekler

Örnek 1 - session_cache_limiter() örneği

<?php

/* önbellik sınırlayıcıya 'private' atayalım */

session_cache_limiter('private');
$cache_limiter = session_cache_limiter();

echo "Önbellek sınırlayıcıya $cache_limiter kipi atandı.<br />";
?>

Ayrıca Bakınız

  • session.cache_limiter

session_cache_expire
session_commit
Oturum İşlevleri


session_write_close işlevinin takma adıdır

session_cache_limiter
session_create_id
Oturum İşlevleri
PHP Manual

session_commit

(PHP 4 >= 4.4.0, PHP 5, PHP 7)

session_commit — session_write_close() işlevinin takma adıdır

Açıklama

Bu işlev session_write_close() işlevinin takma adıdır.

session_cache_limiter
session_create_id
Oturum İşlevleri


Create new session id

session_commit
session_decode
Oturum İşlevleri
PHP Manual

session_create_id

(PHP 7 >= 7.1.0)

session_create_id — Create new session id

Açıklama

string session_create_id ([ string $prefix ] )

session_create_id() is used to create new session id for the current session. It returns collision free session id.

If session is not active, collision check is omitted.

Session ID is created according to php.ini settings.

It is important to use the same user ID of your web server for GC task script. Otherwise, you may have permission problems especially with files save handler.

Değiştirgeler

prefix

If prefix is specified, new session id is prefixed by prefix. Not all characters are allowed within the session id. Characters in the range a-z A-Z 0-9 , (comma) and - (minus) are allowed.

Dönen Değerler

session_create_id() returns new collision free session id for the current session. If it is used without active session, it omits collision check.

Örnekler

Örnek 1 session_create_id() example with session_regenerate_id()

<?php
// My session start function support timestamp management
function my_session_start() {
    session_start();
    // Do not allow to use too old session ID
    if (!empty($_SESSION['deleted_time']) && $_SESSION['deleted_time'] < time() - 180) {
        session_destroy();
        session_start();
    }
}

// My session regenerate id function
function my_session_regenerate_id() {
    // Call session_create_id() while session is active to
    // make sure collision free.
    if (session_status() != PHP_SESSION_ACTIVE) {
        session_start();
    }
    // WARNING: Never use confidential strings for prefix!
    $newid = session_create_id('myprefix-');
    // Set deleted timestamp. Session data must not be deleted immediately for reasons.
    $_SESSION['deleted_time'] = time();
    // Finish session
    session_commit();
    // Make sure to accept user defined session ID
    // NOTE: You must enable use_strict_mode for normal operations.
    ini_set('session.use_strict_mode', 0);
    // Set new custome session ID
    session_id($newid);
    // Start with custome session ID
    session_start();
}

// Make sure use_strict_mode is enabled.
// use_strict_mode is mandatory for security reasons.
ini_set('session.use_strict_mode', 1);
my_session_start();

// Session ID must be regenerated when
//  - User logged in
//  - User logged out
//  - Certain period has passed
my_session_regenerate_id();

// Write useful codes
?>

Ayrıca Bakınız

  • session_regenerate_id() - Geçerli oturum kimliğini yenisiyle değiştirir
  • session_start() - Oturum verisini ilklendirir
  • session.use_strict_mode

session_commit
session_decode
Oturum İşlevleri


Oturum verisini bir dizgeden elde eder

session_create_id
session_destroy
Oturum İşlevleri
PHP Manual

session_decode

(PHP 4, PHP 5, PHP 7)

session_decode — Oturum verisini bir dizgeden elde eder

Açıklama

bool session_decode ( string $veri )

session_decode() işlevi oturumdaki değişkenleri tekrar atamak için veri dizgesini çözümler.

Değiştirgeler

veri

Saklanmak üzere dizge olarak kodlanmış veri.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • session_encode() - Geçerli oturum verisini bir dizge olarak kodlar

session_create_id
session_destroy
Oturum İşlevleri


Bir oturumla ilişkilendirilmiş tüm veriyi yokeder

session_decode
session_encode
Oturum İşlevleri
PHP Manual

session_destroy

(PHP 4, PHP 5, PHP 7)

session_destroy — Bir oturumla ilişkilendirilmiş tüm veriyi yokeder

Açıklama

bool session_destroy ( void )

session_destroy() işlevi geçerli oturumla ilişkilendirilmiş tüm veriyi yok eder. Oturumla ilişkilendirilmiş küresel değişkenleri ve oturum çerezini tanımsız yapmaz. Oturum değişkenlerini tekrar kullanmak için session_start() çağrısı yapılmalıdır.

Kullanıcı çıktısını günlüğe kaydetmek gibi bir amaçla oturumu topyekün öldürmek için oturum kimliğinin de tanımsız yapılması gerekir. Eğer oturum kimliğini yaymak için bir çerez kullanılmışsa (öntanımlı olarak böyledir), oturum çerezinin de silinmesi gerekir. Bunun için setcookie() kullanılabilir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Bir oturumun $_SESSION ile yokedilmesi

<?php
// Oturumu ilklendirelim.
// session_name("birisim") kullanacaksanız tam sırasıdır!
session_start();

// Oturum değişkenlerinin tamamını tanımsız yapalım.
$_SESSION = array();

// Oturum öldürülmek istenirse oturum çerezinin de silinmesi gerekir.
// Dikkat: Bu sadece oturum verisini değil, oturumu da yok edecektir!
if (isset($_COOKIE[session_name()])) {
    setcookie(session_name(), '', time()-42000, '/');
}

// Son olarak oturumu yok ediyoruz.
session_destroy();
?>

Notlar

Bilginize:

session_unset() işlevini sadece $_SESSION kullanmayan eski kodlarda kullanın.

Ayrıca Bakınız

  • unset() - Belirtilen değişkeni tanımsız yapar
  • setcookie() - Bir çerez gönderir

session_decode
session_encode
Oturum İşlevleri


Geçerli oturum verisini bir dizge olarak kodlar

session_destroy
session_gc
Oturum İşlevleri
PHP Manual

session_encode

(PHP 4, PHP 5, PHP 7)

session_encode — Geçerli oturum verisini bir dizge olarak kodlar

Açıklama

string session_encode ( void )

session_encode() işlevi, geçerli oturumun içeriğini kodlanmış bir dizge olarak döndürür.

Dönen Değerler

Geçerli oturumun içeriğini kodlanmış bir dizge olarak döndürür.

Ayrıca Bakınız

  • session_decode() - Oturum verisini bir dizgeden elde eder

session_destroy
session_gc
Oturum İşlevleri


Perform session data garbage collection

session_encode
session_get_cookie_params
Oturum İşlevleri
PHP Manual

session_gc

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

session_gc — Perform session data garbage collection

Açıklama

int session_gc ( void )

session_gc() is used to perform session data GC(garbage collection). PHP does probability based session GC by default.

Probability based GC works somewhat but it has few problems. 1) Low traffic site's session data may not be deleted within preferred duration. 2) High traffic site's may have too frequent GC. 3) GC is performed on the user's request and the user will experience GC delay.

Therefore, it is recommended to execute GC periodically for production systems. e.g. Use "cron" for UNIX like systems. Make sure to disable probability based GC by setting session.gc_probability to 0.

Dönen Değerler

session_gc() returns number of deleted session data for success, FALSE for failure.

Old save handlers do not return number of deleted session data, but only success/failure flag. If this is the case, number of deleted session data became 1 regardless of actually deleted data.

Örnekler

Örnek 1 session_gc() example for task managers like cron

<?php
// Note: This script should be executed by the same user of web server process.

// Need active session to initialize session data storage access.
session_start();

// Executes GC immediately
session_gc();

// Clean up session ID created by session_gc()
session_destroy();
?>

Örnek 2 session_gc() example for user accessible script

<?php
// Note: session_gc() is recommended to be used by task manager script, but
// it may be used as follows.

// Used for last GC time check
$gc_time = '/tmp/php_session_last_gc';
$gc_period = 1800;

session_start();
// Execute GC only when GC period elapsed.
// i.e. Calling session_gc() every request is waste of resources.
if (file_exists($gc_time)) {
    if (filemtime($gc_time) < time() - $gc_period) {
        session_gc();
        touch($gc_time);
    }
} else {
    touch($gc_time);
}
?>

Ayrıca Bakınız

  • session_start() - Oturum verisini ilklendirir
  • session_destroy() - Bir oturumla ilişkilendirilmiş tüm veriyi yokeder
  • session.gc_probability

session_encode
session_get_cookie_params
Oturum İşlevleri


Oturum çerezi değiştirgelerini döndürür

session_gc
session_id
Oturum İşlevleri
PHP Manual

session_get_cookie_params

(PHP 4, PHP 5, PHP 7)

session_get_cookie_params — Oturum çerezi değiştirgelerini döndürür

Açıklama

array session_get_cookie_params ( void )

Oturum çerezi değiştirgelerini döndürür.

Dönen Değerler

Geçerli oturum çerezi bilgisini içeren bir dizi döndürür. Dizi şu elemanları içerir:

  • "lifetime" - Çerezin saniye cinsinden ömrü.
  • "path" - Oturum bilgisinin saklanacağı dosya yolu.
  • "domain" - Çerezi bırakan alanın ismi.
  • "secure" - TRUE ise çerez sadece güvenli bağlantılar üzerinden gönderilir.
  • "httponly" - TRUE ise çereze sadece HTTP protokolü üzerinden erişilebilir.

Sürüm Bilgisi

Sürüm: | Açıklama
5.2.0 | Dönen diziye "httponly" anahtarı eklendi.
4.0.4 | Dönen diziye "secure" anahtarı eklendi.

Ayrıca Bakınız

  • session.cookie_lifetime
  • session.cookie_path
  • session.cookie_domain
  • session.cookie_secure
  • session.cookie_httponly
  • session_set_cookie_params() - Oturum çerezi değiştirgelerini tanımlar

session_gc
session_id
Oturum İşlevleri


Geçerli oturum kimliğini döndürür ve/veya tanımlar

session_get_cookie_params
session_is_registered
Oturum İşlevleri
PHP Manual

session_id

(PHP 4, PHP 5, PHP 7)

session_id — Geçerli oturum kimliğini döndürür ve/veya tanımlar

Açıklama

string session_id ([ string $id ] )

session_id() işlevi, geçerli oturumun oturum kimliğini döndürür.

URL'lere eklemek amacıyla geçerli oturumun oturum kimliği oturum ismiyle birlikte SID sabitinden de öğrenilebilir. Daha ayrıntılı bilgi için Oturum Yönetim Sistemine bakınız.

Değiştirgeler

id

id belirtilmişse, geçerli oturum kimliğinin yerini alır. session_id() bu amaçla kullanılacaksa session_start() işlevinden önce çağrılmalıdır. Oturum kayıt ortamına bağlı olarak oturum kimliği içinde tüm karakterlere izin verilmez. Örneğin, oturum kayıt ortamı dosyalar olduğu takdirde sadece a-z A-Z 0-9 , (virgül) and - (tire) karakterlerine izin verilir.

Bilginize: Oturum çerezleri kullanıldığında, session_id() işlevini oturum kimliğini değiştirmek için kullanırsanız, geçerli oturum kimliğinin belirtilenle aynı olup olmadığına bakılmaksızın session_start() çağrısı yapıldığında daima yeni bir çerez gönderilir.

Dönen Değerler

session_id() işlevi geçerli oturumun oturum kimliğini veya geçerli bir oturum yoksa boş bir dizge ("") döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.0 | Oturum kayıt ortamı dosyalar olduğu takdirde, artık , (virgül) ve - (tire) karakterlerine de izin veriliyor.

Ayrıca Bakınız

  • session_regenerate_id() - Geçerli oturum kimliğini yenisiyle değiştirir
  • session_start() - Oturum verisini ilklendirir
  • session_set_save_handler() - Kullanıcı seviyesi oturum saklama işlevlerini bildirir
  • session.save_handler

session_get_cookie_params
session_is_registered
Oturum İşlevleri


Bir küresel değişkenin oturumda kayıtlı olup olmadığına bakar

session_id
session_module_name
Oturum İşlevleri
PHP Manual

session_is_registered

(PHP 4, PHP 5 < 5.4.0)

session_is_registered — Bir küresel değişkenin oturumda kayıtlı olup olmadığına bakar

Açıklama

bool session_is_registered ( string $isim )

Bir küresel değişkenin oturumda kayıtlı olup olmadığına bakar.

Uyarı

Bu işlevin kullanımı PHP 5.3.0'dan beri ÖNERİLMEMEKTEDİR ve PHP 6.0.0'da tamamen KALDIRILMIŞTIR. Bu işleve kesinlikle güvenmemelisiniz.

Değiştirgeler

isim

Değişkenin ismi.

Dönen Değerler

Geçerli oturumda isim adında kayıtlı bir değişken varsa TRUEyoksa FALSE döner.

Notlar

Bilginize:

Eğer $_SESSION (veya PHP 4.0.6 ve öncesinde $HTTP_SESSION_VARS kullanılmışsa, değişkenin $_SESSION içinde kayıtlı olup olmadığına bakmak için isset() işlevini kullanın.

Dikkat

$_SESSION (veya $HTTP_SESSION_VARS)
dizisini kullanıyorsanız, session_register(),
session_is_registered() ve
session_unregister() işlevlerini kullanmayın.

session_id
session_module_name
Oturum İşlevleri


Geçerli oturum modülünü döndürür ve/veya tanımlar

session_is_registered
session_name
Oturum İşlevleri
PHP Manual

session_module_name

(PHP 4, PHP 5, PHP 7)

session_module_name — Geçerli oturum modülünü döndürür ve/veya tanımlar

Açıklama

string session_module_name ([ string $modül ] )

session_module_name() işlevi geçerli oturum modülünün ismini döndürür.

Değiştirgeler

modül

Belirtildiği takdirde oturum modülü olarak belirtilen modül kullanılır.

Dönen Değerler

Oturum modülünün o anki ismini döndürür.

session_is_registered
session_name
Oturum İşlevleri


Geçerli oturum ismini döndürür ve/veya tanımlar

session_module_name
session_regenerate_id
Oturum İşlevleri
PHP Manual

session_name

(PHP 4, PHP 5, PHP 7)

session_name — Geçerli oturum ismini döndürür ve/veya tanımlar

Açıklama

string session_name ([ string $isim ] )

session_name() işlevi geçerli oturumun ismini döndürür.

Oturum ismi istek başlangıcında session.name PHP yönergesinde tanımlı isimle sıfırlanır. Oturumun ismini öntanımlı isimden farklı bir isimle değiştirmek için her istekte session_name() çağrısı yapmalısınız (session_start() veya session_register() çağrısından önce).

Değiştirgeler

isim

Oturum ismi, çerezler ve URL'lerde oturum kimliğine gönderimlidir. Oturum ismi sadece abecesayısal karakterler içermeli, (çerez uyarılarını etkin kılan kullanıcılar için) kısa ve açıklayıcı olmalıdır. Bir isim belirtilirse, geçerli oturumun ismi bu isimle değiştirilir.

Uyarı

Oturum ismi sadece rakamlardan oluşamaz, hiç olmazsa bir harf içermesi gerekir. Aksi takdirde her seferinde yeni bir oturum kimliği üretilir.

Dönen Değerler

Geçerli oturumun ismini döndürür.

Örnekler

Örnek 1 - session_name() örneği

<?php

/* oturum ismini SiteID yapalım */

$eski_isim = session_name("SiteID");

echo "Önceki oturum ismi $eski_isim idi.<br />";
?>

Ayrıca Bakınız

  • session.name yapılandıma yönergesi

session_module_name
session_regenerate_id
Oturum İşlevleri


Geçerli oturum kimliğini yenisiyle değiştirir

session_name
session_register_shutdown
Oturum İşlevleri
PHP Manual

session_regenerate_id

(PHP 4 >= 4.3.2, PHP 5, PHP 7)

session_regenerate_id — Geçerli oturum kimliğini yenisiyle değiştirir

Açıklama

bool session_regenerate_id ([ bool $eski_oturumu_sil = false ] )

session_regenerate_id() işlevi geçerli oturum kimliğini yenisiyle değiştirirken oturum bigisini korur.

Değiştirgeler

eski_oturumu_sil

TRUE ise oturumla ilişkili eski dosya silinir. FALSE öntanımlı değerdir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.3 | Oturum çerezleri etkinse, yeni oturum kimliğiyle ilişkili yeni oturum çerezi artık session_regenerate_id() işlevi tarafından gönderiliyor.
5.1.0 | eski_oturumu_sil değiştirgesi eklendi.

Örnekler

Örnek 1 - session_regenerate_id() örneği

<?php
session_start();

$old_sessionid = session_id();

session_regenerate_id();

$new_sessionid = session_id();

echo "Eski oturum: $old_sessionid<br />";
echo "Yeni oturum: $new_sessionid<br />";

print_r($_SESSION);
?>

Ayrıca Bakınız

  • session_id() - Geçerli oturum kimliğini döndürür ve/veya tanımlar
  • session_start() - Oturum verisini ilklendirir
  • session_name() - Geçerli oturum ismini döndürür ve/veya tanımlar

session_name
session_register_shutdown
Oturum İşlevleri


Session shutdown function

session_regenerate_id
session_register
Oturum İşlevleri
PHP Manual

session_register_shutdown

(PHP >=5.4.0)

session_register_shutdown — Session shutdown function

Açıklama

void session_register_shutdown ( void )

Registers session_write_close() as a shutdown function.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

Emits E_WARNING if registering the shutdown function fails.

session_regenerate_id
session_register
Oturum İşlevleri


Geçerli oturuma bir veya daha fazla küresel değişkeni kaydeder

session_register_shutdown
session_reset
Oturum İşlevleri
PHP Manual

session_register

(PHP 4, PHP 5 < 5.4.0)

session_register — Geçerli oturuma bir veya daha fazla küresel değişkeni kaydeder

Açıklama

bool session_register ( mixed $isim [, mixed $... ] )

session_register() işlevi değişken sayıda değiştirge kabul eder. Tek bir değişkenin ismini içeren bir dizge olabileceği gibi, değişken isimlerini veya diğer dizileri içeren bir dizi olabilir. İşlev, belirtilen her isim için aynı isimdeki bir küresel değişkeni oturum değişkeni haline getirir.

Bir oturum değişkenini $_SESSION veya $HTTP_SESSION_VARS (PHP < 4.1.0) dizisinin bir üyesi olarak da oluşturabilirsiniz.

<?php
//session_register() kullanımı artık önerilmiyor
$barney = "Devasa pembe bir dinazor.";
session_register("barney");

// PHP 4.1.0'dan itibaren, $_SESSION tercih ediliyor
$_SESSION["zim"] = "Başka bir gezegenden bir istilacı.";

// Eski yol, $HTTP_SESSION_VARS kullanmaktı
$HTTP_SESSION_VARS["spongebob"] = "O bir kare pantolon giyiyor.";
?>

Bu işlevden önce bir session_start() çağrısı yapılmazsa örtük olarak değiştirgesiz bir session_start() çağrısı çağrısı yapılır. $_SESSION kullanacaksanız bu davranışın size bir faydası olmaz ve önce bir session_start() çağrısı yapmanız gerekir.

Uyarı

Bu işlevin kullanımı PHP 5.3.0'dan beri ÖNERİLMEMEKTEDİR ve PHP 6.0.0'da tamamen KALDIRILMIŞTIR. Bu işleve kesinlikle güvenmemelisiniz.

Değiştirgeler

isim

Tek bir değişkenin ismini içeren bir dizge veya değişken isimlerinden ve diğer dizilerden oluşan bir dizi.

...

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

Dikkat

Betiğinizin register_globals yönergesinin değerine aldırmaksızın çalışmasını isterseniz, bu işlev yerine $_SESSION dizisini kullanmalısınız; $_SESSION girdileri özdevinimli olarak oturum değişkenleri haline gelirler. Betiğiniz session_register() işlevini kullanacaksa, register_globals PHP yönergesinin değerinin On olmadığı yerlerde çalışmayacaktır.

Bilginize: register_globals için önemli bilgi

PHP 4.2.0'dan itibaren, register_globals yönergesinin öntanımlı değeri off olup PHP 6.0.0'dan itibaren tamamen kaldırılmıştır. PHP topluluğu, geliştiricilere, bu yönergeyi kullanmaktan vazgeçmelerini ve yerine süper küreselleri tercih etmelerini önermektedir.

Dikkat

Bu işlev bir küresel değişkeni kayıtlı hale getirir. İşlevi bir oturum değişkenini kayıtlı duruma getirmek için kullanacaksanız değişkeni önce global anahtar sözcüğüyle veya $GLOBALS[] dizisinde belirterek bir küresel değişken haline getirmelisinz. Daha da iyisi özel oturum dizilerini kullanmaktır.

Dikkat

$_SESSION (veya $HTTP_SESSION_VARS)
dizisini kullanıyorsanız, session_register(),
session_is_registered() ve
session_unregister() işlevlerini kullanmayın.

Bilginize:

resource türünden değişkenleri bir oturumun kayıtlı değişkeni yapmak mümkün değildir. Örneğin, bir veritabanını bağlantısı oluşturup bunun bağlantı kimliğini bir oturum değişkeninde saklayamazsınız. Çünkü oturum tekrar oluşturulduğunda bu bağlantının geçerli kalacağı beklenemez. Bir özkaynak döndüren PHP işlevleri, işlev tanımında resource türünde bir değer döndüren işlevler olup bunların bir listesi eklerdeki Özkaynak Türlerinin Listesi bölümünde bulunabilir.

Eğer $_SESSION (veya PHP 4.0.6 ve öncesinde $HTTP_SESSION_VARS) kullanılıyorsa, değerler $_SESSION dizisine şöyle atanır: $_SESSION['var'] = 'ABC';

Ayrıca Bakınız

  • session_is_registered() - Bir küresel değişkenin oturumda kayıtlı olup olmadığına bakar
  • session_unregister() - Geçerli oturumdaki bir küresel değişkeni kayıtdışı yapar
  • $_SESSION

session_register_shutdown
session_reset
Oturum İşlevleri


Re-initialize session array with original values

session_register
session_save_path
Oturum İşlevleri
PHP Manual

session_reset

(PHP 5 >= 5.6.0, PHP 7)

session_reset — Re-initialize session array with original values

Açıklama

void session_reset ( void )

session_reset() reinitializes a session with original values stored in session storage. This function requires an active session and discards changes in $_SESSION.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • $_SESSION
  • The session.auto_start configuration directive
  • session_start() - Oturum verisini ilklendirir
  • session_abort() - Discard session array changes and finish session
  • session_commit() - session_write_close işlevinin takma adıdır

session_register
session_save_path
Oturum İşlevleri


Geçerli oturum kayıt yolunu tanımlar ve/veya döndürür

session_reset
session_set_cookie_params
Oturum İşlevleri
PHP Manual

session_save_path

(PHP 4, PHP 5, PHP 7)

session_save_path — Geçerli oturum kayıt yolunu tanımlar ve/veya döndürür

Açıklama

string session_save_path ([ string $yol ] )

session_save_path() işlevi oturum verisini kaydetmek için kullanılan dizinin yolunu döndürür.

Değiştirgeler

yol

Oturum verisinin kaydedileceği dizinin yolu. Belirtildiği takdirde oturum verisinin kaydedildiği dizin yol olarak değiştirilir. session_save_path() işlevi bu amaçla kullanılacaksa session_start() işlevinden önce çağrılmalıdır.

Bilginize:

Bazı işletim sistemlerinde, bu dosya yolunu küçük dosyalarla daha verimli olan dosya sistemlerinde belirtmek daha iyidir. Örneğin, Linux üzerinde küçük dosyalarla ext2fs'ten daha yüksek başarıma sahip reiserfs kullanılabilir.

Dönen Değerler

Oturum verisini saklamak için kullanılan dizinin yolunu döndürür.

Ayrıca Bakınız

  • session.save_path yapılandırma yönergesi

session_reset
session_set_cookie_params
Oturum İşlevleri


Oturum çerezi değiştirgelerini tanımlar

session_save_path
session_set_save_handler
Oturum İşlevleri
PHP Manual

session_set_cookie_params

(PHP 4, PHP 5, PHP 7)

session_set_cookie_params — Oturum çerezi değiştirgelerini tanımlar

Açıklama

void session_set_cookie_params ( int $lifetime [, string $path [, string $domain [, bool $secure = false [, bool $httponly = false ]]]] )

php.ini dosyasındaki çerez yönergelerinin değerlerini tanımlar. Bu işlevin etkisi betiğin çalışma süresiyle sınırlıdır. Bu bakımdan session_set_cookie_params() çağrısını her istek için session_start() çağrısından önce yapmalısınız.

Değiştirgeler

lifetime

Oturum çerezinin ömrünü saniye cinsinden tanımlar.

path

Çerezin çalışacağı alandaki dosya yolunu tanımlar. Alandaki tüm dosya yolları için bir bölü çizgisi ('/')kullanın.

domain

'www.php.net' gibi bir çerez alanı. Çerezleri tüm alt alanlarda geçerli kılmak için alan adının önüne '.php.net' şeklinde bir notka koyun.

secure

TRUE olduğu takdirde, çerez sadece güvenli bağlantılar üzerinden gönderilir.

httponly

TRUE ise PHP oturum çerezini sadece HTTP protokolü üzerinden göndermeye çalışır.

Dönen Değerler

Hiçbir değer dönmez.

Sürüm Bilgisi

Sürüm: | Açıklama
5.2.0 | httponly değiştirgesi eklendi.
4.0.4 | secure değiştirgesi eklendi.

Ayrıca Bakınız

  • session.cookie_lifetime
  • session.cookie_domain
  • session.cookie_secure
  • session.cookie_httponly
  • session_get_cookie_params() - Oturum çerezi değiştirgelerini döndürür

session_save_path
session_set_save_handler
Oturum İşlevleri


Kullanıcı seviyesi oturum saklama işlevlerini bildirir

session_set_cookie_params
session_start
Oturum İşlevleri
PHP Manual

session_set_save_handler

(PHP 4, PHP 5, PHP 7)

session_set_save_handler — Kullanıcı seviyesi oturum saklama işlevlerini bildirir

Açıklama

bool session_set_save_handler ( callback $aç , callback $kapa , callback $oku , callback $yaz , callback $yoket , callback $çöpçü )

session_set_save_handler() işlevi, bir oturumla ilişkili verileri almak ve saklamak için kullanılan kullanıcı seviyesi oturum saklama işlevlerini bildirir. PHP oturumlarında başka kaynaklardan sağlanmış bir saklama yöntemi (oturum verilerini bir yerel veritabanıda saklamak gibi) kullanılacaksa bu işlev çok işe yarar.

Değiştirgeler

aç

Bu işlev, sınıflardaki kurucular gibi çalışır ve oturum açıldığında çalıştırılır. Açma işlevinin iki değiştirge kabul edeceği varsayılır. İlkinde dosyaların kaydedileceği yerin yolu, ikincisinde oturum ismi verilir.

kapa

Bu işlev, sınıflardaki yıkıcılar gibi çalışır ve oturum işlemleri bittiğinde çalıştırılır.

oku

Oturum bilgilerinin kayıt eylemcisinin beklendiği gibi çalışması için bu işlevin daima dizge değer döndürmesi gerekir. Okunacak veri yoksa işlev boş dizge döndürmelidir. Diğer eylemcilerden dönen değerler başarı durumunda TRUE başarısızlık durumunda FALSE döndüren mantıksal ifadelere dönüştürülür.

yaz

Bilginize:

Bu işlev çıktı akımı kapanana kadar çalıştırılmaz. Bu bakımdan bu işlevdeki hata ayıklama deyimlerinin çıktıları tarayıcıda hiçbir zaman görünmez. Eğer hata ayıklama çıktısı gerekliyse, bu çıktının bir dosyaya yazılması önerilir.

yoket

Bu işlev, oturum kimliğini tek değiştirge olarak alır ve session_destroy() işlevi ile bir oturum yok edildiğinde çalıştırılır.

çöpçü

Çöp toplayıcı işlev. Oturumun azami ömrünü tek değiştirge olarak alır ve oturumun çöp toplayıcısı çalıştırıldığı zaman çalıştırılır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - session_set_save_handler() örneği

Aşağıdaki örnekte, PHP'nin öntanımlı kayıt ortamı olan dosyalara (files) benzer dosya temelli bir oturum kayıt ortamı oluşturulmaktadır. Bu örnek, PHP destekli veritabanı mekanizmanızı kapsayacak şekilde kolayca genişletilebilir.

<?php
function aç($saklama_yeri, $oturum_ismi)
{
  global $oturum_kayıt_yeri;

  $oturum_kayıt_yeri = $saklama_yeri;
  return(true);
}

function kapat()
{
  return(true);
}

function oku($id)
{
  global $oturum_kayıt_yeri;

  $saklama_dosyası = "$oturum_kayıt_yeri/oturum_$id";
  return (string) @file_get_contents($saklama_dosyası);
}

function yaz($id, $saklama_verisi)
{
  global $oturum_kayıt_yeri;

  $saklama_dosyası = "$oturum_kayıt_yeri/oturum_$id";
  if ($fp = @fopen($saklama_dosyası, "w")) {
    $return = fwrite($fp, $saklama_verisi);
    fclose($fp);
    return $return;
  } else {
    return(false);
  }

}

function yoket($id)
{
  global $oturum_kayıt_yeri;

  $saklama_dosyası = "$oturum_kayıt_yeri/oturum_$id";
  return(@unlink($saklama_dosyası));
}

function çöpçü($azami_ömür)
{
  global $oturum_kayıt_yeri;

  foreach (glob("$oturum_kayıt_yeri/oturum_*") as $dosya) {
    if (filemtime($dosya) + $azami_ömür < time()) {
      @unlink($dosya);
    }
  }
  return true;
}

session_set_save_handler("aç", "kapat", "oku", "yaz", "yoket", "çöpçü");

session_start();

// Oturum ile ilgili diğer işlemler

?>

Notlar

Uyarı

PHP 5.0.5'ten itibaren yaz ve kapat eylemcileri nesne yokedildikten sonra çağrılmaktadır. Bu bakımdan nesneler ve oluşturulan istisnalar kullanılamaz. Ancak nesne yıkıcılar oturumları kullanabilir.

Bu yumurta/tavuk sorununu çözümlemek için bir yıkıcıdan session_write_close() çağrısı yapmak mümkündür.

Uyarı

Eğer oturum, betiğin sonlanmasıyla kapanmışsa bazı SAPI'lerde geçirli çalışma dizini değiştirilir. Böyle durumlarda oturumu önceden session_write_close() ile kapatmak mümkündür.

Ayrıca Bakınız

  • session.save_handler yapılandırma yönergesi

session_set_cookie_params
session_start
Oturum İşlevleri


Oturum verisini ilklendirir

session_set_save_handler
session_status
Oturum İşlevleri
PHP Manual

session_start

(PHP 4, PHP 5, PHP 7)

session_start — Oturum verisini ilklendirir

Açıklama

bool session_start ( void )

session_start() bir oturumu ya oluşturur ya da GET, POST veya bir çerez gibi bir istek üzerinden aktarılan oturum kimliğine istinaden eski bir oturumu geçerli oturum haline getirir.

İsimli oturumlar kullanmak istiyorsanız bu işlevden önce bir session_name() çağrısı yapmalısınız.

session_start() işlevi, trans-sid etkinken URL yeniden yazımı için dahili çıktı eylemcisini devreye sokar. Eğer kullanıcı ob_gzhandler() işlevini veya ob_start() ile benzerini kullanıyorsa çıktı eylemcilerin sırası çıktının düzgün olmasında önem kazanır. Örneğin, kullanıcının oturumu başlatmadan önce ob_gzhandler() işlevini devreye sokması gerekir.

Dönen Değerler

Oturum başarıyla başlatılabilmişse TRUE aksi takdirde FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | Eğer oturum bir sebeple başlatılamazsa FALSE döndürülür. Evvelce daima TRUE döndürülüyordu.
4.3.3 | Oturum zaten başlatılmışken yapılan bir session_start() çağrısı artık E_NOTICE seviyesinden bir hata ile sonuçlanıyor. Ayrıca, ikinci oturum başlatma isteği de basitçe yok sayılıyor.

Örnekler

Örnek 1 - Bir oturum örneği: sayfa1.php

<?php
// sayfa1.php

session_start();

echo '1. sayfaya hoş geldiniz';

$_SESSION['renk']   = 'yeşil';
$_SESSION['hayvan'] = 'kedi';
$_SESSION['zaman']  = time();

// Oturum verisi kabul edilmişse çalışır
echo '<br /><a href="sayfa2.php">2. Sayfa</a>';

// Veya gerekirse oturum kimliği üzerinden de aktarılabilir
echo '<br /><a href="sayfa2.php?' . SID . '">2. Sayfa</a>';
?>

sayfa1.php gösterildikten sonra, ikinci sayfa sayfa2.php oturum verisini sihirli bir şekilde içerecektir. SID sabiti dahil, oturum kimliklerinin yayını hakkında bilgi edinmek için oturum eklentisini okuyun.

Örnek 2 - Bir oturum örneği: sayfa2.php

<?php
// sayfa2.php

session_start();

echo '2. sayfaya hoş geldiniz<br />';

echo $_SESSION['renk'];     // yeşil
echo $_SESSION['hayvan'];   // kedi
echo date('Y m d H:i:s', $_SESSION['zaman']);

// sayfa1.php'de yaptığımız gibi burada da SID kullanabilirsiniz
echo '<br /><a href="sayfa1.php">1. Sayfa</a>';
?>

Notlar

Bilginize:

Çereze dayalı oturumlar kullanıyorsanız tarayıcıya herhangi bir çıktılama yapmadan önce mutlaka bir session_start() çağrısı yapmalısınız.

Bilginize:

ob_gzhandler() işlevinden ziyade zlib.output_compression yönergesini kullanmanızı öneririz.

Bilginize:

Bu işlev yapılandırmaya bağlı olarak dışarıya çeşitli HTTP başlıkları gönderir. Bu başlıkları özelleştirmek için session_cache_limiter()işlevine bakınız.

Ayrıca Bakınız

  • $_SESSION
  • session.auto_start yapılandırma yönergesi
  • session_id() - Geçerli oturum kimliğini döndürür ve/veya tanımlar

session_set_save_handler
session_status
Oturum İşlevleri


Returns the current session status

session_start
session_unregister
Oturum İşlevleri
PHP Manual

session_status

(PHP >=5.4.0)

session_status — Returns the current session status

Açıklama

int session_status ( void )

session_status() is used to return the current session status.

Dönen Değerler

  • PHP_SESSION_DISABLED if sessions are disabled.
  • PHP_SESSION_NONE if sessions are enabled, but none exists.
  • PHP_SESSION_ACTIVE if sessions are enabled, and one exists.

Ayrıca Bakınız

  • session_start() - Oturum verisini ilklendirir
session_start
session_unregister
Oturum İşlevleri


Geçerli oturumdaki bir küresel değişkeni kayıtdışı yapar

session_status
session_unset
Oturum İşlevleri
PHP Manual

session_unregister

(PHP 4, PHP 5 < 5.4.0)

session_unregister — Geçerli oturumdaki bir küresel değişkeni kayıtdışı yapar

Açıklama

bool session_unregister ( string $isim )

Geçerli oturumdaki isim küresel değişkenini kayıtdışı yapar.

Uyarı

Bu işlevin kullanımı PHP 5.3.0'dan beri ÖNERİLMEMEKTEDİR ve PHP 6.0.0'da tamamen KALDIRILMIŞTIR. Bu işleve kesinlikle güvenmemelisiniz.

Değiştirgeler

isim

Değişken ismi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Notlar

Bilginize:

$_SESSION (veya PHP 4.0.6 ve öncesinde $HTTP_SESSION_VARS) kullanılıyorsa bir oturum değişkenini serbest bırakmak için unset() kullanın. Örnek: unset ($_SESSION['degisken']);. $_SESSION dizisinin tamamını unset($_SESSION) ile tanımsız yapmayın, aksi takdirde oturum değişkenlerini $_SESSION süper küreseli üzerinden kayıt altına alamazsınız.

Dikkat

Bu işlev isim küresel değişkenini tanımsız yapmaz, sadece oturumun bir parçası olarak kaydedilmemesini sağlar. Değişkeni tanımsız yapmak isterseniz unset() işlevini kullanabilirsiniz.

Dikkat

$_SESSION (veya $HTTP_SESSION_VARS)
kullanıyorsanız session_register(),
session_is_registered() ve
session_unregister() işlevlerini kullanmayın.

session_status
session_unset
Oturum İşlevleri


Free all session variables

session_unregister
session_write_close
Oturum İşlevleri
PHP Manual

session_unset

(PHP 4, PHP 5, PHP 7)

session_unset — Free all session variables

Açıklama

void session_unset ( void )

Oturuma kayıtlı tüm oturum değişkenlerini serbest bırakır.

Dönen Değerler

Hiçbir değer dönmez.

Notlar

Bilginize:

$_SESSION (veya PHP 4.0.6 ve öncesinde $HTTP_SESSION_VARS) kullanılıyorsa bir oturum değişkenini serbest bırakmak için unset() kullanın. Örnek: unset ($_SESSION['degisken']);.

Dikkat

$_SESSION dizisinin tamamını unset($_SESSION) ile tanımsız yapmayın, aksi takdirde oturum değişkenlerini $_SESSION süper küreseli üzerinden kayıt altına alamazsınız.

session_unregister
session_write_close
Oturum İşlevleri


Oturum verisini yazıp oturumu kapatır

session_unset
SessionHandler
Oturum İşlevleri
PHP Manual

session_write_close

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

session_write_close — Oturum verisini yazıp oturumu kapatır

Açıklama

void session_write_close ( void )

Oturum verisini kaydedip oturumu sonlandırır.

Oturum verisi normalde session_write_close() çağrısına gerek kalmaksızın betiğiniz sonlanınca kaydedilir, fakat aynı anda yazmaları engellemek ve oturumda aynı anda sadece bir betiğin çalışmasına izin vermek için oturum verisi kilitlenir. Oturumlarda frameset etiketlerini kullanıyorsanız frame'lerin bu kilitlemeden dolayı birer birer yüklendiklerini görürsünüz. Oturum değişkenlerindeki tüm değişikliler yapıldıkça oturumu kapatarak tüm frame'lerin yüklenme zamanını azaltabilirsiniz.

Dönen Değerler

Hiçbir değer dönmez.

session_unset
SessionHandler
Oturum İşlevleri


The SessionHandler class

(PHP 5 >= 5.4.0, PHP 7)

Giriş

SessionHandler is a special class that can be used to expose the current internal PHP session save handler by inheritance. There are seven methods which wrap the seven internal session save handler callbacks (open, close, read, write, destroy, gc and create_sid). By default, this class will wrap whatever internal save handler is set as defined by the session.save_handler configuration directive which is usually files by default. Other internal session save handlers are provided by PHP extensions such as SQLite (as sqlite), Memcache (as memcache), and Memcached (as memcached).

When a plain instance of SessionHandler is set as the save handler using session_set_save_handler() it will wrap the current save handlers. A class extending from SessionHandler allows you to override the methods or intercept or filter them by calls the parent class methods which ultimately wrap the interal PHP session handlers.

This allows you, for example, to intercept the read and write methods to encrypt/decrypt the session data and then pass the result to and from the parent class. Alternatively one might chose to entirely override a method like the garbage collection callback gc.

Because the SessionHandler wraps the current internal save handler methods, the above example of encryption can be applied to any internal save handler without having to know the internals of the handlers.

To use this class, first set the save handler you wish to expose using session.save_handler and then pass an instance of SessionHandler or one extending it to session_set_save_handler().

Please note the callback methods of this class are designed to be called internally by PHP and are not meant to be called from user-space code. The return values are equally processed internally by PHP. For more information on the session workflow, please refer session_set_save_handler().

Sınıf Sözdizimi

SessionHandler implements SessionHandlerInterface {
/* Yöntemler */
public bool close ( void )
public string create_sid ( void )
public bool destroy ( string $session_id )
public bool gc ( int $maxlifetime )
public bool open ( string $save_path , string $session_name )
public string read ( string $session_id )
public bool write ( string $session_id , string $session_data )
}
Uyarı

This class is designed to expose the current internal PHP session save handler, if you want to write your own custom save handlers, please implement the SessionHandlerInterface interface instead of extending from SessionHandler.

Sürüm Bilgisi

Sürüm: | Açıklama
5.5.1 | Added SessionHandler::create_sid().

Örnek 1 Using SessionHandler to add encryption to internal PHP save handlers.

<?php

 /**
  * decrypt AES 256
  *
  * @param data $edata
  * @param string $password
  * @return decrypted data
  */
function decrypt($edata, $password) {
    $data = base64_decode($edata);
    $salt = substr($data, 0, 16);
    $ct = substr($data, 16);

    $rounds = 3; // depends on key length
    $data00 = $password.$salt;
    $hash = array();
    $hash[0] = hash('sha256', $data00, true);
    $result = $hash[0];
    for ($i = 1; $i < $rounds; $i++) {
        $hash[$i] = hash('sha256', $hash[$i - 1].$data00, true);
        $result .= $hash[$i];
    }
    $key = substr($result, 0, 32);
    $iv  = substr($result, 32,16);

    return openssl_decrypt($ct, 'AES-256-CBC', $key, true, $iv);
  }

/**
 * crypt AES 256
 *
 * @param data $data
 * @param string $password
 * @return base64 encrypted data
 */
function encrypt($data, $password) {
    // Set a random salt
    $salt = openssl_random_pseudo_bytes(16);

    $salted = '';
    $dx = '';
    // Salt the key(32) and iv(16) = 48
    while (strlen($salted) < 48) {
      $dx = hash('sha256', $dx.$password.$salt, true);
      $salted .= $dx;
    }

    $key = substr($salted, 0, 32);
    $iv  = substr($salted, 32,16);

    $encrypted_data = openssl_encrypt($data, 'AES-256-CBC', $key, true, $iv);
    return base64_encode($salt . $encrypted_data);
}

class EncryptedSessionHandler extends SessionHandler
{
    private $key;

    public function __construct($key)
    {
        $this->key = $key;
    }

    public function read($id)
    {
        $data = parent::read($id);

        if (!$data) {
            return "";
        } else {
            return decrypt($data, $this->key);
        }
    }

    public function write($id, $data)
    {
        $data = encrypt($data, $this->key);

        return parent::write($id, $data);
    }
}

// we'll intercept the native 'files' handler, but will equally work
// with other internal native handlers like 'sqlite', 'memcache' or 'memcached'
// which are provided by PHP extensions.
ini_set('session.save_handler', 'files');

$key = 'secret_string';
$handler = new EncryptedSessionHandler($key);
session_set_save_handler($handler, true);
session_start();

// proceed to set and retrieve values by key from $_SESSION

Bilginize:

Since this class' methods are designed to be called internally by PHP as part of the normal session workflow, child class calls to parent methods (i.e. the actual internal native handlers) will return FALSE unless the session has actually been started (either automatically, or by explicit session_start(). This is important to consider when writing unit tests where the class methods might be invoked manually.

İçindekiler

  • SessionHandler::close — Close the session
  • SessionHandler::create_sid — Return a new session ID
  • SessionHandler::destroy — Destroy a session
  • SessionHandler::gc — Cleanup old sessions
  • SessionHandler::open — Initialize session
  • SessionHandler::read — Read session data
  • SessionHandler::write — Write session data
session_write_close
SessionHandler::close
Oturumlar


Close the session

SessionHandler
SessionHandler::create_sid
SessionHandler
PHP Manual

SessionHandler::close

(PHP 5 >= 5.4.0, PHP 7)

SessionHandler::close — Close the session

Açıklama

public bool SessionHandler::close ( void )

Closes the current session. This method is automatically executed internally by PHP when closing the session, or explicitly via session_write_close() (which first calls the SessionHandler::write()).

This method wraps the internal PHP save handler defined in the session.save_handler ini setting that was set before this handler was activated by session_set_save_handler().

If this class is extended by inheritiance, calling the parent close method will invoke the wrapper for this method and therefor invoke the associated internal callback. This allows the method to be overidden and or intercepted.

For more information on what this method is expected to do, please refer to the documentation at SessionHandlerInterface::close().

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Oturum kaydının dönüş değeri (normalde başarı durumunda TRUE, aksi durumda FALSE). Dikkat edin, bu değer işlenmek üzere dahili olarak PHP'ye döndürülür.

SessionHandler
SessionHandler::create_sid
SessionHandler


Return a new session ID

SessionHandler::close
SessionHandler::destroy
SessionHandler
PHP Manual

SessionHandler::create_sid

(PHP 5 >= 5.5.1, PHP 7)

SessionHandler::create_sid — Return a new session ID

Açıklama

public string SessionHandler::create_sid ( void )

Generates and returns a new session ID.

Dönen Değerler

A session ID valid for the default session handler.

Ayrıca Bakınız

  • session_id() - Geçerli oturum kimliğini döndürür ve/veya tanımlar

SessionHandler::close
SessionHandler::destroy
SessionHandler


Destroy a session

SessionHandler::create_sid
SessionHandler::gc
SessionHandler
PHP Manual

SessionHandler::destroy

(PHP 5 >= 5.4.0, PHP 7)

SessionHandler::destroy — Destroy a session

Açıklama

public bool SessionHandler::destroy ( string $session_id )

Destroys a session. Called internally by PHP with session_regenerate_id() (assuming the $destroy is set to TRUE, by session_destroy() or when session_decode() fails.

This method wraps the internal PHP save handler defined in the session.save_handler ini setting that was set before this handler was set by session_set_save_handler().

If this class is extended by inheritiance, calling the parent destroy method will invoke the wrapper for this method and therefor invoke the associated internal callback. This allows this method to be overidden and or intercepted and filtered.

For more information on what this method is expected to do, please refer to the documentation at SessionHandlerInterface::destroy().

Değiştirgeler

session_id

The session ID being destroyed.

Dönen Değerler

Oturum kaydının dönüş değeri (normalde başarı durumunda TRUE, aksi durumda FALSE). Dikkat edin, bu değer işlenmek üzere dahili olarak PHP'ye döndürülür.

SessionHandler::create_sid
SessionHandler::gc
SessionHandler


Cleanup old sessions

SessionHandler::destroy
SessionHandler::open
SessionHandler
PHP Manual

SessionHandler::gc

(PHP 5 >= 5.4.0, PHP 7)

SessionHandler::gc — Cleanup old sessions

Açıklama

public bool SessionHandler::gc ( int $maxlifetime )

Cleans up expired sessions. Called randomly by PHP internally when a session starts or when session_start() is invoked. The frequency this is called is based on the session.gc_divisor and session.gc_probability configuration directives.

This method wraps the internal PHP save handler defined in the session.save_handler ini setting that was set before this handler was set by session_set_save_handler().

If this class is extended by inheritiance, calling the parent gc method will invoke the wrapper for this method and therefore invoke the associated internal callback. This allows this method to be overidden and or intercepted and filtered.

For more information on what this method is expected to do, please refer to the documentation at SessionHandlerInterface::gc().

Değiştirgeler

maxlifetime

Sessions that have not updated for the last maxlifetime seconds will be removed.

Dönen Değerler

Oturum kaydının dönüş değeri (normalde başarı durumunda TRUE, aksi durumda FALSE). Dikkat edin, bu değer işlenmek üzere dahili olarak PHP'ye döndürülür.

SessionHandler::destroy
SessionHandler::open
SessionHandler


Initialize session

SessionHandler::gc
SessionHandler::read
SessionHandler
PHP Manual

SessionHandler::open

(PHP 5 >= 5.4.0, PHP 7)

SessionHandler::open — Initialize session

Açıklama

public bool SessionHandler::open ( string $save_path , string $session_name )

Create new session, or re-initialize existing session. Called internally by PHP when a session starts either automatically or when session_start() is invoked.

This method wraps the internal PHP save handler defined in the session.save_handler ini setting that was set before this handler was set by session_set_save_handler().

If this class is extended by inheritiance, calling the parent open method will invoke the wrapper for this method and therefor invoke the associated internal callback. This allows this method to be overidden and or intercepted and filtered.

For more information on what this method is expected to do, please refer to the documentation at SessionHandlerInterface::open().

Değiştirgeler

save_path

The path where to store/retrieve the session.

session_name

The session name.

Dönen Değerler

Oturum kaydının dönüş değeri (normalde başarı durumunda TRUE, aksi durumda FALSE). Dikkat edin, bu değer işlenmek üzere dahili olarak PHP'ye döndürülür.

Ayrıca Bakınız

  • The session.auto-start configuration directive.

SessionHandler::gc
SessionHandler::read
SessionHandler


Read session data

SessionHandler::open
SessionHandler::write
SessionHandler
PHP Manual

SessionHandler::read

(PHP 5 >= 5.4.0, PHP 7)

SessionHandler::read — Read session data

Açıklama

public string SessionHandler::read ( string $session_id )

Reads the session data from the session storage, and returns the result back to PHP for internal processing. This method is called automatically by PHP when a session is started (either automatically or explicity with session_start() and is preceeded by an internal call to the SessionHandler::open().

This method wraps the internal PHP save handler defined in the session.save_handler ini setting that was set before this handler was set by session_set_save_handler().

If this class is extended by inheritiance, calling the parent read method will invoke the wrapper for this method and therefor invoke the associated internal callback. This allows the method to be overidden and or intercepted and filtered (for example, decrypting $data value returned by the parent read method).

For more information on what this method is expected to do, please refer to the documentation at SessionHandlerInterface::read().

Değiştirgeler

session_id

The session id to read data for.

Dönen Değerler

Returns an encoded string of the read data. If nothing was read, it must return an empty string. Note this value is returned internally to PHP for processing.

Ayrıca Bakınız

  • The session.serialize_handler configuration directive.

SessionHandler::open
SessionHandler::write
SessionHandler


Write session data

SessionHandler::read
SessionHandlerInterface
SessionHandler
PHP Manual

SessionHandler::write

(PHP 5 >= 5.4.0, PHP 7)

SessionHandler::write — Write session data

Açıklama

public bool SessionHandler::write ( string $session_id , string $session_data )

Writes the session data to the session storage. Called by normal PHP shutdown, by session_write_close(), or when session_register_shutdown() fails. PHP will call SessionHandler::close() immediately after this method returns.

This method wraps the internal PHP save handler defined in the session.save_handler ini setting that was set before this handler was set by session_set_save_handler().

If this class is extended by inheritiance, calling the parent write method will invoke the wrapper for this method and therefor invoke the associated internal callback. This allows this method to be overidden and or intercepted and filtered (for example, encrypting the $data value before sending it to the parent write method).

For more information on what this method is expected to do, please refer to the documentation at SessionHandlerInterface::write().

Değiştirgeler

session_id

The session id.

session_data

The encoded session data. This data is the result of the PHP internally encoding the $_SESSION superglobal to a serialized string and passing it as this parameter. Please note sessions use an alternative serialization method.

Dönen Değerler

Oturum kaydının dönüş değeri (normalde başarı durumunda TRUE, aksi durumda FALSE). Dikkat edin, bu değer işlenmek üzere dahili olarak PHP'ye döndürülür.

Ayrıca Bakınız

  • The session.serialize_handler configuration directive.

SessionHandler::read
SessionHandlerInterface
SessionHandler


The SessionHandlerInterface class

(PHP 5 >= 5.4.0, PHP 7)

Giriş

SessionHandlerInterface is an interface which defines a prototype for creating a custom session handler. In order to pass a custom session handler to session_set_save_handler() using its OOP invocation, the class must implement this interface.

Please note the callback methods of this class are designed to be called internally by PHP and are not meant to be called from user-space code.

Sınıf Sözdizimi

SessionHandlerInterface {
/* Yöntemler */
abstract public bool close ( void )
abstract public bool destroy ( string $session_id )
abstract public bool gc ( int $maxlifetime )
abstract public bool open ( string $save_path , string $session_name )
abstract public string read ( string $session_id )
abstract public bool write ( string $session_id , string $session_data )
}

Örnek 1 Example using SessionHandlerInterface

The following example provides file based session storage similar to the PHP sessions default save handler files. This example could easily be extended to cover database storage using your favorite PHP supported database engine.

Note we use the OOP prototype with session_set_save_handler() and register the shutdown function using the function's parameter flag. This is generally advised when registering objects as session save handlers.

<?php
class MySessionHandler implements SessionHandlerInterface
{
    private $savePath;

    public function open($savePath, $sessionName)
    {
        $this->savePath = $savePath;
        if (!is_dir($this->savePath)) {
            mkdir($this->savePath, 0777);
        }

        return true;
    }

    public function close()
    {
        return true;
    }

    public function read($id)
    {
        return (string)@file_get_contents("$this->savePath/sess_$id");
    }

    public function write($id, $data)
    {
        return file_put_contents("$this->savePath/sess_$id", $data) === false ? false : true;
    }

    public function destroy($id)
    {
        $file = "$this->savePath/sess_$id";
        if (file_exists($file)) {
            unlink($file);
        }

        return true;
    }

    public function gc($maxlifetime)
    {
        foreach (glob("$this->savePath/sess_*") as $file) {
            if (filemtime($file) + $maxlifetime < time() && file_exists($file)) {
                unlink($file);
            }
        }

        return true;
    }
}

$handler = new MySessionHandler();
session_set_save_handler($handler, true);
session_start();

// proceed to set and retrieve values by key from $_SESSION

İçindekiler

  • SessionHandlerInterface::close — Close the session
  • SessionHandlerInterface::destroy — Destroy a session
  • SessionHandlerInterface::gc — Cleanup old sessions
  • SessionHandlerInterface::open — Initialize session
  • SessionHandlerInterface::read — Read session data
  • SessionHandlerInterface::write — Write session data
SessionHandler::write
SessionHandlerInterface::close
Oturumlar


Close the session

SessionHandlerInterface
SessionHandlerInterface::destroy
SessionHandlerInterface
PHP Manual

SessionHandlerInterface::close

(PHP 5 >= 5.4.0, PHP 7)

SessionHandlerInterface::close — Close the session

Açıklama

abstract public bool SessionHandlerInterface::close ( void )

Closes the current session. This function is automatically executed when closing the session, or explicitly via session_write_close().

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Oturum kaydının dönüş değeri (normalde başarı durumunda TRUE, aksi durumda FALSE). Dikkat edin, bu değer işlenmek üzere dahili olarak PHP'ye döndürülür.

SessionHandlerInterface
SessionHandlerInterface::destroy
SessionHandlerInterface


Destroy a session

SessionHandlerInterface::close
SessionHandlerInterface::gc
SessionHandlerInterface
PHP Manual

SessionHandlerInterface::destroy

(PHP 5 >= 5.4.0, PHP 7)

SessionHandlerInterface::destroy — Destroy a session

Açıklama

abstract public bool SessionHandlerInterface::destroy ( string $session_id )

Destroys a session. Called by session_regenerate_id() (with $destroy = TRUE), session_destroy() and when session_decode() fails.

Değiştirgeler

session_id

The session ID being destroyed.

Dönen Değerler

Oturum kaydının dönüş değeri (normalde başarı durumunda TRUE, aksi durumda FALSE). Dikkat edin, bu değer işlenmek üzere dahili olarak PHP'ye döndürülür.

SessionHandlerInterface::close
SessionHandlerInterface::gc
SessionHandlerInterface


Cleanup old sessions

SessionHandlerInterface::destroy
SessionHandlerInterface::open
SessionHandlerInterface
PHP Manual

SessionHandlerInterface::gc

(PHP 5 >= 5.4.0, PHP 7)

SessionHandlerInterface::gc — Cleanup old sessions

Açıklama

abstract public bool SessionHandlerInterface::gc ( int $maxlifetime )

Cleans up expired sessions. Called by session_start(), based on session.gc_divisor, session.gc_probability and session.gc_maxlifetime settings.

Değiştirgeler

maxlifetime

Sessions that have not updated for the last maxlifetime seconds will be removed.

Dönen Değerler

Oturum kaydının dönüş değeri (normalde başarı durumunda TRUE, aksi durumda FALSE). Dikkat edin, bu değer işlenmek üzere dahili olarak PHP'ye döndürülür.

SessionHandlerInterface::destroy
SessionHandlerInterface::open
SessionHandlerInterface


Initialize session

SessionHandlerInterface::gc
SessionHandlerInterface::read
SessionHandlerInterface
PHP Manual

SessionHandlerInterface::open

(PHP 5 >= 5.4.0, PHP 7)

SessionHandlerInterface::open — Initialize session

Açıklama

abstract public bool SessionHandlerInterface::open ( string $save_path , string $session_name )

Re-initialize existing session, or creates a new one. Called when a session starts or when session_start() is invoked.

Değiştirgeler

save_path

The path where to store/retrieve the session.

session_name

The session name.

Dönen Değerler

Oturum kaydının dönüş değeri (normalde başarı durumunda TRUE, aksi durumda FALSE). Dikkat edin, bu değer işlenmek üzere dahili olarak PHP'ye döndürülür.

Ayrıca Bakınız

  • session_name() - Geçerli oturum ismini döndürür ve/veya tanımlar
  • The session.auto-start configuration directive.

SessionHandlerInterface::gc
SessionHandlerInterface::read
SessionHandlerInterface


Read session data

SessionHandlerInterface::open
SessionHandlerInterface::write
SessionHandlerInterface
PHP Manual

SessionHandlerInterface::read

(PHP 5 >= 5.4.0, PHP 7)

SessionHandlerInterface::read — Read session data

Açıklama

abstract public string SessionHandlerInterface::read ( string $session_id )

Reads the session data from the session storage, and returns the results. Called right after the session starts or when session_start() is called. Please note that before this method is called SessionHandlerInterface::open() is invoked.

This method is called by PHP itself when the session is started. This method should retrieve the session data from storage by the session ID provided. The string returned by this method must be in the same serialized format as when originally passed to the SessionHandlerInterface::write() If the record was not found, return an empty string.

The data returned by this method will be decoded internally by PHP using the unserialization method specified in session.serialize_handler. The resulting data will be used to populate the $_SESSION superglobal.

Note that the serialization scheme is not the same as unserialize() and can be accessed by session_decode().

Değiştirgeler

session_id

The session id.

Dönen Değerler

Returns an encoded string of the read data. If nothing was read, it must return an empty string. Note this value is returned internally to PHP for processing.

Ayrıca Bakınız

  • The session.serialize_handler configuration directive.

SessionHandlerInterface::open
SessionHandlerInterface::write
SessionHandlerInterface


Write session data

SessionHandlerInterface::read
Session PgSQL
SessionHandlerInterface
PHP Manual

SessionHandlerInterface::write

(PHP 5 >= 5.4.0, PHP 7)

SessionHandlerInterface::write — Write session data

Açıklama

abstract public bool SessionHandlerInterface::write ( string $session_id , string $session_data )

Writes the session data to the session storage. Called by session_write_close(), when session_register_shutdown() fails, or during a normal shutdown. Note: SessionHandlerInterface::close() is called immediately after this function.

PHP will call this method when the session is ready to be saved and closed. It encodes the session data from the $_SESSION superglobal to a serialized string and passes this along with the session ID to this method for storage. The serialization method used is specified in the session.serialize_handler setting.

Note this method is normally called by PHP after the output buffers have been closed unless explicitly called by session_write_close()

Değiştirgeler

session_id

The session id.

session_data

The encoded session data. This data is the result of the PHP internally encoding the $_SESSION superglobal to a serialized string and passing it as this parameter. Please note sessions use an alternative serialization method.

Dönen Değerler

Oturum kaydının dönüş değeri (normalde başarı durumunda TRUE, aksi durumda FALSE). Dikkat edin, bu değer işlenmek üzere dahili olarak PHP'ye döndürülür.

Ayrıca Bakınız

  • The session.serialize_handler configuration directive.

SessionHandlerInterface::read
Session PgSQL
SessionHandlerInterface


PostgreSQL Session Save Handler

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Table definitions
  • Öntanımlı Sabitler
  • Session PgSQL İşlevleri
    • session_pgsql_add_error — Increments error counts and sets last error message
    • session_pgsql_get_error — Returns number of errors and last error message
    • session_pgsql_get_field — Get custom field value
    • session_pgsql_reset — Reset connection to session database servers
    • session_pgsql_set_field — Set custom field value
    • session_pgsql_status — Get current save handler status
SessionHandlerInterface::write
Giriş
Oturum Eklentileri


Giriş

Bilginize: Bu eklenti Windows sistemlerinde çalışmaz.

This module provides an additional session save handler for the session module using » PostgreSQL as a storage system. A user-level session storage function may also be used - session_set_save_handler(), but this module is written in C and therefore could be twice as fast, compared to a session save handler written in PHP.

Session PgSQL is designed to scale any size of web sites and offers some advanced features:

  • session tables are created automatically
  • automatic session table vacuum
  • better garbage collection
  • multiple PostgreSQL servers support
  • automatic database server failover (switching)
  • automatic database server load balancing if there are multiple PostgreSQL servers.
  • short circuit UPDATE

Session PgSQL
Yapılandırma/Kurulum
Session PgSQL


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Session PgSQL


Gereksinimler

You need at least PHP >= 4.3.0, and PostgreSQL >=7.2.0 as database server. libpq that comes with PostgreSQL 7.2.0 or later (and header files to build) and » libmm (and header files).

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu eklentinin geliştirmesi durmuştur. Ancak, kaynak kodunu PECL SVN deposunda bulabilirsiniz. Yeri: » http://svn.php.net/viewvc/pecl/session_pgsql.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

PostgreSQL session save handler is still under development. Refer to the README file in the source distribution for configuration details.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Özkaynak Türleri

Bu eklentinin tanımlı hiçbir özkaynak türü yoktur.

Çalışma Anı Yapılandırması
Table definitions
Yapılandırma/Kurulum


Table definitions

Session table definition

CREATE TABLE php_session (
 sess_id            text,
 sess_name          text,
 sess_data          text,
 sess_created       integer,
 sess_modified      integer,
 sess_expire        integer,
 sess_addr_created  text,
 sess_addr_modified text,
 sess_counter       integer,
 sess_error         integer,
 sess_warning       integer,
 sess_notice        integer,
 sess_err_message   text,
 sess_custom        text
);

CREATE INDEX php_session_idx ON php_session USING BTREE (sess_id);

Uyarı

If you use HASH for INDEX, you'll have a deadlock problem when the server load is very high. Even if it's unlikely to have a deadlock under normal operation, it can occur. Do not use HASH for INDEX.

You may change the session table as long as all fields are defined.

Application variables table definition

CREATE TABLE php_app_vars (
 app_modified       integer,
 app_name           text,
 app_vars           text
);

Özkaynak Türleri
Öntanımlı Sabitler
Session PgSQL


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Table definitions
Session PgSQL İşlevleri
Session PgSQL


Session PgSQL İşlevleri

Contact Information

I have at the moment not very much time to further develop this extension. I will implement more and more features in the near future.

If you have comments, bug fixes, enhancements or want to help developing this, you can drop me a mail at » yohgaki@php.net. Any help is very welcome.

İçindekiler

  • session_pgsql_add_error — Increments error counts and sets last error message
  • session_pgsql_get_error — Returns number of errors and last error message
  • session_pgsql_get_field — Get custom field value
  • session_pgsql_reset — Reset connection to session database servers
  • session_pgsql_set_field — Set custom field value
  • session_pgsql_status — Get current save handler status
Öntanımlı Sabitler
session_pgsql_add_error
Session PgSQL


Increments error counts and sets last error message

Session PgSQL İşlevleri
session_pgsql_get_error
Session PgSQL İşlevleri
PHP Manual

session_pgsql_add_error

(PECL session_pgsql SVN)

session_pgsql_add_error — Increments error counts and sets last error message

Açıklama

bool session_pgsql_add_error ( int $error_level [, string $error_message ] )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

error_level

error_message

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • session_pgsql_get_error() - Returns number of errors and last error message

Session PgSQL İşlevleri
session_pgsql_get_error
Session PgSQL İşlevleri


Returns number of errors and last error message

session_pgsql_add_error
session_pgsql_get_field
Session PgSQL İşlevleri
PHP Manual

session_pgsql_get_error

(PECL session_pgsql SVN)

session_pgsql_get_error — Returns number of errors and last error message

Açıklama

array session_pgsql_get_error ([ bool $with_error_message = false ] )

Get the number of errors and optional the error messages.

Değiştirgeler

with_error_message

Set to TRUE the literal error message for each error is also returned.

Dönen Değerler

The number of errors are returned as array.

Ayrıca Bakınız

  • session_pgsql_add_error() - Increments error counts and sets last error message

session_pgsql_add_error
session_pgsql_get_field
Session PgSQL İşlevleri


Get custom field value

session_pgsql_get_error
session_pgsql_reset
Session PgSQL İşlevleri
PHP Manual

session_pgsql_get_field

(PECL session_pgsql SVN)

session_pgsql_get_field — Get custom field value

Açıklama

string session_pgsql_get_field ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Ayrıca Bakınız

  • session_pgsql_set_field() - Set custom field value

session_pgsql_get_error
session_pgsql_reset
Session PgSQL İşlevleri


Reset connection to session database servers

session_pgsql_get_field
session_pgsql_set_field
Session PgSQL İşlevleri
PHP Manual

session_pgsql_reset

(PECL session_pgsql SVN)

session_pgsql_reset — Reset connection to session database servers

Açıklama

bool session_pgsql_reset ( void )

Reset the connection to the session database servers.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

session_pgsql_get_field
session_pgsql_set_field
Session PgSQL İşlevleri


Set custom field value

session_pgsql_reset
session_pgsql_status
Session PgSQL İşlevleri
PHP Manual

session_pgsql_set_field

(PECL session_pgsql SVN)

session_pgsql_set_field — Set custom field value

Açıklama

bool session_pgsql_set_field ( string $value )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

value

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • session_pgsql_get_field() - Get custom field value

session_pgsql_reset
session_pgsql_status
Session PgSQL İşlevleri


Get current save handler status

session_pgsql_set_field
Metin İşleme
Session PgSQL İşlevleri
PHP Manual

session_pgsql_status

(PECL session_pgsql SVN)

session_pgsql_status — Get current save handler status

Açıklama

array session_pgsql_status ( void )
Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

session_pgsql_set_field
Metin İşleme
Session PgSQL İşlevleri


Metin İşleme

  • BBCode — Bulletin Board Code
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • BBCode İşlevleri
  • Perl Uyumlu Düzenli İfadeler — PCRE Eklentisi
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • PCRE Şablonları
    • PCRE İşlevleri
  • POSIX Düzenli İfadeleri — Düzenli İfadeler (Gelişmiş POSIX)
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • POSIX Düzenli İfade İşlevleri
  • ssdeep — ssdeep Fuzzy Hashing
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • ssdeep İşlevleri
  • Dizgeler
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Dizge İşlevleri
session_pgsql_status
BBCode
İşlev Başvuru Kılavuzu


Bulletin Board Code

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • BBCode İşlevleri
    • bbcode_add_element — Bir bbcode öğesi ekler
    • bbcode_add_smiley — Çözümleyiciye gülen surat ekler
    • bbcode_create — Bir BBCode özkaynağı oluşturur
    • bbcode_destroy — BBCode_Havuzu özkaynağını kapatır
    • bbcode_parse — Belirtilen dizgeyi kural kümesine göre çözümler
    • bbcode_set_arg_parser — Özkaynağa, değiştirge çözümlemesi için farklı bir kural kümesi kullanan başka bir çözümleyici ekler
    • bbcode_set_flags — Çözümleyici seçeneklerini belirler veya değiştirir
Metin İşleme
Giriş
Metin İşleme


Giriş

Bu eklenti BBCode kodlanmış metni, HTML veya başka bir biçimleme diline çevirmek için yardımcı olmayı amaçlar. Tek geçişli çözümleme (one pass parsing) kullanır ve bu genel düzenli ifade temelli yaklaşımdan daha fazla hız artışı sağlar. Ayrıca açılan/kapanan etiketleri yeniden düzenleyerek ve kapanmamış etiketleri kapatarak geçerli HTML üretir.

0.10.1 sürümünden beri tek tırnak, çift tırnak, HTML öncelenmiş çift tırnak değiştirgeleri destekler.

BBCode
Yapılandırma/Kurulum
BBCode


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
BBCode


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/bbcode

Başka bir çözüm de PHP ile yazılmış olan » HTML_BBCodeParser PEAR paketidir.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Özkaynak Türleri

BBCode eklentisinde kullanılan tek bir özkaynak vardır: bbcode_create() tarafından döndürülen BBCode_Container.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

BBCODE_TYPE_NOARG (integer)
Bu BBCode etiketi herhangi bir değiştirge almaz.
BBCODE_TYPE_SINGLE (integer)
Bu BBCode etiketine ait kapanış etiketi yoktur.
BBCODE_TYPE_ARG (integer)
Bu BBCode etiketi bir değiştireye ihtiyaç duyar.
BBCODE_TYPE_OPTARG (integer)
Bu BBCode etiketi seçimlik bir değiştirge alabilir.
BBCODE_TYPE_ROOT (integer)
Bu BBCode etiketi özel kök etiketidir (yuvalama seviyesi 0).
BBCODE_FLAGS_ARG_PARSING (integer)
Bu BBCode etiketi için alt-çözümleyici değiştirge gereklidir (değiştirge BBCode eklentisi tarafından ayrıca çözümlenir). 0.10.2 sürümünden beri başka bir çözümleyici, değiştirge çözümleyicisi olarak kullanılabilir.
BBCODE_FLAGS_CDATA_NOT_ALLOWED (integer)
Bu BBCode etiketi içerik kabul etmez (otomatik olarak boşaltır).
BBCODE_FLAGS_SMILEYS_ON (integer) - sürüm 0.10.2'den beri
Bu BBCode etiketi gülen suratlar kabul eder.
BBCODE_FLAGS_SMILEYS_OFF (integer) - sürüm 0.10.2'den beri
Bu BBCode etiketi gülen suratlar kabul etmez.
BBCODE_FLAGS_ONE_OPEN_PER_LEVEL (integer) - sürüm 0.10.2'den beri
Bu BBCode etiketi, eğer aynı yuvalama seviyesinde benzer tipte bir etiket bulursa kendiliğinden kapatır.
BBCODE_FLAGS_REMOVE_IF_EMPTY (integer) - 0.10.2'den beri
Bu BBCode etiketi eğer içerik boşsa kendiliğinden çıkartır, daha hafif HTML üretimi sağlar.
BBCODE_FLAGS_DENY_REOPEN_CHILD (integer) - 0.10.3'den beri
Bu BBCode etiketi, otomatik kapatılırken, kapatılmamış çocuk etiketlerin yeniden açılmasına izin vermez.
BBCODE_ARG_DOUBLE_QUOTE (integer) - 0.10.2'den beri
HTML değiştirgelerinde çift tırnak (") kullanılmasını sağlayan bir çözümleyici seçeneğidir.
BBCODE_ARG_SINGLE_QUOTE (integer) - 0.10.2'den beri
HTML değiştirgelerinde tek tırnak (') kullanılmasını sağlayan bir çözümleyici seçeneğidir.
BBCODE_ARG_HTML_QUOTE (integer) - 0.10.2'den beri
Bu çözümleyici seçeneği, değiştirgelerde çift tırnakların HTML sürümünün (&quot;) kullanılmasını sağlar.
BBCODE_ARG_QUOTE_ESCAPING (integer) - 1.0.2'den beri
Bu çözümleyici seçeneği, değiştirge tırnaklarının kaçılmış durumda kalmasına izin verir. Bu \ ile kaçılabilen herhangi bir tırnak karakterinin veya ters bölü karakterinin kendisinin değiştirge ayracı olmasını önler. Eğer kaçılamaz bir karakter önünde bulunursa atılacaktır. Öntanımlı olarak kaçış kullanılmaz.
BBCODE_AUTO_CORRECT (integer) - 0.10.2'den beri
Bu çözümleyici seçeneği hatalara karşı çözümleyicinin davranışını düzenler. Açılmış etiketleri açıldığı sırada kapatır ve bir kapanış etiketi ile karşılaştığı zaman, eğer açılış etiketi varsa geçerli olarak alınır.
BBCODE_CORRECT_REOPEN_TAGS (integer) - 0.10.2'den beri
Bu çözümleyici seçeneği hatalara karşı çözümleyicinin davranışını düzenler. Kapanış etiketleri düzgün sırasında değilse açılış etiketlerini yeniden açar.
BBCODE_DISABLE_TREE_BUILD (integer) - 0.10.2'den beri
BBCode çözümlemeyi iptal eden bir çözümleyici seçeneğidir, sadece "gülen suratlar" değiştirmesi yapılacaksa yararlıdır.
BBCODE_DEFAULT_SMILEYS_ON (integer) - 0.10.2'den beri
Etiket seviyesinde bir işaret verilmediyse gülen suratlar değiştirgesini ektin(ON) duruma getiren çözümleyici seçeneğidir.
BBCODE_DEFAULT_SMILEYS_OFF (integer) - 0.10.2'den beri
Etiket seviyesinde bir işaret verilmediyse gülen suratlar değiştirgesini etkisiz (OFF) duruma getiren çözümleyici seçeneğidir.
BBCODE_FORCE_SMILEYS_OFF (integer) - 0.10.2'den beri
Gülen suratlar çözümlemesini tamamen etkisiz duruma getiren çözümleyici seçeneğidir.
BBCODE_SMILEYS_CASE_INSENSITIVE (integer) - 0.10.3'den beri
Gülen suratların bulunabilmesi için basit ikilik arama yerine büyüklük duyarsız arama kullanılır.
BBCODE_SET_FLAGS_SET (integer) - 0.10.2'den beri
Çözümleyici üzerinde bütün seçenek düzenlemelerinin yapılmasına (SET) izin verir.
BBCODE_SET_FLAGS_ADD (integer) - 0.10.2'den beri
Çözümleyici üzerinde bir seçenek değerini etkin (ON) duruma getirir.
BBCODE_SET_FLAGS_REMOVE (integer) - 0.10.2'den beri
Çözümleyici üzerinde bir seçenek değerini etkisiz (OFF) duruma getirir.
Özkaynak Türleri
BBCode İşlevleri
BBCode


BBCode İşlevleri

İçindekiler

  • bbcode_add_element — Bir bbcode öğesi ekler
  • bbcode_add_smiley — Çözümleyiciye gülen surat ekler
  • bbcode_create — Bir BBCode özkaynağı oluşturur
  • bbcode_destroy — BBCode_Havuzu özkaynağını kapatır
  • bbcode_parse — Belirtilen dizgeyi kural kümesine göre çözümler
  • bbcode_set_arg_parser — Özkaynağa, değiştirge çözümlemesi için farklı bir kural kümesi kullanan başka bir çözümleyici ekler
  • bbcode_set_flags — Çözümleyici seçeneklerini belirler veya değiştirir
Öntanımlı Sabitler
bbcode_add_element
BBCode


Bir bbcode öğesi ekler

BBCode İşlevleri
bbcode_add_smiley
BBCode İşlevleri
PHP Manual

bbcode_add_element

(PECL bbcode >= 0.9.0)

bbcode_add_element — Bir bbcode öğesi ekler

Açıklama

bool bbcode_add_element ( resource $bbcode_havuzu , string $etiket_adi , array $etiket_kurallari )

Mevcut bir BBCode_Havuzu etiket kümesine, etiket kurallarını kullanarak, bir etiket ekler.

Değiştirgeler

bbcode_havuzu

bbcode_create() işlevi ile oluşturulmuş bir BBCode_Havuzu özkaynağı.

etiket_adi

BBCode_Havuzu etiket kümesine eklenecek yeni bir etiket.

etiket_kurallari

Çözümleme kurallarını içeren ilişkisel bir dizi; kullanılabilir anahtarlar için bbcode_create() işlevine bakın.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

BBCode İşlevleri
bbcode_add_smiley
BBCode İşlevleri


Çözümleyiciye gülen surat ekler

bbcode_add_element
bbcode_create
BBCode İşlevleri
PHP Manual

bbcode_add_smiley

(PECL bbcode >= 0.10.2)

bbcode_add_smiley — Çözümleyiciye gülen surat ekler

Açıklama

bool bbcode_add_smiley ( resource $bbcode_havuzu , string $kaynak , string $hedef )

Çözümleyiciye gülen surat ekler.

Değiştirgeler

bbcode_havuzu

bbcode_create() işlevinden dönen BBCode_Havuzu özkaynağı.

kaynak

Bulunduğu zaman değiştirilecek gülen surat dizgesi.

hedef

Gülen surat ile değişitirilecek dizge.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - bbcode_add_smiley() örneği

<?php
/*
 * Kural kumesi
 */
$arrayBBCode=array(
    ''=>         array('type'=>BBCODE_TYPE_ROOT,
                       'childs'=>'!i'),
    'b'=>        array('type'=>BBCODE_TYPE_NOARG,
                       'open_tag'=>'<b>',
                       'close_tag'=>'</b>'),
    'u'=>        array('type'=>BBCODE_TYPE_NOARG,
                       'open_tag'=>'<u>',
                       'close_tag'=>'</u>',
                       'flags'=>BBCODE_FLAGS_SMILEYS_OFF),
    'i'=>        array('type'=>BBCODE_TYPE_NOARG,
                       'open_tag'=>'<i>',
                       'close_tag'=>'</i>',
                       'childs'=>'b'),
);
/*
 * Cozumlenecek Metin
 */
$text=<<<EOF
[i] Bu bolume dokunma [/i] :)
[b] Gulen surat kullanarak :( [/b]
[u] Gulen surat kullanmadan :D [/u]
EOF;
/*
 * Cozumeliyici baslatma
 */
$BBHandler=bbcode_create($arrayBBCode);
/*
 * Gulen Surat kurallarini cozumleyiciye ekleme
 */
bbcode_add_smiley($BBHandler, ":)", "<img src=\"smiley.gif\" alt=\":)\" />");
bbcode_add_smiley($BBHandler, ":(", "<img src=\"sad.gif\" alt=\":(\" />");
bbcode_add_smiley($BBHandler, ":D", "<img src=\"happy.gif\" alt=\":D\" />");
bbcode_add_smiley($BBHandler, ":p", "<img src=\"tong.gif\" alt=\":p\" />");
bbcode_add_smiley($BBHandler, ":|", "<img src=\"special.gif\" alt=\":|\" />");
bbcode_add_smiley($BBHandler, ":6:", "<img src=\"six.gif\" alt=\":6:\" />");
/*
 * Metni cozumle
 */
echo bbcode_parse($BBHandler,$text);
?>

Yukarıdaki örneğin çıktısı:

<i> Bu bolume dokunma </i> <img src="smiley.gif" alt=":)" />
<b> Gulen surat kullanarak <img src="sad.gif" alt=":(" /> </b>
<u> Gulen surat kullanmadan :D </u>

bbcode_add_element
bbcode_create
BBCode İşlevleri


Bir BBCode özkaynağı oluşturur

bbcode_add_smiley
bbcode_destroy
BBCode İşlevleri
PHP Manual

bbcode_create

(PECL bbcode >= 0.9.0)

bbcode_create — Bir BBCode özkaynağı oluşturur

Açıklama

resource bbcode_create ([ array $bbcode_baslangic_etiketleri ] )

İşlev, BBCode dizgelerini çözümlemek için yeni bir özkaynak oluşturur.

Değiştirgeler

bbcode_baslangic_etiketleri

Etiket isimlerinin anahtar, bu anahtar için değiştirgeleri dizi olarak içeren ilişkisel dizidir. Aşağıdaki anahtar/değer çiftleri desteklenir.

  • flags seçimlik - BBCODE_FLAGS_* sabitlerinden oluşan bir seçenek kümesi.
  • type gerekli - etiketin türünü gösteren bir tamsayı değeri. BBCODE_TYPE_* sabitlerini kullanın.
  • open_tag gerekli - açılış etiketi için HTML dizge değeri.
  • close_tag gerekli - kapanış etiketi için HTML dizge değeri.
  • default_arg seçimlik - etiket türü OPTARG türünde ise ve değiştirge verilmedi ise bu anahtarın değeri kullanılır.
  • content_handling seçimlik - İçeriğin değiştirilmesi için geriçağırım işlevi sağlar. Nesne yönelimli biçim 0.10.1 sürümü ve sonrasında desteklenmiştir. Geriçağırım işlevinin sözdizimi: isim(string $icerik, string $degistirge)
  • param_handling seçimlik - Değiştirgenin değiştirilmesi için geriçağırım işlevi sağlar. Nesne yönelimli biçim 0.10.1 sürümü ve sonrasında desteklenmiştir. Geriçağırım işlevinin sözdizimi: isim(string $icerik, string $degistirge)
  • childs seçimlik - Etiket için kabul edilen alt etiketlerin listesidir. Listenin biçimi virgüller ile ayrılmış bir dizgedir. Eğer liste ! ile başlarsa, dizge kabul edilmeyen alt etiketleri gösterir.
  • parent seçimlik - Etiket için kabul edilen alt etiketlerin listesidir. Listenin biçimi virgüller ile ayrılmış bir dizgedir.

Dönen Değerler

Bir BBCode_Havuzu özkaynağı döndürür.

Örnekler

Örnek 1 - bbcode_create() örneği

<?php
$arrayBBCode=array(
    ''=>         array('type'=>BBCODE_TYPE_ROOT,  'childs'=>'!i'),
    'i'=>        array('type'=>BBCODE_TYPE_NOARG, 'open_tag'=>'<i>',
                    'close_tag'=>'</i>', 'childs'=>'b'),
    'url'=>      array('type'=>BBCODE_TYPE_OPTARG,
                    'open_tag'=>'<a href="{PARAM}">', 'close_tag'=>'</a>',
                    'default_arg'=>'{CONTENT}',
                    'childs'=>'b,i'),
    'img'=>      array('type'=>BBCODE_TYPE_NOARG,
                    'open_tag'=>'<img src="', 'close_tag'=>'" />',
                    'childs'=>''),
    'b'=>        array('type'=>BBCODE_TYPE_NOARG, 'open_tag'=>'<b>',
                    'close_tag'=>'</b>'),
);
$text=<<<EOF
[b]Bold Text[/b]
[i]Italic Text[/i]
[url]http://www.php.net/[/url]
[url=http://pecl.php.net/][b]Content Text[/b][/url]
[img]http://static.php.net/www.php.net/images/php.gif[/img]
[url=http://www.php.net/]
[img]http://static.php.net/www.php.net/images/php.gif[/img]
[/url]
EOF;
$BBHandler=bbcode_create($arrayBBCode);
echo bbcode_parse($BBHandler,$text);
?>

Yukarıdaki örneğin çıktısı:

<b>Bold Text</b>
<i>Italic Text</i>
<a href="http://www.php.net/">http://www.php.net/</a>
<a href="http://pecl.php.net/"><b>Content Text</b></a>
<img src="http://static.php.net/www.php.net/images/php.gif" />
<a href="http://www.php.net/">
[img]http://static.php.net/www.php.net/images/php.gif[/img]
</a>

bbcode_add_smiley
bbcode_destroy
BBCode İşlevleri


BBCode_Havuzu özkaynağını kapatır

bbcode_create
bbcode_parse
BBCode İşlevleri
PHP Manual

bbcode_destroy

(PECL bbcode >= 0.9.0)

bbcode_destroy — BBCode_Havuzu özkaynağını kapatır

Açıklama

bool bbcode_destroy ( resource $bbcode_havuzu )

Bu işlev bbcode_create() işlevi ile açılmış olan özkaynağı kapatır.

Değiştirgeler

bbcode_havuzu

bbcode_create() işlevinden dönen özkaynak.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

bbcode_create
bbcode_parse
BBCode İşlevleri


Belirtilen dizgeyi kural kümesine göre çözümler

bbcode_destroy
bbcode_set_arg_parser
BBCode İşlevleri
PHP Manual

bbcode_parse

(PECL bbcode >= 0.9.0)

bbcode_parse — Belirtilen dizgeyi kural kümesine göre çözümler

Açıklama

string bbcode_parse ( resource $bbcode_havuzu , string $cozumlenecek_dizge )

bbcode_create() işlevi ile oluşturulmuş bbcode_havuzundaki kural kümesine göre cozumlenecek_dizge'yi çözümler.

Değiştirgeler

bbcode_havuzu

bbcode_create() işlevinden geri dönen BBCode_Havuz özkaynağı

cozumlenecek_dizge

Çözümlenecek dizge.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

bbcode_destroy
bbcode_set_arg_parser
BBCode İşlevleri


Özkaynağa, değiştirge çözümlemesi için farklı bir kural kümesi kullanan başka bir çözümleyici ekler

bbcode_parse
bbcode_set_flags
BBCode İşlevleri
PHP Manual

bbcode_set_arg_parser

(PECL bbcode >= 0.10.2)

bbcode_set_arg_parser — Özkaynağa, değiştirge çözümlemesi için farklı bir kural kümesi kullanan başka bir çözümleyici ekler

Açıklama

bool bbcode_set_arg_parser ( resource $bbcode_havuzu , resource $bbcode_degistirge_havuzu )

bbcode_havuzuna başka bir çözümleyici ekler. Bu ikinci çözümleyici sadece değiştirge çözümlemesinde kullanılır. Eğer bu işlev kullanılmazsa, öntanımlı değiştirge çözümleyicisi, çözümleyicinin kendisidir.

Değiştirgeler

bbcode_havuzu

bbcode_create() işlevinden dönen BBCode_Havuz özkaynağı.

bbcode_degistirge_havuzu

Sadece değiştirge çözümlemesi için kullanılacak olan, bbcode_create() işlevinden dönen BBCode_Havuz özkaynağı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - bbcode_set_arg_parser() örneği

<?php
/*
 * Ana cozumleyici icin kural kumesi
 */
$arrayBBCode=array(
    'quote'=>    array('type'=>BBCODE_TYPE_ARG,
                       'open_tag'=>'<quote><h4>Source: {PARAM}</h4>',
                       'close_tag'=>'</quote>',
                       'flags'=>BBCODE_FLAGS_REMOVE_IF_EMPTY|
                       BBCODE_FLAGS_ARG_PARSING),
    'b'=>        array('type'=>BBCODE_TYPE_NOARG,
                       'open_tag'=>'<b>', 'close_tag'=>'</b>',
                       'flags'=>BBCODE_FLAGS_REMOVE_IF_EMPTY),
    'u'=>        array('type'=>BBCODE_TYPE_NOARG,
                       'open_tag'=>'<u>', 'close_tag'=>'</u>',
                       'flags'=>BBCODE_FLAGS_SMILEYS_OFF |
                          BBCODE_FLAGS_REMOVE_IF_EMPTY |
                          BBCODE_FLAGS_SMILEYS_OFF),
    'i'=>        array('type'=>BBCODE_TYPE_NOARG,
                       'open_tag'=>'<i>', 'close_tag'=>'</i>',
                       'flags'=>BBCODE_FLAGS_REMOVE_IF_EMPTY),
);
/*
 * Degistirge cozumleyicisi icin kural kumesi
 */
$arrayBBCode_arg=array(
    'b'=>        array('type'=>BBCODE_TYPE_NOARG,
                       'open_tag'=>'<b class="sub">', 'close_tag'=>'</b>',
                       'flags'=>BBCODE_FLAGS_REMOVE_IF_EMPTY),
    'u'=>        array('type'=>BBCODE_TYPE_NOARG,
                       'open_tag'=>'<u>', 'close_tag'=>'</u>',
                       'flags'=>BBCODE_FLAGS_SMILEYS_OFF |
                         BBCODE_FLAGS_REMOVE_IF_EMPTY |
                         BBCODE_FLAGS_SMILEYS_OFF),
    'i'=>        array('type'=>BBCODE_TYPE_NOARG,
                       'open_tag'=>'<i>', 'close_tag'=>'</i>',
                       'flags'=>BBCODE_FLAGS_REMOVE_IF_EMPTY),
);
/*
 * Cozumleyecegimiz metin
 */
$text=<<<EOF
[quote="[b]Test[/b]"]
Foo :)
[/quote]
[b]Bar example :)[/b] :)
EOF;
/*
 * Iki cozumleyiciyi baslatma
 */
$BBHandler=bbcode_create($arrayBBCode);
$BBArgHandler=bbcode_create($arrayBBCode_arg);
/*
 * Cozumleyiciler uzerinde secenekleri ayarlama
 */
bbcode_set_flags($BBHandler,
                 BBCODE_CORRECT_REOPEN_TAGS|BBCODE_DEFAULT_SMILEYS_ON|
                 BBCODE_ARG_DOUBLE_QUOTE|BBCODE_ARG_SINGLE_QUOTE|
                 BBCODE_ARG_HTML_QUOTE, BBCODE_SET_FLAGS_SET);
bbcode_set_flags($BBArgHandler,
                 BBCODE_CORRECT_REOPEN_TAGS|BBCODE_DEFAULT_SMILEYS_ON|
                 BBCODE_ARG_DOUBLE_QUOTE|BBCODE_ARG_SINGLE_QUOTE|
                 BBCODE_ARG_HTML_QUOTE, BBCODE_SET_FLAGS_SET);
/*
 * $BBArgHandler degiskenini, degistirge cozumleyicisi olarak atama
 */
bbcode_set_arg_parser($BBHandler,$BBArgHandler);
/*
 * Ana cozumleyiciye gulen surat kurallari ekleme
 */
bbcode_add_smiley($BBHandler, ":)", "<img src=\"smiley.gif\" alt=\":)\" />");
/*
 * Ana cozumleyiciye cozumlenecek metni verme
 */
echo bbcode_parse($BBHandler,$text);
?>

Yukarıdaki örneğin çıktısı:

<quote><h4>Source: <b class="sub">Test</b></h4>
Foo <img src="smiley.gif" alt=":)" />
</quote>
<b>Bar example :)</b> <img src="smiley.gif" alt=":)" />

bbcode_parse
bbcode_set_flags
BBCode İşlevleri


Çözümleyici seçeneklerini belirler veya değiştirir

bbcode_set_arg_parser
Perl Uyumlu Düzenli İfadeler
BBCode İşlevleri
PHP Manual

bbcode_set_flags

(PECL bbcode >= 0.10.2)

bbcode_set_flags — Çözümleyici seçeneklerini belirler veya değiştirir

Açıklama

bool bbcode_set_flags ( resource $bbcode_havuzu , int $secenekler [, int $durum = BBCODE_SET_FLAGS_SET ] )

Çözümleyici seçeneklerini belirler veya değiştirir.

Değiştirgeler

bbcode_havuzu

bbcode_create() işlevinden dönen BBCode_Havuz önkaynağı.

secenekler

BBCode_Havuz seçeneklerine uygulanacak seçenek veya seçenekler.

durum

Belirtilen seçenek kümesindeki seçeneklerin atanacağını mı yoksa değiştirileceğini mi belirleyen BBCODE_SET_FLAGS_* sabitlerinden biri.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - bbcode_set_flags() örneği

<?php
/*
 * Kural Kümesini Hazırlama
 */
$arrayBBCode=array(
    'b'=>        array('type'=>BBCODE_TYPE_NOARG,
                       'open_tag'=>'<b>', 'close_tag'=>'</b>'),
    'u'=>        array('type'=>BBCODE_TYPE_NOARG,
                       'open_tag'=>'<u>', 'close_tag'=>'</u>'),
    'i'=>        array('type'=>BBCODE_TYPE_NOARG,
                       'open_tag'=>'<i>', 'close_tag'=>'</i>'),
);
/*
 * Etiketleri geçersiz eşleşmiş bir BBCode
 */
$text="[i] Parser [b] Auto Correction [/i] at work [/b]\n";
$BBHandler=bbcode_create($arrayBBCode);
echo bbcode_parse($BBHandler,$text);
// Kapanan etiketleri kendiliğinden açmayı etkinleştirme
bbcode_set_flags($BBHandler,BBCODE_CORRECT_REOPEN_TAGS,
                 BBCODE_SET_FLAGS_SET);
echo bbcode_parse($BBHandler,$text);

/*
 * Etiketleri eşleşmemiş bir BBCode
 */
$text="[i] Parser [b] Auto Correction [/i] at work\n";
echo bbcode_parse($BBHandler,$text);
// Askıdaki etiketi otomatik kapatmayı etkinleştirme
bbcode_set_flags($BBHandler,
                 BBCODE_CORRECT_REOPEN_TAGS|BBCODE_AUTO_CORRECT,
                 BBCODE_SET_FLAGS_SET);
echo bbcode_parse($BBHandler,$text);
?>

Yukarıdaki örneğin çıktısı:

<i> Parser <b> Auto Correction </b></i> at work
<i> Parser <b> Auto Correction </b></i><b> at work </b>
<i> Parser [b] Auto Correction </i> at work
<i> Parser <b> Auto Correction </b></i><b> at work
</b>

bbcode_set_arg_parser
Perl Uyumlu Düzenli İfadeler
BBCode İşlevleri


PCRE Eklentisi

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
  • PCRE Şablonları
    • Şablon Değiştiricileri — Düzenli ifadeler için kullanılabilecek değiştiriciler
    • Perl ile Farklar — Perl'e göre farklılıklar
    • POSIX regex'ten farklılıklar
    • Şablon Sözdizimi — PCRE düzenli ifade sözdizimi
  • PCRE İşlevleri
    • preg_filter — Bir düzenli ifade arama ve değiştirmesi yapar
    • preg_grep — Düzenli ifadeyle eşleşenleri içeren bir dizi döndürür
    • preg_last_error — Son PCRE düzenli ifade aramasından dönen hatayı döndürür
    • preg_match_all — Kapsamlı bir düzenli ifade eşleştirmesi yapar
    • preg_match — Bir düzenli ifadeyi eşleştirmeye çalışır
    • preg_quote — Düzenli ifadelerin özel karakterlerini önceler
    • preg_replace_callback_array — Perform a regular expression search and replace using callbacks
    • preg_replace_callback — Geriçağırım işlevi kullanarak düzenli ifadeye göre dizgede değişiklik yapar
    • preg_replace — Düzenli ifadeye göre dizgede değişiklik yapar
    • preg_split — Dizgeyi düzenli ifadeye göre böler
bbcode_set_flags
Giriş
Metin İşleme


Giriş

Bu işlevlerde kullanılan şablonların sözdizimi Perl düzenli ifade şablonlarınınkine çok benzer. Örneğin, ifadenin bir ayraçla (bir bölü çizgisi) sarmalanması gerekir. Tersbölü çizgisi ve 0. karakter haricinde her karakter ayraç olarak kullanılabilir. Eğer ayraç karakteri, ifadenin içinde kullanılmışsa bir tersbölü çizgisi ile öncelenmesi gerekir. PHP 4.0.4'ten beri, Perl tarzı (), {}, [] ve <> ayraç çiftleri kullanılabilmektedir. Daha ayrıntılı bilgi için Şablon Sözdizimi bölümüne bakınız.

Sonlandırıcı ayracın ardına eşleşmeyi etkileyen çeşitli değiştiriciler eklenebilir. Daha ayrıntılı bilgi için Şablon Değiştiricileri bölümüne bakınız.

PHP ayrıca, POSIX gelişkin sözdizimini kullanan gelişkin POSIX düzenli ifade işlevlerini de destekler.

Bilginize:

Bu eklenti her evre için ayrı bir derlenmiş düzenli ifade önbelleği (en fazla 4096 bayt) tutar.

Uyarı

PCRE ile ilgili bir takım kısıtlamalar hakkında bilgi sahibi olmalısınız. Daha ayrıntılı bilgi için » http://www.pcre.org/pcre.txt adresine bakınız.

PCRE kütüphanesi, düzenli ifade şablonlarını bir kaç küçük fark dışında, Perl 5 ile aynı sözdizimini ve aynı anlamsallığı kullanarak gerçekler. Şu anki gerçeklenim Perl 5.005 sürümüne karşılık gelir.

Perl Uyumlu Düzenli İfadeler
Yapılandırma/Kurulum
Perl Uyumlu Düzenli İfadeler


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Perl Uyumlu Düzenli İfadeler


Kurulum

PHP 4.2.0'dan itibaren bu işlevler öntanımlı olarak etkindir. PCRE işlevlerinin derlenmesini --without-pcre-regex seçeneği ile engelleyebilirsiniz. Eğer PHP dağıtımı ile gelen kütüphaneyi kullanmayacaksanız kullanacağınız kütüphanenin yerini --with-pcre-regex=DiZiN seçeneği ile belirtebilirsiniz. Daha eski sürümleri kullananlar bu işlevleri kullanmak istiyorlarsa PHP'yi --with-pcre-regex[=DiZiN] seçeneğini kullanarak derlemelidirler.

PHP'nin Windows sürümünde bu eklenti yerleşik olarak gelmektedir. Bu işlevleri Windows'ta kullanmak için herhangi bir eklenti kurmanıza gerek yoktur.

Bilginize:

PHP 5.3.0'dan itibaren bu eklenti iptal edilememekte olup daima kullanılabilir durumdadır.

Ancak, PCRE'yi hala harici bir kütüphaneyi --with-pcre-regex=DiZiN seçeneğiyle belirterek kulanmak mümkündür.

PCRE etkin bir proje olup PHP'nin işlevselliği bu değişikliklerden etkilenir. PCRE'nin en yeni özellikleri PHP belgelerine zamanında aktarılamadığından belgeler kısmen güncel olmayabilir. Değişikliklerin listesini » PCRE kütüphanesi değişiklik günlüğünde bulabilirsiniz. PHP ile dağıtılan PCRE sürümleri aşağıda listelenmiştir:

PHP ile dağıtılan PCRE kütüphanesinin güncelleme geçmişi
PHP Sürümü | Güncel PCRE Sürümü | Açıklama
4.4.7 | 7.7 |
5.0.0 | 4.5 |
5.0.5 | 5.0 |
5.1.0 | 6.2 |
5.2.0 | 6.7 |
5.2.2 | 7.0 |
5.2.4 | 7.2 |
5.2.5 | 7.3 |
5.2.6 | 7.6 |
5.2.7 | 7.8 |
5.3.0 | 7.9 |

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

PCRE Yapılandırma Yönergeleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
pcre.backtrack_limit | "1000000" | PHP_INI_ALL | PHP 5.2.0'dan beri kullanılabilmektedir.
pcre.recursion_limit | "100000" | PHP_INI_ALL | PHP 5.2.0'dan beri kullanılabilmektedir.
pcre.jit | "1" | PHP_INI_ALL | PHP 7.0.0'dan beri kullanılabilmektedir.
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

pcre.backtrack_limit integer

PCRE'nin geriye doğru izleme sınırı. PHP < 5.3.7 için öntanımlı değer: 100000

pcre.recursion_limit integer

PCRE'nin içi içelik sınırı. Bu değeri yüksekçe bir sayıya ayarlarsanız kullanılabilecek tüm yığıtın harcanıp PHP'nin çökmesine sebep olabilirsiniz (Yığıt boyutunu işletim sistemi belirler ve yığıt taşınca PHP çöker).

pcre.jit boolean

PCRE'nin tam kullanım anında derlenip derlenmeyeceğini belirler.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

PCRE Sabitleri
Sabit | Açıklama
PREG_PATTERN_ORDER | Sonuçlar sıralanır. Yani, $eşleşen[0] şablonla eşleşen dizgenin tamamını, $eşleşen[1] ilk parantezli grupla eşleşen alt dizgeyi, $eşleşen[2] ikincisini, vb. içerir. Bu seçenek sadece preg_match_all() işlevi ile kullanılır.
PREG_SET_ORDER | Sonuçlar sıralanır. Yani, $eşleşen[0] şablonla eşleşen ilk kümeyi, $eşleşen[2] ikincisini, vb. içerir. Bu seçenek sadece preg_match_all() işlevi ile kullanılır.
PREG_OFFSET_CAPTURE | PREG_SPLIT_OFFSET_CAPTURE sabitinin açıklamasına bakın. Bu seçenek PHP 4.3.0'dan beri kullanılabilmektedir.
PREG_SPLIT_NO_EMPTY | Bu seçenek preg_split() işlevinin sadece boş olmayan parçaları döndürmesini sağlar.
PREG_SPLIT_DELIM_CAPTURE | Bu seçenek preg_split() işlevinin ayraçlı şablon içindeki parantezli grupları da yakalamasını sağlar. Bu seçenek PHP 4.0.5'ten beri kullanılabilmektedir.
PREG_SPLIT_OFFSET_CAPTURE | Bu seçenek etkinse, her eşleşmede ayrıca sona eklenen dizgenin başlangıcı da döndürülür. Bu, dizi içindeki dönüş değerini değiştirir. Böylece dizinin her elemanı 0. başlangıçtan itibaren eşleşen dizgeyi ve 1. başlangıca konu dizge başlangıcını içeren bir dizi içerir. Bu seçenek PHP 4.3.0'dan beri sadece preg_split() için kullanılabilmektedir.
PREG_NO_ERROR | Hiçbir hata oluşmamışsa preg_last_error() işlevi tarafından döndürülür. Bu seçenek PHP 5.2.0'dan beri kullanılabilmektedir.
PREG_INTERNAL_ERROR | Dahili bir PCRE hatası oluşmuşsa preg_last_error() işlevi tarafından döndürülür. Bu seçenek PHP 5.2.0'dan beri kullanılabilmektedir.
PREG_BACKTRACK_LIMIT_ERROR | Bu seçenek, geriye doğru izleme sınırına ulaşılmışsa preg_last_error() işlevi tarafından döndürülür. Bu seçenek PHP 5.2.0'dan beri kullanılabilmektedir.
PREG_RECURSION_LIMIT_ERROR | Bu seçenek, iç içelik sınırına ulaşılmışsa preg_last_error() işlevi tarafından döndürülür. Bu seçenek PHP 5.2.0'dan beri kullanılabilmektedir.
PREG_BAD_UTF8_ERROR | Son hata bozuk bir UTF-8 verisinden kaynaklanmışsa bu seçenek preg_last_error() işlevi tarafından döndürülür. (Bu sadece düzenli ifade UTF-8 kipinde çalışıyorsa mümkündür.) Bu seçenek PHP 5.2.0'dan beri kullanılabilmektedir.
PREG_BAD_UTF8_OFFSET_ERROR | Başlangıç, geçerli bir UTF-8 kodun başlangıcı değilse bu seçenek preg_last_error() işlevi tarafından döndürülür. (Bu sadece düzenli ifade UTF-8 kipinde çalışıyorsa mümkündür.) Bu seçenek PHP 5.3.0'dan beri kullanılabilmektedir.
PCRE_VERSION | PCRE sürümü ve dağıtım tarihi ("7.0 18-Dec-2006" gibi). Bu seçenek PHP 5.2.4'ten beri kullanılabilmektedir.
Özkaynak Türleri
Örnekler
Perl Uyumlu Düzenli İfadeler


Örnekler

Örnek 1 - Geçerli şablon örnekleri

  • /<\/\w+>/
  • |(\d{3})-\d+|Sm
  • /^(?i)php[34]/
  • {^\s+(\s+)?$}

Örnek 2 - Geçersiz şablon örnekleri

  • /href='(.*)' - son ayraç eksik
  • /\w+\s*\w+/J - 'J' diye bir değiştirici bilinmiyor
  • 1-\d3-\d3-\d4| - ilk ayraç eksik

Öntanımlı Sabitler
PCRE Şablonları
Perl Uyumlu Düzenli İfadeler


PCRE Şablonları

İçindekiler

  • Şablon Değiştiricileri
  • Perl ile Farklar
  • POSIX regex'ten farklılıklar
  • Şablon Sözdizimi
Örnekler
Şablon Değiştiricileri
Perl Uyumlu Düzenli İfadeler


Düzenli ifadeler için kullanılabilecek değiştiriciler

Mevcut olası PCRE değiştiricileri aşağıda listelenmiştir. Yaylı ayraçlar içinde belirtilen isimler bu değiştiricilerin dahili PCRE isimleridir. Değiştiricilerdeki boşluklar va satırsonu karakterleri yok sayılır, diğer karakterler ise hataya sebep olur.

i (PCRE_CASELESS)
Bu değiştirici etkin olursa şablondaki harfler hem küçük hem de büyük harflerle eşleşir.
m (PCRE_MULTILINE)
PCRE öntanımlı olarak, eşleşmeye konu dizgeyi karakterlerden oluşan tek bir satır olarak ele alır (satırsonu karakter ile bitmese bile). "Satır başlangıcıyla eşleşme işleci" olan ^ karakteri dizgenin başlangıcıyla, "satır sonuyla eşleşme işleci" olan $ karakteri ise dizgenin sonu ile veya (D değiştiricisi belirtilmedikçe) satırı sonlandıran satırsonu karakterinin öncesiyle eşleşir. Bu. Perl'de de böyledir. Bu değiştiricinin etkin olduğu durumda, satır başı ve satır sonu ile eşleşme işleçleri, dizgenin başı ve sonu ile eşleşmenin yanında satırsonu karakterinin (sırasıyla) sonrası ve öncesiyle de eşleşir. Bu değiştirici Perl'in \m değiştiricisine eşdeğerdir. Eğer eşleşmeye konu dizge "satırsonu karakteri "\n" içermiyorsa veya şablonda ^ veya $ işleçleri kullanılmamışsa bu değiştiricinin bir etkisi olmayacaktır.
s (PCRE_DOTALL)
Bu değiştirici etkin olduğunda şablondaki nokta işleci, satırsonu karakteri dahil tüm karakterlerle eşleşir. Etkin olmadığı takdirde satırsonu karakterleri dışlanır. Bu değiştirici Perl'ün \s değiştiricisine eşdeğerdir. [^a] gibi olumsuz bir sınıf, bu değiştiriciden bağımsız olarak daima satırsonu karateriyle eşleşir.
x (PCRE_EXTENDED)
Bu değiştirici etkin olduğunda şablondaki boşluk karakterleri, öncelenmedikçe veya bir karakter sınıfı içinde yer almadıkça tamamen yoksayıldıkları gibi, bir karakter sınıfının dışında öncelenMEmiş bir # ve sonraki satırsonu karakteri arasındaki karakterlerin tamamı ile satırsonu karakteri de yoksayılır. Bu değiştirici Perl'ün \x değiştiricisine eşdeğerdir ve karmaşık şablonların içine açıklamalar konmasını mümkün kılar. Ancak, bunun sadece veri karakterlerine uygulanmakta oluşuna dikkat ediniz. Boşluk karakterleri, bir şablonda özel karakter dizilimlerinin içinde bulunamazlar; örneğin, bir koşullu alt şablon başlatan (?( dizilimi içinde bulunamazlar.
e (PREG_REPLACE_EVAL)
Bu değiştirici etkin olduğunda, preg_replace() işlevi sonuç dizgesini PHP kodu olarak değerlendirerek normal geriye gönderim ikameleri yapar ve sonucu arama dizgesiyle değiştirmek için kullanır. İkameli geriye gönderimlerdeki tek ve çift tırnaklarla tersbölü ve NULL karakterleri tersbölülerle öncelenir.

Bu değiştiriciyi sadece preg_replace() kullanır; diğer PCRE işlevleri bu değiştiriciyi yok sayar.

A (PCRE_ANCHORED)
Bu değiştirici etkin olduğunda, şablon demirlemeye zolanır yani, şablon eşleşmeye konu dizgenin sadece başlangıcı ile eşleşmeye zorlanır. Bu etki, şablonun içindeki oluşumlarla da sağlanabilir ve Perl'de bunu yapmanın başka yolu yoktur.
D (PCRE_DOLLAR_ENDONLY)
Bu değiştirici etkin olduğunda, şablondaki dolar işleci eşleşmeye konu dizgenin sadece sonu ile eşleşir. Bu değiştirici olmaksızın dolar işleci, satır sonlandıran karakter satırsonu karakteri olduğu takdirde sonuncu satır sonu karakterinin (daha öncekilerin değil) hemen öncesi ile eşleşir. m değiştiricisi etkin olduğunda bu değiştirici yok sayılır. Perl'de bu değiştiricinin eşdeğeri yoktur.
S
Bir şablon defalarca eşleştirilmeye çalışılıyorsa, eşleşme için harcanan zamanı kısaltmak için çözümlemeye harcanan zamanı arttırmak en iyi çözümdür. Bu değiştirici etkin olduğunda ek çözümlemeler yapılır. Halihazırda bu sadece, şablonu tek bir başlangıç karakteriyle eşleşmeye zorlayan demirli şablonlar hariçindeki şablonlar için yararlı olmaktadır.
U (PCRE_UNGREEDY)
Bu değiştirici etkin olduğunda, niceleyicilerin tamahkarlığını tersine çevirir. Böylece, ardlarına bir "?" konmadıkça niceleyiciler öntanımlı olarak tamahkar olmazlar. Bu değiştirici Perl ile uyumlu değildir. Ayrıca, değiştirici şablon içinde de (?U ile) etkin kılılınabileceği gibi niceleyicinin ardına bir soru işareti konarak da (.*? gibi) bu sağlanabilir.
X (PCRE_EXTRA)
Bu değiştirici PCRE'nin Perl ile uyumlu olmayan bir işlevselliğini açıp kapamakta kullanılır. Bir şablonda tersbölü ile öncelenmiş bir karakter özel bir anlama sahip değilse hataya sebep olur. Bu davranış, gelecekteki yorumlamalar için böyle tasarlanmıştır. Perl'de öntanımlı olarak, özel anlamı olmayan tersbölü ile öncelenmiş karakterler kendileri olarak ele alınırlar. Bu değiştiriciden etkilenen bir değiştirici henüz yoktur.
J (PCRE_INFO_JCHANGED)
(?J) dahili seçenek ayarı yerel PCRE_DUPNAMES seçeneğini değiştirerek isimlerin alt şablonlarda tekrarlanmasını mümkün kılar.
u (PCRE_UTF8)
Bu değiştirici PCRE'nin Perl ile uyumlu olmayan bir işlevselliğini etkin kılarak şablon dizgelerinin karakter kodlamasının UTF-8 olduğunun varsayılmasını sağlar. Bu değiştirici Unix türevlerinde PHP 4.1.0'dan beri, win32'de PHP 4.2.3'ten beri kullanılabilmektedir. Şablonun UTF-8 olarak geçerliliği ise PHP 4.3.5 sürümünden beri denetlenmektedir.

PCRE Şablonları
Perl ile Farklar
PCRE Şablonları


Perl'e göre farklılıklar

PCRE'nin Perl'in 5.005 sürümüne göre farkları burada açıklanmıştır.

  1. PCRE'yi başka bir karakter türü tablosu ile derlemek mümkünse de bir boşluk karakteri, öntanımlı olarak, C kütüphanesinin isspace() işlevi ile tanınan bir karakterdir. Normalde isspace() işlevinin eşleştiği boşluk karakterleri, boşluk, sayfa ileri, satırsonu, satırbaşı yatay ve düşey sekme karakterleridir. Perl 5'te düşey sekme karakteri artık boşluk karakterlerinden biri olarak ele alınmamaktadır. \v özel karakteri Perl belgelerinde uzun zamandır yer almamaktadır. Yine de, 5.002 sürümüne kadar boşluk karakterlerinden biri olarak ele alınmaktaydı. 5.004 ve 5.005'te \s ile eşleşmemektedir.
  2. PCRE ileriye bakan savlarda yineleyicilere izin vermez. Perl buna izin verirse de bunu sizin düşündüğünüz tarzda ele almaz. Örneğin, (?!a){3} şablonu, sonraki üç karakterin "a" olmayacağını değil, sonraki "a"'nın üç kere yinelenmeyeceğini iddia eder.
  3. İleriye bakan savların içinde yer alan numaralı alt şablonlar sayılır fakat başlangıç yöneylerindeki girdileri hiçbir zaman ektin kılınmaz. Perl, savın başarısız olmasından önce eşleşen böyle şablonlardaki sayısal değişkenleri sadece ileriye bakan olumsuz bir sav tek bir dal oluşturuyorsa atar.
  4. İkil sıfır karakterleri eşleşmeye konu dizgede destekleniyorsa da normalde C dizgelerini sonlandırdıklarından şablonlar içinde bulunmalarına izin verilmez. Bir şablon içinde ikil sıfırı belirtmek için "\x00" dizilimi kullanılabilir.
  5. \l, \u, \L, \U Perl öncelemleri desteklenmemektedir. Aslında bunlar Perl'in genel dizge işlemleri altında gerçeklenmiş olup şablon eşleme motorunun parçaları değildirler.
  6. Perl'de \G savı, tekil şablon eşleşmeleri ile ilgili olmadığından desteklenmemektedir.
  7. Oldukça açıktır ki, PCRE (?{kod}) ve (??{kod}) oluşumlarını desteklemez. Ancak şablonlar içi içe olduğunda desteklenir.
  8. Numaralı alt dizgelerin şablonun yinelenen parçaları olduğu durumda Perl 5.005_02'den kaynaklanan bazı tuhaflıklar söz konusunudr. Örneğin, /^(a(b)?)+$/ şablonu "aba" dizgesiyle eşleşirken "b" değerine $2 atanır. Fakat, /^(aa(bb)?)+$/ şablonu "aabbaa" dizgesiyle eşleşirken $2'ye hiçbir şey atanmaz. Ancak, şablon, /^(aa(b(b))?)+$/ olarak yazılırsa $2 (ve $3) değişkenlerine değer atanır. Perl 5.004'te $2 her iki durumda da atanmaktadır. Eğer Perl, gelecekte bu tutarlı durumda bir değişiklik yapacak olursa PCRE de bu değişikliğe uyum sağlayacaktır.
  9. Perl 5.005_02'deki henüz çözümlenmemiş başka bir tutarsızlık da, PCRE'nin tersine /^(a)?(?(1)a|b)+$/ şablonunun "a" dizgesiyle eşleşmesidir. Bununla birlikte gerek Perl gerekse PCRE, /^(a)?a/ şablonunu "a" ile eşleştirirken $2 değişkenine hiçbir şey atamazlar.

  10. PCRE'nin Perl düzenli ifade oluşumlarına ek olarak bazı oluşumları vardır:

    1. Geriye bakan savların sabit uzunlukta dizgelerle eşleşmesi gerektiği halde, geriye bakan savın içerdiği her olasılık farklı uzunluktaki bir dizgeyle eşleşebilir. Perl 5.005'te her iki durumda da uzunlukların eşit olması gerekir.
    2. Eğer PCRE_DOLLAR_ENDONLY seçeneği etkinken PCRE_MULTILINE etkin değilse $ işleci sadece dizgenin en sonu ile eşleşir.
    3. Eğer PCRE_EXTRA etkinse tersbölü ile öncelenmiş karakterlerden özel anlamı olmayanlar hataya sebep olur.
    4. Eğer PCRE_UNGREEDY etkinse yineleyicilerin tamahkarlığı ters çevrilir, yani, yineleyicinin ardına bir "?" imi konmadıkça yineleyiciler öntanımlı olarak tamahkarlık göstermezler.

Şablon Değiştiricileri
POSIX regex'ten farklılıklar
PCRE Şablonları


POSIX regex'ten farklılıklar

PHP 5.3.0'dan itibaren POSIX Regex eklentisinin kullanımı önerilmemektedir.POSIX regex ile PCRE regex arasında bazı farklar vardır. Bu sayada, PCRE'ye geçerken size gerekli olacak en belirgin farklar listelenmiştir.

  1. PCRE işlevleri şablonların ayırıcılar arasına alınmasını gerektirir.
  2. POSIX'in tersine, PCRE eklentisi harf büyüklüğüne duyarsız eşleşmeye adanmış işlevlere sahip değildir. Bunun yerine /i şablon değiştiricisi. kullanılır. Eşleşme stratejisini değiştirmek için kullanılabilecek başka değiştiriciler de vardır.
  3. POSIX işlevleri en soldaki en uzun eşleşmeyi bulurken PCRE ilk geçerli eşleşmede durur. Eğer dizgenin tamamı eşleşmiyorsa bir fark ortaya çıkmaz ama eşleşme durumunda eşleşme hızı ve sonuçlar bakımından kayda değer farklar söz konusudur. Bu farkları görebilmek için Jeffrey Friedl'ın "Mastering Regular Expressions" adlı eserinden alımış örneğe bakalım. oneselfsufficient dizgesinde one(self)? (selfsufficient)? şablonunun PCRE ile kullanırsak eşleşme sonucu oneself olacaktır. POSIX ile kullanıldığında ise, sonuç dizgenin tamamı, yani oneselfsufficient olacaktır. Her iki sonuç da özgün dizge ile eşleşmesine rağmen POSIX en uzun eşleşmeyi gerektirir.

İşlevlerdeki farklar
POSIX | PCRE
ereg_replace() | preg_replace()
ereg() | preg_match()
eregi_replace() | preg_replace()
eregi() | preg_match()
split() | preg_split()
spliti() | preg_split()
sql_regcase() | No equivalent

Perl ile Farklar
Şablon Sözdizimi
PCRE Şablonları


PCRE düzenli ifade sözdizimi

İçindekiler

  • Giriş
  • Ayırıcılar
  • Düzenli ifade İşleçleri
  • Tersbölü
  • Evrenkodlu Karakterlerin Özellikleri
  • Şapka ve Dolar İmi
  • Nokta
  • Köşeli Ayraçlar
  • Boru Karakteri
  • Dahili Seçeneklerin Ayarlanması
  • Alt Şablonlar
  • Yineleme
  • Geriye Gönderimler
  • Tezler
  • Sadece bir kerelik alt şablonlar
  • Koşullu alt şablonlar
  • Açıklamalar
  • İç içe şablonlar
  • Başarım
POSIX regex'ten farklılıklar
Giriş
PCRE Şablonları


Giriş

PCRE tarafından desteklenen düzenli ifadelerin sözdizimi ve anlamları aşağıda açıklanmıştır. Düzenli ifadeler ayrıca Perl belgelerinde ve pek çok kitapta bol sayıda örneklerle açıklanmıştır. O'Reilly tarafından yayınlanan Friedl'ın "Mastering Regular Expressions" kitabı (ISBN 1-56592-257-3) oldukça ayrıntılıdır. Buradaki açıklamalar bir başvuru kılavuzu niteliğindedir.

Bir düzenli ifade eşleştirileceği dizgeye soldan sağa uygulanan bir şablondur. Çoğu karakter bir şablonun içinde sadece kendilerini ifade ederler ve şablonun eşleştirildiği dizgedeki karşılıkları ile eşleşirler. Önemsiz bir örnek olarak The quick brown fox şablonu kendisiyle aynı olan dizgeyle eşleşecektir.

Şablon Sözdizimi
Ayırıcılar
Şablon Sözdizimi


Ayırıcılar

PCRE işlevlerini kullanırken şablonların ayırıcılar arasına alınması gerekir. Ayırıcılar tersbölü imi ve boşluk karakterleri hariç herhangi bir abecesayısal karakter olabilir.

Sıkça kullanılan ayırıcılar şunlardır: Bölü çizgisi (/), diyez imi (#) yaklaşık imi (~). Aşağıda, şablonlarda ayırıcı kullanımı ile örneklere yer verilmiştir.

/foo bar/
#^[^0-9]$#
+php+
%[a-zA-Z0-9_-]%

Bir ayırıcının bir şablon içinde kendisiyle eşleşmesi gerekiyorsa önüne bir tersbölü imi konmalıdır. Eğer ayırıcı şablon içinde çok sık kullanılıyorsa başka bir ayırıcı seçmek okunabilirlik açısından daha iyidir.

/http:\/\//
#http://#
Bir dizgeyi bir şablon içine yerleştirmek için preg_quote() işlevi kullanılabilir ve işlevin ikinci değiştirgesinde tersbölü ile öncelenecek ayırıcı belirtilebilir.

Şimdiye kadar bahsedilen ayırıcılara ek olarak ayraç tarzı ayırıcılar da kullanmak mümkündür. Aşağıdaki örnekteki gibi, şablon kaşlı ayraçlar arasına da alınabilir.

{this is a pattern}

Şablonu sonalndıran ayırıcının ardına bir şablon değiştircisi eklemek de mümkündür. Aşağıda, harf büyüklüğüne duyarsız eşleşmeyle ilgili bir örnek vardır:

#[a-z]#i

Giriş
Düzenli ifade İşleçleri
Şablon Sözdizimi


Düzenli ifade İşleçleri

Düzenli ifadelerin gücü, şablon içinde yinelemeler ve ikameler içerme yeteneğinden kaynaklanır. Bunlar şablon içinde düzenli ifade işleçleri adı verilen ve özel bir şekilde yorumlanan ancak doğrudan kendileriyle eşleşmeyen karakterlerle kodlanırlar.

İki ayrı işleç ailesi vardır: Köşeli ayraçların içindekiler ve dışındakiler. Köşeli ayraçların dışındaki işleçler şunlardır:

\
çeşitli kullanımları olan genel önceleme karakteri
^
konu başlangıcıyla eşleşme işleci (satır kipinde veya çok satırlı kipte)
$
konu sonuyla eşleşme işleci (satır kipinde veya çok satırlı kipte)
.
(öntanımlı olarak) satırsonu hariç herhangi bir karakterle eşleşme işleci
[
Karakter sınıfı tanımı başlatma işleci
]
Karakter sınıfı tanımı bitirme işleci
|
VEYA işleci
(
alt şablon başlatma işleci
)
alt şablon bitirme işleci
?
"(" işlecinin anlamını genişletir; 0 veya 1 kere eşleşir, ayrıca tamahkarlığa son verilir. (bkz. Yineleme)
*
0 veya daha fazlasıyla eşleşme işleci
+
1 veya daha fazlasıyla eşleşme işleci
{
Yineleme başlatma işleci
}
Yineleme bitirme işleci
Köşeli ayraçların içinde kalan kısım "karakter sınıfı" adını alır. Bir karakter sınıfı içinde özel anlamı olan işleçler şunlardır:
\
genel önceleme karakteri
^
sınıfın ilk karakteri olduğu takdirde sınıfla eşleşmeme işleci
-
karakter aralığı işleci
]
karakter sınıfı bitirme işleci
Aşağıdaki bölümlerde bu işleçler ayrı ayrı açıklanmıştır.

Ayırıcılar
Tersbölü
Şablon Sözdizimi


Tersbölü

Tersbölü karakterinin çeşitli kullanımları vardır. Tersbölünün ilk kullanım çeşidinde, bir harfin veya bir rakamın soluna konmuşsa karakterin özel anlamını kaldırır; karakter sınıflarının içinde ve dışında bir önceleme karakteri olarak iş görür.

Örneğin, şablonunuzun "*" karakteri ile eşleşmesini isterseniz, şablonu "\*" biçiminde yazmalısınız. Tersbölü karakterinin öncelediği karakter bir düzenli ifade işleci olsun ya da olmasın yorumu değişmeyecek, daima öncelediği karakter kendisiyle eşleşecektir. Sonuç olarak, önceleme işleci harf veya rakam olmayan karakterlerle de güvenle kullanılabilmektedir. Özellikle, bir tersbölü karakteri ile eşleşme sağlamak için "\\" yazmalısınız.

Bilginize:

Tek ve çift tırnaklı PHP dizgeleri içinde tersbölü karakteri özel olarak ele alınır. Bir \ ile eşleşen \\ düzenli ifadesi, PHP kodu içinde "\\\\" veya '\\\\' olarak belirtilmelidir.

Bir şablon PCRE_EXTENDED seçeneği ile derlenmişse kalıp içindeki (bir karakter sınıfının dışında kalan) boşluk karakterleri ve bir karakter sınıfının dışındaki bir "#" karakteri ile sonraki satırsonu karakteri arasındaki karakterler yok sayılır. Bir boşluk veya "#" karakterini şablonun parçası haline getirmek için, karakter tersbölü ile öncelenir.

Tersbölü karakterinin ikinci kullanımı, basılamayan karakterleri şablon içinde görünür kılmak içindir. İkil sıfırın şablonu sonlandırması dışında basılamayan karakterlerin görünümü ile ilgili bir kısıtlama yoktur. Fakat, bir şablon, bir metni düzenleyerek hazırlanıyorsa aşağıdaki önceleme dizilimlerini kullanmak, ifade ettikleri ikil karakterleri kullanmaktan daha kolaydır:

\a
sesli uyarı, yani BEL karakteri (onaltılık 07)
\cx
"CTRL-x"; buradaki x yerine herhangi bir karakter konabilir
\e
kaçış karakteri (onaltılık 1B)
\f
sayfa ileri (onaltılık 0C)
\n
satırsonu (onaltılık 0A)
\p{xx}
xx özellikli bir karakter, daha fazla bilgi için bkz. unicode özellikleri.
\P{xx}
xx özelliksiz bir karakter, daha fazla bilgi için bkz. unicode özellikleri.
\r
satırbaşı (onaltılık 0D)
\t
sekme (onaltılık 09)
\xhh
onaltılık kodu hh olan karakter, daha fazla bilgi için bkz. unicode özellikleri.
\ddd
sekizlik kodu ddd olan karakter veya bir geriye gönderim

"\cx" diziliminin en hassas etkisi şöyledir: "x" bir küçük harf ise büyük harfe dönüştürülür ve karakterin 6. biti (onaltılık 40) evrilir. Böylece, "\cz" dizilimi onaltılık 1A haline gelirken "\c{" onaltılık 3B ve "\c;" onaltılık 7B haline gelir.

"\x" dizilimden sonra en fazla iki onaltılık rakam okunur (harfler büyük veya küçük olabilir). UTF-8 kipinde, "\x{...}" gösterimine izin verilir; kaşlı ayraçların arasına yazılan onaltılık sayı UTF-8 karakterin kodu olarak yorumlanır. Özgün onaltılık önceleme dizilimi \xhh, eğer karakterin kodu 127'den büyükse iki baytlık bir UTF-8 karakteri ile eşleşecektir.

"\0" dizilimden sonra en fazla iki sekizlik rakam okunur. Her iki durumda da, iki rakamdan azı varsa olanlar kullanılır. Böylece, "\0\x\07" dizilimi iki ikil sıfırdan sonra bir BEL karakteri olarak yorumlanır. Eğer sekizlik gösterimin hemen ardından sekizlik rakam olarak yorumlanabilecek bir karakter geliyorsa ilk sıfırdan sonra mutlaka iki sekizlik rakam kullanın.

Tersbölünün hemen ardından 0 haricinde bir rakam gelmesi durumunda durum biraz karışır. Bir karakter sınıfının dışında, PCRE o rakamı ve diğer rakamları bir onluk sayı olarak okur. Eğer sayı 10'dan küçükse veya evvelce belirtilmiş yakalayan alt şablonlar varsa dizilimin tamamı bir geriye gönderim olarak ele alınır. İkinci durumun nasıl çalıştığı aşağıda parantezli alt şablonların açıklamasında anlatılmıştır.

Bir karakter sınıfının içinde veya evvelinde yakalayan alt şablonlar bulunmayan 9'dan büyük bir onluk sayı varlığında PCRE tersbölüden sonra en fazla üç sekizlik rakam okur ve değerin en önemsiz 8 bitinden tek bir bayt üretir. Daha sonraki rakamlar karakterlerin kendileri olarak ele alınır. Örnekler:

\040
Boşluk karakterini ifade etmenin bir başka yolu.
\40
40'tan az yakalayan alt şablon varlığında bu da aynısı.
\7
Daima geriye gönderim olarak yorumlanır.
\11
Duruma göre, bir geriye gönderim olabileceği gibi sekme karakteri olarak da yorumlanabilir.
\011
Daima bir sekme karakteridir
\0113
Sekme karakterinden sonra "3" var.
\113
Sekizlik kodu 113 olan karakter (99'dan fazla geriye gönderim olamayacağı için).
\377
Tamamı 1 bitten oluşan bir bayt.
\81
Duruma göre, bir geriye gönderim olabileceği gibi ikil sıfırın ardından gelen "8" ve "1" karakterleri de olabilir.

100'den büyük sekizlik değerlerin başına sıfır konmamalıdır, çünkü üç sekizlik rakamdan fazlası sekizlik sayının rakamları olarak ele alınmamaktadır.

Tek bir bayt değerini tanımlayan tüm dizilimler karakter sınıflarının içinde de dışında da kullanılabilir. Ek olarak, bir karakter sınıfının içinde, "\b" dizilimi bir tersbölü karakteri (onaltılık 08) olarak yorumlanır. Karakter sınıfının dışında ise anlamı farklıdır (aşağıya bakınız).

Tersbölünün üçüncü kullanımı soysal karakter türlerini belirtmek içindir:

\d
Herhangi bir onluk rakam
\D
Bir onluk rakam olmayan herhangi bir karakter
\h
Herhangi bir yatay boşluk karakteri (PHP 5.2.4'ten beri)
\H
Bir yatay boşluk karakteri olmayan herhangi bir karakter (PHP 5.2.4'ten beri)
\s
Herhangi bir boşluk karakteri
\S
Bir boşluk karakteri olmayan herhangi bir karakter
\v
Herhangi bir düşey boşluk karakteri (PHP 5.2.4'ten beri)
\V
Bir düşey boşluk karakteri olmayan herhangi bir karakter (PHP 5.2.4'ten beri)
\w
Herhangi bir "sözcük" karakteri
\W
Bir "sözcük" karakteri olmayan herhangi bir karakter

Her önceleme dizilimi çifti karakter kümesinin tamamını iki ayrı küme haline getirir. Belirtilen her karakter sadece ve sadece bir çift ile eşleşir.

Bir "sözcük" karakteri herhangi bir harf, rakam veya alt çizgi karakteri olabilir, yani, bir Perl sözcüğünün parçası olabilen her karakter bir "sözcük" karakteri olabilir. Harflerin ve rakamların tanımı PCRE'nin karakter tablosu tarafından denetlenir ve eşleştirme yerele özgü yapılıyorsa bu tanım değişebilir. Örneğin "tr" yerelindeki 128'den büyük karakter koduna sahip "çğıöşü" gibi karakterler \w ile eşleşir.

Karakter türündeki bu dizilimler karakter sınıflarının içinde veya dışında bulunabilir. Her biri uygun türdeki bir karakterle eşleşir. Eğer karakter eşleştirmesinde eşleşmeye konu dizgenin sonuna gelinmişse hiçbir karakter eşleşmeyeceğinden işlem başarısız olacaktır.

Tersbölünün dördüncü kullanımı bazı basit tezleri belirtmek içindir. Bir tez, eşleşmeye konu dizgenin hiçbir karakterini harcamaksızın belli bir noktada yerine getirilmesi gereken bir koşul belirtir. Daha karmaşık tezler için alt şablonların kullanımı aşağıda açıklanmıştır. Tez işleçleri şunlardır:

\b
Sözcük sınırlarıyla eşleşme işleci
\B
Sözcük içi eşleşme işleci
\A
Eşleşmeye konu dizgenin başlangıcı ile eşleşme işleci (çok satırlı kipten bağımsız)
\Z
Eşleşmeye konu dizgedeki satırsonu karakterinin öncesiyle eşleşme işleci (çok satırlı kipten bağımsız)
\z
Eşleşmeye konu dizgenin sonu ile eşleşme işleci (çok satırlı kipten bağımsız)
\G
eşleşmeye konu dizgede eşleşme başlangıcını belirtme işleci

Bu tez işleçleri "\b" hariç karakter sınıfları içinde görünmezler. "\b" işleci karakter sınıfları içinde özel bir anlama sahiptir ve tersbölü karaterini simgeler.

Eşleşmeye konu dizge içinde geçerli karakterin \w işleci ile ve önceki karakterin \W işleci ile eşleştiği nokta sözcük sınırının başlangıcını; geçerli karakterin \W işleci ile ve önceki karakterin \w işleci ile eşleştiği nokta ise sözcük sınırının bitişini belirler.

\A, \Z ve \z tez işleçleri, seçeneklerle belirlenen şekilde dizgenin en başı ve dizgenin en sonu ile eşleşen geleneksel şapka ve dolar imli işleçlerden (aşağıda açıklanmıştır) farklı olup PCRE_MULTILINE veya PCRE_DOLLAR_ENDONLY seçeneğinden etkilenmezler. \Z ile \z arasındaki fark \Z işlecinin dizgenin son karakteri olan satırsonu karakterinin öncesiyle eşleşmesi, \z işlecinin ise sadece dizge sonu ile eşleşmesidir.

\G savı, sadece, geçerli eşleşme konumu eşleşmenin başlangıç noktasında (preg_match() işlevinin başlangıç değiştirgesi ile belirtilen noktada) olduğu takdirde doğru olacaktır. başlangıç sıfırdan farklı olduğu durumda \G işleci \A işlecinden farklıdır. PHP'nin 4.3.3 sürümünden beri kullanılabilmektedir.

PHP 4.3.3'ten beri, \Q ve \E işleçleri şablon içindeki düzenli ifade işleçlerini geçersiz kılmak için kullanılabilmektedir. Örneğin, \w+\Q.$.\E$ düzenli ifadesi dizge sonuna demirlenmiş .$. karakterleriyle ve bunların öncesindeki bir veya daha fazla sayıda sözcük karakteriyle eşleşecektir.

\K işleci PHP'nin 5.2.4 sürümünden beri eşleşme başlangıcını sıfırlamak için kullanılabilmektedir. Örneğin, foo\Kbar şablonu, "foobar" ile eşleşir, fakat "bar" ile eşleştiğini raporlar. \K işlecinin kullanımı zaten eşleştirilmiş alt dizge ile etkileşmez. Örneğin, (foo)\Kbar şablonu "foobar" ile eşleşirken eşleşen ilk alt dizge "foo" olacaktır.

Düzenli ifade İşleçleri
Evrenkodlu Karakterlerin Özellikleri
Şablon Sözdizimi


Evrenkodlu Karakterlerin Özellikleri

PHP 4.4.0 ve 5.1.0 sürümlerinde, UTF-8 kipi seçildiğinde soysal karakter türleriyle eşleşen üç düzenli ifade işleci daha devreye girmiştir. Bunlar:

\p{xx}
xx özelliğine sahip bir karakter
\P{xx}
xx özelliği olmayan bir karakter
\X
bir genişletilmiş Evrenkod dizilimi

Yukarıda xx ile belirtilen özellik isimleri Evrenkod genel sınıf özellikleriyle sınırlıdır. Belirtilen her karakter, belli bir özelliğin iki harflik kısaltmasındaki harflerle aynı olmak zorundadır. Perl ile uyumluluk için, olumsuzlama işleci kaşlı ayraç ile özellik kısaltmasının ilk harfi arasına konmalıdır. Örneğin, \p{^Lu} şablonu \P{Lu} ile aynıdır.

Eğer \p veya \P ile tek bir harf belirtilirse bu harfle başlayan tüm özellikleri ifade edecektir. Böyle bir durumda, olumsuzlama işleci kullanılmayacaksa kaşlı ayraçların kullanımı isteğe bağlıdır. Yani, bu iki örnek aynı etkiye sahiptir:

      \p{L}
      \pL

Desteklenen özellik kodları
Özellik | Eşleşmeler | Açıklamalar
C | Diğer |
Cc | Denetim |
Cf | Biçem |
Cn | Atanmamış |
Co | Özel kullanım |
Cs | İkame |
L | Harf | Şu özellikleri içerir: Ll, Lm, Lo, Lt ve Lu.
Ll | Küçük harf |
Lm | Değiştirici harf |
Lo | Diğer harf |
Lt | Başlık harfi |
Lu | Büyük harf |
M | İm |
Mc | Boşluk imi |
Me | Kapsama imi |
Mn | Boşluk bırakmama imi |
N | Sayı |
Nd | Onluk sayı |
Nl | Harf numarası |
No | Diğer sayı |
P | Noktalama |
Pc | Bağlayıcı noktalama |
Pd | Tire imi |
Pe | Kapama imi |
Pf | Sonlandırma imi |
Pi | Başlatma imi |
Po | Diğer noktalama |
Ps | Açma imi |
S | Simge |
Sc | Para simgesi |
Sk | Değiştirici simge
Sm | Matematiksel simge |
So | Diğer simge |
Z | Ayraç |
Zl | Satır ayracı |
Zp | Paragraf ayracı |
Zs | Boşluk ayracı |

"Greek" veya "InMusicalSymbols" gibi ek özellikler PCRE tarafından desteklenmemektedir.

Harf büyüklüğüne duyarsız eşleşme belirtilmesi bu önceleme dizilimlerini etkilemez. Örneğin, \p{Lu} şablonu daima sadece büyük harflerle eşleşecektir.

\X işleci, bir ek Evrenkod dizilimi biçimindeki herhangi bir Evrenkod karakteri ile eşleşir. \X işleci (?>\PM\pM*) şablonuna eşdeğerdir.

Yani, bir im olmayan karakteri izleyen sıfır veya daha fazla sayıda im karakteri ile eşleşir ve bu dizilim bir atomik grup olarak ele alınır (aşağıya bakın). İm karaterleri genellikle kendilerinden önceki karakterleri etkileyen aksanlardır.

Evrenkodlu karakterlerle eşleşme hızlı değildir, çünkü PCRE on beş binden fazla karakter içeren bir kümeyi araştırmak zorundadır. \d ve \w gibi geleneksel işleçlerin PCRE'de Evrenkod özelliklerini kullanmamasının sebebi budur.

Tersbölü
Şapka ve Dolar İmi
Şablon Sözdizimi


Şapka ve Dolar İmi

Bir karakter sınıfının dışında, öntanımlı eşleşme kipinde, şapka imi (^), eğer geçerli eşleşme noktası eşleşmeye konu dizgenin başlangıcındaysa doğru sonuç veren bir savdır. Bir karakter sınıfının içinde ise tamamen farklı bir anlama sahiptir (aşağıya bakın).

Şapka imi (^), eğer şablon olasılıklar içeriyorsa şablonun ilk karakteri olmak zorunda değildir, fakat eşleşmenin istendiği her olasılığın ilk karakteri olmak zorundadır. Eğer tüm olasılıklar bir şapka imi (^) ile başlıyorsa, yani şablon eşleşmeye konu dizgenin daima başlangıcıyla eşleştirilmeye çalışılıyorsa buna, dizge başlangıcına demirlenmiş şablon denir. (Bir şablonun demirlenmesine sebep olan başka oluşumlar da olabilir.)

Dolar imi ($), eğer geçerli eşleşme noktası eşleşmeye konu dizgenin sonundaysa veya dizgenin (öntanımlı olarak) son karakteri olan satırsonu karakterinin hemen öncesindeyse doğru sonuç veren bir savdır. Dolar imi ($), eğer şablon olasılıklar içeriyorsa şablonun son karakteri olmak zorunda değildir, fakat eşleşmenin istendiği her olasılığın son karakteri olmak zorundadır. Dolar iminin bir karakter sınıfının içinde özel bir anlamı yoktur.

Derleme veya eşleştirme sırasında PCRE_DOLLAR_ENDONLY seçeneğini etkin kılarak dolar iminin eşleşmeye konu dizgenin daima sonu ile eşleşmesi sağlanacak şekilde anlamı değiştirilebilir. Bu seçeneğin atanmış olması \Z tezinin anlamını etkilemeyecektir.

Şapka ve dolar imlerinin anlamları PCRE_MULTILINE seçeneği (çok satırlı kip) etkin kılınarak değiştirilebilir. Bu durumda, şapka imi eşleşmeye konu dizge içindeki "\n" karakterinin hemen sonrasıyla, dolar imi ise hemen öncesiyle eşleşecektir. Örneğin, aksi belirtilmedikçe, /^abc$/ şablonu çok satırlı kipte "def\nabc" dizgesiyle eşleşecektir. Sonuç olarak, tek satırlık kipte, tüm olasılıkların şapka imi ile başlaması sebebiyle dizge başlangıcına demirlenmiş şablonlar çok satırlı kipte dizge başlangıcına demirlenmiş olmazlar. Eğer PCRE_MULTILINE seçeneği etkinse PCRE_DOLLAR_ENDONLY seçeneği yoksayılır.

\A, \Z ve \z tezlerinin eşleşmeye konu dizgenin başlangıcı ve sonu ile eşleşmek amacıyla her iki kipte de kullanılabileceğine dikkat ediniz. Eğer bir şablondaki tüm olasılıklar \A ile başlıyorsa, PCRE_MULTILINE seçeneği etkin olsun olmasın, şablon daima dizgenin başlangıcına demirlenmiş olacaktır.

Evrenkodlu Karakterlerin Özellikleri
Nokta
Şablon Sözdizimi


Nokta

Bir nokta imi, bir karakter sınıfının dışında, eşleşmeye konu dizge içindeki herhangi bir tek karakterle eşleşecektir; bu karakterlere basılamayan karakterler de dahildir, ancak (öntanımlı olarak) satırsonu karakteri ile eşleşmeyecektir. Eğer PCRE_DOTALL seçeneği etkin kılınmışsa nokta imleri satırsonu karakterleri ile de eşleşecektir. Nokta imi değerlendirilirken şapka ve dolar imlerinden bağımsız olarak ele alınır; tek ilişki her ikisinin de satırsonu karakteriyle olan ilişkileridir. Nokta iminin bir karakter sınıfı içinde özel bir anlamı yoktur.

\C işleci tek bir bayt ile eşleşme için kullanılabilir. Nokta imi UTF-8 kipinde çok baytlı bir karakterin bütün baytları ile eşleşeceğinden tek bir baytla eşleşme isteniyorsa \C işleci önem kazanacaktır.

Şapka ve Dolar İmi
Köşeli Ayraçlar
Şablon Sözdizimi


Köşeli Ayraçlar

Bir karakter sınıfı [ köşeli ayracıyla ] köşeli ayracı arasına alınarak tanımlanır. Bir karakter sınıfı içinde ] köşeli ayracının özel bir anlamı yoktur, ancak bir karakter sınıfı içinde kullanılması gerekliyse sınıfın (varsa, şapka iminden sonraki) ilk üyesi olmak zorundadır, yoksa bir tersbölüyle öncelenmesi gerekir.

Bir karakter sınıfı eşleşmeye konu dizgenin içindeki tek bir karakterle eşleşir; sınıfın ilk üyesi bir şapka imi olmadıkça, eşleşen karakterin karakter sınıfının üyesi olması yeterlidir; aksi takdirde eşleşen karakterin sınıfın bir üyesi olmaması gerekir. Eğer şapka iminin bir karakter sınıfının üyesi olması gerekliyse, ya sınıfın ilk üyesi olmamalı ya da bir tersbölü ile öncelenmelidir.

Örneğin, [aeıioöuü] sınıfı herhangi bir küçük sesli ile eşleşirken [^aeıioöuü] sınıfı herhangi bir küçük sessizle eşleşecektir. Yalnız şuna dikkat edin: Karakter sınıfının başlangıcındaki şapka imi, sadece sınıfı olumsuzlayan bir gösterim uzlaşımıdır. Bir tez işleci değildir; eşleşmeye konu dizge içindeki karakterleri yine de tüketmeye devam eder ve dizgenin sonuna gelindiğinde başarısız olur.

Harf büyüklüğüne duyarsız eşleşme etkinken, sınıf içindeki herhangi bir harf, hem büyük hem de küçük harfi simgeleyecektir. Örneğin, harf büyüklüğüne duyarsız eşleşme etkinken [aeiou] sınıfı "A" veya "a" ile eşleşirken, [^aeiou] sınıfı harf büyüklüğüne duyarlılık etkin kılınmış gibi sadece "A" ile eşleşmeyecektir.

Satırsonu karakteri, PCRE_DOTALL veya PCRE_MULTILINE seçeneği atanmış olsun ya da olmasın karakter sınıfları içinde asla özel bir anlamda ele alınmaz. [^a] gibi bir sınıf daima bir satırsonu karakteri ile eşleşecektir.

Tire imi, bir karakter sınıfı içinde bir aralık belirtmek için kullanılabilir. Örneğin, [d-m] sınıfı, d ve m dahil ikisi arasında kalan herhangi bir karakterle eşleşecektir. Eğer bir tire iminin sınıfın bir üyesi olması gerekliyse, ya bir aralık belirteci olarak değerlendirilmeyeceği bir yere (başa veya sona) konmalı ya da tersbölü ile öncelenmelidir.

Bir "]" karakterinin kendisi olarak bir aralığın son karakteri olması mümkün değildir. Örneğin, [W-]46] şablonu içindeki sınıf "W" ve "-" karakterlerinden oluşacak, dolayısıyla sadece "W46]" veya "-46]" dizgesiyle eşleşecektir. Halbuki, "]" karakteri bir tersbölü ile öncelenseydi, [W-\]46] şablonu içindeki sınıf "W" ve "]" dahil arada kalan tüm karakterlerle eşleşecekti. Sınıf içinde "]" karakterini tersbölü ile öncelemek yerine karakterin sekizlik veya onaltılık gösterimleri de kullanılabilirdi.

Aralıklar ASCII harmanlama dizilimleri olarak çalışabildiği gibi örneğin, [\000-\037] şeklinde sayısal olarak belirtilmiş karakterler içinde kullanılabilir. Eğer harflerden oluşan bir aralık belirtilmişse ve harf büyüklüğüne duyarsız eşleşme yapılıyorsa aralık, içerdiği bir harfin hem büyüğüyle hem de küçüğüyle eşleşecektir. Örneğin [W-c] aralığı harf büyüklüğüne duyarsız olarak [][\^_`wxyzabc] dizgesiyle eşleşir. Eğer "tr" yereli kullanılıyorsa, [\xc6-\xcb] aralığı hem büyük hem de küçük Ç ile eşleşir.

\d, \D, \s, \S, \w ve \W karakter türleri de bir karakter sınıfı içinde kullanılabilir ve sınıfa eşleştikleri karakterleri eklerler. Örneğin, [\dABCDEF] sınıfı herhangi bir onaltılık rakam ile eşleşecektir. Şapka karakteri, küçük harfli işleçlerle sağlanandan daha sınırlı bir kümeyi belirtmek için büyük harfli işleçlerle kullanılabilir. Örneğin, [^\W_] sınıfı alt çizgi imi hariç herhangi bir harf veya rakam ile eşleşecektir.

Bir karakter sınıfının başlangıcında belirtildiğinde \, -, ^ karakterleri ve sonlandırıcı ] karakteri, karakter sınıfı içinde özel bir anlama sahip değildir, ancak öncelenmiş olmaları da bir sorun teşkil etmezdi. Şablon sonlandırıcı daima özeldir ve bir ifade içinde kullanıldığında daima öncelenmesi gerekir.

Perl, karakter sınıfları için POSIX gösterimini destekler. Bu gösterimde sınıf isimleri [: ve :] karakterleri arasına alınır. Örneğin, [01[:alpha:]%] şablonu, "0", "1", herhangi bir abecesel karakter veya "%" ile eşleşecekir. Desteklenen sınıf isimleri şunlardır:

Karakter sınıfları
alnum | harfler ve rakamlar
alpha | sadece harfler
ascii | 0 - 127 arasındaki karakter kodları
blank | sadece boşluk ve sekme karakteri
cntrl | denetim karakterleri
digit | onluk rakamlar (\d ile aynı)
graph | boşluk hariç tüm basılabilen karakterler
lower | küçük harfler
print | boşluk dahil tüm basılabilen karakterler
punct | harfler ve rakamlar hariç tüm basılabilen karakterler
space | tüm boşluk karakterleri (\s ile benzer fakat aynı değil)
upper | büyük harfler
word | "sözcük" karakterleri (\w ile aynı)
xdigit | onaltılık rakamlar
space karakterleri: HT (9), LF (10), VT (11), FF (12), CR (13) ve boşluk (32). Farkedeceğiniz gibi VT karakteri de (kod 11) listeye dahil edilmiştir. Perl uyumluluğu açısından "space" ile \s arasındaki fark budur.

word ismi bir Perl eklemesi olup blank ismi Perl 5.8'deki bir GNU eklemesidir. Diğer bir ekleme de olumsuzlama belirten ^ karakteri olup ikinokta iminden hemen sonra kullanılır. Örneğin, [12[:^digit:]] şablonu "1", "2" veya rakam olmayan herhangi bir karakter ile eşleşir.

UTF-8 kipinde, 128'den büyük değerli karakterler POSIX karakter sınıflarının hiçbiriyle eşleşmeyecektir.

Nokta
Boru Karakteri
Şablon Sözdizimi


Boru Karakteri

Boru karakteri bir şablon içinde olasılıkları ayırmak için kullanılır. Örneğin, Hasan|Hüseyin şablonu hem "Hasan" hem de "Hüseyin" ile eşleşir. Olasılıkların sayısı ile ilgili bir sınırlama yoktur ve boş bir dizge ile eşleşen bir boş olasılık da belirtilebilir. Eşleştirme soldan sağa doğru yapılır ve ilk eşleşen kullanılır. Eğer olasılıklar bir alt şablonun içindeyse (aşağıya bakınız), başarılı bir eşleşme için alt şablonun içindeki olasılıklardan biri ve ana şablonun kalanının eşleşmesi gerekir.

Köşeli Ayraçlar
Dahili Seçeneklerin Ayarlanması
Şablon Sözdizimi


Dahili Seçeneklerin Ayarlanması

PCRE_CASELESS, PCRE_MULTILINE, PCRE_DOTALL, PCRE_UNGREEDY, PCRE_EXTRA, PCRE_EXTENDED ve PCRE_DUPNAMES seçenekleri bir şablonun içinden Perl seçenek harfleri "(?" ve ")" arasında kullanılarak değiştirilebilir. Seçenek harfleri şunlardır:

Dahili seçenek harfleri
i | PCRE_CASELESS için
m | PCRE_MULTILINE için
s | PCRE_DOTALL için
x | PCRE_EXTENDED için
U | PCRE_UNGREEDY için
X | PCRE_EXTRA için
J | PCRE_INFO_JCHANGED için

Örneğin, (?im) dizilimi harf büyüklüğüne duyarsız, çok satırlı eşleşmeyi etkin kılar. Seçenekleri etkisiz hale getirmek için bu harflerin önüne bir tire imi konabilir. Örneğin, (?im-sx) dizilimi, PCRE_CASELESS ve PCRE_MULTILINE seçeneklerini etkin, PCRE_DOTALL ve PCRE_EXTENDED seçeneklerini ise etkisiz kılar. Eğer bir harf tire iminin hem öncesinde hem de sonrasında görünüyorsa onunla ilgili seçenek tanımsız olur.

Üst seviyeden bir seçenek değişikliği varsa (yani değişiklik bir alt şablon içinde değilse), değişiklik şablonun kalanına uygulanacaktır. Bu bakımdan, /ab(?i)c/ şablonu sadece "abc" ve "abC" dizgeleri ile eşleşecektir. Bu işlem PHP 4.3.3 ile dağıtılan PCRE 4.0'dan itibaren bu şekilde uygulanmaktadır. Daha önceki sürümlerde /ab(?i)c/ şablonu /abc/i olarak uygulanırdı (yani, "ABC" ve "aBc" ile eşleşirdi).

Değişiklik bir alt şablonun içinde yapılırsa etkisi farklı olur. Bu davranış Perl 5.005'ten itibaren geçerlidir. Bir alt şablon içindeki seçenek değişiklikleri sadece alt şablonun kalanını etkileyecektir. Bu bakımdan (a(?i)b)c şablonu abc ve aBc dizgelerinden başka bir dizgeyle eşleşmez (PCRE_CASELESS seçeneğinin şablon genelinde kullanılmadığı varsayılıyor). Yani, bir şablonun farklı yerlerinde farklı seçenekler farklı ayarlarla kullanılabilir. Olasılıklardan birinde yapılmış bir seçenek değişikliği sonraki diğer olasılıklar için de geçerli olacaktır. Örneğin, (a(?i)b|c) şablonu "ab", "aB", "c" ve "C" dizgeleriyle eşleşecektir. Bunun sebebi, seçenek ayarlarının etkilerinin derleme sırasında gözönüne alınmasıdır. Yoksa çok tuhaf davranışlar ortaya çıkabilirdi.

Perl uyumlu seçeneklerde olduğu gibi, PCRE'ye özgü seçenekler olan PCRE_UNGREEDY ve PCRE_EXTRA seçenekleri de sırayla U ve X karakterleri ile kullanılarak değiştirilebilir. (?X) ayarı özel bir ayar olup, bir şablonda herhangi bir ek özelliğin etkin kılınmasından önce kullanılmayı gerektirir. Yapılacak en iyi şey en başa koymaktır.

Boru Karakteri
Alt Şablonlar
Şablon Sözdizimi


Alt Şablonlar

Alt şablonlar yaylı ayraçlarla sınırlanır ve iç içe olabilirler. Bir şablonun bir alt parçası iki şekilde kendini gösterir:

1. Bir olasılık kümesinden oluşabilir. Örneğin, gel(enek|incik|) şablonu "gel", "gelenek" ve "gelincik" sözcüklerinden biriyle eşleşecektir. Yaylı ayraçlar olmasaydı "gelenek", "incik" ve boş bir dizge ile eşleşirdi.

2. Şablon grupları olarak görünebilir (aşağıya bakınız). Şablonun tamamı eşleştiğinde, eşleşmeye konu dizgenin alt şablonla eşleşen parçası pcre_exec() işlevinin ovector değiştirgesi üzerinden çağrıcıya aktarılır. Yakalayan alt şablon sayısını tutturmak için grup açılışları soldan sağa doğru sayılır (ilk grup 1 olmak üzere).

Örneğin, "the red king" dizgesini the ((red|white) (king|queen)) şablonuyla eşleştirmek istersek "red king", "red" ve "king" dizgeleri 1, 2 ve 3 olarak numaralanacaktır.

Aslında, salt yaylı ayraçları kullanarak bu iki işlevi yerine getirmek her zaman yararlı olmaz. Çoğu zaman bir gruplama alt şablonu bir yakalama gereksinimi olmaksızın kullanılır. Eğer açan yaylı ayracı takiben bir "?:" dizilimi varsa bu alt şablon herhangi bir yakalama yapmaz ve ardından gelen diğer yakalayan alt şablonların sayısında hesaba katılmaz. Örneğin, "the white queen" dizgesini the ((?:red|white) (king|queen)) şablonu ile eşleştirmek istersek "white queen" ve "queen" alt dizgeleri 1 ve 2 olarak numaralanır. Yakalayan alt şablonların azami sayısı 99, yakalayan ve yakalamayan alt şablonların azami sayısı ise 200'dür.

Uygun bir kısaltma olarak, yakalamayan bir alt şablonun başlangıcında bir seçenek ayarı gerekliyse seçenek harfleri "?" ile ":" arasına konabilir. Dolayısıyla,

       (?i:saturday|sunday)
       (?:(?i)saturday|sunday)

şablonlarının ikisi de aynı dizgeyle eşleşecektir. Olasılıklar soldan sağa değerlendirildiğinden ve seçenekler alt şablonun sonuna ulaşılıncaya kadar sıfırlanmayacağından tek bir olasılık dahilindeki bir seçenek ayarı sonraki olasılıkları da etkileyecektir, dolayısıyla yukarıdaki şablonlar "Saturday" ve hatta "SUNDAY" ile de eşleşecektir.

PHP 4.3.3'ten beri bir alt şablonu (?P<ad>şablon) ile isimlendirmek mümkündür. Eşleşmeleri içeren dizi, numaralarına göre indislenmiş eşleşmelerin yanısıra dizgelerine göre indislenmiş eşleşmeleri de içerecektir.

Dahili Seçeneklerin Ayarlanması
Yineleme
Şablon Sözdizimi


Yineleme

Yineleme, aşağıdaki öğeleri takibeden niceleyicilerle belirtilir:

  • Tek bir karakter; öncelenmiş olabilir.
  • Bir işleç olarak nokta.
  • Bir karakter sınıfı.
  • Bir geriye gönderim (sonraki bölüme bakınız).
  • Ayraçlı bir alt şablon (bir sav ileri sürmedikçe; aşağıya bakınız).

Genel yineleme niceleyicileri, kaşlı ayraçlar arasına alınıp virgülle ayrılmış olarak asgari ve azami miktarda eşleşme belirirler. Belirtilen sayılar 65536'dan küçük olmalı ve ilk sayı ikincisine eşit veya ondan küçük olmalıdır. Örneğin, z{2,4} şablonu "zz", "zzz" veya "zzzz" ile eşleşecektir. Kapatan kaşlı ayraç özel bir karakter değil, kendisidir. Eğer virgül konduğu halde ikinci niceleyici verilmezse bir üst sınır olmayacaktır. Eğer ikinci niceleyici virgülsüz olarak belirtilmemişse, tam olarak belirtilen sayıda eşleşme sağlanmaya çalışılır. Dolayısıyla, [aeiou]{3,} şablonu en az üç sesli harfle eşleşecektir. Ancak, \d{8} şablonu tam olarak 8 rakamla eşleşecektir. Şayet birinci niceleyici belirtilmezse veya kaşlı ayraçtan sonraki karakter bir rakam değilse kaşlı ayraç sadece kendisiyle eşleşir. Örneğin, {,6} şablonu bir yineleyici değil, dört karakterden oluşan sıradan bir dizgedir.

Bir yineleyici olarak {0} şablonuna izin verilir ve ifadenin, önceki öğe ve niceleyici hiç yokmuş gibi davranmasına sebep olur.

Geriye uyumluluk adına, üç yineleyici türünün tek karakterlik kısaltmalarına izin verilmektedir:

Tek karakterlik yineleyiciler
* | {0,} yineleyicisine eşdeğerdir.
+ | {1,} yineleyicisine eşdeğerdir.
? | {0,1} yineleyicisine eşdeğerdir.

Hiçbir karakterle eşleşmeyen bir alt şablonu takibeden üst sınırsız bir yineleyici belirterek sonsuz döngü oluşturmak mümkündür. Örnek: (a?)*

Perl ve PCRE'nin önceki sürümleri böyle şablonların derlenmesi sırasında hata verirdi. Ancak, bu şablonlar bazen yararlı olabildiklerinden artık kabul edilmektedir, fakat hiçbir karakterle eşleşmeme durumunda döngü bilinçli olarak kırılmaktadır.

Yineleyiciler öntanımlı olarak "tamahkar" olurlar. Yani, şablonun geri kalanının başarısız olmasına sebep olmaksızın olabildiğince çok (azami niceleyicisinin izin verdiği ölçüde) eşleşme yapmaya çalışır. Klasik bir örnek olarak, C kodları arasındaki açıklamalarla eşleşme sorunları verilebilir. Bu açıklamalar /* ve */ dizilimleri arasında bulunurlar ve içlerinde birbirlerinden bağımsız olarak / ve * karakterleri bulunabilir. Örneğin, /\*.*\*/ şablonu /* birinci açıklama */ bu açıklama değil /* ikinci açıklama */ dizgesiyle eşleştirilmeye çalışıldığında başarısız olunacaktır. Çünkü .* öğesinin tamahkarlığı yüzünden dizgenin tamamı ile eşleşecektir.

Bununla birlikte, bir yineleyicinin ardına bir soru imi konursa, tamahkarlığa son verilmiş olur ve olası en az sayıda eşleşme yapılmaya çalışılır. Dolayısıyla, /\*.*?\*/ şablonu C açıklamaları ile beklendiği gibi eşleşir. Yineleyiciler, anlamları değiştirilmediği sürece sadece tercih edilen sayıda eşleşme yapacaktır. Soru imini, bir yineleyici olarak kendisinin sonrasına koymaktan çekinmeyin. İki çeşit kullanımı olduğundan bazen \d??\d örneğindeki gibi bir soru imi çifti olarak görünür ve tercihan tek bir rakamla eşleşirse de şablonun kalanının eşleşmesi için başka çare yoksa iki rakamla da eşleşir.

PCRE_UNGREEDY seçeneği (Perl'de bulunmayan bir seçenektir) etkinse yineleyiciler öntanımlı olarak tamahkar olmazlar, fakat bir yineleyiciyi takibeden bir soru imi varsa o yineleyici tamahkarlık gösterebilir. Başka bir deyişle, bu seçenek öntanımlı davranışı tersine çevirir.

+ imi yineleyicilerin ardına konduğunda yineleyiciyi bencilleştirir. Yani, şablonun kalanının başarısızlığı pahasına olabildiğince çok eşleşme yapmaya çalışır. Bu bakımdan, örneğin, .*abc şablonu "aabc" ile eşleştiği halde .*+abc şablonu eşleşmeyecektir. Çünkü .*+ dizgenin tamamını yiyecektir. Bencil yineleyiciler işlemi hızlandırmak için PHP 4.3.3'ten beri kullanılabilmektedir.

Bir yaylı ayraçlı alt şablon, 1'den büyük bir asgari ve sınırlı bir azami yineleme değeriyle nicelendiğinde derlenmiş şablon için asgari ve azami değerlerin büyüklüklerine bağlı olarak daha fazla alan gerekir.

Eğer bir şablon, .* veya .{0,} ile başlıyorsa ve (Perl'in /s seçeneğine eşdeğer) PCRE_DOTALL seçeneği etkinse, noktanın satırsonu karakterleriyle eşleşmesini sağlamak için, eşleşmeye konu dizgedeki karakterleri şablonun kalanı ile eşleştirmek adına, şablon örtük olarak satırsonlarına demirlenir. Dolayısıyla, ilkinden sonraki eşleşmeler için yineleme gereği kalmaz. PCRE böyle bir şablonu \A ile öncelenmiş gibi ele alır. Eşleşmeye konu dizgenin satırsonu karakterlerini içermediğinin bilindiği durumlarda, demirleme işlemini dolaylı olarak belirtmek amacıyla ^ kullanmak veya bu en iyilemeyi sağlamak için şablon .* ile başlatıldığı takdirde PCRE_DOTALL seçeneğini etkin kılmak akıllıca olur.

Bir yakalayan alt şablonun yinelenmesi durumunda, alt şablonun eşleştiği alt dizge son yineleme ile eşleşen alt dizgedir. Örneğin, (tweedle[dume]{3}\s*)+ şablonu "tweedledum tweedledee" dizgesiyle eşleştirilmeye çalışıldığında eşleşen alt dizge "tweedledee" olur. Bununla birlikte, iç içe yakalayan alt şablonların varlığında, alt şablonun eşleştiği alt dizge önceki yinelemelerle eşleşen alt dizgeler olabilir. Örneğin, /(a|(b))+/ şablonu "aba" ile eşleştirilmeye çalışıldığında eşleşen ikinci alt dizge "b" olur.

Alt Şablonlar
Geriye Gönderimler
Şablon Sözdizimi


Geriye Gönderimler

Bir karakter sınıfının dışında, bir tersbölü ile öncelenmiş 0'dan büyük bir sayı, şablonda kendinden önce yaylı ayraçlarla gruplanmış alt şablonlar varsa, bunlar arasından kendisiyle ilgili yakalayan alt şablona gönderim olarak ele alınır.

Ancak, tersbölüyü takibeden onluk sayı 10'dan küçükse, bu daima bir geriye gönderim olarak ele alınır ve şablonun öncesinde bir yakalayan alt şablon başlatan bundan daha az sayıda yaylı ayraç varsa işlem bir hata ile sonuçlanır. Başka bir deyişle, 10'dan küçük numaralı yakalayan alt şablonları kapatan ayraçların kendileriyle ilgili geriye gönderimlerin öncesinde bulunma koşulu yoktur. Tersbölüyü takibeden rakamların ele alınışları ile ilgili ayrıntılı bilgiyi Tersbölü bölümünde bulabilirsiniz.

Bir geriye gönderimin eşleştiği alt şablon olasılıklar içeriyorsa, geriye gönderim, şablonun kalanının eşleştiği olasılıktan başka bir olasılıkla eşleşmez. Yani, (sens|respons)e and \1ibility şablonu, "sense and sensibility" ve "response and responsibility" ile eşleştiği halde "sense and responsibility" ile eşleşmeyecektir. Harf büyüklüğüne duyarlılık etkin olduğunda geriye gönderim de aynı duyarlılığa sahip olacaktır. Örneğin, ((?i)rah)\s+\1 şablonunda, yakalayan alt şablon özgün olarak harf büyüklüğüne duyarlı eşleştiği halde bile "rah rah" ve "RAH RAH" ile eşleşecek ama "RAH rah" ile eşleşmeyecektir.

Aynı alt şablon için birden fazla geriye gönderim olabilir. Bir şablonun eşleşeceği bir dizge parçası yoksa onunla ilgili geriye gönderimler daima başarısız olacaktır. Örneğin, (a|(bc))\2 şablonu "bc" yerine "a" ile başlayan bir dizgeyle başarısız olacaktır. 99 ayrı geriye gönderim olabileceğinden bir tersbölüyü takibeden tüm rakamlar olası bir geriye gönderim olarak ele alınacaktır. Eğer alt şablon bir rakam karakteri ile devam ediyorsa geri gönderimi sonlandırmak için bir ayraç karakteri gerekir. PCRE_EXTENDED seçeneği etkinse bu ayraç karakteri, boşluk karakteridir. Aksi takdirde boş bir açıklama kullanmak gerekir.

Yaylı ayraçların içinde kullanılan bir geriye gönderim, ilgili alt şablonun hemen ardından kullanılmışsa başarısız olacaktır. Bu bakımdan, örneğin (a\1) şablonu hiçbir dizgeyle eşleşmeyecektir. Bununla birlikte, böyle alt şablon içindeki geriye gönderimler bazı durumlarda oldukça kullanışlı olabilir. Örneğin, (a|b\1)+ şablonu herhangi bir sayıda "a" veya "aba" ya da "ababba" ve benzeri dizgesiyle eşleşecektir. Alt şablonun her yinelenişinde, geriye gönderim kendisiyle ilişkili alt dizge ile eşleşecektir. Bunun çalışması için, ilk yinelemenin geriye gönderimle eşleşmesi gerekli değildir. Bu, yukarıdaki gibi olasılık belirtimiyle veya asgarisi sıfır olan bir yineleyici kullanılarak yapılabilir.

İsimli alt şablonlarla ilgili geriye gönderimler (?P=isim) veya PHP 5.2.4 sürümünden beri ayrıca, \k<isim>, \k'isim', \k{isim} veya \g{isim} biçeminde olabilmektedir.

Yineleme
Tezler
Şablon Sözdizimi


Tezler

Bir tez, herhangi bir karakterin tüketilmediği bir eşleşme noktasının öncesinde veya sonrasındaki karakterler üzerinde yapılacak bir sınama belirtir. Basit savlar yukarıda da açıklandığı gibi \b, \B, \A, \Z, \z, ^ ve $ olarak kodlanabilir. Birden fazla alt şablondan oluşan daha karmaşık savlar da düzenlenebilir. Bunların iki çeşidi vardır: Eşleşmeye konu dizge içinde geçerli konumun öncesine bakanlar ve sonrasına bakanlar.

Bir tez alt şablonu, eşleşme noktasının değişmesine sebep olmadığı takdirde normal yollarla eşleşecektir. Eşleşme noktasının sonrasına bakan tezler, olumlu savlar için (?= ile, olumsuz savlar için ise (?! ile başlar. Örneğin, \w+(?=;) şablonu, ardına bir noktalı virgül konmuş bir sözcükle eşleşecek, ancak ardında noktalı virgül bulunmayan bir sözcükle eşleşmeyecektir. foo(?!bar) şablonu ardında "bar" bulunmayan herhangi bir "foo" ile eşleşecektir. Ancak, benzer şekilde, (?!foo)bar şablonu, öncesinde "foo" dışında bir dizge bulunan bir "bar" dizgesini bulamayacak; buna karşın, öncesinde hiçbir şey bulunmayan, ilk "bar" dizgesini bulacaktır. Çünkü (?!foo) savı, sonraki üç karakter "bar" olduğu takdirde daima doğru olacaktır. Bu etkiyi geriye bakan bir savla da sağlamak mümkündür.

Eşleşme noktasının öncesine bakan tezler, olumlu savlar için (?<= ile, olumsuz savlar için ise (?<! ile başlar. Örneğin, (?<!foo)bar şablonu öncesinde "foo" bulunmayan bir "bar" dizgesiyle eşleşecektir. Geriye bakan bir savın içeriğinin eşleşeceği dizgenin sabit uzunlukta olması gerekir. (?<=bullock|donkey) şablonu bu kurala uyarken (?<!dogs?|cats?) şablonu, derleme sırasında hataya sebep olur. Farklı uzunlukta dizgelerle eşleşen geriye bakan şablonlara sadece olasılıkların belirtildiği alt şablonun dışında izin verilir. Bu kural, tüm olasılıkların aynı uzunlukta dizge ile eşleşmesini gerektiren Perl 5.005 sürümünden farklıdır. Örneğin, (?<=ab(c|de)) savına Perl 5.005 sürümünde izin verilmez, çünkü üst seviye olasılıklar farklı uzunlukta dizgelerden oluşur. Ancak, şablon, (?<=abc|abde) örneğindeki gibi iki ayrı olasılığa bölünürse sorun çıkmaz. Geriye bakan savların gerçekleniminde, her olasılık için, geçici olarak belli bir uzunlukta geriye gidilip eşleşme denenir. Eğer, eşleşme noktasının öncesinde yeteri sayıda karakter yoksa eşleşme ister istemez başarısız olur. Geriye bakan savlar, dizge sonlarıyla eşleşmede, sadece bir kere eşleşen alt şablonlarla birlikte kullanıldığında oldukça yararlıdır. Böyle, sadece bir kere eşleşen alt şablon örneklerini Sadece bir kerelik alt şablonlar bölümünde bulabilirsiniz.

Başarılı bir eşleşmede birden fazla sav bulunabilir. Örneğin, (?<=\d{3})(?<!999)foo şablonu, öncesindeki üç rakam "999" olmayan bir "foo" dizgesiyle eşleşecektir. Farkettiğiniz gibi, her sav, eşleşmeye konu dizge içinde hep aynı noktaya bağımsız olarak uygulanır. Yapılan ilk şey, önceki üç karakterin birer rakam olup olmadığıdır. Ancak bundan sonra o üç rakamın "999" olup olmadığına bakılır. Bu şablon, "foo" dizgesinin önündeki, ilk üç karakteri rakam olan ve son üç karakteri "999" olmayan altı karakterle eşleşmez. Örneğin, "123abcfoo" dizgesiyle eşleşme sağlanamayacaktır. İstenen eşleşmeyi sağlamak için şablonun (?<=\d{3}...)(?<!999)foo olarak düzenlenmesi gerekir.

İlk sav için önce, "foo" dizgesini önceleyen altı karakterin ilk üçünün rakam olup olmadığına bakılır. Sonra ikinci sav için altılının son üç karakterinin "999" olup olmadığına bakılır.

Savlar çeşitli birleşimler oluşturacak şekilde iç içe düzenlenebilir. Örneğin, (?<=(?<!foo)bar)baz şablonu öncesinde "foo" ile öncelenmemiş "bar" dizgeleri bulunan "baz" dizgeleriyle eşleşir. (?<=\d{3}...(?<!999))foo şablonu ise, öncesinde 3 rakam ile öncelenmiş "999" içermeyen üç karakter bulunan "foo" dizgeleriyle eşleşecektir.

Aynı savı bir kereden fazla kanıtlamanın bir anlamı olmadığından, sav alt şablonları, yinelenemeyecekleri gibi yakalayan alt şablonlar da olamazlar. Sav alt şablonların içerdiği yakalayan alt şablonlar, ana şablonun tümüne ait yakalayan alt şablonlar olarak değerlendirilirler. Bununla birlikte, bu çeşit yakalayan alt şablonlar sadece olumlu savlarda dışa taşınırlar, çünkü olumsuz savlarda dışa taşınacak bir şey olmaz.

Savlar en fazla 200 yaylı ayraçlı alt şablon içerebilir.

Geriye Gönderimler
Sadece bir kerelik alt şablonlar
Şablon Sözdizimi


Sadece bir kerelik alt şablonlar

Yinelemeyi gerek asgarileştirirken gerekse azamileştirirken, yineleme sayısının her değiştirilişinde ana şablonun kalanının eşleştiğini görmek için yapılan değerlendirmedeki başarısızlık normal olarak bu işlemin yinelenmesine sebep olur. Eşleşmenin doğasını değiştirerek veya şablonun yazarı numaralı eşleşmenin mümkün olmadığı noktayı biliyorsa eşleşmenin vaktinden önce başarısız olmasını sağlamak suretiyle bazen bunun olmasını engellemek yararlı olabilir.

\d+foo şablonunun 123456bar satırına uygulandığını varsayalım.

Eşleşterici, ilk altı rakamı eşleştirdikten sonra "foo" ile eşleşmenin mümkün olmadığını görünce, eninde sonunda başarısız olmadan önce şablonun \d+ parçasını önce 5 rakamla, sonra 4 rakamla, vb. eşleştirmeyi dener. Sadece bir kerelik alt şablonlar, şablonun belli bir parçasınının sadece bir kere eşleştirileceğini belirten alt şablonlardır. Böylece eşleştirici "foo" ile ilk eşleştirme denemesinin hemen ardından başarısız olur. Alt şablonun sözdizimi, aşağıdaki örnekte olduğu gibi (?> ile başlayan yaylı ayraçlı alt şablonların özel bir çeşididir: (?>\d+)bar

Eşleştiriciyi azami sayıda eşleşmeye kilitleyen bu çeşit alt şablonlar bir kerelik eşleşme sağlarlar ve şablonun tamamını eşleştirmedeki ilk başarısızlıkta şablonun geriye saymasını engellerler. Ancak, şablonun diğer parçaları geriye saymayı gerektiriyorsa bu normal olarak çalışır.

Başka bir deyişle, bu tür bir alt şablon, eşleşmeye konu dizgenin belli bir noktasına demirlemenin mümkün olduğu bir durumda tekil bir şablonun eşleşeceği dizgeyle eşleşir.

Sadece bir kerelik alt şablonlar, yakalamayan alt şablonlardır. Yukarıdaki örnekteki gibi basit durumlar, kalan herşeyin tüketilmesine sebep olan bir yineleme azamileştirmesi olarak düşünülebilir. Bu bakımdan, \d+ ve \d+? şablonlarının ikisi de şablonun kalanını eşleştirmek için rakam sayısını ayarlamaya çalışırken, (?>\d+) şablonu rakam dizisinin tamamıyla sadece bir kere eşleşebilir.

Bu oluşum, şüphesiz keyfi olarak karmaşıklaştırılmış alt şablonlar içerebilir ve bunlar iç içe olabilir.

Sadece bir kerelik alt şablonlar, dizge sonuyla etkili bir eşleşme belirtmek için, geriye bakan sav alt şablonları ile birlikte kullanılabilir. Eşleşmeyeceği uzun bir dizgeye uygulanacak, basit bir şablon olarak abcd$ şablonunu ele alalım. İşlem soldan sağa doğru uygulanacağından, PCRE, eşleşmeye konu dizgedeki her "a" için şablonun kalanıyla bir eşleşme arayacaktır. Eğer şablon, ^.*abcd$ olarak belirtilirse, ilk olarak baştaki .* dizgenin tamamıyla eşleşir, fakat bu başarısız olursa (dizgenin ardında bir "a" bulunmaması durumu), önce son bir karakteri bütün dizgeyle eşleştirmek için dizgede geriye gitmeye başlar, sonra bunu son iki karakter için ve son üç için, vb. dener. Dolayısıyla, "a" için dizgenin tamamıyla eşleşmeyi sağlayacak taramanın bu kez sağdan sola sola uygulanmasından başka değişen bir şey olmayacaktır. Bununla birlikte, şablon, ^(?>.*)(?<=abcd) olarak yazılırsa .* için geriye doğru defalarca eşleştirme denemesi yerine, dizgenin tamamıyla bir kerede eşleşme denenebilecektir. İkinci grupta belirtilen geriye bakan sav, son dört karakterin üzerinde sadece bir deneme yapacak, eğer eşleşme sağlanamazsa eşleştirici başarısız olacaktır. Uzun dizgeler sözkonusu olduğunda bu yaklaşım işlem süresi üzerinde önemli bir fark yaratacaktır.

Bir şablonun sınırsız sayıda yineleme içeren bir alt şablonu olması durumunda şablonun tamamı için sınırsız sayıda eşleşme denenecek demektir; eşleşme başarısızlığının çok uzun bir sürenin sonunda alınmasından kaçınmanın tek yolu ne yazık ki, sadece bir kerelik alt şablon kullanımıdır. (\D+|<\d+>)*[!?] şablonu, gerek hiç rakam bulunmaması gerekse rakamların <> ile sarmalanması durumunda, ardından ! veya ? belirtilmesi nedeniyle, sınırsız sayıda alt dizge ile eşleşecektir. Eğer eşleşme olursa işlem çabucak bitecektir. Bununla birlikte, şablon, aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa dizgesine uygulandığında başarısızlığın raporlanması çok uzun zaman alacaktır. Bunun sebebi, dizgenin çok sayıda yolla iki yinelemeye bölünebilmesi ve hepsinin denenmesidir. (Hem PCRE hem de Perl'in, tek bir karakter kullanıldığında hızlı bir başarısızlığa izin vermesi nedeniyle, örnekte sondaki tek karakter yerine [!?] kullanılmıştır. Bir eşleşme için son tek karakterin varlığı gereklidir ve dizgede bulunmazsa erken bir başarısızlık söz konusudur.) Eğer şablon, ((?>\D+)|<\d+>)*[!?] olarak değiştirilirse, rakam bulunmayan dizgeler bölünemeyecek ve başarısızlık çabucak gerçekleşecektir.

Tezler
Koşullu alt şablonlar
Şablon Sözdizimi


Koşullu alt şablonlar

Eşleşme sürecinin, bir savın veya önceki bir yakalayan alt şablonun eşleşme sonucuna bağlı olarak, bir şablona koşullu olarak boyun eğmesi veya iki olasılık arasında seçim yapabilmesi mümkündür. Koşullu alt şablonların olası iki çeşidi şunlardır:

       (?(koşul)evet-şablonu)
       (?(koşul)evet-şablonu|hayır-şablonu)

Koşul sağlandığı takdirde evet-şablonu, aksi takdirde hayır-şablonu uygulanır veya hiçbir şablon uygulanmaz. Koşullu alt şablonda ikiden fazla olasılık varsa derleme sırasında hata oluşur.

İki çeşit koşul vardır. Eğer yaylı ayraçlar arasındaki metin rakamlardan oluşuyorsa koşulun içerdiği sayıların önceki yakalayan alt şablonlarla eşleşeceği varsayılır. Şablonu daha okunabilir kılmak için boşluk karakterlerinin yok sayılmakta olduğunu (PCRE_EXTENDED seçeneği) varsayarak boşluklarla üç parçaya bölünmüş şu şablonu ele alalım: ( \( )? [^()]+ (?(1) \) )

İlk parça bir açan yaylı ayraç ile eşleşir ve karakter mevcut olduğu takdirde bu, ilk yakalayan alt dizge olur. İkinci parça yaylı ayraç olmayan bir veya daha fazla karakterle eşleşir. Üçüncü parça ise bir koşullu alt şablon olarak, ilk yaylı ayraçlı grupla eşleşip eşleşmediğine bakar; eşleşme varsa, yani eşleşmeye konu dizge bir açan yaylı ayraç ile başlıyorsa, koşul doğrulanmış olur. Dolayısıyla evet-şablonu çalıştırılır ve kapatan yaylı ayraç aranır. Aksi takdirde şablon hiçbir şeyle eşleşmez. Başka bir deyişle, bu şablona göre açan yaylı ayraçla başlayan bir dizge kapatan bir yaylı ayraçla bitebileceği gibi bitmeyebilir de.

Eğer koşul olarak (R) dizgesi verilmişse, şablona veya alt şablona ardışık bir çağrı yapılmış gibi ele alınır. "Üst seviye" için koşul daima yanlış sonuç verir.

Eğer koşul rakamlardan veya (R) dizgerinden oluşmuyorsa, bir sav olarak ele alınır.Olumlu veya olumsuz, ileriye veya geriye bakan bir sav olabilir. Yine boşluk karakterlerinin yok sayılacağı varsayımıyla ikinci satırında iki olasılık içeren şu şablonu ele alalım:

       (?(?=[^a-z]*[a-z])
       \d{2}-[a-z]{3}-\d{2}  |  \d{2}-\d{2}-\d{2} )

Koşul, ileriye bakan olumlu bir sav olup, isteğe bağlı olarak harf olmayan karakterleri takibeden bir harf ile eşleşir. Başka bir deyişle, eşleşmeye konu dizge içinde en azından bir harfin var olup olmadığına bakar. Eğer bir harf varsa, eşleşmeye konu dizge ilk olasılıkla, aksi takdirde ikinci olasılıkla eşleşir, Şablon, aaa'nın harfleri, dd'nin rakamları ifade ettiği durumda dizgenin ya dd-aaa-dd ya da dd-dd-dd dizilimiyle eşleşecektir.

Sadece bir kerelik alt şablonlar
Açıklamalar
Şablon Sözdizimi


Açıklamalar

(?# dizilimi sonraki kapatan yaylı ayraca kadar devam eden bir açıklamanın başlangıcını belirtir. İç içe açıklamalara izin verilmez. Açıklama olarak imlenmiş parçalar şablonun yorumlanan parçaları olarak ele alınmazlar.

Eğer PCRE_EXTENDED seçeneği etkinse, şablon içinde, bir karakter sınıfının dışındaki öncelenmemiş bir # karakteri sonraki satırsonu karakterine kadar devam eden bir açıklamanın başlangıcı olarak ele alınır.

Koşullu alt şablonlar
İç içe şablonlar
Şablon Sözdizimi


İç içe şablonlar

Sınırsız iç içe yaylı ayraçların kullanıldığı bir şablonu yaylı ayraçlar arasındaki bir dizgeyle eşleştirme sorununu ele alalım. Ardışık işlem haricinde yapılabilecek en iyi şey iç içe sabit bir derinliğe kadar eşleşebilecek bir şablon kullanmaktır. Sabit olmayan derinlikli iç içe şablonları işlemek mümkün değildir. Perl'in 5.6 sürümü, ardışık (iç içe) düzenli ifadelere izin veren deneysel bir oluşuma sahiptir. Belli bir ardışıklık durumu için özel bir öğe, (?R) öğesi sağlanmıştır. Bu PCRE şablonu yaylı ayraçlarla ilgili bu sorunu çözmektedir: \( ( (?>[^()]+) | (?R) )* \) (Boşlukların gözardı edilmesini sağlayan PCRE_EXTENDED seçeneğinin etkin olduğu varsayılmıştır.)

İlk eşleşme bir açan yaylı ayraçla olur. Sonraki eşleşme, ya yaylı ayraçlar içine alınmamış bir dizi alt dizgeyle olur ya da şablonun kendisi ardışık olarak (doğru olarak yaylı ayraçlar içine alınmış alt dizgelerle) eşleşir. Ve son eşleşme bir kapatan yaylı ayraçla olur.

Örnek olarak verdiğimiz bu şablon sınırsız sayıda iç içe yineleme içerir; dolayısıyla şablon, eşleşmeyeceği dizgelere uygulandığında, yaylı ayraç içine alınmamış dizgelerle eşleşmek için sadece bir kerelik alt şablonların kullanımı önem kazanır. Bu duruma bir örnek olarak çabuk bir eşleşmemeyle sonuçlanan şu dizge verilebilir: (aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa()

Bununla birlikte, sadece bir kerelik alt şablon kullanılmazsa eşleştirme işlemi çok uzun sürecektir. Bunun sebebi, eşleşmeye konu dizgeyi çok çeşitli şekillerde bölen + ve * yinelemelerinin olması ve bir başarısızlık raporlamadan önce bunların hepsinin denenmesi gereğidir.

Herhangi bir yakalama alt şablonu için belirlenmiş değerler, alt şablon değerinin atandığı ardışık işlemin en dış seviyesindeki değerlerdir. Eğer yukardaki şablon, (ab(cd)ef) dizgesiyle eşleştirilmeye çalışılırsa yakalanan ayraçlı değer, en üst seviyede elde edilen son değer olan "ef" olur. Eğer başka yaylı ayraçlar da eklenirse, \( ( ( (?>[^()]+) | (?R) )* ) \) şablonu ile yakalanan dizge, en üst seviye yaylı ayraçların içindeki "ab(cd)ef" olur. Eğer bir şablonda 15'ten fazla yakalayan yaylı ayraç varsa, PCRE ardışık bir işlem sırasında veriyi saklamak için pcre_malloc ile ayırarak ve işi bitince pcre_free ile serbest bırakarak fazladan bellek sağlamak zorundadır. Eğer bu bellek ayrılamazsa, bir ardışık işlem sırasında bellek yetersiz hatası vermek mümkün olmadığından veriyi, sadece ilk 15 yakalayan yaylı ayraç için saklar.

PHP 4.3.3'ten beri, (?1), (?2) ve benzerleri ardışık alt şablonlarda da kullanılabilmektedir. Ayrıca, (?P>isim) veya (?P&isim) isimli alt şablonlarını da kullanmak mümkündür.

İsimli veya numararalı bir ardışık alt şablon gönderim sözdizimi, gönderimde bulunduğu yaylı ayraçların dışında kullanılmışsa bir programlama dilindeki bir alt yordam gibi işlem yapar. Önceki örneklerden birinde, (sens|respons)e and \1ibility şablonu "sense and sensibility" ve "response and responsibility" ile eşleşiyor, fakat "sense and responsibility" ile eşleşmiyordu. Eğer (sens|respons)e and (?1)ibility şablonu kullanılmış olsaydı diğer iki dizgeyle birlikte "sense and responsibility" dizgesi de eşleşecekti. Böyle gönderimlerin, yine de atıfta bulunduğu alt şablondan sonra gelmesi gerekir.

Eşleşmeye konu dizgenin azami uzunluğu bir tamsayı değişkenin tutabileceği en büyük pozitif tamsayı kadar olabilirse de PCRE ardışık işlem yaparak sonsuz sayıda yinelemeyi ve alt şablonu işleyebilir. Bu bakımdan, belli bir şablon tarafından işlenebilecek bir dizgenin uzunluğunu sınırlayan şey aslında, kullanılabilecek yığıtın büyüklüğüdür.

Açıklamalar
Başarım
Şablon Sözdizimi


Başarım

Şablonların içindeki bazı ögeler diğerlerine göre daha verimli olabilir. Örneğin, [aeiou] gibi bir karakter sınıfı, (a|e|i|o|u) gibi bir olasılık kümesine göre daha verimlidir. Genelde, gerekli davranışı sergileyen en basit oluşum normal olarak en verimli oluşumdur. Jeffrey Friedl'ın kitabı, düzenli ifadelerin verimini arttırmak için en iyilenmeleriyle ilgili bir çok inceleme içerir.

Bir şablon .* ile başlıyorsa ve PCRE_DOTALL seçeneği etkinse, şablon, sadece eşleşmeye konu dizgenin başlangıcı ile eşleşebileceğinden, örtük olarak PCRE tarafından demirlenir. Bununla birlikte, PCRE_DOTALL seçeneği etkin değilse, nokta işleci satırsonu karakteri ile eşleşmeyeceğinden ve eşleşmeye konu dizge çok sayıda satırsonu içeriyorsa şablon dizgenin başlangıcından başka diğer satırsonu karakterlerinin sonrası ile de eşleşeceğinden PCRE bu en iyilemeyi yapamaz. Örneğin, (.*) ikinci şablonu, ilk yakalanan alt dizge "ve" olmak üzere "birinci\nve ikinci" dizgesiyle eşleşir (\n satırsonu karakteridir). PCRE bunu yaparken, eşleşmeye konu dizgedeki her satırsonu karakterinden sonra eşleşme başlatmayı tekrarlamak zorundadır.

Böyle bir şablonu satırsonu karakteri içermeyen bir dizgeyle eşleştirmek için kullanıyorsanız en iyi başarımı PCRE_DOTALL seçeneğini etkin kılarak veya demirlemeyi açıkça belirtmek için şablonu ^.* ile başlatarak sağlayabilirsiniz. Bu, PCRE'yi her satırsonunda eşleşmeyi yeni baştan başlatmaktan kurtarır.

İç içe sonsuz sayıda yineleme içeren şablonlara karşı dikkatli olun. Kendileriyle eşleşmeyen bir dizgeye rastladıklarında sonuç almak çok uzun sürebilir. Örneğin (a+)* şablonunu ele alalım.

Bu şablon "aaaa" dizgesiyle 33 farklı yolla eşleşir ve dizge uzadıkça bu sayı büyük bir hızla artar. (* yinelemesi 0, 1, 2, 3, 4 kere eşleşir ve sıfırdan farklı bütün durumlarda + yinelemeleri farklı kereler eşleşebilir.) Şablonun kalanı böyle olduğu takdirde şablonun tamamıyla eşleşme mümkün olmayacaktır. PCRE kural olarak olası her çeşit yinelemeyi deneyeceğinden bu işlem oldukça uzun bir zaman alacaktır.

Şablonun ardına, (a+)*b şeklinde özel olmayan bir karakter getirilmesi gibi basit çözümlerle bir en iyileme mümkündür. Standart eşleştirme işlemlerine girişmeden önce, PCRE eşleşmeye konu dizgenin sonlarına doğru bir "b" varlığını araştırır; bulamazsa, hemen eşleşmenin başarısız olduğunu bildirir. Ancak böyle arda eklenebilecek özel olmayan bir karakterin yokluğunda bu en iyileme kullanılamaz. (a+)*\d şablonunun davranışını yukarıdaki şablonla karşılaştırarak farkı görebilirsiniz. Birincisi sadece "a"lardan oluşan bir satıra uygulandığında hemen her durumda daima anında başarısız olurken ikincisinin başarısızlığı dizge 20 karakterden uzun olduğunda farkedilebilecek kadar uzun bir süre sonra gerçekleşir.

İç içe şablonlar
PCRE İşlevleri
Şablon Sözdizimi


PCRE İşlevleri

İçindekiler

  • preg_filter — Bir düzenli ifade arama ve değiştirmesi yapar
  • preg_grep — Düzenli ifadeyle eşleşenleri içeren bir dizi döndürür
  • preg_last_error — Son PCRE düzenli ifade aramasından dönen hatayı döndürür
  • preg_match_all — Kapsamlı bir düzenli ifade eşleştirmesi yapar
  • preg_match — Bir düzenli ifadeyi eşleştirmeye çalışır
  • preg_quote — Düzenli ifadelerin özel karakterlerini önceler
  • preg_replace_callback_array — Perform a regular expression search and replace using callbacks
  • preg_replace_callback — Geriçağırım işlevi kullanarak düzenli ifadeye göre dizgede değişiklik yapar
  • preg_replace — Düzenli ifadeye göre dizgede değişiklik yapar
  • preg_split — Dizgeyi düzenli ifadeye göre böler
Başarım
preg_filter
Perl Uyumlu Düzenli İfadeler


Bir düzenli ifade arama ve değiştirmesi yapar

PCRE İşlevleri
preg_grep
PCRE İşlevleri
PHP Manual

preg_filter

(PHP 5 >= 5.3.0, PHP 7)

preg_filter — Bir düzenli ifade arama ve değiştirmesi yapar

Açıklama

mixed preg_filter ( mixed $şablon , mixed $yenisi , mixed $konu [, int $sınır = -1 [, int &$sayı ]] )

preg_filter() sadece eşleşenleri döndürmesi dışında
preg_replace() işlevi gibidir. Bu işlevin nasıl
çalıştığıyla ilgili ayrıntılar için preg_replace()
belgesini okuyun.

Değiştirgeler

şablon

yenisi

konu

sınır

sayı

Dönen Değerler

konu değiştirgesi bir dizi ise bir dizi döndürür aksi takdirde bir dizge döner.

Eşleşmeler bulunduğu takdirde yeni konu döner, aksi takdirde bir hata oluşmamışsa konu değiştirilmeden döndürülür; bir hata oluşmuşsa NULL döner.

Örnekler

Örnek 1 - preg_filter() ile preg_replace() işlevini karşılaştırma örneği

<?php
$subject = array('1', 'a', '2', 'b', '3', 'A', 'B', '4');
$pattern = array('/\d/', '/[a-z]/', '/[1a]/');
$replace = array('A:$0', 'B:$0', 'C:$0');

echo "preg_filter işlevinin sonucu:\n";
print_r(preg_filter($pattern, $replace, $subject));

echo "preg_replace  işlevinin sonucu:\n";
print_r(preg_replace($pattern, $replace, $subject));
?>

Yukarıdaki örneğin çıktısı:

preg_filter işlevinin sonucu:
Array
(
    [0] => A:C:1
    [1] => B:C:a
    [2] => A:2
    [3] => B:b
    [4] => A:3
    [7] => A:4
)
preg_replace işlevinin sonucu:
Array
(
    [0] => A:C:1
    [1] => B:C:a
    [2] => A:2
    [3] => B:b
    [4] => A:3
    [5] => A
    [6] => B
    [7] => A:4
)

Ayrıca Bakınız

  • preg_replace() - Düzenli ifadeye göre dizgede değişiklik yapar
  • preg_replace_callback() - Geriçağırım işlevi kullanarak düzenli ifadeye göre dizgede değişiklik yapar
  • preg_match() - Bir düzenli ifadeyi eşleştirmeye çalışır
  • preg_split() - Dizgeyi düzenli ifadeye göre böler

PCRE İşlevleri
preg_grep
PCRE İşlevleri


Düzenli ifadeyle eşleşenleri içeren bir dizi döndürür

preg_filter
preg_last_error
PCRE İşlevleri
PHP Manual

preg_grep

(PHP 4, PHP 5, PHP 7)

preg_grep — Düzenli ifadeyle eşleşenleri içeren bir dizi döndürür

Açıklama

array preg_grep ( string $şablon , array $girdi [, int $seçenekler = 0 ] )

şablon ile eşleşen girdi dizisinin elemanlarından oluşan bir dizi ile döner.

Değiştirgeler

şablon

Bir dizge olarak, aranacak şablon.

girdi

Girdi dizisi.

seçenekler

PREG_GREP_INVERT belirtilirse, şablon ile eşleşmeyen girdi dizisinin elemanlarından oluşan bir dizi ile döner.

Dönen Değerler

girdi dizisindeki anahtarları kullanan bir dizi ile döner.

Sürüm Bilgisi

Sürüm: | Açıklama
4.2.0 | seçenekler değiştirgesi eklendi.
4.0.4 | Bu sürümden önce dönen dizinin elemanları girdi dizisindeki anahtarları kullanmazdı. Bu eski davranışı elde etmek isterseniz, dönen diziyi anahtarlarından arındırmak için array_values() işlevini kullanabilirsiniz.

Örnekler

Örnek 1 - preg_grep() örneği

<?php
// Gerçek sayı içeren bütün dizi elemanlarını döndürür
$fl_array = preg_grep("/^(\d+)?\.\d+$/", $array);
?>

preg_filter
preg_last_error
PCRE İşlevleri


Son PCRE düzenli ifade aramasından dönen hatayı döndürür

preg_grep
preg_match_all
PCRE İşlevleri
PHP Manual

preg_last_error

(PHP 5 >= 5.2.0, PHP 7)

preg_last_error — Son PCRE düzenli ifade aramasından dönen hatayı döndürür

Açıklama

int preg_last_error ( void )

Son PCRE düzenli ifade aramasından dönen hatanın kodunu döndürür.

Örnek 1 - preg_last_error() örneği

<?php

preg_match('/(?:\D+|<\d+>)*[!?]/', 'foobar foobar foobar');

if (preg_last_error() == PREG_BACKTRACK_LIMIT_ERROR) {
    print 'Geri izleme sınırına ulaşıldı!';
}

?>

Yukarıdaki örneğin çıktısı:

Geri izleme sınırına ulaşıldı!

Dönen Değerler

Aşağıdaki sabitlerden biri döner:

  • PREG_NO_ERROR
  • PREG_INTERNAL_ERROR
  • PREG_BACKTRACK_LIMIT_ERROR (ayrıca bkz: pcre.backtrack_limit)
  • PREG_RECURSION_LIMIT_ERROR (ayrıca bkz: pcre.recursion_limit)
  • PREG_BAD_UTF8_ERROR
  • PREG_BAD_UTF8_OFFSET_ERROR (PHP 5.3.0'dan beri)

preg_grep
preg_match_all
PCRE İşlevleri


Kapsamlı bir düzenli ifade eşleştirmesi yapar

preg_last_error
preg_match
PCRE İşlevleri
PHP Manual

preg_match_all

(PHP 4, PHP 5, PHP 7)

preg_match_all — Kapsamlı bir düzenli ifade eşleştirmesi yapar

Açıklama

int preg_match_all ( string $şablon , string $konu , array &$eşleşmeler [, int $seçenekler [, int $başlangıç ]] )

şablon ile belirtilen düzenli ifadeyi eşleştirmek için konu dizgesinde arama yapar ve bulunanları seçenekler ile belirtilen sırada eşleşmeler dizisine yerleştirir.

İlk eşleşme bulunduğunda arama işlemi bitmez, dizgenin sonuna kadar sürdürülür.

Değiştirgeler

şablon

Bir dizge olarak, aranacak şablon.

konu

Şablonla eşleşeceği düşünülen dizge.

eşleşmeler

seçenekler değiştirgesine göre sıralanmış olarak tüm eşleşenleri içerecek dizi.

seçenekler

Aşağıdaki seçeneklerin bir birleşimi belirtilebilir (Dikkat: PREG_PATTERN_ORDER ve PREG_SET_ORDER birlikte beklenen yararı sağlamaz.):

PREG_PATTERN_ORDER

$eşleşmeler[0] şablonun tamamıyla eşleşen dizgeyi, $eşleşmeler[1] ve sonrakiler alt şablonlarla eşleşen alt dizgeleri içermek üzere sonuçları sıralar.

<?php
preg_match_all("|<[^>]+>(.*)</[^>]+>|U",
    "<b>örnek: </b><div align=left>bu bir denemedir</div>",
    $out, PREG_PATTERN_ORDER);
echo $out[0][0] . ", " . $out[0][1] . "\n";
echo $out[1][0] . ", " . $out[1][1] . "\n";
?>

Yukarıdaki örneğin çıktısı:

<b>örnek: </b>, <div align=left>bu bir denemedir</div>
örnek: , bu bir denemedir

Böylece, $out[0] şablonun tamamıyla eşleşen dizgeleri içeren bir dizi, $out[1] ise etiketler arasında kalan dizgeleri içeren bir dizi içerir.

PREG_SET_ORDER

$eşleşmeler[0] ilk eşleşme kümesini, $matches[1] ve sonrakiler sonraki eşleşme kümelerini içermek üzere çıktıyı sıralar.

<?php
preg_match_all("|<[^>]+>(.*)</[^>]+>|U",
    "<b>örnek: </b><div align=\"left\">bu bir denemedir</div>",
    $out, PREG_SET_ORDER);
echo $out[0][0] . ", " . $out[0][1] . "\n";
echo $out[1][0] . ", " . $out[1][1] . "\n";
?>

Yukarıdaki örneğin çıktısı:

<b>örnek: </b>, örnek:
<div align="left">bu bir denemedir</div>, bu bir denemedir

PREG_OFFSET_CAPTURE

Bu seçenek etkin olduğunda, her eşleşme bulunduğunda sonraki arama başlangıcı da döner. Bu durumda, dönen dizinin her elemanı ayrıca birer dizi olup, her elemanın 0 indisinde eşleşen dizge, 1 indisinde ise konu içindeki başlangıç konumunu bulunur.

Bir sıralama seçeneği belirtilmediği takdirde PREG_PATTERN_ORDER öntanımlıdır.

başlangıç

konu dizgesinde aramanın başlatılacağı konum; isteğe bağlı olup bayt cinsinden belirtilir.

Bilginize:

başlangıç değiştirgesinin kullanımı, substr($konu, $başlangıç) ile konu dizgede belirtilen başlangıca göre işleve bir alt dizge aktarmaya eşdeğer değildir. Çünkü, şablon, ^, $, (?<=x) gibi savlar içerebilir. Örnekler için preg_match() işlevine bakınız.

Dönen Değerler

Hata oluşmuşsa FALSE, aksi takdirde şablonun tamamıyla eşleşenlerin sayısını (0 olabilir) döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.3 | başlangıç değiştirgesi eklendi.
4.3.0 | PREG_OFFSET_CAPTURE seçeneği eklendi.

Örnekler

Örnek 1 - Bir metinden telefon numaralarının toplanması

<?php
preg_match_all("/\(?  (\d{3})?  \)?  (?(1)  [\-\s] ) \d{3}-\d{4}/x",
                "555-1212 veya 1-800-555-1212 numarayı arayın", $teller);
?>

Örnek 2 - HTML etiketlerini bulmak (tamahkarca)

<?php
// \\2 bir geriye gönderim örneği olup PCRE'ye düzenli ifadenin
// ikinci yaylı ayraçlı grubuyla eşleşeceğini söyler; yani ([\w]+) ile.
// Dizge çift tırnak içine alınmış olduğundan çift tersbölü kullanılmıştır.
$html = "<b>Vurgulanmış metin</b><a href=howdy.html>buraya tıklayın</a>";

preg_match_all("/(<([\w]+)[^>]*>)(.*?)(<\/\\2>)/",
               $html, $eşleşenler, PREG_SET_ORDER);

foreach ($eşleşenler as $eşleşen) {
    echo " eşleşen: " . $eşleşen[0] . "\n";
    echo "1. parça: " . $eşleşen[1] . "\n";
    echo "2. parça: " . $eşleşen[2] . "\n";
    echo "3. parça: " . $eşleşen[3] . "\n";
    echo "4. parça: " . $eşleşen[4] . "\n\n";
}
?>

Yukarıdaki örneğin çıktısı:

 eşleşen: <b>Vurgulanmış metin</b>
1. parça: <b>
2. parça: b
3. parça: Vurgulanmış metin
4. parça: </b>

 eşleşen: <a href=howdy.html>buraya tıklayın</a>
1. parça: <a href=howdy.html>
2. parça: a
3. parça: buraya tıklayın
4. parça: </a>

Örnek 3 İsimli alt şablon kullanımı

<?php

$konu = <<<FOO
a: 1
b: 2
c: 3
FOO;

preg_match_all('/(?<harf>\w+): (?<rakam>\d+)/', $konu, $eşleşenler);

    print_r($eşleşenler);

?>

Yukarıdaki örneğin çıktısı:

Array
(
    [0] => Array
        (
            [0] => a: 1
            [1] => b: 2
            [2] => c: 3
        )

    [harf] => Array
        (
            [0] => a
            [1] => b
            [2] => c
        )

    [1] => Array
        (
            [0] => a
            [1] => b
            [2] => c
        )

    [rakam] => Array
        (
            [0] => 1
            [1] => 2
            [2] => 3
        )

    [2] => Array
        (
            [0] => 1
            [1] => 2
            [2] => 3
        )

)

Ayrıca Bakınız

  • preg_match() - Bir düzenli ifadeyi eşleştirmeye çalışır
  • preg_replace() - Düzenli ifadeye göre dizgede değişiklik yapar
  • preg_split() - Dizgeyi düzenli ifadeye göre böler

preg_last_error
preg_match
PCRE İşlevleri


Bir düzenli ifadeyi eşleştirmeye çalışır

preg_match_all
preg_quote
PCRE İşlevleri
PHP Manual

preg_match

(PHP 4, PHP 5, PHP 7)

preg_match — Bir düzenli ifadeyi eşleştirmeye çalışır

Açıklama

int preg_match ( string $şablon , string $konu [, array &$eşleşenler [, int $seçenekler [, int $başlangıç ]]] )

şablon ile belirtilen düzenli ifadeyi eşleştirmek için konu dizgesinde arama yapar.

Değiştirgeler

şablon

Bir dizge olarak, aranacak şablon.

konu

Şablonla eşleşeceği düşünülen dizge.

eşleşmeler

Belirtildiği takdirde sonuçları içerecek dizi. $eşleşmeler[0] elemanı şablonun tamamıyla eşleşen metni, $eşleşmeler[1] ve sonrakiler yakalayan yaylı ayraçlı alt şablonlarla eşleşen alt dizgeleri içerir.

seçenekler

Bu değiştirgede şu seçenekler belirtilebilir:

PREG_OFFSET_CAPTURE
Bu seçenek etkin olduğunda, her eşleşme bulunduğunda sonraki arama başlangıcı da döner. Bu durumda, dönen dizinin her elemanı ayrıca birer dizi olup, her elemanın 0 indisinde eşleşen dizge, 1 indisinde ise konu içindeki başlangıç konumunu bulunur.
başlangıç

konu dizgesinde aramanın başlatılacağı konum; isteğe bağlı olup bayt cinsinden belirtilir.

Bilginize:

başlangıç değiştirgesinin kullanımı, substr($konu, $başlangıç) ile konu dizgede belirtilen başlangıca göre işleve bir alt dizge aktarmaya eşdeğer değildir. Çünkü, şablon, ^, $, (?<=x) gibi savlar içerebilir. Şu iki örneği karşılaştıralım:

1. örnek:

<?php
$subject = "abcdef";
$pattern = '/^def/';
preg_match($pattern, $subject, $matches, PREG_OFFSET_CAPTURE, 3);
print_r($matches);
?>

Yukarıdaki örneğin çıktısı:

Array
(
)

2. örnek:

<?php
$subject = "abcdef";
$pattern = '/^def/';
preg_match($pattern, substr($subject,3), $matches, PREG_OFFSET_CAPTURE);
print_r($matches);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [0] => Array
        (
            [0] => def
            [1] => 0
        )

)

Dönen Değerler

preg_match() işlevi şablon ile eşleşme sayısını döndürür. Değer olarak, hiç eşleşme olmadığını belirtmek üzere 0 veya eşleşme olduğunu belirtmeki üzere 1 döner; çünkü preg_match() ilk eşleşmeyi bulur bulmaz döner. preg_match_all() ise tersine, konu dizgesinin sonuna kadar eşleşenleri arar. Bir hata oluşması durumunda işlev FALSE döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
5.2.2 | İsimli alt şablonlar artık (?<isim>), (?'isim') ve (?P<isim>) sözdizimleri ile kabul ediliyor. Önceki sürümlerde sadece (?P<isim>) kabul edilmekteydi.
4.3.3 | başlangıç değiştirgesi eklendi
4.3.0 | PREG_OFFSET_CAPTURE seçeneği eklendi.
4.3.0 | seçenekler değiştirgesi eklendi.

Örnekler

Örnek 1 - Metin içinde "php" dizgesini bulmak

<?php
// Şablonun ardına konan "i" aramanın harf büyüklüğüne
// duyarsız olacağını belirtir.
if (preg_match("/php/i", "PHP bir betik dilidir.")) {
    echo "Eşleşme sağlandı.";
} else {
    echo "Eşleşme sağlanamadı.";
}
?>

Örnek 2 - "cebir" sözcüğünü bulmak

<?php
/* \b işleci şablonun tam bir sözcükle eşleşeceğini belirtir,
   yani "cebir" eşleşirken "cebirci", "cebirsel "eşleşmez.*/
if (preg_match("/\bcebir\b/i", "Cebir en sevdiğim derstir.")) {
    echo "Eşleşme var.";
} else {
    echo "Eşleşme yok.";
}

if (preg_match("/\bcebir\b/i", "Cebirci yazılı yapacak!")) {
    echo "Eşleşme var.";
} else {
    echo "Eşleşme yok.";
}
?>

Örnek 3 - Bir adresten alan ismini çekip almak

<?php
// adresten alan ismini alalım
preg_match('@^(?:http://)?([^/]+)@i',
    "http://www.php.net/index.html", $matches);
$host = $matches[1];

// alan adının son iki parçasını alalım
preg_match('/[^.]+\.[^.]+$/', $host, $matches);
echo "alan adı: {$matches[0]}\n";
?>

Yukarıdaki örneğin çıktısı:

alan adı: php.net

Örnek 4 - İsimli alt şablon kullanımı

<?php

$dizge = 'mesela: 2008';

// PHP 5.2.2 ve sonrasında çalışır
preg_match('/(?<isim>\w+): (?<sene>\d+)/', $dizge, $eşleşmeler);

// PHP 5.2.2 öncesinde bu gerekiyordu:
// preg_match('/(?P<isim>\w+): (?P<sene>\d+)/', $dizge, $eşleşmeler);

print_r($eşleşmeler);

?>

Yukarıdaki örneğin çıktısı:

(
    [0] => mesela: 2008
    [isim] => mesela
    [1] => mesela
    [sene] => 2008
    [2] => 2008
)

Notlar

İpucu

Bir dizgeyi başka bir dizge ile eşleştirmek için bu işlevi değil, bu işi daha hızlı yapan strpos() veya strstr()işlevini kullanın.

Ayrıca Bakınız

  • preg_match_all() - Kapsamlı bir düzenli ifade eşleştirmesi yapar
  • preg_replace() - Düzenli ifadeye göre dizgede değişiklik yapar
  • preg_split() - Dizgeyi düzenli ifadeye göre böler

preg_match_all
preg_quote
PCRE İşlevleri


Düzenli ifadelerin özel karakterlerini önceler

preg_match
preg_replace_callback_array
PCRE İşlevleri
PHP Manual

preg_quote

(PHP 4, PHP 5, PHP 7)

preg_quote — Düzenli ifadelerin özel karakterlerini önceler

Açıklama

string preg_quote ( string $dizge [, string $im = NULL ] )

preg_quote() işlevi dizge değiştirgesinde bulunan düzenli ifade özel karakterlerinin her birinin önüne tersbölü karakteri yerleştirir. Düzenli ifade dizgesini çalışma anında oluşturuyorsanız ve du dizgelerin özel karakterleri içerme olasılığı varsa bu işlev çok işe yarar.

Özel düzenli ifade karakterleri şunlardır: . \ + * ? [ ^ ] $ ( ) { } = ! < > | : -

Değiştirgeler

dizge

Girdi dizgesi.

im

Belirtilmesi isteğe bağlı olup, gerekirse bu im de öncelenecektir. PCRE işlevlerinin gerektirdiği imleri öncelemek için yararlıdır. / karakteri en çok kullanılan imlerden biridir.

Dönen Değerler

Öncelenmiş dizge ile döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | - karakteri artık önceleniyor.

Örnekler

Örnek 1 - preg_quote() örneği

<?php
$keywords = '$40 for a g3/400';
$keywords = preg_quote($keywords, '/');
echo $keywords; // çıktısı: \$40 for a g3\/400
?>

Örnek 2 - Bir metnin içindeki bir kelimeyi vurgulamak

<?php
// Bu örnekte, preg_quote($kelime),
// düzenli ifade için özel anlama sahip
// yıldız imlerini öncelemekte kullanılmıştır.

$metin = "Bu kitabı bulmak çok *zor*.";
$kelime = "*zor*";
$metin = preg_replace ("/" . preg_quote($kelime) . "/",
                          "<i>" . $kelime . "</i>",
                          $metin);
?>

Notlar

Bilginize: Bu işlev ikil dosyalarla çalışırken dosya içeriğini değiştirmez.

preg_match
preg_replace_callback_array
PCRE İşlevleri


Perform a regular expression search and replace using callbacks

preg_quote
preg_replace_callback
PCRE İşlevleri
PHP Manual

preg_replace_callback_array

(PHP 7)

preg_replace_callback_array — Perform a regular expression search and replace using callbacks

Açıklama

mixed preg_replace_callback_array ( array $patterns_and_callbacks , mixed $subject [, int $limit = -1 [, int &$count ]] )

The behavior of this function is similar to preg_replace_callback(), except that callbacks are executed on a per-pattern basis.

Değiştirgeler

patterns_and_callbacks

An associative array mapping patterns (keys) to callbacks (values).

subject

The string or an array with strings to search and replace.

limit

The maximum possible replacements for each pattern in each subject string. Defaults to -1 (no limit).

count

If specified, this variable will be filled with the number of replacements done.

Dönen Değerler

preg_replace_callback_array() returns an array if the subject parameter is an array, or a string otherwise. On errors the return value is NULL

If matches are found, the new subject will be returned, otherwise subject will be returned unchanged.

Örnekler

Örnek 1 preg_replace_callback_array() example

<?php
$subject = 'Aaaaaa Bbb';

preg_replace_callback_array(
    [
        '~[a]+~i' => function ($match) {
            echo strlen($match[0]), ' matches for "a" found', PHP_EOL;
        },
        '~[b]+~i' => function ($match) {
            echo strlen($match[0]), ' matches for "b" found', PHP_EOL;
        }
    ],
    $subject
);
?>

Yukarıdaki örneğin çıktısı:

6 matches for "a" found
3 matches for "b" found

Ayrıca Bakınız

  • PCRE Patterns
  • preg_replace_callback() - Geriçağırım işlevi kullanarak düzenli ifadeye göre dizgede değişiklik yapar
  • preg_quote() - Düzenli ifadelerin özel karakterlerini önceler
  • preg_replace() - Düzenli ifadeye göre dizgede değişiklik yapar
  • preg_last_error() - Son PCRE düzenli ifade aramasından dönen hatayı döndürür
  • Anonymous functions
  • callback türü hakkında bilgi

preg_quote
preg_replace_callback
PCRE İşlevleri


Geriçağırım işlevi kullanarak düzenli ifadeye göre dizgede değişiklik yapar

preg_replace_callback_array
preg_replace
PCRE İşlevleri
PHP Manual

preg_replace_callback

(PHP 4 >= 4.0.5, PHP 5, PHP 7)

preg_replace_callback — Geriçağırım işlevi kullanarak düzenli ifadeye göre dizgede değişiklik yapar

Açıklama

mixed preg_replace_callback ( mixed $şablon , callback $geriçağırım , mixed $konu [, int $sınır = -1 [, int &$sayı ]] )

yenisi değiştirgesinin yerini bir geriçağırım işlevinin alması dışında, davranış bakımından preg_replace() işlevine hemen hemen eşdeğerdir.

Değiştirgeler

şablon

Aranacak şablon. Tek bir dizge olabileceği gibi çok sayıda dizge içeren bir dizi de olabilir.

geriçağırım

konu dizgesiyle eşleşen elemanlardan oluşan bir dizi ile çağrılıp yer değiştirilecek dizgeleri içeren bir dizi döndüren bir geriçağırım işlevinin ismi.

Genellikle geriçağırım işlevi preg_replace_callback() işlevinin çağrısı sırasında bir satıriçi işlev olarak kullanılır. Böyle bir durumda, geriçağırım işlevi olarak bir anonim işlev bildirimi için bir anonim işlev (PHP 5.3.0'dan beri) veya create_function() kullanılır. Böylece çağrı için gereken tüm bilgi tek bir yerde toplanmış olur ve bir daha başka bir yerde kullanılmayacak olan geriçağırım işlevi, işlev isim alanında kalabalık etmez.

Örnek 1 preg_replace_callback() ve create_function()

<?php
/* Paragraf başlangıcındaki büyük harfi küçük harfe çevirmek
   için bir Unix tarzı komut satırı uygulaması */
$fp = fopen("php://stdin", "r") or die("std girdi okunamadı");
while (!feof($fp)) {
    $line = fgets($fp);
    $line = preg_replace_callback(
        '|<p>\s*\w|',
        create_function(
            // Buradaki tek tırnaklar önemli yoksa
            // $ imlerini \$ olarak öncelemek gerekir.
            '$matches',
            'return strtolower($matches[0]);'
        ),
        $line
    );
    echo $line;
}
fclose($fp);
?>

konu

Şablonun aranacağı yer değiştirmeye konu dizge veya dizi.

sınır

Her konu dizgesinde her şablon için olası azami yer değiştirme sayısı. -1 öntanımlıdır (sınırsız).

sayı

Belirtildiği takdirde yapılan yer değiştirmelerin sayısı bu değiştirgeye konur.

Dönen Değerler

konu değiştirgesi bir dizi ise preg_replace_callback() de bir dizi döndürür aksi takdirde bir dizge döner. Hata durumunda daima NULL döner.

Eşleşmeler bulunduğu takdirde yeni konu döner, aksi takdirde bir hata oluşmamışsa konu değiştirilmeden döndürülür.

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.0 | sayı değiştirgesi eklendi.

Örnekler

Örnek 2 - 1. preg_replace_callback() örneği

<?php
// Bu metindeki 2002'yi 2003 yapacağız
$metin = "Zafer Bayramı 30/08/2002 tarihinde olacak,\n";
$metin.= "Cumhuriyet bayramı ise 29/10/2001 tarihinde idi.\n";
// geriçağırım işlevi
function gelecek_sene($eşleşenler)
{
  // normalde: $eşleşenler[0] eşleşmenin tamamını,
  // $eşleşenler[1] (...) içindeki ilk altşablonla eşleşen kısmı,
  // $eşleşenler[n] (...) içindeki n. altşablonla eşleşen kısmı içerir
  return $eşleşenler[1].($eşleşenler[2]+1);
}
echo preg_replace_callback(
            "|(\d{2}/\d{2}/)(\d{4})|",
            "gelecek_sene",
            $metin);

?>

Yukarıdaki örneğin çıktısı:

Zafer Bayramı 30/08/2003 tarihinde olacak,
Cumhuriyet bayramı ise 29/10/2002 tarihinde idi.

Örnek 3 - 2. preg_replace_callback() örneği

<?php
$input = "plain [indent] deep [indent] deeper [/indent] deep [/indent] plain";

function parseTagsRecursive($input)
{

    $regex = '#\[indent]((?:[^[]|\[(?!/?indent])|(?R))+)\[/indent]#';

    if (is_array($input)) {
        $input = '<div style="margin-left: 10px">'.$input[1].'</div>';
    }

    return preg_replace_callback($regex, 'parseTagsRecursive', $input);
}

$output = parseTagsRecursive($input);

echo $output;
?>

Ayrıca Bakınız

  • preg_replace() - Düzenli ifadeye göre dizgede değişiklik yapar
  • create_function() - Bir anonim (lamda tarzı) işlev oluşturur
  • callback türü hakkında bilgi

preg_replace_callback_array
preg_replace
PCRE İşlevleri


Düzenli ifadeye göre dizgede değişiklik yapar

preg_replace_callback
preg_split
PCRE İşlevleri
PHP Manual

preg_replace

(PHP 4, PHP 5, PHP 7)

preg_replace — Düzenli ifadeye göre dizgede değişiklik yapar

Açıklama

mixed preg_replace ( mixed $şablon , mixed $yenisi , mixed $konu [, int $sınır = -1 [, int &$sayı ]] )

konu dizgesini şablon ile eşleştirmeye çalışır ve bulduklarını yenisi ile değiştirir.

Değiştirgeler

şablon

Aranacak şablon. Tek bir dizge olabileceği gibi çok sayıda dizge içeren bir dizi de olabilir.

e değiştiricisi preg_replace() işlevinin, uygun geriye gönderimleri bulduktan sonra yenisi değiştirgesini bir PHP kodu olarak ele almasını sağlar. İpucu: yenisi değiştirgesinin bir PHP kod dizgesi içerdiğinden emin olun, aksi takdirde işlev, satırda bir çözümleme hatası verecektir.

yenisi

Yer değiştirme için kullanılacak dizge veya dizi. Eğer bir dizge belirtilmişse ve şablon bir dizi ise dizideki şablonlarla eşleşen tüm parçalara bu dizge yerleştirilir. Her iki değiştirgede de dizi belirtilmişse her şablon elemanı için kendine karşılık gelen yenisi elemanı yerleştirilir. Eğer yenisi dizisinde daha az eleman varsa, karşılığı olmayan şablon elemanları için boş dizge kullanılır.

yenisi değiştirgesi \\n veya (PHP 4.0.4'ten beri) $n, biçiminde geriye gönderimler içerebilir. Genellikle ikinci biçem tarcih edilir. Böyle her geriye gönderim n'inci yaylı ayraçlı şablon grubuyla yakalanan metne karşılıktır. n 0 ve 99 dahil bu ikisi arasında herhangi bir sayı olabilir ve \\0 veya $0 şablonun tamamıyla eşleşen dizgeye karşılık gelir. Açan yaylı ayraçlar ilki 1 olmak üzere soldan sağa doğru sayılarak bu sayılar yakalayan alt şablonların numaraları olurlar. yenisi değiştirgesinde tersbölü kullanılacaksa bunların öncelenmesi gerekir (PHP dizgesi olarak her tersbölü için "\\\\").

Bir yer değiştirme şablonu ile çalışırken, bir geriye gönderimin hemen ardından başka bir sayının gelmesi durumunda geriye gönderim için alışılagelen \\1 gösterimini kullanamazsınız. Örneğin \\11 için işlev sizin \\1 geriye gönderiminden sonra 1 mi koyduğunuzu yoksa ardına hiçbir sayı konulmamış \\11 geriye gönderimini mi belirttiğinizi bilemeyeceğinden işlev hata verecektir. Böyle bir durumda çözüm \${1}1 kullanmaktır. Böylece $1 geriye gönderimi ardından gelen 1 rakamından yalıtılmış olur.

e değiştiricisi kullanılırken, bu işlev geriye gönderimlerle değiştirilen dizgelerdeki bazı karakterleri (', ", \ ve NULL karakterlerini) tersbölü ile önceler. Bunun böyle yapılmasının sebebi, tek veya çift tırnak içine alınmış geriye gönderimlerin ('strlen(\'$1\')+strlen("$2")' gibi) sözdizimi hatası vermesine engel olmaktır. PHP'nin dizgeleri nasıl yorumladığını anlayabilmek için PHP'nin dizge sözdizimini iyi bilmeniz gerekir.

konu

Şablonun aranacağı yer değiştirmeye konu dizge veya dizi.

Eğer konu bir dizge ise arama ve değiştirme her eleman için ayrı ayrı yapılır ve sonuçlar da bir dizi olarak döndürülür.

sınır

Her konu dizgesinde her şablon için olası azami yer değiştirme sayısı. -1 öntanımlıdır (sınırsız).

sayı

Belirtildiği takdirde yapılan yer değiştirmelerin sayısı bu değiştirgeye konur.

Dönen Değerler

konu değiştirgesi bir dizi ise preg_replace() de bir dizi döndürür aksi takdirde bir dizge döner.

Eşleşmeler bulunduğu takdirde yeni konu döner, aksi takdirde bir hata oluşmamışsa konu değiştirilmeden döndürülür; bir hata oluşmuşsa NULL döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.0 | sayı değiştirgesi eklendi.
4.0.4 | yenisi değiştirgesi için '$n' biçimi eklendi
4.0.2 | sınır değiştirgesi eklendi.

Örnekler

Örnek 1 - Ardından bir sayı gelen geriye gönderim kullanımı

<?php
$dizge = 'April 15, 2003';
$şablon = '/(\w+) (\d+), (\d+)/i';
$yenisi = '${1}1,$3';
echo preg_replace($şablon, $yenisi, $dizge);
?>

Yukarıdaki örneğin çıktısı:

April1,2003

Örnek 2 - preg_replace() ile indisli dizi kullanımı

<?php
$dizge = 'The quick brown fox jumped over the lazy dog.';
$sablonlar[0] = '/quick/';
$sablonlar[1] = '/brown/';
$sablonlar[2] = '/fox/';
$yeniler[2] = 'bear';
$yeniler[1] = 'black';
$yeniler[0] = 'slow';
echo preg_replace($sablonlar, $yeniler, $dizge);
?>

Yukarıdaki örneğin çıktısı:

The bear black slow jumped over the lazy dog.

Şablonlarla yenileri ksorting ile sıralarsak istediğimiz olur.

<?php
ksort($sablonlar);
ksort($yeniler);
echo preg_replace($sablonlar, $yeniler, $dizge);
?>

Yukarıdaki örneğin çıktısı:

The slow black bear jumped over the lazy dog.

Örnek 3 - Çeşitli değerlerin değiştirilmesi

<?php
$sablonlar = array ('/(19|20)(\d{2})-(\d{1,2})-(\d{1,2})/',
                   '/^\s*{(\w+)}\s*=/');
$yeniler = array ('\3/\4/\1\2', '$\1 =');
echo preg_replace($sablonlar, $yeniler, '{startDate} = 1999-5-27');
?>

Yukarıdaki örneğin çıktısı:

$startDate = 5/27/1999

Örnek 4 - 'e' değiştiricisinin kullanımı

<?php
preg_replace("/(<\/?)(\w+)([^>]*>)/e",
             "'\\1'.strtoupper('\\2').'\\3'",
             $html_body);
?>

Bu, girdi metnindeki tüm HTML etiketlerini büyük harfli yapacaktır.

Örnek 5 - Boşluk ayıklama

Bu örnekte dizgedeki fazladan boşluklar temizlenmektedir.

<?php
$str = 'foo   o';
$str = preg_replace('/\s\s+/', ' ', $str);
// 'foo o' basılacak
echo $str;
?>

Örnek 6 - sayı değiştirgesinin kullanımı

<?php
$count = 0;

echo preg_replace(array('/\d/', '/\s/'), '*', 'xp 4 to', -1 , $sayı);
echo $count; //3
?>

Yukarıdaki örneğin çıktısı:

xp***to
3

Notlar

Bilginize:

şablon ve yenisi değiştirgelerinde dizi kullanıldığında anahtarlar dizide yer aldıkları sırayla işlenirler. Bunun sayısal indis sırasında olması şart değildir. Hangi şablon'un yenisi'nin ne olacağını indis sırasına göre belirlemek isterseniz preg_replace() işlevini çağırmadan önce her iki diziyi de ksort() işlevinden geçirmelisiniz.

Ayrıca Bakınız

  • preg_filter() - Bir düzenli ifade arama ve değiştirmesi yapar
  • preg_match() - Bir düzenli ifadeyi eşleştirmeye çalışır
  • preg_replace_callback() - Geriçağırım işlevi kullanarak düzenli ifadeye göre dizgede değişiklik yapar
  • preg_split() - Dizgeyi düzenli ifadeye göre böler

preg_replace_callback
preg_split
PCRE İşlevleri


Dizgeyi düzenli ifadeye göre böler

preg_replace
POSIX Düzenli İfadeleri
PCRE İşlevleri
PHP Manual

preg_split

(PHP 4, PHP 5, PHP 7)

preg_split — Dizgeyi düzenli ifadeye göre böler

Açıklama

array preg_split ( string $şablon , string $konu [, int $sınır = -1 [, int $seçenekler = 0 ]] )

Belirtilen dizgeyi belirtilen düzenli ifadeye göre parçalara ayırır.

Değiştirgeler

şablon

Bir dizge olarak aranacak şablon.

konu

Parçalara ayrılacak dizge.

sınır

Belirtildiği takdirde sadece sınır sayıda alt dizge döner. sınır olarak -1, 0 veya NULL belirtilmişse herhangi bir sayı sınırlaması yok demektir ve genellikle seçenekler değiştirgesinin belirtilmesinin gerekli olduğu durumlarda kullanılır.

seçenekler

seçenekler olarak, bit seviyesinde VEYA ( | ) işleci ile birleştirilerek şunlar belirtilebilir:

PREG_SPLIT_NO_EMPTY
Etkin olduğunda işlev tarafından sadece boş olmayan parçalar döndürülür.
PREG_SPLIT_DELIM_CAPTURE
Etkin olduğunda şablon içindeki yaylı ayraçlı ifade yakalanıp döndürülür.
PREG_SPLIT_OFFSET_CAPTURE

Etkin olduğunda, eşleşmenin olduğu son dizgenin başlangıç konumu da döndürülür. Bu seçenek dönen dizideki değeri değiştirir. Dizideki her eleman, 0 indisinde eşleşen alt dizge, 1 indisinde ise alt dizgenin konu içindeki başlangıcını içeren bir diziden oluşur.

Dönen Değerler

konu dizgesinin şablon ile eşleşen parçalarını içeren bir dizi döner.

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.0 | PREG_SPLIT_OFFSET_CAPTURE eklendi.
4.0.5 | PREG_SPLIT_DELIM_CAPTURE eklendi.
4.0.0 | seçenekler değiştirgesi eklendi.

Örnekler

Örnek 1 - preg_split() örneği

<?php
// Cümleyi virgül ve boşluk (" ", \r, \t, \n ve \f)
// karakterlerine göre parçalar.
$keywords = preg_split("/[\s,]+/", "hypertext language, programming");
?>

Örnek 2 - Bir dizgeyi karakterlerine bölmek

<?php
$str = 'string';
$chars = preg_split('//', $str, -1, PREG_SPLIT_NO_EMPTY);
print_r($chars);
?>

Örnek 3 - Bir dizgeyi sözcüklerine ayırıp başlangıçlarıyla döndürmek

<?php
$str = 'hypertext language programming';
$chars = preg_split('/ /', $str, -1, PREG_SPLIT_OFFSET_CAPTURE);
print_r($chars);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [0] => Array
        (
            [0] => hypertext
            [1] => 0
        )

    [1] => Array
        (
            [0] => language
            [1] => 10
        )

    [2] => Array
        (
            [0] => programming
            [1] => 19
        )

)

Notlar

İpucu

Düzenli ifadelerin gücünün gerekli olmadığı durumlar için explode(), str_split() işlevleri daha kullanışlı olabilir.

Ayrıca Bakınız

  • spliti() - Belirtilen dizgeyi harf büyüklüğüne duyarsız olarak düzenli ifadeye göre dizi elemanlarına böler
  • split() - Belirtilen dizgeyi düzenli ifadeye göre dizi elemanlarına böler
  • implode() - Dizi elemanlarını birleştirip bir dizge elde eder
  • preg_match() - Bir düzenli ifadeyi eşleştirmeye çalışır
  • preg_match_all() - Kapsamlı bir düzenli ifade eşleştirmesi yapar
  • preg_replace() - Düzenli ifadeye göre dizgede değişiklik yapar

preg_replace
POSIX Düzenli İfadeleri
PCRE İşlevleri


Düzenli İfadeler (Gelişmiş POSIX)

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
  • POSIX Düzenli İfade İşlevleri
    • ereg_replace — Düzenli ifadeye göre dizgede değişiklik yapar
    • ereg — Düzenli ifadeyi eşleştirir
    • eregi_replace — Düzenli ifadeye göre dizgede harf büyüklüğüne duyarsız olarak değişiklik yapar
    • eregi — Düzenli ifadeyi harf büyüklüğüne duyarsız olarak eşleştirir
    • split — Belirtilen dizgeyi düzenli ifadeye göre dizi elemanlarına böler
    • spliti — Belirtilen dizgeyi harf büyüklüğüne duyarsız olarak düzenli ifadeye göre dizi elemanlarına böler
    • sql_regcase — Harf büyüklüğüne duyarsız eşleşme için düzenli ifade oluşturur
preg_split
Giriş
Metin İşleme


Giriş

İpucu

PHP ayrıca, POSIX düzenli ifadelerinden başka Perl uyumlu bir sözdizimi kullanan PCRE işlevlerini de desteklemektedir. Bu işlevler, açgözlü olmayan eşlemeler, savlar, koşullu alt kalıplar yanında gelişkin POSIX düzenli ifade sözdizimi tarafından desteklenmeyen bir takım başka özellikleri de destekler.

Uyarı

Bu düzenli ifade işlevleri ikil bakımdan güvenilir olmadığı halde PCRE işlevleri güvenilirdir.

Bilginize:

PHP 5.3.0'dan itibaren bu eklentinin kullanımı önerilmemektedir. Bu eklenti tarafından sağlanan işlevlerden biri çağrıldığında bir E_DEPRECATED iletisi çıktılanır.

Düzenli ifadeler karmaşık dizge değişiklikleri için kullanılır. PHP, gelişkin POSIX düzenli ifadelerini POSIX 1003.2 tarafından tanımlandığı şekliyle destekler. POSIX düzenli ifadelerinin tam açıklaması için PHP dağıtımının regex dizininde bulunan » regex kılavuz sayfasına bakınız. Bir kılavuz sayfası olması nedeniyle kabukta man /usr/local/src/regex/regex.7 komutunu vererek okuyabilirsiniz.

POSIX Düzenli İfadeleri
Yapılandırma/Kurulum
POSIX Düzenli İfadeleri


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
POSIX Düzenli İfadeleri


Kurulum

POSIX düzenli ifadelerini etkin kılmak için PHP'yi derlemek için yapılandırırken --with-regex[=TÜR] seçeneği kullanılmalıdır. TÜR, öntanımlı olarak php olup, system, apache veya php değerlerini alabilir.

Uyarı

Ne yaptığınızdan emin değilseniz, TÜR yerine bir şey yazmayınız.

PHP'nin Windows sürümünde bu eklenti yerleşik olarak gelmektedir. Bu işlevleri Windows'ta kullanmak için herhangi bir eklenti kurmanıza gerek yoktur.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
Örnekler
POSIX Düzenli İfadeleri


Örnekler

Örnek 1 Düzenli İfade Örnekleri

<?php
// $string içinde "abc" varsa TRUE döner.
ereg("abc", $string);

// $string başlangıcında "abc" varsa TRUE döner.
ereg("^abc", $string);

// $string sonunda "abc" varsa TRUE döner.
ereg("abc$", $string);

// İstemcinin tarayıcısı Netscape 2, 3 veya MSIE 3 ise  TRUE döner.
eregi("(ozilla.[23]|MSIE.3)", $_SERVER["HTTP_USER_AGENT"]);

// Boşluk karakteri ile ayrılmış üç sözcüğü
// $regs[1], $regs[2] ve $regs[3]'e yerleştirir.
ereg("([[:alnum:]]+) ([[:alnum:]]+) ([[:alnum:]]+)", $string, $regs);

// $string başlangıcına bir <br /> etiketi yerleştirir.
$string = ereg_replace("^", "<br />", $string);

// $string sonuna bir <br /> etiketi yerleştirir.
$string = ereg_replace("$", "<br />", $string);

// $string içindeki satırsonu karakterlerini siler.
$string = ereg_replace("\n", "", $string);
?>

Öntanımlı Sabitler
POSIX Düzenli İfade İşlevleri
POSIX Düzenli İfadeleri


POSIX Düzenli İfade İşlevleri

Ayrıca Bakınız

Perl uyumlu düzenli ifade sözdizimini kullanan düzenli ifadeler için PCRE İşlevleri bölümüne bakın. Daha basit kabuk tarzı dosya eşleme kalıpları ise fnmatch() işlevi ile sağlanmıştır.

İçindekiler

  • ereg_replace — Düzenli ifadeye göre dizgede değişiklik yapar
  • ereg — Düzenli ifadeyi eşleştirir
  • eregi_replace — Düzenli ifadeye göre dizgede harf büyüklüğüne duyarsız olarak değişiklik yapar
  • eregi — Düzenli ifadeyi harf büyüklüğüne duyarsız olarak eşleştirir
  • split — Belirtilen dizgeyi düzenli ifadeye göre dizi elemanlarına böler
  • spliti — Belirtilen dizgeyi harf büyüklüğüne duyarsız olarak düzenli ifadeye göre dizi elemanlarına böler
  • sql_regcase — Harf büyüklüğüne duyarsız eşleşme için düzenli ifade oluşturur
Örnekler
ereg_replace
POSIX Düzenli İfadeleri


Düzenli ifadeye göre dizgede değişiklik yapar

POSIX Düzenli İfade İşlevleri
ereg
POSIX Düzenli İfade İşlevleri
PHP Manual

ereg_replace

(PHP 4, PHP 5)

ereg_replace — Düzenli ifadeye göre dizgede değişiklik yapar

Açıklama

string ereg_replace ( string $şablon , string $yenisi , string $dizge )

Bu işlev dizge dizgesi içinde şablon düzenli ifadesini arar ve eşleşen metnin yerine yenisi'ni yerleştirir.

Uyarı

Evrenkod uyumsuzluğu nedeniyle bu işlevin kullanımı PHP 5.3.0'dan beri ÖNERİLMEMEKTEDİR.

Değiştirgeler

şablon

Bir POSIX gelişkin düzenli ifadesi.

yenisi

Eğer şablon parantezli gruplar içeriyorsa yenisi değiştirgesi \\rakam biçeminde bir dizge içerebilir. Burada rakam, parantezli grubun şablonun solundan itibaren kaçıncı grup olduğunu gösterir. \\0 değeri dizgenin tamamınına karşılıktır. Böyle 9 alt dizge belirtilebilir. Parantezler iç içe olabilir, bu durumda aç parantezler sayılır.

dizge

Girdi dizgesi.

Dönen Değerler

Değiştirilen dizgeyi döndürür. Dizge ile eşleşme sağlanamamışsa dizgenin kendisini değiştirmeden döndürür.

Örnekler

Örneğin, aşağıdaki kod parçası üç kere "This was a test" basacaktır.

Örnek 1 - ereg_replace() örneği - 1

<?php

$string = "This is a test";
echo str_replace(" is", " was", $string);
echo ereg_replace("( )is", "\\1was", $string);
echo ereg_replace("(( )is)", "\\2was", $string);

?>

Burada dikkat edilmesi gereken, yenisi değiştirgesinde bir tamsayı belirtirseniz beklenmedik sonuçlar alabilecek olmanızdır. Bunun sebebi, ereg_replace() işlevinin sayıyı sıradan bir karakter değeri olarak yorumlaması ve buna göre davranmasıdır. Örnek:

Örnek 2 - ereg_replace() örneği - 2

<?php
/* Bu beklendiği gibi çalışmaz. */
$num = 4;
$string = "This string has four words.";
$string = ereg_replace('four', $num, $string);
echo $string;   /* Çıktısı: 'This string has   words.' */

/* Bu çalışır. */
$num = '4';
$string = "This string has four words.";
$string = ereg_replace('four', $num, $string);
echo $string;   /* Çıktısı: 'This string has 4 words.' */
?>

Örnek 3 - URL'den bağlantı oluşturma

<?php
$text = ereg_replace("[[:alpha:]]+://[^<>[:space:]]+[[:alnum:]/]",
                     "<a href=\"\\0\">\\0</a>", $text);
?>

Notlar

Bilginize:

PHP 5.3.0 ve sonrasında regex eklentisinin kullanımı artık önerilmemekte olup yerine PCRE eklentisinin kullanılması önerilmekte ve bu işleve yapılan çağrılar bu nedenle bir E_DEPRECATED uyarısı çıktılamaktadır.PCRE'ye dönüşümü kolaylaştırmak için fark listesine bakınız.

İpucu

Perl uyumlu düzenli ifade sözdizimini kullanan preg_replace() işlevi çoğu durumda ereg_replace() işlevinden daha hızlıdır.

Ayrıca Bakınız

  • ereg() - Düzenli ifadeyi eşleştirir
  • eregi() - Düzenli ifadeyi harf büyüklüğüne duyarsız olarak eşleştirir
  • eregi_replace() - Düzenli ifadeye göre dizgede harf büyüklüğüne duyarsız olarak değişiklik yapar
  • str_replace() - Bir alt dizgenin bütün örneklerini yenisiyle değiştirir
  • preg_match() - Bir düzenli ifadeyi eşleştirmeye çalışır

POSIX Düzenli İfade İşlevleri
ereg
POSIX Düzenli İfade İşlevleri


Düzenli ifadeyi eşleştirir

ereg_replace
eregi_replace
POSIX Düzenli İfade İşlevleri
PHP Manual

ereg

(PHP 4, PHP 5)

ereg — Düzenli ifadeyi eşleştirir

Açıklama

int ereg ( string $şablon , string $dizge [, array &$gruplar ] )

Belirtilen dizge içinde harf büyüklüğüne duyarlı olarak şablon düzenli ifadesini eşleştirmeye çalışır.

Uyarı

Evrenkod uyumsuzluğu nedeniyle bu işlevin kullanımı PHP 5.3.0'dan beri ÖNERİLMEMEKTEDİR.

Değiştirgeler

şablon

Harf büyüklüğüne duyarlı düzenli ifade.

dizge

Girdi dizgesi.

gruplar

şablon içindeki parantezli alt gruplarla eşleşme sağlanırsa ve işlev bu değiştirge belirtilerek çağrılmışsa eşleşen gruplar gruplar dizisinin elemanlarına yerleştirilir.

$gruplar[1] soldan itibaren ilk parantezli grupla eşleşen alt dizgeyi, $gruplar[2] ikincisini, vb. içerecektir. $gruplar[0] eşleşen dizgenin tamamını içerir.

Dönen Değerler

şablon, dizge içinde bulunmuşsa eşleşen dizgenin uzunluğu, eşleşme sağlanamazsa veya bir hata oluşursa FALSE döner.

Seçimlik gruplar değiştirgesi aktarılmamışsa veya eşleşen dizge uzunluğu 0 ise bu işlev 1 değerini döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
4.1.0 | PHP 4.1.0 ve öncesinde $gruplar dizisinin (fazlası da azı da eşleşse) daima 10 elemanı doldurulurdu . Bunun, ereg() işlevinin daha fazla alt dizge eşleştirme yeteneğine bir etkisi yoktur. Eğer hiçbir eşleşme bulunamazsa işlev, $gruplar üzerinde hiçbir değişiklik yapmayacaktır.

Örnekler

Örnek 1 - ereg() örneği

Aşağıdaki betik ISO biçemli bir tarih dizgesi (YYYY-MM-DD) alır ve bunu DD.MM.YYYY biçeminde basar:

<?php
if (ereg ("([0-9]{4})-([0-9]{1,2})-([0-9]{1,2})", $tarih, $gruplar)) {
    echo "$gruplar[3].$gruplar[2].$gruplar[1]";
} else {
    echo "Tarih biçemi geçersiz: $tarih";
}
?>

Notlar

Bilginize:

PHP 5.3.0 ve sonrasında regex eklentisinin kullanımı artık önerilmemekte olup yerine PCRE eklentisinin kullanılması önerilmekte ve bu işleve yapılan çağrılar bu nedenle bir E_DEPRECATED uyarısı çıktılamaktadır.PCRE'ye dönüşümü kolaylaştırmak için fark listesine bakınız.

Bilginize:

Perl uyumlu düzenli ifade sözdizimini kullanan preg_match() işlevi çoğu durumda ereg() işlevinden daha hızlıdır.

Ayrıca Bakınız

  • eregi() - Düzenli ifadeyi harf büyüklüğüne duyarsız olarak eşleştirir
  • ereg_replace() - Düzenli ifadeye göre dizgede değişiklik yapar
  • eregi_replace() - Düzenli ifadeye göre dizgede harf büyüklüğüne duyarsız olarak değişiklik yapar
  • preg_match() - Bir düzenli ifadeyi eşleştirmeye çalışır
  • strpos() - Bir alt dizgenin ilkinin konumunu bulur
  • strstr() - İlk alt dizgeyi bulur
  • quotemeta() - Özel anlamı olan karakterleri tersbölü ile önceler

ereg_replace
eregi_replace
POSIX Düzenli İfade İşlevleri


Düzenli ifadeye göre dizgede harf büyüklüğüne duyarsız olarak değişiklik yapar

ereg
eregi
POSIX Düzenli İfade İşlevleri
PHP Manual

eregi_replace

(PHP 4, PHP 5)

eregi_replace — Düzenli ifadeye göre dizgede harf büyüklüğüne duyarsız olarak değişiklik yapar

Açıklama

string eregi_replace ( string $şablon , string $yenisi , string $dizge )

Harflerle eşleştirme sırasında harf büyüklüğünü dikkate almaması dışında ereg_replace() işlevi gibidir.

Uyarı

Evrenkod uyumsuzluğu nedeniyle bu işlevin kullanımı PHP 5.3.0'dan beri ÖNERİLMEMEKTEDİR.

Değiştirgeler

şablon

Bir POSIX gelişkin düzenli ifadesi.

yenisi

Eğer şablon parantezli gruplar içeriyorsa yenisi değiştirgesi \\rakam biçeminde bir dizge içerebilir. Burada rakam, parantezli grubun şablonun solundan itibaren kaçıncı grup olduğunu gösterir. \\0 değeri dizgenin tamamınına karşılıktır. Böyle 9 alt dizge belirtilebilir. Parantezler iç içe olabilir, bu durumda aç parantezler sayılır.

dizge

Girdi dizgesi.

Dönen Değerler

Değiştirilen dizgeyi döndürür. Dizge ile eşleşme sağlanamamışsa dizgenin kendisini değiştirmeden döndürür.

Örnekler

Örnek 1 - Arama sonuçlarını göster

<?php
$pattern = '(>[^<]*)('. quotemeta($_GET['search']) .')';
$replacement = '\\1<span class="search">\\2</span>';
$body = eregi_replace($pattern, $replacement, $body);
?>

Notlar

Bilginize:

PHP 5.3.0 ve sonrasında regex eklentisinin kullanımı artık önerilmemekte olup yerine PCRE eklentisinin kullanılması önerilmekte ve bu işleve yapılan çağrılar bu nedenle bir E_DEPRECATED uyarısı çıktılamaktadır.PCRE'ye dönüşümü kolaylaştırmak için fark listesine bakınız.

Ayrıca Bakınız

  • ereg() - Düzenli ifadeyi eşleştirir
  • eregi() - Düzenli ifadeyi harf büyüklüğüne duyarsız olarak eşleştirir
  • ereg_replace() - Düzenli ifadeye göre dizgede değişiklik yapar

ereg
eregi
POSIX Düzenli İfade İşlevleri


Düzenli ifadeyi harf büyüklüğüne duyarsız olarak eşleştirir

eregi_replace
split
POSIX Düzenli İfade İşlevleri
PHP Manual

eregi

(PHP 4, PHP 5)

eregi — Düzenli ifadeyi harf büyüklüğüne duyarsız olarak eşleştirir

Açıklama

int eregi ( string $şablon , string $dizge [, array &$gruplar ] )

Harflerle eşleştirme sırasında harf büyüklüğünü dikkate almaması dışında ereg() işlevi gibidir.

Uyarı

Evrenkod uyumsuzluğu nedeniyle bu işlevin kullanımı PHP 5.3.0'dan beri ÖNERİLMEMEKTEDİR.

Değiştirgeler

şablon

Harf büyüklüğüne duyarsız düzenli ifade.

dizge

Girdi dizgesi.

gruplar

şablon içindeki parantezli alt gruplarla eşleşme sağlanırsa ve işlev bu değiştirge belirtilerek çağrılmışsa eşleşen gruplar gruplar dizisinin elemanlarına yerleştirilir.

$gruplar[1] soldan itibaren ilk parantezli grupla eşleşen alt dizgeyi, $gruplar[2] ikincisini, vb. içerecektir. $gruplar[0] eşleşen dizgenin tamamını içerir.

Dönen Değerler

şablon, dizge içinde bulunmuşsa eşleşen dizgenin uzunluğu, eşleşme sağlanamazsa veya bir hata oluşursa FALSE döner.

Seçimlik gruplar değiştirgesi aktarılmamışsa veya eşleşen dizge uzunluğu 0 ise bu işlev 1 değerini döndürür.

Örnekler

Örnek 1 - eregi() örneği

<?php
$string = 'XYZ';
if (eregi('z', $string)) {
    echo "'$string' dizgesi bir 'z' veya 'Z' içeriyor!";
}
?>

Notlar

Bilginize:

PHP 5.3.0 ve sonrasında regex eklentisinin kullanımı artık önerilmemekte olup yerine PCRE eklentisinin kullanılması önerilmekte ve bu işleve yapılan çağrılar bu nedenle bir E_DEPRECATED uyarısı çıktılamaktadır.PCRE'ye dönüşümü kolaylaştırmak için fark listesine bakınız.

Ayrıca Bakınız

  • ereg() - Düzenli ifadeyi eşleştirir
  • ereg_replace() - Düzenli ifadeye göre dizgede değişiklik yapar
  • eregi_replace() - Düzenli ifadeye göre dizgede harf büyüklüğüne duyarsız olarak değişiklik yapar
  • stripos() - Harf büyüklüğüne duyarsız olarak bir alt dizgenin ilkinin konumunu bulur
  • stristr() - Harf büyüklüğüne duyarsız olarak ilk alt dizgeyi bulur

eregi_replace
split
POSIX Düzenli İfade İşlevleri


Belirtilen dizgeyi düzenli ifadeye göre dizi elemanlarına böler

eregi
spliti
POSIX Düzenli İfade İşlevleri
PHP Manual

split

(PHP 4, PHP 5)

split — Belirtilen dizgeyi düzenli ifadeye göre dizi elemanlarına böler

Açıklama

array split ( string $şablon , string $dizge [, int $sınır ] )

Belirtilen dizgeyi düzenli ifadeye göre dizi elemanlarına böler.

Uyarı

Evrenkod uyumsuzluğu nedeniyle bu işlevin kullanımı PHP 5.3.0'dan beri ÖNERİLMEMEKTEDİR.

Değiştirgeler

şablon

Harf büyüklüğüne duyarlı düzenli ifade.

Düzenli ifadelere özgü karakterlerden birine göre bölme yapmak isterseniz o karakteri öncelemeniz gerekir. Eğer split() işlevinin (veya bu konu ile ilgili diğer düzenli ifade işlevlerinin) tuhaf şeyler yaptığını düşünüyorsanız, PHP dağıtımının regex/ alt dizininde bulunan regex.7 kılavuz sayfasını okuyunuz. Bir kılavuz sayfası olması nedeniyle kabukta man /usr/local/src/regex/regex.7 komutunu vererek dosyayı okuyabilirsiniz.

dizge

Girdi dizgesi.

sınır

Bu değiştirge belirtilmişse, son elemanında dizge'nin kalanını içermek üzere en fazla sınır sayıda eleman içeren bir dizi dönecektir.

Dönen Değerler

Her elemanında, dizge dizgesinin, sınırları harf büyüklüğüne duyarlı şablon düzenli ifadesine göre belirlenen, alt dizgelerini içeren bir dizi döner.

şablon ile eşleşen n alt dizge varsa dönen dizi n+1 eleman içerecektir. Örneğin, şablon ile eşleşen hiçbir alt dizge yoksa, işlev tek elemanlı bir dizi döndürecektir. Bu durum dizge dizgesinin boş olduğu durumda da geçerlidir. Bir hata oluşursa işlev FALSE döndürür.

Örnekler

Örnek 1 - split() örneği - 1

/etc/passwd dosyasının her satırındaki ilk dört alanı seçmek için:

<?php
list($kullanıcı, $parola, $uid, $gid, $ek) =
    split(":", $passwd_line, 5);
?>

Örnek 2 - split() örneği - 2

Bölü çizgisi, nokta ve tire ile ayrılan tarih alanlarını ayrıştırmak için:

<?php
// Ayraçları bölü çizgisi, nokta veya tire olabilir
$tarih = "04/30/1973";
list($ay, $gün, $yıl) = split('[/.-]', $tarih);
echo "Ay: $ay; Gün: $gün; Yıl: $yıl<br />\n";
?>

Notlar

Bilginize:

PHP 5.3.0 ve sonrasında regex eklentisinin kullanımı artık önerilmemekte olup yerine PCRE eklentisinin kullanılması önerilmekte ve bu işleve yapılan çağrılar bu nedenle bir E_DEPRECATED uyarısı çıktılamaktadır.PCRE'ye dönüşümü kolaylaştırmak için fark listesine bakınız.

İpucu

Perl uyumlu düzenli ifade sözdizimini kullanan preg_split() işlevi çoğunlukla bu işlevden daha hızlıdır. Bir düzenli ifadenin çok da gerekmediği yerlerde düzenli ifade motorunu yormayan explode() işlevi çok daha hızlıdır.

İpucu

Perl'in @chars = split('', $str) davranışını taklit etmek için bir yol arayışında olanların preg_split() veya str_split() işlevlerinin örneklerine bakmaları önerilir.

Ayrıca Bakınız

  • preg_split() - Dizgeyi düzenli ifadeye göre böler
  • spliti() - Belirtilen dizgeyi harf büyüklüğüne duyarsız olarak düzenli ifadeye göre dizi elemanlarına böler
  • str_split() - Bir dizgeyi bir diziye dönüştürür
  • explode() - Bir dizgeyi bir ayraca göre bölüp bir dizi haline getirir
  • implode() - Dizi elemanlarını birleştirip bir dizge elde eder
  • chunk_split() - Bir dizgeyi daha küçük parçalara ayırır
  • wordwrap() - Bir dizgeyi belli bir uzunlukta katlar

eregi
spliti
POSIX Düzenli İfade İşlevleri


Belirtilen dizgeyi harf büyüklüğüne duyarsız olarak düzenli ifadeye göre dizi elemanlarına böler

split
sql_regcase
POSIX Düzenli İfade İşlevleri
PHP Manual

spliti

(PHP 4 >= 4.0.1, PHP 5)

spliti — Belirtilen dizgeyi harf büyüklüğüne duyarsız olarak düzenli ifadeye göre dizi elemanlarına böler

Açıklama

array spliti ( string $şablon , string $dizge [, int $sınır ] )

Belirtilen dizgeyi harf büyüklüğüne duyarsız düzenli ifadeye göre dizi elemanlarına böler.

Harfleri eşleştirirken harf büyüklüğünü dikkate almaması dışında split() işlevi ile aynıdır.

Uyarı

Evrenkod uyumsuzluğu nedeniyle bu işlevin kullanımı PHP 5.3.0'dan beri ÖNERİLMEMEKTEDİR.

Değiştirgeler

şablon

Harf büyüklüğüne duyarsız düzenli ifade.

Düzenli ifadelere özgü karakterlerden birine göre bölme yapmak isterseniz o karakteri öncelemeniz gerekir. Eğer spliti() işlevinin (veya bu konu ile ilgili diğer düzenli ifade işlevlerinin) tuhaf şeyler yaptığını düşünüyorsanız, PHP dağıtımının regex/ alt dizininde bulunan regex.7 kılavuz sayfasını okuyunuz. Bir kılavuz sayfası olması nedeniyle kabukta man /usr/local/src/regex/regex.7 komutunu vererek dosyayı okuyabilirsiniz.

dizge

Girdi dizgesi.

sınır

Bu değiştirge belirtilmişse, son elemanında dizge'nin kalanını içermek üzere en fazla sınır sayıda eleman içeren bir dizi dönecektir.

Dönen Değerler

Her elemanında, dizge dizgesinin, sınırları harf büyüklüğüne duyarsız şablon düzenli ifadesine göre belirlenen, alt dizgelerini içeren bir dizi döner.

şablon ile eşleşen n alt dizge varsa dönen dizi n+1 eleman içerecektir. Örneğin, şablon ile eşleşen hiçbir alt dizge yoksa, işlev tek elemanlı bir dizi döndürecektir. Bu durum dizge dizgesinin boş olduğu durumda da geçerlidir. Bir hata oluşursa işlev FALSE döndürür.

Örnekler

Bu örnekte, dizge 'a' harfi ayraç olarak kullanılarak ayrıştırılmaktadır:

Örnek 1 - spliti() örneği

<?php
$string = "aBBBaCCCADDDaEEEaGGGA";
$chunks = spliti ("a", $string, 5);
print_r($chunks);
?>

Yukarıdaki örneğin çıktısı:

Array
(
  [0] =>
  [1] => BBB
  [2] => CCC
  [3] => DDD
  [4] => EEEaGGGA
)

Notlar

Bilginize:

PHP 5.3.0 ve sonrasında regex eklentisinin kullanımı artık önerilmemekte olup yerine PCRE eklentisinin kullanılması önerilmekte ve bu işleve yapılan çağrılar bu nedenle bir E_DEPRECATED uyarısı çıktılamaktadır.PCRE'ye dönüşümü kolaylaştırmak için fark listesine bakınız.

Ayrıca Bakınız

  • preg_split() - Dizgeyi düzenli ifadeye göre böler
  • split() - Belirtilen dizgeyi düzenli ifadeye göre dizi elemanlarına böler
  • explode() - Bir dizgeyi bir ayraca göre bölüp bir dizi haline getirir
  • implode() - Dizi elemanlarını birleştirip bir dizge elde eder

split
sql_regcase
POSIX Düzenli İfade İşlevleri


Harf büyüklüğüne duyarsız eşleşme için düzenli ifade oluşturur

spliti
ssdeep
POSIX Düzenli İfade İşlevleri
PHP Manual

sql_regcase

(PHP 4, PHP 5)

sql_regcase — Harf büyüklüğüne duyarsız eşleşme için düzenli ifade oluşturur

Açıklama

string sql_regcase ( string $dizge )

Harf büyüklüğüne duyarsız eşleşme için düzenli ifade oluşturur.

Uyarı

Evrenkod uyumsuzluğu nedeniyle bu işlevin kullanımı PHP 5.3.0'dan beri ÖNERİLMEMEKTEDİR.

Değiştirgeler

dizge

Girdi dizgesi.

Dönen Değerler

dizge ile harf büyüklüğüne duyarsız olarak eşleşecek bir düzenli ifade döndürür. Bu ifade, dizge dizgesinin her harfinin bir köşeli ayraç ifadesine dönüştürülmesiyle elde edilir; bu köşeli ayraç ifadesi karakterin büyük ve küçük harflerini içerir. Harf olmayan karakterler oldukları gibi bırakılırlar.

Örnekler

Örnek 1 - sql_regcase() örneği

<?php
echo sql_regcase("Foo - bar.");
?>

Yukarıdaki örneğin çıktısı:

[Ff][Oo][Oo] - [Bb][Aa][Rr].

Sadece harf büyüklüğüne duyarlı düzenli ifadelerin desteklendiği durumlarda harf büyüklüğüne duyarsız eşleşmeleri kullanmak için yararlıdır.

Notlar

Bilginize:

PHP 5.3.0 ve sonrasında regex eklentisinin kullanımı artık önerilmemekte olup yerine PCRE eklentisinin kullanılması önerilmekte ve bu işleve yapılan çağrılar bu nedenle bir E_DEPRECATED uyarısı çıktılamaktadır.PCRE'ye dönüşümü kolaylaştırmak için fark listesine bakınız.

spliti
ssdeep
POSIX Düzenli İfade İşlevleri


ssdeep Fuzzy Hashing

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • ssdeep İşlevleri
    • ssdeep_fuzzy_compare — Calculates the match score between two fuzzy hash signatures
    • ssdeep_fuzzy_hash_filename — Create a fuzzy hash from a file
    • ssdeep_fuzzy_hash — Create a fuzzy hash from a string
sql_regcase
Giriş
Metin İşleme


Giriş

ssdeep is a utility for creating and comparing fuzzy hashes or » context-triggered piecewise hashing.

Fuzzy hashing can match signatures which have "...sequences of identical bytes in the same order, although bytes in between these sequences may be different in both content and length". (» ssdeep project page)

This extension provides functions for creating and comparing fuzzy hashes.

ssdeep
Yapılandırma/Kurulum
ssdeep


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
ssdeep


Gereksinimler

This extension requires the » ssdeep library.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu » PECL eklentisi PHP ile gelmez.

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/ssdeep.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
ssdeep İşlevleri
ssdeep


ssdeep İşlevleri

İçindekiler

  • ssdeep_fuzzy_compare — Calculates the match score between two fuzzy hash signatures
  • ssdeep_fuzzy_hash_filename — Create a fuzzy hash from a file
  • ssdeep_fuzzy_hash — Create a fuzzy hash from a string
Öntanımlı Sabitler
ssdeep_fuzzy_compare
ssdeep


Calculates the match score between two fuzzy hash signatures

ssdeep İşlevleri
ssdeep_fuzzy_hash_filename
ssdeep İşlevleri
PHP Manual

ssdeep_fuzzy_compare

(PECL ssdeep >= 1.0.0)

ssdeep_fuzzy_compare — Calculates the match score between two fuzzy hash signatures

Açıklama

int ssdeep_fuzzy_compare ( string $signature1 , string $signature2 )

Calculates the match score between signature1 and signature2 using » context-triggered piecewise hashing, and returns the match score.

Değiştirgeler

signature1

The first fuzzy hash signature string.

signature2

The second fuzzy hash signature string.

Dönen Değerler

Returns an integer from 0 to 100 on success, FALSE otherwise.

ssdeep İşlevleri
ssdeep_fuzzy_hash_filename
ssdeep İşlevleri


Create a fuzzy hash from a file

ssdeep_fuzzy_compare
ssdeep_fuzzy_hash
ssdeep İşlevleri
PHP Manual

ssdeep_fuzzy_hash_filename

(PECL ssdeep >= 1.0.0)

ssdeep_fuzzy_hash_filename — Create a fuzzy hash from a file

Açıklama

string ssdeep_fuzzy_hash_filename ( string $file_name )

ssdeep_fuzzy_hash_filename() calculates the hash of the file specified by file_name using » context-triggered piecewise hashing, and returns that hash.

Değiştirgeler

file_name

The filename of the file to hash.

Dönen Değerler

Returns a string on success, FALSE otherwise.

ssdeep_fuzzy_compare
ssdeep_fuzzy_hash
ssdeep İşlevleri


Create a fuzzy hash from a string

ssdeep_fuzzy_hash_filename
Dizgeler
ssdeep İşlevleri
PHP Manual

ssdeep_fuzzy_hash

(PECL ssdeep >= 1.0.0)

ssdeep_fuzzy_hash — Create a fuzzy hash from a string

Açıklama

string ssdeep_fuzzy_hash ( string $to_hash )

ssdeep_fuzzy_hash() calculates the hash of to_hash using » context-triggered piecewise hashing, and returns that hash.

Değiştirgeler

to_hash

The input string.

Dönen Değerler

Returns a string on success, FALSE otherwise.

ssdeep_fuzzy_hash_filename
Dizgeler
ssdeep İşlevleri


Dizgeler

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Dizge İşlevleri
    • addcslashes — Dizgeye C tarzı öncelem uygular
    • addslashes — Özel karakterlerin önüne tersbölü yerleştirir
    • bin2hex — Bir ikil verinin onaltılık gösterimini elde eder
    • chop — rtrim işlevinin takma adıdır
    • chr — Kodu belirtilen karakteri döndürür
    • chunk_split — Bir dizgeyi daha küçük parçalara ayırır
    • convert_cyr_string — Bir Kril karakter kümesini bir diğerine çevirir
    • convert_uudecode — Uuencoded ile kodlanmış bir dizgeyi eski haline getirir
    • convert_uuencode — Bir dizgeyi uuencode algoritmasıyla kodlar
    • count_chars — Bir dizgedeki karakterler hakkında bilgi döndürür
    • crc32 — Bir dizgenin crc32 çok terimlisini hesaplar
    • crypt — Tek yönlü dizge şifrelemesi yapar
    • echo — Bir veya daha fazla dizgeyi çıktılar
    • explode — Bir dizgeyi bir ayraca göre bölüp bir dizi haline getirir
    • fprintf — Biçemli dizgeyi bir akıma yazar
    • get_html_translation_table — htmlspecialchars ve htmlentities tarafından kullanılan dönüşüm tablosunu döndürür
    • hebrev — Mantıksal İbranice metni görsel metne dönüştürür
    • hebrevc — Mantıksal İbranice metni satırsonlarıyla birlikte görsel metne dönüştürür
    • hex2bin — Decodes a hexadecimally encoded binary string
    • html_entity_decode — Dönüştürülebilecek tüm HTML öğelerini karakter haline getirir
    • htmlentities — Dönüştürülebilecek tüm karakterleri HTML öğeleri haline getirir
    • htmlspecialchars_decode — Özel HTML öğelerini gerisin geriye karakterlere dönüştürür
    • htmlspecialchars — Özel karakterleri HTML öğeleri haline getirir
    • implode — Dizi elemanlarını birleştirip bir dizge elde eder
    • join — implode işlevinin takma adıdır
    • lcfirst — Bir dizgenin ilk karakterini küçük harf yapar
    • levenshtein — İki dizge arasındaki Levenştayn mesafesini hesaplar
    • localeconv — Sayısal biçemleme bilgisini döndürür
    • ltrim — Dizgenin başındaki boşlukları (veya diğer karakterleri) budar
    • md5_file — Belirtilen dosyanın md5 özetini hesaplar
    • md5 — Bir dizgenin md5 özetini hesaplar
    • metaphone — Bir dizgenin metafon anahtarını hesaplar
    • money_format — Bir sayıyı para olarak biçemler
    • nl_langinfo — Dili ve yerel bilgisini sorgular
    • nl2br — Dizgedeki tüm satırsonlarının yerine HTML satır katlayıcıları yerleştirilir
    • number_format — Sayıyı binlik bölümlere ayırır
    • ord — Karakterin ASCII değerini döndürür
    • parse_str — Dizge içindeki değişkenleri çözümler
    • print — Bir dizge çıktılar
    • printf — Biçemli bir dizge çıktılar
    • quoted_printable_decode — ASCII olarak basılabilir (quoted-printable) bir dizgenin 8 bitlik sürümünü döndürür
    • quoted_printable_encode — 8 bitlik bir dizgenin ASCII olarak basılabilir (quoted-printable) sürümünü döndürür
    • quotemeta — Özel anlamı olan karakterleri tersbölü ile önceler
    • rtrim — Dizgenin sonundaki boşlukları (veya diğer karakterleri) budar
    • setlocale — Yereli ayarlar
    • sha1_file — Bir dosyanın sha1 özetini hesaplar
    • sha1 — Bir dizgenin sha1 özetini hesaplar
    • similar_text — İki dizge arasındaki benzerliği hesaplar
    • soundex — Bir dizgenin sestek anahtarını hesaplar
    • sprintf — Biçemli bir dizge döndürür
    • sscanf — Girdi dizgesini belli bir biçeme göre yorumlar
    • str_getcsv — Bir CSV dizgesinin girdilerini bir dizinin elemanlarına paylaştırır
    • str_ireplace — Bir alt dizgenin bütün örneklerini yenisiyle değiştirirken harf büyüklüklerini dikkate almaz
    • str_pad — Bir dizgeyi belli bir uzunlukta diğer dizgeyle doldurur
    • str_repeat — Bir dizgeyi yineler
    • str_replace — Bir alt dizgenin bütün örneklerini yenisiyle değiştirir
    • str_rot13 — Bir dizgeye rot13 dönüşümü uygular
    • str_shuffle — Bir dizgenin karakterlerini devşirir
    • str_split — Bir dizgeyi bir diziye dönüştürür
    • str_word_count — Bir dizgedeki sözcükler hakkında bilgi verir
    • strcasecmp — İkil olarak güvenilir ve harf büyüklüğüne duyarsız dizge karşılaştırması yapar
    • strchr — strstr işlevinin takma adıdır
    • strcmp — İkil olarak güvenilir dizge karşılaştırması yapar
    • strcoll — Yerele göre dizge karşılaştırma
    • strcspn — Maske ile eşleşMEyen ilk parçanın uzunluğunu bulur
    • strip_tags — Bir dizgeden HTML ve PHP etiketlerini ayıklar
    • stripcslashes — addcslashes ile öncelenmiş dizgeyi eski haline getirir
    • stripos — Harf büyüklüğüne duyarsız olarak bir alt dizgenin ilkinin konumunu bulur
    • stripslashes — Bir dizgeden tersbölüleri ayıklar
    • stristr — Harf büyüklüğüne duyarsız olarak ilk alt dizgeyi bulur
    • strlen — Dizge uzunluğunu döndürür
    • strnatcasecmp — "Doğal sıralama" algoritmasını kullanarak dizgeleri harf büyüklüğüne duyarsız olarak karşılaştırır
    • strnatcmp — "Doğal sıralama" algoritmasını kullanarak dizgeleri karşılaştırır
    • strncasecmp — İlk n karakteri ikil ve harf büyüklüğüne duyarsız olarak karşılaştırır
    • strncmp — İlk n karakteri ikil olarak karşılaştırır
    • strpbrk — Belirtilen karakterleri bir dizge içinde arar
    • strpos — Bir alt dizgenin ilkinin konumunu bulur
    • strrchr — Bir dizgede belli bir karakterin sonuncusuna göre dizgenin bir parçasıyla döner
    • strrev — Bir dizgeyi ters çevirir
    • strripos — Bir dizgede harf büyüklüğüne duyarsız olarak bir alt dizgenin sonuncusunu bulur
    • strrpos — Bir dizgede bir karakterin sonuncusunu bulur
    • strspn — Dizgenin, maskenin tam karakterleri ile eşleşen ilk parçasının uzunluğunu bulur
    • strstr — İlk alt dizgeyi bulur
    • strtok — Dizgeyi bir dizgeciğe göre böler
    • strtolower — Bir dizgenin harflerini küçük harfe çevirir
    • strtoupper — Bir dizgenin harflerini büyük harfe çevirir
    • strtr — Belli karakterleri dönüştürür
    • substr_compare — İki dizgenin belli bir konumdan itibaren belli uzunluktaki parçalarını bayt bayt karşılaştırır
    • substr_count — Bir dizge içinde belli bir alt dizgeden kaç tane bulunduğunu bulur
    • substr_replace — Bir dizgenin belli bir bölümünü değiştirir
    • substr — Dizgenin bir kısmını döndürür
    • trim — Dizgenin başındaki ve sonundaki boşlukları (veya diğer karakterleri) budar
    • ucfirst — Dizgenin ilk karakterini büyük harfe çevirir
    • ucwords — Dizgedeki her sözcüğün ilk harfini büyük harf yapar
    • vfprintf — Biçemli dizgeyi bir akıma yazar
    • vprintf — Biçemli bir dizge çıktılar
    • vsprintf — Biçemli bir dizge döndürür
    • wordwrap — Bir dizgeyi belli bir uzunlukta katlar
ssdeep_fuzzy_hash
Giriş
Metin İşleme


Giriş

Bu işlevlerin hepsi dizgelerde çeşitli yollarla değişiklik yapmak için kullanılır. Daha özelleştirilmiş işlevleri düzenli ifadeler ve URL işlevleri bölümlerinde bulabilirsiniz.

Dizgelerin davranışları, özellikle de çift tırnak, tek tırnak ve önceleme dizilimleri kullanımları hakkında bilgi edinmek için Türler bölümündeki strings belgesine bakınız.

Dizgeler
Yapılandırma/Kurulum
Dizgeler


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Dizgeler


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

CRYPT_SALT_LENGTH integer
CRYPT_STD_DES integer
CRYPT_EXT_DES integer
CRYPT_MD5 integer
CRYPT_BLOWFISH integer
HTML_SPECIALCHARS (integer)
HTML_ENTITIES (integer)
ENT_COMPAT (integer)
ENT_QUOTES (integer)
ENT_NOQUOTES (integer)
CHAR_MAX (integer)
LC_CTYPE (integer)
LC_NUMERIC (integer)
LC_TIME (integer)
LC_COLLATE (integer)
LC_MONETARY (integer)
LC_ALL (integer)
LC_MESSAGES (integer)
STR_PAD_LEFT (integer)
STR_PAD_RIGHT (integer)
STR_PAD_BOTH (integer)
Özkaynak Türleri
Dizge İşlevleri
Dizgeler


Dizge İşlevleri

Ayrıca Bakınız

Daha güçlü dizge işleme ve değiştirme işlevleri için POSIX düzenli ifade işlevleri ve Perl uyumlu düzenli ifade işlevleri bölümlerine bakınız.

İçindekiler

  • addcslashes — Dizgeye C tarzı öncelem uygular
  • addslashes — Özel karakterlerin önüne tersbölü yerleştirir
  • bin2hex — Bir ikil verinin onaltılık gösterimini elde eder
  • chop — rtrim işlevinin takma adıdır
  • chr — Kodu belirtilen karakteri döndürür
  • chunk_split — Bir dizgeyi daha küçük parçalara ayırır
  • convert_cyr_string — Bir Kril karakter kümesini bir diğerine çevirir
  • convert_uudecode — Uuencoded ile kodlanmış bir dizgeyi eski haline getirir
  • convert_uuencode — Bir dizgeyi uuencode algoritmasıyla kodlar
  • count_chars — Bir dizgedeki karakterler hakkında bilgi döndürür
  • crc32 — Bir dizgenin crc32 çok terimlisini hesaplar
  • crypt — Tek yönlü dizge şifrelemesi yapar
  • echo — Bir veya daha fazla dizgeyi çıktılar
  • explode — Bir dizgeyi bir ayraca göre bölüp bir dizi haline getirir
  • fprintf — Biçemli dizgeyi bir akıma yazar
  • get_html_translation_table — htmlspecialchars ve htmlentities tarafından kullanılan dönüşüm tablosunu döndürür
  • hebrev — Mantıksal İbranice metni görsel metne dönüştürür
  • hebrevc — Mantıksal İbranice metni satırsonlarıyla birlikte görsel metne dönüştürür
  • hex2bin — Decodes a hexadecimally encoded binary string
  • html_entity_decode — Dönüştürülebilecek tüm HTML öğelerini karakter haline getirir
  • htmlentities — Dönüştürülebilecek tüm karakterleri HTML öğeleri haline getirir
  • htmlspecialchars_decode — Özel HTML öğelerini gerisin geriye karakterlere dönüştürür
  • htmlspecialchars — Özel karakterleri HTML öğeleri haline getirir
  • implode — Dizi elemanlarını birleştirip bir dizge elde eder
  • join — implode işlevinin takma adıdır
  • lcfirst — Bir dizgenin ilk karakterini küçük harf yapar
  • levenshtein — İki dizge arasındaki Levenştayn mesafesini hesaplar
  • localeconv — Sayısal biçemleme bilgisini döndürür
  • ltrim — Dizgenin başındaki boşlukları (veya diğer karakterleri) budar
  • md5_file — Belirtilen dosyanın md5 özetini hesaplar
  • md5 — Bir dizgenin md5 özetini hesaplar
  • metaphone — Bir dizgenin metafon anahtarını hesaplar
  • money_format — Bir sayıyı para olarak biçemler
  • nl_langinfo — Dili ve yerel bilgisini sorgular
  • nl2br — Dizgedeki tüm satırsonlarının yerine HTML satır katlayıcıları yerleştirilir
  • number_format — Sayıyı binlik bölümlere ayırır
  • ord — Karakterin ASCII değerini döndürür
  • parse_str — Dizge içindeki değişkenleri çözümler
  • print — Bir dizge çıktılar
  • printf — Biçemli bir dizge çıktılar
  • quoted_printable_decode — ASCII olarak basılabilir (quoted-printable) bir dizgenin 8 bitlik sürümünü döndürür
  • quoted_printable_encode — 8 bitlik bir dizgenin ASCII olarak basılabilir (quoted-printable) sürümünü döndürür
  • quotemeta — Özel anlamı olan karakterleri tersbölü ile önceler
  • rtrim — Dizgenin sonundaki boşlukları (veya diğer karakterleri) budar
  • setlocale — Yereli ayarlar
  • sha1_file — Bir dosyanın sha1 özetini hesaplar
  • sha1 — Bir dizgenin sha1 özetini hesaplar
  • similar_text — İki dizge arasındaki benzerliği hesaplar
  • soundex — Bir dizgenin sestek anahtarını hesaplar
  • sprintf — Biçemli bir dizge döndürür
  • sscanf — Girdi dizgesini belli bir biçeme göre yorumlar
  • str_getcsv — Bir CSV dizgesinin girdilerini bir dizinin elemanlarına paylaştırır
  • str_ireplace — Bir alt dizgenin bütün örneklerini yenisiyle değiştirirken harf büyüklüklerini dikkate almaz
  • str_pad — Bir dizgeyi belli bir uzunlukta diğer dizgeyle doldurur
  • str_repeat — Bir dizgeyi yineler
  • str_replace — Bir alt dizgenin bütün örneklerini yenisiyle değiştirir
  • str_rot13 — Bir dizgeye rot13 dönüşümü uygular
  • str_shuffle — Bir dizgenin karakterlerini devşirir
  • str_split — Bir dizgeyi bir diziye dönüştürür
  • str_word_count — Bir dizgedeki sözcükler hakkında bilgi verir
  • strcasecmp — İkil olarak güvenilir ve harf büyüklüğüne duyarsız dizge karşılaştırması yapar
  • strchr — strstr işlevinin takma adıdır
  • strcmp — İkil olarak güvenilir dizge karşılaştırması yapar
  • strcoll — Yerele göre dizge karşılaştırma
  • strcspn — Maske ile eşleşMEyen ilk parçanın uzunluğunu bulur
  • strip_tags — Bir dizgeden HTML ve PHP etiketlerini ayıklar
  • stripcslashes — addcslashes ile öncelenmiş dizgeyi eski haline getirir
  • stripos — Harf büyüklüğüne duyarsız olarak bir alt dizgenin ilkinin konumunu bulur
  • stripslashes — Bir dizgeden tersbölüleri ayıklar
  • stristr — Harf büyüklüğüne duyarsız olarak ilk alt dizgeyi bulur
  • strlen — Dizge uzunluğunu döndürür
  • strnatcasecmp — "Doğal sıralama" algoritmasını kullanarak dizgeleri harf büyüklüğüne duyarsız olarak karşılaştırır
  • strnatcmp — "Doğal sıralama" algoritmasını kullanarak dizgeleri karşılaştırır
  • strncasecmp — İlk n karakteri ikil ve harf büyüklüğüne duyarsız olarak karşılaştırır
  • strncmp — İlk n karakteri ikil olarak karşılaştırır
  • strpbrk — Belirtilen karakterleri bir dizge içinde arar
  • strpos — Bir alt dizgenin ilkinin konumunu bulur
  • strrchr — Bir dizgede belli bir karakterin sonuncusuna göre dizgenin bir parçasıyla döner
  • strrev — Bir dizgeyi ters çevirir
  • strripos — Bir dizgede harf büyüklüğüne duyarsız olarak bir alt dizgenin sonuncusunu bulur
  • strrpos — Bir dizgede bir karakterin sonuncusunu bulur
  • strspn — Dizgenin, maskenin tam karakterleri ile eşleşen ilk parçasının uzunluğunu bulur
  • strstr — İlk alt dizgeyi bulur
  • strtok — Dizgeyi bir dizgeciğe göre böler
  • strtolower — Bir dizgenin harflerini küçük harfe çevirir
  • strtoupper — Bir dizgenin harflerini büyük harfe çevirir
  • strtr — Belli karakterleri dönüştürür
  • substr_compare — İki dizgenin belli bir konumdan itibaren belli uzunluktaki parçalarını bayt bayt karşılaştırır
  • substr_count — Bir dizge içinde belli bir alt dizgeden kaç tane bulunduğunu bulur
  • substr_replace — Bir dizgenin belli bir bölümünü değiştirir
  • substr — Dizgenin bir kısmını döndürür
  • trim — Dizgenin başındaki ve sonundaki boşlukları (veya diğer karakterleri) budar
  • ucfirst — Dizgenin ilk karakterini büyük harfe çevirir
  • ucwords — Dizgedeki her sözcüğün ilk harfini büyük harf yapar
  • vfprintf — Biçemli dizgeyi bir akıma yazar
  • vprintf — Biçemli bir dizge çıktılar
  • vsprintf — Biçemli bir dizge döndürür
  • wordwrap — Bir dizgeyi belli bir uzunlukta katlar
Öntanımlı Sabitler
addcslashes
Dizgeler


Dizgeye C tarzı öncelem uygular

Dizge İşlevleri
addslashes
Dizge İşlevleri
PHP Manual

addcslashes

(PHP 4, PHP 5, PHP 7)

addcslashes — Dizgeye C tarzı öncelem uygular

Açıklama

string addcslashes ( string $dizge , string $karakterler )

dizge dizgesindeki karakterler değiştirgesinde listelenmiş karakterlerin önüne tersbölü yerleştirilerek elde edilen dizgeyi döndürür.

Değiştirgeler

dizge

Öncelenecek dizge.

karakterler

Önlerine tersbölü konulacak \n, \r gibi karakterleri içeren dizge. Belirtilen karakterler C tarzı öncelenirken, ASCII kodu 32'den küçük ve 126'dan büyük karakterler sekizlik gösterimlerine dönüştürülür.

Bu değiştirgede bir karakter aralığı belirtiyorsanız bu aralığın hangi karakterleri içerdiğine dikkat etmelisiniz.

<?php
echo addcslashes('foo[ ]', 'A..z');
// çıktısı:  \f\o\o\[ \]
// Tüm büyük ve küçük harflerden başka [\]^_` karakterleri de öncelenir
?>
Ayrıca, bir aralığın başlangıç karakterinin ASCII değeri son karakterininkinden büyükse ilk ve son karakter hariç bu aralıktaki hiçbir karakter öncelenmez. Bir karakterin ASCII değerini bulmak için ord() işlevini kullanın.
<?php
echo addcslashes("zoo['.']", 'z..A');
// çıktısı:  \zoo['\.']
?>

Karakterleri seçerken dikkatli olun: 0, a, b, f, n, r, t ve v karakterleri \0, \a, \b, \f, \n, \r, \t ve \v karakterlerine dönüştürülecektir. Bunların hepsi C tarzı öncelemde öntanımlı dizilimler olup PHP'de \0 (NULL), \r (satırbaşı), \n (satırsonu), \f (sayfa ileri), \v (düşey sekme) ve \t (yatay sekme) öntanımlı dizilimlerdir.

Dönen Değerler

Öncelenmiş dizge.

Sürüm Bilgisi

Sürüm: | Açıklama
5.2.5 | \v ve \f öncelem dizilimleri eklendi.

Örnekler

"\0..\37" gibi bir aralık ASCII kodu 0 ile 31 arasında kalan karakterlerin de öncelenmesini sağlayacaktır.

Örnek 1 - addcslashes() örneği

<?php
$öncelemli = addcslashes($öncelemsiz, "\0..\37!@\177..\377");
?>

Ayrıca Bakınız

  • stripcslashes() - addcslashes ile öncelenmiş dizgeyi eski haline getirir
  • stripslashes() - Bir dizgeden tersbölüleri ayıklar
  • addslashes() - Özel karakterlerin önüne tersbölü yerleştirir
  • htmlspecialchars() - Özel karakterleri HTML öğeleri haline getirir
  • quotemeta() - Özel anlamı olan karakterleri tersbölü ile önceler

Dizge İşlevleri
addslashes
Dizge İşlevleri


Özel karakterlerin önüne tersbölü yerleştirir

addcslashes
bin2hex
Dizge İşlevleri
PHP Manual

addslashes

(PHP 4, PHP 5, PHP 7)

addslashes — Özel karakterlerin önüne tersbölü yerleştirir

Açıklama

string addslashes ( string $dizge )

Veritabanı sorguları gibi yerlerde kullanılmak üzere bir dizgenin içindeki özel karakterlerin önüne tersbölü koyarak elde edilen dizgeyi döndürür. Özel karakterler: tek tırmak ('), çift tırnak ("), tersbölü (\) ve NUL (0. bayt).

addslashes() işlevinin örnek kullanımlarından biri, bir veritabanına girilecek veriyi hazırlamaktır. Örneğin O'reilly dizgesini bir veritabanına girerken onu öncelemeniz gerekir. Bu işlem için veritabanına özgü öncelem işlevlerini kullanmanız daha iyi olur (MySQL için mysqli_real_escape_string(), PostgreSQL için pg_escape_string() gibi). Sadece, kullandığınız veritabanı özel karakterlerin öncelenmesini gerektirdiği halde böyle bir işleve sahip değilse, bu işlevi kullanın. Tek tırnak karakterini kendisiyle öncelemek için magic_quotes_sybase PHP ini yönergesine on değeri atanmış olmalıdır.

magic_quotes_gpc yönergesi öntanımlı olarak on değerine sahip olup tüm GET, POST ve COOKIE verileri üzerinde addslashes() çalıştırılmasını sağlar. Çifte öncelem yapmamak için bu yönergenin etkin olduğu sistemlerde GET, POST ve COOKIE verileri üzerinde addslashes() işlevini kullanmayın. Böyle bir durumda addslashes() işlevini kullanıp kullanmayacağınızı get_magic_quotes_gpc() işlevi ile sınayabilirsiniz.

Değiştirgeler

dizge

Öncelenecek dizge.

Dönen Değerler

Öncelemli dizge.

Örnekler

Örnek 1 - addslashes() örneği

<?php
$str = "İsminiz O'reilly mi?";

// Çıktısı: İsminiz O\'reilly mi?
echo addslashes($str);
?>

Ayrıca Bakınız

  • stripcslashes() - addcslashes ile öncelenmiş dizgeyi eski haline getirir
  • stripslashes() - Bir dizgeden tersbölüleri ayıklar
  • addcslashes() - Dizgeye C tarzı öncelem uygular
  • htmlspecialchars() - Özel karakterleri HTML öğeleri haline getirir
  • quotemeta() - Özel anlamı olan karakterleri tersbölü ile önceler
  • get_magic_quotes_gpc() - magic_quotes_gpc yönergesinin değerini döndürür

addcslashes
bin2hex
Dizge İşlevleri


Bir ikil verinin onaltılık gösterimini elde eder

addslashes
chop
Dizge İşlevleri
PHP Manual

bin2hex

(PHP 4, PHP 5, PHP 7)

bin2hex — Bir ikil verinin onaltılık gösterimini elde eder

Açıklama

string bin2hex ( string $dizge )

dizge dizgesinin onaltılık gösterimini içeren bir dizge döner. Dönüşüm bayt bayt ve her baytın en kıymetli dört biti önce gelecek şekilde yapılır.

Değiştirgeler

dizge

Dönüştürülecek dizge.

Dönen Değerler

Belirtilen dizgenin onaltılık gösterimi döner.

Ayrıca Bakınız

  • pack() - Veriyi bir ikil dizge halinde paketler
  • unpack() - Paketlenmiş bir ikil dizgeden verileri ayrıştırır

addslashes
chop
Dizge İşlevleri


rtrim işlevinin takma adıdır

bin2hex
chr
Dizge İşlevleri
PHP Manual

chop

(PHP 4, PHP 5, PHP 7)

chop — rtrim() işlevinin takma adıdır

Açıklama

Bu işlev rtrim() işlevinin takma adıdır.

Notlar

Bilginize:

Bu işlev, dizgedeki son karakteri silen Perl'in chop() işlevinden farklıdır.

bin2hex
chr
Dizge İşlevleri


Kodu belirtilen karakteri döndürür

chop
chunk_split
Dizge İşlevleri
PHP Manual

chr

(PHP 4, PHP 5, PHP 7)

chr — Kodu belirtilen karakteri döndürür

Açıklama

string chr ( int $ascii )

Kodu ascii ile belirtilen karakteri döndürür.

ord() işlevinin zıddıdır.

Değiştirgeler

ascii

Karakterin ASCII kodu.

Dönen Değerler

Belirtilen karakter.

Sürüm Bilgisi

Sürüm: | Açıklama
6.0.0 | Bu işlevde artık sadece 255'den küçük karakterler değil tüm karakterlerin karakter kodları kabul ediliyor.

Örnekler

Örnek 1 - chr() örneği

<?php
$dizge = "The string ends in escape: ";
$dizge .= chr(27); /* $dizgenin sonuna kaçış karakterini ekleyelim */

/* Aslında bu daha kullanışlıdır */
$dizge = sprintf("The string ends in escape: %c", 27);
?>

Ayrıca Bakınız

  • sprintf() - Biçemli bir dizge döndürür
  • ord() - Karakterin ASCII değerini döndürür
  • » ASCII tablosu

chop
chunk_split
Dizge İşlevleri


Bir dizgeyi daha küçük parçalara ayırır

chr
convert_cyr_string
Dizge İşlevleri
PHP Manual

chunk_split

(PHP 4, PHP 5, PHP 7)

chunk_split — Bir dizgeyi daha küçük parçalara ayırır

Açıklama

string chunk_split ( string $dizge [, int $parça_uzunluğu [, string $son ]] )

Belirtilen dizge dizgesini. örneğin, RFC 2045'e uygun olarak base64_encode() ile çıktılamakta kullanmak üzere daha küçük parçalara bölmek için kullanılır. Her parça_uzunluğu karakterin sonuna son dizgesi yerleştirilir.

Değiştirgeler

dizge

Parçalara ayrılacak dizge.

parça_uzunluğu

Parça uzunluğu. 76 öntanımlıdır.

son

Her satırın sonuna yerleştirilecek dizge; "\r\n" öntanımlıdır.

Dönen Değerler

Parçalanan dizge döner.

Örnekler

Örnek 1 - chunk_split() örneği

<?php
// $veri'yi RFC 2045'e uygun olarak biçemleyelim
$yeni_dizge = chunk_split(base64_encode($veri));
?>

Ayrıca Bakınız

  • str_split() - Bir dizgeyi bir diziye dönüştürür
  • explode() - Bir dizgeyi bir ayraca göre bölüp bir dizi haline getirir
  • split() - Belirtilen dizgeyi düzenli ifadeye göre dizi elemanlarına böler
  • wordwrap() - Bir dizgeyi belli bir uzunlukta katlar
  • » RFC 2045

chr
convert_cyr_string
Dizge İşlevleri


Bir Kril karakter kümesini bir diğerine çevirir

chunk_split
convert_uudecode
Dizge İşlevleri
PHP Manual

convert_cyr_string

(PHP 4, PHP 5, PHP 7)

convert_cyr_string — Bir Kril karakter kümesini bir diğerine çevirir

Açıklama

string convert_cyr_string ( string $dizge , string $kaynak , string $hedef )

Bir Kril karakter kümesini bir diğerine çevirir.

Değiştirgeler

dizge

Dönüştürülecek dizge.

kaynak

Tek bir karakter olarak kaynak dizgenin Kril karakter kümesi.

hedef

Tek bir karakter olarak hedef dizgenin Kril karakter kümesi.

Karakter kümesi adı olarak desteklenen karakterler:

  • k - koi8-r
  • w - windows-1251
  • i - iso8859-5
  • a - x-cp866
  • d - x-cp866
  • m - x-mac-cyrillic

Dönen Değerler

Dönüştürülen dizge.

Notlar

Bilginize: Bu işlev ikil dosyalarla çalışırken dosya içeriğini değiştirmez.

chunk_split
convert_uudecode
Dizge İşlevleri


Uuencoded ile kodlanmış bir dizgeyi eski haline getirir

convert_cyr_string
convert_uuencode
Dizge İşlevleri
PHP Manual

convert_uudecode

(PHP 5, PHP 7)

convert_uudecode — Uuencoded ile kodlanmış bir dizgeyi eski haline getirir

Açıklama

string convert_uudecode ( string $veri )

convert_uudecode() işlevi uuencoded ile kodlanmış bir dizgeyi eski haline getirir.

Değiştirgeler

veri

Kodu çözülecek dizge.

Dönen Değerler

Kodu çözülmüş veriyi bir dizge olarak döndürür.

Örnekler

Örnek 1 - convert_uudecode() örneği

<?php
/* Bunun ne basacağını hayal edebiliyor musunuz? :) */
echo convert_uudecode("14\$A0)WEI('-E=FEY;W)U;2$`\n`");
?>

Ayrıca Bakınız

  • convert_uuencode() - Bir dizgeyi uuencode algoritmasıyla kodlar

convert_cyr_string
convert_uuencode
Dizge İşlevleri


Bir dizgeyi uuencode algoritmasıyla kodlar

convert_uudecode
count_chars
Dizge İşlevleri
PHP Manual

convert_uuencode

(PHP 5, PHP 7)

convert_uuencode — Bir dizgeyi uuencode algoritmasıyla kodlar

Açıklama

string convert_uuencode ( string $veri )

convert_uuencode() işlevi belirtilen dizgeyi dizgeyi uuencode algoritmasını kullanarak kodlar.

Uuencode tüm dizgeleri (ikil olanlar da dahil), ağ üzerinden aktarılabilir duruma getirmek için basılabilir karakterlere dönüştürür. Kodlanmış dizge özgün dizgeden yaklayık %35 daha uzun olur.

Değiştirgeler

veri

Kodlanacak veri.

Dönen Değerler

Kodlanmış veri.

Örnekler

Örnek 1 - convert_uuencode() örneği

<?php
$bir_dizge = "deneme\nmetninin metni\r\n";

echo convert_uuencode($bir_dizge);
?>

Ayrıca Bakınız

  • convert_uudecode() - Uuencoded ile kodlanmış bir dizgeyi eski haline getirir
  • base64_encode() - Veriye MIME base64 kodlaması uygular

convert_uudecode
count_chars
Dizge İşlevleri


Bir dizgedeki karakterler hakkında bilgi döndürür

convert_uuencode
crc32
Dizge İşlevleri
PHP Manual

count_chars

(PHP 4, PHP 5, PHP 7)

count_chars — Bir dizgedeki karakterler hakkında bilgi döndürür

Açıklama

mixed count_chars ( string $dizge [, int $kip = 0 ] )

dizge dizgesi içindeki her bayt değerini (0..255) sayar ve sonuçları çeşitli yollarla döndürür.

Değiştirgeler

dizge

İncelenecek dizge.

kip

Belirtilmesi isteğe bağlı olup öntanımlı değeri 0'dır.

Dönen Değerler

kip değiştirgesine bağlı olarak count_chars() şunlardan birini döndürür:

  • 0 - Bayt değeri anahtar ve bu bayta rastlanma sıklığı değer olmak üzere bir ilişkisel dizi döner.
  • 1 - Sadece rastlanma sıklığı sıfırdan büyük olan baytlarla ilgili sonuçları döndürmesi dışında 0 ile aynıdır.
  • 2 - Sadece rastlanma sıklığı sıfır olan baytlarla ilgili sonuçları döndürmesi dışında 0 ile aynıdır.
  • 3 - Tüm eşsiz karakterleri içeren bir dizge döner.
  • 4 - Kullanılmamış karakterleri içeren bir dizge döner.

Örnekler

Örnek 1 - count_chars() örneği

<?php
$veri = "Beş N ve bir K.";

foreach (count_chars($veri, 1) as $bayt => $kaç) {
   echo "Dizgede $kaç tane $bayt numaralı karakter var.\n";
}
?>

Yukarıdaki örneğin çıktısı:

Dizgede 4 tane 32 numaralı karakter var.
Dizgede 1 tane 46 numaralı karakter var.
Dizgede 1 tane 66 numaralı karakter var.
Dizgede 1 tane 75 numaralı karakter var.
Dizgede 1 tane 78 numaralı karakter var.
Dizgede 1 tane 98 numaralı karakter var.
Dizgede 2 tane 101 numaralı karakter var.
Dizgede 1 tane 105 numaralı karakter var.
Dizgede 1 tane 114 numaralı karakter var.
Dizgede 1 tane 118 numaralı karakter var.
Dizgede 1 tane 159 numaralı karakter var.
Dizgede 1 tane 197 numaralı karakter var.

Ayrıca Bakınız

  • strpos() - Bir alt dizgenin ilkinin konumunu bulur
  • substr_count() - Bir dizge içinde belli bir alt dizgeden kaç tane bulunduğunu bulur

convert_uuencode
crc32
Dizge İşlevleri


Bir dizgenin crc32 çok terimlisini hesaplar

count_chars
crypt
Dizge İşlevleri
PHP Manual

crc32

(PHP 4 >= 4.0.1, PHP 5, PHP 7)

crc32 — Bir dizgenin crc32 çok terimlisini hesaplar

Açıklama

int crc32 ( string $dizge )

dizge dizgesinin çevrimsel artıklık sağlaması çok terimlisinin sonucunu hesaplar. Bu genellikle aktarılan bir verinin bütünlük doğrulamasını yapmak için kullanılır.

PHP'nin tamsayı türü işaretli olduğundan ve çoğu crc32 sağlaması negatif tamsayılar ürettiğinden işaretsiz crc32 sağlamalarının dizgesel gösterimlerini elde etmek için sprintf() ve printf() işlevlerinde "%u" belirtimini kullanın

Değiştirgeler

dizge

Veri.

Dönen Değerler

dizge dizgesinin crc32 sağlamasını bir tamsayı olarak döndürür.

Örnekler

Örnek 1 - Bir crc32 sağlamasının gösterilmesi

Bu örnekte sağlama toplamını basmak için printf() işlevinin kullanımı gösterilmiştir.

<?php
$checksum = crc32("The quick brown fox jumped over the lazy dog.");
printf("%u\n", $checksum);
?>

Ayrıca Bakınız

  • md5() - Bir dizgenin md5 özetini hesaplar
  • sha1() - Bir dizgenin sha1 özetini hesaplar

count_chars
crypt
Dizge İşlevleri


Tek yönlü dizge şifrelemesi yapar

crc32
echo
Dizge İşlevleri
PHP Manual

crypt

(PHP 4, PHP 5, PHP 7)

crypt — Tek yönlü dizge şifrelemesi yapar

Açıklama

string crypt ( string $dizge [, string $tuz ] )

crypt() işlevi standart Unix DES şifreleme algoritmasını veya sistemdeki uygun algoritmalardan birini kullanarak dizge dizgesinin şifrelenmiş sürümünü döndürür.

Bazı işletim sistemleri birden fazla şifreleme türü destekler. Çoğunlukla da standart DES şifrelemesinin yerini MD5 şifreleme algoritması alır. Şifreleme türü tuz değiştirgesiyle tetiklenir. Tuz kabul edecek şifreleme türlerini ve işlevin yeteneklerini PHP kurulum sırasında saptar. tuz belirtilmemişse ve sistemin öntanımlı şifreleme türü MD5 ise rasgele bir MD5 uyumlu bir tuz üretilir; sistemin öntanımlı şifreleme türü MD5 değilse PHP öntanımlı olarak iki karakterlik tuz üretir. PHP, CRYPT_SALT_LENGTH sabitinde tuz uzunluğunu tanımlayarak, sistemde iki karakterlik mi yoksa daha uzun bir tuz mu (en fazla 20) kullanıldığını belirtir.

Standart DES şifrelemesinde crypt() işlevi tuz olarak çıktının ilk iki karakterini döndürür. Ayrıca, dizgenin sadece ilk sekiz karakterini kullanır, bu nedenle ilk sekiz karakteri aynı olan sekiz karakterden daha uzun dizgeler için tuz aynı olduğu sürece hep aynı sonucu üretir.

İşlevin çok sayıda şifreleme algoritması ile desteklendiği sistemlerde aşağıdaki sabitler desteklenen şifreleme türüne göre 0 veya 1 değerini alırlar:

  • CRYPT_STD_DES - İki karakterlik tuz kullanan standart DES şifrelemesi.
  • CRYPT_EXT_DES - Dokuz karakterlik tuz kullanan gelişkin DES şifrelemesi.
  • CRYPT_MD5 - $1$ ile başlayan on iki karakterlik MD5 şifrelemesi.
  • CRYPT_BLOWFISH - $2$ veya $2a$ ile başlayan on altı karakterlik Blowfish şifrelemesi.

Bilginize:

PHP 5.3.0 ve sonrasında, PHP kendi gerçeklenimini içerir ve sistemde desteği bulunmayan algoritmalar için bu gerçeklenimi kullanır.

Değiştirgeler

dizge

Şifrelenecek dizge.

tuz

Şifrelemeye göre değişen isteğe bağlı tuz dizgesi. Belirtilmediği takdirde PHP, işlevin her çağrılışında rasgele bir tane üretir.

Eğer kendi tuzunuzu kullanacaksanız işlevi çağırmadan önce üretmiş olmalısınız. İşlevi tekrar takrar çağırdığınız durumlarda bunun hem görünürde hem de güvenlikte bazı etkileri olur.

Dönen Değerler

Şifrelenmiş dizge.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | PHP artık MD5, standart DES, gelişkin DES ve Blowfish şifreleme algoritmaları için kendi gerçeklenimini içeriyor ve sistemde bu algoritmalardan bulunmayanların yerine bu algoritmaları kullanıyor.

Örnekler

Örnek 1 - crypt() örnekleri

<?php
$parola = crypt('parolam'); // Tuzu PHP üretsin

/* Parola karşılaştırmasında, farklı şifreleme algoritmaları ile ilgili
   sorunlardan kaçınmak için crypt() sonucunun tamamını tuz olarak işleve
   aktarmalısınız. (Yukarıda belirtildiği gibi standart DES parola özetleri
   2 karakterlik tuz kullanırken MD5 parola özetleri 12 karakterlik tuz
   kullanır.) */
if (crypt($kullanıcı _girdisi, $parola) == $parola) {
   echo "Parola doğru!";
}
?>

Örnek 2 - htpasswd ile crypt() kullanımı

<?php
// Parolayı tanmılayalım
$parola = 'parolam';

// Tuzu PHP üretsin ve bize parola özetini versin
$hash = crypt($parola);
?>

Örnek 3 - crypt() işlevinin farklı şifreleme türleri ile kullanımı

<?php
if (CRYPT_STD_DES == 1) {
    echo 'Standart DES: ' . crypt('rasmuslerdorf', 'rl') . "\n";
}

if (CRYPT_EXT_DES == 1) {
    echo 'Gelişkin DES: ' . crypt('rasmuslerdorf', '_J9..rasm') . "\n";
}

if (CRYPT_MD5 == 1) {
    echo 'MD5:          ' . crypt('rasmuslerdorf', '$1$rasmusle$') . "\n";
}

if (CRYPT_BLOWFISH == 1) {
    echo 'Blowfish:     ' . crypt('rasmuslerdorf',
            '$2a$07$usesomesillystringforsalt$') . "\n";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Standart DES: rl.3StKT.4T8M
Gelişkin DES: _J9..rasmBYk8r9AiWNc
MD5:          $1$rasmusle$rISCgZzpwk3UhDidwXvin0
Blowfish:     $2a$07$usesomesillystringfore2uDLvp1Ii2e./U9C8sBjqp8I90dH6hi

Notlar

Bilginize: crypt() tek yönlü algoritma kullandığından tekrar özgün dizgeyi elde etmenizi sağlayacak bir işlev yoktur.

Ayrıca Bakınız

  • md5() - Bir dizgenin md5 özetini hesaplar
  • Mcrypt eklentisi
  • » crypt işlevinin Unix kılavuz sayfası

crc32
echo
Dizge İşlevleri


Bir veya daha fazla dizgeyi çıktılar

crypt
explode
Dizge İşlevleri
PHP Manual

echo

(PHP 4, PHP 5, PHP 7)

echo — Bir veya daha fazla dizgeyi çıktılar

Açıklama

void echo ( string $değ1 [, string $... ] )

Tüm değiştirgelerini çıktılar.

echo aslında bir işlev değil bir dil oluşumudur, yani değiştirgelerini yaylı ayraçlar arasına almak gerekmez. echo (diğer dil oluşumlarından farklı olarak) bir işlev gibi davranmaz, bu bakımdan bir işlevin değiştirgesinde kullanılamaz. Ek olarak, echo'ya birden fazla değiştirge aktarmak isterseniz bu değiştirgeleri asla yaylı ayraçlar arasına almamalısınız.

echo ayrıca kısaltılmış bir sözdizimine de sahiptir. Bir açan PHP etiketinin ardına bir eşit işareti koyup dizgeyi ardına yazmanız yeterlidir. Bu kısa kullanım sadece short_open_tag yönergesi etkin kılınmışsa kullanılabilir. Örnek:

I have <?=$foo?> foo.

Değiştirgeler

değ1

Çıktılanacak değiştirge.

...

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 - echo örnekleri

<?php
echo "Hello World";

echo "Bu çok satırlı bir
dizge olup satırsonu karakterleri
de çıktılanır.";

echo "Bu çok satırlı bir\ndizge olup satırsonu karakterleri\nde çıktılanır.";

echo "Karakterlerin öncelenmesi böyle yapılır: \"Tıpkı böyle\".";

// echo deyiminde değişkenleri de kullanabilirsiniz
$bu = "Bu da";

echo "$bu Buda"; // Bu da Buda

// Ayrıca dizileri de kullanabilirsiniz
$bar = array("değer" => "Buda");

echo "Bu da {$bar['değer']} !"; //  Bu da Buda !

// Tek tırnak içine alırsanız değişken basılır, değeri değil
echo '$bu Buda'; // $bu Buda

// Başka karakter kullanmazsanız sadece değişkenin değeri basılır
print $bu;          // Bu da
echo $foo,$bar;     // Bu daBuda

// Bazıları birleştirerek basılmak üzere çok sayıda değiştirgeyi böyle aktarır
echo 'Bu ', 'dizge ', 'çok ', 'değiştirgelidir.', chr(10);
echo 'Bu ' . 'dizge ' . 'çok ' . 'değiştirgelidir.' . "\n";

echo <<<END
Burada "yorumlu metin" (heredoc) sözdizimi kullanılmış
olup bu dizgenin içindeki her $değişken yorumlanır.
Yorumlu metin sonlandırıcısı son satırda yer almalı ve
ardındaki noktalı virgül dışında etrafında hiçbir karakter
(boşluklar dahil) bulunmamalıdır!
END;

// echo bir işlev gibi davranmadığından bu kod geçersizdir.
($some_var) ? echo 'true' : echo 'false';

// Ancak, bu kod çalışır:
($some_var) ? print 'true' : print 'false'; // print de bir dil oluşumudur
                                            // fakat bir işlev gibi davranır.
                                            // Dolayısıyla bu bağlamda
                                            // kullanılabilir.
echo $some_var ? 'true': 'false'; // echo kendi içeriğini yorumlayabilir
?>

Notlar

Bilginize: Bu bir işlev değil, dil oluşumu olduğundan değişken işlevler kullanılarak çağrılamaz.

Ayrıca Bakınız

  • print - Bir dizge çıktılar
  • printf() - Biçemli bir dizge çıktılar
  • flush() - Çıktı tamponunu boşaltır
  • Yorumlu metinler

crypt
explode
Dizge İşlevleri


Bir dizgeyi bir ayraca göre bölüp bir dizi haline getirir

echo
fprintf
Dizge İşlevleri
PHP Manual

explode

(PHP 4, PHP 5, PHP 7)

explode — Bir dizgeyi bir ayraca göre bölüp bir dizi haline getirir

Açıklama

array explode ( string $ayraç , string $dizge [, int $sınır ] )

Belirtilen dizge dizgesini belirtilen ayraç dizgesine göre alt dizgelere ayırıp bunları bir diziye yerleştirir.

Değiştirgeler

ayraç

Dizgeleri ayırmak için kullanılacak dizge.

dizge

Alt dizgelerine ayrılacak dizge.

sınır

sınır pozitifse dizi en çok sınır sayıda eleman içerir ve dizgenin kalanı son elemana yerleştirilir.

sınır negatifse, son sınır eleman hariç tüm elemanlar döndürülür.

sınır sıfırsa, 1 olarak ele alınır.

implode() işlevinin değiştirgeleri tarihsel sebeplerle yer değiştirebilse de, bu explode() için geçerli değildir. ayraç değiştirgesi dizge değiştirgesinden önce belirtilmelidir.

Dönen Değerler

ayraç boş ("") bir dizge ise explode() FALSE döndürür. Eğer ayraç dizgesi dizge içinde bulunmayan bir karakter içeriyorsa ve negatif bir sınır belirtilmişse boş bir dizi döner. Diğer sınır değerleri için dizge dizgesini içeren bir dizi döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.0 | Negatif sınır desteği eklendi.
4.0.1 | sınır değiştirgesi eklendi.

Örnekler

Örnek 1 - explode() örneği

<?php
// 1. örnek
$pizza  = "dilim1 dilim2 dilim3 dilim4 dilim5 dilim6";
$dilimler = explode(" ", $pizza);
echo $dilimler[0]; // dilim1
echo $dilimler[1]; // dilim2

// 2. örnek
$data = "foo:*:1023:1000::/home/foo:/bin/sh";
list($user, $pass, $uid, $gid, $gecos, $home, $shell) = explode(":", $data);
echo $user; // foo
echo $pass; // *

?>

Örnek 2 - sınır değiştirgesi örnekleri

<?php
$str = 'one|two|three|four';

// positif sınır
print_r(explode('|', $str, 2));

// negatif sınır (PHP 5.1 ve sonrası)
print_r(explode('|', $str, -1));
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [0] => one
    [1] => two|three|four
)
Array
(
    [0] => one
    [1] => two
    [2] => three
)

Notlar

Bilginize: Bu işlev ikil dosyalarla çalışırken dosya içeriğini değiştirmez.

Ayrıca Bakınız

  • preg_split() - Dizgeyi düzenli ifadeye göre böler
  • str_split() - Bir dizgeyi bir diziye dönüştürür
  • str_word_count() - Bir dizgedeki sözcükler hakkında bilgi verir
  • strtok() - Dizgeyi bir dizgeciğe göre böler
  • implode() - Dizi elemanlarını birleştirip bir dizge elde eder

echo
fprintf
Dizge İşlevleri


Biçemli dizgeyi bir akıma yazar

explode
get_html_translation_table
Dizge İşlevleri
PHP Manual

fprintf

(PHP 5, PHP 7)

fprintf — Biçemli dizgeyi bir akıma yazar

Açıklama

int fprintf ( resource $dt , string $biçem [, mixed $değiştirgeler [, mixed $... ]] )

Tanıtıcısı dt ile belirtilen dosyaya (akıma) biçem dizgesine göre üretilen dizgeyi yazar.

Değiştirgeler

dt

Bir dosya tanıtıcısı. Genellikle fopen() kullanılarak oluşturulur.

biçem

biçem dizgesinin açıklaması için sprintf() işlevine bakınız.

değiştirgeler

...

Dönen Değerler

Akıma yazılan dizgenin uzunluğunu döndürür.

Örnekler

Örnek 1 - fprintf(): Sıfır dolgulu tamsayılar

<?php
if (!($fp = fopen('date.txt', 'w'))) {
    return;
}

fprintf($fp, "%04d-%02d-%02d", $year, $month, $day);
// ISO biçemli tarihi date.txt dosyasına yazar
?>

Örnek 2 - fprintf(): para biçemleme

<?php
if (!($fp = fopen('currency.txt', 'w'))) {
    return;
}

$money1 = 68.75;
$money2 = 54.35;
$money = $money1 + $money2;
// echo $money çıktısı: "123.1";
$len = fprintf($fp, '%01.2f', $money);
// currency.txt dosyasına "123.10" yazar

echo "currency.txt dosyasına $len bayt yazıldı";
// Kaç bayt yazıldığını belirtmek için fprintf dönüş değerini kullanıyoruz
?>

Ayrıca Bakınız

  • printf() - Biçemli bir dizge çıktılar
  • sprintf() - Biçemli bir dizge döndürür
  • sscanf() - Girdi dizgesini belli bir biçeme göre yorumlar
  • fscanf() - Bir dosyadaki girdiyi belli bir biçeme göre çözümler
  • vsprintf() - Biçemli bir dizge döndürür
  • number_format() - Sayıyı binlik bölümlere ayırır

explode
get_html_translation_table
Dizge İşlevleri


htmlspecialchars ve htmlentities tarafından kullanılan dönüşüm tablosunu döndürür

fprintf
hebrev
Dizge İşlevleri
PHP Manual

get_html_translation_table

(PHP 4, PHP 5, PHP 7)

get_html_translation_table — htmlspecialchars() ve htmlentities() tarafından kullanılan dönüşüm tablosunu döndürür

Açıklama

array get_html_translation_table ([ int $tablo = HTML_SPECIALCHARS [, int $öncelem_türü = ENT_COMPAT ]] )

get_html_translation_table() işlevi, htmlspecialchars() ve htmlentities() tarafından kullanılan dahili dönüşüm tablosunu döndürür.

Bilginize:

Özel karakterler çeşitli yollarla kodlanabilir. Örneğin " karateri &quot;, &#34; veya &#x22 olarak kodlanabilir. get_html_translation_table() işlevi sadece en bilinenini döndürür.

Değiştirgeler

tablo

Hangi tabloyu istediğinizi HTML_ENTITIES ve HTML_SPECIALCHARS sabitlerinden biri ile belirtebilirsiniz. HTML_SPECIALCHARS öntanımlıdır.

öncelem_türü

Belirtilmesi isteğe bağlı olan bu değiştirgede tek ve çift tırnaklar için işlevin nasıl işlem yapacağı belirtilir. Öntanımlı olan ENT_COMPAT ile geriye uyumlu olarak sadece çift tırnaklar dönüştürülür, tek tırnaklara dokunulmaz. ENT_QUOTES belirtilmişse çift tırnaklara ilaveten tek tırnaklar da dönüştürülür. ENT_NOQUOTES belirtilirse ne tek ne de çift tırnaklar dönüştürülür.

Dönen Değerler

Dönüşüm tablosunu bir dizi olarak döndürür.

Örnekler

Örnek 1 - Dönüşüm tablosu örneği

<?php
$trans = get_html_translation_table(HTML_ENTITIES);
$str = "Hallo & <Frau> & Krämer";
$encoded = strtr($str, $trans);

echo $encoded;
?>

Yukarıdaki örneğin çıktısı:

Hallo &amp; &lt;Frau&gt; &amp; Kr&auml;mer

Ayrıca Bakınız

  • htmlspecialchars() - Özel karakterleri HTML öğeleri haline getirir
  • htmlentities() - Dönüştürülebilecek tüm karakterleri HTML öğeleri haline getirir
  • html_entity_decode() - Dönüştürülebilecek tüm HTML öğelerini karakter haline getirir

fprintf
hebrev
Dizge İşlevleri


Mantıksal İbranice metni görsel metne dönüştürür

get_html_translation_table
hebrevc
Dizge İşlevleri
PHP Manual

hebrev

(PHP 4, PHP 5, PHP 7)

hebrev — Mantıksal İbranice metni görsel metne dönüştürür

Açıklama

string hebrev ( string $ibranice_metin [, int $satırdaki_azami_krk_sayısı = 0 ] )

Mantıksal İbranice metni görsel metne dönüştürür.

İşlev sözcükleri bölmekten kaçınmaya çalışır.

Değiştirgeler

ibranice_metin

İbranice girdi dizgesi.

satırdaki_azami_krk_sayısı

İsteğe bağlı bu değiştirge ile her satırda bulunabilecek azami karakter sayısı belirtilebilir.

Dönen Değerler

Görsel dizge.

Ayrıca Bakınız

  • hebrevc() - Mantıksal İbranice metni satırsonlarıyla birlikte görsel metne dönüştürür

get_html_translation_table
hebrevc
Dizge İşlevleri


Mantıksal İbranice metni satırsonlarıyla birlikte görsel metne dönüştürür

hebrev
hex2bin
Dizge İşlevleri
PHP Manual

hebrevc

(PHP 4, PHP 5, PHP 7)

hebrevc — Mantıksal İbranice metni satırsonlarıyla birlikte görsel metne dönüştürür

Açıklama

string hebrevc ( string $ibranice_metin [, int $satırdaki_azami_krk_sayısı = 0 ] )

Satırsonu (\n) karaktelerini "<br>\n" dizgesine dönüştürmesi dışında hebrev() işlevi gibidir.

İşlev sözcükleri bölmekten kaçınmaya çalışır.

Değiştirgeler

ibranice_metin

İbranice girdi dizgesi.

satırdaki_azami_krk_sayısı

İsteğe bağlı bu değiştirge ile her satırda bulunabilecek azami karakter sayısı belirtilebilir.

Dönen Değerler

Görsel dizge.

Ayrıca Bakınız

  • hebrev() - Mantıksal İbranice metni görsel metne dönüştürür

hebrev
hex2bin
Dizge İşlevleri


Decodes a hexadecimally encoded binary string

hebrevc
html_entity_decode
Dizge İşlevleri
PHP Manual

hex2bin

(PHP >= 5.4.0)

hex2bin — Decodes a hexadecimally encoded binary string

Açıklama

string hex2bin ( string $data )

Decodes a hexadecimally encoded binary string.

Dikkat

This function does NOT convert a hexadecimal number to a binary number. This can be done using the base_convert() function.

Değiştirgeler

data

Hexadecimal representation of data.

Dönen Değerler

Returns the binary representation of the given data başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

If the hexadecimal input string is of odd length or invalid hexadecimal string an E_WARNING level error is thrown.

Sürüm Bilgisi

Sürüm: | Açıklama
5.5.1 | A warning is thrown if the input string is invalid hexadecimal string.
5.4.4 | A warning is thrown if the input string is of odd length. In PHP 5.4.0 the string was silently accepted, but the last byte was truncated.

Örnekler

Örnek 1 hex2bin() example

<?php
$hex = hex2bin("6578616d706c65206865782064617461");
var_dump($hex);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(16) "example hex data"

Ayrıca Bakınız

  • bin2hex() - Bir ikil verinin onaltılık gösterimini elde eder
  • unpack() - Paketlenmiş bir ikil dizgeden verileri ayrıştırır

hebrevc
html_entity_decode
Dizge İşlevleri


Dönüştürülebilecek tüm HTML öğelerini karakter haline getirir

hex2bin
htmlentities
Dizge İşlevleri
PHP Manual

html_entity_decode

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

html_entity_decode — Dönüştürülebilecek tüm HTML öğelerini karakter haline getirir

Açıklama

string html_entity_decode ( string $dizge [, int $öncelem_türü = ENT_COMPAT [, string $karküm ]] )

html_entity_decode() işlevi htmlentities() işlevinin tersine bir karaktere dönüşebilecek tüm HTML öğelerini dönüştürür.

Değiştirgeler

dizge

Girdi dizgesi.

öncelem_türü

Seçimlik öncelem_türü değiştirgesi ile çift ve tek tırnaklar için işlevin nasıl davranacağını belirleyebilirsiniz. ENT_COMPAT öntanımlı olmak üzere şu üç sabitten biri belirtilebilir:

Olası öncelem_türü sabitleri
Sabit İsmi | Açıklama
ENT_COMPAT | Sadece çift tırnaklar dönüştürülür, tek tırnaklara dokunulmaz.
ENT_QUOTES | Çift tırnaklara ilaveten tek tırnaklar da dönüştürülür.
ENT_NOQUOTES | Ne tek ne de çift tırnaklar dönüştürülür.

karküm

Dönüşümde kullanılacak karakter kümesi. ISO-8859-1 öntanımlıdır.

Aşağıdaki karakter kümeleri PHP 4.3.0 ve sonrasında desteklenmektedirr.

Desteklenen karakter kümeleri
Karakter kümesi | Takma adı | Açıklama
ISO-8859-1 | ISO8859-1 | Batı Avrupa, Latin-1
ISO-8859-15 | ISO8859-15 | Doğu Avrupa, Latin-9. Euro işaretini ekler, Fransızca ve Fince harfler Latin-1'de (ISO-8859-1) yoktur.
UTF-8 | ASCII uyumlu 8 bitlik çok baytlı Evrenkod.
cp866 | ibm866, 866 | DOS'a özgü Kril karakter kümesi. Bu karakter kümesi 4.3.2'den beri desteklenmektedir.
cp1251 | Windows-1251, win-1251, 1251 | Windows'a özgü Kril karakter kümesi. Bu karakter kümesi 4.3.2'den beri desteklenmektedir.
cp1252 | Windows-1252, 1252 | Doğu Avrupa için Windows'a özgü karakter kümesi.
KOI8-R | koi8-ru, koi8r | Rusça. Bu karakter kümesi 4.3.2'den beri desteklenmektedir.
BIG5 | 950 | Geleneksel Çince, aslında Tayvan'da kullanılır.
GB2312 | 936 | Basitleştirilmiş Çince, ulusal standart karakter kümesi.
BIG5-HKSCS | Geleneksel Çince, Hong Kong eklentisi ile Big5.
Shift_JIS | SJIS, 932 | Japonca.
EUC-JP | EUCJP | Japonca.

Bilginize: Bunlardan başka karakter kümesi tanınmaz ve yerlerine ISO-8859-1 kullanılır.

Dönen Değerler

Kodlaması çözülmüş dizge.

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.0 | Çok baytlı karakter desteği eklendi.

Örnekler

Örnek 1 - HTML öğelerinin karakterlere dönüştürülmesi

<?php
$orig = "I'll \"walk\" the <b>dog</b> now";

$a = htmlentities($orig);

$b = html_entity_decode($a);

echo $a; // I'll &quot;walk&quot; the &lt;b&gt;dog&lt;/b&gt; now

echo $b; // I'll "walk" the <b>dog</b> now

// PHP 4.3.0 ve öncesi için bu şöyle yapılır:
function unhtmlentities($string)
{
    // sayısal öğeleri yerleştirelim
    $string = preg_replace('~&#x([0-9a-f]+);~ei', 'chr(hexdec("\\1"))', $string);
    $string = preg_replace('~&#([0-9]+);~e', 'chr("\\1")', $string);
    // sayıl öğeleri değiştirelim
    $trans_tbl = get_html_translation_table(HTML_ENTITIES);
    $trans_tbl = array_flip($trans_tbl);
    return strtr($string, $trans_tbl);
}

$c = unhtmlentities($a);

echo $c; // I'll "walk" the <b>dog</b> now

?>

Notlar

Bilginize:

trim(html_entity_decode('&nbsp;')); ile dizgenin neden boş bir dizgeye dönüşmediğini merak ediyor olabilirsiniz. Bunun sebebi '&nbsp;' öğesinin ASCII kodunun 32 değil 160 olmasıdır.

Ayrıca Bakınız

  • htmlentities() - Dönüştürülebilecek tüm karakterleri HTML öğeleri haline getirir
  • htmlspecialchars() - Özel karakterleri HTML öğeleri haline getirir
  • get_html_translation_table() - htmlspecialchars ve htmlentities tarafından kullanılan dönüşüm tablosunu döndürür
  • urldecode() - URL kodlamalı dizgenin kodlamasını çözer

hex2bin
htmlentities
Dizge İşlevleri


Dönüştürülebilecek tüm karakterleri HTML öğeleri haline getirir

html_entity_decode
htmlspecialchars_decode
Dizge İşlevleri
PHP Manual

htmlentities

(PHP 4, PHP 5, PHP 7)

htmlentities — Dönüştürülebilecek tüm karakterleri HTML öğeleri haline getirir

Açıklama

string htmlentities ( string $dizge [, int $öncelem_türü = ENT_COMPAT [, string $karküm [, bool $çifte_kodlama = true ]]] )

HTML öğesi olarak bir karşılığı bulunan tüm karakterleri dönüştürmesi dışında htmlspecialchars() işlevi gibidir.

Bu işlev ile dönüştürülen bir dizgeyi eski haline getirmek için html_entity_decode() işlevini kullanabilirsiniz.

Değiştirgeler

dizge

Girdi dizgesi.

öncelem_türü

htmlspecialchars() gibi seçimlik öncelem_türü değiştirgesi ile çift ve tek tırnaklar için işlevin nasıl davranacağını belirleyebilirsiniz. ENT_COMPAT öntanımlı olmak üzere şu üç sabitten biri belirtilebilir:

Olası öncelem_türü sabitleri
Sabit İsmi | Açıklama
ENT_COMPAT | Sadece çift tırnaklar dönüştürülür, tek tırnaklara dokunulmaz.
ENT_QUOTES | Çift tırnaklara ilaveten tek tırnaklar da dönüştürülür.
ENT_NOQUOTES | Ne tek ne de çift tırnaklar dönüştürülür.

karküm

Dönüşümde kullanılacak karakter kümesi. ISO-8859-1 öntanımlıdır.

Aşağıdaki karakter kümeleri PHP 4.3.0 ve sonrasında desteklenmektedirr.

Desteklenen karakter kümeleri
Karakter kümesi | Takma adı | Açıklama
ISO-8859-1 | ISO8859-1 | Batı Avrupa, Latin-1
ISO-8859-15 | ISO8859-15 | Doğu Avrupa, Latin-9. Euro işaretini ekler, Fransızca ve Fince harfler Latin-1'de (ISO-8859-1) yoktur.
UTF-8 | ASCII uyumlu 8 bitlik çok baytlı Evrenkod.
cp866 | ibm866, 866 | DOS'a özgü Kril karakter kümesi. Bu karakter kümesi 4.3.2'den beri desteklenmektedir.
cp1251 | Windows-1251, win-1251, 1251 | Windows'a özgü Kril karakter kümesi. Bu karakter kümesi 4.3.2'den beri desteklenmektedir.
cp1252 | Windows-1252, 1252 | Doğu Avrupa için Windows'a özgü karakter kümesi.
KOI8-R | koi8-ru, koi8r | Rusça. Bu karakter kümesi 4.3.2'den beri desteklenmektedir.
BIG5 | 950 | Geleneksel Çince, aslında Tayvan'da kullanılır.
GB2312 | 936 | Basitleştirilmiş Çince, ulusal standart karakter kümesi.
BIG5-HKSCS | Geleneksel Çince, Hong Kong eklentisi ile Big5.
Shift_JIS | SJIS, 932 | Japonca.
EUC-JP | EUCJP | Japonca.

Bilginize: Bunlardan başka karakter kümesi tanınmaz ve yerlerine ISO-8859-1 kullanılır.

çifte_kodlama

Bu değiştirgede FALSE belirtilirse zaten kodlanmış HTML öğeleri tekrar kodlanmaz. Öntanımlı olarak herşey dönüştürülür.

Dönen Değerler

Dönüştürülen dizge.

Sürüm Bilgisi

Sürüm: | Açıklama
5.2.3 | çifte_kodlama değiştirgesi eklendi.
4.1.0 | karküm değiştirgesi eklendi.
4.0.3 | öncelem_türü değiştirgesi eklendi.

Örnekler

Örnek 1 - htmlentities() örneği

<?php
$str = "<b>Tek</b> bir 'tırnak'";

// Çıktısı: &lt;b&gt;Tek&lt;/b&gt; bir 'tırnak'
echo htmlentities($str);

// Çıktısı: &lt;b&gt;Tek&lt;/b&gt; bir &#039;quote&#039;
echo htmlentities($str, ENT_QUOTES);
?>

Ayrıca Bakınız

  • html_entity_decode() - Dönüştürülebilecek tüm HTML öğelerini karakter haline getirir
  • get_html_translation_table() - htmlspecialchars ve htmlentities tarafından kullanılan dönüşüm tablosunu döndürür
  • htmlspecialchars() - Özel karakterleri HTML öğeleri haline getirir
  • nl2br() - Dizgedeki tüm satırsonlarının yerine HTML satır katlayıcıları yerleştirilir
  • urlencode() - Dizgeye URL kodlaması uygular

html_entity_decode
htmlspecialchars_decode
Dizge İşlevleri


Özel HTML öğelerini gerisin geriye karakterlere dönüştürür

htmlentities
htmlspecialchars
Dizge İşlevleri
PHP Manual

htmlspecialchars_decode

(PHP 5 >= 5.1.0, PHP 7)

htmlspecialchars_decode — Özel HTML öğelerini gerisin geriye karakterlere dönüştürür

Açıklama

string htmlspecialchars_decode ( string $dizge [, int $öncelem_türü = ENT_COMPAT ] )

Bu işlev htmlspecialchars() işlevinin zıddıdır. HTML öğelerini gerisin geriye karakterlere dönüştürür

Dönüştürülen öğeler: &amp;, &quot; (ENT_NOQUOTES belirtilmişse), &#039; (ENT_QUOTES belirtilmişse), &lt; ve &gt;.

Değiştirgeler

dizge

Kodu çözülecek dizge.

öncelem_türü

Şu sabitlerden biri olabilir:

öncelem_türü sabitleri
Sabit İsmi | Açıklama
ENT_COMPAT | Çift tırnaklar dönüştürülür, tek tırnaklara dokunulmaz (öntanımlı)
ENT_QUOTES | Hem tek hem de çift tırnaklar dönüştürülür
ENT_NOQUOTES | Ne tek ne de çift tırnaklar dönüştürülür

Dönen Değerler

Kodlaması çözülmüş dizge.

Örnekler

Örnek 1 - htmlspecialchars_decode() örneği

<?php
$str = '<p>Bu -&gt; &quot;</p>';

echo htmlspecialchars_decode($str);

// Burada tırnaklar dönüştürülmüyor
echo htmlspecialchars_decode($str, ENT_NOQUOTES);
?>

Yukarıdaki örneğin çıktısı:

<p>Bu -> "</p>
<p>Bu -> &quot;</p>

Ayrıca Bakınız

  • htmlspecialchars() - Özel karakterleri HTML öğeleri haline getirir
  • html_entity_decode() - Dönüştürülebilecek tüm HTML öğelerini karakter haline getirir
  • get_html_translation_table() - htmlspecialchars ve htmlentities tarafından kullanılan dönüşüm tablosunu döndürür

htmlentities
htmlspecialchars
Dizge İşlevleri


Özel karakterleri HTML öğeleri haline getirir

htmlspecialchars_decode
implode
Dizge İşlevleri
PHP Manual

htmlspecialchars

(PHP 4, PHP 5, PHP 7)

htmlspecialchars — Özel karakterleri HTML öğeleri haline getirir

Açıklama

string htmlspecialchars ( string $dizge [, int $öncelem_türü = ENT_COMPAT [, string $karküm [, bool $çifte_kodlama = true ]]] )

Bazı karakterler HTML'de özel anlama sahiptir ve anlamlarını korumaları için HTML öğesi olarak gösterilmesi gerekir. Bu işlev bu dönüşümleri yapılmış olarak bir dizge döndürür. Her gün HTML programlayanlar için bu dönüşümler çok yararlıdır. Eğer tüm HTML karakter öğelerinin dönüştürülmesi gerekiyorsa htmlentities() işlevini kullanın.

Bu işlev kullanıcı tarafından sağlanan metni HTML imleniminden arındırmak için yararlıdır.

Dönüşüm sırasında şunlar yapılır:

  • '&' (ve imi) '&amp;' haline gelir.
  • '"' (çift tırnak) ENT_NOQUOTES belirtilmişse '&quot;' haline gelir.
  • ''' (tek tırnak) ENT_QUOTES belirtilmişse '&#039;' haline gelir.
  • '<' (küçüktür) '&lt;' haline gelir
  • '>' (büyüktür) '&gt;' haline gelir

Değiştirgeler

dizge

Dönüştürülecek dizge.

öncelem_türü

Belirtilmesi isteğe bağlı olan bu değiştirgede tek ve çift tırnaklar için işlevin nasıl işlem yapacağı belirtilir. Öntanımlı olan ENT_COMPAT ile geriye uyumlu olarak sadece çift tırnaklar dönüştürülür, tek tırnaklara dokunulmaz. ENT_QUOTES belirtilmişse çift tırnaklara ilaveten tek tırnaklar da dönüştürülür. ENT_NOQUOTES belirtilirse ne tek ne de çift tırnaklar dönüştürülür.

karküm

Dönüşümde kullanılacak karakter kümesi. ISO-8859-1 öntanımlıdır.

Bu işlevin amacı gereği, ISO-8859-1, ISO-8859-15, UTF-8, cp866, cp1251, cp1252 ve KOI8-R karakter kümeleri, aynı konumları işgal eden karakterler bakımından eşdeğerdir.

Aşağıdaki karakter kümeleri PHP 4.3.0 ve sonrasında desteklenmektedirr.

Desteklenen karakter kümeleri
Karakter kümesi | Takma adı | Açıklama
ISO-8859-1 | ISO8859-1 | Batı Avrupa, Latin-1
ISO-8859-15 | ISO8859-15 | Doğu Avrupa, Latin-9. Euro işaretini ekler, Fransızca ve Fince harfler Latin-1'de (ISO-8859-1) yoktur.
UTF-8 | ASCII uyumlu 8 bitlik çok baytlı Evrenkod.
cp866 | ibm866, 866 | DOS'a özgü Kril karakter kümesi. Bu karakter kümesi 4.3.2'den beri desteklenmektedir.
cp1251 | Windows-1251, win-1251, 1251 | Windows'a özgü Kril karakter kümesi. Bu karakter kümesi 4.3.2'den beri desteklenmektedir.
cp1252 | Windows-1252, 1252 | Doğu Avrupa için Windows'a özgü karakter kümesi.
KOI8-R | koi8-ru, koi8r | Rusça. Bu karakter kümesi 4.3.2'den beri desteklenmektedir.
BIG5 | 950 | Geleneksel Çince, aslında Tayvan'da kullanılır.
GB2312 | 936 | Basitleştirilmiş Çince, ulusal standart karakter kümesi.
BIG5-HKSCS | Geleneksel Çince, Hong Kong eklentisi ile Big5.
Shift_JIS | SJIS, 932 | Japonca.
EUC-JP | EUCJP | Japonca.

Bilginize: Bunlardan başka karakter kümesi tanınmaz ve yerlerine ISO-8859-1 kullanılır.

çifte_kodlama

Bu değiştirgede FALSE belirtilirse zaten kodlanmış HTML öğeleri tekrar kodlanmaz. Öntanımlı olarak herşey dönüştürülür.

Dönen Değerler

Dönüştürülen dizge.

Sürüm Bilgisi

Sürüm: | Açıklama
5.2.3 | çifte_kodlama değiştirgesi eklendi.
4.1.0 | karküm değiştirgesi eklendi.

Örnekler

Örnek 1 - htmlspecialchars() örneği

<?php
$yenisi = htmlspecialchars("<a href='dnm'>Deneme</a>", ENT_QUOTES);
echo $yenisi; // &lt;a href=&#039;dnm&#039;&gt;Deneme&lt;/a&gt;
?>

Notlar

Bilginize:

Bu işlev yukarıda listelenenler dışında hiçbir şeyi dönüştürmez. Tam bir dönüşüm istiyorsanız htmlentities() işlevine bakınız.

Ayrıca Bakınız

  • get_html_translation_table() - htmlspecialchars ve htmlentities tarafından kullanılan dönüşüm tablosunu döndürür
  • htmlspecialchars_decode() - Özel HTML öğelerini gerisin geriye karakterlere dönüştürür
  • strip_tags() - Bir dizgeden HTML ve PHP etiketlerini ayıklar
  • htmlentities() - Dönüştürülebilecek tüm karakterleri HTML öğeleri haline getirir
  • nl2br() - Dizgedeki tüm satırsonlarının yerine HTML satır katlayıcıları yerleştirilir

htmlspecialchars_decode
implode
Dizge İşlevleri


Dizi elemanlarını birleştirip bir dizge elde eder

htmlspecialchars
join
Dizge İşlevleri
PHP Manual

implode

(PHP 4, PHP 5, PHP 7)

implode — Dizi elemanlarını birleştirip bir dizge elde eder

Açıklama

string implode ( string $yapıştırıcı , array $parçalar )
string implode ( array $parçalar )

Dizi elemanlarını bir yapıştırıcı ile birleştirir.

Bilginize:

implode() işlevi geçmişle ilgili sorunlar yüzünden değiştirgelerini herhangi bir sırada kabul edebilir. explode() ile uyumluluk adına değiştirgeler, bu belgede belirtilen sırayla belirtilirse daha iyi olur.

Değiştirgeler

yapıştırıcı

Öntanımlı olarak boş bir dizgedir. Bu bakımdan işlevin bu değiştirge belirtilmeden kullanılması tercih edilmez.

parçalar

Dizge haline getirilecek dizi.

Dönen Değerler

Her eleman arasına yapıştırıcı dizge yerleştirilmiş olarak dizi elemanlarını aynı sırada içeren bir dizge döner.

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.0 | yapıştırıcı değiştirgesi isteğe bağlı yapıldı.

Örnekler

Örnek 1 - implode() örneği

<?php

$dizi = array('soyadı', 'eposta', 'telefon');
$virgül_ayraçlı = implode(",", $array);

echo $virgül_ayraçlı; // soyadı,eposta,telefon

?>

Notlar

Bilginize: Bu işlev ikil dosyalarla çalışırken dosya içeriğini değiştirmez.

Ayrıca Bakınız

  • explode() - Bir dizgeyi bir ayraca göre bölüp bir dizi haline getirir
  • split() - Belirtilen dizgeyi düzenli ifadeye göre dizi elemanlarına böler

htmlspecialchars
join
Dizge İşlevleri


implode işlevinin takma adıdır

implode
lcfirst
Dizge İşlevleri
PHP Manual

join

(PHP 4, PHP 5, PHP 7)

join — implode() işlevinin takma adıdır

Açıklama

Bu işlev implode() işlevinin takma adıdır.

implode
lcfirst
Dizge İşlevleri


Bir dizgenin ilk karakterini küçük harf yapar

join
levenshtein
Dizge İşlevleri
PHP Manual

lcfirst

(PHP 5 >= 5.3.0, PHP 7)

lcfirst — Bir dizgenin ilk karakterini küçük harf yapar

Açıklama

string lcfirst ( string $dizge )

Eğer dizge'nin ilk karakteri harf ise, küçük harfe çevirerek dizgeyi döndürür.

Burada, 'harf' geçerli yerele göre saptanır. Mesela, öntanımlı "C" yerelinde Ü harfi ü harfine çevirilmeyecektir.

Değiştirgeler

dizge

Girdi dizgesi.

Dönen Değerler

Elde edilen dizgeyi döndürür.

Örnekler

Örnek 1 - lcfirst() örneği

<?php
$foo = 'HelloWorld';
$foo = lcfirst($foo);             // helloWorld

$bar = 'HELLO WORLD!';
$bar = lcfirst($bar);             // hELLO WORLD!
$bar = lcfirst(strtoupper($bar)); // hELLO WORLD!
?>

Ayrıca Bakınız

  • ucfirst() - Dizgenin ilk karakterini büyük harfe çevirir
  • strtolower() - Bir dizgenin harflerini küçük harfe çevirir
  • strtoupper() - Bir dizgenin harflerini büyük harfe çevirir
  • ucwords() - Dizgedeki her sözcüğün ilk harfini büyük harf yapar

join
levenshtein
Dizge İşlevleri


İki dizge arasındaki Levenştayn mesafesini hesaplar

lcfirst
localeconv
Dizge İşlevleri
PHP Manual

levenshtein

(PHP 4 >= 4.0.1, PHP 5, PHP 7)

levenshtein — İki dizge arasındaki Levenştayn mesafesini hesaplar

Açıklama

int levenshtein ( string $d1 , string $d2 )
int levenshtein ( string $d1 , string $d2 , int $yerleştirme_bedeli , int $değiştirme_bedeli , int $silme_bedeli )

Levenştayn mesafesi, d1 dizgesini d2'ye dönüştürmek için silinecek, yerleştirilecek veya değiştirilecek karakterlerin asgarisini tanımlar. Algoritmanın hesaplama karmaşıklığı, n ve m, d1 ve d2'nin uzunluğu olmak üzere O(m*n)'dir (Hesaplama karmaşıklığı O(max(n,m)**3) olan similar_text() işlevine göre daha iyi olsa da hala pahalıdır).

İşlevin en basit kullanımında, işlev sadece iki değiştirge alır ve d1 dizgesini d2'ye dönüştürmek için silinecek, yerleştirilecek veya değiştirilecek karakterlerin sayısını hesaplar.

İşlevin diğer bir kullanım türünde, işlev, yerleştirme, değiştirme ve silme işlemlerinin maliyetini tanımlayan üç değiştirge daha alır. Bu daha genel ve daha uyarlanabilir bir kullanım olsa da o kadar verimli değildir.

Değiştirgeler

d1

Levenştayn mesafesi değerlendirilecek dizgelerden biri.

d2

Levenştayn mesafesi değerlendirilecek dizgelerden biri.

yerleştirme_bedeli

Yerleştirme maliyetini tanımlar.

değiştirme_bedeli

Değiştirme maliyetini tanımlar.

silme_bedeli

Silme maliyetini tanımlar.

Dönen Değerler

Belirtilen diziler 255 karakterlik üst sınırdan uzunsa -1 değilse Levenştayn mesafesi döner.

Örnekler

Örnek 1 - levenshtein() örneği

<?php
// girdi yanlış yazılmış olsun
$input = 'carrrot';

// bir sözcük dizisiyle karşılaştıralım
$words  = array('apple','pineapple','banana','orange',
                'radish','carrot','pea','bean','potato');

// en kısa mesafenin bulunamaması durumu
$shortest = -1;

// En kısa mesafeyi bulmak için döngü
foreach ($words as $word) {

    // girdi ile sözcük arasındaki mesafeyi hesaplatalım
    $lev = levenshtein($input, $word);

    // Bir eşleşme var mı bakalım
    if ($lev == 0) {

        // en yakın sözcük bu olacak (tam eşleşme)
        $closest = $word;
        $shortest = 0;

        // Tam bir eşleşme bulduğumuza göre döngüden çıkalım
        break;
    }

    // Eğer bu mesafe bir öncekinden kısaysa
    // veya en kısa mesafe henüz bulunamadıysa
    if ($lev <= $shortest || $shortest < 0) {
        // en yakın eşleşmeyi ve en kısa mesafeyi tanımlayalım
        $closest  = $word;
        $shortest = $lev;
    }
}

echo "Girdi: $input\n";
if ($shortest == 0) {
    echo "Tam eşleşme bulundu: $closest\n";
} else {
    echo "Doğrusu bu olabilir mi?: $closest\n";
}

?>

Yukarıdaki örneğin çıktısı:

Girdi: carrrot
Doğrusu bu olabilir mi?: carrot

Ayrıca Bakınız

  • soundex() - Bir dizgenin sestek anahtarını hesaplar
  • similar_text() - İki dizge arasındaki benzerliği hesaplar
  • metaphone() - Bir dizgenin metafon anahtarını hesaplar

lcfirst
localeconv
Dizge İşlevleri


Sayısal biçemleme bilgisini döndürür

levenshtein
ltrim
Dizge İşlevleri
PHP Manual

localeconv

(PHP 4 >= 4.0.5, PHP 5, PHP 7)

localeconv — Sayısal biçemleme bilgisini döndürür

Açıklama

array localeconv ( void )

Sayı ve para biçemleme bilgisini içeren bir ilişkisel dizi döndürür.

Dönen Değerler

localeconv() işlevi setlocale() tarafından ayarlanan geçerli yerele özgü verinin tamamını ilişkisel bir dizi içinde döndürür. İlişkisel dizi şu alanları içerir:

Dizi elemanı | Açıklama
decimal_point | Ondalık ayracı
thousands_sep | Sayı için binlik ayracı
grouping | Sayısal gruplama içeren dizi
int_curr_symbol | Uluslararası para simgesi (TRL gibi)
currency_symbol | Ulusal para simgesi (TL gibi)
mon_decimal_point | Kuruş ayracı
mon_thousands_sep | Para için binlik ayracı
mon_grouping | Parasal gruplama içeren dizi
positive_sign | Pozitif değerler için işaret
negative_sign | Negatif değerler için işaret
int_frac_digits | Uluslararası kuruş hane sayısı
frac_digits | Ulusal kuruş hane sayısı
p_cs_precedes | Pozitif işareti para simgesinin önünde ise TRUE ardında ise FALSE.
p_sep_by_space | Pozitif işareti ile para simgesi arasında bir boşluk varsa TRUE yoksa FALSE
n_cs_precedes | Para simgesi bir negatif değerin önündeyse TRUE ardındaysa FALSE
n_sep_by_space | Para simgesi ile negatif değer arasında bir boşluk varsa TRUE yoksa FALSE
p_sign_posn
  • 0 - Pozitif miktar ve para simgesi yaylı ayraçlar arasında.
  • 1 - Pozitif işareti, miktar ve para simgesinin önüne konur.
  • 2 - Pozitif işareti, miktar ve para simgesinin ardına konur.
  • 3 - Pozitif işareti, para simgesinin hemen önüne konur.
  • 4 - Pozitif işareti, para simgesinin hemen ardına konur.
n_sign_posn
  • 0 - Negatif miktar ve para simgesi yaylı ayraçlar arasında.
  • 1 - Negatif işareti, miktar ve para simgesinin önüne konur.
  • 2 - Negatif işareti, miktar ve para simgesinin ardına konur.
  • 3 - Negatif işareti, para simgesinin hemen önüne konur.
  • 4 - Negatif işareti, para simgesinin hemen ardına konur.

p_sign_posn ve n_sign_posn bir biçemleme seçenekleri dizgesi içerir. Her sayı yukarıda listelenen durumlardan birini gösterir.

Gruplama alanları sayıların nasıl gruplanacağını tanımlayan diziler içerir. Örneğin, tr_TR yereli için para gruplama alanı 3 ve 3 değerlerinden oluşan bir dizi içerir. Daha yüksek indis öteki gruplamaya bırakılır. Bir dizi elemanı CHAR_MAX değerine eşitse başka gruplama yapılmaz. Bir dizi elemanı 0'a eşitse önceki elemanın kullanılması gerekir.

Örnekler

Örnek 1 - localeconv() örneği

<?php
if (false !== setlocale(LC_ALL, 'tr_TR.UTF-8')) {
    $locale_info = localeconv();
    print_r($locale_info);
}
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [decimal_point] => ,
    [thousands_sep] => .
    [int_curr_symbol] => TRL
    [currency_symbol] => TL
    [mon_decimal_point] => ,
    [mon_thousands_sep] => .
    [positive_sign] =>
    [negative_sign] => -
    [int_frac_digits] => 2
    [frac_digits] => 2
    [p_cs_precedes] => 0
    [p_sep_by_space] => 1
    [n_cs_precedes] => 0
    [n_sep_by_space] => 1
    [p_sign_posn] => 1
    [n_sign_posn] => 1
    [grouping] => Array
        (
            [0] => 3
            [1] => 3
        )

    [mon_grouping] => Array
        (
            [0] => 3
            [1] => 3
        )

)

Ayrıca Bakınız

  • setlocale() - Yereli ayarlar

levenshtein
ltrim
Dizge İşlevleri


Dizgenin başındaki boşlukları (veya diğer karakterleri) budar

localeconv
md5_file
Dizge İşlevleri
PHP Manual

ltrim

(PHP 4, PHP 5, PHP 7)

ltrim — Dizgenin başındaki boşlukları (veya diğer karakterleri) budar

Açıklama

string ltrim ( string $dizge [, string $karakterler ] )

Bu işlev dizge'nin başındaki boşlukları budar.

Değiştirgeler

dizge

Budanacak dizge.

karakterler

Seçimlik olarak, karakterler değiştirgesi kullanılarak budanacak karakterler belirlenebilir. Basitçe budamak istediğiniz tüm karakterleri belirtin. Bir karakter aralığını .. kullanarak belirtebilirsiniz.

Dönen Değerler

Bu işlev dizge'nin başındaki boşlukları budar. İkinci değiştirge olmaksızın ltrim() sadece aşağıdaki karakterleri budayacaktır:

  • " " (ASCII 32 (0x20)), sıradan boşluk.
  • "\t" (ASCII 9 (0x09)), sekme.
  • "\n" (ASCII 10 (0x0A)), satırsonu.
  • "\r" (ASCII 13 (0x0D)), satırbaşı.
  • "\0" (ASCII 0 (0x00)), NUL-bayt.
  • "\x0B" (ASCII 11 (0x0B)), dikey sekme.

Sürüm Bilgisi

Sürüm: | Açıklama
4.1.0 | İsteğe bağlı karakterler değiştirgesi eklendi.

Örnekler

Örnek 1 - ltrim() örneği

<?php

$metin   = "\t\tBir kaç kelam :) ...  ";
$ikil = "\x09Örnek dizge\x0A";
$selam  = "Merhaba Dünya";
var_dump($metin, $ikil, $selam);

print "\n";

$kırpık = ltrim($metin);
var_dump($kırpık);

$kırpık = ltrim($metin, " \t.");
var_dump($kırpık);

$kırpık = ltrim($selam, "aerMy");
var_dump($kırpık);

// $ikil'in başındaki ve sonundaki ASCII denetim karakterlerini budar
// (0'dan 31'e kadar, 0 ve 31 dahil)
$temiz = ltrim($ikil, "\x00..\x1F");
var_dump($temiz);

?>

Yukarıdaki örneğin çıktısı:

string(25) "            Bir kaç kelam :) ...  "
string(14) "    Örnek dizge
"
string(14) "Merhaba Dünya"

string(23) "Bir kaç kelam :) ...  "
string(23) "Bir kaç kelam :) ...  "
string(11) "haba Dünya"
string(13) "Örnek dizge
"

Ayrıca Bakınız

  • trim() - Dizgenin başındaki ve sonundaki boşlukları (veya diğer karakterleri) budar
  • rtrim() - Dizgenin sonundaki boşlukları (veya diğer karakterleri) budar

localeconv
md5_file
Dizge İşlevleri


Belirtilen dosyanın md5 özetini hesaplar

ltrim
md5
Dizge İşlevleri
PHP Manual

md5_file

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

md5_file — Belirtilen dosyanın md5 özetini hesaplar

Açıklama

string md5_file ( string $dosya [, bool $ham_çıktı = false ] )

dosya dosyasının MD5 özetini » RSA Data Security, Inc. MD5 İleti Özeti Algoritmasını kullanarak hesaplar ve bu özeti döndürür. Çırpı 32 haneli onaltılık bir sayıdır.

Değiştirgeler

dosya

Dosya ismi.

ham_çıktı

İsteğe bağlı bu değiştirgede TRUE belirtirseniz MD5 özeti 16 bayt uzunlukta ham ikil biçemli bir dizge olarak döner. FALSE öntanımlıdır.

Dönen Değerler

Başarıli bir işlem sonunda bir dizge aksi takdirde FALSE dördürür.

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.0 | ham_çıktı değiştirgesi eklendi.
5.1.0 | İşlev akım arayüzü kullanacak şekilde değiştirildi. Yani dosya belirtirken artık md5_file('http://example.com/..') gibi bir sarmalayıcı kullanabilirsiniz.

Örnekler

Örnek 1 - md5_file()örneği

<?php
$file = 'php-5.3.0alpha2-Win32-VC9-x64.zip';

echo '$file . ' dosyasının MD5 özeti: ' . md5_file($file);
?>

Ayrıca Bakınız

  • md5() - Bir dizgenin md5 özetini hesaplar
  • sha1_file() - Bir dosyanın sha1 özetini hesaplar
  • crc32() - Bir dizgenin crc32 çok terimlisini hesaplar

ltrim
md5
Dizge İşlevleri


Bir dizgenin md5 özetini hesaplar

md5_file
metaphone
Dizge İşlevleri
PHP Manual

md5

(PHP 4, PHP 5, PHP 7)

md5 — Bir dizgenin md5 özetini hesaplar

Açıklama

string md5 ( string $dizge [, bool $ham_çıktı = false ] )

dizge dizgesinin MD5 özetini » RSA Data Security, Inc. MD5 İleti Özeti Algoritmasını kullanarak hesaplar ve bu özeti döndürür.

Değiştirgeler

dizge

Özeti hesaplanacak dizge.

ham_çıktı

İsteğe bağlı bu değiştirgede TRUE belirtirseniz MD5 özeti 16 bayt uzunlukta ham ikil biçemli bir dizge olarak döner. FALSE öntanımlıdır.

Dönen Değerler

İleti özetini 32 haneli onaltılık bir sayı dizgesi olarak olarak döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.0 | ham_çıktı değiştirgesi eklendi.

Örnekler

Örnek 1 - md5() örneği

<?php
$str = 'apple';

if (md5($str) === '1f3870be274f6c49b3e31a0c6728957f') {
    echo "Yeşil elma mı istersin kırmızı mı?";
    exit;
}
?>

Ayrıca Bakınız

  • md5_file() - Belirtilen dosyanın md5 özetini hesaplar
  • sha1_file() - Bir dosyanın sha1 özetini hesaplar
  • crc32() - Bir dizgenin crc32 çok terimlisini hesaplar
  • sha1() - Bir dizgenin sha1 özetini hesaplar
  • hash() - Bir ileti özeti üretir

md5_file
metaphone
Dizge İşlevleri


Bir dizgenin metafon anahtarını hesaplar

md5
money_format
Dizge İşlevleri
PHP Manual

metaphone

(PHP 4, PHP 5, PHP 7)

metaphone — Bir dizgenin metafon anahtarını hesaplar

Açıklama

string metaphone ( string $dizge [, int $sesler = 0 ] )

dizge dizgesinin metafon anahtarını hesaplar.

Benzer sesletime sahip sözcükler için aynı anahtarı üretmesi bakımından soundex() işlevine benzer. Ancak İngilizce okunuşun temel kuralları kullanıldığından soundex() işlevine göre daha doğru anahtarlar üretir. Ayrıca bu işlevin ürettiği anahtarlar değişken uzunluktadır.

Metafon Lawrence Philips <lphilips at verity dot com> tarafından geliştirilmiş ve şu kitapta açıklanmıştır: ["Practical Algorithms for Programmers", Binstock & Rex, Addison Wesley, 1995]

Değiştirgeler

dizge

Girdi dizgesi.

sesler

Dönen Değerler

Metafonu bir dizge olarak döndürür.

md5
money_format
Dizge İşlevleri


Bir sayıyı para olarak biçemler

metaphone
nl_langinfo
Dizge İşlevleri
PHP Manual

money_format

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

money_format — Bir sayıyı para olarak biçemler

Açıklama

string money_format ( string $biçem , float $sayı )

money_format() işlevi belirtilen sayı'nın para olarak biçemlenmiş sürümünü döndürür. Bu gerçeklenimin bir defada sadece bir sayıyı dönüştürmesi dışında C kütüphanesinin strfmon() işlevinin yaptığını yapar.

Değiştirgeler

biçem

Biçem belirtimleri şu dizilimlerden oluşur:

  • % karakteri

  • seçimlik seçenekler

  • seçimlik alan genişlikleri

  • seçimlik sol taraf hassasiyeti

  • seçimlik sağ taraf hassasiyeti

  • gerekli bir dönüşüm karakteri

Seçenekler

Aşağıdaki seçeneklerden bir veya daha fazlası kullanılabilir:

=f

= iminden sonra gelen bir tek baytlık karakter sayısal dolgu karakteri olarak kullanılır. Boşluk, öntanımlı dolgu karakteridir.

^

Geçerli yerelde tanımlı binlik ayracını iptal eder.

+ veya (

Pozitif ve negatif sayılar için biçemleme tarzını belirler. + kullanılmışsa + ve - için yereldeki eşdeğeri kullanılır. ( kullanılmışsa negatif miktarlar yaylı ayraç içine alınır. Hiçbir şey belirtilmemişse + öntanımlıdır.

!

Çıktı dizgesinde para biriminin bulunmamasını sağlar.

-

Belirtilmesi halinde bütün alanlar sola yanaştırılır (sağ tarafa dolgu yapılır). Belirtilmemesi halinde (öntanımlı durum) alanlar sağa yanaştırılır (sol tarafa dolgu yapılır).

Alan genişliği

w

En küçük alan genişliğini belirten onluk bir rakam. - seçeneği belirtilmedikçe alan sağa yanaştırılır. Öntanımlı değer sıfırdır (0).

Sol taraf hassasiyeti

#n

Ondalık ayracın sol tarafındaki hanelerin azami sayısı (n). Normalde sayıları aynı sütun genişliğinde alt alta dizerken belirtilenden daha az genişliğe sahip sayılarda dolgu yapılması için kullanılır. Burada belirtilenden daha geniş sayılara bu belirtim uygulanmaz.

^ seçeneği ile binlik gruplama engellenmemişse eklenen (varsa) dolgu karakterlerinin öncesine binlik ayracı yerleştirilir. Binlik ayracı dolgu karakterlerine, 0 bile olsalar uygulanmaz.

Hizalamak amacıyla pozitif ve negatif biçemlerin genişliklerini eşitlemek için gerekirse, biçemli çıktıdaki sayıdan önceki veya sonraki herhangi bir karaktere kadar (para birimi veya işaret simgesi) boşluk karakteri doldurulur.

Sağ taraf hassasiyeti

.p

Ondalık ayracın sağındaki hane sayısı (p). Eğer p 0 (sıfır) ise, ondalık ayraç ve sağındaki rakamlar yoksayılır. Sağ taraf hassasiyeti olarak hiçbir şey belirtilmemişse geçerli yereldeki kullanılır. Belirtilen genişlikten daha fazla sayıda hane varsa bu haneler biçemleme öncesi yuvarlatılır.

Dönüşüm karakterleri

i

Sayı yerelin uluslararası para birimine göre biçemlenir (örn, en_US yereli için: USD 1,234.56).

n

Sayı yerelin ulusal para birimine göre biçemlenir (örn, de_DE yereli için: DM1.234,56).

%

% karakteri döner.

sayı

Biçemlenecek sayı.

Dönen Değerler

Biçemlenmiş dizge döner. Biçemlenen sayının önündeki veya ardındaki karakterler değişmeden döner. sayı bir sayısal değer değilse işlev NULL döndürür ve bir E_WARNING çıktılar.

Notlar

Bilginize:

money_format() işlevi sadece sistem strfmon yeteneklerine sahipse tanımlıdır. Örneğin Windows'ta money_format() kullanılamaz.

Bilginize:

Yerelin LC_MONETARY sınıfı bu işlevin davranışını etkiler. Bu bakımdan bu işlevi kullanmadan önce uygun bir yereli öntanımlı yerel yapmak için setlocale() işlevini kullanın.

Örnekler

Örnek 1 - money_format() örneği

Bu işlevin neler yapabileceğini göstermek için farklı yereller kullanacağız.

<?php

$number = 1234.56;

// Amerikan yereli için uluslararası biçemi kullanalım
setlocale(LC_MONETARY, 'en_US');
echo money_format('%i', $number) . "\n";
// USD 1,234.56

// 2 ondalık haneli İtalyan ulusal biçemi
setlocale(LC_MONETARY, 'it_IT');
echo money_format('%.2n', $number) . "\n";
// L. 1.234,56

// Negatif sayı kullanımı
$number = -1234.5672;

// Negatif sayılar için () ve sol tarafı 10 hanelik
// Amerikan ulusal biçemi
setlocale(LC_MONETARY, 'en_US');
echo money_format('%(#10n', $number) . "\n";
// ($        1,234.57)

// Yukarıdaki biçeme ek olarak sağ taraf için 2 hane
// ve dolgu karakteri olarak '*' kullanımı;
echo money_format('%=*(#10.2n', $number) . "\n";
// ($********1,234.57)

// Sola hizalı, 14 hane genişlikte, sol taraf hassasiyeti olarak 8,
// sağ taraf hassasiyeti olarak 2 hanelik, binlik ayracı kullanmaksızın
// Alman yereli için uluslararası biçemi kullanarak sayıyı biçemleyelim
setlocale(LC_MONETARY, 'de_DE');
echo money_format('%=*^-14#8.2i', 1234.56) . "\n";
// DEM 1234,56****

// Dönüşüm belirtiminin önüne ve ardına bir şeyler ekleyelim
setlocale(LC_MONETARY, 'en_GB');
$fmt = 'Son fiyat %i olur (%%10 indirim sonrası)';
echo money_format($fmt, 1234.56) . "\n";
// Son fiyat GBP 1,234.56 olur (%10 indirim sonrası)

?>

Ayrıca Bakınız

  • setlocale() - Yereli ayarlar
  • sscanf() - Girdi dizgesini belli bir biçeme göre yorumlar
  • sprintf() - Biçemli bir dizge döndürür
  • printf() - Biçemli bir dizge çıktılar
  • number_format() - Sayıyı binlik bölümlere ayırır

metaphone
nl_langinfo
Dizge İşlevleri


Dili ve yerel bilgisini sorgular

money_format
nl2br
Dizge İşlevleri
PHP Manual

nl_langinfo

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

nl_langinfo — Dili ve yerel bilgisini sorgular

Açıklama

string nl_langinfo ( int $eleman )

nl_langinfo() işlevi yerel sınıflarındaki elemanlara tek tek erişmek için kullanılır.Tüm elemanları döndüren localeconv() işlevinin tersine, nl_langinfo() belli bir elemanı seçme olanağı verir.

Değiştirgeler

eleman

eleman değiştirgesi elemanın sabit ismi olabileceği gibi elemanın tamsayı değeri de olabilir. Aşağıda açıklamalarıyla birlikte verilen sabit isimleri eleman olarak kullanılabilir. Bu sabitlerin bazıları geçerli yerelde tanımlanmamış olabilir.

nl_langinfo Sabitleri
Sabit | Açıklama
LC_TIME Sınıfının Sabitleri
ABDAY_(1-7) | Haftanın n. gününün kısaltılmış ismi.
DAY_(1-7) | Haftanın n. gününün tam ismi (DAY_1 = Pazar).
ABMON_(1-12) | Yılın n. ayının kısaltılmış ismi.
MON_(1-12) | Yılın n. ayının tam ismi.
AM_STR | Öğleden önce.
PM_STR | Öğleden sonra.
D_T_FMT | Tarih ve saati göstermek için strftime() işlevinde kullanılabilecek dizge.
D_FMT | Tarihi göstermek için strftime() işlevinde kullanılabilecek dizge.
T_FMT | Saati göstermek için strftime() işlevinde kullanılabilecek dizge.
T_FMT_AMPM | 12 saatlik öö/ös gösterimli saati göstermek için strftime() işlevinde kullanılabilecek dizge.
ERA | Diğer çağ ismi.
ERA_YEAR | Diğer çağ biçeminde yıl.
ERA_D_T_FMT | Diğer çağ biçeminde tarih ve saati göstermek için strftime() işlevinde kullanılabilecek dizge.
ERA_D_FMT | Diğer çağ biçeminde tarihi göstermek için strftime() işlevinde kullanılabilecek dizge.
ERA_T_FMT | Diğer çağ biçeminde saati göstermek için strftime() işlevinde kullanılabilecek dizge.
LC_MONETARY Sınıfının Sabitleri
INT_CURR_SYMBOL | Uluslararası para birimi.
CURRENCY_SYMBOL | Yerel para birimi.
CRNCYSTR | CURRENCY_SYMBOL ile aynı.
MON_DECIMAL_POINT | Para için ondalık ayracı.
MON_THOUSANDS_SEP | Para için binlik ayracı.
MON_GROUPING | Para için binlik ayracı.
POSITIVE_SIGN | Pozitif değerler için im.
NEGATIVE_SIGN | Negatif değerler için im.
INT_FRAC_DIGITS | Uluslararası kuruş hanelerinin sayısı.
FRAC_DIGITS | Yerel kuruş hanelerinin sayısı.
P_CS_PRECEDES | CURRENCY_SYMBOL bir pozitif değerin önüne getirilecekse 1 döner.
P_SEP_BY_SPACE | CURRENCY_SYMBOL bir pozitif değerden bir boşlukla ayrılacaksa 1 döner.
N_CS_PRECEDES | CURRENCY_SYMBOL bir negatif değerin önüne getirilecekse 1 döner.
N_SEP_BY_SPACE | CURRENCY_SYMBOL bir negatif değerden bir boşlukla ayrılacaksa 1 döner.
P_SIGN_POSN
  • Para birimi ve miktar yaylı ayraçların arasına alınacaksa 0 döner.
  • İşaret dizgesi, miktar ve para biriminin önüne konacaksa 1 döner.
  • İşaret dizgesi, miktar ve para biriminin ardına konacaksa 2 döner.
  • İşaret dizgesi, para biriminin önüne konacaksa 3 döner.
  • İşaret dizgesi, para biriminin ardına konacaksa 4 döner.
N_SIGN_POSN
LC_NUMERIC Sınıfının Sabitleri
DECIMAL_POINT | Sayılar için ondalık ayraç.
RADIXCHAR | DECIMAL_POINT ile aynı.
THOUSANDS_SEP | Sayılar için binlik ayraç.
THOUSEP | THOUSANDS_SEP ile aynı.
GROUPING
LC_MESSAGES Sınıfının Sabitleri
YESEXPR | 'evet' veya 'yes' girdisi ile eşleşen düzenli ifade dizgesi (Glibc Türkçe yerelinde ikisi de kullanılabilmektedir).
NOEXPR | 'hayır' veya 'no' dizgesi ile eşleşen düzenli ifade girdisi (Glibc Türkçe yerelinde ikisi de kullanılabilmektedir).
YESSTR | 'evet' veya 'yes' için çıktı dizgesi.
NOSTR | 'hayır' veya 'no' çıktı dizgesi.
LC_CTYPE Sınıfının Sabitleri
CODESET | Karakter kodlamasının ismini içeren bir dizge döner.

Dönen Değerler

Bir elemanı bir dizge olarak döndürür. eleman geçersizse FALSE döner.

Notlar

Bilginize: Bu işlev Windows sistemlerinde çalışmaz.

Ayrıca Bakınız

  • setlocale() - Yereli ayarlar
  • localeconv() - Sayısal biçemleme bilgisini döndürür

money_format
nl2br
Dizge İşlevleri


Dizgedeki tüm satırsonlarının yerine HTML satır katlayıcıları yerleştirilir

nl_langinfo
number_format
Dizge İşlevleri
PHP Manual

nl2br

(PHP 4, PHP 5, PHP 7)

nl2br — Dizgedeki tüm satırsonlarının yerine HTML satır katlayıcıları yerleştirilir

Açıklama

string nl2br ( string $string [, bool $xhtml = true ] )

dizge içindeki bütün satırsonu karakterlerinin yerlerine '<br />' veya '<br>' yerleştirilerek elde edilen dizgeyi döndürür.

Değiştirgeler

dizge

Girdi dizgesi.

xhtml

XHTML uyumlu etiket kullanılıp kullanılmayacağını belirler (TRUE öntanımlıdır).

Dönen Değerler

Elde edilen dizge.

Örnekler

Örnek 1 - nl2br() örneği

<?php
echo nl2br("foo isn't\n bar");
?>

Yukarıdaki örneğin çıktısı:

foo isn't<br />
 bar

Örnek 2 - xhtml değiştirgesi kullanımı

<?php
echo nl2br("Hoş Geldiniz\r\nBu bir HTML belgedir", false);
?>

Yukarıdaki örneğin çıktısı:

Hoş Geldiniz<br>
Bu bir HTML belgedir

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | Seçimlik xhtml değiştirgesi eklendi.
4.0.5 | nl2br() XHTML uyumlu oldu. Eski sürümlerde dizge '<br />' yerine '<br>' kullanılarak döndürülürdü.

Ayrıca Bakınız

  • htmlspecialchars() - Özel karakterleri HTML öğeleri haline getirir
  • htmlentities() - Dönüştürülebilecek tüm karakterleri HTML öğeleri haline getirir
  • wordwrap() - Bir dizgeyi belli bir uzunlukta katlar
  • str_replace() - Bir alt dizgenin bütün örneklerini yenisiyle değiştirir

nl_langinfo
number_format
Dizge İşlevleri


Sayıyı binlik bölümlere ayırır

nl2br
ord
Dizge İşlevleri
PHP Manual

number_format

(PHP 4, PHP 5, PHP 7)

number_format — Sayıyı binlik bölümlere ayırır

Açıklama

string number_format ( float $sayı [, int $ondalık_hane ] )
string number_format ( float $sayı , int $ondalık_hane , string $ondalık_ayracı , string $binlik_ayracı )

Bu işlev bir, iki ve dört değiştirge kabul eder (üç değil):

Tek bir değiştirge belirtilmişse sayı, ondalık kısmı olmaksızın, binlik bölümler arasına virgül (",") konarak çıktılanır.

İki değiştirge belirtilmişse sayı, ondalık kısmı ondalık_hane sayıda hane içerecek şekilde ondalık ayraç olarak nokta ("."), binlik ayraç olarak virgül (",") kullanılarak çıktılanır.

Dört değiştirgenin tamamı kulanılmışsa sayı, ondalık kısmı ondalık_hane sayıda hane içerecek şekilde ondalık ayraç olarak ondalık_ayracı, binlik ayraç olarak binlik_ayracı kullanılarak çıktılanır.

Değiştirgeler

sayı

Biçemlenecek sayı.

ondalık_hane

Ondalık hanelerin sayısı.

ondalık_ayracı

Ondalık ayracı.

binlik_ayracı

Binlik ayracı.

binlik_ayracı dizgesinin sadece ilk karakteri kullanılır. Örneğin, değer olarak bar belirtilmişse 1000 sayısı 1b000 olarak biçemlenir.

Dönen Değerler

sayı'nın biçemlenmiş sürümü.

Örnekler

Örnek 1 - number_format() örneği

Türkçede sayıları gösterirken genellikle iki ondalık hane, ondalık ayracı olarak virgül (','), binlik ayracı olarak nokta ('.')kullanırız.

<?php

$sayı = 1234.56;

// İngilizcedeki gösterim (öntanımlı)
$english_format_number = number_format($sayı);
// 1,235

// Bizimki
$bizimki = number_format($sayı, 2, ',', '.');
// 1.234,56

$number = 1234.5678;

// İngilizcede binlik ayraçsız gösterim
$english_format_number = number_format($number, 2, '.', '');
// 1234.57

?>

Ayrıca Bakınız

  • money_format() - Bir sayıyı para olarak biçemler
  • sprintf() - Biçemli bir dizge döndürür
  • printf() - Biçemli bir dizge çıktılar
  • sscanf() - Girdi dizgesini belli bir biçeme göre yorumlar

nl2br
ord
Dizge İşlevleri


Karakterin ASCII değerini döndürür

number_format
parse_str
Dizge İşlevleri
PHP Manual

ord

(PHP 4, PHP 5, PHP 7)

ord — Karakterin ASCII değerini döndürür

Açıklama

int ord ( string $dizge )

dizge dizgesinin ilk karakterinin ASCII değerini döndürür.

Bu işlev chr() işlevinin tersidir.

Değiştirgeler

dizge

Bir karakter.

Dönen Değerler

ASCII değeri bir tamsayı olarak döndürür.

Örnekler

Örnek 1 - ord() örneği

<?php
$str = "\n";
if (ord($str) == 10) {
    echo "\$str dizgesinin ilk karakteri bir satırsonudur.\n";
}
?>

Ayrıca Bakınız

  • chr() - Kodu belirtilen karakteri döndürür
  • » ASCII tablosu

number_format
parse_str
Dizge İşlevleri


Dizge içindeki değişkenleri çözümler

ord
print
Dizge İşlevleri
PHP Manual

parse_str

(PHP 4, PHP 5, PHP 7)

parse_str — Dizge içindeki değişkenleri çözümler

Açıklama

void parse_str ( string $dizge [, array &$dizi ] )

Bir URL üzerinden aktarılan bir sorgu dizgesindeki değişkenleri çözümler ve bunları geçerli etki alanında tanımlı hale getirir.

Bilginize:

Geçerli QUERY_STRING dizgesini almak için $_SERVER['QUERY_STRING'] değişkenini kullanabilirsiniz. Ayrıca, Dış Kaynaklı Değişkenler bölümünü de okumanızda fayda var.

Bilginize:

magic_quotes_gpc ayarı bu işlevin çıktısını etkiler: parse_str()işlevi $_GET, $_POST gibi değişkenler için PHP'nin kullandığı mekanizmayı kullanır.

Değiştirgeler

dizge

Girdi dizgesi.

dizi

Seçimlik olan bu değiştirge kullanılmışsa değişkenler etki alanında tanımlanmak yerine bu dizinin elemanlarına yerleştirilir.

Dönen Değerler

Hiçbir değer dönmez.

Sürüm Bilgisi

Sürüm: | Açıklama
4.0.3 | dizi değiştirgesi eklendi.

Örnekler

Örnek 1 - parse_str() kullanımı

<?php
$str = "first=value&arr[]=foo+bar&arr[]=baz";
parse_str($str);
echo $first;  // value
echo $arr[0]; // foo bar
echo $arr[1]; // baz

parse_str($str, $output);
echo $output['first'];  // value
echo $output['arr'][0]; // foo bar
echo $output['arr'][1]; // baz

?>

Ayrıca Bakınız

  • parse_url() - Bir URL'yi bileşenlerine ayırır
  • pathinfo() - Bir dosya yolu hakkında bilgi döndürür
  • http_build_query() - URL kodlamalı sorgu dizgesi üretir
  • get_magic_quotes_gpc() - magic_quotes_gpc yönergesinin değerini döndürür
  • urldecode() - URL kodlamalı dizgenin kodlamasını çözer

ord
print
Dizge İşlevleri


Bir dizge çıktılar

parse_str
printf
Dizge İşlevleri
PHP Manual

print

(PHP 4, PHP 5, PHP 7)

print — Bir dizge çıktılar

Açıklama

int print ( string $dizge )

dizge dizgesini çıktılar.

print aslında bir işlev değildir (bir dil oluşumudur), dolayısıyla değiştirgesini belirtirken yaylı ayraçları kullanmanız gerekmez.

Değiştirgeler

dizge

Girdi dizgesi.

Dönen Değerler

Daima 1 döner.

Örnekler

Örnek 1 - print örnekleri

<?php
print("Hello World");

print "print() yaylı ayraçlar olmadan da çalışır.";

print "Bu çok satırlı bir
dizge olup satırsonu karakterleri
de çıktılanır.";

print "Bu çok satırlı bir\ndizge olup satırsonu karakterleri\nde çıktılanır.";

print "Karakterlerin öncelenmesi böyle yapılır: \"Tıpkı böyle\".";

// print deyiminde değişkenleri de kullanabilirsiniz
$bu = "Bu da";

print "$bu Buda"; // Bu da Buda

// Ayrıca dizileri de kullanabilirsiniz
$bar = array("değer" => "Buda");

print "Bu da {$bar['değer']} !"; //  Bu da Buda !

// Tek tırnak içine alırsanız değişken basılır, değeri değil
print '$bu Buda'; // $bu Buda

// Başka karakter kullanmazsanız sadece değişkenin değeri basılır
print $bu;          // Bu da

print <<<END
Burada "yorumlu metin" (heredoc) sözdizimi kullanılmış
olup bu dizgenin içindeki her $değişken yorumlanır.
Yorumlu metin sonlandırıcısı son satırda yer almalı ve
ardındaki noktalı virgül dışında etrafında hiçbir karakter
(boşluklar dahil) bulunmamalıdır!
END;
?>

Notlar

Bilginize: Bu bir işlev değil, dil oluşumu olduğundan değişken işlevler kullanılarak çağrılamaz.

Ayrıca Bakınız

  • echo - Bir veya daha fazla dizgeyi çıktılar
  • printf() - Biçemli bir dizge çıktılar
  • flush() - Çıktı tamponunu boşaltır
  • Yorumlu metinler

parse_str
printf
Dizge İşlevleri


Biçemli bir dizge çıktılar

print
quoted_printable_decode
Dizge İşlevleri
PHP Manual

printf

(PHP 4, PHP 5, PHP 7)

printf — Biçemli bir dizge çıktılar

Açıklama

int printf ( string $biçem [, mixed $değiştirgeler [, mixed $... ]] )

Belirtilen biçem dizgesine göre üretilmiş bir dizge çıktılar.

Değiştirgeler

biçem

Bu değiştirgenin açıklaması için sprintf() işlevine bakınız.

değiştirgeler

...

Dönen Değerler

Çıktılanın dizgenin uzunluğunu döndürür.

Ayrıca Bakınız

  • print - Bir dizge çıktılar
  • sprintf() - Biçemli bir dizge döndürür
  • vprintf() - Biçemli bir dizge çıktılar
  • sscanf() - Girdi dizgesini belli bir biçeme göre yorumlar
  • fscanf() - Bir dosyadaki girdiyi belli bir biçeme göre çözümler
  • flush() - Çıktı tamponunu boşaltır

print
quoted_printable_decode
Dizge İşlevleri


ASCII olarak basılabilir (quoted-printable) bir dizgenin 8 bitlik sürümünü döndürür

printf
quoted_printable_encode
Dizge İşlevleri
PHP Manual

quoted_printable_decode

(PHP 4, PHP 5, PHP 7)

quoted_printable_decode — ASCII olarak basılabilir (quoted-printable) bir dizgenin 8 bitlik sürümünü döndürür

Açıklama

string quoted_printable_decode ( string $dizge )

Bu işlev ASCII olarak basılabilir (quoted-printable) bir dizgenin » RFC2821'in, 4.5.2. bölümüne göre değil, » RFC2045'in, 6.7. bölümüne göre oluşturulmuş 8 bitlik sürümünü döndürür; böylece satır başlarındaki noktalar ayıklanmaz.

Çalışması için IMAP modülünü gerektirmemesi dışında imap_qprint() işlevinin benzeridir.

Değiştirgeler

dizge

Girdi dizgesi.

Dönen Değerler

8 bitlik ikil dizge döner.

Ayrıca Bakınız

  • quoted_printable_encode() - 8 bitlik bir dizgenin ASCII olarak basılabilir (quoted-printable) sürümünü döndürür

printf
quoted_printable_encode
Dizge İşlevleri


8 bitlik bir dizgenin ASCII olarak basılabilir (quoted-printable) sürümünü döndürür

quoted_printable_decode
quotemeta
Dizge İşlevleri
PHP Manual

quoted_printable_encode

(PHP 5 >= 5.3.0, PHP 7)

quoted_printable_encode — 8 bitlik bir dizgenin ASCII olarak basılabilir (quoted-printable) sürümünü döndürür

Açıklama

string quoted_printable_encode ( string $dizge )

ASCII olarak basılabilir (quoted-printable) bir dizge » RFC2045'in 6.7. bölümünde açıklandığı gibi oluşturulur.

Çalışması için IMAP modülünü gerektirmemesi dışında imap_8bit() işlevine benzer.

Değiştirgeler

dizge

Girdi dizgesi.

Dönen Değerler

Kodlanmış dizgeyi döndürür.

Ayrıca Bakınız

  • quoted_printable_decode() - ASCII olarak basılabilir (quoted-printable) bir dizgenin 8 bitlik sürümünü döndürür
  • iconv_mime_encode() - Bir MIME başlık alanı tertipler

quoted_printable_decode
quotemeta
Dizge İşlevleri


Özel anlamı olan karakterleri tersbölü ile önceler

quoted_printable_encode
rtrim
Dizge İşlevleri
PHP Manual

quotemeta

(PHP 4, PHP 5, PHP 7)

quotemeta — Özel anlamı olan karakterleri tersbölü ile önceler

Açıklama

string quotemeta ( string $dizge )

dizge dizgesinin içinde bulunan karakterlerden

. \ + * ? [ ^ ] ( $ )
karakterlerini bir tersbölü (\) ile önceleyerek elde edilen dizgeyi döndürür.

Değiştirgeler

dizge

Girdi dizgesi.

Dönen Değerler

Özel anlamı olan karakterleri tersbölü ile öncelenmiş bir dizge döner.

Notlar

Bilginize: Bu işlev ikil dosyalarla çalışırken dosya içeriğini değiştirmez.

Ayrıca Bakınız

  • addslashes() - Özel karakterlerin önüne tersbölü yerleştirir
  • addcslashes() - Dizgeye C tarzı öncelem uygular
  • htmlentities() - Dönüştürülebilecek tüm karakterleri HTML öğeleri haline getirir
  • htmlspecialchars() - Özel karakterleri HTML öğeleri haline getirir
  • nl2br() - Dizgedeki tüm satırsonlarının yerine HTML satır katlayıcıları yerleştirilir
  • stripslashes() - Bir dizgeden tersbölüleri ayıklar
  • stripcslashes() - addcslashes ile öncelenmiş dizgeyi eski haline getirir
  • preg_match() - Bir düzenli ifadeyi eşleştirmeye çalışır

quoted_printable_encode
rtrim
Dizge İşlevleri


Dizgenin sonundaki boşlukları (veya diğer karakterleri) budar

quotemeta
setlocale
Dizge İşlevleri
PHP Manual

rtrim

(PHP 4, PHP 5, PHP 7)

rtrim — Dizgenin sonundaki boşlukları (veya diğer karakterleri) budar

Açıklama

string rtrim ( string $dizge [, string $karakterler ] )

Bu işlev dizge'nin sonundaki boşlukları budar.

İkinci değiştirge olmaksızın rtrim() sadece aşağıdaki karakterleri budayacaktır:

  • " " (ASCII 32 (0x20)), sıradan boşluk.
  • "\t" (ASCII 9 (0x09)), sekme.
  • "\n" (ASCII 10 (0x0A)), satırsonu.
  • "\r" (ASCII 13 (0x0D)), satırbaşı.
  • "\0" (ASCII 0 (0x00)), NUL-bayt.
  • "\x0B" (ASCII 11 (0x0B)), dikey sekme.

Değiştirgeler

dizge

Budanacak dizge.

karakterler

Seçimlik olarak, karakterler değiştirgesi kullanılarak budanacak karakterler belirlenebilir. Basitçe budamak istediğiniz tüm karakterleri belirtin. Bir karakter aralığını .. kullanarak belirtebilirsiniz.

Dönen Değerler

Budanmış dizge.

Sürüm Bilgisi

Sürüm: | Açıklama
4.1.0 | İsteğe bağlı karakterler değiştirgesi eklendi.

Örnekler

Örnek 1 - rtrim() örneği

<?php

$metin   = "\t\tBir kaç kelam :) ...  ";
$ikil = "\x09Örnek dizge\x0A";
$selam  = "Merhaba Dünya";
var_dump($metin, $ikil, $selam);

print "\n";

$kırpık = rtrim($metin);
var_dump($kırpık);

$kırpık = rtrim($metin, " \t.");
var_dump($kırpık);

$kırpık = rtrim($selam, "aerMy");
var_dump($kırpık);

// $ikil'in başındaki ve sonundaki ASCII denetim karakterlerini budar
// (0'dan 31'e kadar, 0 ve 31 dahil)
$temiz = rtrim($ikil, "\x00..\x1F");
var_dump($temiz);

?>

Yukarıdaki örneğin çıktısı:

string(25) "            Bir kaç kelam :) ...  "
string(14) "    Örnek dizge
"
string(14) "Merhaba Dünya"

string(23) "            Bir kaç kelam :) ..."
string(19) "            Bir kaç kelam :)"
string(12) "Merhaba Dün"
string(13) "    Örnek dizge"

Ayrıca Bakınız

  • trim() - Dizgenin başındaki ve sonundaki boşlukları (veya diğer karakterleri) budar
  • ltrim() - Dizgenin başındaki boşlukları (veya diğer karakterleri) budar

quotemeta
setlocale
Dizge İşlevleri


Yereli ayarlar

rtrim
sha1_file
Dizge İşlevleri
PHP Manual

setlocale

(PHP 4, PHP 5, PHP 7)

setlocale — Yereli ayarlar

Açıklama

string setlocale ( int $sınıf , string $yerel [, string $... ] )
string setlocale ( int $sınıf , array $yerel )

Yerel bilgisini ayarlar.

Değiştirgeler

sınıf

sınıf olarak yerel ayarıyla ilgili belli bir işlevsellik belirten şu sabitlerden biri belirtilebilir:

  • LC_ALL - aşağıdakilerin hepsi.
  • LC_COLLATE - dizge karşılaştırması için; strcoll() işlevine bakınız.
  • LC_CTYPE - karakter sınıflaması ve dönüşümü için; bir örnek olarak strtoupper() işlevine bakınız.
  • LC_MONETARY - Para biçemlemesi için; bkz, localeconv().
  • LC_NUMERIC - ondalık ayraçlar için; bkz, localeconv().
  • LC_TIME - tarih ve saat biçemlemesi için; bkz, strftime()
  • LC_MESSAGES - sistem iletileri için (PHP libintl ile derlendiği takdirde kullanılabilir).

yerel

Eğer NULL belirtilirse veya "" şeklinde boş bir dizge belirtilmişse, yerel isimleri yukarıdaki sınıflarla aynı isimdeki ortam değişkenlerinden veya "LANG" ortam değişkeninden alınır.

Eğer yerel "0" ise, yerel ayarı değiştirilmeden mevcut ayar döndürülür.

Eğer yerel bir dizi ise veya ek değiştirgeler belirtilmişse, yeni yerel başarıyla ayarlanana kadar belirtilen her dizi elemanı veya her değiştirge tek tek denenir. Yerel isimlerinin farklı sistemlerde farklı isimlerde bulunması durumunda veya kullanılabilir yerelin bulunamaması olasılığına karşı son çareleri belirtmek için kullanılır.

...

Yerel ayarları başarılı olana kadar denenecek seçimlik dizi veya dizge.

Bilginize:

Windows'ta, setlocale(LC_ALL, '') kullanımında, sistemin bölgesel ayarlar/dil ayarlarında (Denetim Masasından erişilebilir) belirtilmiş yerelin ismi kullanılır.

Dönen Değerler

Ayarlama yapılabilmişse yeni yerel ismi, platformunuzda yereller işlevsel değilse, belirtilen yerel yoksa veya sınıf ismi geçersizse FALSE döner.

Geçersiz bir sınıf ismi ayrıca bir uyarı üretilmesine sebep olur. Sınıf ve yerel isimleri » RFC 1766 ve » ISO 639'da bulunabilir. Farklı sistemler yereller için farklı isimleme şemaları kullanırlar.

Bilginize:

setlocale() işlevinin dönüş değeri PHP'nin üzerinde çalıştığı sisteme bağlıdır. Sistemin setlocale işlevinin döndürdüğü değeri döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | sınıf değiştirgesinde LC_* sabitlerinden biri yerine bir dizge aktarılırsa işlev artık bir E_DEPRECATED uyarısı çıktılamaktadır.
4.3.0 | Çok sayıda yerel belirtilebilir oldu.
4.2.0 | sınıf olarak bir dizge aktarılması artık önerilmiyor. Dizge değil yukarıdaki sabitlerin kullanılması gerekiyor. Bu sabitlerin bir dizge olarak (tırnak içinde) belirtilmesi artık bir uyarıya sebep olmaktadır.

Örnekler

Örnek 1 - setlocale() örnekleri

<?php
/* Yereli Türkçe yapalım */
setlocale(LC_ALL, 'tr_TR.UTF-8');

/* Çıktısı: 22 Aralık 1978 Cuma */
echo strftime("%e %B %Y %A\n", mktime(0, 0, 0, 12, 22, 1978));

/* Türkçe için farklı yerel isimleri deneyelim (PHP 4.3.0 ve sonrası) */
$loc_tr = setlocale(LC_ALL, 'tr_TR.UTF-8', 'tr_TR', 'tr', 'turkish');
echo "Türkçe için tercih edilen yerel ismi: '$loc_tr\n'";
?>

Örnek 2 - Windows için setlocale() örnekleri

<?php
/* Yereli Felemenkçe yapalım */
setlocale(LC_ALL, 'nld_nld');

/* Çıktısı: vrijdag 22 december 1978 */
echo strftime("%A %d %B %Y", mktime(0, 0, 0, 12, 22, 1978));

/* Almanca için farklı yerel isimleri deneyelim (PHP 4.3.0 ve sonrası) */
$loc_de = setlocale(LC_ALL, 'de_DE@euro', 'de_DE', 'deu_deu');
echo "Almanca için tercih edilen yerel ismi: '$loc_de'";
?>

Notlar

Uyarı

Evre başına değil süreç başına yerel bilgisi ayarlanır. Windows üzerinde Apache veya IIS gibi çok evreli bir sunucu çalıştırıyorsanız, betiğinizde setlocale() işlevini hiç çağırmadığınız halde yerel ayarlarında ani değişiklikler olduğunu gözlemlemişsinizdir. Bunun sebebi aynı anda aynı süreç altında başka evrelerde başka betiklerin çalışması ve bunların süreç genelinde geçerli olan setlocale() kullanımlarıdır.

İpucu

Windows kullanıcıları Microsoft'un MSDN sitesinde yerel dizgeleri hakkında bilgi bulabilirler. Desteklenen dil dizgeleri » http://msdn.microsoft.com/en-us/library/39cwe7zf%28v=vs.90%29.aspx adresinde desteklenen ülke/bölge dizgeleri ise » http://msdn.microsoft.com/en-us/library/cdax410z%28v=vs.90%29.aspx adresinde bulunabilir.

rtrim
sha1_file
Dizge İşlevleri


Bir dosyanın sha1 özetini hesaplar

setlocale
sha1
Dizge İşlevleri
PHP Manual

sha1_file

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

sha1_file — Bir dosyanın sha1 özetini hesaplar

Açıklama

string sha1_file ( string $dosya [, bool $ham_çıktı = false ] )

dosya dosyasını sha1 özetini hesaplar. Hesaplamada kullanılan algoritma: » US Secure Hash Algorithm 1. Özet 40 haneli bir onaltılık sayıdır.

Değiştirgeler

dosya

Dosya ismi.

ham_çıktı

TRUE belirtildiği takdirde sha1 özeti 20 bayt uzunluğundaki ham ikil biçemli bir dizge olarak döner. FALSE öntanımlıdır.

Dönen Değerler

İşlem başarılı olursa bir dizge, olmazsa FALSE döner.

Örnekler

Örnek 1 - sha1_file() örneği

<?php
foreach(glob('/home/Kalle/myproject/*.php') as $ent)
{
  if(is_dir($ent))
  {
    continue;
  }

  echo $ent . ' (SHA1: ' . sha1_file($ent) . ')', PHP_EOL;
}
?>

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.0 | ham_çıktı değiştirgesi eklendi.
5.1.0 | İşlev akım arayüzü kullanacak şekilde değiştirildi. Yani dosya belirtirken artık sha1_file('http://example.com/..') gibi bir sarmalayıcı kullanabilirsiniz.

Ayrıca Bakınız

  • sha1() - Bir dizgenin sha1 özetini hesaplar
  • md5_file() - Belirtilen dosyanın md5 özetini hesaplar
  • crc32() - Bir dizgenin crc32 çok terimlisini hesaplar

setlocale
sha1
Dizge İşlevleri


Bir dizgenin sha1 özetini hesaplar

sha1_file
similar_text
Dizge İşlevleri
PHP Manual

sha1

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

sha1 — Bir dizgenin sha1 özetini hesaplar

Açıklama

string sha1 ( string $dizge [, bool $ham_çıktı = false ] )

dizge dizgesinin sha1 özetini hesaplar. Hesaplamada kullanılan algoritma: » US Secure Hash Algorithm 1.

Değiştirgeler

dizge

Girdi dizgesi.

ham_çıktı

Seçimlik olan bu değiştirgeyle işleve TRUE aktarırsanız, sha1 özeti, 20 bayt uzunluğunda ham ikil biçemli bir dizge olarak, aksi takdirde 40 haneli onaltılık bir sayı dizgesi olarak döner. FALSE öntanımlıdır.

Dönen Değerler

SHA1 özetini bir dizge olarak döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.0 | ham_çıktı değiştirgesi eklendi.

Örnekler

Örnek 1 - sha1() örneği

<?php
$str = 'apple';

if (sha1($str) === 'd0be2dc421be4fcd0172e5afceea3970e2f3d940') {
    echo "Yeşil elma mı yoksa kırmızı elma mı isterseniz?";
    exit;
}
?>

Ayrıca Bakınız

  • sha1_file() - Bir dosyanın sha1 özetini hesaplar
  • crc32() - Bir dizgenin crc32 çok terimlisini hesaplar
  • md5() - Bir dizgenin md5 özetini hesaplar
  • hash() - Bir ileti özeti üretir

sha1_file
similar_text
Dizge İşlevleri


İki dizge arasındaki benzerliği hesaplar

sha1
soundex
Dizge İşlevleri
PHP Manual

similar_text

(PHP 4, PHP 5, PHP 7)

similar_text — İki dizge arasındaki benzerliği hesaplar

Açıklama

int similar_text ( string $d1 , string $d2 [, float &$oran ] )

Oliver'in [1993] açıkladığı şekilde iki dizge arasındaki benzerliği hesaplar. Ancak bu gerçeklenim Oliver'in kod örneğindeki gibi bir yığıt kullanmaz. Ayrıca bu algoritmanın hesaplama karmaşıklığı, N en uzun dizgenin uzunluğu olmak üzere O(N^3)'tür.

Değiştirgeler

d1

İlk dizge.

d2

İkinci dizge.

oran

Benzerlik oranını belirtmek için kullanılır.

Dönen Değerler

Her iki dizgede eşleşen karakterlerin sayısı döner.

Ayrıca Bakınız

  • levenshtein() - İki dizge arasındaki Levenştayn mesafesini hesaplar
  • soundex() - Bir dizgenin sestek anahtarını hesaplar

sha1
soundex
Dizge İşlevleri


Bir dizgenin sestek anahtarını hesaplar

similar_text
sprintf
Dizge İşlevleri
PHP Manual

soundex

(PHP 4, PHP 5, PHP 7)

soundex — Bir dizgenin sestek anahtarını hesaplar

Açıklama

string soundex ( string $dizge )

dizge dizgesinin sestek (soundex) anahtarını hesaplar.

Sestek anahtarlarının özelliği aynı sesletime sahip sözcüklerin benzer sestek anahtarları üretmesi özelliğine dayanır. Böylece sesletimini bildiğiniz ama nasıl yazıldığını bilmediğiniz sözcükleri veritabanlarında arayabilirsiniz. Bu soundex işlevi ilk karakteri bir harf olmak üzere 4 karakter uzunluğunda bir dizge döndürür.

Bu kısmen Donald Knuth'un "The Art Of Computer Programming, vol. 3: Sorting And Searching", Addison-Wesley (1973), pp. 391-392'de açıkladığı bir soundex işlevine dayanır.

Değiştirgeler

dizge

Girdi dizgesi.

Dönen Değerler

Sestek anahtarını bir dizge olarak döndürür.

Örnekler

Örnek 1 - soundex() örnekleri

<?php
soundex("Euler")       == soundex("Ellery");    // E460
soundex("Gauss")       == soundex("Ghosh");     // G200
soundex("Hilbert")     == soundex("Heilbronn"); // H416
soundex("Knuth")       == soundex("Kant");      // K530
soundex("Lloyd")       == soundex("Ladd");      // L300
soundex("Lukasiewicz") == soundex("Lissajous"); // L222
?>

Ayrıca Bakınız

  • levenshtein() - İki dizge arasındaki Levenştayn mesafesini hesaplar
  • metaphone() - Bir dizgenin metafon anahtarını hesaplar
  • similar_text() - İki dizge arasındaki benzerliği hesaplar

similar_text
sprintf
Dizge İşlevleri


Biçemli bir dizge döndürür

soundex
sscanf
Dizge İşlevleri
PHP Manual

sprintf

(PHP 4, PHP 5, PHP 7)

sprintf — Biçemli bir dizge döndürür

Açıklama

string sprintf ( string $biçem [, mixed $değiştirgeler [, mixed $... ]] )

biçem dizgesiyle biçemlenerek üretilmiş bir dizge döndürür.

Değiştirgeler

biçem

Biçem dizgesi sıfır veya daha fazla sayıda yönergeden oluşur: Sıradan karakterler (% hariç) doğrudan çıktıya kopyalanır. Dönüşüm belirtimleri ise her biri kendi değiştirgesini alarak bir sonuç üretir. printf() işlevi bu bakımdan sprintf() işlevi gibidir.

Her dönüşüm belirtimi, önüne yüzde imi (%) getirilmiş bir veya daha fazla sayıda, sırayla şu elemanlardan oluşur:

  1. Bir sayı üzerinde kullanılmak üzere + veya - işareti konulmasını sağlayan isteğe bağlı bir işaret belirteci. Öntanımlı olarak, sayı negatifse sadece - imini koymak için kullanılır. Bu belirteç PHP 4.3.0'dan itibaren pozitif sayılar için + iminin konulmasını da sağlamaktadır.
  2. Doğru dizge uzunluğunu elde etmek amacıyla dolgu olarak kullanılacak karakterin belirtilmesi için isteğe bağlı bir dolgu belirteci. Bu bir boşluk karakteri olabileceği gibi 0 karakteri de olabilir. Öntanımlı olarak boşlukla dolgu yapılır. Bir dolgu karakteri daha belirtmek gerekirse tek tırnak ile öncelenerek belirtilebilir. Örnekler için aşağıya bakınız.
  3. Sonucun sola mı yoksa sağa mı yanaştırılacağını belirtmek için isteğe bağlı bir hizalama belirteci. Öntanımlı olarak sağa hizalama yapılır; bir - karakteri sola hizalama yapılmasını sağlar.
  4. Dönüşümün en az kaç karakterle sonuçlanacağını belirten isteğe bağlı bir sayı olarak bir genişlik belirteci.
  5. Gerçek sayılarda ondalık hane sayısını belirtmek üzere bir noktanın (`.') ardına konan isteğe bağlı bir rakamdan oluşan bir dizge olarak isteğe bağlı bir hassasiyet belirteci. Bu belirteç bir dizge üzerinde kullanılırsa dizgenin içerebileceği azami karakter sayısını belirtir.

  6. Değiştirge verisinin hangi türde ele alınacağını belirtmek için bir tür belirteci. Olası türler:

    • % - Yüzde iminin kendisi. Bir değiştirge gerektirmez.
    • b - Değiştirgenin bir tamsayı olarak ele alınmasını ve bir ikil sayı olarak gösterilmesini sağlar.
    • c - Değiştirgenin bir tamsayı olarak ele alınmasını ve bu ASCII değere sahip karakterin gösterilmesini sağlar.
    • d - Değiştirgenin bir tamsayı olarak ele alınmasını ve bir (işaretli) onluk sayı olarak gösterilmesini sağlar.
    • e - Değiştirge bilimsel gösterimle ele alınır (1.2e+2 gibi). Hassasiyet belirteci PHP 5.2.1'den beri ondalık noktadan sonraki hane sayısını belirlemekte kullanılmaktadır. Önceki sürümlerde (bir eksiğiyle) kıymetli hanelerin sayısı olarak ele alınırdı.
    • u - Değiştirgenin bir tamsayı olarak ele alınmasını ve bir işaretsiz onluk sayı olarak gösterilmesini sağlar.
    • f - Değiştirgenin bir kayan noktalı sayı olarak ele alınmasını ve bir gerçek sayı olarak (yerele bağlı) gösterilmesini sağlar.
    • F - Değiştirgenin bir kayan noktalı sayı olarak ele alınmasını ve bir gerçek sayı olarak (yerele bağlı olmaksızın) gösterilmesini sağlar. PHP 4.3.10 ve PHP 5.0.3'ten beri kullanılabilmektedir.
    • o - Değiştirgenin bir tamsayı olarak ele alınmasını ve bir sekizlik sayı olarak gösterilmesini sağlar.
    • s - Değiştirge dizge olarak ele alınıp dizge olarak gösterilir.
    • x - Değiştirgenin bir tamsayı olarak ele alınmasını ve (küçük harfli) bir onaltılık sayı olarak gösterilmesini sağlar.
    • X - Değiştirgenin bir tamsayı olarak ele alınmasını ve (büyük harfli) bir onaltılık sayı olarak gösterilmesini sağlar.

Biçem dizgesi değiştirge numaralama ve yer değiştirme işlemlerini de destekler. Örnek:

Örnek 1 - Değiştirge takaslama

<?php
$format = 'There are %d monkeys in the %s';
printf($format, $num, $location);
?>
Çıktısı, "There are 5 monkeys in the tree" olmalıdır. Fakat biçem dizgesini uluslararasılaştırma amacıyla ayrı bir dosyada tuttuğumuzu varsayarak örneği şöyle oluşturursak asıl sorun ortaya çıkar:

Örnek 2 - Değiştirge takaslama

<?php
$format = 'The %s contains %d monkeys';
printf($format, $num, $location);
?>
İşte şimdi sorun var. Değiştirgelerin sırası biçem dizgesindeki sırayla eşleşmiyor. Kodu olduğu gibi bırakıp biçem dizgesindeki belirtimlerin sırasını değiştirebiliriz. Bu durumda biçem dizgesi şöyle olur:

Örnek 3 - Değiştirge takaslama

<?php
$format = 'The %2$s contains %1$d monkeys';
printf($format, $num, $location);
?>
Değiştirge sayısını arttırmadan biçem dizgesindeki belirtimlerin sayısını arttırabiliriz:

Örnek 4 - Değiştirge takaslama

<?php
$format = 'The %2$s contains %1$d monkeys.
           That\'s a nice %2$s full of %1$d monkeys.';
printf($format, $num, $location);
?>

args

...

Dönen Değerler

biçem dizgesine göre biçemlendirilerek üretilen bir dizge döner.

Sürüm Bilgisi

Sürüm: | Açıklama
4.0.6 | Değiştirge numaralama/takaslama desteği eklendi.

Örnekler

Örnek 5 - Çeşitli printf()örnekleri

<?php
$n =  43951789;
$u = -43951789;
$c = 65; // ASCII 65 is 'A'

// Dikkat: %%, sadece bir tane '%' basar
printf("%%b = '%b'\n", $n); // ikil gösterim
printf("%%c = '%c'\n", $c); // ascii karakteri basar; chr() ile aynı
printf("%%d = '%d'\n", $n); // standart tamsayı gösterimi
printf("%%e = '%e'\n", $n); // bilimsel gösterim
printf("%%u = '%u'\n", $n); // pozitif tamsayının işaretsiz tamsayı gösterimi
printf("%%u = '%u'\n", $u); // negatif tamsayının işaretsiz tamsayı gösterimi
printf("%%f = '%f'\n", $n); // gerçek sayı gösterimi
printf("%%o = '%o'\n", $n); // sekizlik gösterim
printf("%%s = '%s'\n", $n); // dizge gösterimi
printf("%%x = '%x'\n", $n); // küçük harfli onaltılık sayı gösterimi
printf("%%X = '%X'\n", $n); // büyük harfli onaltılık sayı gösterimi

printf("%%+d = '%+d'\n", $n); // pozitif tamsayı üzerinde işaret belirteci
printf("%%+d = '%+d'\n", $u); // negatif tamsayı üzerinde işaret belirteci
?>

Yukarıdaki örneğin çıktısı:

%b = '10100111101010011010101101'
%c = 'A'
%d = '43951789'
%e = '4.39518e+7'
%u = '43951789'
%u = '4251015507'
%f = '43951789.000000'
%o = '247523255'
%s = '43951789'
%x = '29ea6ad'
%X = '29EA6AD'
%+d = '+43951789'
%+d = '-43951789'

Örnek 6 - printf() dizge belirtimleri

<?php
$s = 'monkey';
$t = 'many monkeys';

printf("[%s]\n",      $s); // standart dizge
printf("[%10s]\n",    $s); // boşluklarla sağa hizalanır
printf("[%-10s]\n",   $s); // boşluklarla sola hizalanır
printf("[%010s]\n",   $s); // 0'larla doldurma dizgelerde de çalışır
printf("[%'#10s]\n",  $s); // '#' özel dolgu karakteri olarak kullanılır
printf("[%10.10s]\n", $t); // 10 karakterlik sınırlamayla sola hizalama
?>

Yukarıdaki örneğin çıktısı:

[monkey]
[    monkey]
[monkey    ]
[0000monkey]
[####monkey]
[many monke]

Örnek 7 - sprintf() ve sıfır dolgulu tamsayılar

<?php
$isodate = sprintf("%04d-%02d-%02d", $year, $month, $day);
?>

Örnek 8 - sprintf() ve para biçemleme

<?php
$money1 = 68.75;
$money2 = 54.35;
$money = $money1 + $money2;
// echo $money çıktısı: "123.1"
$formatted = sprintf("%01.2f", $money);
// echo $formatted çıktısı: "123.10"
?>

Örnek 9 - sprintf() ve bilimsel gösterim

<?php
$number = 362525200;

echo sprintf("%.3e", $number); // 3.625e+8 çıktılar
?>

Ayrıca Bakınız

  • printf() - Biçemli bir dizge çıktılar
  • sscanf() - Girdi dizgesini belli bir biçeme göre yorumlar
  • fscanf() - Bir dosyadaki girdiyi belli bir biçeme göre çözümler
  • vsprintf() - Biçemli bir dizge döndürür
  • number_format() - Sayıyı binlik bölümlere ayırır

soundex
sscanf
Dizge İşlevleri


Girdi dizgesini belli bir biçeme göre yorumlar

sprintf
str_getcsv
Dizge İşlevleri
PHP Manual

sscanf

(PHP 4 >= 4.0.1, PHP 5, PHP 7)

sscanf — Girdi dizgesini belli bir biçeme göre yorumlar

Açıklama

mixed sscanf ( string $dizge , string $biçem [, mixed &$... ] )

sscanf() işlevi, printf() işlevinin tersine çıktıyı biçemlemek yerine girdiyi bir biçeme göre çözümler. sscanf() belirtilen dizge dizgesini okur ve ayrıntıları sprintf() belgesinde açıklanan bir biçem dizgesine göre bu dizgeyi yorumlar.

Biçem dizgesindeki herhangi bir boşluk karakteri girdi dizgesindeki herhangi bir boşluk karakteriyle eşleşir. Yani, biçem dizgesindeki bir sekme karakteri (\t) girdi dizgesindeki tek bir boşluk karakteri ile eşleşebilir.

Değiştirgeler

dizge

Yorumlanacak dizge.

biçem

Girdi dizgesinin yorumlanmasında kullanılacak dizge. Bu dizge ile ilgili ayrıntılar için sprintf() işlevinin belgesine bakınız.

...

Çözümlenen değerleri içermek üzere aktarımı isteğe bağlı gönderimli değişkenler.

Dönen Değerler

İşleve sadece iki değiştirge aktarılmışsa, çözümlenen değerler bir dizi içinde döndürülür. İsteğe bağlı değiştirgeler belirtilmişse işlev bu değiştirgelere atanan değer sayısını döndürür. İsteğe bağlı değiştirgelerin gönderimli olarak aktarılmaları gerekir.

Örnekler

Örnek 1 - sscanf() örneği

<?php
// Seri numarasını döndürelim
list($serial) = sscanf("SN/2350001", "SN/%d");
// üretim tarihini de döndürelim
$mandate = "January 01 2000";
list($month, $day, $year) = sscanf($mandate, "%s %d %d");
echo "$serial numaralı mal şu tarihte üretildi: $year-" .
      substr($month, 0, 3) . "-$day\n";
?>

İşleve isteğe bağlı değiştirgeler belirtilmişse işlev bu değiştirgelere atanan değer sayısını döndürür.

Örnek 2 - Seçimlik değiştirgelerle sscanf() kullanımı

<?php
// Yazar bilgisiyle bir DocBook girdisi üretelim
$auth = "24\tLewis Carroll";
$n = sscanf($auth, "%d\t%s %s", $id, $first, $last);
echo "<author id='$id'>
    <firstname>$first</firstname>
    <surname>$last</surname>
</author>\n";
?>

Ayrıca Bakınız

  • fscanf() - Bir dosyadaki girdiyi belli bir biçeme göre çözümler
  • printf() - Biçemli bir dizge çıktılar
  • sprintf() - Biçemli bir dizge döndürür

sprintf
str_getcsv
Dizge İşlevleri


Bir CSV dizgesinin girdilerini bir dizinin elemanlarına paylaştırır

sscanf
str_ireplace
Dizge İşlevleri
PHP Manual

str_getcsv

(PHP 5 >= 5.3.0, PHP 7)

str_getcsv — Bir CSV dizgesinin girdilerini bir dizinin elemanlarına paylaştırır

Açıklama

array str_getcsv ( string $girdi [, string $ayraç [, string $sarmalayıcı [, string $öncelem ]]] )

Girdi olarak bir dosya alan fgetcsv() işlevinden farklı olarak bu işlev girdi olarak bir dizge alır.

Değiştirgeler

girdi

Ayrıştırılacak dizge.

ayraç

Alanlar arasında kullanılan ayraç (tek bir karakter). Virgül öntanımlıdır.

sarmalayıcı

Alanı sarmalayan karakterler (tek bir karakter). Çift tırnak öntanımlıdır.

öncelem

Önceleme karakteri (tek bir karakter). Tersbölü (\) öntanımlıdır.

Dönen Değerler

Okunan alanları içeren bir dizi döner.

Ayrıca Bakınız

  • fgetcsv() - Dosya tanıtıcısından CSV alanlarını çözümleyerek bir satır döndürür

sscanf
str_ireplace
Dizge İşlevleri


Bir alt dizgenin bütün örneklerini yenisiyle değiştirirken harf büyüklüklerini dikkate almaz

str_getcsv
str_pad
Dizge İşlevleri
PHP Manual

str_ireplace

(PHP 5, PHP 7)

str_ireplace — Bir alt dizgenin bütün örneklerini yenisiyle değiştirirken harf büyüklüklerini dikkate almaz

Açıklama

mixed str_ireplace ( mixed $eski , mixed $yeni , mixed $konu [, int &$sayı ] )

Harf büyüklüğüne duyarsız olarak konu dizgesi içindeki eski dizgelerinin her birini yeni dizgesiyle değiştirerek elde edilen dizi veya dizgeyi döndürür. Kaprisli yer değiştirme kurallarına ihtiyacınız olmayacaksa (düzenli ifadeler gibi) preg_replace() işlevini i değiştiricisi ile kullanmak yerine daima bu işlevi kullanın.

Değiştirgeler

eski

Bilginize:

eski dizisindeki her yer değiştirme önceki yer değiştirme sonucunun üzerine uygulanır.

yeni

konu

Eğer konu bir dizi ise, arama ve değiştirme her eleman için ayrı ayrı yapılır ve dönen değer de bir dizi olur.

sayı

Eğer belirtilirse, yer değiştirilen dizgelerin sayısı bu değiştirgede döndürülür.

Eğer eski ve yeni birer dizi ise str_replace() her diziden birer değer alıp bunları kullanarak konu dizgesinde arama ve yer değiştirme yapar. Eğer yeni dizisi eski dizisinden daha az değere sahipse eksik kalan yeni dizgelerin yerine boş dizgeler konur. Eğer eski bir dizi ve yeni bir dizge ise her eski dizgesinin yerine bu yeni dizgesi konur. Zıddı anlamlı değildir.

Dönen Değerler

Yer değiştirmeler yapılmış dizge veya diziyi döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.0 | sayı değiştirgesi eklendi.

Örnekler

Örnek 1 - str_ireplace() örneği

<?php
$bodytag = str_ireplace("%body%", "black", "<body text=%BODY%>");
?>

Notlar

Bilginize: Bu işlev ikil dosyalarla çalışırken dosya içeriğini değiştirmez.

Ayrıca Bakınız

  • str_replace() - Bir alt dizgenin bütün örneklerini yenisiyle değiştirir
  • preg_replace() - Düzenli ifadeye göre dizgede değişiklik yapar
  • strtr() - Belli karakterleri dönüştürür

str_getcsv
str_pad
Dizge İşlevleri


Bir dizgeyi belli bir uzunlukta diğer dizgeyle doldurur

str_ireplace
str_repeat
Dizge İşlevleri
PHP Manual

str_pad

(PHP 4 >= 4.0.1, PHP 5, PHP 7)

str_pad — Bir dizgeyi belli bir uzunlukta diğer dizgeyle doldurur

Açıklama

string str_pad ( string $girdi , int $dolgulu_uzunluk [, string $dolgu_dizgesi = " " [, int $dolgu_türü = STR_PAD_RIGHT ]] )

Bu işlev girdi dizgesinin solunu, sağını veya her iki tarafını belirtilen dolgu_dizgesi ile dolgulu_uzunluk'a kadar doldurarak sonucu döndürür. Eğer seçimlik dolgu_dizgesi belirtilmezse dolgu işlemi boşluk karakterleriyle yapılır.

Değiştirgeler

girdi

Girdi dizgesi.

dolgulu_uzunluk

dolgulu_uzunluk negatifse veya girdi dizgesinin uzunluğundan küçükse herhangi bir dolgu işlemi yapılmaz.

dolgu_dizgesi

Bilginize:

Son dolgu_dizgesi dolgulu uzunluğu tam olarak dolduramazsa kırpılır.

dolgu_türü

Seçimlik dolgu_türü olarak STR_PAD_RIGHT (sağ), STR_PAD_LEFT (sol) veya STR_PAD_BOTH sabiti (her iki taraf) belirtilebilir. dolgu_türü belirtilmezse STR_PAD_RIGHT değeri öntanımlıdır.

Dönen Değerler

Dolgulu dizge döner.

Örnekler

Örnek 1 - str_pad() örneği

<?php
$input = "Ayran";
echo str_pad($input, 10);                      // "Ayran     " üretilir
echo str_pad($input, 10, "-=", STR_PAD_LEFT);  // "-=-=-Ayran" üretilir
echo str_pad($input, 10, "_", STR_PAD_BOTH);   // "__Ayran___" üretilir
echo str_pad($input, 6 , "___");               // "Ayran_" üretilir
?>

str_ireplace
str_repeat
Dizge İşlevleri


Bir dizgeyi yineler

str_pad
str_replace
Dizge İşlevleri
PHP Manual

str_repeat

(PHP 4, PHP 5, PHP 7)

str_repeat — Bir dizgeyi yineler

Açıklama

string str_repeat ( string $girdi , int $çarpan )

girdi dizgesinin çarpan kere yinelendiği dizge ile döner.

Değiştirgeler

girdi

Yinelenecek dizge.

çarpan

Dizgenin yinelenme sayısı.

çarpan 0 veya sıfırdan büyük bir değer olmalıdır. Eğer çarpan 0 ise, işlev boş dizge döndürür.

Dönen Değerler

Yinelenmiş dizge döner.

Örnekler

Örnek 1 - str_repeat() örneği

<?php
echo str_repeat("-=", 10);
?>

Yukarıdaki örneğin çıktısı:

-=-=-=-=-=-=-=-=-=-=

Ayrıca Bakınız

  • for
  • str_pad() - Bir dizgeyi belli bir uzunlukta diğer dizgeyle doldurur
  • substr_count() - Bir dizge içinde belli bir alt dizgeden kaç tane bulunduğunu bulur

str_pad
str_replace
Dizge İşlevleri


Bir alt dizgenin bütün örneklerini yenisiyle değiştirir

str_repeat
str_rot13
Dizge İşlevleri
PHP Manual

str_replace

(PHP 4, PHP 5, PHP 7)

str_replace — Bir alt dizgenin bütün örneklerini yenisiyle değiştirir

Açıklama

mixed str_replace ( mixed $eski , mixed $yeni , mixed $konu [, int &$sayı ] )

konu dizgesi içindeki eski dizgelerinin her birini yeni dizgesiyle değiştirerek elde edilen dizi veya dizgeyi döndürür.

Kaprisli yer değiştirme kurallarına ihtiyacınız olmayacaksa (düzenli ifadeler gibi) ereg_replace() veya preg_replace() yerine daima bu işlevi kullanın.

Değiştirgeler

Eğer eski ve yeni birer dizi ise str_replace() her diziden birer değer alıp bunları kullanarak konu dizgesinde arama ve yer değiştirme yapar. Eğer yeni dizisi eski dizisinden daha az değere sahipse eksik kalan yeni dizgelerin yerine boş dizgeler konur. Eğer eski bir dizi ve yeni bir dizge ise her eski dizgesinin yerine bu yeni dizgesi konur. Zıddı anlamlı değildir.

Eğer eski veya yeni bir dizi ise elemanları baştan sona doğru ele alınır.

eski

Aranacak değer; çok sayıda değer belirtmek için dizi kullanılabilir.

yeni

Yeni değer; çok sayıda değer belirtmek için dizi kullanılabilir.

konu

Bir dizge veya dizi belirtilebilir.

Eğer konu bir dizi ise, arama ve değiştirme her eleman için ayrı ayrı yapılır ve dönen değer de bir dizi olur.

sayı

Bilginize: Eğer belirtilirse, yer değiştirilen dizgelerin sayısı bu değiştirgede döndürülür.

Dönen Değerler

Yer değiştirmeler yapılmış dizge veya diziyi döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.0 | sayı değiştirgesi eklendi.
4.3.3 | İşlevin davranışı değişti. Eski sürümlerde bir hata vardı; eski ve yeni birer dizi olduğunda eski dizinin dahili göstericisi ilerletilmeksizin boş yeni indisleri atlanırdı. Bu sorun 4.3.3 sürümünde düzeltildi. Bu hatadan etkilenen betiklerde özgün davranışı taklit etmek için bu işlev çağrılmadan önce boş eski değerlerinin kaldırılması gerekir.
4.0.5 | Değiştirgelerin çoğu artık birer dizi olabiliyor.

Örnekler

Örnek 1 - Basit str_replace() örnekleri

<?php
// Sonuç: <body text='black'>
$bodytag = str_replace("%body%", "black", "<body text='%body%'>");

// Sonuç: Hll Wrld f PHP
$vowels = array("a", "e", "i", "o", "u", "A", "E", "I", "O", "U");
$onlyconsonants = str_replace($vowels, "", "Hello World of PHP");

// Sonuç: You should eat pizza, beer, and ice cream every day
$phrase  = "You should eat fruits, vegetables, and fiber every day.";
$healthy = array("fruits", "vegetables", "fiber");
$yummy   = array("pizza", "beer", "ice cream");

$newphrase = str_replace($healthy, $yummy, $phrase);

// sağlanan: 2
$str = str_replace("ll", "", "good golly miss molly!", $count);
echo $count;
?>

Örnek 2 - str_replace()str_replace() ile ilgili olası sorunlar

<?php

// Yer değiştirme sırası
$str     = "Line 1\nLine 2\rLine 3\r\nLine 4\n";
$order   = array("\r\n", "\n", "\r");
$replace = '<br />';

// \r\n'ler önce değiştirilmeli ki tekrar değiştirilmesin
$newstr = str_replace($order, $replace, $str);

// F çıktılanır, çünkü A ile B, B ile C, ... yer değiştirir.
// Yer değiştirme soldan sağa doğru yapıldığından
// son olarak E ile F yer değiştirir.
$search  = array('A', 'B', 'C', 'D', 'E');
$replace = array('B', 'C', 'D', 'E', 'F');
$subject = 'A';
echo str_replace($search, $replace, $subject);

// Çıktısı: apearpearle pear
// yukarda bahsedilen sebeple
$letters = array('a', 'p');
$fruit   = array('apple', 'pear');
$text    = 'a p';
$output  = str_replace($letters, $fruit, $text);
echo $output;
?>

Notlar

Bilginize: Bu işlev ikil dosyalarla çalışırken dosya içeriğini değiştirmez.

Dikkat

Çoklu yer değiştirmeler

str_replace() yer değiştirmeyi soldan sağa doğru yaptığından, örneklerde de göreceğiniz gibi, çok sayıda yer değiştirme yapıldığında bir önceki değer tekrar değiştirilir.

Bilginize:

Bu işlev harf büyüklüğüne duyarlıdır. Harf büyüklüğüne duyarsız işlem yapmak istiyorsanız str_ireplace() işlevini kullanınız.

Ayrıca Bakınız

  • str_ireplace() - Bir alt dizgenin bütün örneklerini yenisiyle değiştirirken harf büyüklüklerini dikkate almaz
  • substr_replace() - Bir dizgenin belli bir bölümünü değiştirir
  • preg_replace() - Düzenli ifadeye göre dizgede değişiklik yapar
  • strtr() - Belli karakterleri dönüştürür

str_repeat
str_rot13
Dizge İşlevleri


Bir dizgeye rot13 dönüşümü uygular

str_replace
str_shuffle
Dizge İşlevleri
PHP Manual

str_rot13

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

str_rot13 — Bir dizgeye rot13 dönüşümü uygular

Açıklama

string str_rot13 ( string $dizge )

dizge değiştirgesine ROT13 kodlaması uygular ve elde edilen dizgeyi döndürür.

ROT13 kodlaması, harf olmayan karakterlere dokunmadan her harfi alfabede 13 harf kaydırır. Kodlama ve geriye kodlama aynı işlevle yapılır. Evvelce kodlanmış dizge değiştirge olarak aktarılırsa kodlanmamış dizge elde edilir. (İşlev İngiliz alfabesinin 26 harflik oluşuna dayanır. Türkçe'de 29 harf bulunduğunu unutmayın.)

Değiştirgeler

dizge

Girdi dizgesi.

Dönen Değerler

Belirtilen dizgenin ROT13 sürümü döner.

Örnekler

Örnek 1 - str_rot13() örneği

<?php

echo str_rot13('PHP 4.3.0'); // CUC 4.3.0

?>

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.0 | İşlevin davranışı düzeltildi. Evvelce dizge gönderimli aktarıldığı için değişikliğe uğrardı.

str_replace
str_shuffle
Dizge İşlevleri


Bir dizgenin karakterlerini devşirir

str_rot13
str_split
Dizge İşlevleri
PHP Manual

str_shuffle

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

str_shuffle — Bir dizgenin karakterlerini devşirir

Açıklama

string str_shuffle ( string $dizge )

str_shuffle() işlevi bir dizgeyi rasgele karar. Tüm olası devşirimleri oluşturulur (her çağrıda farklı bir sonuç döner).

Değiştirgeler

dizge

Girdi dizgesi.

Dönen Değerler

Devşirilen dizge döner.

Örnekler

Örnek 1 - str_shuffle() örneği

<?php
$str = 'abcdef';
$shuffled = str_shuffle($str);

// Çıktısı şöyle bir şey olur: baefcd
echo $shuffled;
?>

Ayrıca Bakınız

  • shuffle() - Bir diziyi karar
  • rand() - Generate a random integer

str_rot13
str_split
Dizge İşlevleri


Bir dizgeyi bir diziye dönüştürür

str_shuffle
str_word_count
Dizge İşlevleri
PHP Manual

str_split

(PHP 5, PHP 7)

str_split — Bir dizgeyi bir diziye dönüştürür

Açıklama

array str_split ( string $dizge [, int $parça_uzunluğu = 1 ] )

Bir dizgeyi bir diziye dönüştürür.

Değiştirgeler

dizge

Girdi dizgesi.

parça_uzunluğu

Azami parça uzunluğu.

Dönen Değerler

Seçimlik parça_uzunluğu değiştirgesi belirtilmişse dönen dizi parça_uzunluğu karakterlik parçalar içerir, aksi takdirde tek karakterlik parçalar içerir.

parça_uzunluğu 1'den küçükse işlev FALSE döndürür. Eğer parça_uzunluğu, dizge uzunluğundan büyükse dizinin tek elemanında dizgenin tamamı bulunur.

Örnekler

Örnek 1 - str_split() örneği

<?php

$str = "Hello Friend";

$arr1 = str_split($str);
$arr2 = str_split($str, 3);

print_r($arr1);
print_r($arr2);

?>

Yukarıdaki örneğin çıktısı:

Array
(
    [0] => H
    [1] => e
    [2] => l
    [3] => l
    [4] => o
    [5] =>
    [6] => F
    [7] => r
    [8] => i
    [9] => e
    [10] => n
    [11] => d
)

Array
(
    [0] => Hel
    [1] => lo
    [2] => Fri
    [3] => end
)

Ayrıca Bakınız

  • chunk_split() - Bir dizgeyi daha küçük parçalara ayırır
  • preg_split() - Dizgeyi düzenli ifadeye göre böler
  • explode() - Bir dizgeyi bir ayraca göre bölüp bir dizi haline getirir
  • count_chars() - Bir dizgedeki karakterler hakkında bilgi döndürür
  • str_word_count() - Bir dizgedeki sözcükler hakkında bilgi verir
  • for

str_shuffle
str_word_count
Dizge İşlevleri


Bir dizgedeki sözcükler hakkında bilgi verir

str_split
strcasecmp
Dizge İşlevleri
PHP Manual

str_word_count

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

str_word_count — Bir dizgedeki sözcükler hakkında bilgi verir

Açıklama

mixed str_word_count ( string $dizge [, int $biçem = 0 [, string $karakterler ]] )

dizge içindeki sözcükleri sayar. Seçimlik olan biçem değiştirgesi belirtilMEmişse, dönüş değeri bulunan sözcüklerin sayısını ifade eden bir tamsayı olur. Belirtilmesi durumunda içeriği belirtilen biçem değiştirgesine bağlı olarak değişen bir dizi döner. biçem değiştirgesinde belirtilebilecek değerler ve sonuçları aşağıda açıklanmıştır.

Bu işlevin amacı doğrultusunda 'sözcük' yerele bağlı abecesel karakterlerden başka, sözcüğün ilk karakteri dışında "'" ve "-" karakterlerini de içerebilir.

Değiştirgeler

dizge

Sözcükleri hakkında bilgi döndürülecek dizge.

biçem

Bu işlevin ne döndüreceği belirtilir. Desteklenen değerler:

  • 0 - Bulunan sözcük sayısı döner.
  • 1 - dizge içindeki tüm sözcükleri içeren bir dizi döner.
  • 2 - Sözcüklerin dizge içindeki konumlarını anahtar, sözcükleri değer olarak içeren bir ilişkisel dizi döner.

karakterler

Bir sözcük karakteri olarak değerlendirilebilecek karakterlerin listesi.

Dönen Değerler

Belirtilen biçem'e göre bir tamsayı veya bir dizi döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.0 | karakterler değiştirgesi eklendi.

Örnekler

Örnek 1 - str_word_count() örneği

<?php

$str = "Hello fri3nd, you're
       looking          good today!";

print_r(str_word_count($str, 1));
print_r(str_word_count($str, 2));
print_r(str_word_count($str, 1, 'àáãç3'));

echo str_word_count($str);

?>

Yukarıdaki örneğin çıktısı:

Array
(
    [0] => Hello
    [1] => fri
    [2] => nd
    [3] => you're
    [4] => looking
    [5] => good
    [6] => today
)

Array
(
    [0] => Hello
    [6] => fri
    [10] => nd
    [14] => you're
    [29] => looking
    [46] => good
    [51] => today
)

Array
(
    [0] => Hello
    [1] => fri3nd
    [2] => you're
    [3] => looking
    [4] => good
    [5] => today
)

7

Ayrıca Bakınız

  • explode() - Bir dizgeyi bir ayraca göre bölüp bir dizi haline getirir
  • preg_split() - Dizgeyi düzenli ifadeye göre böler
  • split() - Belirtilen dizgeyi düzenli ifadeye göre dizi elemanlarına böler
  • count_chars() - Bir dizgedeki karakterler hakkında bilgi döndürür
  • substr_count() - Bir dizge içinde belli bir alt dizgeden kaç tane bulunduğunu bulur

str_split
strcasecmp
Dizge İşlevleri


İkil olarak güvenilir ve harf büyüklüğüne duyarsız dizge karşılaştırması yapar

str_word_count
strchr
Dizge İşlevleri
PHP Manual

strcasecmp

(PHP 4, PHP 5, PHP 7)

strcasecmp — İkil olarak güvenilir ve harf büyüklüğüne duyarsız dizge karşılaştırması yapar

Açıklama

int strcasecmp ( string $d1 , string $d2 )

İkil olarak güvenilir ve harf büyüklüğüne duyarsız dizge karşılaştırması yapar.

Değiştirgeler

d1

İlk dizge.

d2

İkinci dizge.

Dönen Değerler

d1 dizgesi d2 dizgesinden küçükse sıfırdan küçük bir değer; d1 dizgesi d2 dizgesinden büyükse sıfırdan büyük bir değer; d1 dizgesi ile d2 dizgesi aynıysa sıfır döndürür.

Örnekler

Örnek 1 - strcasecmp() örneği

<?php
$d1 = "Hello";
$d2 = "hello";
if (strcasecmp($d1, $d2) == 0) {
    echo '$d1 ve $d2 dizgeleri harf büyüklükleri dikkate alınmazsa aynıdırlar';
}
?>

Ayrıca Bakınız

  • preg_match() - Bir düzenli ifadeyi eşleştirmeye çalışır
  • strcmp() - İkil olarak güvenilir dizge karşılaştırması yapar
  • substr() - Dizgenin bir kısmını döndürür
  • stristr() - Harf büyüklüğüne duyarsız olarak ilk alt dizgeyi bulur
  • strncasecmp() - İlk n karakteri ikil ve harf büyüklüğüne duyarsız olarak karşılaştırır
  • strstr() - İlk alt dizgeyi bulur

str_word_count
strchr
Dizge İşlevleri


strstr işlevinin takma adıdır

strcasecmp
strcmp
Dizge İşlevleri
PHP Manual

strchr

(PHP 4, PHP 5, PHP 7)

strchr — strstr() işlevinin takma adıdır

Açıklama

Bu işlev strstr() işlevinin takma adıdır.

strcasecmp
strcmp
Dizge İşlevleri


İkil olarak güvenilir dizge karşılaştırması yapar

strchr
strcoll
Dizge İşlevleri
PHP Manual

strcmp

(PHP 4, PHP 5, PHP 7)

strcmp — İkil olarak güvenilir dizge karşılaştırması yapar

Açıklama

int strcmp ( string $d1 , string $d2 )

Karşılaştırma harf büyüklüğüne duyarlıdır.

Değiştirgeler

d1

İlk dizge.

d2

İkinci dizge.

Dönen Değerler

d1 dizgesi d2 dizgesinden küçükse sıfırdan küçük bir değer; d1 dizgesi d2 dizgesinden büyükse sıfırdan büyük bir değer; d1 dizgesi ile d2 dizgesi aynıysa sıfır döndürür.

Ayrıca Bakınız

  • preg_match() - Bir düzenli ifadeyi eşleştirmeye çalışır
  • strcasecmp() - İkil olarak güvenilir ve harf büyüklüğüne duyarsız dizge karşılaştırması yapar
  • substr() - Dizgenin bir kısmını döndürür
  • stristr() - Harf büyüklüğüne duyarsız olarak ilk alt dizgeyi bulur
  • strncasecmp() - İlk n karakteri ikil ve harf büyüklüğüne duyarsız olarak karşılaştırır
  • strncmp() - İlk n karakteri ikil olarak karşılaştırır
  • strstr() - İlk alt dizgeyi bulur

strchr
strcoll
Dizge İşlevleri


Yerele göre dizge karşılaştırma

strcmp
strcspn
Dizge İşlevleri
PHP Manual

strcoll

(PHP 4 >= 4.0.5, PHP 5, PHP 7)

strcoll — Yerele göre dizge karşılaştırma

Açıklama

int strcoll ( string $d1 , string $d2 )

strcmp() işlevinin tersine bu işlev ikil olarak güvenilir değildir ancak strcmp() gibi harf büyüklüğüne duyarlı karşılaştırma yapılır.

strcoll() işlevi karşılaştırma yaparken yereli kullanır. Eğer kullanıldığı yerel C veya POSIX ise bu işlev strcmp() işlevine eşdeğerdir.

Değiştirgeler

d1

İlk dizge.

d2

İkinci dizge.

Dönen Değerler

d1 dizgesi d2 dizgesinden küçükse sıfırdan küçük bir değer; d1 dizgesi d2 dizgesinden büyükse sıfırdan büyük bir değer; d1 dizgesi ile d2 dizgesi aynıysa sıfır döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
4.2.3 | Bu işlev artık win32'de çalışmıyor.

Ayrıca Bakınız

  • preg_match() - Bir düzenli ifadeyi eşleştirmeye çalışır
  • strcmp() - İkil olarak güvenilir dizge karşılaştırması yapar
  • strcasecmp() - İkil olarak güvenilir ve harf büyüklüğüne duyarsız dizge karşılaştırması yapar
  • substr() - Dizgenin bir kısmını döndürür
  • stristr() - Harf büyüklüğüne duyarsız olarak ilk alt dizgeyi bulur
  • strncasecmp() - İlk n karakteri ikil ve harf büyüklüğüne duyarsız olarak karşılaştırır
  • strncmp() - İlk n karakteri ikil olarak karşılaştırır
  • strstr() - İlk alt dizgeyi bulur
  • setlocale() - Yereli ayarlar

strcmp
strcspn
Dizge İşlevleri


Maske ile eşleşMEyen ilk parçanın uzunluğunu bulur

strcoll
strip_tags
Dizge İşlevleri
PHP Manual

strcspn

(PHP 4, PHP 5, PHP 7)

strcspn — Maske ile eşleşMEyen ilk parçanın uzunluğunu bulur

Açıklama

int strcspn ( string $dizge , string $maske [, int $başlangıç [, int $uzunluk ]] )

dizge dizgesinin maske maskesiyle eşleşMEyen en uzun ilk parçasının uzunluğunu döndürür.

Değiştirgeler

dizge

Maskenin eşleşmeyeceği dizge.

maske

Dizge ile eşleşmeyecek maske.

başlangıç

Eşleştirmenin başlatılacağı konum. Negatif değerler dizgenin sonundan itibaren sayılır.

uzunluk

Eşleşmemenin aranacağı alt dizge uzunluğu. Negatif değerler uzunluğu dizgenin sonundan başına doğru belirlerler.

Dönen Değerler

Parça uzunluğunu bir tamsayı olarak döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.0 | başlangıç ve uzunluk değiştirgeleri eklendi.

Notlar

Bilginize: Bu işlev ikil dosyalarla çalışırken dosya içeriğini değiştirmez.

Ayrıca Bakınız

  • strspn() - Dizgenin, maskenin tam karakterleri ile eşleşen ilk parçasının uzunluğunu bulur

strcoll
strip_tags
Dizge İşlevleri


Bir dizgeden HTML ve PHP etiketlerini ayıklar

strcspn
stripcslashes
Dizge İşlevleri
PHP Manual

strip_tags

(PHP 4, PHP 5, PHP 7)

strip_tags — Bir dizgeden HTML ve PHP etiketlerini ayıklar

Açıklama

string strip_tags ( string $dizge [, string $ayıklanmayacaklar ] )

Bu işlev belirtilen dizge dizgesinden tüm HTML ve PHP etiketleri ayıklanmış olarak bir dizge döndürmeye çalışır. fgetss() işlevinin kullandığı etiket ayıklama motoru kullanılır.

Değiştirgeler

dizge

Girdi dizgesi.

ayıklanmayacaklar

Seçimlik olan bu değiştirgede ayıklanmayacak etiketleri belirtebilirsiniz.

Bilginize:

HTML içi açıklamalar ile PHP etiketleri de ayıklanır ve bu durum ayıklanmayacaklar ile değiştirilemez.

Dönen Değerler

Ayıklanmış dizge döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.0 | strip_tags() ikil olarak güvenilir kılındı.
4.3.0 | HTML içi açıklamalar da ayıklanabilir oldu.
4.0.0 | ayıklanmayacaklar değiştirgesi eklendi

Örnekler

Örnek 1 - strip_tags() örneği

<?php
$metin = '<p>Deneme paragrafı.</p><!-- Açıklama --> ' .
         '<a href="#capa">Başka bir metin</a>';
echo strip_tags($metin);
echo "\n";

// <p> ve <a>'ya izin verelim
echo strip_tags($metin, '<p><a>');
?>

Yukarıdaki örneğin çıktısı:

Deneme paragrafı. Başka bir metin
<p>Deneme paragrafı.</p> <a href="#capa">Başka bir metin</a>

Notlar

Uyarı

strip_tags() işlevi HTML doğrulaması yapmadığından kısmen veya tamamen bozuk etiketler nedeniyle beklenenden daha az metin veya veri elde edilebilir.

Uyarı

Bu işlev ayıklanmayacaklar değiştirgesinde belirtilen etiketlerdeki özniteliklerde, haylaz bir kullanıcıyı baştan çıkarabilecek bilgiler içerebilen style ve onmouseover öznitelikleri dahil, bir değişiklik yapmaz.

Ayrıca Bakınız

  • htmlspecialchars() - Özel karakterleri HTML öğeleri haline getirir

strcspn
stripcslashes
Dizge İşlevleri


addcslashes ile öncelenmiş dizgeyi eski haline getirir

strip_tags
stripos
Dizge İşlevleri
PHP Manual

stripcslashes

(PHP 4, PHP 5, PHP 7)

stripcslashes — addcslashes() ile öncelenmiş dizgeyi eski haline getirir

Açıklama

string stripcslashes ( string $dizge )

Tersbölüleri ayklanmış bir dizgeyle döner. C-tarzı \n, \r ..., sekizlik ve onaltılık gösterimler tanınır.

Değiştirgeler

dizge

Öncelemleri ayıklanacak dizge.

Dönen Değerler

Öncelemsiz dizgeyle döner.

Ayrıca Bakınız

  • addcslashes() - Dizgeye C tarzı öncelem uygular

strip_tags
stripos
Dizge İşlevleri


Harf büyüklüğüne duyarsız olarak bir alt dizgenin ilkinin konumunu bulur

stripcslashes
stripslashes
Dizge İşlevleri
PHP Manual

stripos

(PHP 5, PHP 7)

stripos — Harf büyüklüğüne duyarsız olarak bir alt dizgenin ilkinin konumunu bulur

Açıklama

int stripos ( string $samanlık , mixed $iğne [, int $başlangıç = 0 ] )

samanlık dizgesi içindeki ilk iğne dizgesinin konumunu döndürür.

strpos() işlevinden farklı olarak, stripos() harf büyüklüğüne duyarsızdır.

Değiştirgeler

samanlık

Aramanın yapılacağı dizge.

iğne

iğne bir dizge değilse, önce bir tamsayıya dönüştürülür ve bu tamsayı karakterin kodu olarak ele alınır.

başlangıç

Seçimlik başlangıç değiştirgesiyle aramanın samanlık içinde kaçıncı karakterden başlayacağını belirtebilirsiniz. Dönen konum yine de samanlık dizgesinin başına göre olacaktır.

Dönen Değerler

Konumu bir tamsayı olarak döndürür. Eğer iğne bulunamazsa stripos() işlevi boolean türünde FALSE döndürür.

Uyarı

Bu işlev mantıksal FALSE değeriyle dönebileceği gibi FALSE olarak değerlendirilebilecek mantıksal olmayan bir değerle de dönebilir. Bu konuda daha fazla bilgi edinmek için Mantıksal Değerler bölümüne bakabilirsiniz. Bu işlevden dönen değeri sınamak için === işlecini kullanınız.

Örnekler

Örnek 1 - stripos() örnekleri

<?php
$findme    = 'a';
$mystring1 = 'xyz';
$mystring2 = 'ABC';

$pos1 = stripos($mystring1, $findme);
$pos2 = stripos($mystring2, $findme);

// 'a' kesinlikle 'xyz' içinde yoktur
if ($pos1 === false) {
  echo "'$mystring1' dizgesinde '$findme' dizgesi yok";
}

// 'a' 0. karakter olduğundan == işleci beklendiği gibi
// çalışmayacaktır. Bu yüzden === kullanmaya çalışın.
if ($pos2 !== false) {
  echo "'$mystring1' dizgesinin $pos2. karakterinde bir '$findme' dizgesi var";
}
?>

Notlar

Bilginize: Bu işlev ikil dosyalarla çalışırken dosya içeriğini değiştirmez.

Ayrıca Bakınız

  • strpos() - Bir alt dizgenin ilkinin konumunu bulur
  • strrpos() - Bir dizgede bir karakterin sonuncusunu bulur
  • strrchr() - Bir dizgede belli bir karakterin sonuncusuna göre dizgenin bir parçasıyla döner
  • substr() - Dizgenin bir kısmını döndürür
  • stristr() - Harf büyüklüğüne duyarsız olarak ilk alt dizgeyi bulur
  • strstr() - İlk alt dizgeyi bulur
  • strripos() - Bir dizgede harf büyüklüğüne duyarsız olarak bir alt dizgenin sonuncusunu bulur
  • str_ireplace() - Bir alt dizgenin bütün örneklerini yenisiyle değiştirirken harf büyüklüklerini dikkate almaz

stripcslashes
stripslashes
Dizge İşlevleri


Bir dizgeden tersbölüleri ayıklar

stripos
stristr
Dizge İşlevleri
PHP Manual

stripslashes

(PHP 4, PHP 5, PHP 7)

stripslashes — Bir dizgeden tersbölüleri ayıklar

Açıklama

string stripslashes ( string $str )

Tersbölüleri ayıklanmış bir dizge döndürür.

Bilginize:

eğer magic_quotes_sybase yönergesinin değeri "On" ise hiçbir tersbölü ayıklanmaz ancak tek tek tırnaklar, çift tek tırnağa çıkarılır.

magic_quotes_gpc yönergesinin değerinin "On" olduğu durumda (öntanımlı olarak böyledir) stripslashes() kullanımına bir örnek olarak, önceleme gerektiren bir yere (bir veritabanı gibi) bu verinin yerleştirilmemesi verilebilir. Örneğin, bir HTML formundan veriyi doğrudan doğruya çıktılıyorsanız.

Değiştirgeler

dizge

Girdi dizgesi.

Dönen Değerler

Tersbölüleri ayıklanmış bir dizge döndürür. Örneğin, \' dizilimleri ' haline gelir, çift tersbölüler (\\) teke (\) indirilir.

Örnekler

Örnek 1 - stripslashes() örneği

<?php
$str = "Is your name O\'reilly?";

// Çıktısı: Is your name O'reilly?
echo stripslashes($str);
?>

Bilginize:

stripslashes() ardışık işlem yapmaz. Bu işlevi çok boyutlu bur diziye uygulamak istersiniz ardışık işlem yapacak bir işlev kullanmalısınız.

Örnek 2 - Dizi üzerinde stripslashes() kullanımı

<?php
function stripslashes_deep($value)
{
    $value = is_array($value) ?
                array_map('stripslashes_deep', $value) :
                stripslashes($value);

    return $value;
}

// Örnek
$array = array("f\\'oo", "b\\'ar", array("fo\\'o", "b\\'ar"));
$array = stripslashes_deep($array);

// Çıktılayalım
print_r($array);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [0] => f'oo
    [1] => b'ar
    [2] => Array
        (
            [0] => fo'o
            [1] => b'ar
        )

)

Ayrıca Bakınız

  • addslashes() - Özel karakterlerin önüne tersbölü yerleştirir
  • get_magic_quotes_gpc() - magic_quotes_gpc yönergesinin değerini döndürür

stripos
stristr
Dizge İşlevleri


Harf büyüklüğüne duyarsız olarak ilk alt dizgeyi bulur

stripslashes
strlen
Dizge İşlevleri
PHP Manual

stristr

(PHP 4, PHP 5, PHP 7)

stristr — Harf büyüklüğüne duyarsız olarak ilk alt dizgeyi bulur

Açıklama

string stristr ( string $samanlık , mixed $iğne [, bool $iğne_öncesi = false ] )

samanlık dizgesinde bulunan ilk iğne dizgesinden başlayan parçayı döndürür.

Değiştirgeler

samanlık

Girdi dizgesi.

iğne

iğne bir dizge değilse, önce bir tamsayıya dönüştürülür ve bu tamsayı karakterin kodu olarak ele alınır.

iğne_öncesi

TRUE ise (FALSE öntanımlıdır), stristr() işlevi samanlık dizgesinde bulunan ilk iğne dizgesinde biten parçayı döndürür.

samanlık ve iğne harf büyüklüğüne duyarsız olarak ele alınır.

Dönen Değerler

iğne bulunamazsa FALSE, aksi takdirde dizge parçası ile döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | Seçimlik iğne_öncesi değiştirgesi eklendi.
4.3.0 | stristr() ikil olarak güvenilir kılındı.

Örnekler

Örnek 1 - stristr() örneği

<?php
  $email = 'USER@EXAMPLE.com';
  echo stristr($email, 'e'); // ER@EXAMPLE.com basar
  echo stristr($email, 'e', true); // PHP 5.3.0 ve sonrası, US basar
?>

Örnek 2 Bir dizgenin varlığına bakmak

<?php
  $string = 'Hello World!';
  if(stristr($string, 'earth') === FALSE) {
    echo '"earth" bu dizgede yok';
  }
// çıktısı: "earth" bu dizgede yok
?>

Örnek 3 - Dizge olmayan iğne kullanımı

<?php
  $string = 'APPLE';
  echo stristr($string, 97); // 97 = küçük a
// çıktısı: APPLE
?>

Notlar

Bilginize: Bu işlev ikil dosyalarla çalışırken dosya içeriğini değiştirmez.

Ayrıca Bakınız

  • strstr() - İlk alt dizgeyi bulur
  • strrchr() - Bir dizgede belli bir karakterin sonuncusuna göre dizgenin bir parçasıyla döner
  • substr() - Dizgenin bir kısmını döndürür
  • preg_match() - Bir düzenli ifadeyi eşleştirmeye çalışır

stripslashes
strlen
Dizge İşlevleri


Dizge uzunluğunu döndürür

stristr
strnatcasecmp
Dizge İşlevleri
PHP Manual

strlen

(PHP 4, PHP 5, PHP 7)

strlen — Dizge uzunluğunu döndürür

Açıklama

int strlen ( string $dizge )

Belirtilen dizge dizgesinin uzunluğunu döndürür.

Değiştirgeler

dizge

Uzunluğu ölçülecek dizge.

Dönen Değerler

Dizge boşsa 0 değilse dizgenin uzunluğu ile döner.

Örnekler

Örnek 1 - strlen() örneği

<?php
$str = 'abcdef';
echo strlen($str); // 6

$str = ' ab cd ';
echo strlen($str); // 7
?>

Ayrıca Bakınız

  • count() - Bir dizideki eleman sayısını veya bir nesnedeki özellik sayısını döndürür
  • mb_strlen() - Dizge uzunluğu ile döner

stristr
strnatcasecmp
Dizge İşlevleri


"Doğal sıralama" algoritmasını kullanarak dizgeleri harf büyüklüğüne duyarsız olarak karşılaştırır

strlen
strnatcmp
Dizge İşlevleri
PHP Manual

strnatcasecmp

(PHP 4, PHP 5, PHP 7)

strnatcasecmp — "Doğal sıralama" algoritmasını kullanarak dizgeleri harf büyüklüğüne duyarsız olarak karşılaştırır

Açıklama

int strnatcasecmp ( string $d1 , string $d2 )

Bu işlev, "doğal sıralama" adı verilen ve alfasayısal dizgeleri insanlarca yapılan sıralamaya uygun olarak sıralayan bir algoritmayı gerçekler. strnatcmp() işlevinden farklı olarak karşılaştırma harf büyüklüğüne duyarlı değildir. Daha fazla bilgi için Martin Pool'un » Natural Order String Comparison belgesine bakınız.

Değiştirgeler

d1

İlk dizge.

d2

İkinci dizge.

Dönen Değerler

d1 dizgesi d2 dizgesinden küçükse sıfırdan küçük bir değer; d1 dizgesi d2 dizgesinden büyükse sıfırdan büyük bir değer; d1 dizgesi ile d2 dizgesi aynıysa sıfır döndürür.

Ayrıca Bakınız

  • preg_match() - Bir düzenli ifadeyi eşleştirmeye çalışır
  • strcmp() - İkil olarak güvenilir dizge karşılaştırması yapar
  • strcasecmp() - İkil olarak güvenilir ve harf büyüklüğüne duyarsız dizge karşılaştırması yapar
  • substr() - Dizgenin bir kısmını döndürür
  • stristr() - Harf büyüklüğüne duyarsız olarak ilk alt dizgeyi bulur
  • strncasecmp() - İlk n karakteri ikil ve harf büyüklüğüne duyarsız olarak karşılaştırır
  • strncmp() - İlk n karakteri ikil olarak karşılaştırır
  • strstr() - İlk alt dizgeyi bulur
  • setlocale() - Yereli ayarlar

strlen
strnatcmp
Dizge İşlevleri


"Doğal sıralama" algoritmasını kullanarak dizgeleri karşılaştırır

strnatcasecmp
strncasecmp
Dizge İşlevleri
PHP Manual

strnatcmp

(PHP 4, PHP 5, PHP 7)

strnatcmp — "Doğal sıralama" algoritmasını kullanarak dizgeleri karşılaştırır

Açıklama

int strnatcmp ( string $d1 , string $d2 )

Bu işlev, "doğal sıralama" adı verilen ve alfasayısal dizgeleri insanlarca yapılan sıralamaya uygun olarak sıralayan bir algoritmayı gerçekler. Karşılaştırma harf büyüklüğüne duyarlı olarak yapılır.

Değiştirgeler

d1

İlk dizge.

d2

İkinci dizge.

Dönen Değerler

d1 dizgesi d2 dizgesinden küçükse sıfırdan küçük bir değer; d1 dizgesi d2 dizgesinden büyükse sıfırdan büyük bir değer; d1 dizgesi ile d2 dizgesi aynıysa sıfır döndürür.

Örnekler

Bu örnekte, bilgisiyar dizge sıralaması yapan strcmp() işlevi ile insani dizge sıralaması yapan strnatcmp() işlevinin sonuçları karşılaştırılmıştır:

<?php
$arr1 = $arr2 = array("img12.png", "img10.png", "img2.png", "img1.png");
echo "Standart dizge karşılaştırması\n";
usort($arr1, "strcmp");
print_r($arr1);
echo "\nDoğal dizge sıralama karşılaştırması\n";
usort($arr2, "strnatcmp");
print_r($arr2);
?>

Yukarıdaki örneğin çıktısı:

Standart dizge karşılaştırması
Array
(
    [0] => img1.png
    [1] => img10.png
    [2] => img12.png
    [3] => img2.png
)

Doğal dizge sıralama karşılaştırması
Array
(
    [0] => img1.png
    [1] => img2.png
    [2] => img10.png
    [3] => img12.png
)
Daha fazla bilgi için bakınız: Martin Pool'un » Natural Order String Comparison belgesi.

Ayrıca Bakınız

  • preg_match() - Bir düzenli ifadeyi eşleştirmeye çalışır
  • strcasecmp() - İkil olarak güvenilir ve harf büyüklüğüne duyarsız dizge karşılaştırması yapar
  • substr() - Dizgenin bir kısmını döndürür
  • stristr() - Harf büyüklüğüne duyarsız olarak ilk alt dizgeyi bulur
  • strcmp() - İkil olarak güvenilir dizge karşılaştırması yapar
  • strncmp() - İlk n karakteri ikil olarak karşılaştırır
  • strncasecmp() - İlk n karakteri ikil ve harf büyüklüğüne duyarsız olarak karşılaştırır
  • strnatcasecmp() - "Doğal sıralama" algoritmasını kullanarak dizgeleri harf büyüklüğüne duyarsız olarak karşılaştırır
  • strstr() - İlk alt dizgeyi bulur
  • natsort() - Bir diziyi "doğal sıralama" algoritmasıyla sıralar
  • natcasesort() - Bir diziyi harf büyüklüğüne duyarsız "doğal sıralama" algoritmasıyla sıralar

strnatcasecmp
strncasecmp
Dizge İşlevleri


İlk n karakteri ikil ve harf büyüklüğüne duyarsız olarak karşılaştırır

strnatcmp
strncmp
Dizge İşlevleri
PHP Manual

strncasecmp

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

strncasecmp — İlk n karakteri ikil ve harf büyüklüğüne duyarsız olarak karşılaştırır

Açıklama

int strncasecmp ( string $d1 , string $d2 , int $uzunluk )

Karşılaştırma için kullanılacak dizge uzunluğunun üst sınırının belirtilebilmesi dışında strcasecmp() işlevi gibidir.

Değiştirgeler

d1

İlk dizge.

d2

İkinci dizge.

uzunluk

Karşılaştırmada kullanılacak karakter sayısı.

Dönen Değerler

d1 dizgesi d2 dizgesinden küçükse sıfırdan küçük bir değer; d1 dizgesi d2 dizgesinden büyükse sıfırdan büyük bir değer; d1 dizgesi ile d2 dizgesi aynıysa sıfır döndürür.

Ayrıca Bakınız

  • preg_match() - Bir düzenli ifadeyi eşleştirmeye çalışır
  • strcmp() - İkil olarak güvenilir dizge karşılaştırması yapar
  • strcasecmp() - İkil olarak güvenilir ve harf büyüklüğüne duyarsız dizge karşılaştırması yapar
  • substr() - Dizgenin bir kısmını döndürür
  • stristr() - Harf büyüklüğüne duyarsız olarak ilk alt dizgeyi bulur
  • strstr() - İlk alt dizgeyi bulur

strnatcmp
strncmp
Dizge İşlevleri


İlk n karakteri ikil olarak karşılaştırır

strncasecmp
strpbrk
Dizge İşlevleri
PHP Manual

strncmp

(PHP 4, PHP 5, PHP 7)

strncmp — İlk n karakteri ikil olarak karşılaştırır

Açıklama

int strncmp ( string $d1 , string $d2 , int $uzunluk )

Karşılaştırma için kullanılacak dizge uzunluğunun üst sınırının belirtilebilmesi dışında strcmp() işlevi gibidir.

Karşılaştırma harf büyüklüğüne duyarlı olarak yapılır.

Değiştirgeler

d1

İlk dizge.

d2

İkinci dizge.

uzunluk

Karşılaştırmada kullanılacak karakter sayısı.

Dönen Değerler

d1 dizgesi d2 dizgesinden küçükse sıfırdan küçük bir değer; d1 dizgesi d2 dizgesinden büyükse sıfırdan büyük bir değer; d1 dizgesi ile d2 dizgesi aynıysa sıfır döndürür.

Ayrıca Bakınız

  • preg_match() - Bir düzenli ifadeyi eşleştirmeye çalışır
  • strcmp() - İkil olarak güvenilir dizge karşılaştırması yapar
  • strcasecmp() - İkil olarak güvenilir ve harf büyüklüğüne duyarsız dizge karşılaştırması yapar
  • substr() - Dizgenin bir kısmını döndürür
  • stristr() - Harf büyüklüğüne duyarsız olarak ilk alt dizgeyi bulur
  • strncasecmp() - İlk n karakteri ikil ve harf büyüklüğüne duyarsız olarak karşılaştırır
  • strstr() - İlk alt dizgeyi bulur

strncasecmp
strpbrk
Dizge İşlevleri


Belirtilen karakterleri bir dizge içinde arar

strncmp
strpos
Dizge İşlevleri
PHP Manual

strpbrk

(PHP 5, PHP 7)

strpbrk — Belirtilen karakterleri bir dizge içinde arar

Açıklama

string strpbrk ( string $dizge , string $karakterler )

strpbrk() işlevi dizge içinde karakterler'den birini bulmaya çalışır.

Değiştirgeler

dizge

Karakterlerin aranacağı dizge.

karakterler

Karakterler harf büyüklüğüne duyarlı olarak aranır.

Dönen Değerler

Bulunan karakterle başlayan dizgeyi döndürür, aranan hiçbir karakter bulunamazsa FALSE döner.

Örnekler

Örnek 1 - strpbrk() örneği

<?php

$text = 'This is a Simple text.';

// ilk eşleşen 'i'den itibaren çıktılanacağından
// "is is a Simple text." basılır
echo strpbrk($text, 'mi');

// İşlev harf büyüklüğüne duyarlı arama yaptığından
// "Simple text." basılacaktır
echo strpbrk($text, 'S');
?>

strncmp
strpos
Dizge İşlevleri


Bir alt dizgenin ilkinin konumunu bulur

strpbrk
strrchr
Dizge İşlevleri
PHP Manual

strpos

(PHP 4, PHP 5, PHP 7)

strpos — Bir alt dizgenin ilkinin konumunu bulur

Açıklama

int strpos ( string $samanlık , mixed $iğne [, int $başlangıç = 0 ] )

samanlık dizgesi içindeki ilk iğne dizgesinin konumunu döndürür. PHP 5 öncesi strrpos() işlevinden farklı olarak bu işleve iğne dizgesinde tam bir dizge aktarılabilir ve işlev bu dizgenin tamamını kullanabilir.

Değiştirgeler

samanlık

Aramanın yapılacağı dizge.

iğne

iğne bir dizge değilse, önce bir tamsayıya dönüştürülür ve bu tamsayı karakterin kodu olarak ele alınır.

başlangıç

Seçimlik başlangıç değiştirgesiyle aramanın samanlık içinde kaçıncı karakterden başlayacağını belirtebilirsiniz. Dönen konum yine de samanlık dizgesinin başına göre olacaktır.

Dönen Değerler

Konumu bir tamsayı olarak döndürür. Eğer iğne bulunamazsa strpos() işlevi boolean türünde FALSE döndürür.

Uyarı

Bu işlev mantıksal FALSE değeriyle dönebileceği gibi FALSE olarak değerlendirilebilecek mantıksal olmayan bir değerle de dönebilir. Bu konuda daha fazla bilgi edinmek için Mantıksal Değerler bölümüne bakabilirsiniz. Bu işlevden dönen değeri sınamak için === işlecini kullanınız.

Örnekler

Örnek 1 - Aynılık işlecinin (===) kullanımı

<?php
$samanlık = 'abc';
$iğne   = 'a';
$konum = strpos($samanlık, $iğne);

// 'a' 0. karakter olduğundan == işleci beklendiği gibi
// çalışmayacaktır. Bu yüzden === kullanmaya çalışın.
if ($konum === false) {
    echo "'$samanlık' dizgesi içinde '$iğne' dizgesi yok";
} else {
    echo "'$samanlık' dizgesi içinde '$iğne' dizgesi var";
    echo " ve $konum. karakterden başlıyor";
}
?>

Örnek 2 - Farklılık işlecinin (!==) kullanımı

<?php
$samanlık = 'abc';
$iğne   = 'a';
$konum = strpos($samanlık, $iğne);

// !== işleci de kullanılabilir.  'a' 0. karakter olduğundan
// != işleci beklendiği gibi çalışmayacak, (0 != false) deyimi
// yanlış sonuç verecektir.
if ($konum !== false) {
    echo "'$samanlık' dizgesi içinde '$iğne' dizgesi var";
    echo " ve $konum. karakterden başlıyor";
} else {
    echo "'$samanlık' dizgesi içinde '$iğne' dizgesi yok";
}
?>

Örnek 3 - Bir başlangıç kullanımı

<?php
// Belli bir konumdan önceki herşeyi yoksayarak bir karakteri arayabiliriz
$samanlık = 'abcdef abcdef';
$konum = strpos($samanlık, 'a', 1); // $konum = 7 olur, 0 değil
?>

Notlar

Bilginize: Bu işlev ikil dosyalarla çalışırken dosya içeriğini değiştirmez.

Ayrıca Bakınız

  • strrpos() - Bir dizgede bir karakterin sonuncusunu bulur
  • stripos() - Harf büyüklüğüne duyarsız olarak bir alt dizgenin ilkinin konumunu bulur
  • strripos() - Bir dizgede harf büyüklüğüne duyarsız olarak bir alt dizgenin sonuncusunu bulur
  • strrchr() - Bir dizgede belli bir karakterin sonuncusuna göre dizgenin bir parçasıyla döner
  • substr() - Dizgenin bir kısmını döndürür
  • stristr() - Harf büyüklüğüne duyarsız olarak ilk alt dizgeyi bulur
  • strstr() - İlk alt dizgeyi bulur

strpbrk
strrchr
Dizge İşlevleri


Bir dizgede belli bir karakterin sonuncusuna göre dizgenin bir parçasıyla döner

strpos
strrev
Dizge İşlevleri
PHP Manual

strrchr

(PHP 4, PHP 5, PHP 7)

strrchr — Bir dizgede belli bir karakterin sonuncusuna göre dizgenin bir parçasıyla döner

Açıklama

string strrchr ( string $samanlık , mixed $iğne )

samanlık dizgesinde bulunan son iğne dizgesinden başlayan parçayı döndürür.

Değiştirgeler

samanlık

Girdi dizgesi.

iğne

iğne birden fazla karakter içeriyorsa ilki kullanılır. Bu davranış strstr() işlevinin davranışından farklıdır.

iğne bir dizge değilse, önce bir tamsayıya dönüştürülür ve bu tamsayı karakterin kodu olarak ele alınır.

Dönen Değerler

iğne bulunamazsa FALSE, aksi takdirde dizge parçası ile döner.

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.0 | İşlev ikil olarak güvenilir kılındı.

Örnekler

Örnek 1 - strrchr() örneği

<?php
// $PATH içindeki son dizini döndürür
$dir = substr(strrchr($PATH, ":"), 1);

// son satırsonu karakterinden sonrakı herşey
$text = "Line 1\nLine 2\nLine 3";
$last = substr(strrchr($text, 10), 1 );
?>

Notlar

Bilginize: Bu işlev ikil dosyalarla çalışırken dosya içeriğini değiştirmez.

Ayrıca Bakınız

  • strstr() - İlk alt dizgeyi bulur
  • substr() - Dizgenin bir kısmını döndürür
  • stristr() - Harf büyüklüğüne duyarsız olarak ilk alt dizgeyi bulur

strpos
strrev
Dizge İşlevleri


Bir dizgeyi ters çevirir

strrchr
strripos
Dizge İşlevleri
PHP Manual

strrev

(PHP 4, PHP 5, PHP 7)

strrev — Bir dizgeyi ters çevirir

Açıklama

string strrev ( string $dizge )

Ters çevrilmiş dizge ile döner.

Değiştirgeler

dizge

Ters çevrilecek dizge.

Dönen Değerler

Ters çevrilen dizge döner.

Örnekler

Örnek 1 - strrev() örneği

<?php
echo strrev("Hello world!"); // çıktısı: "!dlrow olleH"
?>

strrchr
strripos
Dizge İşlevleri


Bir dizgede harf büyüklüğüne duyarsız olarak bir alt dizgenin sonuncusunu bulur

strrev
strrpos
Dizge İşlevleri
PHP Manual

strripos

(PHP 5, PHP 7)

strripos — Bir dizgede harf büyüklüğüne duyarsız olarak bir alt dizgenin sonuncusunu bulur

Açıklama

int strripos ( string $samanlık , string $iğne [, int $başlangıç = 0 ] )

samanlık dizgesi içindeki son iğne dizgesini harf büyüklüğüne duyarsız olarak bulur ve sayısal konumunu döndürür. strrpos() işlevinin tersine, strripos() harf büyükğüne duyarsızdır.

Değiştirgeler

samanlık

İğnenin aranacağı dizge.

needle

Samanlıkta aranacak dizge.

başlangıç

başlangıç ile aramanın başlatılacağı konum belirtilir.

Negatif değerler dizgenin sonundan ne kadar önce aramanın durdurulacağını belirtmek için kullanılır.

Dönen Değerler

iğne dizgesine son rastlanılan yerin konumunu döndürür. Dizgenin başlangıç konumu 1 değil 0'dır.

Eğer iğne bulunamazsa, FALSE döner.

Uyarı

Bu işlev mantıksal FALSE değeriyle dönebileceği gibi FALSE olarak değerlendirilebilecek mantıksal olmayan bir değerle de dönebilir. Bu konuda daha fazla bilgi edinmek için Mantıksal Değerler bölümüne bakabilirsiniz. Bu işlevden dönen değeri sınamak için === işlecini kullanınız.

Örnekler

Örnek 1 - strripos() örneği

<?php
$samanlık = 'ababcd';
$iğne   = 'aB';

$konum      = strripos($samanlık, $iğne);

if ($konum === false) {
    echo "($samanlık) içinde ($iğne) bulunamadı";
} else {
    echo "Tebrikler!\n";
    echo "($samanlık) içindeki son ($iğne) ($konum) konumunda bulundu";
}
?>

Yukarıdaki örneğin çıktısı:

Tebrikler!
(ababcd) içindeki son (aB) (2) konumunda bulundu

Ayrıca Bakınız

  • strpos() - Bir alt dizgenin ilkinin konumunu bulur
  • stripos() - Harf büyüklüğüne duyarsız olarak bir alt dizgenin ilkinin konumunu bulur
  • strrchr() - Bir dizgede belli bir karakterin sonuncusuna göre dizgenin bir parçasıyla döner
  • substr() - Dizgenin bir kısmını döndürür
  • stristr() - Harf büyüklüğüne duyarsız olarak ilk alt dizgeyi bulur
  • strstr() - İlk alt dizgeyi bulur

strrev
strrpos
Dizge İşlevleri


Bir dizgede bir karakterin sonuncusunu bulur

strripos
strspn
Dizge İşlevleri
PHP Manual

strrpos

(PHP 4, PHP 5, PHP 7)

strrpos — Bir dizgede bir karakterin sonuncusunu bulur

Açıklama

int strrpos ( string $samanlık , string $iğne [, int $başlangıç = 0 ] )

samanlık dizgesi içindeki son iğne dizgesinin sayısal konumunu döndürür. PHP 4 için iğne tek karakterden oluşmalıdır. iğne olarak bir dizge aktarılırsa dizgenin sadece ilk karakteri kullanılır.

Eğer iğne bulunamazsa FALSE döner.

"Karakter 0. konumda bulundu" veya "Karakter yok" şeklinde dönen değer kolayca yanlış yorumlanabilir. Şimdi farkın nasıl ayırdedileceğini görelim:

<?php

// PHP 4.0.0 ve sonrası:
$pos = strrpos($mystring, "b");
if ($pos === false) { // üç eşit imine dikkat!
    // yok...
}

// PHP 4.0.0 öncesi:
$pos = strrpos($mystring, "b");
if (is_bool($pos) && !$pos) {
    // yok...
}
?>

iğne bir dizge değilse, önce bir tamsayıya dönüştürülür ve bu tamsayı karakterin kodu olarak ele alınır.

Bilginize: PHP 5.0.0'dan itibaren başlangıç ile aramanın başlatılacağı konum belirtilebilmektedir. Negatif değerler dizgenin sonundan ne kadar önce aramanın durdurulacağını belirtmek için kullanılır.

Bilginize: iğne, PHP 5.0.0'dan itibaren bir karakterden daha uzun bir dizge olarak belirtilebilmektedir.

Değiştirgeler

samanlık

İğnenin aranacağı dizge.

iğne

Samanlıkta aranacak karakter.

başlangıç

Aramanın başlatılacağı veya durdurulacağı konum.

Dönen Değerler

Ayrıca Bakınız

  • strpos() - Bir alt dizgenin ilkinin konumunu bulur
  • strripos() - Bir dizgede harf büyüklüğüne duyarsız olarak bir alt dizgenin sonuncusunu bulur
  • strrchr() - Bir dizgede belli bir karakterin sonuncusuna göre dizgenin bir parçasıyla döner
  • substr() - Dizgenin bir kısmını döndürür
  • stristr() - Harf büyüklüğüne duyarsız olarak ilk alt dizgeyi bulur
  • strstr() - İlk alt dizgeyi bulur

strripos
strspn
Dizge İşlevleri


Dizgenin, maskenin tam karakterleri ile eşleşen ilk parçasının uzunluğunu bulur

strrpos
strstr
Dizge İşlevleri
PHP Manual

strspn

(PHP 4, PHP 5, PHP 7)

strspn — Dizgenin, maskenin tam karakterleri ile eşleşen ilk parçasının uzunluğunu bulur

Açıklama

int strspn ( string $dizge , string $maske [, int $başlangıç [, int $uzunluk ]] )

dizge dizgesinin maske maskesinin tüm karakterleri ile eşleşen en uzun ilk parçasının uzunluğunu döndürür.

Eğer başlangıç ve uzunluk değiştirgeleri kullanılmamışsa dizge dizgesinin tamamı gözden geçirilir. Bunlar kullanılmışsa etkisi, strspn(substr($dizge, $başlangıç, $uzunluk), $maske) çağrısına eşdeğerdir. (Ayrıntılı bilgi için substr() işlevinin açıklamasına bakınız.)

Örnek:

<?php
$var = strspn("42 is the answer to the 128th question.", "1234567890");
?>
"1234567890" maskesiyle eşleşen en uzun ilk dizge parçası "42" olduğundan $var değişkenine 2 atanacaktır.

Değiştirgeler

dizge

Maskenin eşleştirileceği dizge.

maske

Dizge ile eşleştirilecek karakterleri içeren maske.

başlangıç

dizge içinde eşleştirmenin başlatılacağı konum.

başlangıç belirtilmişse ve negatif değilse arama işlemi dizge dizgesinin baştan başlangıç'ıncı karakterinden başlar; ilk karakterin konumu 0'dır.

Negatif değerler dizgenin sonundan itibaren sayılır.

uzunluk

Eşleşmenin aranacağı alt dizge uzunluğu.

uzunluk belirtilmişse ve negatif değilse arama dizgenin başlangıcından itibaren uzunluk'uncu karakterden başlar.

Negatif bir değer belirtilmişse arama işlemi dizgenin başından başlar ve dizgenin sonundan itibaren uzunluk'uncu karakterde biter.

Dönen Değerler

dizge dizgesinin maske maskesindeki karakterlerden oluşan ilk parçasının uzunluğunu döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.0 | başlangıç ve uzunluk değiştirgeleri eklendi.

Örnekler

Örnek 1 - strspn() örneği

<?php
echo strspn("foo", "o", 1, 2); // çıktısı: 2
?>

Notlar

Bilginize: Bu işlev ikil dosyalarla çalışırken dosya içeriğini değiştirmez.

Ayrıca Bakınız

  • strcspn() - Maske ile eşleşMEyen ilk parçanın uzunluğunu bulur

strrpos
strstr
Dizge İşlevleri


İlk alt dizgeyi bulur

strspn
strtok
Dizge İşlevleri
PHP Manual

strstr

(PHP 4, PHP 5, PHP 7)

strstr — İlk alt dizgeyi bulur

Açıklama

string strstr ( string $samanlık , mixed $iğne [, bool $iğne_öncesi = false ] )

samanlık dizgesinde bulunan ilk iğne dizgesinden başlayan parçayı döndürür.

Bilginize:

İşlev harf büyüklüğüne duyarlıdır. Harf büyüklüğüne duyarsız arama yapmak için stristr() işlevini kullanınız.

Bilginize:

İstediğiniz sadece samanlık içinde iğne var mı diye bakmaksa daha hızlı ve daha az bellek harcayan strpos() işlevini kullanın.

Değiştirgeler

samanlık

Girdi dizgesi.

iğne

iğne bir dizge değilse, önce bir tamsayıya dönüştürülür ve bu tamsayı karakterin kodu olarak ele alınır.

iğne_öncesi

TRUE ise (FALSE öntanımlıdır), strstr() işlevi samanlık dizgesinde bulunan ilk iğne dizgesinde biten parçayı döndürür.

Dönen Değerler

iğne bulunamazsa FALSE, aksi takdirde dizge parçası ile döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | Seçimlik iğne_öncesi değiştirgesi eklendi.
4.3.0 | strstr() ikil olarak güvenilir kılındı.

Örnekler

Örnek 1 - strstr() örneği

<?php
$email  = 'name@example.com';
$domain = strstr($email, '@');
echo $domain; // @example.com basar

$user = strstr($email, '@', true); // PHP 5.3.0 ve sonrası
echo $user; // name basar
?>

Ayrıca Bakınız

  • preg_match() - Bir düzenli ifadeyi eşleştirmeye çalışır
  • stristr() - Harf büyüklüğüne duyarsız olarak ilk alt dizgeyi bulur
  • strpos() - Bir alt dizgenin ilkinin konumunu bulur
  • strrchr() - Bir dizgede belli bir karakterin sonuncusuna göre dizgenin bir parçasıyla döner
  • substr() - Dizgenin bir kısmını döndürür

strspn
strtok
Dizge İşlevleri


Dizgeyi bir dizgeciğe göre böler

strstr
strtolower
Dizge İşlevleri
PHP Manual

strtok

(PHP 4, PHP 5, PHP 7)

strtok — Dizgeyi bir dizgeciğe göre böler

Açıklama

string strtok ( string $dizge , string $ayraçlar )
string strtok ( string $ayraçlar )

strtok() işlevi dizge dizgesini ayraçlar dizgesindeki karakterleri ayraç olarak kullanarak daha küçük dizgelere böler. Yani, "Bu örnek bir dizgedir" dizgesini boşluk karakterini ayraç olarak kullanarak sözcüklerine bölebilirsiniz.

Sadece ilk strtok() çağrısında dizge değiştirgesi belirtilir. Sonraki çağrılarda sadece ayraçlar değiştirgesini kullanmak yeterlidir. Baştan başlamak veya yeni dizgelerden birini ayrıştırmak için işlevi dizge değiştirgesi ile çağırmak işlemi ilklendirmek için yeterlidir. ayraçlar değiştirgesine birden fazla ayraç koyabilirsiniz. Dizge belirtilen bu ayraçlardan ilk rastladığıyla dizgeyi böler.

Değiştirgeler

dizge

Daha küçük parçalara bölünecek dizge.

ayraçlar

Dizgeyi bölmek için kullanılacak ayraçlardan oluşan dizge.

Dönen Değerler

Bir dizge parçası.

Örnekler

Örnek 1 - strtok() örneği

<?php
$string = "This is\tan example\nstring";
/* Sekme ve satırsonu karakterlerine göre dizgeyi bölelim */
$tok = strtok($string, " \n\t");

while ($tok !== false) {
    echo "Word=$tok<br />";
    $tok = strtok(" \n\t");
}
?>

İşlevin boş bir parça bulunduğu durumdaki davranışı PHP 4.1.0'dan itibaren değişmiştir. Eski davranış boş bir dizge döndürmekti. Yenisinde dizgenin o parçası basitçe atlanmaktadır. Örnek:

Örnek 2 - Eski strtok() davranışı

<?php
$dizge1  = strtok('/something', '/');
$dizge2 = strtok('/');
var_dump($dizge1, $dizge2);
?>

Yukarıdaki örneğin çıktısı:

    string(0) ""
    string(9) "something"

Örnek 3 Yeni strtok() davranışı

<?php
$dizge1  = strtok('/something', '/');
$dizge2 = strtok('/');
var_dump($dizge1, $dizge2);
?>

Yukarıdaki örneğin çıktısı:

    string(9) "something"
    bool(false)

Notlar

Uyarı

Bu işlev mantıksal FALSE değeriyle dönebileceği gibi FALSE olarak değerlendirilebilecek mantıksal olmayan bir değerle de dönebilir. Bu konuda daha fazla bilgi edinmek için Mantıksal Değerler bölümüne bakabilirsiniz. Bu işlevden dönen değeri sınamak için === işlecini kullanınız.

Ayrıca Bakınız

  • split() - Belirtilen dizgeyi düzenli ifadeye göre dizi elemanlarına böler
  • explode() - Bir dizgeyi bir ayraca göre bölüp bir dizi haline getirir

strstr
strtolower
Dizge İşlevleri


Bir dizgenin harflerini küçük harfe çevirir

strtok
strtoupper
Dizge İşlevleri
PHP Manual

strtolower

(PHP 4, PHP 5, PHP 7)

strtolower — Bir dizgenin harflerini küçük harfe çevirir

Açıklama

string strtolower ( string $dizge )

Belirtilen dizge dizgesindeki tüm abecesel karakterleri küçük harfe dönüştürerek elde edilen dizgeyi döndürür.

Abecesel karakterler mevcut yerele göre değerlendirilir. Örneğin "C" yerelinde Ü harfi ü harfine dönüştürülmeyecektir.

Değiştirgeler

dizge

Girdi dizgesi.

Dönen Değerler

Küçük harfli dizgeyle döner.

Örnekler

Örnek 1 - strtolower() örneği

<?php
$str = "Mini MİNİ bir KUŞ uçmuştu PENCEREME konmuştu.";
$str = strtolower($str);
echo $str;
// PHP 5.3.0beta2-dev (cli) ile tr_TR.UTF-8 yerelindeki çıktısı:
// mini mİnİ bir kuŞ uçmuştu pencereme konmuştu.
?>

Notlar

Bilginize: Bu işlev ikil dosyalarla çalışırken dosya içeriğini değiştirmez.

Ayrıca Bakınız

  • strtoupper() - Bir dizgenin harflerini büyük harfe çevirir
  • ucfirst() - Dizgenin ilk karakterini büyük harfe çevirir
  • ucwords() - Dizgedeki her sözcüğün ilk harfini büyük harf yapar
  • mb_strtolower() - Dizgeyi küçük harfli yapar

strtok
strtoupper
Dizge İşlevleri


Bir dizgenin harflerini büyük harfe çevirir

strtolower
strtr
Dizge İşlevleri
PHP Manual

strtoupper

(PHP 4, PHP 5, PHP 7)

strtoupper — Bir dizgenin harflerini büyük harfe çevirir

Açıklama

string strtoupper ( string $dizge )

Belirtilen dizge dizgesindeki tüm abecesel karakterleri büyük harfe dönüştürerek elde edilen dizgeyi döndürür.

Abecesel karakterler mevcut yerele göre değerlendirilir. Örneğin "C" yerelinde ü harfi Ü harfine dönüştürülmeyecektir.

Değiştirgeler

dizge

Girdi dizgesi.

Dönen Değerler

Büyük harfli dizgeyle döner.

Örnekler

Örnek 1 - strtoupper() örneği

<?php
$str = "BiR küçÜcÜK ASLANcık varmış";
$str = strtoupper($str);
echo $str;
// PHP 5.3.0beta2-dev (cli) ile tr_TR.UTF-8 yerelindeki çıktısı:
// BiR KüçÜCÜK ASLANCıK VARMış
?>

Notlar

Bilginize: Bu işlev ikil dosyalarla çalışırken dosya içeriğini değiştirmez.

Ayrıca Bakınız

  • strtolower() - Bir dizgenin harflerini küçük harfe çevirir
  • ucfirst() - Dizgenin ilk karakterini büyük harfe çevirir
  • ucwords() - Dizgedeki her sözcüğün ilk harfini büyük harf yapar
  • mb_strtoupper() - Dizgeyi büyük harfli yapar

strtolower
strtr
Dizge İşlevleri


Belli karakterleri dönüştürür

strtoupper
substr_compare
Dizge İşlevleri
PHP Manual

strtr

(PHP 4, PHP 5, PHP 7)

strtr — Belli karakterleri dönüştürür

Açıklama

string strtr ( string $dizge , string $eski , string $yeni )
string strtr ( string $dizge , array $eski_yeni )

Bu işlev dizge dizgesindeki her eski dizgesinin yerine yeni dizgesini yerleştirilerek elde edilen dizgeyi döndürür.

Değiştirgeler

dizge

Karakterleri dönüştürülecek dizge.

eski

Yerine yenisi konacak dizge.

yeni

Eskisinin yerine konacak dizge.

eski_yeni

array('eski' => 'yeni', ...) çiftlerinden oluşan bir dizi.

Dönen Değerler

dizge dizgesindeki her eski dizgesinin yerine yeni dizgesi yerleştirilerek elde edilen dizgeyle döner.

Sürüm Bilgisi

Sürüm: | Açıklama
4.0.0 | Seçimlik eski ve yeni değiştirgeleri eklendi.

Örnekler

Örnek 1 - strtr() örneği

<?php
$addr = strtr($addr, "äåö", "aao");
?>

strtr() işlevi iki değiştirge ile de çağrılabilir. Bu durumda birinci değiştirgede belirtilen dizge ikinci değiştirgedeki eski -> yeni çiftleri kullanılarak dönüştürülür. strtr() olası en uzun ilk eşleşmeyi arar, ancak daha önce değişiklik yaptığı kısmı yeniden değerlendirmez.

Örnek 2 - İki değiştirgeli strtr() örneği

<?php
$trans = array("hello" => "hi", "hi" => "hello");
echo strtr("hi all, I said hello", $trans);
?>

Yukarıdaki örneğin çıktısı:

hello all, I said hi

Ayrıca Bakınız

  • preg_replace() - Düzenli ifadeye göre dizgede değişiklik yapar

strtoupper
substr_compare
Dizge İşlevleri


İki dizgenin belli bir konumdan itibaren belli uzunluktaki parçalarını bayt bayt karşılaştırır

strtr
substr_count
Dizge İşlevleri
PHP Manual

substr_compare

(PHP 5, PHP 7)

substr_compare — İki dizgenin belli bir konumdan itibaren belli uzunluktaki parçalarını bayt bayt karşılaştırır

Açıklama

int substr_compare ( string $ana_dizge , string $dizge , int $başlangıç [, int $uzunluk = 0 [, bool $büyüklük_duyarsız = false ]] )

substr_compare() işlevi ana_dizge dizgesinin başlangıç'tan itibaren uzunluk karakterlik parçasını dizge dizgesiyle karşılaştırır.

Değiştirgeler

ana_dizge

dizge

başlangıç

Karşılaştırmanın başlayacağı konum. Negatifse, saymaya dizgenin sonundan itibaren başlanır.

uzunluk

Karşılaştırılacak uzunluk.

büyüklük_duyarsız

büyüklük_duyarsız TRUE ise, karşılaştırmada harf büyüklükleri dikkade alınmaz.

Dönen Değerler

Eğer ana_dizge dizgesinin başlangıç konumundan başlayan parçası dizge dizgesinden küçükse sıfırdan küçük bir değer, büyükse sıfırdan büyük bir değer, ikisi eşitse sıfır döner. Eğer uzunluk belirtilmişse ve ana_dizge dizgesinin uzunluğuna eşit veya ondan büyükse substr_compare() bir uyarı basar ve FALSE döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.0 | Negatif bir başlangıç kullanma olasılığı dikkate alındı.

Örnekler

Örnek 1 - substr_compare() örneği

<?php
echo substr_compare("abcde", "bc", 1, 2); // 0
echo substr_compare("abcde", "de", -2, 2); // 0
echo substr_compare("abcde", "bcg", 1, 2); // 0
echo substr_compare("abcde", "BC", 1, 2, true); // 0
echo substr_compare("abcde", "bc", 1, 3); // 1
echo substr_compare("abcde", "cd", 1, 2); // -1
echo substr_compare("abcde", "abc", 5, 1); // uyarı
?>

strtr
substr_count
Dizge İşlevleri


Bir dizge içinde belli bir alt dizgeden kaç tane bulunduğunu bulur

substr_compare
substr_replace
Dizge İşlevleri
PHP Manual

substr_count

(PHP 4, PHP 5, PHP 7)

substr_count — Bir dizge içinde belli bir alt dizgeden kaç tane bulunduğunu bulur

Açıklama

int substr_count ( string $samanlık , string $iğne [, int $başlangıç = 0 [, int $uzunluk ]] )

substr_count() işlevi samanlık dizgesi içindeki iğne alt dizgelerinin sayısını döndürür. iğne değiştirgesinin harf büyüklüğüne duyarlı oluşuna dikkat ediniz.

Bilginize:

Bu işlev, birbirinin üstüne binmiş alt dizgeleri saymaz. Örnek için aşağıya bakın!

Değiştirgeler

samanlık

Araştırılacak dizge.

iğne

Aranacak dizge.

başlangıç

Saymaya başlanacak konum.

uzunluk

Dizgenin ne kadarlık parçasında arama yapılacağı burada belirtilir. Eğer başlangıç artı uzunluk, samanlık uzunluğundan fazla ise bir uyarı oluşur.

Dönen Değerler

İşlev bir tamsayı döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.0 | başlangıç ve uzunluk değiştirgeleri eklendi.

Örnekler

Örnek 1 - substr_count() örneği

<?php
$text = 'This is a test';
echo strlen($text); // 14

echo substr_count($text, 'is'); // 2

// Arama 's is a test' parçasında yapılır ve 1 basılır
echo substr_count($text, 'is', 3);

// Arama 's i' parçasında yapılır ve 0 basılır
echo substr_count($text, 'is', 3, 3);

// 5+10 > 14 olduğundan bir uyarı verilir
echo substr_count($text, 'is', 5, 10);

// üst üste binen dizgeleri saymadığından sadece 1 basılır
$text2 = 'gcdgcdgcd';
echo substr_count($text2, 'gcdgcd');
?>

Ayrıca Bakınız

  • count_chars() - Bir dizgedeki karakterler hakkında bilgi döndürür
  • strpos() - Bir alt dizgenin ilkinin konumunu bulur
  • substr() - Dizgenin bir kısmını döndürür
  • strstr() - İlk alt dizgeyi bulur

substr_compare
substr_replace
Dizge İşlevleri


Bir dizgenin belli bir bölümünü değiştirir

substr_count
substr
Dizge İşlevleri
PHP Manual

substr_replace

(PHP 4, PHP 5, PHP 7)

substr_replace — Bir dizgenin belli bir bölümünü değiştirir

Açıklama

mixed substr_replace ( mixed $dizge , string $yenisi , int $başlangıç [, int $uzunluk ] )

substr_replace() işlevi dizge dizgesinin başlangıç (seçimlik) konumundan itibaren uzunluk karakterlik parçasının yerine yenisi dizgesini yerleştirir.

Değiştirgeler

dizge

Girdi dizgesi.

yenisi

Değiştirilecek kısma yerleştirilecek dizge.

başlangıç

Eğer başlangıç pozitifse, yer değiştirme işlemi dizge dizgesinin baştan başlangıç'ıncı karakterinden başlar.

Eğer başlangıç negatifse, yer değiştirme işlemi dizge dizgesinin sondan başlangıç'ıncı karakterinden başlar.

uzunluk

Belirtilmiş ve pozitifse, dizge dizgesinin değiştirilecek parçasının uzunluğudur; negatif ise, dizge dizgesinin sonundan itibaren yerleştirmenin durdurulacağı karakter sayısıdır. Belirtilmezse, strlen(dizge) öntanımlıdır, yani yerleştirme işlemi dizgenin sonunda biter. uzunluk sıfırsa, yenisi dizgesi dizge dizgesine başlangıç (seçimlik) konumundan itibaren yerleştirir.

Dönen Değerler

Elde edilen dizge döner. dizge bir dizi ise bir dizi döner.

Örnekler

Örnek 1 - substr_replace() örneği

<?php
$var = 'ABCDEFGH:/MNRPQR/';
echo "Original: $var<hr />\n";

/* Bu iki örnek $var dizgesinin tamamını 'bob' yapar. */
echo substr_replace($var, 'bob', 0) . "<br />\n";
echo substr_replace($var, 'bob', 0, strlen($var)) . "<br />\n";

/* 'bob' $var dizgesine dizgenin başından itibaren yerleştirilir. */
echo substr_replace($var, 'bob', 0, 0) . "<br />\n";

/* Bu ikisi $var içindeki 'MNRPQR' yerine 'bob' yerleştirir. */
echo substr_replace($var, 'bob', 10, -1) . "<br />\n";
echo substr_replace($var, 'bob', -7, -1) . "<br />\n";

/* $var dizgesinin 'MNRPQR' parçasını siler. */
echo substr_replace($var, '', 10, -1) . "<br />\n";
?>

Notlar

Bilginize: Bu işlev ikil dosyalarla çalışırken dosya içeriğini değiştirmez.

Ayrıca Bakınız

  • str_replace() - Bir alt dizgenin bütün örneklerini yenisiyle değiştirir
  • substr() - Dizgenin bir kısmını döndürür

substr_count
substr
Dizge İşlevleri


Dizgenin bir kısmını döndürür

substr_replace
trim
Dizge İşlevleri
PHP Manual

substr

(PHP 4, PHP 5, PHP 7)

substr — Dizgenin bir kısmını döndürür

Açıklama

string substr ( string $dizge , int $başlangıç [, integer $uzunluk ] )

dizge'nin başlangıç'tan itibaren uzunluk uzunluğunda parçasını döndürür.

Değiştirgeler

dizge

Girilen dizge.

başlangıç

Eğer başlangıç değiştirgesi negatif değilse geri dönen dizge değeri, dizge'nin 0'dan itibaren başlangıç'ıncı konumundan başlar. Mesela, 'abcdef' dizgesinde, 0'ıncı konumdaki karakter 'a', 2'inci konumdaki karakter 'c'dir.

Eğer başlangıç değiştirgesi negatif ise, dönen dizge değeri dizge'nin sonundan başlangıç karakter önce başlar.

Eğer dizge dizgesinin uzunluğu başlangıç dizgesinin uzunluğundan küçükse ya da eşitse işlev FALSE döndürür.

Örnek 1 - Negatif başlangıç kullanımı

<?php
$rest = substr("abcdef", -1);    // "f" döndürür
$rest = substr("abcdef", -2);    // "ef" döndürür
$rest = substr("abcdef", -3, 1); // "d" döndürür
?>

uzunluk

Eğer uzunluk değiştirgesi verildiyse ve pozitifse dönen dizge, dizge'nin uzunluğuna göre başlangıç'tan itibaren uzunluk'ta belirtilen karakter sayısı kadar karakter içerir.

Eğer uzunluk değiştirgesi verildiyse ve negatifse dizge'nin sonundan belirtilen kadar karakter çıkartılır (başlangıç negatif ise önce başlagıç konumu hesaplanır). Eğer başlangıç değiştirgesi negatif uzunlukla çıkarılan parçanın içindeki bir yeri işaret ediyorsa boş dizge döner.

uzunluk verilmiş ve 0 ise FALSE, NULL ise boş bir dizge döner.

Örnek 2 - Negatif uzunluk kullanımı

<?php
$rest = substr("abcdef", 0, -1);  // "abcde" döndürür
$rest = substr("abcdef", 2, -1);  // "cde" döndürür
$rest = substr("abcdef", 4, -4);  // "" döndürür
$rest = substr("abcdef", -3, -1); // "de" döndürür
?>

Dönen Değerler

Başarı durumunda dizgenin çıkarılan kısmı, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 3 - Basit substr() kullanımı

<?php
echo substr('abcdef', 1);     // bcdef
echo substr('abcdef', 1, 3);  // bcd
echo substr('abcdef', 0, 4);  // abcd
echo substr('abcdef', 0, 8);  // abcdef
echo substr('abcdef', -1, 1); // f

// Dizge içerisindeki tek bir karaktere ulaşmak için
// "köşeli ayraçlar" da kullanılabilir.
$dizge = 'abcdef';
echo $dizge[0];                 // a
echo $dizge[3];                 // d
echo $dizge[strlen($dizge)-1];  // f

?>

Hatalar/İstisnalar

Hata oluşursa FALSE döner.

<?php
var_dump(substr('a', 1)); // bool(false)
?>

Ayrıca Bakınız

  • strrchr() - Bir dizgede belli bir karakterin sonuncusuna göre dizgenin bir parçasıyla döner
  • substr_replace() - Bir dizgenin belli bir bölümünü değiştirir
  • preg_match() - Bir düzenli ifadeyi eşleştirmeye çalışır
  • trim() - Dizgenin başındaki ve sonundaki boşlukları (veya diğer karakterleri) budar
  • mb_substr() - Dizgenin bir alt dizgesini alır
  • wordwrap() - Bir dizgeyi belli bir uzunlukta katlar

substr_replace
trim
Dizge İşlevleri


Dizgenin başındaki ve sonundaki boşlukları (veya diğer karakterleri) budar

substr
ucfirst
Dizge İşlevleri
PHP Manual

trim

(PHP 4, PHP 5, PHP 7)

trim — Dizgenin başındaki ve sonundaki boşlukları (veya diğer karakterleri) budar

Açıklama

string trim ( string $dizge [, string $karakterler ] )

Bu işlev dizge'nin başındaki ve sonundaki boşlukları budar. İkinci değiştirge olmaksızın trim() sadece aşağıdaki karakterleri budayacaktır:

  • " " (ASCII 32 (0x20)), sıradan boşluk.
  • "\t" (ASCII 9 (0x09)), sekme.
  • "\n" (ASCII 10 (0x0A)), satırsonu.
  • "\r" (ASCII 13 (0x0D)), satırbaşı.
  • "\0" (ASCII 0 (0x00)), NUL-bayt.
  • "\x0B" (ASCII 11 (0x0B)), dikey sekme.

Değiştirgeler

dizge

Budanacak dizge.

karakterler

Seçimlik olarak, karakterler değiştirgesi kullanılarak budanacak karakterler belirlenebilir. Basitçe budamak istediğiniz tüm karakterleri belirtin. Bir karakter aralığını .. kullanarak belirtebilirsiniz.

Dönen Değerler

Budanmış dizge.

Sürüm Bilgisi

Sürüm: | Açıklama
4.1.0 | İsteğe bağlı karakterler değiştirgesi eklendi.

Örnekler

Örnek 1 - trim() işlevinin kullanımı

<?php

$metin   = "\t\tBir kaç kelam :) ...  ";
$ikil = "\x09Örnek dizge\x0A";
$selam  = "Merhaba Dünya";
var_dump($metin, $ikil, $selam);

print "\n";

$kırpık = trim($metin);
var_dump($kırpık);

$kırpık = trim($metin, " \t.");
var_dump($kırpık);

$kırpık = trim($selam, "aerMy");
var_dump($kırpık);

// $ikil'in başındaki ve sonundaki ASCII denetim karakterlerini budar
// (0'dan 31'e kadar, 0 ve 31 dahil)
$temiz = trim($ikil, "\x00..\x1F");
var_dump($temiz);

?>

Yukarıdaki örneğin çıktısı:

string(25) "            Bir kaç kelam :) ...  "
string(14) "    Örnek dizge
"
string(14) "Merhaba Dünya"

string(21) "Bir kaç kelam :) ..."
string(17) "Bir kaç kelam :)"
string(9) "haba Dün"
string(12) "Örnek dizge"

Örnek 2 - trim() işlevini dizi değerlerine uygulama

<?php
function değeri_buda(&$değer)
{
    $değer = trim($değer);
}

$meyve = array('elma','muz ', ' muşmula ');
var_dump($meyve);

array_walk($meyve, 'değeri_buda');
var_dump($meyve);

?>

Yukarıdaki örneğin çıktısı:

array(3) {
  [0]=>
  string(4) "elma"
  [1]=>
  string(4) "muz "
  [2]=>
  string(10) " muşmula "
}
array(3) {
  [0]=>
  string(4) "elma"
  [1]=>
  string(3) "muz"
  [2]=>
  string(8) "muşmula"
}

Ayrıca Bakınız

  • ltrim() - Dizgenin başındaki boşlukları (veya diğer karakterleri) budar
  • rtrim() - Dizgenin sonundaki boşlukları (veya diğer karakterleri) budar

substr
ucfirst
Dizge İşlevleri


Dizgenin ilk karakterini büyük harfe çevirir

trim
ucwords
Dizge İşlevleri
PHP Manual

ucfirst

(PHP 4, PHP 5, PHP 7)

ucfirst — Dizgenin ilk karakterini büyük harfe çevirir

Açıklama

string ucfirst ( string $dizge )

Eğer dizge'nin ilk karakteri harf ise, büyük harfe çevirerek dizgeyi döndürür.

Burada, 'harf' geçerli yerele göre saptanır. Mesela, öntanımlı "C" yerelinde ü harfi Ü harfine çevirilmeyecektir.

Değiştirgeler

dizge

Girdi dizgesi.

Dönen Değerler

Sonuçlanan dizgeyi döndürür.

Örnekler

Örnek 1 - ucfirst() örneği

<?php
$foo = 'merhaba!';
$foo = ucfirst($foo);             // Merhaba!

$bar = 'MERHABA!';
$bar = ucfirst($bar);             // MERHABA!
$bar = ucfirst(strtolower($bar)); // Merhaba!
?>

Ayrıca Bakınız

  • lcfirst() - Bir dizgenin ilk karakterini küçük harf yapar
  • strtolower() - Bir dizgenin harflerini küçük harfe çevirir
  • strtoupper() - Bir dizgenin harflerini büyük harfe çevirir
  • ucwords() - Dizgedeki her sözcüğün ilk harfini büyük harf yapar

trim
ucwords
Dizge İşlevleri


Dizgedeki her sözcüğün ilk harfini büyük harf yapar

ucfirst
vfprintf
Dizge İşlevleri
PHP Manual

ucwords

(PHP 4, PHP 5, PHP 7)

ucwords — Dizgedeki her sözcüğün ilk harfini büyük harf yapar

Açıklama

string ucwords ( string $dizge )

dizge dizgesindeki her sözcüğün ilk harfini büyük harf yapar. Sözcüğün ilk karakteri bir harf değilse o sözcüğe dokunulmaz.

Bir sözcük, bir boşluk karakterlerinden sonra gelen ve boşluk karakterleri içermeyen bir dizge olarak tanımlanır (Boşluk karakterleri: boşluk, sayfa ileri, satırsonu, satırbaşı, yatay ve düşey sekme).

Değiştirgeler

dizge

Girdi dizgesi.

Dönen Değerler

Dönüştürülen dizgeyi döndürür.

Örnekler

Örnek 1 - ucwords() örneği

<?php
$foo = 'hello world!';
$foo = ucwords($foo);             // Hello World!

$bar = 'HELLO WORLD!';
$bar = ucwords($bar);             // HELLO WORLD!
$bar = ucwords(strtolower($bar)); // Hello World!
?>

Notlar

Bilginize: Bu işlev ikil dosyalarla çalışırken dosya içeriğini değiştirmez.

Ayrıca Bakınız

  • strtoupper() - Bir dizgenin harflerini büyük harfe çevirir
  • strtolower() - Bir dizgenin harflerini küçük harfe çevirir
  • ucfirst() - Dizgenin ilk karakterini büyük harfe çevirir
  • mb_convert_case() - Bir dizgeye büyük-küçük harf dönüşümü uygular

ucfirst
vfprintf
Dizge İşlevleri


Biçemli dizgeyi bir akıma yazar

ucwords
vprintf
Dizge İşlevleri
PHP Manual

vfprintf

(PHP 5, PHP 7)

vfprintf — Biçemli dizgeyi bir akıma yazar

Açıklama

int vfprintf ( resource $dt , string $biçem , array $değiştirgeler )

değiştirgeler dizisindeki değiştirgeler biçem dizgesine göre değerlendirilerek, oluşturulan dizge tanıtıcısı dt ile belirtilen akıma yazılır.

Değişken sayıda değiştirge yerine bunları bir dizi içinde kabul etmesi dışında fprintf() gibidir.

Değiştirgeler

dt

Dosya tanıtıcısı.

biçem

biçem ile ilgili açıklama için sprintf() işlevine bakınız.

değiştirgeler

biçem dizgesine göre değerlendirilecek değiştirgelerden oluşan dizi.

Dönen Değerler

Çıktılanan dizgenin uzunluğu ile döner.

Örnekler

Örnek 1 vfprintf(): sıfır dolgulu tamsayılar

<?php
if (!($dt = fopen('date.txt', 'w')))
    return;

vfprintf($dt, "%04d-%02d-%02d", array($year, $month, $day));
// ISO biçemli tarih date.txt dosyasına yazılır
?>

Ayrıca Bakınız

  • printf() - Biçemli bir dizge çıktılar
  • sprintf() - Biçemli bir dizge döndürür
  • sscanf() - Girdi dizgesini belli bir biçeme göre yorumlar
  • fscanf() - Bir dosyadaki girdiyi belli bir biçeme göre çözümler
  • vsprintf() - Biçemli bir dizge döndürür
  • number_format() - Sayıyı binlik bölümlere ayırır

ucwords
vprintf
Dizge İşlevleri


Biçemli bir dizge çıktılar

vfprintf
vsprintf
Dizge İşlevleri
PHP Manual

vprintf

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

vprintf — Biçemli bir dizge çıktılar

Açıklama

int vprintf ( string $biçem , array $değiştirgeler )

değiştirgeler dizisindeki değiştirgeler biçem dizgesine göre değerlendirilerek, oluşturulan dizgeyi basar. biçem ile ilgili açıklama için sprintf() işlevine bakınız.

Değişken sayıda değiştirge yerine bunları bir dizi içinde kabul etmesi dışında printf() gibidir.

Değiştirgeler

biçem

biçem ile ilgili açıklama için sprintf() işlevine bakınız.

değiştirgeler

biçem dizgesine göre değerlendirilecek değiştirgelerden oluşan dizi.

Dönen Değerler

Çıktılanan dizgenin uzunluğu ile döner.

Örnekler

Örnek 1 - vprintf(): sıfır dolgulu tamsayılar

<?php
vprintf("%04d-%02d-%02d", explode('-', '1988-8-1')); // 1988-08-01
?>

Ayrıca Bakınız

  • printf() - Biçemli bir dizge çıktılar
  • sprintf() - Biçemli bir dizge döndürür
  • vsprintf() - Biçemli bir dizge döndürür

vfprintf
vsprintf
Dizge İşlevleri


Biçemli bir dizge döndürür

vprintf
wordwrap
Dizge İşlevleri
PHP Manual

vsprintf

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

vsprintf — Biçemli bir dizge döndürür

Açıklama

string vsprintf ( string $biçem , array $değiştirgeler )

Değişken sayıda değiştirge yerine bunları bir dizi içinde kabul etmesi dışında sprintf() gibidir.

Değiştirgeler

biçem

biçem ile ilgili açıklama için sprintf() işlevine bakınız.

değiştirgeler

biçem dizgesine göre değerlendirilecek değiştirgelerden oluşan dizi.

Dönen Değerler

değiştirgeler dizisindeki değiştirgeler biçem dizgesine göre değerlendirilerek, oluşturulan dizge döner. biçem ile ilgili açıklama için sprintf() işlevine bakınız.

Örnekler

Örnek 1 - vsprintf(): sıfır dolgulu tamsayılar

<?php
print vsprintf("%04d-%02d-%02d", explode('-', '1988-8-1')); // 1988-08-01
?>

Ayrıca Bakınız

  • sprintf() - Biçemli bir dizge döndürür
  • vprintf() - Biçemli bir dizge çıktılar

vprintf
wordwrap
Dizge İşlevleri


Bir dizgeyi belli bir uzunlukta katlar

vsprintf
Değişkenler ve Veri Türleriyle İlgili Eklentiler
Dizge İşlevleri
PHP Manual

wordwrap

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

wordwrap — Bir dizgeyi belli bir uzunlukta katlar

Açıklama

string wordwrap ( string $dizge [, int $genişlik = 75 [, string $satırsonu = "\n" [, bool $kes = false ]]] )

Belirtilen dizgeyi belirtilen genişlikte belirtilen satırsonu karakterini kullanarak katlar.

Değiştirgeler

dizge

Girdi dizgesi.

genişlik

Sütun genişliği; 75 öntanımlıdır.

satırsonu

Satırın sonuna eklenecek isteğe bağlı satırsonu karakteri. '\n' öntanımlıdır.

kes

kes TRUE ise, dizge belirtilen genişlikte veya daha önce, satırdaki son sözcüğü kesme pahasına katlanır. (İkinci örneğe bakınız).

Dönen Değerler

Belirtilen sütunda katlanan dizgeyi döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
4.0.3 | Seçimlik kesdeğiştirgesi eklendi.

Örnekler

Örnek 1 - wordwrap() örneği

<?php
$metin = "Dağ başını duman almış, gümüş dere durmaz akar.";
$yenisi = wordwrap($metin, 30, "<br />\n");

echo $yenisi;
?>

Yukarıdaki örneğin çıktısı:

Dağ başını duman almış,<br />
gümüş dere durmaz akar.

Örnek 2 - Kesmeli wordwrap() örneği

<?php
$metin = "Çoooooooooooook uzun bir sözcük.";
$yenisi = wordwrap($metin, 10, "\n", true);

echo "$yenisi\n";
?>

Yukarıdaki örneğin çıktısı:

Çoooooooo
oooook
uzun bir
sözcük.

Ayrıca Bakınız

  • nl2br() - Dizgedeki tüm satırsonlarının yerine HTML satır katlayıcıları yerleştirilir
  • chunk_split() - Bir dizgeyi daha küçük parçalara ayırır

vsprintf
Değişkenler ve Veri Türleriyle İlgili Eklentiler
Dizge İşlevleri


Değişkenler ve Veri Türleriyle İlgili Eklentiler

  • Diziler
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Dizilerde Sıralama
    • Dizi İşlevleri
  • Sınıflar ve Nesneler — Sınıf ve Nesne Bilgileri
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • Sınıf ve Nesne İşlevleri
  • Classkit
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Classkit İşlevleri
  • Ctype — Karakter Türü Sınaması
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Karakter Türü Sınama İşlevleri
  • Data Structures
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • Collection — The Collection interface
    • Hashable — The Hashable interface
    • Sequence — The Sequence interface
    • Vector — The Vector class
    • Deque — The Deque class
    • Map — The Map class
    • Pair — The Pair class
    • Set — The Set class
    • Stack — The Stack class
    • Queue — The Queue class
    • PriorityQueue — The PriorityQueue class
  • Filter — Data Filtering
    • Giriş
    • Yapılandırma/Kurulum
    • Types of filters
    • Öntanımlı Sabitler
    • Örnekler
    • Filter İşlevleri
  • İşlevlerle İlgili İşlemler
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • İşlevlerle İlgili İşlevler
  • Quickhash
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • QuickHashIntSet — The QuickHashIntSet class
    • QuickHashIntHash — The QuickHashIntHash class
    • QuickHashStringIntHash — The QuickHashStringIntHash class
    • QuickHashIntStringHash — The QuickHashIntStringHash class
  • Reflection — Yansıtma
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • Yansıtma Sınıflarının Genişletilmesi
    • Reflection — Reflection Sınıfı
    • ReflectionClass — ReflectionClass Sınıfı
    • ReflectionExtension — ReflectionExtension Sınıfı
    • ReflectionFunction — ReflectionFunction Sınıfı
    • ReflectionFunctionAbstract — ReflectionFunctionAbstract sınıfı
    • ReflectionMethod — ReflectionMethod Sınıfı
    • ReflectionObject — ReflectionObject Sınıfı
    • ReflectionParameter — ReflectionParameter Sınıfı
    • ReflectionProperty — ReflectionProperty Sınıfı
    • Reflector — Reflector Arayüzü
  • Değişken İşlemleri
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Değişkenlerle ilgili işlevler
wordwrap
Diziler
İşlev Başvuru Kılavuzu


Diziler

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Dizilerde Sıralama
  • Dizi İşlevleri
    • array_change_key_case — Bir dizideki tüm anahtarların harf büyüklüğünü değiştirir
    • array_chunk — Bir diziyi belli uzunlukta bölümlere ayırır
    • array_column — Return the values from a single column in the input array
    • array_combine — Anahtarlar için bir dizi, değerler için ise başka bir dizi kullanarak bir ilişkisel dizi oluşturur
    • array_count_values — Bir dizideki tüm değerleri sayar
    • array_diff_assoc — Dizilerin farkını hesaplarken ek olarak indisleri de karşılaştırır
    • array_diff_key — Dizilerin farkını hesaplarken indisleri karşılaştırır
    • array_diff_uassoc — Dizilerin farkını hesaplarken ek olarak bir geriçağırım işlevi üzerinden indisleri de karşılaştırır
    • array_diff_ukey — Karşılaştırma için bir geriçağırım işlevi kullanarak dizilerin farkını hesaplar
    • array_diff — Dizilerin farkını hesaplar
    • array_fill_keys — Anahtarları belirtilen diziyi değerlerle doldurur
    • array_fill — Bir diziyi değerlerle doldurur
    • array_filter — Bir dizinin elemanlarını bir geriçağırım işleviyle süzgeçten geçirir
    • array_flip — Bir dizideki anahtarlarla değerleri yer değiştirir
    • array_intersect_assoc — Dizilerin kesişimini hesaplarken ek olarak indisleri de karşılaştırır
    • array_intersect_key — Karşılaştırma için anahtarları kullanarak dizilerin kesişimini hesaplar
    • array_intersect_uassoc — Dizilerin kesişimini hesaplarken ek olarak bir geriçağırım işlevi üzerinden indisleri de karşılaştırır
    • array_intersect_ukey — Anahtarları karşılaştırmak için bir geriçağırım işlevi kullanarak dizilerin kesişimini hesaplar
    • array_intersect — Dizilerin kesişimini hesaplar
    • array_key_exists — Belirtilen anahtar veya indis dizide var mı diye bakar
    • array_keys — Bir dizideki tüm anahtarları veya bir anahtar altkümesini döndürür
    • array_map — Belirtilen dizilerin elemanlarına geriçağırım işlevini uygular
    • array_merge_recursive — İki veya daha fazla sayıda diziyi ardarda ekleyerek yeni bir dizi oluşturur
    • array_merge — Belirtilen dizileri ardarda ekleyerek yeni bir dizi oluşturur
    • array_multisort — Çok sayıda diziyi veya çok boyutlu dizileri sıralar
    • array_pad — Dizi boyutunu belirtilen boyuta çıkarırken, yeni elemanlara belirtilen değeri yerleştirir
    • array_pop — Dizinin sonundaki elemanı diziden çıkartır
    • array_product — Bir dizideki değerlerin çarpımını bulur
    • array_push — Belli sayıda elemanı dizinin sonuna ekler
    • array_rand — Bir diziden belli sayıda rasgele eleman döndürür
    • array_reduce — Bir geriçağırım işlevini dizinin bütün elemanlarına tek tek uygulayıp sonucu döndürür
    • array_replace_recursive — İlk dizinin elemanlarını aktarılan dizilerden ardışık olarak günceller
    • array_replace — İlk dizinin elemanlarını aktarılan dizilerden günceller
    • array_reverse — Diziyi tersine sıralayıp döndürür
    • array_search — Bir dizide belirtilen değeri arar ve bulursa ilgili anahtarı döndürür
    • array_shift — Dizini başlangıcından bir eleman çeker
    • array_slice — Bir dizinin belli bir bölümünü döndürür
    • array_splice — Bir dizinin belli bir bölümünü silip yerine başka şeyler koyar
    • array_sum — Bir dizideki değerlerin toplamını hesaplar
    • array_udiff_assoc — Veri karşılaştırması için bir geriçağırım işlevi kullanarak diziler arasındaki farkı indislerine de bakarak bulur
    • array_udiff_uassoc — Veri ve indis karşılaştırması için bir geriçağırım işlevi kullanarak diziler arasındaki farkı indislerine de bakarak bulur
    • array_udiff — Veri karşılaştırması için bir geriçağırım işlevi kullanarak diziler arasındaki farkı bulur
    • array_uintersect_assoc — Veriyi bir geriçağırım işleviyle karşılaştırarak dizilerin kesişimini hesaplarken ek olarak indislere de bakar
    • array_uintersect_uassoc — Veriyi ve indisleri bir geriçağırım işleviyle karşılaştırarak dizilerin kesişimini hesaplarken ek olarak indislere de bakar
    • array_uintersect — Veriyi bir geriçağırım işleviyle karşılaştırarak dizilerin kesişimini hesaplar
    • array_unique — Diziden yinelenen değerleri siler
    • array_unshift — Bir dizinin başlangıcına bir veya daha fazla eleman ekler
    • array_values — Bir dizinin tüm değerlerini döndürür
    • array_walk_recursive — Bir dizinin ardışık olarak her üyesine kullanıcı tanımlı bir işlevi uygular
    • array_walk — Bir dizinin her üyesine kullanıcı tanımlı bir işlevi uygular
    • array — Bir dizi oluşturur
    • arsort — Bir dizinin değerlerini anahtarlarıyla ilişkilerini bozmadan tersine sıralar
    • asort — Bir dizinin değerlerini anahtarlarıyla ilişkilerini bozmadan sıralar
    • compact — Değişkenlerle değerlerinden oluşan bir dizi oluşturur
    • count — Bir dizideki eleman sayısını veya bir nesnedeki özellik sayısını döndürür
    • current — Bir diziden gösterici konumundaki elemanı döndürür
    • each — Bir diziden, gösterici konumundaki anahtar değer çiftini döndürdükten sonra göstericiyi bir ilerletir
    • end — Bir dizinin dahili göstericisini sonuncu elemana konumlandırır
    • extract — Bir dizideki değişkenleri simge tablosuna dahil eder
    • in_array — Bir dizide bir değerin varlığını araştırır
    • key_exists — Takma Adı: array_key_exists
    • key — Bir diziden gösterici konumundaki anahtarı döndürür
    • krsort — Bir diziyi anahtarlarına göre tersine sıralar
    • ksort — Bir diziyi anahtarlarına göre sıralar
    • list — Değişkenlere bir dizi gibi atama yapar
    • natcasesort — Bir diziyi harf büyüklüğüne duyarsız "doğal sıralama" algoritmasıyla sıralar
    • natsort — Bir diziyi "doğal sıralama" algoritmasıyla sıralar
    • next — Dahili dizi göstericisini bir ilerletir
    • pos — current işlevinin takma adıdır
    • prev — Dahili dizi göstericisini bir geriletir
    • range — Belli bir eleman aralığını içeren bir dizi oluşturur
    • reset — Bir dizinin dahili göstericisini ilk elemana konumlar
    • rsort — Bir diziyi tersine sıralar
    • shuffle — Bir diziyi karar
    • sizeof — count işlevinin takma adıdır
    • sort — Bir diziyi sıralar
    • uasort — Bir diziyi kullanıcı tanımlı bir işlev kullanarak indislerine göre sıralarken anahtar/değer ilişkisini korur
    • uksort — Bir diziyi kullanıcı tanımlı bir işlev kullanarak anahtarlarına göre sıralar
    • usort — Bir diziyi kullanıcı tanımlı bir işlev kullanarak değerlerine göre sıralar
Değişkenler ve Veri Türleriyle İlgili Eklentiler
Giriş
Değişkenler ve Veri Türleriyle İlgili Eklentiler


Giriş

Bu işlevler dizilerle çeşitli yollarla etkileşmek ve dizilerde değişiklik yapmak için kullanılır. Diziler esasen değişken kümeleri üzerinde işlemler yapmak, bunları değiştirmek ve saklamak içindir.

Basit ve çok boyutlu diziler desteklenmektedir. Diziler kullanıcı tarafından oluşturulabileceği gibi işlevler tarafından da oluşturulabilir. Dizileri veritabanı sorgularından toplanan verilerle oluşturmak için kullanılan veritabanlarına özgü işlevlerden başka dizi döndüren çeşitli işlevler vardır.

PHP'de dizilerin nasıl gerçeklendiğiyle ilgili ayrıntılı bilgiler için array bölümüne bakınız. Diziler üzerinde nasıl değişiklik yapıldığından ise Dizi işleçleri bölümünde bahsedilmiştir.

Diziler
Yapılandırma/Kurulum
Diziler


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Diziler


Öntanımlı Sabitler

Aşağıdaki sabitler PHP çekirdeğinin parçası olarak daima kullanılabilir durumdadır.

CASE_LOWER (integer)
CASE_LOWER array_change_key_case() işleviyle beraber, dizi anahtarlarının harflerini küçük harflere çevirmek için kullanılır. Bu aynı zamanda array_change_key_case() işlevi için öntanımlı durumdur.
CASE_UPPER (integer)
CASE_UPPER array_change_key_case() işleviyle beraber, dizi anahtarlarının harflerini büyük harflere çevirmek için kullanılır.

Sıralama belirtme seçenekleri:

SORT_ASC (integer)
SORT_ASC array_multisort() işleviyle beraber artan düzende sıralama için kullanılır.
SORT_DESC (integer)
SORT_DESC array_multisort() işleviyle beraber azalan düzende sıralama için kullanılır.

Sıralama türü seçenekleri: çeşitli sıralama işlevleri tarafından kullanılır

SORT_REGULAR (integer)
SORT_REGULAR elemanları normal olarak karşılaştırmak için kullanılınır.
SORT_NUMERIC (integer)
SORT_NUMERIC elemanları sayısal olarak karşılaştırmak için kullanılınır.
SORT_STRING (integer)
SORT_STRING elemanları dizgesel olarak karşılaştırmak için kullanılınır.
SORT_LOCALE_STRING (integer)
SORT_LOCALE_STRING elemanları dizgesel olarak, mevcut yerel sisteme göre karşılaştırmak için kullanılınır. PHP 4.4.0 ve 5.0.2 sürümlerinde eklenmiştir.
SORT_NATURAL (integer)
natsort() işlevinin yaptığı gibi dizgeleri doğal sıramaya göre karşılaştırmak için kullanılır. PHP 5.4.0'da eklendi.
SORT_FLAG_CASE (integer)
SORT_FLAG_CASE dizgeleri harf büyüklüğne duyarlı sıralamak için SORT_STRING veya SORT_NATURAL ile bit seviyesinde veyalanarak kullanılabilir. PHP 5.4.0'da eklendi.

Süzme seçenekleri:

ARRAY_FILTER_USE_KEY (integer)
ARRAY_FILTER_USE_KEY seçeneği array_filter() işleviyle kullanılarak her anahtarı belirtilen geri çağırım işlevine ilk değiştirge olarak aktarmakta kullanılır. PHP 5.6.0'da eklendi.
ARRAY_FILTER_USE_BOTH (integer)
ARRAY_FILTER_USE_BOTH seçeneği array_filter() işlevi ile kullanılarak hem anahtarı hem de değeri belirtilen geri çağırım işlevine aktarmakta kullanılır. PHP 5.6.0'da eklendi.

COUNT_NORMAL (integer)
COUNT_RECURSIVE (integer)
EXTR_OVERWRITE (integer)
EXTR_SKIP (integer)
EXTR_PREFIX_SAME (integer)
EXTR_PREFIX_ALL (integer)
EXTR_PREFIX_INVALID (integer)
EXTR_PREFIX_IF_EXISTS (integer)
EXTR_IF_EXISTS (integer)
EXTR_REFS (integer)
Özkaynak Türleri
Dizilerde Sıralama
Diziler


Dizilerde Sıralama

PHP, dizileri sıralamak için kullanılabilen çeşitli işlevlere sahiptir ve bu belgede bunların kullanımları ele alınmıştır.

Bu işlevler arasındaki başlıca farklar şunlardır:

  • Bazı sıralama işlemleri dizilerin anahtarlarına göre yapılırken bazılarında değerlere göre yapılır: $dizi['anahtar'] = 'değer';
  • Anahtarların sayısal olarak ele alındığı durumda sıralama sonrası anahtarlarla değerleri arasındaki ilişki bozulmuş olabilir de olmayabilir de.
  • Sıralama çeşitleri: abecesel, küçükten büyüğe (artan), büyükten küçüğe (azalan), sayısal, doğal, rasgele, kullanıcı tanımlı
  • Dikkat: Sıralama işlevlerinin hepsi doğrudan dizi üzerinde çalışmazlar; bazıları sonucu başka bir dizide döndürebilir.
  • Bu sıralama işlevlerinin işleme soktuğu üyelerden ikisi birbirine eşitse sıralama istenen sonucu vermeyebilir.

Sıralama işlevleri ve özellikleri
İşlev ismi | Sıralama yeri | Anahtar değer ilişkisi | Sıralama kuralı | İlgili işlevler
array_multisort() | değer | ilişkiselse korunur, sayısalsa korunmaz | ilk dizi veya sıralama seçenekleri | array_walk()
asort() | değer | korunur | küçükten büyüğe | arsort()
arsort() | değer | korunur | büyükten küçüğe | asort()
krsort() | key | korunur | büyükten küçüğe | ksort()
ksort() | key | korunur | küçükten büyüğe | asort()
natcasesort() | değer | korunur | doğal, harf büyüklüğüne duyarsız | natsort()
natsort() | değer | korunur | doğal | natcasesort()
rsort() | değer | korunmaz | büyükten küçüğe | sort()
shuffle() | değer | korunmaz | rasgele | array_rand()
sort() | değer | korunmaz | küçükten büyüğe | rsort()
uasort() | değer | korunur | kullanıcı tanımlı | uksort()
uksort() | key | korunur | kullanıcı tanımlı | uasort()
usort() | değer | korunmaz | kullanıcı tanımlı | uasort()

Öntanımlı Sabitler
Dizi İşlevleri
Diziler


Dizi İşlevleri

Ayrıca Bakınız

Ayrıca bakınız: is_array(),
explode(), implode(),
split(), preg_split() ve
unset().

İçindekiler

  • array_change_key_case — Bir dizideki tüm anahtarların harf büyüklüğünü değiştirir
  • array_chunk — Bir diziyi belli uzunlukta bölümlere ayırır
  • array_column — Return the values from a single column in the input array
  • array_combine — Anahtarlar için bir dizi, değerler için ise başka bir dizi kullanarak bir ilişkisel dizi oluşturur
  • array_count_values — Bir dizideki tüm değerleri sayar
  • array_diff_assoc — Dizilerin farkını hesaplarken ek olarak indisleri de karşılaştırır
  • array_diff_key — Dizilerin farkını hesaplarken indisleri karşılaştırır
  • array_diff_uassoc — Dizilerin farkını hesaplarken ek olarak bir geriçağırım işlevi üzerinden indisleri de karşılaştırır
  • array_diff_ukey — Karşılaştırma için bir geriçağırım işlevi kullanarak dizilerin farkını hesaplar
  • array_diff — Dizilerin farkını hesaplar
  • array_fill_keys — Anahtarları belirtilen diziyi değerlerle doldurur
  • array_fill — Bir diziyi değerlerle doldurur
  • array_filter — Bir dizinin elemanlarını bir geriçağırım işleviyle süzgeçten geçirir
  • array_flip — Bir dizideki anahtarlarla değerleri yer değiştirir
  • array_intersect_assoc — Dizilerin kesişimini hesaplarken ek olarak indisleri de karşılaştırır
  • array_intersect_key — Karşılaştırma için anahtarları kullanarak dizilerin kesişimini hesaplar
  • array_intersect_uassoc — Dizilerin kesişimini hesaplarken ek olarak bir geriçağırım işlevi üzerinden indisleri de karşılaştırır
  • array_intersect_ukey — Anahtarları karşılaştırmak için bir geriçağırım işlevi kullanarak dizilerin kesişimini hesaplar
  • array_intersect — Dizilerin kesişimini hesaplar
  • array_key_exists — Belirtilen anahtar veya indis dizide var mı diye bakar
  • array_keys — Bir dizideki tüm anahtarları veya bir anahtar altkümesini döndürür
  • array_map — Belirtilen dizilerin elemanlarına geriçağırım işlevini uygular
  • array_merge_recursive — İki veya daha fazla sayıda diziyi ardarda ekleyerek yeni bir dizi oluşturur
  • array_merge — Belirtilen dizileri ardarda ekleyerek yeni bir dizi oluşturur
  • array_multisort — Çok sayıda diziyi veya çok boyutlu dizileri sıralar
  • array_pad — Dizi boyutunu belirtilen boyuta çıkarırken, yeni elemanlara belirtilen değeri yerleştirir
  • array_pop — Dizinin sonundaki elemanı diziden çıkartır
  • array_product — Bir dizideki değerlerin çarpımını bulur
  • array_push — Belli sayıda elemanı dizinin sonuna ekler
  • array_rand — Bir diziden belli sayıda rasgele eleman döndürür
  • array_reduce — Bir geriçağırım işlevini dizinin bütün elemanlarına tek tek uygulayıp sonucu döndürür
  • array_replace_recursive — İlk dizinin elemanlarını aktarılan dizilerden ardışık olarak günceller
  • array_replace — İlk dizinin elemanlarını aktarılan dizilerden günceller
  • array_reverse — Diziyi tersine sıralayıp döndürür
  • array_search — Bir dizide belirtilen değeri arar ve bulursa ilgili anahtarı döndürür
  • array_shift — Dizini başlangıcından bir eleman çeker
  • array_slice — Bir dizinin belli bir bölümünü döndürür
  • array_splice — Bir dizinin belli bir bölümünü silip yerine başka şeyler koyar
  • array_sum — Bir dizideki değerlerin toplamını hesaplar
  • array_udiff_assoc — Veri karşılaştırması için bir geriçağırım işlevi kullanarak diziler arasındaki farkı indislerine de bakarak bulur
  • array_udiff_uassoc — Veri ve indis karşılaştırması için bir geriçağırım işlevi kullanarak diziler arasındaki farkı indislerine de bakarak bulur
  • array_udiff — Veri karşılaştırması için bir geriçağırım işlevi kullanarak diziler arasındaki farkı bulur
  • array_uintersect_assoc — Veriyi bir geriçağırım işleviyle karşılaştırarak dizilerin kesişimini hesaplarken ek olarak indislere de bakar
  • array_uintersect_uassoc — Veriyi ve indisleri bir geriçağırım işleviyle karşılaştırarak dizilerin kesişimini hesaplarken ek olarak indislere de bakar
  • array_uintersect — Veriyi bir geriçağırım işleviyle karşılaştırarak dizilerin kesişimini hesaplar
  • array_unique — Diziden yinelenen değerleri siler
  • array_unshift — Bir dizinin başlangıcına bir veya daha fazla eleman ekler
  • array_values — Bir dizinin tüm değerlerini döndürür
  • array_walk_recursive — Bir dizinin ardışık olarak her üyesine kullanıcı tanımlı bir işlevi uygular
  • array_walk — Bir dizinin her üyesine kullanıcı tanımlı bir işlevi uygular
  • array — Bir dizi oluşturur
  • arsort — Bir dizinin değerlerini anahtarlarıyla ilişkilerini bozmadan tersine sıralar
  • asort — Bir dizinin değerlerini anahtarlarıyla ilişkilerini bozmadan sıralar
  • compact — Değişkenlerle değerlerinden oluşan bir dizi oluşturur
  • count — Bir dizideki eleman sayısını veya bir nesnedeki özellik sayısını döndürür
  • current — Bir diziden gösterici konumundaki elemanı döndürür
  • each — Bir diziden, gösterici konumundaki anahtar değer çiftini döndürdükten sonra göstericiyi bir ilerletir
  • end — Bir dizinin dahili göstericisini sonuncu elemana konumlandırır
  • extract — Bir dizideki değişkenleri simge tablosuna dahil eder
  • in_array — Bir dizide bir değerin varlığını araştırır
  • key_exists — Takma Adı: array_key_exists
  • key — Bir diziden gösterici konumundaki anahtarı döndürür
  • krsort — Bir diziyi anahtarlarına göre tersine sıralar
  • ksort — Bir diziyi anahtarlarına göre sıralar
  • list — Değişkenlere bir dizi gibi atama yapar
  • natcasesort — Bir diziyi harf büyüklüğüne duyarsız "doğal sıralama" algoritmasıyla sıralar
  • natsort — Bir diziyi "doğal sıralama" algoritmasıyla sıralar
  • next — Dahili dizi göstericisini bir ilerletir
  • pos — current işlevinin takma adıdır
  • prev — Dahili dizi göstericisini bir geriletir
  • range — Belli bir eleman aralığını içeren bir dizi oluşturur
  • reset — Bir dizinin dahili göstericisini ilk elemana konumlar
  • rsort — Bir diziyi tersine sıralar
  • shuffle — Bir diziyi karar
  • sizeof — count işlevinin takma adıdır
  • sort — Bir diziyi sıralar
  • uasort — Bir diziyi kullanıcı tanımlı bir işlev kullanarak indislerine göre sıralarken anahtar/değer ilişkisini korur
  • uksort — Bir diziyi kullanıcı tanımlı bir işlev kullanarak anahtarlarına göre sıralar
  • usort — Bir diziyi kullanıcı tanımlı bir işlev kullanarak değerlerine göre sıralar
Dizilerde Sıralama
array_change_key_case
Diziler


Bir dizideki tüm anahtarların harf büyüklüğünü değiştirir

Dizi İşlevleri
array_chunk
Dizi İşlevleri
PHP Manual

array_change_key_case

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

array_change_key_case — Bir dizideki tüm anahtarların harf büyüklüğünü değiştirir

Açıklama

array array_change_key_case ( array $dizi [, int $büyüklük = CASE_LOWER ] )

Belirilen dizideki tüm anahtarların harflerini büyük harfe veya küçük harfe dönüştürür. Sayısal indislere dokunulmaz.

Değiştirgeler

dizi

Üzerinde işlem yapılacak dizi.

büyüklük

Büyük harfe dönüşüm için CASE_UPPER, küçük harfe dönüşüm için CASE_LOWER (öntanımlı) belirtilebilir.

Dönen Değerler

Anahtarların büyük harflerden veya küçük harflerden oluştuğu bir dizi döner. Eğer belirtilen dizi bir dizi değilse FALSE döner.

Hatalar/İstisnalar

Eğer belirtilen dizi bir dizi değilse bir E_WARNING oluşur.

Örnekler

Örnek 1 - array_change_key_case() örneği

<?php
$input_array = array("FirSt" => 1, "SecOnd" => 4);
print_r(array_change_key_case($input_array, CASE_UPPER));
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [FIRST] => 1
    [SECOND] => 4
)

Notlar

Bilginize:

Eğer dönüşüm sonunda aynı anahtarlara sahip olan elemanlar varsa ("keY" ve "kEY" gibi) sonraki elemanın değeri öncekinin üzerine yazar..

Dizi İşlevleri
array_chunk
Dizi İşlevleri


Bir diziyi belli uzunlukta bölümlere ayırır

array_change_key_case
array_column
Dizi İşlevleri
PHP Manual

array_chunk

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

array_chunk — Bir diziyi belli uzunlukta bölümlere ayırır

Açıklama

array array_chunk ( array $dizi , int $boyut [, bool $anahtarları_koru = false ] )

Belirtilen diziyi boyut elemanlı dizilere böler. Son parça boyut elemandan daha az eleman içerebilir.

Değiştirgeler

dizi

Parçalanacak dizi.

boyut

Her parçanın uzunluğu.

anahtarları_koru

TRUE ise anahtarlar korunur. FALSE öntanımlı olup parçalar sayısal olarak yeniden indislenir.

Dönen Değerler

Her biri sıfır indisiyle başlayan boyut elemanlı dizilerden oluşan sayısal indisli çok boyutlu bir dizi döner.

Hatalar/İstisnalar

Eğer boyut 1'den küçükse bir E_WARNING oluşur ve NULL döner.

Örnekler

Örnek 1 - array_chunk() örneği

<?php
$input_array = array('a', 'b', 'c', 'd', 'e');
print_r(array_chunk($input_array, 2));
print_r(array_chunk($input_array, 2, true));
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [0] => Array
        (
            [0] => a
            [1] => b
        )

    [1] => Array
        (
            [0] => c
            [1] => d
        )

    [2] => Array
        (
            [0] => e
        )

)
Array
(
    [0] => Array
        (
            [0] => a
            [1] => b
        )

    [1] => Array
        (
            [2] => c
            [3] => d
        )

    [2] => Array
        (
            [4] => e
        )

)

Ayrıca Bakınız

  • array_slice() - Bir dizinin belli bir bölümünü döndürür

array_change_key_case
array_column
Dizi İşlevleri


Return the values from a single column in the input array

array_chunk
array_combine
Dizi İşlevleri
PHP Manual

array_column

(PHP 5 >= 5.5.0, PHP 7)

array_column — Return the values from a single column in the input array

Açıklama

array array_column ( array $input , mixed $column_key [, mixed $index_key = null ] )

array_column() returns the values from a single column of the input, identified by the column_key. Optionally, an index_key may be provided to index the values in the returned array by the values from the index_key column of the input array.

Değiştirgeler

input

A multi-dimensional array or an array of objects from which to pull a column of values from. If an array of objects is provided, then public properties can be directly pulled. In order for protected or private properties to be pulled, the class must implement both the __get() and __isset() magic methods.

column_key

The column of values to return. This value may be an integer key of the column you wish to retrieve, or it may be a string key name for an associative array or property name. It may also be NULL to return complete arrays or objects (this is useful together with index_key to reindex the array).

index_key

The column to use as the index/keys for the returned array. This value may be the integer key of the column, or it may be the string key name.

Dönen Değerler

Returns an array of values representing a single column from the input array.

Sürüm Bilgisi

Sürüm: | Açıklama
7.0.0 | Added the ability for the input parameter to be an array of objects.

Örnekler

Örnek 1 Get the column of first names from a recordset

<?php
// Array representing a possible record set returned from a database
$records = array(
    array(
        'id' => 2135,
        'first_name' => 'John',
        'last_name' => 'Doe',
    ),
    array(
        'id' => 3245,
        'first_name' => 'Sally',
        'last_name' => 'Smith',
    ),
    array(
        'id' => 5342,
        'first_name' => 'Jane',
        'last_name' => 'Jones',
    ),
    array(
        'id' => 5623,
        'first_name' => 'Peter',
        'last_name' => 'Doe',
    )
);

$first_names = array_column($records, 'first_name');
print_r($first_names);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [0] => John
    [1] => Sally
    [2] => Jane
    [3] => Peter
)

Örnek 2 Get the column of last names from a recordset, indexed by the "id" column

<?php
// Using the $records array from Example #1
$last_names = array_column($records, 'last_name', 'id');
print_r($last_names);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [2135] => Doe
    [3245] => Smith
    [5342] => Jones
    [5623] => Doe
)

Örnek 3 Get the column of usernames from the public "username" property of an object

<?php

class User
{
    public $username;

    public function __construct(string $username)
    {
        $this->username = $username;
    }
}

$users = [
    new User('user 1'),
    new User('user 2'),
    new User('user 3'),
];

print_r(array_column($users, 'username'));
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [0] => user 1
    [1] => user 2
    [2] => user 3
)

Örnek 4 Get the column of names from the private "name" property of an object using the magic __get() method.

<?php

class Person
{
    private $name;

    public function __construct(string $name)
    {
        $this->name = $name;
    }

    public function __get($prop)
    {
        return $this->$prop;
    }

    public function __isset($prop) : bool
    {
        return isset($this->$prop);
    }
}

$people = [
    new Person('Fred'),
    new Person('Jane'),
    new Person('John'),
];

print_r(array_column($people, 'name'));
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [0] => Fred
    [1] => Jane
    [2] => John
)
If __isset() is not provided, then an empty array will be returned.

Ayrıca Bakınız

  • » Recommended userland implementation for PHP lower than 5.5

array_chunk
array_combine
Dizi İşlevleri


Anahtarlar için bir dizi, değerler için ise başka bir dizi kullanarak bir ilişkisel dizi oluşturur

array_column
array_count_values
Dizi İşlevleri
PHP Manual

array_combine

(PHP 5, PHP 7)

array_combine — Anahtarlar için bir dizi, değerler için ise başka bir dizi kullanarak bir ilişkisel dizi oluşturur

Açıklama

array array_combine ( array $anahtarlar , array $değerler )

anahtarlar dizisinden anahtarları, değerler dizisinden değerleri alıp oluşturduğu ilişkisel diziyi döndürür.

Değiştirgeler

anahtarlar

Anahtar olarak kullanılacak elemanları içeren dizi. Anahtar olarak geçersiz değerler string türüne dönüştürülür.

değerler

Değer olarak kullanılacak elemanları içeren dizi.

Dönen Değerler

Dizilerdeki eleman sayısı aynı değilse FALSE, aksi takdirde oluşturulan ilişkisel dizi döner.

Hatalar/İstisnalar

anahtarlar ve değerler Dizilerindeki eleman sayısı aynı değilse bir E_WARNING oluşur.

Sürüm Bilgisi

Sürüm: | Açıklama
5.4.0 | Önceki sürümler boş dizilerde için FALSE döndürür ve bir E_WARNINGoluştururdu.

Örnekler

Örnek 1 - array_combine() örneği

<?php
$a = array('green', 'red', 'yellow');
$b = array('avocado', 'apple', 'banana');
$c = array_combine($a, $b);

print_r($c);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [green]  => avocado
    [red]    => apple
    [yellow] => banana
)

Ayrıca Bakınız

  • array_merge() - Belirtilen dizileri ardarda ekleyerek yeni bir dizi oluşturur
  • array_walk() - Bir dizinin her üyesine kullanıcı tanımlı bir işlevi uygular
  • array_values() - Bir dizinin tüm değerlerini döndürür

array_column
array_count_values
Dizi İşlevleri


Bir dizideki tüm değerleri sayar

array_combine
array_diff_assoc
Dizi İşlevleri
PHP Manual

array_count_values

(PHP 4, PHP 5, PHP 7)

array_count_values — Bir dizideki tüm değerleri sayar

Açıklama

array array_count_values ( array $dizi )

array_count_values() işlevi dizi dizisindeki değerleri anahtar olarak ve dizi dizisinde bu değerlere rastlanma sıklığını değer olarak içeren bir dizi ile döner.

Değiştirgeler

dizi

Değerleri sayılacak dizi.

Dönen Değerler

dizi dizisindeki değerlerin anahtarları, değerlerin sayısının ise değerleri oluşturduğu bir ilişkisel dizi döner.

Hatalar/İstisnalar

string veya integer türünde olmayan her eleman için bir E_WARNING oluşur.

Örnekler

Örnek 1 - array_count_values() örneği

<?php
$array = array(1, "hello", 1, "world", "hello");
print_r(array_count_values($array));
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [1] => 2
    [hello] => 2
    [world] => 1
)

Ayrıca Bakınız

  • count() - Bir dizideki eleman sayısını veya bir nesnedeki özellik sayısını döndürür
  • array_unique() - Diziden yinelenen değerleri siler
  • array_values() - Bir dizinin tüm değerlerini döndürür
  • count_chars() - Bir dizgedeki karakterler hakkında bilgi döndürür

array_combine
array_diff_assoc
Dizi İşlevleri


Dizilerin farkını hesaplarken ek olarak indisleri de karşılaştırır

array_count_values
array_diff_key
Dizi İşlevleri
PHP Manual

array_diff_assoc

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

array_diff_assoc — Dizilerin farkını hesaplarken ek olarak indisleri de karşılaştırır

Açıklama

array array_diff_assoc ( array $dizi1 , array $dizi2 [, array $... ] )

dizi1 ile dizi2'yi karşılaştırır ve farkı döndürür. Değerler yerine anahtarları karşılaştırması dışında array_diff() işlevi gibidir.

Değiştirgeler

dizi1

Karşılaştırılacak dizi.

dizi2

Karşılaştırılacak diğer dizi.

...

Karşılaştırılacak diğer diziler.

Dönen Değerler

Diğer tüm değiştirgelerde mevcut olmayan dizi1 girdilerinden oluşan bir dizi döner.

Örnekler

Örnek 1 - array_diff_assoc() örneği - 1

"a" => "green" çifti her iki dizide de mevcut olduğundan bu eleman çıktıda bulunmaz. 0 => "red" çifti ise aksine, ikinci "red" değeri 1 anahtarına sahip olduğundan çıktıda bulunur.

<?php
$dizi1 = array("a" => "green", "b" => "brown", "c" => "blue", "red");
$dizi2 = array("a" => "green", "yellow", "red");
$sonuc = array_diff_assoc($dizi1, $dizi2);
print_r($sonuc);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [b] => brown
    [c] => blue
    [0] => red
)

Örnek 2 - array_diff_assoc() örneği - 2

İki elemanın eşit olması için sadece ve sadece (string) $elem1 === (string) $elem2 olmalıdır. Başka bir deyişle, dizgesel gösterimler aynı olmalıdır.

<?php
$array1 = array(0, 1, 2);
$array2 = array("00", "01", "2");
$result = array_diff_assoc($array1, $array2);
print_r($result);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [0] => 0
    [1] => 1
    )

Notlar

Bilginize: Bu işlev n boyutlu bir dizinin sadece bir boyutunu karşılaştırır. Daha derinliğine karşılaştırmalar yapmak için array_diff_assoc($dizi1[0], $dizi2[0]); sözdizimini kullanabilirsiniz.

Bilginize: Çok fazla anahtara sahip benzer dizileri karşılaştırırken değiştirgeleri doğru sırada vermeye dikkat edin. Yeni dizi listedeki ilk dizi olmalıdır.

Ayrıca Bakınız

  • array_diff() - Dizilerin farkını hesaplar
  • array_intersect() - Dizilerin kesişimini hesaplar
  • array_intersect_assoc() - Dizilerin kesişimini hesaplarken ek olarak indisleri de karşılaştırır

array_count_values
array_diff_key
Dizi İşlevleri


Dizilerin farkını hesaplarken indisleri karşılaştırır

array_diff_assoc
array_diff_uassoc
Dizi İşlevleri
PHP Manual

array_diff_key

(PHP 5 >= 5.1.0, PHP 7)

array_diff_key — Dizilerin farkını hesaplarken indisleri karşılaştırır

Açıklama

array array_diff_key ( array $dizi1 , array $dizi2 [, array $... ] )

dizi1 ile dizi2'yi karşılaştırır ve farkı döndürür. Değerler yerine anahtarları karşılaştırması dışında array_diff() işlevi gibidir.

Değiştirgeler

dizi1

Karşılaştırılacak dizi.

dizi2

Karşılaştırılacak diğer dizi.

...

Karşılaştırılacak diğer diziler.

Dönen Değerler

Diğer tüm değiştirgelerde mevcut olmayan dizi1 anahtarlarından oluşan bir dizi döner.

Örnekler

Örnek 1 - array_diff_key() örneği

İki anahtarın eşit olması için sadece ve sadece (string) $anahtar1 === (string) $anahtar2 olmalıdır. Başka bir deyişle, anahtarların dizgesel gösterimleri aynı olmalıdır.

<?php
$array1 = array('blue'  => 1, 'red'  => 2, 'green'  => 3, 'purple' => 4);
$array2 = array('green' => 5, 'blue' => 6, 'yellow' => 7, 'cyan'   => 8);

var_dump(array_diff_key($array1, $array2));
?>

Yukarıdaki örneğin çıktısı:

array(2) {
  ["red"]=>
  int(2)
  ["purple"]=>
  int(4)
}

Notlar

Bilginize:

Bu işlev n boyutlu bir dizinin sadece bir boyutunu karşılaştırır. Daha derinliğine karşılaştırmalar yapmak için array_diff_key($dizi1[0], $dizi2[0]); sözdizimini kullanabilirsiniz.

Ayrıca Bakınız

  • array_diff() - Dizilerin farkını hesaplar
  • array_udiff() - Veri karşılaştırması için bir geriçağırım işlevi kullanarak diziler arasındaki farkı bulur
  • array_diff_assoc() - Dizilerin farkını hesaplarken ek olarak indisleri de karşılaştırır
  • array_diff_uassoc() - Dizilerin farkını hesaplarken ek olarak bir geriçağırım işlevi üzerinden indisleri de karşılaştırır
  • array_udiff_assoc() - Veri karşılaştırması için bir geriçağırım işlevi kullanarak diziler arasındaki farkı indislerine de bakarak bulur
  • array_udiff_uassoc() - Veri ve indis karşılaştırması için bir geriçağırım işlevi kullanarak diziler arasındaki farkı indislerine de bakarak bulur
  • array_diff_ukey() - Karşılaştırma için bir geriçağırım işlevi kullanarak dizilerin farkını hesaplar
  • array_intersect() - Dizilerin kesişimini hesaplar
  • array_intersect_assoc() - Dizilerin kesişimini hesaplarken ek olarak indisleri de karşılaştırır
  • array_intersect_uassoc() - Dizilerin kesişimini hesaplarken ek olarak bir geriçağırım işlevi üzerinden indisleri de karşılaştırır
  • array_intersect_key() - Karşılaştırma için anahtarları kullanarak dizilerin kesişimini hesaplar
  • array_intersect_ukey() - Anahtarları karşılaştırmak için bir geriçağırım işlevi kullanarak dizilerin kesişimini hesaplar

array_diff_assoc
array_diff_uassoc
Dizi İşlevleri


Dizilerin farkını hesaplarken ek olarak bir geriçağırım işlevi üzerinden indisleri de karşılaştırır

array_diff_key
array_diff_ukey
Dizi İşlevleri
PHP Manual

array_diff_uassoc

(PHP 5, PHP 7)

array_diff_uassoc — Dizilerin farkını hesaplarken ek olarak bir geriçağırım işlevi üzerinden indisleri de karşılaştırır

Açıklama

array array_diff_uassoc ( array $dizi1 , array $dizi2 [, array $... ], callable $anh_karş_işlevi )

dizi1 ile dizi2'yi karşılaştırır ve farkı döndürür. Değerler yerine anahtarları karşılaştırması dışında array_diff() işlevi gibidir.

array_diff_assoc() işlevinden farklı olarak anahtarları karşılaştırmak için bir dahili işlev değil, kullanıcı tanımlı bir geriçağırım işlevi kullanılır.

Değiştirgeler

dizi1

Karşılaştırılacak dizi.

dizi2

Karşılaştırılacak diğer dizi.

...

Karşılaştırılacak diğer diziler.

anh_karş_işlevi

Karşılaştırma işlevinin, ilk bileşeninin ikinci bileşenden küçük, eşit veya büyük olması durumunda sıfırdan küçük, eşit veya büyük bir tamsayı döndürmesi gerekir.

int callback ( mixed $a, mixed $b )

Dönen Değerler

Diğer tüm değiştirgelerde mevcut olmayan dizi1 girdilerinden oluşan bir dizi döner.

Örnekler

Örnek 1 - array_diff_uassoc() örneği

"a" => "green" çifti her iki dizide de mevcut olduğundan bu eleman çıktıda bulunmaz. 0 => "red" çifti ise aksine, ikinci "red" değeri 1 anahtarına sahip olduğundan çıktıda bulunur.

<?php
function anh_karş_işlevi($a, $b)
{
    if ($a === $b) {
        return 0;
    }
    return ($a > $b)? 1:-1;
}

$dizi1 = array("a" => "green", "b" => "brown", "c" => "blue", "red");
$dizi2 = array("a" => "green", "yellow", "red");
$result = array_diff_uassoc($dizi1, $dizi2, "anh_karş_işlevi");
print_r($result);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [b] => brown
    [c] => blue
    [0] => red
)

İki indisin eşitliğine kullanıcı tarafından sağlanmış geriçağırım işlevi tarafından bakılır.

Notlar

Bilginize:

Bu işlev n boyutlu bir dizinin sadece bir boyutunu karşılaştırır. Daha derinliğine karşılaştırmalar yapmak için array_diff_uassoc($dizi1[0], $dizi2[0], 'anh_kars_islevi'); sözdizimini kullanabilirsiniz.

Ayrıca Bakınız

  • array_diff() - Dizilerin farkını hesaplar
  • array_diff_assoc() - Dizilerin farkını hesaplarken ek olarak indisleri de karşılaştırır
  • array_udiff() - Veri karşılaştırması için bir geriçağırım işlevi kullanarak diziler arasındaki farkı bulur
  • array_udiff_assoc() - Veri karşılaştırması için bir geriçağırım işlevi kullanarak diziler arasındaki farkı indislerine de bakarak bulur
  • array_udiff_uassoc() - Veri ve indis karşılaştırması için bir geriçağırım işlevi kullanarak diziler arasındaki farkı indislerine de bakarak bulur
  • array_intersect() - Dizilerin kesişimini hesaplar
  • array_intersect_assoc() - Dizilerin kesişimini hesaplarken ek olarak indisleri de karşılaştırır
  • array_uintersect() - Veriyi bir geriçağırım işleviyle karşılaştırarak dizilerin kesişimini hesaplar
  • array_uintersect_assoc() - Veriyi bir geriçağırım işleviyle karşılaştırarak dizilerin kesişimini hesaplarken ek olarak indislere de bakar
  • array_uintersect_uassoc() - Veriyi ve indisleri bir geriçağırım işleviyle karşılaştırarak dizilerin kesişimini hesaplarken ek olarak indislere de bakar

array_diff_key
array_diff_ukey
Dizi İşlevleri


Karşılaştırma için bir geriçağırım işlevi kullanarak dizilerin farkını hesaplar

array_diff_uassoc
array_diff
Dizi İşlevleri
PHP Manual

array_diff_ukey

(PHP 5 >= 5.1.0, PHP 7)

array_diff_ukey — Karşılaştırma için bir geriçağırım işlevi kullanarak dizilerin farkını hesaplar

Açıklama

array array_diff_ukey ( array $dizi1 , array $dizi2 [, array $ ... ], callable $anh_karş_işlevi )

dizi1 ile dizi2'yi karşılaştırır ve farkı döndürür. Değerler yerine anahtarları karşılaştırması dışında array_diff() işlevi gibidir.

array_diff_key() işlevinden farklı olarak anahtarları karşılaştırmak için bir dahili işlev değil, kullanıcı tanımlı bir geriçağırım işlevi kullanılır.

Değiştirgeler

dizi1

Karşılaştırılacak dizi.

dizi2

Karşılaştırılacak diğer dizi.

...

Karşılaştırılacak diğer diziler.

anh_karş_işlevi

Karşılaştırma işlevinin, ilk bileşeninin ikinci bileşenden küçük, eşit veya büyük olması durumunda sıfırdan küçük, eşit veya büyük bir tamsayı döndürmesi gerekir.

int callback ( mixed $a, mixed $b )

Dönen Değerler

Diğer tüm değiştirgelerde mevcut olmayan dizi1 girdilerinden oluşan bir dizi döner.

Örnekler

Örnek 1 - array_diff_ukey() örneği

<?php
function anh_kars_islevi($a1, $a2)
{
    if ($a1 == $a2)
        return 0;
    else if ($a1 > $a2)
        return 1;
    else
        return -1;
}

$dizi1 = array('blue'  => 1, 'red'  => 2, 'green'  => 3, 'purple' => 4);
$dizi2 = array('green' => 5, 'blue' => 6, 'yellow' => 7, 'cyan'   => 8);

var_dump(array_diff_ukey($dizi1, $dizi2, 'anh_kars_islevi'));
?>

Yukarıdaki örneğin çıktısı:

array(2) {
  ["red"]=>
  int(2)
  ["purple"]=>
  int(4)
}

Notlar

Bilginize:

Bu işlev n boyutlu bir dizinin sadece bir boyutunu karşılaştırır. Daha derinliğine karşılaştırmalar yapmak için array_diff_ukey($dizi1[0], $dizi2[0], 'anh_kars_islevi'); sözdizimini kullanabilirsiniz.

Ayrıca Bakınız

  • array_diff() - Dizilerin farkını hesaplar
  • array_udiff() - Veri karşılaştırması için bir geriçağırım işlevi kullanarak diziler arasındaki farkı bulur
  • array_diff_assoc() - Dizilerin farkını hesaplarken ek olarak indisleri de karşılaştırır
  • array_diff_uassoc() - Dizilerin farkını hesaplarken ek olarak bir geriçağırım işlevi üzerinden indisleri de karşılaştırır
  • array_udiff_assoc() - Veri karşılaştırması için bir geriçağırım işlevi kullanarak diziler arasındaki farkı indislerine de bakarak bulur
  • array_udiff_uassoc() - Veri ve indis karşılaştırması için bir geriçağırım işlevi kullanarak diziler arasındaki farkı indislerine de bakarak bulur
  • array_diff_key() - Dizilerin farkını hesaplarken indisleri karşılaştırır
  • array_intersect() - Dizilerin kesişimini hesaplar
  • array_intersect_assoc() - Dizilerin kesişimini hesaplarken ek olarak indisleri de karşılaştırır
  • array_intersect_uassoc() - Dizilerin kesişimini hesaplarken ek olarak bir geriçağırım işlevi üzerinden indisleri de karşılaştırır
  • array_intersect_key() - Karşılaştırma için anahtarları kullanarak dizilerin kesişimini hesaplar
  • array_intersect_ukey() - Anahtarları karşılaştırmak için bir geriçağırım işlevi kullanarak dizilerin kesişimini hesaplar

array_diff_uassoc
array_diff
Dizi İşlevleri


Dizilerin farkını hesaplar

array_diff_ukey
array_fill_keys
Dizi İşlevleri
PHP Manual

array_diff

(PHP 4 >= 4.0.1, PHP 5, PHP 7)

array_diff — Dizilerin farkını hesaplar

Açıklama

array array_diff ( array $dizi1 , array $dizi2 [, array $ ... ] )

dizi1 ile bir veya daha fazla diziyi karşılaştırır ve diğer dizilerde bulunmayan değerleri dizi1 içinde döndürür.

Değiştirgeler

dizi1

Karşılaştırılacak dizi.

dizi2

Karşılaştırılacak diğer dizi.

...

Karşılaştırılacak diğer diziler.

Dönen Değerler

Diğer tüm değiştirgelerde mevcut olmayan dizi1 girdilerinden oluşan bir dizi döner.

Örnekler

Örnek 1 - array_diff() örneği

<?php
$dizi1 = array("a" => "green", "red", "blue", "red");
$dizi2 = array("b" => "green", "yellow", "red");
$result = array_diff($dizi1, $dizi2);

print_r($result);
?>

$dizi1 içinde aynı değerde birden fazla eleman varsa hepsi tek bir girdi kabul edilir ve çıktı şöyle olur:

Array
(
    [1] => blue
)

Notlar

Bilginize:

İki elemanın eşit olması için sadece ve sadece (string) $elem1 === (string) $elem2 olmalıdır. Başka bir deyişle, dizgesel gösterimler aynı olmalıdır.

Bilginize:

Bu işlev n boyutlu bir dizinin sadece bir boyutunu karşılaştırır. Daha derinliğine karşılaştırmalar yapmak için array_diff($dizi1[0], $dizi2[0]); sözdizimini kullanabilirsiniz.

Ayrıca Bakınız

  • array_diff_assoc() - Dizilerin farkını hesaplarken ek olarak indisleri de karşılaştırır
  • array_intersect() - Dizilerin kesişimini hesaplar
  • array_intersect_assoc() - Dizilerin kesişimini hesaplarken ek olarak indisleri de karşılaştırır

array_diff_ukey
array_fill_keys
Dizi İşlevleri


Anahtarları belirtilen diziyi değerlerle doldurur

array_diff
array_fill
Dizi İşlevleri
PHP Manual

array_fill_keys

(PHP 5 >= 5.2.0, PHP 7)

array_fill_keys — Anahtarları belirtilen diziyi değerlerle doldurur

Açıklama

array array_fill_keys ( array $anahtarlar , mixed $dolgu )

anahtarlar dizisindeki elemanlara değer olarak dolgu değerini yerleştirir.

Değiştirgeler

anahtarlar

Değerleri anahtar olarak kullanılacak dizi. Anahtar olarak geçersiz değerler string türüne dönüştürülür.

dolgu

Dolgu için kullanılacak değer.

Dönen Değerler

Doldurulmuş dizi döner.

Örnekler

Örnek 1 - array_fill_keys() örneği

<?php
$anahtarlar = array('foo', 5, 10, 'bar');
$a = array_fill_keys($anahtarlar, 'banana');
print_r($a);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [foo] => banana
    [5] => banana
    [10] => banana
    [bar] => banana
)

Ayrıca Bakınız

  • array_fill() - Bir diziyi değerlerle doldurur
  • array_combine() - Anahtarlar için bir dizi, değerler için ise başka bir dizi kullanarak bir ilişkisel dizi oluşturur

array_diff
array_fill
Dizi İşlevleri


Bir diziyi değerlerle doldurur

array_fill_keys
array_filter
Dizi İşlevleri
PHP Manual

array_fill

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

array_fill — Bir diziyi değerlerle doldurur

Açıklama

array array_fill ( int $başlangıç , int $miktar , mixed $dolgu )

başlangıç değiştirgesi ile belirtilen anahtardan başlayarak miktar sayıda elemana dolgu değerini yerleştirir.

Değiştirgeler

başlangıç

Döndürülecek dizinin ilk indisi. Sadece negatif olmayan indisler desteklenmektedir.

başlangıç negatifse, dönen dizinin ilk indisi başlangıç olacak sonrakiler ise sıfırdan başlayacaktır. (örneğe bakın).

miktar

Diziye yerleştirilecek eleman sayısı. Sıfırdan büyük olmalıdır.

dolgu

Dolgu için kullanılacak değer.

Dönen Değerler

Doldurulmuş diziyi döndürür.

Hatalar/İstisnalar

miktar olarak birden küçük bir değer belirtilirse bir E_WARNING oluşur.

Örnekler

Örnek 1 - array_fill() örneği

<?php
$a = array_fill(5, 6, 'banana');
$b = array_fill(-2, 4, 'pear');
print_r($a);
print_r($b);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [5]  => banana
    [6]  => banana
    [7]  => banana
    [8]  => banana
    [9]  => banana
    [10] => banana
)
Array
(
    [-2] => pear
    [0] => pear
    [1] => pear
    [2] => pear
)

Notlar

Negatif anahtarlarla ilgili ayrıntılı bilgi edinmek için array bölümüne bakınız.

Ayrıca Bakınız

  • array_fill_keys() - Anahtarları belirtilen diziyi değerlerle doldurur
  • str_repeat() - Bir dizgeyi yineler
  • range() - Belli bir eleman aralığını içeren bir dizi oluşturur

array_fill_keys
array_filter
Dizi İşlevleri


Bir dizinin elemanlarını bir geriçağırım işleviyle süzgeçten geçirir

array_fill
array_flip
Dizi İşlevleri
PHP Manual

array_filter

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

array_filter — Bir dizinin elemanlarını bir geriçağırım işleviyle süzgeçten geçirir

Açıklama

array array_filter ( array $dizi [, callable $işlev [, int $seçenek = 0 ]] )

dizi dizisinin her elemanını sırayla işlev işlevine aktarır. Eğer işlev TRUE dönerse o dizi elemanı sonuç dizisine konur, yoksa konmaz. Dizideki anahtarlar korunur.

Değiştirgeler

dizi

Elemanları tek tek işleve aktarılacak dizi.

işlev

Kullanılacak geriçağırım işlevi.

Bu değiştirgede bir geriçağırım işlevi belirtilmezse, boolean türüne dönüşüm yapıldığında FALSE döndüren elemanlar süzülür.

seçenek

işlev işlevine hangi değiştirgelerin gönderileceğini belirler:

  • ARRAY_FILTER_USE_KEY - işlev işlevine tek değiştirge olarak değer değil anahtar aktarılır.
  • ARRAY_FILTER_USE_BOTH - işlev işlevine değiştirge olarak sadece değer değil anahtar da aktarılır.

Dönen Değerler

Süzülen dizi döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.6.0 | Seçimlik seçenek değiştirgesi ve ARRAY_FILTER_USE_KEY ile ARRAY_FILTER_USE_BOTH sabiti eklendi.

Örnekler

Örnek 1 - array_filter() örneği

<?php
function tek($var)
{
   //tamsayı girdi tek sayı mı diye bakar
    return($var & 1);
}

function cift($var)
{
   //tamsayı girdi çift sayı mı diye bakar
    return(!($var & 1));
}

$array1 = array("a"=>1, "b"=>2, "c"=>3, "d"=>4, "e"=>5);
$array2 = array(6, 7, 8, 9, 10, 11, 12);

echo " Tek:\n";
print_r(array_filter($array1, "tek"));
echo "Çift:\n";
print_r(array_filter($array2, "cift"));
?>

Yukarıdaki örneğin çıktısı:

 Tek:
Array
(
    [a] => 1
    [c] => 3
    [e] => 5
)
Çift:
Array
(
    [0] => 6
    [2] => 8
    [4] => 10
    [6] => 12
)

Örnek 2 - işlevsiz array_filter() örneği

<?php

$girdi = array(
             0 => 'foo',
             1 => false,
             2 => -1,
             3 => null,
             4 => ''
          );

print_r(array_filter($girdi));
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [0] => foo
    [2] => -1
)

Örnek 3 array_filter() ile seçenek kullanımı

<?php

$arr = ['a' => 1, 'b' => 2, 'c' => 3, 'd' => 4];

var_dump(array_filter($arr, function($k) {
    return $k == 'b';
}, ARRAY_FILTER_USE_KEY));

var_dump(array_filter($arr, function($v, $k) {
    return $k == 'b' || $v == 4;
}, ARRAY_FILTER_USE_BOTH));
?>

Yukarıdaki örneğin çıktısı:

array(1) {
  ["b"]=>
  int(2)
}
array(2) {
  ["b"]=>
  int(2)
  ["d"]=>
  int(4)
}

Notlar

Dikkat

Eğer geriçağırım işlevinde dizi değişikliğe uğrarsa (yani, elemen ekleme, silme, tanımsız yapma gibi işlemler) bu işlevin davranışı belirsizdir.

Ayrıca Bakınız

  • array_map() - Belirtilen dizilerin elemanlarına geriçağırım işlevini uygular
  • array_reduce() - Bir geriçağırım işlevini dizinin bütün elemanlarına tek tek uygulayıp sonucu döndürür
  • array_walk() - Bir dizinin her üyesine kullanıcı tanımlı bir işlevi uygular

array_fill
array_flip
Dizi İşlevleri


Bir dizideki anahtarlarla değerleri yer değiştirir

array_filter
array_intersect_assoc
Dizi İşlevleri
PHP Manual

array_flip

(PHP 4, PHP 5, PHP 7)

array_flip — Bir dizideki anahtarlarla değerleri yer değiştirir

Açıklama

array array_flip ( array $dizi )

array_flip() işlevi belirtilen dizinin anahtarlarını değer, değerlerini anahtar olarak içeren bir dizi döndürür.

Belirtilen dizi içindeki değerlerin anahtar olarak geçerli olmaları gerekir, yani ya integer ya da string türünde olmaları gerekir. Değerlerden birinin türü bu türlerden biri değilse bir uyarı verilir ve bu anahtar/değer çifti dönen dizide bulunmaz.

Bir değer birden fazla elemanda varsa değer olarak sonuncusunun anahtarı kullanılır, diğerlerinin anahtarları kaybedilmiş olur.

Değiştirgeler

dizi

Anahtarları ile değerleri yer değiştirilecek dizi.

Dönen Değerler

Bir hata oluşmuşsa NULL, aksi takdirde belirtilen dizinin anahtarlarını değer, değerlerini anahtar olarak içeren bir dizi döndürür.

Örnekler

Örnek 1 - array_flip() örneği

<?php
$trans = array_flip($trans);
$original = strtr($str, $trans);
?>

Örnek 2 - Kayıplı array_flip() örneği

<?php
$trans = array("a" => 1, "b" => 1, "c" => 2);
$trans = array_flip($trans);
print_r($trans);
?>

$trans dizisi şöyle olur:

Array
(
    [1] => b
    [2] => c
)

Ayrıca Bakınız

  • array_values() - Bir dizinin tüm değerlerini döndürür
  • array_keys() - Bir dizideki tüm anahtarları veya bir anahtar altkümesini döndürür
  • array_reverse() - Diziyi tersine sıralayıp döndürür

array_filter
array_intersect_assoc
Dizi İşlevleri


Dizilerin kesişimini hesaplarken ek olarak indisleri de karşılaştırır

array_flip
array_intersect_key
Dizi İşlevleri
PHP Manual

array_intersect_assoc

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

array_intersect_assoc — Dizilerin kesişimini hesaplarken ek olarak indisleri de karşılaştırır

Açıklama

array array_intersect_assoc ( array $dizi1 , array $dizi2 [, array $ ... ] )

array_intersect_assoc() işlevi tüm değiştirgelerinde mevcut olan dizi1 değerlerini içeren bir dizi döndürür. array_intersect() işlevinin aksine karşılaştırmada anahtarların kullanıldığına dikkat ediniz.

Değiştirgeler

dizi1

Diğer dizilerin karşılaştırılacağı ilk dizi.

dizi2

Değerleri ilk dizi ile karşılaştırılacak dizi.

...

Değerleri ilk dizi ile karşılaştırılacak diğer dizilerin değişkenlerinin listesi.

Dönen Değerler

Tüm değiştirgelerde mevcut dizi1 değerlerini içeren bir dizi döndürür.

Örnekler

Örnek 1 - array_intersect_assoc() örneği

<?php
$array1 = array("a" => "green", "b" => "brown", "c" => "blue", "red");
$array2 = array("a" => "green", "b" => "yellow", "blue", "red");
$result_array = array_intersect_assoc($array1, $array2);
print_r($result_array);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [a] => green
)

Örnekte gördüğünüz gibi her iki dizide de sadece "a" => "green" ortak olduğundan dönen dizi sadece bu elemanı içermektedir. "red" değerinin döndürülmeme sebebi birinci dizide indisi 0 iken ikinci dizide 1 olmasıdır. "b" değerinin döndürülmeme sebebi de değerinin her dizide farklı olmasıdır.

İki elemanın eşit olması için sadece ve sadece (string) $elem1 === (string) $elem2 olmalıdır. Başka bir deyişle, elemanların dizgesel gösterimleri aynı olmalıdır.

Ayrıca Bakınız

  • array_intersect() - Dizilerin kesişimini hesaplar
  • array_uintersect_assoc() - Veriyi bir geriçağırım işleviyle karşılaştırarak dizilerin kesişimini hesaplarken ek olarak indislere de bakar
  • array_intersect_uassoc() - Dizilerin kesişimini hesaplarken ek olarak bir geriçağırım işlevi üzerinden indisleri de karşılaştırır
  • array_uintersect_uassoc() - Veriyi ve indisleri bir geriçağırım işleviyle karşılaştırarak dizilerin kesişimini hesaplarken ek olarak indislere de bakar
  • array_diff() - Dizilerin farkını hesaplar
  • array_diff_assoc() - Dizilerin farkını hesaplarken ek olarak indisleri de karşılaştırır
array_flip
array_intersect_key
Dizi İşlevleri


Karşılaştırma için anahtarları kullanarak dizilerin kesişimini hesaplar

array_intersect_assoc
array_intersect_uassoc
Dizi İşlevleri
PHP Manual

array_intersect_key

(PHP 5 >= 5.1.0, PHP 7)

array_intersect_key — Karşılaştırma için anahtarları kullanarak dizilerin kesişimini hesaplar

Açıklama

array array_intersect_key ( array $dizi1 , array $dizi2 [, array $ ... ] )

array_intersect_key() işlevi dizi1 dizisinin tüm değiştirgelerde mevcut anahtarlarından oluşan bir ilişkisel dizi döndürür.

Değiştirgeler

dizi1

Diğer dizilerin karşılaştırılacağı ilk dizi.

dizi2

İlk dizi ile karşılaştırılacak dizi.

...

İlk dizi ile karşılaştırılacak diğer dizilerin değişkenlerinin listesi.

Dönen Değerler

dizi1 dizisinin tüm değiştirgelerde mevcut anahtarlarından oluşan bir ilişkisel dizi döndürür.

Örnekler

Örnek 1 - array_intersect_key() örneği

<?php
$array1 = array('blue'  => 1, 'red'  => 2, 'green'  => 3, 'purple' => 4);
$array2 = array('green' => 5, 'blue' => 6, 'yellow' => 7, 'cyan'   => 8);

var_dump(array_intersect_key($array1, $array2));
?>

Yukarıdaki örneğin çıktısı:

array(2) {
  ["blue"]=>
  int(1)
  ["green"]=>
  int(3)
}

Örnekte gördüğünüz gibi her iki dizide de sadece 'blue' ve 'green' anahtarları ortak olduğundan dönen dizi sadece bu elemanları içermektedir. Ayrıca, dizilerde 'blue' ve 'green' anahtarlı elemanların değerlerinin farklı oluşuna da dikkat ediniz. Sadece anahtarlara bakıldığından bir eşleşme oluşmakta ve sadece dizi1 dizisindeki değerler döndürülmektedir.

İki anahtarın eşit olması için sadece ve sadece (string) $anahtar1 === (string) $anahtar2 olmalıdır. Başka bir deyişle, anahtarların dizgesel gösterimleri aynı olmalıdır.

Ayrıca Bakınız

  • array_diff() - Dizilerin farkını hesaplar
  • array_udiff() - Veri karşılaştırması için bir geriçağırım işlevi kullanarak diziler arasındaki farkı bulur
  • array_diff_assoc() - Dizilerin farkını hesaplarken ek olarak indisleri de karşılaştırır
  • array_diff_uassoc() - Dizilerin farkını hesaplarken ek olarak bir geriçağırım işlevi üzerinden indisleri de karşılaştırır
  • array_udiff_assoc() - Veri karşılaştırması için bir geriçağırım işlevi kullanarak diziler arasındaki farkı indislerine de bakarak bulur
  • array_udiff_uassoc() - Veri ve indis karşılaştırması için bir geriçağırım işlevi kullanarak diziler arasındaki farkı indislerine de bakarak bulur
  • array_diff_key() - Dizilerin farkını hesaplarken indisleri karşılaştırır
  • array_diff_ukey() - Karşılaştırma için bir geriçağırım işlevi kullanarak dizilerin farkını hesaplar
  • array_intersect() - Dizilerin kesişimini hesaplar
  • array_intersect_assoc() - Dizilerin kesişimini hesaplarken ek olarak indisleri de karşılaştırır
  • array_intersect_uassoc() - Dizilerin kesişimini hesaplarken ek olarak bir geriçağırım işlevi üzerinden indisleri de karşılaştırır
  • array_intersect_ukey() - Anahtarları karşılaştırmak için bir geriçağırım işlevi kullanarak dizilerin kesişimini hesaplar

array_intersect_assoc
array_intersect_uassoc
Dizi İşlevleri


Dizilerin kesişimini hesaplarken ek olarak bir geriçağırım işlevi üzerinden indisleri de karşılaştırır

array_intersect_key
array_intersect_ukey
Dizi İşlevleri
PHP Manual

array_intersect_uassoc

(PHP 5, PHP 7)

array_intersect_uassoc — Dizilerin kesişimini hesaplarken ek olarak bir geriçağırım işlevi üzerinden indisleri de karşılaştırır

Açıklama

array array_intersect_uassoc ( array $dizi1 , array $dizi2 [, array $ ... ], callable $anh_karş_işlevi )

array_intersect_uassoc() işlevi tüm değiştirgelerinde mevcut olan dizi1 değerlerini içeren bir dizi döndürür. array_intersect() işlevinin aksine karşılaştırmada anahtarların kullanıldığına dikkat ediniz.

Değiştirgeler

dizi1

Diğer dizilerin karşılaştırılacağı ilk dizi.

dizi2

Değerleri ilk dizi ile karşılaştırılacak dizi.

...

Değerleri ilk dizi ile karşılaştırılacak diğer dizilerin değişkenlerinin listesi.

anh_karş_işlevi

Karşılaştırma işlevinin, ilk bileşeninin ikinci bileşenden küçük, eşit veya büyük olması durumunda sıfırdan küçük, eşit veya büyük bir tamsayı döndürmesi gerekir.

int callback ( mixed $a, mixed $b )

Dönen Değerler

Tüm değiştirgelerde mevcut dizi1 değerlerini içeren bir dizi döndürür.

Örnekler

Örnek 1 - array_intersect_uassoc() örneği

<?php
$array1 = array("a" => "green", "b" => "brown", "c" => "blue", "red");
$array2 = array("a" => "GREEN", "B" => "brown", "yellow", "red");

print_r(array_intersect_uassoc($array1, $array2, "strcasecmp"));
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [b] => brown
)

Ayrıca Bakınız

  • array_intersect() - Dizilerin kesişimini hesaplar
  • array_intersect_assoc() - Dizilerin kesişimini hesaplarken ek olarak indisleri de karşılaştırır
  • array_uintersect_assoc() - Veriyi bir geriçağırım işleviyle karşılaştırarak dizilerin kesişimini hesaplarken ek olarak indislere de bakar
  • array_uintersect_uassoc() - Veriyi ve indisleri bir geriçağırım işleviyle karşılaştırarak dizilerin kesişimini hesaplarken ek olarak indislere de bakar
  • array_intersect_key() - Karşılaştırma için anahtarları kullanarak dizilerin kesişimini hesaplar
  • array_intersect_ukey() - Anahtarları karşılaştırmak için bir geriçağırım işlevi kullanarak dizilerin kesişimini hesaplar

array_intersect_key
array_intersect_ukey
Dizi İşlevleri


Anahtarları karşılaştırmak için bir geriçağırım işlevi kullanarak dizilerin kesişimini hesaplar

array_intersect_uassoc
array_intersect
Dizi İşlevleri
PHP Manual

array_intersect_ukey

(PHP 5 >= 5.1.0, PHP 7)

array_intersect_ukey — Anahtarları karşılaştırmak için bir geriçağırım işlevi kullanarak dizilerin kesişimini hesaplar

Açıklama

array array_intersect_ukey ( array $dizi1 , array $dizi2 [, array $... ], callable $anh_karş_işlevi )

array_intersect_ukey() işlevi tüm değiştirgelerinde mevcut olan ve anahtarları eşleşen tüm dizi1 değerlerini içeren bir dizi döndürür.

Değiştirgeler

dizi1

Diğer dizilerin karşılaştırılacağı ilk dizi.

dizi2

İlk dizi ile karşılaştırılacak dizi.

...

İlk dizi ile karşılaştırılacak diğer dizilerin değişkenlerinin listesi.

anh_karş_işlevi

Karşılaştırma işlevinin, ilk bileşeninin ikinci bileşenden küçük, eşit veya büyük olması durumunda sıfırdan küçük, eşit veya büyük bir tamsayı döndürmesi gerekir.

int callback ( mixed $a, mixed $b )

Dönen Değerler

Anahtarları tüm değiştirgelerde mevcut dizi1 değerlerini içeren bir dizi döndürür.

Örnekler

Örnek 1 - array_intersect_ukey() örneği

<?php
function anh_kars_islevi($a1, $a2)
{
    if ($a1 == $a2)
        return 0;
    else if ($a1 > $a2)
        return 1;
    else
        return -1;
}

$dizi1 = array('blue'  => 1, 'red'  => 2, 'green'  => 3, 'purple' => 4);
$dizi2 = array('green' => 5, 'blue' => 6, 'yellow' => 7, 'cyan'   => 8);

var_dump(array_intersect_ukey($dizi1, $dizi2, 'anh_kars_islevi'));
?>

Yukarıdaki örneğin çıktısı:

array(2) {
  ["blue"]=>
  int(1)
  ["green"]=>
  int(3)
}

Örnekte gördüğünüz gibi her iki dizide de sadece 'blue' ve 'green' anahtarları ortak olduğundan dönen dizi sadece bu elemanları içermektedir. Ayrıca, dizilerde 'blue' ve 'green' anahtarlı elemanların değerlerinin farklı oluşuna da dikkat ediniz. Sadece anahtarlara bakıldığından bir eşleşme oluşmakta ve sadece dizi1 dizisindeki değerler döndürülmektedir.

Ayrıca Bakınız

  • array_diff() - Dizilerin farkını hesaplar
  • array_udiff() - Veri karşılaştırması için bir geriçağırım işlevi kullanarak diziler arasındaki farkı bulur
  • array_diff_assoc() - Dizilerin farkını hesaplarken ek olarak indisleri de karşılaştırır
  • array_diff_uassoc() - Dizilerin farkını hesaplarken ek olarak bir geriçağırım işlevi üzerinden indisleri de karşılaştırır
  • array_udiff_assoc() - Veri karşılaştırması için bir geriçağırım işlevi kullanarak diziler arasındaki farkı indislerine de bakarak bulur
  • array_udiff_uassoc() - Veri ve indis karşılaştırması için bir geriçağırım işlevi kullanarak diziler arasındaki farkı indislerine de bakarak bulur
  • array_diff_key() - Dizilerin farkını hesaplarken indisleri karşılaştırır
  • array_diff_ukey() - Karşılaştırma için bir geriçağırım işlevi kullanarak dizilerin farkını hesaplar
  • array_intersect() - Dizilerin kesişimini hesaplar
  • array_intersect_assoc() - Dizilerin kesişimini hesaplarken ek olarak indisleri de karşılaştırır
  • array_intersect_uassoc() - Dizilerin kesişimini hesaplarken ek olarak bir geriçağırım işlevi üzerinden indisleri de karşılaştırır
  • array_intersect_key() - Karşılaştırma için anahtarları kullanarak dizilerin kesişimini hesaplar

array_intersect_uassoc
array_intersect
Dizi İşlevleri


Dizilerin kesişimini hesaplar

array_intersect_ukey
array_key_exists
Dizi İşlevleri
PHP Manual

array_intersect

(PHP 4 >= 4.0.1, PHP 5, PHP 7)

array_intersect — Dizilerin kesişimini hesaplar

Açıklama

array array_intersect ( array $dizi1 , array $dizi2 [, array $ ... ] )

array_intersect() işlevi tüm değiştirgelerinde mevcut olan dizi1 değerlerini anahtarlarını koruyarak bir dizi içinde döndürür.

Değiştirgeler

dizi1

Aranacak ana değerleri içeren dizi.

array2

Değerleri dizi1 dizisindeki değerlerle karşılaştırılacak ilk dizi.

...

Değerleri dizi1 dizisindeki değerlerle karşılaştırılacak diğer dizilerin değişkenlerinin listesi.

Dönen Değerler

Tüm değiştirgelerde mevcut olan dizi1 değerlerini içeren bir dizi döner.

Örnekler

Örnek 1 - array_intersect() örneği

<?php
$array1 = array("a" => "green", "red", "blue");
$array2 = array("b" => "green", "yellow", "red");
$result = array_intersect($array1, $array2);
print_r($result);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [a] => green
    [0] => red
)

Notlar

Bilginize: İki elemanın eşit olması için sadece ve sadece (string) $elem1 === (string) $elem2 olmalıdır. Başka bir deyişle, değerlerin dizgesel gösterimleri aynı olmalıdır.

Ayrıca Bakınız

  • array_intersect_assoc() - Dizilerin kesişimini hesaplarken ek olarak indisleri de karşılaştırır
  • array_diff() - Dizilerin farkını hesaplar
  • array_diff_assoc() - Dizilerin farkını hesaplarken ek olarak indisleri de karşılaştırır

array_intersect_ukey
array_key_exists
Dizi İşlevleri


Belirtilen anahtar veya indis dizide var mı diye bakar

array_intersect
array_keys
Dizi İşlevleri
PHP Manual

array_key_exists

(PHP 4 >= 4.0.7, PHP 5, PHP 7)

array_key_exists — Belirtilen anahtar veya indis dizide var mı diye bakar

Açıklama

bool array_key_exists ( mixed $anahtar , array $dizi )

array_key_exists() işlevi anahtar dizide varsa TRUE döndürür. anahtar yerine bir indis de belirtilebilir.

Değiştirgeler

anahtar

Aranacak anahtar veya indis.

dizi

Anahtarın aranacağı dizi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - array_key_exists() örneği

<?php
$dizi = array('ilk' => 1, 'ikinci' => 4);
if (array_key_exists('ilk', $dizi)) {
    echo "'ilk' elememanı dizide mevcut";
}
?>

Örnek 2 - array_key_exists() işlevine karşı isset()

isset() işlevi NULL değerli dizi anahtarları için TRUE döndürmez ama array_key_exists() döndürür.

<?php
$dizi = array('ilk' => null, 'ikinci' => 4);

// false döner
isset($dizi['ilk']);

// true döner
array_key_exists('ilk', $dizi);
?>

Notlar

Bilginize:

Geriye uyumluluk adına, kullanımı önerilmese de şu takma adı kullanabilirsiniz: key_exists()

Bilginize:

Geriye uyumluluk adına, array_key_exists() işlevi anahtar değiştirgesinin dizi olarak beliritlen bir object içinde tanımlanmış bir özellik olması durumunda da TRUE döndürür. Bu davranışa güvenilmemeli, dizi'nin array türünde olduğundan özellikle emin olunmalıdır.

Bir nesne içinde bir özelliğin bulunup bulunmadığını sınamak için property_exists() işlevini kullanın.

Ayrıca Bakınız

  • isset() - Değişken tanımlı mı diye bakar
  • array_keys() - Bir dizideki tüm anahtarları veya bir anahtar altkümesini döndürür
  • in_array() - Bir dizide bir değerin varlığını araştırır
  • property_exists() - Bir nesne veya sınıfın belirtilen özelliğe sahip olup olmadığına bakar

array_intersect
array_keys
Dizi İşlevleri


Bir dizideki tüm anahtarları veya bir anahtar altkümesini döndürür

array_key_exists
array_map
Dizi İşlevleri
PHP Manual

array_keys

(PHP 4, PHP 5, PHP 7)

array_keys — Bir dizideki tüm anahtarları veya bir anahtar altkümesini döndürür

Açıklama

array array_keys ( array $dizi [, mixed $arama_değeri [, bool $aynısı = false ]] )

array_keys() işlevi dizi dizisindeki sayısal ve dizgesel anahtarları döndürür.

İsteğe bağlı arama_değeri değiştirgesi belirtilmişse sadece bu değere sahip anahtarlar döndürülür. Aksi takdirde dizi dizisindeki tüm anahtarlar döndürülür.

Değiştirgeler

dizi

Döndürülecek anahtarları içeren dizi.

arama_değeri

Belirtilmişse sadece bu değeri içeren anahtarlar döndürülür.

aynısı

Arama sırasında tam karşılaştırma (===) yapılır.

Dönen Değerler

dizi dizisindeki anahtarları içeren bir dizi döndürür.

Örnekler

Örnek 1 - array_keys() örneği

<?php
$array = array(0 => 100, "color" => "red");
print_r(array_keys($array));

$array = array("blue", "red", "green", "blue", "blue");
print_r(array_keys($array, "blue"));

$array = array("color" => array("blue", "red", "green"),
               "size"  => array("small", "medium", "large"));
print_r(array_keys($array));
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [0] => 0
    [1] => color
)
Array
(
    [0] => 0
    [1] => 3
    [2] => 4
)
Array
(
    [0] => color
    [1] => size
)

Ayrıca Bakınız

  • array_values() - Bir dizinin tüm değerlerini döndürür
  • array_key_exists() - Belirtilen anahtar veya indis dizide var mı diye bakar
  • array_search() - Bir dizide belirtilen değeri arar ve bulursa ilgili anahtarı döndürür

array_key_exists
array_map
Dizi İşlevleri


Belirtilen dizilerin elemanlarına geriçağırım işlevini uygular

array_keys
array_merge_recursive
Dizi İşlevleri
PHP Manual

array_map

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

array_map — Belirtilen dizilerin elemanlarına geriçağırım işlevini uygular

Açıklama

array array_map ( callable $işlev , array $dizi1 [, array $... ] )

array_map() işlevi belirtilen dizilerin elemanlarının her birine işlev işlevini uygulayıp sonucu bir dizi olarak döndürür. Geriçağırım işlevinin değiştirge sayısı array_map() işlevine aktarılan değiştirge sayısını kabul edebilmelidir.

Değiştirgeler

işlev

Her dizinin her elemanına uygulanacak geri çağırım işlevi.

dizi1

Elemanları işlev tarafından işlenecek ilk dizi.

array

Elemanları işlev tarafından işlenecek diğer diziler.

Dönen Değerler

Belirtilen dizilerin elemanlarının her birine işlev işlevini uyguladıktan sonra oluşan diziyi döndürür.

Örnekler

Örnek 1 - array_map() örneği

<?php
function cube($n)
{
    return($n * $n * $n);
}

$a = array(1, 2, 3, 4, 5);
$b = array_map("cube", $a);
print_r($b);
?>

$b şöyle olur:

Array
(
    [0] => 1
    [1] => 8
    [2] => 27
    [3] => 64
    [4] => 125
)

Örnek 2 - Lamda işlevi kullanan array_map() örneği (PHP 5.3.0 ve sonrası)

<?php
$func = function($deger) {
    return $deger * 2;
};

print_r(array_map($func, range(1, 5)));
?>
Array
(
    [0] => 2
    [1] => 4
    [2] => 6
    [3] => 8
    [4] => 10
)

Örnek 3 - Birden fazla diziyle array_map() örneği

<?php
function show_Spanish($n, $m)
{
    return("İspanyolcada $n sayısının ismi:");
}

function map_Spanish($n, $m)
{
    return(array($n => $m));
}

$a = array(1, 2, 3, 4, 5);
$b = array("uno", "dos", "tres", "cuatro", "cinco");

$c = array_map("show_Spanish", $a, $b);
print_r($c);

$d = array_map("map_Spanish", $a , $b);
print_r($d);
?>

Yukarıdaki örneğin çıktısı:

// $c çıktısı
Array
(
    [0] => İspanyolcada 1 sayısının ismi: uno
    [1] => İspanyolcada 2 sayısının ismi: dos
    [2] => İspanyolcada 3 sayısının ismi: tres
    [3] => İspanyolcada 4 sayısının ismi: cuatro
    [4] => İspanyolcada 5 sayısının ismi: cinco
)

// $d çıktısı
Array
(
    [0] => Array
        (
            [1] => uno
        )

    [1] => Array
        (
            [2] => dos
        )

    [2] => Array
        (
            [3] => tres
        )

    [3] => Array
        (
            [4] => cuatro
        )

    [4] => Array
        (
            [5] => cinco
        )

)

İki veya daha fazla sayıda dizi kullanırken işlev elemanlara karşılıklı uygulanacağından normal olarak dizilerin eleman sayılarının eşit olması gerekir. Eğer bu eşitlik yoksa, kısa olanlar boş elemanlar eklenerek en uzun olanın boyuna eşitlenir

Bu işlevin ilginç bir kullanımı da, geriçağırım işlevi ismi olarak NULL belirterek bir diziler dizisi oluşturmaktır.

Örnek 4 - Bir diziler dizisi oluşturmak

<?php
$a = array(1, 2, 3, 4, 5);
$b = array("one", "two", "three", "four", "five");
$c = array("bir", "iki", "üç", "dört", "beş");

$d = array_map(null, $a, $b, $c);
print_r($d);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [0] => Array
        (
            [0] => 1
            [1] => one
            [2] => bir
        )

    [1] => Array
        (
            [0] => 2
            [1] => two
            [2] => iki
        )

    [2] => Array
        (
            [0] => 3
            [1] => three
            [2] => üç
        )

    [3] => Array
        (
            [0] => 4
            [1] => four
            [2] => dört
        )

    [4] => Array
        (
            [0] => 5
            [1] => five
            [2] => beş
        )

)

Eğer dizi elemanları dizgesel anahtarlar içeriyorsa, sadece aynı anahtara sahip olmayan elemanlar dizgesel anahtarlarıyla içerilir. Eğer aynı anahtara sahip birden fazla eleman varsa dönen dizi bu elemanları daima sayısal indisli olarak içerir.

Örnek 5 - Dizgesel anahtarlarla array_map() örneği

<?php
$arr = array("anahtar" => "değer");
function cb1($a) {
    return array ($a);
}
function cb2($a, $b) {
    return array ($a, $b);
}
var_dump(array_map("cb1", $arr));
var_dump(array_map("cb2", $arr, $arr));
var_dump(array_map(null,  $arr));
var_dump(array_map(null, $arr, $arr));
?>

Yukarıdaki örneğin çıktısı:

array(1) {
  ["anahtar"]=>
  array(1) {
    [0]=>
    string(5) "deger"
  }
}
array(1) {
  [0]=>
  array(2) {
    [0]=>
    string(5) "deger"
    [1]=>
    string(5) "deger"
  }
}
array(1) {
  ["stringkey"]=>
  string(5) "deger"
}
array(1) {
  [0]=>
  array(2) {
    [0]=>
    string(5) "deger"
    [1]=>
    string(5) "deger"
  }
}

Ayrıca Bakınız

  • array_filter() - Bir dizinin elemanlarını bir geriçağırım işleviyle süzgeçten geçirir
  • array_reduce() - Bir geriçağırım işlevini dizinin bütün elemanlarına tek tek uygulayıp sonucu döndürür
  • array_walk() - Bir dizinin her üyesine kullanıcı tanımlı bir işlevi uygular
  • callback türü hakkında bilgi

array_keys
array_merge_recursive
Dizi İşlevleri


İki veya daha fazla sayıda diziyi ardarda ekleyerek yeni bir dizi oluşturur

array_map
array_merge
Dizi İşlevleri
PHP Manual

array_merge_recursive

(PHP 4 >= 4.0.1, PHP 5, PHP 7)

array_merge_recursive — İki veya daha fazla sayıda diziyi ardarda ekleyerek yeni bir dizi oluşturur

Açıklama

array array_merge_recursive ( array $dizi1 [, array $... ] )

Belirtilen dizilerin elemanlarını bir öncekinin elemanlarının ardına eklemek suretiyle yeni bir dizi oluşturur ve bu diziyi döndürür.

Eğer dizilerde aynı anahtara sahip elemanlar varsa sonraki dizilerin eleman değerleri ilk elemana bir alt dizi değeri olarak ardarda eklenir. Eğer değerlerden biri zaten bir dizi ise işlev bu diziyi diğer dizideki ilgili girdiye katıştırır. Ancak, eğer diziler sayısal anahtarlar içeriyorsa sonraki değer daima sona eklenir.

Değiştirgeler

dizi1

Diğerlerinin ardına ekleneceği dizi.

...

Kendinden öncekinin ardına eklenecek diziler.

Dönen Değerler

Elde edilen diziyi döndürür.

Örnekler

Örnek 1 - array_merge_recursive() örneği

<?php
$ar1 = array("color" => array("favorite" => "red"), 5);
$ar2 = array(10, "color" => array("favorite" => "green", "blue"));
$result = array_merge_recursive($ar1, $ar2);
print_r($result);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [color] => Array
        (
            [favorite] => Array
                (
                    [0] => red
                    [1] => green
                )

            [0] => blue
        )

    [0] => 5
    [1] => 10
)

Ayrıca Bakınız

  • array_merge() - Belirtilen dizileri ardarda ekleyerek yeni bir dizi oluşturur
  • array_replace_recursive() - İlk dizinin elemanlarını aktarılan dizilerden ardışık olarak günceller

array_map
array_merge
Dizi İşlevleri


Belirtilen dizileri ardarda ekleyerek yeni bir dizi oluşturur

array_merge_recursive
array_multisort
Dizi İşlevleri
PHP Manual

array_merge

(PHP 4, PHP 5, PHP 7)

array_merge — Belirtilen dizileri ardarda ekleyerek yeni bir dizi oluşturur

Açıklama

array array_merge ( array $dizi1 [, array $... ] )

Belirtilen dizilerin elemanlarını bir öncekinin elemanlarının ardına eklemek suretiyle yeni bir dizi oluşturur ve bu diziyi döndürür.

Eğer dizilerde aynı anahtara sahip elemanlar varsa sonraki dizinin elemanı öncekinin yerine konur. Ancak, eğer diziler sayısal anahtarlar içeriyorsa sonraki değer öncekinin üzerine yazılmaz, sona eklenir.

Belirtilen dizi sayısal indisli ise sonuç dizisndeki indisler sıfırdan başlayarak yeniden oluşturulur.

Değiştirgeler

dizi1

Diğerlerinin ardına ekleneceği dizi.

dizi2

Katıştırılacak diğer dizilerin değişkenlerinin listesi.

Dönen Değerler

Elde edilen diziyi döndürür.

Örnekler

Örnek 1 - array_merge() örneği

<?php
$array1 = array("color" => "red", 2, 4);
$array2 = array("a", "b", "color" => "green", "shape" => "trapezoid", 4);
$result = array_merge($array1, $array2);
print_r($result);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [color] => green
    [0] => 2
    [1] => 4
    [2] => a
    [3] => b
    [shape] => trapezoid
    [4] => 4
)

Örnek 2 - Basit array_merge() örneği

<?php
$dizi1 = array();
$dizi2 = array(1 => "veri");
$sonuç = array_merge($dizi1, $dizi2);
?>

Sayısal anahtarların yeniden numaralanacağını unutmayın!

Array
(
    [0] => veri
)

İkinci dizideki elemanlar birinci diziye eklerken sirinci dizideki elemanların üzerine yazılmaması ve yeniden indislenmemesi için + (dizi birleştirme) işlecini kullanın:

<?php
$dizi1 = array(0 => 'sıfır_a', 2 => 'iki_a', 3 => 'üç_a');
$dizi2 = array(1 => 'bir_b', 3 => 'üç_b', 4 => 'dört_b');
$sonuç = $dizi1 + $dizi2;

var_dump($sonuç);
?>

Birinci dizideki anahtarlar korunur. Bir anahtar iki dizide de mevcutsa birincisi kullanılır ikinci dizideki yok sayılır.

array(5) {
  [0]=>
  string(9) "sıfır_a"
  [2]=>
  string(5) "iki_a"
  [3]=>
  string(6) "üç_a"
  [1]=>
  string(5) "bir_b"
  [4]=>
  string(7) "dört_b"
}

Örnek 3 - array türünde olmayan dizilerle array_merge()

<?php
$ilk = 'foo';
$son = array(1 => 'bar');
$sonuc = array_merge((array)$ilk, (array)$son);
print_r($sonuc);
?>

Yukarıdaki örneğin çıktısı:

    Array
    (
        [0] => foo
        [1] => bar
    )

Ayrıca Bakınız

  • array_merge_recursive() - İki veya daha fazla sayıda diziyi ardarda ekleyerek yeni bir dizi oluşturur
  • array_replace() - İlk dizinin elemanlarını aktarılan dizilerden günceller
  • array_combine() - Anahtarlar için bir dizi, değerler için ise başka bir dizi kullanarak bir ilişkisel dizi oluşturur
  • dizi İşleçleri

array_merge_recursive
array_multisort
Dizi İşlevleri


Çok sayıda diziyi veya çok boyutlu dizileri sıralar

array_merge
array_pad
Dizi İşlevleri
PHP Manual

array_multisort

(PHP 4, PHP 5, PHP 7)

array_multisort — Çok sayıda diziyi veya çok boyutlu dizileri sıralar

Açıklama

bool array_multisort ( array &$dizi [, mixed $arg = SORT_ASC [, mixed $arg = SORT_REGULAR [, mixed $... ]]] )

array_multisort() işlevi çok sayıda diziyi bir kerede sıralayabileceği gibi çok boyutlu bir diziyi bir veya daha fazla boyuta göre de sıralayabilir.

İlişkisel (string) anahtarlar korunursa da sayısal indisler yeniden oluşturulur.

Değiştirgeler

dizi

Sıralanacak dizi.

arg

Belirtildiği takdirde, önceki diziye uygulanmak üzere ya başka bir dizi ya da şu seçeneklerden biri belirtilir: SORT_ASC (artan sırada), SORT_DESC (azalan sırada), SORT_REGULAR (normal), SORT_NUMERIC (sayısal), SORT_STRING (dizgesel).

...

Ek değiştirge'ler.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Çok sayıda diziyi sıralamak

<?php
$ar1 = array(10, 100, 100, 0);
$ar2 = array(1, 3, 2, 4);
array_multisort($ar1, $ar2);

var_dump($ar1);
var_dump($ar2);
?>

Bu örnekte sıralama sonrasında iki dizi arasındaki elemanlar yerlerine göre birbirinin karşıtı olmak üzere ilk dizi 0, 10, 100, 100; ikinci dizi 4, 1, 2, 3 içerir.

array(4) {
  [0]=> int(0)
  [1]=> int(10)
  [2]=> int(100)
  [3]=> int(100)
}
array(4) {
  [0]=> int(4)
  [1]=> int(1)
  [2]=> int(2)
  [3]=> int(3)
}

Örnek 2 - Çok boyutlu diziyi sıralamak

<?php
$ar = array(
       array("10", 11, 100, 100, "a"),
       array(   1,  2, "2",   3,   1)
      );
array_multisort($ar[0], SORT_ASC, SORT_STRING,
                $ar[1], SORT_NUMERIC, SORT_DESC);
var_dump($ar);
?>

Bu örnekte sıralama sonrasında, ilk dizi "10", 100, 100, 11, "a" dizisine dönüşecek (artan düzende dizgesel olarak sıralanır), ikinci dizi ise 1, 3, "2", 2, 1 değerlerini içerecektir (azalan düzende sayısal olarak sıralanır) .

array(2) {
  [0]=> array(5) {
    [0]=> string(2) "10"
    [1]=> int(100)
    [2]=> int(100)
    [3]=> int(11)
    [4]=> string(1) "a"
  }
  [1]=> array(5) {
    [0]=> int(1)
    [1]=> int(3)
    [2]=> string(1) "2"
    [3]=> int(2)
    [4]=> int(1)
  }
}

Örnek 3 - Veritabanı sonuçlarının sıralanması

Bu örnek için, veri dizisindeki her eleman tablodaki bir satıra karşılıktır.

Örnek veri:

 bölüm |   baskı
-------+--------
    67 |       2
    86 |       1
    85 |       6
    98 |       2
    86 |       6
    67 |       7

Dizi olarak veri dizisi kullanılmıştır. Aynı sonuç mysql_fetch_assoc() işlevini bir döngü içinde kullanarak da elde edilebilir.

<?php
$veri[] = array('bölüm' => 67, 'baskı' => 2);
$veri[] = array('bölüm' => 86, 'baskı' => 1);
$veri[] = array('bölüm' => 85, 'baskı' => 6);
$veri[] = array('bölüm' => 98, 'baskı' => 2);
$veri[] = array('bölüm' => 86, 'baskı' => 6);
$veri[] = array('bölüm' => 67, 'baskı' => 7);
?>

Bu örnekte bölüm'ü azalan baskı'yı artan düzende sıralayacağız.

Satırlara karşılık gelen bir dizimiz var, fakat array_multisort() sütun dizileri gerektiriyor. Bu nedenle sıralamayı yapmadan önce sütunları elde etmek için şu kodu kullanacağız:

<?php
// Sütun listelerini elde edelim
foreach ($veri as $anahtar => $satır) {
    $bölüm[$anahtar]  = $satır['bölüm'];
    $baskı[$anahtar] = $satır['baskı'];
}

// bölüm'ü azalan, baskı'yı artan düzende sıralayalım ve
// ortak bir anahtara göre sıralamak için $veri'yi son
// değiştirge olarak ekleyelim
array_multisort($bölüm, SORT_DESC, $baskı, SORT_ASC, $veri);
?>

Veri kümemiz artık sıraya dizildi:

bölüm | baskı
------+------
   98 |     2
   86 |     1
   86 |     6
   85 |     6
   67 |     2
   67 |     7

Örnek 4 - Harf büyüklüğüne duyarsız sıralama

SORT_STRING ve SORT_REGULAR seçenekleri harf büyüklüğüne duyarlı olup, büyük harf ile başlayan dizgeler sıralamada küçük harfle başlayanlardan önce gelir.

Harf büyüklüğüne duyarsız sıralama yapmak için özgün dizinin önce küçük harfli bir kopyası oluşturulur.

<?php
$dizi = array('Alpha', 'atomic', 'Beta', 'bank');
$küçük_harfli_dizi = array_map('strtolower', $array);

array_multisort($küçük_harfli_dizi, SORT_ASC, SORT_STRING, $dizi);

print_r($array);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [0] => Alpha
    [1] => atomic
    [2] => bank
    [3] => Beta
)

Ayrıca Bakınız

  • usort() - Bir diziyi kullanıcı tanımlı bir işlev kullanarak değerlerine göre sıralar
  • Dizilerde Sıralama

array_merge
array_pad
Dizi İşlevleri


Dizi boyutunu belirtilen boyuta çıkarırken, yeni elemanlara belirtilen değeri yerleştirir

array_multisort
array_pop
Dizi İşlevleri
PHP Manual

array_pad

(PHP 4, PHP 5, PHP 7)

array_pad — Dizi boyutunu belirtilen boyuta çıkarırken, yeni elemanlara belirtilen değeri yerleştirir

Açıklama

array array_pad ( array $girdi , int $yeni_boyut , mixed $dolgu )

array_pad() işlevi yeni elemanlara dolgu değerini yerleştirerek yeni_boyut elemanlı bir dizi ile döner. Eğer yeni_boyut olarak pozitif bir değer belirtilmişse yeni elemanlar dizinin sonuna, negatif bir değer için ise dizinin başına eklenir. Eğer yeni_boyut'un mutlak değeri dizinin mevcut boyutundan küçük veya ona eşitse dizide değişiklik olmaz. Bir seferde en fazla 1048576 eleman belirtilebilir.

Değiştirgeler

girdi

Değer eklenecek dizi.

yeni_boyut

Dizinin yeni boyutu.

dolgu

girdi dizisinin eleman sayısı yeni_boyut'tan kısa ise eklenecek elemanların değeri.

Dönen Değerler

girdi dizisinin yeni elemanlarına dolgu değeri yerleştirilerek elde edilen yeni_boyut elemanlı yeni bir dizi ile döner. Eğer yeni_boyut olarak pozitif bir değer belirtilmişse yeni elemanlar dizinin sonuna, negatif bir değer için ise dizinin başına eklenir. Eğer yeni_boyut'un mutlak değeri dizinin mevcut boyutundan küçük veya ona eşitse dizide değişiklik olmaz.

Örnekler

Örnek 1 - array_pad() örneği

<?php
$input = array(12, 10, 9);

$result = array_pad($input, 5, 0);
// sonuç: array(12, 10, 9, 0, 0)

$result = array_pad($input, -7, -1);
// sonuç: array(-1, -1, -1, -1, 12, 10, 9)

$result = array_pad($input, 2, "noop");
// dizide değişiklik olmaz
?>

Ayrıca Bakınız

  • array_fill() - Bir diziyi değerlerle doldurur
  • range() - Belli bir eleman aralığını içeren bir dizi oluşturur

array_multisort
array_pop
Dizi İşlevleri


Dizinin sonundaki elemanı diziden çıkartır

array_pad
array_product
Dizi İşlevleri
PHP Manual

array_pop

(PHP 4, PHP 5, PHP 7)

array_pop — Dizinin sonundaki elemanı diziden çıkartır

Açıklama

mixed array_pop ( array &$dizi )

array_pop() dizi'deki son elemanı çıkartır ve son elemanın değerini döndürür, dizi bir eleman kısalır. Eğer dizi boş (veya dizi değilse), NULL döndürür. Ek olarak, dizi olmayan bir değiştirge ile çağrıldığında bir E_WARNING iletisi oluşturacaktır.

Bilginize: Bu işlev diziyi kullandıktan sonra girdi dizisinin dahili göstericisini ilk elemana konumlandırır.

Değiştirgeler

dizi

Değer alınacak dizi.

Dönen Değerler

dizi'nin son elemanının değerini döndürür. Eğer dizi boş (veya dizi değil) ise , NULL değer döndürür.

Örnekler

Örnek 1 - array_pop() örneği

<?php
$depo = array("portakal", "muz", "elma", "ahududu");
$meyve = array_pop($depo);
print_r($depo);
?>

Bundan sonra, $depo üç elemana sahiptir:

Array
(
    [0] => portakal
    [1] => muz
    [2] => elma
)

Ve ahududu $meyve değişkenine atanmıştır.

Ayrıca Bakınız

  • array_push() - Belli sayıda elemanı dizinin sonuna ekler
  • array_shift() - Dizini başlangıcından bir eleman çeker
  • array_unshift() - Bir dizinin başlangıcına bir veya daha fazla eleman ekler
array_pad
array_product
Dizi İşlevleri


Bir dizideki değerlerin çarpımını bulur

array_pop
array_push
Dizi İşlevleri
PHP Manual

array_product

(PHP 5 >= 5.1.0, PHP 7)

array_product — Bir dizideki değerlerin çarpımını bulur

Açıklama

number array_product ( array $dizi )

array_product() işlevi bir dizideki değerlerin çarpımını döndürür.

Değiştirgeler

dizi

Dizi.

Dönen Değerler

Çarpımı bir tamsayı veya gerçek sayı olarak döndürür.

Örnekler

Örnek 1 - array_product() örneği

<?php

$a = array(2, 4, 6, 8);
echo "çarpım(a) = " . array_product($a) . "\n";

?>

Yukarıdaki örneğin çıktısı:

çarpım(a) = 384

array_pop
array_push
Dizi İşlevleri


Belli sayıda elemanı dizinin sonuna ekler

array_product
array_rand
Dizi İşlevleri
PHP Manual

array_push

(PHP 4, PHP 5, PHP 7)

array_push — Belli sayıda elemanı dizinin sonuna ekler

Açıklama

int array_push ( array &$dizi , mixed $değişken [, mixed $... ] )

array_push() işlevi dizi dizisini bir yığıt olarak ele alır ve aktarılan değişkenleri yığıtın sonuna ekler. Yığıtın boyutu eklenen her değişken için bir artar. İşlevin davranışı her değişken için şu satırı işletmeye eşdeğerdir:

<?php
$array[] = $var;
?>

Bilginize: Diziye sadece bir eleman ekleyecekseniz array_push() işlevi yerine $array[] = kullanmak daha iyidir.

Bilginize: array_push() işlevi ilk eleman bir dizi değilse bir uyarı verir. $dizi[] ile yeni bir dizi oluştururken böyle bir uyarı almazsınız.

Değiştirgeler

dizi

İşleme sokulacak dizi.

değişken

Diziye eklenecek değişken.

Dönen Değerler

Ekleme sonucunda dizideki eleman sayısı ile döner.

Örnekler

Örnek 1 - array_push() örneği

<?php
$küme = array("elma", "armut");
array_push($küme, "muz", "portakal");
print_r($küme);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [0] => elma
    [1] => armut
    [2] => muz
    [3] => portakal
)

Ayrıca Bakınız

  • array_pop() - Dizinin sonundaki elemanı diziden çıkartır
  • array_shift() - Dizini başlangıcından bir eleman çeker
  • array_unshift() - Bir dizinin başlangıcına bir veya daha fazla eleman ekler

array_product
array_rand
Dizi İşlevleri


Bir diziden belli sayıda rasgele eleman döndürür

array_push
array_reduce
Dizi İşlevleri
PHP Manual

array_rand

(PHP 4, PHP 5, PHP 7)

array_rand — Bir diziden belli sayıda rasgele eleman döndürür

Açıklama

mixed array_rand ( array $girdi [, int $istek_sayısı = 1 ] )

array_rand() işlevi bir diziden belli sayıda rasgele eleman elde etmek için kullanılır.

Değiştirgeler

girdi

İşleme sokulacak dizi.

istek_sayısı

Kaç tane rasgele eleman döndürüleceği belirtilir.

Dönen Değerler

Sadece bir girdi almak istiyorsanız array_rand() işlevi diziden rasgele bir anahtarla döner. Aksi takdirde, rasgele elemanları içeren bir dizi döndürür. Böylece, diziden rasgele anahtarlar değerleriyle birlikte bir dizi olarak çekilmiş olur.

Sürüm Bilgisi

Sürüm: | Açıklama
5.2.10 | Elde edilen anahtar dizisi artık karılmıyor.
4.2.0 | Rasgele sayı üreteci özdevinimli tohumlanır.

Örnekler

Örnek 1 - array_rand() örneği

<?php
$input = array("Neo", "Morpheus", "Trinity", "Cypher", "Tank");
$rand_keys = array_rand($input, 2);
echo $input[$rand_keys[0]] . "\n";
echo $input[$rand_keys[1]] . "\n";
?>

Ayrıca Bakınız

  • shuffle() - Bir diziyi karar

array_push
array_reduce
Dizi İşlevleri


Bir geriçağırım işlevini dizinin bütün elemanlarına tek tek uygulayıp sonucu döndürür

array_rand
array_replace_recursive
Dizi İşlevleri
PHP Manual

array_reduce

(PHP 4 >= 4.0.5, PHP 5, PHP 7)

array_reduce — Bir geriçağırım işlevini dizinin bütün elemanlarına tek tek uygulayıp sonucu döndürür

Açıklama

mixed array_reduce ( array $girdi , callback $işlev [, int $ilk_değer ] )

array_reduce() işlevi işlev işlevini girdi dizisinin bütün elemanlarına tek tek uygulayıp sonucu döndürür.

Değiştirgeler

girdi

Girdi olarak bir dizi.

işlev

Geriçağırım işlevi.

ilk_değer

Seçimlik ilk_değer değiştirgesi verilmişse ve dizi boşsa işlevin dönüş değeri ilk_değer olur, aksi takdirde işleme sokulan ilk değer belirtilen ilk_değer olur.

Dönen Değerler

Elde edilen sonucu döndürür.

Eğer dizi boşsa ve bir ilk_değer belirtilmemişse array_reduce() NULL döndürür.

Örnekler

Örnek 1 - array_reduce() örneği

<?php
function rsum($v, $w)
{
    $v += $w;
    return $v;
}

function rmul($v, $w)
{
    $v *= $w;
    return $v;
}

$a = array(1, 2, 3, 4, 5);
$x = array();
$b = array_reduce($a, "rsum");
$c = array_reduce($a, "rmul", 10);
$d = array_reduce($x, "rsum", 1);
?>

İşlem sonucunda $b 15, $c ise 1200 (= 10*1*2*3*4*5) değerini içerirken $d 1 içerir.

Ayrıca Bakınız

  • array_filter() - Bir dizinin elemanlarını bir geriçağırım işleviyle süzgeçten geçirir
  • array_map() - Belirtilen dizilerin elemanlarına geriçağırım işlevini uygular
  • array_unique() - Diziden yinelenen değerleri siler
  • array_count_values() - Bir dizideki tüm değerleri sayar

array_rand
array_replace_recursive
Dizi İşlevleri


İlk dizinin elemanlarını aktarılan dizilerden ardışık olarak günceller

array_reduce
array_replace
Dizi İşlevleri
PHP Manual

array_replace_recursive

(PHP 5 >= 5.3.0, PHP 7)

array_replace_recursive — İlk dizinin elemanlarını aktarılan dizilerden ardışık olarak günceller

Açıklama

array array_replace_recursive ( array &$disi , array &$dizi1 [, array &$dizi2 [, array &$... ]] )

dizi dizisinin değerlerini belirtilen diğer dizilerin değerleriyle günceller. İlk dizideki bir anahtar ikinci dizide mevcutsa ilk dizideki değer ikinciden güncellenir. İkinci dizide olup ilk dizide olmayan anahtarlar ilk dizide oluşturulur. Sadece ilk dizide bulunan anahtarların değerlerine dokunulmaz. Birden fazla güncelleyici dizi belirtilmişse diziler sırayla işlenir; yani daima sonraki dizideki değerler daima üste yazar.

array_replace_recursive() ardışık işlem yapar: alt dizilerdeki değerleri de aynı şekilde günceller.

İlk dizideki değer sayıl bir değerse, ikinci dizideki sayıl veya dizi değerle güncellenir. İlk ve ikinci dizideki değerlerin ikisi de dizi ise güncelleme işlemi bu alt dizilere ardışık olarak uygulanır.

Değiştirgeler

dizi

Elemanları güncellenecek dizi.

dizi1

İlk diziyi güncelleyecek dizi.

Dönen Değerler

Bir hata durumunda NULL aksi takdirde bir dizi döner.

Örnekler

Örnek 1 - array_replace_recursive() örneği

<?php
$esas = array('kışlık' => array( "portakal"),
              'yazlık' => array("karpuz", "kavun"), );
$ikame = array('kışlık' => array('mandalina'),
               'yazlık' => array('üzüm'));

$sepet = array_replace_recursive($esas, $ikame);
print_r($sepet);

$sepet = array_replace($esas, $ikame);
print_r($sepet);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [kışlık] => Array
        (
            [0] => mandalina
        )

    [yazlık] => Array
        (
            [0] => üzüm
            [1] => kavun
        )

)
Array
(
    [kışlık] => Array
        (
            [0] => mandalina
        )

    [yazlık] => Array
        (
            [0] => üzüm
        )

)

Örnek 2 - array_replace_recursive()ve ardışık işlem

<?php
$esas = array('kışlık' => array("portakal"),
              'yazlık' => array("kavun", "karpuz"),
               'diğer' => 'avakado' );
$ikame = array('kışlık' => 'mandalina',
               'yazlık' => array('üzüm'),
                'diğer' => array('ananas'));
$ikame2 = array('kışlık' => array('nar'),
                'yazlık' => array('üzüm'),
                'diğer' => 'muz');

$sepet = array_replace_recursive($esas, $ikame, $ikame2);
print_r($sepet);

?>

Yukarıdaki örneğin çıktısı:

Array
(
    [kışlık] => Array
        (
            [0] => nar
        )

    [yazlık] => Array
        (
            [0] => üzüm
            [1] => karpuz
        )

    [diğer] => muz
)

Ayrıca Bakınız

  • array_replace() - İlk dizinin elemanlarını aktarılan dizilerden günceller

array_reduce
array_replace
Dizi İşlevleri


İlk dizinin elemanlarını aktarılan dizilerden günceller

array_replace_recursive
array_reverse
Dizi İşlevleri
PHP Manual

array_replace

(PHP 5 >= 5.3.0, PHP 7)

array_replace — İlk dizinin elemanlarını aktarılan dizilerden günceller

Açıklama

array array_replace ( array &$dizi , array &$dizi1 [, array &$dizi2 [, array &$... ]] )

dizi dizisinin değerlerini belirtilen diğer dizilerin değerleriyle günceller. İlk dizideki bir anahtar ikinci dizide mevcutsa ilk dizideki değer ikinciden güncellenir. İkinci dizide olup ilk dizide olmayan anahtarlar ilk dizide oluşturulur. Sadece ilk dizide bulunan anahtarların değerlerine dokunulmaz. Birden fazla güncelleyici dizi belirtilmişse diziler sırayla işlenir; yani daima sonraki dizideki değerler daima üste yazar.

array_replace() ardışık işlem yapmaz; ikinci dizide ne varsa ilkini onunla günceller.

Değiştirgeler

dizi

Elemanları güncellenecek dizi.

dizi1

İlk diziyi güncelleyecek dizi.

Dönen Değerler

Bir hata durumunda NULL aksi takdirde bir dizi döner.

Örnekler

Örnek 1 - array_replace() örneği

<?php
$esas = array("portakal", "muz", "elma", "armut");
$ikame = array(0 => "karpuz", 4 => "kavun");
$ikame2 = array(0 => "dondurma");

$sepet = array_replace($esas, $ikame, $ikame2);
print_r($sepet);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [0] => ahududu
    [1] => muz
    [2] => elma
    [3] => armut
    [4] => dondurma
)

Ayrıca Bakınız

  • array_replace_recursive() - İlk dizinin elemanlarını aktarılan dizilerden ardışık olarak günceller

array_replace_recursive
array_reverse
Dizi İşlevleri


Diziyi tersine sıralayıp döndürür

array_replace
array_search
Dizi İşlevleri
PHP Manual

array_reverse

(PHP 4, PHP 5, PHP 7)

array_reverse — Diziyi tersine sıralayıp döndürür

Açıklama

array array_reverse ( array $dizi [, bool $anahtarları_koru = false ] )

Belirtilen dizi dizisini alıp elemanlarını tersine sıralayıp yeni bir dizi olarak döndürür.

Değiştirgeler

dizi

Girdi olarak alınan dizi.

anahtarları_koru

TRUE belirtilirse dizideki anahtarlar korunur.

Dönen Değerler

Tersine sıralanmış diziyi döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
4.0.3 | anahtarları_koru değiştirgesi eklendi.

Örnekler

Örnek 1 - array_reverse() örneği

<?php
$girdi  = array("php", 4.0, array("green", "red"));
$sonuç = array_reverse($girdi);
$anahtarlı_sonuç = array_reverse($girdi, true);
?>

Burada $sonuç ve $anahtarlı_sonuç aynı elemanları içerir, sadece anahtarları farklıdır. $sonuç ve $anahtarlı_sonuç dizilerinin çıktısı şöyle olur::

Array
(
    [0] => Array
        (
            [0] => green
            [1] => red
        )

    [1] => 4
    [2] => php
)
Array
(
    [2] => Array
        (
            [0] => green
            [1] => red
        )

    [1] => 4
    [0] => php
)

Ayrıca Bakınız

  • array_flip() - Bir dizideki anahtarlarla değerleri yer değiştirir

array_replace
array_search
Dizi İşlevleri


Bir dizide belirtilen değeri arar ve bulursa ilgili anahtarı döndürür

array_reverse
array_shift
Dizi İşlevleri
PHP Manual

array_search

(PHP 4 >= 4.0.5, PHP 5, PHP 7)

array_search — Bir dizide belirtilen değeri arar ve bulursa ilgili anahtarı döndürür

Açıklama

mixed array_search ( mixed $iğne , array $samanlık [, bool $türüne_bak ] )

samanlık'ta iğne arar.

Değiştirgeler

iğne

Aranacak değer.

Bilginize:

iğne bir dizge ise karşılaştırma harf büyüklüğüne duyarlıdır.

samanlık

Değerin aranacağı dizi.

türüne_bak

Bu değiştirgede TRUE belirtilmişse array_search() işlevi ayrıca, iğne'yi samanlık'ta ararken türüne de bakar.

Dönen Değerler

Bulursa iğne'yi bulamazsa FALSE döndürür.

Eğer iğne, samanlık içinde birden fazla varsa ilk bulunan döndürülür. Eşleşen tüm değerlerin anahtarlarını döndürmek isterseniz bu işlevi kullanmak yerine, array_keys() işlevini seçimlik arama_değeri değiştirgesi ile kullanın.

Uyarı

Bu işlev mantıksal FALSE değeriyle dönebileceği gibi FALSE olarak değerlendirilebilecek mantıksal olmayan bir değerle de dönebilir. Bu konuda daha fazla bilgi edinmek için Mantıksal Değerler bölümüne bakabilirsiniz. Bu işlevden dönen değeri sınamak için === işlecini kullanınız.

Sürüm Bilgisi

Sürüm: | Açıklama
4.2.0 | PHP 4.2.0 öncesinde, array_search() aranan değeri bulamazsa FALSE yerine NULL döndürürdü.

Örnekler

Örnek 1 - array_search() örneği

<?php
$array = array(0 => 'blue', 1 => 'red', 2 => 'green', 3 => 'red');

$key = array_search('green', $array); // $key = 2;
$key = array_search('red', $array);   // $key = 1;
?>

Ayrıca Bakınız

  • array_keys() - Bir dizideki tüm anahtarları veya bir anahtar altkümesini döndürür
  • array_values() - Bir dizinin tüm değerlerini döndürür
  • array_key_exists() - Belirtilen anahtar veya indis dizide var mı diye bakar
  • in_array() - Bir dizide bir değerin varlığını araştırır

array_reverse
array_shift
Dizi İşlevleri


Dizini başlangıcından bir eleman çeker

array_search
array_slice
Dizi İşlevleri
PHP Manual

array_shift

(PHP 4, PHP 5, PHP 7)

array_shift — Dizini başlangıcından bir eleman çeker

Açıklama

mixed array_shift ( array &$deste )

array_shift() işlevi deste dizisinin ilk elemanını çekip döndürürken diziden o elemanı eksiltip diziyi yeniden indisler. Dizgesel anahtarlara dokunulmazken sayısal anahtarlar sıfırdan başlayarak yeniden oluşturulur.

Bilginize: Bu işlev diziyi kullandıktan sonra girdi dizisinin dahili göstericisini ilk elemana konumlandırır.

Değiştirgeler

deste

İlk elemanı çekilecek dizi.

Dönen Değerler

deste bir dizi değilse veya boş bir dizi ise NULL yoksa çekilen değerle döner.

Örnekler

Örnek 1 - array_shift() örneği

<?php
$deste = array("as", "papaz", "kız", "vale");
$kart = array_shift($deste);
print_r($deste);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [0] => papaz
    [1] => kız
    [2] => vale
)

$kart değişkenine ise as atanır.

Ayrıca Bakınız

  • array_unshift() - Bir dizinin başlangıcına bir veya daha fazla eleman ekler
  • array_push() - Belli sayıda elemanı dizinin sonuna ekler
  • array_pop() - Dizinin sonundaki elemanı diziden çıkartır

array_search
array_slice
Dizi İşlevleri


Bir dizinin belli bir bölümünü döndürür

array_shift
array_splice
Dizi İşlevleri
PHP Manual

array_slice

(PHP 4, PHP 5, PHP 7)

array_slice — Bir dizinin belli bir bölümünü döndürür

Açıklama

array array_slice ( array $girdi , int $başlangıç [, int $uzunluk [, bool $indisleri_koru = false ]] )

array_slice() işlevi girdi dizisinin başlangıç'tan itibaren uzunluk sayıda elemanından oluşan bir dizi ile döner.

Bilginize: Bu işlev diziyi kullandıktan sonra girdi dizisinin dahili göstericisini ilk elemana konumlandırır.

Değiştirgeler

girdi

Girdi dizisi.

başlangıç

başlangıç pozitif bir değerse silinecek kısmın başlangıcı girdi dizisinin başlangıcından itibaren sayılır. Negatif bir değerse girdi dizisinin sonundan itibaren sayılır.

uzunluk

uzunluk verilmezse, başlangıç'tan dizi sonuna kadar herşey silinir. Belirtilmişse ve pozitifse başlangıç'tan dizi sonuna kadar belirtilen kadar eleman silinir. Belirtilmişse ve negatifse başlangıç'tan dizi sonuna kadar, dizi sonundan belirtilen sayıda eleman hariç herşey silinir.

indisleri_koru

array_slice() öntanımlı olarak dizi indislerini sıfırdan itbaren yeniden oluşturur. Bu davranışı indisleri_koru değiştirgesinde TRUE aktararak değiştirebilirsiniz.

Dönen Değerler

Dizinin istenen parçasıyla döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.2 | İsteğe bağlı preserve_keys değiştirgesi eklendi.

Örnekler

Örnek 1 - array_slice() örnekleri

<?php
$input = array("a", "b", "c", "d", "e");

$output = array_slice($input, 2);      // çıktısı: "c", "d", "e"
$output = array_slice($input, -2, 1);  // çıktısı: "d"
$output = array_slice($input, 0, 3);   // çıktısı: "a", "b", "c"

// dizi indisleri arasındaki farklara dikkat edin
print_r(array_slice($input, 2, -1));
print_r(array_slice($input, 2, -1, true));
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [0] => c
    [1] => d
)
Array
(
    [2] => c
    [3] => d
)

Ayrıca Bakınız

  • array_splice() - Bir dizinin belli bir bölümünü silip yerine başka şeyler koyar
  • unset() - Belirtilen değişkeni tanımsız yapar

array_shift
array_splice
Dizi İşlevleri


Bir dizinin belli bir bölümünü silip yerine başka şeyler koyar

array_slice
array_sum
Dizi İşlevleri
PHP Manual

array_splice

(PHP 4, PHP 5, PHP 7)

array_splice — Bir dizinin belli bir bölümünü silip yerine başka şeyler koyar

Açıklama

array array_splice ( array &$girdi , int $başlangıç [, int $uzunluk = 0 [, mixed $yenisi ]] )

girdi dizisinin başlangıç indisinden başlayan uzunluk sayıda elemanını siler ve belirtildiği takdirde, bunların yerlerine yenisi'ni yerleştirir.

girdi içindeki sayısal indislerin korunacağına dikkat edin.

Bilginize: Eğer yenisi bir dizi değilse (array) $yenisi şeklinde bir tür dönüşümüne tabi tutulacaktır. yenisi olarak bir nesne belirttiğiniz takdirde bu durum beklenmedik sonuçlar verebilir.

Değiştirgeler

girdi

Üzerinde işlem yapılacak dizi.

başlangıç

başlangıç pozitif bir değerse silinecek kısmın başlangıcı girdi dizisinin başlangıcından itibaren sayılır. Negatif bir değerse girdi dizisinin sonundan itibaren sayılır.

uzunluk

uzunluk verilmezse, başlangıç'tan dizi sonuna kadar herşey silinir. Belirtilmişse ve pozitifse başlangıç'tan dizi sonuna kadar belirtilen kadar eleman silinir. Belirtilmişse ve negatifse başlangıç'tan dizi sonuna kadar, dizi sonundan belirtilen sayıda eleman hariç herşey silinir. İpucu: başlangıç'tan dizi sonuna kadar herşeyin silindiği durumda yenisi de belirtilecekse uzunluk için count($girdi) ifadesini kullanın.

yenisi

yenisi dizisi belirtilmişse silinen elemanların yerine bu dizi konur.

Eğer başlangıç ve uzunluk ile hiçbir şey silinmiyorsa yenisi dizisi başlangıç konumunda dizi elemanlarının arasına yerleştirilir. Yerleştirme sırasında yenisi dizisinden değerlerin anahtarlarıyla değil tek başlarına aktarılacağını unutmayın.

Eğer yenisi tek bir elemandan ibaretse ve bir dizi değilse değeri array() ile dizi olarak belirtmek gerekli değildir.

Dönen Değerler

Diziden kaldırılan elemanlardan oluşan bir dizi ile döner.

Örnekler

Örnek 1 - array_splice() örnekleri

<?php
$input = array("red", "green", "blue", "yellow");
array_splice($input, 2);
// $input = array("red", "green")

$input = array("red", "green", "blue", "yellow");
array_splice($input, 1, -1);
// $input = array("red", "yellow")

$input = array("red", "green", "blue", "yellow");
array_splice($input, 1, count($input), "orange");
// $input = array("red", "orange")

$input = array("red", "green", "blue", "yellow");
array_splice($input, -1, 1, array("black", "maroon"));
// $input = array("red", "green", "blue", "black", "maroon")

$input = array("red", "green", "blue", "yellow");
array_splice($input, 3, 0, "purple");
// $input = array("red", "green", "blue", "purple", "yellow");
?>

Örnek 2 - array_splice() örnekleri

Aşağıdaki deyimler $input değerlerini aynı şekilde değiştirir:

<?php
array_push($input, $x, $y);
array_splice($input, count($input), 0, array($x, $y));
array_pop($input);
array_splice($input, -1);
array_shift($input);
array_splice($input, 0, 1);
array_unshift($input, $x, $y);
array_splice($input, 0, 0, array($x, $y));
$input[$x] = $y; // for arrays where key equals offset
array_splice($input, $x, 1, $y);
?>

Ayrıca Bakınız

  • array_slice() - Bir dizinin belli bir bölümünü döndürür
  • unset() - Belirtilen değişkeni tanımsız yapar
  • array_merge() - Belirtilen dizileri ardarda ekleyerek yeni bir dizi oluşturur

array_slice
array_sum
Dizi İşlevleri


Bir dizideki değerlerin toplamını hesaplar

array_splice
array_udiff_assoc
Dizi İşlevleri
PHP Manual

array_sum

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

array_sum — Bir dizideki değerlerin toplamını hesaplar

Açıklama

number array_sum ( array $dizi )

array_sum() işlevi belirtilen dizideki değerlerin toplamını bulur.

Değiştirgeler

dizi

Değerleri toplanacak dizi.

Dönen Değerler

Toplam bir tamsayı veya gerçek sayı olarak döner.

Sürüm Bilgisi

Sürüm: | Açıklama
4.2.1 | PHP'nin 4.2.1'den önceki sürümlerinde dizgeler sayılara dönüştürülerek aktarılan dizinin kendisi değiştirilirdi (çoğu zaman değerlerine bağlı olarak sıfıra dönüştürülürlerdi).

Örnekler

Örnek 1 - array_sum() örnekleri

<?php
$a = array(2, 4, 6, 8);
echo "sum(a) = " . array_sum($a) . "\n";

$b = array("a" => 1.2, "b" => 2.3, "c" => 3.4);
echo "sum(b) = " . array_sum($b) . "\n";
?>

Yukarıdaki örneğin çıktısı:

sum(a) = 20
sum(b) = 6.9

array_splice
array_udiff_assoc
Dizi İşlevleri


Veri karşılaştırması için bir geriçağırım işlevi kullanarak diziler arasındaki farkı indislerine de bakarak bulur

array_sum
array_udiff_uassoc
Dizi İşlevleri
PHP Manual

array_udiff_assoc

(PHP 5, PHP 7)

array_udiff_assoc — Veri karşılaştırması için bir geriçağırım işlevi kullanarak diziler arasındaki farkı indislerine de bakarak bulur

Açıklama

array array_udiff_assoc ( array $dizi1 , array $dizi2 [, array $ ... ], callback $veri_karş_işlevi )

Veri karşılaştırması için bir geriçağırım işlevi kullanarak diziler arasındaki farkı indislerine de bakarak bulur.

Bilginize: Bu işlevin bir n boyutlu dizinin tek bir boyutunu ele alacağına dikkat ediniz. Şüphesiz daha fazla sayıda boyutun hesaba katılmasını, örneğin array_udiff_assoc($dizi1[0], $dizi2[0], "veri_karş_işlevi"); gibi bir kullanımla sağlayabilirsiniz.

Değiştirgeler

dizi1

İlk dizi.

dizi2

İkinci dizi.

veri_karş_işlevi

Veri karşılaştırması için geriçağırım işlevi.

Kullanıcı tarafından sağlanır. Dizi değerlerinin aktarılacağı iki değiştirge kabul etmelidir. Birinci değiştirgenin ikinciden büyük, küçük veya ona eşit olduğu durumlarda sırayla sıfırdan büyük, sıfırdan küçük bir değer veya sıfır döndürmelidir.

Dönen Değerler

Diğer değiştirgelerin hiçbirinde mevcut olmayan tüm dizi1 değerlerini içeren bir dizi ile döner. Karşılaştırmada array_diff() ve array_udiff() işlevlerinden farklı olarak anahtarlar kullanılır. Verilerin karşılaştırması kullanıcı tarafından tanımlanmış bir işlev kullanılarak yapılır. Verileri karşılaştırmak için dahili bir işlev kullanan array_diff_assoc() işlevinden farklı olarak bu işlev kullanıcı tanımlı bir işlev kullanır.

Örnekler

Örnek 1 - array_udiff_assoc() örneği

<?php
class cr {
    private $priv_member;
    function cr($val)
    {
        $this->priv_member = $val;
    }

    static function comp_func_cr($a, $b)
    {
        if ($a->priv_member === $b->priv_member) return 0;
        return ($a->priv_member > $b->priv_member)? 1:-1;
    }
}

$a = array("0.1" => new cr(9), "0.5" => new cr(12), 0 => new cr(23),
                1=> new cr(4), 2 => new cr(-15),);
$b = array("0.2" => new cr(9), "0.5" => new cr(22), 0 => new cr(3),
                1=> new cr(4), 2 => new cr(-15),);

$result = array_udiff_assoc($a, $b, array("cr", "comp_func_cr"));
print_r($result);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [0.1] => cr Object
        (
            [priv_member:private] => 9
        )

    [0.5] => cr Object
        (
            [priv_member:private] => 12
        )

    [0] => cr Object
        (
            [priv_member:private] => 23
        )
)

Yukarıdaki örnekte gördüğünüz gibi "1" => new cr(4) çifti her iki dizide de mevcut olduğundan çıktıda gözükmemektedir.

Ayrıca Bakınız

  • array_diff() - Dizilerin farkını hesaplar
  • array_diff_assoc() - Dizilerin farkını hesaplarken ek olarak indisleri de karşılaştırır
  • array_diff_uassoc() - Dizilerin farkını hesaplarken ek olarak bir geriçağırım işlevi üzerinden indisleri de karşılaştırır
  • array_udiff() - Veri karşılaştırması için bir geriçağırım işlevi kullanarak diziler arasındaki farkı bulur
  • array_udiff_uassoc() - Veri ve indis karşılaştırması için bir geriçağırım işlevi kullanarak diziler arasındaki farkı indislerine de bakarak bulur
  • array_intersect() - Dizilerin kesişimini hesaplar
  • array_intersect_assoc() - Dizilerin kesişimini hesaplarken ek olarak indisleri de karşılaştırır
  • array_uintersect() - Veriyi bir geriçağırım işleviyle karşılaştırarak dizilerin kesişimini hesaplar
  • array_uintersect_assoc() - Veriyi bir geriçağırım işleviyle karşılaştırarak dizilerin kesişimini hesaplarken ek olarak indislere de bakar
  • array_uintersect_uassoc() - Veriyi ve indisleri bir geriçağırım işleviyle karşılaştırarak dizilerin kesişimini hesaplarken ek olarak indislere de bakar

array_sum
array_udiff_uassoc
Dizi İşlevleri


Veri ve indis karşılaştırması için bir geriçağırım işlevi kullanarak diziler arasındaki farkı indislerine de bakarak bulur

array_udiff_assoc
array_udiff
Dizi İşlevleri
PHP Manual

array_udiff_uassoc

(PHP 5, PHP 7)

array_udiff_uassoc — Veri ve indis karşılaştırması için bir geriçağırım işlevi kullanarak diziler arasındaki farkı indislerine de bakarak bulur

Açıklama

array array_udiff_uassoc ( array $dizi1 , array $dizi2 [, array $ ... ], callback $veri_karş_işlevi , callback $anh_karş_işlevi )

Veri ve indis karşılaştırması için bir geriçağırım işlevi kullanarak diziler arasındaki farkı indislerine de bakarak bulur.

Karşılaştırmada array_diff() ve array_udiff() işlevlerinden farklı olarak anahtarlar kullanılır.

Değiştirgeler

dizi1

İlk dizi.

dizi2

İkinci dizi.

veri_karş_işlevi

Veri karşılaştırması için geriçağırım işlevi.

Kullanıcı tarafından sağlanır. Dizi değerlerinin aktarılacağı iki değiştirge kabul etmelidir. Birinci değiştirgenin ikinciden büyük, küçük veya ona eşit olduğu durumlarda sırayla sıfırdan büyük, sıfırdan küçük bir değer veya sıfır döndürmelidir.

Verileri karşılaştırmak için dahili bir işlev kullanan array_diff_assoc() işlevinden farklı olarak bu işlev kullanıcı tanımlı bir işlev kullanır.

anh_karş_işlevi

Anahtarları (indisleri) ayrıca karşılaştırmak için bu işlev kullanılır. Anahtarları karşılaştırmak için dahili bir işlev kullanan array_udiff_assoc() işlevinden farklı olarak bu işlev kullanıcı tanımlı bir işlev kullanır.

Dönen Değerler

Diğer değiştirgelerin hiçbirinde mevcut olmayan tüm dizi1 değerlerini içeren bir dizi ile döner.

Örnekler

Örnek 1 - array_udiff_uassoc() örneği

<?php
class cr {
    private $priv_member;
    function cr($val)
    {
        $this->priv_member = $val;
    }

    static function comp_func_cr($a, $b)
    {
        if ($a->priv_member === $b->priv_member) return 0;
        return ($a->priv_member > $b->priv_member)? 1:-1;
    }

    static function comp_func_key($a, $b)
    {
        if ($a === $b) return 0;
        return ($a > $b)? 1:-1;
    }
}
$a = array("0.1" => new cr(9), "0.5" => new cr(12), 0 => new cr(23),
               1 => new cr(4), 2 => new cr(-15),);
$b = array("0.2" => new cr(9), "0.5" => new cr(22), 0 => new cr(3),
               1 => new cr(4), 2 => new cr(-15),);

$result = array_udiff_uassoc($a, $b, array("cr", "comp_func_cr"),
                                     array("cr", "comp_func_key"));
print_r($result);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [0.1] => cr Object
        (
            [priv_member:private] => 9
        )

    [0.5] => cr Object
        (
            [priv_member:private] => 12
        )

    [0] => cr Object
        (
            [priv_member:private] => 23
        )
)

Yukarıdaki örnekte gördüğünüz gibi "1" => new cr(4) çifti her iki dizide de mevcut olduğundan çıktıda gözükmemektedir. 2 geriçağırım işlevi belirtmeyi unutmayın.

Notlar

Bilginize: Bu işlevin bir n boyutlu dizinin tek bir boyutunu ele alacağına dikkat ediniz. Şüphesiz daha fazla sayıda boyutun hesaba katılmasını, örneğin array_udiff_uassoc($dizi1[0], $dizi2[0], "veri_karş_işlevi", "anh_karş_işlevi"); gibi bir kullanımla sağlayabilirsiniz.

Ayrıca Bakınız

  • array_diff() - Dizilerin farkını hesaplar
  • array_diff_assoc() - Dizilerin farkını hesaplarken ek olarak indisleri de karşılaştırır
  • array_udiff() - Veri karşılaştırması için bir geriçağırım işlevi kullanarak diziler arasındaki farkı bulur
  • array_udiff_assoc() - Veri karşılaştırması için bir geriçağırım işlevi kullanarak diziler arasındaki farkı indislerine de bakarak bulur
  • array_intersect() - Dizilerin kesişimini hesaplar
  • array_intersect_assoc() - Dizilerin kesişimini hesaplarken ek olarak indisleri de karşılaştırır
  • array_uintersect() - Veriyi bir geriçağırım işleviyle karşılaştırarak dizilerin kesişimini hesaplar
  • array_uintersect_assoc() - Veriyi bir geriçağırım işleviyle karşılaştırarak dizilerin kesişimini hesaplarken ek olarak indislere de bakar
  • array_uintersect_uassoc() - Veriyi ve indisleri bir geriçağırım işleviyle karşılaştırarak dizilerin kesişimini hesaplarken ek olarak indislere de bakar

array_udiff_assoc
array_udiff
Dizi İşlevleri


Veri karşılaştırması için bir geriçağırım işlevi kullanarak diziler arasındaki farkı bulur

array_udiff_uassoc
array_uintersect_assoc
Dizi İşlevleri
PHP Manual

array_udiff

(PHP 5, PHP 7)

array_udiff — Veri karşılaştırması için bir geriçağırım işlevi kullanarak diziler arasındaki farkı bulur

Açıklama

array array_udiff ( array $dizi1 , array $dizi2 [, array $ ... ], callback $veri_karş_işlevi )

Veri karşılaştırması için dahili bir işlev kullanan array_diff() işlevinden farklı olarak, veri karşılaştırması için bir geriçağırım işlevi kullanarak diziler arasındaki farkı bulur.

Değiştirgeler

dizi1

İlk dizi.

dizi2

İkinci dizi.

veri_karş_işlevi

Veri karşılaştırması için geriçağırım işlevi.

Kullanıcı tarafından sağlanır. Dizi değerlerinin aktarılacağı iki değiştirge kabul etmelidir. Birinci değiştirgenin ikinciden büyük, küçük veya ona eşit olduğu durumlarda sırayla sıfırdan büyük, sıfırdan küçük bir değer veya sıfır döndürmelidir.

Dönen Değerler

Diğer değiştirgelerin hiçbirinde mevcut olmayan tüm dizi1 değerlerini içeren bir dizi ile döner.

Örnekler

Örnek 1 - array_udiff() örneği

<?php
class cr {
    private $özel_üye;
    function cr($val)
    {
        $this->özel_üye = $val;
    }

    static function cr_karş_işlevi($a, $b)
    {
        if ($a->özel_üye === $b->özel_üye) return 0;
        return ($a->özel_üye > $b->özel_üye)? 1:-1;
    }
}
$a = array("0.1" => new cr(9), "0.5" => new cr(12), 0 => new cr(23),
               1 => new cr(4), 2 => new cr(-15),);
$b = array("0.2" => new cr(9), "0.5" => new cr(22), 0 => new cr(3),
               1 => new cr(4), 2 => new cr(-15),);

$sonuç = array_udiff($a, $b, array("cr", "cr_karş_işlevi"));
print_r($sonuç);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [0.5] => cr Object
        (
            [özel_üye:cr:private] => 12
        )

    [0] => cr Object
        (
            [özel_üye:cr:private] => 23
        )

)

Notlar

Bilginize: Bu işlevin bir n boyutlu dizinin tek bir boyutunu ele alacağına dikkat ediniz. Şüphesiz daha fazla sayıda boyutun hesaba katılmasını, örneğin array_udiff($dizi1[0], $dizi2[0], "veri_karş_işlevi"); gibi bir kullanımla sağlayabilirsiniz.

Ayrıca Bakınız

  • array_diff() - Dizilerin farkını hesaplar
  • array_diff_assoc() - Dizilerin farkını hesaplarken ek olarak indisleri de karşılaştırır
  • array_diff_uassoc() - Dizilerin farkını hesaplarken ek olarak bir geriçağırım işlevi üzerinden indisleri de karşılaştırır
  • array_udiff_assoc() - Veri karşılaştırması için bir geriçağırım işlevi kullanarak diziler arasındaki farkı indislerine de bakarak bulur
  • array_udiff_uassoc() - Veri ve indis karşılaştırması için bir geriçağırım işlevi kullanarak diziler arasındaki farkı indislerine de bakarak bulur
  • array_intersect() - Dizilerin kesişimini hesaplar
  • array_intersect_assoc() - Dizilerin kesişimini hesaplarken ek olarak indisleri de karşılaştırır
  • array_uintersect() - Veriyi bir geriçağırım işleviyle karşılaştırarak dizilerin kesişimini hesaplar
  • array_uintersect_assoc() - Veriyi bir geriçağırım işleviyle karşılaştırarak dizilerin kesişimini hesaplarken ek olarak indislere de bakar
  • array_uintersect_uassoc() - Veriyi ve indisleri bir geriçağırım işleviyle karşılaştırarak dizilerin kesişimini hesaplarken ek olarak indislere de bakar

array_udiff_uassoc
array_uintersect_assoc
Dizi İşlevleri


Veriyi bir geriçağırım işleviyle karşılaştırarak dizilerin kesişimini hesaplarken ek olarak indislere de bakar

array_udiff
array_uintersect_uassoc
Dizi İşlevleri
PHP Manual

array_uintersect_assoc

(PHP 5, PHP 7)

array_uintersect_assoc — Veriyi bir geriçağırım işleviyle karşılaştırarak dizilerin kesişimini hesaplarken ek olarak indislere de bakar

Açıklama

array array_uintersect_assoc ( array $dizi1 , array $dizi2 [, array $ ... ], callback $veri_karş_işlevi )

Veriyi bir geriçağırım işleviyle karşılaştırarak dizilerin kesişimini hesaplarken ek olarak indislere de bakar.

array_uintersect() işlevinin tersine karşılaştırmada anahtarlar kullanılır. Veri bir karşılaştırma işlevi kullanılarak karşılaştırılır.

Değiştirgeler

dizi1

İlk dizi.

dizi2

İkinci dizi.

veri_karş_işlevi

Karşılaştırma için kullanıcı tarafından sağlanan bir geriçağırım işlevi kullanılır. İşlev, ilk değiştirgenin ikinciden büyük, küçük veya ikinciye eşit olması durumlarında sırayla sıfırdan büyük, küçük bir değer veya sıfır döndürmelidir.

Dönen Değerler

Tüm değiştirgeleri ifade etmek üzere dizi1'in tüm değerlerini içeren bir dizi ile döner.

Örnekler

Örnek 1 - array_uintersect_assoc() örneği

<?php
$dizi1 = array("a" => "mor", "b" => "sarı", "c" => "mavi", "kırmızı");
$dizi2 = array("a" => "MOR", "B" => "sarı", "yeşil", "kırmızı");

print_r(array_uintersect_assoc($dizi1, $dizi2, "strcasecmp"));
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [a] => mor
)

Ayrıca Bakınız

  • array_uintersect() - Veriyi bir geriçağırım işleviyle karşılaştırarak dizilerin kesişimini hesaplar
  • array_intersect_assoc() - Dizilerin kesişimini hesaplarken ek olarak indisleri de karşılaştırır
  • array_intersect_uassoc() - Dizilerin kesişimini hesaplarken ek olarak bir geriçağırım işlevi üzerinden indisleri de karşılaştırır
  • array_uintersect_uassoc() - Veriyi ve indisleri bir geriçağırım işleviyle karşılaştırarak dizilerin kesişimini hesaplarken ek olarak indislere de bakar

array_udiff
array_uintersect_uassoc
Dizi İşlevleri


Veriyi ve indisleri bir geriçağırım işleviyle karşılaştırarak dizilerin kesişimini hesaplarken ek olarak indislere de bakar

array_uintersect_assoc
array_uintersect
Dizi İşlevleri
PHP Manual

array_uintersect_uassoc

(PHP 5, PHP 7)

array_uintersect_uassoc — Veriyi ve indisleri bir geriçağırım işleviyle karşılaştırarak dizilerin kesişimini hesaplarken ek olarak indislere de bakar

Açıklama

array array_uintersect_uassoc ( array $dizi1 , array $dizi2 [, array $ ... ], callback $veri_karş_işlevi , callback $anh_karş_işlevi )

Veriyi ve indisleri bir geriçağırım işleviyle karşılaştırarak dizilerin kesişimini hesaplarken ek olarak indislere de bakar. array_uintersect() işlevinin tersine karşılaştırmada anahtarlar kullanılır. Veri ve anahtarlar ayrı karşılaştırma işlevleri kullanılarak karşılaştırılırlar.

Değiştirgeler

dizi1

İlk dizi.

dizi2

İkinci dizi.

veri_karş_işlevi

Karşılaştırma için kullanıcı tarafından sağlanan bir geriçağırım işlevi kullanılır. İşlev, ilk değiştirgenin ikinciden büyük, küçük veya ikinciye eşit olması durumlarında sırayla sıfırdan büyük, küçük bir değer veya sıfır döndürmelidir.

anh_karş_işlevi

Anahtarları karşılaştırmak için geriçağırım işlevi.

Dönen Değerler

Tüm değiştirgeleri ifade etmek üzere dizi1'in tüm değerlerini içeren bir dizi ile döner.

Örnekler

Örnek 1 - array_uintersect_uassoc() örneği

<?php
$dizi1 = array("a" => "mor", "b" => "sarı", "c" => "mavi", "kırmızı");
$dizi2 = array("a" => "MOR", "B" => "sarı", "yeşil", "kırmızı");

print_r(array_uintersect_uassoc($dizi1, $dizi2, "strcasecmp", "strcasecmp"));
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [a] => mor
    [b] => sarı
)

Ayrıca Bakınız

  • array_uintersect() - Veriyi bir geriçağırım işleviyle karşılaştırarak dizilerin kesişimini hesaplar
  • array_intersect_assoc() - Dizilerin kesişimini hesaplarken ek olarak indisleri de karşılaştırır
  • array_intersect_uassoc() - Dizilerin kesişimini hesaplarken ek olarak bir geriçağırım işlevi üzerinden indisleri de karşılaştırır
  • array_uintersect_assoc() - Veriyi bir geriçağırım işleviyle karşılaştırarak dizilerin kesişimini hesaplarken ek olarak indislere de bakar

array_uintersect_assoc
array_uintersect
Dizi İşlevleri


Veriyi bir geriçağırım işleviyle karşılaştırarak dizilerin kesişimini hesaplar

array_uintersect_uassoc
array_unique
Dizi İşlevleri
PHP Manual

array_uintersect

(PHP 5, PHP 7)

array_uintersect — Veriyi bir geriçağırım işleviyle karşılaştırarak dizilerin kesişimini hesaplar

Açıklama

array array_uintersect ( array $dizi1 , array $dizi2 [, array $ ... ], callback $işlev )

Veriyi bir geriçağırım işleviyle karşılaştırarak dizilerin kesişimini hesaplar.

Değiştirgeler

dizi1

İlk dizi.

dizi2

İkinci dizi.

işlev

Karşılaştırma için geriçağırım işlevi.

Karşılaştırma için kullanıcı tarafından sağlanan bir geriçağırım işlevi kullanılır. İşlev, ilk değiştirgenin ikinciden büyük, küçük veya ikinciye eşit olması durumlarında sırayla sıfırdan büyük, küçük bir değer veya sıfır döndürmelidir.

Dönen Değerler

Tüm değiştirgeleri ifade etmek üzere dizi1'in tüm değerlerini içeren bir dizi ile döner.

Örnekler

Örnek 1 - array_uintersect() örneği

<?php
$dizi1 = array("a" => "mor", "b" => "sarı", "c" => "mavi", "kırmızı");
$dizi2 = array("a" => "MOR", "B" => "sarı", "yeşil", "kırmızı");

print_r(array_uintersect($dizi1, $dizi2, "strcasecmp"));
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [a] => mor
    [b] => sarı
    [0] => kırmızı
)

Ayrıca Bakınız

  • array_intersect() - Dizilerin kesişimini hesaplar
  • array_intersect_assoc() - Dizilerin kesişimini hesaplarken ek olarak indisleri de karşılaştırır
  • array_uintersect_assoc() - Veriyi bir geriçağırım işleviyle karşılaştırarak dizilerin kesişimini hesaplarken ek olarak indislere de bakar
  • array_uintersect_uassoc() - Veriyi ve indisleri bir geriçağırım işleviyle karşılaştırarak dizilerin kesişimini hesaplarken ek olarak indislere de bakar

array_uintersect_uassoc
array_unique
Dizi İşlevleri


Diziden yinelenen değerleri siler

array_uintersect
array_unshift
Dizi İşlevleri
PHP Manual

array_unique

(PHP 4 >= 4.0.1, PHP 5, PHP 7)

array_unique — Diziden yinelenen değerleri siler

Açıklama

array array_unique ( array $dizi [, int $seçenekler = SORT_STRING ] )

dizi dizisinden yinelenen değerleri sildikten sonra yeni diziyi döndürür.

Anahtarlar korunacaktır. array_unique() önce değerleri birer dizge olarak sıralar, sonra her eleman için saptadığı ilk anahtarı tutar ve diğer tüm anahtarları yoksayar. Burada bahsedilen ilk anahtar girdi olarak verilen (sıralanmamış) dizinin ilk elemanı ile ilişkili anahtar olmayabilir.

Bilginize: İki elemanın eşit kabul edilebilmesi için şu şart sağlanmış olmalıdır: (string) $elem1 === (string) $elem2. Başka bir deyişle: İki elemanın dizgesel gösterimleri aynıysa bu iki eleman birbirine eşittir. İlk eleman daima kullanılır.

Değiştirgeler

dizi

Üzerinde işlem yapılacak dizi.

seçenekler

İsteğe bağlı bu değiştirge ile işlevin davranışını değiştirebilirsiniz.

Olası seçenekler:

  • SORT_REGULAR - öğeler normal olarak karşılaştırılır (türleri değiştirilmez).
  • SORT_NUMERIC - öğeler sayısal olarak karşılaştırılır
  • SORT_STRING - üyeler dizgesel olarak karşılaştırılır
  • SORT_LOCALE_STRING - öğeler dizgesel olarak yerele göre karşılaştırılır. PHP 4.4.0 ve 5.0.2'de eklermiştir. PHP 6 öncesinde, sistem yereli setlocale() kullanılarak değiştirilirdi. PHP 6'dan itibaren i18n_loc_set_default() işlevini kullanmalısınız.

Dönen Değerler

Yinelenen değerler içermeyen bir dizi döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.2.9 | Seçimlik seçenekler değiştirgesi, öntanımlı SORT_REGULAR değeri ile eklendi. 5.2.9 öncesinde işlev dahili olarak SORT_STRING ile diziyi sıralardı.
5.2.10 | seçenekler değiştirgesinin öntanımlı değeri tekrar SORT_STRING yapıldı.

Örnekler

Örnek 1 - array_unique() örneği

<?php
$girdi = array("a" => "yeşil", "kırmızı", "b" => "yeşil", "mavi", "kırmızı");
$sonuç = array_unique($girdi);
print_r($sonuç);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [a] => yeşil
    [0] => kırmızı
    [1] => mavi
)

Örnek 2 - array_unique() ve türler

<?php
$input = array(4, "4", "3", 4, 3, "3");
$result = array_unique($input);
var_dump($result);
?>

Yukarıdaki örneğin çıktısı:

array(2) {
  [0] => int(4)
  [2] => string(1) "3"
}

Notlar

Bilginize: array_unique() çok boyutlu dizilerle çalışmak üzere tasarlanmamıştır.

array_uintersect
array_unshift
Dizi İşlevleri


Bir dizinin başlangıcına bir veya daha fazla eleman ekler

array_unique
array_values
Dizi İşlevleri
PHP Manual

array_unshift

(PHP 4, PHP 5, PHP 7)

array_unshift — Bir dizinin başlangıcına bir veya daha fazla eleman ekler

Açıklama

int array_unshift ( array &$dizi , mixed $dğş [, mixed $... ] )

array_unshift() işlevi aktarılan elemanları array dizisinin önüne ekler. Elemanlar diziye işleve aktarıldıkları sıra ile eklenirler. Sayısal anahtarlar sıfırdan başlayacak şekilde değiştirilir fakat dizgesel anahtarlara dokunulmaz.

Değiştirgeler

dizi

İşleme sokulacak dizi.

dğş

Diziye eklenecek değişken.

Dönen Değerler

Dizeye eklenen üye sayısı ile döner.

Örnekler

Örnek 1 - array_unshift() örneği

<?php
$liste = array("ayva", "muz");
array_unshift($liste, "elma", "armut");
print_r($liste);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [0] => elma
    [1] => armut
    [2] => ayva
    [3] => muz
)

Ayrıca Bakınız

  • array_shift() - Dizini başlangıcından bir eleman çeker
  • array_push() - Belli sayıda elemanı dizinin sonuna ekler
  • array_pop() - Dizinin sonundaki elemanı diziden çıkartır

array_unique
array_values
Dizi İşlevleri


Bir dizinin tüm değerlerini döndürür

array_unshift
array_walk_recursive
Dizi İşlevleri
PHP Manual

array_values

(PHP 4, PHP 5, PHP 7)

array_values — Bir dizinin tüm değerlerini döndürür

Açıklama

array array_values ( array $dizi )

array_values() işlevi dizi dizisindeki tüm değerleri sayısal olarak indisleyerek döndürür.

Değiştirgeler

dizi

İşlenecek dizi.

Dönen Değerler

Değerleri indislenmiş bir dizi döndürür.

Örnekler

Örnek 1 - array_values() örneği

<?php
$dizi = array("beden" => "XL", "renk" => "sarı");
print_r(array_values($dizi));
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [0] => XL
    [1] => gold
)

Ayrıca Bakınız

  • array_keys() - Bir dizideki tüm anahtarları veya bir anahtar altkümesini döndürür

array_unshift
array_walk_recursive
Dizi İşlevleri


Bir dizinin ardışık olarak her üyesine kullanıcı tanımlı bir işlevi uygular

array_values
array_walk
Dizi İşlevleri
PHP Manual

array_walk_recursive

(PHP 5, PHP 7)

array_walk_recursive — Bir dizinin ardışık olarak her üyesine kullanıcı tanımlı bir işlevi uygular

Açıklama

bool array_walk_recursive ( array &$dizi , callback $işlev [, mixed $veri ] )

dizi dizisinin her elemanına kullanıcı tarafından tanımlanmış işlev işlevini uygular. Bu işlev iç içe dizilerde ardışık işlem yapar.

Değiştirgeler

dizi

İşleme sokulacak dizi.

işlev

Normalde, işlev iki değiştirge alır. İlki dizi değiştirgesi ikincisi ise indis veya anahtardır.

Bilginize:

Eğer işlev işlevinin doğrudan dizinin kendisi üzerinde işlem yapması gerekiyorsa işlevin ilk değiştirgesini bir gönderim olarak belirtin. Böylece elemanlar üzerinde yapılan her değişiklik özgün dizide yapılmış olur.

veri

Eğer isteğe bağlı veri değiştirgesi belirtilmişse, değeri işlev işlevine üçüncü değiştirge olarak aktarılır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - array_walk_recursive() örneği

<?php
$tatlı = array('a' => 'elma', 'b' => 'muz');
$meyveler = array('tatlı' => $tatlı, 'ekşi' => 'limon');

function baskı_deneme($öğe, $anh)
{
    echo "$öğe $anh\n";
}

array_walk_recursive($meyveler, 'baskı_deneme');
?>

Yukarıdaki örneğin çıktısı:

elma a
muz b
limon ekşi

Farkedeğceğiniz gibi 'tatlı' anahtarı hiç gösterilmedi. Bir dizi içeren elemanların anahtarları işleve aktarılmaz.

Ayrıca Bakınız

  • array_walk() - Bir dizinin her üyesine kullanıcı tanımlı bir işlevi uygular
  • callback türü hakkında bilgi

array_values
array_walk
Dizi İşlevleri


Bir dizinin her üyesine kullanıcı tanımlı bir işlevi uygular

array_walk_recursive
array
Dizi İşlevleri
PHP Manual

array_walk

(PHP 4, PHP 5, PHP 7)

array_walk — Bir dizinin her üyesine kullanıcı tanımlı bir işlevi uygular

Açıklama

bool array_walk ( array &$dizi , callback $işlev [, mixed $veri ] )

dizi dizisinin her elemanına kullanıcı tarafından tanımlanmış işlev işlevini uygular.

array_walk() işlevi dizinin dahili göstericisinin konumunda etkilenmez. Dizinin dahili göstericisini dikkate almaksızın dizi elemanları üzerinde sırayla işlem yapar.

Değiştirgeler

dizi

İşleme sokulacak dizi.

işlev

Normalde, işlev iki değiştirge alır. İlki dizi değiştirgesi ikincisi ise indis veya anahtardır.

Bilginize:

Eğer işlev işlevinin doğrudan dizinin kendisi üzerinde işlem yapması gerekiyorsa işlevin ilk değiştirgesini bir gönderim olarak belirtin. Böylece elemanlar üzerinde yapılan her değişiklik özgün dizide yapılmış olur.

Kullanıcılar ekleme/silme gibi işlemlerle geriçağırım işlevinde işlem görmekte olan dizi üzerinde değişiklik yapmamalıdırlar. Eğer array_walk() uygulaması sırasında dizi değişikliğe uğrarsa bu işlevin davranışı beklendiği gibi olmayabilir.

veri

Eğer isteğe bağlı veri değiştirgesi belirtilmişse, değeri işlev işlevine üçüncü değiştirge olarak aktarılır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

Eğer işlev belirtilenden daha fazla değiştirge gerektiriyorsa array_walk() işlevinin yaptığı her işlev çağrısında E_WARNING seviyesinde bir uyarı üretilir. Bu uyarılar array_walk() işlevinin adının önüne bir @ işleci getirilerek veya error_reporting() kullanılarak bastırılabilir

Örnekler

Örnek 1 - array_walk() örneği

<?php
$fruits = array("d" => "limon", "a" => "ayva", "b" => "muz", "c" => "elma");

function test_alter(&$item1, $key, $prefix)
{
    $item1 = "$prefix: $item1";
}

function test_print($item2, $key)
{
    echo "$key. $item2<br />\n";
}

echo "Önce ...:\n";
array_walk($fruits, 'test_print');

array_walk($fruits, 'test_alter', 'fruit');
echo "... ve sonra:\n";

array_walk($fruits, 'test_print');
?>

Yukarıdaki örneğin çıktısı:

Önce ...:
d. limon
a. ayva
b. muz
c. elma
... ve sonra:
d. meyve: limon
a. meyve: ayva
b. meyve: muz
c. meyve: elma

Ayrıca Bakınız

  • array_walk_recursive() - Bir dizinin ardışık olarak her üyesine kullanıcı tanımlı bir işlevi uygular
  • iterator_apply() - Call a function for every element in an iterator
  • create_function() - Bir anonim (lamda tarzı) işlev oluşturur
  • list() - Değişkenlere bir dizi gibi atama yapar
  • each() - Bir diziden, gösterici konumundaki anahtar değer çiftini döndürdükten sonra göstericiyi bir ilerletir
  • call_user_func_array() - Değiştirgelerin bir dizi olarak verildiği kullanıcı işlevini çağırır
  • array_map() - Belirtilen dizilerin elemanlarına geriçağırım işlevini uygular
  • callback türü hakkında bilgi
  • foreach

array_walk_recursive
array
Dizi İşlevleri


Bir dizi oluşturur

array_walk
arsort
Dizi İşlevleri
PHP Manual

array

(PHP 4, PHP 5, PHP 7)

array — Bir dizi oluşturur

Açıklama

array array ([ mixed $... ] )

Bir dizi oluşturur. Diziler hakkında ayrıntılı bilgi edinmek için array türünün belgesine bakınız.

Değiştirgeler

...

Burada, "indis => değerler", sözdizimi virgüllerle ayrılarak indis ve değerler tanımlanır. İndis string veya integer türünde olabilir. İndis belirtilmezse 0'dan başlamak üzere özdevinimli olarak üretilir. İndis olarak bir tamsayı belirtilirse üretilecek sonraki indis, indis + 1 olacaktır. Eğer birbirinin aynı iki indis belirtilirse sonuncusu öncekini geçersiz kılar.

Son tanımlanan dizi elemanından sonra bir virgül konursa, yararsız olmakla beraber sözdizimsel olarak geçerlidir.

Dönen Değerler

Değiştirgelerle tanımlanan diziyi döndürür. Değiştirgelerde => işleci ile bir indis belirtilebilir. Diziler hakkında daha ayrıntılı bilgi için array türünün belgesine bakınız.

Örnekler

Aşağıdaki örnekte iki boyutlu bir dizinin nasıl oluşturulduğu, ilişkisel bir dizide anahtarların nasıl belirtildiği ve normal dizilerde sayısal indislerin nasıl atlanarak devam edileceği gösterilmiştir.

Örnek 1 - array() örneği

<?php
$fruits = array (
    "meyveler"  => array("a" => "portakal", "b" => "muz", "c" => "elma"),
    "numaralar" => array(1, 2, 3, 4, 5, 6),
    "delikler"   => array("ilk", 5 => "ikinci", "üçüncü")
);
?>

Örnek 2 array() ile özdevinimli indis üretimi

<?php
$array = array(1, 1, 1, 1,  1, 8 => 1,  4 => 1, 19, 3 => 13);
print_r($array);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [0] => 1
    [1] => 1
    [2] => 1
    [3] => 13
    [4] => 1
    [8] => 1
    [9] => 19
)

Dikkat ederseniz, '3' indisi iki kere tanımlandı. Ancak son değer olan 13 saklandı. 4 indisi 8 indisinden sonra tanımlandı ve en büyük indis 8 olduğundan ondan sonra üretilen indis 9 oldu.

Bu örnek 1 indisinden başlayan bir dizi oluşturuyor.

Örnek 3 - İlk indisi 1 olan dizi üretimi

<?php
$firstquarter = array(1 => 'January', 'February', 'March');
print_r($firstquarter);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [1] => January
    [2] => February
    [3] => March
)

Perl'de olduğu gibi çift tırnak içine alınmış bir dizi içindeki bir değere erişebilirsiniz. Ancak PHP'de diziyi kaşlı ayraçlar arasına almak zorunda değilsiniz.

Örnek 4 - Çift tırnak içine alınmış bir diziye erişim

<?php

$foo = array('bar' => 'baz');
echo "Hello {$foo['bar']}!"; // Çıktısı: Hello baz!

?>

Notlar

Bilginize:

array() normal bir işlev değil, dizileri birebir göstermekte kullanılan bir dil oluşumudur.

Ayrıca Bakınız

  • array_pad() - Dizi boyutunu belirtilen boyuta çıkarırken, yeni elemanlara belirtilen değeri yerleştirir
  • list() - Değişkenlere bir dizi gibi atama yapar
  • count() - Bir dizideki eleman sayısını veya bir nesnedeki özellik sayısını döndürür
  • range() - Belli bir eleman aralığını içeren bir dizi oluşturur
  • foreach
  • array türü

array_walk
arsort
Dizi İşlevleri


Bir dizinin değerlerini anahtarlarıyla ilişkilerini bozmadan tersine sıralar

array
asort
Dizi İşlevleri
PHP Manual

arsort

(PHP 4, PHP 5, PHP 7)

arsort — Bir dizinin değerlerini anahtarlarıyla ilişkilerini bozmadan tersine sıralar

Açıklama

bool arsort ( array &$dizi [, int $seçenekler = SORT_REGULAR ] )

Bu işlev bir dizinin değerlerini anahtarlarıyla ilişkilerini bozmadan tersine sıralar.

Esas olarak, asıl eleman sırasının önemli olduğu ilişkisel dizilerin sıralanmasında kullanılır.

Değiştirgeler

dizi

Sıralanacak dizi.

seçenekler

Bu değiştirge ile sıralamayı değiştirebilirsiniz. Bu değiştirgede belirtilebilecek değerler için sort() işlevine bakınız.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - arsort() örneği

<?php
$fruits = array("d" => "lemon", "a" => "orange", "b" => "banana", "c" => "apple");
arsort($fruits);
foreach ($fruits as $key => $val) {
    echo "$key = $val\n";
}
?>

Yukarıdaki örneğin çıktısı:

a = orange
d = lemon
b = banana
c = apple

Meyveler alfabetik olarak ters sırada basılırken indisleri ile ilişkileri korunmuştur.

Ayrıca Bakınız

  • asort() - Bir dizinin değerlerini anahtarlarıyla ilişkilerini bozmadan sıralar
  • Dizilerde Sıralama

array
asort
Dizi İşlevleri


Bir dizinin değerlerini anahtarlarıyla ilişkilerini bozmadan sıralar

arsort
compact
Dizi İşlevleri
PHP Manual

asort

(PHP 4, PHP 5, PHP 7)

asort — Bir dizinin değerlerini anahtarlarıyla ilişkilerini bozmadan sıralar

Açıklama

bool asort ( array &$dizi [, int $seçenekler = SORT_REGULAR ] )

Bu işlev bir dizinin değerlerini anahtarlarıyla ilişkilerini bozmadan sıralar. Esas olarak, asıl eleman sırasının önemli olduğu ilişkisel dizilerin sıralanmasında kullanılır.

Değiştirgeler

dizi

Sıralanacak dizi.

seçenekler

Bu değiştirge ile sıralamayı değiştirebilirsiniz. Bu değiştirgede belirtilebilecek değerler için sort() işlevine bakınız.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - asort() örneği

<?php
$fruits = array("d" => "lemon", "a" => "orange", "b" => "banana", "c" => "apple");
asort($fruits);
foreach ($fruits as $key => $val) {
    echo "$key = $val\n";
}
?>

Yukarıdaki örneğin çıktısı:

c = apple
b = banana
d = lemon
a = orange

Meyveler alfabetik sırada basılırken indisleri ile ilişkileri korunmuştur.

Ayrıca Bakınız

  • arsort() - Bir dizinin değerlerini anahtarlarıyla ilişkilerini bozmadan tersine sıralar
  • Dizilerde Sıralama

arsort
compact
Dizi İşlevleri


Değişkenlerle değerlerinden oluşan bir dizi oluşturur

asort
count
Dizi İşlevleri
PHP Manual

compact

(PHP 4, PHP 5, PHP 7)

compact — Değişkenlerle değerlerinden oluşan bir dizi oluşturur

Açıklama

array compact ( mixed $değişken [, mixed $... ] )

Değişkenlerle değerlerinden oluşan bir dizi oluşturur.

compact() işlevi, değişken ile belirtilen değişkenlerden ismi simge tablosunda yer alanları, değerleriyle birlikte çıktılayacağı diziye ekler; değişken isimleri anahtar olarak kullanılır. Özetle, extract() işlevinin yaptığının tersini yapar.

Tanımsız değişkenler basitçe atlanır.

Değiştirgeler

değişken

compact() işlevi bu değiştirgeden sınırsız sayıda kabul edebilir. Her değiştirge değişken ismini içeren bir dizge olabileceği gibi değişken isimlerinden oluşan bir dizi de olabilir. Değişken isimlerini içeren dizi, başka değişken dizileri içerebilir; böyle bir durumda dizi ardışık olarak işlenir.

Dönen Değerler

Belirtilen değişkenlerin tanımlı olanlarını içeren bir dizi ile döner.

Örnekler

Örnek 1 - compact() örneği

<?php
$il  = "Antalya";
$ilçe = "Alanya";
$olay = "UYARI";

$idari_bölümler = array("il", "ilçe");

$sonuç = compact("olay", "hiçbir_şey", $idari_bölümler);
print_r($sonuç);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [olay] => UYARI
    [il] => Antalya
    [ilçe] => Alanya
)

Notlar

Bilginize:

Değişken değişkenler işlevlerin içinde PHP'nin süper küresel dizileri ile kullanılamayacağından süper küresel diziler compact() işlevine değiştirge olarak aktarılamaz.

Ayrıca Bakınız

  • extract() - Bir dizideki değişkenleri simge tablosuna dahil eder

asort
count
Dizi İşlevleri


Bir dizideki eleman sayısını veya bir nesnedeki özellik sayısını döndürür

compact
current
Dizi İşlevleri
PHP Manual

count

(PHP 4, PHP 5, PHP 7)

count — Bir dizideki eleman sayısını veya bir nesnedeki özellik sayısını döndürür

Açıklama

int count ( mixed $girdi [, int $kip = COUNT_NORMAL ] )

Bir dizideki eleman sayısını veya bir nesnedeki özellik sayısını döndürür.

Nesneler için, eğer SPL kuruluysa Countable tarafından gerçeklenen count() yöntemini sonucu almak için kullanabilirsiniz. Nesne arayüzü sadece bir yönteme, count() işlevinden dönen değeri döndüren count() yöntemine sahiptir.

PHP'de kullanılan dizilerin nasıl gerçeklendiği ile ilgili daha ayrıntılı bilgi edinmek için array sayfasına bakınız.

Değiştirgeler

girdi

Dizi veya nesne.

kip

İsteğe bağlı kip değiştirgesine COUNT_RECURSIVE (veya 1) atanırsa, count() işlevi diziyi ardışık olarak sayar. Böylece çok boyutlu bir dizinin bütün elemanları sayılabilir. count() sonsuz iç içeliği algılayacak yetenekte değildir.

Dönen Değerler

Bir dizi dışında her şey tek elemanlı bir dizi kabul edilebileceğinden işlev daima girdi'deki eleman sayısını döndürür.

Eğer girdi array veya object türünde değilse Countable arayüzü, 1 döndürür. Tek istisnası girdi'nin NULL olması durumu olup böyle bir durumda 0 döner.

Dikkat

count() işlevi atanmamış bir değişken için 0 döndürebilir, fakat değişken boş bir dizi ile ilklendirilmişse de 0 döndürecektir. Değişkenin tanımlı olup olmadığını isset() ile sınayabilirsiniz.

Sürüm Bilgisi

Sürüm: | Açıklama
4.2.0 | İsteğe bağlı kip değiştirgesi eklendi.

Örnekler

Örnek 1 - count() örneği

<?php
$a[0] = 1;
$a[1] = 3;
$a[2] = 5;
$sonuç = count($a);
// $sonuç == 3

$b[0]  = 7;
$b[5]  = 9;
$b[10] = 11;
$sonuç = count($b);
// $sonuç == 3

$sonuç = count(null);
// $sonuç == 0

$sonuç = count(false);
// $sonuç == 1
?>

Örnek 2 - Ardışık count() örneği

<?php
$food = array('fruits' => array('orange', 'banana', 'apple'),
              'veggie' => array('carrot', 'collard', 'pea'));

// ardışık sayım
echo count($food, COUNT_RECURSIVE); // 8

// normal sayım
echo count($food); // 2

?>

Ayrıca Bakınız

  • is_array() - Değişkenin bir dizi içerip içermediğine bakar
  • isset() - Değişken tanımlı mı diye bakar
  • strlen() - Dizge uzunluğunu döndürür

compact
current
Dizi İşlevleri


Bir diziden gösterici konumundaki elemanı döndürür

count
each
Dizi İşlevleri
PHP Manual

current

(PHP 4, PHP 5, PHP 7)

current — Bir diziden gösterici konumundaki elemanı döndürür

Açıklama

mixed current ( array &$dizi )

Her dizinin, ilklendirme anında ilk elemanına konumlanan bir göstericisi vardır.

Değiştirgeler

dizi

Üzerinde işlem yapılacak dizi.

Dönen Değerler

current() işlevi dizinin dahili göstericinin işaret ettiği elemanı döndürür. Göstericinin yeri değiştirilmez. Eğer gösterici sonuncu elemanın sonrasını işaret ediyorsa veya dizi boşsa FALSE döner.

Uyarı

Bu işlev mantıksal FALSE değeriyle dönebileceği gibi FALSE olarak değerlendirilebilecek mantıksal olmayan bir değerle de dönebilir. Bu konuda daha fazla bilgi edinmek için Mantıksal Değerler bölümüne bakabilirsiniz. Bu işlevden dönen değeri sınamak için === işlecini kullanınız.

Örnekler

Örnek 1 - current() örneği

<?php
$araç = array('tabanvay', 'bisiklet', 'otomobil', 'uçak');
$kip = current($araç); // $kip = 'tabanvay';
$kip = next($araç);    // $kip = 'bisiklet';
$kip = current($araç); // $kip = 'bisiklet';
$kip = next($araç);    // $kip = 'otomobil';
$kip = prev($araç);    // $kip = 'bisiklet';
$kip = end($araç);     // $kip = 'uçak';
$kip = current($araç); // $kip = 'uçak';

$arr = array();
var_dump(current($arr)); // bool(false)

$arr = array(array());
var_dump(current($arr)); // array(0) { }
?>

Notlar

Bilginize: Bir dizi sonunu boolean FALSE değerinden ayıramazsınız. element. FALSE değerli elemanlar içeren bir dizide bilinçli olarak ilerlemenin en doğru yolu each() kullanmaktır.

Ayrıca Bakınız

  • end() - Bir dizinin dahili göstericisini sonuncu elemana konumlandırır
  • key() - Bir diziden gösterici konumundaki anahtarı döndürür
  • each() - Bir diziden, gösterici konumundaki anahtar değer çiftini döndürdükten sonra göstericiyi bir ilerletir
  • prev() - Dahili dizi göstericisini bir geriletir
  • reset() - Bir dizinin dahili göstericisini ilk elemana konumlar
  • next() - Dahili dizi göstericisini bir ilerletir

count
each
Dizi İşlevleri


Bir diziden, gösterici konumundaki anahtar değer çiftini döndürdükten sonra göstericiyi bir ilerletir

current
end
Dizi İşlevleri
PHP Manual

each

(PHP 4, PHP 5, PHP 7)

each — Bir diziden, gösterici konumundaki anahtar değer çiftini döndürdükten sonra göstericiyi bir ilerletir

Açıklama

array each ( array &$dizi )

Belirtilen diziden, gösterici konumundaki anahtar değer çiftini döndürür ve göstericiyi bir ilerletir.

each() işini bitirdikten sonra dizi göstericisi bir sonraki elemana konumlanır; eğer gösterici zaten sonuncu elemandaysa gösterici sonuncudan sonraki olmayan elemana konumlanır. Diziyi baştan taramak isterseniz göstericiyi reset() ile dizinin başlangıcına taşımanız gerekir.

Değiştirgeler

dizi

Üzerinde işlem yapılacak dizi.

Dönen Değerler

dizi dizisinin göstericisinin üzerinde bulunduğu anahtar değer çifti ile döner. Bu çift dört elemanlı, 0, 1, key ve value anahtarlarına sahip bir dizi olarak döner. 0 ve key elemanları anahtarı, 1 ve value ise değeri içerir.

Eğer gösterici sonuncu dizi elemanının sonrasındaysa each() işlevi FALSE döndürür.

Örnekler

Örnek 1 - each() örnekleri

<?php
$foo = array("bob", "fred", "jussi", "jouni", "egon", "marliese");
$bar = each($foo);
print_r($bar);
?>

$bar şu anahtar değer çiftlerini içerir:

Array
(
    [1] => bob
    [value] => bob
    [0] => 0
    [key] => 0
)

<?php
$foo = array("Robert" => "Bob", "Seppo" => "Sepi");
$bar = each($foo);
print_r($bar);
?>

$bar şu anahtar değer çiftlerini içerir:

Array
(
    [1] => Bob
    [value] => Bob
    [0] => Robert
    [key] => Robert
)

each() genellikle bir diziyi taramak için list() işleviyle birlikte kullanılır. Örnek:

Örnek 2 - each() ile bir dizinin taranması

<?php
$fruit = array('a' => 'apple', 'b' => 'banana', 'c' => 'cranberry');

reset($fruit);
while (list($key, $val) = each($fruit)) {
    echo "$key => $val\n";
}
?>

Yukarıdaki örneğin çıktısı:

a => apple
b => banana
c => cranberry

Dikkat

Bir dizinin bir değişkene atanması özgün dizi göstericisini sıfırladığından yukarıdaki örnekte $fruit dizisini döngü içinde başka bir değişkene atamamız sonsuz bir döngüye sebep olurdu.

Uyarı

each() işlevi nesne de kabul eder fakat beklenmedik sonuçlar verebilir. Bu bakımdan nesne öğelerinin each() ile taranması önerilmez.

Ayrıca Bakınız

  • key() - Bir diziden gösterici konumundaki anahtarı döndürür
  • list() - Değişkenlere bir dizi gibi atama yapar
  • current() - Bir diziden gösterici konumundaki elemanı döndürür
  • reset() - Bir dizinin dahili göstericisini ilk elemana konumlar
  • next() - Dahili dizi göstericisini bir ilerletir
  • prev() - Dahili dizi göstericisini bir geriletir
  • foreach
  • Nesne Yineleme

current
end
Dizi İşlevleri


Bir dizinin dahili göstericisini sonuncu elemana konumlandırır

each
extract
Dizi İşlevleri
PHP Manual

end

(PHP 4, PHP 5, PHP 7)

end — Bir dizinin dahili göstericisini sonuncu elemana konumlandırır

Açıklama

mixed end ( array &$dizi )

end() işlevi dizi'nin dahili göstericisini son elemana kadar ilerletir ve bu elemanın değerini döndürür.

Değiştirgeler

dizi

İşlev tarafından değiştirileceği için bu dizi gönderimli olarak aktarılır. Yani, burada bir işlevin dönüş değerini kullanamazsınız. Gönderimli aktarılabilmesi için gerçek bir değişken belirtilmelidir.

Dönen Değerler

Dizi boşsa FALSE yoksa son elemanın değeri.

Örnekler

Örnek 1 - end() örneği

<?php

$meyveler = array('muşmula', 'zerdali', 'iğde');
echo end($meyveler); // iğde

?>

Ayrıca Bakınız

  • current() - Bir diziden gösterici konumundaki elemanı döndürür
  • each() - Bir diziden, gösterici konumundaki anahtar değer çiftini döndürdükten sonra göstericiyi bir ilerletir
  • prev() - Dahili dizi göstericisini bir geriletir
  • reset() - Bir dizinin dahili göstericisini ilk elemana konumlar
  • next() - Dahili dizi göstericisini bir ilerletir

each
extract
Dizi İşlevleri


Bir dizideki değişkenleri simge tablosuna dahil eder

end
in_array
Dizi İşlevleri
PHP Manual

extract

(PHP 4, PHP 5, PHP 7)

extract — Bir dizideki değişkenleri simge tablosuna dahil eder

Açıklama

int extract ( array $dizi [, int $çıkarım_türü = EXTR_OVERWRITE [, string $önek ]] )

Bir dizideki değişkenleri simge tablosuna dahil eder.

Her anahtarın geçerli bir değişken adı olup olmadığına bakmaktan başka bu değişkenlerin simge tablosundakilerle çakışıp çakışmadığına da bakar.

Değiştirgeler

dizi

Bir ilişkisel dizi. Bu işlev anahtarları değişken ismi, değerleri de değişkenin değeri olarak değerlendirir. Her anahtar/değer çifti için simge tablosunda çıkarım_türü ve önek'e uygun bir değişken oluşturulur.

EXTR_PREFIX_ALL veya EXTR_PREFIX_INVALID kullanmadıkça bir sayısal indisli dizi sonuç üretmeyeceğinden bir ilişkisel dizi kullanmanız gerekir.

çıkarım_türü

Geçersiz veya sayısal anahtarların ve çakışmaların ele alınma yöntemini belirtmek için kullanılır. Aşağıdaki değerlerden biri olmalıdır:

EXTR_OVERWRITE
Bir çakışma varsa mevcut değişkenin üzerine yazılır.
EXTR_SKIP
Bir çakışma varsa mevcut değişkenin üzerine yazılmaz.
EXTR_PREFIX_SAME
Bir çakışma varsa değişken isminin başına önek konur.
EXTR_PREFIX_ALL
Tüm değişken isimlerinin başına önek konur.
EXTR_PREFIX_INVALID
Sadece geçersiz veya sayısal indisli değişkerlerin başına önek konur.
EXTR_IF_EXISTS
Sadece simge tablosunda mevcut değişkenlerin üzerine yazılır, bunun dışında bir şey yapılmaz. Geçerli değişkenleri bir liste halinde tanımladıktan sonra bunlardan sadece örneğin $_REQUEST dışında tanımlanmış olanlarını çıkarmak için yararlıdır.
EXTR_PREFIX_IF_EXISTS
Sadece simge tablosunda öneksiz sürümü bulunan değişkenlerin önekli sürümleri oluşturulur.
EXTR_REFS
Değişkenler gönderimli olarak çıkarılır. Dahil edilen değişkenler dizi değerlerine gönderimli iseler bu anlamlıdır. Bu seçeneği tek başına ya da VEYAlamak suretiyle başka bir seçenekle birlikte kullanabilirsiniz.

çıkarım_türü belirtilmezse EXTR_OVERWRITE belirtilmiş sayılır.

önek

Bu değiştirge sadece çıkarım_türü olarak EXTR_PREFIX_SAME, EXTR_PREFIX_ALL, EXTR_PREFIX_INVALID veya EXTR_PREFIX_IF_EXISTS belirtilmişse anlamlıdır. Önekli bir sonuç geçerli bir değişken ismi oluşturmuyorsa simge tablosuna dahil edilmez. Önekler dizi anahtarlarından özdevinimli olarak bir altçizgi karakteri ile ayrılırlar.

Dönen Değerler

Simge tablosuna başarıyla eklenen değişkenlerin sayısı.

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.0 | EXTR_REFS seçeneği eklendi.
4.2.0 | EXTR_IF_EXISTS ve EXTR_PREFIX_IF_EXISTS eklendi.
4.0.5 | Dahil edilen değişken sayısını döndürür oldu. EXTR_PREFIX_INVALID eklendi. EXTR_PREFIX_ALL sayısal isimli değişkenleri de içerir oldu.

Örnekler

Örnek 1 - extract() örneği

extract() işlevinin olası kullanımlarınadn biri de wddx_deserialize() tarafından döndürülen ilişkisel dizi içeriğinin simge tablosuna dahil edilmesidir.

<?php

/* Dizinin wddx_deserialize tarafından döndürülen
   bir dizi olduğunu varsayalım */

$boyut = "büyük";
$dizi = array("renk"  => "mavi",
              "boyut" => "orta",
              "şekil" => "küre");
extract($dizi, EXTR_PREFIX_SAME, "wddx");

echo "$renk, $boyut, $şekil, $wddx_boyut\n";

?>

Yukarıdaki örneğin çıktısı:

mavi, büyük, küre, orta

$wddx_boyut değişkeninin oluşturulmasını sağlayan EXTR_PREFIX_SAME seçeneğini belirttiğimizden $boyut değişkeninin üzerine yazılmaz. Eğer seçenek olarak EXTR_SKIP belirtmiş olsaydık $wddx_boyut değişkeni oluşturulmazdı. EXTR_OVERWRITE belirtseydik, $size "orta" değerine sahip olacaktı. Eğer EXTR_PREFIX_ALL belirtmiş olsaydık $wddx_renk, $wddx_boyut ve $wddx_şekil değişkenlerini oluşturmuş olurduk.

Notlar

Uyarı

extract() işlevini kullanıcı girdisi ($_GET, $_FILES, vb.) gibi güvenilmez veriler üzerinde kullanmayın. Aksi takdirde, örneğin, register_globals yönergesinin 'On' olmasını gerektiren eski kodları geçici olarak çalıştırmak isterseniz EXTR_SKIP gibi üste yazmayan çıkarım_türü değerlerini kullanmaya ve php.ini dosyasındaki variables_order yönergesinde tanımlı sırada çıkartmaya çalışın.

Bilginize:

Eğer register_globals yönergesini etkin kılar ve $_FILES üzerinde extract() kullanıp EXTR_SKIP belirtirseniz hiç beklenmedik bir sonuç alabilirsiniz.

Uyarı

Uygulamada bu önerilmez ve bir şeyleri eksik bırakmamak için burada belgelendirmekle yetinilmiştir. Yukarıda belirtildiği gibi, register_globals kullanımı artık önerilmemekte ve $_FILES gibi güvenilir olmayan veriler üzerinde extract() kullanımı olası bir güvenlik riskini beraberinde getirebilir. Böyle bir durumla karşılaşırsanız en azından bu iki kötü kodlama uygulamasından birini kullanıyorsunuz demektir.

<?php

/* Yüklenecek dosyanın ismi $testfile ve
   'register_globals on' olsun. */

var_dump($testfile);
extract($_FILES, EXTR_SKIP);
var_dump($testfile);
var_dump($testfile['tmp_name']);

?>
Sonuç olarak şöyle bir şeyler umabiliriz:
string(14) "/tmp/phpgCCPX8"
array(5) {
  ["name"]=>
  string(10) "somefile.txt"
  ["type"]=>
  string(24) "application/octet-stream"
  ["tmp_name"]=>
  string(14) "/tmp/phpgCCPX8"
  ["error"]=>
  int(0)
  ["size"]=>
  int(4208)
}
string(14) "/tmp/phpgCCPX8"
Ancak, bunun yerine aşağıdaki gibi bir şeylaer görürüz:
string(14) "/tmp/phpgCCPX8"
string(14) "/tmp/phpgCCPX8"
string(1) "/"

Bunun sebebi, register_globals 'on' olduğundan dolayı extract() çağrısı yapıldığında $testfile değişkeninin küresel etki alanında mevcut olması ve EXTR_SKIP belirtilmesi nedeniyle $_FILES dizisinin içeriğinin $testfile üzerine yazılmaması, dolayısıyla $testfile'ın bir dizge olarak kalmasıdır. Dizgelere dizi sözdizimi kullanılarak erişilebildiğinden ve sayısal olmayan tmp_name dizgesi 0 olarak yorumlandığından, PHP, $testfile['tmp_name'] ifadesini $testfile[0] olarak görür.

Ayrıca Bakınız

  • compact() - Değişkenlerle değerlerinden oluşan bir dizi oluşturur

end
in_array
Dizi İşlevleri


Bir dizide bir değerin varlığını araştırır

extract
key_exists
Dizi İşlevleri
PHP Manual

in_array

(PHP 4, PHP 5, PHP 7)

in_array — Bir dizide bir değerin varlığını araştırır

Açıklama

bool in_array ( mixed $iğne , array $samanlık [, bool $strict ] )

samanlık'ta iğne'yi' arar.

Değiştirgeler

iğne

Aranan değer.

Bilginize:

iğne bir dizge ise harf büyüklüğüne duyarlı karşılaştırma uygulanır.

samanlık

Dizi.

türüne_de_bak

Bu değiştirgede TRUE belirtilmişse in_array() işlevi samanlık içindeki iğne'nin türüne de bakacaktır.

Dönen Değerler

iğne bulunursa TRUE, aksi takdirde FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
4.2.0 | iğne olarak bir dizi belirtilebilir oldu.

Örnekler

Örnek 1 - in_array() örneği

<?php
$os = array("Mac", "NT", "Irix", "Linux");
if (in_array("Irix", $os)) {
    echo "Irix var";
}
if (in_array("mac", $os)) {
    echo "Mac var";
}
?>

The second condition fails because in_array() işlevi harf büyüklüğüne duyarlı olduğundan ikinci koşul başarısız olur ve sonuç şu olur:

Irix var

Örnek 2 - Türe de bakan in_array() örneği

<?php
$a = array('1.10', 12.4, 1.13);

if (in_array('12.4', $a, true)) {
    echo "'12.4' uygun türde bulundu\n";
}

if (in_array(1.13, $a, true)) {
    echo "1.13 uygun türde bulundu\n";
}
?>

Yukarıdaki örneğin çıktısı:

1.13 uygun türde bulundu

Örnek 3 - iğnenin bir dizi olduğu in_array() örneği

<?php
$a = array(array('p', 'h'), array('p', 'r'), 'o');

if (in_array(array('p', 'h'), $a)) {
    echo "'ph' bulundu\n";
}

if (in_array(array('f', 'i'), $a)) {
    echo "'fi' bulundu\n";
}

if (in_array('o', $a)) {
    echo "'o' bulundu\n";
}
?>

Yukarıdaki örneğin çıktısı:

  'ph' bulundu
  'o' bulundu

Ayrıca Bakınız

  • array_search() - Bir dizide belirtilen değeri arar ve bulursa ilgili anahtarı döndürür
  • isset() - Değişken tanımlı mı diye bakar
  • array_key_exists() - Belirtilen anahtar veya indis dizide var mı diye bakar

extract
key_exists
Dizi İşlevleri


Takma Adı: array_key_exists

in_array
key
Dizi İşlevleri
PHP Manual

key_exists

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

key_exists — Takma Adı: array_key_exists()

Açıklama

Bu işlev şu işlevin takma adıdır: array_key_exists().

in_array
key
Dizi İşlevleri


Bir diziden gösterici konumundaki anahtarı döndürür

key_exists
krsort
Dizi İşlevleri
PHP Manual

key

(PHP 4, PHP 5, PHP 7)

key — Bir diziden gösterici konumundaki anahtarı döndürür

Açıklama

mixed key ( array &$dizi )

key() işlevi belirtilen diziden göstericinin işaret ettiği elemanın anahtarını döndürür.

Değiştirgeler

dizi

Anahtarın alınacağı dizi.

Dönen Değerler

Dahili göstericinin üzerinde bulunduğu elemanın anahtarını döndürür. Eğer gösterici son elemandan sonrasını gösteriyorsa NULL döner.

Örnekler

Örnek 1 - key() örneği

<?php
$dizi = array(
    'meyve1' => 'elma',
    'meyve2' => 'muz',
    'meyve3' => 'armut',
    'meyve4' => 'elma',
    'meyve5' => 'elma');

// Değeri "elma" olan tüm anahtarları gösterir
while ($meyve_adı = current($dizi)) {
    if ($meyve_adı == 'elma') {
        echo key($dizi).'<br />';
    }
    next($dizi);
}
?>

Yukarıdaki örneğin çıktısı:

meyve1<br />
meyve4<br />
meyve5<br />

Ayrıca Bakınız

  • current() - Bir diziden gösterici konumundaki elemanı döndürür
  • next() - Dahili dizi göstericisini bir ilerletir

key_exists
krsort
Dizi İşlevleri


Bir diziyi anahtarlarına göre tersine sıralar

key
ksort
Dizi İşlevleri
PHP Manual

krsort

(PHP 4, PHP 5, PHP 7)

krsort — Bir diziyi anahtarlarına göre tersine sıralar

Açıklama

bool krsort ( array &$dizi [, int $seçenekler = SORT_REGULAR ] )

Bir diziyi anahtar/değer ilişkisini koruyarak anahtarlarına göre tersine sıralar. Esas olarak, ilişkisel dizilerin sıralanmasında kullanılır.

Değiştirgeler

dizi

Sıralanacak dizi.

seçenekler

İsteğe bağlı bu değiştirge ile sıralama türünü değiştirebilirsiniz. Olası seçenekler için sort() işlevine bakınız.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - krsort() örneği

<?php
$fruits = array("d"=>"lemon", "a"=>"orange", "b"=>"banana", "c"=>"apple");
krsort($fruits);
foreach ($fruits as $key => $val) {
    echo "$key = $val\n";
}
?>

Yukarıdaki örneğin çıktısı:

d = lemon
c = apple
b = banana
a = orange

Ayrıca Bakınız

  • arsort() - Bir dizinin değerlerini anahtarlarıyla ilişkilerini bozmadan tersine sıralar
  • ksort() - Bir diziyi anahtarlarına göre sıralar
  • Dizilerde Sıralama

key
ksort
Dizi İşlevleri


Bir diziyi anahtarlarına göre sıralar

krsort
list
Dizi İşlevleri
PHP Manual

ksort

(PHP 4, PHP 5, PHP 7)

ksort — Bir diziyi anahtarlarına göre sıralar

Açıklama

bool ksort ( array &$dizi [, int $seçenekler = SORT_REGULAR ] )

Bir diziyi anahtar/değer ilişkisini koruyarak anahtarlarına göre sıralar. Esas olarak, ilişkisel dizilerin sıralanmasında kullanılır.

Değiştirgeler

dizi

Sıralanacak dizi.

seçenekler

İsteğe bağlı bu değiştirge ile sıralama türünü değiştirebilirsiniz. Olası seçenekler için sort() işlevine bakınız.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - ksort() örneği

<?php
$fruits = array("d"=>"lemon", "a"=>"orange", "b"=>"banana", "c"=>"apple");
ksort($fruits);
foreach ($fruits as $key => $val) {
    echo "$key = $val\n";
}
?>

Yukarıdaki örneğin çıktısı:

a = orange
b = banana
c = apple
d = lemon

Ayrıca Bakınız

  • asort() - Bir dizinin değerlerini anahtarlarıyla ilişkilerini bozmadan sıralar
  • Dizilerde Sıralama

krsort
list
Dizi İşlevleri


Değişkenlere bir dizi gibi atama yapar

ksort
natcasesort
Dizi İşlevleri
PHP Manual

list

(PHP 4, PHP 5, PHP 7)

list — Değişkenlere bir dizi gibi atama yapar

Açıklama

array list ( mixed $değişken [, mixed $... ] )

array() gibi bu da bir işlev değil bir dil oluşumudur. list() işlevi tek deyimde birden fazla değişkene atama yapmak için kullanılır.

Değiştirgeler

değişken

Bir değişken.

Dönen Değerler

Atanan dizi döner.

Örnekler

Örnek 1 - list() örnekleri

<?php

$veri = array('kahve', 'uyku', 'kafein');

// Değişkenlerin tamamını listeleyelim
list($içecek, $neyi, $güç) = $veri;
echo "$içecek $neyi kaçırır, çünkü içinde $güç vardır.\n";

// Bir kısmını listeleyelim
list($içecek, , $güç) = $veri;
echo "$içecek $güç içerir.\n";

// Sadece üçüncü kalsın
list( , , $güç) = $veri;
echo "Bana $güç lazım!\n";

// list() dizgelerle çalışmaz
list($bar) = "abcde";
var_dump($bar); // NULL
?>

Örnek 2 - list() kullanım örneği

<table>
 <tr>
  <th>Çalışanın adı</th>
  <th>Ücreti</th>
 </tr>

<?php

$sonuç = mysql_query("SELECT id, ad, ucret FROM personel", $conn);
while (list($id, $ad, $ücret) = mysql_fetch_row($sonuç)) {
    echo " <tr>\n" .
          "  <td><a href=\"info.php?id=$id\">$ad</a></td>\n" .
          "  <td>$ücret</td>\n" .
          " </tr>\n";
}

?>

</table>

Örnek 3 - İç içe list() kullanımı

<?php

list($a, list($b, $c)) = array(1, array(2, 3));

var_dump($a, $b, $c);

?>
int(1)
int(2)
int(3)

Örnek 4 - Dizi indisleri ile list() kullanımı

<?php

$veri = array('kahve', 'uyku', 'kafein');

list($a[0], $a[1], $a[2]) = $veri;

var_dump($a);

?>

Aşağıdaki çıktıyı verir (dikkatı ederseniz, eleman sırası list() ile belirtilen sıra ile aynıdır):

array(3) {
  [2]=>
  string(6) "kafein"
  [1]=>
  string(4) "uyku"
  [0]=>
  string(5) "kahve"
}

Notlar

Uyarı

list() değerleri en sağdaki değiştirgeden itibaren atar. Düz değişken kullanıyorsanız bundan dolayı endişelenmeniz gerekmez. Fakat indisli diziler kullanıyorsanız, dizi indislerinin, list()'teki yazılış sırasına göre soldan sağa sıralanacağını düşünürsünüz. Fakat atama sağdan sola doğru yapılır.

Bilginize:

list() sadece sayısal indisli dizilerle çalışır ve indislerin 0'dan başladığı varsayılır.

Ayrıca Bakınız

  • each() - Bir diziden, gösterici konumundaki anahtar değer çiftini döndürdükten sonra göstericiyi bir ilerletir
  • array() - Bir dizi oluşturur
  • extract() - Bir dizideki değişkenleri simge tablosuna dahil eder

ksort
natcasesort
Dizi İşlevleri


Bir diziyi harf büyüklüğüne duyarsız "doğal sıralama" algoritmasıyla sıralar

list
natsort
Dizi İşlevleri
PHP Manual

natcasesort

(PHP 4, PHP 5, PHP 7)

natcasesort — Bir diziyi harf büyüklüğüne duyarsız "doğal sıralama" algoritmasıyla sıralar

Açıklama

bool natcasesort ( array &$dizi )

natcasesort() işlevi natsort() işlevinin harf büyüklüğüne duyarsız sürümüdür.

Bu işlev, abecesayısal dizgeleri, insanların anahtar değer ilişkisini sağlayarak yaptıkları şekilde gerçekleyen bir sıralama algoritmasını kullanarak sıralar. Bu algoritmaya "doğal sıralama" algoritması adı verilir.

Değiştirgeler

dizi

Sıralanacak dizi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - natcasesort() örneği

<?php
$array1 = $array2 = array('IMG0.png', 'img12.png', 'img10.png', 'img2.png',
                          'img1.png', 'IMG3.png');

sort($array1);
echo "Standart sıralama\n";
print_r($array1);

natcasesort($array2);
echo "\nDoğal sıralama (harf büyüklüğüne duyarsız)\n";
print_r($array2);
?>

Yukarıdaki örneğin çıktısı:

Standart sıralama
Array
(
    [0] => IMG0.png
    [1] => IMG3.png
    [2] => img1.png
    [3] => img10.png
    [4] => img12.png
    [5] => img2.png
)

Doğal sıralama (harf büyüklüğüne duyarsız)
Array
(
    [0] => IMG0.png
    [4] => img1.png
    [3] => img2.png
    [5] => IMG3.png
    [2] => img10.png
    [1] => img12.png
)

Daha fazla bilgi için Martin Pool'un » Natural Order String Comparison sayfasına bakınız.

Ayrıca Bakınız

  • natsort() - Bir diziyi "doğal sıralama" algoritmasıyla sıralar
  • Dizilerde Sıralama
  • strnatcmp() - "Doğal sıralama" algoritmasını kullanarak dizgeleri karşılaştırır
  • strnatcasecmp() - "Doğal sıralama" algoritmasını kullanarak dizgeleri harf büyüklüğüne duyarsız olarak karşılaştırır

list
natsort
Dizi İşlevleri


Bir diziyi "doğal sıralama" algoritmasıyla sıralar

natcasesort
next
Dizi İşlevleri
PHP Manual

natsort

(PHP 4, PHP 5, PHP 7)

natsort — Bir diziyi "doğal sıralama" algoritmasıyla sıralar

Açıklama

bool natsort ( array &$array )

Bu işlev, abecesayısal dizgeleri, insanların anahtar değer ilişkisini sağlayarak yaptıkları şekilde gerçekleyen bir sıralama algoritmasını kullanarak sıralar. Bu algoritmaya "doğal sıralama" algoritması adı verilir. Bu algoritma ile sort() işlevinin yaptığı standart sıralama arasındaki farkı gösteren bir örnek aşağıdadır.

Değiştirgeler

dizi

Sıralanacak dizi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - natsort() örneği

<?php
$array1 = $array2 = array("img12.png", "img10.png", "img2.png", "img1.png");

sort($array1);
echo "Standart sıralama\n";
print_r($array1);

natsort($array2);
echo "\nDoğal sıralama\n";
print_r($array2);
?>

Yukarıdaki örneğin çıktısı:

Standart sıralama
Array
(
    [0] => img1.png
    [1] => img10.png
    [2] => img12.png
    [3] => img2.png
)

Doğal sıralama
Array
(
    [3] => img1.png
    [2] => img2.png
    [1] => img10.png
    [0] => img12.png
)

Daha fazla bilgi için Martin Pool'un » Natural Order String Comparison sayfasına bakınız.

Ayrıca Bakınız

  • natcasesort() - Bir diziyi harf büyüklüğüne duyarsız "doğal sıralama" algoritmasıyla sıralar
  • Dizilerde Sıralama
  • strnatcmp() - "Doğal sıralama" algoritmasını kullanarak dizgeleri karşılaştırır
  • strnatcasecmp() - "Doğal sıralama" algoritmasını kullanarak dizgeleri harf büyüklüğüne duyarsız olarak karşılaştırır

natcasesort
next
Dizi İşlevleri


Dahili dizi göstericisini bir ilerletir

natsort
pos
Dizi İşlevleri
PHP Manual

next

(PHP 4, PHP 5, PHP 7)

next — Dahili dizi göstericisini bir ilerletir

Açıklama

mixed next ( array &$dizi )

next() işlevi bir farkla current() işlevi gibi davranır. Eleman değerini döndürmeden önce dahili dizi göstericisini bir ileri taşır. Yani farklı olarak dahili dizi göstericisini bir ilerlettikten sonra, current() işlevindeki gibi dahili dizi göstericisinin gösterdiği elemanın değerini döndürür.

Değiştirgeler

dizi

Göstericisi konumlanacak dizi.

Dönen Değerler

Dizinin dahili göstericisinin bulunduğu konumun bir sonrasında eleman varsa o elemanın değeri döner, yoksa FALSE döner.

Uyarı

Bu işlev mantıksal FALSE değeriyle dönebileceği gibi FALSE olarak değerlendirilebilecek mantıksal olmayan bir değerle de dönebilir. Bu konuda daha fazla bilgi edinmek için Mantıksal Değerler bölümüne bakabilirsiniz. Bu işlevden dönen değeri sınamak için === işlecini kullanınız.

Örnekler

Örnek 1 - next() ve şürekası

<?php
$araç = array('tabanvay', 'bisiklet', 'otomobil', 'uçak');
$kip = current($araç); // $kip = 'tabanvay';
$kip = next($araç);    // $kip = 'bisiklet';
$kip = next($araç);    // $kip = 'otomobil';
$kip = prev($araç);    // $kip = 'bisiklet';
$kip = end($araç);     // $kip = 'uçak';
?>

Notlar

Bilginize: Bir dizinin sonundaki elemanın değerinin boolean FALSE olup olmadığını anlayamazsınız. FALSE değerli elemanlar içeren bir dizide bilinçli olarak ilerlemenin en doğru yolu each() kullanmaktır.

Ayrıca Bakınız

  • current() - Bir diziden gösterici konumundaki elemanı döndürür
  • end() - Bir dizinin dahili göstericisini sonuncu elemana konumlandırır
  • prev() - Dahili dizi göstericisini bir geriletir
  • reset() - Bir dizinin dahili göstericisini ilk elemana konumlar
  • each() - Bir diziden, gösterici konumundaki anahtar değer çiftini döndürdükten sonra göstericiyi bir ilerletir

natsort
pos
Dizi İşlevleri


current işlevinin takma adıdır

next
prev
Dizi İşlevleri
PHP Manual

pos

(PHP 4, PHP 5, PHP 7)

pos — current() işlevinin takma adıdır

Açıklama

Bu işlev current() işlevinin takma adıdır.

next
prev
Dizi İşlevleri


Dahili dizi göstericisini bir geriletir

pos
range
Dizi İşlevleri
PHP Manual

prev

(PHP 4, PHP 5, PHP 7)

prev — Dahili dizi göstericisini bir geriletir

Açıklama

mixed prev ( array &$dizi )

Dahili dizi göstericisini bir geriletir.

prev() işlevi dahili dizi göstericisini bir ileri değil de bir geri alması dışında next() gibidir.

Değiştirgeler

dizi

Göstericisi konumlanacak dizi.

Dönen Değerler

Dizinin dahili göstericisinin bulunduğu konumun bir öncesinde eleman varsa o elemanın değeri döner, yoksa FALSE döner.

Örnekler

Örnek 1 - prev() ve şürekası

<?php
$araç = array('tabanvay', 'bisiklet', 'otomobil', 'uçak');
$kip = current($araç); // $kip = 'tabanvay';
$kip = next($araç);    // $kip = 'bisiklet';
$kip = next($araç);    // $kip = 'otomobil';
$kip = prev($araç);    // $kip = 'bisiklet';
$kip = end($araç);     // $kip = 'uçak';
?>

Notlar

Uyarı

Bu işlev mantıksal FALSE değeriyle dönebileceği gibi FALSE olarak değerlendirilebilecek mantıksal olmayan bir değerle de dönebilir. Bu konuda daha fazla bilgi edinmek için Mantıksal Değerler bölümüne bakabilirsiniz. Bu işlevden dönen değeri sınamak için === işlecini kullanınız.

Bilginize: Bir dizinin başlangıcındaki elemanın değerinin boolean FALSE olup olmadığını anlayamazsınız. FALSE değerli elemanlar içeren bir dizide bilinçli olarak ilerlemenin en doğru yolu each() kullanmaktır.

Ayrıca Bakınız

  • current() - Bir diziden gösterici konumundaki elemanı döndürür
  • end() - Bir dizinin dahili göstericisini sonuncu elemana konumlandırır
  • next() - Dahili dizi göstericisini bir ilerletir
  • reset() - Bir dizinin dahili göstericisini ilk elemana konumlar
  • each() - Bir diziden, gösterici konumundaki anahtar değer çiftini döndürdükten sonra göstericiyi bir ilerletir

pos
range
Dizi İşlevleri


Belli bir eleman aralığını içeren bir dizi oluşturur

prev
reset
Dizi İşlevleri
PHP Manual

range

(PHP 4, PHP 5, PHP 7)

range — Belli bir eleman aralığını içeren bir dizi oluşturur

Açıklama

array range ( mixed $düşük , mixed $yüksek [, number $adım ] )

Aralığı belirtilen elemanları içeren bir dizi oluşturur.

Değiştirgeler

düşük

Düşük değer.

yüksek

Yüksek değer.

adım

Bu değiştirge belirtilmişse eleman sırası artış değerini belirler. Bir pozitif sayı olmalıdır. Belirtilmezse 1 öntanımlıdır.

Dönen Değerler

düşük-yüksek aralığındaki elemanlardan oluşan bir dizi döner. Eğer düşük > yüksek ise sıralama yüksekten düşüğe doğru olur.

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.0 | İsteğe bağlı adım değiştirgesi eklendi.
4.1.0'ten 4.3.2'ye kadar | PHP'nin 4.1.0 ile 4.3.2 sürümleri arasında range() sayısal dizgeleri sayı değil dizge olarak görür ve bir karakter dizisi olarak ele alır. Örneğin, "4242" değeri "4" olarak ele alınır.
4.1.0 | PHP 4.1.0 öncesinde range() sadece tamsayı dizileri artan sırada oluşturur. Dizgeler ve azalan sıralı tamsayı dizilerine destek 4.1.0 sürümünde eklenmiştir. Dizge değerlerin uzunluğu bir bayt ile sınırlıdır, dolayısıyla daha uzun dizgelerin sadece ilk karakteri kullanılır.

Örnekler

Örnek 1 - range() örnekleri

<?php
// array(0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12)
foreach (range(0, 12) as $number) {
    echo $number;
}

// adım değiştirgesi 5.0.0 sürümünde devreye girdi
// array(0, 10, 20, 30, 40, 50, 60, 70, 80, 90, 100)
foreach (range(0, 100, 10) as $number) {
    echo $number;
}

// Dizgelere destek 4.1.0 sürümünde devreye girdi
// array('a', 'b', 'c', 'd', 'e', 'f', 'g', 'h', 'i');
foreach (range('a', 'i') as $letter) {
    echo $letter;
}
// array('c', 'b', 'a');
foreach (range('c', 'a') as $letter) {
    echo $letter;
}
?>

Ayrıca Bakınız

  • shuffle() - Bir diziyi karar
  • array_fill() - Bir diziyi değerlerle doldurur
  • foreach

prev
reset
Dizi İşlevleri


Bir dizinin dahili göstericisini ilk elemana konumlar

range
rsort
Dizi İşlevleri
PHP Manual

reset

(PHP 4, PHP 5, PHP 7)

reset — Bir dizinin dahili göstericisini ilk elemana konumlar

Açıklama

mixed reset ( array &$dizi )

reset() işleve dizi dizisinin dahili göstericisini ilk elemana konumlar ve ilk dizi elemanının değeri ile döner.

Değiştirgeler

dizi

Dahili göstericisi sıfırlanacak dizi.

Dönen Değerler

Dizi boşsa FALSE, değilse dizinin ilk elemanının değeri.

Örnekler

Örnek 1 - reset() örneği

<?php

$dizi = array('bir adım', 'iki adım', 'üç adım', 'dörtadım');

// Öntanımlı olarak gösterici ilk elemandadır
echo current($dizi) . "<br />\n"; // "bir adım"

// İki adım atalım
next($dizi);
next($dizi);
echo current($dizi) . "<br />\n"; // "üç adım"

// Göstericiyi sıfırlayalım
reset($dizi);
echo current($dizi) . "<br />\n"; // "bir adım"

?>

Ayrıca Bakınız

  • current() - Bir diziden gösterici konumundaki elemanı döndürür
  • each() - Bir diziden, gösterici konumundaki anahtar değer çiftini döndürdükten sonra göstericiyi bir ilerletir
  • end() - Bir dizinin dahili göstericisini sonuncu elemana konumlandırır
  • next() - Dahili dizi göstericisini bir ilerletir
  • prev() - Dahili dizi göstericisini bir geriletir

range
rsort
Dizi İşlevleri


Bir diziyi tersine sıralar

reset
shuffle
Dizi İşlevleri
PHP Manual

rsort

(PHP 4, PHP 5, PHP 7)

rsort — Bir diziyi tersine sıralar

Açıklama

bool rsort ( array &$dizi [, int $seçenekler = SORT_REGULAR ] )

Bu işlev belirtilen diziyi tersine (büyükten küçüğe) sıralar.

Değiştirgeler

dizi

Sıralanacak dizi.

seçenekler

Bu değiştirge ile sıralamayı değiştirebilirsiniz. Bu değiştirgede belirtilebilecek değerler için sort() işlevine bakınız.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - rsort() örneği

<?php
$meyveler = array("portakal", "armut", "muz", "kayısı");
rsort($meyveler);
foreach ($meyveler as $indis => $meyve) {
    echo "$indis = $meyve\n";
}
?>

Yukarıdaki örneğin çıktısı:

0 = portakal
1 = muz
2 = kayısı
3 = armut

Meyveler abecesel olarak ters sırada dizilmiştir.

Notlar

Bilginize: Bu işlev dizi elemanlarına yeni anahtarlar atar. Anahtarları yeniden düzenlemek yerine evvelce atanmış anahtarları silecektir.

Ayrıca Bakınız

  • arsort() - Bir dizinin değerlerini anahtarlarıyla ilişkilerini bozmadan tersine sıralar
  • krsort() - Bir diziyi anahtarlarına göre tersine sıralar
  • Dizilerde Sıralama

reset
shuffle
Dizi İşlevleri


Bir diziyi karar

rsort
sizeof
Dizi İşlevleri
PHP Manual

shuffle

(PHP 4, PHP 5, PHP 7)

shuffle — Bir diziyi karar

Açıklama

bool shuffle ( array &$dizi )

Bu işlev belirtilen diziyi karar (elemanları rasgele sıralar).

Değiştirgeler

dizi

Karılacak dizi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
4.2.0 | Rasgele sayı üreteci özdevinimli tohumlanır.

Örnekler

Örnek 1 - shuffle() örneği

<?php
$sayılar = range(1, 20);
shuffle($sayılar);
foreach ($sayılar as $sayı) {
    echo "$sayı ";
}
?>

Notlar

Bilginize: Bu işlev dizi elemanlarına yeni anahtarlar atar. Anahtarları yeniden düzenlemek yerine evvelce atanmış anahtarları silecektir.

Ayrıca Bakınız

  • Dizilerde Sıralama

rsort
sizeof
Dizi İşlevleri


count işlevinin takma adıdır

shuffle
sort
Dizi İşlevleri
PHP Manual

sizeof

(PHP 4, PHP 5, PHP 7)

sizeof — count() işlevinin takma adıdır

Açıklama

Bu işlev count() işlevinin takma adıdır.

shuffle
sort
Dizi İşlevleri


Bir diziyi sıralar

sizeof
uasort
Dizi İşlevleri
PHP Manual

sort

(PHP 4, PHP 5, PHP 7)

sort — Bir diziyi sıralar

Açıklama

bool sort ( array &$dizi [, int $seçenekler = SORT_REGULAR ] )

Bu işlev bir diziyi sıralar. Sıralama işlemi bittiğinde dizinin elemanları küçükten büyüğe doğru sıralanmış olur.

Değiştirgeler

dizi

Sıralanacak dizi.

seçenekler

İsteğe bağlı seçenekler değiştirgesinde aşağıdaki değerler kullanılarak sıralama kuralı değiştirilebilir:

Sıralama türü seçenekleri:

  • SORT_REGULAR - Elemanlar normal olarak sıralanır (öntanımlı)
  • SORT_NUMERIC - Elemanlar sayısal olarak sıralanır
  • SORT_STRING - Elemanlar dizgesel olarak sıralanır
  • SORT_LOCALE_STRING - Yerele göre dizgesel sıralama yapılır. PHP 4.4.0 ve 5.0.2'de eklendi. PHP 6 öncesinde, setlocale() işlevi ile değiştirilebilen sistem yereli kullanılıyordu. PHP 6'dan itibaren sistem yerelini değiştirmek için i18n_loc_set_default() işlevini kullanmalısınız.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - sort() örneği

<?php

$fruits = array("lemon", "orange", "banana", "apple");
sort($fruits);
foreach ($fruits as $key => $val) {
    echo "fruits[" . $key . "] = " . $val . "\n";
}

?>

Yukarıdaki örneğin çıktısı:

fruits[0] = apple
fruits[1] = banana
fruits[2] = lemon
fruits[3] = orange

Meyvalar abecesel olarak sıralanmıştır.

Notlar

Bilginize: Bu işlev dizi elemanlarına yeni anahtarlar atar. Anahtarları yeniden düzenlemek yerine evvelce atanmış anahtarları silecektir.

Bilginize: Çoğu PHP sıralama işlevindeki gibi sort() işlevinde de » Quicksort gerçeklenimi kullanılmıştır.

Uyarı

Farklı türde değerler içeren dizileri sıralarken dikkatli olun; yoksa sort() işlevi umulmadık sonuçlar üretebilir.

Ayrıca Bakınız

  • asort() - Bir dizinin değerlerini anahtarlarıyla ilişkilerini bozmadan sıralar
  • Dizilerde Sıralama

sizeof
uasort
Dizi İşlevleri


Bir diziyi kullanıcı tanımlı bir işlev kullanarak indislerine göre sıralarken anahtar/değer ilişkisini korur

sort
uksort
Dizi İşlevleri
PHP Manual

uasort

(PHP 4, PHP 5, PHP 7)

uasort — Bir diziyi kullanıcı tanımlı bir işlev kullanarak indislerine göre sıralarken anahtar/değer ilişkisini korur

Açıklama

bool uasort ( array &$dizi , callback $karş_işlevi )

Bu işlev kullanıcı tarafından sağlanmış bir karşılaştırma işlevini kullanarak diziyi indislerine göre sıralarken anahtar/değer ilişkisini korur.

Bu işlev, esas olarak, eleman sırasının önemli olduğu ilişkisel dizileri sıralarken kullanılır.

Değiştirgeler

dizi

Sıralanacak dizi.

karş_işlevi

Kullanıcı tanamlı karşılaştırma işlevi örnekleri için usort() ve uksort() işlevlerine bakınız.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - uasort() örneği

<?php
// Karşılaştırma işlevi
function karş($a, $b) {
    if ($a == $b) {
        return 0;
    }
    return ($a < $b) ? -1 : 1;
}

// Sıralanacak dizi
$dizi = array('a' => 4, 'b' => 8, 'c' => -1, 'd' => -9, 'e' => 2, 'f' => 5, 'g' => 3, 'h' => -4);
print_r($dizi);

// Sıralayıp sonucu basalım
uasort($dizi, 'karş');
print_r($dizi);
?>

Yukarıdaki örneğin çıktısı:

Array
(
    [a] => 4
    [b] => 8
    [c] => -1
    [d] => -9
    [e] => 2
    [f] => 5
    [g] => 3
    [h] => -4
)
Array
(
    [d] => -9
    [h] => -4
    [c] => -1
    [e] => 2
    [g] => 3
    [a] => 4
    [f] => 5
    [b] => 8
)

Ayrıca Bakınız

  • usort() - Bir diziyi kullanıcı tanımlı bir işlev kullanarak değerlerine göre sıralar
  • Dizilerde Sıralama

sort
uksort
Dizi İşlevleri


Bir diziyi kullanıcı tanımlı bir işlev kullanarak anahtarlarına göre sıralar

uasort
usort
Dizi İşlevleri
PHP Manual

uksort

(PHP 4, PHP 5, PHP 7)

uksort — Bir diziyi kullanıcı tanımlı bir işlev kullanarak anahtarlarına göre sıralar

Açıklama

bool uksort ( array &$dizi , callback $karş_işlevi )

Bu işlev kullanıcı tarafından sağlanmış bir karşılaştırma işlevini kullanarak diziyi anahtarlarına göre sıralar. Sıralamak istediğiniz diziyi mevcut kuralların dışında bir kurala göre sıralamak isterseniz bu işlev çok işe yarar.

Değiştirgeler

dizi

Sıralanacak dizi.

karş_işlevi

Karşılaştırma için geriçağırım işlevi.

karş_işlevi dizi anahtarlarının aktarılacağı iki değiştirge kabul etmelidir. Birinci değiştirgenin ikinciden büyük, küçük veya ona eşit olduğu durumlarda sırayla sıfırdan büyük, sıfırdan küçük bir değer veya sıfır döndürmelidir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - uksort() örneği

<?php
function cmp($a, $b)
{
    $a = preg_replace('@^(a|an|the) @', '', $a);
    $b = preg_replace('@^(a|an|the) @', '', $b);
    return strcasecmp($a, $b);
}

$a = array("John" => 1, "the Earth" => 2, "an apple" => 3, "a banana" => 4);

uksort($a, "cmp");

foreach ($a as $key => $value) {
    echo "$key: $value\n";
}
?>

Yukarıdaki örneğin çıktısı:

an apple: 3
a banana: 4
the Earth: 2
John: 1

Ayrıca Bakınız

  • usort() - Bir diziyi kullanıcı tanımlı bir işlev kullanarak değerlerine göre sıralar
  • Dizilerde Sıralama

uasort
usort
Dizi İşlevleri


Bir diziyi kullanıcı tanımlı bir işlev kullanarak değerlerine göre sıralar

uksort
Sınıflar ve Nesneler
Dizi İşlevleri
PHP Manual

usort

(PHP 4, PHP 5, PHP 7)

usort — Bir diziyi kullanıcı tanımlı bir işlev kullanarak değerlerine göre sıralar

Açıklama

bool usort ( array &$array , callback $karş_işlevi )

Bu işlev kullanıcı tarafından sağlanmış bir karşılaştırma işlevini kullanarak diziyi değerlerine göre sıralar. Sıralamak istediğiniz diziyi mevcut kuralların dışında bir kurala göre sıralamak isterseniz bu işlev çok işe yarar.

Bilginize:

Karşılaştırma sırasında birbirinin eşi iki üye bulunursa aralarındaki sıralamanın nasıl olacağı belirsizdir.

Bilginize: Bu işlev dizi elemanlarına yeni anahtarlar atar. Anahtarları yeniden düzenlemek yerine evvelce atanmış anahtarları silecektir.

Değiştirgeler

dizi

Sıralanacak dizi.

karş_işlevi

Karşılaştırma için geriçağırım işlevi.

karş_işlevi dizi değerlerinin aktarılacağı iki değiştirge kabul etmelidir. Birinci değiştirgenin ikinciden büyük, küçük veya ona eşit olduğu durumlarda sırayla sıfırdan büyük, sıfırdan küçük bir değer veya sıfır döndürmelidir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
4.1.0 | Yeni sıralama algoritması devreye girdi. karş_işlevi karşılaştırıldıklarında eşit olan elemanların özgün sırasını korumuyor.

Örnekler

Örnek 1 - usort() örneği

<?php
function cmp($a, $b)
{
    if ($a == $b) {
        return 0;
    }
    return ($a < $b) ? -1 : 1;
}

$a = array(3, 2, 5, 6, 1);

usort($a, "cmp");

foreach ($a as $anahtar => $değer) {
    echo "$anahtar: $değer\n";
}
?>

Yukarıdaki örneğin çıktısı:

0: 1
1: 2
2: 3
3: 5
4: 6

Bilginize:

Açıkçası, bu örnek için sort() işlevi daha uygun olurdu.

Örnek 2 - usort() ve çok boyutlu dizi

<?php
function karşılaştır($a, $b)
{
    return strcmp($a["meyva"], $b["meyva"]);
}

$meyvalar[0]["meyva"] = "mandalina";
$meyvalar[1]["meyva"] = "limon";
$meyvalar[2]["meyva"] = "portakal";

usort($meyvalar, "karşılaştır");

while (list($anah, $değer) = each($meyvalar)) {
    echo "\$meyvalar[$anah]: " . $değer["meyva"] . "\n";
}
?>

Bir çok boyutlu dizi sıralanırken $a ve $b dizinin ilk indisine gönderimleri içerir.

Yukarıdaki örneğin çıktısı:

$meyvalar[0]: limon
$meyvalar[1]: mandalina
$meyvalar[2]: portakal

Örnek 3 - Bir nesnenin üye yöntemini kullanan usort() örneği

<?php
class Deneme {
    var $isim;

    function Deneme($isim)
    {
        $this->isim = $isim;
    }

    /* Duruk karşılaştırma işlevi: */
    static function nesne_karşılaştır($a, $b)
    {
        $al = strtolower($a->isim);
        $bl = strtolower($b->isim);
        if ($al == $bl) {
            return 0;
        }
        return ($al > $bl) ? +1 : -1;
    }
}

$a[] = new Deneme("c");
$a[] = new Deneme("b");
$a[] = new Deneme("d");

usort($a, array("Deneme", "nesne_karşılaştır"));

foreach ($a as $öğe) {
    echo $öğe->isim . "\n";
}
?>

Yukarıdaki örneğin çıktısı:

b
c
d

Ayrıca Bakınız

  • uasort() - Bir diziyi kullanıcı tanımlı bir işlev kullanarak indislerine göre sıralarken anahtar/değer ilişkisini korur
  • Dizilerde Sıralama

uksort
Sınıflar ve Nesneler
Dizi İşlevleri


Sınıf ve Nesne Bilgileri

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
  • Sınıf ve Nesne İşlevleri
    • __autoload — Attempt to load undefined class
    • call_user_method_array — Değiştirge dizisi belirtilen bir kullanıcı yöntemini çağırır [önerilmiyor]
    • call_user_method — Belli bir nesnenin bir kullanıcı yöntemini çağırır [önerilmiyor]
    • class_alias — Creates an alias for a class
    • class_exists — Sınıf tanımlı mı diye bakar
    • get_called_class — Çağrıldığı duruk yöntemin sınıf ismini döndürür
    • get_class_methods — Sınıf yöntemlerinin isimlerini döndürür
    • get_class_vars — Sınıfın öntanımlı özelliklerini döndürür
    • get_class — Bir nesnenin ait olduğu sınıfın ismini döndürür
    • get_declared_classes — Tanımlı sınıfların isimlerini bir dizi olarak döndürür
    • get_declared_interfaces — Bildirilmiş tüm arayüzleri bir dizi olarak döndürür
    • get_declared_traits — Returns an array of all declared traits
    • get_object_vars — Belirtilen nesnenin özelliklerini döndürür
    • get_parent_class — Nesne veya sınıfın ebeveyn sınıfının ismini döndürür
    • interface_exists — Arayüz tanımlı mı diye bakar
    • is_a — Nesne ile sınıf arasında ebeveyn/çocuk ilişkisi var mı diye bakar
    • is_subclass_of — Belirtilen sınıfın belirtilen nesnenin ebeveynlerinden biri olup olmadığına bakar
    • method_exists — Bir sınıf yöntemi mevcut mu diye bakar
    • property_exists — Bir nesne veya sınıfın belirtilen özelliğe sahip olup olmadığına bakar
    • trait_exists — Checks if the trait exists
usort
Giriş
Değişkenler ve Veri Türleriyle İlgili Eklentiler


Giriş

Bu işlevler, sınıflar ve bunlardan örneklenmiş nesneler hakkında bilgi edinmenizi sağlar. Bir nesneye karşılık gelen sınıf isminden başka yöntem ve özellik isimlerini de bu işlevlerle öğrenebilirsiniz. Bu işlevleri kullanarak, bir nesnenin sadece sınıf üyeliğini bulmakla kalmaz ayrıca ebeveyn sınıflarınkileri de bulabilirsiniz.

Sınıflar ve Nesneler
Yapılandırma/Kurulum
Sınıflar ve Nesneler


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Sınıflar ve Nesneler


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
Örnekler
Sınıflar ve Nesneler


Örnekler

Bu örnekte, önce bir temel sınıf ve bu sınıfın bir türevini tanımlayacağız. Temel sınıf, genel olarak bitkileri, yenebilir olup olmadıkları ve renkleri ile tanımlayacak. Lahana alt sınıfı, sebzeyi pişirmek için bir yöntem ile pişirilmiş olup olmadığını bulan bir başka yöntem ekleyecek.

Örnek 1 sınıflar.inc

<?php

// Üye özellikler ve yöntemlerle temel sınıf
class Bitki {

   var $yenir;
   var $renk;

   function Bitki($yenir, $renk="yeşil")
   {
       $this->yenir = $yenir;
       $this->renk = $renk;
   }

   function yenir_mi()
   {
       return $this->yenir;
   }

   function ne_renk()
   {
       return $this->renk;
   }

} // Bitki sınıfının sonu

// temel sınıfı türetelim
class Lahana extends Bikti {

   var $pişmiş = false;

   function Lahana()
   {
       $this->Bitki(true, "yeşil");
   }

   function pişir()
   {
       $this->pişmiş = true;
   }

   function pişmiş_mi()
   {
       return $this->pişmiş;
   }

} // Lahana sınıfının sonu

?>

Bu sınıflardan iki nesne örnekleyip, ata sınıfları dahil bunlar hakkındaki tüm bilgiyi çıktılayacağız. Ayrıca, değişkenlerin çıktılarını güzelleştirmek için bazı ek işlevler tanımlayacağız.

Örnek 2 dnm.php

<pre>
<?php

include "sınıflar.inc";

// biçemleme işlevleri

function print_vars($obj)
{
foreach (get_object_vars($obj) as $prop => $val) {
    echo "\t$prop = $val\n";
}
}

function print_methods($obj)
{
$arr = get_class_methods(get_class($obj));
foreach ($arr as $method) {
    echo "\t$method() işlevi\n";
}
}

function class_parentage($obj, $class)
{
if (is_subclass_of($GLOBALS[$obj], $class)) {
    echo "$obj nesnesinin ait olduğu sınıf: " . get_class($$obj);
    echo ", alt sınıf ise: $class\n";
} else {
    echo "$obj nesnesi $class alt sınıfına ait değildir.\n";
}
}

// 2 nesne örnekleyelim

$sebze = new Bitki(true, "mavi");
$tombul = new Lahana();

// Nesne bilgilerini basalım
echo "sebze: " . get_class($sebze) . " sınıfında\n";
echo "tombul: " . get_class($tombul) . " sınıfında";
echo ", ATA sınıfı " . get_parent_class($tombul) . "\n";

// Sebze özelliklerini gösterelim
echo "\nsebze: Özellikler\n";
print_vars($sebze);

// ve tompul yöntemleri
echo "\ntombul: Yöntemler\n";
print_methods($tombul);

echo "\nEbeveynler:\n";
class_parentage("tombul", "Lahana");
class_parentage("tombul", "Bitki");
?>
</pre>

Yukarıdaki örnekte önemli şeylerden biri, $tombul nesnesinin Lahana sınıfının bir örneği, Lahana sınıfının ise Bitki sınıfının ise bir alt sınıfı oluşudur. Bu bakımdan betiğin son kısmının çıktısı şöyle olur:

   [...]
Ebeveynler:
tombul nesnesi Lahana alt sınıfına ait değildir.
tombul nesnesinin ait olduğu sınıf: Lahana, alt sınıf ise: Bitki

Öntanımlı Sabitler
Sınıf ve Nesne İşlevleri
Sınıflar ve Nesneler


Sınıf ve Nesne İşlevleri

İçindekiler

  • __autoload — Attempt to load undefined class
  • call_user_method_array — Değiştirge dizisi belirtilen bir kullanıcı yöntemini çağırır [önerilmiyor]
  • call_user_method — Belli bir nesnenin bir kullanıcı yöntemini çağırır [önerilmiyor]
  • class_alias — Creates an alias for a class
  • class_exists — Sınıf tanımlı mı diye bakar
  • get_called_class — Çağrıldığı duruk yöntemin sınıf ismini döndürür
  • get_class_methods — Sınıf yöntemlerinin isimlerini döndürür
  • get_class_vars — Sınıfın öntanımlı özelliklerini döndürür
  • get_class — Bir nesnenin ait olduğu sınıfın ismini döndürür
  • get_declared_classes — Tanımlı sınıfların isimlerini bir dizi olarak döndürür
  • get_declared_interfaces — Bildirilmiş tüm arayüzleri bir dizi olarak döndürür
  • get_declared_traits — Returns an array of all declared traits
  • get_object_vars — Belirtilen nesnenin özelliklerini döndürür
  • get_parent_class — Nesne veya sınıfın ebeveyn sınıfının ismini döndürür
  • interface_exists — Arayüz tanımlı mı diye bakar
  • is_a — Nesne ile sınıf arasında ebeveyn/çocuk ilişkisi var mı diye bakar
  • is_subclass_of — Belirtilen sınıfın belirtilen nesnenin ebeveynlerinden biri olup olmadığına bakar
  • method_exists — Bir sınıf yöntemi mevcut mu diye bakar
  • property_exists — Bir nesne veya sınıfın belirtilen özelliğe sahip olup olmadığına bakar
  • trait_exists — Checks if the trait exists
Örnekler
__autoload
Sınıflar ve Nesneler


Attempt to load undefined class

Sınıf ve Nesne İşlevleri
call_user_method_array
Sınıf ve Nesne İşlevleri
PHP Manual

__autoload

(PHP 5, PHP 7)

__autoload — Attempt to load undefined class

Açıklama

void __autoload ( string $class )

You can define this function to enable classes autoloading.

Değiştirgeler

class

Name of the class to load

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • spl_autoload_register() - Register given function as __autoload() implementation

Sınıf ve Nesne İşlevleri
call_user_method_array
Sınıf ve Nesne İşlevleri


Değiştirge dizisi belirtilen bir kullanıcı yöntemini çağırır [önerilmiyor]

__autoload
call_user_method
Sınıf ve Nesne İşlevleri
PHP Manual

call_user_method_array

(PHP 4 >= 4.0.5, PHP 5)

call_user_method_array — Değiştirge dizisi belirtilen bir kullanıcı yöntemini çağırır [önerilmiyor]

Açıklama

mixed call_user_method_array ( string $yöntem , object &$obj , array $değiştirgeler )
Uyarı

PHP 4.1.0'dan beri call_user_method_array() işlevinin kullanımı önerilmemektedir.

Örnekler

Örnek 1 - call_user_method_array() yerine call_user_func_array() kullanın

<?php
call_user_func_array(array($nesne, $yöntem), $değiştirgeler);
call_user_func_array(array(&$nesne, $yöntem), $değiştirgeler); // PHP 4
?>

Ayrıca Bakınız

  • call_user_func_array() - Değiştirgelerin bir dizi olarak verildiği kullanıcı işlevini çağırır
  • call_user_func() - İlk değiştirgede belirtilen kullanıcı işlevini çağırır

__autoload
call_user_method
Sınıf ve Nesne İşlevleri


Belli bir nesnenin bir kullanıcı yöntemini çağırır [önerilmiyor]

call_user_method_array
class_alias
Sınıf ve Nesne İşlevleri
PHP Manual

call_user_method

(PHP 4, PHP 5)

call_user_method — Belli bir nesnenin bir kullanıcı yöntemini çağırır [önerilmiyor]

Açıklama

mixed call_user_method ( string $yöntem , object &$nesne [, mixed $değiştirge [, mixed $... ]] )
Uyarı

PHP 4.1.0'dan beri call_user_method() işlevinin kullanımı önerilmemektedir.

Örnekler

Örnek 1 - call_user_method() yerine call_user_func() kullanın

<?php
call_user_func(array($nesne, $yöntem), $değiştirge /* , ... */);
call_user_func(array(&$nesne, $yöntem), $değiştirge /* , ... */); // PHP 4
?>

Ayrıca Bakınız

  • call_user_func_array() - Değiştirgelerin bir dizi olarak verildiği kullanıcı işlevini çağırır
  • call_user_func() - İlk değiştirgede belirtilen kullanıcı işlevini çağırır

call_user_method_array
class_alias
Sınıf ve Nesne İşlevleri


Creates an alias for a class

call_user_method
class_exists
Sınıf ve Nesne İşlevleri
PHP Manual

class_alias

(PHP 5 >= 5.3.0, PHP 7)

class_alias — Creates an alias for a class

Açıklama

bool class_alias ( string $original , string $alias [, bool $autoload = TRUE ] )

Creates an alias named alias based on the user defined class original. The aliased class is exactly the same as the original class.

Değiştirgeler

original

The original class.

alias

The alias name for the class.

autoload

Whether to autoload if the original class is not found.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 class_alias() example

<?php

class foo { }

class_alias('foo', 'bar');

$a = new foo;
$b = new bar;

// the objects are the same
var_dump($a == $b, $a === $b);
var_dump($a instanceof $b);

// the classes are the same
var_dump($a instanceof foo);
var_dump($a instanceof bar);

var_dump($b instanceof foo);
var_dump($b instanceof bar);

?>

Yukarıdaki örneğin çıktısı:

bool(true)
bool(false)
bool(true)
bool(true)
bool(true)
bool(true)
bool(true)

Ayrıca Bakınız

  • get_parent_class() - Nesne veya sınıfın ebeveyn sınıfının ismini döndürür
  • is_subclass_of() - Belirtilen sınıfın belirtilen nesnenin ebeveynlerinden biri olup olmadığına bakar

call_user_method
class_exists
Sınıf ve Nesne İşlevleri


Sınıf tanımlı mı diye bakar

class_alias
get_called_class
Sınıf ve Nesne İşlevleri
PHP Manual

class_exists

(PHP 4, PHP 5, PHP 7)

class_exists — Sınıf tanımlı mı diye bakar

Açıklama

bool class_exists ( string $sınıf [, bool $özdevinimli_yükle = true ] )

Bu işlev belirtilen sınıfın tanımlı olup olmadığına bakar.

Değiştirgeler

sınıf

Sınıf ismi. İsim eşleştirilirken harf büyüklüğü dikkate alınmaz.

özdevinimli_yükle

Öntanımlı olarak __autoload çağrısı yapılıp yapılmayacağı.

Dönen Değerler

sınıf tanımlı bir sınıfın ismi ise TRUE, aksi takdirde FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.2 | Tanımlı arayüzler için artık TRUE dönmüyor. Arayüzler için interface_exists() işlevini kullanın.
5.0.0 | özdevinimli_yükle değiştirgesi eklendi.

Örnekler

Örnek 1 class_exists() example

<?php
// Check that the class exists before trying to use it
if (class_exists('MyClass')) {
    $myclass = new MyClass();
}

?>

Örnek 2 autoload parameter example

<?php
function __autoload($class)
{
    include($class . '.php');

    // Check to see whether the include declared the class
    if (!class_exists($class, false)) {
        trigger_error("Unable to load class: $class", E_USER_WARNING);
    }
}

if (class_exists('MyClass')) {
    $myclass = new MyClass();
}

?>

Ayrıca Bakınız

  • function_exists() - Eğer işlev tanımlanmış ise TRUE döndürür
  • interface_exists() - Arayüz tanımlı mı diye bakar
  • get_declared_classes() - Tanımlı sınıfların isimlerini bir dizi olarak döndürür

class_alias
get_called_class
Sınıf ve Nesne İşlevleri


Çağrıldığı duruk yöntemin sınıf ismini döndürür

class_exists
get_class_methods
Sınıf ve Nesne İşlevleri
PHP Manual

get_called_class

(PHP 5 >= 5.3.0, PHP 7)

get_called_class — Çağrıldığı duruk yöntemin sınıf ismini döndürür

Açıklama

string get_called_class ( void )

Çağrıldığı duruk yöntemin sınıf ismini döndürür.

Dönen Değerler

Çağrıldığı sınıfın ismini döndürür. Bir sınıfın dışında çağrılırsa FALSE döndürür.

Örnekler

Örnek 1 - get_called_class() örneği

<?php

class foo {
    static public function test() {
        var_dump(get_called_class());
    }
}

class bar extends foo {
}

foo::test();
bar::test();

?>

Yukarıdaki örneğin çıktısı:

string(3) "foo"
string(3) "bar"

Ayrıca Bakınız

  • get_parent_class() - Nesne veya sınıfın ebeveyn sınıfının ismini döndürür
  • get_class() - Bir nesnenin ait olduğu sınıfın ismini döndürür
  • is_subclass_of() - Belirtilen sınıfın belirtilen nesnenin ebeveynlerinden biri olup olmadığına bakar

class_exists
get_class_methods
Sınıf ve Nesne İşlevleri


Sınıf yöntemlerinin isimlerini döndürür

get_called_class
get_class_vars
Sınıf ve Nesne İşlevleri
PHP Manual

get_class_methods

(PHP 4, PHP 5, PHP 7)

get_class_methods — Sınıf yöntemlerinin isimlerini döndürür

Açıklama

array get_class_methods ( mixed $sınıf )

Sınıf yöntemlerinin isimlerini döndürür.

Değiştirgeler

sınıf

Sınıf veya nesne ismi.

Dönen Değerler

Sınıf yöntemlerinin isimlerini bir dizi olarak döndürür. Hata durumunda NULL döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.0 | PHP 5'ten itibaren, bu işlev yöntem isimlerini bildirildikleri isimleriyle (harf büyüklüğüne duyarlı) döndürmektedir. PHP 4'te küçük harfli döndürülürdü.
4.0.6 | Nesnenin kendisini belirtebilmesi yeteneği eklendi.

Örnekler

Örnek 1 - get_class_methods() örneği

<?php

class myclass {
    // kurucu
    function myclass()
    {
        return(true);
    }

    // 1. yöntem
    function myfunc1()
    {
        return(true);
    }

    // 2. yöntem
    function myfunc2()
    {
        return(true);
    }
}

$class_methods = get_class_methods('myclass');
// veya
$class_methods = get_class_methods(new myclass());

foreach ($class_methods as $method_name) {
    echo "$method_name\n";
}

?>

Yukarıdaki örneğin çıktısı:

myclass
myfunc1
myfunc2

Ayrıca Bakınız

  • get_class() - Bir nesnenin ait olduğu sınıfın ismini döndürür
  • get_class_vars() - Sınıfın öntanımlı özelliklerini döndürür
  • get_object_vars() - Belirtilen nesnenin özelliklerini döndürür

get_called_class
get_class_vars
Sınıf ve Nesne İşlevleri


Sınıfın öntanımlı özelliklerini döndürür

get_class_methods
get_class
Sınıf ve Nesne İşlevleri
PHP Manual

get_class_vars

(PHP 4, PHP 5, PHP 7)

get_class_vars — Sınıfın öntanımlı özelliklerini döndürür

Açıklama

array get_class_vars ( string $sınıf )

Belirtilen sınıf sınıfının öntanımlı public özelliklerini döndürür.

Değiştirgeler

sınıf

Sınıfın ismi.

Dönen Değerler

Belirtilen sınıf sınıfının öntanımlı public özelliklerini içeren bir ilişkisel dizi döndürür. Dizi elemanları özellik => değer biçemindedir.

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.3 | Etki alanına bağlı olarak, get_class_vars() artık sadece, geçerli etki alanında erişilebilir olan özellikleri döndürüyor.
5.0.2 | get_class_vars() artık dizi içinde tüm özellikleri döndürüyor. Evvelce protected ve private özellikler nul baytlarla öncelenerek döndürülürdü.
5.0.1 | get_class_vars(), bir nesne bir sınıfa dönüştürüldüğünde artık tüm özellikleri döndürüyor.
4.2.0 öncesi | İlklendirilmemiş sınıf değişkenleri get_class_vars() ile döndürülmez.

Örnekler

Örnek 1 - get_class_vars() örneği

<?php

class myclass {

    var $var1; // Bunun öntanımlı bir değeri yok...
    var $var2 = "xyz";
    var $var3 = 100;
    private $var4; // PHP 5

    // constructor
    function myclass() {
        // Bazı özellikleri değiştirelim
        $this->var1 = "foo";
        $this->var2 = "bar";
        return true;
    }

}

$my_class = new myclass();

$class_vars = get_class_vars(get_class($my_class));

foreach ($class_vars as $name => $value) {
    echo "$name : $value\n";
}

?>

Yukarıdaki örneğin çıktısı:

// PHP 4.2.0 öncesi
var2 : xyz
var3 : 100

// PHP 4.2.0'dan itibaren
var1 :
var2 : xyz
var3 : 100

Örnek 2 - get_class_vars() ve etki alanı

<?php
function format($array)
{
 return implode('|', array_keys($array)) . "\r\n";
}

class TestCase
{
 public $a = 1;
 protected $b  = 2;
 private $c  = 3;

 public static function expose()
 {
   echo format(get_class_vars(__CLASS__));
 }
}

TestCase::expose();
echo format(get_class_vars('TestCase'));
?>

Yukarıdaki örneğin çıktısı:

// 5.0.0
a| * b| TestCase c
a| * b| TestCase c

// 5.0.1 - 5.0.2
a|b|c
a|b|c

// 5.0.3 +
a|b|c
a

Ayrıca Bakınız

  • get_class_methods() - Sınıf yöntemlerinin isimlerini döndürür
  • get_object_vars() - Belirtilen nesnenin özelliklerini döndürür

get_class_methods
get_class
Sınıf ve Nesne İşlevleri


Bir nesnenin ait olduğu sınıfın ismini döndürür

get_class_vars
get_declared_classes
Sınıf ve Nesne İşlevleri
PHP Manual

get_class

(PHP 4, PHP 5, PHP 7)

get_class — Bir nesnenin ait olduğu sınıfın ismini döndürür

Açıklama

string get_class ([ object $nesne ] )

Belirtilen nesne nesnesinin ait olduğu sınıfın ismini döndürür.

Değiştirgeler

nesne

Sınanacak nesne.

Dönen Değerler

Belirtilen nesne nesnesinin ait olduğu sınıfın ismini bir dizge olarak döndürür. Eğer nesne bir nesne değilse FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.0'dan itibaren | Sınıf ismi özgün yazılışı ile döndürülüyor.
5.0.0'dan itibaren | İşlev nesnenin bir yönteminden çağrılırsa nesne değiştirgesinin belirtilmesi isteğe bağlıdır.

Örnekler

Örnek 1 - get_class() örneği

<?php

class foo {
    function ismin_ne()
    {
        echo "İsmim " , get_class($this) , "\n";
    }
}

// Bir nesne oluşturalım
$bar = new foo();

// dışardan çağrı
echo "İsmi " , get_class($bar) , "\n";

// içerden çağrı
$bar->ismin_ne();

?>

Yukarıdaki örneğin çıktısı:

İsmi foo
İsmim foo

Örnek 2 - Alt sınıftan get_class() çağrısı

<?php

abstract class bar {
  public function __construct()
  {
    var_dump(get_class($this));
    var_dump(get_class());
  }
}

class foo extends bar {
}

new foo;

?>

Yukarıdaki örneğin çıktısı:

string(3) "foo"
string(3) "bar"

Ayrıca Bakınız

  • get_parent_class() - Nesne veya sınıfın ebeveyn sınıfının ismini döndürür
  • gettype() - Bir değişkenin türünü döndürür
  • is_subclass_of() - Belirtilen sınıfın belirtilen nesnenin ebeveynlerinden biri olup olmadığına bakar

get_class_vars
get_declared_classes
Sınıf ve Nesne İşlevleri


Tanımlı sınıfların isimlerini bir dizi olarak döndürür

get_class
get_declared_interfaces
Sınıf ve Nesne İşlevleri
PHP Manual

get_declared_classes

(PHP 4, PHP 5, PHP 7)

get_declared_classes — Tanımlı sınıfların isimlerini bir dizi olarak döndürür

Açıklama

array get_declared_classes ( void )

Tanımlı sınıfların isimlerini döndürür.

Dönen Değerler

Betikte tanımlanmış sınıfların isimlerini içeren bir dizi döner.

Bilginize:

PHP ile derlediğiniz veya yüklediğiniz eklentilere bağlı olarak, dizi başka sınıflar de içerebilir. Yani, bu sınıflarla aynı isimde kendi sınıflarınızı tanımlayamazsınız. Evvelce tanımlanmış sınıfların isimlerini eklerdeki Öntanımlı Sınıflar bölümünde bulabilirsiniz.

Örnekler

Örnek 1 - get_declared_classes() örneği

<?php
print_r(get_declared_classes());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [0] => stdClass
    [1] => Exception
    [2] => ErrorException
    [3] => InvalidArgumentException
    [4] => UnexpectedValueException
)

Ayrıca Bakınız

  • class_exists() - Sınıf tanımlı mı diye bakar
  • get_declared_interfaces() - Bildirilmiş tüm arayüzleri bir dizi olarak döndürür
  • get_defined_functions() - Tanımlanmış bütün işlevleri içeren bir dizi döndürür

get_class
get_declared_interfaces
Sınıf ve Nesne İşlevleri


Bildirilmiş tüm arayüzleri bir dizi olarak döndürür

get_declared_classes
get_declared_traits
Sınıf ve Nesne İşlevleri
PHP Manual

get_declared_interfaces

(PHP 5, PHP 7)

get_declared_interfaces — Bildirilmiş tüm arayüzleri bir dizi olarak döndürür

Açıklama

array get_declared_interfaces ( void )

Bildirilmiş tüm arayüzleri döndürür.

Dönen Değerler

Betikte bildirilmiş arayüzlerin isimlerini içeren bir dizi döner.

Örnekler

Örnek 1 - get_declared_interfaces() örneği

<?php
print_r(get_declared_interfaces());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [0] => Traversable
    [1] => IteratorAggregate
    [2] => Iterator
    [3] => ArrayAccess
    [4] => reflector
    [5] => RecursiveIterator
    [6] => SeekableIterator
)

Ayrıca Bakınız

  • get_declared_classes() - Tanımlı sınıfların isimlerini bir dizi olarak döndürür
  • class_implements() - Return the interfaces which are implemented by the given class or interface

get_declared_classes
get_declared_traits
Sınıf ve Nesne İşlevleri


Returns an array of all declared traits

get_declared_interfaces
get_object_vars
Sınıf ve Nesne İşlevleri
PHP Manual

get_declared_traits

(PHP 5 >= 5.4.0, PHP 7)

get_declared_traits — Returns an array of all declared traits

Açıklama

array get_declared_traits ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array with names of all declared traits in values. Returns NULL in case of a failure.

Ayrıca Bakınız

  • class_uses() - Return the traits used by the given class

get_declared_interfaces
get_object_vars
Sınıf ve Nesne İşlevleri


Belirtilen nesnenin özelliklerini döndürür

get_declared_traits
get_parent_class
Sınıf ve Nesne İşlevleri
PHP Manual

get_object_vars

(PHP 4, PHP 5, PHP 7)

get_object_vars — Belirtilen nesnenin özelliklerini döndürür

Açıklama

array get_object_vars ( object $nesne )

Belirtilen nesne nesnesinin etki alanına bağlı olarak erişilebilen duruk olmayan özelliklerini döndürür.

Değiştirgeler

nesne

Bir sınıfın örneği.

Dönen Değerler

Belirtilen nesne nesnesinin etki alanına bağlı olarak erişilebilen duruk olmayan özelliklerini bir dizi olarak döndürür. Eğer bir özelliğe henüz bir değer atanmamışsa bu özellik bir NULL değerle döner.

Sürüm Bilgisi

Sürüm: | Açıklama
4.2.0 öncesi | nesne nesnesinin bir örneği olduğu sınıf içinde, değer atanmadan bildirilmiş değişkenler varsa bunlar dizi içinde dönmez.

Örnekler

Örnek 1 - get_object_vars() örneği

<?php

class foo {
    private $a;
    public $b = 1;
    public $c;
    private $d;
    static $e;

    public function test() {
        var_dump(get_object_vars($this));
    }
}

$test = new foo;
var_dump(get_object_vars($test));

$test->test();

?>

Yukarıdaki örneğin çıktısı:

array(2) {
  ["b"]=>
  int(1)
  ["c"]=>
  NULL
}
array(4) {
  ["a"]=>
  NULL
  ["b"]=>
  int(1)
  ["c"]=>
  NULL
  ["d"]=>
  NULL
}

Ayrıca Bakınız

  • get_class_methods() - Sınıf yöntemlerinin isimlerini döndürür
  • get_class_vars() - Sınıfın öntanımlı özelliklerini döndürür

get_declared_traits
get_parent_class
Sınıf ve Nesne İşlevleri


Nesne veya sınıfın ebeveyn sınıfının ismini döndürür

get_object_vars
interface_exists
Sınıf ve Nesne İşlevleri
PHP Manual

get_parent_class

(PHP 4, PHP 5, PHP 7)

get_parent_class — Nesne veya sınıfın ebeveyn sınıfının ismini döndürür

Açıklama

string get_parent_class ([ mixed $nesne ] )

Belirtilen nesne nesnesinin veya sınıfının ebeveyn sınıfının ismini döndürür.

Değiştirgeler

nesne

Sınanacak sınıf veya nesne ismi.

Dönen Değerler

Belirtilen nesne nesnesinin veya sınıfının ebeveyn sınıfının ismini bir dizge olarak döndürür.

Bilginize:

Nesnenin bir ebeveyni yoksa FALSE döner.

İşlev değiştirgesiz çağrılırsa FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.0 öncesi | Değiştirgesiz çağrıldığında bir uyarıyla birlikte NULL dönerdi.
5.0.0'dan itibaren | Nesnenin yönteminden çağrıldığında değiştirge isteğe bağlıdır.
4.0.5'ten itibaren | nesne bir dizge ise bu isimdeki sınıfın ebeveyn sınıfının ismi döner.

Örnekler

Örnek 1 - get_parent_class() örneği

<?php

class baba {
    function baba()
    {
    // Biraz mantık yürütelim
    }
}

class oğul extends baba {
    function oğul()
    {
        echo "Ben " , get_parent_class($this) , "mın oğluyum\n";
    }
}

class kız extends baba{
    function kız()
    {
        echo "Ben " , get_parent_class('kız') , "mın kızıyım\n";
    }
}

$bar = new oğul();
$foo = new kız();

?>

Yukarıdaki örneğin çıktısı:

Ben babamın oğluyum
Ben babamın kızıyım

Ayrıca Bakınız

  • get_class() - Bir nesnenin ait olduğu sınıfın ismini döndürür
  • is_subclass_of() - Belirtilen sınıfın belirtilen nesnenin ebeveynlerinden biri olup olmadığına bakar

get_object_vars
interface_exists
Sınıf ve Nesne İşlevleri


Arayüz tanımlı mı diye bakar

get_parent_class
is_a
Sınıf ve Nesne İşlevleri
PHP Manual

interface_exists

(PHP 5 >= 5.0.2, PHP 7)

interface_exists — Arayüz tanımlı mı diye bakar

Açıklama

bool interface_exists ( string $arayüz [, bool $özdevinimli_yükle = true ] )

Belirtilen arayüz tanımlı mı diye bakar.

Değiştirgeler

arayüz

Arayüzün ismi.

özdevinimli_yükle

__autoload çağrısı yapılıp yapılmayacağı. Öntanımlı olarak yapılmaz.

Dönen Değerler

Belirtilen arayüz tanımlıysa TRUE, aksi takdirde FALSE döner.

Örnekler

Örnek 1 - interface_exists() örneği

<?php
// Kullanmaya çalışmadan önce arayüz tanımlı mı diye bakalım
if (interface_exists('Arayüzüm')) {
    class Sınıfım implements Arayüzüm
    {
        // Yöntemler
    }
}

?>

Ayrıca Bakınız

  • class_exists() - Sınıf tanımlı mı diye bakar

get_parent_class
is_a
Sınıf ve Nesne İşlevleri


Nesne ile sınıf arasında ebeveyn/çocuk ilişkisi var mı diye bakar

interface_exists
is_subclass_of
Sınıf ve Nesne İşlevleri
PHP Manual

is_a

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

is_a — Nesne ile sınıf arasında ebeveyn/çocuk ilişkisi var mı diye bakar

Açıklama

bool is_a ( object $nesne , string $sınıf )

Belirtilen sınıf sınıfının, belirtilen nesne nesnesinin ebeveynlerinden veya çocuklarından biri mi diye bakar.

Değiştirgeler

nesne

Sınanacak nesne.

sınıf

Olası ebeveyn veya çocuk sınıf ismi.

Dönen Değerler

nesne nesnesi sınıf sınıfının alt veya üst sınıflarından birinin nesnesi ise TRUE değilse FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | Bu işlev artık önerilmeyen bir işlev değil ve artık bir E_STRICT uyarısı oluşturmuyor.
5.0.0 | instanceof işlecinin varlığı nedeniyle bu işlevin kullanımı artık önerilmiyor. Bu işleve yapılan çağrılar E_STRICT seviyesinde bir uyarıya sebep oluyor.

Örnekler

Örnek 1 - is_a() örneği

<?php
// bir sınıf tanımlayalım
class EdevatFabrikası
{
  var $oink = 'moo';
}

// Bir nesne oluşturalım
$EF = new EdevatFabrikası();

if (is_a($EF, 'EdevatFabrikası')) {
  echo "Evet, \$EF hala bir EdevatFabrikası\n";
}
?>

Örnek 2 - PHP 5'teki instanceof işlecinin kullanımı

<?php
if ($EF instanceof EdevatFabrikası) {
    echo 'Evet, $EF bir EdevatFabrikası';
}
?>

Ayrıca Bakınız

  • get_class() - Bir nesnenin ait olduğu sınıfın ismini döndürür
  • get_parent_class() - Nesne veya sınıfın ebeveyn sınıfının ismini döndürür
  • is_subclass_of() - Belirtilen sınıfın belirtilen nesnenin ebeveynlerinden biri olup olmadığına bakar

interface_exists
is_subclass_of
Sınıf ve Nesne İşlevleri


Belirtilen sınıfın belirtilen nesnenin ebeveynlerinden biri olup olmadığına bakar

is_a
method_exists
Sınıf ve Nesne İşlevleri
PHP Manual

is_subclass_of

(PHP 4, PHP 5, PHP 7)

is_subclass_of — Belirtilen sınıfın belirtilen nesnenin ebeveynlerinden biri olup olmadığına bakar

Açıklama

bool is_subclass_of ( mixed $nesne , string $sınıf )

Belirtilen sınıf sınıfının, belirtilen nesne nesnesinin ebeveynlerinden biri olup olmadığına bakar.

Değiştirgeler

nesne

Çocuk sınıf veya nesne ismi.

sınıf

Olası ebeveynin ismi.

Dönen Değerler

nesne nesnesi sınıf sınıfının alt sınıflarından birinin nesnesi ise TRUE değilse FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.3 | nesne değiştirgesinde artık bir dizge (sınıfın ismi) belirtilebiliyor.

Örnekler

Örnek 1 - is_subclass_of() örneği

<?php
// bir sınıf tanımlayalım
class EdevatFabrikası
{
  var $oink = 'moo';
}

// Bir alt sınıf tanımlayalım
class MakineAtölyesi extends EdevatFabrikası
{
  var $oink = 'oink';
}

// Yeni bir nesne oluşturalım
$EF = new EdevatFabrikası();
$MA = new MakineAtölyesi();

if (is_subclass_of($MA, 'EdevatFabrikası')) {
  echo "Evet, \$MA EdevatFabrikası'nın bir alt sınıfıdır\n";
} else {
  echo "Hayır, \$MA EdevatFabrikası'nın bir alt sınıfı değildir\n";
}

if (is_subclass_of($EF, 'MakineAtölyesi')) {
  echo "Evet, \$EF MakineAtölyesi'nin bir alt sınıfıdır\n";
} else {
  echo "Hayır, \$EF MakineAtölyesi'nin bir alt sınıfı değildir\n";
}

// PHP 5.0.3'ten itibaren
if (is_subclass_of('MakineAtölyesi', 'EdevatFabrikası')) {
  echo "Evet, MakineAtölyesi EdevatFabrikası'nın bir alt sınıfıdır\n";
} else {
  echo "Hayır, MakineAtölyesi EdevatFabrikası'nın bir alt sınıfı değildir\n";
}
?>

Yukarıdaki örneğin çıktısı:

Evet, $MA EdevatFabrikası'nın bir alt sınıfıdır
Hayır, $EF MakineAtölyesi'nin bir alt sınıfı değildir
Evet, MakineAtölyesi EdevatFabrikası'nın bir alt sınıfıdır

Ayrıca Bakınız

  • get_class() - Bir nesnenin ait olduğu sınıfın ismini döndürür
  • get_parent_class() - Nesne veya sınıfın ebeveyn sınıfının ismini döndürür
  • is_a() - Nesne ile sınıf arasında ebeveyn/çocuk ilişkisi var mı diye bakar

is_a
method_exists
Sınıf ve Nesne İşlevleri


Bir sınıf yöntemi mevcut mu diye bakar

is_subclass_of
property_exists
Sınıf ve Nesne İşlevleri
PHP Manual

method_exists

(PHP 4, PHP 5, PHP 7)

method_exists — Bir sınıf yöntemi mevcut mu diye bakar

Açıklama

bool method_exists ( mixed $sınıf , string $yöntem )

Belirtilen sınıf sınıfının belirtilen yöntem yöntemine sahip olup olmadığına bakar.

Değiştirgeler

sınıf

Sınanacak nesne veya sınıfın ismi.

yöntem

Aranacak yöntemin ismi.

Dönen Değerler

Belirtilen sınıf sınıfı, belirtilen yöntem yöntemine sahipse TRUE, değilse FALSE döner.

Örnekler

Örnek 1 - method_exists() örneği

<?php
$directory = new Directory('.');
var_dump(method_exists($directory,'read'));
?>

Yukarıdaki örneğin çıktısı:

bool(true)

Örnek 2 - Duruk method_exists() örneği

<?php
var_dump(method_exists('Directory','read'));
?>

Yukarıdaki örneğin çıktısı:

bool(true)

Ayrıca Bakınız

  • function_exists() - Eğer işlev tanımlanmış ise TRUE döndürür
  • is_callable() - Bir değişkenin içeriğinin bir işlev olarak çağrılabilirliğini doğrular

is_subclass_of
property_exists
Sınıf ve Nesne İşlevleri


Bir nesne veya sınıfın belirtilen özelliğe sahip olup olmadığına bakar

method_exists
trait_exists
Sınıf ve Nesne İşlevleri
PHP Manual

property_exists

(PHP 5 >= 5.1.0, PHP 7)

property_exists — Bir nesne veya sınıfın belirtilen özelliğe sahip olup olmadığına bakar

Açıklama

bool property_exists ( mixed $sınıf , string $özellik )

Bu işlev, belirtilen sınıf sınıfının belirtilen özellik özelliğine sahip olup olmadığına bakar.

Bilginize:

isset() işlevinin tersine, property_exists() işlevi, özelliğin değeri NULL olsa bile TRUE döndürür.

Değiştirgeler

sınıf

Sınanacak sınıf veya nesne.

özellik

Aranacak özelliğin ismi.

Dönen Değerler

Özellik mevcutsa TRUE, değilse FALSE, bir hata durumunda NULL döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | Artık özelliğin varlığına erişilebilirlikten bağımsız olarak bakılıyor.

Örnekler

Örnek 1 - property_exists() örneği

<?php

class myClass {
    public $mine;
    private $xpto;
    static protected $test;

    static function test() {
        var_dump(property_exists('myClass', 'xpto')); //true
    }
}

var_dump(property_exists('myClass', 'mine'));   //true
var_dump(property_exists(new myClass, 'mine')); //true
var_dump(property_exists('myClass', 'xpto'));   //true, PHP 5.3.0'dan beri
var_dump(property_exists('myClass', 'bar'));    //false
var_dump(property_exists('myClass', 'test'));   //true, PHP 5.3.0'dan beri
myClass::test();

?>

Ayrıca Bakınız

  • method_exists() - Bir sınıf yöntemi mevcut mu diye bakar

method_exists
trait_exists
Sınıf ve Nesne İşlevleri


Checks if the trait exists

property_exists
Classkit
Sınıf ve Nesne İşlevleri
PHP Manual

trait_exists

(PHP 5 >= 5.4.0, PHP 7)

trait_exists — Checks if the trait exists

Açıklama

bool trait_exists ( string $traitname [, bool $autoload ] )

Değiştirgeler

traitname

Name of the trait to check

autoload

Whether to autoload if not already loaded.

Dönen Değerler

Returns TRUE if trait exists, FALSE if not, NULL in case of an error.

property_exists
Classkit
Sınıf ve Nesne İşlevleri


Classkit

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Classkit İşlevleri
    • classkit_import — Yeni sınıf yöntem tanımlarını, verilen dosyadan içe aktarır
    • classkit_method_add — Verilen sınıfa devingen olarak yeni bir yöntem ekler
    • classkit_method_copy — Yöntemi bir sınıftan diğerine kopyalar
    • classkit_method_redefine — Verilen yöntemin kodunu devingen olarak değiştirir
    • classkit_method_remove — Verilen yöntemi devingen olarak kaldırır
    • classkit_method_rename — Verilen yöntemin ismini devingen olarak değiştirir
trait_exists
Giriş
Değişkenler ve Veri Türleriyle İlgili Eklentiler


Giriş

Bu işlevler çalışma anında, PHP sınıfları üzerinde devingen işlemler yapılmasını sağlar.

Bilginize:

Bu eklenti, runkit ile değiştirilmiştir. Runkit eklentisi, sadece sınıflar üzerinde değil, işlevler üzerinde de devingen işlem yapılmasına izin verir.

Classkit
Yapılandırma/Kurulum
Classkit


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Classkit


Kurulum

Bu eklentinin geliştirmesi durmuştur. Ancak, kaynak kodunu PECL SVN deposunda bulabilirsiniz. Yeri: » http://svn.php.net/viewvc/pecl/classkit.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

CLASSKIT_ACC_PRIVATE (int)
Yöntemi private olarak işaretler.
CLASSKIT_ACC_PROTECTED (int)
Yöntemi protected olarak işaretler.
CLASSKIT_ACC_PUBLIC (int)
Yöntemi public olarak işaretler.

Özkaynak Türleri
Classkit İşlevleri
Classkit


Classkit İşlevleri

İçindekiler

  • classkit_import — Yeni sınıf yöntem tanımlarını, verilen dosyadan içe aktarır
  • classkit_method_add — Verilen sınıfa devingen olarak yeni bir yöntem ekler
  • classkit_method_copy — Yöntemi bir sınıftan diğerine kopyalar
  • classkit_method_redefine — Verilen yöntemin kodunu devingen olarak değiştirir
  • classkit_method_remove — Verilen yöntemi devingen olarak kaldırır
  • classkit_method_rename — Verilen yöntemin ismini devingen olarak değiştirir
Öntanımlı Sabitler
classkit_import
Classkit


Yeni sınıf yöntem tanımlarını, verilen dosyadan içe aktarır

Classkit İşlevleri
classkit_method_add
Classkit İşlevleri
PHP Manual

classkit_import

(PECL classkit >= 0.3)

classkit_import — Yeni sınıf yöntem tanımlarını, verilen dosyadan içe aktarır

Açıklama

array classkit_import ( string $dosyaadi )

Bilginize: Bu işlev çalışmakta olan yöntemi değiştirmekte kullanılamaz.

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Değiştirgeler

dosyaadi

İçe aktarılacak sınıf yöntemlerini içeren dosya adı

Dönen Değerler

İçe aktarılan yöntemleri içeren ilişkili dizi

Örnekler

Örnek 1 - classkit_import() örneği

<?php
// file: newclass.php
class Example {
    function foo() {
        return "bar!\n";
    }
}
?>
<?php
// requires newclass.php
class Example {
    function foo() {
        return "foo!\n";
    }
}

$e = new Example();

// özgün çıktı
echo $e->foo();

// değiştirilecek yöntemi aktar
classkit_import('newclass.php');

// aktarılan yöntem
echo $e->foo();

?>

Yukarıdaki örneğin çıktısı:

foo!
bar!

Ayrıca Bakınız

  • classkit_method_add() - Verilen sınıfa devingen olarak yeni bir yöntem ekler
  • classkit_method_copy() - Yöntemi bir sınıftan diğerine kopyalar

Classkit İşlevleri
classkit_method_add
Classkit İşlevleri


Verilen sınıfa devingen olarak yeni bir yöntem ekler

classkit_import
classkit_method_copy
Classkit İşlevleri
PHP Manual

classkit_method_add

(PECL classkit >= 0.1)

classkit_method_add — Verilen sınıfa devingen olarak yeni bir yöntem ekler

Açıklama

bool classkit_method_add ( string $sinifadi , string $yontemadi , string $degistirgeler , string $kod [, int $bayraklar = CLASSKIT_ACC_PUBLIC ] )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Değiştirgeler

sinifadi

Yöntemin ekleneceği sınıf adı

yontemadi

Eklenecek yöntemin adı

degistirgeler

Yeni yöntem için virgülle ayrılmış değiştirgeler listesi

kod

yontemadi çağrıldığı zaman işleyecek kod

bayraklar

Yöntemin tipi, CLASSKIT_ACC_PUBLIC, CLASSKIT_ACC_PROTECTED veya CLASSKIT_ACC_PRIVATE değerlerinden biri olabilir

Bilginize:

Bu değiştirge, PHP 5'den itibaren kullanılabilir, öncesinde bütün yöntemler açıktır (public).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - classkit_method_add() örneği

<?php
class Example {
    function foo() {
        echo "foo!\n";
    }
}

// Example nesnesi oluştur
$e = new Example();

// Yeni açık (public) yöntem ekle
classkit_method_add(
    'Example',
    'add',
    '$num1, $num2',
    'return $num1 + $num2;',
    CLASSKIT_ACC_PUBLIC
);

// 12 + 4
echo $e->add(12, 4);
?>

Yukarıdaki örneğin çıktısı:

16

Ayrıca Bakınız

  • classkit_method_copy() - Yöntemi bir sınıftan diğerine kopyalar
  • classkit_method_redefine() - Verilen yöntemin kodunu devingen olarak değiştirir
  • classkit_method_remove() - Verilen yöntemi devingen olarak kaldırır
  • classkit_method_rename() - Verilen yöntemin ismini devingen olarak değiştirir
  • create_function() - Bir anonim (lamda tarzı) işlev oluşturur

classkit_import
classkit_method_copy
Classkit İşlevleri


Yöntemi bir sınıftan diğerine kopyalar

classkit_method_add
classkit_method_redefine
Classkit İşlevleri
PHP Manual

classkit_method_copy

(PECL classkit >= 0.2)

classkit_method_copy — Yöntemi bir sınıftan diğerine kopyalar

Açıklama

bool classkit_method_copy ( string $hSinif , string $hYontem , string $kSinif [, string $kYontem ] )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Değiştirgeler

hSinif

Kopyalanacak yöntem için hedef sınıf

hYontem

Hedef yöntem adı

kSinif

Kopyalanacak yöntemin kaynak sınıfı

kYontem

Kaynak sınıftan kopyalanacak yöntem adı. Eğer değiştirge ihmal edilirse öntanımlı olarak hYontem değeri kullanılır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - classkit_method_copy() örneği

<?php
class Foo {
    function example() {
        return "foo!\n";
    }
}

class Bar {
    // başlangıçta hiçbir yontem yok
}

// example yöntemini, Foo sınıfından Bar sınıfına, baz ismi ile kopyala
classkit_method_copy('Bar', 'baz', 'Foo', 'example');

// kopyalanmış yöntem çıktısı
echo Bar::baz();
?>

Yukarıdaki örneğin çıktısı:

foo!

Ayrıca Bakınız

  • classkit_method_add() - Verilen sınıfa devingen olarak yeni bir yöntem ekler
  • classkit_method_redefine() - Verilen yöntemin kodunu devingen olarak değiştirir
  • classkit_method_remove() - Verilen yöntemi devingen olarak kaldırır
  • classkit_method_rename() - Verilen yöntemin ismini devingen olarak değiştirir

classkit_method_add
classkit_method_redefine
Classkit İşlevleri


Verilen yöntemin kodunu devingen olarak değiştirir

classkit_method_copy
classkit_method_remove
Classkit İşlevleri
PHP Manual

classkit_method_redefine

(PECL classkit >= 0.1)

classkit_method_redefine — Verilen yöntemin kodunu devingen olarak değiştirir

Açıklama

bool classkit_method_redefine ( string $sinifadi , string $yontemadi , string $degistirgeler , string $kod [, int $bayraklar = CLASSKIT_ACC_PUBLIC ] )

Bilginize: Bu işlev çalışmakta olan yöntemi değiştirmekte kullanılamaz.

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Değiştirgeler

sinifadi

Yeniden tanımlanacak yöntemin sınıfı

yontemadi

Yeniden tanımlanacak yöntem

degistirgeler

Yöntemin virgülle ayrılmış değiştirgeler listesi

kod

yontemadi çağrıldığında işleyecek olan yeni kod

bayraklar

Yöntem CLASSKIT_ACC_PUBLIC, CLASSKIT_ACC_PROTECTED veya CLASSKIT_ACC_PRIVATE tiplerinden biri olabilir

Bilginize:

Bu değiştirge, PHP 5'den itibaren kullanılabilir, öncesinde bütün yöntemler açıktır (public).

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - classkit_method_redefine() örneği

<?php
class Example {
    function foo() {
        return "foo!\n";
    }
}

// Example nesnesi oluştur
$e = new Example();

// Example::foo() (yeniden tanımlamadan önce yöntem çıktısı)
echo "Before: " . $e->foo();

// 'foo' yöntemini yeniden tanımla
classkit_method_redefine(
    'Example',
    'foo',
    '',
    'return "bar!\n";',
    CLASSKIT_ACC_PUBLIC
);

// Example::foo() (yeniden tanımlamadan sonra yöntem çıktısı)
echo "After: " . $e->foo();
?>

Yukarıdaki örneğin çıktısı:

Before: foo!
After: bar!

Ayrıca Bakınız

  • classkit_method_add() - Verilen sınıfa devingen olarak yeni bir yöntem ekler
  • classkit_method_copy() - Yöntemi bir sınıftan diğerine kopyalar
  • classkit_method_remove() - Verilen yöntemi devingen olarak kaldırır
  • classkit_method_rename() - Verilen yöntemin ismini devingen olarak değiştirir

classkit_method_copy
classkit_method_remove
Classkit İşlevleri


Verilen yöntemi devingen olarak kaldırır

classkit_method_redefine
classkit_method_rename
Classkit İşlevleri
PHP Manual

classkit_method_remove

(PECL classkit >= 0.1)

classkit_method_remove — Verilen yöntemi devingen olarak kaldırır

Açıklama

bool classkit_method_remove ( string $sinifadi , string $yontemadi )

Bilginize: Bu işlev çalışmakta olan yöntemi değiştirmekte kullanılamaz.

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Değiştirgeler

sinifadi

Yöntemin kaldırılacağı sınıf adı

yontemadi

Kaldırılacak yöntemin adı

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - classkit_method_remove() örneği

<?php
class Example {
    function foo() {
        return "foo!\n";
    }

    function bar() {
        return "bar!\n";
    }
}

// foo yöntemini kaldır
classkit_method_remove(
    'Example',
    'foo'
);

echo implode(' ', get_class_methods('Example'));

?>

Yukarıdaki örneğin çıktısı:

bar

Ayrıca Bakınız

  • classkit_method_add() - Verilen sınıfa devingen olarak yeni bir yöntem ekler
  • classkit_method_copy() - Yöntemi bir sınıftan diğerine kopyalar
  • classkit_method_redefine() - Verilen yöntemin kodunu devingen olarak değiştirir
  • classkit_method_rename() - Verilen yöntemin ismini devingen olarak değiştirir

classkit_method_redefine
classkit_method_rename
Classkit İşlevleri


Verilen yöntemin ismini devingen olarak değiştirir

classkit_method_remove
Ctype
Classkit İşlevleri
PHP Manual

classkit_method_rename

(PECL classkit >= 0.1)

classkit_method_rename — Verilen yöntemin ismini devingen olarak değiştirir

Açıklama

bool classkit_method_rename ( string $sinifadi , string $yontemadi , string $yeniisim )

Bilginize: Bu işlev çalışmakta olan yöntemi değiştirmekte kullanılamaz.

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Değiştirgeler

sinifadi

Yeniden isimlendirilecek yöntemin sınıf adı

yontemadi

Yeniden isimlendirilecek yöntemin adı

yeniisim

Yöntemin yeni ismi

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 classkit_method_rename() örneği

<?php
class Example {
    function foo() {
        return "foo!\n";
    }
}

// 'foo' yöntemini 'bar' olarak isimlendir
classkit_method_rename(
    'Example',
    'foo',
    'bar'
);

// yöntem çıktısı
echo Example::bar();
?>

Yukarıdaki örneğin çıktısı:

foo!

Ayrıca Bakınız

  • classkit_method_add() - Verilen sınıfa devingen olarak yeni bir yöntem ekler
  • classkit_method_copy() - Yöntemi bir sınıftan diğerine kopyalar
  • classkit_method_redefine() - Verilen yöntemin kodunu devingen olarak değiştirir
  • classkit_method_remove() - Verilen yöntemi devingen olarak kaldırır

classkit_method_remove
Ctype
Classkit İşlevleri


Karakter Türü Sınaması

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Karakter Türü Sınama İşlevleri
    • ctype_alnum — Sınama, abecesayısal karakterler için yapılır
    • ctype_alpha — Sınama, abecesel karakterler için yapılır
    • ctype_cntrl — Sınama, denetim karakterleri için yapılır
    • ctype_digit — Sınama, rakamlar için yapılır
    • ctype_graph — Sınama, boşluk karakterleri hariç basılabilir karakterler için yapılır
    • ctype_lower — Sınama, küçük harfler için yapılır
    • ctype_print — Sınama, basılabilir karakterler için yapılır
    • ctype_punct — Sınama, birer alfasayısal veya boşluk karakteri olmayan basılabilir karakterler için yapılır
    • ctype_space — Sınama, boşluk karakterleri için yapılır
    • ctype_upper — Sınama, büyük harfler için yapılır
    • ctype_xdigit — Sınama, onaltılık rakamlar için yapılır
classkit_method_rename
Giriş
Değişkenler ve Veri Türleriyle İlgili Eklentiler


Giriş

Bu eklenti ile sağlanan işlevler, bir karakter veya dizgenin geçerli yerele göre (setlocale() işlevine de bakınız) belli bir karakter sınıfına ait olup olmadığını saptamaya yarar.

Bu işlevler, bir tamsayı değiştirge ile çağrıldığında ctype.h dosyasındaki eşdeğerleri gibi davranır. Yani, işleve 256'dan küçük bir tamsayı aktarırsanız, belirtilen aralık içinde kalıp kalmadığına (0x30-0x39 aralığındaki rakamlar) bakmak için sayı bir ASCII değer olarak kullanılır. Eğer sayı -128 (dahil) ile -1 (dahil) arasındaysa sayıya önce 256 eklenir sonra sınama yapılır.

İşlevler bir dizge değiştirge ile çağrıldığında, dizgedeki her karakter sınanır ve sadece tüm karakterlerin istenen koşulları sağlaması durumunda TRUE döndürülür. İşlevler boş bir dizge ile çağrıldıklarında PHP < 5.1 için daima TRUE, 5.1'den itibaren ise daima FALSE döndürür.

Bir dizge veya sayı haricinde bir değer aktarımı işlevin anında FALSE döndürmesi ile sonuçlanır.

Bu işlevler sıradan düzenli ifade işlevlerine ve hatta str_* ve is_* işlevlerine daima tercih edilmelidir. Ctype eklentisi C kütüphanesini kullandığından bunlardan belirgin şekilde daha hızlıdır.

Ctype
Yapılandırma/Kurulum
Ctype


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Ctype


Gereksinimler

Standart C kütüphanesindeki işlevlerden başka bir şeye ihtiyaç yoktur.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

4.2.0'dan itibaren bu işlevler öntanımlı olarak etkindir. Daha eski sürümler için PHP'yi --enable-ctype seçeneği ile yapılandırarak derlemelisiniz. Ctype desteğini iptal etmek için --disable-ctype seçeneğini kullanın.

PHP'nin Windows sürümünde bu eklenti yerleşik olarak gelmektedir. Bu işlevleri Windows'ta kullanmak için herhangi bir eklenti kurmanıza gerek yoktur.

Bilginize: PHP 4.3.0'dan beri ctype için yerleşik destek vardır.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
Karakter Türü Sınama İşlevleri
Ctype


Karakter Türü Sınama İşlevleri

İçindekiler

  • ctype_alnum — Sınama, abecesayısal karakterler için yapılır
  • ctype_alpha — Sınama, abecesel karakterler için yapılır
  • ctype_cntrl — Sınama, denetim karakterleri için yapılır
  • ctype_digit — Sınama, rakamlar için yapılır
  • ctype_graph — Sınama, boşluk karakterleri hariç basılabilir karakterler için yapılır
  • ctype_lower — Sınama, küçük harfler için yapılır
  • ctype_print — Sınama, basılabilir karakterler için yapılır
  • ctype_punct — Sınama, birer alfasayısal veya boşluk karakteri olmayan basılabilir karakterler için yapılır
  • ctype_space — Sınama, boşluk karakterleri için yapılır
  • ctype_upper — Sınama, büyük harfler için yapılır
  • ctype_xdigit — Sınama, onaltılık rakamlar için yapılır
Öntanımlı Sabitler
ctype_alnum
Ctype


Sınama, abecesayısal karakterler için yapılır

Karakter Türü Sınama İşlevleri
ctype_alpha
Karakter Türü Sınama İşlevleri
PHP Manual

ctype_alnum

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

ctype_alnum — Sınama, abecesayısal karakterler için yapılır

Açıklama

bool ctype_alnum ( string $metin )

Belirtilen metin içindeki karakterlerin hepsi geçerli yerele göre birer harf veya rakam ise TRUE döner. Standart C yerelinde harflerin tamamı [A-Za-z] aralığında yer alır.

Değiştirgeler

metin

Sınanacak dizge.

Dönen Değerler

Belirtilen metin içindeki karakterlerin hepsi geçerli yerele göre birer harf veya rakam ise TRUE, değilse FALSE döner.

Örnekler

Örnek 1 - ctype_alnum() örneği (öntanımlı yerel kullanılarak)

<?php
$dizgeler = array('AbCd1zyZ9', 'foo!#$bar');
foreach ($dizgeler as $dizge) {
    if (ctype_alnum($dizge)) {
        echo "$dizge tamamen harflerden ve/veya rakamlardan oluşuyor.\n";
    } else {
        echo "$dizge tamamen harflerden ve/veya rakamlardan oluşmuyor.\n";
    }
}
?>

Yukarıdaki örneğin çıktısı:

AbCd1zyZ9 tamamen harflerden ve/veya rakamlardan oluşuyor.
foo!#$bar tamamen harflerden ve/veya rakamlardan oluşmuyor.

Ayrıca Bakınız

  • ctype_alpha() - Sınama, abecesel karakterler için yapılır
  • ctype_digit() - Sınama, rakamlar için yapılır
  • setlocale() - Yereli ayarlar

Karakter Türü Sınama İşlevleri
ctype_alpha
Karakter Türü Sınama İşlevleri


Sınama, abecesel karakterler için yapılır

ctype_alnum
ctype_cntrl
Karakter Türü Sınama İşlevleri
PHP Manual

ctype_alpha

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

ctype_alpha — Sınama, abecesel karakterler için yapılır

Açıklama

bool ctype_alpha ( string $metin )

Belirtilen metin içindeki karakterlerin hepsi geçerli yerele göre birer harf ise TRUE döner. Standart C yerelinde harfler [A-Za-z] aralığında olup ctype_alpha() işlevi, $metin tek bir karakterden ibaretse (ctype_upper($metin) || ctype_lower($metin)) ifadesine denktir. Ancak bazı dillerde harfler ne büyük ne de küçük harf olarak nitelenebilmektedir.

Değiştirgeler

metin

Sınanacak dizge.

Dönen Değerler

Belirtilen metin içindeki karakterlerin hepsi geçerli yerele göre birer harf ise TRUE, değilse FALSE döner.

Örnekler

Örnek 1 - ctype_alpha() örneği (öntanımlı yerel kullanılarak)

<?php
$dizgeler = array('KjgWZC', 'arf12');
foreach ($dizgeler as $dizge) {
    if (ctype_alpha($dizge)) {
        echo "$dizge tamamen harflerden oluşuyor.\n";
    } else {
        echo "$dizge tamamen harflerden oluşmuyor.\n";
    }
}
?>

Yukarıdaki örneğin çıktısı:

KjgWZC tamamen harflerden oluşuyor.
arf12 tamamen harflerden oluşmuyor.

Ayrıca Bakınız

  • ctype_upper() - Sınama, büyük harfler için yapılır
  • ctype_lower() - Sınama, küçük harfler için yapılır
  • setlocale() - Yereli ayarlar

ctype_alnum
ctype_cntrl
Karakter Türü Sınama İşlevleri


Sınama, denetim karakterleri için yapılır

ctype_alpha
ctype_digit
Karakter Türü Sınama İşlevleri
PHP Manual

ctype_cntrl

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

ctype_cntrl — Sınama, denetim karakterleri için yapılır

Açıklama

bool ctype_cntrl ( string $metin )

Belirtilen metin içindeki karakterlerin hepsi birer denetim karakteri (ASCII kodu 32'den küçük karakterler) ise TRUE döner.

Değiştirgeler

metin

Sınanacak dizge.

Dönen Değerler

Belirtilen metin içindeki karakterlerin hepsi birer denetim karakteri ise TRUE değilse FALSE döner.

Örnekler

Örnek 1 - ctype_cntrl() örneği

<?php
$dizgeler = array('dizge1' => "\n\r\t",
                  'dizge2' => 'arf12');
foreach ($dizgeler as $isim => $dizge) {
    if (ctype_cntrl($dizge)) {
        echo "'$isim' tamamen denetim karakterlerinden oluşuyor.\n";
    } else {
        echo "'$isim' tamamen denetim karakterlerinden oluşmuyor.\n";
    }
}
?>

Yukarıdaki örneğin çıktısı:

'dizge1' tamamen denetim karakterlerinden oluşuyor.
'dizge2' tamamen denetim karakterlerinden oluşmuyor.

Ayrıca Bakınız

  • ctype_print() - Sınama, basılabilir karakterler için yapılır

ctype_alpha
ctype_digit
Karakter Türü Sınama İşlevleri


Sınama, rakamlar için yapılır

ctype_cntrl
ctype_graph
Karakter Türü Sınama İşlevleri
PHP Manual

ctype_digit

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

ctype_digit — Sınama, rakamlar için yapılır

Açıklama

bool ctype_digit ( string $metin )

Belirtilen metin içindeki karakterlerin hepsi rakamlardan oluşuyorsa TRUE döner.

Değiştirgeler

metin

Sınanacak dizge.

Dönen Değerler

Belirtilen metin içindeki karakterlerin hepsi birer rakam ise TRUE, değilse FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.0 | PHP 5.1.0 öncesinde, metin boş bir dizge bile olsa bu işlev TRUE döndürürdü.

Örnekler

Örnek 1 - ctype_digit() örneği

<?php
$dizgeler = array('1820.20', '10002', 'wsl!12');
foreach ($dizgeler as $dizge) {
    if (ctype_digit($dizge)) {
        echo "$dizge tamamen rakamlardan oluşuyor.\n";
    } else {
        echo "$dizge tamamen rakamlardan oluşmuyor.\n";
    }
}
?>

Yukarıdaki örneğin çıktısı:

1820.20 tamamen rakamlardan oluşmuyor.
10002 tamamen rakamlardan oluşuyor.
wsl!12 tamamen rakamlardan oluşmuyor.

Örnek 2 - ctype_digit() (dizgelerle tamsayıları karşılaştırma) örneği

<?php

$numeric_string = '42';
$integer        = 42;

ctype_digit($numeric_string);  // true
ctype_digit($integer);         // false

is_numeric($numeric_string);   // true
is_numeric($integer);          // true
?>

Notlar

Bilginize:

Bu işlevin işe yaraması için değiştirgesi bir dizge olmalıdır. Bir tamsayı verilirse daima FALSE döndürür. Bununla birlikte HTML formlarının sayısal dizge döndürdüklerini, tamsayı döndürmediklerini hatırlamakta fayda var. Ayrıca, veri türleri bölümüne de bakınız.

Ayrıca Bakınız

  • ctype_alnum() - Sınama, abecesayısal karakterler için yapılır
  • ctype_xdigit() - Sınama, onaltılık rakamlar için yapılır
  • is_numeric() - Değişken bir sayı veya bir sayısal dizge mi diye bakar
  • is_int() - Değişken bir tamsayı mı diye bakar
  • is_string() - Değişken string türünde mi diye bakar

ctype_cntrl
ctype_graph
Karakter Türü Sınama İşlevleri


Sınama, boşluk karakterleri hariç basılabilir karakterler için yapılır

ctype_digit
ctype_lower
Karakter Türü Sınama İşlevleri
PHP Manual

ctype_graph

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

ctype_graph — Sınama, boşluk karakterleri hariç basılabilir karakterler için yapılır

Açıklama

bool ctype_graph ( string $metin )

Belirtilen metin içindeki karakterlerin hepsi görsel çıktı oluşturuyorsa TRUE döner.

Değiştirgeler

metin

Sınanacak dizge.

Dönen Değerler

Belirtilen metin içindeki karakterlerin hepsi basılabilirse ve birer görsel çıktı oluşturuyorlarsa (boşluk karakterleri değilseler) TRUE, aksi takdirde FALSE döner.

Örnekler

Örnek 1 - ctype_graph() örneği

<?php
$dizgeler = array('dizge1' => "asdf\n\r\t",
                  'dizge2' => 'arf12',
                  'dizge3' => 'LKA#@%.54');
foreach ($dizgeler as $isim => $dizge) {
    if (ctype_graph($dizge)) {
      echo "'$isim' tamamen (görsel) basılabilir karakterlerden oluşuyor.\n";
    } else {
      echo "'$isim' tamamen (görsel) basılabilir karakterlerden oluşmuyor.\n";
    }
}
?>

Yukarıdaki örneğin çıktısı:

'dizge1' tamamen (görsel) basılabilir karakterlerden oluşmuyor.
'dizge2' tamamen (görsel) basılabilir karakterlerden oluşuyor.
'dizge3' tamamen (görsel) basılabilir karakterlerden oluşuyor.

Ayrıca Bakınız

  • ctype_alnum() - Sınama, abecesayısal karakterler için yapılır
  • ctype_print() - Sınama, basılabilir karakterler için yapılır
  • ctype_punct() - Sınama, birer alfasayısal veya boşluk karakteri olmayan basılabilir karakterler için yapılır

ctype_digit
ctype_lower
Karakter Türü Sınama İşlevleri


Sınama, küçük harfler için yapılır

ctype_graph
ctype_print
Karakter Türü Sınama İşlevleri
PHP Manual

ctype_lower

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

ctype_lower — Sınama, küçük harfler için yapılır

Açıklama

bool ctype_lower ( string $metin )

Belirtilen metin içindeki karakterlerin hepsi birer küçük harf ise TRUE döner.

Değiştirgeler

metin

Sınanacak metin.

Dönen Değerler

Belirtilen metin içindeki karakterlerin hepsi geçerli yerele göre birer küçük harf ise TRUE döner.

Örnekler

Örnek 1 - ctype_lower() örneği (öntanımlı yerel kullanılarak)

<?php
$dizgeler = array('aac123', 'qiutoas', 'QASsdks');
foreach ($dizgeler as $dizge) {
    if (ctype_lower($dizge)) {
        echo "$dizge tamamen küçük harflerden oluşuyor.\n";
    } else {
        echo "$dizge tamamen küçük harflerden oluşmuyor";
    }
}
?>

Yukarıdaki örneğin çıktısı:

aac123 tamamen küçük harflerden oluşmuyor.
qiutoas tamamen küçük harflerden oluşuyor.
QASsdks tamamen küçük harflerden oluşmuyor.

Ayrıca Bakınız

  • ctype_alpha() - Sınama, abecesel karakterler için yapılır
  • ctype_upper() - Sınama, büyük harfler için yapılır
  • setlocale() - Yereli ayarlar

ctype_graph
ctype_print
Karakter Türü Sınama İşlevleri


Sınama, basılabilir karakterler için yapılır

ctype_lower
ctype_punct
Karakter Türü Sınama İşlevleri
PHP Manual

ctype_print

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

ctype_print — Sınama, basılabilir karakterler için yapılır

Açıklama

bool ctype_print ( string $metin )

Belirtilen metin içindeki karakterlerin hepsi basılabilir karakterlerden oluşuyorsa TRUE döner.

Değiştirgeler

metin

Sınanacak metin.

Dönen Değerler

Belirtilen metin içindeki karakterlerin hepsi basılabilir karakterlerden (boşluklar dahil) oluşuyorsa TRUE döner. Denetim karakterleri, hiçbir çıktı üretmeyen veya bir işlevi denetleyen karakterleri içeriyorsa FALSE döner.

Örnekler

Örnek 1 - ctype_print() örneği

<?php
$dizgeler = array('dizge1' => "asdf\n\r\t",
                  'dizge2' => 'arf12',
                  'dizge3' => 'LKA#@%.54');
foreach ($dizgeler as $isim => $dizge) {
    if (ctype_print($testcase)) {
        echo "'$isim' tamamen basılabilir karakterlerden oluşuyor.\n";
    } else {
        echo "'$isim' tamamen basılabilir karakterlerden oluşmuyor.\n";
    }
}
?>

Yukarıdaki örneğin çıktısı:

'dizge1' tamamen basılabilir karakterlerden oluşmuyor.
'dizge2' tamamen basılabilir karakterlerden oluşuyor.
'dizge3' tamamen basılabilir karakterlerden oluşuyor.

Ayrıca Bakınız

  • ctype_cntrl() - Sınama, denetim karakterleri için yapılır
  • ctype_graph() - Sınama, boşluk karakterleri hariç basılabilir karakterler için yapılır
  • ctype_punct() - Sınama, birer alfasayısal veya boşluk karakteri olmayan basılabilir karakterler için yapılır

ctype_lower
ctype_punct
Karakter Türü Sınama İşlevleri


Sınama, birer alfasayısal veya boşluk karakteri olmayan basılabilir karakterler için yapılır

ctype_print
ctype_space
Karakter Türü Sınama İşlevleri
PHP Manual

ctype_punct

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

ctype_punct — Sınama, birer alfasayısal veya boşluk karakteri olmayan basılabilir karakterler için yapılır

Açıklama

bool ctype_punct ( string $metin )

Belirtilen metin içindeki karakterlerin hepsi birer noktalama karakteri ise TRUE döner.

Değiştirgeler

metin

Sınanacak dizge.

Dönen Değerler

Belirtilen metin içindeki karakterlerin hepsi birer noktalama karakteri (harf, rakam ve boşluklar dışında kalan basılabilir karakterler) ise TRUE, aksi takdirde FALSE döner.

Örnekler

Örnek 1 - ctype_punct() örneği

<?php
$dizgeler = array('ABasdk!@!$#', '!@ # $', '*&$()');
foreach ($dizgeler as $dizge) {
    if (ctype_punct($tdizge)) {
        echo "$dizge tamamen noktalama işaretlerinden oluşuyor.\n";
    } else {
        echo "$dizge tamamen noktalama imlerinden oluşmuyor.\n";
    }
}
?>

Yukarıdaki örneğin çıktısı:

ABasdk!@!$# tamamen noktalama imlerinden oluşmuyor.
!@ # $ tamamen noktalama imlerinden oluşmuyor.
*&$() tamamen noktalama işaretlerinden oluşuyor.

Ayrıca Bakınız

  • ctype_cntrl() - Sınama, denetim karakterleri için yapılır
  • ctype_graph() - Sınama, boşluk karakterleri hariç basılabilir karakterler için yapılır

ctype_print
ctype_space
Karakter Türü Sınama İşlevleri


Sınama, boşluk karakterleri için yapılır

ctype_punct
ctype_upper
Karakter Türü Sınama İşlevleri
PHP Manual

ctype_space

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

ctype_space — Sınama, boşluk karakterleri için yapılır

Açıklama

bool ctype_space ( string $metin )

Belirtilen metin içindeki karakterlerin hepsi boşluk karakterlerinden oluşuyorsa TRUE döner.

Değiştirgeler

metin

Sınanacak metin.

Dönen Değerler

Belirtilen metin içindeki karakterlerin hepsi boşluk karakterlerinden (normal boşluk, yatay ve düşey sekme, satırsonu, satırbaşı ve sayfa ileri karakterleri) oluşuyorsa TRUE döner.

Örnekler

Örnek 1 - ctype_space() örneği

<?php
$dizgeler = array('dizge1' => "\n\r\t",
                  'dizge2' => "\narf12",
                  'dizge3' => '\n\r\t');
foreach ($dizgeler as $isim => $dizge) {
    if (ctype_space($dizge)) {
        echo "'$isim' tamamen boşluk karakterlerinden oluşuyor.\n";
    } else {
        echo "'$isim' tamamen boşluk karakterlerinden oluşmuyor.\n";
    }
}
?>

Yukarıdaki örneğin çıktısı:

'dizge1' tamamen boşluk karakterlerinden oluşuyor.
'dizge2' tamamen boşluk karakterlerinden oluşmuyor.
'dizge3' tamamen boşluk karakterlerinden oluşmuyor.

Ayrıca Bakınız

  • ctype_cntrl() - Sınama, denetim karakterleri için yapılır
  • ctype_graph() - Sınama, boşluk karakterleri hariç basılabilir karakterler için yapılır
  • ctype_punct() - Sınama, birer alfasayısal veya boşluk karakteri olmayan basılabilir karakterler için yapılır

ctype_punct
ctype_upper
Karakter Türü Sınama İşlevleri


Sınama, büyük harfler için yapılır

ctype_space
ctype_xdigit
Karakter Türü Sınama İşlevleri
PHP Manual

ctype_upper

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

ctype_upper — Sınama, büyük harfler için yapılır

Açıklama

bool ctype_upper ( string $metin )

Belirtilen metin içindeki karakterlerin hepsi geçerli yerele göre birer büyük harf ise TRUE döner.

Değiştirgeler

metin

Sınanacak dizge.

Dönen Değerler

Belirtilen metin içindeki karakterlerin hepsi geçerli yerele göre birer büyük harf ise TRUE döner.

Örnekler

Örnek 1 - ctype_upper() örneği (öntanımlı yereli kullanarak)

<?php
$dizgeler = array('AKLMC139', 'LMNSDO', 'akwSKBsm');
foreach ($dizgeler as $dizge) {
    if (ctype_upper($dizge)) {
        echo "$dizge tamamen büyük harflerden oluşuyor.\n";
    } else {
        echo "$dizge tamamen büyük harflerden oluşmuyor.\n";
    }
}
?>

Yukarıdaki örneğin çıktısı:

AKLMC139 tamamen büyük harflerden oluşmuyor.
LMNSDO tamamen büyük harflerden oluşuyor.
akwSKBsm tamamen büyük harflerden oluşmuyor.

Ayrıca Bakınız

  • ctype_alpha() - Sınama, abecesel karakterler için yapılır
  • ctype_lower() - Sınama, küçük harfler için yapılır
  • setlocale() - Yereli ayarlar

ctype_space
ctype_xdigit
Karakter Türü Sınama İşlevleri


Sınama, onaltılık rakamlar için yapılır

ctype_upper
Data Structures
Karakter Türü Sınama İşlevleri
PHP Manual

ctype_xdigit

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

ctype_xdigit — Sınama, onaltılık rakamlar için yapılır

Açıklama

bool ctype_xdigit ( string $metin )

Belirtilen metin içindeki karakterlerin hepsi birer onaltılık rakam ise TRUE döner.

Değiştirgeler

metin

Sınanacak dizge.

Dönen Değerler

Belirtilen metin içindeki karakterlerin hepsi birer onaltılık rakam ise, yani rakamlar ve [A-Fa-f] aralığındaki karakterlerden biri iseler TRUE, aksi takdirde FALSE döner.

Örnekler

Örnek 1 - ctype_xdigit() örneği

<?php
$dizgeler = array('AB10BC99', 'AR1012', 'ab12bc99');
foreach ($dizgeler as $dizge) {
    if (ctype_xdigit($dizge)) {
        echo "$dizge tamamen onaltılık rakamlardan oluşuyor.\n";
    } else {
        echo "$dizge tamamen onaltılık rakamlardan oluşmuyor.\n";
    }
}
?>

Yukarıdaki örneğin çıktısı:

AB10BC99 tamamen onaltılık rakamlardan oluşuyor.
AR1012 tamamen onaltılık rakamlardan oluşmuyor.
ab12bc99 tamamen onaltılık rakamlardan oluşuyor.

Ayrıca Bakınız

  • ctype_digit() - Sınama, rakamlar için yapılır

ctype_upper
Data Structures
Karakter Türü Sınama İşlevleri


Data Structures

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
  • Öntanımlı Sabitler
  • Örnekler
  • Collection — The Collection interface
    • Ds\Collection::clear — Removes all values.
    • Ds\Collection::copy — Returns a shallow copy of the collection.
    • Ds\Collection::isEmpty — Returns whether the collection is empty
    • Ds\Collection::toArray — Converts the collection to an array.
  • Hashable — The Hashable interface
    • Ds\Hashable::equals — Determines whether an object is equal to the current instance.
    • Ds\Hashable::hash — Returns a scalar value to be used as a hash value.
  • Sequence — The Sequence interface
    • Ds\Sequence::allocate — Allocates enough memory for a required capacity.
    • Ds\Sequence::apply — Updates all values by applying a callback function to each value.
    • Ds\Sequence::capacity — Returns the current capacity.
    • Ds\Sequence::contains — Determines if the sequence contains given values.
    • Ds\Sequence::filter — Creates a new sequence using a callable to determine which values to include.
    • Ds\Sequence::find — Attempts to find a value's index.
    • Ds\Sequence::first — Returns the first value in the sequence.
    • Ds\Sequence::get — Returns the value at a given index.
    • Ds\Sequence::insert — Inserts values at a given index.
    • Ds\Sequence::join — Joins all values together as a string.
    • Ds\Sequence::last — Returns the last value.
    • Ds\Sequence::map — Returns the result of applying a callback to each value.
    • Ds\Sequence::merge — Returns the result of adding all given values to the sequence.
    • Ds\Sequence::pop — Removes and returns the last value.
    • Ds\Sequence::push — Adds values to the end of the sequence.
    • Ds\Sequence::reduce — Reduces the sequence to a single value using a callback function.
    • Ds\Sequence::remove — Removes and returns a value by index.
    • Ds\Sequence::reverse — Reverses the sequence in-place.
    • Ds\Sequence::reversed — Returns a reversed copy.
    • Ds\Sequence::rotate — Rotates the sequence by a given number of rotations.
    • Ds\Sequence::set — Updates a value at a given index.
    • Ds\Sequence::shift — Removes and returns the first value.
    • Ds\Sequence::slice — Returns a sub-sequence of a given range.
    • Ds\Sequence::sort — Sorts the sequence in-place.
    • Ds\Sequence::sorted — Returns a sorted copy.
    • Ds\Sequence::sum — Returns the sum of all values in the sequence.
    • Ds\Sequence::unshift — Adds values to the front of the sequence.
  • Vector — The Vector class
    • Ds\Vector::allocate — Allocates enough memory for a required capacity.
    • Ds\Vector::apply — Updates all values by applying a callback function to each value.
    • Ds\Vector::capacity — Returns the current capacity.
    • Ds\Vector::clear — Removes all values.
    • Ds\Vector::__construct — Creates a new instance.
    • Ds\Vector::contains — Determines if the vector contains given values.
    • Ds\Vector::copy — Returns a shallow copy of the vector.
    • Ds\Vector::count — Returns the number of values in the collection.
    • Ds\Vector::filter — Creates a new vector using a callable to determine which values to include.
    • Ds\Vector::find — Attempts to find a value's index.
    • Ds\Vector::first — Returns the first value in the vector.
    • Ds\Vector::get — Returns the value at a given index.
    • Ds\Vector::insert — Inserts values at a given index.
    • Ds\Vector::isEmpty — Returns whether the vector is empty
    • Ds\Vector::join — Joins all values together as a string.
    • Ds\Vector::jsonSerialize — Returns a representation that can be converted to JSON.
    • Ds\Vector::last — Returns the last value.
    • Ds\Vector::map — Returns the result of applying a callback to each value.
    • Ds\Vector::merge — Returns the result of adding all given values to the vector.
    • Ds\Vector::pop — Removes and returns the last value.
    • Ds\Vector::push — Adds values to the end of the vector.
    • Ds\Vector::reduce — Reduces the vector to a single value using a callback function.
    • Ds\Vector::remove — Removes and returns a value by index.
    • Ds\Vector::reverse — Reverses the vector in-place.
    • Ds\Vector::reversed — Returns a reversed copy.
    • Ds\Vector::rotate — Rotates the vector by a given number of rotations.
    • Ds\Vector::set — Updates a value at a given index.
    • Ds\Vector::shift — Removes and returns the first value.
    • Ds\Vector::slice — Returns a sub-vector of a given range.
    • Ds\Vector::sort — Sorts the vector in-place.
    • Ds\Vector::sorted — Returns a sorted copy.
    • Ds\Vector::sum — Returns the sum of all values in the vector.
    • Ds\Vector::toArray — Converts the vector to an array.
    • Ds\Vector::unshift — Adds values to the front of the vector.
  • Deque — The Deque class
    • Ds\Deque::allocate — Allocates enough memory for a required capacity.
    • Ds\Deque::apply — Updates all values by applying a callback function to each value.
    • Ds\Deque::capacity — Returns the current capacity.
    • Ds\Deque::clear — Removes all values from the deque.
    • Ds\Deque::__construct — Creates a new instance.
    • Ds\Deque::contains — Determines if the deque contains given values.
    • Ds\Deque::copy — Returns a shallow copy of the deque.
    • Ds\Deque::count — Returns the number of values in the collection.
    • Ds\Deque::filter — Creates a new deque using a callable to determine which values to include.
    • Ds\Deque::find — Attempts to find a value's index.
    • Ds\Deque::first — Returns the first value in the deque.
    • Ds\Deque::get — Returns the value at a given index.
    • Ds\Deque::insert — Inserts values at a given index.
    • Ds\Deque::isEmpty — Returns whether the deque is empty
    • Ds\Deque::join — Joins all values together as a string.
    • Ds\Deque::jsonSerialize — Returns a representation that can be converted to JSON.
    • Ds\Deque::last — Returns the last value.
    • Ds\Deque::map — Returns the result of applying a callback to each value.
    • Ds\Deque::merge — Returns the result of adding all given values to the deque.
    • Ds\Deque::pop — Removes and returns the last value.
    • Ds\Deque::push — Adds values to the end of the deque.
    • Ds\Deque::reduce — Reduces the deque to a single value using a callback function.
    • Ds\Deque::remove — Removes and returns a value by index.
    • Ds\Deque::reverse — Reverses the deque in-place.
    • Ds\Deque::reversed — Returns a reversed copy.
    • Ds\Deque::rotate — Rotates the deque by a given number of rotations.
    • Ds\Deque::set — Updates a value at a given index.
    • Ds\Deque::shift — Removes and returns the first value.
    • Ds\Deque::slice — Returns a sub-deque of a given range.
    • Ds\Deque::sort — Sorts the deque in-place.
    • Ds\Deque::sorted — Returns a sorted copy.
    • Ds\Deque::sum — Returns the sum of all values in the deque.
    • Ds\Deque::toArray — Converts the deque to an array.
    • Ds\Deque::unshift — Adds values to the front of the deque.
  • Map — The Map class
    • Ds\Map::allocate — Allocates enough memory for a required capacity.
    • Ds\Map::apply — Updates all values by applying a callback function to each value.
    • Ds\Map::capacity — Returns the current capacity.
    • Ds\Map::clear — Removes all values.
    • Ds\Map::__construct — Creates a new instance.
    • Ds\Map::copy — Returns a shallow copy of the map.
    • Ds\Map::count — Returns the number of values in the map.
    • Ds\Map::diff — Creates a new map using keys that aren't in another map.
    • Ds\Map::filter — Creates a new map using a callable to determine which pairs to include.
    • Ds\Map::first — Returns the first pair in the map.
    • Ds\Map::get — Returns the value for a given key.
    • Ds\Map::hasKey — Determines whether the map contains a given key.
    • Ds\Map::hasValue — Determines whether the map contains a given value.
    • Ds\Map::intersect — Creates a new map by intersecting keys with another map.
    • Ds\Map::isEmpty — Returns whether the map is empty
    • Ds\Map::jsonSerialize — Returns a representation that can be converted to JSON.
    • Ds\Map::keys — Returns a set of the map's keys.
    • Ds\Map::ksort — Sorts the map in-place by key.
    • Ds\Map::ksorted — Returns a copy, sorted by key.
    • Ds\Map::last — Returns the last pair of the map.
    • Ds\Map::map — Returns the result of applying a callback to each value.
    • Ds\Map::merge — Returns the result of adding all given associations.
    • Ds\Map::pairs — Returns a sequence containing all the pairs of the map.
    • Ds\Map::put — Associates a key with a value.
    • Ds\Map::putAll — Associates all key-value pairs of a traversable object or array.
    • Ds\Map::reduce — Reduces the map to a single value using a callback function.
    • Ds\Map::remove — Removes and returns a value by key.
    • Ds\Map::reverse — Reverses the map in-place.
    • Ds\Map::reversed — Returns a reversed copy.
    • Ds\Map::skip — Returns the pair at a given positional index.
    • Ds\Map::slice — Returns a subset of the map defined by a starting index and length.
    • Ds\Map::sort — Sorts the map in-place by value.
    • Ds\Map::sorted — Returns a copy, sorted by value.
    • Ds\Map::sum — Returns the sum of all values in the map.
    • Ds\Map::toArray — Converts the map to an array.
    • Ds\Map::union — Creates a new map using values from the current instance and another map.
    • Ds\Map::values — Returns a sequence of the map's values.
    • Ds\Map::xor — Creates a new map using keys of either the current instance or of another map, but not of both.
  • Pair — The Pair class
    • Ds\Pair::clear — Removes all values.
    • Ds\Pair::__construct — Creates a new instance.
    • Ds\Pair::copy — Returns a shallow copy of the pair.
    • Ds\Pair::isEmpty — Returns whether the pair is empty
    • Ds\Pair::jsonSerialize — Returns a representation that can be converted to JSON.
    • Ds\Pair::toArray — Converts the pair to an array.
  • Set — The Set class
    • Ds\Set::add — Adds values to the set.
    • Ds\Set::allocate — Allocates enough memory for a required capacity.
    • Ds\Set::capacity — Returns the current capacity.
    • Ds\Set::clear — Removes all values.
    • Ds\Set::__construct — Creates a new instance.
    • Ds\Set::contains — Determines if the set contains all values.
    • Ds\Set::copy — Returns a shallow copy of the set.
    • Ds\Set::count — Returns the number of values in the set.
    • Ds\Set::diff — Creates a new set using values that aren't in another set.
    • Ds\Set::filter — Creates a new set using a callable to determine which values to include.
    • Ds\Set::first — Returns the first value in the set.
    • Ds\Set::get — Returns the value at a given index.
    • Ds\Set::intersect — Creates a new set by intersecting values with another set.
    • Ds\Set::isEmpty — Returns whether the set is empty
    • Ds\Set::join — Joins all values together as a string.
    • Ds\Set::jsonSerialize — Returns a representation that can be converted to JSON.
    • Ds\Set::last — Returns the last value in the set.
    • Ds\Set::merge — Returns the result of adding all given values to the set.
    • Ds\Set::reduce — Reduces the set to a single value using a callback function.
    • Ds\Set::remove — Removes all given values from the set.
    • Ds\Set::reverse — Reverses the set in-place.
    • Ds\Set::reversed — Returns a reversed copy.
    • Ds\Set::slice — Returns a sub-set of a given range.
    • Ds\Set::sort — Sorts the set in-place.
    • Ds\Set::sorted — Returns a sorted copy.
    • Ds\Set::sum — Returns the sum of all values in the set.
    • Ds\Set::toArray — Converts the set to an array.
    • Ds\Set::union — Creates a new set using values from the current instance and another set.
    • Ds\Set::xor — Creates a new set using values in either the current instance or in another set, but not in both.
  • Stack — The Stack class
    • Ds\Stack::allocate — Allocates enough memory for a required capacity.
    • Ds\Stack::capacity — Returns the current capacity.
    • Ds\Stack::clear — Removes all values.
    • Ds\Stack::__construct — Creates a new instance.
    • Ds\Stack::copy — Returns a shallow copy of the stack.
    • Ds\Stack::count — Returns the number of values in the stack.
    • Ds\Stack::isEmpty — Returns whether the stack is empty
    • Ds\Stack::jsonSerialize — Returns a representation that can be converted to JSON.
    • Ds\Stack::peek — Returns the value at the top of the stack.
    • Ds\Stack::pop — Removes and returns the value at the top of the stack.
    • Ds\Stack::push — Pushes values onto the stack.
    • Ds\Stack::toArray — Converts the stack to an array.
  • Queue — The Queue class
    • Ds\Queue::allocate — Allocates enough memory for a required capacity.
    • Ds\Queue::capacity — Returns the current capacity.
    • Ds\Queue::clear — Removes all values.
    • Ds\Queue::__construct — Creates a new instance.
    • Ds\Queue::copy — Returns a shallow copy of the queue.
    • Ds\Queue::count — Returns the number of values in the queue.
    • Ds\Queue::isEmpty — Returns whether the queue is empty
    • Ds\Queue::jsonSerialize — Returns a representation that can be converted to JSON.
    • Ds\Queue::peek — Returns the value at the front of the queue.
    • Ds\Queue::pop — Removes and returns the value at the front of the queue.
    • Ds\Queue::push — Pushes values into the queue.
    • Ds\Queue::toArray — Converts the queue to an array.
  • PriorityQueue — The PriorityQueue class
    • Ds\PriorityQueue::allocate — Allocates enough memory for a required capacity.
    • Ds\PriorityQueue::capacity — Returns the current capacity.
    • Ds\PriorityQueue::clear — Removes all values.
    • Ds\PriorityQueue::__construct — Creates a new instance.
    • Ds\PriorityQueue::copy — Returns a shallow copy of the queue.
    • Ds\PriorityQueue::count — Returns the number of values in the queue.
    • Ds\PriorityQueue::isEmpty — Returns whether the queue is empty
    • Ds\PriorityQueue::jsonSerialize — Returns a representation that can be converted to JSON.
    • Ds\PriorityQueue::peek — Returns the value at the front of the queue.
    • Ds\PriorityQueue::pop — Removes and returns the value with the highest priority.
    • Ds\PriorityQueue::push — Pushes values into the queue.
    • Ds\PriorityQueue::toArray — Converts the queue to an array.
ctype_xdigit
Giriş
Değişkenler ve Veri Türleriyle İlgili Eklentiler


Giriş

Efficient data structures for PHP 7, provided as an alternative to the array.

See » this blog post for benchmarks, discussion and frequently asked questions.

Data Structures
Yapılandırma/Kurulum
Data Structures


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
Giriş
Gereksinimler
Data Structures


Gereksinimler

PHP 7 is required by both the extension and the compatibility polyfill.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

The easiest way to install the extension is via » PECL

pecl install ds

You can also build directly from source:

# Dependencies you might need to install
# sudo apt-get install git build-essential php7.0-dev

git clone https://github.com/php-ds/extension "php-ds"
cd php-ds

# Build and install the extension
phpize
./configure
make
make install

# Clean up the build files
make clean
phpize --clean

If you're on Windows, you can » download a compiled .dll on PECL

Bilginize:

If you're using Composer, it's highly recommended that you include » php-ds/php-ds in your project so that your code is still functional in an environment where the extension is not installed. The extension will take priority if installed.

Gereksinimler
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Kurulum
Örnekler
Data Structures


Örnekler

Örnek 1 Vector

<?php

$vector = new \Ds\Vector();

$vector->push('a');
$vector->push('b', 'c');

$vector[] = 'd';

print_r($vector);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Vector Object
(
    [0] => a
    [1] => b
    [2] => c
    [3] => d
)

Örnek 2 Map

<?php

$map = new \Ds\Map();

$map->put('a', 1);
$map->put('b', 2);

$map['c'] = 3;

print_r($map);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => a
            [value] => 1
        )

    [1] => Ds\Pair Object
        (
            [key] => b
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => c
            [value] => 3
        )

)
Öntanımlı Sabitler
Collection
Data Structures


The Collection interface

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

Collection is the base interface which covers functionality common to all the data structures in this library. It guarantees that all structures are traversable, countable, and can be converted to json using json_encode().

Arayüz Sözdizimi

Ds\Collection implements Traversable , Countable , JsonSerializable {
/* Yöntemler */
abstract public void clear ( void )
abstract public Ds\Collection copy ( void )
abstract public bool isEmpty ( void )
abstract public array toArray ( void )
}

İçindekiler

  • Ds\Collection::clear — Removes all values.
  • Ds\Collection::copy — Returns a shallow copy of the collection.
  • Ds\Collection::isEmpty — Returns whether the collection is empty
  • Ds\Collection::toArray — Converts the collection to an array.
Örnekler
Ds\Collection::clear
Data Structures


Removes all values.

Collection
Ds\Collection::copy
Collection
PHP Manual

Ds\Collection::clear

(PECL ds >= 1.0.0)

Ds\Collection::clear — Removes all values.

Açıklama

abstract public void Ds\Collection::clear ( void )

Removes all values from the collection.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\Collection::clear() example

<?php
$collection = new \Ds\Vector([1, 2, 3]);
print_r($collection);

$collection->clear();
print_r($collection);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Vector Object
(
    [0] => 1
    [1] => 2
    [2] => 3
)
Ds\Vector Object
(
)
Collection
Ds\Collection::copy
Collection


Returns a shallow copy of the collection.

Ds\Collection::clear
Ds\Collection::isEmpty
Collection
PHP Manual

Ds\Collection::copy

(PECL ds >= 1.0.0)

Ds\Collection::copy — Returns a shallow copy of the collection.

Açıklama

abstract public Ds\Collection Ds\Collection::copy ( void )

Returns a shallow copy of the collection.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a shallow copy of the collection.

Örnekler

Örnek 1 Ds\Collection::copy() example

<?php
$a = new \Ds\Vector([1, 2, 3]);
$b = $a->copy();

$b->push(4);

print_r($a);
print_r($b);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Vector Object
(
    [0] => 1
    [1] => 2
    [2] => 3
)
Ds\Vector Object
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
)
Ds\Collection::clear
Ds\Collection::isEmpty
Collection


Returns whether the collection is empty

Ds\Collection::copy
Ds\Collection::toArray
Collection
PHP Manual

Ds\Collection::isEmpty

(PECL ds >= 1.0.0)

Ds\Collection::isEmpty — Returns whether the collection is empty

Açıklama

abstract public bool Ds\Collection::isEmpty ( void )

Returns whether the collection is empty.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the collection is empty, FALSE otherwise.

Örnekler

Örnek 1 Ds\Collection::isEmpty() example

<?php
$a = new \Ds\Vector([1, 2, 3]);
$b = new \Ds\Vector();

var_dump($a->isEmpty());
var_dump($b->isEmpty());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(false)
bool(true)
Ds\Collection::copy
Ds\Collection::toArray
Collection


Converts the collection to an array.

Ds\Collection::isEmpty
Hashable
Collection
PHP Manual

Ds\Collection::toArray

(PECL ds >= 1.0.0)

Ds\Collection::toArray — Converts the collection to an array.

Açıklama

abstract public array Ds\Collection::toArray ( void )

Converts the collection to an array.

Bilginize:

Casting to an array is not supported yet.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

An array containing all the values in the same order as the collection.

Örnekler

Örnek 1 Ds\Collection::toArray() example

<?php
$collection = new \Ds\Vector([1, 2, 3]);

var_dump($collection->toArray());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}
Ds\Collection::isEmpty
Hashable
Collection


The Hashable interface

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

Hashable is an interface which allows objects to be used as keys. It's an alternative to spl_object_hash(), which determines an object's hash based on its handle: this means that two objects that are considered equal by an implicit definition would not treated as equal because they are not the same instance.

hash() is used to return a scalar value to be used as the object's hash value, which determines where it goes in the hash table. While this value does not have to be unique, objects which are equal must have the same hash value.

equals() is used to determine if two objects are equal. It's guaranteed that the comparing object will be an instance of the same class as the subject.

Arayüz Sözdizimi

Ds\Hashable {
/* Yöntemler */
abstract public bool equals ( object $obj )
abstract public mixed hash ( void )
}

İçindekiler

  • Ds\Hashable::equals — Determines whether an object is equal to the current instance.
  • Ds\Hashable::hash — Returns a scalar value to be used as a hash value.
Ds\Collection::toArray
Ds\Hashable::equals
Data Structures


Determines whether an object is equal to the current instance.

Hashable
Ds\Hashable::hash
Hashable
PHP Manual

Ds\Hashable::equals

(PECL ds >= 1.0.0)

Ds\Hashable::equals — Determines whether an object is equal to the current instance.

Açıklama

abstract public bool Ds\Hashable::equals ( object $obj )

Determines whether another object is equal to the current instance.

This method allows objects to be used as keys in structures such as Ds\Map and Ds\Set, or any other lookup structure that honors this interface.

Bilginize:

It's guaranteed that obj is an instance of the same class.

Dikkat

It's important that objects which are equal also have the same hash value. See Ds\Hashable::hash().

Değiştirgeler

obj

The object to compare the current instance to, which is always an instance of the same class.

Dönen Değerler

TRUE if equal, FALSE otherwise.

Hashable
Ds\Hashable::hash
Hashable


Returns a scalar value to be used as a hash value.

Ds\Hashable::equals
Sequence
Hashable
PHP Manual

Ds\Hashable::hash

(PECL ds >= 1.0.0)

Ds\Hashable::hash — Returns a scalar value to be used as a hash value.

Açıklama

abstract public mixed Ds\Hashable::hash ( void )

Returns a scalar value to be used as the hash value of the objects.

While the hash value does not define equality, all objects that are equal according to Ds\Hashable::equals() must have the same hash value. Hash values of equal objects don't have to be unique, for example you could just return TRUE for all objects and nothing would break - the only implication would be that hash tables then turn into linked lists because all your objects will be hashed to the same bucket. It's therefore very important that you pick a good hash value, such as an ID or email address.

This method allows objects to be used as keys in structures such as Ds\Map and Ds\Set, or any other lookup structure that honors this interface.

Dikkat

Do not pick a value that might change within the object, such as a public property. Hash table lookups would fail because the hash has changed.

Dikkat

All objects that are equal must have the same hash value.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A scalar value to be used as this object's hash value.

Örnekler

Örnek 1 Ds\Hashable::hash() example

<?php
class HashableObject implements \Ds\Hashable
{
    private $name;
    private $email;

    public function __construct($name, $email)
    {
        $this->name  = $name;
        $this->email = $email;
    }

    /**
     * Should return the same value for all equal objects, but doesn't have to
     * be unique. This value will not be used to determine equality.
     */
    public function hash()
    {
        return $this->email;
    }

    /**
     * This determines equality, usually during a hash table lookup to determine
     * if the bucket's key matches the lookup key. The hash has to be equal if
     * the objects are equal, otherwise this determination wouldn't be reached.
     */
    public function equals($obj): bool
    {
        return $this->name  === $obj->name
            && $this->email === $obj->email;
    }
}
?>
Ds\Hashable::equals
Sequence
Hashable


The Sequence interface

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

A Sequence describes the behaviour of values arranged in a single, linear dimension. Some languages refer to this as a "List". It's similar to an array that uses incremental integer keys, with the exception of a few characteristics:

  • Values will always be indexed as [0, 1, 2, ..., size - 1].
  • Only allowed to access values by index in the range [0, size - 1].

Use cases:

  • Wherever you would use an array as a list (not concerned with keys).
  • A more efficient alternative to SplDoublyLinkedList and SplFixedArray.

Arayüz Sözdizimi

Ds\Sequence implements Ds\Collection {
/* Yöntemler */
abstract public void allocate ( int $capacity )
abstract public void apply ( callable $callback )
abstract public int capacity ( void )
abstract public bool contains ([ mixed $...values ] )
abstract public Ds\Sequence filter ([ callable $callback ] )
abstract public mixed find ( mixed $value )
abstract public mixed first ( void )
abstract public mixed get ( int $index )
abstract public void insert ( int $index [, mixed $...values ] )
abstract public string join ([ string $glue ] )
abstract public mixed last ( void )
abstract public Ds\Sequence map ( callable $callback )
abstract public Ds\Sequence merge ( mixed $values )
abstract public mixed pop ( void )
abstract public void push ([ mixed $...values ] )
abstract public mixed reduce ( callable $callback [, mixed $initial ] )
abstract public mixed remove ( int $index )
abstract public void reverse ( void )
abstract public Ds\Sequence reversed ( void )
abstract public void rotate ( int $rotations )
abstract public void set ( int $index , mixed $value )
abstract public mixed shift ( void )
abstract public Ds\Sequence slice ( int $index [, int $length ] )
abstract public void sort ([ callable $comparator ] )
abstract public Ds\Sequence sorted ([ callable $comparator ] )
abstract public number sum ( void )
abstract public void unshift ([ mixed $values ] )
}

İçindekiler

  • Ds\Sequence::allocate — Allocates enough memory for a required capacity.
  • Ds\Sequence::apply — Updates all values by applying a callback function to each value.
  • Ds\Sequence::capacity — Returns the current capacity.
  • Ds\Sequence::contains — Determines if the sequence contains given values.
  • Ds\Sequence::filter — Creates a new sequence using a callable to determine which values to include.
  • Ds\Sequence::find — Attempts to find a value's index.
  • Ds\Sequence::first — Returns the first value in the sequence.
  • Ds\Sequence::get — Returns the value at a given index.
  • Ds\Sequence::insert — Inserts values at a given index.
  • Ds\Sequence::join — Joins all values together as a string.
  • Ds\Sequence::last — Returns the last value.
  • Ds\Sequence::map — Returns the result of applying a callback to each value.
  • Ds\Sequence::merge — Returns the result of adding all given values to the sequence.
  • Ds\Sequence::pop — Removes and returns the last value.
  • Ds\Sequence::push — Adds values to the end of the sequence.
  • Ds\Sequence::reduce — Reduces the sequence to a single value using a callback function.
  • Ds\Sequence::remove — Removes and returns a value by index.
  • Ds\Sequence::reverse — Reverses the sequence in-place.
  • Ds\Sequence::reversed — Returns a reversed copy.
  • Ds\Sequence::rotate — Rotates the sequence by a given number of rotations.
  • Ds\Sequence::set — Updates a value at a given index.
  • Ds\Sequence::shift — Removes and returns the first value.
  • Ds\Sequence::slice — Returns a sub-sequence of a given range.
  • Ds\Sequence::sort — Sorts the sequence in-place.
  • Ds\Sequence::sorted — Returns a sorted copy.
  • Ds\Sequence::sum — Returns the sum of all values in the sequence.
  • Ds\Sequence::unshift — Adds values to the front of the sequence.
Ds\Hashable::hash
Ds\Sequence::allocate
Data Structures


Allocates enough memory for a required capacity.

Sequence
Ds\Sequence::apply
Sequence
PHP Manual

Ds\Sequence::allocate

(PECL ds >= 1.0.0)

Ds\Sequence::allocate — Allocates enough memory for a required capacity.

Açıklama

abstract public void Ds\Sequence::allocate ( int $capacity )

Ensures that enough memory is allocated for a required capacity. This removes the need to reallocate the internal as values are added.

Değiştirgeler

capacity

The number of values for which capacity should be allocated.

Bilginize:

Capacity will stay the same if this value is less than or equal to the current capacity.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\Sequence::allocate() example

<?php
$sequence = new \Ds\Vector();
var_dump($sequence->capacity());

$vector->allocate(100);
var_dump($sequence->capacity());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(10)
int(100)
Sequence
Ds\Sequence::apply
Sequence


Updates all values by applying a callback function to each value.

Ds\Sequence::allocate
Ds\Sequence::capacity
Sequence
PHP Manual

Ds\Sequence::apply

(PECL ds >= 1.0.0)

Ds\Sequence::apply — Updates all values by applying a callback function to each value.

Açıklama

abstract public void Ds\Sequence::apply ( callable $callback )

Updates all values by applying a callback function to each value in the sequence.

Değiştirgeler

callback

mixed callback ( mixed $value )

A callable to apply to each value in the sequence.

The callback should return what the value should be replaced by.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\Sequence::apply() example

<?php
$sequence = new \Ds\Sequence([1, 2, 3]);
$sequence->apply(function($value) { return $value * 2; });

print_r($sequence);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Vector Object
(
    [0] => 2
    [1] => 4
    [2] => 6
)
Ds\Sequence::allocate
Ds\Sequence::capacity
Sequence


Returns the current capacity.

Ds\Sequence::apply
Ds\Sequence::contains
Sequence
PHP Manual

Ds\Sequence::capacity

(PECL ds >= 1.0.0)

Ds\Sequence::capacity — Returns the current capacity.

Açıklama

abstract public int Ds\Sequence::capacity ( void )

Returns the current capacity.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current capacity.

Örnekler

Örnek 1 Ds\Sequence::capacity() example

<?php
$sequence = new \Ds\Vector();
var_dump($sequence->capacity());

$sequence->push(...range(1, 50));
var_dump($sequence->capacity());

$sequence[] = "a";
var_dump($sequence->capacity());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(10)
int(50)
int(75)
Ds\Sequence::apply
Ds\Sequence::contains
Sequence


Determines if the sequence contains given values.

Ds\Sequence::capacity
Ds\Sequence::filter
Sequence
PHP Manual

Ds\Sequence::contains

(PECL ds >= 1.0.0)

Ds\Sequence::contains — Determines if the sequence contains given values.

Açıklama

abstract public bool Ds\Sequence::contains ([ mixed $...values ] )

Determines if the sequence contains all values.

Değiştirgeler

values

Values to check.

Dönen Değerler

FALSE if any of the provided values are not in the sequence, TRUE otherwise.

Örnekler

Örnek 1 Ds\Sequence::contains() example

<?php
$sequence = new \Ds\Vector(['a', 'b', 'c', 1, 2, 3]);

var_dump($sequence->contains('a'));                // true
var_dump($sequence->contains('a', 'b'));           // true
var_dump($sequence->contains('c', 'd'));           // false

var_dump($sequence->contains(...['c', 'b', 'a'])); // true

// Always strict
var_dump($sequence->contains(1));                  // true
var_dump($sequence->contains('1'));                // false

var_dump($sequece->contains(...[]));               // true
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(true)
bool(true)
bool(false)
bool(true)
bool(true)
bool(false)
bool(true)
Ds\Sequence::capacity
Ds\Sequence::filter
Sequence


Creates a new sequence using a callable to determine which values to include.

Ds\Sequence::contains
Ds\Sequence::find
Sequence
PHP Manual

Ds\Sequence::filter

(PECL ds >= 1.0.0)

Ds\Sequence::filter — Creates a new sequence using a callable to determine which values to include.

Açıklama

abstract public Ds\Sequence Ds\Sequence::filter ([ callable $callback ] )

Creates a new sequence using a callable to determine which values to include.

Değiştirgeler

callback

bool callback ( mixed $value )

Optional callable which returns TRUE if the value should be included, FALSE otherwise.

If a callback is not provided, only values which are TRUE (see converting to boolean) will be included.

Dönen Değerler

A new sequence containing all the values for which either the callback returned TRUE, or all values that convert to TRUE if a callback was not provided.

Örnekler

Örnek 1 Ds\Sequence::filter() example using callback function

<?php
$sequence = new \Ds\Vector([1, 2, 3, 4, 5]);

var_dump($sequence->filter(function($value) {
    return $value % 2 == 0;
}));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(Ds\Vector)#3 (2) {
  [0]=>
  int(2)
  [1]=>
  int(4)
}

Örnek 2 Ds\Sequence::filter() example without a callback function

<?php
$sequence = new \Ds\Vector([0, 1, 'a', true, false]);

var_dump($sequence->filter());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(Ds\Vector)#2 (3) {
  [0]=>
  int(1)
  [1]=>
  string(1) "a"
  [2]=>
  bool(true)
}
Ds\Sequence::contains
Ds\Sequence::find
Sequence


Attempts to find a value's index.

Ds\Sequence::filter
Ds\Sequence::first
Sequence
PHP Manual

Ds\Sequence::find

(PECL ds >= 1.0.0)

Ds\Sequence::find — Attempts to find a value's index.

Açıklama

abstract public mixed Ds\Sequence::find ( mixed $value )

Returns the index of the value, or FALSE if not found.

Değiştirgeler

value

The value to find.

Dönen Değerler

The index of the value, or FALSE if not found.

Bilginize:

Values will be compared by value and by type.

Örnekler

Örnek 1 Ds\Sequence::find() example

<?php
$sequence = new \Ds\Vector(["a", 1, true]);

var_dump($sequence->find("a")); // 0
var_dump($sequence->find("b")); // false
var_dump($sequence->find("1")); // false
var_dump($sequence->find(1));   // 1
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(0)
bool(false)
bool(false)
int(1)
Ds\Sequence::filter
Ds\Sequence::first
Sequence


Returns the first value in the sequence.

Ds\Sequence::find
Ds\Sequence::get
Sequence
PHP Manual

Ds\Sequence::first

(PECL ds >= 1.0.0)

Ds\Sequence::first — Returns the first value in the sequence.

Açıklama

abstract public mixed Ds\Sequence::first ( void )

Returns the first value in the sequence.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The first value in the sequence.

Hatalar/İstisnalar

UnderflowException if empty.

Örnekler

Örnek 1 Ds\Sequence::first() example

<?php
$sequence = new \Ds\Vector([1, 2, 3]);
var_dump($sequence->first());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(1)
Ds\Sequence::find
Ds\Sequence::get
Sequence


Returns the value at a given index.

Ds\Sequence::first
Ds\Sequence::insert
Sequence
PHP Manual

Ds\Sequence::get

(PECL ds >= 1.0.0)

Ds\Sequence::get — Returns the value at a given index.

Açıklama

abstract public mixed Ds\Sequence::get ( int $index )

Returns the value at a given index.

Değiştirgeler

index

The index to access, starting at 0.

Dönen Değerler

The value at the requested index.

Hatalar/İstisnalar

OutOfRangeException if the index is not valid.

Örnekler

Örnek 1 Ds\Sequence::get() example

<?php
$sequence = new \Ds\Vector(["a", "b", "c"]);

var_dump($sequence->get(0));
var_dump($sequence->get(1));
var_dump($sequence->get(2));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(1) "a"
string(1) "b"
string(1) "c"

Örnek 2 Ds\Sequence::get() example using array syntax

<?php
$sequence = new \Ds\Vector(["a", "b", "c"]);

var_dump($sequence[0]);
var_dump($sequence[1]);
var_dump($sequence[2]);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(1) "a"
string(1) "b"
string(1) "c"
Ds\Sequence::first
Ds\Sequence::insert
Sequence


Inserts values at a given index.

Ds\Sequence::get
Ds\Sequence::join
Sequence
PHP Manual

Ds\Sequence::insert

(PECL ds >= 1.0.0)

Ds\Sequence::insert — Inserts values at a given index.

Açıklama

abstract public void Ds\Sequence::insert ( int $index [, mixed $...values ] )

Inserts values into the sequence at a given index.

Değiştirgeler

index

The index at which to insert. 0 <= index <= count

Bilginize:

You can insert at the index equal to the number of values.

values

The value or values to insert.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

OutOfRangeException if the index is not valid.

Örnekler

Örnek 1 Ds\Sequence::insert() example

<?php
$sequence = new \Ds\Vector();

$sequence->insert(0, "e");             // [e]
$sequence->insert(1, "f");             // [e, f]
$sequence->insert(2, "g");             // [e, f, g]
$sequence->insert(0, "a", "b");        // [a, b, e, f, g]
$sequence->insert(2, ...["c", "d"]);   // [a, b, c, d, e, f, g]

var_dump($sequence);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(Ds\Vector)#1 (7) {
  [0]=>
  string(1) "a"
  [1]=>
  string(1) "b"
  [2]=>
  string(1) "c"
  [3]=>
  string(1) "d"
  [4]=>
  string(1) "e"
  [5]=>
  string(1) "f"
  [6]=>
  string(1) "g"
}
Ds\Sequence::get
Ds\Sequence::join
Sequence


Joins all values together as a string.

Ds\Sequence::insert
Ds\Sequence::last
Sequence
PHP Manual

Ds\Sequence::join

(PECL ds >= 1.0.0)

Ds\Sequence::join — Joins all values together as a string.

Açıklama

abstract public string Ds\Sequence::join ([ string $glue ] )

Joins all values together as a string using an optional separator between each value.

Değiştirgeler

glue

An optional string to separate each value.

Dönen Değerler

All values of the sequence joined together as a string.

Örnekler

Örnek 1 Ds\Sequence::join() example using a separator string

<?php
$sequence = new \Ds\Vector(["a", "b", "c", 1, 2, 3]);

var_dump($sequence->join("|"));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(11) "a|b|c|1|2|3"

Örnek 2 Ds\Sequence::join() example without a separator string

<?php
$sequence = new \Ds\Vector(["a", "b", "c", 1, 2, 3]);

var_dump($sequence->join());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(11) "abc123"
Ds\Sequence::insert
Ds\Sequence::last
Sequence


Returns the last value.

Ds\Sequence::join
Ds\Sequence::map
Sequence
PHP Manual

Ds\Sequence::last

(PECL ds >= 1.0.0)

Ds\Sequence::last — Returns the last value.

Açıklama

abstract public mixed Ds\Sequence::last ( void )

Returns the last value in the sequence.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The last value in the sequence.

Hatalar/İstisnalar

UnderflowException if empty.

Örnekler

Örnek 1 Ds\Sequence::last() example

<?php
$sequence = new \Ds\Vector([1, 2, 3]);
var_dump($sequence->last());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(3)
Ds\Sequence::join
Ds\Sequence::map
Sequence


Returns the result of applying a callback to each value.

Ds\Sequence::last
Ds\Sequence::merge
Sequence
PHP Manual

Ds\Sequence::map

(PECL ds >= 1.0.0)

Ds\Sequence::map — Returns the result of applying a callback to each value.

Açıklama

abstract public Ds\Sequence Ds\Sequence::map ( callable $callback )

Returns the result of applying a callback function to each value in the sequence.

Değiştirgeler

callback

mixed callback ( mixed $value )

A callable to apply to each value in the sequence.

The callable should return what the new value will be in the new sequence.

Dönen Değerler

The result of applying a callback to each value in the sequence.

Bilginize:

The values of the current instance won't be affected.

Örnekler

Örnek 1 Ds\Sequence::map() example

<?php
$sequence = new \Ds\Vector([1, 2, 3]);

print_r($sequence->map(function($value) { return $value * 2; }));
print_r($sequence);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Vector Object
(
    [0] => 2
    [1] => 4
    [2] => 6
)
Ds\Vector Object
(
    [0] => 1
    [1] => 2
    [2] => 3
)
Ds\Sequence::last
Ds\Sequence::merge
Sequence


Returns the result of adding all given values to the sequence.

Ds\Sequence::map
Ds\Sequence::pop
Sequence
PHP Manual

Ds\Sequence::merge

(PECL ds >= 1.0.0)

Ds\Sequence::merge — Returns the result of adding all given values to the sequence.

Açıklama

abstract public Ds\Sequence Ds\Sequence::merge ( mixed $values )

Returns the result of adding all given values to the sequence.

Değiştirgeler

values

A traversable object or an array.

Dönen Değerler

The result of adding all given values to the sequence, effectively the same as adding the values to a copy, then returning that copy.

Bilginize:

The current instance won't be affected.

Örnekler

Örnek 1 Ds\Sequence::merge() example

<?php
$sequence = new \Ds\Vector([1, 2, 3]);

var_dump($sequence->merge([4, 5, 6]));
var_dump($sequence);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(Ds\Vector)#2 (6) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
  [3]=>
  int(4)
  [4]=>
  int(5)
  [5]=>
  int(6)
}
object(Ds\Vector)#1 (3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}
Ds\Sequence::map
Ds\Sequence::pop
Sequence


Removes and returns the last value.

Ds\Sequence::merge
Ds\Sequence::push
Sequence
PHP Manual

Ds\Sequence::pop

(PECL ds >= 1.0.0)

Ds\Sequence::pop — Removes and returns the last value.

Açıklama

abstract public mixed Ds\Sequence::pop ( void )

Removes and returns the last value.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The removed last value.

Hatalar/İstisnalar

UnderflowException if empty.

Örnekler

Örnek 1 Ds\Sequence::pop() example

<?php
$sequence = new \Ds\Vector([1, 2, 3]);

var_dump($sequence->pop());
var_dump($sequence->pop());
var_dump($sequence->pop());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(3)
int(2)
int(1)
Ds\Sequence::merge
Ds\Sequence::push
Sequence


Adds values to the end of the sequence.

Ds\Sequence::pop
Ds\Sequence::reduce
Sequence
PHP Manual

Ds\Sequence::push

(PECL ds >= 1.0.0)

Ds\Sequence::push — Adds values to the end of the sequence.

Açıklama

abstract public void Ds\Sequence::push ([ mixed $...values ] )

Adds values to the end of the sequence.

Değiştirgeler

values

The values to add.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\Sequence::push() example

<?php
$sequence = new \Ds\Vector();

$sequence->push("a");
$sequence->push("b");
$sequence->push("c", "d");
$sequence->push(...["e", "f"]);

print_r($sequence);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Vector Object
(
    [0] => a
    [1] => b
    [2] => c
    [3] => d
    [4] => e
    [5] => f
)
Ds\Sequence::pop
Ds\Sequence::reduce
Sequence


Reduces the sequence to a single value using a callback function.

Ds\Sequence::push
Ds\Sequence::remove
Sequence
PHP Manual

Ds\Sequence::reduce

(PECL ds >= 1.0.0)

Ds\Sequence::reduce — Reduces the sequence to a single value using a callback function.

Açıklama

abstract public mixed Ds\Sequence::reduce ( callable $callback [, mixed $initial ] )

Reduces the sequence to a single value using a callback function.

Değiştirgeler

callback
mixed callback ( mixed $carry , mixed $value )
carry

The return value of the previous callback, or initial if it's the first iteration.

value

The value of the current iteration.

initial

The initial value of the carry value. Can be NULL.

Dönen Değerler

The return value of the final callback.

Örnekler

Örnek 1 Ds\Sequence::reduce() with initial value example

<?php
$sequence = new \Ds\Vector([1, 2, 3]);

$callback = function($carry, $value) {
    return $carry * $value;
};

var_dump($sequence->reduce($callback, 5));

// Iterations:
//
// $carry = $initial = 5
//
// $carry = $carry * 1 =  5
// $carry = $carry * 2 = 10
// $carry = $carry * 3 = 30
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(30)

Örnek 2 Ds\Sequence::reduce() without an initial value example

<?php
$sequence = new \Ds\Vector([1, 2, 3]);

var_dump($sequence->reduce(function($carry, $value) {
    return $carry + $value + 5;
}));

// Iterations:
//
// $carry = $initial = null
//
// $carry = $carry + 1 + 5 =  6
// $carry = $carry + 2 + 5 = 13
// $carry = $carry + 3 + 5 = 21
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(21)
Ds\Sequence::push
Ds\Sequence::remove
Sequence


Removes and returns a value by index.

Ds\Sequence::reduce
Ds\Sequence::reverse
Sequence
PHP Manual

Ds\Sequence::remove

(PECL ds >= 1.0.0)

Ds\Sequence::remove — Removes and returns a value by index.

Açıklama

abstract public mixed Ds\Sequence::remove ( int $index )

Removes and returns a value by index.

Değiştirgeler

index

The index of the value to remove.

Dönen Değerler

The value that was removed.

Hatalar/İstisnalar

OutOfRangeException if the index is not valid.

Örnekler

Örnek 1 Ds\Sequence::remove() example

<?php
$sequence = new \Ds\Vector(["a", "b", "c"]);

var_dump($sequence->remove(1));
var_dump($sequence->remove(0));
var_dump($sequence->remove(0));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(1) "b"
string(1) "a"
string(1) "c"
Ds\Sequence::reduce
Ds\Sequence::reverse
Sequence


Reverses the sequence in-place.

Ds\Sequence::remove
Ds\Sequence::reversed
Sequence
PHP Manual

Ds\Sequence::reverse

(PECL ds >= 1.0.0)

Ds\Sequence::reverse — Reverses the sequence in-place.

Açıklama

abstract public void Ds\Sequence::reverse ( void )

Reverses the sequence in-place.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\Sequence::reverse() example

<?php
$sequence = new \Ds\Vector(["a", "b", "c"]);
$sequence->reverse();

print_r($sequence);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Vector Object
(
    [0] => c
    [1] => b
    [2] => a
)
Ds\Sequence::remove
Ds\Sequence::reversed
Sequence


Returns a reversed copy.

Ds\Sequence::reverse
Ds\Sequence::rotate
Sequence
PHP Manual

Ds\Sequence::reversed

(PECL ds >= 1.0.0)

Ds\Sequence::reversed — Returns a reversed copy.

Açıklama

abstract public Ds\Sequence Ds\Sequence::reversed ( void )

Returns a reversed copy of the sequence.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A reversed copy of the sequence.

Bilginize:

The current instance is not affected.

Örnekler

Örnek 1 Ds\Sequence::reversed() example

<?php
$sequence = new \Ds\Vector(["a", "b", "c"]);

print_r($sequence->reversed());
print_r($sequence);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Vector Object
(
    [0] => c
    [1] => b
    [2] => a
)
Ds\Vector Object
(
    [0] => a
    [1] => b
    [2] => c
)
Ds\Sequence::reverse
Ds\Sequence::rotate
Sequence


Rotates the sequence by a given number of rotations.

Ds\Sequence::reversed
Ds\Sequence::set
Sequence
PHP Manual

Ds\Sequence::rotate

(PECL ds >= 1.0.0)

Ds\Sequence::rotate — Rotates the sequence by a given number of rotations.

Açıklama

abstract public void Ds\Sequence::rotate ( int $rotations )

Rotates the sequence by a given number of rotations, which is equivalent to successively calling $sequence->push($sequence->shift()) if the number of rotations is positive, or $sequence->unshift($sequence->pop()) if negative.

Değiştirgeler

rotations

The number of times the sequence should be rotated.

Dönen Değerler

Hiçbir değer dönmez.. The sequence of the current instance will be rotated.

Örnekler

Örnek 1 Ds\Sequence::rotate() example

<?php
$sequence = new \Ds\Vector(["a", "b", "c", "d"]);

$sequence->rotate(1);  // "a" is shifted, then pushed.
print_r($sequence);

$sequence->rotate(2);  // "b" and "c" are both shifted, the pushed.
print_r($sequence);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

(
    [0] => b
    [1] => c
    [2] => d
    [3] => a
)
Ds\Vector Object
(
    [0] => d
    [1] => a
    [2] => b
    [3] => c
)
Ds\Sequence::reversed
Ds\Sequence::set
Sequence


Updates a value at a given index.

Ds\Sequence::rotate
Ds\Sequence::shift
Sequence
PHP Manual

Ds\Sequence::set

(PECL ds >= 1.0.0)

Ds\Sequence::set — Updates a value at a given index.

Açıklama

abstract public void Ds\Sequence::set ( int $index , mixed $value )

Updates a value at a given index.

Değiştirgeler

index

The index of the value to update.

value

The new value.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

OutOfRangeException if the index is not valid.

Örnekler

Örnek 1 Ds\Sequence::set() example

<?php
$sequence = new \Ds\Vector(["a", "b", "c"]);

$sequence->set(1, "_");
print_r($sequence);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Vector Object
(
    [0] => a
    [1] => _
    [2] => c
)

Örnek 2 Ds\Sequence::set() example using array syntax

<?php
$sequence = new \Ds\Vector(["a", "b", "c"]);

$sequence[1] = "_";
print_r($sequence);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Vector Object
(
    [0] => a
    [1] => _
    [2] => c
)
Ds\Sequence::rotate
Ds\Sequence::shift
Sequence


Removes and returns the first value.

Ds\Sequence::set
Ds\Sequence::slice
Sequence
PHP Manual

Ds\Sequence::shift

(PECL ds >= 1.0.0)

Ds\Sequence::shift — Removes and returns the first value.

Açıklama

abstract public mixed Ds\Sequence::shift ( void )

Removes and returns the first value.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The first value, which was removed.

Hatalar/İstisnalar

UnderflowException if empty.

Örnekler

Örnek 1 Ds\Sequence::shift() example

<?php
$sequence = new \Ds\Vector(["a", "b", "c"]);

var_dump($sequence->shift());
var_dump($sequence->shift());
var_dump($sequence->shift());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(1) "a"
string(1) "b"
string(1) "c"
Ds\Sequence::set
Ds\Sequence::slice
Sequence


Returns a sub-sequence of a given range.

Ds\Sequence::shift
Ds\Sequence::sort
Sequence
PHP Manual

Ds\Sequence::slice

(PECL ds >= 1.0.0)

Ds\Sequence::slice — Returns a sub-sequence of a given range.

Açıklama

abstract public Ds\Sequence Ds\Sequence::slice ( int $index [, int $length ] )

Creates a sub-sequence of a given range.

Değiştirgeler

index

The index at which the sub-sequence starts.

If positive, the sequence will start at that index in the sequence. If negative, the sequence will start that far from the end.

length

If a length is given and is positive, the resulting sequence will have up to that many values in it. If the length results in an overflow, only values up to the end of the sequence will be included. If a length is given and is negative, the sequence will stop that many values from the end. If a length is not provided, the resulting sequence will contain all values between the index and the end of the sequence.

Dönen Değerler

A sub-sequence of the given range.

Örnekler

Örnek 1 Ds\Sequence::slice() example

<?php
$sequence = new \Ds\Vector(["a", "b", "c", "d", "e"]);

// Slice from 2 onwards
print_r($sequence->slice(2));

// Slice from 1, for a length of 3
print_r($sequence->slice(1, 3));

// Slice from 1 onwards
print_r($sequence->slice(1));

// Slice from 2 from the end onwards
print_r($sequence->slice(-2));

// Slice from 1 to 1 from the end
print_r($sequence->slice(1, -1));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Vector Object
(
    [0] => c
    [1] => d
    [2] => e
)
Ds\Vector Object
(
    [0] => b
    [1] => c
    [2] => d
)
Ds\Vector Object
(
    [0] => b
    [1] => c
    [2] => d
    [3] => e
)
Ds\Vector Object
(
    [0] => d
    [1] => e
)
Ds\Vector Object
(
    [0] => b
    [1] => c
    [2] => d
)
Ds\Sequence::shift
Ds\Sequence::sort
Sequence


Sorts the sequence in-place.

Ds\Sequence::slice
Ds\Sequence::sorted
Sequence
PHP Manual

Ds\Sequence::sort

(PECL ds >= 1.0.0)

Ds\Sequence::sort — Sorts the sequence in-place.

Açıklama

abstract public void Ds\Sequence::sort ([ callable $comparator ] )

Sorts the sequence in-place, using an optional comparator function.

Değiştirgeler

comparator

Karşılaştırma işlevinin, ilk bileşeninin ikinci bileşenden küçük, eşit veya büyük olması durumunda sıfırdan küçük, eşit veya büyük bir tamsayı döndürmesi gerekir.

int callback ( mixed $a, mixed $b )
Dikkat

Returning non-integer values from the comparison function, such as float, will result in an internal cast to integer of the callback's return value. So values such as 0.99 and 0.1 will both be cast to an integer value of 0, which will compare such values as equal.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\Sequence::sort() example

<?php
$sequence = new \Ds\Vector([4, 5, 1, 3, 2]);
$sequence->sort();

print_r($sequence);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Vector Object
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
    [4] => 5
)

Örnek 2 Ds\Sequence::sort() example using a comparator

<?php
$sequence = new \Ds\Vector([4, 5, 1, 3, 2]);

$sequence->sort(function($a, $b) {
    return $b <=> $a;
});

print_r($sequence);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Vector Object
(
    [0] => 5
    [1] => 4
    [2] => 3
    [3] => 2
    [4] => 1
)
Ds\Sequence::slice
Ds\Sequence::sorted
Sequence


Returns a sorted copy.

Ds\Sequence::sort
Ds\Sequence::sum
Sequence
PHP Manual

Ds\Sequence::sorted

(PECL ds >= 1.0.0)

Ds\Sequence::sorted — Returns a sorted copy.

Açıklama

abstract public Ds\Sequence Ds\Sequence::sorted ([ callable $comparator ] )

Returns a sorted copy, using an optional comparator function.

Değiştirgeler

comparator

Karşılaştırma işlevinin, ilk bileşeninin ikinci bileşenden küçük, eşit veya büyük olması durumunda sıfırdan küçük, eşit veya büyük bir tamsayı döndürmesi gerekir.

int callback ( mixed $a, mixed $b )
Dikkat

Returning non-integer values from the comparison function, such as float, will result in an internal cast to integer of the callback's return value. So values such as 0.99 and 0.1 will both be cast to an integer value of 0, which will compare such values as equal.

Dönen Değerler

Returns a sorted copy of the sequence.

Örnekler

Örnek 1 Ds\Sequence::sorted() example

<?php
$sequence = new \Ds\Vector([4, 5, 1, 3, 2]);

print_r($sequence->sorted());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Vector Object
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
    [4] => 5
)

Örnek 2 Ds\Sequence::sorted() example using a comparator

<?php
$sequence = new \Ds\Vector([4, 5, 1, 3, 2]);

$sorted = $sequence->sorted(function($a, $b) {
    return $b <=> $a;
});

print_r($sorted);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Vector Object
(
    [0] => 5
    [1] => 4
    [2] => 3
    [3] => 2
    [4] => 1
)
Ds\Sequence::sort
Ds\Sequence::sum
Sequence


Returns the sum of all values in the sequence.

Ds\Sequence::sorted
Ds\Sequence::unshift
Sequence
PHP Manual

Ds\Sequence::sum

(PECL ds >= 1.0.0)

Ds\Sequence::sum — Returns the sum of all values in the sequence.

Açıklama

abstract public number Ds\Sequence::sum ( void )

Returns the sum of all values in the sequence.

Bilginize:

Arrays and objects are considered equal to zero when calculating the sum.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The sum of all the values in the sequence as either a float or int depending on the values in the sequence.

Örnekler

Örnek 1 Ds\Sequence::sum() integer example

<?php
$sequence = new \Ds\Vector([1, 2, 3]);
var_dump($sequence->sum());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(6)

Örnek 2 Ds\Sequence::sum() float example

<?php
$sequence = new \Ds\Vector([1, 2.5, 3]);
var_dump($sequence->sum());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

float(6.5)
Ds\Sequence::sorted
Ds\Sequence::unshift
Sequence


Adds values to the front of the sequence.

Ds\Sequence::sum
Vector
Sequence
PHP Manual

Ds\Sequence::unshift

(PECL ds >= 1.0.0)

Ds\Sequence::unshift — Adds values to the front of the sequence.

Açıklama

abstract public void Ds\Sequence::unshift ([ mixed $values ] )

Adds values to the front of the sequence, moving all the current values forward to make room for the new values.

Değiştirgeler

values

The values to add to the front of the sequence.

Bilginize:

Multiple values will be added in the same order that they are passed.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\Sequence::unshift() example

<?php
$sequence = new \Ds\Vector([1, 2, 3]);

$sequence->unshift("a");
$sequence->unshift("b", "c");

print_r($sequence);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Vector Object
(
    [0] => b
    [1] => c
    [2] => a
    [3] => 1
    [4] => 2
    [5] => 3
)
Ds\Sequence::sum
Vector
Sequence


The Vector class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

A Vector is a sequence of values in a contiguous buffer that grows and shrinks automatically. It's the most efficient sequential structure because a value's index is a direct mapping to its index in the buffer, and the growth factor isn't bound to a specific multiple or exponent.

Strengths

  • Supports array syntax (square brackets).
  • Uses less overall memory than an array for the same number of values.
  • Automatically frees allocated memory when its size drops low enough.
  • Capacity does not have to be a power of 2.
  • get(),
set(),
push(),
pop() are all O(1).

Weaknesses

  • shift(),
unshift(),
insert() and
remove() are all O(n).

Sınıf Sözdizimi

Ds\Vector implements Ds\Sequence {
/* Constants */
const int MIN_CAPACITY = 10 ;
/* Yöntemler */
public void allocate ( int $capacity )
public void apply ( callable $callback )
public int capacity ( void )
public void clear ( void )
public bool contains ([ mixed $...values ] )
public Ds\Vector copy ( void )
public Ds\Vector filter ([ callable $callback ] )
public mixed find ( mixed $value )
public mixed first ( void )
public mixed get ( int $index )
public void insert ( int $index [, mixed $...values ] )
public bool isEmpty ( void )
public string join ([ string $glue ] )
public mixed last ( void )
public Ds\Vector map ( callable $callback )
public Ds\Vector merge ( mixed $values )
public mixed pop ( void )
public void push ([ mixed $...values ] )
public mixed reduce ( callable $callback [, mixed $initial ] )
public mixed remove ( int $index )
public void reverse ( void )
public Ds\Vector reversed ( void )
public void rotate ( int $rotations )
public void set ( int $index , mixed $value )
public mixed shift ( void )
public Ds\Vector slice ( int $index [, int $length ] )
public void sort ([ callable $comparator ] )
public Ds\Vector sorted ([ callable $comparator ] )
public number sum ( void )
public array toArray ( void )
public void unshift ([ mixed $values ] )
}

Öntanımlı Sabitler

Ds\Vector::MIN_CAPACITY

İçindekiler

  • Ds\Vector::allocate — Allocates enough memory for a required capacity.
  • Ds\Vector::apply — Updates all values by applying a callback function to each value.
  • Ds\Vector::capacity — Returns the current capacity.
  • Ds\Vector::clear — Removes all values.
  • Ds\Vector::__construct — Creates a new instance.
  • Ds\Vector::contains — Determines if the vector contains given values.
  • Ds\Vector::copy — Returns a shallow copy of the vector.
  • Ds\Vector::count — Returns the number of values in the collection.
  • Ds\Vector::filter — Creates a new vector using a callable to determine which values to include.
  • Ds\Vector::find — Attempts to find a value's index.
  • Ds\Vector::first — Returns the first value in the vector.
  • Ds\Vector::get — Returns the value at a given index.
  • Ds\Vector::insert — Inserts values at a given index.
  • Ds\Vector::isEmpty — Returns whether the vector is empty
  • Ds\Vector::join — Joins all values together as a string.
  • Ds\Vector::jsonSerialize — Returns a representation that can be converted to JSON.
  • Ds\Vector::last — Returns the last value.
  • Ds\Vector::map — Returns the result of applying a callback to each value.
  • Ds\Vector::merge — Returns the result of adding all given values to the vector.
  • Ds\Vector::pop — Removes and returns the last value.
  • Ds\Vector::push — Adds values to the end of the vector.
  • Ds\Vector::reduce — Reduces the vector to a single value using a callback function.
  • Ds\Vector::remove — Removes and returns a value by index.
  • Ds\Vector::reverse — Reverses the vector in-place.
  • Ds\Vector::reversed — Returns a reversed copy.
  • Ds\Vector::rotate — Rotates the vector by a given number of rotations.
  • Ds\Vector::set — Updates a value at a given index.
  • Ds\Vector::shift — Removes and returns the first value.
  • Ds\Vector::slice — Returns a sub-vector of a given range.
  • Ds\Vector::sort — Sorts the vector in-place.
  • Ds\Vector::sorted — Returns a sorted copy.
  • Ds\Vector::sum — Returns the sum of all values in the vector.
  • Ds\Vector::toArray — Converts the vector to an array.
  • Ds\Vector::unshift — Adds values to the front of the vector.
Ds\Sequence::unshift
Ds\Vector::allocate
Data Structures


Allocates enough memory for a required capacity.

Vector
Ds\Vector::apply
Vector
PHP Manual

Ds\Vector::allocate

(PECL ds >= 1.0.0)

Ds\Vector::allocate — Allocates enough memory for a required capacity.

Açıklama

public void Ds\Vector::allocate ( int $capacity )

Ensures that enough memory is allocated for a required capacity. This removes the need to reallocate the internal as values are added.

Değiştirgeler

capacity

The number of values for which capacity should be allocated.

Bilginize:

Capacity will stay the same if this value is less than or equal to the current capacity.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\Vector::allocate() example

<?php
$vector = new \Ds\Vector();
var_dump($vector->capacity());

$vector->allocate(100);
var_dump($vector->capacity());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(10)
int(100)
Vector
Ds\Vector::apply
Vector


Updates all values by applying a callback function to each value.

Ds\Vector::allocate
Ds\Vector::capacity
Vector
PHP Manual

Ds\Vector::apply

(PECL ds >= 1.0.0)

Ds\Vector::apply — Updates all values by applying a callback function to each value.

Açıklama

public void Ds\Vector::apply ( callable $callback )

Updates all values by applying a callback function to each value in the vector.

Değiştirgeler

callback

mixed callback ( mixed $value )

A callable to apply to each value in the vector.

The callback should return what the value should be replaced by.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\Vector::apply() example

<?php
$vector = new \Ds\Vector([1, 2, 3]);
$vector->apply(function($value) { return $value * 2; });

print_r($vector);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Vector Object
(
    [0] => 2
    [1] => 4
    [2] => 6
)
Ds\Vector::allocate
Ds\Vector::capacity
Vector


Returns the current capacity.

Ds\Vector::apply
Ds\Vector::clear
Vector
PHP Manual

Ds\Vector::capacity

(PECL ds >= 1.0.0)

Ds\Vector::capacity — Returns the current capacity.

Açıklama

public int Ds\Vector::capacity ( void )

Returns the current capacity.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current capacity.

Örnekler

Örnek 1 Ds\Vector::capacity() example

<?php
$vector = new \Ds\Vector();
var_dump($vector->capacity());

$vector->push(...range(1, 50));
var_dump($vector->capacity());

$vector[] = "a";
var_dump($vector->capacity());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(10)
int(50)
int(75)
Ds\Vector::apply
Ds\Vector::clear
Vector


Removes all values.

Ds\Vector::capacity
Ds\Vector::__construct
Vector
PHP Manual

Ds\Vector::clear

(PECL ds >= 1.0.0)

Ds\Vector::clear — Removes all values.

Açıklama

public void Ds\Vector::clear ( void )

Removes all values from the vector.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\Vector::clear() example

<?php
$vector = new \Ds\Vector([1, 2, 3]);
print_r($vector);

$vector->clear();
print_r($vector);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Vector Object
(
    [0] => 1
    [1] => 2
    [2] => 3
)
Ds\Vector Object
(
)
Ds\Vector::capacity
Ds\Vector::__construct
Vector


Creates a new instance.

Ds\Vector::clear
Ds\Vector::contains
Vector
PHP Manual

Ds\Vector::__construct

(PECL ds >= 1.0.0)

Ds\Vector::__construct — Creates a new instance.

Açıklama

public Ds\Vector::__construct ([ mixed $values ] )

Creates a new instance, using either a traversable object or an array for the initial values.

Değiştirgeler

values

A traversable object or an array to use for the initial values.

Örnekler

Örnek 1 Ds\Vector::__construct() example

<?php
$vector = new \Ds\Vector();
var_dump($vector);

$vector = new \Ds\Vector([1, 2, 3]);
var_dump($vector);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(Ds\Vector)#2 (0) {
}
object(Ds\Vector)#2 (3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}
Ds\Vector::clear
Ds\Vector::contains
Vector


Determines if the vector contains given values.

Ds\Vector::__construct
Ds\Vector::copy
Vector
PHP Manual

Ds\Vector::contains

(PECL ds >= 1.0.0)

Ds\Vector::contains — Determines if the vector contains given values.

Açıklama

public bool Ds\Vector::contains ([ mixed $...values ] )

Determines if the vector contains all values.

Değiştirgeler

values

Values to check.

Dönen Değerler

FALSE if any of the provided values are not in the vector, TRUE otherwise.

Örnekler

Örnek 1 Ds\Vector::contains() example

<?php
$vector = new \Ds\Vector(['a', 'b', 'c', 1, 2, 3]);

var_dump($vector->contains('a'));                // true
var_dump($vector->contains('a', 'b'));           // true
var_dump($vector->contains('c', 'd'));           // false

var_dump($vector->contains(...['c', 'b', 'a'])); // true

// Always strict
var_dump($vector->contains(1));                  // true
var_dump($vector->contains('1'));                // false

var_dump($sequece->contains(...[]));               // true
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(true)
bool(true)
bool(false)
bool(true)
bool(true)
bool(false)
bool(true)
Ds\Vector::__construct
Ds\Vector::copy
Vector


Returns a shallow copy of the vector.

Ds\Vector::contains
Ds\Vector::count
Vector
PHP Manual

Ds\Vector::copy

(PECL ds >= 1.0.0)

Ds\Vector::copy — Returns a shallow copy of the vector.

Açıklama

public Ds\Vector Ds\Vector::copy ( void )

Returns a shallow copy of the vector.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a shallow copy of the vector.

Örnekler

Örnek 1 Ds\Vector::copy() example

<?php
$a = new \Ds\Vector([1, 2, 3]);
$b = $a->copy();

// Updating the copy doesn't affect the original
$b->push(4);

print_r($a);
print_r($b);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Vector Object
(
    [0] => 1
    [1] => 2
    [2] => 3
)
Ds\Vector Object
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
)
Ds\Vector::contains
Ds\Vector::count
Vector


Returns the number of values in the collection.

Ds\Vector::copy
Ds\Vector::filter
Vector
PHP Manual

Ds\Vector::count

(PECL ds >= 1.0.0)

Ds\Vector::count — Returns the number of values in the collection.

See Countable::count()

Ds\Vector::copy
Ds\Vector::filter
Vector


Creates a new vector using a callable to determine which values to include.

Ds\Vector::count
Ds\Vector::find
Vector
PHP Manual

Ds\Vector::filter

(PECL ds >= 1.0.0)

Ds\Vector::filter — Creates a new vector using a callable to determine which values to include.

Açıklama

public Ds\Vector Ds\Vector::filter ([ callable $callback ] )

Creates a new vector using a callable to determine which values to include.

Değiştirgeler

callback

bool callback ( mixed $value )

Optional callable which returns TRUE if the value should be included, FALSE otherwise.

If a callback is not provided, only values which are TRUE (see converting to boolean) will be included.

Dönen Değerler

A new vector containing all the values for which either the callback returned TRUE, or all values that convert to TRUE if a callback was not provided.

Örnekler

Örnek 1 Ds\Vector::filter() example using callback function

<?php
$vector = new \Ds\Vector([1, 2, 3, 4, 5]);

var_dump($vector->filter(function($value) {
    return $value % 2 == 0;
}));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(Ds\Vector)#3 (2) {
  [0]=>
  int(2)
  [1]=>
  int(4)
}

Örnek 2 Ds\Vector::filter() example without a callback function

<?php
$vector = new \Ds\Vector([0, 1, 'a', true, false]);

var_dump($vector->filter());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(Ds\Vector)#2 (3) {
  [0]=>
  int(1)
  [1]=>
  string(1) "a"
  [2]=>
  bool(true)
}
Ds\Vector::count
Ds\Vector::find
Vector


Attempts to find a value's index.

Ds\Vector::filter
Ds\Vector::first
Vector
PHP Manual

Ds\Vector::find

(PECL ds >= 1.0.0)

Ds\Vector::find — Attempts to find a value's index.

Açıklama

public mixed Ds\Vector::find ( mixed $value )

Returns the index of the value, or FALSE if not found.

Değiştirgeler

value

The value to find.

Dönen Değerler

The index of the value, or FALSE if not found.

Bilginize:

Values will be compared by value and by type.

Örnekler

Örnek 1 Ds\Vector::find() example

<?php
$vector = new \Ds\Vector(["a", 1, true]);

var_dump($vector->find("a")); // 0
var_dump($vector->find("b")); // false
var_dump($vector->find("1")); // false
var_dump($vector->find(1));   // 1
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(0)
bool(false)
bool(false)
int(1)
Ds\Vector::filter
Ds\Vector::first
Vector


Returns the first value in the vector.

Ds\Vector::find
Ds\Vector::get
Vector
PHP Manual

Ds\Vector::first

(PECL ds >= 1.0.0)

Ds\Vector::first — Returns the first value in the vector.

Açıklama

public mixed Ds\Vector::first ( void )

Returns the first value in the vector.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The first value in the vector.

Hatalar/İstisnalar

UnderflowException if empty.

Örnekler

Örnek 1 Ds\Vector::first() example

<?php
$vector = new \Ds\Vector([1, 2, 3]);
var_dump($vector->first());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(1)
Ds\Vector::find
Ds\Vector::get
Vector


Returns the value at a given index.

Ds\Vector::first
Ds\Vector::insert
Vector
PHP Manual

Ds\Vector::get

(PECL ds >= 1.0.0)

Ds\Vector::get — Returns the value at a given index.

Açıklama

public mixed Ds\Vector::get ( int $index )

Returns the value at a given index.

Değiştirgeler

index

The index to access, starting at 0.

Dönen Değerler

The value at the requested index.

Hatalar/İstisnalar

OutOfRangeException if the index is not valid.

Örnekler

Örnek 1 Ds\Vector::get() example

<?php
$vector = new \Ds\Vector(["a", "b", "c"]);

var_dump($vector->get(0));
var_dump($vector->get(1));
var_dump($vector->get(2));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(1) "a"
string(1) "b"
string(1) "c"

Örnek 2 Ds\Vector::get() example using array syntax

<?php
$vector = new \Ds\Vector(["a", "b", "c"]);

var_dump($vector[0]);
var_dump($vector[1]);
var_dump($vector[2]);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(1) "a"
string(1) "b"
string(1) "c"
Ds\Vector::first
Ds\Vector::insert
Vector


Inserts values at a given index.

Ds\Vector::get
Ds\Vector::isEmpty
Vector
PHP Manual

Ds\Vector::insert

(PECL ds >= 1.0.0)

Ds\Vector::insert — Inserts values at a given index.

Açıklama

public void Ds\Vector::insert ( int $index [, mixed $...values ] )

Inserts values into the vector at a given index.

Değiştirgeler

index

The index at which to insert. 0 <= index <= count

Bilginize:

You can insert at the index equal to the number of values.

values

The value or values to insert.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

OutOfRangeException if the index is not valid.

Örnekler

Örnek 1 Ds\Vector::insert() example

<?php
$vector = new \Ds\Vector();

$vector->insert(0, "e");             // [e]
$vector->insert(1, "f");             // [e, f]
$vector->insert(2, "g");             // [e, f, g]
$vector->insert(0, "a", "b");        // [a, b, e, f, g]
$vector->insert(2, ...["c", "d"]);   // [a, b, c, d, e, f, g]

var_dump($vector);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(Ds\Vector)#1 (7) {
  [0]=>
  string(1) "a"
  [1]=>
  string(1) "b"
  [2]=>
  string(1) "c"
  [3]=>
  string(1) "d"
  [4]=>
  string(1) "e"
  [5]=>
  string(1) "f"
  [6]=>
  string(1) "g"
}
Ds\Vector::get
Ds\Vector::isEmpty
Vector


Returns whether the vector is empty

Ds\Vector::insert
Ds\Vector::join
Vector
PHP Manual

Ds\Vector::isEmpty

(PECL ds >= 1.0.0)

Ds\Vector::isEmpty — Returns whether the vector is empty

Açıklama

public bool Ds\Vector::isEmpty ( void )

Returns whether the vector is empty.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the vector is empty, FALSE otherwise.

Örnekler

Örnek 1 Ds\Vector::isEmpty() example

<?php
$a = new \Ds\Vector([1, 2, 3]);
$b = new \Ds\Vector();

var_dump($a->isEmpty());
var_dump($b->isEmpty());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(false)
bool(true)
Ds\Vector::insert
Ds\Vector::join
Vector


Joins all values together as a string.

Ds\Vector::isEmpty
Ds\Vector::jsonSerialize
Vector
PHP Manual

Ds\Vector::join

(PECL ds >= 1.0.0)

Ds\Vector::join — Joins all values together as a string.

Açıklama

public string Ds\Vector::join ([ string $glue ] )

Joins all values together as a string using an optional separator between each value.

Değiştirgeler

glue

An optional string to separate each value.

Dönen Değerler

All values of the vector joined together as a string.

Örnekler

Örnek 1 Ds\Vector::join() example using a separator string

<?php
$vector = new \Ds\Vector(["a", "b", "c", 1, 2, 3]);

var_dump($vector->join("|"));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(11) "a|b|c|1|2|3"

Örnek 2 Ds\Vector::join() example without a separator string

<?php
$vector = new \Ds\Vector(["a", "b", "c", 1, 2, 3]);

var_dump($vector->join());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(11) "abc123"
Ds\Vector::isEmpty
Ds\Vector::jsonSerialize
Vector


Returns a representation that can be converted to JSON.

Ds\Vector::join
Ds\Vector::last
Vector
PHP Manual

Ds\Vector::jsonSerialize

(PECL ds >= 1.0.0)

Ds\Vector::jsonSerialize — Returns a representation that can be converted to JSON.

See JsonSerializable::jsonSerialize()

Bilginize:

You should never need to call this directly.

Ds\Vector::join
Ds\Vector::last
Vector


Returns the last value.

Ds\Vector::jsonSerialize
Ds\Vector::map
Vector
PHP Manual

Ds\Vector::last

(PECL ds >= 1.0.0)

Ds\Vector::last — Returns the last value.

Açıklama

public mixed Ds\Vector::last ( void )

Returns the last value in the vector.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The last value in the vector.

Hatalar/İstisnalar

UnderflowException if empty.

Örnekler

Örnek 1 Ds\Vector::last() example

<?php
$vector = new \Ds\Vector([1, 2, 3]);
var_dump($vector->last());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(3)
Ds\Vector::jsonSerialize
Ds\Vector::map
Vector


Returns the result of applying a callback to each value.

Ds\Vector::last
Ds\Vector::merge
Vector
PHP Manual

Ds\Vector::map

(PECL ds >= 1.0.0)

Ds\Vector::map — Returns the result of applying a callback to each value.

Açıklama

public Ds\Vector Ds\Vector::map ( callable $callback )

Returns the result of applying a callback function to each value in the vector.

Değiştirgeler

callback

mixed callback ( mixed $value )

A callable to apply to each value in the vector.

The callable should return what the new value will be in the new vector.

Dönen Değerler

The result of applying a callback to each value in the vector.

Bilginize:

The values of the current instance won't be affected.

Örnekler

Örnek 1 Ds\Vector::map() example

<?php
$vector = new \Ds\Vector([1, 2, 3]);

print_r($vector->map(function($value) { return $value * 2; }));
print_r($vector);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Vector Object
(
    [0] => 2
    [1] => 4
    [2] => 6
)
Ds\Vector Object
(
    [0] => 1
    [1] => 2
    [2] => 3
)
Ds\Vector::last
Ds\Vector::merge
Vector


Returns the result of adding all given values to the vector.

Ds\Vector::map
Ds\Vector::pop
Vector
PHP Manual

Ds\Vector::merge

(PECL ds >= 1.0.0)

Ds\Vector::merge — Returns the result of adding all given values to the vector.

Açıklama

public Ds\Vector Ds\Vector::merge ( mixed $values )

Returns the result of adding all given values to the vector.

Değiştirgeler

values

A traversable object or an array.

Dönen Değerler

The result of adding all given values to the vector, effectively the same as adding the values to a copy, then returning that copy.

Bilginize:

The current instance won't be affected.

Örnekler

Örnek 1 Ds\Vector::merge() example

<?php
$vector = new \Ds\Vector([1, 2, 3]);

var_dump($vector->merge([4, 5, 6]));
var_dump($vector);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(Ds\Vector)#2 (6) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
  [3]=>
  int(4)
  [4]=>
  int(5)
  [5]=>
  int(6)
}
object(Ds\Vector)#1 (3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}
Ds\Vector::map
Ds\Vector::pop
Vector


Removes and returns the last value.

Ds\Vector::merge
Ds\Vector::push
Vector
PHP Manual

Ds\Vector::pop

(PECL ds >= 1.0.0)

Ds\Vector::pop — Removes and returns the last value.

Açıklama

public mixed Ds\Vector::pop ( void )

Removes and returns the last value.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The removed last value.

Hatalar/İstisnalar

UnderflowException if empty.

Örnekler

Örnek 1 Ds\Vector::pop() example

<?php
$vector = new \Ds\Vector([1, 2, 3]);

var_dump($vector->pop());
var_dump($vector->pop());
var_dump($vector->pop());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(3)
int(2)
int(1)
Ds\Vector::merge
Ds\Vector::push
Vector


Adds values to the end of the vector.

Ds\Vector::pop
Ds\Vector::reduce
Vector
PHP Manual

Ds\Vector::push

(PECL ds >= 1.0.0)

Ds\Vector::push — Adds values to the end of the vector.

Açıklama

public void Ds\Vector::push ([ mixed $...values ] )

Adds values to the end of the vector.

Değiştirgeler

values

The values to add.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\Vector::push() example

<?php
$vector = new \Ds\Vector();

$vector->push("a");
$vector->push("b");
$vector->push("c", "d");
$vector->push(...["e", "f"]);

print_r($vector);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Vector Object
(
    [0] => a
    [1] => b
    [2] => c
    [3] => d
    [4] => e
    [5] => f
)
Ds\Vector::pop
Ds\Vector::reduce
Vector


Reduces the vector to a single value using a callback function.

Ds\Vector::push
Ds\Vector::remove
Vector
PHP Manual

Ds\Vector::reduce

(PECL ds >= 1.0.0)

Ds\Vector::reduce — Reduces the vector to a single value using a callback function.

Açıklama

public mixed Ds\Vector::reduce ( callable $callback [, mixed $initial ] )

Reduces the vector to a single value using a callback function.

Değiştirgeler

callback
mixed callback ( mixed $carry , mixed $value )
carry

The return value of the previous callback, or initial if it's the first iteration.

value

The value of the current iteration.

initial

The initial value of the carry value. Can be NULL.

Dönen Değerler

The return value of the final callback.

Örnekler

Örnek 1 Ds\Vector::reduce() with initial value example

<?php
$vector = new \Ds\Vector([1, 2, 3]);

$callback = function($carry, $value) {
    return $carry * $value;
};

var_dump($vector->reduce($callback, 5));

// Iterations:
//
// $carry = $initial = 5
//
// $carry = $carry * 1 =  5
// $carry = $carry * 2 = 10
// $carry = $carry * 3 = 30
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(30)

Örnek 2 Ds\Vector::reduce() without an initial value example

<?php
$vector = new \Ds\Vector([1, 2, 3]);

var_dump($vector->reduce(function($carry, $value) {
    return $carry + $value + 5;
}));

// Iterations:
//
// $carry = $initial = null
//
// $carry = $carry + 1 + 5 =  6
// $carry = $carry + 2 + 5 = 13
// $carry = $carry + 3 + 5 = 21
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(21)
Ds\Vector::push
Ds\Vector::remove
Vector


Removes and returns a value by index.

Ds\Vector::reduce
Ds\Vector::reverse
Vector
PHP Manual

Ds\Vector::remove

(PECL ds >= 1.0.0)

Ds\Vector::remove — Removes and returns a value by index.

Açıklama

public mixed Ds\Vector::remove ( int $index )

Removes and returns a value by index.

Değiştirgeler

index

The index of the value to remove.

Dönen Değerler

The value that was removed.

Hatalar/İstisnalar

OutOfRangeException if the index is not valid.

Örnekler

Örnek 1 Ds\Vector::remove() example

<?php
$vector = new \Ds\Vector(["a", "b", "c"]);

var_dump($vector->remove(1));
var_dump($vector->remove(0));
var_dump($vector->remove(0));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(1) "b"
string(1) "a"
string(1) "c"
Ds\Vector::reduce
Ds\Vector::reverse
Vector


Reverses the vector in-place.

Ds\Vector::remove
Ds\Vector::reversed
Vector
PHP Manual

Ds\Vector::reverse

(PECL ds >= 1.0.0)

Ds\Vector::reverse — Reverses the vector in-place.

Açıklama

public void Ds\Vector::reverse ( void )

Reverses the vector in-place.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\Vector::reverse() example

<?php
$vector = new \Ds\Vector(["a", "b", "c"]);
$vector->reverse();

print_r($vector);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Vector Object
(
    [0] => c
    [1] => b
    [2] => a
)
Ds\Vector::remove
Ds\Vector::reversed
Vector


Returns a reversed copy.

Ds\Vector::reverse
Ds\Vector::rotate
Vector
PHP Manual

Ds\Vector::reversed

(PECL ds >= 1.0.0)

Ds\Vector::reversed — Returns a reversed copy.

Açıklama

public Ds\Vector Ds\Vector::reversed ( void )

Returns a reversed copy of the vector.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A reversed copy of the vector.

Bilginize:

The current instance is not affected.

Örnekler

Örnek 1 Ds\Vector::reversed() example

<?php
$vector = new \Ds\Vector(["a", "b", "c"]);

print_r($vector->reversed());
print_r($vector);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Vector Object
(
    [0] => c
    [1] => b
    [2] => a
)
Ds\Vector Object
(
    [0] => a
    [1] => b
    [2] => c
)
Ds\Vector::reverse
Ds\Vector::rotate
Vector


Rotates the vector by a given number of rotations.

Ds\Vector::reversed
Ds\Vector::set
Vector
PHP Manual

Ds\Vector::rotate

(PECL ds >= 1.0.0)

Ds\Vector::rotate — Rotates the vector by a given number of rotations.

Açıklama

public void Ds\Vector::rotate ( int $rotations )

Rotates the vector by a given number of rotations, which is equivalent to successively calling $vector->push($vector->shift()) if the number of rotations is positive, or $vector->unshift($vector->pop()) if negative.

Değiştirgeler

rotations

The number of times the vector should be rotated.

Dönen Değerler

Hiçbir değer dönmez.. The vector of the current instance will be rotated.

Örnekler

Örnek 1 Ds\Vector::rotate() example

<?php
$vector = new \Ds\Vector(["a", "b", "c", "d"]);

$vector->rotate(1);  // "a" is shifted, then pushed.
print_r($vector);

$vector->rotate(2);  // "b" and "c" are both shifted, the pushed.
print_r($vector);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

(
    [0] => b
    [1] => c
    [2] => d
    [3] => a
)
Ds\Vector Object
(
    [0] => d
    [1] => a
    [2] => b
    [3] => c
)
Ds\Vector::reversed
Ds\Vector::set
Vector


Updates a value at a given index.

Ds\Vector::rotate
Ds\Vector::shift
Vector
PHP Manual

Ds\Vector::set

(PECL ds >= 1.0.0)

Ds\Vector::set — Updates a value at a given index.

Açıklama

public void Ds\Vector::set ( int $index , mixed $value )

Updates a value at a given index.

Değiştirgeler

index

The index of the value to update.

value

The new value.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

OutOfRangeException if the index is not valid.

Örnekler

Örnek 1 Ds\Vector::set() example

<?php
$vector = new \Ds\Vector(["a", "b", "c"]);

$vector->set(1, "_");
print_r($vector);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Vector Object
(
    [0] => a
    [1] => _
    [2] => c
)

Örnek 2 Ds\Vector::set() example using array syntax

<?php
$vector = new \Ds\Vector(["a", "b", "c"]);

$vector[1] = "_";
print_r($vector);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Vector Object
(
    [0] => a
    [1] => _
    [2] => c
)
Ds\Vector::rotate
Ds\Vector::shift
Vector


Removes and returns the first value.

Ds\Vector::set
Ds\Vector::slice
Vector
PHP Manual

Ds\Vector::shift

(PECL ds >= 1.0.0)

Ds\Vector::shift — Removes and returns the first value.

Açıklama

public mixed Ds\Vector::shift ( void )

Removes and returns the first value.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The first value, which was removed.

Hatalar/İstisnalar

UnderflowException if empty.

Örnekler

Örnek 1 Ds\Vector::shift() example

<?php
$vector = new \Ds\Vector(["a", "b", "c"]);

var_dump($vector->shift());
var_dump($vector->shift());
var_dump($vector->shift());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(1) "a"
string(1) "b"
string(1) "c"
Ds\Vector::set
Ds\Vector::slice
Vector


Returns a sub-vector of a given range.

Ds\Vector::shift
Ds\Vector::sort
Vector
PHP Manual

Ds\Vector::slice

(PECL ds >= 1.0.0)

Ds\Vector::slice — Returns a sub-vector of a given range.

Açıklama

public Ds\Vector Ds\Vector::slice ( int $index [, int $length ] )

Creates a sub-vector of a given range.

Değiştirgeler

index

The index at which the sub-vector starts.

If positive, the vector will start at that index in the vector. If negative, the vector will start that far from the end.

length

If a length is given and is positive, the resulting vector will have up to that many values in it. If the length results in an overflow, only values up to the end of the vector will be included. If a length is given and is negative, the vector will stop that many values from the end. If a length is not provided, the resulting vector will contain all values between the index and the end of the vector.

Dönen Değerler

A sub-vector of the given range.

Örnekler

Örnek 1 Ds\Vector::slice() example

<?php
$vector = new \Ds\Vector(["a", "b", "c", "d", "e"]);

// Slice from 2 onwards
print_r($vector->slice(2));

// Slice from 1, for a length of 3
print_r($vector->slice(1, 3));

// Slice from 1 onwards
print_r($vector->slice(1));

// Slice from 2 from the end onwards
print_r($vector->slice(-2));

// Slice from 1 to 1 from the end
print_r($vector->slice(1, -1));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Vector Object
(
    [0] => c
    [1] => d
    [2] => e
)
Ds\Vector Object
(
    [0] => b
    [1] => c
    [2] => d
)
Ds\Vector Object
(
    [0] => b
    [1] => c
    [2] => d
    [3] => e
)
Ds\Vector Object
(
    [0] => d
    [1] => e
)
Ds\Vector Object
(
    [0] => b
    [1] => c
    [2] => d
)
Ds\Vector::shift
Ds\Vector::sort
Vector


Sorts the vector in-place.

Ds\Vector::slice
Ds\Vector::sorted
Vector
PHP Manual

Ds\Vector::sort

(PECL ds >= 1.0.0)

Ds\Vector::sort — Sorts the vector in-place.

Açıklama

public void Ds\Vector::sort ([ callable $comparator ] )

Sorts the vector in-place, using an optional comparator function.

Değiştirgeler

comparator

Karşılaştırma işlevinin, ilk bileşeninin ikinci bileşenden küçük, eşit veya büyük olması durumunda sıfırdan küçük, eşit veya büyük bir tamsayı döndürmesi gerekir.

int callback ( mixed $a, mixed $b )
Dikkat

Returning non-integer values from the comparison function, such as float, will result in an internal cast to integer of the callback's return value. So values such as 0.99 and 0.1 will both be cast to an integer value of 0, which will compare such values as equal.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\Vector::sort() example

<?php
$vector = new \Ds\Vector([4, 5, 1, 3, 2]);
$vector->sort();

print_r($vector);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Vector Object
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
    [4] => 5
)

Örnek 2 Ds\Vector::sort() example using a comparator

<?php
$vector = new \Ds\Vector([4, 5, 1, 3, 2]);

$vector->sort(function($a, $b) {
    return $b <=> $a;
});

print_r($vector);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Vector Object
(
    [0] => 5
    [1] => 4
    [2] => 3
    [3] => 2
    [4] => 1
)
Ds\Vector::slice
Ds\Vector::sorted
Vector


Returns a sorted copy.

Ds\Vector::sort
Ds\Vector::sum
Vector
PHP Manual

Ds\Vector::sorted

(PECL ds >= 1.0.0)

Ds\Vector::sorted — Returns a sorted copy.

Açıklama

public Ds\Vector Ds\Vector::sorted ([ callable $comparator ] )

Returns a sorted copy, using an optional comparator function.

Değiştirgeler

comparator

Karşılaştırma işlevinin, ilk bileşeninin ikinci bileşenden küçük, eşit veya büyük olması durumunda sıfırdan küçük, eşit veya büyük bir tamsayı döndürmesi gerekir.

int callback ( mixed $a, mixed $b )
Dikkat

Returning non-integer values from the comparison function, such as float, will result in an internal cast to integer of the callback's return value. So values such as 0.99 and 0.1 will both be cast to an integer value of 0, which will compare such values as equal.

Dönen Değerler

Returns a sorted copy of the vector.

Örnekler

Örnek 1 Ds\Vector::sorted() example

<?php
$vector = new \Ds\Vector([4, 5, 1, 3, 2]);

print_r($vector->sorted());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Vector Object
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
    [4] => 5
)

Örnek 2 Ds\Vector::sorted() example using a comparator

<?php
$vector = new \Ds\Vector([4, 5, 1, 3, 2]);

$sorted = $vector->sorted(function($a, $b) {
    return $b <=> $a;
});

print_r($sorted);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Vector Object
(
    [0] => 5
    [1] => 4
    [2] => 3
    [3] => 2
    [4] => 1
)
Ds\Vector::sort
Ds\Vector::sum
Vector


Returns the sum of all values in the vector.

Ds\Vector::sorted
Ds\Vector::toArray
Vector
PHP Manual

Ds\Vector::sum

(PECL ds >= 1.0.0)

Ds\Vector::sum — Returns the sum of all values in the vector.

Açıklama

public number Ds\Vector::sum ( void )

Returns the sum of all values in the vector.

Bilginize:

Arrays and objects are considered equal to zero when calculating the sum.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The sum of all the values in the vector as either a float or int depending on the values in the vector.

Örnekler

Örnek 1 Ds\Vector::sum() integer example

<?php
$vector = new \Ds\Vector([1, 2, 3]);
var_dump($vector->sum());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(6)

Örnek 2 Ds\Vector::sum() float example

<?php
$vector = new \Ds\Vector([1, 2.5, 3]);
var_dump($vector->sum());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

float(6.5)
Ds\Vector::sorted
Ds\Vector::toArray
Vector


Converts the vector to an array.

Ds\Vector::sum
Ds\Vector::unshift
Vector
PHP Manual

Ds\Vector::toArray

(PECL ds >= 1.0.0)

Ds\Vector::toArray — Converts the vector to an array.

Açıklama

public array Ds\Vector::toArray ( void )

Converts the vector to an array.

Bilginize:

Casting to an array is not supported yet.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

An array containing all the values in the same order as the vector.

Örnekler

Örnek 1 Ds\Vector::toArray() example

<?php
$vector = new \Ds\Vector([1, 2, 3]);

var_dump($vector->toArray());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}
Ds\Vector::sum
Ds\Vector::unshift
Vector


Adds values to the front of the vector.

Ds\Vector::toArray
Deque
Vector
PHP Manual

Ds\Vector::unshift

(PECL ds >= 1.0.0)

Ds\Vector::unshift — Adds values to the front of the vector.

Açıklama

public void Ds\Vector::unshift ([ mixed $values ] )

Adds values to the front of the vector, moving all the current values forward to make room for the new values.

Değiştirgeler

values

The values to add to the front of the vector.

Bilginize:

Multiple values will be added in the same order that they are passed.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\Vector::unshift() example

<?php
$vector = new \Ds\Vector([1, 2, 3]);

$vector->unshift("a");
$vector->unshift("b", "c");

print_r($vector);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Vector Object
(
    [0] => b
    [1] => c
    [2] => a
    [3] => 1
    [4] => 2
    [5] => 3
)
Ds\Vector::toArray
Deque
Vector


The Deque class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

A Deque (pronounced "deck") is a sequence of values in a contiguous buffer that grows and shrinks automatically. The name is a common abbreviation of "double-ended queue" and is used internally by Ds\Queue.

Two pointers are used to keep track of a head and a tail. The pointers can "wrap around" the end of the buffer, which avoids the need to move other values around to make room. This makes shift and unshift very fast?—? something a Ds\Vector can't compete with.

Accessing a value by index requires a translation between the index and its corresponding position in the buffer: ((head + position) % capacity).

Strengths

  • Supports array syntax (square brackets).
  • Uses less overall memory than an array for the same number of values.
  • Automatically frees allocated memory when its size drops low enough.
  • get(),
set(),
push(),
pop(),
shift(), and
unshift() are all O(1).

Weaknesses

  • Capacity must be a power of 2.
  • insert() and remove() are O(n).

Sınıf Sözdizimi

Ds\Deque implements Ds\Sequence {
/* Constants */
const int MIN_CAPACITY = 8 ;
/* Yöntemler */
public void allocate ( int $capacity )
public void apply ( callable $callback )
public int capacity ( void )
public void clear ( void )
public bool contains ([ mixed $...values ] )
public Ds\Deque copy ( void )
public Ds\Deque filter ([ callable $callback ] )
public mixed find ( mixed $value )
public mixed first ( void )
public mixed get ( int $index )
public void insert ( int $index [, mixed $...values ] )
public bool isEmpty ( void )
public string join ([ string $glue ] )
public mixed last ( void )
public Ds\Deque map ( callable $callback )
public Ds\Deque merge ( mixed $values )
public mixed pop ( void )
public void push ([ mixed $...values ] )
public mixed reduce ( callable $callback [, mixed $initial ] )
public mixed remove ( int $index )
public void reverse ( void )
public Ds\Deque reversed ( void )
public void rotate ( int $rotations )
public void set ( int $index , mixed $value )
public mixed shift ( void )
public Ds\Deque slice ( int $index [, int $length ] )
public void sort ([ callable $comparator ] )
public Ds\Deque sorted ([ callable $comparator ] )
public number sum ( void )
public array toArray ( void )
public void unshift ([ mixed $values ] )
}

Öntanımlı Sabitler

Ds\Deque::MIN_CAPACITY

İçindekiler

  • Ds\Deque::allocate — Allocates enough memory for a required capacity.
  • Ds\Deque::apply — Updates all values by applying a callback function to each value.
  • Ds\Deque::capacity — Returns the current capacity.
  • Ds\Deque::clear — Removes all values from the deque.
  • Ds\Deque::__construct — Creates a new instance.
  • Ds\Deque::contains — Determines if the deque contains given values.
  • Ds\Deque::copy — Returns a shallow copy of the deque.
  • Ds\Deque::count — Returns the number of values in the collection.
  • Ds\Deque::filter — Creates a new deque using a callable to determine which values to include.
  • Ds\Deque::find — Attempts to find a value's index.
  • Ds\Deque::first — Returns the first value in the deque.
  • Ds\Deque::get — Returns the value at a given index.
  • Ds\Deque::insert — Inserts values at a given index.
  • Ds\Deque::isEmpty — Returns whether the deque is empty
  • Ds\Deque::join — Joins all values together as a string.
  • Ds\Deque::jsonSerialize — Returns a representation that can be converted to JSON.
  • Ds\Deque::last — Returns the last value.
  • Ds\Deque::map — Returns the result of applying a callback to each value.
  • Ds\Deque::merge — Returns the result of adding all given values to the deque.
  • Ds\Deque::pop — Removes and returns the last value.
  • Ds\Deque::push — Adds values to the end of the deque.
  • Ds\Deque::reduce — Reduces the deque to a single value using a callback function.
  • Ds\Deque::remove — Removes and returns a value by index.
  • Ds\Deque::reverse — Reverses the deque in-place.
  • Ds\Deque::reversed — Returns a reversed copy.
  • Ds\Deque::rotate — Rotates the deque by a given number of rotations.
  • Ds\Deque::set — Updates a value at a given index.
  • Ds\Deque::shift — Removes and returns the first value.
  • Ds\Deque::slice — Returns a sub-deque of a given range.
  • Ds\Deque::sort — Sorts the deque in-place.
  • Ds\Deque::sorted — Returns a sorted copy.
  • Ds\Deque::sum — Returns the sum of all values in the deque.
  • Ds\Deque::toArray — Converts the deque to an array.
  • Ds\Deque::unshift — Adds values to the front of the deque.
Ds\Vector::unshift
Ds\Deque::allocate
Data Structures


Allocates enough memory for a required capacity.

Deque
Ds\Deque::apply
Deque
PHP Manual

Ds\Deque::allocate

(PECL ds >= 1.0.0)

Ds\Deque::allocate — Allocates enough memory for a required capacity.

Açıklama

public void Ds\Deque::allocate ( int $capacity )

Ensures that enough memory is allocated for a required capacity. This removes the need to reallocate the internal as values are added.

Değiştirgeler

capacity

The number of values for which capacity should be allocated.

Bilginize:

Capacity will stay the same if this value is less than or equal to the current capacity.

Bilginize:

Capacity will always be rounded up to the nearest power of 2.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\Deque::allocate() example

<?php
$deque = new \Ds\Deque();
var_dump($deque->capacity());

$deque->allocate(100);
var_dump($deque->capacity());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(8)
int(128)
Deque
Ds\Deque::apply
Deque


Updates all values by applying a callback function to each value.

Ds\Deque::allocate
Ds\Deque::capacity
Deque
PHP Manual

Ds\Deque::apply

(PECL ds >= 1.0.0)

Ds\Deque::apply — Updates all values by applying a callback function to each value.

Açıklama

public void Ds\Deque::apply ( callable $callback )

Updates all values by applying a callback function to each value in the deque.

Değiştirgeler

callback

mixed callback ( mixed $value )

A callable to apply to each value in the deque.

The callback should return what the value should be replaced by.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\Deque::apply() example

<?php
$deque = new \Ds\Deque([1, 2, 3]);
$deque->apply(function($value) { return $value * 2; });

print_r($deque);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Deque Object
(
    [0] => 2
    [1] => 4
    [2] => 6
)
Ds\Deque::allocate
Ds\Deque::capacity
Deque


Returns the current capacity.

Ds\Deque::apply
Ds\Deque::clear
Deque
PHP Manual

Ds\Deque::capacity

(PECL ds >= 1.0.0)

Ds\Deque::capacity — Returns the current capacity.

Açıklama

public int Ds\Deque::capacity ( void )

Returns the current capacity.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current capacity.

Örnekler

Örnek 1 Ds\Deque::capacity() example

<?php
$deque = new \Ds\Deque();
var_dump($deque->capacity());

$deque->push(...range(1, 50));
var_dump($deque->capacity());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(8)
int(64)
Ds\Deque::apply
Ds\Deque::clear
Deque


Removes all values from the deque.

Ds\Deque::capacity
Ds\Deque::__construct
Deque
PHP Manual

Ds\Deque::clear

(PECL ds >= 1.0.0)

Ds\Deque::clear — Removes all values from the deque.

Açıklama

public void Ds\Deque::clear ( void )

Removes all values from the deque.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\Deque::clear() example

<?php
$deque = new \Ds\Deque([1, 2, 3]);
print_r($deque);

$deque->clear();
print_r($deque);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Deque Object
(
    [0] => 1
    [1] => 2
    [2] => 3
)
Ds\Deque Object
(
)
Ds\Deque::capacity
Ds\Deque::__construct
Deque


Creates a new instance.

Ds\Deque::clear
Ds\Deque::contains
Deque
PHP Manual

Ds\Deque::__construct

(PECL ds >= 1.0.0)

Ds\Deque::__construct — Creates a new instance.

Açıklama

public Ds\Deque::__construct ([ mixed $values ] )

Creates a new instance, using either a traversable object or an array for the initial values.

Değiştirgeler

values

A traversable object or an array to use for the initial values.

Örnekler

Örnek 1 Ds\Deque::__construct() example

<?php
$deque = new \Ds\Deque();
var_dump($deque);

$deque = new \Ds\Deque([1, 2, 3]);
var_dump($deque);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(Ds\Deque)#2 (0) {
}
object(Ds\Deque)#2 (3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}
Ds\Deque::clear
Ds\Deque::contains
Deque


Determines if the deque contains given values.

Ds\Deque::__construct
Ds\Deque::copy
Deque
PHP Manual

Ds\Deque::contains

(PECL ds >= 1.0.0)

Ds\Deque::contains — Determines if the deque contains given values.

Açıklama

public bool Ds\Deque::contains ([ mixed $...values ] )

Determines if the deque contains all values.

Değiştirgeler

values

Values to check.

Dönen Değerler

FALSE if any of the provided values are not in the deque, TRUE otherwise.

Örnekler

Örnek 1 Ds\Deque::contains() example

<?php
$deque = new \Ds\Deque(['a', 'b', 'c', 1, 2, 3]);

var_dump($deque->contains('a'));                // true
var_dump($deque->contains('a', 'b'));           // true
var_dump($deque->contains('c', 'd'));           // false

var_dump($deque->contains(...['c', 'b', 'a'])); // true

// Always strict
var_dump($deque->contains(1));                  // true
var_dump($deque->contains('1'));                // false

var_dump($sequece->contains(...[]));               // true
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(true)
bool(true)
bool(false)
bool(true)
bool(true)
bool(false)
bool(true)
Ds\Deque::__construct
Ds\Deque::copy
Deque


Returns a shallow copy of the deque.

Ds\Deque::contains
Ds\Deque::count
Deque
PHP Manual

Ds\Deque::copy

(PECL ds >= 1.0.0)

Ds\Deque::copy — Returns a shallow copy of the deque.

Açıklama

public Ds\Deque Ds\Deque::copy ( void )

Returns a shallow copy of the deque.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A shallow copy of the deque.

Örnekler

Örnek 1 Ds\Deque::copy() example

<?php
$a = new \Ds\Deque([1, 2, 3]);
$b = $a->copy();

$b->push(4);

print_r($a);
print_r($b);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Deque Object
(
    [0] => 1
    [1] => 2
    [2] => 3
)
Ds\Deque Object
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
)
Ds\Deque::contains
Ds\Deque::count
Deque


Returns the number of values in the collection.

Ds\Deque::copy
Ds\Deque::filter
Deque
PHP Manual

Ds\Deque::count

(PECL ds >= 1.0.0)

Ds\Deque::count — Returns the number of values in the collection.

See Countable::count()

Ds\Deque::copy
Ds\Deque::filter
Deque


Creates a new deque using a callable to determine which values to include.

Ds\Deque::count
Ds\Deque::find
Deque
PHP Manual

Ds\Deque::filter

(PECL ds >= 1.0.0)

Ds\Deque::filter — Creates a new deque using a callable to determine which values to include.

Açıklama

public Ds\Deque Ds\Deque::filter ([ callable $callback ] )

Creates a new deque using a callable to determine which values to include.

Değiştirgeler

callback

bool callback ( mixed $value )

Optional callable which returns TRUE if the value should be included, FALSE otherwise.

If a callback is not provided, only values which are TRUE (see converting to boolean) will be included.

Dönen Değerler

A new deque containing all the values for which either the callback returned TRUE, or all values that convert to TRUE if a callback was not provided.

Örnekler

Örnek 1 Ds\Deque::filter() example using callback function

<?php
$deque = new \Ds\Deque([1, 2, 3, 4, 5]);

var_dump($deque->filter(function($value) {
    return $value % 2 == 0;
}));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(Ds\Deque)#3 (2) {
  [0]=>
  int(2)
  [1]=>
  int(4)
}

Örnek 2 Ds\Deque::filter() example without a callback function

<?php
$deque = new \Ds\Deque([0, 1, 'a', true, false]);

var_dump($deque->filter());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(Ds\Deque)#2 (3) {
  [0]=>
  int(1)
  [1]=>
  string(1) "a"
  [2]=>
  bool(true)
}
Ds\Deque::count
Ds\Deque::find
Deque


Attempts to find a value's index.

Ds\Deque::filter
Ds\Deque::first
Deque
PHP Manual

Ds\Deque::find

(PECL ds >= 1.0.0)

Ds\Deque::find — Attempts to find a value's index.

Açıklama

public mixed Ds\Deque::find ( mixed $value )

Returns the index of the value, or FALSE if not found.

Değiştirgeler

value

The value to find.

Dönen Değerler

The index of the value, or FALSE if not found.

Bilginize:

Values will be compared by value and by type.

Örnekler

Örnek 1 Ds\Deque::find() example

<?php
$deque = new \Ds\Deque(["a", 1, true]);

var_dump($deque->find("a")); // 0
var_dump($deque->find("b")); // false
var_dump($deque->find("1")); // false
var_dump($deque->find(1));   // 1
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(0)
bool(false)
bool(false)
int(1)
Ds\Deque::filter
Ds\Deque::first
Deque


Returns the first value in the deque.

Ds\Deque::find
Ds\Deque::get
Deque
PHP Manual

Ds\Deque::first

(PECL ds >= 1.0.0)

Ds\Deque::first — Returns the first value in the deque.

Açıklama

public mixed Ds\Deque::first ( void )

Returns the first value in the deque.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The first value in the deque.

Hatalar/İstisnalar

UnderflowException if empty.

Örnekler

Örnek 1 Ds\Deque::first() example

<?php
$deque = new \Ds\Deque([1, 2, 3]);
var_dump($deque->first());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(1)
Ds\Deque::find
Ds\Deque::get
Deque


Returns the value at a given index.

Ds\Deque::first
Ds\Deque::insert
Deque
PHP Manual

Ds\Deque::get

(PECL ds >= 1.0.0)

Ds\Deque::get — Returns the value at a given index.

Açıklama

public mixed Ds\Deque::get ( int $index )

Returns the value at a given index.

Değiştirgeler

index

The index to access, starting at 0.

Dönen Değerler

The value at the requested index.

Hatalar/İstisnalar

OutOfRangeException if the index is not valid.

Örnekler

Örnek 1 Ds\Deque::get() example

<?php
$deque = new \Ds\Deque(["a", "b", "c"]);

var_dump($deque->get(0));
var_dump($deque->get(1));
var_dump($deque->get(2));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(1) "a"
string(1) "b"
string(1) "c"

Örnek 2 Ds\Deque::get() example using array syntax

<?php
$deque = new \Ds\Deque(["a", "b", "c"]);

var_dump($deque[0]);
var_dump($deque[1]);
var_dump($deque[2]);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(1) "a"
string(1) "b"
string(1) "c"
Ds\Deque::first
Ds\Deque::insert
Deque


Inserts values at a given index.

Ds\Deque::get
Ds\Deque::isEmpty
Deque
PHP Manual

Ds\Deque::insert

(PECL ds >= 1.0.0)

Ds\Deque::insert — Inserts values at a given index.

Açıklama

public void Ds\Deque::insert ( int $index [, mixed $...values ] )

Inserts values into the deque at a given index.

Değiştirgeler

index

The index at which to insert. 0 <= index <= count

Bilginize:

You can insert at the index equal to the number of values.

values

The value or values to insert.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

OutOfRangeException if the index is not valid.

Örnekler

Örnek 1 Ds\Deque::insert() example

<?php
$deque = new \Ds\Deque();

$deque->insert(0, "e");             // [e]
$deque->insert(1, "f");             // [e, f]
$deque->insert(2, "g");             // [e, f, g]
$deque->insert(0, "a", "b");        // [a, b, e, f, g]
$deque->insert(2, ...["c", "d"]);   // [a, b, c, d, e, f, g]

var_dump($deque);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(Ds\Deque)#1 (7) {
  [0]=>
  string(1) "a"
  [1]=>
  string(1) "b"
  [2]=>
  string(1) "c"
  [3]=>
  string(1) "d"
  [4]=>
  string(1) "e"
  [5]=>
  string(1) "f"
  [6]=>
  string(1) "g"
}
Ds\Deque::get
Ds\Deque::isEmpty
Deque


Returns whether the deque is empty

Ds\Deque::insert
Ds\Deque::join
Deque
PHP Manual

Ds\Deque::isEmpty

(PECL ds >= 1.0.0)

Ds\Deque::isEmpty — Returns whether the deque is empty

Açıklama

public bool Ds\Deque::isEmpty ( void )

Returns whether the deque is empty.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the deque is empty, FALSE otherwise.

Örnekler

Örnek 1 Ds\Deque::isEmpty() example

<?php
$a = new \Ds\Deque([1, 2, 3]);
$b = new \Ds\Deque();

var_dump($a->isEmpty());
var_dump($b->isEmpty());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(false)
bool(true)
Ds\Deque::insert
Ds\Deque::join
Deque


Joins all values together as a string.

Ds\Deque::isEmpty
Ds\Deque::jsonSerialize
Deque
PHP Manual

Ds\Deque::join

(PECL ds >= 1.0.0)

Ds\Deque::join — Joins all values together as a string.

Açıklama

public string Ds\Deque::join ([ string $glue ] )

Joins all values together as a string using an optional separator between each value.

Değiştirgeler

glue

An optional string to separate each value.

Dönen Değerler

All values of the deque joined together as a string.

Örnekler

Örnek 1 Ds\Deque::join() example using a separator string

<?php
$deque = new \Ds\Deque(["a", "b", "c", 1, 2, 3]);

var_dump($deque->join("|"));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(11) "a|b|c|1|2|3"

Örnek 2 Ds\Deque::join() example without a separator string

<?php
$deque = new \Ds\Deque(["a", "b", "c", 1, 2, 3]);

var_dump($deque->join());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(11) "abc123"
Ds\Deque::isEmpty
Ds\Deque::jsonSerialize
Deque


Returns a representation that can be converted to JSON.

Ds\Deque::join
Ds\Deque::last
Deque
PHP Manual

Ds\Deque::jsonSerialize

(PECL ds >= 1.0.0)

Ds\Deque::jsonSerialize — Returns a representation that can be converted to JSON.

See JsonSerializable::jsonSerialize()

Bilginize:

You should never need to call this directly.

Ds\Deque::join
Ds\Deque::last
Deque


Returns the last value.

Ds\Deque::jsonSerialize
Ds\Deque::map
Deque
PHP Manual

Ds\Deque::last

(PECL ds >= 1.0.0)

Ds\Deque::last — Returns the last value.

Açıklama

public mixed Ds\Deque::last ( void )

Returns the last value in the deque.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The last value in the deque.

Hatalar/İstisnalar

UnderflowException if empty.

Örnekler

Örnek 1 Ds\Deque::last() example

<?php
$deque = new \Ds\Deque([1, 2, 3]);
var_dump($deque->last());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(3)
Ds\Deque::jsonSerialize
Ds\Deque::map
Deque


Returns the result of applying a callback to each value.

Ds\Deque::last
Ds\Deque::merge
Deque
PHP Manual

Ds\Deque::map

(PECL ds >= 1.0.0)

Ds\Deque::map — Returns the result of applying a callback to each value.

Açıklama

public Ds\Deque Ds\Deque::map ( callable $callback )

Returns the result of applying a callback function to each value in the deque.

Değiştirgeler

callback

mixed callback ( mixed $value )

A callable to apply to each value in the deque.

The callable should return what the new value will be in the new deque.

Dönen Değerler

The result of applying a callback to each value in the deque.

Bilginize:

The values of the current instance won't be affected.

Örnekler

Örnek 1 Ds\Deque::map() example

<?php
$deque = new \Ds\Deque([1, 2, 3]);

print_r($deque->map(function($value) { return $value * 2; }));
print_r($deque);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Deque Object
(
    [0] => 2
    [1] => 4
    [2] => 6
)
Ds\Deque Object
(
    [0] => 1
    [1] => 2
    [2] => 3
)
Ds\Deque::last
Ds\Deque::merge
Deque


Returns the result of adding all given values to the deque.

Ds\Deque::map
Ds\Deque::pop
Deque
PHP Manual

Ds\Deque::merge

(PECL ds >= 1.0.0)

Ds\Deque::merge — Returns the result of adding all given values to the deque.

Açıklama

public Ds\Deque Ds\Deque::merge ( mixed $values )

Returns the result of adding all given values to the deque.

Değiştirgeler

values

A traversable object or an array.

Dönen Değerler

The result of adding all given values to the deque, effectively the same as adding the values to a copy, then returning that copy.

Bilginize:

The current instance won't be affected.

Örnekler

Örnek 1 Ds\Deque::merge() example

<?php
$deque = new \Ds\Deque([1, 2, 3]);

var_dump($deque->merge([4, 5, 6]));
var_dump($deque);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(Ds\Deque)#2 (6) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
  [3]=>
  int(4)
  [4]=>
  int(5)
  [5]=>
  int(6)
}
object(Ds\Deque)#1 (3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}
Ds\Deque::map
Ds\Deque::pop
Deque


Removes and returns the last value.

Ds\Deque::merge
Ds\Deque::push
Deque
PHP Manual

Ds\Deque::pop

(PECL ds >= 1.0.0)

Ds\Deque::pop — Removes and returns the last value.

Açıklama

public mixed Ds\Deque::pop ( void )

Removes and returns the last value.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The removed last value.

Hatalar/İstisnalar

UnderflowException if empty.

Örnekler

Örnek 1 Ds\Deque::pop() example

<?php
$deque = new \Ds\Deque([1, 2, 3]);

var_dump($deque->pop());
var_dump($deque->pop());
var_dump($deque->pop());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(3)
int(2)
int(1)
Ds\Deque::merge
Ds\Deque::push
Deque


Adds values to the end of the deque.

Ds\Deque::pop
Ds\Deque::reduce
Deque
PHP Manual

Ds\Deque::push

(PECL ds >= 1.0.0)

Ds\Deque::push — Adds values to the end of the deque.

Açıklama

public void Ds\Deque::push ([ mixed $...values ] )

Adds values to the end of the deque.

Değiştirgeler

values

The values to add.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\Deque::push() example

<?php
$deque = new \Ds\Deque();

$deque->push("a");
$deque->push("b");
$deque->push("c", "d");
$deque->push(...["e", "f"]);

print_r($deque);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Deque Object
(
    [0] => a
    [1] => b
    [2] => c
    [3] => d
    [4] => e
    [5] => f
)
Ds\Deque::pop
Ds\Deque::reduce
Deque


Reduces the deque to a single value using a callback function.

Ds\Deque::push
Ds\Deque::remove
Deque
PHP Manual

Ds\Deque::reduce

(PECL ds >= 1.0.0)

Ds\Deque::reduce — Reduces the deque to a single value using a callback function.

Açıklama

public mixed Ds\Deque::reduce ( callable $callback [, mixed $initial ] )

Reduces the deque to a single value using a callback function.

Değiştirgeler

callback
mixed callback ( mixed $carry , mixed $value )
carry

The return value of the previous callback, or initial if it's the first iteration.

value

The value of the current iteration.

initial

The initial value of the carry value. Can be NULL.

Dönen Değerler

The return value of the final callback.

Örnekler

Örnek 1 Ds\Deque::reduce() with initial value example

<?php
$deque = new \Ds\Deque([1, 2, 3]);

$callback = function($carry, $value) {
    return $carry * $value;
};

var_dump($deque->reduce($callback, 5));

// Iterations:
//
// $carry = $initial = 5
//
// $carry = $carry * 1 =  5
// $carry = $carry * 2 = 10
// $carry = $carry * 3 = 30
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(30)

Örnek 2 Ds\Deque::reduce() without an initial value example

<?php
$deque = new \Ds\Deque([1, 2, 3]);

var_dump($deque->reduce(function($carry, $value) {
    return $carry + $value + 5;
}));

// Iterations:
//
// $carry = $initial = null
//
// $carry = $carry + 1 + 5 =  6
// $carry = $carry + 2 + 5 = 13
// $carry = $carry + 3 + 5 = 21
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(21)
Ds\Deque::push
Ds\Deque::remove
Deque


Removes and returns a value by index.

Ds\Deque::reduce
Ds\Deque::reverse
Deque
PHP Manual

Ds\Deque::remove

(PECL ds >= 1.0.0)

Ds\Deque::remove — Removes and returns a value by index.

Açıklama

public mixed Ds\Deque::remove ( int $index )

Removes and returns a value by index.

Değiştirgeler

index

The index of the value to remove.

Dönen Değerler

The value that was removed.

Hatalar/İstisnalar

OutOfRangeException if the index is not valid.

Örnekler

Örnek 1 Ds\Deque::remove() example

<?php
$deque = new \Ds\Deque(["a", "b", "c"]);

var_dump($deque->remove(1));
var_dump($deque->remove(0));
var_dump($deque->remove(0));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(1) "b"
string(1) "a"
string(1) "c"
Ds\Deque::reduce
Ds\Deque::reverse
Deque


Reverses the deque in-place.

Ds\Deque::remove
Ds\Deque::reversed
Deque
PHP Manual

Ds\Deque::reverse

(PECL ds >= 1.0.0)

Ds\Deque::reverse — Reverses the deque in-place.

Açıklama

public void Ds\Deque::reverse ( void )

Reverses the deque in-place.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\Deque::reverse() example

<?php
$deque = new \Ds\Deque(["a", "b", "c"]);
$deque->reverse();

print_r($deque);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Deque Object
(
    [0] => c
    [1] => b
    [2] => a
)
Ds\Deque::remove
Ds\Deque::reversed
Deque


Returns a reversed copy.

Ds\Deque::reverse
Ds\Deque::rotate
Deque
PHP Manual

Ds\Deque::reversed

(PECL ds >= 1.0.0)

Ds\Deque::reversed — Returns a reversed copy.

Açıklama

public Ds\Deque Ds\Deque::reversed ( void )

Returns a reversed copy of the deque.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A reversed copy of the deque.

Bilginize:

The current instance is not affected.

Örnekler

Örnek 1 Ds\Deque::reversed() example

<?php
$deque = new \Ds\Deque(["a", "b", "c"]);

print_r($deque->reversed());
print_r($deque);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Deque Object
(
    [0] => c
    [1] => b
    [2] => a
)
Ds\Deque Object
(
    [0] => a
    [1] => b
    [2] => c
)
Ds\Deque::reverse
Ds\Deque::rotate
Deque


Rotates the deque by a given number of rotations.

Ds\Deque::reversed
Ds\Deque::set
Deque
PHP Manual

Ds\Deque::rotate

(PECL ds >= 1.0.0)

Ds\Deque::rotate — Rotates the deque by a given number of rotations.

Açıklama

public void Ds\Deque::rotate ( int $rotations )

Rotates the deque by a given number of rotations, which is equivalent to successively calling $deque->push($deque->shift()) if the number of rotations is positive, or $deque->unshift($deque->pop()) if negative.

Değiştirgeler

rotations

The number of times the deque should be rotated.

Dönen Değerler

Hiçbir değer dönmez.. The deque of the current instance will be rotated.

Örnekler

Örnek 1 Ds\Deque::rotate() example

<?php
$deque = new \Ds\Deque(["a", "b", "c", "d"]);

$deque->rotate(1);  // "a" is shifted, then pushed.
print_r($deque);

$deque->rotate(2);  // "b" and "c" are both shifted, the pushed.
print_r($deque);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

(
    [0] => b
    [1] => c
    [2] => d
    [3] => a
)
Ds\Deque Object
(
    [0] => d
    [1] => a
    [2] => b
    [3] => c
)
Ds\Deque::reversed
Ds\Deque::set
Deque


Updates a value at a given index.

Ds\Deque::rotate
Ds\Deque::shift
Deque
PHP Manual

Ds\Deque::set

(PECL ds >= 1.0.0)

Ds\Deque::set — Updates a value at a given index.

Açıklama

public void Ds\Deque::set ( int $index , mixed $value )

Updates a value at a given index.

Değiştirgeler

index

The index of the value to update.

value

The new value.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

OutOfRangeException if the index is not valid.

Örnekler

Örnek 1 Ds\Deque::set() example

<?php
$deque = new \Ds\Deque(["a", "b", "c"]);

$deque->set(1, "_");
print_r($deque);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Deque Object
(
    [0] => a
    [1] => _
    [2] => c
)

Örnek 2 Ds\Deque::set() example using array syntax

<?php
$deque = new \Ds\Deque(["a", "b", "c"]);

$deque[1] = "_";
print_r($deque);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Deque Object
(
    [0] => a
    [1] => _
    [2] => c
)
Ds\Deque::rotate
Ds\Deque::shift
Deque


Removes and returns the first value.

Ds\Deque::set
Ds\Deque::slice
Deque
PHP Manual

Ds\Deque::shift

(PECL ds >= 1.0.0)

Ds\Deque::shift — Removes and returns the first value.

Açıklama

public mixed Ds\Deque::shift ( void )

Removes and returns the first value.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The first value, which was removed.

Hatalar/İstisnalar

UnderflowException if empty.

Örnekler

Örnek 1 Ds\Deque::shift() example

<?php
$deque = new \Ds\Deque(["a", "b", "c"]);

var_dump($deque->shift());
var_dump($deque->shift());
var_dump($deque->shift());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(1) "a"
string(1) "b"
string(1) "c"
Ds\Deque::set
Ds\Deque::slice
Deque


Returns a sub-deque of a given range.

Ds\Deque::shift
Ds\Deque::sort
Deque
PHP Manual

Ds\Deque::slice

(PECL ds >= 1.0.0)

Ds\Deque::slice — Returns a sub-deque of a given range.

Açıklama

public Ds\Deque Ds\Deque::slice ( int $index [, int $length ] )

Creates a sub-deque of a given range.

Değiştirgeler

index

The index at which the sub-deque starts.

If positive, the deque will start at that index in the deque. If negative, the deque will start that far from the end.

length

If a length is given and is positive, the resulting deque will have up to that many values in it. If the length results in an overflow, only values up to the end of the deque will be included. If a length is given and is negative, the deque will stop that many values from the end. If a length is not provided, the resulting deque will contain all values between the index and the end of the deque.

Dönen Değerler

A sub-deque of the given range.

Örnekler

Örnek 1 Ds\Deque::slice() example

<?php
$deque = new \Ds\Deque(["a", "b", "c", "d", "e"]);

// Slice from 2 onwards
print_r($deque->slice(2));

// Slice from 1, for a length of 3
print_r($deque->slice(1, 3));

// Slice from 1 onwards
print_r($deque->slice(1));

// Slice from 2 from the end onwards
print_r($deque->slice(-2));

// Slice from 1 to 1 from the end
print_r($deque->slice(1, -1));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Deque Object
(
    [0] => c
    [1] => d
    [2] => e
)
Ds\Deque Object
(
    [0] => b
    [1] => c
    [2] => d
)
Ds\Deque Object
(
    [0] => b
    [1] => c
    [2] => d
    [3] => e
)
Ds\Deque Object
(
    [0] => d
    [1] => e
)
Ds\Deque Object
(
    [0] => b
    [1] => c
    [2] => d
)
Ds\Deque::shift
Ds\Deque::sort
Deque


Sorts the deque in-place.

Ds\Deque::slice
Ds\Deque::sorted
Deque
PHP Manual

Ds\Deque::sort

(PECL ds >= 1.0.0)

Ds\Deque::sort — Sorts the deque in-place.

Açıklama

public void Ds\Deque::sort ([ callable $comparator ] )

Sorts the deque in-place, using an optional comparator function.

Değiştirgeler

comparator

Karşılaştırma işlevinin, ilk bileşeninin ikinci bileşenden küçük, eşit veya büyük olması durumunda sıfırdan küçük, eşit veya büyük bir tamsayı döndürmesi gerekir.

int callback ( mixed $a, mixed $b )
Dikkat

Returning non-integer values from the comparison function, such as float, will result in an internal cast to integer of the callback's return value. So values such as 0.99 and 0.1 will both be cast to an integer value of 0, which will compare such values as equal.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\Deque::sort() example

<?php
$deque = new \Ds\Deque([4, 5, 1, 3, 2]);
$deque->sort();

print_r($deque);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Deque Object
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
    [4] => 5
)

Örnek 2 Ds\Deque::sort() example using a comparator

<?php
$deque = new \Ds\Deque([4, 5, 1, 3, 2]);

$deque->sort(function($a, $b) {
    return $b <=> $a;
});

print_r($deque);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Deque Object
(
    [0] => 5
    [1] => 4
    [2] => 3
    [3] => 2
    [4] => 1
)
Ds\Deque::slice
Ds\Deque::sorted
Deque


Returns a sorted copy.

Ds\Deque::sort
Ds\Deque::sum
Deque
PHP Manual

Ds\Deque::sorted

(PECL ds >= 1.0.0)

Ds\Deque::sorted — Returns a sorted copy.

Açıklama

public Ds\Deque Ds\Deque::sorted ([ callable $comparator ] )

Returns a sorted copy, using an optional comparator function.

Değiştirgeler

comparator

Karşılaştırma işlevinin, ilk bileşeninin ikinci bileşenden küçük, eşit veya büyük olması durumunda sıfırdan küçük, eşit veya büyük bir tamsayı döndürmesi gerekir.

int callback ( mixed $a, mixed $b )
Dikkat

Returning non-integer values from the comparison function, such as float, will result in an internal cast to integer of the callback's return value. So values such as 0.99 and 0.1 will both be cast to an integer value of 0, which will compare such values as equal.

Dönen Değerler

Returns a sorted copy of the deque.

Örnekler

Örnek 1 Ds\Deque::sorted() example

<?php
$deque = new \Ds\Deque([4, 5, 1, 3, 2]);

print_r($deque->sorted());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Deque Object
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
    [4] => 5
)

Örnek 2 Ds\Deque::sorted() example using a comparator

<?php
$deque = new \Ds\Deque([4, 5, 1, 3, 2]);

$sorted = $deque->sorted(function($a, $b) {
    return $b <=> $a;
});

print_r($sorted);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Deque Object
(
    [0] => 5
    [1] => 4
    [2] => 3
    [3] => 2
    [4] => 1
)
Ds\Deque::sort
Ds\Deque::sum
Deque


Returns the sum of all values in the deque.

Ds\Deque::sorted
Ds\Deque::toArray
Deque
PHP Manual

Ds\Deque::sum

(PECL ds >= 1.0.0)

Ds\Deque::sum — Returns the sum of all values in the deque.

Açıklama

public number Ds\Deque::sum ( void )

Returns the sum of all values in the deque.

Bilginize:

Arrays and objects are considered equal to zero when calculating the sum.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The sum of all the values in the deque as either a float or int depending on the values in the deque.

Örnekler

Örnek 1 Ds\Deque::sum() integer example

<?php
$deque = new \Ds\Deque([1, 2, 3]);
var_dump($deque->sum());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(6)

Örnek 2 Ds\Deque::sum() float example

<?php
$deque = new \Ds\Deque([1, 2.5, 3]);
var_dump($deque->sum());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

float(6.5)
Ds\Deque::sorted
Ds\Deque::toArray
Deque


Converts the deque to an array.

Ds\Deque::sum
Ds\Deque::unshift
Deque
PHP Manual

Ds\Deque::toArray

(PECL ds >= 1.0.0)

Ds\Deque::toArray — Converts the deque to an array.

Açıklama

public array Ds\Deque::toArray ( void )

Converts the deque to an array.

Bilginize:

Casting to an array is not supported yet.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

An array containing all the values in the same order as the deque.

Örnekler

Örnek 1 Ds\Deque::toArray() example

<?php
$deque = new \Ds\Deque([1, 2, 3]);

var_dump($deque->toArray());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}
Ds\Deque::sum
Ds\Deque::unshift
Deque


Adds values to the front of the deque.

Ds\Deque::toArray
Map
Deque
PHP Manual

Ds\Deque::unshift

(PECL ds >= 1.0.0)

Ds\Deque::unshift — Adds values to the front of the deque.

Açıklama

public void Ds\Deque::unshift ([ mixed $values ] )

Adds values to the front of the deque, moving all the current values forward to make room for the new values.

Değiştirgeler

values

The values to add to the front of the deque.

Bilginize:

Multiple values will be added in the same order that they are passed.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\Deque::unshift() example

<?php
$deque = new \Ds\Deque([1, 2, 3]);

$deque->unshift("a");
$deque->unshift("b", "c");

print_r($deque);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Deque Object
(
    [0] => b
    [1] => c
    [2] => a
    [3] => 1
    [4] => 2
    [5] => 3
)
Ds\Deque::toArray
Map
Deque


The Map class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

A Map is a sequential collection of key-value pairs, almost identical to an array used in a similar context. Keys can be any type, but must be unique. Values are replaced if added to the map using the same key.

Strengths

  • Keys and values can be any type, including objects.
  • Supports array syntax (square brackets).
  • Insertion order is preserved.
  • Performance and memory efficiency is very similar to an array.
  • Automatically frees allocated memory when its size drops low enough.

Weaknesses

  • Can't be converted to an array when objects are used as keys.

Sınıf Sözdizimi

Ds\Map implements Ds\Collection {
/* Constants */
const int MIN_CAPACITY = 16 ;
/* Yöntemler */
public void allocate ( int $capacity )
public void apply ( callable $callback )
public int capacity ( void )
public void clear ( void )
public Ds\Map copy ( void )
public Ds\Map diff ( Ds\Map $map )
public Ds\Map filter ([ callable $callback ] )
public Ds\Pair first ( void )
public mixed get ( mixed $key [, mixed $default ] )
public bool hasKey ( mixed $key )
public bool hasValue ( mixed $value )
public Ds\Map intersect ( Ds\Map $map )
public bool isEmpty ( void )
public Ds\Set keys ( void )
public void ksort ([ callable $comparator ] )
public Ds\Map ksorted ([ callable $comparator ] )
public Ds\Pair last ( void )
public Ds\Map map ( callable $callback )
public Ds\Map merge ( mixed $values )
public Ds\Sequence pairs ( void )
public void put ( mixed $key , mixed $value )
public void putAll ( mixed $pairs )
public mixed reduce ( callable $callback [, mixed $initial ] )
public mixed remove ( mixed $key [, mixed $default ] )
public void reverse ( void )
public Ds\Map reversed ( void )
public Ds\Pair skip ( int $position )
public Ds\Map slice ( int $index [, int $length ] )
public void sort ([ callable $comparator ] )
public Ds\Map sorted ([ callable $comparator ] )
public number sum ( void )
public array toArray ( void )
public Ds\Map union ( Ds\Map $map )
public Ds\Sequence values ( void )
public Ds\Map xor ( Ds\Map $map )
}

Öntanımlı Sabitler

Ds\Map::MIN_CAPACITY

İçindekiler

  • Ds\Map::allocate — Allocates enough memory for a required capacity.
  • Ds\Map::apply — Updates all values by applying a callback function to each value.
  • Ds\Map::capacity — Returns the current capacity.
  • Ds\Map::clear — Removes all values.
  • Ds\Map::__construct — Creates a new instance.
  • Ds\Map::copy — Returns a shallow copy of the map.
  • Ds\Map::count — Returns the number of values in the map.
  • Ds\Map::diff — Creates a new map using keys that aren't in another map.
  • Ds\Map::filter — Creates a new map using a callable to determine which pairs to include.
  • Ds\Map::first — Returns the first pair in the map.
  • Ds\Map::get — Returns the value for a given key.
  • Ds\Map::hasKey — Determines whether the map contains a given key.
  • Ds\Map::hasValue — Determines whether the map contains a given value.
  • Ds\Map::intersect — Creates a new map by intersecting keys with another map.
  • Ds\Map::isEmpty — Returns whether the map is empty
  • Ds\Map::jsonSerialize — Returns a representation that can be converted to JSON.
  • Ds\Map::keys — Returns a set of the map's keys.
  • Ds\Map::ksort — Sorts the map in-place by key.
  • Ds\Map::ksorted — Returns a copy, sorted by key.
  • Ds\Map::last — Returns the last pair of the map.
  • Ds\Map::map — Returns the result of applying a callback to each value.
  • Ds\Map::merge — Returns the result of adding all given associations.
  • Ds\Map::pairs — Returns a sequence containing all the pairs of the map.
  • Ds\Map::put — Associates a key with a value.
  • Ds\Map::putAll — Associates all key-value pairs of a traversable object or array.
  • Ds\Map::reduce — Reduces the map to a single value using a callback function.
  • Ds\Map::remove — Removes and returns a value by key.
  • Ds\Map::reverse — Reverses the map in-place.
  • Ds\Map::reversed — Returns a reversed copy.
  • Ds\Map::skip — Returns the pair at a given positional index.
  • Ds\Map::slice — Returns a subset of the map defined by a starting index and length.
  • Ds\Map::sort — Sorts the map in-place by value.
  • Ds\Map::sorted — Returns a copy, sorted by value.
  • Ds\Map::sum — Returns the sum of all values in the map.
  • Ds\Map::toArray — Converts the map to an array.
  • Ds\Map::union — Creates a new map using values from the current instance and another map.
  • Ds\Map::values — Returns a sequence of the map's values.
  • Ds\Map::xor — Creates a new map using keys of either the current instance or of another map, but not of both.
Ds\Deque::unshift
Ds\Map::allocate
Data Structures


Allocates enough memory for a required capacity.

Map
Ds\Map::apply
Map
PHP Manual

Ds\Map::allocate

(PECL ds >= 1.0.0)

Ds\Map::allocate — Allocates enough memory for a required capacity.

Açıklama

public void Ds\Map::allocate ( int $capacity )

Allocates enough memory for a required capacity.

Değiştirgeler

capacity

The number of values for which capacity should be allocated.

Bilginize:

Capacity will stay the same if this value is less than or equal to the current capacity.

Bilginize:

Capacity will always be rounded up to the nearest power of 2.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\Map::allocate() example

<?php
$map = new \Ds\Map();
var_dump($map->capacity());

$map->allocate(100);
var_dump($map->capacity());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(16)
int(128)
Map
Ds\Map::apply
Map


Updates all values by applying a callback function to each value.

Ds\Map::allocate
Ds\Map::capacity
Map
PHP Manual

Ds\Map::apply

(PECL ds >= 1.0.0)

Ds\Map::apply — Updates all values by applying a callback function to each value.

Açıklama

public void Ds\Map::apply ( callable $callback )

Updates all values by applying a callback function to each value in the map.

Değiştirgeler

callback

mixed callback ( mixed $key , mixed $value )

A callable to apply to each value in the map.

The callback should return what the value should be replaced by.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\Map::apply() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);
$map->apply(function($key, $value) { return $value * 2; });

print_r($map);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => a
            [value] => 2
        )

    [1] => Ds\Pair Object
        (
            [key] => b
            [value] => 4
        )

    [2] => Ds\Pair Object
        (
            [key] => c
            [value] => 6
        )

)
Ds\Map::allocate
Ds\Map::capacity
Map


Returns the current capacity.

Ds\Map::apply
Ds\Map::clear
Map
PHP Manual

Ds\Map::capacity

(PECL ds >= 1.0.0)

Ds\Map::capacity — Returns the current capacity.

Açıklama

public int Ds\Map::capacity ( void )

Returns the current capacity.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current capacity.

Örnekler

Örnek 1 Ds\Map::capacity() example

<?php
$map = new \Ds\Map();
var_dump($map->capacity());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(16)
Ds\Map::apply
Ds\Map::clear
Map


Removes all values.

Ds\Map::capacity
Ds\Map::__construct
Map
PHP Manual

Ds\Map::clear

(PECL ds >= 1.0.0)

Ds\Map::clear — Removes all values.

Açıklama

public void Ds\Map::clear ( void )

Removes all values from the map.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\Map::clear() example

<?php
$map = new \Ds\Map([
    "a" => 1,
    "b" => 2,
    "c" => 3,
]);
print_r($map);

$map->clear();
print_r($map);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => a
            [value] => 1
        )

    [1] => Ds\Pair Object
        (
            [key] => b
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => c
            [value] => 3
        )

)
Ds\Map Object
(
)
Ds\Map::capacity
Ds\Map::__construct
Map


Creates a new instance.

Ds\Map::clear
Ds\Map::copy
Map
PHP Manual

Ds\Map::__construct

(PECL ds >= 1.0.0)

Ds\Map::__construct — Creates a new instance.

Açıklama

public Ds\Map::__construct ([ mixed $...values ] )

Creates a new instance, using either a traversable object or an array for the initial values.

Değiştirgeler

values

A traversable object or an array to use for the initial values.

Örnekler

Örnek 1 Ds\Map::__construct() example

<?php
$map = new \Ds\Map();
var_dump($map);

$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);
var_dump($map);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(Ds\Map)#1 (0) {
}
object(Ds\Map)#2 (3) {
  [0]=>
  object(Ds\Pair)#1 (2) {
    ["key"]=>
    string(1) "a"
    ["value"]=>
    int(1)
  }
  [1]=>
  object(Ds\Pair)#3 (2) {
    ["key"]=>
    string(1) "b"
    ["value"]=>
    int(2)
  }
  [2]=>
  object(Ds\Pair)#4 (2) {
    ["key"]=>
    string(1) "c"
    ["value"]=>
    int(3)
  }
}
Ds\Map::clear
Ds\Map::copy
Map


Returns a shallow copy of the map.

Ds\Map::__construct
Ds\Map::count
Map
PHP Manual

Ds\Map::copy

(PECL ds >= 1.0.0)

Ds\Map::copy — Returns a shallow copy of the map.

Açıklama

public Ds\Map Ds\Map::copy ( void )

Returns a shallow copy of the map.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a shallow copy of the map.

Örnekler

Örnek 1 Ds\Map::copy() example

<?php
$map = new \Ds\Map([
    "a" => 1,
    "b" => 2,
    "c" => 3,
]);

print_r($map->copy());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => a
            [value] => 1
        )

    [1] => Ds\Pair Object
        (
            [key] => b
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => c
            [value] => 3
        )

)
Ds\Map::__construct
Ds\Map::count
Map


Returns the number of values in the map.

Ds\Map::copy
Ds\Map::diff
Map
PHP Manual

Ds\Map::count

(PECL ds >= 1.0.0)

Ds\Map::count — Returns the number of values in the map.

See Countable::count()

Ds\Map::copy
Ds\Map::diff
Map


Creates a new map using keys that aren't in another map.

Ds\Map::count
Ds\Map::filter
Map
PHP Manual

Ds\Map::diff

(PECL ds >= 1.0.0)

Ds\Map::diff — Creates a new map using keys that aren't in another map.

Açıklama

public Ds\Map Ds\Map::diff ( Ds\Map $map )

Returns the result of removing all keys from the current instance that are present in a given map.

A \ B = {x ? A | x ? B}

Değiştirgeler

map

The map containing the keys to exclude in the resulting map.

Dönen Değerler

The result of removing all keys from the current instance that are present in a given map.

See Also

  • » Compliment on Wikipedia

Örnekler

Örnek 1 Ds\Map::diff() example

<?php
$a = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);
$b = new \Ds\Map(["b" => 4, "c" => 5, "d" => 6]);

var_dump($a->diff($b));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(Ds\Map)#3 (1) {
  [0]=>
  object(Ds\Pair)#4 (2) {
    ["key"]=>
    string(1) "a"
    ["value"]=>
    int(1)
  }
}
Ds\Map::count
Ds\Map::filter
Map


Creates a new map using a callable to determine which pairs to include.

Ds\Map::diff
Ds\Map::first
Map
PHP Manual

Ds\Map::filter

(PECL ds >= 1.0.0)

Ds\Map::filter — Creates a new map using a callable to determine which pairs to include.

Açıklama

public Ds\Map Ds\Map::filter ([ callable $callback ] )

Creates a new map using a callable to determine which pairs to include.

Değiştirgeler

callback

bool callback ( mixed $key , mixed $value )

Optional callable which returns TRUE if the pair should be included, FALSE otherwise.

If a callback is not provided, only values which are TRUE (see converting to boolean) will be included.

Dönen Değerler

A new map containing all the pairs for which either the callback returned TRUE, or all values that convert to TRUE if a callback was not provided.

Örnekler

Örnek 1 Ds\Map::filter() example using callback function

<?php
$map = new \Ds\Map(["a", "b", "c", "d", "e"]);

var_dump($map->filter(function($key, $value) {
    return $key % 2 == 0;
}));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(Ds\Map)#3 (3) {
  [0]=>
  object(Ds\Pair)#2 (2) {
    ["key"]=>
    int(0)
    ["value"]=>
    string(1) "a"
  }
  [1]=>
  object(Ds\Pair)#4 (2) {
    ["key"]=>
    int(2)
    ["value"]=>
    string(1) "c"
  }
  [2]=>
  object(Ds\Pair)#5 (2) {
    ["key"]=>
    int(4)
    ["value"]=>
    string(1) "e"
  }
}

Örnek 2 Ds\Map::filter() example without a callback function

<?php
$map = new \Ds\Map(["a" => 0, "b" => 1, "c" => true, "d" => false]);

var_dump($map->filter());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(Ds\Map)#2 (3) {
  [0]=>
  int(1)
  [1]=>
  string(1) "a"
  [2]=>
  bool(true)
}
Ds\Map::diff
Ds\Map::first
Map


Returns the first pair in the map.

Ds\Map::filter
Ds\Map::get
Map
PHP Manual

Ds\Map::first

(PECL ds >= 1.0.0)

Ds\Map::first — Returns the first pair in the map.

Açıklama

public Ds\Pair Ds\Map::first ( void )

Returns the first pair in the map.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The first pair in the map.

Hatalar/İstisnalar

UnderflowException if empty.

Örnekler

Örnek 1 Ds\Map::first() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);
var_dump($map->first());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(Ds\Pair)#2 (2) {
  ["key"]=>
  string(1) "a"
  ["value"]=>
  int(1)
}
Ds\Map::filter
Ds\Map::get
Map


Returns the value for a given key.

Ds\Map::first
Ds\Map::hasKey
Map
PHP Manual

Ds\Map::get

(PECL ds >= 1.0.0)

Ds\Map::get — Returns the value for a given key.

Açıklama

public mixed Ds\Map::get ( mixed $key [, mixed $default ] )

Returns the value for a given key, or an optional default value if the key could not be found.

Bilginize:

Keys of type object are supported. If an object implements Ds\Hashable, equality will be determined by the object's equals function. If an object does not implement Ds\Hashable, objects must be references to the same instance to be considered equal.

Bilginize:

You can also use array syntax to access values by key, eg. $map["key"].

Dikkat

Be careful when using array syntax. Scalar keys will be coerced to integers by the engine. For example, $map["1"] will attempt to access int(1), while $map->get("1") will correctly look up the string key.

See Arrays.

Değiştirgeler

key

The key to look up.

default

The optional default value, returned if the key could not be found.

Dönen Değerler

The value mapped to the given key, or the default value if provided and the key could not be found in the map.

Hatalar/İstisnalar

OutOfBoundsException if the key could not be found and a default value was not provided.

Örnekler

Örnek 1 Ds\Map::get() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);

var_dump($map->get("a"));       // 1
var_dump($map->get("d", 10));   // 10 (default used)
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(1)
int(10)

Örnek 2 Ds\Map::get() example using array syntax

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);

var_dump($map["a"])); // 1
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(1)
Ds\Map::first
Ds\Map::hasKey
Map


Determines whether the map contains a given key.

Ds\Map::get
Ds\Map::hasValue
Map
PHP Manual

Ds\Map::hasKey

(PECL ds >= 1.0.0)

Ds\Map::hasKey — Determines whether the map contains a given key.

Açıklama

public bool Ds\Map::hasKey ( mixed $key )

Determines whether the map contains a given key.

Değiştirgeler

key

The key to look for.

Dönen Değerler

Returns TRUE if the key could found, FALSE otherwise.

Örnekler

Örnek 1 Ds\Map::hasKey() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);

var_dump($map->hasKey("a")); // true
var_dump($map->hasKey("e")); // false
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(true)
bool(false)
Ds\Map::get
Ds\Map::hasValue
Map


Determines whether the map contains a given value.

Ds\Map::hasKey
Ds\Map::intersect
Map
PHP Manual

Ds\Map::hasValue

(PECL ds >= 1.0.0)

Ds\Map::hasValue — Determines whether the map contains a given value.

Açıklama

public bool Ds\Map::hasValue ( mixed $value )

Determines whether the map contains a given value.

Değiştirgeler

value

The value to look for.

Dönen Değerler

Returns TRUE if the value could found, FALSE otherwise.

Örnekler

Örnek 1 Ds\Map::hasValue() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);

var_dump($map->hasValue(1)); // true
var_dump($map->hasValue(4)); // false
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(true)
bool(false)
Ds\Map::hasKey
Ds\Map::intersect
Map


Creates a new map by intersecting keys with another map.

Ds\Map::hasValue
Ds\Map::isEmpty
Map
PHP Manual

Ds\Map::intersect

(PECL ds >= 1.0.0)

Ds\Map::intersect — Creates a new map by intersecting keys with another map.

Açıklama

public Ds\Map Ds\Map::intersect ( Ds\Map $map )

Creates a new map containing the pairs of the current instance whose keys are also present in the given map. In other words, returns a copy of the current instance with all keys removed that are not also in the other map.

A ? B = {x : x ? A ? x ? B}

Bilginize:

Values from the current instance will be kept.

Değiştirgeler

map

The other map, containing the keys to intersect with.

Dönen Değerler

The key intersection of the current instance and another map.

See Also

  • » Intersection on Wikipedia

Örnekler

Örnek 1 Ds\Map::intersect() example

<?php
$a = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);
$b = new \Ds\Map(["b" => 4, "c" => 5, "d" => 6]);

var_dump($a->intersect($b));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(Ds\Map)#3 (2) {
  [0]=>
  object(Ds\Pair)#4 (2) {
    ["key"]=>
    string(1) "b"
    ["value"]=>
    int(2)
  }
  [1]=>
  object(Ds\Pair)#5 (2) {
    ["key"]=>
    string(1) "c"
    ["value"]=>
    int(3)
  }
}
Ds\Map::hasValue
Ds\Map::isEmpty
Map


Returns whether the map is empty

Ds\Map::intersect
Ds\Map::jsonSerialize
Map
PHP Manual

Ds\Map::isEmpty

(PECL ds >= 1.0.0)

Ds\Map::isEmpty — Returns whether the map is empty

Açıklama

public bool Ds\Map::isEmpty ( void )

Returns whether the map is empty.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the map is empty, FALSE otherwise.

Örnekler

Örnek 1 Ds\Map::isEmpty() example

<?php
$a = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);
$b = new \Ds\Map();

var_dump($a->isEmpty());
var_dump($b->isEmpty());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(false)
bool(true)
Ds\Map::intersect
Ds\Map::jsonSerialize
Map


Returns a representation that can be converted to JSON.

Ds\Map::isEmpty
Ds\Map::keys
Map
PHP Manual

Ds\Map::jsonSerialize

(PECL ds >= 1.0.0)

Ds\Map::jsonSerialize — Returns a representation that can be converted to JSON.

See JsonSerializable::jsonSerialize()

Bilginize:

You should never need to call this directly.

Ds\Map::isEmpty
Ds\Map::keys
Map


Returns a set of the map's keys.

Ds\Map::jsonSerialize
Ds\Map::ksort
Map
PHP Manual

Ds\Map::keys

(PECL ds >= 1.0.0)

Ds\Map::keys — Returns a set of the map's keys.

Açıklama

public Ds\Set Ds\Map::keys ( void )

Returns a set containing all the keys of the map, in the same order.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A Ds\Set containing all the keys of the map.

Örnekler

Örnek 1 Ds\Map::keys() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);
var_dump($map->keys());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(Ds\Set)#2 (3) {
  [0]=>
  string(1) "a"
  [1]=>
  string(1) "b"
  [2]=>
  string(1) "c"
}
Ds\Map::jsonSerialize
Ds\Map::ksort
Map


Sorts the map in-place by key.

Ds\Map::keys
Ds\Map::ksorted
Map
PHP Manual

Ds\Map::ksort

(PECL ds >= 1.0.0)

Ds\Map::ksort — Sorts the map in-place by key.

Açıklama

public void Ds\Map::ksort ([ callable $comparator ] )

Sorts the map in-place by key, using an optional comparator function.

Değiştirgeler

comparator

Karşılaştırma işlevinin, ilk bileşeninin ikinci bileşenden küçük, eşit veya büyük olması durumunda sıfırdan küçük, eşit veya büyük bir tamsayı döndürmesi gerekir.

int callback ( mixed $a, mixed $b )
Dikkat

Returning non-integer values from the comparison function, such as float, will result in an internal cast to integer of the callback's return value. So values such as 0.99 and 0.1 will both be cast to an integer value of 0, which will compare such values as equal.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\Map::ksort() example

<?php
$map = new \Ds\Map(["b" => 2, "c" => 3, "a" => 1]);
$map->ksort();

print_r($map);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => a
            [value] => 1
        )

    [1] => Ds\Pair Object
        (
            [key] => b
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => c
            [value] => 3
        )

)

Örnek 2 Ds\Map::ksort() example using a comparator

<?php
$map = new \Ds\Map([1 => "x", 2 => "y", 0 => "z"]);

// Reverse
$map->ksort(function($a, $b) {
    return $b <=> $a;
});

print_r($map);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Map Object
Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => 2
            [value] => y
        )

    [1] => Ds\Pair Object
        (
            [key] => 1
            [value] => x
        )

    [2] => Ds\Pair Object
        (
            [key] => 0
            [value] => z
        )

)
Ds\Map::keys
Ds\Map::ksorted
Map


Returns a copy, sorted by key.

Ds\Map::ksort
Ds\Map::last
Map
PHP Manual

Ds\Map::ksorted

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Ds\Map::ksorted — Returns a copy, sorted by key.

Açıklama

public Ds\Map Ds\Map::ksorted ([ callable $comparator ] )

Returns a copy sorted by key, using an optional comparator function.

Değiştirgeler

comparator

Karşılaştırma işlevinin, ilk bileşeninin ikinci bileşenden küçük, eşit veya büyük olması durumunda sıfırdan küçük, eşit veya büyük bir tamsayı döndürmesi gerekir.

int callback ( mixed $a, mixed $b )
Dikkat

Returning non-integer values from the comparison function, such as float, will result in an internal cast to integer of the callback's return value. So values such as 0.99 and 0.1 will both be cast to an integer value of 0, which will compare such values as equal.

Dönen Değerler

Returns a copy of the map, sorted by key.

Örnekler

Örnek 1 Ds\Map::ksorted() example

<?php
$map = new \Ds\Map(["b" => 2, "c" => 3, "a" => 1]);

print_r($map->ksorted());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Map Object
Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => a
            [value] => 1
        )

    [1] => Ds\Pair Object
        (
            [key] => b
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => c
            [value] => 3
        )

)

Örnek 2 Ds\Map::ksorted() example using a comparator

<?php
$map = new \Ds\Map([1 => "x", 2 => "y", 0 => "z"]);

// Reverse
$sorted = $map->ksorted(function($a, $b) {
    return $b <=> $a;
});

print_r($sorted);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Map Object
Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => 2
            [value] => y
        )

    [1] => Ds\Pair Object
        (
            [key] => 1
            [value] => x
        )

    [2] => Ds\Pair Object
        (
            [key] => 0
            [value] => z
        )

)
Ds\Map::ksort
Ds\Map::last
Map


Returns the last pair of the map.

Ds\Map::ksorted
Ds\Map::map
Map
PHP Manual

Ds\Map::last

(PECL ds >= 1.0.0)

Ds\Map::last — Returns the last pair of the map.

Açıklama

public Ds\Pair Ds\Map::last ( void )

Returns the last pair of the map.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The last pair of the map.

Hatalar/İstisnalar

UnderflowException if empty.

Örnekler

Örnek 1 Ds\Map::last() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);
var_dump($map->last());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(Ds\Pair)#2 (2) {
  ["key"]=>
  string(1) "c"
  ["value"]=>
  int(3)
}
Ds\Map::ksorted
Ds\Map::map
Map


Returns the result of applying a callback to each value.

Ds\Map::last
Ds\Map::merge
Map
PHP Manual

Ds\Map::map

(PECL ds >= 1.0.0)

Ds\Map::map — Returns the result of applying a callback to each value.

Açıklama

public Ds\Map Ds\Map::map ( callable $callback )

Returns the result of applying a callback function to each value of the map.

Değiştirgeler

callback

mixed callback ( mixed $key , mixed $value )

A callable to apply to each value in the map.

The callable should return what the key will be mapped to in the resulting map.

Dönen Değerler

The result of applying a callback to each value in the map.

Bilginize:

The keys and values of the current instance won't be affected.

Örnekler

Örnek 1 Ds\Map::map() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);

print_r($map->map(function($key, $value) { return $value * 2; }));
print_r($map);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

(
    [0] => Ds\Pair Object
        (
            [key] => a
            [value] => 2
        )

    [1] => Ds\Pair Object
        (
            [key] => b
            [value] => 4
        )

    [2] => Ds\Pair Object
        (
            [key] => c
            [value] => 6
        )

)
Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => a
            [value] => 1
        )

    [1] => Ds\Pair Object
        (
            [key] => b
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => c
            [value] => 3
        )

)
Ds\Map::last
Ds\Map::merge
Map


Returns the result of adding all given associations.

Ds\Map::map
Ds\Map::pairs
Map
PHP Manual

Ds\Map::merge

(PECL ds >= 1.0.0)

Ds\Map::merge — Returns the result of adding all given associations.

Açıklama

public Ds\Map Ds\Map::merge ( mixed $values )

Returns the result of associating all keys of a given traversable object or array with their corresponding values, combined with the current instance.

Bilginize:

Values of the current instance will be overwritten by those provided where keys are equal.

Değiştirgeler

values

A traversable object or an array.

Dönen Değerler

The result of associating all keys of a given traversable object or array with their corresponding values, combined with the current instance.

Bilginize:

The current instance won't be affected.

Örnekler

Örnek 1 Ds\Map::merge() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);

print_r($map->merge(["a" => 10, "e" => 50]));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => a
            [value] => 10
        )

    [1] => Ds\Pair Object
        (
            [key] => b
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => c
            [value] => 3
        )

    [3] => Ds\Pair Object
        (
            [key] => e
            [value] => 50
        )

)
Ds\Map::map
Ds\Map::pairs
Map


Returns a sequence containing all the pairs of the map.

Ds\Map::merge
Ds\Map::put
Map
PHP Manual

Ds\Map::pairs

(PECL ds >= 1.0.0)

Ds\Map::pairs — Returns a sequence containing all the pairs of the map.

Açıklama

public Ds\Sequence Ds\Map::pairs ( void )

Returns a Ds\Sequence containing all the pairs of the map.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Ds\Sequence containing all the pairs of the map.

Örnekler

Örnek 1 Ds\Map::pairs() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);

var_dump($map->pairs());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(Ds\Map)#8 (3) {
  [0]=>
  object(Ds\Pair)#5 (2) {
    ["key"]=>
    string(1) "a"
    ["value"]=>
    int(1)
  }
  [1]=>
  object(Ds\Pair)#6 (2) {
    ["key"]=>
    string(1) "b"
    ["value"]=>
    int(2)
  }
  [2]=>
  object(Ds\Pair)#7 (2) {
    ["key"]=>
    string(1) "c"
    ["value"]=>
    int(3)
  }
}
p
Ds\Map::merge
Ds\Map::put
Map


Associates a key with a value.

Ds\Map::pairs
Ds\Map::putAll
Map
PHP Manual

Ds\Map::put

(PECL ds >= 1.0.0)

Ds\Map::put — Associates a key with a value.

Açıklama

public void Ds\Map::put ( mixed $key , mixed $value )

Associates a key with a value, overwriting a previous association if one exists.

Bilginize:

Keys of type object are supported. If an object implements Ds\Hashable, equality will be determined by the object's equals function. If an object does not implement Ds\Hashable, objects must be references to the same instance to be considered equal.

Bilginize:

You can also use array syntax to associate values by key, eg. $map["key"] = $value.

Dikkat

Be careful when using array syntax. Scalar keys will be coerced to integers by the engine. For example, $map["1"] will attempt to access int(1), while $map->get("1") will correctly look up the string key.

See Arrays.

Değiştirgeler

key

The key to associate the value with.

value

The value to be associated with the key.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\Map::put() example

<?php
$map = new \Ds\Map();

$map->put("a", 1);
$map->put("b", 2);
$map->put("c", 3);

print_r($map);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => a
            [value] => 1
        )

    [1] => Ds\Pair Object
        (
            [key] => b
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => c
            [value] => 3
        )

)

Örnek 2 Ds\Map::put() example using objects as keys

<?php
class HashableObject implements \Ds\Hashable
{
    /**
     * An arbitrary value to use as the hash value. Does not define equality.
     */
    private $value;

    public function __construct($value)
    {
        $this->value = $value;
    }

    public function hash()
    {
        return $this->value;
    }

    public function equals($obj): bool
    {
        return $this->value === $obj->value;
    }
}

$map = new \Ds\Map();

$obj = new \ArrayIterator([]);

// Using the same instance multiple times will overwrite the previous value.
$map->put($obj, 1);
$map->put($obj, 2);

// Using multiple instances of the same object will create new associations.
$map->put(new \stdClass(), 3);
$map->put(new \stdClass(), 4);

// Using multiple instances of equal hashable objects will overwrite previous values.
$map->put(new \HashableObject(1), 5);
$map->put(new \HashableObject(1), 6);
$map->put(new \HashableObject(2), 7);
$map->put(new \HashableObject(2), 8);

var_dump($map);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(Ds\Map)#1 (5) {
  [0]=>
  object(Ds\Pair)#7 (2) {
    ["key"]=>
    object(ArrayIterator)#2 (1) {
      ["storage":"ArrayIterator":private]=>
      array(0) {
      }
    }
    ["value"]=>
    int(2)
  }
  [1]=>
  object(Ds\Pair)#8 (2) {
    ["key"]=>
    object(stdClass)#3 (0) {
    }
    ["value"]=>
    int(3)
  }
  [2]=>
  object(Ds\Pair)#9 (2) {
    ["key"]=>
    object(stdClass)#4 (0) {
    }
    ["value"]=>
    int(4)
  }
  [3]=>
  object(Ds\Pair)#10 (2) {
    ["key"]=>
    object(HashableObject)#5 (1) {
      ["value":"HashableObject":private]=>
      int(1)
    }
    ["value"]=>
    int(6)
  }
  [4]=>
  object(Ds\Pair)#11 (2) {
    ["key"]=>
    object(HashableObject)#6 (1) {
      ["value":"HashableObject":private]=>
      int(2)
    }
    ["value"]=>
    int(8)
  }
}
Ds\Map::pairs
Ds\Map::putAll
Map


Associates all key-value pairs of a traversable object or array.

Ds\Map::put
Ds\Map::reduce
Map
PHP Manual

Ds\Map::putAll

(PECL ds >= 1.0.2)

Ds\Map::putAll — Associates all key-value pairs of a traversable object or array.

Açıklama

public void Ds\Map::putAll ( mixed $pairs )

Associates all key-value pairs of a traversable object or array.

Bilginize:

Keys of type object are supported. If an object implements Ds\Hashable, equality will be determined by the object's equals function. If an object does not implement Ds\Hashable, objects must be references to the same instance to be considered equal.

Değiştirgeler

pairs

traversable object or array.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\Map::putAll() example

<?php
$map = new \Ds\Map();

$map->putAll([
    "a" => 1,
    "b" => 2,
    "c" => 3,
]);

print_r($map);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => a
            [value] => 1
        )

    [1] => Ds\Pair Object
        (
            [key] => b
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => c
            [value] => 3
        )

)
Ds\Map::put
Ds\Map::reduce
Map


Reduces the map to a single value using a callback function.

Ds\Map::putAll
Ds\Map::remove
Map
PHP Manual

Ds\Map::reduce

(PECL ds >= 1.0.0)

Ds\Map::reduce — Reduces the map to a single value using a callback function.

Açıklama

public mixed Ds\Map::reduce ( callable $callback [, mixed $initial ] )

Reduces the map to a single value using a callback function.

Değiştirgeler

callback
mixed callback ( mixed $carry , mixed $key , mixed $value )
carry

The return value of the previous callback, or initial if it's the first iteration.

key

The key of the current iteration.

value

The value of the current iteration.

initial

The initial value of the carry value. Can be NULL.

Dönen Değerler

The return value of the final callback.

Örnekler

Örnek 1 Ds\Map::reduce() with initial value example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);

$callback = function($carry, $key, $value) {
    return $carry * $value;
};

var_dump($map->reduce($callback, 5));

// Iterations:
//
// $carry = $initial = 5
//
// $carry = $carry * 1 =  5
// $carry = $carry * 2 = 10
// $carry = $carry * 3 = 30
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(30)

Örnek 2 Ds\Map::reduce() without an initial value example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);

var_dump($map->reduce(function($carry, $key, $value) {
    return $carry + $value + 5;
}));

// Iterations:
//
// $carry = $initial = null
//
// $carry = $carry + 1 + 5 =  6
// $carry = $carry + 2 + 5 = 13
// $carry = $carry + 3 + 5 = 21
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(21)
Ds\Map::putAll
Ds\Map::remove
Map


Removes and returns a value by key.

Ds\Map::reduce
Ds\Map::reverse
Map
PHP Manual

Ds\Map::remove

(PECL ds >= 1.0.0)

Ds\Map::remove — Removes and returns a value by key.

Açıklama

public mixed Ds\Map::remove ( mixed $key [, mixed $default ] )

Removes and returns a value by key, or return an optional default value if the key could not be found.

Bilginize:

Keys of type object are supported. If an object implements Ds\Hashable, equality will be determined by the object's equals function. If an object does not implement Ds\Hashable, objects must be references to the same instance to be considered equal.

Bilginize:

You can also use array syntax to access values by key, eg. $map["key"].

Dikkat

Be careful when using array syntax. Scalar keys will be coerced to integers by the engine. For example, $map["1"] will attempt to access int(1), while $map->get("1") will correctly look up the string key.

See Arrays.

Değiştirgeler

key

The key to remove.

default

The optional default value, returned if the key could not be found.

Dönen Değerler

The value that was removed, or the default value if provided and the key could not be found in the map.

Hatalar/İstisnalar

OutOfBoundsException if the key could not be found and a default value was not provided.

Örnekler

Örnek 1 Ds\Map::remove() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);

var_dump($map->remove("a"));      //  1
var_dump($map->remove("e", 10));  // 10 (default used)
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(1)
int(10)
Ds\Map::reduce
Ds\Map::reverse
Map


Reverses the map in-place.

Ds\Map::remove
Ds\Map::reversed
Map
PHP Manual

Ds\Map::reverse

(PECL ds >= 1.0.0)

Ds\Map::reverse — Reverses the map in-place.

Açıklama

public void Ds\Map::reverse ( void )

Reverses the map in-place.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\Map::reverse() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);
$map->reverse();

print_r($map);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => c
            [value] => 3
        )

    [1] => Ds\Pair Object
        (
            [key] => b
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => a
            [value] => 1
        )

)
Ds\Map::remove
Ds\Map::reversed
Map


Returns a reversed copy.

Ds\Map::reverse
Ds\Map::skip
Map
PHP Manual

Ds\Map::reversed

(PECL ds >= 1.0.0)

Ds\Map::reversed — Returns a reversed copy.

Açıklama

public Ds\Map Ds\Map::reversed ( void )

Returns a reversed copy of the map.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A reversed copy of the map.

Bilginize:

The current instance is not affected.

Örnekler

Örnek 1 Ds\Map::reversed() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);

print_r($map->reversed());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => c
            [value] => 3
        )

    [1] => Ds\Pair Object
        (
            [key] => b
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => a
            [value] => 1
        )

)
Ds\Map::reverse
Ds\Map::skip
Map


Returns the pair at a given positional index.

Ds\Map::reversed
Ds\Map::slice
Map
PHP Manual

Ds\Map::skip

(PECL ds >= 1.0.0)

Ds\Map::skip — Returns the pair at a given positional index.

Açıklama

public Ds\Pair Ds\Map::skip ( int $position )

Returns the pair at a given zero-based position.

Değiştirgeler

position

The zero-based positional index to return.

Dönen Değerler

Returns the Ds\Pair at the given position.

Hatalar/İstisnalar

OutOfRangeException if the position is not valid.

Örnekler

Örnek 1 Ds\Map::skip() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);

var_dump($map->skip(1));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(Ds\Pair)#2 (2) {
  ["key"]=>
  string(1) "b"
  ["value"]=>
  int(2)
}
Ds\Map::reversed
Ds\Map::slice
Map


Returns a subset of the map defined by a starting index and length.

Ds\Map::skip
Ds\Map::sort
Map
PHP Manual

Ds\Map::slice

(PECL ds >= 1.0.0)

Ds\Map::slice — Returns a subset of the map defined by a starting index and length.

Açıklama

public Ds\Map Ds\Map::slice ( int $index [, int $length ] )

Returns a subset of the map defined by a starting index and length.

Değiştirgeler

index

The index at which the range starts.

If positive, the range will start at that index in the map. If negative, the range will start that far from the end.

length

If a length is given and is positive, the resulting map will have up to that many pairs in it. If a length is given and is negative, the range will stop that many pairs from the end. If the length results in an overflow, only pairs up to the end of the map will be included. If a length is not provided, the resulting map will contain all pairs between the index and the end of the map.

Dönen Değerler

A subset of the map defined by a starting index and length.

Örnekler

Örnek 1 Ds\Map::slice() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3, "d" => 4, "e" => 5]);

// Slice from 2 onwards
print_r($map->slice(2)->toArray());

// Slice from 1, for a length of 3
print_r($map->slice(1, 3)->toArray());

// Slice from 1 onwards
print_r($map->slice(1)->toArray());

// Slice from 2 from the end onwards
print_r($map->slice(-2)->toArray());

// Slice from 1 to 1 from the end
print_r($map->slice(1, -1)->toArray());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [c] => 3
    [d] => 4
    [e] => 5
)
Array
(
    [b] => 2
    [c] => 3
    [d] => 4
)
Array
(
    [b] => 2
    [c] => 3
    [d] => 4
    [e] => 5
)
Array
(
    [d] => 4
    [e] => 5
)
Array
(
    [b] => 2
    [c] => 3
    [d] => 4
)
Ds\Map::skip
Ds\Map::sort
Map


Sorts the map in-place by value.

Ds\Map::slice
Ds\Map::sorted
Map
PHP Manual

Ds\Map::sort

(PECL ds >= 1.0.0)

Ds\Map::sort — Sorts the map in-place by value.

Açıklama

public void Ds\Map::sort ([ callable $comparator ] )

Sorts the map in-place by value, using an optional comparator function.

Değiştirgeler

comparator

Karşılaştırma işlevinin, ilk bileşeninin ikinci bileşenden küçük, eşit veya büyük olması durumunda sıfırdan küçük, eşit veya büyük bir tamsayı döndürmesi gerekir.

int callback ( mixed $a, mixed $b )
Dikkat

Returning non-integer values from the comparison function, such as float, will result in an internal cast to integer of the callback's return value. So values such as 0.99 and 0.1 will both be cast to an integer value of 0, which will compare such values as equal.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\Map::sort() example

<?php
$map = new \Ds\Map(["a" => 2, "b" => 3, "c" => 1]);
$map->sort();

print_r($map);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => c
            [value] => 1
        )

    [1] => Ds\Pair Object
        (
            [key] => a
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => b
            [value] => 3
        )

)

Örnek 2 Ds\Map::sort() example using a comparator

<?php
$map = new \Ds\Map(["a" => 2, "b" => 3, "c" => 1]);

$map->sort(function($a, $b) {
    return $b <=> $a;
});

print_r($map);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => b
            [value] => 3
        )

    [1] => Ds\Pair Object
        (
            [key] => a
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => c
            [value] => 1
        )

)
Ds\Map::slice
Ds\Map::sorted
Map


Returns a copy, sorted by value.

Ds\Map::sort
Ds\Map::sum
Map
PHP Manual

Ds\Map::sorted

(PECL ds >= 1.0.0)

Ds\Map::sorted — Returns a copy, sorted by value.

Açıklama

public Ds\Map Ds\Map::sorted ([ callable $comparator ] )

Returns a copy, sorted by value using an optional comparator function.

Değiştirgeler

comparator

Karşılaştırma işlevinin, ilk bileşeninin ikinci bileşenden küçük, eşit veya büyük olması durumunda sıfırdan küçük, eşit veya büyük bir tamsayı döndürmesi gerekir.

int callback ( mixed $a, mixed $b )
Dikkat

Returning non-integer values from the comparison function, such as float, will result in an internal cast to integer of the callback's return value. So values such as 0.99 and 0.1 will both be cast to an integer value of 0, which will compare such values as equal.

Dönen Değerler

Returns a copy of the map, sorted by value.

Örnekler

Örnek 1 Ds\Map::sort() example

<?php
$map = new \Ds\Map(["a" => 2, "b" => 3, "c" => 1]);

print_r($map->sorted());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => c
            [value] => 1
        )

    [1] => Ds\Pair Object
        (
            [key] => a
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => b
            [value] => 3
        )

)

Örnek 2 Ds\Map::sort() example using a comparator

<?php
$map = new \Ds\Map(["a" => 2, "b" => 3, "c" => 1]);

// Reverse
$sorted = $map->sorted(function($a, $b) {
    return $b <=> $a;
});

print_r($sorted);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => b
            [value] => 3
        )

    [1] => Ds\Pair Object
        (
            [key] => a
            [value] => 2
        )

    [2] => Ds\Pair Object
        (
            [key] => c
            [value] => 1
        )

)
Ds\Map::sort
Ds\Map::sum
Map


Returns the sum of all values in the map.

Ds\Map::sorted
Ds\Map::toArray
Map
PHP Manual

Ds\Map::sum

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Ds\Map::sum — Returns the sum of all values in the map.

Açıklama

public number Ds\Map::sum ( void )

Returns the sum of all values in the map.

Bilginize:

Arrays and objects are considered equal to zero when calculating the sum.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The sum of all the values in the map as either a float or int depending on the values in the map.

Örnekler

Örnek 1 Ds\Map::sum() integer example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);
var_dump($map->sum());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(6)

Örnek 2 Ds\Map::sum() float example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2.5, "c" => 3]);
var_dump($map->sum());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

float(6.5)
Ds\Map::sorted
Ds\Map::toArray
Map


Converts the map to an array.

Ds\Map::sum
Ds\Map::union
Map
PHP Manual

Ds\Map::toArray

(PECL ds >= 1.0.0)

Ds\Map::toArray — Converts the map to an array.

Açıklama

public array Ds\Map::toArray ( void )

Converts the map to an array.

Dikkat

Maps where non-scalar keys are can't be converted to an array.

Dikkat

An array will treat all numeric keys as integers, eg. "1" and 1 as keys in the map will only result in 1 being included in the array.

Bilginize:

Casting to an array is not supported yet.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

An array containing all the values in the same order as the map.

Örnekler

Örnek 1 Ds\Map::toArray() example

<?php
$map = new \Ds\Map([
    "a" => 1,
    "b" => 2,
    "c" => 3,
]);

var_dump($map->toArray());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(3) {
  ["a"]=>
  int(1)
  ["b"]=>
  int(2)
  ["c"]=>
  int(3)
}
Ds\Map::sum
Ds\Map::union
Map


Creates a new map using values from the current instance and another map.

Ds\Map::toArray
Ds\Map::values
Map
PHP Manual

Ds\Map::union

(PECL ds >= 1.0.0)

Ds\Map::union — Creates a new map using values from the current instance and another map.

Açıklama

public Ds\Map Ds\Map::union ( Ds\Map $map )

Creates a new map that contains the pairs of the current instance as well as the pairs of another map.

A ? B = {x: x ? A ? x ? B}

Bilginize:

Values of the current instance will be overwritten by those provided where keys are equal.

Değiştirgeler

map

The other map, to combine with the current instance.

Dönen Değerler

A new map containing all the pairs of the current instance as well as another map.

See Also

  • » Union on Wikipedia

Örnekler

Örnek 1 Ds\Map::union() example

<?php
$a = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);
$b = new \Ds\Map(["b" => 3, "c" => 4, "d" => 5]);

print_r($a->union($b));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => a
            [value] => 1
        )

    [1] => Ds\Pair Object
        (
            [key] => b
            [value] => 3
        )

    [2] => Ds\Pair Object
        (
            [key] => c
            [value] => 4
        )

    [3] => Ds\Pair Object
        (
            [key] => d
            [value] => 5
        )

)
Ds\Map::toArray
Ds\Map::values
Map


Returns a sequence of the map's values.

Ds\Map::union
Ds\Map::xor
Map
PHP Manual

Ds\Map::values

(PECL ds >= 1.0.0)

Ds\Map::values — Returns a sequence of the map's values.

Açıklama

public Ds\Sequence Ds\Map::values ( void )

Returns a sequence containing all the values of the map, in the same order.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A Ds\Sequence containing all the values of the map.

Örnekler

Örnek 1 Ds\Map::values() example

<?php
$map = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);
var_dump($map->values());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(Ds\Map)#2 (3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}
Ds\Map::union
Ds\Map::xor
Map


Creates a new map using keys of either the current instance or of another map, but not of both.

Ds\Map::values
Pair
Map
PHP Manual

Ds\Map::xor

(PECL ds >= 1.0.0)

Ds\Map::xor — Creates a new map using keys of either the current instance or of another map, but not of both.

Açıklama

public Ds\Map Ds\Map::xor ( Ds\Map $map )

Creates a new map containing keys of the current instance as well as another map, but not of both.

A ? B = {x : x ? (A \ B) ? (B \ A)}

Değiştirgeler

map

The other map.

Dönen Değerler

A new map containing keys in the current instance as well as another map, but not in both.

See Also

  • » Symmetric Difference on Wikipedia

Örnekler

Örnek 1 Ds\Map::xor() example

<?php
$a = new \Ds\Map(["a" => 1, "b" => 2, "c" => 3]);
$b = new \Ds\Map(["b" => 4, "c" => 5, "d" => 6]);

print_r($a->xor($b));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Map Object
(
    [0] => Ds\Pair Object
        (
            [key] => a
            [value] => 1
        )

    [1] => Ds\Pair Object
        (
            [key] => d
            [value] => 6
        )

)
Ds\Map::values
Pair
Map


The Pair class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

A pair is used by Ds\Map to pair keys with values.

Sınıf Sözdizimi

Ds\Pair implements JsonSerializable {
/* Yöntemler */
public __construct ([ mixed $key [, mixed $value ]] )
}

İçindekiler

  • Ds\Pair::clear — Removes all values.
  • Ds\Pair::__construct — Creates a new instance.
  • Ds\Pair::copy — Returns a shallow copy of the pair.
  • Ds\Pair::isEmpty — Returns whether the pair is empty
  • Ds\Pair::jsonSerialize — Returns a representation that can be converted to JSON.
  • Ds\Pair::toArray — Converts the pair to an array.
Ds\Map::xor
Ds\Pair::clear
Data Structures


Removes all values.

Pair
Ds\Pair::__construct
Pair
PHP Manual

Ds\Pair::clear

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Ds\Pair::clear — Removes all values.

Açıklama

public void Ds\Pair::clear ( void )

Removes all values from the pair.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\Pair::clear() example

<?php
$pair = new \Ds\Pair("a", 1);
print_r($pair);

$pair->clear();
print_r($pair);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Pair Object
(
    [0] => 1
    [1] => 2
    [2] => 3
)
Ds\Pair Object
(
)
Pair
Ds\Pair::__construct
Pair


Creates a new instance.

Ds\Pair::clear
Ds\Pair::copy
Pair
PHP Manual

Ds\Pair::__construct

(PECL ds >= 1.0.0)

Ds\Pair::__construct — Creates a new instance.

Açıklama

public Ds\Pair::__construct ([ mixed $key [, mixed $value ]] )

Creates a new instance using a given key and value.

Değiştirgeler

key

The key.

value

The value.

Ds\Pair::clear
Ds\Pair::copy
Pair


Returns a shallow copy of the pair.

Ds\Pair::__construct
Ds\Pair::isEmpty
Pair
PHP Manual

Ds\Pair::copy

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Ds\Pair::copy — Returns a shallow copy of the pair.

Açıklama

public Ds\Pair Ds\Pair::copy ( void )

Returns a shallow copy of the pair.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a shallow copy of the pair.

Örnekler

Örnek 1 Ds\Pair::copy() example

<?php
$a = new \Ds\Pair("a", 1);
$b = $a->copy();

$a->key = "x";

print_r($a);
print_r($b);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Pair Object
(
    [key] => x
    [value] => 1
)
Ds\Pair Object
(
    [key] => a
    [value] => 1
)
Ds\Pair::__construct
Ds\Pair::isEmpty
Pair


Returns whether the pair is empty

Ds\Pair::copy
Ds\Pair::jsonSerialize
Pair
PHP Manual

Ds\Pair::isEmpty

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Ds\Pair::isEmpty — Returns whether the pair is empty

Açıklama

public bool Ds\Pair::isEmpty ( void )

Returns whether the pair is empty.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the pair is empty, FALSE otherwise.

Örnekler

Örnek 1 Ds\Pair::isEmpty() example

<?php
$a = new \Ds\Pair("a", 1);
$b = new \Ds\Pair();

var_dump($a->isEmpty());
var_dump($b->isEmpty());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(false)
bool(true)
Ds\Pair::copy
Ds\Pair::jsonSerialize
Pair


Returns a representation that can be converted to JSON.

Ds\Pair::isEmpty
Ds\Pair::toArray
Pair
PHP Manual

Ds\Pair::jsonSerialize

(PECL ds >= 1.0.0)

Ds\Pair::jsonSerialize — Returns a representation that can be converted to JSON.

See JsonSerializable::jsonSerialize()

Bilginize:

You should never need to call this directly.

Ds\Pair::isEmpty
Ds\Pair::toArray
Pair


Converts the pair to an array.

Ds\Pair::jsonSerialize
Set
Pair
PHP Manual

Ds\Pair::toArray

(PECL ds >= 1.0.0)

Ds\Pair::toArray — Converts the pair to an array.

Açıklama

public array Ds\Pair::toArray ( void )

Converts the pair to an array.

Bilginize:

Casting to an array is not supported yet.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

An array containing all the values in the same order as the pair.

Örnekler

Örnek 1 Ds\Pair::toArray() example

<?php
$pair = new \Ds\Pair("a", 1);

var_dump($pair->toArray());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(2) {
  ["key"]=>
  string(1) "a"
  ["value"]=>
  int(1)
}
Ds\Pair::jsonSerialize
Set
Pair


The Set class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

A Set is a sequence of unique values. This implementation uses the same hash table as Ds\Map, where values are used as keys and the mapped value is ignored.

Strengths

  • Values can be any type, including objects.
  • Supports array syntax (square brackets).
  • Insertion order is preserved.
  • Automatically frees allocated memory when its size drops low enough.
  • add(),
remove() and
contains() are all O(1).

Weaknesses

  • Doesn't support
                push(),
                pop(),
                insert(),
                shift(), or
                unshift().
  • get() is O(n) if there are deleted values in the buffer before the accessed index, O(1) otherwise.

Sınıf Sözdizimi

Ds\Set implements Ds\Collection {
/* Constants */
const int MIN_CAPACITY = 16 ;
/* Yöntemler */
public void add ([ mixed $...values ] )
public void allocate ( int $capacity )
public int capacity ( void )
public void clear ( void )
public bool contains ([ mixed $...values ] )
public Ds\Set copy ( void )
public Ds\Set diff ( Ds\Set $set )
public Ds\Set filter ([ callable $callback ] )
public void first ( void )
public mixed get ( int $index )
public Ds\Set intersect ( Ds\Set $set )
public bool isEmpty ( void )
public string join ([ string $glue ] )
public void last ( void )
public Ds\Set merge ( mixed $values )
public mixed reduce ( callable $callback [, mixed $initial ] )
public void remove ([ mixed $...values ] )
public void reverse ( void )
public Ds\Set reversed ( void )
public Ds\Set slice ( int $index [, int $length ] )
public void sort ([ callable $comparator ] )
public Ds\Set sorted ([ callable $comparator ] )
public number sum ( void )
public array toArray ( void )
public Ds\Set union ( Ds\Set $set )
public Ds\Set xor ( Ds\Set $set )
}

Öntanımlı Sabitler

Ds\Set::MIN_CAPACITY

İçindekiler

  • Ds\Set::add — Adds values to the set.
  • Ds\Set::allocate — Allocates enough memory for a required capacity.
  • Ds\Set::capacity — Returns the current capacity.
  • Ds\Set::clear — Removes all values.
  • Ds\Set::__construct — Creates a new instance.
  • Ds\Set::contains — Determines if the set contains all values.
  • Ds\Set::copy — Returns a shallow copy of the set.
  • Ds\Set::count — Returns the number of values in the set.
  • Ds\Set::diff — Creates a new set using values that aren't in another set.
  • Ds\Set::filter — Creates a new set using a callable to determine which values to include.
  • Ds\Set::first — Returns the first value in the set.
  • Ds\Set::get — Returns the value at a given index.
  • Ds\Set::intersect — Creates a new set by intersecting values with another set.
  • Ds\Set::isEmpty — Returns whether the set is empty
  • Ds\Set::join — Joins all values together as a string.
  • Ds\Set::jsonSerialize — Returns a representation that can be converted to JSON.
  • Ds\Set::last — Returns the last value in the set.
  • Ds\Set::merge — Returns the result of adding all given values to the set.
  • Ds\Set::reduce — Reduces the set to a single value using a callback function.
  • Ds\Set::remove — Removes all given values from the set.
  • Ds\Set::reverse — Reverses the set in-place.
  • Ds\Set::reversed — Returns a reversed copy.
  • Ds\Set::slice — Returns a sub-set of a given range.
  • Ds\Set::sort — Sorts the set in-place.
  • Ds\Set::sorted — Returns a sorted copy.
  • Ds\Set::sum — Returns the sum of all values in the set.
  • Ds\Set::toArray — Converts the set to an array.
  • Ds\Set::union — Creates a new set using values from the current instance and another set.
  • Ds\Set::xor — Creates a new set using values in either the current instance or in another set, but not in both.
Ds\Pair::toArray
Ds\Set::add
Data Structures


Adds values to the set.

Set
Ds\Set::allocate
Set
PHP Manual

Ds\Set::add

(PECL ds >= 1.0.0)

Ds\Set::add — Adds values to the set.

Açıklama

public void Ds\Set::add ([ mixed $...values ] )

Adds all given values to the set that haven't already been added.

Bilginize:

Values of type object are supported. If an object implements Ds\Hashable, equality will be determined by the object's equals function. If an object does not implement Ds\Hashable, objects must be references to the same instance to be considered equal.

Dikkat

All comparisons are strict (type and value).

Değiştirgeler

values

Values to add to the set.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\Set::add() example using integers

<?php
$set = new \Ds\Set();

$set->add(1);
$set->add(1);
$set->add(2);
$set->add(3);

// Strict comparison would not treat these the same as int(1)
$set->add("1");
$set->add(true);

var_dump($set);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(Ds\Set)#1 (5) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
  [3]=>
  string(1) "1"
  [4]=>
  bool(true)
}

Örnek 2 Ds\Set::add() example using objects

<?php
class HashableObject implements \Ds\Hashable
{
    /**
     * An arbitrary value to use as the hash value. Does not define equality.
     */
    private $value;

    public function __construct($value)
    {
        $this->value = $value;
    }

    public function hash()
    {
        return $this->value;
    }

    public function equals($obj): bool
    {
        return $this->value === $obj->value;
    }
}

$set = new \Ds\Set();

$obj = new \ArrayIterator([]);

// Adding the same instance multiple times will only add the first.
$set->add($obj);
$set->add($obj);

// Adding multiple instances of the same object will add them all.
$set->add(new \stdClass());
$set->add(new \stdClass());

// Adding multiple instances of equal hashable objects will only add the first.
$set->add(new \HashableObject(1));
$set->add(new \HashableObject(1));
$set->add(new \HashableObject(2));
$set->add(new \HashableObject(2));

var_dump($set);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(Ds\Set)#1 (5) {
  [0]=>
  object(ArrayIterator)#2 (1) {
    ["storage":"ArrayIterator":private]=>
    array(0) {
    }
  }
  [1]=>
  object(stdClass)#3 (0) {
  }
  [2]=>
  object(stdClass)#4 (0) {
  }
  [3]=>
  object(HashableObject)#5 (1) {
    ["value":"HashableObject":private]=>
    int(1)
  }
  [4]=>
  object(HashableObject)#6 (1) {
    ["value":"HashableObject":private]=>
    int(2)
  }
}
Set
Ds\Set::allocate
Set


Allocates enough memory for a required capacity.

Ds\Set::add
Ds\Set::capacity
Set
PHP Manual

Ds\Set::allocate

(PECL ds >= 1.0.0)

Ds\Set::allocate — Allocates enough memory for a required capacity.

Açıklama

public void Ds\Set::allocate ( int $capacity )

Allocates enough memory for a required capacity.

Değiştirgeler

capacity

The number of values for which capacity should be allocated.

Bilginize:

Capacity will stay the same if this value is less than or equal to the current capacity.

Bilginize:

Capacity will always be rounded up to the nearest power of 2.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\Set::allocate() example

<?php
$set = new \Ds\Set();
var_dump($set->capacity());

$set->allocate(100);
var_dump($set->capacity());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(16)
int(128)
Ds\Set::add
Ds\Set::capacity
Set


Returns the current capacity.

Ds\Set::allocate
Ds\Set::clear
Set
PHP Manual

Ds\Set::capacity

(PECL ds >= 1.0.0)

Ds\Set::capacity — Returns the current capacity.

Açıklama

public int Ds\Set::capacity ( void )

Returns the current capacity.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current capacity.

Örnekler

Örnek 1 Ds\Set::capacity() example

<?php
$set = new \Ds\Set();
var_dump($set->capacity());

$set->push(...range(1, 50));
var_dump($set->capacity());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(16)
int(64)
Ds\Set::allocate
Ds\Set::clear
Set


Removes all values.

Ds\Set::capacity
Ds\Set::__construct
Set
PHP Manual

Ds\Set::clear

(PECL ds >= 1.0.0)

Ds\Set::clear — Removes all values.

Açıklama

public void Ds\Set::clear ( void )

Removes all values from the set.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\Set::clear() example

<?php
$set = new \Ds\Set([1, 2, 3]);
print_r($set);

$set->clear();
print_r($set);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Set Object
(
    [0] => 1
    [1] => 2
    [2] => 3
)
Ds\Set Object
(
)
Ds\Set::capacity
Ds\Set::__construct
Set


Creates a new instance.

Ds\Set::clear
Ds\Set::contains
Set
PHP Manual

Ds\Set::__construct

(PECL ds >= 1.0.0)

Ds\Set::__construct — Creates a new instance.

Açıklama

public Ds\Set::__construct ([ mixed $...values ] )

Creates a new instance, using either a traversable object or an array for the initial values.

Değiştirgeler

values

A traversable object or an array to use for the initial values.

Örnekler

Örnek 1 Ds\Set::__construct() example

<?php
$set = new \Ds\Set();
var_dump($set);

$set = new \Ds\Set([1, 2, 3]);
var_dump($set);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(Ds\Set)#1 (0) {
}
object(Ds\Set)#2 (3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}
Ds\Set::clear
Ds\Set::contains
Set


Determines if the set contains all values.

Ds\Set::__construct
Ds\Set::copy
Set
PHP Manual

Ds\Set::contains

(PECL ds >= 1.0.0)

Ds\Set::contains — Determines if the set contains all values.

Açıklama

public bool Ds\Set::contains ([ mixed $...values ] )

Determines if the set contains all values.

Bilginize:

Values of type object are supported. If an object implements Ds\Hashable, equality will be determined by the object's equals function. If an object does not implement Ds\Hashable, objects must be references to the same instance to be considered equal.

Dikkat

All comparisons are strict (type and value).

Değiştirgeler

values

Values to check.

Dönen Değerler

FALSE if any of the provided values are not in the set, TRUE otherwise.

Örnekler

Örnek 1 Ds\Set::contains() example

<?php
$set = new \Ds\Set([1, 2, 3]);

var_dump($set->contains(1));                // true
var_dump($set->contains(1, 2));             // true
var_dump($set->contains(...[1, 2]));        // true

var_dump($set->contains("1"));              // false
var_dump($set->contains(...[1, 2, 3, 4]));  // false

var_dump($set->contains(...[]));            // true
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(true)
bool(true)
bool(true)
bool(false)
bool(false)
bool(true)
Ds\Set::__construct
Ds\Set::copy
Set


Returns a shallow copy of the set.

Ds\Set::contains
Ds\Set::count
Set
PHP Manual

Ds\Set::copy

(PECL ds >= 1.0.0)

Ds\Set::copy — Returns a shallow copy of the set.

Açıklama

public Ds\Set Ds\Set::copy ( void )

Returns a shallow copy of the set.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a shallow copy of the set.

Örnekler

Örnek 1 Ds\Set::copy() example

<?php
$a = new \Ds\Set([1, 2, 3]);
$b = $a->copy();

// Updating the copy doesn't affect the original
$b->add(4);

print_r($a);
print_r($b);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Set Object
(
    [0] => 1
    [1] => 2
    [2] => 3
)
Ds\Set Object
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
)
Ds\Set::contains
Ds\Set::count
Set


Returns the number of values in the set.

Ds\Set::copy
Ds\Set::diff
Set
PHP Manual

Ds\Set::count

(PECL ds >= 1.0.0)

Ds\Set::count — Returns the number of values in the set.

See Countable::count()

Ds\Set::copy
Ds\Set::diff
Set


Creates a new set using values that aren't in another set.

Ds\Set::count
Ds\Set::filter
Set
PHP Manual

Ds\Set::diff

(PECL ds >= 1.0.0)

Ds\Set::diff — Creates a new set using values that aren't in another set.

Açıklama

public Ds\Set Ds\Set::diff ( Ds\Set $set )

Creates a new set using values that aren't in another set.

A \ B = {x ? A | x ? B}

Değiştirgeler

set

Set containing the values to exclude.

Dönen Değerler

A new set containing all values that were not in the other set.

See Also

  • » Compliment on Wikipedia

Örnekler

Örnek 1 Ds\Set::diff() example

<?php
$a = new \Ds\Set([1, 2, 3]);
$b = new \Ds\Set([3, 4, 5]);

var_dump($a->diff($b));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(Ds\Set)#3 (2) {
  [0]=>
  int(1)
  [1]=>
  int(2)
}
Ds\Set::count
Ds\Set::filter
Set


Creates a new set using a callable to determine which values to include.

Ds\Set::diff
Ds\Set::first
Set
PHP Manual

Ds\Set::filter

(PECL ds >= 1.0.0)

Ds\Set::filter — Creates a new set using a callable to determine which values to include.

Açıklama

public Ds\Set Ds\Set::filter ([ callable $callback ] )

Creates a new set using a callable to determine which values to include.

Değiştirgeler

callback

bool callback ( mixed $value )

Optional callable which returns TRUE if the value should be included, FALSE otherwise.

If a callback is not provided, only values which are TRUE (see converting to boolean) will be included.

Dönen Değerler

A new set containing all the values for which either the callback returned TRUE, or all values that convert to TRUE if a callback was not provided.

Örnekler

Örnek 1 Ds\Set::filter() example using callback function

<?php
$set = new \Ds\Set([1, 2, 3, 4, 5]);

var_dump($set->filter(function($value) {
    return $value % 2 == 0;
}));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(Ds\Set)#3 (2) {
  [0]=>
  int(2)
  [1]=>
  int(4)
}

Örnek 2 Ds\Set::filter() example without a callback function

<?php
$set = new \Ds\Set([0, 1, 'a', true, false]);

var_dump($set->filter());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(Ds\Set)#2 (3) {
  [0]=>
  int(1)
  [1]=>
  string(1) "a"
  [2]=>
  bool(true)
}
Ds\Set::diff
Ds\Set::first
Set


Returns the first value in the set.

Ds\Set::filter
Ds\Set::get
Set
PHP Manual

Ds\Set::first

(PECL ds >= 1.0.0)

Ds\Set::first — Returns the first value in the set.

Açıklama

public void Ds\Set::first ( void )

Returns the first value in the set.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The first value in the set.

Hatalar/İstisnalar

UnderflowException if empty.

Örnekler

Örnek 1 Ds\Set::first() example

<?php
$set = new \Ds\Set([1, 2, 3]);
var_dump($set->first());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(1)
Ds\Set::filter
Ds\Set::get
Set


Returns the value at a given index.

Ds\Set::first
Ds\Set::intersect
Set
PHP Manual

Ds\Set::get

(PECL ds >= 1.0.0)

Ds\Set::get — Returns the value at a given index.

Açıklama

public mixed Ds\Set::get ( int $index )

Returns the value at a given index.

Değiştirgeler

index

The index to access, starting at 0.

Dönen Değerler

The value at the requested index.

Hatalar/İstisnalar

OutOfRangeException if the index is not valid.

Örnekler

Örnek 1 Ds\Set::get() example

<?php
$set = new \Ds\Set(["a", "b", "c"]);

var_dump($set->get(0));
var_dump($set->get(1));
var_dump($set->get(2));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(1) "a"
string(1) "b"
string(1) "c"

Örnek 2 Ds\Set::get() example using array syntax

<?php
$set = new \Ds\Set(["a", "b", "c"]);

var_dump($set[0]);
var_dump($set[1]);
var_dump($set[2]);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(1) "a"
string(1) "b"
string(1) "c"
Ds\Set::first
Ds\Set::intersect
Set


Creates a new set by intersecting values with another set.

Ds\Set::get
Ds\Set::isEmpty
Set
PHP Manual

Ds\Set::intersect

(PECL ds >= 1.0.0)

Ds\Set::intersect — Creates a new set by intersecting values with another set.

Açıklama

public Ds\Set Ds\Set::intersect ( Ds\Set $set )

Creates a new set using values common to both the current instance and another set. In other words, returns a copy of the current instance with all values removed that are not in the other set.

A ? B = {x : x ? A ? x ? B}

Değiştirgeler

set

The other set.

Dönen Değerler

The intersection of the current instance and another set.

See Also

  • » Intersection on Wikipedia

Örnekler

Örnek 1 Ds\Set::intersect() example

<?php
$a = new \Ds\Set([1, 2, 3]);
$b = new \Ds\Set([3, 4, 5]);

var_dump($a->intersect($b));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(Ds\Set)#3 (1) {
  [0]=>
  int(3)
}
Ds\Set::get
Ds\Set::isEmpty
Set


Returns whether the set is empty

Ds\Set::intersect
Ds\Set::join
Set
PHP Manual

Ds\Set::isEmpty

(PECL ds >= 1.0.0)

Ds\Set::isEmpty — Returns whether the set is empty

Açıklama

public bool Ds\Set::isEmpty ( void )

Returns whether the set is empty.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the set is empty, FALSE otherwise.

Örnekler

Örnek 1 Ds\Set::isEmpty() example

<?php
$a = new \Ds\Set([1, 2, 3]);
$b = new \Ds\Set();

var_dump($a->isEmpty());
var_dump($b->isEmpty());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(false)
bool(true)
Ds\Set::intersect
Ds\Set::join
Set


Joins all values together as a string.

Ds\Set::isEmpty
Ds\Set::jsonSerialize
Set
PHP Manual

Ds\Set::join

(PECL ds >= 1.0.0)

Ds\Set::join — Joins all values together as a string.

Açıklama

public string Ds\Set::join ([ string $glue ] )

Joins all values together as a string using an optional separator between each value.

Değiştirgeler

glue

An optional string to separate each value.

Dönen Değerler

All values of the set joined together as a string.

Örnekler

Örnek 1 Ds\Set::join() example using a separator string

<?php
$set = new \Ds\Set(["a", "b", "c", 1, 2, 3]);

var_dump($set->join("|"));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(11) "a|b|c|1|2|3"

Örnek 2 Ds\Set::join() example without a separator string

<?php
$set = new \Ds\Set(["a", "b", "c", 1, 2, 3]);

var_dump($set->join());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(11) "abc123"
Ds\Set::isEmpty
Ds\Set::jsonSerialize
Set


Returns a representation that can be converted to JSON.

Ds\Set::join
Ds\Set::last
Set
PHP Manual

Ds\Set::jsonSerialize

(PECL ds >= 1.0.0)

Ds\Set::jsonSerialize — Returns a representation that can be converted to JSON.

See JsonSerializable::jsonSerialize()

Bilginize:

You should never need to call this directly.

Ds\Set::join
Ds\Set::last
Set


Returns the last value in the set.

Ds\Set::jsonSerialize
Ds\Set::merge
Set
PHP Manual

Ds\Set::last

(PECL ds >= 1.0.0)

Ds\Set::last — Returns the last value in the set.

Açıklama

public void Ds\Set::last ( void )

Returns the last value in the set.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The last value in the set.

Hatalar/İstisnalar

UnderflowException if empty.

Örnekler

Örnek 1 Ds\Set::last() example

<?php
$set = new \Ds\Set([1, 2, 3]);
var_dump($set->last());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(3)
Ds\Set::jsonSerialize
Ds\Set::merge
Set


Returns the result of adding all given values to the set.

Ds\Set::last
Ds\Set::reduce
Set
PHP Manual

Ds\Set::merge

(PECL ds >= 1.0.3)

Ds\Set::merge — Returns the result of adding all given values to the set.

Açıklama

public Ds\Set Ds\Set::merge ( mixed $values )

Returns the result of adding all given values to the set.

Değiştirgeler

values

A traversable object or an array.

Dönen Değerler

The result of adding all given values to the set, effectively the same as adding the values to a copy, then returning that copy.

Bilginize:

The current instance won't be affected.

Örnekler

Örnek 1 Ds\Set::merge() example

<?php
$set = new \Ds\Set([1, 2, 3]);

var_dump($set->merge([3, 4, 5]));
var_dump($set);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(Ds\Set)#2 (6) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
  [3]=>
  int(4)
  [4]=>
  int(5)
}
object(Ds\Set)#1 (3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}
Ds\Set::last
Ds\Set::reduce
Set


Reduces the set to a single value using a callback function.

Ds\Set::merge
Ds\Set::remove
Set
PHP Manual

Ds\Set::reduce

(PECL ds >= 1.0.0)

Ds\Set::reduce — Reduces the set to a single value using a callback function.

Açıklama

public mixed Ds\Set::reduce ( callable $callback [, mixed $initial ] )

Reduces the set to a single value using a callback function.

Değiştirgeler

callback
mixed callback ( mixed $carry , mixed $value )
carry

The return value of the previous callback, or initial if it's the first iteration.

value

The value of the current iteration.

initial

The initial value of the carry value. Can be NULL.

Dönen Değerler

The return value of the final callback.

Örnekler

Örnek 1 Ds\Set::reduce() with initial value example

<?php
$set = new \Ds\Set([1, 2, 3]);

$callback = function($carry, $value) {
    return $carry * $value;
};

var_dump($set->reduce($callback, 5));

// Iterations:
//
// $carry = $initial = 5
//
// $carry = $carry * 1 =  5
// $carry = $carry * 2 = 10
// $carry = $carry * 3 = 30
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(30)

Örnek 2 Ds\Set::reduce() without an initial value example

<?php
$set = new \Ds\Set([1, 2, 3]);

var_dump($set->reduce(function($carry, $value) {
    return $carry + $value + 5;
}));

// Iterations:
//
// $carry = $initial = null
//
// $carry = $carry + 1 + 5 =  6
// $carry = $carry + 2 + 5 = 13
// $carry = $carry + 3 + 5 = 21
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(21)
Ds\Set::merge
Ds\Set::remove
Set


Removes all given values from the set.

Ds\Set::reduce
Ds\Set::reverse
Set
PHP Manual

Ds\Set::remove

(PECL ds >= 1.0.0)

Ds\Set::remove — Removes all given values from the set.

Açıklama

public void Ds\Set::remove ([ mixed $...values ] )

Removes all given values from the set, ignoring any that are not in the set.

Değiştirgeler

values

The values to remove.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\Set::remove() example

<?php
$set = new \Ds\Set([1, 2, 3, 4, 5]);

$set->remove(1);            // Remove 1
$set->remove(1, 2);         // Can't find 1, but remove 2
$set->remove(...[3, 4]);    // Remove 3 and 4

var_dump($set);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(Ds\Set)#1 (1) {
  [0]=>
  int(5)
}
Ds\Set::reduce
Ds\Set::reverse
Set


Reverses the set in-place.

Ds\Set::remove
Ds\Set::reversed
Set
PHP Manual

Ds\Set::reverse

(PECL ds >= 1.0.0)

Ds\Set::reverse — Reverses the set in-place.

Açıklama

public void Ds\Set::reverse ( void )

Reverses the set in-place.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\Set::reverse() example

<?php
$set = new \Ds\Set(["a", "b", "c"]);
$set->reverse();

print_r($set);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Set Object
(
    [0] => c
    [1] => b
    [2] => a
)
Ds\Set::remove
Ds\Set::reversed
Set


Returns a reversed copy.

Ds\Set::reverse
Ds\Set::slice
Set
PHP Manual

Ds\Set::reversed

(PECL ds >= 1.0.0)

Ds\Set::reversed — Returns a reversed copy.

Açıklama

public Ds\Set Ds\Set::reversed ( void )

Returns a reversed copy of the set.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A reversed copy of the set.

Bilginize:

The current instance is not affected.

Örnekler

Örnek 1 Ds\Set::reversed() example

<?php
$set = new \Ds\Set(["a", "b", "c"]);

print_r($set->reversed());
print_r($set);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Set Object
(
    [0] => c
    [1] => b
    [2] => a
)
Ds\Set Object
(
    [0] => a
    [1] => b
    [2] => c
)
Ds\Set::reverse
Ds\Set::slice
Set


Returns a sub-set of a given range.

Ds\Set::reversed
Ds\Set::sort
Set
PHP Manual

Ds\Set::slice

(PECL ds >= 1.0.0)

Ds\Set::slice — Returns a sub-set of a given range.

Açıklama

public Ds\Set Ds\Set::slice ( int $index [, int $length ] )

Creates a sub-set of a given range.

Değiştirgeler

index

The index at which the sub-set starts.

If positive, the set will start at that index in the set. If negative, the set will start that far from the end.

length

If a length is given and is positive, the resulting set will have up to that many values in it. If the length results in an overflow, only values up to the end of the set will be included. If a length is given and is negative, the set will stop that many values from the end. If a length is not provided, the resulting set will contain all values between the index and the end of the set.

Dönen Değerler

A sub-set of the given range.

Örnekler

Örnek 1 Ds\Set::slice() example

<?php
$set = new \Ds\Set(["a", "b", "c", "d", "e"]);

// Slice from 2 onwards
print_r($set->slice(2));

// Slice from 1, for a length of 3
print_r($set->slice(1, 3));

// Slice from 1 onwards
print_r($set->slice(1));

// Slice from 2 from the end onwards
print_r($set->slice(-2));

// Slice from 1 to 1 from the end
print_r($set->slice(1, -1));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Set Object
(
    [0] => c
    [1] => d
    [2] => e
)
Ds\Set Object
(
    [0] => b
    [1] => c
    [2] => d
)
Ds\Set Object
(
    [0] => b
    [1] => c
    [2] => d
    [3] => e
)
Ds\Set Object
(
    [0] => d
    [1] => e
)
Ds\Set Object
(
    [0] => b
    [1] => c
    [2] => d
)
Ds\Set::reversed
Ds\Set::sort
Set


Sorts the set in-place.

Ds\Set::slice
Ds\Set::sorted
Set
PHP Manual

Ds\Set::sort

(PECL ds >= 1.0.0)

Ds\Set::sort — Sorts the set in-place.

Açıklama

public void Ds\Set::sort ([ callable $comparator ] )

Sorts the set in-place, using an optional comparator function.

Değiştirgeler

comparator

Karşılaştırma işlevinin, ilk bileşeninin ikinci bileşenden küçük, eşit veya büyük olması durumunda sıfırdan küçük, eşit veya büyük bir tamsayı döndürmesi gerekir.

int callback ( mixed $a, mixed $b )
Dikkat

Returning non-integer values from the comparison function, such as float, will result in an internal cast to integer of the callback's return value. So values such as 0.99 and 0.1 will both be cast to an integer value of 0, which will compare such values as equal.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\Set::sort() example

<?php
$set = new \Ds\Set([4, 5, 1, 3, 2]);
$set->sort();

print_r($set);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Set Object
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
    [4] => 5
)

Örnek 2 Ds\Set::sort() example using a comparator

<?php
$set = new \Ds\Set([4, 5, 1, 3, 2]);

$set->sort(function($a, $b) {
    return $b <=> $a;
});

print_r($set);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Set Object
(
    [0] => 5
    [1] => 4
    [2] => 3
    [3] => 2
    [4] => 1
)
Ds\Set::slice
Ds\Set::sorted
Set


Returns a sorted copy.

Ds\Set::sort
Ds\Set::sum
Set
PHP Manual

Ds\Set::sorted

(PECL ds >= 1.0.0)

Ds\Set::sorted — Returns a sorted copy.

Açıklama

public Ds\Set Ds\Set::sorted ([ callable $comparator ] )

Returns a sorted copy, using an optional comparator function.

Değiştirgeler

comparator

Karşılaştırma işlevinin, ilk bileşeninin ikinci bileşenden küçük, eşit veya büyük olması durumunda sıfırdan küçük, eşit veya büyük bir tamsayı döndürmesi gerekir.

int callback ( mixed $a, mixed $b )
Dikkat

Returning non-integer values from the comparison function, such as float, will result in an internal cast to integer of the callback's return value. So values such as 0.99 and 0.1 will both be cast to an integer value of 0, which will compare such values as equal.

Dönen Değerler

Returns a sorted copy of the set.

Örnekler

Örnek 1 Ds\Set::sorted() example

<?php
$set = new \Ds\Set([4, 5, 1, 3, 2]);

print_r($set->sorted());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Set Object
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
    [4] => 5
)

Örnek 2 Ds\Set::sorted() example using a comparator

<?php
$set = new \Ds\Set([4, 5, 1, 3, 2]);

$sorted = $set->sorted(function($a, $b) {
    return $b <=> $a;
});

print_r($sorted);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Set Object
(
    [0] => 5
    [1] => 4
    [2] => 3
    [3] => 2
    [4] => 1
)
Ds\Set::sort
Ds\Set::sum
Set


Returns the sum of all values in the set.

Ds\Set::sorted
Ds\Set::toArray
Set
PHP Manual

Ds\Set::sum

(PECL ds >= 1.0.0)

Ds\Set::sum — Returns the sum of all values in the set.

Açıklama

public number Ds\Set::sum ( void )

Returns the sum of all values in the set.

Bilginize:

Arrays and objects are considered equal to zero when calculating the sum.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The sum of all the values in the set as either a float or int depending on the values in the set.

Örnekler

Örnek 1 Ds\Set::sum() integer example

<?php
$set = new \Ds\Set([1, 2, 3]);
var_dump($set->sum());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(6)

Örnek 2 Ds\Set::sum() float example

<?php
$set = new \Ds\Set([1, 2.5, 3]);
var_dump($set->sum());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

float(6.5)
Ds\Set::sorted
Ds\Set::toArray
Set


Converts the set to an array.

Ds\Set::sum
Ds\Set::union
Set
PHP Manual

Ds\Set::toArray

(PECL ds >= 1.0.0)

Ds\Set::toArray — Converts the set to an array.

Açıklama

public array Ds\Set::toArray ( void )

Converts the set to an array.

Bilginize:

Casting to an array is not supported yet.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

An array containing all the values in the same order as the set.

Örnekler

Örnek 1 Ds\Set::toArray() example

<?php
$set = new \Ds\Set([1, 2, 3]);

var_dump($set->toArray());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}
Ds\Set::sum
Ds\Set::union
Set


Creates a new set using values from the current instance and another set.

Ds\Set::toArray
Ds\Set::xor
Set
PHP Manual

Ds\Set::union

(PECL ds >= 1.0.0)

Ds\Set::union — Creates a new set using values from the current instance and another set.

Açıklama

public Ds\Set Ds\Set::union ( Ds\Set $set )

Creates a new set that contains the values of the current instance as well as the values of another set.

A ? B = {x: x ? A ? x ? B}

Değiştirgeler

set

The other set, to combine with the current instance.

Dönen Değerler

A new set containing all the values of the current instance as well as another set.

See Also

  • » Union on Wikipedia

Örnekler

Örnek 1 Ds\Set::union() example

<?php
$a = new \Ds\Set([1, 2, 3]);
$b = new \Ds\Set([3, 4, 5]);

var_dump($a->union($b));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(Ds\Set)#3 (5) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
  [3]=>
  int(4)
  [4]=>
  int(5)
}
Ds\Set::toArray
Ds\Set::xor
Set


Creates a new set using values in either the current instance or in another set, but not in both.

Ds\Set::union
Stack
Set
PHP Manual

Ds\Set::xor

(PECL ds >= 1.0.0)

Ds\Set::xor — Creates a new set using values in either the current instance or in another set, but not in both.

Açıklama

public Ds\Set Ds\Set::xor ( Ds\Set $set )

Creates a new set containing values in the current instance as well as another set, but not in both.

A ? B = {x : x ? (A \ B) ? (B \ A)}

Değiştirgeler

set

The other set.

Dönen Değerler

A new set containing values in the current instance as well as another set, but not in both.

See Also

  • » Symmetric Difference on Wikipedia

Örnekler

Örnek 1 Ds\Set::xor() example

<?php
$a = new \Ds\Set([1, 2, 3]);
$b = new \Ds\Set([3, 4, 5]);

var_dump($a->xor($b));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(Ds\Set)#3 (4) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(4)
  [3]=>
  int(5)
}
Ds\Set::union
Stack
Set


The Stack class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

A Stack is a "last in, first out" or "LIFO" collection that only allows access to the value at the top of the structure and iterates in that order, destructively.

Uses a Ds\Vector internally.

Sınıf Sözdizimi

Ds\Stack implements Ds\Collection {
/* Yöntemler */
public void allocate ( int $capacity )
public int capacity ( void )
public void clear ( void )
public Ds\Stack copy ( void )
public bool isEmpty ( void )
public mixed peek ( void )
public mixed pop ( void )
public void push ([ mixed $...values ] )
public array toArray ( void )
}

İçindekiler

  • Ds\Stack::allocate — Allocates enough memory for a required capacity.
  • Ds\Stack::capacity — Returns the current capacity.
  • Ds\Stack::clear — Removes all values.
  • Ds\Stack::__construct — Creates a new instance.
  • Ds\Stack::copy — Returns a shallow copy of the stack.
  • Ds\Stack::count — Returns the number of values in the stack.
  • Ds\Stack::isEmpty — Returns whether the stack is empty
  • Ds\Stack::jsonSerialize — Returns a representation that can be converted to JSON.
  • Ds\Stack::peek — Returns the value at the top of the stack.
  • Ds\Stack::pop — Removes and returns the value at the top of the stack.
  • Ds\Stack::push — Pushes values onto the stack.
  • Ds\Stack::toArray — Converts the stack to an array.
Ds\Set::xor
Ds\Stack::allocate
Data Structures


Allocates enough memory for a required capacity.

Stack
Ds\Stack::capacity
Stack
PHP Manual

Ds\Stack::allocate

(PECL ds >= 1.0.0)

Ds\Stack::allocate — Allocates enough memory for a required capacity.

Açıklama

public void Ds\Stack::allocate ( int $capacity )

Ensures that enough memory is allocated for a required capacity. This removes the need to reallocate the internal as values are added.

Değiştirgeler

capacity

The number of values for which capacity should be allocated.

Bilginize:

Capacity will stay the same if this value is less than or equal to the current capacity.

Dönen Değerler

Hiçbir değer dönmez.

Stack
Ds\Stack::capacity
Stack


Returns the current capacity.

Ds\Stack::allocate
Ds\Stack::clear
Stack
PHP Manual

Ds\Stack::capacity

(PECL ds >= 1.0.0)

Ds\Stack::capacity — Returns the current capacity.

Açıklama

public int Ds\Stack::capacity ( void )

Returns the current capacity.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current capacity.

Ds\Stack::allocate
Ds\Stack::clear
Stack


Removes all values.

Ds\Stack::capacity
Ds\Stack::__construct
Stack
PHP Manual

Ds\Stack::clear

(PECL ds >= 1.0.0)

Ds\Stack::clear — Removes all values.

Açıklama

public void Ds\Stack::clear ( void )

Removes all values from the stack.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\Stack::clear() example

<?php
$stack = new \Ds\Stack([1, 2, 3]);
print_r($stack);

$stack->clear();
print_r($stack);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Stack Object
(
    [0] => 3
    [1] => 2
    [2] => 1
)
Ds\Stack Object
(
)
Ds\Stack::capacity
Ds\Stack::__construct
Stack


Creates a new instance.

Ds\Stack::clear
Ds\Stack::copy
Stack
PHP Manual

Ds\Stack::__construct

(PECL ds >= 1.0.0)

Ds\Stack::__construct — Creates a new instance.

Açıklama

public Ds\Stack::__construct ([ mixed $values ] )

Creates a new instance, using either a traversable object or an array for the initial values.

Değiştirgeler

values

A traversable object or an array to use for the initial values.

Örnekler

Örnek 1 Ds\Stack::__construct() example

<?php
$stack = new \Ds\Stack();
print_r($stack);

$stack = new \Ds\Stack([1, 2, 3]);
print_r($stack);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Stack Object
(
)
Ds\Stack Object
(
    [0] => 3
    [1] => 2
    [2] => 1
)
Ds\Stack::clear
Ds\Stack::copy
Stack


Returns a shallow copy of the stack.

Ds\Stack::__construct
Ds\Stack::count
Stack
PHP Manual

Ds\Stack::copy

(PECL ds >= 1.0.0)

Ds\Stack::copy — Returns a shallow copy of the stack.

Açıklama

public Ds\Stack Ds\Stack::copy ( void )

Returns a shallow copy of the stack.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a shallow copy of the stack.

Örnekler

Örnek 1 Ds\Stack::copy() example

<?php
$a = new \Ds\Stack([1, 2, 3]);
$b = $a->copy();

// Updating the copy doesn't affect the original
$b->push(4);

print_r($a);
print_r($b);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Stack Object
(
    [0] => 3
    [1] => 2
    [2] => 1
)
Ds\Stack Object
(
    [0] => 4
    [1] => 3
    [2] => 2
    [3] => 1
)
Ds\Stack::__construct
Ds\Stack::count
Stack


Returns the number of values in the stack.

Ds\Stack::copy
Ds\Stack::isEmpty
Stack
PHP Manual

Ds\Stack::count

(PECL ds >= 1.0.0)

Ds\Stack::count — Returns the number of values in the stack.

See Countable::count()

Ds\Stack::copy
Ds\Stack::isEmpty
Stack


Returns whether the stack is empty

Ds\Stack::count
Ds\Stack::jsonSerialize
Stack
PHP Manual

Ds\Stack::isEmpty

(PECL ds >= 1.0.0)

Ds\Stack::isEmpty — Returns whether the stack is empty

Açıklama

public bool Ds\Stack::isEmpty ( void )

Returns whether the stack is empty.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the stack is empty, FALSE otherwise.

Örnekler

Örnek 1 Ds\Stack::isEmpty() example

<?php
$a = new \Ds\Stack([1, 2, 3]);
$b = new \Ds\Stack();

var_dump($a->isEmpty());
var_dump($b->isEmpty());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(false)
bool(true)
Ds\Stack::count
Ds\Stack::jsonSerialize
Stack


Returns a representation that can be converted to JSON.

Ds\Stack::isEmpty
Ds\Stack::peek
Stack
PHP Manual

Ds\Stack::jsonSerialize

(PECL ds >= 1.0.0)

Ds\Stack::jsonSerialize — Returns a representation that can be converted to JSON.

See JsonSerializable::jsonSerialize()

Bilginize:

You should never need to call this directly.

Ds\Stack::isEmpty
Ds\Stack::peek
Stack


Returns the value at the top of the stack.

Ds\Stack::jsonSerialize
Ds\Stack::pop
Stack
PHP Manual

Ds\Stack::peek

(PECL ds >= 1.0.0)

Ds\Stack::peek — Returns the value at the top of the stack.

Açıklama

public mixed Ds\Stack::peek ( void )

Returns the value at the top of the stack, but does not remove it.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The value at the top of the stack.

Hatalar/İstisnalar

UnderflowException if empty.

Örnekler

Örnek 1 Ds\Stack::peek() example

<?php
$stack = new \Ds\Stack();

$stack->push("a");
$stack->push("b");
$stack->push("c");

var_dump($stack->peek());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(1) "c"
Ds\Stack::jsonSerialize
Ds\Stack::pop
Stack


Removes and returns the value at the top of the stack.

Ds\Stack::peek
Ds\Stack::push
Stack
PHP Manual

Ds\Stack::pop

(PECL ds >= 1.0.0)

Ds\Stack::pop — Removes and returns the value at the top of the stack.

Açıklama

public mixed Ds\Stack::pop ( void )

Removes and returns the value at the top of the stack.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The removed value which was at the top of the stack.

Hatalar/İstisnalar

UnderflowException if empty.

Örnekler

Örnek 1 Ds\Stack::pop() example

<?php
$stack = new \Ds\Stack();

$stack->push("a");
$stack->push("b");
$stack->push("c");

var_dump($stack->pop());
var_dump($stack->pop());
var_dump($stack->pop());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(1) "c"
string(1) "b"
string(1) "a"
Ds\Stack::peek
Ds\Stack::push
Stack


Pushes values onto the stack.

Ds\Stack::pop
Ds\Stack::toArray
Stack
PHP Manual

Ds\Stack::push

(PECL ds >= 1.0.0)

Ds\Stack::push — Pushes values onto the stack.

Açıklama

public void Ds\Stack::push ([ mixed $...values ] )

Pushes values onto the stack.

Değiştirgeler

values

The values to push onto the stack.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\Stack::push() example

<?php
$stack = new \Ds\Stack();

$stack->push("a");
$stack->push("b");
$stack->push("c", "d");
$stack->push(...["e", "f"]);

print_r($stack);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Stack Object
(
    [0] => a
    [1] => b
    [2] => c
    [3] => d
    [4] => e
    [5] => f
)
Ds\Stack::pop
Ds\Stack::toArray
Stack


Converts the stack to an array.

Ds\Stack::push
Queue
Stack
PHP Manual

Ds\Stack::toArray

(PECL ds >= 1.0.0)

Ds\Stack::toArray — Converts the stack to an array.

Açıklama

public array Ds\Stack::toArray ( void )

Converts the stack to an array.

Bilginize:

Casting to an array is not supported yet.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

An array containing all the values in the same order as the stack.

Örnekler

Örnek 1 Ds\Stack::toArray() example

<?php
$stack = new \Ds\Stack([1, 2, 3]);

var_dump($stack->toArray());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(3) {
  [0]=>
  int(3)
  [1]=>
  int(2)
  [2]=>
  int(1)
}
Ds\Stack::push
Queue
Stack


The Queue class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

A Queue is a "first in, first out" or "FIFO" collection that only allows access to the value at the front of the queue and iterates in that order, destructively.

Sınıf Sözdizimi

Ds\Queue implements Ds\Collection {
/* Constants */
const int MIN_CAPACITY = 8 ;
/* Yöntemler */
public void allocate ( int $capacity )
public int capacity ( void )
public void clear ( void )
public Ds\Queue copy ( void )
public bool isEmpty ( void )
public mixed peek ( void )
public mixed pop ( void )
public void push ([ mixed $...values ] )
public array toArray ( void )
}

Öntanımlı Sabitler

Ds\Queue::MIN_CAPACITY

İçindekiler

  • Ds\Queue::allocate — Allocates enough memory for a required capacity.
  • Ds\Queue::capacity — Returns the current capacity.
  • Ds\Queue::clear — Removes all values.
  • Ds\Queue::__construct — Creates a new instance.
  • Ds\Queue::copy — Returns a shallow copy of the queue.
  • Ds\Queue::count — Returns the number of values in the queue.
  • Ds\Queue::isEmpty — Returns whether the queue is empty
  • Ds\Queue::jsonSerialize — Returns a representation that can be converted to JSON.
  • Ds\Queue::peek — Returns the value at the front of the queue.
  • Ds\Queue::pop — Removes and returns the value at the front of the queue.
  • Ds\Queue::push — Pushes values into the queue.
  • Ds\Queue::toArray — Converts the queue to an array.
Ds\Stack::toArray
Ds\Queue::allocate
Data Structures


Allocates enough memory for a required capacity.

Queue
Ds\Queue::capacity
Queue
PHP Manual

Ds\Queue::allocate

(PECL ds >= 1.0.0)

Ds\Queue::allocate — Allocates enough memory for a required capacity.

Açıklama

public void Ds\Queue::allocate ( int $capacity )

Ensures that enough memory is allocated for a required capacity. This removes the need to reallocate the internal as values are added.

Bilginize:

Capacity will always be rounded up to the nearest power of 2.

Değiştirgeler

capacity

The number of values for which capacity should be allocated.

Bilginize:

Capacity will stay the same if this value is less than or equal to the current capacity.

Bilginize:

Capacity will always be rounded up to the nearest power of 2.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\Queue::allocate() example

<?php
$queue = new \Ds\Queue();
var_dump($queue->capacity());

$queue->allocate(100);
var_dump($queue->capacity());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(8)
int(128)
Queue
Ds\Queue::capacity
Queue


Returns the current capacity.

Ds\Queue::allocate
Ds\Queue::clear
Queue
PHP Manual

Ds\Queue::capacity

(PECL ds >= 1.0.0)

Ds\Queue::capacity — Returns the current capacity.

Açıklama

public int Ds\Queue::capacity ( void )

Returns the current capacity.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current capacity.

Örnekler

Örnek 1 Ds\Queue::capacity() example

<?php
$queue = new \Ds\Queue();
var_dump($queue->capacity());

$queue->push(...range(1, 50));
var_dump($queue->capacity());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(8)
int(64)
Ds\Queue::allocate
Ds\Queue::clear
Queue


Removes all values.

Ds\Queue::capacity
Ds\Queue::__construct
Queue
PHP Manual

Ds\Queue::clear

(PECL ds >= 1.0.0)

Ds\Queue::clear — Removes all values.

Açıklama

public void Ds\Queue::clear ( void )

Removes all values from the queue.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\Queue::clear() example

<?php
$queue = new \Ds\Queue([1, 2, 3]);
print_r($queue);

$queue->clear();
print_r($queue);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Queue Object
(
    [0] => 1
    [1] => 2
    [2] => 3
)
Ds\Queue Object
(
)
Ds\Queue::capacity
Ds\Queue::__construct
Queue


Creates a new instance.

Ds\Queue::clear
Ds\Queue::copy
Queue
PHP Manual

Ds\Queue::__construct

(PECL ds >= 1.0.0)

Ds\Queue::__construct — Creates a new instance.

Açıklama

public Ds\Queue::__construct ([ mixed $values ] )

Creates a new instance, using either a traversable object or an array for the initial values.

Değiştirgeler

values

A traversable object or an array to use for the initial values.

Örnekler

Örnek 1 Ds\Queue::__construct() example

<?php
$queue = new \Ds\Queue();
var_dump($queue);

$queue = new \Ds\Queue([1, 2, 3]);
var_dump($queue);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(Ds\Queue)#2 (0) {
}
object(Ds\Queue)#2 (3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}
Ds\Queue::clear
Ds\Queue::copy
Queue


Returns a shallow copy of the queue.

Ds\Queue::__construct
Ds\Queue::count
Queue
PHP Manual

Ds\Queue::copy

(PECL ds >= 1.0.0)

Ds\Queue::copy — Returns a shallow copy of the queue.

Açıklama

public Ds\Queue Ds\Queue::copy ( void )

Returns a shallow copy of the queue.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a shallow copy of the queue.

Örnekler

Örnek 1 Ds\Queue::copy() example

<?php
$a = new \Ds\Queue([1, 2, 3]);
$b = $a->copy();

// Updating the copy doesn't affect the original
$b->push(4);

print_r($a);
print_r($b);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Queue Object
(
    [0] => 1
    [1] => 2
    [2] => 3
)
Ds\Queue Object
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
)
Ds\Queue::__construct
Ds\Queue::count
Queue


Returns the number of values in the queue.

Ds\Queue::copy
Ds\Queue::isEmpty
Queue
PHP Manual

Ds\Queue::count

(PECL ds >= 1.0.0)

Ds\Queue::count — Returns the number of values in the queue.

See Countable::count()

Ds\Queue::copy
Ds\Queue::isEmpty
Queue


Returns whether the queue is empty

Ds\Queue::count
Ds\Queue::jsonSerialize
Queue
PHP Manual

Ds\Queue::isEmpty

(PECL ds >= 1.0.0)

Ds\Queue::isEmpty — Returns whether the queue is empty

Açıklama

public bool Ds\Queue::isEmpty ( void )

Returns whether the queue is empty.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the queue is empty, FALSE otherwise.

Örnekler

Örnek 1 Ds\Queue::isEmpty() example

<?php
$a = new \Ds\Queue([1, 2, 3]);
$b = new \Ds\Queue();

var_dump($a->isEmpty());
var_dump($b->isEmpty());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(false)
bool(true)
Ds\Queue::count
Ds\Queue::jsonSerialize
Queue


Returns a representation that can be converted to JSON.

Ds\Queue::isEmpty
Ds\Queue::peek
Queue
PHP Manual

Ds\Queue::jsonSerialize

(PECL ds >= 1.0.0)

Ds\Queue::jsonSerialize — Returns a representation that can be converted to JSON.

See JsonSerializable::jsonSerialize()

Bilginize:

You should never need to call this directly.

Ds\Queue::isEmpty
Ds\Queue::peek
Queue


Returns the value at the front of the queue.

Ds\Queue::jsonSerialize
Ds\Queue::pop
Queue
PHP Manual

Ds\Queue::peek

(PECL ds >= 1.0.0)

Ds\Queue::peek — Returns the value at the front of the queue.

Açıklama

public mixed Ds\Queue::peek ( void )

Returns the value at the front of the queue, but does not remove it.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The value at the front of the queue.

Hatalar/İstisnalar

UnderflowException if empty.

Örnekler

Örnek 1 Ds\Queue::peek() example

<?php
$queue = new \Ds\Queue();

$queue->push("a");
$queue->push("b");
$queue->push("c");

var_dump($queue->peek());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(1) "a"
Ds\Queue::jsonSerialize
Ds\Queue::pop
Queue


Removes and returns the value at the front of the queue.

Ds\Queue::peek
Ds\Queue::push
Queue
PHP Manual

Ds\Queue::pop

(PECL ds >= 1.0.0)

Ds\Queue::pop — Removes and returns the value at the front of the queue.

Açıklama

public mixed Ds\Queue::pop ( void )

Removes and returns the value at the front of the queue.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The removed value which was at the front of the queue.

Hatalar/İstisnalar

UnderflowException if empty.

Örnekler

Örnek 1 Ds\Queue::pop() example

<?php
$queue = new \Ds\Queue();

$queue->push("a");
$queue->push("b");
$queue->push("c");

var_dump($queue->pop());
var_dump($queue->pop());
var_dump($queue->pop());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(1) "a"
string(1) "b"
string(1) "c"
Ds\Queue::peek
Ds\Queue::push
Queue


Pushes values into the queue.

Ds\Queue::pop
Ds\Queue::toArray
Queue
PHP Manual

Ds\Queue::push

(PECL ds >= 1.0.0)

Ds\Queue::push — Pushes values into the queue.

Açıklama

public void Ds\Queue::push ([ mixed $...values ] )

Pushes values into the queue.

Değiştirgeler

values

The values to push into the queue.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\Queue::push() example

<?php
$queue = new \Ds\Queue();

$queue->push("a");
$queue->push("b");
$queue->push("c", "d");
$queue->push(...["e", "f"]);

print_r($queue);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\Queue Object
(
    [0] => a
    [1] => b
    [2] => c
    [3] => d
    [4] => e
    [5] => f
)
Ds\Queue::pop
Ds\Queue::toArray
Queue


Converts the queue to an array.

Ds\Queue::push
PriorityQueue
Queue
PHP Manual

Ds\Queue::toArray

(PECL ds >= 1.0.0)

Ds\Queue::toArray — Converts the queue to an array.

Açıklama

public array Ds\Queue::toArray ( void )

Converts the queue to an array.

Bilginize:

Casting to an array is not supported yet.

Bilginize:

This method is not destructive.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

An array containing all the values in the same order as the queue.

Örnekler

Örnek 1 Ds\Queue::toArray() example

<?php
$queue = new \Ds\Queue([1, 2, 3]);

var_dump($queue->toArray());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}
Ds\Queue::push
PriorityQueue
Queue


The PriorityQueue class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

A PriorityQueue is very similar to a Queue. Values are pushed into the queue with an assigned priority, and the value with the highest priority will always be at the front of the queue.

Implemented using a max heap.

Bilginize:

"First in, first out" ordering is preserved for values with the same priority.

Bilginize:

Iterating over a PriorityQueue is destructive, equivalent to successive pop operations until the queue is empty.

Sınıf Sözdizimi

Ds\PriorityQueue implements Ds\Collection {
/* Constants */
const int MIN_CAPACITY = 8 ;
/* Yöntemler */
public void allocate ( int $capacity )
public int capacity ( void )
public void clear ( void )
public Ds\PriorityQueue copy ( void )
public bool isEmpty ( void )
public mixed peek ( void )
public mixed pop ( void )
public void push ( mixed $value , int $priority )
public array toArray ( void )
}

Öntanımlı Sabitler

Ds\PriorityQueue::MIN_CAPACITY

İçindekiler

  • Ds\PriorityQueue::allocate — Allocates enough memory for a required capacity.
  • Ds\PriorityQueue::capacity — Returns the current capacity.
  • Ds\PriorityQueue::clear — Removes all values.
  • Ds\PriorityQueue::__construct — Creates a new instance.
  • Ds\PriorityQueue::copy — Returns a shallow copy of the queue.
  • Ds\PriorityQueue::count — Returns the number of values in the queue.
  • Ds\PriorityQueue::isEmpty — Returns whether the queue is empty
  • Ds\PriorityQueue::jsonSerialize — Returns a representation that can be converted to JSON.
  • Ds\PriorityQueue::peek — Returns the value at the front of the queue.
  • Ds\PriorityQueue::pop — Removes and returns the value with the highest priority.
  • Ds\PriorityQueue::push — Pushes values into the queue.
  • Ds\PriorityQueue::toArray — Converts the queue to an array.
Ds\Queue::toArray
Ds\PriorityQueue::allocate
Data Structures


Allocates enough memory for a required capacity.

PriorityQueue
Ds\PriorityQueue::capacity
PriorityQueue
PHP Manual

Ds\PriorityQueue::allocate

(PECL ds >= 1.0.0)

Ds\PriorityQueue::allocate — Allocates enough memory for a required capacity.

Açıklama

public void Ds\PriorityQueue::allocate ( int $capacity )

Ensures that enough memory is allocated for a required capacity. This removes the need to reallocate the internal as values are added.

Değiştirgeler

capacity

The number of values for which capacity should be allocated.

Bilginize:

Capacity will stay the same if this value is less than or equal to the current capacity.

Bilginize:

Capacity will always be rounded up to the nearest power of 2.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\PriorityQueue::allocate() example

<?php
$queue = new \Ds\PriorityQueue();
var_dump($queue->capacity());

$queue->allocate(100);
var_dump($queue->capacity());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(8)
int(128)
PriorityQueue
Ds\PriorityQueue::capacity
PriorityQueue


Returns the current capacity.

Ds\PriorityQueue::allocate
Ds\PriorityQueue::clear
PriorityQueue
PHP Manual

Ds\PriorityQueue::capacity

(PECL ds >= 1.0.0)

Ds\PriorityQueue::capacity — Returns the current capacity.

Açıklama

public int Ds\PriorityQueue::capacity ( void )

Returns the current capacity.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current capacity.

Örnekler

Örnek 1 Ds\PriorityQueue::capacity() example

<?php
$queue = new \Ds\PriorityQueue();
var_dump($queue->capacity());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(8)
Ds\PriorityQueue::allocate
Ds\PriorityQueue::clear
PriorityQueue


Removes all values.

Ds\PriorityQueue::capacity
Ds\PriorityQueue::__construct
PriorityQueue
PHP Manual

Ds\PriorityQueue::clear

(PECL ds >= 1.0.0)

Ds\PriorityQueue::clear — Removes all values.

Açıklama

public void Ds\PriorityQueue::clear ( void )

Removes all values from the queue.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\PriorityQueue::clear() example

<?php
$queue = new \Ds\PriorityQueue();

$queue->push("a",  5);
$queue->push("b", 15);
$queue->push("c", 10);

$queue->clear();
print_r($queue);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\PriorityQueue Object
(
)
Ds\PriorityQueue::capacity
Ds\PriorityQueue::__construct
PriorityQueue


Creates a new instance.

Ds\PriorityQueue::clear
Ds\PriorityQueue::copy
PriorityQueue
PHP Manual

Ds\PriorityQueue::__construct

(PECL ds >= 1.0.0)

Ds\PriorityQueue::__construct — Creates a new instance.

Açıklama

public Ds\PriorityQueue::__construct ( void )

Creates a new instance.

Örnekler

Örnek 1 Ds\PriorityQueue::__construct() example

<?php
$queue = new \Ds\PriorityQueue();
var_dump($queue);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(Ds\PriorityQueue)#1 (0) {
}
Ds\PriorityQueue::clear
Ds\PriorityQueue::copy
PriorityQueue


Returns a shallow copy of the queue.

Ds\PriorityQueue::__construct
Ds\PriorityQueue::count
PriorityQueue
PHP Manual

Ds\PriorityQueue::copy

(PECL ds >= 1.0.0)

Ds\PriorityQueue::copy — Returns a shallow copy of the queue.

Açıklama

public Ds\PriorityQueue Ds\PriorityQueue::copy ( void )

Returns a shallow copy of the queue.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a shallow copy of the queue.

Örnekler

Örnek 1 Ds\PriorityQueue::copy() example

<?php
$queue = new \Ds\PriorityQueue();

$queue->push("a",  5);
$queue->push("b", 15);
$queue->push("c", 10);

print_r($queue->copy());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ds\PriorityQueue Object
(
    [0] => b
    [1] => c
    [2] => a
)
Ds\PriorityQueue::__construct
Ds\PriorityQueue::count
PriorityQueue


Returns the number of values in the queue.

Ds\PriorityQueue::copy
Ds\PriorityQueue::isEmpty
PriorityQueue
PHP Manual

Ds\PriorityQueue::count

(PECL ds >= 1.0.0)

Ds\PriorityQueue::count — Returns the number of values in the queue.

See Countable::count()

Ds\PriorityQueue::copy
Ds\PriorityQueue::isEmpty
PriorityQueue


Returns whether the queue is empty

Ds\PriorityQueue::count
Ds\PriorityQueue::jsonSerialize
PriorityQueue
PHP Manual

Ds\PriorityQueue::isEmpty

(PECL ds >= 1.0.0)

Ds\PriorityQueue::isEmpty — Returns whether the queue is empty

Açıklama

public bool Ds\PriorityQueue::isEmpty ( void )

Returns whether the queue is empty.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the queue is empty, FALSE otherwise.

Örnekler

Örnek 1 Ds\PriorityQueue::isEmpty() example

<?php
$a = new \Ds\PriorityQueue();
$b = new \Ds\PriorityQueue();

$a->push("a",  5);
$a->push("b", 15);
$a->push("c", 10);

var_dump($a->isEmpty());
var_dump($b->isEmpty());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(false)
bool(true)
Ds\PriorityQueue::count
Ds\PriorityQueue::jsonSerialize
PriorityQueue


Returns a representation that can be converted to JSON.

Ds\PriorityQueue::isEmpty
Ds\PriorityQueue::peek
PriorityQueue
PHP Manual

Ds\PriorityQueue::jsonSerialize

(PECL ds >= 1.0.0)

Ds\PriorityQueue::jsonSerialize — Returns a representation that can be converted to JSON.

See JsonSerializable::jsonSerialize()

Bilginize:

You should never need to call this directly.

Ds\PriorityQueue::isEmpty
Ds\PriorityQueue::peek
PriorityQueue


Returns the value at the front of the queue.

Ds\PriorityQueue::jsonSerialize
Ds\PriorityQueue::pop
PriorityQueue
PHP Manual

Ds\PriorityQueue::peek

(PECL ds >= 1.0.0)

Ds\PriorityQueue::peek — Returns the value at the front of the queue.

Açıklama

public mixed Ds\PriorityQueue::peek ( void )

Returns the value at the front of the queue, but does not remove it.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The value at the front of the queue.

Hatalar/İstisnalar

UnderflowException if empty.

Örnekler

Örnek 1 Ds\PriorityQueue::peek() example

<?php
$queue = new \Ds\PriorityQueue();

$queue->push("a",  5);
$queue->push("b", 15);
$queue->push("c", 10);

var_dump($queue->peek());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(1) "b"
Ds\PriorityQueue::jsonSerialize
Ds\PriorityQueue::pop
PriorityQueue


Removes and returns the value with the highest priority.

Ds\PriorityQueue::peek
Ds\PriorityQueue::push
PriorityQueue
PHP Manual

Ds\PriorityQueue::pop

(PECL ds >= 1.0.0)

Ds\PriorityQueue::pop — Removes and returns the value with the highest priority.

Açıklama

public mixed Ds\PriorityQueue::pop ( void )

Removes and returns the value at the front of the queue, ie. the value with the highest priority.

Bilginize:

Values with equal priority fall back to FIFO (first in first out).

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The removed value which was at the front of the queue.

Hatalar/İstisnalar

UnderflowException if empty.

Örnekler

Örnek 1 Ds\PriorityQueue::pop() example

<?php
$queue = new \Ds\PriorityQueue();

$queue->push("a",  5);
$queue->push("b", 15);
$queue->push("c", 10);

print_r($queue->pop());
print_r($queue->pop());
print_r($queue->pop());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(1) "a"
string(1) "b"
string(1) "c"
Ds\PriorityQueue::peek
Ds\PriorityQueue::push
PriorityQueue


Pushes values into the queue.

Ds\PriorityQueue::pop
Ds\PriorityQueue::toArray
PriorityQueue
PHP Manual

Ds\PriorityQueue::push

(PECL ds >= 1.0.0)

Ds\PriorityQueue::push — Pushes values into the queue.

Açıklama

public void Ds\PriorityQueue::push ( mixed $value , int $priority )

Pushes a value with a given priority into the queue.

Değiştirgeler

value

The value to push into the queue.

priority

The priority associated with the value.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Ds\PriorityQueue::push() example

<?php
$queue = new \Ds\PriorityQueue();

$queue->push("a",  5);
$queue->push("b", 15);
$queue->push("c", 10);

print_r($queue->pop());
print_r($queue->pop());
print_r($queue->pop());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(1) "b"
string(1) "c"
string(1) "a"
Ds\PriorityQueue::pop
Ds\PriorityQueue::toArray
PriorityQueue


Converts the queue to an array.

Ds\PriorityQueue::push
Filter
PriorityQueue
PHP Manual

Ds\PriorityQueue::toArray

(PECL ds >= 1.0.0)

Ds\PriorityQueue::toArray — Converts the queue to an array.

Açıklama

public array Ds\PriorityQueue::toArray ( void )

Converts the queue to an array.

Bilginize:

This method is not destructive.

Bilginize:

Casting to an array is not supported yet.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

An array containing all the values in the same order as the queue.

Örnekler

Örnek 1 Ds\PriorityQueue::toArray() example

<?php
$queue = new \Ds\PriorityQueue();

$queue->push("a",  5);
$queue->push("b", 15);
$queue->push("c", 10);

var_dump($queue->toArray());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(3) {
  [0]=>
  string(1) "b"
  [1]=>
  string(1) "c"
  [2]=>
  string(1) "a"
}
Ds\PriorityQueue::push
Filter
PriorityQueue


Data Filtering

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Types of filters
    • Validate filters
    • Sanitize filters
    • Other filters
    • Filter flags
  • Öntanımlı Sabitler
  • Örnekler
    • Validation
    • Sanitization
  • Filter İşlevleri
    • filter_has_var — Checks if variable of specified type exists
    • filter_id — Returns the filter ID belonging to a named filter
    • filter_input_array — Gets external variables and optionally filters them
    • filter_input — Gets a specific external variable by name and optionally filters it
    • filter_list — Returns a list of all supported filters
    • filter_var_array — Gets multiple variables and optionally filters them
    • filter_var — Filters a variable with a specified filter
Ds\PriorityQueue::toArray
Giriş
Değişkenler ve Veri Türleriyle İlgili Eklentiler


Giriş

This extension filters data by either validating or sanitizing it. This is especially useful when the data source contains unknown (or foreign) data, like user supplied input. For example, this data may come from an HTML form.

There are two main types of filtering: validation and sanitization.

Validation is used to validate or check if the data meets certain qualifications. For example, passing in FILTER_VALIDATE_EMAIL will determine if the data is a valid email address, but will not change the data itself.

Sanitization will sanitize the data, so it may alter it by removing undesired characters. For example, passing in FILTER_SANITIZE_EMAIL will remove characters that are inappropriate for an email address to contain. That said, it does not validate the data.

Flags are optionally used with both validation and sanitization to tweak behaviour according to need. For example, passing in FILTER_FLAG_PATH_REQUIRED while filtering an URL will require a path (like /foo in http://example.org/foo) to be present.

Filter
Yapılandırma/Kurulum
Filter


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Filter


Kurulum

The filter extension is enabled by default as of PHP 5.2.0. Before this time an experimental PECL extension was used, however, the PECL version is no longer recommended or updated.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Filter Configuration Options
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
filter.default | "unsafe_raw" | PHP_INI_PERDIR | PHP_INI_ALL in filter <= 0.9.4. Available since PHP 5.2.0.
filter.default_flags | NULL | PHP_INI_PERDIR | PHP_INI_ALL in filter <= 0.9.4. Available since PHP 5.2.0.
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

filter.default string

Filter all $_GET, $_POST, $_COOKIE, $_REQUEST and $_SERVER data by this filter. Original data can be accessed through filter_input().

Accepts the name of the filter you like to use by default. See the existing filter list for the list of the filter names.

Bilginize:

Be careful about the default flags for the default filters. You should explicitly set them to the value you want. For example, to configure the default filter to behave exactly like htmlspecialchars() you need to set them default flags to 0 as shown below.

Örnek 1 Configuring the default filter to act like htmlspecialchars

filter.default = full_special_chars
filter.default_flags = 0

filter.default_flags integer

Default flags to apply when the default filter is set. This is set to FILTER_FLAG_NO_ENCODE_QUOTES by default for backwards compatibility reasons. See the flag list for the list of all the flag names.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Özkaynak Türleri

Bu eklentinin tanımlı hiçbir özkaynak türü yoktur.

Çalışma Anı Yapılandırması
Types of filters
Yapılandırma/Kurulum


Types of filters

İçindekiler

  • Validate filters
  • Sanitize filters
  • Other filters
  • Filter flags
Özkaynak Türleri
Validate filters
Filter


Validate filters

Listing of filters for validation
ID | Name | Options | Flags | Description
FILTER_VALIDATE_BOOLEAN | "boolean" | default | FILTER_NULL_ON_FAILURE | Returns TRUE for "1", "true", "on" and "yes". Returns FALSE otherwise. If FILTER_NULL_ON_FAILURE is set, FALSE is returned only for "0", "false", "off", "no", and "", and NULL is returned for all non-boolean values.
FILTER_VALIDATE_EMAIL | "validate_email" | default | FILTER_FLAG_EMAIL_UNICODE | Validates whether the value is a valid e-mail address. In general, this validates e-mail addresses against the syntax in RFC 822, with the exceptions that comments and whitespace folding and dotless domain names are not supported.
FILTER_VALIDATE_FLOAT | "float" | default, decimal | FILTER_FLAG_ALLOW_THOUSAND | Validates value as float, and converts to float on success.
FILTER_VALIDATE_INT | "int" | default, min_range, max_range | FILTER_FLAG_ALLOW_OCTAL, FILTER_FLAG_ALLOW_HEX | Validates value as integer, optionally from the specified range, and converts to int on success.
FILTER_VALIDATE_IP | "validate_ip" | default | FILTER_FLAG_IPV4, FILTER_FLAG_IPV6, FILTER_FLAG_NO_PRIV_RANGE, FILTER_FLAG_NO_RES_RANGE | Validates value as IP address, optionally only IPv4 or IPv6 or not from private or reserved ranges.
FILTER_VALIDATE_MAC | "validate_mac_address" | default |  | Validates value as MAC address.
FILTER_VALIDATE_REGEXP | "validate_regexp" | default, regexp |  | Validates value against regexp, a Perl-compatible regular expression.
FILTER_VALIDATE_URL | "validate_url" | default | FILTER_FLAG_SCHEME_REQUIRED, FILTER_FLAG_HOST_REQUIRED, FILTER_FLAG_PATH_REQUIRED, FILTER_FLAG_QUERY_REQUIRED | Validates value as URL (according to » http://www.faqs.org/rfcs/rfc2396), optionally with required components. Beware a valid URL may not specify the HTTP protocol http:// so further validation may be required to determine the URL uses an expected protocol, e.g. ssh:// or mailto:. Note that the function will only find ASCII URLs to be valid; internationalized domain names (containing non-ASCII characters) will fail.

Bilginize:

As of PHP 5.4.11, the numbers +0 and -0 validate as both integers as well as floats (using FILTER_VALIDATE_FLOAT and FILTER_VALIDATE_INT). Before PHP 5.4.11 they only validated as floats (using FILTER_VALIDATE_FLOAT).

When default is set to option, default's value is used if value is not validated.

Sürüm Bilgisi

Sürüm: | Açıklama
5.5.0 | Added FILTER_VALIDATE_MAC
5.2.1 | FILTER_VALIDATE_URL now defaults to FILTER_FLAG_SCHEME_REQUIRED and FILTER_FLAG_HOST_REQUIRED.

Types of filters
Sanitize filters
Types of filters


Sanitize filters

List of filters for sanitization
ID | Name | Flags | Description
FILTER_SANITIZE_EMAIL | "email" |  | Remove all characters except letters, digits and !#$%&'*+-=?^_`{|}~@.[].
FILTER_SANITIZE_ENCODED | "encoded" | FILTER_FLAG_STRIP_LOW, FILTER_FLAG_STRIP_HIGH, FILTER_FLAG_STRIP_BACKTICK, FILTER_FLAG_ENCODE_LOW, FILTER_FLAG_ENCODE_HIGH | URL-encode string, optionally strip or encode special characters.
FILTER_SANITIZE_MAGIC_QUOTES | "magic_quotes" |  | Apply addslashes().
FILTER_SANITIZE_NUMBER_FLOAT | "number_float" | FILTER_FLAG_ALLOW_FRACTION, FILTER_FLAG_ALLOW_THOUSAND, FILTER_FLAG_ALLOW_SCIENTIFIC | Remove all characters except digits, +- and optionally .,eE.
FILTER_SANITIZE_NUMBER_INT | "number_int" |  | Remove all characters except digits, plus and minus sign.
FILTER_SANITIZE_SPECIAL_CHARS | "special_chars" | FILTER_FLAG_STRIP_LOW, FILTER_FLAG_STRIP_HIGH, FILTER_FLAG_STRIP_BACKTICK, FILTER_FLAG_ENCODE_HIGH | HTML-escape '"<>& and characters with ASCII value less than 32, optionally strip or encode other special characters.
FILTER_SANITIZE_FULL_SPECIAL_CHARS | "full_special_chars" | FILTER_FLAG_NO_ENCODE_QUOTES, | Equivalent to calling htmlspecialchars() with ENT_QUOTES set. Encoding quotes can be disabled by setting FILTER_FLAG_NO_ENCODE_QUOTES. Like htmlspecialchars(), this filter is aware of the default_charset and if a sequence of bytes is detected that makes up an invalid character in the current character set then the entire string is rejected resulting in a 0-length string. When using this filter as a default filter, see the warning below about setting the default flags to 0.
FILTER_SANITIZE_STRING | "string" | FILTER_FLAG_NO_ENCODE_QUOTES, FILTER_FLAG_STRIP_LOW, FILTER_FLAG_STRIP_HIGH, FILTER_FLAG_STRIP_BACKTICK, FILTER_FLAG_ENCODE_LOW, FILTER_FLAG_ENCODE_HIGH, FILTER_FLAG_ENCODE_AMP | Strip tags, optionally strip or encode special characters.
FILTER_SANITIZE_STRIPPED | "stripped" |  | Alias of "string" filter.
FILTER_SANITIZE_URL | "url" |  | Remove all characters except letters, digits and $-_.+!*'(),{}|\\^~[]`<>#%";/?:@&=.
FILTER_UNSAFE_RAW | "unsafe_raw" | FILTER_FLAG_STRIP_LOW, FILTER_FLAG_STRIP_HIGH, FILTER_FLAG_STRIP_BACKTICK, FILTER_FLAG_ENCODE_LOW, FILTER_FLAG_ENCODE_HIGH, FILTER_FLAG_ENCODE_AMP | Do nothing, optionally strip or encode special characters. This filter is also aliased to FILTER_DEFAULT.

Uyarı

When using one of these filters as a default filter either through your ini file or through your web server's configuration, the default flags is set to FILTER_FLAG_NO_ENCODE_QUOTES. You need to explicitly set filter.default_flags to 0 to have quotes encoded by default. Like this:

Örnek 1 Configuring the default filter to act like htmlspecialchars

filter.default = full_special_chars
filter.default_flags = 0

Sürüm Bilgisi

Sürüm: | Açıklama
5.2.11/5.3.1 | Slashes (/) are removed by FILTER_SANITIZE_EMAIL. Prior they were retained.

Validate filters
Other filters
Types of filters


Other filters

List of miscellaneous filters
ID | Name | Options | Flags | Description
FILTER_CALLBACK | "callback" | callable function or method |  | Call user-defined function to filter data.

Sanitize filters
Filter flags
Types of filters


Filter flags

List of filter flags
ID | Used with | Description
FILTER_FLAG_STRIP_LOW | FILTER_SANITIZE_ENCODED, FILTER_SANITIZE_SPECIAL_CHARS, FILTER_SANITIZE_STRING, FILTER_UNSAFE_RAW | Strips characters that have a numerical value <32.
FILTER_FLAG_STRIP_HIGH | FILTER_SANITIZE_ENCODED, FILTER_SANITIZE_SPECIAL_CHARS, FILTER_SANITIZE_STRING, FILTER_UNSAFE_RAW | Strips characters that have a numerical value >127.
FILTER_FLAG_STRIP_BACKTICK | FILTER_SANITIZE_ENCODED, FILTER_SANITIZE_SPECIAL_CHARS, FILTER_SANITIZE_STRING, FILTER_UNSAFE_RAW | Strips backtick characters.
FILTER_FLAG_ALLOW_FRACTION | FILTER_SANITIZE_NUMBER_FLOAT | Allows a period (.) as a fractional separator in numbers.
FILTER_FLAG_ALLOW_THOUSAND | FILTER_SANITIZE_NUMBER_FLOAT, FILTER_VALIDATE_FLOAT | Allows a comma (,) as a thousands separator in numbers.
FILTER_FLAG_ALLOW_SCIENTIFIC | FILTER_SANITIZE_NUMBER_FLOAT | Allows an e or E for scientific notation in numbers.
FILTER_FLAG_NO_ENCODE_QUOTES | FILTER_SANITIZE_STRING | If this flag is present, single (') and double (") quotes will not be encoded.
FILTER_FLAG_ENCODE_LOW | FILTER_SANITIZE_ENCODED, FILTER_SANITIZE_STRING, FILTER_SANITIZE_RAW | Encodes all characters with a numerical value <32.
FILTER_FLAG_ENCODE_HIGH | FILTER_SANITIZE_ENCODED, FILTER_SANITIZE_SPECIAL_CHARS, FILTER_SANITIZE_STRING, FILTER_SANITIZE_RAW | Encodes all characters with a numerical value >127.
FILTER_FLAG_ENCODE_AMP | FILTER_SANITIZE_STRING, FILTER_SANITIZE_RAW | Encodes ampersands (&).
FILTER_NULL_ON_FAILURE | FILTER_VALIDATE_BOOLEAN | Returns NULL for unrecognized boolean values.
FILTER_FLAG_ALLOW_OCTAL | FILTER_VALIDATE_INT | Regards inputs starting with a zero (0) as octal numbers. This only allows the succeeding digits to be 0-7.
FILTER_FLAG_ALLOW_HEX | FILTER_VALIDATE_INT | Regards inputs starting with 0x or 0X as hexadecimal numbers. This only allows succeeding characters to be a-fA-F0-9.
FILTER_FLAG_EMAIL_UNICODE | FILTER_VALIDATE_EMAIL | Allows the local part of the email address to contain Unicode characters.
FILTER_FLAG_IPV4 | FILTER_VALIDATE_IP | Allows the IP address to be in IPv4 format.
FILTER_FLAG_IPV6 | FILTER_VALIDATE_IP | Allows the IP address to be in IPv6 format.
FILTER_FLAG_NO_PRIV_RANGE | FILTER_VALIDATE_IP | Fails validation for the following private IPv4 ranges: 10.0.0.0/8, 172.16.0.0/12 and 192.168.0.0/16. Fails validation for the IPv6 addresses starting with FD or FC.
FILTER_FLAG_NO_RES_RANGE | FILTER_VALIDATE_IP | Fails validation for the following reserved IPv4 ranges: 0.0.0.0/8, 169.254.0.0/16, 127.0.0.0/8 and 240.0.0.0/4. Fails validation for the following reserved IPv6 ranges: ::1/128, ::/128, ::ffff:0:0/96 and fe80::/10.
FILTER_FLAG_SCHEME_REQUIRED | FILTER_VALIDATE_URL | Requires the URL to contain a scheme part.
FILTER_FLAG_HOST_REQUIRED | FILTER_VALIDATE_URL | Requires the URL to contain a host part.
FILTER_FLAG_PATH_REQUIRED | FILTER_VALIDATE_URL | Requires the URL to contain a path part.
FILTER_FLAG_QUERY_REQUIRED | FILTER_VALIDATE_URL | Requires the URL to contain a query string.
FILTER_REQUIRE_SCALAR |  | Requires the value to be scalar.
FILTER_REQUIRE_ARRAY |  | Requires the value to be an array.
FILTER_FORCE_ARRAY |  | If the value is a scalar, it is treated as array with the scalar value as only element.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.2 | FILTER_FLAG_STRIP_BACKTICK has been added.
5.2.10 | FILTER_FLAG_NO_RES_RANGE supports also IPv6 addresses.

Other filters
Öntanımlı Sabitler
Types of filters


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

INPUT_POST (integer)
POST variables.
INPUT_GET (integer)
GET variables.
INPUT_COOKIE (integer)
COOKIE variables.
INPUT_ENV (integer)
ENV variables.
INPUT_SERVER (integer)
SERVER variables.
INPUT_SESSION (integer)
SESSION variables. (not implemented yet)
INPUT_REQUEST (integer)
REQUEST variables. (not implemented yet)
FILTER_FLAG_NONE (integer)
No flags.
FILTER_REQUIRE_SCALAR (integer)
Flag used to require scalar as input
FILTER_REQUIRE_ARRAY (integer)
Require an array as input.
FILTER_FORCE_ARRAY (integer)
Always returns an array.
FILTER_NULL_ON_FAILURE (integer)
Use NULL instead of FALSE on failure.
FILTER_VALIDATE_INT (integer)
ID of "int" filter.
FILTER_VALIDATE_BOOLEAN (integer)
ID of "boolean" filter.
FILTER_VALIDATE_FLOAT (integer)
ID of "float" filter.
FILTER_VALIDATE_REGEXP (integer)
ID of "validate_regexp" filter.
FILTER_VALIDATE_URL (integer)
ID of "validate_url" filter.
FILTER_VALIDATE_EMAIL (integer)
ID of "validate_email" filter.
FILTER_VALIDATE_IP (integer)
ID of "validate_ip" filter.
FILTER_VALIDATE_MAC (integer)
ID of "validate_mac_address" filter. (Available as of PHP 5.5.0)
FILTER_DEFAULT (integer)
ID of default ("unsafe_raw") filter. This is equivalent to FILTER_UNSAFE_RAW.
FILTER_UNSAFE_RAW (integer)
ID of "unsafe_raw" filter.
FILTER_SANITIZE_STRING (integer)
ID of "string" filter.
FILTER_SANITIZE_STRIPPED (integer)
ID of "stripped" filter.
FILTER_SANITIZE_ENCODED (integer)
ID of "encoded" filter.
FILTER_SANITIZE_SPECIAL_CHARS (integer)
ID of "special_chars" filter.
FILTER_SANITIZE_EMAIL (integer)
ID of "email" filter.
FILTER_SANITIZE_URL (integer)
ID of "url" filter.
FILTER_SANITIZE_NUMBER_INT (integer)
ID of "number_int" filter.
FILTER_SANITIZE_NUMBER_FLOAT (integer)
ID of "number_float" filter.
FILTER_SANITIZE_MAGIC_QUOTES (integer)
ID of "magic_quotes" filter.
FILTER_CALLBACK (integer)
ID of "callback" filter.
FILTER_FLAG_ALLOW_OCTAL (integer)
Allow octal notation (0[0-7]+) in "int" filter.
FILTER_FLAG_ALLOW_HEX (integer)
Allow hex notation (0x[0-9a-fA-F]+) in "int" filter.
FILTER_FLAG_STRIP_LOW (integer)
Strip characters with ASCII value less than 32.
FILTER_FLAG_STRIP_HIGH (integer)
Strip characters with ASCII value greater than 127.
FILTER_FLAG_ENCODE_LOW (integer)
Encode characters with ASCII value less than 32.
FILTER_FLAG_ENCODE_HIGH (integer)
Encode characters with ASCII value greater than 127.
FILTER_FLAG_ENCODE_AMP (integer)
Encode &.
FILTER_FLAG_NO_ENCODE_QUOTES (integer)
Don't encode ' and ".
FILTER_FLAG_EMPTY_STRING_NULL (integer)
(No use for now.)
FILTER_FLAG_ALLOW_FRACTION (integer)
Allow fractional part in "number_float" filter.
FILTER_FLAG_ALLOW_THOUSAND (integer)
Allow thousand separator (,) in "number_float" filter.
FILTER_FLAG_ALLOW_SCIENTIFIC (integer)
Allow scientific notation (e, E) in "number_float" filter.
FILTER_FLAG_PATH_REQUIRED (integer)
Require path in "validate_url" filter.
FILTER_FLAG_QUERY_REQUIRED (integer)
Require query in "validate_url" filter.
FILTER_FLAG_IPV4 (integer)
Allow only IPv4 address in "validate_ip" filter.
FILTER_FLAG_IPV6 (integer)
Allow only IPv6 address in "validate_ip" filter.
FILTER_FLAG_NO_RES_RANGE (integer)
Deny reserved addresses in "validate_ip" filter.
FILTER_FLAG_NO_PRIV_RANGE (integer)
Deny private addresses in "validate_ip" filter.
FILTER_FLAG_EMAIL_UNICODE (integer)
Accepts Unicode characters in the local part in "validate_email" filter. (Available as of PHP 7.1.0)
Filter flags
Örnekler
Filter


Örnekler

İçindekiler

  • Validation
  • Sanitization
Öntanımlı Sabitler
Validation
Filter


Validation

Örnek 1 Validating email addresses with filter_var()

<?php
$email_a = 'joe@example.com';
$email_b = 'bogus';

if (filter_var($email_a, FILTER_VALIDATE_EMAIL)) {
    echo "This ($email_a) email address is considered valid.\n";
}
if (filter_var($email_b, FILTER_VALIDATE_EMAIL)) {
    echo "This ($email_b) email address is considered valid.\n";
} else {
    echo "This ($email_b) email address is considered invalid.\n";
}
?>

Yukarıdaki örneğin çıktısı:

This (joe@example.com) email address is considered valid.
This (bogus) email address is considered invalid.

Örnek 2 Validating IP addresses with filter_var()

<?php
$ip_a = '127.0.0.1';
$ip_b = '42.42';

if (filter_var($ip_a, FILTER_VALIDATE_IP)) {
    echo "This (ip_a) IP address is considered valid.";
}
if (filter_var($ip_b, FILTER_VALIDATE_IP)) {
    echo "This (ip_b) IP address is considered valid.";
}
?>

Yukarıdaki örneğin çıktısı:

This (ip_a) IP address is considered valid.

Örnek 3 Passing options to filter_var()

<?php
$int_a = '1';
$int_b = '-1';
$int_c = '4';
$options = array(
    'options' => array(
                      'min_range' => 0,
                      'max_range' => 3,
                      )
);
if (filter_var($int_a, FILTER_VALIDATE_INT, $options) !== FALSE) {
    echo "This (int_a) integer is considered valid (between 0 and 3).\n";
}
if (filter_var($int_b, FILTER_VALIDATE_INT, $options) !== FALSE) {
    echo "This (int_b) integer is considered valid (between 0 and 3).\n";
}
if (filter_var($int_c, FILTER_VALIDATE_INT, $options) !== FALSE) {
    echo "This (int_c) integer is considered valid (between 0 and 3).\n";
}

$options['options']['default'] = 1;
if (($int_c = filter_var($int_c, FILTER_VALIDATE_INT, $options)) !== FALSE) {
    echo "This (int_c) integer is considered valid (between 0 and 3) and is $int_c.";
}
?>

Yukarıdaki örneğin çıktısı:

This (int_a) integer is considered valid (between 0 and 3).
This (int_c) integer is considered valid (between 0 and 3) and is 1.

Örnekler
Sanitization
Örnekler


Sanitization

Örnek 1 Sanitizing and validating email addresses

<?php
$a = 'joe@example.org';
$b = 'bogus - at - example dot org';
$c = '(bogus@example.org)';

$sanitized_a = filter_var($a, FILTER_SANITIZE_EMAIL);
if (filter_var($sanitized_a, FILTER_VALIDATE_EMAIL)) {
    echo "This (a) sanitized email address is considered valid.\n";
}

$sanitized_b = filter_var($b, FILTER_SANITIZE_EMAIL);
if (filter_var($sanitized_b, FILTER_VALIDATE_EMAIL)) {
    echo "This sanitized email address is considered valid.";
} else {
    echo "This (b) sanitized email address is considered invalid.\n";
}

$sanitized_c = filter_var($c, FILTER_SANITIZE_EMAIL);
if (filter_var($sanitized_c, FILTER_VALIDATE_EMAIL)) {
    echo "This (c) sanitized email address is considered valid.\n";
    echo "Before: $c\n";
    echo "After:  $sanitized_c\n";
}
?>

Yukarıdaki örneğin çıktısı:

This (a) sanitized email address is considered valid.
This (b) sanitized email address is considered invalid.
This (c) sanitized email address is considered valid.
Before: (bogus@example.org)
After: bogus@example.org

Örnek 2 Configuring a default filter

filter.default = full_special_chars
filter.default_flags = 0

Validation
Filter İşlevleri
Örnekler


Filter İşlevleri

İçindekiler

  • filter_has_var — Checks if variable of specified type exists
  • filter_id — Returns the filter ID belonging to a named filter
  • filter_input_array — Gets external variables and optionally filters them
  • filter_input — Gets a specific external variable by name and optionally filters it
  • filter_list — Returns a list of all supported filters
  • filter_var_array — Gets multiple variables and optionally filters them
  • filter_var — Filters a variable with a specified filter
Sanitization
filter_has_var
Filter


Checks if variable of specified type exists

Filter İşlevleri
filter_id
Filter İşlevleri
PHP Manual

filter_has_var

(PHP 5 >= 5.2.0, PHP 7)

filter_has_var — Checks if variable of specified type exists

Açıklama

bool filter_has_var ( int $type , string $variable_name )

Değiştirgeler

type

One of INPUT_GET, INPUT_POST, INPUT_COOKIE, INPUT_SERVER, or INPUT_ENV.

variable_name

Name of a variable to check.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Filter İşlevleri
filter_id
Filter İşlevleri


Returns the filter ID belonging to a named filter

filter_has_var
filter_input_array
Filter İşlevleri
PHP Manual

filter_id

(PHP 5 >= 5.2.0, PHP 7)

filter_id — Returns the filter ID belonging to a named filter

Açıklama

int filter_id ( string $filtername )

Değiştirgeler

filtername

Name of a filter to get.

Dönen Değerler

ID of a filter on success or FALSE if filter doesn't exist.

Ayrıca Bakınız

  • filter_list() - Returns a list of all supported filters

filter_has_var
filter_input_array
Filter İşlevleri


Gets external variables and optionally filters them

filter_id
filter_input
Filter İşlevleri
PHP Manual

filter_input_array

(PHP 5 >= 5.2.0, PHP 7)

filter_input_array — Gets external variables and optionally filters them

Açıklama

mixed filter_input_array ( int $type [, mixed $definition [, bool $add_empty = true ]] )

This function is useful for retrieving many values without repetitively calling filter_input().

Değiştirgeler

type

One of INPUT_GET, INPUT_POST, INPUT_COOKIE, INPUT_SERVER, or INPUT_ENV.

definition

An array defining the arguments. A valid key is a string containing a variable name and a valid value is either a filter type, or an array optionally specifying the filter, flags and options. If the value is an array, valid keys are filter which specifies the filter type, flags which specifies any flags that apply to the filter, and options which specifies any options that apply to the filter. See the example below for a better understanding.

This parameter can be also an integer holding a filter constant. Then all values in the input array are filtered by this filter.

add_empty

Add missing keys as NULL to the return value.

Dönen Değerler

An array containing the values of the requested variables on success, or FALSE on failure. An array value will be FALSE if the filter fails, or NULL if the variable is not set. Or if the flag FILTER_NULL_ON_FAILURE is used, it returns FALSE if the variable is not set and NULL if the filter fails.

Örnekler

Örnek 1 A filter_input_array() example

<?php
error_reporting(E_ALL | E_STRICT);
/* data actually came from POST
$_POST = array(
    'product_id'    => 'libgd<script>',
    'component'     => '10',
    'versions'      => '2.0.33',
    'testscalar'    => array('2', '23', '10', '12'),
    'testarray'     => '2',
);
*/

$args = array(
    'product_id'   => FILTER_SANITIZE_ENCODED,
    'component'    => array('filter'    => FILTER_VALIDATE_INT,
                            'flags'     => FILTER_REQUIRE_ARRAY,
                            'options'   => array('min_range' => 1, 'max_range' => 10)
                           ),
    'versions'     => FILTER_SANITIZE_ENCODED,
    'doesnotexist' => FILTER_VALIDATE_INT,
    'testscalar'   => array(
                            'filter' => FILTER_VALIDATE_INT,
                            'flags'  => FILTER_REQUIRE_SCALAR,
                           ),
    'testarray'    => array(
                            'filter' => FILTER_VALIDATE_INT,
                            'flags'  => FILTER_REQUIRE_ARRAY,
                           )

);

$myinputs = filter_input_array(INPUT_POST, $args);

var_dump($myinputs);
echo "\n";
?>

Yukarıdaki örneğin çıktısı:

array(6) {
  ["product_id"]=>
  string(17) "libgd%3Cscript%3E"
  ["component"]=>
  array(1) {
    [0]=>
    int(10)
  }
  ["versions"]=>
  string(6) "2.0.33"
  ["doesnotexist"]=>
  NULL
  ["testscalar"]=>
  bool(false)
  ["testarray"]=>
  array(1) {
    [0]=>
    int(2)
  }
}

Sürüm Bilgisi

Sürüm: | Açıklama
5.4.0 | Added add_empty parameter.

Notlar

Bilginize:

There is no REQUEST_TIME key in INPUT_SERVER array because it is inserted into the $_SERVER later.

Ayrıca Bakınız

  • filter_input() - Gets a specific external variable by name and optionally filters it
  • filter_var_array() - Gets multiple variables and optionally filters them
  • Types of filters

filter_id
filter_input
Filter İşlevleri


Gets a specific external variable by name and optionally filters it

filter_input_array
filter_list
Filter İşlevleri
PHP Manual

filter_input

(PHP 5 >= 5.2.0, PHP 7)

filter_input — Gets a specific external variable by name and optionally filters it

Açıklama

mixed filter_input ( int $type , string $variable_name [, int $filter = FILTER_DEFAULT [, mixed $options ]] )

Değiştirgeler

type

One of INPUT_GET, INPUT_POST, INPUT_COOKIE, INPUT_SERVER, or INPUT_ENV.

variable_name

Name of a variable to get.

filter

The ID of the filter to apply. The Types of filters manual page lists the available filters.

If omitted, FILTER_DEFAULT will be used, which is equivalent to FILTER_UNSAFE_RAW. This will result in no filtering taking place by default.

options

Associative array of options or bitwise disjunction of flags. If filter accepts options, flags can be provided in "flags" field of array.

Dönen Değerler

Value of the requested variable on success, FALSE if the filter fails, or NULL if the variable_name variable is not set. If the flag FILTER_NULL_ON_FAILURE is used, it returns FALSE if the variable is not set and NULL if the filter fails.

Örnekler

Örnek 1 A filter_input() example

<?php
$search_html = filter_input(INPUT_GET, 'search', FILTER_SANITIZE_SPECIAL_CHARS);
$search_url = filter_input(INPUT_GET, 'search', FILTER_SANITIZE_ENCODED);
echo "You have searched for $search_html.\n";
echo "<a href='?search=$search_url'>Search again.</a>";
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

You have searched for Me &#38; son.
<a href='?search=Me%20%26%20son'>Search again.</a>

Ayrıca Bakınız

  • filter_var() - Filters a variable with a specified filter
  • filter_input_array() - Gets external variables and optionally filters them
  • filter_var_array() - Gets multiple variables and optionally filters them
  • Types of filters

filter_input_array
filter_list
Filter İşlevleri


Returns a list of all supported filters

filter_input
filter_var_array
Filter İşlevleri
PHP Manual

filter_list

(PHP 5 >= 5.2.0, PHP 7)

filter_list — Returns a list of all supported filters

Açıklama

array filter_list ( void )

Dönen Değerler

Returns an array of names of all supported filters, empty array if there are no such filters. Indexes of this array are not filter IDs, they can be obtained with filter_id() from a name instead.

Örnekler

Örnek 1 A filter_list() example

<?php
print_r(filter_list());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [0] => int
    [1] => boolean
    [2] => float
    [3] => validate_regexp
    [4] => validate_url
    [5] => validate_email
    [6] => validate_ip
    [7] => string
    [8] => stripped
    [9] => encoded
    [10] => special_chars
    [11] => unsafe_raw
    [12] => email
    [13] => url
    [14] => number_int
    [15] => number_float
    [16] => magic_quotes
    [17] => callback
)

filter_input
filter_var_array
Filter İşlevleri


Gets multiple variables and optionally filters them

filter_list
filter_var
Filter İşlevleri
PHP Manual

filter_var_array

(PHP 5 >= 5.2.0, PHP 7)

filter_var_array — Gets multiple variables and optionally filters them

Açıklama

mixed filter_var_array ( array $data [, mixed $definition [, bool $add_empty = true ]] )

This function is useful for retrieving many values without repetitively calling filter_var().

Değiştirgeler

data

An array with string keys containing the data to filter.

definition

An array defining the arguments. A valid key is a string containing a variable name and a valid value is either a filter type, or an array optionally specifying the filter, flags and options. If the value is an array, valid keys are filter which specifies the filter type, flags which specifies any flags that apply to the filter, and options which specifies any options that apply to the filter. See the example below for a better understanding.

This parameter can be also an integer holding a filter constant. Then all values in the input array are filtered by this filter.

add_empty

Add missing keys as NULL to the return value.

Dönen Değerler

An array containing the values of the requested variables on success, or FALSE on failure. An array value will be FALSE if the filter fails, or NULL if the variable is not set.

Örnekler

Örnek 1 A filter_var_array() example

<?php
error_reporting(E_ALL | E_STRICT);
$data = array(
    'product_id'    => 'libgd<script>',
    'component'     => '10',
    'versions'      => '2.0.33',
    'testscalar'    => array('2', '23', '10', '12'),
    'testarray'     => '2',
);

$args = array(
    'product_id'   => FILTER_SANITIZE_ENCODED,
    'component'    => array('filter'    => FILTER_VALIDATE_INT,
                            'flags'     => FILTER_FORCE_ARRAY,
                            'options'   => array('min_range' => 1, 'max_range' => 10)
                           ),
    'versions'     => FILTER_SANITIZE_ENCODED,
    'doesnotexist' => FILTER_VALIDATE_INT,
    'testscalar'   => array(
                            'filter' => FILTER_VALIDATE_INT,
                            'flags'  => FILTER_REQUIRE_SCALAR,
                           ),
    'testarray'    => array(
                            'filter' => FILTER_VALIDATE_INT,
                            'flags'  => FILTER_FORCE_ARRAY,
                           )

);

$myinputs = filter_var_array($data, $args);

var_dump($myinputs);
echo "\n";
?>

Yukarıdaki örneğin çıktısı:

array(6) {
  ["product_id"]=>
  string(17) "libgd%3Cscript%3E"
  ["component"]=>
  array(1) {
    [0]=>
    int(10)
  }
  ["versions"]=>
  string(6) "2.0.33"
  ["doesnotexist"]=>
  NULL
  ["testscalar"]=>
  bool(false)
  ["testarray"]=>
  array(1) {
    [0]=>
    int(2)
  }
}

Sürüm Bilgisi

Sürüm: | Açıklama
5.4.0 | Added add_empty parameter.

Ayrıca Bakınız

  • filter_input_array() - Gets external variables and optionally filters them
  • filter_var() - Filters a variable with a specified filter
  • filter_input() - Gets a specific external variable by name and optionally filters it
  • Types of filters

filter_list
filter_var
Filter İşlevleri


Filters a variable with a specified filter

filter_var_array
İşlevlerle İlgili İşlemler
Filter İşlevleri
PHP Manual

filter_var

(PHP 5 >= 5.2.0, PHP 7)

filter_var — Filters a variable with a specified filter

Açıklama

mixed filter_var ( mixed $variable [, int $filter = FILTER_DEFAULT [, mixed $options ]] )

Değiştirgeler

variable

Value to filter. Note that scalar values are converted to string internally before they are filtered.

filter

The ID of the filter to apply. The Types of filters manual page lists the available filters.

If omitted, FILTER_DEFAULT will be used, which is equivalent to FILTER_UNSAFE_RAW. This will result in no filtering taking place by default.

options

Associative array of options or bitwise disjunction of flags. If filter accepts options, flags can be provided in "flags" field of array. For the "callback" filter, callable type should be passed. The callback must accept one argument, the value to be filtered, and return the value after filtering/sanitizing it.

<?php
// for filters that accept options, use this format
$options = array(
    'options' => array(
        'default' => 3, // value to return if the filter fails
        // other options here
        'min_range' => 0
    ),
    'flags' => FILTER_FLAG_ALLOW_OCTAL,
);
$var = filter_var('0755', FILTER_VALIDATE_INT, $options);

// for filter that only accept flags, you can pass them directly
$var = filter_var('oops', FILTER_VALIDATE_BOOLEAN, FILTER_NULL_ON_FAILURE);

// for filter that only accept flags, you can also pass as an array
$var = filter_var('oops', FILTER_VALIDATE_BOOLEAN,
                  array('flags' => FILTER_NULL_ON_FAILURE));

// callback validate filter
function foo($value)
{
    // Expected format: Surname, GivenNames
    if (strpos($value, ", ") === false) return false;
    list($surname, $givennames) = explode(", ", $value, 2);
    $empty = (empty($surname) || empty($givennames));
    $notstrings = (!is_string($surname) || !is_string($givennames));
    if ($empty || $notstrings) {
        return false;
    } else {
        return $value;
    }
}
$var = filter_var('Doe, Jane Sue', FILTER_CALLBACK, array('options' => 'foo'));
?>

Dönen Değerler

Returns the filtered data, or FALSE if the filter fails.

Örnekler

Örnek 1 A filter_var() example

<?php
var_dump(filter_var('bob@example.com', FILTER_VALIDATE_EMAIL));
var_dump(filter_var('http://example.com', FILTER_VALIDATE_URL, FILTER_FLAG_PATH_REQUIRED));
?>

Yukarıdaki örneğin çıktısı:

string(15) "bob@example.com"
bool(false)

Ayrıca Bakınız

  • filter_var_array() - Gets multiple variables and optionally filters them
  • filter_input() - Gets a specific external variable by name and optionally filters it
  • filter_input_array() - Gets external variables and optionally filters them
  • Types of filters
  • callback türü hakkında bilgi

filter_var_array
İşlevlerle İlgili İşlemler
Filter İşlevleri


İşlevlerle İlgili İşlemler

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • İşlevlerle İlgili İşlevler
    • call_user_func_array — Değiştirgelerin bir dizi olarak verildiği kullanıcı işlevini çağırır
    • call_user_func — İlk değiştirgede belirtilen kullanıcı işlevini çağırır
    • create_function — Bir anonim (lamda tarzı) işlev oluşturur
    • forward_static_call_array — Call a static method and pass the arguments as array
    • forward_static_call — Call a static method
    • func_get_arg — Değiştirge listesinden bir üyeyi döndürür
    • func_get_args — İşleve aktarılan değiştirgelerin listesini dizi olarak döndürür
    • func_num_args — İşleve aktarılan değiştirge sayısını döndürür
    • function_exists — Eğer işlev tanımlanmış ise TRUE döndürür
    • get_defined_functions — Tanımlanmış bütün işlevleri içeren bir dizi döndürür
    • register_shutdown_function — Betiğin işi bittiğinde çalıştırılacak işlevi tanımlar
    • register_tick_function — Her tikte çalıştırılacak işlevi tanımlar
    • unregister_tick_function — Her tikte çalıştırılacak işlevi tanımsız yapar
filter_var
Giriş
Değişkenler ve Veri Türleriyle İlgili Eklentiler


Giriş

Bütün bu işlevler, işlevlerle çalışırken gereken çeşitli işlemleri yaparlar.

İşlevlerle İlgili İşlemler
Yapılandırma/Kurulum
İşlevlerle İlgili İşlemler


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
İşlevlerle İlgili İşlemler


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
İşlevlerle İlgili İşlevler
İşlevlerle İlgili İşlemler


İşlevlerle İlgili İşlevler

İçindekiler

  • call_user_func_array — Değiştirgelerin bir dizi olarak verildiği kullanıcı işlevini çağırır
  • call_user_func — İlk değiştirgede belirtilen kullanıcı işlevini çağırır
  • create_function — Bir anonim (lamda tarzı) işlev oluşturur
  • forward_static_call_array — Call a static method and pass the arguments as array
  • forward_static_call — Call a static method
  • func_get_arg — Değiştirge listesinden bir üyeyi döndürür
  • func_get_args — İşleve aktarılan değiştirgelerin listesini dizi olarak döndürür
  • func_num_args — İşleve aktarılan değiştirge sayısını döndürür
  • function_exists — Eğer işlev tanımlanmış ise TRUE döndürür
  • get_defined_functions — Tanımlanmış bütün işlevleri içeren bir dizi döndürür
  • register_shutdown_function — Betiğin işi bittiğinde çalıştırılacak işlevi tanımlar
  • register_tick_function — Her tikte çalıştırılacak işlevi tanımlar
  • unregister_tick_function — Her tikte çalıştırılacak işlevi tanımsız yapar
Öntanımlı Sabitler
call_user_func_array
İşlevlerle İlgili İşlemler


Değiştirgelerin bir dizi olarak verildiği kullanıcı işlevini çağırır

İşlevlerle İlgili İşlevler
call_user_func
İşlevlerle İlgili İşlevler
PHP Manual

call_user_func_array

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

call_user_func_array — Değiştirgelerin bir dizi olarak verildiği kullanıcı işlevini çağırır

Açıklama

mixed call_user_func_array ( callback $işlev , array $değiştirge_dizisi )

değiştirge_dizisi içindeki değiştirgeleri kullanarak kullanıcının tanımladığı işlev işlevini çağırır.

Değiştirgeler

işlev

Çağrılacak işlev.

değiştirge_dizisi

İşleve aktarılacak indisli dizi şeklinde değiştirgeler.

Dönen Değerler

Bir hata oluşmamışsa işlevin sonucunu, aksi takdirde FALSE döndürür.

Örnekler

Örnek 1 - call_user_func_array() örneği

<?php
function foobar($arg, $arg2) {
    echo __FUNCTION__, " got $arg and $arg2\n";
}

class foo {
    function bar($arg, $arg2) {
        echo __METHOD__, " got $arg and $arg2\n";
    }
}
// foobar() işlevini iki değiştirge ile çağıralım
call_user_func_array("foobar", array("one", "two"));

// $foo->bar() yöntemini iki değiştirge ile çağıralım
$foo = new foo;
call_user_func_array(array($foo, "bar"), array("three", "four"));

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

foobar got one and two
foo::bar got three and four

Örnek 2 - İsim alanı ismi kullanarak call_user_func_array()

<?php

namespace Mesela;

class Misal {
    static public function dnm($isim) {
        print "Merhaba {$isim}!\n";
    }
}

// PHP 5.3.0 ve sonrası
call_user_func_array(__NAMESPACE__ .'\Misal\dnm', array('Ozan'));

// PHP 5.3.0 ve sonrası
call_user_func_array(array(__NAMESPACE__ .'\Misal', 'dnm'), array('Özgür'));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Merhaba Ozan!
Merhaba Özgür!

Örnek 3 - Lamda işlevi kullanımı

<?php

$işlev = function($dğş1, $dğş2) {
    return $dğş1 * $dğş2;
};

var_dump(call_user_func_array($işlev, array(2, 4))); /* PHP 5.3.0 ve sonrası */
?>

Yukarıdaki örneğin çıktısı:

int(8)

Notlar

Bilginize:

değiştirge_dizisi içindeki gönderimli değiştirgeler işleve gönderimli aktarılır, diğerleri ise değerleriyle aktarılır. Başka bir deyişle değiştirgenin değeriyle mi yoksa gönderimli olarak mı aktarılacağı işlevin nasıl tanımlandığı ile ilgili değildir.

Ayrıca Bakınız

  • call_user_func() - İlk değiştirgede belirtilen kullanıcı işlevini çağırır
  • callback türü hakkında bilgi

İşlevlerle İlgili İşlevler
call_user_func
İşlevlerle İlgili İşlevler


İlk değiştirgede belirtilen kullanıcı işlevini çağırır

call_user_func_array
create_function
İşlevlerle İlgili İşlevler
PHP Manual

call_user_func

(PHP 4, PHP 5, PHP 7)

call_user_func — İlk değiştirgede belirtilen kullanıcı işlevini çağırır

Açıklama

mixed call_user_func ( callback $işlev [, mixed $değiştirge [, mixed $... ]] )

işlev değiştirgesi ile belirtilen kullanıcı tanımlı işlevi çağırır.

Değiştirgeler

işlev

Çağırılacak işlev. Ayrıca, bu değiştirgede bir nesne örneğinin sınıf yöntemlerinin, array($sınıfadı, $yöntemadı) biçiminde belirtilmek suretiyle çağrılması da mümkündür.

değiştirge

İşleve sıfır veya daha fazla sayıda değiştirge aktarılabilir.

Bilginize:

call_user_func() işlevi gönderimli değiştirgeleri aktarmaz.

Örnek 1 - call_user_func() örneği ve gönderimler

<?php
error_reporting(E_ALL);

function say(&$sayı)
{
    $sayı++;
}

$a = 0;
call_user_func('say', $a);
echo $a."\n";

call_user_func_array('say', array(&$a)); // PHP 5.3 öncesinde bunu kullanın
echo $a."\n";
?>

Yukarıdaki örneğin çıktısı:

0
1

Dönen Değerler

Hata oluşmamışsa işlevin sonucunu aksi takdirde FALSE döndürür.

Örnekler

Örnek 2 - call_user_func() örneği

<?php
function berber($tür)
{
    echo "Demek $tür kesimi istiyorsunuz, sorun yok.\n";
}
call_user_func('berber', "saç");
call_user_func('berber', "sakal");
?>

Yukarıdaki örneğin çıktısı:

Demek saç kesimi istiyorsunuz, sorun yok.
Demek sakal kesimi istiyorsunuz, sorun yok.

Örnek 3 - İsim alanı ismi kullanarak call_user_func()

<?php

namespace Mesela;

class Misal {
    static public function dnm() {
        print "Merhaba Dünyalı!\n";
    }
}

// PHP 5.3.0 ve sonrası
call_user_func(__NAMESPACE__ .'\Misal\dnm');

// PHP 5.3.0 ve sonrası
call_user_func(array(__NAMESPACE__ .'\Misal', 'dnm'));

?>

Yukarıdaki örneğin çıktısı:

Merhaba Dünyalı!
Merhaba Dünyalı!

Örnek 4 - Sınıf yöntemi kullanarak call_user_func()

<?php

class Sınıfım {
    static function selam_ver()
    {
        echo "Merhaba!\n";
    }
}

$sınıf = "Sınıfım";

call_user_func(array($sınıf, 'selam_ver'));
call_user_func($sınıf .'::selam_ver'); // PHP 5.2.3 ve sonrası

$nesne = new Sınıfım();

call_user_func(array($nesne, 'selam_ver'));

?>

Yukarıdaki örneğin çıktısı:

Merhaba!
Merhaba!
Merhaba!

Örnek 5 - Lamda işlevi kullanarak call_user_func()

<?php
// PHP 5.3.0 ve sonrası
call_user_func(function($arg) { print "[$arg]\n"; }, 'test');
?>

Yukarıdaki örneğin çıktısı:

[test]

Ayrıca Bakınız

  • call_user_func_array() - Değiştirgelerin bir dizi olarak verildiği kullanıcı işlevini çağırır
  • is_callable() - Bir değişkenin içeriğinin bir işlev olarak çağrılabilirliğini doğrular
  • callback türü hakkında bilgi

call_user_func_array
create_function
İşlevlerle İlgili İşlevler


Bir anonim (lamda tarzı) işlev oluşturur

call_user_func
forward_static_call_array
İşlevlerle İlgili İşlevler
PHP Manual

create_function

(PHP 4 >= 4.0.1, PHP 5, PHP 7)

create_function — Bir anonim (lamda tarzı) işlev oluşturur

Açıklama

string create_function ( string $değiştirgeler , string $kod )

Verilen değiştirgelerden isimsiz bir işlev oluşturur ve onun için eşsiz bir isim döndürür.

Değiştirgeler

Genellikle bu değiştirgeler tek tırnaklar arasına alınmış bir dizge ile işleve aktarılır. Tek tırnak kullanılmasının nedeni değişken isimlerini çözümleme işleminden korumaktır. Çift tırnak kullanırsanız, değişken adlarını \$avar örneğinde olduğu öncelemeniz gerekecektir.

değiştirgeler

İşlevin değiştirgeleri.

kod

İşlevin kodu.

Dönen Değerler

Hata oluşmamışsa bir dizge olarak işleve eşsiz bir isim, aksi takdirde FALSE döndürür.

Örnekler

Örnek 1 - create_function() ile isimsiz işlev oluşturmak

Bu işlevi, çalışma anında toplanan bilgileri kullanarak yeni bir işlev oluşturmak için kullanabilirsiniz.

<?php
$işlev = create_function('$a,$b', 'return "ln($a) + ln($b) = " . log($a * $b);');
echo "Yeni bir isimsiz işlev: $işlev\n";
echo $işlev(2, M_E) . "\n";
// Çıktısı:
// Yeni bir isimsiz işlev: lambda_1
// ln(2) + ln(2.718281828459) = 1.6931471805599
?>

Belki, bir değiştirge listesi üzerinde belli işlemler yapan bir genel işlem işlevi tercih edersiniz:

Örnek 2 - create_function() işlevi ile bir genel işlem işlevi oluşturmak

<?php
function process($var1, $var2, $farr)
{
    foreach ($farr as $f) {
        echo $f($var1, $var2) . "\n";
    }
}

// Birkaç matematik işlevi oluşturalım
$f1 = 'if ($a >=0) {return "b*a^2 = ".$b*sqrt($a);} else {return false;}';
$f2 = "return \"min(b^2+a, a^2,b) = \".min(\$a*\$a+\$b,\$b*\$b+\$a);";
$f3 = 'if ($a > 0 && $b != 0) {return "ln(a)/b = ".log($a)/$b; } else { return false; }';
$farr = array(
    create_function('$x,$y', 'return "biraz trig: ".(sin($x) + $x*cos($y));'),
    create_function('$x,$y', 'return "bir hipotenüs: ".sqrt($x*$x + $y*$y);'),
    create_function('$a,$b', $f1),
    create_function('$a,$b', $f2),
    create_function('$a,$b', $f3)
    );

echo "\nİlk isimsiz işlev grubumuz\n";
echo "değiştirgeler: 2.3445, M_PI\n";
process(2.3445, M_PI, $farr);

// birkaç tane de dizge işlevi oluşturalım
$garr = array(
    create_function('$b,$a', 'if (strncmp($a, $b, 3) == 0) return "** \"$a\" '.
    've \"$b\"\n** (ilk üç karaktere bakarak) Bak bu ikisi aynı!";'),
    create_function('$a,$b', '; return "CRC\'ler: " . crc32($a) . ", ".crc32(b);'),
    create_function('$a,$b', '; return "benzerlik(a,b) = " . similar_text($a, $b, &$p) . "(%$p)";')
    );
echo "\nİkinci isimsiz işlev grubumuz\n";
process("Gün yavaş yavaş ışıyordu", "Gün aydınlanıyordu", $garr);
?>

Yukarıdaki örneğin çıktısı:

İlk isimsiz işlev grubumuz
değiştirgeler: 2.3445, M_PI
biraz trig: -1.6291725057799
bir hipotenüs: 3.9199852871011
b*a^2 = 4.8103313314525
min(b^2+a, a^2,b) = 8.6382729035898
ln(a)/b = 0.27122299212594

İkinci isimsiz işlev grubumuz
** "Gün aydınlanıyordu" ve "Gün yavaş yavaş ışıyordu"
** (ilk üç karaktere bakarak) Bak bu ikisi aynı!
CRC'ler: 2226456759, 1908338681
benzerlik(a,b) = 15(%58.823529411765)

Şüphesiz, lamda tarzı (isimsiz) işlevlerin asıl kullanım amacı geriçağırım işlevleri oluşturmaktır. array_walk() ve usort() işlevlerini kullanan örnekler:

Örnek 3 - İsimsiz işlevlerin geriçağırım işlevlerinde kullanımı

<?php

$av = array("işte ", "bir ", "bu ", "şu ");
array_walk($av, create_function('&$v,$k', '$v = $v . "mango";'));
print_r($av);

?>

Yukarıdaki örneğin çıktısı:

Array
(
    [0] => işte mango
    [1] => bir mango
    [2] => bu mango
    [3] => şu mango
)

Kısadan uzuna sıralanmış dizgelerden oluşan bir dizi:

<?php

$sv = array("kısa", "daha uzun", "daha da uzun", "daha daha uzun");
print_r($sv);

?>

Yukarıdaki örneğin çıktısı:

Array
(
    [0] => kısa
    [1] => daha uzun
    [2] => daha da uzun
    [3] => daha daha uzun
)

Şimdi uzundan kısaya doğru sıralayalım:

<?php

usort($sv, create_function('$a,$b','return strlen($b) - strlen($a);'));
print_r($sv);

?>

Yukarıdaki örneğin çıktısı:

(
    [0] => daha daha uzun
    [1] => daha da uzun
    [2] => daha uzun
    [3] => kısa
)

Ayrıca Bakınız

  • Anonim işlevler

call_user_func
forward_static_call_array
İşlevlerle İlgili İşlevler


Call a static method and pass the arguments as array

create_function
forward_static_call
İşlevlerle İlgili İşlevler
PHP Manual

forward_static_call_array

(PHP 5 >= 5.3.0, PHP 7)

forward_static_call_array — Call a static method and pass the arguments as array

Açıklama

mixed forward_static_call_array ( callable $function , array $parameters )

Calls a user defined function or method given by the function parameter. This function must be called within a method context, it can't be used outside a class. It uses the late static binding. All arguments of the forwarded method are passed as values, and as an array, similarly to call_user_func_array().

Değiştirgeler

function

The function or method to be called. This parameter may be an array, with the name of the class, and the method, or a string, with a function name.

parameter

One parameter, gathering all the method parameter in one array.

Bilginize:

Note that the parameters for forward_static_call_array() are not passed by reference.

Dönen Değerler

Returns the function result, or FALSE on error.

Örnekler

Örnek 1 forward_static_call_array() example

<?php

class A
{
    const NAME = 'A';
    public static function test() {
        $args = func_get_args();
        echo static::NAME, " ".join(',', $args)." \n";
    }
}

class B extends A
{
    const NAME = 'B';

    public static function test() {
        echo self::NAME, "\n";
        forward_static_call_array(array('A', 'test'), array('more', 'args'));
        forward_static_call_array( 'test', array('other', 'args'));
    }
}

B::test('foo');

function test() {
        $args = func_get_args();
        echo "C ".join(',', $args)." \n";
    }

?>

Yukarıdaki örneğin çıktısı:

B
B more,args
C other,args

Ayrıca Bakınız

  • forward_static_call() - Call a static method
  • call_user_func() - İlk değiştirgede belirtilen kullanıcı işlevini çağırır
  • call_user_func_array() - Değiştirgelerin bir dizi olarak verildiği kullanıcı işlevini çağırır
  • is_callable() - Bir değişkenin içeriğinin bir işlev olarak çağrılabilirliğini doğrular
  • callback türü hakkında bilgi

create_function
forward_static_call
İşlevlerle İlgili İşlevler


Call a static method

forward_static_call_array
func_get_arg
İşlevlerle İlgili İşlevler
PHP Manual

forward_static_call

(PHP 5 >= 5.3.0, PHP 7)

forward_static_call — Call a static method

Açıklama

mixed forward_static_call ( callable $function [, mixed $parameter [, mixed $... ]] )

Calls a user defined function or method given by the function parameter, with the following arguments. This function must be called within a method context, it can't be used outside a class. It uses the late static binding.

Değiştirgeler

function

The function or method to be called. This parameter may be an array, with the name of the class, and the method, or a string, with a function name.

parameter

Zero or more parameters to be passed to the function.

Dönen Değerler

Returns the function result, or FALSE on error.

Örnekler

Örnek 1 forward_static_call() example

<?php

class A
{
    const NAME = 'A';
    public static function test() {
        $args = func_get_args();
        echo static::NAME, " ".join(',', $args)." \n";
    }
}

class B extends A
{
    const NAME = 'B';

    public static function test() {
        echo self::NAME, "\n";
        forward_static_call(array('A', 'test'), 'more', 'args');
        forward_static_call( 'test', 'other', 'args');
    }
}

B::test('foo');

function test() {
        $args = func_get_args();
        echo "C ".join(',', $args)." \n";
    }

?>

Yukarıdaki örneğin çıktısı:

B
B more,args
C other,args

Ayrıca Bakınız

  • forward_static_call_array() - Call a static method and pass the arguments as array
  • call_user_func_array() - Değiştirgelerin bir dizi olarak verildiği kullanıcı işlevini çağırır
  • call_user_func() - İlk değiştirgede belirtilen kullanıcı işlevini çağırır
  • is_callable() - Bir değişkenin içeriğinin bir işlev olarak çağrılabilirliğini doğrular
  • callback türü hakkında bilgi

forward_static_call_array
func_get_arg
İşlevlerle İlgili İşlevler


Değiştirge listesinden bir üyeyi döndürür

forward_static_call
func_get_args
İşlevlerle İlgili İşlevler
PHP Manual

func_get_arg

(PHP 4, PHP 5, PHP 7)

func_get_arg — Değiştirge listesinden bir üyeyi döndürür

Açıklama

mixed func_get_arg ( int $dğş_num )

Kullanıcı tanımlı işlevin değiştirge listesinden belirli bir değiştirgeyi getirir.

Bu işlev kullanıcı tanımlı işlevlerin değişken sayıda değiştirge kabul edebilmesini sağlamak için func_get_args() ve func_num_args() ile birlikte kullanılabilir.

Değiştirgeler

dğş_num

Değiştirgenin konumu. İşlevin değiştirgeleri sıfırdan sayılmaya başlanır.

Dönen Değerler

Hata oluşmamışsa konumu belirtilen değiştirgeyi, aksi takdirde FALSE döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | Bu işlev artık değiştirge listelerinde kullanılabilmektedir.
5.3.0 | Bu işlev, çağrının yapıldığı dosyadaki bir işlev tanımında bulunan bir include veya require üzerinden dosyaya dahil edilen bir dosyadan yani, asıl dosyanın etki alanının dışından) çağrılırsa artık bir uyarı üretip FALSE döndürmektedir.

Hatalar/İstisnalar

Eğer kullanıcı tanımlı bir işlevin dışında çağrılırsa veya dğş_num gerçekten aktarılan değiştirge sayısından büyük ise uyarı oluşturur.

Örnekler

Örnek 1 - func_get_arg() örneği

<?php
function işlev()
{
    $dğşsayısı = func_num_args();
    echo "Değiştirge sayısı: $dğşsayısı<br />\n";
    if ($dğşsayısı >= 2) {
        echo "İkinci değiştirge: " . func_get_arg(1) . "<br />\n";
    }
}

işlev(1, 2, 3);
?>

Örnek 2 - PHP 5.3 sonrası func_get_arg()örneği

test.php
<?php
function foo() {
    include './fga.inc';
}

foo('First arg', 'Second arg');
?>

fga.php
<?php

$arg = func_get_arg1(1);
var_export($arg);

?>

PHP 5.3 öncesi için çıktı:

'Second arg'

PHP 5.3 ve sonrası için çıktı:

Warning: func_get_arg():  Called from the global scope - no function
context in /home/torben/Desktop/code/ml/fga.inc on line 3
false

Notlar

Bilginize:

Bu işlev değiştirge ayrıntılarını saptamak için mevcut etki alanına bağımlı olduğundan bir işlev değiştirgesi olarak kullanılamaz. Eğer bu değerin aktarılması gerekli ise sonuçlar bir değişkene atanmalı ve bu değişken aktarılmalıdır.

Bilginize: Bu işlev sadece işleve aktarılan değiştirgelerden birini döndürür ve öntanımlı (aktarılmayan) değiştirgeleri hesaba katmaz.

Ayrıca Bakınız

  • func_get_args() - İşleve aktarılan değiştirgelerin listesini dizi olarak döndürür
  • func_num_args() - İşleve aktarılan değiştirge sayısını döndürür

forward_static_call
func_get_args
İşlevlerle İlgili İşlevler


İşleve aktarılan değiştirgelerin listesini dizi olarak döndürür

func_get_arg
func_num_args
İşlevlerle İlgili İşlevler
PHP Manual

func_get_args

(PHP 4, PHP 5, PHP 7)

func_get_args — İşleve aktarılan değiştirgelerin listesini dizi olarak döndürür

Açıklama

array func_get_args ( void )

İşlevin değiştirge listesini bir dizi olarak döndürür.

Bu işlev kullanıcı tanımlı işlevlerin değişken sayıda değiştirge kabul edebilmesini sağlamak için func_get_arg() ve func_num_args() ile birlikte kullanılabilir.

Dönen Değerler

Her elemanı, mevcut kullanıcı tanımlı işlevin değiştirge listesinin birer kopyası olan bir dizi döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | Bu işlev artık değiştirge listelerinde kullanılabilmektedir.
5.3.0 | Bu işlev, çağrının yapıldığı dosyadaki bir işlev tanımında bulunan bir include veya require üzerinden dosyaya dahil edilen bir dosyadan yani, asıl dosyanın etki alanının dışından) çağrılırsa artık bir uyarı üretip FALSE döndürmektedir.

Hatalar/İstisnalar

Eğer kullanıcı tanımlı işlevin dışından çağrılırsa uyarı oluşturur.

Örnekler

Örnek 1 - func_get_args() örneği

<?php
function işlev()
{
    $dğşsayısı = func_num_args();
    echo "Değiştirge sayısı: $dğşsayısı<br />\n";
    if ($dğşsayısı >= 2) {
        echo "İkinci değiştirge: " . func_get_arg(1) . "<br />\n";
    }
    $dğş_listesi = func_get_args();
    for ($i = 0; $i < $dğşsayısı; $i++) {
        echo "$i. değiştirge: " . $dğş_listesi[$i] . "<br />\n";
    }
}

işlev(1, 2, 3);
?>

Yukarıdaki örneğin çıktısı:

Değiştirge sayısı: 3<br />
İkinci değiştirge: 2<br />
0. değiştirge: 1<br />
1. değiştirge: 2<br />
2. değiştirge: 3<br />

Örnek 2 - PHP 5.3 sonrası func_get_arg()örneği

test.php
<?php
function foo() {
    include './fga.inc';
}

foo('First arg', 'Second arg');
?>

fga.inc
<?php

$arg = func_get_arg1(1);
var_export($arg);

?>

PHP 5.3 öncesi için çıktı:

'Second arg'

PHP 5.3 ve sonrası için çıktı:

Warning: func_get_arg():  Called from the global scope - no function
context in /home/torben/Desktop/code/ml/fga.inc on line 3
false

Notlar

Bilginize:

Bu işlev değiştirge ayrıntılarını saptamak için mevcut etki alanına bağımlı olduğundan bir işlev değiştirgesi olarak kullanılamaz. Eğer bu değerin aktarılması gerekli ise sonuçlar bir değişkene atanmalı ve bu değişken aktarılmalıdır.

Bilginize: Bu işlev sadece işleve aktarılan değiştirgeleri döndürür ve öntanımlı (aktarılmayan) değiştirgeleri hesaba katmaz.

Ayrıca Bakınız

  • func_get_arg() - Değiştirge listesinden bir üyeyi döndürür
  • func_num_args() - İşleve aktarılan değiştirge sayısını döndürür

func_get_arg
func_num_args
İşlevlerle İlgili İşlevler


İşleve aktarılan değiştirge sayısını döndürür

func_get_args
function_exists
İşlevlerle İlgili İşlevler
PHP Manual

func_num_args

(PHP 4, PHP 5, PHP 7)

func_num_args — İşleve aktarılan değiştirge sayısını döndürür

Açıklama

int func_num_args ( void )

İşleve aktarılan değiştirge sayısını elde eder.

Bu işlev kullanıcı tanımlı işlevlerin değişken sayıda değiştirge kabul edebilmesini sağlamak için func_get_arg() ve func_get_args() ile birlikte kullanılabilir.

Dönen Değerler

Mevcut kullanıcı tanımlı işleve aktarılan değiştirge sayısını döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | Bu işlev artık değiştirge listelerinde kullanılabilmektedir.
5.3.0 | Bu işlev, çağrının yapıldığı dosyadaki bir işlev tanımında bulunan bir include veya require üzerinden dosyaya dahil edilen bir dosyadan yani, asıl dosyanın etki alanının dışından) çağrılırsa artık bir uyarı üretip FALSE döndürmektedir.

Hatalar/İstisnalar

Eğer kullanıcı tanımlı işlev dışından çağrılırsa uyarı oluşturur.

Örnekler

Örnek 1 - func_num_args() örneği

<?php
function işlev()
{
    $dğşsayısı = func_num_args();
    echo "Değiştirge sayısı: $dğşsayısı\n";
}

işlev(1, 2, 3);
?>

Yukarıdaki örneğin çıktısı:

Değiştirge sayısı: 3

Örnek 2 - PHP 5.3 sonrası func_get_arg()örneği

test.php
<?php
function foo() {
    include './fga.inc';
}

foo('First arg', 'Second arg');
?>

fga.php
<?php

$arg = func_get_arg1(1);
var_export($arg);

?>

PHP 5.3 öncesi için çıktı:

'Second arg'

PHP 5.3 ve sonrası için çıktı:

Warning: func_get_arg():  Called from the global scope - no function
context in /home/torben/Desktop/code/ml/fga.inc on line 3
false

Notlar

Bilginize:

Bu işlev değiştirge ayrıntılarını saptamak için mevcut etki alanına bağımlı olduğundan bir işlev değiştirgesi olarak kullanılamaz. Eğer bu değerin aktarılması gerekli ise sonuçlar bir değişkene atanmalı ve bu değişken aktarılmalıdır.

Ayrıca Bakınız

  • func_get_arg() - Değiştirge listesinden bir üyeyi döndürür
  • func_get_args() - İşleve aktarılan değiştirgelerin listesini dizi olarak döndürür

func_get_args
function_exists
İşlevlerle İlgili İşlevler


Eğer işlev tanımlanmış ise TRUE döndürür

func_num_args
get_defined_functions
İşlevlerle İlgili İşlevler
PHP Manual

function_exists

(PHP 4, PHP 5, PHP 7)

function_exists — Eğer işlev tanımlanmış ise TRUE döndürür

Açıklama

bool function_exists ( string $işlev_ismi )

işlev_ismi hem dahili (yerleşik) hem de kullanıcı tanımlı işlevlerin listesinde aranır.

Değiştirgeler

işlev_ismi

Bir dizge olarak işlevin ismi.

Dönen Değerler

Eğer işlev_ismi mevcut ve bir işlevin ismi ise TRUE döndürür, aksi takdirde FALSE döndürür.

Bilginize:

include_once ve echo gibi oluşumlar için bu işlev FALSE döndürür.

Örnekler

Örnek 1 - function_exists() örneği

<?php
if (function_exists('imap_open')) {
    echo "IMAP işlevleri mevcut.<br />\n";
} else {
    echo "IMAP işlevleri mevcut değil.<br />\n";
}
?>

Notlar

Bilginize:

Yapılandırma ve derleme seçeneklerinden dolayı işlev kullanılabilir olmasa bile işlevin ismi mevcut olabilir (resim işlevleri buna iyi bir örnektir.)

Ayrıca Bakınız

  • method_exists() - Bir sınıf yöntemi mevcut mu diye bakar
  • is_callable() - Bir değişkenin içeriğinin bir işlev olarak çağrılabilirliğini doğrular
  • get_defined_functions() - Tanımlanmış bütün işlevleri içeren bir dizi döndürür

func_num_args
get_defined_functions
İşlevlerle İlgili İşlevler


Tanımlanmış bütün işlevleri içeren bir dizi döndürür

function_exists
register_shutdown_function
İşlevlerle İlgili İşlevler
PHP Manual

get_defined_functions

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

get_defined_functions — Tanımlanmış bütün işlevleri içeren bir dizi döndürür

Açıklama

array get_defined_functions ( void )

Tanımlanmış bütün işlevleri bir dizi olarak döndürür.

Dönen Değerler

Hem kullanıcı tanımlı hem de yerleşik (dahili) bütün tanımlanmış işlevlerin listesini bir çok boyutlu dizi olarak döndürür. Dahili işlevlere $dizi["internal"] ile ulaşılabilirken kullanıcı tanımlı işlevlere $dizi["user"] ile ulaşılabilir (aşağıdaki örneğe bakınız).

Örnekler

Örnek 1 - get_defined_functions() örneği

<?php
function satır($id, $veri)
{
    return "<tr><th>$id</th><td>$veri</td></tr>\n";
}

$dizi = get_defined_functions();

print_r($dizi);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [internal] => Array
        (
            [0] => zend_version
            [1] => func_num_args
            [2] => func_get_arg
            [3] => func_get_args
            [4] => strlen
            [5] => strcmp
            [6] => strncmp
            ...
            [750] => bcscale
            [751] => bccomp
        )

    [user] => Array
        (
            [0] => satır
        )

)

Ayrıca Bakınız

  • function_exists() - Eğer işlev tanımlanmış ise TRUE döndürür
  • get_defined_vars() - Tüm tanımlı değişkenleri içeren bir dizi döndürür
  • get_defined_constants() - Tüm sabitlerin isimlerini ve değerlerini içeren bir ilişkisel dizi döndürür
  • get_declared_classes() - Tanımlı sınıfların isimlerini bir dizi olarak döndürür

function_exists
register_shutdown_function
İşlevlerle İlgili İşlevler


Betiğin işi bittiğinde çalıştırılacak işlevi tanımlar

get_defined_functions
register_tick_function
İşlevlerle İlgili İşlevler
PHP Manual

register_shutdown_function

(PHP 4, PHP 5, PHP 7)

register_shutdown_function — Betiğin işi bittiğinde çalıştırılacak işlevi tanımlar

Açıklama

void register_shutdown_function ( callback $işlev [, mixed $değiştirge [, mixed $... ]] )

Betiğin işi bittiğinde çalıştırılacak kapatma işlevini işlev olarak tanımlar.

register_shutdown_function() her gerekişinde bir kere olmak üzere defalarca çağrılabilir. Tanımlanan bir kapatma işlevinin içinde exit() çağrısı yapılırsa betik orada sonlanır ve başka kapatma işlevi çağrılmaz.

PHP 4'ten beri register_shutdown_function() işlevi üzerinden kapatma işlevine ek değiştirgeler aktarılabilmektedir.

Değiştirgeler

işlev

Tanımlanacak kapatma işlevinin ismi.

Kapatma işlevleri isteğin parçası olarak çağrılmakta dolayısıyla bunlardan çıktı göndermek mümkün olmaktadır. Kapatma işlevlerinin içinde çıktı tamponlama ile veri işlemenin şimdilik bir yolu yoktur.

Kapatma işlevleri tüm açık çıktı tamponları kapandıktan sonra çağrıldığından örneğin, zlib.output_compression etkin olsa bile çıktı sıkıştırılmaz.

değiştirge

register_shutdown_function() işlevi üzerinden kapatma işlevine ek değiştirgeler aktarılabilmektedir.

...

Dönen Değerler

Hiçbir değer dönmez.

Sürüm Bilgisi

Sürüm: | Açıklama
4.1.0 | Apache altında, tanımlı kapatma işlevleri istek tamamlandıktan sonra (çıktı tamponlarının gönderilmesi dahil) çağrılır. Dolayısıyla bir daha echo veya print kullanarak tarayıcıya bir şey gönderilemez veya ob_get_contents() kullanarak herhangi bir çıktı tamponunun içeriği alınamaz. Ancak, başlıklar daima gönderilir.
4.0.0 | Kapatma işlevine değiştirgelerini aktarmak mümkün oldu.

Örnekler

Örnek 1 - register_shutdown_function() örneği

<?php
function kapat()
{
  // bu bizim kapatma işlevimiz.
  // Burada betik sonlanmadan önce yapılacak
  // son işlemleri gerçekleştiriyoruz.

  echo 'Betik işini gerektiği gibi yaptı', PHP_EOL;
}

register_shutdown_function('kapat');
?>

Notlar

Bilginize:

Normal olarak tanımsız işlevler PHP'de ölümcül hatalara sebep olurlar, fakat register_shutdown_function() ile tanımlanmamış bir işlev çağrıldığında sadece E_WARNING seviyesinde bir hata çıktılanır. Ayrıca, PHP'ye özgü sebeplerle bu hata 0. satırda Unknown olarak gösterilir.

Bilginize:

Apache gibi bazı HTTP sunucularında çalışma dizini kapatma işlevi içinde değiştirilebilmektedir.

Ayrıca Bakınız

  • auto_append_file
  • exit() - Bir ileti çıktılayıp çalışmakta olan betiği sonlandırır
  • Bağlantı yönetimi bölümü

get_defined_functions
register_tick_function
İşlevlerle İlgili İşlevler


Her tikte çalıştırılacak işlevi tanımlar

register_shutdown_function
unregister_tick_function
İşlevlerle İlgili İşlevler
PHP Manual

register_tick_function

(PHP 4 >= 4.0.3, PHP 5, PHP 7)

register_tick_function — Her tikte çalıştırılacak işlevi tanımlar

Açıklama

bool register_tick_function ( callback $işlev [, mixed $değiştirge [, mixed $... ]] )

Her tik deyimde bir çalıştırılacak işlevi işlev olarak tanımlar.

Değiştirgeler

işlev

Dizge olarak işlev ismi veya bir nesne ve bir yöntemden oluşan bir dizi.

değiştirge

...

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - register_tick_function() örneği

<?php
// Bir geriçağırım işlevi kullanarak
register_tick_function('işlevim', true);

// Bir nesne->yöntem kullanarak
$nesne = new sınıf();
register_tick_function(array(&$nesne, 'yöntem'), true);
?>

Sürüm Bilgisi

Sürüm: | Açıklama
5.3.0 | Tikler artık evreli HTTP sunucu modülleri tarafından da destekleniyor.

Notlar

Uyarı

register_tick_function() işlevi PHP 5.2 ve öncesi sürümü evreli HTTP sunucu modülleri ile kullanılmamalıdır.

Ayrıca Bakınız

  • declare
  • unregister_tick_function() - Her tikte çalıştırılacak işlevi tanımsız yapar

register_shutdown_function
unregister_tick_function
İşlevlerle İlgili İşlevler


Her tikte çalıştırılacak işlevi tanımsız yapar

register_tick_function
Quickhash
İşlevlerle İlgili İşlevler
PHP Manual

unregister_tick_function

(PHP 4 >= 4.0.3, PHP 5, PHP 7)

unregister_tick_function — Her tikte çalıştırılacak işlevi tanımsız yapar

Açıklama

void unregister_tick_function ( string $işlevismi )

işlevismi ile belirtilen işlevi tanımsız hale getirmek suretiyle işlevin her tik deyimde bir çalıştırılmamasını sağlar.

Değiştirgeler

işlevismi

Bir dizge olarak işlevin ismi.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • register_tick_function() - Her tikte çalıştırılacak işlevi tanımlar

register_tick_function
Quickhash
İşlevlerle İlgili İşlevler


Quickhash

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
  • Öntanımlı Sabitler
  • Örnekler
  • QuickHashIntSet — The QuickHashIntSet class
    • QuickHashIntSet::add — This method adds a new entry to the set
    • QuickHashIntSet::__construct — Creates a new QuickHashIntSet object
    • QuickHashIntSet::delete — This method deletes an entry from the set
    • QuickHashIntSet::exists — This method checks whether a key is part of the set
    • QuickHashIntSet::getSize — Returns the number of elements in the set
    • QuickHashIntSet::loadFromFile — This factory method creates a set from a file
    • QuickHashIntSet::loadFromString — This factory method creates a set from a string
    • QuickHashIntSet::saveToFile — This method stores an in-memory set to disk
    • QuickHashIntSet::saveToString — This method returns a serialized version of the set
  • QuickHashIntHash — The QuickHashIntHash class
    • QuickHashIntHash::add — This method adds a new entry to the hash
    • QuickHashIntHash::__construct — Creates a new QuickHashIntHash object
    • QuickHashIntHash::delete — This method deletes am entry from the hash
    • QuickHashIntHash::exists — This method checks whether a key is part of the hash
    • QuickHashIntHash::get — This method retrieves a value from the hash by its key
    • QuickHashIntHash::getSize — Returns the number of elements in the hash
    • QuickHashIntHash::loadFromFile — This factory method creates a hash from a file
    • QuickHashIntHash::loadFromString — This factory method creates a hash from a string
    • QuickHashIntHash::saveToFile — This method stores an in-memory hash to disk
    • QuickHashIntHash::saveToString — This method returns a serialized version of the hash
    • QuickHashIntHash::set — This method updates an entry in the hash with a new value, or adds a new one if the entry doesn't exist
    • QuickHashIntHash::update — This method updates an entry in the hash with a new value
  • QuickHashStringIntHash — The QuickHashStringIntHash class
    • QuickHashStringIntHash::add — This method adds a new entry to the hash
    • QuickHashStringIntHash::__construct — Creates a new QuickHashStringIntHash object
    • QuickHashStringIntHash::delete — This method deletes am entry from the hash
    • QuickHashStringIntHash::exists — This method checks whether a key is part of the hash
    • QuickHashStringIntHash::get — This method retrieves a value from the hash by its key
    • QuickHashStringIntHash::getSize — Returns the number of elements in the hash
    • QuickHashStringIntHash::loadFromFile — This factory method creates a hash from a file
    • QuickHashStringIntHash::loadFromString — This factory method creates a hash from a string
    • QuickHashStringIntHash::saveToFile — This method stores an in-memory hash to disk
    • QuickHashStringIntHash::saveToString — This method returns a serialized version of the hash
    • QuickHashStringIntHash::set — This method updates an entry in the hash with a new value, or adds a new one if the entry doesn't exist
    • QuickHashStringIntHash::update — This method updates an entry in the hash with a new value
  • QuickHashIntStringHash — The QuickHashIntStringHash class
    • QuickHashIntStringHash::add — This method adds a new entry to the hash
    • QuickHashIntStringHash::__construct — Creates a new QuickHashIntStringHash object
    • QuickHashIntStringHash::delete — This method deletes am entry from the hash
    • QuickHashIntStringHash::exists — This method checks whether a key is part of the hash
    • QuickHashIntStringHash::get — This method retrieves a value from the hash by its key
    • QuickHashIntStringHash::getSize — Returns the number of elements in the hash
    • QuickHashIntStringHash::loadFromFile — This factory method creates a hash from a file
    • QuickHashIntStringHash::loadFromString — This factory method creates a hash from a string
    • QuickHashIntStringHash::saveToFile — This method stores an in-memory hash to disk
    • QuickHashIntStringHash::saveToString — This method returns a serialized version of the hash
    • QuickHashIntStringHash::set — This method updates an entry in the hash with a new value, or adds a new one if the entry doesn't exist
    • QuickHashIntStringHash::update — This method updates an entry in the hash with a new value
unregister_tick_function
Giriş
Değişkenler ve Veri Türleriyle İlgili Eklentiler


Giriş

The quickhash extension contains a set of specific strongly-typed classes to deal with specific set and hash implementations.

Quickhash
Yapılandırma/Kurulum
Quickhash


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
Giriş
Gereksinimler
Quickhash


Gereksinimler

This extension requires no additional libraries.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/quickhash

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Çalışma Anı Yapılandırması
Örnekler
Quickhash


Örnekler

Örnek 1 Quickhash Example

<?php
$set = new QuickHashIntSet( 1024, QuickHashIntSet::CHECK_FOR_DUPES );
$set->add( 1 );
$set->add( 3 );

var_dump( $set->exists( 3 ) );
var_dump( $set->exists( 4 ) );

$set->saveToFile( "/tmp/test-set.set" );

$newSet = QuickHashIntSet::loadFromFile(
    "/tmp/test-set.set"
);

var_dump( $newSet->exists( 3 ) );
var_dump( $newSet->exists( 4 ) );
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(true)
bool(false)
bool(true)
bool(false)

Örnek 2 Quickhash ArrayAccess Example

<?php
$hash = new QuickHashIntHash( 64 );

// Adding and updating hash entries.
$hash[3] = 145926;
$hash[3] = 1415926;
$hash[2] = 72;

// Checking if keys exist
var_dump( isset( $hash[3] ) );

// Removing hash entries
unset( $hash[2] );

// Retrieving the value stored for a hash
echo $hash[3], "\n";
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(true)
1415926

Örnek 3 Quickhash Iterator Example

<?php
$hash = new QuickHashIntHash( 64 );

// Adding hash entries.
$hash[1] = 145926;
$hash[2] = 1415926;
$hash[3] = 72;
$hash[4] = 712314;
$hash[5] = -4234;

foreach( $hash as $key => $value )
{
    echo $key, ' => ', $value, "\n";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

5 => -4234
4 => 712314
1 => 145926
2 => 1415926
3 => 72

Örnek 4 Quickhash String Values Example

<?php
$hash = new QuickHashIntStringHash( 64 );

// Adding hash entries.
$hash[1] = "one million four hundred fifteen thousand nine hundred twenty six";
$hash->add( 2, "one more" );

foreach( $hash as $key => $value )
{
    echo $key, ' => ', $value, "\n";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

1 => one million four hundred fifteen thousand nine hundred twenty six
2 => one more
Öntanımlı Sabitler
QuickHashIntSet
Quickhash


The QuickHashIntSet class

(PECL quickhash >= Unknown)

Giriş

This class wraps around a set containing integer numbers.

Sets can also be iterated over with foreach as the Iterator interface is implemented as well. The order of which elements are returned in is not guaranteed.

Sınıf Sözdizimi

QuickHashIntSet {
/* Constants */
const integer CHECK_FOR_DUPES = 1 ;
const integer DO_NOT_USE_ZEND_ALLOC = 2 ;
const integer HASHER_NO_HASH = 256 ;
const integer HASHER_JENKINS1 = 512 ;
const integer HASHER_JENKINS2 = 1024 ;
/* Methods */
public bool add ( int $key )
public __construct ( int $size [, int $options ] )
public bool delete ( int $key )
public bool exists ( int $key )
publicint getSize ( void )
public static QuickHashIntSet loadFromFile ( string $filename [, int $size [, int $options ]] )
public static QuickHashIntSet loadFromString ( string $contents [, int $size [, int $options ]] )
public void saveToFile ( string $filename )
public string saveToString ( void )
}

Öntanımlı Sabitler

QuickHashIntSet::CHECK_FOR_DUPES

If enabled, adding duplicate elements to a set (through either add() or loadFromFile()) will result in those elements to be dropped from the set. This will take up extra time, so only used when it is required.

QuickHashIntSet::DO_NOT_USE_ZEND_ALLOC

Disables the use of PHP's internal memory manager for internal set structures. With this option enabled, internal allocations will not count towards the memory_limit settings.

QuickHashIntSet::HASHER_NO_HASH

Selects to not use a hashing function, but merely use a modulo to find the bucket list index. This is not faster than normal hashing, and gives more collisions.

QuickHashIntSet::HASHER_JENKINS1

This is the default hashing function to turn the integer hashes into bucket list indexes.

QuickHashIntSet::HASHER_JENKINS2

Selects a variant hashing algorithm.

İçindekiler

  • QuickHashIntSet::add — This method adds a new entry to the set
  • QuickHashIntSet::__construct — Creates a new QuickHashIntSet object
  • QuickHashIntSet::delete — This method deletes an entry from the set
  • QuickHashIntSet::exists — This method checks whether a key is part of the set
  • QuickHashIntSet::getSize — Returns the number of elements in the set
  • QuickHashIntSet::loadFromFile — This factory method creates a set from a file
  • QuickHashIntSet::loadFromString — This factory method creates a set from a string
  • QuickHashIntSet::saveToFile — This method stores an in-memory set to disk
  • QuickHashIntSet::saveToString — This method returns a serialized version of the set
Örnekler
QuickHashIntSet::add
Quickhash


This method adds a new entry to the set

QuickHashIntSet
QuickHashIntSet::__construct
QuickHashIntSet
PHP Manual

QuickHashIntSet::add

(PECL quickhash >= Unknown)

QuickHashIntSet::add — This method adds a new entry to the set

Açıklama

public bool QuickHashIntSet::add ( int $key )

This method adds a new entry to the set, and returns whether the entry was added. Entries are by default always added unless QuickHashIntSet::CHECK_FOR_DUPES has been passed when the set was created.

Değiştirgeler

key

The key of the entry to add.

Dönen Değerler

TRUE when the entry was added, and FALSE if the entry was not added.

Örnekler

Örnek 1 QuickHashIntSet::add() example

<?php
echo "without dupe checking\n";
$set = new QuickHashIntSet( 1024 );
var_dump( $set->exists( 4 ) );
var_dump( $set->add( 4 ) );
var_dump( $set->exists( 4 ) );
var_dump( $set->add( 4 ) );

echo "\nwith dupe checking\n";
$set = new QuickHashIntSet( 1024, QuickHashIntSet::CHECK_FOR_DUPES );
var_dump( $set->exists( 4 ) );
var_dump( $set->add( 4 ) );
var_dump( $set->exists( 4 ) );
var_dump( $set->add( 4 ) );
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

without dupe checking
bool(false)
bool(true)
bool(true)
bool(true)

with dupe checking
bool(false)
bool(true)
bool(true)
bool(false)

QuickHashIntSet
QuickHashIntSet::__construct
QuickHashIntSet


Creates a new QuickHashIntSet object

QuickHashIntSet::add
QuickHashIntSet::delete
QuickHashIntSet
PHP Manual

QuickHashIntSet::__construct

(PECL quickhash >= Unknown)

QuickHashIntSet::__construct — Creates a new QuickHashIntSet object

Açıklama

public QuickHashIntSet::__construct ( int $size [, int $options ] )

This constructor creates a new QuickHashIntSet. The size is the amount of bucket lists to create. The more lists there are, the less collisions you will have. Options are also supported.

Değiştirgeler

size

The amount of bucket lists to configure. The number you pass in will be automatically rounded up to the next power of two. It is also automatically limited from 4 to 4194304.

options

The options that you can pass in are: QuickHashIntSet::CHECK_FOR_DUPES, which makes sure no duplicate entries are added to the set; QuickHashIntSet::DO_NOT_USE_ZEND_ALLOC to not use PHP's internal memory manager as well as one of QuickHashIntSet::HASHER_NO_HASH, QuickHashIntSet::HASHER_JENKINS1 or QuickHashIntSet::HASHER_JENKINS2. These last three configure which hashing algorithm to use. All options can be combined using bitmasks.

Dönen Değerler

Returns a new QuickHashIntSet object.

Örnekler

Örnek 1 QuickHashIntSet::__construct() example

<?php
var_dump( new QuickHashIntSet( 1024 ) );
var_dump( new QuickHashIntSet( 1024, QuickHashIntSet::CHECK_FOR_DUPES ) );
var_dump(
    new QuickHashIntSet(
        1024,
        QuickHashIntSet::DO_NOT_USE_ZEND_ALLOC | QuickHashIntSet::HASHER_JENKINS2
    )
);
?>

QuickHashIntSet::add
QuickHashIntSet::delete
QuickHashIntSet


This method deletes an entry from the set

QuickHashIntSet::__construct
QuickHashIntSet::exists
QuickHashIntSet
PHP Manual

QuickHashIntSet::delete

(PECL quickhash >= Unknown)

QuickHashIntSet::delete — This method deletes an entry from the set

Açıklama

public bool QuickHashIntSet::delete ( int $key )

This method deletes an entry from the set, and returns whether the entry was deleted or not. Associated memory structures will not be freed immediately, but rather when the set itself is freed.

Değiştirgeler

key

The key of the entry to delete.

Dönen Değerler

TRUE when the entry was deleted, and FALSE if the entry was not deleted.

Örnekler

Örnek 1 QuickHashIntSet::delete() example

<?php
$set = new QuickHashIntSet( 1024 );
var_dump( $set->exists( 4 ) );
var_dump( $set->add( 4 ) );
var_dump( $set->delete( 4 ) );
var_dump( $set->exists( 4 ) );
var_dump( $set->delete( 4 ) );
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(false)
bool(true)
bool(true)
bool(false)
bool(false)

QuickHashIntSet::__construct
QuickHashIntSet::exists
QuickHashIntSet


This method checks whether a key is part of the set

QuickHashIntSet::delete
QuickHashIntSet::getSize
QuickHashIntSet
PHP Manual

QuickHashIntSet::exists

(PECL quickhash >= Unknown)

QuickHashIntSet::exists — This method checks whether a key is part of the set

Açıklama

public bool QuickHashIntSet::exists ( int $key )

This method checks whether an entry with the provided key exists in the set.

Değiştirgeler

key

The key of the entry to check for whether it exists in the set.

Dönen Değerler

Returns TRUE when the entry was found, or FALSE when the entry is not found.

Örnekler

Örnek 1 QuickHashIntSet::exists() example

<?php
//generate 200000 elements
$array = range( 0, 199999 );
$existingEntries = array_rand( array_flip( $array ), 180000 );
$testForEntries = array_rand( array_flip( $array ), 1000 );
$foundCount = 0;

echo "Creating set: ", microtime( true ), "\n";
$set = new QuickHashIntSet( 100000 );
echo "Adding elements: ", microtime( true ), "\n";
foreach( $existingEntries as $key )
{
     $set->add( $key );
}

echo "Doing 1000 tests: ", microtime( true ), "\n";
foreach( $testForEntries as $key )
{
     $foundCount += $set->exists( $key );
}
echo "Done, $foundCount found: ", microtime( true ), "\n";
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Creating set: 1263588703.0748
Adding elements: 1263588703.0757
Doing 1000 tests: 1263588703.7851
Done, 898 found: 1263588703.7897

QuickHashIntSet::delete
QuickHashIntSet::getSize
QuickHashIntSet


Returns the number of elements in the set

QuickHashIntSet::exists
QuickHashIntSet::loadFromFile
QuickHashIntSet
PHP Manual

QuickHashIntSet::getSize

(PECL quickhash >= Unknown)

QuickHashIntSet::getSize — Returns the number of elements in the set

Açıklama

publicint QuickHashIntSet::getSize ( void )

Returns the number of elements in the set.

Değiştirgeler

key

The key of the entry to add.

Dönen Değerler

The number of elements in the set.

Örnekler

Örnek 1 QuickHashIntSet::getSize() example

<?php
$set = new QuickHashIntSet( 8 );
var_dump( $set->add( 2 ) );
var_dump( $set->add( 3 ) );
var_dump( $set->getSize() );
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(true)
bool(true)
int(2)

QuickHashIntSet::exists
QuickHashIntSet::loadFromFile
QuickHashIntSet


This factory method creates a set from a file

QuickHashIntSet::getSize
QuickHashIntSet::loadFromString
QuickHashIntSet
PHP Manual

QuickHashIntSet::loadFromFile

(PECL quickhash >= Unknown)

QuickHashIntSet::loadFromFile — This factory method creates a set from a file

Açıklama

public static QuickHashIntSet QuickHashIntSet::loadFromFile ( string $filename [, int $size [, int $options ]] )

This factory method creates a new set from a definition file on disk. The file format consists of 32 bit signed integers packed together in the Endianness that the system that the code runs on uses.

Değiştirgeler

filename

The filename of the file to read the set from.

size

The amount of bucket lists to configure. The number you pass in will be automatically rounded up to the next power of two. It is also automatically limited from 4 to 4194304.

options

The same options that the class' constructor takes; except that the size option is ignored. It is automatically calculated to be the same as the number of entries in the set, rounded up to the nearest power of two with a maximum limit of 4194304.

Dönen Değerler

Returns a new QuickHashIntSet.

Örnekler

Örnek 1 QuickHashIntSet::loadFromFile() example

<?php
$file = dirname( __FILE__ ) . "/simple.set";
$set = QuickHashIntSet::loadFromFile(
    $file,
    QuickHashIntSet::DO_NOT_USE_ZEND_ALLOC
);
foreach( range( 0, 0x0f ) as $key )
{
    printf( "Key %3d (%2x) is %s\n",
        $key, $key,
        $set->exists( $key ) ? 'set' : 'unset'
    );
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Key   0 ( 0) is unset
Key   1 ( 1) is set
Key   2 ( 2) is set
Key   3 ( 3) is set
Key   4 ( 4) is unset
Key   5 ( 5) is set
Key   6 ( 6) is unset
Key   7 ( 7) is set
Key   8 ( 8) is unset
Key   9 ( 9) is unset
Key  10 ( a) is unset
Key  11 ( b) is set
Key  12 ( c) is unset
Key  13 ( d) is set
Key  14 ( e) is unset
Key  15 ( f) is unset

QuickHashIntSet::getSize
QuickHashIntSet::loadFromString
QuickHashIntSet


This factory method creates a set from a string

QuickHashIntSet::loadFromFile
QuickHashIntSet::saveToFile
QuickHashIntSet
PHP Manual

QuickHashIntSet::loadFromString

(PECL quickhash >= Unknown)

QuickHashIntSet::loadFromString — This factory method creates a set from a string

Açıklama

public static QuickHashIntSet QuickHashIntSet::loadFromString ( string $contents [, int $size [, int $options ]] )

This factory method creates a new set from a definition in a string. The file format consists of 32 bit signed integers packed together in the Endianness that the system that the code runs on uses.

Değiştirgeler

contents

The string containing a serialized format of the set.

size

The amount of bucket lists to configure. The number you pass in will be automatically rounded up to the next power of two. It is also automatically limited from 4 to 4194304.

options

The same options that the class' constructor takes; except that the size option is ignored. It is automatically calculated to be the same as the number of entries in the set, rounded up to the nearest power of two automatically limited from 64 to 4194304.

Dönen Değerler

Returns a new QuickHashIntSet.

Örnekler

Örnek 1 QuickHashIntSet::loadFromString() example

<?php
$contents = file_get_contents( dirname( __FILE__ ) . "/simple.set" );
$set = QuickHashIntSet::loadFromString(
    $contents,
    QuickHashIntSet::DO_NOT_USE_ZEND_ALLOC
);
foreach( range( 0, 0x0f ) as $key )
{
    printf( "Key %3d (%2x) is %s\n",
        $key, $key,
        $set->exists( $key ) ? 'set' : 'unset'
    );
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Key   0 ( 0) is unset
Key   1 ( 1) is set
Key   2 ( 2) is set
Key   3 ( 3) is set
Key   4 ( 4) is unset
Key   5 ( 5) is set
Key   6 ( 6) is unset
Key   7 ( 7) is set
Key   8 ( 8) is unset
Key   9 ( 9) is unset
Key  10 ( a) is unset
Key  11 ( b) is set
Key  12 ( c) is unset
Key  13 ( d) is set
Key  14 ( e) is unset
Key  15 ( f) is unset

QuickHashIntSet::loadFromFile
QuickHashIntSet::saveToFile
QuickHashIntSet


This method stores an in-memory set to disk

QuickHashIntSet::loadFromString
QuickHashIntSet::saveToString
QuickHashIntSet
PHP Manual

QuickHashIntSet::saveToFile

(PECL quickhash >= Unknown)

QuickHashIntSet::saveToFile — This method stores an in-memory set to disk

Açıklama

public void QuickHashIntSet::saveToFile ( string $filename )

This method stores an existing set to a file on disk, in the same format that loadFromFile() can read.

Değiştirgeler

filename

The filename of the file to store the hash in.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 QuickHashIntSet::saveToFile() example

<?php
$set = new QuickHashIntSet( 1024 );
var_dump( $set->exists( 4 ) );
var_dump( $set->add( 4 ) );
var_dump( $set->exists( 4 ) );
var_dump( $set->add( 4 ) );

$set->saveToFile( '/tmp/test.set' );
?>

QuickHashIntSet::loadFromString
QuickHashIntSet::saveToString
QuickHashIntSet


This method returns a serialized version of the set

QuickHashIntSet::saveToFile
QuickHashIntHash
QuickHashIntSet
PHP Manual

QuickHashIntSet::saveToString

(PECL quickhash >= Unknown)

QuickHashIntSet::saveToString — This method returns a serialized version of the set

Açıklama

public string QuickHashIntSet::saveToString ( void )

This method returns a serialized version of the set in the same format that loadFromString() can read.

Dönen Değerler

This method returns a string containing a serialized format of the set. Each element is stored as a four byte value in the Endianness that the current system uses.

Örnekler

Örnek 1 QuickHashIntSet::saveToString() example

<?php
$set = new QuickHashIntSet( 1024 );
var_dump( $set->exists( 4 ) );
var_dump( $set->add( 4 ) );
var_dump( $set->exists( 4 ) );
var_dump( $set->add( 4 ) );

var_dump( $set->saveToString() );
?>

QuickHashIntSet::saveToFile
QuickHashIntHash
QuickHashIntSet


The QuickHashIntHash class

(PECL quickhash >= Unknown)

Giriş

This class wraps around a hash containing integer numbers, where the values are also integer numbers. Hashes are also available as implementation of the ArrayAccess interface.

Hashes can also be iterated over with foreach as the Iterator interface is implemented as well. The order of which elements are returned in is not guaranteed.

Sınıf Sözdizimi

QuickHashIntHash {
/* Constants */
const integer CHECK_FOR_DUPES = 1 ;
const integer DO_NOT_USE_ZEND_ALLOC = 2 ;
const integer HASHER_NO_HASH = 256 ;
const integer HASHER_JENKINS1 = 512 ;
const integer HASHER_JENKINS2 = 1024 ;
/* Methods */
public bool add ( int $key [, int $value ] )
public __construct ( int $size [, int $options ] )
public bool delete ( int $key )
public bool exists ( int $key )
public int get ( int $key )
public int getSize ( void )
public static QuickHashIntHash loadFromFile ( string $filename [, int $options ] )
public static QuickHashIntHash loadFromString ( string $contents [, int $options ] )
public void saveToFile ( string $filename )
public string saveToString ( void )
public bool set ( int $key , int $value )
public bool update ( int $key , int $value )
}

Öntanımlı Sabitler

QuickHashIntHash::CHECK_FOR_DUPES

If enabled, adding duplicate elements to a set (through either add() or loadFromFile()) will result in those elements to be dropped from the set. This will take up extra time, so only used when it is required.

QuickHashIntHash::DO_NOT_USE_ZEND_ALLOC

Disables the use of PHP's internal memory manager for internal set structures. With this option enabled, internal allocations will not count towards the memory_limit settings.

QuickHashIntHash::HASHER_NO_HASH

Selects to not use a hashing function, but merely use a modulo to find the bucket list index. This is not faster than normal hashing, and gives more collisions.

QuickHashIntHash::HASHER_JENKINS1

This is the default hashing function to turn the integer hashes into bucket list indexes.

QuickHashIntHash::HASHER_JENKINS2

Selects a variant hashing algorithm.

İçindekiler

  • QuickHashIntHash::add — This method adds a new entry to the hash
  • QuickHashIntHash::__construct — Creates a new QuickHashIntHash object
  • QuickHashIntHash::delete — This method deletes am entry from the hash
  • QuickHashIntHash::exists — This method checks whether a key is part of the hash
  • QuickHashIntHash::get — This method retrieves a value from the hash by its key
  • QuickHashIntHash::getSize — Returns the number of elements in the hash
  • QuickHashIntHash::loadFromFile — This factory method creates a hash from a file
  • QuickHashIntHash::loadFromString — This factory method creates a hash from a string
  • QuickHashIntHash::saveToFile — This method stores an in-memory hash to disk
  • QuickHashIntHash::saveToString — This method returns a serialized version of the hash
  • QuickHashIntHash::set — This method updates an entry in the hash with a new value, or adds a new one if the entry doesn't exist
  • QuickHashIntHash::update — This method updates an entry in the hash with a new value
QuickHashIntSet::saveToString
QuickHashIntHash::add
Quickhash


This method adds a new entry to the hash

QuickHashIntHash
QuickHashIntHash::__construct
QuickHashIntHash
PHP Manual

QuickHashIntHash::add

(PECL quickhash >= Unknown)

QuickHashIntHash::add — This method adds a new entry to the hash

Açıklama

public bool QuickHashIntHash::add ( int $key [, int $value ] )

This method adds a new entry to the hash, and returns whether the entry was added. Entries are by default always added unless QuickHashIntHash::CHECK_FOR_DUPES has been passed when the hash was created.

Değiştirgeler

key

The key of the entry to add.

value

The optional value of the entry to add. If no value is specified, 1 will be used.

Dönen Değerler

TRUE when the entry was added, and FALSE if the entry was not added.

Örnekler

Örnek 1 QuickHashIntHash::add() example

<?php
echo "without dupe checking\n";
$hash = new QuickHashIntHash( 1024 );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->get( 4 ) );
var_dump( $hash->add( 4, 22 ) );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->get( 4 ) );
var_dump( $hash->add( 4, 12 ) );

echo "\nwith dupe checking\n";
$hash = new QuickHashIntHash( 1024, QuickHashIntHash::CHECK_FOR_DUPES );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->get( 4 ) );
var_dump( $hash->add( 4, 78 ) );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->get( 4 ) );
var_dump( $hash->add( 4, 9 ) );

echo "\ndefault value\n";
var_dump( $hash->add( 5 ) );
var_dump( $hash->get( 5 ) );
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

without dupe checking
bool(false)
bool(false)
bool(true)
bool(true)
int(22)
bool(true)

with dupe checking
bool(false)
bool(false)
bool(true)
bool(true)
int(78)
bool(false)

default value
bool(true)
int(1)

QuickHashIntHash
QuickHashIntHash::__construct
QuickHashIntHash


Creates a new QuickHashIntHash object

QuickHashIntHash::add
QuickHashIntHash::delete
QuickHashIntHash
PHP Manual

QuickHashIntHash::__construct

(PECL quickhash >= Unknown)

QuickHashIntHash::__construct — Creates a new QuickHashIntHash object

Açıklama

public QuickHashIntHash::__construct ( int $size [, int $options ] )

This constructor creates a new QuickHashIntHash. The size is the amount of bucket lists to create. The more lists there are, the less collisions you will have. Options are also supported.

Değiştirgeler

size

The amount of bucket lists to configure. The number you pass in will be automatically rounded up to the next power of two. It is also automatically limited from 64 to 4194304.

options

The options that you can pass in are: QuickHashIntHash::CHECK_FOR_DUPES, which makes sure no duplicate entries are added to the hash; QuickHashIntHash::DO_NOT_USE_ZEND_ALLOC to not use PHP's internal memory manager as well as one of QuickHashIntHash::HASHER_NO_HASH, QuickHashIntHash::HASHER_JENKINS1 or QuickHashIntHash::HASHER_JENKINS2. These last three configure which hashing algorithm to use. All options can be combined using bitmasks.

Dönen Değerler

Returns a new QuickHashIntHash object.

Örnekler

Örnek 1 QuickHashIntHash::__construct() example

<?php
var_dump( new QuickHashIntHash( 1024 ) );
var_dump( new QuickHashIntHash( 1024, QuickHashIntHash::CHECK_FOR_DUPES ) );
var_dump(
    new QuickHashIntHash(
        1024,
        QuickHashIntHash::DO_NOT_USE_ZEND_ALLOC | QuickHashIntHash::HASHER_JENKINS2
    )
);
?>

QuickHashIntHash::add
QuickHashIntHash::delete
QuickHashIntHash


This method deletes am entry from the hash

QuickHashIntHash::__construct
QuickHashIntHash::exists
QuickHashIntHash
PHP Manual

QuickHashIntHash::delete

(PECL quickhash >= Unknown)

QuickHashIntHash::delete — This method deletes am entry from the hash

Açıklama

public bool QuickHashIntHash::delete ( int $key )

This method deletes an entry from the hash, and returns whether the entry was deleted or not. Associated memory structures will not be freed immediately, but rather when the hash itself is freed.

Elements can not be deleted when the hash is used in an iterator. The method will not throw an exception, but simply return FALSE like would happen with any other deletion failure.

Değiştirgeler

key

The key of the entry to delete.

Dönen Değerler

TRUE when the entry was deleted, and FALSE if the entry was not deleted.

Örnekler

Örnek 1 QuickHashIntHash::delete() example

<?php
$hash = new QuickHashIntHash( 1024 );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->add( 4, 5 ) );
var_dump( $hash->delete( 4 ) );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->delete( 4 ) );
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(false)
bool(true)
bool(true)
bool(false)
bool(false)

QuickHashIntHash::__construct
QuickHashIntHash::exists
QuickHashIntHash


This method checks whether a key is part of the hash

QuickHashIntHash::delete
QuickHashIntHash::get
QuickHashIntHash
PHP Manual

QuickHashIntHash::exists

(PECL quickhash >= Unknown)

QuickHashIntHash::exists — This method checks whether a key is part of the hash

Açıklama

public bool QuickHashIntHash::exists ( int $key )

This method checks whether an entry with the provided key exists in the hash.

Değiştirgeler

key

The key of the entry to check for whether it exists in the hash.

Dönen Değerler

Returns TRUE when the entry was found, or FALSE when the entry is not found.

Örnekler

Örnek 1 QuickHashIntHash::exists() example

<?php
//generate 200000 elements
$array = range( 0, 199999 );
$existingEntries = array_rand( array_flip( $array ), 180000 );
$testForEntries = array_rand( array_flip( $array ), 1000 );
$foundCount = 0;

echo "Creating hash: ", microtime( true ), "\n";
$hash = new QuickHashIntHash( 100000 );
echo "Adding elements: ", microtime( true ), "\n";
foreach( $existingEntries as $key )
{
     $hash->add( $key, 56 );
}

echo "Doing 1000 tests: ", microtime( true ), "\n";
foreach( $testForEntries as $key )
{
     $foundCount += $hash->exists( $key );
}
echo "Done, $foundCount found: ", microtime( true ), "\n";
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Creating hash: 1263588703.0748
Adding elements: 1263588703.0757
Doing 1000 tests: 1263588703.7851
Done, 898 found: 1263588703.7897

QuickHashIntHash::delete
QuickHashIntHash::get
QuickHashIntHash


This method retrieves a value from the hash by its key

QuickHashIntHash::exists
QuickHashIntHash::getSize
QuickHashIntHash
PHP Manual

QuickHashIntHash::get

(PECL quickhash >= Unknown)

QuickHashIntHash::get — This method retrieves a value from the hash by its key

Açıklama

public int QuickHashIntHash::get ( int $key )

This method retrieves a value from the hash by its key.

Değiştirgeler

key

The key of the entry to add.

Dönen Değerler

The value if the key exists, or NULL if the key wasn't part of the hash.

Örnekler

Örnek 1 QuickHashIntHash::get() example

<?php
$hash = new QuickHashIntHash( 8 );
var_dump( $hash->get( 1 ) );

var_dump( $hash->add( 2 ) );
var_dump( $hash->get( 2 ) );

var_dump( $hash->add( 3, 5 ) );
var_dump( $hash->get( 3 ) );
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(false)
bool(true)
int(1)
bool(true)
int(5)

QuickHashIntHash::exists
QuickHashIntHash::getSize
QuickHashIntHash


Returns the number of elements in the hash

QuickHashIntHash::get
QuickHashIntHash::loadFromFile
QuickHashIntHash
PHP Manual

QuickHashIntHash::getSize

(PECL quickhash >= Unknown)

QuickHashIntHash::getSize — Returns the number of elements in the hash

Açıklama

public int QuickHashIntHash::getSize ( void )

Returns the number of elements in the hash.

Değiştirgeler

key

The key of the entry to add.

Dönen Değerler

The number of elements in the hash.

Örnekler

Örnek 1 QuickHashIntHash::getSize() example

<?php
$hash = new QuickHashIntHash( 8 );
var_dump( $hash->add( 2 ) );
var_dump( $hash->add( 3, 5 ) );
var_dump( $hash->getSize() );
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(true)
bool(true)
int(2)

QuickHashIntHash::get
QuickHashIntHash::loadFromFile
QuickHashIntHash


This factory method creates a hash from a file

QuickHashIntHash::getSize
QuickHashIntHash::loadFromString
QuickHashIntHash
PHP Manual

QuickHashIntHash::loadFromFile

(PECL quickhash >= Unknown)

QuickHashIntHash::loadFromFile — This factory method creates a hash from a file

Açıklama

public static QuickHashIntHash QuickHashIntHash::loadFromFile ( string $filename [, int $options ] )

This factory method creates a new hash from a definition file on disk. The file format consists of a signature 'QH\0x11\0', the number of elements as a 32 bit signed integer in system Endianness, followed by 32 bit signed integers packed together in the Endianness that the system that the code runs on uses. For each hash element there are two 32 bit signed integers stored. The first of each element is the key, and the second is the value belonging to the key. An example could be:

Örnek 1 QuickHash IntHash file format

00000000  51 48 11 00 02 00 00 00  01 00 00 00 01 00 00 00  |QH..............|
00000010  03 00 00 00 09 00 00 00                           |........|
00000018

Örnek 2 QuickHash IntHash file format

header signature ('QH'; key type: 1; value type: 1; filler: \0x00)
00000000  51 48 11 00

number of elements:
00000004  02 00 00 00

data string:
00000000  01 00 00 00 01 00 00 00  03 00 00 00 09 00 00 00

key/value 1 (key = 1, value = 1)
01 00 00 00  01 00 00 00

key/value 2 (key = 3, value = 9)
03 00 00 00  09 00 00 00

Değiştirgeler

filename

The filename of the file to read the hash from.

options

The same options that the class' constructor takes; except that the size option is ignored. It is automatically calculated to be the same as the number of entries in the hash, rounded up to the nearest power of two with a maximum limit of 4194304.

Dönen Değerler

Returns a new QuickHashIntHash.

Örnekler

Örnek 3 QuickHashIntHash::loadFromFile() example

<?php
$file = dirname( __FILE__ ) . "/simple.hash";
$hash = QuickHashIntHash::loadFromFile(
    $file,
    QuickHashIntHash::DO_NOT_USE_ZEND_ALLOC
);
foreach( range( 0, 0x0f ) as $key )
{
    printf( "Key %3d (%2x) is %s\n",
        $key, $key,
        $hash->exists( $key ) ? 'set' : 'unset'
    );
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Key   0 ( 0) is unset
Key   1 ( 1) is set
Key   2 ( 2) is set
Key   3 ( 3) is set
Key   4 ( 4) is unset
Key   5 ( 5) is set
Key   6 ( 6) is unset
Key   7 ( 7) is set
Key   8 ( 8) is unset
Key   9 ( 9) is unset
Key  10 ( a) is unset
Key  11 ( b) is set
Key  12 ( c) is unset
Key  13 ( d) is set
Key  14 ( e) is unset
Key  15 ( f) is unset

QuickHashIntHash::getSize
QuickHashIntHash::loadFromString
QuickHashIntHash


This factory method creates a hash from a string

QuickHashIntHash::loadFromFile
QuickHashIntHash::saveToFile
QuickHashIntHash
PHP Manual

QuickHashIntHash::loadFromString

(PECL quickhash >= Unknown)

QuickHashIntHash::loadFromString — This factory method creates a hash from a string

Açıklama

public static QuickHashIntHash QuickHashIntHash::loadFromString ( string $contents [, int $options ] )

This factory method creates a new hash from a definition in a string. The file format consists of 32 bit signed integers packed together in the Endianness that the system that the code runs on uses. For each element there are two 32 bit signed integers stored. The first of each element is the key, and the second is the value belonging to the key.

Değiştirgeler

contents

The string containing a serialized format of the hash.

options

The same options that the class' constructor takes; except that the size option is ignored. It is automatically calculated to be the same as the number of entries in the hash, rounded up to the nearest power of two with a maximum limit of 4194304.

Dönen Değerler

Returns a new QuickHashIntHash.

Örnekler

Örnek 1 QuickHashIntHash::loadFromString() example

<?php
$contents = file_get_contents( dirname( __FILE__ ) . "/simple.hash" );
$hash = QuickHashIntHash::loadFromString(
    $contents,
    QuickHashIntHash::DO_NOT_USE_ZEND_ALLOC
);
foreach( range( 0, 0x0f ) as $key )
{
    printf( "Key %3d (%2x) is %s\n",
        $key, $key,
        $hash->exists( $key ) ? 'set' : 'unset'
    );
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Key   0 ( 0) is unset
Key   1 ( 1) is set
Key   2 ( 2) is set
Key   3 ( 3) is set
Key   4 ( 4) is unset
Key   5 ( 5) is set
Key   6 ( 6) is unset
Key   7 ( 7) is set
Key   8 ( 8) is unset
Key   9 ( 9) is unset
Key  10 ( a) is unset
Key  11 ( b) is set
Key  12 ( c) is unset
Key  13 ( d) is set
Key  14 ( e) is unset
Key  15 ( f) is unset

QuickHashIntHash::loadFromFile
QuickHashIntHash::saveToFile
QuickHashIntHash


This method stores an in-memory hash to disk

QuickHashIntHash::loadFromString
QuickHashIntHash::saveToString
QuickHashIntHash
PHP Manual

QuickHashIntHash::saveToFile

(PECL quickhash >= Unknown)

QuickHashIntHash::saveToFile — This method stores an in-memory hash to disk

Açıklama

public void QuickHashIntHash::saveToFile ( string $filename )

This method stores an existing hash to a file on disk, in the same format that loadFromFile() can read.

Değiştirgeler

filename

The filename of the file to store the hash in.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 QuickHashIntHash::saveToFile() example

<?php
$hash = new QuickHashIntHash( 1024 );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->add( 4, 43 ) );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->add( 4, 52 ) );

$hash->saveToFile( '/tmp/test.hash' );
?>

QuickHashIntHash::loadFromString
QuickHashIntHash::saveToString
QuickHashIntHash


This method returns a serialized version of the hash

QuickHashIntHash::saveToFile
QuickHashIntHash::set
QuickHashIntHash
PHP Manual

QuickHashIntHash::saveToString

(PECL quickhash >= Unknown)

QuickHashIntHash::saveToString — This method returns a serialized version of the hash

Açıklama

public string QuickHashIntHash::saveToString ( void )

This method returns a serialized version of the hash in the same format that loadFromString() can read.

Dönen Değerler

This method returns a string containing a serialized format of the hash. Each element is stored as a four byte value in the Endianness that the current system uses.

Örnekler

Örnek 1 QuickHashIntHash::saveToString() example

<?php
$hash = new QuickHashIntHash( 1024 );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->add( 4, 34 ) );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->add( 4, 55 ) );

var_dump( $hash->saveToString() );
?>

QuickHashIntHash::saveToFile
QuickHashIntHash::set
QuickHashIntHash


This method updates an entry in the hash with a new value, or adds a new one if the entry doesn't exist

QuickHashIntHash::saveToString
QuickHashIntHash::update
QuickHashIntHash
PHP Manual

QuickHashIntHash::set

(PECL quickhash >= Unknown)

QuickHashIntHash::set — This method updates an entry in the hash with a new value, or adds a new one if the entry doesn't exist

Açıklama

public bool QuickHashIntHash::set ( int $key , int $value )

This method tries to update an entry with a new value. In case the entry did not yet exist, it will instead add a new entry. It returns whether the entry was added or update. If there are duplicate keys, only the first found element will get an updated value. Use QuickHashIntHash::CHECK_FOR_DUPES during hash creation to prevent duplicate keys from being part of the hash.

Değiştirgeler

key

The key of the entry to add or update.

value

The new value to set the entry with.

Dönen Değerler

2 if the entry was found and updated, 1 if the entry was newly added or 0 if there was an error.

Örnekler

Örnek 1 QuickHashIntHash::set() example

<?php
$hash = new QuickHashIntHash( 1024 );

echo "Set->Add\n";
var_dump( $hash->get( 46692 ) );
var_dump( $hash->set( 46692, 16091 ) );
var_dump( $hash->get( 46692 ) );

echo "Set->Update\n";
var_dump( $hash->set( 46692, 29906 ) );
var_dump( $hash->get( 46692 ) );
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(false)
int(2)
int(16091)
Set->Update
int(1)
int(29906)

QuickHashIntHash::saveToString
QuickHashIntHash::update
QuickHashIntHash


This method updates an entry in the hash with a new value

QuickHashIntHash::set
QuickHashStringIntHash
QuickHashIntHash
PHP Manual

QuickHashIntHash::update

(PECL quickhash >= Unknown)

QuickHashIntHash::update — This method updates an entry in the hash with a new value

Açıklama

public bool QuickHashIntHash::update ( int $key , int $value )

This method updates an entry with a new value, and returns whether the entry was update. If there are duplicate keys, only the first found element will get an updated value. Use QuickHashIntHash::CHECK_FOR_DUPES during hash creation to prevent duplicate keys from being part of the hash.

Değiştirgeler

key

The key of the entry to add.

value

The new value to update the entry with.

Dönen Değerler

TRUE when the entry was found and updated, and FALSE if the entry was not part of the hash already.

Örnekler

Örnek 1 QuickHashIntHash::update() example

<?php
$hash = new QuickHashIntHash( 1024 );

var_dump( $hash->add( 141421, 173205 ) );
var_dump( $hash->update( 141421, 223606 ) );
var_dump( $hash->get( 141421 ) );
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(true)
bool(true)
int(223606)

QuickHashIntHash::set
QuickHashStringIntHash
QuickHashIntHash


The QuickHashStringIntHash class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

This class wraps around a hash containing strings, where the values are integer numbers. Hashes are also available as implementation of the ArrayAccess interface.

Hashes can also be iterated over with foreach as the Iterator interface is implemented as well. The order of which elements are returned in is not guaranteed.

Sınıf Sözdizimi

QuickHashStringIntHash {
/* Constants */
const integer CHECK_FOR_DUPES = 1 ;
const integer DO_NOT_USE_ZEND_ALLOC = 2 ;
/* Methods */
public bool add ( string $key , int $value )
public __construct ( int $size [, int $options = 0 ] )
public bool delete ( string $key )
public bool exists ( string $key )
public mixed get ( string $key )
public int getSize ( void )
public static QuickHashStringIntHash loadFromFile ( string $filename [, int $size = 0 [, int $options = 0 ]] )
public static QuickHashStringIntHash loadFromString ( string $contents [, int $size = 0 [, int $options = 0 ]] )
public void saveToFile ( string $filename )
public string saveToString ( void )
public int set ( string $key , int $value )
public bool update ( string $key , int $value )
}

Öntanımlı Sabitler

QuickHashStringIntHash::CHECK_FOR_DUPES

If enabled, adding duplicate elements to a set (through either add() or loadFromFile()) will result in those elements to be dropped from the set. This will take up extra time, so only used when it is required.

QuickHashStringIntHash::DO_NOT_USE_ZEND_ALLOC

Disables the use of PHP's internal memory manager for internal set structures. With this option enabled, internal allocations will not count towards the memory_limit settings.

İçindekiler

  • QuickHashStringIntHash::add — This method adds a new entry to the hash
  • QuickHashStringIntHash::__construct — Creates a new QuickHashStringIntHash object
  • QuickHashStringIntHash::delete — This method deletes am entry from the hash
  • QuickHashStringIntHash::exists — This method checks whether a key is part of the hash
  • QuickHashStringIntHash::get — This method retrieves a value from the hash by its key
  • QuickHashStringIntHash::getSize — Returns the number of elements in the hash
  • QuickHashStringIntHash::loadFromFile — This factory method creates a hash from a file
  • QuickHashStringIntHash::loadFromString — This factory method creates a hash from a string
  • QuickHashStringIntHash::saveToFile — This method stores an in-memory hash to disk
  • QuickHashStringIntHash::saveToString — This method returns a serialized version of the hash
  • QuickHashStringIntHash::set — This method updates an entry in the hash with a new value, or adds a new one if the entry doesn't exist
  • QuickHashStringIntHash::update — This method updates an entry in the hash with a new value
QuickHashIntHash::update
QuickHashStringIntHash::add
Quickhash


This method adds a new entry to the hash

QuickHashStringIntHash
QuickHashStringIntHash::__construct
QuickHashStringIntHash
PHP Manual

QuickHashStringIntHash::add

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

QuickHashStringIntHash::add — This method adds a new entry to the hash

Açıklama

public bool QuickHashStringIntHash::add ( string $key , int $value )

This method adds a new entry to the hash, and returns whether the entry was added. Entries are by default always added unless QuickHashStringIntHash::CHECK_FOR_DUPES has been passed when the hash was created.

Değiştirgeler

key

The key of the entry to add.

value

The value of the entry to add.

Dönen Değerler

TRUE when the entry was added, and FALSE if the entry was not added.

Örnekler

Örnek 1 QuickHashStringIntHash::add() example

<?php
echo "without dupe checking\n";
$hash = new QuickHashStringIntHash( 1024 );
var_dump( $hash );
var_dump( $hash->exists( "four" ) );
var_dump( $hash->get( "four" ) );
var_dump( $hash->add( "four", 22 ) );
var_dump( $hash->exists( "four" ) );
var_dump( $hash->get( "four" ) );
var_dump( $hash->add( "four", 12 ) );

echo "\nwith dupe checking\n";
$hash = new QuickHashStringIntHash( 1024, QuickHashStringIntHash::CHECK_FOR_DUPES );
var_dump( $hash );
var_dump( $hash->exists( "four" ) );
var_dump( $hash->get( "four" ) );
var_dump( $hash->add( "four", 78 ) );
var_dump( $hash->exists( "four" ) );
var_dump( $hash->get( "four" ) );
var_dump( $hash->add( "four", 9 ) );
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

without dupe checking
object(QuickHashStringIntHash)#1 (0) {
}
bool(false)
bool(false)
bool(true)
bool(true)
int(22)
bool(true)

with dupe checking
object(QuickHashStringIntHash)#2 (0) {
}
bool(false)
bool(false)
bool(true)
bool(true)
int(78)
bool(false)

QuickHashStringIntHash
QuickHashStringIntHash::__construct
QuickHashStringIntHash


Creates a new QuickHashStringIntHash object

QuickHashStringIntHash::add
QuickHashStringIntHash::delete
QuickHashStringIntHash
PHP Manual

QuickHashStringIntHash::__construct

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

QuickHashStringIntHash::__construct — Creates a new QuickHashStringIntHash object

Açıklama

public QuickHashStringIntHash::__construct ( int $size [, int $options = 0 ] )

This constructor creates a new QuickHashStringIntHash. The size is the amount of bucket lists to create. The more lists there are, the less collisions you will have. Options are also supported.

Değiştirgeler

size

The amount of bucket lists to configure. The number you pass in will be automatically rounded up to the next power of two. It is also automatically limited from 64 to 4194304.

options

The options that you can pass in are: QuickHashStringIntHash::CHECK_FOR_DUPES, which makes sure no duplicate entries are added to the hash and QuickHashStringIntHash::DO_NOT_USE_ZEND_ALLOC to not use PHP's internal memory manager.

Dönen Değerler

Returns a new QuickHashStringIntHash object.

Örnekler

Örnek 1 QuickHashStringIntHash::__construct() example

<?php
var_dump( new QuickHashStringIntHash( 1024 ) );
var_dump( new QuickHashStringIntHash( 1024, QuickHashStringIntHash::CHECK_FOR_DUPES ) );
?>

QuickHashStringIntHash::add
QuickHashStringIntHash::delete
QuickHashStringIntHash


This method deletes am entry from the hash

QuickHashStringIntHash::__construct
QuickHashStringIntHash::exists
QuickHashStringIntHash
PHP Manual

QuickHashStringIntHash::delete

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

QuickHashStringIntHash::delete — This method deletes am entry from the hash

Açıklama

public bool QuickHashStringIntHash::delete ( string $key )

This method deletes an entry from the hash, and returns whether the entry was deleted or not. Associated memory structures will not be freed immediately, but rather when the hash itself is freed.

Elements can not be deleted when the hash is used in an iterator. The method will not throw an exception, but simply return FALSE like would happen with any other deletion failure.

Değiştirgeler

key

The key of the entry to delete.

Dönen Değerler

TRUE when the entry was deleted, and FALSE if the entry was not deleted.

Örnekler

Örnek 1 QuickHashStringIntHash::delete() example

<?php
$hash = new QuickHashStringIntHash( 1024 );
var_dump( $hash->exists( 'four' ) );
var_dump( $hash->add( 'four', 5 ) );
var_dump( $hash->get( 'four' ) );
var_dump( $hash->delete( 'four' ) );
var_dump( $hash->exists( 'four' ) );
var_dump( $hash->get( 'four' ) );
var_dump( $hash->delete( 'four' ) );
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(false)
bool(true)
int(5)
bool(true)
bool(false)
bool(false)
bool(false)

QuickHashStringIntHash::__construct
QuickHashStringIntHash::exists
QuickHashStringIntHash


This method checks whether a key is part of the hash

QuickHashStringIntHash::delete
QuickHashStringIntHash::get
QuickHashStringIntHash
PHP Manual

QuickHashStringIntHash::exists

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

QuickHashStringIntHash::exists — This method checks whether a key is part of the hash

Açıklama

public bool QuickHashStringIntHash::exists ( string $key )

This method checks whether an entry with the provided key exists in the hash.

Değiştirgeler

key

The key of the entry to check for whether it exists in the hash.

Dönen Değerler

Returns TRUE when the entry was found, or FALSE when the entry is not found.

QuickHashStringIntHash::delete
QuickHashStringIntHash::get
QuickHashStringIntHash


This method retrieves a value from the hash by its key

QuickHashStringIntHash::exists
QuickHashStringIntHash::getSize
QuickHashStringIntHash
PHP Manual

QuickHashStringIntHash::get

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

QuickHashStringIntHash::get — This method retrieves a value from the hash by its key

Açıklama

public mixed QuickHashStringIntHash::get ( string $key )

This method retrieves a value from the hash by its key.

Değiştirgeler

key

The key of the entry to add.

Dönen Değerler

The value if the key exists, or NULL if the key wasn't part of the hash.

Örnekler

Örnek 1 QuickHashStringIntHash::get() example

<?php
$hash = new QuickHashStringIntHash( 8 );
var_dump( $hash->get( "one" ) );

var_dump( $hash->add( "two", 2 ) );
var_dump( $hash->get( "two" ) );
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(false)
bool(true)
int(2)

QuickHashStringIntHash::exists
QuickHashStringIntHash::getSize
QuickHashStringIntHash


Returns the number of elements in the hash

QuickHashStringIntHash::get
QuickHashStringIntHash::loadFromFile
QuickHashStringIntHash
PHP Manual

QuickHashStringIntHash::getSize

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

QuickHashStringIntHash::getSize — Returns the number of elements in the hash

Açıklama

public int QuickHashStringIntHash::getSize ( void )

Returns the number of elements in the hash.

Değiştirgeler

key

The key of the entry to add.

Dönen Değerler

The number of elements in the hash.

Örnekler

Örnek 1 QuickHashStringIntHash::getSize() example

<?php
$hash = new QuickHashStringIntHash( 8 );
var_dump( $hash->add( "two", 2 ) );
var_dump( $hash->add( "three", 5 ) );
var_dump( $hash->getSize() );
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(true)
bool(true)
int(2)

QuickHashStringIntHash::get
QuickHashStringIntHash::loadFromFile
QuickHashStringIntHash


This factory method creates a hash from a file

QuickHashStringIntHash::getSize
QuickHashStringIntHash::loadFromString
QuickHashStringIntHash
PHP Manual

QuickHashStringIntHash::loadFromFile

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

QuickHashStringIntHash::loadFromFile — This factory method creates a hash from a file

Açıklama

public static QuickHashStringIntHash QuickHashStringIntHash::loadFromFile ( string $filename [, int $size = 0 [, int $options = 0 ]] )

This factory method creates a new hash from a definition file on disk. The file format consists of a signature 'QH\0x21\0', the number of elements as a 32 bit signed integer in system Endianness, an unsigned 32 bit integer containing the number of element data to follow in characters. This element data contains all the strings. The follows another signed 32 bit integer containing the number of bucket lists. After the header and the strings, the elements follow. They are ordered by bucket list so that the keys don't have to be hashed in order to restore the hash. For each bucket list, the following information is stored (all as 32 bit integers): the bucket list index, the number of elements in that list, and then in pairs of two unsigned 32 bit integers the elements, where the first one is the index into the string list containing the keys, and the second one the value. An example could be:

Örnek 1 QuickHash StringIntHash file format

00000000  51 48 21 00 02 00 00 00  09 00 00 00 40 00 00 00  |QH!.........@...|
00000010  4f 4e 45 00 4e 49 4e 45  00 07 00 00 00 01 00 00  |ONE.NINE........|
00000020  00 00 00 00 00 01 00 00  00 2f 00 00 00 01 00 00  |........./......|
00000030  00 04 00 00 00 03 00 00  00                       |.........|
00000039

Örnek 2 QuickHash IntHash file format

header signature ('QH'; key type: 2; value type: 1; filler: \0x00)
00000000  51 48 21 00

number of elements:
00000004  02 00 00 00

length of string values (9 characters):
00000008  09 00 00 00

number of hash bucket lists (this is configured for hashes as argument to the
constructor normally, 64 in this case):
0000000C  40 00 00 00

string values:
00000010  4f 4e 45 00 4e 49 4e 45  00

bucket lists:
  bucket list 1 (with key 7, and 1 element):
    header:
    07 00 00 00 01 00 00 00
    elements (key index: 0 ('ONE'), value = 0):
    00 00 00 00 01 00 00 00
  bucket list 2 (with key 0x2f, and 1 element):
    header:
    2f 00 00 00 01 00 00 00
    elements (key index: 4 ('NINE'), value = 3):
    04 00 00 00 03 00 00 00

Değiştirgeler

filename

The filename of the file to read the hash from.

size

The amount of bucket lists to configure. The number you pass in will be automatically rounded up to the next power of two. It is also automatically limited from 4 to 4194304.

options

The same options that the class' constructor takes; except that the size option is ignored. It is read from the file format (unlike the QuickHashIntHash and QuickHashIntStringHash classes, where it is automatically calculated from the number of entries in the hash.)

Dönen Değerler

Returns a new QuickHashStringIntHash.

Örnekler

Örnek 3 QuickHashStringIntHash::loadFromFile() example

<?php
$file = dirname( __FILE__ ) . "/simple.hash.string";
$hash = QuickHashStringIntHash::loadFromFile(
    $file,
    QuickHashStringIntHash::DO_NOT_USE_ZEND_ALLOC
);
foreach( range( 0, 0x0f ) as $key )
{
    $i = 48712 + $key * 1631;
    $k = base_convert( $i, 10, 36 );
    echo $k, ' => ', $hash->get( $k ), "\n";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

11l4 => 48712
12uf => 50343
143q => 51974
15d1 => 53605
16mc => 55236
17vn => 56867
194y => 58498
1ae9 => 60129
1bnk => 61760
1cwv => 63391
1e66 => 65022
1ffh => 66653
1gos => 68284
1hy3 => 69915
1j7e => 71546
1kgp => 73177

QuickHashStringIntHash::getSize
QuickHashStringIntHash::loadFromString
QuickHashStringIntHash


This factory method creates a hash from a string

QuickHashStringIntHash::loadFromFile
QuickHashStringIntHash::saveToFile
QuickHashStringIntHash
PHP Manual

QuickHashStringIntHash::loadFromString

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

QuickHashStringIntHash::loadFromString — This factory method creates a hash from a string

Açıklama

public static QuickHashStringIntHash QuickHashStringIntHash::loadFromString ( string $contents [, int $size = 0 [, int $options = 0 ]] )

This factory method creates a new hash from a definition in a string. The format is the same as the one used in "loadFromFile".

Değiştirgeler

contents

The string containing a serialized format of the hash.

size

The amount of bucket lists to configure. The number you pass in will be automatically rounded up to the next power of two. It is also automatically limited from 4 to 4194304.

options

The same options that the class' constructor takes; except that the size option is ignored. It is automatically calculated to be the same as the number of entries in the hash, rounded up to the nearest power of two with a maximum limit of 4194304.

Dönen Değerler

Returns a new QuickHashStringIntHash.

Örnekler

Örnek 1 QuickHashStringIntHash::loadFromString() example

<?php
$contents = file_get_contents( dirname( __FILE__ ) . "/simple.hash.string" );
$hash = QuickHashStringIntHash::loadFromString(
    $contents,
    QuickHashStringIntHash::DO_NOT_USE_ZEND_ALLOC
);
foreach( range( 0, 0x0f ) as $key )
{
    $i = 48712 + $key * 1631;
    $k = base_convert( $i, 10, 36 );
    echo $k, ' => ', $hash->get( $k ), "\n";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

11l4 => 48712
12uf => 50343
143q => 51974
15d1 => 53605
16mc => 55236
17vn => 56867
194y => 58498
1ae9 => 60129
1bnk => 61760
1cwv => 63391
1e66 => 65022
1ffh => 66653
1gos => 68284
1hy3 => 69915
1j7e => 71546
1kgp => 73177

QuickHashStringIntHash::loadFromFile
QuickHashStringIntHash::saveToFile
QuickHashStringIntHash


This method stores an in-memory hash to disk

QuickHashStringIntHash::loadFromString
QuickHashStringIntHash::saveToString
QuickHashStringIntHash
PHP Manual

QuickHashStringIntHash::saveToFile

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

QuickHashStringIntHash::saveToFile — This method stores an in-memory hash to disk

Açıklama

public void QuickHashStringIntHash::saveToFile ( string $filename )

This method stores an existing hash to a file on disk, in the same format that loadFromFile() can read.

Değiştirgeler

filename

The filename of the file to store the hash in.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 QuickHashStringIntHash::saveToFile() example

<?php
$hash = new QuickHashStringIntHash( 1024 );
var_dump( $hash->add( "fourty three", 42 ) );
var_dump( $hash->add( "fifty two", 52 ) );

$hash->saveToFile( '/tmp/test.hash.string' );
?>

QuickHashStringIntHash::loadFromString
QuickHashStringIntHash::saveToString
QuickHashStringIntHash


This method returns a serialized version of the hash

QuickHashStringIntHash::saveToFile
QuickHashStringIntHash::set
QuickHashStringIntHash
PHP Manual

QuickHashStringIntHash::saveToString

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

QuickHashStringIntHash::saveToString — This method returns a serialized version of the hash

Açıklama

public string QuickHashStringIntHash::saveToString ( void )

This method returns a serialized version of the hash in the same format that loadFromString() can read.

Dönen Değerler

This method returns a serialized format of an existing hash, in the same format that loadFromString() can read.

Örnekler

Örnek 1 QuickHashStringIntHash::saveToString() example

<?php
$hash = new QuickHashStringIntHash( 1024 );
var_dump( $hash->add( "fourty three", 42 ) );
var_dump( $hash->add( "fifty two", 52 ) );

var_dump( $hash->saveToString() );
?>

QuickHashStringIntHash::saveToFile
QuickHashStringIntHash::set
QuickHashStringIntHash


This method updates an entry in the hash with a new value, or adds a new one if the entry doesn't exist

QuickHashStringIntHash::saveToString
QuickHashStringIntHash::update
QuickHashStringIntHash
PHP Manual

QuickHashStringIntHash::set

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

QuickHashStringIntHash::set — This method updates an entry in the hash with a new value, or adds a new one if the entry doesn't exist

Açıklama

public int QuickHashStringIntHash::set ( string $key , int $value )

This method tries to update an entry with a new value. In case the entry did not yet exist, it will instead add a new entry. It returns whether the entry was added or update. If there are duplicate keys, only the first found element will get an updated value. Use QuickHashStringIntHash::CHECK_FOR_DUPES during hash creation to prevent duplicate keys from being part of the hash.

Değiştirgeler

key

The key of the entry to add or update.

value

The value of the entry to add. If a non-string is passed, it will be converted to a string automatically if possible.

Dönen Değerler

2 if the entry was found and updated, 1 if the entry was newly added or 0 if there was an error.

Örnekler

Örnek 1 QuickHashStringIntHash::set() example

<?php
$hash = new QuickHashStringIntHash( 1024 );

echo "Set->Add\n";
var_dump( $hash->get( "fourty six thousand six hundred ninety two" ) );
var_dump( $hash->set( "fourty six thousand six hundred ninety two", 16091 ) );
var_dump( $hash->get( "fourty six thousand six hundred ninety two" ) );

echo "Set->Update\n";
var_dump( $hash->set( "fourty six thousand six hundred ninety two", 29906 ) );
var_dump( $hash->get( "fourty six thousand six hundred ninety two" ) );
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Set->Add
bool(false)
int(2)
int(16091)
Set->Update
int(1)
int(29906)

QuickHashStringIntHash::saveToString
QuickHashStringIntHash::update
QuickHashStringIntHash


This method updates an entry in the hash with a new value

QuickHashStringIntHash::set
QuickHashIntStringHash
QuickHashStringIntHash
PHP Manual

QuickHashStringIntHash::update

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

QuickHashStringIntHash::update — This method updates an entry in the hash with a new value

Açıklama

public bool QuickHashStringIntHash::update ( string $key , int $value )

This method updates an entry with a new value, and returns whether the entry was update. If there are duplicate keys, only the first found element will get an updated value. Use QuickHashStringIntHash::CHECK_FOR_DUPES during hash creation to prevent duplicate keys from being part of the hash.

Değiştirgeler

key

The key of the entry to add.

value

The new value for the entry. If a non-string is passed, it will be converted to a string automatically if possible.

Dönen Değerler

TRUE when the entry was found and updated, and FALSE if the entry was not part of the hash already.

Örnekler

Örnek 1 QuickHashStringIntHash::update() example

<?php
$hash = new QuickHashStringIntHash( 1024 );

$hash->add( 'six', 314159265 );
$hash->add( "a lot", 314159265 );

echo $hash->get( 'six' ), "\n";
echo $hash->get( 'a lot' ), "\n";

var_dump( $hash->update( 'a lot', 314159266 ) );
var_dump( $hash->update( "a lot plus one", 314159999 ) );

echo $hash->get( 'six' ), "\n";
echo $hash->get( 'a lot' ), "\n";
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

314159265
314159265
bool(true)
bool(false)
314159265
314159266

QuickHashStringIntHash::set
QuickHashIntStringHash
QuickHashStringIntHash


The QuickHashIntStringHash class

(PECL quickhash >= Unknown)

Giriş

This class wraps around a hash containing integer numbers, where the values are strings. Hashes are also available as implementation of the ArrayAccess interface.

Hashes can also be iterated over with foreach as the Iterator interface is implemented as well. The order of which elements are returned in is not guaranteed.

Sınıf Sözdizimi

QuickHashIntStringHash {
/* Constants */
const integer CHECK_FOR_DUPES = 1 ;
const integer DO_NOT_USE_ZEND_ALLOC = 2 ;
const integer HASHER_NO_HASH = 256 ;
const integer HASHER_JENKINS1 = 512 ;
const integer HASHER_JENKINS2 = 1024 ;
/* Methods */
public bool add ( int $key , string $value )
public __construct ( int $size [, int $options = 0 ] )
public bool delete ( int $key )
public bool exists ( int $key )
public mixed get ( int $key )
public int getSize ( void )
public static QuickHashIntStringHash loadFromFile ( string $filename [, int $size = 0 [, int $options = 0 ]] )
public static QuickHashIntStringHash loadFromString ( string $contents [, int $size = 0 [, int $options = 0 ]] )
public void saveToFile ( string $filename )
public string saveToString ( void )
public int set ( int $key , string $value )
public bool update ( int $key , string $value )
}

Öntanımlı Sabitler

QuickHashIntStringHash::CHECK_FOR_DUPES

If enabled, adding duplicate elements to a set (through either add() or loadFromFile()) will result in those elements to be dropped from the set. This will take up extra time, so only used when it is required.

QuickHashIntStringHash::DO_NOT_USE_ZEND_ALLOC

Disables the use of PHP's internal memory manager for internal set structures. With this option enabled, internal allocations will not count towards the memory_limit settings.

QuickHashIntStringHash::HASHER_NO_HASH

Selects to not use a hashing function, but merely use a modulo to find the bucket list index. This is not faster than normal hashing, and gives more collisions.

QuickHashIntStringHash::HASHER_JENKINS1

This is the default hashing function to turn the integer hashes into bucket list indexes.

QuickHashIntStringHash::HASHER_JENKINS2

Selects a variant hashing algorithm.

İçindekiler

  • QuickHashIntStringHash::add — This method adds a new entry to the hash
  • QuickHashIntStringHash::__construct — Creates a new QuickHashIntStringHash object
  • QuickHashIntStringHash::delete — This method deletes am entry from the hash
  • QuickHashIntStringHash::exists — This method checks whether a key is part of the hash
  • QuickHashIntStringHash::get — This method retrieves a value from the hash by its key
  • QuickHashIntStringHash::getSize — Returns the number of elements in the hash
  • QuickHashIntStringHash::loadFromFile — This factory method creates a hash from a file
  • QuickHashIntStringHash::loadFromString — This factory method creates a hash from a string
  • QuickHashIntStringHash::saveToFile — This method stores an in-memory hash to disk
  • QuickHashIntStringHash::saveToString — This method returns a serialized version of the hash
  • QuickHashIntStringHash::set — This method updates an entry in the hash with a new value, or adds a new one if the entry doesn't exist
  • QuickHashIntStringHash::update — This method updates an entry in the hash with a new value
QuickHashStringIntHash::update
QuickHashIntStringHash::add
Quickhash


This method adds a new entry to the hash

QuickHashIntStringHash
QuickHashIntStringHash::__construct
QuickHashIntStringHash
PHP Manual

QuickHashIntStringHash::add

(PECL quickhash >= Unknown)

QuickHashIntStringHash::add — This method adds a new entry to the hash

Açıklama

public bool QuickHashIntStringHash::add ( int $key , string $value )

This method adds a new entry to the hash, and returns whether the entry was added. Entries are by default always added unless QuickHashIntStringHash::CHECK_FOR_DUPES has been passed when the hash was created.

Değiştirgeler

key

The key of the entry to add.

value

The value of the entry to add. If a non-string is passed, it will be converted to a string automatically if possible.

Dönen Değerler

TRUE when the entry was added, and FALSE if the entry was not added.

Örnekler

Örnek 1 QuickHashIntStringHash::add() example

<?php
echo "without dupe checking\n";
$hash = new QuickHashIntStringHash( 1024 );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->get( 4 ) );
var_dump( $hash->add( 4, "twenty two" ) );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->get( 4 ) );
var_dump( $hash->add( 4, "twelve" ) );

echo "\nwith dupe checking\n";
$hash = new QuickHashIntStringHash( 1024, QuickHashIntStringHash::CHECK_FOR_DUPES );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->get( 4 ) );
var_dump( $hash->add( 4, "seventy eight" ) );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->get( 4 ) );
var_dump( $hash->add( 4, "nine" ) );
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

without dupe checking
bool(false)
bool(false)
bool(true)
bool(true)
string(10) "twenty two"
bool(true)

with dupe checking
bool(false)
bool(false)
bool(true)
bool(true)
string(13) "seventy eight"
bool(false)

QuickHashIntStringHash
QuickHashIntStringHash::__construct
QuickHashIntStringHash


Creates a new QuickHashIntStringHash object

QuickHashIntStringHash::add
QuickHashIntStringHash::delete
QuickHashIntStringHash
PHP Manual

QuickHashIntStringHash::__construct

(PECL quickhash >= Unknown)

QuickHashIntStringHash::__construct — Creates a new QuickHashIntStringHash object

Açıklama

public QuickHashIntStringHash::__construct ( int $size [, int $options = 0 ] )

This constructor creates a new QuickHashIntStringHash. The size is the amount of bucket lists to create. The more lists there are, the less collisions you will have. Options are also supported.

Değiştirgeler

size

The amount of bucket lists to configure. The number you pass in will be automatically rounded up to the next power of two. It is also automatically limited from 64 to 4194304.

options

The options that you can pass in are: QuickHashIntStringHash::CHECK_FOR_DUPES, which makes sure no duplicate entries are added to the hash; QuickHashIntStringHash::DO_NOT_USE_ZEND_ALLOC to not use PHP's internal memory manager as well as one of QuickHashIntStringHash::HASHER_NO_HASH, QuickHashIntStringHash::HASHER_JENKINS1 or QuickHashIntStringHash::HASHER_JENKINS2. These last three configure which hashing algorithm to use. All options can be combined using bitmasks.

Dönen Değerler

Returns a new QuickHashIntStringHash object.

Örnekler

Örnek 1 QuickHashIntStringHash::__construct() example

<?php
var_dump( new QuickHashIntStringHash( 1024 ) );
var_dump( new QuickHashIntStringHash( 1024, QuickHashIntStringHash::CHECK_FOR_DUPES ) );
var_dump(
    new QuickHashIntStringHash(
        1024,
        QuickHashIntStringHash::DO_NOT_USE_ZEND_ALLOC | QuickHashIntStringHash::HASHER_JENKINS2
    )
);
?>

QuickHashIntStringHash::add
QuickHashIntStringHash::delete
QuickHashIntStringHash


This method deletes am entry from the hash

QuickHashIntStringHash::__construct
QuickHashIntStringHash::exists
QuickHashIntStringHash
PHP Manual

QuickHashIntStringHash::delete

(PECL quickhash >= Unknown)

QuickHashIntStringHash::delete — This method deletes am entry from the hash

Açıklama

public bool QuickHashIntStringHash::delete ( int $key )

This method deletes an entry from the hash, and returns whether the entry was deleted or not. Associated memory structures will not be freed immediately, but rather when the hash itself is freed.

Elements can not be deleted when the hash is used in an iterator. The method will not throw an exception, but simply return FALSE like would happen with any other deletion failure.

Değiştirgeler

key

The key of the entry to delete.

Dönen Değerler

TRUE when the entry was deleted, and FALSE if the entry was not deleted.

Örnekler

Örnek 1 QuickHashIntStringHash::delete() example

<?php
$hash = new QuickHashIntStringHash( 1024 );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->add( 4, "five" ) );
var_dump( $hash->delete( 4 ) );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->delete( 4 ) );
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(false)
bool(true)
bool(true)
bool(false)
bool(false)

QuickHashIntStringHash::__construct
QuickHashIntStringHash::exists
QuickHashIntStringHash


This method checks whether a key is part of the hash

QuickHashIntStringHash::delete
QuickHashIntStringHash::get
QuickHashIntStringHash
PHP Manual

QuickHashIntStringHash::exists

(PECL quickhash >= Unknown)

QuickHashIntStringHash::exists — This method checks whether a key is part of the hash

Açıklama

public bool QuickHashIntStringHash::exists ( int $key )

This method checks whether an entry with the provided key exists in the hash.

Değiştirgeler

key

The key of the entry to check for whether it exists in the hash.

Dönen Değerler

Returns TRUE when the entry was found, or FALSE when the entry is not found.

QuickHashIntStringHash::delete
QuickHashIntStringHash::get
QuickHashIntStringHash


This method retrieves a value from the hash by its key

QuickHashIntStringHash::exists
QuickHashIntStringHash::getSize
QuickHashIntStringHash
PHP Manual

QuickHashIntStringHash::get

(PECL quickhash >= Unknown)

QuickHashIntStringHash::get — This method retrieves a value from the hash by its key

Açıklama

public mixed QuickHashIntStringHash::get ( int $key )

This method retrieves a value from the hash by its key.

Değiştirgeler

key

The key of the entry to add.

Dönen Değerler

The value if the key exists, or NULL if the key wasn't part of the hash.

Örnekler

Örnek 1 QuickHashIntStringHash::get() example

<?php
$hash = new QuickHashIntStringHash( 8 );
var_dump( $hash->get( 1 ) );

var_dump( $hash->add( 2, "two" ) );
var_dump( $hash->get( 2 ) );

var_dump( $hash->add( 3, 5 ) );
var_dump( $hash->get( 3 ) );
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(false)
bool(true)
string(3) "two"
bool(true)
string(1) "5"

QuickHashIntStringHash::exists
QuickHashIntStringHash::getSize
QuickHashIntStringHash


Returns the number of elements in the hash

QuickHashIntStringHash::get
QuickHashIntStringHash::loadFromFile
QuickHashIntStringHash
PHP Manual

QuickHashIntStringHash::getSize

(PECL quickhash >= Unknown)

QuickHashIntStringHash::getSize — Returns the number of elements in the hash

Açıklama

public int QuickHashIntStringHash::getSize ( void )

Returns the number of elements in the hash.

Dönen Değerler

The number of elements in the hash.

Örnekler

Örnek 1 QuickHashIntStringHash::getSize() example

<?php
$hash = new QuickHashIntStringHash( 8 );
var_dump( $hash->add( 2, "two" ) );
var_dump( $hash->add( 3, 5 ) );
var_dump( $hash->getSize() );
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(true)
bool(true)
int(2)

QuickHashIntStringHash::get
QuickHashIntStringHash::loadFromFile
QuickHashIntStringHash


This factory method creates a hash from a file

QuickHashIntStringHash::getSize
QuickHashIntStringHash::loadFromString
QuickHashIntStringHash
PHP Manual

QuickHashIntStringHash::loadFromFile

(PECL quickhash >= Unknown)

QuickHashIntStringHash::loadFromFile — This factory method creates a hash from a file

Açıklama

public static QuickHashIntStringHash QuickHashIntStringHash::loadFromFile ( string $filename [, int $size = 0 [, int $options = 0 ]] )

This factory method creates a new hash from a definition file on disk. The file format consists of a signature 'QH\0x12\0', the number of elements as a 32 bit signed integer in system Endianness, an unsigned 32 bit integer containing the number of element data to follow in characters. This element data contains all the strings. After the header and the strings, the elements follow in pairs of two unsigned 32 bit integers where the first one is the key, and the second one the index in the element data string. An example could be:

Örnek 1 QuickHash IntString file format

00000000  51 48 12 00 02 00 00 00  09 00 00 00 4f 4e 45 00  |QH..........ONE.|
00000010  4e 49 4e 45 00 01 00 00  00 00 00 00 00 03 00 00  |NINE............|
00000020  00 04 00 00 00                                    |.....|
00000025

Örnek 2 QuickHash IntString file format

header signature ('QH'; key type: 1; value type: 2; filler: \0x00)
00000000  51 48 12 00

number of elements:
00000004  02 00 00 00

length of string values (9 characters):
00000008  09 00 00 00

string values:
0000000C  4f 4e 45 00 4e 49 4e 45  00

data string:
00000015  01 00 00 00 00 00 00 00  03 00 00 00 04 00 00 00

key/value 1 (key = 1, string index = 0 ("ONE")):
01 00 00 00  00 00 00 00

key/value 2 (key = 3, string index = 4 ("NINE")):
03 00 00 00  04 00 00 00

Değiştirgeler

filename

The filename of the file to read the hash from.

size

The amount of bucket lists to configure. The number you pass in will be automatically rounded up to the next power of two. It is also automatically limited from 4 to 4194304.

options

The same options that the class' constructor takes; except that the size option is ignored. It is automatically calculated to be the same as the number of entries in the hash, rounded up to the nearest power of two with a maximum limit of 4194304.

Dönen Değerler

Returns a new QuickHashIntStringHash.

Örnekler

Örnek 3 QuickHashIntStringHash::loadFromFile() example

<?php
$file = dirname( __FILE__ ) . "/simple.string.hash";
$hash = QuickHashIntStringHash::loadFromFile(
    $file,
    QuickHashIntStringHash::DO_NOT_USE_ZEND_ALLOC
);
foreach( range( 0, 0x0f ) as $key )
{
    printf( "Key %3d (%2x) is %s\n",
        $key, $key,
        $hash->exists( $key ) ? 'set' : 'unset'
    );
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Key   0 ( 0) is unset
Key   1 ( 1) is set
Key   2 ( 2) is set
Key   3 ( 3) is set
Key   4 ( 4) is unset
Key   5 ( 5) is set
Key   6 ( 6) is unset
Key   7 ( 7) is set
Key   8 ( 8) is unset
Key   9 ( 9) is unset
Key  10 ( a) is unset
Key  11 ( b) is set
Key  12 ( c) is unset
Key  13 ( d) is set
Key  14 ( e) is unset
Key  15 ( f) is unset

QuickHashIntStringHash::getSize
QuickHashIntStringHash::loadFromString
QuickHashIntStringHash


This factory method creates a hash from a string

QuickHashIntStringHash::loadFromFile
QuickHashIntStringHash::saveToFile
QuickHashIntStringHash
PHP Manual

QuickHashIntStringHash::loadFromString

(PECL quickhash >= Unknown)

QuickHashIntStringHash::loadFromString — This factory method creates a hash from a string

Açıklama

public static QuickHashIntStringHash QuickHashIntStringHash::loadFromString ( string $contents [, int $size = 0 [, int $options = 0 ]] )

This factory method creates a new hash from a definition in a string. The format is the same as the one used in "loadFromFile".

Değiştirgeler

contents

The string containing a serialized format of the hash.

size

The amount of bucket lists to configure. The number you pass in will be automatically rounded up to the next power of two. It is also automatically limited from 4 to 4194304.

options

The same options that the class' constructor takes; except that the size option is ignored. It is automatically calculated to be the same as the number of entries in the hash, rounded up to the nearest power of two with a maximum limit of 4194304.

Dönen Değerler

Returns a new QuickHashIntStringHash.

Örnekler

Örnek 1 QuickHashIntStringHash::loadFromString() example

<?php
$contents = file_get_contents( dirname( __FILE__ ) . "/simple.hash" );
$hash = QuickHashIntStringHash::loadFromString(
    $contents,
    QuickHashIntStringHash::DO_NOT_USE_ZEND_ALLOC
);
foreach( range( 0, 0x0f ) as $key )
{
    printf( "Key %3d (%2x) is %s\n",
        $key, $key,
        $hash->exists( $key ) ? 'set' : 'unset'
    );
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Key   0 ( 0) is unset
Key   1 ( 1) is set
Key   2 ( 2) is set
Key   3 ( 3) is set
Key   4 ( 4) is unset
Key   5 ( 5) is set
Key   6 ( 6) is unset
Key   7 ( 7) is set
Key   8 ( 8) is unset
Key   9 ( 9) is unset
Key  10 ( a) is unset
Key  11 ( b) is set
Key  12 ( c) is unset
Key  13 ( d) is set
Key  14 ( e) is unset
Key  15 ( f) is unset

QuickHashIntStringHash::loadFromFile
QuickHashIntStringHash::saveToFile
QuickHashIntStringHash


This method stores an in-memory hash to disk

QuickHashIntStringHash::loadFromString
QuickHashIntStringHash::saveToString
QuickHashIntStringHash
PHP Manual

QuickHashIntStringHash::saveToFile

(PECL quickhash >= Unknown)

QuickHashIntStringHash::saveToFile — This method stores an in-memory hash to disk

Açıklama

public void QuickHashIntStringHash::saveToFile ( string $filename )

This method stores an existing hash to a file on disk, in the same format that loadFromFile() can read.

Değiştirgeler

filename

The filename of the file to store the hash in.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 QuickHashIntStringHash::saveToFile() example

<?php
$hash = new QuickHashIntStringHash( 1024 );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->add( 4, "fourty three" ) );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->add( 4, "fifty two" ) );

$hash->saveToFile( '/tmp/test.string.hash' );
?>

QuickHashIntStringHash::loadFromString
QuickHashIntStringHash::saveToString
QuickHashIntStringHash


This method returns a serialized version of the hash

QuickHashIntStringHash::saveToFile
QuickHashIntStringHash::set
QuickHashIntStringHash
PHP Manual

QuickHashIntStringHash::saveToString

(PECL quickhash >= Unknown)

QuickHashIntStringHash::saveToString — This method returns a serialized version of the hash

Açıklama

public string QuickHashIntStringHash::saveToString ( void )

This method returns a serialized version of the hash in the same format that loadFromString() can read.

Dönen Değerler

This method returns a string containing a serialized format of the hash. Each element is stored as a four byte value in the Endianness that the current system uses.

Örnekler

Örnek 1 QuickHashIntStringHash::saveToString() example

<?php
$hash = new QuickHashIntStringHash( 1024 );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->add( 4, "thirty four" ) );
var_dump( $hash->exists( 4 ) );
var_dump( $hash->add( 5, "fifty five" ) );

var_dump( $hash->saveToString() );
?>

QuickHashIntStringHash::saveToFile
QuickHashIntStringHash::set
QuickHashIntStringHash


This method updates an entry in the hash with a new value, or adds a new one if the entry doesn't exist

QuickHashIntStringHash::saveToString
QuickHashIntStringHash::update
QuickHashIntStringHash
PHP Manual

QuickHashIntStringHash::set

(PECL quickhash >= Unknown)

QuickHashIntStringHash::set — This method updates an entry in the hash with a new value, or adds a new one if the entry doesn't exist

Açıklama

public int QuickHashIntStringHash::set ( int $key , string $value )

This method tries to update an entry with a new value. In case the entry did not yet exist, it will instead add a new entry. It returns whether the entry was added or update. If there are duplicate keys, only the first found element will get an updated value. Use QuickHashIntStringHash::CHECK_FOR_DUPES during hash creation to prevent duplicate keys from being part of the hash.

Değiştirgeler

key

The key of the entry to add or update.

value

The value of the entry to add. If a non-string is passed, it will be converted to a string automatically if possible.

Dönen Değerler

2 if the entry was found and updated, 1 if the entry was newly added or 0 if there was an error.

Örnekler

Örnek 1 QuickHashIntStringHash::set() example

<?php
$hash = new QuickHashIntStringHash( 1024 );

echo "Set->Add\n";
var_dump( $hash->get( 46692 ) );
var_dump( $hash->set( 46692, "sixteen thousand ninety one" ) );
var_dump( $hash->get( 46692 ) );

echo "Set->Update\n";
var_dump( $hash->set( 46692, "twenty nine thousand nine hundred six" ) );
var_dump( $hash->get( 46692 ) );
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Set->Add
bool(false)
int(2)
string(27) "sixteen thousand ninety one"
Set->Update
int(1)
string(37) "twenty nine thousand nine hundred six"

QuickHashIntStringHash::saveToString
QuickHashIntStringHash::update
QuickHashIntStringHash


This method updates an entry in the hash with a new value

QuickHashIntStringHash::set
Reflection
QuickHashIntStringHash
PHP Manual

QuickHashIntStringHash::update

(PECL quickhash >= Unknown)

QuickHashIntStringHash::update — This method updates an entry in the hash with a new value

Açıklama

public bool QuickHashIntStringHash::update ( int $key , string $value )

This method updates an entry with a new value, and returns whether the entry was update. If there are duplicate keys, only the first found element will get an updated value. Use QuickHashIntStringHash::CHECK_FOR_DUPES during hash creation to prevent duplicate keys from being part of the hash.

Değiştirgeler

key

The key of the entry to add.

value

The new value for the entry. If a non-string is passed, it will be converted to a string automatically if possible.

Dönen Değerler

TRUE when the entry was found and updated, and FALSE if the entry was not part of the hash already.

Örnekler

Örnek 1 QuickHashIntStringHash::update() example

<?php
$hash->add( 161803398, "--" );
$hash->add( 314159265, "a lot" );

echo $hash->get( 161803398 ), "\n";
echo $hash->get( 314159265 ), "\n";

var_dump( $hash->update( 314159265, "a lot plus one" ) );
var_dump( $hash->update( 314159999, "a lot plus one" ) );

echo $hash->get( 161803398 ), "\n";
echo $hash->get( 314159265 ), "\n";
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

--
a lot
bool(true)
bool(false)
--
a lot plus one

QuickHashIntStringHash::set
Reflection
QuickHashIntStringHash


Yansıtma

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
  • Yansıtma Sınıflarının Genişletilmesi
  • Reflection — Reflection Sınıfı
    • Reflection::export — Sınıfı ihraç eder
    • Reflection::getModifierNames — Değiştirici isimlerini döndürür
  • ReflectionClass — ReflectionClass Sınıfı
    • ReflectionClass::__construct — Bir ReflectionClass nesnesi oluşturur
    • ReflectionClass::export — Bir sınıf ihraç eder
    • ReflectionClass::getConstant — Tanımlı sabitleri döndürür
    • ReflectionClass::getConstants — Sabitleri döndürür
    • ReflectionClass::getConstructor — Kurucuyu döndürür
    • ReflectionClass::getDefaultProperties — Öntanımlı özellikleri döndürür
    • ReflectionClass::getDocComment — Belgelendirici açıklamaları döndürür
    • ReflectionClass::getEndLine — Son satırın numarasını döndürür
    • ReflectionClass::getExtension — Eklenti bilgilerini döndürür
    • ReflectionClass::getExtensionName — Eklentinin ismini döndürür
    • ReflectionClass::getFileName — Bir dosya adı döndürür
    • ReflectionClass::getInterfaceNames — Arayüz isimlerini döndürür
    • ReflectionClass::getInterfaces — Arayüzleri döndürür
    • ReflectionClass::getMethod — Bir yöntemle ilgili bir ReflectionMethod nesnesi döndürür
    • ReflectionClass::getMethods — Yöntem listesini döndürür
    • ReflectionClass::getModifiers — Değiştiricileri döndürür
    • ReflectionClass::getName — Sınıf ismini döndürür
    • ReflectionClass::getNamespaceName — İsim alanı ismini döndürür
    • ReflectionClass::getParentClass — Ebeveyn sınıfı döndürür
    • ReflectionClass::getProperties — Özellikleri döndürür
    • ReflectionClass::getProperty — Bir özellik döndürür
    • ReflectionClass::getShortName — Kısa adı döndürür
    • ReflectionClass::getStartLine — Başlangıç satır numarasını döndürür
    • ReflectionClass::getStaticProperties — Duruk özellikleri döndürür
    • ReflectionClass::getStaticPropertyValue — Duruk özelliğin değerini döndürür
    • ReflectionClass::getTraitAliases — Returns an array of trait aliases
    • ReflectionClass::getTraitNames — Returns an array of names of traits used by this class
    • ReflectionClass::getTraits — Returns an array of traits used by this class
    • ReflectionClass::hasConstant — Sabit tanımlı mı diye bakar
    • ReflectionClass::hasMethod — Yöntem tanımlı mı diye bakar
    • ReflectionClass::hasProperty — Özellik tanımlı mı diye bakar
    • ReflectionClass::implementsInterface — Arayüz gerçeklenmiş mi diye bakar
    • ReflectionClass::inNamespace — Sınıf isim alanında mı diye bakar
    • ReflectionClass::isAbstract — Sınıf soyut mu diye bakar
    • ReflectionClass::isAnonymous — Checks if class is anonymous
    • ReflectionClass::isCloneable — Returns whether this class is cloneable
    • ReflectionClass::isFinal — Sınıf bir final sınıf mı diye bakar
    • ReflectionClass::isInstance — Sınıf bir nesne örneği mi diye bakar
    • ReflectionClass::isInstantiable — Sınıf örneklenebilir mi diye bakar
    • ReflectionClass::isInterface — Sınıf bir arayüz mü diye bakar
    • ReflectionClass::isInternal — Sınıf yerleşik bir sınıf mı diye bakar
    • ReflectionClass::isIterateable — Sınıf yinelenebilir mi diye bakar
    • ReflectionClass::isSubclassOf — Sınıf bir alt sınıf mı diye bakar
    • ReflectionClass::isTrait — Returns whether this is a trait
    • ReflectionClass::isUserDefined — Sınıf bir kullanıcı tanımlı sınıf mı diye bakar
    • ReflectionClass::newInstance — Yeni örnek
    • ReflectionClass::newInstanceArgs — Yeni örnek değiştirgeleri
    • ReflectionClass::newInstanceWithoutConstructor — Creates a new class instance without invoking the constructor.
    • ReflectionClass::setStaticPropertyValue — Duruk özelliğe değer atar
    • ReflectionClass::__toString — Dizgesel tepkiyi görselleştirir
  • ReflectionExtension — ReflectionExtension Sınıfı
    • ReflectionExtension::__clone — Nesnenin bir kopyasını oluşturur
    • ReflectionExtension::__construct — Bir ReflectionExtension nesnesi oluşturur
    • ReflectionExtension::export — Sınıfı ihraç eder
    • ReflectionExtension::getClasses — Eklentinin sınıflarını döndürür
    • ReflectionExtension::getClassNames — Eklentide tanımlı sınıf isimlerini döndürür
    • ReflectionExtension::getConstants — Eklentinin sabitlerini döndürür
    • ReflectionExtension::getDependencies — Bağımlılıkları döndürür
    • ReflectionExtension::getFunctions — Eklenti işlevlerini döndürür
    • ReflectionExtension::getINIEntries — Eklentinin ini girdilerini döndürür
    • ReflectionExtension::getName — Eklenti ismini döndürür
    • ReflectionExtension::getVersion — Eklentinin sürüm bilgisini döndürür
    • ReflectionExtension::info — Eklenti bilgilerini döndürür
    • ReflectionExtension::isPersistent — Returns whether this extension is persistent
    • ReflectionExtension::isTemporary — Returns whether this extension is temporary
    • ReflectionExtension::__toString — Dizgesel tepkiyi görselleştirir
  • ReflectionFunction — ReflectionFunction Sınıfı
    • ReflectionFunction::__construct — Bir ReflectionFunction nesnesi oluşturur
    • ReflectionFunction::export — İşlevi ihraç eder
    • ReflectionFunction::getClosure — Returns a dynamically created closure for the function
    • ReflectionFunction::invoke — İşlevi çağırır
    • ReflectionFunction::invokeArgs — İşlev değiştirgelerini çağırır
    • ReflectionFunction::isDisabled — İşlevin iptal edilip edilmediğine bakar
    • ReflectionFunction::__toString — Dizgesel tepkiyi görselleştirir
  • ReflectionFunctionAbstract — ReflectionFunctionAbstract sınıfı
    • ReflectionFunctionAbstract::__clone — İşlevi kopyalar
    • ReflectionFunctionAbstract::getClosureScopeClass — Returns the scope associated to the closure
    • ReflectionFunctionAbstract::getClosureThis — Returns this pointer bound to closure
    • ReflectionFunctionAbstract::getDocComment — Belgelendirici açıklamaları döndürür
    • ReflectionFunctionAbstract::getEndLine — Son satır numarasını döndürür
    • ReflectionFunctionAbstract::getExtension — Eklenti bilgilerini döndürür
    • ReflectionFunctionAbstract::getExtensionName — Eklenti ismini döndürür
    • ReflectionFunctionAbstract::getFileName — Dosya ismini döndürür
    • ReflectionFunctionAbstract::getName — İşlev ismini döndürür
    • ReflectionFunctionAbstract::getNamespaceName — İsim alanı adını döndürür
    • ReflectionFunctionAbstract::getNumberOfParameters — Değiştirge sayısını döndürür
    • ReflectionFunctionAbstract::getNumberOfRequiredParameters — Zorunlu değiştirge sayısını döndürür
    • ReflectionFunctionAbstract::getParameters — Değiştirgeleri döndürür
    • ReflectionFunctionAbstract::getReturnType — Gets the specified return type of a function
    • ReflectionFunctionAbstract::getShortName — İşlevin kısa ismini döndürür
    • ReflectionFunctionAbstract::getStartLine — Başlangıç satır numarasını döndürür
    • ReflectionFunctionAbstract::getStaticVariables — Duruk değişkenleri döndürür
    • ReflectionFunctionAbstract::hasReturnType — Checks if the function has a specified return type
    • ReflectionFunctionAbstract::inNamespace — İşlev isim alanına ait mi diye bakar
    • ReflectionFunctionAbstract::isClosure — Bir anonim işlev mi diye bakar
    • ReflectionFunctionAbstract::isDeprecated — Kullanımı önerilmiyor mu diye bakar
    • ReflectionFunctionAbstract::isGenerator — Returns whether this function is a generator
    • ReflectionFunctionAbstract::isInternal — İşlev yerleşik mi diye bakar
    • ReflectionFunctionAbstract::isUserDefined — İşlev kullanıcı tanımlı bir işlev mi diye bakar
    • ReflectionFunctionAbstract::isVariadic — Checks if the function is variadic
    • ReflectionFunctionAbstract::returnsReference — İşlev dönüş değeri gönderimli mi diye bakar
    • ReflectionFunctionAbstract::__toString — Dizgesel tepkiyi görselleştirir
  • ReflectionMethod — ReflectionMethod Sınıfı
    • ReflectionMethod::__construct — Yeni bir ReflectionMethod nesnesi oluşturur
    • ReflectionMethod::export — Sınıfı ihraç eder
    • ReflectionMethod::getClosure — Returns a dynamically created closure for the method
    • ReflectionMethod::getDeclaringClass — Bildiren sınıfı döndürür
    • ReflectionMethod::getModifiers — Değiştirici sayısını döndürür
    • ReflectionMethod::getPrototype — Bildirimi döndürür
    • ReflectionMethod::invoke — Yöntemi çağırır
    • ReflectionMethod::invokeArgs — Değiştirgeleri çağırır
    • ReflectionMethod::isAbstract — Yöntem soyut mu diye bakar
    • ReflectionMethod::isConstructor — Yöntem bir kurucu mu diye bakar
    • ReflectionMethod::isDestructor — Yöntem bir yıkıcı mı diye bakar
    • ReflectionMethod::isFinal — Yöntem final olarak mı bildirilmiş diye bakar
    • ReflectionMethod::isPrivate — Yöntem private olarak mı bildirilmiş diye bakar
    • ReflectionMethod::isProtected — Yöntem protected olarak mı bildirilmiş diye bakar
    • ReflectionMethod::isPublic — Yöntem public olarak mı bildirilmiş diye bakar
    • ReflectionMethod::isStatic — Yöntem bir duruk yöntem mi diye bakar
    • ReflectionMethod::setAccessible — Set method accessibility
    • ReflectionMethod::__toString — Dizgesel tepkiyi görselleştirir
  • ReflectionObject — ReflectionObject Sınıfı
    • ReflectionObject::__construct — Bir ReflectionObject nesnesi oluşturur
    • ReflectionObject::export — Sınıfı ihraç eder
  • ReflectionParameter — ReflectionParameter Sınıfı
    • ReflectionParameter::allowsNull — NULL değere izin veriliyor mu diye bakar
    • ReflectionParameter::canBePassedByValue — Returns whether this parameter can be passed by value
    • ReflectionParameter::__clone — Nesneyi kopyalar
    • ReflectionParameter::__construct — Bir ReflectionParameter nesnesi oluşturur
    • ReflectionParameter::export — Sınıfı ihraç eder
    • ReflectionParameter::getClass — Sınıfı döndürür
    • ReflectionParameter::getDeclaringClass — Bildiren sınıfı döndürür
    • ReflectionParameter::getDeclaringFunction — Bildiren işlevi döndürür
    • ReflectionParameter::getDefaultValue — Değiştirgenin öntanımlı değerini döndürür
    • ReflectionParameter::getDefaultValueConstantName — Returns the default value's constant name if default value is constant or null
    • ReflectionParameter::getName — Değiştirgenin ismini döndürür
    • ReflectionParameter::getPosition — Değiştirgenin konumunu döndürür
    • ReflectionParameter::getType — Gets a parameter's type
    • ReflectionParameter::hasType — Checks if parameter has a type
    • ReflectionParameter::isArray — Değiştirge değeri bir dizi mi olacak diye bakar
    • ReflectionParameter::isCallable — Returns whether parameter MUST be callable
    • ReflectionParameter::isDefaultValueAvailable — Öntanımlı bir değerin kullanılabilir olup olmadığına bakar
    • ReflectionParameter::isDefaultValueConstant — Returns whether the default value of this parameter is constant
    • ReflectionParameter::isOptional — Değiştirge seçimlik mi diye bakar
    • ReflectionParameter::isPassedByReference — Değiştirge gönderimli aktarılabilir mi diye bakar
    • ReflectionParameter::isVariadic — Checks if the parameter is variadic
    • ReflectionParameter::__toString — Dizgesel tepkiyi görselleştirir
  • ReflectionProperty — ReflectionProperty Sınıfı
    • ReflectionProperty::__clone — Özelliği kopyalar
    • ReflectionProperty::__construct — Bir ReflectionProperty nesnesi oluşturur
    • ReflectionProperty::export — Özelliği ihraç eder
    • ReflectionProperty::getDeclaringClass — Bildiren sınıfı döndürür
    • ReflectionProperty::getDocComment — Bilgilendirici açıklamaları döndürür
    • ReflectionProperty::getModifiers — Değiştirici sayısını döndürür
    • ReflectionProperty::getName — Özelliğin ismini döndürür
    • ReflectionProperty::getValue — Özelliğin değerini döndürür
    • ReflectionProperty::isDefault — Öntanımlı değer mi atanmış diye bakar
    • ReflectionProperty::isPrivate — Özellik private olarak mı bildirilmiş diye bakar
    • ReflectionProperty::isProtected — Özellik protected olarak mı bildirilmiş diye bakar
    • ReflectionProperty::isPublic — Özellik public olarak mı bildirilmiş diye bakar
    • ReflectionProperty::isStatic — Özellik duruk mu diye bakar
    • ReflectionProperty::setAccessible — Özelliği erişilebilir kılar
    • ReflectionProperty::setValue — Özelliğe değer atar
    • ReflectionProperty::__toString — Dizgesel tepkiyi görselleştirir
  • Reflector — Reflector Arayüzü
    • Reflector::export — Sınıfı ihraç eder
    • Reflector::__toString — Dizgesel tepkiyi görselleştirir
QuickHashIntStringHash::update
Giriş
Değişkenler ve Veri Türleriyle İlgili Eklentiler


Giriş

PHP 5, sınıflar, arayüzler, işlevler, yöntemler ve hatta eklentiler üzerinde "tersine mühendislik" yapabilmeyi sağlayan eksiksiz bir yansıtma arayüzü ile gelmektedir. Buna ek olarak, yansıtma arayüzü, işlevler, sınıflar ve yöntemler için belgeleme açıklamalarının elde edilmesini sağlayan yollar içerir.

Reflection
Yapılandırma/Kurulum
Reflection


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Reflection


Öntanımlı Sabitler

Her sınıfın kendi sabitleri vardır.

Özkaynak Türleri
Örnekler
Reflection


Örnekler

Reflection eklentisinin belgelerinde bir çok örnek vardır ve genellikle bunlar her sınıfın kurucusunun belgesinde yer almaktadır.

Örnek 1 - Reflection eklentisinin kabuktan kullanımı

$ php --rf strlen
$ php --rc finfo
$ php --re json
$ php --ri dom

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Function [ <internal:Core> function strlen ] {

  - Parameters [1] {
    Parameter #0 [ <required> $str ]
  }
}

Class [ <internal:fileinfo> class finfo ] {

  - Constants [0] {
  }

  - Static properties [0] {
  }

  - Static methods [0] {
  }

  - Properties [0] {
  }

  - Methods [4] {
    Method [ <internal:fileinfo, ctor> public method finfo ] {

      - Parameters [2] {
        Parameter #0 [ <optional> $options ]
        Parameter #1 [ <optional> $arg ]
      }
    }

    Method [ <internal:fileinfo> public method set_flags ] {

      - Parameters [1] {
        Parameter #0 [ <required> $options ]
      }
    }

    Method [ <internal:fileinfo> public method file ] {

      - Parameters [3] {
        Parameter #0 [ <required> $filename ]
        Parameter #1 [ <optional> $options ]
        Parameter #2 [ <optional> $context ]
      }
    }

    Method [ <internal:fileinfo> public method buffer ] {

      - Parameters [3] {
        Parameter #0 [ <required> $string ]
        Parameter #1 [ <optional> $options ]
        Parameter #2 [ <optional> $context ]
      }
    }
  }
}

Extension [ <persistent> extension #23 json version 1.2.1 ] {

  - Constants [10] {
    Constant [ integer JSON_HEX_TAG ] { 1 }
    Constant [ integer JSON_HEX_AMP ] { 2 }
    Constant [ integer JSON_HEX_APOS ] { 4 }
    Constant [ integer JSON_HEX_QUOT ] { 8 }
    Constant [ integer JSON_FORCE_OBJECT ] { 16 }
    Constant [ integer JSON_ERROR_NONE ] { 0 }
    Constant [ integer JSON_ERROR_DEPTH ] { 1 }
    Constant [ integer JSON_ERROR_STATE_MISMATCH ] { 2 }
    Constant [ integer JSON_ERROR_CTRL_CHAR ] { 3 }
    Constant [ integer JSON_ERROR_SYNTAX ] { 4 }
  }

  - Functions {
    Function [ <internal:json> function json_encode ] {

      - Parameters [2] {
        Parameter #0 [ <required> $value ]
        Parameter #1 [ <optional> $options ]
      }
    }
    Function [ <internal:json> function json_decode ] {

      - Parameters [3] {
        Parameter #0 [ <required> $json ]
        Parameter #1 [ <optional> $assoc ]
        Parameter #2 [ <optional> $depth ]
      }
    }
    Function [ <internal:json> function json_last_error ] {

      - Parameters [0] {
      }
    }
  }
}

dom

DOM/XML => enabled
DOM/XML API Version => 20031129
libxml Version => 2.7.3
HTML Support => enabled
XPath Support => enabled
XPointer Support => enabled
Schema Support => enabled
RelaxNG Support => enabled
Öntanımlı Sabitler
Yansıtma Sınıflarının Genişletilmesi
Reflection


Yansıtma Sınıflarının Genişletilmesi

Yerleşik sınıfların özelleştirilmiş sürümlerini oluşturmak istediğiniz takdirde (yöntemler yerine üye değişkenlere kolayca erişmek veya aracı yöntemlere sahip olmak ya da renkli HTML sürümünü oluşturmak istiyorsunuz diyelim), baştan sona hepsini genişletebilirsiniz.

Örnek 1 - Yerleşik sınıfların genişletilmesi

<?php
/**
 * Kendi Reflection_Method sınıfımız
 */
class My_Reflection_Method extends ReflectionMethod
{
    public $visibility = array();

    public function __construct($o, $m)
    {
      parent::__construct($o, $m);
      $this->visibility = Reflection::getModifierNames($this->getModifiers());
    }
}

/**
 * Sınıf denemesi 1
 *
 */
class T {
    protected function x() {}
}

/**
 * Sınıf denemesi 2
 *
 */
class U extends T {
    function x() {}
}

// Bilgiler görelim
var_dump(new My_Reflection_Method('U', 'x'));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(My_Reflection_Method)#1 (3) {
  ["visibility"]=>
  array(1) {
    [0]=>
    string(6) "public"
  }
  ["name"]=>
  string(1) "x"
  ["class"]=>
  string(1) "U"
}
Dikkat

Kurucunun üzerine yazıyorsanız, herhangi bir kod yazmadan önce ebeveynin kurucusunu çağırmayı unutmayın. Bunu yapmazsanız şöyle bir sonuç alırsınız: Fatal error: Internal error: Failed to retrieve the reflection object Türkçesi: Ölümcül hata: Dahili hata: reflection nesnesi alınamadı

Örnekler
Reflection
Reflection


Reflection Sınıfı

(PHP 5, PHP 7)

Giriş

Yansıtma sınıfı.

Sınıf Sözdizimi

Reflection {
/* Yöntemler */
public static void export ( Reflector $yansıtıcı [, string $ihracet = false ] )
public static array getModifierNames ( int $değiştiriciler )
}

İçindekiler

  • Reflection::export — Sınıfı ihraç eder
  • Reflection::getModifierNames — Değiştirici isimlerini döndürür
Yansıtma Sınıflarının Genişletilmesi
Reflection::export
Reflection


Sınıfı ihraç eder

Reflection
Reflection::getModifierNames
Reflection
PHP Manual

Reflection::export

(PHP 5, PHP 7)

Reflection::export — Sınıfı ihraç eder

Açıklama

public static void Reflection::export ( Reflector $yansıtıcı [, string $ihracet = false ] )

Bir sınıfı ihraceder.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

yansıtıcı

İhraç edilecek Reflection nesnesi.

ihracet

TRUE belirtilirse yansıtmak yerine ihrac eder. FALSE olursa (öntanımlıdır) tersini yapar.

Dönen Değerler

TRUE belirtilirse bir dizge yoksa NULL döner.

Ayrıca Bakınız

  • Reflection::getModifierNames() - Değiştirici isimlerini döndürür

Reflection
Reflection::getModifierNames
Reflection


Değiştirici isimlerini döndürür

Reflection::export
ReflectionClass
Reflection
PHP Manual

Reflection::getModifierNames

(PHP 5, PHP 7)

Reflection::getModifierNames — Değiştirici isimlerini döndürür

Açıklama

public static array Reflection::getModifierNames ( int $değiştiriciler )

Değiştirici isimlerini döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

değiştiriciler

Bir sayısal değerdeki değiştiriciler.

Dönen Değerler

Değiştirici isimlerini içeren bir dizi.

Ayrıca Bakınız

  • Reflection::export() - Sınıfı ihraç eder

Reflection::export
ReflectionClass
Reflection


ReflectionClass Sınıfı

(PHP 5, PHP 7)

Giriş

ReflectionClass sınıfı bir sınıf hakkında bilgi edinilmesini sağlar.

Sınıf Sözdizimi

ReflectionClass implements Reflector {
/* Sabitler */
const integer IS_IMPLICIT_ABSTRACT = 16 ;
const integer IS_EXPLICIT_ABSTRACT = 32 ;
const integer IS_FINAL = 64 ;
/* Özellikler */
public $name ;
/* Yöntemler */
__construct ( string $değiştirge )
public static string export ( mixed $değiştirge [, bool $ihracet = false ] )
public mixed getConstant ( string $isim )
public array getConstants ( void )
public object getConstructor ( void )
public array getDefaultProperties ( void )
public string getDocComment ( void )
public int getEndLine ( void )
public ReflectionExtension getExtension ( void )
public string getExtensionName ( void )
public string getFileName ( void )
public array getInterfaceNames ( void )
public array getInterfaces ( void )
public object getMethod ( string $isim )
public array getMethods ([ string $süzgeç ] )
public int getModifiers ( void )
public string getName ( void )
public string getNamespaceName ( void )
public object getParentClass ( void )
public array getProperties ([ int $süzgeç ] )
public ReflectionProperty getProperty ( string $isim )
public string getShortName ( void )
public int getStartLine ( void )
public array getStaticProperties ( void )
public mixed getStaticPropertyValue ( string $isim [, string $öntanımlı ] )
public array getTraitAliases ( void )
public array getTraitNames ( void )
public array getTraits ( void )
public bool hasConstant ( string $isim )
public bool hasMethod ( string $isim )
public bool hasProperty ( string $isim )
public bool implementsInterface ( string $arayüz )
public bool inNamespace ( void )
public bool isAbstract ( void )
public bool isAnonymous ( void )
public bool isCloneable ( void )
public bool isFinal ( void )
public bool isInstance ( string $nesne )
public bool isInstantiable ( void )
public bool isInterface ( void )
public bool isInternal ( void )
public bool isIterateable ( void )
public bool isSubclassOf ( string $sınıf )
public bool isTrait ( void )
public bool isUserDefined ( void )
public object newInstance ( mixed $değiştirgeler [, mixed $... ] )
public object newInstanceArgs ([ array $değiştirgeler ] )
public object newInstanceWithoutConstructor ( void )
public void setStaticPropertyValue ( string $isim , string $değer )
public string __toString ( void )
}

Özellikler

name

Sınıfın ismi. Salt-okunur olup, yazılmaya çalışılırsa ReflectionException istisnası oluşur.

Öntanımlı Sabitler

ReflectionClass Değiştiricileri

ReflectionClass::IS_IMPLICIT_ABSTRACT

Bazı soyut yöntemler içerdiğinden sınıfın soyut olduğunu belirtir.

ReflectionClass::IS_EXPLICIT_ABSTRACT

Sınıfın tanımından dolayı soyut olduğunu belirtir.

ReflectionClass::IS_FINAL

Sınıfın bir final sınıf olduğunu belirtir.

İçindekiler

  • ReflectionClass::__construct — Bir ReflectionClass nesnesi oluşturur
  • ReflectionClass::export — Bir sınıf ihraç eder
  • ReflectionClass::getConstant — Tanımlı sabitleri döndürür
  • ReflectionClass::getConstants — Sabitleri döndürür
  • ReflectionClass::getConstructor — Kurucuyu döndürür
  • ReflectionClass::getDefaultProperties — Öntanımlı özellikleri döndürür
  • ReflectionClass::getDocComment — Belgelendirici açıklamaları döndürür
  • ReflectionClass::getEndLine — Son satırın numarasını döndürür
  • ReflectionClass::getExtension — Eklenti bilgilerini döndürür
  • ReflectionClass::getExtensionName — Eklentinin ismini döndürür
  • ReflectionClass::getFileName — Bir dosya adı döndürür
  • ReflectionClass::getInterfaceNames — Arayüz isimlerini döndürür
  • ReflectionClass::getInterfaces — Arayüzleri döndürür
  • ReflectionClass::getMethod — Bir yöntemle ilgili bir ReflectionMethod nesnesi döndürür
  • ReflectionClass::getMethods — Yöntem listesini döndürür
  • ReflectionClass::getModifiers — Değiştiricileri döndürür
  • ReflectionClass::getName — Sınıf ismini döndürür
  • ReflectionClass::getNamespaceName — İsim alanı ismini döndürür
  • ReflectionClass::getParentClass — Ebeveyn sınıfı döndürür
  • ReflectionClass::getProperties — Özellikleri döndürür
  • ReflectionClass::getProperty — Bir özellik döndürür
  • ReflectionClass::getShortName — Kısa adı döndürür
  • ReflectionClass::getStartLine — Başlangıç satır numarasını döndürür
  • ReflectionClass::getStaticProperties — Duruk özellikleri döndürür
  • ReflectionClass::getStaticPropertyValue — Duruk özelliğin değerini döndürür
  • ReflectionClass::getTraitAliases — Returns an array of trait aliases
  • ReflectionClass::getTraitNames — Returns an array of names of traits used by this class
  • ReflectionClass::getTraits — Returns an array of traits used by this class
  • ReflectionClass::hasConstant — Sabit tanımlı mı diye bakar
  • ReflectionClass::hasMethod — Yöntem tanımlı mı diye bakar
  • ReflectionClass::hasProperty — Özellik tanımlı mı diye bakar
  • ReflectionClass::implementsInterface — Arayüz gerçeklenmiş mi diye bakar
  • ReflectionClass::inNamespace — Sınıf isim alanında mı diye bakar
  • ReflectionClass::isAbstract — Sınıf soyut mu diye bakar
  • ReflectionClass::isAnonymous — Checks if class is anonymous
  • ReflectionClass::isCloneable — Returns whether this class is cloneable
  • ReflectionClass::isFinal — Sınıf bir final sınıf mı diye bakar
  • ReflectionClass::isInstance — Sınıf bir nesne örneği mi diye bakar
  • ReflectionClass::isInstantiable — Sınıf örneklenebilir mi diye bakar
  • ReflectionClass::isInterface — Sınıf bir arayüz mü diye bakar
  • ReflectionClass::isInternal — Sınıf yerleşik bir sınıf mı diye bakar
  • ReflectionClass::isIterateable — Sınıf yinelenebilir mi diye bakar
  • ReflectionClass::isSubclassOf — Sınıf bir alt sınıf mı diye bakar
  • ReflectionClass::isTrait — Returns whether this is a trait
  • ReflectionClass::isUserDefined — Sınıf bir kullanıcı tanımlı sınıf mı diye bakar
  • ReflectionClass::newInstance — Yeni örnek
  • ReflectionClass::newInstanceArgs — Yeni örnek değiştirgeleri
  • ReflectionClass::newInstanceWithoutConstructor — Creates a new class instance without invoking the constructor.
  • ReflectionClass::setStaticPropertyValue — Duruk özelliğe değer atar
  • ReflectionClass::__toString — Dizgesel tepkiyi görselleştirir
Reflection::getModifierNames
ReflectionClass::__construct
Reflection


Bir ReflectionClass nesnesi oluşturur

ReflectionClass
ReflectionClass::export
ReflectionClass
PHP Manual

ReflectionClass::__construct

(PHP 5, PHP 7)

ReflectionClass::__construct — Bir ReflectionClass nesnesi oluşturur

Açıklama

ReflectionClass::__construct ( string $değiştirge )

Yeni bir ReflectionClass nesnesi oluşturur.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

değiştirge

Yansıtılacak sınıf.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 - Temel kullanım örneği

<?php
Reflection::export(new ReflectionClass('Exception'));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Class [ <internal:Core> class Exception ] {

  - Constants [0] {
  }

  - Static properties [0] {
  }

  - Static methods [0] {
  }

  - Properties [7] {
    Property [ <default> protected $message ]
    Property [ <default> private $string ]
    Property [ <default> protected $code ]
    Property [ <default> protected $file ]
    Property [ <default> protected $line ]
    Property [ <default> private $trace ]
    Property [ <default> private $previous ]
  }

  - Methods [10] {
    Method [ <internal:Core> final private method __clone ] {
    }

    Method [ <internal:Core, ctor> public method __construct ] {

      - Parameters [3] {
        Parameter #0 [ <optional> $message ]
        Parameter #1 [ <optional> $code ]
        Parameter #2 [ <optional> $previous ]
      }
    }

    Method [ <internal:Core> final public method getMessage ] {
    }

    Method [ <internal:Core> final public method getCode ] {
    }

    Method [ <internal:Core> final public method getFile ] {
    }

    Method [ <internal:Core> final public method getLine ] {
    }

    Method [ <internal:Core> final public method getTrace ] {
    }

    Method [ <internal:Core> final public method getPrevious ] {
    }

    Method [ <internal:Core> final public method getTraceAsString ] {
    }

    Method [ <internal:Core> public method __toString ] {
    }
  }
}

Ayrıca Bakınız

  • ReflectionObject::__construct() - Bir ReflectionObject nesnesi oluşturur
  • Kurucular ve Yıkıcılar

ReflectionClass
ReflectionClass::export
ReflectionClass


Bir sınıf ihraç eder

ReflectionClass::__construct
ReflectionClass::getConstant
ReflectionClass
PHP Manual

ReflectionClass::export

(PHP 5, PHP 7)

ReflectionClass::export — Bir sınıf ihraç eder

Açıklama

public static string ReflectionClass::export ( mixed $değiştirge [, bool $ihracet = false ] )

Bir yansıtıcı sınıfı ihraç eder.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

değiştirge

İhraç edilecek Reflection nesnesi.

ihracet

TRUE belirtilirse yansıtmak yerine ihrac eder. FALSE olursa (öntanımlıdır) tersini yapar.

Dönen Değerler

TRUE belirtilirse bir dizge yoksa NULL döner.

Ayrıca Bakınız

  • ReflectionClass::getName() - Sınıf ismini döndürür

ReflectionClass::__construct
ReflectionClass::getConstant
ReflectionClass


Tanımlı sabitleri döndürür

ReflectionClass::export
ReflectionClass::getConstants
ReflectionClass
PHP Manual

ReflectionClass::getConstant

(PHP 5, PHP 7)

ReflectionClass::getConstant — Tanımlı sabitleri döndürür

Açıklama

public mixed ReflectionClass::getConstant ( string $isim )

Tanımlı sabitleri döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

isim

Dönen Değerler

Ayrıca Bakınız

  • ReflectionClass::getConstants() - Sabitleri döndürür

ReflectionClass::export
ReflectionClass::getConstants
ReflectionClass


Sabitleri döndürür

ReflectionClass::getConstant
ReflectionClass::getConstructor
ReflectionClass
PHP Manual

ReflectionClass::getConstants

(PHP 5, PHP 7)

ReflectionClass::getConstants — Sabitleri döndürür

Açıklama

public array ReflectionClass::getConstants ( void )

Sınıfın tanımlı sabitlerini döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Sabitleri içeren bir dizi.

Ayrıca Bakınız

  • ReflectionClass::getConstant() - Tanımlı sabitleri döndürür

ReflectionClass::getConstant
ReflectionClass::getConstructor
ReflectionClass


Kurucuyu döndürür

ReflectionClass::getConstants
ReflectionClass::getDefaultProperties
ReflectionClass
PHP Manual

ReflectionClass::getConstructor

(PHP 5, PHP 7)

ReflectionClass::getConstructor — Kurucuyu döndürür

Açıklama

public object ReflectionClass::getConstructor ( void )

Sınıf kurucusunu döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Bir ReflectionMethod nesnesi.

Ayrıca Bakınız

  • ReflectionClass::getName() - Sınıf ismini döndürür

ReflectionClass::getConstants
ReflectionClass::getDefaultProperties
ReflectionClass


Öntanımlı özellikleri döndürür

ReflectionClass::getConstructor
ReflectionClass::getDocComment
ReflectionClass
PHP Manual

ReflectionClass::getDefaultProperties

(PHP 5, PHP 7)

ReflectionClass::getDefaultProperties — Öntanımlı özellikleri döndürür

Açıklama

public array ReflectionClass::getDefaultProperties ( void )

Sınıfın öntanımlı özelliklerini döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Öntanımlı özellikleri içeren bir dizi.

Ayrıca Bakınız

  • ReflectionClass::getProperties() - Özellikleri döndürür

ReflectionClass::getConstructor
ReflectionClass::getDocComment
ReflectionClass


Belgelendirici açıklamaları döndürür

ReflectionClass::getDefaultProperties
ReflectionClass::getEndLine
ReflectionClass
PHP Manual

ReflectionClass::getDocComment

(PHP 5 >= 5.1.0, PHP 7)

ReflectionClass::getDocComment — Belgelendirici açıklamaları döndürür

Açıklama

public string ReflectionClass::getDocComment ( void )

Sınıftan belgelendirici açıklamaları döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Varsa belgelelndirici açıklamalar, yoksa FALSE döner.

Örnekler

Örnek 1 - ReflectionClass::getDocComment() örneği

<?php
/**
* A test class
*
* @param  foo bar
* @return baz
*/
class TestClass { }

$rc = new ReflectionClass('TestClass');
var_dump($rc->getDocComment())
?>

Yukarıdaki örneğin çıktısı:

string(55) "/**
* A test class
*
* @param  foo bar
* @return baz
*/"

Ayrıca Bakınız

  • ReflectionClass::getName() - Sınıf ismini döndürür

ReflectionClass::getDefaultProperties
ReflectionClass::getEndLine
ReflectionClass


Son satırın numarasını döndürür

ReflectionClass::getDocComment
ReflectionClass::getExtension
ReflectionClass
PHP Manual

ReflectionClass::getEndLine

(PHP 5, PHP 7)

ReflectionClass::getEndLine — Son satırın numarasını döndürür

Açıklama

public int ReflectionClass::getEndLine ( void )

Bir kullanıcı tanımlı sınıfın son satırının numarasını döndürür.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Bir kullanıcı tanımlı sınıfın son satırının numarasını döndürür. Satır numarası bilinmiyorsa FALSE döner.

Örnekler

Örnek 1 - ReflectionClass::getEndLine() örneği

<?php
// Test Class
class TestClass { }

$rc = new ReflectionClass('TestClass');

echo $rc->getEndLine();
?>

Yukarıdaki örneğin çıktısı:

3

Ayrıca Bakınız

  • ReflectionClass::getStartLine() - Başlangıç satır numarasını döndürür

ReflectionClass::getDocComment
ReflectionClass::getExtension
ReflectionClass


Eklenti bilgilerini döndürür

ReflectionClass::getEndLine
ReflectionClass::getExtensionName
ReflectionClass
PHP Manual

ReflectionClass::getExtension

(PHP 5, PHP 7)

ReflectionClass::getExtension — Eklenti bilgilerini döndürür

Açıklama

public ReflectionExtension ReflectionClass::getExtension ( void )

Bir eklentinin ReflectionExtension nesnesini döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Bir ReflectionExtension nesnesi.

Ayrıca Bakınız

  • ReflectionClass::getExtensionName() - Eklentinin ismini döndürür

ReflectionClass::getEndLine
ReflectionClass::getExtensionName
ReflectionClass


Eklentinin ismini döndürür

ReflectionClass::getExtension
ReflectionClass::getFileName
ReflectionClass
PHP Manual

ReflectionClass::getExtensionName

(PHP 5, PHP 7)

ReflectionClass::getExtensionName — Eklentinin ismini döndürür

Açıklama

public string ReflectionClass::getExtensionName ( void )

Eklentinin ismini döndürür

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Eklentinin ismi.

Ayrıca Bakınız

  • ReflectionClass::getExtension() - Eklenti bilgilerini döndürür

ReflectionClass::getExtension
ReflectionClass::getFileName
ReflectionClass


Bir dosya adı döndürür

ReflectionClass::getExtensionName
ReflectionClass::getInterfaceNames
ReflectionClass
PHP Manual

ReflectionClass::getFileName

(PHP 5, PHP 7)

ReflectionClass::getFileName — Bir dosya adı döndürür

Açıklama

public string ReflectionClass::getFileName ( void )

Bir dosya adı döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Dosya adı.

Ayrıca Bakınız

  • ReflectionClass::getExtensionName() - Eklentinin ismini döndürür

ReflectionClass::getExtensionName
ReflectionClass::getInterfaceNames
ReflectionClass


Arayüz isimlerini döndürür

ReflectionClass::getFileName
ReflectionClass::getInterfaces
ReflectionClass
PHP Manual

ReflectionClass::getInterfaceNames

(PHP 5 >= 5.2.0, PHP 7)

ReflectionClass::getInterfaceNames — Arayüz isimlerini döndürür

Açıklama

public array ReflectionClass::getInterfaceNames ( void )

Arayüz isimlerini döndürür.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Arayüz isimlerini bir sayısal indisli dizi olarak döndürür.

Örnekler

Örnek 1 - ReflectionClass::getInterfaceNames() örneği

<?php
interface Foo { }

interface Bar { }

class Baz implements Foo, Bar { }

$rc1 = new ReflectionClass("Baz");

print_r($rc1->getInterfaceNames());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [0] => Foo
    [1] => Bar
)

Ayrıca Bakınız

  • ReflectionClass::getInterfaces() - Arayüzleri döndürür

ReflectionClass::getFileName
ReflectionClass::getInterfaces
ReflectionClass


Arayüzleri döndürür

ReflectionClass::getInterfaceNames
ReflectionClass::getMethod
ReflectionClass
PHP Manual

ReflectionClass::getInterfaces

(PHP 5, PHP 7)

ReflectionClass::getInterfaces — Arayüzleri döndürür

Açıklama

public array ReflectionClass::getInterfaces ( void )

Arayüzleri döndürür.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Anahtarların arayüz isimlerini, değerlerin ise ReflectionClass nesnelerini içerdiği bir dizi döner.

Örnekler

Örnek 1 - ReflectionClass::getInterfaces() örneği

<?php
interface Foo { }

interface Bar { }

class Baz implements Foo, Bar { }

$rc1 = new ReflectionClass("Baz");

print_r($rc1->getInterfaces());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
Array
(
    [Foo] => ReflectionClass Object
        (
            [name] => Foo
        )

    [Bar] => ReflectionClass Object
        (
            [name] => Bar
        )

)

Ayrıca Bakınız

  • ReflectionClass::getInterfaceNames() - Arayüz isimlerini döndürür

ReflectionClass::getInterfaceNames
ReflectionClass::getMethod
ReflectionClass


Bir yöntemle ilgili bir ReflectionMethod nesnesi döndürür

ReflectionClass::getInterfaces
ReflectionClass::getMethods
ReflectionClass
PHP Manual

ReflectionClass::getMethod

(PHP 5, PHP 7)

ReflectionClass::getMethod — Bir yöntemle ilgili bir ReflectionMethod nesnesi döndürür

Açıklama

public object ReflectionClass::getMethod ( string $isim )

İsmi belirtilen yöntemle ilgili bir ReflectionMethod nesnesi döndürür

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

isim

Bilgileri yansıtılacak yöntemin ismi.

Dönen Değerler

Bir ReflectionMethod nesnesi.

Ayrıca Bakınız

  • ReflectionClass::getMethods() - Yöntem listesini döndürür

ReflectionClass::getInterfaces
ReflectionClass::getMethods
ReflectionClass


Yöntem listesini döndürür

ReflectionClass::getMethod
ReflectionClass::getModifiers
ReflectionClass
PHP Manual

ReflectionClass::getMethods

(PHP 5, PHP 7)

ReflectionClass::getMethods — Yöntem listesini döndürür

Açıklama

public array ReflectionClass::getMethods ([ string $süzgeç ] )

Yöntem listesini döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

süzgeç

Süzgeç.

Dönen Değerler

Yöntemleri içeren bir dizi.

Ayrıca Bakınız

  • ReflectionClass::getMethod() - Bir yöntemle ilgili bir ReflectionMethod nesnesi döndürür

ReflectionClass::getMethod
ReflectionClass::getModifiers
ReflectionClass


Değiştiricileri döndürür

ReflectionClass::getMethods
ReflectionClass::getName
ReflectionClass
PHP Manual

ReflectionClass::getModifiers

(PHP 5, PHP 7)

ReflectionClass::getModifiers — Değiştiricileri döndürür

Açıklama

public int ReflectionClass::getModifiers ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Ayrıca Bakınız

  • ReflectionClass::getProperties() - Özellikleri döndürür

ReflectionClass::getMethods
ReflectionClass::getName
ReflectionClass


Sınıf ismini döndürür

ReflectionClass::getModifiers
ReflectionClass::getNamespaceName
ReflectionClass
PHP Manual

ReflectionClass::getName

(PHP 5, PHP 7)

ReflectionClass::getName — Sınıf ismini döndürür

Açıklama

public string ReflectionClass::getName ( void )

Sınıf ismini döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Sınıf ismi.

Örnekler

Örnek 1 - ReflectionClass::getName() örneği

<?php
namespace A\B;

class Foo { }

$function = new \ReflectionClass('stdClass');

var_dump($function->inNamespace());
var_dump($function->getName());
var_dump($function->getNamespaceName());
var_dump($function->getShortName());

$function = new \ReflectionClass('A\\B\\Foo');

var_dump($function->inNamespace());
var_dump($function->getName());
var_dump($function->getNamespaceName());
var_dump($function->getShortName());
?>

Yukarıdaki örneğin çıktısı:

bool(false)
string(8) "stdClass"
string(0) ""
string(8) "stdClass"

bool(true)
string(7) "A\B\Foo"
string(3) "A\B"
string(3) "Foo"

Ayrıca Bakınız

  • ReflectionClass::getNamespaceName() - İsim alanı ismini döndürür

ReflectionClass::getModifiers
ReflectionClass::getNamespaceName
ReflectionClass


İsim alanı ismini döndürür

ReflectionClass::getName
ReflectionClass::getParentClass
ReflectionClass
PHP Manual

ReflectionClass::getNamespaceName

(PHP 5 >= 5.3.0, PHP 7)

ReflectionClass::getNamespaceName — İsim alanı ismini döndürür

Açıklama

public string ReflectionClass::getNamespaceName ( void )

İsim alanı ismini döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

İsim alanı ismi.

Örnekler

Örnek 1 - ReflectionClass::getNamespaceName() örneği

<?php
namespace A\B;

class Foo { }

$function = new \ReflectionClass('stdClass');

var_dump($function->inNamespace());
var_dump($function->getName());
var_dump($function->getNamespaceName());
var_dump($function->getShortName());

$function = new \ReflectionClass('A\\B\\Foo');

var_dump($function->inNamespace());
var_dump($function->getName());
var_dump($function->getNamespaceName());
var_dump($function->getShortName());
?>

Yukarıdaki örneğin çıktısı:

bool(false)
string(8) "stdClass"
string(0) ""
string(8) "stdClass"

bool(true)
string(7) "A\B\Foo"
string(3) "A\B"
string(3) "Foo"

Ayrıca Bakınız

  • ReflectionClass::getParentClass() - Ebeveyn sınıfı döndürür
  • İsim Alanları

ReflectionClass::getName
ReflectionClass::getParentClass
ReflectionClass


Ebeveyn sınıfı döndürür

ReflectionClass::getNamespaceName
ReflectionClass::getProperties
ReflectionClass
PHP Manual

ReflectionClass::getParentClass

(PHP 5, PHP 7)

ReflectionClass::getParentClass — Ebeveyn sınıfı döndürür

Açıklama

public object ReflectionClass::getParentClass ( void )

Ebeveyn sınıfı döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Bir ReflectionClass nesnesi.

Ayrıca Bakınız

  • ReflectionClass::__construct() - Bir ReflectionClass nesnesi oluşturur

ReflectionClass::getNamespaceName
ReflectionClass::getProperties
ReflectionClass


Özellikleri döndürür

ReflectionClass::getParentClass
ReflectionClass::getProperty
ReflectionClass
PHP Manual

ReflectionClass::getProperties

(PHP 5, PHP 7)

ReflectionClass::getProperties — Özellikleri döndürür

Açıklama

public array ReflectionClass::getProperties ([ int $süzgeç ] )

Yansıtılan özellikleri döndürür.

Değiştirgeler

süzgeç

İstenen özellik türlerini seçmek için seçimlik süzgeç. Öntanımlı olarak tüm özellik türlerini seçmeye ayarlı olup, ReflectionProperty sabitleri kullanılarak yapılandırılabilir.

Dönen Değerler

ReflectionProperty nesnelerini içeren bir dizi.

Örnekler

Örnek 1 - ReflectionClass::getProperties() süzgeç örneği

Bu örnek isteğe bağlı süzgeç değiştirgesinin özel nitelikleri atlayacak şekilde kullanımını gösterir.

<?php
class Foo {
    public    $foo  = 1;
    protected $bar  = 2;
    private   $baz  = 3;
}

$foo = new Foo();

$reflect = new ReflectionClass($foo);
$props   = $reflect->getProperties(ReflectionProperty::IS_PUBLIC | ReflectionProperty::IS_PROTECTED);

foreach ($props as $prop) {
    print $prop->getName() . "\n";
}

var_dump($props);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

foo
bar
array(2) {
  [0]=>
  object(ReflectionProperty)#3 (2) {
    ["name"]=>
    string(3) "foo"
    ["class"]=>
    string(3) "Foo"
  }
  [1]=>
  object(ReflectionProperty)#4 (2) {
    ["name"]=>
    string(3) "bar"
    ["class"]=>
    string(3) "Foo"
  }
}

Ayrıca Bakınız

  • ReflectionClass::getProperty() - Bir özellik döndürür
  • ReflectionProperty
  • ReflectionProperty değiştirici sabitleri

ReflectionClass::getParentClass
ReflectionClass::getProperty
ReflectionClass


Bir özellik döndürür

ReflectionClass::getProperties
ReflectionClass::getShortName
ReflectionClass
PHP Manual

ReflectionClass::getProperty

(PHP 5, PHP 7)

ReflectionClass::getProperty — Bir özellik döndürür

Açıklama

public ReflectionProperty ReflectionClass::getProperty ( string $isim )

Bir özellik döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

isim

Özelliğin ismi.

Dönen Değerler

Bir ReflectionProperty nesnesi.

Ayrıca Bakınız

  • ReflectionClass::getProperties() - Özellikleri döndürür

ReflectionClass::getProperties
ReflectionClass::getShortName
ReflectionClass


Kısa adı döndürür

ReflectionClass::getProperty
ReflectionClass::getStartLine
ReflectionClass
PHP Manual

ReflectionClass::getShortName

(PHP 5 >= 5.3.0, PHP 7)

ReflectionClass::getShortName — Kısa adı döndürür

Açıklama

public string ReflectionClass::getShortName ( void )

Sınıfın adını isim alanı parçası olmaksızın döndürür.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Sınıfın kısa adı.

Örnekler

Örnek 1 - ReflectionClass::getShortName() örneği

<?php
namespace A\B;

class Foo { }

$function = new \ReflectionClass('stdClass');

var_dump($function->inNamespace());
var_dump($function->getName());
var_dump($function->getNamespaceName());
var_dump($function->getShortName());

$function = new \ReflectionClass('A\\B\\Foo');

var_dump($function->inNamespace());
var_dump($function->getName());
var_dump($function->getNamespaceName());
var_dump($function->getShortName());
?>

Yukarıdaki örneğin çıktısı:

bool(false)
string(8) "stdClass"
string(0) ""
string(8) "stdClass"

bool(true)
string(7) "A\B\Foo"
string(3) "A\B"
string(3) "Foo"

Ayrıca Bakınız

  • ReflectionClass::getName() - Sınıf ismini döndürür

ReflectionClass::getProperty
ReflectionClass::getStartLine
ReflectionClass


Başlangıç satır numarasını döndürür

ReflectionClass::getShortName
ReflectionClass::getStaticProperties
ReflectionClass
PHP Manual

ReflectionClass::getStartLine

(PHP 5, PHP 7)

ReflectionClass::getStartLine — Başlangıç satır numarasını döndürür

Açıklama

public int ReflectionClass::getStartLine ( void )

Başlangıç satır numarasını döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başlangıç satır numarasını bir tamsayı olarak döndürür.

Ayrıca Bakınız

  • ReflectionClass::getEndLine() - Son satırın numarasını döndürür

ReflectionClass::getShortName
ReflectionClass::getStaticProperties
ReflectionClass


Duruk özellikleri döndürür

ReflectionClass::getStartLine
ReflectionClass::getStaticPropertyValue
ReflectionClass
PHP Manual

ReflectionClass::getStaticProperties

(PHP 5, PHP 7)

ReflectionClass::getStaticProperties — Duruk özellikleri döndürür

Açıklama

public array ReflectionClass::getStaticProperties ( void )

Duruk özellikleri döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Duruk özellikleri bir dizi içinde döndürür.

Ayrıca Bakınız

  • ReflectionClass::getStaticPropertyValue() - Duruk özelliğin değerini döndürür
  • ReflectionClass::setStaticPropertyValue() - Duruk özelliğe değer atar

ReflectionClass::getStartLine
ReflectionClass::getStaticPropertyValue
ReflectionClass


Duruk özelliğin değerini döndürür

ReflectionClass::getStaticProperties
ReflectionClass::getTraitAliases
ReflectionClass
PHP Manual

ReflectionClass::getStaticPropertyValue

(PHP 5 >= 5.1.0, PHP 7)

ReflectionClass::getStaticPropertyValue — Duruk özelliğin değerini döndürür

Açıklama

public mixed ReflectionClass::getStaticPropertyValue ( string $isim [, string $öntanımlı ] )

Duruk özelliğin değerini döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

isim

Duruk özelliğin ismi.

öntanımlı

Dönen Değerler

Ayrıca Bakınız

  • ReflectionClass::getStaticProperties() - Duruk özellikleri döndürür
  • ReflectionClass::setStaticPropertyValue() - Duruk özelliğe değer atar

ReflectionClass::getStaticProperties
ReflectionClass::getTraitAliases
ReflectionClass


Returns an array of trait aliases

ReflectionClass::getStaticPropertyValue
ReflectionClass::getTraitNames
ReflectionClass
PHP Manual

ReflectionClass::getTraitAliases

(PHP >= 5.4.0)

ReflectionClass::getTraitAliases — Returns an array of trait aliases

Açıklama

public array ReflectionClass::getTraitAliases ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array with new method names in keys and original names (in the format "TraitName::original") in values. Returns NULL in case of an error.

ReflectionClass::getStaticPropertyValue
ReflectionClass::getTraitNames
ReflectionClass


Returns an array of names of traits used by this class

ReflectionClass::getTraitAliases
ReflectionClass::getTraits
ReflectionClass
PHP Manual

ReflectionClass::getTraitNames

(PHP >= 5.4.0)

ReflectionClass::getTraitNames — Returns an array of names of traits used by this class

Açıklama

public array ReflectionClass::getTraitNames ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array with trait names in values. Returns NULL in case of an error.

ReflectionClass::getTraitAliases
ReflectionClass::getTraits
ReflectionClass


Returns an array of traits used by this class

ReflectionClass::getTraitNames
ReflectionClass::hasConstant
ReflectionClass
PHP Manual

ReflectionClass::getTraits

(PHP >= 5.4.0)

ReflectionClass::getTraits — Returns an array of traits used by this class

Açıklama

public array ReflectionClass::getTraits ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array with trait names in keys and instances of trait's ReflectionClass in values. Returns NULL in case of an error.

ReflectionClass::getTraitNames
ReflectionClass::hasConstant
ReflectionClass


Sabit tanımlı mı diye bakar

ReflectionClass::getTraits
ReflectionClass::hasMethod
ReflectionClass
PHP Manual

ReflectionClass::hasConstant

(PHP 5 >= 5.1.0, PHP 7)

ReflectionClass::hasConstant — Sabit tanımlı mı diye bakar

Açıklama

public bool ReflectionClass::hasConstant ( string $isim )

Belirtilen sabit tanımlıysa TRUE döner.

Değiştirgeler

isim

Bakılacak sabitin ismi.

Dönen Değerler

Sabit tanımlıysa TRUE değilse FALSE.

Örnekler

Örnek 1 - ReflectionClass::hasConstant() örneği

<?php
class Foo {
    const c1 = 1;
}

$class = new ReflectionClass("Foo");

var_dump($class->hasConstant("c1"));
var_dump($class->hasConstant("c2"));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(true)
bool(false)

Ayrıca Bakınız

  • ReflectionClass::hasMethod() - Yöntem tanımlı mı diye bakar
  • ReflectionClass::hasProperty() - Özellik tanımlı mı diye bakar

ReflectionClass::getTraits
ReflectionClass::hasMethod
ReflectionClass


Yöntem tanımlı mı diye bakar

ReflectionClass::hasConstant
ReflectionClass::hasProperty
ReflectionClass
PHP Manual

ReflectionClass::hasMethod

(PHP 5 >= 5.1.0, PHP 7)

ReflectionClass::hasMethod — Yöntem tanımlı mı diye bakar

Açıklama

public bool ReflectionClass::hasMethod ( string $isim )

Belirtilen yöntem sınıfta tanımlı ise TRUE döner.

Değiştirgeler

isim

Bakılacak yöntemin ismi.

Dönen Değerler

Yöntem tanımlı ise TRUE yoksa FALSE döner.

Örnekler

Örnek 1 - ReflectionClass::hasMethod() örneği

<?php
Class C {
    public function publicFoo() {
        return true;
    }

    protected function protectedFoo() {
        return true;
    }

    private function privateFoo() {
        return true;
    }

    static function staticFoo() {
        return true;
    }
}

$rc = new ReflectionClass("C");

var_dump($rc->hasMethod('publicFoo'));

var_dump($rc->hasMethod('protectedFoo'));

var_dump($rc->hasMethod('privateFoo'));

var_dump($rc->hasMethod('staticFoo'));

// bar diye bir yöntem olmaması lazım
var_dump($rc->hasMethod('bar'));

// Yöntem isimleri harf büyüklüğüne duyarsızdır
var_dump($rc->hasMethod('PUBLICfOO'));
?>

Yukarıdaki örneğin çıktısı:

bool(true)
bool(true)
bool(true)
bool(true)
bool(false)
bool(true)

Ayrıca Bakınız

  • ReflectionClass::hasConstant() - Sabit tanımlı mı diye bakar
  • ReflectionClass::hasProperty() - Özellik tanımlı mı diye bakar

ReflectionClass::hasConstant
ReflectionClass::hasProperty
ReflectionClass


Özellik tanımlı mı diye bakar

ReflectionClass::hasMethod
ReflectionClass::implementsInterface
ReflectionClass
PHP Manual

ReflectionClass::hasProperty

(PHP 5 >= 5.1.0, PHP 7)

ReflectionClass::hasProperty — Özellik tanımlı mı diye bakar

Açıklama

public bool ReflectionClass::hasProperty ( string $isim )

Belirtilen özellik tanımlıysa TRUE döner.

Değiştirgeler

isim

Bakılacak özelliğin ismi.

Dönen Değerler

Özellik tanımlıysa TRUE yoksa FALSE döner.

Örnekler

Örnek 1 - ReflectionClass::hasProperty() örneği

<?php
class Foo {
    public    $p1;
    protected $p2;
    private   $p3;

}

$obj = new ReflectionObject(new Foo());

var_dump($obj->hasProperty("p1"));
var_dump($obj->hasProperty("p2"));
var_dump($obj->hasProperty("p3"));
var_dump($obj->hasProperty("p4"));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(true)
bool(true)
bool(true)
bool(false)

Ayrıca Bakınız

  • ReflectionClass::hasConstant() - Sabit tanımlı mı diye bakar
  • ReflectionClass::hasMethod() - Yöntem tanımlı mı diye bakar

ReflectionClass::hasMethod
ReflectionClass::implementsInterface
ReflectionClass


Arayüz gerçeklenmiş mi diye bakar

ReflectionClass::hasProperty
ReflectionClass::inNamespace
ReflectionClass
PHP Manual

ReflectionClass::implementsInterface

(PHP 5, PHP 7)

ReflectionClass::implementsInterface — Arayüz gerçeklenmiş mi diye bakar

Açıklama

public bool ReflectionClass::implementsInterface ( string $arayüz )

Belirtilen arayüzü gerçeklenmişse TRUE döner.

Değiştirgeler

arayüz

Bakılacak arayüzün ismi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ReflectionClass::isInterface() - Sınıf bir arayüz mü diye bakar
  • interface_exists() - Arayüz tanımlı mı diye bakar
  • Nesne Arayüzleri

ReflectionClass::hasProperty
ReflectionClass::inNamespace
ReflectionClass


Sınıf isim alanında mı diye bakar

ReflectionClass::implementsInterface
ReflectionClass::isAbstract
ReflectionClass
PHP Manual

ReflectionClass::inNamespace

(PHP 5 >= 5.3.0, PHP 7)

ReflectionClass::inNamespace — Sınıf isim alanında mı diye bakar

Açıklama

public bool ReflectionClass::inNamespace ( void )

Sınıf isim alanında tanımlıysa TRUE döner.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - ReflectionClass::inNamespace() örneği

<?php
namespace A\B;

class Foo { }

$function = new \ReflectionClass('stdClass');

var_dump($function->inNamespace());
var_dump($function->getName());
var_dump($function->getNamespaceName());
var_dump($function->getShortName());

$function = new \ReflectionClass('A\\B\\Foo');

var_dump($function->inNamespace());
var_dump($function->getName());
var_dump($function->getNamespaceName());
var_dump($function->getShortName());
?>

Yukarıdaki örneğin çıktısı:

bool(false)
string(8) "stdClass"
string(0) ""
string(8) "stdClass"

bool(true)
string(7) "A\B\Foo"
string(3) "A\B"
string(3) "Foo"

Ayrıca Bakınız

  • ReflectionClass::getNamespaceName() - İsim alanı ismini döndürür
  • İsim Alanları

ReflectionClass::implementsInterface
ReflectionClass::isAbstract
ReflectionClass


Sınıf soyut mu diye bakar

ReflectionClass::inNamespace
ReflectionClass::isAnonymous
ReflectionClass
PHP Manual

ReflectionClass::isAbstract

(PHP 5, PHP 7)

ReflectionClass::isAbstract — Sınıf soyut mu diye bakar

Açıklama

public bool ReflectionClass::isAbstract ( void )

Sınıf soyutsa TRUE döner.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - ReflectionClass::isAbstract() örneği

<?php
class          TestClass { }
abstract class TestAbstractClass { }

$testClass     = new ReflectionClass('TestClass');
$abstractClass = new ReflectionClass('TestAbstractClass');

var_dump($testClass->isAbstract());
var_dump($abstractClass->isAbstract());
?>

Yukarıdaki örneğin çıktısı:

bool(false)
bool(true)

Ayrıca Bakınız

  • ReflectionClass::isInterface() - Sınıf bir arayüz mü diye bakar
  • Class Abstraction

ReflectionClass::inNamespace
ReflectionClass::isAnonymous
ReflectionClass


Checks if class is anonymous

ReflectionClass::isAbstract
ReflectionClass::isCloneable
ReflectionClass
PHP Manual

ReflectionClass::isAnonymous

(PHP 7)

ReflectionClass::isAnonymous — Checks if class is anonymous

Açıklama

public bool ReflectionClass::isAnonymous ( void )

Checks if a class is an anonymous class.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 ReflectionClass::isAnonymous() example

<?php
class TestClass {}
$anonClass = new class {};

$normalClass = new ReflectionClass('TestClass');
$anonClass  = new ReflectionClass($anonClass);

var_dump($normalClass->isAnonymous());
var_dump($anonClass->isAnonymous());

?>

Yukarıdaki örneğin çıktısı:

bool(false)
bool(true)

Ayrıca Bakınız

  • ReflectionClass::isFinal() - Sınıf bir final sınıf mı diye bakar

ReflectionClass::isAbstract
ReflectionClass::isCloneable
ReflectionClass


Returns whether this class is cloneable

ReflectionClass::isAnonymous
ReflectionClass::isFinal
ReflectionClass
PHP Manual

ReflectionClass::isCloneable

(PHP >= 5.4.0)

ReflectionClass::isCloneable — Returns whether this class is cloneable

Açıklama

public bool ReflectionClass::isCloneable ( void )

Returns whether this class is cloneable.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the class is cloneable, FALSE otherwise.

Örnekler

Örnek 1 Basic usage of ReflectionClass::isCloneable()

<?php
class NotCloneable {
    public $var1;

    private function __clone() {
    }
}

class Cloneable {
    public $var1;
}

$notCloneable = new ReflectionClass('NotCloneable');
$cloneable = new ReflectionClass('Cloneable');

var_dump($notCloneable->isCloneable());
var_dump($cloneable->isCloneable());
?>

Yukarıdaki örneğin çıktısı:

bool(false)
bool(true)

ReflectionClass::isAnonymous
ReflectionClass::isFinal
ReflectionClass


Sınıf bir final sınıf mı diye bakar

ReflectionClass::isCloneable
ReflectionClass::isInstance
ReflectionClass
PHP Manual

ReflectionClass::isFinal

(PHP 5, PHP 7)

ReflectionClass::isFinal — Sınıf bir final sınıf mı diye bakar

Açıklama

public bool ReflectionClass::isFinal ( void )

Sınıf bir final sınıf ise TRUE döner.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - ReflectionClass::isAbstract() örneği

<?php
class       TestClass { }
final class TestFinalClass { }

$normalClass = new ReflectionClass('TestClass');
$finalClass  = new ReflectionClass('TestFinalClass');

var_dump($normalClass->isFinal());
var_dump($finalClass->isFinal());

?>

Yukarıdaki örneğin çıktısı:

bool(false)
bool(true)

Ayrıca Bakınız

  • ReflectionClass::isAbstract() - Sınıf soyut mu diye bakar
  • Final Keyword

ReflectionClass::isCloneable
ReflectionClass::isInstance
ReflectionClass


Sınıf bir nesne örneği mi diye bakar

ReflectionClass::isFinal
ReflectionClass::isInstantiable
ReflectionClass
PHP Manual

ReflectionClass::isInstance

(PHP 5, PHP 7)

ReflectionClass::isInstance — Sınıf bir nesne örneği mi diye bakar

Açıklama

public bool ReflectionClass::isInstance ( string $nesne )

Sınıf bir nesne örneği ise TRUE döner.

Değiştirgeler

nesne

Bakılacak nesne.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - ReflectionClass::isInstance() örneği

<?php
// Kullanım örneği
$class = new ReflectionClass('Foo');

if ($class->isInstance($arg)) {
    echo "Yes";
}

// Buna eşdeğer
if ($arg instanceof Foo) {
    echo "Yes";
}

// Buna da
if (is_a($arg, 'Foo')) {
    echo "Yes";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Yes
Yes
Yes

Ayrıca Bakınız

  • ReflectionClass::isInterface() - Sınıf bir arayüz mü diye bakar
  • Tür İşleçleri
  • Nesne Arayüzleri
  • is_a() - Nesne ile sınıf arasında ebeveyn/çocuk ilişkisi var mı diye bakar

ReflectionClass::isFinal
ReflectionClass::isInstantiable
ReflectionClass


Sınıf örneklenebilir mi diye bakar

ReflectionClass::isInstance
ReflectionClass::isInterface
ReflectionClass
PHP Manual

ReflectionClass::isInstantiable

(PHP 5, PHP 7)

ReflectionClass::isInstantiable — Sınıf örneklenebilir mi diye bakar

Açıklama

public bool ReflectionClass::isInstantiable ( void )

Sınıf örneklenebiliyorsa TRUE döner.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - ReflectionClass::isInstantiable() örneği

<?php
class C { }

interface iface {
    function f1();
}

class ifaceImpl implements iface {
    function f1() {}
}

abstract class abstractClass {
    function f1() { }
    abstract function f2();
}

class D extends abstractClass {
    function f2() { }
}

$classes = array("C", "iface", "ifaceImpl", "abstractClass", "D");

foreach($classes  as $class ) {
    $reflectionClass = new ReflectionClass($class);
    echo "$class örneklenebilir mi?  ";
    var_dump($reflectionClass->IsInstantiable());
}

?>

Yukarıdaki örneğin çıktısı:

C örneklenebilir mi?  bool(true)
iface örneklenebilir mi?  bool(false)
ifaceImpl örneklenebilir mi?  bool(true)
abstractClass örneklenebilir mi?  bool(false)
D örneklenebilir mi?  bool(true)

Ayrıca Bakınız

  • ReflectionClass::isInstance() - Sınıf bir nesne örneği mi diye bakar

ReflectionClass::isInstance
ReflectionClass::isInterface
ReflectionClass


Sınıf bir arayüz mü diye bakar

ReflectionClass::isInstantiable
ReflectionClass::isInternal
ReflectionClass
PHP Manual

ReflectionClass::isInterface

(PHP 5, PHP 7)

ReflectionClass::isInterface — Sınıf bir arayüz mü diye bakar

Açıklama

public bool ReflectionClass::isInterface ( void )

Sınıf bir arayüz ise TRUE döner.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ReflectionClass::isInstance() - Sınıf bir nesne örneği mi diye bakar

ReflectionClass::isInstantiable
ReflectionClass::isInternal
ReflectionClass


Sınıf yerleşik bir sınıf mı diye bakar

ReflectionClass::isInterface
ReflectionClass::isIterateable
ReflectionClass
PHP Manual

ReflectionClass::isInternal

(PHP 5, PHP 7)

ReflectionClass::isInternal — Sınıf yerleşik bir sınıf mı diye bakar

Açıklama

public bool ReflectionClass::isInternal ( void )

Sınıf yerleşik bir sınıf ise TRUE kullanıcı tanımlı ise FALSE döner.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ReflectionClass::isUserDefined() - Sınıf bir kullanıcı tanımlı sınıf mı diye bakar

ReflectionClass::isInterface
ReflectionClass::isIterateable
ReflectionClass


Sınıf yinelenebilir mi diye bakar

ReflectionClass::isInternal
ReflectionClass::isSubclassOf
ReflectionClass
PHP Manual

ReflectionClass::isIterateable

(PHP 5, PHP 7)

ReflectionClass::isIterateable — Sınıf yinelenebilir mi diye bakar

Açıklama

public bool ReflectionClass::isIterateable ( void )

Sınıf yinelenebiliyorsa TRUE döner.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - ReflectionClass::isIterateable() örneği

<?php

class IteratorClass implements Iterator {
    public function __construct() { }
    public function key() { }
    public function current() { }
    function next() { }
    function valid() { }
    function rewind() { }
}
class DerivedClass extends IteratorClass { }
class NonIterator { }

function dump_iterateable($class) {
    $reflection = new ReflectionClass($class);
    var_dump($reflection->isIterateable());
}

$classes = array("ArrayObject", "IteratorClass", "DerivedClass", "NonIterator");

foreach ($classes as $class) {
    echo "$class yinelenebiliyor mu? ";
    dump_iterateable($class);
}
?>

Yukarıdaki örneğin çıktısı:

ArrayObject yinelenebiliyor mu? bool(true)
IteratorClass yinelenebiliyor mu? bool(true)
DerivedClass yinelenebiliyor mu? bool(true)
NonIterator yinelenebiliyor mu? bool(false)

Ayrıca Bakınız

  • ReflectionClass::__construct() - Bir ReflectionClass nesnesi oluşturur

ReflectionClass::isInternal
ReflectionClass::isSubclassOf
ReflectionClass


Sınıf bir alt sınıf mı diye bakar

ReflectionClass::isIterateable
ReflectionClass::isTrait
ReflectionClass
PHP Manual

ReflectionClass::isSubclassOf

(PHP 5, PHP 7)

ReflectionClass::isSubclassOf — Sınıf bir alt sınıf mı diye bakar

Açıklama

public bool ReflectionClass::isSubclassOf ( string $sınıf )

Sınıf belirtilen sınıfın bir alt sınıfı ise TRUE döner.

Değiştirgeler

sınıf

Olası ebeveyn sınıf.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ReflectionClass::isInterface() - Sınıf bir arayüz mü diye bakar
  • is_subclass_of() - Belirtilen sınıfın belirtilen nesnenin ebeveynlerinden biri olup olmadığına bakar
  • get_parent_class() - Nesne veya sınıfın ebeveyn sınıfının ismini döndürür

ReflectionClass::isIterateable
ReflectionClass::isTrait
ReflectionClass


Returns whether this is a trait

ReflectionClass::isSubclassOf
ReflectionClass::isUserDefined
ReflectionClass
PHP Manual

ReflectionClass::isTrait

(PHP >= 5.4.0)

ReflectionClass::isTrait — Returns whether this is a trait

Açıklama

public bool ReflectionClass::isTrait ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if this is a trait, FALSE otherwise. Returns NULL in case of an error.

ReflectionClass::isSubclassOf
ReflectionClass::isUserDefined
ReflectionClass


Sınıf bir kullanıcı tanımlı sınıf mı diye bakar

ReflectionClass::isTrait
ReflectionClass::newInstance
ReflectionClass
PHP Manual

ReflectionClass::isUserDefined

(PHP 5, PHP 7)

ReflectionClass::isUserDefined — Sınıf bir kullanıcı tanımlı sınıf mı diye bakar

Açıklama

public bool ReflectionClass::isUserDefined ( void )

Sınıf bir kullanıcı tanımlı sınıf ise TRUE, yerleşik bir sınıf ise FALSE döner.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • ReflectionClass::isInternal() - Sınıf yerleşik bir sınıf mı diye bakar

ReflectionClass::isTrait
ReflectionClass::newInstance
ReflectionClass


Yeni örnek

ReflectionClass::isUserDefined
ReflectionClass::newInstanceArgs
ReflectionClass
PHP Manual

ReflectionClass::newInstance

(PHP 5, PHP 7)

ReflectionClass::newInstance — Yeni örnek

Açıklama

public object ReflectionClass::newInstance ( mixed $değiştirgeler [, mixed $... ] )

Yeni bir örnek.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

değiştirgeler

call_user_func() işlevindeki gibi işleve istenen sayıda değiştirge aktarılabilir.

Dönen Değerler

Ayrıca Bakınız

  • ReflectionClass::newInstanceArgs() - Yeni örnek değiştirgeleri

ReflectionClass::isUserDefined
ReflectionClass::newInstanceArgs
ReflectionClass


Yeni örnek değiştirgeleri

ReflectionClass::newInstance
ReflectionClass::newInstanceWithoutConstructor
ReflectionClass
PHP Manual

ReflectionClass::newInstanceArgs

(PHP 5 >= 5.1.3, PHP 7)

ReflectionClass::newInstanceArgs — Yeni örnek değiştirgeleri

Açıklama

public object ReflectionClass::newInstanceArgs ([ array $değiştirgeler ] )

Yeni örnek değiştirgeleri.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

değiştirgeler

Dönen Değerler

Ayrıca Bakınız

  • ReflectionClass::newInstance() - Yeni örnek

ReflectionClass::newInstance
ReflectionClass::newInstanceWithoutConstructor
ReflectionClass


Creates a new class instance without invoking the constructor.

ReflectionClass::newInstanceArgs
ReflectionClass::setStaticPropertyValue
ReflectionClass
PHP Manual

ReflectionClass::newInstanceWithoutConstructor

(PHP >= 5.4.0)

ReflectionClass::newInstanceWithoutConstructor — Creates a new class instance without invoking the constructor.

Açıklama

public object ReflectionClass::newInstanceWithoutConstructor ( void )

Creates a new instance of the class without invoking the constructor.

Değiştirgeler

Dönen Değerler

Sürüm Bilgisi

Sürüm: | Açıklama
5.6.0 | All internal classes can now be instantiated except for those declared final.

Hatalar/İstisnalar

A ReflectionException if the class is an internal class that cannot be instantiated without invoking the constructor. In PHP 5.6.0 onwards, this exception is limited only to internal classes that are final.

Ayrıca Bakınız

  • ReflectionClass::newInstance() - Yeni örnek
  • ReflectionClass::newInstanceArgs() - Yeni örnek değiştirgeleri

ReflectionClass::newInstanceArgs
ReflectionClass::setStaticPropertyValue
ReflectionClass


Duruk özelliğe değer atar

ReflectionClass::newInstanceWithoutConstructor
ReflectionClass::__toString
ReflectionClass
PHP Manual

ReflectionClass::setStaticPropertyValue

(PHP 5 >= 5.1.0, PHP 7)

ReflectionClass::setStaticPropertyValue — Duruk özelliğe değer atar

Açıklama

public void ReflectionClass::setStaticPropertyValue ( string $isim , string $değer )

Duruk özelliğe değer atar.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

isim

Özellik adı.

değer

Özelliğin yeni değeri.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • ReflectionClass::getStaticPropertyValue() - Duruk özelliğin değerini döndürür

ReflectionClass::newInstanceWithoutConstructor
ReflectionClass::__toString
ReflectionClass


Dizgesel tepkiyi görselleştirir

ReflectionClass::setStaticPropertyValue
ReflectionExtension
ReflectionClass
PHP Manual

ReflectionClass::__toString

(PHP 5, PHP 7)

ReflectionClass::__toString — Dizgesel tepkiyi görselleştirir

Açıklama

public string ReflectionClass::__toString ( void )

Dizgesel tepkiyi görselleştirir.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Bir dizge.

Ayrıca Bakınız

  • ReflectionClass::export() - Bir sınıf ihraç eder
  • __toString

ReflectionClass::setStaticPropertyValue
ReflectionExtension
ReflectionClass


ReflectionExtension Sınıfı

(PHP 5, PHP 7)

Giriş

ReflectionExtension sınıfı, bir eklenti hakkında bilgi edinilmesini sağlar.

Sınıf Sözdizimi

ReflectionExtension implements Reflector {
/* Özellikler */
public $name ;
/* Yöntemler */
final private void __clone ( void )
__construct ( string $isim )
public static string export ( string $isim [, string $ihracet = false ] )
public array getClasses ( void )
public array getClassNames ( void )
public array getConstants ( void )
public array getDependencies ( void )
public array getFunctions ( void )
public array getINIEntries ( void )
public string getName ( void )
public string getVersion ( void )
public string info ( void )
public void isPersistent ( void )
public void isTemporary ( void )
public string __toString ( void )
}

Özellikler

name

İsim.

İçindekiler

  • ReflectionExtension::__clone — Nesnenin bir kopyasını oluşturur
  • ReflectionExtension::__construct — Bir ReflectionExtension nesnesi oluşturur
  • ReflectionExtension::export — Sınıfı ihraç eder
  • ReflectionExtension::getClasses — Eklentinin sınıflarını döndürür
  • ReflectionExtension::getClassNames — Eklentide tanımlı sınıf isimlerini döndürür
  • ReflectionExtension::getConstants — Eklentinin sabitlerini döndürür
  • ReflectionExtension::getDependencies — Bağımlılıkları döndürür
  • ReflectionExtension::getFunctions — Eklenti işlevlerini döndürür
  • ReflectionExtension::getINIEntries — Eklentinin ini girdilerini döndürür
  • ReflectionExtension::getName — Eklenti ismini döndürür
  • ReflectionExtension::getVersion — Eklentinin sürüm bilgisini döndürür
  • ReflectionExtension::info — Eklenti bilgilerini döndürür
  • ReflectionExtension::isPersistent — Returns whether this extension is persistent
  • ReflectionExtension::isTemporary — Returns whether this extension is temporary
  • ReflectionExtension::__toString — Dizgesel tepkiyi görselleştirir
ReflectionClass::__toString
ReflectionExtension::__clone
Reflection


Nesnenin bir kopyasını oluşturur

ReflectionExtension
ReflectionExtension::__construct
ReflectionExtension
PHP Manual

ReflectionExtension::__clone

(PHP 5, PHP 7)

ReflectionExtension::__clone — Nesnenin bir kopyasını oluşturur

Açıklama

final private void ReflectionExtension::__clone ( void )

Nesnenin bir kopyasını oluşturur.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Ayrıca Bakınız

  • ReflectionExtension::__construct() - Bir ReflectionExtension nesnesi oluşturur
  • Nesne Kopyalama

ReflectionExtension
ReflectionExtension::__construct
ReflectionExtension


Bir ReflectionExtension nesnesi oluşturur

ReflectionExtension::__clone
ReflectionExtension::export
ReflectionExtension
PHP Manual

ReflectionExtension::__construct

(PHP 5, PHP 7)

ReflectionExtension::__construct — Bir ReflectionExtension nesnesi oluşturur

Açıklama

ReflectionExtension::__construct ( string $isim )

Bir ReflectionExtension nesnesi oluşturur.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

isim

Eklentini ismi.

Dönen Değerler

Bir ReflectionExtension nesnesi.

Ayrıca Bakınız

  • ReflectionExtension::info() - Eklenti bilgilerini döndürür
  • Kurucular ve Yıkıcılar

ReflectionExtension::__clone
ReflectionExtension::export
ReflectionExtension


Sınıfı ihraç eder

ReflectionExtension::__construct
ReflectionExtension::getClasses
ReflectionExtension
PHP Manual

ReflectionExtension::export

(PHP 5, PHP 7)

ReflectionExtension::export — Sınıfı ihraç eder

Açıklama

public static string ReflectionExtension::export ( string $isim [, string $ihracet = false ] )

Yansıtılmış eklentiyi ihraç eder.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

isim

İhraç edilecek Reflection nesnesi.

ihracet

TRUE belirtilirse yansıtmak yerine ihrac eder. FALSE olursa (öntanımlıdır) tersini yapar.

Dönen Değerler

TRUE belirtilirse bir dizge yoksa NULL döner.

Ayrıca Bakınız

  • ReflectionExtension::info() - Eklenti bilgilerini döndürür

ReflectionExtension::__construct
ReflectionExtension::getClasses
ReflectionExtension


Eklentinin sınıflarını döndürür

ReflectionExtension::export
ReflectionExtension::getClassNames
ReflectionExtension
PHP Manual

ReflectionExtension::getClasses

(PHP 5, PHP 7)

ReflectionExtension::getClasses — Eklentinin sınıflarını döndürür

Açıklama

public array ReflectionExtension::getClasses ( void )

Eklentideki sınıfların listesini döndürür.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Bir ReflectionClass nesneleri dizisi. Hiç sınıf tanımlanmamışsa boş bir dizi döner.

Örnekler

Örnek 1 ReflectionExtension::getClasses() örneği

<?php
$ext = new ReflectionExtension('XMLWriter');
var_dump($ext->getClasses());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(1) {
  ["XMLWriter"]=>
  &object(ReflectionClass)#2 (1) {
    ["name"]=>
    string(9) "XMLWriter"
  }
}

Ayrıca Bakınız

  • ReflectionExtension::getClassNames() - Eklentide tanımlı sınıf isimlerini döndürür

ReflectionExtension::export
ReflectionExtension::getClassNames
ReflectionExtension


Eklentide tanımlı sınıf isimlerini döndürür

ReflectionExtension::getClasses
ReflectionExtension::getConstants
ReflectionExtension
PHP Manual

ReflectionExtension::getClassNames

(PHP 5, PHP 7)

ReflectionExtension::getClassNames — Eklentide tanımlı sınıf isimlerini döndürür

Açıklama

public array ReflectionExtension::getClassNames ( void )

Eklentide tanımlı sınıf isimlerinin listesini döndürür.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Sınıf isimlerinden oluşan bir dizi. Hiç tanımlı sınıf yoksa boş bir dizi döner.

Örnekler

Örnek 1 ReflectionExtension::getClassNames() örneği

<?php
$ext = new ReflectionExtension('XMLWriter');
var_dump($ext->getClassNames());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

array(1) {
  [0]=>
  string(9) "XMLWriter"
}

Ayrıca Bakınız

  • ReflectionExtension::getClasses() - Eklentinin sınıflarını döndürür
  • ReflectionExtension::getName() - Eklenti ismini döndürür

ReflectionExtension::getClasses
ReflectionExtension::getConstants
ReflectionExtension


Eklentinin sabitlerini döndürür

ReflectionExtension::getClassNames
ReflectionExtension::getDependencies
ReflectionExtension
PHP Manual

ReflectionExtension::getConstants

(PHP 5, PHP 7)

ReflectionExtension::getConstants — Eklentinin sabitlerini döndürür

Açıklama

public array ReflectionExtension::getConstants ( void )

Eklentide tanımlı sabitleri listeler.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Sabitlerin isimleri anahtarlara yerleştirilmiş olarak bir ilişkisel dizi.

Örnekler

Örnek 1 ReflectionExtension::getClasses() örneği

<?php
$ext = new ReflectionExtension('DOM');

print_r($ext->getConstants());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [XML_ELEMENT_NODE] => 1
    [XML_ATTRIBUTE_NODE] => 2
    [XML_TEXT_NODE] => 3
    [XML_CDATA_SECTION_NODE] => 4
    [XML_ENTITY_REF_NODE] => 5
    [XML_ENTITY_NODE] => 6
    [XML_PI_NODE] => 7
    [XML_COMMENT_NODE] => 8
    [XML_DOCUMENT_NODE] => 9
    [XML_DOCUMENT_TYPE_NODE] => 10
    [XML_DOCUMENT_FRAG_NODE] => 11
    [XML_NOTATION_NODE] => 12
    [XML_HTML_DOCUMENT_NODE] => 13
    [XML_DTD_NODE] => 14
    [XML_ELEMENT_DECL_NODE] => 15
    [XML_ATTRIBUTE_DECL_NODE] => 16
    [XML_ENTITY_DECL_NODE] => 17
    [XML_NAMESPACE_DECL_NODE] => 18
    [XML_LOCAL_NAMESPACE] => 18
    [XML_ATTRIBUTE_CDATA] => 1
    [XML_ATTRIBUTE_ID] => 2
    [XML_ATTRIBUTE_IDREF] => 3
    [XML_ATTRIBUTE_IDREFS] => 4
    [XML_ATTRIBUTE_ENTITY] => 6
    [XML_ATTRIBUTE_NMTOKEN] => 7
    [XML_ATTRIBUTE_NMTOKENS] => 8
    [XML_ATTRIBUTE_ENUMERATION] => 9
    [XML_ATTRIBUTE_NOTATION] => 10
    [DOM_PHP_ERR] => 0
    [DOM_INDEX_SIZE_ERR] => 1
    [DOMSTRING_SIZE_ERR] => 2
    [DOM_HIERARCHY_REQUEST_ERR] => 3
    [DOM_WRONG_DOCUMENT_ERR] => 4
    [DOM_INVALID_CHARACTER_ERR] => 5
    [DOM_NO_DATA_ALLOWED_ERR] => 6
    [DOM_NO_MODIFICATION_ALLOWED_ERR] => 7
    [DOM_NOT_FOUND_ERR] => 8
    [DOM_NOT_SUPPORTED_ERR] => 9
    [DOM_INUSE_ATTRIBUTE_ERR] => 10
    [DOM_INVALID_STATE_ERR] => 11
    [DOM_SYNTAX_ERR] => 12
    [DOM_INVALID_MODIFICATION_ERR] => 13
    [DOM_NAMESPACE_ERR] => 14
    [DOM_INVALID_ACCESS_ERR] => 15
    [DOM_VALIDATION_ERR] => 16
)

Ayrıca Bakınız

  • ReflectionExtension::getINIEntries() - Eklentinin ini girdilerini döndürür

ReflectionExtension::getClassNames
ReflectionExtension::getDependencies
ReflectionExtension


Bağımlılıkları döndürür

ReflectionExtension::getConstants
ReflectionExtension::getFunctions
ReflectionExtension
PHP Manual

ReflectionExtension::getDependencies

(PHP 5, PHP 7)

ReflectionExtension::getDependencies — Bağımlılıkları döndürür

Açıklama

public array ReflectionExtension::getDependencies ( void )

Eklenti için gerekli ve eklentiyle çelişen bağımlılıkları birlikte listeler.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Bağımlılık isimlerinin anahtar, değerlerin ise ya Required (gerekli) ya da Conflicts (çelişen) olduğu bir ilişkisel dizi.

Örnekler

Örnek 1 ReflectionExtension::getDependencies() örneği

<?php
$dom = new ReflectionExtension('dom');

print_r($dom->getDependencies());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [libxml] => Required
    [domxml] => Conflicts
)

Ayrıca Bakınız

  • ReflectionExtension::getVersion() - Eklentinin sürüm bilgisini döndürür

ReflectionExtension::getConstants
ReflectionExtension::getFunctions
ReflectionExtension


Eklenti işlevlerini döndürür

ReflectionExtension::getDependencies
ReflectionExtension::getINIEntries
ReflectionExtension
PHP Manual

ReflectionExtension::getFunctions

(PHP 5, PHP 7)

ReflectionExtension::getFunctions — Eklenti işlevlerini döndürür

Açıklama

public array ReflectionExtension::getFunctions ( void )

Eklentide tanımlı işlevleri döndürür.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

ReflectionFunction nesnelerinden oluşan bir ilişkisel dizi. İşlev isimleri anahtarlara yerleştirilir. Hiç işlev tanımlanmamışsa boş bir dizi döner.

Örnekler

Örnek 1 - ReflectionExtension::getFunctions() örneği

<?php
$dom = new ReflectionExtension('SimpleXML');

print_r($dom->getFunctions());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [simplexml_load_file] => ReflectionFunction Object
        (
            [name] => simplexml_load_file
        )

    [simplexml_load_string] => ReflectionFunction Object
        (
            [name] => simplexml_load_string
        )

    [simplexml_import_dom] => ReflectionFunction Object
        (
            [name] => simplexml_import_dom
        )

)

Ayrıca Bakınız

  • ReflectionExtension::getClasses() - Eklentinin sınıflarını döndürür

ReflectionExtension::getDependencies
ReflectionExtension::getINIEntries
ReflectionExtension


Eklentinin ini girdilerini döndürür

ReflectionExtension::getFunctions
ReflectionExtension::getName
ReflectionExtension
PHP Manual

ReflectionExtension::getINIEntries

(PHP 5, PHP 7)

ReflectionExtension::getINIEntries — Eklentinin ini girdilerini döndürür

Açıklama

public array ReflectionExtension::getINIEntries ( void )

Eklentinin ini girdilerini döndürür.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yönerge isimlerinin anahtar, değerlerinin değer olduğu bir ilişkisel dizi döner.

Örnekler

Örnek 1 - ReflectionExtension::getFunctions() örneği

<?php
$dom = new ReflectionExtension('mysql');

print_r($dom->getINIEntries());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [mysql.allow_persistent] => 1
    [mysql.max_persistent] => -1
    [mysql.max_links] => -1
    [mysql.default_host] =>
    [mysql.default_user] =>
    [mysql.default_password] =>
    [mysql.default_port] =>
    [mysql.default_socket] =>
    [mysql.connect_timeout] => 60
    [mysql.trace_mode] =>
    [mysql.allow_local_infile] => 1
    [mysql.cache_size] => 2000
)

Ayrıca Bakınız

  • ReflectionExtension::getConstants() - Eklentinin sabitlerini döndürür

ReflectionExtension::getFunctions
ReflectionExtension::getName
ReflectionExtension


Eklenti ismini döndürür

ReflectionExtension::getINIEntries
ReflectionExtension::getVersion
ReflectionExtension
PHP Manual

ReflectionExtension::getName

(PHP 5, PHP 7)

ReflectionExtension::getName — Eklenti ismini döndürür

Açıklama

public string ReflectionExtension::getName ( void )

Eklenti ismini döndürür.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Eklenti ismi.

Örnekler

Örnek 1 - ReflectionExtension::getName() örneği

<?php
$ext = new ReflectionExtension('mysqli');
var_dump($ext->getName());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(6) "mysqli"

Ayrıca Bakınız

  • ReflectionExtension::getClassNames() - Eklentide tanımlı sınıf isimlerini döndürür

ReflectionExtension::getINIEntries
ReflectionExtension::getVersion
ReflectionExtension


Eklentinin sürüm bilgisini döndürür

ReflectionExtension::getName
ReflectionExtension::info
ReflectionExtension
PHP Manual

ReflectionExtension::getVersion

(PHP 5, PHP 7)

ReflectionExtension::getVersion — Eklentinin sürüm bilgisini döndürür

Açıklama

public string ReflectionExtension::getVersion ( void )

Eklentinin sürüm bilgisini döndürür.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Eklentinin sürüm bilgisi.

Örnekler

Örnek 1 - ReflectionExtension::getVersion() örneği

<?php
$ext = new ReflectionExtension('mysqli');
var_dump($ext->getVersion());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(3) "0.1"

Ayrıca Bakınız

  • ReflectionExtension::info() - Eklenti bilgilerini döndürür

ReflectionExtension::getName
ReflectionExtension::info
ReflectionExtension


Eklenti bilgilerini döndürür

ReflectionExtension::getVersion
ReflectionExtension::isPersistent
ReflectionExtension
PHP Manual

ReflectionExtension::info

(PHP 5, PHP 7)

ReflectionExtension::info — Eklenti bilgilerini döndürür

Açıklama

public string ReflectionExtension::info ( void )

Eklenti hakkında bilgi döndürür.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Eklenti hakkında bilgiyi bir dizge olarak döndürür.

Örnekler

Örnek 1 - ReflectionExtension::info() örneği

<?php
$ext = new ReflectionExtension('mysqli');
print_r($ext->info());
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

mysqli

MysqlI Support => enabled
Client API library version => mysqlnd 5.0.5-dev - 081106 - $Revision: 314031 $
Active Persistent Links => 0
Inactive Persistent Links => 0
Active Links => 0
Persistent cache => enabled
put_hits => 0
put_misses => 0
get_hits => 0
get_misses => 0
size => 2000
free_items => 2000
references => 2

Directive => Local Value => Master Value
mysqli.max_links => Unlimited => Unlimited
mysqli.max_persistent => Unlimited => Unlimited
mysqli.allow_persistent => On => On
mysqli.default_host => no value => no value
mysqli.default_user => no value => no value
mysqli.default_pw => no value => no value
mysqli.default_port => 3306 => 3306
mysqli.default_socket => no value => no value
mysqli.reconnect => Off => Off
mysqli.allow_local_infile => On => On
mysqli.cache_size => 2000 => 2000
NULL

Ayrıca Bakınız

  • ReflectionExtension::getName() - Eklenti ismini döndürür
  • phpinfo() - PHP'nin o anki durumu hakkında büyük miktarda bilgi çıktılar

ReflectionExtension::getVersion
ReflectionExtension::isPersistent
ReflectionExtension


Returns whether this extension is persistent

ReflectionExtension::info
ReflectionExtension::isTemporary
ReflectionExtension
PHP Manual

ReflectionExtension::isPersistent

(PHP >= 5.4.0)

ReflectionExtension::isPersistent — Returns whether this extension is persistent

Açıklama

public void ReflectionExtension::isPersistent ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE for extensions loaded by extension, FALSE otherwise.

Ayrıca Bakınız

  • ReflectionExtension::isTemporary() - Returns whether this extension is temporary

ReflectionExtension::info
ReflectionExtension::isTemporary
ReflectionExtension


Returns whether this extension is temporary

ReflectionExtension::isPersistent
ReflectionExtension::__toString
ReflectionExtension
PHP Manual

ReflectionExtension::isTemporary

(PHP >= 5.4.0)

ReflectionExtension::isTemporary — Returns whether this extension is temporary

Açıklama

public void ReflectionExtension::isTemporary ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE for extensions loaded by dl(), FALSE otherwise.

Ayrıca Bakınız

  • ReflectionExtension::isPersistent() - Returns whether this extension is persistent

ReflectionExtension::isPersistent
ReflectionExtension::__toString
ReflectionExtension


Dizgesel tepkiyi görselleştirir

ReflectionExtension::isTemporary
ReflectionFunction
ReflectionExtension
PHP Manual

ReflectionExtension::__toString

(PHP 5, PHP 7)

ReflectionExtension::__toString — Dizgesel tepkiyi görselleştirir

Açıklama

public string ReflectionExtension::__toString ( void )

Dizgesel tepkiyi görselleştirir.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Bir dizge.

Ayrıca Bakınız

  • ReflectionExtension::__construct() - Bir ReflectionExtension nesnesi oluşturur
  • __toString

ReflectionExtension::isTemporary
ReflectionFunction
ReflectionExtension


ReflectionFunction Sınıfı

(PHP 5, PHP 7)

Giriş

ReflectionFunction sınıfı bir işlevle ilgili bilgi verir.

Sınıf Sözdizimi

ReflectionFunction extends ReflectionFunctionAbstract implements Reflector {
/* Sabitler */
const integer IS_DEPRECATED = 262144 ;
/* Özellikler */
public $name ;
/* Yöntemler */
__construct ( string $isim )
public static string export ( string $isim [, string $ihracet ] )
public Closure getClosure ( void )
public mixed invoke ([ string $değiştirgeler ] )
public mixed invokeArgs ( array $değiştirgeler )
public bool isDisabled ( void )
public string __toString ( void )
/* Miras alınan yöntemler */
final private void ReflectionFunctionAbstract::__clone ( void )
public ReflectionClass ReflectionFunctionAbstract::getClosureScopeClass ( void )
public object ReflectionFunctionAbstract::getClosureThis ( void )
public string ReflectionFunctionAbstract::getDocComment ( void )
public int ReflectionFunctionAbstract::getEndLine ( void )
public ReflectionExtension ReflectionFunctionAbstract::getExtension ( void )
public string ReflectionFunctionAbstract::getExtensionName ( void )
public string ReflectionFunctionAbstract::getFileName ( void )
public string ReflectionFunctionAbstract::getName ( void )
public string ReflectionFunctionAbstract::getNamespaceName ( void )
public int ReflectionFunctionAbstract::getNumberOfParameters ( void )
public int ReflectionFunctionAbstract::getNumberOfRequiredParameters ( void )
public array ReflectionFunctionAbstract::getParameters ( void )
public ReflectionType ReflectionFunctionAbstract::getReturnType ( void )
public string ReflectionFunctionAbstract::getShortName ( void )
public int ReflectionFunctionAbstract::getStartLine ( void )
public array ReflectionFunctionAbstract::getStaticVariables ( void )
public bool ReflectionFunctionAbstract::hasReturnType ( void )
public bool ReflectionFunctionAbstract::inNamespace ( void )
public bool ReflectionFunctionAbstract::isClosure ( void )
public bool ReflectionFunctionAbstract::isDeprecated ( void )
public bool ReflectionFunctionAbstract::isGenerator ( void )
public bool ReflectionFunctionAbstract::isInternal ( void )
public bool ReflectionFunctionAbstract::isUserDefined ( void )
public bool ReflectionFunctionAbstract::isVariadic ( void )
public bool ReflectionFunctionAbstract::returnsReference ( void )
abstract public void ReflectionFunctionAbstract::__toString ( void )
}

Özellikler

name

İşlevin ismi. Salt-okunur olup, bir yazma çabası ReflectionException istisnasına yol açar.

Öntanımlı Sabitler

ReflectionFunction Değiştiricileri

ReflectionFunction::IS_DEPRECATED

İşlevin kullanımının önerilmediğini belirtir.

İçindekiler

  • ReflectionFunction::__construct — Bir ReflectionFunction nesnesi oluşturur
  • ReflectionFunction::export — İşlevi ihraç eder
  • ReflectionFunction::getClosure — Returns a dynamically created closure for the function
  • ReflectionFunction::invoke — İşlevi çağırır
  • ReflectionFunction::invokeArgs — İşlev değiştirgelerini çağırır
  • ReflectionFunction::isDisabled — İşlevin iptal edilip edilmediğine bakar
  • ReflectionFunction::__toString — Dizgesel tepkiyi görselleştirir
ReflectionExtension::__toString
ReflectionFunction::__construct
Reflection


Bir ReflectionFunction nesnesi oluşturur

ReflectionFunction
ReflectionFunction::export
ReflectionFunction
PHP Manual

ReflectionFunction::__construct

(PHP 5, PHP 7)

ReflectionFunction::__construct — Bir ReflectionFunction nesnesi oluşturur

Açıklama

ReflectionFunction::__construct ( string $isim )

Bir ReflectionFunction nesnesi oluşturur.

Değiştirgeler

name

Yansıtılılacak işlevin ismi.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

isim değiştirgesi geçerli bir işlev ismi içermiyorsa bir ReflectionException nesnesi döner.

Örnekler

Örnek 1 - ReflectionFunction::__construct() örneği

<?php
/**
 * Basit bir sayaç
 *
 * @return    int
 */
function sayaç()
{
    static $c = 0;
    return ++$c;
}

// Bir ReflectionFunction örneği oluşturalım
$func = new ReflectionFunction('sayaç');

// Temel bilgileri basalım
printf(
    "===> %s '%s' işlevi\n".
    "     %s dosyasının\n".
    "     %d. satırından %d. satırına kadar tanımlanmış\n",
    $func->isInternal() ? 'Yerleşik' : 'Kullanıcı tanımlı',
    $func->getName(),
    $func->getFileName(),
    $func->getStartLine(),
    $func->getEndline()
);

// Belgelendirici açıklamaları basalım
printf("---> Belgeleme:\n %s\n", var_export($func->getDocComment(), 1));

// Varsa duruk değişkenleri basalım
if ($statics = $func->getStaticVariables())
{
    printf("---> Duruk değişkenler: %s\n", var_export($statics, 1));
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

===> Kullanıcı tanımlı 'sayaç' işlevi
     /home/Nilgun/dnm.php dosyasının
     7. satırından 11. satırına kadar tanımlanmış
---> Belgeleme:
 '/**
 * Basit bir sayaç
 *
 * @return    int
 */'
---> Duruk değişkenler: array (
  'c' => 0,
)

Ayrıca Bakınız

  • ReflectionMethod::__construct() - Yeni bir ReflectionMethod nesnesi oluşturur
  • Kurucular ve Yıkıcılar

ReflectionFunction
ReflectionFunction::export
ReflectionFunction


İşlevi ihraç eder

ReflectionFunction::__construct
ReflectionFunction::getClosure
ReflectionFunction
PHP Manual

ReflectionFunction::export

(PHP 5, PHP 7)

ReflectionFunction::export — İşlevi ihraç eder

Açıklama

public static string ReflectionFunction::export ( string $isim [, string $ihracet ] )

Yansıtılmış bir işlevi ihraç eder.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

isim

İhraç edilecek Reflection nesnesi.

ihracet

TRUE belirtilirse yansıtmak yerine ihrac eder. FALSE olursa (öntanımlıdır) tersini yapar.

Dönen Değerler

TRUE belirtilirse bir dizge yoksa NULL döner.

Ayrıca Bakınız

  • ReflectionFunction::invoke() - İşlevi çağırır

ReflectionFunction::__construct
ReflectionFunction::getClosure
ReflectionFunction


Returns a dynamically created closure for the function

ReflectionFunction::export
ReflectionFunction::invoke
ReflectionFunction
PHP Manual

ReflectionFunction::getClosure

(PHP >= 5.4.0)

ReflectionFunction::getClosure — Returns a dynamically created closure for the function

Açıklama

public Closure ReflectionFunction::getClosure ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns Closure. Returns NULL in case of an error.

ReflectionFunction::export
ReflectionFunction::invoke
ReflectionFunction


İşlevi çağırır

ReflectionFunction::getClosure
ReflectionFunction::invokeArgs
ReflectionFunction
PHP Manual

ReflectionFunction::invoke

(PHP 5, PHP 7)

ReflectionFunction::invoke — İşlevi çağırır

Açıklama

public mixed ReflectionFunction::invoke ([ string $değiştirgeler ] )

Yansıtılmış bir işlevi çağırır.

Değiştirgeler

değiştirgeler

İşleve aktarılacak değiştirge listesi. call_user_func() işlevindeki gibi yeteri sayıda değiştirge aktarabilirsiniz.

Dönen Değerler

Ayrıca Bakınız

  • ReflectionFunction::export() - İşlevi ihraç eder
  • __invoke

ReflectionFunction::getClosure
ReflectionFunction::invokeArgs
ReflectionFunction


İşlev değiştirgelerini çağırır

ReflectionFunction::invoke
ReflectionFunction::isDisabled
ReflectionFunction
PHP Manual

ReflectionFunction::invokeArgs

(PHP 5 >= 5.1.0, PHP 7)

ReflectionFunction::invokeArgs — İşlev değiştirgelerini çağırır

Açıklama

public mixed ReflectionFunction::invokeArgs ( array $değiştirgeler )

İşlev değiştirgelerini çağırır.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

değiştirgeler

Çağrılacak değiştirgeler.

Dönen Değerler

Ayrıca Bakınız

  • ReflectionFunction::invoke() - İşlevi çağırır
  • ReflectionFunctionAbstract::getNumberOfParameters() - Değiştirge sayısını döndürür
  • __invoke

ReflectionFunction::invoke
ReflectionFunction::isDisabled
ReflectionFunction


İşlevin iptal edilip edilmediğine bakar

ReflectionFunction::invokeArgs
ReflectionFunction::__toString
ReflectionFunction
PHP Manual

ReflectionFunction::isDisabled

(PHP 5, PHP 7)

ReflectionFunction::isDisabled — İşlevin iptal edilip edilmediğine bakar

Açıklama

public bool ReflectionFunction::isDisabled ( void )

İşlev disable_functions yönergesiyle iptal edilmişse TRUE döner.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

İşlev iptal edilmişse TRUE yoksa FALSE döner.

Ayrıca Bakınız

  • ReflectionFunctionAbstract::isUserDefined() - İşlev kullanıcı tanımlı bir işlev mi diye bakar
  • disable_functions yönergesi

ReflectionFunction::invokeArgs
ReflectionFunction::__toString
ReflectionFunction


Dizgesel tepkiyi görselleştirir

ReflectionFunction::isDisabled
ReflectionFunctionAbstract
ReflectionFunction
PHP Manual

ReflectionFunction::__toString

(PHP 5, PHP 7)

ReflectionFunction::__toString — Dizgesel tepkiyi görselleştirir

Açıklama

public string ReflectionFunction::__toString ( void )

Dizgesel tepkiyi görselleştirir.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Bir dizge.

Ayrıca Bakınız

  • ReflectionFunctionAbstract::clone()
  • __toString

ReflectionFunction::isDisabled
ReflectionFunctionAbstract
ReflectionFunction


ReflectionFunctionAbstract sınıfı

(PHP 5, PHP 7)

Giriş

ReflectionFunction sınıfının ebeveyni olup, ayrıntılar için onun belgesine bakın.

Sınıf Sözdizimi

ReflectionFunctionAbstract implements Reflector {
/* Özellikler */
public $name ;
/* Yöntemler */
final private void __clone ( void )
public ReflectionClass getClosureScopeClass ( void )
public object getClosureThis ( void )
public string getDocComment ( void )
public int getEndLine ( void )
public ReflectionExtension getExtension ( void )
public string getExtensionName ( void )
public string getFileName ( void )
public string getName ( void )
public string getNamespaceName ( void )
public int getNumberOfParameters ( void )
public int getNumberOfRequiredParameters ( void )
public array getParameters ( void )
public ReflectionType getReturnType ( void )
public string getShortName ( void )
public int getStartLine ( void )
public array getStaticVariables ( void )
public bool hasReturnType ( void )
public bool inNamespace ( void )
public bool isClosure ( void )
public bool isDeprecated ( void )
public bool isGenerator ( void )
public bool isInternal ( void )
public bool isUserDefined ( void )
public bool isVariadic ( void )
public bool returnsReference ( void )
abstract public void __toString ( void )
}

Özellikler

name

İsim.

İçindekiler

  • ReflectionFunctionAbstract::__clone — İşlevi kopyalar
  • ReflectionFunctionAbstract::getClosureScopeClass — Returns the scope associated to the closure
  • ReflectionFunctionAbstract::getClosureThis — Returns this pointer bound to closure
  • ReflectionFunctionAbstract::getDocComment — Belgelendirici açıklamaları döndürür
  • ReflectionFunctionAbstract::getEndLine — Son satır numarasını döndürür
  • ReflectionFunctionAbstract::getExtension — Eklenti bilgilerini döndürür
  • ReflectionFunctionAbstract::getExtensionName — Eklenti ismini döndürür
  • ReflectionFunctionAbstract::getFileName — Dosya ismini döndürür
  • ReflectionFunctionAbstract::getName — İşlev ismini döndürür
  • ReflectionFunctionAbstract::getNamespaceName — İsim alanı adını döndürür
  • ReflectionFunctionAbstract::getNumberOfParameters — Değiştirge sayısını döndürür
  • ReflectionFunctionAbstract::getNumberOfRequiredParameters — Zorunlu değiştirge sayısını döndürür
  • ReflectionFunctionAbstract::getParameters — Değiştirgeleri döndürür
  • ReflectionFunctionAbstract::getReturnType — Gets the specified return type of a function
  • ReflectionFunctionAbstract::getShortName — İşlevin kısa ismini döndürür
  • ReflectionFunctionAbstract::getStartLine — Başlangıç satır numarasını döndürür
  • ReflectionFunctionAbstract::getStaticVariables — Duruk değişkenleri döndürür
  • ReflectionFunctionAbstract::hasReturnType — Checks if the function has a specified return type
  • ReflectionFunctionAbstract::inNamespace — İşlev isim alanına ait mi diye bakar
  • ReflectionFunctionAbstract::isClosure — Bir anonim işlev mi diye bakar
  • ReflectionFunctionAbstract::isDeprecated — Kullanımı önerilmiyor mu diye bakar
  • ReflectionFunctionAbstract::isGenerator — Returns whether this function is a generator
  • ReflectionFunctionAbstract::isInternal — İşlev yerleşik mi diye bakar
  • ReflectionFunctionAbstract::isUserDefined — İşlev kullanıcı tanımlı bir işlev mi diye bakar
  • ReflectionFunctionAbstract::isVariadic — Checks if the function is variadic
  • ReflectionFunctionAbstract::returnsReference — İşlev dönüş değeri gönderimli mi diye bakar
  • ReflectionFunctionAbstract::__toString — Dizgesel tepkiyi görselleştirir
ReflectionFunction::__toString
ReflectionFunctionAbstract::__clone
Reflection


İşlevi kopyalar

ReflectionFunctionAbstract
ReflectionFunctionAbstract::getClosureScopeClass
ReflectionFunctionAbstract
PHP Manual

ReflectionFunctionAbstract::__clone

(PHP 5, PHP 7)

ReflectionFunctionAbstract::__clone — İşlevi kopyalar

Açıklama

final private void ReflectionFunctionAbstract::__clone ( void )

İşlevi kopyalar.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Ayrıca Bakınız

  • Nesne Kopyalama

ReflectionFunctionAbstract
ReflectionFunctionAbstract::getClosureScopeClass
ReflectionFunctionAbstract


Returns the scope associated to the closure

ReflectionFunctionAbstract::__clone
ReflectionFunctionAbstract::getClosureThis
ReflectionFunctionAbstract
PHP Manual

ReflectionFunctionAbstract::getClosureScopeClass

(PHP >= 5.4.0)

ReflectionFunctionAbstract::getClosureScopeClass — Returns the scope associated to the closure

Açıklama

public ReflectionClass ReflectionFunctionAbstract::getClosureScopeClass ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the class on success or NULL on failure.

ReflectionFunctionAbstract::__clone
ReflectionFunctionAbstract::getClosureThis
ReflectionFunctionAbstract


Returns this pointer bound to closure

ReflectionFunctionAbstract::getClosureScopeClass
ReflectionFunctionAbstract::getDocComment
ReflectionFunctionAbstract
PHP Manual

ReflectionFunctionAbstract::getClosureThis

(PHP >= 5.4.0)

ReflectionFunctionAbstract::getClosureThis — Returns this pointer bound to closure

Açıklama

public object ReflectionFunctionAbstract::getClosureThis ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns $this pointer. Returns NULL in case of an error.

ReflectionFunctionAbstract::getClosureScopeClass
ReflectionFunctionAbstract::getDocComment
ReflectionFunctionAbstract


Belgelendirici açıklamaları döndürür

ReflectionFunctionAbstract::getClosureThis
ReflectionFunctionAbstract::getEndLine
ReflectionFunctionAbstract
PHP Manual

ReflectionFunctionAbstract::getDocComment

(PHP 5 >= 5.1.0, PHP 7)

ReflectionFunctionAbstract::getDocComment — Belgelendirici açıklamaları döndürür

Açıklama

public string ReflectionFunctionAbstract::getDocComment ( void )

İşlev tanımındaki belgelendirici açıklamaları döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Belgelendirici açıklamalar varsa olanlar, yoksa FALSE döner.

Ayrıca Bakınız

  • ReflectionFunctionAbstract::getStartLine() - Başlangıç satır numarasını döndürür

ReflectionFunctionAbstract::getClosureThis
ReflectionFunctionAbstract::getEndLine
ReflectionFunctionAbstract


Son satır numarasını döndürür

ReflectionFunctionAbstract::getDocComment
ReflectionFunctionAbstract::getExtension
ReflectionFunctionAbstract
PHP Manual

ReflectionFunctionAbstract::getEndLine

(PHP 5, PHP 7)

ReflectionFunctionAbstract::getEndLine — Son satır numarasını döndürür

Açıklama

public int ReflectionFunctionAbstract::getEndLine ( void )

Son satır numarasını döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Kullanıcı tanımlı sınıfın son satır numarasını döndürür. Satır numarası bilinmiyorsa FALSE döner.

Ayrıca Bakınız

  • ReflectionFunctionAbstract::getStartLine() - Başlangıç satır numarasını döndürür

ReflectionFunctionAbstract::getDocComment
ReflectionFunctionAbstract::getExtension
ReflectionFunctionAbstract


Eklenti bilgilerini döndürür

ReflectionFunctionAbstract::getEndLine
ReflectionFunctionAbstract::getExtensionName
ReflectionFunctionAbstract
PHP Manual

ReflectionFunctionAbstract::getExtension

(PHP 5, PHP 7)

ReflectionFunctionAbstract::getExtension — Eklenti bilgilerini döndürür

Açıklama

public ReflectionExtension ReflectionFunctionAbstract::getExtension ( void )

Bir işlevin eklenti bilgilerini döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Bir ReflectionExtension nesnesi döner.

Ayrıca Bakınız

  • ReflectionFunctionAbstract::getExtensionName() - Eklenti ismini döndürür

ReflectionFunctionAbstract::getEndLine
ReflectionFunctionAbstract::getExtensionName
ReflectionFunctionAbstract


Eklenti ismini döndürür

ReflectionFunctionAbstract::getExtension
ReflectionFunctionAbstract::getFileName
ReflectionFunctionAbstract
PHP Manual

ReflectionFunctionAbstract::getExtensionName

(PHP 5, PHP 7)

ReflectionFunctionAbstract::getExtensionName — Eklenti ismini döndürür

Açıklama

public string ReflectionFunctionAbstract::getExtensionName ( void )

Eklenti ismini döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Eklenti ismi.

Ayrıca Bakınız

  • ReflectionFunctionAbstract::getExtension() - Eklenti bilgilerini döndürür

ReflectionFunctionAbstract::getExtension
ReflectionFunctionAbstract::getFileName
ReflectionFunctionAbstract


Dosya ismini döndürür

ReflectionFunctionAbstract::getExtensionName
ReflectionFunctionAbstract::getName
ReflectionFunctionAbstract
PHP Manual

ReflectionFunctionAbstract::getFileName

(PHP 5, PHP 7)

ReflectionFunctionAbstract::getFileName — Dosya ismini döndürür

Açıklama

public string ReflectionFunctionAbstract::getFileName ( void )

Kullanıcı tanımlı işlevin dosya ismini döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Dosya ismi.

Ayrıca Bakınız

  • ReflectionFunctionAbstract::getNamespaceName() - İsim alanı adını döndürür

ReflectionFunctionAbstract::getExtensionName
ReflectionFunctionAbstract::getName
ReflectionFunctionAbstract


İşlev ismini döndürür

ReflectionFunctionAbstract::getFileName
ReflectionFunctionAbstract::getNamespaceName
ReflectionFunctionAbstract
PHP Manual

ReflectionFunctionAbstract::getName

(PHP 5, PHP 7)

ReflectionFunctionAbstract::getName — İşlev ismini döndürür

Açıklama

public string ReflectionFunctionAbstract::getName ( void )

İşlev ismini döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

İşlev ismi.

Ayrıca Bakınız

  • ReflectionFunctionAbstract::getExtensionName() - Eklenti ismini döndürür
  • ReflectionFunctionAbstract::isUserDefined() - İşlev kullanıcı tanımlı bir işlev mi diye bakar

ReflectionFunctionAbstract::getFileName
ReflectionFunctionAbstract::getNamespaceName
ReflectionFunctionAbstract


İsim alanı adını döndürür

ReflectionFunctionAbstract::getName
ReflectionFunctionAbstract::getNumberOfParameters
ReflectionFunctionAbstract
PHP Manual

ReflectionFunctionAbstract::getNamespaceName

(PHP 5 >= 5.3.0, PHP 7)

ReflectionFunctionAbstract::getNamespaceName — İsim alanı adını döndürür

Açıklama

public string ReflectionFunctionAbstract::getNamespaceName ( void )

Sınıfın tanımlandığı isim alanının adını döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

İsim alanı adı.

Ayrıca Bakınız

  • ReflectionFunctionAbstract::getFileName() - Dosya ismini döndürür
  • İsim Alanları

ReflectionFunctionAbstract::getName
ReflectionFunctionAbstract::getNumberOfParameters
ReflectionFunctionAbstract


Değiştirge sayısını döndürür

ReflectionFunctionAbstract::getNamespaceName
ReflectionFunctionAbstract::getNumberOfRequiredParameters
ReflectionFunctionAbstract
PHP Manual

ReflectionFunctionAbstract::getNumberOfParameters

(PHP 5 >= 5.0.3, PHP 7)

ReflectionFunctionAbstract::getNumberOfParameters — Değiştirge sayısını döndürür

Açıklama

public int ReflectionFunctionAbstract::getNumberOfParameters ( void )

İşlevin tanımladığı zorunlu ve seçimlik değiştirgelerin toplam sayısını döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Değiştirge sayısı.

Ayrıca Bakınız

  • ReflectionFunctionAbstract::getNumberOfRequiredParameters() - Zorunlu değiştirge sayısını döndürür

ReflectionFunctionAbstract::getNamespaceName
ReflectionFunctionAbstract::getNumberOfRequiredParameters
ReflectionFunctionAbstract


Zorunlu değiştirge sayısını döndürür

ReflectionFunctionAbstract::getNumberOfParameters
ReflectionFunctionAbstract::getParameters
ReflectionFunctionAbstract
PHP Manual

ReflectionFunctionAbstract::getNumberOfRequiredParameters

(PHP 5 >= 5.0.3, PHP 7)

ReflectionFunctionAbstract::getNumberOfRequiredParameters — Zorunlu değiştirge sayısını döndürür

Açıklama

public int ReflectionFunctionAbstract::getNumberOfRequiredParameters ( void )

Bir işlevde tanımlı zorunlu değiştirge sayısını döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Zorunlu değiştirge sayısı.

Ayrıca Bakınız

  • ReflectionFunctionAbstract::getNumberOfParameters() - Değiştirge sayısını döndürür

ReflectionFunctionAbstract::getNumberOfParameters
ReflectionFunctionAbstract::getParameters
ReflectionFunctionAbstract


Değiştirgeleri döndürür

ReflectionFunctionAbstract::getNumberOfRequiredParameters
ReflectionFunctionAbstract::getReturnType
ReflectionFunctionAbstract
PHP Manual

ReflectionFunctionAbstract::getParameters

(PHP 5, PHP 7)

ReflectionFunctionAbstract::getParameters — Değiştirgeleri döndürür

Açıklama

public array ReflectionFunctionAbstract::getParameters ( void )

Değiştirgeleri bir ReflectionParameter dizisi olarak döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Bir ReflectionParameter nesnesi döner.

Ayrıca Bakınız

  • ReflectionFunctionAbstract::getNumberOfParameters() - Değiştirge sayısını döndürür

ReflectionFunctionAbstract::getNumberOfRequiredParameters
ReflectionFunctionAbstract::getReturnType
ReflectionFunctionAbstract


Gets the specified return type of a function

ReflectionFunctionAbstract::getParameters
ReflectionFunctionAbstract::getShortName
ReflectionFunctionAbstract
PHP Manual

ReflectionFunctionAbstract::getReturnType

(PHP 7)

ReflectionFunctionAbstract::getReturnType — Gets the specified return type of a function

Açıklama

public ReflectionType ReflectionFunctionAbstract::getReturnType ( void )

Gets the specified return type of a reflected function.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a ReflectionType object if a return type is specified, NULL otherwise.

Örnekler

Örnek 1 ReflectionFunctionAbstract::getReturnType() example

<?php

function to_int($param) : int {
    return (int) $param;
}

$reflection1 = new ReflectionFunction('to_int');
echo $reflection1->getReturnType();

Yukarıdaki örneğin çıktısı:

int

Örnek 2 Usage on built-in functions

<?php

$reflection2 = new ReflectionFunction('array_merge');

var_dump($reflection2->getReturnType());

Yukarıdaki örneğin çıktısı:

null

This is because many internal functions do not have types specified for their parameters or return values. It is therefore best to avoid using this method on built-in functions.

Ayrıca Bakınız

  • ReflectionFunctionAbstract::hasReturnType() - Checks if the function has a specified return type
  • ReflectionType::__toString()

ReflectionFunctionAbstract::getParameters
ReflectionFunctionAbstract::getShortName
ReflectionFunctionAbstract


İşlevin kısa ismini döndürür

ReflectionFunctionAbstract::getReturnType
ReflectionFunctionAbstract::getStartLine
ReflectionFunctionAbstract
PHP Manual

ReflectionFunctionAbstract::getShortName

(PHP 5 >= 5.3.0, PHP 7)

ReflectionFunctionAbstract::getShortName — İşlevin kısa ismini döndürür

Açıklama

public string ReflectionFunctionAbstract::getShortName ( void )

İşlevin kısa ismini (isim alansız ismini) döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

İşlevin kısa ismi.

Ayrıca Bakınız

  • ReflectionFunctionAbstract::getNamespaceName() - İsim alanı adını döndürür
  • İsim Alanları

ReflectionFunctionAbstract::getReturnType
ReflectionFunctionAbstract::getStartLine
ReflectionFunctionAbstract


Başlangıç satır numarasını döndürür

ReflectionFunctionAbstract::getShortName
ReflectionFunctionAbstract::getStaticVariables
ReflectionFunctionAbstract
PHP Manual

ReflectionFunctionAbstract::getStartLine

(PHP 5, PHP 7)

ReflectionFunctionAbstract::getStartLine — Başlangıç satır numarasını döndürür

Açıklama

public int ReflectionFunctionAbstract::getStartLine ( void )

İşlev tanımının başlangıç satır numarasını döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Başlangıç satır numarası.

Ayrıca Bakınız

  • ReflectionFunctionAbstract::getEndLine() - Son satır numarasını döndürür

ReflectionFunctionAbstract::getShortName
ReflectionFunctionAbstract::getStaticVariables
ReflectionFunctionAbstract


Duruk değişkenleri döndürür

ReflectionFunctionAbstract::getStartLine
ReflectionFunctionAbstract::hasReturnType
ReflectionFunctionAbstract
PHP Manual

ReflectionFunctionAbstract::getStaticVariables

(PHP 5, PHP 7)

ReflectionFunctionAbstract::getStaticVariables — Duruk değişkenleri döndürür

Açıklama

public array ReflectionFunctionAbstract::getStaticVariables ( void )

Duruk değişkenleri döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Duruk değişken dizisi.

Ayrıca Bakınız

  • ReflectionFunctionAbstract::getParameters() - Değiştirgeleri döndürür

ReflectionFunctionAbstract::getStartLine
ReflectionFunctionAbstract::hasReturnType
ReflectionFunctionAbstract


Checks if the function has a specified return type

ReflectionFunctionAbstract::getStaticVariables
ReflectionFunctionAbstract::inNamespace
ReflectionFunctionAbstract
PHP Manual

ReflectionFunctionAbstract::hasReturnType

(PHP 7)

ReflectionFunctionAbstract::hasReturnType — Checks if the function has a specified return type

Açıklama

public bool ReflectionFunctionAbstract::hasReturnType ( void )

Checks whether the reflected function has a return type specified.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the function is a specified return type, otherwise FALSE.

Örnekler

Örnek 1 ReflectionFunctionAbstract::hasReturnType() example

<?php

function to_int($param) : int {
    return (int) $param;
}

$reflection1 = new ReflectionFunction('to_int');
var_dump($reflection1->hasReturnType());

Yukarıdaki örneğin çıktısı:

bool(true)

Örnek 2 Usage on built-in functions

<?php

$reflection2 = new ReflectionFunction('array_merge');

var_dump($reflection2->hasReturnType());

Yukarıdaki örneğin çıktısı:

bool(false)

This is because many internal functions do not have types specified for their parameters or return values. It is therefore best to avoid using this method on built-in functions.

Ayrıca Bakınız

  • ReflectionFunctionAbstract::getReturnType() - Gets the specified return type of a function

ReflectionFunctionAbstract::getStaticVariables
ReflectionFunctionAbstract::inNamespace
ReflectionFunctionAbstract


İşlev isim alanına ait mi diye bakar

ReflectionFunctionAbstract::hasReturnType
ReflectionFunctionAbstract::isClosure
ReflectionFunctionAbstract
PHP Manual

ReflectionFunctionAbstract::inNamespace

(PHP 5 >= 5.3.0, PHP 7)

ReflectionFunctionAbstract::inNamespace — İşlev isim alanına ait mi diye bakar

Açıklama

public bool ReflectionFunctionAbstract::inNamespace ( void )

İşlev isim alanında ise TRUE döner.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

İşlev isim alanında ise TRUE değilse FALSE döner.

Ayrıca Bakınız

  • ReflectionFunctionAbstract::getNamespaceName() - İsim alanı adını döndürür
  • İsim Alanları

ReflectionFunctionAbstract::hasReturnType
ReflectionFunctionAbstract::isClosure
ReflectionFunctionAbstract


Bir anonim işlev mi diye bakar

ReflectionFunctionAbstract::inNamespace
ReflectionFunctionAbstract::isDeprecated
ReflectionFunctionAbstract
PHP Manual

ReflectionFunctionAbstract::isClosure

(PHP 5 >= 5.3.0, PHP 7)

ReflectionFunctionAbstract::isClosure — Bir anonim işlev mi diye bakar

Açıklama

public bool ReflectionFunctionAbstract::isClosure ( void )

Bir anonim işlev ise TRUE döner.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Bir anonim işlev ise TRUE yoksa FALSE döner

Ayrıca Bakınız

  • ReflectionFunctionAbstract::isinternal() - İşlev yerleşik mi diye bakar

ReflectionFunctionAbstract::inNamespace
ReflectionFunctionAbstract::isDeprecated
ReflectionFunctionAbstract


Kullanımı önerilmiyor mu diye bakar

ReflectionFunctionAbstract::isClosure
ReflectionFunctionAbstract::isGenerator
ReflectionFunctionAbstract
PHP Manual

ReflectionFunctionAbstract::isDeprecated

(PHP 5, PHP 7)

ReflectionFunctionAbstract::isDeprecated — Kullanımı önerilmiyor mu diye bakar

Açıklama

public bool ReflectionFunctionAbstract::isDeprecated ( void )

İşlevin kullanımı önerilmiyorsa TRUE döner.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

İşlevin kullanımı önerilmiyorsa TRUE yoksa FALSE döner

Ayrıca Bakınız

  • ReflectionFunctionAbstract::getDocComment() - Belgelendirici açıklamaları döndürür

ReflectionFunctionAbstract::isClosure
ReflectionFunctionAbstract::isGenerator
ReflectionFunctionAbstract


Returns whether this function is a generator

ReflectionFunctionAbstract::isDeprecated
ReflectionFunctionAbstract::isInternal
ReflectionFunctionAbstract
PHP Manual

ReflectionFunctionAbstract::isGenerator

(PHP 5 >= 5.5.0, PHP 7)

ReflectionFunctionAbstract::isGenerator — Returns whether this function is a generator

Açıklama

public bool ReflectionFunctionAbstract::isGenerator ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the function is generator, FALSE if it is not or NULL on failure.

ReflectionFunctionAbstract::isDeprecated
ReflectionFunctionAbstract::isInternal
ReflectionFunctionAbstract


İşlev yerleşik mi diye bakar

ReflectionFunctionAbstract::isGenerator
ReflectionFunctionAbstract::isUserDefined
ReflectionFunctionAbstract
PHP Manual

ReflectionFunctionAbstract::isInternal

(PHP 5, PHP 7)

ReflectionFunctionAbstract::isInternal — İşlev yerleşik mi diye bakar

Açıklama

public bool ReflectionFunctionAbstract::isInternal ( void )

İşlev yerleşik ise TRUE kullanıcı tanımlı ise FALSE döner.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

İşlev yerleşik ise TRUE yoksa FALSE döner.

Ayrıca Bakınız

  • ReflectionFunctionAbstract::isUserDefined() - İşlev kullanıcı tanımlı bir işlev mi diye bakar

ReflectionFunctionAbstract::isGenerator
ReflectionFunctionAbstract::isUserDefined
ReflectionFunctionAbstract


İşlev kullanıcı tanımlı bir işlev mi diye bakar

ReflectionFunctionAbstract::isInternal
ReflectionFunctionAbstract::isVariadic
ReflectionFunctionAbstract
PHP Manual

ReflectionFunctionAbstract::isUserDefined

(PHP 5, PHP 7)

ReflectionFunctionAbstract::isUserDefined — İşlev kullanıcı tanımlı bir işlev mi diye bakar

Açıklama

public bool ReflectionFunctionAbstract::isUserDefined ( void )

İşlev kullanıcı tanımlı bir işlev ise TRUE yerleşik bir işlevse FALSE döner.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

İşlev kullanıcı tanımlı bir işlev ise TRUE yoksa FALSE döner.

Ayrıca Bakınız

  • ReflectionFunctionAbstract::isInternal() - İşlev yerleşik mi diye bakar

ReflectionFunctionAbstract::isInternal
ReflectionFunctionAbstract::isVariadic
ReflectionFunctionAbstract


Checks if the function is variadic

ReflectionFunctionAbstract::isUserDefined
ReflectionFunctionAbstract::returnsReference
ReflectionFunctionAbstract
PHP Manual

ReflectionFunctionAbstract::isVariadic

(PHP 5 >= 5.6.0, PHP 7)

ReflectionFunctionAbstract::isVariadic — Checks if the function is variadic

Açıklama

public bool ReflectionFunctionAbstract::isVariadic ( void )

Checks if the function is variadic.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the function is variadic, otherwise FALSE.

ReflectionFunctionAbstract::isUserDefined
ReflectionFunctionAbstract::returnsReference
ReflectionFunctionAbstract


İşlev dönüş değeri gönderimli mi diye bakar

ReflectionFunctionAbstract::isVariadic
ReflectionFunctionAbstract::__toString
ReflectionFunctionAbstract
PHP Manual

ReflectionFunctionAbstract::returnsReference

(PHP 5, PHP 7)

ReflectionFunctionAbstract::returnsReference — İşlev dönüş değeri gönderimli mi diye bakar

Açıklama

public bool ReflectionFunctionAbstract::returnsReference ( void )

İşlev dönüş değeri gönderimli ise TRUE döner.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

İşlev dönüş değeri gönderimli ise TRUE yoksa FALSE döner.

Ayrıca Bakınız

  • ReflectionFunctionAbstract::isClosure() - Bir anonim işlev mi diye bakar

ReflectionFunctionAbstract::isVariadic
ReflectionFunctionAbstract::__toString
ReflectionFunctionAbstract


Dizgesel tepkiyi görselleştirir

ReflectionFunctionAbstract::returnsReference
ReflectionMethod
ReflectionFunctionAbstract
PHP Manual

ReflectionFunctionAbstract::__toString

(PHP 5, PHP 7)

ReflectionFunctionAbstract::__toString — Dizgesel tepkiyi görselleştirir

Açıklama

abstract public void ReflectionFunctionAbstract::__toString ( void )

Dizgesel tepkiyi görselleştirir.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Bir dizge.

Ayrıca Bakınız

  • ReflectionFunctionAbstract::clone()
  • __toString

ReflectionFunctionAbstract::returnsReference
ReflectionMethod
ReflectionFunctionAbstract


ReflectionMethod Sınıfı

(PHP 5, PHP 7)

Giriş

ReflectionMethod sınıfı bir yöntem hakkında bilgi edinilmesini sağlar.

Sınıf Sözdizimi

ReflectionMethod extends ReflectionFunctionAbstract implements Reflector {
/* Sabitler */
const integer IS_STATIC = 1 ;
const integer IS_PUBLIC = 256 ;
const integer IS_PROTECTED = 512 ;
const integer IS_PRIVATE = 1024 ;
const integer IS_ABSTRACT = 2 ;
const integer IS_FINAL = 4 ;
/* Özellikler */
public $name ;
public $class ;
/* Yöntemler */
__construct ( string $sınıf_veya_yöntem [, string $isim ] )
public static string export ( string $sınıf , string $isim [, bool $return = false ] )
public Closure getClosure ( object $object )
public ReflectionClass getDeclaringClass ( void )
public int getModifiers ( void )
public void getPrototype ( void )
public mixed invoke ( object $nesne , string $değiştirgeler )
public mixed invokeArgs ( string $nesne , array $değiştirgeler )
public bool isAbstract ( void )
public bool isConstructor ( void )
public bool isDestructor ( void )
public bool isFinal ( void )
public bool isPrivate ( void )
public bool isProtected ( void )
public bool isPublic ( void )
public bool isStatic ( void )
public void setAccessible ( bool $accessible )
public string __toString ( void )
/* Miras alınan yöntemler */
final private void ReflectionFunctionAbstract::__clone ( void )
public ReflectionClass ReflectionFunctionAbstract::getClosureScopeClass ( void )
public object ReflectionFunctionAbstract::getClosureThis ( void )
public string ReflectionFunctionAbstract::getDocComment ( void )
public int ReflectionFunctionAbstract::getEndLine ( void )
public ReflectionExtension ReflectionFunctionAbstract::getExtension ( void )
public string ReflectionFunctionAbstract::getExtensionName ( void )
public string ReflectionFunctionAbstract::getFileName ( void )
public string ReflectionFunctionAbstract::getName ( void )
public string ReflectionFunctionAbstract::getNamespaceName ( void )
public int ReflectionFunctionAbstract::getNumberOfParameters ( void )
public int ReflectionFunctionAbstract::getNumberOfRequiredParameters ( void )
public array ReflectionFunctionAbstract::getParameters ( void )
public ReflectionType ReflectionFunctionAbstract::getReturnType ( void )
public string ReflectionFunctionAbstract::getShortName ( void )
public int ReflectionFunctionAbstract::getStartLine ( void )
public array ReflectionFunctionAbstract::getStaticVariables ( void )
public bool ReflectionFunctionAbstract::hasReturnType ( void )
public bool ReflectionFunctionAbstract::inNamespace ( void )
public bool ReflectionFunctionAbstract::isClosure ( void )
public bool ReflectionFunctionAbstract::isDeprecated ( void )
public bool ReflectionFunctionAbstract::isGenerator ( void )
public bool ReflectionFunctionAbstract::isInternal ( void )
public bool ReflectionFunctionAbstract::isUserDefined ( void )
public bool ReflectionFunctionAbstract::isVariadic ( void )
public bool ReflectionFunctionAbstract::returnsReference ( void )
abstract public void ReflectionFunctionAbstract::__toString ( void )
}

Özellikler

name

Yöntemin ismi.

class

Sınıfın ismi

Öntanımlı Sabitler

ReflectionMethod Değiştiricileri

ReflectionMethod::IS_STATIC

Yöntemin duruk olduğunu belirtir.

ReflectionMethod::IS_PUBLIC

Yöntemin genel bir yöntem olduğunu belirtir

ReflectionMethod::IS_PROTECTED

Yöntemin korunmuş olduğunu belirtir.

ReflectionMethod::IS_PRIVATE

Yöntemin özel olduğunu belirtir.

ReflectionMethod::IS_ABSTRACT

Yöntemin soyut olduğunu belirtir.

ReflectionMethod::IS_FINAL

Yöntemin bir final yöntem olduğunu belirtir.

İçindekiler

  • ReflectionMethod::__construct — Yeni bir ReflectionMethod nesnesi oluşturur
  • ReflectionMethod::export — Sınıfı ihraç eder
  • ReflectionMethod::getClosure — Returns a dynamically created closure for the method
  • ReflectionMethod::getDeclaringClass — Bildiren sınıfı döndürür
  • ReflectionMethod::getModifiers — Değiştirici sayısını döndürür
  • ReflectionMethod::getPrototype — Bildirimi döndürür
  • ReflectionMethod::invoke — Yöntemi çağırır
  • ReflectionMethod::invokeArgs — Değiştirgeleri çağırır
  • ReflectionMethod::isAbstract — Yöntem soyut mu diye bakar
  • ReflectionMethod::isConstructor — Yöntem bir kurucu mu diye bakar
  • ReflectionMethod::isDestructor — Yöntem bir yıkıcı mı diye bakar
  • ReflectionMethod::isFinal — Yöntem final olarak mı bildirilmiş diye bakar
  • ReflectionMethod::isPrivate — Yöntem private olarak mı bildirilmiş diye bakar
  • ReflectionMethod::isProtected — Yöntem protected olarak mı bildirilmiş diye bakar
  • ReflectionMethod::isPublic — Yöntem public olarak mı bildirilmiş diye bakar
  • ReflectionMethod::isStatic — Yöntem bir duruk yöntem mi diye bakar
  • ReflectionMethod::setAccessible — Set method accessibility
  • ReflectionMethod::__toString — Dizgesel tepkiyi görselleştirir
ReflectionFunctionAbstract::__toString
ReflectionMethod::__construct
Reflection


Yeni bir ReflectionMethod nesnesi oluşturur

ReflectionMethod
ReflectionMethod::export
ReflectionMethod
PHP Manual

ReflectionMethod::__construct

(PHP 5, PHP 7)

ReflectionMethod::__construct — Yeni bir ReflectionMethod nesnesi oluşturur

Açıklama

ReflectionMethod::__construct ( string $sınıf_veya_yöntem [, string $isim ] )

Yeni bir ReflectionMethod nesnesi oluşturur.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

sınıf_veya_yöntem

isim

Dönen Değerler

Örnekler

Örnek 1 - ReflectionMethod::__construct() örneği

<?php
class Sayaç
{
    private static $c = 0;

    /**
     * Artan sayaç
     *
     * @final
     * @static
     * @access  public
     * @return  int
     */
    final public static function arttır()
    {
        return ++self::$c;
    }
}

// ReflectionMethod sınıfının yeni bir örneğini oluşturalım
$method = new ReflectionMethod('Sayaç', 'arttır');

// Temel bilgileri basalım
printf(
    "===> %s%s%s%s%s%s%s '%s' yöntemi (%s)\n" .
    "     %s dosyasının\n" .
    "     %d. satırından %d. satırına kadar\n" .
    "     %d[%s] değiştiriciyle tanımlanmış.\n",
        $method->isInternal() ? 'Yerleşik' : 'Kullanıcı tanımlı',
        $method->isAbstract() ? ' abstract' : '',
        $method->isFinal() ? ' final' : '',
        $method->isPublic() ? ' public' : '',
        $method->isPrivate() ? ' private' : '',
        $method->isProtected() ? ' protected' : '',
        $method->isStatic() ? ' static' : '',
        $method->getName(),
        $method->isConstructor() ? 'bir kurucu' : 'sıradan bir yöntem',
        $method->getFileName(),
        $method->getStartLine(),
        $method->getEndline(),
        $method->getModifiers(),
        implode(' ', Reflection::getModifierNames($method->getModifiers()))
);

// Belgelendirici açıklamaları basalım
printf("---> Belgeleme:\n %s\n", var_export($method->getDocComment(), 1));

// Varsa duruk değişkenleri basalım
if ($statics= $method->getStaticVariables()) {
    printf("---> Duruk değişkenler: %s\n", var_export($statics, 1));
}

// Yöntemi çağıralım
printf("---> Çağrı sonuçları: ");
var_dump($method->invoke(NULL));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

===> Kullanıcı tanımlı final public static 'arttır' yöntemi (sıradan bir yöntem)
     /home/nilgun/dnm.php dosyasının
     14. satırından 17. satırına kadar
     261[final public static] değiştiriciyle tanımlanmış.
---> Belgeleme:
 '/**
     * Artan sayaç
     *
     * @final
     * @static
     * @access  public
     * @return  int
     */'
---> Çağrı sonuçları: int(1)

Ayrıca Bakınız

  • ReflectionMethod::export() - Sınıfı ihraç eder
  • Kurucular ve Yıkıcılar

ReflectionMethod
ReflectionMethod::export
ReflectionMethod


Sınıfı ihraç eder

ReflectionMethod::__construct
ReflectionMethod::getClosure
ReflectionMethod
PHP Manual

ReflectionMethod::export

(PHP 5, PHP 7)

ReflectionMethod::export — Sınıfı ihraç eder

Açıklama

public static string ReflectionMethod::export ( string $sınıf , string $isim [, bool $return = false ] )

ReflectionMethod sınıfını ihraç eder.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

sınıf

Sınıf ismi.

isim

Yöntem ismi.

ihracet

TRUE belirtilirse yansıtmak yerine ihrac eder. FALSE olursa (öntanımlıdır) tersini yapar.

Dönen Değerler

TRUE belirtilirse bir dizge yoksa NULL döner.

Ayrıca Bakınız

  • ReflectionMethod::__construct() - Yeni bir ReflectionMethod nesnesi oluşturur

ReflectionMethod::__construct
ReflectionMethod::getClosure
ReflectionMethod


Returns a dynamically created closure for the method

ReflectionMethod::export
ReflectionMethod::getDeclaringClass
ReflectionMethod
PHP Manual

ReflectionMethod::getClosure

(PHP >= 5.4.0)

ReflectionMethod::getClosure — Returns a dynamically created closure for the method

Açıklama

public Closure ReflectionMethod::getClosure ( object $object )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

object

Forbidden for static methods, required for other methods.

Dönen Değerler

Returns Closure. Returns NULL in case of an error.

ReflectionMethod::export
ReflectionMethod::getDeclaringClass
ReflectionMethod


Bildiren sınıfı döndürür

ReflectionMethod::getClosure
ReflectionMethod::getModifiers
ReflectionMethod
PHP Manual

ReflectionMethod::getDeclaringClass

(PHP 5, PHP 7)

ReflectionMethod::getDeclaringClass — Bildiren sınıfı döndürür

Açıklama

public ReflectionClass ReflectionMethod::getDeclaringClass ( void )

Bildiren sınıfı döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Bir ReflectionClass nesnesi.

Ayrıca Bakınız

  • ReflectionMethod::isAbstract() - Yöntem soyut mu diye bakar

ReflectionMethod::getClosure
ReflectionMethod::getModifiers
ReflectionMethod


Değiştirici sayısını döndürür

ReflectionMethod::getDeclaringClass
ReflectionMethod::getPrototype
ReflectionMethod
PHP Manual

ReflectionMethod::getModifiers

(PHP 5, PHP 7)

ReflectionMethod::getModifiers — Değiştirici sayısını döndürür

Açıklama

public int ReflectionMethod::getModifiers ( void )

Değiştirici sayısını döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Değiştirici sayısı.

Örnekler

Örnek 1 - ReflectionMethod::getModifiers() örneği

<?php
class Testing
{
    final public static function foo()
    {
        return;
    }
    public function bar()
    {
        return;
    }
}

$foo = new ReflectionMethod('Testing', 'foo');

echo "foo() yönteminin değiştirici sayısı:\n";
echo $foo->getModifiers() . "\n";
echo implode(' ', Reflection::getModifierNames($foo->getModifiers())) . "\n";

$bar = new ReflectionMethod('Testing', 'bar');

echo "bar() yönteminin değiştirici sayısı:\n";
echo $bar->getModifiers() . "\n";
echo implode(' ', Reflection::getModifierNames($bar->getModifiers()));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

foo() yönteminin değiştirici sayısı:
261
final public static
bar() yönteminin değiştirici sayısı:
65792

Ayrıca Bakınız

  • Reflection::getModifierNames() - Değiştirici isimlerini döndürür

ReflectionMethod::getDeclaringClass
ReflectionMethod::getPrototype
ReflectionMethod


Bildirimi döndürür

ReflectionMethod::getModifiers
ReflectionMethod::invoke
ReflectionMethod
PHP Manual

ReflectionMethod::getPrototype

(PHP 5, PHP 7)

ReflectionMethod::getPrototype — Bildirimi döndürür

Açıklama

public void ReflectionMethod::getPrototype ( void )

Yöntem bildirimini döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yöntem bildirimi.

Hatalar/İstisnalar

Yöntemin bir bildirimi yoksa bir ReflectionException istisnası oluşur.

Ayrıca Bakınız

  • ReflectionMethod::getModifiers() - Değiştirici sayısını döndürür

ReflectionMethod::getModifiers
ReflectionMethod::invoke
ReflectionMethod


Yöntemi çağırır

ReflectionMethod::getPrototype
ReflectionMethod::invokeArgs
ReflectionMethod
PHP Manual

ReflectionMethod::invoke

(PHP 5, PHP 7)

ReflectionMethod::invoke — Yöntemi çağırır

Açıklama

public mixed ReflectionMethod::invoke ( object $nesne , string $değiştirgeler )

Yansıtılan yöntemi çağırır.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

nesne

Çağrılacak nesne.

değiştirgeler

Aktarılacak değiştirge listesi. call_user_func() işlevindeki gibi yeteri sayıda değiştirge aktarabilirsiniz.

Dönen Değerler

Ayrıca Bakınız

  • ReflectionMethod::invokeArgs() - Değiştirgeleri çağırır
  • __invoke

ReflectionMethod::getPrototype
ReflectionMethod::invokeArgs
ReflectionMethod


Değiştirgeleri çağırır

ReflectionMethod::invoke
ReflectionMethod::isAbstract
ReflectionMethod
PHP Manual

ReflectionMethod::invokeArgs

(PHP 5 >= 5.1.0, PHP 7)

ReflectionMethod::invokeArgs — Değiştirgeleri çağırır

Açıklama

public mixed ReflectionMethod::invokeArgs ( string $nesne , array $değiştirgeler )

Değiştirgeleri çağırır.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

nesne

değiştirgeler

Dönen Değerler

Ayrıca Bakınız

  • ReflectionMethod::invoke() - Yöntemi çağırır
  • __invoke

ReflectionMethod::invoke
ReflectionMethod::isAbstract
ReflectionMethod


Yöntem soyut mu diye bakar

ReflectionMethod::invokeArgs
ReflectionMethod::isConstructor
ReflectionMethod
PHP Manual

ReflectionMethod::isAbstract

(PHP 5, PHP 7)

ReflectionMethod::isAbstract — Yöntem soyut mu diye bakar

Açıklama

public bool ReflectionMethod::isAbstract ( void )

Yöntem soyut ise TRUE döner.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yöntem soyut ise TRUE yoksa FALSE döner.

Ayrıca Bakınız

  • ReflectionMethod::getDeclaringClass() - Bildiren sınıfı döndürür

ReflectionMethod::invokeArgs
ReflectionMethod::isConstructor
ReflectionMethod


Yöntem bir kurucu mu diye bakar

ReflectionMethod::isAbstract
ReflectionMethod::isDestructor
ReflectionMethod
PHP Manual

ReflectionMethod::isConstructor

(PHP 5, PHP 7)

ReflectionMethod::isConstructor — Yöntem bir kurucu mu diye bakar

Açıklama

public bool ReflectionMethod::isConstructor ( void )

Yöntem bir kurucu yöntem ise TRUE döner.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yöntem bir kurucu yöntem ise TRUE yoksa FALSE.

Ayrıca Bakınız

  • ReflectionMethod::__construct() - Yeni bir ReflectionMethod nesnesi oluşturur
  • ReflectionMethod::isAbstract() - Yöntem soyut mu diye bakar
  • ReflectionMethod::isDestructor() - Yöntem bir yıkıcı mı diye bakar

ReflectionMethod::isAbstract
ReflectionMethod::isDestructor
ReflectionMethod


Yöntem bir yıkıcı mı diye bakar

ReflectionMethod::isConstructor
ReflectionMethod::isFinal
ReflectionMethod
PHP Manual

ReflectionMethod::isDestructor

(PHP 5, PHP 7)

ReflectionMethod::isDestructor — Yöntem bir yıkıcı mı diye bakar

Açıklama

public bool ReflectionMethod::isDestructor ( void )

Yöntem bir yıkıcı ise TRUE döner.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yöntem bir yıkıcı ise TRUE yoksa FALSE.

Ayrıca Bakınız

  • ReflectionMethod::isConstructor() - Yöntem bir kurucu mu diye bakar

ReflectionMethod::isConstructor
ReflectionMethod::isFinal
ReflectionMethod


Yöntem final olarak mı bildirilmiş diye bakar

ReflectionMethod::isDestructor
ReflectionMethod::isPrivate
ReflectionMethod
PHP Manual

ReflectionMethod::isFinal

(PHP 5, PHP 7)

ReflectionMethod::isFinal — Yöntem final olarak mı bildirilmiş diye bakar

Açıklama

public bool ReflectionMethod::isFinal ( void )

Yöntem final olarak bildirilmişse TRUE döner.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yöntem final olarak bildirilmişse TRUE yoksa FALSE.

Ayrıca Bakınız

  • ReflectionMethod::isStatic() - Yöntem bir duruk yöntem mi diye bakar

ReflectionMethod::isDestructor
ReflectionMethod::isPrivate
ReflectionMethod


Yöntem private olarak mı bildirilmiş diye bakar

ReflectionMethod::isFinal
ReflectionMethod::isProtected
ReflectionMethod
PHP Manual

ReflectionMethod::isPrivate

(PHP 5, PHP 7)

ReflectionMethod::isPrivate — Yöntem private olarak mı bildirilmiş diye bakar

Açıklama

public bool ReflectionMethod::isPrivate ( void )

Yöntem private olarak bildirilmişse TRUE döner.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yöntem private olarak bildirilmişse TRUE yoksa FALSE.

Ayrıca Bakınız

  • ReflectionMethod::isPublic() - Yöntem public olarak mı bildirilmiş diye bakar

ReflectionMethod::isFinal
ReflectionMethod::isProtected
ReflectionMethod


Yöntem protected olarak mı bildirilmiş diye bakar

ReflectionMethod::isPrivate
ReflectionMethod::isPublic
ReflectionMethod
PHP Manual

ReflectionMethod::isProtected

(PHP 5, PHP 7)

ReflectionMethod::isProtected — Yöntem protected olarak mı bildirilmiş diye bakar

Açıklama

public bool ReflectionMethod::isProtected ( void )

Yöntem protected olarak bildirilmişse TRUE döner.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yöntem protected olarak bildirilmişse TRUE yoksa FALSE.

Ayrıca Bakınız

  • ReflectionMethod::isPrivate() - Yöntem private olarak mı bildirilmiş diye bakar

ReflectionMethod::isPrivate
ReflectionMethod::isPublic
ReflectionMethod


Yöntem public olarak mı bildirilmiş diye bakar

ReflectionMethod::isProtected
ReflectionMethod::isStatic
ReflectionMethod
PHP Manual

ReflectionMethod::isPublic

(PHP 5, PHP 7)

ReflectionMethod::isPublic — Yöntem public olarak mı bildirilmiş diye bakar

Açıklama

public bool ReflectionMethod::isPublic ( void )

Yöntem public olarak bildirilmişse TRUE döner.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yöntem public olarak bildirilmişse TRUE yoksa FALSE

Ayrıca Bakınız

  • ReflectionMethod::isPrivate() - Yöntem private olarak mı bildirilmiş diye bakar

ReflectionMethod::isProtected
ReflectionMethod::isStatic
ReflectionMethod


Yöntem bir duruk yöntem mi diye bakar

ReflectionMethod::isPublic
ReflectionMethod::setAccessible
ReflectionMethod
PHP Manual

ReflectionMethod::isStatic

(PHP 5, PHP 7)

ReflectionMethod::isStatic — Yöntem bir duruk yöntem mi diye bakar

Açıklama

public bool ReflectionMethod::isStatic ( void )

Yöntem bir duruk yöntem ise TRUE döner.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yöntem bir durum yöntem ise TRUE yoksa FALSE.

Ayrıca Bakınız

  • ReflectionMethod::isFinal() - Yöntem final olarak mı bildirilmiş diye bakar

ReflectionMethod::isPublic
ReflectionMethod::setAccessible
ReflectionMethod


Set method accessibility

ReflectionMethod::isStatic
ReflectionMethod::__toString
ReflectionMethod
PHP Manual

ReflectionMethod::setAccessible

(PHP 5 >= 5.3.2, PHP 7)

ReflectionMethod::setAccessible — Set method accessibility

Açıklama

public void ReflectionMethod::setAccessible ( bool $accessible )

Sets a method to be accessible. For example, it may allow protected and private methods to be invoked.

Değiştirgeler

accessible

TRUE to allow accessibility, or FALSE.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • ReflectionMethod::isPrivate() - Yöntem private olarak mı bildirilmiş diye bakar
  • ReflectionMethod::isProtected() - Yöntem protected olarak mı bildirilmiş diye bakar

ReflectionMethod::isStatic
ReflectionMethod::__toString
ReflectionMethod


Dizgesel tepkiyi görselleştirir

ReflectionMethod::setAccessible
ReflectionObject
ReflectionMethod
PHP Manual

ReflectionMethod::__toString

(PHP 5, PHP 7)

ReflectionMethod::__toString — Dizgesel tepkiyi görselleştirir

Açıklama

public string ReflectionMethod::__toString ( void )

Dizgesel tepkiyi görselleştirir.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Bir dizge.

Ayrıca Bakınız

  • ReflectionMethod::export() - Sınıfı ihraç eder
  • __toString

ReflectionMethod::setAccessible
ReflectionObject
ReflectionMethod


ReflectionObject Sınıfı

(PHP 5, PHP 7)

Giriş

ReflectionObject sınıfı bir nesne (object) hakkında bigi edinilmesini sağlar.

Sınıf Sözdizimi

ReflectionObject extends ReflectionClass implements Reflector {
/* Sabitler */
const integer IS_IMPLICIT_ABSTRACT = 16 ;
const integer IS_EXPLICIT_ABSTRACT = 32 ;
const integer IS_FINAL = 64 ;
/* >Özellikler */
/* Yöntemler */
__construct ( object $değiştirge )
public static string export ( string $değiştirge [, bool $ihracet ] )
/* Miras alınan yöntemler */
ReflectionClass::__construct ( string $değiştirge )
public static string ReflectionClass::export ( mixed $değiştirge [, bool $ihracet = false ] )
public mixed ReflectionClass::getConstant ( string $isim )
public array ReflectionClass::getConstants ( void )
public object ReflectionClass::getConstructor ( void )
public array ReflectionClass::getDefaultProperties ( void )
public string ReflectionClass::getDocComment ( void )
public int ReflectionClass::getEndLine ( void )
public ReflectionExtension ReflectionClass::getExtension ( void )
public string ReflectionClass::getExtensionName ( void )
public string ReflectionClass::getFileName ( void )
public array ReflectionClass::getInterfaceNames ( void )
public array ReflectionClass::getInterfaces ( void )
public object ReflectionClass::getMethod ( string $isim )
public array ReflectionClass::getMethods ([ string $süzgeç ] )
public int ReflectionClass::getModifiers ( void )
public string ReflectionClass::getName ( void )
public string ReflectionClass::getNamespaceName ( void )
public object ReflectionClass::getParentClass ( void )
public array ReflectionClass::getProperties ([ int $süzgeç ] )
public ReflectionProperty ReflectionClass::getProperty ( string $isim )
public string ReflectionClass::getShortName ( void )
public int ReflectionClass::getStartLine ( void )
public array ReflectionClass::getStaticProperties ( void )
public mixed ReflectionClass::getStaticPropertyValue ( string $isim [, string $öntanımlı ] )
public array ReflectionClass::getTraitAliases ( void )
public array ReflectionClass::getTraitNames ( void )
public array ReflectionClass::getTraits ( void )
public bool ReflectionClass::hasConstant ( string $isim )
public bool ReflectionClass::hasMethod ( string $isim )
public bool ReflectionClass::hasProperty ( string $isim )
public bool ReflectionClass::implementsInterface ( string $arayüz )
public bool ReflectionClass::inNamespace ( void )
public bool ReflectionClass::isAbstract ( void )
public bool ReflectionClass::isAnonymous ( void )
public bool ReflectionClass::isCloneable ( void )
public bool ReflectionClass::isFinal ( void )
public bool ReflectionClass::isInstance ( string $nesne )
public bool ReflectionClass::isInstantiable ( void )
public bool ReflectionClass::isInterface ( void )
public bool ReflectionClass::isInternal ( void )
public bool ReflectionClass::isIterateable ( void )
public bool ReflectionClass::isSubclassOf ( string $sınıf )
public bool ReflectionClass::isTrait ( void )
public bool ReflectionClass::isUserDefined ( void )
public object ReflectionClass::newInstance ( mixed $değiştirgeler [, mixed $... ] )
public object ReflectionClass::newInstanceArgs ([ array $değiştirgeler ] )
public object ReflectionClass::newInstanceWithoutConstructor ( void )
public void ReflectionClass::setStaticPropertyValue ( string $isim , string $değer )
public string ReflectionClass::__toString ( void )
}

Özellikler

name

Nesnenin sınıf ismi. Salt-okunur olup, bir yazma çabası ReflectionException istisnasına yol açar.

İçindekiler

  • ReflectionObject::__construct — Bir ReflectionObject nesnesi oluşturur
  • ReflectionObject::export — Sınıfı ihraç eder
ReflectionMethod::__toString
ReflectionObject::__construct
Reflection


Bir ReflectionObject nesnesi oluşturur

ReflectionObject
ReflectionObject::export
ReflectionObject
PHP Manual

ReflectionObject::__construct

(PHP 5, PHP 7)

ReflectionObject::__construct — Bir ReflectionObject nesnesi oluşturur

Açıklama

ReflectionObject::__construct ( object $değiştirge )

Bir ReflectionObject nesnesi oluşturur.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

değiştirge

Bir nesne örneği.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • ReflectionObject::export() - Sınıfı ihraç eder
  • Kurucular ve Yıkıcılar

ReflectionObject
ReflectionObject::export
ReflectionObject


Sınıfı ihraç eder

ReflectionObject::__construct
ReflectionParameter
ReflectionObject
PHP Manual

ReflectionObject::export

(PHP 5, PHP 7)

ReflectionObject::export — Sınıfı ihraç eder

Açıklama

public static string ReflectionObject::export ( string $değiştirge [, bool $ihracet ] )

Sınıfı ihraç eder.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

değiştirge

İhraç edilecek Reflection nesnesi.

ihracet

TRUE belirtilirse yansıtmak yerine ihrac eder. FALSE olursa (öntanımlıdır) tersini yapar.

Dönen Değerler

TRUE belirtilirse bir dizge yoksa NULL döner.

Ayrıca Bakınız

  • ReflectionObject::__construct() - Bir ReflectionObject nesnesi oluşturur

ReflectionObject::__construct
ReflectionParameter
ReflectionObject


ReflectionParameter Sınıfı

(PHP 5, PHP 7)

Giriş

ReflectionParameter sınıfı bir işlev veya yöntemin değiştirgeleri hakkında bilgi edinilmesini sağlar.

Bir işlevin değiştirgelerini incelemek için önce ReflectionFunction veya ReflectionMethod sınıfının bir örneğini oluşturmalı, sonra da bu sınıfların ReflectionFunctionAbstract::getParameters() yöntemini kullanarak değiştirge dizisini almalısınız.

Sınıf Sözdizimi

ReflectionParameter implements Reflector {
/* Özellikler */
public $name ;
/* Yöntemler */
public bool allowsNull ( void )
public bool canBePassedByValue ( void )
final private void __clone ( void )
__construct ( string $işlev , string $değiştirge )
public static string export ( string $işlev , string $değiştirge [, bool $ihracet ] )
public ReflectionClass getClass ( void )
public ReflectionClass getDeclaringClass ( void )
public ReflectionFunction getDeclaringFunction ( void )
public mixed getDefaultValue ( void )
public string getDefaultValueConstantName ( void )
public string getName ( void )
public int getPosition ( void )
public ReflectionType getType ( void )
public bool hasType ( void )
public bool isArray ( void )
public bool isCallable ( void )
public bool isDefaultValueAvailable ( void )
public bool isDefaultValueConstant ( void )
public bool isOptional ( void )
public bool isPassedByReference ( void )
public bool isVariadic ( void )
public string __toString ( void )
}

Özellikler

name

İsim.

İçindekiler

  • ReflectionParameter::allowsNull — NULL değere izin veriliyor mu diye bakar
  • ReflectionParameter::canBePassedByValue — Returns whether this parameter can be passed by value
  • ReflectionParameter::__clone — Nesneyi kopyalar
  • ReflectionParameter::__construct — Bir ReflectionParameter nesnesi oluşturur
  • ReflectionParameter::export — Sınıfı ihraç eder
  • ReflectionParameter::getClass — Sınıfı döndürür
  • ReflectionParameter::getDeclaringClass — Bildiren sınıfı döndürür
  • ReflectionParameter::getDeclaringFunction — Bildiren işlevi döndürür
  • ReflectionParameter::getDefaultValue — Değiştirgenin öntanımlı değerini döndürür
  • ReflectionParameter::getDefaultValueConstantName — Returns the default value's constant name if default value is constant or null
  • ReflectionParameter::getName — Değiştirgenin ismini döndürür
  • ReflectionParameter::getPosition — Değiştirgenin konumunu döndürür
  • ReflectionParameter::getType — Gets a parameter's type
  • ReflectionParameter::hasType — Checks if parameter has a type
  • ReflectionParameter::isArray — Değiştirge değeri bir dizi mi olacak diye bakar
  • ReflectionParameter::isCallable — Returns whether parameter MUST be callable
  • ReflectionParameter::isDefaultValueAvailable — Öntanımlı bir değerin kullanılabilir olup olmadığına bakar
  • ReflectionParameter::isDefaultValueConstant — Returns whether the default value of this parameter is constant
  • ReflectionParameter::isOptional — Değiştirge seçimlik mi diye bakar
  • ReflectionParameter::isPassedByReference — Değiştirge gönderimli aktarılabilir mi diye bakar
  • ReflectionParameter::isVariadic — Checks if the parameter is variadic
  • ReflectionParameter::__toString — Dizgesel tepkiyi görselleştirir
ReflectionObject::export
ReflectionParameter::allowsNull
Reflection


NULL değere izin veriliyor mu diye bakar

ReflectionParameter
ReflectionParameter::canBePassedByValue
ReflectionParameter
PHP Manual

ReflectionParameter::allowsNull

(PHP 5, PHP 7)

ReflectionParameter::allowsNull — NULL değere izin veriliyor mu diye bakar

Açıklama

public bool ReflectionParameter::allowsNull ( void )

NULL değere izin veriliyorsa TRUE döner.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

NULL değere izin veriliyorsa TRUE yoksa FALSE.

Ayrıca Bakınız

  • ReflectionParameter::isOptional() - Değiştirge seçimlik mi diye bakar

ReflectionParameter
ReflectionParameter::canBePassedByValue
ReflectionParameter


Returns whether this parameter can be passed by value

ReflectionParameter::allowsNull
ReflectionParameter::__clone
ReflectionParameter
PHP Manual

ReflectionParameter::canBePassedByValue

(PHP >= 5.4.0)

ReflectionParameter::canBePassedByValue — Returns whether this parameter can be passed by value

Açıklama

public bool ReflectionParameter::canBePassedByValue ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the parameter can be passed by value, FALSE otherwise. Returns NULL in case of an error.

ReflectionParameter::allowsNull
ReflectionParameter::__clone
ReflectionParameter


Nesneyi kopyalar

ReflectionParameter::canBePassedByValue
ReflectionParameter::__construct
ReflectionParameter
PHP Manual

ReflectionParameter::__clone

(PHP 5, PHP 7)

ReflectionParameter::__clone — Nesneyi kopyalar

Açıklama

final private void ReflectionParameter::__clone ( void )

Nesneyi kopyalar.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Ayrıca Bakınız

  • ReflectionParameter::__toString() - Dizgesel tepkiyi görselleştirir
  • Nesne Kopyalama

ReflectionParameter::canBePassedByValue
ReflectionParameter::__construct
ReflectionParameter


Bir ReflectionParameter nesnesi oluşturur

ReflectionParameter::__clone
ReflectionParameter::export
ReflectionParameter
PHP Manual

ReflectionParameter::__construct

(PHP 5, PHP 7)

ReflectionParameter::__construct — Bir ReflectionParameter nesnesi oluşturur

Açıklama

ReflectionParameter::__construct ( string $işlev , string $değiştirge )

Bir ReflectionParameter nesnesi oluşturur.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

işlev

Değiştirgeleri yansıtılacak işlev.

değiştirge

Değiştirge.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 - ReflectionParameter örneği

<?php
function foo($a, $b, $c) { }
function bar(Exception $a, &$b, $c) { }
function baz(ReflectionFunction $a, $b = 1, $c = null) { }
function abc() { }

$reflect = new ReflectionFunction('foo');

echo $reflect;

foreach ($reflect->getParameters() as $i => $param) {
    printf(
        "-- %d. değiştirge: %s {\n".
        "   Sınıf: %s\n".
        "   NULL'a izin var mı?: %s\n".
        "   Gönderimli aktarılır mı?: %s\n".
        "   Seçimlik mi?: %s\n".
        "}\n",
        $i, // PHP 5.2.3'ten itibaren $param->getPosition() kullanılabilir.
        $param->getName(),
        var_export($param->getClass(), 1),
        $param->allowsNull() ? 'Evet' : 'Hayır',
        $param->isPassedByReference() ? 'Evet' : 'Hayır',
        $param->isOptional() ? 'Evet' : 'Hayır'
    );
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Function [ <user> function foo ] {
  @@ /home/nilgun/dnm.php 2 - 2

  - Parameters [3] {
    Parameter #0 [ <required> $a ]
    Parameter #1 [ <required> $b ]
    Parameter #2 [ <required> $c ]
  }
}
-- 0. değiştirge: a {
   Sınıf: NULL
   NULL'a izin var mı?: Evet
   Gönderimli aktarılır mı?: Hayır
   Seçimlik mi?: Hayır
}
-- 1. değiştirge: b {
   Sınıf: NULL
   NULL'a izin var mı?: Evet
   Gönderimli aktarılır mı?: Hayır
   Seçimlik mi?: Hayır
}
-- 2. değiştirge: c {
   Sınıf: NULL
   NULL'a izin var mı?: Evet
   Gönderimli aktarılır mı?: Hayır
   Seçimlik mi?: Hayır
}

Ayrıca Bakınız

  • ReflectionFunction::__construct() - Bir ReflectionFunction nesnesi oluşturur
  • ReflectionMethod::__construct() - Yeni bir ReflectionMethod nesnesi oluşturur
  • Kurucular ve Yıkıcılar

ReflectionParameter::__clone
ReflectionParameter::export
ReflectionParameter


Sınıfı ihraç eder

ReflectionParameter::__construct
ReflectionParameter::getClass
ReflectionParameter
PHP Manual

ReflectionParameter::export

(PHP 5, PHP 7)

ReflectionParameter::export — Sınıfı ihraç eder

Açıklama

public static string ReflectionParameter::export ( string $işlev , string $değiştirge [, bool $ihracet ] )

Sınıfı ihraç eder.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

işlev

İşlev ismi.

değiştirge

Değiştirge ismi.

ihracet

TRUE belirtilirse yansıtmak yerine ihrac eder. FALSE olursa (öntanımlıdır) tersini yapar.

Dönen Değerler

Bir dizge.

Ayrıca Bakınız

  • ReflectionParameter::__toString() - Dizgesel tepkiyi görselleştirir

ReflectionParameter::__construct
ReflectionParameter::getClass
ReflectionParameter


Sınıfı döndürür

ReflectionParameter::export
ReflectionParameter::getDeclaringClass
ReflectionParameter
PHP Manual

ReflectionParameter::getClass

(PHP 5, PHP 7)

ReflectionParameter::getClass — Sınıfı döndürür

Açıklama

public ReflectionClass ReflectionParameter::getClass ( void )

Sınıfı döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Bir ReflectionClass nesnesi.

Ayrıca Bakınız

  • ReflectionParameter::getDeclaringClass() - Bildiren sınıfı döndürür

ReflectionParameter::export
ReflectionParameter::getDeclaringClass
ReflectionParameter


Bildiren sınıfı döndürür

ReflectionParameter::getClass
ReflectionParameter::getDeclaringFunction
ReflectionParameter
PHP Manual

ReflectionParameter::getDeclaringClass

(PHP 5, PHP 7)

ReflectionParameter::getDeclaringClass — Bildiren sınıfı döndürür

Açıklama

public ReflectionClass ReflectionParameter::getDeclaringClass ( void )

Bildiren sınıfı döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Bir ReflectionClass nesnesi.

Ayrıca Bakınız

  • ReflectionParameter::getClass() - Sınıfı döndürür

ReflectionParameter::getClass
ReflectionParameter::getDeclaringFunction
ReflectionParameter


Bildiren işlevi döndürür

ReflectionParameter::getDeclaringClass
ReflectionParameter::getDefaultValue
ReflectionParameter
PHP Manual

ReflectionParameter::getDeclaringFunction

(PHP 5 >= 5.2.3, PHP 7)

ReflectionParameter::getDeclaringFunction — Bildiren işlevi döndürür

Açıklama

public ReflectionFunction ReflectionParameter::getDeclaringFunction ( void )

Bildiren işlevi döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Bir ReflectionFunction nesnesi.

Ayrıca Bakınız

  • ReflectionParameter::getDeclaringClass() - Bildiren sınıfı döndürür

ReflectionParameter::getDeclaringClass
ReflectionParameter::getDefaultValue
ReflectionParameter


Değiştirgenin öntanımlı değerini döndürür

ReflectionParameter::getDeclaringFunction
ReflectionParameter::getDefaultValueConstantName
ReflectionParameter
PHP Manual

ReflectionParameter::getDefaultValue

(PHP 5 >= 5.0.3, PHP 7)

ReflectionParameter::getDefaultValue — Değiştirgenin öntanımlı değerini döndürür

Açıklama

public mixed ReflectionParameter::getDefaultValue ( void )

Değiştirgenin öntanımlı değerini döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Değiştirgenin öntanımlı değeri.

Ayrıca Bakınız

  • ReflectionParameter::isOptional() - Değiştirge seçimlik mi diye bakar
  • ReflectionParameter::isPassedByReference() - Değiştirge gönderimli aktarılabilir mi diye bakar

ReflectionParameter::getDeclaringFunction
ReflectionParameter::getDefaultValueConstantName
ReflectionParameter


Returns the default value's constant name if default value is constant or null

ReflectionParameter::getDefaultValue
ReflectionParameter::getName
ReflectionParameter
PHP Manual

ReflectionParameter::getDefaultValueConstantName

(PHP 5 >= 5.4.6, PHP 7)

ReflectionParameter::getDefaultValueConstantName — Returns the default value's constant name if default value is constant or null

Açıklama

public string ReflectionParameter::getDefaultValueConstantName ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns string on success or NULL on failure.

ReflectionParameter::getDefaultValue
ReflectionParameter::getName
ReflectionParameter


Değiştirgenin ismini döndürür

ReflectionParameter::getDefaultValueConstantName
ReflectionParameter::getPosition
ReflectionParameter
PHP Manual

ReflectionParameter::getName

(PHP 5, PHP 7)

ReflectionParameter::getName — Değiştirgenin ismini döndürür

Açıklama

public string ReflectionParameter::getName ( void )

Değiştirgenin ismini döndürür.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yansıtılan değiştirgenin ismi.

Ayrıca Bakınız

  • ReflectionParameter::getDefaultValue() - Değiştirgenin öntanımlı değerini döndürür

ReflectionParameter::getDefaultValueConstantName
ReflectionParameter::getPosition
ReflectionParameter


Değiştirgenin konumunu döndürür

ReflectionParameter::getName
ReflectionParameter::getType
ReflectionParameter
PHP Manual

ReflectionParameter::getPosition

(PHP 5 >= 5.2.3, PHP 7)

ReflectionParameter::getPosition — Değiştirgenin konumunu döndürür

Açıklama

public int ReflectionParameter::getPosition ( void )

Değiştirgenin konumunu döndürür.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Değiştirgenin konumu; soldan sağa sayılır, ilk değiştirgenin konumu 0'dır.

Ayrıca Bakınız

  • ReflectionParameter::getName() - Değiştirgenin ismini döndürür

ReflectionParameter::getName
ReflectionParameter::getType
ReflectionParameter


Gets a parameter's type

ReflectionParameter::getPosition
ReflectionParameter::hasType
ReflectionParameter
PHP Manual

ReflectionParameter::getType

(PHP 7)

ReflectionParameter::getType — Gets a parameter's type

Açıklama

public ReflectionType ReflectionParameter::getType ( void )

Gets the associated type of a parameter.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a ReflectionType object if a parameter type is specified, NULL otherwise.

Örnekler

Örnek 1 ReflectionParameter::getType() example

<?php
function someFunction(int $param, $param2) {}

$reflectionFunc = new ReflectionFunction('someFunction');
$reflectionParams = $reflectionFunc->getParameters();
$reflectionType1 = $reflectionParams[0]->getType();
$reflectionType2 = $reflectionParams[1]->getType();

echo $reflectionType1;
var_dump($reflectionType2);

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int
null

Ayrıca Bakınız

  • ReflectionParameter::hasType() - Checks if parameter has a type
  • ReflectionType::__toString()

ReflectionParameter::getPosition
ReflectionParameter::hasType
ReflectionParameter


Checks if parameter has a type

ReflectionParameter::getType
ReflectionParameter::isArray
ReflectionParameter
PHP Manual

ReflectionParameter::hasType

(PHP 7)

ReflectionParameter::hasType — Checks if parameter has a type

Açıklama

public bool ReflectionParameter::hasType ( void )

Checks if the parameter has a type associated with it.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

TRUE if a type is specified, FALSE otherwise.

Örnekler

Örnek 1 ReflectionParameter::hasType() example

<?php
function someFunction(string $param, $param2 = null) {}

$reflectionFunc = new ReflectionFunction('someFunction');
$reflectionParams = $reflectionFunc->getParameters();

var_dump($reflectionParams[0]->hasType());
var_dump($reflectionParams[1]->hasType());

Yukarıdaki örnek şuna benzer bir çıktı üretir:

bool(true)
bool(false)

Ayrıca Bakınız

  • ReflectionParameter::getType() - Gets a parameter's type

ReflectionParameter::getType
ReflectionParameter::isArray
ReflectionParameter


Değiştirge değeri bir dizi mi olacak diye bakar

ReflectionParameter::hasType
ReflectionParameter::isCallable
ReflectionParameter
PHP Manual

ReflectionParameter::isArray

(PHP 5 >= 5.1.0, PHP 7)

ReflectionParameter::isArray — Değiştirge değeri bir dizi mi olacak diye bakar

Açıklama

public bool ReflectionParameter::isArray ( void )

Değiştirge değeri bir dizi olacaksa TRUE döner.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Değiştirge değeri bir dizi olacaksa TRUE yoksa FALSE.

Ayrıca Bakınız

  • ReflectionParameter::isOptional() - Değiştirge seçimlik mi diye bakar

ReflectionParameter::hasType
ReflectionParameter::isCallable
ReflectionParameter


Returns whether parameter MUST be callable

ReflectionParameter::isArray
ReflectionParameter::isDefaultValueAvailable
ReflectionParameter
PHP Manual

ReflectionParameter::isCallable

(PHP 5 >= 5.4.0, PHP 7)

ReflectionParameter::isCallable — Returns whether parameter MUST be callable

Açıklama

public bool ReflectionParameter::isCallable ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the parameter is callable, FALSE if it is not or NULL on failure.

ReflectionParameter::isArray
ReflectionParameter::isDefaultValueAvailable
ReflectionParameter


Öntanımlı bir değerin kullanılabilir olup olmadığına bakar

ReflectionParameter::isCallable
ReflectionParameter::isDefaultValueConstant
ReflectionParameter
PHP Manual

ReflectionParameter::isDefaultValueAvailable

(PHP 5 >= 5.0.3, PHP 7)

ReflectionParameter::isDefaultValueAvailable — Öntanımlı bir değerin kullanılabilir olup olmadığına bakar

Açıklama

public bool ReflectionParameter::isDefaultValueAvailable ( void )

Öntanımlı bir değerin kullanılabilir olup olmadığına bakar.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Öntanımlı değer kullanılabiliyorsa TRUE yoksa FALSE.

Ayrıca Bakınız

  • ReflectionParameter::getDefaultValue() - Değiştirgenin öntanımlı değerini döndürür
  • ReflectionParameter::getName() - Değiştirgenin ismini döndürür

ReflectionParameter::isCallable
ReflectionParameter::isDefaultValueConstant
ReflectionParameter


Returns whether the default value of this parameter is constant

ReflectionParameter::isDefaultValueAvailable
ReflectionParameter::isOptional
ReflectionParameter
PHP Manual

ReflectionParameter::isDefaultValueConstant

(PHP 5 >= 5.4.6, PHP 7)

ReflectionParameter::isDefaultValueConstant — Returns whether the default value of this parameter is constant

Açıklama

public bool ReflectionParameter::isDefaultValueConstant ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the default value is constant, FALSE if it is not or NULL on failure.

ReflectionParameter::isDefaultValueAvailable
ReflectionParameter::isOptional
ReflectionParameter


Değiştirge seçimlik mi diye bakar

ReflectionParameter::isDefaultValueConstant
ReflectionParameter::isPassedByReference
ReflectionParameter
PHP Manual

ReflectionParameter::isOptional

(PHP 5 >= 5.0.3, PHP 7)

ReflectionParameter::isOptional — Değiştirge seçimlik mi diye bakar

Açıklama

public bool ReflectionParameter::isOptional ( void )

Değiştirge seçimlikse TRUE döner.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Değiştirge seçimlikse TRUE yoksa FALSE.

Ayrıca Bakınız

  • ReflectionParameter::getName() - Değiştirgenin ismini döndürür

ReflectionParameter::isDefaultValueConstant
ReflectionParameter::isPassedByReference
ReflectionParameter


Değiştirge gönderimli aktarılabilir mi diye bakar

ReflectionParameter::isOptional
ReflectionParameter::isVariadic
ReflectionParameter
PHP Manual

ReflectionParameter::isPassedByReference

(PHP 5, PHP 7)

ReflectionParameter::isPassedByReference — Değiştirge gönderimli aktarılabilir mi diye bakar

Açıklama

public bool ReflectionParameter::isPassedByReference ( void )

Değiştirge gönderimli aktarılabiliyorsa TRUE döner.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Değiştirge gönderimli aktarılabiliyorsa TRUE yoksa FALSE.

Ayrıca Bakınız

  • ReflectionParameter::getName() - Değiştirgenin ismini döndürür

ReflectionParameter::isOptional
ReflectionParameter::isVariadic
ReflectionParameter


Checks if the parameter is variadic

ReflectionParameter::isPassedByReference
ReflectionParameter::__toString
ReflectionParameter
PHP Manual

ReflectionParameter::isVariadic

(PHP 5 >= 5.6.0, PHP 7)

ReflectionParameter::isVariadic — Checks if the parameter is variadic

Açıklama

public bool ReflectionParameter::isVariadic ( void )

Checks if the parameter was declared as a variadic parameter.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns TRUE if the parameter is variadic, otherwise FALSE.

ReflectionParameter::isPassedByReference
ReflectionParameter::__toString
ReflectionParameter


Dizgesel tepkiyi görselleştirir

ReflectionParameter::isVariadic
ReflectionProperty
ReflectionParameter
PHP Manual

ReflectionParameter::__toString

(PHP 5, PHP 7)

ReflectionParameter::__toString — Dizgesel tepkiyi görselleştirir

Açıklama

public string ReflectionParameter::__toString ( void )

Dizgesel tepkiyi görselleştirir.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Bir dizge.

Ayrıca Bakınız

  • ReflectionParameter::export() - Sınıfı ihraç eder
  • __toString

ReflectionParameter::isVariadic
ReflectionProperty
ReflectionParameter


ReflectionProperty Sınıfı

(PHP 5, PHP 7)

Giriş

ReflectionProperty sınıfı bir sınıfın özellikleri hakkında bilgi edinilmesini sağlar.

Sınıf Sözdizimi

ReflectionProperty implements Reflector {
/* Sabitler */
const integer IS_STATIC = 1 ;
const integer IS_PUBLIC = 256 ;
const integer IS_PROTECTED = 512 ;
const integer IS_PRIVATE = 1024 ;
/* Özellikler */
public $name ;
public $class ;
/* Yöntemler */
final private void __clone ( void )
__construct ( mixed $sınıf , string $isim )
public static string export ( mixed $sınıf , string $isim [, bool $ihracet ] )
public ReflectionClass getDeclaringClass ( void )
public string getDocComment ( void )
public int getModifiers ( void )
public string getName ( void )
public mixed getValue ([ string $özellik ] )
public bool isDefault ( void )
public bool isPrivate ( void )
public bool isProtected ( void )
public bool isPublic ( void )
public bool isStatic ( void )
public void setAccessible ( bool $erişilebilir )
public void setValue ( object $nesne , mixed $değer )
public string __toString ( void )
}

Özellikler

name

Özelliğin ismi. Salt-okunur olup, bir yazma çabası ReflectionException istisnasına yol açar.

class

Özelliği tanımlayan sınıfın ismi. Salt-okunur olup, bir yazma çabası ReflectionException istisnasına yol açar.

Öntanımlı Sabitler

ReflectionProperty Değiştiricileri

ReflectionProperty::IS_STATIC

Özelliğin static olduğunu belirtir.

ReflectionProperty::IS_PUBLIC

Özelliğin public olduğunu belirtir.

ReflectionProperty::IS_PROTECTED

Özelliğin protected olduğunu belirtir.

ReflectionProperty::IS_PRIVATE

Özelliğin private olduğunu belirtir.

İçindekiler

  • ReflectionProperty::__clone — Özelliği kopyalar
  • ReflectionProperty::__construct — Bir ReflectionProperty nesnesi oluşturur
  • ReflectionProperty::export — Özelliği ihraç eder
  • ReflectionProperty::getDeclaringClass — Bildiren sınıfı döndürür
  • ReflectionProperty::getDocComment — Bilgilendirici açıklamaları döndürür
  • ReflectionProperty::getModifiers — Değiştirici sayısını döndürür
  • ReflectionProperty::getName — Özelliğin ismini döndürür
  • ReflectionProperty::getValue — Özelliğin değerini döndürür
  • ReflectionProperty::isDefault — Öntanımlı değer mi atanmış diye bakar
  • ReflectionProperty::isPrivate — Özellik private olarak mı bildirilmiş diye bakar
  • ReflectionProperty::isProtected — Özellik protected olarak mı bildirilmiş diye bakar
  • ReflectionProperty::isPublic — Özellik public olarak mı bildirilmiş diye bakar
  • ReflectionProperty::isStatic — Özellik duruk mu diye bakar
  • ReflectionProperty::setAccessible — Özelliği erişilebilir kılar
  • ReflectionProperty::setValue — Özelliğe değer atar
  • ReflectionProperty::__toString — Dizgesel tepkiyi görselleştirir
ReflectionParameter::__toString
ReflectionProperty::__clone
Reflection


Özelliği kopyalar

ReflectionProperty
ReflectionProperty::__construct
ReflectionProperty
PHP Manual

ReflectionProperty::__clone

(PHP 5, PHP 7)

ReflectionProperty::__clone — Özelliği kopyalar

Açıklama

final private void ReflectionProperty::__clone ( void )

Özelliği kopyalar.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Ayrıca Bakınız

  • ReflectionProperty::export() - Özelliği ihraç eder
  • Nesne Kopyalama

ReflectionProperty
ReflectionProperty::__construct
ReflectionProperty


Bir ReflectionProperty nesnesi oluşturur

ReflectionProperty::__clone
ReflectionProperty::export
ReflectionProperty
PHP Manual

ReflectionProperty::__construct

(PHP 5, PHP 7)

ReflectionProperty::__construct — Bir ReflectionProperty nesnesi oluşturur

Açıklama

ReflectionProperty::__construct ( mixed $sınıf , string $isim )

Bir ReflectionProperty nesnesi oluşturur.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

sınıf

Özelliği içeren sınıfın ismi.

isim

Yansıtılacak özelliğin ismi.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

Private veya protected sınıf özelliklerinin değerlerini değiştirme veya döndürme girişimleri bir istisna oluşmasına sebep olur.

Örnekler

Örnek 1 - ReflectionProperty::__construct() örneği

<?php
class Dizge
{
    public $uzunluk  = 5;
}

// ReflectionProperty sınıfının bir örneğini oluşturalım
$prop = new ReflectionProperty('Dizge', 'uzunluk');

// Print out basic information
printf(
    "===> %s%s%s%s '%s' özelliği %s olup\n" .
    "    %s değiştiriciye sahiptir.\n",
        $prop->isPublic() ? ' public' : '',
        $prop->isPrivate() ? ' private' : '',
        $prop->isProtected() ? ' protected' : '',
        $prop->isStatic() ? ' static' : '',
        $prop->getName(),
        $prop->isDefault() ? 'derleme sırasında bildirilmiş' :
                             'çalışma anında oluşturulmuş',
        var_export(Reflection::getModifierNames($prop->getModifiers()), 1)
);

// Dizge sınıfının bir örneğini oluşturalım
$nesne= new Dizge();

// Mevcut değeri öğrenelim
printf("---> Değeri: ");
var_dump($prop->getValue($nesne));

// Değeri değiştirelim
$prop->setValue($nesne, 10);
printf("---> Yeni değer olarak 10 atandıktan sonra yeni değer: ");
var_dump($prop->getValue($nesne));

// Nesneyi dökümü
var_dump($nesne);
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

===>  public 'uzunluk' özelliği derleme sırasında bildirilmiş olup
    array (
  0 => 'public',
) değiştiriciye sahiptir.
---> Değeri: int(5)
---> Yeni değer olarak 10 atandıktan sonra yeni değer: int(10)
object(Dizge)#2 (1) {
  ["uzunluk"]=>
  int(10)
}

Örnek 2 - ReflectionProperty sınıfından private ve protected özelliklerin değerlerini öğrenmek

<?php

class Foo {
    public $x = 1;
    protected $y = 2;
    private $z = 3;
}

$obj = new Foo;

$prop = new ReflectionProperty('Foo', 'y');
$prop->setAccessible(true); /* PHP 5.3.0'dan itibaren */
var_dump($prop->getValue($obj)); // int(2)

$prop = new ReflectionProperty('Foo', 'z');
$prop->setAccessible(true); /* PHP 5.3.0'dan itibaren */
var_dump($prop->getValue($obj)); // int(2)

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(2)
int(3)

Ayrıca Bakınız

  • ReflectionProperty::getName() - Özelliğin ismini döndürür
  • Kurucular ve Yıkıcılar

ReflectionProperty::__clone
ReflectionProperty::export
ReflectionProperty


Özelliği ihraç eder

ReflectionProperty::__construct
ReflectionProperty::getDeclaringClass
ReflectionProperty
PHP Manual

ReflectionProperty::export

(PHP 5, PHP 7)

ReflectionProperty::export — Özelliği ihraç eder

Açıklama

public static string ReflectionProperty::export ( mixed $sınıf , string $isim [, bool $ihracet ] )

Yansıtılan özelliği ihraç eder.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

sınıf

İhraç edilecek Reflection nesnesi.

isim

Özelliğin ismi.

ihracet

TRUE belirtilirse yansıtmak yerine ihrac eder. FALSE olursa (öntanımlıdır) tersini yapar.

Dönen Değerler

Ayrıca Bakınız

  • ReflectionProperty::__toString() - Dizgesel tepkiyi görselleştirir

ReflectionProperty::__construct
ReflectionProperty::getDeclaringClass
ReflectionProperty


Bildiren sınıfı döndürür

ReflectionProperty::export
ReflectionProperty::getDocComment
ReflectionProperty
PHP Manual

ReflectionProperty::getDeclaringClass

(PHP 5, PHP 7)

ReflectionProperty::getDeclaringClass — Bildiren sınıfı döndürür

Açıklama

public ReflectionClass ReflectionProperty::getDeclaringClass ( void )

Bildiren sınıfı döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Bir ReflectionClass nesnesi.

Ayrıca Bakınız

  • ReflectionProperty::getName() - Özelliğin ismini döndürür

ReflectionProperty::export
ReflectionProperty::getDocComment
ReflectionProperty


Bilgilendirici açıklamaları döndürür

ReflectionProperty::getDeclaringClass
ReflectionProperty::getModifiers
ReflectionProperty
PHP Manual

ReflectionProperty::getDocComment

(PHP 5 >= 5.1.0, PHP 7)

ReflectionProperty::getDocComment — Bilgilendirici açıklamaları döndürür

Açıklama

public string ReflectionProperty::getDocComment ( void )

Bilgilendirici açıklamaları döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Bir dizge.

Ayrıca Bakınız

  • ReflectionProperty::export() - Özelliği ihraç eder

ReflectionProperty::getDeclaringClass
ReflectionProperty::getModifiers
ReflectionProperty


Değiştirici sayısını döndürür

ReflectionProperty::getDocComment
ReflectionProperty::getName
ReflectionProperty
PHP Manual

ReflectionProperty::getModifiers

(PHP 5, PHP 7)

ReflectionProperty::getModifiers — Değiştirici sayısını döndürür

Açıklama

public int ReflectionProperty::getModifiers ( void )

Değiştirici sayısını döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Değiştirici sayısı.

Ayrıca Bakınız

  • ReflectionProperty::isPrivate() - Özellik private olarak mı bildirilmiş diye bakar
  • Reflection::getModifierNames() - Değiştirici isimlerini döndürür

ReflectionProperty::getDocComment
ReflectionProperty::getName
ReflectionProperty


Özelliğin ismini döndürür

ReflectionProperty::getModifiers
ReflectionProperty::getValue
ReflectionProperty
PHP Manual

ReflectionProperty::getName

(PHP 5, PHP 7)

ReflectionProperty::getName — Özelliğin ismini döndürür

Açıklama

public string ReflectionProperty::getName ( void )

Özelliğin ismini döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Yansıtılan özelliğin ismi.

Ayrıca Bakınız

  • ReflectionProperty::getValue() - Özelliğin değerini döndürür

ReflectionProperty::getModifiers
ReflectionProperty::getValue
ReflectionProperty


Özelliğin değerini döndürür

ReflectionProperty::getName
ReflectionProperty::isDefault
ReflectionProperty
PHP Manual

ReflectionProperty::getValue

(PHP 5, PHP 7)

ReflectionProperty::getValue — Özelliğin değerini döndürür

Açıklama

public mixed ReflectionProperty::getValue ([ string $özellik ] )

Özelliğin değerini döndürür.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

özellik

Yansıtılan nesne.

Dönen Değerler

Özelliğin değeri.

Ayrıca Bakınız

  • ReflectionProperty::getName() - Özelliğin ismini döndürür
  • ReflectionProperty::setValue() - Özelliğe değer atar

ReflectionProperty::getName
ReflectionProperty::isDefault
ReflectionProperty


Öntanımlı değer mi atanmış diye bakar

ReflectionProperty::getValue
ReflectionProperty::isPrivate
ReflectionProperty
PHP Manual

ReflectionProperty::isDefault

(PHP 5, PHP 7)

ReflectionProperty::isDefault — Öntanımlı değer mi atanmış diye bakar

Açıklama

public bool ReflectionProperty::isDefault ( void )

Öntanımlı değer atanmışsa TRUE döner.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Özellik derleme sırasında bildirildiği gibiyse TRUE, çalışma anında oluşturulmuşsa FALSE döner.

Ayrıca Bakınız

  • ReflectionProperty::getValue() - Özelliğin değerini döndürür

ReflectionProperty::getValue
ReflectionProperty::isPrivate
ReflectionProperty


Özellik private olarak mı bildirilmiş diye bakar

ReflectionProperty::isDefault
ReflectionProperty::isProtected
ReflectionProperty
PHP Manual

ReflectionProperty::isPrivate

(PHP 5, PHP 7)

ReflectionProperty::isPrivate — Özellik private olarak mı bildirilmiş diye bakar

Açıklama

public bool ReflectionProperty::isPrivate ( void )

Özellik private olarak bildirilmişse TRUE döner.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Özellik private olarak bildirilmişse TRUE yoksa FALSE.

Ayrıca Bakınız

  • ReflectionProperty::isPublic() - Özellik public olarak mı bildirilmiş diye bakar

ReflectionProperty::isDefault
ReflectionProperty::isProtected
ReflectionProperty


Özellik protected olarak mı bildirilmiş diye bakar

ReflectionProperty::isPrivate
ReflectionProperty::isPublic
ReflectionProperty
PHP Manual

ReflectionProperty::isProtected

(PHP 5, PHP 7)

ReflectionProperty::isProtected — Özellik protected olarak mı bildirilmiş diye bakar

Açıklama

public bool ReflectionProperty::isProtected ( void )

Özellik protected olarak bildirilmişse TRUE döner.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Özellik protected olarak bildirilmişse TRUE yoksa FALSE.

Ayrıca Bakınız

  • ReflectionProperty::isPrivate() - Özellik private olarak mı bildirilmiş diye bakar

ReflectionProperty::isPrivate
ReflectionProperty::isPublic
ReflectionProperty


Özellik public olarak mı bildirilmiş diye bakar

ReflectionProperty::isProtected
ReflectionProperty::isStatic
ReflectionProperty
PHP Manual

ReflectionProperty::isPublic

(PHP 5, PHP 7)

ReflectionProperty::isPublic — Özellik public olarak mı bildirilmiş diye bakar

Açıklama

public bool ReflectionProperty::isPublic ( void )

Özellik public olarak bildirilmişse TRUE döner.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Özellik public olarak bildirilmişse TRUE yoksa FALSE.

Ayrıca Bakınız

  • ReflectionProperty::isPrivate() - Özellik private olarak mı bildirilmiş diye bakar

ReflectionProperty::isProtected
ReflectionProperty::isStatic
ReflectionProperty


Özellik duruk mu diye bakar

ReflectionProperty::isPublic
ReflectionProperty::setAccessible
ReflectionProperty
PHP Manual

ReflectionProperty::isStatic

(PHP 5, PHP 7)

ReflectionProperty::isStatic — Özellik duruk mu diye bakar

Açıklama

public bool ReflectionProperty::isStatic ( void )

Özellik duruk ise TRUE döner.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Özellik duruk ise TRUE yoksa FALSE.

Ayrıca Bakınız

  • ReflectionProperty::isPrivate() - Özellik private olarak mı bildirilmiş diye bakar

ReflectionProperty::isPublic
ReflectionProperty::setAccessible
ReflectionProperty


Özelliği erişilebilir kılar

ReflectionProperty::isStatic
ReflectionProperty::setValue
ReflectionProperty
PHP Manual

ReflectionProperty::setAccessible

(PHP 5 >= 5.3.0, PHP 7)

ReflectionProperty::setAccessible — Özelliği erişilebilir kılar

Açıklama

public void ReflectionProperty::setAccessible ( bool $erişilebilir )

Özelliği erişilebilir kılar. Örneğin, protected ve private özelliklerin erişilebilir olması sağlanabilir.

Değiştirgeler

erişilebilir

Özellik erişilebilir olacaksa TRUE yoksa FALSE belirtilir.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • ReflectionProperty::isPrivate() - Özellik private olarak mı bildirilmiş diye bakar
  • ReflectionProperty::isProtected() - Özellik protected olarak mı bildirilmiş diye bakar

ReflectionProperty::isStatic
ReflectionProperty::setValue
ReflectionProperty


Özelliğe değer atar

ReflectionProperty::setAccessible
ReflectionProperty::__toString
ReflectionProperty
PHP Manual

ReflectionProperty::setValue

(PHP 5, PHP 7)

ReflectionProperty::setValue — Özelliğe değer atar

Açıklama

public void ReflectionProperty::setValue ( object $nesne , mixed $değer )

Bir özelliğin değerini değiştirir.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

nesne

Bir ReflectionProperty nesnesi.

değer

Yeni değer.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • ReflectionProperty::getValue() - Özelliğin değerini döndürür

ReflectionProperty::setAccessible
ReflectionProperty::__toString
ReflectionProperty


Dizgesel tepkiyi görselleştirir

ReflectionProperty::setValue
Reflector
ReflectionProperty
PHP Manual

ReflectionProperty::__toString

(PHP 5, PHP 7)

ReflectionProperty::__toString — Dizgesel tepkiyi görselleştirir

Açıklama

public string ReflectionProperty::__toString ( void )

Dizgesel tepkiyi görselleştirir.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Bir dizge.

Ayrıca Bakınız

  • ReflectionProperty::()
  • __toString

ReflectionProperty::setValue
Reflector
ReflectionProperty


Reflector Arayüzü

(PHP 5, PHP 7)

Giriş

Reflector arayüzü, tüm ihraç edilebilir yansıtma sınıflarınca gerçeklenmiş bir arayüzdür.

Sınıf Sözdizimi

Reflector {
/* Yöntemler */
abstract public static string export ( void )
abstract public string __toString ( void )
}

İçindekiler

  • Reflector::export — Sınıfı ihraç eder
  • Reflector::__toString — Dizgesel tepkiyi görselleştirir
ReflectionProperty::__toString
Reflector::export
Reflection


Sınıfı ihraç eder

Reflector
Reflector::__toString
Reflector
PHP Manual

Reflector::export

(PHP 5, PHP 7)

Reflector::export — Sınıfı ihraç eder

Açıklama

abstract public static string Reflector::export ( void )

Sınıfı ihraç eder.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Ayrıca Bakınız

  • Reflector::__toString() - Dizgesel tepkiyi görselleştirir

Reflector
Reflector::__toString
Reflector


Dizgesel tepkiyi görselleştirir

Reflector::export
Değişken İşlemleri
Reflector
PHP Manual

Reflector::__toString

(PHP 5, PHP 7)

Reflector::__toString — Dizgesel tepkiyi görselleştirir

Açıklama

abstract public string Reflector::__toString ( void )

Dizgesel tepkiyi görselleştirir.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Bir dizge.

Ayrıca Bakınız

  • ReflectionProperty::export() - Özelliği ihraç eder
  • __toString

Reflector::export
Değişken İşlemleri
Reflector


Değişken İşlemleri

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Değişkenlerle ilgili işlevler
    • boolval — Get the boolean value of a variable
    • debug_zval_dump — Dahili bir zend değerinin dizgesel gösterimini çıktıya dökümler
    • doubleval — floatval işlevinin takma ismidir
    • empty — Bir değişkenin boş olup olmadığını saptar
    • floatval — Bir değişkenin gerçek sayı değerini döndürür
    • get_defined_vars — Tüm tanımlı değişkenleri içeren bir dizi döndürür
    • get_resource_type — Özkaynak türünü döndürür
    • gettype — Bir değişkenin türünü döndürür
    • import_request_variables — GET/POST/Çerez değişkenlerini küresel etki alanına dahil eder
    • intval — Bir değişkenin tamsayı değerini döndürür
    • is_array — Değişkenin bir dizi içerip içermediğine bakar
    • is_bool — Değişken boolean türünde mi diye bakar
    • is_callable — Bir değişkenin içeriğinin bir işlev olarak çağrılabilirliğini doğrular
    • is_double — is_float işlevinin takma adıdır
    • is_float — Değişken float türünde mi diye bakar
    • is_int — Değişken bir tamsayı mı diye bakar
    • is_integer — is_int işlevinin takma adıdır
    • is_long — is_int işlevinin takma adıdır
    • is_null — Bir değişkenin değerinin NULL olup olmadığına bakar
    • is_numeric — Değişken bir sayı veya bir sayısal dizge mi diye bakar
    • is_object — Değişken object türünde mi diye bakar
    • is_real — is_float işlevinin takma adıdır
    • is_resource — Değişken resource türünde mi diye bakar
    • is_scalar — Bir değişken sayıl mı diye bakar
    • is_string — Değişken string türünde mi diye bakar
    • isset — Değişken tanımlı mı diye bakar
    • print_r — Bir değişkenin insanlarca okunabilecek gösterimini basar
    • serialize — Bir değerin saklanabilir bir gösterimini üretir
    • settype — Bir değişkenin türünü belirler
    • strval — Bir değişkenin dizgesel değerini döndürür
    • unserialize — Bir PHP değerini saklanmış gösteriminden oluşturur
    • unset — Belirtilen değişkeni tanımsız yapar
    • var_dump — Bir değişkenle ilgili bilgiyi dökümler
    • var_export — Bir değişkenin çözümlenebilir dizge gösterimini döndürür veya çıktılar
Reflector::__toString
Giriş
Değişkenler ve Veri Türleriyle İlgili Eklentiler


Giriş

Değişkenlerin nasıl davranışlar gösterdikleriyle ilgili bilgileri Değişkenler bölümünde bulabilirsiniz (Dil Başvuru Kılavuzunda).

Değişken İşlemleri
Yapılandırma/Kurulum
Değişken İşlemleri


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Değişken İşlemleri


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Değişkenleri Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişebilir | Günce kaydı
unserialize_callback_func | NULL | PHP_INI_ALL | PHP 4.2.0'dan beri mevcut.
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

unserialize_callback_func string

unserialize() tanımsız bir sınıfı kullanmaya çalışırsa belirtilen geriçağırım işlevi çağrılır. Belirtilen işlev tanımlanmamışsa veya işlev eksik sınıfı içermiyor veya gerçeklemiyorsa bir uyarı görüntülenir.

Ayrıca bakınız: unserialize() ve Özdevinimli Nesne Yükleme.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
Değişkenlerle ilgili işlevler
Değişken İşlemleri


Değişkenlerle ilgili işlevler

İçindekiler

  • boolval — Get the boolean value of a variable
  • debug_zval_dump — Dahili bir zend değerinin dizgesel gösterimini çıktıya dökümler
  • doubleval — floatval işlevinin takma ismidir
  • empty — Bir değişkenin boş olup olmadığını saptar
  • floatval — Bir değişkenin gerçek sayı değerini döndürür
  • get_defined_vars — Tüm tanımlı değişkenleri içeren bir dizi döndürür
  • get_resource_type — Özkaynak türünü döndürür
  • gettype — Bir değişkenin türünü döndürür
  • import_request_variables — GET/POST/Çerez değişkenlerini küresel etki alanına dahil eder
  • intval — Bir değişkenin tamsayı değerini döndürür
  • is_array — Değişkenin bir dizi içerip içermediğine bakar
  • is_bool — Değişken boolean türünde mi diye bakar
  • is_callable — Bir değişkenin içeriğinin bir işlev olarak çağrılabilirliğini doğrular
  • is_double — is_float işlevinin takma adıdır
  • is_float — Değişken float türünde mi diye bakar
  • is_int — Değişken bir tamsayı mı diye bakar
  • is_integer — is_int işlevinin takma adıdır
  • is_long — is_int işlevinin takma adıdır
  • is_null — Bir değişkenin değerinin NULL olup olmadığına bakar
  • is_numeric — Değişken bir sayı veya bir sayısal dizge mi diye bakar
  • is_object — Değişken object türünde mi diye bakar
  • is_real — is_float işlevinin takma adıdır
  • is_resource — Değişken resource türünde mi diye bakar
  • is_scalar — Bir değişken sayıl mı diye bakar
  • is_string — Değişken string türünde mi diye bakar
  • isset — Değişken tanımlı mı diye bakar
  • print_r — Bir değişkenin insanlarca okunabilecek gösterimini basar
  • serialize — Bir değerin saklanabilir bir gösterimini üretir
  • settype — Bir değişkenin türünü belirler
  • strval — Bir değişkenin dizgesel değerini döndürür
  • unserialize — Bir PHP değerini saklanmış gösteriminden oluşturur
  • unset — Belirtilen değişkeni tanımsız yapar
  • var_dump — Bir değişkenle ilgili bilgiyi dökümler
  • var_export — Bir değişkenin çözümlenebilir dizge gösterimini döndürür veya çıktılar
Öntanımlı Sabitler
boolval
Değişken İşlemleri


Get the boolean value of a variable

Değişkenlerle ilgili işlevler
debug_zval_dump
Değişkenlerle ilgili işlevler
PHP Manual

boolval

(PHP 5 >= 5.5.0, PHP 7)

boolval — Get the boolean value of a variable

Açıklama

boolean boolval ( mixed $var )

Returns the boolean value of var.

Değiştirgeler

var

The scalar value being converted to a boolean.

Dönen Değerler

The boolean value of var.

Örnekler

Örnek 1 boolval() examples

<?php
echo '0:        '.(boolval(0) ? 'true' : 'false')."\n";
echo '42:       '.(boolval(42) ? 'true' : 'false')."\n";
echo '0.0:      '.(boolval(0.0) ? 'true' : 'false')."\n";
echo '4.2:      '.(boolval(4.2) ? 'true' : 'false')."\n";
echo '"":       '.(boolval("") ? 'true' : 'false')."\n";
echo '"string": '.(boolval("string") ? 'true' : 'false')."\n";
echo '"0":      '.(boolval("0") ? 'true' : 'false')."\n";
echo '"1":      '.(boolval("1") ? 'true' : 'false')."\n";
echo '[1, 2]:   '.(boolval([1, 2]) ? 'true' : 'false')."\n";
echo '[]:       '.(boolval([]) ? 'true' : 'false')."\n";
echo 'stdClass: '.(boolval(new stdClass) ? 'true' : 'false')."\n";
?>

Yukarıdaki örneğin çıktısı:

0:        false
42:       true
0.0:      false
4.2:      true
"":       false
"string": true
"0":      false
"1":      true
[1, 2]:   true
[]:       false
stdClass: true

Ayrıca Bakınız

  • floatval() - Bir değişkenin gerçek sayı değerini döndürür
  • intval() - Bir değişkenin tamsayı değerini döndürür
  • strval() - Bir değişkenin dizgesel değerini döndürür
  • settype() - Bir değişkenin türünü belirler
  • is_bool() - Değişken boolean türünde mi diye bakar
  • Type juggling

Değişkenlerle ilgili işlevler
debug_zval_dump
Değişkenlerle ilgili işlevler


Dahili bir zend değerinin dizgesel gösterimini çıktıya dökümler

boolval
doubleval
Değişkenlerle ilgili işlevler
PHP Manual

debug_zval_dump

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

debug_zval_dump — Dahili bir zend değerinin dizgesel gösterimini çıktıya dökümler

Açıklama

void debug_zval_dump ( mixed $değişken )

Dahili bir zend değerinin dizgesel gösterimini çıktıya dökümler.

Değiştirgeler

değişken

İşleme alınacak değişken.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 - debug_zval_dump() örneği

<?php
$var1 = 'Hello World';
$var2 = '';

$var2 =& $var1;

debug_zval_dump(&$var1);
?>

Yukarıdaki örneğin çıktısı:

&string(11) "Hello World" refcount(3)

Bilginize: refcount hakkında

Bu işlevden döndürülen refcount değerinin ne olduğu bazı durumlarda pek açık değildir. Örneğin bir geliştirici yukarıdaki örneğin refcount değerinin 2 olacağını bekleyebilirdi. Üçüncü gönderim aslında debug_zval_dump() çağrılırken oluşur.

Bu davranış, bir değişken debug_zval_dump() işlevine gönderimli aktarılmadığı takdirde daha da karmaşıklaşır. Bunu göstermek için yukardaki örneğin hafifçe değiştirilmiş bir sürümünü ele alalım:

<?php
$var1 = 'Hello World';
$var2 = '';

$var2 =& $var1;

debug_zval_dump($var1); // bu sefer gönderimli aktarmadık
?>

Yukarıdaki örneğin çıktısı:

string(11) "Hello World" refcount(1)

Neden refcount(1)? Çünkü $var1 değişkeni işlev çağrılırken kopyalandı.

Bu işlev, 1 refcount'lu bir değişken değeriyle aktarıldığında işleri daha da karmaşıklaştırır:

<?php
$var1 = 'Hello World';

debug_zval_dump($var1);
?>

Yukarıdaki örneğin çıktısı:

string(11) "Hello World" refcount(2)

Buradaki 2'lik refcount neredeyse kesinlikle apaçık değildir. Özellikle yukarıdaki örnekler göz önüne alınarak. Peki ne oluyor?

Bir değişken tek bir gönderime sahipse (debug_zval_dump() işlevinde bir değiştirge olarak kullanılmadan önce, $var1'de olduğu gibi), PHP motoru, aktarılan gönderim yazılacaksa sadece yazma anında bir kopyasının yapılacağı ikazıyla bunu bir işleve aktarılmış gibi eniyileştirir. Buna "yazma sırasında kopyalama" denir.

Eğer debug_zval_dump() işlevi kendi tek değiştirgesine yazarsa (ki normalde yazmaz) bu durumda (bellekte bu parametre için) bir kopya oluşturulur. O zamana kadar bu değiştirge bir gönderim olarak kalır ve işlev çağrısının etki alanı içinde refcount değeri 2'ye yükseltilir.

Ayrıca Bakınız

  • var_dump() - Bir değişkenle ilgili bilgiyi dökümler
  • debug_backtrace() - Hata izleme raporunu bir dizi olarak üretir
  • Gönderimlerle İlgili Herşey
  • » References Explained (Derick Rethans)

boolval
doubleval
Değişkenlerle ilgili işlevler


floatval işlevinin takma ismidir

debug_zval_dump
empty
Değişkenlerle ilgili işlevler
PHP Manual

doubleval

(PHP 4, PHP 5, PHP 7)

doubleval — floatval() işlevinin takma ismidir

Açıklama

Bu işlev, floatval() işlevinin takma ismidir.

Sürüm Bilgisi

Sürüm: | Açıklama
4.2.0 | doubleval() işlevi floatval() işlevinin takma adı oldu. Daha önce sadece doubleval() vardı.

debug_zval_dump
empty
Değişkenlerle ilgili işlevler


Bir değişkenin boş olup olmadığını saptar

doubleval
floatval
Değişkenlerle ilgili işlevler
PHP Manual

empty

(PHP 4, PHP 5, PHP 7)

empty — Bir değişkenin boş olup olmadığını saptar

Açıklama

bool empty ( mixed $değişken )

Belirtilen değişkenin boş kabul edilip edilmeyeceğine bakar.

Değiştirgeler

değişken

Sınanacak değişken

Bilginize:

empty() işlevi sadece bir çözümleme hatasına yol açmayan değişkenleri sınar. Başka bir deyişle şu satır çalışmaz: empty(trim($isim)).

İşlev, değişken tanımsız olduğunda uyarı üretmemesi dışında (boolean) değişken deyiminin zıddıdır.

Dönen Değerler

Belirtilen değişken boş değilse ve değeri sıfırdan farklıysa FALSE döner.

Aşağıdakiler boş olarak ele alınır:

  • "" (boş bir dizge)
  • 0 (bir tamsayı olarak 0)
  • "0" (bir dizge olarak 0)
  • NULL
  • FALSE
  • array() (boş bir dizi)
  • var $var; (bir sınıf içinde bir değeri olmaksızın bildirilmiş bir değişken)

Sürüm Bilgisi

Sürüm: | Açıklama
PHP 5 | PHP 5'ten beri, özellikleri olmayan nesneler boş sayılmamaktadır.
PHP 4 | PHP 4'ten beri, dizge değeri olarak "0" boş sayılmaktadır.

Örnekler

Örnek 1 - Basit bir empty() / isset() karşılaştırması

<?php
$var = 0;

// $var boş olduğundan sonuç true olur
if (empty($var)) {
    echo '$var ya 0, ya boş ya da tanımsızdır';
}

// $var tanımlı olduğundan sonuç true olur
if (isset($var)) {
    echo '$var boş olsa da tanımlıdır';
}
?>

Notlar

Bilginize: Bu bir işlev değil, dil oluşumu olduğundan değişken işlevler kullanılarak çağrılamaz.

Bilginize:

empty() erişilir olmayan nesne özellikleri kullanıyorsa, bildirimli olduğu taktirde __isset yöntemi çağrılabilir.

Ayrıca Bakınız

  • isset() - Değişken tanımlı mı diye bakar
  • __isset
  • unset() - Belirtilen değişkeni tanımsız yapar
  • array_key_exists() - Belirtilen anahtar veya indis dizide var mı diye bakar
  • count() - Bir dizideki eleman sayısını veya bir nesnedeki özellik sayısını döndürür
  • strlen() - Dizge uzunluğunu döndürür
  • Tür Karşılaştırma Tabloları

doubleval
floatval
Değişkenlerle ilgili işlevler


Bir değişkenin gerçek sayı değerini döndürür

empty
get_defined_vars
Değişkenlerle ilgili işlevler
PHP Manual

floatval

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

floatval — Bir değişkenin gerçek sayı değerini döndürür

Açıklama

float floatval ( mixed $değişken )

Belirtilen değişkenin değerini float türünde döndürür.

Değiştirgeler

değişken

Herhangi bir sayıl değer olabilir. floatval() işlevini nesnelerle kullanamazsınız, aksi takdirde E_NOTICE seviyesinde bir hata çıktılanır ve işlev 1 değeriyle döner.

Dönen Değerler

Belirtilen değişkenin değerini float türünde döndürür. Boş diziler için 0, boş olmayanlar için ise 1 döner.

Örnekler

Örnek 1 - floatval() örneği

<?php
$var = '122.34343The';
$float_value_of_var = floatval($var);
echo $float_value_of_var; // 122.34343
?>

Ayrıca Bakınız

  • intval() - Bir değişkenin tamsayı değerini döndürür
  • strval() - Bir değişkenin dizgesel değerini döndürür
  • settype() - Bir değişkenin türünü belirler
  • Tür Dönüşümü

empty
get_defined_vars
Değişkenlerle ilgili işlevler


Tüm tanımlı değişkenleri içeren bir dizi döndürür

floatval
get_resource_type
Değişkenlerle ilgili işlevler
PHP Manual

get_defined_vars

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

get_defined_vars — Tüm tanımlı değişkenleri içeren bir dizi döndürür

Açıklama

array get_defined_vars ( void )

get_defined_vars() işlevinin çağrıldığı etki alanında geçerli tüm değişkenleri (ortam değişkenleri, sunucu ve kullanıcı tanımlı değişkenler) içeren çok boyutlu bir dizi döner.

Dönen Değerler

Tüm tanımlı değişkenleri içeren çok boyutlu bir dizi.

Örnekler

Örnek 1 - get_defined_vars() örneği

<?php
$b = array(1, 1, 2, 3, 5, 8);

$arr = get_defined_vars();

// $b içeriğini basar
print_r($arr["b"]);

/* PHP yorumlayıcısının yolunu basar (kullanılmışsa, CGI olarak)
 * örn, /usr/local/bin/php */
echo $arr["_"];

// Varsa komut satırı değiştirgelerini basar
print_r($arr["argv"]);

// tüm sunucu değişkenlerini basar
print_r($arr["_SERVER"]);

// Değişkenler dizisinin kullanılabilen tüm anahtarlarını basar
print_r(array_keys(get_defined_vars()));
?>

Sürüm Bilgisi

Sürüm: | Açıklama
5.0.0 | $GLOBALS değişkeni dönen dizi sonuçlarına dahil edildi.

Ayrıca Bakınız

  • isset() - Değişken tanımlı mı diye bakar
  • get_defined_functions() - Tanımlanmış bütün işlevleri içeren bir dizi döndürür
  • get_defined_constants() - Tüm sabitlerin isimlerini ve değerlerini içeren bir ilişkisel dizi döndürür

floatval
get_resource_type
Değişkenlerle ilgili işlevler


Özkaynak türünü döndürür

get_defined_vars
gettype
Değişkenlerle ilgili işlevler
PHP Manual

get_resource_type

(PHP 4 >= 4.0.2, PHP 5, PHP 7)

get_resource_type — Özkaynak türünü döndürür

Açıklama

string get_resource_type ( resource $tanıtıcı )

Bu işlev belirtilen özkaynağın türünü döndürür.

Değiştirgeler

tanıtıcı

Sınanacak özkaynak.

Dönen Değerler

Belirtilen tanıtıcı bir özkaynak ise bu işlev bu özkaynağın türünü belirten bir dizge döndürür. Eğer tür, bu işlev tarafından tanınmıyorsa Unknown dizgesi döner.

tanıtıcı resource türünde değilse işlev FALSE döndürür ve bir hata üretir.

Örnekler

Örnek 1 - get_resource_type() örneği

<?php
// 'mysql link' basar
$c = mysql_connect();
echo get_resource_type($c) . "\n";

// 'file' basar
$fp = fopen("foo", "w");
echo get_resource_type($fp) . "\n";

// 'domxml document' basar
$doc = new_xmldoc("1.0");
echo get_resource_type($doc->doc) . "\n";
?>

get_defined_vars
gettype
Değişkenlerle ilgili işlevler


Bir değişkenin türünü döndürür

get_resource_type
import_request_variables
Değişkenlerle ilgili işlevler
PHP Manual

gettype

(PHP 4, PHP 5, PHP 7)

gettype — Bir değişkenin türünü döndürür

Açıklama

string gettype ( mixed $var )

Belirtilen değişkenin türünü döndürür.

Uyarı

İşlevin döndürdüğü dizge ileride değişebileceğinden işlevden dönen türü asla belli bir türü sınamak için kullanmayın. Dizge karşılaştırması olarak bu işlem ayrıca yavaştır.

Bu amaçla is_* işlevlerini kullanın.

Değiştirgeler

değişken

Sınanacak değişken.

Dönen Değerler

Olası dönüş değerleri:

  • "boolean"
  • "integer"
  • "double" (tarihsel sebeplerle float durumunda "double" döndürülür)
  • "string"
  • "array"
  • "object"
  • "resource"
  • "NULL"
  • "unknown type"

Örnekler

Örnek 1 - gettype() örneği

<?php

$data = array(1, 1., NULL, new stdClass, 'foo');

foreach ($data as $value) {
    echo gettype($value), "\n";
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

integer
double
NULL
object
string

Ayrıca Bakınız

  • settype() - Bir değişkenin türünü belirler
  • get_class() - Bir nesnenin ait olduğu sınıfın ismini döndürür
  • is_array() - Değişkenin bir dizi içerip içermediğine bakar
  • is_bool() - Değişken boolean türünde mi diye bakar
  • is_float() - Değişken float türünde mi diye bakar
  • is_int() - Değişken bir tamsayı mı diye bakar
  • is_null() - Bir değişkenin değerinin NULL olup olmadığına bakar
  • is_numeric() - Değişken bir sayı veya bir sayısal dizge mi diye bakar
  • is_object() - Değişken object türünde mi diye bakar
  • is_resource() - Değişken resource türünde mi diye bakar
  • is_scalar() - Bir değişken sayıl mı diye bakar
  • is_string() - Değişken string türünde mi diye bakar
  • function_exists() - Eğer işlev tanımlanmış ise TRUE döndürür
  • method_exists() - Bir sınıf yöntemi mevcut mu diye bakar

get_resource_type
import_request_variables
Değişkenlerle ilgili işlevler


GET/POST/Çerez değişkenlerini küresel etki alanına dahil eder

gettype
intval
Değişkenlerle ilgili işlevler
PHP Manual

import_request_variables

(PHP 4 >= 4.1.0, PHP 5 < 5.4.0)

import_request_variables — GET/POST/Çerez değişkenlerini küresel etki alanına dahil eder

Açıklama

bool import_request_variables ( string $türler [, string $önek ] )

GET/POST/Çerez değşkenlerini küresel etki alanına dahil eder. register_globals yönergesine 'Off' atadıysanız fakat bazı değişkenleri küresel etki alanında görmek istiyorsanız bu işlev işinize yarayacaktır.

$_SERVER gibi başka değişkenleri de küresel etki alanına dahil etmek isterseniz extract() işlevini kullanabilirsiniz.

Değiştirgeler

türler

türler değiştirgesini kullanarak küresel etki alanına dahil edeceğiniz istek değişkenlerini belirtebilirsiniz. GET, POST ve Cookie için sırayla 'G', 'P' ve 'C' karakterlerini belirtebilirsiniz. Bu karakterlerin büyük veya küçük harf olmasının bir önemi yoktur. POST, karşıya yüklenen dosya bilgisini dahil eder.

Bilginize:

Harflerin veriliş sırası önemlidir. Örneğin, "GP" olarak belirtilirse, aynı isimli POST değişkenleri GET değişkenlerinin üzerine yazar. GPC dışındaki diğer karakterler iptal edilir.

önek

Küresel etki alanına dahil edilen tüm değişken isimlerinin önüne getirilecek dizge. Örneğin, "userid" isimli bir GET değeri varsa ve önek olarak "pref_" belirtmişseniz $pref_userid isimli bir küresel değişkeniniz olur.

Bilginize:

önek değiştirgesi isteğe bağlı olmakla birlikte bir önek belirtmezseniz veya önek olarak boş bir dizge belirtirseniz E_NOTICE seviyesinde bir uyarı alırsınız. Bu, olası bir güvenlik riskidir. Uyarı seviyesinden hataların gösterilmesini öntanımlı hata raporlama seviyesiyle engelleyebilirsiniz.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - import_request_variables() örneği

<?php
// Bu satır, GET ve POST değişkenlerini "rvar_"
// önekiyle küresel etki alanına dahil edecektir
import_request_variables("gp", "rvar_");

echo $rvar_foo;
?>

Ayrıca Bakınız

  • $_REQUEST
  • register_globals
  • Öntanımlı Değişkenler
  • extract() - Bir dizideki değişkenleri simge tablosuna dahil eder

gettype
intval
Değişkenlerle ilgili işlevler


Bir değişkenin tamsayı değerini döndürür

import_request_variables
is_array
Değişkenlerle ilgili işlevler
PHP Manual

intval

(PHP 4, PHP 5, PHP 7)

intval — Bir değişkenin tamsayı değerini döndürür

Açıklama

int intval ( mixed $değişken [, int $taban = 10 ] )

Belirtilen değişkenin taban tabanında tamsayı değerini döndürür (10 tabanı öntanımlıdır). İşlev nesnelerle kullanılamaz, aksi takdirde E_NOTICE seviyesinde bir hata çıktılanır ve işlev 1 döndürür.

Değiştirgeler

değişken

Bir tamsayıya dönüştürülecek bir sayıl değer.

taban

Dönüşülecek sayı tabanı.

Dönen Değerler

Başarısızlık durumunda 0, aksi takdirde belirtilen değerin tamsayı değeriyle döner. Boş diziler ve nesneler 0 döndürür. Boş olmayan diziler ve nesneler ise 1 döndürür.

Azami değer sisteme bağlıdır. 32 bitlik sistemlerde işaretli tamsayılar için azami değerler -2147483648 ve 2147483647'dir. Bu bakımdan, böyle sistemlerde örneğin intval('1000000000000') değeri 2147483647 döndürür. 64 bitlik sistemlerde işaretli tamsayılar için azami değer 9223372036854775807'dir.

Dizgeler için dönecek değer genellikle en soldaki karaktere bağlıysa da çoğunlukla 0 döner. Genel kurallar için integer türüne dönüşüm bölümüne bakınız.

Örnekler

Örnek 1 - intval() örnekleri

Aşağıdaki örnekler 32 bitlik sistemler içindir.

<?php
echo intval(42);                      // 42
echo intval(4.2);                     // 4
echo intval('42');                    // 42
echo intval('+42');                   // 42
echo intval('-42');                   // -42
echo intval(042);                     // 34
echo intval('042');                   // 42
echo intval(1e10);                    // 1410065408
echo intval('1e10');                  // 1
echo intval(0x1A);                    // 26
echo intval(42000000);                // 42000000
echo intval(420000000000000000000);   // 0
echo intval('420000000000000000000'); // 2147483647
echo intval(42, 8);                   // 42
echo intval('42', 8);                 // 34
echo intval(array());                 // 0
echo intval(array('foo', 'bar'));     // 1
?>

Notlar

Bilginize:

Belirtilen değişken bir dizge olmadıkça taban değiştirgesinin bir etkisi yoktur.

Ayrıca Bakınız

  • floatval() - Bir değişkenin gerçek sayı değerini döndürür
  • strval() - Bir değişkenin dizgesel değerini döndürür
  • settype() - Bir değişkenin türünü belirler
  • is_numeric() - Değişken bir sayı veya bir sayısal dizge mi diye bakar
  • Tür Dönüşümü
  • BCMath Keyfi Hassasiyetli Matematik İşlevleri

import_request_variables
is_array
Değişkenlerle ilgili işlevler


Değişkenin bir dizi içerip içermediğine bakar

intval
is_bool
Değişkenlerle ilgili işlevler
PHP Manual

is_array

(PHP 4, PHP 5, PHP 7)

is_array — Değişkenin bir dizi içerip içermediğine bakar

Açıklama

bool is_array ( mixed $değişken )

Belirtilen değişken bir dizi içeriyorsa TRUE döner.

Değiştirgeler

değişken

Sınanacak değişken.

Dönen Değerler

Belirtilen değişken bir dizi içeriyorsa TRUE, aksi takdirde FALSE döner.

Örnekler

Örnek 1 - Değişken içeriğinin bir dizi olup olmadığının sınanması

<?php
$yes = array('bu', 'bir', 'dizidir');

echo is_array($yes) ? 'Dizi' : 'Dizi değil';
echo "\n";

$no = 'bu bir dizgedir';

echo is_array($no) ? 'Dizi' : 'Dizi değil';
?>

Yukarıdaki örneğin çıktısı:

Dizi
Dizi değil

Ayrıca Bakınız

  • is_float() - Değişken float türünde mi diye bakar
  • is_int() - Değişken bir tamsayı mı diye bakar
  • is_string() - Değişken string türünde mi diye bakar
  • is_object() - Değişken object türünde mi diye bakar

intval
is_bool
Değişkenlerle ilgili işlevler


Değişken boolean türünde mi diye bakar

is_array
is_callable
Değişkenlerle ilgili işlevler
PHP Manual

is_bool

(PHP 4, PHP 5, PHP 7)

is_bool — Değişken boolean türünde mi diye bakar

Açıklama

bool is_bool ( mixed $değişken )

Belirtilen değişken boolean türündeyse TRUE döner.

Değiştirgeler

değişken

Sınanacak değişken.

Dönen Değerler

Belirtilen değişken boolean türündeyse TRUE aksi takdirde FALSE döner.

Örnekler

Örnek 1 - is_bool() örnekleri

<?php
$a = false;
$b = 0;

// $a mantıksal türde olduğundan true döner
if (is_bool($a) === true) {
    echo "Evet, bu bir mantıksal değerdir";
}

// $b mantıksal türde olmadığından true dönmez
if (is_bool($b) === false) {
    echo "Hayır, bu bir mantıksal değer değildir";
}
?>

Ayrıca Bakınız

  • is_float() - Değişken float türünde mi diye bakar
  • is_int() - Değişken bir tamsayı mı diye bakar
  • is_string() - Değişken string türünde mi diye bakar
  • is_object() - Değişken object türünde mi diye bakar
  • is_array() - Değişkenin bir dizi içerip içermediğine bakar

is_array
is_callable
Değişkenlerle ilgili işlevler


Bir değişkenin içeriğinin bir işlev olarak çağrılabilirliğini doğrular

is_bool
is_double
Değişkenlerle ilgili işlevler
PHP Manual

is_callable

(PHP 4 >= 4.0.6, PHP 5, PHP 7)

is_callable — Bir değişkenin içeriğinin bir işlev olarak çağrılabilirliğini doğrular

Açıklama

bool is_callable ( callback $işlev [, bool $sözdizimsel = false [, string &$isim ]] )

Belirtilen değişkenin içeriğinin bir işlev olarak çağrılabilirliğini doğrular. işlev değiştirgesinde geçerli bir işlev ismi veya düzgün olarak kodlanmış bir nesne ve işlev ismi içeren bir dizi belirtilebilir.

Değiştirgeler

işlev

Bir işlev ismi veya aşağıdaki gibi bir nesne ve nesne içinde bir yöntem ismi olabilir:

array($BirNesne, 'Yöntemİsmi')

sözdizimsel

TRUE atanırsa işlev değiştirgesinde bir işlev veya yöntem ismi belirtildiği varsayımıyla doğrulama yapılmaya çalışılır. Sadece dizge olmayan veya bir geriçağırım işlevi olarak kullanılabilecek geçerli bir yapıya sahip olmayan bir dizi içeren basit değişkenler reddedilir. Geçerli bir dizinin 2 girdisi olacağı varsayılır; ilki bir nesne veya bir dizge, ikincisi ise bir dizge.

isim

İşlev veya yöntemin çağrılabilir ismi. Aşağıdaki örnekteki "birSınıf::birYöntem" gibi. birSınıf::birYöntem() çağrılabilir bir duruk yöntem olsa da bunun hep böyle olması gerekmez.

Dönen Değerler

Belirtilen işlev bir işlev olarak çağrılabiliyorsa TRUE, aksi takdirde FALSE döner.

Örnekler

Örnek 1 - is_callable() örneği

<?php
//  Bir  değişkenin içeriğinin bir işlev olarak
//  çağrılabilirliğinin sınanması.

//
//  Bir işlev içeren basit bir değişken
//

function bir_işlev()
{
}

$işlevDeğişkeni = 'bir_işlev';

var_dump(is_callable($işlevDeğişkeni, false, $isim));  // bool(true)

echo $isim, "\n";  // bir_işlev

//
//  Bir yöntem içeren bir dizi
//

class birSınıf {

  function birYöntem()
  {
  }

}

$birNesne = new birSınıf();

$yöntemDeğişkeni = array($birNesne, 'birYöntem');

var_dump(is_callable($yöntemDeğişkeni, true, $isim));  //  bool(true)

echo $isim, "\n";  //  birSınıf::birYöntem

?>

Ayrıca Bakınız

  • function_exists() - Eğer işlev tanımlanmış ise TRUE döndürür
  • method_exists() - Bir sınıf yöntemi mevcut mu diye bakar

is_bool
is_double
Değişkenlerle ilgili işlevler


is_float işlevinin takma adıdır

is_callable
is_float
Değişkenlerle ilgili işlevler
PHP Manual

is_double

(PHP 4, PHP 5, PHP 7)

is_double — is_float() işlevinin takma adıdır

Açıklama

Bu işlev is_float() işlevinin takma adıdır.

is_callable
is_float
Değişkenlerle ilgili işlevler


Değişken float türünde mi diye bakar

is_double
is_int
Değişkenlerle ilgili işlevler
PHP Manual

is_float

(PHP 4, PHP 5, PHP 7)

is_float — Değişken float türünde mi diye bakar

Açıklama

bool is_float ( mixed $değişken )

Belirtilen değişken float türündeyse TRUE döner.

Bilginize:

Değişkenin değerinin bir sayı veya bir sayısal dizge olup olmadığını öğrenmek istiyorsanız is_numeric() işlevini kullanın.

Değiştirgeler

değişken

Sınanacak değişken.

Dönen Değerler

Belirtilen değişken float türündeyse TRUE aksi takdirde FALSE döner.

Örnekler

Örnek 1 - is_float() örneği

<?php
if (is_float(27.25)) {
    echo "float türünde\n";
} else {
    echo "float türünde değil\n";
}
var_dump(is_float('abc'));
var_dump(is_float(23));
var_dump(is_float(23.5));
var_dump(is_float(1e7));  //Bilimsel gösterim
var_dump(is_float(true));
?>

Yukarıdaki örneğin çıktısı:

float türünde
bool(false)
bool(false)
bool(true)
bool(true)
bool(false)

Ayrıca Bakınız

  • is_bool() - Değişken boolean türünde mi diye bakar
  • is_int() - Değişken bir tamsayı mı diye bakar
  • is_numeric() - Değişken bir sayı veya bir sayısal dizge mi diye bakar
  • is_string() - Değişken string türünde mi diye bakar
  • is_array() - Değişkenin bir dizi içerip içermediğine bakar
  • is_object() - Değişken object türünde mi diye bakar

is_double
is_int
Değişkenlerle ilgili işlevler


Değişken bir tamsayı mı diye bakar

is_float
is_integer
Değişkenlerle ilgili işlevler
PHP Manual

is_int

(PHP 4, PHP 5, PHP 7)

is_int — Değişken bir tamsayı mı diye bakar

Açıklama

bool is_int ( mixed $değişken )

Belirtilen değişkenin değeri bir tamsayı ise bu işlev TRUE döndürür.

Bilginize:

Değişkenin değerinin bir sayı veya bir sayısal dizge olup olmadığını öğrenmek istiyorsanız is_numeric() işlevini kullanın.

Değiştirgeler

değişken

Sınanacak değişken.

Dönen Değerler

Belirtilen değişkenin değeri tamsayı ise TRUE aksi takdirde FALSE döndürür.

Örnekler

Örnek 1 - is_int() örneği

<?php
if (is_int(23)) {
    echo "tamsayıdır\n";
} else {
    echo "tamsayı değildir\n";
}
var_dump(is_int(23));
var_dump(is_int("23"));
var_dump(is_int(23.5));
var_dump(is_int(true));
?>

Yukarıdaki örneğin çıktısı:

tamsayıdır
bool(true)
bool(false)
bool(false)
bool(false)

Ayrıca Bakınız

  • is_bool() - Değişken boolean türünde mi diye bakar
  • is_float() - Değişken float türünde mi diye bakar
  • is_numeric() - Değişken bir sayı veya bir sayısal dizge mi diye bakar
  • is_string() - Değişken string türünde mi diye bakar
  • is_array() - Değişkenin bir dizi içerip içermediğine bakar
  • is_object() - Değişken object türünde mi diye bakar

is_float
is_integer
Değişkenlerle ilgili işlevler


is_int işlevinin takma adıdır

is_int
is_long
Değişkenlerle ilgili işlevler
PHP Manual

is_integer

(PHP 4, PHP 5, PHP 7)

is_integer — is_int() işlevinin takma adıdır

Açıklama

Bu işlev is_int() işlevinin takma adıdır.

is_int
is_long
Değişkenlerle ilgili işlevler


is_int işlevinin takma adıdır

is_integer
is_null
Değişkenlerle ilgili işlevler
PHP Manual

is_long

(PHP 4, PHP 5, PHP 7)

is_long — is_int() işlevinin takma adıdır

Açıklama

Bu işlev is_int() işlevinin takma adıdır.

is_integer
is_null
Değişkenlerle ilgili işlevler


Bir değişkenin değerinin NULL olup olmadığına bakar

is_long
is_numeric
Değişkenlerle ilgili işlevler
PHP Manual

is_null

(PHP 4 >= 4.0.4, PHP 5, PHP 7)

is_null — Bir değişkenin değerinin NULL olup olmadığına bakar

Açıklama

bool is_null ( mixed $değişken )

Belirtilen değişkenin değeri NULL ise bu işlev TRUE döndürür.

Değiştirgeler

değişken

Sınanacak değişken.

Dönen Değerler

Belirtilen değişkenin değeri NULL ise TRUE aksi takdirde FALSE döndürür.

Örnekler

Örnek 1 - is_null() örneği

<?php

error_reporting(E_ALL);

$foo = NULL;
var_dump(is_null($inexistent), is_null($foo));

?>
Notice: Undefined variable: inexistent in ...
bool(true)
bool(true)

Ayrıca Bakınız

  • The NULL türü
  • isset() - Değişken tanımlı mı diye bakar
  • is_bool() - Değişken boolean türünde mi diye bakar
  • is_numeric() - Değişken bir sayı veya bir sayısal dizge mi diye bakar
  • is_float() - Değişken float türünde mi diye bakar
  • is_int() - Değişken bir tamsayı mı diye bakar
  • is_string() - Değişken string türünde mi diye bakar
  • is_object() - Değişken object türünde mi diye bakar
  • is_array() - Değişkenin bir dizi içerip içermediğine bakar

is_long
is_numeric
Değişkenlerle ilgili işlevler


Değişken bir sayı veya bir sayısal dizge mi diye bakar

is_null
is_object
Değişkenlerle ilgili işlevler
PHP Manual

is_numeric

(PHP 4, PHP 5, PHP 7)

is_numeric — Değişken bir sayı veya bir sayısal dizge mi diye bakar

Açıklama

bool is_numeric ( mixed $değişken )

Belirtilen değişkenin değeri bir sayı ise bu işlev TRUE döndürür. Sayısal dizgeler isteğe bağlı bir işaret, bir miktar rakam, isteğe bağlı bir ondalık ve üstel kısımdan oluşur. Bu bakımdan +0123.45e6 geçerli bir sayısal değerdir. İşaretsiz, ondalık ve üstel kısımları olmadan onaltılık (0xFF) gösterim de kabul edilir.

Değiştirgeler

değişken

Sınanacak değişken.

Dönen Değerler

Belirtilen değişkenin değeri bir sayı veya sayısal bir dizge ise TRUE aksi takdirde FALSE döndürür.

Örnekler

Örnek 1 - is_numeric() örnekleri

<?php
$tests = Array(
    "42",
    1337,
    "1e4",
    "sayısal değil",
    Array(),
    9.1
    );

foreach($tests as $element)
{
  if(is_numeric($element))  {
      echo "'{$element}' sayısaldır", PHP_EOL;
  } else {
      echo "'{$element}' sayısal DEĞİLdir", PHP_EOL;
  }
}
?>

Yukarıdaki örneğin çıktısı:

'42' sayısaldır
'1337' sayısaldır
'1e4' sayısaldır
'not numeric' sayısal DEĞİLdir
'Array' sayısal DEĞİLdir
'9.1' sayısaldır

Ayrıca Bakınız

  • ctype_digit() - Sınama, rakamlar için yapılır
  • is_bool() - Değişken boolean türünde mi diye bakar
  • is_null() - Bir değişkenin değerinin NULL olup olmadığına bakar
  • is_float() - Değişken float türünde mi diye bakar
  • is_int() - Değişken bir tamsayı mı diye bakar
  • is_string() - Değişken string türünde mi diye bakar
  • is_object() - Değişken object türünde mi diye bakar
  • is_array() - Değişkenin bir dizi içerip içermediğine bakar

is_null
is_object
Değişkenlerle ilgili işlevler


Değişken object türünde mi diye bakar

is_numeric
is_real
Değişkenlerle ilgili işlevler
PHP Manual

is_object

(PHP 4, PHP 5, PHP 7)

is_object — Değişken object türünde mi diye bakar

Açıklama

bool is_object ( mixed $değişken )

Belirtilen değişken object türündeyse TRUE döner.

Değiştirgeler

değişken

Sınanacak değişken.

Dönen Değerler

Belirtilen değişken object türündeyse TRUE aksi takdirde FALSE döner.

Örnekler

Örnek 1 - is_object() örneği

<?php
// Nesnemizi bir diziye dönüştürecek bir işlev tanımlayalım
function get_students($obj) {
    if(!is_object($obj)) {
        return(false);
    }

     return($obj->students);
}

// Yeni bir sınıfı örnekleyip bazı değerlerle içini dolduralım
$obj = new stdClass();
$obj->students = array('Kalle', 'Ross', 'Felipe');

var_dump(get_students(null));
var_dump(get_students($obj));
?>

Notlar

Bilginize:

Değer olarak, dizgeleştirilmiş bir değerden elde edilen sınıf tanımı olmayan bir nesne için (gettype() işlevi object döndürse bile) işlev FALSE döndürecektir.

Ayrıca Bakınız

  • is_bool() - Değişken boolean türünde mi diye bakar
  • is_int() - Değişken bir tamsayı mı diye bakar
  • is_float() - Değişken float türünde mi diye bakar
  • is_string() - Değişken string türünde mi diye bakar
  • is_array() - Değişkenin bir dizi içerip içermediğine bakar

is_numeric
is_real
Değişkenlerle ilgili işlevler


is_float işlevinin takma adıdır

is_object
is_resource
Değişkenlerle ilgili işlevler
PHP Manual

is_real

(PHP 4, PHP 5, PHP 7)

is_real — is_float() işlevinin takma adıdır

Açıklama

Bu işlev is_float() işlevinin takma adıdır.

is_object
is_resource
Değişkenlerle ilgili işlevler


Değişken resource türünde mi diye bakar

is_real
is_scalar
Değişkenlerle ilgili işlevler
PHP Manual

is_resource

(PHP 4, PHP 5, PHP 7)

is_resource — Değişken resource türünde mi diye bakar

Açıklama

bool is_resource ( mixed $değişken )

Belirtilen değişken resource türündeyse TRUE döner.

Değiştirgeler

değişken

Sınanacak değişken.

Dönen Değerler

Belirtilen değişken resource türündeyse TRUE aksi takdirde FALSE döner.

Örnekler

Örnek 1 - is_resource() örneği

<?php

$db_link = @mysql_connect('localhost', 'mysql_user', 'mysql_pass');
if (!is_resource($db_link)) {
    die('Bağlantı kurulamadı: ' . mysql_error());
}

?>

Ayrıca Bakınız

  • resource
  • get_resource_type() - Özkaynak türünü döndürür

is_real
is_scalar
Değişkenlerle ilgili işlevler


Bir değişken sayıl mı diye bakar

is_resource
is_string
Değişkenlerle ilgili işlevler
PHP Manual

is_scalar

(PHP 4 >= 4.0.5, PHP 5, PHP 7)

is_scalar — Bir değişken sayıl mı diye bakar

Açıklama

bool is_scalar ( mixed $değişken )

Belirtilen değişkenin değeri sayıl türlerden biri ise TRUE döner.

Sayıl türler: integer, float, string ve boolean. Sayıl olmayan türler: array, object ve resource.

Bilginize:

is_scalar() işlevi resource türündeki değerleri, tamsayılara dayalı soyut veri türleri olduklarından sayıl değerler olarak ele almaz. Bu gerçeklenim ayrıntısı bir kural olarak ele alınmamalıdır, ileride değişebilir.

Değiştirgeler

değişken

Sınanacak değişken.

Dönen Değerler

Belirtilen değişkenin değeri sayıl türlerden biri ise TRUE, aksi takdirde FALSE döner.

Örnekler

Örnek 1 - is_scalar() örneği

<?php
function show_var($var)
{
    if (is_scalar($var)) {
        echo $var;
    } else {
        var_dump($var);
    }
}
$pi = 3.1416;
$proteins = array("hemoglobin", "cytochrome c oxidase", "ferredoxin");

show_var($pi);
show_var($proteins)

?>

Yukarıdaki örneğin çıktısı:

3.1416
array(3) {
  [0]=>
  string(10) "hemoglobin"
  [1]=>
  string(20) "cytochrome c oxidase"
  [2]=>
  string(10) "ferredoxin"
}

Ayrıca Bakınız

  • is_float() - Değişken float türünde mi diye bakar
  • is_int() - Değişken bir tamsayı mı diye bakar
  • is_numeric() - Değişken bir sayı veya bir sayısal dizge mi diye bakar
  • is_real() - is_float işlevinin takma adıdır
  • is_string() - Değişken string türünde mi diye bakar
  • is_bool() - Değişken boolean türünde mi diye bakar
  • is_object() - Değişken object türünde mi diye bakar
  • is_array() - Değişkenin bir dizi içerip içermediğine bakar

is_resource
is_string
Değişkenlerle ilgili işlevler


Değişken string türünde mi diye bakar

is_scalar
isset
Değişkenlerle ilgili işlevler
PHP Manual

is_string

(PHP 4, PHP 5, PHP 7)

is_string — Değişken string türünde mi diye bakar

Açıklama

bool is_string ( mixed $değişken )

Belirtilen değişken string türündeyse TRUE döner.

Değiştirgeler

değişken

Sınanacak değişken.

Dönen Değerler

Belirtilen değişken string türündeyse TRUE aksi takdirde FALSE döner.

Örnekler

Örnek 1 - is_string() örneği

<?php
if (is_string("23")) {
    echo "dizgedir\n";
} else {
    echo "dizge değildir\n";
}
var_dump(is_string('abc'));
var_dump(is_string("23"));
var_dump(is_string(23.5));
var_dump(is_string(true));
?>

Yukarıdaki örneğin çıktısı:

dizgedir
bool(true)
bool(true)
bool(false)
bool(false)

Ayrıca Bakınız

  • is_float() - Değişken float türünde mi diye bakar
  • is_int() - Değişken bir tamsayı mı diye bakar
  • is_bool() - Değişken boolean türünde mi diye bakar
  • is_object() - Değişken object türünde mi diye bakar
  • is_array() - Değişkenin bir dizi içerip içermediğine bakar

is_scalar
isset
Değişkenlerle ilgili işlevler


Değişken tanımlı mı diye bakar

is_string
print_r
Değişkenlerle ilgili işlevler
PHP Manual

isset

(PHP 4, PHP 5, PHP 7)

isset — Değişken tanımlı mı diye bakar

Açıklama

bool isset ( mixed $değişken [, mixed $değişken [, $... ]] )

Belirtilen değişken tanımlıysa ve NULL değilse TRUE döner.

Bir değişken unset() ile yok edilmişse artık tanımlı değildir. isset() değişkene NULL atanmış olduğunu saptarsa FALSE döndürür. Bir NULL baytın ("\0") PHP'nin NULL sabitine eşdeğer olmadığına dikkat ediniz.

İşleve çok sayıda değiştirge aktarılmışsa sadece tüm değiştirgeler NULL'dan farklı bir değer içerdiği takdirde işlev TRUE döndürecektir. Değerlendirme soldan sağa ilerler ve NULL atanmış ilk değişkende işlem durdurulur.

Değiştirgeler

değişken

Sınanacak değişken.

değişken

Başka bir değişken..

...

Daha başka değişkenler.

Dönen Değerler

Belirtilen değişken tanımlıysa ve NULL'dan farklı bir değere sahipse TRUE, aksi takdirde FALSE döner.

Örnekler

Örnek 1 - isset() örnekleri

<?php

$var = '';

// Bu, TRUE olarak değerlendirilir, dolayısıyla metin basılır.
if (isset($var)) {
    echo "This var is set so I will print.";
}

// Aşağıdaki örneklerde isset() değerini basmak
// için var_dump işlevini kullanacağız.

$a = "deneme";
$b = "başka bir deneme";

var_dump(isset($a));      // TRUE
var_dump(isset($a, $b));  // TRUE

unset ($a);

var_dump(isset($a));     // FALSE
var_dump(isset($a, $b)); // FALSE

$foo = NULL;
var_dump(isset($foo));   // FALSE

?>

Bu ayrıca dizi elemanları için de çalışır:

<?php

$a = array ('test' => 1, 'hello' => NULL);

var_dump(isset($a['test']));            // TRUE
var_dump(isset($a['foo']));             // FALSE
var_dump(isset($a['hello']));           // FALSE

// 'hello' anahtarının NULL'a eşitlenmesi elemanın tanımsız olması demektir
// NULL anahtarın durumunu öğrenmek için şunu deneyebilirsiniz:
var_dump(array_key_exists('hello', $a)); // TRUE

?>

Notlar

Uyarı

isset() işlevi bir çözümleme hatası oluşturmayacak her değişkenle çalışır. Sabitlerin tanımlı olup olmadığını öğrenmek için defined() işlevini kullanın.

Bilginize: Bu bir işlev değil, dil oluşumu olduğundan değişken işlevler kullanılarak çağrılamaz.

Bilginize:

empty() erişilir olmayan nesne özellikleri kullanıyorsa, bildirimli olduğu taktirde __isset yöntemi çağrılabilir.

Ayrıca Bakınız

  • empty() - Bir değişkenin boş olup olmadığını saptar
  • __isset
  • unset() - Belirtilen değişkeni tanımsız yapar
  • defined() - Belirtilen isimli sabit tanımlı mı diye bakar
  • Tür Karşılaştırma Tabloları
  • array_key_exists() - Belirtilen anahtar veya indis dizide var mı diye bakar
  • is_null() - Bir değişkenin değerinin NULL olup olmadığına bakar
  • @ hata denetim işleci

is_string
print_r
Değişkenlerle ilgili işlevler


Bir değişkenin insanlarca okunabilecek gösterimini basar

isset
serialize
Değişkenlerle ilgili işlevler
PHP Manual

print_r

(PHP 4, PHP 5, PHP 7)

print_r — Bir değişkenin insanlarca okunabilecek gösterimini basar

Açıklama

mixed print_r ( mixed $ifade [, bool $döndür = false ] )

print_r() işlevi, bir değişkenin insanlarca okunabilecek gösterimini basar.

print_r(), var_dump() ve var_export() işlevleri PHP5 ve sonrasında nesnelerin protected ve private özelliklerini de gösterirler. Statik sınıf üyeleri gösterilmez.

print_r() işlevinin dizi göstericisini dizinin sonuna konuşlandıracağını unutmayın; dizinin başına konuşlandırmak için reset() işlevini kullanın.

Değiştirgeler

ifade

Gösterimi basılacak ifade.

döndür

Bu değiştirgeye TRUE atarsanız, print_r() çıktısını basmak yerine bir bilgi döndürür. Çıktısını basması öntanımlı davranıştır.

Dönen Değerler

Eğer belirtilen değer string, integer veya float türündeyse değerin kendi basılır; array türündeyse anahtarların ve elemanların gösterileceği biçemde basılır. Diziler için kulanılan yöntemin benzeri nesneler (object) için de kullanılır.

döndür TRUE olduğu takdirde bu işlev bir dizge döndürür, aksi takdirde dönen değer TRUE olur.

Notlar

Bilginize:

Bu işlev bu değiştirge ile bir dahili çıktı tamponu kullanır, dolayısıyla ob_start() geriçağırım işlevinin içinde kullanılamaz.

Sürüm Bilgisi

Sürüm: | Açıklama
4.3.0 | döndür değiştirgesi eklendi. Daha eski sürümlerde print_r() işlevinin bastığı çıktıyı döndürmek için Çıktı Denetim İşlevlerini kullanın.
4.0.4 | PHP 4.0.4 öncesinde, print_r() işlevi, değer olarak bir dizi veya nesne belirtildiği taktirde bunlar doğrudan veya dolaylı kendilerine gönderimli iseler işlev sürekli çıktılama yapardı. Buna bir örnek olarak print_r($GLOBALS) verilebilir, çünkü $GLOBALS dizisinin kendisi, kendine gönderimli bir küresel değişkendir.

Örnekler

Örnek 1 - print_r() örneği

<pre>
<?php
$a = array ('a' => 'apple', 'b' => 'banana', 'c' => array ('x', 'y', 'z'));
print_r ($a);
?>
</pre>

Yukarıdaki örneğin çıktısı:

<pre>
Array
(
    [a] => apple
    [b] => banana
    [c] => Array
        (
            [0] => x
            [1] => y
            [2] => z
        )
)
</pre>

Örnek 2 - döndür değiştirgeli örnek

<?php
$b = array ('m' => 'monkey', 'foo' => 'bar', 'x' => array ('x', 'y', 'z'));
$results = print_r($b, true); // $results print_r çıktısını içerir
?>

Ayrıca Bakınız

  • ob_start() - Çıktı tamponlamasını başlatır
  • var_dump() - Bir değişkenle ilgili bilgiyi dökümler
  • var_export() - Bir değişkenin çözümlenebilir dizge gösterimini döndürür veya çıktılar

isset
serialize
Değişkenlerle ilgili işlevler


Bir değerin saklanabilir bir gösterimini üretir

print_r
settype
Değişkenlerle ilgili işlevler
PHP Manual

serialize

(PHP 4, PHP 5, PHP 7)

serialize — Bir değerin saklanabilir bir gösterimini üretir

Açıklama

string serialize ( mixed $değer )

Bir değerin saklanabilir bir gösterimini üretir.

PHP değerlerini, yapısını ve türünü kaybetmeden saklamak veya aktarmak için kullanışlıdır.

Böyle bir değerden tekrar özgün değeri elde etmek için unserialize() işlevini kullanın.

Değiştirgeler

değer

Dizgeleştirilecek değer. serialize() işlevi, resource türü hariç her türü dizgeleştirebilir. Hatta kendine gönderimli dizileri bile dizgeleştirebilirsiniz. Dizgeleştirdiğiniz dizi veya nesnelerin içindeki döngüsel gönderimler bile saklanabilir. Bunlar dışında kalan gönderimler kaybedilir.

PHP nesneleri dizgeleştirirken önce __sleep üye işlevi çağrılmaya çalışılır. Bu işlem, nesneye dizgeleştirme öncesinde bir takım temizlikler yapabilmesi imkanını tanır. Benzer şekilde, unserialize() kullanılarak nesne özgün durumuna getirilirken __wakeup üye işlevi çağrılmaya çalışılır.

Bilginize:

Nesnenin özel üyelerinin isimlerinin önünde sınıf ismi, protected üyelerin isimlerinin önünde ise bir '*' bulunur. İsimlerin başına getirilen bu değerler her iki tarafta null baytlarla ifade edilirler.

Dönen Değerler

Belirtilen değerin herhangi bir yerde saklanabilecek, akımlar üzerinden aktarılabilen bir gösterimini döndürür.

Bunun ikil bir dizge oluşuna, null baytlar içerebileceğine ve ikil olarak ele alınabileceğine dikkat ediniz. Örneğin, serialize() çıktısının genelde bir veritabanının bir CHAR veya TEXT alanında değil bir BLOB alanında saklanması gerekir.

Örnekler

Örnek 1 - serialize() örneği

<?php
// $session_data, geçerli kullanıcı için oturum bilgisini
// içeren çok boyutlu bir dizi içerir. İsteğin sonunda bu diziyi bir
// veritabanında saklamak için serialize() işlevini kullanacağız.

$conn = odbc_connect("webdb", "php", "chicken");
$stmt = odbc_prepare($conn,
      "UPDATE sessions SET data = ? WHERE id = ?");
$sqldata = array (serialize($session_data), $_SERVER['PHP_AUTH_USER']);
if (!odbc_execute($stmt, $sqldata)) {
    $stmt = odbc_prepare($conn,
     "INSERT INTO sessions (id, data) VALUES(?, ?)");
    if (!odbc_execute($stmt, $sqldata)) {
        /* Birşeyler yanlış gitmiş.. */
    }
}
?>

Notlar

Bilginize:

Yerleşik PHP nesenelerinin çoğunun dizgeleştirilemeyeceğine dikkar ediniz. Bu bakımda ya Serializable arayüzü veya sihirli __sleep() ve __wakeup() yöntemleri kullanılarak gerçeklenir. Dahili bir sınıf bu gereksinimleri sağlamıyorsa gerektiği gibi dizgeleştirilemez.

Yukarıdaki kuralın geçmişten gelen bazı istisnaları olup bazı dahili nesneler arayüz gerçeklemeden veya malum yöntemleri kullanmadan dizgeleştirilebilir. Özellikle, PHP 5.2.0 öncesi ArrayObject buna bir örnektir.

Uyarı

serialize() işlevi nesneleri dizgeleştirirken, azami uyumluluğu sağlamak için isimalanlı sınıfların sınıf isimlerinin sonuna tersbölü konmaz.

Ayrıca Bakınız

  • unserialize() - Bir PHP değerini saklanmış gösteriminden oluşturur
  • var_export() - Bir değişkenin çözümlenebilir dizge gösterimini döndürür veya çıktılar
  • json_encode() - Değerin JSON karşılığını verir.
  • Nesneleri Dizgeleştirme
  • __sleep()
  • __wakeup()

print_r
settype
Değişkenlerle ilgili işlevler


Bir değişkenin türünü belirler

serialize
strval
Değişkenlerle ilgili işlevler
PHP Manual

settype

(PHP 4, PHP 5, PHP 7)

settype — Bir değişkenin türünü belirler

Açıklama

bool settype ( mixed &$değişken , string $tür )

Belirtilen değişkenin türünü belirler.

Değiştirgeler

değişken

Türü belirlenecek değişken.

tür

Olası tür değerleri:

  • "boolean" (veya PHP 4.2.0'dan beri "bool")
  • "integer" (veya PHP 4.2.0'dan beri "int")
  • "float" (sadece PHP 4.2.0'dan beri; daha eski sürümler artık önerilmeyen "double" türünü kullanırdı)
  • "string"
  • "array"
  • "object"
  • "null" (PHP 4.2.0'dan beri)

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - settype() örneği

<?php
$foo = "5bar"; // string
$bar = true;   // boolean

settype($foo, "integer"); // $foo is now 5   (integer)
settype($bar, "string");  // $bar is now "1" (string)
?>

Notlar

Bilginize:

"int" için azami değer PHP_INT_MAX'tır.

Ayrıca Bakınız

  • gettype() - Bir değişkenin türünü döndürür
  • Tür Çarpıtma
  • Tür Dönüşümü

serialize
strval
Değişkenlerle ilgili işlevler


Bir değişkenin dizgesel değerini döndürür

settype
unserialize
Değişkenlerle ilgili işlevler
PHP Manual

strval

(PHP 4, PHP 5, PHP 7)

strval — Bir değişkenin dizgesel değerini döndürür

Açıklama

string strval ( mixed $değişken )

Bir değişkenin dizgesel değerini döndürür. Dizgeye dönüşümle ilgili daha fazla bilgi için string sayfasına bakınız.

Bu işlev dönen değere hiçbir biçemleme uygulamaz. Sayısal bir değeri bir dizge olarak biçemlemenin bir yolunu arıyorsanız sprintf() veya number_format() işlevi işinizi görebilir.

Değiştirgeler

değişken

Dizgeye dönüşürülecek değişken.

değişken herhangi bir sayıl değer olabilir. strval() işlevini diziler ve nesneler üzerinde kullanamazsınız.

Dönen Değerler

Belirtilen değişken'in string türünde değeri.

Örnekler

Örnek 1 - PHP5'in sihirli __toString yöntemini kullanan strval() örneği

<?php
class StrValTest
{
    public function __toString()
    {
         return __CLASS__;
    }
}

// Prints 'StrValTest'
echo strval(new StrValTest);
?>

Ayrıca Bakınız

  • floatval() - Bir değişkenin gerçek sayı değerini döndürür
  • intval() - Bir değişkenin tamsayı değerini döndürür
  • settype() - Bir değişkenin türünü belirler
  • sprintf() - Biçemli bir dizge döndürür
  • number_format() - Sayıyı binlik bölümlere ayırır
  • Tür Dönüşümü

settype
unserialize
Değişkenlerle ilgili işlevler


Bir PHP değerini saklanmış gösteriminden oluşturur

strval
unset
Değişkenlerle ilgili işlevler
PHP Manual

unserialize

(PHP 4, PHP 5, PHP 7)

unserialize — Bir PHP değerini saklanmış gösteriminden oluşturur

Açıklama

mixed unserialize ( string $dizge )

unserialize() işlevi tek bir dizgeleştirilmiş değişken alır ve bunu tekrar bir PHP değeri haline getirir.

Değiştirgeler

dizge

Dizgeleştirilmiş değer.

Dizgeleştirilmiş bir değişkeni bir nesne haline getirmeye çalışırsanız PHP nesneyi oluşturduktan sonra özdevinimli olarak __wakeup() üye işlevini (varsa) çağıracaktır.

Bilginize: unserialize_callback_func yönergesi

Nesneleştirme sırasında tanımsız bir sınıf örneklenecekse (eksikli bir "__PHP_Incomplete_Class" nesnesinin elde edilmesini engellemek için) çağrılmak üzere bir geriçağırım işlevi tanımlamak mümkündür. Böyle bir işlevi php.ini veya .htaccess dosyasında unserialize_callback_func yönergesinde veya ya da ini_set() işlevinde belirtebilirsiniz. Bu işlevin her çağrılışında tanımsız bir sınıfın örneklenmesi gerekir. Bu özelliği iptal etmek için bu ayarı boş bırakmanız yeterlidir.

Dönen Değerler

Dönüştürülerek döndürülen değer boolean, integer, float, string, array veya object türünde olabilir.

Nesneleştirilemeyen bir dizge belirtilmesi durumunda işlev FALSE döndürür ve bir E_NOTICE çıktılar.

Sürüm Bilgisi

Sürüm: | Açıklama
4.2.0 | unserialize_callback_func işlevi kullanılabilir oldu.

Örnekler

Örnek 1 - unserialize() örneği

<?php
// Burada, oturum verisini $session_data dizisine yüklemek
// için bir veritabanından seçilmiş bir dizgeyi nesneleştireceğiz
// Bu örnek serialize() işlevi örneğinin tamamlayıcısıdır.

$conn = odbc_connect("webdb", "php", "chicken");
$stmt = odbc_prepare($conn, "SELECT data FROM sessions WHERE id = ?");
$sqldata = array($_SERVER['PHP_AUTH_USER']);
if (!odbc_execute($stmt, $sqldata) || !odbc_fetch_into($stmt, $tmp)) {
    // çalıştırma veya alım başarısız olursa boş bir dizi ilklendireceğiz
    $session_data = array();
} else {
    // artık dizgeleştirilmiş veri $tmp[0] içinde.
    $session_data = unserialize($tmp[0]);
    if (!is_array($session_data)) {
        // birşeyler yanlış gitmiş, boş bir dizi ilklendirelim
        $session_data = array();
    }
}
?>

Örnek 2 - unserialize_callback_func örneği

<?php
$serialized_object='O:1:"a":1:{s:5:"value";s:3:"100";}';

// unserialize_callback_func yönergesi PHP 4.2.0'dan beri kullanılabilmektedir.
// kendi geriçağırım işlevimizi belirtelim
ini_set('unserialize_callback_func', 'mycallback');

function mycallback($classname)
{
    // Sınıf tanımınızı içeren bir dosyayı dahil etmeniz yeterlidir
    // Hangi sınıf tanımının gerçekleneceğini $classname değişkenine
    // bakarak saptayacaksınız
}
?>

Notlar

Uyarı

Hata durumunda veya dizgeleştirilmiş bir FALSE değerini nesneleştirmeye çalışıyorsanız işlev FALSE döndürür. Bu özel durumu str değiştirgesini serialize(false) ile karşılaştırarak veya E_NOTICE çıktısını inceleyerek yakalayabilirsiniz.

Ayrıca Bakınız

  • serialize() - Bir değerin saklanabilir bir gösterimini üretir
  • Özdevinimli Nesne Yükleme
  • unserialize_callback_func

strval
unset
Değişkenlerle ilgili işlevler


Belirtilen değişkeni tanımsız yapar

unserialize
var_dump
Değişkenlerle ilgili işlevler
PHP Manual

unset

(PHP 4, PHP 5, PHP 7)

unset — Belirtilen değişkeni tanımsız yapar

Açıklama

void unset ( mixed $değişken [, mixed $değişken [, mixed $... ]] )

unset() işlevi belirtilen değişkenleri hiç tanımlanmamış duruma getirir.

İşlevin başka bir işlev içindeki davranışı tanımsız yapılmaya çalışılan değişkenin türüne bağlıdır.

Aşağıdaki örnekte işlevin içinde yokedilmeye çalışılan değişken işlev içinde küreselleştirilmiş bir değişken olup değişkenin sadece yerel tanımı yok edilir. Değişkenin çağrı ortamındaki değeri unset() çağrılmadan önceki değerini korur.

<?php
function foo_yu_gebert()
{
    global $foo;
    unset($foo);
}

$foo = 'bar';
foo_yu_gebert();
echo $foo;
?>

Yukarıdaki örneğin çıktısı:

bar

Bir küresel değişkeni bir işlev içinde yoketmeniz gerekliyse $GLOBALS dizisini kullanabilirsiniz:

<?php
function foo()
{
    unset($GLOBALS['bar']);
}

$bar = "something";
foo();
?>

Gönderimli aktarılan bir değişkeni bir işlev içinde yoketmeye çalışırsanız sadece yerel değişkeni yoketmiş olursunuz. Değişkenin, işlevin çağrıldıgı ortamdaki değeri unset() çağrılmadan önceki değerini korur.

<?php
function foo(&$bar)
{
    unset($bar);
    $bar = "başka bir şey";
}

$bar = 'bir şey';
echo "$bar\n";

foo($bar);
echo "$bar\n";
?>

Yukarıdaki örneğin çıktısı:

bir şey
bir şey

Bir duruk değişkeni bir işlev içinde yoketmeye çalışırsanız değişkeni sadece işlevin kalan bağlamı için yoketmiş olursunuz. Aşağıdaki çağrılar değişkenin önceki değerinin geçerli kaldığını gösterecektir.

<?php
function foo()
{
    static $bar;
    $bar++;
    echo "unset öncesi: $bar, ";
    unset($bar);
    $bar = 23;
    echo "unset sonrası: $bar\n";
}

foo();
foo();
foo();
?>

Yukarıdaki örneğin çıktısı:

unset öncesi: 1, unset sonrası: 23
unset öncesi: 2, unset sonrası: 23
unset öncesi: 3, unset sonrası: 23

Değiştirgeler

değişken

Yokedilecek değişken.

değişken

Başka bir değişken.

...

Başka değişkenler.

Dönen Değerler

Hiçbir değer dönmez.

Sürüm Bilgisi

Sürüm: | Açıklama
4.0.1 | Çok sayıda değiştirge belirtebilme desteği eklendi.

Örnekler

Örnek 1 - unset() örneği

<?php
// tek bir değişkeni yokedelim
unset($foo);

// Bir dizinin tek bir elemanını yokedelim
unset($bar['quux']);

// birden fazla değiykeni yokedelim
unset($foo1, $foo2, $foo3);
?>

Örnek 2 - (unset) - NULL'a dönüşüm örneği (PHP 5 ve sonrası)

<?php
$name = 'Felipe';

var_dump((unset) $name);
?>

Notlar

Bilginize: Bu bir işlev değil, dil oluşumu olduğundan değişken işlevler kullanılarak çağrılamaz.

Bilginize:

Nesne özelliklerini geçerli bağlamda görünür olsalar bile yoketmek mümkündür.

Bilginize:

PHP 5'ten beri bir nesne yöntemi içinde $this yokedilememektedir.

Bilginize:

empty() erişilir olmayan nesne özellikleri kullanıyorsa, bildirimli olduğu taktirde __isset yöntemi çağrılabilir.

Ayrıca Bakınız

  • isset() - Değişken tanımlı mı diye bakar
  • empty() - Bir değişkenin boş olup olmadığını saptar
  • __isset
  • array_splice() - Bir dizinin belli bir bölümünü silip yerine başka şeyler koyar

unserialize
var_dump
Değişkenlerle ilgili işlevler


Bir değişkenle ilgili bilgiyi dökümler

unset
var_export
Değişkenlerle ilgili işlevler
PHP Manual

var_dump

(PHP 4, PHP 5, PHP 7)

var_dump — Bir değişkenle ilgili bilgiyi dökümler

Açıklama

void var_dump ( mixed $ifade [, mixed $ifade [, $... ]] )

Bu işlev bir değişkenin türü ve değeri dahil değişkenle ilgili bilgileri gösterir. Diziler ve nesneler ardışık olarak bileşenlerine ayrılarak tüm yapısı değerleriyle birlikte gösterilir.

PHP 5'te nesnelerin tüm public, private ve protected özellikleri çıktıda gösterilir.

İpucu

Sonuçlarını doğrudan tarayıcıya çıktılayan her şey gibi, çıktı denetleme işlevleri bu işlevin de çıktısını yakalamak ve (örneğin) string türünde saklamak için kullanılabilir.

Değiştirgeler

ifade

Bilgileri dökümlenecek değişken.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 - var_dump() örneği

<?php
$a = array(1, 2, array("a", "b", "c"));
var_dump($a);
?>

Yukarıdaki örneğin çıktısı:

array(3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  array(3) {
    [0]=>
    string(1) "a"
    [1]=>
    string(1) "b"
    [2]=>
    string(1) "c"
  }
}
<?php

$b = 3.1;
$c = true;
var_dump($b, $c);

?>

Yukarıdaki örneğin çıktısı:

float(3.1)
bool(true)

Ayrıca Bakınız

  • var_export() - Bir değişkenin çözümlenebilir dizge gösterimini döndürür veya çıktılar
  • print_r() - Bir değişkenin insanlarca okunabilecek gösterimini basar

unset
var_export
Değişkenlerle ilgili işlevler


Bir değişkenin çözümlenebilir dizge gösterimini döndürür veya çıktılar

var_dump
HTTP Hizmetleri
Değişkenlerle ilgili işlevler
PHP Manual

var_export

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

var_export — Bir değişkenin çözümlenebilir dizge gösterimini döndürür veya çıktılar

Açıklama

mixed var_export ( mixed $ifade [, bool $döndür = false ] )

var_export() işlevi belirtilen değişken hakkında yapı bilgisi döndürür. Dönen gösterimin geçerli bir PHP kodu olması dışında var_dump() işlevine benzer.

Değiştirgeler

ifade

Bilgi edinmek istenen değişken.

döndür

TRUE belirtilmişse, var_export() işlevi değişken gösterimini çıktılamak yerine döndürür.

Bilginize:

Bu işlev bu değiştirge ile bir dahili çıktı tamponu kullanır, dolayısıyla ob_start() geriçağırım işlevinin içinde kullanılamaz.

Dönen Değerler

döndür değiştirgesinde TRUE belirtildiğinde değişkenin gösterimini döndürür. Aksi takdirde NULL döndürür.

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.0 | __set_state sihirli yöntemi kullanılarak sınıfları ve sınıfları içeren dizileri çıktılamak mümkün oldu.

Örnekler

Örnek 1 - var_export() örnekleri

<?php
$a = array (1, 2, array ("a", "b", "c"));
var_export($a);
?>

Yukarıdaki örneğin çıktısı:

array (
  0 => 1,
  1 => 2,
  2 =>
  array (
    0 => 'a',
    1 => 'b',
    2 => 'c',
  ),
)
<?php

$b = 3.1;
$v = var_export($b, true);
echo $v;

?>

Yukarıdaki örneğin çıktısı:

3.1

Örnek 2 - PHP 5.1.0'den beri sınıfların çıktılanması

<?php
class A { public $var; }
$a = new A;
$a->var = 5;
var_export($a);
?>

Yukarıdaki örneğin çıktısı:

A::__set_state(array(
   'var' => 5,
))

Örnek 3 - __set_state kullanımı (PHP 5.1.0'dan beri)

<?php
class A
{
    public $var1;
    public $var2;

    public static function __set_state($an_array)
    {
        $obj = new A;
        $obj->var1 = $an_array['var1'];
        $obj->var2 = $an_array['var2'];
        return $obj;
    }
}

$a = new A;
$a->var1 = 5;
$a->var2 = 'foo';

eval('$b = ' . var_export($a, true) . ';'); // $b = A::__set_state(array(
                                            //    'var1' => 5,
                                            //    'var2' => 'foo',
                                            // ));
var_dump($b);
?>

Yukarıdaki örneğin çıktısı:

object(A)#2 (2) {
  ["var1"]=>
  int(5)
  ["var2"]=>
  string(3) "foo"
}

Notlar

Bilginize:

resource türündeki değişkenler bu işlev ile çıktılanamaz.

Bilginize:

var_export() işlevi, döngüsel gönderimler için PHP'nin çözümlenebilir bir kod üretmesi imkansıza yakın olduğundan bu tür döngüler işleme sokulmaz. Bir dizi veya nesnenin dizgesel gösterimi üzerinde işlemler yapmak istiyorsanız serialize() işlevini kullanın.

Ayrıca Bakınız

  • print_r() - Bir değişkenin insanlarca okunabilecek gösterimini basar
  • serialize() - Bir değerin saklanabilir bir gösterimini üretir
  • var_dump() - Bir değişkenle ilgili bilgiyi dökümler

var_dump
HTTP Hizmetleri
Değişkenlerle ilgili işlevler


HTTP Hizmetleri

  • OAuth
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • OAuth İşlevleri
    • OAuth — The OAuth class
    • OAuthProvider — The OAuthProvider class
    • OAuthException — OAuthException class
  • SCA
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • SCA İşlevleri
  • SOAP
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • SOAP İşlevleri
    • SoapClient — The SoapClient class
    • SoapServer — The SoapServer class
    • SoapFault — The SoapFault class
    • SoapHeader — The SoapHeader class
    • SoapParam — The SoapParam class
    • SoapVar — The SoapVar class
  • Yar — Yet Another RPC Framework
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • Yar_Server — The Yar_Server class
    • Yar_Client — The Yar_Client class
    • Yar_Concurrent_Client — The Yar_Concurrent_Client class
    • Yar_Server_Exception — The Yar_Server_Exception class
    • Yar_Client_Exception — The Yar_Client_Exception class
  • XML-RPC
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • XML-RPC İşlevleri
var_export
OAuth
İşlev Başvuru Kılavuzu


OAuth

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
    • FireEagle
  • OAuth İşlevleri
    • oauth_get_sbs — Generate a Signature Base String
    • oauth_urlencode — Encode a URI to RFC 3986
  • OAuth — The OAuth class
    • OAuth::__construct — Create a new OAuth object
    • OAuth::__destruct — The destructor
    • OAuth::disableDebug — Turn off verbose debugging
    • OAuth::disableRedirects — Turn off redirects
    • OAuth::disableSSLChecks — Turn off SSL checks
    • OAuth::enableDebug — Turn on verbose debugging
    • OAuth::enableRedirects — Turn on redirects
    • OAuth::enableSSLChecks — Turn on SSL checks
    • OAuth::fetch — Fetch an OAuth protected resource
    • OAuth::generateSignature — Generate a signature
    • OAuth::getAccessToken — Fetch an access token
    • OAuth::getCAPath — Gets CA information
    • OAuth::getLastResponse — Get the last response
    • OAuth::getLastResponseHeaders — Get headers for last response
    • OAuth::getLastResponseInfo — Get HTTP information about the last response
    • OAuth::getRequestHeader — Generate OAuth header string signature
    • OAuth::getRequestToken — Fetch a request token
    • OAuth::setAuthType — Set authorization type
    • OAuth::setCAPath — Set CA path and info
    • OAuth::setNonce — Set the nonce for subsequent requests
    • OAuth::setRequestEngine — The setRequestEngine purpose
    • OAuth::setRSACertificate — Set the RSA certificate
    • OAuth::setSSLChecks — Tweak specific SSL checks for requests.
    • OAuth::setTimestamp — Set the timestamp
    • OAuth::setToken — Sets the token and secret
    • OAuth::setVersion — Set the OAuth version
  • OAuthProvider — The OAuthProvider class
    • OAuthProvider::addRequiredParameter — Add required parameters
    • OAuthProvider::callconsumerHandler — Calls the consumerNonceHandler callback
    • OAuthProvider::callTimestampNonceHandler — Calls the timestampNonceHandler callback
    • OAuthProvider::calltokenHandler — Calls the tokenNonceHandler callback
    • OAuthProvider::checkOAuthRequest — Check an oauth request
    • OAuthProvider::__construct — Constructs a new OAuthProvider object
    • OAuthProvider::consumerHandler — Set the consumerHandler handler callback
    • OAuthProvider::generateToken — Generate a random token
    • OAuthProvider::is2LeggedEndpoint — is2LeggedEndpoint
    • OAuthProvider::isRequestTokenEndpoint — Sets isRequestTokenEndpoint
    • OAuthProvider::removeRequiredParameter — Remove a required parameter
    • OAuthProvider::reportProblem — Report a problem
    • OAuthProvider::setParam — Set a parameter
    • OAuthProvider::setRequestTokenPath — Set request token path
    • OAuthProvider::timestampNonceHandler — Set the timestampNonceHandler handler callback
    • OAuthProvider::tokenHandler — Set the tokenHandler handler callback
  • OAuthException — OAuthException class
HTTP Hizmetleri
Giriş
HTTP Hizmetleri


Giriş

This extension provides OAuth 1.0a consumer and provider bindings. OAuth is an authorization protocol built on top of HTTP which allows applications to securely access data without having to store usernames and passwords.

OAuth
Yapılandırma/Kurulum
OAuth


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
OAuth


Gereksinimler

PECL/oauth requires PHP 5.1 or newer, ext/hash and ext/pcre.

PECL/oauth may optionally require libcurl if selected at build time. If configured with libcurl, it must be built with HTTPS support.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pear.php.net/package/oauth

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

Most of these constants involve problems, which are also described within the official OAuth » Problem Reporting documentation. Note however, that these constant names are specific to PHP, although the naming scheme is similar.

OAUTH_SIG_METHOD_RSASHA1 (string)
OAuth RSA-SHA1 signature method.
OAUTH_SIG_METHOD_HMACSHA1 (string)

OAuth HMAC-SHA1 signature method.

OAUTH_SIG_METHOD_HMACSHA256 (string)
OAuth HMAC-SHA256 signature method.
OAUTH_AUTH_TYPE_AUTHORIZATION (string)

This constant represents putting OAuth parameters in the Authorization header.

OAUTH_AUTH_TYPE_NONE (string)

This constant indicates a NoAuth OAuth request.

OAUTH_AUTH_TYPE_URI (string)

This constant represents putting OAuth parameters in the request URI.

OAUTH_AUTH_TYPE_FORM (string)

This constant represents putting OAuth parameters as part of the HTTP POST body.

OAUTH_HTTP_METHOD_GET (string)

Use the GET method for the OAuth request.

OAUTH_HTTP_METHOD_POST (string)

Use the POST method for the OAuth request.

OAUTH_HTTP_METHOD_PUT (string)

Use the PUT method for the OAuth request.

OAUTH_HTTP_METHOD_HEAD (string)

Use the HEAD method for the OAuth request.

OAUTH_HTTP_METHOD_DELETE (string)
Use the DELETE method for the OAuth request.
OAUTH_REQENGINE_STREAMS (integer)
Used by OAuth::setRequestEngine() to set the engine to PHP streams, as opposed to OAUTH_REQENGINE_CURL for Curl.
OAUTH_REQENGINE_CURL (integer)
Used by OAuth::setRequestEngine() to set the engine to Curl, as opposed to OAUTH_REQENGINE_STREAMS for PHP streams.
OAUTH_OK (integer)
Life is good.
OAUTH_BAD_NONCE (integer)
The oauth_nonce value was used in a previous request, therefore it cannot be used now.
OAUTH_BAD_TIMESTAMP (integer)
The oauth_timestamp value was not accepted by the service provider. In this case, the response should also contain the oauth_acceptable_timestamps parameter.
OAUTH_CONSUMER_KEY_UNKNOWN (integer)
The oauth_consumer_key is temporarily unacceptable to the service provider. For example, the service provider may be throttling the consumer.
OAUTH_CONSUMER_KEY_REFUSED (integer)
The consumer key was refused.
OAUTH_INVALID_SIGNATURE (integer)
The oauth_signature is invalid, as it does not match the signature computed by the service provider.
OAUTH_TOKEN_USED (integer)
The oauth_token has been consumed. It can no longer be used because it has already been used in the previous request(s).
OAUTH_TOKEN_EXPIRED (integer)
The oauth_token has expired.
OAUTH_TOKEN_REVOKED (integer)
The oauth_token has been revoked, and will never be accepted.
OAUTH_TOKEN_REJECTED (integer)
The oauth_token was not accepted by the service provider. The reason is not known, but it might be because the token was never issued, already consumed, expired, and/or forgotten by the service provider.
OAUTH_VERIFIER_INVALID (integer)
The oauth_verifier is incorrect.
OAUTH_PARAMETER_ABSENT (integer)
A required parameter was not received. In this case, the response should also contain the oauth_parameters_absent parameter.
OAUTH_SIGNATURE_METHOD_REJECTED (integer)
The oauth_signature_method was not accepted by service provider.

Özkaynak Türleri
Örnekler
OAuth


Örnekler

İçindekiler

  • FireEagle
Öntanımlı Sabitler
FireEagle
OAuth


FireEagle

<?php
$req_url = 'https://fireeagle.yahooapis.com/oauth/request_token';
$authurl = 'https://fireeagle.yahoo.net/oauth/authorize';
$acc_url = 'https://fireeagle.yahooapis.com/oauth/access_token';
$api_url = 'https://fireeagle.yahooapis.com/api/0.1';
$conskey = 'your_consumer_key';
$conssec = 'your_consumer_secret';

session_start();

// In state=1 the next request should include an oauth_token.
// If it doesn't go back to 0
if(!isset($_GET['oauth_token']) && $_SESSION['state']==1) $_SESSION['state'] = 0;
try {
  $oauth = new OAuth($conskey,$conssec,OAUTH_SIG_METHOD_HMACSHA1,OAUTH_AUTH_TYPE_URI);
  $oauth->enableDebug();
  if(!isset($_GET['oauth_token']) && !$_SESSION['state']) {
    $request_token_info = $oauth->getRequestToken($req_url);
    $_SESSION['secret'] = $request_token_info['oauth_token_secret'];
    $_SESSION['state'] = 1;
    header('Location: '.$authurl.'?oauth_token='.$request_token_info['oauth_token']);
    exit;
  } else if($_SESSION['state']==1) {
    $oauth->setToken($_GET['oauth_token'],$_SESSION['secret']);
    $access_token_info = $oauth->getAccessToken($acc_url);
    $_SESSION['state'] = 2;
    $_SESSION['token'] = $access_token_info['oauth_token'];
    $_SESSION['secret'] = $access_token_info['oauth_token_secret'];
  }
  $oauth->setToken($_SESSION['token'],$_SESSION['secret']);
  $oauth->fetch("$api_url/user.json");
  $json = json_decode($oauth->getLastResponse());
  print_r($json);
} catch(OAuthException $E) {
  print_r($E);
}
?>

Örnekler
OAuth İşlevleri
Örnekler


OAuth İşlevleri

İçindekiler

  • oauth_get_sbs — Generate a Signature Base String
  • oauth_urlencode — Encode a URI to RFC 3986
FireEagle
oauth_get_sbs
OAuth


Generate a Signature Base String

OAuth İşlevleri
oauth_urlencode
OAuth İşlevleri
PHP Manual

oauth_get_sbs

(PECL OAuth >=0.99.7)

oauth_get_sbs — Generate a Signature Base String

Açıklama

string oauth_get_sbs ( string $http_method , string $uri [, array $request_parameters ] )

Generates a Signature Base String according to pecl/oauth.

Değiştirgeler

http_method

The HTTP method.

uri

URI to encode.

request_parameters

Array of request parameters.

Dönen Değerler

Returns a Signature Base String.

OAuth İşlevleri
oauth_urlencode
OAuth İşlevleri


Encode a URI to RFC 3986

oauth_get_sbs
OAuth
OAuth İşlevleri
PHP Manual

oauth_urlencode

(PECL OAuth >=0.99.2)

oauth_urlencode — Encode a URI to RFC 3986

Açıklama

string oauth_urlencode ( string $uri )

Encodes a URI to » RFC 3986.

Değiştirgeler

uri

URI to encode.

Dönen Değerler

Returns an » RFC 3986 encoded string.

oauth_get_sbs
OAuth
OAuth İşlevleri


The OAuth class

(PECL OAuth >= 0.99.1)

Giriş

The OAuth extension provides a simple interface to interact with data providers using the OAuth HTTP specification to protect private resources.

Sınıf Sözdizimi

OAuth {
/* Özellikler */
public $debug ;
public $sslChecks ;
public $debugInfo ;
/* Yöntemler */
public __construct ( string $consumer_key , string $consumer_secret [, string $signature_method = OAUTH_SIG_METHOD_HMACSHA1 [, int $auth_type = 0 ]] )
public void __destruct ( void )
public bool disableDebug ( void )
public bool disableRedirects ( void )
public bool disableSSLChecks ( void )
public bool enableDebug ( void )
public bool enableRedirects ( void )
public bool enableSSLChecks ( void )
public mixed fetch ( string $protected_resource_url [, array $extra_parameters [, string $http_method [, array $http_headers ]]] )
public string generateSignature ( string $http_method , string $url [, mixed $extra_parameters ] )
public array getAccessToken ( string $access_token_url [, string $auth_session_handle [, string $verifier_token [, string $http_method ]]] )
public array getCAPath ( void )
public string getLastResponse ( void )
public string getLastResponseHeaders ( void )
public array getLastResponseInfo ( void )
public string getRequestHeader ( string $http_method , string $url [, mixed $extra_parameters ] )
public array getRequestToken ( string $request_token_url [, string $callback_url [, string $http_method ]] )
public mixed setAuthType ( int $auth_type )
public mixed setCAPath ([ string $ca_path [, string $ca_info ]] )
public mixed setNonce ( string $nonce )
public void setRequestEngine ( int $reqengine )
public mixed setRSACertificate ( string $cert )
public bool setSSLChecks ( int $sslcheck )
public mixed setTimestamp ( string $timestamp )
public bool setToken ( string $token , string $token_secret )
public bool setVersion ( string $version )
}

Özellikler

debug

sslChecks

debugInfo

İçindekiler

  • OAuth::__construct — Create a new OAuth object
  • OAuth::__destruct — The destructor
  • OAuth::disableDebug — Turn off verbose debugging
  • OAuth::disableRedirects — Turn off redirects
  • OAuth::disableSSLChecks — Turn off SSL checks
  • OAuth::enableDebug — Turn on verbose debugging
  • OAuth::enableRedirects — Turn on redirects
  • OAuth::enableSSLChecks — Turn on SSL checks
  • OAuth::fetch — Fetch an OAuth protected resource
  • OAuth::generateSignature — Generate a signature
  • OAuth::getAccessToken — Fetch an access token
  • OAuth::getCAPath — Gets CA information
  • OAuth::getLastResponse — Get the last response
  • OAuth::getLastResponseHeaders — Get headers for last response
  • OAuth::getLastResponseInfo — Get HTTP information about the last response
  • OAuth::getRequestHeader — Generate OAuth header string signature
  • OAuth::getRequestToken — Fetch a request token
  • OAuth::setAuthType — Set authorization type
  • OAuth::setCAPath — Set CA path and info
  • OAuth::setNonce — Set the nonce for subsequent requests
  • OAuth::setRequestEngine — The setRequestEngine purpose
  • OAuth::setRSACertificate — Set the RSA certificate
  • OAuth::setSSLChecks — Tweak specific SSL checks for requests.
  • OAuth::setTimestamp — Set the timestamp
  • OAuth::setToken — Sets the token and secret
  • OAuth::setVersion — Set the OAuth version
oauth_urlencode
OAuth::__construct
OAuth


Create a new OAuth object

OAuth
OAuth::__destruct
OAuth
PHP Manual

OAuth::__construct

(PECL OAuth >= 0.99.1)

OAuth::__construct — Create a new OAuth object

Açıklama

public OAuth::__construct ( string $consumer_key , string $consumer_secret [, string $signature_method = OAUTH_SIG_METHOD_HMACSHA1 [, int $auth_type = 0 ]] )

Creates a new OAuth object

Değiştirgeler

consumer_key

The consumer key provided by the service provider.

consumer_secret

The consumer secret provided by the service provider.

signature_method

This optional parameter defines which signature method to use, by default it is OAUTH_SIG_METHOD_HMACSHA1 (HMAC-SHA1).

auth_type

This optional parameter defines how to pass the OAuth parameters to a consumer, by default it is OAUTH_AUTH_TYPE_AUTHORIZATION (in the Authorization header).

OAuth
OAuth::__destruct
OAuth


The destructor

OAuth::__construct
OAuth::disableDebug
OAuth
PHP Manual

OAuth::__destruct

(PECL OAuth >= 0.99.9)

OAuth::__destruct — The destructor

Açıklama

public void OAuth::__destruct ( void )

The destructor.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • OAuth::__construct() - Create a new OAuth object
OAuth::__construct
OAuth::disableDebug
OAuth


Turn off verbose debugging

OAuth::__destruct
OAuth::disableRedirects
OAuth
PHP Manual

OAuth::disableDebug

(PECL OAuth >= 0.99.3)

OAuth::disableDebug — Turn off verbose debugging

Açıklama

public bool OAuth::disableDebug ( void )

Turns off verbose request information (off by default). Alternatively, the debug property can be set to a FALSE value to turn debug off.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

TRUE

Sürüm Bilgisi

Sürüm: | Açıklama
0.99.8 | The related debug property was added.

Ayrıca Bakınız

  • OAuth::enableDebug() - Turn on verbose debugging

OAuth::__destruct
OAuth::disableRedirects
OAuth


Turn off redirects

OAuth::disableDebug
OAuth::disableSSLChecks
OAuth
PHP Manual

OAuth::disableRedirects

(PECL OAuth >= 0.99.9)

OAuth::disableRedirects — Turn off redirects

Açıklama

public bool OAuth::disableRedirects ( void )

Disable redirects from being followed automatically, thus allowing the request to be manually redirected.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

TRUE

Ayrıca Bakınız

  • OAuth::enableRedirects() - Turn on redirects
OAuth::disableDebug
OAuth::disableSSLChecks
OAuth


Turn off SSL checks

OAuth::disableRedirects
OAuth::enableDebug
OAuth
PHP Manual

OAuth::disableSSLChecks

(PECL OAuth >= 0.99.5)

OAuth::disableSSLChecks — Turn off SSL checks

Açıklama

public bool OAuth::disableSSLChecks ( void )

Turns off the usual SSL peer certificate and host checks, this is not for production environments. Alternatively, the sslChecks member can be set to FALSE to turn SSL checks off.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

TRUE

Sürüm Bilgisi

Sürüm: | Açıklama
0.99.8 | The sslChecks member was added

Ayrıca Bakınız

  • OAuth::enableSSLChecks() - Turn on SSL checks

OAuth::disableRedirects
OAuth::enableDebug
OAuth


Turn on verbose debugging

OAuth::disableSSLChecks
OAuth::enableRedirects
OAuth
PHP Manual

OAuth::enableDebug

(PECL OAuth >= 0.99.3)

OAuth::enableDebug — Turn on verbose debugging

Açıklama

public bool OAuth::enableDebug ( void )

Turns on verbose request information useful for debugging, the debug information is stored in the debugInfo member. Alternatively, the debug member can be set to a non-FALSE value to turn debug on.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

TRUE

Sürüm Bilgisi

Sürüm: | Açıklama
0.99.8 | The debug and debugInfo members were added

Ayrıca Bakınız

  • OAuth::disableDebug() - Turn off verbose debugging

OAuth::disableSSLChecks
OAuth::enableRedirects
OAuth


Turn on redirects

OAuth::enableDebug
OAuth::enableSSLChecks
OAuth
PHP Manual

OAuth::enableRedirects

(PECL OAuth >= 0.99.9)

OAuth::enableRedirects — Turn on redirects

Açıklama

public bool OAuth::enableRedirects ( void )

Follow and sign redirects automatically, which is enabled by default.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

TRUE

Ayrıca Bakınız

  • OAuth::disableRedirects() - Turn off redirects
OAuth::enableDebug
OAuth::enableSSLChecks
OAuth


Turn on SSL checks

OAuth::enableRedirects
OAuth::fetch
OAuth
PHP Manual

OAuth::enableSSLChecks

(PECL OAuth >= 0.99.5)

OAuth::enableSSLChecks — Turn on SSL checks

Açıklama

public bool OAuth::enableSSLChecks ( void )

Turns on the usual SSL peer certificate and host checks (enabled by default). Alternatively, the sslChecks member can be set to a non-FALSE value to turn SSL checks off.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

TRUE

Sürüm Bilgisi

Sürüm: | Açıklama
0.99.8 | The sslChecks member was added

Ayrıca Bakınız

  • OAuth::disableSSLChecks() - Turn off SSL checks

OAuth::enableRedirects
OAuth::fetch
OAuth


Fetch an OAuth protected resource

OAuth::enableSSLChecks
OAuth::generateSignature
OAuth
PHP Manual

OAuth::fetch

(PECL OAuth >= 0.99.1)

OAuth::fetch — Fetch an OAuth protected resource

Açıklama

public mixed OAuth::fetch ( string $protected_resource_url [, array $extra_parameters [, string $http_method [, array $http_headers ]]] )

Fetch a resource.

Değiştirgeler

protected_resource_url

URL to the OAuth protected resource.

extra_parameters

Extra parameters to send with the request for the resource.

http_method

One of the OAUTH_HTTP_METHOD_* OAUTH constants, which includes GET, POST, PUT, HEAD, or DELETE.

HEAD (OAUTH_HTTP_METHOD_HEAD) can be useful for discovering information prior to the request (if OAuth credentials are in the Authorization header).

http_headers

HTTP client headers (such as User-Agent, Accept, etc.)

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
1.0.0 | Başarısızlık durumunda FALSE yerine evvelce NULL dönerdi.
0.99.5 | The http_method parameter was added
0.99.8 | The http_headers parameter was added

Örnekler

Örnek 1 OAuth::fetch() example

<?php
try {
    $oauth = new OAuth("consumer_key","consumer_secret",OAUTH_SIG_METHOD_HMACSHA1,OAUTH_AUTH_TYPE_AUTHORIZATION);
    $oauth->setToken("access_token","access_token_secret");

    $oauth->fetch("http://photos.example.net/photo?file=vacation.jpg");

    $response_info = $oauth->getLastResponseInfo();
    header("Content-Type: {$response_info["content_type"]}");
    echo $oauth->getLastResponse();
} catch(OAuthException $E) {
    echo "Exception caught!\n";
    echo "Response: ". $E->lastResponse . "\n";
}
?>

Ayrıca Bakınız

  • OAuth::getLastResponse() - Get the last response
  • OAuth::getLastResponseInfo() - Get HTTP information about the last response
  • OAuth::setToken() - Sets the token and secret

OAuth::enableSSLChecks
OAuth::generateSignature
OAuth


Generate a signature

OAuth::fetch
OAuth::getAccessToken
OAuth
PHP Manual

OAuth::generateSignature

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

OAuth::generateSignature — Generate a signature

Açıklama

public string OAuth::generateSignature ( string $http_method , string $url [, mixed $extra_parameters ] )

Generate a signature based on the final HTTP method, URL and a string/array of parameters.

Değiştirgeler

http_method

HTTP method for request

url

URL for request

extra_parameters

String or array of additional parameters.

Dönen Değerler

A string containing the generated signature başarısızlık durumunda FALSE döner

OAuth::fetch
OAuth::getAccessToken
OAuth


Fetch an access token

OAuth::generateSignature
OAuth::getCAPath
OAuth
PHP Manual

OAuth::getAccessToken

(PECL OAuth >= 0.99.1)

OAuth::getAccessToken — Fetch an access token

Açıklama

public array OAuth::getAccessToken ( string $access_token_url [, string $auth_session_handle [, string $verifier_token [, string $http_method ]]] )

Fetch an access token, secret and any additional response parameters from the service provider.

Değiştirgeler

access_token_url

URL to the access token API.

auth_session_handle

Authorization session handle, this parameter does not have any citation in the core OAuth 1.0 specification but may be implemented by large providers. » See ScalableOAuth for more information.

verifier_token

For service providers which support 1.0a, a verifier_token must be passed while exchanging the request token for the access token. If the verifier_token is present in $_GET or $_POST it is passed automatically and the caller does not need to specify a verifier_token (usually if the access token is exchanged at the oauth_callback URL). » See ScalableOAuth for more information.

http_method

HTTP method to use, e.g. GET or POST.

Dönen Değerler

Returns an array containing the parsed OAuth response on success or FALSE on failure.

Sürüm Bilgisi

Sürüm: | Açıklama
1.0.0 | Başarısızlık durumunda FALSE yerine evvelce NULL dönerdi.
0.99.9 | The verifier_token parameter was added

Örnekler

Örnek 1 OAuth::getAccessToken() example

<?php
try {
    $oauth = new OAuth(OAUTH_CONSUMER_KEY,OAUTH_CONSUMER_SECRET);
    $oauth->setToken($request_token,$request_token_secret);
    $access_token_info = $oauth->getAccessToken("https://example.com/oauth/access_token");
    if(!empty($access_token_info)) {
        print_r($access_token_info);
    } else {
        print "Failed fetching access token, response was: " . $oauth->getLastResponse();
    }
} catch(OAuthException $E) {
    echo "Response: ". $E->lastResponse . "\n";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [oauth_token] => some_token
    [oauth_token_secret] => some_token_secret
)

Ayrıca Bakınız

  • OAuth::getLastResponse() - Get the last response
  • OAuth::getLastResponseInfo() - Get HTTP information about the last response
  • OAuth::setToken() - Sets the token and secret

OAuth::generateSignature
OAuth::getCAPath
OAuth


Gets CA information

OAuth::getAccessToken
OAuth::getLastResponse
OAuth
PHP Manual

OAuth::getCAPath

(PECL OAuth >= 0.99.8)

OAuth::getCAPath — Gets CA information

Açıklama

public array OAuth::getCAPath ( void )

Gets the Certificate Authority information, which includes the ca_path and ca_info set by OAuth::setCaPath().

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

An array of Certificate Authority information, specifically as ca_path and ca_info keys within the returned associative array.

Ayrıca Bakınız

  • OAuth::setCAPath() - Set CA path and info
  • OAuth::getLastResponseInfo() - Get HTTP information about the last response
OAuth::getAccessToken
OAuth::getLastResponse
OAuth


Get the last response

OAuth::getCAPath
OAuth::getLastResponseHeaders
OAuth
PHP Manual

OAuth::getLastResponse

(PECL OAuth >= 0.99.1)

OAuth::getLastResponse — Get the last response

Açıklama

public string OAuth::getLastResponse ( void )

Get the raw response of the most recent request.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a string containing the last response.

Ayrıca Bakınız

  • OAuth::getLastResponseInfo() - Get HTTP information about the last response
  • OAuth::fetch() - Fetch an OAuth protected resource

OAuth::getCAPath
OAuth::getLastResponseHeaders
OAuth


Get headers for last response

OAuth::getLastResponse
OAuth::getLastResponseInfo
OAuth
PHP Manual

OAuth::getLastResponseHeaders

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

OAuth::getLastResponseHeaders — Get headers for last response

Açıklama

public string OAuth::getLastResponseHeaders ( void )

Get headers for last response.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A string containing the last response's headers başarısızlık durumunda FALSE döner

OAuth::getLastResponse
OAuth::getLastResponseInfo
OAuth


Get HTTP information about the last response

OAuth::getLastResponseHeaders
OAuth::getRequestHeader
OAuth
PHP Manual

OAuth::getLastResponseInfo

(PECL OAuth >= 0.99.1)

OAuth::getLastResponseInfo — Get HTTP information about the last response

Açıklama

public array OAuth::getLastResponseInfo ( void )

Get HTTP information about the last response.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns an array containing the response information for the last request. Constants from curl_getinfo() may be used.

Ayrıca Bakınız

  • OAuth::fetch() - Fetch an OAuth protected resource
  • OAuth::getLastResponse() - Get the last response

OAuth::getLastResponseHeaders
OAuth::getRequestHeader
OAuth


Generate OAuth header string signature

OAuth::getLastResponseInfo
OAuth::getRequestToken
OAuth
PHP Manual

OAuth::getRequestHeader

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

OAuth::getRequestHeader — Generate OAuth header string signature

Açıklama

public string OAuth::getRequestHeader ( string $http_method , string $url [, mixed $extra_parameters ] )

Generate OAuth header string signature based on the final HTTP method, URL and a string/array of parameters

Değiştirgeler

http_method

HTTP method for request.

url

URL for request.

extra_parameters

String or array of additional parameters.

Dönen Değerler

A string containing the generated request header başarısızlık durumunda FALSE döner

OAuth::getLastResponseInfo
OAuth::getRequestToken
OAuth


Fetch a request token

OAuth::getRequestHeader
OAuth::setAuthType
OAuth
PHP Manual

OAuth::getRequestToken

(PECL OAuth >= 0.99.1)

OAuth::getRequestToken — Fetch a request token

Açıklama

public array OAuth::getRequestToken ( string $request_token_url [, string $callback_url [, string $http_method ]] )

Fetch a request token, secret and any additional response parameters from the service provider.

Değiştirgeler

request_token_url

URL to the request token API.

callback_url

OAuth callback URL. If callback_url is passed and is an empty value, it is set to "oob" to address the OAuth 2009.1 advisory.

http_method

HTTP method to use, e.g. GET or POST.

Dönen Değerler

Returns an array containing the parsed OAuth response on success or FALSE on failure.

Sürüm Bilgisi

Sürüm: | Açıklama
1.0.0 | Başarısızlık durumunda FALSE yerine evvelce NULL dönerdi.
0.99.9 | The callback_url parameter was added

Örnekler

Örnek 1 OAuth::getRequestToken() example

<?php
try {
    $oauth = new OAuth(OAUTH_CONSUMER_KEY,OAUTH_CONSUMER_SECRET);
    $request_token_info = $oauth->getRequestToken("https://example.com/oauth/request_token");
    if(!empty($request_token_info)) {
        print_r($request_token_info);
    } else {
        print "Failed fetching request token, response was: " . $oauth->getLastResponse();
    }
} catch(OAuthException $E) {
    echo "Response: ". $E->lastResponse . "\n";
}
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Array
(
    [oauth_token] => some_token
    [oauth_token_secret] => some_token_secret
)

Ayrıca Bakınız

  • OAuth::getLastResponse() - Get the last response
  • OAuth::getLastResponseInfo() - Get HTTP information about the last response

OAuth::getRequestHeader
OAuth::setAuthType
OAuth


Set authorization type

OAuth::getRequestToken
OAuth::setCAPath
OAuth
PHP Manual

OAuth::setAuthType

(PECL OAuth >= 0.99.1)

OAuth::setAuthType — Set authorization type

Açıklama

public mixed OAuth::setAuthType ( int $auth_type )

Set where the OAuth parameters should be passed.

Değiştirgeler

auth_type

auth_type can be one of the following flags (in order of decreasing preference as per OAuth 1.0 section 5.2):

OAUTH_AUTH_TYPE_AUTHORIZATION
Pass the OAuth parameters in the HTTP Authorization header.
OAUTH_AUTH_TYPE_FORM
Append the OAuth parameters to the HTTP POST request body.
OAUTH_AUTH_TYPE_URI
Append the OAuth parameters to the request URI.
OAUTH_AUTH_TYPE_NONE
None.

Dönen Değerler

Returns TRUE if a parameter is correctly set, otherwise FALSE (e.g., if an invalid auth_type is passed in.)

Sürüm Bilgisi

Sürüm: | Açıklama
1.0.0 | Başarısızlık durumunda FALSE yerine evvelce NULL dönerdi.

OAuth::getRequestToken
OAuth::setCAPath
OAuth


Set CA path and info

OAuth::setAuthType
OAuth::setNonce
OAuth
PHP Manual

OAuth::setCAPath

(PECL OAuth >= 0.99.8)

OAuth::setCAPath — Set CA path and info

Açıklama

public mixed OAuth::setCAPath ([ string $ca_path [, string $ca_info ]] )

Sets the Certificate Authority (CA), both for path and info.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

ca_path

The CA Path being set.

ca_info

The CA Info being set.

Dönen Değerler

Returns TRUE on success, or FALSE if either ca_path or ca_info are considered invalid.

Sürüm Bilgisi

Sürüm: | Açıklama
1.0.0 | Başarısızlık durumunda FALSE yerine evvelce NULL dönerdi.

Ayrıca Bakınız

  • OAuth::getCaPath() - Gets CA information
OAuth::setAuthType
OAuth::setNonce
OAuth


Set the nonce for subsequent requests

OAuth::setCAPath
OAuth::setRequestEngine
OAuth
PHP Manual

OAuth::setNonce

(PECL OAuth >= 0.99.1)

OAuth::setNonce — Set the nonce for subsequent requests

Açıklama

public mixed OAuth::setNonce ( string $nonce )

Sets the nonce for all subsequent requests.

Değiştirgeler

nonce

The value for oauth_nonce.

Dönen Değerler

Returns TRUE on success, or FALSE if the nonce is considered invalid.

Sürüm Bilgisi

Sürüm: | Açıklama
1.0.0 | Başarısızlık durumunda FALSE yerine evvelce NULL dönerdi.

Ayrıca Bakınız

  • OAuth::setToken() - Sets the token and secret
  • OAuth::setAuthType() - Set authorization type
  • OAuth::setVersion() - Set the OAuth version

OAuth::setCAPath
OAuth::setRequestEngine
OAuth


The setRequestEngine purpose

OAuth::setNonce
OAuth::setRSACertificate
OAuth
PHP Manual

OAuth::setRequestEngine

(PECL OAuth >= 1.0.0)

OAuth::setRequestEngine — The setRequestEngine purpose

Açıklama

public void OAuth::setRequestEngine ( int $reqengine )

Sets the Request Engine, that will be sending the HTTP requests.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

reqengine

The desired request engine. Set to OAUTH_REQENGINE_STREAMS to use PHP Streams, or OAUTH_REQENGINE_CURL to use Curl.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

Emits an OAuthException exception if an invalid request engine is chosen.

Örnekler

Örnek 1 OAuth::setRequestEngine() example

<?php
$consumer = new OAuth();

$consumer->setRequestEngine(OAUTH_REQENGINE_STREAMS);
?>

Ayrıca Bakınız

  • Curl
  • PHP streams
  • OAuthException
OAuth::setNonce
OAuth::setRSACertificate
OAuth


Set the RSA certificate

OAuth::setRequestEngine
OAuth::setSSLChecks
OAuth
PHP Manual

OAuth::setRSACertificate

(PECL OAuth >= 1.0.0)

OAuth::setRSACertificate — Set the RSA certificate

Açıklama

public mixed OAuth::setRSACertificate ( string $cert )

Sets the RSA certificate.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

cert

The RSA certificate.

Dönen Değerler

Returns TRUE on success, or FALSE on failure (e.g., the RSA certificate cannot be parsed.)

Sürüm Bilgisi

Sürüm: | Açıklama
1.0.0 | Başarısızlık durumunda FALSE yerine evvelce NULL dönerdi.

Örnekler

Örnek 1 An OAuth::setRsaCertificate() example

<?php
$consume = new OAuth('1234', '', OAUTH_SIG_METHOD_RSASHA1);

$consume->setRSACertificate(file_get_contents('test.pem'));
?>

Ayrıca Bakınız

  • OAuth::setCaPath() - Set CA path and info
OAuth::setRequestEngine
OAuth::setSSLChecks
OAuth


Tweak specific SSL checks for requests.

OAuth::setRSACertificate
OAuth::setTimestamp
OAuth
PHP Manual

OAuth::setSSLChecks

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

OAuth::setSSLChecks — Tweak specific SSL checks for requests.

Açıklama

public bool OAuth::setSSLChecks ( int $sslcheck )

Tweak specific SSL checks for requests.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

sslcheck

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

OAuth::setRSACertificate
OAuth::setTimestamp
OAuth


Set the timestamp

OAuth::setSSLChecks
OAuth::setToken
OAuth
PHP Manual

OAuth::setTimestamp

(PECL OAuth >= 1.0.0)

OAuth::setTimestamp — Set the timestamp

Açıklama

public mixed OAuth::setTimestamp ( string $timestamp )

Sets the OAuth timestamp for subsequent requests.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

timestamp

The timestamp.

Dönen Değerler

Returns TRUE, unless the timestamp is invalid, in which case FALSE is returned.

Sürüm Bilgisi

Sürüm: | Açıklama
1.0.0 | Başarısızlık durumunda FALSE yerine evvelce NULL dönerdi.

Ayrıca Bakınız

  • OAuth::setNonce() - Set the nonce for subsequent requests
OAuth::setSSLChecks
OAuth::setToken
OAuth


Sets the token and secret

OAuth::setTimestamp
OAuth::setVersion
OAuth
PHP Manual

OAuth::setToken

(PECL OAuth >= 0.99.1)

OAuth::setToken — Sets the token and secret

Açıklama

public bool OAuth::setToken ( string $token , string $token_secret )

Set the token and secret for subsequent requests.

Değiştirgeler

token

The OAuth token.

token_secret

The OAuth token secret.

Dönen Değerler

TRUE

Örnekler

Örnek 1 OAuth::setToken() example

<?php
$oauth = new OAuth(OAUTH_CONSUMER_KEY,OAUTH_CONSUMER_SECRET);
$oauth->setToken("token","token-secret");
?>

OAuth::setTimestamp
OAuth::setVersion
OAuth


Set the OAuth version

OAuth::setToken
OAuthProvider
OAuth
PHP Manual

OAuth::setVersion

(PECL OAuth >= 0.99.1)

OAuth::setVersion — Set the OAuth version

Açıklama

public bool OAuth::setVersion ( string $version )

Sets the OAuth version for subsequent requests

Değiştirgeler

version

OAuth version, default value is always "1.0"

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

OAuth::setToken
OAuthProvider
OAuth


The OAuthProvider class

(PECL OAuth >= 1.0.0)

Giriş

Manages an OAuth provider class.

See also an external in-depth tutorial titled » Writing an OAuth Provider Service, which takes a hands-on approach to providing this service. There are also » OAuth provider examples within the OAuth extensions sources.

Sınıf Sözdizimi

OAuthProvider {
/* Methods */
final public bool addRequiredParameter ( string $req_params )
public void callconsumerHandler ( void )
public void callTimestampNonceHandler ( void )
public void calltokenHandler ( void )
public void checkOAuthRequest ([ string $uri [, string $method ]] )
public __construct ([ array $params_array ] )
public void consumerHandler ( callable $callback_function )
final public static string generateToken ( int $size [, bool $strong = false ] )
public void is2LeggedEndpoint ( mixed $params_array )
public void isRequestTokenEndpoint ( bool $will_issue_request_token )
final public bool removeRequiredParameter ( string $req_params )
final public static string reportProblem ( string $oauthexception [, bool $send_headers = true ] )
final public bool setParam ( string $param_key [, mixed $param_val ] )
final public bool setRequestTokenPath ( string $path )
public void timestampNonceHandler ( callable $callback_function )
public void tokenHandler ( callable $callback_function )
}

İçindekiler

  • OAuthProvider::addRequiredParameter — Add required parameters
  • OAuthProvider::callconsumerHandler — Calls the consumerNonceHandler callback
  • OAuthProvider::callTimestampNonceHandler — Calls the timestampNonceHandler callback
  • OAuthProvider::calltokenHandler — Calls the tokenNonceHandler callback
  • OAuthProvider::checkOAuthRequest — Check an oauth request
  • OAuthProvider::__construct — Constructs a new OAuthProvider object
  • OAuthProvider::consumerHandler — Set the consumerHandler handler callback
  • OAuthProvider::generateToken — Generate a random token
  • OAuthProvider::is2LeggedEndpoint — is2LeggedEndpoint
  • OAuthProvider::isRequestTokenEndpoint — Sets isRequestTokenEndpoint
  • OAuthProvider::removeRequiredParameter — Remove a required parameter
  • OAuthProvider::reportProblem — Report a problem
  • OAuthProvider::setParam — Set a parameter
  • OAuthProvider::setRequestTokenPath — Set request token path
  • OAuthProvider::timestampNonceHandler — Set the timestampNonceHandler handler callback
  • OAuthProvider::tokenHandler — Set the tokenHandler handler callback
OAuth::setVersion
OAuthProvider::addRequiredParameter
OAuth


Add required parameters

OAuthProvider
OAuthProvider::callconsumerHandler
OAuthProvider
PHP Manual

OAuthProvider::addRequiredParameter

(PECL OAuth >= 1.0.0)

OAuthProvider::addRequiredParameter — Add required parameters

Açıklama

final public bool OAuthProvider::addRequiredParameter ( string $req_params )

Add required oauth provider parameters.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

req_params

The required parameters.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • OAuthProvider::removeRequiredParameter() - Remove a required parameter
OAuthProvider
OAuthProvider::callconsumerHandler
OAuthProvider


Calls the consumerNonceHandler callback

OAuthProvider::addRequiredParameter
OAuthProvider::callTimestampNonceHandler
OAuthProvider
PHP Manual

OAuthProvider::callconsumerHandler

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

OAuthProvider::callconsumerHandler — Calls the consumerNonceHandler callback

Açıklama

public void OAuthProvider::callconsumerHandler ( void )

Calls the registered consumer handler callback function, which is set with OAuthProvider::consumerHandler().

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

Bir geriçağırım işlevi belirtilmemişse veya çağrılamazsa E_ERROR seviyesinden bir ileti çıktılanır.

Ayrıca Bakınız

  • OAuthProvider::consumerHandler() - Set the consumerHandler handler callback
OAuthProvider::addRequiredParameter
OAuthProvider::callTimestampNonceHandler
OAuthProvider


Calls the timestampNonceHandler callback

OAuthProvider::callconsumerHandler
OAuthProvider::calltokenHandler
OAuthProvider
PHP Manual

OAuthProvider::callTimestampNonceHandler

(PECL OAuth >= 1.0.0)

OAuthProvider::callTimestampNonceHandler — Calls the timestampNonceHandler callback

Açıklama

public void OAuthProvider::callTimestampNonceHandler ( void )

Calls the registered timestamp handler callback function, which is set with OAuthProvider::timestampNonceHandler().

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

Bir geriçağırım işlevi belirtilmemişse veya çağrılamazsa E_ERROR seviyesinden bir ileti çıktılanır.

Ayrıca Bakınız

  • OAuthProvider::timestampNonceHandler() - Set the timestampNonceHandler handler callback
OAuthProvider::callconsumerHandler
OAuthProvider::calltokenHandler
OAuthProvider


Calls the tokenNonceHandler callback

OAuthProvider::callTimestampNonceHandler
OAuthProvider::checkOAuthRequest
OAuthProvider
PHP Manual

OAuthProvider::calltokenHandler

(PECL OAuth >= 1.0.0)

OAuthProvider::calltokenHandler — Calls the tokenNonceHandler callback

Açıklama

public void OAuthProvider::calltokenHandler ( void )

Calls the registered token handler callback function, which is set with OAuthProvider::tokenHandler().

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

Bir geriçağırım işlevi belirtilmemişse veya çağrılamazsa E_ERROR seviyesinden bir ileti çıktılanır.

Ayrıca Bakınız

  • OAuthProvider::tokenHandler() - Set the tokenHandler handler callback
OAuthProvider::callTimestampNonceHandler
OAuthProvider::checkOAuthRequest
OAuthProvider


Check an oauth request

OAuthProvider::calltokenHandler
OAuthProvider::__construct
OAuthProvider
PHP Manual

OAuthProvider::checkOAuthRequest

(PECL OAuth >= 1.0.0)

OAuthProvider::checkOAuthRequest — Check an oauth request

Açıklama

public void OAuthProvider::checkOAuthRequest ([ string $uri [, string $method ]] )

Checks an OAuth request.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

uri

The optional URI, or endpoint.

method

The HTTP method. Optionally pass in one of the OAUTH_HTTP_METHOD_* OAuth constants.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

Emits an E_ERROR level error if the HTTP method cannot be detected.

Ayrıca Bakınız

  • OAuthProvider::reportProblem() - Report a problem
OAuthProvider::calltokenHandler
OAuthProvider::__construct
OAuthProvider


Constructs a new OAuthProvider object

OAuthProvider::checkOAuthRequest
OAuthProvider::consumerHandler
OAuthProvider
PHP Manual

OAuthProvider::__construct

(PECL OAuth >= 1.0.0)

OAuthProvider::__construct — Constructs a new OAuthProvider object

Açıklama

public OAuthProvider::__construct ([ array $params_array ] )

Initiates a new OAuthProvider object.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

params_array

Setting these optional parameters is limited to the CLI SAPI.

Dönen Değerler

An OAuthProvider object.

Örnekler

Örnek 1 OAuthProvider::__construct() example

<?php
try {

    $op = new OAuthProvider();

    // Uses user-defined callback functions
    $op->consumerHandler(array($this, 'lookupConsumer'));
    $op->timestampNonceHandler(array($this, 'timestampNonceChecker'));
    $op->tokenHandler(array($this, 'myTokenHandler'));

    // Ignore the foo_uri parameter
    $op->setParam('foo_uri', NULL);

    // No token needed for this end point
    $op->setRequestTokenPath('/v1/oauth/request_token');

    $op->checkOAuthRequest();

} catch (OAuthException $e) {

    echo OAuthProvider::reportProblem($e);
}
?>

Ayrıca Bakınız

  • OAuthProvider::setParam() - Set a parameter
OAuthProvider::checkOAuthRequest
OAuthProvider::consumerHandler
OAuthProvider


Set the consumerHandler handler callback

OAuthProvider::__construct
OAuthProvider::generateToken
OAuthProvider
PHP Manual

OAuthProvider::consumerHandler

(PECL OAuth >= 1.0.0)

OAuthProvider::consumerHandler — Set the consumerHandler handler callback

Açıklama

public void OAuthProvider::consumerHandler ( callable $callback_function )

Sets the consumer handler callback, which will later be called with OAuthProvider::callConsumerHandler().

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

callback_function

The callable functions name.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Example OAuthProvider::consumerHandler() callback

<?php
function lookupConsumer($provider) {

    if ($provider->consumer_key === 'unknown') {
        return OAUTH_CONSUMER_KEY_UNKNOWN;
    } else if($provider->consumer_key == 'blacklisted' || $provider->consumer_key === 'throttled') {
        return OAUTH_CONSUMER_KEY_REFUSED;
    }

    $provider->consumer_secret = "the_consumers_secret";

    return OAUTH_OK;
}
?>

Ayrıca Bakınız

  • OAuthProvider::callConsumerHandler() - Calls the consumerNonceHandler callback
OAuthProvider::__construct
OAuthProvider::generateToken
OAuthProvider


Generate a random token

OAuthProvider::consumerHandler
OAuthProvider::is2LeggedEndpoint
OAuthProvider
PHP Manual

OAuthProvider::generateToken

(PECL OAuth >= 1.0.0)

OAuthProvider::generateToken — Generate a random token

Açıklama

final public static string OAuthProvider::generateToken ( int $size [, bool $strong = false ] )

Generates a string of pseudo-random bytes.

Değiştirgeler

size

The desired token length, in terms of bytes.

strong

Setting to TRUE means /dev/random will be used for entropy, as otherwise the non-blocking /dev/urandom is used. This parameter is ignored on Windows.

Dönen Değerler

The generated token, as a string of bytes.

Hatalar/İstisnalar

If the strong parameter is TRUE, then an E_WARNING level error will be emitted when the fallback rand() implementation is used to fill the remaining random bytes (e.g., when not enough random data was found, initially).

Örnekler

Örnek 1 OAuthProvider::generateToken() example

<?php
$p = new OAuthProvider();

$t = $p->generateToken(4);

echo strlen($t),  PHP_EOL;
echo bin2hex($t), PHP_EOL;

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

4
b6a82c27

Notlar

Bilginize:

When not enough random data is available to the system, this function will fill the remaining random bytes using the internal PHP rand() implementation.

Ayrıca Bakınız

  • openssl_random_pseudo_bytes() - Yarı-rasgele dizge üretir
  • mcrypt_create_iv() - Rasgele bir kaynaktan bir ilklendirme vektörü (IV) oluşturur
OAuthProvider::consumerHandler
OAuthProvider::is2LeggedEndpoint
OAuthProvider


is2LeggedEndpoint

OAuthProvider::generateToken
OAuthProvider::isRequestTokenEndpoint
OAuthProvider
PHP Manual

OAuthProvider::is2LeggedEndpoint

(PECL OAuth >= 1.0.0)

OAuthProvider::is2LeggedEndpoint — is2LeggedEndpoint

Açıklama

public void OAuthProvider::is2LeggedEndpoint ( mixed $params_array )

The 2-legged flow, or request signing. It does not require a token.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

params_array

Dönen Değerler

An OAuthProvider object.

Örnekler

Örnek 1 OAuthProvider::is2LeggedEndpoint() example

<?php

$provider = new OAuthProvider();

$provider->is2LeggedEndpoint(true);

?>

Ayrıca Bakınız

  • OAuthProvider::__construct() - Constructs a new OAuthProvider object
OAuthProvider::generateToken
OAuthProvider::isRequestTokenEndpoint
OAuthProvider


Sets isRequestTokenEndpoint

OAuthProvider::is2LeggedEndpoint
OAuthProvider::removeRequiredParameter
OAuthProvider
PHP Manual

OAuthProvider::isRequestTokenEndpoint

(PECL OAuth >= 1.0.0)

OAuthProvider::isRequestTokenEndpoint — Sets isRequestTokenEndpoint

Açıklama

public void OAuthProvider::isRequestTokenEndpoint ( bool $will_issue_request_token )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

will_issue_request_token

Sets whether or not it will issue a request token, thus determining if OAuthProvider::tokenHandler() needs to be called.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • OAuthProvider::setRequestTokenPath() - Set request token path
  • OAuthProvider::reportProblem() - Report a problem
OAuthProvider::is2LeggedEndpoint
OAuthProvider::removeRequiredParameter
OAuthProvider


Remove a required parameter

OAuthProvider::isRequestTokenEndpoint
OAuthProvider::reportProblem
OAuthProvider
PHP Manual

OAuthProvider::removeRequiredParameter

(PECL OAuth >= 1.0.0)

OAuthProvider::removeRequiredParameter — Remove a required parameter

Açıklama

final public bool OAuthProvider::removeRequiredParameter ( string $req_params )

Removes a required parameter.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

req_params

The required parameter to be removed.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • OAuthProvider::setParam() - Set a parameter
  • OAuthProvider::addRequiredParameter() - Add required parameters
OAuthProvider::isRequestTokenEndpoint
OAuthProvider::reportProblem
OAuthProvider


Report a problem

OAuthProvider::removeRequiredParameter
OAuthProvider::setParam
OAuthProvider
PHP Manual

OAuthProvider::reportProblem

(PECL OAuth >= 1.0.0)

OAuthProvider::reportProblem — Report a problem

Açıklama

final public static string OAuthProvider::reportProblem ( string $oauthexception [, bool $send_headers = true ] )

Pass in a problem as an OAuthException, with possible problems listed in the OAuth constants section.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

oauthexception

The OAuthException.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • OAuthProvider::checkOAuthRequest() - Check an oauth request
  • OAuthProvider::isRequestTokenEndpoint() - Sets isRequestTokenEndpoint
OAuthProvider::removeRequiredParameter
OAuthProvider::setParam
OAuthProvider


Set a parameter

OAuthProvider::reportProblem
OAuthProvider::setRequestTokenPath
OAuthProvider
PHP Manual

OAuthProvider::setParam

(PECL OAuth >= 1.0.0)

OAuthProvider::setParam — Set a parameter

Açıklama

final public bool OAuthProvider::setParam ( string $param_key [, mixed $param_val ] )

Sets a parameter.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

param_key

The parameter key.

param_val

The optional parameter value.

To exclude a parameter from signature verification, set its value to NULL.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • OAuthProvider::addRequiredParameter() - Add required parameters
OAuthProvider::reportProblem
OAuthProvider::setRequestTokenPath
OAuthProvider


Set request token path

OAuthProvider::setParam
OAuthProvider::timestampNonceHandler
OAuthProvider
PHP Manual

OAuthProvider::setRequestTokenPath

(PECL OAuth >= 1.0.0)

OAuthProvider::setRequestTokenPath — Set request token path

Açıklama

final public bool OAuthProvider::setRequestTokenPath ( string $path )

Sets the request tokens path.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

path

The path.

Dönen Değerler

TRUE

Ayrıca Bakınız

  • OAuthProvider::tokenHandler() - Set the tokenHandler handler callback
OAuthProvider::setParam
OAuthProvider::timestampNonceHandler
OAuthProvider


Set the timestampNonceHandler handler callback

OAuthProvider::setRequestTokenPath
OAuthProvider::tokenHandler
OAuthProvider
PHP Manual

OAuthProvider::timestampNonceHandler

(PECL OAuth >= 1.0.0)

OAuthProvider::timestampNonceHandler — Set the timestampNonceHandler handler callback

Açıklama

public void OAuthProvider::timestampNonceHandler ( callable $callback_function )

Sets the timestamp nonce handler callback, which will later be called with OAuthProvider::callTimestampNonceHandler(). Errors related to timestamp/nonce are thrown to this callback.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

callback_function

The callable functions name.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Example OAuthProvider::timestampNonceHandler() callback

<?php
function timestampNonceChecker($provider) {

    if ($provider->nonce === 'bad') {
        return OAUTH_BAD_NONCE;
    } elseif ($provider->timestamp == '0') {
        return OAUTH_BAD_TIMESTAMP;
    }

    return OAUTH_OK;
}
?>

Ayrıca Bakınız

  • OAuthProvider::callTimestampNonceHandler() - Calls the timestampNonceHandler callback
OAuthProvider::setRequestTokenPath
OAuthProvider::tokenHandler
OAuthProvider


Set the tokenHandler handler callback

OAuthProvider::timestampNonceHandler
OAuthException
OAuthProvider
PHP Manual

OAuthProvider::tokenHandler

(PECL OAuth >= 1.0.0)

OAuthProvider::tokenHandler — Set the tokenHandler handler callback

Açıklama

public void OAuthProvider::tokenHandler ( callable $callback_function )

Sets the token handler callback, which will later be called with OAuthProvider::callTokenHandler().

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

callback_function

The callable functions name.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 Example OAuthProvider::tokenHandler() callback

<?php
function tokenHandler($provider) {

    if ($provider->token === 'rejected') {
        return OAUTH_TOKEN_REJECTED;
    } elseif ($provider->token === 'revoked') {
        return OAUTH_TOKEN_REVOKED;
    }

    $provider->token_secret = "the_tokens_secret";
    return OAUTH_OK;
}
?>

Ayrıca Bakınız

  • OAuthProvider::callTokenHandler() - Calls the tokenNonceHandler callback
OAuthProvider::timestampNonceHandler
OAuthException
OAuthProvider


OAuthException class

(PECL OAuth >= 0.99.1)

Giriş

This exception is thrown when exceptional errors occur while using the OAuth extension and contains useful debugging information.

Sınıf Sözdizimi

OAuthException extends Exception {
/* Özellikler */
public $lastResponse ;
public $debugInfo ;
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}

Özellikler

lastResponse

The response of the exception which occurred, if any

debugInfo

OAuthProvider::tokenHandler
SCA
OAuth


SCA

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
    • The structure of a Service Component
    • Obtaining a proxy for another Service Component
    • Calling another Service Component
    • Locating and calling services from a script which is not an SCA Component
    • Exposing a Service Component as a Web service
    • Deploying an SCA component
    • Obtaining the WSDL for an SCA component offering a Service as a Web service
    • Understanding how the WSDL is generated
    • Working with Data Structures
    • Error handling
  • SCA İşlevleri
    • SCA::createDataObject — create an SDO
    • SCA::getService — Obtain a proxy for a service
    • SCA_LocalProxy::createDataObject — create an SDO
    • SCA_SoapProxy::createDataObject — create an SDO
OAuthException
Giriş
HTTP Hizmetleri


Giriş

Uyarı

Bu eklenti DENEYSELDİR. Bu eklentinin davranışı, işlev isimleri ve tüm belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu eklentiyi kullanmayın.

SCA for PHP makes it possible for a PHP programmer to write reusable components, which can be called in a variety of ways, with an identical interface and with a minimum of fuss. At present components can call each other either locally or via Web services, but in the future it is expected that other ways will be possible. It provides the programmer with a way of doing this which will look as natural as possible in PHP.

SCA components use phpDocumentor-style (see http://www.phpdoc.org/) annotations to declare dependencies on other SCA components or Web services. The SCA for PHP runtime resolves these dependencies at runtime on behalf of the components, and thus allows the PHP programmer to focus on the business logic rather than on locating and obtaining references to dependencies.

The SCA for PHP programming model can be extended to support a number of service types, such as REST and Atompub. However, Web services (more accurately, WSDL defined, SOAP/HTTP services), are the only type currently specified.

Components also use annotations to define the interface which they expose as a service. The SCA for PHP runtime will automatically generate WSDL from these annotations, so that an SCA component is easily exposed as a web service. These annotations are a natural extension to those provided by phpDocumentor. Deploying a Web service can be as simple as placing a PHP component under the document root of a web server.

Components also use annotations to specify data structures (expressed using XML schema complex types) which are then handled using Service Data Objects (SDOs).

A PHP script which is not an SCA component and which contains no annotations can use the services of an SCA component. A PHP script or component can make calls to a web service that is not an SCA component, but using the same system of calls or annotations to obtain a reference.

First we show a single SCA component, ConvertedStockQuote which illustrates many of the features of SCA for PHP. It has one method, getQuote(), which given a stock "ticker" obtains a price quote for that stock, converted to a given currency. We shall be using this example as a basis for explaining the SCA for PHP throughout the rest of this document.

Örnek 1 A sample SCA component

<?php

include "SCA/SCA.php";

/**
 * Calculate a stock price for a given ticker symbol in a given currency.
 *
 * @service
 * @binding.soap
 */
class ConvertedStockQuote {

    /**
     * The currency exchange rate service to use.
     *
     * @reference
     * @binding.php ../ExchangeRate/ExchangeRate.php
     */
    public $exchange_rate;

    /**
     * The stock quote service to use.
     *
     * @reference
     * @binding.soap ../StockQuote/StockQuote.wsdl
     */
    public $stock_quote;

    /**
     * Get a stock quote for a given ticker symbol in a given currency.
     *
     * @param string $ticker The ticker symbol.
     * @param string $currency What currency to convert the value to.
     * @return float The stock value is the target currency.
     */
    function getQuote($ticker, $currency)
    {
        $quote  = $this->stock_quote->getQuote($ticker);
        $rate   = $this->exchange_rate->getRate($currency);
        return  $rate * $quote;
    }
}
?>

In this example, we see that an SCA component is implemented by a script containing a PHP class and includes SCA.php. The class contains a mixture of business logic and references to other components or services. In the illustrated getQuote() method there is only business logic, but it relies on the instance variables $stock_quote and $exchange_rate having been initialized. These refer to two other components and will be initialized by the SCA runtime with proxies for these two services, whenever this component executes. The annotations for these two services show one to be a local component, which will be called within the same PHP runtime, and one to be a remote component which will be called via a SOAP request. This component also exposes the getQuote() method both locally and as a web service, so it in turn can be called either locally or remotely.

SCA
Yapılandırma/Kurulum
SCA


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
SCA


Gereksinimler

If you want to use SCA to consume or produce Web services then you need PHP 5.2.0 or later, built with the soap extension enabled. If you just want to use local components, and do not wish to use the Web service bindings, then this version of SCA for PHP will also run with PHP 5.1.6.

SCA is packaged along with SDO in one combined package on PECL. See http://www.php.net/sdo#sdo.installation for installing the SCA_SDO package from PECL. The SCA code must be on the include path of your PHP installation, for example if it is installed as /usr/local/lib/php/SCA, the include_path directive must include /usr/local/lib/php

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/sca.

Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
Örnekler
SCA


Örnekler

İçindekiler

  • The structure of a Service Component
  • Obtaining a proxy for another Service Component
  • Calling another Service Component
  • Locating and calling services from a script which is not an SCA Component
  • Exposing a Service Component as a Web service
  • Deploying an SCA component
  • Obtaining the WSDL for an SCA component offering a Service as a Web service
  • Understanding how the WSDL is generated
  • Working with Data Structures
  • Error handling

The examples in the subsequent sections illustrate the following aspects of PHP for SCA:

  • How PHP annotations are used to define PHP classes as SCA components, and how annotations are used to define the services.

  • How an SCA component can be exposed as a Web service

  • How an SCA component can consume a Web service, whether provided by another SCA component or by some other service which knows nothing of SCA

  • How an SCA component can call another SCA component locally (within the same process and on the same call stack)

  • How a client script which is not an SCA component can use the getService call to obtain a proxy for an SCA component.

  • How data structures such as Addresses, or Puchase Orders, are represented as Service Data Objects, and handled.

  • How SCA components are deployed, and in particular how and when WSDL is generated for a service.

  • How parameters are always passed by value (and not by reference) between components, even when the calls are local. This ensures that the semantics of a call do not change depending on the location of a component.

  • How positional parameters to a service are supported, even when the underlying WSDL is document literal wrapped, and naturally supports only named parameters.

  • How business and runtime exceptions are handled.

Öntanımlı Sabitler
The structure of a Service Component
SCA


The structure of a Service Component

A service component is implemented by a class. To identify it as a service component, it contains an @service annotation. The SCA runtime will use the file name of the script to determine the component name, by convention. The class and script file must therefore share the same name.

PHP SCA components always expose a service, and there is no way for a component to be invoked other than to be called as a result of a Web service request, or called directly from another component or from a script. For this reason a valid PHP SCA component will always contain an @service annotation and at least one public method.

Each SCA Component requires that the SCA.php script is included. As well as containing the definition of the SCA class, this script contains executable PHP code that will run whenever the script is called, and which will be responsible for making the component behave as needed.

Dikkat

It is very important that if your file contains other includes, they come before the include for SCA.php. If there are includes after the include for SCA.php, they will not have been processed when the SCA runtime runs your class.

The example below illustrates this overall structure

Örnek 1 The structure of an SCA for PHP component

<?php

// any includes

include "SCA/SCA.php";

/**
 * @service
 */

class ConvertedStockQuote {

       // instance variables, business logic, including at least one public method

}
?>

Örnekler
Obtaining a proxy for another Service Component
Örnekler


Obtaining a proxy for another Service Component

One SCA component can call the service provided by another SCA component. The service a component provides is made up of all of its public methods. SCA for PHP currently provides two ways for one component to call another: either locally (i.e. within the same PHP run-time, and on the same call stack) or remotely if the called component exposes a Web service binding.

In order for one component to call another, the calling component needs a proxy for the called component. This proxy is usually provided as an instance variable in the calling component, though proxies can also be obtained with the SCA::getService() call, as we shall see later. When a component is constructed, proxies are constructed for any instance variable which refer to another component, and these proxies are "injected" into the instance variables. Proxies are always used, whether the component is local or remote, in order to provide identical calling behavior between remote and local calls (for example, local calls are made to always pass data by-value). The proxies know how to locate the required component and to pass the calls made on to them.

Instance variables which are intended to hold proxies for services are indicated by the two PHPDocumentor-style annotations, @reference and @binding. Both annotations are placed in the documentation section for a class instance variable, as shown by the code below.

The @reference annotation before an instance variable indicates that the instance variable is to be initialized with a proxy to a component.

The @binding annotation has two forms @binding.php and @binding.soap, and indicates that the proxy is either for a local component or for a Web service respectively. For both @binding.php and @binding.soap, the annotation gives a target URI.

At the moment, with the annotation-based method of specifying dependencies, the only way to alter the intended target of a reference is to alter the annotation within the component.

In our ConvertedStockQuote example, the $exchange_rate instance variable will be initialized with a proxy to the local ExchangeRate component whenever an instance of the ConvertedStockQuote is constructed.

Örnek 1 Obtaining a proxy for a local PHP class

<?php
   /**
     * The currency exchange rate service to use.
     *
     * @reference
     * @binding.php ../ExchangeRate/ExchangeRate.php
     */
    public $exchange_rate;
?>

For @binding.php, the URI identifies the location of the script containing the implementation of the component. The component will be called locally. The service provided is the set of public methods of the component. The URI must be a simple pathname, either absolute or relative. The component will be loaded with the PHP include directive, after testing to see if it is already loaded with class_exists(). If the URI is a relative path, it is resolved relative to the component containing the annotation. Note that this is different from the normal PHP behaviour where scripts would be looked for along the PHP include_path, This is intended to provide some location-independence for cross-component references.

If this ExchangeRate service were remote and to be called as a Web service, only the @binding line changes. Instead of giving the location of a PHP class, it gives the location of the WSDL describing the web service. In our example component, this is illustrated by the second reference:

Örnek 2 Obtaining a proxy for a web service

<?php
/**
     * The stock quote service to use.
     *
     * @reference
     * @binding.soap ../StockQuote/StockQuote.wsdl
     */
    public $stock_quote;
?>

The StockQuote component will be called via a Web service request. In this case the URI for the WSDL can be a simple pathname, or may contain a PHP wrapper and begin, for example, with file:// or http://. In the event that it is a simple pathname, it can be absolute or relative, and if relative will be resolved relative to the component containing the annotation. Note that this is like the behaviour for @binding.php, and different from the normal PHP behaviour where the file would be looked for relative to the PHP current working directory, which would usually be the location of the first script to be called. This behaviour is intended to give consistency across the different bindings and to provide some location-independence for references between components.

The structure of a Service Component
Calling another Service Component
Örnekler


Calling another Service Component

The ConvertedStockQuote example also calls the proxies for the two components to which it refers.

Örnek 1 Calling services

<?php
$quote  = $this->stock_quote->getQuote($ticker);
$rate   = $this->exchange_rate->getRate($currency);
?>

The call to the StockQuote service is a call to a local service; the call to the ExchangeRate service is a call to a remote service. Note that the way the call is made looks the same regardless of whether the call is to a local service or a remote one.

The proxies which have been injected ensure that the way calls to components look and behave are the same way regardless of whether they are to a local or remote service, so that components are not sensitive to whether a call is to a local or a remote service. For example, the proxy for a local service takes copies of the arguments and passes only those copies, to ensure that calls are made to be pass-by-value, as they would be for a remote call. Also, the proxy for a remote service takes the arguments from a positional parameter list and ensures they are packaged properly in a SOAP request and converted back to a positional parameter list at the far end.

In the example above, the $ticker and $currency are clearly PHP scalar types. Components can pass the PHP scalar types string, integer, float and boolean, but data structures on service calls are always passed as Service Data Objects (SDOs). A later section describes how a component can create an SDO to pass on a local or Web service call, or how a component can create an SDO to return. The PHP SDO project documentation describes how to work with the SDO APIs (see the SDO pages).

Obtaining a proxy for another Service Component
Locating and calling services from a script which is not an SCA Component
Örnekler


Locating and calling services from a script which is not an SCA Component

SCA components obtain proxies for other components or services as instance variables annotated with @reference, but this is not possible for a script that is not itself also a component. A client script which is not a component must use the SCA::getService() static method to obtain a proxy for a service, whether local or remote. The getService() method takes a URI as the argument. Typically this is the location of a local PHP script containing a component, or of a wsdl file, and is used in exactly the same way as the targets of the @binding annotations described in the previous section: that is, relative URIs are resolved against the location of the client script and not against the PHP include_path or current working directory.

For example, a script that needed to obtain proxies for the ExchangeRate and StockQuote services but was not a component would use the getService() method as follows:

Örnek 1 Obtaining a proxy using getService

<?php
$exchange_rate = SCA::getService('../ExchangeRate/ExchangeRate.php');
$stock_quote   = SCA::getService('../StockQuote/StockQuote.wsdl');
?>

Methods on services can then be called on the returned proxy, just as they can in a component.

Örnek 2 Making calls on the proxy

<?php
$quote  = $stock_quote->getQuote($ticker);
$rate   = $exchange_rate->getRate($currency);
?>

Calling another Service Component
Exposing a Service Component as a Web service
Örnekler


Exposing a Service Component as a Web service

SCA for PHP can generate WSDL from the annotations within a service component, so that it can be easily deployed and exposed as a Web service. To provide SCA with the information it needs to generate the WSDL, it is necessary to add the annotation @binding.soap under the @service annotation and to specify the parameters and return values of the methods using the @param and @return annotations. These annotations will be read when WSDL is generated, and the order and types of the parameters determine the contents of the <schema> section of the WSDL.

SCA for PHP always generates document/literal wrapped WSDL for components that are exposing a Web service. Note that this does not stop components from consuming Web services which are not SCA components and which are documented with WSDL written in a different style.

The scalar types which can be used in the @param annotation are the four common PHP scalar types: boolean, integer, float and string. These are simply mapped to the XML schema types of the same name in the WSDL. The example below, which is a trivial implementation of the StockQuote service that the ConvertedStockQuote component calls, illustrates string and float types.

Örnek 1 StockQuote Service

<?php

include "SCA/SCA.php";

/**
 * Scaffold implementation for a remote StockQuote Web service.
 *
 * @service
 * @binding.soap
 *
 */
class StockQuote {

    /**
     * Get a stock quote for a given ticker symbol.
     *
     * @param string $ticker The ticker symbol.
     * @return float The stock quote.
     */
    function getQuote($ticker) {
        return 80.9;
  }
}
?>

WSDL much like the following (though with a service location other than 'localhost', probably) would be generated from this service:

Örnek 2 Generated WSDL

<?xml version="1.0" encoding="UTF-8"?>
<definitions xmlns="http://schemas.xmlsoap.org/wsdl/" xsi:type="tDefinitions"
    xmlns:tns2="http://StockQuote" xmlns:tns="http://schemas.xmlsoap.org/wsdl/"
    xmlns:tns3="http://schemas.xmlsoap.org/wsdl/soap/"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" targetNamespace="http://StockQuote">
  <types>
    <xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema"
      targetNamespace="http://StockQuote">
      <xs:element name="getQuote">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ticker" type="xs:string"/>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="getQuoteResponse">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="getQuoteReturn" type="xs:float"/>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:schema>
  </types>

  <message name="getQuoteRequest">
    <part name="getQuoteRequest" element="tns2:getQuote"/>
  </message>
  <message name="getQuoteResponse">
    <part name="return" element="tns2:getQuoteResponse"/>
  </message>
  <portType name="StockQuotePortType">
    <operation name="getQuote">
      <input message="tns2:getQuoteRequest"/>
      <output message="tns2:getQuoteResponse"/>
    </operation>
  </portType>
  <binding name="StockQuoteBinding" type="tns2:StockQuotePortType">
    <operation name="getQuote">
      <input>
        <tns3:body xsi:type="tBody" use="literal"/>
      </input>
      <output>
        <tns3:body xsi:type="tBody" use="literal"/>
      </output>
      <tns3:operation xsi:type="tOperation" soapAction=""/>
    </operation>
    <tns3:binding xsi:type="tBinding" transport="http://schemas.xmlsoap.org/soap/http" style="document"/>
  </binding>
  <service name="StockQuoteService">
    <port name="StockQuotePort" binding="tns2:StockQuoteBinding">
      <tns3:address xsi:type="tAddress" location="http://localhost/StockQuote/StockQuote.php"/>
    </port>
  </service>
</definitions>

<!-- this line identifies this file as WSDL generated by SCA for PHP. Do not remove -->

Locating and calling services from a script which is not an SCA Component
Deploying an SCA component
Örnekler


Deploying an SCA component

There are no special steps needed to deploy a PHP SCA component. It is sufficient to place the component PHP script in its proper place under the web server document root, just like any other PHP script. It is the SCA::initComponent() executable line within each component that will be executed whenever the script is called, and which will be responsible for making the component respond appropriately to Web service calls, local calls, or requests for WSDL.

Exposing a Service Component as a Web service
Obtaining the WSDL for an SCA component offering a Service as a Web service
Örnekler


Obtaining the WSDL for an SCA component offering a Service as a Web service

SCA components that expose a Web service interface (i.e. have an @binding.soap annotation) will return their WSDL definition in response to an HTTP request with a get parameter of "wsdl". The usual way to obtain this is with "?wsdl" on the end of a URL. The example below uses file_get_contents() to obtain WSDL from a service and writes it to a temporary file before then obtaining a proxy for the service in the usual way. You could of course also obtain the WSDL in a browser, or by some other means, and save the file yourself.

Örnek 1 Generated WSDL

<?php
$wsdl = file_get_contents('http://www.example.com/Services/Example.php?wsdl');
file_put_contents("service.wsdl",$wsdl); //write the wsdl to a file
$service = SCA::getService('service.wsdl');
?>

NOTE: If the wsdl requires imported xsds, these will need to be fetched separately.

Deploying an SCA component
Understanding how the WSDL is generated
Örnekler


Understanding how the WSDL is generated

SCA for PHP generates WSDL for components which contain an @binding.soap annotation after the @service annotation. To generate WSDL, the SCA runtime reflects on the component and examines the @param and @return annotations for each public method, as well as any @types annotations within the component. The information from the @param and @return annotations is used to build the <types> section of the WSDL. Any @types annotations which specify a separate schema file will result in an <import> element for that schema within the WSDL.

Location attribute of the <service> element

At the bottom of the WSDL is the <service> element which uses the location attribute to identify the URL of the service. For example this might look as follows:

Örnek 1 location attribute

<service name="ConvertedStockQuote"
...
location="http://localhost/ConvertedStockQuote/ConvertedStockQuote.php"/>

Note that this location is relative to the document root of the web server, and cannot be worked out in advance. It can only be worked out once the component is in its proper place under a running web server, when the hostname and port can be known and placed in the WSDL. Detail from the URL that requests the WSDL is used, so for example if the WSDL is generated in response to a request to http://www.example.com:1111/ConvertedStockQuote/ConvertedStockQuote.php?wsdl, a location of http://www.example.com:1111/ConvertedStockQuote/ConvertedStockQuote.php is what will be inserted into the location attribute in the WSDL.

Document/literal wrapped WSDL and positional parameters

SCA for PHP generates WSDL in the document/literal wrapped style. This style encloses the parameters and return types of a method in 'wrappers' which are named after the corresponding method. The <types> element at the top of the WSDL defines each of these wrappers. If we consider the getQuote() method of the ConvertedStockQuote example:

Örnek 2 method with two arguments

<?php
   /**
     * Get a stock quote for a given ticker symbol in a given currency.
     *
     * @param string $ticker The ticker symbol.
     * @param string $currency What currency to convert the value to.
     * @return float The stock value is the target currency.
     */
    function getQuote($ticker, $currency)
    {
        $quote  = $this->stock_quote->getQuote($ticker);
        $rate   = $this->exchange_rate->getRate($currency);
        return  $rate * $quote;
    }
?>

The WSDL generated to define this method will name both the method and the parameters, and give an XML schema type for the parameters. The types section of the WSDL looks like this:

Örnek 3 types section illustrating named parameters

<types>
    <xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema"
      targetNamespace="http://ConvertedStockQuote">
      <xs:element name="getQuote">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="ticker" type="xs:string"/>
            <xs:element name="currency" type="xs:string"/>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
      <xs:element name="getQuoteResponse">
        <xs:complexType>
          <xs:sequence>
            <xs:element name="getQuoteReturn" type="xs:float"/>
          </xs:sequence>
        </xs:complexType>
      </xs:element>
    </xs:schema>
  </types>

The SCA run-time has special processing to handle how positional parameter lists in the interface are converted to XML containing named parameters in the soap request, and then back to positional parameter lists again. To see why this matters, consider how a PHP script which used a different interface to make a SOAP call would need to construct the parameter list. A PHP script using the PHP SoapClient, for example, would need to pass the SoapClient a single parameter giving the values for "ticker" and "currency", perhaps as an associative array. To insist that SCA components construct parameter lists to make Web service calls in this way would be to make local and remote calls look different, so a different approach is needed.

When SCA generates WSDL for an SCA component it includes a comment in the WSDL which marks that WSDL as being the interface for an SCA component. In this case, when one SCA component calls another through a Web service, the SCA runtime on the calling end takes the positional parameter list from the call and assigns the values one by one to the named elements in the soap message. For example a call to the getQuote() method defined above that passes the values 'IBM' and 'USD' and looks like this:

<?php
  $quote = $remote_service->getQuote('IBM','USD');
?>

will result in a soap message containing the following:

<getQuote>
  <ticker>IBM</ticker>
  <currency>USD</currency>
</getQuote>

On the service-providing end, the SCA run-time takes the parameters one by one from the soap message and forms a positional parameter list from them, re-forming the argument list ('IBM','USD').

Dikkat

At both ends the SCA runtime relies on the order in which the parameters appear in the soap message being the same as that in the target method's parameter list. This is ultimately determined by the order of the @param annotations: this determines the order in which the parameters appear in the WSDL and thereby the order in which they appear in the soap message. Therefore it is essential that the order of the @param annotations matches that of the parameters in the method's parameter list.

Obtaining the WSDL for an SCA component offering a Service as a Web service
Working with Data Structures
Örnekler


Working with Data Structures

SCA components can pass and return the four PHP scalar types boolean, integer, float and string, but to pass or return data structures, SCA components use Service Data Objects (SDOs). SDOs are described in much more detail in the SDO pages of this manual. Readers familiar with SDOs will know that they are suitable for representing the sort of structured and semi-structured data that is frequently modeled in XML, and that they serialize very naturally for passing between remote components, or in Web services. SDOs are presently the only supported way to pass and return data structures. It is not possible to pass or return PHP objects, or PHP arrays.

The SCA runtime always assures data is passed by-value, even for local calls. To do this, the SCA runtime copies any SDOs in the parameter list before passing them on, just as it does for scalar types.

How data structures are defined to SCA components

Currently the only mechanism for specifying the location of a data structure definition is by specifying the types in an XML schema file. However, in the future it may be possible to define types in other ways, such as based on PHP classes or interfaces, or based on definitions expressed as associative arrays.

To illustrate the use of SDOs we introduce a new component. The PortfolioMangement service below returns an SDO representing a stock portfolio for a given customer.

Örnek 1 A Component that uses Data Structures

<?php

include "SCA/SCA.php";

/**
 * Manage the portfolio for a customer.
 *
 * @service
 * @binding.soap
 *
 * @types http://www.example.org/Portfolio PortfolioTypes.xsd
 *
 */
class PortfolioManagement {

    /**
     * Get the stock portfolio for a given customer.
     *
     * @param integer $customer_id The id for the customer
     * @return Portfolio http://www.example.org/Portfolio The stock portfolio (symbols and quantities)
     */
    function getPortfolio($customer_id) {
        // Pretend we just got this from a database
        $portfolio = SCA::createDataObject('http://www.example.org/Portfolio', 'Portfolio');
        $holding = $portfolio->createDataObject('holding');
        $holding->ticker = 'AAPL';
        $holding->number = 100.5;
        $holding = $portfolio->createDataObject('holding');
        $holding->ticker = 'INTL';
        $holding->number = 100.5;
        $holding = $portfolio->createDataObject('holding');
        $holding->ticker = 'IBM';
        $holding->number = 100.5;
        return $portfolio;
    }

}
?>

The @types annotation:

<?php
@types http://www.example.org/Portfolio PortfolioTypes.xsd
?>

indicates that types in the namespace http://www.example.org/Portfolio will be found in the schema file located by the URI PortfolioTypes.xsd. The generated WSDL would reproduce this information with an import statement as follows:

<xs:import schemaLocation="PortfolioTypes.xsd"
                      namespace="http://www.example.org/Portfolio"/>

so the URI, absolute or relative, must be one that can be resolved when included in the schemaLocation attribute.

Creating SDOs

Readers familiar with SDOs will know that they are always created according to a description of the permitted structure (sometimes referred to as the 'schema' or 'model') and that, rather than creating them directly using 'new', some form of data factory is needed. Often, an existing data object can be used as the data factory, but sometimes, and especially in order to get the first data object, something else must act as the data factory.

In SCA, either the SCA runtime class or the proxies for services, whether local or remote, can act as the data factories for SDOs. The choice of which to use, and when, is described in the next two sections.

We switch to a new example in order to illustrate the creation of SDOs, both to pass to a service, and to be returned from a service.

Creating an SDO to pass to a service

A caller of a service which requires a data structure to be passed in to it uses the proxy to the service as the data factory for the corresponding SDOs. For example, suppose a component makes use of a proxy for a service provided by a local AddressBook component.

<?php
/**
 * @reference
 * @binding.local AddressBook.php
 */
$address_book;
?>

The AddressBook component that it wishes to call is defined as follows:

<?php
/**
* @service
* @binding.soap
* @types http://addressbook ../AddressBook/AddressBook.xsd
*/
class AddressBook {

    /**
     * @param personType $person http://addressbook (a person object)
     * @return addressType http://addressbook (the address object for the person object)
     */
    function lookupAddress($person)  {
        ...
    }
}
?>

The AddressBook component provides a service method called lookupAddress() which uses types from the http://addressbook namespace. The lookupAddress method takes a personType data structure and returns an addressType. Both types are defined in the schema file addressbook.xsd.

Once the component that wishes to use the AddressBook component has been constructed, so that the $address_book instance variable contains a proxy for the service, the calling component can use the proxy in $address_book to create the person SDO, as shown below:

<?php
$william_shakespeare        = $address_book->createDataObject('http://addressbook','personType');
$william_shakespeare ->name = "William Shakespeare";
$address                    = $address_book->lookupAddress($william_shakespeare);
?>

Note, the use of the proxy as the means to create the SDO is not limited to SCA components. If a service is being called from a general PHP script, and the proxy was obtained with getService() then the same approach is used.

<?php
$address_book = SCA::getService('AddressBook.php');
$william_shakespeare = $address_book->createDataObject('http://addressbook','personType');
?>

Creating an SDO to return from a component

A component that needs to create a data object for return to a caller will not have a proxy to use as a data object, In this case it uses the createDataObject() static method on SCA.php. Hence if the AddressBook component described above needed to create an object of type addressType within the namespace http://addressbook, it might do so as follows:

<?php
$address = SCA::createDataObject('http://addressbook','addressType');
?>

Understanding how the WSDL is generated
Error handling
Örnekler


Error handling

This section describes how errors are handled. There are two types of errors:

  • SCA runtime exceptions are those that signal problems in the management of the execution of components, and in the interaction with remote services. These might occur due to network or configuration problems.

  • Business exceptions are those that are defined by the programmer. They extend the PHP Exception class, and are thrown and caught deliberately as part of the business logic.

Handling of Runtime exceptions

There are two types of SCA runtime exception:

  • SCA_RuntimeException - signals a problem found by or perhaps occurring within the SCA runtime. This can be thrown for a variety of reasons, many of which can occur regardless of whether a connection is being made to a local or a remote service: an error in one of the annotations within a component, a missing WSDL or php file, and so on. In the case of Web services, an SCA_RuntimeException can also be thrown if a SoapFault is received from a remote Web service and the fault code in the SoapFault indicates that a retry is unlikely to be successful.

  • SCA_ServiceUnavailableException - this is a subclass of SCA_RuntimeException and signals a problem in connecting to or using a remote service, but one which might succeed if retried. In the case of Web services, this exception is thrown if a SoapFault is received with a fault code that indicates that a retry might be successful.

Handling of Business exceptions

Business exceptions may be defined and thrown by a component in the normal way, regardless of whether the component has been called locally or remotely. The SCA runtime does not catch business exceptions that have been thrown by a component called locally, so they will be returned to a caller in the normal way. If a component has been called via a Web service, on the other hand, the SCA runtime on the service providing end does catch business exceptions, and will ensure these are passed back to the calling end and re-thrown. Assuming that the calling end has a definition of the exception (that is, is able to include a file containing the PHP class defining the exception) the re-thrown exception will contain the same details as the original, so that the getLine() and getFile() methods for example will contain the location where the exception was thrown within the business logic. The exception will be passed in the detail field of a soap fault with a fault code of "Client".

Working with Data Structures
SCA İşlevleri
Örnekler


Error handling
SCA::createDataObject
SCA
PHP Manual

SCA İşlevleri

Öntanımlı Sınıflar

Most of the interface to SCA is through the annotations within SCA components so there are few public classes and methods. The only SCA classes that scripts or components can call are the SCA class itself, and the proxy classes SCA_LocalProxy and SCA_SoapProxy.

SCA

Much of the work of the SCA class is performed when the file SCA.php is included within an SCA component. However, a PHP script may include SCA.php and call the getService() method on the SCA class in order to obtain a proxy for a service. A component will not need to do this as proxies are obtained instead by defining an instance variable with the @reference annotation.

Components that need to create an SDO to return to a caller will need a data factory to call. For this purpose the SCA class supports the createDataObject() method, which will create an SDO according to the model defined by the component's @types annotations. The arguments to createDataObject() are the same as those to SDO's XML Data Access Service.

Yöntemler

  • getService - obtain a proxy for a service

  • createDataObject - create an SDO

SCA_LocalProxy

When getService() is called with the target of a local PHP component, a local proxy is returned. A local proxy is also injected into the instance variables of a component that are defined with an @reference and an @binding.php anotation. When the script or component makes calls on the local proxy, they are passed on to the target component itself.

Components that need to create an SDO to pass to a component will need a data factory to call. For this purpose the SCA_LocalProxy class supports the createDataObject() method, which will create an SDO according to the model defined by the components' @types annotations. The arguments to the createDataObject() are the same as those to SDO's XML Data Access Service.

Yöntemler

  • createDataObject - create an SDO

SCA_SoapProxy

When getService() is called with the target of a WSDL file, a SOAP proxy is returned. A SOAP proxy is also injected into the instance variables of a component that are defined with an @reference and an @binding.soap anotations. When the script or component makes calls on the SOAP proxy, they are formed into Web service SOAP requests and passed on to the target component, with the help of the PHP Soap extension.

Components that need to create an SDO to pass to a component will need a data factory to call. For this purpose the SCA_SoapProxy class supports the createDataObject() method, which will create an SDO according to the model defined within the target WSDL. The arguments to the createDataObject() are the same as those to SDO's XML Data Access Service.

Yöntemler

  • createDataObject - create an SDO

İçindekiler

  • SCA::createDataObject — create an SDO
  • SCA::getService — Obtain a proxy for a service
  • SCA_LocalProxy::createDataObject — create an SDO
  • SCA_SoapProxy::createDataObject — create an SDO
Error handling
SCA::createDataObject
SCA
PHP Manual


create an SDO

SCA İşlevleri
SCA::getService
SCA İşlevleri
PHP Manual

SCA::createDataObject

(PECL SDO >= 0.5.0)

SCA::createDataObject — create an SDO

Açıklama

SDO_DataObject SCA::createDataObject ( string $type_namespace_uri , string $type_name )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

This method is used inside an SCA component that needs to create an SDO to return. The parameters are the desired SDO's namespace URI and type name. The namespace and type must be defined in one of the schema files which are specified on the @types annotation within the component.

Değiştirgeler

type_namespace_uri

The namespace of the type.

type_name

The name of the type.

Dönen Değerler

Returns the newly created SDO_DataObject.

Hatalar/İstisnalar

SDO_TypeNotFoundException

Thrown if the namespaceURI and typeName do not correspond to a type in any of the schema files specified in the @types annotations.

SCA İşlevleri
SCA::getService
SCA İşlevleri


Obtain a proxy for a service

SCA::createDataObject
SCA_LocalProxy::createDataObject
SCA İşlevleri
PHP Manual

SCA::getService

(PECL SDO >= 0.5.0)

SCA::getService — Obtain a proxy for a service

Açıklama

mixed SCA::getService ( string $target [, string $binding [, array $config ]] )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Examine the target and initialize and return a proxy of the appropriate sort. If the target is for a local PHP component the returned proxy will be an SCA_LocalProxy. If the target is for a WSDL file, the returned proxy will be a SCA_SoapProxy.

Değiştirgeler

target

An absolute or relative path to the target service or service description (e.g. a URL to a json-rpc service description, a PHP component, a WSDL file, and so on.). A relative path, if specified, is resolved relative to the location of the script issuing the getService() call, and not against the include_path or current working directory.

binding

The binding (i.e. protocol) to use to communicate with the service (e.g binding.jsonrpc for a json-rpc service). Note, some service types can be deduced from the target parameter (e.g. if the target parameter ends in .wsdl then SCA will assume binding.soap). Any binding which can be specified in an annotation can be specified here. For example 'binding.soap' is equivalent to the '@binding.soap' annotation.

config

Any additional configuration properties for the binding (e.g. array('location' => 'http://example.org')). Any binding configuration which can be specified in an annotation can be specified here. For example, 'location' is equivalent to the '@location' annotation to configure the location of a target soap service.

Dönen Değerler

The SCA_LocalProxy or SCA_SoapProxy.

Örnekler

Örnek 1 An SCA::getService() example

This example shows how to get a proxy to an email soap service described by EmailService.wsdl and located at http://example.org.

<?php
include 'SCA/SCA.php';
$service = SCA::getService('EmailService.wsdl', 'binding.soap', array('location' => 'http://example.org'));
$service->send(...);
?>

Yukarıdaki örneğin çıktısı:

SCA::createDataObject
SCA_LocalProxy::createDataObject
SCA İşlevleri


create an SDO

SCA::getService
SCA_SoapProxy::createDataObject
SCA İşlevleri
PHP Manual

SCA_LocalProxy::createDataObject

(PECL SDO >= 0.5.0)

SCA_LocalProxy::createDataObject — create an SDO

Açıklama

SDO_DataObject SCA_LocalProxy::createDataObject ( string $type_namespace_uri , string $type_name )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

This method is used inside either an ordinary PHP script or an SCA component that needs to create an SDO to pass to a local service. The parameters are the desired SDO's namespace URI and type name. The namespace and type must be defined in the interface of the component that is to be called, so the namespace and type must be defined in one of the schema files which are specified on the @types annotation within the component for which the SCA_LocalProxy object is a proxy.

Değiştirgeler

type_namespace_uri

The namespace of the type.

type_name

The name of the type.

Dönen Değerler

Returns the newly created SDO_DataObject.

Hatalar/İstisnalar

SDO_TypeNotFoundException

Thrown if the namespaceURI and typeName do not correspond to a type in any of the schema files specified in the @types annotations within the component for which the SCA_LocalProxy object is a proxy..

SCA::getService
SCA_SoapProxy::createDataObject
SCA İşlevleri


create an SDO

SCA_LocalProxy::createDataObject
SOAP
SCA İşlevleri
PHP Manual

SCA_SoapProxy::createDataObject

(PECL SDO >= 0.5.0)

SCA_SoapProxy::createDataObject — create an SDO

Açıklama

SDO_DataObject SCA_SoapProxy::createDataObject ( string $type_namespace_uri , string $type_name )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

This method is used inside either an ordinary PHP script or an SCA component that needs to create an SDO to pass to a web service. The parameters are the desired SDO's namespace URI and type name. The namespace and type must be defined in the interface of the component that is to be called, so the namespace and type must be defined within the WSDL for the web service. If the web service is also an SCA component then the types will have been defined within one of the schema files which are specified on the @types annotation within the component for which the SCA_SoapProxy object is a proxy.

Değiştirgeler

type_namespace_uri

The namespace of the type.

type_name

The name of the type.

Dönen Değerler

Returns the newly created SDO_DataObject.

Hatalar/İstisnalar

SDO_TypeNotFoundException

Thrown if the namespaceURI and typeName do not correspond to a type found in the WSDL that was used to initialise this SCA_SoapProxy.

SCA_LocalProxy::createDataObject
SOAP
SCA İşlevleri


SOAP

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • SOAP İşlevleri
    • is_soap_fault — Checks if a SOAP call has failed
    • use_soap_error_handler — Set whether to use the SOAP error handler
  • SoapClient — The SoapClient class
    • SoapClient::__call — Calls a SOAP function (deprecated)
    • SoapClient::__construct — SoapClient constructor
    • SoapClient::__doRequest — Performs a SOAP request
    • SoapClient::__getFunctions — Returns list of available SOAP functions
    • SoapClient::__getLastRequest — Returns last SOAP request
    • SoapClient::__getLastRequestHeaders — Returns the SOAP headers from the last request
    • SoapClient::__getLastResponse — Returns last SOAP response
    • SoapClient::__getLastResponseHeaders — Returns the SOAP headers from the last response
    • SoapClient::__getTypes — Returns a list of SOAP types
    • SoapClient::__setCookie — The __setCookie purpose
    • SoapClient::__setLocation — Sets the location of the Web service to use
    • SoapClient::__setSoapHeaders — Sets SOAP headers for subsequent calls
    • SoapClient::__soapCall — Calls a SOAP function
    • SoapClient::SoapClient — SoapClient constructor
  • SoapServer — The SoapServer class
    • SoapServer::addFunction — Adds one or more functions to handle SOAP requests
    • SoapServer::addSoapHeader — Add a SOAP header to the response
    • SoapServer::__construct — SoapServer constructor
    • SoapServer::fault — Issue SoapServer fault indicating an error
    • SoapServer::getFunctions — Returns list of defined functions
    • SoapServer::handle — Handles a SOAP request
    • SoapServer::setClass — Sets the class which handles SOAP requests
    • SoapServer::setObject — Sets the object which will be used to handle SOAP requests
    • SoapServer::setPersistence — Sets SoapServer persistence mode
    • SoapServer::SoapServer — SoapServer constructor
  • SoapFault — The SoapFault class
    • SoapFault::__construct — SoapFault constructor
    • SoapFault::SoapFault — SoapFault constructor
    • SoapFault::__toString — Obtain a string representation of a SoapFault
  • SoapHeader — The SoapHeader class
    • SoapHeader::__construct — SoapHeader constructor
    • SoapHeader::SoapHeader — SoapHeader constructor
  • SoapParam — The SoapParam class
    • SoapParam::__construct — SoapParam constructor
    • SoapParam::SoapParam — SoapParam constructor
  • SoapVar — The SoapVar class
    • SoapVar::__construct — SoapVar constructor
    • SoapVar::SoapVar — SoapVar constructor
SCA_SoapProxy::createDataObject
Giriş
HTTP Hizmetleri


Giriş

The SOAP extension can be used to write SOAP Servers and Clients. It supports subsets of » SOAP 1.1, » SOAP 1.2 and » WSDL 1.1 specifications.

SOAP
Yapılandırma/Kurulum
SOAP


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
SOAP


Gereksinimler

Bu eklenti PHP'nin libxml eklentsini gerektirir. Bu, libxml öntanımlı olarak etkin olduğundan bu örtük olarak sağlansa da derlemme sırasında ayrıca bir --enable-libxml gerektiği anlamına gelir.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

To enable SOAP support, configure PHP with --enable-soap .

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

SOAP Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
soap.wsdl_cache_enabled | 1 | PHP_INI_ALL |
soap.wsdl_cache_dir | /tmp | PHP_INI_ALL |
soap.wsdl_cache_ttl | 86400 | PHP_INI_ALL |
soap.wsdl_cache | 1 | PHP_INI_ALL |
soap.wsdl_cache_limit | 5 | PHP_INI_ALL |

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

soap.wsdl_cache_enabled integer

Enables or disables the WSDL caching feature.

soap.wsdl_cache_dir string

Sets the directory name where the SOAP extension will put cache files.

soap.wsdl_cache_ttl integer

Sets the number of seconds (time to live) that cached files will be used instead of the originals.

soap.wsdl_cache integer

If soap.wsdl_cache_enabled is on, this setting determines the type of caching. It can be any of: WSDL_CACHE_NONE (0), WSDL_CACHE_DISK (1), WSDL_CACHE_MEMORY (2) or WSDL_CACHE_BOTH (3). This can also be set via the options array in the SoapClient or SoapServer constructor.

soap.wsdl_cache_limit integer

Maximum number of in-memory cached WSDL files. Adding further files into a full memory cache will delete the oldest files from it.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

SOAP constants
Constant | Value | Description
SOAP_1_1 (integer) | 1 |
SOAP_1_2 (integer) | 2 |
SOAP_PERSISTENCE_SESSION (integer) | 1 |
SOAP_PERSISTENCE_REQUEST (integer) | 2 |
SOAP_FUNCTIONS_ALL (integer) | 999 |
SOAP_ENCODED (integer) | 1 |
SOAP_LITERAL (integer) | 2 |
SOAP_RPC (integer) | 1 |
SOAP_DOCUMENT (integer) | 2 |
SOAP_ACTOR_NEXT (integer) | 1 |
SOAP_ACTOR_NONE (integer) | 2 |
SOAP_ACTOR_UNLIMATERECEIVER (integer) | 3 |
SOAP_COMPRESSION_ACCEPT (integer) | 32 |
SOAP_COMPRESSION_GZIP (integer) | 0 |
SOAP_COMPRESSION_DEFLATE (integer) | 16 |
SOAP_AUTHENTICATION_BASIC (integer) | 0 |
SOAP_AUTHENTICATION_DIGEST (integer) | 1 |
SOAP_SSL_METHOD_TLS (integer) | 0 | Since PHP 5.5.0.
SOAP_SSL_METHOD_SSLv2 (integer) | 1 | Since PHP 5.5.0.
SOAP_SSL_METHOD_SSLv3 (integer) | 2 | Since PHP 5.5.0.
SOAP_SSL_METHOD_SSLv23 (integer) | 3 | Since PHP 5.5.0.
UNKNOWN_TYPE (integer) | 999998 |
XSD_STRING (integer) | 101 |
XSD_BOOLEAN (integer) | 102 |
XSD_DECIMAL (integer) | 103 |
XSD_FLOAT (integer) | 104 |
XSD_DOUBLE (integer) | 105 |
XSD_DURATION (integer) | 106 |
XSD_DATETIME (integer) | 107 |
XSD_TIME (integer) | 108 |
XSD_DATE (integer) | 109 |
XSD_GYEARMONTH (integer) | 110 |
XSD_GYEAR (integer) | 111 |
XSD_GMONTHDAY (integer) | 112 |
XSD_GDAY (integer) | 113 |
XSD_GMONTH (integer) | 114 |
XSD_HEXBINARY (integer) | 115 |
XSD_BASE64BINARY (integer) | 116 |
XSD_ANYURI (integer) | 117 |
XSD_QNAME (integer) | 118 |
XSD_NOTATION (integer) | 119 |
XSD_NORMALIZEDSTRING (integer) | 120 |
XSD_TOKEN (integer) | 121 |
XSD_LANGUAGE (integer) | 122 |
XSD_NMTOKEN (integer) | 123 |
XSD_NAME (integer) | 124 |
XSD_NCNAME (integer) | 125 |
XSD_ID (integer) | 126 |
XSD_IDREF (integer) | 127 |
XSD_IDREFS (integer) | 128 |
XSD_ENTITY (integer) | 129 |
XSD_ENTITIES (integer) | 130 |
XSD_INTEGER (integer) | 131 |
XSD_NONPOSITIVEINTEGER (integer) | 132 |
XSD_NEGATIVEINTEGER (integer) | 133 |
XSD_LONG (integer) | 134 |
XSD_INT (integer) | 135 |
XSD_SHORT (integer) | 136 |
XSD_BYTE (integer) | 137 |
XSD_NONNEGATIVEINTEGER (integer) | 138 |
XSD_UNSIGNEDLONG (integer) | 139 |
XSD_UNSIGNEDINT (integer) | 140 |
XSD_UNSIGNEDSHORT (integer) | 141 |
XSD_UNSIGNEDBYTE (integer) | 142 |
XSD_POSITIVEINTEGER (integer) | 143 |
XSD_NMTOKENS (integer) | 144 |
XSD_ANYTYPE (integer) | 145 |
XSD_ANYXML (integer) | 147 |
APACHE_MAP (integer) | 200 |
SOAP_ENC_OBJECT (integer) | 301 |
SOAP_ENC_ARRAY (integer) | 300 |
XSD_1999_TIMEINSTANT (integer) | 401 |
XSD_NAMESPACE (integer) | http://www.w3.org/2001/XMLSchema |
XSD_1999_NAMESPACE (integer) | http://www.w3.org/1999/XMLSchema |
SOAP_SINGLE_ELEMENT_ARRAYS (integer) | 1 |
SOAP_WAIT_ONE_WAY_CALLS (integer) | 2 |
SOAP_USE_XSI_ARRAY_TYPE (integer) | 4 |
WSDL_CACHE_NONE (integer) | 0 |
WSDL_CACHE_DISK (integer) | 1 |
WSDL_CACHE_MEMORY (integer) | 2 |
WSDL_CACHE_BOTH (integer) | 3 |
Özkaynak Türleri
SOAP İşlevleri
SOAP


SOAP İşlevleri

İçindekiler

  • is_soap_fault — Checks if a SOAP call has failed
  • use_soap_error_handler — Set whether to use the SOAP error handler
Öntanımlı Sabitler
is_soap_fault
SOAP


Checks if a SOAP call has failed

SOAP İşlevleri
use_soap_error_handler
SOAP İşlevleri
PHP Manual

is_soap_fault

(Unknown)

is_soap_fault — Checks if a SOAP call has failed

Açıklama

bool is_soap_fault ( mixed $object )

This function is useful to check if the SOAP call failed, but without using exceptions. To use it, create a SoapClient object with the exceptions option set to zero or FALSE. In this case, the SOAP method will return a special SoapFault object which encapsulates the fault details (faultcode, faultstring, faultactor and faultdetails).

If exceptions is not set then SOAP call will throw an exception on error. is_soap_fault() checks if the given parameter is a SoapFault object.

Değiştirgeler

object

The object to test.

Dönen Değerler

This will return TRUE on error, and FALSE otherwise.

Örnekler

Örnek 1 is_soap_fault() example

<?php
$client = new SoapClient("some.wsdl", array('exceptions' => 0));
$result = $client->SomeFunction();
if (is_soap_fault($result)) {
    trigger_error("SOAP Fault: (faultcode: {$result->faultcode}, faultstring: {$result->faultstring})", E_USER_ERROR);
}
?>

Örnek 2 SOAP's standard method for error reporting is exceptions

<?php
try {
    $client = new SoapClient("some.wsdl");
    $result = $client->SomeFunction(/* ... */);
} catch (SoapFault $fault) {
    trigger_error("SOAP Fault: (faultcode: {$fault->faultcode}, faultstring: {$fault->faultstring})", E_USER_ERROR);
}
?>

Ayrıca Bakınız

  • SoapClient::SoapClient() - SoapClient constructor
  • SoapFault::SoapFault() - SoapFault constructor

SOAP İşlevleri
use_soap_error_handler
SOAP İşlevleri


Set whether to use the SOAP error handler

is_soap_fault
SoapClient
SOAP İşlevleri
PHP Manual

use_soap_error_handler

(Unknown)

use_soap_error_handler — Set whether to use the SOAP error handler

Açıklama

bool use_soap_error_handler ([ bool $handler = true ] )

This function sets whether or not to use the SOAP error handler in the SOAP server. It will return the previous value. If set to TRUE, details of errors in a SoapServer application will be sent to the client as a SOAP fault message. If FALSE, the standard PHP error handler is used. The default is to send error to the client as SOAP fault message.

Değiştirgeler

handler

Set to TRUE to send error details to clients.

Dönen Değerler

Returns the original value.

Ayrıca Bakınız

  • set_error_handler() - Kullanıcı tanımlı bir hata eylemcisi bildirir
  • set_exception_handler() - Kullanıcı tanımlı bir istisna eylemcisi bildirir

is_soap_fault
SoapClient
SOAP İşlevleri


The SoapClient class

(PHP 5 >= 5.0.1, PHP 7)

Giriş

The SoapClient class provides a client for » SOAP 1.1, » SOAP 1.2 servers. It can be used in WSDL or non-WSDL mode.

Sınıf Sözdizimi

SoapClient {
/* Yöntemler */
public mixed __call ( string $function_name , string $arguments )
public SoapClient ( mixed $wsdl [, array $options ] )
public string __doRequest ( string $request , string $location , string $action , int $version [, int $one_way = 0 ] )
public array __getFunctions ( void )
public string __getLastRequest ( void )
public string __getLastRequestHeaders ( void )
public string __getLastResponse ( void )
public string __getLastResponseHeaders ( void )
public array __getTypes ( void )
public void __setCookie ( string $name [, string $value ] )
public string __setLocation ([ string $new_location ] )
public bool __setSoapHeaders ([ mixed $soapheaders ] )
public mixed __soapCall ( string $function_name , array $arguments [, array $options [, mixed $input_headers [, array &$output_headers ]]] )
public SoapClient ( mixed $wsdl [, array $options ] )
}

İçindekiler

  • SoapClient::__call — Calls a SOAP function (deprecated)
  • SoapClient::__construct — SoapClient constructor
  • SoapClient::__doRequest — Performs a SOAP request
  • SoapClient::__getFunctions — Returns list of available SOAP functions
  • SoapClient::__getLastRequest — Returns last SOAP request
  • SoapClient::__getLastRequestHeaders — Returns the SOAP headers from the last request
  • SoapClient::__getLastResponse — Returns last SOAP response
  • SoapClient::__getLastResponseHeaders — Returns the SOAP headers from the last response
  • SoapClient::__getTypes — Returns a list of SOAP types
  • SoapClient::__setCookie — The __setCookie purpose
  • SoapClient::__setLocation — Sets the location of the Web service to use
  • SoapClient::__setSoapHeaders — Sets SOAP headers for subsequent calls
  • SoapClient::__soapCall — Calls a SOAP function
  • SoapClient::SoapClient — SoapClient constructor
use_soap_error_handler
SoapClient::__call
SOAP


Calls a SOAP function (deprecated)

SoapClient
SoapClient::__construct
SoapClient
PHP Manual

SoapClient::__call

(PHP 5 >= 5.0.1, PHP 7)

SoapClient::__call — Calls a SOAP function (deprecated)

Açıklama

public mixed SoapClient::__call ( string $function_name , string $arguments )

Calling this method directly is deprecated. Usually, SOAP functions can be called as methods of the SoapClient object; in situations where this is not possible or additional options are needed, use SoapClient::__soapCall().

SoapClient
SoapClient::__construct
SoapClient


SoapClient constructor

SoapClient::__call
SoapClient::__doRequest
SoapClient
PHP Manual

SoapClient::__construct

(PHP 5 >= 5.0.1, PHP 7)

SoapClient::__construct — SoapClient constructor

Açıklama

public SoapClient::SoapClient ( mixed $wsdl [, array $options ] )

Bu işlev şu işlevin takma adıdır: SoapClient::SoapClient()

SoapClient::__call
SoapClient::__doRequest
SoapClient


Performs a SOAP request

SoapClient::__construct
SoapClient::__getFunctions
SoapClient
PHP Manual

SoapClient::__doRequest

(PHP 5 >= 5.0.1, PHP 7)

SoapClient::__doRequest — Performs a SOAP request

Açıklama

public string SoapClient::__doRequest ( string $request , string $location , string $action , int $version [, int $one_way = 0 ] )

Performs SOAP request over HTTP.

This method can be overridden in subclasses to implement different transport layers, perform additional XML processing or other purpose.

Değiştirgeler

request

The XML SOAP request.

location

The URL to request.

action

The SOAP action.

version

The SOAP version.

one_way

If one_way is set to 1, this method returns nothing. Use this where a response is not expected.

Dönen Değerler

The XML SOAP response.

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.3 | The one_way parameter was added.

Örnekler

Örnek 1 SoapClient::__doRequest() example

<?php
function Add($x,$y) {
  return $x+$y;
}

class LocalSoapClient extends SoapClient {

  function __construct($wsdl, $options) {
    parent::__construct($wsdl, $options);
    $this->server = new SoapServer($wsdl, $options);
    $this->server->addFunction('Add');
  }

  function __doRequest($request, $location, $action, $version, $one_way = 0) {
    ob_start();
    $this->server->handle($request);
    $response = ob_get_contents();
    ob_end_clean();
    return $response;
  }

}

$x = new LocalSoapClient(NULL,array('location'=>'test://',
                                   'uri'=>'http://testuri.org'));
var_dump($x->Add(3,4));
?>

SoapClient::__construct
SoapClient::__getFunctions
SoapClient


Returns list of available SOAP functions

SoapClient::__doRequest
SoapClient::__getLastRequest
SoapClient
PHP Manual

SoapClient::__getFunctions

(PHP 5 >= 5.0.1, PHP 7)

SoapClient::__getFunctions — Returns list of available SOAP functions

Açıklama

public array SoapClient::__getFunctions ( void )

Returns an array of functions described in the WSDL for the Web service.

Bilginize:

Bu işlev sadece WSDL kipinde çalışır.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The array of SOAP function prototypes, detailing the return type, the function name and type-hinted parameters.

Örnekler

Örnek 1 SoapClient::__getFunctions() example

<?php
$client = new SoapClient('http://soap.amazon.com/schemas3/AmazonWebServices.wsdl');
var_dump($client->__getFunctions());
?>

Yukarıdaki örneğin çıktısı:

array(26) {
  [0]=>
  string(70) "ProductInfo KeywordSearchRequest(KeywordRequest $KeywordSearchRequest)"
  [1]=>
  string(79) "ProductInfo TextStreamSearchRequest(TextStreamRequest $TextStreamSearchRequest)"
  [2]=>
  string(64) "ProductInfo PowerSearchRequest(PowerRequest $PowerSearchRequest)"
...
  [23]=>
  string(107) "ShoppingCart RemoveShoppingCartItemsRequest(RemoveShoppingCartItemsRequest $RemoveShoppingCartItemsRequest)"
  [24]=>
  string(107) "ShoppingCart ModifyShoppingCartItemsRequest(ModifyShoppingCartItemsRequest $ModifyShoppingCartItemsRequest)"
  [25]=>
  string(118) "GetTransactionDetailsResponse GetTransactionDetailsRequest(GetTransactionDetailsRequest $GetTransactionDetailsRequest)"
}

Ayrıca Bakınız

  • SoapClient::SoapClient() - SoapClient constructor

SoapClient::__doRequest
SoapClient::__getLastRequest
SoapClient


Returns last SOAP request

SoapClient::__getFunctions
SoapClient::__getLastRequestHeaders
SoapClient
PHP Manual

SoapClient::__getLastRequest

(PHP 5 >= 5.0.1, PHP 7)

SoapClient::__getLastRequest — Returns last SOAP request

Açıklama

public string SoapClient::__getLastRequest ( void )

Returns the XML sent in the last SOAP request.

Bilginize:

This method works only if the SoapClient object was created with the trace option set to TRUE.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The last SOAP request, as an XML string.

Örnekler

Örnek 1 SoapClient::__getLastRequest() example

<?php
$client = new SoapClient("some.wsdl", array('trace' => 1));
$result = $client->SomeFunction();
echo "REQUEST:\n" . $client->__getLastRequest() . "\n";
?>

Ayrıca Bakınız

  • SoapClient::__getLastRequestHeaders() - Returns the SOAP headers from the last request
  • SoapClient::__getLastResponse() - Returns last SOAP response
  • SoapClient::__getLastResponseHeaders() - Returns the SOAP headers from the last response

SoapClient::__getFunctions
SoapClient::__getLastRequestHeaders
SoapClient


Returns the SOAP headers from the last request

SoapClient::__getLastRequest
SoapClient::__getLastResponse
SoapClient
PHP Manual

SoapClient::__getLastRequestHeaders

(PHP 5 >= 5.0.1, PHP 7)

SoapClient::__getLastRequestHeaders — Returns the SOAP headers from the last request

Açıklama

public string SoapClient::__getLastRequestHeaders ( void )

Returns the SOAP headers from the last request.

Bilginize:

This function only works if the SoapClient object was created with the trace option set to TRUE.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The last SOAP request headers.

Örnekler

Örnek 1 SoapClient::__getLastRequestHeaders() example

<?php
$client = SoapClient("some.wsdl", array('trace' => 1));
$result = $client->SomeFunction();
echo "REQUEST HEADERS:\n" . $client->__getLastRequestHeaders() . "\n";
?>

Ayrıca Bakınız

  • SoapClient::__getLastResponseHeaders() - Returns the SOAP headers from the last response
  • SoapClient::__getLastRequest() - Returns last SOAP request
  • SoapClient::__getLastResponse() - Returns last SOAP response

SoapClient::__getLastRequest
SoapClient::__getLastResponse
SoapClient


Returns last SOAP response

SoapClient::__getLastRequestHeaders
SoapClient::__getLastResponseHeaders
SoapClient
PHP Manual

SoapClient::__getLastResponse

(PHP 5 >= 5.0.1, PHP 7)

SoapClient::__getLastResponse — Returns last SOAP response

Açıklama

public string SoapClient::__getLastResponse ( void )

Returns the XML received in the last SOAP response.

Bilginize:

This method works only if the SoapClient object was created with the trace option set to TRUE.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The last SOAP response, as an XML string.

Örnekler

Örnek 1 SoapClient::__getLastResponse() example

<?php
$client = SoapClient("some.wsdl", array('trace' => 1));
$result = $client->SomeFunction();
echo "Response:\n" . $client->__getLastResponse() . "\n";
?>

Ayrıca Bakınız

  • SoapClient::__getLastResponseHeaders() - Returns the SOAP headers from the last response
  • SoapClient::__getLastRequest() - Returns last SOAP request
  • SoapClient::__getLastRequestHeaders() - Returns the SOAP headers from the last request

SoapClient::__getLastRequestHeaders
SoapClient::__getLastResponseHeaders
SoapClient


Returns the SOAP headers from the last response

SoapClient::__getLastResponse
SoapClient::__getTypes
SoapClient
PHP Manual

SoapClient::__getLastResponseHeaders

(PHP 5 >= 5.0.1, PHP 7)

SoapClient::__getLastResponseHeaders — Returns the SOAP headers from the last response

Açıklama

public string SoapClient::__getLastResponseHeaders ( void )

Returns the SOAP headers from the last response.

Bilginize:

This function only works if the SoapClient object was created with the trace option set to TRUE.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The last SOAP response headers.

Örnekler

Örnek 1 SoapClient::__getLastResponse() example

<?php
$client = SoapClient("some.wsdl", array('trace' => 1));
$result = $client->SomeFunction();
echo "RESPONSE HEADERS:\n" . $client->__getLastResponseHeaders() . "\n";
?>

Ayrıca Bakınız

  • SoapClient::__getLastRequestHeaders() - Returns the SOAP headers from the last request
  • SoapClient::__getLastRequest() - Returns last SOAP request
  • SoapClient::__getLastResponse() - Returns last SOAP response

SoapClient::__getLastResponse
SoapClient::__getTypes
SoapClient


Returns a list of SOAP types

SoapClient::__getLastResponseHeaders
SoapClient::__setCookie
SoapClient
PHP Manual

SoapClient::__getTypes

(PHP 5 >= 5.0.1, PHP 7)

SoapClient::__getTypes — Returns a list of SOAP types

Açıklama

public array SoapClient::__getTypes ( void )

Returns an array of types described in the WSDL for the Web service.

Bilginize:

Bu işlev sadece WSDL kipinde çalışır.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The array of SOAP types, detailing all structures and types.

Örnekler

Örnek 1 SoapClient::__getTypes() example

<?php
$client = new SoapClient('http://soap.amazon.com/schemas3/AmazonWebServices.wsdl');
var_dump($client->__getTypes());
?>

Yukarıdaki örneğin çıktısı:

array(88) {
  [0]=>
  string(30) "ProductLine ProductLineArray[]"
  [1]=>
  string(85) "struct ProductLine {
 string Mode;
 string RelevanceRank;
 ProductInfo ProductInfo;
}"
  [2]=>
  string(105) "struct ProductInfo {
 string TotalResults;
 string TotalPages;
 string ListName;
 DetailsArray Details;
}"
...
  [85]=>
  string(32) "ShortSummary ShortSummaryArray[]"
  [86]=>
  string(121) "struct GetTransactionDetailsRequest {
 string tag;
 string devtag;
 string key;
 OrderIdArray OrderIds;
 string locale;
}"
  [87]=>
  string(75) "struct GetTransactionDetailsResponse {
 ShortSummaryArray ShortSummaries;
}"
}

Ayrıca Bakınız

  • SoapClient::SoapClient() - SoapClient constructor

SoapClient::__getLastResponseHeaders
SoapClient::__setCookie
SoapClient


The __setCookie purpose

SoapClient::__getTypes
SoapClient::__setLocation
SoapClient
PHP Manual

SoapClient::__setCookie

(PHP 5 >= 5.0.4, PHP 7)

SoapClient::__setCookie — The __setCookie purpose

Açıklama

public void SoapClient::__setCookie ( string $name [, string $value ] )

Defines a cookie to be sent along with the SOAP requests.

Bilginize:

Calling this method will affect all following calls to SoapClient methods.

Değiştirgeler

name

The name of the cookie.

value

The value of the cookie. If not specified, the cookie will be deleted.

Dönen Değerler

Hiçbir değer dönmez.

SoapClient::__getTypes
SoapClient::__setLocation
SoapClient


Sets the location of the Web service to use

SoapClient::__setCookie
SoapClient::__setSoapHeaders
SoapClient
PHP Manual

SoapClient::__setLocation

(PHP 5 >= 5.0.1, PHP 7)

SoapClient::__setLocation — Sets the location of the Web service to use

Açıklama

public string SoapClient::__setLocation ([ string $new_location ] )

Sets the endpoint URL that will be touched by following SOAP requests. This is equivalent to specifying the location option when constructing the SoapClient.

Bilginize:

Calling this method is optional. The SoapClient uses the endpoint from the WSDL file by default.

Değiştirgeler

new_location

The new endpoint URL.

Dönen Değerler

The old endpoint URL.

Örnekler

Örnek 1 SoapClient::__setLocation() example

<?php
$client = new SoapClient('http://example.com/webservice.php?wsdl');

$client->__setLocation('http://www.somethirdparty.com');

$old_location = $client->__setLocation(); // unsets the location option

echo $old_location;

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

http://www.somethirdparty.com

Ayrıca Bakınız

  • SoapClient::SoapClient() - SoapClient constructor

SoapClient::__setCookie
SoapClient::__setSoapHeaders
SoapClient


Sets SOAP headers for subsequent calls

SoapClient::__setLocation
SoapClient::__soapCall
SoapClient
PHP Manual

SoapClient::__setSoapHeaders

(PHP 5 >= 5.0.5, PHP 7)

SoapClient::__setSoapHeaders — Sets SOAP headers for subsequent calls

Açıklama

public bool SoapClient::__setSoapHeaders ([ mixed $soapheaders ] )

Defines headers to be sent along with the SOAP requests.

Bilginize:

Calling this method will replace any previous values.

Değiştirgeler

soapheaders

The headers to be set. It could be SoapHeader object or array of SoapHeader objects. If not specified or set to NULL, the headers will be deleted.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 SoapClient::__setSoapHeaders() example

<?php

$client = new SoapClient(null, array('location' => "http://localhost/soap.php",
                                     'uri'      => "http://test-uri/"));
$header = new SoapHeader('http://soapinterop.org/echoheader/',
                            'echoMeStringRequest',
                            'hello world');

$client->__setSoapHeaders($header);

$client->__soapCall("echoVoid", null);
?>

Örnek 2 Set Multiple Headers

<?php

$client = new SoapClient(null, array('location' => "http://localhost/soap.php",
                                     'uri'      => "http://test-uri/"));
$headers = array();

$headers[] = new SoapHeader('http://soapinterop.org/echoheader/',
                            'echoMeStringRequest',
                            'hello world');

$headers[] = new SoapHeader('http://soapinterop.org/echoheader/',
                            'echoMeStringRequest',
                            'hello world again');

$client->__setSoapHeaders($headers);

$client->__soapCall("echoVoid", null);
?>

SoapClient::__setLocation
SoapClient::__soapCall
SoapClient


Calls a SOAP function

SoapClient::__setSoapHeaders
SoapClient::SoapClient
SoapClient
PHP Manual

SoapClient::__soapCall

(PHP 5 >= 5.0.1, PHP 7)

SoapClient::__soapCall — Calls a SOAP function

Açıklama

public mixed SoapClient::__soapCall ( string $function_name , array $arguments [, array $options [, mixed $input_headers [, array &$output_headers ]]] )

This is a low level API function that is used to make a SOAP call. Usually, in WSDL mode, SOAP functions can be called as methods of the SoapClient object. This method is useful in non-WSDL mode when soapaction is unknown, uri differs from the default or when sending and/or receiving SOAP Headers.

On error, a call to a SOAP function can cause PHP to throw exceptions or return a SoapFault object if exceptions are disabled. To check if the function call failed to catch the SoapFault exceptions, check the result with is_soap_fault().

Değiştirgeler

function_name

The name of the SOAP function to call.

arguments

An array of the arguments to pass to the function. This can be either an ordered or an associative array. Note that most SOAP servers require parameter names to be provided, in which case this must be an associative array.

options

An associative array of options to pass to the client.

The location option is the URL of the remote Web service.

The uri option is the target namespace of the SOAP service.

The soapaction option is the action to call.

input_headers

An array of headers to be sent along with the SOAP request.

output_headers

If supplied, this array will be filled with the headers from the SOAP response.

Dönen Değerler

SOAP functions may return one, or multiple values. If only one value is returned by the SOAP function, the return value of __soapCall will be a simple value (e.g. an integer, a string, etc). If multiple values are returned, __soapCall will return an associative array of named output parameters.

On error, if the SoapClient object was constructed with the exceptions option set to FALSE, a SoapFault object will be returned.

Örnekler

Örnek 1 SoapClient::__soapCall() example

<?php

$client = new SoapClient("some.wsdl");
$client->SomeFunction($a, $b, $c);

$client->__soapCall("SomeFunction", array($a, $b, $c));
$client->__soapCall("SomeFunction", array($a, $b, $c), NULL,
                    new SoapHeader(), $output_headers);

$client = new SoapClient(null, array('location' => "http://localhost/soap.php",
                                     'uri'      => "http://test-uri/"));
$client->SomeFunction($a, $b, $c);
$client->__soapCall("SomeFunction", array($a, $b, $c));
$client->__soapCall("SomeFunction", array($a, $b, $c),
                    array('soapaction' => 'some_action',
                          'uri'        => 'some_uri'));
?>

Ayrıca Bakınız

  • SoapClient::SoapClient() - SoapClient constructor
  • SoapParam::SoapParam() - SoapParam constructor
  • SoapVar::SoapVar() - SoapVar constructor
  • SoapHeader::SoapHeader() - SoapHeader constructor
  • SoapFault::SoapFault() - SoapFault constructor
  • is_soap_fault() - Checks if a SOAP call has failed

SoapClient::__setSoapHeaders
SoapClient::SoapClient
SoapClient


SoapClient constructor

SoapClient::__soapCall
SoapServer
SoapClient
PHP Manual

SoapClient::SoapClient

(PHP 5 >= 5.0.1, PHP 7)

SoapClient::SoapClient — SoapClient constructor

Açıklama

public SoapClient::SoapClient ( mixed $wsdl [, array $options ] )

This constructor creates SoapClient objects in WSDL or non-WSDL mode.

Değiştirgeler

wsdl

URI of the WSDL file or NULL if working in non-WSDL mode.

Bilginize:

During development, WSDL caching may be disabled by the use of the soap.wsdl_cache_ttl php.ini setting otherwise changes made to the WSDL file will have no effect until soap.wsdl_cache_ttl is expired.

options

An array of options. If working in WSDL mode, this parameter is optional. If working in non-WSDL mode, the location and uri options must be set, where location is the URL of the SOAP server to send the request to, and uri is the target namespace of the SOAP service.

The style and use options only work in non-WSDL mode. In WSDL mode, they come from the WSDL file.

The soap_version option should be one of either SOAP_1_1 or SOAP_1_2 to select SOAP 1.1 or 1.2, respectively. If omitted, 1.1 is used.

For HTTP authentication, the login and password options can be used to supply credentials. For making an HTTP connection through a proxy server, the options proxy_host, proxy_port, proxy_login and proxy_password are also available. For HTTPS client certificate authentication use local_cert and passphrase options. An authentication may be supplied in the authentication option. The authentication method may be either SOAP_AUTHENTICATION_BASIC (default) or SOAP_AUTHENTICATION_DIGEST.

The compression option allows to use compression of HTTP SOAP requests and responses.

The encoding option defines internal character encoding. This option does not change the encoding of SOAP requests (it is always utf-8), but converts strings into it.

The trace option enables tracing of request so faults can be backtraced. This defaults to FALSE

The classmap option can be used to map some WSDL types to PHP classes. This option must be an array with WSDL types as keys and names of PHP classes as values.

Setting the boolean trace option enables use of the
methods
SoapClient->__getLastRequest,

SoapClient->__getLastRequestHeaders,

SoapClient->__getLastResponse and

SoapClient->__getLastResponseHeaders.

The exceptions option is a boolean value defining whether soap errors throw exceptions of type SoapFault.

The connection_timeout option defines a timeout in seconds for the connection to the SOAP service. This option does not define a timeout for services with slow responses. To limit the time to wait for calls to finish the default_socket_timeout setting is available.

The typemap option is an array of type mappings. Type mapping is an array with keys type_name, type_ns (namespace URI), from_xml (callback accepting one string parameter) and to_xml (callback accepting one object parameter).

The cache_wsdl option is one of WSDL_CACHE_NONE, WSDL_CACHE_DISK, WSDL_CACHE_MEMORY or WSDL_CACHE_BOTH.

The user_agent option specifies string to use in User-Agent header.

The stream_context option is a resource for context.

The features option is a bitmask of SOAP_SINGLE_ELEMENT_ARRAYS, SOAP_USE_XSI_ARRAY_TYPE, SOAP_WAIT_ONE_WAY_CALLS.

The keep_alive option is a boolean value defining whether to send the Connection: Keep-Alive header or Connection: close.

The ssl_method option is one of SOAP_SSL_METHOD_TLS, SOAP_SSL_METHOD_SSLv2, SOAP_SSL_METHOD_SSLv3 or SOAP_SSL_METHOD_SSLv23.

Hatalar/İstisnalar

SoapClient::SoapClient() will generate an E_ERROR error if the location and uri options aren't provided in non-WSDL mode.

A SoapFault exception will be thrown if the wsdl URI cannot be loaded.

Sürüm Bilgisi

Sürüm: | Açıklama
5.5.0 | New ssl_method option.
5.4.0 | New keep_alive option.

Örnekler

Örnek 1 SoapClient::SoapClient() example

<?php

$client = new SoapClient("some.wsdl");

$client = new SoapClient("some.wsdl", array('soap_version'   => SOAP_1_2));

$client = new SoapClient("some.wsdl", array('login'          => "some_name",
                                            'password'       => "some_password"));

$client = new SoapClient("some.wsdl", array('proxy_host'     => "localhost",
                                            'proxy_port'     => 8080));

$client = new SoapClient("some.wsdl", array('proxy_host'     => "localhost",
                                            'proxy_port'     => 8080,
                                            'proxy_login'    => "some_name",
                                            'proxy_password' => "some_password"));

$client = new SoapClient("some.wsdl", array('local_cert'     => "cert_key.pem"));

$client = new SoapClient(null, array('location' => "http://localhost/soap.php",
                                     'uri'      => "http://test-uri/"));

$client = new SoapClient(null, array('location' => "http://localhost/soap.php",
                                     'uri'      => "http://test-uri/",
                                     'style'    => SOAP_DOCUMENT,
                                     'use'      => SOAP_LITERAL));

$client = new SoapClient("some.wsdl",
  array('compression' => SOAP_COMPRESSION_ACCEPT | SOAP_COMPRESSION_GZIP));

$client = new SoapClient("some.wsdl", array('encoding'=>'ISO-8859-1'));

class MyBook {
    public $title;
    public $author;
}

$client = new SoapClient("books.wsdl", array('classmap' => array('book' => "MyBook")));

?>

SoapClient::__soapCall
SoapServer
SoapClient


The SoapServer class

(PHP 5 >= 5.0.1, PHP 7)

Giriş

The SoapServer class provides a server for the » SOAP 1.1 and » SOAP 1.2 protocols. It can be used with or without a WSDL service description.

Sınıf Sözdizimi

SoapServer {
/* Yöntemler */
public void addFunction ( mixed $functions )
public void addSoapHeader ( SoapHeader $object )
public __construct ( mixed $wsdl [, array $options ] )
public void fault ( string $code , string $string [, string $actor [, string $details [, string $name ]]] )
public array getFunctions ( void )
public void handle ([ string $soap_request ] )
public void setClass ( string $class_name [, mixed $args [, mixed $... ]] )
public void setObject ( object $object )
public void setPersistence ( int $mode )
public SoapServer ( mixed $wsdl [, array $options ] )
}

İçindekiler

  • SoapServer::addFunction — Adds one or more functions to handle SOAP requests
  • SoapServer::addSoapHeader — Add a SOAP header to the response
  • SoapServer::__construct — SoapServer constructor
  • SoapServer::fault — Issue SoapServer fault indicating an error
  • SoapServer::getFunctions — Returns list of defined functions
  • SoapServer::handle — Handles a SOAP request
  • SoapServer::setClass — Sets the class which handles SOAP requests
  • SoapServer::setObject — Sets the object which will be used to handle SOAP requests
  • SoapServer::setPersistence — Sets SoapServer persistence mode
  • SoapServer::SoapServer — SoapServer constructor
SoapClient::SoapClient
SoapServer::addFunction
SOAP


Adds one or more functions to handle SOAP requests

SoapServer
SoapServer::addSoapHeader
SoapServer
PHP Manual

SoapServer::addFunction

(PHP 5 >= 5.0.1, PHP 7)

SoapServer::addFunction — Adds one or more functions to handle SOAP requests

Açıklama

public void SoapServer::addFunction ( mixed $functions )

Exports one or more functions for remote clients

Değiştirgeler

functions

To export one function, pass the function name into this parameter as a string.

To export several functions, pass an array of function names.

To export all the functions, pass a special constant SOAP_FUNCTIONS_ALL.

Bilginize:

functions must receive all input arguments in the same order as defined in the WSDL file (They should not receive any output parameters as arguments) and return one or more values. To return several values they must return an array with named output parameters.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 SoapServer::addFunction() example

<?php

function echoString($inputString)
{
    return $inputString;
}

$server->addFunction("echoString");

function echoTwoStrings($inputString1, $inputString2)
{
    return array("outputString1" => $inputString1,
                 "outputString2" => $inputString2);
}
$server->addFunction(array("echoString", "echoTwoStrings"));

$server->addFunction(SOAP_FUNCTIONS_ALL);

?>

Ayrıca Bakınız

  • SoapServer::SoapServer() - SoapServer constructor
  • SoapServer::setClass() - Sets the class which handles SOAP requests

SoapServer
SoapServer::addSoapHeader
SoapServer


Add a SOAP header to the response

SoapServer::addFunction
SoapServer::__construct
SoapServer
PHP Manual

SoapServer::addSoapHeader

(PHP 5 >= 5.0.1, PHP 7)

SoapServer::addSoapHeader — Add a SOAP header to the response

Açıklama

public void SoapServer::addSoapHeader ( SoapHeader $object )

Adds a SOAP header to be returned with the response to the current request.

Değiştirgeler

object

The header to be returned.

Dönen Değerler

Hiçbir değer dönmez.

SoapServer::addFunction
SoapServer::__construct
SoapServer


SoapServer constructor

SoapServer::addSoapHeader
SoapServer::fault
SoapServer
PHP Manual

SoapServer::__construct

(PHP 5 >= 5.0.1, PHP 7)

SoapServer::__construct — SoapServer constructor

Açıklama

public SoapServer::__construct ( mixed $wsdl [, array $options ] )

Bu işlev şu işlevin takma adıdır: SoapServer::SoapServer()

SoapServer::addSoapHeader
SoapServer::fault
SoapServer


Issue SoapServer fault indicating an error

SoapServer::__construct
SoapServer::getFunctions
SoapServer
PHP Manual

SoapServer::fault

(PHP 5 >= 5.0.1, PHP 7)

SoapServer::fault — Issue SoapServer fault indicating an error

Açıklama

public void SoapServer::fault ( string $code , string $string [, string $actor [, string $details [, string $name ]]] )

Sends a response to the client of the current request indicating an error.

Bilginize:

This can only be called when handling a request.

Değiştirgeler

code

The error code to return

string

A brief description of the error

actor

A string identifying the actor that caused the fault.

details

More details of the fault

name

The name of the fault. This can be used to select a name from a WSDL file.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SoapFault::SoapFault() - SoapFault constructor

SoapServer::__construct
SoapServer::getFunctions
SoapServer


Returns list of defined functions

SoapServer::fault
SoapServer::handle
SoapServer
PHP Manual

SoapServer::getFunctions

(PHP 5 >= 5.0.1, PHP 7)

SoapServer::getFunctions — Returns list of defined functions

Açıklama

public array SoapServer::getFunctions ( void )

Returns a list of the defined functions in the SoapServer object. This method returns the list of all functions added by SoapServer::addFunction() or SoapServer::setClass().

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

An array of the defined functions.

Örnekler

Örnek 1 SoapServer::getFunctions() example

<?php
$server = new SoapServer(NULL, array("uri" => "http://test-uri"));
$server->addFunction(SOAP_FUNCTIONS_ALL);
if ($_SERVER["REQUEST_METHOD"] == "POST") {
  $server->handle();
} else {
  echo "This SOAP server can handle following functions: ";
  $functions = $server->getFunctions();
  foreach($functions as $func) {
    echo $func . "\n";
  }
}
?>

Ayrıca Bakınız

  • SoapServer::SoapServer() - SoapServer constructor
  • SoapServer::addFunction() - Adds one or more functions to handle SOAP requests
  • SoapServer::setClass() - Sets the class which handles SOAP requests

SoapServer::fault
SoapServer::handle
SoapServer


Handles a SOAP request

SoapServer::getFunctions
SoapServer::setClass
SoapServer
PHP Manual

SoapServer::handle

(PHP 5 >= 5.0.1, PHP 7)

SoapServer::handle — Handles a SOAP request

Açıklama

public void SoapServer::handle ([ string $soap_request ] )

Processes a SOAP request, calls necessary functions, and sends a response back.

Değiştirgeler

soap_request

The SOAP request. If this argument is omitted, the request is assumed to be in the raw POST data of the HTTP request.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 SoapServer::handle() example

<?php
function test($x)
{
    return $x;
}

$server = new SoapServer(null, array('uri' => "http://test-uri/"));
$server->addFunction("test");
$server->handle();
?>

Ayrıca Bakınız

  • SoapServer::SoapServer() - SoapServer constructor

SoapServer::getFunctions
SoapServer::setClass
SoapServer


Sets the class which handles SOAP requests

SoapServer::handle
SoapServer::setObject
SoapServer
PHP Manual

SoapServer::setClass

(PHP 5 >= 5.0.1, PHP 7)

SoapServer::setClass — Sets the class which handles SOAP requests

Açıklama

public void SoapServer::setClass ( string $class_name [, mixed $args [, mixed $... ]] )

Exports all methods from specified class.

The object can be made persistent across request for a given PHP session with the SoapServer::setPersistence() method.

Değiştirgeler

class_name

The name of the exported class.

args

These optional parameters will be passed to the default class constructor during object creation.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SoapServer::SoapServer() - SoapServer constructor
  • SoapServer::addFunction() - Adds one or more functions to handle SOAP requests
  • SoapServer::setPersistence() - Sets SoapServer persistence mode

SoapServer::handle
SoapServer::setObject
SoapServer


Sets the object which will be used to handle SOAP requests

SoapServer::setClass
SoapServer::setPersistence
SoapServer
PHP Manual

SoapServer::setObject

(PHP 5 >= 5.2.0, PHP 7)

SoapServer::setObject — Sets the object which will be used to handle SOAP requests

Açıklama

public void SoapServer::setObject ( object $object )

This sets a specific object as the handler for SOAP requests, rather than just a class as in SoapServer::setClass().

Değiştirgeler

object

The object to handle the requests.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • SoapServer::setClass() - Sets the class which handles SOAP requests

SoapServer::setClass
SoapServer::setPersistence
SoapServer


Sets SoapServer persistence mode

SoapServer::setObject
SoapServer::SoapServer
SoapServer
PHP Manual

SoapServer::setPersistence

(PHP 5 >= 5.1.2, PHP 7)

SoapServer::setPersistence — Sets SoapServer persistence mode

Açıklama

public void SoapServer::setPersistence ( int $mode )

This function allows changing the persistence state of a SoapServer object between requests. This function allows saving data between requests utilizing PHP sessions. This method only has an affect on a SoapServer after it has exported functions utilizing SoapServer::setClass().

Bilginize:

The persistence of SOAP_PERSISTENCE_SESSION makes only objects of the given class persistent, but not the class static data. In this case, use $this->bar instead of self::$bar.

Bilginize:

SOAP_PERSISTENCE_SESSION serializes data on the class object between requests. In order to properly utilize resources (e.g. PDO), __wakeup() and __sleep() magic methods should be utilized.

Değiştirgeler

mode

One of the SOAP_PERSISTENCE_XXX constants.

SOAP_PERSISTENCE_REQUEST - SoapServer data does not persist between requests. This is the default behavior of any SoapServer object after setClass is called.

SOAP_PERSISTENCE_SESSION - SoapServer data persists between requests. This is accomplished by serializing the SoapServer class data into $_SESSION['_bogus_session_name'], because of this session_start() must be called before this persistence mode is set.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 SoapServer::setPersistence() example

<?php
 class MyFirstPersistentSoapServer {
     private $resource; // (Such as PDO, mysqli, etc..)
     public $myvar1;
     public $myvar2;

     public function __construct() {
         $this->__wakeup(); // We're calling our wakeup to handle starting our resource
     }

     public function __wakeup() {
         $this->resource = CodeToStartOurResourceUp();
     }

     public function __sleep() {
         // We make sure to leave out $resource here, so our session data remains persistent
         // Failure to do so will result in the failure during the unserialization of data
         // on the next request; thus, our SoapObject would not be persistent across requests.
         return array('myvar1','myvar2');
     }
 }

 try {
     session_start();
     $server = new SoapServer(null, array('uri' => $_SERVER['REQUEST_URI']));
     $server->setClass('MyFirstPersistentSoapServer');
     // setPersistence MUST be called after setClass, because setClass's
     // behavior sets SESSION_PERSISTENCE_REQUEST upon enacting the method.
     $server->setPersistence(SOAP_PERSISTENCE_SESSION);
     $server->handle();
 } catch(SoapFault $e) {
     error_log("SOAP ERROR: ". $e->getMessage());
 }
?>

Ayrıca Bakınız

  • SoapServer::setClass() - Sets the class which handles SOAP requests

SoapServer::setObject
SoapServer::SoapServer
SoapServer


SoapServer constructor

SoapServer::setPersistence
SoapFault
SoapServer
PHP Manual

SoapServer::SoapServer

(PHP 5 >= 5.0.1, PHP 7)

SoapServer::SoapServer — SoapServer constructor

Açıklama

public SoapServer::SoapServer ( mixed $wsdl [, array $options ] )

This constructor allows the creation of SoapServer objects in WSDL or non-WSDL mode.

Değiştirgeler

wsdl

To use the SoapServer in WSDL mode, pass the URI of a WSDL file. Otherwise, pass NULL and set the uri option to the target namespace for the server.

options

Allow setting a default SOAP version (soap_version), internal character encoding (encoding), and actor URI (actor).

The classmap option can be used to map some WSDL types to PHP classes. This option must be an array with WSDL types as keys and names of PHP classes as values.

The typemap option is an array of type mappings. Type mapping is an array with keys type_name, type_ns (namespace URI), from_xml (callback accepting one string parameter) and to_xml (callback accepting one object parameter).

The cache_wsdl option is one of WSDL_CACHE_NONE, WSDL_CACHE_DISK, WSDL_CACHE_MEMORY or WSDL_CACHE_BOTH.

There is also a features option which can be set to SOAP_WAIT_ONE_WAY_CALLS, SOAP_SINGLE_ELEMENT_ARRAYS, SOAP_USE_XSI_ARRAY_TYPE.

The send_errors option can be set to FALSE to sent a generic error message ("Internal error") instead of the specific error message sent otherwise.

Örnekler

Örnek 1 SoapServer::SoapServer() example

<?php

$server = new SoapServer("some.wsdl");

$server = new SoapServer("some.wsdl", array('soap_version' => SOAP_1_2));

$server = new SoapServer("some.wsdl", array('actor' => "http://example.org/ts-tests/C"));

$server = new SoapServer("some.wsdl", array('encoding'=>'ISO-8859-1'));

$server = new SoapServer(null, array('uri' => "http://test-uri/"));

class MyBook {
    public $title;
    public $author;
}

$server = new SoapServer("books.wsdl", array('classmap' => array('book' => "MyBook")));

?>

Sürüm Bilgisi

Sürüm: | Açıklama
5.2.0 | Added the typemap option.

Ayrıca Bakınız

  • SoapClient::SoapClient() - SoapClient constructor

SoapServer::setPersistence
SoapFault
SoapServer


The SoapFault class

(PHP 5 >= 5.0.1, PHP 7)

Giriş

Represents a SOAP fault.

Sınıf Sözdizimi

SoapFault extends Exception {
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Yöntemler */
__construct ( string $faultcode , string $faultstring [, string $faultactor [, string $detail [, string $faultname [, string $headerfault ]]]] )
SoapFault ( string $faultcode , string $faultstring [, string $faultactor [, string $detail [, string $faultname [, string $headerfault ]]]] )
public string __toString ( void )
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}

İçindekiler

  • SoapFault::__construct — SoapFault constructor
  • SoapFault::SoapFault — SoapFault constructor
  • SoapFault::__toString — Obtain a string representation of a SoapFault
SoapServer::SoapServer
SoapFault::__construct
SOAP


SoapFault constructor

SoapFault
SoapFault::SoapFault
SoapFault
PHP Manual

SoapFault::__construct

(PHP 5 >= 5.0.1, PHP 7)

SoapFault::__construct — SoapFault constructor

Açıklama

SoapFault::__construct ( string $faultcode , string $faultstring [, string $faultactor [, string $detail [, string $faultname [, string $headerfault ]]]] )

Bu işlev şu işlevin takma adıdır: SoapFault::SoapFault()

SoapFault
SoapFault::SoapFault
SoapFault


SoapFault constructor

SoapFault::__construct
SoapFault::__toString
SoapFault
PHP Manual

SoapFault::SoapFault

(PHP 5 >= 5.0.1, PHP 7)

SoapFault::SoapFault — SoapFault constructor

Açıklama

SoapFault::SoapFault ( string $faultcode , string $faultstring [, string $faultactor [, string $detail [, string $faultname [, string $headerfault ]]]] )

This class is used to send SOAP fault responses from the PHP handler. faultcode, faultstring, faultactor and detail are standard elements of a SOAP Fault.

Değiştirgeler

faultcode

The error code of the SoapFault.

faultstring

The error message of the SoapFault.

faultactor

A string identifying the actor that caused the error.

detail

More details about the cause of the error.

faultname

Can be used to select the proper fault encoding from WSDL.

headerfault

Can be used during SOAP header handling to report an error in the response header.

Örnekler

Örnek 1 Some examples

<?php
function test($x)
{
    return new SoapFault("Server", "Some error message");
}

$server = new SoapServer(null, array('uri' => "http://test-uri/"));
$server->addFunction("test");
$server->handle();
?>

It is possible to use PHP exception mechanism to throw SOAP Fault.

Örnek 2 Some examples

<?php
function test($x)
{
    throw new SoapFault("Server", "Some error message");
}

$server = new SoapServer(null, array('uri' => "http://test-uri/"));
$server->addFunction("test");
$server->handle();
?>

Ayrıca Bakınız

  • SoapServer::fault() - Issue SoapServer fault indicating an error
  • is_soap_fault() - Checks if a SOAP call has failed

SoapFault::__construct
SoapFault::__toString
SoapFault


Obtain a string representation of a SoapFault

SoapFault::SoapFault
SoapHeader
SoapFault
PHP Manual

SoapFault::__toString

(PHP 5 >= 5.0.1, PHP 7)

SoapFault::__toString — Obtain a string representation of a SoapFault

Açıklama

public string SoapFault::__toString ( void )

Returns a string representation of the SoapFault.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A string describing the SoapFault.

SoapFault::SoapFault
SoapHeader
SoapFault


The SoapHeader class

(PHP 5 >= 5.0.1, PHP 7)

Giriş

Represents a SOAP header.

Sınıf Sözdizimi

SoapHeader {
/* Yöntemler */
__construct ( string $namespace , string $name [, mixed $data [, bool $mustunderstand [, string $actor ]]] )
SoapHeader ( string $namespace , string $name [, mixed $data [, bool $mustunderstand = false [, string $actor ]]] )
}

İçindekiler

  • SoapHeader::__construct — SoapHeader constructor
  • SoapHeader::SoapHeader — SoapHeader constructor
SoapFault::__toString
SoapHeader::__construct
SOAP


SoapHeader constructor

SoapHeader
SoapHeader::SoapHeader
SoapHeader
PHP Manual

SoapHeader::__construct

(PHP 5 >= 5.0.1, PHP 7)

SoapHeader::__construct — SoapHeader constructor

Açıklama

SoapHeader::__construct ( string $namespace , string $name [, mixed $data [, bool $mustunderstand [, string $actor ]]] )

Bu işlev şu işlevin takma adıdır: SoapHeader::SoapHeader()

SoapHeader
SoapHeader::SoapHeader
SoapHeader


SoapHeader constructor

SoapHeader::__construct
SoapParam
SoapHeader
PHP Manual

SoapHeader::SoapHeader

(PHP 5 >= 5.0.1, PHP 7)

SoapHeader::SoapHeader — SoapHeader constructor

Açıklama

SoapHeader::SoapHeader ( string $namespace , string $name [, mixed $data [, bool $mustunderstand = false [, string $actor ]]] )

Constructs a new SoapHeader object.

Değiştirgeler

namespace

The namespace of the SOAP header element.

name

The name of the SoapHeader object.

data

A SOAP header's content. It can be a PHP value or a SoapVar object.

mustUnderstand

Value of the mustUnderstand attribute of the SOAP header element.

actor

Value of the actor attribute of the SOAP header element.

Örnekler

Örnek 1 SoapHeader::SoapHeader() example

<?php
$client = new SoapClient(null, array('location' => "http://localhost/soap.php",
                                     'uri'      => "http://test-uri/"));
$client->__soapCall("echoVoid", null, null,
                new SoapHeader('http://soapinterop.org/echoheader/',
                               'echoMeStringRequest',
                               'hello world'));
?>

Ayrıca Bakınız

  • SoapClient::__soapCall() - Calls a SOAP function
  • SoapVar::SoapVar() - SoapVar constructor
  • SoapParam::SoapParam() - SoapParam constructor
  • SoapServer::addSoapHeader() - Add a SOAP header to the response

SoapHeader::__construct
SoapParam
SoapHeader


The SoapParam class

(PHP 5 >= 5.0.1, PHP 7)

Giriş

Represents parameter to a SOAP call.

Sınıf Sözdizimi

SoapParam {
/* Yöntemler */
__construct ( mixed $data , string $name )
SoapParam ( mixed $data , string $name )
}

İçindekiler

  • SoapParam::__construct — SoapParam constructor
  • SoapParam::SoapParam — SoapParam constructor
SoapHeader::SoapHeader
SoapParam::__construct
SOAP


SoapParam constructor

SoapParam
SoapParam::SoapParam
SoapParam
PHP Manual

SoapParam::__construct

(PHP 5 >= 5.0.1, PHP 7)

SoapParam::__construct — SoapParam constructor

Açıklama

SoapParam::__construct ( mixed $data , string $name )

Bu işlev şu işlevin takma adıdır: SoapParam::SoapParam()

SoapParam
SoapParam::SoapParam
SoapParam


SoapParam constructor

SoapParam::__construct
SoapVar
SoapParam
PHP Manual

SoapParam::SoapParam

(PHP 5 >= 5.0.1, PHP 7)

SoapParam::SoapParam — SoapParam constructor

Açıklama

SoapParam::SoapParam ( mixed $data , string $name )

Constructs a new SoapParam object.

Değiştirgeler

data

The data to pass or return. This parameter can be passed directly as PHP value, but in this case it will be named as paramN and the SOAP service may not understand it.

name

The parameter name.

Örnekler

Örnek 1 SoapParam::SoapParam() example

<?php
$client = new SoapClient(null,array('location' => "http://localhost/soap.php",
                                    'uri'      => "http://test-uri/"));
$client->SomeFunction(new SoapParam($a, "a"),
                      new SoapParam($b, "b"),
                      new SoapParam($c, "c"));
?>

Ayrıca Bakınız

  • SoapClient::__soapCall() - Calls a SOAP function
  • SoapVar::SoapVar() - SoapVar constructor

SoapParam::__construct
SoapVar
SoapParam


The SoapVar class

(PHP 5 >= 5.0.1, PHP 7)

Giriş

A class representing a variable or object for use with SOAP services.

Sınıf Sözdizimi

SoapVar {
/* Yöntemler */
__construct ( mixed $data , string $encoding [, string $type_name [, string $type_namespace [, string $node_name [, string $node_namespace ]]]] )
SoapVar ( mixed $data , string $encoding [, string $type_name [, string $type_namespace [, string $node_name [, string $node_namespace ]]]] )
}

İçindekiler

  • SoapVar::__construct — SoapVar constructor
  • SoapVar::SoapVar — SoapVar constructor
SoapParam::SoapParam
SoapVar::__construct
SOAP


SoapVar constructor

SoapVar
SoapVar::SoapVar
SoapVar
PHP Manual

SoapVar::__construct

(PHP 5 >= 5.0.1, PHP 7)

SoapVar::__construct — SoapVar constructor

Açıklama

SoapVar::__construct ( mixed $data , string $encoding [, string $type_name [, string $type_namespace [, string $node_name [, string $node_namespace ]]]] )

Bu işlev şu işlevin takma adıdır: SoapVar::SoapVar()

SoapVar
SoapVar::SoapVar
SoapVar


SoapVar constructor

SoapVar::__construct
Yar
SoapVar
PHP Manual

SoapVar::SoapVar

(PHP 5 >= 5.0.1, PHP 7)

SoapVar::SoapVar — SoapVar constructor

Açıklama

SoapVar::SoapVar ( mixed $data , string $encoding [, string $type_name [, string $type_namespace [, string $node_name [, string $node_namespace ]]]] )

Constructs a new SoapVar object.

Değiştirgeler

data

The data to pass or return.

encoding

The encoding ID, one of the XSD_... constants.

type_name

The type name.

type_namespace

The type namespace.

node_name

The XML node name.

node_namespace

The XML node namespace.

Örnekler

Örnek 1 SoapVar::SoapVar() example

<?php
class SOAPStruct {
    function SOAPStruct($s, $i, $f)
    {
        $this->varString = $s;
        $this->varInt = $i;
        $this->varFloat = $f;
    }
}
$client = new SoapClient(null, array('location' => "http://localhost/soap.php",
                                     'uri'      => "http://test-uri/"));
$struct = new SOAPStruct('arg', 34, 325.325);
$soapstruct = new SoapVar($struct, SOAP_ENC_OBJECT, "SOAPStruct", "http://soapinterop.org/xsd");
$client->echoStruct(new SoapParam($soapstruct, "inputStruct"));
?>

Ayrıca Bakınız

  • SoapClient::__soapCall() - Calls a SOAP function
  • SoapParam::SoapParam() - SoapParam constructor

SoapVar::__construct
Yar
SoapVar


Yet Another RPC Framework

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
  • Yar_Server — The Yar_Server class
    • Yar_Server::__construct — Register a server
    • Yar_Server::handle — Start RPC Server
  • Yar_Client — The Yar_Client class
    • Yar_Client::__call — Call service
    • Yar_Client::__construct — Create a client
    • Yar_Client::setOpt — Set calling contexts
  • Yar_Concurrent_Client — The Yar_Concurrent_Client class
    • Yar_Concurrent_Client::call — Register a concurrent call
    • Yar_Concurrent_Client::loop — Send all calls
    • Yar_Concurrent_Client::reset — Clean all registered calls
  • Yar_Server_Exception — The Yar_Server_Exception class
    • Yar_Server_Exception::getType — The getType purpose
  • Yar_Client_Exception — The Yar_Client_Exception class
    • Yar_Client_Exception::getType — The getType purpose
SoapVar::SoapVar
Giriş
HTTP Hizmetleri


Giriş

Yar is a RPC framework which aims to provide a simple and easy way to do communication between PHP applications It has the ability to concurrently call multiple remote services.

Yar
Yapılandırma/Kurulum
Yar


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Yar


Gereksinimler

if you want to use msgpack as packager, you need compile Yar by your self with ./configure --enable-msgpack

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu » PECL eklentisi PHP ile gelmez.

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/yar.

Bu PECL eklentisi için bir DLL mevcut değildir. Ayrıca, Windows üzerinde kurulum bölümüne de bakınız.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Yar Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
yar.packager | php | PHP_INI_SYSTEM |
yar.debug | Off | PHP_INI_ALL |
yar.connect_timeout | 1000 | PHP_INI_ALL |
yar.timeout | 5000 | PHP_INI_ALL |
yar.expose_info | On | PHP_INI_SYS |

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

yar.packager string

it could be php, json, and msgpack(require built with msgpack support)

yar.debug string

yar.connect_timeout integer

timeout in ms

yar.timeout integer

timeout in ms

yar.expose_info bool

whether expose the service info(when access the server via GET)

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

YAR_VERSION (string)
YAR_CLIENT_PROTOCOL_HTTP (integer)
YAR_CLIENT_OPT_PACKAGER (integer)
YAR_CLIENT_OPT_TIMEOUT (integer)
YAR_CLIENT_OPT_CONNECT_TIMEOUT (integer)
YAR_PACKAGER_PHP (string)
YAR_PACKAGER_JSON (string)
YAR_ERR_OKEY (integer)
YAR_ERR_OUTPUT (integer)
YAR_ERR_TRANSPORT (integer)
YAR_ERR_REQUEST (integer)
YAR_ERR_PROTOCOL (integer)
YAR_ERR_PACKAGER (integer)
YAR_ERR_EXCEPTION (integer)

Özkaynak Türleri
Örnekler
Yar


Örnekler

Örnek 1 Yar Server Example

<?php

/* assume this page can be accessed by http://example.com/operator.php */

class Operator {

    /**
     * Add two operands
     * @param interge
     * @return interge
     */
    public function add($a, $b) {
        return $this->_add($a, $b);
    }

    /**
     * Sub
     */
    public function sub($a, $b) {
        return $a - $b;
    }

    /**
     * Mul
     */
    public function mul($a, $b) {
        return $a * $b;
    }

    /**
     * Protected methods will not be exposed
     * @param interge
     * @return interge
     */
    protected function _add($a, $b) {
        return $a + $b;
    }
}

$server = new Yar_Server(new Operator());
$server->handle();
?>

Örnek 2 Access the server in borwser(GET request)

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Yar Server Info

Örnek 3 Yar Client Example

<?php
$client = new yar_client("http://example.com/operator.php");

/* call directly */
var_dump($client->add(1, 2));

/* call via call */
var_dump($client->call("add", array(3, 2)));

/* __add can not be called */
var_dump($client->_add(1, 2));
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

int(3)
int(5)
PHP Fatal error:  Uncaught exception 'Yar_Server_Exception' with message 'call to api Operator::_add() failed' in *

Örnek 4 Yar Concurrent Client Example

<?php
function callback($ret, $callinfo) {
    echo $callinfo['method'] , " result: ", $ret , "\n";
}

/* register async call to remote services */
Yar_Concurrent_Client::call("http://example.com/operator.php", "add", array(1, 2), "callback");
Yar_Concurrent_Client::call("http://example.com/operator.php", "sub", array(2, 1), "callback");
Yar_Concurrent_Client::call("http://example.com/operator.php", "mul", array(2, 2), "callback");

/* sent all request and wait for response */
Yar_Concurrent_Client::loop();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

mul result: 4
sub result: 1
add result: 3
Öntanımlı Sabitler
Yar_Server
Yar


The Yar_Server class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

Sınıf Sözdizimi

Yar_Server {
/* Özellikler */
protected $_executor ;
/* Yöntemler */
final public __construct ( Object $obj )
public boolean handle ( void )
}

Özellikler

_executor

İçindekiler

  • Yar_Server::__construct — Register a server
  • Yar_Server::handle — Start RPC Server
Örnekler
Yar_Server::__construct
Yar


Register a server

Yar_Server
Yar_Server::handle
Yar_Server
PHP Manual

Yar_Server::__construct

(PECL yar >= 1.0.0)

Yar_Server::__construct — Register a server

Açıklama

final public Yar_Server::__construct ( Object $obj )

Set up a Yar HTTP RPC Server, All the public methods of $obj will be register as a RPC service.

Değiştirgeler

obj

An Object, all public methods of its will be registered as RPC services.

Dönen Değerler

An instance of Yar_Server.

Örnekler

Örnek 1 Yar_Server::__construct() example

<?php
class API {
    /**
     * the doc info will be generated automatically into service info page.
     * @params
     * @return
     */
    public function some_method($parameter, $option = "foo") {
         return "some_method";
    }

    protected function client_can_not_see() {
    }
}

$service = new Yar_Server(new API());
$service->handle();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ayrıca Bakınız

  • Yar_Server::handle() - Start RPC Server
    •

Yar_Server

Yar_Server::handle

Yar_Server


Start RPC Server

Yar_Server::__construct
Yar_Client
Yar_Server
PHP Manual

Yar_Server::handle

(PECL yar >= 1.0.0)

Yar_Server::handle — Start RPC Server

Açıklama

public boolean Yar_Server::handle ( void )

Start a RPC HTTP server, and ready for accpet RPC requests.

Bilginize:

Usual RPC calls will be issued as HTTP POST requests. If a HTTP GET request is issued to the uri, the service information (commented section above) will be printed on the page

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

boolean

Örnekler

Örnek 1 Yar_Server::handle() example

<?php
class API {
    /**
     * the doc info will be generated automatically into service info page.
     * @params
     * @return
     */
    public function some_method($parameter, $option = "foo") {
    }

    protected function client_can_not_see() {
    }
}

$service = new Yar_Server(new API());
$service->handle();
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ayrıca Bakınız

  • Yar_Server::__construct() - Register a server
    •

Yar_Server::__construct

Yar_Client

Yar_Server


The Yar_Client class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

Sınıf Sözdizimi

Yar_Client {
/* Özellikler */
protected $_protocol ;
protected $_uri ;
protected $_options ;
protected $_running ;
/* Yöntemler */
public void __call ( string $method , array $parameters )
final public __construct ( string $url )
public boolean setOpt ( number $name , mixed $value )
}

Özellikler

_protocol

_uri

_options

_running

İçindekiler

  • Yar_Client::__call — Call service
  • Yar_Client::__construct — Create a client
  • Yar_Client::setOpt — Set calling contexts
Yar_Server::handle
Yar_Client::__call
Yar


Call service

Yar_Client
Yar_Client::__construct
Yar_Client
PHP Manual

Yar_Client::__call

(PECL yar >= 1.0.0)

Yar_Client::__call — Call service

Açıklama

public void Yar_Client::__call ( string $method , array $parameters )

Issue a call to remote RPC method.

Değiştirgeler

method

Remote RPC method name.

parameters

Parameters.

Dönen Değerler

Örnekler

Örnek 1 Yar_Client::__call() example

<?php

$client = new Yar_Client("http://host/api/");

/* call remote service */
$result = $client->some_method("parameter");
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ayrıca Bakınız

  • Yar_Client::setOpt() - Set calling contexts
    •

Yar_Client

Yar_Client::__construct

Yar_Client


Create a client

Yar_Client::__call
Yar_Client::setOpt
Yar_Client
PHP Manual

Yar_Client::__construct

(PECL yar >= 1.0.0)

Yar_Client::__construct — Create a client

Açıklama

final public Yar_Client::__construct ( string $url )

Create a Yar_Client to a Yar_Server.

Değiştirgeler

url

Yar Server URL.

Dönen Değerler

Yar_Client instance.

Örnekler

Örnek 1 Yar_Client::__construct() example

<?php
$client = new Yar_Client("http://host/api/");
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ayrıca Bakınız

  • Yar_Client::__call() - Call service
    •

  • Yar_Client::setOpt() - Set calling contexts
    •

Yar_Client::__call

Yar_Client::setOpt

Yar_Client


Set calling contexts

Yar_Client::__construct
Yar_Concurrent_Client
Yar_Client
PHP Manual

Yar_Client::setOpt

(PECL yar >= 1.0.0)

Yar_Client::setOpt — Set calling contexts

Açıklama

public boolean Yar_Client::setOpt ( number $name , mixed $value )

Değiştirgeler

name

it can be: YAR_OPT_PACKAGER, YAR_OPT_PERSISTENT (Need server support), YAR_OPT_TIMEOUT, YAR_OPT_CONNECT_TIMEOUT

value

Dönen Değerler

Örnekler

Örnek 1 Yar_Client::setOpt() example

<?php

$cient = new Yar_Client("http://host/api/");

//Set timeout to 1s
$client->SetOpt(YAR_OPT_CONNECT_TIMEOUT, 1000);

//Set packager to JSON
$client->SetOpt(YAR_OPT_PACKAGER, "json");

/* call remote service */
$result = $client->some_method("parameter");
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ayrıca Bakınız

  • Yar_Client::__call() - Call service
    •

Yar_Client::__construct

Yar_Concurrent_Client

Yar_Client


The Yar_Concurrent_Client class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

Sınıf Sözdizimi

Yar_Concurrent_Client {
/* Özellikler */
static $_callstack ;
static $_callback ;
static $_error_callback ;
/* Yöntemler */
public static int call ( string $uri , string $method , array $parameters [, callable $callback ] )
public static boolean loop ([ callable $callback [, callable $error_callback ]] )
public static boolean reset ( void )
}

Özellikler

_callstack

_callback

_error_callback

İçindekiler

  • Yar_Concurrent_Client::call — Register a concurrent call
  • Yar_Concurrent_Client::loop — Send all calls
  • Yar_Concurrent_Client::reset — Clean all registered calls
Yar_Client::setOpt
Yar_Concurrent_Client::call
Yar


Register a concurrent call

Yar_Concurrent_Client
Yar_Concurrent_Client::loop
Yar_Concurrent_Client
PHP Manual

Yar_Concurrent_Client::call

(PECL yar >= 1.0.0)

Yar_Concurrent_Client::call — Register a concurrent call

Açıklama

public static int Yar_Concurrent_Client::call ( string $uri , string $method , array $parameters [, callable $callback ] )

Register a RPC call, but won't sent it immediately, it will be send while further call to Yar_Concurrent_Client::loop()

Değiştirgeler

uri

The RPC server URI(http, tcp)

method

Service name(aka the method name)

parameters

Parameters

callback

A function callback, which will be called while the response return.

Dönen Değerler

An unique id, can be used to identified which call it is.

Örnekler

Örnek 1 Yar_Concurrent_Client::call() example

<?php
function callback($retval, $callinfo) {
     var_dump($retval);
}

function error_callback($type, $error, $callinfo) {
    error_log($error);
}

Yar_Concurrent_Client::call("http://host/api/", "some_method", array("parameters"), "callback");
Yar_Concurrent_Client::call("http://host/api/", "some_method", array("parameters"));   // if the callback is not specificed,
                                                                               // callback in loop will be used
Yar_Concurrent_Client::call("http://host/api/", "some_method", array("parameters"), "callback", NULL, array(YAR_OPT_PACKAGER => "json"));
                                                                               //this server accept json packager
Yar_Concurrent_Client::call("http://host/api/", "some_method", array("parameters"), "callback", NULL, array(YAR_OPT_TIMEOUT=>1));
                                                                               //custom timeout

//The requests are not sent yet
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ayrıca Bakınız

  • Yar_Concurrent_Client::loop() - Send all calls
    •

  • Yar_Concurrent_Client::reset() - Clean all registered calls
    •

  • Yar_Server::__construct() - Register a server
    •

  • Yar_Server::handle() - Start RPC Server
    •

Yar_Concurrent_Client

Yar_Concurrent_Client::loop

Yar_Concurrent_Client


Send all calls

Yar_Concurrent_Client::call
Yar_Concurrent_Client::reset
Yar_Concurrent_Client
PHP Manual

Yar_Concurrent_Client::loop

(PECL yar >= 1.0.0)

Yar_Concurrent_Client::loop — Send all calls

Açıklama

public static boolean Yar_Concurrent_Client::loop ([ callable $callback [, callable $error_callback ]] )

Send all registed remote RPC calls.

Değiştirgeler

callback

If this callback is set, then Yar will call this callback after all calls are sent and before any response return, with a $callinfo NULL.

Then, if user didn't specify callback when registering concurrent call, this callback will be used to handle response, otherwise, the callback specified while registering will be used.

error_callback

If this callback is set, then Yar will call this callback while error occurred.

Dönen Değerler

Örnekler

Örnek 1 Yar_Concurrent_Client::loop() example

<?php
function callback($retval, $callinfo) {
     if ($callinfo == NULL) {
        echo "Now, all requests are sent, and no any response available\n";
     } else {
        echo "This is a remote call response, the method name is", $callinfo["method"],
             ". calling sequence is " , $callinfo["sequence"] , "\n";
        var_dump($retval);
     }
}

function error_callback($type, $error, $callinfo) {
    error_log($error);
}

Yar_Concurrent_Client::call("http://host/api/", "some_method", array("parameters"), "callback");
Yar_Concurrent_Client::call("http://host/api/", "some_method", array("parameters"));   // if the callback is not specificed,
                                                                               // callback in loop will be used
Yar_Concurrent_Client::call("http://host/api/", "some_method", array("parameters"), "callback", NULL, array(YAR_OPT_PACKAGER => "json"));
                                                                               //this server accept json packager
Yar_Concurrent_Client::call("http://host/api/", "some_method", array("parameters"), "callback", NULL, array(YAR_OPT_TIMEOUT=>1));
                                                                               //custom timeout

Yar_Concurrent_Client::loop("callback", "error_callback"); //send the requests,
                                                           //the error_callback is optional
?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Now, all requests are sent, and no any response available
This is a remote call response, the method name issome_method. calling sequence is 4
string(11) "some_method"
This is a remote call response, the method name issome_method. calling sequence is 1
string(11) "some_method"
This is a remote call response, the method name issome_method. calling sequence is 2
string(11) "some_method"
This is a remote call response, the method name issome_method. calling sequence is 3
string(11) "some_method"

Ayrıca Bakınız

  • Yar_Concurrent_Client::call() - Register a concurrent call
  • Yar_Concurrent_Client::reset() - Clean all registered calls
  • Yar_Server::__construct() - Register a server
  • Yar_Server::handle() - Start RPC Server
Yar_Concurrent_Client::call
Yar_Concurrent_Client::reset
Yar_Concurrent_Client


Clean all registered calls

Yar_Concurrent_Client::loop
Yar_Server_Exception
Yar_Concurrent_Client
PHP Manual

Yar_Concurrent_Client::reset

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Yar_Concurrent_Client::reset — Clean all registered calls

Açıklama

public static boolean Yar_Concurrent_Client::reset ( void )

Clean all registered calls

Değiştirgeler

Dönen Değerler

Örnekler

Örnek 1 Yar_Concurrent_Client::reset() example

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Ayrıca Bakınız

  • Yar_Concurrent_Client::call() - Register a concurrent call
    •

  • Yar_Concurrent_Client::loop() - Send all calls
    •

  • Yar_Server::__construct() - Register a server
    •

  • Yar_Server::handle() - Start RPC Server
    •

Yar_Concurrent_Client::loop

Yar_Server_Exception

Yar_Concurrent_Client


The Yar_Server_Exception class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

If service threw exceptions, A Yar_Server_Exception will be threw in client side.

Sınıf Sözdizimi

Yar_Server_Exception extends Exception {
/* Özellikler */
protected $_type ;
/* Yöntemler */
public string getType ( void )
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}

Özellikler

message

code

file

line

_type

İçindekiler

  • Yar_Server_Exception::getType — The getType purpose
Yar_Concurrent_Client::reset
Yar_Server_Exception::getType
Yar


The getType purpose

Yar_Server_Exception
Yar_Client_Exception
Yar_Server_Exception
PHP Manual

Yar_Server_Exception::getType

(PECL yar >= 1.0.0)

Yar_Server_Exception::getType — The getType purpose

Açıklama

public string Yar_Server_Exception::getType ( void )

Get the exception original type threw by server

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

string

Örnekler

Örnek 1 Yar_Server_Exception::getType() example

//Server.php
<?php
class Custom_Exception extends Exception {};

class API {
    public function throw_exception($name) {
        throw new Custom_Exception($name);
    }
}

$service = new Yar_Server(new API());
$service->handle();
?>

//Client.php
<?php
$client = new Yar_Client("http://host/api.php");

try {
    $client->throw_exception("client");
} catch (Yar_Server_Exception $e) {
    var_dump($e->getType());
    var_dump($e->getMessage());
}

Yukarıdaki örnek şuna benzer bir çıktı üretir:

string(16) "Custom_Exception"
string(6) "client"

Ayrıca Bakınız

Yar_Server_Exception
Yar_Client_Exception
Yar_Server_Exception


The Yar_Client_Exception class

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

Giriş

Sınıf Sözdizimi

Yar_Client_Exception extends Exception {
/* Özellikler */
/* Yöntemler */
public void getType ( void )
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}

Özellikler

message

code

file

line

İçindekiler

  • Yar_Client_Exception::getType — The getType purpose
Yar_Server_Exception::getType
Yar_Client_Exception::getType
Yar


The getType purpose

Yar_Client_Exception
XML-RPC
Yar_Client_Exception
PHP Manual

Yar_Client_Exception::getType

(PECL yar >= 1.0.0)

Yar_Client_Exception::getType — The getType purpose

Açıklama

public void Yar_Client_Exception::getType ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Örnekler

Örnek 1 Yar_Client_Exception::getType() example

<?php

/* ... */

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

...

Ayrıca Bakınız

Yar_Client_Exception
XML-RPC
Yar_Client_Exception


XML-RPC

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • XML-RPC İşlevleri
    • xmlrpc_decode_request — XML'i doğal PHP türlerine dönüştürür
    • xmlrpc_decode — XML'i doğal PHP türlerine dönüştürür
    • xmlrpc_encode_request — Bir yöntem çağrısı için XML üretir
    • xmlrpc_encode — Bir PHP değeri için XML üretir
    • xmlrpc_get_type — Bir PHP değerinin xmlrpc türünü döndürür
    • xmlrpc_is_fault — Bir dizinin bir XMLRPC hatasını gösterip göstermediğini tespit eder
    • xmlrpc_parse_method_descriptions — XML'i bir yöntem açıklamaları listesine dönüştürür
    • xmlrpc_server_add_introspection_data — Kendiliğinden üretilen belgeleme ekler
    • xmlrpc_server_call_method — XML isteklerini ve yöntem çağrılarını çözümler
    • xmlrpc_server_create — Bir xmlrpc sunucusu oluşturur
    • xmlrpc_server_destroy — Sunucuya ayrılan özkaynakları serbest bırakır
    • xmlrpc_server_register_introspection_callback — Belge üretimi için bir PHP işlevi atar
    • xmlrpc_server_register_method — Belirtilen yöntemle eşleşen özkaynak için bir PHP işlevi atar
    • xmlrpc_set_type — Bir PHP dizge değeri için xmlrpc türünü base64 veya datetime türüne dönüştürür
Yar_Client_Exception::getType
Giriş
HTTP Hizmetleri


Giriş

Bu işlevler XML-RPC sunucularını ve istemcilerini yazmakta kullanılabilir. » http://www.xmlrpc.com/ adresinde XML-RPC hakkında daha ayrıntılı bilgi bulabilirsiniz. Bu eklenti ve işlevleri hakkında daha fazla bilgi edinmek için » http://xmlrpc-epi.sourceforge.net/ adresine bakınız.

Uyarı

Bu eklenti DENEYSELDİR. Bu eklentinin davranışı, işlev isimleri ve tüm belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu eklentiyi kullanmayın.

XML-RPC
Yapılandırma/Kurulum
XML-RPC


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
XML-RPC


Kurulum

PHP'de XML-RPC desteği öntanımlı olarak etkin değildir. XML-RPC desteğini etkin kılmak için PHP'yi derlerken --with-xmlrpc[=DiZiN] yapılandırma seçeneğini kullanmalısınız. Bu eklenti PHP 4.1.0'dan beri PHP kaynak paketinde yer almaktadır.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Özkaynak Türleri

Bu eklenti xmlrpc_server_create() tarafından döndürülen bir XML-RPC sunucu özkaynağına sahiptir.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
XML-RPC İşlevleri
XML-RPC


XML-RPC İşlevleri

İçindekiler

  • xmlrpc_decode_request — XML'i doğal PHP türlerine dönüştürür
  • xmlrpc_decode — XML'i doğal PHP türlerine dönüştürür
  • xmlrpc_encode_request — Bir yöntem çağrısı için XML üretir
  • xmlrpc_encode — Bir PHP değeri için XML üretir
  • xmlrpc_get_type — Bir PHP değerinin xmlrpc türünü döndürür
  • xmlrpc_is_fault — Bir dizinin bir XMLRPC hatasını gösterip göstermediğini tespit eder
  • xmlrpc_parse_method_descriptions — XML'i bir yöntem açıklamaları listesine dönüştürür
  • xmlrpc_server_add_introspection_data — Kendiliğinden üretilen belgeleme ekler
  • xmlrpc_server_call_method — XML isteklerini ve yöntem çağrılarını çözümler
  • xmlrpc_server_create — Bir xmlrpc sunucusu oluşturur
  • xmlrpc_server_destroy — Sunucuya ayrılan özkaynakları serbest bırakır
  • xmlrpc_server_register_introspection_callback — Belge üretimi için bir PHP işlevi atar
  • xmlrpc_server_register_method — Belirtilen yöntemle eşleşen özkaynak için bir PHP işlevi atar
  • xmlrpc_set_type — Bir PHP dizge değeri için xmlrpc türünü base64 veya datetime türüne dönüştürür
Öntanımlı Sabitler
xmlrpc_decode_request
XML-RPC


XML'i doğal PHP türlerine dönüştürür

XML-RPC İşlevleri
xmlrpc_decode
XML-RPC İşlevleri
PHP Manual

xmlrpc_decode_request

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

xmlrpc_decode_request — XML'i doğal PHP türlerine dönüştürür

Açıklama

mixed xmlrpc_decode_request ( string $xml , string &$yöntem [, string $kodlama ] )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

XML-RPC İşlevleri
xmlrpc_decode
XML-RPC İşlevleri


XML'i doğal PHP türlerine dönüştürür

xmlrpc_decode_request
xmlrpc_encode_request
XML-RPC İşlevleri
PHP Manual

xmlrpc_decode

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

xmlrpc_decode — XML'i doğal PHP türlerine dönüştürür

Açıklama

mixed xmlrpc_decode ( string $xml [, string $kodlama = "iso-8859-1" ] )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Değiştirgeler

xml

XMLRPC yöntemi tarafından döndürülen XML yanıtı.

kodlama

iconv tarafından desteklenen karakter kodlamalarından biri.

Dönen Değerler

XMLRPC yöntemiyle döndürülen yanıta göre bir dizi, bir tamsayı, bir dizge veya mantıksal bir değer döner.

Örnekler

xmlrpc_encode_request() işlevindeki örneğe bakınız.

Ayrıca Bakınız

  • xmlrpc_encode_request() - Bir yöntem çağrısı için XML üretir
  • xmlrpc_is_fault() - Bir dizinin bir XMLRPC hatasını gösterip göstermediğini tespit eder

xmlrpc_decode_request
xmlrpc_encode_request
XML-RPC İşlevleri


Bir yöntem çağrısı için XML üretir

xmlrpc_decode
xmlrpc_encode
XML-RPC İşlevleri
PHP Manual

xmlrpc_encode_request

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

xmlrpc_encode_request — Bir yöntem çağrısı için XML üretir

Açıklama

string xmlrpc_encode_request ( string $yöntem , mixed $değiştirgeler [, array $çıktı_seçenekleri ] )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Değiştirgeler

yöntem

Çağrılacak yöntemin ismi.

değiştirgeler

Yöntem bildirimiyle uyumlu yöntem değiştirgeleri.

çıktı_seçenekleri

Çıktı seçenekleri bir dizi olarak belirtilir ve dizi şunları içerebilir (öntanımlı değerler vurgulanmış, Türkçe anlamları ayrıca verilmiştir):

  • output_type: php, xml (çıktı türü: php, xml)

  • verbosity: no_white_space, newlines_only, pretty (ayrıntı düzeyi: boşluksuz, sadece satırsonu karakterleri, olduğu gibi)

  • escaping: cdata, non-ascii, non-print, markup (öncelem: CDATA bölümü, ascii-dışı, basılmayan, imlenim - Değer bir dizge olabileceği gibi çok sayıda değer içeren bir dizi de olabilir.)

  • version: simple, xmlrpc, soap 1.1, auto (sürüm: basit, ...)

  • encoding: utf-8, ... (kodlama: utf-8 veya iconv tarafından desteklenen herhangi bir karakter kümesi)

Dönen Değerler

İsteğin XML gösterimini içeren bir dizge döner.

Örnekler

Örnek 1 - XMLRPC istemci işlevleri örneği

<?php
$request = xmlrpc_encode_request("method", array(1, 2, 3));
$context = stream_context_create(array('http' => array(
    'method' => "POST",
    'header' => "Content-Type: text/xml",
    'content' => $request
)));
$file = file_get_contents("http://www.example.com/xmlrpc", false, $context);
$response = xmlrpc_decode($file);
if ($response && xmlrpc_is_fault($response)) {
    trigger_error("xmlrpc: $response[faultString] ($response[faultCode])");
} else {
    print_r($response);
}
?>

Ayrıca Bakınız

  • stream_context_create() - Bir akım bağlamı oluşturur
  • file_get_contents() - Dosya içeriğinin tamamını bir dizge olarak döndürür
  • xmlrpc_decode() - XML'i doğal PHP türlerine dönüştürür

xmlrpc_decode
xmlrpc_encode
XML-RPC İşlevleri


Bir PHP değeri için XML üretir

xmlrpc_encode_request
xmlrpc_get_type
XML-RPC İşlevleri
PHP Manual

xmlrpc_encode

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

xmlrpc_encode — Bir PHP değeri için XML üretir

Açıklama

string xmlrpc_encode ( mixed $değer )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

xmlrpc_encode_request
xmlrpc_get_type
XML-RPC İşlevleri


Bir PHP değerinin xmlrpc türünü döndürür

xmlrpc_encode
xmlrpc_is_fault
XML-RPC İşlevleri
PHP Manual

xmlrpc_get_type

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

xmlrpc_get_type — Bir PHP değerinin xmlrpc türünü döndürür

Açıklama

string xmlrpc_get_type ( mixed $değer )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Bu işlev, özellikle base64 ve datetime dizgelerinde kullanılır.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

xmlrpc_encode
xmlrpc_is_fault
XML-RPC İşlevleri


Bir dizinin bir XMLRPC hatasını gösterip göstermediğini tespit eder

xmlrpc_get_type
xmlrpc_parse_method_descriptions
XML-RPC İşlevleri
PHP Manual

xmlrpc_is_fault

(PHP 4 >= 4.3.0, PHP 5, PHP 7)

xmlrpc_is_fault — Bir dizinin bir XMLRPC hatasını gösterip göstermediğini tespit eder

Açıklama

bool xmlrpc_is_fault ( array $dizi )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Değiştirgeler

dizi

xmlrpc_decode() ile döndürülmüş bir dizi.

Dönen Değerler

$dizi bir hata içeriyorsa TRUE, aksi takdirde FALSE döner. Hatanın koduna $dizi["faultCode"], açıklamasına ise $dizi["faultString"] ile erişilir.

Örnekler

xmlrpc_encode_request() işlevindeki örneğe bakınız.

Ayrıca Bakınız

  • xmlrpc_decode() - XML'i doğal PHP türlerine dönüştürür

xmlrpc_get_type
xmlrpc_parse_method_descriptions
XML-RPC İşlevleri


XML'i bir yöntem açıklamaları listesine dönüştürür

xmlrpc_is_fault
xmlrpc_server_add_introspection_data
XML-RPC İşlevleri
PHP Manual

xmlrpc_parse_method_descriptions

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

xmlrpc_parse_method_descriptions — XML'i bir yöntem açıklamaları listesine dönüştürür

Açıklama

array xmlrpc_parse_method_descriptions ( string $xml )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

xmlrpc_is_fault
xmlrpc_server_add_introspection_data
XML-RPC İşlevleri


Kendiliğinden üretilen belgeleme ekler

xmlrpc_parse_method_descriptions
xmlrpc_server_call_method
XML-RPC İşlevleri
PHP Manual

xmlrpc_server_add_introspection_data

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

xmlrpc_server_add_introspection_data — Kendiliğinden üretilen belgeleme ekler

Açıklama

int xmlrpc_server_add_introspection_data ( resource $sunucu , array $açıklama )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

xmlrpc_parse_method_descriptions
xmlrpc_server_call_method
XML-RPC İşlevleri


XML isteklerini ve yöntem çağrılarını çözümler

xmlrpc_server_add_introspection_data
xmlrpc_server_create
XML-RPC İşlevleri
PHP Manual

xmlrpc_server_call_method

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

xmlrpc_server_call_method — XML isteklerini ve yöntem çağrılarını çözümler

Açıklama

string xmlrpc_server_call_method ( resource $sunucu , string $xml , mixed $kullanıcı_verisi [, array $çıktı_seçenekleri ] )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

xmlrpc_server_add_introspection_data
xmlrpc_server_create
XML-RPC İşlevleri


Bir xmlrpc sunucusu oluşturur

xmlrpc_server_call_method
xmlrpc_server_destroy
XML-RPC İşlevleri
PHP Manual

xmlrpc_server_create

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

xmlrpc_server_create — Bir xmlrpc sunucusu oluşturur

Açıklama

resource xmlrpc_server_create ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

xmlrpc_server_call_method
xmlrpc_server_destroy
XML-RPC İşlevleri


Sunucuya ayrılan özkaynakları serbest bırakır

xmlrpc_server_create
xmlrpc_server_register_introspection_callback
XML-RPC İşlevleri
PHP Manual

xmlrpc_server_destroy

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

xmlrpc_server_destroy — Sunucuya ayrılan özkaynakları serbest bırakır

Açıklama

int xmlrpc_server_destroy ( resource $sunucu )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

xmlrpc_server_create
xmlrpc_server_register_introspection_callback
XML-RPC İşlevleri


Belge üretimi için bir PHP işlevi atar

xmlrpc_server_destroy
xmlrpc_server_register_method
XML-RPC İşlevleri
PHP Manual

xmlrpc_server_register_introspection_callback

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

xmlrpc_server_register_introspection_callback — Belge üretimi için bir PHP işlevi atar

Açıklama

bool xmlrpc_server_register_introspection_callback ( resource $sunucu , string $işlev )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

xmlrpc_server_destroy
xmlrpc_server_register_method
XML-RPC İşlevleri


Belirtilen yöntemle eşleşen özkaynak için bir PHP işlevi atar

xmlrpc_server_register_introspection_callback
xmlrpc_set_type
XML-RPC İşlevleri
PHP Manual

xmlrpc_server_register_method

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

xmlrpc_server_register_method — Belirtilen yöntemle eşleşen özkaynak için bir PHP işlevi atar

Açıklama

bool xmlrpc_server_register_method ( resource $sunucu , string $yöntem , string $işlev )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

xmlrpc_server_register_introspection_callback
xmlrpc_set_type
XML-RPC İşlevleri


Bir PHP dizge değeri için xmlrpc türünü base64 veya datetime türüne dönüştürür

xmlrpc_server_register_method
Windows’a Özgü Eklentiler
XML-RPC İşlevleri
PHP Manual

xmlrpc_set_type

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

xmlrpc_set_type — Bir PHP dizge değeri için xmlrpc türünü base64 veya datetime türüne dönüştürür

Açıklama

bool xmlrpc_set_type ( string &$değer , string $tür )

Bir PHP dizge değeri için xmlrpc türünü base64 veya datetime türüne dönüştürür.

Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Değiştirgeler

değer

Türü belirlenecek değer.

tür

'base64' veya 'datetime'

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. Bir hata oluşmadığı takdirde değer bir nesneye dönüştürülür.

Örnekler

Örnek 1 - xmlrpc_set_type() örneği

<?php

$params = date("Ymd\TH:i:s", time());
xmlrpc_set_type($params, 'datetime');
echo xmlrpc_encode($params);

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

<?xml version="1.0" encoding="utf-8"?>
<params>
<param>
 <value>
  <dateTime.iso8601>20090322T23:43:03</dateTime.iso8601>
 </value>
</param>
</params>

Hatalar/İstisnalar

Türün XMLRPC tarafından desteklenmediğini belirten bir E_WARNING çıktılanır.

xmlrpc_server_register_method
Windows’a Özgü Eklentiler
XML-RPC İşlevleri


Windows’a Özgü Eklentiler

xmlrpc_set_type
COM
İşlev Başvuru Kılavuzu
PHP Manual

Windows'a Özgü Eklentiler

  • COM — COM ve .Net (Windows)
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Hatalar ve hata yönetimi
    • Örnekler
    • COM — The COM class
    • DOTNET — The DOTNET class
    • VARIANT — VARIANT class
    • COM İşlevleri
  • win32ps
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • win32ps İşlevleri
  • win32service
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • win32service İşlevleri
xmlrpc_set_type
COM
İşlev Başvuru Kılavuzu


COM ve .Net (Windows)

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Hatalar ve hata yönetimi
  • Örnekler
    • For Each
    • Diziler ve Dizi tarzı COM özellikleri
  • COM — The COM class
  • DOTNET — The DOTNET class
  • VARIANT — VARIANT class
  • COM İşlevleri
    • com_create_guid — Evrensel tanımlayıcı (Globally Unique Identifier) üretir
    • com_event_sink — Bir COM nesnesinden, PHP nesnesine olayları bağlar
    • com_get_active_object — COM nesnesinin çalışan bir örneği için tanıtıcı döner
    • com_load_typelib — Verilen tür kütüphanesini yükler
    • com_message_pump — COM iletilerini işler, zaman_asimi süresince uykudadır
    • com_print_typeinfo — İncelenebilecek şekilde PHP sınıf tanımını yazar
    • variant_abs — Bir varyantın mutlak değerini döndürür
    • variant_add — İki varyant değeri birleştirir ve sonucu geri döndürür
    • variant_and — İki varyant üzerinde ikilik VE işlemi yapar
    • variant_cast — Varyantı başka türde bir varyant nesneye dönüştürür
    • variant_cat — İki varyant değeri birleştirir ve sonucu geri döndürür
    • variant_cmp — İki varyant değerini karşılaştırır
    • variant_date_from_timestamp — Unix zaman damgasının varyant tarih gösterimini döndürür
    • variant_date_to_timestamp — Varyant tarih/zaman değerini Unix zaman damgasına çevirir
    • variant_div — İki varyant değerin bölme sonucunu döndürür
    • variant_eqv — İki varyant arasında ikilik denklik karşılaştırması yapar
    • variant_fix — Varyantın tamsayı kısmını geri döndürür
    • variant_get_type — Varyant nesnenin türünü geri döndürür
    • variant_idiv — Varyant değerleri tamsayıya çevirir ve bölme yaparak sonucu döndürür
    • variant_imp — İki varyant üzerinde ikilik çıkarım yapar
    • variant_int — Varyantın tamsayı kısmını döndürür
    • variant_mod — İki varyantın bölme işleminden kalanı geri döndürür
    • variant_mul — İki varyant değerleri için çarpma işlemi yapar
    • variant_neg — Bir varyant üzerinde mantıksal değil işlemi yapar
    • variant_not — Bir varyant üzerinde ikilik değil işlemi yapar
    • variant_or — İki varyant üzerinde mantıksal ayırma işlemi yapar
    • variant_pow — Üs alma işlemi yaparak sonucu döndürür
    • variant_round — Bir varyantı verilen ondalık basamağa yuvarlar
    • variant_set_type — Varyantı başka bir türe "yerinde" dönüştürür
    • variant_set — Varyant nesnesine yeni bir değer verir
    • variant_sub — Sağ varyant değerini sol varyant değerinden çıkartır
    • variant_xor — İki varyant arasında mantıksal çıkarma yapar
Windows’a Özgü Eklentiler
Giriş
Windows’a Özgü Eklentiler


Giriş

COM, Bileşen Nesne Modelinin kısaltmasıdır; DCE RPC (açık standart) üzerinde nesne yönelimli bir katmandır (ilişkili diğer servisler ile) ve bir dilde yazılmış kodun başka bir dil ile (COM destekleyen diller) yazılmış kodu çağırmasını, birlikte çalışmasını sağlayan ortak bir zemin sağlar. Sadece kodun başka bir dil ile yazılmasının değil, bileşenin nerede olduğunun da bir önemi yoktur; kod DLL'den yüklenebilir, aynı makina üzerinde çalışan başka bir süreç içerisinde veya DCOM (Dağıtık COM) ile uzaktaki makina üzerindeki süreç içerisinde de olabilir.

COM'un OLE Özdevinim olarak bilinen (COM nesnelerine geç bağlama sağlar, böylece içebakışa sahip olabilir ve çalışma zamanında nesnenin nasıl çalıştığı bilgisine ihtiyaç duyan derleme zamanı bilgisine gerek olmadan çağrılabilirler) COM arabirimlerini içeren bir alt kümesi vardır. PHP COM eklentisi, betiklerinizde uyumlu nesneleri oluşturabilmek ve çağırabilmek için OLE Özdevinim arabirimlerini kullanır. Bütün COM nesneleri OLE uyumlu olmadığı için eklenti "PHP için OLE Özdevinim Eklentisi" olarak çağrılmalıdır.

Neden COM kullanmalısınız? COM, Windows sistemleri üzerinde uygulama ve bileşenleri birlikte kullanmanın temel yollarından biridir; COM kullanarak Microsoft Word uygulamasını başlatabilir, doküman şablonu doldurabilir, sonucu Word dokümanı olarak saklayarak, ziyaretçilerinize gönderebilirsiniz. COM ile yerel ağınızdaki yönetim görevlerini yapabilir, IIS uygulamasını ayarlayabilirsiniz. Bunlar sadece yaygın olarak görülen kullanımlardır, çok daha fazlasını COM ile yapabilirsiniz.

PHP 5 sürümü ile eklenti sıfırdan tekrar yazılmış, eski, kafa karıştıran, belirsiz bölümler çıkartılmıştır. Ek olarak, Microsoft tarafından sağlanan COM birlekte işlerlik katmanı kullanılarak .NET kütüphanelerinin başlatılması ve oluşturulmasına da destek verilmiştir.

PHP 5'deki değişiklikler için lütfen » makalesine bakınız.

COM
Yapılandırma/Kurulum
COM


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
COM


Gereksinimler

COM işlevlerine sadece PHP'nin Windows sürümünde ulaşılabilir.

.Net desteği için PHP 5 ve .Net çalışma zamanı kütüphanesi gereklidir.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu işlevleri kullanmak için hiçbir şey kurmaya gerek yoktur; PHP çekirdeğinin parçasıdırlar.

PHP'nin Windows sürümünde bu eklenti yerleşik olarak gelmektedir. Bu işlevleri Windows'ta kullanmak için herhangi bir eklenti kurmanıza gerek yoktur.

Kullanmak istediğiniz çeşitli COM nesnelerini (MS Word gibi) kendi başınıza kurmak zorundasınız; Bütün bu nesneler PHP ile birlikte paketlenemez.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Com Yapılandırma Yönergeleri
İsim | Öntanımlı Değeri | Değişiklik Yeri | Sürüm Bilgisi
com.allow_dcom | "0" | PHP_INI_SYSTEM | PHP 4.0.5'den beri kullanılabilir.
com.autoregister_typelib | "0" | PHP_INI_ALL | PHP 4'te PHP_INI_SYSTEM. PHP 4.1.0'dan beri kullanılabilir.
com.autoregister_verbose | "0" | PHP_INI_ALL | PHP 4'te PHP_INI_SYSTEM. PHP 4.1.0'dan beri kullanılabilir.
com.autoregister_casesensitive | "1" | PHP_INI_ALL | PHP 4'te PHP_INI_SYSTEM. PHP 4.1.0'dan beri kullanılabilir.
com.code_page | "" | PHP_INI_ALL | PHP 5.0.0'dan beri kullanılabilir.
com.typelib_file | "" | PHP_INI_SYSTEM | PHP 4.0.5'den beri kullanılabilir.
PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

com.allow_dcom

Etkin duruma getirildiğinde, PHP'ye D-COM (Dağıtık COM) istemcisi olarak izin verilir ve PHP betikleri uzak sunucudaki COM nesnelerini başlatabilir.

com.autoregister_typelib

Etkin duruma getirildiğinde, PHP başlattığı nesnelerin tür kitaplığındaki sabitleri kayıt altına almaya çalışacaktır, bu nesneler arayüzlerde kullanılacaksa bu bilgi gereklidir. Sabitlerin büyüklük duyarlılığı yapılandırma yönergesiyle kontrol edilir.

com.autoregister_verbose

Etkin duruma getirildiğinde, nesne başlatılırken tür kitaplığı yüklemesindeki herhangi bir hata, PHP hata yönetimi kullanılarak bildirilecektir. Öntanımlı olarak kapalıdır yani tür kitaplığının yüklemesi veya bulunmasındaki herhangi bir hata bildirilmeyecektir.

com.autoregister_casesensitive

Etkin durumda iken, öntanımlı olarak etkindir, otomatik yüklenen tür kitaplıklarındaki sabitler büyüklük duyarlı olarak kaydedilecektir. Daha fazla bilgi için com_load_typelib() işlevine bakınız.

com.code_page

COM nesnelerine gönderilen ve gelen dizgelerin öntanımlı karakter kod sayfasının ayarlanmasını sağlar. Eğer boş bir dizgeye ayarlanırsa, PHP CP_ACP sabitini alır, bu sabit öntanımlı olarak sistem ANSI kod sayfasına eşittir.

Eğer betiklerinizde öntanımlı olandan farklı bir karakter kümesi kullandıysanız, bu yönerge sizi COM sınıf yapılandırıcısına, kod sayfasını değiştirge olarak göndermekten kurtaracaktır. Bu yönergeyi kullanmak (diğer yapılandırma yönergelerinde olduğu gibi) PHP betiklerinizin daha az taşınabilir olmasına yol açar, eğer imkan dahilinde ise COM yapılandırma değiştirgelerini kullanmalısınız.

Bilginize: PHP 5 ile kullanılmaya başlanmıştır.

com.typelib_file

Etkin duruma getirildiğinde, başlangıçta yüklenecek tür kitaplıklarının listesini içeren bir dosyayı göstermelidir. Dosyanın her bir satırı tür kitaplık ismi olarak com_load_typelib() işlevini çağırdığınızdaki gibi işlem görecektir. Kütüphanenin ihtiyacı olanı sadece bir kez yüklemek için sabitler kalıcı olarak kaydedilecektir. Eğer tür kitaplığı adı, #cis veya #case_insensitive dizgeleri ile bitiyorsa sabitler büyüklük duyarsız olarak kaydedilecektir.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Özkaynak Türleri

Eklenti, bırakılmış com_load() (Bu işlev PHP 5'de bulunmaz yerine COM sınıfı kullanılır) işlevinden dönen bir COM bileşenine gönderim tanımlar.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

XML sabitleri
Sabit | Değer | Açıklama
CLSCTX_INPROC_SERVER (integer) | 1 |
CLSCTX_INPROC_HANDLER (integer) | 2 |
CLSCTX_LOCAL_SERVER (integer) | 4 |
CLSCTX_REMOTE_SERVER (integer) | 16 |
CLSCTX_SERVER (integer) | 21 |
CLSCTX_ALL (integer) | 23 |
VT_NULL (integer) | 1 |
VT_EMPTY (integer) | 0 |
VT_UI1 (integer) | 17 |
VT_I2 (integer) | 2 |
VT_I4 (integer) | 3 |
VT_R4 (integer) | 4 |
VT_R8 (integer) | 5 |
VT_BOOL (integer) | 11 |
VT_ERROR (integer) | 10 |
VT_CY (integer) | 6 |
VT_DATE (integer) | 7 |
VT_BSTR (integer) | 8 |
VT_DECIMAL (integer) | 14 |
VT_UNKNOWN (integer) | 13 |
VT_DISPATCH (integer) | 9 |
VT_VARIANT (integer) | 12 |
VT_I1 (integer) | 16 |
VT_UI2 (integer) | 18 |
VT_UI4 (integer) | 19 |
VT_INT (integer) | 22 |
VT_UINT (integer) | 23 |
VT_ARRAY (integer) | 8192 |
VT_BYREF (integer) | 16384 |
CP_ACP (integer) | 0 |
CP_MACCP (integer) | 2 |
CP_OEMCP (integer) | 1 |
CP_UTF7 (integer) | 65000 |
CP_UTF8 (integer) | 65001 |
CP_SYMBOL (integer) | 42 |
CP_THREAD_ACP (integer) | 3 |
VARCMP_LT (integer) | 0 |
VARCMP_EQ (integer) | 1 |
VARCMP_GT (integer) | 2 |
VARCMP_NULL (integer) | 3 |
NORM_IGNORECASE (integer) | 1 |
NORM_IGNORENONSPACE (integer) | 2 |
NORM_IGNORESYMBOLS (integer) | 4 |
NORM_IGNOREWIDTH (integer) | 131072 |
NORM_IGNOREKANATYPE (integer) | 65536 |
NORM_IGNOREKASHIDA (integer) | 262144 | Kullanılabilirliği altında çalıştığı kütüphaneye bağlıdır.
DISP_E_DIVBYZERO (integer) | -2147352558 |
DISP_E_OVERFLOW (integer) | -2147352566 |
MK_E_UNAVAILABLE (integer) | -2147221021 |
Özkaynak Türleri
Hatalar ve hata yönetimi
COM


Hatalar ve hata yönetimi

İstisnalar (PHP 5)

Eklenti, COM tarafından ölümcül bir hata rapor edildiği zaman com_exception sınıfından bir nesne örneği fırlatır. Bütün COM istisnaları, çeşitli COM işlemlerinden dönen HRESULT geri dönüş değerine karşılık gelen, code özelliğine sahiptir. Bu özelliği, istisnaları nasıl yöneteceğinize karar vermekte kullanabilirsiniz.

Öntanımlı Sabitler
Örnekler
COM


Örnekler

İçindekiler

  • For Each
  • Diziler ve Dizi tarzı COM özellikleri
Hatalar ve hata yönetimi
For Each
COM


For Each

PHP 5'den başlayarak, COM/OLE IEnumVariant içeriği üzerinde foreach deyimini kullanabilirsiniz. Bu, basit bir şekilde, VB/ASP kodunda For Each kullandığınız yerlerde foreach kullanabilirsiniz demektir.

Örnek 1 ASP'de For Each

<%
Set domainObject = GetObject("WinNT://Domain")
For Each obj in domainObject
  Response.Write obj.Name & "<br />"
Next
%>

Örnek 2 PHP 4'de while() ... Next()

<?php
$domainObject = new COM("WinNT://Domain");
while ($obj = $domainObject->Next()) {
   echo $obj->Name . "<br />";
}
?>

Örnek 3 PHP 5'de foreach

<?php
$domainObject = new COM("WinNT://Domain");
foreach ($domainObject as $obj) {
   echo $obj->Name . "<br />";
}
?>

Örnekler
Diziler ve Dizi tarzı COM özellikleri
Örnekler


Diziler ve Dizi tarzı COM özellikleri

Birçok COM nesnesi, özelliklerini dizi olarak gösterirler veya dizi tarzı erişim ile kullanılırlar. PHP 4 tarzı dizi sentaksını, böyle bir özelliğe okumak/yazmak için kullanabilirsiniz fakat sadece 1 boyuta izin verilmiştir. Eğer çok boyutlu bir özellik okumak istiyorsanız, her değiştirgesi erişilmek istenen dizinin bir boyutuna karşılık gelen bir işlev çağrısı yapabilirsiniz, fakat böyle bir özelliğe yazmanın bir yolu yoktur.

PHP 5 hayatınızı kolaylaştırmak için aşağıdaki yeni özellikleri sağlar:

  • Çok boyutlu dizilere veya PHP dizi sentaksı ile çoklu değiştirge kullanılmasına gerek olan COM özelliklerine erişim. Ayrıca bu tekniği kullanarak yazabilir veya başlatabilirsiniz.

  • SafeArrays ("true" diziler) foreach kontrol deyimi ile kullanın. Bu çalışır çünkü SafeArrays kendi boyutu hakkında bilgiye sahiptir. Eğer dizi tarzı özellik IEnumVariant ile kodlandı ise foreach yine bu özellik ile kullanabilirsiniz, daha ayrıntılı bilgi için For Each buraya bakın.

For Each
COM
Örnekler


The COM class

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

Description

The COM class allows you to instantiate an OLE compatible COM object and call its methods and access its properties.

$obj = new COM("Application.ID")

Methods

COM::__construct ( string $module_name [, mixed $server_name [, int $codepage [, string $typelib ]]] )

COM class constructor. The parameters have the following meanings:

module_name
Can be a ProgID, Class ID or Moniker that names the component to load. A ProgID is typically the application or DLL name, followed by a period, followed by the object name. e.g: Word.Application. A Class ID is the UUID that uniquely identifies a given class. A Moniker is a special form of naming, similar in concept to a URL scheme, that identifies a resource and specifies how it should be loaded. As an example, you could load up Word and get an object representing a word document by specifying the full path to the word document as the module name, or you can use LDAP: as a moniker to use the ADSI interface to LDAP.
server_name
The name of the DCOM server on which the component should be loaded and run. If NULL, the object is run using the default for the application. The default is typically to run it on the local machine, although the administrator might have configured the application to launch on a different machine. If you specify a non-NULL value for server, PHP will refuse to load the object unless the configuration option is set to TRUE.

If server_name is an array, it should contain the following elements (case sensitive!). Note that they are all optional (although you need to specify both Username and Password together); if you omit the Server setting, the default server will be used (as mentioned above), and the instantiation of the object will not be affected by the directive.

DCOM server name
server_name key | type | description
Server | string | The name of the server.
Username | string | The username to connect as.
Password | string | The password for Username.
Flags | integer | One or more of the following constants, logically OR'd together: CLSCTX_INPROC_SERVER, CLSCTX_INPROC_HANDLER, CLSCTX_LOCAL_SERVER, CLSCTX_REMOTE_SERVER, CLSCTX_SERVER and CLSCTX_ALL. The default value if not specified here is CLSCTX_SERVER if you also omit Server, or CLSCTX_REMOTE_SERVER if you do specify a server. You should consult the Microsoft documentation for CoCreateInstance for more information on the meaning of these constants; you will typically never have to use them.

codepage
Specifies the codepage that is used to convert strings to unicode-strings and vice versa. The conversion is applied whenever a PHP string is passed as a parameter or returned from a method of this COM object. The code page is sticky in PHP 5, which means that it will propagate to objects and variants returned from the object. Possible values are CP_ACP (use system default ANSI code page - the default if this parameter is omitted), CP_MACCP, CP_OEMCP, CP_SYMBOL, CP_THREAD_ACP (use codepage/locale set for the current executing thread), CP_UTF7 and CP_UTF8. You may also use the number for a given codepage; consult the Microsoft documentation for more details on codepages and their numeric values.

Overloaded Methods

The returned object is an overloaded object, which means that PHP does not see any fixed methods as it does with regular classes; instead, any property or method accesses are passed through to COM.

Starting with PHP 5, PHP will automatically detect methods that accept parameters by reference, and will automatically convert regular PHP variables to a form that can be passed by reference. This means that you can call the method very naturally; you needn't go to any extra effort in your code.

Pseudo Methods

In PHP versions prior to 5, a number of not very pleasant hacks meant that the following method names were not passed through to COM and were handled directly by PHP. PHP 5 eliminates these things; read the details below to determine how to fix your scripts. These magic method names are case insensitive.

void COM::AddRef ( void )

Artificially adds a reference count to the COM object.

Uyarı

You should never need to use this method. It exists as a logical complement to the Release() method below.

void COM::Release ( void )

Artificially removes a reference count from the COM object.

Uyarı

You should never need to use this method. Its existence in PHP is a bug designed to work around a bug that keeps COM objects running longer than they should.

Pseudo Methods for Iterating

These pseudo methods are only available if com_isenum() returns TRUE, in which case, they hide any methods with the same names that might otherwise be provided by the COM object. These methods have all been eliminated in PHP 5, and you should use For Each instead.

variant COM::All ( void )

Returns a variant representing a SafeArray that has 10 elements; each element will be an empty/null variant. This function was supposed to return an array containing all the elements from the iterator, but was never completed. Do not use.

variant COM::Next ( void )

Returns a variant representing the next element available from the iterator, or FALSE when there are no more elements.

variant COM::Prev ( void )

Returns a variant representing the previous element available from the iterator, or FALSE when there are no more elements.

void COM::Reset ( void )

Rewinds the iterator back to the start.

COM examples

Örnek 1 COM example (1)

<?php
// starting word
$word = new COM("word.application") or die("Unable to instantiate Word");
echo "Loaded Word, version {$word->Version}\n";

//bring it to front
$word->Visible = 1;

//open an empty document
$word->Documents->Add();

//do some weird stuff
$word->Selection->TypeText("This is a test...");
$word->Documents[1]->SaveAs("Useless test.doc");

//closing word
$word->Quit();

//free the object
$word = null;
?>

Örnek 2 COM example (2)

<?php

$conn = new COM("ADODB.Connection") or die("Cannot start ADO");
$conn->Open("Provider=SQLOLEDB; Data Source=localhost;
Initial Catalog=database; User ID=user; Password=password");

$rs = $conn->Execute("SELECT * FROM sometable");    // Recordset

$num_columns = $rs->Fields->Count();
echo $num_columns . "\n";

for ($i=0; $i < $num_columns; $i++) {
    $fld[$i] = $rs->Fields($i);
}

$rowcount = 0;
while (!$rs->EOF) {
    for ($i=0; $i < $num_columns; $i++) {
        echo $fld[$i]->value . "\t";
    }
    echo "\n";
    $rowcount++;            // increments rowcount
    $rs->MoveNext();
}

$rs->Close();
$conn->Close();

$rs = null;
$conn = null;

?>

Diziler ve Dizi tarzı COM özellikleri
DOTNET
COM


The DOTNET class

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

Description

The DOTNET class allows you to instantiate a class from a .Net assembly and call its methods and access its properties.

$obj = new DOTNET("assembly", "classname")

Methods

DOTNET::__construct ( string $assembly_name , string $class_name [, int $codepage ] )

DOTNET class constructor. assembly_name specifies which assembly should be loaded, and class_name specifices which class in that assembly to instantiate. You may optionally specify a codepage to use for unicode string transformations; see the COM class for more details on code pages.

The returned object is an overloaded object, which means that PHP does not see any fixed methods as it does with regular classes; instead, any property or method accesses are passed through to COM and from there to DOTNET. In other words, the .Net object is mapped through the COM interoperability layer provided by the .Net runtime.

Once you have created a DOTNET object, PHP treats it identically to any other COM object; all the same rules apply.

Örnek 1 DOTNET example

<?php
 $stack = new DOTNET("mscorlib", "System.Collections.Stack");
 $stack->Push(".Net");
 $stack->Push("Hello ");
 echo $stack->Pop() . $stack->Pop();
?>

Bilginize:

You need to install the .Net runtime on your web server to take advantage of this feature.

COM
VARIANT
COM


VARIANT class

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

Description

The VARIANT is COM's equivalent of the PHP zval; it is a structure that can contain a value with a range of different possible types. The VARIANT class provided by the COM extension allows you to have more control over the way that PHP passes values to and from COM.

$vVar = new VARIANT($var)

Methods

VARIANT::__construct ([ mixed $value [, int $type [, int $codepage ]]] )

VARIANT class constructor. Parameters:

value
initial value. if omitted, or set to NULL an VT_EMPTY object is created.
type
specifies the content type of the VARIANT object. Possible values are one of the VT_XXX Öntanımlı Sabitler. In PHP versions prior to PHP 5, you could force PHP to pass a variant object by reference by OR'ing VT_BYREF with the type. In PHP 5, this hack is not supported; instead, PHP 5 can detect parameters passed by reference automatically; they do not even need to be passed as VARIANT objects. Consult the MSDN library for additional information on the VARIANT type.
codepage
specifies the codepage that is used to convert strings to unicode. See the parameter of the same name in the COM class for more information.

PHP versions prior to PHP 5 define a number of (undocumented) virtual properties for instances of the VARIANT class; these properties have all been removed in PHP 5 in favour of its more natural syntax; these differences are best highlighted by example:

Örnek 1 Variant example, PHP 4.x style

<?php
$v = new VARIANT(42);
print "The type is " . $v->type . "<br/>";
print "The value is " . $v->value . "<br/>";
?>

Örnek 2 Variant example, PHP 5 style

<?php
$v = new VARIANT(42);
print "The type is " . variant_get_type($v) . "<br/>";
print "The value is " . $v . "<br/>";
?>

The reason for the change is that, internally, the COM extension sees VARIANT, COM and DOTNET classes as the same thing, and the design philosophy for these classes is that all property and member accesses are passed through to COM with no interference. The new syntax is more natural and less effort, and most of the removed virtual properties didn't make any sense in a PHP context in any case.

Bilginize:

PHP 5 takes a much simpler approach to handling VARIANTs; when returning a value or fetching a variant property, the variant is converted to a PHP value only when there is a direct mapping between the types that would not result in a loss of information. In all other cases, the result is returned as an instance of the VARIANT class. You can force PHP to convert or evaluate the variant as a PHP native type by using a casting operator explicitly, or implicitly casting to a string by printing it. You may use the wide range of variant functions to perform arithmetic operations on variants without forcing a conversion or risking a loss of data.

See also variant_get_type().

DOTNET
COM İşlevleri
COM


COM İşlevleri

Ayrıca Bakınız

COM hakkında daha başka bilgiler için » COM tanımları belgesine bakınız. PHP ve COM FAQ internet sayfalarında da yararlı bilgiler bulabilirsiniz. MS Office uygulamalarını sunucu tarafında kullanmayı düşünüyorsanız » Office sunucu taraflı özdevinim belgelerine bakınız.

İçindekiler

  • com_create_guid — Evrensel tanımlayıcı (Globally Unique Identifier) üretir
  • com_event_sink — Bir COM nesnesinden, PHP nesnesine olayları bağlar
  • com_get_active_object — COM nesnesinin çalışan bir örneği için tanıtıcı döner
  • com_load_typelib — Verilen tür kütüphanesini yükler
  • com_message_pump — COM iletilerini işler, zaman_asimi süresince uykudadır
  • com_print_typeinfo — İncelenebilecek şekilde PHP sınıf tanımını yazar
  • variant_abs — Bir varyantın mutlak değerini döndürür
  • variant_add — İki varyant değeri birleştirir ve sonucu geri döndürür
  • variant_and — İki varyant üzerinde ikilik VE işlemi yapar
  • variant_cast — Varyantı başka türde bir varyant nesneye dönüştürür
  • variant_cat — İki varyant değeri birleştirir ve sonucu geri döndürür
  • variant_cmp — İki varyant değerini karşılaştırır
  • variant_date_from_timestamp — Unix zaman damgasının varyant tarih gösterimini döndürür
  • variant_date_to_timestamp — Varyant tarih/zaman değerini Unix zaman damgasına çevirir
  • variant_div — İki varyant değerin bölme sonucunu döndürür
  • variant_eqv — İki varyant arasında ikilik denklik karşılaştırması yapar
  • variant_fix — Varyantın tamsayı kısmını geri döndürür
  • variant_get_type — Varyant nesnenin türünü geri döndürür
  • variant_idiv — Varyant değerleri tamsayıya çevirir ve bölme yaparak sonucu döndürür
  • variant_imp — İki varyant üzerinde ikilik çıkarım yapar
  • variant_int — Varyantın tamsayı kısmını döndürür
  • variant_mod — İki varyantın bölme işleminden kalanı geri döndürür
  • variant_mul — İki varyant değerleri için çarpma işlemi yapar
  • variant_neg — Bir varyant üzerinde mantıksal değil işlemi yapar
  • variant_not — Bir varyant üzerinde ikilik değil işlemi yapar
  • variant_or — İki varyant üzerinde mantıksal ayırma işlemi yapar
  • variant_pow — Üs alma işlemi yaparak sonucu döndürür
  • variant_round — Bir varyantı verilen ondalık basamağa yuvarlar
  • variant_set_type — Varyantı başka bir türe "yerinde" dönüştürür
  • variant_set — Varyant nesnesine yeni bir değer verir
  • variant_sub — Sağ varyant değerini sol varyant değerinden çıkartır
  • variant_xor — İki varyant arasında mantıksal çıkarma yapar
VARIANT
com_create_guid
COM


Evrensel tanımlayıcı (Globally Unique Identifier) üretir

COM İşlevleri
com_event_sink
COM İşlevleri
PHP Manual

com_create_guid

(PHP 5, PHP 7)

com_create_guid — Evrensel tanımlayıcı (Globally Unique Identifier) üretir

Açıklama

string com_create_guid ( void )

Evrensel tanımlayıcı üretir.

Bir GUID, Microsoft geleneğine göre, kaşlı ayraç ile sarmalanması dışında, DCE UUID ile benzer şekilde üretilir.

Dönen Değerler

Dizge olarak GUID döner.

Ayrıca Bakınız

  • PECL uuid eklentisindeki uuid_create() işlevine bakınız

COM İşlevleri
com_event_sink
COM İşlevleri


Bir COM nesnesinden, PHP nesnesine olayları bağlar

com_create_guid
com_get_active_object
COM İşlevleri
PHP Manual

com_event_sink

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

com_event_sink — Bir COM nesnesinden, PHP nesnesine olayları bağlar

Açıklama

bool com_event_sink ( variant $comNesne , object $aliciNesne [, mixed $aliciArayuz ] )

comNesne ile üretilen olayların, PHP nesnesi aliciNesne içine bağlanmasını sağlar.

Bu özelliği kullanırken dikkatli olun; eğer aşağıdaki örnek benzeri bir şey yapıyorsanız bunun bir html sunucusunda çalışmasının anlamı yoktur.

Değiştirgeler

comNesne

aliciNesne

aliciNesne istenen arayüzün yöntem isimlerinin olduğu sınıftan türemiş nesne olmalıdır; bu amaçla şablon bir sınıf üretmek için com_print_typeinfo() işlevinden yardım alabilirsiniz.

aliciArayuz

PHP, comNesne tür kitaplığındaki öntanımlı arayüz türünü kullanmaya çalışacaktır, bu durumu kullanmak istediğiniz arayüzü aliciArayuz değiştirgesine yazarak engelleyebilirsiniz.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 COM olay bağlayıcı örneği

<?php
class IEEventSinker {
    var $terminated = false;

   function ProgressChange($progress, $progressmax) {
      echo "İndirme işlemi: $progress / $progressmax\n";
    }

    function DocumentComplete(&$dom, $url) {
      echo "$url tamamlandı\n";
    }

    function OnQuit() {
      echo "Çık!\n";
      $this->terminated = true;
    }
}
$ie = new COM("InternetExplorer.Application");
// PHP 5 ile & kullanılmasına gerek kalmadığına dikkat edin!
$sink = new IEEventSinker();
com_event_sink($ie, $sink, "DWebBrowserEvents2");
$ie->Visible = true;
$ie->Navigate("http://www.example.org");
while(!$sink->terminated) {
  com_message_pump(4000);
}
$ie = null;
?>

Ayrıca Bakınız

  • com_print_typeinfo() - İncelenebilecek şekilde PHP sınıf tanımını yazar
  • com_message_pump() - COM iletilerini işler, zaman_asimi süresince uykudadır

com_create_guid
com_get_active_object
COM İşlevleri


COM nesnesinin çalışan bir örneği için tanıtıcı döner

com_event_sink
com_load_typelib
COM İşlevleri
PHP Manual

com_get_active_object

(PHP 5, PHP 7)

com_get_active_object — COM nesnesinin çalışan bir örneği için tanıtıcı döner

Açıklama

variant com_get_active_object ( string $progid [, int $kodSayfasi ] )

com_get_active_object() işlevi COM nesnesinden yeni bir örnek yaratma ile benzer işi yapar. Aralarındaki fark eğer nesne hali hazırda çalışıyorsa işlevden bir nesne dönecektir. OLE uygulamaları, sık kullanılan uygulamaları sadece bir kez yüklemek için Çalışan Nesne Tablosu olarak bilinen yapıyı kullanır; bu işlev çalışan nesne tanıtıcısını almak için COM kütüphanesinden GetActiveObject() işlevini kullanır.

Değiştirgeler

progid

Erişmek istediğiniz nesne için (örneğin Word.Application) progid değiştirgesi ProgID veya CLSID olmalıdır.

kodSayfasi

Tam olarak COM sınıfındaki gibi rol oynar.

Dönen Değerler

İstenen nesne çalışıyorsa, betiğinizdeki herhangi bir COM nesnesi gibi döndürülecektir.

Hatalar/İstisnalar

İşlevin başarısız olmasının çeşitli nedenleri vardır, en sık karşılaşılan istenen nesnenin çalışmamasından kaynaklanır. Bu durumda, istisna hata kodu MK_E_UNAVAILABLE olacaktır; Hata kodunu kontrol etmek için istisna nesnesinin getCode yöntemini kullanabilirsiniz.

Notlar

Uyarı

com_get_active_object() işlevini bir html sunucuda kullanmak akıllıca bir fikir değildir. Birçok COM/OLE uygulaması eşzamanlı birden fazla istemci ile çalışacak şekilde tasarlanmamıştır, hatta (özellikle) Microsoft Office bile. Bu konuda daha fazla bilgi için » Sunucu taraflı ofis özdevinimi üzerine düşünceler adresine bakınız.

com_event_sink
com_load_typelib
COM İşlevleri


Verilen tür kütüphanesini yükler

com_get_active_object
com_message_pump
COM İşlevleri
PHP Manual

com_load_typelib

(PHP 4 >= 4.1.0, PHP 5, PHP 7)

com_load_typelib — Verilen tür kütüphanesini yükler

Açıklama

bool com_load_typelib ( string $turKutuphaneAdi [, bool $buyuklukDuyarsiz ] )

Tür kütüphanesini yükler ve define() işlevi kullanılarak tanımlanan sabitlerini kaydeder.

Ön yükleme ve kaydetme için bu kadar esnek olmasa da kurulum seçeneklerini kullanmak çok daha etkilidir.

Eğer seçeneğini etkin duruma getirirseniz, PHP özdevinimli olarak bir COM nesnesi başlattığınızda onunla ilişkili sabitleri kaydetmeye çalışacaktır. Bu işlev COM nesnesinin kendisi tarafından sağlanan arayüze bağlıdır ve her zaman geçerli değildir.

Değiştirgeler

turKutuphaneAdi

turKutuphaneAdi aşağıdakilerden biri olabilir:

  • .tlb dosyasının veya tür kütüphanesini içeren çalıştırılabilir modülün adı.

  • Tür kütüphanesi GUID, sürüm numarası, örneğin; {00000200-0000-0010-8000-00AA006D2EA4},2,0.

  • Tür kütüphanesi adı, örneğin; Microsoft OLE DB ActiveX Data Objects 1.0 Library.

PHP tür kütüphanesini çözümlemeye çalışacaktır, süreç sıralamada aşağı doğru gidildikçe daha fazla kaynak gerektirecektir; tür kütüphanesini adı ile aramak, uygun bir eşleşme bulana kadar kayıt defterini fiziksel olarak tarayacaktır.

buyuklukDuyarsiz

buyuklukDuyarsiz, define() işlevindeki aynı isimli değiştirge gibi çalışır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

com_get_active_object
com_message_pump
COM İşlevleri


COM iletilerini işler, zaman_asimi süresince uykudadır

com_load_typelib
com_print_typeinfo
COM İşlevleri
PHP Manual

com_message_pump

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

com_message_pump — COM iletilerini işler, zaman_asimi süresince uykudadır

Açıklama

bool com_message_pump ([ int $zaman_asimi ] )

İşlev, milisaniye zaman_asimi süresince veya kuyruğa bir ileti gelene kadar uyuyacaktır.

İşlevin amacı, bölümler arasındaki COM çağrılarını yönlendirmek ve çeşitli eşzamanlama konularını çözmektir. Bu diğer olaylar işlenirken veya arkaplanda diğer kodlar çalışırken, olayların tetiklediği betiğinizin etkili bir şekilde beklemesini sağlayacaktır. com_event_sink() işlevi örneğinde gösterildiği gibi, olay bağlı COM nesnesi kullanımı bitene kadar bir döngü içinde kullanılmalıdır.

Değiştirgeler

zaman_asimi

Milisaniye cinsinden zaman aşımı.

zaman_asimi değiştirgesini belirtmezseniz öntanımlı olarak 0 alınacaktır. 0 beklenmeyeceği anlamına gelir; bekleyen mesajlar varsa önce işlenecektir, bekleyen mesaj yoksa işlev uyumaksızın FALSE döndürecektir.

Dönen Değerler

Eğer mesaj veya mesajlar zaman aşımından önce gelirse işlenecektir ve işlev TRUE döndürecektir. Eğer zaman aşımı gerçekleşirse ve hiç bir mesaj işlenmediyse geri dönüş değeri FALSE olacaktır.

com_load_typelib
com_print_typeinfo
COM İşlevleri


İncelenebilecek şekilde PHP sınıf tanımını yazar

com_message_pump
variant_abs
COM İşlevleri
PHP Manual

com_print_typeinfo

(PHP 4 >= 4.2.0, PHP 5, PHP 7)

com_print_typeinfo — İncelenebilecek şekilde PHP sınıf tanımını yazar

Açıklama

bool com_print_typeinfo ( object $comNesne [, string $arayuz [, bool $baglama ]] )

İşlevin amacı olay bağlamada kullanmak için sınıf yapısının üretilmesidir. İşlevi ayrıca, içbakış arayüzlerinin desteklediği kadar, herhangi bir COM nesnesinin dökümünü üretmek için kullanabilirsiniz, görüntülemek istediğiniz arayüz adını bilmeniz gerekmektedir.

Değiştirgeler

comNesne

comNesne değiştirgesi ya COM nesnesinin bir örneği ya da tür kütüphane adı (com_load_typelib() işlevinde gösterilen kurallara göre çözümlenecektir) olmalıdır.

arayuz

Göstermek istediğiniz, IDispatch türevinden, arayüz adı.

baglama

TRUE olarak düzelenirse karşılık gelen bağlama arayüzü gösterilecektir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • com_event_sink() - Bir COM nesnesinden, PHP nesnesine olayları bağlar
  • com_load_typelib() - Verilen tür kütüphanesini yükler

com_message_pump
variant_abs
COM İşlevleri


Bir varyantın mutlak değerini döndürür

com_print_typeinfo
variant_add
COM İşlevleri
PHP Manual

variant_abs

(PHP 5, PHP 7)

variant_abs — Bir varyantın mutlak değerini döndürür

Açıklama

mixed variant_abs ( mixed $val )

Bir varyantın mutlak değerini döndürür.

Değiştirgeler

val

Varyant.

Bilginize:

As with all the variant arithmetic functions, the parameters for this function can be either a PHP native type (integer, string, floating point, boolean or NULL), or an instance of a COM, VARIANT or DOTNET class. PHP native types will be converted to variants using the same rules as found in the constructor for the VARIANT class. COM and DOTNET objects will have the value of their default property taken and used as the variant value.

The variant arithmetic functions are wrappers around the similarly named functions in the COM library; for more information on these functions, consult the MSDN library. The PHP functions are named slightly differently; for example variant_add() in PHP corresponds to VarAdd() in the MSDN documentation.

Dönen Değerler

val değiştirgesi ile verilen varyantın mutlak değerini geri döndürür.

Ayrıca Bakınız

  • abs() - Absolute value

com_print_typeinfo
variant_add
COM İşlevleri


İki varyant değeri birleştirir ve sonucu geri döndürür

variant_abs
variant_and
COM İşlevleri
PHP Manual

variant_add

(PHP 5, PHP 7)

variant_add — İki varyant değeri birleştirir ve sonucu geri döndürür

Açıklama

mixed variant_add ( mixed $sol , mixed $sag )

Aşağıdaki kuralları (MSDN kütüphanesinden alınmıştır) kullanarak, sol değiştirgeyi sag değiştirge ile birleştirir.

Varyant Birleştirme Kuralları
Durum | Sonuç
İki deyim dizge tipinde | Ekleme
Bir deyim dizge diğeri karakter türünde | Toplama
Bir deyim sayısal diğeri dizge türünde | Toplama
İki deyimde sayısal | Toplama
Deyimlerden biri NULL | NULL döner
Her iki deyim boş | Tamsayı döner

Değiştirgeler

sol

Sol terim.

sag

Sağ terim.

Bilginize:

As with all the variant arithmetic functions, the parameters for this function can be either a PHP native type (integer, string, floating point, boolean or NULL), or an instance of a COM, VARIANT or DOTNET class. PHP native types will be converted to variants using the same rules as found in the constructor for the VARIANT class. COM and DOTNET objects will have the value of their default property taken and used as the variant value.

The variant arithmetic functions are wrappers around the similarly named functions in the COM library; for more information on these functions, consult the MSDN library. The PHP functions are named slightly differently; for example variant_add() in PHP corresponds to VarAdd() in the MSDN documentation.

Dönen Değerler

İşlem sonucunu döndürür.

Ayrıca Bakınız

  • variant_sub() - Sağ varyant değerini sol varyant değerinden çıkartır

variant_abs
variant_and
COM İşlevleri


İki varyant üzerinde ikilik VE işlemi yapar

variant_add
variant_cast
COM İşlevleri
PHP Manual

variant_and

(PHP 5, PHP 7)

variant_and — İki varyant üzerinde ikilik VE işlemi yapar

Açıklama

mixed variant_and ( mixed $sol , mixed $sag )

İkilik VE işlemi yapar. Normal VE işleminden oldukça farklı olduğunu belirtmemiz gerekir.

Değiştirgeler

sol

Sol terim.

sag

Sağ terim.

Bilginize:

As with all the variant arithmetic functions, the parameters for this function can be either a PHP native type (integer, string, floating point, boolean or NULL), or an instance of a COM, VARIANT or DOTNET class. PHP native types will be converted to variants using the same rules as found in the constructor for the VARIANT class. COM and DOTNET objects will have the value of their default property taken and used as the variant value.

The variant arithmetic functions are wrappers around the similarly named functions in the COM library; for more information on these functions, consult the MSDN library. The PHP functions are named slightly differently; for example variant_add() in PHP corresponds to VarAdd() in the MSDN documentation.

Dönen Değerler

Varyant VE Kuralları
sol | sag | Sonuç
TRUE | TRUE | TRUE
TRUE | FALSE | FALSE
TRUE | NULL | NULL
FALSE | TRUE | FALSE
FALSE | FALSE | FALSE
FALSE | NULL | FALSE
NULL | TRUE | NULL
NULL | FALSE | FALSE
NULL | NULL | NULL

Ayrıca Bakınız

  • variant_or() - İki varyant üzerinde mantıksal ayırma işlemi yapar

variant_add
variant_cast
COM İşlevleri


Varyantı başka türde bir varyant nesneye dönüştürür

variant_and
variant_cat
COM İşlevleri
PHP Manual

variant_cast

(PHP 5, PHP 7)

variant_cast — Varyantı başka türde bir varyant nesneye dönüştürür

Açıklama

variant variant_cast ( variant $varyant , int $tur )

İşlev varyant değiştirgesinin kopyasını oluşturur, daha sonra kopyayı tur ile verilene çarpıtma işlemi yapar.

İşlev COM kütüphanesindeki VariantChangeType() işlevini sarmalar; daha fazla bilgi için MSDN'e bakınız.

Değiştirgeler

varyant

Varyant.

tur

tur VT_XXX sabitlerinden biri olmalıdır.

Dönen Değerler

VT_DATE türünde varyant döndürür.

Ayrıca Bakınız

  • variant_set_type() - Varyantı başka bir türe "yerinde" dönüştürür

variant_and
variant_cat
COM İşlevleri


İki varyant değeri birleştirir ve sonucu geri döndürür

variant_cast
variant_cmp
COM İşlevleri
PHP Manual

variant_cat

(PHP 5, PHP 7)

variant_cat — İki varyant değeri birleştirir ve sonucu geri döndürür

Açıklama

mixed variant_cat ( mixed $sol , mixed $sag )

sol ile sag birleştirmesi yapar ve sonucu döndürür.

İşlev gösterim olarak $sol . $sag yazılmasına eşittir.

Değiştirgeler

sol

Sol terim.

sag

Sağ terim.

Bilginize:

As with all the variant arithmetic functions, the parameters for this function can be either a PHP native type (integer, string, floating point, boolean or NULL), or an instance of a COM, VARIANT or DOTNET class. PHP native types will be converted to variants using the same rules as found in the constructor for the VARIANT class. COM and DOTNET objects will have the value of their default property taken and used as the variant value.

The variant arithmetic functions are wrappers around the similarly named functions in the COM library; for more information on these functions, consult the MSDN library. The PHP functions are named slightly differently; for example variant_add() in PHP corresponds to VarAdd() in the MSDN documentation.

Dönen Değerler

Birleştirmenin sonucunu döndürür.

Ayrıca Bakınız

  • Dizge birleştirme işleçleri için Dizge İşleçleri belgesine bakınız

variant_cast
variant_cmp
COM İşlevleri


İki varyant değerini karşılaştırır

variant_cat
variant_date_from_timestamp
COM İşlevleri
PHP Manual

variant_cmp

(PHP 5, PHP 7)

variant_cmp — İki varyant değerini karşılaştırır

Açıklama

int variant_cmp ( mixed $sol , mixed $sag [, int $yerel [, int $secenekler ]] )

sol ile sag karşılaştırması yapar.

İşlev sadece sayıl değerleri karşılaştırır, dizi veya varyant için çalışmaz.

Değiştirgeler

sol

Sol terim.

sag

Sağ terim.

yerel

Dizgeleri karşılaştırırken kullanılacak geçerli bir yerel tanımlayıcı (dizge karşılaştırmayı etkiler).

secenekler

secenekler aşağıdakilerden biri veya birkaçı olabilir, OR ile birleştirilir ve dizge karşılaştırmasını etkiler:

Varyant Karşılaştırma Seçenekleri
deger | anlamı
NORM_IGNORECASE | Büyüklük duyarsız karşılaştırma
NORM_IGNORENONSPACE | Boşluksuz karakterleri dikkate alma
NORM_IGNORESYMBOLS | Sembolleri dikkate alma
NORM_IGNOREWIDTH | Dizge genişliğini dikkate alma
NORM_IGNOREKANATYPE | Kana tarzını dikkate alma
NORM_IGNOREKASHIDA | Arap keşide karakterini dikkate alma

Bilginize:

As with all the variant arithmetic functions, the parameters for this function can be either a PHP native type (integer, string, floating point, boolean or NULL), or an instance of a COM, VARIANT or DOTNET class. PHP native types will be converted to variants using the same rules as found in the constructor for the VARIANT class. COM and DOTNET objects will have the value of their default property taken and used as the variant value.

The variant arithmetic functions are wrappers around the similarly named functions in the COM library; for more information on these functions, consult the MSDN library. The PHP functions are named slightly differently; for example variant_add() in PHP corresponds to VarAdd() in the MSDN documentation.

Dönen Değerler

Aşağıdakilerden biri geri döner:

Varyant Karşılaştırma Sonuçları
değer | anlamı
VARCMP_LT | sol sag'dan küçüktür
VARCMP_EQ | sol ile sag eşittir
VARCMP_GT | sol sag'dan büyüktür
VARCMP_NULL | sol, sag veya ikisi birden NULL'dur.

variant_cat
variant_date_from_timestamp
COM İşlevleri


Unix zaman damgasının varyant tarih gösterimini döndürür

variant_cmp
variant_date_to_timestamp
COM İşlevleri
PHP Manual

variant_date_from_timestamp

(PHP 5, PHP 7)

variant_date_from_timestamp — Unix zaman damgasının varyant tarih gösterimini döndürür

Açıklama

variant variant_date_from_timestamp ( int $zamandamgasi )

Unix zamandamgasi değerini VT_DATE türü varyant tarihe çevirir. COM ve PHP'nin unix parçaları arasında çalışma kolaylığı sağlar.

Değiştirgeler

zamandamgasi

Unix zaman damgası.

Dönen Değerler

VT_DATE türünde varyant bir değer döndürür.

Ayrıca Bakınız

  • variant_date_to_timestamp() - Varyant tarih/zaman değerini Unix zaman damgasına çevirir
  • mktime() - Bir tarih için Unix zaman damgasını döndürür
  • time() - Geçerli Unix zaman damgasını döndürür

variant_cmp
variant_date_to_timestamp
COM İşlevleri


Varyant tarih/zaman değerini Unix zaman damgasına çevirir

variant_date_from_timestamp
variant_div
COM İşlevleri
PHP Manual

variant_date_to_timestamp

(PHP 5, PHP 7)

variant_date_to_timestamp — Varyant tarih/zaman değerini Unix zaman damgasına çevirir

Açıklama

int variant_date_to_timestamp ( variant $varyant )

VT_DATE veya benzeri varyant değeri Unix zaman damgasına çevirir. COM ve PHP'nin unix parçaları arasında çalışma kolaylığı sağlar.

Değiştirgeler

varyant

Varyant değer.

Dönen Değerler

Unix zaman damgası geri döner.

Ayrıca Bakınız

  • variant_date_from_timestamp() - Unix zaman damgasının varyant tarih gösterimini döndürür
  • date() - Yerel tarihi/saati biçimlendirir
  • strftime() - Format a local time/date according to locale settings

variant_date_from_timestamp
variant_div
COM İşlevleri


İki varyant değerin bölme sonucunu döndürür

variant_date_to_timestamp
variant_eqv
COM İşlevleri
PHP Manual

variant_div

(PHP 5, PHP 7)

variant_div — İki varyant değerin bölme sonucunu döndürür

Açıklama

mixed variant_div ( mixed $sol , mixed $sag )

sol ile sag değiştirge arasında bölme yapar ve sonucu döndürür.

Değiştirgeler

sol

Sol terim.

sag

Sağ terim.

Bilginize:

As with all the variant arithmetic functions, the parameters for this function can be either a PHP native type (integer, string, floating point, boolean or NULL), or an instance of a COM, VARIANT or DOTNET class. PHP native types will be converted to variants using the same rules as found in the constructor for the VARIANT class. COM and DOTNET objects will have the value of their default property taken and used as the variant value.

The variant arithmetic functions are wrappers around the similarly named functions in the COM library; for more information on these functions, consult the MSDN library. The PHP functions are named slightly differently; for example variant_add() in PHP corresponds to VarAdd() in the MSDN documentation.

Dönen Değerler

Varyant Bölme Kuralları
Durum | Sonuç
İki deyimde dizge, tarih, karakter, mantıksal ise | Çift duyarlıklı sayı döner
Bir deyim dizge diğer deyim karakter ise | Bölme ve çift duyarlıklı sayı döner
Bir deyim sayısal diğeri dizge ise | Bölme ve çift duyarlıklı sayı döner
İki deyimde sayısal ise | Bölme ve çift duyarlıklı sayı döner
Deyimlerden biri NULL ise | NULL döner
sag boş, sol boş olmayan herhangi bir şey ise | DISP_E_DIVBYZERO kodu ile com_exception istisnası fırlatılır
sol boş, sag boş olmayan herhangi bir şey ise | Çift duyarlıklı 0 döner
Her iki deyim boş ise | DISP_E_OVERFLOW kodu ile com_exception istisnası fırlatılır

Ayrıca Bakınız

  • variant_idiv() - Varyant değerleri tamsayıya çevirir ve bölme yaparak sonucu döndürür

variant_date_to_timestamp
variant_eqv
COM İşlevleri


İki varyant arasında ikilik denklik karşılaştırması yapar

variant_div
variant_fix
COM İşlevleri
PHP Manual

variant_eqv

(PHP 5, PHP 7)

variant_eqv — İki varyant arasında ikilik denklik karşılaştırması yapar

Açıklama

mixed variant_eqv ( mixed $sol , mixed $sag )

İki varyant arasında ikilik denklik karşılaştırması yapar.

Değiştirgeler

sol

Sol terim.

sag

Sağ terim.

Bilginize:

As with all the variant arithmetic functions, the parameters for this function can be either a PHP native type (integer, string, floating point, boolean or NULL), or an instance of a COM, VARIANT or DOTNET class. PHP native types will be converted to variants using the same rules as found in the constructor for the VARIANT class. COM and DOTNET objects will have the value of their default property taken and used as the variant value.

The variant arithmetic functions are wrappers around the similarly named functions in the COM library; for more information on these functions, consult the MSDN library. The PHP functions are named slightly differently; for example variant_add() in PHP corresponds to VarAdd() in the MSDN documentation.

Dönen Değerler

sol'un her bir biti sag'ın karşılık gelen bitine eşitse TRUE, aksi durumda FALSE döner.

variant_div
variant_fix
COM İşlevleri


Varyantın tamsayı kısmını geri döndürür

variant_eqv
variant_get_type
COM İşlevleri
PHP Manual

variant_fix

(PHP 5, PHP 7)

variant_fix — Varyantın tamsayı kısmını geri döndürür

Açıklama

mixed variant_fix ( mixed $varyant )

Varyant bir değerin tamsayı kısmını alır.

Değiştirgeler

varyant

Varyant.

Bilginize:

As with all the variant arithmetic functions, the parameters for this function can be either a PHP native type (integer, string, floating point, boolean or NULL), or an instance of a COM, VARIANT or DOTNET class. PHP native types will be converted to variants using the same rules as found in the constructor for the VARIANT class. COM and DOTNET objects will have the value of their default property taken and used as the variant value.

The variant arithmetic functions are wrappers around the similarly named functions in the COM library; for more information on these functions, consult the MSDN library. The PHP functions are named slightly differently; for example variant_add() in PHP corresponds to VarAdd() in the MSDN documentation.

Dönen Değerler

varyant negatif ise varyanta eşit veya büyük olan ilk negatif tamsayı, diğer durumda varyant değerinin tamsayı kısmı geri döner.

Notlar

Uyarı

Bilgiler MSDN belgelerinden alınmıştır; Bu işlev variant_int() işlevi ile aynı gözükmektedir veya MSDN belgelerinde bir hata vardır.

Ayrıca Bakınız

  • variant_int() - Varyantın tamsayı kısmını döndürür
  • variant_round() - Bir varyantı verilen ondalık basamağa yuvarlar
  • floor() - Round fractions down
  • ceil() - Round fractions up
  • round() - Rounds a float

variant_eqv
variant_get_type
COM İşlevleri


Varyant nesnenin türünü geri döndürür

variant_fix
variant_idiv
COM İşlevleri
PHP Manual

variant_get_type

(PHP 5, PHP 7)

variant_get_type — Varyant nesnenin türünü geri döndürür

Açıklama

int variant_get_type ( variant $varyant )

Varyant nesnenin türünü geri döndürür.

Değiştirgeler

varyant

Varyant nesne.

Dönen Değerler

İşlev, varyant nesnesinin COM, DOTNET veya VARIANT sınıfından hangisinden türediğini gösteren bir tamsayı döndürür, geri dönüş değeri VT_XXX sabitlerinden biri ile karşılaştırılabilir.

COM ve DOTNET nesneleri için geri dönüş değeri genellikle VT_DISPATCH olur; işlevin bu sınıflar için çalışmasının tek nedeni COM ve DOTNET'in VARIANT soyundan gelmesidir.

PHP 5'den önceki sürümlerde, bu bilgiyi, VARIANT sınıfından türeyen bir nesnenin sahte tur özelliğini okuyarak elde edebilirsiniz, daha fazla bilgi için VARIANT sınıfına bakınız.

variant_fix
variant_idiv
COM İşlevleri


Varyant değerleri tamsayıya çevirir ve bölme yaparak sonucu döndürür

variant_get_type
variant_imp
COM İşlevleri
PHP Manual

variant_idiv

(PHP 5, PHP 7)

variant_idiv — Varyant değerleri tamsayıya çevirir ve bölme yaparak sonucu döndürür

Açıklama

mixed variant_idiv ( mixed $sol , mixed $sag )

sol ve sag değiştirgeyi tamsayıya çevirir ve bölme işlemi yapar.

Değiştirgeler

sol

Sol terim.

sag

Sağ terim.

Bilginize:

As with all the variant arithmetic functions, the parameters for this function can be either a PHP native type (integer, string, floating point, boolean or NULL), or an instance of a COM, VARIANT or DOTNET class. PHP native types will be converted to variants using the same rules as found in the constructor for the VARIANT class. COM and DOTNET objects will have the value of their default property taken and used as the variant value.

The variant arithmetic functions are wrappers around the similarly named functions in the COM library; for more information on these functions, consult the MSDN library. The PHP functions are named slightly differently; for example variant_add() in PHP corresponds to VarAdd() in the MSDN documentation.

Dönen Değerler

Varyant Tamsayı Bölme Kuralları
Durum | İşlem
Her iki deyim dizge, tarih, karakter, mantıksal türde ise | Bölme ve tamsayı döndürülür
Bir deyim dizge diğeri karakter ise | Bölme
Bir deyim sayısal diğeri dizge ise | Bölme
İki deyimde sayısal ise | Bölme
Deyimlerden biri NULL ise | NULL döndürülür
Her iki deyim boş ise | DISP_E_DIVBYZERO kodu ile com_exception istisnası fırlatılır

Ayrıca Bakınız

  • variant_div() - İki varyant değerin bölme sonucunu döndürür

variant_get_type
variant_imp
COM İşlevleri


İki varyant üzerinde ikilik çıkarım yapar

variant_idiv
variant_int
COM İşlevleri
PHP Manual

variant_imp

(PHP 5, PHP 7)

variant_imp — İki varyant üzerinde ikilik çıkarım yapar

Açıklama

mixed variant_imp ( mixed $sol , mixed $sag )

İkilik çıkarım işlemi yapar.

Değiştirgeler

sol

Sol terim.

sag

Sağ terim.

Bilginize:

As with all the variant arithmetic functions, the parameters for this function can be either a PHP native type (integer, string, floating point, boolean or NULL), or an instance of a COM, VARIANT or DOTNET class. PHP native types will be converted to variants using the same rules as found in the constructor for the VARIANT class. COM and DOTNET objects will have the value of their default property taken and used as the variant value.

The variant arithmetic functions are wrappers around the similarly named functions in the COM library; for more information on these functions, consult the MSDN library. The PHP functions are named slightly differently; for example variant_add() in PHP corresponds to VarAdd() in the MSDN documentation.

Dönen Değerler

Varyant Çıkarım Tablosu
sol | sag | Sonuç
TRUE | TRUE | TRUE
TRUE | FALSE | TRUE
TRUE | NULL | TRUE
FALSE | TRUE | TRUE
FALSE | FALSE | TRUE
FALSE | NULL | TRUE
NULL | TRUE | TRUE
NULL | FALSE | NULL
NULL | NULL | NULL

variant_idiv
variant_int
COM İşlevleri


Varyantın tamsayı kısmını döndürür

variant_imp
variant_mod
COM İşlevleri
PHP Manual

variant_int

(PHP 5, PHP 7)

variant_int — Varyantın tamsayı kısmını döndürür

Açıklama

mixed variant_int ( mixed $varyant )

Varyantın tamsayı kısmını döndürür.

Değiştirgeler

varyant

Varyant.

Bilginize:

As with all the variant arithmetic functions, the parameters for this function can be either a PHP native type (integer, string, floating point, boolean or NULL), or an instance of a COM, VARIANT or DOTNET class. PHP native types will be converted to variants using the same rules as found in the constructor for the VARIANT class. COM and DOTNET objects will have the value of their default property taken and used as the variant value.

The variant arithmetic functions are wrappers around the similarly named functions in the COM library; for more information on these functions, consult the MSDN library. The PHP functions are named slightly differently; for example variant_add() in PHP corresponds to VarAdd() in the MSDN documentation.

Dönen Değerler

varyant negatif ise varyanta eşit veya büyük olan ilk negatif tamsayı, diğer durumda varyant değerinin tamsayı kısmı geri döner.

Ayrıca Bakınız

  • variant_fix() - Varyantın tamsayı kısmını geri döndürür
  • variant_round() - Bir varyantı verilen ondalık basamağa yuvarlar
  • floor() - Round fractions down
  • ceil() - Round fractions up
  • round() - Rounds a float

variant_imp
variant_mod
COM İşlevleri


İki varyantın bölme işleminden kalanı geri döndürür

variant_int
variant_mul
COM İşlevleri
PHP Manual

variant_mod

(PHP 5, PHP 7)

variant_mod — İki varyantın bölme işleminden kalanı geri döndürür

Açıklama

mixed variant_mod ( mixed $sol , mixed $sag )

sol ile sag değiştirgeyi böler ve kalanı geri döndürür.

Değiştirgeler

sol

Sol terim.

sag

Sağ terim.

Bilginize:

As with all the variant arithmetic functions, the parameters for this function can be either a PHP native type (integer, string, floating point, boolean or NULL), or an instance of a COM, VARIANT or DOTNET class. PHP native types will be converted to variants using the same rules as found in the constructor for the VARIANT class. COM and DOTNET objects will have the value of their default property taken and used as the variant value.

The variant arithmetic functions are wrappers around the similarly named functions in the COM library; for more information on these functions, consult the MSDN library. The PHP functions are named slightly differently; for example variant_add() in PHP corresponds to VarAdd() in the MSDN documentation.

Dönen Değerler

Bölme işleminden kalanı geri döndürür.

Ayrıca Bakınız

  • variant_div() - İki varyant değerin bölme sonucunu döndürür
  • variant_idiv() - Varyant değerleri tamsayıya çevirir ve bölme yaparak sonucu döndürür

variant_int
variant_mul
COM İşlevleri


İki varyant değerleri için çarpma işlemi yapar

variant_mod
variant_neg
COM İşlevleri
PHP Manual

variant_mul

(PHP 5, PHP 7)

variant_mul — İki varyant değerleri için çarpma işlemi yapar

Açıklama

mixed variant_mul ( mixed $sol , mixed $sag )

sol ile sag değiştirgeyi çarpar.

Değiştirgeler

sol

Sol terim.

sag

Sağ terim.

Mantıksal değerler FALSE -1, TRUE 0 olarak dönüştürülür.

Bilginize:

As with all the variant arithmetic functions, the parameters for this function can be either a PHP native type (integer, string, floating point, boolean or NULL), or an instance of a COM, VARIANT or DOTNET class. PHP native types will be converted to variants using the same rules as found in the constructor for the VARIANT class. COM and DOTNET objects will have the value of their default property taken and used as the variant value.

The variant arithmetic functions are wrappers around the similarly named functions in the COM library; for more information on these functions, consult the MSDN library. The PHP functions are named slightly differently; for example variant_add() in PHP corresponds to VarAdd() in the MSDN documentation.

Dönen Değerler

Varyant Çarpma Kuralları
Durum | İşlem
İki deyimde dizge, tarih, karakter, mantıksal türlerinden biri | Çarpma
Bir deyim dizge diğeri karakter | Çarpma
Bir deyim sayısal diğeri dizge | Çarpma
Her iki deyim sayısal | Çarpma
Biri NULL | NULL döner
Her iki deyim boş ise | Boş bir dizge döner

Ayrıca Bakınız

  • variant_div() - İki varyant değerin bölme sonucunu döndürür
  • variant_idiv() - Varyant değerleri tamsayıya çevirir ve bölme yaparak sonucu döndürür

variant_mod
variant_neg
COM İşlevleri


Bir varyant üzerinde mantıksal değil işlemi yapar

variant_mul
variant_not
COM İşlevleri
PHP Manual

variant_neg

(PHP 5, PHP 7)

variant_neg — Bir varyant üzerinde mantıksal değil işlemi yapar

Açıklama

mixed variant_neg ( mixed $varyant )

varyant üzerinde mantıksal değil işlemi yapar.

Değiştirgeler

varyant

Varyant.

Bilginize:

As with all the variant arithmetic functions, the parameters for this function can be either a PHP native type (integer, string, floating point, boolean or NULL), or an instance of a COM, VARIANT or DOTNET class. PHP native types will be converted to variants using the same rules as found in the constructor for the VARIANT class. COM and DOTNET objects will have the value of their default property taken and used as the variant value.

The variant arithmetic functions are wrappers around the similarly named functions in the COM library; for more information on these functions, consult the MSDN library. The PHP functions are named slightly differently; for example variant_add() in PHP corresponds to VarAdd() in the MSDN documentation.

Dönen Değerler

Mantıksal değil sonucunu döndürür.

variant_mul
variant_not
COM İşlevleri


Bir varyant üzerinde ikilik değil işlemi yapar

variant_neg
variant_or
COM İşlevleri
PHP Manual

variant_not

(PHP 5, PHP 7)

variant_not — Bir varyant üzerinde ikilik değil işlemi yapar

Açıklama

mixed variant_not ( mixed $varyant )

varyant üzerinde ikilik değil işlemi yapar ve sonucu geri döndürür.

Değiştirgeler

varyant

Varyant.

Bilginize:

As with all the variant arithmetic functions, the parameters for this function can be either a PHP native type (integer, string, floating point, boolean or NULL), or an instance of a COM, VARIANT or DOTNET class. PHP native types will be converted to variants using the same rules as found in the constructor for the VARIANT class. COM and DOTNET objects will have the value of their default property taken and used as the variant value.

The variant arithmetic functions are wrappers around the similarly named functions in the COM library; for more information on these functions, consult the MSDN library. The PHP functions are named slightly differently; for example variant_add() in PHP corresponds to VarAdd() in the MSDN documentation.

Dönen Değerler

İkilik değil sonucunu döndürür. Eğer varyant NULL ise NULL geri dönecektir.

variant_neg
variant_or
COM İşlevleri


İki varyant üzerinde mantıksal ayırma işlemi yapar

variant_not
variant_pow
COM İşlevleri
PHP Manual

variant_or

(PHP 5, PHP 7)

variant_or — İki varyant üzerinde mantıksal ayırma işlemi yapar

Açıklama

mixed variant_or ( mixed $sol , mixed $sag )

İkilik veya işlemi yapar. Bunun normal veya işleminden farklı olduğuna dikkat ediniz.

Değiştirgeler

sol

Sol terim.

sag

Sağ terim.

Bilginize:

As with all the variant arithmetic functions, the parameters for this function can be either a PHP native type (integer, string, floating point, boolean or NULL), or an instance of a COM, VARIANT or DOTNET class. PHP native types will be converted to variants using the same rules as found in the constructor for the VARIANT class. COM and DOTNET objects will have the value of their default property taken and used as the variant value.

The variant arithmetic functions are wrappers around the similarly named functions in the COM library; for more information on these functions, consult the MSDN library. The PHP functions are named slightly differently; for example variant_add() in PHP corresponds to VarAdd() in the MSDN documentation.

Dönen Değerler

Varyant VEYA Kuralları
sol | sag | Sonuç
TRUE | TRUE | TRUE
TRUE | FALSE | TRUE
TRUE | NULL | TRUE
FALSE | TRUE | TRUE
FALSE | FALSE | FALSE
FALSE | NULL | NULL
NULL | TRUE | TRUE
NULL | FALSE | NULL
NULL | NULL | NULL

Ayrıca Bakınız

  • variant_and() - İki varyant üzerinde ikilik VE işlemi yapar
  • variant_xor() - İki varyant arasında mantıksal çıkarma yapar

variant_not
variant_pow
COM İşlevleri


Üs alma işlemi yaparak sonucu döndürür

variant_or
variant_round
COM İşlevleri
PHP Manual

variant_pow

(PHP 5, PHP 7)

variant_pow — Üs alma işlemi yaparak sonucu döndürür

Açıklama

mixed variant_pow ( mixed $sol , mixed $sag )

sol'un sag üssünü alarak sonucu geri döndürür.

Değiştirgeler

sol

Sol terim.

sag

Sağ terim.

Bilginize:

As with all the variant arithmetic functions, the parameters for this function can be either a PHP native type (integer, string, floating point, boolean or NULL), or an instance of a COM, VARIANT or DOTNET class. PHP native types will be converted to variants using the same rules as found in the constructor for the VARIANT class. COM and DOTNET objects will have the value of their default property taken and used as the variant value.

The variant arithmetic functions are wrappers around the similarly named functions in the COM library; for more information on these functions, consult the MSDN library. The PHP functions are named slightly differently; for example variant_add() in PHP corresponds to VarAdd() in the MSDN documentation.

Dönen Değerler

sol'un sag üssünü alarak sonucu geri döndürür.

Ayrıca Bakınız

  • pow() - Exponential expression

variant_or
variant_round
COM İşlevleri


Bir varyantı verilen ondalık basamağa yuvarlar

variant_pow
variant_set_type
COM İşlevleri
PHP Manual

variant_round

(PHP 5, PHP 7)

variant_round — Bir varyantı verilen ondalık basamağa yuvarlar

Açıklama

mixed variant_round ( mixed $varyant , int $ondalik )

varyant değerini ondalik basamağına kadar yuvarlayarak sonucu döndürür.

Değiştirgeler

varyant

Varyant.

ondalik

Ondalık basamak sayısı.

Bilginize:

As with all the variant arithmetic functions, the parameters for this function can be either a PHP native type (integer, string, floating point, boolean or NULL), or an instance of a COM, VARIANT or DOTNET class. PHP native types will be converted to variants using the same rules as found in the constructor for the VARIANT class. COM and DOTNET objects will have the value of their default property taken and used as the variant value.

The variant arithmetic functions are wrappers around the similarly named functions in the COM library; for more information on these functions, consult the MSDN library. The PHP functions are named slightly differently; for example variant_add() in PHP corresponds to VarAdd() in the MSDN documentation.

Dönen Değerler

Yuvarlanmış sonucu döndürür.

Ayrıca Bakınız

  • round() - Rounds a float

variant_pow
variant_set_type
COM İşlevleri


Varyantı başka bir türe "yerinde" dönüştürür

variant_round
variant_set
COM İşlevleri
PHP Manual

variant_set_type

(PHP 5, PHP 7)

variant_set_type — Varyantı başka bir türe "yerinde" dönüştürür

Açıklama

void variant_set_type ( variant $varyant , int $tur )

İşlev, varyantı "yerinde" değiştirmesi hariç variant_cast() ile benzerdir; yeni bir varyant yaratılmaz. Değiştirgeler variant_cast() ile aynı anlama sahiptir.

Değiştirgeler

varyant

Varyant.

tur

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • variant_cast() - Varyantı başka türde bir varyant nesneye dönüştürür

variant_round
variant_set
COM İşlevleri


Varyant nesnesine yeni bir değer verir

variant_set_type
variant_sub
COM İşlevleri
PHP Manual

variant_set

(PHP 5, PHP 7)

variant_set — Varyant nesnesine yeni bir değer verir

Açıklama

void variant_set ( variant $varyant , mixed $deger )

deger'i varyanta dönüştürür ve varyant nesnesine yükler; yeni bir varyant nesnesi oluşturulmaz, varyant eski değeri serbest bırakılır.

Değiştirgeler

varyant

Varyant.

deger

Dönen Değerler

Hiçbir değer dönmez.

variant_set_type
variant_sub
COM İşlevleri


Sağ varyant değerini sol varyant değerinden çıkartır

variant_set
variant_xor
COM İşlevleri
PHP Manual

variant_sub

(PHP 5, PHP 7)

variant_sub — Sağ varyant değerini sol varyant değerinden çıkartır

Açıklama

mixed variant_sub ( mixed $sol , mixed $sag )

sag değeri sol değerden çıkartır.

Değiştirgeler

sol

Sol terim.

sag

Sağ terim.

Bilginize:

As with all the variant arithmetic functions, the parameters for this function can be either a PHP native type (integer, string, floating point, boolean or NULL), or an instance of a COM, VARIANT or DOTNET class. PHP native types will be converted to variants using the same rules as found in the constructor for the VARIANT class. COM and DOTNET objects will have the value of their default property taken and used as the variant value.

The variant arithmetic functions are wrappers around the similarly named functions in the COM library; for more information on these functions, consult the MSDN library. The PHP functions are named slightly differently; for example variant_add() in PHP corresponds to VarAdd() in the MSDN documentation.

Dönen Değerler

Varyant Çıkartma Kuralları
Durum | İşlem
İki deyimde dizge türünde ise | Çıkartma
Bir deyim dizge diğeri karakter ise | Çıkartma
Bir deyim sayısal diğeri dizge ise | Çıkartma
İki deyimde sayısal ise | Çıkartma
İki deyimden biri NULL ise | NULL döner
İki deyimde boş ise | Boş dizge geri döner

Ayrıca Bakınız

  • variant_add() - İki varyant değeri birleştirir ve sonucu geri döndürür

variant_set
variant_xor
COM İşlevleri


İki varyant arasında mantıksal çıkarma yapar

variant_sub
win32ps
COM İşlevleri
PHP Manual

variant_xor

(PHP 5, PHP 7)

variant_xor — İki varyant arasında mantıksal çıkarma yapar

Açıklama

mixed variant_xor ( mixed $sol , mixed $sag )

Mantıksal çıkarma yapar.

Değiştirgeler

sol

Sol terim.

sag

Sağ terim.

Bilginize:

As with all the variant arithmetic functions, the parameters for this function can be either a PHP native type (integer, string, floating point, boolean or NULL), or an instance of a COM, VARIANT or DOTNET class. PHP native types will be converted to variants using the same rules as found in the constructor for the VARIANT class. COM and DOTNET objects will have the value of their default property taken and used as the variant value.

The variant arithmetic functions are wrappers around the similarly named functions in the COM library; for more information on these functions, consult the MSDN library. The PHP functions are named slightly differently; for example variant_add() in PHP corresponds to VarAdd() in the MSDN documentation.

Dönen Değerler

Varyant Mantıksal Çıkarma Kuralları
sol | sag | Sonuç
TRUE | TRUE | FALSE
TRUE | FALSE | TRUE
FALSE | TRUE | TRUE
FALSE | FALSE | FALSE
NULL | NULL | NULL

Ayrıca Bakınız

  • variant_or() - İki varyant üzerinde mantıksal ayırma işlemi yapar
  • variant_and() - İki varyant üzerinde ikilik VE işlemi yapar

variant_sub
win32ps
COM İşlevleri


win32ps

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
    • win32ps örnekleri
  • win32ps İşlevleri
    • win32_ps_list_procs — Çalışan süreçleri listeler
    • win32_ps_stat_mem — Bellek kullanımı ile ilgili istatistikleri döndürür
    • win32_ps_stat_proc — Belirtilen süreçle ilgili istatistikleri döndürür
variant_xor
Giriş
Windows’a Özgü Eklentiler


Giriş

win32ps eklentisi Windows'a özgü olup PHP'nin süreç ve bellek kullanımları ile ilgili istatistikleri almasını sağlar.

win32ps
Yapılandırma/Kurulum
win32ps


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
win32ps


Gereksinimler

Windows NT, Windows 2000, Windows XP veya Windows Server 2003. Windows NT'den türetilmiş her Windows sürümüyle uyumludur.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/win32ps.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
Örnekler
win32ps


Örnekler

İçindekiler

  • win32ps örnekleri
Öntanımlı Sabitler
win32ps örnekleri
win32ps


win32ps örnekleri

Örnek 1 - PHP süreciyle ilgili istatistikler

<?php
print_r(win32_ps_stat_proc());
/*
    Array
    (
        [pid] => 936
        [exe] => D:\Daten\Source\php-5.1\Debug_TS\php.exe
        [mem] => Array
            (
                [page_fault_count] => 2062
                [peak_working_set_size] => 8396800
                [working_set_size] => 8396800
                [quota_peak_paged_pool_usage] => 32080
                [quota_paged_pool_usage] => 31876
                [quota_peak_non_paged_pool_usage] => 4240
                [quota_non_paged_pool_usage] => 3888
                [pagefile_usage] => 5865472
                [peak_pagefile_usage] => 5865472
            )

        [tms] => Array
            (
                [created] => 0.093
                [kernel] => 0.015
                [user] => 0.062
            )

    )
*/
?>

Örnek 2 - Küresel bellek kullanımı ile ilgili istatistikler

<?php
print_r(win32_ps_stat_mem());
/*
    Array
    (
        [load] => 37
        [unit] => 1024
        [total_phys] => 1048096
        [avail_phys] => 649960
        [total_pagefile] => 2521368
        [avail_pagefile] => 2237940
        [total_virtual] => 2097024
        [avail_virtual] => 2057848
    )
*/
?>

Örnekler
win32ps İşlevleri
Örnekler


win32ps İşlevleri

İçindekiler

  • win32_ps_list_procs — Çalışan süreçleri listeler
  • win32_ps_stat_mem — Bellek kullanımı ile ilgili istatistikleri döndürür
  • win32_ps_stat_proc — Belirtilen süreçle ilgili istatistikleri döndürür
win32ps örnekleri
win32_ps_list_procs
win32ps


Çalışan süreçleri listeler

win32ps İşlevleri
win32_ps_stat_mem
win32ps İşlevleri
PHP Manual

win32_ps_list_procs

(PECL win32ps >= 1.0.1)

win32_ps_list_procs — Çalışan süreçleri listeler

Açıklama

array win32_ps_list_procs ( void )

Çalışan süreçlerle ilgili istatistikleri döndürür.

Dönen Değerler

Başarısızlık durumunda FALSE, aksi takdirde win32_ps_stat_proc() işlevinin bir süreç için döndürdüğü istatistikleri çalışan tüm süreçler için bir dizi olarak döndürür.

Ayrıca Bakınız

  • win32_ps_stat_proc() - Belirtilen süreçle ilgili istatistikleri döndürür

win32ps İşlevleri
win32_ps_stat_mem
win32ps İşlevleri


Bellek kullanımı ile ilgili istatistikleri döndürür

win32_ps_list_procs
win32_ps_stat_proc
win32ps İşlevleri
PHP Manual

win32_ps_stat_mem

(PECL win32ps >= 1.0.1)

win32_ps_stat_mem — Bellek kullanımı ile ilgili istatistikleri döndürür

Açıklama

array win32_ps_stat_mem ( void )

Küresel bellek kullanımı ile ilgili istatistikleri döndürür.

Dönen Değerler

Başarısızlık durumunda FALSE, aksi takdirde aşağıdaki bilgileri içeren bir dizi döner:

load

Geçerli bellek yükünün fiziksel belleğe oranı.

unit

Daima 1024 olup, izleyen değerlerin 1024 baytın katları olduğunu belirtir.

total_phys

Toplam fiziksel bellek miktarı.

avail_phys

Kullanılabilir fiziksel bellek miktarı.

total_pagefile

Sayfalanabilir bellek miktarı (fiziksel bellek + sayfalama dosyası).

avail_pagefile

Kullanılabilir sayfalanabilir bellek miktarı (fiziksel bellek + sayfalama dosyası).

total_virtual

Bir süreç için toplam sanal bellek miktarı.

avail_virtual

Bir süreç için kullanılabilir sanal bellek miktarı.

win32_ps_list_procs
win32_ps_stat_proc
win32ps İşlevleri


Belirtilen süreçle ilgili istatistikleri döndürür

win32_ps_stat_mem
win32service
win32ps İşlevleri
PHP Manual

win32_ps_stat_proc

(PECL win32ps >= 1.0.1)

win32_ps_stat_proc — Belirtilen süreçle ilgili istatistikleri döndürür

Açıklama

array win32_ps_stat_proc ([ int $pid = 0 ] )

Süreç kimliği pid ile belirtilen süreçle ilgili istatistikleri döndürür.

Değiştirgeler

pid

Durumu döndürülecek sürecin süreç kimliği. Belirtilmezse çağrıyı yapan sürecin kimliği öntanımlıdır.

Dönen Değerler

Başarısızlık durumunda FALSE, aksi takdirde aşağıdaki bilgileri içeren bir dizi döner:

pid

Süreç kimliği.

exe

Çalıştırılabilir dosyanın ismi.

mem

Bellekle ilgili şu anahtarları içeren bir dizi: page_fault_count, peak_working_set_size, working_set_size, quota_peak_paged_pool_usage, quota_paged_pool_usage, quota_peak_non_paged_pool_usage, quota_non_paged_pool_usage, pagefile_usage ve peak_pagefile_usage.

tms

İşlemci zamanıyla ilgili şu anahtarları içeren bir dizi: created, kernel ve user.

Ayrıca Bakınız

  • win32_ps_list_procs() - Çalışan süreçleri listeler

win32_ps_stat_mem
win32service
win32ps İşlevleri


win32service

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
    • Win32Service Service Type Bitmasks
    • Win32Service Service Status Constants
    • Win32Service Service Control Message Constants
    • Win32Service Service Control Message Accepted Bitmasks
    • Win32Service Service Start Type Constants
    • Win32Service Service Error Control Constants
    • Win32Service Service Flag Constants
    • Win32 Error Codes
    • Win32 Base Priority Classes
  • Örnekler
    • Bir PHP betiğinin hizmet olarak çalışacağını belirtmek
  • win32service İşlevleri
    • win32_continue_service — Resumes a paused service
    • win32_create_service — Hizmet yönetim veritabanında yeni bir hizmet girdisi oluşturur
    • win32_delete_service — Bir hizmet girdisini Hizmet yönetim veritabanından siler
    • win32_get_last_control_message — Hizmete gönderilmiş son denetim kodunu döndürür
    • win32_pause_service — Pauses a service
    • win32_query_service_status — Bir hizmetin durumunu sorgular
    • win32_set_service_status — Hizmet durumunu günceller
    • win32_start_service_ctrl_dispatcher — Hizmet yöneticisine ismi belirtilen hizmet gibi davranacak bir betik tanıtır
    • win32_start_service — Bir hizmeti başlatır
    • win32_stop_service — Bir hizmeti durdurur
win32_ps_stat_proc
Giriş
Windows’a Özgü Eklentiler


Giriş

win32service eklentisi tamamen Windows'a özgü bir eklenti olup PHP'nin hizmetleri başlatmak, durdurmak ve hizmet dışı bırakmak, hatta PHP betiklerinin birer hizmet olarak çalıştırılmasını temin için hizmet denetim yöneticisi ile iletişimini sağlar.

win32service
Yapılandırma/Kurulum
win32service


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
win32service


Gereksinimler

Windows NT, Windows 2000, Windows XP veya Windows Server 2003. Windows NT'den türetilmiş her Windows sürümü ile uyumludur.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

PECL'den kurulum

  1. php_win32service.dll http://snaps.php.net/win32/ adresinden indirilebilir. PHP sürümünüzle eşleşen PECL_X_X dizinini seçiniz.

  2. php_win32service.dll dosyasını extension_dir dizininize kopyalayın.

  3. Eklentiyi php.ini dosyanızdan yükleyin:

    extension=php_win32service.dll

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

İçindekiler

  • Win32Service Service Type Bitmasks
  • Win32Service Service Status Constants
  • Win32Service Service Control Message Constants
  • Win32Service Service Control Message Accepted Bitmasks
  • Win32Service Service Start Type Constants
  • Win32Service Service Error Control Constants
  • Win32Service Service Flag Constants
  • Win32 Error Codes
  • Win32 Base Priority Classes

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

Özkaynak Türleri
Win32Service Service Type Bitmasks
win32service


Win32Service Service Type Bitmasks

Öntanımlı Sabitler
Win32Service Service Status Constants
Öntanımlı Sabitler
PHP Manual
Win32Service Service Type Bitmasks
Constant | Value | Description
WIN32_SERVICE_WIN32_OWN_PROCESS | 0x00000010 | The service runs in its own process.
WIN32_SERVICE_INTERACTIVE_PROCESS | 0x00000100 | The service can interact with the desktop. This option is not available on Windows Vista or later.
WIN32_SERVICE_WIN32_OWN_PROCESS_INTERACTIVE | 0x00000110 | The service runs in its own process and can interact with the desktop. This option is not available on Windows Vista or later.
Öntanımlı Sabitler
Win32Service Service Status Constants
Öntanımlı Sabitler


Win32Service Service Status Constants

Win32Service Service Type Bitmasks
Win32Service Service Control Message Constants
Öntanımlı Sabitler
PHP Manual
Win32Service Service Status Constants
Constant | Value | Description
WIN32_SERVICE_CONTINUE_PENDING | 0x00000005 | The service continue is pending.
WIN32_SERVICE_PAUSE_PENDING | 0x00000006 | The service pause is pending.
WIN32_SERVICE_PAUSED | 0x00000007 | The service is paused.
WIN32_SERVICE_RUNNING | 0x00000004 | The service is running.
WIN32_SERVICE_START_PENDING | 0x00000002 | The service is starting.
WIN32_SERVICE_STOP_PENDING | 0x00000003 | The service is stopping.
WIN32_SERVICE_STOPPED | 0x00000001 | The service is not running.
Win32Service Service Type Bitmasks
Win32Service Service Control Message Constants
Öntanımlı Sabitler


Win32Service Service Control Message Constants

Win32Service Service Status Constants
Win32Service Service Control Message Accepted Bitmasks
Öntanımlı Sabitler
PHP Manual
Win32Service Service Control Message Constants
Constant | Value | Description
WIN32_SERVICE_CONTROL_CONTINUE | 0x00000003 | Notifies a paused service that it should resume.
WIN32_SERVICE_CONTROL_INTERROGATE | 0x00000004 | Notifies a service that it should report its current status information to the service control manager.
WIN32_SERVICE_CONTROL_PAUSE | 0x00000002 | Notifies a service that it should pause.
WIN32_SERVICE_CONTROL_PRESHUTDOWN | 0x0000000F | Notifies a service that the system will be shutting down. A service that handles this notification blocks system shutdown until the service stops or the preshutdown time-out interval expires. This value is not supported by Windows Server 2003 and Windows XP/2000.
WIN32_SERVICE_CONTROL_SHUTDOWN | 0x00000005 | Notifies a service that the system is shutting down so the service can perform cleanup tasks. If a service accepts this control code, it must stop after it performs its cleanup tasks. After the SCM sends this control code, it will not send other control codes to the service.
WIN32_SERVICE_CONTROL_STOP | 0x00000001 | Notifies a service that it should stop.
Win32Service Service Status Constants
Win32Service Service Control Message Accepted Bitmasks
Öntanımlı Sabitler


Win32Service Service Control Message Accepted Bitmasks

Win32Service Service Control Message Constants
Win32Service Service Start Type Constants
Öntanımlı Sabitler
PHP Manual
Win32Service Service Control Message Accepted Bitmasks
Constant | Value | Description
WIN32_SERVICE_ACCEPT_PAUSE_CONTINUE | 0x00000002 | The service can be paused and continued. This control code allows the service to receive WIN32_SERVICE_CONTROL_PAUSE and WIN32_SERVICE_CONTROL_CONTINUE notifications.
WIN32_SERVICE_ACCEPT_PRESHUTDOWN | 0x00000100 | The service can perform preshutdown tasks. This control code enables the service to receive WIN32_SERVICE_CONTROL_PRESHUTDOWN notifications. This value is not supported by Windows Server 2003 and Windows XP/2000.
WIN32_SERVICE_ACCEPT_SHUTDOWN | 0x00000004 | The service is notified when system shutdown occurs. This control code allows the service to receive WIN32_SERVICE_CONTROL_SHUTDOWN notifications.
WIN32_SERVICE_ACCEPT_STOP | 0x00000001 | The service can be stopped. This control code allows the service to receive WIN32_SERVICE_CONTROL_STOP notifications.
Win32Service Service Control Message Constants
Win32Service Service Start Type Constants
Öntanımlı Sabitler


Win32Service Service Start Type Constants

Win32Service Service Control Message Accepted Bitmasks
Win32Service Service Error Control Constants
Öntanımlı Sabitler
PHP Manual
Win32Service Service Start Type Constants
Constant | Value | Description
WIN32_SERVICE_AUTO_START | 0x00000002 | A service started automatically by the service control manager during system startup.
WIN32_SERVICE_DEMAND_START | 0x00000003 | A service started by the service control manager when a process calls the StartService function.
WIN32_SERVICE_DISABLED | 0x00000004 | A service that cannot be started. Attempts to start the service result in the error code WIN32_ERROR_SERVICE_DISABLED.
Win32Service Service Control Message Accepted Bitmasks
Win32Service Service Error Control Constants
Öntanımlı Sabitler


Win32Service Service Error Control Constants

Win32Service Service Start Type Constants
Win32Service Service Flag Constants
Öntanımlı Sabitler
PHP Manual
Win32Service Service Error Control Constants
Constant | Value | Description
WIN32_SERVICE_ERROR_IGNORE | 0x00000000 | The startup program ignores the error and continues the startup operation.
WIN32_SERVICE_ERROR_NORMAL | 0x00000001 | The startup program logs the error in the event log but continues the startup operation.
Win32Service Service Start Type Constants
Win32Service Service Flag Constants
Öntanımlı Sabitler


Win32Service Service Flag Constants

Win32Service Service Error Control Constants
Win32 Error Codes
Öntanımlı Sabitler
PHP Manual
Win32Service Service Flag Constants
Constant | Value | Description
WIN32_SERVICE_RUNS_IN_SYSTEM_PROCESS | 0x00000001 | The service runs in a system process that must always be running.
Win32Service Service Error Control Constants
Win32 Error Codes
Öntanımlı Sabitler


Win32 Error Codes

Win32Service Service Flag Constants
Win32 Base Priority Classes
Öntanımlı Sabitler
PHP Manual
Win32 Error Codes
Constant | Value | Description
WIN32_ERROR_ACCESS_DENIED | 0x00000005 | The handle to the SCM database does not have the appropriate access rights.
WIN32_ERROR_CIRCULAR_DEPENDENCY | 0x00000423 | A circular service dependency was specified.
WIN32_ERROR_DATABASE_DOES_NOT_EXIST | 0x00000429 | The specified database does not exist.
WIN32_ERROR_DEPENDENT_SERVICES_RUNNING | 0x0000041B | The service cannot be stopped because other running services are dependent on it.
WIN32_ERROR_DUPLICATE_SERVICE_NAME | 0x00000436 | The display name already exists in the service control manager database either as a service name or as another display name.
WIN32_ERROR_FAILED_SERVICE_CONTROLLER_CONNECT | 0x00000427 | This error is returned if the program is being run as a console application rather than as a service. If the program will be run as a console application for debugging purposes, structure it such that service-specific code is not called.
WIN32_ERROR_INSUFFICIENT_BUFFER | 0x0000007A | The buffer is too small for the service status structure. Nothing was written to the structure.
WIN32_ERROR_INVALID_DATA | 0x0000000D | The specified service status structure is invalid.
WIN32_ERROR_INVALID_HANDLE | 0x00000006 | The handle to the specified service control manager database is invalid.
WIN32_ERROR_INVALID_LEVEL | 0x0000007C | The InfoLevel parameter contains an unsupported value.
WIN32_ERROR_INVALID_NAME | 0x0000007B | The specified service name is invalid.
WIN32_ERROR_INVALID_PARAMETER | 0x00000057 | A parameter that was specified is invalid.
WIN32_ERROR_INVALID_SERVICE_ACCOUNT | 0x00000421 | The user account name specified in the user parameter does not exist. See win32_create_service().
WIN32_ERROR_INVALID_SERVICE_CONTROL | 0x0000041C | The requested control code is not valid, or it is unacceptable to the service.
WIN32_ERROR_PATH_NOT_FOUND | 0x00000003 | The service binary file could not be found.
WIN32_ERROR_SERVICE_ALREADY_RUNNING | 0x00000420 | An instance of the service is already running.
WIN32_ERROR_SERVICE_CANNOT_ACCEPT_CTRL | 0x00000425 | The requested control code cannot be sent to the service because the state of the service is WIN32_SERVICE_STOPPED, WIN32_SERVICE_START_PENDING, or WIN32_SERVICE_STOP_PENDING.
WIN32_ERROR_SERVICE_DATABASE_LOCKED | 0x0000041F | The database is locked.
WIN32_ERROR_SERVICE_DEPENDENCY_DELETED | 0x00000433 | The service depends on a service that does not exist or has been marked for deletion.
WIN32_ERROR_SERVICE_DEPENDENCY_FAIL | 0x0000042C | The service depends on another service that has failed to start.
WIN32_ERROR_SERVICE_DISABLED | 0x00000422 | The service has been disabled.
WIN32_ERROR_SERVICE_DOES_NOT_EXIST | 0x00000424 | The specified service does not exist as an installed service.
WIN32_ERROR_SERVICE_EXISTS | 0x00000431 | The specified service already exists in this database.
WIN32_ERROR_SERVICE_LOGON_FAILED | 0x0000042D | The service did not start due to a logon failure. This error occurs if the service is configured to run under an account that does not have the "Log on as a service" right.
WIN32_ERROR_SERVICE_MARKED_FOR_DELETE | 0x00000430 | The specified service has already been marked for deletion.
WIN32_ERROR_SERVICE_NO_THREAD | 0x0000041E | A thread could not be created for the service.
WIN32_ERROR_SERVICE_NOT_ACTIVE | 0x00000426 | The service has not been started.
WIN32_ERROR_SERVICE_REQUEST_TIMEOUT | 0x0000041D | The process for the service was started, but it did not call StartServiceCtrlDispatcher, or the thread that called StartServiceCtrlDispatcher may be blocked in a control handler function.
WIN32_ERROR_SHUTDOWN_IN_PROGRESS | 0x0000045B | The system is shutting down; this function cannot be called.
WIN32_NO_ERROR | 0x00000000 | No error.
Win32Service Service Flag Constants
Win32 Base Priority Classes
Öntanımlı Sabitler


Win32 Base Priority Classes

Win32 Error Codes
Örnekler
Öntanımlı Sabitler
PHP Manual
Win32 Base Priority Classes
Constant | Value | Description
WIN32_ABOVE_NORMAL_PRIORITY_CLASS | 0x00008000 | Process that has priority above WIN32_NORMAL_PRIORITY_CLASS but below WIN32_HIGH_PRIORITY_CLASS.
WIN32_BELOW_NORMAL_PRIORITY_CLASS | 0x00004000 | Process that has priority above WIN32_IDLE_PRIORITY_CLASS but below WIN32_NORMAL_PRIORITY_CLASS.
WIN32_HIGH_PRIORITY_CLASS | 0x00000080 | Process that performs time-critical tasks that must be executed immediately. The threads of the process preempt the threads of normal or idle priority class processes. An example is the Task List, which must respond quickly when called by the user, regardless of the load on the operating system. Use extreme care when using the high-priority class, because a high-priority class application can use nearly all available CPU time.
WIN32_IDLE_PRIORITY_CLASS | 0x00000040 | Process whose threads run only when the system is idle. The threads of the process are preempted by the threads of any process running in a higher priority class. An example is a screen saver. The idle-priority class is inherited by child processes.
WIN32_NORMAL_PRIORITY_CLASS | 0x00000020 | Process with no special scheduling needs.
WIN32_REALTIME_PRIORITY_CLASS | 0x00000100 | Process that has the highest possible priority. The threads of the process preempt the threads of all other processes, including operating system processes performing important tasks. For example, a real-time process that executes for more than a very brief interval can cause disk caches not to flush or cause the mouse to be unresponsive.
Win32 Error Codes
Örnekler
Öntanımlı Sabitler


Örnekler

İçindekiler

  • Bir PHP betiğinin hizmet olarak çalışacağını belirtmek
Win32 Base Priority Classes
Bir PHP betiğinin hizmet olarak çalışacağını belirtmek
win32service


Bir PHP betiğinin hizmet olarak çalışacağını belirtmek

Örnek 1 - Bir PHP betiğinin hizmet olarak çalışacağını belirtmek

<?php
win32_create_service(array(
    'service' => 'dummyphp',                 # hizmetin ismi
    'display' => 'sample dummy PHP service', # açıklama
    'params' => 'c:\path\to\script.php run', # betiğin yolu ve değiştirgeleri
));
?>

Örnek 2 - Bir hizmeti kullanımdan kaldırmak

<?php
win32_delete_service('dummyphp');
?>

Örnek 3 - Bir hizmet olarak çalıştırmak

<?php
if ($argv[1] == 'run') {
  win32_start_service_ctrl_dispatcher('dummyphp');

  while (WIN32_SERVICE_CONTROL_STOP != win32_get_last_control_message()) {
    # İşlemler burada.
    # Döngüyü yinelemeden önce 30 saniyeden fazla beklememeye çalış
  }
}
?>

Örnekler
win32service İşlevleri
Örnekler


win32service İşlevleri

İçindekiler

  • win32_continue_service — Resumes a paused service
  • win32_create_service — Hizmet yönetim veritabanında yeni bir hizmet girdisi oluşturur
  • win32_delete_service — Bir hizmet girdisini Hizmet yönetim veritabanından siler
  • win32_get_last_control_message — Hizmete gönderilmiş son denetim kodunu döndürür
  • win32_pause_service — Pauses a service
  • win32_query_service_status — Bir hizmetin durumunu sorgular
  • win32_set_service_status — Hizmet durumunu günceller
  • win32_start_service_ctrl_dispatcher — Hizmet yöneticisine ismi belirtilen hizmet gibi davranacak bir betik tanıtır
  • win32_start_service — Bir hizmeti başlatır
  • win32_stop_service — Bir hizmeti durdurur
Bir PHP betiğinin hizmet olarak çalışacağını belirtmek
win32_continue_service
win32service


Resumes a paused service

win32service İşlevleri
win32_create_service
win32service İşlevleri
PHP Manual

win32_continue_service

(PECL win32service SVN)

win32_continue_service — Resumes a paused service

Açıklama

int win32_continue_service ( string $servicename [, string $machine ] )

Resumes a paused, named service. Requires administrative privileges.

Değiştirgeler

servicename

The short name of the service.

machine

Optional machine name. If omitted, the local machine is used.

Dönen Değerler

Başarı durumunda WIN32_NO_ERROR, başarısızlık durumunda değiştirgelerle ilgili bir sorun varsa veya bir Win32 Hata Kodu sözkonusuysa FALSE döner.

Ayrıca Bakınız

  • win32_start_service() - Bir hizmeti başlatır
  • Win32 Error Codes

win32service İşlevleri
win32_create_service
win32service İşlevleri


Hizmet yönetim veritabanında yeni bir hizmet girdisi oluşturur

win32_continue_service
win32_delete_service
win32service İşlevleri
PHP Manual

win32_create_service

(PECL win32service SVN)

win32_create_service — Hizmet yönetim veritabanında yeni bir hizmet girdisi oluşturur

Açıklama

mixed win32_create_service ( array $ayrıntılar [, string $makine ] )

Hizmet yönetim veritabanında yeni bir hizmet girdisi oluşturur.

Değiştirgeler

ayrıntılar

Hizmet ayrıntıları dizisi:

service

Hizmetin kısa ismi. net komutuyla hizmeti denetlemekte kullanılacak isimdir. İsim eşsiz olmalı (aynı isimde iki hizmet olmamalı) ve mümkünse boşluk karakterleri içermemelidir.

display

Hizmetin görünen ismi. Hizmetler programcığında göreceğiniz isimdir.

user

Hizmetin aidiyetinde çalışacağı kullanıcı hesabı. Belirtilmediği takdirde hizmet LocalSystem hesabı altında çalışır. Bir kullanıcı ismi belirtilirse bir parola da belirtmek gerekir.

password

user anahtarında belirtilen kullanıcının parolası.

path

Hizmet başlatıldığında çalıştırılacak çalıştırılabilirin mutlak dosya yolu. Belirtilmediği takdirde geçerli PHP süreci kullanılır.

params

Hizmet başlatılırken komut satırına aktarılacak değiştirgeler. Bir PHP betiğini hizmet olarak çalıştıracaksanız ilk değiştirge çalıştırılacak PHP betiğinin mutlak yolu olmalıdır. Eğer betik ismi veya dosya yolu boşluk karakteri içeriyorsa PHP betiğindeki dosya yolunun tamamını çift tırnak (") karakterlerinin arasına alın.

load_order

load_order denetimi. Bu henüz tamamen desteklenmiyor.

svc_type

Hizmet türü belirtilir. Belirtilmezse öntanımlı değer: WIN32_SERVICE_WIN32_OWN_PROCESS. Ne yaptığınızdan emin değilseniz bunu değiştirmeyin.

start_type

Hizmetin nasıl başlatılması gerektiği belirtilir. Öntanımlı değer WIN32_SERVICE_AUTO_START olup hizmetin makine başlatıldığında çalıştırılacağı anlamına gelir.

error_control

Hizmet yöneticisinin hizmet ile ilgili bir sorun saptadığında ne yapacağı belirtilir. Öntanımlı değer: WIN32_SERVER_ERROR_IGNORE. Desteklenen tek değer budur.

machine

Hizmeti oluşturmak istediğiniz makinenin ismi; belirtilmesi isteğe bağlıdır. Verilmezse yerel makine ismi kullanılır.

Dönen Değerler

Başarılı olursa TRUE, aksi takdirde bir win32 hata kodu döner.

Örnekler

Örnek 1 - win32_create_service() örneği

'dummyphp' kısa isimli bir hizmet oluşturur.

<?php
$x = win32_create_service(array(
        'service' => 'dummyphp',
        'display' => 'PHP hizmeti denemesi',
        'params' => __FILE__ . ' run',
));
debug_zval_dump($x);
?>

Ayrıca Bakınız

  • win32_delete_service() - Bir hizmet girdisini Hizmet yönetim veritabanından siler

win32_continue_service
win32_delete_service
win32service İşlevleri


Bir hizmet girdisini Hizmet yönetim veritabanından siler

win32_create_service
win32_get_last_control_message
win32service İşlevleri
PHP Manual

win32_delete_service

(PECL win32service SVN)

win32_delete_service — Bir hizmet girdisini Hizmet yönetim veritabanından siler

Açıklama

int win32_delete_service ( string $hizmet [, string $makine ] )

Bir hizmet girdisini Hizmet yönetim veritabanından silmeye çalışır. Yönetici yetkileri gerekir.

Bu işlev süreci sadece silinmek üzere imler. Eğer başka bir süreç açıksa (Hizmetler programcığı gibi) silme işlemi uygulama kapanıncaya kadar ertelenir. Hizmet silinmek üzere imlenmişse silme çabaları bu süre zarfında başarısız olur ve bu isimle yeni bir hizmet oluşturma çabaları da başarısız olur.

Değiştirgeler

hizmet

Hizmetin kısa ismi.

makine

Belirtilmesi isteğe bağlıdır. Belirtilmezse yerel makine ismi kullanılır.

Dönen Değerler

Başarılı olursa TRUE, aksi takdirde bir win32 hata kodu döner.

Örnekler

Örnek 1 - win32_delete_service() örneği

dummyphp hizmetini siler.

<?php
win32_delete_service('dummyphp');
?>

win32_create_service
win32_get_last_control_message
win32service İşlevleri


Hizmete gönderilmiş son denetim kodunu döndürür

win32_delete_service
win32_pause_service
win32service İşlevleri
PHP Manual

win32_get_last_control_message

(PECL win32service SVN)

win32_get_last_control_message — Hizmete gönderilmiş son denetim kodunu döndürür

Açıklama

int win32_get_last_control_message ( void )

Bu hizmet sürecine gönderilmiş son denetim kodunu döndürür. Bir hizmet olarak çalışma sırasında sürecin durup durmadığını saptamak için bu denetimi belirli aralıklarla yapmalısınız.

Dönen Değerler

Bir denetim sabiti döner. Şunlardan biri olabilir: WIN32_SERVICE_CONTROL_CONTINUE, WIN32_SERVICE_CONTROL_INTERROGATE, WIN32_SERVICE_CONTROL_PAUSE, WIN32_SERVICE_CONTROL_STOP, WIN32_SERVICE_CONTROL_HARDWAREPROFILECHANGE, WIN32_SERVICE_CONTROL_POWEREVENT, WIN32_SERVICE_CONTROL_SESSIONCHANGE.

Ayrıca Bakınız

  • win32_start_service_ctrl_dispatcher() - Hizmet yöneticisine ismi belirtilen hizmet gibi davranacak bir betik tanıtır

win32_delete_service
win32_pause_service
win32service İşlevleri


Pauses a service

win32_get_last_control_message
win32_query_service_status
win32service İşlevleri
PHP Manual

win32_pause_service

(PECL win32service SVN)

win32_pause_service — Pauses a service

Açıklama

int win32_pause_service ( string $servicename [, string $machine ] )

Pauses a named service. Requires administrative privileges.

Değiştirgeler

servicename

The short name of the service.

machine

Optional machine name. If omitted, the local machine is used.

Dönen Değerler

Başarı durumunda WIN32_NO_ERROR, başarısızlık durumunda değiştirgelerle ilgili bir sorun varsa veya bir Win32 Hata Kodu sözkonusuysa FALSE döner.

Ayrıca Bakınız

  • win32_start_service() - Bir hizmeti başlatır
  • Win32 Error Codes

win32_get_last_control_message
win32_query_service_status
win32service İşlevleri


Bir hizmetin durumunu sorgular

win32_pause_service
win32_set_service_status
win32service İşlevleri
PHP Manual

win32_query_service_status

(PECL win32service SVN)

win32_query_service_status — Bir hizmetin durumunu sorgular

Açıklama

mixed win32_query_service_status ( string $hizmet [, string $makine ] )

Bir hizmetin mevcut durumunu sorgular ve sonucu bir dizi içinde döndürür.

Değiştirgeler

hizmet

Hizmetin kısa ismi.

makine

İsteğe bağlı olarak makine ismi. Belirtilmezse yerel makine ismi kullanılır.

Dönen Değerler

Başarısızlık durumunda FALSE, aksi takdirde aşağıdaki bilgileri içeren bir dizi döner:

ServiceType

dwServiceType.

CurrentState

dwCurrentState.

ControlsAccepted

Hizmet tarafından kabul edilen hizmet denetimleri.

Win32ExitCode

Hizmet çıkmışsa sürecin çıkış kodu.

ServiceSpecificExitCode

Hizmet bir hata koduyla çıkmışsa olay günlüğündeki hizmete özgü kod.

CheckPoint

Hizmet sonlanmışsa geçerli sınama sayısı. Bu hizmet yöneticisi tarafından kısıtlanan bir hizmet sürecini saptamak için bir kalp atışı tarzında kullanılır. Bu değer en iyi WaitHint değeriyle birlikte değerlendirilir.

WaitHint

Hizmet sonlanmışsa geçerli sınama sayısının tamamının kullanıldığını belirtmek üzere sınama sayısı. Bir süreç göstergesi oluşturmak için kullanılabilir.

ProcessId

Windows süreç kimliği. Sıfırsa süreç çalışmıyor demektir.

ServiceFlags

dwServiceFlags.

win32_pause_service
win32_set_service_status
win32service İşlevleri


Hizmet durumunu günceller

win32_query_service_status
win32_start_service_ctrl_dispatcher
win32service İşlevleri
PHP Manual

win32_set_service_status

(PECL win32service SVN)

win32_set_service_status — Hizmet durumunu günceller

Açıklama

bool win32_set_service_status ( int $durum )

Hizmet yöneticisine çalışan hizmetin durumu hakkında bilgi verir. Bu çağrı sadece çalışmakta olan hizmet süreçleri için geçerlidir.

Değiştirgeler

durum

Hizmet durum kodu. Şunlardan biri olmalıdır: WIN32_SERVICE_RUNNING, WIN32_SERVICE_STOPPED, WIN32_SERVICE_STOP_PENDING, WIN32_SERVICE_START_PENDING, WIN32_SERVICE_CONTINUE_PENDING, WIN32_SERVICE_PAUSE_PENDING, WIN32_SERVICE_PAUSED.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • win32_start_service_ctrl_dispatcher() - Hizmet yöneticisine ismi belirtilen hizmet gibi davranacak bir betik tanıtır

win32_query_service_status
win32_start_service_ctrl_dispatcher
win32service İşlevleri


Hizmet yöneticisine ismi belirtilen hizmet gibi davranacak bir betik tanıtır

win32_set_service_status
win32_start_service
win32service İşlevleri
PHP Manual

win32_start_service_ctrl_dispatcher

(PECL win32service SVN)

win32_start_service_ctrl_dispatcher — Hizmet yöneticisine ismi belirtilen hizmet gibi davranacak bir betik tanıtır

Açıklama

mixed win32_start_service_ctrl_dispatcher ( string $isim )

Bir hizmet, Hizmet yöneticisi üzerinden başlatıldığında hizmet sürecinin hizmet izleme ve iletişim oluşumlarını sağlayıp sağlamadığına bakılır. Bu işlev, hizmet yöneticisi ile düşük seviyeli iletişimi sağlamak üzere bir evre çatallayarak bu gereksinimi yerine getirir.

Hizmet başlatıldıktan sonra Hizmet yöneticisi hizmet sürecinin sonlanıp sonlanmadığını saptamak amacıyla denetimlerini sürdürür. Bu belli aralıklarla win32_get_last_control_message() çağrısı yaparak ve dönen koda bakarak sağlanır.

Değiştirgeler

isim

Hizmetin win32_create_service() tarafından tanıtılan kısa ismi.

Dönen Değerler

Başarılı olursa TRUE, aksi takdirde bir win32 hata kodu döner.

Örnekler

Örnek 1 - win32_start_service_ctrl_dispatcher() örneği

Hizmetin SCM altında çalışıp çalışmadığına bakar.

<?php
if (!win32_start_service_ctrl_dispatcher('dummyphp')) {
  die("Galiba hizmet yöneticisi altında çalışmıyorum");
}

while (WIN32_SERVICE_CONTROL_STOP != win32_get_last_control_message()) {
    # İşlemler burada.
    # Döngüyü yinelemeden önce 30 saniyeden fazla beklememeye çalış
}
?>

Ayrıca Bakınız

  • win32_get_last_control_message() - Hizmete gönderilmiş son denetim kodunu döndürür

win32_set_service_status
win32_start_service
win32service İşlevleri


Bir hizmeti başlatır

win32_start_service_ctrl_dispatcher
win32_stop_service
win32service İşlevleri
PHP Manual

win32_start_service

(PECL win32service SVN)

win32_start_service — Bir hizmeti başlatır

Açıklama

int win32_start_service ( string $hizmet [, string $makine ] )

İsmi belirtilen hizmeti çalıştırmaya çalışır. Genellikle yönetici yetkileri gerekir.

Değiştirgeler

hizmet

Hizmetin kısa ismi.

makine

İsteğe bağlı olarak makine ismi. Belirtilmezse yerel makine ismi kullanılır.

Dönen Değerler

Başarı durumunda WIN32_NO_ERROR, aksi takdirde bir win32 hata kodu döner.

Ayrıca Bakınız

  • win32_stop_service() - Bir hizmeti durdurur

win32_start_service_ctrl_dispatcher
win32_stop_service
win32service İşlevleri


Bir hizmeti durdurur

win32_start_service
XML İşleme
win32service İşlevleri
PHP Manual

win32_stop_service

(PECL win32service SVN)

win32_stop_service — Bir hizmeti durdurur

Açıklama

int win32_stop_service ( string $hizmet [, string $makine ] )

İsmi belirtilen hizmeti durdurur. Yönetici yetkileri gerektirir.

Değiştirgeler

hizmet

Hizmetin kısa ismi.

makine

Belirtilmesi isteğe bağlıdır. Belirtilmezse yerel makine ismi kullanılır.

Dönen Değerler

Başarı durumunda WIN32_NO_ERROR, aksi takdirde bir win32 hata kodu döner.

Ayrıca Bakınız

  • win32_start_service() - Bir hizmeti başlatır

win32_start_service
XML İşleme
win32service İşlevleri


XML İşleme

  • DOM — Belge Nesne Modeli
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • DOMAttr — DOMAttr sınıfı
    • DOMCharacterData — DOMCharacterData sınıfı
    • DOMComment — DOMComment sınıfı
    • DOMDocument — DOMDocument sınıfı
    • DOMDocumentFragment — DOMDocumentFragment sınıfı
    • DOMDocumentType — DOMDocumentType sınıfı
    • DOMElement — DOMElement sınıfı
    • DOMEntity — DOMEntity sınıfı
    • DOMEntityReference — DOMEntityReference sınıfı
    • DOMException — DOMException sınıfı
    • DOMImplementation — DOMImplementation sınıfı
    • DOMNamedNodeMap — DOMNamedNodeMap sınıfı
    • DOMNode — DOMNode sınıfı
    • DOMNodeList — DOMNodeList sınıfı
    • DOMNotation — DOMNotation sınıfı
    • DOMProcessingInstruction — DOMProcessingInstruction sınıfı
    • DOMText — DOMText sınıfı
    • DOMXPath — DOMXPath sınıfı
    • DOM İşlevleri
  • libxml
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • libXMLError — libXMLError sınıfı
    • libxml İşlevleri
  • SDO — Service Data Objects
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Limitations
    • Örnekler
    • SDO İşlevleri
  • SDO-DAS-Relational — SDO Relational Data Access Service
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • Limitations
    • SDO-DAS-Relational İşlevleri
  • SDO DAS XML — SDO XML Data Access Service
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • SDO DAS XML İşlevleri
  • Basit XML
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • SimpleXMLElement — SimpleXMLElement Sınıfı
    • Basit XML İşlevleri
  • WDDX
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • WDDX İşlevleri
  • XMLDiff — XML diff and merge
    • Giriş
    • Yapılandırma/Kurulum
    • XMLDiff\Base — The XMLDiff\Base class
    • XMLDiff\DOM — The XMLDiff\DOM class
    • XMLDiff\Memory — The XMLDiff\Memory class
    • XMLDiff\File — The XMLDiff\File class
  • XML Çözümleyici
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Geriçağırım İşlevleri
    • Büyük Harfe Dönüşüm
    • Hata Kodları
    • Karakter Kodlaması
    • Örnekler
    • XML Çözümleyici İşlevleri
  • XMLReader
    • Giriş
    • Yapılandırma/Kurulum
    • XMLReader — XMLReader sınıfı
  • XMLWriter
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • XMLWriter İşlevleri
  • XSL
    • Giriş
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • XSLTProcessor — XSLTProcessor sınıfı
win32_stop_service
DOM
İşlev Başvuru Kılavuzu


Belge Nesne Modeli

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • DOMAttr — DOMAttr sınıfı
    • DOMAttr::__construct — Yeni bir DOMAttr nesnesi oluşturur
    • DOMAttr::isId — Öznitelik bir ID mi tanımlıyor diye bakar
  • DOMCharacterData — DOMCharacterData sınıfı
    • DOMCharacterData::appendData — Düğümün karakter verisinin sonuna bir dizge ekler
    • DOMCharacterData::deleteData — Düğümden belirtilen alt dizgeyi siler
    • DOMCharacterData::insertData — 16 bitlik birimlerle belirtilen konuma bir dizge yerleştirir
    • DOMCharacterData::replaceData — DOMCharacterData içindeki bir alt dizgeyi değiştirir
    • DOMCharacterData::substringData — Düğümden belli miktarda veri döndürür
  • DOMComment — DOMComment sınıfı
    • DOMComment::__construct — Yeni bir DOMComment nesnesi oluşturur
  • DOMDocument — DOMDocument sınıfı
    • DOMDocument::__construct — Yeni bir DOMDocument nesnesi oluşturur
    • DOMDocument::createAttribute — Yeni bir öznitelik düğümü oluşturur
    • DOMDocument::createAttributeNS — Yeni bir isim alanlı öznitelik düğümü oluşturur
    • DOMDocument::createCDATASection — Yeni bir CDATA düğümü oluşturur
    • DOMDocument::createComment — Yeni bir açıklama düğümü oluşturur
    • DOMDocument::createDocumentFragment — Yeni bir belge bölütü oluşturur
    • DOMDocument::createElement — Yeni bir eleman düğümü oluşturur
    • DOMDocument::createElementNS — İsim alanlı bir eleman düğümü oluşturur
    • DOMDocument::createEntityReference — Yeni bir öğe bildirimi düğümü oluşturur
    • DOMDocument::createProcessingInstruction — Yeni bir işlem komutu düğümü oluşturur
    • DOMDocument::createTextNode — Yeni bir metin düğümü oluşturur
    • DOMDocument::getElementById — ID'si belirtilen elemanı döndürür
    • DOMDocument::getElementsByTagName — İsmi belirtilen tüm elemanları döndürür
    • DOMDocument::getElementsByTagNameNS — İsmi ve isim alanı belirtilen tüm elemanları döndürür
    • DOMDocument::importNode — Belgeye bir düğüm dahil eder
    • DOMDocument::load — XML belgeyi bir dosyadan yükler
    • DOMDocument::loadHTML — HTML belgeyi bir dizgeden yükler
    • DOMDocument::loadHTMLFile — HTML belgeyi bir dosyadan yükler
    • DOMDocument::loadXML — XML belgeyi bir dizgeden yükler
    • DOMDocument::normalizeDocument — Belgeyi normalleştirir
    • DOMDocument::registerNodeClass — Temel düğüm türünü oluşturmakta kullanılacak türetilmiş sınıfı belirtmek için kullanılır
    • DOMDocument::relaxNGValidate — Belgeyi belirtilen RNG dosyasıyla doğrular
    • DOMDocument::relaxNGValidateSource — Belgeyi belirtilen RNG dizgesiyle doğrular
    • DOMDocument::save — Dahili XML ağacını bir dizge olarak dosyaya yazar
    • DOMDocument::saveHTML — Dahili belgeyi bir HTML dizgesi olarak çıktılar
    • DOMDocument::saveHTMLFile — Dahili belgeyi bir HTML dizge olarak dosyaya yazar
    • DOMDocument::saveXML — Dahili XML ağacını bir dizge olarak çıktılar
    • DOMDocument::schemaValidate — Belgeyi bir şema dosyasına göre doğrular
    • DOMDocument::schemaValidateSource — Belgeyi bir şema dizgesine göre doğrular
    • DOMDocument::validate — Belgeyi DTD'sine göre doğrular
    • DOMDocument::xinclude — Bir DOMDocument nesnesindeki XInclude dosyalarını belgeye dahil eder
  • DOMDocumentFragment — DOMDocumentFragment sınıfı
    • DOMDocumentFragment::appendXML — Ham bir XML verisi ekler
  • DOMDocumentType — DOMDocumentType sınıfı
  • DOMElement — DOMElement sınıfı
    • DOMElement::__construct — Yeni bir DOMElement nesnesi oluşturur
    • DOMElement::getAttribute — İsmi belirtilen özniteliğin değerini döndürür
    • DOMElement::getAttributeNode — İsmi belirtilen öznitelik düğümünü döndürür
    • DOMElement::getAttributeNodeNS — İsmi ve isim alanı belirtilen öznitelik düğümünü döndürür
    • DOMElement::getAttributeNS — İsmi ve isim alanı belirtilen özniteliğin değerini döndürür
    • DOMElement::getElementsByTagName — İsmi belirtilen elemanları döndürür
    • DOMElement::getElementsByTagNameNS — İsmi ve isim alanı belirtilen elemanları döndürür
    • DOMElement::hasAttribute — İsmi belirtilen öznitelik mevcut mu diye bakar
    • DOMElement::hasAttributeNS — Belirtilen isim alanlı öznitelik var mı diye bakar
    • DOMElement::removeAttribute — İsmi belirtilen özniteliği siler
    • DOMElement::removeAttributeNode — Belirtilen öznitelik düğümünü siler
    • DOMElement::removeAttributeNS — İsmi ve isim alanı belirtilen özniteliği siler
    • DOMElement::setAttribute — Yeni bir öznitelik ekler
    • DOMElement::setAttributeNode — Elemana yeni bir öznitelik düğümü ekler
    • DOMElement::setAttributeNodeNS — Elemana isim alanlı yeni bir öznitelik düğümü ekler
    • DOMElement::setAttributeNS — İsim alanlı yeni bir öznitelik ekler
    • DOMElement::setIdAttribute — İsmi belirtilen özniteliği bir ID özniteliği olarak tanımlar
    • DOMElement::setIdAttributeNode — Belirtilen öznitelik düğümünü ID türünde bir öznitelik düğümü haline getirir
    • DOMElement::setIdAttributeNS — İsmi ve isim alanı belirtilen özniteliği bir ID özniteliği olarak tanımlar
  • DOMEntity — DOMEntity sınıfı
  • DOMEntityReference — DOMEntityReference sınıfı
    • DOMEntityReference::__construct — Yeni bir DOMEntityReference nesnesi oluşturur
  • DOMException — DOMException sınıfı
  • DOMImplementation — DOMImplementation sınıfı
    • DOMImplementation::__construct — Yeni bir DOMImplementation nesnesi oluşturur
    • DOMImplementation::createDocument — Belge elemanı belirtilen DOMDocument nesnesini oluşturur
    • DOMImplementation::createDocumentType — Boş bir DOMDocumentType nesnesi oluşturur
    • DOMImplementation::hasFeature — DOM gerçeklenimi belirtilen özelliğe sahip mi diye bakar
  • DOMNamedNodeMap — DOMNamedNodeMap sınıfı
    • DOMNamedNodeMap::getNamedItem — İsmi belirtilen düğümü döndürür
    • DOMNamedNodeMap::getNamedItemNS — İsmi ve isim alanı belirtilen düğümü döndürür
    • DOMNamedNodeMap::item — İndisi belirtilen düğümü döndürür
  • DOMNode — DOMNode sınıfı
    • DOMNode::appendChild — Listenin sonuna yeni bir çocuk ekler
    • DOMNode::C14N — Canonicalize nodes to a string
    • DOMNode::C14NFile — Canonicalize nodes to a file
    • DOMNode::cloneNode — Düğümün bir kopyasını yapar
    • DOMNode::getLineNo — Get line number for a node
    • DOMNode::getNodePath — Get an XPath for a node
    • DOMNode::hasAttributes — Düğümün öznitelikleri var mı diye bakar
    • DOMNode::hasChildNodes — Düğümün çocuk düğümleri var mı diye bakar
    • DOMNode::insertBefore — Yeni çocuğu belirtilen çocuğun öncesine yerleştirir
    • DOMNode::isDefaultNamespace — Belirtilen isim alanının öntanımlı olup olmadığına bakar
    • DOMNode::isSameNode — İki düğüm aynı mı diye bakar
    • DOMNode::isSupported — Özelliğin belirtilen sürümünün desteklenip desteklenmediğine bakar
    • DOMNode::lookupNamespaceURI — İsim alanı öneki belirtilen düğümün isim alanı betimleyicisini döndürür
    • DOMNode::lookupPrefix — Belirtilen isim alanıyla ilişkili düğümün isim alanı önekini döndürür
    • DOMNode::normalize — Düğümü normalleştirir
    • DOMNode::removeChild — Listeden belirtilen çocuğu siler
    • DOMNode::replaceChild — Bir çocuk düğümü yenisi ile değiştirir
  • DOMNodeList — DOMNodeList sınıfı
    • DOMNodelist::item — İndisi belirtilen düğümü döndürür
  • DOMNotation — DOMNotation sınıfı
  • DOMProcessingInstruction — DOMProcessingInstruction sınıfı
    • DOMProcessingInstruction::__construct — Yeni bir DOMProcessingInstruction nesnesi oluşturur
  • DOMText — DOMText sınıfı
    • DOMText::__construct — Yeni bir DOMText nesnesi oluşturur
    • DOMText::isWhitespaceInElementContent — Düğümün boşluk içerip içermediğini belirtir
    • DOMText::splitText — Düğümü belirtilen konumda iki düğüme böler
  • DOMXPath — DOMXPath sınıfı
    • DOMXPath::__construct — Yeni bir DOMXPath nesnesi oluşturur
    • DOMXPath::evaluate — Belirtilen XPath ifadesini çözümler ve mümkünse yazılı bir sonuç verir
    • DOMXPath::query — Belirtilen XPath ifadesini değerlendirir
    • DOMXPath::registerNamespace — Belirtilen isim alanını DOMXPath nesnesi ile ilişkilendirir
    • DOMXPath::registerPhpFunctions — Register PHP functions as XPath functions
  • DOM İşlevleri
    • dom_import_simplexml — Bir SimpleXMLElement düğümü alıp bir DOMElement düğümü döndürür
XML İşleme
Giriş
XML İşleme


Giriş

DOM eklentisi, PHP 5 ile DOM arayüzü sayesinde XML belgeler üzerinde işlem yapmayı sağlar.

PHP 4 için, DOM XML eklentisini kullanın.

Bilginize:

DOM eklentisi UTF-8 kodlama kullanır. ISO-8859-1 belgelerle çalışmak için utf8_encode() ve utf8_decode() işlevlerini, diğer karakter kodlamaları için ise iconv eklentisinin işlevlerini kullanın.

DOM
Yapılandırma/Kurulum
DOM


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
DOM


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

XML sabitleri
Sabit | Değer | Açıklama
XML_ELEMENT_NODE (integer) | 1 | Düğüm bir DOMElement nesnesidir.
XML_ATTRIBUTE_NODE (integer) | 2 | Düğüm bir DOMAttr nesnesidir.
XML_TEXT_NODE (integer) | 3 | Düğüm bir DOMText nesnesidir.
XML_CDATA_SECTION_NODE (integer) | 4 | Düğüm bir DOMCharacterData nesnesidir.
XML_ENTITY_REF_NODE (integer) | 5 | Düğüm bir DOMEntityReference nesnesidir.
XML_ENTITY_NODE (integer) | 6 | Düğüm bir DOMEntity nesnesidir.
XML_PI_NODE (integer) | 7 | Düğüm bir DOMProcessingInstruction nesnesidir.
XML_COMMENT_NODE (integer) | 8 | Düğüm bir DOMComment nesnesidir.
XML_DOCUMENT_NODE (integer) | 9 | Düğüm bir DOMDocument nesnesidir.
XML_DOCUMENT_TYPE_NODE (integer) | 10 | Düğüm bir DOMDocumentType nesnesidir.
XML_DOCUMENT_FRAG_NODE (integer) | 11 | Düğüm bir DOMDocumentFragment nesnesidir.
XML_NOTATION_NODE (integer) | 12 | Düğüm bir DOMNotation nesnesidir.
XML_HTML_DOCUMENT_NODE (integer) | 13 |
XML_DTD_NODE (integer) | 14 |
XML_ELEMENT_DECL_NODE (integer) | 15 |
XML_ATTRIBUTE_DECL_NODE (integer) | 16 |
XML_ENTITY_DECL_NODE (integer) | 17 |
XML_NAMESPACE_DECL_NODE (integer) | 18 |
XML_ATTRIBUTE_CDATA (integer) | 1 |
XML_ATTRIBUTE_ID (integer) | 2 |
XML_ATTRIBUTE_IDREF (integer) | 3 |
XML_ATTRIBUTE_IDREFS (integer) | 4 |
XML_ATTRIBUTE_ENTITY (integer) | 5 |
XML_ATTRIBUTE_NMTOKEN (integer) | 7 |
XML_ATTRIBUTE_NMTOKENS (integer) | 8 |
XML_ATTRIBUTE_ENUMERATION (integer) | 9 |
XML_ATTRIBUTE_NOTATION (integer) | 10 |
DOMException sabitleri
Sabit | Değer | Açıklama
DOM_PHP_ERR (integer) | 0 | Hata kodu DOM belirtiminin bir parçası dağil, PHP'nin bir parçasıdır.
DOM_INDEX_SIZE_ERR (integer) | 1 | İndis veya boyut ya negatiftir ya da izin verilenden büyüktür.
DOMSTRING_SIZE_ERR (integer) | 2 | Belirtilen metnin boyutu DOMString nesnesine sığmıyordur.
DOM_HIERARCHY_REQUEST_ERR (integer) | 3 | Yerleştirilen düğüm oraya uygun değildir.
DOM_WRONG_DOCUMENT_ERR (integer) | 4 | Düğüm oluşturulduğu belgede değil başka bir belgede kullanılmıştır.
DOM_INVALID_CHARACTER_ERR (integer) | 5 | İsim gibi bir yerde geçersiz veya kuraldışı bir karakter belirtilmiştir.
DOM_NO_DATA_ALLOWED_ERR (integer) | 6 | Düğüm belirtilen veriyi desteklemiyordur.
DOM_NO_MODIFICATION_ALLOWED_ERR (integer) | 7 | Değişikliğe izin verilmeyen bir nesnede değişiklik yapılmaya çalışılmıştır.
DOM_NOT_FOUND_ERR (integer) | 8 | Bağlamda mevcut olmayan bir düğüme gönderim yapılmaya çalışılmıştır.
DOM_NOT_SUPPORTED_ERR (integer) | 9 | Gerçeklenim istenen nesne türünü veya işlemi desteklemiyordur.
DOM_INUSE_ATTRIBUTE_ERR (integer) | 10 | Başka bir yerde zaten kullanılmış bir öznitelik eklenmeye çalışılmıştır.
DOM_INVALID_STATE_ERR (integer) | 11 | Olmayan veya artık kullanılmayan bir nesne kullanılmaya çalışılmıştır.
DOM_SYNTAX_ERR (integer) | 12 | Geçersiz veya kuraldışı bir dizge belirtilmeye çalışılmıştır.
DOM_INVALID_MODIFICATION_ERR (integer) | 13 | İlgili nesne türü değiştirilmeye çalışılmıştır.
DOM_NAMESPACE_ERR (integer) | 14 | İsim alanına göre yanlış bir yoldan bir nesne oluşturulmaya veya değiştirilmeye çalışılmıştır.
DOM_INVALID_ACCESS_ERR (integer) | 15 | Bir değiştirge veya işlem ilgili nesne tarafından desteklenmiyordur.
DOM_VALIDATION_ERR (integer) | 16 | insertBefore veya removeChild gibi bir çağrı ile düğüm, kısmi doğruluk bakımından geçersizleştirilmeye çalışılmıştır. Bu istisna oluştuğunda işlem yapılmaz.
Özkaynak Türleri
DOMAttr
DOM


DOMAttr sınıfı

(PHP 5, PHP 7)

Giriş

Bir DOMAttr nesnesi, bir DOMElement nesnesindeki bir özniteliği temsil eder.

Sınıf Sözdizimi

DOMAttr extends DOMNode {
/* Özellikler */
public readonly string $name ;
public readonly DOMElement $ownerElement ;
public readonly bool $schemaTypeInfo ;
public readonly bool $specified ;
public string $value ;
/* Yöntemler */
__construct ( string $isim [, string $değer ] )
bool isId ( void )
/* Miras alınan yöntemler */
DOMNode DOMNode::appendChild ( DOMNode $yeni )
public string DOMNode::C14N ([ bool $exclusive [, bool $with_comments [, array $xpath [, array $ns_prefixes ]]]] )
public int DOMNode::C14NFile ( string $uri [, bool $exclusive [, bool $with_comments [, array $xpath [, array $ns_prefixes ]]]] )
DOMNode DOMNode::cloneNode ([ bool $torunlar_dahil = TRUE ] )
public int DOMNode::getLineNo ( void )
public string DOMNode::getNodePath ( void )
bool DOMNode::hasAttributes ( void )
bool DOMNode::hasChildNodes ( void )
DOMNode DOMNode::insertBefore ( DOMNode $yeni [, DOMNode $mevcut ] )
bool DOMNode::isDefaultNamespace ( string $uri )
bool DOMNode::isSameNode ( DOMNode $düğüm )
bool DOMNode::isSupported ( string $özellik , string $sürüm )
string DOMNode::lookupNamespaceURI ( string $önek )
string DOMNode::lookupPrefix ( string $uri )
void DOMNode::normalize ( void )
DOMNode DOMNode::removeChild ( DOMNode $eski )
DOMNode DOMNode::replaceChild ( DOMNode $yeni , DOMNode $eski )
}

Özellikler

name

Özniteliğin ismi.

ownerElement

Özniteliği içeren eleman.

schemaTypeInfo

Henüz gerçeklenmemiştir, daima NULL'dur.

specified

Henüz gerçeklenmemiştir, daima NULL'dur.

value

Özniteliğin değeri.

Ayrıca Bakınız

  • » Attr arayüzünün W3C belirtimi

İçindekiler

  • DOMAttr::__construct — Yeni bir DOMAttr nesnesi oluşturur
  • DOMAttr::isId — Öznitelik bir ID mi tanımlıyor diye bakar
Öntanımlı Sabitler
DOMAttr::__construct
DOM


Yeni bir DOMAttr nesnesi oluşturur

DOMAttr
DOMAttr::isId
DOMAttr
PHP Manual

DOMAttr::__construct

(PHP 5, PHP 7)

DOMAttr::__construct — Yeni bir DOMAttr nesnesi oluşturur

Açıklama

DOMAttr::__construct ( string $isim [, string $değer ] )

Yeni bir DOMAttr nesnesi oluşturur. Nesne bu haliyle bir belgeye eklenebilir, fakat belge ile ilişkilendirilinceye kadar yeni bir düğüm eklenemez. Yazılabilir bir düğüm oluşturmak için DOMDocument::createAttribute() yöntemini kullanın.

Değiştirgeler

isim

Özniteliğin ismi.

değer

Özniteliğin değeri.

Örnekler

Örnek 1 - Yeni bir DOMAttr oluşturmak

<?php

$dom = new DOMDocument('1.0', 'utf-8');
$element = $dom->appendChild(new DOMElement('root'));
$attr = $element->setAttributeNode(new DOMAttr('attr', 'attrvalue'));
echo $dom->saveXML();

?>

Yukarıdaki örneğin çıktısı:

<?xml version="1.0" encoding="iso-8859-1"?>
<root attr="attrvalue" />

Ayrıca Bakınız

  • DOMDocument::createAttribute() - Yeni bir öznitelik düğümü oluşturur

DOMAttr
DOMAttr::isId
DOMAttr


Öznitelik bir ID mi tanımlıyor diye bakar

DOMAttr::__construct
DOMCharacterData
DOMAttr
PHP Manual

DOMAttr::isId

(PHP 5, PHP 7)

DOMAttr::isId — Öznitelik bir ID mi tanımlıyor diye bakar

Açıklama

bool DOMAttr::isId ( void )

Öznitelik bir ID tanımlıyorsa TRUE döner.

DOM standardı gereği, ID özniteliğini ID türünde tanımlayan bir DTD olmalıdır. Bu işlevi kullanmadan önce belgenizi DOMDocument::validate() veya DOMDocument ::validateOnParse ile doğrulamanız gerekir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - DOMAttr::isId() örneği

<?php

$doc = new DomDocument;

// Belgemizi önce doğrulamalıyız
$doc->validateOnParse = true;
$doc->Load('book.xml');

// chapter elemanının id özniteliğini öğrenelim
$attr = $doc->getElementsByTagName('chapter')->item(0)->getAttributeNode('id');

var_dump($attr->isId()); // bool(true)

?>

DOMAttr::__construct
DOMCharacterData
DOMAttr


DOMCharacterData sınıfı

(PHP 5, PHP 7)

Giriş

Karakter verisi içeren düğümleri temsil eder. Bu sınıfa karşılık gelen hiçbir düğüm yoktur, ancak diğer düğümlerce miras alınır.

Sınıf Sözdizimi

DOMCharacterData extends DOMNode {
/* Özellikler */
public string $data ;
readonly public int $length ;
/* Yöntemler */
void appendData ( string $veri )
void deleteData ( int $başlangıç , int $uzunluk )
void insertData ( int $başlangıç , string $veri )
void replaceData ( int $başlangıç , int $uzunluk , string $veri )
string substringData ( int $başlangıç , int $uzunluk )
/* Miras alınan yöntemler */
DOMNode DOMNode::appendChild ( DOMNode $yeni )
public string DOMNode::C14N ([ bool $exclusive [, bool $with_comments [, array $xpath [, array $ns_prefixes ]]]] )
public int DOMNode::C14NFile ( string $uri [, bool $exclusive [, bool $with_comments [, array $xpath [, array $ns_prefixes ]]]] )
DOMNode DOMNode::cloneNode ([ bool $torunlar_dahil = TRUE ] )
public int DOMNode::getLineNo ( void )
public string DOMNode::getNodePath ( void )
bool DOMNode::hasAttributes ( void )
bool DOMNode::hasChildNodes ( void )
DOMNode DOMNode::insertBefore ( DOMNode $yeni [, DOMNode $mevcut ] )
bool DOMNode::isDefaultNamespace ( string $uri )
bool DOMNode::isSameNode ( DOMNode $düğüm )
bool DOMNode::isSupported ( string $özellik , string $sürüm )
string DOMNode::lookupNamespaceURI ( string $önek )
string DOMNode::lookupPrefix ( string $uri )
void DOMNode::normalize ( void )
DOMNode DOMNode::removeChild ( DOMNode $eski )
DOMNode DOMNode::replaceChild ( DOMNode $yeni , DOMNode $eski )
}

Özellikler

data

Düğüm içeriği.

length

İçerek uzunluğu.

Ayrıca Bakınız

  • » CharacterData arayüzünün W3C belirtimi

İçindekiler

  • DOMCharacterData::appendData — Düğümün karakter verisinin sonuna bir dizge ekler
  • DOMCharacterData::deleteData — Düğümden belirtilen alt dizgeyi siler
  • DOMCharacterData::insertData — 16 bitlik birimlerle belirtilen konuma bir dizge yerleştirir
  • DOMCharacterData::replaceData — DOMCharacterData içindeki bir alt dizgeyi değiştirir
  • DOMCharacterData::substringData — Düğümden belli miktarda veri döndürür
DOMAttr::isId
DOMCharacterData::appendData
DOM


Düğümün karakter verisinin sonuna bir dizge ekler

DOMCharacterData
DOMCharacterData::deleteData
DOMCharacterData
PHP Manual

DOMCharacterData::appendData

(PHP 5, PHP 7)

DOMCharacterData::appendData — Düğümün karakter verisinin sonuna bir dizge ekler

Açıklama

void DOMCharacterData::appendData ( string $veri )

Düğümün karakter verisinin sonuna veri dizgesini ekler.

Değiştirgeler

veri

Eklenecek dizge.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • DOMCharacterData::deleteData() - Düğümden belirtilen alt dizgeyi siler
  • DOMCharacterData::insertData() - 16 bitlik birimlerle belirtilen konuma bir dizge yerleştirir
  • DOMCharacterData::replaceData() - DOMCharacterData içindeki bir alt dizgeyi değiştirir
  • DOMCharacterData::substringData() - Düğümden belli miktarda veri döndürür

DOMCharacterData
DOMCharacterData::deleteData
DOMCharacterData


Düğümden belirtilen alt dizgeyi siler

DOMCharacterData::appendData
DOMCharacterData::insertData
DOMCharacterData
PHP Manual

DOMCharacterData::deleteData

(PHP 5, PHP 7)

DOMCharacterData::deleteData — Düğümden belirtilen alt dizgeyi siler

Açıklama

void DOMCharacterData::deleteData ( int $başlangıç , int $uzunluk )

Düğümden başlangıç karakterinden başlayan uzunluk karakterlik alt dizgeyi siler.

Değiştirgeler

başlangıç

Silinecek alt dizgenin başlangıcı.

uzunluk

Silinecek karakter sayısı. başlangıç + uzunluk toplamı dizge uzunluğunu aşarsa verinin sonundaki tüm karakterler silinir.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

DOM_INDEX_SIZE_ERR

başlangıç veya uzunluk negatifse veya başlangıç verideki 16 bitlik birimlerin sayısından büyükse bu hata oluşur.

Ayrıca Bakınız

  • DOMCharacterData::appendData() - Düğümün karakter verisinin sonuna bir dizge ekler
  • DOMCharacterData::insertData() - 16 bitlik birimlerle belirtilen konuma bir dizge yerleştirir
  • DOMCharacterData::replaceData() - DOMCharacterData içindeki bir alt dizgeyi değiştirir
  • DOMCharacterData::substringData() - Düğümden belli miktarda veri döndürür

DOMCharacterData::appendData
DOMCharacterData::insertData
DOMCharacterData


16 bitlik birimlerle belirtilen konuma bir dizge yerleştirir

DOMCharacterData::deleteData
DOMCharacterData::replaceData
DOMCharacterData
PHP Manual

DOMCharacterData::insertData

(PHP 5, PHP 7)

DOMCharacterData::insertData — 16 bitlik birimlerle belirtilen konuma bir dizge yerleştirir

Açıklama

void DOMCharacterData::insertData ( int $başlangıç , string $veri )

veri alt dizgesini başlangıç konumundan itibaren dizgeye yerleştirir.

Değiştirgeler

başlangıç

veri dizgesinin yerleştirileceği konum.

veri

Yerleştirilecek alt dizge.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

DOM_INDEX_SIZE_ERR

başlangıç negatifse veya 16 bitlik birimlerle veriden uzunsa bu hata oluşur.

Ayrıca Bakınız

  • DOMCharacterData::appendData() - Düğümün karakter verisinin sonuna bir dizge ekler
  • DOMCharacterData::deleteData() - Düğümden belirtilen alt dizgeyi siler
  • DOMCharacterData::replaceData() - DOMCharacterData içindeki bir alt dizgeyi değiştirir
  • DOMCharacterData::substringData() - Düğümden belli miktarda veri döndürür

DOMCharacterData::deleteData
DOMCharacterData::replaceData
DOMCharacterData


DOMCharacterData içindeki bir alt dizgeyi değiştirir

DOMCharacterData::insertData
DOMCharacterData::substringData
DOMCharacterData
PHP Manual

DOMCharacterData::replaceData

(PHP 5, PHP 7)

DOMCharacterData::replaceData — DOMCharacterData içindeki bir alt dizgeyi değiştirir

Açıklama

void DOMCharacterData::replaceData ( int $başlangıç , int $uzunluk , string $veri )

başlangıç konumundan itibaren uzunluk karakterlik alt dizgenin yerine veri dizgesini yerleştirir.

Değiştirgeler

başlangıç

Değiştirilecek alt dizgenin başlangıç konumu.

uzunluk

Değiştirilecek alt dizgenin karakter sayısı. başlangıç + uzunluk toplamı dizgenin toplam uzunluğunu aşarsa verinin sonundaki tüm karakterler değiştirilir.

veri

Değiştirilecek alt dizgenin yerini alacak dizge.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

DOM_INDEX_SIZE_ERR

başlangıç veya uzunluk negatifse veya başlangıç verideki 16 bitlik birimlerin sayısından büyükse bu hata oluşur.

Ayrıca Bakınız

  • DOMCharacterData::appendData() - Düğümün karakter verisinin sonuna bir dizge ekler
  • DOMCharacterData::deleteData() - Düğümden belirtilen alt dizgeyi siler
  • DOMCharacterData::insertData() - 16 bitlik birimlerle belirtilen konuma bir dizge yerleştirir
  • DOMCharacterData::substringData() - Düğümden belli miktarda veri döndürür

DOMCharacterData::insertData
DOMCharacterData::substringData
DOMCharacterData


Düğümden belli miktarda veri döndürür

DOMCharacterData::replaceData
DOMComment
DOMCharacterData
PHP Manual

DOMCharacterData::substringData

(PHP 5, PHP 7)

DOMCharacterData::substringData — Düğümden belli miktarda veri döndürür

Açıklama

string DOMCharacterData::substringData ( int $başlangıç , int $uzunluk )

Belirtilen alt dizgeyi döndürür.

Değiştirgeler

başlangıç

Döndürülecek alt dizgenin başlangıç konumu.

uzunluk

Döndürülecek alt dizgenin karakter sayısı.

Dönen Değerler

Belirtilen alt dizgeyi döndürür. Eğer başlangıç + uzunluk toplamı dizge uzunluğunu aşarsa verinin sonundaki 16 bitlik birimlerin tamamı döndürülür.

Hatalar/İstisnalar

DOM_INDEX_SIZE_ERR

başlangıç veya uzunluk negatifse veya başlangıç verideki 16 bitlik birimlerin sayısından büyükse bu hata oluşur.

Ayrıca Bakınız

  • DOMCharacterData::appendData() - Düğümün karakter verisinin sonuna bir dizge ekler
  • DOMCharacterData::deleteData() - Düğümden belirtilen alt dizgeyi siler
  • DOMCharacterData::insertData() - 16 bitlik birimlerle belirtilen konuma bir dizge yerleştirir
  • DOMCharacterData::replaceData() - DOMCharacterData içindeki bir alt dizgeyi değiştirir

DOMCharacterData::replaceData
DOMComment
DOMCharacterData


DOMComment sınıfı

(PHP 5, PHP 7)

Giriş

<!-- ve --> karakterleri ile sınırlanan bölgedeki karakterlerden oluşan açıklama düğümlerini temsil eder.

Sınıf Sözdizimi

DOMComment extends DOMCharacterData {
/* Yöntemler */
__construct ([ string $değer ] )
/* Miras alınan yöntemler */
void DOMCharacterData::appendData ( string $veri )
void DOMCharacterData::deleteData ( int $başlangıç , int $uzunluk )
void DOMCharacterData::insertData ( int $başlangıç , string $veri )
void DOMCharacterData::replaceData ( int $başlangıç , int $uzunluk , string $veri )
string DOMCharacterData::substringData ( int $başlangıç , int $uzunluk )
DOMNode DOMNode::appendChild ( DOMNode $yeni )
public string DOMNode::C14N ([ bool $exclusive [, bool $with_comments [, array $xpath [, array $ns_prefixes ]]]] )
public int DOMNode::C14NFile ( string $uri [, bool $exclusive [, bool $with_comments [, array $xpath [, array $ns_prefixes ]]]] )
DOMNode DOMNode::cloneNode ([ bool $torunlar_dahil = TRUE ] )
public int DOMNode::getLineNo ( void )
public string DOMNode::getNodePath ( void )
bool DOMNode::hasAttributes ( void )
bool DOMNode::hasChildNodes ( void )
DOMNode DOMNode::insertBefore ( DOMNode $yeni [, DOMNode $mevcut ] )
bool DOMNode::isDefaultNamespace ( string $uri )
bool DOMNode::isSameNode ( DOMNode $düğüm )
bool DOMNode::isSupported ( string $özellik , string $sürüm )
string DOMNode::lookupNamespaceURI ( string $önek )
string DOMNode::lookupPrefix ( string $uri )
void DOMNode::normalize ( void )
DOMNode DOMNode::removeChild ( DOMNode $eski )
DOMNode DOMNode::replaceChild ( DOMNode $yeni , DOMNode $eski )
}

Ayrıca Bakınız

  • » Comment arayüzünün W3C belirtimi

İçindekiler

  • DOMComment::__construct — Yeni bir DOMComment nesnesi oluşturur
DOMCharacterData::substringData
DOMComment::__construct
DOM


Yeni bir DOMComment nesnesi oluşturur

DOMComment
DOMDocument
DOMComment
PHP Manual

DOMComment::__construct

(PHP 5, PHP 7)

DOMComment::__construct — Yeni bir DOMComment nesnesi oluşturur

Açıklama

__construct ([ string $değer ] )

Yeni bir DOMComment nesnesi oluşturur. Nesne bu haliyle bir belgeye eklenebilir, fakat belge ile ilişkilendirilinceye kadar yeni bir düğüm eklenemez. Yazılabilir bir düğüm oluşturmak için DOMDocument::createComment() yöntemini kullanın.

Değiştirgeler

değer

Açıklama dizgesi.

Örnekler

Örnek 1 - Yeni bir DOMComment oluşturmak

<?php

$dom = new DOMDocument('1.0', 'utf-8');
$element = $dom->appendChild(new DOMElement('root'));
$comment = $element->appendChild(new DOMComment('bir açıklama'));
echo $dom->saveXML();

?>

Yukarıdaki örneğin çıktısı:

<?xml version="1.0" encoding="iso-8859-1"?>
<root><!-- bir açıklama --></root>

Ayrıca Bakınız

  • DOMDocument::createComment() - Yeni bir açıklama düğümü oluşturur

DOMComment
DOMDocument
DOMComment


DOMDocument sınıfı

(PHP 5, PHP 7)

Giriş

Bir HTML veya XML belgeyi temsil eder ve belgeyi belge ağacının kökü olarak sunar.

Sınıf Sözdizimi

DOMDocument extends DOMNode {
/* Özellikler */
readonly public string $actualEncoding ;
readonly public DOMConfiguration $config ;
readonly public DOMDocumentType $doctype ;
readonly public DOMElement $documentElement ;
public string $documentURI ;
public string $encoding ;
public bool $formatOutput ;
readonly public DOMImplementation $implementation ;
public bool $preserveWhiteSpace = true ;
public bool $recover ;
public bool $resolveExternals ;
public bool $standalone ;
public bool $strictErrorChecking = true ;
public bool $substituteEntities ;
public bool $validateOnParse = false ;
public string $version ;
readonly public string $xmlEncoding ;
public bool $xmlStandalone ;
public string $xmlVersion ;
/* Yöntemler */
__construct ([ string $sürüm [, string $kodlama ]] )
DOMAttr createAttribute ( string $isim )
DOMAttr createAttributeNS ( string $uri , string $önekliAd )
DOMCDATASection createCDATASection ( string $veri )
DOMComment createComment ( string $veri )
DOMDocumentFragment createDocumentFragment ( void )
DOMElement createElement ( string $isim [, string $değer ] )
DOMElement createElementNS ( string $uri , string $önekliAd [, string $değer ] )
DOMEntityReference createEntityReference ( string $isim )
DOMProcessingInstruction createProcessingInstruction ( string $hedef [, string $veri ] )
DOMText createTextNode ( string $içerik )
DOMElement getElementById ( string $id )
DOMNodeList getElementsByTagName ( string $isim )
DOMNodeList getElementsByTagNameNS ( string $uri , string $isim )
DOMNode importNode ( DOMNode $düğüm [, bool $içiçe ] )
mixed load ( string $dosya [, int $seçenekler = 0 ] )
bool loadHTML ( string $dizge )
bool loadHTMLFile ( string $dosya )
mixed loadXML ( string $dizge [, int $seçenekler = 0 ] )
void normalizeDocument ( void )
bool registerNodeClass ( string $temelSınıf , string $türetilenSınıf )
bool relaxNGValidate ( string $dosya )
bool relaxNGValidateSource ( string $rng )
int save ( string $dosya [, int $seçenekler ] )
string saveHTML ( void )
int saveHTMLFile ( string $dosya )
string saveXML ([ DOMNode $düğüm [, int $seçenekler ]] )
bool schemaValidate ( string $dosya )
bool schemaValidateSource ( string $şema )
bool validate ( void )
int xinclude ([ int $seçenekler ] )
/* Miras alınan yöntemler */
DOMNode DOMNode::appendChild ( DOMNode $yeni )
public string DOMNode::C14N ([ bool $exclusive [, bool $with_comments [, array $xpath [, array $ns_prefixes ]]]] )
public int DOMNode::C14NFile ( string $uri [, bool $exclusive [, bool $with_comments [, array $xpath [, array $ns_prefixes ]]]] )
DOMNode DOMNode::cloneNode ([ bool $torunlar_dahil = TRUE ] )
public int DOMNode::getLineNo ( void )
public string DOMNode::getNodePath ( void )
bool DOMNode::hasAttributes ( void )
bool DOMNode::hasChildNodes ( void )
DOMNode DOMNode::insertBefore ( DOMNode $yeni [, DOMNode $mevcut ] )
bool DOMNode::isDefaultNamespace ( string $uri )
bool DOMNode::isSameNode ( DOMNode $düğüm )
bool DOMNode::isSupported ( string $özellik , string $sürüm )
string DOMNode::lookupNamespaceURI ( string $önek )
string DOMNode::lookupPrefix ( string $uri )
void DOMNode::normalize ( void )
DOMNode DOMNode::removeChild ( DOMNode $eski )
DOMNode DOMNode::replaceChild ( DOMNode $yeni , DOMNode $eski )
}

Özellikler

actualEncoding

Kullanımı önerilmiyor. encoding özelliğinin salt okunur eşdeğeri olarak belgenin asıl kodlaması.

config

Kullanımı önerilmiyor. DOMDocument::normalizeDocument() çağrıldığında kullanılan yapılandırma.

doctype

Bu belgenin Belge Türü Bildirimi.

documentElement

Belgenin belge elemanı çocuğuna doğrudan erişmeyi sağlayan öznitelik.

documentURI

Belgenin bulunduğu yer; tanımlanmamışsa NULL'dur.

encoding

Belgenin XMl bildiriminde belirtilen karakter kodlaması. Bu öznitelik 3. seviye DOM belirtiminin son sürümünde yoktur, ancak bu gerçeklenimin XML belge kodlamasını bir yerde belirtmesi gerekiyordu ve tek yol buydu.

formatOutput

Çıktı, girintiler ve ek boşluklarla daha hoş biçemlenir.

implementation

Belgenin elde edilmesinde kullanılan DOMImplementation nesnesi.

preserveWhiteSpace

Fazladan boşluklar silinmez. Öntanımlı değer: TRUE.

recover

Tescilli. Kurtarma kipini etkin kılar. Yani, iyi biçemli olmayan belgeler de çözümlenmeye çalışılır. Bu öznitelik DOM belirtiminin bir parçası değildir; libxml'e özgüdür.

resolveExternals

Bir belge türü bildirimindeki harici öğeleri yüklemek için TRUE atayın. Karakter öğelerini XML belgeye dahil etmek için yararlıdır.

standalone

Kullanımı önerilmiyor. XML bildiriminde belirtildiği gibi, belgenin tek bir belgeden oluşup oluşmadığını belirtir. xmlStandalone özniteliğine karşılıktır.

strictErrorChecking

Hata durumunda DOMException oluşur. Öntanımlı değer: TRUE.

substituteEntities

Tescilli. Öğelerin yerine konup konmayacağı. Bu öznitelik DOM belirtiminin bir parçası değildir; libxml'e özgüdür.

validateOnParse

Belge DTD'ye uygun olarak doğrulanır ve yüklenir. Öntanımlı değer: FALSE.

version

Kullanımı önerilmiyor. xmlVersion özelliğinin karşılığı olarak XML sürümü.

xmlEncoding

Belgenin karakter kodlaması olarak, XML bildiriminde belirtilen karakter kodlaması. Belgede belirtilmediğinde veya bilinmediğinde (örneğin, belge bellekte oluşturulmuşssa) değeri NULL'dur.

xmlStandalone

XML bildiriminde belirtildiği gibi, belgenin tek bir belgeden oluşup oluşmadığını belirtir. Belgede belirtilmemişse değeri NULL'dur.

xmlVersion

XML bildiriminde belirtildiği gibi, belgenin XML sürümü. Hiçbir bildirim yoksa ve belge XML'i destekliyorsa değer: "1.0".

Ayrıca Bakınız

  • » Document arayüzünün W3C belirtimi

İçindekiler

  • DOMDocument::__construct — Yeni bir DOMDocument nesnesi oluşturur
  • DOMDocument::createAttribute — Yeni bir öznitelik düğümü oluşturur
  • DOMDocument::createAttributeNS — Yeni bir isim alanlı öznitelik düğümü oluşturur
  • DOMDocument::createCDATASection — Yeni bir CDATA düğümü oluşturur
  • DOMDocument::createComment — Yeni bir açıklama düğümü oluşturur
  • DOMDocument::createDocumentFragment — Yeni bir belge bölütü oluşturur
  • DOMDocument::createElement — Yeni bir eleman düğümü oluşturur
  • DOMDocument::createElementNS — İsim alanlı bir eleman düğümü oluşturur
  • DOMDocument::createEntityReference — Yeni bir öğe bildirimi düğümü oluşturur
  • DOMDocument::createProcessingInstruction — Yeni bir işlem komutu düğümü oluşturur
  • DOMDocument::createTextNode — Yeni bir metin düğümü oluşturur
  • DOMDocument::getElementById — ID'si belirtilen elemanı döndürür
  • DOMDocument::getElementsByTagName — İsmi belirtilen tüm elemanları döndürür
  • DOMDocument::getElementsByTagNameNS — İsmi ve isim alanı belirtilen tüm elemanları döndürür
  • DOMDocument::importNode — Belgeye bir düğüm dahil eder
  • DOMDocument::load — XML belgeyi bir dosyadan yükler
  • DOMDocument::loadHTML — HTML belgeyi bir dizgeden yükler
  • DOMDocument::loadHTMLFile — HTML belgeyi bir dosyadan yükler
  • DOMDocument::loadXML — XML belgeyi bir dizgeden yükler
  • DOMDocument::normalizeDocument — Belgeyi normalleştirir
  • DOMDocument::registerNodeClass — Temel düğüm türünü oluşturmakta kullanılacak türetilmiş sınıfı belirtmek için kullanılır
  • DOMDocument::relaxNGValidate — Belgeyi belirtilen RNG dosyasıyla doğrular
  • DOMDocument::relaxNGValidateSource — Belgeyi belirtilen RNG dizgesiyle doğrular
  • DOMDocument::save — Dahili XML ağacını bir dizge olarak dosyaya yazar
  • DOMDocument::saveHTML — Dahili belgeyi bir HTML dizgesi olarak çıktılar
  • DOMDocument::saveHTMLFile — Dahili belgeyi bir HTML dizge olarak dosyaya yazar
  • DOMDocument::saveXML — Dahili XML ağacını bir dizge olarak çıktılar
  • DOMDocument::schemaValidate — Belgeyi bir şema dosyasına göre doğrular
  • DOMDocument::schemaValidateSource — Belgeyi bir şema dizgesine göre doğrular
  • DOMDocument::validate — Belgeyi DTD'sine göre doğrular
  • DOMDocument::xinclude — Bir DOMDocument nesnesindeki XInclude dosyalarını belgeye dahil eder
DOMComment::__construct
DOMDocument::__construct
DOM


Yeni bir DOMDocument nesnesi oluşturur

DOMDocument
DOMDocument::createAttribute
DOMDocument
PHP Manual

DOMDocument::__construct

(PHP 5, PHP 7)

DOMDocument::__construct — Yeni bir DOMDocument nesnesi oluşturur

Açıklama

DOMDocument::__construct ([ string $sürüm [, string $kodlama ]] )

Yeni bir DOMDocument nesnesi oluşturur.

Değiştirgeler

sürüm

XML bildiriminin 'version' özniteliğinin değeri.

kodlama

XML bildiriminin 'encoding' özniteliğinin değeri.

Örnekler

Örnek 1 - Yeni bir DOMDocument oluşturmak

<?php

$dom = new DOMDocument('1.0', 'utf-8');

echo $dom->saveXML(); /* <?xml version="1.0" encoding="utf-8"?> */

?>

Ayrıca Bakınız

  • DOMImplementation::createDocument() - Belge elemanı belirtilen DOMDocument nesnesini oluşturur

DOMDocument
DOMDocument::createAttribute
DOMDocument


Yeni bir öznitelik düğümü oluşturur

DOMDocument::__construct
DOMDocument::createAttributeNS
DOMDocument
PHP Manual

DOMDocument::createAttribute

(PHP 5, PHP 7)

DOMDocument::createAttribute — Yeni bir öznitelik düğümü oluşturur

Açıklama

DOMAttr DOMDocument::createAttribute ( string $isim )

Yeni bir DOMAttr nesnesi oluşturur. Bu düğüm, DomNode::append_child() gibi bir yöntemle belgeye yerleştirilmedikçe belgede gösterilmez.

Değiştirgeler

isim

Özniteliğin ismi.

Dönen Değerler

Bir hata oluşursa FALSE yoksa yeni bir DOMAttr nesnesi döner.

Hatalar/İstisnalar

DOM_INVALID_CHARACTER_ERR

isim geçersiz karakter içeriyorsa oluşur.

Ayrıca Bakınız

  • DOMNode::appendChild() - Listenin sonuna yeni bir çocuk ekler
  • DOMDocument::createAttributeNS() - Yeni bir isim alanlı öznitelik düğümü oluşturur
  • DOMDocument::createCDATASection() - Yeni bir CDATA düğümü oluşturur
  • DOMDocument::createComment() - Yeni bir açıklama düğümü oluşturur
  • DOMDocument::createDocumentFragment() - Yeni bir belge bölütü oluşturur
  • DOMDocument::createElement() - Yeni bir eleman düğümü oluşturur
  • DOMDocument::createElementNS() - İsim alanlı bir eleman düğümü oluşturur
  • DOMDocument::createEntityReference() - Yeni bir öğe bildirimi düğümü oluşturur
  • DOMDocument::createProcessingInstruction() - Yeni bir işlem komutu düğümü oluşturur
  • DOMDocument::createTextNode() - Yeni bir metin düğümü oluşturur

DOMDocument::__construct
DOMDocument::createAttributeNS
DOMDocument


Yeni bir isim alanlı öznitelik düğümü oluşturur

DOMDocument::createAttribute
DOMDocument::createCDATASection
DOMDocument
PHP Manual

DOMDocument::createAttributeNS

(PHP 5, PHP 7)

DOMDocument::createAttributeNS — Yeni bir isim alanlı öznitelik düğümü oluşturur

Açıklama

DOMAttr DOMDocument::createAttributeNS ( string $uri , string $önekliAd )

Yeni bir DOMAttr nesnesi oluşturur. Bu düğüm, DomNode::append_child() gibi bir yöntemle belgeye yerleştirilmedikçe belgede gösterilmez.

Değiştirgeler

uri

İsim alanını betimleyen adres.

önekliAd

önek:öznitelik biçeminde etiket ismi.

Dönen Değerler

Bir hata oluşursa FALSE yoksa yeni bir DOMAttr nesnesi döner.

Hatalar/İstisnalar

DOM_INVALID_CHARACTER_ERR

önekliAd geçersiz karakter içeriyorsa oluşur.

DOM_NAMESPACE_ERR

önekliAd, isim alanlı bir etiket adı olarak uygun değilse oluşur.

Ayrıca Bakınız

  • DOMNode::appendChild() - Listenin sonuna yeni bir çocuk ekler
  • DOMDocument::createAttribute() - Yeni bir öznitelik düğümü oluşturur
  • DOMDocument::createCDATASection() - Yeni bir CDATA düğümü oluşturur
  • DOMDocument::createComment() - Yeni bir açıklama düğümü oluşturur
  • DOMDocument::createDocumentFragment() - Yeni bir belge bölütü oluşturur
  • DOMDocument::createElement() - Yeni bir eleman düğümü oluşturur
  • DOMDocument::createElementNS() - İsim alanlı bir eleman düğümü oluşturur
  • DOMDocument::createEntityReference() - Yeni bir öğe bildirimi düğümü oluşturur
  • DOMDocument::createProcessingInstruction() - Yeni bir işlem komutu düğümü oluşturur
  • DOMDocument::createTextNode() - Yeni bir metin düğümü oluşturur

DOMDocument::createAttribute
DOMDocument::createCDATASection
DOMDocument


Yeni bir CDATA düğümü oluşturur

DOMDocument::createAttributeNS
DOMDocument::createComment
DOMDocument
PHP Manual

DOMDocument::createCDATASection

(PHP 5, PHP 7)

DOMDocument::createCDATASection — Yeni bir CDATA düğümü oluşturur

Açıklama

DOMCDATASection DOMDocument::createCDATASection ( string $veri )

Yeni bir DOMCDATASection nesnesi oluşturur. Bu düğüm, DomNode::append_child() gibi bir yöntemle belgeye yerleştirilmedikçe belgede gösterilmez.

Değiştirgeler

veri

CDATA içeriği.

Dönen Değerler

Bir hata oluşursa FALSE yoksa yeni bir DOMCDATASection nesnesi döner.

Ayrıca Bakınız

  • DOMNode::appendChild() - Listenin sonuna yeni bir çocuk ekler
  • DOMDocument::createAttribute() - Yeni bir öznitelik düğümü oluşturur
  • DOMDocument::createAttributeNS() - Yeni bir isim alanlı öznitelik düğümü oluşturur
  • DOMDocument::createComment() - Yeni bir açıklama düğümü oluşturur
  • DOMDocument::createDocumentFragment() - Yeni bir belge bölütü oluşturur
  • DOMDocument::createElement() - Yeni bir eleman düğümü oluşturur
  • DOMDocument::createElementNS() - İsim alanlı bir eleman düğümü oluşturur
  • DOMDocument::createEntityReference() - Yeni bir öğe bildirimi düğümü oluşturur
  • DOMDocument::createProcessingInstruction() - Yeni bir işlem komutu düğümü oluşturur
  • DOMDocument::createTextNode() - Yeni bir metin düğümü oluşturur

DOMDocument::createAttributeNS
DOMDocument::createComment
DOMDocument


Yeni bir açıklama düğümü oluşturur

DOMDocument::createCDATASection
DOMDocument::createDocumentFragment
DOMDocument
PHP Manual

DOMDocument::createComment

(PHP 5, PHP 7)

DOMDocument::createComment — Yeni bir açıklama düğümü oluşturur

Açıklama

DOMComment DOMDocument::createComment ( string $veri )

Yeni bir DOMComment nesnesi oluşturur. Bu düğüm, DomNode::append_child() gibi bir yöntemle belgeye yerleştirilmedikçe belgede gösterilmez.

Değiştirgeler

veri

Açıklamanın içeriği.

Dönen Değerler

Bir hata oluşursa FALSE yoksa yeni bir DOMComment nesnesi döner.

Ayrıca Bakınız

  • DOMNode::appendChild() - Listenin sonuna yeni bir çocuk ekler
  • DOMDocument::createAttribute() - Yeni bir öznitelik düğümü oluşturur
  • DOMDocument::createAttributeNS() - Yeni bir isim alanlı öznitelik düğümü oluşturur
  • DOMDocument::createCDATASection() - Yeni bir CDATA düğümü oluşturur
  • DOMDocument::createDocumentFragment() - Yeni bir belge bölütü oluşturur
  • DOMDocument::createElement() - Yeni bir eleman düğümü oluşturur
  • DOMDocument::createElementNS() - İsim alanlı bir eleman düğümü oluşturur
  • DOMDocument::createEntityReference() - Yeni bir öğe bildirimi düğümü oluşturur
  • DOMDocument::createProcessingInstruction() - Yeni bir işlem komutu düğümü oluşturur
  • DOMDocument::createTextNode() - Yeni bir metin düğümü oluşturur

DOMDocument::createCDATASection
DOMDocument::createDocumentFragment
DOMDocument


Yeni bir belge bölütü oluşturur

DOMDocument::createComment
DOMDocument::createElement
DOMDocument
PHP Manual

DOMDocument::createDocumentFragment

(PHP 5, PHP 7)

DOMDocument::createDocumentFragment — Yeni bir belge bölütü oluşturur

Açıklama

DOMDocumentFragment DOMDocument::createDocumentFragment ( void )

Yeni bir DOMDocumentFragment nesnesi oluşturur. Bu düğüm, DomNode::append_child() gibi bir yöntemle belgeye yerleştirilmedikçe belgede gösterilmez.

Dönen Değerler

Bir hata oluşursa FALSE yoksa yeni bir DOMDocumentFragment nesnesi döner.

Ayrıca Bakınız

  • DOMNode::appendChild() - Listenin sonuna yeni bir çocuk ekler
  • DOMDocument::createAttribute() - Yeni bir öznitelik düğümü oluşturur
  • DOMDocument::createAttributeNS() - Yeni bir isim alanlı öznitelik düğümü oluşturur
  • DOMDocument::createCDATASection() - Yeni bir CDATA düğümü oluşturur
  • DOMDocument::createComment() - Yeni bir açıklama düğümü oluşturur
  • DOMDocument::createElement() - Yeni bir eleman düğümü oluşturur
  • DOMDocument::createElementNS() - İsim alanlı bir eleman düğümü oluşturur
  • DOMDocument::createEntityReference() - Yeni bir öğe bildirimi düğümü oluşturur
  • DOMDocument::createProcessingInstruction() - Yeni bir işlem komutu düğümü oluşturur
  • DOMDocument::createTextNode() - Yeni bir metin düğümü oluşturur

DOMDocument::createComment
DOMDocument::createElement
DOMDocument


Yeni bir eleman düğümü oluşturur

DOMDocument::createDocumentFragment
DOMDocument::createElementNS
DOMDocument
PHP Manual

DOMDocument::createElement

(PHP 5, PHP 7)

DOMDocument::createElement — Yeni bir eleman düğümü oluşturur

Açıklama

DOMElement DOMDocument::createElement ( string $isim [, string $değer ] )

Yeni bir DOMElement nesnesi oluşturur. Bu düğüm, DomNode::append_child() gibi bir yöntemle belgeye yerleştirilmedikçe belgede gösterilmez.

Değiştirgeler

isim

Elemanın etiket ismi.

değer

Elemanın değeri. Öntanımlı olarak boş eleman oluşturulur. Değeri daha sonra DOMElement->nodeValue özelliğine de atayabilirsiniz.

Dönen Değerler

Bir hata oluşursa FALSE yoksa yeni bir DOMElement nesnesi döner.

Hatalar/İstisnalar

DOM_INVALID_CHARACTER_ERR

isim geçersiz karakter içeriyorsa oluşur.

Örnekler

Örnek 1 - Yeni bir eleman oluşturup belge elemanı yapmak

<?php

$dom = new DOMDocument('1.0', 'utf-8');

$element = $dom->createElement('test', 'This is the root element!');

// Oluşturduğumuz elemanı belge elemanı yapalım
$dom->appendChild($element);

echo $dom->saveXML();
?>

Yukarıdaki örneğin çıktısı:

<?xml version="1.0" encoding="utf-8"?>
<test>This is the root element!</test>

Ayrıca Bakınız

  • DOMNode::appendChild() - Listenin sonuna yeni bir çocuk ekler
  • DOMDocument::createAttribute() - Yeni bir öznitelik düğümü oluşturur
  • DOMDocument::createAttributeNS() - Yeni bir isim alanlı öznitelik düğümü oluşturur
  • DOMDocument::createCDATASection() - Yeni bir CDATA düğümü oluşturur
  • DOMDocument::createComment() - Yeni bir açıklama düğümü oluşturur
  • DOMDocument::createDocumentFragment() - Yeni bir belge bölütü oluşturur
  • DOMDocument::createElementNS() - İsim alanlı bir eleman düğümü oluşturur
  • DOMDocument::createEntityReference() - Yeni bir öğe bildirimi düğümü oluşturur
  • DOMDocument::createProcessingInstruction() - Yeni bir işlem komutu düğümü oluşturur
  • DOMDocument::createTextNode() - Yeni bir metin düğümü oluşturur

DOMDocument::createDocumentFragment
DOMDocument::createElementNS
DOMDocument


İsim alanlı bir eleman düğümü oluşturur

DOMDocument::createElement
DOMDocument::createEntityReference
DOMDocument
PHP Manual

DOMDocument::createElementNS

(PHP 5, PHP 7)

DOMDocument::createElementNS — İsim alanlı bir eleman düğümü oluşturur

Açıklama

DOMElement DOMDocument::createElementNS ( string $uri , string $önekliAd [, string $değer ] )

İsim alanlı yeni bir eleman düğümü oluşturur. Bu düğüm, DomNode::append_child() gibi bir yöntemle belgeye yerleştirilmedikçe belgede gösterilmez.

Değiştirgeler

uri

İsim alanını betimleyen adres.

önekliAd

önek:etiket biçeminde etiket ismi.

değer

Elemanın değeri. Öntanımlı olarak boş eleman oluşturulur. Değeri daha sonra DOMElement->nodeValue özelliğine de atayabilirsiniz.

Dönen Değerler

Bir hata oluşursa FALSE yoksa yeni bir DOMElement nesnesi döner.

Hatalar/İstisnalar

DOM_INVALID_CHARACTER_ERR

önekliAd geçersiz karakter içeriyorsa oluşur.

DOM_NAMESPACE_ERR

önekliAd, isim alanlı bir etiket adı olarak uygun değilse oluşur.

Örnekler

Örnek 1 - Yeni bir eleman oluşturup belge elemanı yapmak

<?php

$dom = new DOMDocument('1.0', 'utf-8');

$element = $dom->createElementNS('http://www.example.com/XFoo', 'xfoo:test',
              'This is the root element!');

// Oluşturduğumuz elemanı belge elemanı yapalım
$dom->appendChild($element);

echo $dom->saveXML();
?>

Yukarıdaki örneğin çıktısı:

<?xml version="1.0" encoding="utf-8"?>
<xfoo:test xmlns:xfoo="http://www.example.com/XFoo">This is the root element!</xfoo:test>

Örnek 2 - İsim alanı öneki örneği

<?php
$doc  = new DOMDocument('1.0', 'utf-8');
$doc->formatOutput = true;
$root = $doc->createElementNS('http://www.w3.org/2005/Atom', 'element');
$doc->appendChild($root);
$root->setAttributeNS('http://www.w3.org/2000/xmlns/' ,'xmlns:g', 'http://base.google.com/ns/1.0');
$item = $doc->createElementNS('http://base.google.com/ns/1.0', 'g:item_type', 'house');
$root->appendChild($item);

echo $doc->saveXML(), "\n";

echo $item->namespaceURI, "\n"; // Çıktısı: http://base.google.com/ns/1.0
echo $item->prefix, "\n";       // Çıktısı: g
echo $item->localName, "\n";    // Çıktısı: item_type
?>

Yukarıdaki örneğin çıktısı:

<?xml version="1.0" encoding="utf-8"?>
<element xmlns="http://www.w3.org/2005/Atom" xmlns:g="http://base.google.com/ns/1.0">
  <g:item_type>house</g:item_type>
</element>

http://base.google.com/ns/1.0
g
item_type

Ayrıca Bakınız

  • DOMNode::appendChild() - Listenin sonuna yeni bir çocuk ekler
  • DOMDocument::createAttribute() - Yeni bir öznitelik düğümü oluşturur
  • DOMDocument::createAttributeNS() - Yeni bir isim alanlı öznitelik düğümü oluşturur
  • DOMDocument::createCDATASection() - Yeni bir CDATA düğümü oluşturur
  • DOMDocument::createComment() - Yeni bir açıklama düğümü oluşturur
  • DOMDocument::createDocumentFragment() - Yeni bir belge bölütü oluşturur
  • DOMDocument::createElement() - Yeni bir eleman düğümü oluşturur
  • DOMDocument::createEntityReference() - Yeni bir öğe bildirimi düğümü oluşturur
  • DOMDocument::createProcessingInstruction() - Yeni bir işlem komutu düğümü oluşturur
  • DOMDocument::createTextNode() - Yeni bir metin düğümü oluşturur

DOMDocument::createElement
DOMDocument::createEntityReference
DOMDocument


Yeni bir öğe bildirimi düğümü oluşturur

DOMDocument::createElementNS
DOMDocument::createProcessingInstruction
DOMDocument
PHP Manual

DOMDocument::createEntityReference

(PHP 5, PHP 7)

DOMDocument::createEntityReference — Yeni bir öğe bildirimi düğümü oluşturur

Açıklama

DOMEntityReference DOMDocument::createEntityReference ( string $isim )

Yeni bir DOMEntityReference nesnesi oluşturur. Bu düğüm, DomNode::append_child() gibi bir yöntemle belgeye yerleştirilmedikçe belgede gösterilmez.

Değiştirgeler

isim

Öğe gönderiminin içeriği. Bir & ile başlayıp ; ile biten bir tire imi öğe bildirimine bir örnektir.

Dönen Değerler

Bir hata oluşursa FALSE yoksa yeni bir DOMEntityReference nesnesi döner.

Hatalar/İstisnalar

DOM_INVALID_CHARACTER_ERR

isim geçersiz karakter içeriyorsa oluşur.

Ayrıca Bakınız

  • DOMNode::appendChild() - Listenin sonuna yeni bir çocuk ekler
  • DOMDocument::createAttribute() - Yeni bir öznitelik düğümü oluşturur
  • DOMDocument::createAttributeNS() - Yeni bir isim alanlı öznitelik düğümü oluşturur
  • DOMDocument::createCDATASection() - Yeni bir CDATA düğümü oluşturur
  • DOMDocument::createComment() - Yeni bir açıklama düğümü oluşturur
  • DOMDocument::createDocumentFragment() - Yeni bir belge bölütü oluşturur
  • DOMDocument::createElement() - Yeni bir eleman düğümü oluşturur
  • DOMDocument::createElementNS() - İsim alanlı bir eleman düğümü oluşturur
  • DOMDocument::createProcessingInstruction() - Yeni bir işlem komutu düğümü oluşturur
  • DOMDocument::createTextNode() - Yeni bir metin düğümü oluşturur

DOMDocument::createElementNS
DOMDocument::createProcessingInstruction
DOMDocument


Yeni bir işlem komutu düğümü oluşturur

DOMDocument::createEntityReference
DOMDocument::createTextNode
DOMDocument
PHP Manual

DOMDocument::createProcessingInstruction

(PHP 5, PHP 7)

DOMDocument::createProcessingInstruction — Yeni bir işlem komutu düğümü oluşturur

Açıklama

DOMProcessingInstruction DOMDocument::createProcessingInstruction ( string $hedef [, string $veri ] )

Bu işlev yeni bir DOMProcessingInstruction nesnesi oluşturur. Bu düğüm, DomNode::append_child() gibi bir yöntemle belgeye yerleştirilmedikçe belgede gösterilmez.

Değiştirgeler

hedef

İşlem komutunun hedefi.

veri

İşlem komutunun içeriği.

Dönen Değerler

Bir hata oluşursa FALSE yoksa yeni bir DOMProcessingInstruction nesnesi döner.

Hatalar/İstisnalar

DOM_INVALID_CHARACTER_ERR

hedef geçersiz karakter içeriyırsa oluşur.

Ayrıca Bakınız

  • DOMNode::appendChild() - Listenin sonuna yeni bir çocuk ekler
  • DOMDocument::createAttribute() - Yeni bir öznitelik düğümü oluşturur
  • DOMDocument::createAttributeNS() - Yeni bir isim alanlı öznitelik düğümü oluşturur
  • DOMDocument::createCDATASection() - Yeni bir CDATA düğümü oluşturur
  • DOMDocument::createComment() - Yeni bir açıklama düğümü oluşturur
  • DOMDocument::createDocumentFragment() - Yeni bir belge bölütü oluşturur
  • DOMDocument::createElement() - Yeni bir eleman düğümü oluşturur
  • DOMDocument::createElementNS() - İsim alanlı bir eleman düğümü oluşturur
  • DOMDocument::createEntityReference() - Yeni bir öğe bildirimi düğümü oluşturur
  • DOMDocument::createTextNode() - Yeni bir metin düğümü oluşturur

DOMDocument::createEntityReference
DOMDocument::createTextNode
DOMDocument


Yeni bir metin düğümü oluşturur

DOMDocument::createProcessingInstruction
DOMDocument::getElementById
DOMDocument
PHP Manual

DOMDocument::createTextNode

(PHP 5, PHP 7)

DOMDocument::createTextNode — Yeni bir metin düğümü oluşturur

Açıklama

DOMText DOMDocument::createTextNode ( string $içerik )

Belirtilen içerik'ten yeni bir DOMText nesnesi oluşturur. Bu düğüm, DomNode::append_child() gibi bir yöntemle belgeye yerleştirilmedikçe belgede gösterilmez.

Değiştirgeler

içerik

Metnin içeriği.

Dönen Değerler

Bir hata oluşursa FALSE yoksa yeni bir DOMText nesnesi döner.

Ayrıca Bakınız

  • DOMNode::appendChild() - Listenin sonuna yeni bir çocuk ekler
  • DOMDocument::createAttribute() - Yeni bir öznitelik düğümü oluşturur
  • DOMDocument::createAttributeNS() - Yeni bir isim alanlı öznitelik düğümü oluşturur
  • DOMDocument::createCDATASection() - Yeni bir CDATA düğümü oluşturur
  • DOMDocument::createComment() - Yeni bir açıklama düğümü oluşturur
  • DOMDocument::createDocumentFragment() - Yeni bir belge bölütü oluşturur
  • DOMDocument::createElement() - Yeni bir eleman düğümü oluşturur
  • DOMDocument::createElementNS() - İsim alanlı bir eleman düğümü oluşturur
  • DOMDocument::createEntityReference() - Yeni bir öğe bildirimi düğümü oluşturur
  • DOMDocument::createProcessingInstruction() - Yeni bir işlem komutu düğümü oluşturur

DOMDocument::createProcessingInstruction
DOMDocument::getElementById
DOMDocument


ID'si belirtilen elemanı döndürür

DOMDocument::createTextNode
DOMDocument::getElementsByTagName
DOMDocument
PHP Manual

DOMDocument::getElementById

(PHP 5, PHP 7)

DOMDocument::getElementById — ID'si belirtilen elemanı döndürür

Açıklama

DOMElement DOMDocument::getElementById ( string $id )

Elemanı ID özniteliğine göre araması dışında DOMDocument::getElementsByTagName() gibidir.

Bu yöntemin çalışması için DOMElement::setIdAttribute() ile elemana bir ID atanmış olması veya ID türünde bir öznitelik tanımlayan bir DTD gerekir. DTD gerektiren durumlarda bu yöntemi kullanmadan önce belgeyi ya DOMDocument::validate() ile ya da DOMDocument ->validateOnParse ile doğrulamalısınız.

Değiştirgeler

id

Elemanın eşsiz ID'si.

Dönen Değerler

Aranan eleman yoksa NULL, varsa bir DOMElement nesnesi döner.

Örnekler

Örnek 1 - DOMDocument::getElementById() örneği

<?php

$doc = new DomDocument;

// Belgeyi önce doğrulamalıyız
$doc->validateOnParse = true;
$doc->Load('book.xml');

echo "'books' ID'li eleman: " . $doc->getElementById('books')->tagName . "\n";

?>

Yukarıdaki örneğin çıktısı:

'books' ID'li eleman: chapter

Ayrıca Bakınız

  • DOMDocument::getElementsByTagName() - İsmi belirtilen tüm elemanları döndürür

DOMDocument::createTextNode
DOMDocument::getElementsByTagName
DOMDocument


İsmi belirtilen tüm elemanları döndürür

DOMDocument::getElementById
DOMDocument::getElementsByTagNameNS
DOMDocument
PHP Manual

DOMDocument::getElementsByTagName

(PHP 5, PHP 7)

DOMDocument::getElementsByTagName — İsmi belirtilen tüm elemanları döndürür

Açıklama

DOMNodeList DOMDocument::getElementsByTagName ( string $isim )

İsmi belirtilen tüm elemanları bir DOMNodeList nesnesi olarak döndürür.

Değiştirgeler

isim

Aranacak etiket ismi. Tüm elemanları döndürmek için * belirtilebilir.

Dönen Değerler

Eşleşen elemanları içeren yeni bir DOMNodeList nesnesi döner.

Ayrıca Bakınız

  • DOMDocument::getElementsByTagNameNS() - İsmi ve isim alanı belirtilen tüm elemanları döndürür

DOMDocument::getElementById
DOMDocument::getElementsByTagNameNS
DOMDocument


İsmi ve isim alanı belirtilen tüm elemanları döndürür

DOMDocument::getElementsByTagName
DOMDocument::importNode
DOMDocument
PHP Manual

DOMDocument::getElementsByTagNameNS

(PHP 5, PHP 7)

DOMDocument::getElementsByTagNameNS — İsmi ve isim alanı belirtilen tüm elemanları döndürür

Açıklama

DOMNodeList DOMDocument::getElementsByTagNameNS ( string $uri , string $isim )

İsmi ve isim alanı belirtilen tüm elemanları bir DOMNodeList nesnesi olarak döndürür.

Değiştirgeler

uri

Elemanların eşleştirileceği isim alanını betimleyen adres. Bütün isim alanları anlamında * belirtilebilir.

isim

Eşleştirilecek elemanın ismi. Tüm elemanları döndürmek için * belirtilebilir.

Dönen Değerler

Eşleşen elemanları içeren yeni bir DOMNodeList nesnesi döner.

Örnekler

Örnek 1 - Tüm XInclude elemanlarını döndürmek

<?php

$xml = <<<EOD
<?xml version="1.0" ?>
<chapter xmlns:xi="http://www.w3.org/2001/XInclude">
<title>Books of the other guy..</title>
<para>
 <xi:include href="book.xml">
  <xi:fallback>
   <error>xinclude: book.xml not found</error>
  </xi:fallback>
 </xi:include>
 <include>
  This is another namespace
 </include>
</para>
</chapter>
EOD;
$dom = new DOMDocument;

// Yukarıdaki XML dizgesini yükleyelim
$dom->loadXML($xml);

foreach ($dom->getElementsByTagNameNS('http://www.w3.org/2001/XInclude', '*') as $element) {
    echo 'eleman: ', $element->localName, ', önek: ', $element->prefix, "\n";
}
?>

Yukarıdaki örneğin çıktısı:

eleman: include, önek: xi
eleman: fallback, önek: xi

Ayrıca Bakınız

  • DOMDocument::getElementsByTagName() - İsmi belirtilen tüm elemanları döndürür

DOMDocument::getElementsByTagName
DOMDocument::importNode
DOMDocument


Belgeye bir düğüm dahil eder

DOMDocument::getElementsByTagNameNS
DOMDocument::load
DOMDocument
PHP Manual

DOMDocument::importNode

(PHP 5, PHP 7)

DOMDocument::importNode — Belgeye bir düğüm dahil eder

Açıklama

DOMNode DOMDocument::importNode ( DOMNode $düğüm [, bool $içiçe ] )

Dahil edilen düğümü belge ile ilişkilendirip düğümün bir kopyasını döndürür.

Değiştirgeler

düğüm

Belgeye dahil edilecek düğüm.

içiçe

TRUE belirtiliği takdirde düğüm alt düğümleriyle birlikte belgeye dahil edilir.

Bilginize:

Düğümlerin özniteliklerini de kopyalamak için bu değiştirgede TRUE belirtmek gerekir.

Dönen Değerler

Düğüm kopyalanamazsa FALSE, yoksa kopyalanan düğümü döndürür.

Hatalar/İstisnalar

Düğüm dahil edilemezse DOMException istisnası oluşur.

Örnekler

Örnek 1 - DOMDocument::importNode() örneği

Düğümlerin bir belgeden başka bir belgeye kopyalanması.

<?php

$orgdoc = new DOMDocument;
$orgdoc->loadXML("<root><eleman><çocuk>çocuk metin</çocuk></eleman></root>");

// Yeni belgeye dahil edilecek düğüm
$node = $orgdoc->getElementsByTagName("element")->item(0);

// Yeni belgeyi oluşturalım
$newdoc = new DOMDocument;
$newdoc->formatOutput = true;

// Biraz imlenim ekleyelim
$newdoc->loadXML("<root><bireleman>elemanın içeriği</bireleman></root>");

echo "Düğümler kopyalanmadan 'yeni belge':\n";
echo $newdoc->saveXML();

// Düğümü alt düğümleriyle birlikte belgeye dahil edelim
$node = $newdoc->importNode($node, true);
// ve "<root>" düğümüne ekleyelim
$newdoc->documentElement->appendChild($node);

echo "\nDüğümler kopyalandıktan sonra 'yeni belge':\n";
echo $newdoc->saveXML();
?>

Yukarıdaki örneğin çıktısı:

Düğümler kopyalanmadan 'yeni belge':
<?xml version="1.0" encoding="utf-8"?>
<root>
  <bireleman>elemanın içeriği</bireleman>
</root>

Düğümler kopyalandıktan sonra 'yeni belge':
<?xml version="1.0" encoding="utf-8"?>
<root>
  <bireleman>elemanın içeriği</bireleman>
  <eleman>
    <çocuk>çocuk metin</çocuk>
  </eleman>
</root>

DOMDocument::getElementsByTagNameNS
DOMDocument::load
DOMDocument


XML belgeyi bir dosyadan yükler

DOMDocument::importNode
DOMDocument::loadHTML
DOMDocument
PHP Manual

DOMDocument::load

(PHP 5, PHP 7)

DOMDocument::load — XML belgeyi bir dosyadan yükler

Açıklama

mixed DOMDocument::load ( string $dosya [, int $seçenekler = 0 ] )

XML belgeyi belirtilen dosyadan yükler.

Uyarı

Unix tarzı düz bölülü dosya yolları Windows sistemlerinde önemli bir başarım kaybına yol açarlar. Böyle durumlarda realpath() kullanımı önerilir.

Değiştirgeler

dosya

XML belgenin dosya yolu.

seçenekler

Bit seviyesinde VEYAlanmış olarak libxml sabitleri.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. Duruk olarak çağrıldığı takdirde bir DOMDocument döndürür ve bir E_STRICT iletisi çıktılar.

Hatalar/İstisnalar

dosya olarak boş bir dizge veya boş bir dosya aktarılırsa bir uyarı üretilir. Bu uyarıyı libxml üretmez ve libxml'in hata işlevleri ile elde edilemez.

Örnekler

Örnek 1 - Bir belge oluşturmak

<?php
$doc = new DOMDocument();
$doc->load('book.xml');
echo $doc->saveXML();
?>

Ayrıca Bakınız

  • DOMDocument::loadXML() - XML belgeyi bir dizgeden yükler
  • DOMDocument::save() - Dahili XML ağacını bir dizge olarak dosyaya yazar
  • DOMDocument::saveXML() - Dahili XML ağacını bir dizge olarak çıktılar

DOMDocument::importNode
DOMDocument::loadHTML
DOMDocument


HTML belgeyi bir dizgeden yükler

DOMDocument::load
DOMDocument::loadHTMLFile
DOMDocument
PHP Manual

DOMDocument::loadHTML

(PHP 5, PHP 7)

DOMDocument::loadHTML — HTML belgeyi bir dizgeden yükler

Açıklama

bool DOMDocument::loadHTML ( string $dizge )

HTML belgeyi belirtilen dizgeden yükler. XML belge yüklemedeki gibi belgenin iyi biçemli olma gereği yoktur. Bu yöntem, bir DOMDocument nesnesini yüklemek ve oluşturmak için duruk olarak da çağrılabilir. Bu duruk yöntem çağrısı, yükleme öncesinde hiçbir DOMDocument özelliğinin atanmasına ihtiyaç duyulmadığı durumlarda kullanılabilir.

Değiştirgeler

dizge

HTML belgeyi içeren dizge.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. Duruk olarak çağrıldığı takdirde bir DOMDocument döndürür ve bir E_STRICT iletisi çıktılar.

Hatalar/İstisnalar

dizge olarak boş bir dizge aktarılırsa bir uyarı üretilir. Bu uyarıyı libxml üretmez ve libxml'in hata işlevleri ile elde edilemez.

Örnekler

Örnek 1 - Bir HTML belge oluşturmak

<?php
$doc = new DOMDocument();
$doc->loadHTML("<html><body>Test<br></body></html>");
echo $doc->saveHTML();
?>

Ayrıca Bakınız

  • DOMDocument::loadHTMLFile() - HTML belgeyi bir dosyadan yükler
  • DOMDocument::saveHTML() - Dahili belgeyi bir HTML dizgesi olarak çıktılar
  • DOMDocument::saveHTMLFile() - Dahili belgeyi bir HTML dizge olarak dosyaya yazar

DOMDocument::load
DOMDocument::loadHTMLFile
DOMDocument


HTML belgeyi bir dosyadan yükler

DOMDocument::loadHTML
DOMDocument::loadXML
DOMDocument
PHP Manual

DOMDocument::loadHTMLFile

(PHP 5, PHP 7)

DOMDocument::loadHTMLFile — HTML belgeyi bir dosyadan yükler

Açıklama

bool DOMDocument::loadHTMLFile ( string $dosya )

HTML belgeyi belirtilen dosyadan yükler. XML belge yüklemedeki gibi belgenin iyi biçemli olma gereği yoktur.

Tavsiye edilmemekle beraber, bu yöntem, bir DOMDocument nesnesini yüklemek ve oluşturmak için duruk olarak da çağrılabilir. Bu duruk yöntem çağrısı, yükleme öncesinde hiçbir DOMDocument özelliğinin atanmasına ihtiyaç duyulmadığı durumlarda kullanılabilir. Ancak böyle bir durumda bir E_STRICT iletisi çıktılanır.

Değiştirgeler

dosya

HTML belgeyi içeren dosyanın yolu.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. Duruk olarak çağrıldığı takdirde bir DOMDocument döndürür ve bir E_STRICT iletisi çıktılar.

Hatalar/İstisnalar

dosya olarak boş bir dizge veya boş bir dosya aktarılırsa bir uyarı üretilir. Bu uyarıyı libxml üretmez ve libxml'in hata işlevleri ile elde edilemez.

Örnekler

Örnek 1 - Bir belge oluşturmak

<?php
$doc = new DOMDocument();
$doc->loadHTMLFile("filename.html");
echo $doc->saveHTML();
?>

Ayrıca Bakınız

  • DOMDocument::loadHTML() - HTML belgeyi bir dizgeden yükler
  • DOMDocument::saveHTML() - Dahili belgeyi bir HTML dizgesi olarak çıktılar
  • DOMDocument::saveHTMLFile() - Dahili belgeyi bir HTML dizge olarak dosyaya yazar

DOMDocument::loadHTML
DOMDocument::loadXML
DOMDocument


XML belgeyi bir dizgeden yükler

DOMDocument::loadHTMLFile
DOMDocument::normalizeDocument
DOMDocument
PHP Manual

DOMDocument::loadXML

(PHP 5, PHP 7)

DOMDocument::loadXML — XML belgeyi bir dizgeden yükler

Açıklama

mixed DOMDocument::loadXML ( string $dizge [, int $seçenekler = 0 ] )

XML belgeyi bir dizgeden yükler.

Bu yöntem, bir DOMDocument nesnesini yüklemek ve oluşturmak için duruk olarak da çağrılabilir. Bu duruk yöntem çağrısı, yükleme öncesinde hiçbir DOMDocument özelliğinin atanmasına ihtiyaç duyulmadığı durumlarda kullanılabilir.

Değiştirgeler

dizge

XML belgeyi içeren dizge.

seçenekler

Bit seviyesinde VEYAlanmış olarak libxml sabitleri.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. Duruk olarak çağrıldığı takdirde bir DOMDocument döndürür ve bir E_STRICT iletisi çıktılar.

Hatalar/İstisnalar

dizge olarak boş bir dizge aktarılırsa bir uyarı üretilir. Bu uyarıyı libxml üretmez ve libxml'in hata işlevleri ile elde edilemez.

Örnekler

Örnek 1 - Bir belge oluşturmak

<?php
$doc = new DOMDocument();
$doc->loadXML('<root><node/></root>');
echo $doc->saveXML();
?>

Örnek 2 - Duruk DOMDocument::loadXML() çağrısı

<?php
$doc = DOMDocument::loadXML('<root><node/></root>');
echo $doc->saveXML();
?>

Ayrıca Bakınız

  • DOMDocument::load() - XML belgeyi bir dosyadan yükler
  • DOMDocument::save() - Dahili XML ağacını bir dizge olarak dosyaya yazar
  • DOMDocument::saveXML() - Dahili XML ağacını bir dizge olarak çıktılar

DOMDocument::loadHTMLFile
DOMDocument::normalizeDocument
DOMDocument


Belgeyi normalleştirir

DOMDocument::loadXML
DOMDocument::registerNodeClass
DOMDocument
PHP Manual

DOMDocument::normalizeDocument

(PHP 5, PHP 7)

DOMDocument::normalizeDocument — Belgeyi normalleştirir

Açıklama

void DOMDocument::normalizeDocument ( void )

Bu yöntem, belgeyi önce kaydedip sonra yüklemişsiniz gibi, belgeyi "normal" biçime getirir.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • » DOM Belirtimi
  • DOMNode::normalize() - Düğümü normalleştirir

DOMDocument::loadXML
DOMDocument::registerNodeClass
DOMDocument


Temel düğüm türünü oluşturmakta kullanılacak türetilmiş sınıfı belirtmek için kullanılır

DOMDocument::normalizeDocument
DOMDocument::relaxNGValidate
DOMDocument
PHP Manual

DOMDocument::registerNodeClass

(PHP 5 >= 5.2.0, PHP 7)

DOMDocument::registerNodeClass — Temel düğüm türünü oluşturmakta kullanılacak türetilmiş sınıfı belirtmek için kullanılır

Açıklama

bool DOMDocument::registerNodeClass ( string $temelSınıf , string $türetilenSınıf )

Sonradan PHP DOM eklentisi tarafından kullanılmak üzere hazırladığınız kendi DOM sınıfınızı tanıtmanızı sağlar.

Bu yöntem DOM standardının bir parçası değildir.

Değiştirgeler

temelSınıf

Kendi sınıfınızı türetirken kullandığınız temel sınıfın ismi. Bu sınıfların listesi için bakınız: DOM.

türetilenSınıf

Türettiğiniz sınıfın ismi. NULL belirtilirse, temelSınıf'tan evvelce türetilen sınıf silinir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
PHP 5.2.2 | 5.2.2 öncesinde, temelSınıf'tan evvelce türetilmiş bir sınıf varsa yenisinin kaydı yapılmadan önce eskisinin kaydı silinmek zorundaydı.

Örnekler

Örnek 1 - Kolaylık olsun diye DOMElement sınıfına yeni bir yöntem eklemek

<?php

class myElement extends DOMElement {
   function appendElement($name) {
      return $this->appendChild(new myElement($name));
   }
}

class myDocument extends DOMDocument {
   function setRoot($name) {
      return $this->appendChild(new myElement($name));
   }
}

$doc = new myDocument();
$doc->registerNodeClass('DOMElement', 'myElement');

// Artık bir elemanı diğerine eklemek için bir yöntem yetecek!
$root = $doc->setRoot('root');
$child = $root->appendElement('child');
$child->setAttribute('foo', 'bar');

echo $doc->saveXML();

?>

Yukarıdaki örneğin çıktısı:

<?xml version="1.0"?>
<root><child foo="bar"/></root>

Örnek 2 - Elemanların özel bir sınıf olarak döndürülmesi

<?php
class myElement extends DOMElement {
    public function __toString() {
        return $this->nodeValue;
    }
}

$doc = new DOMDocument;
$doc->loadXML("<root><element><child>text in child</child></element></root>");
$doc->registerNodeClass("DOMElement", "myElement");

$element = $doc->getElementsByTagName("child")->item(0);
var_dump(get_class($element));

// __toString yönteminden yararlanalım
echo $element;
?>

Yukarıdaki örneğin çıktısı:

string(9) "myElement"
text in child

Örnek 3 - Asıl belgeyi döndürmek

DOMDocument sınıfına özgü olarak, sınıf örneklenirken sınıfın ownerDocument özelliği örneklenen sınıfı gösterecektir. Yani, DOMDocument sınıfı için DOMDocument::registerNodeClass() yönteminin kullanımına aslında gerek yoktur.

<?php
class myDOMDocument extends DOMDocument {
}

class myOtherDOMDocument extends DOMDocument {
}

// myDOMDocument nesnesini XML belge olarak oluşturalım
$doc = new myDOMDocument;
$doc->loadXML("<root><element><child>text in child</child></element></root>");

$child = $doc->getElementsByTagName("child")->item(0);

// Düğümün sahibi myDOMDocument nesnesidir
var_dump(get_class($child->ownerDocument));

// myDOMDocument nesnesinden bir düğüm alalım
$newdoc = new myOtherDOMDocument;
$child = $newdoc->importNode($child);

// Düğümün sahibi artık myOtherDOMDocument nesnesi oldu
var_dump(get_class($child->ownerDocument));
?>

Yukarıdaki örneğin çıktısı:

string(13) "myDOMDocument"
string(18) "myOtherDOMDocument"

DOMDocument::normalizeDocument
DOMDocument::relaxNGValidate
DOMDocument


Belgeyi belirtilen RNG dosyasıyla doğrular

DOMDocument::registerNodeClass
DOMDocument::relaxNGValidateSource
DOMDocument
PHP Manual

DOMDocument::relaxNGValidate

(PHP 5, PHP 7)

DOMDocument::relaxNGValidate — Belgeyi belirtilen RNG dosyasıyla doğrular

Açıklama

bool DOMDocument::relaxNGValidate ( string $dosya )

Belirtilen RNG şemasına göre belgeye » relaxNG doğrulaması uygular.

Değiştirgeler

dosya

RNG dosyasının yolu.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • DOMDocument::relaxNGValidateSource() - Belgeyi belirtilen RNG dizgesiyle doğrular
  • DOMDocument::schemaValidate() - Belgeyi bir şema dosyasına göre doğrular
  • DOMDocument::schemaValidateSource() - Belgeyi bir şema dizgesine göre doğrular
  • DOMDocument::validate() - Belgeyi DTD'sine göre doğrular

DOMDocument::registerNodeClass
DOMDocument::relaxNGValidateSource
DOMDocument


Belgeyi belirtilen RNG dizgesiyle doğrular

DOMDocument::relaxNGValidate
DOMDocument::save
DOMDocument
PHP Manual

DOMDocument::relaxNGValidateSource

(PHP 5, PHP 7)

DOMDocument::relaxNGValidateSource — Belgeyi belirtilen RNG dizgesiyle doğrular

Açıklama

bool DOMDocument::relaxNGValidateSource ( string $rng )

Belirtilen RNG şemasına göre belgeye » relaxNG doğrulaması uygular.

Değiştirgeler

rng

RNG şemasını içeren dizge.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • DOMDocument::relaxNGValidate() - Belgeyi belirtilen RNG dosyasıyla doğrular
  • DOMDocument::schemaValidate() - Belgeyi bir şema dosyasına göre doğrular
  • DOMDocument::schemaValidateSource() - Belgeyi bir şema dizgesine göre doğrular
  • DOMDocument::validate() - Belgeyi DTD'sine göre doğrular

DOMDocument::relaxNGValidate
DOMDocument::save
DOMDocument


Dahili XML ağacını bir dizge olarak dosyaya yazar

DOMDocument::relaxNGValidateSource
DOMDocument::saveHTML
DOMDocument
PHP Manual

DOMDocument::save

(PHP 5, PHP 7)

DOMDocument::save — Dahili XML ağacını bir dizge olarak dosyaya yazar

Açıklama

int DOMDocument::save ( string $dosya [, int $seçenekler ] )

Belgeyi DOM gösteriminden oluşturur. Bu yöntem genellikle, aşağıdaki örnekte olduğu gibi sıfırdan bir belge oluşturulduktan sonra çağrılır.

Değiştirgeler

dosya

XML belgenin kaydedileceği dosyanın yolu.

seçenekler

Ek seçenekler. Şimdilik sadece LIBXML_NOEMPTYTAG desteklenmektedir.

Dönen Değerler

Bir hata oluşmuşsa FALSE yoksa yazılan bayt sayısı döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.0 | seçenekler değiştirgesi eklendi.

Örnekler

Örnek 1 - Bir DOM ağacının bir dosyaya kaydedilmesi

<?php

$doc = new DOMDocument('1.0');
// Çıktı göze hoş görünsün
$doc->formatOutput = true;

$root = $doc->createElement('book');
$root = $doc->appendChild($root);

$title = $doc->createElement('title');
$title = $root->appendChild($title);

$text = $doc->createTextNode('This is the title');
$text = $title->appendChild($text);

echo $doc->save("/tmp/test.xml") . ' bayt yazıldı'; // 72 bayt yazıldı

?>

Ayrıca Bakınız

  • DOMDocument::saveXML() - Dahili XML ağacını bir dizge olarak çıktılar
  • DOMDocument::load() - XML belgeyi bir dosyadan yükler
  • DOMDocument::loadXML() - XML belgeyi bir dizgeden yükler

DOMDocument::relaxNGValidateSource
DOMDocument::saveHTML
DOMDocument


Dahili belgeyi bir HTML dizgesi olarak çıktılar

DOMDocument::save
DOMDocument::saveHTMLFile
DOMDocument
PHP Manual

DOMDocument::saveHTML

(PHP 5, PHP 7)

DOMDocument::saveHTML — Dahili belgeyi bir HTML dizgesi olarak çıktılar

Açıklama

string DOMDocument::saveHTML ( void )

HTML belgeyi DOM gösteriminden oluşturur. Bu yöntem genellikle, aşağıdaki örnekte olduğu gibi sıfırdan bir belge oluşturulduktan sonra çağrılır.

Dönen Değerler

Bir hata oluşursa FALSE, yoksa HTML belge döner.

Örnekler

Örnek 1 - Bir HTML ağacının dizge olarak çıktılanması

<?php

$doc = new DOMDocument('1.0');

$root = $doc->createElement('html');
$root = $doc->appendChild($root);

$head = $doc->createElement('head');
$head = $root->appendChild($head);

$title = $doc->createElement('title');
$title = $head->appendChild($title);

$text = $doc->createTextNode('This is the title');
$text = $title->appendChild($text);

echo $doc->saveHTML();

?>

Ayrıca Bakınız

  • DOMDocument::saveHTMLFile() - Dahili belgeyi bir HTML dizge olarak dosyaya yazar
  • DOMDocument::loadHTML() - HTML belgeyi bir dizgeden yükler
  • DOMDocument::loadHTMLFile() - HTML belgeyi bir dosyadan yükler

DOMDocument::save
DOMDocument::saveHTMLFile
DOMDocument


Dahili belgeyi bir HTML dizge olarak dosyaya yazar

DOMDocument::saveHTML
DOMDocument::saveXML
DOMDocument
PHP Manual

DOMDocument::saveHTMLFile

(PHP 5, PHP 7)

DOMDocument::saveHTMLFile — Dahili belgeyi bir HTML dizge olarak dosyaya yazar

Açıklama

int DOMDocument::saveHTMLFile ( string $dosya )

HTML belgeyi DOM gösteriminden oluşturur. Bu yöntem genellikle, aşağıdaki örnekte olduğu gibi sıfırdan bir belge oluşturulduktan sonra çağrılır.

Değiştirgeler

dosya

HTML belgenin kaydedileceği dosyanın yolu.

Dönen Değerler

Bir hata oluşmuşsa FALSE yoksa yazılan bayt sayısı döner.

Örnekler

Örnek 1 - Bir HTML ağacının bir dosyaya kaydedilmesi

<?php

$doc = new DOMDocument('1.0');
// Çıktı göze hoş görünsün
$doc->formatOutput = true;

$root = $doc->createElement('html');
$root = $doc->appendChild($root);

$head = $doc->createElement('head');
$head = $root->appendChild($head);

$title = $doc->createElement('title');
$title = $head->appendChild($title);

$text = $doc->createTextNode('This is the title');
$text = $title->appendChild($text);

echo $doc->saveHTMLFile("/tmp/test.html") . ' bayt yazıldı';
// Çıktısı: 129 bayt yazıldı

?>

Ayrıca Bakınız

  • DOMDocument::saveHTML() - Dahili belgeyi bir HTML dizgesi olarak çıktılar
  • DOMDocument::loadHTML() - HTML belgeyi bir dizgeden yükler
  • DOMDocument::loadHTMLFile() - HTML belgeyi bir dosyadan yükler

DOMDocument::saveHTML
DOMDocument::saveXML
DOMDocument


Dahili XML ağacını bir dizge olarak çıktılar

DOMDocument::saveHTMLFile
DOMDocument::schemaValidate
DOMDocument
PHP Manual

DOMDocument::saveXML

(PHP 5, PHP 7)

DOMDocument::saveXML — Dahili XML ağacını bir dizge olarak çıktılar

Açıklama

string DOMDocument::saveXML ([ DOMNode $düğüm [, int $seçenekler ]] )

Belgeyi DOM gösteriminden oluşturur. Bu yöntem genellikle, aşağıdaki örnekte olduğu gibi sıfırdan bir belge oluşturulduktan sonra çağrılır.

Değiştirgeler

düğüm

XML belgenin tamamını değil de sadece bir düğümünü (XML bildirimi olmaksızın) çıktılamak için kullanılır.

seçenekler

Ek seçenekler. Şimdilik sadece LIBXML_NOEMPTYTAG desteklenmektedir.

Dönen Değerler

Bir hata oluşursa FALSE, yoksa XML belge döner.

Hatalar/İstisnalar

DOM_WRONG_DOCUMENT_ERR

düğüm başka bir belgeye aitse bu hata oluşur.

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.0 | seçenekler değiştirgesi eklendi.

Örnekler

Örnek 1 - Bir DOM ağacının dizge olarak çıktılanması

<?php

$doc = new DOMDocument('1.0');
// Çıktı göze hoş görünsün
$doc->formatOutput = true;

$root = $doc->createElement('book');
$root = $doc->appendChild($root);

$title = $doc->createElement('title');
$title = $root->appendChild($title);

$text = $doc->createTextNode('Başlık');
$text = $title->appendChild($text);

echo "Belgenin tamamı:\n";
echo $doc->saveXML() . "\n";

echo "Sadece başlığı:\n";
echo $doc->saveXML($title);

?>

Yukarıdaki örneğin çıktısı:

Belgenin tamamı:
<?xml version="1.0"?>
<book>
  <title>Başlık</title>
</book>

Sadece başlığı:
<title>Başlık</title>

Ayrıca Bakınız

  • DOMDocument::save() - Dahili XML ağacını bir dizge olarak dosyaya yazar
  • DOMDocument::load() - XML belgeyi bir dosyadan yükler
  • DOMDocument::loadXML() - XML belgeyi bir dizgeden yükler

DOMDocument::saveHTMLFile
DOMDocument::schemaValidate
DOMDocument


Belgeyi bir şema dosyasına göre doğrular

DOMDocument::saveXML
DOMDocument::schemaValidateSource
DOMDocument
PHP Manual

DOMDocument::schemaValidate

(PHP 5, PHP 7)

DOMDocument::schemaValidate — Belgeyi bir şema dosyasına göre doğrular

Açıklama

bool DOMDocument::schemaValidate ( string $dosya )

Belgeyi belirtilen şema dosyasına göre doğrular.

Değiştirgeler

dosya

Şema dosyasının yolu.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • DOMDocument::schemaValidateSource() - Belgeyi bir şema dizgesine göre doğrular
  • DOMDocument::relaxNGValidate() - Belgeyi belirtilen RNG dosyasıyla doğrular
  • DOMDocument::relaxNGValidateSource() - Belgeyi belirtilen RNG dizgesiyle doğrular
  • DOMDocument::validate() - Belgeyi DTD'sine göre doğrular

DOMDocument::saveXML
DOMDocument::schemaValidateSource
DOMDocument


Belgeyi bir şema dizgesine göre doğrular

DOMDocument::schemaValidate
DOMDocument::validate
DOMDocument
PHP Manual

DOMDocument::schemaValidateSource

(PHP 5, PHP 7)

DOMDocument::schemaValidateSource — Belgeyi bir şema dizgesine göre doğrular

Açıklama

bool DOMDocument::schemaValidateSource ( string $şema )

Belgeyi belirtilen şema dizgesine göre doğrular.

Değiştirgeler

şema

Şemayı içeren dizge.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • DOMDocument::schemaValidate() - Belgeyi bir şema dosyasına göre doğrular
  • DOMDocument::relaxNGValidate() - Belgeyi belirtilen RNG dosyasıyla doğrular
  • DOMDocument::relaxNGValidateSource() - Belgeyi belirtilen RNG dizgesiyle doğrular
  • DOMDocument::validate() - Belgeyi DTD'sine göre doğrular

DOMDocument::schemaValidate
DOMDocument::validate
DOMDocument


Belgeyi DTD'sine göre doğrular

DOMDocument::schemaValidateSource
DOMDocument::xinclude
DOMDocument
PHP Manual

DOMDocument::validate

(PHP 5, PHP 7)

DOMDocument::validate — Belgeyi DTD'sine göre doğrular

Açıklama

bool DOMDocument::validate ( void )

Belgeyi DTD'sine göre doğrular.

Bir DTD doğrulaması yapmak için DOMDocument sınıfının validateOnParse özelliği de kullanılabilir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner. Belgeye ekli bir DTD yoksa bu yöntem FALSE döndürür.

Örnekler

Örnek 1 - DTD'ye göre doğrulama örneği

<?php
$dom = new DOMDocument;
$dom->Load('book.xml');
if ($dom->validate()) {
    echo "Belge geçerli!\n";
}
?>

XML dosyayı yüklerken de doğrulatmak mümkündür:

<?php
$dom = new DOMDocument;
$dom->validateOnParse = true;
$dom->Load('book.xml');
?>

Ayrıca Bakınız

  • DOMDocument::schemaValidate() - Belgeyi bir şema dosyasına göre doğrular
  • DOMDocument::schemaValidateSource() - Belgeyi bir şema dizgesine göre doğrular
  • DOMDocument::relaxNGValidate() - Belgeyi belirtilen RNG dosyasıyla doğrular
  • DOMDocument::relaxNGValidateSource() - Belgeyi belirtilen RNG dizgesiyle doğrular

DOMDocument::schemaValidateSource
DOMDocument::xinclude
DOMDocument


Bir DOMDocument nesnesindeki XInclude dosyalarını belgeye dahil eder

DOMDocument::validate
DOMDocumentFragment
DOMDocument
PHP Manual

DOMDocument::xinclude

(PHP 5, PHP 7)

DOMDocument::xinclude — Bir DOMDocument nesnesindeki XInclude dosyalarını belgeye dahil eder

Açıklama

int DOMDocument::xinclude ([ int $seçenekler ] )

Bir DOMDocument nesnesinde, » XInclude mekanizması kullanılarak belgeye dahil edilen dosyaların içeriklerini yerlerine yerleştirir.

Bilginize:

libxml2'nin öğeleri özdevinimli olarak çözümlemesinden dolayı, eğer dahil edilen XML dosyanın kendine ekli bir DTD'si varsa bu yöntem beklenmedik sonuçlara yol açabilir.

Değiştirgeler

seçenekler

libxml sabitleri. PHP 5.1.0 ve Libxml 2.6.7'den itibaren kullanılabilmektedir.

Dönen Değerler

Belgeye dahil edilen dosyaların sayısı.

Örnekler

Örnek 1 - DOMDocument::xinclude() örneği

<?php

$xml = <<<EOD
<?xml version="1.0" ?>
<chapter xmlns:xi="http://www.w3.org/2001/XInclude">
 <title>Yabancı kitapları</title>
 <para>
  <xi:include href="kitap.xml">
   <xi:fallback>
    <error>xinclude: kitap.xml dosyasına rastlanmadı</error>
   </xi:fallback>
  </xi:include>
 </para>
</chapter>
EOD;

$dom = new DOMDocument;

// çıktı göze hoş görünsün
$dom->preserveWhiteSpace = false;
$dom->formatOutput = true;

// yutarıdaki XML dizgeyi yükleyelim
$dom->loadXML($xml);

// dahil edilecek dosyaların içeriklerini alalım
$dom->xinclude();

echo $dom->saveXML();

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

<?xml version="1.0"?>
<chapter xmlns:xi="http://www.w3.org/2001/XInclude">
  <title>Yabancı kitaplar</title>
  <para>
    <row xml:base="/home/didou/book.xml">
       <entry>The Grapes of Wrath</entry>
       <entry>John Steinbeck</entry>
       <entry>en</entry>
       <entry>0140186409</entry>
      </row>
    <row xml:base="/home/didou/book.xml">
       <entry>The Pearl</entry>
       <entry>John Steinbeck</entry>
       <entry>en</entry>
       <entry>014017737X</entry>
      </row>
    <row xml:base="/home/didou/book.xml">
       <entry>Samarcande</entry>
       <entry>Amine Maalouf</entry>
       <entry>fr</entry>
       <entry>2253051209</entry>
      </row>
  </para>
</chapter>

DOMDocument::validate
DOMDocumentFragment
DOMDocument


DOMDocumentFragment sınıfı

(PHP 5, PHP 7)

Sınıf Sözdizimi

DOMDocumentFragment extends DOMNode {
/* Özellikler */
/* Yöntemler */
bool appendXML ( string $veri )
/* Miras alınan yöntemler */
DOMNode DOMNode::appendChild ( DOMNode $yeni )
public string DOMNode::C14N ([ bool $exclusive [, bool $with_comments [, array $xpath [, array $ns_prefixes ]]]] )
public int DOMNode::C14NFile ( string $uri [, bool $exclusive [, bool $with_comments [, array $xpath [, array $ns_prefixes ]]]] )
DOMNode DOMNode::cloneNode ([ bool $torunlar_dahil = TRUE ] )
public int DOMNode::getLineNo ( void )
public string DOMNode::getNodePath ( void )
bool DOMNode::hasAttributes ( void )
bool DOMNode::hasChildNodes ( void )
DOMNode DOMNode::insertBefore ( DOMNode $yeni [, DOMNode $mevcut ] )
bool DOMNode::isDefaultNamespace ( string $uri )
bool DOMNode::isSameNode ( DOMNode $düğüm )
bool DOMNode::isSupported ( string $özellik , string $sürüm )
string DOMNode::lookupNamespaceURI ( string $önek )
string DOMNode::lookupPrefix ( string $uri )
void DOMNode::normalize ( void )
DOMNode DOMNode::removeChild ( DOMNode $eski )
DOMNode DOMNode::replaceChild ( DOMNode $yeni , DOMNode $eski )
}

İçindekiler

  • DOMDocumentFragment::appendXML — Ham bir XML verisi ekler
DOMDocument::xinclude
DOMDocumentFragment::appendXML
DOM


Ham bir XML verisi ekler

DOMDocumentFragment
DOMDocumentType
DOMDocumentFragment
PHP Manual

DOMDocumentFragment::appendXML

(PHP 5 >= 5.1.0, PHP 7)

DOMDocumentFragment::appendXML — Ham bir XML verisi ekler

Açıklama

bool DOMDocumentFragment::appendXML ( string $veri )

Bir DOMDocumentFragment nesnesine ham bir XML verisi ekler.

Bu yöntem DOM standardının bir parçası değildir. Bir DOMDocument nesnesine bir XML belge parçası eklemek için basit bir yaklaşım olarak gerçeklenmiştir.

Standardla tam uyum içinde olmak isterseniz, sahte bir kök elemana sahip geçici bir DOMDocument oluşturup XML verinizi ekleyeceğiniz kök elemanın çocuk düğümleriyle bir döngüye girmelisiniz.

Değiştirgeler

veri

Eklenecek XML veri.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Belgeye XML veri eklemek

<?php
$doc = new DOMDocument();
$doc->loadXML("<root/>");
$f = $doc->createDocumentFragment();
$f->appendXML("<foo>text</foo><bar>text2</bar>");
$doc->documentElement->appendChild($f);
echo $doc->saveXML();
?>

Yukarıdaki örneğin çıktısı:

<?xml version="1.0"?>
<root><foo>text</foo><bar>text2</bar></root>

DOMDocumentFragment
DOMDocumentType
DOMDocumentFragment


DOMDocumentType sınıfı

(PHP 5, PHP 7)

Giriş

Her DOMDocument nesnesi, değeri NULL veya bir DOMDocumentType nesnesi olabilen bir doctype özniteliğine sahiptir.

Sınıf Sözdizimi

DOMDocumentType extends DOMNode {
/* Özellikler */
readonly public string $publicId ;
readonly public string $systemId ;
readonly public string $name ;
readonly public DOMNamedNodeMap $entities ;
readonly public DOMNamedNodeMap $notations ;
readonly public string $internalSubset ;
/* Miras alınan yöntemler */
DOMNode DOMNode::appendChild ( DOMNode $yeni )
public string DOMNode::C14N ([ bool $exclusive [, bool $with_comments [, array $xpath [, array $ns_prefixes ]]]] )
public int DOMNode::C14NFile ( string $uri [, bool $exclusive [, bool $with_comments [, array $xpath [, array $ns_prefixes ]]]] )
DOMNode DOMNode::cloneNode ([ bool $torunlar_dahil = TRUE ] )
public int DOMNode::getLineNo ( void )
public string DOMNode::getNodePath ( void )
bool DOMNode::hasAttributes ( void )
bool DOMNode::hasChildNodes ( void )
DOMNode DOMNode::insertBefore ( DOMNode $yeni [, DOMNode $mevcut ] )
bool DOMNode::isDefaultNamespace ( string $uri )
bool DOMNode::isSameNode ( DOMNode $düğüm )
bool DOMNode::isSupported ( string $özellik , string $sürüm )
string DOMNode::lookupNamespaceURI ( string $önek )
string DOMNode::lookupPrefix ( string $uri )
void DOMNode::normalize ( void )
DOMNode DOMNode::removeChild ( DOMNode $eski )
DOMNode DOMNode::replaceChild ( DOMNode $yeni , DOMNode $eski )
}

Özellikler

publicId

Harici alt kümenin genel betimleyicisi.

systemId

Harici alt kümenin sistem betimleyicisi. Bu bir mutlak URI olabileceği gibi olmayabilir de.

name

DTD ismi; yani, DOCTYPE anahtar sözcüğünden sonra gelen sözcük.

entities

DTD'de bildirilmiş harici ve dahili genel öğeleri içeren bir DOMNamedNodeMap nesnesi.

notations

DTD'de bildirilmiş gösterimleri içeren bir DOMNamedNodeMap nesnesi.

internalSubset

Bir dizge olarak dahili alt küme; hiçbir şey yoksa NULL. Sınırlayıcı köşeli ayraçları içermez.

DOMDocumentFragment::appendXML
DOMElement
DOM


DOMElement sınıfı

(PHP 5, PHP 7)

Sınıf Sözdizimi

DOMElement extends DOMNode {
/* Özellikler */
readonly public bool $schemaTypeInfo ;
readonly public string $tagName ;
/* Yöntemler */
__construct ( string $isim [, string $değer [, string $uri ]] )
string getAttribute ( string $isim )
DOMAttr getAttributeNode ( string $isim )
DOMAttr getAttributeNodeNS ( string $uri , string $isim )
string getAttributeNS ( string $uri , string $isim )
DOMNodeList getElementsByTagName ( string $isim )
DOMNodeList getElementsByTagNameNS ( string $uri , string $önekli_isim )
bool hasAttribute ( string $isim )
bool hasAttributeNS ( string $uri , string $önekli_isim )
bool removeAttribute ( string $isim )
bool removeAttributeNode ( DOMAttr $öznitelik )
bool removeAttributeNS ( string $uri , string $isim )
DOMAttr setAttribute ( string $isim , string $değer )
DOMAttr setAttributeNode ( DOMAttr $öznitelik )
DOMAttr setAttributeNodeNS ( DOMAttr $öznitelik )
void setAttributeNS ( string $uri , string $önekli_isim , string $değer )
void setIdAttribute ( string $isim , bool $id_olarak )
void setIdAttributeNode ( DOMAttr $öznitelik , bool $id_olarak )
void setIdAttributeNS ( string $uri , string $isim , bool $id_olarak )
/* Miras alınan yöntemler */
DOMNode DOMNode::appendChild ( DOMNode $yeni )
public string DOMNode::C14N ([ bool $exclusive [, bool $with_comments [, array $xpath [, array $ns_prefixes ]]]] )
public int DOMNode::C14NFile ( string $uri [, bool $exclusive [, bool $with_comments [, array $xpath [, array $ns_prefixes ]]]] )
DOMNode DOMNode::cloneNode ([ bool $torunlar_dahil = TRUE ] )
public int DOMNode::getLineNo ( void )
public string DOMNode::getNodePath ( void )
bool DOMNode::hasAttributes ( void )
bool DOMNode::hasChildNodes ( void )
DOMNode DOMNode::insertBefore ( DOMNode $yeni [, DOMNode $mevcut ] )
bool DOMNode::isDefaultNamespace ( string $uri )
bool DOMNode::isSameNode ( DOMNode $düğüm )
bool DOMNode::isSupported ( string $özellik , string $sürüm )
string DOMNode::lookupNamespaceURI ( string $önek )
string DOMNode::lookupPrefix ( string $uri )
void DOMNode::normalize ( void )
DOMNode DOMNode::removeChild ( DOMNode $eski )
DOMNode DOMNode::replaceChild ( DOMNode $yeni , DOMNode $eski )
}

Özellikler

schemaTypeInfo

Henüz gerçeklenmedi; daima NULL döndürür.

tagName

Elemanın ismi

İçindekiler

  • DOMElement::__construct — Yeni bir DOMElement nesnesi oluşturur
  • DOMElement::getAttribute — İsmi belirtilen özniteliğin değerini döndürür
  • DOMElement::getAttributeNode — İsmi belirtilen öznitelik düğümünü döndürür
  • DOMElement::getAttributeNodeNS — İsmi ve isim alanı belirtilen öznitelik düğümünü döndürür
  • DOMElement::getAttributeNS — İsmi ve isim alanı belirtilen özniteliğin değerini döndürür
  • DOMElement::getElementsByTagName — İsmi belirtilen elemanları döndürür
  • DOMElement::getElementsByTagNameNS — İsmi ve isim alanı belirtilen elemanları döndürür
  • DOMElement::hasAttribute — İsmi belirtilen öznitelik mevcut mu diye bakar
  • DOMElement::hasAttributeNS — Belirtilen isim alanlı öznitelik var mı diye bakar
  • DOMElement::removeAttribute — İsmi belirtilen özniteliği siler
  • DOMElement::removeAttributeNode — Belirtilen öznitelik düğümünü siler
  • DOMElement::removeAttributeNS — İsmi ve isim alanı belirtilen özniteliği siler
  • DOMElement::setAttribute — Yeni bir öznitelik ekler
  • DOMElement::setAttributeNode — Elemana yeni bir öznitelik düğümü ekler
  • DOMElement::setAttributeNodeNS — Elemana isim alanlı yeni bir öznitelik düğümü ekler
  • DOMElement::setAttributeNS — İsim alanlı yeni bir öznitelik ekler
  • DOMElement::setIdAttribute — İsmi belirtilen özniteliği bir ID özniteliği olarak tanımlar
  • DOMElement::setIdAttributeNode — Belirtilen öznitelik düğümünü ID türünde bir öznitelik düğümü haline getirir
  • DOMElement::setIdAttributeNS — İsmi ve isim alanı belirtilen özniteliği bir ID özniteliği olarak tanımlar
DOMDocumentType
DOMElement::__construct
DOM


Yeni bir DOMElement nesnesi oluşturur

DOMElement
DOMElement::getAttribute
DOMElement
PHP Manual

DOMElement::__construct

(PHP 5, PHP 7)

DOMElement::__construct — Yeni bir DOMElement nesnesi oluşturur

Açıklama

__construct ( string $isim [, string $değer [, string $uri ]] )

Yeni bir DOMElement nesnesi oluşturur. Bu nesne salt okunurdur. Nesne bu haliyle bir belgeye eklenebilir, fakat belge ile ilişkilendirilinceye kadar yeni bir düğüm eklenemez. Yazılabilir bir düğüm oluşturmak için DOMDocument::createElement() veya DOMDocument::createElementNS() yöntemlerini kullanın.

Değiştirgeler

isim

Elemanın etiket ismi. Bir isim alanı betimleyicisi belirtildiği takdirde eleman ismi bu isim alanı ile ilişkili bir önek alabilir.

değer

Elemanın değeri.

uri

Elemanın bir isim alanına ait olması halinde bu isim alanını betimleyen adres.

Örnekler

Örnek 1 - Yeni bir DOMElement oluşturmak

<?php

$dom = new DOMDocument('1.0', 'utf-8');
$element = $dom->appendChild(new DOMElement('kök'));
$element_ns = new DOMElement('bir:düğüm1', 'birdeğer', 'http://rst');
$element->appendChild($element_ns);
echo $dom->saveXML(); /* <?xml version="1.0" encoding="utf-8"?>
<kök><bir:düğüm1 xmlns:bu="http://rst">birdeğer</bir:düğüm1></kök> */

?>

Ayrıca Bakınız

  • DOMDocument::createElement() - Yeni bir eleman düğümü oluşturur
  • DOMDocument::createElementNS() - İsim alanlı bir eleman düğümü oluşturur

DOMElement
DOMElement::getAttribute
DOMElement


İsmi belirtilen özniteliğin değerini döndürür

DOMElement::__construct
DOMElement::getAttributeNode
DOMElement
PHP Manual

DOMElement::getAttribute

(PHP 5, PHP 7)

DOMElement::getAttribute — İsmi belirtilen özniteliğin değerini döndürür

Açıklama

string DOMElement::getAttribute ( string $isim )

Düğümün ismi belirtilen özniteliğinin değerini döndürür.

Değiştirgeler

isim

Özniteliğin ismi.

Dönen Değerler

isim özniteliği yoksa boş bir dizge, varsa öznitelik değerini içeren bir dizge döner.

Ayrıca Bakınız

  • DOMElement::hasAttribute() - İsmi belirtilen öznitelik mevcut mu diye bakar
  • DOMElement::setAttribute() - Yeni bir öznitelik ekler
  • DOMElement::removeAttribute() - İsmi belirtilen özniteliği siler

DOMElement::__construct
DOMElement::getAttributeNode
DOMElement


İsmi belirtilen öznitelik düğümünü döndürür

DOMElement::getAttribute
DOMElement::getAttributeNodeNS
DOMElement
PHP Manual

DOMElement::getAttributeNode

(PHP 5, PHP 7)

DOMElement::getAttributeNode — İsmi belirtilen öznitelik düğümünü döndürür

Açıklama

DOMAttr DOMElement::getAttributeNode ( string $isim )

Düğümün ismi belirtilen öznitelik düğümünü döndürür.

Değiştirgeler

isim

Özniteliğin ismi.

Dönen Değerler

Öznitelik düğümü.

Ayrıca Bakınız

  • DOMElement::hasAttribute() - İsmi belirtilen öznitelik mevcut mu diye bakar
  • DOMElement::setAttributeNode() - Elemana yeni bir öznitelik düğümü ekler
  • DOMElement::removeAttributeNode() - Belirtilen öznitelik düğümünü siler

DOMElement::getAttribute
DOMElement::getAttributeNodeNS
DOMElement


İsmi ve isim alanı belirtilen öznitelik düğümünü döndürür

DOMElement::getAttributeNode
DOMElement::getAttributeNS
DOMElement
PHP Manual

DOMElement::getAttributeNodeNS

(PHP 5, PHP 7)

DOMElement::getAttributeNodeNS — İsmi ve isim alanı belirtilen öznitelik düğümünü döndürür

Açıklama

DOMAttr DOMElement::getAttributeNodeNS ( string $uri , string $isim )

Düğümün ismi ve isim alanı belirtilen öznitelik düğümünü döndürür.

Değiştirgeler

uri

İsim alanını betimleyen adres.

isim

önek:öznitelik biçeminde öznitelik ismi.

Dönen Değerler

Öznitelik düğümü.

Ayrıca Bakınız

  • DOMElement::hasAttributeNS() - Belirtilen isim alanlı öznitelik var mı diye bakar
  • DOMElement::setAttributeNodeNS() - Elemana isim alanlı yeni bir öznitelik düğümü ekler
  • DOMElement::removeAttributeNode() - Belirtilen öznitelik düğümünü siler

DOMElement::getAttributeNode
DOMElement::getAttributeNS
DOMElement


İsmi ve isim alanı belirtilen özniteliğin değerini döndürür

DOMElement::getAttributeNodeNS
DOMElement::getElementsByTagName
DOMElement
PHP Manual

DOMElement::getAttributeNS

(PHP 5, PHP 7)

DOMElement::getAttributeNS — İsmi ve isim alanı belirtilen özniteliğin değerini döndürür

Açıklama

string DOMElement::getAttributeNS ( string $uri , string $isim )

Düğümün ismi ve isim alanı belirtilen özniteliğinin değerini döndürür.

Değiştirgeler

uri

İsim alanını betimleyen adres.

isim

önek:öznitelik biçeminde öznitelik ismi.

Dönen Değerler

isim özniteliği yoksa boş bir dizge, varsa öznitelik değerini içeren bir dizge döner.

Ayrıca Bakınız

  • DOMElement::hasAttributeNS() - Belirtilen isim alanlı öznitelik var mı diye bakar
  • DOMElement::setAttributeNS() - İsim alanlı yeni bir öznitelik ekler
  • DOMElement::removeAttributeNS() - İsmi ve isim alanı belirtilen özniteliği siler

DOMElement::getAttributeNodeNS
DOMElement::getElementsByTagName
DOMElement


İsmi belirtilen elemanları döndürür

DOMElement::getAttributeNS
DOMElement::getElementsByTagNameNS
DOMElement
PHP Manual

DOMElement::getElementsByTagName

(PHP 5, PHP 7)

DOMElement::getElementsByTagName — İsmi belirtilen elemanları döndürür

Açıklama

DOMNodeList DOMElement::getElementsByTagName ( string $isim )

Düğümün ismi belirtilen alt düğümlerini rastlandıkları sıra ile ve alt düğümleri ile içeren yeni bir DOMNodeList nesnesi döndürür.

Değiştirgeler

isim

Etiket ismi. Tüm eleman ağacını döndürmek için * belirtin.

Dönen Değerler

Eşleşen tüm elemanları içeren yeni bir DOMNodeList nesnesi döner.

Ayrıca Bakınız

  • DOMElement::getElementsByTagNameNS() - İsmi ve isim alanı belirtilen elemanları döndürür

DOMElement::getAttributeNS
DOMElement::getElementsByTagNameNS
DOMElement


İsmi ve isim alanı belirtilen elemanları döndürür

DOMElement::getElementsByTagName
DOMElement::hasAttribute
DOMElement
PHP Manual

DOMElement::getElementsByTagNameNS

(PHP 5, PHP 7)

DOMElement::getElementsByTagNameNS — İsmi ve isim alanı belirtilen elemanları döndürür

Açıklama

DOMNodeList DOMElement::getElementsByTagNameNS ( string $uri , string $önekli_isim )

Düğümün ismi ve isim alanı belirtilen alt düğümlerini rastlandıkları sıra ile ve alt düğümleri ile içeren yeni bir DOMNodeList nesnesi döndürür.

Değiştirgeler

uri

İsim alanını betimleyen adres.

önekli_isim

önek:etiket biçeminde eleman ismi. Tüm eleman ağacını döndürmek için * belirtin.

Dönen Değerler

Eşleşen tüm elemanları içeren yeni bir DOMNodeList nesnesi döner.

Ayrıca Bakınız

  • DOMElement::getElementsByTagName() - İsmi belirtilen elemanları döndürür

DOMElement::getElementsByTagName
DOMElement::hasAttribute
DOMElement


İsmi belirtilen öznitelik mevcut mu diye bakar

DOMElement::getElementsByTagNameNS
DOMElement::hasAttributeNS
DOMElement
PHP Manual

DOMElement::hasAttribute

(PHP 5, PHP 7)

DOMElement::hasAttribute — İsmi belirtilen öznitelik mevcut mu diye bakar

Açıklama

bool DOMElement::hasAttribute ( string $isim )

İsmi belirtilen öznitelik mevcutsa TRUE döndürür.

Değiştirgeler

isim

Özniteliğin ismi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • DOMElement::hasAttributeNS() - Belirtilen isim alanlı öznitelik var mı diye bakar
  • DOMElement::getAttribute() - İsmi belirtilen özniteliğin değerini döndürür
  • DOMElement::setAttribute() - Yeni bir öznitelik ekler
  • DOMElement::removeAttribute() - İsmi belirtilen özniteliği siler

DOMElement::getElementsByTagNameNS
DOMElement::hasAttributeNS
DOMElement


Belirtilen isim alanlı öznitelik var mı diye bakar

DOMElement::hasAttribute
DOMElement::removeAttribute
DOMElement
PHP Manual

DOMElement::hasAttributeNS

(PHP 5, PHP 7)

DOMElement::hasAttributeNS — Belirtilen isim alanlı öznitelik var mı diye bakar

Açıklama

bool DOMElement::hasAttributeNS ( string $uri , string $önekli_isim )

İsmi ve isim alanı belirtilen öznitelik mevcutsa TRUE döndürür.

Değiştirgeler

uri

İsim alanını betimleyen adres.

önekli_isim

önek:etiket biçeminde öznitelik ismi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • DOMElement::hasAttribute() - İsmi belirtilen öznitelik mevcut mu diye bakar
  • DOMElement::getAttributeNS() - İsmi ve isim alanı belirtilen özniteliğin değerini döndürür
  • DOMElement::setAttributeNS() - İsim alanlı yeni bir öznitelik ekler
  • DOMElement::removeAttributeNS() - İsmi ve isim alanı belirtilen özniteliği siler

DOMElement::hasAttribute
DOMElement::removeAttribute
DOMElement


İsmi belirtilen özniteliği siler

DOMElement::hasAttributeNS
DOMElement::removeAttributeNode
DOMElement
PHP Manual

DOMElement::removeAttribute

(PHP 5, PHP 7)

DOMElement::removeAttribute — İsmi belirtilen özniteliği siler

Açıklama

bool DOMElement::removeAttribute ( string $isim )

İsmi belirtilen özniteliği siler.

Değiştirgeler

isim

Silinecek özniteliğin ismi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

DOM_NO_MODIFICATION_ALLOWED_ERR

Düğüm salt okunur ise oluşur.

Ayrıca Bakınız

  • DOMElement::hasAttribute() - İsmi belirtilen öznitelik mevcut mu diye bakar
  • DOMElement::getAttribute() - İsmi belirtilen özniteliğin değerini döndürür
  • DOMElement::setAttribute() - Yeni bir öznitelik ekler

DOMElement::hasAttributeNS
DOMElement::removeAttributeNode
DOMElement


Belirtilen öznitelik düğümünü siler

DOMElement::removeAttribute
DOMElement::removeAttributeNS
DOMElement
PHP Manual

DOMElement::removeAttributeNode

(PHP 5, PHP 7)

DOMElement::removeAttributeNode — Belirtilen öznitelik düğümünü siler

Açıklama

bool DOMElement::removeAttributeNode ( DOMAttr $öznitelik )

öznitelik düğümünü eleman düğümünden siler.

Değiştirgeler

öznitelik

Silinecek öznitelik düğümü.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

DOM_NO_MODIFICATION_ALLOWED_ERR

Düğüm salt okunur ise oluşur.

DOM_NOT_FOUND_ERROR

öznitelik, bu düğümün bir özniteliği değilse oluşur.

Ayrıca Bakınız

  • DOMElement::hasAttribute() - İsmi belirtilen öznitelik mevcut mu diye bakar
  • DOMElement::getAttributeNode() - İsmi belirtilen öznitelik düğümünü döndürür
  • DOMElement::setAttributeNode() - Elemana yeni bir öznitelik düğümü ekler

DOMElement::removeAttribute
DOMElement::removeAttributeNS
DOMElement


İsmi ve isim alanı belirtilen özniteliği siler

DOMElement::removeAttributeNode
DOMElement::setAttribute
DOMElement
PHP Manual

DOMElement::removeAttributeNS

(PHP 5, PHP 7)

DOMElement::removeAttributeNS — İsmi ve isim alanı belirtilen özniteliği siler

Açıklama

bool DOMElement::removeAttributeNS ( string $uri , string $isim )

İsmi ve isim alanı belirtilen özniteliği siler.

Değiştirgeler

uri

İsim alanını betimleyen adres.

isim

önek:öznitelik biçeminde öznitelik ismi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

DOM_NO_MODIFICATION_ALLOWED_ERR

Düğüm salt okunur ise oluşur.

Ayrıca Bakınız

  • DOMElement::hasAttributeNS() - Belirtilen isim alanlı öznitelik var mı diye bakar
  • DOMElement::getAttributeNS() - İsmi ve isim alanı belirtilen özniteliğin değerini döndürür
  • DOMElement::setAttributeNS() - İsim alanlı yeni bir öznitelik ekler

DOMElement::removeAttributeNode
DOMElement::setAttribute
DOMElement


Yeni bir öznitelik ekler

DOMElement::removeAttributeNS
DOMElement::setAttributeNode
DOMElement
PHP Manual

DOMElement::setAttribute

(PHP 5, PHP 7)

DOMElement::setAttribute — Yeni bir öznitelik ekler

Açıklama

DOMAttr DOMElement::setAttribute ( string $isim , string $değer )

İsmi ve değeri belirtilen özniteliği tanımlar. Öznitelik düğümde mevcut değilse oluşturulur.

Değiştirgeler

isim

Özniteliğin ismi.

değer

Özniteliğin değeri.

Dönen Değerler

Bir hata durumunda FALSE, aksi takdirde yeni bir DOMAttr nesnesi döner.

Hatalar/İstisnalar

DOM_NO_MODIFICATION_ALLOWED_ERR

Düğüm salt okunur ise oluşur.

Örnekler

Örnek 1 - Bir özniteliğin atanması

<?php
$doc = new DOMDocument("1.0");
$node = $doc->createElement("para");
$newnode = $doc->appendChild($node);
$newnode->setAttribute("align", "left");
?>

Ayrıca Bakınız

  • DOMElement::hasAttribute() - İsmi belirtilen öznitelik mevcut mu diye bakar
  • DOMElement::getAttribute() - İsmi belirtilen özniteliğin değerini döndürür
  • DOMElement::removeAttribute() - İsmi belirtilen özniteliği siler

DOMElement::removeAttributeNS
DOMElement::setAttributeNode
DOMElement


Elemana yeni bir öznitelik düğümü ekler

DOMElement::setAttribute
DOMElement::setAttributeNodeNS
DOMElement
PHP Manual

DOMElement::setAttributeNode

(PHP 5, PHP 7)

DOMElement::setAttributeNode — Elemana yeni bir öznitelik düğümü ekler

Açıklama

DOMAttr DOMElement::setAttributeNode ( DOMAttr $öznitelik )

Elemana öznitelik düğümünü ekler.

Değiştirgeler

öznitelik

Eklenecek öznitelik düğümü.

Dönen Değerler

Öznitelik mevcut olanla değiştirilmişse eski düğümü yoksa NULL döndürür.

Hatalar/İstisnalar

DOM_NO_MODIFICATION_ALLOWED_ERR

Düğüm salt okunur ise oluşur.

Ayrıca Bakınız

  • DOMElement::hasAttribute() - İsmi belirtilen öznitelik mevcut mu diye bakar
  • DOMElement::getAttributeNode() - İsmi belirtilen öznitelik düğümünü döndürür
  • DOMElement::removeAttributeNode() - Belirtilen öznitelik düğümünü siler

DOMElement::setAttribute
DOMElement::setAttributeNodeNS
DOMElement


Elemana isim alanlı yeni bir öznitelik düğümü ekler

DOMElement::setAttributeNode
DOMElement::setAttributeNS
DOMElement
PHP Manual

DOMElement::setAttributeNodeNS

(PHP 5, PHP 7)

DOMElement::setAttributeNodeNS — Elemana isim alanlı yeni bir öznitelik düğümü ekler

Açıklama

DOMAttr DOMElement::setAttributeNodeNS ( DOMAttr $öznitelik )

Elemana isim alanlı öznitelik düğümünü ekler.

Değiştirgeler

öznitelik

Eklenecek öznitelik düğümü.

Dönen Değerler

Öznitelik mevcut olanla değiştirilmişse eski düğümü yoksa NULL döndürür.

Hatalar/İstisnalar

DOM_NO_MODIFICATION_ALLOWED_ERR

Düğüm salt okunur ise oluşur.

Ayrıca Bakınız

  • DOMElement::hasAttributeNS() - Belirtilen isim alanlı öznitelik var mı diye bakar
  • DOMElement::getAttributeNodeNS() - İsmi ve isim alanı belirtilen öznitelik düğümünü döndürür
  • DOMElement::removeAttributeNode() - Belirtilen öznitelik düğümünü siler

DOMElement::setAttributeNode
DOMElement::setAttributeNS
DOMElement


İsim alanlı yeni bir öznitelik ekler

DOMElement::setAttributeNodeNS
DOMElement::setIdAttribute
DOMElement
PHP Manual

DOMElement::setAttributeNS

(PHP 5, PHP 7)

DOMElement::setAttributeNS — İsim alanlı yeni bir öznitelik ekler

Açıklama

void DOMElement::setAttributeNS ( string $uri , string $önekli_isim , string $değer )

İsmi, değeri ve isim alanı belirtilen özniteliği tanımlar. Öznitelik düğümde mevcut değilse oluşturulur.

Değiştirgeler

uri

İsim alanını betimleyen adres.

önekli_isim

önek:öznitelik biçeminde öznitelik ismi.

değer

Özniteliğin değeri.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

DOM_NO_MODIFICATION_ALLOWED_ERR

Düğüm salt okunur ise oluşur.

DOM_NAMESPACE_ERR

önekli_isim uygun değilse veya bir önek belirtildiği halde uri olarak NULL verilmişse bu hata oluşur.

Ayrıca Bakınız

  • DOMElement::hasAttributeNS() - Belirtilen isim alanlı öznitelik var mı diye bakar
  • DOMElement::getAttributeNS() - İsmi ve isim alanı belirtilen özniteliğin değerini döndürür
  • DOMElement::removeAttributeNS() - İsmi ve isim alanı belirtilen özniteliği siler

DOMElement::setAttributeNodeNS
DOMElement::setIdAttribute
DOMElement


İsmi belirtilen özniteliği bir ID özniteliği olarak tanımlar

DOMElement::setAttributeNS
DOMElement::setIdAttributeNode
DOMElement
PHP Manual

DOMElement::setIdAttribute

(PHP 5, PHP 7)

DOMElement::setIdAttribute — İsmi belirtilen özniteliği bir ID özniteliği olarak tanımlar

Açıklama

void DOMElement::setIdAttribute ( string $isim , bool $id_olarak )

isim özniteliğini bir ID özniteliği haline getirir.

Değiştirgeler

isim

Özniteliğin ismi.

isId

isim özniteliği bir ID özniteliği olarak bildiriliyorsa TRUE, aksi takdirde FALSE olmalıdır.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

DOM_NO_MODIFICATION_ALLOWED_ERR

Düğüm salt okunursa oluşur.

DOM_NOT_FOUND

isim, bu düğümün bir özniteliği değilse oluşur.

Ayrıca Bakınız

  • DOMDocument::getElementById() - ID'si belirtilen elemanı döndürür
  • DOMElement::setIdAttributeNode() - Belirtilen öznitelik düğümünü ID türünde bir öznitelik düğümü haline getirir
  • DOMElement::setIdAttributeNS() - İsmi ve isim alanı belirtilen özniteliği bir ID özniteliği olarak tanımlar

DOMElement::setAttributeNS
DOMElement::setIdAttributeNode
DOMElement


Belirtilen öznitelik düğümünü ID türünde bir öznitelik düğümü haline getirir

DOMElement::setIdAttribute
DOMElement::setIdAttributeNS
DOMElement
PHP Manual

DOMElement::setIdAttributeNode

(PHP 5, PHP 7)

DOMElement::setIdAttributeNode — Belirtilen öznitelik düğümünü ID türünde bir öznitelik düğümü haline getirir

Açıklama

void DOMElement::setIdAttributeNode ( DOMAttr $öznitelik , bool $id_olarak )

Belirtilen öznitelik düğümünü ID türünde bir öznitelik düğümü haline getirir.

Değiştirgeler

öznitelik

Öznitelik düğümü.

id_olarak

isim özniteliği bir ID özniteliği olarak bildiriliyorsa TRUE, aksi takdirde FALSE olmalıdır.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

DOM_NO_MODIFICATION_ALLOWED_ERR

Düğüm salt okunursa oluşur.

DOM_NOT_FOUND

öznitelik, bu düğümün bir özniteliği değilse oluşur.

Ayrıca Bakınız

  • DOMDocument::getElementById() - ID'si belirtilen elemanı döndürür
  • DOMElement::setIdAttribute() - İsmi belirtilen özniteliği bir ID özniteliği olarak tanımlar
  • DOMElement::setIdAttributeNS() - İsmi ve isim alanı belirtilen özniteliği bir ID özniteliği olarak tanımlar

DOMElement::setIdAttribute
DOMElement::setIdAttributeNS
DOMElement


İsmi ve isim alanı belirtilen özniteliği bir ID özniteliği olarak tanımlar

DOMElement::setIdAttributeNode
DOMEntity
DOMElement
PHP Manual

DOMElement::setIdAttributeNS

(PHP 5, PHP 7)

DOMElement::setIdAttributeNS — İsmi ve isim alanı belirtilen özniteliği bir ID özniteliği olarak tanımlar

Açıklama

void DOMElement::setIdAttributeNS ( string $uri , string $isim , bool $id_olarak )

uri ile belirtilen isim alanındaki isim özniteliğini bir ID özniteliği haline getirir.

Değiştirgeler

uri

Özniteliğin isim alanını betimleyen adres.

isim

önek:öznitelik biçeminde özniteliğin ismi.

id_olarak

isim özniteliği bir ID özniteliği olarak bildiriliyorsa TRUE, aksi takdirde FALSE olmalıdır.

Dönen Değerler

Hiçbir değer dönmez.

Hatalar/İstisnalar

DOM_NO_MODIFICATION_ALLOWED_ERR

Düğüm salt okunursa oluşur.

DOM_NOT_FOUND

isim, bu düğümün bir özniteliği değilse oluşur.

Ayrıca Bakınız

  • DOMDocument::getElementById() - ID'si belirtilen elemanı döndürür
  • DOMElement::setIdAttribute() - İsmi belirtilen özniteliği bir ID özniteliği olarak tanımlar
  • DOMElement::setIdAttributeNode() - Belirtilen öznitelik düğümünü ID türünde bir öznitelik düğümü haline getirir

DOMElement::setIdAttributeNode
DOMEntity
DOMElement


DOMEntity sınıfı

(PHP 5, PHP 7)

Giriş

Bu arayüz, bir XML belgede, çözümlenebilir olsun olmasın, bilinen bir öğeyi temsil eder.

Sınıf Sözdizimi

DOMEntity extends DOMNode {
/* Özellikler */
readonly public string $publicId ;
readonly public string $systemId ;
readonly public string $notationName ;
public string $actualEncoding ;
readonly public string $encoding ;
readonly public string $version ;
/* Miras alınan yöntemler */
DOMNode DOMNode::appendChild ( DOMNode $yeni )
public string DOMNode::C14N ([ bool $exclusive [, bool $with_comments [, array $xpath [, array $ns_prefixes ]]]] )
public int DOMNode::C14NFile ( string $uri [, bool $exclusive [, bool $with_comments [, array $xpath [, array $ns_prefixes ]]]] )
DOMNode DOMNode::cloneNode ([ bool $torunlar_dahil = TRUE ] )
public int DOMNode::getLineNo ( void )
public string DOMNode::getNodePath ( void )
bool DOMNode::hasAttributes ( void )
bool DOMNode::hasChildNodes ( void )
DOMNode DOMNode::insertBefore ( DOMNode $yeni [, DOMNode $mevcut ] )
bool DOMNode::isDefaultNamespace ( string $uri )
bool DOMNode::isSameNode ( DOMNode $düğüm )
bool DOMNode::isSupported ( string $özellik , string $sürüm )
string DOMNode::lookupNamespaceURI ( string $önek )
string DOMNode::lookupPrefix ( string $uri )
void DOMNode::normalize ( void )
DOMNode DOMNode::removeChild ( DOMNode $eski )
DOMNode DOMNode::replaceChild ( DOMNode $yeni , DOMNode $eski )
}

Özellikler

publicId

Belirtilmişse öğe ile ilişkili genel betimleyici, yoksa NULL.

systemId

Belirtilmişse öğe ile ilişkili sistem betimleyici, yoksa NULL. Bir mutlak URI olabileceği gibi olmayabilir de.

notationName

Çözümsüz öğeler için öğenin gösterim ismi. Çözümlenebilen öğeler için NULL.

actualEncoding

Öğe bir harici çözümlenebilir öğe olduğu takdirde, çözümleme sırasında öğe için kullanılan kodlamayı belirten bir öznitelik. Eğer öğe bir dahili alt kümedeyse veya bilinmiyorsa NULL'dur.

encoding

Öğe bir harici çözümlenebilir öğe olduğu takdirde, metin bildiriminin bir parçası olarak öğenin karakter kodlamasını belirten bir özniteliktir, aksi takdirde NULL'dur.

version

Öğe bir harici çözümlenebilir öğe olduğu takdirde, metin bildiriminin bir parçası olarak öğenin sürüm numarasını belirten bir özniteliktir, aksi takdirde NULL'dur.

DOMElement::setIdAttributeNS
DOMEntityReference
DOM


DOMEntityReference sınıfı

(PHP 5, PHP 7)

Sınıf Sözdizimi

DOMEntityReference extends DOMNode {
/* Özellikler */
/* Yöntemler */
__construct ( string $isim )
/* Miras alınan yöntemler */
DOMNode DOMNode::appendChild ( DOMNode $yeni )
public string DOMNode::C14N ([ bool $exclusive [, bool $with_comments [, array $xpath [, array $ns_prefixes ]]]] )
public int DOMNode::C14NFile ( string $uri [, bool $exclusive [, bool $with_comments [, array $xpath [, array $ns_prefixes ]]]] )
DOMNode DOMNode::cloneNode ([ bool $torunlar_dahil = TRUE ] )
public int DOMNode::getLineNo ( void )
public string DOMNode::getNodePath ( void )
bool DOMNode::hasAttributes ( void )
bool DOMNode::hasChildNodes ( void )
DOMNode DOMNode::insertBefore ( DOMNode $yeni [, DOMNode $mevcut ] )
bool DOMNode::isDefaultNamespace ( string $uri )
bool DOMNode::isSameNode ( DOMNode $düğüm )
bool DOMNode::isSupported ( string $özellik , string $sürüm )
string DOMNode::lookupNamespaceURI ( string $önek )
string DOMNode::lookupPrefix ( string $uri )
void DOMNode::normalize ( void )
DOMNode DOMNode::removeChild ( DOMNode $eski )
DOMNode DOMNode::replaceChild ( DOMNode $yeni , DOMNode $eski )
}

İçindekiler

  • DOMEntityReference::__construct — Yeni bir DOMEntityReference nesnesi oluşturur
DOMEntity
DOMEntityReference::__construct
DOM


Yeni bir DOMEntityReference nesnesi oluşturur

DOMEntityReference
DOMException
DOMEntityReference
PHP Manual

DOMEntityReference::__construct

(PHP 5, PHP 7)

DOMEntityReference::__construct — Yeni bir DOMEntityReference nesnesi oluşturur

Açıklama

__construct ( string $isim )

Yeni bir DOMEntityReference nesnesi oluşturur.

Değiştirgeler

isim

Öğe gönderiminin ismi.

Örnekler

Örnek 1 Yeni bir DOMEntityReference oluşturmak

<?php

$dom = new DOMDocument('1.0', 'utf-8');
$element = $dom->appendChild(new DOMElement('root'));
$entity = $element->appendChild(new DOMEntityReference('nbsp'));
echo $dom->saveXML(); /* <?xml version="1.0" encoding="utf-8"?><root>&nbsp;</root> */

?>

Ayrıca Bakınız

  • DOMDocument::createEntityReference() - Yeni bir öğe bildirimi düğümü oluşturur

DOMEntityReference
DOMException
DOMEntityReference


DOMException sınıfı

(PHP 5, PHP 7)

Giriş

Bir işlemin mantıksal sebeplerle yerine getirilmesinin imkansız olduğu durumlarda olduğu gibi, belli durumlarda istisnalar oluşturan DOM işlemleri.

Ayrıca bakınız: İstisnalar.

Sınıf Sözdizimi

DOMException extends Exception {
/* Özellikler */
readonly public int $code ;
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}

Özellikler

code

Üretilen hatanın türünü belirten bir tamsayı.

DOMEntityReference::__construct
DOMImplementation
DOM


DOMImplementation sınıfı

(PHP 5, PHP 7)

Giriş

İşlemleri belli bir belge nesne modeli örneğinden bağımsız olarak gerçekleştirmek için bazı yöntemler sunan bir arayüz.

Sınıf Sözdizimi

DOMImplementation {
/* Özellikler */
/* Yöntemler */
__construct ( void )
DOMDocument createDocument ([ string $uri = NULL [, string $önekliAd = NULL [, DOMDocumentType $belgeTürü = NULL ]]] )
DOMDocumentType createDocumentType ([ string $belgeAdı = NULL [, string $publicId = NULL [, string $systemId = NULL ]]] )
bool hasFeature ( string $özellik , string $sürüm )
}

İçindekiler

  • DOMImplementation::__construct — Yeni bir DOMImplementation nesnesi oluşturur
  • DOMImplementation::createDocument — Belge elemanı belirtilen DOMDocument nesnesini oluşturur
  • DOMImplementation::createDocumentType — Boş bir DOMDocumentType nesnesi oluşturur
  • DOMImplementation::hasFeature — DOM gerçeklenimi belirtilen özelliğe sahip mi diye bakar
DOMException
DOMImplementation::__construct
DOM


Yeni bir DOMImplementation nesnesi oluşturur

DOMImplementation
DOMImplementation::createDocument
DOMImplementation
PHP Manual

DOMImplementation::__construct

(PHP 5, PHP 7)

DOMImplementation::__construct — Yeni bir DOMImplementation nesnesi oluşturur

Açıklama

__construct ( void )

Yeni bir DOMImplementation nesnesi oluşturur.

DOMImplementation
DOMImplementation::createDocument
DOMImplementation


Belge elemanı belirtilen DOMDocument nesnesini oluşturur

DOMImplementation::__construct
DOMImplementation::createDocumentType
DOMImplementation
PHP Manual

DOMImplementation::createDocument

(PHP 5, PHP 7)

DOMImplementation::createDocument — Belge elemanı belirtilen DOMDocument nesnesini oluşturur

Açıklama

DOMDocument DOMImplementation::createDocument ([ string $uri = NULL [, string $önekliAd = NULL [, DOMDocumentType $belgeTürü = NULL ]]] )

Belge elemanı belirtilen DOMDocument nesnesini oluşturur.

Değiştirgeler

uri

Oluşturulacak belge elemanının isim alanını betimleyen adres.

önekliAd

Oluşturulacak belge elemanının isim alanı önekli ismi.

belgeTürü

Oluşturulacak belgenin türü veya NULL.

Dönen Değerler

Yeni bir DOMDocument nesnesi. uri, önekliAd ve belgeTürü olarak NULL belirtilirse belge elemanı olmayan boş bir DOMDocument nesnesi döner.

Hatalar/İstisnalar

DOM_WRONG_DOCUMENT_ERR

belgeTürü başka bir belgede zaten kullanılmışsa veya başka bir gerçeklenim tarafından oluşturulmuşsa bu hata oluşur.

DOM_NAMESPACE_ERR

uri ve önekliAd ile saptanan isim alanı ile ilgili bir hata durumunda bu hata oluşur.

Ayrıca Bakınız

  • DOMDocument::__construct() - Yeni bir DOMDocument nesnesi oluşturur
  • DOMImplementation::createDocumentType() - Boş bir DOMDocumentType nesnesi oluşturur

DOMImplementation::__construct
DOMImplementation::createDocumentType
DOMImplementation


Boş bir DOMDocumentType nesnesi oluşturur

DOMImplementation::createDocument
DOMImplementation::hasFeature
DOMImplementation
PHP Manual

DOMImplementation::createDocumentType

(PHP 5, PHP 7)

DOMImplementation::createDocumentType — Boş bir DOMDocumentType nesnesi oluşturur

Açıklama

DOMDocumentType DOMImplementation::createDocumentType ([ string $belgeAdı = NULL [, string $publicId = NULL [, string $systemId = NULL ]]] )

Boş bir DOMDocumentType nesnesi oluşturur. Öğe bildirimleri ve gösterimler kullanılabilir değildir. Öğe gönderimi dönüşümleri ve öntanımlı öznitelik eklemeleri yapılmaz.

Değiştirgeler

belgeAdı

Oluşturulacak belgenin nitelikli adı.

publicId

Harici alt kümenin genel betimleyicisi.

systemId

Harici alt kümenin sistem betimleyicisi.

Dönen Değerler

ownerDocument özelliği NULL olmak üzere yeni bir DOMDocumentType nesnesi döner.

Örnekler

Örnek 1 - Bir DTD ekleyerek bir belge oluşturmak

<?php

// Yeni bir DOMImplementation nesnesi oluşturalım
$imp = new DOMImplementation;

// Bir DOMDocumentType nesnesi oluşturalım
$dtd = $imp->createDocumentType('graph', '', 'graph.dtd');

// Bir DOMDocument nesnesi oluşturalım
$dom = $imp->createDocument("", "", $dtd);

// Diğer özellikleri tanımlayalım
$dom->encoding = 'UTF-8';
$dom->standalone = false;

// Boş bir eleman oluşturalım
$element = $dom->createElement('graph');

// Bir eleman ekleyelim
$dom->appendChild($element);

// Belgeyi çıktılayalım
echo $dom->saveXML();

?>

Yukarıdaki örneğin çıktısı:

<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<!DOCTYPE graph SYSTEM "graph.dtd">
<graph/>

Hatalar/İstisnalar

DOM_NAMESPACE_ERR

belgeAdına göre saptanan isim alanı ile ilgili bir hata varsa bu hata oluşur.

Ayrıca Bakınız

  • DOMImplementation::createDocument() - Belge elemanı belirtilen DOMDocument nesnesini oluşturur

DOMImplementation::createDocument
DOMImplementation::hasFeature
DOMImplementation


DOM gerçeklenimi belirtilen özelliğe sahip mi diye bakar

DOMImplementation::createDocumentType
DOMNamedNodeMap
DOMImplementation
PHP Manual

DOMImplementation::hasFeature

(PHP 5, PHP 7)

DOMImplementation::hasFeature — DOM gerçeklenimi belirtilen özelliğe sahip mi diye bakar

Açıklama

bool DOMImplementation::hasFeature ( string $özellik , string $sürüm )

DOM gerçeklenimi belirtilen özelliğe sahip mi diye bakar.

Özelliklerin tam listesini DOM belirtiminin » Conformance bölümünde bulabilirsiniz.

Değiştirgeler

özellik

Varlığı sınanacak özellik.

sürüm

Varlığı sınanacak özelliğin sürümü. 2. seviyede bu değer 2.0 veya 1.0 olabilir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - DOM Gerçekleniminin özellikleri

<?php

$features = array(
  'Core'           => 'Çekirdek modülü',
  'XML'            => 'XML modülü',
  'HTML'           => 'HTML modülü',
  'Views'          => 'Görünüm modülü',
  'Stylesheets'    => 'XSLT modülü',
  'CSS'            => 'CSS modülü',
  'CSS2'           => 'CSS2 modülü',
  'Events'         => 'Olay modülü',
  'UIEvents'       => 'Kullanıcı arayüzü olay modülü',
  'MouseEvents'    => 'Fare olayları modülü',
  'MutationEvents' => 'Başkalaşım olayları modülü',
  'HTMLEvents'     => 'HTML olayları modülü',
  'Range'          => 'Aralık modülü',
  'Traversal'      => 'Geçişli modül'
);

foreach ($features as $isim => $özellik) {
  if (DOMImplementation::hasFeature($key, '2.0')) {
    echo "$özellik var\n";
  } else {
    echo "$özellik yok\n";
  }
}

?>

Ayrıca Bakınız

  • DOMNode::isSupported() - Özelliğin belirtilen sürümünün desteklenip desteklenmediğine bakar

DOMImplementation::createDocumentType
DOMNamedNodeMap
DOMImplementation


DOMNamedNodeMap sınıfı

(PHP 5, PHP 7)

Sınıf Sözdizimi

DOMNamedNodeMap {
/* Özellikler */
/* Yöntemler */
DOMNode getNamedItem ( string $isim )
DOMNode getNamedItemNS ( string $uri , string $önekli_isim )
DOMNode item ( int $indis )
}

İçindekiler

  • DOMNamedNodeMap::getNamedItem — İsmi belirtilen düğümü döndürür
  • DOMNamedNodeMap::getNamedItemNS — İsmi ve isim alanı belirtilen düğümü döndürür
  • DOMNamedNodeMap::item — İndisi belirtilen düğümü döndürür
DOMImplementation::hasFeature
DOMNamedNodeMap::getNamedItem
DOM


İsmi belirtilen düğümü döndürür

DOMNamedNodeMap
DOMNamedNodeMap::getNamedItemNS
DOMNamedNodeMap
PHP Manual

DOMNamedNodeMap::getNamedItem

(PHP 5, PHP 7)

DOMNamedNodeMap::getNamedItem — İsmi belirtilen düğümü döndürür

Açıklama

DOMNode DOMNamedNodeMap::getNamedItem ( string $isim )

İsmi belirtilen düğümü döndürür.

Değiştirgeler

isim

Döndürülecek düğümün ismi.

Dönen Değerler

Belirtilen düğüm yoksa NULL varsa düğümü döndürür.

Ayrıca Bakınız

  • DOMNamedNodeMap::getNamedItemNS() - İsmi ve isim alanı belirtilen düğümü döndürür

DOMNamedNodeMap
DOMNamedNodeMap::getNamedItemNS
DOMNamedNodeMap


İsmi ve isim alanı belirtilen düğümü döndürür

DOMNamedNodeMap::getNamedItem
DOMNamedNodeMap::item
DOMNamedNodeMap
PHP Manual

DOMNamedNodeMap::getNamedItemNS

(PHP 5, PHP 7)

DOMNamedNodeMap::getNamedItemNS — İsmi ve isim alanı belirtilen düğümü döndürür

Açıklama

DOMNode DOMNamedNodeMap::getNamedItemNS ( string $uri , string $önekli_isim )

İsmi ve isim alanı belirtilen düğümü döndürür.

Değiştirgeler

uri

İsim alanını betimleyen adres.

önekli_isim

önek:etiket biçeminde öznitelik ismi.

Dönen Değerler

Belirtilen düğüm yoksa NULL varsa düğümü döndürür.

Ayrıca Bakınız

  • DOMNamedNodeMap::getNamedItem() - İsmi belirtilen düğümü döndürür

DOMNamedNodeMap::getNamedItem
DOMNamedNodeMap::item
DOMNamedNodeMap


İndisi belirtilen düğümü döndürür

DOMNamedNodeMap::getNamedItemNS
DOMNode
DOMNamedNodeMap
PHP Manual

DOMNamedNodeMap::item

(PHP 5, PHP 7)

DOMNamedNodeMap::item — İndisi belirtilen düğümü döndürür

Açıklama

DOMNode DOMNamedNodeMap::item ( int $indis )

DOMNamedNodeMap nesnesinin indis'inci düğümünü döndürür.

Değiştirgeler

indis

Eşlemdeki indis.

Dönen Değerler

Geçerli bir indis belirtilmemişse (indis düğüm sayısına eşit veya ondan büyükse) NULL, aksi takdirde listedeki indis'inci düğümü döndürür.

DOMNamedNodeMap::getNamedItemNS
DOMNode
DOMNamedNodeMap


DOMNode sınıfı

(PHP 5, PHP 7)

Sınıf Sözdizimi

DOMNode {
/* Özellikler */
public readonly string $nodeName ;
public string $nodeValue ;
public readonly int $nodeType ;
public readonly DOMNode $parentNode ;
public readonly DOMNodeList $childNodes ;
public readonly DOMNode $firstChild ;
public readonly DOMNode $lastChild ;
public readonly DOMNode $previousSibling ;
public readonly DOMNode $nextSibling ;
public readonly DOMNamedNodeMap $attributes ;
public readonly DOMDocument $ownerDocument ;
public readonly string $namespaceURI ;
public string $prefix ;
public readonly string $localName ;
public readonly string $baseURI ;
public string $textContent ;
/* Yöntemler */
DOMNode appendChild ( DOMNode $yeni )
public string C14N ([ bool $exclusive [, bool $with_comments [, array $xpath [, array $ns_prefixes ]]]] )
public int C14NFile ( string $uri [, bool $exclusive [, bool $with_comments [, array $xpath [, array $ns_prefixes ]]]] )
DOMNode cloneNode ([ bool $torunlar_dahil = TRUE ] )
public int getLineNo ( void )
public string getNodePath ( void )
bool hasAttributes ( void )
bool hasChildNodes ( void )
DOMNode insertBefore ( DOMNode $yeni [, DOMNode $mevcut ] )
bool isDefaultNamespace ( string $uri )
bool isSameNode ( DOMNode $düğüm )
bool isSupported ( string $özellik , string $sürüm )
string lookupNamespaceURI ( string $önek )
string lookupPrefix ( string $uri )
void normalize ( void )
DOMNode removeChild ( DOMNode $eski )
DOMNode replaceChild ( DOMNode $yeni , DOMNode $eski )
}

Özellikler

nodeName

Geçerli düğüm türü için en doğru ismi döndürür.

nodeValue

Düğümün türüne bağlı olarak düğümün değeri.

nodeType

XML_xxx_NODE sabitlerinden biri olarak düğüm türü.

parentNode

Düğümün ebeveyni.

childNodes

Düğümün tüm çocuklarını içeren bir DOMNodeList nesnesi; düğüm çocuksuzsa boş bir DOMNodeList nesnesidir.

firstChild

Düğümün ilk çocuğu; yoksa NULL'dur.

lastChild

Düğümün son çocuğu; yoksa NULL'dur.

previousSibling

Bir önceki kardeş düğüm; yoksa NULL'dur.

nextSibling

Bir sonraki kardeş düğüm; yoksa NULL'dur.

attributes

Düğüm bir DOMElement nesnesi ise düğümün özniteliklerini içeren bir DOMNamedNodeMap nesnesi, yoksa NULL'dur.

ownerDocument

Düğümün ait olduğu DOMDocument nesnesi.

namespaceURI

Belirtilmişse düğümün isim alanını betimleyen adres; yoksa NULL'dur.

prefix

Belirtilmişse düğümün isim alanı öneki; yoksa NULL'dur.

localName

Düğümün nitelikli isminin yerel kısmı.

baseURI

Düğümün mutlak adresi; eğer gerçeklenim bir mutlak adres sağlayamıyorsa NULL'dur.

textContent

Düğümün kendinin, çocuk ve torunlarının metin içeriği.

Ayrıca Bakınız

  • » Node arayüzünün W3C belirtimi

İçindekiler

  • DOMNode::appendChild — Listenin sonuna yeni bir çocuk ekler
  • DOMNode::C14N — Canonicalize nodes to a string
  • DOMNode::C14NFile — Canonicalize nodes to a file
  • DOMNode::cloneNode — Düğümün bir kopyasını yapar
  • DOMNode::getLineNo — Get line number for a node
  • DOMNode::getNodePath — Get an XPath for a node
  • DOMNode::hasAttributes — Düğümün öznitelikleri var mı diye bakar
  • DOMNode::hasChildNodes — Düğümün çocuk düğümleri var mı diye bakar
  • DOMNode::insertBefore — Yeni çocuğu belirtilen çocuğun öncesine yerleştirir
  • DOMNode::isDefaultNamespace — Belirtilen isim alanının öntanımlı olup olmadığına bakar
  • DOMNode::isSameNode — İki düğüm aynı mı diye bakar
  • DOMNode::isSupported — Özelliğin belirtilen sürümünün desteklenip desteklenmediğine bakar
  • DOMNode::lookupNamespaceURI — İsim alanı öneki belirtilen düğümün isim alanı betimleyicisini döndürür
  • DOMNode::lookupPrefix — Belirtilen isim alanıyla ilişkili düğümün isim alanı önekini döndürür
  • DOMNode::normalize — Düğümü normalleştirir
  • DOMNode::removeChild — Listeden belirtilen çocuğu siler
  • DOMNode::replaceChild — Bir çocuk düğümü yenisi ile değiştirir
DOMNamedNodeMap::item
DOMNode::appendChild
DOM


Listenin sonuna yeni bir çocuk ekler

DOMNode
DOMNode::C14N
DOMNode
PHP Manual

DOMNode::appendChild

(PHP 5, PHP 7)

DOMNode::appendChild — Listenin sonuna yeni bir çocuk ekler

Açıklama

DOMNode DOMNode::appendChild ( DOMNode $yeni )

Listeye yeni bir çocuk ekler; liste yoksa oluşturulur. Çocuk DOMDocument::createElement(), DOMDocument::createTextNode() gibi yöntemlerle oluşturulabileceği gibi oluşturulmuş diğer düğümlerden biri de olabilir.

Değiştirgeler

yeni

Listeye eklenecek çocuk.

Dönen Değerler

Eklenen düğüm.

Hatalar/İstisnalar

DOM_NO_MODIFICATION_ALLOWED_ERR

Düğüm salt okunursa veya düğümün önceki ebeveyni salt okunur olarak yerleştirilmişse bu hata oluşur.

DOM_HIERARCHY_REQUEST_ERR

Düğüm, yeni düğümün türündeki çocuk düğümlere izin vermeyen türde ise veya yeni düğüm, çocuğu olacağı düğümün ebeveyni veya atalarından biri ise bu hata oluşur.

DOM_WRONG_DOCUMENT_ERR

Eğer yeni düğüm, çocuğu olacağı düğümü oluşturan belgeden farklı bir belge tarafından oluşturulmuşsa bu hata oluşur.

Örnekler

Aşağıdaki örnekte yeni bir belgeye yeni bir eleman düğümü eklenmektedir.

Örnek 1 - Bir çocuk düğüm eklemek

<?php

$doc = new DOMDocument;

$node = $doc->createElement("para");
$newnode = $doc->appendChild($node);

echo $doc->saveXML();
?>

Ayrıca Bakınız

  • DOMNode::removeChild() - Listeden belirtilen çocuğu siler
  • DOMNode::replaceChild() - Bir çocuk düğümü yenisi ile değiştirir

DOMNode
DOMNode::C14N
DOMNode


Canonicalize nodes to a string

DOMNode::appendChild
DOMNode::C14NFile
DOMNode
PHP Manual

DOMNode::C14N

(PHP 5 >= 5.2.0, PHP 7)

DOMNode::C14N — Canonicalize nodes to a string

Açıklama

public string DOMNode::C14N ([ bool $exclusive [, bool $with_comments [, array $xpath [, array $ns_prefixes ]]]] )

Canonicalize nodes to a string

Değiştirgeler

exclusive

Enable exclusive parsing of only the nodes matched by the provided xpath or namespace prefixes.

with_comments

Retain comments in output.

xpath

An array of xpaths to filter the nodes by.

ns_prefixes

An array of namespace prefixes to filter the nodes by.

Dönen Değerler

Returns canonicalized nodes as a string başarısızlık durumunda FALSE döner

Ayrıca Bakınız

  • DOMNode::C14NFile() - Canonicalize nodes to a file

DOMNode::appendChild
DOMNode::C14NFile
DOMNode


Canonicalize nodes to a file

DOMNode::C14N
DOMNode::cloneNode
DOMNode
PHP Manual

DOMNode::C14NFile

(PHP 5 >= 5.2.0, PHP 7)

DOMNode::C14NFile — Canonicalize nodes to a file

Açıklama

public int DOMNode::C14NFile ( string $uri [, bool $exclusive [, bool $with_comments [, array $xpath [, array $ns_prefixes ]]]] )

Canonicalize nodes to a file.

Değiştirgeler

uri

Path to write the output to.

exclusive

Enable exclusive parsing of only the nodes matched by the provided xpath or namespace prefixes.

with_comments

Retain comments in output.

xpath

An array of xpaths to filter the nodes by.

ns_prefixes

An array of namespace prefixes to filter the nodes by.

Dönen Değerler

Number of bytes written başarısızlık durumunda FALSE döner

Ayrıca Bakınız

  • DOMNode::C14N() - Canonicalize nodes to a string

DOMNode::C14N
DOMNode::cloneNode
DOMNode


Düğümün bir kopyasını yapar

DOMNode::C14NFile
DOMNode::getLineNo
DOMNode
PHP Manual

DOMNode::cloneNode

(PHP 5, PHP 7)

DOMNode::cloneNode — Düğümün bir kopyasını yapar

Açıklama

DOMNode DOMNode::cloneNode ([ bool $torunlar_dahil = TRUE ] )

Düğümün bir kopyasını oluşturur.

Değiştirgeler

torunlar_dahil

Tüm çocuk ve torunların da kopyalanıp kopyalanmayaçağı. Öntanımlı değer: TRUE.

Dönen Değerler

Kopyalanan düğüm.

DOMNode::C14NFile
DOMNode::getLineNo
DOMNode


Get line number for a node

DOMNode::cloneNode
DOMNode::getNodePath
DOMNode
PHP Manual

DOMNode::getLineNo

(PHP 5 >= 5.3.0, PHP 7)

DOMNode::getLineNo — Get line number for a node

Açıklama

public int DOMNode::getLineNo ( void )

Gets line number for where the node is defined.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Always returns the line number where the node was defined in.

Örnekler

Örnek 1 DOMNode::getLineNo() example

<?php
// XML dump for below example
$xml = <<<XML
<?xml version="1.0" encoding="utf-8"?>
<root>
    <node />
</root>
XML;

// Create a new DOMDocument instance
$dom = new DOMDocument;

// Load the XML
$dom->loadXML($xml);

// Print where the line where the 'node' element was defined in
printf('The <node> tag is defined on line %d', $dom->getElementsByTagName('node')->item(0)->getLineNo());
?>

Yukarıdaki örneğin çıktısı:

The <node> tag is defined in line 3

DOMNode::cloneNode
DOMNode::getNodePath
DOMNode


Get an XPath for a node

DOMNode::getLineNo
DOMNode::hasAttributes
DOMNode
PHP Manual

DOMNode::getNodePath

(PHP 5 >= 5.2.0, PHP 7)

DOMNode::getNodePath — Get an XPath for a node

Açıklama

public string DOMNode::getNodePath ( void )

Gets an XPath location path for the node.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns a string containing the XPath, or NULL in case of an error.

Örnekler

Örnek 1 DOMNode::getNodePath() example

<?php
// Create a new DOMDocument instance
$dom = new DOMDocument;

// Load the XML
$dom->loadXML('
<fruits>
 <apples>
  <apple>braeburn</apple>
  <apple>granny smith</apple>
 </apples>
 <pears>
  <pear>conference</pear>
 </pears>
</fruits>
');

// Print XPath for each element
foreach ($dom->getElementsByTagName('*') as $node) {
    echo $node->getNodePath() . "\n";
}
?>

Yukarıdaki örneğin çıktısı:

/fruits
/fruits/apples
/fruits/apples/apple[1]
/fruits/apples/apple[2]
/fruits/pears
/fruits/pears/pear

Ayrıca Bakınız

  • DOMXPath

DOMNode::getLineNo
DOMNode::hasAttributes
DOMNode


Düğümün öznitelikleri var mı diye bakar

DOMNode::getNodePath
DOMNode::hasChildNodes
DOMNode
PHP Manual

DOMNode::hasAttributes

(PHP 5, PHP 7)

DOMNode::hasAttributes — Düğümün öznitelikleri var mı diye bakar

Açıklama

bool DOMNode::hasAttributes ( void )

Bakılan düğümün türü XML_ELEMENT_NODE ise ve öznitelikleri varsa TRUE döner.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • DOMNode::hasChildNodes() - Düğümün çocuk düğümleri var mı diye bakar

DOMNode::getNodePath
DOMNode::hasChildNodes
DOMNode


Düğümün çocuk düğümleri var mı diye bakar

DOMNode::hasAttributes
DOMNode::insertBefore
DOMNode
PHP Manual

DOMNode::hasChildNodes

(PHP 5, PHP 7)

DOMNode::hasChildNodes — Düğümün çocuk düğümleri var mı diye bakar

Açıklama

bool DOMNode::hasChildNodes ( void )

Düğümün çocuk düğümleri varsa TRUE döner.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • DOMNode::hasAttributes() - Düğümün öznitelikleri var mı diye bakar

DOMNode::hasAttributes
DOMNode::insertBefore
DOMNode


Yeni çocuğu belirtilen çocuğun öncesine yerleştirir

DOMNode::hasChildNodes
DOMNode::isDefaultNamespace
DOMNode
PHP Manual

DOMNode::insertBefore

(PHP 5, PHP 7)

DOMNode::insertBefore — Yeni çocuğu belirtilen çocuğun öncesine yerleştirir

Açıklama

DOMNode DOMNode::insertBefore ( DOMNode $yeni [, DOMNode $mevcut ] )

yeni düğümü mevcut düğümün hemen öncesine yerleştirir. Eklenen çocukta değişiklik yapmayı düşünüyorsanız dönen düğümü kullanın.

Değiştirgeler

yeni

Yeni çocuk düğüm.

mevcut

Mevcut çocuk düğüm. Belirtilmediği takdirde yeni düğüm listeye son çocuk olarak eklenir.

Dönen Değerler

Yerleştirilen düğüm.

Hatalar/İstisnalar

DOM_NO_MODIFICATION_ALLOWED_ERR

Düğüm salt okunursa veya düğümün önceki ebeveyni salt okunur olarak yerleştirilmişse bu hata oluşur.

DOM_HIERARCHY_REQUEST_ERR

Düğüm, yeni düğümün türündeki çocuk düğümlere izin vermeyen türde ise veya yeni düğüm, çocuğu olacağı düğümün ebeveyni veya atalarından biri ise bu hata oluşur.

DOM_WRONG_DOCUMENT_ERR

Eğer yeni düğüm, çocuğu olacağı düğümü oluşturan belgeden farklı bir belge tarafından oluşturulmuşsa bu hata oluşur.

DOM_NOT_FOUND

mevcut düğüm, bir çocuk düğüm değilse bu hata oluşur.

DOMNode::hasChildNodes
DOMNode::isDefaultNamespace
DOMNode


Belirtilen isim alanının öntanımlı olup olmadığına bakar

DOMNode::insertBefore
DOMNode::isSameNode
DOMNode
PHP Manual

DOMNode::isDefaultNamespace

(PHP 5, PHP 7)

DOMNode::isDefaultNamespace — Belirtilen isim alanının öntanımlı olup olmadığına bakar

Açıklama

bool DOMNode::isDefaultNamespace ( string $uri )

İsim alanı betimleyicisi uri ile belirtilen isim alanının öntanımlı isim alanı olup olmadığına bakar.

Değiştirgeler

uri

Bakılacak isim alanını betimleyen adres.

Dönen Değerler

uri öntanımlı isim alanını betimliyorsa TRUE aksi takdirde FALSE döner.

DOMNode::insertBefore
DOMNode::isSameNode
DOMNode


İki düğüm aynı mı diye bakar

DOMNode::isDefaultNamespace
DOMNode::isSupported
DOMNode
PHP Manual

DOMNode::isSameNode

(PHP 5, PHP 7)

DOMNode::isSameNode — İki düğüm aynı mı diye bakar

Açıklama

bool DOMNode::isSameNode ( DOMNode $düğüm )

Düğüm, belirtilen düğümle aynı mı diye bakar. Karşılaştırma içeriği göre yapılmaz.

Değiştirgeler

düğüm

Karşılaştırılacak düğüm.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

DOMNode::isDefaultNamespace
DOMNode::isSupported
DOMNode


Özelliğin belirtilen sürümünün desteklenip desteklenmediğine bakar

DOMNode::isSameNode
DOMNode::lookupNamespaceURI
DOMNode
PHP Manual

DOMNode::isSupported

(PHP 5, PHP 7)

DOMNode::isSupported — Özelliğin belirtilen sürümünün desteklenip desteklenmediğine bakar

Açıklama

bool DOMNode::isSupported ( string $özellik , string $sürüm )

özellik özelliğinin sürüm sürümünün gerçeklenim tarafından desteklenip desteklenmediğine bakar.

Değiştirgeler

özellik

Sınanacak özellik. Özelliklerin listesi için DOMImplementation::hasFeature() yöntemine bakınız.

sürüm

Sınanacak özellik özelliğinin sürüm numarası.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • DOMImplementation::hasFeature() - DOM gerçeklenimi belirtilen özelliğe sahip mi diye bakar

DOMNode::isSameNode
DOMNode::lookupNamespaceURI
DOMNode


İsim alanı öneki belirtilen düğümün isim alanı betimleyicisini döndürür

DOMNode::isSupported
DOMNode::lookupPrefix
DOMNode
PHP Manual

DOMNode::lookupNamespaceURI

(PHP 5, PHP 7)

DOMNode::lookupNamespaceURI — İsim alanı öneki belirtilen düğümün isim alanı betimleyicisini döndürür

Açıklama

string DOMNode::lookupNamespaceURI ( string $önek )

İsim alanı öneki önek ile belirtilen düğümün isim alanı betimleyicisini döndürür.

Değiştirgeler

önek

İsim alanı öneki.

Dönen Değerler

İsim alanını betimleyen adres.

Ayrıca Bakınız

  • DOMNode::lookupPrefix() - Belirtilen isim alanıyla ilişkili düğümün isim alanı önekini döndürür

DOMNode::isSupported
DOMNode::lookupPrefix
DOMNode


Belirtilen isim alanıyla ilişkili düğümün isim alanı önekini döndürür

DOMNode::lookupNamespaceURI
DOMNode::normalize
DOMNode
PHP Manual

DOMNode::lookupPrefix

(PHP 5, PHP 7)

DOMNode::lookupPrefix — Belirtilen isim alanıyla ilişkili düğümün isim alanı önekini döndürür

Açıklama

string DOMNode::lookupPrefix ( string $uri )

İsim alanı betimleyicisi uri ile belirtilen isim alanı ile ilişkili düğümün isim alanı önekini döndürür.

Değiştirgeler

uri

İsim alanını betimleyen adres.

Dönen Değerler

İsim alanı öneki.

Ayrıca Bakınız

  • DOMNode::lookupNamespaceURI() - İsim alanı öneki belirtilen düğümün isim alanı betimleyicisini döndürür

DOMNode::lookupNamespaceURI
DOMNode::normalize
DOMNode


Düğümü normalleştirir

DOMNode::lookupPrefix
DOMNode::removeChild
DOMNode
PHP Manual

DOMNode::normalize

(PHP 5, PHP 7)

DOMNode::normalize — Düğümü normalleştirir

Açıklama

void DOMNode::normalize ( void )

Düğümü normalleştirir.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • » DOM Belirtimi
  • DOMDocument::normalizeDocument() - Belgeyi normalleştirir

DOMNode::lookupPrefix
DOMNode::removeChild
DOMNode


Listeden belirtilen çocuğu siler

DOMNode::normalize
DOMNode::replaceChild
DOMNode
PHP Manual

DOMNode::removeChild

(PHP 5, PHP 7)

DOMNode::removeChild — Listeden belirtilen çocuğu siler

Açıklama

DOMNode DOMNode::removeChild ( DOMNode $eski )

Listeden belirtilen çocuğu siler.

Değiştirgeler

eski

Silinecek çocuk.

Dönen Değerler

Belirtilen çocuk silinebilmişse silinen çocuğu döndürür.

Hatalar/İstisnalar

DOM_NO_MODIFICATION_ALLOWED_ERR

Düğüm salt okunursa oluşur.

DOM_NOT_FOUND

eski düğüm listedeki çocuklardan biri değilse oluşur.

Örnekler

Aşağıdaki örnekte, XML belgedeki chapter elemanı silinmektedir.

Örnek 1 Removing a child

<?php

$doc = new DOMDocument;
$doc->load('book.xml');

$kitap = $doc->documentElement;

// chapter elemanını döndürüp $kitaptan siliyoruz
$chapter = $kitap->getElementsByTagName('chapter')->item(0);
$eskisi = $kitap->removeChild($chapter);

echo $doc->saveXML();
?>

Yukarıdaki örneğin çıktısı:

<?xml version="1.0" encoding="utf-8"?>
<!DOCTYPE book PUBLIC "-//OASIS//DTD DocBook XML V4.1.2//EN"
          "http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd">
<book id="listing">
 <title>My lists</title>

</book>

Ayrıca Bakınız

  • DOMNode::appendChild() - Listenin sonuna yeni bir çocuk ekler
  • DOMNode::replaceChild() - Bir çocuk düğümü yenisi ile değiştirir

DOMNode::normalize
DOMNode::replaceChild
DOMNode


Bir çocuk düğümü yenisi ile değiştirir

DOMNode::removeChild
DOMNodeList
DOMNode
PHP Manual

DOMNode::replaceChild

(PHP 5, PHP 7)

DOMNode::replaceChild — Bir çocuk düğümü yenisi ile değiştirir

Açıklama

DOMNode DOMNode::replaceChild ( DOMNode $yeni , DOMNode $eski )

Düğümün eski çocuk düğümünün yerine yeni düğümünü yerleştirir. Yeni düğüm zaten bir çocuk düğümse ikinci kez eklenmez. Yer değiştirme başarılı olursa eski düğüm döndürülür.

Değiştirgeler

yeni

Yeni düğüm. Hedef belgenin bir üyesi olmalıdır. Yani, DOMDocument->createXXX() yöntemlerinden biri ile oluşturulmuş veya DOMDocument::importNode() ile belgeye dahil edilmiş olmalıdır.

eski

Eski düğüm.

Dönen Değerler

Bir hata oluşursa FALSE yoksa eski düğüm.

Hatalar/İstisnalar

DOM_NO_MODIFICATION_ALLOWED_ERR

Düğüm salt okunursa veya düğümün önceki ebeveyni salt okunur olarak yerleştirilmişse bu hata oluşur.

DOM_HIERARCHY_REQUEST_ERR

Düğüm, yeni düğümün türündeki çocuk düğümlere izin vermeyen türde ise veya yeni düğüm, çocuğu olacağı düğümün ebeveyni veya atalarından biri ise bu hata oluşur.

DOM_WRONG_DOCUMENT_ERR

Eğer yeni düğüm, çocuğu olacağı düğümü oluşturan belgeden farklı bir belge tarafından oluşturulmuşsa bu hata oluşur.

DOM_NOT_FOUND

eski düğüm, bir çocuk düğüm değilse bu hata oluşur.

Ayrıca Bakınız

  • DOMNode::appendChild() - Listenin sonuna yeni bir çocuk ekler
  • DOMNode::removeChild() - Listeden belirtilen çocuğu siler

DOMNode::removeChild
DOMNodeList
DOMNode


DOMNodeList sınıfı

(PHP 5, PHP 7)

Sınıf Sözdizimi

DOMNodeList {
/* Özellikler */
readonly public int $length ;
/* Yöntemler */
DOMNode DOMNodelist::item ( int $indis )
}

Özellikler

length

Listedeki düğüm sayısı. Geçerli çocuk düğümlerin indisleri 0'dan başlar, length - 1'de biter.

İçindekiler

  • DOMNodelist::item — İndisi belirtilen düğümü döndürür
DOMNode::replaceChild
DOMNodelist::item
DOM


İndisi belirtilen düğümü döndürür

DOMNodeList
DOMNotation
DOMNodeList
PHP Manual

DOMNodelist::item

(PHP 5, PHP 7)

DOMNodelist::item — İndisi belirtilen düğümü döndürür

Açıklama

DOMNode DOMNodelist::item ( int $indis )

DOMNodeList nesnesi içindeki indis'i belirtilen düğümü döndürür.

İpucu

Listedeki düğüm sayısını öğrenmek için DOMNodeList nesnesinin length özelliğini kullanın.

Değiştirgeler

indis

İstenen düğümün düğüm listesindeki indisi.

Dönen Değerler

DOMNodeList nesnesindeki indis'inci düğümü döndürür; belirtilen indis geçersizse NULL döner.

Örnekler

Örnek 1 - Bir tablonun tüm girdilerini çıktılamak

<?php

$doc = new DOMDocument;
$doc->load('book.xml');

$items = $doc->getElementsByTagName('entry');

for ($i = 0; $i < $items->length; $i++) {
    echo $items->item($i)->nodeValue . "\n";
}

?>

for yerine foreach de kullanılabilirdi:

<?php

foreach ($items as $item) {
    echo $item->nodeValue . "\n";
}

?>

Yukarıdaki örneğin çıktısı:

Title
Author
Language
ISBN
The Grapes of Wrath
John Steinbeck
en
0140186409
The Pearl
John Steinbeck
en
014017737X
Samarcande
Amine Maalouf
fr
2253051209

DOMNodeList
DOMNotation
DOMNodeList


DOMNotation sınıfı

(PHP 5, PHP 7)

Sınıf Sözdizimi

DOMNotation extends DOMNode {
/* Özellikler */
readonly public string $publicId ;
readonly public string $systemId ;
/* Miras alınan yöntemler */
DOMNode DOMNode::appendChild ( DOMNode $yeni )
public string DOMNode::C14N ([ bool $exclusive [, bool $with_comments [, array $xpath [, array $ns_prefixes ]]]] )
public int DOMNode::C14NFile ( string $uri [, bool $exclusive [, bool $with_comments [, array $xpath [, array $ns_prefixes ]]]] )
DOMNode DOMNode::cloneNode ([ bool $torunlar_dahil = TRUE ] )
public int DOMNode::getLineNo ( void )
public string DOMNode::getNodePath ( void )
bool DOMNode::hasAttributes ( void )
bool DOMNode::hasChildNodes ( void )
DOMNode DOMNode::insertBefore ( DOMNode $yeni [, DOMNode $mevcut ] )
bool DOMNode::isDefaultNamespace ( string $uri )
bool DOMNode::isSameNode ( DOMNode $düğüm )
bool DOMNode::isSupported ( string $özellik , string $sürüm )
string DOMNode::lookupNamespaceURI ( string $önek )
string DOMNode::lookupPrefix ( string $uri )
void DOMNode::normalize ( void )
DOMNode DOMNode::removeChild ( DOMNode $eski )
DOMNode DOMNode::replaceChild ( DOMNode $yeni , DOMNode $eski )
}

Özellikler

publicId

Genel betimleyici.

systemId

Sistem betimleyicisi.

DOMNodelist::item
DOMProcessingInstruction
DOM


DOMProcessingInstruction sınıfı

(PHP 5, PHP 7)

Sınıf Sözdizimi

DOMProcessingInstruction extends DOMNode {
/* Özellikler */
readonly public string $target ;
public string $data ;
/* Yöntemler */
__construct ( string $name [, string $value ] )
/* Miras alınan yöntemler */
DOMNode DOMNode::appendChild ( DOMNode $yeni )
public string DOMNode::C14N ([ bool $exclusive [, bool $with_comments [, array $xpath [, array $ns_prefixes ]]]] )
public int DOMNode::C14NFile ( string $uri [, bool $exclusive [, bool $with_comments [, array $xpath [, array $ns_prefixes ]]]] )
DOMNode DOMNode::cloneNode ([ bool $torunlar_dahil = TRUE ] )
public int DOMNode::getLineNo ( void )
public string DOMNode::getNodePath ( void )
bool DOMNode::hasAttributes ( void )
bool DOMNode::hasChildNodes ( void )
DOMNode DOMNode::insertBefore ( DOMNode $yeni [, DOMNode $mevcut ] )
bool DOMNode::isDefaultNamespace ( string $uri )
bool DOMNode::isSameNode ( DOMNode $düğüm )
bool DOMNode::isSupported ( string $özellik , string $sürüm )
string DOMNode::lookupNamespaceURI ( string $önek )
string DOMNode::lookupPrefix ( string $uri )
void DOMNode::normalize ( void )
DOMNode DOMNode::removeChild ( DOMNode $eski )
DOMNode DOMNode::replaceChild ( DOMNode $yeni , DOMNode $eski )
}

Özellikler

target

Hedef.

data

Veri.

İçindekiler

  • DOMProcessingInstruction::__construct — Yeni bir DOMProcessingInstruction nesnesi oluşturur
DOMNotation
DOMProcessingInstruction::__construct
DOM


Yeni bir DOMProcessingInstruction nesnesi oluşturur

DOMProcessingInstruction
DOMText
DOMProcessingInstruction
PHP Manual

DOMProcessingInstruction::__construct

(PHP 5, PHP 7)

DOMProcessingInstruction::__construct — Yeni bir DOMProcessingInstruction nesnesi oluşturur

Açıklama

__construct ( string $name [, string $value ] )

Yeni bir DOMProcessingInstruction nesnesi oluşturur. Bu nesne salt okunurdur. Bir belgeye eklenebilir, fakat düğüm bir belge ile ilişkilendirilene kadar düğüme yeni düğümler eklenemez. Yazılabilir bir düğüm oluşturmak için DOMDocument::createProcessingInstruction() yöntemini kullanın.

Değiştirgeler

isim

İşlem komutunun etiket ismi.

değer

İşlem komutunun değeri.

Örnekler

Örnek 1 - Yeni bir DOMProcessingInstruction oluşturmak

<?php

$dom = new DOMDocument('1.0', 'UTF-8');
$html = $dom->appendChild(new DOMElement('html'));
$body = $html->appendChild(new DOMElement('body'));
$pinode = new DOMProcessingInstruction('php', 'echo "Merhaba Arz"; ');
$body->appendChild($pinode);
echo $dom->saveXML();

?>

Yukarıdaki örneğin çıktısı:

<?xml version="1.0" encoding="UTF-8"?>
<html><body><?php echo "Merhaba Arz"; ?></body></html>

Ayrıca Bakınız

  • DOMDocument::createProcessingInstruction() - Yeni bir işlem komutu düğümü oluşturur

DOMProcessingInstruction
DOMText
DOMProcessingInstruction


DOMText sınıfı

(PHP 5, PHP 7)

Giriş

DOMText sınıfı DOMCharacterData sınıfından türetilir ve bir DOMElement veya DOMAttr düğümünün metin içeriğini temsil eder.

Sınıf Sözdizimi

DOMText extends DOMCharacterData {
/* Özellikler */
readonly public string $wholeText ;
/* Yöntemler */
__construct ([ string $değer ] )
bool isWhitespaceInElementContent ( void )
DOMText splitText ( int $konum )
/* Miras alınan yöntemler */
void DOMCharacterData::appendData ( string $veri )
void DOMCharacterData::deleteData ( int $başlangıç , int $uzunluk )
void DOMCharacterData::insertData ( int $başlangıç , string $veri )
void DOMCharacterData::replaceData ( int $başlangıç , int $uzunluk , string $veri )
string DOMCharacterData::substringData ( int $başlangıç , int $uzunluk )
DOMNode DOMNode::appendChild ( DOMNode $yeni )
public string DOMNode::C14N ([ bool $exclusive [, bool $with_comments [, array $xpath [, array $ns_prefixes ]]]] )
public int DOMNode::C14NFile ( string $uri [, bool $exclusive [, bool $with_comments [, array $xpath [, array $ns_prefixes ]]]] )
DOMNode DOMNode::cloneNode ([ bool $torunlar_dahil = TRUE ] )
public int DOMNode::getLineNo ( void )
public string DOMNode::getNodePath ( void )
bool DOMNode::hasAttributes ( void )
bool DOMNode::hasChildNodes ( void )
DOMNode DOMNode::insertBefore ( DOMNode $yeni [, DOMNode $mevcut ] )
bool DOMNode::isDefaultNamespace ( string $uri )
bool DOMNode::isSameNode ( DOMNode $düğüm )
bool DOMNode::isSupported ( string $özellik , string $sürüm )
string DOMNode::lookupNamespaceURI ( string $önek )
string DOMNode::lookupPrefix ( string $uri )
void DOMNode::normalize ( void )
DOMNode DOMNode::removeChild ( DOMNode $eski )
DOMNode DOMNode::replaceChild ( DOMNode $yeni , DOMNode $eski )
}

Özellikler

wholeText

Mantıken birbirine komşu metin düğümlerinin (eleman, açıklama veya işlem komutları ile ayrılmamış) tüm metinlerini içerir.

İçindekiler

  • DOMText::__construct — Yeni bir DOMText nesnesi oluşturur
  • DOMText::isWhitespaceInElementContent — Düğümün boşluk içerip içermediğini belirtir
  • DOMText::splitText — Düğümü belirtilen konumda iki düğüme böler
DOMProcessingInstruction::__construct
DOMText::__construct
DOM


Yeni bir DOMText nesnesi oluşturur

DOMText
DOMText::isWhitespaceInElementContent
DOMText
PHP Manual

DOMText::__construct

(PHP 5, PHP 7)

DOMText::__construct — Yeni bir DOMText nesnesi oluşturur

Açıklama

__construct ([ string $değer ] )

Yeni bir DOMText nesnesi oluşturur.

Değiştirgeler

değer

Metin düğümünün değeri. Belirtilmezse boş bir metin düğümü oluşturulur.

Örnekler

Örnek 1 - Yeni bir DOMText nesnesi oluşturmak

<?php

$dom = new DOMDocument('1.0', 'utf-8');
$element = $dom->appendChild(new DOMElement('root'));
$text = $element->appendChild(new DOMText('kök değer'));
echo $dom->saveXML();
/* çıktısı:
     <?xml version="1.0" encoding="utf-8"?><root>kök değer</root> */

?>

Ayrıca Bakınız

  • DOMDocument::createTextNode() - Yeni bir metin düğümü oluşturur

DOMText
DOMText::isWhitespaceInElementContent
DOMText


Düğümün boşluk içerip içermediğini belirtir

DOMText::__construct
DOMText::splitText
DOMText
PHP Manual

DOMText::isWhitespaceInElementContent

(PHP 5, PHP 7)

DOMText::isWhitespaceInElementContent — Düğümün boşluk içerip içermediğini belirtir

Açıklama

bool DOMText::isWhitespaceInElementContent ( void )

Düğümün boşluk içerip içermediğini belirtir. Metin düğümünün boşluk içerip içermediği belgenin yüklenmesi sırasında saptanır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

DOMText::__construct
DOMText::splitText
DOMText


Düğümü belirtilen konumda iki düğüme böler

DOMText::isWhitespaceInElementContent
DOMXPath
DOMText
PHP Manual

DOMText::splitText

(PHP 5, PHP 7)

DOMText::splitText — Düğümü belirtilen konumda iki düğüme böler

Açıklama

DOMText DOMText::splitText ( int $konum )

Düğümü konum ile belirtilen konuma göre iki düğüme böler ve iki düğümü kardeş düğümler haline getirir.

Bölünme sonrası, düğüm konum konumuna kadar olan parçayı içerir. Düğümün bir ebeveyni varsa yeni düğüm, sonraki kardeş düğüm olarak eklenir. Eğer konum düğümün uzunluğuna eşitse kardeş düğüm boş olur.

Değiştirgeler

konum

Bölme yeri. İlk konum 0'dır.

Dönen Değerler

konum konumundan sonraki parçayı içeren yeni bir düğüm döner.

DOMText::isWhitespaceInElementContent
DOMXPath
DOMText


DOMXPath sınıfı

(PHP 5, PHP 7)

Giriş

XPath 1.0 desteklenir.

Sınıf Sözdizimi

DOMXPath {
/* Özellikler */
public DOMDocument $document ;
/* Yöntemler */
__construct ( DOMDocument $belge )
mixed evaluate ( string $ifade [, DOMNode $bağlamsal_düğüm ] )
DOMNodeList query ( string $ifade [, DOMNode $bağlamsal_düğüm ] )
bool registerNamespace ( string $önek , string $uri )
public void registerPhpFunctions ([ mixed $restrict ] )
}

Özellikler

document

Belge.

İçindekiler

  • DOMXPath::__construct — Yeni bir DOMXPath nesnesi oluşturur
  • DOMXPath::evaluate — Belirtilen XPath ifadesini çözümler ve mümkünse yazılı bir sonuç verir
  • DOMXPath::query — Belirtilen XPath ifadesini değerlendirir
  • DOMXPath::registerNamespace — Belirtilen isim alanını DOMXPath nesnesi ile ilişkilendirir
  • DOMXPath::registerPhpFunctions — Register PHP functions as XPath functions
DOMText::splitText
DOMXPath::__construct
DOM


Yeni bir DOMXPath nesnesi oluşturur

DOMXPath
DOMXPath::evaluate
DOMXPath
PHP Manual

DOMXPath::__construct

(PHP 5, PHP 7)

DOMXPath::__construct — Yeni bir DOMXPath nesnesi oluşturur

Açıklama

__construct ( DOMDocument $belge )

Yeni bir DOMXPath nesnesi oluşturur.

Değiştirgeler

belge

DOMXPath ile ilişkili DOMDocument nesnesi.

DOMXPath
DOMXPath::evaluate
DOMXPath


Belirtilen XPath ifadesini çözümler ve mümkünse yazılı bir sonuç verir

DOMXPath::__construct
DOMXPath::query
DOMXPath
PHP Manual

DOMXPath::evaluate

(PHP 5 >= 5.1.0, PHP 7)

DOMXPath::evaluate — Belirtilen XPath ifadesini çözümler ve mümkünse yazılı bir sonuç verir

Açıklama

mixed DOMXPath::evaluate ( string $ifade [, DOMNode $bağlamsal_düğüm ] )

ifade ile belirtilen XPath ifadesini çözümler ve mümkünse yazılı bir sonuç verir.

Değiştirgeler

ifade

Değerlenderelecek XPath ifadesi.

bağlamsal_düğüm

Seçimlik olarak, göreli XPath sorguları yapmak içindir. Öntanımlı olarak sorgular kök elemana göre çözümlenir.

Dönen Değerler

Mümkünse sonucu bir dizge orarak döndürür, değilse belirtilen XPath ifadesi ile eşleşen tüm düğümleri içeren bir DOMNodeList nesnesi döner.

Örnekler

Örnek 1 - Tüm İngilizce kitapların sayısını döndürmek

<?php

$doc = new DOMDocument;

$doc->load('book.xml');

$xpath = new DOMXPath($doc);

$tbody = $doc->getElementsByTagName('tbody')->item(0);

// sorgumuzu tbody düğümüne göre yapalım
$query = 'count(row/entry[. = "en"])';

$entries = $xpath->evaluate($query, $tbody);
echo "$entries İngilizce kitap var.\n";

?>

Yukarıdaki örneğin çıktısı:

2 İngilizce kitap var.

Ayrıca Bakınız

  • DOMXPath::query() - Belirtilen XPath ifadesini değerlendirir

DOMXPath::__construct
DOMXPath::query
DOMXPath


Belirtilen XPath ifadesini değerlendirir

DOMXPath::evaluate
DOMXPath::registerNamespace
DOMXPath
PHP Manual

DOMXPath::query

(PHP 5, PHP 7)

DOMXPath::query — Belirtilen XPath ifadesini değerlendirir

Açıklama

DOMNodeList DOMXPath::query ( string $ifade [, DOMNode $bağlamsal_düğüm ] )

Belirtilen XPath ifade'sini çözümler.

Değiştirgeler

ifade

Değerlendirilecek XPath ifadesi.

bağlamsal_düğüm

Seçimlik olarak, göreli XPath sorguları yapmak içindir. Öntanımlı olarak sorgular kök elemana göre çözümlenir.

Dönen Değerler

Belirtilen XPath ifade'si ile eşleşen tüm düğümleri içeren bir DOMNodeList nesnesi döner. Hiçbir eşleşme olmamışsa boş bir DOMNodeList nesnesi döner.

Örnekler

Örnek 1 - Tüm İngilizce kitapları listelemek

<?php

$doc = new DOMDocument;

// Fazladan boşlukları korumak istemiyoruz
$doc->preserveWhiteSpace = false;

$doc->Load('book.xml');

$xpath = new DOMXPath($doc);

// Sorguyu kök elemandan başlatıyoruz
$query = '//book/chapter/para/informaltable/tgroup/tbody/row/entry[. = "en"]';

$entries = $xpath->query($query);

foreach ($entries as $entry) {
    echo "Found {$entry->previousSibling->previousSibling->nodeValue}," .
         " by {$entry->previousSibling->nodeValue}\n";
}
?>

Yukarıdaki örneğin çıktısı:

Found The Grapes of Wrath, by John Steinbeck
Found The Pearl, by John Steinbeck

İfademizi kısaltmak için bağlamsal_düğüm değiştirgesini kullanabilirdik:

<?php

$doc = new DOMDocument;
$doc->preserveWhiteSpace = false;

$doc->load('book.xml');

$xpath = new DOMXPath($doc);

$tbody = $doc->getElementsByTagName('tbody')->item(0);

// Sorguyu tbody düğümüne göre yapalım
$query = 'row/entry[. = "en"]';

$entries = $xpath->query($query, $tbody);

foreach ($entries as $entry) {
    echo "Found {$entry->previousSibling->previousSibling->nodeValue}," .
         " by {$entry->previousSibling->nodeValue}\n";
}
?>

Ayrıca Bakınız

  • DOMXPath::evaluate() - Belirtilen XPath ifadesini çözümler ve mümkünse yazılı bir sonuç verir

DOMXPath::evaluate
DOMXPath::registerNamespace
DOMXPath


Belirtilen isim alanını DOMXPath nesnesi ile ilişkilendirir

DOMXPath::query
DOMXPath::registerPhpFunctions
DOMXPath
PHP Manual

DOMXPath::registerNamespace

(PHP 5, PHP 7)

DOMXPath::registerNamespace — Belirtilen isim alanını DOMXPath nesnesi ile ilişkilendirir

Açıklama

bool DOMXPath::registerNamespace ( string $önek , string $uri )

önek ve uri ile belirtilen isim alanını DOMXPath nesnesi ile ilişkilendirir.

Değiştirgeler

önek

İsim alanı öneki.

uri

İsim alanını betimleyen adres.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

DOMXPath::query
DOMXPath::registerPhpFunctions
DOMXPath


Register PHP functions as XPath functions

DOMXPath::registerNamespace
DOM İşlevleri
DOMXPath
PHP Manual

DOMXPath::registerPhpFunctions

(PHP 5 >= 5.3.0, PHP 7)

DOMXPath::registerPhpFunctions — Register PHP functions as XPath functions

Açıklama

public void DOMXPath::registerPhpFunctions ([ mixed $restrict ] )

This method enables the ability to use PHP functions within XPath expressions.

Değiştirgeler

restrict

Use this parameter to only allow certain functions to be called from XPath.

This parameter can be either a string (a function name) or an array of function names.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

The following examples use book.xml which contains the following:

Örnek 1 book.xml

<?xml version="1.0" encoding="UTF-8"?>
<books>
 <book>
  <title>PHP Basics</title>
  <author>Jim Smith</author>
  <author>Jane Smith</author>
 </book>
 <book>
  <title>PHP Secrets</title>
  <author>Jenny Smythe</author>
 </book>
 <book>
  <title>XML basics</title>
  <author>Joe Black</author>
 </book>
</books>

Örnek 2 DOMXPath::registerPHPFunctions() with php:functionString

<?php
$doc = new DOMDocument;
$doc->load('book.xml');

$xpath = new DOMXPath($doc);

// Register the php: namespace (required)
$xpath->registerNamespace("php", "http://php.net/xpath");

// Register PHP functions (no restrictions)
$xpath->registerPHPFunctions();

// Call substr function on the book title
$nodes = $xpath->query('//book[php:functionString("substr", title, 0, 3) = "PHP"]');

echo "Found {$nodes->length} books starting with 'PHP':\n";
foreach ($nodes as $node) {
    $title  = $node->getElementsByTagName("title")->item(0)->nodeValue;
    $author = $node->getElementsByTagName("author")->item(0)->nodeValue;
    echo "$title by $author\n";
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Found 2 books starting with 'PHP':
PHP Basics by Jim Smith
PHP Secrets by Jenny Smythe

Örnek 3 DOMXPath::registerPHPFunctions() with php:function

<?php
$doc = new DOMDocument;
$doc->load('book.xml');

$xpath = new DOMXPath($doc);

// Register the php: namespace (required)
$xpath->registerNamespace("php", "http://php.net/xpath");

// Register PHP functions (has_multiple only)
$xpath->registerPHPFunctions("has_multiple");

function has_multiple($nodes) {
    // Return true if more than one author
    return count($nodes) > 1;
}
// Filter books with multiple authors
$books = $xpath->query('//book[php:function("has_multiple", author)]');

echo "Books with multiple authors:\n";
foreach ($books as $book) {
    echo $book->getElementsByTagName("title")->item(0)->nodeValue . "\n";
}

?>

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Books with multiple authors:
PHP Basics

Ayrıca Bakınız

  • DOMXPath::registerNamespace() - Belirtilen isim alanını DOMXPath nesnesi ile ilişkilendirir
  • DOMXPath::query() - Belirtilen XPath ifadesini değerlendirir
  • DOMXPath::evaluate() - Belirtilen XPath ifadesini çözümler ve mümkünse yazılı bir sonuç verir

DOMXPath::registerNamespace
DOM İşlevleri
DOMXPath


DOM İşlevleri

İçindekiler

  • dom_import_simplexml — Bir SimpleXMLElement düğümü alıp bir DOMElement düğümü döndürür
DOMXPath::registerPhpFunctions
dom_import_simplexml
DOM


Bir SimpleXMLElement düğümü alıp bir DOMElement düğümü döndürür

DOM İşlevleri
libxml
DOM İşlevleri
PHP Manual

dom_import_simplexml

(PHP 5, PHP 7)

dom_import_simplexml — Bir SimpleXMLElement düğümü alıp bir DOMElement düğümü döndürür

Açıklama

DOMElement dom_import_simplexml ( SimpleXMLElement $düğüm )

Bir SimpleXMLElement düğümü alıp bir DOMElement düğümü döndürür. Bu yeni nesne doğal bir DOMElement düğümü olarak kullanılabilir.

Değiştirgeler

düğüm

Bir SimpleXMLElement düğümü.

Dönen Değerler

Başarısız olursa FALSE yoksa bir DOMElement nesnesi döndürür.

Örnekler

Örnek 1 - dom_import_simplexml() ile DOM'a SimpleXML ithali

<?php

$sxe = simplexml_load_string('<books><book><title>blah</title></book></books>');

if ($sxe === false) {
    echo 'Belge çözümlenirken hata oluştu ';
    exit;
}

$dom_sxe = dom_import_simplexml($sxe);
if (!$dom_sxe) {
    echo 'XML dönüşümünde hata oluştu ';
    exit;
}

$dom = new DOMDocument('1.0');
$dom_sxe = $dom->importNode($dom_sxe, true);
$dom_sxe = $dom->appendChild($dom_sxe);

echo $dom->saveXML();

?>

Ayrıca Bakınız

  • simplexml_import_dom() - Bir DOM düğümü alıp bir SimpleXMLElement nesnesi döndürür

DOM İşlevleri
libxml
DOM İşlevleri


libxml

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • libXMLError — libXMLError sınıfı
  • libxml İşlevleri
    • libxml_clear_errors — libxml hata tamponunu temizler
    • libxml_disable_entity_loader — Disable the ability to load external entities
    • libxml_get_errors — Hataları içeren bir dizi döndürür
    • libxml_get_last_error — libxml'den son hatayı döndürür
    • libxml_set_external_entity_loader — Changes the default external entity loader
    • libxml_set_streams_context — Yüklenecek veya yazılacak sonraki libxml belgesinin akım bağlamını belirler
    • libxml_use_internal_errors — libxml hatalarını kapatarak kullanıcı tanımlı hataları mümkün kılar
dom_import_simplexml
Giriş
XML İşleme


Giriş

Bu işlevler ve sabitler PHP 5.1.0'dan beri kullanılabilmekte olup, bu eklenti ile ilgili yerleşik eklentiler şunlardır: SimpleXML, SOAP, WDDX, XSL, XML, XMLReader, XMLRPC ve XMLWriter.

libxml
Yapılandırma/Kurulum
libxml


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
libxml


Gereksinimler

Bu eklenti » libxml >= 2.6.0 gerektirir.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Libxml eklentisi öntanımlı olarak etkin olup iptal edilmek istenirse --disable-libxml derleme seçeneği kullanılabilir.

Seçimlik olan --with-libxml-dir seçeneği belirtildiği takdirde PHP belirtilen yerdeki libxml kütüphanesiyle derlenir, aksi takdirde kütüphane standart yerlerde aranır. Yapılandırma işlemi libxml kütüphanesini (özellikle xml2-config) bulmak için şu yolu izler:

  1. --with-libxml-dir seçeneğinde belirtilen DiZiN ([DiZiN]/bin/xml2-config)

  2. /usr/local/bin/xml2-config

  3. /usr/bin/xml2-config

xml2-config dosyası --with-libxml-dir ile belirttiğiniz yerde bulunamazsa standart yerlere bakılır.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

LIBXML_COMPACT (integer)
Küçük düğüm ayırma en iyilemesini etkinleştirir. Kodda değişiklik yapmaksızın uygulamanızın hızlanmasını sağlar.

Bilginize:

Sadece Libxml >= 2.6.21 sürümlerinde kullanılabilmektedir.

LIBXML_DTDATTR (integer)
Öntanımlı DTD öznitelikleri.
LIBXML_DTDLOAD (integer)
Harici alt kümeyi yükler.
LIBXML_DTDVALID (integer)
DTD ile doğrulama yapar.
LIBXML_NOBLANKS (integer)
Boş düğümleri siler.
LIBXML_NOCDATA (integer)
CDATA bölümleri metin düğümü olarak ele alınır.
LIBXML_NOEMPTYTAG (integer)
Boş etiketleri genişletir (örneğin, <br/> etiketi <br></br> haline getirilir).

Bilginize:

Bu seçenek şimdilik sadece DOMDocument::save() ve DOMDocument::saveXML() yönteminde kullanılabilmektedir.

LIBXML_NOENT (integer)
Öğe ikameleri yapılır.
LIBXML_NOERROR (integer)
Hata raporlama kapatılır.
LIBXML_NONET (integer)
Belgeler yüklenirken ağ erişimi iptal edilir.
LIBXML_NOWARNING (integer)
Uyarı raporlama kapatılır.
LIBXML_NOXMLDECL (integer)
Bir belgeyi kaydederken XML bildirimi atlanır.

Bilginize:

Sadece Libxml >= 2.6.21 sürümlerinde kullanılabilmektedir.

LIBXML_NSCLEAN (integer)
Gereksiz isim alanı bildirimleri silinir.
LIBXML_XINCLUDE (integer)
XInclude ikamesi gerçeklenir.
LIBXML_ERR_ERROR (integer)
Kurtarılabilir hata.
LIBXML_ERR_FATAL (integer)
Ölümcül hata.
LIBXML_ERR_NONE (integer)
Hata yok.
LIBXML_ERR_WARNING (integer)
Basit uyarı.
LIBXML_VERSION (integer)
20605 veya 20617 biçiminde libxml sürümü.
LIBXML_DOTTED_VERSION (string)
2.6.5 veya 2.6.17 biçiminde libxml sürümü.
Özkaynak Türleri
libXMLError
libxml


libXMLError sınıfı

(PHP 5 >= 5.1.0, PHP 7)

Giriş

Libxml tarafından oluşturulan hatalar hakkında çeşitli bilgiler içerir. Hata kodları, resmi » xmlError API belgelerinde açıklanmıştır.

Sınıf Sözdizimi

libXMLError {
/* Özellikler */
public int $level ;
public int $code ;
public int $column ;
public string $message ;
public string $file ;
public int $line ;
}

Özellikler

level

Hatanın önem derecesi. Şu sabitlerden biri olmalıdır: LIBXML_ERR_WARNING, LIBXML_ERR_ERROR veya LIBXML_ERR_FATAL.

code

Hatanın kodu.

column

Hatanın oluştuğu sütun.

Bilginize:

Bu özellik libxml'de tamamen gerçeklenmediğinden çoğunlukla 0 döner.

message

Varsa hatanın iletisi.

file

Dosya ismi. XML belge bir dizge olarak yüklenmişse boştur.

line

Hatanın oluştuğu satır.

Öntanımlı Sabitler
libxml İşlevleri
libxml


libxml İşlevleri

İçindekiler

  • libxml_clear_errors — libxml hata tamponunu temizler
  • libxml_disable_entity_loader — Disable the ability to load external entities
  • libxml_get_errors — Hataları içeren bir dizi döndürür
  • libxml_get_last_error — libxml'den son hatayı döndürür
  • libxml_set_external_entity_loader — Changes the default external entity loader
  • libxml_set_streams_context — Yüklenecek veya yazılacak sonraki libxml belgesinin akım bağlamını belirler
  • libxml_use_internal_errors — libxml hatalarını kapatarak kullanıcı tanımlı hataları mümkün kılar
libXMLError
libxml_clear_errors
libxml


libxml hata tamponunu temizler

libxml İşlevleri
libxml_disable_entity_loader
libxml İşlevleri
PHP Manual

libxml_clear_errors

(PHP 5 >= 5.1.0, PHP 7)

libxml_clear_errors — libxml hata tamponunu temizler

Açıklama

void libxml_clear_errors ( void )

libxml hata tamponunu temizler.

Dönen Değerler

Hiçbir değer dönmez.

Ayrıca Bakınız

  • libxml_get_errors() - Hataları içeren bir dizi döndürür
  • libxml_get_last_error() - libxml'den son hatayı döndürür

libxml İşlevleri
libxml_disable_entity_loader
libxml İşlevleri


Disable the ability to load external entities

libxml_clear_errors
libxml_get_errors
libxml İşlevleri
PHP Manual

libxml_disable_entity_loader

(PHP 5 >= 5.2.11, PHP 7)

libxml_disable_entity_loader — Disable the ability to load external entities

Açıklama

bool libxml_disable_entity_loader ([ bool $disable = true ] )

Disable/enable the ability to load external entities.

Değiştirgeler

disable

Disable (TRUE) or enable (FALSE) libxml extensions (such as DOM, XMLWriter and XMLReader) to load external entities.

Dönen Değerler

Returns the previous value.

Ayrıca Bakınız

  • libxml_use_internal_errors() - libxml hatalarını kapatarak kullanıcı tanımlı hataları mümkün kılar
  • The LIBXML_NONET constant

libxml_clear_errors
libxml_get_errors
libxml İşlevleri


Hataları içeren bir dizi döndürür

libxml_disable_entity_loader
libxml_get_last_error
libxml İşlevleri
PHP Manual

libxml_get_errors

(PHP 5 >= 5.1.0, PHP 7)

libxml_get_errors — Hataları içeren bir dizi döndürür

Açıklama

array libxml_get_errors ( void )

Hataları içeren bir dizi döndürür.

Dönen Değerler

Tamponda bir hata oluşmuşsa LibXMLError nesnelerinden oluşan bir dizi, yoksa boş bir dizi döner.

Örnekler

Örnek 1 - libxml_get_errors() örneği

Örnekte basit bir libxml hata eylemcisinin gerçeklenişi gösterilmiştir.

<?php

libxml_use_internal_errors(true);

$xmlstr = <<< XML
<?xml version='1.0' standalone='yes'?>
<movies>
 <movie>
  <titles>PHP: Behind the Parser</title>
 </movie>
</movies>
XML;

$doc = simplexml_load_string($xmlstr);
$xml = explode("\n", $xmlstr);

if (!$doc) {
    $errors = libxml_get_errors();

    foreach ($errors as $error) {
        echo display_xml_error($error, $xml);
    }

    libxml_clear_errors();
}

function display_xml_error($error, $xml)
{
    $return  = $xml[$error->line - 1] . "\n";
    $return .= str_repeat('-', $error->column) . "^\n";

    switch ($error->level) {
        case LIBXML_ERR_WARNING:
            $return .= "Uyarı $error->code: ";
            break;
         case LIBXML_ERR_ERROR:
            $return .= "Hata $error->code: ";
            break;
        case LIBXML_ERR_FATAL:
            $return .= "Ölümcül hata $error->code: ";
            break;
    }

    $return .= trim($error->message) .
               "\n  Satır: $error->line" .
               "\n  Sütun: $error->column";

    if ($error->file) {
        $return .= "\n  Dosya: $error->file";
    }

    return "$return\n\n--------------------------------------------\n\n";
}

?>

Yukarıdaki örneğin çıktısı:

  <titles>PHP: Behind the Parser</title>
----------------------------------------------^
Ölümcül hata 76: Opening and ending tag mismatch: titles line 4 and title
  Satır: 4
  Sütun: 46

--------------------------------------------

Ayrıca Bakınız

  • libxml_get_last_error() - libxml'den son hatayı döndürür
  • libxml_clear_errors() - libxml hata tamponunu temizler

libxml_disable_entity_loader
libxml_get_last_error
libxml İşlevleri


libxml'den son hatayı döndürür

libxml_get_errors
libxml_set_external_entity_loader
libxml İşlevleri
PHP Manual

libxml_get_last_error

(PHP 5 >= 5.1.0, PHP 7)

libxml_get_last_error — libxml'den son hatayı döndürür

Açıklama

LibXMLError libxml_get_last_error ( void )

libxml'den son hatayı döndürür.

Dönen Değerler

Tamponda bir hata oluşmuşsa bir LibXMLError nesnesi, yoksa FALSE döner.

Ayrıca Bakınız

  • libxml_get_errors() - Hataları içeren bir dizi döndürür
  • libxml_clear_errors() - libxml hata tamponunu temizler

libxml_get_errors
libxml_set_external_entity_loader
libxml İşlevleri


Changes the default external entity loader

libxml_get_last_error
libxml_set_streams_context
libxml İşlevleri
PHP Manual

libxml_set_external_entity_loader

(PHP 5 >= 5.4.0, PHP 7)

libxml_set_external_entity_loader — Changes the default external entity loader

Açıklama

void libxml_set_external_entity_loader ( callable $resolver_function )

Changes the default external entity loader.

Değiştirgeler

resolver_function

A callable that takes three arguments. Two strings, a public id and system id, and a context (an array with four keys) as the third argument. This callback should return a resource, a string from which a resource can be opened, or NULL.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 libxml_set_external_entity_loader() example

<?php
$xml = <<<XML
<!DOCTYPE foo PUBLIC "-//FOO/BAR" "http://example.com/foobar">
<foo>bar</foo>
XML;

$dtd = <<<DTD
<!ELEMENT foo (#PCDATA)>
DTD;

libxml_set_external_entity_loader(
    function ($public, $system, $context) use($dtd) {
        var_dump($public);
        var_dump($system);
        var_dump($context);
        $f = fopen("php://temp", "r+");
        fwrite($f, $dtd);
        rewind($f);
        return $f;
    }
);

$dd = new DOMDocument;
$r  = $dd->loadXML($xml);

var_dump($dd->validate());
?>

Yukarıdaki örneğin çıktısı:

string(10) "-//FOO/BAR"
string(25) "http://example.com/foobar"
array(4) {
    ["directory"]    => NULL
    ["intSubName"]   => NULL
    ["extSubURI"]    => NULL
    ["extSubSystem"] => NULL
}
bool(true)

Ayrıca Bakınız

  • libxml_disable_entity_loader() - Disable the ability to load external entities

libxml_get_last_error
libxml_set_streams_context
libxml İşlevleri


Yüklenecek veya yazılacak sonraki libxml belgesinin akım bağlamını belirler

libxml_set_external_entity_loader
libxml_use_internal_errors
libxml İşlevleri
PHP Manual

libxml_set_streams_context

(PHP 5, PHP 7)

libxml_set_streams_context — Yüklenecek veya yazılacak sonraki libxml belgesinin akım bağlamını belirler

Açıklama

void libxml_set_streams_context ( resource $akım_bağlamı )

Yüklenecek veya yazılacak sonraki libxml belgesinin akım bağlamını belirler.

Değiştirgeler

akım_bağlamı

stream_context_create() ile oluşturulan bir akım bağlamı özkaynağı.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 - libxml_set_streams_context() örneği

<?php

$opts = array(
    'http' => array(
        'user_agent' => 'PHP libxml agent',
    )
);

$context = stream_context_create($opts);
libxml_set_streams_context($context);

// Dosyayı HTTP üzerinden isteyelim
$doc = DOMDocument::load('http://www.example.com/file.xml');

?>

Ayrıca Bakınız

  • stream_context_create() - Bir akım bağlamı oluşturur

libxml_set_external_entity_loader
libxml_use_internal_errors
libxml İşlevleri


libxml hatalarını kapatarak kullanıcı tanımlı hataları mümkün kılar

libxml_set_streams_context
SDO
libxml İşlevleri
PHP Manual

libxml_use_internal_errors

(PHP 5 >= 5.1.0, PHP 7)

libxml_use_internal_errors — libxml hatalarını kapatarak kullanıcı tanımlı hataları mümkün kılar

Açıklama

bool libxml_use_internal_errors ([ bool $hatalar_etkin = FALSE ] )

Standart libxml hatalarını iptal edip kullanıcı tanımlı hataları etkin kılar.

Değiştirgeler

hatalar_etkin

TRUE atanırsa kullanıcı hataları etkin olur.

Dönen Değerler

hatalar_etkin değiştirgesinin önceki değerini döndürür.

Örnekler

Örnek 1 - libxml_use_internal_errors() örneği

Aşağıdaki örnekte işlevin döndürdüğü değer ve libxml hatalarının temel kullanımı gösterilmiştir.

<?php

// Kullanıcı tanımlı hataları etkin kılalım
var_dump(libxml_use_internal_errors(true));

// Belgeyi yükleyelim
$doc = new DOMDocument;

if (!$doc->load('file.xml')) {
    foreach (libxml_get_errors() as $error) {
        // Hataları burada ele alıyoruz
    }

    libxml_clear_errors();
}

?>

Yukarıdaki örneğin çıktısı:

bool(false)

Ayrıca Bakınız

  • libxml_clear_errors() - libxml hata tamponunu temizler
  • libxml_get_errors() - Hataları içeren bir dizi döndürür

libxml_set_streams_context
SDO
libxml İşlevleri


Service Data Objects

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Limitations
  • Örnekler
    • Basic usage
    • Setting and Getting Property Values
    • Working with Sequenced Data Objects
    • Reflecting on Service Data Objects
  • SDO İşlevleri
    • SDO_DAS_ChangeSummary::beginLogging — Begin change logging
    • SDO_DAS_ChangeSummary::endLogging — End change logging
    • SDO_DAS_ChangeSummary::getChangeType — Get the type of change made to an SDO_DataObject
    • SDO_DAS_ChangeSummary::getChangedDataObjects — Get the changed data objects from a change summary
    • SDO_DAS_ChangeSummary::getOldContainer — Get the old container for a deleted SDO_DataObject
    • SDO_DAS_ChangeSummary::getOldValues — Get the old values for a given changed SDO_DataObject
    • SDO_DAS_ChangeSummary::isLogging — Test to see whether change logging is switched on
    • SDO_DAS_DataFactory::addPropertyToType — Adds a property to a type
    • SDO_DAS_DataFactory::addType — Add a new type to a model
    • SDO_DAS_DataFactory::getDataFactory — Get a data factory instance
    • SDO_DAS_DataObject::getChangeSummary — Get a data object's change summary
    • SDO_DAS_Setting::getListIndex — Get the list index for a changed many-valued property
    • SDO_DAS_Setting::getPropertyIndex — Get the property index for a changed property
    • SDO_DAS_Setting::getPropertyName — Get the property name for a changed property
    • SDO_DAS_Setting::getValue — Get the old value for the changed property
    • SDO_DAS_Setting::isSet — Test whether a property was set prior to being modified
    • SDO_DataFactory::create — Create an SDO_DataObject
    • SDO_DataObject::clear — Clear an SDO_DataObject's properties
    • SDO_DataObject::createDataObject — Create a child SDO_DataObject
    • SDO_DataObject::getContainer — Get a data object's container
    • SDO_DataObject::getSequence — Get the sequence for a data object
    • SDO_DataObject::getTypeName — Return the name of the type for a data object.
    • SDO_DataObject::getTypeNamespaceURI — Return the namespace URI of the type for a data object.
    • SDO_Exception::getCause — Get the cause of the exception.
    • SDO_List::insert — Insert into a list
    • SDO_Model_Property::getContainingType — Get the SDO_Model_Type which contains this property
    • SDO_Model_Property::getDefault — Get the default value for the property
    • SDO_Model_Property::getName — Get the name of the SDO_Model_Property
    • SDO_Model_Property::getType — Get the SDO_Model_Type of the property
    • SDO_Model_Property::isContainment — Test to see if the property defines a containment relationship
    • SDO_Model_Property::isMany — Test to see if the property is many-valued
    • SDO_Model_ReflectionDataObject::__construct — Construct an SDO_Model_ReflectionDataObject
    • SDO_Model_ReflectionDataObject::export — Get a string describing the SDO_DataObject.
    • SDO_Model_ReflectionDataObject::getContainmentProperty — Get the property which defines the containment relationship to the data object
    • SDO_Model_ReflectionDataObject::getInstanceProperties — Get the instance properties of the SDO_DataObject
    • SDO_Model_ReflectionDataObject::getType — Get the SDO_Model_Type for the SDO_DataObject
    • SDO_Model_Type::getBaseType — Get the base type for this type
    • SDO_Model_Type::getName — Get the name of the type
    • SDO_Model_Type::getNamespaceURI — Get the namespace URI of the type
    • SDO_Model_Type::getProperties — Get the SDO_Model_Property objects defined for the type
    • SDO_Model_Type::getProperty — Get an SDO_Model_Property of the type
    • SDO_Model_Type::isAbstractType — Test to see if this SDO_Model_Type is an abstract data type
    • SDO_Model_Type::isDataType — Test to see if this SDO_Model_Type is a primitive data type
    • SDO_Model_Type::isInstance — Test for an SDO_DataObject being an instance of this SDO_Model_Type
    • SDO_Model_Type::isOpenType — Test to see if this type is an open type
    • SDO_Model_Type::isSequencedType — Test to see if this is a sequenced type
    • SDO_Sequence::getProperty — Return the property for the specified sequence index.
    • SDO_Sequence::insert — Insert into a sequence
    • SDO_Sequence::move — Move an item to another sequence position
libxml_use_internal_errors
Giriş
XML İşleme


Giriş

Service Data Objects (SDOs) enable PHP applications to work with data from different sources (like a database query, an XML file, and a spreadsheet) using a single interface.

Each different kind of data source requires a Data Access Service (DAS) to provide access to the data in the data source. In your PHP application, you use a DAS to create an SDO instance that represents some data in the data source. You can then set and get values in the SDO instance using the standard SDO interface. Finally, you use a DAS to write the modified data back to a data source, typically the same one.

See the list of Data Access Services for details on those currently available. In addition to the provided DASs, SDO also provides interfaces to enable others to be implemented (see the section on SDO Data Access Services Interface for more details).

This extension is derived from concepts taken from the » Service Data Objects specification. It includes a version of the » Apache Tuscany SDO for C++ project.

The Structure of a Service Data Object

A Service Data Object instance is made up of a tree of data objects. The tree is defined by containment relationships between the data objects. For example, a Company data object might consist of a number of Department data objects and therefore the Company would have a containment relationship to the Departments.

An SDO may also have non-containment references between data objects in the tree. For example, one Employee data object might reference another Employee to identify a career mentor.

As well as data objects referencing each other, they can also have primitive properties. For example, the Company data object might have a property called "name" of type string, for holding the name of the company (for example, "Acme").

Each of these properties of a data object - containment relationships, non-containment references, or primitive properties - may be many-valued or single-valued. In the above examples, Departments is many-valued and the Company name is single-valued.

In PHP, each SDO data object is represented as a PHP object. The properties of the data object can be accessed using either object syntax or associative array syntax. We'll see some examples of this later.

SDO
Yapılandırma/Kurulum
SDO


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
SDO


Gereksinimler

The SDO extension requires PHP 5.1.0 or higher. It also requires the libxml2 library. Normally libxml2 will already be installed, but if not, it can be downloaded from » http://www.xmlsoft.org/.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/sca_sdo.

Bilginize:

Earlier versions of the SDO extension required a separate shared library for the XML DAS. This is now obsolete and any references to php_sdo_das_xml.dll or sdo_das_xml.so should be removed from your php.ini.

Unix systems

  1. The three SDO components - the SDO core, the XML DAS and the Relational DAS - are packaged together with Service Component Architecture (SCA) into one PECL project, SCA_SDO, so you can download SCA and all three parts of SDO with the command:

    pecl install SCA_SDO

    This command will build the SDO shared library as well as installing the PHP files that make up SCA and the SDO Relational DAS.

    If you want to use the latest beta version, then instead run:

    pecl install SCA_SDO-beta

  2. The pecl command automatically installs the SDO module into your PHP extensions directory. To enable the SDO extension you must add the following line to php.ini:

    extension=sdo.so

    For more information about building PECL packages, consult the PECL installation section of the manual.

Building SDO on Linux

This section describes how to build the SDO core and XML DAS on Linux. You would only need to know how to do this if you wish to build a recent version that you have checked out of SVN.

  1. Change to the main extension directory: cd < wherever your sdo code is >

  2. Run phpize, which will set up the environment to compile SDO.

  3. Next, run ./configure; make; make install. Please note, you may need to login as root to install the extension.

  4. Make sure that the module is loaded by PHP, by adding extension=sdo.so to your php.ini file.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

SDO_DAS_ChangeSummary::NONE=0 (integer)
Represents a change type of 'none'.
SDO_DAS_ChangeSummary::MODIFICATION=1 (integer)
Represents a change type of 'modification'.
SDO_DAS_ChangeSummary::ADDITION=2 (integer)
Represents a change type of 'addition'.
SDO_DAS_ChangeSummary::DELETION=3 (integer)
Represents a change type of 'deletion'.
Özkaynak Türleri
Limitations
SDO


Limitations

Implementation Limitations

The following are limitations in the current SDO implementation:

  1. There is no support for multi-byte character sets. This will be considered, depending on community requirements, in a Unicode-enabled version of PHP.

SDO Limitations

The following SDO 2.0 concepts are not supported in the current PHP implementation. It is not necessarily the case that these will all be added over time. Their inclusion will depend on community requirements.

  1. Bi-directional relationships.

  2. Type and property alias names.

  3. Read-only properties.

  4. The Helper classes defined in SDO 2.0 are not directly implemented. However equivalent function is provided in a more natural way for PHP. For example the function of CopyHelper::copy() is provided by applying the PHP clone keyword to a data object.

Öntanımlı Sabitler
Örnekler
SDO


Örnekler

İçindekiler

  • Basic usage
  • Setting and Getting Property Values
  • Working with Sequenced Data Objects
  • Reflecting on Service Data Objects
Limitations
Basic usage
SDO


Basic usage

The examples below assume an SDO created with the schema and instance information shown below, using the XML Data Access Service.

The instance document below describes a single company, called 'MegaCorp', which contains a single department, called 'Advanced Technologies'. The Advanced Technologies department contains three employees. The company employeeOfTheMonth is referencing the second employee, 'Jane Doe'.

<?xml version="1.0" encoding="UTF-8" ?>
<company xmlns="companyNS" name="MegaCorp"
  employeeOfTheMonth="E0003">
  <departments name="Advanced Technologies" location="NY" number="123">
    <employees name="John Jones" SN="E0001"/>
    <employees name="Jane Doe" SN="E0003"/>
    <employees name="Al Smith" SN="E0004" manager="true"/>
  </departments>
</company>

The root element of the schema is a company. The company contains departments, and each department contains employees. Each element has a number of attributes to store things like name, serial number, and so on. Finally, the company also has an IDREF attribute which identifies one of the employees as the 'employeeOfTheMonth'.

<xsd:schema
  xmlns:xsd="http://www.w3.org/2001/XMLSchema"
  xmlns:sdo="commonj.sdo"
  xmlns:sdoxml="commonj.sdo/xml"
  xmlns:company="companyNS"
  targetNamespace="companyNS">
  <xsd:element name="company" type="company:CompanyType"/>
  <xsd:complexType name="CompanyType">
    <xsd:sequence>
      <xsd:element name="departments" type="company:DepartmentType"
        maxOccurs="unbounded"/>
    </xsd:sequence>
    <xsd:attribute name="name" type="xsd:string"/>
    <xsd:attribute name="employeeOfTheMonth" type="xsd:IDREF"
      sdoxml:propertyType="company:EmployeeType"/>
  </xsd:complexType>
  <xsd:complexType name="DepartmentType">
    <xsd:sequence>
      <xsd:element name="employees" type="company:EmployeeType"
        maxOccurs="unbounded"/>
    </xsd:sequence>
    <xsd:attribute name="name" type="xsd:string"/>
    <xsd:attribute name="location" type="xsd:string"/>
    <xsd:attribute name="number" type="xsd:int"/>
  </xsd:complexType>
  <xsd:complexType name="EmployeeType">
    <xsd:attribute name="name" type="xsd:string"/>
    <xsd:attribute name="SN" type="xsd:ID"/>
    <xsd:attribute name="manager" type="xsd:boolean"/>
  </xsd:complexType>
</xsd:schema>

The XML Data Access Service maps the schema to an SDO. Attributes such as "name" become primitive properties, the sequence of employees becomes a many-valued containment relationship, and so on. Note that the containment relationships are expressed as one complex type within another, whereas non-containment references are expressed in terms of ID and IDREF, with a special sdoxml:propertyType attribute specifying the type of the non-containment reference.

Örnekler
Setting and Getting Property Values
Örnekler


Setting and Getting Property Values

The following examples assume $company is the root of a tree of data objects created from the schema and instance document shown above.

Örnek 1 Access via property name

Data object properties can be accessed using the object property access syntax. The following sets the company name to 'Acme'.

<?php
$company->name = 'Acme';
?>

Örnek 2 Access via property name as array index

We can also access properties using associative array syntax. The simplest form of this uses the property name as the array index. For example, the following sets the company name and gets the employeeOfTheMonth.

<?php
$company['name'] = 'UltraCorp';
$eotm = $company['employeeOfTheMonth'];
?>

Örnek 3 Data Object iteration

We can iterate over the properties of a data object using foreach. The following iterates over the properties of the employee of the month.

<?php
  $eotm = $company->employeeOfTheMonth;
  foreach ($eotm as $name => $value) {
      echo "$name: $value\n";
  }
?>

which will output:

name: Jane Doe
SN: E0003

The 'manager' property is not output, because it has not been set.

Örnek 4 Access many-valued property by name

Many-valued data object properties can also be accessed using the object property name syntax. The following gets the list of departments.

<?php
$departments = $company->departments;
?>

Örnek 5 Many-valued element access

We can access individual elements of many-valued properties using array syntax. The following accesses the first department in the company.

<?php
$ad_tech_dept = $company->departments[0];
?>

Örnek 6 Many-valued property iteration

Many-valued properties can also be iterated over using foreach. The following iterates over the company's departments.

<?php
  foreach ($company->departments as $department) {
    // ...
  }
?>

Each iteration will assign the next department in the list to the variable $department.

Örnek 7 Chained property access

We can chain property references on a single line. The following sets and gets the name of the first department.

<?php
  $company->departments[0]->name = 'Emerging Technologies';
  $dept_name = $company->departments[0]->name;
?>

Using the associative array syntax, this is equivalent to

<?php
  $company['departments'][0]['name'] = 'Emerging Technologies';
  $dept_name = $company['departments'][0]['name'];
?>

In either case, the dept_name variable is set to 'Emerging Technologies'.

Örnek 8 XPath navigation

The associative array index can be an XPath-like expression. Valid expressions are defined by an augmented sub-set of XPath.

Two forms of indexing into many-valued properties are supported. The first is the standard XPath array syntax with the indexing starting at one, the second is an SDO extension to XPath with an index starting at zero. The standard syntax is:

<?php
  $jane_doe = $company["departments[1]/employees[2]"];
?>

and the SDO XPath extension syntax is:

<?php
  $jane_doe = $company["departments.0/employees.1"];
?>

Both these examples get the second employee from the first department.

Örnek 9 XPath querying

We can use XPath to query and identify parts of a data object based on instance data. The following retrieves the manager from the 'Advanced Technologies' department.

<?php
 $ad_tech_mgr =
  $company["departments[name='Advanced Technologies']/employees[manager=true]"];
?>

Örnek 10 Creating child data objects

A data object can be a factory for its child data objects. A child data object is automatically part of the data graph. The following add a new employee to the 'Advanced Technologies' department.

<?php
  $ad_tech_dept = $company["departments[name='Advanced Technologies']"];
  $new_hire = $ad_tech_dept->createDataObject('employees');
  $new_hire->name = 'John Johnson';
  $new_hire->SN = 'E0005';
  $new_hire->manager = false;
?>

Örnek 11 Unset a primitive property

We can use the isset() and unset() functions to test and remove items from the data object.

The following clears the name of the first department.

<?php
  unset($company->departments[0]->name);
?>

Örnek 12 Unset a data object

unset can also be used to remove a data object from the tree. The following example shows John Jones leaving the company.

<?php
  unset($company->departments[0]->employees[0]);
?>

Örnek 13 Unset a referenced data object

The following removes the 'employeeOfTheMonth' from the company. If this were a containment relationship then the employee would be removed from the company (probably not a good idea to sack your best employee each month!), but since this is a non-containment reference, the employee being referenced will remain in the department in the company, but will no longer be accessible via the employeeOfTheMonth property.

<?php
  if (isset($company->employeeOfTheMonth)) {
    unset($company->employeeOfTheMonth);
  }
?>

Örnek 14 Access via property index

Data object properties can be accessed via their property index using array syntax. The property index is the position at which the property's definition appears in the model (in this case the xml schema). We can see from the schema listing above that the company name attribute is the second company property (the SDO interface makes no distinction between XML attributes and elements). The following sets the company name to 'Acme', with the same result as Access via property name

<?php
  $company[1] = 'Acme';
?>

Using the index directly in this way is likely to be fragile. Normally the property name syntax should be preferred, but the property index may be required in special cases.

Basic usage
Working with Sequenced Data Objects
Örnekler


Working with Sequenced Data Objects

Sequenced data objects are SDOs which can track property ordering across the properties of a data object. They can also contain unstructured text elements (text element which do not belong to any of the SDO's properties). Sequenced data objects are useful for working with XML documents which allow unstructured text (i.e. mixed=true) or if the elements can be interleaved (

<A/><B/><A/>
). This can occur for example when the schema defines maxOccurs>1 on a element which is a complexType with a choice order indicator.

The examples below assume an SDO created with the following schema and instance information, using the XML Data Access Service.

The schema below describes the format of a letter. The letter can optionally contain three properties; date, firstName, and lastName. The schema states mixed="true" which means that unstructured text can be interspersed between the three properties.

<xsd:schema xmlns:xsd="http://www.w3.org/2001/XMLSchema"
  xmlns:letter="http://letterSchema"
  targetNamespace="http://letterSchema">
  <xsd:element name="letters" type="letter:FormLetter"/>
  <xsd:complexType name="FormLetter" mixed="true">
    <xsd:sequence>
      <xsd:element name="date" minOccurs="0" type="xsd:string"/>
      <xsd:element name="firstName" minOccurs="0" type="xsd:string"/>
      <xsd:element name="lastName" minOccurs="0" type="xsd:string"/>
    </xsd:sequence>
  </xsd:complexType>
</xsd:schema>

The following is an instance letter document. It contains the three letter properties; date, firstName and lastName, and has unstructured text elements for the address and letter body.

<letter:letters xmlns:letter="http://letterSchema">
  <date>March 1, 2005</date>
  Mutual of Omaha
  Wild Kingdom, USA
  Dear
  <firstName>Casy</firstName>
  <lastName>Crocodile</lastName>
  Please buy more shark repellent.
  Your premium is past due.
</letter:letters>

When loaded, the letter data object will have the sequence and property indices shown in the table below:

Sequence Index | Property Index:Name | Value
0 | 0:date | March 1, 2005
1 | - | Mutual of Omaha
2 | - | Wild Kingdom, USA
3 | - | Dear
4 | 1:firstName | Casy
5 | 2:lastName | Crocodile
6 | - | Please buy more shark repellent.
7 | - | Your premium is past due.

To ensure sequence indices are maintained, sequenced data objects should be manipulated through the SDO_Sequence interface. This allows the data object's instance data to be manipulated in terms of the sequence index as opposed to the property index (shown in the table above). The following examples assume the letter instance has been loaded into a data object referenced by the variable $letter.

Örnek 1 Getting the SDO_Sequence interface

We obtain a data object's sequence using the getSequence() method. The follow gets the sequence for the letter data object.

<?php
  $letter_seq = $letter->getSequence();
?>

All subsequent examples assume that the $letter_seq variable has been assigned the sequence for the letter data object.

Örnek 2 Get/set sequence values

We can get and set individual values (including unstructured text) using the sequence index. The following sets the firstName to 'Snappy' and gets the last sequence values (the unstructured text, 'Your premium is past due.').

<?php
  $letter_seq[4] = 'Snappy';
  $text = $letter_seq[count($letter_seq) - 1];
?>

Örnek 3 Sequence iteration

We can iterate through the individual sequence values using foreach. The following runs through the individual values in sequence order.

<?php
foreach ($letter->getSequence() as $value) {
    // ...
}
?>

Örnek 4 Sequence versus Data Object

Setting values through the data object interface may result in the value not being part of the sequence. A value set through the data object will only be accessible through the sequence if the property was already part of the sequence. The following example sets the lastName through the data object and gets it through the sequence. This is fine because lastName already exists in the sequence. If it had not previously been set, then lastName would be set to 'Smith', but would not be part of the sequence.

<?php
  $letter[2] = 'Smith';
  $last_name = $letter_seq[5];
?>

Örnek 5 Adding to a sequence

We can add new values to a sequence using the SDO_Sequence::insert() method. The following examples assume that the 'firstName' and 'lastName' properties are initially unset.

<?php
  // Append a firstName value to the sequence
  // value: 'Smith'
  // sequence index: NULL (append)
  // propertyIdentifier: 1 (firtName property index)
  $letter_seq->insert('Smith', NULL, 1);

  // Append a lastName value to the sequence
  // value: 'Jones'
  // sequence index: NULL (append)
  // propertyIdentifier: 'lastName' (lastName property name)
  $letter_seq->insert('Jones', NULL, 'lastName');

  // Append unstructured text
  // value: 'Cancel Subscription.'
  // sequence index: absent (append)
  // propertyIdentifier: absent (unstructured text)
  $letter_seq->insert('Cancel Subscription.');

  // Insert new unstructured text.  Subsequent sequence values
  // are shifted up.
  // value: 'Care of:'
  // sequence index: 1 (insert as second element)
  // propertyIdentifier: absent (unstructured text)
  $letter_seq->insert('Care of:', 1);
?>

Örnek 6 Removing from a sequence

We can use the isset() and unset() functions to test and remove items from the sequence (Note: unset() currently leaves the values in the data object, but this behaviour is likely to change to also remove the data from the data object). A sequence behaves like a contiguous list; therefore, removing items from the middle will shift entries at higher indices down. The following example tests to see if the first sequence element is set and unsets it if is.

<?php
  if (isset($letter_seq[0])) {
    unset($letter_seq[0]);
  }
?>

Setting and Getting Property Values
Reflecting on Service Data Objects
Örnekler


Reflecting on Service Data Objects

SDOs have a knowledge of the structure they have been created to represent (the model). For example, a Company SDO created using the Company XML schema above would only be permitted to contain DepartmentType data objects which in turn could only contain EmployeeType data objects.

Sometimes it is useful to be able to access this model information at runtime. For example, this could be used to automatically generate a user interface for populating a data object. The model information is accessed using reflection.

Örnek 1 Reflecting on a Data Object

The following example shows how we can reflect on an empty Employee data object.

<?php
  // Create the employee data object (e.g. from an XML Data Access Service)
  $employee = ...;
  $reflection = new SDO_Model_ReflectionDataObject($employee);
  print($reflection);
?>

Yukarıdaki örneğin çıktısı:

object(SDO_Model_ReflectionDataObject)#4 { - ROOT OBJECT - Type {
companyNS:EmployeeType[3] { commonj.sdo:String $name;
commonj.sdo:String $SN; commonj.sdo:Boolean $manager; } }

Using print on the SDO_Model_ReflectionDataObject writes out the data object's model. We can see from the output how the type companyNS:EmployeeType has three properties and we can see the names of the properties along with their types. Note, the primitive types are listed as SDO types (e.g. commonj.sdo namespace, String type). It is worth noting that this is the SDO model and when these are surfaced to an application they can be treated as the PHP equivalent types (e.g. string and boolean).

Örnek 2 Accessing the type information

We can query the type information of a data object using reflection. The following example checks the type corresponds to a data object rather than a primitive and then iterates through the properties of the type, writing out the name of each property ($type and $property are SDO_Model_Type and SDO_Model_Property objects, respectively).

<?php
    // Create the employee data object (e.g. from an XML Data Access Service)
    $employee = ...;
    $reflection = new SDO_Model_ReflectionDataObject($employee);
    $type = $reflection->getType();
    if (! $type->isDataType()) {
        foreach ($type->getProperties() as $property) {
            print $property->getName() . "\n";
        }
    }
?>

Yukarıdaki örneğin çıktısı:

name
SN
manager

Working with Sequenced Data Objects
SDO İşlevleri
Örnekler


SDO İşlevleri

Data Access Services

The table below lists the currently provided SDO Data Access Services:

DAS Name | Description
SDO_DAS_XML | An XML Data Access Service supporting reading/writing SDOs as XML documents.
SDO_DAS_Relational | A PDO-based Data Access Service supporting reading/writing SDO to relational databases. Implements an optimistic concurrency policy for updates.

Öntanımlı Sınıflar

SDO consists of three sets of interfaces. The first set covers those interfaces for use by typical SDO applications. These are identified by the package prefix 'SDO_'. The second set is those used to reflect on, and work with, the model of a data object. These are identified by the package prefix 'SDO_Model_'. Finally, the third set are those use by Data Access Service implementations and are identified by the package prefix 'SDO_DAS_'. The majority of SDO users will not need to use or understand the 'SDO_Model_' and 'SDO_DAS_' interfaces.

SDO Application Programmer Interface

SDO_DataObject

The main interface through which data objects are manipulated. In addition to the methods below, SDO_DataObject extends the ArrayAccess, SDO_PropertyAccess (defines __get() / __set() methods for property access overloading), Iterator, and Countable interfaces.

Yöntemler

  • getSequence - get the sequence for the data object

  • createDataObject - create a child data object

  • clear - unset the properties of a data object

  • getContainer - get the container (also known as 'parent') of this data object

  • getTypeName - get the name of the type for this data object

  • getTypeNamespaceURI - get the namespace URI of the type for this data object

SDO_Sequence

The interface through which sequenced data objects can be accessed to preserve ordering across a data object's properties and to allow unstructured text. SDO_Sequence preserves contiguous indices and therefore inserting or removing elements may shift other elements up or down. In addition to the methods below, SDO_Sequence extends the ArrayAccess, Iterator and Countable interface.

Yöntemler

  • getProperty - get the property for a given sequence index

  • move - move an element from one property index to another

  • insert - insert a new value into the sequence

SDO_List

The interface through which many-valued properties are manipulated. In addition to the method defined below, SDO_List extends ArrayAccess, Iterator and Countable. SDO_List preserves contiguous indices and therefore inserting or removing elements may shift other elements up or down.

Yöntemler

  • insert - insert a new value into the list

SDO_DataFactory

The interface through which data objects can be created. A Data Access Service is responsible for populating the model (i.e. configuring the data factory with the type and structure information for the data objects it can create.) for the factory and can then optionally return an instance of, or implement, the SDO_DataFactory interface.

Yöntemler

  • create - create a new data object

SDO_Exception

An SDO_Exception is thrown when the caller's request cannot be completed. The subclasses of SDO_Exception are:

  • SDO_PropertyNotSetException - the property specified exists but has not been set or does not have a default value

  • SDO_PropertyNotFoundException - the property specified is not part of the data object's type

  • SDO_TypeNotFoundException - the specified namespace URI or type name is unknown

  • SDO_InvalidConversionException - conversion between the types of the assignment is not possible

  • SDO_IndexOutOfBoundsException - the numeric index into a data object, sequence or list is not in the valid range

  • SDO_UnsupportedOperationException - the request cannot be completed because it is not allowed, for example an attempt to set a read-only property.

Yöntemler

One method is added to those inherited from the built in Exception class:

  • getCause - get the cause of this SDO_Exception

SDO Reflection Application Programmer Interfaces

SDO_Model_ReflectionDataObject

The main interface used to reflect on a data object instance to obtain its model type and property information. It is designed to follow the reflection pattern introduced in PHP 5.

Nesne Kurucu

  • __construct - construct a new SDO_Model_ReflectionDataObject.

Yöntemler

  • export - get a string describing the data object.

  • getType - get the SDO_Model_Type for the data object.

  • getInstanceProperties - get the instance properties of the data object.

  • getContainmentProperty - get the property which defines the containment relationship to the data object.

SDO_Model_Type

The interface through which a data object's type information can be retrieved. This interface can be used to find out the type name and namespace URI of the type, whether the type allow open content, and so on.

Yöntemler

  • getName - get the name of the type.

  • getNamespaceURI - get the namespace URI of the type.

  • isInstance - test for a data object being an instance of the type.

  • getProperties - get the properties of the type.

  • getProperty - get a property of the type.

  • isDataType - test to see if this type is a primitive scalar type.

  • isSequencedType - test to see if this is a sequenced type.

  • isOpenType - test to see if this is an open type.

  • isAbstractType - test to see if this is an abstract type.

  • getBaseType - get the base type of this type (if one exists).

SDO_Model_Property

The interface through which a data object's property information can be retrieved. This interface can be used to find out the type of a property, whether a property has a default value, whether the property is contained or reference by its parent, its cardinality, and so on.

Yöntemler

  • getName - get the name of the property.

  • getType - get the type of the property.

  • isMany - test to see if the property is many-valued.

  • isContainment - test to see if the property describes a containment relationship.

  • getContainingType - get the type which contains this property.

  • getDefault - get the default value for a property.

SDO Data Access Service Developer Interfaces

SDO_DAS_DataObject

The interface through which a Data Access Service can access a data object's SDO_DAS_ChangeSummary. The change summary is used by the Data Access Service to check for conflicts when applying changes back to a data source.

Yöntemler

  • getChangeSummary - get the change summary for a data object

SDO_DAS_ChangeSummary

The interface through which the change history of a data object is accessed. The change summary holds information for any modifications on a data object which occurred since logging was activated. In the case of deletions and modifications, the old values are also held in the change summary.

If logging is no longer active then the change summary only holds changes made up to the point when logging was deactivated. Reactivating logging clears the change summary. This is useful when a set of changes have been written out by a DAS and the data object is to be reused.

Yöntemler

  • beginLogging - begin logging changes made to a data object

  • endLogging - end logging changes made to a data object

  • isLogging - test to see if change logging is on

  • getChangedDataObjects - get a list of the data objects which have been changed

  • getChangeType - get the type of change which has been made to a data object

  • getOldValues - get a list of old values for a data object

  • getOldContainer - get the old container data object for a deleted data object

SDO_DAS_Setting

The interface through which the old value for a property is accessed. A list of settings is returned by the change summary method getOldValues.

Yöntemler

  • getPropertyIndex - get the property index for the changed property

  • getPropertyName - get the property name for the changed property

  • getValue - get the old value for the changed property

  • getListIndex - get the list index for the old value if it was part of a many-valued property

  • isSet - test to see if the property was set prior to being modified

SDO_DAS_DataFactory

The interface for constructing the model for an SDO_DataObject. The SDO_DAS_DataFactory is an abstract class providing a static method which returns a concrete data factory implementation. The implementation is used by Data Access Services to create an SDO model from their model. For example, a Relational Data Access Service might create and populate an SDO_DAS_DataFactory model based on a schema for a relational database.

Yöntemler

  • getDataFactory - static methods for getting a concrete data factory instance

  • addType - add a new type to the SDO model

  • addPropertyToType - add a new property to a type definition in the SDO model

İçindekiler

  • SDO_DAS_ChangeSummary::beginLogging — Begin change logging
  • SDO_DAS_ChangeSummary::endLogging — End change logging
  • SDO_DAS_ChangeSummary::getChangeType — Get the type of change made to an SDO_DataObject
  • SDO_DAS_ChangeSummary::getChangedDataObjects — Get the changed data objects from a change summary
  • SDO_DAS_ChangeSummary::getOldContainer — Get the old container for a deleted SDO_DataObject
  • SDO_DAS_ChangeSummary::getOldValues — Get the old values for a given changed SDO_DataObject
  • SDO_DAS_ChangeSummary::isLogging — Test to see whether change logging is switched on
  • SDO_DAS_DataFactory::addPropertyToType — Adds a property to a type
  • SDO_DAS_DataFactory::addType — Add a new type to a model
  • SDO_DAS_DataFactory::getDataFactory — Get a data factory instance
  • SDO_DAS_DataObject::getChangeSummary — Get a data object's change summary
  • SDO_DAS_Setting::getListIndex — Get the list index for a changed many-valued property
  • SDO_DAS_Setting::getPropertyIndex — Get the property index for a changed property
  • SDO_DAS_Setting::getPropertyName — Get the property name for a changed property
  • SDO_DAS_Setting::getValue — Get the old value for the changed property
  • SDO_DAS_Setting::isSet — Test whether a property was set prior to being modified
  • SDO_DataFactory::create — Create an SDO_DataObject
  • SDO_DataObject::clear — Clear an SDO_DataObject's properties
  • SDO_DataObject::createDataObject — Create a child SDO_DataObject
  • SDO_DataObject::getContainer — Get a data object's container
  • SDO_DataObject::getSequence — Get the sequence for a data object
  • SDO_DataObject::getTypeName — Return the name of the type for a data object.
  • SDO_DataObject::getTypeNamespaceURI — Return the namespace URI of the type for a data object.
  • SDO_Exception::getCause — Get the cause of the exception.
  • SDO_List::insert — Insert into a list
  • SDO_Model_Property::getContainingType — Get the SDO_Model_Type which contains this property
  • SDO_Model_Property::getDefault — Get the default value for the property
  • SDO_Model_Property::getName — Get the name of the SDO_Model_Property
  • SDO_Model_Property::getType — Get the SDO_Model_Type of the property
  • SDO_Model_Property::isContainment — Test to see if the property defines a containment relationship
  • SDO_Model_Property::isMany — Test to see if the property is many-valued
  • SDO_Model_ReflectionDataObject::__construct — Construct an SDO_Model_ReflectionDataObject
  • SDO_Model_ReflectionDataObject::export — Get a string describing the SDO_DataObject.
  • SDO_Model_ReflectionDataObject::getContainmentProperty — Get the property which defines the containment relationship to the data object
  • SDO_Model_ReflectionDataObject::getInstanceProperties — Get the instance properties of the SDO_DataObject
  • SDO_Model_ReflectionDataObject::getType — Get the SDO_Model_Type for the SDO_DataObject
  • SDO_Model_Type::getBaseType — Get the base type for this type
  • SDO_Model_Type::getName — Get the name of the type
  • SDO_Model_Type::getNamespaceURI — Get the namespace URI of the type
  • SDO_Model_Type::getProperties — Get the SDO_Model_Property objects defined for the type
  • SDO_Model_Type::getProperty — Get an SDO_Model_Property of the type
  • SDO_Model_Type::isAbstractType — Test to see if this SDO_Model_Type is an abstract data type
  • SDO_Model_Type::isDataType — Test to see if this SDO_Model_Type is a primitive data type
  • SDO_Model_Type::isInstance — Test for an SDO_DataObject being an instance of this SDO_Model_Type
  • SDO_Model_Type::isOpenType — Test to see if this type is an open type
  • SDO_Model_Type::isSequencedType — Test to see if this is a sequenced type
  • SDO_Sequence::getProperty — Return the property for the specified sequence index.
  • SDO_Sequence::insert — Insert into a sequence
  • SDO_Sequence::move — Move an item to another sequence position
Reflecting on Service Data Objects
SDO_DAS_ChangeSummary::beginLogging
SDO


Begin change logging

SDO İşlevleri
SDO_DAS_ChangeSummary::endLogging
SDO İşlevleri
PHP Manual

SDO_DAS_ChangeSummary::beginLogging

(^)

SDO_DAS_ChangeSummary::beginLogging — Begin change logging

Açıklama

void SDO_DAS_ChangeSummary::beginLogging ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Begin logging changes made to the SDO_DataObject.

Değiştirgeler

None.

Dönen Değerler

None.

SDO İşlevleri
SDO_DAS_ChangeSummary::endLogging
SDO İşlevleri


End change logging

SDO_DAS_ChangeSummary::beginLogging
SDO_DAS_ChangeSummary::getChangeType
SDO İşlevleri
PHP Manual

SDO_DAS_ChangeSummary::endLogging

(^)

SDO_DAS_ChangeSummary::endLogging — End change logging

Açıklama

void SDO_DAS_ChangeSummary::endLogging ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

End logging changes made to an SDO_DataObject.

Değiştirgeler

None.

Dönen Değerler

None.

SDO_DAS_ChangeSummary::beginLogging
SDO_DAS_ChangeSummary::getChangeType
SDO İşlevleri


Get the type of change made to an SDO_DataObject

SDO_DAS_ChangeSummary::endLogging
SDO_DAS_ChangeSummary::getChangedDataObjects
SDO İşlevleri
PHP Manual

SDO_DAS_ChangeSummary::getChangeType

(^)

SDO_DAS_ChangeSummary::getChangeType — Get the type of change made to an SDO_DataObject

Açıklama

int SDO_DAS_ChangeSummary::getChangeType ( SDO_DataObject $dataObject )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Get the type of change which has been made to the supplied SDO_DataObject.

Değiştirgeler

dataObject

The SDO_DataObject which has been changed.

Dönen Değerler

The type of change which has been made. The change type is expressed as an enumeration and will be one of the following four values:

  • SDO_DAS_ChangeSummary::NONE

  • SDO_DAS_ChangeSummary::MODIFICATION

  • SDO_DAS_ChangeSummary::ADDITION

  • SDO_DAS_ChangeSummary::DELETION

SDO_DAS_ChangeSummary::endLogging
SDO_DAS_ChangeSummary::getChangedDataObjects
SDO İşlevleri


Get the changed data objects from a change summary

SDO_DAS_ChangeSummary::getChangeType
SDO_DAS_ChangeSummary::getOldContainer
SDO İşlevleri
PHP Manual

SDO_DAS_ChangeSummary::getChangedDataObjects

(^)

SDO_DAS_ChangeSummary::getChangedDataObjects — Get the changed data objects from a change summary

Açıklama

SDO_List SDO_DAS_ChangeSummary::getChangedDataObjects ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Get an SDO_List of the SDO_DataObjects which have been changed. These data objects can then be used to identify the types of change made to each, along with the old values.

Değiştirgeler

None.

Dönen Değerler

Returns an SDO_List of SDO_DataObjects.

SDO_DAS_ChangeSummary::getChangeType
SDO_DAS_ChangeSummary::getOldContainer
SDO İşlevleri


Get the old container for a deleted SDO_DataObject

SDO_DAS_ChangeSummary::getChangedDataObjects
SDO_DAS_ChangeSummary::getOldValues
SDO İşlevleri
PHP Manual

SDO_DAS_ChangeSummary::getOldContainer

(^)

SDO_DAS_ChangeSummary::getOldContainer — Get the old container for a deleted SDO_DataObject

Açıklama

SDO_DataObject SDO_DAS_ChangeSummary::getOldContainer ( SDO_DataObject $data_object )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Get the old container (SDO_DataObject) for a deleted SDO_DataObject.

Değiştirgeler

data_object

The SDO_DataObject which has been deleted and whose container we wish to identify.

Dönen Değerler

The old containing data object of the deleted SDO_DataObject.

SDO_DAS_ChangeSummary::getChangedDataObjects
SDO_DAS_ChangeSummary::getOldValues
SDO İşlevleri


Get the old values for a given changed SDO_DataObject

SDO_DAS_ChangeSummary::getOldContainer
SDO_DAS_ChangeSummary::isLogging
SDO İşlevleri
PHP Manual

SDO_DAS_ChangeSummary::getOldValues

(^)

SDO_DAS_ChangeSummary::getOldValues — Get the old values for a given changed SDO_DataObject

Açıklama

SDO_List SDO_DAS_ChangeSummary::getOldValues ( SDO_DataObject $data_object )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Get a list of the old values for a given changed SDO_DataObject. Returns a list of SDO_DAS_Settings describing the old values for the changed properties of the SDO_DataObject.

Değiştirgeler

data_object

The data object which has been changed.

Dönen Değerler

A list of SDO_DAS_Settings describing the old values for the changed properties of the SDO_DataObject. If the change type is SDO_DAS_ChangeSummary::ADDITION, this list is empty.

SDO_DAS_ChangeSummary::getOldContainer
SDO_DAS_ChangeSummary::isLogging
SDO İşlevleri


Test to see whether change logging is switched on

SDO_DAS_ChangeSummary::getOldValues
SDO_DAS_DataFactory::addPropertyToType
SDO İşlevleri
PHP Manual

SDO_DAS_ChangeSummary::isLogging

(^)

SDO_DAS_ChangeSummary::isLogging — Test to see whether change logging is switched on

Açıklama

bool SDO_DAS_ChangeSummary::isLogging ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Test to see whether change logging is switched on.

Değiştirgeler

None.

Dönen Değerler

Returns TRUE if change logging is on, otherwise returns FALSE.

SDO_DAS_ChangeSummary::getOldValues
SDO_DAS_DataFactory::addPropertyToType
SDO İşlevleri


Adds a property to a type

SDO_DAS_ChangeSummary::isLogging
SDO_DAS_DataFactory::addType
SDO İşlevleri
PHP Manual

SDO_DAS_DataFactory::addPropertyToType

(^)

SDO_DAS_DataFactory::addPropertyToType — Adds a property to a type

Açıklama

void SDO_DAS_DataFactory::addPropertyToType ( string $parent_type_namespace_uri , string $parent_type_name , string $property_name , string $type_namespace_uri , string $type_name [, array $options ] )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Adds a property to a type. The type must already be known to the SDO_DAS_DataFactory (i.e. have been added using addType()). The property becomes a property of the type. This is how the graph model for the structure of an SDO_DataObject is built.

Değiştirgeler

parent_type_namespace_uri

The namespace URI for the parent type.

parent_type_name

The type name for the parent type.

property_name

The name by which the property will be known in the parent type.

type_namespace_uri

The namespace URI for the type of the property.

type_name

The type name for the type of the property

options

This array holds one or more key=>value pairs to set attribute values for the property. The optional keywords are:

many

A flag to say whether the property is many-valued. A value of 'true' adds the property as a many-valued property (default is 'false').

readOnly

A flag to say whether the property is read-only. A value of 'true' means the property value cannot be modified through the SDO application APIs (default is 'false').

containment

A flag to say whether the property is contained by the parent. A value of 'true' means the property is contained by the parent. A value of 'false' results in a non-containment reference (default is 'true'). This flag is only interpreted when adding properties which are data object types, otherwise it is ignored.

default

A default value for the property. Omitting this key means that the property does not have a default value. A property can only have a default value if it is a single-valued data type (primitive).

Dönen Değerler

None.

Sürüm Bilgisi

Sürüm: | Açıklama
0.5.2 | Optional parameters many, readOnly, and containment deprecated in favour of the options array.

Örnekler

Örnek 1 A SDO_DAS_DataFactory::addPropertyToType() example

The following adds an 'addressline' property to a Person type. The person type is identified by its namespace, 'PersonNS', and type name, 'PersonType'. The type of the 'addressline' property is a many-valued SDO data type (primitive) with namespace 'commonj.sdo' and type name 'String'.

<?php
  $df->addPropertyToType('PersonNS', 'PersonType',
    'addressline', 'commonj.sdo', 'String', array('many'=>true));
?>

SDO_DAS_ChangeSummary::isLogging
SDO_DAS_DataFactory::addType
SDO İşlevleri


Add a new type to a model

SDO_DAS_DataFactory::addPropertyToType
SDO_DAS_DataFactory::getDataFactory
SDO İşlevleri
PHP Manual

SDO_DAS_DataFactory::addType

(^)

SDO_DAS_DataFactory::addType — Add a new type to a model

Açıklama

void SDO_DAS_DataFactory::addType ( string $type_namespace_uri , string $type_name [, array $options ] )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Add a new type to the SDO_DAS_DataFactory, defined by its namespace and type name. The type becomes part of the model of data objects that the data factory can create.

Değiştirgeler

type_namespace_uri

The namespace of the type.

type_name

The name of the type.

options

This array holds one or more key=>value pairs to set attribute values for the type. The optional keywords are:

open

A flag to say whether the type is open. An SDO_DataObject whose type is open can have properties added to them which are not described by the type. This capability is used to support working with XML documents whose schema support open content such as that described by an <xsd:any> element. The default value is 'false'.

sequenced

A flag to say whether the type is sequenced. Sequenced types can have the ordering across properties preserved and can contain unstructured text. The default value is 'false'. For more information on sequenced types see the section on Working with Sequenced Data Objects.

basetype

If specified, an array of namespace URI and type name strings for the type from which this type is derived. An example of the use of base types is when a type derived in an XML schema inherits from another type by using <extension base="...">.

Dönen Değerler

None.

Örnekler

Örnek 1 A SDO_DAS_DataFactory::addType() example

The following adds a new data object type of 'CompanyType' where that type belongs to the namespace 'CompanyNS'.

<?php
  $df->addType('CompanyNS', 'CompanyType');
?>

SDO_DAS_DataFactory::addPropertyToType
SDO_DAS_DataFactory::getDataFactory
SDO İşlevleri


Get a data factory instance

SDO_DAS_DataFactory::addType
SDO_DAS_DataObject::getChangeSummary
SDO İşlevleri
PHP Manual

SDO_DAS_DataFactory::getDataFactory

(^)

SDO_DAS_DataFactory::getDataFactory — Get a data factory instance

Açıklama

SDO_DAS_DataFactory SDO_DAS_DataFactory::getDataFactory ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Static method to get an instance of an SDO_DAS_DataFactory. This instance is initially only configured with the basic SDO types. A Data Access Service is responsible for populating the data factory model and then allowing PHP applications to create SDOs based on the model through the SDO_DataFactory interface. PHP applications should always obtain a data factory from a configured Data Access Service, not through this interface.

Değiştirgeler

None.

Dönen Değerler

Returns an SDO_DAS_DataFactory.

SDO_DAS_DataFactory::addType
SDO_DAS_DataObject::getChangeSummary
SDO İşlevleri


Get a data object's change summary

SDO_DAS_DataFactory::getDataFactory
SDO_DAS_Setting::getListIndex
SDO İşlevleri
PHP Manual

SDO_DAS_DataObject::getChangeSummary

(^)

SDO_DAS_DataObject::getChangeSummary — Get a data object's change summary

Açıklama

SDO_DAS_ChangeSummary SDO_DAS_DataObject::getChangeSummary ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Get the SDO_DAS_ChangeSummary for an SDO_DAS_DataObject, or NULL if it does not have one.

Değiştirgeler

None.

Dönen Değerler

Returns the SDO_DAS_ChangeSummary for an SDO_DAS_DataObject, or NULL if it does not have one.

SDO_DAS_DataFactory::getDataFactory
SDO_DAS_Setting::getListIndex
SDO İşlevleri


Get the list index for a changed many-valued property

SDO_DAS_DataObject::getChangeSummary
SDO_DAS_Setting::getPropertyIndex
SDO İşlevleri
PHP Manual

SDO_DAS_Setting::getListIndex

(^)

SDO_DAS_Setting::getListIndex — Get the list index for a changed many-valued property

Açıklama

int SDO_DAS_Setting::getListIndex ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Get the list index for a modification made to an element of a many-valued property. For example, if we modified the third element of a many-valued property we could obtain an SDO_DAS_Setting from the change summary corresponding to that modification. A call to getListIndex() on that setting would return the value 2 (lists are indexed from zero).

Değiştirgeler

None.

Dönen Değerler

The list index for the element of the many-valued property which has been changed.

SDO_DAS_DataObject::getChangeSummary
SDO_DAS_Setting::getPropertyIndex
SDO İşlevleri


Get the property index for a changed property

SDO_DAS_Setting::getListIndex
SDO_DAS_Setting::getPropertyName
SDO İşlevleri
PHP Manual

SDO_DAS_Setting::getPropertyIndex

(^)

SDO_DAS_Setting::getPropertyIndex — Get the property index for a changed property

Açıklama

int SDO_DAS_Setting::getPropertyIndex ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Returns the property index for the changed property. This index identifies the property which was modified in data object.

Değiştirgeler

None.

Dönen Değerler

The property index for a changed property.

SDO_DAS_Setting::getListIndex
SDO_DAS_Setting::getPropertyName
SDO İşlevleri


Get the property name for a changed property

SDO_DAS_Setting::getPropertyIndex
SDO_DAS_Setting::getValue
SDO İşlevleri
PHP Manual

SDO_DAS_Setting::getPropertyName

(^)

SDO_DAS_Setting::getPropertyName — Get the property name for a changed property

Açıklama

string SDO_DAS_Setting::getPropertyName ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Returns the property name for the changed property. This name identifies the property which was modified in data object.

Değiştirgeler

None.

Dönen Değerler

The property name for a changed property.

SDO_DAS_Setting::getPropertyIndex
SDO_DAS_Setting::getValue
SDO İşlevleri


Get the old value for the changed property

SDO_DAS_Setting::getPropertyName
SDO_DAS_Setting::isSet
SDO İşlevleri
PHP Manual

SDO_DAS_Setting::getValue

(^)

SDO_DAS_Setting::getValue — Get the old value for the changed property

Açıklama

mixed SDO_DAS_Setting::getValue ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Returns the old value for the changed property. This can be used by a Data Access Service when writing updates to a data source. The DAS uses the old value to detect conflicts by comparing it with the current value in the data source. If they do not match, then the data source has been updated since the data object was originally populated, and therefore writing any new updates risks compromising the integrity of the data.

Değiştirgeler

None.

Dönen Değerler

Returns the old value of the changed property.

SDO_DAS_Setting::getPropertyName
SDO_DAS_Setting::isSet
SDO İşlevleri


Test whether a property was set prior to being modified

SDO_DAS_Setting::getValue
SDO_DataFactory::create
SDO İşlevleri
PHP Manual

SDO_DAS_Setting::isSet

(^)

SDO_DAS_Setting::isSet — Test whether a property was set prior to being modified

Açıklama

bool SDO_DAS_Setting::isSet ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Test whether a property was set prior to being modified. If it was set prior to being modified then the SDO_DAS_Setting will also contain the old value.

Değiştirgeler

None.

Dönen Değerler

Returns TRUE if the property was set prior to being modified, otherwise returns FALSE.

SDO_DAS_Setting::getValue
SDO_DataFactory::create
SDO İşlevleri


Create an SDO_DataObject

SDO_DAS_Setting::isSet
SDO_DataObject::clear
SDO İşlevleri
PHP Manual

SDO_DataFactory::create

(^)

SDO_DataFactory::create — Create an SDO_DataObject

Açıklama

void SDO_DataFactory::create ( string $type_namespace_uri , string $type_name )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Create a new SDO_DataObject given the data object's namespace URI and type name.

Değiştirgeler

type_namespace_uri

The namespace of the type.

type_name

The name of the type.

Dönen Değerler

Returns the newly created SDO_DataObject.

Hatalar/İstisnalar

SDO_TypeNotFoundException

Thrown if the namespaceURI and typeName do not correspond to a type known to this data factory.

SDO_DAS_Setting::isSet
SDO_DataObject::clear
SDO İşlevleri


Clear an SDO_DataObject's properties

SDO_DataFactory::create
SDO_DataObject::createDataObject
SDO İşlevleri
PHP Manual

SDO_DataObject::clear

(^)

SDO_DataObject::clear — Clear an SDO_DataObject's properties

Açıklama

void SDO_DataObject::clear ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Clear an SDO_DataObject's properties. Read-only properties are unaffected. Subsequent calls to isset() for the data object will return FALSE.

Değiştirgeler

None.

Dönen Değerler

No return values.

SDO_DataFactory::create
SDO_DataObject::createDataObject
SDO İşlevleri


Create a child SDO_DataObject

SDO_DataObject::clear
SDO_DataObject::getContainer
SDO İşlevleri
PHP Manual

SDO_DataObject::createDataObject

(^)

SDO_DataObject::createDataObject — Create a child SDO_DataObject

Açıklama

SDO_DataObject SDO_DataObject::createDataObject ( mixed $identifier )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Create a child SDO_DataObject of the default type for the property identified. The data object is automatically inserted into the tree and a reference to it is returned.

Değiştirgeler

identifier

Identifies the property for the data object type to be created. Can be either a property name (string), a property index (int), or an SDO_Model_Property.

Dönen Değerler

Returns the newly created SDO_DataObject.

Hatalar/İstisnalar

SDO_PropertyNotFoundException

Thrown if the identifier does not correspond to a property of the data object.

SDO_DataObject::clear
SDO_DataObject::getContainer
SDO İşlevleri


Get a data object's container

SDO_DataObject::createDataObject
SDO_DataObject::getSequence
SDO İşlevleri
PHP Manual

SDO_DataObject::getContainer

(^)

SDO_DataObject::getContainer — Get a data object's container

Açıklama

SDO_DataObject SDO_DataObject::getContainer ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Get the data object which contains this data object.

Değiştirgeler

None.

Dönen Değerler

Returns the SDO_DataObject which contains this SDO_DataObject, or returns NULL if this is a root SDO_DataObject (i.e. it has no container).

SDO_DataObject::createDataObject
SDO_DataObject::getSequence
SDO İşlevleri


Get the sequence for a data object

SDO_DataObject::getContainer
SDO_DataObject::getTypeName
SDO İşlevleri
PHP Manual

SDO_DataObject::getSequence

(^)

SDO_DataObject::getSequence — Get the sequence for a data object

Açıklama

SDO_Sequence SDO_DataObject::getSequence ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Return the SDO_Sequence for this SDO_DataObject. Accessing the SDO_DataObject through the SDO_Sequence interface acts on the same SDO_DataObject instance data, but preserves ordering across properties.

Değiştirgeler

None.

Dönen Değerler

The SDO_Sequence for this SDO_DataObject, or returns NULL if the SDO_DataObject is not of a type which can have a sequence.

SDO_DataObject::getContainer
SDO_DataObject::getTypeName
SDO İşlevleri


Return the name of the type for a data object.

SDO_DataObject::getSequence
SDO_DataObject::getTypeNamespaceURI
SDO İşlevleri
PHP Manual

SDO_DataObject::getTypeName

(^)

SDO_DataObject::getTypeName — Return the name of the type for a data object.

Açıklama

string SDO_DataObject::getTypeName ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Return the name of the type for a data object. A convenience method corresponding to SDO_Model_ReflectionDataObject::getType().getName().

Değiştirgeler

None.

Dönen Değerler

The name of the type for the data object.

SDO_DataObject::getSequence
SDO_DataObject::getTypeNamespaceURI
SDO İşlevleri


Return the namespace URI of the type for a data object.

SDO_DataObject::getTypeName
SDO_Exception::getCause
SDO İşlevleri
PHP Manual

SDO_DataObject::getTypeNamespaceURI

(^)

SDO_DataObject::getTypeNamespaceURI — Return the namespace URI of the type for a data object.

Açıklama

string SDO_DataObject::getTypeNamespaceURI ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Return the namespace URI of the type for a data object. A convenience method corresponding to SDO_Model_ReflectionDataObject::getType().getNamespaceURI().

Değiştirgeler

None.

Dönen Değerler

The namespace URI of the type for the data object.

SDO_DataObject::getTypeName
SDO_Exception::getCause
SDO İşlevleri


Get the cause of the exception.

SDO_DataObject::getTypeNamespaceURI
SDO_List::insert
SDO İşlevleri
PHP Manual

SDO_Exception::getCause

(^)

SDO_Exception::getCause — Get the cause of the exception.

Açıklama

mixed SDO_Exception::getCause ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Returns the cause of this exception or NULL if the cause is nonexistent or unknown. Typically the cause will be an SDO_CPPException object, which may be used to obtain additional diagnostic information.

Değiştirgeler

None.

Dönen Değerler

Returns the cause of this exception or NULL if the cause is nonexistent or unknown.

SDO_DataObject::getTypeNamespaceURI
SDO_List::insert
SDO İşlevleri


Insert into a list

SDO_Exception::getCause
SDO_Model_Property::getContainingType
SDO İşlevleri
PHP Manual

SDO_List::insert

(^)

SDO_List::insert — Insert into a list

Açıklama

void SDO_List::insert ( mixed $value [, int $index ] )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Insert a new element at a specified position in the list. All subsequent list items are moved up.

Değiştirgeler

value

The new value to be inserted. This can be either a primitive or an SDO_DataObject.

index

The position at which to insert the new element. If this argument is not specified then the new value will be appended.

Dönen Değerler

None.

Hatalar/İstisnalar

SDO_IndexOutOfBoundsException

Thrown if the list index is less than zero or greater than the size of the list.

SDO_InvalidConversionException

Thrown if the type of the new value does not match the type for the list (e.g. the type of the many-valued property that the list represents).

SDO_Exception::getCause
SDO_Model_Property::getContainingType
SDO İşlevleri


Get the SDO_Model_Type which contains this property

SDO_List::insert
SDO_Model_Property::getDefault
SDO İşlevleri
PHP Manual

SDO_Model_Property::getContainingType

(^)

SDO_Model_Property::getContainingType — Get the SDO_Model_Type which contains this property

Açıklama

SDO_Model_Type SDO_Model_Property::getContainingType ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Returns the SDO_Model_Type which contains this property.

Değiştirgeler

None.

Dönen Değerler

Returns the SDO_Model_Type which contains this property.

SDO_List::insert
SDO_Model_Property::getDefault
SDO İşlevleri


Get the default value for the property

SDO_Model_Property::getContainingType
SDO_Model_Property::getName
SDO İşlevleri
PHP Manual

SDO_Model_Property::getDefault

(^)

SDO_Model_Property::getDefault — Get the default value for the property

Açıklama

mixed SDO_Model_Property::getDefault ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Returns the default value for the property. Only primitive data type properties can have default values.

Değiştirgeler

None.

Dönen Değerler

Returns the default value for the property.

SDO_Model_Property::getContainingType
SDO_Model_Property::getName
SDO İşlevleri


Get the name of the SDO_Model_Property

SDO_Model_Property::getDefault
SDO_Model_Property::getType
SDO İşlevleri
PHP Manual

SDO_Model_Property::getName

(^)

SDO_Model_Property::getName — Get the name of the SDO_Model_Property

Açıklama

string SDO_Model_Property::getName ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Returns the name of the SDO_Model_Property.

Değiştirgeler

None.

Dönen Değerler

Returns the name of the SDO_Model_Property.

SDO_Model_Property::getDefault
SDO_Model_Property::getType
SDO İşlevleri


Get the SDO_Model_Type of the property

SDO_Model_Property::getName
SDO_Model_Property::isContainment
SDO İşlevleri
PHP Manual

SDO_Model_Property::getType

(^)

SDO_Model_Property::getType — Get the SDO_Model_Type of the property

Açıklama

SDO_Model_Type SDO_Model_Property::getType ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Get the SDO_Model_Type of the property. The SDO_Model_Type describes the type information for the property, such as its type name, namespace URI, whether it is a primitive data type, and so on.

Değiştirgeler

None.

Dönen Değerler

Returns the SDO_Model_Type describing the property's type information.

SDO_Model_Property::getName
SDO_Model_Property::isContainment
SDO İşlevleri


Test to see if the property defines a containment relationship

SDO_Model_Property::getType
SDO_Model_Property::isMany
SDO İşlevleri
PHP Manual

SDO_Model_Property::isContainment

(^)

SDO_Model_Property::isContainment — Test to see if the property defines a containment relationship

Açıklama

bool SDO_Model_Property::isContainment ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Test to see if the property corresponds to a containment relationship. Returns TRUE if the property defines a containment relationship, or FALSE if it is reference.

Değiştirgeler

None.

Dönen Değerler

Returns TRUE if the property defines a containment relationship, or FALSE if it is reference.

SDO_Model_Property::getType
SDO_Model_Property::isMany
SDO İşlevleri


Test to see if the property is many-valued

SDO_Model_Property::isContainment
SDO_Model_ReflectionDataObject::__construct
SDO İşlevleri
PHP Manual

SDO_Model_Property::isMany

(^)

SDO_Model_Property::isMany — Test to see if the property is many-valued

Açıklama

bool SDO_Model_Property::isMany ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Test to see if the property is many-valued. Returns TRUE if this is a many-valued property, otherwise returns FALSE.

Değiştirgeler

None.

Dönen Değerler

Returns TRUE if this is a many-valued property, otherwise returns FALSE.

SDO_Model_Property::isContainment
SDO_Model_ReflectionDataObject::__construct
SDO İşlevleri


Construct an SDO_Model_ReflectionDataObject

SDO_Model_Property::isMany
SDO_Model_ReflectionDataObject::export
SDO İşlevleri
PHP Manual

SDO_Model_ReflectionDataObject::__construct

(^)

SDO_Model_ReflectionDataObject::__construct — Construct an SDO_Model_ReflectionDataObject

Açıklama

SDO_Model_ReflectionDataObject::__construct ( SDO_DataObject $data_object )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Construct an SDO_Model_ReflectionDataObject to reflect on an SDO_DataObject. Reflecting on an SDO_DataObject gives access to information about its model. The model contains information such as the data object's type, and whether that type is sequenced (preserves ordering across properties) or open (each instance can have its model extended). The model also holds information about the data object's properties, any default values they may have, and so on.

Değiştirgeler

data_object

The SDO_DataObject being reflected upon.

Dönen Değerler

None.

SDO_Model_Property::isMany
SDO_Model_ReflectionDataObject::export
SDO İşlevleri


Get a string describing the SDO_DataObject.

SDO_Model_ReflectionDataObject::__construct
SDO_Model_ReflectionDataObject::getContainmentProperty
SDO İşlevleri
PHP Manual

SDO_Model_ReflectionDataObject::export

(^)

SDO_Model_ReflectionDataObject::export — Get a string describing the SDO_DataObject.

Açıklama

mixed SDO_Model_ReflectionDataObject::export ( SDO_Model_ReflectionDataObject $rdo [, bool $return ] )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Get a string describing the SDO_DataObject. The default behaviour is to print the output, but if TRUE is specified for return, it is returned as a string.

Değiştirgeler

rdo

An SDO_Model_ReflectionDataObject.

return

If TRUE, return the output as a string, otherwise print it.

Dönen Değerler

Returns the output if TRUE is specified for return, otherwise NULL.

SDO_Model_ReflectionDataObject::__construct
SDO_Model_ReflectionDataObject::getContainmentProperty
SDO İşlevleri


Get the property which defines the containment relationship to the data object

SDO_Model_ReflectionDataObject::export
SDO_Model_ReflectionDataObject::getInstanceProperties
SDO İşlevleri
PHP Manual

SDO_Model_ReflectionDataObject::getContainmentProperty

(^)

SDO_Model_ReflectionDataObject::getContainmentProperty — Get the property which defines the containment relationship to the data object

Açıklama

SDO_Model_Property SDO_Model_ReflectionDataObject::getContainmentProperty ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Get the SDO_Model_Property that contains the SDO_DataObject. This method is used to navigate up to the parent's property which contains the data object which has been reflected upon.

Değiştirgeler

None.

Dönen Değerler

Returns the container's SDO_Model_Property which references the SDO_DataObject, or NULL if it is a root SDO_DataObject.

SDO_Model_ReflectionDataObject::export
SDO_Model_ReflectionDataObject::getInstanceProperties
SDO İşlevleri


Get the instance properties of the SDO_DataObject

SDO_Model_ReflectionDataObject::getContainmentProperty
SDO_Model_ReflectionDataObject::getType
SDO İşlevleri
PHP Manual

SDO_Model_ReflectionDataObject::getInstanceProperties

(^)

SDO_Model_ReflectionDataObject::getInstanceProperties — Get the instance properties of the SDO_DataObject

Açıklama

array SDO_Model_ReflectionDataObject::getInstanceProperties ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Get the instance properties for the SDO_DataObject. The instance properties consist of all the properties defined on the data object's type, plus any instance properties from open content (if the data object is an open type).

Değiştirgeler

None.

Dönen Değerler

An array of SDO_Model_Property objects.

SDO_Model_ReflectionDataObject::getContainmentProperty
SDO_Model_ReflectionDataObject::getType
SDO İşlevleri


Get the SDO_Model_Type for the SDO_DataObject

SDO_Model_ReflectionDataObject::getInstanceProperties
SDO_Model_Type::getBaseType
SDO İşlevleri
PHP Manual

SDO_Model_ReflectionDataObject::getType

(^)

SDO_Model_ReflectionDataObject::getType — Get the SDO_Model_Type for the SDO_DataObject

Açıklama

SDO_Model_Type SDO_Model_ReflectionDataObject::getType ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Returns the SDO_Model_Type for the SDO_DataObject. The SDO_Model_Type holds all the information about the data object's type, such as namespace URI, type name, whether it is a primitive data type, and so on.

Değiştirgeler

None.

Dönen Değerler

Returns the SDO_Model_Type for the SDO_DataObject.

SDO_Model_ReflectionDataObject::getInstanceProperties
SDO_Model_Type::getBaseType
SDO İşlevleri


Get the base type for this type

SDO_Model_ReflectionDataObject::getType
SDO_Model_Type::getName
SDO İşlevleri
PHP Manual

SDO_Model_Type::getBaseType

(^)

SDO_Model_Type::getBaseType — Get the base type for this type

Açıklama

SDO_Model_Type SDO_Model_Type::getBaseType ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Get the base type for this type. Returns the SDO_Model_Type for the base type if this type inherits from another, otherwise returns NULL. An example of when base types occur is when a type defined in XML schema inherits from another type by using

<extension base="...">
.

Değiştirgeler

None.

Dönen Değerler

Returns the SDO_Model_Type for the base type if this type inherits from another, otherwise returns NULL.

SDO_Model_ReflectionDataObject::getType
SDO_Model_Type::getName
SDO İşlevleri


Get the name of the type

SDO_Model_Type::getBaseType
SDO_Model_Type::getNamespaceURI
SDO İşlevleri
PHP Manual

SDO_Model_Type::getName

(^)

SDO_Model_Type::getName — Get the name of the type

Açıklama

string SDO_Model_Type::getName ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Returns the name of the type. The combination of type name and namespace URI is used to uniquely identify the type.

Değiştirgeler

None.

Dönen Değerler

Returns the name of the type.

SDO_Model_Type::getBaseType
SDO_Model_Type::getNamespaceURI
SDO İşlevleri


Get the namespace URI of the type

SDO_Model_Type::getName
SDO_Model_Type::getProperties
SDO İşlevleri
PHP Manual

SDO_Model_Type::getNamespaceURI

(^)

SDO_Model_Type::getNamespaceURI — Get the namespace URI of the type

Açıklama

string SDO_Model_Type::getNamespaceURI ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Returns the namespace URI of the type. The combination of namespace URI and type name is used to uniquely identify the type.

Değiştirgeler

None.

Dönen Değerler

Returns the namespace URI of the type.

SDO_Model_Type::getName
SDO_Model_Type::getProperties
SDO İşlevleri


Get the SDO_Model_Property objects defined for the type

SDO_Model_Type::getNamespaceURI
SDO_Model_Type::getProperty
SDO İşlevleri
PHP Manual

SDO_Model_Type::getProperties

(^)

SDO_Model_Type::getProperties — Get the SDO_Model_Property objects defined for the type

Açıklama

array SDO_Model_Type::getProperties ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Get an array of SDO_Model_Property objects describing the properties defined for the SDO_Model_Type. Each SDO_Model_Property holds information such as the property name, default value, and so on.

Değiştirgeler

None.

Dönen Değerler

Returns an array of SDO_Model_Property objects.

SDO_Model_Type::getNamespaceURI
SDO_Model_Type::getProperty
SDO İşlevleri


Get an SDO_Model_Property of the type

SDO_Model_Type::getProperties
SDO_Model_Type::isAbstractType
SDO İşlevleri
PHP Manual

SDO_Model_Type::getProperty

(^)

SDO_Model_Type::getProperty — Get an SDO_Model_Property of the type

Açıklama

SDO_Model_Property SDO_Model_Type::getProperty ( mixed $identifier )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Get an SDO_Model_Property of the type, identified by its property index or property name.

Değiştirgeler

identifier

The property index or property name.

Dönen Değerler

Returns the SDO_Model_Property.

SDO_Model_Type::getProperties
SDO_Model_Type::isAbstractType
SDO İşlevleri


Test to see if this SDO_Model_Type is an abstract data type

SDO_Model_Type::getProperty
SDO_Model_Type::isDataType
SDO İşlevleri
PHP Manual

SDO_Model_Type::isAbstractType

(^)

SDO_Model_Type::isAbstractType — Test to see if this SDO_Model_Type is an abstract data type

Açıklama

bool SDO_Model_Type::isAbstractType ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Test to see if this SDO_Model_Type is an abstract data type. Returns TRUE if this type is abstract, that is, no SDO_DataObject of this type can be instantiated, though other types may inherit from it.

Değiştirgeler

None.

Dönen Değerler

Returns TRUE if this type is an abstract data type, otherwise returns FALSE.

SDO_Model_Type::getProperty
SDO_Model_Type::isDataType
SDO İşlevleri


Test to see if this SDO_Model_Type is a primitive data type

SDO_Model_Type::isAbstractType
SDO_Model_Type::isInstance
SDO İşlevleri
PHP Manual

SDO_Model_Type::isDataType

(^)

SDO_Model_Type::isDataType — Test to see if this SDO_Model_Type is a primitive data type

Açıklama

bool SDO_Model_Type::isDataType ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Test to see if this SDO_Model_Type is a primitive data type. Returns TRUE if this type is a primitive data type, otherwise returns FALSE.

Değiştirgeler

None.

Dönen Değerler

Returns TRUE if this type is a primitive data type, otherwise returns FALSE.

SDO_Model_Type::isAbstractType
SDO_Model_Type::isInstance
SDO İşlevleri


Test for an SDO_DataObject being an instance of this SDO_Model_Type

SDO_Model_Type::isDataType
SDO_Model_Type::isOpenType
SDO İşlevleri
PHP Manual

SDO_Model_Type::isInstance

(^)

SDO_Model_Type::isInstance — Test for an SDO_DataObject being an instance of this SDO_Model_Type

Açıklama

bool SDO_Model_Type::isInstance ( SDO_DataObject $data_object )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Test for an SDO_DataObject being an instance of this SDO_Model_Type. Returns TRUE if the SDO_DataObject provided is an instance of this SDO_Model_Type, or a derived type, otherwise returns FALSE.

Değiştirgeler

data_object

The SDO_DataObject to be tested.

Dönen Değerler

Returns TRUE if the SDO_DataObject provided is an instance of this SDO_Model_Type, or a derived type, otherwise returns FALSE.

SDO_Model_Type::isDataType
SDO_Model_Type::isOpenType
SDO İşlevleri


Test to see if this type is an open type

SDO_Model_Type::isInstance
SDO_Model_Type::isSequencedType
SDO İşlevleri
PHP Manual

SDO_Model_Type::isOpenType

(^)

SDO_Model_Type::isOpenType — Test to see if this type is an open type

Açıklama

bool SDO_Model_Type::isOpenType ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Test to see if this type is open. Returns TRUE if this type is open, otherwise returns FALSE. An SDO_DataObject whose type is open can have properties added to them which are not described by the type. This capability is used to support working with XML documents whose schema support open content, such as that defined by an

<xsd:any>
element.

Değiştirgeler

None.

Dönen Değerler

Returns TRUE if this type is open, otherwise returns FALSE.

SDO_Model_Type::isInstance
SDO_Model_Type::isSequencedType
SDO İşlevleri


Test to see if this is a sequenced type

SDO_Model_Type::isOpenType
SDO_Sequence::getProperty
SDO İşlevleri
PHP Manual

SDO_Model_Type::isSequencedType

(^)

SDO_Model_Type::isSequencedType — Test to see if this is a sequenced type

Açıklama

bool SDO_Model_Type::isSequencedType ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Test to see if this is a sequenced type. Returns TRUE if this type is sequence, otherwise returns FALSE. Sequenced types can have the ordering across properties preserved and can contain unstructured text. For more information on sequenced types see the section on Working with Sequenced Data Objects.

Değiştirgeler

None.

Dönen Değerler

Returns TRUE if this type is sequence, otherwise return FALSE.

SDO_Model_Type::isOpenType
SDO_Sequence::getProperty
SDO İşlevleri


Return the property for the specified sequence index.

SDO_Model_Type::isSequencedType
SDO_Sequence::insert
SDO İşlevleri
PHP Manual

SDO_Sequence::getProperty

(^)

SDO_Sequence::getProperty — Return the property for the specified sequence index.

Açıklama

SDO_Model_Property SDO_Sequence::getProperty ( int $sequence_index )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Return the property for the specified sequence index.

Değiştirgeler

sequence_index

The position of the element in the sequence.

Dönen Değerler

An SDO_Model_Property. A return value of NULL means the sequence element does not belong to a property and must therefore be unstructured text.

Hatalar/İstisnalar

SDO_IndexOutOfBoundsException

Thrown if the sequence index is less than zero or greater than the size of the sequence.

SDO_Model_Type::isSequencedType
SDO_Sequence::insert
SDO İşlevleri


Insert into a sequence

SDO_Sequence::getProperty
SDO_Sequence::move
SDO İşlevleri
PHP Manual

SDO_Sequence::insert

(^)

SDO_Sequence::insert — Insert into a sequence

Açıklama

void SDO_Sequence::insert ( mixed $value [, int $sequenceIndex [, mixed $propertyIdentifier ]] )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Insert a new element at a specified position in the sequence. All subsequent sequence items are moved up.

Değiştirgeler

value

The new value to be inserted. This can be either a primitive or an SDO_DataObject.

sequenceIndex

The position at which to insert the new element. Default is NULL, which results in the new value being appended to the sequence.

propertyIdentifier

Either a property index, a property name, or an SDO_Model_Property, used to identify a property in the sequence's corresponding SDO_DataObject. A value of NULL signifies unstructured text.

Dönen Değerler

None.

Hatalar/İstisnalar

SDO_IndexOutOfBoundsException

Thrown if the sequence index is less than zero or greater than the size of the sequence.

SDO_InvalidConversionException

Thrown if the type of the new value cannot be juggled to match the type for the specified data object property.

SDO_Sequence::getProperty
SDO_Sequence::move
SDO İşlevleri


Move an item to another sequence position

SDO_Sequence::insert
SDO-DAS-Relational
SDO İşlevleri
PHP Manual

SDO_Sequence::move

(^)

SDO_Sequence::move — Move an item to another sequence position

Açıklama

void SDO_Sequence::move ( int $toIndex, int $fromIndex )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Modify the position of the item in the sequence, without altering the value of the property in the SDO_DataObject.

Değiştirgeler

toIndex

The destination sequence index. If this index is less than zero or greater than the size of the sequence then the value is appended.

fromIndex

The source sequence index.

Dönen Değerler

None.

Hatalar/İstisnalar

SDO_IndexOutOfBoundsException

Thrown if the fromIndex sequence index is less than zero or greater than the size of the sequence.

SDO_Sequence::insert
SDO-DAS-Relational
SDO İşlevleri


SDO Relational Data Access Service

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
    • Creating, retrieving, updating and deleting data
    • Specifying the metadata
    • One-table examples
    • Two-table examples
    • Three-table example
  • Limitations
  • SDO-DAS-Relational İşlevleri
    • SDO_DAS_Relational::applyChanges — Applies the changes made to a data graph back to the database.
    • SDO_DAS_Relational::__construct — Creates an instance of a Relational Data Access Service
    • SDO_DAS_Relational::createRootDataObject — Returns the special root object in an otherwise empty data graph. Used when creating a data graph from scratch.
    • SDO_DAS_Relational::executePreparedQuery — Executes an SQL query passed as a prepared statement, with a list of values to substitute for placeholders, and return the results as a normalised data graph.
    • SDO_DAS_Relational::executeQuery — Executes a given SQL query against a relational database and returns the results as a normalised data graph.
SDO_Sequence::move
Giriş
XML İşleme


Giriş

Uyarı

Bu eklenti DENEYSELDİR. Bu eklentinin davranışı, işlev isimleri ve tüm belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu eklentiyi kullanmayın.

In order to use the Relational Data Access Service for Service Data Objects, you will need to understand some of the concepts behind SDO: the data graph, the data object, the disconnected way of working, the change summary, XPath and property expressions, and so on. If you are not familiar with these ideas, you might want to look first at the section on SDO. In addition, the Relational DAS makes use of the PDO extension to isolate itself from specifics of different back-end relational databases. In order to use the Relational DAS you will need to be able to create and pass a PDO database connection; for this reason you might also want to take a look at the section on PDO.

The job of the Relational DAS is to move data between the application and a relational database. In order to do this it needs to be told the mapping between the database entities - tables, columns, primary keys and foreign keys - and the elements of the SDO model - types, properties, containment relationships and so on. You specify this information as metadata when you construct the Relational DAS.

Overview of Operation

  1. The first step is to call the Relational DAS's constructor, passing the metadata that defines the mapping between database and SDO model. There are examples of this below.

  2. The next step might be to call the executeQuery() or executePreparedQuery() methods on the Relational DAS, passing either a literal SQL statement for the DAS to prepare and execute, or a prepared statement with placeholders and a list of values to be inserted. You may also need to specify a small amount of metadata about the query itself, so that the Relational DAS knows exactly what columns will be returned from the database and in what order. You will also need to pass a PDO database connection.

    The return value from executeQuery() or executePreparedQuery() is a normalised data graph containing all the data from the result set. For a query that returns data obtained from a number of tables, this graph will contain a number of data objects, linked by SDO containment relationships. There may also be SDO non-containment references within the data.

    Once the query has been executed and the data graph constructed, there is no need for either that instance of the Relational DAS or the database connection. There are no locks held on the database. Both the Relational DAS and the PDO database connection can be garbage collected.

  3. Quite possibly the data in the data graph will go through a number of modifications. The data graph can be serialised into the PHP session and so may have a lifetime beyond just one client-server interaction. Data objects can be created and added to the graph, the data objects already in the graph can be deleted, and data objects in the graph can be modified.

  4. Finally, the changes made to the data graph can be applied back to the database using the applyChanges() method of the Relational DAS. For this, another instance of the Relational DAS must be constructed, using the same metadata, and another connection to the database obtained. The connection and the data graph are passed to applyChanges(). At this point the Relational DAS examines the change summary and generates the necessary INSERT, UPDATE and DELETE SQL statements to apply the changes. Any UPDATE and DELETE statements are qualified with the original values of the data so that should the data have changed in the database in the meantime this will be detected. Assuming no such collisions have occurred the changes will be committed to the database. The application can then continue to work with the data graph, make more changes and apply them, or can discard it.

There are other ways of working with the data in the database: it is possible to just create data objects and write them to the database without a preliminary call to executeQuery(), for example. This scenario and others are explored in the Examples section below.

SDO-DAS-Relational
Yapılandırma/Kurulum
SDO-DAS-Relational


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
SDO-DAS-Relational


Gereksinimler

The Relational DAS requires that the SDO extension be installed. The SDO extension requires a version of PHP 5.1, and the Relational DAS requires a recent version that contains an important fix for PDO. The most up-to-date information about required levels of PHP should be found in the changelog for the package on PECL. At the time of writing, though, the Relational DAS requires the most recent beta level of PHP 5.1, that is PHP 5.1.0.

The Relational DAS uses PDO to access the relational database, and so should run with a variety of different relational databases. At the time of writing it has been tested in the following configurations

  • MySQL 4.1.14, on Windows. The Relational DAS operates correctly with the php_pdo_mysql driver that comes with the pre-built binaries for PHP 5.1.0.

  • MySQL 4.1.13, on Linux. It is necessary to have the most up-to-date PDO driver for MySQL, which comes built in to PHP 5.1.0. It may be necessary to uninstall the usual driver that would have come from PECL using pear uninstall pdo_mysql. You will need to configure PHP with the --with-pdo-mysql option.

  • DB2 8.2 Personal Edition, on Windows. The Relational DAS operates correctly with the php_pdo_odbc driver that comes with the pre-built binaries for PHP 5.1.0.

  • DB2 8.2 Personal Developer's Edition, on Linux. The Developer's Edition is needed because it contains the include files needed when PHP is configured and built. You will need to configure PHP with the --with-pdo-odbc=ibm-db2 option.

The Relational DAS applies changes to the database within a user-delimited transaction: that is, it issues a call to PDO::beginTransaction() before beginning to apply changes, and PDO::commit() or PDO::rollback() on completion. Whichever database is chosen, the database and the PDO driver for the database must support these calls.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

The installation instructions for all the SDO components are in the SDO install section of the SDO documentation.

In any case, the essential facts are that the Relational DAS is written in PHP and it should be placed somewhere on the PHP include_path.

Your application will of course need to include the Relational DAS with a statement like this:

<?php
require_once 'SDO/DAS/Relational.php';
?>

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu eklentinin php.ini'de tanımlı yapılandırma yönergesi yoktur.

Tracing

You may be interested in seeing the SQL statements that are generated in order to apply changes back to the database. At the top of the SDO/DAS/Relational.php you will find a number of constants which control whether the process of constructing and executing the SQL statements is to be traced. Try setting DEBUG_EXECUTE_PLAN to TRUE to see the generated SQL statements.

Kurulum
Özkaynak Türleri
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

The Relational DAS introduces no predefined constants.

Özkaynak Türleri
Örnekler
SDO-DAS-Relational


Örnekler

İçindekiler

  • Creating, retrieving, updating and deleting data
  • Specifying the metadata
  • One-table examples
  • Two-table examples
  • Three-table example
Öntanımlı Sabitler
Creating, retrieving, updating and deleting data
SDO-DAS-Relational


Creating, retrieving, updating and deleting data

This section illustrates how the Relational DAS can be used to create, retrieve, update and delete data in a relational database. Many of the examples are illustrated with a three-table database that contains companies, departments within those companies, and employees that work in those departments. This example is used in a number of places within the SDO literature. See the examples section of the » Service Data Objects specification or the Examples section of the documentation for the SDO extension.

The Relational DAS is constructed with metadata that defines the relational database and how it should be mapped to SDO. The long section that follows describes this metadata and how to construct the Relational DAS. The examples that follow it all assume that this metadata is in an included php file.

The examples below and others can all be found in the Scenarios directory in the Relational DAS package.

The Relational DAS throws exceptions in the event that it finds errors in the metadata or errors when executing SQL statements against the database. For brevity the examples below all omit the use of try/catch blocks around the calls to the Relational DAS.

These examples all differ from the expected use of SDO in two important respects.

First, they show all interactions with the database completed within one script. In this respect these scenarios are not realistic but are chosen to illustrate just the use of the Relational DAS. It is expected that interactions with the database will be separated in time and the data graph serialized and deserialized into the PHP session one or more times as the application interacts with an end user.

Second, all queries executed against the database use hard-coded queries with no variables substituted. In this case it is safe to use the simple executeQuery() call, and this is what the examples illustrate. In practice, though, it is unlikely that the SQL statement is known entirely ahead of time. In order to allow variables to be safely substituted into the SQL queries, without running the risk of injecting SQL with unknown effects, it is safer to use the executePreparedQuery() which takes a prepared SQL statement containing placeholders and a list of values to be substituted.

Örnekler
Specifying the metadata
Örnekler


Specifying the metadata

This first long section describes in detail how the metadata describing the database and the required SDO model is supplied to the Relational DAS.

When the constructor for the Relational DAS is invoked, it needs to be passed several pieces of information. The bulk of the information, passed as an associative array in the first argument to the constructor, tells the Relational DAS what it needs to know about the relational database. It describes the names of the tables, columns, primary keys and foreign keys. It should be fairly easy to understand what is required, and once written it can be placed in a php file and included when needed. The remainder of the information, passed in the second and third arguments to the constructor, tells the Relational DAS what it needs to know about the relationships between objects and the shape of the data graph; it ultimately determines how the data from the database is to be normalized into a graph.

Database metadata

The first argument to the constructor describes the target relational database.

Each table is described by an associative array with up to four keys.

Key | Value
name | The name of the table.
columns | An array listing the names of the columns, in any order.
PK | The name of the column containing the primary key.
FK | An array with two entries, 'from' and 'to', which define a column containing a foreign key, and a table to which the foreign key points. If there are no foreign keys in the table then the 'FK' entry does not need to be specified. Only one foreign key can be specified. Only a foreign key pointing to the primary key of a table can be specified.

<?php
/*****************************************************************
* METADATA DEFINING THE DATABASE
******************************************************************/
$company_table = array (
  'name' => 'company',
  'columns' => array('id', 'name',  'employee_of_the_month'),
  'PK' => 'id',
  'FK' => array (
      'from' => 'employee_of_the_month',
      'to' => 'employee',
      ),
  );
$department_table = array (
  'name' => 'department',
  'columns' => array('id', 'name', 'location', 'number', 'co_id'),
  'PK' => 'id',
  'FK' => array (
      'from' => 'co_id',
      'to' => 'company',
      )
  );
$employee_table = array (
  'name' => 'employee',
  'columns' => array('id', 'name', 'SN', 'manager', 'dept_id'),
  'PK' => 'id',
  'FK' => array (
      'from' => 'dept_id',
      'to' => 'department',
      )
  );
$database_metadata = array($company_table, $department_table, $employee_table);
?>

This metadata corresponds to a relational database that might have been defined to MySQL as:

create table company (
 id integer auto_increment,
 name char(20),
 employee_of_the_month integer,
 primary key(id)
);
create table department (
 id integer auto_increment,
 name char(20),
 location char(10),
 number integer(3),
 co_id integer,
 primary key(id)
);
create table employee (
 id integer auto_increment,
 name char(20),
 SN char(4),
 manager tinyint(1),
 dept_id integer,
 primary key(id)
);

or to DB2 as:

create table company ( \
  id integer not null generated by default as identity,  \
  name varchar(20), \
  employee_of_the_month integer, \
  primary key(id) )
create table department ( \
  id integer not null generated by default as identity, \
  name varchar(20), \
  location varchar(10), \
  number integer, \
  co_id integer, \
  primary key(id) )
create table employee ( \
  id integer not null generated by default as identity, \
  name varchar(20), \
  SN char(4), \
  manager smallint, \
  dept_id integer, \
  primary key(id) )

Note that although in this example there are no foreign keys specified to the database and so the database is not expected to enforce referential integrity, the intention behind the co_id column on the department table and the dept_id column on the employee table is they should contain the primary key of their containing company or department record, respectively. So these two columns are acting as foreign keys.

There is a third foreign key in this example, that from the employee_of_the_month column of the company record to a single row of the employee table. Note the difference in intent between this foreign key and the other two. The employee_of_the_month column represents a single-valued relationship: there can be only one employee of the month for a given company. The co_id and dept_id columns represent multi-valued relationships: a company can contain many departments and a department can contain many employees. This distinction will become evident when the remainder of the metadata picks out the company-department and department-employee relationships as containment relationships.

There are a few simple rules to be followed when constructing the database metadata:

  • All tables must have primary keys, and the primary keys must be specified in the metadata. Without primary keys it is not possible to keep track of object identities. As you can see from the SQL statements that create the tables, primary keys can be auto-generated, that is, generated and assigned by the database when a record is inserted. In this case the auto-generated primary key is obtained from the database and inserted into the data object immediately after the row is inserted into the database.

  • It is not necessary to specify in the metadata all the columns that exist in the database, only those that will be used. For example, if the company table had another column that the application did not want to access with SDO, this need not be specified in the metadata. On the other hand it would have done no harm to specify it: if specified in the metadata but never retrieved, or assigned to by the application, then the unused column will not affect anything.

  • In the database metadata note that the foreign key definitions identify not the destination column in the table which is pointed to, but the table name itself. Strictly, the relational model permits the destination of a foreign key to be a non-primary key. Only foreign keys that point to a primary key are useful for constructing the SDO model, so the metadata specifies the table name. It is understood that the foreign key points to the primary key of the given table.

Given these rules, and given the SQL statements that define the database, the database metadata should be easy to construct.

What the Relational DAS does with the metadata

The Relational DAS uses the database metadata to form most of the SDO model. For each table in the database metadata, an SDO type is defined. Each column which can represent a primitive value (columns which are not defined as foreign keys) are added as properties to the SDO type.

All primitive properties are given a type of string in the SDO model, regardless of their SQL type. When writing values back to the database the Relational DAS will create SQL statements that treat the values as strings, and the database will convert them to the appropriate type.

Foreign keys are interpreted in one of two ways, depending on the metadata in the third argument to the constructor that defines the SDO containment relationships. A discussion of this is therefore deferred until the section on SDO containment relationships below.

Specifying the application root type

The second argument to the constructor is the application root type. The true root of each data graph is an object of a special root type and all application data objects come somewhere below that. Of the various application types in the SDO model, one has to be the application type immediately below the root of the data graph. If there is only one table in the database metadata, the application root type can be inferred, and this argument can be omitted.

Specifying the SDO containment relationships

The third argument to the constructor defines how the types in the model are to be linked together to form a graph. It identifies the parent-child relationships between the types which collectively form a graph. The relationships need to be supported by foreign keys to be found in the data, in a way shortly to be described.

The metadata is an array containing one or more associative arrays, each of which identifies a parent and a child. The example below shows a parent-child relationship from company to department, and another from department to employee. Each of these will become an SDO property defining a multi-valued containment relationship in the SDO model.

<?php
$department_containment = array( 'parent' => 'company', 'child' => 'department');
$employee_containment = array( 'parent' => 'department', 'child' => 'employee');

$SDO_containment_metadata = array($department_containment, $employee_containment);
?>

Foreign keys in the database metadata are interpreted as properties with either multi-valued containment relationships or single-valued non-containment references, depending on whether they have a corresponding SDO containment relationship specified in the metadata. In the example here, the foreign keys from department to company (the co_id column in the department table) and from employee to department (the dept_id column in the employee table) are interpreted as supporting the SDO containment relationships. Each containment relationship mentioned in the SDO containment relationships metadata must have a corresponding foreign key present in the database and defined in the database metadata. The values of the foreign key columns for containment relationships do not appear in the data objects, instead each is represented by a containment relationship from the parent to the child. So the co_id column in the department row in the database, for example, does not appear as a property on the department type, but instead as a containment relationship called department on the company type. Note that the foreign key and the parent-child relationship appear to have opposite senses: the foreign key points from the department to the company, but the parent-child relationship points from company to department.

The third foreign key in this example, the employee_of_the_month , is handled differently. This is not mentioned in the SDO containment relationships metadata. As a consequence this is interpreted in the second way: it becomes a single-valued non-containment reference on the company object, to which can be assigned references to SDO data objects of the employee type. It does appear as a property on the company type. The way to assign a value to it in the SDO data graph is to have a graph that contains an employee object through the containment relationships, and to assign the object to it. This is illustrated in the later examples below.

Creating, retrieving, updating and deleting data
One-table examples
Örnekler


One-table examples

The following set of examples all use the Relational DAS to work with a data graph containing just one application data object, a single company and the data just to be found the company table. These examples do not exercise the power of SDO or the Relational DAS and of course the same result could be achieved more economically with direct SQL statements but they are intended to illustrate how to work with the Relational DAS.

For this very simple scenario it would be possible to simplify the database metadata to include just the company table - if that were done the second and third arguments to the constructor and the column specifier used in the query example would become optional.

Örnek 1 Creating a data object

The simplest example is that of creating a single data object and writing it to the database. In this example a single company object is created, its name is set to 'Acme', and the Relational DAS is called to write the changes to the database. The company name is set here using the property name method. See the Examples section on the SDO extension for other ways of accessing the properties of an object.

Data objects can only be created when you have a data object to start with, however. It is for that reason that the first call to the Relational DAS here is to obtain a root object. This is in effect how to ask for an empty data graph - the special root object is the true root of the tree. The company data object is then created with a call to createDataObject() on the root object. This creates the company data object and inserts it in the graph by inserting into a multi-valued containment property on the root object called 'company'.

When the Relational DAS is called to apply the changes a simple insert statement 'INSERT INTO company (name) VALUES ("Acme");' will be constructed and executed. The auto-generated primary key will be set into the data object and the change summary will be reset, so that it would be possible to continue working with the same data object, modify it, and apply the newer changes a second time.

<?php
require_once 'SDO/DAS/Relational.php';
require_once 'company_metadata.inc.php';

/**************************************************************
* Construct the DAS with the metadata
***************************************************************/
$das = new SDO_DAS_Relational ($database_metadata,'company',$SDO_containment_metadata);

/**************************************************************
* Obtain a root object and create a company object underneath.
* Make a simple change to the data object.
***************************************************************/
$root = $das  -> createRootDataObject();
$acme = $root -> createDataObject('company');

$acme->name = "Acme";

/**************************************************************
* Get a database connection and write the object to the database
***************************************************************/
$dbh = new PDO(PDO_DSN,DATABASE_USER,DATABASE_PASSWORD);
$das -> applyChanges($dbh, $root);
?>

Örnek 2 Retrieving a data object

In this example a single data object is retrieved from the database - or possibly more than one if there is more than one company called 'Acme'. For each company returned, the name and id properties are echoed.

In this example the third argument to executeQuery(), the column specifier is needed as there are other tables in the metadata with column names of name and id. If there were no possible ambiguity it could be omitted.

<?php
require_once 'SDO/DAS/Relational.php';
require_once 'company_metadata.inc.php';

/**************************************************************
* Construct the DAS with the metadata
***************************************************************/
$das = new SDO_DAS_Relational ($database_metadata,'company',$SDO_containment_metadata);

/**************************************************************
* Get a database connection
***************************************************************/
$dbh = new PDO(PDO_DSN,DATABASE_USER,DATABASE_PASSWORD);

/**************************************************************
* Issue a query to obtain a company object - possibly more if they exist
***************************************************************/
$root = $das->executeQuery($dbh,
         'select name, id from company where name="Acme"',
          array('company.name', 'company.id') );

/**************************************************************
* Echo name and id
***************************************************************/
foreach ($root['company'] as $company) {
  echo "Company obtained from the database has name = " .
  $company['name'] . " and id " . $company['id'] . "\n";
}
?>

Örnek 3 Updating a data object

This example combines the previous two, in the sense that in order to be updated the object must first be retrieved. The application code reverses the company name (so 'Acme' becomes 'emcA') and then the changes are written back to the database in the same way that they were when the object was created. Because the query searches for the name both ways round the program can be run repeatedly to find the company and reverse its name each time.

In this example the same instance of the Relational DAS is reused for the applyChanges(), as is the PDO database handle. This is quite alright; it also alright to allow the previous instances to be garbage collected and to obtain new instances. No state data regarding the graph is held the Relational DAS once it has returned a data graph to the application. All necessary data is either within the graph itself, or can be reconstructed from the metadata.

<?php
require_once 'SDO/DAS/Relational.php';
require_once 'company_metadata.inc.php';

/**************************************************************
* Construct the DAS with the metadata
***************************************************************/
$das = new SDO_DAS_Relational ($database_metadata,'company',$SDO_containment_metadata);

/**************************************************************
* Get a database connection
***************************************************************/
$dbh = new PDO(PDO_DSN,DATABASE_USER,DATABASE_PASSWORD);

/**************************************************************
* Issue a query to obtain a company object - possibly more if they exist
***************************************************************/
$root = $das->executeQuery($dbh,
  'select name, id from company where name="Acme" or name="emcA"',
  array('company.name', 'company.id') );

/**************************************************************
* Alter the name of just the first company
***************************************************************/
$company = $root['company'][0];
echo "obtained a company with name of " . $company->name . "\n";
$company->name = strrev($company->name);

/**************************************************************
* Write the change back
***************************************************************/
$das->applyChanges($dbh,$root);
?>

Örnek 4 Deleting a data object

Any companies called 'Acme' or its reverse 'emcA' are retrieved. They are then all deleted from the graph with unset.

In this example they are all deleted in one go by unsetting the containing property (the property defining the containment relationship). It is also possible to delete them individually.

<?php
require_once 'SDO/DAS/Relational.php';
require_once 'company_metadata.inc.php';

/**************************************************************
* Construct the DAS with the metadata
***************************************************************/
$das = new SDO_DAS_Relational ($database_metadata,'company',$SDO_containment_metadata);

/**************************************************************
* Get a database connection
***************************************************************/
$dbh = new PDO(PDO_DSN,DATABASE_USER,DATABASE_PASSWORD);

/**************************************************************
* Issue a query to obtain a company object - possibly more if they exist
***************************************************************/
$root = $das->executeQuery($dbh,
  'select name, id from company where name="Acme" or name="emcA"',
  array('company.name', 'company.id') );

/**************************************************************
* Delete any companies found from the data graph
***************************************************************/
unset($root['company']);

/**************************************************************
* Write the change(s) back
***************************************************************/
$das->applyChanges($dbh,$root);
?>

Specifying the metadata
Two-table examples
Örnekler


Two-table examples

The following set of examples all use two tables from the company database: the company and department tables. These examples exercise more of the function of the Relational DAS.

In this series of examples a company and department are created, retrieved, updated, and finally deleted. This illustrates the lifecycle for a data graph containing more than one object. Note that this example clears out the company and department tables at the start so that the exact results of the queries can be known.

You can find these examples combined into one script called 1cd-CRUD in the Scenarios directory in the Relational DAS package.

Örnek 1 One company, one department - Create

As in the earlier example of creating just one company data object, the first action after constructing the Relational DAS is to call createRootDataObject() to obtain the special root object of the otherwise empty data graph. The company object is then created as a child of the root object, and the department object as a child of the company object.

When it comes to applying the changes, the Relational DAS has to perform special processing to maintain the foreign keys that support the containment relationships, especially if auto-generated primary keys are involved. In this example, the relationship between the auto-generated primary key id in the company table and the co_id column in the department table must be maintained. When inserting a company and department for the first time the Relational DAS has to first insert the company row, then call PDO's getLastInsertId() method to obtain the auto-generated primary key, then add that as the value of the co_id column when inserting the department row.

<?php
require_once 'SDO/DAS/Relational.php';
require_once 'company_metadata.inc.php';

/*************************************************************************************
* Empty out the two tables
*************************************************************************************/
$dbh = new PDO(PDO_DSN,DATABASE_USER,DATABASE_PASSWORD);
$pdo_stmt = $dbh->prepare('DELETE FROM COMPANY;');
$rows_affected = $pdo_stmt->execute();
$pdo_stmt = $dbh->prepare('DELETE FROM DEPARTMENT;');
$rows_affected = $pdo_stmt->execute();

/**************************************************************
* Create a company with name Acme and one department, the Shoe department
***************************************************************/
$dbh = new PDO(PDO_DSN,DATABASE_USER,DATABASE_PASSWORD);
$das = new SDO_DAS_Relational ($database_metadata,'company',$SDO_containment_metadata);

$root = $das -> createRootDataObject();

$acme = $root -> createDataObject('company');
$acme -> name = "Acme";

$shoe = $acme->createDataObject('department');
$shoe->name = 'Shoe';

$das -> applyChanges($dbh, $root);

?>

Örnek 2 One company, one department - Retrieve and Update

In this case the SQL query passed to executeQuery() performs an inner join to join the data from the company and department tables. Primary keys for both the company and department tables must be included in the query. The result set is re-normalised to form a normalised data graph. Note that a column specifier is passed as the third argument to the executeQuery() call enabling the Relational DAS to know which column is which in the result set.

Note that the co_id column although used in the query is not needed in the result set. In order to understand what the Relational DAS is doing when it builds the data graph it may be helpful to visualise what the result set looks like. Although the data in the database is normalised, so that multiple department rows can point through their foreign key to one company row, the data in the result set is non-normalised: that is, if there is one company and multiple departments, the values for the company are repeated in each row. The Relational DAS has to reverse this process and turn the result set back into a normalised data graph, with just one company object.

In this example the Relational DAS will examine the result set and column specifier, find data for both the company and department tables, find primary keys for both, and interpret each row as containing data for a department and its parent company. If it has not seen data for that company before (it uses the primary key to check) it creates a company object and then a department object underneath it. If it has seen data for that company before and has already created the company object it just creates the department object underneath.

In this way the Relational DAS can retrieve and renormalise data for multiple companies and multiple departments underneath them.

<?php
require_once 'SDO/DAS/Relational.php';
require_once 'company_metadata.inc.php';

/**************************************************************
* Retrieve the company and Shoe department, then delete Shoe and add IT
***************************************************************/
$dbh = new PDO(PDO_DSN,DATABASE_USER,DATABASE_PASSWORD);
$das = new SDO_DAS_Relational ($database_metadata,'company',$SDO_containment_metadata);

$root = $das->executeQuery($dbh,
'select c.id, c.name, d.id, d.name from company c, department d where d.co_id = c.id',
array('company.id','company.name','department.id','department.name'));

$acme = $root['company'][0];            // get the first company - will be 'Acme'
$shoe = $acme['department'][0];         // get the first department underneath - will be 'Shoe'

unset($acme['department'][0]);

$it = $acme->createDataObject('department');
$it->name = 'IT';

$das -> applyChanges($dbh, $root);
?>

Örnek 3 One company, two departments - Retrieve and Delete

In this example the company and department are retrieved and then deleted. It is not necessary to delete them individually (although that would be possible) - deleting the company object from the data graph also deletes any departments underneath it.

Note the way that the company object is actually deleted using the PHP unset call. The unset has to be performed on the containing property which in this case is the company property on the special root object. You must use:

<?php
unset($root['company'][0]);
?>
and not:
<?php
unset($acme); //WRONG
?>
Simply unsetting $acme would destroy the variable but leave the data in the data graph untouched.

<?php
require_once 'SDO/DAS/Relational.php';
require_once 'company_metadata.inc.php';

/**************************************************************
* Retrieve the company and IT department, then delete the whole company
***************************************************************/
$dbh = new PDO(PDO_DSN,DATABASE_USER,DATABASE_PASSWORD);
$das = new SDO_DAS_Relational ($database_metadata,'company',$SDO_containment_metadata);

$root = $das->executeQuery($dbh,
'select c.id, c.name, d.id, d.name from company c, department d where d.co_id = c.id',
array('company.id','company.name','department.id','department.name'));

$acme = $root['company'][0];
$it = $acme['department'][0];

unset($root['company'][0]);

$das -> applyChanges($dbh, $root);

?>

One-table examples
Three-table example
Örnekler


Three-table example

The following examples use all three tables from the company database: the company, department, and employee tables. These introduce the final piece of function not exercised by the examples above: the non-containment reference employee_of_the_month.

Like the examples above for company and department, this set of examples is intended to illustrate the full lifecycle of such a data graph.

Örnek 1 One company, one department, one employee - Create

In this example a company is created containing one department and just one employee. Note that this example clears out all three tables at the start so that the exact results of the queries can be known.

Note how once the company, department and employee have been created, the employee_of_the_month property of the company can be made to point at the new employee. As this is a non-containment reference, this cannot be done until the employee object has been created within the graph. Non-containment references need to be managed carefully. For example if the employee were now deleted from under the department, it would not be correct to try to save the graph without first clearing or re-assigning the employee_of_the_month property. The closure rule for SDO data graphs requires that any object pointed at by a non-containment reference must also be reachable by containment relationships.

When it comes to inserting the graph into the database, the procedure is similar to the example of inserting the company and department, but employee_of_the_month introduces an extra complexity. The Relational DAS needs to insert the objects working down the tree formed by containment relationships, so company, then department, then employee. This is necessary so that it always has the auto-generated primary key of a parent on hand to include in a child row. But when the company row is inserted the employee who is employee of the month has not yet been inserted and the primary key is not known. The procedure is that after the employee record is inserted and its primary key known, a final step is performed in which the company record is updated with the employee's primary key.

<?php
require_once 'SDO/DAS/Relational.php';
require_once 'company_metadata.inc.php';

/*************************************************************************************
* Empty out the three tables
*************************************************************************************/
$dbh = new PDO(PDO_DSN,DATABASE_USER,DATABASE_PASSWORD);
$pdo_stmt = $dbh->prepare('DELETE FROM COMPANY;');
$rows_affected = $pdo_stmt->execute();
$pdo_stmt = $dbh->prepare('DELETE FROM DEPARTMENT;');
$rows_affected = $pdo_stmt->execute();
$pdo_stmt = $dbh->prepare('DELETE FROM EMPLOYEE;');
$rows_affected = $pdo_stmt->execute();

/*************************************************************************************
* Create a tiny but complete company.
* The company name is Acme.
* There is one department, Shoe.
* There is one employee, Sue.
* The employee of the month is Sue.
*************************************************************************************/
$das = new SDO_DAS_Relational ($database_metadata,'company',$SDO_containment_metadata);
$dbh = new PDO(PDO_DSN,DATABASE_USER,DATABASE_PASSWORD);

$root             = $das  -> createRootDataObject();
$acme             = $root -> createDataObject('company');
$acme -> name     = "Acme";
$shoe             = $acme -> createDataObject('department');
$shoe -> name     = 'Shoe';
$shoe -> location = 'A-block';
$sue              = $shoe -> createDataObject('employee');
$sue -> name      = 'Sue';
$acme -> employee_of_the_month = $sue;

$das -> applyChanges($dbh, $root);

echo "Wrote back Acme with one department and one employee\n";
?>

Örnek 2 One company, one department, one employee - Retrieve and update

The SQL statement passed to the Relational DAS is this time an inner join that retrieves data from all three tables. Otherwise this example introduces nothing that has not appeared in a previous example.

The graph is updated by the addition of a new department and employee and some alterations to the name properties of the existing objects in the graph. The combined changes are then written back. The Relational DAS will process and apply an arbitrary mixture of additions, modifications and deletions to and from the data graph.

<?php
require_once 'SDO/DAS/Relational.php';
require_once 'company_metadata.inc.php';

/*************************************************************************************
* Find the company again and change various aspects.
* Change the name of the company, department and employee.
* Add a second department and a new employee.
* Change the employee of the month.
*************************************************************************************/
$das = new SDO_DAS_Relational ($database_metadata,'company',$SDO_containment_metadata);
$dbh = new PDO(PDO_DSN,DATABASE_USER,DATABASE_PASSWORD);

$root = $das->executeQuery($dbh,
  "select c.id, c.name, c.employee_of_the_month, d.id, d.name, e.id, e.name " .
  "from company c, department d, employee e " .
  "where e.dept_id = d.id and d.co_id = c.id and c.name='Acme'",
   array('company.id','company.name','company.employee_of_the_month',
   'department.id','department.name','employee.id','employee.name'));
$acme         = $root['company'][0];

$shoe         = $acme->department[0];
$sue          = $shoe -> employee[0];

$it           = $acme->createDataObject('department');
$it->name     = 'IT';
$it->location = 'G-block';
$billy        = $it->createDataObject('employee');
$billy->name  = 'Billy';

$acme->name   = 'MegaCorp';
$shoe->name   = 'Footwear';
$sue->name    = 'Susan';

$acme->employee_of_the_month = $billy;
$das -> applyChanges($dbh, $root);
echo "Wrote back company with extra department and employee and all the names changed (Megacorp/Footwear/Susan)\n";

?>

Örnek 3 One company, two departments, two employees - Retrieve and delete

The company is retrieved as a complete data graph containing five data objects - the company, two departments and two employees. They are all deleted by deleting the company object. Deleting an object from the graph deletes all the object beneath it in the graph. Five SQL DELETE statements will be generated and executed. As always they will be qualified with a WHERE clause that contains all of the fields that were retrieved, so that any updates to the data in the database in the meantime by another process will be detected.

<?php
require_once 'SDO/DAS/Relational.php';
require_once 'company_metadata.inc.php';

/*************************************************************************************
* Now read it one more time and delete it.
* You can delete part, apply the changes, then carry on working with the same graph but
* care is needed to keep closure - you cannot delete the employee who is eotm without
* reassigning. For safety here we delete the company all in one go.
*************************************************************************************/
$das = new SDO_DAS_Relational ($database_metadata,'company',$SDO_containment_metadata);
$dbh = new PDO(PDO_DSN,DATABASE_USER,DATABASE_PASSWORD);

$root = $das->executeQuery($dbh,
  "select c.id, c.name, c.employee_of_the_month, d.id, d.name, e.id, e.name " .
  "from company c, department d, employee e " .
  "where e.dept_id = d.id and d.co_id = c.id and c.name='MegaCorp';",
   array('company.id','company.name','company.employee_of_the_month',
   'department.id','department.name','employee.id','employee.name'));
$megacorp = $root['company'][0];

unset($root['company']);
$das -> applyChanges($dbh, $root);

echo "Deleted the company, departments and employees all in one go.\n";

?>

Two-table examples
Limitations
Örnekler


Limitations

There are the following limitations in the current release of the Relational DAS:

  • No support for nulls. There is no support for SQL NULL type. It is not legal to assign PHP NULL to a data object property and the Relational DAS will not write that back as a NULL to the database. If nulls are found in the database on a query, the property will remain unset.

  • Only two types of SDO relationship. The metadata described below allows the Relational DAS to model just two types of SDO relationship: multi-valued containment relationships and single-valued non-containment references. In SDO, whether a property describes a single- or multi-valued relationship, and whether it is containment or non-containment, are independent. The full range of possibilities that SDO allows cannot all be defined. There may be relationships that it would be useful to model but which the current implementation cannot manage. One example is a single-valued containment relationship.

  • No support for the full range of SDO data types. The Relational DAS defines all primitive properties in the SDO model as being of type string. SDO defines a richer set of types containing various integer, float, boolean and data and time types. String is adequate for the purposes of the Relational DAS since the combination of PHP, PDO and the database will ensure that values passed as strings will be converted to the proper type before being put in the database. This does affect some scenarios in which the Relational DAS has to work with a data graph that has come from or will go to a different DAS.

  • Only one foreign key per table. The metadata only provides the means to specify one foreign key per table. This foreign key may be mapped to one of the two types of SDO relationship supported. Obviously there are some scenarios that cannot be described under this limitation - it is not possible to have two non-containment references from one table to another for example.

Three-table example
SDO-DAS-Relational İşlevleri
SDO-DAS-Relational


SDO-DAS-Relational İşlevleri

Öntanımlı Sınıflar

The Relational DAS provides two classes: the Relational DAS itself and the subclass of Exception that can be thrown. The Relational DAS has four publicly useful calls: the constructor, the createRootDataObject() call to obtain the root object of an empty data graph, the executeQuery() call to obtain a data graph containing data from a relational database, and the applyChanges() call to write changes made to a data graph back to the relational database.

SDO_DAS_Relational

The only object other than an SDO_DAS_Relational_Exception with which the application is expected to interact.

Yöntemler

  • __construct - construct the Relational DAS with a model derived from the passed metadata

  • createRootDataObject - obtain an otherwise empty data graph containing just the special root object

  • executeQuery - execute an SQL query passed as a literal string and return the results as a normalised data graph

  • executePreparedQuery - execute an SQL query passed as a prepared statement, with a list of values to substitute for placeholders, and return the results as a normalised data graph

  • applyChanges - examine the change summary in the data graph and apply those changes back to the database, subject to an assumption of optimistic concurrency

SDO_DAS_Relational_Exception

Is a subclass of PHP's Exception. It adds no behaviour to Exception. Thrown, with useful descriptive text, to signal errors in the metadata or unexpected failures to perform SQL operations.

İçindekiler

  • SDO_DAS_Relational::applyChanges — Applies the changes made to a data graph back to the database.
  • SDO_DAS_Relational::__construct — Creates an instance of a Relational Data Access Service
  • SDO_DAS_Relational::createRootDataObject — Returns the special root object in an otherwise empty data graph. Used when creating a data graph from scratch.
  • SDO_DAS_Relational::executePreparedQuery — Executes an SQL query passed as a prepared statement, with a list of values to substitute for placeholders, and return the results as a normalised data graph.
  • SDO_DAS_Relational::executeQuery — Executes a given SQL query against a relational database and returns the results as a normalised data graph.
Limitations
SDO_DAS_Relational::applyChanges
SDO-DAS-Relational


Applies the changes made to a data graph back to the database.

SDO-DAS-Relational İşlevleri
SDO_DAS_Relational::__construct
SDO-DAS-Relational İşlevleri
PHP Manual

SDO_DAS_Relational::applyChanges

(^)

SDO_DAS_Relational::applyChanges — Applies the changes made to a data graph back to the database.

Açıklama

void SDO_DAS_Relational::applyChanges ( PDO $database_handle , SDODataObject $root_data_object )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Given a PDO database handle and the special root object of a data graph, examine the change summary in the datagraph and applies the changes to the database. The changes that it can apply can be creations of data objects, deletes of data objects, and modifications to properties of data objects.

Değiştirgeler

PDO_database_handle

Constructed using the PDO extension. A typical line to construct a PDO database handle might look like this:

$dbh = new PDO("mysql:dbname=COMPANYDB;host=localhost",DATABASE_USER,DATABASE_PASSWORD);

root_data_object

The special root object which is at the top of every SDO data graph.

Dönen Değerler

None. Note however that the datagraph that was passed is still intact and usable. Furthermore, if data objects were created and written back to a table with autogenerated primary keys, then those primary keys will now be set in the data objects. If the changes were successfully written, then the change summary associated with the datagraph will have been cleared, so that it is possible to now make further changes to the data graph and apply those changes in turn. In this way it is possible to work with the same data graph and apply changes repeatedly.

Hatalar/İstisnalar

SDO_DAS_Relational::applyChanges() can throw an SDO_DAS_Relational_Exception if it is unable to apply all the changes correctly.

The Relational DAS starts a database transaction before beginning to apply the changes and will commit the transaction only if they are all successful. The Relational DAS generates qualified update and delete statements which contain a where clause that specifies that the row to be updated or deleted must contain the same values that it did when the data was first retrieved. This is how the optimistic concurrency is implemented. If any of the qualified update or delete statements fails to update or delete their target row, it may be because the data has been altered in the database in the meantime. In any event, if any update fails for any reason, the transaction is rolled back and an exception thrown. The exception will contain the generated SQL statement that failed.

The Relational DAS also catches any PDO exceptions and obtains PDO diagnostic information which it includes in an SDO_DAS_Relational_Exception which it then throws.

Örnekler

Please see the Examples section in the general information about the Relational DAS for many examples of calling this method. Please see also the section on Tracing to see how you can see what SQL statements are generated by the Relational DAS.

SDO-DAS-Relational İşlevleri
SDO_DAS_Relational::__construct
SDO-DAS-Relational İşlevleri


Creates an instance of a Relational Data Access Service

SDO_DAS_Relational::applyChanges
SDO_DAS_Relational::createRootDataObject
SDO-DAS-Relational İşlevleri
PHP Manual

SDO_DAS_Relational::__construct

(^)

SDO_DAS_Relational::__construct — Creates an instance of a Relational Data Access Service

Açıklama

SDO_DAS_Relational::__construct ( array $database_metadata [, string $application_root_type [, array $SDO_containment_references_metadata ]] )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Constructs an instance of a Relational Data Access Service from the passed metadata.

Değiştirgeler

database_metadata

An array containing one or more table definitions, each of which is an associative array containing the keys name, columns, PK, and optionally, FK. For a full discussion of the metadata, see the metadata section in the general information about the Relational DAS.

application_root_type

The root of each data graph is an object of a special root type and the application data objects come below that. Of the various application types in the SDO model, one has to be the application type immediately below the root of the data graph. If there is only one table in the database metadata, so the application root type can be inferred, this argument can be omitted.

SDO_containment_references_metadata

An array containing one or more definitions of a containment relation, each of which is an associative array containing the keys parent and child. The containment relations describe how the types in the model are connected to form a tree. The type specified as the application root type must be present as one of the parent types in the containment references. If the application only needs to work with one table at a time, and there are no containment relations in the model, this argument can be omitted. For a full discussion of the metadata, see the metadata section in the general information about the Relational DAS.

Dönen Değerler

Returns an SDO_DAS_Relational object on success.

Hatalar/İstisnalar

SDO_DAS_Relational::__construct() throws a SDO_DAS_Relational_Exception if any problems are found in the metadata.

Örnekler

For a full discussion of the metadata, see the metadata section in the general information about the Relational DAS.

SDO_DAS_Relational::applyChanges
SDO_DAS_Relational::createRootDataObject
SDO-DAS-Relational İşlevleri


Returns the special root object in an otherwise empty data graph. Used when creating a data graph from scratch.

SDO_DAS_Relational::__construct
SDO_DAS_Relational::executePreparedQuery
SDO-DAS-Relational İşlevleri
PHP Manual

SDO_DAS_Relational::createRootDataObject

(^)

SDO_DAS_Relational::createRootDataObject — Returns the special root object in an otherwise empty data graph. Used when creating a data graph from scratch.

Açıklama

SDODataObject SDO_DAS_Relational::createRootDataObject ( void )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Returns the special root object at the top of an otherwise empty data graph. This call is used when the application wants to create a data graph from scratch, without having called executeQuery() to create a data graph.

The special root object has one multi-valued containment property, with a name of the application root type that was passed when the Relational DAS was constructed. The property can take values of only that type. The only thing that the application can usefully do with the root type is to call createDataObject() on it, passing the name of the application root type, in order to create a data object of their own application type.

Değiştirgeler

None.

Dönen Değerler

The root object.

Hatalar/İstisnalar

None.

Örnekler

Please see the Examples section in the general information about the Relational DAS for many examples of calling this method.

SDO_DAS_Relational::__construct
SDO_DAS_Relational::executePreparedQuery
SDO-DAS-Relational İşlevleri


Executes an SQL query passed as a prepared statement, with a list of values to substitute for placeholders, and return the results as a normalised data graph.

SDO_DAS_Relational::createRootDataObject
SDO_DAS_Relational::executeQuery
SDO-DAS-Relational İşlevleri
PHP Manual

SDO_DAS_Relational::executePreparedQuery

(^)

SDO_DAS_Relational::executePreparedQuery — Executes an SQL query passed as a prepared statement, with a list of values to substitute for placeholders, and return the results as a normalised data graph.

Açıklama

SDODataObject SDO_DAS_Relational::executePreparedQuery ( PDO $database_handle , PDOStatement $prepared_statement , array $value_list [, array $column_specifier ] )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Executes a given query against the relational database, using the supplied PDO database handle. Differs from the simpler executeQuery() in that it takes a prepared statement and a list of values. This is the appropriate call to use either when the statement is to executed a number of times with different arguments, and there is therefore a performance benefit to be had from preparing the statement only once, or when the SQL statement is to contain varying values taken from a source that cannot be completely trusted. In this latter case it may be unsafe to construct the SQL statement by simply concatenating the parts of the statement together, since the values may contain pieces of SQL. To guard against this, a so-called SQL injection attack, it is safer to prepare the SQL statement with placeholders (also known as parameter markers, denoted by '?') and supply a list of the values to be substituted as a separate argument. Otherwise this function is the same as executeQuery() in that it uses the model that it built from the metadata to interpret the result set and returns a data graph.

Değiştirgeler

PDO_database_handle

Constructed using the PDO extension. A typical line to construct a PDO database handle might look like this:

$dbh = new PDO("mysql:dbname=COMPANYDB;host=localhost",DATABASE_USER,DATABASE_PASSWORD);

prepared_statement

A prepared SQL statement to be executed against the database. This will have been prepared by PDO's prepare() method.

value_list

An array of the values to be substituted into the SQL statement in place of the placeholders. In the event that there are no placeholders or parameter markers in the SQL statement then this argument can be specified as NULL or as an empty array;

column_specifier

The Relational DAS needs to examine the result set and for every column, know which table and which column of that table it came from. In some circumstances it can find this information for itself, but sometimes it cannot. In these cases a column specifier is needed, which is an array that identifies the columns. Each entry in the array is simply a string in the form table-name.column_name.

The column specifier is needed when there are duplicate column names in the database metadata, For example, in the database used within the examples, all the tables have both a id and a name column. When the Relational DAS fetches the result set from PDO it can do so with the PDO_FETCH_ASSOC attribute, which will cause the columns in the results set to be labelled with the column name, but will not distinguish duplicates. So this will only work when there are no duplicates possible in the results set.

To summarise, specify a column specifier array whenever there is any uncertainty about which column could be from which table and only omit it when every column name in the database metadata is unique.

All of the examples in the Examples use a column specifier. There is one example in the Scenarios directory of the installation that does not: that which works with just the employee table, and because it works with just one table, there can not exist duplicate column names.

Dönen Değerler

Returns a data graph. Specifically, it returns a root object of a special type. Under this root object will be the data from the result set. The root object will have a multi-valued containment property with the same name as the application root type specified on the constructor, and that property will contain one or more data objects of the application root type.

In the event that the query returns no data, the special root object will still be returned but the containment property for the application root type will be empty.

Hatalar/İstisnalar

SDO_DAS_Relational::executePreparedQuery() can throw an SDO_DAS_Relational_Exception if it is unable to construct the data graph correctly. This can occur for a number of reasons: for example if it finds that it does not have primary keys in the result set for all the objects. It also catches any PDO exceptions and obtains PDO diagnostic information which it includes in an SDO_DAS_Relational_Exception which it then throws.

Örnekler

Örnek 1 Retrieving a data object using executePreparedQuery()

In this example a single data object is retrieved from the database - or possibly more than one if there is more than one company called 'Acme'. For each company returned, the name and id properties are echoed.

Other examples of the use of executePreparedQuery() can be found in the example code supplied in sdo/DAS/Relational/Scenarios.

<?php
require_once 'SDO/DAS/Relational.php';
require_once 'company_metadata.inc.php';

/**************************************************************
 * Construct the DAS with the metadata
 ***************************************************************/
$das = new SDO_DAS_Relational ($database_metadata,'company',$SDO_reference_metadata);

/**************************************************************
 * Get a database connection
 ***************************************************************/
$dbh = new PDO(PDO_DSN,DATABASE_USER,DATABASE_PASSWORD);

/**************************************************************
 * Issue a query to obtain a company object - possibly more if they exist
 * Use a prepared query with a placeholder.
 ***************************************************************/
$name = 'Acme';
$pdo_stmt = $dbh->prepare('select name, id from company where name=?');
$root = $das->executePreparedQuery(
    $dbh,
    $pdo_stmt,
    array($name),
    array('company.name', 'company.id'));

/**************************************************************
 * Echo name and id
 ***************************************************************/
foreach ($root['company'] as $company) {
    echo "Company obtained from the database has name = " .
    $company['name'] . " and id " . $company['id'] . "\n";
}
?>

SDO_DAS_Relational::createRootDataObject
SDO_DAS_Relational::executeQuery
SDO-DAS-Relational İşlevleri


Executes a given SQL query against a relational database and returns the results as a normalised data graph.

SDO_DAS_Relational::executePreparedQuery
SDO DAS XML
SDO-DAS-Relational İşlevleri
PHP Manual

SDO_DAS_Relational::executeQuery

(^)

SDO_DAS_Relational::executeQuery — Executes a given SQL query against a relational database and returns the results as a normalised data graph.

Açıklama

SDODataObject SDO_DAS_Relational::executeQuery ( PDO $database_handle , string $SQL_statement [, array $column_specifier ] )
Uyarı

Bu işlev DENEYSELDİR. Bu işlevin davranışı, ismi ve belgeleri PHP'nin sonraki sürümlerinde hiçbir duyuru yapılmaksızın değiştirilebilir. Bu riski göze alamayacaksanız bu işlevi kullanmayın.

Executes a given query against the relational database, using the supplied PDO database handle. Uses the model that it built from the metadata to interpret the result set. Returns a data graph.

Değiştirgeler

PDO_database_handle

Constructed using the PDO extension. A typical line to construct a PDO database handle might look like this:

$dbh = new PDO("mysql:dbname=COMPANYDB;host=localhost",DATABASE_USER,DATABASE_PASSWORD);

SQL_statement

The SQL statement to be executed against the database.

column_specifier

The Relational DAS needs to examine the result set and for every column, know which table and which column of that table it came from. In some circumstances it can find this information for itself, but sometimes it cannot. In these cases a column specifier is needed, which is an array that identifies the columns. Each entry in the array is simply a string in the form table-name.column_name.

The column specifier is needed when there are duplicate column names in the database metadata. For example, in the database used within the examples, all the tables have both a id and a name column. When the Relational DAS fetches the result set from PDO it can do so with the PDO_FETCH_ASSOC attribute, which will cause the columns in the results set to be labelled with the column name, but will not distinguish duplicates. So this will only work when there are no duplicates possible in the results set.

To summarise, specify a column specifier array whenever there is any uncertainty about which column could be from which table and only omit it when every column name in the database metadata is unique.

All of the examples in the Examples use a column specifier. There is one example in the Scenarios directory of the installation that does not: that which works with just the employee table, and because it works with just one table, there can not exist duplicate column names.

Dönen Değerler

Returns a data graph. Specifically, it returns a root object of a special type. Under this root object will be the data from the result set. The root object will have a multi-valued containment property with the same name as the application root type specified on the constructor, and that property will contain one or more data objects of the application root type.

In the event that the query returns no data, the special root object will still be returned but the containment property for the application root type will be empty.

Hatalar/İstisnalar

SDO_DAS_Relational::executeQuery() can throw an SDO_DAS_Relational_Exception if it is unable to construct the data graph correctly. This can occur for a number of reasons: for example if it finds that it does not have primary keys in the result set for all the objects. It also catches any PDO exceptions and obtains PDO diagnostic information which it includes in an SDO_DAS_Relational_Exception which it then throws.

Örnekler

Please see the Examples section in the general information about the Relational DAS for many examples of calling this method.

SDO_DAS_Relational::executePreparedQuery
SDO DAS XML
SDO-DAS-Relational İşlevleri


SDO XML Data Access Service

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
  • SDO DAS XML İşlevleri
    • SDO_DAS_XML::addTypes — To load a second or subsequent schema file to a SDO_DAS_XML object
    • SDO_DAS_XML::create — To create SDO_DAS_XML object for a given schema file
    • SDO_DAS_XML::createDataObject — Creates SDO_DataObject for a given namespace URI and type name
    • SDO_DAS_XML::createDocument — Creates an XML Document object from scratch, without the need to load a document from a file or string.
    • SDO_DAS_XML::loadFile — Returns SDO_DAS_XML_Document object for a given path to xml instance document
    • SDO_DAS_XML::loadString — Returns SDO_DAS_XML_Document for a given xml instance string
    • SDO_DAS_XML::saveFile — Saves the SDO_DAS_XML_Document object to a file
    • SDO_DAS_XML::saveString — Saves the SDO_DAS_XML_Document object to a string
    • SDO_DAS_XML_Document::getRootDataObject — Returns the root SDO_DataObject
    • SDO_DAS_XML_Document::getRootElementName — Returns root element's name
    • SDO_DAS_XML_Document::getRootElementURI — Returns root element's URI string
    • SDO_DAS_XML_Document::setEncoding — Sets the given string as encoding
    • SDO_DAS_XML_Document::setXMLDeclaration — Sets the xml declaration
    • SDO_DAS_XML_Document::setXMLVersion — Sets the given string as xml version
SDO_DAS_Relational::executeQuery
Giriş
XML İşleme


Giriş

In order to use the XML Data Access Service for Service Data Objects, you will need to understand some of the concepts behind SDO: the data graph, the data object, XPath and property expressions, and so on. If you are not familiar with these ideas, you might want to look first at the section on SDO.

The job of the XML DAS is to move data between the application and an XML data source, which can be either a file or a URL. SDOs are always created and maintained according to a model which defines type names and what property names each type may have. For data which is from XML, this SDO model is built from a schema file written in XML schema language (an xsd file). This schema file is usually passed to the create method when the XMLDAS is initialised. The » SDO 2.0 specification defines the mapping between XML types and SDO types. There are a number of small limitations in the PHP support - not everything which is in the specification can be done - and these limitations are summarised in a later section.

SDO DAS XML
Yapılandırma/Kurulum
SDO DAS XML


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
SDO DAS XML


Gereksinimler

The SDO XML Data Access Service requires PHP 5.1.0 or higher. It is packaged with the SDO extension and requires SDO to have been installed. See the SDO installation instructions for the details of how to do this.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

The XML Data Access Service is packaged and installed as part of the SDO extension. Please Refer SDO installation instructions.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
Örnekler
SDO DAS XML


Örnekler

Several of the following examples are based on the letter example described in the SDO documentation. The examples assume the XML Schema for the letter is contained in a file letter.xsd and the letter instance is in the file letter.xml. These two files are reproduced here:

<xsd:schema xmlns:xsd="http://www.w3.org/2001/XMLSchema"
  xmlns:letter="http://letterSchema"
  targetNamespace="http://letterSchema">
  <xsd:element name="letters" type="letter:FormLetter"/>
  <xsd:complexType name="FormLetter" mixed="true">
    <xsd:sequence>
      <xsd:element name="date" minOccurs="0" type="xsd:string"/>
      <xsd:element name="firstName" minOccurs="0" type="xsd:string"/>
      <xsd:element name="lastName" minOccurs="0" type="xsd:string"/>
    </xsd:sequence>
  </xsd:complexType>
</xsd:schema>

<letter:letters xmlns:letter="http://letterSchema">
  <date>March 1, 2005</date>
  Mutual of Omaha
  Wild Kingdom, USA
  Dear
  <firstName>Casy</firstName>
  <lastName>Crocodile</lastName>
  Please buy more shark repellent.
  Your premium is past due.
</letter:letters>

Örnek 1 Loading, altering, and saving an XML document

The following example shows how an XML document can be loaded from a file, altered, and written back.

<?php
/**
 * Load, update, and save an XML document
 */
try {
   $xmldas = SDO_DAS_XML::create("letter.xsd");
   $document = $xmldas->loadFile("letter.xml");
   $root_data_object = $document->getRootDataObject();
   $root_data_object->date = "September 03, 2004";
   $root_data_object->firstName = "Anantoju";
   $root_data_object->lastName = "Madhu";
   $xmldas->saveFile($document, "letter-out.xml");
   echo "New file has been written:\n";
   print file_get_contents("letter-out.xml");
} catch (SDO_Exception $e) {
   print($e->getMessage());
}
?>

An instance of the XML DAS is first obtained from the SDO_DAS_XML::create() method, which is a static method of the SDO_DAS_XML class. The location of the xsd is passed as a parameter. Once we have an instance of the XML DAS initialised with a given schema, we can use it to load the instance document using the loadFile() method. There is also a loadString() method if you want to load an XML instance document from a string. If the instance document loads successfully, you will be returned an object of type SDO_DAS_XML_Document, on which you can call the getRootDataObject() method to get the SDO data object which is the root of the SDO data graph. You can then use SDO operations to change the graph. In this example we alter the date, firstName, and lastName properties. Then we use the saveFile() method to write the changed document back to the file system. The saveFile method has an optional extra integer argument which if specified will cause the XML DAS to format the XML, using the integer as the amount to indent by at each change in level on the document.

This will write the following to letter-out.xml.

<?xml version="1.0" encoding="UTF-8"?>
<FormLetter xmlns="http://letterSchema" xsi:type="FormLetter" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
  <date>September 03, 2004</date>
  Mutual of Omaha
  Wild Kingdom, USA
  Dear
  <firstName>Anantoju</firstName>
  <lastName>Madhu</lastName>
  Please buy more shark repellent.
  Your premium is past due.
</FormLetter>

Örnek 2 Creating a new XML document

The previous example loaded the document from a file. This example shows how to create an SDO data graph in memory. In this example it is then saved to an XML string. Furthermore, because the letter contains both structured and unstructured content, it uses the Sequence API as well assignments to properties to construct the data graph.

<?php
/**
 * Create an XML document from scratch
 */
try {
   $xmldas = SDO_DAS_XML::create("letter.xsd");
   try {
       $doc = $xmldas->createDocument();
       $rdo = $doc->getRootDataObject();
       $seq = $rdo->getSequence();
       $seq->insert("April 09, 2005", NULL, 'date');
       $seq->insert("Acme Inc. ", NULL, NULL);
       $seq->insert("United Kingdom. ");
       $seq->insert("Dear", NULL, NULL);
       $seq->insert("Tarun", NULL, "firstName");
       $seq->insert("Nayaraaa", NULL, "lastName");
       $rdo->lastName = "Nayar";
       $seq->insert("Please note that your order number ");
       $seq->insert(12345);
       $seq->insert(" has been dispatched today. Thanks for your business with us.");
       print($xmldas->saveString($doc));
   } catch (SDO_Exception $e) {
       print($e);
   }
} catch (SDO_Exception $e) {
   print("Problem creating an XML document: " . $e->getMessage());
}
?>

The createDocument() method on the XML DAS returns a document object with a single root data object corresponding to an empty document element. The element name of the document element is known from the schema file. If there is any ambiguity about what the document element is, as there can be when more than one schema has been loaded into the same XML DAS, the element name and the namespace URI can be passed to the createDocument() method.

This will emit the following output (line breaks have been inserted for readability):

<?xml version="1.0" encoding="UTF-8"?>
<FormLetter xmlns="http://letterSchema" xsi:type="FormLetter"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<date>April 09, 2005</date>
Acme Inc. United Kingdom.
Dear
<firstName>Tarun</firstName>
<lastName>Nayar</lastName>
Please note that your order number 12345 has been
dispatched today. Thanks for your business with us.
</FormLetter>

Örnek 3 Setting XML document properties

This third example shows you how to set the XML version and encoding on the document object. These will be used when the XML is written out. If no XML declaration is wanted at all (perhaps you want to generate the XML as a string to embed in something) then you can use the setXMLDeclaration() method to suppress it.

<?php
/**
 * Illustrate the calls that control the XML declaration
 */
   $xmldas = SDO_DAS_XML::create("letter.xsd");
   $document = $xmldas->loadFile("letter.xml");
   $document->setXMLVersion("1.1");
   $document->setEncoding("ISO-8859-1");
   print($xmldas->saveString($document));
?>

The XML version and encoding are set in the XML declaration at the top of the XML document.

<?xml version="1.1" encoding="utf-8"?>
.../...

Örnek 4 Using an open type

This fourth example illustrates the use of an SDO open type and the use of the createDataObject() method. For this example we use the following two schema:

<schema
  xmlns="http://www.w3.org/2001/XMLSchema">

  <element name="jungle">
    <complexType>
      <sequence>
        <any minOccurs="0" maxOccurs="unbounded"/>
      </sequence>
    </complexType>
  </element>

</schema>

Note the presence of the any element in the definition. This first schema defines the jungle complex type as containing a sequence of any other type. The other types that the example will use are defined in a second schema file:

<schema xmlns= "http://www.w3.org/2001/XMLSchema">

   <complexType name="snakeType">
     <sequence>
       <element name= "name" type="string"/>
       <element name= "length" type="positiveInteger" />
     </sequence>
   </complexType>

   <complexType name="bearType">
     <sequence>
       <element name= "name" type="string"/>
       <element name= "weight" type="positiveInteger" />
     </sequence>
   </complexType>

   <complexType name="pantherType">
     <sequence>
       <element name= "name" type="string"/>
       <element name= "colour" type="string" />
     </sequence>
   </complexType>

</schema>

Here is the example PHP code that uses these two schema files:

<?php

/**
 * Illustrate open types and the use of the addTypes() method
 */

$xmldas = SDO_DAS_XML::create();
$xmldas->addTypes("jungle.xsd"); // this is an open type i.e. the xsd specifies it can contain "any" type
$xmldas->addTypes('animalTypes.xsd');

$baloo            = $xmldas->createDataObject('','bearType');
$baloo->name      = "Baloo";
$baloo->weight    = 800;

$bagheera         = $xmldas->createDataObject('','pantherType');
$bagheera->name   = "Bagheera";
$bagheera->colour = 'inky black';

$kaa              = $xmldas->createDataObject('','snakeType');
$kaa->name        = "Kaa";
$kaa->length      = 25;

$document         = $xmldas->createDocument();
$do               = $document->getRootDataObject();
$do->bear         = $baloo;
$do->panther      = $bagheera;
$do->snake        = $kaa;

print($xmldas->saveString($document,2));

?>

These two schema files are loaded into the XML DAS with first the create() and addTypes() methods. The createDataObject() method is used to create three separate data objects. In each case the namespaceURI and typename of the type are passed to the createDataObject() method: in this example the namespace URI is blank because no namespace is used in the schema. Once the three data objects - representing a bear, a panther and a snake - have been created, a document object is created with the createDocument() method. In this case there is no ambiguity about what the document element of the document should be - as the second schema file only defines complex types, the document element can only be the global jungle element defined in the first schema. This document will have a single root data object corresponding to an empty document element jungle. As this is an open type, properties can be added at will. When the first assignment is made to $do->bear, a property bear is added to the root data object: likewise for the next two assignments. When the document is written out by the saveString() method, the resulting document is:

<?xml version="1.0" encoding="UTF-8"?>
<jungle xsi:type="jungle" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
  <bear xsi:type="bearType">
    <name>Baloo</name>
    <weight>800</weight>
  </bear>
  <panther xsi:type="pantherType">
    <name>Bagheera</name>
    <colour>inky black</colour>
  </panther>
  <snake xsi:type="snakeType">
    <name>Kaa</name>
    <length>25</length>
  </snake>
</jungle>

Örnek 5 Finding out what you can from the document

This example is intended to illustrate how you can find the element name and namespace of the document element from the XML Document object, and the SDO type and namespace from the root data object of the XML data object, and how they relate to one another. This can be difficult to understand because there are four method calls: two can be made against the Document object, and two that can be made against any data object including the root data object. Because of the rules that define how the SDO model is derived from the XML model, when the data object concerned is the root object that represents the document object for the document, only three possible values can come back from these four method calls.

The two method calls that can be made against the document are getRootElementName() and getRootEelementURI(). These return the element name and namespace of the document element, respectively.

The two method calls that can be made against any data object are getTypeName() and getTypeNamespaceURI(). These return the SDO type name and type namespace of the data object, respectively.

Always, calling getRootElementURI() on the document object will return the same value as calling getNamespaceURI() on the root data object. Essentially, the information is all derived from the first few lines of the schema file, where there are three distinct pieces of information. For illustration, here again are the first few lines of the letter.xsd that we used above.

<xsd:schema xmlns:xsd="http://www.w3.org/2001/XMLSchema"
            xmlns:letter="http://letterSchema"
            targetNamespace="http://letterSchema">

  <xsd:element name="letters" type="letter:FormLetter"/>

  <xsd:complexType name="FormLetter" mixed="true">
    .../...

The three important values are:

  • letters, the name of the document element

  • FormLetter, the name of the complex type of the document element. This is also the name of the SDO type of the root data object.

  • http://letterSchema, the namespace to which the document element belongs. This is also the namespaceURI of the SDO type of the root data object.

It is part of the XML-SDO mapping rules that when the SDO model is built from the schema file, the typename and namespaceURI of the SDO types for the root element are taken from those of the complex type of the document element, where it exists. Hence in this example the typename of the root data object is FormLetter. In the event that there is no separate complex type definition for the document element, when the type is defined inline and is anonymous, the SDO type name will be the same as the element name.

The following program loads the letter document and checks the return values from each of the four calls.

<?php
/**
 * Finding out what you can about the document and document element
 * This can be quite hard to understand because there are four calls
 * Two calls are made against the document
 * Two calls are made against the root data object and its model
 * Because of the SDO-XML mapping rules and how the SDO model is derived
 * from the XML model, only three possible values can come back from these four calls.
 * Always, $document->getRootElementURI() == (type of root data object)->namespaceURI
 * Essentially, it all comes form the first few lines of the xsd:
 * <xsd:schema xmlns:xsd="http://www.w3.org/2001/XMLSchema"
 *   xmlns:letter="http://letterSchema"
 *   targetNamespace="http://letterSchema">
 *   <xsd:element name="letters" type="letter:FormLetter"/>
 */

$xmldas = SDO_DAS_XML::create("letter.xsd");
$document = $xmldas->loadFile("letter.xml");
$root_do = $document->getRootDataObject();

/**
 * The "root element name" is the element name of the document element
 * in this case 'letters'
 * This matches the 'name' attribute of the document element in the xsd and matches
 * the element name from the xml
 */
echo "The document element name is " . $document->getRootElementName() . "\n";
assert($document->getRootElementName() == 'letters'); // a property of the document

/**
 * The "root element URI" is the namespace part of the element name of the document element
 * in this case 'http://letterSchema' since 'letters' is in that namespace
 * This is taken from the xsd and matches the namespace picked up from the xml
 */
echo "The document element is in the namespace " . $document->getRootElementURI() . "\n";
assert($document->getRootElementURI() == 'http://letterSchema'); // a property of the document

/**
 * The type name is taken from the SDO model
 * The XML-SDO mapping rules make this either:
 *   The name of the complexType if there is one (in this case there is)
 *   The document element name if there no complexType
 * This is taken from the xsd
 */
echo "The type name of the root data object is " . $root_do->getTypeName() . "\n";
assert($root_do->getTypeName() == 'FormLetter');

/**
 * The type's namespaceURI is taken from the SDO model
 * The XML-SDO mapping rules ensure that this will always be the same as
 * the namepace URI of the document element
 */
echo "The namespaceURI of the root data object is " . $root_do->getTypeNamespaceURI() . "\n";
assert($root_do->getTypeNamespaceURI() == 'http://letterSchema');

?>

The output from this program is as follows:

The document element name is letters
The document element is in the namespace http://letterSchema
The type name of the root data object is FormLetter
The namespaceURI of the root data object is http://letterSchema

Örnek 6 Printing the SDO model

The XML DAS provides a simple means to see what types and properties have been loaded. The php "print" or "echo" instruction will print out the types and properties.

<?php
/**
 * Illustrate printing out the model
 */

$xmldas = SDO_DAS_XML::create("letter.xsd");
print $xmldas;

?>

The output from this program is as follows:

object(SDO_XML_DAS)#1 {
18 types have been defined. The types and their properties are::
1. commonj.sdo:BigDecimal
2. commonj.sdo:BigInteger
3. commonj.sdo:Boolean
4. commonj.sdo:Byte
5. commonj.sdo:Bytes
6. commonj.sdo:ChangeSummary
7. commonj.sdo:Character
8. commonj.sdo:DataObject
9. commonj.sdo:Date
10. commonj.sdo:Double
11. commonj.sdo:Float
12. commonj.sdo:Integer
13. commonj.sdo:Long
14. commonj.sdo:Short
15. commonj.sdo:String
16. commonj.sdo:URI
17. http://letterSchema:FormLetter
    - date (commonj.sdo:String)
    - firstName (commonj.sdo:String)
    - lastName (commonj.sdo:String)
18. http://letterSchema:RootType
    - letters (http://letterSchema:FormLetter)
Öntanımlı Sabitler
SDO DAS XML İşlevleri
SDO DAS XML


SDO DAS XML İşlevleri

Öntanımlı Sınıflar

The XML DAS provides two main classes. The first is SDO_DAS_XML which is the main class used to fetch the data from the XML source and used to write the data back. The second is the SDO_DAS_XML_Document class, which represents the data in the XML document.

There are also some exception classes which can be thrown if errors are found when looking for or parsing the xsd or xml files.

SDO_DAS_XML

This is the main class of the XML DAS, which is used fetch the data from the xml source and also used to write the data back. Other than the methods to load and save xml files,

Yöntemler

  • create This is a static method available in the SDO_DAS_XML class. Used to construct an SDO_DAS_XML object.

  • addTypes Works in much the same way as create() but used to add the contents of a second or subsequent schema file to an XML DAS that has already been created.

  • createDataObject Can be used to construct an SDO data object of a given type.

  • createDocument Can be used to construct an XML Document object from scratch.

  • loadFile Loads the xml instance document from a file. This file can be at local file system or it can be on a remote host.

  • loadString same as the above method. Loads the xml instance which is available as string.

  • saveFile save SDO_DAS_XML_Document object as a xml file.

  • saveString save SDO_DAS_XML_Document object as a xml string.

SDO_DAS_XML_Document

This class can be used to get to the name and namespace of the document element, and to get to the root data object of the document. Lastly, it can also be used to set the XML version and encoding of a document on output.

Yöntemler

  • getRootDataObject gets the root DataObject.

  • getRootElementName gets the root DataObject's name.

  • getRootElementURI gets the root DataObject's URI.

  • setEncoding sets the encoding string with the given value.

  • setXMLDeclaraion to set/unset the xml declaration.

  • setXMLVersion sets the xml version with the given value.

SDO_DAS_XML_ParserException

Is a subclass of SDO_Exception. Thrown for any parser errors while loading the xsd/xml file.

SDO_DAS_XML_FileException

Is a subclass of SDO_Exception. Thrown by any of the methods that load data from a file, when the file cannot be found.

Limitations compared with SDO 2.0 specification

The » SDO 2.0 specification defines the mapping between XML types and SDO types. With Java SDO, this mapping is implemented by the XMLHelper. With SDO for PHP, this mapping is implemented by the XML Data Access Service. The XML DAS implements the mapping described in the SDO 2.0 specification with some restrictions. A detailed list is of the limitations is:

XML Simple Types

  1. Simple Type with sdoJava:instanceClass - no PHP equivalent provided.

  2. Simple Type with sdoJava:extendedInstanceClass - no PHP equivalent provided.

  3. Simple Type with list of itemType.

  4. Simple Type with union.

XML Complex Types

  1. Complex Type with sdo:aliasName - no PHP support for SDO Type aliases.

XSD Attribute

  1. Attribute with sdo:aliasName - no PHP support for SDO property aliases.

  2. Attribute with default value - no PHP support for SDO property defaults.

  3. Attribute with fixed value - no PHP support for SDO read-only properties or default values.

  4. Attribute referencing a DataObject with sdo:propertyType - no support for sdo:propertyType="...".

  5. Attribute with bi-directional property to a DataObject with sdo:oppositeProperty and sdo:propertyType - no PHP support for SDO opposite.

XSD Elements

  1. Element with sdo:aliasName - no PHP support for SDO property aliases.

  2. Element with substitution group.

XSD Elements with Simple Type

  1. Element of SimpleType with default - no PHP support for SDO defaults

  2. Element of SimpleType with fixed value - no PHP support for SDO read-only properties or default values.

  3. Element of SimpleType with sdo:string - no support for sdo:string="true".

  4. Element referencing a DataObject with sdo:propertyType - no support for sdo:propertyType="..."

  5. Element with bi-directional reference to a DataObject with sdo:oppositeProperty and sdo:propertyType - no PHP support for SDO opposite.

İçindekiler

  • SDO_DAS_XML::addTypes — To load a second or subsequent schema file to a SDO_DAS_XML object
  • SDO_DAS_XML::create — To create SDO_DAS_XML object for a given schema file
  • SDO_DAS_XML::createDataObject — Creates SDO_DataObject for a given namespace URI and type name
  • SDO_DAS_XML::createDocument — Creates an XML Document object from scratch, without the need to load a document from a file or string.
  • SDO_DAS_XML::loadFile — Returns SDO_DAS_XML_Document object for a given path to xml instance document
  • SDO_DAS_XML::loadString — Returns SDO_DAS_XML_Document for a given xml instance string
  • SDO_DAS_XML::saveFile — Saves the SDO_DAS_XML_Document object to a file
  • SDO_DAS_XML::saveString — Saves the SDO_DAS_XML_Document object to a string
  • SDO_DAS_XML_Document::getRootDataObject — Returns the root SDO_DataObject
  • SDO_DAS_XML_Document::getRootElementName — Returns root element's name
  • SDO_DAS_XML_Document::getRootElementURI — Returns root element's URI string
  • SDO_DAS_XML_Document::setEncoding — Sets the given string as encoding
  • SDO_DAS_XML_Document::setXMLDeclaration — Sets the xml declaration
  • SDO_DAS_XML_Document::setXMLVersion — Sets the given string as xml version
Örnekler
SDO_DAS_XML::addTypes
SDO DAS XML


To load a second or subsequent schema file to a SDO_DAS_XML object

SDO DAS XML İşlevleri
SDO_DAS_XML::create
SDO DAS XML İşlevleri
PHP Manual

SDO_DAS_XML::addTypes

(^)

SDO_DAS_XML::addTypes — To load a second or subsequent schema file to a SDO_DAS_XML object

Açıklama

void SDO_DAS_XML::addTypes ( string $xsd_file )

Load a second or subsequent schema file to an XML DAS that has already been created with the static method create(). Although the file may be any valid schema file, a likely reason for using this method is to add a schema file containing definitions of extra complex types, hence the name. See Example 4 of the parent document for an example.

Değiştirgeler

xsd_file

Path to XSD Schema file.

Dönen Değerler

None if successful, otherwise throws an exception as described below.

Hatalar/İstisnalar

SDO_TypeNotFoundException

Thrown if a type is not defined in the underlying model.

SDO_DAS_XML_ParserException

Thrown for any problems while parsing the given XSD File.

SDO_DAS_XML_FileException

Thrown if the specified file cannot be found.

SDO DAS XML İşlevleri
SDO_DAS_XML::create
SDO DAS XML İşlevleri


To create SDO_DAS_XML object for a given schema file

SDO_DAS_XML::addTypes
SDO_DAS_XML::createDataObject
SDO DAS XML İşlevleri
PHP Manual

SDO_DAS_XML::create

(^)

SDO_DAS_XML::create — To create SDO_DAS_XML object for a given schema file

Açıklama

SDO_DAS_XML SDO_DAS_XML::create ([ mixed $xsd_file [, string $key ]] )

This is the only static method of SDO_DAS_XML class. Used to instantiate SDO_DAS_XML object.

Değiştirgeler

xsd_file

Path to XSD Schema file. This is optional. If omitted a DAS will be created that only has the SDO base types defined. Schema files can then be loaded with the addTypes() method. Can be string or array of values.

key

Dönen Değerler

Returns SDO_DAS_XML object on success otherwise throws an exception as described below.

Hatalar/İstisnalar

SDO_TypeNotFoundException

Thrown if a type is not defined in the underlying model.

SDO_DAS_XML_ParserException

Thrown for any problems while parsing the given XSD File.

SDO_DAS_XML_FileException

Thrown if the specified file cannot be found.

SDO_DAS_XML::addTypes
SDO_DAS_XML::createDataObject
SDO DAS XML İşlevleri


Creates SDO_DataObject for a given namespace URI and type name

SDO_DAS_XML::create
SDO_DAS_XML::createDocument
SDO DAS XML İşlevleri
PHP Manual

SDO_DAS_XML::createDataObject

(^)

SDO_DAS_XML::createDataObject — Creates SDO_DataObject for a given namespace URI and type name

Açıklama

SDO_DataObject SDO_DAS_XML::createDataObject ( string $namespace_uri , string $type_name )

Creates SDO_DataObject for a given namespace URI and type name. The type should be defined in the underlying model otherwise SDO_TypeNotFoundException will be thrown.

Değiştirgeler

namespace_uri

Namespace URI of the type name.

type_name

Type Name.

Dönen Değerler

Returns SDO_DataObject on success.

Hatalar/İstisnalar

SDO_TypeNotFoundException

Thrown if a type is not defined in the underlying model.

SDO_DAS_XML::create
SDO_DAS_XML::createDocument
SDO DAS XML İşlevleri


Creates an XML Document object from scratch, without the need to load a document from a file or string.

SDO_DAS_XML::createDataObject
SDO_DAS_XML::loadFile
SDO DAS XML İşlevleri
PHP Manual

SDO_DAS_XML::createDocument

(^)

SDO_DAS_XML::createDocument — Creates an XML Document object from scratch, without the need to load a document from a file or string.

Açıklama

SDO_DAS_XML_Document SDO_DAS_XML::createDocument ([ string $document_element_name ] )
SDO_DAS_XML_Document SDO_DAS_XML::createDocument ( string $document_element_namespace_URI , string $document_element_name [, SDO_DataObject $dataobject ] )

Creates an XML Document object. This will contain just one empty root element on which none of the properties will have been set. The purpose of this call is to allow an application to create an XML document from scratch without the need to load a document from a file or string. The document that is created will be as if a document had been loaded that contained just a single empty document element with no attributes set or elements within it.

createDocument() may need to be told what the document element is. This will not be necessary in simple cases. When there is no ambiguity then no parameter need be passed to the method. However it is possible to load more than one schema file into the same XML DAS and in this case there may be more than one possible document element defined: furthermore it is even possible that there are two possible document elements that differ only in the namespace. To cope with these cases it is possible to specify either the document element name, or both the document element name and namespace to the method.

Değiştirgeler

document_element_name

The name of the document element. Only needed if there is more than one possibility.

document_element_namespace_URI

The namespace part of the document element name. Only needed if there is more than one possible document element with the same name.

dataobject

Dönen Değerler

Returns an SDO_XML_DAS_Document object on success.

Hatalar/İstisnalar

SDO_UnsupportedOperationException

Thrown if an element name or element name and namespace URI is passed, but not found in the underlying model.

SDO_DAS_XML::createDataObject
SDO_DAS_XML::loadFile
SDO DAS XML İşlevleri


Returns SDO_DAS_XML_Document object for a given path to xml instance document

SDO_DAS_XML::createDocument
SDO_DAS_XML::loadString
SDO DAS XML İşlevleri
PHP Manual

SDO_DAS_XML::loadFile

(^)

SDO_DAS_XML::loadFile — Returns SDO_DAS_XML_Document object for a given path to xml instance document

Açıklama

SDO_XMLDocument SDO_DAS_XML::loadFile ( string $xml_file )

Constructs the tree of SDO_DataObjects from the given address to xml instance document. Returns SDO_DAS_XML_Document Object. Use SDO_DAS_XML_Document::getRootDataObject method to get root data object.

Değiştirgeler

xml_file

Path to Instance document. This can be a path to a local file or it can be a URL.

Dönen Değerler

Returns SDO_DAS_XML_Document object on Success or throws exception as described.

Hatalar/İstisnalar

SDO_TypeNotFoundException

Thrown if a type is not defined by the underlying model.

SDO_PropertyNotFoundException

Thrown if a property within a type is not defined in the underlying model.

SDO_DAS_XML_ParserException

Thrown for any problems while parsing the given XSD File.

SDO_DAS_XML_FileException

Thrown if the specified file cannot be found.

SDO_DAS_XML::createDocument
SDO_DAS_XML::loadString
SDO DAS XML İşlevleri


Returns SDO_DAS_XML_Document for a given xml instance string

SDO_DAS_XML::loadFile
SDO_DAS_XML::saveFile
SDO DAS XML İşlevleri
PHP Manual

SDO_DAS_XML::loadString

(^)

SDO_DAS_XML::loadString — Returns SDO_DAS_XML_Document for a given xml instance string

Açıklama

SDO_DAS_XML_Document SDO_DAS_XML::loadString ( string $xml_string )

Constructs the tree of SDO_DataObjects from the given xml instance string. Returns SDO_DAS_XML_Document Object. Use SDO_DAS_XML_Document::getRootDataObject method to get root data object.

Değiştirgeler

xml_string

xml string.

Dönen Değerler

Returns SDO_DAS_XML_Document object on Success or throws exception as described.

Hatalar/İstisnalar

SDO_TypeNotFoundException

Thrown if a type is not defined by the underlying model.

SDO_PropertyNotFoundException

Thrown if the a property within a type is not defined in the underlying model.

SDO_DAS_XML_ParserException

Thrown for any problems while parsing the given XSD File.

SDO_DAS_XML::loadFile
SDO_DAS_XML::saveFile
SDO DAS XML İşlevleri


Saves the SDO_DAS_XML_Document object to a file

SDO_DAS_XML::loadString
SDO_DAS_XML::saveString
SDO DAS XML İşlevleri
PHP Manual

SDO_DAS_XML::saveFile

(^)

SDO_DAS_XML::saveFile — Saves the SDO_DAS_XML_Document object to a file

Açıklama

void SDO_DAS_XML::saveFile ( SDO_XMLDocument $xdoc , string $xml_file [, int $indent ] )

Saves the SDO_DAS_XML_Document object to a file.

Değiştirgeler

xdoc

SDO_DAS_XML_Document object.

xml_file

xml file.

indent

Optional argument to specify that the xml should be formatted. A non-negative integer is the amount to indent each level of the xml. So, the integer 2, for example, will indent the xml so that each contained element is two spaces further to the right than its containing element. The integer 0 will cause the xml to be completely left-aligned. The integer -1 means no formatting - the xml will come out on one long line.

Dönen Değerler

None.

Hatalar/İstisnalar

SDO_DAS_XML_FileException

Thrown if the specified file cannot be found.

SDO_DAS_XML::loadString
SDO_DAS_XML::saveString
SDO DAS XML İşlevleri


Saves the SDO_DAS_XML_Document object to a string

SDO_DAS_XML::saveFile
SDO_DAS_XML_Document::getRootDataObject
SDO DAS XML İşlevleri
PHP Manual

SDO_DAS_XML::saveString

(^)

SDO_DAS_XML::saveString — Saves the SDO_DAS_XML_Document object to a string

Açıklama

string SDO_DAS_XML::saveString ( SDO_XMLDocument $xdoc [, int $indent ] )

Saves the SDO_DAS_XML_Document object to string.

Değiştirgeler

xdoc

SDO_DAS_XML_Document object.

indent

Optional argument to specify that the xml should be formatted. A non-negative integer is the amount to indent each level of the xml. So, the integer 2, for example, will indent the xml so that each contained element is two spaces further to the right than its containing element. The integer 0 will cause the xml to be completely left-aligned. The integer -1 means no formatting - the xml will come out on one long line.

Dönen Değerler

xml string.

SDO_DAS_XML::saveFile
SDO_DAS_XML_Document::getRootDataObject
SDO DAS XML İşlevleri


Returns the root SDO_DataObject

SDO_DAS_XML::saveString
SDO_DAS_XML_Document::getRootElementName
SDO DAS XML İşlevleri
PHP Manual

SDO_DAS_XML_Document::getRootDataObject

(^)

SDO_DAS_XML_Document::getRootDataObject — Returns the root SDO_DataObject

Açıklama

SDO_DataObject SDO_DAS_XML_Document::getRootDataObject ( void )

Returns the root SDO_DataObject.

Değiştirgeler

Dönen Değerler

Returns the root SDO_DataObject.

SDO_DAS_XML::saveString
SDO_DAS_XML_Document::getRootElementName
SDO DAS XML İşlevleri


Returns root element's name

SDO_DAS_XML_Document::getRootDataObject
SDO_DAS_XML_Document::getRootElementURI
SDO DAS XML İşlevleri
PHP Manual

SDO_DAS_XML_Document::getRootElementName

(^)

SDO_DAS_XML_Document::getRootElementName — Returns root element's name

Açıklama

string SDO_DAS_XML_Document::getRootElementName ( void )

Returns root element's name.

Değiştirgeler

Dönen Değerler

Returns root element's name.

SDO_DAS_XML_Document::getRootDataObject
SDO_DAS_XML_Document::getRootElementURI
SDO DAS XML İşlevleri


Returns root element's URI string

SDO_DAS_XML_Document::getRootElementName
SDO_DAS_XML_Document::setEncoding
SDO DAS XML İşlevleri
PHP Manual

SDO_DAS_XML_Document::getRootElementURI

(^)

SDO_DAS_XML_Document::getRootElementURI — Returns root element's URI string

Açıklama

string SDO_DAS_XML_Document::getRootElementURI ( void )

Returns root element's URI string.

Değiştirgeler

Dönen Değerler

Returns root element's URI string.

SDO_DAS_XML_Document::getRootElementName
SDO_DAS_XML_Document::setEncoding
SDO DAS XML İşlevleri


Sets the given string as encoding

SDO_DAS_XML_Document::getRootElementURI
SDO_DAS_XML_Document::setXMLDeclaration
SDO DAS XML İşlevleri
PHP Manual

SDO_DAS_XML_Document::setEncoding

(^)

SDO_DAS_XML_Document::setEncoding — Sets the given string as encoding

Açıklama

void SDO_DAS_XML_Document::setEncoding ( string $encoding )

Sets the given string as encoding.

Değiştirgeler

encoding

Encoding string.

Dönen Değerler

None.

SDO_DAS_XML_Document::getRootElementURI
SDO_DAS_XML_Document::setXMLDeclaration
SDO DAS XML İşlevleri


Sets the xml declaration

SDO_DAS_XML_Document::setEncoding
SDO_DAS_XML_Document::setXMLVersion
SDO DAS XML İşlevleri
PHP Manual

SDO_DAS_XML_Document::setXMLDeclaration

(^)

SDO_DAS_XML_Document::setXMLDeclaration — Sets the xml declaration

Açıklama

void SDO_DAS_XML_Document::setXMLDeclaration ( bool $xmlDeclatation )

Controls whether an XML declaration will be generated at the start of the XML document. Set to TRUE to generate the XML declaration, or FALSE to suppress it.

Değiştirgeler

xmlDeclatation

Boolean value to set the XML declaration.

Dönen Değerler

None.

SDO_DAS_XML_Document::setEncoding
SDO_DAS_XML_Document::setXMLVersion
SDO DAS XML İşlevleri


Sets the given string as xml version

SDO_DAS_XML_Document::setXMLDeclaration
Basit XML
SDO DAS XML İşlevleri
PHP Manual

SDO_DAS_XML_Document::setXMLVersion

(^)

SDO_DAS_XML_Document::setXMLVersion — Sets the given string as xml version

Açıklama

void SDO_DAS_XML_Document::setXMLVersion ( string $xmlVersion )

Sets the given string as xml version.

Değiştirgeler

xmlVersion

xml version string.

Dönen Değerler

None.

SDO_DAS_XML_Document::setXMLDeclaration
Basit XML
SDO DAS XML İşlevleri


Basit XML

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
    • Temel kullanım
    • XML hatalarıya ilgilenmek
  • SimpleXMLElement — SimpleXMLElement Sınıfı
    • SimpleXMLElement::addAttribute — XML elemanına bir öznitelik ekler
    • SimpleXMLElement::addChild — XML düğümüne bir çocuk düğüm ekler
    • SimpleXMLElement::asXML — Nesnenin içerdiği belgeyi iyi biçemli bir XML dizge olarak döndürür
    • SimpleXMLElement::attributes — Bir elemanın özniteliklerine erişim sağlar
    • SimpleXMLElement::children — Belirtilen düğümün çocuklarını bulur
    • SimpleXMLElement::__construct — Yeni bir SimpleXMLElement nesnesi oluşturur
    • SimpleXMLElement::count — Counts the children of an element
    • SimpleXMLElement::getDocNamespaces — Belgede bildirilmiş isim alanlarını döndürür
    • SimpleXMLElement::getName — XML eleman ismi döndürür
    • SimpleXMLElement::getNamespaces — Belgede kullanılan isim alanlarını döndürür
    • SimpleXMLElement::registerXPathNamespace — Sonraki XPath ifadesi için bir önek/isim alanı bağlamı oluşturur
    • SimpleXMLElement::saveXML — Takma Adı: SimpleXMLElement::asXML
    • SimpleXMLElement::__toString — Returns the string content
    • SimpleXMLElement::xpath — Bir XML veri üzerinde bir XPath sorgusu çalıştırır
  • Basit XML İşlevleri
    • simplexml_import_dom — Bir DOM düğümü alıp bir SimpleXMLElement nesnesi döndürür
    • simplexml_load_file — Bir XML dosyasının içeriğini bir nesne haline getirir
    • simplexml_load_string — Bir XML dizgesini bir nesne haline getirir
SDO_DAS_XML_Document::setXMLVersion
Giriş
XML İşleme


Giriş

Basit XML eklentisi, XML belgeleri, normal özellik seçicileri ve dizi yineleyicileri ile işleyebilen bir nesneye dönüştürmeyi kolaylaştıran araçları içerir.

Basit XML
Yapılandırma/Kurulum
Basit XML


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
Basit XML


Gereksinimler

Basit XML eklentisi PHP 5 gerektirir.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Basit XML eklentisi öntanımlı olarak etkindir. Etkisiz kılmak için PHP'yi derlerken --disable-simplexml configure seçeneğini kullanın.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
Örnekler
Basit XML


Örnekler

İçindekiler

  • Temel kullanım
  • XML hatalarıya ilgilenmek
Öntanımlı Sabitler
Temel kullanım
Basit XML


Temel kullanım

Bu eklentideki bir çok örnek bir XML dizge gerektirir. Her örnekte bu dizgeyi tekrar tekrar yazmak yerine her örnekte içerilmek üzere bir dosyaya koyduk. Bu dosyanın içeriği aşağıda verilmiştir. İsterseniz kendi XML belgenizi oluşturup simplexml_load_file() işleviyle de okutabilirsiniz.

Örnek 1 - XML dizge olarak içerilecek example.php dosyası

<?php
$xmlstr = <<<XML
<?xml version='1.0' standalone='yes'?>
<movies>
 <movie>
  <title>PHP: Behind the Parser</title>
  <characters>
   <character>
    <name>Ms. Coder</name>
    <actor>Onlivia Actora</actor>
   </character>
   <character>
    <name>Mr. Coder</name>
    <actor>El Act&#211;r</actor>
   </character>
  </characters>
  <plot>
   So, this language. It's like, a programming language. Or is it a
   scripting language? All is revealed in this thrilling horror spoof
   of a documentary.
  </plot>
  <great-lines>
   <line>PHP solves all my web problems</line>
  </great-lines>
  <rating type="thumbs">7</rating>
  <rating type="stars">5</rating>
 </movie>
</movies>
XML;
?>

Basit XML eklentisinin basitleştiriciliği, en açık haliyle basit bir XML belgeden bir sayı veya dizgeyi çıkarırken görülür.

Örnek 2 - <plot> içeriğinin eldesi

<?php
include 'example.php';

$xml = new SimpleXMLElement($xmlstr);

echo $xml->movie[0]->plot; // "So this language. It's like..."
?>

Bir XML belgedeki elemanlara erişirken, PHP isimlendirme kurallarına uymayan (örneğin, tire içeren) eleman isimleri tek tırnak ve kaşlı ayraçlarla sarmalanarak belirtilebilir.

Örnek 3 - <line> içeriğinin eldesi

<?php
include 'example.php';

$xml = new SimpleXMLElement($xmlstr);

echo $xml->movie->{'great-lines'}->line; // "PHP solves all my web problems"
?>

Örnek 4 - Bir elemanın birden fazla örneğine erişim

Bir ebeveyn elemanın aynı isimdeki birden fazla çocuğunun içeriğini elde etmek için normal yineleme teknikleri kullanılır.

<?php
include 'example.php';

$xml = new SimpleXMLElement($xmlstr);

/* Her <movie> düğümündeki <plot> içeriğini çıkaralım */
foreach ($xml->movie as $movie) {
   echo $movie->plot, '<br />';
}

?>

Örnek 5 - Özniteliklerin kullanımı

Şimdiye kadar hep eleman isimleri ve içerikleri ile çalıştık. Basit XML eklentisi eleman özniteliklerine de erişir. Eleman özniteliklerine, eleman ismini taşıyan dizinin anahtarları olarak erişebilirsiniz.

<?php
include 'example.php';

$xml = new SimpleXMLElement($xmlstr);

/* İlk <movie> içindeki <rating> düğümlerine erişelim.
 * İstatistiksel sonuçları çıktılayalım. */
foreach ($xml->movie[0]->rating as $rating) {
    switch((string) $rating['type']) { // Öznitelikler birer anahtardır
    case 'thumbs':
        echo $rating, ' onaylı';
        break;
    case 'stars':
        echo $rating, ' yıldızlı';
        break;
    }
}
?>

Örnek 6 - Elemanları ve öznitelikleri karşılaştırmak

Bir elemanı veya özniteliği bir dizge ile karşılaştırmak veya bir dizge gerektiren bir işleve aktarmak için nesnenin önüne (string) getirerek tür dönüşümü yapmalısınız. Aksi takdirde PHP, elemanı bir nesne olarak ele alır.

<?php
include 'example.php';

$xml = new SimpleXMLElement($xmlstr);

if ((string) $xml->movie->title == 'PHP: Behind the Parser') {
    print 'My favorite movie.';
}

htmlentities((string) $xml->movie->title);
?>

Örnek 7 - İki elemanı karşılaştırmak

İki SimpleXMLElement nesnesi, aynı elemana ait olsalar bile, PHP 5.2.0'dan beri farklı nesneler olarak ele alınırlar.

<?php
$el1 = new SimpleXMLElement($xmlstr);
$el2 = new SimpleXMLElement($xmlstr);
var_dump($el1 == $el2); // PHP 5.2.0'dan sonra FALSE
?>

Örnek 8 - XPath kullanımı

Basit XML eklentisinin yerleşik XPath desteği vardar. Tüm <character> elemanlarını bulmak isteyelim:

<?php
include 'example.php';
$xml = new SimpleXMLElement($xmlstr);

foreach ($xml->xpath('//character') as $character) {
    echo $character->name, 'played by ', $character->actor, '<br />';
}
?>

'//character' ifadesindeki '//' bir kısaltma olup, belgedeki tüm character elemanları anlamına gelir (Bakınız: » XML Adresleme Dili (XPath) 1.0 belirtimi).

Örnek 9 - Değer atamak

SimpleXMLElement nesnesinin verileri birer sabit değildir. Nesnenin tüm elemanlarında değişiklik yapılabilir.

<?php
include 'example.php';
$xml = new SimpleXMLElement($xmlstr);

$xml->movie[0]->characters->character[0]->name = 'Miss Coder';

echo $xml->asXML();
?>

Yukarıdaki kod, özgün belgedeki 'Ms. Coder' dizgesinin yerine 'Miss Coder' dizgesini yerleştirerek yeni bir XML belge çıktılar.

Örnek 10 - Eleman ve öznitelik eklemek

PHP 5.1.3'ten beri, SimpleXMLElement nesnesine çocuk elemanlar ve öznitelikler eklenebilmektedir.

<?php
include 'example.php';
$xml = new SimpleXMLElement($xmlstr);

$character = $xml->movie[0]->characters->addChild('character');
$character->addChild('name', 'Mr. Parser');
$character->addChild('actor', 'John Doe');

$rating = $xml->movie[0]->addChild('rating', 'PG');
$rating->addAttribute('type', 'mpaa');

echo $xml->asXML();
?>

Yukarıdaki kod, özgün belgeye yeni elemanlar ve öznitelikler ekleyerek yeni bir XML belge çıktılar.

Örnek 11 - DOM ile çalışabilirlik

PHP, XML düğümlerin Basit XML ve DOM biçemleri arasında dönüşüm yapılabilmeyi sağlayan bir mekanizmaya sahiptir. Bu örnekte bir DOM elemanının bir SimpleXMLElement nesnesine dönüştürülmesi gösterilmiştir.

<?php
$dom = new domDocument;
$dom->loadXML('<books><book><title>blah</title></book></books>');
if (!$dom) {
     echo 'Belge çözümlenirken hata oluştu';
     exit;
}

$s = simplexml_import_dom($dom);

echo $s->book[0]->title;
?>

Örnekler
XML hatalarıya ilgilenmek
Örnekler


XML hatalarıya ilgilenmek

Belgeleri yüklerken XML hatalarını ele almak basit bir işlemdir. Belgeyi yüklerken XML hatalarını libxml işlevselliğini kullanarak bastırdıktan sonra hatalar tek tek ele alınabilir.

libxml_get_errors() işlevi tarafından döndürülen libXMLError nesnesi, hata ile ilgili ileti, satır ve sütun gibi özellikler içerir.

Örnek 1 - Hatalı bir XML dizgesinin yüklenmesi

<?php
libxml_use_internal_errors(true);
$sxe = simplexml_load_string("<?xml version='1.0'><broken><xml></broken>");
if (!$sxe) {
    echo "XML yüklemesi başarısız oldu\n";
    foreach(libxml_get_errors() as $error) {
        echo "\t", $error->message;
    }
}

Yukarıdaki örneğin çıktısı:

XML yüklemesi başarısız oldu
 Blank needed here
 parsing XML declaration: '?>' expected
 Opening and ending tag mismatch: xml line 1 and broken
 Premature end of data in tag broken line 1

Ayrıca Bakınız

  • libxml_use_internal_errors()
  • libxml_get_errors()
  • libXMLError

Temel kullanım
SimpleXMLElement
Örnekler


SimpleXMLElement Sınıfı

(PHP 5 >= 5.0.1, PHP 7)

Giriş

XML belgesindeki bir elemanı temsil eder.

Sınıf Sözdizimi

SimpleXMLElement {
/* Yöntemler */
void addAttribute ( string $isim , string $değer [, string $isimalanı ] )
SimpleXMLElement addChild ( string $isim [, string $değer [, string $isimalanı ]] )
mixed asXML ([ string $dosya ] )
SimpleXMLElement attributes ([ string $isimalanı [, bool $önek_var ]] )
SimpleXMLElement children ([ string $isimalanı [, bool $önek_var ]] )
public int count ( void )
array getDocNamespaces ([ bool $ardışık ] )
string getName ( void )
array getNamespaces ([ bool $ardışık ] )
bool registerXPathNamespace ( string $önek , string $isimalanı )
public string __toString ( void )
array xpath ( string $ifade )
}

İçindekiler

  • SimpleXMLElement::addAttribute — XML elemanına bir öznitelik ekler
  • SimpleXMLElement::addChild — XML düğümüne bir çocuk düğüm ekler
  • SimpleXMLElement::asXML — Nesnenin içerdiği belgeyi iyi biçemli bir XML dizge olarak döndürür
  • SimpleXMLElement::attributes — Bir elemanın özniteliklerine erişim sağlar
  • SimpleXMLElement::children — Belirtilen düğümün çocuklarını bulur
  • SimpleXMLElement::__construct — Yeni bir SimpleXMLElement nesnesi oluşturur
  • SimpleXMLElement::count — Counts the children of an element
  • SimpleXMLElement::getDocNamespaces — Belgede bildirilmiş isim alanlarını döndürür
  • SimpleXMLElement::getName — XML eleman ismi döndürür
  • SimpleXMLElement::getNamespaces — Belgede kullanılan isim alanlarını döndürür
  • SimpleXMLElement::registerXPathNamespace — Sonraki XPath ifadesi için bir önek/isim alanı bağlamı oluşturur
  • SimpleXMLElement::saveXML — Takma Adı: SimpleXMLElement::asXML
  • SimpleXMLElement::__toString — Returns the string content
  • SimpleXMLElement::xpath — Bir XML veri üzerinde bir XPath sorgusu çalıştırır
XML hatalarıya ilgilenmek
SimpleXMLElement::addAttribute
Basit XML


XML elemanına bir öznitelik ekler

SimpleXMLElement
SimpleXMLElement::addChild
SimpleXMLElement
PHP Manual

SimpleXMLElement::addAttribute

(PHP 5 >= 5.1.3, PHP 7)

SimpleXMLElement::addAttribute — XML elemanına bir öznitelik ekler

Açıklama

void addAttribute ( string $isim , string $değer [, string $isimalanı ] )

SimpleXMLElement düğümüne bir öznitelik ekler.

Değiştirgeler

isim

Eklenecek özniteliğin ismi.

değer

Özniteliğin değeri.

isimalanı

Belirtilmişse, özniteliğin ait olduğu isim alanı.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 - Bir SimpleXMLElement nesnesine öznitelikler ve çocuk elemanlar eklemek

<?php

include 'example.php';

$sxe = new SimpleXMLElement($xmlstr);
$sxe->addAttribute('type', 'documentary');

$movie = $sxe->addChild('movie');
$movie->addChild('title', 'PHP2: More Parser Stories');
$movie->addChild('plot', 'This is all about the people who make it work.');

$characters = $movie->addChild('characters');
$character  = $characters->addChild('character');
$character->addChild('name', 'Mr. Parser');
$character->addChild('actor', 'John Doe');

$rating = $movie->addChild('rating', '5');
$rating->addAttribute('type', 'stars');

echo $sxe->asXML();

?>

Ayrıca Bakınız

  • SimpleXMLElement::addChild() - XML düğümüne bir çocuk düğüm ekler

SimpleXMLElement
SimpleXMLElement::addChild
SimpleXMLElement


XML düğümüne bir çocuk düğüm ekler

SimpleXMLElement::addAttribute
SimpleXMLElement::asXML
SimpleXMLElement
PHP Manual

SimpleXMLElement::addChild

(PHP 5 >= 5.1.3, PHP 7)

SimpleXMLElement::addChild — XML düğümüne bir çocuk düğüm ekler

Açıklama

SimpleXMLElement addChild ( string $isim [, string $değer [, string $isimalanı ]] )

XML düğümüne bir çocuk düğüm ekleyip çocuk elemanı bir SimpleXMLElement nesnesi olarak döndürür.

Değiştirgeler

isim

Eklenecek çocuk elemanın ismi.

değer

Belirtilmişse, çocuk elemanın değeri.

isimalanı

Belirtilmişse çocuk elemanın ait olduğu isim alanı.

Dönen Değerler

Eklenen çocuk elemanı bir SimpleXMLElement nesnesi olarak döndürür.

Örnekler

Örnek 1 - Bir SimpleXMLElement nesnesine öznitelikleriyle çocuk elemanlar eklemek

<?php

include 'example.php';

$sxe = new SimpleXMLElement($xmlstr);
$sxe->addAttribute('type', 'documentary');

$movie = $sxe->addChild('movie');
$movie->addChild('title', 'PHP2: More Parser Stories');
$movie->addChild('plot', 'This is all about the people who make it work.');

$characters = $movie->addChild('characters');
$character  = $characters->addChild('character');
$character->addChild('name', 'Mr. Parser');
$character->addChild('actor', 'John Doe');

$rating = $movie->addChild('rating', '5');
$rating->addAttribute('type', 'stars');

echo $sxe->asXML();

?>

Ayrıca Bakınız

  • SimpleXMLElement::addAttribute() - XML elemanına bir öznitelik ekler

SimpleXMLElement::addAttribute
SimpleXMLElement::asXML
SimpleXMLElement


Nesnenin içerdiği belgeyi iyi biçemli bir XML dizge olarak döndürür

SimpleXMLElement::addChild
SimpleXMLElement::attributes
SimpleXMLElement
PHP Manual

SimpleXMLElement::asXML

(PHP 5 >= 5.0.1, PHP 7)

SimpleXMLElement::asXML — Nesnenin içerdiği belgeyi iyi biçemli bir XML dizge olarak döndürür

Açıklama

mixed asXML ([ string $dosya ] )

Nesnenin içerdiği belgeyi iyi biçemli bir XML 1.0 dizgesi olarak döndürür.

Değiştirgeler

dosya

Belirtildiği takdirde, sonuç döndürülmeyip bu dosyaya yazılır.

Dönen Değerler

Eğer dosya belirtilmezse fakat bir hata oluşursa FALSE aksi takdirde bir dizge döner. Eğer dosya belirtilir ve dosyaya başarıyla yazılırsa TRUE aksi takdirde FALSE döner.

Örnekler

Örnek 1 - XML belgenin döndürülmesi

<?php
$string = <<<XML
<a>
 <b>
  <c>text</c>
  <c>stuff</c>
 </b>
 <d>
  <c>code</c>
 </d>
</a>
XML;

$xml = new SimpleXMLElement($string);

echo $xml->asXML(); // <?xml ... <a><b><c>text</c><c>stuff</c> ...

?>

asXML Xpath sonuçları üzerinde de çalışır:

Örnek 2 - SimpleXMLElement::xpath() sonucundan bir XML belge döndürmek

<?php
// Yukarıdaki örneğin devamıdır.

/* <a><b><c>'yi arayalım */
$result = $xml->xpath('/a/b/c');

while(list( , $node) = each($result)) {
    echo $node->asXML(); // <c>text</c> and <c>stuff</c>
}
?>

SimpleXMLElement::addChild
SimpleXMLElement::attributes
SimpleXMLElement


Bir elemanın özniteliklerine erişim sağlar

SimpleXMLElement::asXML
SimpleXMLElement::children
SimpleXMLElement
PHP Manual

SimpleXMLElement::attributes

(PHP 5 >= 5.0.1, PHP 7)

SimpleXMLElement::attributes — Bir elemanın özniteliklerine erişim sağlar

Açıklama

SimpleXMLElement attributes ([ string $isimalanı [, bool $önek_var ]] )

Bir XML etiketinin içerdiği özniteliklere ve değerlerine erişim sağlar.

Bilginize: SimpleXML iç içe nesnelerden (XML düğümlerinden) oluşur. Bu nedenle nesne içeriğini görmek için var_dump() ve benzerleri kullanılamaz.

Değiştirgeler

isimalanı

Özniteliklerin alınabilmesi için gerekebilecek isim alanı.

is_prefix

FALSE öntanımlıdır.

Dönen Değerler

Örnekler

Örnek 1 - Bir XML dizgenin yorumlanması

<?php
$string = <<<XML
<a xmlns:b>
 <foo name="one" game="lonely">1</foo>
</a>
XML;

$xml = simplexml_load_string($string);
foreach($xml->foo[0]->attributes() as $a => $b) {
    echo $a,'="',$b,"\"\n";
}
?>

Yukarıdaki örneğin çıktısı:

name="one"
game="lonely"

SimpleXMLElement::asXML
SimpleXMLElement::children
SimpleXMLElement


Belirtilen düğümün çocuklarını bulur

SimpleXMLElement::attributes
SimpleXMLElement::__construct
SimpleXMLElement
PHP Manual

SimpleXMLElement::children

(PHP 5 >= 5.0.1, PHP 7)

SimpleXMLElement::children — Belirtilen düğümün çocuklarını bulur

Açıklama

SimpleXMLElement children ([ string $isimalanı [, bool $önek_var ]] )

Bu yöntem nesnenin içerdiği alt düğümleri bulur. Sonuçlara foreach döngüleri üzerinden erişilebilir.

Bilginize: SimpleXML iç içe nesnelerden (XML düğümlerinden) oluşur. Bu nedenle nesne içeriğini görmek için var_dump() ve benzerleri kullanılamaz.

Değiştirgeler

isimalanı

önek_var

FALSE öntanımlıdır.

Dönen Değerler

Sürüm Bilgisi

Sürüm: | Açıklama
5.2.0 | Seçimlik önek_var değiştirgesi eklendi.

Örnekler

Örnek 1 - children() dizimsisi

<?php
$xml = new SimpleXMLElement(
'<person>
 <child role="son">
  <child role="daughter"/>
 </child>
 <child role="daughter">
  <child role="son">
   <child role="son"/>
  </child>
 </child>
</person>');

foreach ($xml->children() as $second_gen) {
    echo ' The person begot a ' . $second_gen['role'];

    foreach ($second_gen->children() as $third_gen) {
        echo ' who begot a ' . $third_gen['role'] . ';';

        foreach ($third_gen->children() as $fourth_gen) {
            echo ' and that ' . $third_gen['role'] .
                ' begot a ' . $fourth_gen['role'];
        }
    }
}
?>

Yukarıdaki örneğin çıktısı:

The person begot a son who begot a daughter; The person
begot a daughter who begot a son; and that son begot a son

SimpleXMLElement::attributes
SimpleXMLElement::__construct
SimpleXMLElement


Yeni bir SimpleXMLElement nesnesi oluşturur

SimpleXMLElement::children
SimpleXMLElement::count
SimpleXMLElement
PHP Manual

SimpleXMLElement::__construct

(PHP 5 >= 5.0.1, PHP 7)

SimpleXMLElement::__construct — Yeni bir SimpleXMLElement nesnesi oluşturur

Açıklama

__construct ( string $veri [, int $seçenekler [, bool $veri_bir_url [, string $isimalanı [, bool $önek_var ]]]] )

Yeni bir SimpleXMLElement nesnesi oluşturur

Değiştirgeler

veri

İyi biçemli bir XML dizgesi veya veri_bir_url ile TRUE belirtilmişse bir XML belge adresi ya da dosya yolu.

seçenekler

Ek Libxml değiştirgelerini belirtmek için isteğe bağlı bir değiştirge.

veri_bir_url

Öntanımlı olarak değeri FALSE'tır. veri değiştirgesinde bir XML belge adresi ya da dosya yolu belirtecekseniz TRUE olmalıdır.

isimalanı

önek_var

İpucu

Tüm XML hatalarını bastırmak için libxml_use_internal_errors() kullanıp daha sonra bu hataları libxml_get_errors() ile tek tek ele alabilirsiniz.

Dönen Değerler

veri ile belirtilen XML belgeyi içeren bir SimpleXMLElement nesnesi döner.

Hatalar/İstisnalar

XML veride saptanan her hata için bir istisna oluşturup bir E_WARNING üretir.

Örnekler

Örnek 1 - Bir dizgeden bir SimpleXMLElement nesnesi oluşturmak

<?php

include 'example.php';

$sxe = new SimpleXMLElement($xmlstr);
echo $sxe->movie[0]->title;

?>

Örnek 2 - Bir dosyadan bir SimpleXMLElement nesnesi oluşturmak

<?php

$sxe = new SimpleXMLElement('http://example.org/document.xml', NULL, TRUE);
echo $sxe->asXML();

?>

Ayrıca Bakınız

  • simplexml_load_string() - Bir XML dizgesini bir nesne haline getirir
  • simplexml_load_file() - Bir XML dosyasının içeriğini bir nesne haline getirir
  • XML hatalarıya ilgilenmek
  • libxml_use_internal_errors() - libxml hatalarını kapatarak kullanıcı tanımlı hataları mümkün kılar

SimpleXMLElement::children
SimpleXMLElement::count
SimpleXMLElement


Counts the children of an element

SimpleXMLElement::__construct
SimpleXMLElement::getDocNamespaces
SimpleXMLElement
PHP Manual

SimpleXMLElement::count

(PHP 5 >= 5.3.0, PHP 7)

SimpleXMLElement::count — Counts the children of an element

Açıklama

public int SimpleXMLElement::count ( void )

This method counts the number of children of an element.

Dönen Değerler

Returns the number of elements of an element.

Örnekler

Örnek 1 Counting the number of children

<?php
$xml = <<<EOF
<people>
 <person name="Person 1">
  <child/>
  <child/>
  <child/>
 </person>
 <person name="Person 2">
  <child/>
  <child/>
  <child/>
  <child/>
  <child/>
 </person>
</people>
EOF;

$elem = new SimpleXMLElement($xml);

foreach ($elem as $person) {
    printf("%s has got %d children.\n", $person['name'], $person->count());
}
?>

Yukarıdaki örneğin çıktısı:

Person 1 has got 3 children.
Person 2 has got 5 children.

Ayrıca Bakınız

  • SimpleXMLElement::children() - Belirtilen düğümün çocuklarını bulur

SimpleXMLElement::__construct
SimpleXMLElement::getDocNamespaces
SimpleXMLElement


Belgede bildirilmiş isim alanlarını döndürür

SimpleXMLElement::count
SimpleXMLElement::getName
SimpleXMLElement
PHP Manual

SimpleXMLElement::getDocNamespaces

(PHP 5 >= 5.1.2, PHP 7)

SimpleXMLElement::getDocNamespaces — Belgede bildirilmiş isim alanlarını döndürür

Açıklama

array getDocNamespaces ([ bool $ardışık ] )

Belgede bildirilmiş isim alanlarını döndürür.

Değiştirgeler

ardışık

TRUE belirtilirse kök düğüm ve tüm çocuk ve torun düğümlerin isim alanlarını, aksi takdirde sadece kök düğümde kullanılan isim alanlarını döndürür.

Dönen Değerler

İsim alanlarını ve betimleyicilerini içeren bir dizi döndürür.

Örnekler

Örnek 1 - Belge isim alanlarının döndürülmesi

<?php

$xml = <<<XML
<?xml version="1.0" standalone="yes"?>
<people xmlns:p="http://example.org/ns">
    <p:person id="1">John Doe</p:person>
    <p:person id="2">Susie Q. Public</p:person>
</people>
XML;

$sxe = new SimpleXMLElement($xml);

$namespaces = $sxe->getDocNamespaces();
var_dump($namespaces);

?>

Örnek 2 - Çok sayıda isim alanı ile çalışma

<?php

$xml = <<<XML
<?xml version="1.0" standalone="yes"?>
<people xmlns:p="http://example.org/ns" xmlns:t="http://example.org/test">
    <p:person t:id="1">John Doe</p:person>
    <p:person t:id="2" a:addr="123 Street" xmlns:a="http://example.org/addr">
        Susie Q. Public
    </p:person>
</people>
XML;

$sxe = new SimpleXMLElement($xml);

$namespaces = $sxe->getDocNamespaces(TRUE);
var_dump($namespaces);

?>

Ayrıca Bakınız

  • SimpleXMLElement::getNamespaces() - Belgede kullanılan isim alanlarını döndürür
  • SimpleXMLElement::registerXPathNamespace() - Sonraki XPath ifadesi için bir önek/isim alanı bağlamı oluşturur

SimpleXMLElement::count
SimpleXMLElement::getName
SimpleXMLElement


XML eleman ismi döndürür

SimpleXMLElement::getDocNamespaces
SimpleXMLElement::getNamespaces
SimpleXMLElement
PHP Manual

SimpleXMLElement::getName

(PHP 5 >= 5.1.3, PHP 7)

SimpleXMLElement::getName — XML eleman ismi döndürür

Açıklama

string getName ( void )

XML eleman ismi döndürür.

Dönen Değerler

SimpleXMLElement nesnesindeki bir XML etiketinin ismini bir dizge olarak döndürür.

Örnekler

Örnek 1 - XML eleman isimlerinin döndürülmesi

<?php

$sxe = new SimpleXMLElement($xmlstr);

echo $sxe->getName() . "\n";

foreach ($sxe->children() as $child)
{
    echo $child->getName() . "\n";
}

?>

SimpleXMLElement::getDocNamespaces
SimpleXMLElement::getNamespaces
SimpleXMLElement


Belgede kullanılan isim alanlarını döndürür

SimpleXMLElement::getName
SimpleXMLElement::registerXPathNamespace
SimpleXMLElement
PHP Manual

SimpleXMLElement::getNamespaces

(PHP 5 >= 5.1.2, PHP 7)

SimpleXMLElement::getNamespaces — Belgede kullanılan isim alanlarını döndürür

Açıklama

array getNamespaces ([ bool $ardışık ] )

Belgede kullanılan isim alanlarını döndürür.

Değiştirgeler

ardışık

TRUE belirtilirse kök düğüm ve tüm çocuk ve torun düğümlerin isim alanlarını, aksi takdirde sadece kök düğümde kullanılan isim alanlarını döndürür.

Dönen Değerler

İsim alanlarını ve betimleyicilerini içeren bir dizi döndürür.

Örnekler

Örnek 1 - Kullanılan belge isim alanlarının döndürülmesi

<?php

$xml = <<<XML
<?xml version="1.0" standalone="yes"?>
<people xmlns:p="http://example.org/ns" xmlns:t="http://example.org/test">
    <p:person id="1">John Doe</p:person>
    <p:person id="2">Susie Q. Public</p:person>
</people>
XML;

$sxe = new SimpleXMLElement($xml);

$namespaces = $sxe->getNamespaces(true);
var_dump($namespaces);

?>

Yukarıdaki örneğin çıktısı:

array(1) {
  ["p"]=>
  string(21) "http://example.org/ns"
}

Ayrıca Bakınız

  • SimpleXMLElement::getDocNamespaces() - Belgede bildirilmiş isim alanlarını döndürür
  • SimpleXMLElement::registerXPathNamespace() - Sonraki XPath ifadesi için bir önek/isim alanı bağlamı oluşturur

SimpleXMLElement::getName
SimpleXMLElement::registerXPathNamespace
SimpleXMLElement


Sonraki XPath ifadesi için bir önek/isim alanı bağlamı oluşturur

SimpleXMLElement::getNamespaces
SimpleXMLElement::saveXML
SimpleXMLElement
PHP Manual

SimpleXMLElement::registerXPathNamespace

(PHP 5 >= 5.2.0, PHP 7)

SimpleXMLElement::registerXPathNamespace — Sonraki XPath ifadesi için bir önek/isim alanı bağlamı oluşturur

Açıklama

bool registerXPathNamespace ( string $önek , string $isimalanı )

Sonraki XPath ifadesi için bir önek/isim alanı bağlamı oluşturur. Özellikle, XML belgenin, isim alanı öneklerinin değiştirilmesi durumunda kullanışlıdır. Bu yöntem, isim alanındaki düğümlere kodda değişiklik yapmadan erişmek amacıyla ilişkili isim alanı için bir önek oluşturur.

Değiştirgeler

önek

isimalanı ile belirtilen isim alanı için Xpath ifadesinde kullanılacak isim alanı öneki.

isimalanı

Xpath ifadesi için kullanılacak isim alanı. Belirtilen önek'in kullanıldığı XPath ifadeleri veya XML belgelerinin bir sonuç üretmesi için kullanılacak isim alanı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Bir XPath ifadesinde kullanılacak isim alanı önekinin belirtilmesi

<?php

$xml = <<<EOD
<book xmlns:chap="http://example.org/chapter-title">
    <title>XPath Kitabı</title>
    <chapter id="1">
        <chap:title>1. Fasıl</chap:title>
        <para>Önemli ifade çeşitlerinden biri konumsal yoldur. Bir konumsal
        yol bağlamsal düğüme göreli olarak bir düğüm kümesini seçer. İfadenin
        konumsal yol olduğu durumda değerlendirme sonucu, konumsal yol
        tarafından seçilen düğümleri içeren düğüm kümesidir. Konumsal yollar
        düğüm kümelerini süzmekte kullanılan ifadeleri dönüşümlü olarak
        içerebilir. İki çeşit konumsal yol vardır: Göreli konumsal yollar ve
        mutlak konumsal yollar.</para>
    </chapter>
    <chapter id="2">
        <chap:title>2. Fasıl</chap:title>
        <para>Bir göreli konumsal yol, / imleriyle birbirlerinden ayrılmış bir
        veya daha fazla konumdan oluşur. Göreli konumsal yoldaki bu konumlar
        soldan sağa birlikte bir bütün oluştururlar. Her konumda bağlamsal
        düğüme göreli bir düğüm kümesi seçilir ve kümedeki her düğüm sonraki
        konumun bağlamsal düğümü olur. Bir mutlak konumsal yol / iminden sonra
        gelen bir göreli konumsal yoldan oluşur. Tek başına / imi, bağlamsal
        düğümü içeren belgenin kök düğümünü seçer. Kök düğüm, bu imden sonra
        gelen göreli konumsal yolun ilk konumunun bağlamsal düğümü olur.</para>
    </chapter>
</book>
EOD;

$sxe = new SimpleXMLElement($xml);

$sxe->registerXPathNamespace('c', 'http://example.org/chapter-title');
$result = $sxe->xpath('//c:title');

foreach ($result as $title) {
  echo $title . "\n";
}

?>

Örnekte, bir isim alanının chap önekiyle bir XML belgede nasıl gösterildiğine dikkat edin. Bu belgenin (veya bir benzerinin) geçmişte, aynı isim alanı için c önekini kullanmış olduğunu varsayalım. Önek değiştiğinden XPath ifadesi beklenen sonucu vermeyecek ve ifadenin değiştirilmesi gerekecektir. İşte bu noktada registerXPathNamespace ile bu gibi önek değişikliklerinde ifadenin değiştirilmesi gereğini ortadan kaldırmak mümkün olur.

Ayrıca Bakınız

  • SimpleXMLElement::getDocNamespaces() - Belgede bildirilmiş isim alanlarını döndürür
  • SimpleXMLElement::getNamespaces() - Belgede kullanılan isim alanlarını döndürür

SimpleXMLElement::getNamespaces
SimpleXMLElement::saveXML
SimpleXMLElement


Takma Adı: SimpleXMLElement::asXML

SimpleXMLElement::registerXPathNamespace
SimpleXMLElement::__toString
SimpleXMLElement
PHP Manual

SimpleXMLElement::saveXML

(PHP 5 >= 5.2.0, PHP 7)

SimpleXMLElement::saveXML — Takma Adı: SimpleXMLElement::asXML()

Açıklama

Bu yöntem şu yöntemin takma adıdır: SimpleXMLElement::asXML()

SimpleXMLElement::registerXPathNamespace
SimpleXMLElement::__toString
SimpleXMLElement


Returns the string content

SimpleXMLElement::saveXML
SimpleXMLElement::xpath
SimpleXMLElement
PHP Manual

SimpleXMLElement::__toString

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

SimpleXMLElement::__toString — Returns the string content

Açıklama

public string SimpleXMLElement::__toString ( void )

Returns text content that is directly in this element. Does not return text content that is inside this element's children.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the string content on success or an empty string on failure.

Örnekler

Örnek 1 Get string content

<?php
$xml = new SimpleXMLElement('<a>1 <b>2 </b>3</a>');
echo $xml;
?>

Yukarıdaki örneğin çıktısı:

1 3

Ayrıca Bakınız

  • SimpleXMLElement::asXML() - Nesnenin içerdiği belgeyi iyi biçemli bir XML dizge olarak döndürür

SimpleXMLElement::saveXML
SimpleXMLElement::xpath
SimpleXMLElement


Bir XML veri üzerinde bir XPath sorgusu çalıştırır

SimpleXMLElement::__toString
Basit XML İşlevleri
SimpleXMLElement
PHP Manual

SimpleXMLElement::xpath

(PHP 5 >= 5.2.0, PHP 7)

SimpleXMLElement::xpath — Bir XML veri üzerinde bir XPath sorgusu çalıştırır

Açıklama

array xpath ( string $ifade )

ifade ile belirtilen XPath yoluyla eşleşen SimpleXMLElement düğümlerini döndürür.

Değiştirgeler

ifade

Bir XPath yolu.

Dönen Değerler

Başarısız olursa FALSE yoksa SimpleXMLElement nesnelerinden oluşan bir dizi döndürür.

Örnekler

Örnek 1 - Xpath örneği

<?php
$string = <<<XML
<a>
 <b>
  <c>text</c>
  <c>stuff</c>
 </b>
 <d>
  <c>code</c>
 </d>
</a>
XML;

$xml = new SimpleXMLElement($string);

/* Search for <a><b><c> */
$result = $xml->xpath('/a/b/c');

while(list( , $node) = each($result)) {
    echo '/a/b/c: ',$node,"\n";
}

/* Göreli yollar da çalışır... */
$result = $xml->xpath('b/c');

while(list( , $node) = each($result)) {
    echo 'b/c: ',$node,"\n";
}
?>

Yukarıdaki örneğin çıktısı:

/a/b/c: text
/a/b/c: stuff
b/c: text
b/c: stuff

İki sonucun da aynı oluşuna dikkat edin.

SimpleXMLElement::__toString
Basit XML İşlevleri
SimpleXMLElement


Basit XML İşlevleri

İçindekiler

  • simplexml_import_dom — Bir DOM düğümü alıp bir SimpleXMLElement nesnesi döndürür
  • simplexml_load_file — Bir XML dosyasının içeriğini bir nesne haline getirir
  • simplexml_load_string — Bir XML dizgesini bir nesne haline getirir
SimpleXMLElement::xpath
simplexml_import_dom
Basit XML


Bir DOM düğümü alıp bir SimpleXMLElement nesnesi döndürür

Basit XML İşlevleri
simplexml_load_file
Basit XML İşlevleri
PHP Manual

simplexml_import_dom

(PHP 5, PHP 7)

simplexml_import_dom — Bir DOM düğümü alıp bir SimpleXMLElement nesnesi döndürür

Açıklama

SimpleXMLElement simplexml_import_dom ( DOMNode $düğüm [, string $sınıfAdı = "SimpleXMLElement" ] )

Bir DOM düğümü alıp bir SimpleXMLElement düğümü oluşturur. Bu yeni nesne yeni bir Basit XML elemanı olarak kullanılabilir.

Değiştirgeler

düğüm

Bir DOM Eleman düğümü

sınıfAdı

İsteğe bağlı bu değiştirge ile bir nesne döndürmek üzere SimpleXMLElement sınıfından türetilmiş bir sınıf ismi belirtilebilir.

Dönen Değerler

Başarısız olursa FALSE yoksa bir SimpleXMLElement nesnesi döndürür.

Örnekler

Örnek 1 - DOM ithali

<?php
$dom = new DOMDocument;
$dom->loadXML('<books><book><title>blah</title></book></books>');
if (!$dom) {
    echo 'Belge çözümlenemedi';
    exit;
}

$s = simplexml_import_dom($dom);

echo $s->book[0]->title; // blah
?>

Ayrıca Bakınız

  • dom_import_simplexml() - Bir SimpleXMLElement düğümü alıp bir DOMElement düğümü döndürür

Basit XML İşlevleri
simplexml_load_file
Basit XML İşlevleri


Bir XML dosyasının içeriğini bir nesne haline getirir

simplexml_import_dom
simplexml_load_string
Basit XML İşlevleri
PHP Manual

simplexml_load_file

(PHP 5, PHP 7)

simplexml_load_file — Bir XML dosyasının içeriğini bir nesne haline getirir

Açıklama

object simplexml_load_file ( string $dosya [, string $sınıfAdı = "SimpleXMLElement" [, int $seçenekler = 0 [, string $isimalanı [, bool $önek_var = false ]]]] )

Dosya ismi belirtilen iyi biçemli bir XML belgeyi bir nesneye dönüştürür.

Değiştirgeler

dosya

XML dosyanın yolu.

Bilginize:

Libxml2, URI üzerinde işlem yaptığından, a değiştirgesiyle b&c aktaracaksanız bunu şöyle yapmalısınız: simplexml_load_file(rawurlencode('http://example.com/?a=' . urlencode('b&c'))). PHP 5.1.0'dan itibaren PHP bunu sizin yerinize yaptığından bu dönüşümü yapma ihtiyacını duymayacaksınız.

sınıfAdı

İsteğe bağlı bu değiştirge ile bir nesne döndürmek üzere SimpleXMLElement sınıfından türetilmiş bir sınıf ismi belirtilebilir.

seçenekler

PHP 5.1.0 ve Libxml 2.6.0'dan beri, bu değiştirge ile ek Libxml değiştirgeleri belirtilebilmektedir.

isimalanı

önek_var

Dönen Değerler

XML belgedeki veriyi içeren, SimpleXMLElement sınıfından türetilmiş bir nesne döndürür. Hata durumunda FALSE döner.

Hatalar/İstisnalar

XML verisinde bulunan her hata için bir E_WARNING hatası üretilir.

İpucu

Tüm XML hatalarını bastırmak için libxml_use_internal_errors() kullanıp daha sonra bu hataları libxml_get_errors() ile tek tek ele alabilirsiniz.

Örnekler

Örnek 1 - Bir XML belgenin yorumlanması

<?php
// test.xml dosyası en azından bir <title> elemanına
// sahip bir XML belge içermektedir.

if (file_exists('test.xml')) {
    $xml = simplexml_load_file('test.xml');

    print_r($xml);
} else {
    exit('test.xml açılamadı.');
}
?>

Betik sorunsuz çalışırsa şunu çıktılar:

SimpleXMLElement Object
(
  [title] => Example Title
  ...
)

Ayrıca, echo $xml->title gibi çıktılamalar da yapabilirdiniz.

Ayrıca Bakınız

  • simplexml_load_string() - Bir XML dizgesini bir nesne haline getirir
  • SimpleXMLElement::__construct() - Yeni bir SimpleXMLElement nesnesi oluşturur
  • XML hatalarıya ilgilenmek
  • libxml_use_internal_errors() - libxml hatalarını kapatarak kullanıcı tanımlı hataları mümkün kılar

simplexml_import_dom
simplexml_load_string
Basit XML İşlevleri


Bir XML dizgesini bir nesne haline getirir

simplexml_load_file
WDDX
Basit XML İşlevleri
PHP Manual

simplexml_load_string

(PHP 5, PHP 7)

simplexml_load_string — Bir XML dizgesini bir nesne haline getirir

Açıklama

object simplexml_load_string ( string $veri [, string $sınıfAdı = "SimpleXMLElement" [, int $seçenekler = 0 [, string $isimalanı [, bool $önek_var = false ]]]] )

İyi biçemli bir XML dizgesi alır ve bir nesne olarak döndürür.

Değiştirgeler

veri

İyi biçemli bir XML dizgesi.

sınıfAdı

İsteğe bağlı bu değiştirge ile bir nesne döndürmek üzere SimpleXMLElement sınıfından türetilmiş bir sınıf ismi belirtilebilir.

seçenekler

PHP 5.1.0 ve Libxml 2.6.0'dan beri, bu değiştirge ile ek Libxml değiştirgeleri belirtilebilmektedir.

isimalanı

önek_var

Dönen Değerler

XML belgedeki veriyi içeren, SimpleXMLElement sınıfından türetilmiş bir nesne döndürür. Hata durumunda FALSE döner.

Hatalar/İstisnalar

XML verisinde bulunan her hata için bir E_WARNING hatası üretilir.

İpucu

Tüm XML hatalarını bastırmak için libxml_use_internal_errors() kullanıp daha sonra bu hataları libxml_get_errors() ile tek tek ele alabilirsiniz.

Örnekler

Örnek 1 - Bir XML belgenin yorumlanması

<?php
$string = <<<XML
<?xml version='1.0'?>
<document>
 <title>Soru Ne?</title>
 <from>Can</from>
 <to>Canan</to>
 <body>
  Cevabı anladık da sonu neydi?
 </body>
</document>
XML;

$xml = simplexml_load_string($string);

var_dump($xml);
?>

Yukarıdaki örneğin çıktısı:

SimpleXMLElement Object
(
  [title] => Soru Ne?
  [from] => Can
  [to] => Canan
  [body] =>
   Cevabı anladık da sonu neydi?
)

Ayrıca, echo $xml->body gibi çıktılamalar da yapabilirdiniz.

Ayrıca Bakınız

  • simplexml_load_file() - Bir XML dosyasının içeriğini bir nesne haline getirir
  • SimpleXMLElement::__construct() - Yeni bir SimpleXMLElement nesnesi oluşturur
  • XML hatalarıya ilgilenmek
  • libxml_use_internal_errors() - libxml hatalarını kapatarak kullanıcı tanımlı hataları mümkün kılar

simplexml_load_file
WDDX
Basit XML İşlevleri


WDDX

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
    • WDDX örnekleri
  • WDDX İşlevleri
    • wddx_add_vars — Tanıtıcısı belirtilen WDDX paketine değişken ekler
    • wddx_deserialize — wddx_unserialize işlevinin takma adıdır
    • wddx_packet_end — Tanıtıcısı belirtilen WDDX paketini kapatır
    • wddx_packet_start — Bir veri yapısı içeren yeni bir WDDX paketi başlatır
    • wddx_serialize_value — Tek bir değeri bir WDDX paketi içinde dizgeleştirir
    • wddx_serialize_vars — Değişkenleri bir WDDX paketi olara dizgeleştirir
simplexml_load_string
Giriş
XML İşleme


Giriş

Bu işlevler » WDDX ile çalışmak üzere tasarlanmıştır.

WDDX
Yapılandırma/Kurulum
WDDX


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
WDDX


Gereksinimler

WDDX eklentisini kullanmak için sisteminizde expat kütüphanesinin kurulu olması gerekir. Expat kütüphanesi Apache 1.3.7 ve üstü sürümlerle gelir.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu eklentinin çalışması için sisteminizde expat kurulu olmalı ve PHP --enable-wddx seçeneği ile derlenmiş olmalıdır.

PHP'nin Windows sürümünde bu eklenti yerleşik olarak gelmektedir. Bu işlevleri Windows'ta kullanmak için herhangi bir eklenti kurmanıza gerek yoktur.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Özkaynak Türleri

Bu eklenti, wddx_packet_start() işlevi tarafından döndürülen bir WDDX paket tanıtıcısına sahiptir.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
Örnekler
WDDX


Örnekler

İçindekiler

  • WDDX örnekleri
Öntanımlı Sabitler
WDDX örnekleri
WDDX


WDDX örnekleri

Değişkenleri dizgeleştiren tüm işlevler, dizinin bir dizi olarak mı yoksa bir yapı olarak mı dizgeleştirileceğini saptamak için bir dizinin ilk elemanını kullanır. Eğer ilk eleman dizgesel bir anahtara sahipse bir yapı olarak aksi takdirde bir dizi olarak dizgeleştirilir.

Örnek 1 - WDDX ile tek bir değerin dizgeleştirilmesi

<?php
echo wddx_serialize_value("PHP'den WDDX paketi elde etme örneği", "PHP paketi");
?>

Bu örnek şunu üretir:

<wddxPacket version='1.0'><header comment='PHP paketi'/><data>
<string>PHP'den WDDX paketi elde etme örneği</string></data></wddxPacket>

Örnek 2 - WDDX ile artırımsal paketlerin kullanımı

<?php
$pi = 3.1415926;
$packet_id = wddx_packet_start("PHP");
wddx_add_vars($packet_id, "pi");

/* $cities veritabanından geliyor olsun */
$cities = array("Austin", "Novato", "Seattle");
wddx_add_vars($packet_id, "cities");

$packet = wddx_packet_end($packet_id);
echo $packet;
?>

Bu örnek şunu üretir:

<wddxPacket version='1.0'><header comment='PHP'/><data><struct>
<var name='pi'><number>3.1415926</number></var><var name='cities'>
<array length='3'><string>Austin</string><string>Novato</string>
<string>Seattle</string></array></var></struct></data></wddxPacket>

Bilginize:

ASCII olmayan karakterleri dizgeleştirmek isterseniz karakter kodlamasını önce UTF-8'e dönüştürmelisiniz (bakınız: utf8_encode() ve iconv()).

Örnekler
WDDX İşlevleri
Örnekler


WDDX İşlevleri

İçindekiler

  • wddx_add_vars — Tanıtıcısı belirtilen WDDX paketine değişken ekler
  • wddx_deserialize — wddx_unserialize işlevinin takma adıdır
  • wddx_packet_end — Tanıtıcısı belirtilen WDDX paketini kapatır
  • wddx_packet_start — Bir veri yapısı içeren yeni bir WDDX paketi başlatır
  • wddx_serialize_value — Tek bir değeri bir WDDX paketi içinde dizgeleştirir
  • wddx_serialize_vars — Değişkenleri bir WDDX paketi olara dizgeleştirir
WDDX örnekleri
wddx_add_vars
WDDX


Tanıtıcısı belirtilen WDDX paketine değişken ekler

WDDX İşlevleri
wddx_deserialize
WDDX İşlevleri
PHP Manual

wddx_add_vars

(PHP 4, PHP 5, PHP 7)

wddx_add_vars — Tanıtıcısı belirtilen WDDX paketine değişken ekler

Açıklama

bool wddx_add_vars ( resource $pt , mixed $değişken [, mixed $... ] )

Aktarılan değişkenleri dizgeleştirip tanıtıcısı belirtilen WDDX paketine ekler.

Değiştirgeler

Bu işlevin alabileceği değiştirge sayısı değişkendir.

pt

wddx_packet_start() tarafından döndürülmüş bir WDDX paket tanıtıcısı.

değişken

Bir değişken ismi veya değişken isimlerini veya diğer dizileri ve benzerlerini içeren bir dizi olabilir.

...

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

WDDX İşlevleri
wddx_deserialize
WDDX İşlevleri


wddx_unserialize işlevinin takma adıdır

wddx_add_vars
wddx_packet_end
WDDX İşlevleri
PHP Manual

wddx_deserialize

(PHP 4, PHP 5, PHP 7)

wddx_deserialize — wddx_unserialize() işlevinin takma adıdır

Açıklama

Bu işlev, wddx_unserialize() işlevinin takma adıdır.

wddx_add_vars
wddx_packet_end
WDDX İşlevleri


Tanıtıcısı belirtilen WDDX paketini kapatır

wddx_deserialize
wddx_packet_start
WDDX İşlevleri
PHP Manual

wddx_packet_end

(PHP 4, PHP 5, PHP 7)

wddx_packet_end — Tanıtıcısı belirtilen WDDX paketini kapatır

Açıklama

string wddx_packet_end ( resource $pt )

Tanıtıcısı belirtilen WDDX paketini kapatır ve döndürür.

Değiştirgeler

pt

wddx_packet_start() tarafından döndürülmüş bir WDDX paket tanıtıcısı.

Dönen Değerler

WDDX paketini içeren bir dizge döner.

wddx_deserialize
wddx_packet_start
WDDX İşlevleri


Bir veri yapısı içeren yeni bir WDDX paketi başlatır

wddx_packet_end
wddx_serialize_value
WDDX İşlevleri
PHP Manual

wddx_packet_start

(PHP 4, PHP 5, PHP 7)

wddx_packet_start — Bir veri yapısı içeren yeni bir WDDX paketi başlatır

Açıklama

resource wddx_packet_start ([ string $azıklama ] )

Değişken eklemek üzere yeni bir WDDX paketi başlatır. Özdevinimli olarak paket içinde değişkenleri içerecek bir veri yapısı oluşturulur.

Değiştirgeler

açıklama

Belirtilmesi isteğe bağlı bir açıklama dizgesi.

Dönen Değerler

Bir hata oluşursa FALSE yoksa daha sonra işlevlerde kullanılmak üzere bir paket tanıtıcısı döner.

wddx_packet_end
wddx_serialize_value
WDDX İşlevleri


Tek bir değeri bir WDDX paketi içinde dizgeleştirir

wddx_packet_start
wddx_serialize_vars
WDDX İşlevleri
PHP Manual

wddx_serialize_value

(PHP 4, PHP 5, PHP 7)

wddx_serialize_value — Tek bir değeri bir WDDX paketi içinde dizgeleştirir

Açıklama

string wddx_serialize_value ( mixed $değer [, string $açıkama ] )

Belirtilen değerden bir WDDX paketi oluşturur.

Değiştirgeler

değer

Dizgeleştirilecek değer.

açıkama

Paket başlığında görünmek üzere belirtilmesi isteğe bağlı açıklama dizgesi.

Dönen Değerler

Bir hata oluşursa FALSE yoksa bir WDDX paketi döner.

wddx_packet_start
wddx_serialize_vars
WDDX İşlevleri


Değişkenleri bir WDDX paketi olara dizgeleştirir

wddx_serialize_value
XMLDiff
WDDX İşlevleri
PHP Manual

wddx_serialize_vars

(PHP 4, PHP 5, PHP 7)

wddx_serialize_vars — Değişkenleri bir WDDX paketi olara dizgeleştirir

Açıklama

string wddx_serialize_vars ( mixed $değişken [, mixed $... ] )

Aktarılan değişkenlerin dizgeleştirilmiş gösterimlerini içeren bir yapı olarak bir WDDX paketi oluşturur.

Değiştirgeler

Bu işlevin alabileceği değiştirge sayısı değişkendir.

değişken

Bir değişken ismi veya değişken isimlerini veya diğer dizileri ve benzerlerini içeren bir dizi olabilir.

...

Dönen Değerler

Bir hata oluşursa FALSE yoksa bir WDDX paketi döner.

Örnekler

Örnek 1 - wddx_serialize_vars() örneği

<?php
$a = 1;
$b = 5.5;
$c = array("blue", "orange", "violet");
$d = "colors";

$clvars = array("c", "d");
echo wddx_serialize_vars("a", "b", $clvars);
?>

Yukarıdaki örneğin çıktısı:

<wddxPacket version='1.0'><header/><data><struct><var name='a'><number>1</number></var>
<var name='b'><number>5.5</number></var><var name='c'><array length='3'>
<string>blue</string><string>orange</string><string>violet</string></array></var>
<var name='d'><string>colors</string></var></struct></data></wddxPacket>

wddx_serialize_value
XMLDiff
WDDX İşlevleri


XML diff and merge

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
  • XMLDiff\Base — The XMLDiff\Base class
    • XMLDiff\Base::__construct — Constructor
    • XMLDiff\Base::diff — Produce diff of two XML documents
    • XMLDiff\Base::merge — Produce new XML document based on diff
  • XMLDiff\DOM — The XMLDiff\DOM class
    • XMLDiff\DOM::diff — Diff two DOMDocument objects
    • XMLDiff\DOM::merge — Produce merged DOMDocument
  • XMLDiff\Memory — The XMLDiff\Memory class
    • XMLDiff\Memory::diff — Diff two XML documents
    • XMLDiff\Memory::merge — Produce merged XML document
  • XMLDiff\File — The XMLDiff\File class
    • XMLDiff\File::diff — Diff two XML files
    • XMLDiff\File::merge — Produce merged XML document
wddx_serialize_vars
Giriş
XML İşleme


Giriş

The extension is able to produce diffs of two XML documents and then to apply the difference to the source document. The diff is a XML document containing copy/insert/delete instruction nodes in human readable format. DOMDocument objects, local files and strings in memory can be processed.

XMLDiff
Yapılandırma/Kurulum
XMLDiff


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
Giriş
Gereksinimler
XMLDiff


Gereksinimler

libdiffmark - version 0.10 is bundled with the extension. If diffmark is available from your system packages, its usage is strongly encouraged.

libxml extension

DOM extension

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu » PECL eklentisi PHP ile gelmez.

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/xmldiff.

A DLL for this PECL extension is available under » http://windows.php.net/downloads/pecl/releases/xmldiff/.

Gereksinimler
XMLDiff\Base
Yapılandırma/Kurulum


The XMLDiff\Base class

(PECL xmldiff >= 0.8.0)

Giriş

Base abstract class for all the comparsion classes in the extension.

Sınıf Sözdizimi

XMLDiff\Base {
/* Yöntemler */
public __construct ( string $nsname )
abstract public mixed diff ( mixed $from , mixed $to )
abstract public mixed merge ( mixed $src , mixed $diff )
}

İçindekiler

  • XMLDiff\Base::__construct — Constructor
  • XMLDiff\Base::diff — Produce diff of two XML documents
  • XMLDiff\Base::merge — Produce new XML document based on diff
Kurulum
XMLDiff\Base::__construct
XMLDiff


Constructor

XMLDiff\Base
XMLDiff\Base::diff
XMLDiff\Base
PHP Manual

XMLDiff\Base::__construct

(PECL xmldiff >= 0.8.0)

XMLDiff\Base::__construct — Constructor

Açıklama

public XMLDiff\Base::__construct ( string $nsname )

Base constructor for all the worker classes in the xmldiff extension.

Değiştirgeler

nsname

Custom namespace name for the diff document. The default namespace is http://www.locus.cz/diffmark and that's enough to avoid namespace conflicts. Use this parameter if you want to change it for some reason.

Dönen Değerler

XMLDiff\Base
XMLDiff\Base::diff
XMLDiff\Base


Produce diff of two XML documents

XMLDiff\Base::__construct
XMLDiff\Base::merge
XMLDiff\Base
PHP Manual

XMLDiff\Base::diff

(PECL xmldiff >= 0.8.0)

XMLDiff\Base::diff — Produce diff of two XML documents

Açıklama

abstract public mixed XMLDiff\Base::diff ( mixed $from , mixed $to )

Abstract diff method to be implemented by inheriting classes.

The basic purpose of this method is to produce diff of the two documents. The param order matters and will produce different output.

Değiştirgeler

from

Source XML document.

to

Target XML document.

Dönen Değerler

Implementation dependent.

XMLDiff\Base::__construct
XMLDiff\Base::merge
XMLDiff\Base


Produce new XML document based on diff

XMLDiff\Base::diff
XMLDiff\DOM
XMLDiff\Base
PHP Manual

XMLDiff\Base::merge

(PECL xmldiff >= 0.8.0)

XMLDiff\Base::merge — Produce new XML document based on diff

Açıklama

abstract public mixed XMLDiff\Base::merge ( mixed $src , mixed $diff )

Abstract merge method to be implemented by inheriting classes.

Basically the method purpose is to produce a new XML document based on the diff information.

Değiştirgeler

src

Source XML document.

diff

Document produced by the diff method.

Dönen Değerler

Implementation dependent.

XMLDiff\Base::diff
XMLDiff\DOM
XMLDiff\Base


The XMLDiff\DOM class

(PECL xmldiff >= 0.8.0)

Giriş

Sınıf Sözdizimi

XMLDiff\DOM extends XMLDiff\Base {
/* Yöntemler */
public DOMDocument diff ( DOMDocument $from , DOMDocument $to )
public DOMDocument merge ( DOMDocument $src , DOMDocument $diff )
/* Miras alınan yöntemler */
public XMLDiff\Base::__construct ( string $nsname )
abstract public mixed XMLDiff\Base::diff ( mixed $from , mixed $to )
abstract public mixed XMLDiff\Base::merge ( mixed $src , mixed $diff )
}

İçindekiler

  • XMLDiff\DOM::diff — Diff two DOMDocument objects
  • XMLDiff\DOM::merge — Produce merged DOMDocument
XMLDiff\Base::merge
XMLDiff\DOM::diff
XMLDiff


Diff two DOMDocument objects

XMLDiff\DOM
XMLDiff\DOM::merge
XMLDiff\DOM
PHP Manual

XMLDiff\DOM::diff

(PECL xmldiff >= 0.8.0)

XMLDiff\DOM::diff — Diff two DOMDocument objects

Açıklama

public DOMDocument XMLDiff\DOM::diff ( DOMDocument $from , DOMDocument $to )

Diff two DOMDocument instances and produce the new one containing the diff information.

Değiştirgeler

from

Source DOMDocument object.

to

Target DOMDocument object.

Dönen Değerler

DOMDocument with the diff information or NULL.

XMLDiff\DOM
XMLDiff\DOM::merge
XMLDiff\DOM


Produce merged DOMDocument

XMLDiff\DOM::diff
XMLDiff\Memory
XMLDiff\DOM
PHP Manual

XMLDiff\DOM::merge

(PECL xmldiff >= 0.8.0)

XMLDiff\DOM::merge — Produce merged DOMDocument

Açıklama

public DOMDocument XMLDiff\DOM::merge ( DOMDocument $src , DOMDocument $diff )

Create new DOMDocument based on the diff.

Değiştirgeler

src

Source DOMDocument object.

diff

DOMDocument object containing the diff information.

Dönen Değerler

Merged DOMDocument or NULL.

XMLDiff\DOM::diff
XMLDiff\Memory
XMLDiff\DOM


The XMLDiff\Memory class

(PECL xmldiff >= 0.8.0)

Giriş

Sınıf Sözdizimi

XMLDiff\Memory extends XMLDiff\Base {
/* Yöntemler */
public string diff ( string $from , string $to )
public string merge ( string $src , string $diff )
/* Miras alınan yöntemler */
public XMLDiff\Base::__construct ( string $nsname )
abstract public mixed XMLDiff\Base::diff ( mixed $from , mixed $to )
abstract public mixed XMLDiff\Base::merge ( mixed $src , mixed $diff )
}

İçindekiler

  • XMLDiff\Memory::diff — Diff two XML documents
  • XMLDiff\Memory::merge — Produce merged XML document
XMLDiff\DOM::merge
XMLDiff\Memory::diff
XMLDiff


Diff two XML documents

XMLDiff\Memory
XMLDiff\Memory::merge
XMLDiff\Memory
PHP Manual

XMLDiff\Memory::diff

(PECL xmldiff >= 0.8.0)

XMLDiff\Memory::diff — Diff two XML documents

Açıklama

public string XMLDiff\Memory::diff ( string $from , string $to )

Diff two strings containing XML documents and produce the diff information.

Değiştirgeler

from

Source XML document.

to

Target XML document.

Dönen Değerler

String with the XML document containing the diff information or NULL.

XMLDiff\Memory
XMLDiff\Memory::merge
XMLDiff\Memory


Produce merged XML document

XMLDiff\Memory::diff
XMLDiff\File
XMLDiff\Memory
PHP Manual

XMLDiff\Memory::merge

(PECL xmldiff >= 0.8.0)

XMLDiff\Memory::merge — Produce merged XML document

Açıklama

public string XMLDiff\Memory::merge ( string $src , string $diff )

Create new XML document based on diffs and source document.

Değiştirgeler

src

Source XML document.

diff

XML document containing diff information.

Dönen Değerler

String with the new XML document or NULL.

XMLDiff\Memory::diff
XMLDiff\File
XMLDiff\Memory


The XMLDiff\File class

(PECL xmldiff >= 0.8.0)

Giriş

Sınıf Sözdizimi

XMLDiff\File extends XMLDiff\Base {
/* Yöntemler */
public string diff ( string $from , string $to )
public string merge ( string $src , string $diff )
/* Miras alınan yöntemler */
public XMLDiff\Base::__construct ( string $nsname )
abstract public mixed XMLDiff\Base::diff ( mixed $from , mixed $to )
abstract public mixed XMLDiff\Base::merge ( mixed $src , mixed $diff )
}

İçindekiler

  • XMLDiff\File::diff — Diff two XML files
  • XMLDiff\File::merge — Produce merged XML document
XMLDiff\Memory::merge
XMLDiff\File::diff
XMLDiff


Diff two XML files

XMLDiff\File
XMLDiff\File::merge
XMLDiff\File
PHP Manual

XMLDiff\File::diff

(PECL xmldiff >= 0.8.0)

XMLDiff\File::diff — Diff two XML files

Açıklama

public string XMLDiff\File::diff ( string $from , string $to )

Diff two local XML files and produce string with the diff information.

Değiştirgeler

from

Path to the source document.

to

Path to the target document.

Dönen Değerler

String with the XML document containing the diff information or NULL.

XMLDiff\File
XMLDiff\File::merge
XMLDiff\File


Produce merged XML document

XMLDiff\File::diff
XML Çözümleyici
XMLDiff\File
PHP Manual

XMLDiff\File::merge

(PECL xmldiff >= 0.8.0)

XMLDiff\File::merge — Produce merged XML document

Açıklama

public string XMLDiff\File::merge ( string $src , string $diff )

Create new XML document based on diffs and source document.

Değiştirgeler

src

Path to the source XML document.

diff

Path to the XML document with the diff information.

Dönen Değerler

String with the new XML document or NULL.

XMLDiff\File::diff
XML Çözümleyici
XMLDiff\File


XML Çözümleyici

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Geriçağırım İşlevleri
  • Büyük Harfe Dönüşüm
  • Hata Kodları
  • Karakter Kodlaması
  • Örnekler
    • XML Eleman Yapısı Örneği
    • XML Etiket Eşleme Örneği
    • XML Harici Öğe Örneği
  • XML Çözümleyici İşlevleri
    • utf8_decode — ISO-8859-1 karakterlerinin UTF-8 gösterimlerini ISO-8859-1 gösterimlerine dönüştürür
    • utf8_encode — Bir ISO-8859-1 dizgeyi UTF-8'e dönüştürür
    • xml_error_string — XML çözümleyici hata iletisini döndürür
    • xml_get_current_byte_index — XML çözümleyicinin geçerli bayt indisini döndürür
    • xml_get_current_column_number — XML çözümleyicide hatanın oluştuğu satırdaki sütun numarasını döndürür
    • xml_get_current_line_number — XML çözümleyicide hatanın oluştuğu satırı döndürür
    • xml_get_error_code — XML çözümleyici hata kodunu döndürür
    • xml_parse_into_struct — XML veriyi çözümleyip sonucu bir dizi içinde döndürür
    • xml_parse — Bir XML belgeyi çözümler
    • xml_parser_create_ns — İsim alanı destekli bir XML çözümleyici oluşturur
    • xml_parser_create — Bir XML çözümleyici oluşturur
    • xml_parser_free — XML çözümleyiciyi serbest bırakır
    • xml_parser_get_option — XML çözümleyici seçeneklerini döndürür
    • xml_parser_set_option — XML çözümleyici seçeneklerini belirler
    • xml_set_character_data_handler — Karakter verisi eylemcisini belirler
    • xml_set_default_handler — Öntanımlı eylemciyi belirler
    • xml_set_element_handler — Açılış ve kapanış etiketi eylemcilerini belirler
    • xml_set_end_namespace_decl_handler — İsim alanı bildirimi sonlandırma eylemcisini belirler
    • xml_set_external_entity_ref_handler — Harici öğe gönderimi eylemcisini belirler
    • xml_set_notation_decl_handler — Gösterim bildirimi eylemcisini belirler
    • xml_set_object — XML çözümleyici, nesne içinde kullanılır
    • xml_set_processing_instruction_handler — İşlem komutu (PI) eylemcisini belirler
    • xml_set_start_namespace_decl_handler — İsim alanı bildirimi başlatma eylemcisini belirler
    • xml_set_unparsed_entity_decl_handler — Çözümlenmeyen öğe bildirimi eylemcisini belirler
XMLDiff\File::merge
Giriş
XML İşleme


Giriş

XML, Genişletilebilir İmlenim Dili, XML belgeleri denen veri nesneleri sınıfını ve kısmen de bunlar üzerinde işlem yapacak bilgisayar programlarının davranışını açıklar. W3C tarafından bir standart olarak yayınlanmıştır. » http://www.w3.org/XML/ adresinde XML ve ilgili teknolojiler hakkında bilgi edinebilirsiniz. Standardın » Türkçe çevirisi mevcuttur.

Bu eklenti James Clark'ın expat kütüphanesini gerektirir. Bu işlevlerle bir XML belgeyi çözümleyebilirsiniz ancak belgenin geçerliliğini doğrulatamazsınız. Eklenti, üç karakter kodlamasını destekler: US-ASCII, ISO-8859-1 ve UTF-8. UTF-16 desteklenmemektedir.

Bu eklentiyle XML çözümleyiciler oluşturabilir ve farklı XML olayları için eylemciler tanımlayabilirsiniz. Ayrıca, her XML çözümleyicinin ayarlanabilen bir kaç değiştirgesi de vardır.

XML Çözümleyici
Yapılandırma/Kurulum
XML Çözümleyici


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
XML Çözümleyici


Gereksinimler

Bu eklenti öntanımlı olarak expat uyumlu bir katman kullanır. Ayrıca, » http://www.jclark.com/xml/expat.html adresinde bulunan expat da kullanılabilir. expat ile gelen Makefile, öntanımlı olarak kütüphaneyi derlemez. Kütüphanenin derlenmesi için Makefile dosyanızda şu kuralı kullanın:

libexpat.a: $(OBJS)
    ar -rc $@ $(OBJS)
    ranlib $@
expat kaynak RPM paketi » http://sourceforge.net/projects/expat/ adresinden edinilebilir.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Kaynak paketiyle birlikte gelen expat kütüphanesi kullanılarak bu eklenti öntanımlı olarak etkin kılınmıştır. XML desteğini PHP'yi derlerken --disable-xml seçeneğini kullanarak iptal edebilirsiniz. PHP'yi Apache 1.3.9 ve sonrası için bir modül olarak derliyorsanız, PHP öntanımlı olarak Apache'nin kullandığı expat kütüphanesini kullanır. PHP ile gelen kütüphaneyi kullanmak istemiyorsanız bunu derleme sırasında --with-expat-dir=DiZiN seçeneğiyle belirtebilirsiniz. Burada DiZiN expat kütüphanesinin kurulu olduğu temel dizindir.

PHP'nin Windows sürümünde bu eklenti yerleşik olarak gelmektedir. Bu işlevleri Windows'ta kullanmak için herhangi bir eklenti kurmanıza gerek yoktur.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Özkaynak Türleri

xml_parser_create() ve xml_parser_create_ns() işlevleri tarafından döndürülen xml özkaynağı, bu eklentinin işlevleri tarafından bir XML çözümleyici nesnesinin tanıtıcısı olarak kullanılır.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

XML_ERROR_NONE (integer)
XML_ERROR_NO_MEMORY (integer)
XML_ERROR_SYNTAX (integer)
XML_ERROR_NO_ELEMENTS (integer)
XML_ERROR_INVALID_TOKEN (integer)
XML_ERROR_UNCLOSED_TOKEN (integer)
XML_ERROR_PARTIAL_CHAR (integer)
XML_ERROR_TAG_MISMATCH (integer)
XML_ERROR_DUPLICATE_ATTRIBUTE (integer)
XML_ERROR_JUNK_AFTER_DOC_ELEMENT (integer)
XML_ERROR_PARAM_ENTITY_REF (integer)
XML_ERROR_UNDEFINED_ENTITY (integer)
XML_ERROR_RECURSIVE_ENTITY_REF (integer)
XML_ERROR_ASYNC_ENTITY (integer)
XML_ERROR_BAD_CHAR_REF (integer)
XML_ERROR_BINARY_ENTITY_REF (integer)
XML_ERROR_ATTRIBUTE_EXTERNAL_ENTITY_REF (integer)
XML_ERROR_MISPLACED_XML_PI (integer)
XML_ERROR_UNKNOWN_ENCODING (integer)
XML_ERROR_INCORRECT_ENCODING (integer)
XML_ERROR_UNCLOSED_CDATA_SECTION (integer)
XML_ERROR_EXTERNAL_ENTITY_HANDLING (integer)
XML_OPTION_CASE_FOLDING (integer)
XML_OPTION_TARGET_ENCODING (integer)
XML_OPTION_SKIP_TAGSTART (integer)
XML_OPTION_SKIP_WHITE (integer)
XML_SAX_IMPL (string)
Yöntemin SAX gerçeklenimi. libxml veya expat olabilir.
Özkaynak Türleri
Geriçağırım İşlevleri
XML Çözümleyici


Geriçağırım İşlevleri

XML geriçağırım işlevlerinin tanımlayan işlevler:

Desteklenen XML eylemcileri
Eylemciyi belirleyen PHP işlevi | Olay açıklaması
xml_set_element_handler() | XML çözümleyicinin her başlangıç veya bitiş etiketine rastlayışında oluşan eleman olayları. Başlangıç ve bitiş etiketlerinin eylemcileri ayrı ayrıdır.
xml_set_character_data_handler() | Kabaca, etiketler arasındaki boşluklar dahil, XML belgelerin imlenim dışında kalan tüm içeriği karakter verisini oluşturur. XML çözümleyicinin boşluk eklemeye ve kaldırmaya karar veremeyeceğine dikkat ediniz. Boşlukların önem derecelerine karar vermek uygulamaya (yani, size) bırakılmıştır.
xml_set_processing_instruction_handler() | PHP ile yazılım geliştirenlerin işlem komutları (PI - processing instruction) hakkında bilgi sahibi oldukları varsayılır. <?php ?> bir işlem komutu olup php dizgesine PI hedefi adı verilir. "XML" ile başlayan PI hedefleri hariç, tüm PI hedefleri uygulamaya özgü ele alınır.
xml_set_default_handler() | Diğer eylemciler tarafından ele alınmayan herşey öntanımlı eylemci tarafından ele alınır. XML ve belge türü bildirimleri gibi şeyleri öntanımlı eylemcilere bırakabilirsiniz.
xml_set_unparsed_entity_decl_handler() | Çözümlenmeyen öğe bildirimleri (NDATA) için bu eylemci çağrılır.
xml_set_notation_decl_handler() | Gösterim bildirimleri için bu eylemci çağrılır.
xml_set_external_entity_ref_handler() | XML çözümleyici, harici olarak çözümlenecek bir genel öğeye bir gönderim bulduğunda bu eylemci çağrılır. Bu örneğin, bir dosyaya veya bir URL'ye bir atıf olabilir. Gerçekleme örneği olarak harici öğe örneğine bakınız.

Öntanımlı Sabitler
Büyük Harfe Dönüşüm
XML Çözümleyici


Büyük Harfe Dönüşüm

Elemanları işlemekte kullanılan işlevler eleman isimlerini büyük harfe dönüştürerek ele alabilir. Büyük harfe dönüştürme işlemi eleman isminde bulunan küçük harflerin yerine büyük harfli eşdeğerlerini koymaktan ibarettir. Ancak, XML dilinin harf büyüklüğüne duyarlı bir dil olduğunu unutmayın.

Öntanımlı olarak, bu işlevlere aktarılan eleman isimleri tamamen büyük harfe dönüşürülür. Bu davranış xml_parser_get_option() işleviyle sorgulanıp xml_parser_set_option() işleviyle değiştirilebilir. (Ç.N.: Türkçe yerelinde i ve ı harfleriyle ilgili dönüşümlerde dikkatli olun. Bu dönüşümün yapılmasına izin vermemek daha iyi olabilir.)

Geriçağırım İşlevleri
Hata Kodları
XML Çözümleyici


Hata Kodları

Aşağıdaki sabitler XML hata kodları olarak tanımlanmıştır. (xml_parse() tarafından döndürülürler):

  • XML_ERROR_NONE
  • XML_ERROR_NO_MEMORY
  • XML_ERROR_SYNTAX
  • XML_ERROR_NO_ELEMENTS
  • XML_ERROR_INVALID_TOKEN
  • XML_ERROR_UNCLOSED_TOKEN
  • XML_ERROR_PARTIAL_CHAR
  • XML_ERROR_TAG_MISMATCH
  • XML_ERROR_DUPLICATE_ATTRIBUTE
  • XML_ERROR_JUNK_AFTER_DOC_ELEMENT
  • XML_ERROR_PARAM_ENTITY_REF
  • XML_ERROR_UNDEFINED_ENTITY
  • XML_ERROR_RECURSIVE_ENTITY_REF
  • XML_ERROR_ASYNC_ENTITY
  • XML_ERROR_BAD_CHAR_REF
  • XML_ERROR_BINARY_ENTITY_REF
  • XML_ERROR_ATTRIBUTE_EXTERNAL_ENTITY_REF
  • XML_ERROR_MISPLACED_XML_PI
  • XML_ERROR_UNKNOWN_ENCODING
  • XML_ERROR_INCORRECT_ENCODING
  • XML_ERROR_UNCLOSED_CDATA_SECTION
  • XML_ERROR_EXTERNAL_ENTITY_HANDLING

Büyük Harfe Dönüşüm
Karakter Kodlaması
XML Çözümleyici


Karakter Kodlaması

PHP'nin XML eklentisi karakter kodlamaları arasında dönüşüm için » Evrenkod karakterlerini kullanır. İki tür karakter kodlaması vardır: kaynak kodlaması ve hedef kodlaması. PHP'nin dahili belge gösterimi daima UTF-8 ile kodlanır.

Kaynak kodlaması XML belge çözümlenirken yapılır. Kaynak kodlaması XML çözümleyici oluşturulurken belirtilebilir (bu kodlama XML çözümleyici işleme başladıktan sonra bir daha değiştirilemez). Desteklenen kaynak kodlamaları ISO-8859-1, US-ASCII ve UTF-8'dir. İlk ikisinde karakterler tek baytlıktır. UTF-8 karakterleri bir bayttan dört bayta kadar farklı sayıda bayttan oluşabilir. PHP'de kullanılan öntanımlı kaynak karakter kodlaması ISO-8859-1'dir.

Kaynak kodlaması, PHP veriyi XML eylemci işlevlerine aktarırken kullanılır. Bir XML çözümleyici oluşturulduğunda hedef kodlaması kaynak kodlaması ile aynı yapılır, fakat istenirse her an değiştirilebilir. Hedef kodlaması karakter verisinin yanında etiket isimleri ile işlem komutlarının hedeflerini de etkiler.

Eğer XML çözümleyici, kaynak karakter kodlamasında gösterimi mümkün olmayan karakterlere rastlarsa hata verir.

Eğer PHP, çözümlenen XML belgede seçilen hedef kodlamasıyla gösterilemeyen karakterler bulunduğunu saptarsa sorunlu karakterler "indirgenir". Şimdilik bunu gerçeklemek için bu karaterlerin yerine soru imleri konmaktadır.

Hata Kodları
Örnekler
XML Çözümleyici


Örnekler

İçindekiler

  • XML Eleman Yapısı Örneği
  • XML Etiket Eşleme Örneği
  • XML Harici Öğe Örneği
Karakter Kodlaması
XML Eleman Yapısı Örneği
XML Çözümleyici


XML Eleman Yapısı Örneği

İlk örnekte, bir belgedeki girintili başlangıç elemanlarının yapısı gösterilmiştir.

Örnek 1 - XML Eleman yapısının gösterimi

<?php
$file = "data.xml";
$depth = array();

function startElement($parser, $name, $attrs)
{
    global $depth;
    for ($i = 0; $i < $depth[$parser]; $i++) {
        echo "  ";
    }
    echo "$name\n";
    $depth[$parser]++;
}

function endElement($parser, $name)
{
    global $depth;
    $depth[$parser]--;
}

$xml_parser = xml_parser_create();
xml_set_element_handler($xml_parser, "startElement", "endElement");
if (!($fp = fopen($file, "r"))) {
    die("XML belge açılamadı");
}

while ($data = fread($fp, 4096)) {
    if (!xml_parse($xml_parser, $data, feof($fp))) {
        die(sprintf("XML hatası: %d. satırda %s",
                    xml_get_current_line_number($xml_parser)),
                    xml_error_string(xml_get_error_code($xml_parser)));
    }
}
xml_parser_free($xml_parser);
?>

Örnekler
XML Etiket Eşleme Örneği
Örnekler


XML Etiket Eşleme Örneği

Örnek 1 - XML etiketlerini HTML etiketlerine eşleme

Bu örnekte bir XML belgedeki etiketler doğrudan HTML etiketlerine eşlenmektedir. $map_array içinde bulunmayan etiketler yok sayılmaktadır. Elbette, bu örnek belli bir XML belgeye özgüdür.

<?php
$file = "data.xml";
$map_array = array(
    "BOLD"     => "B",
    "EMPHASIS" => "I",
    "LITERAL"  => "TT"
);

function startElement($parser, $name, $attrs)
{
    global $map_array;
    if (isset($map_array[$name])) {
        echo "<$map_array[$name]>";
    }
}

function endElement($parser, $name)
{
    global $map_array;
    if (isset($map_array[$name])) {
        echo "</$map_array[$name]>";
    }
}

function characterData($parser, $data)
{
    echo $data;
}

$xml_parser = xml_parser_create();
// Etiketin $map_array içinde bulunduğundan emin olmak için
// büyük harfe dönüşüm uyguluyoruz
xml_parser_set_option($xml_parser, XML_OPTION_CASE_FOLDING, true);
xml_set_element_handler($xml_parser, "startElement", "endElement");
xml_set_character_data_handler($xml_parser, "characterData");
if (!($fp = fopen($file, "r"))) {
    die("XML belge açılamadı");
}

while ($data = fread($fp, 4096)) {
    if (!xml_parse($xml_parser, $data, feof($fp))) {
        die(sprintf("XML hatası: %d. satırda %s",
                    xml_get_current_line_number($xml_parser)),
                    xml_error_string(xml_get_error_code($xml_parser)));
    }
}
xml_parser_free($xml_parser);
?>

XML Eleman Yapısı Örneği
XML Harici Öğe Örneği
Örnekler


XML Harici Öğe Örneği

Bu örnekte XML kodu renklendirilmektedir. Bir harici öğe gönderimi eylemcisinin diğer belgeleri içermek ve çözümlemek amacıyla nasıl kullanıldığı gösterilmiştir. Bunun yanında, PI hedeflerinin ve bunları içeren kodun nasıl ele alınacağı da gösterilmiştir.

Bu örnek için kullanılan XML belgeler:

Örnek 1 - Harici Öğe Örneği

<?php
$file = "xmltest.xml";

function trustedFile($file)
{
    // sadece sahibi olduğumuz yerel dosyalara güveniyoruz
    if (!preg_match("@^([a-z]+)\:\/\/@i", $file)
        && fileowner($file) == getmyuid()) {
            return true;
    }
    return false;
}

function startElement($parser, $name, $attribs)
{
    echo "&lt;<font color=\"#0000cc\">$name</font>";
    if (count($attribs)) {
        foreach ($attribs as $k => $v) {
            echo " <font color=\"#009900\">$k</font>=\"<font
                   color=\"#990000\">$v</font>\"";
        }
    }
    echo "&gt;";
}

function endElement($parser, $name)
{
    echo "&lt;/<font color=\"#0000cc\">$name</font>&gt;";
}

function characterData($parser, $data)
{
    echo "<b>$data</b>";
}

function PIHandler($parser, $target, $data)
{
    switch (strtolower($target)) {
        case "php":
            global $parser_file;
            // Çözümlenen belge "güvenilir" ise içerdiği PHP kodu da
            // güvenilirdir diyebiliriz. Değilse, kodu göstermekle
            // yetineceğiz.
            if (trustedFile($parser_file[$parser])) {
                eval($data);
            } else {
                printf("Güvenilmez PHP kodu: <i>%s</i>",
                        htmlspecialchars($data));
            }
            break;
    }
}

function defaultHandler($parser, $data)
{
    if (substr($data, 0, 1) == "&" && substr($data, -1, 1) == ";") {
        printf('<font color="#aa00aa">%s</font>',
                htmlspecialchars($data));
    } else {
        printf('<font size="-1">%s</font>',
                htmlspecialchars($data));
    }
}

function externalEntityRefHandler($parser, $openEntityNames, $base, $systemId,
                                  $publicId) {
    if ($systemId) {
        if (!list($parser, $fp) = new_xml_parser($systemId)) {
            printf("%s dosyasındaki %s öğesi açılamadı\n", $systemId,
                   $openEntityNames);
            return false;
        }
        while ($data = fread($fp, 4096)) {
            if (!xml_parse($parser, $data, feof($fp))) {
                printf("XML hatası: %s öğesi çözümlenirken %d. satırda %s\n",
                       $openEntityNames,
                       xml_get_current_line_number($parser),
                       xml_error_string(xml_get_error_code($parser));
                xml_parser_free($parser);
                return false;
            }
        }
        xml_parser_free($parser);
        return true;
    }
    return false;
}

function new_xml_parser($file)
{
    global $parser_file;

    $xml_parser = xml_parser_create();
    xml_parser_set_option($xml_parser, XML_OPTION_CASE_FOLDING, 1);
    xml_set_element_handler($xml_parser, "startElement", "endElement");
    xml_set_character_data_handler($xml_parser, "characterData");
    xml_set_processing_instruction_handler($xml_parser, "PIHandler");
    xml_set_default_handler($xml_parser, "defaultHandler");
    xml_set_external_entity_ref_handler($xml_parser,
              "externalEntityRefHandler");

    if (!($fp = @fopen($file, "r"))) {
        return false;
    }
    if (!is_array($parser_file)) {
        settype($parser_file, "array");
    }
    $parser_file[$xml_parser] = $file;
    return array($xml_parser, $fp);
}

if (!(list($xml_parser, $fp) = new_xml_parser($file))) {
    die("XML girdi açılamadı");
}

echo "<pre>";
while ($data = fread($fp, 4096)) {
    if (!xml_parse($xml_parser, $data, feof($fp))) {
        die(sprintf("XML hatası: %d. satırda %s",
                    xml_get_current_line_number($xml_parser)),
                    xml_error_string(xml_get_error_code($xml_parser)));
    }
}
echo "</pre>";
echo "Çözümleme bitti\n";
xml_parser_free($xml_parser);

?>

Örnek 2 xmltest.xml

<?xml version='1.0'?>
<!DOCTYPE chapter SYSTEM "/sadece/bir/test.dtd" [
<!ENTITY plainEntity "DNM öğesi">
<!ENTITY systemEntity SYSTEM "xmltest2.xml">
]>
<chapter>
 <TITLE>&plainEntity; başlığı</TITLE>
 <para>
  <informaltable>
   <tgroup cols="3">
    <tbody>
     <row><entry>a1</entry><entry morerows="1">b1</entry><entry>c1</entry></row>
     <row><entry>a2</entry><entry>c2</entry></row>
     <row><entry>a3</entry><entry>b3</entry><entry>c3</entry></row>
    </tbody>
   </tgroup>
  </informaltable>
 </para>
 &systemEntity;
 <section id="about">
  <title>Belge hakkında/title>
  <para>
   <!-- Bu bir açıklama -->
   <?php echo 'Merhaba!  PHP sürümü: ' . phpversion(); ?>
  </para>
 </section>
</chapter>

xmltest.xml dosyasında içerilen dosya:

Örnek 3 xmltest2.xml

<?xml version="1.0"?>
<!DOCTYPE foo [
<!ENTITY testEnt "deneme öğesi">
]>
<foo>
   <element attrib="value"/>
   &testEnt;
   <?php echo "Burada çalıştırılacak bir PHP kodu var."; ?>
</foo>

XML Etiket Eşleme Örneği
XML Çözümleyici İşlevleri
Örnekler


XML Çözümleyici İşlevleri

İçindekiler

  • utf8_decode — ISO-8859-1 karakterlerinin UTF-8 gösterimlerini ISO-8859-1 gösterimlerine dönüştürür
  • utf8_encode — Bir ISO-8859-1 dizgeyi UTF-8'e dönüştürür
  • xml_error_string — XML çözümleyici hata iletisini döndürür
  • xml_get_current_byte_index — XML çözümleyicinin geçerli bayt indisini döndürür
  • xml_get_current_column_number — XML çözümleyicide hatanın oluştuğu satırdaki sütun numarasını döndürür
  • xml_get_current_line_number — XML çözümleyicide hatanın oluştuğu satırı döndürür
  • xml_get_error_code — XML çözümleyici hata kodunu döndürür
  • xml_parse_into_struct — XML veriyi çözümleyip sonucu bir dizi içinde döndürür
  • xml_parse — Bir XML belgeyi çözümler
  • xml_parser_create_ns — İsim alanı destekli bir XML çözümleyici oluşturur
  • xml_parser_create — Bir XML çözümleyici oluşturur
  • xml_parser_free — XML çözümleyiciyi serbest bırakır
  • xml_parser_get_option — XML çözümleyici seçeneklerini döndürür
  • xml_parser_set_option — XML çözümleyici seçeneklerini belirler
  • xml_set_character_data_handler — Karakter verisi eylemcisini belirler
  • xml_set_default_handler — Öntanımlı eylemciyi belirler
  • xml_set_element_handler — Açılış ve kapanış etiketi eylemcilerini belirler
  • xml_set_end_namespace_decl_handler — İsim alanı bildirimi sonlandırma eylemcisini belirler
  • xml_set_external_entity_ref_handler — Harici öğe gönderimi eylemcisini belirler
  • xml_set_notation_decl_handler — Gösterim bildirimi eylemcisini belirler
  • xml_set_object — XML çözümleyici, nesne içinde kullanılır
  • xml_set_processing_instruction_handler — İşlem komutu (PI) eylemcisini belirler
  • xml_set_start_namespace_decl_handler — İsim alanı bildirimi başlatma eylemcisini belirler
  • xml_set_unparsed_entity_decl_handler — Çözümlenmeyen öğe bildirimi eylemcisini belirler
XML Harici Öğe Örneği
utf8_decode
XML Çözümleyici


ISO-8859-1 karakterlerinin UTF-8 gösterimlerini ISO-8859-1 gösterimlerine dönüştürür

XML Çözümleyici İşlevleri
utf8_encode
XML Çözümleyici İşlevleri
PHP Manual

utf8_decode

(PHP 4, PHP 5, PHP 7)

utf8_decode — ISO-8859-1 karakterlerinin UTF-8 gösterimlerini ISO-8859-1 gösterimlerine dönüştürür

Açıklama

string utf8_decode ( string $veri )

Belirtilen data dizgesindeki ISO-8859-1 karakterlerinin UTF-8 gösterimlerini ISO-8859-1 gösterimlerine dönüştürür.

Değiştirgeler

veri

UTF-8 ile kodlanmış bir dizge.

Dönen Değerler

Belirtilen veri dizgesinin ISO-8859-1 gösterimini döndürür.

Ayrıca Bakınız

  • utf8_encode() - Bir ISO-8859-1 dizgeyi UTF-8'e dönüştürür

XML Çözümleyici İşlevleri
utf8_encode
XML Çözümleyici İşlevleri


Bir ISO-8859-1 dizgeyi UTF-8'e dönüştürür

utf8_decode
xml_error_string
XML Çözümleyici İşlevleri
PHP Manual

utf8_encode

(PHP 4, PHP 5, PHP 7)

utf8_encode — Bir ISO-8859-1 dizgeyi UTF-8'e dönüştürür

Açıklama

string utf8_encode ( string $veri )

Belirtilen veri dizgesinin karakter kodlamasını UTF-8'e dönüştürüp üretilen dizgeyi döndürür. UTF-8, Evrenkod tarafından kullanılan, geniş karakterleri bayt dizilimleri halinde kodlamanın bir yoludur. UTF-8, ASCII karakterleri de kapsar ve metnin tamamen ASCII karakterlerden oluşması halinde bunlar üzerinde normal dizge karşılaştırma ve sıralama işlevleri kullanılabilir. PHP, UTF-8 karakterleri 4 baytlık genişliğe kadar kodlayabilir:

UTF-8 kodlama
Bayt sayısı | Bit sayısı | Gösterim
1 | 7 | 0bbbbbbb
2 | 11 | 110bbbbb 10bbbbbb
3 | 16 | 1110bbbb 10bbbbbb 10bbbbbb
4 | 21 | 11110bbb 10bbbbbb 10bbbbbb 10bbbbbb
Buradaki her b, karakter verisini saklamakta kullanılan bir bite karşılıktır.

Değiştirgeler

veri

ISO-8859-1 ile kodlanmış bir dizge.

Dönen Değerler

Belirtilen veri dizgesinin UTF-8 gösterimini döndürür.

utf8_decode
xml_error_string
XML Çözümleyici İşlevleri


XML çözümleyici hata iletisini döndürür

utf8_encode
xml_get_current_byte_index
XML Çözümleyici İşlevleri
PHP Manual

xml_error_string

(PHP 4, PHP 5, PHP 7)

xml_error_string — XML çözümleyici hata iletisini döndürür

Açıklama

string xml_error_string ( int $hatanum )

Belirtilen hatanum ile ilgili hatanın açıklamasını döndürür.

Değiştirgeler

hatanum

xml_get_error_code() işlevinden dönen hata kodu.

Dönen Değerler

Belirtilen hatanum ile ilgili bir açıklama yoksa FALSE, aksi takdirde açıklama dizgesini döndürür.

Ayrıca Bakınız

  • xml_get_error_code() - XML çözümleyici hata kodunu döndürür

utf8_encode
xml_get_current_byte_index
XML Çözümleyici İşlevleri


XML çözümleyicinin geçerli bayt indisini döndürür

xml_error_string
xml_get_current_column_number
XML Çözümleyici İşlevleri
PHP Manual

xml_get_current_byte_index

(PHP 4, PHP 5, PHP 7)

xml_get_current_byte_index — XML çözümleyicinin geçerli bayt indisini döndürür

Açıklama

int xml_get_current_byte_index ( resource $çözümleyici )

Belirtilen XML çözümleyicinin geçerli bayt indisini döndürür.

Değiştirgeler

çözümleyici

xml_parser_create() ve xml_parser_create_ns() işlevleri tarafından döndürülen bir XML özkaynağı.

Dönen Değerler

çözümleyici olarak geçerli bir çözümleyici belirtilmemişse FALSE, aksi takdirde çözümleyici veri tamponundaki geçerli baytın indisini döndürür (ilk baytın indisi 0'dır).

Notlar

Uyarı

İşlev, karakter kodlamasından bağımsız olarak metnin UTF-8 kodlamasına göre bayt indisini döndürür.

Ayrıca Bakınız

  • xml_get_current_column_number() - XML çözümleyicide hatanın oluştuğu satırdaki sütun numarasını döndürür
  • xml_get_current_line_number() - XML çözümleyicide hatanın oluştuğu satırı döndürür

xml_error_string
xml_get_current_column_number
XML Çözümleyici İşlevleri


XML çözümleyicide hatanın oluştuğu satırdaki sütun numarasını döndürür

xml_get_current_byte_index
xml_get_current_line_number
XML Çözümleyici İşlevleri
PHP Manual

xml_get_current_column_number

(PHP 4, PHP 5, PHP 7)

xml_get_current_column_number — XML çözümleyicide hatanın oluştuğu satırdaki sütun numarasını döndürür

Açıklama

int xml_get_current_column_number ( resource $parser )

Belirtilen XML çözümleyicinin veri tamponunda hatanın oluştuğu satırdaki sütun numarasını döndürür.

Değiştirgeler

çözümleyici

xml_parser_create() ve xml_parser_create_ns() işlevleri tarafından döndürülen bir XML özkaynağı.

Dönen Değerler

çözümleyici olarak geçerli bir çözümleyici belirtilmemişse FALSE, aksi takdirde çözümleyici veri tamponunda hatanın oluştuğu (xml_get_current_line_number() ile döndürülen) satırdaki hatalı yerin sütun numarasını döndürür.

Ayrıca Bakınız

  • xml_get_current_byte_index() - XML çözümleyicinin geçerli bayt indisini döndürür
  • xml_get_current_line_number() - XML çözümleyicide hatanın oluştuğu satırı döndürür

xml_get_current_byte_index
xml_get_current_line_number
XML Çözümleyici İşlevleri


XML çözümleyicide hatanın oluştuğu satırı döndürür

xml_get_current_column_number
xml_get_error_code
XML Çözümleyici İşlevleri
PHP Manual

xml_get_current_line_number

(PHP 4, PHP 5, PHP 7)

xml_get_current_line_number — XML çözümleyicide hatanın oluştuğu satırı döndürür

Açıklama

int xml_get_current_line_number ( resource $parser )

Belirtilen XML çözümleyicinin veri tamponunda hatanın oluştuğu satırın numarasını döndürür.

Değiştirgeler

çözümleyici

xml_parser_create() ve xml_parser_create_ns() işlevleri tarafından döndürülen bir XML özkaynağı.

Dönen Değerler

çözümleyici olarak geçerli bir çözümleyici belirtilmemişse FALSE, aksi takdirde çözümleyici veri tamponunda hatanın oluştuğu satırın numarasını döndürür.

Ayrıca Bakınız

  • xml_get_current_column_number() - XML çözümleyicide hatanın oluştuğu satırdaki sütun numarasını döndürür
  • xml_get_current_byte_index() - XML çözümleyicinin geçerli bayt indisini döndürür

xml_get_current_column_number
xml_get_error_code
XML Çözümleyici İşlevleri


XML çözümleyici hata kodunu döndürür

xml_get_current_line_number
xml_parse_into_struct
XML Çözümleyici İşlevleri
PHP Manual

xml_get_error_code

(PHP 4, PHP 5, PHP 7)

xml_get_error_code — XML çözümleyici hata kodunu döndürür

Açıklama

int xml_get_error_code ( resource $çözümleyici )

XML çözümleyici hata kodunu döndürür.

Değiştirgeler

çözümleyici

xml_parser_create() ve xml_parser_create_ns() işlevleri tarafından döndürülen bir XML özkaynağı.

Dönen Değerler

çözümleyici olarak geçerli bir çözümleyici belirtilmemişse FALSE, aksi takdirde Hata Kodları sayfasında listelenen hata kodlarından biri döner.

Ayrıca Bakınız

  • xml_error_string() - XML çözümleyici hata iletisini döndürür

xml_get_current_line_number
xml_parse_into_struct
XML Çözümleyici İşlevleri


XML veriyi çözümleyip sonucu bir dizi içinde döndürür

xml_get_error_code
xml_parse
XML Çözümleyici İşlevleri
PHP Manual

xml_parse_into_struct

(PHP 4, PHP 5, PHP 7)

xml_parse_into_struct — XML veriyi çözümleyip sonucu bir dizi içinde döndürür

Açıklama

int xml_parse_into_struct ( resource $çözümleyici , string $veri , array &$değerler [, array &$indis ] )

Bu işlev bir XML belgeyi iki diziye çözümler. indis dizisi, değerler dizisindeki değerlerin konumlarına birer gösterici içerir. Bu dizilerin işleve gönderimli aktarılmaları gerekir.

Değiştirgeler

çözümleyici

xml_parser_create() ve xml_parser_create_ns() işlevleri tarafından döndürülen bir XML özkaynağı.

veri

değerler

indis

Dönen Değerler

Başarısızlık durumunda 0, başarı durumunda 1 döner. Bu, FALSE ve TRUE olarak ele alınmamalıdır. Dönen değeri === işleci ile karşılaştırın.

Örnekler

Aşağıdaki örnekte dönen dizilerin iç yapısı gösterilmiştir. Basit olarak, para etiketi içine note etiketini gömüp, bunu çözümledikten sonra üretilen dizileri dökümlüyoruz.

Örnek 1 - xml_parse_into_struct() örneği

<?php
$simple = "<para><note>basit örnek</note></para>";
$p = xml_parser_create();
xml_parse_into_struct($p, $simple, $vals, $index);
xml_parser_free($p);
echo "İndis dizisi\n";
print_r($index);
echo "\nDeğerler dizisi\n";
print_r($vals);
?>

Çıktı şöyle olur:

İndis dizisi
Array
(
    [PARA] => Array
        (
            [0] => 0
            [1] => 2
        )

    [NOTE] => Array
        (
            [0] => 1
        )

)

Değerler dizisi
Array
(
    [0] => Array
        (
            [tag] => PARA
            [type] => open
            [level] => 1
        )

    [1] => Array
        (
            [tag] => NOTE
            [type] => complete
            [level] => 2
            [value] => basit örnek
        )

    [2] => Array
        (
            [tag] => PARA
            [type] => close
            [level] => 1
        )

)

Olaylarla tetiklenen çözümleme (expat kütüphanesine dayalı olarak) XML belgenin karmaşıklığına bağlı olarak karmaşıklaşabilir. Bu işlev DOM tarzı bir nesne üretmez fakat bir ağaç halinde uygun bir yapı üretir. Bu bakımdan, XML belge içindeki veriyi gösteren nesneler kolayca oluşturulabilir. Amino asitlerden oluşan küçük bir veritabanı olarak aşağıdaki XML belgeyi ele alalım:

Örnek 2 - moldb.xml - küçük bir moleküler bilgi veritabanı

<?xml version="1.0"?>
<moldb>

  <molecule>
      <name>Alanine</name>
      <symbol>ala</symbol>
      <code>A</code>
      <type>hydrophobic</type>
  </molecule>

  <molecule>
      <name>Lysine</name>
      <symbol>lys</symbol>
      <code>K</code>
      <type>charged</type>
  </molecule>

</moldb>
Bu belgeyi çözümleyip uygun nesneleri üretecek kod:

Örnek 3 - parsemoldb.php - moldb.xml dosyasını bir moleküler nesne dizisine çözümler

<?php

class AminoAcid {
    var $name;    // amino asidin ismi
    var $symbol;  // üç harfli simge
    var $code;    // tek harflik kod
    var $type;    // hydrophobic, charged veya neutral

    function AminoAcid ($aa)
    {
        foreach ($aa as $k=>$v)
            $this->$k = $aa[$k];
    }
}

function readDatabase($filename)
{
    // amino asit veritabanını okuyalım
    $data = implode("", file($filename));
    $parser = xml_parser_create();
    xml_parser_set_option($parser, XML_OPTION_CASE_FOLDING, 0);
    xml_parser_set_option($parser, XML_OPTION_SKIP_WHITE, 1);
    xml_parse_into_struct($parser, $data, $values, $tags);
    xml_parser_free($parser);

    // dizileri açalım
    foreach ($tags as $key=>$val) {
        if ($key == "molecule") {
            $molranges = $val;
            // Dizi girdilerindeki her devamlı dizi çifti
            // bir molekülün alt ve üst aralıklarını tanımlar
            for ($i=0; $i < count($molranges); $i+=2) {
                $offset = $molranges[$i] + 1;
                $len = $molranges[$i + 1] - $offset;
                $tdb[] = parseMol(array_slice($values, $offset, $len));
            }
        } else {
            continue;
        }
    }
    return $tdb;
}

function parseMol($mvalues)
{
    for ($i=0; $i < count($mvalues); $i++) {
        $mol[$mvalues[$i]["tag"]] = $mvalues[$i]["value"];
    }
    return new AminoAcid($mol);
}

$db = readDatabase("moldb.xml");
echo "** Amino Asit Nesneleri Veritabanı:\n";
print_r($db);

?>
parsemoldb.php betiği çalıştırılınca, $db dizisi Amino asit nesnelerinden oluşturulmuş olur. Betiğin çıktısı şöyle olur:
** Amino Asit Nesneleri Veritabanı:
Array
(
    [0] => aminoacid Object
        (
            [name] => Alanine
            [symbol] => ala
            [code] => A
            [type] => hydrophobic
        )

    [1] => aminoacid Object
        (
            [name] => Lysine
            [symbol] => lys
            [code] => K
            [type] => charged
        )

)

xml_get_error_code
xml_parse
XML Çözümleyici İşlevleri


Bir XML belgeyi çözümler

xml_parse_into_struct
xml_parser_create_ns
XML Çözümleyici İşlevleri
PHP Manual

xml_parse

(PHP 4, PHP 5, PHP 7)

xml_parse — Bir XML belgeyi çözümler

Açıklama

int xml_parse ( resource $çözümleyici , string $veri [, bool $son = false ] )

xml_parse() işlevi bir XML belgeyi çözümler. Yapılandırılmış olaylar için tanımlanmış eylemci işlevler gerektiği yerlerde defalarca çağrılabilir.

Değiştirgeler

çözümleyici

xml_parser_create() ve xml_parser_create_ns() işlevleri tarafından döndürülen bir XML özkaynağı.

veri

Çözümlenecek veri parçası. Bir belge, çeşitli parçalara bölünerek bu parçalar xml_parse() işleviyle işlenerek çok sayıda adımda çözümlenebilir. Son parça çözümleneceği zaman son değiştirgesine TRUE atanmalıdır.

son

TRUE belirtilirse, çözümleyiciye aktarılan veri son veri olarak ele alınır.

Dönen Değerler

Başarı durumunda 1, aksi takdirde 0 döndürür.

Başarısız bir çözümlemede hata bilgisi
xml_get_error_code(),
xml_error_string(),
xml_get_current_line_number(),
xml_get_current_column_number() ve
xml_get_current_byte_index() işlevleri ile alınabilir.

Bilginize:

Öğe hataları sadece son değiştirgesine TRUE atandığı veri sonunda raporlanır.

xml_parse_into_struct
xml_parser_create_ns
XML Çözümleyici İşlevleri


İsim alanı destekli bir XML çözümleyici oluşturur

xml_parse
xml_parser_create
XML Çözümleyici İşlevleri
PHP Manual

xml_parser_create_ns

(PHP 4 >= 4.0.5, PHP 5, PHP 7)

xml_parser_create_ns — İsim alanı destekli bir XML çözümleyici oluşturur

Açıklama

resource xml_parser_create_ns ([ string $kodlama [, string $ayraç = ':' ]] )

xml_parser_create_ns() işlevi, isim alanı destekli yeni bir XML çözümleyici oluşturup diğer XML işlevleri tarafından kullanılmak üzere çözümleyici için bir tanıtıcı döndürür.

Değiştirgeler

kodlama

İsteğe bağlı kodlama değiştirgesi ile PHP4'te girdi/çıktı için karakter kodlaması belirtilir. PHP 5'ten itibaren, girdi kodlaması özdevinimli olarak algılanmakta olduğundan bu değiştirge ile sadece çıktı karakter kodlaması belirtilebilmektedir. PHP 4'te her iki kodlama da aynı olmak zorundadır. Değiştirgeye boş bir dizge atanmışsa çözümleyici belgenin ilk 3 veya 4 baytına bakarak kodlamayı belirlemeye çalışır. PHP 5.0.0 ve 5.0.1'de öntanımlı karakter kümesi ISO-8859-1, PHP 5.0.2'den itibaren UTF-8'dir. Desteklenen karakter kodlamaları: ISO-8859-1, UTF-8 ve US-ASCII.

ayraç

İsim alanı içeren etiket ve öznitelik isimlerinde isim alanı önekinden sonra kullanılacak ayraç.

Dönen Değerler

Yeni XML çözümleyicinin tanıtıcısı ile döner.

Ayrıca Bakınız

  • xml_parser_create() - Bir XML çözümleyici oluşturur
  • xml_parser_free() - XML çözümleyiciyi serbest bırakır

xml_parse
xml_parser_create
XML Çözümleyici İşlevleri


Bir XML çözümleyici oluşturur

xml_parser_create_ns
xml_parser_free
XML Çözümleyici İşlevleri
PHP Manual

xml_parser_create

(PHP 4, PHP 5, PHP 7)

xml_parser_create — Bir XML çözümleyici oluşturur

Açıklama

resource xml_parser_create ([ string $kodlama ] )

xml_parser_create() işlevi, yeni bir XML çözümleyici oluşturup diğer XML işlevleri tarafından kullanılmak üzere çözümleyici için bir tanıtıcı döndürür.

Değiştirgeler

kodlama

İsteğe bağlı kodlama değiştirgesi ile PHP4'te girdi/çıktı için karakter kodlaması belirtilir. PHP 5'ten itibaren, girdi kodlaması özdevinimli olarak algılanmakta olduğundan bu değiştirge ile sadece çıktı karakter kodlaması belirtilebilmektedir. PHP 4'te her iki kodlama da aynı olmak zorundadır. Değiştirgeye boş bir dizge atanmışsa çözümleyici belgenin ilk 3 veya 4 baytına bakarak kodlamayı belirlemeye çalışır. PHP 5.0.0 ve 5.0.1'de öntanımlı karakter kümesi ISO-8859-1, PHP 5.0.2'den itibaren UTF-8'dir. Desteklenen karakter kodlamaları: ISO-8859-1, UTF-8 ve US-ASCII.

Dönen Değerler

Yeni XML çözümleyicinin tanıtıcısı ile döner.

Ayrıca Bakınız

  • xml_parser_create_ns() - İsim alanı destekli bir XML çözümleyici oluşturur
  • xml_parser_free() - XML çözümleyiciyi serbest bırakır

xml_parser_create_ns
xml_parser_free
XML Çözümleyici İşlevleri


XML çözümleyiciyi serbest bırakır

xml_parser_create
xml_parser_get_option
XML Çözümleyici İşlevleri
PHP Manual

xml_parser_free

(PHP 4, PHP 5, PHP 7)

xml_parser_free — XML çözümleyiciyi serbest bırakır

Açıklama

bool xml_parser_free ( resource $çözümleyici )

Belirtilen XML çözümleyici için ayrılan kaynakları serbest bırakır.

Değiştirgeler

çözümleyici

xml_parser_create() ve xml_parser_create_ns() işlevleri tarafından döndürülen bir XML özkaynağı.

Dönen Değerler

Belirtilen XML çözümleyici geçersizse FALSE döndürür, aksi takdirde çözümleyiciyi serbest bırakıp TRUE döndürür.

xml_parser_create
xml_parser_get_option
XML Çözümleyici İşlevleri


XML çözümleyici seçeneklerini döndürür

xml_parser_free
xml_parser_set_option
XML Çözümleyici İşlevleri
PHP Manual

xml_parser_get_option

(PHP 4, PHP 5, PHP 7)

xml_parser_get_option — XML çözümleyici seçeneklerini döndürür

Açıklama

mixed xml_parser_get_option ( resource $çözümleyici , int $seçenek )

Belirtilen XML çözümleyici seçeneğinin değerini döndürür.

Değiştirgeler

çözümleyici

xml_parser_create() ve xml_parser_create_ns() işlevleri tarafından döndürülen bir XML özkaynağı.

seçenek
Değeri öğrenilecek seçenek. XML_OPTION_CASE_FOLDING veya XML_OPTION_TARGET_ENCODING belirtilebilir. Bu seçeneklerin açıklamaları için xml_parser_set_option() işlevine bakınız.

Dönen Değerler

çözümleyici veya seçenek geçerli değilse FALSE döner ve ayrıca bir E_WARNING çıktılanır, aksi takdirde seçeneğin değeri döner.

xml_parser_free
xml_parser_set_option
XML Çözümleyici İşlevleri


XML çözümleyici seçeneklerini belirler

xml_parser_get_option
xml_set_character_data_handler
XML Çözümleyici İşlevleri
PHP Manual

xml_parser_set_option

(PHP 4, PHP 5, PHP 7)

xml_parser_set_option — XML çözümleyici seçeneklerini belirler

Açıklama

bool xml_parser_set_option ( resource $çözümleyici , int $seçenek , mixed $değer )

XML çözümleyici seçeneklerinden birine değer atar.

Değiştirgeler

çözümleyici

xml_parser_create() ve xml_parser_create_ns() işlevleri tarafından döndürülen bir XML özkaynağı.

seçenek

Değer atanacak seçenek.

Kullanılabilecek seçenekler:

XML çözümleyici seçenekleri
Seçenek sabiti | Veri türü | Açıklama
XML_OPTION_CASE_FOLDING | integer | Büyük harfe dönüşüm yapılıp yapılmayacağını belirler. Öntanımlı olarak büyük harfe dönüşüm yapılır.
XML_OPTION_SKIP_TAGSTART | integer | Bir etiket isminin başlangıcından itibaren kaç karakter atlanacağını belirler.
XML_OPTION_SKIP_WHITE | integer | Boşluk karakterlerinden oluşan değerlerin atlanıp atlanmayacağı belirtilir.
XML_OPTION_TARGET_ENCODING | string | XML çözümleyci tarafından kullanılacak hedef kodlamayı belirler. Öntanımlı olarak, xml_parser_create() tarafından kullanılan kaynak kodlamasıyla aynıdır. Desteklenen hedef kodlamalar: ISO-8859-1, US-ASCII ve UTF-8.

değer

Seçeneğin değeri.

Dönen Değerler

çözümleyici olarak geçerli bir çözümleyici belirtilmemişse veya seçenek atanamazsa FALSE, aksi takdirde TRUE döner.

xml_parser_get_option
xml_set_character_data_handler
XML Çözümleyici İşlevleri


Karakter verisi eylemcisini belirler

xml_parser_set_option
xml_set_default_handler
XML Çözümleyici İşlevleri
PHP Manual

xml_set_character_data_handler

(PHP 4, PHP 5, PHP 7)

xml_set_character_data_handler — Karakter verisi eylemcisini belirler

Açıklama

bool xml_set_character_data_handler ( resource $çözümleyici , callback $eylemci )

çözümleyici ile belirtilen XML çözümleyici için karakter verisi eylemcisini belirler.

Değiştirgeler

çözümleyici

xml_parser_create() ve xml_parser_create_ns() işlevleri tarafından döndürülen bir XML özkaynağı.

eylemci

xml_parse() işlevi çözümleyici için çağrıldığında mevcut olması gereken işlevin ismini içeren dizge.

İsmi eylemci ile belirtilen işlevin iki değiştirge kabul etmesi gerekir:

eylemci ( resource $çözümleyici , string $veri )
çözümleyici
İlk değiştirge, eylemci işlevi çağıran XML çözümleyicinin tanıtıcısıdır.
data
İkinci değiştirge olan veri, karakter verisini dizge olarak içerir.

Karakter verisi eylemcisi, XML belgedeki her metin parçası için ayrı ayrı çağrılır. Her bölümde defalarca çağrılabilir (örneğin, ascii olmayan dizgelerde).

eylemci değiştirgesinde işlev olarak boş bir dizge veya FALSE belirtilirse ilgili eylemci iptal edilir.

Bilginize: Bir işlev ismi yerine, bir nesneye gönderim ve bir yöntem ismi içeren bir dizi de kullanılabilir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

xml_parser_set_option
xml_set_default_handler
XML Çözümleyici İşlevleri


Öntanımlı eylemciyi belirler

xml_set_character_data_handler
xml_set_element_handler
XML Çözümleyici İşlevleri
PHP Manual

xml_set_default_handler

(PHP 4, PHP 5, PHP 7)

xml_set_default_handler — Öntanımlı eylemciyi belirler

Açıklama

bool xml_set_default_handler ( resource $çözümleyici , callback $eylemci )

çözümleyici ile belirtilen XML çözümleyici için öntanımlı eylemciyi belirler.

Değiştirgeler

çözümleyici

xml_parser_create() ve xml_parser_create_ns() işlevleri tarafından döndürülen bir XML özkaynağı.

eylemci

xml_parse() işlevi çözümleyici için çağrıldığında mevcut olması gereken işlevin ismini içeren dizge.

İsmi eylemci ile belirtilen işlevin iki değiştirge kabul etmesi gerekir:

eylemci ( resource $çözümleyici , string $veri )
çözümleyici
İlk değiştirge, eylemci işlevi çağıran XML çözümleyicinin tanıtıcısıdır.
veri
İkinci değiştirge olan veri, karakter verisini içerir. Dizge, XML bildirimi, belge türü bildirimi veya diğer eylemciler tarafından ele alınmayan başka bir verileri içerebilir.

eylemci değiştirgesinde işlev olarak boş bir dizge veya FALSE belirtilirse ilgili eylemci iptal edilir.

Bilginize: Bir işlev ismi yerine, bir nesneye gönderim ve bir yöntem ismi içeren bir dizi de kullanılabilir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

xml_set_character_data_handler
xml_set_element_handler
XML Çözümleyici İşlevleri


Açılış ve kapanış etiketi eylemcilerini belirler

xml_set_default_handler
xml_set_end_namespace_decl_handler
XML Çözümleyici İşlevleri
PHP Manual

xml_set_element_handler

(PHP 4, PHP 5, PHP 7)

xml_set_element_handler — Açılış ve kapanış etiketi eylemcilerini belirler

Açıklama

bool xml_set_element_handler ( resource $çözümleyici , callback $açılış_etiketi_eylemcisi , callback $kapanış_etiketi_eylemcisi )

çözümleyici ile belirtilen XML çözümleyici için açılış ve kapanış etiketi eylemcilerini belirler. açılış_etiketi_eylemcisi ve kapanış_etiketi_eylemcisi işlevleri çözümleyici ile belirtilen XML çözümleyici için xml_parse() çağrılmadan önce tanımlanmış olmalıdır.

Değiştirgeler

çözümleyici

açılış_etiketi_eylemcisi

İsmi açılış_etiketi_eylemcisi ile belirtilen işlevin üç değiştirge kabul etmesi gerekir:

açılış_etiketi_eylemcisi ( resource $çözümleyici , string $isim , array $öznitelikler )
çözümleyici
İlk değiştirge, eylemci işlevi çağıran XML çözümleyicinin tanıtıcısıdır.
isim
İkinci değiştirge olan isim, bu eylemcinin çağrılacağı elemanın ismidir. Eğer çözümleyicide büyük harfe dönüşüm etkinse eleman isminin harfleri büyük harfe dönüştürülür.
öznitelikler
Üçüncü değiştirge olan öznitelikler, (varsa) eleman özniteliklerini içeren ilişkisel bir dizidir. Dizi elemanlarının anahtarları özniteliklerin isimleri, değerleri ise özniteliklerin değerleridir. Eğer çözümleyicide büyük harfe dönüşüm etkinse eleman isimlerine uygulanan işlem öznitelik isimlerine de uygulanır. Değerlere ise bu işlem uygulanmaz. Öznitelikler, dizi elemanlarına each() uygulanarak özgün sıralarıyla ele alınabilir. Dizideki ilk eleman elemanın ilk özniteliğini içerir ve böyle devam eder.

Bilginize: Bir işlev ismi yerine, bir nesneye gönderim ve bir yöntem ismi içeren bir dizi de kullanılabilir.

kapanış_etiketi_eylemcisi

İsmi kapanış_etiketi_eylemcisi ile belirtilen işlevin iki değiştirge kabul etmesi gerekir:

kapanış_etiketi_eylemcisi ( resource $çözümleyici , string $isim )
çözümleyici
İlk değiştirge, eylemci işlevi çağıran XML çözümleyicinin tanıtıcısıdır.
isim
İkinci değiştirge olan isim, bu eylemcinin çağrılacağı elemanın ismidir. Eğer çözümleyicide büyük harfe dönüşüm etkinse eleman isminin harfleri büyük harfe dönüştürülür.

eylemci değiştirgesinde işlev olarak boş bir dizge veya FALSE belirtilirse ilgili eylemci iptal edilir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

xml_set_default_handler
xml_set_end_namespace_decl_handler
XML Çözümleyici İşlevleri


İsim alanı bildirimi sonlandırma eylemcisini belirler

xml_set_element_handler
xml_set_external_entity_ref_handler
XML Çözümleyici İşlevleri
PHP Manual

xml_set_end_namespace_decl_handler

(PHP 4 >= 4.0.5, PHP 5, PHP 7)

xml_set_end_namespace_decl_handler — İsim alanı bildirimi sonlandırma eylemcisini belirler

Açıklama

bool xml_set_end_namespace_decl_handler ( resource $çözümleyici , callback $eylemci )

İsim alanı bildirimi etki alanından çıkılırken çağrılacak eylemci işlevi belirler. İsim alanı bildirimi sonlandırma eylemcisi, her isim alanlı başlangıç etiketinin karşılığı olan kapama etiketinin eylemcisinden sonra çağrılır.

Değiştirgeler

çözümleyici

xml_parser_create() ve xml_parser_create_ns() işlevleri tarafından döndürülen bir XML özkaynağı.

eylemci

xml_parse() işlevi çözümleyici için çağrıldığında mevcut olması gereken işlevin ismini içeren dizge.

İsmi eylemci değiştirgesiyle belirtilen işlev üç değiştirge kabul etmeli ve bir tamsayı değer döndürmelidir. Eğer FALSE döndürülürse (bir değer dönmemesi hali), XML çözümleyici çözümlemeyi durdurur ve xml_get_error_code() işlevi XML_ERROR_EXTERNAL_ENTITY_HANDLING hatasını döndürür. Eylemci işlev sözdizimi:

eylemci ( resource $çözümleyici , string $kullanıcı_verisi , string $önek )
çözümleyici
İlk değiştirge, eylemci işlevi çağıran XML çözümleyicinin tanıtıcısıdır.
user_data
prefix

eylemci değiştirgesinde işlev olarak boş bir dizge veya FALSE belirtilirse ilgili eylemci iptal edilir.

Bilginize: Bir işlev ismi yerine, bir nesneye gönderim ve bir yöntem ismi içeren bir dizi de kullanılabilir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • xml_set_start_namespace_decl_handler() - İsim alanı bildirimi başlatma eylemcisini belirler

xml_set_element_handler
xml_set_external_entity_ref_handler
XML Çözümleyici İşlevleri


Harici öğe gönderimi eylemcisini belirler

xml_set_end_namespace_decl_handler
xml_set_notation_decl_handler
XML Çözümleyici İşlevleri
PHP Manual

xml_set_external_entity_ref_handler

(PHP 4, PHP 5, PHP 7)

xml_set_external_entity_ref_handler — Harici öğe gönderimi eylemcisini belirler

Açıklama

bool xml_set_external_entity_ref_handler ( resource $çözümleyici , callback $eylemci )

çözümleyici ile belirtilen XML çözümleyici için harici öğe gönderimi eylemcisini belirler.

Değiştirgeler

çözümleyici

xml_parser_create() ve xml_parser_create_ns() işlevleri tarafından döndürülen bir XML özkaynağı.

eylemci

xml_parse() işlevi çözümleyici için çağrıldığında mevcut olması gereken işlevin ismini içeren dizge.

İsmi eylemci değiştirgesiyle belirtilen işlev beş değiştirge kabul etmeli ve bir tamsayı değer döndürmelidir. Eğer FALSE döndürülürse (bir değer dönmemesi hali), XML çözümleyici çözümlemeyi durdurur ve xml_get_error_code() işlevi XML_ERROR_EXTERNAL_ENTITY_HANDLING hatasını döndürür. Eylemci işlev sözdizimi:

eylemci ( resource $çözümleyici , string $açık_öğe_isimleri , string $taban , string $sistem_id , string $genel_id )
çözümleyici
İlk değiştirge, eylemci işlevi çağıran XML çözümleyicinin tanıtıcısıdır.
açık_öğe_isimleri
İkinci değiştirge, açık_öğe_isimleri, öğenin çözümlenmesi için açılan öğe isimlerinin boşluk ayraçlı listesidir (belirtilen öğenin ismi dahil).
taban
Harici öğenin sistem betimleyicisini (sistem_id) çözümlemek için kullanılacak dizge. Şimdilik bu değiştirge daima boş bir dizgedir.
system_id
Harici öğenin sistem betimleyicisi.
public_id
Harici öğenin genel betimleyicisi. Belirtilmediği takdirde boş bir dizgedir. Betimleyici içindeki boşluklar XML belirtiminde belirtildiği gibi normalleştirilir.

eylemci değiştirgesinde işlev olarak boş bir dizge veya FALSE belirtilirse ilgili eylemci iptal edilir.

Bilginize: Bir işlev ismi yerine, bir nesneye gönderim ve bir yöntem ismi içeren bir dizi de kullanılabilir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

xml_set_end_namespace_decl_handler
xml_set_notation_decl_handler
XML Çözümleyici İşlevleri


Gösterim bildirimi eylemcisini belirler

xml_set_external_entity_ref_handler
xml_set_object
XML Çözümleyici İşlevleri
PHP Manual

xml_set_notation_decl_handler

(PHP 4, PHP 5, PHP 7)

xml_set_notation_decl_handler — Gösterim bildirimi eylemcisini belirler

Açıklama

bool xml_set_notation_decl_handler ( resource $çözümleyici , callback $eylemci )

çözümleyici ile belirtilen XML çözümleyici için gösterim bildirimi eylemcisini belirler.

Bir gösterim bildirimi belge DTD'sinin bir parçası olup sözdizimi şöyledir:

<!NOTATION isim
{
sistem_id
|
genel_id
?>
Gösterim bildirimi tanımı için » XML 1.0 belirtiminin ilgili bölümüne bakınız.

Değiştirgeler

çözümleyici

xml_parser_create() ve xml_parser_create_ns() işlevleri tarafından döndürülen bir XML özkaynağı.

eylemci

xml_parse() işlevi çözümleyici için çağrıldığında mevcut olması gereken işlevin ismini içeren dizge.

İsmi eylemci ile belirtilen işlevin beş değiştirge kabul etmesi gerekir:

eylemci ( resource $çözümleyici , string $gösterim_adı , string $taban , string $sistem_id , string $genel_id )
çözümleyici
İlk değiştirge, eylemci işlevi çağıran XML çözümleyicinin tanıtıcısıdır.
gösterim_adı
Yukarıdaki gösterim bildirimi sözdiziminde isim değiştirgesinin değeri.
taban
Harici öğenin sistem betimleyicisini (sistem_id) çözümlemek için kullanılacak dizge. Şimdilik bu değiştirge daima boş bir dizgedir.
system_id
Harici gösterim bildiriminin sistem betimleyicisi.
public_id
Harici öğenin genel betimleyicisi. Belirtilmediği takdirde boş bir dizgedir. Betimleyici içindeki boşluklar XML belirtiminde belirtildiği gibi normalleştirilir.

eylemci değiştirgesinde işlev olarak boş bir dizge veya FALSE belirtilirse ilgili eylemci iptal edilir.

Bilginize: Bir işlev ismi yerine, bir nesneye gönderim ve bir yöntem ismi içeren bir dizi de kullanılabilir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

xml_set_external_entity_ref_handler
xml_set_object
XML Çözümleyici İşlevleri


XML çözümleyici, nesne içinde kullanılır

xml_set_notation_decl_handler
xml_set_processing_instruction_handler
XML Çözümleyici İşlevleri
PHP Manual

xml_set_object

(PHP 4, PHP 5, PHP 7)

xml_set_object — XML çözümleyici, nesne içinde kullanılır

Açıklama

bool xml_set_object ( resource $çözümleyici , object &$nesne )

Bu işlev, çözümleyici ile belirtilen XML çözümleyicinin belirtilen nesne nesnesi içinde kullanılmasını mümkün kılar. Bu durumda, xml_set_element_handler() benzeri işlevlerle belirtilen eylemci işlevlerin nesne nesnesinin yöntemleri olarak belirtilmesi gerekir.

Değiştirgeler

çözümleyici

xml_parser_create() ve xml_parser_create_ns() işlevleri tarafından döndürülen bir XML özkaynağı.

nesne

Eylemci yöntemleri içeren nesne.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - xml_set_object() örneği

<?php
class xml  {
    var $çözümleyici;

    function xml()
    {
        $this->çözümleyici = xml_parser_create();

        xml_set_object($this->çözümleyici, $this);
        xml_set_element_handler($this->çözümleyici, "etiketAç", "etiketKapa");
        xml_set_character_data_handler($this->çözümleyici, "cdata");
    }

    function çözümle($veri)
    {
        xml_parse($this->çözümleyici, $veri);
    }

    function etiketAç($çözümleyici, $etiket, $değiştirgeler)
    {
        var_dump($çözümleyici, $etiket, $değiştirgeler);
    }

    function cdata($çözümleyici, $cdata)
    {
        var_dump($çözümleyici, $cdata);
    }

    function etiketKapa($çözümleyici, $etiket)
    {
        var_dump($çözümleyici, $etiket);
    }

} // xml sınıfının sonu

$xml_çözümleyici = new xml();
$xml_çözümleyici->çözümle("<A ID='alo'>PHP</A>");
?>

xml_set_notation_decl_handler
xml_set_processing_instruction_handler
XML Çözümleyici İşlevleri


İşlem komutu (PI) eylemcisini belirler

xml_set_object
xml_set_start_namespace_decl_handler
XML Çözümleyici İşlevleri
PHP Manual

xml_set_processing_instruction_handler

(PHP 4, PHP 5, PHP 7)

xml_set_processing_instruction_handler — İşlem komutu (PI) eylemcisini belirler

Açıklama

bool xml_set_processing_instruction_handler ( resource $çözümleyici , callback $eylemci )

çözümleyici ile belirtilen XML çözümleyici için işlem komutu (PI) eylemcisini belirler.

Bir işlem komutunun biçemi şöyledir:

<?hedef veri?>
PHP kodunu böyle bir işlem komutu içine koyabilirsiniz, fakat bir sınırlama konusunda dikkatli olmalısınız: Bir XML işlemci komutunda kapama etiketi (?>) öncelenmemelidir (anlamsızlaştırılmamalıdır). Dolayısıyla XML belgelere işlem komutlarıyla gömülen PHP kodları böyle karakter dizilimleri içermemelidir. Aksi takdirde, PHP kodu ve işlem komutunun kapama etiketi karakter verisi olarak ele alınır.

Değiştirgeler

çözümleyici

xml_parser_create() ve xml_parser_create_ns() işlevleri tarafından döndürülen bir XML özkaynağı.

eylemci

xml_parse() işlevi çözümleyici için çağrıldığında mevcut olması gereken işlevin ismini içeren dizge.

İsmi eylemci ile belirtilen işlevin üç değiştirge kabul etmesi gerekir:

handler ( resource $çözümleyici , string $hedef , string $veri )
çözümleyici
İlk değiştirge, eylemci işlevi çağıran XML çözümleyicinin tanıtıcısıdır.
hedef
İkinci değiştirge, hedef, PI hedefini içermelidir.
veri
Üçüncü değiştirge, veri, PI verisini içermelidir.

eylemci değiştirgesinde işlev olarak boş bir dizge veya FALSE belirtilirse ilgili eylemci iptal edilir.

Bilginize: Bir işlev ismi yerine, bir nesneye gönderim ve bir yöntem ismi içeren bir dizi de kullanılabilir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

xml_set_object
xml_set_start_namespace_decl_handler
XML Çözümleyici İşlevleri


İsim alanı bildirimi başlatma eylemcisini belirler

xml_set_processing_instruction_handler
xml_set_unparsed_entity_decl_handler
XML Çözümleyici İşlevleri
PHP Manual

xml_set_start_namespace_decl_handler

(PHP 4 >= 4.0.5, PHP 5, PHP 7)

xml_set_start_namespace_decl_handler — İsim alanı bildirimi başlatma eylemcisini belirler

Açıklama

bool xml_set_start_namespace_decl_handler ( resource $çözümleyici , callback $eylemcisini )

İsim alanı bildirimi yapıldığında bu işlev çağrılır. İsim alanı bildirimleri başlangıç etiketinde bulunur. Fakat, isim alanı bildirim eylemcisi, her isim alanlı etiket için başlangıç etiketi eylemcisinden önce çağrılır.

Değiştirgeler

çözümleyici

xml_parser_create() ve xml_parser_create_ns() işlevleri tarafından döndürülen bir XML özkaynağı.

eylemci

xml_parse() işlevi çözümleyici için çağrıldığında mevcut olması gereken işlevin ismini içeren dizge.

İsmi eylemci değiştirgesiyle belirtilen işlev dört değiştirge kabul etmeli ve bir tamsayı değer döndürmelidir. Eğer FALSE döndürülürse (bir değer dönmemesi hali), XML çözümleyici çözümlemeyi durdurur ve xml_get_error_code() işlevi XML_ERROR_EXTERNAL_ENTITY_HANDLING hatasını döndürür. Eylemci işlev sözdizimi:

eylemci ( resource $çözümleyici , string $kullanıcı_verisi , string $önek , string $uri )
parser
İlk değiştirge, eylemci işlevi çağıran XML çözümleyicinin tanıtıcısıdır.
user_data
prefix
uri

eylemci değiştirgesinde işlev olarak boş bir dizge veya FALSE belirtilirse ilgili eylemci iptal edilir.

Bilginize: Bir işlev ismi yerine, bir nesneye gönderim ve bir yöntem ismi içeren bir dizi de kullanılabilir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • xml_set_end_namespace_decl_handler() - İsim alanı bildirimi sonlandırma eylemcisini belirler

xml_set_processing_instruction_handler
xml_set_unparsed_entity_decl_handler
XML Çözümleyici İşlevleri


Çözümlenmeyen öğe bildirimi eylemcisini belirler

xml_set_start_namespace_decl_handler
XMLReader
XML Çözümleyici İşlevleri
PHP Manual

xml_set_unparsed_entity_decl_handler

(PHP 4, PHP 5, PHP 7)

xml_set_unparsed_entity_decl_handler — Çözümlenmeyen öğe bildirimi eylemcisini belirler

Açıklama

bool xml_set_unparsed_entity_decl_handler ( resource $çözümleyici , callback $eylemci )

çözümleyici ile belirtilen XML çözümleyici için çözümlenmeyen öğe bildirimi (NDATA) eylemcisini belirler.

XML çözümleyici, aşağıdaki gibi bir NDATA bildirimli bir harici öğe bildirimi saptarsa ismi eylemci değiştirgesinde belirtilen işlev çağrılır:

<!ENTITY isim {genel_id | sistem_id}

        NDATA gösterim_adı

Harici öğe olarak bildirilen gösterim tanımı için » XML 1.0 belirtiminin ilgili bölümüne bakınız.

Değiştirgeler

çözümleyici

xml_parser_create() ve xml_parser_create_ns() işlevleri tarafından döndürülen bir XML özkaynağı.

eylemci

xml_parse() işlevi çözümleyici için çağrıldığında mevcut olması gereken işlevin ismini içeren dizge.

İsmi eylemci ile belirtilen işlevin altı değiştirge kabul etmesi gerekir:

eylemci ( resource $çözümleyici , string $öğe_adı , string $taban , string $sistem_id , string $genel_id , string $gösterim_adı )
çözümleyici
İlk değiştirge, eylemci işlevi çağıran XML çözümleyicinin tanıtıcısıdır.
öğe_adı
Tanımlanmaya hazırlanılan öğenin ismi.
taban
Harici öğenin sistem betimleyicisini (sistem_id) çözümlemek için kullanılacak dizge. Şimdilik bu değiştirge daima boş bir dizgedir.
sistem_id
Harici öğenin sistem betimleyicisi.
genel_id
Harici öğenin genel betimleyicisi. Belirtilmediği takdirde boş bir dizgedir. Betimleyici içindeki boşluklar XML belirtiminde belirtildiği gibi normalleştirilir.
gösterim_adı
Bu öğenin gösterim ismi (xml_set_notation_decl_handler() işlevine bakınız).

eylemci değiştirgesinde işlev olarak boş bir dizge veya FALSE belirtilirse ilgili eylemci iptal edilir.

Bilginize: Bir işlev ismi yerine, bir nesneye gönderim ve bir yöntem ismi içeren bir dizi de kullanılabilir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

xml_set_start_namespace_decl_handler
XMLReader
XML Çözümleyici İşlevleri


XMLReader

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • XMLReader — XMLReader sınıfı
    • XMLReader::close — XMLReader girdisini kapatır
    • XMLReader::expand — Geçerli düğümün bir kopyasını bir DOM nesnesi olarak döndürür
    • XMLReader::getAttribute — İsmi belirtilen özniteliğin değerini döndürür
    • XMLReader::getAttributeNo — İndisi belirtilen özniteliğin değerini döndürür
    • XMLReader::getAttributeNs — İsmi ve isim alanı belirtilen özniteliğin değerini döndürür
    • XMLReader::getParserProperty — Belirtilen özelliğin tanımlı olup olmadığına bakar
    • XMLReader::isValid — Çözümlenen belgenin geçerli olup olmadığına bakar
    • XMLReader::lookupNamespace — Bir önek için isim alanına bakar
    • XMLReader::moveToAttribute — İmleci ismi belirtilen özniteliğe konumlar
    • XMLReader::moveToAttributeNo — Move cursor to an attribute by index
    • XMLReader::moveToAttributeNs — Move cursor to a named attribute
    • XMLReader::moveToElement — İmleci geçerli özniteliğin ebeveyn elemanına konumlar
    • XMLReader::moveToFirstAttribute — İmleci ilk özniteliğe konumlar
    • XMLReader::moveToNextAttribute — İmleci sonraki özniteliğe konumlar
    • XMLReader::next — Alt ağaçların tümünü atlayıp sonraki düğüme gider
    • XMLReader::open — Çözemlenecek XML belgeyi içeren adresi belirler
    • XMLReader::read — Belgedeki sonraki düğüme gidilir
    • XMLReader::readInnerXML — Geçerli düğümün içeriğini okur
    • XMLReader::readOuterXML — Geçerli düğümün içeriğini düğümün kendisiyle birlikte okur
    • XMLReader::readString — Geçerli düğümün içeriğini bir dizge olarak okur
    • XMLReader::setParserProperty — Çözümleyici seçeneklerini tanımlar
    • XMLReader::setRelaxNGSchema — Belgeyi RelaxNG şemasına göre doğrular
    • XMLReader::setRelaxNGSchemaSource — Belgeyi dizge olarak belirtilen RelaxNG şemasına göre doğrular
    • XMLReader::setSchema — Belgeyi XSD şemasına göre doğrular
    • XMLReader::XML — Çözümlenecek XML belge içeriği belirtilir
xml_set_unparsed_entity_decl_handler
Giriş
XML İşleme


Giriş

XMLReader eklentisi bir XML çözümleyicisidir. Belge akımı üzerinde her düğümde durarak bir imleç gibi hareket eder.

Kodlama

libxml dahili olarak UTF-8 kullandığından alınan içeriğin daima UTF-8 kodlanmış olması gerekir.

XMLReader
Yapılandırma/Kurulum
XMLReader


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
XMLReader


Kurulum

XMLReader eklentisi PHP 5.0.0'dan beri PECL'de mevcut olup PHP 5.1.0'dan itibaren öntanımlı olarak etkindir. PHP'yi derlerken configure betiğine --enable-xmlreader (5.1.0 öncesi için --with-xmlreader ) seçeneğini belirterek etkin kılabilirsiniz. Eklenti, libxml eklentisini gerektirir.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Özkaynak Türleri

Bu eklentinin tanımlı hiçbir özkaynak türü yoktur.

Çalışma Anı Yapılandırması
XMLReader
Yapılandırma/Kurulum


XMLReader sınıfı

(PHP 5 >= 5.1.0, PHP 7)

Giriş

XMLReader eklentisi bir XML çözümleyicisidir. Belge akımı üzerinde her düğümde durarak bir imleç gibi hareket eder.

Sınıf Sözdizimi

XMLReader {
/* Sabitler */
const int NONE = 0 ;
const int ELEMENT = 1 ;
const int ATTRIBUTE = 2 ;
const int TEXT = 3 ;
const int CDATA = 4 ;
const int ENTITY_REF = 5 ;
const int ENTITY = 6 ;
const int PI = 7 ;
const int COMMENT = 8 ;
const int DOC = 9 ;
const int DOC_TYPE = 10 ;
const int DOC_FRAGMENT = 11 ;
const int NOTATION = 12 ;
const int WHITESPACE = 13 ;
const int SIGNIFICANT_WHITESPACE = 14 ;
const int END_ELEMENT = 15 ;
const int END_ENTITY = 16 ;
const int XML_DECLARATION = 17 ;
const int LOADDTD = 1 ;
const int DEFAULTATTRS = 2 ;
const int VALIDATE = 3 ;
const int SUBST_ENTITIES = 4 ;
/* Özellikler */
public readonly int $attributeCount ;
public readonly string $baseURI ;
public readonly int $depth ;
public readonly bool $hasAttributes ;
public readonly bool $hasValue ;
public readonly bool $isDefault ;
public readonly bool $isEmptyElement ;
public readonly string $localName ;
public readonly string $name ;
public readonly string $namespaceURI ;
public readonly int $nodeType ;
public readonly string $prefix ;
public readonly string $value ;
public readonly string $xmlLang ;
/* Yöntemler */
bool close ( void )
DOMNode expand ( void )
string getAttribute ( string $isim )
string getAttributeNo ( int $index )
string getAttributeNs ( string $isim , string $isimalanı )
bool getParserProperty ( int $özellik )
bool isValid ( void )
bool lookupNamespace ( string $önek )
bool moveToAttribute ( string $isim )
public bool moveToAttributeNo ( int $index )
public bool moveToAttributeNs ( string $localName , string $namespaceURI )
bool moveToElement ( void )
bool moveToFirstAttribute ( void )
bool moveToNextAttribute ( void )
bool next ([ string $isim ] )
bool open ( string $URI [, string $kodlama [, int $seçenekler = 0 ]] )
bool read ( void )
string readInnerXML ( void )
string readOuterXML ( void )
string readString ( void )
bool setParserProperty ( int $seçenek , bool $etkin )
bool setRelaxNGSchema ( string $dosya )
bool setRelaxNGSchemaSource ( string $kaynak )
bool setSchema ( string $dosya )
bool xml ( string $kaynak [, string $kodlama [, int $seçenekler = 0 ]] )
}

Özellikler

attributeCount

Düğümdeki özniteliklerin sayısı.

baseURI

Düğümün taban adresi.

depth

Düğümün ağaçtaki derinliği; 0'dan başlar.

hasAttributes

Düğümün öznitelikleri varsa TRUE.

hasValue

Düğüm bir metin değerine sahipse TRUE.

isDefault

Özniteliğin DTD'de öntanımlısı varsa TRUE.

isEmptyElement

Düğüm boş bir elemansa TRUE

localName

Düğümün yerel ismi.

name

Düğümün nitelenmiş ismi.

namespaceURI

Düğüm ile ilişkili isim alanını betimleyen adres.

nodeType

Düğümün düğüm türü.

önek

Düğüm ile ilişkili isim alanı öneki.

value

Düğümün metin değeri.

xmlLang

Düğümün ait olduğu xml:lang etki alanı

Öntanımlı Sabitler

XMLReader Düğüm Türleri

XMLReader::NONE

Düğüm türü yok

XMLReader::ELEMENT

Eleman başlatır

XMLReader::ATTRIBUTE

Öznitelik düğümü

XMLReader::TEXT

Metin düğümü

XMLReader::CDATA

CDATA düğümü

XMLReader::ENTITY_REF

Öğe gönderimi düğümü

XMLReader::ENTITY

Öğe bildirimi düğümü

XMLReader::PI

İşlem komutu düğümü

XMLReader::COMMENT

Açıklama düğümü

XMLReader::DOC

Belge düğümü

XMLReader::DOC_TYPE

Belge türü düğümü

XMLReader::DOC_FRAGMENT

Belge bölümü düğümü

XMLReader::NOTATION

Gösterim düğümü

XMLReader::WHITESPACE

Boşluk düğümü

XMLReader::SIGNIFICANT_WHITESPACE

Anlamlı boşluk düğümü

XMLReader::END_ELEMENT

Elemanı kapatır

XMLReader::END_ENTITY

Öğeyi kapatır

XMLReader::XML_DECLARATION

XML Bildirimi düğümü

XMLReader Çözümleyici Seçenekleri

XMLReader::LOADDTD

DTD'yi yükler fakat doğrulama yapmaz.

XMLReader::DEFAULTATTRS

DTD'yi ve öntanımlı öznitelikleri yükler fakat doğrulama yapmaz.

XMLReader::VALIDATE

DTD'yi yükler ve çözümleme sırasında doğrulama yapar.

XMLReader::SUBST_ENTITIES

Öğe ikamelelerini yapar ve gönderimleri genişletir.

İçindekiler

  • XMLReader::close — XMLReader girdisini kapatır
  • XMLReader::expand — Geçerli düğümün bir kopyasını bir DOM nesnesi olarak döndürür
  • XMLReader::getAttribute — İsmi belirtilen özniteliğin değerini döndürür
  • XMLReader::getAttributeNo — İndisi belirtilen özniteliğin değerini döndürür
  • XMLReader::getAttributeNs — İsmi ve isim alanı belirtilen özniteliğin değerini döndürür
  • XMLReader::getParserProperty — Belirtilen özelliğin tanımlı olup olmadığına bakar
  • XMLReader::isValid — Çözümlenen belgenin geçerli olup olmadığına bakar
  • XMLReader::lookupNamespace — Bir önek için isim alanına bakar
  • XMLReader::moveToAttribute — İmleci ismi belirtilen özniteliğe konumlar
  • XMLReader::moveToAttributeNo — Move cursor to an attribute by index
  • XMLReader::moveToAttributeNs — Move cursor to a named attribute
  • XMLReader::moveToElement — İmleci geçerli özniteliğin ebeveyn elemanına konumlar
  • XMLReader::moveToFirstAttribute — İmleci ilk özniteliğe konumlar
  • XMLReader::moveToNextAttribute — İmleci sonraki özniteliğe konumlar
  • XMLReader::next — Alt ağaçların tümünü atlayıp sonraki düğüme gider
  • XMLReader::open — Çözemlenecek XML belgeyi içeren adresi belirler
  • XMLReader::read — Belgedeki sonraki düğüme gidilir
  • XMLReader::readInnerXML — Geçerli düğümün içeriğini okur
  • XMLReader::readOuterXML — Geçerli düğümün içeriğini düğümün kendisiyle birlikte okur
  • XMLReader::readString — Geçerli düğümün içeriğini bir dizge olarak okur
  • XMLReader::setParserProperty — Çözümleyici seçeneklerini tanımlar
  • XMLReader::setRelaxNGSchema — Belgeyi RelaxNG şemasına göre doğrular
  • XMLReader::setRelaxNGSchemaSource — Belgeyi dizge olarak belirtilen RelaxNG şemasına göre doğrular
  • XMLReader::setSchema — Belgeyi XSD şemasına göre doğrular
  • XMLReader::XML — Çözümlenecek XML belge içeriği belirtilir
Özkaynak Türleri
XMLReader::close
XMLReader


XMLReader girdisini kapatır

XMLReader
XMLReader::expand
XMLReader
PHP Manual

XMLReader::close

(PHP 5 >= 5.1.0, PHP 7)

XMLReader::close — XMLReader girdisini kapatır

Açıklama

bool XMLReader::close ( void )

Çözümlenmekte olan XMLReader nesnesini kapatır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLReader::open() - Çözemlenecek XML belgeyi içeren adresi belirler
  • XMLReader::xml() - Çözümlenecek XML belge içeriği belirtilir

XMLReader
XMLReader::expand
XMLReader


Geçerli düğümün bir kopyasını bir DOM nesnesi olarak döndürür

XMLReader::close
XMLReader::getAttribute
XMLReader
PHP Manual

XMLReader::expand

(PHP 5 >= 5.1.0, PHP 7)

XMLReader::expand — Geçerli düğümün bir kopyasını bir DOM nesnesi olarak döndürür

Açıklama

DOMNode XMLReader::expand ( void )

Geçerli düğümü kopyalar ve kopyayı bir DOM nesnesi olarak döndürür.

Dönen Değerler

Hata durumunda FALSE, aksi takdirde elde edilen DOMNode nesnesi döner.

XMLReader::close
XMLReader::getAttribute
XMLReader


İsmi belirtilen özniteliğin değerini döndürür

XMLReader::expand
XMLReader::getAttributeNo
XMLReader
PHP Manual

XMLReader::getAttribute

(PHP 5 >= 5.1.0, PHP 7)

XMLReader::getAttribute — İsmi belirtilen özniteliğin değerini döndürür

Açıklama

string XMLReader::getAttribute ( string $isim )

İsmi belirtilen özniteliğin değerini döndürür. Öznitelik yoksa veya eleman düğümünde özniteliğe konumlanamıyorsa boş bir dizge döner.

Değiştirgeler

isim

Özniteliğin ismi.

Dönen Değerler

İsmi belirtilen özniteliğin değerini bir dizge olarak döndürür. Öznitelik yoksa veya eleman düğümünde özniteliğe konumlanamıyorsa boş bir dizge döner.

Ayrıca Bakınız

  • XMLReader::getAttributeNo() - İndisi belirtilen özniteliğin değerini döndürür
  • XMLReader::getAttributeNs() - İsmi ve isim alanı belirtilen özniteliğin değerini döndürür

XMLReader::expand
XMLReader::getAttributeNo
XMLReader


İndisi belirtilen özniteliğin değerini döndürür

XMLReader::getAttribute
XMLReader::getAttributeNs
XMLReader
PHP Manual

XMLReader::getAttributeNo

(PHP 5 >= 5.1.0, PHP 7)

XMLReader::getAttributeNo — İndisi belirtilen özniteliğin değerini döndürür

Açıklama

string XMLReader::getAttributeNo ( int $index )

İndisi belirtilen özniteliğin değerini döndürür. Öznitelik yoksa veya eleman düğümünde özniteliğe konumlanamıyorsa boş bir dizge döner.

Değiştirgeler

indis

Özniteliğin konumu.

Dönen Değerler

İndisi belirtilen özniteliğin değerini bir dizge olarak döndürür. Öznitelik yoksa veya eleman düğümünde özniteliğe konumlanamıyorsa boş bir dizge döner.

Ayrıca Bakınız

  • XMLReader::getAttribute() - İsmi belirtilen özniteliğin değerini döndürür
  • XMLReader::getAttributeNs() - İsmi ve isim alanı belirtilen özniteliğin değerini döndürür

XMLReader::getAttribute
XMLReader::getAttributeNs
XMLReader


İsmi ve isim alanı belirtilen özniteliğin değerini döndürür

XMLReader::getAttributeNo
XMLReader::getParserProperty
XMLReader
PHP Manual

XMLReader::getAttributeNs

(PHP 5 >= 5.1.0, PHP 7)

XMLReader::getAttributeNs — İsmi ve isim alanı belirtilen özniteliğin değerini döndürür

Açıklama

string XMLReader::getAttributeNs ( string $isim , string $isimalanı )

İsmi ve isim alanı belirtilen özniteliğin değerini döndürür. Öznitelik yoksa veya eleman düğümünde özniteliğe konumlanamıyorsa boş bir dizge döner.

Değiştirgeler

isim

Özniteliğin yerel ismi.

isimalanı

İsim alanını betimleyen adres.

Dönen Değerler

İsmi ve isim alanı belirtilen özniteliğin değerini bir dizge olarak döndürür. Öznitelik yoksa veya eleman düğümünde özniteliğe konumlanamıyorsa boş bir dizge döner.

Ayrıca Bakınız

  • XMLReader::getAttribute() - İsmi belirtilen özniteliğin değerini döndürür
  • XMLReader::getAttributeNo() - İndisi belirtilen özniteliğin değerini döndürür

XMLReader::getAttributeNo
XMLReader::getParserProperty
XMLReader


Belirtilen özelliğin tanımlı olup olmadığına bakar

XMLReader::getAttributeNs
XMLReader::isValid
XMLReader
PHP Manual

XMLReader::getParserProperty

(PHP 5 >= 5.1.0, PHP 7)

XMLReader::getParserProperty — Belirtilen özelliğin tanımlı olup olmadığına bakar

Açıklama

bool XMLReader::getParserProperty ( int $özellik )

Belirtilen özelliğin tanımlı olup olmadığına bakar.

Değiştirgeler

özellik

Çözümleyici seçeneği sabitlerinden biri.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLReader::setParserProperty() - Çözümleyici seçeneklerini tanımlar

XMLReader::getAttributeNs
XMLReader::isValid
XMLReader


Çözümlenen belgenin geçerli olup olmadığına bakar

XMLReader::getParserProperty
XMLReader::lookupNamespace
XMLReader
PHP Manual

XMLReader::isValid

(PHP 5 >= 5.1.0, PHP 7)

XMLReader::isValid — Çözümlenen belgenin geçerli olup olmadığına bakar

Açıklama

bool XMLReader::isValid ( void )

Çözümlenen belge geçerli ise TRUE döner.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - XML belgenin doğrulanması

<?php
$xml = XMLReader::open('test.xml');

// Doğrulamanın gerekliliğini belirtelim
$xml->setParserProperty(XMLReader::VALIDATE, true);

var_dump($xml->isValid());
?>

Ayrıca Bakınız

  • XMLReader::setParserProperty() - Çözümleyici seçeneklerini tanımlar
  • XMLReader::setRelaxNGSchema() - Belgeyi RelaxNG şemasına göre doğrular
  • XMLReader::setRelaxNGSchemaSource() - Belgeyi dizge olarak belirtilen RelaxNG şemasına göre doğrular

XMLReader::getParserProperty
XMLReader::lookupNamespace
XMLReader


Bir önek için isim alanına bakar

XMLReader::isValid
XMLReader::moveToAttribute
XMLReader
PHP Manual

XMLReader::lookupNamespace

(PHP 5 >= 5.1.0, PHP 7)

XMLReader::lookupNamespace — Bir önek için isim alanına bakar

Açıklama

bool XMLReader::lookupNamespace ( string $önek )

Belirtilen önek için isim alanına bakar.

Değiştirgeler

önek

Önek olarak kullanılan dizge.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

XMLReader::isValid
XMLReader::moveToAttribute
XMLReader


İmleci ismi belirtilen özniteliğe konumlar

XMLReader::lookupNamespace
XMLReader::moveToAttributeNo
XMLReader
PHP Manual

XMLReader::moveToAttribute

(PHP 5 >= 5.1.0, PHP 7)

XMLReader::moveToAttribute — İmleci ismi belirtilen özniteliğe konumlar

Açıklama

bool XMLReader::moveToAttribute ( string $isim )

İmleci ismi belirtilen özniteliğe konumlar.

Değiştirgeler

isim

Özniteliğin ismi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLReader::moveToElement() - İmleci geçerli özniteliğin ebeveyn elemanına konumlar
  • XMLReader::moveToAttributeNo() - Move cursor to an attribute by index
  • XMLReader::moveToAttributeNs() - Move cursor to a named attribute
  • XMLReader::moveToFirstAttribute() - İmleci ilk özniteliğe konumlar

XMLReader::lookupNamespace
XMLReader::moveToAttributeNo
XMLReader


Move cursor to an attribute by index

XMLReader::moveToAttribute
XMLReader::moveToAttributeNs
XMLReader
PHP Manual

XMLReader::moveToAttributeNo

(PHP 5 >= 5.1.0, PHP 7)

XMLReader::moveToAttributeNo — Move cursor to an attribute by index

Açıklama

public bool XMLReader::moveToAttributeNo ( int $index )

Positions cursor on attribute based on its position.

Değiştirgeler

index

The position of the attribute.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLReader::moveToElement() - İmleci geçerli özniteliğin ebeveyn elemanına konumlar
  • XMLReader::moveToAttribute() - İmleci ismi belirtilen özniteliğe konumlar
  • XMLReader::moveToAttributeNs() - Move cursor to a named attribute
  • XMLReader::moveToFirstAttribute() - İmleci ilk özniteliğe konumlar

XMLReader::moveToAttribute
XMLReader::moveToAttributeNs
XMLReader


Move cursor to a named attribute

XMLReader::moveToAttributeNo
XMLReader::moveToElement
XMLReader
PHP Manual

XMLReader::moveToAttributeNs

(PHP 5 >= 5.1.0, PHP 7)

XMLReader::moveToAttributeNs — Move cursor to a named attribute

Açıklama

public bool XMLReader::moveToAttributeNs ( string $localName , string $namespaceURI )

Positions cursor on the named attribute in specified namespace.

Değiştirgeler

localName

The local name.

namespaceURI

The namespace URI.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLReader::moveToElement() - İmleci geçerli özniteliğin ebeveyn elemanına konumlar
  • XMLReader::moveToAttribute() - İmleci ismi belirtilen özniteliğe konumlar
  • XMLReader::moveToAttributeNo() - Move cursor to an attribute by index
  • XMLReader::moveToFirstAttribute() - İmleci ilk özniteliğe konumlar

XMLReader::moveToAttributeNo
XMLReader::moveToElement
XMLReader


İmleci geçerli özniteliğin ebeveyn elemanına konumlar

XMLReader::moveToAttributeNs
XMLReader::moveToFirstAttribute
XMLReader
PHP Manual

XMLReader::moveToElement

(PHP 5 >= 5.1.0, PHP 7)

XMLReader::moveToElement — İmleci geçerli özniteliğin ebeveyn elemanına konumlar

Açıklama

bool XMLReader::moveToElement ( void )

İmleci geçerli özniteliğin ebeveyn elemanına konumlar.

Dönen Değerler

İmleç bir özniteliğin üzerinde değilse veya işlem başarısız olursa FALSE, yoksa TRUE döner.

Ayrıca Bakınız

  • XMLReader::moveToAttribute() - İmleci ismi belirtilen özniteliğe konumlar
  • XMLReader::moveToAttributeNo() - Move cursor to an attribute by index
  • XMLReader::moveToAttributeNs() - Move cursor to a named attribute
  • XMLReader::moveToFirstAttribute() - İmleci ilk özniteliğe konumlar

XMLReader::moveToAttributeNs
XMLReader::moveToFirstAttribute
XMLReader


İmleci ilk özniteliğe konumlar

XMLReader::moveToElement
XMLReader::moveToNextAttribute
XMLReader
PHP Manual

XMLReader::moveToFirstAttribute

(PHP 5 >= 5.1.0, PHP 7)

XMLReader::moveToFirstAttribute — İmleci ilk özniteliğe konumlar

Açıklama

bool XMLReader::moveToFirstAttribute ( void )

İmleci ilk özniteliğe konumlar.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLReader::moveToElement() - İmleci geçerli özniteliğin ebeveyn elemanına konumlar
  • XMLReader::moveToAttribute() - İmleci ismi belirtilen özniteliğe konumlar
  • XMLReader::moveToAttributeNo() - Move cursor to an attribute by index
  • XMLReader::moveToAttributeNs() - Move cursor to a named attribute
  • XMLReader::moveToNextAttribute() - İmleci sonraki özniteliğe konumlar

XMLReader::moveToElement
XMLReader::moveToNextAttribute
XMLReader


İmleci sonraki özniteliğe konumlar

XMLReader::moveToFirstAttribute
XMLReader::next
XMLReader
PHP Manual

XMLReader::moveToNextAttribute

(PHP 5 >= 5.1.0, PHP 7)

XMLReader::moveToNextAttribute — İmleci sonraki özniteliğe konumlar

Açıklama

bool XMLReader::moveToNextAttribute ( void )

İmleç bir özniteliğin üzerindeyse bir sonraki özniteliğe geçer, elemanın üzerindeyse elemanın ilk özniteliğine gider.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLReader::moveToElement() - İmleci geçerli özniteliğin ebeveyn elemanına konumlar
  • XMLReader::moveToAttribute() - İmleci ismi belirtilen özniteliğe konumlar
  • XMLReader::moveToAttributeNo() - Move cursor to an attribute by index
  • XMLReader::moveToAttributeNs() - Move cursor to a named attribute
  • XMLReader::moveToFirstAttribute() - İmleci ilk özniteliğe konumlar

XMLReader::moveToFirstAttribute
XMLReader::next
XMLReader


Alt ağaçların tümünü atlayıp sonraki düğüme gider

XMLReader::moveToNextAttribute
XMLReader::open
XMLReader
PHP Manual

XMLReader::next

(PHP 5 >= 5.1.0, PHP 7)

XMLReader::next — Alt ağaçların tümünü atlayıp sonraki düğüme gider

Açıklama

bool XMLReader::next ([ string $isim ] )

Alt ağaçların tümünü atlayıp imleci sonraki düğüme konumlandırır.

Değiştirgeler

isim

Gidilecek sonraki düğümün yerel ismi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLReader::moveToNextAttribute() - İmleci sonraki özniteliğe konumlar
  • XMLReader::moveToAttribute() - İmleci ismi belirtilen özniteliğe konumlar
  • XMLReader::moveToElement() - İmleci geçerli özniteliğin ebeveyn elemanına konumlar

XMLReader::moveToNextAttribute
XMLReader::open
XMLReader


Çözemlenecek XML belgeyi içeren adresi belirler

XMLReader::next
XMLReader::read
XMLReader
PHP Manual

XMLReader::open

(PHP 5 >= 5.1.0, PHP 7)

XMLReader::open — Çözemlenecek XML belgeyi içeren adresi belirler

Açıklama

bool XMLReader::open ( string $URI [, string $kodlama [, int $seçenekler = 0 ]] )

Çözemlenecek XML belgeyi içeren adresi belirler.

Değiştirgeler

URI

Belgenin adresi.

kodlama

Belgenin karakter kodlaması veya NULL.

seçenekler

LIBXML_* sabitlerinden oluşan bir bit maskesi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.2.0 | kodlama ve seçenekler değiştirgeleri eklendi.

Ayrıca Bakınız

  • XMLReader::xml() - Çözümlenecek XML belge içeriği belirtilir
  • XMLReader::close() - XMLReader girdisini kapatır

XMLReader::next
XMLReader::read
XMLReader


Belgedeki sonraki düğüme gidilir

XMLReader::open
XMLReader::readInnerXML
XMLReader
PHP Manual

XMLReader::read

(PHP 5 >= 5.1.0, PHP 7)

XMLReader::read — Belgedeki sonraki düğüme gidilir

Açıklama

bool XMLReader::read ( void )

İmleci belgede sonraki düğüme konumlandırır.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLReader::moveToElement() - İmleci geçerli özniteliğin ebeveyn elemanına konumlar
  • XMLReader::moveToAttribute() - İmleci ismi belirtilen özniteliğe konumlar
  • XMLReader::next() - Alt ağaçların tümünü atlayıp sonraki düğüme gider

XMLReader::open
XMLReader::readInnerXML
XMLReader


Geçerli düğümün içeriğini okur

XMLReader::read
XMLReader::readOuterXML
XMLReader
PHP Manual

XMLReader::readInnerXML

(PHP 5 >= 5.2.0, PHP 7)

XMLReader::readInnerXML — Geçerli düğümün içeriğini okur

Açıklama

string XMLReader::readInnerXML ( void )

Geçerli düğümün içeriğini, çocuk düğümler ve imlenimle birlikte okur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Geçerli düğümün içeriğini bir dizge olarak döndürür. Başarısızlık durumunda boş dizge döner.

Notlar

Dikkat

Bu işlev sadece PHP, libxml 20620 veya sonraki bir sürüm kullanılarak derlendiği takdirde kullanılabilir.

Ayrıca Bakınız

  • XMLReader::readString() - Geçerli düğümün içeriğini bir dizge olarak okur
  • XMLReader::readOuterXML() - Geçerli düğümün içeriğini düğümün kendisiyle birlikte okur
  • XMLReader::expand() - Geçerli düğümün bir kopyasını bir DOM nesnesi olarak döndürür

XMLReader::read
XMLReader::readOuterXML
XMLReader


Geçerli düğümün içeriğini düğümün kendisiyle birlikte okur

XMLReader::readInnerXML
XMLReader::readString
XMLReader
PHP Manual

XMLReader::readOuterXML

(PHP 5 >= 5.2.0, PHP 7)

XMLReader::readOuterXML — Geçerli düğümün içeriğini düğümün kendisiyle birlikte okur

Açıklama

string XMLReader::readOuterXML ( void )

Geçerli düğümün içeriğini düğümün kendisiyle birlikte okur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Geçerli düğümün içeriğini düğümün kendisiyle birlikte bir dizge olarak döndürür. Başarısızlık durumunda boş dizge döner.

Notlar

Dikkat

Bu işlev sadece PHP, libxml 20620 veya sonraki bir sürüm kullanılarak derlendiği takdirde kullanılabilir.

Ayrıca Bakınız

  • XMLReader::readString() - Geçerli düğümün içeriğini bir dizge olarak okur
  • XMLReader::readInnerXML() - Geçerli düğümün içeriğini okur
  • XMLReader::expand() - Geçerli düğümün bir kopyasını bir DOM nesnesi olarak döndürür

XMLReader::readInnerXML
XMLReader::readString
XMLReader


Geçerli düğümün içeriğini bir dizge olarak okur

XMLReader::readOuterXML
XMLReader::setParserProperty
XMLReader
PHP Manual

XMLReader::readString

(PHP 5 >= 5.2.0, PHP 7)

XMLReader::readString — Geçerli düğümün içeriğini bir dizge olarak okur

Açıklama

string XMLReader::readString ( void )

Geçerli düğümün içeriğini bir dizge olarak okur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Geçerli düğümün içeriğini bir dizge olarak döndürür. Başarısızlık durumunda boş dizge döner.

Notlar

Dikkat

Bu işlev sadece PHP, libxml 20620 veya sonraki bir sürüm kullanılarak derlendiği takdirde kullanılabilir.

Ayrıca Bakınız

  • XMLReader::readOuterXML() - Geçerli düğümün içeriğini düğümün kendisiyle birlikte okur
  • XMLReader::readInnerXML() - Geçerli düğümün içeriğini okur
  • XMLReader::expand() - Geçerli düğümün bir kopyasını bir DOM nesnesi olarak döndürür

XMLReader::readOuterXML
XMLReader::setParserProperty
XMLReader


Çözümleyici seçeneklerini tanımlar

XMLReader::readString
XMLReader::setRelaxNGSchema
XMLReader
PHP Manual

XMLReader::setParserProperty

(PHP 5 >= 5.1.0, PHP 7)

XMLReader::setParserProperty — Çözümleyici seçeneklerini tanımlar

Açıklama

bool XMLReader::setParserProperty ( int $seçenek , bool $etkin )

Çözümleyici seçeneklerini etkin veya etkisiz kılar. Seçeneklerin
xmlreader-open() veya
xmlreader-xml() çağrıldıktan sonra
xmlreader-read() çağrılmadan önce belirlenmesi gerekir.

Değiştirgeler

seçenek

Çözümleyici seçeneği sabitlerinden biri.

etkin

TRUE atanırsa seçenek etkin olur, aksi takdirde seçenek etkisiz olur.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

XMLReader::readString
XMLReader::setRelaxNGSchema
XMLReader


Belgeyi RelaxNG şemasına göre doğrular

XMLReader::setParserProperty
XMLReader::setRelaxNGSchemaSource
XMLReader
PHP Manual

XMLReader::setRelaxNGSchema

(PHP 5 >= 5.2.0, PHP 7)

XMLReader::setRelaxNGSchema — Belgeyi RelaxNG şemasına göre doğrular

Açıklama

bool XMLReader::setRelaxNGSchema ( string $dosya )

XML belgeyi doğrulamak için dosya ile belirtilen RelaxNG şeması kullanılır.

Değiştirgeler

dosya

RelaxNG şemasının dosya yolu veya adresi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLReader::setRelaxNGSchemaSource() - Belgeyi dizge olarak belirtilen RelaxNG şemasına göre doğrular

XMLReader::setParserProperty
XMLReader::setRelaxNGSchemaSource
XMLReader


Belgeyi dizge olarak belirtilen RelaxNG şemasına göre doğrular

XMLReader::setRelaxNGSchema
XMLReader::setSchema
XMLReader
PHP Manual

XMLReader::setRelaxNGSchemaSource

(PHP 5 >= 5.1.0, PHP 7)

XMLReader::setRelaxNGSchemaSource — Belgeyi dizge olarak belirtilen RelaxNG şemasına göre doğrular

Açıklama

bool XMLReader::setRelaxNGSchemaSource ( string $kaynak )

XML belgeyi doğrulamak için kaynak dizgesi ile belirtilen RelaxNG şeması kullanılır.

Değiştirgeler

kaynak

RelaxNG şemasını içeren dizge.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLReader::setRelaxNGSchema() - Belgeyi RelaxNG şemasına göre doğrular

XMLReader::setRelaxNGSchema
XMLReader::setSchema
XMLReader


Belgeyi XSD şemasına göre doğrular

XMLReader::setRelaxNGSchemaSource
XMLReader::XML
XMLReader
PHP Manual

XMLReader::setSchema

(PHP 5 >= 5.2.0, PHP 7)

XMLReader::setSchema — Belgeyi XSD şemasına göre doğrular

Açıklama

bool XMLReader::setSchema ( string $dosya )

XML belgeyi doğrulamak için dosya ile belirtilen W3C XSD şeması kullanılır. Etkinleştirme sadece ilk XMLReader::read() öncesi mümkündür.

Değiştirgeler

dosya

XSD şemasının dosya yolu.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Hatalar/İstisnalar

libxml şema desteği olmaksızın derlenmişse, şema hatalıysa veya daha önce bir XMLReader::read() çağrısı yapılmışsa bir E_WARNING çıktılanır.

Notlar

Dikkat

Bu işlev sadece PHP, libxml 20620 veya sonraki bir sürüm kullanılarak derlendiği takdirde kullanılabilir.

Ayrıca Bakınız

  • XMLReader::setRelaxNGSchema() - Belgeyi RelaxNG şemasına göre doğrular

XMLReader::setRelaxNGSchemaSource
XMLReader::XML
XMLReader


Çözümlenecek XML belge içeriği belirtilir

XMLReader::setSchema
XMLWriter
XMLReader
PHP Manual

XMLReader::XML

(PHP 5 >= 5.1.0, PHP 7)

XMLReader::XML — Çözümlenecek XML belge içeriği belirtilir

Açıklama

bool XMLReader::xml ( string $kaynak [, string $kodlama [, int $seçenekler = 0 ]] )

Çözümlenecek XML belge içeriğini belirtmek için kullanılır.

Değiştirgeler

kaynak

Çözümlenecek XML belgeyi içeren dizge.

kodlama

Belgenin karakter kodlaması veya NULL.

seçenekler

LIBXML_* sabitlerinden oluşan bir bit maskesi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
5.2.0 | kodlama ve seçenekler değiştirgeleri eklendi.

Ayrıca Bakınız

  • XMLReader::open() - Çözemlenecek XML belgeyi içeren adresi belirler
  • XMLReader::close() - XMLReader girdisini kapatır

XMLReader::setSchema
XMLWriter
XMLReader


XMLWriter

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • XMLWriter İşlevleri
    • XMLWriter::endAttribute — Geçerli özniteliği sonlandırır
    • XMLWriter::endCData — Geçerli CDATA bölümünü kapatır
    • XMLWriter::endComment — Geçerli açıklamayı kapatır
    • XMLWriter::endDocument — Geçerli belgeyi sonlandırır
    • XMLWriter::endDTDAttlist — Geçerli DTD öznitelik listesi bildirimini kapatır
    • XMLWriter::endDTDElement — Geçerli DTD eleman bildirimini kapatır
    • XMLWriter::endDTDEntity — Geçerli DTD öğe bildirimini kapatır
    • XMLWriter::endDTD — Geçerli DTD'yi kapatır
    • XMLWriter::endElement — Geçerli elemanı kapatır
    • XMLWriter::endPI — Geçerli işlem komutunu kapatır
    • XMLWriter::flush — Geçerli tamponu boşaltır
    • XMLWriter::fullEndElement — Geçerli elemanı kapatır
    • XMLWriter::openMemory — Dizge çıktılamak için belleği kullanmak üzere yeni bir XMLWriter nesnesi oluşturur
    • XMLWriter::openURI — Çıktı için kaynak adresini kullanarak yeni bir XMLWriter nesnesi oluşturur
    • XMLWriter::outputMemory — Geçerli tamponu döndürür
    • XMLWriter::setIndentString — Girintileme için kullanılacak dizgeyi belirler
    • XMLWriter::setIndent — Girintilemeyi açıp kapar
    • XMLWriter::startAttributeNS — İsim alanlı bir öznitelik başlatır
    • XMLWriter::startAttribute — Bir öznitelik başlatır
    • XMLWriter::startCData — Bir CDATA bölümü başlatır
    • XMLWriter::startComment — Bir açıklama başlatır
    • XMLWriter::startDocument — Belgenin XML bildirimini yazar
    • XMLWriter::startDTDAttlist — Bir DTD öznitelik listesi bildirimini başlatır
    • XMLWriter::startDTDElement — Bir DTD eleman bildirimini başlatır
    • XMLWriter::startDTDEntity — Bir DTD öğe bildirimini başlatır
    • XMLWriter::startDTD — Bir DTD başlangıç etiketi oluşturur
    • XMLWriter::startElementNS — Bir isim alanlı eleman başlangıç etiketi oluşturur
    • XMLWriter::startElement — Bir eleman başlangıç etiketi oluşturur
    • XMLWriter::startPI — Bir işlem komutu başlangıç etiketi oluşturur
    • XMLWriter::text — Bir metni yazar
    • XMLWriter::writeAttributeNS — İsim alanlı öznitelik yazar
    • XMLWriter::writeAttribute — Öznitelik yazar
    • XMLWriter::writeCData — CDATA yazar
    • XMLWriter::writeComment — Açıklama yazar
    • XMLWriter::writeDTDAttlist — DTD öznitelik listesi yazar
    • XMLWriter::writeDTDElement — DTD elemanını yazar
    • XMLWriter::writeDTDEntity — DTD öğesini yazar
    • XMLWriter::writeDTD — DTD'yi yazar
    • XMLWriter::writeElementNS — İsim alanlı elemanı içeriğiyle birlikte yazar
    • XMLWriter::writeElement — Elemanı içeriğiyle birlikte yazar
    • XMLWriter::writePI — Bir işlem komutu (PI) yazar
    • XMLWriter::writeRaw — Ham XML metni yazar
XMLReader::XML
Giriş
XML İşleme


Giriş

Bu eklenti, libxml kütüphanesinin xmlWriter arayüzünün sarmalayıcısıdır.

Bu eklenti, XML veri içeren dosyalar veya akımlar üretmek anlamında tek yönlü ve önbelleklemesiz olarak bir XML yazıcı gerçekler.

Eklenti, nesne yönelimli kullanılabileceği gibi yordamsal olarak da kullanılabilir, Her yöntemin belgesinde yordamsal kullanım da açıklanmıştır.

XMLWriter
Yapılandırma/Kurulum
XMLWriter


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
XMLWriter


Kurulum

Bu eklenti PHP 5.1.2'den beri öntanımlı olarak etkindir.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Özkaynak Türleri

XMLWriter eklentisinin yordamsal sürümü tarafından kullanılan tek bir özkaynağı vardır ve bu özkaynak xmlwriter_open_memory() veya xmlwriter_open_uri() işlevi tarafından döndürülür.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Bu eklentinin tanımlanmış sabitleri yoktur.

Özkaynak Türleri
XMLWriter İşlevleri
XMLWriter


XMLWriter İşlevleri

İçindekiler

  • XMLWriter::endAttribute — Geçerli özniteliği sonlandırır
  • XMLWriter::endCData — Geçerli CDATA bölümünü kapatır
  • XMLWriter::endComment — Geçerli açıklamayı kapatır
  • XMLWriter::endDocument — Geçerli belgeyi sonlandırır
  • XMLWriter::endDTDAttlist — Geçerli DTD öznitelik listesi bildirimini kapatır
  • XMLWriter::endDTDElement — Geçerli DTD eleman bildirimini kapatır
  • XMLWriter::endDTDEntity — Geçerli DTD öğe bildirimini kapatır
  • XMLWriter::endDTD — Geçerli DTD'yi kapatır
  • XMLWriter::endElement — Geçerli elemanı kapatır
  • XMLWriter::endPI — Geçerli işlem komutunu kapatır
  • XMLWriter::flush — Geçerli tamponu boşaltır
  • XMLWriter::fullEndElement — Geçerli elemanı kapatır
  • XMLWriter::openMemory — Dizge çıktılamak için belleği kullanmak üzere yeni bir XMLWriter nesnesi oluşturur
  • XMLWriter::openURI — Çıktı için kaynak adresini kullanarak yeni bir XMLWriter nesnesi oluşturur
  • XMLWriter::outputMemory — Geçerli tamponu döndürür
  • XMLWriter::setIndentString — Girintileme için kullanılacak dizgeyi belirler
  • XMLWriter::setIndent — Girintilemeyi açıp kapar
  • XMLWriter::startAttributeNS — İsim alanlı bir öznitelik başlatır
  • XMLWriter::startAttribute — Bir öznitelik başlatır
  • XMLWriter::startCData — Bir CDATA bölümü başlatır
  • XMLWriter::startComment — Bir açıklama başlatır
  • XMLWriter::startDocument — Belgenin XML bildirimini yazar
  • XMLWriter::startDTDAttlist — Bir DTD öznitelik listesi bildirimini başlatır
  • XMLWriter::startDTDElement — Bir DTD eleman bildirimini başlatır
  • XMLWriter::startDTDEntity — Bir DTD öğe bildirimini başlatır
  • XMLWriter::startDTD — Bir DTD başlangıç etiketi oluşturur
  • XMLWriter::startElementNS — Bir isim alanlı eleman başlangıç etiketi oluşturur
  • XMLWriter::startElement — Bir eleman başlangıç etiketi oluşturur
  • XMLWriter::startPI — Bir işlem komutu başlangıç etiketi oluşturur
  • XMLWriter::text — Bir metni yazar
  • XMLWriter::writeAttributeNS — İsim alanlı öznitelik yazar
  • XMLWriter::writeAttribute — Öznitelik yazar
  • XMLWriter::writeCData — CDATA yazar
  • XMLWriter::writeComment — Açıklama yazar
  • XMLWriter::writeDTDAttlist — DTD öznitelik listesi yazar
  • XMLWriter::writeDTDElement — DTD elemanını yazar
  • XMLWriter::writeDTDEntity — DTD öğesini yazar
  • XMLWriter::writeDTD — DTD'yi yazar
  • XMLWriter::writeElementNS — İsim alanlı elemanı içeriğiyle birlikte yazar
  • XMLWriter::writeElement — Elemanı içeriğiyle birlikte yazar
  • XMLWriter::writePI — Bir işlem komutu (PI) yazar
  • XMLWriter::writeRaw — Ham XML metni yazar
Öntanımlı Sabitler
XMLWriter::endAttribute
XMLWriter


Geçerli özniteliği sonlandırır

XMLWriter İşlevleri
XMLWriter::endCData
XMLWriter İşlevleri
PHP Manual

XMLWriter::endAttribute

(PHP 5 >= 5.1.2, PHP 7, PECL xmlwriter >= 0.1.0)

XMLWriter::endAttribute — Geçerli özniteliği sonlandırır

Açıklama

Nesne yönelimli kullanım

bool endAttribute ( void )

Yordamsal kullanım

bool xmlwriter_end_attribute ( resource $xmlwriter )

Geçerli özniteliği sonlandırır.

Değiştirgeler

xmlwriter

Sadece yordamsal kullanım için. xmlwriter_open_uri() veya xmlwriter_open_memory() çağrılarıyla elde edilen, üzerinde işlem yapılacak XMLWriter özkaynağı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLWriter::startAttribute() - Bir öznitelik başlatır
  • XMLWriter::startAttributeNS() - İsim alanlı bir öznitelik başlatır
  • XMLWriter::writeAttribute() - Öznitelik yazar
  • XMLWriter::writeAttributeNS() - İsim alanlı öznitelik yazar

XMLWriter İşlevleri
XMLWriter::endCData
XMLWriter İşlevleri


Geçerli CDATA bölümünü kapatır

XMLWriter::endAttribute
XMLWriter::endComment
XMLWriter İşlevleri
PHP Manual

XMLWriter::endCData

(PHP 5 >= 5.1.2, PHP 7, PECL xmlwriter >= 0.1.0)

XMLWriter::endCData — Geçerli CDATA bölümünü kapatır

Açıklama

Nesne yönelimli kullanım

bool endCData ( void )

Yordamsal kullanım

bool xmlwriter_end_cdata ( resource $xmlwriter )

Geçerli CDATA bölümünü kapatır.

Değiştirgeler

xmlwriter

Sadece yordamsal kullanım için. xmlwriter_open_uri() veya xmlwriter_open_memory() çağrılarıyla elde edilen, üzerinde işlem yapılacak XMLWriter özkaynağı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLWriter::startCData() - Bir CDATA bölümü başlatır
  • XMLWriter::writeCData() - CDATA yazar

XMLWriter::endAttribute
XMLWriter::endComment
XMLWriter İşlevleri


Geçerli açıklamayı kapatır

XMLWriter::endCData
XMLWriter::endDocument
XMLWriter İşlevleri
PHP Manual

XMLWriter::endComment

(PHP 5 >= 5.1.2, PHP 7, PECL xmlwriter >= 1.0.0)

XMLWriter::endComment — Geçerli açıklamayı kapatır

Açıklama

Nesne yönelimli kullanım

bool endComment ( void )

Yordamsal kullanım

bool xmlwriter_end_comment ( resource $xmlwriter )

Geçerli açıklamayı kapatır.

Değiştirgeler

xmlwriter

Sadece yordamsal kullanım için. xmlwriter_open_uri() veya xmlwriter_open_memory() çağrılarıyla elde edilen, üzerinde işlem yapılacak XMLWriter özkaynağı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLWriter::startComment() - Bir açıklama başlatır
  • XMLWriter::writeComment() - Açıklama yazar

XMLWriter::endCData
XMLWriter::endDocument
XMLWriter İşlevleri


Geçerli belgeyi sonlandırır

XMLWriter::endComment
XMLWriter::endDTDAttlist
XMLWriter İşlevleri
PHP Manual

XMLWriter::endDocument

(PHP 5 >= 5.1.2, PHP 7, PECL xmlwriter >= 0.1.0)

XMLWriter::endDocument — Geçerli belgeyi sonlandırır

Açıklama

Nesne yönelimli kullanım

bool endDocument ( void )

Yordamsal kullanım

bool xmlwriter_end_document ( resource $xmlwriter )

Geçerli belgeyi sonlandırır.

Değiştirgeler

xmlwriter

Sadece yordamsal kullanım için. xmlwriter_open_uri() veya xmlwriter_open_memory() çağrılarıyla elde edilen, üzerinde işlem yapılacak XMLWriter özkaynağı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLWriter::startDocument() - Belgenin XML bildirimini yazar

XMLWriter::endComment
XMLWriter::endDTDAttlist
XMLWriter İşlevleri


Geçerli DTD öznitelik listesi bildirimini kapatır

XMLWriter::endDocument
XMLWriter::endDTDElement
XMLWriter İşlevleri
PHP Manual

XMLWriter::endDTDAttlist

(PHP 5 >= 5.1.2, PHP 7, PECL xmlwriter >= 0.1.0)

XMLWriter::endDTDAttlist — Geçerli DTD öznitelik listesi bildirimini kapatır

Açıklama

Nesne yönelimli kullanım

bool endDTDAttlist ( void )

Yordamsal kullanım

bool xmlwriter_end_dtd_attlist ( resource $xmlwriter )

Geçerli DTD öznitelik listesi bildirimini kapatır.

Değiştirgeler

xmlwriter

Sadece yordamsal kullanım için. xmlwriter_open_uri() veya xmlwriter_open_memory() çağrılarıyla elde edilen, üzerinde işlem yapılacak XMLWriter özkaynağı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLWriter::startDTDAttlist() - Bir DTD öznitelik listesi bildirimini başlatır
  • XMLWriter::writeDTDAttlist() - DTD öznitelik listesi yazar

XMLWriter::endDocument
XMLWriter::endDTDElement
XMLWriter İşlevleri


Geçerli DTD eleman bildirimini kapatır

XMLWriter::endDTDAttlist
XMLWriter::endDTDEntity
XMLWriter İşlevleri
PHP Manual

XMLWriter::endDTDElement

(PHP 5 >= 5.1.2, PHP 7, PECL xmlwriter >= 0.1.0)

XMLWriter::endDTDElement — Geçerli DTD eleman bildirimini kapatır

Açıklama

Nesne yönelimli kullanım

bool endDTDElement ( void )

Yordamsal kullanım

bool xmlwriter_end_dtd_element ( resource $xmlwriter )

Geçerli DTD eleman bildirimini kapatır.

Değiştirgeler

xmlwriter

Sadece yordamsal kullanım için. xmlwriter_open_uri() veya xmlwriter_open_memory() çağrılarıyla elde edilen, üzerinde işlem yapılacak XMLWriter özkaynağı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLWriter::startDTDElement() - Bir DTD eleman bildirimini başlatır
  • XMLWriter::writeDTDElement() - DTD elemanını yazar

XMLWriter::endDTDAttlist
XMLWriter::endDTDEntity
XMLWriter İşlevleri


Geçerli DTD öğe bildirimini kapatır

XMLWriter::endDTDElement
XMLWriter::endDTD
XMLWriter İşlevleri
PHP Manual

XMLWriter::endDTDEntity

(PHP 5 >= 5.1.2, PHP 7, PECL xmlwriter >= 0.1.0)

XMLWriter::endDTDEntity — Geçerli DTD öğe bildirimini kapatır

Açıklama

Nesne yönelimli kullanım

bool endDTDEntity ( void )

Yordamsal kullanım

bool xmlwriter_end_dtd_entity ( resource $xmlwriter )

Geçerli DTD öğe bildirimini kapatır.

Değiştirgeler

xmlwriter

Sadece yordamsal kullanım için. xmlwriter_open_uri() veya xmlwriter_open_memory() çağrılarıyla elde edilen, üzerinde işlem yapılacak XMLWriter özkaynağı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLWriter::startDTDEntity() - Bir DTD öğe bildirimini başlatır
  • XMLWriter::writeDTDEntity() - DTD öğesini yazar

XMLWriter::endDTDElement
XMLWriter::endDTD
XMLWriter İşlevleri


Geçerli DTD'yi kapatır

XMLWriter::endDTDEntity
XMLWriter::endElement
XMLWriter İşlevleri
PHP Manual

XMLWriter::endDTD

(PHP 5 >= 5.1.2, PHP 7, PECL xmlwriter >= 0.1.0)

XMLWriter::endDTD — Geçerli DTD'yi kapatır

Açıklama

Nesne yönelimli kullanım

bool endDTD ( void )

Yordamsal kullanım

bool xmlwriter_end_dtd ( resource $xmlwriter )

Belgenin DTD bölümünü kapatır.

Değiştirgeler

xmlwriter

Sadece yordamsal kullanım için. xmlwriter_open_uri() veya xmlwriter_open_memory() çağrılarıyla elde edilen, üzerinde işlem yapılacak XMLWriter özkaynağı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLWriter::startDTD() - Bir DTD başlangıç etiketi oluşturur
  • XMLWriter::writeDTD() - DTD'yi yazar

XMLWriter::endDTDEntity
XMLWriter::endElement
XMLWriter İşlevleri


Geçerli elemanı kapatır

XMLWriter::endDTD
XMLWriter::endPI
XMLWriter İşlevleri
PHP Manual

XMLWriter::endElement

(PHP 5 >= 5.1.2, PHP 7, PECL xmlwriter >= 0.1.0)

XMLWriter::endElement — Geçerli elemanı kapatır

Açıklama

Nesne yönelimli kullanım

bool endElement ( void )

Yordamsal kullanım

bool xmlwriter_end_element ( resource $xmlwriter )

Geçerli elemanı kapatır.

Değiştirgeler

xmlwriter

Sadece yordamsal kullanım için. xmlwriter_open_uri() veya xmlwriter_open_memory() çağrılarıyla elde edilen, üzerinde işlem yapılacak XMLWriter özkaynağı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLWriter::startElement() - Bir eleman başlangıç etiketi oluşturur
  • XMLWriter::writeElement() - Elemanı içeriğiyle birlikte yazar

XMLWriter::endDTD
XMLWriter::endPI
XMLWriter İşlevleri


Geçerli işlem komutunu kapatır

XMLWriter::endElement
XMLWriter::flush
XMLWriter İşlevleri
PHP Manual

XMLWriter::endPI

(PHP 5 >= 5.1.2, PHP 7, PECL xmlwriter >= 0.1.0)

XMLWriter::endPI — Geçerli işlem komutunu kapatır

Açıklama

Nesne yönelimli kullanım

bool endPI ( void )

Yordamsal kullanım

bool xmlwriter_end_pi ( resource $xmlwriter )

Geçerli işlem komutunu kapatır.

Değiştirgeler

xmlwriter

Sadece yordamsal kullanım için. xmlwriter_open_uri() veya xmlwriter_open_memory() çağrılarıyla elde edilen, üzerinde işlem yapılacak XMLWriter özkaynağı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLWriter::startPI() - Bir işlem komutu başlangıç etiketi oluşturur
  • XMLWriter::writePI() - Bir işlem komutu (PI) yazar

XMLWriter::endElement
XMLWriter::flush
XMLWriter İşlevleri


Geçerli tamponu boşaltır

XMLWriter::endPI
XMLWriter::fullEndElement
XMLWriter İşlevleri
PHP Manual

XMLWriter::flush

(PHP 5 >= 5.1.2, PHP 7, PECL xmlwriter >= 1.0.0)

XMLWriter::flush — Geçerli tamponu boşaltır

Açıklama

Nesne yönelimli kullanım

mixed flush ([ bool $boş ] )

Yordamsal kullanım

mixed xmlwriter_flush ( resource $xmlwriter [, bool $boş ] )

Geçerli tamponu boşaltır.

Değiştirgeler

xmlwriter

Sadece yordamsal kullanım için. xmlwriter_open_uri() veya xmlwriter_open_memory() çağrılarıyla elde edilen, üzerinde işlem yapılacak XMLWriter özkaynağı.

boş

Tamponun içeriği boşaltılmayacaksa FALSE belirtilir. TRUE öntanımlıdır.

Dönen Değerler

Nesneyi bellekte oluşturmuşsanız bu işlev üretilen XML tamponunu döndürür. Çıktı için bir adres kullanıyorsanız bu işlev tampona yazar ve yazılan baytların sayısını döndürür.

XMLWriter::endPI
XMLWriter::fullEndElement
XMLWriter İşlevleri


Geçerli elemanı kapatır

XMLWriter::flush
XMLWriter::openMemory
XMLWriter İşlevleri
PHP Manual

XMLWriter::fullEndElement

(PHP 5 >= 5.2.0, PHP 7, PECL xmlwriter >= 2.0.4)

XMLWriter::fullEndElement — Geçerli elemanı kapatır

Açıklama

Nesne yönelimli kullanım

bool fullEndElement ( void )

Yordamsal kullanım

bool xmlwriter_full_end_element ( resource $xmlwriter )

Geçerli elemanı kapatır. Eleman boş olsa bile kapama etiketini yazar.

Değiştirgeler

xmlwriter

Sadece yordamsal kullanım için. xmlwriter_open_uri() veya xmlwriter_open_memory() çağrılarıyla elde edilen, üzerinde işlem yapılacak XMLWriter özkaynağı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLWriter::endElement() - Geçerli elemanı kapatır

XMLWriter::flush
XMLWriter::openMemory
XMLWriter İşlevleri


Dizge çıktılamak için belleği kullanmak üzere yeni bir XMLWriter nesnesi oluşturur

XMLWriter::fullEndElement
XMLWriter::openURI
XMLWriter İşlevleri
PHP Manual

XMLWriter::openMemory

(PHP 5 >= 5.1.2, PHP 7, PECL xmlwriter >= 0.1.0)

XMLWriter::openMemory — Dizge çıktılamak için belleği kullanmak üzere yeni bir XMLWriter nesnesi oluşturur

Açıklama

Nesne yönelimli kullanım

bool openMemory ( void )

Yordamsal kullanım

resource xmlwriter_open_memory ( void )

Dizge çıktılamak için belleği kullanmak üzere yeni bir XMLWriter nesnesi oluşturur.

Değiştirgeler

Dönen Değerler

Nesne yönelimli kullanım: Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Yordamsal kullanım: Başarı durumunda XMLWriter işlevleri ile kullanılmak üzere yeni bir XMLWriter özkaynağı, aksi takdirde FALSE döndürür.

Ayrıca Bakınız

  • XMLWriter::openURI() - Çıktı için kaynak adresini kullanarak yeni bir XMLWriter nesnesi oluşturur

XMLWriter::fullEndElement
XMLWriter::openURI
XMLWriter İşlevleri


Çıktı için kaynak adresini kullanarak yeni bir XMLWriter nesnesi oluşturur

XMLWriter::openMemory
XMLWriter::outputMemory
XMLWriter İşlevleri
PHP Manual

XMLWriter::openURI

(PHP 5 >= 5.1.2, PHP 7, PECL xmlwriter >= 0.1.0)

XMLWriter::openURI — Çıktı için kaynak adresini kullanarak yeni bir XMLWriter nesnesi oluşturur

Açıklama

Nesne yönelimli kullanım

bool openURI ( string $uri )

Yordamsal kullanım

resource xmlwriter_open_uri ( string $uri )

Çıktı için uri ile belirtilen kaynak adresini kullanarak yeni bir XMLWriter nesnesi oluşturur.

Değiştirgeler

uri

Çıktılanacak özkaynağın adresi.

Dönen Değerler

Nesne yönelimli kullanım: Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Yordamsal kullanım: Başarı durumunda XMLWriter işlevleri ile kullanılmak üzere yeni bir XMLWriter özkaynağı, aksi takdirde FALSE döndürür.

Ayrıca Bakınız

  • XMLWriter::openMemory() - Dizge çıktılamak için belleği kullanmak üzere yeni bir XMLWriter nesnesi oluşturur

XMLWriter::openMemory
XMLWriter::outputMemory
XMLWriter İşlevleri


Geçerli tamponu döndürür

XMLWriter::openURI
XMLWriter::setIndentString
XMLWriter İşlevleri
PHP Manual

XMLWriter::outputMemory

(PHP 5 >= 5.1.2, PHP 7, PECL xmlwriter >= 0.1.0)

XMLWriter::outputMemory — Geçerli tamponu döndürür

Açıklama

Nesne yönelimli kullanım

string outputMemory ([ bool $boşalt ] )

Yordamsal kullanım

string xmlwriter_output_memory ( resource $xmlwriter [, bool $boşalt ] )

Geçerli tamponu döndürür.

Değiştirgeler

xmlwriter

Sadece yordamsal kullanım için. xmlwriter_open_uri() veya xmlwriter_open_memory() çağrılarıyla elde edilen, üzerinde işlem yapılacak XMLWriter özkaynağı.

boşalt

Çıktı tamponu boşaltılmayacaksa FALSE belirtilir. TRUE öntanımlıdır.

Dönen Değerler

Geçerli tamponun içeriğini bir dizge olarak döndürür.

Ayrıca Bakınız

  • XMLWriter::flush() - Geçerli tamponu boşaltır

XMLWriter::openURI
XMLWriter::setIndentString
XMLWriter İşlevleri


Girintileme için kullanılacak dizgeyi belirler

XMLWriter::outputMemory
XMLWriter::setIndent
XMLWriter İşlevleri
PHP Manual

XMLWriter::setIndentString

(PHP 5 >= 5.1.2, PHP 7, PECL xmlwriter >= 0.1.0)

XMLWriter::setIndentString — Girintileme için kullanılacak dizgeyi belirler

Açıklama

Nesne yönelimli kullanım

bool setIndentString ( string $girintiDizgesi )

Yordamsal kullanım

bool xmlwriter_set_indent_string ( resource $xmlwriter , string $girintiDizgesi )

XML belgedeki her elemanı girintilemekte kullanılacak dizgeyi belirler.

Değiştirgeler

xmlwriter

Sadece yordamsal kullanım için. xmlwriter_open_uri() veya xmlwriter_open_memory() çağrılarıyla elde edilen, üzerinde işlem yapılacak XMLWriter özkaynağı.

girintiDizgesi

Girintileme dizgesi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLWriter::setIndent() - Girintilemeyi açıp kapar

XMLWriter::outputMemory
XMLWriter::setIndent
XMLWriter İşlevleri


Girintilemeyi açıp kapar

XMLWriter::setIndentString
XMLWriter::startAttributeNS
XMLWriter İşlevleri
PHP Manual

XMLWriter::setIndent

(PHP 5 >= 5.1.2, PHP 7, PECL xmlwriter >= 0.1.0)

XMLWriter::setIndent — Girintilemeyi açıp kapar

Açıklama

Nesne yönelimli kullanım

bool setIndent ( bool $girinti )

Yordamsal kullanım

bool xmlwriter_set_indent ( resource $xmlwriter , bool $girinti )

Girintilemeyi açıp kapar.

Değiştirgeler

xmlwriter

Sadece yordamsal kullanım için. xmlwriter_open_uri() veya xmlwriter_open_memory() çağrılarıyla elde edilen, üzerinde işlem yapılacak XMLWriter özkaynağı.

girinti

Girintileme etkin olacaksa TRUE belirtilir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLWriter::setIndentString() - Girintileme için kullanılacak dizgeyi belirler

XMLWriter::setIndentString
XMLWriter::startAttributeNS
XMLWriter İşlevleri


İsim alanlı bir öznitelik başlatır

XMLWriter::setIndent
XMLWriter::startAttribute
XMLWriter İşlevleri
PHP Manual

XMLWriter::startAttributeNS

(PHP 5 >= 5.1.2, PHP 7, PECL xmlwriter >= 0.1.0)

XMLWriter::startAttributeNS — İsim alanlı bir öznitelik başlatır

Açıklama

Nesne yönelimli kullanım

bool startAttributeNS ( string $önek , string $isim , string $uri )

Yordamsal kullanım

bool xmlwriter_start_attribute_ns ( resource $xmlwriter , string $önek , string $isim , string $uri )

İsim alanlı bir öznitelik başlatır.

Değiştirgeler

xmlwriter

Sadece yordamsal kullanım için. xmlwriter_open_uri() veya xmlwriter_open_memory() çağrılarıyla elde edilen, üzerinde işlem yapılacak XMLWriter özkaynağı.

önek

İsim alanı öneki.

isim

Özniteliğin ismi.

uri

İsim alanını betimleyen adres.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLWriter::startAttribute() - Bir öznitelik başlatır
  • XMLWriter::endAttribute() - Geçerli özniteliği sonlandırır
  • XMLWriter::writeAttribute() - Öznitelik yazar
  • XMLWriter::writeAttributeNS() - İsim alanlı öznitelik yazar

XMLWriter::setIndent
XMLWriter::startAttribute
XMLWriter İşlevleri


Bir öznitelik başlatır

XMLWriter::startAttributeNS
XMLWriter::startCData
XMLWriter İşlevleri
PHP Manual

XMLWriter::startAttribute

(PHP 5 >= 5.1.2, PHP 7, PECL xmlwriter >= 0.1.0)

XMLWriter::startAttribute — Bir öznitelik başlatır

Açıklama

Nesne yönelimli kullanım

bool startAttribute ( string $isim )

Yordamsal kullanım

bool xmlwriter_start_attribute ( resource $xmlwriter , string $isim )

Bir öznitelik başlatır.

Değiştirgeler

xmlwriter

Sadece yordamsal kullanım için. xmlwriter_open_uri() veya xmlwriter_open_memory() çağrılarıyla elde edilen, üzerinde işlem yapılacak XMLWriter özkaynağı.

isim

Özniteliğin ismi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLWriter::startAttributeNS() - İsim alanlı bir öznitelik başlatır
  • XMLWriter::endAttribute() - Geçerli özniteliği sonlandırır
  • XMLWriter::writeAttribute() - Öznitelik yazar
  • XMLWriter::writeAttributeNS() - İsim alanlı öznitelik yazar

XMLWriter::startAttributeNS
XMLWriter::startCData
XMLWriter İşlevleri


Bir CDATA bölümü başlatır

XMLWriter::startAttribute
XMLWriter::startComment
XMLWriter İşlevleri
PHP Manual

XMLWriter::startCData

(PHP 5 >= 5.1.2, PHP 7, PECL xmlwriter >= 0.1.0)

XMLWriter::startCData — Bir CDATA bölümü başlatır

Açıklama

Nesne yönelimli kullanım

bool startCData ( void )

Yordamsal kullanım

bool xmlwriter_start_cdata ( resource $xmlwriter )

Bir CDATA bölümü başlatır.

Değiştirgeler

xmlwriter

Sadece yordamsal kullanım için. xmlwriter_open_uri() veya xmlwriter_open_memory() çağrılarıyla elde edilen, üzerinde işlem yapılacak XMLWriter özkaynağı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLWriter::endCData() - Geçerli CDATA bölümünü kapatır
  • XMLWriter::writeCData() - CDATA yazar

XMLWriter::startAttribute
XMLWriter::startComment
XMLWriter İşlevleri


Bir açıklama başlatır

XMLWriter::startCData
XMLWriter::startDocument
XMLWriter İşlevleri
PHP Manual

XMLWriter::startComment

(PHP 5 >= 5.1.2, PHP 7, PECL xmlwriter >= 1.0.0)

XMLWriter::startComment — Bir açıklama başlatır

Açıklama

Nesne yönelimli kullanım

bool startComment ( void )

Yordamsal kullanım

bool xmlwriter_start_comment ( resource $xmlwriter )

Bir açıklama başlatır.

Değiştirgeler

xmlwriter

Sadece yordamsal kullanım için. xmlwriter_open_uri() veya xmlwriter_open_memory() çağrılarıyla elde edilen, üzerinde işlem yapılacak XMLWriter özkaynağı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLWriter::endComment() - Geçerli açıklamayı kapatır
  • XMLWriter::writeComment() - Açıklama yazar

XMLWriter::startCData
XMLWriter::startDocument
XMLWriter İşlevleri


Belgenin XML bildirimini yazar

XMLWriter::startComment
XMLWriter::startDTDAttlist
XMLWriter İşlevleri
PHP Manual

XMLWriter::startDocument

(PHP 5 >= 5.1.2, PHP 7, PECL xmlwriter >= 0.1.0)

XMLWriter::startDocument — Belgenin XML bildirimini yazar

Açıklama

Nesne yönelimli kullanım

bool startDocument ([ string $version [, string $encoding [, string $standalone ]]] )

Yordamsal kullanım

bool xmlwriter_start_document ( resource $xmlwriter [, string $version [, string $encoding [, string $standalone = NULL ]]] )

Belgenin XML bildirimini yazar.

Değiştirgeler

xmlwriter

Sadece yordamsal kullanım için. xmlwriter_open_uri() veya xmlwriter_open_memory() çağrılarıyla elde edilen, üzerinde işlem yapılacak XMLWriter özkaynağı.

version

XML bildirimindeki version özniteliğinin değeri. 1.0 öntanımlıdır.

encoding

XML bildirimindeki encoding özniteliğinin değeri. Öntanımlı olarak bu öznitelik belirtilmez.

standalone

XML bildirimindeki standalone özniteliğinin değeri. yes veya no olabilir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLWriter::endDocument() - Geçerli belgeyi sonlandırır

XMLWriter::startComment
XMLWriter::startDTDAttlist
XMLWriter İşlevleri


Bir DTD öznitelik listesi bildirimini başlatır

XMLWriter::startDocument
XMLWriter::startDTDElement
XMLWriter İşlevleri
PHP Manual

XMLWriter::startDTDAttlist

(PHP 5 >= 5.1.2, PHP 7, PECL xmlwriter >= 0.1.0)

XMLWriter::startDTDAttlist — Bir DTD öznitelik listesi bildirimini başlatır

Açıklama

Nesne yönelimli kullanım

bool startDTDAttlist ( string $isim )

Yordamsal kullanım

bool xmlwriter_start_dtd_attlist ( resource $xmlwriter , string $isim )

Bir DTD öznitelik listesi bildirimini başlatır.

Değiştirgeler

xmlwriter

Sadece yordamsal kullanım için. xmlwriter_open_uri() veya xmlwriter_open_memory() çağrılarıyla elde edilen, üzerinde işlem yapılacak XMLWriter özkaynağı.

isim

Öznitelik listesinin ismi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLWriter::endDTDAttlist() - Geçerli DTD öznitelik listesi bildirimini kapatır
  • XMLWriter::writeDTDAttlist() - DTD öznitelik listesi yazar

XMLWriter::startDocument
XMLWriter::startDTDElement
XMLWriter İşlevleri


Bir DTD eleman bildirimini başlatır

XMLWriter::startDTDAttlist
XMLWriter::startDTDEntity
XMLWriter İşlevleri
PHP Manual

XMLWriter::startDTDElement

(PHP 5 >= 5.1.2, PHP 7, PECL xmlwriter >= 0.1.0)

XMLWriter::startDTDElement — Bir DTD eleman bildirimini başlatır

Açıklama

Nesne yönelimli kullanım

bool startDTDElement ( string $isim )

Yordamsal kullanım

bool xmlwriter_start_dtd_element ( resource $xmlwriter , string $isim )

Bir DTD eleman bildirimini başlatır.

Değiştirgeler

xmlwriter

Sadece yordamsal kullanım için. xmlwriter_open_uri() veya xmlwriter_open_memory() çağrılarıyla elde edilen, üzerinde işlem yapılacak XMLWriter özkaynağı.

isim

Elemanın ismi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLWriter::endDTDElement() - Geçerli DTD eleman bildirimini kapatır
  • XMLWriter::writeDTDElement() - DTD elemanını yazar

XMLWriter::startDTDAttlist
XMLWriter::startDTDEntity
XMLWriter İşlevleri


Bir DTD öğe bildirimini başlatır

XMLWriter::startDTDElement
XMLWriter::startDTD
XMLWriter İşlevleri
PHP Manual

XMLWriter::startDTDEntity

(PHP 5 >= 5.1.2, PHP 7, PECL xmlwriter >= 0.1.0)

XMLWriter::startDTDEntity — Bir DTD öğe bildirimini başlatır

Açıklama

Nesne yönelimli kullanım

bool startDTDEntity ( string $isim , bool $değiş_var )

Yordamsal kullanım

bool xmlwriter_start_dtd_entity ( resource $xmlwriter , string $isim , bool $değiş_var )

Bir DTD öğe bildirimini başlatır.

Değiştirgeler

xmlwriter

Sadece yordamsal kullanım için. xmlwriter_open_uri() veya xmlwriter_open_memory() çağrılarıyla elde edilen, üzerinde işlem yapılacak XMLWriter özkaynağı.

isim

Öğe ismi.

değiş_var

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLWriter::endDTDEntity() - Geçerli DTD öğe bildirimini kapatır
  • XMLWriter::writeDTDEntity() - DTD öğesini yazar

XMLWriter::startDTDElement
XMLWriter::startDTD
XMLWriter İşlevleri


Bir DTD başlangıç etiketi oluşturur

XMLWriter::startDTDEntity
XMLWriter::startElementNS
XMLWriter İşlevleri
PHP Manual

XMLWriter::startDTD

(PHP 5 >= 5.1.2, PHP 7, PECL xmlwriter >= 0.1.0)

XMLWriter::startDTD — Bir DTD başlangıç etiketi oluşturur

Açıklama

Nesne yönelimli kullanım

bool startDTD ( string $kök_eleman [, string $publicId [, string $systemId ]] )

Yordamsal kullanım

bool xmlwriter_start_dtd ( resource $xmlwriter , string $kök_eleman [, string $publicId [, string $systemId ]] )

Bir DTD bölümünü başlatır.

Değiştirgeler

xmlwriter

Sadece yordamsal kullanım için. xmlwriter_open_uri() veya xmlwriter_open_memory() çağrılarıyla elde edilen, üzerinde işlem yapılacak XMLWriter özkaynağı.

kök_eleman

Oluşturulacak belgenin kök elemanının ismi.

publicId

Harici alt kümenin genel betimleyicisi.

systemId

Harici alt kümenin sistem betimleyicisi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLWriter::endDTD() - Geçerli DTD'yi kapatır
  • XMLWriter::writeDTD() - DTD'yi yazar

XMLWriter::startDTDEntity
XMLWriter::startElementNS
XMLWriter İşlevleri


Bir isim alanlı eleman başlangıç etiketi oluşturur

XMLWriter::startDTD
XMLWriter::startElement
XMLWriter İşlevleri
PHP Manual

XMLWriter::startElementNS

(PHP 5 >= 5.1.2, PHP 7, PECL xmlwriter >= 0.1.0)

XMLWriter::startElementNS — Bir isim alanlı eleman başlangıç etiketi oluşturur

Açıklama

Nesne yönelimli kullanım

bool startElementNS ( string $önek , string $isim , string $uri )

Yordamsal kullanım

bool xmlwriter_start_element_ns ( resource $xmlwriter , string $önek , string $isim , string $uri )

İsim alanlı bir etiket başlatır.

Değiştirgeler

xmlwriter

Sadece yordamsal kullanım için. xmlwriter_open_uri() veya xmlwriter_open_memory() çağrılarıyla elde edilen, üzerinde işlem yapılacak XMLWriter özkaynağı.

önek

İsim alanı öneki.

isim

Elemanın ismi.

uri

İsim alanını betimleyen adres.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLWriter::endElement() - Geçerli elemanı kapatır
  • XMLWriter::writeElementNS() - İsim alanlı elemanı içeriğiyle birlikte yazar

XMLWriter::startDTD
XMLWriter::startElement
XMLWriter İşlevleri


Bir eleman başlangıç etiketi oluşturur

XMLWriter::startElementNS
XMLWriter::startPI
XMLWriter İşlevleri
PHP Manual

XMLWriter::startElement

(PHP 5 >= 5.1.2, PHP 7, PECL xmlwriter >= 0.1.0)

XMLWriter::startElement — Bir eleman başlangıç etiketi oluşturur

Açıklama

Nesne yönelimli kullanım

bool startElement ( string $isim )

Yordamsal kullanım

bool xmlwriter_start_element ( resource $xmlwriter , string $isim )

Bir elemanı başlatır.

Değiştirgeler

xmlwriter

Sadece yordamsal kullanım için. xmlwriter_open_uri() veya xmlwriter_open_memory() çağrılarıyla elde edilen, üzerinde işlem yapılacak XMLWriter özkaynağı.

isim

Elemanın ismi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLWriter::endElement() - Geçerli elemanı kapatır
  • XMLWriter::writeElement() - Elemanı içeriğiyle birlikte yazar

XMLWriter::startElementNS
XMLWriter::startPI
XMLWriter İşlevleri


Bir işlem komutu başlangıç etiketi oluşturur

XMLWriter::startElement
XMLWriter::text
XMLWriter İşlevleri
PHP Manual

XMLWriter::startPI

(PHP 5 >= 5.1.2, PHP 7, PECL xmlwriter >= 0.1.0)

XMLWriter::startPI — Bir işlem komutu başlangıç etiketi oluşturur

Açıklama

Nesne yönelimli kullanım

bool startPI ( string $hedef )

Yordamsal kullanım

bool xmlwriter_start_pi ( resource $xmlwriter , string $hedef )

Bir işlem komutu başlangıç etiketi oluşturur.

Değiştirgeler

xmlwriter

Sadece yordamsal kullanım için. xmlwriter_open_uri() veya xmlwriter_open_memory() çağrılarıyla elde edilen, üzerinde işlem yapılacak XMLWriter özkaynağı.

hedef

İşlem komutunun hedefi.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLWriter::endPI() - Geçerli işlem komutunu kapatır
  • XMLWriter::writePI() - Bir işlem komutu (PI) yazar

XMLWriter::startElement
XMLWriter::text
XMLWriter İşlevleri


Bir metni yazar

XMLWriter::startPI
XMLWriter::writeAttributeNS
XMLWriter İşlevleri
PHP Manual

XMLWriter::text

(PHP 5 >= 5.1.2, PHP 7, PECL xmlwriter >= 0.1.0)

XMLWriter::text — Bir metni yazar

Açıklama

Nesne yönelimli kullanım

bool text ( string $içerik )

Yordamsal kullanım

bool xmlwriter_text ( resource $xmlwriter , string $içerik )

Bir metni yazar.

Değiştirgeler

xmlwriter

Sadece yordamsal kullanım için. xmlwriter_open_uri() veya xmlwriter_open_memory() çağrılarıyla elde edilen, üzerinde işlem yapılacak XMLWriter özkaynağı.

içerik

Metin içeriği.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

XMLWriter::startPI
XMLWriter::writeAttributeNS
XMLWriter İşlevleri


İsim alanlı öznitelik yazar

XMLWriter::text
XMLWriter::writeAttribute
XMLWriter İşlevleri
PHP Manual

XMLWriter::writeAttributeNS

(PHP 5 >= 5.1.2, PHP 7, PECL xmlwriter >= 0.1.0)

XMLWriter::writeAttributeNS — İsim alanlı öznitelik yazar

Açıklama

Nesne yönelimli kullanım

bool writeAttributeNS ( string $önek , string $isim , string $uri , string $değer )

Yordamsal kullanım

bool xmlwriter_write_attribute_ns ( resource $xmlwriter , string $önek , string $isim , string $uri , string $değer )

Bir isim alanlı özniteliği değeriyle birlikte yazar.

Değiştirgeler

xmlwriter

Sadece yordamsal kullanım için. xmlwriter_open_uri() veya xmlwriter_open_memory() çağrılarıyla elde edilen, üzerinde işlem yapılacak XMLWriter özkaynağı.

önek

İsim alanı öneki.

isim

Özniteliğin ismi.

uri

İsim alanını betimleyen adres.

değer

Özniteliğin değeri.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLWriter::writeAttribute() - Öznitelik yazar
  • XMLWriter::startAttribute() - Bir öznitelik başlatır
  • XMLWriter::startAttributeNS() - İsim alanlı bir öznitelik başlatır
  • XMLWriter::endAttribute() - Geçerli özniteliği sonlandırır

XMLWriter::text
XMLWriter::writeAttribute
XMLWriter İşlevleri


Öznitelik yazar

XMLWriter::writeAttributeNS
XMLWriter::writeCData
XMLWriter İşlevleri
PHP Manual

XMLWriter::writeAttribute

(PHP 5 >= 5.1.2, PHP 7, PECL xmlwriter >= 0.1.0)

XMLWriter::writeAttribute — Öznitelik yazar

Açıklama

Nesne yönelimli kullanım

bool writeAttribute ( string $isim , string $değer )

Yordamsal kullanım

bool xmlwriter_write_attribute ( resource $xmlwriter , string $isim , string $değer )

Bir özniteliği değeriyle birlikte yazar.

Değiştirgeler

xmlwriter

Sadece yordamsal kullanım için. xmlwriter_open_uri() veya xmlwriter_open_memory() çağrılarıyla elde edilen, üzerinde işlem yapılacak XMLWriter özkaynağı.

isim

Özniteliğin ismi.

değer

Özniteliğin değeri.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLWriter::writeAttributeNS() - İsim alanlı öznitelik yazar
  • XMLWriter::startAttribute() - Bir öznitelik başlatır
  • XMLWriter::startAttributeNS() - İsim alanlı bir öznitelik başlatır
  • XMLWriter::endAttribute() - Geçerli özniteliği sonlandırır

XMLWriter::writeAttributeNS
XMLWriter::writeCData
XMLWriter İşlevleri


CDATA yazar

XMLWriter::writeAttribute
XMLWriter::writeComment
XMLWriter İşlevleri
PHP Manual

XMLWriter::writeCData

(PHP 5 >= 5.1.2, PHP 7, PECL xmlwriter >= 0.1.0)

XMLWriter::writeCData — CDATA yazar

Açıklama

Nesne yönelimli kullanım

bool writeCData ( string $içerik )

Yordamsal kullanım

bool xmlwriter_write_cdata ( resource $xmlwriter , string $içerik )

İçeriğiyle birlikte CDATA yazar.

Değiştirgeler

xmlwriter

Sadece yordamsal kullanım için. xmlwriter_open_uri() veya xmlwriter_open_memory() çağrılarıyla elde edilen, üzerinde işlem yapılacak XMLWriter özkaynağı.

içerik

CDATA içeriği.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLWriter::startCData() - Bir CDATA bölümü başlatır
  • XMLWriter::endCData() - Geçerli CDATA bölümünü kapatır

XMLWriter::writeAttribute
XMLWriter::writeComment
XMLWriter İşlevleri


Açıklama yazar

XMLWriter::writeCData
XMLWriter::writeDTDAttlist
XMLWriter İşlevleri
PHP Manual

XMLWriter::writeComment

(PHP 5 >= 5.1.2, PHP 7, PECL xmlwriter >= 0.1.0)

XMLWriter::writeComment — Açıklama yazar

Açıklama

Nesne yönelimli kullanım

bool writeComment ( string $içerik )

Yordamsal kullanım

bool xmlwriter_write_comment ( resource $xmlwriter , string $içerik )

Açıklama yazar.

Değiştirgeler

xmlwriter

Sadece yordamsal kullanım için. xmlwriter_open_uri() veya xmlwriter_open_memory() çağrılarıyla elde edilen, üzerinde işlem yapılacak XMLWriter özkaynağı.

içerik

Açıklama içeriği.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLWriter::startComment() - Bir açıklama başlatır
  • XMLWriter::endComment() - Geçerli açıklamayı kapatır

XMLWriter::writeCData
XMLWriter::writeDTDAttlist
XMLWriter İşlevleri


DTD öznitelik listesi yazar

XMLWriter::writeComment
XMLWriter::writeDTDElement
XMLWriter İşlevleri
PHP Manual

XMLWriter::writeDTDAttlist

(PHP 5 >= 5.1.2, PHP 7, PECL xmlwriter >= 0.1.0)

XMLWriter::writeDTDAttlist — DTD öznitelik listesi yazar

Açıklama

Nesne yönelimli kullanım

bool writeDTDAttlist ( string $isim , string $içerik )

Yordamsal kullanım

bool xmlwriter_write_dtd_attlist ( resource $xmlwriter , string $isim , string $içerik )

Bir DTD öznitelik listesini yazar.

Değiştirgeler

xmlwriter

Sadece yordamsal kullanım için. xmlwriter_open_uri() veya xmlwriter_open_memory() çağrılarıyla elde edilen, üzerinde işlem yapılacak XMLWriter özkaynağı.

isim

DTD öznitelik listesinin ismi.

içerik

DTD öznitelik listesinin içeriği.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLWriter::startDTDAttlist() - Bir DTD öznitelik listesi bildirimini başlatır
  • XMLWriter::endDTDAttlist() - Geçerli DTD öznitelik listesi bildirimini kapatır

XMLWriter::writeComment
XMLWriter::writeDTDElement
XMLWriter İşlevleri


DTD elemanını yazar

XMLWriter::writeDTDAttlist
XMLWriter::writeDTDEntity
XMLWriter İşlevleri
PHP Manual

XMLWriter::writeDTDElement

(PHP 5 >= 5.1.2, PHP 7, PECL xmlwriter >= 0.1.0)

XMLWriter::writeDTDElement — DTD elemanını yazar

Açıklama

Nesne yönelimli kullanım

bool writeDTDElement ( string $isim , string $içerik )

Yordamsal kullanım

bool xmlwriter_write_dtd_element ( resource $xmlwriter , string $isim , string $içerik )

Bir DTD elemanını yazar.

Değiştirgeler

xmlwriter

Sadece yordamsal kullanım için. xmlwriter_open_uri() veya xmlwriter_open_memory() çağrılarıyla elde edilen, üzerinde işlem yapılacak XMLWriter özkaynağı.

isim

DTD elemanının ismi.

içerik

Elemanın içeriği.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLWriter::startDTDElement() - Bir DTD eleman bildirimini başlatır
  • XMLWriter::endDTDElement() - Geçerli DTD eleman bildirimini kapatır

XMLWriter::writeDTDAttlist
XMLWriter::writeDTDEntity
XMLWriter İşlevleri


DTD öğesini yazar

XMLWriter::writeDTDElement
XMLWriter::writeDTD
XMLWriter İşlevleri
PHP Manual

XMLWriter::writeDTDEntity

(PHP 5 >= 5.1.2, PHP 7, PECL xmlwriter >= 0.1.0)

XMLWriter::writeDTDEntity — DTD öğesini yazar

Açıklama

Nesne yönelimli kullanım

bool writeDTDEntity ( string $isim , string $içerik , bool $pe , string $pubid , string $sysid , string $ndataid )

Yordamsal kullanım

bool xmlwriter_write_dtd_entity ( resource $xmlwriter , string $isim , string $içerik , bool $pe , string $pubid , string $sysid , string $ndataid )

Bir DTD öğesini yazar.

Değiştirgeler

xmlwriter

Sadece yordamsal kullanım için. xmlwriter_open_uri() veya xmlwriter_open_memory() çağrılarıyla elde edilen, üzerinde işlem yapılacak XMLWriter özkaynağı.

isim

Öğe ismi.

içerik

Öğe içeriği.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLWriter::startDTDEntity() - Bir DTD öğe bildirimini başlatır
  • XMLWriter::endDTDEntity() - Geçerli DTD öğe bildirimini kapatır

XMLWriter::writeDTDElement
XMLWriter::writeDTD
XMLWriter İşlevleri


DTD'yi yazar

XMLWriter::writeDTDEntity
XMLWriter::writeElementNS
XMLWriter İşlevleri
PHP Manual

XMLWriter::writeDTD

(PHP 5 >= 5.1.2, PHP 7, PECL xmlwriter >= 0.1.0)

XMLWriter::writeDTD — DTD'yi yazar

Açıklama

Nesne yönelimli kullanım

bool writeDTD ( string $isim [, string $publicId [, string $systemId [, string $altküme ]]] )

Yordamsal kullanım

bool xmlwriter_write_dtd ( resource $xmlwriter , string $isim [, string $publicId [, string $systemId [, string $altküme ]]] )

DTD'yi yazar.

Değiştirgeler

xmlwriter

Sadece yordamsal kullanım için. xmlwriter_open_uri() veya xmlwriter_open_memory() çağrılarıyla elde edilen, üzerinde işlem yapılacak XMLWriter özkaynağı.

isim

DTD ismi.

publicId

Harici alt kümenin genel betimleyicisi.

systemId

Harici alt kümenin sistem betimleyicisi.

altküme

DTD içeriği.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLWriter::startDTD() - Bir DTD başlangıç etiketi oluşturur
  • XMLWriter::endDTD() - Geçerli DTD'yi kapatır

XMLWriter::writeDTDEntity
XMLWriter::writeElementNS
XMLWriter İşlevleri


İsim alanlı elemanı içeriğiyle birlikte yazar

XMLWriter::writeDTD
XMLWriter::writeElement
XMLWriter İşlevleri
PHP Manual

XMLWriter::writeElementNS

(PHP 5 >= 5.1.2, PHP 7, PECL xmlwriter >= 0.1.0)

XMLWriter::writeElementNS — İsim alanlı elemanı içeriğiyle birlikte yazar

Açıklama

Nesne yönelimli kullanım

bool writeElementNS ( string $önek , string $eleman , string $uri [, string $içerik ] )

Yordamsal kullanım

bool xmlwriter_write_element_ns ( resource $xmlwriter , string $önek , string $eleman , string $uri [, string $içerik ] )

İsim alanlı elemanı içeriğiyle birlikte yazar.

Değiştirgeler

xmlwriter

Sadece yordamsal kullanım için. xmlwriter_open_uri() veya xmlwriter_open_memory() çağrılarıyla elde edilen, üzerinde işlem yapılacak XMLWriter özkaynağı.

önek

İsim alanı öneki.

eleman

Elemanın ismi.

uri

İsim alanını betimleyen adres.

içerik

Elemanın içeriği.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
PHP 5.2.3 | içerik değiştirgesi isteğe bağlı oldu.

Ayrıca Bakınız

  • XMLWriter::startElementNS() - Bir isim alanlı eleman başlangıç etiketi oluşturur
  • XMLWriter::endElement() - Geçerli elemanı kapatır
  • XMLWriter::writeElement() - Elemanı içeriğiyle birlikte yazar

XMLWriter::writeDTD
XMLWriter::writeElement
XMLWriter İşlevleri


Elemanı içeriğiyle birlikte yazar

XMLWriter::writeElementNS
XMLWriter::writePI
XMLWriter İşlevleri
PHP Manual

XMLWriter::writeElement

(PHP 5 >= 5.1.2, PHP 7, PECL xmlwriter >= 0.1.0)

XMLWriter::writeElement — Elemanı içeriğiyle birlikte yazar

Açıklama

Nesne yönelimli kullanım

bool writeElement ( string $eleman [, string $içerik ] )

Yordamsal kullanım

bool xmlwriter_write_element ( resource $xmlwriter , string $eleman [, string $içerik ] )

Elemanı içeriğiyle birlikte yazar.

Değiştirgeler

xmlwriter

Sadece yordamsal kullanım için. xmlwriter_open_uri() veya xmlwriter_open_memory() çağrılarıyla elde edilen, üzerinde işlem yapılacak XMLWriter özkaynağı.

etiket

Elemanın ismi.

içerik

Elemanın içeriği.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Sürüm Bilgisi

Sürüm: | Açıklama
PHP 5.2.3 | içerik değiştirgesi isteğe bağlı oldu.

Ayrıca Bakınız

  • XMLWriter::startElement() - Bir eleman başlangıç etiketi oluşturur
  • XMLWriter::endElement() - Geçerli elemanı kapatır
  • XMLWriter::writeElementNS() - İsim alanlı elemanı içeriğiyle birlikte yazar

XMLWriter::writeElementNS
XMLWriter::writePI
XMLWriter İşlevleri


Bir işlem komutu (PI) yazar

XMLWriter::writeElement
XMLWriter::writeRaw
XMLWriter İşlevleri
PHP Manual

XMLWriter::writePI

(PHP 5 >= 5.1.2, PHP 7, PECL xmlwriter >= 0.1.0)

XMLWriter::writePI — Bir işlem komutu (PI) yazar

Açıklama

Nesne yönelimli kullanım

bool writePI ( string $hedef , string $içerik )

Yordamsal kullanım

bool xmlwriter_write_pi ( resource $xmlwriter , string $hedef , string $içerik )

Bir işlem komutu (PI) yazar.

Değiştirgeler

xmlwriter

Sadece yordamsal kullanım için. xmlwriter_open_uri() veya xmlwriter_open_memory() çağrılarıyla elde edilen, üzerinde işlem yapılacak XMLWriter özkaynağı.

hedef

İşlem komutunun hedefi.

içerik

İşlem komutunun içeriği.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLWriter::startPI() - Bir işlem komutu başlangıç etiketi oluşturur
  • XMLWriter::endPI() - Geçerli işlem komutunu kapatır

XMLWriter::writeElement
XMLWriter::writeRaw
XMLWriter İşlevleri


Ham XML metni yazar

XMLWriter::writePI
XSL
XMLWriter İşlevleri
PHP Manual

XMLWriter::writeRaw

(PHP 5 >= 5.2.0, PHP 7, PECL xmlwriter >= 2.0.4)

XMLWriter::writeRaw — Ham XML metni yazar

Açıklama

Nesne yönelimli kullanım

bool writeRaw ( string $içerik )

Yordamsal kullanım

bool xmlwriter_write_raw ( resource $xmlwriter , string $içerik )

Ham XML metni yazar.

Değiştirgeler

xmlwriter

Sadece yordamsal kullanım için. xmlwriter_open_uri() veya xmlwriter_open_memory() çağrılarıyla elde edilen, üzerinde işlem yapılacak XMLWriter özkaynağı.

içerik

Yazılacak metin.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XMLWriter::text() - Bir metni yazar

XMLWriter::writePI
XSL
XMLWriter İşlevleri


XSL

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
    • Çalışma Anı Yapılandırması
    • Özkaynak Türleri
  • Öntanımlı Sabitler
  • Örnekler
  • XSLTProcessor — XSLTProcessor sınıfı
    • XSLTProcessor::__construct — Yeni bir XSLTProcessor nesnesi oluşturur
    • XSLTProcessor::getParameter — Bir değiştirgenin değerini döndürür
    • XsltProcessor::getSecurityPrefs — Get security preferences
    • XSLTProcessor::hasExsltSupport — PHP, EXSLT desteğine sahip mi diye bakar
    • XSLTProcessor::importStylesheet — Biçembent ithal eder
    • XSLTProcessor::registerPHPFunctions — XSLT işlevleri olarak PHP işlevlerinin kullanılması yeteneğini etkin kılar
    • XSLTProcessor::removeParameter — Değiştirge siler
    • XSLTProcessor::setParameter — Bir değiştirgeye bir değer atar
    • XSLTProcessor::setProfiling — Profil çıktı dosyasını belirler
    • XsltProcessor::setSecurityPrefs — Set security preferences
    • XSLTProcessor::transformToDoc — Dönüşüm sonucunu bir DOMDocument olarak döndürür
    • XSLTProcessor::transformToUri — Dönüşüm sonucunu bir dosyaya yazar
    • XSLTProcessor::transformToXML — Dönüşümü bir dizge olarak döndürür
XMLWriter::writeRaw
Giriş
XML İşleme


Giriş

XSL eklentisi, » XSLT dönüşümleri yapmak için » libxslt kütüphanesini kullanarak XSL standardını gerçekler.

XSL
Yapılandırma/Kurulum
XSL


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
Giriş
Gereksinimler
XSL


Gereksinimler

Bu eklenti, libxslt kütüphanesinin 1.1.0 veya üstü sürümlerini kullanır. Kütüphane » http://xmlsoft.org/XSLT/ adresinden edinilebilir.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

PHP 5 XSL eklentisini öntanımlı olarak içerir ve derleme sırasında --with-xsl[=DiZiN] seçeneği ile destek etkin kılınabilir. Buradaki DiZiN libxslt kütüphanesinin kurulu olduğu dizindir.

Gereksinimler
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

XSL_CLONE_AUTO (integer)
XSL_CLONE_NEVER (integer)
XSL_CLONE_ALWAYS (integer)
LIBXSLT_VERSION (integer)
10117 gibi bir libxslt sürümü. PHP 5.1.2'den beri kullanılabilmektedir.
LIBXSLT_DOTTED_VERSION (string)
1.1.17 gibi bir libxslt sürümü. PHP 5.1.2'den beri kullanılabilmektedir.
LIBEXSLT_VERSION (integer)
813 gibi bir libexslt sürümü. PHP 5.1.2'den beri kullanılabilmektedir.
LIBEXSLT_DOTTED_VERSION (string)
1.1.17 gibi bir libexslt sürümü. PHP 5.1.2'den beri kullanılabilmektedir.
Özkaynak Türleri
Örnekler
XSL


Örnekler

İçindekiler

Öntanımlı Sabitler
XSL


Örnekler
XSLTProcessor
Örnekler
PHP Manual

Bu eklentideki örneklerin çoğu hem bir XML hem de bir XSL dosyası gerektirir. Örneklerde kullanacağımız collection.xml ve collection.xsl dosyalarının içerikleri:

Örnek 1 - collection.xml

<collection>
 <cd>
  <title>Fight for your mind</title>
  <artist>Ben Harper</artist>
  <year>1995</year>
 </cd>
 <cd>
  <title>Electric Ladyland</title>
  <artist>Jimi Hendrix</artist>
  <year>1997</year>
 </cd>
</collection>

Örnek 2 - collection.xsl

<xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform">
 <xsl:param name="owner" select="'Nicolas Eliaszewicz'"/>
 <xsl:output method="html" encoding="utf-8" indent="no"/>
 <xsl:template match="collection">
  Hey! Welcome to <xsl:value-of select="$owner"/>'s sweet CD collection!
  <xsl:apply-templates/>
 </xsl:template>
 <xsl:template match="cd">
  <h1><xsl:value-of select="title"/></h1>
  <h2>by <xsl:value-of select="artist"/> - <xsl:value-of select="year"/></h2>
  <hr />
 </xsl:template>
</xsl:stylesheet>

Örnekler
XSLTProcessor
Örnekler


XSLTProcessor sınıfı

(PHP 5, PHP 7)

Sınıf Sözdizimi

XSLTProcessor {
/* Yöntemler */
string getParameter ( string $isimalanı , string $isim )
public int XsltProcessor::getSecurityPrefs ( void )
bool hasExsltSupport ( void )
void importStylesheet ( object $biçembent )
void registerPHPFunctions ([ mixed $sınırla ] )
bool removeParameter ( string $isimalanı , string $isim )
bool setParameter ( string $isimalanı , string $isim , string $değer )
bool setProfiling ( string $dosya )
public int XsltProcessor::setSecurityPrefs ( int $securityPrefs )
DOMDocument transformToDoc ( DOMNode $belge )
int transformToURI ( DOMDocument $belge , string $dosya )
string transformToXML ( DOMDocument $belge )
}

İçindekiler

  • XSLTProcessor::__construct — Yeni bir XSLTProcessor nesnesi oluşturur
  • XSLTProcessor::getParameter — Bir değiştirgenin değerini döndürür
  • XsltProcessor::getSecurityPrefs — Get security preferences
  • XSLTProcessor::hasExsltSupport — PHP, EXSLT desteğine sahip mi diye bakar
  • XSLTProcessor::importStylesheet — Biçembent ithal eder
  • XSLTProcessor::registerPHPFunctions — XSLT işlevleri olarak PHP işlevlerinin kullanılması yeteneğini etkin kılar
  • XSLTProcessor::removeParameter — Değiştirge siler
  • XSLTProcessor::setParameter — Bir değiştirgeye bir değer atar
  • XSLTProcessor::setProfiling — Profil çıktı dosyasını belirler
  • XsltProcessor::setSecurityPrefs — Set security preferences
  • XSLTProcessor::transformToDoc — Dönüşüm sonucunu bir DOMDocument olarak döndürür
  • XSLTProcessor::transformToUri — Dönüşüm sonucunu bir dosyaya yazar
  • XSLTProcessor::transformToXML — Dönüşümü bir dizge olarak döndürür
XSLTProcessor::__construct
XSL


Yeni bir XSLTProcessor nesnesi oluşturur

XSLTProcessor
XSLTProcessor::getParameter
XSLTProcessor
PHP Manual

XSLTProcessor::__construct

(PHP 5, PHP 7)

XSLTProcessor::__construct — Yeni bir XSLTProcessor nesnesi oluşturur

Açıklama

__construct ( void )

Yeni bir XSLTProcessor nesnesi oluşturur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 - Bir XSLTProcessor oluşturmak

<?php

$doc = new DOMDocument();
$xsl = new XSLTProcessor();

$doc->load($xsl_filename);
$xsl->importStyleSheet($doc);

$doc->load($xml_filename);
echo $xsl->transformToXML($doc);

?>

XSLTProcessor
XSLTProcessor::getParameter
XSLTProcessor


Bir değiştirgenin değerini döndürür

XSLTProcessor::__construct
XsltProcessor::getSecurityPrefs
XSLTProcessor
PHP Manual

XSLTProcessor::getParameter

(PHP 5, PHP 7)

XSLTProcessor::getParameter — Bir değiştirgenin değerini döndürür

Açıklama

string getParameter ( string $isimalanı , string $isim )

Evvelce XSLTProcessor::setParameter() tarafından atanmış bir değiştirgenin değerini döndürür.

Değiştirgeler

isimalanı

XSLT değiştirgesinin ait olduğu isim alanının adresi.

isim

XSLT değiştirgesinin yerel adı.

Dönen Değerler

Değiştirgeye değer atanmamışsa NULL yoksa değeri döndürür.

Ayrıca Bakınız

  • XSLTProcessor::setParameter() - Bir değiştirgeye bir değer atar
  • XSLTProcessor::removeParameter() - Değiştirge siler

XSLTProcessor::__construct
XsltProcessor::getSecurityPrefs
XSLTProcessor


Get security preferences

XSLTProcessor::getParameter
XSLTProcessor::hasExsltSupport
XSLTProcessor
PHP Manual

XsltProcessor::getSecurityPrefs

(PHP >= 5.4.0)

XsltProcessor::getSecurityPrefs — Get security preferences

Açıklama

public int XsltProcessor::getSecurityPrefs ( void )

Gets the security preferences.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

A bitmask consisting of XSL_SECPREF_READ_FILE, XSL_SECPREF_WRITE_FILE, XSL_SECPREF_CREATE_DIRECTORY, XSL_SECPREF_READ_NETWORK, XSL_SECPREF_WRITE_NETWORK.

XSLTProcessor::getParameter
XSLTProcessor::hasExsltSupport
XSLTProcessor


PHP, EXSLT desteğine sahip mi diye bakar

XsltProcessor::getSecurityPrefs
XSLTProcessor::importStylesheet
XSLTProcessor
PHP Manual

XSLTProcessor::hasExsltSupport

(PHP 5 >= 5.0.4, PHP 7)

XSLTProcessor::hasExsltSupport — PHP, EXSLT desteğine sahip mi diye bakar

Açıklama

bool hasExsltSupport ( void )

PHP, yerleşik » EXSLT kütüphanesi ile derlenmiş mi diye bakar.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - EXSLT desteğinin sınanması

<?php

$proc = new XSLTProcessor;
if (!$proc->hasExsltSupport()) {
    die('EXSLT desteği yok');
}

// EXSLT işlemleri yapabiliriz ..

?>

XsltProcessor::getSecurityPrefs
XSLTProcessor::importStylesheet
XSLTProcessor


Biçembent ithal eder

XSLTProcessor::hasExsltSupport
XSLTProcessor::registerPHPFunctions
XSLTProcessor
PHP Manual

XSLTProcessor::importStylesheet

(PHP 5, PHP 7)

XSLTProcessor::importStylesheet — Biçembent ithal eder

Açıklama

void importStylesheet ( object $biçembent )

Dönüşüm için kullanılmak üzere XSLTProcessor nesnesine biçembent dahil eder.

Değiştirgeler

biçembent

Bir DOMDocument veya bir SimpleXMLElement nesnesi olarak dahil edilecek biçembent.

Dönen Değerler

Hiçbir değer dönmez.

Sürüm Bilgisi

Sürüm: | Açıklama
5.2.8 | PHP 5.2.6'dan beri kabul edilemeyen SimpleXMLElement kabul edilir oldu.

XSLTProcessor::hasExsltSupport
XSLTProcessor::registerPHPFunctions
XSLTProcessor


XSLT işlevleri olarak PHP işlevlerinin kullanılması yeteneğini etkin kılar

XSLTProcessor::importStylesheet
XSLTProcessor::removeParameter
XSLTProcessor
PHP Manual

XSLTProcessor::registerPHPFunctions

(PHP 5 >= 5.0.4, PHP 7)

XSLTProcessor::registerPHPFunctions — XSLT işlevleri olarak PHP işlevlerinin kullanılması yeteneğini etkin kılar

Açıklama

void registerPHPFunctions ([ mixed $sınırla ] )

XSL biçembentlerinde XSLT işlevleri olarak PHP işlevlerinin kullanılabilmesini etkin kılar.

Değiştirgeler

sınırla

XSLT'den çağrılacak işlevleri belli işlev isimleriyle sınırlamak için kullanılır.

Dizge olarak tek bir işlevin ismi veya dizi olarak işlev isimleri.

Dönen Değerler

Hiçbir değer dönmez.

Örnekler

Örnek 1 - Bir biçembentten bir PHP işlevinin çağrılması

<?php

$xml = <<<EOB
<allusers>
 <user>
  <uid>bob</uid>
 </user>
 <user>
  <uid>joe</uid>
 </user>
</allusers>
EOB;
$xsl = <<<EOB
<?xml version="1.0" encoding="UTF-8"?>
<xsl:stylesheet version="1.0"
     xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
     xmlns:php="http://php.net/xsl">
<xsl:output method="html" encoding="utf-8" indent="yes"/>
 <xsl:template match="allusers">
  <html><body>
    <h2>Users</h2>
    <table>
    <xsl:for-each select="user">
      <tr><td>
        <xsl:value-of
             select="php:function('ucfirst',string(uid))"/>
      </td></tr>
    </xsl:for-each>
    </table>
  </body></html>
 </xsl:template>
</xsl:stylesheet>
EOB;
$xmldoc = DOMDocument::loadXML($xml);
$xsldoc = DOMDocument::loadXML($xsl);

$proc = new XSLTProcessor();
$proc->registerPHPFunctions();
$proc->importStyleSheet($xsldoc);
echo $proc->transformToXML($xmldoc);
?>

Sürüm Bilgisi

Sürüm: | Açıklama
5.1.0 | sınırla değiştirgesi eklendi.

XSLTProcessor::importStylesheet
XSLTProcessor::removeParameter
XSLTProcessor


Değiştirge siler

XSLTProcessor::registerPHPFunctions
XSLTProcessor::setParameter
XSLTProcessor
PHP Manual

XSLTProcessor::removeParameter

(PHP 5, PHP 7)

XSLTProcessor::removeParameter — Değiştirge siler

Açıklama

bool removeParameter ( string $isimalanı , string $isim )

Atanmış bir değiştirgeyi siler. Böylece değiştirgenin biçembentteki öntanımlı değerinin kullanılması sağlanmış olur.

Değiştirgeler

isimalanı

XSLT değiştirgesinin ait olduğu isim alanının adresi.

isim

XSLT değiştirgesinin yerel adı.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Ayrıca Bakınız

  • XSLTProcessor::setParameter() - Bir değiştirgeye bir değer atar
  • XSLTProcessor::getParameter() - Bir değiştirgenin değerini döndürür

XSLTProcessor::registerPHPFunctions
XSLTProcessor::setParameter
XSLTProcessor


Bir değiştirgeye bir değer atar

XSLTProcessor::removeParameter
XSLTProcessor::setProfiling
XSLTProcessor
PHP Manual

XSLTProcessor::setParameter

(PHP 5, PHP 7)

XSLTProcessor::setParameter — Bir değiştirgeye bir değer atar

Açıklama

bool setParameter ( string $isimalanı , string $isim , string $değer )
bool setParameter ( string $isimalanı , array $seçenekler )

XSLTProcessor tarafından dönüşüm sırasında kullanılmak üzere bir veya daha fazla değiştirgeye değer atar. Biçembentte mevcut olmayan değiştirgeler yok sayılır.

Değiştirgeler

isimalanı

XSLT değiştirgesinin ait olduğu isim alanının adresi.

isim

XSLT değiştirgesinin yerel adı.

değer

XSLT değiştirgesinin değeri.

seçenekler

isim => değer çiftlerinden oluşan bir dizi. Bu söz dizimi PHP 5.1.0'dan beri kullanılabilmektedir.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Dönüşüm öncesi sahip değişimi

<?php

$collections = array(
    'Marc Rutkowski' => 'marc',
    'Olivier Parmentier' => 'olivier'
);

$xsl = new DOMDocument;
$xsl->load('collection.xsl');

// Dönüştürücüyü yapılandıralım
$proc = new XSLTProcessor;
$proc->importStyleSheet($xsl); // XSL kuralları

foreach ($collections as $name => $file) {
    // XML belgeyi yükleyelim
    $xml = new DOMDocument;
    $xml->load('collection_' . $file . '.xml');

    $proc->setParameter('', 'owner', $name);
    $proc->transformToURI($xml, 'file:///tmp/' . $file . '.html');
}

?>

Ayrıca Bakınız

  • XSLTProcessor::getParameter() - Bir değiştirgenin değerini döndürür
  • XSLTProcessor::removeParameter() - Değiştirge siler

XSLTProcessor::removeParameter
XSLTProcessor::setProfiling
XSLTProcessor


Profil çıktı dosyasını belirler

XSLTProcessor::setParameter
XsltProcessor::setSecurityPrefs
XSLTProcessor
PHP Manual

XSLTProcessor::setProfiling

(PHP >= 5.3.0)

XSLTProcessor::setProfiling — Profil çıktı dosyasını belirler

Açıklama

bool setProfiling ( string $dosya )

Bir biçembent uygulanırken oluşan profil bilgisini belirtilen dosyaya çıktılar.

Değiştirgeler

dosya

Profil bilgisinin döküleceği dosyanın yolu.

Dönen Değerler

Başarı durumunda TRUE, başarısızlık durumunda FALSE döner.

Örnekler

Örnek 1 - Profil bilgisi çıktılama örneği

<?php
// XML belgeyi yükleyelim
$xml = new DOMDocument;
$xml->load('collection.xml');

$xsl = new DOMDocument;
$xsl->load('collection.xsl');

// Dönüştürücüyü yapılandıralım
$proc = new XSLTProcessor;
$proc->setProfiling('profiling.txt');
$proc->importStyleSheet($xsl); // XSL kuralları

echo trim($proc->transformToDoc($xml)->firstChild->wholeText);
?>

Üretilen profil bilgisi:

number               match                name      mode  Calls Tot 100us Avg

    0                   cd                                    2      3      1
    1           collection                                    1      1      1

                         Total                                3      4

XSLTProcessor::setParameter
XsltProcessor::setSecurityPrefs
XSLTProcessor


Set security preferences

XSLTProcessor::setProfiling
XSLTProcessor::transformToDoc
XSLTProcessor
PHP Manual

XsltProcessor::setSecurityPrefs

(PHP >= 5.4.0)

XsltProcessor::setSecurityPrefs — Set security preferences

Açıklama

public int XsltProcessor::setSecurityPrefs ( int $securityPrefs )

Sets the security preferences.

Değiştirgeler

securityPrefs

The new security preferences. The following constants can be ORed: XSL_SECPREF_READ_FILE, XSL_SECPREF_WRITE_FILE, XSL_SECPREF_CREATE_DIRECTORY, XSL_SECPREF_READ_NETWORK, XSL_SECPREF_WRITE_NETWORK. Alternatively, XSL_SECPREF_NONE or XSL_SECPREF_DEFAULT can be passed.

Dönen Değerler

Returns the old security preferences.

XSLTProcessor::setProfiling
XSLTProcessor::transformToDoc
XSLTProcessor


Dönüşüm sonucunu bir DOMDocument olarak döndürür

XsltProcessor::setSecurityPrefs
XSLTProcessor::transformToUri
XSLTProcessor
PHP Manual

XSLTProcessor::transformToDoc

(PHP 5, PHP 7)

XSLTProcessor::transformToDoc — Dönüşüm sonucunu bir DOMDocument olarak döndürür

Açıklama

DOMDocument transformToDoc ( DOMNode $belge )

xsltprocessor::importStylesheet() yöntemi ile belirtilen biçembendi belirtilen belgeye uygulayarak kaynak düğümünü bir DOMDocument nesnesine dönüştürür.

Değiştirgeler

belge

Dönüştürülecek belge.

Dönen Değerler

Bir hata oluşursa FALSE aksi takdirde bir DOMDocument nesnesi döner.

Örnekler

Örnek 1 - Bir DOMDocument nesnesine dönüşüm

<?php

// XML belgeyi yükleyelim
$xml = new DOMDocument;
$xml->load('collection.xml');

$xsl = new DOMDocument;
$xsl->load('collection.xsl');

// Dönüştürücüyü yapılandıralım
$proc = new XSLTProcessor;
$proc->importStyleSheet($xsl); // XSL kuralları

echo trim($proc->transformToDoc($xml)->firstChild->wholeText);

?>

Yukarıdaki örneğin çıktısı:

Hey! Welcome to Nicolas Eliaszewicz's sweet CD collection!

Ayrıca Bakınız

  • XSLTProcessor::transformToUri() - Dönüşüm sonucunu bir dosyaya yazar
  • XSLTProcessor::transformToXml() - Dönüşümü bir dizge olarak döndürür

XsltProcessor::setSecurityPrefs
XSLTProcessor::transformToUri
XSLTProcessor


Dönüşüm sonucunu bir dosyaya yazar

XSLTProcessor::transformToDoc
XSLTProcessor::transformToXML
XSLTProcessor
PHP Manual

XSLTProcessor::transformToUri

(PHP 5, PHP 7)

XSLTProcessor::transformToUri — Dönüşüm sonucunu bir dosyaya yazar

Açıklama

int transformToURI ( DOMDocument $belge , string $dosya )

xsltprocessor::importStylesheet() yöntemi ile belirtilen biçembendi belirtilen belgeye uygulayarak kaynak düğümünü bir dizgeye dönüştürüp belirtilen dosyaya yazar.

Değiştirgeler

belge

Dönüştürülecek belge.

dosya

Dönüşüm sonucunun yazılacağı dosyanın yolu.

Dönen Değerler

Bir hata oluşmuşsa FALSE aksi takdirde yazılan bayt sayısı döner.

Örnekler

Örnek 1 - Bir HTML dosyaya dönüşüm

<?php

// XML belgeyi yükleyelim
$xml = new DOMDocument;
$xml->load('collection.xml');

$xsl = new DOMDocument;
$xsl->load('collection.xsl');

// Dönüştürücüyü yapılandıralım
$proc = new XSLTProcessor;
$proc->importStyleSheet($xsl); // XSL kodları

$proc->transformToURI($xml, 'file:///tmp/out.html');

?>

Ayrıca Bakınız

  • XSLTProcessor::transformToDoc() - Dönüşüm sonucunu bir DOMDocument olarak döndürür
  • XSLTProcessor::transformToXml() - Dönüşümü bir dizge olarak döndürür

XSLTProcessor::transformToDoc
XSLTProcessor::transformToXML
XSLTProcessor


Dönüşümü bir dizge olarak döndürür

XSLTProcessor::transformToUri
GUI Extensions
XSLTProcessor
PHP Manual

XSLTProcessor::transformToXML

(PHP 5, PHP 7)

XSLTProcessor::transformToXML — Dönüşümü bir dizge olarak döndürür

Açıklama

string transformToXML ( DOMDocument $belge )

xsltprocessor::importStylesheet() yöntemi ile belirtilen biçembendi belirtilen belgeye uygulayarak kaynak düğümünü bir dizgeye dönüştürüp döndürür.

Değiştirgeler

belge

Dönüştürülecek belge.

Dönen Değerler

Hata durumunda FALSE, aksi takdirde dönüşüm sonucunu bir dizge olarak döndürür.

Örnekler

Örnek 1 - Bir dizgeye dönüşüm

<?php

// XML belgeyi yükleyelim
$xml = new DOMDocument;
$xml->load('collection.xml');

$xsl = new DOMDocument;
$xsl->load('collection.xsl');

// Dönüştürücüyü yapılandıralım
$proc = new XSLTProcessor;
$proc->importStyleSheet($xsl); // XSL kurallarını ekliyoruz

echo $proc->transformToXML($xml);

?>

Yukarıdaki örneğin çıktısı:

Hey! Welcome to Nicolas Eliaszewicz's sweet CD collection!

<h1>Fight for your mind</h1><h2>by Ben Harper - 1995</h2><hr>
<h1>Electric Ladyland</h1><h2>by Jimi Hendrix - 1997</h2><hr>

Ayrıca Bakınız

  • XSLTProcessor::transformToDoc() - Dönüşüm sonucunu bir DOMDocument olarak döndürür
  • XSLTProcessor::transformToUri() - Dönüşüm sonucunu bir dosyaya yazar

XSLTProcessor::transformToUri
GUI Extensions
XSLTProcessor


GUI Extensions

  • UI
    • Giriş
    • Yapılandırma/Kurulum
    • UI\Point — Represents a position (x,y)
    • UI\Size — Represents dimenstions (width, height)
    • UI\Window — Window
    • UI\Control — Control
    • UI\Menu — Menu
    • UI\MenuItem — Menu Item
    • UI\Area — Area
    • UI\Executor — Execution Scheduler
    • UI\Controls\Tab — Tab Control
    • UI\Controls\Check — Check Control
    • UI\Controls\Button — Button Control
    • UI\Controls\ColorButton — ColorButton Control
    • UI\Controls\Label — Label Control
    • UI\Controls\Entry — Entry Control
    • UI\Controls\MultilineEntry — MultilineEntry Control
    • UI\Controls\Spin — Spin Control
    • UI\Controls\Slider — Slider Control
    • UI\Controls\Progress — Progress Control
    • UI\Controls\Separator — Control Separator
    • UI\Controls\Combo — Combo Control
    • UI\Controls\EditableCombo — EdiableCombo Control
    • UI\Controls\Radio — Radio Control
    • UI\Controls\Picker — Picker Control
    • UI\Controls\Form — Control Form (Arrangement)
    • UI\Controls\Grid — Control Grid (Arrangement)
    • UI\Controls\Group — Control Group (Arrangement)
    • UI\Controls\Box — Control Box (Arrangement)
    • UI\Draw\Pen — Draw Pen
    • UI\Draw\Path — Draw Path
    • UI\Draw\Matrix — Draw Matrix
    • UI\Draw\Color — Color Representation
    • UI\Draw\Stroke — Draw Stroke
    • UI\Draw\Brush — Brushes
    • UI\Draw\Brush\Gradient — Gradient Brushes
    • UI\Draw\Brush\LinearGradient — Linear Gradient
    • UI\Draw\Brush\RadialGradient — Radial Gradient
    • UI\Draw\Text\Layout — Represents Text Layout
    • UI\Draw\Text\Font — Represents a Font
    • UI\Draw\Text\Font\Descriptor — Font Descriptor
    • UI İşlevleri
    • UI\Draw\Text\Font\Weight — Font Weight Settings
    • UI\Draw\Text\Font\Italic — Italic Font Settings
    • UI\Draw\Text\Font\Stretch — Font Stretch Settings
    • UI\Draw\Line\Cap — Line Cap Settings
    • UI\Draw\Line\Join — Line Join Settings
    • UI\Key — Key Identifiers
    • UI\Exception\InvalidArgumentException — InvalidArgumentException
    • UI\Exception\RuntimeException — RuntimeException
XSLTProcessor::transformToXML
UI
İşlev Başvuru Kılavuzu


UI

  • Giriş
  • Yapılandırma/Kurulum
    • Gereksinimler
    • Kurulum
  • UI\Point — Represents a position (x,y)
    • UI\Point::at — Size Coercion
    • UI\Point::__construct — Construct a new Point
    • UI\Point::getX — Retrieves X
    • UI\Point::getY — Retrieves Y
    • UI\Point::setX — Set X
    • UI\Point::setY — Set Y
  • UI\Size — Represents dimenstions (width, height)
    • UI\Size::__construct — Construct a new Size
    • UI\Size::getHeight — Retrieves Height
    • UI\Size::getWidth — Retrives Width
    • UI\Size::of — Point Coercion
    • UI\Size::setHeight — Set Height
    • UI\Size::setWidth — Set Width
  • UI\Window — Window
    • UI\Window::add — Add a Control
    • UI\Window::__construct — Construct a new Window
    • UI\Window::error — Show Error Box
    • UI\Window::getSize — Get Window Size
    • UI\Window::getTitle — Get Title
    • UI\Window::hasBorders — Border Detection
    • UI\Window::hasMargin — Margin Detection
    • UI\Window::isFullScreen — Full Screen Detection
    • UI\Window::msg — Show Message Box
    • UI\Window::onClosing — Closing Callback
    • UI\Window::open — Open Dialog
    • UI\Window::save — Save Dialog
    • UI\Window::setBorders — Border Use
    • UI\Window::setFullScreen — Full Screen Use
    • UI\Window::setMargin — Margin Use
    • UI\Window::setSize — Set Size
    • UI\Window::setTitle — Window Title
  • UI\Control — Control
    • UI\Control::destroy — Destroy Control
    • UI\Control::disable — Disable Control
    • UI\Control::enable — Enable Control
    • UI\Control::getParent — Get Parent Control
    • UI\Control::getTopLevel — Get Top Level
    • UI\Control::hide — Hide Control
    • UI\Control::isEnabled — Determine if Control is enabled
    • UI\Control::isVisible — Determine if Control is visible
    • UI\Control::setParent — Set Parent Control
    • UI\Control::show — Control Show
  • UI\Menu — Menu
    • UI\Menu::append — Append Menu Item
    • UI\Menu::appendAbout — Append About Menu Item
    • UI\Menu::appendCheck — Append Checkable Menu Item
    • UI\Menu::appendPreferences — Append Preferences Menu Item
    • UI\Menu::appendQuit — Append Quit Menu Item
    • UI\Menu::appendSeparator — Append Menu Item Separator
    • UI\Menu::__construct — Construct a new Menu
  • UI\MenuItem — Menu Item
    • UI\MenuItem::disable — Disable Menu Item
    • UI\MenuItem::enable — Enable Menu Item
    • UI\MenuItem::isChecked — Detect Checked
    • UI\MenuItem::onClick — On Click Callback
    • UI\MenuItem::setChecked — Set Checked
  • UI\Area — Area
    • UI\Area::onDraw — Draw Callback
    • UI\Area::onKey — Key Callback
    • UI\Area::onMouse — Mouse Callback
    • UI\Area::redraw — Redraw Area
    • UI\Area::scrollTo — Area Scroll
    • UI\Area::setSize — Set Size
  • UI\Executor — Execution Scheduler
    • UI\Executor::__construct — Construct a new Executor
    • UI\Executor::kill — Stop Executor
    • UI\Executor::onExecute — Execution Callback
    • UI\Executor::setInterval — Interval Manipulation
  • UI\Controls\Tab — Tab Control
    • UI\Controls\Tab::append — Append Page
    • UI\Controls\Tab::delete — Delete Page
    • UI\Controls\Tab::hasMargin — Margin Detection
    • UI\Controls\Tab::insertAt — Insert Page
    • UI\Controls\Tab::pages — Page Count
    • UI\Controls\Tab::setMargin — Set Margin
  • UI\Controls\Check — Check Control
    • UI\Controls\Check::__construct — Construct a new Check
    • UI\Controls\Check::getText — Get Text
    • UI\Controls\Check::isChecked — Checked Detection
    • UI\Controls\Check::onToggle — Toggle Callback
    • UI\Controls\Check::setChecked — Set Checked
    • UI\Controls\Check::setText — Set Text
  • UI\Controls\Button — Button Control
    • UI\Controls\Button::__construct — Construct a new Button
    • UI\Controls\Button::getText — Get Text
    • UI\Controls\Button::onClick — Click Handler
    • UI\Controls\Button::setText — Set Text
  • UI\Controls\ColorButton — ColorButton Control
    • UI\Controls\ColorButton::getColor — Get Color
    • UI\Controls\ColorButton::onChange — Change Handler
    • UI\Controls\ColorButton::setColor — Set Color
  • UI\Controls\Label — Label Control
    • UI\Controls\Label::__construct — Construct a new Label
    • UI\Controls\Label::getText — Get Text
    • UI\Controls\Label::setText — Set Text
  • UI\Controls\Entry — Entry Control
    • UI\Controls\Entry::__construct — Construct a new Entry
    • UI\Controls\Entry::getText — Get Text
    • UI\Controls\Entry::isReadOnly — Detect Read Only
    • UI\Controls\Entry::onChange — Change Handler
    • UI\Controls\Entry::setReadOnly — Set Read Only
    • UI\Controls\Entry::setText — Set Text
  • UI\Controls\MultilineEntry — MultilineEntry Control
    • UI\Controls\MultilineEntry::append — Append Text
    • UI\Controls\MultilineEntry::__construct — Construct a new Multiline Entry
    • UI\Controls\MultilineEntry::getText — Get Text
    • UI\Controls\MultilineEntry::isReadOnly — Read Only Detection
    • UI\Controls\MultilineEntry::onChange — Change Handler
    • UI\Controls\MultilineEntry::setReadOnly — Set Read Only
    • UI\Controls\MultilineEntry::setText — Set Text
  • UI\Controls\Spin — Spin Control
    • UI\Controls\Spin::__construct — Construct a new Spin
    • UI\Controls\Spin::getValue — Get Value
    • UI\Controls\Spin::onChange — Change Handler
    • UI\Controls\Spin::setValue — Set Value
  • UI\Controls\Slider — Slider Control
    • UI\Controls\Slider::__construct — Construct a new Slider
    • UI\Controls\Slider::getValue — Get Value
    • UI\Controls\Slider::onChange — Change Handler
    • UI\Controls\Slider::setValue — Set Value
  • UI\Controls\Progress — Progress Control
    • UI\Controls\Progress::getValue — Get Value
    • UI\Controls\Progress::setValue — Set Value
  • UI\Controls\Separator — Control Separator
    • UI\Controls\Separator::__construct — Construct a new Separator
  • UI\Controls\Combo — Combo Control
    • UI\Controls\Combo::append — Append Option
    • UI\Controls\Combo::getSelected — Get Selected Option
    • UI\Controls\Combo::onSelected — Selected Handler
    • UI\Controls\Combo::setSelected — Set Selected Option
  • UI\Controls\EditableCombo — EdiableCombo Control
    • UI\Controls\EditableCombo::append — Append Option
    • UI\Controls\EditableCombo::getText — Get Text
    • UI\Controls\EditableCombo::onChange — Change Handler
    • UI\Controls\EditableCombo::setText — Set Text
  • UI\Controls\Radio — Radio Control
    • UI\Controls\Radio::append — Append Option
    • UI\Controls\Radio::getSelected — Get Selected Option
    • UI\Controls\Radio::onSelected — Selected Handler
    • UI\Controls\Radio::setSelected — Set Selected Option
  • UI\Controls\Picker — Picker Control
    • UI\Controls\Picker::__construct — Construct a new Picker
  • UI\Controls\Form — Control Form (Arrangement)
    • UI\Controls\Form::append — Append Control
    • UI\Controls\Form::delete — Delete Control
    • UI\Controls\Form::isPadded — Padding Detection
    • UI\Controls\Form::setPadded — Set Padding
  • UI\Controls\Grid — Control Grid (Arrangement)
    • UI\Controls\Grid::append — Append Control
    • UI\Controls\Grid::isPadded — Padding Detection
    • UI\Controls\Grid::setPadded — Set Padding
  • UI\Controls\Group — Control Group (Arrangement)
    • UI\Controls\Group::append — Append Control
    • UI\Controls\Group::__construct — Construct a new Group
    • UI\Controls\Group::getTitle — Get Title
    • UI\Controls\Group::hasMargin — Margin Detection
    • UI\Controls\Group::setMargin — Set Margin
    • UI\Controls\Group::setTitle — Set Title
  • UI\Controls\Box — Control Box (Arrangement)
    • UI\Controls\Box::append — Append Control
    • UI\Controls\Box::__construct — Construct a new Box
    • UI\Controls\Box::delete — Delete Control
    • UI\Controls\Box::getOrientation — Get Orientation
    • UI\Controls\Box::isPadded — Padding Detection
    • UI\Controls\Box::setPadded — Set Padding
  • UI\Draw\Pen — Draw Pen
    • UI\Draw\Pen::clip — Clip a Path
    • UI\Draw\Pen::fill — Fill a Path
    • UI\Draw\Pen::restore — Restore
    • UI\Draw\Pen::save — Save
    • UI\Draw\Pen::stroke — Stroke a Path
    • UI\Draw\Pen::transform — Matrix Transform
    • UI\Draw\Pen::write — Draw Text at Point
  • UI\Draw\Path — Draw Path
    • UI\Draw\Path::addRectangle — Draw a Rectangle
    • UI\Draw\Path::arcTo — Draw an Arc
    • UI\Draw\Path::bezierTo — Draw Bezier Curve
    • UI\Draw\Path::closeFigure — Close Figure
    • UI\Draw\Path::__construct — Construct a new Path
    • UI\Draw\Path::end — Finalize Path
    • UI\Draw\Path::lineTo — Draw a Line
    • UI\Draw\Path::newFigure — Draw Figure
    • UI\Draw\Path::newFigureWithArc — Draw Figure with Arc
  • UI\Draw\Matrix — Draw Matrix
    • UI\Draw\Matrix::invert — Invert Matrix
    • UI\Draw\Matrix::isInvertible — Invertible Detection
    • UI\Draw\Matrix::multiply — Multiply Matrix
    • UI\Draw\Matrix::rotate — Rotate Matrix
    • UI\Draw\Matrix::scale — Scale Matrix
    • UI\Draw\Matrix::skew — Skew Matrix
    • UI\Draw\Matrix::translate — Translate Matrix
  • UI\Draw\Color — Color Representation
    • UI\Draw\Color::__construct — Construct new Color
    • UI\Draw\Color::getChannel — Color Manipulation
    • UI\Draw\Color::setChannel — Color Manipulation
  • UI\Draw\Stroke — Draw Stroke
    • UI\Draw\Stroke::__construct — Construct a new Stroke
    • UI\Draw\Stroke::getCap — Get Line Cap
    • UI\Draw\Stroke::getJoin — Get Line Join
    • UI\Draw\Stroke::getMiterLimit — Get Miter Limit
    • UI\Draw\Stroke::getThickness — Get Thickness
    • UI\Draw\Stroke::setCap — Set Line Cap
    • UI\Draw\Stroke::setJoin — Set Line Join
    • UI\Draw\Stroke::setMiterLimit — Set Miter Limit
    • UI\Draw\Stroke::setThickness — Set Thickness
  • UI\Draw\Brush — Brushes
    • UI\Draw\Brush::__construct — Construct a new Brush
    • UI\Draw\Brush::getColor — Get Color
    • UI\Draw\Brush::setColor — Set Color
  • UI\Draw\Brush\Gradient — Gradient Brushes
    • UI\Draw\Brush\Gradient::addStop — Stop Manipulation
    • UI\Draw\Brush\Gradient::delStop — Stop Manipulation
    • UI\Draw\Brush\Gradient::setStop — Stop Manipulation
  • UI\Draw\Brush\LinearGradient — Linear Gradient
    • UI\Draw\Brush\LinearGradient::__construct — Construct a Linear Gradient
  • UI\Draw\Brush\RadialGradient — Radial Gradient
    • UI\Draw\Brush\RadialGradient::__construct — Construct a new Radial Gradient
  • UI\Draw\Text\Layout — Represents Text Layout
    • UI\Draw\Text\Layout::__construct — Construct a new Text Layout
    • UI\Draw\Text\Layout::setColor — Set Color
    • UI\Draw\Text\Layout::setWidth — Set Width
  • UI\Draw\Text\Font — Represents a Font
    • UI\Draw\Text\Font::__construct — Construct a new Font
    • UI\Draw\Text\Font::getAscent — Font Metrics
    • UI\Draw\Text\Font::getDescent — Font Metrics
    • UI\Draw\Text\Font::getLeading — Font Metrics
    • UI\Draw\Text\Font::getUnderlinePosition — Font Metrics
    • UI\Draw\Text\Font::getUnderlineThickness — Font Metrics
  • UI\Draw\Text\Font\Descriptor — Font Descriptor
    • UI\Draw\Text\Font\Descriptor::__construct — Construct a new Font Descriptor
    • UI\Draw\Text\Font\Descriptor::getFamily — Get Font Family
    • UI\Draw\Text\Font\Descriptor::getItalic — Style Detection
    • UI\Draw\Text\Font\Descriptor::getSize — Size Detection
    • UI\Draw\Text\Font\Descriptor::getStretch — Style Detection
    • UI\Draw\Text\Font\Descriptor::getWeight — Weight Detection
  • UI İşlevleri
    • UI\Draw\Text\Font\fontFamilies — Retrieve Font Families
    • UI\quit — Quit UI Loop
    • UI\run — Enter UI Loop
  • UI\Draw\Text\Font\Weight — Font Weight Settings
  • UI\Draw\Text\Font\Italic — Italic Font Settings
  • UI\Draw\Text\Font\Stretch — Font Stretch Settings
  • UI\Draw\Line\Cap — Line Cap Settings
  • UI\Draw\Line\Join — Line Join Settings
  • UI\Key — Key Identifiers
  • UI\Exception\InvalidArgumentException — InvalidArgumentException
  • UI\Exception\RuntimeException — RuntimeException
GUI Extensions
Giriş
GUI Extensions


Giriş

This extension wraps libui to provide an OO API for the cross platform development of native look-and-feel user interfaces .

UI
Yapılandırma/Kurulum
UI


Yapılandırma/Kurulum

İçindekiler

  • Gereksinimler
  • Kurulum
Giriş
Gereksinimler
UI


Gereksinimler

Installation requires the libui library, and PHP 7 or newer.

This extension requires the » libui library version 0.1.0 or higher to be installed. See the libui documentation for a list of prerequisites.

Yapılandırma/Kurulum
Kurulum
Yapılandırma/Kurulum


Kurulum

Bu » PECL eklentisi PHP ile gelmez.

Bu PECL eklentisini kurma bilgisi kılavuzun PECL eklentisinin kurulması başlıklı faslında bulunabilir. Yeni dağıtımlar, indirmeler, kaynak dosyaları, sürdürücü bilgileri ve CHANGELOG gibi ek bilgiyi şu adreste bulabilirsiniz: » http://pecl.php.net/package/ui.

Windows binaries (DLL files) for this PECL extension are available from the PECL website.

Gereksinimler
UI\Point
Yapılandırma/Kurulum


Represents a position (x,y)

(PHP 7, UI 0.9.9)

Giriş

Points are used throughout UI to represent co-ordinates on a screen, control, or area.

Sınıf Sözdizimi

final UI\Point {
/* Özellikler */
public $x ;
public $y ;
/* Constructor */
public __construct ( float $x , float $y )
/* Yöntemler */
public static UI\Point at ( float $point )
public static UI\Point at ( UI\Size $size )
public float getX ( void )
public float getY ( void )
public setX ( float $point )
public setY ( float $point )
}

Özellikler

x

Holds the X co-ordinate, can be read/written directly

y

Holds the Y co-ordinate, can be read/written directly

İçindekiler

  • UI\Point::at — Size Coercion
  • UI\Point::__construct — Construct a new Point
  • UI\Point::getX — Retrieves X
  • UI\Point::getY — Retrieves Y
  • UI\Point::setX — Set X
  • UI\Point::setY — Set Y
Kurulum
UI\Point::at
UI


Size Coercion

UI\Point
UI\Point::__construct
UI\Point
PHP Manual

UI\Point::at

(PHP 7, UI 1.0.2)

UI\Point::at — Size Coercion

Açıklama

public static UI\Point UI\Point::at ( float $point )
public static UI\Point UI\Point::at ( UI\Size $size )

Shall return a UI\Point object where x and y are equal to those supplied, either in float or UI\Size form

Değiştirgeler

point

The value for x and y

size

The Size to convert

Dönen Değerler

The resulting Point

UI\Point
UI\Point::__construct
UI\Point


Construct a new Point

UI\Point::at
UI\Point::getX
UI\Point
PHP Manual

UI\Point::__construct

(PHP 7, UI 0.9.9)

UI\Point::__construct — Construct a new Point

Açıklama

public UI\Point::__construct ( float $x , float $y )

Construct a new Point using new co-ordinates

Değiştirgeler

x

The new X co-ordinate

y

The new Y co-ordinate

UI\Point::at
UI\Point::getX
UI\Point


Retrieves X

UI\Point::__construct
UI\Point::getY
UI\Point
PHP Manual

UI\Point::getX

(PHP 7, UI 0.9.9)

UI\Point::getX — Retrieves X

Açıklama

public float UI\Point::getX ( void )

Retrieves the X co-ordinate

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current X co-ordinate

UI\Point::__construct
UI\Point::getY
UI\Point


Retrieves Y

UI\Point::getX
UI\Point::setX
UI\Point
PHP Manual

UI\Point::getY

(PHP 7, UI 0.9.9)

UI\Point::getY — Retrieves Y

Açıklama

public float UI\Point::getY ( void )

Retrieves the Y co-ordinate

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current Y co-ordinate

UI\Point::getX
UI\Point::setX
UI\Point


Set X

UI\Point::getY
UI\Point::setY
UI\Point
PHP Manual

UI\Point::setX

(PHP 7, UI 0.9.9)

UI\Point::setX — Set X

Açıklama

public UI\Point::setX ( float $point )

Set the X co-ordinate

Değiştirgeler

point

The new X co-ordinate

Dönen Değerler

UI\Point::getY
UI\Point::setY
UI\Point


Set Y

UI\Point::setX
UI\Size
UI\Point
PHP Manual

UI\Point::setY

(PHP 7, UI 0.9.9)

UI\Point::setY — Set Y

Açıklama

public UI\Point::setY ( float $point )

Set the Y co-ordinate

Değiştirgeler

point

The new Y co-ordinate

Dönen Değerler

UI\Point::setX
UI\Size
UI\Point


Represents dimenstions (width, height)

(PHP 7, UI 0.9.9)

Giriş

Sizes are used throughout UI to represent the size of a screen, control, or area.

Sınıf Sözdizimi

final UI\Size {
/* Özellikler */
public $width ;
public $height ;
/* Constructor */
public __construct ( float $width , float $height )
/* Yöntemler */
public float getHeight ( void )
public float getWidth ( void )
public static UI\Size of ( float $size )
public static UI\Size of ( UI\Point $point )
public setHeight ( float $size )
public setWidth ( float $size )
}

Özellikler

width

Holds the width, can be read/written directly

height

Holds the height, can be read/written directly

İçindekiler

  • UI\Size::__construct — Construct a new Size
  • UI\Size::getHeight — Retrieves Height
  • UI\Size::getWidth — Retrives Width
  • UI\Size::of — Point Coercion
  • UI\Size::setHeight — Set Height
  • UI\Size::setWidth — Set Width
UI\Point::setY
UI\Size::__construct
UI


Construct a new Size

UI\Size
UI\Size::getHeight
UI\Size
PHP Manual

UI\Size::__construct

(PHP 7, UI 0.9.9)

UI\Size::__construct — Construct a new Size

Açıklama

public UI\Size::__construct ( float $width , float $height )

Construct a new Size using new width and height

Değiştirgeler

width

The new width

height

The new height

UI\Size
UI\Size::getHeight
UI\Size


Retrieves Height

UI\Size::__construct
UI\Size::getWidth
UI\Size
PHP Manual

UI\Size::getHeight

(PHP 7, UI 0.9.9)

UI\Size::getHeight — Retrieves Height

Açıklama

public float UI\Size::getHeight ( void )

Retrieves the Height

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current Height

UI\Size::__construct
UI\Size::getWidth
UI\Size


Retrives Width

UI\Size::getHeight
UI\Size::of
UI\Size
PHP Manual

UI\Size::getWidth

(PHP 7, UI 0.9.9)

UI\Size::getWidth — Retrives Width

Açıklama

public float UI\Size::getWidth ( void )

Retrieves the Width

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current Width

UI\Size::getHeight
UI\Size::of
UI\Size


Point Coercion

UI\Size::getWidth
UI\Size::setHeight
UI\Size
PHP Manual

UI\Size::of

(PHP 7, UI 1.0.2)

UI\Size::of — Point Coercion

Açıklama

public static UI\Size UI\Size::of ( float $size )
public static UI\Size UI\Size::of ( UI\Point $point )

Shall return a UI\Size object where width and height are equal to those supplied, either in float or UI\Point form

Değiştirgeler

size

The value for width and height

point

The Point to convert

Dönen Değerler

The resulting Size

UI\Size::getWidth
UI\Size::setHeight
UI\Size


Set Height

UI\Size::of
UI\Size::setWidth
UI\Size
PHP Manual

UI\Size::setHeight

(PHP 7, UI 0.9.9)

UI\Size::setHeight — Set Height

Açıklama

public UI\Size::setHeight ( float $size )

Set new Height

Değiştirgeler

size

The new Height

Dönen Değerler

UI\Size::of
UI\Size::setWidth
UI\Size


Set Width

UI\Size::setHeight
UI\Window
UI\Size
PHP Manual

UI\Size::setWidth

(PHP 7, UI 0.9.9)

UI\Size::setWidth — Set Width

Açıklama

public UI\Size::setWidth ( float $size )

Set new Width

Değiştirgeler

size

The new Width

Dönen Değerler

UI\Size::setHeight
UI\Window
UI\Size


Window

(PHP 7, UI 0.9.9)

Giriş

Represents a UI Window

Sınıf Sözdizimi

UI\Window extends UI\Control {
/* Özellikler */
protected $controls ;
/* Constructor */
public __construct ( string $title , Size $size [, boolean $menu = false ] )
/* Yöntemler */
public add ( UI\Control $control )
public error ( string $title , string $msg )
public UI\Size getSize ( void )
public string getTitle ( void )
public bool hasBorders ( void )
public bool hasMargin ( void )
public bool isFullScreen ( void )
public msg ( string $title , string $msg )
protected int onClosing ( void )
public string open ( void )
public string save ( void )
public setBorders ( boolean $borders )
public setFullScreen ( boolean $full )
public setMargin ( boolean $margin )
public setSize ( UI\Size $size )
public setTitle ( string $title )
/* Miras alınan yöntemler */
public UI\Control::destroy ( void )
public UI\Control::disable ( void )
public UI\Control::enable ( void )
public UI\Control UI\Control::getParent ( void )
public int UI\Control::getTopLevel ( void )
public UI\Control::hide ( void )
public bool UI\Control::isEnabled ( void )
public bool UI\Control::isVisible ( void )
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( void )
}

Özellikler

controls

Contains controls, should not be manipulated directly

İçindekiler

  • UI\Window::add — Add a Control
  • UI\Window::__construct — Construct a new Window
  • UI\Window::error — Show Error Box
  • UI\Window::getSize — Get Window Size
  • UI\Window::getTitle — Get Title
  • UI\Window::hasBorders — Border Detection
  • UI\Window::hasMargin — Margin Detection
  • UI\Window::isFullScreen — Full Screen Detection
  • UI\Window::msg — Show Message Box
  • UI\Window::onClosing — Closing Callback
  • UI\Window::open — Open Dialog
  • UI\Window::save — Save Dialog
  • UI\Window::setBorders — Border Use
  • UI\Window::setFullScreen — Full Screen Use
  • UI\Window::setMargin — Margin Use
  • UI\Window::setSize — Set Size
  • UI\Window::setTitle — Window Title
UI\Size::setWidth
UI\Window::add
UI


Add a Control

UI\Window
UI\Window::__construct
UI\Window
PHP Manual

UI\Window::add

(PHP 7, UI 0.9.9)

UI\Window::add — Add a Control

Açıklama

public UI\Window::add ( UI\Control $control )

Shall add a Control to this Window

Değiştirgeler

control

The Control to add

Dönen Değerler

UI\Window
UI\Window::__construct
UI\Window


Construct a new Window

UI\Window::add
UI\Window::error
UI\Window
PHP Manual

UI\Window::__construct

(PHP 7, UI 0.9.9)

UI\Window::__construct — Construct a new Window

Açıklama

public UI\Window::__construct ( string $title , Size $size [, boolean $menu = false ] )

Shall construct a new Window

Değiştirgeler

title

The title of the Window

size

The size of the Window

menu

Menu switch

UI\Window::add
UI\Window::error
UI\Window


Show Error Box

UI\Window::__construct
UI\Window::getSize
UI\Window
PHP Manual

UI\Window::error

(PHP 7, UI 0.9.9)

UI\Window::error — Show Error Box

Açıklama

public UI\Window::error ( string $title , string $msg )

Shall show an error box

Değiştirgeler

title

The title of the error box

msg

The message for the error box

UI\Window::__construct
UI\Window::getSize
UI\Window


Get Window Size

UI\Window::error
UI\Window::getTitle
UI\Window
PHP Manual

UI\Window::getSize

(PHP 7, UI 0.9.9)

UI\Window::getSize — Get Window Size

Açıklama

public UI\Size UI\Window::getSize ( void )

Shall return the size of this Window

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

UI\Window::error
UI\Window::getTitle
UI\Window


Get Title

UI\Window::getSize
UI\Window::hasBorders
UI\Window
PHP Manual

UI\Window::getTitle

(PHP 7, UI 0.9.9)

UI\Window::getTitle — Get Title

Açıklama

public string UI\Window::getTitle ( void )

Shall retrieve the title of this Window

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

UI\Window::getSize
UI\Window::hasBorders
UI\Window


Border Detection

UI\Window::getTitle
UI\Window::hasMargin
UI\Window
PHP Manual

UI\Window::hasBorders

(PHP 7, UI 0.9.9)

UI\Window::hasBorders — Border Detection

Açıklama

public bool UI\Window::hasBorders ( void )

Shall detect if borders are used on this Window

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

UI\Window::getTitle
UI\Window::hasMargin
UI\Window


Margin Detection

UI\Window::hasBorders
UI\Window::isFullScreen
UI\Window
PHP Manual

UI\Window::hasMargin

(PHP 7, UI 0.9.9)

UI\Window::hasMargin — Margin Detection

Açıklama

public bool UI\Window::hasMargin ( void )

Shall detect if margins are used on this Window

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

UI\Window::hasBorders
UI\Window::isFullScreen
UI\Window


Full Screen Detection

UI\Window::hasMargin
UI\Window::msg
UI\Window
PHP Manual

UI\Window::isFullScreen

(PHP 7, UI 0.9.9)

UI\Window::isFullScreen — Full Screen Detection

Açıklama

public bool UI\Window::isFullScreen ( void )

Shall detect if this Window us using the whole screen

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

UI\Window::hasMargin
UI\Window::msg
UI\Window


Show Message Box

UI\Window::isFullScreen
UI\Window::onClosing
UI\Window
PHP Manual

UI\Window::msg

(PHP 7, UI 0.9.9)

UI\Window::msg — Show Message Box

Açıklama

public UI\Window::msg ( string $title , string $msg )

Shall show a message box

Değiştirgeler

title

The title of the message box

msg

The message

UI\Window::isFullScreen
UI\Window::onClosing
UI\Window


Closing Callback

UI\Window::msg
UI\Window::open
UI\Window
PHP Manual

UI\Window::onClosing

(PHP 7, UI 0.9.9)

UI\Window::onClosing — Closing Callback

Açıklama

protected int UI\Window::onClosing ( void )

Should gracefully destroy this Window

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

UI\Window::msg
UI\Window::open
UI\Window


Open Dialog

UI\Window::onClosing
UI\Window::save
UI\Window
PHP Manual

UI\Window::open

(PHP 7, UI 0.9.9)

UI\Window::open — Open Dialog

Açıklama

public string UI\Window::open ( void )

Shall show an open file dialog

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the name of the file selected for opening

UI\Window::onClosing
UI\Window::save
UI\Window


Save Dialog

UI\Window::open
UI\Window::setBorders
UI\Window
PHP Manual

UI\Window::save

(PHP 7, UI 0.9.9)

UI\Window::save — Save Dialog

Açıklama

public string UI\Window::save ( void )

Shall show a save dialog

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

Returns the file name selecting for saving

UI\Window::open
UI\Window::setBorders
UI\Window


Border Use

UI\Window::save
UI\Window::setFullScreen
UI\Window
PHP Manual

UI\Window::setBorders

(PHP 7, UI 0.9.9)

UI\Window::setBorders — Border Use

Açıklama

public UI\Window::setBorders ( boolean $borders )

Shall enable or disable the use of borders on this Window

Değiştirgeler

borders

UI\Window::save
UI\Window::setFullScreen
UI\Window


Full Screen Use

UI\Window::setBorders
UI\Window::setMargin
UI\Window
PHP Manual

UI\Window::setFullScreen

(PHP 7, UI 0.9.9)

UI\Window::setFullScreen — Full Screen Use

Açıklama

public UI\Window::setFullScreen ( boolean $full )

Shall enable or disable the use of the full screen for this Window

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

full

UI\Window::setBorders
UI\Window::setMargin
UI\Window


Margin Use

UI\Window::setFullScreen
UI\Window::setSize
UI\Window
PHP Manual

UI\Window::setMargin

(PHP 7, UI 0.9.9)

UI\Window::setMargin — Margin Use

Açıklama

public UI\Window::setMargin ( boolean $margin )

Shall enable or disable the use of margins for this Window

Değiştirgeler

margin

UI\Window::setFullScreen
UI\Window::setSize
UI\Window


Set Size

UI\Window::setMargin
UI\Window::setTitle
UI\Window
PHP Manual

UI\Window::setSize

(PHP 7, UI 0.9.9)

UI\Window::setSize — Set Size

Açıklama

public UI\Window::setSize ( UI\Size $size )

Shall set the size of this Window

Değiştirgeler

size

Dönen Değerler

UI\Window::setMargin
UI\Window::setTitle
UI\Window


Window Title

UI\Window::setSize
UI\Control
UI\Window
PHP Manual

UI\Window::setTitle

(PHP 7, UI 0.9.9)

UI\Window::setTitle — Window Title

Açıklama

public UI\Window::setTitle ( string $title )

Shall set the title for this Window

Değiştirgeler

title

The new title

UI\Window::setSize
UI\Control
UI\Window


Control

(PHP 7, UI 0.9.9)

Giriş

This is the closed base class for all UI Controls.

Sınıf Sözdizimi

final UI\Control {
/* Yöntemler */
public destroy ( void )
public disable ( void )
public enable ( void )
public UI\Control getParent ( void )
public int getTopLevel ( void )
public hide ( void )
public bool isEnabled ( void )
public bool isVisible ( void )
public setParent ( UI\Control $parent )
public show ( void )
}

İçindekiler

  • UI\Control::destroy — Destroy Control
  • UI\Control::disable — Disable Control
  • UI\Control::enable — Enable Control
  • UI\Control::getParent — Get Parent Control
  • UI\Control::getTopLevel — Get Top Level
  • UI\Control::hide — Hide Control
  • UI\Control::isEnabled — Determine if Control is enabled
  • UI\Control::isVisible — Determine if Control is visible
  • UI\Control::setParent — Set Parent Control
  • UI\Control::show — Control Show
UI\Window::setTitle
UI\Control::destroy
UI


Destroy Control

UI\Control
UI\Control::disable
UI\Control
PHP Manual

UI\Control::destroy

(PHP 7, UI 0.9.9)

UI\Control::destroy — Destroy Control

Açıklama

public UI\Control::destroy ( void )

Shall destroy this Control

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

UI\Control
UI\Control::disable
UI\Control


Disable Control

UI\Control::destroy
UI\Control::enable
UI\Control
PHP Manual

UI\Control::disable

(PHP 7, UI 0.9.9)

UI\Control::disable — Disable Control

Açıklama

public UI\Control::disable ( void )

Shall disable this Control

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

UI\Control::destroy
UI\Control::enable
UI\Control


Enable Control

UI\Control::disable
UI\Control::getParent
UI\Control
PHP Manual

UI\Control::enable

(PHP 7, UI 0.9.9)

UI\Control::enable — Enable Control

Açıklama

public UI\Control::enable ( void )

Shall enable this Control

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

UI\Control::disable
UI\Control::getParent
UI\Control


Get Parent Control

UI\Control::enable
UI\Control::getTopLevel
UI\Control
PHP Manual

UI\Control::getParent

(PHP 7, UI 0.9.9)

UI\Control::getParent — Get Parent Control

Açıklama

public UI\Control UI\Control::getParent ( void )

Shall return the parent Control

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

UI\Control::enable
UI\Control::getTopLevel
UI\Control


Get Top Level

UI\Control::getParent
UI\Control::hide
UI\Control
PHP Manual

UI\Control::getTopLevel

(PHP 7, UI 0.9.9)

UI\Control::getTopLevel — Get Top Level

Açıklama

public int UI\Control::getTopLevel ( void )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

UI\Control::getParent
UI\Control::hide
UI\Control


Hide Control

UI\Control::getTopLevel
UI\Control::isEnabled
UI\Control
PHP Manual

UI\Control::hide

(PHP 7, UI 0.9.9)

UI\Control::hide — Hide Control

Açıklama

public UI\Control::hide ( void )

Shall hide this Control

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

UI\Control::getTopLevel
UI\Control::isEnabled
UI\Control


Determine if Control is enabled

UI\Control::hide
UI\Control::isVisible
UI\Control
PHP Manual

UI\Control::isEnabled

(PHP 7, UI 0.9.9)

UI\Control::isEnabled — Determine if Control is enabled

Açıklama

public bool UI\Control::isEnabled ( void )

Shall detect if this Control is enabled

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

UI\Control::hide
UI\Control::isVisible
UI\Control


Determine if Control is visible

UI\Control::isEnabled
UI\Control::setParent
UI\Control
PHP Manual

UI\Control::isVisible

(PHP 7, UI 0.9.9)

UI\Control::isVisible — Determine if Control is visible

Açıklama

public bool UI\Control::isVisible ( void )

Shall detect if this Control is visible

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

UI\Control::isEnabled
UI\Control::setParent
UI\Control


Set Parent Control

UI\Control::isVisible
UI\Control::show
UI\Control
PHP Manual

UI\Control::setParent

(PHP 7, UI 0.9.9)

UI\Control::setParent — Set Parent Control

Açıklama

public UI\Control::setParent ( UI\Control $parent )

Shall set the parent Control of this Control

Değiştirgeler

parent

The parent Control

Dönen Değerler

UI\Control::isVisible
UI\Control::show
UI\Control


Control Show

UI\Control::setParent
UI\Menu
UI\Control
PHP Manual

UI\Control::show

(PHP 7, UI 0.9.9)

UI\Control::show — Control Show

Açıklama

public UI\Control::show ( void )

Shall show this Control

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

UI\Control::setParent
UI\Menu
UI\Control


Menu

(PHP 7, UI 0.9.9)

Giriş

Menus must be constructed before the first Window, and can be shown on any Window

Sınıf Sözdizimi

UI\Menu {
/* Constructor */
public __construct ( string $name )
/* Yöntemler */
public UI\MenuItem append ( string $name [, string $type = UI\MenuItem::class ] )
public UI\MenuItem appendAbout ([ string $type = UI\MenuItem::class ] )
public UI\MenuItem appendCheck ( string $name [, string $type = UI\MenuItem::class ] )
public UI\MenuItem appendPreferences ([ string $type = UI\MenuItem::class ] )
public UI\MenuItem appendQuit ([ string $type = UI\MenuItem::class ] )
public appendSeparator ( void )
}

İçindekiler

  • UI\Menu::append — Append Menu Item
  • UI\Menu::appendAbout — Append About Menu Item
  • UI\Menu::appendCheck — Append Checkable Menu Item
  • UI\Menu::appendPreferences — Append Preferences Menu Item
  • UI\Menu::appendQuit — Append Quit Menu Item
  • UI\Menu::appendSeparator — Append Menu Item Separator
  • UI\Menu::__construct — Construct a new Menu
UI\Control::show
UI\Menu::append
UI


Append Menu Item

UI\Menu
UI\Menu::appendAbout
UI\Menu
PHP Manual

UI\Menu::append

(PHP 7, UI 0.9.9)

UI\Menu::append — Append Menu Item

Açıklama

public UI\MenuItem UI\Menu::append ( string $name [, string $type = UI\MenuItem::class ] )

Shall append a new Menu Item

Değiştirgeler

name

The name (text) for the new item

type

The type for the new item

Dönen Değerler

A constructed object of the given type

UI\Menu
UI\Menu::appendAbout
UI\Menu


Append About Menu Item

UI\Menu::append
UI\Menu::appendCheck
UI\Menu
PHP Manual

UI\Menu::appendAbout

(PHP 7, UI 0.9.9)

UI\Menu::appendAbout — Append About Menu Item

Açıklama

public UI\MenuItem UI\Menu::appendAbout ([ string $type = UI\MenuItem::class ] )

Shall append an About menu item

Değiştirgeler

type

The type for the new item

Dönen Değerler

A constructed About menu item of the given type

UI\Menu::append
UI\Menu::appendCheck
UI\Menu


Append Checkable Menu Item

UI\Menu::appendAbout
UI\Menu::appendPreferences
UI\Menu
PHP Manual

UI\Menu::appendCheck

(PHP 7, UI 0.9.9)

UI\Menu::appendCheck — Append Checkable Menu Item

Açıklama

public UI\MenuItem UI\Menu::appendCheck ( string $name [, string $type = UI\MenuItem::class ] )

Shall append a checkable menu item

Değiştirgeler

name

The name (text) for the new item

type

The type for the new item

Dönen Değerler

A constructed checkable menu item of the given type

UI\Menu::appendAbout
UI\Menu::appendPreferences
UI\Menu


Append Preferences Menu Item

UI\Menu::appendCheck
UI\Menu::appendQuit
UI\Menu
PHP Manual

UI\Menu::appendPreferences

(PHP 7, UI 0.9.9)

UI\Menu::appendPreferences — Append Preferences Menu Item

Açıklama

public UI\MenuItem UI\Menu::appendPreferences ([ string $type = UI\MenuItem::class ] )

Shall append a Preferences menu item

Değiştirgeler

type

The type for the new item

Dönen Değerler

A constructed Preferences menu item of the given type

UI\Menu::appendCheck
UI\Menu::appendQuit
UI\Menu


Append Quit Menu Item

UI\Menu::appendPreferences
UI\Menu::appendSeparator
UI\Menu
PHP Manual

UI\Menu::appendQuit

(PHP 7, UI 0.9.9)

UI\Menu::appendQuit — Append Quit Menu Item

Açıklama

public UI\MenuItem UI\Menu::appendQuit ([ string $type = UI\MenuItem::class ] )

Shall append a Quit menu item

Değiştirgeler

type

The type for the new item

Dönen Değerler

A constructed Quit menu item of the given type

UI\Menu::appendPreferences
UI\Menu::appendSeparator
UI\Menu


Append Menu Item Separator

UI\Menu::appendQuit
UI\Menu::__construct
UI\Menu
PHP Manual

UI\Menu::appendSeparator

(PHP 7, UI 0.9.9)

UI\Menu::appendSeparator — Append Menu Item Separator

Açıklama

public UI\Menu::appendSeparator ( void )

Shall append a separator

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

UI\Menu::appendQuit
UI\Menu::__construct
UI\Menu


Construct a new Menu

UI\Menu::appendSeparator
UI\MenuItem
UI\Menu
PHP Manual

UI\Menu::__construct

(PHP 7, UI 0.9.9)

UI\Menu::__construct — Construct a new Menu

Açıklama

public UI\Menu::__construct ( string $name )

Shall construct a new Menu

Değiştirgeler

name

The name (text) for the menu

UI\Menu::appendSeparator
UI\MenuItem
UI\Menu


Menu Item

(PHP 7, UI 0.9.9)

Giriş

Menu Items should only be created by the Menu

Sınıf Sözdizimi

UI\MenuItem {
/* Yöntemler */
public disable ( void )
public enable ( void )
public bool isChecked ( void )
protected onClick ( void )
public setChecked ( boolean $checked )
}

İçindekiler

  • UI\MenuItem::disable — Disable Menu Item
  • UI\MenuItem::enable — Enable Menu Item
  • UI\MenuItem::isChecked — Detect Checked
  • UI\MenuItem::onClick — On Click Callback
  • UI\MenuItem::setChecked — Set Checked
UI\Menu::__construct
UI\MenuItem::disable
UI


Disable Menu Item

UI\MenuItem
UI\MenuItem::enable
UI\MenuItem
PHP Manual

UI\MenuItem::disable

(PHP 7, UI 0.9.9)

UI\MenuItem::disable — Disable Menu Item

Açıklama

public UI\MenuItem::disable ( void )

Shall disable this Menu Item

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

UI\MenuItem
UI\MenuItem::enable
UI\MenuItem


Enable Menu Item

UI\MenuItem::disable
UI\MenuItem::isChecked
UI\MenuItem
PHP Manual

UI\MenuItem::enable

(PHP 7, UI 0.9.9)

UI\MenuItem::enable — Enable Menu Item

Açıklama

public UI\MenuItem::enable ( void )

Shall enable this Menu Item

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

UI\MenuItem::disable
UI\MenuItem::isChecked
UI\MenuItem


Detect Checked

UI\MenuItem::enable
UI\MenuItem::onClick
UI\MenuItem
PHP Manual

UI\MenuItem::isChecked

(PHP 7, UI 0.9.9)

UI\MenuItem::isChecked — Detect Checked

Açıklama

public bool UI\MenuItem::isChecked ( void )

Shall detect if this Menu Item is checked

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

UI\MenuItem::enable
UI\MenuItem::onClick
UI\MenuItem


On Click Callback

UI\MenuItem::isChecked
UI\MenuItem::setChecked
UI\MenuItem
PHP Manual

UI\MenuItem::onClick

(PHP 7, UI 0.9.9)

UI\MenuItem::onClick — On Click Callback

Açıklama

protected UI\MenuItem::onClick ( void )

Shall be executed when this Menu Item is clicked

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

UI\MenuItem::isChecked
UI\MenuItem::setChecked
UI\MenuItem


Set Checked

UI\MenuItem::onClick
UI\Area
UI\MenuItem
PHP Manual

UI\MenuItem::setChecked

(PHP 7, UI 0.9.9)

UI\MenuItem::setChecked — Set Checked

Açıklama

public UI\MenuItem::setChecked ( boolean $checked )

Shall set the checked status of this Menu Item

Değiştirgeler

checked

The new status

UI\MenuItem::onClick
UI\Area
UI\MenuItem


Area

(PHP 7, UI 0.9.9)

Giriş

An Area represents a canvas which can be used to draw, and respond to mouse and key events.

Sınıf Sözdizimi

UI\Area extends UI\Control {
/* Constants */
const integer Ctrl ;
const integer Alt ;
const integer Shift ;
const integer Super ;
const integer Down ;
const integer Up ;
/* Yöntemler */
protected onDraw ( UI\Draw\Pen $pen , UI\Size $areaSize , UI\Point $clipPoint , UI\Size $clipSize )
protected onKey ( string $key , integer $ext , integer $flags )
protected onMouse ( UI\Point $areaPoint , UI\Size $areaSize , integer $flags )
public redraw ( void )
public scrollTo ( UI\Point $point , UI\Size $size )
public setSize ( UI\Size $size )
/* Miras alınan yöntemler */
public UI\Control::destroy ( void )
public UI\Control::disable ( void )
public UI\Control::enable ( void )
public UI\Control UI\Control::getParent ( void )
public int UI\Control::getTopLevel ( void )
public UI\Control::hide ( void )
public bool UI\Control::isEnabled ( void )
public bool UI\Control::isVisible ( void )
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( void )
}

Öntanımlı Sabitler

UI\Area::Ctrl

Shall be set in the modifiers passed to key and mouse events when the CTRL key is active

UI\Area::Alt

Shall be set in the modifiers passed to key and mouse events when the ALT key is active

UI\Area::Shift

Shall be set in the modifiers passed to key and mouse events when the SHIFT key is active

UI\Area::Super

UI\Area::Down

Shall be set in the modifiers passed to key and mouse events

UI\Area::Up

Shall be set in the modifiers passed to key and mouse events

İçindekiler

  • UI\Area::onDraw — Draw Callback
  • UI\Area::onKey — Key Callback
  • UI\Area::onMouse — Mouse Callback
  • UI\Area::redraw — Redraw Area
  • UI\Area::scrollTo — Area Scroll
  • UI\Area::setSize — Set Size
UI\MenuItem::setChecked
UI\Area::onDraw
UI


Draw Callback

UI\Area
UI\Area::onKey
UI\Area
PHP Manual

UI\Area::onDraw

(PHP 7, UI 0.9.9)

UI\Area::onDraw — Draw Callback

Açıklama

protected UI\Area::onDraw ( UI\Draw\Pen $pen , UI\Size $areaSize , UI\Point $clipPoint , UI\Size $clipSize )

Shall be invoked when this Area requires redrawing

Değiştirgeler

pen

A Pen suitable for drawing in this Area

areaSize

The size of the Area

clipPoint

The clip point of the Area

clipSize

The clip size of the Area

UI\Area
UI\Area::onKey
UI\Area


Key Callback

UI\Area::onDraw
UI\Area::onMouse
UI\Area
PHP Manual

UI\Area::onKey

(PHP 7, UI 0.9.9)

UI\Area::onKey — Key Callback

Açıklama

protected UI\Area::onKey ( string $key , integer $ext , integer $flags )

Shall be executed on key events

Değiştirgeler

key

The key pressed

ext

The extended key pressed

flags

Event modifiers

Dönen Değerler

UI\Area::onDraw
UI\Area::onMouse
UI\Area


Mouse Callback

UI\Area::onKey
UI\Area::redraw
UI\Area
PHP Manual

UI\Area::onMouse

(PHP 7, UI 0.9.9)

UI\Area::onMouse — Mouse Callback

Açıklama

protected UI\Area::onMouse ( UI\Point $areaPoint , UI\Size $areaSize , integer $flags )

Shall be executed on mouse events

Değiştirgeler

areaPoint

The co-ordinates of the event

areaSize

The size of the area of the event

flags

Event modifiers

UI\Area::onKey
UI\Area::redraw
UI\Area


Redraw Area

UI\Area::onMouse
UI\Area::scrollTo
UI\Area
PHP Manual

UI\Area::redraw

(PHP 7, UI 0.9.9)

UI\Area::redraw — Redraw Area

Açıklama

public UI\Area::redraw ( void )

Requests that this Area is redrawn

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

UI\Area::onMouse
UI\Area::scrollTo
UI\Area


Area Scroll

UI\Area::redraw
UI\Area::setSize
UI\Area
PHP Manual

UI\Area::scrollTo

(PHP 7, UI 0.9.9)

UI\Area::scrollTo — Area Scroll

Açıklama

public UI\Area::scrollTo ( UI\Point $point , UI\Size $size )

Scroll this Area

Değiştirgeler

point

The point to scroll to

size

The size of the scroll pane

UI\Area::redraw
UI\Area::setSize
UI\Area


Set Size

UI\Area::scrollTo
UI\Executor
UI\Area
PHP Manual

UI\Area::setSize

(PHP 7, UI 0.9.9)

UI\Area::setSize — Set Size

Açıklama

public UI\Area::setSize ( UI\Size $size )

Sets the size of this Area

Değiştirgeler

size

The new size

UI\Area::scrollTo
UI\Executor
UI\Area


Execution Scheduler

(PHP 7, UI 2.0.0)

Giriş

This facility schedules repetitive execution of a callback, useful for animations and other such activities.

Sınıf Sözdizimi

abstract UI\Executor {
/* Constructor */
public __construct ( void )
public __construct ( integer $microseconds )
public __construct ( integer $seconds , integer $microseconds )
/* Yöntemler */
public void kill ( void )
abstract protected void onExecute ( void )
public bool setInterval ( integer $microseconds )
public bool setInterval ( integer $seconds , integer $microseconds )
}

İçindekiler

  • UI\Executor::__construct — Construct a new Executor
  • UI\Executor::kill — Stop Executor
  • UI\Executor::onExecute — Execution Callback
  • UI\Executor::setInterval — Interval Manipulation
UI\Area::setSize
UI\Executor::__construct
UI


Construct a new Executor

UI\Executor
UI\Executor::kill
UI\Executor
PHP Manual

UI\Executor::__construct

(PHP 7, UI 2.0.0)

UI\Executor::__construct — Construct a new Executor

Açıklama

public UI\Executor::__construct ( void )
public UI\Executor::__construct ( integer $microseconds )
public UI\Executor::__construct ( integer $seconds , integer $microseconds )

Shall construct an executor with the given interval, will not start executing until main loop is entered

Değiştirgeler

seconds

Seconds between executions

microseconds

Microseconds between executions

UI\Executor
UI\Executor::kill
UI\Executor


Stop Executor

UI\Executor::__construct
UI\Executor::onExecute
UI\Executor
PHP Manual

UI\Executor::kill

(PHP 7, UI 2.0.0)

UI\Executor::kill — Stop Executor

Açıklama

public void UI\Executor::kill ( void )

Shall stop an executor, the executor cannot be restarted

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

UI\Executor::__construct
UI\Executor::onExecute
UI\Executor


Execution Callback

UI\Executor::kill
UI\Executor::setInterval
UI\Executor
PHP Manual

UI\Executor::onExecute

(PHP 7, UI 2.0.0)

UI\Executor::onExecute — Execution Callback

Açıklama

abstract protected void UI\Executor::onExecute ( void )

Shall be repetitively queued for execution in the main thread

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

UI\Executor::kill
UI\Executor::setInterval
UI\Executor


Interval Manipulation

UI\Executor::onExecute
UI\Controls\Tab
UI\Executor
PHP Manual

UI\Executor::setInterval

(PHP 7, UI 2.0.0)

UI\Executor::setInterval — Interval Manipulation

Açıklama

public bool UI\Executor::setInterval ( integer $microseconds )
public bool UI\Executor::setInterval ( integer $seconds , integer $microseconds )

Shall set the new interval. An interval of 0 will pause the executor until a new interval has been set

Değiştirgeler

seconds

microseconds

Dönen Değerler

Indication of success

UI\Executor::onExecute
UI\Controls\Tab
UI\Executor


Tab Control

(PHP 7, UI 0.9.9)

Giriş

A Tab can contain many pages of Controls, each with a title, each selectable by the user.

Sınıf Sözdizimi

UI\Controls\Tab extends UI\Control {
/* Özellikler */
protected $controls ;
/* Yöntemler */
public integer append ( string $name , UI\Control $control )
public boolean delete ( integer $index )
public bool hasMargin ( integer $page )
public insertAt ( string $name , integer $page , UI\Control $control )
public integer pages ( void )
public setMargin ( integer $page , boolean $margin )
/* Miras alınan yöntemler */
public UI\Control::destroy ( void )
public UI\Control::disable ( void )
public UI\Control::enable ( void )
public UI\Control UI\Control::getParent ( void )
public int UI\Control::getTopLevel ( void )
public UI\Control::hide ( void )
public bool UI\Control::isEnabled ( void )
public bool UI\Control::isVisible ( void )
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( void )
}

Özellikler

controls

Contains controls, should not be manipulated directly

İçindekiler

  • UI\Controls\Tab::append — Append Page
  • UI\Controls\Tab::delete — Delete Page
  • UI\Controls\Tab::hasMargin — Margin Detection
  • UI\Controls\Tab::insertAt — Insert Page
  • UI\Controls\Tab::pages — Page Count
  • UI\Controls\Tab::setMargin — Set Margin
UI\Executor::setInterval
UI\Controls\Tab::append
UI


Append Page

UI\Controls\Tab
UI\Controls\Tab::delete
UI\Controls\Tab
PHP Manual

UI\Controls\Tab::append

(PHP 7, UI 0.9.9)

UI\Controls\Tab::append — Append Page

Açıklama

public integer UI\Controls\Tab::append ( string $name , UI\Control $control )

Append a new page to this Tab

Değiştirgeler

name

The name for the new page

control

The control for the new page

Dönen Değerler

Shall return the index of the appended control, may be 0

UI\Controls\Tab
UI\Controls\Tab::delete
UI\Controls\Tab


Delete Page

UI\Controls\Tab::append
UI\Controls\Tab::hasMargin
UI\Controls\Tab
PHP Manual

UI\Controls\Tab::delete

(PHP 7, UI 0.9.9)

UI\Controls\Tab::delete — Delete Page

Açıklama

public boolean UI\Controls\Tab::delete ( integer $index )

Shall remove the selected page from this Tab

Değiştirgeler

index

The index of the page to remove

Dönen Değerler

Indication of success

UI\Controls\Tab::append
UI\Controls\Tab::hasMargin
UI\Controls\Tab


Margin Detection

UI\Controls\Tab::delete
UI\Controls\Tab::insertAt
UI\Controls\Tab
PHP Manual

UI\Controls\Tab::hasMargin

(PHP 7, UI 0.9.9)

UI\Controls\Tab::hasMargin — Margin Detection

Açıklama

public bool UI\Controls\Tab::hasMargin ( integer $page )

Shall detect if the given page has a margin.

Değiştirgeler

page

The index of the page

Dönen Değerler

UI\Controls\Tab::delete
UI\Controls\Tab::insertAt
UI\Controls\Tab


Insert Page

UI\Controls\Tab::hasMargin
UI\Controls\Tab::pages
UI\Controls\Tab
PHP Manual

UI\Controls\Tab::insertAt

(PHP 7, UI 0.9.9)

UI\Controls\Tab::insertAt — Insert Page

Açıklama

public UI\Controls\Tab::insertAt ( string $name , integer $page , UI\Control $control )

Shall insert a new page into this Tab

Değiştirgeler

name

The name for the new page

page

The index to perform the insertion before

control

The control for the new page

UI\Controls\Tab::hasMargin
UI\Controls\Tab::pages
UI\Controls\Tab


Page Count

UI\Controls\Tab::insertAt
UI\Controls\Tab::setMargin
UI\Controls\Tab
PHP Manual

UI\Controls\Tab::pages

(PHP 7, UI 0.9.9)

UI\Controls\Tab::pages — Page Count

Açıklama

public integer UI\Controls\Tab::pages ( void )

Shall return the number of pages in this Tab

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The number of pages in this Tab

UI\Controls\Tab::insertAt
UI\Controls\Tab::setMargin
UI\Controls\Tab


Set Margin

UI\Controls\Tab::pages
UI\Controls\Check
UI\Controls\Tab
PHP Manual

UI\Controls\Tab::setMargin

(PHP 7, UI 0.9.9)

UI\Controls\Tab::setMargin — Set Margin

Açıklama

public UI\Controls\Tab::setMargin ( integer $page , boolean $margin )

Shall enable or disable margins on the selected page

Değiştirgeler

page

The page to select

margin

Margin switch

UI\Controls\Tab::pages
UI\Controls\Check
UI\Controls\Tab


Check Control

(PHP 7, UI 0.9.9)

Giriş

A Check is a labelled checkable box

Sınıf Sözdizimi

UI\Controls\Check extends UI\Control {
/* Constructor */
public __construct ( string $text )
/* Yöntemler */
public string getText ( void )
public bool isChecked ( void )
protected onToggle ( void )
public setChecked ( boolean $checked )
public setText ( string $text )
/* Miras alınan yöntemler */
public UI\Control::destroy ( void )
public UI\Control::disable ( void )
public UI\Control::enable ( void )
public UI\Control UI\Control::getParent ( void )
public int UI\Control::getTopLevel ( void )
public UI\Control::hide ( void )
public bool UI\Control::isEnabled ( void )
public bool UI\Control::isVisible ( void )
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( void )
}

İçindekiler

  • UI\Controls\Check::__construct — Construct a new Check
  • UI\Controls\Check::getText — Get Text
  • UI\Controls\Check::isChecked — Checked Detection
  • UI\Controls\Check::onToggle — Toggle Callback
  • UI\Controls\Check::setChecked — Set Checked
  • UI\Controls\Check::setText — Set Text
UI\Controls\Tab::setMargin
UI\Controls\Check::__construct
UI


Construct a new Check

UI\Controls\Check
UI\Controls\Check::getText
UI\Controls\Check
PHP Manual

UI\Controls\Check::__construct

(PHP 7, UI 0.9.9)

UI\Controls\Check::__construct — Construct a new Check

Açıklama

public UI\Controls\Check::__construct ( string $text )

Shall construct a new Check

Değiştirgeler

text

The text (label) for the Check box

UI\Controls\Check
UI\Controls\Check::getText
UI\Controls\Check


Get Text

UI\Controls\Check::__construct
UI\Controls\Check::isChecked
UI\Controls\Check
PHP Manual

UI\Controls\Check::getText

(PHP 7, UI 0.9.9)

UI\Controls\Check::getText — Get Text

Açıklama

public string UI\Controls\Check::getText ( void )

Shall return the text (label) for this Check

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current text (label)

UI\Controls\Check::__construct
UI\Controls\Check::isChecked
UI\Controls\Check


Checked Detection

UI\Controls\Check::getText
UI\Controls\Check::onToggle
UI\Controls\Check
PHP Manual

UI\Controls\Check::isChecked

(PHP 7, UI 0.9.9)

UI\Controls\Check::isChecked — Checked Detection

Açıklama

public bool UI\Controls\Check::isChecked ( void )

Shall detect the status of this Check

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

UI\Controls\Check::getText
UI\Controls\Check::onToggle
UI\Controls\Check


Toggle Callback

UI\Controls\Check::isChecked
UI\Controls\Check::setChecked
UI\Controls\Check
PHP Manual

UI\Controls\Check::onToggle

(PHP 7, UI 0.9.9)

UI\Controls\Check::onToggle — Toggle Callback

Açıklama

protected UI\Controls\Check::onToggle ( void )

Shall be executed when the status of this Check is changed

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

UI\Controls\Check::isChecked
UI\Controls\Check::setChecked
UI\Controls\Check


Set Checked

UI\Controls\Check::onToggle
UI\Controls\Check::setText
UI\Controls\Check
PHP Manual

UI\Controls\Check::setChecked

(PHP 7, UI 0.9.9)

UI\Controls\Check::setChecked — Set Checked

Açıklama

public UI\Controls\Check::setChecked ( boolean $checked )

Shall change the status of this Check

Değiştirgeler

checked

The new status

UI\Controls\Check::onToggle
UI\Controls\Check::setText
UI\Controls\Check


Set Text

UI\Controls\Check::setChecked
UI\Controls\Button
UI\Controls\Check
PHP Manual

UI\Controls\Check::setText

(PHP 7, UI 0.9.9)

UI\Controls\Check::setText — Set Text

Açıklama

public UI\Controls\Check::setText ( string $text )

Shall set the text (label) for this Check

Değiştirgeler

text

The new text (label)

UI\Controls\Check::setChecked
UI\Controls\Button
UI\Controls\Check


Button Control

(PHP 7, UI 0.9.9)

Giriş

Represents a labelled clickable button

Sınıf Sözdizimi

UI\Controls\Button extends UI\Control {
/* Constructor */
public __construct ( string $text )
/* Yöntemler */
public string getText ( void )
protected onClick ( void )
public setText ( string $text )
/* Miras alınan yöntemler */
public UI\Control::destroy ( void )
public UI\Control::disable ( void )
public UI\Control::enable ( void )
public UI\Control UI\Control::getParent ( void )
public int UI\Control::getTopLevel ( void )
public UI\Control::hide ( void )
public bool UI\Control::isEnabled ( void )
public bool UI\Control::isVisible ( void )
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( void )
}

İçindekiler

  • UI\Controls\Button::__construct — Construct a new Button
  • UI\Controls\Button::getText — Get Text
  • UI\Controls\Button::onClick — Click Handler
  • UI\Controls\Button::setText — Set Text
UI\Controls\Check::setText
UI\Controls\Button::__construct
UI


Construct a new Button

UI\Controls\Button
UI\Controls\Button::getText
UI\Controls\Button
PHP Manual

UI\Controls\Button::__construct

(PHP 7, UI 0.9.9)

UI\Controls\Button::__construct — Construct a new Button

Açıklama

public UI\Controls\Button::__construct ( string $text )

Shall construct a new Button

Değiştirgeler

text

The text (label) for this Button

UI\Controls\Button
UI\Controls\Button::getText
UI\Controls\Button


Get Text

UI\Controls\Button::__construct
UI\Controls\Button::onClick
UI\Controls\Button
PHP Manual

UI\Controls\Button::getText

(PHP 7, UI 0.9.9)

UI\Controls\Button::getText — Get Text

Açıklama

public string UI\Controls\Button::getText ( void )

Shall retrieve the text (label) for this Button

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current text (label)

UI\Controls\Button::__construct
UI\Controls\Button::onClick
UI\Controls\Button


Click Handler

UI\Controls\Button::getText
UI\Controls\Button::setText
UI\Controls\Button
PHP Manual

UI\Controls\Button::onClick

(PHP 7, UI 0.9.9)

UI\Controls\Button::onClick — Click Handler

Açıklama

protected UI\Controls\Button::onClick ( void )

Shall be executed when this Button is clicked

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

UI\Controls\Button::getText
UI\Controls\Button::setText
UI\Controls\Button


Set Text

UI\Controls\Button::onClick
UI\Controls\ColorButton
UI\Controls\Button
PHP Manual

UI\Controls\Button::setText

(PHP 7, UI 0.9.9)

UI\Controls\Button::setText — Set Text

Açıklama

public UI\Controls\Button::setText ( string $text )

Shall set the text (label) for this Button

Değiştirgeler

text

The new text (label)

UI\Controls\Button::onClick
UI\Controls\ColorButton
UI\Controls\Button


ColorButton Control

(PHP 7, UI 0.9.9)

Giriş

A Color Button is a button which displays a color picker when clicked

Sınıf Sözdizimi

UI\Controls\ColorButton extends UI\Control {
/* Yöntemler */
public UI\Color getColor ( void )
protected onChange ( void )
public setColor ( UI\Draw\Color $color )
public setColor ( integer $color )
/* Miras alınan yöntemler */
public UI\Control::destroy ( void )
public UI\Control::disable ( void )
public UI\Control::enable ( void )
public UI\Control UI\Control::getParent ( void )
public int UI\Control::getTopLevel ( void )
public UI\Control::hide ( void )
public bool UI\Control::isEnabled ( void )
public bool UI\Control::isVisible ( void )
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( void )
}

İçindekiler

  • UI\Controls\ColorButton::getColor — Get Color
  • UI\Controls\ColorButton::onChange — Change Handler
  • UI\Controls\ColorButton::setColor — Set Color
UI\Controls\Button::setText
UI\Controls\ColorButton::getColor
UI


Get Color

UI\Controls\ColorButton
UI\Controls\ColorButton::onChange
UI\Controls\ColorButton
PHP Manual

UI\Controls\ColorButton::getColor

(PHP 7, UI 0.9.9)

UI\Controls\ColorButton::getColor — Get Color

Açıklama

public UI\Color UI\Controls\ColorButton::getColor ( void )

Shall retrieve the currently selected Color

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

UI\Controls\ColorButton
UI\Controls\ColorButton::onChange
UI\Controls\ColorButton


Change Handler

UI\Controls\ColorButton::getColor
UI\Controls\ColorButton::setColor
UI\Controls\ColorButton
PHP Manual

UI\Controls\ColorButton::onChange

(PHP 7, UI 0.9.9)

UI\Controls\ColorButton::onChange — Change Handler

Açıklama

protected UI\Controls\ColorButton::onChange ( void )

Shall be executed when the selected Color is changed

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

UI\Controls\ColorButton::getColor
UI\Controls\ColorButton::setColor
UI\Controls\ColorButton


Set Color

UI\Controls\ColorButton::onChange
UI\Controls\Label
UI\Controls\ColorButton
PHP Manual

UI\Controls\ColorButton::setColor

(PHP 7, UI 0.9.9)

UI\Controls\ColorButton::setColor — Set Color

Açıklama

public UI\Controls\ColorButton::setColor ( UI\Draw\Color $color )
public UI\Controls\ColorButton::setColor ( integer $color )

Shall set the currently selected Color

Değiştirgeler

color

The new color

UI\Controls\ColorButton::onChange
UI\Controls\Label
UI\Controls\ColorButton


Label Control

(PHP 7, UI 0.9.9)

Giriş

A Label is a single line of text, meant to identify, for the user, some element of the interface.

Sınıf Sözdizimi

UI\Controls\Label extends UI\Control {
/* Constructor */
public __construct ( string $text )
/* Yöntemler */
public string getText ( void )
public setText ( string $text )
/* Miras alınan yöntemler */
public UI\Control::destroy ( void )
public UI\Control::disable ( void )
public UI\Control::enable ( void )
public UI\Control UI\Control::getParent ( void )
public int UI\Control::getTopLevel ( void )
public UI\Control::hide ( void )
public bool UI\Control::isEnabled ( void )
public bool UI\Control::isVisible ( void )
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( void )
}

İçindekiler

  • UI\Controls\Label::__construct — Construct a new Label
  • UI\Controls\Label::getText — Get Text
  • UI\Controls\Label::setText — Set Text
UI\Controls\ColorButton::setColor
UI\Controls\Label::__construct
UI


Construct a new Label

UI\Controls\Label
UI\Controls\Label::getText
UI\Controls\Label
PHP Manual

UI\Controls\Label::__construct

(PHP 7, UI 0.9.9)

UI\Controls\Label::__construct — Construct a new Label

Açıklama

public UI\Controls\Label::__construct ( string $text )

Shall construct a new Label

Değiştirgeler

text

The text for this label

UI\Controls\Label
UI\Controls\Label::getText
UI\Controls\Label


Get Text

UI\Controls\Label::__construct
UI\Controls\Label::setText
UI\Controls\Label
PHP Manual

UI\Controls\Label::getText

(PHP 7, UI 0.9.9)

UI\Controls\Label::getText — Get Text

Açıklama

public string UI\Controls\Label::getText ( void )

Shall return the current text for this Label

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

UI\Controls\Label::__construct
UI\Controls\Label::setText
UI\Controls\Label


Set Text

UI\Controls\Label::getText
UI\Controls\Entry
UI\Controls\Label
PHP Manual

UI\Controls\Label::setText

(PHP 7, UI 0.9.9)

UI\Controls\Label::setText — Set Text

Açıklama

public UI\Controls\Label::setText ( string $text )

Shall set the text for this Label

Değiştirgeler

text

The new text

UI\Controls\Label::getText
UI\Controls\Entry
UI\Controls\Label


Entry Control

(PHP 7, UI 0.9.9)

Giriş

An Entry is a text entry control, suitable for entering plain text, passwords, or search terms.

Sınıf Sözdizimi

UI\Controls\Entry extends UI\Control {
/* Constants */
const integer Normal ;
const integer Password ;
const integer Search ;
/* Constructor */
public __construct ([ integer $type = UI\Controls\Entry::Normal ] )
/* Yöntemler */
public string getText ( void )
public bool isReadOnly ( void )
protected onChange ( void )
public setReadOnly ( boolean $readOnly )
public setText ( string $text )
/* Miras alınan yöntemler */
public UI\Control::destroy ( void )
public UI\Control::disable ( void )
public UI\Control::enable ( void )
public UI\Control UI\Control::getParent ( void )
public int UI\Control::getTopLevel ( void )
public UI\Control::hide ( void )
public bool UI\Control::isEnabled ( void )
public bool UI\Control::isVisible ( void )
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( void )
}

Öntanımlı Sabitler

UI\Controls\Entry::Normal

A normal single line entry

UI\Controls\Entry::Password

A password entry

UI\Controls\Entry::Search

A search entry

İçindekiler

  • UI\Controls\Entry::__construct — Construct a new Entry
  • UI\Controls\Entry::getText — Get Text
  • UI\Controls\Entry::isReadOnly — Detect Read Only
  • UI\Controls\Entry::onChange — Change Handler
  • UI\Controls\Entry::setReadOnly — Set Read Only
  • UI\Controls\Entry::setText — Set Text
UI\Controls\Label::setText
UI\Controls\Entry::__construct
UI


Construct a new Entry

UI\Controls\Entry
UI\Controls\Entry::getText
UI\Controls\Entry
PHP Manual

UI\Controls\Entry::__construct

(PHP 7, UI 0.9.9)

UI\Controls\Entry::__construct — Construct a new Entry

Açıklama

public UI\Controls\Entry::__construct ([ integer $type = UI\Controls\Entry::Normal ] )

Construct a new entry of the given type

Değiştirgeler

type

Entry::Normal, Entry::Password, or Entry::Search

UI\Controls\Entry
UI\Controls\Entry::getText
UI\Controls\Entry


Get Text

UI\Controls\Entry::__construct
UI\Controls\Entry::isReadOnly
UI\Controls\Entry
PHP Manual

UI\Controls\Entry::getText

(PHP 7, UI 0.9.9)

UI\Controls\Entry::getText — Get Text

Açıklama

public string UI\Controls\Entry::getText ( void )

Shall return the current text from this Entry

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current text

UI\Controls\Entry::__construct
UI\Controls\Entry::isReadOnly
UI\Controls\Entry


Detect Read Only

UI\Controls\Entry::getText
UI\Controls\Entry::onChange
UI\Controls\Entry
PHP Manual

UI\Controls\Entry::isReadOnly

(PHP 7, UI 0.9.9)

UI\Controls\Entry::isReadOnly — Detect Read Only

Açıklama

public bool UI\Controls\Entry::isReadOnly ( void )

Shall detect if this Entry is read only

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

UI\Controls\Entry::getText
UI\Controls\Entry::onChange
UI\Controls\Entry


Change Handler

UI\Controls\Entry::isReadOnly
UI\Controls\Entry::setReadOnly
UI\Controls\Entry
PHP Manual

UI\Controls\Entry::onChange

(PHP 7, UI 0.9.9)

UI\Controls\Entry::onChange — Change Handler

Açıklama

protected UI\Controls\Entry::onChange ( void )

Shall be executed when the text in this Entry changes

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

UI\Controls\Entry::isReadOnly
UI\Controls\Entry::setReadOnly
UI\Controls\Entry


Set Read Only

UI\Controls\Entry::onChange
UI\Controls\Entry::setText
UI\Controls\Entry
PHP Manual

UI\Controls\Entry::setReadOnly

(PHP 7, UI 0.9.9)

UI\Controls\Entry::setReadOnly — Set Read Only

Açıklama

public UI\Controls\Entry::setReadOnly ( boolean $readOnly )

Shall enable or disable read only for this Entry

Değiştirgeler

readOnly

UI\Controls\Entry::onChange
UI\Controls\Entry::setText
UI\Controls\Entry


Set Text

UI\Controls\Entry::setReadOnly
UI\Controls\MultilineEntry
UI\Controls\Entry
PHP Manual

UI\Controls\Entry::setText

(PHP 7, UI 0.9.9)

UI\Controls\Entry::setText — Set Text

Açıklama

public UI\Controls\Entry::setText ( string $text )

Shall set the text for this Entry

Değiştirgeler

text

The new text

UI\Controls\Entry::setReadOnly
UI\Controls\MultilineEntry
UI\Controls\Entry


MultilineEntry Control

(PHP 7, UI 0.9.9)

Giriş

A Multiline Entry is a text entry control able to hold multiple lines of text, with or without wrapping.

Sınıf Sözdizimi

UI\Controls\MultilineEntry extends UI\Control {
/* Constants */
const integer Wrap ;
const integer NoWrap ;
/* Constructor */
public __construct ([ integer $type ] )
/* Yöntemler */
public append ( string $text )
public string getText ( void )
public bool isReadOnly ( void )
protected onChange ( void )
public setReadOnly ( boolean $readOnly )
public setText ( string $text )
/* Miras alınan yöntemler */
public UI\Control::destroy ( void )
public UI\Control::disable ( void )
public UI\Control::enable ( void )
public UI\Control UI\Control::getParent ( void )
public int UI\Control::getTopLevel ( void )
public UI\Control::hide ( void )
public bool UI\Control::isEnabled ( void )
public bool UI\Control::isVisible ( void )
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( void )
}

Öntanımlı Sabitler

UI\Controls\MultilineEntry::Wrap

Allow lines to wrap

UI\Controls\MultilineEntry::NoWrap

Do not allow lines to wrap

İçindekiler

  • UI\Controls\MultilineEntry::append — Append Text
  • UI\Controls\MultilineEntry::__construct — Construct a new Multiline Entry
  • UI\Controls\MultilineEntry::getText — Get Text
  • UI\Controls\MultilineEntry::isReadOnly — Read Only Detection
  • UI\Controls\MultilineEntry::onChange — Change Handler
  • UI\Controls\MultilineEntry::setReadOnly — Set Read Only
  • UI\Controls\MultilineEntry::setText — Set Text
UI\Controls\Entry::setText
UI\Controls\MultilineEntry::append
UI


Append Text

UI\Controls\MultilineEntry
UI\Controls\MultilineEntry::__construct
UI\Controls\MultilineEntry
PHP Manual

UI\Controls\MultilineEntry::append

(PHP 7, UI 0.9.9)

UI\Controls\MultilineEntry::append — Append Text

Açıklama

public UI\Controls\MultilineEntry::append ( string $text )

Shall append the given text to the text in this Multiline Entry

Değiştirgeler

text

The text to append

UI\Controls\MultilineEntry
UI\Controls\MultilineEntry::__construct
UI\Controls\MultilineEntry


Construct a new Multiline Entry

UI\Controls\MultilineEntry::append
UI\Controls\MultilineEntry::getText
UI\Controls\MultilineEntry
PHP Manual

UI\Controls\MultilineEntry::__construct

(PHP 7, UI 0.9.9)

UI\Controls\MultilineEntry::__construct — Construct a new Multiline Entry

Açıklama

public UI\Controls\MultilineEntry::__construct ([ integer $type ] )

Shall construct a new Multiline Entry of the given type

Değiştirgeler

type

MultilineEntry::Wrap or MultilineEntry::NoWrap

UI\Controls\MultilineEntry::append
UI\Controls\MultilineEntry::getText
UI\Controls\MultilineEntry


Get Text

UI\Controls\MultilineEntry::__construct
UI\Controls\MultilineEntry::isReadOnly
UI\Controls\MultilineEntry
PHP Manual

UI\Controls\MultilineEntry::getText

(PHP 7, UI 0.9.9)

UI\Controls\MultilineEntry::getText — Get Text

Açıklama

public string UI\Controls\MultilineEntry::getText ( void )

Shall return the text in this Multiline Entry

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

UI\Controls\MultilineEntry::__construct
UI\Controls\MultilineEntry::isReadOnly
UI\Controls\MultilineEntry


Read Only Detection

UI\Controls\MultilineEntry::getText
UI\Controls\MultilineEntry::onChange
UI\Controls\MultilineEntry
PHP Manual

UI\Controls\MultilineEntry::isReadOnly

(PHP 7, UI 0.9.9)

UI\Controls\MultilineEntry::isReadOnly — Read Only Detection

Açıklama

public bool UI\Controls\MultilineEntry::isReadOnly ( void )

Shall detect if this Multiline Entry is read only

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

UI\Controls\MultilineEntry::getText
UI\Controls\MultilineEntry::onChange
UI\Controls\MultilineEntry


Change Handler

UI\Controls\MultilineEntry::isReadOnly
UI\Controls\MultilineEntry::setReadOnly
UI\Controls\MultilineEntry
PHP Manual

UI\Controls\MultilineEntry::onChange

(PHP 7, UI 0.9.9)

UI\Controls\MultilineEntry::onChange — Change Handler

Açıklama

protected UI\Controls\MultilineEntry::onChange ( void )

Shall be executed when the text in this Multiline Entry is changed

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

UI\Controls\MultilineEntry::isReadOnly
UI\Controls\MultilineEntry::setReadOnly
UI\Controls\MultilineEntry


Set Read Only

UI\Controls\MultilineEntry::onChange
UI\Controls\MultilineEntry::setText
UI\Controls\MultilineEntry
PHP Manual

UI\Controls\MultilineEntry::setReadOnly

(PHP 7, UI 0.9.9)

UI\Controls\MultilineEntry::setReadOnly — Set Read Only

Açıklama

public UI\Controls\MultilineEntry::setReadOnly ( boolean $readOnly )

Shall enable or disable read only on this Multiline Entry

Değiştirgeler

readOnly

UI\Controls\MultilineEntry::onChange
UI\Controls\MultilineEntry::setText
UI\Controls\MultilineEntry


Set Text

UI\Controls\MultilineEntry::setReadOnly
UI\Controls\Spin
UI\Controls\MultilineEntry
PHP Manual

UI\Controls\MultilineEntry::setText

(PHP 7, UI 0.9.9)

UI\Controls\MultilineEntry::setText — Set Text

Açıklama

public UI\Controls\MultilineEntry::setText ( string $text )

Shall set the text in this Multiline Entry

Değiştirgeler

text

The new text

UI\Controls\MultilineEntry::setReadOnly
UI\Controls\Spin
UI\Controls\MultilineEntry


Spin Control

(PHP 7, UI 0.9.9)

Giriş

A Spin box is a text box with an up-down control which changes the integer value in the box, within a defined range

Sınıf Sözdizimi

UI\Controls\Spin extends UI\Control {
/* Constructor */
public __construct ( integer $min , integer $max )
/* Yöntemler */
public int getValue ( void )
protected onChange ( void )
public setValue ( integer $value )
/* Miras alınan yöntemler */
public UI\Control::destroy ( void )
public UI\Control::disable ( void )
public UI\Control::enable ( void )
public UI\Control UI\Control::getParent ( void )
public int UI\Control::getTopLevel ( void )
public UI\Control::hide ( void )
public bool UI\Control::isEnabled ( void )
public bool UI\Control::isVisible ( void )
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( void )
}

İçindekiler

  • UI\Controls\Spin::__construct — Construct a new Spin
  • UI\Controls\Spin::getValue — Get Value
  • UI\Controls\Spin::onChange — Change Handler
  • UI\Controls\Spin::setValue — Set Value
UI\Controls\MultilineEntry::setText
UI\Controls\Spin::__construct
UI


Construct a new Spin

UI\Controls\Spin
UI\Controls\Spin::getValue
UI\Controls\Spin
PHP Manual

UI\Controls\Spin::__construct

(PHP 7, UI 0.9.9)

UI\Controls\Spin::__construct — Construct a new Spin

Açıklama

public UI\Controls\Spin::__construct ( integer $min , integer $max )

Constructs a new Spin with the given range

Değiştirgeler

min

The minimum value allowed

max

The maximum value allowed

UI\Controls\Spin
UI\Controls\Spin::getValue
UI\Controls\Spin


Get Value

UI\Controls\Spin::__construct
UI\Controls\Spin::onChange
UI\Controls\Spin
PHP Manual

UI\Controls\Spin::getValue

(PHP 7, UI 0.9.9)

UI\Controls\Spin::getValue — Get Value

Açıklama

public int UI\Controls\Spin::getValue ( void )

Get the value in this Spin

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

UI\Controls\Spin::__construct
UI\Controls\Spin::onChange
UI\Controls\Spin


Change Handler

UI\Controls\Spin::getValue
UI\Controls\Spin::setValue
UI\Controls\Spin
PHP Manual

UI\Controls\Spin::onChange

(PHP 7, UI 0.9.9)

UI\Controls\Spin::onChange — Change Handler

Açıklama

protected UI\Controls\Spin::onChange ( void )

Shall be executed when the value in this Spin changes

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

UI\Controls\Spin::getValue
UI\Controls\Spin::setValue
UI\Controls\Spin


Set Value

UI\Controls\Spin::onChange
UI\Controls\Slider
UI\Controls\Spin
PHP Manual

UI\Controls\Spin::setValue

(PHP 7, UI 0.9.9)

UI\Controls\Spin::setValue — Set Value

Açıklama

public UI\Controls\Spin::setValue ( integer $value )

Set the value in this Spin

Değiştirgeler

value

The new value

UI\Controls\Spin::onChange
UI\Controls\Slider
UI\Controls\Spin


Slider Control

(PHP 7, UI 0.9.9)

Giriş

A Slider is a control which represents a range, and a current value in the range. The sliding element of the control (sometimes called the "thumb") reflects the value, and can be adjusted within the range.

Sınıf Sözdizimi

UI\Controls\Slider extends UI\Control {
/* Constructor */
public __construct ( integer $min , integer $max )
/* Yöntemler */
public integer getValue ( void )
protected onChange ( void )
public setValue ( integer $value )
/* Miras alınan yöntemler */
public UI\Control::destroy ( void )
public UI\Control::disable ( void )
public UI\Control::enable ( void )
public UI\Control UI\Control::getParent ( void )
public int UI\Control::getTopLevel ( void )
public UI\Control::hide ( void )
public bool UI\Control::isEnabled ( void )
public bool UI\Control::isVisible ( void )
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( void )
}

İçindekiler

  • UI\Controls\Slider::__construct — Construct a new Slider
  • UI\Controls\Slider::getValue — Get Value
  • UI\Controls\Slider::onChange — Change Handler
  • UI\Controls\Slider::setValue — Set Value
UI\Controls\Spin::setValue
UI\Controls\Slider::__construct
UI


Construct a new Slider

UI\Controls\Slider
UI\Controls\Slider::getValue
UI\Controls\Slider
PHP Manual

UI\Controls\Slider::__construct

(PHP 7, UI 0.9.9)

UI\Controls\Slider::__construct — Construct a new Slider

Açıklama

public UI\Controls\Slider::__construct ( integer $min , integer $max )

Construct a new Slider with the given range

Değiştirgeler

min

The minimum allowed value

max

The maximum allowed value

UI\Controls\Slider
UI\Controls\Slider::getValue
UI\Controls\Slider


Get Value

UI\Controls\Slider::__construct
UI\Controls\Slider::onChange
UI\Controls\Slider
PHP Manual

UI\Controls\Slider::getValue

(PHP 7, UI 0.9.9)

UI\Controls\Slider::getValue — Get Value

Açıklama

public integer UI\Controls\Slider::getValue ( void )

Get the value from this Slider

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

UI\Controls\Slider::__construct
UI\Controls\Slider::onChange
UI\Controls\Slider


Change Handler

UI\Controls\Slider::getValue
UI\Controls\Slider::setValue
UI\Controls\Slider
PHP Manual

UI\Controls\Slider::onChange

(PHP 7, UI 0.9.9)

UI\Controls\Slider::onChange — Change Handler

Açıklama

protected UI\Controls\Slider::onChange ( void )

Shall be executed when the value of this Slider changes

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

UI\Controls\Slider::getValue
UI\Controls\Slider::setValue
UI\Controls\Slider


Set Value

UI\Controls\Slider::onChange
UI\Controls\Progress
UI\Controls\Slider
PHP Manual

UI\Controls\Slider::setValue

(PHP 7, UI 0.9.9)

UI\Controls\Slider::setValue — Set Value

Açıklama

public UI\Controls\Slider::setValue ( integer $value )

Shall set the value for this Slider

Değiştirgeler

value

The new value

UI\Controls\Slider::onChange
UI\Controls\Progress
UI\Controls\Slider


Progress Control

(PHP 7, UI 0.9.9)

Giriş

A Progress control is a familiar Progress bar: It represents progress as a percentage, with a possible range of 0 to 100 (inclusive).

Sınıf Sözdizimi

UI\Controls\Progress extends UI\Control {
/* Yöntemler */
public int getValue ( void )
public setValue ( integer $value )
/* Miras alınan yöntemler */
public UI\Control::destroy ( void )
public UI\Control::disable ( void )
public UI\Control::enable ( void )
public UI\Control UI\Control::getParent ( void )
public int UI\Control::getTopLevel ( void )
public UI\Control::hide ( void )
public bool UI\Control::isEnabled ( void )
public bool UI\Control::isVisible ( void )
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( void )
}

İçindekiler

  • UI\Controls\Progress::getValue — Get Value
  • UI\Controls\Progress::setValue — Set Value
UI\Controls\Slider::setValue
UI\Controls\Progress::getValue
UI


Get Value

UI\Controls\Progress
UI\Controls\Progress::setValue
UI\Controls\Progress
PHP Manual

UI\Controls\Progress::getValue

(PHP 7, UI 0.9.9)

UI\Controls\Progress::getValue — Get Value

Açıklama

public int UI\Controls\Progress::getValue ( void )

Shall retrieve the current value of this Progress bar

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

UI\Controls\Progress
UI\Controls\Progress::setValue
UI\Controls\Progress


Set Value

UI\Controls\Progress::getValue
UI\Controls\Separator
UI\Controls\Progress
PHP Manual

UI\Controls\Progress::setValue

(PHP 7, UI 0.9.9)

UI\Controls\Progress::setValue — Set Value

Açıklama

public UI\Controls\Progress::setValue ( integer $value )

Shall set the value for this Progress bar

Değiştirgeler

value

An integer between 0 and 100 (inclusive)

UI\Controls\Progress::getValue
UI\Controls\Separator
UI\Controls\Progress


Control Separator

(PHP 7, UI 0.9.9)

Giriş

A Separator represents a control separator, it has no other function.

Sınıf Sözdizimi

UI\Controls\Separator extends UI\Control {
/* Constants */
const integer Horizontal ;
const integer Vertical ;
/* Constructor */
public __construct ([ integer $type = UI\Controls\Separator::Horizontal ] )
/* Miras alınan yöntemler */
public UI\Control::destroy ( void )
public UI\Control::disable ( void )
public UI\Control::enable ( void )
public UI\Control UI\Control::getParent ( void )
public int UI\Control::getTopLevel ( void )
public UI\Control::hide ( void )
public bool UI\Control::isEnabled ( void )
public bool UI\Control::isVisible ( void )
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( void )
}

Öntanımlı Sabitler

UI\Controls\Separator::Horizontal

A Horizontal Separator

UI\Controls\Separator::Vertical

A Vertical Separator

İçindekiler

  • UI\Controls\Separator::__construct — Construct a new Separator
UI\Controls\Progress::setValue
UI\Controls\Separator::__construct
UI


Construct a new Separator

UI\Controls\Separator
UI\Controls\Combo
UI\Controls\Separator
PHP Manual

UI\Controls\Separator::__construct

(PHP 7, UI 0.9.9)

UI\Controls\Separator::__construct — Construct a new Separator

Açıklama

public UI\Controls\Separator::__construct ([ integer $type = UI\Controls\Separator::Horizontal ] )

Shall construct a new Separator of the given type

Değiştirgeler

type

Separator::Horizonal or Separator::Vertical

UI\Controls\Separator
UI\Controls\Combo
UI\Controls\Separator


Combo Control

(PHP 7, UI 0.9.9)

Giriş

A Combo control represents a list of options, like the familiar select HTML element.

Sınıf Sözdizimi

UI\Controls\Combo extends UI\Control {
/* Yöntemler */
public append ( string $text )
public integer getSelected ( void )
protected onSelected ( void )
public setSelected ( integer $index )
/* Miras alınan yöntemler */
public UI\Control::destroy ( void )
public UI\Control::disable ( void )
public UI\Control::enable ( void )
public UI\Control UI\Control::getParent ( void )
public int UI\Control::getTopLevel ( void )
public UI\Control::hide ( void )
public bool UI\Control::isEnabled ( void )
public bool UI\Control::isVisible ( void )
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( void )
}

İçindekiler

  • UI\Controls\Combo::append — Append Option
  • UI\Controls\Combo::getSelected — Get Selected Option
  • UI\Controls\Combo::onSelected — Selected Handler
  • UI\Controls\Combo::setSelected — Set Selected Option
UI\Controls\Separator::__construct
UI\Controls\Combo::append
UI


Append Option

UI\Controls\Combo
UI\Controls\Combo::getSelected
UI\Controls\Combo
PHP Manual

UI\Controls\Combo::append

(PHP 7, UI 0.9.9)

UI\Controls\Combo::append — Append Option

Açıklama

public UI\Controls\Combo::append ( string $text )

Append an option to this Combo

Değiştirgeler

text

The text for the new option

UI\Controls\Combo
UI\Controls\Combo::getSelected
UI\Controls\Combo


Get Selected Option

UI\Controls\Combo::append
UI\Controls\Combo::onSelected
UI\Controls\Combo
PHP Manual

UI\Controls\Combo::getSelected

(PHP 7, UI 0.9.9)

UI\Controls\Combo::getSelected — Get Selected Option

Açıklama

public integer UI\Controls\Combo::getSelected ( void )

Shall retrieve the index of the option selected in this Combo

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

UI\Controls\Combo::append
UI\Controls\Combo::onSelected
UI\Controls\Combo


Selected Handler

UI\Controls\Combo::getSelected
UI\Controls\Combo::setSelected
UI\Controls\Combo
PHP Manual

UI\Controls\Combo::onSelected

(PHP 7, UI 0.9.9)

UI\Controls\Combo::onSelected — Selected Handler

Açıklama

protected UI\Controls\Combo::onSelected ( void )

Shall be executed when an option is selected in this Combo

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

UI\Controls\Combo::getSelected
UI\Controls\Combo::setSelected
UI\Controls\Combo


Set Selected Option

UI\Controls\Combo::onSelected
UI\Controls\EditableCombo
UI\Controls\Combo
PHP Manual

UI\Controls\Combo::setSelected

(PHP 7, UI 0.9.9)

UI\Controls\Combo::setSelected — Set Selected Option

Açıklama

public UI\Controls\Combo::setSelected ( integer $index )

Shall set the currently selected option in this Combo

Değiştirgeler

index

The index of the option to select

UI\Controls\Combo::onSelected
UI\Controls\EditableCombo
UI\Controls\Combo


EdiableCombo Control

(PHP 7, UI 0.9.9)

Giriş

An Editable Combo is a Combo which allows the user to enter custom options

Sınıf Sözdizimi

UI\Controls\EditableCombo extends UI\Control {
/* Yöntemler */
public append ( string $text )
public string getText ( void )
protected onChange ( void )
public setText ( string $text )
/* Miras alınan yöntemler */
public UI\Control::destroy ( void )
public UI\Control::disable ( void )
public UI\Control::enable ( void )
public UI\Control UI\Control::getParent ( void )
public int UI\Control::getTopLevel ( void )
public UI\Control::hide ( void )
public bool UI\Control::isEnabled ( void )
public bool UI\Control::isVisible ( void )
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( void )
}

İçindekiler

  • UI\Controls\EditableCombo::append — Append Option
  • UI\Controls\EditableCombo::getText — Get Text
  • UI\Controls\EditableCombo::onChange — Change Handler
  • UI\Controls\EditableCombo::setText — Set Text
UI\Controls\Combo::setSelected
UI\Controls\EditableCombo::append
UI


Append Option

UI\Controls\EditableCombo
UI\Controls\EditableCombo::getText
UI\Controls\EditableCombo
PHP Manual

UI\Controls\EditableCombo::append

(PHP 7, UI 0.9.9)

UI\Controls\EditableCombo::append — Append Option

Açıklama

public UI\Controls\EditableCombo::append ( string $text )

Shall append a new option to this Editable Combo

Değiştirgeler

text

The text for the new option

UI\Controls\EditableCombo
UI\Controls\EditableCombo::getText
UI\Controls\EditableCombo


Get Text

UI\Controls\EditableCombo::append
UI\Controls\EditableCombo::onChange
UI\Controls\EditableCombo
PHP Manual

UI\Controls\EditableCombo::getText

(PHP 7, UI 0.9.9)

UI\Controls\EditableCombo::getText — Get Text

Açıklama

public string UI\Controls\EditableCombo::getText ( void )

Get the value of the currently selected option in this Editable Combo

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

UI\Controls\EditableCombo::append
UI\Controls\EditableCombo::onChange
UI\Controls\EditableCombo


Change Handler

UI\Controls\EditableCombo::getText
UI\Controls\EditableCombo::setText
UI\Controls\EditableCombo
PHP Manual

UI\Controls\EditableCombo::onChange

(PHP 7, UI 0.9.9)

UI\Controls\EditableCombo::onChange — Change Handler

Açıklama

protected UI\Controls\EditableCombo::onChange ( void )

Shall be executed when the value of this Editable Combobox changes

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

UI\Controls\EditableCombo::getText
UI\Controls\EditableCombo::setText
UI\Controls\EditableCombo


Set Text

UI\Controls\EditableCombo::onChange
UI\Controls\Radio
UI\Controls\EditableCombo
PHP Manual

UI\Controls\EditableCombo::setText

(PHP 7, UI 0.9.9)

UI\Controls\EditableCombo::setText — Set Text

Açıklama

public UI\Controls\EditableCombo::setText ( string $text )

Shall set the text of the currently selected option in this Editable Combo

Değiştirgeler

text

The new text

UI\Controls\EditableCombo::onChange
UI\Controls\Radio
UI\Controls\EditableCombo


Radio Control

(PHP 7, UI 0.9.9)

Giriş

A Radio is similar to the radio input type familiar from HTML

Sınıf Sözdizimi

UI\Controls\Radio extends UI\Control {
/* Yöntemler */
public append ( string $text )
public integer getSelected ( void )
protected onSelected ( void )
public setSelected ( integer $index )
/* Miras alınan yöntemler */
public UI\Control::destroy ( void )
public UI\Control::disable ( void )
public UI\Control::enable ( void )
public UI\Control UI\Control::getParent ( void )
public int UI\Control::getTopLevel ( void )
public UI\Control::hide ( void )
public bool UI\Control::isEnabled ( void )
public bool UI\Control::isVisible ( void )
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( void )
}

İçindekiler

  • UI\Controls\Radio::append — Append Option
  • UI\Controls\Radio::getSelected — Get Selected Option
  • UI\Controls\Radio::onSelected — Selected Handler
  • UI\Controls\Radio::setSelected — Set Selected Option
UI\Controls\EditableCombo::setText
UI\Controls\Radio::append
UI


Append Option

UI\Controls\Radio
UI\Controls\Radio::getSelected
UI\Controls\Radio
PHP Manual

UI\Controls\Radio::append

(PHP 7, UI 0.9.9)

UI\Controls\Radio::append — Append Option

Açıklama

public UI\Controls\Radio::append ( string $text )

Shall append a new option to this Radio

Değiştirgeler

text

The text (label) for the option

UI\Controls\Radio
UI\Controls\Radio::getSelected
UI\Controls\Radio


Get Selected Option

UI\Controls\Radio::append
UI\Controls\Radio::onSelected
UI\Controls\Radio
PHP Manual

UI\Controls\Radio::getSelected

(PHP 7, UI 0.9.9)

UI\Controls\Radio::getSelected — Get Selected Option

Açıklama

public integer UI\Controls\Radio::getSelected ( void )

Shall retrieve the index of the currently selected option in this Radio

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

UI\Controls\Radio::append
UI\Controls\Radio::onSelected
UI\Controls\Radio


Selected Handler

UI\Controls\Radio::getSelected
UI\Controls\Radio::setSelected
UI\Controls\Radio
PHP Manual

UI\Controls\Radio::onSelected

(PHP 7, UI 0.9.9)

UI\Controls\Radio::onSelected — Selected Handler

Açıklama

protected UI\Controls\Radio::onSelected ( void )

Shall be executed when the option selected in this Radio changes

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

UI\Controls\Radio::getSelected
UI\Controls\Radio::setSelected
UI\Controls\Radio


Set Selected Option

UI\Controls\Radio::onSelected
UI\Controls\Picker
UI\Controls\Radio
PHP Manual

UI\Controls\Radio::setSelected

(PHP 7, UI 0.9.9)

UI\Controls\Radio::setSelected — Set Selected Option

Açıklama

public UI\Controls\Radio::setSelected ( integer $index )

Shall set the currently selected option in this Radio

Değiştirgeler

index

The index of the option to select

UI\Controls\Radio::onSelected
UI\Controls\Picker
UI\Controls\Radio


Picker Control

(PHP 7, UI 0.9.9)

Giriş

A Picker represents a button which when clicked presents a native Date/Time/DateTime Picker interface to the user.

Sınıf Sözdizimi

UI\Controls\Picker extends UI\Control {
/* Constants */
const integer Date ;
const integer Time ;
const integer DateTime ;
/* Constructor */
public __construct ([ integer $type = UI\Controls\Picker::Date ] )
/* Miras alınan yöntemler */
public UI\Control::destroy ( void )
public UI\Control::disable ( void )
public UI\Control::enable ( void )
public UI\Control UI\Control::getParent ( void )
public int UI\Control::getTopLevel ( void )
public UI\Control::hide ( void )
public bool UI\Control::isEnabled ( void )
public bool UI\Control::isVisible ( void )
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( void )
}

Öntanımlı Sabitler

UI\Controls\Picker::Date

A Date Picker

UI\Controls\Picker::Time

A Time Picker

UI\Controls\Picker::DateTime

A Date and Time Picker

İçindekiler

  • UI\Controls\Picker::__construct — Construct a new Picker
UI\Controls\Radio::setSelected
UI\Controls\Picker::__construct
UI


Construct a new Picker

UI\Controls\Picker
UI\Controls\Form
UI\Controls\Picker
PHP Manual

UI\Controls\Picker::__construct

(PHP 7, UI 0.9.9)

UI\Controls\Picker::__construct — Construct a new Picker

Açıklama

public UI\Controls\Picker::__construct ([ integer $type = UI\Controls\Picker::Date ] )

Construct a new Picker of the given type

Değiştirgeler

type

Picker::Date, Picker::Time, or Picker::DateTime

UI\Controls\Picker
UI\Controls\Form
UI\Controls\Picker


Control Form (Arrangement)

(PHP 7, UI 0.9.9)

Giriş

A Form is a control which allows the arrangement of other controls into a familiar layout (the form).

Sınıf Sözdizimi

UI\Controls\Form extends UI\Control {
/* Özellikler */
protected $controls ;
/* Yöntemler */
public integer append ( string $label , UI\Control $control [, boolean $stretchy = false ] )
public boolean delete ( integer $index )
public bool isPadded ( void )
public setPadded ( boolean $padded )
/* Miras alınan yöntemler */
public UI\Control::destroy ( void )
public UI\Control::disable ( void )
public UI\Control::enable ( void )
public UI\Control UI\Control::getParent ( void )
public int UI\Control::getTopLevel ( void )
public UI\Control::hide ( void )
public bool UI\Control::isEnabled ( void )
public bool UI\Control::isVisible ( void )
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( void )
}

Özellikler

controls

Contains controls, should not be manipulated directly

İçindekiler

  • UI\Controls\Form::append — Append Control
  • UI\Controls\Form::delete — Delete Control
  • UI\Controls\Form::isPadded — Padding Detection
  • UI\Controls\Form::setPadded — Set Padding
UI\Controls\Picker::__construct
UI\Controls\Form::append
UI


Append Control

UI\Controls\Form
UI\Controls\Form::delete
UI\Controls\Form
PHP Manual

UI\Controls\Form::append

(PHP 7, UI 0.9.9)

UI\Controls\Form::append — Append Control

Açıklama

public integer UI\Controls\Form::append ( string $label , UI\Control $control [, boolean $stretchy = false ] )

Shall append the control to the form, and set the label

Değiştirgeler

label

The text for the label

control

A control

stretchy

Should be set true to stretch the control

Dönen Değerler

Shall return the index of the appended control, may be 0

UI\Controls\Form
UI\Controls\Form::delete
UI\Controls\Form


Delete Control

UI\Controls\Form::append
UI\Controls\Form::isPadded
UI\Controls\Form
PHP Manual

UI\Controls\Form::delete

(PHP 7, UI 0.9.9)

UI\Controls\Form::delete — Delete Control

Açıklama

public boolean UI\Controls\Form::delete ( integer $index )

Shall delete the control at the given index in this Form

Değiştirgeler

index

The index of the control to remove

Dönen Değerler

Indication of succcess

UI\Controls\Form::append
UI\Controls\Form::isPadded
UI\Controls\Form


Padding Detection

UI\Controls\Form::delete
UI\Controls\Form::setPadded
UI\Controls\Form
PHP Manual

UI\Controls\Form::isPadded

(PHP 7, UI 0.9.9)

UI\Controls\Form::isPadded — Padding Detection

Açıklama

public bool UI\Controls\Form::isPadded ( void )

Shall detect if padding is enabled on this Form

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

UI\Controls\Form::delete
UI\Controls\Form::setPadded
UI\Controls\Form


Set Padding

UI\Controls\Form::isPadded
UI\Controls\Grid
UI\Controls\Form
PHP Manual

UI\Controls\Form::setPadded

(PHP 7, UI 0.9.9)

UI\Controls\Form::setPadded — Set Padding

Açıklama

public UI\Controls\Form::setPadded ( boolean $padded )

Shall enable or disable padding on this Form

Değiştirgeler

padded

UI\Controls\Form::isPadded
UI\Controls\Grid
UI\Controls\Form


Control Grid (Arrangement)

(PHP 7, UI 0.9.9)

Giriş

A Grid is a control which is allows the arrangement of children into a grid

Sınıf Sözdizimi

UI\Controls\Grid extends UI\Control {
/* Constants */
const integer Fill ;
const integer Start ;
const integer Center ;
const integer End ;
const integer Leading ;
const integer Top ;
const integer Trailing ;
const integer Bottom ;
/* Özellikler */
protected $controls ;
/* Yöntemler */
public append ( UI\Control $control , integer $left , integer $top , integer $xspan , integer $yspan , boolean $hexpand , integer $halign , boolean $vexpand , integer $valign )
public bool isPadded ( void )
public setPadded ( boolean $padding )
/* Miras alınan yöntemler */
public UI\Control::destroy ( void )
public UI\Control::disable ( void )
public UI\Control::enable ( void )
public UI\Control UI\Control::getParent ( void )
public int UI\Control::getTopLevel ( void )
public UI\Control::hide ( void )
public bool UI\Control::isEnabled ( void )
public bool UI\Control::isVisible ( void )
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( void )
}

Öntanımlı Sabitler

UI\Controls\Grid::Fill

UI\Controls\Grid::Start

UI\Controls\Grid::Center

UI\Controls\Grid::End

UI\Controls\Grid::Leading

UI\Controls\Grid::Top

UI\Controls\Grid::Trailing

UI\Controls\Grid::Bottom

Özellikler

controls

Contains controls, should not be manipulated directly

İçindekiler

  • UI\Controls\Grid::append — Append Control
  • UI\Controls\Grid::isPadded — Padding Detection
  • UI\Controls\Grid::setPadded — Set Padding
UI\Controls\Form::setPadded
UI\Controls\Grid::append
UI


Append Control

UI\Controls\Grid
UI\Controls\Grid::isPadded
UI\Controls\Grid
PHP Manual

UI\Controls\Grid::append

(PHP 7, UI 0.9.9)

UI\Controls\Grid::append — Append Control

Açıklama

public UI\Controls\Grid::append ( UI\Control $control , integer $left , integer $top , integer $xspan , integer $yspan , boolean $hexpand , integer $halign , boolean $vexpand , integer $valign )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

control

The Control to append

left

top

xspan

yspan

hexpand

halign

vexpand

valign

Dönen Değerler

UI\Controls\Grid
UI\Controls\Grid::isPadded
UI\Controls\Grid


Padding Detection

UI\Controls\Grid::append
UI\Controls\Grid::setPadded
UI\Controls\Grid
PHP Manual

UI\Controls\Grid::isPadded

(PHP 7, UI 0.9.9)

UI\Controls\Grid::isPadded — Padding Detection

Açıklama

public bool UI\Controls\Grid::isPadded ( void )

Shall detect if padding is enabled on this Grid

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

UI\Controls\Grid::append
UI\Controls\Grid::setPadded
UI\Controls\Grid


Set Padding

UI\Controls\Grid::isPadded
UI\Controls\Group
UI\Controls\Grid
PHP Manual

UI\Controls\Grid::setPadded

(PHP 7, UI 0.9.9)

UI\Controls\Grid::setPadded — Set Padding

Açıklama

public UI\Controls\Grid::setPadded ( boolean $padding )

Shall enable or disable padding for this Grid

Değiştirgeler

padding

UI\Controls\Grid::isPadded
UI\Controls\Group
UI\Controls\Grid


Control Group (Arrangement)

(PHP 7, UI 0.9.9)

Giriş

A Group is a titled container for child controls

Sınıf Sözdizimi

UI\Controls\Group extends UI\Control {
/* Özellikler */
protected $controls ;
/* Constructor */
public __construct ( string $title )
/* Yöntemler */
public append ( UI\Control $control )
public string getTitle ( void )
public bool hasMargin ( void )
public setMargin ( boolean $margin )
public setTitle ( string $title )
/* Miras alınan yöntemler */
public UI\Control::destroy ( void )
public UI\Control::disable ( void )
public UI\Control::enable ( void )
public UI\Control UI\Control::getParent ( void )
public int UI\Control::getTopLevel ( void )
public UI\Control::hide ( void )
public bool UI\Control::isEnabled ( void )
public bool UI\Control::isVisible ( void )
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( void )
}

Özellikler

controls

Contains controls, should not be manipulated directly

İçindekiler

  • UI\Controls\Group::append — Append Control
  • UI\Controls\Group::__construct — Construct a new Group
  • UI\Controls\Group::getTitle — Get Title
  • UI\Controls\Group::hasMargin — Margin Detection
  • UI\Controls\Group::setMargin — Set Margin
  • UI\Controls\Group::setTitle — Set Title
UI\Controls\Grid::setPadded
UI\Controls\Group::append
UI


Append Control

UI\Controls\Group
UI\Controls\Group::__construct
UI\Controls\Group
PHP Manual

UI\Controls\Group::append

(Bir sürüm bilgisi bulunamadı; sadece SVN'de olabilir.)

UI\Controls\Group::append — Append Control

Açıklama

public UI\Controls\Group::append ( UI\Control $control )

Shall append a control to this Group

Değiştirgeler

control

The control to append

UI\Controls\Group
UI\Controls\Group::__construct
UI\Controls\Group


Construct a new Group

UI\Controls\Group::append
UI\Controls\Group::getTitle
UI\Controls\Group
PHP Manual

UI\Controls\Group::__construct

(PHP 7, UI 0.9.9)

UI\Controls\Group::__construct — Construct a new Group

Açıklama

public UI\Controls\Group::__construct ( string $title )

Shall construct a new Group with the given title

Değiştirgeler

title

The text for the title label

UI\Controls\Group::append
UI\Controls\Group::getTitle
UI\Controls\Group


Get Title

UI\Controls\Group::__construct
UI\Controls\Group::hasMargin
UI\Controls\Group
PHP Manual

UI\Controls\Group::getTitle

(PHP 7, UI 0.9.9)

UI\Controls\Group::getTitle — Get Title

Açıklama

public string UI\Controls\Group::getTitle ( void )

Shall return the current title for this Group

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current title

UI\Controls\Group::__construct
UI\Controls\Group::hasMargin
UI\Controls\Group


Margin Detection

UI\Controls\Group::getTitle
UI\Controls\Group::setMargin
UI\Controls\Group
PHP Manual

UI\Controls\Group::hasMargin

(PHP 7, UI 0.9.9)

UI\Controls\Group::hasMargin — Margin Detection

Açıklama

public bool UI\Controls\Group::hasMargin ( void )

Shall detect if this Group has a margin

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

UI\Controls\Group::getTitle
UI\Controls\Group::setMargin
UI\Controls\Group


Set Margin

UI\Controls\Group::hasMargin
UI\Controls\Group::setTitle
UI\Controls\Group
PHP Manual

UI\Controls\Group::setMargin

(PHP 7, UI 0.9.9)

UI\Controls\Group::setMargin — Set Margin

Açıklama

public UI\Controls\Group::setMargin ( boolean $margin )

Shall enable or disable margins for this Group

Değiştirgeler

margin

UI\Controls\Group::hasMargin
UI\Controls\Group::setTitle
UI\Controls\Group


Set Title

UI\Controls\Group::setMargin
UI\Controls\Box
UI\Controls\Group
PHP Manual

UI\Controls\Group::setTitle

(PHP 7, UI 0.9.9)

UI\Controls\Group::setTitle — Set Title

Açıklama

public UI\Controls\Group::setTitle ( string $title )

Shall set the title for this Group

Değiştirgeler

title

The text for the new title

UI\Controls\Group::setMargin
UI\Controls\Box
UI\Controls\Group


Control Box (Arrangement)

(PHP 7, UI 0.9.9)

Giriş

A Box allows the arrangement of other controls

Sınıf Sözdizimi

UI\Controls\Box extends UI\Control {
/* Constants */
const integer Vertical ;
const integer Horizontal ;
/* Özellikler */
protected $controls ;
/* Constructor */
public __construct ([ integer $orientation = UI\Controls\Box::Horizontal ] )
/* Yöntemler */
public integer append ( Control $control [, boolean $stretchy = false ] )
public boolean delete ( integer $index )
public integer getOrientation ( void )
public bool isPadded ( void )
public setPadded ( boolean $padded )
/* Miras alınan yöntemler */
public UI\Control::destroy ( void )
public UI\Control::disable ( void )
public UI\Control::enable ( void )
public UI\Control UI\Control::getParent ( void )
public int UI\Control::getTopLevel ( void )
public UI\Control::hide ( void )
public bool UI\Control::isEnabled ( void )
public bool UI\Control::isVisible ( void )
public UI\Control::setParent ( UI\Control $parent )
public UI\Control::show ( void )
}

Özellikler

controls

Contains controls, should not be manipulated directly

Öntanımlı Sabitler

UI\Controls\Box::Vertical

UI\Controls\Box::Horizontal

İçindekiler

  • UI\Controls\Box::append — Append Control
  • UI\Controls\Box::__construct — Construct a new Box
  • UI\Controls\Box::delete — Delete Control
  • UI\Controls\Box::getOrientation — Get Orientation
  • UI\Controls\Box::isPadded — Padding Detection
  • UI\Controls\Box::setPadded — Set Padding
UI\Controls\Group::setTitle
UI\Controls\Box::append
UI


Append Control

UI\Controls\Box
UI\Controls\Box::__construct
UI\Controls\Box
PHP Manual

UI\Controls\Box::append

(PHP 7, UI 0.9.9)

UI\Controls\Box::append — Append Control

Açıklama

public integer UI\Controls\Box::append ( Control $control [, boolean $stretchy = false ] )

Shall append the given control to this Box

Değiştirgeler

control

The control to append

stretchy

Set true to stretch the control

Dönen Değerler

Shall return the index of the appended control, may be 0

UI\Controls\Box
UI\Controls\Box::__construct
UI\Controls\Box


Construct a new Box

UI\Controls\Box::append
UI\Controls\Box::delete
UI\Controls\Box
PHP Manual

UI\Controls\Box::__construct

(PHP 7, UI 0.9.9)

UI\Controls\Box::__construct — Construct a new Box

Açıklama

public UI\Controls\Box::__construct ([ integer $orientation = UI\Controls\Box::Horizontal ] )

Shall construct a new box

Değiştirgeler

orientation

Box::Horizontal or Box::Vertical

UI\Controls\Box::append
UI\Controls\Box::delete
UI\Controls\Box


Delete Control

UI\Controls\Box::__construct
UI\Controls\Box::getOrientation
UI\Controls\Box
PHP Manual

UI\Controls\Box::delete

(PHP 7, UI 0.9.9)

UI\Controls\Box::delete — Delete Control

Açıklama

public boolean UI\Controls\Box::delete ( integer $index )

Shall delete the control at the given index from this Box

Değiştirgeler

index

The index of the control to delete

Dönen Değerler

Indication of success

UI\Controls\Box::__construct
UI\Controls\Box::getOrientation
UI\Controls\Box


Get Orientation

UI\Controls\Box::delete
UI\Controls\Box::isPadded
UI\Controls\Box
PHP Manual

UI\Controls\Box::getOrientation

(PHP 7, UI 0.9.9)

UI\Controls\Box::getOrientation — Get Orientation

Açıklama

public integer UI\Controls\Box::getOrientation ( void )

Shall retrieve the orientation of this Box

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

UI\Controls\Box::delete
UI\Controls\Box::isPadded
UI\Controls\Box


Padding Detection

UI\Controls\Box::getOrientation
UI\Controls\Box::setPadded
UI\Controls\Box
PHP Manual

UI\Controls\Box::isPadded

(PHP 7, UI 0.9.9)

UI\Controls\Box::isPadded — Padding Detection

Açıklama

public bool UI\Controls\Box::isPadded ( void )

Shall detect if padding is enabled on this Box

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

UI\Controls\Box::getOrientation
UI\Controls\Box::setPadded
UI\Controls\Box


Set Padding

UI\Controls\Box::isPadded
UI\Draw\Pen
UI\Controls\Box
PHP Manual

UI\Controls\Box::setPadded

(PHP 7, UI 0.9.9)

UI\Controls\Box::setPadded — Set Padding

Açıklama

public UI\Controls\Box::setPadded ( boolean $padded )

Shall enable or disable padding on this Box

Değiştirgeler

padded

UI\Controls\Box::isPadded
UI\Draw\Pen
UI\Controls\Box


Draw Pen

(PHP 7, UI 0.9.9)

Giriş

The Pen is passed to the Area Draw event handler, it is used for clipping, filling, stroking, and writing to Draw Paths.

Sınıf Sözdizimi

final UI\Draw\Pen {
/* Yöntemler */
public clip ( UI\Draw\Path $path )
public fill ( UI\Draw\Path $path , UI\Draw\Brush $with )
public fill ( UI\Draw\Path $path , UI\Draw\Color $with )
public fill ( UI\Draw\Path $path , integer $with )
public restore ( void )
public save ( void )
public stroke ( UI\Draw\Path $path , UI\Draw\Brush $with , UI\Draw\Stroke $stroke )
public stroke ( UI\Draw\Path $path , UI\Draw\Color $with , UI\Draw\Stroke $stroke )
public stroke ( UI\Draw\Path $path , integer $with , UI\Draw\Stroke $stroke )
public transform ( UI\Draw\Matrix $matrix )
public write ( UI\Point $point , UI\Draw\Text\Layout $layout )
}

İçindekiler

  • UI\Draw\Pen::clip — Clip a Path
  • UI\Draw\Pen::fill — Fill a Path
  • UI\Draw\Pen::restore — Restore
  • UI\Draw\Pen::save — Save
  • UI\Draw\Pen::stroke — Stroke a Path
  • UI\Draw\Pen::transform — Matrix Transform
  • UI\Draw\Pen::write — Draw Text at Point
UI\Controls\Box::setPadded
UI\Draw\Pen::clip
UI


Clip a Path

UI\Draw\Pen
UI\Draw\Pen::fill
UI\Draw\Pen
PHP Manual

UI\Draw\Pen::clip

(PHP 7, UI 0.9.9)

UI\Draw\Pen::clip — Clip a Path

Açıklama

public UI\Draw\Pen::clip ( UI\Draw\Path $path )

Shall clip the given Path

Değiştirgeler

path

The path to clip

UI\Draw\Pen
UI\Draw\Pen::fill
UI\Draw\Pen


Fill a Path

UI\Draw\Pen::clip
UI\Draw\Pen::restore
UI\Draw\Pen
PHP Manual

UI\Draw\Pen::fill

(PHP 7, UI 0.9.9)

UI\Draw\Pen::fill — Fill a Path

Açıklama

public UI\Draw\Pen::fill ( UI\Draw\Path $path , UI\Draw\Brush $with )
public UI\Draw\Pen::fill ( UI\Draw\Path $path , UI\Draw\Color $with )
public UI\Draw\Pen::fill ( UI\Draw\Path $path , integer $with )

Shall fill the given path

Değiştirgeler

path

The path to fill

with

The color or brush to fill with

UI\Draw\Pen::clip
UI\Draw\Pen::restore
UI\Draw\Pen


Restore

UI\Draw\Pen::fill
UI\Draw\Pen::save
UI\Draw\Pen
PHP Manual

UI\Draw\Pen::restore

(PHP 7, UI 0.9.9)

UI\Draw\Pen::restore — Restore

Açıklama

public UI\Draw\Pen::restore ( void )

Shall restore a previously saved Pen

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

UI\Draw\Pen::fill
UI\Draw\Pen::save
UI\Draw\Pen


Save

UI\Draw\Pen::restore
UI\Draw\Pen::stroke
UI\Draw\Pen
PHP Manual

UI\Draw\Pen::save

(PHP 7, UI 0.9.9)

UI\Draw\Pen::save — Save

Açıklama

public UI\Draw\Pen::save ( void )

Shall save the Pen

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

UI\Draw\Pen::restore
UI\Draw\Pen::stroke
UI\Draw\Pen


Stroke a Path

UI\Draw\Pen::save
UI\Draw\Pen::transform
UI\Draw\Pen
PHP Manual

UI\Draw\Pen::stroke

(PHP 7, UI 0.9.9)

UI\Draw\Pen::stroke — Stroke a Path

Açıklama

public UI\Draw\Pen::stroke ( UI\Draw\Path $path , UI\Draw\Brush $with , UI\Draw\Stroke $stroke )
public UI\Draw\Pen::stroke ( UI\Draw\Path $path , UI\Draw\Color $with , UI\Draw\Stroke $stroke )
public UI\Draw\Pen::stroke ( UI\Draw\Path $path , integer $with , UI\Draw\Stroke $stroke )

Shall stroke the given path

Değiştirgeler

path

The path to stroke

with

The color or brush to stroke with

stroke

The configuration of the stroke

UI\Draw\Pen::save
UI\Draw\Pen::transform
UI\Draw\Pen


Matrix Transform

UI\Draw\Pen::stroke
UI\Draw\Pen::write
UI\Draw\Pen
PHP Manual

UI\Draw\Pen::transform

(PHP 7, UI 0.9.9)

UI\Draw\Pen::transform — Matrix Transform

Açıklama

public UI\Draw\Pen::transform ( UI\Draw\Matrix $matrix )

Shall perform matrix transformation

Değiştirgeler

matrix

The matrix to use

UI\Draw\Pen::stroke
UI\Draw\Pen::write
UI\Draw\Pen


Draw Text at Point

UI\Draw\Pen::transform
UI\Draw\Path
UI\Draw\Pen
PHP Manual

UI\Draw\Pen::write

(PHP 7, UI 0.9.9)

UI\Draw\Pen::write — Draw Text at Point

Açıklama

public UI\Draw\Pen::write ( UI\Point $point , UI\Draw\Text\Layout $layout )

Shall draw the given text layout at the given point

Değiştirgeler

point

The point to perform the drawing

layout

The layout of the text to draw

UI\Draw\Pen::transform
UI\Draw\Path
UI\Draw\Pen


Draw Path

(PHP 7, UI 0.9.9)

Giriş

A Draw Path guides a Draw Pen, telling the Pen where to draw on an Area.

Sınıf Sözdizimi

UI\Draw\Path {
/* Constants */
const integer Winding ;
const integer Alternate ;
/* Constructor */
public __construct ([ integer $mode = UI\Draw\Path::Winding ] )
/* Yöntemler */
public addRectangle ( UI\Point $point , UI\Size $size )
public arcTo ( UI\Point $point , float $radius , float $angle , float $sweep , float $negative )
public bezierTo ( UI\Point $point , float $radius , float $angle , float $sweep , float $negative )
public closeFigure ( void )
public end ( void )
public lineTo ( UI\Point $point , float $radius , float $angle , float $sweep , float $negative )
public newFigure ( UI\Point $point )
public newFigureWithArc ( UI\Point $point , float $radius , float $angle , float $sweep , float $negative )
}

Öntanımlı Sabitler

UI\Draw\Path::Winding

This is the default draw path mode

UI\Draw\Path::Alternate

This is the alternate draw path mode

İçindekiler

  • UI\Draw\Path::addRectangle — Draw a Rectangle
  • UI\Draw\Path::arcTo — Draw an Arc
  • UI\Draw\Path::bezierTo — Draw Bezier Curve
  • UI\Draw\Path::closeFigure — Close Figure
  • UI\Draw\Path::__construct — Construct a new Path
  • UI\Draw\Path::end — Finalize Path
  • UI\Draw\Path::lineTo — Draw a Line
  • UI\Draw\Path::newFigure — Draw Figure
  • UI\Draw\Path::newFigureWithArc — Draw Figure with Arc
UI\Draw\Pen::write
UI\Draw\Path::addRectangle
UI


Draw a Rectangle

UI\Draw\Path
UI\Draw\Path::arcTo
UI\Draw\Path
PHP Manual

UI\Draw\Path::addRectangle

(PHP 7, UI 0.9.9)

UI\Draw\Path::addRectangle — Draw a Rectangle

Açıklama

public UI\Draw\Path::addRectangle ( UI\Point $point , UI\Size $size )

Shall map the path of a rectangle of the given size, at the given point

Değiştirgeler

point

The point to begin the shape

size

The size of the rectangle

UI\Draw\Path
UI\Draw\Path::arcTo
UI\Draw\Path


Draw an Arc

UI\Draw\Path::addRectangle
UI\Draw\Path::bezierTo
UI\Draw\Path
PHP Manual

UI\Draw\Path::arcTo

(PHP 7, UI 0.9.9)

UI\Draw\Path::arcTo — Draw an Arc

Açıklama

public UI\Draw\Path::arcTo ( UI\Point $point , float $radius , float $angle , float $sweep , float $negative )

Shall map the path for an arc

Değiştirgeler

point

The point to begin mapping

radius

The radius of the arc

angle

The angle of the arc

sweep

The sweep of the arc

negative

Dönen Değerler

UI\Draw\Path::addRectangle
UI\Draw\Path::bezierTo
UI\Draw\Path


Draw Bezier Curve

UI\Draw\Path::arcTo
UI\Draw\Path::closeFigure
UI\Draw\Path
PHP Manual

UI\Draw\Path::bezierTo

(PHP 7, UI 0.9.9)

UI\Draw\Path::bezierTo — Draw Bezier Curve

Açıklama

public UI\Draw\Path::bezierTo ( UI\Point $point , float $radius , float $angle , float $sweep , float $negative )

Shall draw a bezier curve

Değiştirgeler

point

The point at which to begin mapping

radius

The radius of the curve

angle

The angle of the curve

sweep

The sweep of the curve

negative

UI\Draw\Path::arcTo
UI\Draw\Path::closeFigure
UI\Draw\Path


Close Figure

UI\Draw\Path::bezierTo
UI\Draw\Path::__construct
UI\Draw\Path
PHP Manual

UI\Draw\Path::closeFigure

(PHP 7, UI 0.9.9)

UI\Draw\Path::closeFigure — Close Figure

Açıklama

public UI\Draw\Path::closeFigure ( void )

Shall close the current figure

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

UI\Draw\Path::bezierTo
UI\Draw\Path::__construct
UI\Draw\Path


Construct a new Path

UI\Draw\Path::closeFigure
UI\Draw\Path::end
UI\Draw\Path
PHP Manual

UI\Draw\Path::__construct

(PHP 7, UI 0.9.9)

UI\Draw\Path::__construct — Construct a new Path

Açıklama

public UI\Draw\Path::__construct ([ integer $mode = UI\Draw\Path::Winding ] )

Shall construct a new path in the given mode

Değiştirgeler

mode

Path::Winding or Path::Alternate

UI\Draw\Path::closeFigure
UI\Draw\Path::end
UI\Draw\Path


Finalize Path

UI\Draw\Path::__construct
UI\Draw\Path::lineTo
UI\Draw\Path
PHP Manual

UI\Draw\Path::end

(PHP 7, UI 0.9.9)

UI\Draw\Path::end — Finalize Path

Açıklama

public UI\Draw\Path::end ( void )

Shall finalize this Path

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

UI\Draw\Path::__construct
UI\Draw\Path::lineTo
UI\Draw\Path


Draw a Line

UI\Draw\Path::end
UI\Draw\Path::newFigure
UI\Draw\Path
PHP Manual

UI\Draw\Path::lineTo

(PHP 7, UI 0.9.9)

UI\Draw\Path::lineTo — Draw a Line

Açıklama

public UI\Draw\Path::lineTo ( UI\Point $point , float $radius , float $angle , float $sweep , float $negative )

Shall map the path for a line

Değiştirgeler

point

The point to begin mapping

radius

angle

sweep

negative

Dönen Değerler

UI\Draw\Path::end
UI\Draw\Path::newFigure
UI\Draw\Path


Draw Figure

UI\Draw\Path::lineTo
UI\Draw\Path::newFigureWithArc
UI\Draw\Path
PHP Manual

UI\Draw\Path::newFigure

(PHP 7, UI 0.9.9)

UI\Draw\Path::newFigure — Draw Figure

Açıklama

public UI\Draw\Path::newFigure ( UI\Point $point )

Shall map a new figure at the given point

Değiştirgeler

point

The point to begin mapping

UI\Draw\Path::lineTo
UI\Draw\Path::newFigureWithArc
UI\Draw\Path


Draw Figure with Arc

UI\Draw\Path::newFigure
UI\Draw\Matrix
UI\Draw\Path
PHP Manual

UI\Draw\Path::newFigureWithArc

(PHP 7, UI 0.9.9)

UI\Draw\Path::newFigureWithArc — Draw Figure with Arc

Açıklama

public UI\Draw\Path::newFigureWithArc ( UI\Point $point , float $radius , float $angle , float $sweep , float $negative )

Değiştirgeler

point

radius

angle

sweep

negative

Dönen Değerler

UI\Draw\Path::newFigure
UI\Draw\Matrix
UI\Draw\Path


Draw Matrix

(PHP 7, UI 0.9.9)

Giriş

Sınıf Sözdizimi

UI\Draw\Matrix {
/* Yöntemler */
public invert ( void )
public bool isInvertible ( void )
public UI\Draw\Matrix multiply ( UI\Draw\Matrix $matrix )
public rotate ( UI\Point $point , float $amount )
public scale ( UI\Point $center , UI\Point $point )
public skew ( UI\Point $point , UI\Point $amount )
public translate ( UI\Point $point )
}

İçindekiler

  • UI\Draw\Matrix::invert — Invert Matrix
  • UI\Draw\Matrix::isInvertible — Invertible Detection
  • UI\Draw\Matrix::multiply — Multiply Matrix
  • UI\Draw\Matrix::rotate — Rotate Matrix
  • UI\Draw\Matrix::scale — Scale Matrix
  • UI\Draw\Matrix::skew — Skew Matrix
  • UI\Draw\Matrix::translate — Translate Matrix
UI\Draw\Path::newFigureWithArc
UI\Draw\Matrix::invert
UI


Invert Matrix

UI\Draw\Matrix
UI\Draw\Matrix::isInvertible
UI\Draw\Matrix
PHP Manual

UI\Draw\Matrix::invert

(PHP 7, UI 0.9.9)

UI\Draw\Matrix::invert — Invert Matrix

Açıklama

public UI\Draw\Matrix::invert ( void )

Shall invert this matrix

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

UI\Draw\Matrix
UI\Draw\Matrix::isInvertible
UI\Draw\Matrix


Invertible Detection

UI\Draw\Matrix::invert
UI\Draw\Matrix::multiply
UI\Draw\Matrix
PHP Manual

UI\Draw\Matrix::isInvertible

(PHP 7, UI 0.9.9)

UI\Draw\Matrix::isInvertible — Invertible Detection

Açıklama

public bool UI\Draw\Matrix::isInvertible ( void )

Shall detect if this Matrix may be inverted

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

UI\Draw\Matrix::invert
UI\Draw\Matrix::multiply
UI\Draw\Matrix


Multiply Matrix

UI\Draw\Matrix::isInvertible
UI\Draw\Matrix::rotate
UI\Draw\Matrix
PHP Manual

UI\Draw\Matrix::multiply

(PHP 7, UI 0.9.9)

UI\Draw\Matrix::multiply — Multiply Matrix

Açıklama

public UI\Draw\Matrix UI\Draw\Matrix::multiply ( UI\Draw\Matrix $matrix )

Shall multiply this matrix with the given matrix

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The new Matrix

UI\Draw\Matrix::isInvertible
UI\Draw\Matrix::rotate
UI\Draw\Matrix


Rotate Matrix

UI\Draw\Matrix::multiply
UI\Draw\Matrix::scale
UI\Draw\Matrix
PHP Manual

UI\Draw\Matrix::rotate

(PHP 7, UI 0.9.9)

UI\Draw\Matrix::rotate — Rotate Matrix

Açıklama

public UI\Draw\Matrix::rotate ( UI\Point $point , float $amount )

Shall rotate this Matrix

Değiştirgeler

point

amount

UI\Draw\Matrix::multiply
UI\Draw\Matrix::scale
UI\Draw\Matrix


Scale Matrix

UI\Draw\Matrix::rotate
UI\Draw\Matrix::skew
UI\Draw\Matrix
PHP Manual

UI\Draw\Matrix::scale

(PHP 7, UI 0.9.9)

UI\Draw\Matrix::scale — Scale Matrix

Açıklama

public UI\Draw\Matrix::scale ( UI\Point $center , UI\Point $point )

Shall scale this Matrix

Değiştirgeler

center

point

UI\Draw\Matrix::rotate
UI\Draw\Matrix::skew
UI\Draw\Matrix


Skew Matrix

UI\Draw\Matrix::scale
UI\Draw\Matrix::translate
UI\Draw\Matrix
PHP Manual

UI\Draw\Matrix::skew

(PHP 7, UI 0.9.9)

UI\Draw\Matrix::skew — Skew Matrix

Açıklama

public UI\Draw\Matrix::skew ( UI\Point $point , UI\Point $amount )

Shall skew this Matrix

Değiştirgeler

point

amount

UI\Draw\Matrix::scale
UI\Draw\Matrix::translate
UI\Draw\Matrix


Translate Matrix

UI\Draw\Matrix::skew
UI\Draw\Color
UI\Draw\Matrix
PHP Manual

UI\Draw\Matrix::translate

(PHP 7, UI 0.9.9)

UI\Draw\Matrix::translate — Translate Matrix

Açıklama

public UI\Draw\Matrix::translate ( UI\Point $point )

Shall translate this Matrix

Değiştirgeler

point

UI\Draw\Matrix::skew
UI\Draw\Color
UI\Draw\Matrix


Color Representation

(PHP 7, UI 0.9.9)

Giriş

Represents RGBA colours, individual channels are accessible via public properties.

Sınıf Sözdizimi

UI\Draw\Color {
/* Constants */
const integer Red ;
const integer Green ;
const integer Blue ;
const integer Alpha ;
/* Özellikler */
public $r ;
public $g ;
public $b ;
public $a ;
/* Constructor */
public __construct ([ UI\Draw\Color $color ] )
public __construct ([ integer $color ] )
/* Yöntemler */
public float getChannel ( integer $channel )
public void setChannel ( integer $channel , float $value )
}

Özellikler

r

Provides access to the red channel

g

Provides access to the green channel

b

Provides access to the blue channel

a

Provides access to the alpha channel

Öntanımlı Sabitler

UI\Draw\Color::Red

Identifies the red channel

UI\Draw\Color::Green

Identifies the green channel

UI\Draw\Color::Blue

Identifies the blue channel

UI\Draw\Color::Alpha

Identifies the alpha channel

İçindekiler

  • UI\Draw\Color::__construct — Construct new Color
  • UI\Draw\Color::getChannel — Color Manipulation
  • UI\Draw\Color::setChannel — Color Manipulation
UI\Draw\Matrix::translate
UI\Draw\Color::__construct
UI


Construct new Color

UI\Draw\Color
UI\Draw\Color::getChannel
UI\Draw\Color
PHP Manual

UI\Draw\Color::__construct

(PHP 7, UI 0.9.9)

UI\Draw\Color::__construct — Construct new Color

Açıklama

public UI\Draw\Color::__construct ([ UI\Draw\Color $color ] )
public UI\Draw\Color::__construct ([ integer $color ] )

Shall construct a new color

Değiştirgeler

color

May be UI\Draw\Color or RRGGBBAA

UI\Draw\Color
UI\Draw\Color::getChannel
UI\Draw\Color


Color Manipulation

UI\Draw\Color::__construct
UI\Draw\Color::setChannel
UI\Draw\Color
PHP Manual

UI\Draw\Color::getChannel

(PHP 7, UI 0.9.9)

UI\Draw\Color::getChannel — Color Manipulation

Açıklama

public float UI\Draw\Color::getChannel ( integer $channel )

Shall retrieve the value for a channel

Değiştirgeler

channel

Constant channel identity

Dönen Değerler

The current value of the requested channel

UI\Draw\Color::__construct
UI\Draw\Color::setChannel
UI\Draw\Color


Color Manipulation

UI\Draw\Color::getChannel
UI\Draw\Stroke
UI\Draw\Color
PHP Manual

UI\Draw\Color::setChannel

(PHP 7, UI 0.9.9)

UI\Draw\Color::setChannel — Color Manipulation

Açıklama

public void UI\Draw\Color::setChannel ( integer $channel , float $value )

Shall set the selected channel to the given value

Değiştirgeler

channel

Constant channel identity

value

The new value for the selected channel

Dönen Değerler

UI\Draw\Color::getChannel
UI\Draw\Stroke
UI\Draw\Color


Draw Stroke

(PHP 7, UI 0.9.9)

Giriş

Holds the configuration for the Pen to perform a stroke

Sınıf Sözdizimi

UI\Draw\Stroke {
/* Constructor */
public __construct ([ integer $cap = UI\Draw\Line\Cap::Flat [, integer $join = UI\Draw\Line\Join::Miter [, float $thickness = 1 [, float $miterLimit = 10 ]]]] )
/* Yöntemler */
public integer getCap ( void )
public integer getJoin ( void )
public float getMiterLimit ( void )
public float getThickness ( void )
public setCap ( integer $cap )
public setJoin ( integer $join )
public setMiterLimit ( float $limit )
public setThickness ( float $thickness )
}

İçindekiler

  • UI\Draw\Stroke::__construct — Construct a new Stroke
  • UI\Draw\Stroke::getCap — Get Line Cap
  • UI\Draw\Stroke::getJoin — Get Line Join
  • UI\Draw\Stroke::getMiterLimit — Get Miter Limit
  • UI\Draw\Stroke::getThickness — Get Thickness
  • UI\Draw\Stroke::setCap — Set Line Cap
  • UI\Draw\Stroke::setJoin — Set Line Join
  • UI\Draw\Stroke::setMiterLimit — Set Miter Limit
  • UI\Draw\Stroke::setThickness — Set Thickness
UI\Draw\Color::setChannel
UI\Draw\Stroke::__construct
UI


Construct a new Stroke

UI\Draw\Stroke
UI\Draw\Stroke::getCap
UI\Draw\Stroke
PHP Manual

UI\Draw\Stroke::__construct

(PHP 7, UI 0.9.9)

UI\Draw\Stroke::__construct — Construct a new Stroke

Açıklama

public UI\Draw\Stroke::__construct ([ integer $cap = UI\Draw\Line\Cap::Flat [, integer $join = UI\Draw\Line\Join::Miter [, float $thickness = 1 [, float $miterLimit = 10 ]]]] )

Shall construct a new Stroke

Değiştirgeler

cap

UI\Draw\Line\Cap::Flat, UI\Draw\Line\Cap::Round, or UI\Draw\Line\Cap::Square

join

UI\Draw\Line\Join::Miter, UI\Draw\Line\Join::Round, or UI\Draw\Line\Join::Bevel

thickness

The thickness of the stroke

miterLimit

Miter limit (default is sensible for all supported platforms)

UI\Draw\Stroke
UI\Draw\Stroke::getCap
UI\Draw\Stroke


Get Line Cap

UI\Draw\Stroke::__construct
UI\Draw\Stroke::getJoin
UI\Draw\Stroke
PHP Manual

UI\Draw\Stroke::getCap

(PHP 7, UI 0.9.9)

UI\Draw\Stroke::getCap — Get Line Cap

Açıklama

public integer UI\Draw\Stroke::getCap ( void )

Shall retrieve the line cap setting of this Stroke

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

UI\Draw\Line\Cap::Flat, UI\Draw\Line\Cap::Round, or UI\Draw\Line\Cap::Square

UI\Draw\Stroke::__construct
UI\Draw\Stroke::getJoin
UI\Draw\Stroke


Get Line Join

UI\Draw\Stroke::getCap
UI\Draw\Stroke::getMiterLimit
UI\Draw\Stroke
PHP Manual

UI\Draw\Stroke::getJoin

(PHP 7, UI 0.9.9)

UI\Draw\Stroke::getJoin — Get Line Join

Açıklama

public integer UI\Draw\Stroke::getJoin ( void )

Shall retrieve the line join setting of this Stroke

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

UI\Draw\Line\Join::Miter, UI\Draw\Line\Join::Round, or UI\Draw\Line\Join::Bevel

UI\Draw\Stroke::getCap
UI\Draw\Stroke::getMiterLimit
UI\Draw\Stroke


Get Miter Limit

UI\Draw\Stroke::getJoin
UI\Draw\Stroke::getThickness
UI\Draw\Stroke
PHP Manual

UI\Draw\Stroke::getMiterLimit

(PHP 7, UI 0.9.9)

UI\Draw\Stroke::getMiterLimit — Get Miter Limit

Açıklama

public float UI\Draw\Stroke::getMiterLimit ( void )

Shall retrieve the miter limit of this Stroke

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current miter limit

UI\Draw\Stroke::getJoin
UI\Draw\Stroke::getThickness
UI\Draw\Stroke


Get Thickness

UI\Draw\Stroke::getMiterLimit
UI\Draw\Stroke::setCap
UI\Draw\Stroke
PHP Manual

UI\Draw\Stroke::getThickness

(PHP 7, UI 0.9.9)

UI\Draw\Stroke::getThickness — Get Thickness

Açıklama

public float UI\Draw\Stroke::getThickness ( void )

Shall retrieve the thickness of this Stroke

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current thickness

UI\Draw\Stroke::getMiterLimit
UI\Draw\Stroke::setCap
UI\Draw\Stroke


Set Line Cap

UI\Draw\Stroke::getThickness
UI\Draw\Stroke::setJoin
UI\Draw\Stroke
PHP Manual

UI\Draw\Stroke::setCap

(PHP 7, UI 0.9.9)

UI\Draw\Stroke::setCap — Set Line Cap

Açıklama

public UI\Draw\Stroke::setCap ( integer $cap )

Shall set the line cap setting for this Stroke

Değiştirgeler

cap

UI\Draw\Line\Cap::Flat, UI\Draw\Line\Cap::Round, or UI\Draw\Line\Cap::Square

UI\Draw\Stroke::getThickness
UI\Draw\Stroke::setJoin
UI\Draw\Stroke


Set Line Join

UI\Draw\Stroke::setCap
UI\Draw\Stroke::setMiterLimit
UI\Draw\Stroke
PHP Manual

UI\Draw\Stroke::setJoin

(PHP 7, UI 0.9.9)

UI\Draw\Stroke::setJoin — Set Line Join

Açıklama

public UI\Draw\Stroke::setJoin ( integer $join )

Shall set the line join setting for this Stroke

Değiştirgeler

join

UI\Draw\Line\Join::Miter, UI\Draw\Line\Join::Round, or UI\Draw\Line\Join::Bevel

Dönen Değerler

UI\Draw\Stroke::setCap
UI\Draw\Stroke::setMiterLimit
UI\Draw\Stroke


Set Miter Limit

UI\Draw\Stroke::setJoin
UI\Draw\Stroke::setThickness
UI\Draw\Stroke
PHP Manual

UI\Draw\Stroke::setMiterLimit

(PHP 7, UI 0.9.9)

UI\Draw\Stroke::setMiterLimit — Set Miter Limit

Açıklama

public UI\Draw\Stroke::setMiterLimit ( float $limit )

Set the miter limit for this Stroke

Değiştirgeler

limit

The new limit

UI\Draw\Stroke::setJoin
UI\Draw\Stroke::setThickness
UI\Draw\Stroke


Set Thickness

UI\Draw\Stroke::setMiterLimit
UI\Draw\Brush
UI\Draw\Stroke
PHP Manual

UI\Draw\Stroke::setThickness

(PHP 7, UI 0.9.9)

UI\Draw\Stroke::setThickness — Set Thickness

Açıklama

public UI\Draw\Stroke::setThickness ( float $thickness )

Shall set the thickness for this Stroke

Değiştirgeler

thickness

The new thickness

UI\Draw\Stroke::setMiterLimit
UI\Draw\Brush
UI\Draw\Stroke


Brushes

(PHP 7, UI 0.9.9)

Giriş

Represents a solid color brush

Sınıf Sözdizimi

UI\Draw\Brush {
/* Constructor */
public __construct ( UI\Draw\Color $color )
public __construct ( integer $color )
/* Yöntemler */
public UI\Draw\Color getColor ( void )
public void setColor ( UI\Draw\Color $color )
public void setColor ( integer $color )
}

İçindekiler

  • UI\Draw\Brush::__construct — Construct a new Brush
  • UI\Draw\Brush::getColor — Get Color
  • UI\Draw\Brush::setColor — Set Color
UI\Draw\Stroke::setThickness
UI\Draw\Brush::__construct
UI


Construct a new Brush

UI\Draw\Brush
UI\Draw\Brush::getColor
UI\Draw\Brush
PHP Manual

UI\Draw\Brush::__construct

(PHP 7, UI 0.9.9)

UI\Draw\Brush::__construct — Construct a new Brush

Açıklama

public UI\Draw\Brush::__construct ( UI\Draw\Color $color )
public UI\Draw\Brush::__construct ( integer $color )

Shall construct a solid brush using the given color

Değiştirgeler

color

Can be a UI\Draw\Color or RRGGBBAA

UI\Draw\Brush
UI\Draw\Brush::getColor
UI\Draw\Brush


Get Color

UI\Draw\Brush::__construct
UI\Draw\Brush::setColor
UI\Draw\Brush
PHP Manual

UI\Draw\Brush::getColor

(PHP 7, UI 0.9.9)

UI\Draw\Brush::getColor — Get Color

Açıklama

public UI\Draw\Color UI\Draw\Brush::getColor ( void )

Shall return a UI\Draw\Color for this brush

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

The current color of the brush

UI\Draw\Brush::__construct
UI\Draw\Brush::setColor
UI\Draw\Brush


Set Color

UI\Draw\Brush::getColor
UI\Draw\Brush\Gradient
UI\Draw\Brush
PHP Manual

UI\Draw\Brush::setColor

(PHP 7, UI 0.9.9)

UI\Draw\Brush::setColor — Set Color

Açıklama

public void UI\Draw\Brush::setColor ( UI\Draw\Color $color )
public void UI\Draw\Brush::setColor ( integer $color )

Shall set the color of this brush to the color provided

Değiştirgeler

color

Can be a UI\Draw\Color or RRGGBBAA

Dönen Değerler

UI\Draw\Brush::getColor
UI\Draw\Brush\Gradient
UI\Draw\Brush


Gradient Brushes

(PHP 7, UI 2.0.0)

Giriş

Abstract for gradient brushes

Sınıf Sözdizimi

abstract UI\Draw\Brush\Gradient extends UI\Draw\Brush {
/* Yöntemler */
public integer addStop ( float $position , UI\Draw\Color $color )
public integer addStop ( float $position , integer $color )
public integer delStop ( integer $index )
public boolean setStop ( integer $index , float $position , UI\Draw\Color $color )
public boolean setStop ( integer $index , float $position , integer $color )
/* Miras alınan yöntemler */
public UI\Draw\Color UI\Draw\Brush::getColor ( void )
public void UI\Draw\Brush::setColor ( UI\Draw\Color $color )
public void UI\Draw\Brush::setColor ( integer $color )
}

İçindekiler

  • UI\Draw\Brush\Gradient::addStop — Stop Manipulation
  • UI\Draw\Brush\Gradient::delStop — Stop Manipulation
  • UI\Draw\Brush\Gradient::setStop — Stop Manipulation
UI\Draw\Brush::setColor
UI\Draw\Brush\Gradient::addStop
UI


Stop Manipulation

UI\Draw\Brush\Gradient
UI\Draw\Brush\Gradient::delStop
UI\Draw\Brush\Gradient
PHP Manual

UI\Draw\Brush\Gradient::addStop

(PHP 7, UI 2.0.0)

UI\Draw\Brush\Gradient::addStop — Stop Manipulation

Açıklama

public integer UI\Draw\Brush\Gradient::addStop ( float $position , UI\Draw\Color $color )
public integer UI\Draw\Brush\Gradient::addStop ( float $position , integer $color )

Shall at a stop of the given color at the given position

Değiştirgeler

position

The position for the new stop

color

The color for the new stop, may be UI\Draw\Color or RRGGBBAA

Dönen Değerler

Total number of stops

UI\Draw\Brush\Gradient
UI\Draw\Brush\Gradient::delStop
UI\Draw\Brush\Gradient


Stop Manipulation

UI\Draw\Brush\Gradient::addStop
UI\Draw\Brush\Gradient::setStop
UI\Draw\Brush\Gradient
PHP Manual

UI\Draw\Brush\Gradient::delStop

(PHP 7, UI 2.0.0)

UI\Draw\Brush\Gradient::delStop — Stop Manipulation

Açıklama

public integer UI\Draw\Brush\Gradient::delStop ( integer $index )

Uyarı

Bu işlev hala belgelendirilmemiştir; sadece değiştirge listesi mevcuttur.

Değiştirgeler

index

Dönen Değerler

Total number of stops

UI\Draw\Brush\Gradient::addStop
UI\Draw\Brush\Gradient::setStop
UI\Draw\Brush\Gradient


Stop Manipulation

UI\Draw\Brush\Gradient::delStop
UI\Draw\Brush\LinearGradient
UI\Draw\Brush\Gradient
PHP Manual

UI\Draw\Brush\Gradient::setStop

(PHP 7, UI 2.0.0)

UI\Draw\Brush\Gradient::setStop — Stop Manipulation

Açıklama

public boolean UI\Draw\Brush\Gradient::setStop ( integer $index , float $position , UI\Draw\Color $color )
public boolean UI\Draw\Brush\Gradient::setStop ( integer $index , float $position , integer $color )

Değiştirgeler

index

The index of the stop to set

position

The position for the stop

color

The color for the stop, may be UI\Draw\Color or RRGGBBAA

Dönen Değerler

Indication of success

UI\Draw\Brush\Gradient::delStop
UI\Draw\Brush\LinearGradient
UI\Draw\Brush\Gradient


Linear Gradient

(PHP 7, UI 2.0.0)

Giriş

Sınıf Sözdizimi

UI\Draw\Brush\LinearGradient extends UI\Draw\Brush\Gradient {
/* Constructor */
public __construct ( UI\Point $start , UI\Point $end )
/* Miras alınan yöntemler */
public integer UI\Draw\Brush\Gradient::addStop ( float $position , UI\Draw\Color $color )
public integer UI\Draw\Brush\Gradient::addStop ( float $position , integer $color )
public integer UI\Draw\Brush\Gradient::delStop ( integer $index )
public boolean UI\Draw\Brush\Gradient::setStop ( integer $index , float $position , UI\Draw\Color $color )
public boolean UI\Draw\Brush\Gradient::setStop ( integer $index , float $position , integer $color )
}

İçindekiler

  • UI\Draw\Brush\LinearGradient::__construct — Construct a Linear Gradient
UI\Draw\Brush\Gradient::setStop
UI\Draw\Brush\LinearGradient::__construct
UI


Construct a Linear Gradient

UI\Draw\Brush\LinearGradient
UI\Draw\Brush\RadialGradient
UI\Draw\Brush\LinearGradient
PHP Manual

UI\Draw\Brush\LinearGradient::__construct

(PHP 7, UI 2.0.0)

UI\Draw\Brush\LinearGradient::__construct — Construct a Linear Gradient

Açıklama

public UI\Draw\Brush\LinearGradient::__construct ( UI\Point $start , UI\Point $end )

Shall construct a new linear gradient

Değiştirgeler

start

end

UI\Draw\Brush\LinearGradient
UI\Draw\Brush\RadialGradient
UI\Draw\Brush\LinearGradient


Radial Gradient

(PHP 7, UI 2.0.0)

Giriş

Sınıf Sözdizimi

UI\Draw\Brush\RadialGradient extends UI\Draw\Brush\Gradient {
/* Constructor */
public __construct ( UI\Point $start , UI\Point $outer , float $radius )
/* Miras alınan yöntemler */
public integer UI\Draw\Brush\Gradient::addStop ( float $position , UI\Draw\Color $color )
public integer UI\Draw\Brush\Gradient::addStop ( float $position , integer $color )
public integer UI\Draw\Brush\Gradient::delStop ( integer $index )
public boolean UI\Draw\Brush\Gradient::setStop ( integer $index , float $position , UI\Draw\Color $color )
public boolean UI\Draw\Brush\Gradient::setStop ( integer $index , float $position , integer $color )
}

İçindekiler

  • UI\Draw\Brush\RadialGradient::__construct — Construct a new Radial Gradient
UI\Draw\Brush\LinearGradient::__construct
UI\Draw\Brush\RadialGradient::__construct
UI


Construct a new Radial Gradient

UI\Draw\Brush\RadialGradient
UI\Draw\Text\Layout
UI\Draw\Brush\RadialGradient
PHP Manual

UI\Draw\Brush\RadialGradient::__construct

(PHP 7, UI 2.0.0)

UI\Draw\Brush\RadialGradient::__construct — Construct a new Radial Gradient

Açıklama

public UI\Draw\Brush\RadialGradient::__construct ( UI\Point $start , UI\Point $outer , float $radius )

Shall construct a new radial gradient

Değiştirgeler

start

outer

radius

UI\Draw\Brush\RadialGradient
UI\Draw\Text\Layout
UI\Draw\Brush\RadialGradient


Represents Text Layout

(PHP 7, UI 0.9.9)

Giriş

A Text Layout represents the layout of text which will be drawn by the Pen

Sınıf Sözdizimi

UI\Draw\Text\Layout {
/* Constructor */
public __construct ( string $text , UI\Draw\Text\Font $font , float $width )
/* Yöntemler */
public setColor ( UI\Draw\Color $color [, integer $start = 0 [, integer $end ]] )
public setColor ( integer $color [, integer $start = 0 [, integer $end ]] )
public setWidth ( float $width )
}

İçindekiler

  • UI\Draw\Text\Layout::__construct — Construct a new Text Layout
  • UI\Draw\Text\Layout::setColor — Set Color
  • UI\Draw\Text\Layout::setWidth — Set Width
UI\Draw\Brush\RadialGradient::__construct
UI\Draw\Text\Layout::__construct
UI


Construct a new Text Layout

UI\Draw\Text\Layout
UI\Draw\Text\Layout::setColor
UI\Draw\Text\Layout
PHP Manual

UI\Draw\Text\Layout::__construct

(PHP 7, UI 0.9.9)

UI\Draw\Text\Layout::__construct — Construct a new Text Layout

Açıklama

public UI\Draw\Text\Layout::__construct ( string $text , UI\Draw\Text\Font $font , float $width )

Shall construct a new Text Layout

Değiştirgeler

text

The text for the layout

font

The font to use for writing

width

The width of the layout

UI\Draw\Text\Layout
UI\Draw\Text\Layout::setColor
UI\Draw\Text\Layout


Set Color

UI\Draw\Text\Layout::__construct
UI\Draw\Text\Layout::setWidth
UI\Draw\Text\Layout
PHP Manual

UI\Draw\Text\Layout::setColor

(PHP 7, UI 0.9.9)

UI\Draw\Text\Layout::setColor — Set Color

Açıklama

public UI\Draw\Text\Layout::setColor ( UI\Draw\Color $color [, integer $start = 0 [, integer $end ]] )
public UI\Draw\Text\Layout::setColor ( integer $color [, integer $start = 0 [, integer $end ]] )

Shall set the Color for all of, or a range of the text in the Layout

Değiştirgeler

color

The color to use

start

The starting character

end

The ending character, by default the end of the string

UI\Draw\Text\Layout::__construct
UI\Draw\Text\Layout::setWidth
UI\Draw\Text\Layout


Set Width

UI\Draw\Text\Layout::setColor
UI\Draw\Text\Font
UI\Draw\Text\Layout
PHP Manual

UI\Draw\Text\Layout::setWidth

(PHP 7, UI 0.9.9)

UI\Draw\Text\Layout::setWidth — Set Width

Açıklama

public UI\Draw\Text\Layout::setWidth ( float $width )

Shall set the width of this Text Layout

Değiştirgeler

width

The new width

UI\Draw\Text\Layout::setColor
UI\Draw\Text\Font
UI\Draw\Text\Layout


Represents a Font

(PHP 7, UI 0.9.9)

Giriş

Loads a described font

Sınıf Sözdizimi

UI\Draw\Text\Font {
/* Constructor */
public __construct ( UI\Draw\Text\Font\Descriptor $descriptor )
/* Yöntemler */
public float getAscent ( void )
public float getDescent ( void )
public float getLeading ( void )
public float getUnderlinePosition ( void )
public float getUnderlineThickness ( void )
}

İçindekiler

  • UI\Draw\Text\Font::__construct — Construct a new Font
  • UI\Draw\Text\Font::getAscent — Font Metrics
  • UI\Draw\Text\Font::getDescent — Font Metrics
  • UI\Draw\Text\Font::getLeading — Font Metrics
  • UI\Draw\Text\Font::getUnderlinePosition — Font Metrics
  • UI\Draw\Text\Font::getUnderlineThickness — Font Metrics
UI\Draw\Text\Layout::setWidth
UI\Draw\Text\Font::__construct
UI


Construct a new Font

UI\Draw\Text\Font
UI\Draw\Text\Font::getAscent
UI\Draw\Text\Font
PHP Manual

UI\Draw\Text\Font::__construct

(PHP 7, UI 0.9.9)

UI\Draw\Text\Font::__construct — Construct a new Font

Açıklama

public UI\Draw\Text\Font::__construct ( UI\Draw\Text\Font\Descriptor $descriptor )

Shall construct a new Font using the given descriptor

Değiştirgeler

descriptor

The descriptor for the Font

UI\Draw\Text\Font
UI\Draw\Text\Font::getAscent
UI\Draw\Text\Font


Font Metrics

UI\Draw\Text\Font::__construct
UI\Draw\Text\Font::getDescent
UI\Draw\Text\Font
PHP Manual

UI\Draw\Text\Font::getAscent

(PHP 7, UI 1.0.3)

UI\Draw\Text\Font::getAscent — Font Metrics

Açıklama

public float UI\Draw\Text\Font::getAscent ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

UI\Draw\Text\Font::__construct
UI\Draw\Text\Font::getDescent
UI\Draw\Text\Font


Font Metrics

UI\Draw\Text\Font::getAscent
UI\Draw\Text\Font::getLeading
UI\Draw\Text\Font
PHP Manual

UI\Draw\Text\Font::getDescent

(PHP 7, UI 1.0.3)

UI\Draw\Text\Font::getDescent — Font Metrics

Açıklama

public float UI\Draw\Text\Font::getDescent ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

UI\Draw\Text\Font::getAscent
UI\Draw\Text\Font::getLeading
UI\Draw\Text\Font


Font Metrics

UI\Draw\Text\Font::getDescent
UI\Draw\Text\Font::getUnderlinePosition
UI\Draw\Text\Font
PHP Manual

UI\Draw\Text\Font::getLeading

(PHP 7, UI 1.0.3)

UI\Draw\Text\Font::getLeading — Font Metrics

Açıklama

public float UI\Draw\Text\Font::getLeading ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

UI\Draw\Text\Font::getDescent
UI\Draw\Text\Font::getUnderlinePosition
UI\Draw\Text\Font


Font Metrics

UI\Draw\Text\Font::getLeading
UI\Draw\Text\Font::getUnderlineThickness
UI\Draw\Text\Font
PHP Manual

UI\Draw\Text\Font::getUnderlinePosition

(PHP 7, UI 1.0.3)

UI\Draw\Text\Font::getUnderlinePosition — Font Metrics

Açıklama

public float UI\Draw\Text\Font::getUnderlinePosition ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

UI\Draw\Text\Font::getLeading
UI\Draw\Text\Font::getUnderlineThickness
UI\Draw\Text\Font


Font Metrics

UI\Draw\Text\Font::getUnderlinePosition
UI\Draw\Text\Font\Descriptor
UI\Draw\Text\Font
PHP Manual

UI\Draw\Text\Font::getUnderlineThickness

(PHP 7, UI 1.0.3)

UI\Draw\Text\Font::getUnderlineThickness — Font Metrics

Açıklama

public float UI\Draw\Text\Font::getUnderlineThickness ( void )

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

UI\Draw\Text\Font::getUnderlinePosition
UI\Draw\Text\Font\Descriptor
UI\Draw\Text\Font


Font Descriptor

(PHP 7, UI 0.9.9)

Giriş

Describes a font

Sınıf Sözdizimi

UI\Draw\Text\Font\Descriptor {
/* Constructor */
public __construct ( string $family , float $size [, integer $weight = UI\Draw\Text\Font\Weight::Normal [, integer $italic = UI\Draw\Text\Font\Italic::Normal [, integer $stretch = UI\Draw\Text\Font\Stretch::Normal ]]] )
/* Yöntemler */
public string getFamily ( void )
public int getItalic ( void )
public float getSize ( void )
public int getStretch ( void )
public int getWeight ( void )
}

İçindekiler

  • UI\Draw\Text\Font\Descriptor::__construct — Construct a new Font Descriptor
  • UI\Draw\Text\Font\Descriptor::getFamily — Get Font Family
  • UI\Draw\Text\Font\Descriptor::getItalic — Style Detection
  • UI\Draw\Text\Font\Descriptor::getSize — Size Detection
  • UI\Draw\Text\Font\Descriptor::getStretch — Style Detection
  • UI\Draw\Text\Font\Descriptor::getWeight — Weight Detection
UI\Draw\Text\Font::getUnderlineThickness
UI\Draw\Text\Font\Descriptor::__construct
UI


Construct a new Font Descriptor

UI\Draw\Text\Font\Descriptor
UI\Draw\Text\Font\Descriptor::getFamily
UI\Draw\Text\Font\Descriptor
PHP Manual

UI\Draw\Text\Font\Descriptor::__construct

(PHP 7, UI 0.9.9)

UI\Draw\Text\Font\Descriptor::__construct — Construct a new Font Descriptor

Açıklama

public UI\Draw\Text\Font\Descriptor::__construct ( string $family , float $size [, integer $weight = UI\Draw\Text\Font\Weight::Normal [, integer $italic = UI\Draw\Text\Font\Italic::Normal [, integer $stretch = UI\Draw\Text\Font\Stretch::Normal ]]] )

Shall construct a new Font Descriptor

Değiştirgeler

family

The name of a valid family of fonts

size

The preferred size

weight

UI\Draw\Text\Font\Weight constant

italic

UI\Draw\Text\Font\Italic constant

stretch

UI\Draw\Text\Font\Stretch constant

UI\Draw\Text\Font\Descriptor
UI\Draw\Text\Font\Descriptor::getFamily
UI\Draw\Text\Font\Descriptor


Get Font Family

UI\Draw\Text\Font\Descriptor::__construct
UI\Draw\Text\Font\Descriptor::getItalic
UI\Draw\Text\Font\Descriptor
PHP Manual

UI\Draw\Text\Font\Descriptor::getFamily

(PHP 7, UI 1.0.3)

UI\Draw\Text\Font\Descriptor::getFamily — Get Font Family

Açıklama

public string UI\Draw\Text\Font\Descriptor::getFamily ( void )

Shall return the requested font family

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

UI\Draw\Text\Font\Descriptor::__construct
UI\Draw\Text\Font\Descriptor::getItalic
UI\Draw\Text\Font\Descriptor


Style Detection

UI\Draw\Text\Font\Descriptor::getFamily
UI\Draw\Text\Font\Descriptor::getSize
UI\Draw\Text\Font\Descriptor
PHP Manual

UI\Draw\Text\Font\Descriptor::getItalic

(PHP 7, UI 1.0.3)

UI\Draw\Text\Font\Descriptor::getItalic — Style Detection

Açıklama

public int UI\Draw\Text\Font\Descriptor::getItalic ( void )

Shall return constant setting

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

UI\Draw\Text\Font\Descriptor::getFamily
UI\Draw\Text\Font\Descriptor::getSize
UI\Draw\Text\Font\Descriptor


Size Detection

UI\Draw\Text\Font\Descriptor::getItalic
UI\Draw\Text\Font\Descriptor::getStretch
UI\Draw\Text\Font\Descriptor
PHP Manual

UI\Draw\Text\Font\Descriptor::getSize

(PHP 7, UI 1.0.3)

UI\Draw\Text\Font\Descriptor::getSize — Size Detection

Açıklama

public float UI\Draw\Text\Font\Descriptor::getSize ( void )

Shall return the requested size

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

UI\Draw\Text\Font\Descriptor::getItalic
UI\Draw\Text\Font\Descriptor::getStretch
UI\Draw\Text\Font\Descriptor


Style Detection

UI\Draw\Text\Font\Descriptor::getSize
UI\Draw\Text\Font\Descriptor::getWeight
UI\Draw\Text\Font\Descriptor
PHP Manual

UI\Draw\Text\Font\Descriptor::getStretch

(PHP 7, UI 1.0.3)

UI\Draw\Text\Font\Descriptor::getStretch — Style Detection

Açıklama

public int UI\Draw\Text\Font\Descriptor::getStretch ( void )

Shall return requested stretch

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

UI\Draw\Text\Font\Descriptor::getSize
UI\Draw\Text\Font\Descriptor::getWeight
UI\Draw\Text\Font\Descriptor


Weight Detection

UI\Draw\Text\Font\Descriptor::getStretch
UI İşlevleri
UI\Draw\Text\Font\Descriptor
PHP Manual

UI\Draw\Text\Font\Descriptor::getWeight

(PHP 7, UI 1.0.3)

UI\Draw\Text\Font\Descriptor::getWeight — Weight Detection

Açıklama

public int UI\Draw\Text\Font\Descriptor::getWeight ( void )

Shall return requested weight

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

UI\Draw\Text\Font\Descriptor::getStretch
UI İşlevleri
UI\Draw\Text\Font\Descriptor


UI İşlevleri

İçindekiler

  • UI\Draw\Text\Font\fontFamilies — Retrieve Font Families
  • UI\quit — Quit UI Loop
  • UI\run — Enter UI Loop
UI\Draw\Text\Font\Descriptor::getWeight
UI\Draw\Text\Font\fontFamilies
UI


Retrieve Font Families

UI İşlevleri
UI\quit
UI İşlevleri
PHP Manual

UI\Draw\Text\Font\fontFamilies

(PHP 7, UI 0.9.9)

UI\Draw\Text\Font\fontFamilies — Retrieve Font Families

Açıklama

array UI\Draw\Text\Font\fontFamilies ( void )

Returns an array of valid font families for the current system

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

UI İşlevleri
UI\quit
UI İşlevleri


Quit UI Loop

UI\Draw\Text\Font\fontFamilies
UI\run
UI İşlevleri
PHP Manual

UI\quit

(PHP 7, UI 2.0.0)

UI\quit — Quit UI Loop

Açıklama

void UI\quit ( void )

Shall cause the main loop to be exited

Değiştirgeler

Bu işlevin değiştirgesi yoktur.

Dönen Değerler

UI\Draw\Text\Font\fontFamilies
UI\run
UI İşlevleri


Enter UI Loop

UI\quit
UI\Draw\Text\Font\Weight
UI İşlevleri
PHP Manual

UI\run

(PHP 7, UI 2.0.0)

UI\run — Enter UI Loop

Açıklama

void UI\run ([ integer $flags ] )

Shall cause PHP to enter into the main loop, by default control will not be returned to the caller

Değiştirgeler

flags

Set UI\Loop to return control, and UI\Wait to return control after waiting

Dönen Değerler

UI\quit
UI\Draw\Text\Font\Weight
UI İşlevleri


Font Weight Settings

(PHP 7, UI 0.9.9)

Giriş

Sınıf Sözdizimi

final UI\Draw\Text\Font\Weight {
/* Constants */
const integer Thin ;
const integer UltraLight ;
const integer Light ;
const integer Book ;
const integer Normal ;
const integer Medium ;
const integer SemiBold ;
const integer Bold ;
const integer UltraBold ;
const integer Heavy ;
const integer UltraHeavy ;
}
UI\run
UI\Draw\Text\Font\Italic
UI


Italic Font Settings

(PHP 7, UI 0.9.9)

Giriş

Sınıf Sözdizimi

final UI\Draw\Text\Font\Italic {
/* Constants */
const integer Normal = 0 ;
const integer Oblique = 1 ;
const integer Italic = 2 ;
}
UI\Draw\Text\Font\Weight
UI\Draw\Text\Font\Stretch
UI


Font Stretch Settings

(PHP 7, UI 0.9.9)

Giriş

Sınıf Sözdizimi

final UI\Draw\Text\Font\Stretch {
/* Constants */
const integer UltraCondensed = 0 ;
const integer ExtraCondensed = 1 ;
const integer Condensed = 2 ;
const integer SemiCondensed = 3 ;
const integer Normal = 4 ;
const integer SemiExpanded = 5 ;
const integer Expanded = 6 ;
const integer ExtraExpanded = 7 ;
const integer UltraExpanded = 8 ;
}
UI\Draw\Text\Font\Italic
UI\Draw\Line\Cap
UI


Line Cap Settings

(PHP 7, UI 0.9.9)

Giriş

Sınıf Sözdizimi

final UI\Draw\Line\Cap {
/* Constants */
const integer Flat ;
const integer Round ;
const integer Square ;
}
UI\Draw\Text\Font\Stretch
UI\Draw\Line\Join
UI


Line Join Settings

(PHP 7, UI 0.9.9)

Giriş

Sınıf Sözdizimi

final UI\Draw\Line\Join {
/* Constants */
const integer Miter ;
const integer Round ;
const integer Bevel ;
}
UI\Draw\Line\Cap
UI\Key
UI


Key Identifiers

(PHP 7, UI 1.0.0)

Giriş

Sınıf Sözdizimi

final UI\Key {
/* Constants */
const integer Escape ;
const integer Insert ;
const integer Delete ;
const integer Home ;
const integer End ;
const integer PageUp ;
const integer PageDown ;
const integer Up ;
const integer Down ;
const integer Left ;
const integer Right ;
const integer F1 ;
const integer F2 ;
const integer F3 ;
const integer F4 ;
const integer F5 ;
const integer F6 ;
const integer F7 ;
const integer F8 ;
const integer F9 ;
const integer F10 ;
const integer F11 ;
const integer F12 ;
const integer N0 ;
const integer N1 ;
const integer N2 ;
const integer N3 ;
const integer N4 ;
const integer N5 ;
const integer N6 ;
const integer N7 ;
const integer N8 ;
const integer N9 ;
const integer NDot ;
const integer NEnter ;
const integer NAdd ;
const integer NSubtract ;
const integer NMultiply ;
const integer NDivide ;
}
UI\Draw\Line\Join
UI\Exception\InvalidArgumentException
UI


InvalidArgumentException

(PHP 7, UI 1.0.3)

Giriş

Sınıf Sözdizimi

UI\Exception\InvalidArgumentException extends InvalidArgumentException implements Throwable {
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}
UI\Key
UI\Exception\RuntimeException
UI


RuntimeException

(PHP 7, UI 1.0.3)

Giriş

Sınıf Sözdizimi

UI\Exception\RuntimeException extends RuntimeException implements Throwable {
/* Miras alınan özellikler */
protected string $message ;
protected int $code ;
protected string $file ;
protected int $line ;
/* Miras alınan yöntemler */
final public string Exception::getMessage ( void )
final public Exception Exception::getPrevious ( void )
final public int Exception::getCode ( void )
final public string Exception::getFile ( void )
final public int Exception::getLine ( void )
final public array Exception::getTrace ( void )
final public string Exception::getTraceAsString ( void )
public string Exception::__toString ( void )
final private void Exception::__clone ( void )
}
UI\Exception\InvalidArgumentException
PHP’nin Çekirdeği; Çekirdek geliştiricilerin Rehberi
UI


PHP’nin Çekirdeği; Çekirdek geliştiricilerin Rehberi

UI\Exception\RuntimeException
Preface
PHP Kılavuzu
PHP Manual

PHP'nin Çekirdeği; Çekirdek geliştiricilerin Rehberi

  • Preface
  • Bellek Yönetimi
    • Temel Bellek Yönetimi
    • Veri kalıcılığı
    • Çok Evreli Özkaynak Yöneticisi
  • Değişkenlerle Çalışmak
  • İşlevlerin Yazılması
  • Sınıflar ve Nesnelerle Çalışma
  • Özkaynaklarla Çalışmak
  • INI ayarlarıyla çalışma
  • Akımlarla Çalışmak
  • The "counter" Extension - A Continuing Example
    • Yapılandırma/Kurulum
    • Öntanımlı Sabitler
    • Örnekler
    • Counter — The Counter class
    • Basic — The basic interface
    • Extended — The extended interface
  • The PHP 5 build system
    • Building PHP for extension development
    • The ext_skel script
    • Talking to the UNIX build system: config.m4
    • Talking to the Windows build system: config.w32
  • Extension structure
    • Files which make up an extension
    • Basic constructs
    • The zend_module structure
    • Extension globals
    • Life cycle of an extension
    • Testing an extension
  • PDO Driver How-To
    • Prerequisites
    • Preparation and Housekeeping
    • Fleshing out your skeleton
    • Building
    • Testing
    • Packaging and distribution
    • pdo_dbh_t definition
    • pdo_stmt_t definition
    • Constants
    • Error handling
  • Eklentilerin SSS'leri
  • Zend Motoru 2 Başvuru Kılavuzu
  • Zend Engine 2 Opcodes
    • Opcode Descriptions and Examples
  • Zend Engine 1
    • Old introduction
    • Streams API for PHP Extension Authors
    • Zend API; PHP Çekirdeğinin Geliştirilmesi
    • TSRM API
UI\Exception\RuntimeException
Preface
PHP Kılavuzu


Preface

This section of the manual is written for the Hacker: someone thinking about getting their hands dirty, someone who wants an understanding of internals in order to advance their PHP skills, or maybe someone looking to write the next best extension. Whatever the reason, this section will seek to provide a good understanding of the internals of PHP, how to write extensions, how to understand existing code containing mystical macros. All of the important internal functionality is documented here, enough anyway to convince you to read the source.

Out of necessity, this section assumes the reader has a working knowledge of the C programming language, and associated tools, like compilers and terminal emulators and the like. You don't need to be the next Alan Turing, but a working knowledge is none the less essential for this section to be of any use. With just that working knowledge, this section should be enough to get you well on the way to earning the title Hacker, and you do have to earn it.

The documentation in this section is current as of PHP 5.3.3, deviations in API functionality are duly noted in the appropriate sections.

Uyarı

This documentation is still under development. The original Zend documentation is preserved in its entirety in the Zend Engine 1 section for those who need it before this documentation is completed.

PHP’nin Çekirdeği; Çekirdek geliştiricilerin Rehberi
Bellek Yönetimi
PHP’nin Çekirdeği; Çekirdek geliştiricilerin Rehberi


Bellek Yönetimi

İçindekiler

  • Temel Bellek Yönetimi
  • Veri kalıcılığı
  • Çok Evreli Özkaynak Yöneticisi

Zend Motorunun bellek yönetimi inanılmaz derecede basittir. Öğrenilecek bazı uygulama programlama arayüzleri ve bunların artalanını anlamaya yarayacak bazı kavramlar vardır ama hepsi bundan ibarettir.

Preface
Temel Bellek Yönetimi
PHP’nin Çekirdeği; Çekirdek geliştiricilerin Rehberi


Temel Bellek Yönetimi

Bellek Yönetimi
Veri kalıcılığı
Bellek Yönetimi


Veri kalıcılığı

Temel Bellek Yönetimi
Çok Evreli Özkaynak Yöneticisi
Bellek Yönetimi


Çok Evreli Özkaynak Yöneticisi

Veri kalıcılığı
Değişkenlerle Çalışmak
Bellek Yönetimi


Değişkenlerle Çalışmak

Çok Evreli Özkaynak Yöneticisi
İşlevlerin Yazılması
PHP’nin Çekirdeği; Çekirdek geliştiricilerin Rehberi


İşlevlerin Yazılması

PHP bir yapıştırıcı dil olarak da bilinir ve eklentiler sayesinde kolayca genişletilebilir. C işlev arayüzü üretmek için bir prototip dosyası ve ext_skel betiğini kullandığınızda oluşturduğunuz işlevleri küresel hale getirmek için şöyle bir basit prototipin yeterli olduğunu farkedeceksiniz: PHP_FUNCTION(işlev_ismi)

Değişkenlerle Çalışmak
Sınıflar ve Nesnelerle Çalışma
PHP’nin Çekirdeği; Çekirdek geliştiricilerin Rehberi


Sınıflar ve Nesnelerle Çalışma

İşlevlerin Yazılması
Özkaynaklarla Çalışmak
PHP’nin Çekirdeği; Çekirdek geliştiricilerin Rehberi


Özkaynaklarla Çalışmak

Sınıflar ve Nesnelerle Çalışma
INI ayarlarıyla çalışma
PHP’nin Çekirdeği; Çekirdek geliştiricilerin Rehberi


INI ayarlarıyla çalışma

Özkaynaklarla Çalışmak
Akımlarla Çalışmak
PHP’nin Çekirdeği; Çekirdek geliştiricilerin Rehberi


Akımlarla Çalışmak

Bilginize:

PHP kaynak kodu içinde akımların kullanımı hakkında bilgi edinmek için PHP Eklenti yazarları için Akım Arayüzü Başvuru Kılavuzu bölümüne bakınız.

INI ayarlarıyla çalışma
The "counter" Extension - A Continuing Example
PHP’nin Çekirdeği; Çekirdek geliştiricilerin Rehberi


The "counter" Extension - A Continuing Example

İçindekiler

  • Yapılandırma/Kurulum
  • Öntanımlı Sabitler
  • Örnekler
  • Counter
  • Basic
  • Extended

Preface

Throughout this Zend documentation, references are made to an example module in order to illustrate various concepts. The "counter" extension is this example, a fictional yet functional Zend module which strives to use as much of the Zend API as is reasonably possible. This short chapter describes the userland interface to the completed extension.

Bilginize: "counter" serves no practical purpose whatsoever, as the functionality it provides is far more effectively implemented by appropriate userland code.

Akımlarla Çalışmak
Yapılandırma/Kurulum
PHP’nin Çekirdeği; Çekirdek geliştiricilerin Rehberi


Yapılandırma/Kurulum

İçindekiler

  • Giriş
  • Çalışma Anı Yapılandırması
  • Özkaynak Türleri
The "counter" Extension - A Continuing Example
Giriş
The "counter" Extension - A Continuing Example


Giriş

The "counter" extension provides any number of counters to PHP code using it which reset at times determined by the caller.

There are three interfaces to "counter": basic, extended, and objective. The basic interface provides a single counter controlled by INI settings and function calls. The extended interface provides an arbitrary number of named counter resources which may optionally persist beyond the lifetime of a single PHP request. The objective interface combines both the basic and extended interfaces into a Counter class.

Yapılandırma/Kurulum
Çalışma Anı Yapılandırması
Yapılandırma/Kurulum


Çalışma Anı Yapılandırması

Bu işlevlerin davranışı php.ini içindeki ayarlardan etkilenir.

Counter configuration options
Name | Default | Changeable | Changelog
counter.reset_time | COUNTER_RESET_PER_REQUEST | PHP_INI_ALL |
counter.save_path | "" | PHP_INI_ALL |
counter.initial_value | "0" | PHP_INI_ALL |

PHP_INI_* kiplerinin tanımları ve ayrıntılı açıklamaları için Yapılandırma ayarlarının yeri bölümüne bakınız.

counter.reset_time integer
counter.reset_time tells "counter" to reset the counter used by the basic interface. It may be any of the COUNTER_RESET_* constants (see below).
counter.save_path string
Tells "counter" where to save data that has to persist between invocations of PHP (i.e. any counter that has COUNTER_RESET_NEVER or COUNTER_FLAG_SAVE). A file will be created at this path, which must be readable and writable to whatever user PHP is running as.
counter.initial_value integer
Sets the initial value of the counter used by the basic interface whenever it is reset.
Giriş
Özkaynak Türleri
Yapılandırma/Kurulum


Özkaynak Türleri

The "counter" extension defines one resource type: a counter.

Çalışma Anı Yapılandırması
Öntanımlı Sabitler
Yapılandırma/Kurulum


Öntanımlı Sabitler

Buradaki sabitler bu eklenti için tanımlanmış olup, sadece eklentinin PHP içinde derlenmiş olması veya çalışma anında devingen olarak yüklenmesi halinde kullanılabilir.

COUNTER_FLAG_PERSIST (integer)
A counter with this flag will be created as a persistent resource.
COUNTER_FLAG_SAVE (integer)
A counter with this flag will be saved between invocations of PHP.
COUNTER_FLAG_NO_OVERWRITE (integer)
This flag causes counter_create() to avoid overwriting an existing named counter with a new one.
COUNTER_META_NAME (string)
Pass this constant to get the name of a counter resource or object.
COUNTER_META_IS_PERISTENT (string)
Pass this constant to determine whether a counter resource or object is persistent (has the COUNTER_FLAG_PERSIST flag).
COUNTER_RESET_NEVER (integer)
The counter will never be reset.
COUNTER_RESET_PER_LOAD (integer)
The counter will be reset on each invocation of PHP.
COUNTER_RESET_PER_REQUEST (integer)
The counter will be reset on each request.
Özkaynak Türleri
Örnekler
The "counter" Extension - A Continuing Example


Örnekler

İçindekiler

  • Basic interface
  • Extended interface
  • Objective interface
Öntanımlı Sabitler
Basic interface
The "counter" Extension - A Continuing Example


Basic interface

The basic interface provides three simple functions, illustrated here:

Örnek 1 "counter"'s basic interface

<?php
$starting_counter_value = counter_get();
counter_bump(1);
$second_counter_value = counter_get();
counter_reset();
$final_counter_value = counter_get();
printf("%3d %3d %3d", $starting_counter_value, $second_counter_value, $final_counter_value);
?>

Yukarıdaki örneğin çıktısı:

  0   1   0

The basic interface also provides a number of INI settings.

Örnekler
Extended interface
Örnekler


Extended interface

The extended interface provides a small suite of functions that allow the user to define an arbitrary number of named counters with unique settings. The basic interface can be used in parallel with the extended interface.

Örnek 1 "counter"'s extended interface

<?php
function print_counter_info($counter)
{
    if (is_resource($counter)) {
        printf("Counter's name is '%s' and is%s persistent. Its current value is %d.\n",
            counter_get_meta($counter, COUNTER_META_NAME),
            counter_get_meta($counter, COUNTER_META_IS_PERSISTENT) ? '' : ' not',
            counter_get_value($counter));
    } else {
      print "Not a valid counter!\n";
    }
}

if (($counter_one = counter_get_named("one")) === NULL) {
    $counter_one = counter_create("one", 0, COUNTER_FLAG_PERSIST);
}
counter_bump_value($counter_one, 2);
$counter_two = counter_create("two", 5);
$counter_three = counter_get_named("three");
$counter_four = counter_create("four", 2, COUNTER_FLAG_PERSIST | COUNTER_FLAG_SAVE | COUNTER_FLAG_NO_OVERWRITE);
counter_bump_value($counter_four, 1);

print_counter_info($counter_one);
print_counter_info($counter_two);
print_counter_info($counter_three);
print_counter_info($counter_four);
?>

When run once, the above example outputs:

Counter's name is 'one' and is persistent. Its current value is 2.
Counter's name is 'two' and is not persistent. Its current value is 5.
Not a valid counter!
Counter's name is 'four' and is persistent. Its current value is 3.

If run a second time within the same instance of PHP, it outputs:

Counter's name is 'one' and is persistent. Its current value is 4.
Counter's name is 'two' and is not persistent. Its current value is 5.
Not a valid counter!
Counter's name is 'four' and is persistent. Its current value is 4.

If then run a third time in a different instance of PHP, it outputs:

Counter's name is 'one' and is persistent. Its current value is 2.
Counter's name is 'two' and is not persistent. Its current value is 5.
Not a valid counter!
Counter's name is 'four' and is persistent. Its current value is 5.
Basic interface
Objective interface
Örnekler


Objective interface

The objective interface provides an object-oriented way to access the extended interfaces. The following example shows how the above one would be implemented using the objective interface. The output of this example is exactly the same, except that instead of printing "Not a valid counter!", this will instead issue a PHP warning that the variable $counter_three is not an object. This example shows that it is possible to subclass the Counter class defined by the extension, as well as that the counter's value is maintained using an instance variable rather than method access.

Örnek 1 "counter"'s objective interface

<?php
class MyCounter extends Counter
{
    public function printCounterInfo() {
        printf("Counter's name is '%s' and is%s persistent. Its current value is %d.\n",
            $this->getMeta(COUNTER_META_NAME),
            $this->getMeta(COUNTER_META_IS_PERSISTENT) ? '' : ' not',
            $this->value);
    }
}

Counter::setCounterClass("MyCounter");
if (($counter_one = Counter::getNamed("one")) === NULL) {
    $counter_one = new Counter("one", 0, COUNTER_FLAG_PERSIST);
}
$counter_one->bumpValue(2); // we aren't allowed to "set" the value directly
$counter_two = new Counter("two", 5);
$counter_three = Counter::getNamed("three");
$counter_four = new Counter("four", 2, COUNTER_FLAG_PERSIST | COUNTER_FLAG_SAVE | COUNTER_FLAG_NO_OVERWRITE);
$counter_four->bumpValue(1);

$counter_one->printCounterInfo();
$counter_two->printCounterInfo();
$counter_three->printCounterInfo();
$counter_four->printCounterInfo();
?>
Extended interface
Counter
Örnekler


The Counter class

Giriş

Represents a single counter object.

Sınıf Sözdizimi

Counter {
__construct ( string $name [, integer $initial_value [, integer $flags ]] )
integer getValue ( void )
bumpValue ( integer $offset )
voidresetValue ( void )
mixed getMeta ( integer $attribute )
static Counter getNamed ( string $name )
static voidsetCounterClass ( string $name )
}

İçindekiler

  • Counter::__construct — Creates an instance of a Counter which maintains a single numeric value.
  • Counter::getValue — Get the current value of a counter.
  • Counter::bumpValue — Change the current value of a counter.
  • Counter::resetValue — Reset the current value of a counter.
  • Counter::getMeta — Return a piece of metainformation about a counter.
  • Counter::getNamed — Retrieve an existing named counter.
  • Counter::setCounterClass — Set the class returned by Counter::getNamed.
Objective interface
Counter::__construct
The "counter" Extension - A Continuing Example


Creates an instance of a Counter which maintains a single numeric value.

Counter
Counter::getValue
Counter
PHP Manual

Counter::__construct

Counter::__construct — Creates an instance of a Counter which maintains a single numeric value.

Açıklama

Counter::__construct ( string $name [, integer $initial_value [, integer $flags ]] )

Creates an instance of a Counter which maintains a single numeric value.

Değiştirgeler

name
The new counter's name.
initial_value
The initial value of the counter. Defaults to zero (0).
flags
Flags for the new counter, chosen from the COUNTER_FLAG_* constants.

Dönen Değerler

Returns a Counter object on success.

Hatalar/İstisnalar

Counter::__construct() throws an Exception if something goes wrong.

Counter
Counter::getValue
Counter


Get the current value of a counter.

Counter::__construct
Counter::bumpValue
Counter
PHP Manual

Counter::getValue

Counter::getValue — Get the current value of a counter.

Açıklama

integer Counter::getValue ( void )

Counter::getValue() returns the current value of a counter.

Dönen Değerler

Counter::getValue() returns an integer.

Ayrıca Bakınız

  • Counter::bumpValue() - Change the current value of a counter.
  • Counter::resetValue() - Reset the current value of a counter.
Counter::__construct
Counter::bumpValue
Counter


Change the current value of a counter.

Counter::getValue
Counter::resetValue
Counter
PHP Manual

Counter::bumpValue

Counter::bumpValue — Change the current value of a counter.

Açıklama

Counter::bumpValue ( integer $offset )

Counter::bumpValue() updates the current value of a counter.

Değiştirgeler

offset
The amount by which to change the counter's value. Can be negative.

Ayrıca Bakınız

  • Counter::getValue() - Get the current value of a counter.
  • Counter::resetValue() - Reset the current value of a counter.
Counter::getValue
Counter::resetValue
Counter


Reset the current value of a counter.

Counter::bumpValue
Counter::getMeta
Counter
PHP Manual

Counter::resetValue

Counter::resetValue — Reset the current value of a counter.

Açıklama

voidCounter::resetValue ( void )

Counter::resetValue() resets the current value of a counter to its original initial value.

Ayrıca Bakınız

  • Counter::getValue() - Get the current value of a counter.
  • Counter::bumpValue() - Change the current value of a counter.
Counter::bumpValue
Counter::getMeta
Counter


Return a piece of metainformation about a counter.

Counter::resetValue
Counter::getNamed
Counter
PHP Manual

Counter::getMeta

Counter::getMeta — Return a piece of metainformation about a counter.

Açıklama

mixed Counter::getMeta ( integer $attribute )

Counter::getMeta() returns metainformation about a counter.

Değiştirgeler

attribute
The metainformation to retrieve.

Dönen Değerler

Counter::getMeta() returns values of varying types based on which metainformation was requested.

Counter::resetValue
Counter::getNamed
Counter


Retrieve an existing named counter.

Counter::getMeta
Counter::setCounterClass
Counter
PHP Manual

Counter::getNamed

Counter::getNamed — Retrieve an existing named counter.

Açıklama

static Counter Counter::getNamed ( string $name )

Counter::getNamed() returns an existing counter by name if that name exists, or NULL otherwise. This is a static function.

Değiştirgeler

name
The counter name to search for.

Dönen Değerler

Counter::getNamed() returns an existing counter by name if that name exists, or NULL otherwise.

Counter::getMeta
Counter::setCounterClass
Counter


Set the class returned by Counter::getNamed.

Counter::getNamed
Basic
Counter
PHP Manual

Counter::setCounterClass

Counter::setCounterClass — Set the class returned by Counter::getNamed().

Açıklama

static voidCounter::setCounterClass ( string $name )

Counter::setCounterClass() changes the class of objects returned by Counter::getNamed(). The class being set must not have a public constructor and must be a subclass of Counter. If these conditions are not met, a fatal error is raised. This is a static function.

Değiştirgeler

name
The name of the class to use.
Counter::getNamed
Basic
Counter


The basic interface

İçindekiler

  • counter_get — Get the current value of the basic counter.
  • counter_bump — Update the current value of the basic counter.
  • counter_reset — Reset the current value of the basic counter.
Counter::setCounterClass
counter_get
The "counter" Extension - A Continuing Example


Get the current value of the basic counter.

Basic
counter_bump
Basic
PHP Manual

counter_get

counter_get — Get the current value of the basic counter.

Açıklama

integer counter_get ( void )

counter_get() returns the current value of the basic interface's counter.

Dönen Değerler

counter_get() returns an integer.

Ayrıca Bakınız

  • counter_bump() - Update the current value of the basic counter.
  • counter_reset() - Reset the current value of the basic counter.
Basic
counter_bump
Basic


Update the current value of the basic counter.

counter_get
counter_reset
Basic
PHP Manual

counter_bump

counter_bump — Update the current value of the basic counter.

Açıklama

voidcounter_bump ( integer $offset )

counter_bump() updates the current value of the basic interface's counter.

Değiştirgeler

offset
The amount by which to change the counter's value. Can be negative.

Ayrıca Bakınız

  • counter_get() - Get the current value of the basic counter.
  • counter_reset() - Reset the current value of the basic counter.
counter_get
counter_reset
Basic


Reset the current value of the basic counter.

counter_bump
Extended
Basic
PHP Manual

counter_reset

counter_reset — Reset the current value of the basic counter.

Açıklama

voidcounter_reset ( void )

counter_reset() resets the current value of the basic interface's counter to its original initial value.

Ayrıca Bakınız

  • counter_get() - Get the current value of the basic counter.
  • counter_bump() - Update the current value of the basic counter.
counter_bump
Extended
Basic


The extended interface

İçindekiler

  • counter_create — Creates a counter which maintains a single numeric value.
  • counter_get_value — Get the current value of a counter resource.
  • counter_bump_value — Change the current value of a counter resource.
  • counter_reset_value — Reset the current value of a counter resource.
  • counter_get_meta — Return a piece of metainformation about a counter resource.
  • counter_get_named — Retrieve an existing named counter as a resource.
counter_reset
counter_create
The "counter" Extension - A Continuing Example


Creates a counter which maintains a single numeric value.

Extended
counter_get_value
Extended
PHP Manual

counter_create

counter_create — Creates a counter which maintains a single numeric value.

Açıklama

resource counter_create ( string $name [, integer $initial_value [, integer $flags ]] )

Creates a counter which maintains a single numeric value.

Değiştirgeler

name
The new counter's name.
initial_value
The initial value of the counter. Defaults to zero (0).
flags
Flags for the new counter, chosen from the COUNTER_FLAG_* constants.

Dönen Değerler

Returns a counter resource.

Extended
counter_get_value
Extended


Get the current value of a counter resource.

counter_create
counter_bump_value
Extended
PHP Manual

counter_get_value

counter_get_value — Get the current value of a counter resource.

Açıklama

integer counter_get_value ( resource $counter )

counter_get_value() returns the current value of a counter resource.

Değiştirgeler

counter
The counter resource to operate on.

Dönen Değerler

counter_get_value() returns an integer.

Ayrıca Bakınız

  • counter_bump_value() - Change the current value of a counter resource.
  • counter_reset_value() - Reset the current value of a counter resource.
counter_create
counter_bump_value
Extended


Change the current value of a counter resource.

counter_get_value
counter_reset_value
Extended
PHP Manual

counter_bump_value

counter_bump_value — Change the current value of a counter resource.

Açıklama

voidcounter_bump_value ( resource $counter , integer $offset )

counter_bump_value() updates the current value of a counter resource.

Değiştirgeler

counter
The counter resource to operate on.
offset
The amount by which to change the counter's value. Can be negative.

Ayrıca Bakınız

  • counter_get_value() - Get the current value of a counter resource.
  • counter_reset_value() - Reset the current value of a counter resource.
counter_get_value
counter_reset_value
Extended


Reset the current value of a counter resource.

counter_bump_value
counter_get_meta
Extended
PHP Manual

counter_reset_value

counter_reset_value — Reset the current value of a counter resource.

Açıklama

voidcounter_reset_value ( resource $counter )

counter_reset_value() resets the current value of a counter resource to its original initial value.

Değiştirgeler

counter
The counter resource to operate on.

Ayrıca Bakınız

  • counter_get_value() - Get the current value of a counter resource.
  • counter_bump_value() - Change the current value of a counter resource.
counter_bump_value
counter_get_meta
Extended


Return a piece of metainformation about a counter resource.

counter_reset_value
counter_get_named
Extended
PHP Manual

counter_get_meta

counter_get_meta — Return a piece of metainformation about a counter resource.

Açıklama

mixed counter_get_meta ( resource $counter , integer $attribute )

counter_get_meta() returns metainformation about a counter resource.

Değiştirgeler

counter
The counter resource to operate on.
attribute
The metainformation to retrieve.

Dönen Değerler

counter_get_meta() returns values of varying types based on which metainformation was requested.

counter_reset_value
counter_get_named
Extended


Retrieve an existing named counter as a resource.

counter_get_meta
The PHP 5 build system
Extended
PHP Manual

counter_get_named

counter_get_named — Retrieve an existing named counter as a resource.

Açıklama

resource Counter::getNamed ( string $name )

counter_get_named() returns an existing counter by name if that name exists, or NULL otherwise.

Değiştirgeler

name
The counter name to search for.

Dönen Değerler

counter_get_name() returns an existing counter by name if that name exists, or NULL otherwise.

counter_get_meta
The PHP 5 build system
Extended


The PHP 5 build system

İçindekiler

  • Building PHP for extension development
  • The ext_skel script
  • Talking to the UNIX build system: config.m4
  • Talking to the Windows build system: config.w32

With all the functionality and flexibility available in PHP 5, it is no surprise that it consists of several thousand files and over one million lines of source code. Equally unsurprising is the necessity of a build system to manage so much data. This section describes how to set PHP up for extension development, the layout of an extension within the PHP source tree, and how to interface your extension with the build system.

counter_get_named
Building PHP for extension development
PHP’nin Çekirdeği; Çekirdek geliştiricilerin Rehberi


Building PHP for extension development

In a typical PHP installation, the need for high performance almost always results in optimization at the cost of debugging facilities. This is a reasonable tradeoff for production use, but when developing an extension it falls short. What we need is a build of PHP which will give us some hints what has gone wrong when something does.

The Zend Engine provides a memory manager which is capable of tracking memory leaks in extensions and providing detailed debugging information. This tracking is disabled by default, as is thread-safety. To turn them on, pass the --enable-debug and --enable-maintainer-zts options to configure, along with whatever options you typically use. For instructions on building PHP from source, see the instructions at Genel Kurulum Değerlendirmesi. A typical configure line might look like this:

$ ./configure --prefix=/where/to/install/php --enable-debug --enable-maintainer-zts --enable-cgi --enable-cli --with-mysql=/path/to/mysql

The PHP 5 build system
The ext_skel script
The PHP 5 build system


The ext_skel script

A PHP extension is composed of several files common to all extensions. As the details of many of those files are similar from extension to extension, it can be laborious to duplicate the content for each one. Fortunately, there is a script which can do all of the initial setup for you. It's called ext_skel, and it's been distributed with PHP since 4.0.

Running ext_skel with no parameters produces this output in PHP 5.2.2:

php-5.2.2/ext$ ./ext_skel
./ext_skel --extname=module [--proto=file] [--stubs=file] [--xml[=file]]
           [--skel=dir] [--full-xml] [--no-help]

  --extname=module   module is the name of your extension
  --proto=file       file contains prototypes of functions to create
  --stubs=file       generate only function stubs in file
  --xml              generate xml documentation to be added to phpdoc-cvs
  --skel=dir         path to the skeleton directory
  --full-xml         generate xml documentation for a self-contained extension
                     (not yet implemented)
  --no-help          don't try to be nice and create comments in the code
                     and helper functions to test if the module compiled
Generally, when developing a new extension the only parameters you will be interested in are --extname and --no-help. Unless you are already experienced with the structure of an extension, you will not want to use --no-help; specifying it causes ext_skel to leave out many helpful comments in the files it generates.

This leaves you with --extname, which tells ext_skel what the name of your extension is. This "name" is an all-lowercase identifier containing only letters and underscores which is unique among everything in the ext/ folder of your PHP distribution.

The --proto option is intended to allow the developer to specify a header file from which a set of PHP functions will be created, ostensibly for the purpose of developing an extension based on a library, but it often functions poorly with most modern header files. A test run on the zlib.h header resulted in a very large number of empty and nonsense prototypes in the ext_skel output files. The --xml and --full-xml options are entirely nonfunctional thus far. The --skel option can be used to specify a modified set of skeleton files to work from, a topic which is beyond the scope of this section.

Building PHP for extension development
Talking to the UNIX build system: config.m4
The PHP 5 build system


Talking to the UNIX build system: config.m4

The config.m4 file for an extension tells the UNIX build system what configure options your extension supports, what external libraries and includes you require, and what source files are to be compiled as part of it. A reference to all the commonly used autoconf macros, both PHP-specific and those built into autoconf, is given in the Zend Motoru 2 Başvuru Kılavuzu section.

İpucu

The version of autoconf you have installed makes a difference when developing an extension. For PHP 5.3 and earlier, you will have the best results with autoconf version 2.13 but versions up to and including 2.59 will work. For PHP 5.4 and later the oldest autoconf version you can use is 2.59 and you will have better results with later versions.

Örnek 1 An example config.m4 file

dnl $Id$
dnl config.m4 for extension example
PHP_ARG_WITH(example, for example support,
[  --with-example[=FILE]       Include example support. File is the optional path to example-config])
PHP_ARG_ENABLE(example-debug, whether to enable debugging support in example,
[  --enable-example-debug        example: Enable debugging support in example], no, no)
PHP_ARG_WITH(example-extra, for extra libraries for example,
[  --with-example-extra=DIR      example: Location of extra libraries for example], no, no)

dnl Check whether the extension is enabled at all
if test "$PHP_EXAMPLE" != "no"; then

  dnl Check for example-config. First try any path that was given to us, then look in $PATH
  AC_MSG_CHECKING([for example-config])
  EXAMPLE_CONFIG="example-config"
  if test "$PHP_EXAMPLE" != "yes"; then
    EXAMPLE_PATH=$PHP_EXAMPLE
  else
    EXAMPLE_PATH=`$php_shtool path $EXAMPLE_CONFIG`
  fi

  dnl If a usable example-config was found, use it
  if test -f "$EXAMPLE_PATH" && test -x "$EXAMPLE_PATH" && $EXAMPLE_PATH --version > /dev/null 2>&1; then
    AC_MSG_RESULT([$EXAMPLE_PATH])
    EXAMPLE_LIB_NAME=`$EXAMPLE_PATH --libname`
    EXAMPLE_INCDIRS=`$EXAMPLE_PATH --incdirs`
    EXAMPLE_LIBS=`$EXAMPLE_PATH --libs`

    dnl Check that the library works properly
    PHP_CHECK_LIBRARY($EXAMPLE_LIB_NAME, example_critical_function,
    [
      dnl Add the necessary include dirs
      PHP_EVAL_INCLINE($EXAMPLE_INCDIRS)
      dnl Add the necessary libraries and library dirs
      PHP_EVAL_LIBLINE($EXAMPLE_LIBS, EXAMPLE_SHARED_LIBADD)
    ],[
      dnl Bail out
      AC_MSG_ERROR([example library not found. Check config.log for more information.])
    ],[$EXAMPLE_LIBS]
    )
  else
    dnl No usable example-config, bail
    AC_MSG_RESULT([not found])
    AC_MSG_ERROR([Please check your example installation.])
  fi

  dnl Check whether to enable debugging
  if test "$PHP_EXAMPLE_DEBUG" != "no"; then
    dnl Yes, so set the C macro
    AC_DEFINE(USE_EXAMPLE_DEBUG,1,[Include debugging support in example])
  fi

  dnl Check for the extra support
  if test "$PHP_EXAMPLE_EXTRA" != "no"; then
    if test "$PHP_EXAMPLE_EXTRA" == "yes"; then
      AC_MSG_ERROR([You must specify a path when using --with-example-extra])
    fi

    PHP_CHECK_LIBRARY(example-extra, example_critical_extra_function,
    [
      dnl Add the neccessary paths
      PHP_ADD_INCLUDE($PHP_EXAMPLE_EXTRA/include)
      PHP_ADD_LIBRARY_WITH_PATH(example-extra, $PHP_EXAMPLE_EXTRA/lib, EXAMPLE_SHARED_LIBADD)
      AC_DEFINE(HAVE_EXAMPLEEXTRALIB,1,[Whether example-extra support is present and requested])
      EXAMPLE_SOURCES="$EXAMPLE_SOURCES example_extra.c"
    ],[
      AC_MSG_ERROR([example-extra lib not found. See config.log for more information.])
    ],[-L$PHP_EXAMPLE_EXTRA/lib]
    )
  fi

  dnl Finally, tell the build system about the extension and what files are needed
  PHP_NEW_EXTENSION(example, example.c $EXAMPLE_SOURCES, $ext_shared)
  PHP_SUBST(EXAMPLE_SHARED_LIBADD)
fi

A short introduction to autoconf syntax

config.m4 files are written using the GNU autoconf syntax. It can be described in a nutshell as shell scripting augmented by a powerful macro language. Comments are delimited by the string dnl, and strings are quoted using left and right brackets (e.g. [ and ]). Quoting of strings can be nested as many times as needed. A full reference to the syntax can be found in the autoconf manual at » http://www.gnu.org/software/autoconf/manual/.

PHP_ARG_*: Giving users the option

The very first thing seen in the example config.m4 above, aside from a couple of comments, are three lines using PHP_ARG_WITH() and PHP_ARG_ENABLE(). These provide configure with the options and help text seen when running ./configure --help. As the names suggest, the difference between the two is whether they create a --with-* option or an --enable-* option. Every extension should provide at least one or the other with the extension name, so that users can choose whether or not to build the extension into PHP. By convention, PHP_ARG_WITH() is used for an option which takes a parameter, such as the location of a library or program required by an extension, while PHP_ARG_ENABLE() is used for an option which represents a simple flag.

Örnek 2 Sample configure output

$ ./configure --help
...
  --with-example[=FILE]       Include example support. FILE is the optional path to example-config
  --enable-example-debug        example: Enable debugging support in example
  --with-example-extra=DIR      example: Location of extra libraries for example
...

$ ./configure --with-example=/some/library/path/example-config --disable-example-debug --with-example-extra=/another/library/path
...
checking for example support... yes
checking whether to enable debugging support in example... no
checking for extra libraries for example... /another/library/path
...

Bilginize:

Regardless of the order in which options are specified on the command line when configure is called, the checks will be run in the order they are specified in config.m4.

Processing the user's choices

Now that config.m4 can provide the user with some choices of what to do, it's time to act upon those choices. In the example above, the obvious default for all three options, if any of them are unspecified, is "no". As a matter of convention, it is best to use this as the default for the option which enables the extension, as it will be overridden by phpize for extensions built separately, and should not clutter the extension space by default when being built into PHP. The code to process the three options is by far the most complicated.

Handling the --with-example[=FILE] option

The first check made of the --with-example[=FILE] option is whether it was set at all. As this option controls the inclusion of the entire extension, if it was unspecified, given in the negative form (--without-example ), or given the value "no", nothing else is done at all. In the example above, it is specified with the value /some/library/path/example-config, so the first test succeeds.

Next, the code calls AC_MSG_CHECKING(), an autoconf macro which outputs a standard "checking for something" line, and checks whether the user gave an explicit path to the fictional example-config. In this example, PHP_EXAMPLE got the value /some/library/path/example-config, which is now copied into the EXAMPLE_PATH variable. Had the user specified only --with-example , the code would have executed $php_shtool path $EXAMPLE_CONFIG, which would try to guess the location of example-config using the user's current PATH. Either way, the next step is to check whether the chosen EXAMPLE_PATH is a regular file, is executable, and can be run successfully. If so, AC_MSG_RESULT() is called, which completes the output line started by AC_MSG_CHECKING(). Otherwise, AC_MSG_ERROR() is called, which prints the given message and halts configure immediately.

The code now determines some site-specific configuration information by running example-config several times. The next call is to PHP_CHECK_LIBRARY(), a macro provided by the PHP buildsystem as a wrapper around autoconf's AC_CHECK_LIB(). PHP_CHECK_LIBRARY() attempts to compile, link, and run a program which calls the symbol specified by the second parameter in the library specified by the first, using the string given in the fifth as extra linker options. If the attempt succeeds, the script given in the third parameter is run. This script tells the PHP buildsystem to extract include paths, library paths, and library names from the raw option strings example-config provided. If the attempt fails, the script in the fourth parameter is run instead. In this case, AC_MSG_ERROR() is called to stop processing.

Handling the --enable-example-debug option

Processing the --enable-example-debug is much simpler. A simple check for its truth value is performed. If that check succeeds, AC_DEFINE() is called to make the C macro USE_EXAMPLE_DEBUG available to the source of the extension. The third parameter is a comment string for config.h; it is safe to leave this empty, and often is.

Handling the --with-example-extra=DIR option

For the sake of this example, the fictional "extra" functionality requested by the --with-example-extra=DIR option does not share the fictional example-config program, nor does it have any default paths to search. Therefore, the user is required to provide the installation prefix of the necessary library. This setup is somewhat unlikely in a real-world extension, but is considered illustrative.

The code begins in a now-familiar way by checking the truth value of PHP_EXAMPLE_EXTRA. If a negative form was provided, no further processing is done; the user did not request extra functionality. If a positive form was provided without a parameter, AC_MSG_ERROR() is called to halt processing. The next step is another invocation of PHP_CHECK_LIBRARY(). This time, since there is no set of predefined compiler options provided, PHP_ADD_INCLUDE() and PHP_ADD_LIBRARY_WITH_PATH() are used to construct the necessary include paths, library paths, and library flags for the extra functionality. AC_DEFINE() is also called to indicate to the code that the extra functionality was both requested and available, and a variable is set to tell later code that there are extra source files to build. If the check fails, the familiar AC_MSG_ERROR() is called. A different way to handle the failure would have been to call AC_MSG_WARNING() instead, e.g.:

AC_MSG_WARNING([example-extra lib not found. example will be built without extra functionality.])

In this case, configure would print a warning message rather than an error, and continue processing. Which way such failures are handled is a design decision left to the extension developer.

Telling the buildsystem what was decided

With all the necessary includes and libraries specified, with all the options processed and macros defined, one more thing remains to be done: The build system must be told to build the extension itself, and which files are to be used for that. To do this, the PHP_NEW_EXTENSION() macro is called. The first parameter is the name of the extension, which is the same as the name of the directory containing it. The second parameter is the list of all source files which are part of the extension. See PHP_ADD_BUILD_DIR() for information about adding source files in subdirectories to the build process. The third parameter should always be $ext_shared, a value which was determined by configure when PHP_ARG_WITH() was called for --with-example[=FILE] . The fourth parameter specifies a "SAPI class", and is only useful for extensions which require the CGI or CLI SAPIs specifically. It should be left empty in all other cases. The fifth parameter specifies a list of flags to be added to CFLAGS while building the extension; the sixth is a boolean value which, if "yes", will force the entire extension to be built using $CXX instead of $CC. All parameters after the third are optional. Finally, PHP_SUBST() is called to enable shared builds of the extension. See Eklentilerin SSS'leri for more information on disabling support for building an extension in shared mode.

The counter extension's config.m4 file

The counter extension previously documented has a much simpler config.m4 file than that described above, as it doesn't make use of many buildsystem features. This is a preferred method of operation for any extension that doesn't use an external or bundled library.

Örnek 3 counter's config.m4 file

dnl
$
Id$
dnl config.m4 for extension counter

PHP_ARG_ENABLE(counter, for counter support,
[  --enable-counter            Include counter support])

dnl Check whether the extension is enabled at all
if test "$PHP_COUNTER" != "no"; then
  dnl Finally, tell the build system about the extension and what files are needed
  PHP_NEW_EXTENSION(counter, counter.c counter_util.c, $ext_shared)
  PHP_SUBST(COUNTER_SHARED_LIBADD)
fi
The ext_skel script
Talking to the Windows build system: config.w32
The PHP 5 build system


Talking to the Windows build system: config.w32

An extension's config.w32 file is similar in usage to the config.m4 file, with two critical differences: first, it is used for Windows builds, and second, it is written in JavaScript. This section makes no attempt to cover JavaScript syntax. For the moment, this section is incomplete in lieu of a Win32 testbed, and an experimental-only port of the example config.m4 is the only example provided.

Örnek 1 An example config.w32 file

// $Id$
// vim:ft=javascript
ARG_WITH("example", "for example support", "no");
ARG_ENABLE("example-debug", "for debugging support in example", "no")
ARG_WITH("example-extra", "for extra functionality in example", "no")
if (PHP_EXAMPLE != "no") {
    if (CHECK_LIB("libexample.lib", "example", PHP_EXAMPLE) &&
        CHECK_HEADER_ADD_INCLUDE("example.h", "CFLAGS_EXAMPLE", PHP_EXAMPLE + "\\include")) {

        if (PHP_EXAMPLE_DEBUG != "no") {
            AC_DEFINE('USE_EXAMPLE_DEBUG', 1, 'Debug support in example');
        }

        if (PHP_EXAMPLE_EXTRA != "no" &&
            CHECK_LIB("libexample-extra.lib", "example", PHP_EXAMPLE) &&
            CHECK_HEADER_ADD_INCLUDE("example-extra.h", "CFLAGS_EXAMPLE", PHP_EXAMPLE + ";" + PHP_PHP_BUILD + "\\include") {
            AC_DEFINE('HAVE_EXAMPLEEXTRA', 1, 'Extra functionality in example');
            HAVE_EXTRA = 1;
        } else {
            WARNING( "extra example functionality not enabled, lib not found" );
        }

        EXTENSION("example", "example.c");
        if (HAVE_EXTRA == 1) {
            ADD_SOURCES("example-extra.c");
        }
    } else {
        WARNING( "example not enabled; libraries not found" );
    }
}

The counter extension's config.w32 file

The counter extension previously documented has a much simpler config.w32 file than that described above, as it doesn't make use of many buildsystem features.

Örnek 2 counter's config.w32 file

// $Id$
// vim:ft=javascript
ARG_ENABLE("counter", "for counter support", "no");
if (PHP_COUNTER != "no") {
    EXTENSION("counter", "counter.c");
    ADD_SOURCE("counter-util.c");
}
Talking to the UNIX build system: config.m4
Extension structure
The PHP 5 build system


Extension structure

İçindekiler

  • Files which make up an extension
  • Basic constructs
  • The zend_module structure
  • Extension globals
  • Life cycle of an extension
  • Testing an extension

Many extension-writing guides focus on simple examples first and ignore the requirements of more complex implementations until later. Often such guides must repeat themselves over and over in order to describe these new features. This section describes extension structure from the perspective of a mature, practical implementation, in order to prepare users for needs and issues they will almost always encounter in the process of extension development.

Talking to the Windows build system: config.w32
Files which make up an extension
PHP’nin Çekirdeği; Çekirdek geliştiricilerin Rehberi


Files which make up an extension

Whether created by hand, using ext_skel, or by an alternate extension generator, such as » CodeGen, all extensions will have at least four files:

config.m4

UNIX build system configuration (see Talking to the UNIX build system: config.m4)

config.w32

Windows buildsystem configuration (see Talking to the Windows build system: config.w32)

php_counter.h

When building an extension as static module into the PHP binary the build system expects a header file with php_ prepended to the extension name which includes a declaration for a pointer to the extension's module structure. This file usually contains additional macros, prototypes, and globals, just like any header.

counter.c

Main extension source file. By convention, the name of this file is the extension name, but this is not a requirement. This file contains the module structure declaration, INI entries, management functions, userspace functions, and other requirements of an extension.

The buildsystem files are discussed elsewhere; this section concentrates on the rest. These four files make up the bare minimum for an extension, which may also contain any number of headers, source files, unit tests, and other support files. The list of files in the counter extension might look like this:

Örnek 1 Files in the counter extension, in no particular order

ext/
 counter/
  .svnignore
  config.m4
  config.w32
  counter_util.h
  counter_util.c
  php_counter.h
  counter.c
  package.xml
  CREDITS
  tests/
   critical_function_001.phpt
   critical_function_002.phpt
   optional_function_001.phpt
   optional_function_002.phpt

Non-source files

The .svnignore file is used for extensions which are checked into the PHP Subversion repository (usually » PECL); the one generated by ext_skel contains:

.deps
*.lo
*.la

These lines tell Subversion to ignore interim files generated by the PHP buildsystem. This is only a convenience, and can be omitted completely without ill effect.

The CREDITS file lists the contributors and/or maintainers of the extension in plain text format. The main purpose of this file is generating the credits information for bundled extensions as used by phpcredits(). By convention the first line of the file should hold the name of the extension, the second a comma separated list of contributors. The contributors are usually ordered by the chronological order of their contributions. In a » PECL package, this information is already maintained in package.xml, for example. This is another file which can be omitted without ill effect.

The package.xml file is specific to » PECL-based extensions; it is a metainformation file which gives details about an extension's dependencies, authors, installation requirements, and other tidbits. In an extension not being hosted in » PECL, this file is extraneous.

Extension structure
Basic constructs
Extension structure


Basic constructs

C is a very low-level language by modern definitions. This means that it has no built-in support for many features that PHP takes for granted, such as reflection, dynamic module loading, bounds checking, threadsafe data management and various useful data structures including linked lists and hash tables. At the same time, C is a common denominator of language support and functionality. Given enough work, none of these concepts are impossible; the Zend Engine uses them all.

A lot of effort has gone into making the Zend API both extensible and understandable, but C forces certain necessary declarations upon any extension that to an inexperienced eye seem redundant or plain unnecessary. All of those constructs, detailed in this section, are "write once and forget" in Zend Engine 2 and 3. Here are some excerpts from the pre-generated php_counter.h and counter.c files created by PHP 5.3's ext_skel, showing the pre-generated declarations:

Bilginize: The astute reader will notice that there are several declarations in the real files that aren't shown here. Those declarations are specific to various Zend subsystems and are discussed elsewhere as appropriate.

extern zend_module_entry counter_module_entry;
#define phpext_counter_ptr &counter_module_entry

#ifdef PHP_WIN32
#    define PHP_COUNTER_API __declspec(dllexport)
#elif defined(__GNUC__) && __GNUC__ >= 4
#    define PHP_COUNTER_API __attribute__ ((visibility("default")))
#else
#    define PHP_COUNTER_API
#endif

#ifdef ZTS
#include "TSRM.h"
#endif

#ifdef HAVE_CONFIG_H
#include "config.h"
#endif

#include "php.h"
#include "php_ini.h"
#include "ext/standard/info.h"
#include "php_counter.h"

/* ... */

#ifdef COMPILE_DL_COUNTER
ZEND_GET_MODULE(counter)
#endif
  • The lines concerning counter_module_entry declare a global variable, and a macroed pointer to it, which contains the zend_module_entry for the extension. Despite the later discussion regarding the drawbacks of "true" globals, this usage is intentional; Zend takes precautions to avoid misusing this variable.
  • PHP_COUNTER_API is declared for use by non-PHP functions the module intends to export for the use of other modules. The counter extension doesn't declare any of these, and in the final version of the header file, this macro has been removed. The PHPAPI macro is declared identically elsewhere and is used by the standard extension to make the phpinfo() utility functions available to other extensions.
  • The include of TSRM.h is skipped if PHP, or the extension, isn't being compiled with thread-safety, since in that case TSRM isn't used.
  • A standard list of includes, especially the extension's own php_counter.h, is given. config.h gives the extension access to determinations made by configure. php.h is the gateway to the entire PHP and Zend APIs. php_ini.h adds the APIs for runtime configuration (INI) entries. Not all extensions will use this. Finally, ext/standard/info.h imports the aforementioned phpinfo() utility API.
  • COMPILE_DL_COUNTER will only be defined by configure if the counter extension is both enabled and wants to be built as a dynamically loadable module instead of being statically linked into PHP. ZEND_GET_MODULE defines a tiny function which Zend can use to get the extension's zend_module_entry at runtime.

    Bilginize: The astute reader who has peeked into main/php_config.h after trying to build with the counter module enabled statically may have noticed that there is also a HAVE_COUNTER constant defined that the source code doesn't check for. There's a simple reason this check isn't done: It's unnecessary. If the extension isn't enabled, the source file will never be compiled.

Files which make up an extension
The zend_module structure
Extension structure


The zend_module structure

The main source file of a PHP extension contains several new constructs for a C programmer. The most important of these, the one touched first when starting a new extension, is the zend_module structure. This structure contains a wealth of information that tells the Zend Engine about the extension's dependencies, version, callbacks, and other critical data. The structure has mutated considerably over time; this section will focus on the structure as it has appeared since PHP 5.2, and will identify the very few parts which have changed in PHP 5.3.

The zend_module declaration from counter.c looks like this before any code has been written. The example file was generated by ext_skel --extname=counter, with some obsolete constructs removed:

Örnek 1 zend_module declaration in the counter extension

/* {{{ counter_module_entry
 */
zend_module_entry counter_module_entry = {
    STANDARD_MODULE_HEADER,
    "counter",
    counter_functions,
    PHP_MINIT(counter),
    PHP_MSHUTDOWN(counter),
    PHP_RINIT(counter),        /* Replace with NULL if there's nothing to do at request start */
    PHP_RSHUTDOWN(counter),    /* Replace with NULL if there's nothing to do at request end */
    PHP_MINFO(counter),
    "0.1", /* Replace with version number for your extension */
    STANDARD_MODULE_PROPERTIES
};
/* }}} */

This may look a bit daunting at first glance, but most of it is very simple to understand. Here's the declaration of zend_module from zend_modules.h in PHP 5.3:

Örnek 2 zend_module definition in PHP 5.3

struct _zend_module_entry {
    unsigned short size;
    unsigned int zend_api;
    unsigned char zend_debug;
    unsigned char zts;
    const struct _zend_ini_entry *ini_entry;
    const struct _zend_module_dep *deps;
    const char *name;
    const struct _zend_function_entry *functions;
    int (*module_startup_func)(INIT_FUNC_ARGS);
    int (*module_shutdown_func)(SHUTDOWN_FUNC_ARGS);
    int (*request_startup_func)(INIT_FUNC_ARGS);
    int (*request_shutdown_func)(SHUTDOWN_FUNC_ARGS);
    void (*info_func)(ZEND_MODULE_INFO_FUNC_ARGS);
    const char *version;
    size_t globals_size;
#ifdef ZTS
    ts_rsrc_id* globals_id_ptr;
#else
    void* globals_ptr;
#endif
    void (*globals_ctor)(void *global TSRMLS_DC);
    void (*globals_dtor)(void *global TSRMLS_DC);
    int (*post_deactivate_func)(void);
    int module_started;
    unsigned char type;
    void *handle;
    int module_number;
};

Many of these fields will never be touched by an extension writer. There are a number of standard macros that set them to their proper values automatically. The macro STANDARD_MODULE_HEADER fills in everything up to the deps field. Alternatively, the STANDARD_MODULE_HEADER_EX will leave the deps field empty for the developer's use. The developer is always responsible for everything from name to version. After that, the STANDARD_MODULE_PROPERTIES macro will fill in the rest of the structure, or the STANDARD_MODULE_PROPERTIES_EX macro can be used to leave the extension globals and post-deactivation function fields unfilled. Most modern extensions will make use of module globals.

Bilginize:

This table gives the values that each field would have if the developer were to fill in the structure entirely by hand, without recourse to any of the shortcut macros. This is not recommended. The "correct" values for many fields may change. Use the macros whenever possible.

Module structure field values
Field | Value | Description
size [1] [2] [3] | sizeof(zend_module_entry) | The size in bytes of the structure.
zend_api [1] [2] [3] | ZEND_MODULE_API_NO | The version of the Zend API this module was compiled against.
zend_debug [1] [2] [3] | ZEND_DEBUG | A flag indicating whether the module was compiled with debugging turned on.
zts [1] [2] [3] | USING_ZTS | A flag indicating whether the module was compiled with ZTS (TSRM) enabled (see Bellek Yönetimi).
ini_entry [1] [3] | NULL | This pointer is used internally by Zend to keep a non-local reference to any INI entries declared for the module.
deps [3] | NULL | A pointer to a list of dependencies for the module.
name | "mymodule" | The name of the module. This is the short name, such as "spl" or "standard".
functions | mymodule_functions | A pointer to the module's function table, which Zend uses to expose functions in the module to user space.
module_startup_func | PHP_MINIT(mymodule) | A callback function that Zend will call the first time a module is loaded into a particular instance of PHP.
module_shutdown_func | PHP_MSHUTDOWN(mymodule) | A callback function that Zend will call the when a module is unloaded from a particular instance of PHP, typically during final shutdown.
request_startup_func | PHP_RINIT(mymodule) | A callback function that Zend will call at the beginning of each request. This should be as short as possible or NULL as calling this has costs on every request.
request_shutdown_func | PHP_RSHUTDOWN(mymodule) | A callback function that Zend will call at the end of each request. This should be as short as possible or NULL as calling this has costs on every request.
info_func | PHP_MINFO(mymodule) | A callback function that Zend will call when the phpinfo() function is called.
version | NO_VERSION_YET | A string giving the version of the module, as specified by the module developer. It is recommended that the version number be either in the format expected by version_compare() (e.g. "1.0.5-dev"), or a CVS or SVN revision number (e.g. "$Rev: 322138 $").
globals_size [1] [4] [5] [6] | sizeof(zend_mymodule_globals) | The size of the data structure containing the module's globals, if any.
globals_id_ptr [1] [4] [5] [6] [7] | &mymodule_globals_id | Only one of these two fields will exist, depending upon whether the USING_ZTS constant is TRUE. The former is an index into TSRM's allocation table for the module's globals, and the latter is a pointer directly to the globals.
globals_ptr [1] [4] [5] [6] [8] | &mymodule_globals
globals_ctor [4] [5] [6] | PHP_GINIT(mymodule) | This funtion is called to initialize a module's globals before any module_startup_func.
globals_dtor [4] [5] [6] | PHP_GSHUTDOWN(mymodule) | This funtion is called to deallocate a module's globals after any module_shutdown_func.
post_deactivate_func [4] | ZEND_MODULE_POST_ZEND_DEACTIVATE_N(mymodule) | This function is called by Zend after request shutdown. It is rarely used.
module_started [1] [9] [4] | 0 | These fields are used for Zend's internal tracking information.
type [1] [9] [4] | 0
handle [1] [9] [4] | NULL
module_number [1] [9] [4] | 0
[1] This field is not intended for use by module developers. [2] This field is filled in by STANDARD_MODULE_HEADER_EX. [3] This field is filled in by STANDARD_MODULE_HEADER. [4] This field is filled in by STANDARD_MODULE_PROPERTIES. [5] This field is filled in by NO_MODULE_GLOBALS. [6] This field is filled in by PHP_MODULE_GLOBALS. [7] This field only exists when USING_ZTS is TRUE. [8] This field only exists when USING_ZTS is FALSE. [9] This field is filled in by STANDARD_MODULE_PROPERTIES_EX.

Filling in the structure in a practical situation

With all these fields to play with, it can be confusing to know which to use for what purpose. Here is the zend_module definition from the "counter" example extension after updating it to its final form.

Örnek 3 Counter extension module definition

/* {{{ counter_module_entry
 */
zend_module_entry counter_module_entry = {
    STANDARD_MODULE_HEADER,
    "counter",
    counter_functions,
    PHP_MINIT(counter),
    PHP_MSHUTDOWN(counter),
    PHP_RINIT(counter),
    PHP_RSHUTDOWN(counter),
    PHP_MINFO(counter),
    NO_VERSION_YET,
    PHP_MODULE_GLOBALS(counter),
    PHP_GINIT(counter),
    PHP_GSHUTDOWN(counter),
    NULL,
    STANDARD_MODULE_PROPERTIES_EX
};
/* }}} */
  • STANDARD_MODULE_HEADER is used since this module doesn't define any dependencies.
  • "counter" is the extension's name, and is used to define the various callback functions the module passes to Zend. "counter" uses module, globals, and request functions at startup and shutdown times, and provides information to phpinfo(), so all seven callbacks are defined.
  • It is assumed that there is a variable of type zend_function_entry * named counter_functions earlier in the file that contains the module definition, listing the functions the module exports to userspace.
  • NO_VERSION_YET is a particularly nice way of telling Zend the module doesn't have a version. It might have been more correct to place "1.0" here instead in a real module.
  • "counter" uses per-module globals, so PHP_MODULE_GLOBALS is used
  • This module has no post-deactivate function, so NULL is used.
  • Since this module does use globals, STANDARD_MODULE_PROPERTIES_EX is used to finish the structure.

What's changed between 5.2 and 5.3?

Nothing. The only differences in the zend_module structure between PHP 5.2 and PHP 5.3 are a few const keywords.

Basic constructs
Extension globals
Extension structure


Extension globals

Introduction to globals in a PHP extension

In a language such as C, a "global" variable is a variable that can be accessed from any function without any extra declaration. These traditional globals have a few drawbacks:

  • Barring any special options passed to the compiler, a global variable can be accessed and changed by any piece of code anywhere in the program, whether or not that code should be doing so.
  • A typical global variable is not thread safe.
  • The names of global variables are as global as the variables themselves.

A PHP extension's globals are more properly called the "extension state", since most modules must remember what they're doing between function calls. The "counter" extension is a perfect example of this need: The basic interface calls for a counter with a persistent value. A programmer new to Zend and PHP might do something like this in counter.c to store that value:

Örnek 1 The wrong way to store the basic counter interface's value

/* ... */
static long basic_counter_value;

/* ... */

PHP_FUNCTION(counter_get)
{
    RETURN_LONG(basic_counter_value);
}

On the surface this appears a viable solution, and indeed in a simple test it would function correctly. However, there are a number of situations in which more than one copy of PHP is running in the same thread, which means more than one instance of the counter module. Suddenly these multiple threads are sharing the same counter value, which is clearly undesirable. Another problem shows itself when considering that another extension might someday happen to have a global with the same name, and due to the rules of C scoping, this has the potential to cause a compile failure, or worse, a runtime error. Something more elaborate is needed, and so exists Zend's support for thread-safe per-module globals.

Declaring module globals

Whether a module uses only a single global or dozens, they must be defined in a structure, and that structure must be declared. There are some macros that assist with doing so in a way that avoids name conflicts between modules: ZEND_BEGIN_MODULE_GLOBALS(), ZEND_END_MODULE_GLOBALS(), and ZEND_DECLARE_MODULE_GLOBALS(). All three take as a parameter the short name of the module, which in the case of the counter module is simply "counter". Here is the global structure declaration from php_counter.h:

Örnek 2 The counter module's globals

ZEND_BEGIN_MODULE_GLOBALS(counter)
    long        basic_counter_value;
ZEND_END_MODULE_GLOBALS(counter)

And this is the declaration from counter.c:

Örnek 3 The counter module's global structure declaration

ZEND_DECLARE_MODULE_GLOBALS(counter)

Accessing module globals

As discussed above, per-module globals are declared inside a C structure whose name is obscured by Zend macros. As a result, the ideal way to access members of this structure is by the use of further macros. Accordingly, most if not all extensions which have globals have a declaration like this somewhere in their header file:

Örnek 4 Accessor macros for per-module globals

#ifdef ZTS
#define COUNTER_G(v) TSRMG(counter_globals_id, zend_counter_globals *, v)
#else
#define COUNTER_G(v) (counter_globals.v)
#endif

Bilginize: This could have been generalized into a macro of its own by the Zend API, but as of PHP 5.3 (and PHP 6 at the time of this writing), that hasn't happened. The global accessor construct is written into the header by ext_skel and thus is generally left alone by extension writers, unless they wish to change the name of the accessor macro.

Bilginize: COUNTER_G was the name given to the macro by ext_skel, but it's not necessary for it to have that name and could just as easily be called FOO instead.

Any code in the counter extension that accesses a global must thus wrap it in the macro COUNTER_G.

Uyarı

Any function which accesses globals must either be declared by Zend macros, have TSRMLS_DC as its last argument, or call the macro TSRMLS_FETCH before accessing the globals. See the TSRM documentation for more information.

So with all of that in mind, here is our new version of the counter_get():

Örnek 5 The right way to store the basic counter interface's value

/* php_counter.h */
ZEND_BEGIN_MODULE_GLOBALS(counter)
    long        basic_counter_value;
ZEND_END_MODULE_GLOBALS(counter)

#ifdef ZTS
#define COUNTER_G(v) TSRMG(counter_globals_id, zend_counter_globals *, v)
#else
#define COUNTER_G(v) (counter_globals.v)
#endif

/* counter.c */
ZEND_DECLARE_MODULE_GLOBALS(counter)

/* ... */

PHP_FUNCTION(counter_get)
{
    RETURN_LONG(COUNTER_G(basic_counter_value));
}

This is a correct implementation. It is not, however, a complete one. The section Life cycle of an extension explains why.

The zend_module structure
Life cycle of an extension
Extension structure


Life cycle of an extension

A PHP extension goes through several phases during its lifetime. All of these phases are opportunities for the developer to perform various initialization, termination, or informational functions. The Zend API allows for hooks into five separate phases of an extension's existence, apart from calls by PHP functions.

Loading, unloading, and requests

As the Zend engine runs, it processes one or more "requests" from its client. In the traditional CGI implementation, this corresponds to one execution of a process. However, many other implementations, most notably the Apache module, can map many requests onto a single PHP process. A PHP extension may thus see many requests in its lifetime.

Overview

  • In the Zend API, a module is loaded into memory only once when the associated PHP process starts up. Each module receives a call to the "module initialization" function specified in its zend_module structure as it is loaded.
  • Whenever the associated PHP process starts to handle a request from its client - i.e. whenever the PHP interpreter is told to start working - each module receives a call to the "request initialization" function specified in its zend_module structure.
  • Whenever the associated PHP process is done handling a request, each module receives a call to the "request termination" function specified in its zend_module structure.
  • A given module is unloaded from memory when its associated PHP process is shut down in an orderly manner. The module receives a call to the "module termination" function specified in its zend_module structure at this time.

What to do, and when to do it

There are many tasks that might be performed at any of these four points. This table details where many common initialization and termination tasks belong.

What to do, and when to do it
Module initialization/termination | Request initialization/termination
Allocate/deallocate and initialize module global variables | Allocate/deallocate and initialize request-specific variables
Register/unregister class entries |
Register/unregister INI entries |
Register constants |

The phpinfo() callback

Aside from globals initialization and certain rarely-used callbacks, there is one more part of a module's lifecycle to examine: A call to phpinfo(). The output a user sees from this call, whether text or HTML or anything else, is generated by each individual extension that is loaded into the PHP interpreter at the time the call is made.

To provide for format-neutral output, the header "ext/standard/info.h" provides an array of functions to produce standardized display elements. Specifically, several functions which create the familiar tables exist:

php_info_print_table_start()
Open a table in phpinfo() output. Takes no parameters.
php_info_print_table_header()
Print a table header in phpinfo() output. Takes one parameter, the number of columns, plus the same number of char * parameters which are the texts for each column heading.
php_info_print_table_row()
Print a table row in phpinfo() output. Takes one parameter, the number of columns, plus the same number of char * parameters which are the texts for each column content.
php_info_print_table_end()
Close a table formerly opened by php_info_print_table_start(). Takes no parameters.

Using these four functions, it is possible to produce status information for nearly any combination of features in an extension. Here is the information callback from the counter extension:

Örnek 1 counter's PHP_MINFO function

/* {{{ PHP_MINFO(counter) */
PHP_MINFO_FUNCTION(counter)
{
    char        buf[10];

    php_info_print_table_start();
    php_info_print_table_row(2, "counter support", "enabled");
    snprintf(buf, sizeof(buf), "%ld", COUNTER_G(basic_counter_value));
    php_info_print_table_row(2, "Basic counter value", buf);
    php_info_print_table_end();
}
/* }}} */
Extension globals
Testing an extension
Extension structure


Testing an extension

One of the accepted requirements of good programming is testing. PHP provides a test harness for unit regression tests, in the form of a script called run-tests.php.

Tests for a particular module are stored in the tests/ subdirectory of the module's folder, and have a .phpt extension. For details of the PHPT format, see » http://qa.php.net/.

Life cycle of an extension
PDO Driver How-To
Extension structure


PDO Driver How-To

İçindekiler

  • Prerequisites
  • Preparation and Housekeeping
  • Fleshing out your skeleton
  • Building
  • Testing
  • Packaging and distribution
  • pdo_dbh_t definition
  • pdo_stmt_t definition
  • Constants
  • Error handling

The purpose of this How-To is to provide a basic understanding of the steps required to write a database driver that interfaces with the PDO layer. Please note that this is still an evolving API and as such, subject to change. This document was prepared based on version 0.3 of PDO. The learning curve is steep; expect to spend a lot of time on the prerequisites.

Testing an extension
Prerequisites
PHP’nin Çekirdeği; Çekirdek geliştiricilerin Rehberi


Prerequisites

The following is list of prerequisites and assumptions needed for writing a PDO database driver:

  1. A working target database, examples, demos, etc. working as per vendor specifications;

  2. A working development environment:

    1. Linux: standard development tools, gcc, ld, make, autoconf, automake, etc., versions dependent on distribution;

    2. Other Unix: standard development tools supplied by vendor plus the GNU development tool set;

    3. Win32: Visual Studio compiler suite;

  3. A working PHP environment version 5.0.3 or higher with a working PEAR extension version 1.3.5 or higher;

  4. A working PDO environment (can be installed using 'sudo pecl install PDO'), including the headers which will be needed to access the PDO type definitions and function declarations;

  5. A good working knowledge of the C programming language;

  6. A good working knowledge of the way to write a PHP extension; George Schlossnagle's Advanced PHP Programming (published by Developer's Library, chapters 21 and 22) is recommended;

  7. Finally, a familiarity with the Zend API that forms the heart of PHP, in particular paying attention to the memory management aspects.

PDO Driver How-To
Preparation and Housekeeping
PDO Driver How-To


Preparation and Housekeeping

Source directory layout

The source directory for a typical PDO driver is laid out as follows, where SKEL represents a shortened form of the name of the database that the driver is going to connect to. Even though SKEL is presented here in uppercase (for clarity), the convention is to use lowercase characters.

pdo_SKEL/
  config.m4                  # unix build script
  config.w32                 # win32 build script
  CREDITS
  package.xml                # meta information about the package
  pdo_SKEL.c                 # standard PHP extension glue
  php_pdo_SKEL.h
  php_pdo_SKEL_int.h         # driver private header
  SKEL_dbh.c                 # contains the implementation of the PDO driver interface
  SKEL_stmt.c                # contains the implementation of the PDO statement interface
  tests/

The contents of these files are defined later in this document.

Creating a skeleton

The easiest way to get started is to use the ext_skel shell script found in the PHP build tree in the ext directory. This will build a skeleton directory containing a lot of the files listed above. It can be build by executing the following command from within the ext directory:

./ext_skel --extname=pdo_SKEL

This will generate a directory called pdo_SKEL containing the skeleton files that you can then modify. This directory should then be moved out of the php extension directory. PDO is a PECL extension and should not be included in the standard extension directory. As long as you have PHP and PDO installed, you should be able to build from any directory.

Standard Includes

Build Specific Headers

The header file config.h is generated by the configure process for the platform for the which the driver is being built. If this header is present, the HAVE_CONFIG_H compiler variable is set. This variable should be tested for and if set, the file config.h should be included in the compilation unit.

PHP Headers

The following standard public php headers should be included in each source module:

  1. php.h

  2. php_ini.h

  3. ext/standard/info.h

PDO Interface Headers

The following standard public PDO header files are also included in each source module:

pdo/php_pdo.h

This header file contains definitions of the initialization and shutdown functions in the main driver as well as definitions of global PDO variables.

pdo/php_pdo_driver.h

This header contains the types and API contracts that are used to write a PDO driver. It also contains method signature for calling back into the PDO layer and registering/unregistering your driver with PDO. Most importantly, this header file contains the type definitions for PDO database handles and statements. The two main structures a driver has to deal with, pdo_dbh_t and pdo_stmt_t, are described in more detail in Appendix A and B.

Driver Specific Headers

The typical PDO driver has two header files that are specific to the database implementation. This does not preclude the use of more depending on the implementation. The following two headers are, by convention, standard:

php_pdo_SKEL.h

This header file is virtually an exact duplicate in functionality and content of the previously defined pdo/php_pdo.h that has been specifically tailored for your database. If your driver requires the use of global variables they should be defined using the ZEND_BEGIN_MODULE_GLOBALS and ZEND_END_MODULE_GLOBALS macros. Macros are then used to access these variables. This macro is usually named PDO_SKEL_G(v) where v is global variable to be accessed. Consult the Zend programmer documentation for more information.

php_pdo_SKEL_int.h

This header file typically contains type definitions and function declarations specific to the driver implementation. It also should contain the db specific definitions of a pdo_SKEL_handle and pdo_SKEL_stmt structures. These are the names of the private data structures that are then referenced by the driver_data members of the handle and statement structures.

Optional Headers

Depending on the implementation details for a particular driver it may be necessary to include the following header:

#include <zend_exceptions.h>
Prerequisites
Fleshing out your skeleton
PDO Driver How-To


Fleshing out your skeleton

Major Structures and Attributes

The major structures, pdo_dbh_t and pdo_stmt_t are defined and explained in Appendix A and B respectively. Database and Statement attributes are defined in Appendix C. Error handling is explained in Appendix D.

pdo_SKEL.c: PHP extension glue

function entries

static function_entry pdo_SKEL_functions[] = {
  { NULL, NULL, NULL }
};

This structure is used to register functions into the global php function namespace. PDO drivers should try to avoid doing this, so it is recommended that you leave this structure initialized to NULL, as shown in the synopsis above.

Module entry

/* {{{ pdo_SKEL_module_entry */
#if ZEND_EXTENSION_API_NO >= 220050617
static zend_module_dep pdo_SKEL_deps[] = {
    ZEND_MOD_REQUIRED("pdo")
    {NULL, NULL, NULL}
};
#endif
/* }}} */

zend_module_entry pdo_SKEL_module_entry = {
#if ZEND_EXTENSION_API_NO >= 220050617
    STANDARD_MODULE_HEADER_EX, NULL,
    pdo_SKEL_deps,
#else
    STANDARD_MODULE_HEADER,
#endif
    "pdo_SKEL",
    pdo_SKEL_functions,
    PHP_MINIT(pdo_SKEL),
    PHP_MSHUTDOWN(pdo_SKEL),
    NULL,
    NULL,
    PHP_MINFO(pdo_SKEL),
    PHP_PDO_<DB>_MODULE_VERSION,
    STANDARD_MODULE_PROPERTIES
};
/* }}} */

#ifdef COMPILE_DL_PDO_<DB>
ZEND_GET_MODULE(pdo_db)
#endif

A structure of type zend_module_entry called pdo_SKEL_module_entry must be declared and should include reference to the pdo_SKEL_functions table defined previously.

Standard PHP Module Extension Functions

PHP_MINIT_FUNCTION
/* {{{ PHP_MINIT_FUNCTION */
PHP_MINIT_FUNCTION(pdo_SKEL)
{
    return php_pdo_register_driver(&pdo_SKEL_driver);
}
/* }}} */

This standard PHP extension function should be used to register your driver with the PDO layer. This is done by calling the php_pdo_register_driver() function passing a pointer to a structure of type pdo_driver_t typically named pdo_SKEL_driver. A pdo_driver_t contains a header that is generated using the PDO_DRIVER_HEADER(SKEL) macro and pdo_SKEL_handle_factory() function pointer. The actual function is described during the discussion of the SKEL_dbh.c unit.

PHP_MSHUTDOWN_FUNCTION
/* {{{ PHP_MSHUTDOWN_FUNCTION */
PHP_MSHUTDOWN_FUNCTION(pdo_SKEL)
{
    php_pdo_unregister_driver(&pdo_SKEL_driver);
    return SUCCESS;
}
/* }}} */

This standard PHP extension function is used to unregister your driver from the PDO layer. This is done by calling the php_pdo_unregister_driver() function, passing the same pdo_SKEL_driver structure that was passed in the init function above.

PHP_MINFO_FUNCTION

This is again a standard PHP extension function. Its purpose is to display information regarding the module when the phpinfo() is called from a script. The convention is to display the version of the module and also what version of the db you are dependent on, along with any other configuration style information that might be relevant.

SKEL_driver.c: Driver implementation

This unit implements all of the database handling methods that support the PDO database handle object. It also contains the error fetching routines. All of these functions will typically need to access the global variable pool. Therefore, it is necessary to use the Zend macro TSRMLS_DC macro at the end of each of these statements. Consult the Zend programmer documentation for more information on this macro.

pdo_SKEL_error

static int pdo_SKEL_error(pdo_dbh_t *dbh,
  pdo_stmt_t *stmt, const char *file, int line TSRMLS_DC)

The purpose of this function is to be used as a generic error handling function within the driver. It is called by the driver when an error occurs within the driver. If an error occurs that is not related to SQLSTATE, the driver should set either dbh->error_code or stmt->error_code to an SQLSTATE that most closely matches the error or the generic SQLSTATE error "HY000". The file pdo_sqlstate.c in the PDO source contains a table of commonly used SQLSTATE codes that the PDO code explicitly recognizes. This setting of the error code should be done prior to calling this function.; This function should set the global pdo_err variable to the error found in either the dbh or the stmt (if the variable stmt is not NULL).

dbh

Pointer to the database handle initialized by the handle factory

stmt

Pointer to the current statement or NULL. If NULL, the error is derived by error code found in the dbh.

file

The source file where the error occurred or NULL if not available.

line

The line number within the source file if available.

If the dbh member methods is NULL (which implies that the error is being raised from within the PDO constructor), this function should call the zend_throw_exception_ex() function otherwise it should return the error code. This function is usually called using a helper macro that customizes the calling sequence for either database handling errors or statement handling errors.

Örnek 1 Example macros for invoking pdo_SKEL_error

#define pdo_SKEL_drv_error(what) \
    pdo_SKEL_error(dbh, NULL, what, __FILE__, __LINE__ TSRMLS_CC)
#define pdo_SKEL_drv_error(what) \
    pdo_SKEL_error(dbh, NULL, what, __FILE__, __LINE__ TSRMLS_CC)

For more info on error handling, see Error handling.

Bilginize:

Despite being documented here, the PDO driver interface does not specify that this function be present; it is merely a convenient way to handle errors, and it just happens to be equally convenient for the majority of database client library APIs to structure your driver implementation in this way.

pdo_SKEL_fetch_error_func

static int pdo_SKEL_fetch_error_func(pdo_dbh_t *dbh, pdo_stmt_t *stmt,
    zval *info TSRMLS_DC)

The purpose of this function is to obtain additional information about the last error that was triggered. This includes the driver specific error code and a human readable string. It may also include additional information if appropriate. This function is called as a result of the PHP script calling the PDO::errorInfo() method.

dbh

Pointer to the database handle initialized by the handle factory

stmt

Pointer to the most current statement or NULL. If NULL, the error translated is derived by error code found in the dbh.

info

A hash table containing error codes and messages.

The error_func should return two pieces of information as successive array elements. The first item is expected to be a numeric error code, the second item is a descriptive string. The best way to set this item is by using add_next_index. Note that the type of the first argument need not be long; use whichever type most closely matches the error code returned by the underlying database API.

/* now add the error information. */
/* These need to be added in a specific order */
add_next_index_long(info, error_code);   /* driver specific error code */
add_next_index_string(info, message, 0); /* readable error message */

This function should return 1 if information is available, 0 if the driver does not have additional info.

SKEL_handle_closer

static int SKEL_handle_closer(pdo_dbh_t *dbh TSRMLS_DC)

This function will be called by PDO to close an open database.

dbh

Pointer to the database handle initialized by the handle factory

This should do whatever database specific activity that needs to be accomplished to close the open database. PDO ignores the return value from this function.

SKEL_handle_preparer

static int SKEL_handle_preparer(pdo_dbh_t *dbh, const char *sql,
long sql_len, pdo_stmt_t *stmt, zval *driver_options TSRMLS_DC)

This function will be called by PDO in response to PDO::query() and PDO::prepare() calls from the PHP script. The purpose of the function is to prepare raw SQL for execution, storing whatever state is appropriate into the stmt that is passed in.

dbh

Pointer to the database handle initialized by the handle factory

sql

Pointer to a character string containing the SQL statement to be prepared.

sql_len

The length of the SQL statement.

Stmt

Pointer to the returned statement or NULL if an error occurs.

driver_options

Any driver specific/defined options.

This function is essentially the constructor for a stmt object. This function is responsible for processing statement options, and setting driver-specific option fields in the pdo_stmt_t structure.

PDO does not process any statement options on the driver's behalf before calling the preparer function. It is your responsibility to process them before you return, raising an error for any unknown options that are passed.

One very important responsibility of this function is the processing of SQL statement parameters. At the time of this call, PDO does not know if your driver supports binding parameters into prepared statements, nor does it know if it supports named or positional parameter naming conventions.

Your driver is responsible for setting stmt->supports_placeholders as appropriate for the underlying database. This may involve some run-time determination on the part of your driver, if this setting depends on the version of the database server to which it is connected. If your driver doesn't directly support both named and positional parameter conventions, you should use the pdo_parse_params() API to have PDO rewrite the query to take advantage of the support provided by your database.

Örnek 2 Using pdo_parse_params

int ret;
    char *nsql = NULL;
    int nsql_len = 0;

    /* before we prepare, we need to peek at the query; if it uses named parameters,
     * we want PDO to rewrite them for us */
    stmt->supports_placeholders = PDO_PLACEHOLDER_POSITIONAL;
    ret = pdo_parse_params(stmt, (char*)sql, sql_len, &nsql, &nsql_len TSRMLS_CC);

    if (ret == 1) {
        /* query was re-written */
        sql = nsql;
    } else if (ret == -1) {
        /* couldn't grok it */
        strcpy(dbh->error_code, stmt->error_code);
        return 0;
    }

    /* now proceed to prepare the query in "sql" */

Possible values for supports_placeholders are: PDO_PLACEHOLDER_NAMED, PDO_PLACEHOLDER_POSITIONAL and PDO_PLACEHOLDER_NONE. If the driver doesn't support prepare statements at all, then this function should simply allocate any state that it might need, and then return:

Örnek 3 Implementing preparer for drivers that don't support native prepared statements

static int SKEL_handle_preparer(pdo_dbh_t *dbh, const char *sql,
    long sql_len, pdo_stmt_t *stmt, zval *driver_options TSRMLS_DC)
{
    pdo_SKEL_db_handle *H = (pdo_SKEL_db_handle *)dbh->driver_data;
    pdo_SKEL_stmt *S = ecalloc(1, sizeof(pdo_SKEL_stmt));

    S->H = H;
    stmt->driver_data = S;
    stmt->methods = &SKEL_stmt_methods;
    stmt->supports_placeholders = PDO_PLACEHOLDER_NONE;

    return 1;
}

This function returns 1 on success or 0 on failure.

SKEL_handle_doer

static long SKEL_handle_doer(pdo_dbh_t *dbh, const char *sql, long sql_len TSRMLS_DC)

This function will be called by PDO to execute a raw SQL statement. No pdo_stmt_t is created.

dbh

Pointer to the database handle initialized by the handle factory

sql

Pointer to a character string containing the SQL statement to be prepared.

sql_len

The length of the SQL statement.

This function returns 1 on success or 0 on failure.

SKEL_handle_quoter

static int SKEL_handle_quoter(pdo_dbh_t *dbh, const char *unquoted,
  int unquoted_len, char **quoted, int quoted_len, enum pdo_param_type param_type TSRMLS_DC)

This function will be called by PDO to turn an unquoted string into a quoted string for use in a query.

dbh

Pointer to the database handle initialized by the handle factory

unquoted

Pointer to a character string containing the string to be quoted.

unquoted_len

The length of the string to be quoted.

quoted

Pointer to the address where a pointer to the newly quoted string will be returned.

quoted_len

The length of the new string.

param_type

A driver specific hint for driver that have alternate quoting styles

This function is called in response to a call to PDO::quote() or when the driver has set supports_placeholder to PDO_PLACEHOLDER_NONE. The purpose is to quote a parameter when building SQL statements.

If your driver does not support native prepared statements, implementation of this function is required.

This function returns 1 if the quoting process reformatted the string, and 0 if it was not necessary to change the string. The original string will be used unchanged with a 0 return.

SKEL_handle_begin

static int SKEL_handle_begin(pdo_dbh_t *dbh TSRMLS_DC)

This function will be called by PDO to begin a database transaction.

dbh

Pointer to the database handle initialized by the handle factory

This should do whatever database specific activity that needs to be accomplished to begin a transaction. This function returns 1 for success or 0 if an error occurred.

SKEL_handle_commit

static int SKEL_handle_commit(pdo_dbh_t *dbh TSRMLS_DC)

This function will be called by PDO to end a database transaction.

dbh

Pointer to the database handle initialized by the handle factory

This should do whatever database specific activity that needs to be accomplished to commit a transaction. This function returns 1 for success or 0 if an error occurred.

SKEL_handle_rollback

static int SKEL_handle_rollback( pdo_dbh_t *dbh TSRMLS_DC)

This function will be called by PDO to rollback a database transaction.

dbh

Pointer to the database handle initialized by the handle factory

This should do whatever database specific activity that needs to be accomplished to rollback a transaction. This function returns 1 for success or 0 if an error occurred.

SKEL_handle_get_attribute

static int SKEL_handle_get_attribute(pdo_dbh_t *dbh, long attr, zval *return_value TSRMLS_DC)

This function will be called by PDO to retrieve a database attribute.

dbh

Pointer to the database handle initialized by the handle factory

attr

long value of one of the PDO_ATTR_xxxx types. See Database and Statement Attributes Table for valid attributes.

return_value

The returned value for the attribute.

It is up to the driver to decide which attributes will be supported for a particular implementation. It is not necessary for a driver to supply this function. PDO driver handles the PDO_ATTR_PERSISTENT, PDO_ATTR_CASE, PDO_ATTR_ORACLE_NULLS, and PDO_ATTR_ERRMODE attributes directly.

This function returns 1 on success or 0 on failure.

SKEL_handle_set_attribute

static int SKEL_handle_set_attribute(pdo_dbh_t *dbh, long attr, zval *val TSRMLS_DC)

This function will be called by PDO to set a database attribute, usually in response to a script calling PDO::setAttribute().

dbh

Pointer to the database handle initialized by the handle factory

attr

long value of one of the PDO_ATTR_xxxx types. See Database and Statement Attributes Table for valid attributes.

val

The new value for the attribute.

It is up to the driver to decide which attributes will be supported for a particular implementation. It is not necessary for a driver to provide this function if it does not need to support additional attributes. The PDO driver handles the PDO_ATTR_CASE, PDO_ATTR_ORACLE_NULLS, and PDO_ATTR_ERRMODE attributes directly.

This function returns 1 on success or 0 on failure.

SKEL_handle_last_id

static char * SKEL_handle_last_id(pdo_dbh_t *dbh, const char *name, unsigned int len TSRMLS_DC)

This function will be called by PDO to retrieve the ID of the last inserted row.

dbh

Pointer to the database handle initialized by the handle factory

name

string representing a table or sequence name.

len

the length of the name parameter.

This function returns a character string containing the id of the last inserted row on success or NULL on failure. This is an optional function.

SKEL_check_liveness

static int SKEL_check_liveness(pdo_dbh_t *dbh TSRMLS_DC)

This function will be called by PDO to test whether or not a persistent connection to a database is alive and ready for use.

dbh

Pointer to the database handle initialized by the handle factory

This function returns 1 if the database connection is alive and ready for use, otherwise it should return 0 to indicate failure or lack of support.

Bilginize:

This is an optional function.

SKEL_get_driver_methods

static function_entry *SKEL_get_driver_methods(pdo_dbh_t *dbh, int kind TSRMLS_DC)

This function will be called by PDO in response to a call to any method that is not a part of either the PDO or PDOStatement classes. It's purpose is to allow the driver to provide additional driver specific methods to those classes.

dbh

Pointer to the database handle initialized by the handle factory

kind

One of the following:

PDO_DBH_DRIVER_METHOD_KIND_DBH

Set when the method call was attempted on an instance of the PDO class. The driver should return a pointer a function_entry table for any methods it wants to add to that class, or NULL if there are none.

PDO_DBH_DRIVER_METHOD_KIND_STMT

Set when the method call was attempted on an instance of the PDOStatement class. The driver should return a pointer to a function_entry table for any methods it wants to add to that class, or NULL if there are none.

This function returns a pointer to the function_entry table requested, or NULL there are no driver specific methods.

SKEL_handle_factory

static int SKEL_handle_factory(pdo_dbh_t *dbh, zval *driver_options TSRMLS_DC)

This function will be called by PDO to create a database handle. For most databases this involves establishing a connection to the database. In some cases, a persistent connection may be requested, in other cases connection pooling may be requested. All of these are database/driver dependent.

dbh

Pointer to the database handle initialized by the handle factory

driver_options

An array of driver options, keyed by integer option number. See Database and Statement Attributes Table for a list of possible attributes.

This function should fill in the passed database handle structure with its driver specific information on success and return 1, otherwise it should return 0 to indicate failure.

PDO processes the AUTOCOMMIT and PERSISTENT driver options before calling the handle_factory. It is the handle factory's responsibility to process other options.

Driver method table

A static structure of type pdo_dbh_methods named SKEL_methods must be declared and initialized to the function pointers for each defined function. If a function is not supported or not implemented the value for that function pointer should be set to NULL.

pdo_SKEL_driver

A structure of type pdo_driver_t named pdo_SKEL_driver should be declared. The PDO_DRIVER_HEADER(SKEL) macro should be used to declare the header and the function pointer to the handle factory function should set.

SKEL_statement.c: Statement implementation

This unit implements all of the database statement handling methods that support the PDO statement object.

SKEL_stmt_dtor

static int SKEL_stmt_dtor(pdo_stmt_t *stmt TSRMLS_DC)

This function will be called by PDO to destroy a previously constructed statement object.

stmt

Pointer to the statement structure initialized by SKEL_handle_preparer.

This should do whatever is necessary to free up any driver specific storage allocated for the statement. The return value from this function is ignored.

SKEL_stmt_execute

static int SKEL_stmt_execute(pdo_stmt_t *stmt TSRMLS_DC)

This function will be called by PDO to execute the prepared SQL statement in the passed statement object.

stmt

Pointer to the statement structure initialized by SKEL_handle_preparer.

This function returns 1 for success or 0 in the event of failure.

SKEL_stmt_fetch

static int SKEL_stmt_fetch(pdo_stmt_t *stmt, enum pdo_fetch_orientation ori,
   long offset TSRMLS_DC)

This function will be called by PDO to fetch a row from a previously executed statement object.

stmt

Pointer to the statement structure initialized by SKEL_handle_preparer.

ori

One of PDO_FETCH_ORI_xxx which will determine which row will be fetched.

offset

If ori is set to PDO_FETCH_ORI_ABS or PDO_FETCH_ORI_REL, offset represents the row desired or the row relative to the current position, respectively. Otherwise, this value is ignored.

The results of this fetch are driver dependent and the data is usually stored in the driver_data member of the pdo_stmt_t object. The ori and offset parameters are only meaningful if the statement represents a scrollable cursor. This function returns 1 for success or 0 in the event of failure.

SKEL_stmt_param_hook

static int SKEL_stmt_param_hook(pdo_stmt_t *stmt,
  struct pdo_bound_param_data *param, enum pdo_param_event event_type TSRMLS_DC)

This function will be called by PDO for handling of both bound parameters and bound columns.

stmt

Pointer to the statement structure initialized by SKEL_handle_preparer.

param

The structure describing either a statement parameter or a bound column.

event_type

The type of event to occur for this parameter, one of the following:

PDO_PARAM_EVT_ALLOC

Called when PDO allocates the binding. Occurs as part of PDOStatement::bindParam(), PDOStatement::bindValue() or as part of an implicit bind when calling PDOStatement::execute(). This is your opportunity to take some action at this point; drivers that implement native prepared statements will typically want to query the parameter information, reconcile the type with that requested by the script, allocate an appropriately sized buffer and then bind the parameter to that buffer. You should not rely on the type or value of the zval at param->parameter at this point in time.

PDO_PARAM_EVT_FREE

Called once per parameter as part of cleanup. You should release any resources associated with that parameter now.

PDO_PARAM_EXEC_PRE

Called once for each parameter immediately before calling SKEL_stmt_execute; take this opportunity to make any final adjustments ready for execution. In particular, you should note that variables bound via PDOStatement::bindParam() are only legal to touch now, and not any sooner.

PDO_PARAM_EXEC_POST

Called once for each parameter immediately after calling SKEL_stmt_execute; take this opportunity to make any post-execution actions that might be required by your driver.

PDO_PARAM_FETCH_PRE

Called once for each parameter immediately prior to calling SKEL_stmt_fetch.

PDO_PARAM_FETCH_POST

Called once for each parameter immediately after calling SKEL_stmt_fetch.

This hook will be called for each bound parameter and bound column in the statement. For ALLOC and FREE events, a single call will be made for each parameter or column. The param structure contains a driver_data field that the driver can use to store implementation specific information about each of the parameters.

For all other events, PDO may call you multiple times as the script issues PDOStatement::execute() and PDOStatement::fetch() calls.

If this is a bound parameter, the is_param flag in the param structure is set, otherwise the param structure refers to a bound column.

This function returns 1 for success or 0 in the event of failure.

SKEL_stmt_describe_col

static int SKEL_stmt_describe_col(pdo_stmt_t *stmt, int colno TSRMLS_DC)

This function will be called by PDO to query information about a particular column.

stmt

Pointer to the statement structure initialized by SKEL_handle_preparer.

colno

The column number to be queried.

The driver should populate the pdo_stmt_t member columns(colno) with the appropriate information. This function returns 1 for success or 0 in the event of failure.

SKEL_stmt_get_col_data

static int SKEL_stmt_get_col_data(pdo_stmt_t *stmt, int colno,
  char **ptr, unsigned long *len, int *caller_frees TSRMLS_DC)

This function will be called by PDO to retrieve data from the specified column.

stmt

Pointer to the statement structure initialized by SKEL_handle_preparer.

colno

The column number to be queried.

ptr

Pointer to the retrieved data.

len

The length of the data pointed to by ptr.

caller_frees

If set, ptr should point to emalloc'd memory and the main PDO driver will free it as soon as it is done with it. Otherwise, it will be the responsibility of the driver to free any allocated memory as a result of this call.

The driver should return the resultant data and length of that data in the ptr and len variables respectively. It should be noted that the main PDO driver expects the driver to manage the lifetime of the data. This function returns 1 for success or 0 in the event of failure.

SKEL_stmt_set_attr

static int SKEL_stmt_set_attr(pdo_stmt_t *stmt, long attr, zval *val TSRMLS_DC)

This function will be called by PDO to allow the setting of driver specific attributes for a statement object.

stmt

Pointer to the statement structure initialized by SKEL_handle_preparer.

attr

long value of one of the PDO_ATTR_xxxx types. See Database and Statement Attributes Table for valid attributes.

val

The new value for the attribute.

This function is driver dependent and allows the driver the capability to set database specific attributes for a statement. This function returns 1 for success or 0 in the event of failure. This is an optional function. If the driver does not support additional settable attributes, it can be NULLed in the method table. The PDO driver does not handle any settable attributes on the database driver's behalf.

SKEL_stmt_get_attr

static int SKEL_stmt_get_attr(pdo_stmt_t *stmt, long attr, zval
   *return_value TSRMLS_DC)

This function will be called by PDO to allow the retrieval of driver specific attributes for a statement object.

stmt

Pointer to the statement structure initialized by SKEL_handle_preparer.

attr

long value of one of the PDO_ATTR_xxxx types. See Database and Statement Attributes Table for valid attributes.

return_value

The returned value for the attribute.

This function is driver dependent and allows the driver the capability to retrieve a previously set database specific attribute for a statement. This function returns 1 for success or 0 in the event of failure. This is an optional function. If the driver does not support additional gettable attributes, it can be NULLed in the method table. The PDO driver does not handle any settable attributes on the database driver's behalf.

SKEL_stmt_get_col_meta

static int SKEL_stmt_get_col_meta(pdo_stmt_t *stmt, int colno,
   zval *return_value TSRMLS_DC)
Uyarı

This function is not well defined and is subject to change.

This function will be called by PDO to retrieve meta data from the specified column.

stmt

Pointer to the statement structure initialized by SKEL_handle_preparer.

colno

The column number for which data is to be retrieved.

return_value

Holds the returned meta data.

The driver author should consult the documentation for this function that can be found in the php_pdo_driver.h header as this will be the most current. This function returns 1 for success or 0 in the event of failure. The database driver does not need to provide this function.

Statement handling method table

A static structure of type pdo_stmt_methods named SKEL_stmt_methods should be declared and initialized to the function pointers for each defined function. If a function is not supported or not implemented the value for that function pointer should be set to NULL.

Preparation and Housekeeping
Building
PDO Driver How-To


Building

The build process is designed to work with PEAR (see » http://pear.php.net/ for more information about PEAR). There are two files that are used to assist in configuring your package for building. The first is config.m4 which is the autoconf configuration file for all platforms except Win32. The second is config.w32 which is a build configuration file for use on Win32. Skeleton files for these are built for you when you first set up your project. You then need to customize them to fit the needs of your project. Once you've customized your config files, you can build your driver using the following sequence of commands:

Before first build:

$ sudo pecl install PDO

For each build:

$ cd pdo_SKEL
$ phpize
$ ./configure
$ make
$ sudo make install

The process can then be repeated as necessary during the development process.

Fleshing out your skeleton
Testing
PDO Driver How-To


Testing

PDO has a set of "core" tests that all drivers should pass before being released. They're designed to run from the PHP source distribution, so running the tests for your driver requires moving things around a bit. The suggested procedure is to obtain the latest PHP 5.1 snapshot and perform the following step:

$ cp -r pdo_SKEL /path/to/php-5.1/ext

This will allow the test harness to run your tests. The next thing you need to do is create a test that will redirect into the PDO common core tests. The convention is to name this file common.phpt; it should be placed in the tests subdirectory that was created by ext_skel when you created your extension skeleton. The content of this file should look something like the following:

--TEST--
SKEL
--SKIPIF--
<?php # vim:ft=php
if (!extension_loaded('pdo_SKEL')) print 'skip'; ?>
--REDIRECTTEST--
if (false !== getenv('PDO_SKEL_TEST_DSN')) {
# user set them from their shell
   $config['ENV']['PDOTEST_DSN'] = getenv('PDO_SKEL_TEST_DSN');
   $config['ENV']['PDOTEST_USER'] = getenv('PDO_SKEL_TEST_USER');
   $config['ENV']['PDOTEST_PASS'] = getenv('PDO_SKEL_TEST_PASS');
   if (false !== getenv('PDO_SKEL_TEST_ATTR')) {
      $config['ENV']['PDOTEST_ATTR'] = getenv('PDO_SKEL_TEST_ATTR');
   }
   return $config;
}
return array(
   'ENV' => array(
           'PDOTEST_DSN' => 'SKEL:dsn',
           'PDOTEST_USER' => 'username',
           'PDOTEST_PASS' => 'password'
       ),
   'TESTS' => 'ext/pdo/tests'
   );

This will cause the common core tests to be run, passing the values of PDOTEST_DSN, PDOTEST_USER and PDOTEST_PASS to the PDO constructor as the dsn, username and password parameters. It will first check the environment, so that appropriate values can be passed in when the test harness is run, rather than hard-coding the database credentials into the test file.

The test harness can be invoked as follows:

$ cd /path/to/php-5.1
$ make TESTS=ext/pdo_SKEL/tests PDO_SKEL_TEST_DSN="skel:dsn" \
 PDO_SKEL_TEST_USER=user PDO_SKEL_TEST_PASS=pass test
Building
Packaging and distribution
PDO Driver How-To


Packaging and distribution

Creating a package

PDO drivers are released via PECL; all the usual rules for PECL extensions apply. Packaging is accomplished by creating a valid package.xml file and then running:

$ pecl package

This will create a tarball named PDO_SKEL-X.Y.Z.tgz.

Before releasing the package, you should test that it builds correctly; if you've made a mistake in your config.m4 or package.xml files, the package may not function correctly. You can test the build, without installing anything, using the following invocation:

$ pecl build package.xml

Once this is proven to work, you can test installation:

$ pecl package
$ sudo pecl install PDO_SKEL-X.Y.X.tgz

Full details about package.xml can be found in the PEAR Programmer's documentation (» http://pear.php.net/manual/).

Releasing the package

A PDO driver is released via the PHP Extension Community Library (PECL). Information about PECL can be found at » http://pecl.php.net/.

Testing
pdo_dbh_t definition
PDO Driver How-To


pdo_dbh_t definition

All fields should be treated as read-only by the driver, unless explicitly stated otherwise.

pdo_dbh_t

/* represents a connection to a database */
struct _pdo_dbh_t {
    /* driver specific methods */
    struct pdo_dbh_methods *methods;
*
/* driver specific data */
    void *driver_data;
**
/* credentials */
    char *username, *password;
***
/* if true, then data stored and pointed at by this handle must all be
     * persistently allocated */
    unsigned is_persistent:1;
****
/* if true, driver should act as though a COMMIT were executed between
     * each executed statement; otherwise, COMMIT must be carried out manually
     * */
    unsigned auto_commit:1;
*****
/* if true, the driver requires that memory be allocated explicitly for
     * the columns that are returned */
    unsigned alloc_own_columns:1;
******
/* if true, commit or rollBack is allowed to be called */
    unsigned in_txn:1;

    /* max length a single character can become after correct quoting */
    unsigned max_escaped_char_length:3;
*******
/* data source string used to open this handle */
    const char *data_source;
********
unsigned long data_source_len;

    /* the global error code. */
    pdo_error_type error_code;
*********
enum pdo_case_conversion native_case
**********
, desired_case;
};
*

The driver must set this during SKEL_handle_factory().

**

This item is for use by the driver; the intended usage is to store a pointer (during SKEL_handle_factory()) to whatever instance data is required to maintain a connection to the database.

***

The username and password that were passed into the PDO constructor. The driver should use these values when it initiates a connection to the database.

****

If this is set to 1, then any data that is referenced by the dbh, including whatever structure your driver allocates, MUST be allocated persistently. This is easy to achieve; rather than using the usual emalloc() simply use pemalloc() and pass the value of this flag as the last parameter. Failure to use the appropriate kind of memory can lead to serious memory faults, resulting (in the best case) a hard crash, and in the worst case, an exploitable memory problem.

If, for whatever reason, your driver is not suitable to run persistently, you MUST check this flag in your SKEL_handle_factory() and raise an appropriate error.

*****

You should check this value in your SKEL_handle_doer() and SKEL_stmt_execute() functions; if it evaluates to true, you must attempt to commit the query now. Most database implementations offer an auto-commit mode that handles this automatically.

******

If your database client library API operates by fetching data into a caller-supplied buffer, you should set this flag to 1 during your SKEL_handle_factory(). When set, PDO will call your SKEL_stmt_describer() earlier than it would otherwise. This early call allows you to determine those buffer sizes and issue appropriate calls to the database client library.

If your database client library API simply returns pointers to its own internal buffers for you to copy after each fetch call, you should leave this value set to 0.

*******

If your driver doesn't support native prepared statements (supports_placeholders is set to PDO_PLACEHOLDER_NONE), you must set this value to the maximum length that can be taken up by a single character when it is quoted by your SKEL_handle_quoter() function. This value is used to calculate the amount of buffer space required when PDO executes the statement.

********

This holds the value of the DSN that was passed into the PDO constructor. If your driver implementation needed to modify the DSN for whatever reason, it should update this member during SKEL_handle_factory(). Modifying this member should be avoided. If you do change it, you must ensure that data_source_len is also correct.

*********

Whenever an error occurs during a call to one of your driver methods, you should set this member to the SQLSTATE code that best describes the error and return an error. In this HOW-TO, the suggested practice is to call SKEL_handle_error() when an error is detected, and have it set the error code.

**********

Your driver should set this during SKEL_handle_factory(); the value should reflect how the database returns the names of the columns in result sets. If the name matches the case that was used in the query, set it to PDO_CASE_NATURAL (this is actually the default). If the column names are always returned in upper case, set it to PDO_CASE_UPPER. If the column names are always returned in lower case, set it to PDO_CASE_LOWER. The value you set is used to determine if PDO should perform case folding when the user sets the PDO_ATTR_CASE attribute.

Packaging and distribution
pdo_stmt_t definition
PDO Driver How-To


pdo_stmt_t definition

All fields should be treated as read-only unless explicitly stated otherwise.

pdo_stmt_t

/* represents a prepared statement */
struct _pdo_stmt_t {
    /* driver specifics */
    struct pdo_stmt_methods *methods;
*
void *driver_data;
**
/* if true, we've already successfully executed this statement at least
     * once */
    unsigned executed:1;
***
/* if true, the statement supports placeholders and can implement
     * bindParam() for its prepared statements, if false, PDO should
     * emulate prepare and bind on its behalf */
    unsigned supports_placeholders:2;
****
/* the number of columns in the result set; not valid until after
     * the statement has been executed at least once.  In some cases, might
     * not be valid until fetch (at the driver level) has been called at least once.
     * */
    int column_count;
*****
struct pdo_column_data *columns;
******
/* points at the dbh that this statement was prepared on */
    pdo_dbh_t *dbh;

    /* keep track of bound input parameters.  Some drivers support
     * input/output parameters, but you can't rely on that working */
    HashTable *bound_params;
    /* When rewriting from named to positional, this maps positions to names */
    HashTable *bound_param_map;
    /* keep track of PHP variables bound to named (or positional) columns
     * in the result set */
    HashTable *bound_columns;

    /* not always meaningful */
    long row_count;

    /* used to hold the statement's current query */
    char *query_string;
    int query_stringlen;

    /* the copy of the query with expanded binds ONLY for emulated-prepare drivers */
    char *active_query_string;
    int active_query_stringlen;

    /* the cursor specific error code. */
    pdo_error_type error_code;

    /* used by the query parser for driver specific
     * parameter naming (see pgsql driver for example) */
    const char *named_rewrite_template;
};
* | The driver must set this during SKEL_handle_preparer().
** | This item is for use by the driver; the intended usage is to store a pointer (during SKEL_handle_factory()) to whatever instance data is required to maintain a connection to the database.
*** | This is set by PDO after the statement has been executed for the first time. Your driver can inspect this value to determine if it can skip one-time actions as an optimization.
**** | Discussed in more detail in SKEL_handle_preparer.
***** | Your driver is responsible for setting this field to the number of columns available in a result set. This is usually set during SKEL_stmt_execute() but with some database implementations, the column count may not be available until SKEL_stmt_fetch() has been called at least once. Drivers that implement SKEL_stmt_next_rowset() should update the column count when a new rowset is available.
****** | PDO will allocate this field based on the value that you set for the column count. You are responsible for populating each column during SKEL_stmt_describe(). You must set the precision, maxlen, name, namelen and param_type members for each column. The name is expected to be allocated using emalloc(); PDO will call efree() at the appropriate time.
pdo_dbh_t definition
Constants
PDO Driver How-To


Constants

Database and Statement Attributes Table

Attribute

Valid value(s)

PDO_ATTR_AUTOCOMMIT

BOOL

TRUE if autocommit is set, FALSE otherwise.

dbh->auto_commit contains value. Processed by PDO directly.

PDO_ATTR_PREFETCH

LONG

Value of the prefetch size in drivers that support it.

PDO_ATTR_TIMEOUT

LONG

How long to wait for a db operation before timing out.

PDO_ATTR_ERRMODE

LONG

Processed and handled by PDO

PDO_ATTR_SERVER_VERSION

STRING

The "human-readable" string representing the Server/Version this driver is currently connected to.

PDO_ATTR_CLIENT_VERSION

STRING

The "human-readable" string representing the Client/Version this driver supports.

PDO_ATTR_SERVER_INFO

STRING

The "human-readable" description of the Server.

PDO_ATTR_CONNECTION_STATUS

LONG

Values not yet defined

PDO_ATTR_CASE

LONG

Processed and handled by PDO.

PDO_ATTR_CURSOR_NAME

STRING

String representing the name for a database cursor for use in "where current in <name>" SQL statements.

PDO_ATTR_CURSOR

LONG

PDO_CURSOR_FWDONLY

Forward only cursor

PDO_CURSOR_SCROLL

Scrollable cursor

The values for the attributes above are all defined in terms of the Zend API. The Zend API contains macros that can be used to convert a *zval to a value. These macros are defined in the Zend header file, zend_API.h in the Zend directory of your PHP build directory. Some of these attributes can be used with the statement attribute handlers such as the PDO_ATTR_CURSOR and PDO_ATTR_CURSOR_NAME. See the statement attribute handling functions for more information.

pdo_stmt_t definition
Error handling
PDO Driver How-To


Error handling

Error handling is implemented using a hand-shaking protocol between PDO and the database driver code. The database driver code signals PDO that an error has occurred via a failure (0) return from any of the interface functions. If a zero is returned, set the field error_code in the control block appropriate to the context (either the pdo_dbh_t or pdo_stmt_t block). In practice, it is probably a good idea to set the field in both blocks to the same value to ensure the correct one is getting used.

The error_mode field is a six-byte field containing a 5 character ASCIIZ SQLSTATE identifier code. This code drives the error message process. The SQLSTATE code is used to look up an error message in the internal PDO error message table (see pdo_sqlstate.c for a list of error codes and their messages). If the code is not known to PDO, a default "Unknown Message" value will be used.

In addition to the SQLSTATE code and error message, PDO will call the driver-specific fetch_err() routine to obtain supplemental data for the particular error condition. This routine is passed an array into which the driver may place additional information. This array has slot positions assigned to particular types of supplemental info:

  1. A native error code. This will frequently be an error code obtained from the database API.

  2. A descriptive string. This string can contain any additional information related to the failure. Database drivers typically include information such as an error message, code location of the failure, and any additional descriptive information the driver developer feels worthy of inclusion. It is generally a good idea to include all diagnostic information obtainable from the database interface at the time of the failure. For driver-detected errors (such as memory allocation problems), the driver developer can define whatever error information that seems appropriate.

Constants
Eklentilerin SSS'leri
PDO Driver How-To


Eklentilerin SSS'leri

Error handling
Zend Motoru 2 Başvuru Kılavuzu
PHP’nin Çekirdeği; Çekirdek geliştiricilerin Rehberi


Zend Motoru 2 Başvuru Kılavuzu

Eklentilerin SSS'leri
Zend Engine 2 Opcodes
PHP’nin Çekirdeği; Çekirdek geliştiricilerin Rehberi


Zend Engine 2 Opcodes

İçindekiler

  • Opcode Descriptions and Examples

When parsing PHP files, Zend Engine 2 generates a series of operation codes, commonly known as "opcodes", representing the function of the code. This part of the manual details those opcodes and their behaviour.

Opcodes may be dumped for a given PHP file using the vld extension (see » http://pecl.php.net/package/vld).

Opcode List
Number | Name | Has sample code?
0 | NOP | yes
1 | ADD | yes
2 | SUB | yes
3 | MUL | yes
4 | DIV | yes
5 | MOD | yes
6 | SL | yes
7 | SR | yes
8 | CONCAT | yes
9 | BW_OR | yes
10 | BW_AND | yes
11 | BW_XOR | yes
12 | BW_NOT | yes
13 | BOOL_NOT | yes
14 | BOOL_XOR | yes
15 | IS_IDENTICAL | yes
16 | IS_NOT_IDENTICAL | yes
17 | IS_EQUAL | yes
18 | IS_NOT_EQUAL | yes
19 | IS_SMALLER | yes
20 | IS_SMALLER_OR_EQUAL | yes
21 | CAST | yes
22 | QM_ASSIGN | yes
23 | ASSIGN_ADD | yes
24 | ASSIGN_SUB | yes
25 | ASSIGN_MUL | yes
26 | ASSIGN_DIV | yes
27 | ASSIGN_MOD | yes
28 | ASSIGN_SL | yes
29 | ASSIGN_SR | yes
30 | ASSIGN_CONCAT | yes
31 | ASSIGN_BW_OR | yes
32 | ASSIGN_BW_AND | yes
33 | ASSIGN_BW_XOR | yes
34 | PRE_INC | yes
35 | PRE_DEC | yes
36 | POST_INC | yes
37 | POST_DEC | yes
38 | ASSIGN | yes
39 | ASSIGN_REF | yes
40 | ECHO | yes
41 | PRINT | yes
42 | JMP | yes
43 | JMPZ | yes
44 | JMPNZ | yes
45 | JMPZNZ | yes
46 | JMPZ_EX | yes
47 | JMPNZ_EX | yes
48 | CASE | yes
49 | SWITCH_FREE | yes
50 | BRK | yes
51 | CONT | yes
52 | BOOL | yes
53 | INIT_STRING | yes
54 | ADD_CHAR | yes
55 | ADD_STRING | yes
56 | ADD_VAR | yes
57 | BEGIN_SILENCE | yes
58 | END_SILENCE | yes
59 | INIT_FCALL_BY_NAME | yes
60 | DO_FCALL | yes
61 | DO_FCALL_BY_NAME | yes
62 | RETURN | yes
63 | RECV | yes
64 | RECV_INIT | yes
65 | SEND_VAL | yes
66 | SEND_VAR | yes
67 | SEND_REF | yes
68 | NEW | yes
69 | INIT_NS_FCALL_BY_NAME | no
70 | FREE | yes
71 | INIT_ARRAY | yes
72 | ADD_ARRAY_ELEMENT | yes
73 | INCLUDE_OR_EVAL | yes
74 | UNSET_VAR | yes
75 | UNSET_DIM | yes
76 | UNSET_OBJ | yes
77 | FE_RESET | yes
78 | FE_FETCH | yes
79 | EXIT | yes
80 | FETCH_R | yes
81 | FETCH_DIM_R | yes
82 | FETCH_OBJ_R | yes
83 | FETCH_W | yes
84 | FETCH_DIM_W | yes
85 | FETCH_OBJ_W | yes
86 | FETCH_RW | yes
87 | FETCH_DIM_RW | yes
88 | FETCH_OBJ_RW | yes
89 | FETCH_IS | yes
90 | FETCH_DIM_IS | no
91 | FETCH_OBJ_IS | no
92 | FETCH_FUNC_ARG | yes
93 | FETCH_DIM_FUNC_ARG | yes
94 | FETCH_OBJ_FUNC_ARG | yes
95 | FETCH_UNSET | no
96 | FETCH_DIM_UNSET | no
97 | FETCH_OBJ_UNSET | no
98 | FETCH_DIM_TMP_VAR | yes
99 | FETCH_CONSTANT | yes
100 | GOTO | no
101 | EXT_STMT | yes
102 | EXT_FCALL_BEGIN | no
103 | EXT_FCALL_END | no
104 | EXT_NOP | no
105 | TICKS | yes
106 | SEND_VAR_NO_REF | no
107 | CATCH | yes
108 | THROW | yes
109 | FETCH_CLASS | yes
110 | CLONE | yes
111 | RETURN_BY_REF | no
112 | INIT_METHOD_CALL | yes
113 | INIT_STATIC_METHOD_CALL | yes
114 | ISSET_ISEMPTY_VAR | yes
115 | ISSET_ISEMPTY_DIM_OBJ | yes
116 | not documented | no
117 | not documented | no
118 | not documented | no
119 | not documented | no
120 | not documented | no
121 | not documented | no
122 | not documented | no
123 | not documented | no
124 | not documented | no
125 | not documented | no
126 | not documented | no
127 | not documented | no
128 | not documented | no
129 | not documented | no
130 | not documented | no
131 | not documented | no
132 | PRE_INC_OBJ | yes
133 | PRE_DEC_OBJ | yes
134 | POST_INC_OBJ | yes
135 | POST_DEC_OBJ | yes
136 | ASSIGN_OBJ | yes
137 | not documented | no
138 | INSTANCEOF | yes
139 | DECLARE_CLASS | yes
140 | DECLARE_INHERITED_CLASS | yes
141 | DECLARE_FUNCTION | yes
142 | RAISE_ABSTRACT_ERROR | yes
143 | DECLARE_CONST | no
144 | ADD_INTERFACE | no
145 | DECLARE_INHERITED_CLASS_DELAYED | no
146 | VERIFY_ABSTRACT_CLASS | no
147 | ASSIGN_DIM | yes
148 | ISSET_ISEMPTY_PROP_OBJ | yes
149 | HANDLE_EXCEPTION | yes
150 | USER_OPCODE | no
152 | ZEND_JMP_SET | no
153 | ZEND_DECLARE_LAMBDA_FUNCTION | no
154 | ZEND_ADD_TRAIT | no
155 | ZEND_BIND_TRAITS | no
156 | ZEND_SEPARATE | no
157 | ZEND_FETCH_CLASS_NAME | no
158 | ZEND_CALL_TRAMPOLINE | no
159 | ZEND_DISCARD_EXCEPTION | no
160 | ZEND_YIELD | no
161 | ZEND_GENERATOR_RETURN | no
162 | ZEND_FAST_CALL | no
163 | ZEND_FAST_RET | no
164 | ZEND_RECV_VARIADIC | no
165 | ZEND_SEND_UNPACK | no
166 | ZEND_POW | no
167 | ZEND_ASSIGN_POW | no
168 | ZEND_BIND_GLOBAL | no
169 | ZEND_COALESCE | no
170 | ZEND_SPACESHIP | no
171 | ZEND_DECLARE_ANON_CLASS | no
172 | ZEND_DECLARE_ANON_INHERITED_CLASS | no
Zend Motoru 2 Başvuru Kılavuzu
Opcode Descriptions and Examples
PHP’nin Çekirdeği; Çekirdek geliştiricilerin Rehberi


Opcode Descriptions and Examples

İçindekiler

  • ADD
  • ADD_ARRAY_ELEMENT
  • ADD_CHAR
  • ADD_INTERFACE
  • ADD_STRING
  • ADD_VAR
  • ASSIGN
  • ASSIGN_ADD
  • ASSIGN_BW_AND
  • ASSIGN_BW_OR
  • ASSIGN_BW_XOR
  • ASSIGN_CONCAT
  • ASSIGN_DIM
  • ASSIGN_DIV
  • ASSIGN_MOD
  • ASSIGN_MUL
  • ASSIGN_OBJ
  • ASSIGN_REF
  • ASSIGN_SL
  • ASSIGN_SR
  • ASSIGN_SUB
  • BEGIN_SILENCE
  • BOOL
  • BOOL_NOT
  • BOOL_XOR
  • BRK
  • BW_AND
  • BW_NOT
  • BW_OR
  • BW_XOR
  • CASE
  • CAST
  • CATCH
  • CLONE
  • CONCAT
  • CONT
  • DECLARE_CLASS
  • DECLARE_CONST
  • DECLARE_FUNCTION
  • DECLARE_INHERITED_CLASS
  • DECLARE_INHERITED_CLASS_DELAYED
  • DIV
  • DO_FCALL
  • DO_FCALL_BY_NAME
  • ECHO
  • END_SILENCE
  • EXIT
  • EXT_FCALL_BEGIN
  • EXT_FCALL_END
  • EXT_NOP
  • EXT_STMT
  • FE_FETCH
  • FE_RESET
  • FETCH_CLASS
  • FETCH_CONSTANT
  • FETCH_DIM_FUNC_ARG
  • FETCH_DIM_IS
  • FETCH_DIM_R
  • FETCH_DIM_RW
  • FETCH_DIM_TMP_VAR
  • FETCH_DIM_UNSET
  • FETCH_DIM_W
  • FETCH_FUNC_ARG
  • FETCH_IS
  • FETCH_OBJ_FUNC_ARG
  • FETCH_OBJ_IS
  • FETCH_OBJ_R
  • FETCH_OBJ_RW
  • FETCH_OBJ_UNSET
  • FETCH_OBJ_W
  • FETCH_R
  • FETCH_RW
  • FETCH_UNSET
  • FETCH_W
  • FREE
  • GOTO
  • HANDLE_EXCEPTION
  • INCLUDE_OR_EVAL
  • INIT_ARRAY
  • INIT_FCALL_BY_NAME
  • INIT_METHOD_CALL
  • INIT_NS_FCALL_BY_NAME
  • INIT_STATIC_METHOD_CALL
  • INIT_STRING
  • INSTANCEOF
  • IS_EQUAL
  • IS_IDENTICAL
  • IS_NOT_EQUAL
  • IS_NOT_IDENTICAL
  • IS_SMALLER
  • IS_SMALLER_OR_EQUAL
  • ISSET_ISEMPTY_DIM_OBJ
  • ISSET_ISEMPTY_PROP_OBJ
  • ISSET_ISEMPTY_VAR
  • JMP
  • JMPNZ
  • JMPNZ_EX
  • JMPZ
  • JMPZ_EX
  • JMPZNZ
  • MOD
  • MUL
  • NEW
  • NOP
  • POST_DEC
  • POST_DEC_OBJ
  • POST_INC
  • POST_INC_OBJ
  • PRE_DEC
  • PRE_DEC_OBJ
  • PRE_INC
  • PRE_INC_OBJ
  • PRINT
  • QM_ASSIGN
  • RAISE_ABSTRACT_ERROR
  • RECV
  • RECV_INIT
  • RETURN
  • RETURN_BY_REF
  • SEND_REF
  • SEND_VAL
  • SEND_VAR
  • SEND_VAR_NO_REF
  • SL
  • SR
  • SUB
  • SWITCH_FREE
  • THROW
  • TICKS
  • UNSET_DIM
  • UNSET_OBJ
  • UNSET_VAR
  • USER_OPCODE
  • VERIFY_ABSTRACT_CLASS
  • ZEND_DECLARE_LAMBDA_FUNCTION
  • ZEND_JMP_SET
Zend Engine 2 Opcodes
ADD
Zend Engine 2 Opcodes


ADD

PHP code

<?php
/*
 * Adds "value1" to "value2" and stores the result into "result".
 * opcode number: 1
 */
echo 1 + 2;
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | ADD |  |  | ~0 | 1,2
 | 1 | ECHO |  |  |  | ~0
7 | 2 | RETURN |  |  |  | 1
Opcode Descriptions and Examples
ADD_ARRAY_ELEMENT
Opcode Descriptions and Examples


ADD_ARRAY_ELEMENT

PHP code

<?php
/*
 * Add elem-value as an element to array-value
 * opcode number: 72
 */
$a = array(1,2,3);
print_r($a);
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$a

line | # | op | fetch | ext | return | operands
6 | 0 | INIT_ARRAY |  |  | ~0 | 1
 | 1 | ADD_ARRAY_ELEMENT |  |  | ~0 | 2
 | 2 | ADD_ARRAY_ELEMENT |  |  | ~0 | 3
 | 3 | ASSIGN |  |  |  | !0,~0
7 | 4 | SEND_VAR |  |  |  | !0
 | 5 | DO_FCALL |  | 1 |  | 'print_r'
8 | 6 | RETURN |  |  |  | 1
ADD
ADD_CHAR
Opcode Descriptions and Examples


ADD_CHAR

PHP code

<?php
/*
 * add regular characters in encapsed string
 * opcode number: 54
 */
echo "$a ";
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$a

line | # | op | fetch | ext | return | operands
6 | 0 | ADD_VAR |  |  |  | !0
 | 1 | ADD_CHAR |  |  |  | 32
 | 2 | ECHO |  |  |  |
 | 3 | RETURN |  |  |  | 1
ADD_ARRAY_ELEMENT
ADD_INTERFACE
Opcode Descriptions and Examples


ADD_INTERFACE

PHP code

<?php
/*
 * adds an implemented interface to a class declaration
 * opcode number: 144
 */
interface iA {
}

class A implements iA {
}
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | NOP |  |  |  |
 | 1 | DECLARE_CLASS |  |  |  | 'a'
 | 2 | ADD_INTERFACE |  |  |  | 'iA'
 | 3 | VERIFY_ABSTRACT_CLASS |  |  |  |
 | 3 | RETURN |  |  |  | 1
ADD_CHAR
ADD_STRING
Opcode Descriptions and Examples


ADD_STRING

PHP code

<?php
/*
 * add string value2 to string value2 and store in result
 * opcode number: 55
 */
echo "hello$a world";
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$a

line | # | op | fetch | ext | return | operands
6 | 0 | ADD_STRING |  |  | ~0 | 'hello'
 | 1 | ADD_VAR |  |  | ~0 | ~0,!0
 | 2 | ADD_STRING |  |  | ~0 | ~0,'+world'
 | 3 | ECHO |  |  |  | ~0
7 | 4 | RETURN |  |  |  | 1
ADD_INTERFACE
ADD_VAR
Opcode Descriptions and Examples


ADD_VAR

PHP code

<?php
/*
 * add contents of variable in value2 to string value1 and store in result
 * opcode number: 56
 */
echo "hello$a world";
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$a

line | # | op | fetch | ext | return | operands
6 | 0 | ADD_STRING |  |  | ~0 | 'hello'
 | 1 | ADD_VAR |  |  | ~0 | ~0,!0
 | 2 | ADD_STRING |  |  | ~0 | ~0,'+world'
 | 3 | ECHO |  |  |  | ~0
7 | 4 | RETURN |  |  |  | 1
ADD_STRING
ASSIGN
Opcode Descriptions and Examples


ASSIGN

PHP code

<?php
/*
 * assigns value1 to result
 * opcode number: 38
 */
$a=1;
$a='a';
$a=new A();
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$a

line | # | op | fetch | ext | return | operands
6 | 0 | ASSIGN |  |  |  | !0,1
7 | 1 | ASSIGN |  |  |  | !0,'a'
8 | 2 | ZEND_FETCH_CLASS |  |  | :2 | 'A'
 | 3 | NEW |  |  | $3 | :2
 | 4 | DO_FCALL_BY_NAME |  | 0 |  |
 | 5 | ASSIGN |  |  |  | !0,$3
9 | 6 | RETURN |  |  |  | 1
ADD_VAR
ASSIGN_ADD
Opcode Descriptions and Examples


ASSIGN_ADD

PHP code

<?php
/*
 * Add value1 to value2 and store in variable indicated by value1
 * opcode number: 23
 */
$a+=3;
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$a

line | # | op | fetch | ext | return | operands
6 | 0 | ASSIGN_ADD |  |  |  | !0,3
7 | 1 | RETURN |  |  |  | 1
ASSIGN
ASSIGN_BW_AND
Opcode Descriptions and Examples


ASSIGN_BW_AND

PHP code

<?php
/*
 * Performs binary AND on result and value1 and stores in variable indicated by result.
 * opcode number: 32
 */
$a &= 64;
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$a

line | # | op | fetch | ext | return | operands
6 | 0 | ASSIGN_BW_AND |  |  |  | !0,64
7 | 1 | RETURN |  |  |  | 1
ASSIGN_ADD
ASSIGN_BW_OR
Opcode Descriptions and Examples


ASSIGN_BW_OR

PHP code

<?php
/*
 * Performs binary OR on result and value1 and stores in variable indicated by result.
 * opcode number: 31
 */
$a |= 64;
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$a

line | # | op | fetch | ext | return | operands
6 | 0 | ASSIGN_BW_OR |  |  |  | !0,64
7 | 1 | RETURN |  |  |  | 1
ASSIGN_BW_AND
ASSIGN_BW_XOR
Opcode Descriptions and Examples


ASSIGN_BW_XOR

PHP code

<?php
/*
 * Performs binary XOR on result and value1and stores in variable indicated by result.
 * opcode number: 33
 */
$a ^= 64;
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$a

line | # | op | fetch | ext | return | operands
6 | 0 | ASSIGN_BW_XOR |  |  |  | !0,64
7 | 1 | RETURN |  |  |  | 1
ASSIGN_BW_OR
ASSIGN_CONCAT
Opcode Descriptions and Examples


ASSIGN_CONCAT

PHP code

<?php
/*
 * Concats string values result and value1 and store in variable indicated by result
 * opcode number: 30
 */
$a .= 'z';
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$a

line | # | op | fetch | ext | return | operands
6 | 0 | ASSIGN_CONCAT |  |  |  | !0,'z'
7 | 1 | RETURN |  |  |  | 1
ASSIGN_BW_XOR
ASSIGN_DIM
Opcode Descriptions and Examples


ASSIGN_DIM

PHP code

<?php
/*
 *
 * opcode number: 147
 */
$b = 1;
$a[1][2] = $b;
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$b, !1=$a

line | # | op | fetch | ext | return | operands
6 | 0 | ASSIGN |  |  |  | !0,1
7 | 1 | FETCH_DIM_W |  |  | $1 | !1,1
 | 2 | ZEND_ASSIGN_DIM |  |  |  | $1,2
 | 3 | ZEND_OP_DATA |  |  |  | !0,$3
8 | 4 | RETURN |  |  |  | 1
ASSIGN_CONCAT
ASSIGN_DIV
Opcode Descriptions and Examples


ASSIGN_DIV

PHP code

<?php
/*
 * Divide result by value1and store in variable indicated by result.
 * opcode number: 26
 */
$a/=3;
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$a

line | # | op | fetch | ext | return | operands
6 | 0 | ASSIGN_DIV |  |  |  | !0,3
7 | 1 | RETURN |  |  |  | 1
ASSIGN_DIM
ASSIGN_MOD
Opcode Descriptions and Examples


ASSIGN_MOD

PHP code

<?php
/*
 * Perform result mod value1 and store in variable indicated by result
 * opcode number: 27
 */
$a %= 3;
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$a

line | # | op | fetch | ext | return | operands
6 | 0 | ASSIGN_MOD |  |  |  | !0,3
7 | 1 | RETURN |  |  |  | 1
ASSIGN_DIV
ASSIGN_MUL
Opcode Descriptions and Examples


ASSIGN_MUL

PHP code

<?php
/*
 * Multiply result by value1 and store in variable indicated by result
 * opcode number: 25
 */
$a*=3;
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$a

line | # | op | fetch | ext | return | operands
6 | 0 | ASSIGN_MUL |  |  |  | !0,3
7 | 1 | RETURN |  |  |  | 1
ASSIGN_MOD
ASSIGN_OBJ
Opcode Descriptions and Examples


ASSIGN_OBJ

PHP code

<?php
/*
 *
 * opcode number: 136
 */
$obj->a = $otherobj;
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$obj, !1=$otherobj

line | # | op | fetch | ext | return | operands
6 | 0 | ZEND_ASSIGN_OBJ |  |  |  | !0,'a'
 | 1 | ZEND_OP_DATA |  |  |  | !1
7 | 2 | RETURN |  |  |  | 1
ASSIGN_MUL
ASSIGN_REF
Opcode Descriptions and Examples


ASSIGN_REF

PHP code

<?php
/*
 * indicates that variable indicated by value1 is to be treated in the global scope for the remainder of the current scope.
 * opcode number: 39
 */
global $a;
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$a

line | # | op | fetch | ext | return | operands
6 | 0 | FETCH_W | globallock |  | $0 | 'a'
 | 1 | ASSIGN_REF |  |  |  | !0,$0
7 | 2 | RETURN |  |  |  | 1
ASSIGN_OBJ
ASSIGN_SL
Opcode Descriptions and Examples


ASSIGN_SL

PHP code

<?php
/*
 * Shift result by value1 bits to left and store in variable indicated by result
 * opcode number: 28
 */
$a <<= 3;
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$a

line | # | op | fetch | ext | return | operands
6 | 0 | ASSIGN_SL |  |  |  | !0,3
7 | 1 | RETURN |  |  |  | 1
ASSIGN_REF
ASSIGN_SR
Opcode Descriptions and Examples


ASSIGN_SR

PHP code

<?php
/*
 * Shift result by value1 bits to right and store in variable indicated by result
 * opcode number: 29
 */
$a >>= 3;
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$a

line | # | op | fetch | ext | return | operands
6 | 0 | ASSIGN_SR |  |  |  | !0,3
7 | 1 | RETURN |  |  |  | 1
ASSIGN_SL
ASSIGN_SUB
Opcode Descriptions and Examples


ASSIGN_SUB

PHP code

<?php
/*
 * Subtract value1 from value2 and store in variable indicated by value1
 * opcode number: 24
 */
$a-=3;
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$a

line | # | op | fetch | ext | return | operands
6 | 0 | ASSIGN_SUB |  |  |  | !0,3
7 | 1 | RETURN |  |  |  | 1
ASSIGN_SR
BEGIN_SILENCE
Opcode Descriptions and Examples


BEGIN_SILENCE

PHP code

<?php
/*
 * prepare to perform function call without displaying error messages
 * opcode number: 57
 */
/* Intentional file error */
$my_file = @file ('non_existent_file') or
   die ("error:'$php_errormsg'");
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$my_file, !1=$php_errormsg

line | # | op | fetch | ext | return | operands
7 | 0 | BEGIN_SILENCE |  |  | ~0 |
 | 1 | SEND_VAL |  |  |  | 'non_existent_file'
 | 2 | DO_FCALL |  | 1 |  | 'file'
 | 3 | END_SILENCE |  |  |  | ~0
 | 4 | ASSIGN |  |  | $2 | !0,$1
 | 5 | JMPNZ_EX |  |  | ~3 | $2,->11
8 | 6 | ADD_STRING |  |  | ~4 | 'error%3A%27'
 | 7 | ADD_VAR |  |  | ~4 | ~4,!1
 | 8 | ADD_CHAR |  |  | ~4 | ~4,39
 | 9 | EXIT |  |  |  | ~4
 | 10 | BOOL |  |  | ~3 | true
 | 11 | FREE |  |  |  | ~3
9 | 12 | RETURN |  |  |  | 1
ASSIGN_SUB
BOOL
Opcode Descriptions and Examples


BOOL

PHP code

<?php
/*
 * convert value1 to boolean and store in result??????????
 * opcode number: 52
 */
if (1 || 2 || 1) echo "foo";
//$a = true;
//if($a) echo "foo";
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | JMPNZ_EX |  |  | ~0 | 1,->2
 | 1 | BOOL |  |  | ~0 | 2
 | 2 | JMPNZ_EX |  |  | ~0 | ~0,->4
 | 3 | BOOL |  |  | ~0 | 1
 | 4 | JMPZ |  |  |  | ~0,->7
 | 5 | ECHO |  |  |  | 'foo'
 | 6 | JMP |  |  |  | ->7
9 | 7 | RETURN |  |  |  | 1
BEGIN_SILENCE
BOOL_NOT
Opcode Descriptions and Examples


BOOL_NOT

PHP code

<?php
/*
 * Boolean (logical) not of "value"
 * opcode number: 13
 */
echo !1;
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | BOOL_NOT |  |  | ~0 | 1
 | 1 | ECHO |  |  |  | ~0
7 | 2 | RETURN |  |  |  | 1
BOOL
BOOL_XOR
Opcode Descriptions and Examples


BOOL_XOR

PHP code

<?php
/*
 * Boolean (logical) xor of value1
 * opcode number: 14
 */
echo 1 xor 2;
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | BOOL_XOR |  |  | ~0 | 1,2
 | 1 | ECHO |  |  |  | ~0
7 | 2 | RETURN |  |  |  | 1
BOOL_NOT
BRK
Opcode Descriptions and Examples


BRK

PHP code

<?php
/*
 * ???  End of a case block exists the current switch block.  Followed by JMP?
 * opcode number: 50
 */
$x = 0;
while(1) {
    if($x == 0) break;
}
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$x

line | # | op | fetch | ext | return | operands
6 | 0 | ASSIGN |  |  |  | !0,0
7 | 1 | JMPZ |  |  |  | 1,->7
8 | 2 | IS_EQUAL |  |  | ~1 | !0,0
 | 3 | JMPZ |  |  |  | ~1,->6
 | 4 | BRK |  |  |  | 1
 | 5 | JMP |  |  |  | ->6
9 | 6 | JMP |  |  |  | ->1
10 | 7 | RETURN |  |  |  | 1
BOOL_XOR
BW_AND
Opcode Descriptions and Examples


BW_AND

PHP code

<?php
/*
 * Bit-wise and of value1 and value2
 * opcode number: 10
 */
echo 1&2;
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | BW_AND |  |  | ~0 | 1,2
 | 1 | ECHO |  |  |  | ~0
7 | 2 | RETURN |  |  |  | 1
BRK
BW_NOT
Opcode Descriptions and Examples


BW_NOT

PHP code

<?php
/*
 * Bit-wise not of "value"
 * opcode number: 12
 */
echo ~15;
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | BW_NOT |  |  | ~0 | 15
 | 1 | ECHO |  |  |  | ~0
7 | 2 | RETURN |  |  |  | 1
BW_AND
BW_OR
Opcode Descriptions and Examples


BW_OR

PHP code

<?php
/*
 * Bit-wise or of value1 and value2
 * opcode number: 9
 */
echo 1|2;
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | BW_OR |  |  | ~0 | 1,2
 | 1 | ECHO |  |  |  | ~0
7 | 2 | RETURN |  |  |  | 1
BW_NOT
BW_XOR
Opcode Descriptions and Examples


BW_XOR

PHP code

<?php
/*
 * Bit-wise xor of value1 and value2
 * opcode number: 11
 */
echo 1^2;
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | BW_XOR |  |  | ~0 | 1,2
 | 1 | ECHO |  |  |  | ~0
7 | 2 | RETURN |  |  |  | 1
BW_OR
CASE
Opcode Descriptions and Examples


CASE

PHP code

<?php
/*
 * Set result to true if value1 equals value2.  The value2 must be a constant value?
 * opcode number: 48
 */
$i=0;
switch ($i) {
   case 0:
         echo "i=0";
         break;
   case 1:
         echo "i=1";
         break;
   case 2:
         echo "i=2";
         break;
}
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$i

line | # | op | fetch | ext | return | operands
6 | 0 | ASSIGN |  |  |  | !0,0
8 | 1 | CASE |  |  | ~1 | !0,0
 | 2 | JMPZ |  |  |  | ~1,->6
9 | 3 | ECHO |  |  |  | 'i%3D0'
10 | 4 | BRK |  |  |  | 1
11 | 5 | JMP |  |  |  | ->8
 | 6 | CASE |  |  | ~1 | !0,1
 | 7 | JMPZ |  |  |  | ~1,->11
12 | 8 | ECHO |  |  |  | 'i%3D1'
13 | 9 | BRK |  |  |  | 1
14 | 10 | JMP |  |  |  | ->13
 | 11 | CASE |  |  | ~1 | !0,2
 | 12 | JMPZ |  |  |  | ~1,->16
15 | 13 | ECHO |  |  |  | 'i%3D2'
16 | 14 | BRK |  |  |  | 1
17 | 15 | JMP |  |  |  | ->16
18 | 16 | RETURN |  |  |  | 1
BW_XOR
CAST
Opcode Descriptions and Examples


CAST

PHP code

<?php
/*
 * casts value1 as type value2 (type in extended_value)
 * opcode number: 21
 */
echo (int)1;
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | CAST |  | 4 | ~0 | 1
 | 1 | ECHO |  |  |  | ~0
7 | 2 | RETURN |  |  |  | 1
CASE
CATCH
Opcode Descriptions and Examples


CATCH

PHP code

<?php
/*
 *
 * opcode number: 107
 */
try {
    $error = 'Always throw this error';
    throw new Exception($error);

    // Code following an exception is not executed.
    echo 'Never executed';

} catch (Exception $e) {
    echo 'Caught exception: ',  $e->getMessage(), "\n";
}

// Continue execution
echo 'Hello World';
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$error, !1=$e

line | # | op | fetch | ext | return | operands
7 | 0 | ASSIGN |  |  |  | !0,'Always+throw+this+error'
8 | 1 | ZEND_FETCH_CLASS |  |  | :1 | 'Exception'
 | 2 | NEW |  |  | $2 | :1
 | 3 | SEND_VAR |  |  |  | !0
 | 4 | DO_FCALL_BY_NAME |  | 1 |  |
 | 5 | ZEND_THROW |  | 0 |  | $2
11 | 6 | ECHO |  |  |  | 'Never+executed'
13 | 7 | JMP |  |  |  | ->15
 | 8 | ZEND_FETCH_CLASS |  |  | :4 | 'Exception'
 | 9 | ZEND_CATCH |  | 15 |  | $4,!1
14 | 10 | ECHO |  |  |  | 'Caught+exception%3A+'
 | 11 | ZEND_INIT_METHOD_CALL |  |  |  | !1,'getMessage'
 | 12 | DO_FCALL_BY_NAME |  | 0 |  |
 | 13 | ECHO |  |  |  | $6
 | 14 | ECHO |  |  |  | '%0A'
18 | 15 | ECHO |  |  |  | 'Hello+World'
19 | 16 | RETURN |  |  |  | 1
CAST
CLONE
Opcode Descriptions and Examples


CLONE

PHP code

<?php
/*
 *
 * opcode number: 110
 */
$obj = new A();
$copy = clone $obj;
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$obj, !1=$copy

line | # | op | fetch | ext | return | operands
6 | 0 | ZEND_FETCH_CLASS |  |  | :0 | 'A'
 | 1 | NEW |  |  | $1 | :0
 | 2 | DO_FCALL_BY_NAME |  | 0 |  |
 | 3 | ASSIGN |  |  |  | !0,$1
7 | 4 | ZEND_CLONE |  |  | $4 | !0
 | 5 | ASSIGN |  |  |  | !1,$4
8 | 6 | RETURN |  |  |  | 1
CATCH
CONCAT
Opcode Descriptions and Examples


CONCAT

PHP code

<?php
/*
 * Concats string values string1 and string2
 * opcode number: 8
 */
echo "hello" . "world";
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | CONCAT |  |  | ~0 | 'hello','world'
 | 1 | ECHO |  |  |  | ~0
7 | 2 | RETURN |  |  |  | 1
CLONE
CONT
Opcode Descriptions and Examples


CONT

PHP code

<?php
/*
 * Continue next iteration of current loop level
 * opcode number: 51
 */
$foo = false;
while(!$foo) {
    $foo = true;
    continue;
}
?>

PHP opcodes

Function name: (null)

compiled vars: !0 = $foo

line | # | op | fetch | ext | return | operands
6 | 0 | ASSIGN |  |  |  | !0, false
7 | 1 | BOOL_NOT |  |  | ~1 | !0
 | 2 | JMPZ |  |  |  | ~1, ->5
8 | 3 | ASSIGN |  |  |  | !0, true
9 | 4 | CONT |  |  |  | 1
10 | 5 | JMP |  |  |  | ->1
12 | 6 | RETURN |  |  |  | 1
CONCAT
DECLARE_CLASS
Opcode Descriptions and Examples


DECLARE_CLASS

PHP code

<?php
/*
 * Declare a class with the name of class-name as the implementation specified by ID.
 * opcode number: 139
 */
class A {
    function methodA(){
        echo "hello world";
    }
}
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | NOP |  |  |  |
11 | 1 | RETURN |  |  |  | 1

Function name: methodA

Compiled variables: none

line | # | op | fetch | ext | return | operands
8 | 0 | ECHO |  |  |  | 'hello+world'
9 | 1 | RETURN |  |  |  | null
CONT
DECLARE_CONST
Opcode Descriptions and Examples


DECLARE_CONST

PHP code

<?php
/*
 *
 * opcode number: 143
 * No sample PHP yet */
?>
DECLARE_CLASS
DECLARE_FUNCTION
Opcode Descriptions and Examples


DECLARE_FUNCTION

PHP code

<?php
/*
 *
 * opcode number: 141
 */
class A{
 function funcA(){
 }
}
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | NOP |  |  |  |
10 | 1 | RETURN |  |  |  | 1

Function name: funcA

Compiled variables: none

line | # | op | fetch | ext | return | operands
8 | 0 | RETURN |  |  |  | null
DECLARE_CONST
DECLARE_INHERITED_CLASS
Opcode Descriptions and Examples


DECLARE_INHERITED_CLASS

PHP code

<?php
/*
 *
 * opcode number: 140
 */
 if($b){
 class Foo {
  public static $my_static = 'foo';
  public function staticValue() {
    return self::$my_static;
  }
 }

 class Bar extends Foo {
  public function fooStatic() {
     echo parent::$my_static;
  }
 }
}
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$b

line | # | op | fetch | ext | return | operands
6 | 0 | JMPZ |  |  |  | !0,->5
7 | 1 | ZEND_DECLARE_CLASS |  |  | $0 | '%00foo%2Fmnt%2Fworkspace%2Fws_phpscripts%2FPHPopcodes%2Fphpsamples%2FDECLARE_INHERITED_CLASS.php0xb7be503b','foo'
14 | 2 | ZEND_FETCH_CLASS |  |  | :1 | 'Foo'
 | 3 | ZEND_DECLARE_INHERITED_CLASS |  |  | $2 | '%00bar%2Fmnt%2Fworkspace%2Fws_phpscripts%2FPHPopcodes%2Fphpsamples%2FDECLARE_INHERITED_CLASS.php0xb7be50bc','bar'
19 | 4 | JMP |  |  |  | ->5
20 | 5 | RETURN |  |  |  | 1

Function name: staticValue

Compiled variables: !0=$my_static

line | # | op | fetch | ext | return | operands
10 | 0 | ZEND_FETCH_CLASS |  |  |  |
 | 1 | FETCH_R | staticmember |  | $1 | 'my_static'
 | 2 | RETURN |  |  |  | $1
11 | 3 | RETURN |  |  |  | null

Function name: fooStatic

Compiled variables: !0=$my_static

line | # | op | fetch | ext | return | operands
16 | 0 | ZEND_FETCH_CLASS |  |  | :0 |
 | 1 | FETCH_R | staticmember |  | $1 | 'my_static'
 | 2 | ECHO |  |  |  | $1
17 | 3 | RETURN |  |  |  | null
DECLARE_FUNCTION
DECLARE_INHERITED_CLASS_DELAYED
Opcode Descriptions and Examples


DECLARE_INHERITED_CLASS_DELAYED

PHP code

<?php
/*
 *
 * opcode number: 145
 * No sample PHP yet */
?>
DECLARE_INHERITED_CLASS
DIV
Opcode Descriptions and Examples


DIV

PHP code

<?php
/*
 * Divides "value1" by "value2" and stores the result into "result".
 * opcode number: 4
 */
echo 6/3;
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | DIV |  |  | ~0 | 6,3
 | 1 | ECHO |  |  |  | ~0
7 | 2 | RETURN |  |  |  | 1
DECLARE_INHERITED_CLASS_DELAYED
DO_FCALL
Opcode Descriptions and Examples


DO_FCALL

PHP code

<?php
/*
 * Call a function.  Following multiple SEND_VAL, SEND_VAR or SEND_REF.
 * opcode number: 60
 */
$a = phpinfo();
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$a

line | # | op | fetch | ext | return | operands
6 | 0 | DO_FCALL |  | 0 |  | 'phpinfo'
 | 1 | ASSIGN |  |  |  | !0,$0
7 | 2 | RETURN |  |  |  | 1
DIV
DO_FCALL_BY_NAME
Opcode Descriptions and Examples


DO_FCALL_BY_NAME

PHP code

<?php
/*
 * Call a function by name.  Following INIT_FCALL_BY_NAME and multiple SEND_VAL, SEND_VAR or SEND_REF.
 * opcode number: 61
 */
$x = 'phpinfo';
$a = $x();
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$x, !1=$a

line | # | op | fetch | ext | return | operands
6 | 0 | ASSIGN |  |  |  | !0,'phpinfo'
7 | 1 | INIT_FCALL_BY_NAME |  |  |  | !0
 | 2 | DO_FCALL_BY_NAME |  | 0 |  |
 | 3 | ASSIGN |  |  |  | !1,$1
8 | 4 | RETURN |  |  |  | 1
DO_FCALL
ECHO
Opcode Descriptions and Examples


ECHO

PHP code

<?php
/*
 * Dump text
 * opcode number: 40
 */
echo "hello world";
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | ECHO |  |  |  | 'hello+world'
7 | 1 | RETURN |  |  |  | 1
DO_FCALL_BY_NAME
END_SILENCE
Opcode Descriptions and Examples


END_SILENCE

PHP code

<?php
/*
 * no longer surpress error messages
 * opcode number: 58
 */
$my_file = @file ('non_existent_file') or
   die ("error:'$php_errormsg'");
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$my_file, !1=$php_errormsg

line | # | op | fetch | ext | return | operands
6 | 0 | BEGIN_SILENCE |  |  | ~0 |
 | 1 | SEND_VAL |  |  |  | 'non_existent_file'
 | 2 | DO_FCALL |  | 1 |  | 'file'
 | 3 | END_SILENCE |  |  |  | ~0
 | 4 | ASSIGN |  |  | $2 | !0,$1
 | 5 | JMPNZ_EX |  |  | ~3 | $2,->11
7 | 6 | ADD_STRING |  |  | ~4 | 'error%3A%27'
 | 7 | ADD_VAR |  |  | ~4 | ~4,!1
 | 8 | ADD_CHAR |  |  | ~4 | ~4,39
 | 9 | EXIT |  |  |  | ~4
 | 10 | BOOL |  |  | ~3 | true
 | 11 | FREE |  |  |  | ~3
8 | 12 | RETURN |  |  |  | 1
ECHO
EXIT
Opcode Descriptions and Examples


EXIT

PHP code

<?php
/*
 * Exit running after dumping "message".
 * opcode number: 79
 */
die("foobar");
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | EXIT |  |  |  | 'foobar'
7 | 1 | RETURN |  |  |  | 1
END_SILENCE
EXT_FCALL_BEGIN
Opcode Descriptions and Examples


EXT_FCALL_BEGIN

PHP code

<?php
/*
 *
 * opcode number: 102
 * No sample PHP yet */
?>
EXIT
EXT_FCALL_END
Opcode Descriptions and Examples


EXT_FCALL_END

PHP code

<?php
/*
 *
 * opcode number: 103
 * No sample PHP yet */
?>
EXT_FCALL_BEGIN
EXT_NOP
Opcode Descriptions and Examples


EXT_NOP

PHP code

<?php
/*
 *
 * opcode number: 104
 * No sample PHP yet */
?>
EXT_FCALL_END
EXT_STMT
Opcode Descriptions and Examples


EXT_STMT

PHP code

<?php
/*
 *
 * opcode number: 101
 */
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
7 | 0 | EXT_STMT |  |  |  |
8 | 1 | RETURN |  |  |  | 1
EXT_NOP
FE_FETCH
Opcode Descriptions and Examples


FE_FETCH

PHP code

<?php
/*
 * Fetch an element from iterator.  If no element is available, jump to address.  Followed by OP_DATA?
 * opcode number: 78
 */
$a = array(1,2,3);
foreach($a as $num){
    print $num;
}
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$a, !1=$num

line | # | op | fetch | ext | return | operands
6 | 0 | INIT_ARRAY |  |  | ~0 | 1
 | 1 | ADD_ARRAY_ELEMENT |  |  | ~0 | 2
 | 2 | ADD_ARRAY_ELEMENT |  |  | ~0 | 3
 | 3 | ASSIGN |  |  |  | !0,~0
7 | 4 | FE_RESET |  |  | $2 | !0,->11
 | 5 | FE_FETCH |  |  | $3 | $2,->11
 | 6 | ZEND_OP_DATA |  |  |  |
 | 7 | ASSIGN |  |  |  | !1,$3
8 | 8 | PRINT |  |  | ~5 | !1
 | 9 | FREE |  |  |  | ~5
9 | 10 | JMP |  |  |  | ->5
 | 11 | SWITCH_FREE |  |  |  | $2
10 | 12 | RETURN |  |  |  | 1
EXT_STMT
FE_RESET
Opcode Descriptions and Examples


FE_RESET

PHP code

<?php
/*
 * Initialize an iterator on array-value.  If the array is empty, jump to address.  Followed by FE_FETCH.
 * opcode number: 77
 */
$a = array(1,2,3);
foreach($a as $num){
    print $num;
}
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$a, !1=$num

line | # | op | fetch | ext | return | operands
6 | 0 | INIT_ARRAY |  |  | ~0 | 1
 | 1 | ADD_ARRAY_ELEMENT |  |  | ~0 | 2
 | 2 | ADD_ARRAY_ELEMENT |  |  | ~0 | 3
 | 3 | ASSIGN |  |  |  | !0,~0
7 | 4 | FE_RESET |  |  | $2 | !0,->11
 | 5 | FE_FETCH |  |  | $3 | $2,->11
 | 6 | ZEND_OP_DATA |  |  |  |
 | 7 | ASSIGN |  |  |  | !1,$3
8 | 8 | PRINT |  |  | ~5 | !1
 | 9 | FREE |  |  |  | ~5
9 | 10 | JMP |  |  |  | ->5
 | 11 | SWITCH_FREE |  |  |  | $2
10 | 12 | RETURN |  |  |  | 1
FE_FETCH
FETCH_CLASS
Opcode Descriptions and Examples


FETCH_CLASS

PHP code

<?php
/*
 *
 * opcode number: 109
 */
$obj = new A();
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$obj

line | # | op | fetch | ext | return | operands
6 | 0 | ZEND_FETCH_CLASS |  |  | :0 | 'A'
 | 1 | NEW |  |  | $1 | :0
 | 2 | DO_FCALL_BY_NAME |  | 0 |  |
 | 3 | ASSIGN |  |  |  | !0,$1
7 | 4 | RETURN |  |  |  | 1
FE_RESET
FETCH_CONSTANT
Opcode Descriptions and Examples


FETCH_CONSTANT

PHP code

<?php
/*
 * Fetch the constant value bound to the specified name (name) and stores it into a variable (result).
 * opcode number: 99
 */
define("FOO", "something");
echo FOO;
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | SEND_VAL |  |  |  | 'FOO'
 | 1 | SEND_VAL |  |  |  | 'something'
 | 2 | DO_FCALL |  | 2 |  | 'define'
7 | 3 | FETCH_CONSTANT |  |  | ~1 | 'FOO'
 | 4 | ECHO |  |  |  | ~1
8 | 5 | RETURN |  |  |  | 1
FETCH_CLASS
FETCH_DIM_FUNC_ARG
Opcode Descriptions and Examples


FETCH_DIM_FUNC_ARG

PHP code

<?php
/*
 *
 * opcode number: 93
 */

function foo(&$x)
{
  print($x);
}

$x = array(0, 1, 2, 3, 4, 5);
$z = "foo";

$z($x[0]);

?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$x, !1=$z

line | # | op | fetch | ext | return | operands
7 | 0 | NOP |  |  |  |
12 | 1 | INIT_ARRAY |  |  | ~0 | 0
 | 2 | ADD_ARRAY_ELEMENT |  |  | ~0 | 1
 | 3 | ADD_ARRAY_ELEMENT |  |  | ~0 | 2
 | 4 | ADD_ARRAY_ELEMENT |  |  | ~0 | 3
 | 5 | ADD_ARRAY_ELEMENT |  |  | ~0 | 4
 | 6 | ADD_ARRAY_ELEMENT |  |  | ~0 | 5
 | 7 | ASSIGN |  |  |  | !0,~0
13 | 8 | ASSIGN |  |  |  | !1,'foo'
15 | 9 | INIT_FCALL_BY_NAME |  |  |  | !1
 | 10 | FETCH_DIM_FUNC_ARG |  |  | $3 | !0,0
 | 11 | SEND_VAR |  |  |  | $3
 | 12 | DO_FCALL_BY_NAME |  | 1 |  |
17 | 13 | RETURN |  |  |  | 1

Function name: foo

Compiled variables: !0=$x

line | # | op | fetch | ext | return | operands
7 | 0 | RECV |  |  |  | 1
9 | 1 | PRINT |  |  | ~0 | !0
 | 2 | FREE |  |  |  | ~0
10 | 3 | RETURN |  |  |  | null
FETCH_CONSTANT
FETCH_DIM_IS
Opcode Descriptions and Examples


FETCH_DIM_IS

PHP code

<?php
/*
 *
 * opcode number: 90
 * No sample PHP yet */
?>
FETCH_DIM_FUNC_ARG
FETCH_DIM_R
Opcode Descriptions and Examples


FETCH_DIM_R

PHP code

<?php
/*
 * Fetch the value of the element at "index" in "array-value" to store it in "result".  Read-only?
 * opcode number: 81
 */
$x = array(1,2,3);
$a = 'x';
echo $$a[0];
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$x, !1=$a

line | # | op | fetch | ext | return | operands
6 | 0 | INIT_ARRAY |  |  | ~0 | 1
 | 1 | ADD_ARRAY_ELEMENT |  |  | ~0 | 2
 | 2 | ADD_ARRAY_ELEMENT |  |  | ~0 | 3
 | 3 | ASSIGN |  |  |  | !0,~0
7 | 4 | ASSIGN |  |  |  | !1,'x'
8 | 5 | FETCH_DIM_R |  |  | $3 | !1,0
 | 6 | FETCH_R | local |  | $4 | $3
 | 7 | ECHO |  |  |  | $4
9 | 8 | RETURN |  |  |  | 1
FETCH_DIM_IS
FETCH_DIM_RW
Opcode Descriptions and Examples


FETCH_DIM_RW

PHP code

<?php
/*
 * Fetch the value of the element at "index" in "array-value" to store it in "result".
 * opcode number: 87
 */
$x = array(1,2,3);
$a = 'x';
$$a[0]++;
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$x, !1=$a

line | # | op | fetch | ext | return | operands
6 | 0 | INIT_ARRAY |  |  | ~0 | 1
 | 1 | ADD_ARRAY_ELEMENT |  |  | ~0 | 2
 | 2 | ADD_ARRAY_ELEMENT |  |  | ~0 | 3
 | 3 | ASSIGN |  |  |  | !0,~0
7 | 4 | ASSIGN |  |  |  | !1,'x'
8 | 5 | FETCH_DIM_R |  |  | $3 | !1,0
 | 6 | FETCH_RW | local |  | $4 | $3
 | 7 | POST_INC |  |  | ~5 | $4
 | 8 | FREE |  |  |  | ~5
9 | 9 | RETURN |  |  |  | 1
FETCH_DIM_R
FETCH_DIM_TMP_VAR
Opcode Descriptions and Examples


FETCH_DIM_TMP_VAR

PHP code

<?php
/*
 * Fetch an entry of an array from a temporal variable?
 * opcode number: 98
 */
list($x) = array("X");
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$x

line | # | op | fetch | ext | return | operands
6 | 0 | INIT_ARRAY |  |  | ~0 | 'X'
 | 1 | FETCH_DIM_TMP_VAR |  |  | $1 | ~0,0
 | 2 | ASSIGN |  |  |  | !0,$1
 | 3 | FREE |  |  |  | ~0
7 | 4 | RETURN |  |  |  | 1
FETCH_DIM_RW
FETCH_DIM_UNSET
Opcode Descriptions and Examples


FETCH_DIM_UNSET

PHP code

<?php
/*
 * Fetch an entry of an array variable for the purpose of unset() operation.
 * opcode number: 96
 * No sample PHP yet */
?>
FETCH_DIM_TMP_VAR
FETCH_DIM_W
Opcode Descriptions and Examples


FETCH_DIM_W

PHP code

<?php
/*
 * Fetch the value of the element at "index" in "array-value" to store it in "result".  Write-only?
 * opcode number: 84
 */
$a = 1;
while($a > 0){
    $a = 0;
}
/*$input =array(1,2,3);
while (list($var,) = @each($input)){
    unset($$var);
}*/
/*$a = array(1,2,3);
$x = 'a';
$$x[0] = 1;*/

/*while ($b = each($a)) {
  print $b;
}*/

?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$a

line | # | op | fetch | ext | return | operands
6 | 0 | ASSIGN |  |  |  | !0,1
7 | 1 | IS_SMALLER |  |  | ~1 | 0,!0
 | 2 | JMPZ |  |  |  | ~1,->5
8 | 3 | ASSIGN |  |  |  | !0,0
9 | 4 | JMP |  |  |  | ->1
23 | 5 | RETURN |  |  |  | 1
FETCH_DIM_UNSET
FETCH_FUNC_ARG
Opcode Descriptions and Examples


FETCH_FUNC_ARG

PHP code

<?php
/*
 *
 * opcode number: 92
 */
function foo($x)
{
}

$x = 1;
$y = "x";
$z = "foo";

$z($$y);

?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$x, !1=$y, !2=$z

line | # | op | fetch | ext | return | operands
6 | 0 | NOP |  |  |  |
10 | 1 | ASSIGN |  |  |  | !0,1
11 | 2 | ASSIGN |  |  |  | !1,'x'
12 | 3 | ASSIGN |  |  |  | !2,'foo'
14 | 4 | INIT_FCALL_BY_NAME |  |  |  | !2
 | 5 | FETCH_FUNC_ARG | local |  | $3 | !1
 | 6 | SEND_VAR |  |  |  | $3
 | 7 | DO_FCALL_BY_NAME |  | 1 |  |
16 | 8 | RETURN |  |  |  | 1

Function name: foo

Compiled variables: !0=$x

line | # | op | fetch | ext | return | operands
6 | 0 | RECV |  |  |  | 1
8 | 1 | RETURN |  |  |  | null
FETCH_DIM_W
FETCH_IS
Opcode Descriptions and Examples


FETCH_IS

PHP code

<?php
/*
 * Fetch the value from variable which is to be used to test if it is set or not, through isset()/isempty().
 * opcode number: 89
 */
echo isset($_SESSION['userid']);
echo isset($_SESSION['userid'][1]);
echo isset($_SESSION->prop->prop);
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | FETCH_IS |  |  | $0 | '_SESSION'
 | 1 | ZEND_ISSET_ISEMPTY_DIM_OBJ |  | 1 | ~1 | $0,'userid'
 | 2 | ECHO |  |  |  | ~1
7 | 3 | FETCH_IS |  |  | $2 | '_SESSION'
 | 4 | FETCH_DIM_IS |  |  | $3 | $2,'userid'
 | 5 | ZEND_ISSET_ISEMPTY_DIM_OBJ |  | 1 | ~4 | $3,1
 | 6 | ECHO |  |  |  | ~4
8 | 7 | FETCH_IS |  |  | $5 | '_SESSION'
 | 8 | FETCH_OBJ_IS |  |  | $6 | $5,'prop'
 | 9 | ZEND_ISSET_ISEMPTY_PROP_OBJ |  |  | ~7 | $6,'prop'
 | 10 | ECHO |  |  |  | ~7
9 | 11 | RETURN |  |  |  | 1
FETCH_FUNC_ARG
FETCH_OBJ_FUNC_ARG
Opcode Descriptions and Examples


FETCH_OBJ_FUNC_ARG

PHP code

<?php
/*
 *
 * opcode number: 94
 */
include './classA.php';

function foo(&$x)
{
  print($x);
}

$z = "foo";

$obj = new A();
print $obj->num;
$z($obj->num);

?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$z, !1=$obj

line | # | op | fetch | ext | return | operands
6 | 0 | INCLUDE_OR_EVAL |  |  |  | '.%2FclassA.php',INCLUDE
8 | 1 | NOP |  |  |  |
13 | 2 | ASSIGN |  |  |  | !0,'foo'
15 | 3 | ZEND_FETCH_CLASS |  |  | :2 | 'A'
 | 4 | NEW |  |  | $3 | :2
 | 5 | DO_FCALL_BY_NAME |  | 0 |  |
 | 6 | ASSIGN |  |  |  | !1,$3
16 | 7 | FETCH_OBJ_R |  |  | $6 | !1,'num'
 | 8 | PRINT |  |  | ~7 | $6
 | 9 | FREE |  |  |  | ~7
17 | 10 | INIT_FCALL_BY_NAME |  |  |  | !0
 | 11 | FETCH_OBJ_FUNC_ARG |  |  | $8 | !1,'num'
 | 12 | SEND_VAR |  |  |  | $8
 | 13 | DO_FCALL_BY_NAME |  | 1 |  |
19 | 14 | RETURN |  |  |  | 1

Function name: foo

Compiled variables: !0=$x

line | # | op | fetch | ext | return | operands
8 | 0 | RECV |  |  |  | 1
10 | 1 | PRINT |  |  | ~0 | !0
 | 2 | FREE |  |  |  | ~0
11 | 3 | RETURN |  |  |  | null

Function name: foo

Compiled variables: !0=$x

line | # | op | fetch | ext | return | operands
8 | 0 | RECV |  |  |  | 1
10 | 1 | PRINT |  |  | ~0 | !0
 | 2 | FREE |  |  |  | ~0
11 | 3 | RETURN |  |  |  | null
FETCH_IS
FETCH_OBJ_IS
Opcode Descriptions and Examples


FETCH_OBJ_IS

PHP code

<?php
/*
 *
 * opcode number: 91
 * No sample PHP yet */
?>
FETCH_OBJ_FUNC_ARG
FETCH_OBJ_R
Opcode Descriptions and Examples


FETCH_OBJ_R

PHP code

<?php
/*
 * Fetch the "prop-name" property value of this object.  Read-only?
 * opcode number: 82
 */
$x = new A();
$a = 'x';
echo $$a->num;
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$x, !1=$a

line | # | op | fetch | ext | return | operands
6 | 0 | ZEND_FETCH_CLASS |  |  | :0 | 'A'
 | 1 | NEW |  |  | $1 | :0
 | 2 | DO_FCALL_BY_NAME |  | 0 |  |
 | 3 | ASSIGN |  |  |  | !0,$1
7 | 4 | ASSIGN |  |  |  | !1,'x'
8 | 5 | FETCH_R | local |  | $5 | !1
 | 6 | FETCH_OBJ_R |  |  | $6 | $5,'num'
 | 7 | ECHO |  |  |  | $6
9 | 8 | RETURN |  |  |  | 1
FETCH_OBJ_IS
FETCH_OBJ_RW
Opcode Descriptions and Examples


FETCH_OBJ_RW

PHP code

<?php
/*
 * Fetch the "prop-name" property value of this object.
 * opcode number: 88
 */
$x = new A();
$a = 'x';
$$a->num++;
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$x, !1=$a

line | # | op | fetch | ext | return | operands
6 | 0 | ZEND_FETCH_CLASS |  |  | :0 | 'A'
 | 1 | NEW |  |  | $1 | :0
 | 2 | DO_FCALL_BY_NAME |  | 0 |  |
 | 3 | ASSIGN |  |  |  | !0,$1
7 | 4 | ASSIGN |  |  |  | !1,'x'
8 | 5 | FETCH_RW | local |  | $5 | !1
 | 6 | ZEND_POST_INC_OBJ |  |  | ~7 | $5,'num'
 | 7 | FREE |  |  |  | ~7
9 | 8 | RETURN |  |  |  | 1
FETCH_OBJ_R
FETCH_OBJ_UNSET
Opcode Descriptions and Examples


FETCH_OBJ_UNSET

PHP code

<?php
/*
 * Fetch a property of an object variable for the purpose of unset() operation.
 * opcode number: 97
 * No sample PHP yet */
?>
FETCH_OBJ_RW
FETCH_OBJ_W
Opcode Descriptions and Examples


FETCH_OBJ_W

PHP code

<?php
/*
 * Fetch an object from the property of this object and write to the property of the fectched object.
 * opcode number: 85
 */
$foo = new stdclass;
$foo->bar = new stdclass;
$foo->bar->baz = 'quix';
?>

PHP opcodes

Function name: (null)

Compiled variables: !0 = $foo

line | # | op | fetch | ext | return | operands
6 | 0 | ZEND_FETCH_CLASS |  | 4 | :0 | 'stdclass'
 | 1 | NEW |  |  |  | :0
 | 2 | DO_FCALL_BY_NAME |  | 0 |  |
 | 3 | ASSIGN |  |  |  | !0
7 | 4 | ZEND_FETCH_CLASS |  | 4 | :5 | 'stdclass'
 | 5 | NEW |  |  |  | :5
 | 6 | DO_FCALL_BY_NAME |  | 0 |  |
 | 7 | ZEND_ASSIGN_OBJ |  |  |  | !0, 'bar'
 | 8 | ZEND_OP_DATA |  |  |  |
8 | 9 | FETCH_OBJ_W |  |  |  | !0, 'bar'
 | 10 | ZEND_ASSIGN_OBJ |  |  |  | 'baz'
 | 11 | ZEND_OP_DATA |  |  |  | 'quix'
9 | 12 | RETURN |  |  |  | 1
FETCH_OBJ_UNSET
FETCH_R
Opcode Descriptions and Examples


FETCH_R

PHP code

<?php
/*
 * Fetch the value of the varible of "name" to assign it to a variable?  Read-only?
 * opcode number: 80
 */
$x = 1;
$a = 'x';
echo $$a;
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$x, !1=$a

line | # | op | fetch | ext | return | operands
6 | 0 | ASSIGN |  |  |  | !0,1
7 | 1 | ASSIGN |  |  |  | !1,'x'
8 | 2 | FETCH_R | local |  | $2 | !1
 | 3 | ECHO |  |  |  | $2
9 | 4 | RETURN |  |  |  | 1
FETCH_OBJ_W
FETCH_RW
Opcode Descriptions and Examples


FETCH_RW

PHP code

<?php
/*
 * Fetch the value of the varible of "name" to assign it to a variable?
 * opcode number: 86
 */
$x = 1;
$a = 'x';
$$a++;
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$x, !1=$a

line | # | op | fetch | ext | return | operands
6 | 0 | ASSIGN |  |  |  | !0,1
7 | 1 | ASSIGN |  |  |  | !1,'x'
8 | 2 | FETCH_RW | local |  | $2 | !1
 | 3 | POST_INC |  |  | ~3 | $2
 | 4 | FREE |  |  |  | ~3
9 | 5 | RETURN |  |  |  | 1
FETCH_R
FETCH_UNSET
Opcode Descriptions and Examples


FETCH_UNSET

PHP code

<?php
/*
 * Fetch a variable for the purpose of unset() operation.
 * opcode number: 95
 * No sample PHP yet */
?>
FETCH_RW
FETCH_W
Opcode Descriptions and Examples


FETCH_W

PHP code

<?php
/*
 * Fetch the value of the varible of "name" to assign it to a variable?  Write-only?
 * opcode number: 83
 */
$x = 1;
$a = 'x';
$$a = 2;
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$x, !1=$a

line | # | op | fetch | ext | return | operands
6 | 0 | ASSIGN |  |  |  | !0,1
7 | 1 | ASSIGN |  |  |  | !1,'x'
8 | 2 | FETCH_W | local |  | $2 | !1
 | 3 | ASSIGN |  |  |  | $2,2
9 | 4 | RETURN |  |  |  | 1
FETCH_UNSET
FREE
Opcode Descriptions and Examples


FREE

PHP code

<?php
/*
 * Release the allocated space of the value.
 * opcode number: 70
 */
 print "Hello World";
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | PRINT |  |  | ~0 | 'Hello+World'
 | 1 | FREE |  |  |  | ~0
7 | 2 | RETURN |  |  |  | 1
FETCH_W
GOTO
Opcode Descriptions and Examples


GOTO

PHP code

<?php
/*
 *
 * opcode number: 100
 * No sample PHP yet */
?>
FREE
HANDLE_EXCEPTION
Opcode Descriptions and Examples


HANDLE_EXCEPTION

PHP code

<?php
/*
 *
 * opcode number: 149
 */
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | RETURN |  |  |  | 1
GOTO
INCLUDE_OR_EVAL
Opcode Descriptions and Examples


INCLUDE_OR_EVAL

PHP code

<?php
/*
 * Include the file specified by filename and eval it.
 * opcode number: 73
 */
include("test.php");
eval("test.php");
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | INCLUDE_OR_EVAL |  |  |  | 'test.php',INCLUDE
7 | 1 | INCLUDE_OR_EVAL |  |  |  | 'test.php',EVAL
8 | 2 | RETURN |  |  |  | 1

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
2 | 0 | DO_FCALL |  | 0 |  | 'phpinfo'
3 | 1 | RETURN |  |  |  | 1
HANDLE_EXCEPTION
INIT_ARRAY
Opcode Descriptions and Examples


INIT_ARRAY

PHP code

<?php
/*
 * Allocate a new array with elem-value as the first element of the array.  Followed by ADD_ARRAY_ELEMENT.
 * opcode number: 71
 */
$a = array(1,2,3);
print_r($a);
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$a

line | # | op | fetch | ext | return | operands
6 | 0 | INIT_ARRAY |  |  | ~0 | 1
 | 1 | ADD_ARRAY_ELEMENT |  |  | ~0 | 2
 | 2 | ADD_ARRAY_ELEMENT |  |  | ~0 | 3
 | 3 | ASSIGN |  |  |  | !0,~0
7 | 4 | SEND_VAR |  |  |  | !0
 | 5 | DO_FCALL |  | 1 |  | 'print_r'
8 | 6 | RETURN |  |  |  | 1
INCLUDE_OR_EVAL
INIT_FCALL_BY_NAME
Opcode Descriptions and Examples


INIT_FCALL_BY_NAME

PHP code

<?php
/*
 * prepare for a function call to function value1
 * opcode number: 59
 */
$x = 'phpinfo';
$a = $x();
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$x, !1=$a

line | # | op | fetch | ext | return | operands
6 | 0 | ASSIGN |  |  |  | !0,'phpinfo'
7 | 1 | INIT_FCALL_BY_NAME |  |  |  | !0
 | 2 | DO_FCALL_BY_NAME |  | 0 |  |
 | 3 | ASSIGN |  |  |  | !1,$1
8 | 4 | RETURN |  |  |  | 1
INIT_ARRAY
INIT_METHOD_CALL
Opcode Descriptions and Examples


INIT_METHOD_CALL

PHP code

<?php
/*
 * Prepare for a method call.  Followed by DO_FCALL.
 * opcode number: 112
 */
class A {
  var $num;
    function incrementNum(){
    $num++;
  }
}

$obj = new A();
$obj->incrementNum();

?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$obj

line | # | op | fetch | ext | return | operands
6 | 0 | NOP |  |  |  |
13 | 1 | ZEND_FETCH_CLASS |  |  | :1 | 'A'
 | 2 | NEW |  |  | $2 | :1
 | 3 | DO_FCALL_BY_NAME |  | 0 |  |
 | 4 | ASSIGN |  |  |  | !0,$2
14 | 5 | ZEND_INIT_METHOD_CALL |  |  |  | !0,'incrementNum'
 | 6 | DO_FCALL_BY_NAME |  | 0 |  |
16 | 7 | RETURN |  |  |  | 1

Function name: incrementNum

Compiled variables: !0=$num

line | # | op | fetch | ext | return | operands
9 | 0 | POST_INC |  |  | ~0 | !0
 | 1 | FREE |  |  |  | ~0
10 | 2 | RETURN |  |  |  | null
INIT_FCALL_BY_NAME
INIT_NS_FCALL_BY_NAME
Opcode Descriptions and Examples


INIT_NS_FCALL_BY_NAME

PHP code

<?php
/*
 *
 * opcode number: 69
 * No sample PHP yet */
?>
INIT_METHOD_CALL
INIT_STATIC_METHOD_CALL
Opcode Descriptions and Examples


INIT_STATIC_METHOD_CALL

PHP code

<?php
/*
 *
 * opcode number: 113
 */
class Foo {
    public static function aStaticMethod() {
            echo "hello world\n";
    }
}

Foo::aStaticMethod();
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | NOP |  |  |  |
12 | 1 | ZEND_INIT_STATIC_METHOD_CALL |  |  |  | 'Foo','aStaticMethod'
 | 2 | ZEND_OP_DATA |  |  |  | 'foo%3A%3Aastaticmethod'
 | 3 | DO_FCALL_BY_NAME |  | 0 |  |
13 | 4 | RETURN |  |  |  | 1

Function name: aStaticMethod

Compiled variables: none

line | # | op | fetch | ext | return | operands
8 | 0 | ECHO |  |  |  | 'hello+world%0A'
9 | 1 | RETURN |  |  |  | null
INIT_NS_FCALL_BY_NAME
INIT_STRING
Opcode Descriptions and Examples


INIT_STRING

PHP code

<?php
/*
 * appears to create a string variable in result
 * opcode number: 53
 */
echo "hello$a world";
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$a

line | # | op | fetch | ext | return | operands
6 | 0 | ADD_STRING |  |  | ~0 | 'hello'
 | 1 | ADD_VAR |  |  | ~0 | ~0,!0
 | 2 | ADD_STRING |  |  | ~0 | ~0,'+world'
 | 3 | ECHO |  |  |  | ~0
7 | 4 | RETURN |  |  |  | 1
INIT_STATIC_METHOD_CALL
INSTANCEOF
Opcode Descriptions and Examples


INSTANCEOF

PHP code

<?php
/*
 *
 * opcode number: 138
 */
$obj = new A();

if ($obj instanceof A) {
   echo 'A';
}
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$obj

line | # | op | fetch | ext | return | operands
6 | 0 | ZEND_FETCH_CLASS |  |  | :0 | 'A'
 | 1 | NEW |  |  | $1 | :0
 | 2 | DO_FCALL_BY_NAME |  | 0 |  |
 | 3 | ASSIGN |  |  |  | !0,$1
8 | 4 | ZEND_FETCH_CLASS |  |  | :4 | 'A'
 | 5 | ZEND_INSTANCEOF |  |  | ~5 | !0,$4
 | 6 | JMPZ |  |  |  | ~5,->9
9 | 7 | ECHO |  |  |  | 'A'
10 | 8 | JMP |  |  |  | ->9
11 | 9 | RETURN |  |  |  | 1
INIT_STRING
IS_EQUAL
Opcode Descriptions and Examples


IS_EQUAL

PHP code

<?php
/*
 * compares if value1 and value2 are equal
 * opcode number: 17
 */
echo (1 == 1);
echo (1 == 'c');
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | IS_EQUAL |  |  | ~0 | 1,1
 | 1 | ECHO |  |  |  | ~0
7 | 2 | IS_EQUAL |  |  | ~1 | 1,'c'
 | 3 | ECHO |  |  |  | ~1
8 | 4 | RETURN |  |  |  | 1
INSTANCEOF
IS_IDENTICAL
Opcode Descriptions and Examples


IS_IDENTICAL

PHP code

<?php
/*
 * Compares value1 and value2 to see if they are equal AND have the same type
 * opcode number: 15
 */
echo (1===1);
echo (1==='a');
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | IS_IDENTICAL |  |  | ~0 | 1,1
 | 1 | ECHO |  |  |  | ~0
7 | 2 | IS_IDENTICAL |  |  | ~1 | 1,'a'
 | 3 | ECHO |  |  |  | ~1
8 | 4 | RETURN |  |  |  | 1
IS_EQUAL
IS_NOT_EQUAL
Opcode Descriptions and Examples


IS_NOT_EQUAL

PHP code

<?php
/*
 * compares if value1 and value2 are not equal
 * opcode number: 18
 */
echo (1 != 1);
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | IS_NOT_EQUAL |  |  | ~0 | 1,1
 | 1 | ECHO |  |  |  | ~0
7 | 2 | RETURN |  |  |  | 1
IS_IDENTICAL
IS_NOT_IDENTICAL
Opcode Descriptions and Examples


IS_NOT_IDENTICAL

PHP code

<?php
/*
 * compares value1 and value2 to see if they are unequal or of different types
 * opcode number: 16
 */
echo (1 !== 1);
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | IS_NOT_IDENTICAL |  |  | ~0 | 1,1
 | 1 | ECHO |  |  |  | ~0
7 | 2 | RETURN |  |  |  | 1
IS_NOT_EQUAL
IS_SMALLER
Opcode Descriptions and Examples


IS_SMALLER

PHP code

<?php
/*
 * compares if value1 is less than value2
 * opcode number: 19
 */
echo (1 < 2);
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | IS_SMALLER |  |  | ~0 | 1,2
 | 1 | ECHO |  |  |  | ~0
7 | 2 | RETURN |  |  |  | 1
IS_NOT_IDENTICAL
IS_SMALLER_OR_EQUAL
Opcode Descriptions and Examples


IS_SMALLER_OR_EQUAL

PHP code

<?php
/*
 * compares if value1 is less than or equal to value2
 * opcode number: 20
 */
echo (2 <= 1);
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | IS_SMALLER_OR_EQUAL |  |  | ~0 | 2,1
 | 1 | ECHO |  |  |  | ~0
7 | 2 | RETURN |  |  |  | 1
IS_SMALLER
ISSET_ISEMPTY_DIM_OBJ
Opcode Descriptions and Examples


ISSET_ISEMPTY_DIM_OBJ

PHP code

<?php
/*
 * Tests if the entry of an array is set or not.
 * opcode number: 115
 */
if(isset($a[0])) return 0;
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$a

line | # | op | fetch | ext | return | operands
6 | 0 | ZEND_ISSET_ISEMPTY_DIM_OBJ |  | 1 | ~0 | !0,0
 | 1 | JMPZ |  |  |  | ~0,->4
 | 2 | RETURN |  |  |  | 0
 | 3 | JMP |  |  |  | ->4
7 | 4 | RETURN |  |  |  | 1
IS_SMALLER_OR_EQUAL
ISSET_ISEMPTY_PROP_OBJ
Opcode Descriptions and Examples


ISSET_ISEMPTY_PROP_OBJ

PHP code

<?php
/*
 *
 * opcode number: 148
 */
$obj = new A();
if(empty($obj->num)) return 0;
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$obj

line | # | op | fetch | ext | return | operands
6 | 0 | ZEND_FETCH_CLASS |  |  | :0 | 'A'
 | 1 | NEW |  |  | $1 | :0
 | 2 | DO_FCALL_BY_NAME |  | 0 |  |
 | 3 | ASSIGN |  |  |  | !0,$1
7 | 4 | ZEND_ISSET_ISEMPTY_PROP_OBJ |  |  | ~4 | !0,'num'
 | 5 | JMPZ |  |  |  | ~4,->8
 | 6 | RETURN |  |  |  | 0
 | 7 | JMP |  |  |  | ->8
8 | 8 | RETURN |  |  |  | 1
ISSET_ISEMPTY_DIM_OBJ
ISSET_ISEMPTY_VAR
Opcode Descriptions and Examples


ISSET_ISEMPTY_VAR

PHP code

<?php
/*
 * Tests if the value of a variable is set or not.
 * opcode number: 114
 */
if(isset($a)){ return 0;}
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$a

line | # | op | fetch | ext | return | operands
6 | 0 | ZEND_ISSET_ISEMPTY_VAR |  | 5 | ~0 | !0
 | 1 | JMPZ |  |  |  | ~0,->4
 | 2 | RETURN |  |  |  | 0
 | 3 | JMP |  |  |  | ->4
7 | 4 | RETURN |  |  |  | 1
ISSET_ISEMPTY_PROP_OBJ
JMP
Opcode Descriptions and Examples


JMP

PHP code

<?php
/*
 * Unconditonally jump to the address
 * opcode number: 42
 */
$foo = false;
while(!$foo) {
    $foo = true;
}
?>

PHP opcodes

Function name: (null)

compiled vars: !0 = $foo

line | # | op | fetch | ext | return | operands
6 | 0 | ASSIGN |  |  |  | !0, false
7 | 1 | BOOL_NOT |  |  | ~1 | !0
 | 2 | JMPZ |  |  |  | ~1, ->5
8 | 3 | ASSIGN |  |  |  | !0, true
9 | 4 | JMP |  |  |  | ->1
11 | 5 | RETURN |  |  |  | 1
ISSET_ISEMPTY_VAR
JMPNZ
Opcode Descriptions and Examples


JMPNZ

PHP code

<?php
/*
 * Jump to the address if the value is not zero
 * opcode number: 44
 */
for($i=0; $i<3; $i++){
    echo "hi";
}
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$i

line | # | op | fetch | ext | return | operands
6 | 0 | ASSIGN |  |  |  | !0,0
 | 1 | IS_SMALLER |  |  | ~1 | !0,3
 | 2 | JMPZNZ |  | 6 |  | ~1,->8
 | 3 | POST_INC |  |  | ~2 | !0
 | 4 | FREE |  |  |  | ~2
 | 5 | JMP |  |  |  | ->1
7 | 6 | ECHO |  |  |  | 'hi'
8 | 7 | JMP |  |  |  | ->3
9 | 8 | RETURN |  |  |  | 1
JMP
JMPNZ_EX
Opcode Descriptions and Examples


JMPNZ_EX

PHP code

<?php
/*
 * Jump to the address if the xor of value1 and value2 is zero .. ???
 * opcode number: 47
 */
if(1^2) return;
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | BW_XOR |  |  | ~0 | 1,2
 | 1 | JMPZ |  |  |  | ~0,->4
 | 2 | RETURN |  |  |  | null
 | 3 | JMP |  |  |  | ->4
7 | 4 | RETURN |  |  |  | 1
JMPNZ
JMPZ
Opcode Descriptions and Examples


JMPZ

PHP code

<?php
/*
 * Jump to the address if the value is zero
 * opcode number: 43
 */
if($a != 0) echo "foo";
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$a

line | # | op | fetch | ext | return | operands
6 | 0 | IS_NOT_EQUAL |  |  | ~0 | !0,0
 | 1 | JMPZ |  |  |  | ~0,->4
 | 2 | ECHO |  |  |  | 'foo'
 | 3 | JMP |  |  |  | ->4
7 | 4 | RETURN |  |  |  | 1
JMPNZ_EX
JMPZ_EX
Opcode Descriptions and Examples


JMPZ_EX

PHP code

<?php
/*
 * Jump to the address if the xor of value1 and value2 is zero .. ???
 * opcode number: 46
 */

?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
7 | 0 | RETURN |  |  |  | 1
JMPZ
JMPZNZ
Opcode Descriptions and Examples


JMPZNZ

PHP code

<?php
/*
 * Jump to the address given in the operands if the value is zero;
 * jump to the address given in extended data if nonzero.
 * opcode number: 45
 */
for($i=0; $i<3; $i++){
    echo "hi";
}
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$i

line | # | op | fetch | ext | return | operands
6 | 0 | ASSIGN |  |  |  | !0,0
 | 1 | IS_SMALLER |  |  | ~1 | !0,3
 | 2 | JMPZNZ |  | 6 |  | ~1,->8
 | 3 | POST_INC |  |  | ~2 | !0
 | 4 | FREE |  |  |  | ~2
 | 5 | JMP |  |  |  | ->1
7 | 6 | ECHO |  |  |  | 'hi'
8 | 7 | JMP |  |  |  | ->3
9 | 8 | RETURN |  |  |  | 1
JMPZ_EX
MOD
Opcode Descriptions and Examples


MOD

PHP code

<?php
/*
 * Makes the value of "result" congruent to "value1" modulo "value2".
 * opcode number: 5
 */
echo 6 % 3;
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | MOD |  |  | ~0 | 6,3
 | 1 | ECHO |  |  |  | ~0
7 | 2 | RETURN |  |  |  | 1
JMPZNZ
MUL
Opcode Descriptions and Examples


MUL

PHP code

<?php
/*
 * Multiplys "value1" by "value2" and stores the result into "result".
 * opcode number: 3
 */
echo 2*3;
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | MUL |  |  | ~0 | 2,3
 | 1 | ECHO |  |  |  | ~0
7 | 2 | RETURN |  |  |  | 1
MOD
NEW
Opcode Descriptions and Examples


NEW

PHP code

<?php
/*
 * Construct an instance of "type" and store the reference to the object into "result".
 * opcode number: 68
 */
$obj = new A();
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$obj

line | # | op | fetch | ext | return | operands
6 | 0 | ZEND_FETCH_CLASS |  |  | :0 | 'A'
 | 1 | NEW |  |  | $1 | :0
 | 2 | DO_FCALL_BY_NAME |  | 0 |  |
 | 3 | ASSIGN |  |  |  | !0,$1
7 | 4 | RETURN |  |  |  | 1
MUL
NOP
Opcode Descriptions and Examples


NOP

PHP code

<?php
/*
 * no operation
 * opcode number: 0
 */
function A(){};
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | NOP |  |  |  |
7 | 1 | RETURN |  |  |  | 1

Function name: A

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | RETURN |  |  |  | null
NEW
POST_DEC
Opcode Descriptions and Examples


POST_DEC

PHP code

<?php
/*
 * decrements variable indicated by value1 by 1 (after performing other operations) and stores in result
 * opcode number: 37
 */
$a--;
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$a

line | # | op | fetch | ext | return | operands
6 | 0 | POST_DEC |  |  | ~0 | !0
 | 1 | FREE |  |  |  | ~0
7 | 2 | RETURN |  |  |  | 1
NOP
POST_DEC_OBJ
Opcode Descriptions and Examples


POST_DEC_OBJ

PHP code

<?php
/*
 *
 * opcode number: 135
 */
$obj = new A();
$obj->num--;
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$obj

line | # | op | fetch | ext | return | operands
6 | 0 | ZEND_FETCH_CLASS |  |  | :0 | 'A'
 | 1 | NEW |  |  | $1 | :0
 | 2 | DO_FCALL_BY_NAME |  | 0 |  |
 | 3 | ASSIGN |  |  |  | !0,$1
7 | 4 | ZEND_POST_DEC_OBJ |  |  | ~5 | !0,'num'
 | 5 | FREE |  |  |  | ~5
8 | 6 | RETURN |  |  |  | 1
POST_DEC
POST_INC
Opcode Descriptions and Examples


POST_INC

PHP code

<?php
/*
 * increments variable indicated by value1 by 1 (after performing other operations) and stores in result
 * opcode number: 36
 */
$a++;
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$a

line | # | op | fetch | ext | return | operands
6 | 0 | POST_INC |  |  | ~0 | !0
 | 1 | FREE |  |  |  | ~0
7 | 2 | RETURN |  |  |  | 1
POST_DEC_OBJ
POST_INC_OBJ
Opcode Descriptions and Examples


POST_INC_OBJ

PHP code

<?php
/*
 * Increment the property value specified by prop-name and store the original value into result.
 * opcode number: 134
 */
$obj = new A();
$obj->num++;
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$obj

line | # | op | fetch | ext | return | operands
6 | 0 | ZEND_FETCH_CLASS |  |  | :0 | 'A'
 | 1 | NEW |  |  | $1 | :0
 | 2 | DO_FCALL_BY_NAME |  | 0 |  |
 | 3 | ASSIGN |  |  |  | !0,$1
7 | 4 | ZEND_POST_INC_OBJ |  |  | ~5 | !0,'num'
 | 5 | FREE |  |  |  | ~5
8 | 6 | RETURN |  |  |  | 1
POST_INC
PRE_DEC
Opcode Descriptions and Examples


PRE_DEC

PHP code

<?php
/*
 * decrements variable indicated by value1 by 1 (before performing other operations) and stores in results
 * opcode number: 35
 */
--$a;
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$a

line | # | op | fetch | ext | return | operands
6 | 0 | PRE_DEC |  |  |  | !0
7 | 1 | RETURN |  |  |  | 1
POST_INC_OBJ
PRE_DEC_OBJ
Opcode Descriptions and Examples


PRE_DEC_OBJ

PHP code

<?php
/*
 *
 * opcode number: 133
 */
$obj = new A();
--$obj->num;
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$obj

line | # | op | fetch | ext | return | operands
6 | 0 | ZEND_FETCH_CLASS |  |  | :0 | 'A'
 | 1 | NEW |  |  | $1 | :0
 | 2 | DO_FCALL_BY_NAME |  | 0 |  |
 | 3 | ASSIGN |  |  |  | !0,$1
7 | 4 | ZEND_PRE_DEC_OBJ |  |  |  | !0,'num'
8 | 5 | RETURN |  |  |  | 1
PRE_DEC
PRE_INC
Opcode Descriptions and Examples


PRE_INC

PHP code

<?php
/*
 * increments variable indicated by value1 by 1 (before performing other operations) and stores in result
 * opcode number: 34
 */
++$a;
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$a

line | # | op | fetch | ext | return | operands
6 | 0 | PRE_INC |  |  |  | !0
7 | 1 | RETURN |  |  |  | 1
PRE_DEC_OBJ
PRE_INC_OBJ
Opcode Descriptions and Examples


PRE_INC_OBJ

PHP code

<?php
/*
 *
 * opcode number: 132
 */
$obj = new A();
++$obj->num;
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$obj

line | # | op | fetch | ext | return | operands
6 | 0 | ZEND_FETCH_CLASS |  |  | :0 | 'A'
 | 1 | NEW |  |  | $1 | :0
 | 2 | DO_FCALL_BY_NAME |  | 0 |  |
 | 3 | ASSIGN |  |  |  | !0,$1
7 | 4 | ZEND_PRE_INC_OBJ |  |  |  | !0,'num'
8 | 5 | RETURN |  |  |  | 1
PRE_INC
PRINT
Opcode Descriptions and Examples


PRINT

PHP code

<?php
/*
 *
 * opcode number: 41
 */
print "Hello World";
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | PRINT |  |  | ~0 | 'Hello+World'
 | 1 | FREE |  |  |  | ~0
7 | 2 | RETURN |  |  |  | 1
PRE_INC_OBJ
QM_ASSIGN
Opcode Descriptions and Examples


QM_ASSIGN

PHP code

<?php
/*
 * Question Mark Assign, used twice inside a question mark assign to temporarily assign result as value1  (this is followed up with an ASSIGN bytecode)
 * opcode number: 22
 */
function A(){
 echo 1?2:3;
}

function B(){
 $b = 0;
 $a = $b > 1 ? 10: 11;
}
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | NOP |  |  |  |
10 | 1 | NOP |  |  |  |
14 | 2 | RETURN |  |  |  | 1

Function name: A

Compiled variables: none

line | # | op | fetch | ext | return | operands
7 | 0 | JMPZ |  |  |  | 1,->3
 | 1 | QM_ASSIGN |  |  | ~0 | 2
 | 2 | JMP |  |  |  | ->4
 | 3 | QM_ASSIGN |  |  | ~0 | 3
 | 4 | ECHO |  |  |  | ~0
8 | 5 | RETURN |  |  |  | null

Function name: B

Compiled variables: !0=$b, !1=$a

line | # | op | fetch | ext | return | operands
11 | 0 | ASSIGN |  |  |  | !0,0
12 | 1 | IS_SMALLER |  |  | ~1 | 1,!0
 | 2 | JMPZ |  |  |  | ~1,->5
 | 3 | QM_ASSIGN |  |  | ~2 | 10
 | 4 | JMP |  |  |  | ->6
 | 5 | QM_ASSIGN |  |  | ~2 | 11
 | 6 | ASSIGN |  |  |  | !1,~2
13 | 7 | RETURN |  |  |  | null
PRINT
RAISE_ABSTRACT_ERROR
Opcode Descriptions and Examples


RAISE_ABSTRACT_ERROR

PHP code

<?php
/*
 *
 * opcode number: 142
 */

abstract class fail {
    abstract function show();
}

class pass extends fail {
    function show() {
        echo "Call to function show()\n";
    }
}

$t2 = new pass();
$t2->show();

$t = new fail();
$t->show();

echo "Done\n"; // shouldn't be displayed
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$t2, !1=$t

line | # | op | fetch | ext | return | operands
7 | 0 | NOP |  |  |  |
11 | 1 | NOP |  |  |  |
 | 2 | NOP |  |  |  |
17 | 3 | ZEND_FETCH_CLASS |  |  | :3 | 'pass'
 | 4 | NEW |  |  | $4 | :3
 | 5 | DO_FCALL_BY_NAME |  | 0 |  |
 | 6 | ASSIGN |  |  |  | !0,$4
18 | 7 | ZEND_INIT_METHOD_CALL |  |  |  | !0,'show'
 | 8 | DO_FCALL_BY_NAME |  | 0 |  |
20 | 9 | ZEND_FETCH_CLASS |  |  | :9 | 'fail'
 | 10 | NEW |  |  | $10 | :9
 | 11 | DO_FCALL_BY_NAME |  | 0 |  |
 | 12 | ASSIGN |  |  |  | !1,$10
21 | 13 | ZEND_INIT_METHOD_CALL |  |  |  | !1,'show'
 | 14 | DO_FCALL_BY_NAME |  | 0 |  |
23 | 15 | ECHO |  |  |  | 'Done%0A'
24 | 16 | RETURN |  |  |  | 1

Function name: show

Compiled variables: none

line | # | op | fetch | ext | return | operands
8 | 0 | ZEND_RAISE_ABSTRACT_ERROR |  |  |  |
 | 1 | RETURN |  |  |  | null

Function name: show

Compiled variables: none

line | # | op | fetch | ext | return | operands
13 | 0 | ECHO |  |  |  | 'Call+to+function+show%28%29%0A'
14 | 1 | RETURN |  |  |  | null
QM_ASSIGN
RECV
Opcode Descriptions and Examples


RECV

PHP code

<?php
/*
 * Receive a functoin argument of "argument-number" and store the argument value into a variable of "argument-number".  (e.g. $1 for 1)
 * opcode number: 63
 */
function hello($a){}
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | NOP |  |  |  |
7 | 1 | RETURN |  |  |  | 1

Function name: hello

Compiled variables: !0=$a

line | # | op | fetch | ext | return | operands
6 | 0 | RECV |  |  |  | 1
 | 1 | RETURN |  |  |  | null
RAISE_ABSTRACT_ERROR
RECV_INIT
Opcode Descriptions and Examples


RECV_INIT

PHP code

<?php
/*
 * Initialize a function argument with "value" if not received from caller.  Otherwise same as RECV.
 * opcode number: 64
 */
function hello($a=5){}
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | NOP |  |  |  |
7 | 1 | RETURN |  |  |  | 1

Function name: hello

Compiled variables: !0=$a

line | # | op | fetch | ext | return | operands
6 | 0 | RECV_INIT |  |  |  | 1,5
 | 1 | RETURN |  |  |  | null
RECV
RETURN
Opcode Descriptions and Examples


RETURN

PHP code

<?php
/*
 * Return value from a funciton.
 * opcode number: 62
 */
return 1;
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | RETURN |  |  |  | 1
7 | 1 | RETURN |  |  |  | 1
RECV_INIT
RETURN_BY_REF
Opcode Descriptions and Examples


RETURN_BY_REF

PHP code

<?php
/*
 *
 * opcode number: 111
 * No sample PHP yet */
?>
RETURN
SEND_REF
Opcode Descriptions and Examples


SEND_REF

PHP code

<?php
/*
 * Pass the reference value as an actual parameter to a function.  DO_FCALL follows.
 * opcode number: 67
 */
@each($input);
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | BEGIN_SILENCE |  |  | ~0 |
 | 1 | FETCH_W | local |  | $1 | 'input'
 | 2 | SEND_REF |  |  |  | $1
 | 3 | DO_FCALL |  | 1 |  | 'each'
 | 4 | END_SILENCE |  |  |  | ~0
7 | 5 | RETURN |  |  |  | 1
RETURN_BY_REF
SEND_VAL
Opcode Descriptions and Examples


SEND_VAL

PHP code

<?php
/*
 * Pass the constant value as an actual parameter to a function.  DO_FCALL follows.
 * opcode number: 65
 */
function funcA($msg){
    print $msg;
}

funcA('HELLO');

defined('IN_PHPBB');
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | NOP |  |  |  |
10 | 1 | SEND_VAL |  |  |  | 'HELLO'
 | 2 | DO_FCALL |  | 1 |  | 'funca'
12 | 3 | SEND_VAL |  |  |  | 'IN_PHPBB'
 | 4 | DO_FCALL |  | 1 |  | 'defined'
13 | 5 | RETURN |  |  |  | 1

Function name: funcA

Compiled variables: !0=$msg

line | # | op | fetch | ext | return | operands
6 | 0 | RECV |  |  |  | 1
7 | 1 | PRINT |  |  | ~0 | !0
 | 2 | FREE |  |  |  | ~0
8 | 3 | RETURN |  |  |  | null
SEND_REF
SEND_VAR
Opcode Descriptions and Examples


SEND_VAR

PHP code

<?php
/*
 * Pass the variable value as an actual parameter to a function.  DO_FCALL follows.
 * opcode number: 66
 */
$a = array(1,2,3);
if(is_array($a)){ return 0; }
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$a

line | # | op | fetch | ext | return | operands
6 | 0 | INIT_ARRAY |  |  | ~0 | 1
 | 1 | ADD_ARRAY_ELEMENT |  |  | ~0 | 2
 | 2 | ADD_ARRAY_ELEMENT |  |  | ~0 | 3
 | 3 | ASSIGN |  |  |  | !0,~0
7 | 4 | SEND_VAR |  |  |  | !0
 | 5 | DO_FCALL |  | 1 |  | 'is_array'
 | 6 | JMPZ |  |  |  | $2,->9
 | 7 | RETURN |  |  |  | 0
 | 8 | JMP |  |  |  | ->9
8 | 9 | RETURN |  |  |  | 1
SEND_VAL
SEND_VAR_NO_REF
Opcode Descriptions and Examples


SEND_VAR_NO_REF

PHP code

<?php
/*
 *
 * opcode number: 106
 * No sample PHP yet */
?>
SEND_VAR
SL
Opcode Descriptions and Examples


SL

PHP code

<?php
/*
 * Shift bits of value1 to the left value2 steps (each step means "multiply by two")
 * opcode number: 6
 */
echo 8 << 2;
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | SL |  |  | ~0 | 8,2
 | 1 | ECHO |  |  |  | ~0
7 | 2 | RETURN |  |  |  | 1
SEND_VAR_NO_REF
SR
Opcode Descriptions and Examples


SR

PHP code

<?php
/*
 * Shift bits of value1 to the right value2 steps (each step means "divide by two")
 * opcode number: 7
 */
echo 8 >> 2;
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | SR |  |  | ~0 | 8,2
 | 1 | ECHO |  |  |  | ~0
7 | 2 | RETURN |  |  |  | 1
SL
SUB
Opcode Descriptions and Examples


SUB

PHP code

<?php
/*
 * Subtracts "value2" from "value1" and stores the result into "result".
 * opcode number: 2
 */
echo 1-2;
?>

PHP opcodes

Function name: (null)

Compiled variables: none

line | # | op | fetch | ext | return | operands
6 | 0 | SUB |  |  | ~0 | 1,2
 | 1 | ECHO |  |  |  | ~0
7 | 2 | RETURN |  |  |  | 1
SR
SWITCH_FREE
Opcode Descriptions and Examples


SWITCH_FREE

PHP code

<?php
/*
 * Release the allocated space of "value"?
 * opcode number: 49
 */
$a = array(1,2,3);
foreach($a as $num){
    print $num;
}
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$a, !1=$num

line | # | op | fetch | ext | return | operands
6 | 0 | INIT_ARRAY |  |  | ~0 | 1
 | 1 | ADD_ARRAY_ELEMENT |  |  | ~0 | 2
 | 2 | ADD_ARRAY_ELEMENT |  |  | ~0 | 3
 | 3 | ASSIGN |  |  |  | !0,~0
7 | 4 | FE_RESET |  |  | $2 | !0,->11
 | 5 | FE_FETCH |  |  | $3 | $2,->11
 | 6 | ZEND_OP_DATA |  |  |  |
 | 7 | ASSIGN |  |  |  | !1,$3
8 | 8 | PRINT |  |  | ~5 | !1
 | 9 | FREE |  |  |  | ~5
9 | 10 | JMP |  |  |  | ->5
 | 11 | SWITCH_FREE |  |  |  | $2
10 | 12 | RETURN |  |  |  | 1
SUB
THROW
Opcode Descriptions and Examples


THROW

PHP code

<?php
/*
 *
 * opcode number: 108
 */
try {
    $error = 'Always throw this error';
    throw new Exception($error);

    // Code following an exception is not executed.
    echo 'Never executed';

} catch (Exception $e) {
    echo 'Caught exception: ',  $e->getMessage(), "\n";
}

// Continue execution
echo 'Hello World';
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$error, !1=$e

line | # | op | fetch | ext | return | operands
7 | 0 | ASSIGN |  |  |  | !0,'Always+throw+this+error'
8 | 1 | ZEND_FETCH_CLASS |  |  | :1 | 'Exception'
 | 2 | NEW |  |  | $2 | :1
 | 3 | SEND_VAR |  |  |  | !0
 | 4 | DO_FCALL_BY_NAME |  | 1 |  |
 | 5 | ZEND_THROW |  | 0 |  | $2
11 | 6 | ECHO |  |  |  | 'Never+executed'
13 | 7 | JMP |  |  |  | ->15
 | 8 | ZEND_FETCH_CLASS |  |  | :4 | 'Exception'
 | 9 | ZEND_CATCH |  | 15 |  | $4,!1
14 | 10 | ECHO |  |  |  | 'Caught+exception%3A+'
 | 11 | ZEND_INIT_METHOD_CALL |  |  |  | !1,'getMessage'
 | 12 | DO_FCALL_BY_NAME |  | 0 |  |
 | 13 | ECHO |  |  |  | $6
 | 14 | ECHO |  |  |  | '%0A'
18 | 15 | ECHO |  |  |  | 'Hello+World'
19 | 16 | RETURN |  |  |  | 1
SWITCH_FREE
TICKS
Opcode Descriptions and Examples


TICKS

PHP code

<?php
/*
 *
 * opcode number: 105
 */
// A function that records the time when it is called
function profile()
{
   echo "profile function is called\n";
}

// Set up a tick handler
register_tick_function("profile");

// Initialize the function before the declare block
profile();

// Run a block of code, throw a tick every 2nd statement
declare(ticks=2) {
   for ($x = 0; $x < 10; ++$x) {
         echo "hello world\n";
   }
}
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$x

line | # | op | fetch | ext | return | operands
7 | 0 | NOP |  |  |  |
13 | 1 | SEND_VAL |  |  |  | 'profile'
 | 2 | DO_FCALL |  | 1 |  | 'register_tick_function'
16 | 3 | DO_FCALL |  | 0 |  | 'profile'
20 | 4 | ASSIGN |  |  |  | !0,0
 | 5 | IS_SMALLER |  |  | ~3 | !0,10
 | 6 | JMPZNZ |  | 9 |  | ~3,->13
 | 7 | PRE_INC |  |  |  | !0
 | 8 | JMP |  |  |  | ->5
21 | 9 | ECHO |  |  |  | 'hello+world%0A'
 | 10 | TICKS |  |  |  | 2
22 | 11 | TICKS |  |  |  | 2
 | 12 | JMP |  |  |  | ->7
 | 13 | TICKS |  |  |  | 2
23 | 14 | TICKS |  |  |  | 2
24 | 15 | RETURN |  |  |  | 1

Function name: profile

Compiled variables: none

line | # | op | fetch | ext | return | operands
9 | 0 | ECHO |  |  |  | 'profile+function+is+called%0A'
10 | 1 | RETURN |  |  |  | null
THROW
UNSET_DIM
Opcode Descriptions and Examples


UNSET_DIM

PHP code

<?php
/*
 * Unset the entry of array-value, which is specified by index, and store the original element value into "result".
 * opcode number: 75
 */
$a = array(1,2,3);
unset($a[0]);
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$a

line | # | op | fetch | ext | return | operands
6 | 0 | INIT_ARRAY |  |  | ~0 | 1
 | 1 | ADD_ARRAY_ELEMENT |  |  | ~0 | 2
 | 2 | ADD_ARRAY_ELEMENT |  |  | ~0 | 3
 | 3 | ASSIGN |  |  |  | !0,~0
7 | 4 | UNSET_DIM |  |  | $2 | !0,0
8 | 5 | RETURN |  |  |  | 1
TICKS
UNSET_OBJ
Opcode Descriptions and Examples


UNSET_OBJ

PHP code

<?php
/*
 * Unset the property of the current object (this) and store the original value into "result".
 * opcode number: 76
 */
$obj = new A();
unset($obj->num);
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$obj

line | # | op | fetch | ext | return | operands
6 | 0 | ZEND_FETCH_CLASS |  |  | :0 | 'A'
 | 1 | NEW |  |  | $1 | :0
 | 2 | DO_FCALL_BY_NAME |  | 0 |  |
 | 3 | ASSIGN |  |  |  | !0,$1
7 | 4 | UNSET_OBJ |  |  | $4 | !0,'num'
8 | 5 | RETURN |  |  |  | 1
UNSET_DIM
UNSET_VAR
Opcode Descriptions and Examples


UNSET_VAR

PHP code

<?php
/*
 * Unset the variable and store the original value into "result".
 * opcode number: 74
 */
$x = 1;
$a='x';
unset($$a);
?>

PHP opcodes

Function name: (null)

Compiled variables: !0=$x, !1=$a

line | # | op | fetch | ext | return | operands
6 | 0 | ASSIGN |  |  |  | !0,1
7 | 1 | ASSIGN |  |  |  | !1,'x'
8 | 2 | UNSET_VAR |  |  | $2 | !1
9 | 3 | RETURN |  |  |  | 1
UNSET_OBJ
USER_OPCODE
Opcode Descriptions and Examples


USER_OPCODE

PHP code

<?php
/*
 *
 * opcode number: 150
 * No sample PHP yet */
?>
UNSET_VAR
VERIFY_ABSTRACT_CLASS
Opcode Descriptions and Examples


VERIFY_ABSTRACT_CLASS

PHP code

<?php
/*
 *
 * opcode number: 146
 * No sample PHP yet */
?>
USER_OPCODE
ZEND_DECLARE_LAMBDA_FUNCTION
Opcode Descriptions and Examples


ZEND_DECLARE_LAMBDA_FUNCTION

PHP code

<?php
/*
 *
 * opcode number: 153
 * No sample PHP yet */
?>
VERIFY_ABSTRACT_CLASS
ZEND_JMP_SET
Opcode Descriptions and Examples


ZEND_JMP_SET

PHP code

<?php
/*
 *
 * opcode number: 152
 * No sample PHP yet */
?>
ZEND_DECLARE_LAMBDA_FUNCTION
Zend Engine 1
Opcode Descriptions and Examples


Zend Engine 1

İçindekiler

  • Old introduction
  • Streams API for PHP Extension Authors
  • Zend API; PHP Çekirdeğinin Geliştirilmesi
  • TSRM API

Zend Engine 1 is the internal engine used by PHP for the entire version 4 release line. It is no longer considered active, but the old ZE1 documentation is preserved here exactly as it was.

ZEND_JMP_SET
Old introduction
PHP’nin Çekirdeği; Çekirdek geliştiricilerin Rehberi


Old introduction

If you are about to begin developing PHP or Zend extensions, you need to prepare yourself for the programming environment provided by the various APIs. This part of the documentation tries to introduce the APIs provided by the different PHP and Zend Engine versions available. Since most of the information available here is somewhat outdated, you'll want to read various files found in the PHP source, files such as README.SELF-CONTAINED-EXTENSIONS and README.EXT_SKEL in addition to the manual.

Zend Engine 1
Streams API for PHP Extension Authors
Zend Engine 1


Streams API for PHP Extension Authors

Bilginize:

The functions in this chapter are for use in the PHP source code and are not PHP functions. Information on userland stream functions can be found in the Stream Reference.

Overview

The PHP Streams API introduces a unified approach to the handling of files and sockets in PHP extension. Using a single API with standard functions for common operations, the streams API allows your extension to access files, sockets, URLs, memory and script-defined objects. Streams is a run-time extensible API that allows dynamically loaded modules (and scripts!) to register new streams.

The aim of the Streams API is to make it comfortable for developers to open files, URLs and other streamable data sources with a unified API that is easy to understand. The API is more or less based on the ANSI C stdio family of functions (with identical semantics for most of the main functions), so C programmers will have a feeling of familiarity with streams.

The streams API operates on a couple of different levels: at the base level, the API defines php_stream objects to represent streamable data sources. On a slightly higher level, the API defines php_stream_wrapper objects which "wrap" around the lower level API to provide support for retrieving data and meta-data from URLs. An additional context parameter, accepted by most stream creation functions, is passed to the wrapper's stream_opener method to fine-tune the behavior of the wrapper.

Any stream, once opened, can also have any number of filters applied to it, which process data as it is read from/written to the stream.

Streams can be cast (converted) into other types of file-handles, so that they can be used with third-party libraries without a great deal of trouble. This allows those libraries to access data directly from URL sources. If your system has the fopencookie() or funopen() function, you can even pass any PHP stream to any library that uses ANSI stdio!

Streams Basics

Using streams is very much like using ANSI stdio functions. The main difference is in how you obtain the stream handle to begin with. In most cases, you will use php_stream_open_wrapper() to obtain the stream handle. This function works very much like fopen, as can be seen from the example below:

Örnek 1 simple stream example that displays the PHP home page

php_stream * stream = php_stream_open_wrapper("http://www.php.net", "rb", REPORT_ERRORS, NULL);
if (stream) {
    while(!php_stream_eof(stream)) {
        char buf[1024];

        if (php_stream_gets(stream, buf, sizeof(buf))) {
            printf(buf);
        } else {
            break;
        }
    }
    php_stream_close(stream);
}

The table below shows the Streams equivalents of the more common ANSI stdio functions. Unless noted otherwise, the semantics of the functions are identical.

ANSI stdio equivalent functions in the Streams API
ANSI Stdio Function | PHP Streams Function | Notes
fopen | php_stream_open_wrapper | Streams includes additional parameters
fclose | php_stream_close |
fgets | php_stream_gets |
fread | php_stream_read | The nmemb parameter is assumed to have a value of 1, so the prototype looks more like read(2)
fwrite | php_stream_write | The nmemb parameter is assumed to have a value of 1, so the prototype looks more like write(2)
fseek | php_stream_seek |
ftell | php_stream_tell |
rewind | php_stream_rewind |
feof | php_stream_eof |
fgetc | php_stream_getc |
fputc | php_stream_putc |
fflush | php_stream_flush |
puts | php_stream_puts | Same semantics as puts, NOT fputs
fstat | php_stream_stat | Streams has a richer stat structure

Streams as Resources

All streams are registered as resources when they are created. This ensures that they will be properly cleaned up even if there is some fatal error. All of the filesystem functions in PHP operate on streams resources - that means that your extensions can accept regular PHP file pointers as parameters to, and return streams from their functions. The streams API makes this process as painless as possible:

Örnek 2 How to accept a stream as a parameter

PHP_FUNCTION(example_write_hello)
{
    zval *zstream;
    php_stream *stream;

    if (FAILURE == zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "r", &zstream))
        return;

    php_stream_from_zval(stream, &zstream);

    /* you can now use the stream.  However, you do not "own" the
        stream, the script does.  That means you MUST NOT close the
        stream, because it will cause PHP to crash! */

    php_stream_write(stream, "hello\n");

    RETURN_TRUE();
}

Örnek 3 How to return a stream from a function

PHP_FUNCTION(example_open_php_home_page)
{
    php_stream *stream;

    stream = php_stream_open_wrapper("http://www.php.net", "rb", REPORT_ERRORS, NULL);

    php_stream_to_zval(stream, return_value);

    /* after this point, the stream is "owned" by the script.
        If you close it now, you will crash PHP! */
}

Since streams are automatically cleaned up, it's tempting to think that we can get away with being sloppy programmers and not bother to close the streams when we are done with them. Although such an approach might work, it is not a good idea for a number of reasons: streams hold locks on system resources while they are open, so leaving a file open after you have finished with it could prevent other processes from accessing it. If a script deals with a large number of files, the accumulation of the resources used, both in terms of memory and the sheer number of open files, can cause web server requests to fail. Sounds bad, doesn't it? The streams API includes some magic that helps you to keep your code clean - if a stream is not closed by your code when it should be, you will find some helpful debugging information in you web server error log.

Bilginize: Always use a debug build of PHP when developing an extension (--enable-debug when running configure), as a lot of effort has been made to warn you about memory and stream leaks.

In some cases, it is useful to keep a stream open for the duration of a request, to act as a log or trace file for example. Writing the code to safely clean up such a stream is not difficult, but it's several lines of code that are not strictly needed. To save yourself the trouble of writing the code, you can mark a stream as being OK for auto cleanup. What this means is that the streams API will not emit a warning when it is time to auto-cleanup a stream. To do this, you can use php_stream_auto_cleanup().

Streams open options

These constants affect the operation of stream factory functions.

IGNORE_PATH
This is the default option for streams; it requests that the include_path is not to be searched for the requested file.
USE_PATH
Requests that the include_path is to be searched for the requested file.
IGNORE_URL
Requests that registered URL wrappers are to be ignored when opening the stream. Other non-URL wrappers will be taken into consideration when decoding the path. There is no opposite form for this flag; the streams API will use all registered wrappers by default.
IGNORE_URL_WIN
On Windows systems, this is equivalent to IGNORE_URL. On all other systems, this flag has no effect.
ENFORCE_SAFE_MODE
Requests that the underlying stream implementation perform safe_mode checks on the file before opening the file. Omitting this flag will skip safe_mode checks and allow opening of any file that the PHP process has rights to access.
REPORT_ERRORS
If this flag is set, and there was an error during the opening of the file or URL, the streams API will call the php_error function for you. This is useful because the path may contain username/password information that should not be displayed in the browser output (it would be a security risk to do so). When the streams API raises the error, it first strips username/password information from the path, making the error message safe to display in the browser.
STREAM_MUST_SEEK
This flag is useful when your extension really must be able to randomly seek around in a stream. Some streams may not be seekable in their native form, so this flag asks the streams API to check to see if the stream does support seeking. If it does not, it will copy the stream into temporary storage (which may be a temporary file or a memory stream) which does support seeking. Please note that this flag is not useful when you want to seek the stream and write to it, because the stream you are accessing might not be bound to the actual resource you requested.

Bilginize: If the requested resource is network based, this flag will cause the opener to block until the whole contents have been downloaded.

STREAM_WILL_CAST
If your extension is using a third-party library that expects a FILE* or file descriptor, you can use this flag to request the streams API to open the resource but avoid buffering. You can then use php_stream_cast() to retrieve the FILE* or file descriptor that the library requires. The is particularly useful when accessing HTTP URLs where the start of the actual stream data is found after an indeterminate offset into the stream. Since this option disables buffering at the streams API level, you may experience lower performance when using streams functions on the stream; this is deemed acceptable because you have told streams that you will be using the functions to match the underlying stream implementation. Only use this option when you are sure you need it.

Old introduction
Zend API; PHP Çekirdeğinin Geliştirilmesi
Zend Engine 1


Zend API; PHP Çekirdeğinin Geliştirilmesi

Introduction

Those who know don't talk.

Those who talk don't know.

Sometimes, PHP "as is" simply isn't enough. Although these cases are rare for the average user, professional applications will soon lead PHP to the edge of its capabilities, in terms of either speed or functionality. New functionality cannot always be implemented natively due to language restrictions and inconveniences that arise when having to carry around a huge library of default code appended to every single script, so another method needs to be found for overcoming these eventual lacks in PHP.

As soon as this point is reached, it's time to touch the heart of PHP and take a look at its core, the C code that makes PHP go.

Uyarı

This information is currently rather outdated, parts of it only cover early stages of the ZendEngine 1.0 API as it was used in early versions of PHP 4.

More recent information may be found in the various README files that come with the PHP source and the » Internals section on the Zend website.

Overview

"Extending PHP" is easier said than done. PHP has evolved to a full-fledged tool consisting of a few megabytes of source code, and to hack a system like this quite a few things have to be learned and considered. When structuring this chapter, we finally decided on the "learn by doing" approach. This is not the most scientific and professional approach, but the method that's the most fun and gives the best end results. In the following sections, you'll learn quickly how to get the most basic extensions to work almost instantly. After that, you'll learn about Zend's advanced API functionality. The alternative would have been to try to impart the functionality, design, tips, tricks, etc. as a whole, all at once, thus giving a complete look at the big picture before doing anything practical. Although this is the "better" method, as no dirty hacks have to be made, it can be very frustrating as well as energy- and time-consuming, which is why we've decided on the direct approach.

Note that even though this chapter tries to impart as much knowledge as possible about the inner workings of PHP, it's impossible to really give a complete guide to extending PHP that works 100% of the time in all cases. PHP is such a huge and complex package that its inner workings can only be understood if you make yourself familiar with it by practicing, so we encourage you to work with the source.

What Is Zend? and What Is PHP?

The name Zend refers to the language engine, PHP's core. The term PHP refers to the complete system as it appears from the outside. This might sound a bit confusing at first, but it's not that complicated ( see below). To implement a Web script interpreter, you need three parts:

  1. The interpreter part analyzes the input code, translates it, and executes it.

  2. The functionality part implements the functionality of the language (its functions, etc.).

  3. The interface part talks to the Web server, etc.

Zend takes part 1 completely and a bit of part 2; PHP takes parts 2 and 3. Together they form the complete PHP package. Zend itself really forms only the language core, implementing PHP at its very basics with some predefined functions. PHP contains all the modules that actually create the language's outstanding capabilities.
The internal structure of PHP.

The following sections discuss where PHP can be extended and how it's done.

Extension Possibilities

As shown above, PHP can be extended primarily at three points: external modules, built-in modules, and the Zend engine. The following sections discuss these options.

External Modules

External modules can be loaded at script runtime using the function dl(). This function loads a shared object from disk and makes its functionality available to the script to which it's being bound. After the script is terminated, the external module is discarded from memory. This method has both advantages and disadvantages, as described in the following table:

Advantages | Disadvantages
External modules don't require recompiling of PHP. | The shared objects need to be loaded every time a script is being executed (every hit), which is very slow.
The size of PHP remains small by "outsourcing" certain functionality. | External additional files clutter up the disk.
 |  | Every script that wants to use an external module's functionality has to specifically include a call to dl(), or the extension tag in php.ini needs to be modified (which is not always a suitable solution).
To sum up, external modules are great for third-party products, small additions to PHP that are rarely used, or just for testing purposes. To develop additional functionality quickly, external modules provide the best results. For frequent usage, larger implementations, and complex code, the disadvantages outweigh the advantages.

Third parties might consider using the extension tag in php.ini to create additional external modules to PHP. These external modules are completely detached from the main package, which is a very handy feature in commercial environments. Commercial distributors can simply ship disks or archives containing only their additional modules, without the need to create fixed and solid PHP binaries that don't allow other modules to be bound to them.

Built-in Modules

Built-in modules are compiled directly into PHP and carried around with every PHP process; their functionality is instantly available to every script that's being run. Like external modules, built-in modules have advantages and disadvantages, as described in the following table:

Advantages | Disadvantages
No need to load the module specifically; the functionality is instantly available. | Changes to built-in modules require recompiling of PHP.
No external files clutter up the disk; everything resides in the PHP binary. | The PHP binary grows and consumes more memory.
Built-in modules are best when you have a solid library of functions that remains relatively unchanged, requires better than poor-to-average performance, or is used frequently by many scripts on your site. The need to recompile PHP is quickly compensated by the benefit in speed and ease of use. However, built-in modules are not ideal when rapid development of small additions is required.

The Zend Engine

Of course, extensions can also be implemented directly in the Zend engine. This strategy is good if you need a change in the language behavior or require special functions to be built directly into the language core. In general, however, modifications to the Zend engine should be avoided. Changes here result in incompatibilities with the rest of the world, and hardly anyone will ever adapt to specially patched Zend engines. Modifications can't be detached from the main PHP sources and are overridden with the next update using the "official" source repositories. Therefore, this method is generally considered bad practice and, due to its rarity, is not covered in this book.

Source Layout

Bilginize:

Prior to working through the rest of this chapter, you should retrieve clean, unmodified source trees of your favorite Web server. We're working with Apache (available at » http://httpd.apache.org/) and, of course, with PHP (available at » http://www.php.net/ - does it need to be said?).

Make sure that you can compile a working PHP environment by yourself! We won't go into this issue here, however, as you should already have this most basic ability when studying this chapter.

Before we start discussing code issues, you should familiarize yourself with the source tree to be able to quickly navigate through PHP's files. This is a must-have ability to implement and debug extensions.

The following table describes the contents of the major directories.

Directory | Contents
php-src | Main PHP source files and main header files; here you'll find all of PHP's API definitions, macros, etc. (important). Everything else is below this directory.
php-src/ext | Repository for dynamic and built-in modules; by default, these are the "official" PHP modules that have been integrated into the main source tree. From PHP 4.0, it's possible to compile these standard extensions as dynamic loadable modules (at least, those that support it).
php-src/main | This directory contains the main php macros and definitions. (important)
php-src/pear | Directory for the PHP Extension and Application Repository. This directory contains core PEAR files.
php-src/sapi | Contains the code for the different server abstraction layers.
TSRM | Location of the "Thread Safe Resource Manager" (TSRM) for Zend and PHP.
ZendEngine2 | Location of the Zend Engine files; here you'll find all of Zend's API definitions, macros, etc. (important).

Discussing all the files included in the PHP package is beyond the scope of this chapter. However, you should take a close look at the following files:

  • php-src/main/php.h, located in the main PHP directory. This file contains most of PHP's macro and API definitions.

  • php-src/Zend/zend.h, located in the main Zend directory. This file contains most of Zend's macros and definitions.

  • php-src/Zend/zend_API.h, also located in the Zend directory, which defines Zend's API.

You should also follow some sub-inclusions from these files; for example, the ones relating to the Zend executor, the PHP initialization file support, and such. After reading these files, take the time to navigate around the package a little to see the interdependencies of all files and modules - how they relate to each other and especially how they make use of each other. This also helps you to adapt to the coding style in which PHP is authored. To extend PHP, you should quickly adapt to this style.

Extension Conventions

Zend is built using certain conventions; to avoid breaking its standards, you should follow the rules described in the following sections.

Macros

For almost every important task, Zend ships predefined macros that are extremely handy. The tables and figures in the following sections describe most of the basic functions, structures, and macros. The macro definitions can be found mainly in zend.h and zend_API.h. We suggest that you take a close look at these files after having studied this chapter. (Although you can go ahead and read them now, not everything will make sense to you yet.)

Memory Management

Resource management is a crucial issue, especially in server software. One of the most valuable resources is memory, and memory management should be handled with extreme care. Memory management has been partially abstracted in Zend, and you should stick to this abstraction for obvious reasons: Due to the abstraction, Zend gets full control over all memory allocations. Zend is able to determine whether a block is in use, automatically freeing unused blocks and blocks with lost references, and thus prevent memory leaks. The functions to be used are described in the following table:

Function | Description
emalloc() | Serves as replacement for malloc().
efree() | Serves as replacement for free().
estrdup() | Serves as replacement for strdup().
estrndup() | Serves as replacement for strndup(). Faster than estrdup() and binary-safe. This is the recommended function to use if you know the string length prior to duplicating it.
ecalloc() | Serves as replacement for calloc().
erealloc() | Serves as replacement for realloc().
emalloc(), estrdup(), estrndup(), ecalloc(), and erealloc() allocate internal memory; efree() frees these previously allocated blocks. Memory handled by the e*() functions is considered local to the current process and is discarded as soon as the script executed by this process is terminated.
Uyarı

To allocate resident memory that survives termination of the current script, you can use malloc() and free(). This should only be done with extreme care, however, and only in conjunction with demands of the Zend API; otherwise, you risk memory leaks.

Zend also features a thread-safe resource manager to provide better native support for multithreaded Web servers. This requires you to allocate local structures for all of your global variables to allow concurrent threads to be run. Because the thread-safe mode of Zend was not finished back when this was written, it is not yet extensively covered here.

Directory and File Functions

The following directory and file functions should be used in Zend modules. They behave exactly like their C counterparts, but provide virtual working directory support on the thread level.

Zend Function | Regular C Function
V_GETCWD() | getcwd()
V_FOPEN() | fopen()
V_OPEN() | open()
V_CHDIR() | chdir()
V_GETWD() | getwd()
V_CHDIR_FILE() | Takes a file path as an argument and changes the current working directory to that file's directory.
V_STAT() | stat()
V_LSTAT() | lstat()

String Handling

Strings are handled a bit differently by the Zend engine than other values such as integers, Booleans, etc., which don't require additional memory allocation for storing their values. If you want to return a string from a function, introduce a new string variable to the symbol table, or do something similar, you have to make sure that the memory the string will be occupying has previously been allocated, using the aforementioned e*() functions for allocation. (This might not make much sense to you yet; just keep it somewhere in your head for now - we'll get back to it shortly.)

Complex Types

Complex types such as arrays and objects require different treatment. Zend features a single API for these types - they're stored using hash tables.

Bilginize:

To reduce complexity in the following source examples, we're only working with simple types such as integers at first. A discussion about creating more advanced types follows later in this chapter.

PHP's Automatic Build System

PHP 4 features an automatic build system that's very flexible. All modules reside in a subdirectory of the ext directory. In addition to its own sources, each module consists of a config.m4 file, for extension configuration. (for example, see » http://www.gnu.org/software/m4/)

All these stub files are generated automatically, along with .cvsignore, by a little shell script named ext_skel that resides in the ext directory. As argument it takes the name of the module that you want to create. The shell script then creates a directory of the same name, along with the appropriate stub files.

Step by step, the process looks like this:

:~/cvs/php4/ext:> ./ext_skel --extname=my_module
Creating directory my_module
Creating basic files: config.m4 .cvsignore my_module.c php_my_module.h CREDITS EXPERIMENTAL tests/001.phpt my_module.php [done].

To use your new extension, you will have to execute the following steps:

1.  $ cd ..
2.  $ vi ext/my_module/config.m4
3.  $ ./buildconf
4.  $ ./configure --[with|enable]-my_module
5.  $ make
6.  $ ./php -f ext/my_module/my_module.php
7.  $ vi ext/my_module/my_module.c
8.  $ make

Repeat steps 3-6 until you are satisfied with ext/my_module/config.m4 and
step 6 confirms that your module is compiled into PHP. Then, start writing
code and repeat the last two steps as often as necessary.
This instruction creates the aforementioned files. To include the new module in the automatic configuration and build process, you have to run buildconf, which regenerates the configure script by searching through the ext directory and including all found config.m4 files.

The default config.m4 shown in The default config.m4. is a bit more complex:

Örnek 1 The default config.m4.

dnl $Id: build.xml 297078 2010-03-29 16:25:51Z degeberg $
dnl config.m4 for extension my_module

dnl Comments in this file start with the string 'dnl'.
dnl Remove where necessary. This file will not work
dnl without editing.

dnl If your extension references something external, use with:

dnl PHP_ARG_WITH(my_module, for my_module support,
dnl Make sure that the comment is aligned:
dnl [  --with-my_module             Include my_module support])

dnl Otherwise use enable:

dnl PHP_ARG_ENABLE(my_module, whether to enable my_module support,
dnl Make sure that the comment is aligned:
dnl [  --enable-my_module           Enable my_module support])

if test "$PHP_MY_MODULE" != "no"; then
  dnl Write more examples of tests here...

  dnl # --with-my_module -> check with-path
  dnl SEARCH_PATH="/usr/local /usr"     # you might want to change this
  dnl SEARCH_FOR="/include/my_module.h"  # you most likely want to change this
  dnl if test -r $PHP_MY_MODULE/; then # path given as parameter
  dnl   MY_MODULE_DIR=$PHP_MY_MODULE
  dnl else # search default path list
  dnl   AC_MSG_CHECKING([for my_module files in default path])
  dnl   for i in $SEARCH_PATH ; do
  dnl     if test -r $i/$SEARCH_FOR; then
  dnl       MY_MODULE_DIR=$i
  dnl       AC_MSG_RESULT(found in $i)
  dnl     fi
  dnl   done
  dnl fi
  dnl
  dnl if test -z "$MY_MODULE_DIR"; then
  dnl   AC_MSG_RESULT([not found])
  dnl   AC_MSG_ERROR([Please reinstall the my_module distribution])
  dnl fi

  dnl # --with-my_module -> add include path
  dnl PHP_ADD_INCLUDE($MY_MODULE_DIR/include)

  dnl # --with-my_module -> chech for lib and symbol presence
  dnl LIBNAME=my_module # you may want to change this
  dnl LIBSYMBOL=my_module # you most likely want to change this

  dnl PHP_CHECK_LIBRARY($LIBNAME,$LIBSYMBOL,
  dnl [
  dnl   PHP_ADD_LIBRARY_WITH_PATH($LIBNAME, $MY_MODULE_DIR/lib, MY_MODULE_SHARED_LIBADD)
  dnl   AC_DEFINE(HAVE_MY_MODULELIB,1,[ ])
  dnl ],[
  dnl   AC_MSG_ERROR([wrong my_module lib version or lib not found])
  dnl ],[
  dnl   -L$MY_MODULE_DIR/lib -lm -ldl
  dnl ])
  dnl
  dnl PHP_SUBST(MY_MODULE_SHARED_LIBADD)

  PHP_NEW_EXTENSION(my_module, my_module.c, $ext_shared)
fi

If you're unfamiliar with M4 files (now is certainly a good time to get familiar), this might be a bit confusing at first; but it's actually quite easy.

Note: Everything prefixed with dnl is treated as a comment and is not parsed.

The config.m4 file is responsible for parsing the command-line options passed to configure at configuration time. This means that it has to check for required external files and do similar configuration and setup tasks.

The default file creates two configuration directives in the configure script: --with-my_module and --enable-my_module. Use the first option when referring external files (such as the --with-apache directive that refers to the Apache directory). Use the second option when the user simply has to decide whether to enable your extension. Regardless of which option you use, you should uncomment the other, unnecessary one; that is, if you're using --enable-my_module, you should remove support for --with-my_module, and vice versa.

By default, the config.m4 file created by ext_skel accepts both directives and automatically enables your extension. Enabling the extension is done by using the PHP_EXTENSION macro. To change the default behavior to include your module into the PHP binary when desired by the user (by explicitly specifying --enable-my_module or --with-my_module), change the test for $PHP_MY_MODULE to == "yes":

if test "$PHP_MY_MODULE" == "yes"; then dnl
    Action.. PHP_EXTENSION(my_module, $ext_shared)
    fi
This would require you to use --enable-my_module each time when reconfiguring and recompiling PHP.

Note: Be sure to run buildconf every time you change config.m4!

We'll go into more details on the M4 macros available to your configuration scripts later in this chapter. For now, we'll simply use the default files.

Creating Extensions

We'll start with the creation of a very simple extension at first, which basically does nothing more than implement a function that returns the integer it receives as parameter. A simple extension. shows the source.

Örnek 2 A simple extension.

/* include standard header */
#include "php.h"

/* declaration of functions to be exported */
ZEND_FUNCTION(first_module);

/* compiled function list so Zend knows what's in this module */
zend_function_entry firstmod_functions[] =
{
    ZEND_FE(first_module, NULL)
    ZEND_FE_END
};

/* compiled module information */
zend_module_entry firstmod_module_entry =
{
    STANDARD_MODULE_HEADER,
    "First Module",
    firstmod_functions,
    NULL,
    NULL,
    NULL,
    NULL,
    NULL,
    NO_VERSION_YET,
    STANDARD_MODULE_PROPERTIES
};

/* implement standard "stub" routine to introduce ourselves to Zend */
#if COMPILE_DL_FIRST_MODULE
ZEND_GET_MODULE(firstmod)
#endif

/* implement function that is meant to be made available to PHP */
ZEND_FUNCTION(first_module)
{
    long parameter;

    if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "l", &parameter) == FAILURE) {
        return;
    }

    RETURN_LONG(parameter);
}

This code contains a complete PHP module. We'll explain the source code in detail shortly, but first we'd like to discuss the build process. (This will allow the impatient to experiment before we dive into API discussions.)

Bilginize:

The example source makes use of some features introduced with the Zend version used in PHP 4.1.0 and above, it won't compile with older PHP 4.0.x versions.

Compiling Modules

There are basically two ways to compile modules:

  • Use the provided "make" mechanism in the ext directory, which also allows building of dynamic loadable modules.

  • Compile the sources manually.

The first method should definitely be favored, since, as of PHP 4.0, this has been standardized into a sophisticated build process. The fact that it is so sophisticated is also its drawback, unfortunately - it's hard to understand at first. We'll provide a more detailed introduction to this later in the chapter, but first let's work with the default files.

The second method is good for those who (for some reason) don't have the full PHP source tree available, don't have access to all files, or just like to juggle with their keyboard. These cases should be extremely rare, but for the sake of completeness we'll also describe this method.

Compiling Using Make

To compile the sample sources using the standard mechanism, copy all their subdirectories to the ext directory of your PHP source tree. Then run buildconf, which will create an updated configure script containing appropriate options for the new extension. By default, all the sample sources are disabled, so you don't have to fear breaking your build process.

After you run buildconf, configure --help shows the following additional modules:

  --enable-array_experiments   BOOK: Enables array experiments
  --enable-call_userland       BOOK: Enables userland module
  --enable-cross_conversion    BOOK: Enables cross-conversion module
  --enable-first_module        BOOK: Enables first module
  --enable-infoprint           BOOK: Enables infoprint module
  --enable-reference_test      BOOK: Enables reference test module
  --enable-resource_test       BOOK: Enables resource test module
  --enable-variable_creation   BOOK: Enables variable-creation module

The module shown earlier in A simple extension. can be enabled with --enable-first_module or --enable-first_module=yes.

Compiling Manually

To compile your modules manually, you need the following commands:

Action | Command
Compiling | cc -fpic -DCOMPILE_DL_FIRST_MODULE=1 -I/usr/local/include -I. -I.. -I../Zend -c -o <your_object_file> <your_c_file>
Linking | cc -shared -L/usr/local/lib -rdynamic -o <your_module_file> <your_object_file(s)>
The command to compile the module simply instructs the compiler to generate position-independent code (-fpic shouldn't be omitted) and additionally defines the constant COMPILE_DL_FIRST_MODULE to tell the module code that it's compiled as a dynamically loadable module (the test module above checks for this; we'll discuss it shortly). After these options, it specifies a number of standard include paths that should be used as the minimal set to compile the source files.

Note: All include paths in the example are relative to the directory ext. If you're compiling from another directory, change the pathnames accordingly. Required items are the PHP directory, the Zend directory, and (if necessary), the directory in which your module resides.

The link command is also a plain vanilla command instructing linkage as a dynamic module.

You can include optimization options in the compilation command, although these have been omitted in this example (but some are included in the makefile template described in an earlier section).

Note: Compiling and linking manually as a static module into the PHP binary involves very long instructions and thus is not discussed here. (It's not very efficient to type all those commands.)

Using Extensions

Depending on the build process you selected, you should either end up with a new PHP binary to be linked into your Web server (or run as CGI), or with an .so (shared object) file. If you compiled the example file first_module.c as a shared object, your result file should be first_module.so. To use it, you first have to copy it to a place from which it's accessible to PHP. For a simple test procedure, you can copy it to your htdocs directory and try it with the source in A test file for first_module.so.. If you compiled it into the PHP binary, omit the call to dl(), as the module's functionality is instantly available to your scripts.

Uyarı

For security reasons, you should not put your dynamic modules into publicly accessible directories. Even though it can be done and it simplifies testing, you should put them into a separate directory in production environments.

Örnek 3 A test file for first_module.so.

<?php

// remove next comment if necessary
// dl("first_module.so");

$param = 2;
$return = first_module($param);

print("We sent '$param' and got '$return'");

?>

Calling this PHP file should output the following:

We sent '2' and got '2'

If required, the dynamic loadable module is loaded by calling the dl() function. This function looks for the specified shared object, loads it, and makes its functions available to PHP. The module exports the function first_module(), which accepts a single parameter, converts it to an integer, and returns the result of the conversion.

If you've gotten this far, congratulations! You just built your first extension to PHP.

Troubleshooting

Actually, not much troubleshooting can be done when compiling static or dynamic modules. The only problem that could arise is that the compiler will complain about missing definitions or something similar. In this case, make sure that all header files are available and that you specified their path correctly in the compilation command. To be sure that everything is located correctly, extract a clean PHP source tree and use the automatic build in the ext directory with the fresh files; this will guarantee a safe compilation environment. If this fails, try manual compilation.

PHP might also complain about missing functions in your module. (This shouldn't happen with the sample sources if you didn't modify them.) If the names of external functions you're trying to access from your module are misspelled, they'll remain as "unlinked symbols" in the symbol table. During dynamic loading and linkage by PHP, they won't resolve because of the typing errors - there are no corresponding symbols in the main binary. Look for incorrect declarations in your module file or incorrectly written external references. Note that this problem is specific to dynamic loadable modules; it doesn't occur with static modules. Errors in static modules show up at compile time.

Source Discussion

Now that you've got a safe build environment and you're able to include the modules into PHP files, it's time to discuss how everything works.

Module Structure

All PHP modules follow a common structure:

  • Header file inclusions (to include all required macros, API definitions, etc.)

  • C declaration of exported functions (required to declare the Zend function block)

  • Declaration of the Zend function block

  • Declaration of the Zend module block

  • Implementation of get_module()

  • Implementation of all exported functions

Header File Inclusions

The only header file you really have to include for your modules is php.h, located in the PHP directory. This file makes all macros and API definitions required to build new modules available to your code.

Tip: It's good practice to create a separate header file for your module that contains module-specific definitions. This header file should contain all the forward definitions for exported functions and include php.h. If you created your module using ext_skel you already have such a header file prepared.

Declaring Exported Functions

To declare functions that are to be exported (i.e., made available to PHP as new native functions), Zend provides a set of macros. A sample declaration looks like this:

ZEND_FUNCTION ( my_function );

ZEND_FUNCTION declares a new C function that complies with Zend's internal API. This means that the function is of type void and accepts INTERNAL_FUNCTION_PARAMETERS (another macro) as parameters. Additionally, it prefixes the function name with zif. The immediately expanded version of the above definitions would look like this:

void zif_my_function ( INTERNAL_FUNCTION_PARAMETERS );
Expanding INTERNAL_FUNCTION_PARAMETERS results in the following:
void zif_my_function( int ht
                    , zval * return_value
                    , zval * this_ptr
                    , int return_value_used
                    , zend_executor_globals * executor_globals
                    );

Since the interpreter and executor core have been separated from the main PHP package, a second API defining macros and function sets has evolved: the Zend API. As the Zend API now handles quite a few of the responsibilities that previously belonged to PHP, a lot of PHP functions have been reduced to macros aliasing to calls into the Zend API. The recommended practice is to use the Zend API wherever possible, as the old API is only preserved for compatibility reasons. For example, the types zval and pval are identical. zval is Zend's definition; pval is PHP's definition (actually, pval is an alias for zval now). As the macro INTERNAL_FUNCTION_PARAMETERS is a Zend macro, the above declaration contains zval. When writing code, you should always use zval to conform to the new Zend API.

The parameter list of this declaration is very important; you should keep these parameters in mind (see Zend's Parameters to Functions Called from PHP for descriptions).

Zend's Parameters to Functions Called from PHP
Parameter | Description
ht | The number of arguments passed to the Zend function. You should not touch this directly, but instead use ZEND_NUM_ARGS() to obtain the value.
return_value | This variable is used to pass any return values of your function back to PHP. Access to this variable is best done using the predefined macros. For a description of these see below.
this_ptr | Using this variable, you can gain access to the object in which your function is contained, if it's used within an object. Use the function getThis() to obtain this pointer.
return_value_used | This flag indicates whether an eventual return value from this function will actually be used by the calling script. 0 indicates that the return value is not used; 1 indicates that the caller expects a return value. Evaluation of this flag can be done to verify correct usage of the function as well as speed optimizations in case returning a value requires expensive operations (for an example, see how array.c makes use of this).
executor_globals | This variable points to global settings of the Zend engine. You'll find this useful when creating new variables, for example (more about this later). The executor globals can also be introduced to your function by using the macro TSRMLS_FETCH().

Declaration of the Zend Function Block

Now that you have declared the functions to be exported, you also have to introduce them to Zend. Introducing the list of functions is done by using an array of zend_function_entry. This array consecutively contains all functions that are to be made available externally, with the function's name as it should appear in PHP and its name as defined in the C source. Internally, zend_function_entry is defined as shown in Internal declaration of zend_function_entry..

Örnek 4 Internal declaration of zend_function_entry.

typedef struct _zend_function_entry {
    char *fname;
    void (*handler)(INTERNAL_FUNCTION_PARAMETERS);
    unsigned char *func_arg_types;
} zend_function_entry;
Entry | Description
fname | Denotes the function name as seen in PHP (for example, fopen, mysql_connect, or, in our example, first_module).
handler | Pointer to the C function responsible for handling calls to this function. For example, see the standard macro INTERNAL_FUNCTION_PARAMETERS discussed earlier.
func_arg_types | Allows you to mark certain parameters so that they're forced to be passed by reference. You usually should set this to NULL.
In the example above, the declaration looks like this:
zend_function_entry firstmod_functions[] =
{
    ZEND_FE(first_module, NULL)
    ZEND_FE_END
};
You can see that the last entry in the list always has to be ZEND_FE_END. This marker has to be set for Zend to know when the end of the list of exported functions is reached.

The macro ZEND_FE (short for 'Zend Function Entry') simply expands to a structure entry in zend_function_entry. Note that these macros introduce a special naming scheme to your functions - your C functions will be prefixed with zif_, meaning that ZEND_FE(first_module) will refer to a C function zif_first_module(). If you want to mix macro usage with hand-coded entries (not a good practice), keep this in mind.

Tip: Compilation errors that refer to functions named zif_*() relate to functions defined with ZEND_FE.

Macros for Defining Functions shows a list of all the macros that you can use to define functions.

Macros for Defining Functions
Macro Name | Description
ZEND_FE(name, arg_types) | Defines a function entry of the name name in zend_function_entry. Requires a corresponding C function. arg_types needs to be set to NULL. This function uses automatic C function name generation by prefixing the PHP function name with zif_. For example, ZEND_FE("first_module", NULL) introduces a function first_module() to PHP and links it to the C function zif_first_module(). Use in conjunction with ZEND_FUNCTION.
ZEND_NAMED_FE(php_name, name, arg_types) | Defines a function that will be available to PHP by the name php_name and links it to the corresponding C function name. arg_types needs to be set to NULL. Use this function if you don't want the automatic name prefixing introduced by ZEND_FE. Use in conjunction with ZEND_NAMED_FUNCTION.
ZEND_FALIAS(name, alias, arg_types) | Defines an alias named alias for name. arg_types needs to be set to NULL. Doesn't require a corresponding C function; refers to the alias target instead.
PHP_FE(name, arg_types) | Old PHP API equivalent of ZEND_FE.
PHP_NAMED_FE(runtime_name, name, arg_types) | Old PHP API equivalent of ZEND_NAMED_FE.

Note: You can't use ZEND_FE in conjunction with PHP_FUNCTION, or PHP_FE in conjunction with ZEND_FUNCTION. However, it's perfectly legal to mix ZEND_FE and ZEND_FUNCTION with PHP_FE and PHP_FUNCTION when staying with the same macro set for each function to be declared. But mixing is not recommended; instead, you're advised to use the ZEND_* macros only.

Declaration of the Zend Module Block

This block is stored in the structure zend_module_entry and contains all necessary information to describe the contents of this module to Zend. You can see the internal definition of this module in Internal declaration of zend_module_entry..

Örnek 5 Internal declaration of zend_module_entry.

typedef struct _zend_module_entry zend_module_entry;

    struct _zend_module_entry {
    unsigned short size;
    unsigned int zend_api;
    unsigned char zend_debug;
    unsigned char zts;
    char *name;
    zend_function_entry *functions;
    int (*module_startup_func)(INIT_FUNC_ARGS);
    int (*module_shutdown_func)(SHUTDOWN_FUNC_ARGS);
    int (*request_startup_func)(INIT_FUNC_ARGS);
    int (*request_shutdown_func)(SHUTDOWN_FUNC_ARGS);
    void (*info_func)(ZEND_MODULE_INFO_FUNC_ARGS);
    char *version;

[ Rest of the structure is not interesting here ]

};
Entry | Description
size, zend_api, zend_debug and zts | Usually filled with the "STANDARD_MODULE_HEADER", which fills these four members with the size of the whole zend_module_entry, the ZEND_MODULE_API_NO, whether it is a debug build or normal build (ZEND_DEBUG) and if ZTS is enabled (USING_ZTS).
name | Contains the module name (for example, "File functions", "Socket functions", "Crypt", etc.). This name will show up in phpinfo(), in the section "Additional Modules."
functions | Points to the Zend function block, discussed in the preceding section.
module_startup_func | This function is called once upon module initialization and can be used to do one-time initialization steps (such as initial memory allocation, etc.). To indicate a failure during initialization, return FAILURE; otherwise, SUCCESS. To mark this field as unused, use NULL. To declare a function, use the macro ZEND_MINIT.
module_shutdown_func | This function is called once upon module shutdown and can be used to do one-time deinitialization steps (such as memory deallocation). This is the counterpart to module_startup_func(). To indicate a failure during deinitialization, return FAILURE; otherwise, SUCCESS. To mark this field as unused, use NULL. To declare a function, use the macro ZEND_MSHUTDOWN.
request_startup_func | This function is called once upon every page request and can be used to do one-time initialization steps that are required to process a request. To indicate a failure here, return FAILURE; otherwise, SUCCESS. Note: As dynamic loadable modules are loaded only on page requests, the request startup function is called right after the module startup function (both initialization events happen at the same time). To mark this field as unused, use NULL. To declare a function, use the macro ZEND_RINIT.
request_shutdown_func | This function is called once after every page request and works as counterpart to request_startup_func(). To indicate a failure here, return FAILURE; otherwise, SUCCESS. Note: As dynamic loadable modules are loaded only on page requests, the request shutdown function is immediately followed by a call to the module shutdown handler (both deinitialization events happen at the same time). To mark this field as unused, use NULL. To declare a function, use the macro ZEND_RSHUTDOWN.
info_func | When phpinfo() is called in a script, Zend cycles through all loaded modules and calls this function. Every module then has the chance to print its own "footprint" into the output page. Generally this is used to dump environmental or statistical information. To mark this field as unused, use NULL. To declare a function, use the macro ZEND_MINFO.
version | The version of the module. You can use NO_VERSION_YET if you don't want to give the module a version number yet, but we really recommend that you add a version string here. Such a version string can look like this (in chronological order): "2.5-dev", "2.5RC1", "2.5" or "2.5pl3".
Remaining structure elements | These are used internally and can be prefilled by using the macro STANDARD_MODULE_PROPERTIES_EX. You should not assign any values to them. Use STANDARD_MODULE_PROPERTIES_EX only if you use global startup and shutdown functions; otherwise, use STANDARD_MODULE_PROPERTIES directly.

In our example, this structure is implemented as follows:

zend_module_entry firstmod_module_entry =
{
    STANDARD_MODULE_HEADER,
    "First Module",
    firstmod_functions,
    NULL, NULL, NULL, NULL, NULL,
    NO_VERSION_YET,
    STANDARD_MODULE_PROPERTIES,
};
This is basically the easiest and most minimal set of values you could ever use. The module name is set to First Module, then the function list is referenced, after which all startup and shutdown functions are marked as being unused.

For reference purposes, you can find a list of the macros involved in declared startup and shutdown functions in Macros to Declare Startup and Shutdown Functions. These are not used in our basic example yet, but will be demonstrated later on. You should make use of these macros to declare your startup and shutdown functions, as these require special arguments to be passed (INIT_FUNC_ARGS and SHUTDOWN_FUNC_ARGS), which are automatically included into the function declaration when using the predefined macros. If you declare your functions manually and the PHP developers decide that a change in the argument list is necessary, you'll have to change your module sources to remain compatible.

Macros to Declare Startup and Shutdown Functions
Macro | Description
ZEND_MINIT(module) | Declares a function for module startup. The generated name will be zend_minit_<module> (for example, zend_minit_first_module). Use in conjunction with ZEND_MINIT_FUNCTION.
ZEND_MSHUTDOWN(module) | Declares a function for module shutdown. The generated name will be zend_mshutdown_<module> (for example, zend_mshutdown_first_module). Use in conjunction with ZEND_MSHUTDOWN_FUNCTION.
ZEND_RINIT(module) | Declares a function for request startup. The generated name will be zend_rinit_<module> (for example, zend_rinit_first_module). Use in conjunction with ZEND_RINIT_FUNCTION.
ZEND_RSHUTDOWN(module) | Declares a function for request shutdown. The generated name will be zend_rshutdown_<module> (for example, zend_rshutdown_first_module). Use in conjunction with ZEND_RSHUTDOWN_FUNCTION.
ZEND_MINFO(module) | Declares a function for printing module information, used when phpinfo() is called. The generated name will be zend_info_<module> (for example, zend_info_first_module). Use in conjunction with ZEND_MINFO_FUNCTION.

Creation of get_module()

This function is special to all dynamic loadable modules. Take a look at the creation via the ZEND_GET_MODULE macro first:

#if COMPILE_DL_FIRSTMOD
     ZEND_GET_MODULE(firstmod)
#endif

The function implementation is surrounded by a conditional compilation statement. This is needed since the function get_module() is only required if your module is built as a dynamic extension. By specifying a definition of COMPILE_DL_FIRSTMOD in the compiler command (see above for a discussion of the compilation instructions required to build a dynamic extension), you can instruct your module whether you intend to build it as a dynamic extension or as a built-in module. If you want a built-in module, the implementation of get_module() is simply left out.

get_module() is called by Zend at load time of the module. You can think of it as being invoked by the dl() call in your script. Its purpose is to pass the module information block back to Zend in order to inform the engine about the module contents.

If you don't implement a get_module() function in your dynamic loadable module, Zend will compliment you with an error message when trying to access it.

Implementation of All Exported Functions

Implementing the exported functions is the final step. The example function in first_module looks like this:

ZEND_FUNCTION(first_module)
{
    long parameter;

    if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "l", &parameter) == FAILURE) {
        return;
    }

    RETURN_LONG(parameter);
}
The function declaration is done using ZEND_FUNCTION, which corresponds to ZEND_FE in the function entry table (discussed earlier).

After the declaration, code for checking and retrieving the function's arguments, argument conversion, and return value generation follows (more on this later).

Summary

That's it, basically - there's nothing more to implementing PHP modules. Built-in modules are structured similarly to dynamic modules, so, equipped with the information presented in the previous sections, you'll be able to fight the odds when encountering PHP module source files.

Now, in the following sections, read on about how to make use of PHP's internals to build powerful extensions.

Accepting Arguments

One of the most important issues for language extensions is accepting and dealing with data passed via arguments. Most extensions are built to deal with specific input data (or require parameters to perform their specific actions), and function arguments are the only real way to exchange data between the PHP level and the C level. Of course, there's also the possibility of exchanging data using predefined global values (which is also discussed later), but this should be avoided by all means, as it's extremely bad practice.

PHP doesn't make use of any formal function declarations; this is why call syntax is always completely dynamic and never checked for errors. Checking for correct call syntax is left to the user code. For example, it's possible to call a function using only one argument at one time and four arguments the next time - both invocations are syntactically absolutely correct.

Determining the Number of Arguments

Since PHP doesn't have formal function definitions with support for call syntax checking, and since PHP features variable arguments, sometimes you need to find out with how many arguments your function has been called. You can use the ZEND_NUM_ARGS macro in this case. In previous versions of PHP, this macro retrieved the number of arguments with which the function has been called based on the function's hash table entry, ht, which is passed in the INTERNAL_FUNCTION_PARAMETERS list. As ht itself now contains the number of arguments that have been passed to the function, ZEND_NUM_ARGS has been stripped down to a dummy macro (see its definition in zend_API.h). But it's still good practice to use it, to remain compatible with future changes in the call interface. Note: The old PHP equivalent of this macro is ARG_COUNT.

The following code checks for the correct number of arguments:

if(ZEND_NUM_ARGS() != 2) WRONG_PARAM_COUNT;
If the function is not called with two arguments, it exits with an error message. The code snippet above makes use of the tool macro WRONG_PARAM_COUNT, which can be used to generate a standard error message like:
"Warning: Wrong parameter count for firstmodule() in /home/www/htdocs/firstmod.php on line 5"

This macro prints a default error message and then returns to the caller. Its definition can also be found in zend_API.h and looks like this:

ZEND_API void wrong_param_count(void);

#define WRONG_PARAM_COUNT { wrong_param_count(); return; }
As you can see, it calls an internal function named wrong_param_count() that's responsible for printing the warning. For details on generating customized error messages, see the later section "Printing Information."

Retrieving Arguments

Bilginize: New parameter parsing API

This chapter documents the new Zend parameter parsing API introduced by Andrei Zmievski. It was introduced in the development stage between PHP 4.0.6 and 4.1.0.

Parsing parameters is a very common operation and it may get a bit tedious. It would also be nice to have standardized error checking and error messages. Since PHP 4.1.0, there is a way to do just that by using the new parameter parsing API. It greatly simplifies the process of receiving parameters, but it has a drawback in that it can't be used for functions that expect variable number of parameters. But since the vast majority of functions do not fall into those categories, this parsing API is recommended as the new standard way.

The prototype for parameter parsing function looks like this:

int zend_parse_parameters(int num_args TSRMLS_DC, char *type_spec, ...);
The first argument to this function is supposed to be the number of actual parameters passed to your function, so ZEND_NUM_ARGS() can be used for that. The second parameter should always be TSRMLS_CC macro. The third argument is a string that specifies the number and types of arguments your function is expecting, similar to how printf format string specifies the number and format of the output values it should operate on. And finally the rest of the arguments are pointers to variables which should receive the values from the parameters.

zend_parse_parameters() also performs type conversions whenever possible, so that you always receive the data in the format you asked for. Any type of scalar can be converted to another one, but conversions between complex types (arrays, objects, and resources) and scalar types are not allowed.

If the parameters could be obtained successfully and there were no errors during type conversion, the function will return SUCCESS, otherwise it will return FAILURE. The function will output informative error messages, if the number of received parameters does not match the requested number, or if type conversion could not be performed.

Here are some sample error messages:

Warning - ini_get_all() requires at most 1 parameter, 2 given
Warning - wddx_deserialize() expects parameter 1 to be string, array given
Of course each error message is accompanied by the filename and line number on which it occurs.

Here is the full list of type specifiers:

  • l - long

  • d - double

  • s - string (with possible null bytes) and its length

  • b - boolean

  • r - resource, stored in zval*

  • a - array, stored in zval*

  • o - object (of any class), stored in zval*

  • O - object (of class specified by class entry), stored in zval*

  • z - the actual zval*

The following characters also have a meaning in the specifier string:

  • | - indicates that the remaining parameters are optional. The storage variables corresponding to these parameters should be initialized to default values by the extension, since they will not be touched by the parsing function if the parameters are not passed.

  • / - the parsing function will call SEPARATE_ZVAL_IF_NOT_REF() on the parameter it follows, to provide a copy of the parameter, unless it's a reference.

  • ! - the parameter it follows can be of specified type or NULL (only applies to a, o, O, r, and z). If NULL value is passed by the user, the storage pointer will be set to NULL.

The best way to illustrate the usage of this function is through examples:

/* Gets a long, a string and its length, and a zval. */
long l;
char *s;
int s_len;
zval *param;
if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC,
                          "lsz", &l, &s, &s_len, &param) == FAILURE) {
    return;
}

/* Gets an object of class specified by my_ce, and an optional double. */
zval *obj;
double d = 0.5;
if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC,
                          "O|d", &obj, my_ce, &d) == FAILURE) {
    return;
}

/* Gets an object or null, and an array.
   If null is passed for object, obj will be set to NULL. */
zval *obj;
zval *arr;
if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "O!a", &obj, &arr) == FAILURE) {
    return;
}

/* Gets a separated array. */
zval *arr;
if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "a/", &arr) == FAILURE) {
    return;
}

/* Get only the first three parameters (useful for varargs functions). */
zval *z;
zend_bool b;
zval *r;
if (zend_parse_parameters(3, "zbr!", &z, &b, &r) == FAILURE) {
    return;
}

Note that in the last example we pass 3 for the number of received parameters, instead of ZEND_NUM_ARGS(). What this lets us do is receive the least number of parameters if our function expects a variable number of them. Of course, if you want to operate on the rest of the parameters, you will have to use zend_get_parameters_array_ex() to obtain them.

The parsing function has an extended version that allows for an additional flags argument that controls its actions.

int zend_parse_parameters_ex(int flags, int num_args TSRMLS_DC, char *type_spec, ...);

The only flag you can pass currently is ZEND_PARSE_PARAMS_QUIET, which instructs the function to not output any error messages during its operation. This is useful for functions that expect several sets of completely different arguments, but you will have to output your own error messages.

For example, here is how you would get either a set of three longs or a string:

long l1, l2, l3;
char *s;
if (zend_parse_parameters_ex(ZEND_PARSE_PARAMS_QUIET,
                             ZEND_NUM_ARGS() TSRMLS_CC,
                             "lll", &l1, &l2, &l3) == SUCCESS) {
    /* manipulate longs */
} else if (zend_parse_parameters_ex(ZEND_PARSE_PARAMS_QUIET,
                                    ZEND_NUM_ARGS(), "s", &s, &s_len) == SUCCESS) {
    /* manipulate string */
} else {
    php_error(E_WARNING, "%s() takes either three long values or a string as argument",
              get_active_function_name(TSRMLS_C));
    return;
}

With all the abovementioned ways of receiving function parameters you should have a good handle on this process. For even more example, look through the source code for extensions that are shipped with PHP - they illustrate every conceivable situation.

Old way of retrieving arguments (deprecated)

Bilginize: Deprecated parameter parsing API

This API is deprecated and superseded by the new ZEND parameter parsing API.

After having checked the number of arguments, you need to get access to the arguments themselves. This is done with the help of zend_get_parameters_ex():

zval **parameter;

if(zend_get_parameters_ex(1, &parameter) != SUCCESS)
  WRONG_PARAM_COUNT;
All arguments are stored in a zval container, which needs to be pointed to twice. The snippet above tries to retrieve one argument and make it available to us via the parameter pointer.

zend_get_parameters_ex() accepts at least two arguments. The first argument is the number of arguments to retrieve (which should match the number of arguments with which the function has been called; this is why it's important to check for correct call syntax). The second argument (and all following arguments) are pointers to pointers to pointers to zvals. (Confusing, isn't it?) All these pointers are required because Zend works internally with **zval; to adjust a local **zval in our function,zend_get_parameters_ex() requires a pointer to it.

The return value of zend_get_parameters_ex() can either be SUCCESS or FAILURE, indicating (unsurprisingly) success or failure of the argument processing. A failure is most likely related to an incorrect number of arguments being specified, in which case you should exit with WRONG_PARAM_COUNT.

To retrieve more than one argument, you can use a similar snippet:

zval **param1, **param2, **param3, **param4;

if(zend_get_parameters_ex(4, &param1, &param2, &param3, &param4) != SUCCESS)
    WRONG_PARAM_COUNT;

zend_get_parameters_ex() only checks whether you're trying to retrieve too many parameters. If the function is called with five arguments, but you're only retrieving three of them with zend_get_parameters_ex(), you won't get an error but will get the first three parameters instead. Subsequent calls of zend_get_parameters_ex() won't retrieve the remaining arguments, but will get the same arguments again.

Dealing with a Variable Number of Arguments/Optional Parameters

If your function is meant to accept a variable number of arguments, the snippets just described are sometimes suboptimal solutions. You have to create a line calling zend_get_parameters_ex() for every possible number of arguments, which is often unsatisfying.

For this case, you can use the function zend_get_parameters_array_ex(), which accepts the number of parameters to retrieve and an array in which to store them:

zval **parameter_array[4];

/* get the number of arguments */
argument_count = ZEND_NUM_ARGS();

/* see if it satisfies our minimal request (2 arguments) */
/* and our maximal acceptance (4 arguments) */
if(argument_count < 2 || argument_count > 4)
    WRONG_PARAM_COUNT;

/* argument count is correct, now retrieve arguments */
if(zend_get_parameters_array_ex(argument_count, parameter_array) != SUCCESS)
    WRONG_PARAM_COUNT;
First, the number of arguments is checked to make sure that it's in the accepted range. After that, zend_get_parameters_array_ex() is used to fill parameter_array with valid pointers to the argument values.

A very clever implementation of this can be found in the code handling PHP's fsockopen() located in ext/standard/fsock.c, as shown in PHP's implementation of variable arguments in fsockopen().. Don't worry if you don't know all the functions used in this source yet; we'll get to them shortly.

Örnek 6 PHP's implementation of variable arguments in fsockopen().

pval **args[5];
int *sock=emalloc(sizeof(int));
int *sockp;
int arg_count=ARG_COUNT(ht);
int socketd = -1;
unsigned char udp = 0;
struct timeval timeout = { 60, 0 };
unsigned short portno;
unsigned long conv;
char *key = NULL;
FLS_FETCH();

if (arg_count > 5 || arg_count < 2 || zend_get_parameters_array_ex(arg_count,args)==FAILURE) {
    CLOSE_SOCK(1);
    WRONG_PARAM_COUNT;
}

switch(arg_count) {
    case 5:
        convert_to_double_ex(args[4]);
        conv = (unsigned long) (Z_DVAL_PP(args[4]) * 1000000.0);
        timeout.tv_sec = conv / 1000000;
        timeout.tv_usec = conv % 1000000;
        /* fall-through */
    case 4:
        if (!PZVAL_IS_REF(*args[3])) {
            php_error(E_WARNING,"error string argument to fsockopen not passed by reference");
        }
        pval_copy_constructor(*args[3]);
        ZVAL_EMPTY_STRING(*args[3]);
        /* fall-through */
    case 3:
        if (!PZVAL_IS_REF(*args[2])) {
            php_error(E_WARNING,"error argument to fsockopen not passed by reference");
            return;
        }
        ZVAL_LONG(*args[2], 0);
        break;
}

convert_to_string_ex(args[0]);
convert_to_long_ex(args[1]);
portno = (unsigned short) Z_LVAL_P(args[1]);

key = emalloc(Z_STRLEN_P(args[0]) + 10);

fsockopen() accepts two, three, four, or five parameters. After the obligatory variable declarations, the function checks for the correct range of arguments. Then it uses a fall-through mechanism in a switch() statement to deal with all arguments. The switch() statement starts with the maximum number of arguments being passed (five). After that, it automatically processes the case of four arguments being passed, then three, by omitting the otherwise obligatory break keyword in all stages. After having processed the last case, it exits the switch() statement and does the minimal argument processing needed if the function is invoked with only two arguments.

This multiple-stage type of processing, similar to a stairway, allows convenient processing of a variable number of arguments.

Accessing Arguments

To access arguments, it's necessary for each argument to have a clearly defined type. Again, PHP's extremely dynamic nature introduces some quirks. Because PHP never does any kind of type checking, it's possible for a caller to pass any kind of data to your functions, whether you want it or not. If you expect an integer, for example, the caller might pass an array, and vice versa - PHP simply won't notice.

To work around this, you have to use a set of API functions to force a type conversion on every argument that's being passed (see Argument Conversion Functions).

Note: All conversion functions expect a **zval as parameter.

Argument Conversion Functions
Function | Description
convert_to_boolean_ex() | Forces conversion to a Boolean type. Boolean values remain untouched. Longs, doubles, and strings containing 0 as well as NULL values will result in Boolean 0 (FALSE). Arrays and objects are converted based on the number of entries or properties, respectively, that they have. Empty arrays and objects are converted to FALSE; otherwise, to TRUE. All other values result in a Boolean 1 (TRUE).
convert_to_long_ex() | Forces conversion to a long, the default integer type. NULL values, Booleans, resources, and of course longs remain untouched. Doubles are truncated. Strings containing an integer are converted to their corresponding numeric representation, otherwise resulting in 0. Arrays and objects are converted to 0 if empty, 1 otherwise.
convert_to_double_ex() | Forces conversion to a double, the default floating-point type. NULL values, Booleans, resources, longs, and of course doubles remain untouched. Strings containing a number are converted to their corresponding numeric representation, otherwise resulting in 0.0. Arrays and objects are converted to 0.0 if empty, 1.0 otherwise.
convert_to_string_ex() | Forces conversion to a string. Strings remain untouched. NULL values are converted to an empty string. Booleans containing TRUE are converted to "1", otherwise resulting in an empty string. Longs and doubles are converted to their corresponding string representation. Arrays are converted to the string "Array" and objects to the string "Object".
convert_to_array_ex(value) | Forces conversion to an array. Arrays remain untouched. Objects are converted to an array by assigning all their properties to the array table. All property names are used as keys, property contents as values. NULL values are converted to an empty array. All other values are converted to an array that contains the specific source value in the element with the key 0.
convert_to_object_ex(value) | Forces conversion to an object. Objects remain untouched. NULL values are converted to an empty object. Arrays are converted to objects by introducing their keys as properties into the objects and their values as corresponding property contents in the object. All other types result in an object with the property scalar , having the corresponding source value as content.
convert_to_null_ex(value) | Forces the type to become a NULL value, meaning empty.

Bilginize:

You can find a demonstration of the behavior in cross_conversion.php on the accompanying CD-ROM.

Cross-conversion behavior of PHP.

Using these functions on your arguments will ensure type safety for all data that's passed to you. If the supplied type doesn't match the required type, PHP forces dummy contents on the resulting value (empty strings, arrays, or objects, 0 for numeric values, FALSE for Booleans) to ensure a defined state.

Following is a quote from the sample module discussed previously, which makes use of the conversion functions:

zval **parameter;

if((ZEND_NUM_ARGS() != 1) || (zend_get_parameters_ex(1, &parameter) != SUCCESS))
{
    WRONG_PARAM_COUNT;
}

convert_to_long_ex(parameter);

RETURN_LONG(Z_LVAL_P(parameter));
After retrieving the parameter pointer, the parameter value is converted to a long (an integer), which also forms the return value of this function. Understanding access to the contents of the value requires a short discussion of the zval type, whose definition is shown in PHP/Zend zval type definition..

Örnek 7 PHP/Zend zval type definition.

typedef pval zval;

typedef struct _zval_struct zval;

typedef union _zvalue_value {
    long lval;                 /* long value */
    double dval;               /* double value */
    struct {
        char *val;
        int len;
    } str;
    HashTable *ht;             /* hash table value */
    struct {
        zend_class_entry *ce;
        HashTable *properties;
    } obj;
} zvalue_value;

struct _zval_struct {
    /* Variable information */
    zvalue_value value;        /* value */
    unsigned char type;        /* active type */
    unsigned char is_ref;
    short refcount;
};

Actually, pval (defined in php.h) is only an alias of zval (defined in zend.h), which in turn refers to _zval_struct. This is a most interesting structure. _zval_struct is the "master" structure, containing the value structure, type, and reference information. The substructure zvalue_value is a union that contains the variable's contents. Depending on the variable's type, you'll have to access different members of this union. For a description of both structures, see Zend zval Structure, Zend zvalue_value Structure and Zend Variable Type Constants.

Zend zval Structure
Entry | Description
value | Union containing this variable's contents. See Zend zvalue_value Structure for a description.
type | Contains this variable's type. For a list of available types, see Zend Variable Type Constants.
is_ref | 0 means that this variable is not a reference; 1 means that this variable is a reference to another variable.
refcount | The number of references that exist for this variable. For every new reference to the value stored in this variable, this counter is increased by 1. For every lost reference, this counter is decreased by 1. When the reference counter reaches 0, no references exist to this value anymore, which causes automatic freeing of the value.
Zend zvalue_value Structure
Entry | Description
lval | Use this property if the variable is of the type IS_LONG, IS_BOOLEAN, or IS_RESOURCE.
dval | Use this property if the variable is of the type IS_DOUBLE.
str | This structure can be used to access variables of the type IS_STRING. The member len contains the string length; the member val points to the string itself. Zend uses C strings; thus, the string length contains a trailing 0x00.
ht | This entry points to the variable's hash table entry if the variable is an array.
obj | Use this property if the variable is of the type IS_OBJECT.
Zend Variable Type Constants
Constant | Description
IS_NULL | Denotes a NULL (empty) value.
IS_LONG | A long (integer) value.
IS_DOUBLE | A double (floating point) value.
IS_STRING | A string.
IS_ARRAY | Denotes an array.
IS_OBJECT | An object.
IS_BOOL | A Boolean value.
IS_RESOURCE | A resource (for a discussion of resources, see the appropriate section below).
IS_CONSTANT | A constant (defined) value.

To access a long you access zval.value.lval, to access a double you use zval.value.dval, and so on. Because all values are stored in a union, trying to access data with incorrect union members results in meaningless output.

Accessing arrays and objects is a bit more complicated and is discussed later.

Dealing with Arguments Passed by Reference

If your function accepts arguments passed by reference that you intend to modify, you need to take some precautions.

What we didn't say yet is that under the circumstances presented so far, you don't have write access to any zval containers designating function parameters that have been passed to you. Of course, you can change any zval containers that you created within your function, but you mustn't change any zvals that refer to Zend-internal data!

We've only discussed the so-called *_ex() API so far. You may have noticed that the API functions we've used are called zend_get_parameters_ex() instead of zend_get_parameters(), convert_to_long_ex() instead of convert_to_long(), etc. The *_ex() functions form the so-called new "extended" Zend API. They give a minor speed increase over the old API, but as a tradeoff are only meant for providing read-only access.

Because Zend works internally with references, different variables may reference the same value. Write access to a zval container requires this container to contain an isolated value, meaning a value that's not referenced by any other containers. If a zval container were referenced by other containers and you changed the referenced zval, you would automatically change the contents of the other containers referencing this zval (because they'd simply point to the changed value and thus change their own value as well).

zend_get_parameters_ex() doesn't care about this situation, but simply returns a pointer to the desired zval containers, whether they consist of references or not. Its corresponding function in the traditional API, zend_get_parameters(), immediately checks for referenced values. If it finds a reference, it creates a new, isolated zval container; copies the referenced data into this newly allocated space; and then returns a pointer to the new, isolated value.

This action is called zval separation (or pval separation). Because the *_ex() API doesn't perform zval separation, it's considerably faster, while at the same time disabling write access.

To change parameters, however, write access is required. Zend deals with this situation in a special way: Whenever a parameter to a function is passed by reference, it performs automatic zval separation. This means that whenever you're calling a function like this in PHP, Zend will automatically ensure that $parameter is being passed as an isolated value, rendering it to a write-safe state:

my_function(&$parameter);

But this is not the case with regular parameters! All other parameters that are not passed by reference are in a read-only state.

This requires you to make sure that you're really working with a reference - otherwise you might produce unwanted results. To check for a parameter being passed by reference, you can use the macro PZVAL_IS_REF. This macro accepts a zval* to check if it is a reference or not. Examples are given in in Testing for referenced parameter passing..

Örnek 8 Testing for referenced parameter passing.

zval *parameter;

if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "z", &parameter) == FAILURE)
    return;

/* check for parameter being passed by reference */
if (!PZVAL_IS_REF(parameter)) {
{
    zend_error(E_WARNING, "Parameter wasn't passed by reference");
    RETURN_NULL();
}

/* make changes to the parameter */
ZVAL_LONG(parameter, 10);
Testing for referenced parameter passing

Assuring Write Safety for Other Parameters

You might run into a situation in which you need write access to a parameter that's retrieved with zend_get_parameters_ex() but not passed by reference. For this case, you can use the macro SEPARATE_ZVAL, which does a zval separation on the provided container. The newly generated zval is detached from internal data and has only a local scope, meaning that it can be changed or destroyed without implying global changes in the script context:

zval **parameter;

/* retrieve parameter */
zend_get_parameters_ex(1, &parameter);

/* at this stage, <parameter> still is connected */
/* to Zend's internal data buffers */

/* make <parameter> write-safe */
SEPARATE_ZVAL(parameter);

/* now we can safely modify <parameter> */
/* without implying global changes */
SEPARATE_ZVAL uses emalloc() to allocate the new zval container, which means that even if you don't deallocate this memory yourself, it will be destroyed automatically upon script termination. However, doing a lot of calls to this macro without freeing the resulting containers will clutter up your RAM.

Note: As you can easily work around the lack of write access in the "traditional" API (with zend_get_parameters() and so on), this API seems to be obsolete, and is not discussed further in this chapter.

Creating Variables

When exchanging data from your own extensions with PHP scripts, one of the most important issues is the creation of variables. This section shows you how to deal with the variable types that PHP supports.

Overview

To create new variables that can be seen "from the outside" by the executing script, you need to allocate a new zval container, fill this container with meaningful values, and then introduce it to Zend's internal symbol table. This basic process is common to all variable creations:

zval *new_variable;

/* allocate and initialize new container */
MAKE_STD_ZVAL(new_variable);

/* set type and variable contents here, see the following sections */

/* introduce this variable by the name "new_variable_name" into the symbol table */
ZEND_SET_SYMBOL(EG(active_symbol_table), "new_variable_name", new_variable);

/* the variable is now accessible to the script by using $new_variable_name */

The macro MAKE_STD_ZVAL allocates a new zval container using ALLOC_ZVAL and initializes it using INIT_ZVAL. As implemented in Zend at the time of this writing, initializing means setting the reference count to 1 and clearing the is_ref flag, but this process could be extended later - this is why it's a good idea to keep using MAKE_STD_ZVAL instead of only using ALLOC_ZVAL. If you want to optimize for speed (and you don't have to explicitly initialize the zval container here), you can use ALLOC_ZVAL, but this isn't recommended because it doesn't ensure data integrity.

ZEND_SET_SYMBOL takes care of introducing the new variable to Zend's symbol table. This macro checks whether the value already exists in the symbol table and converts the new symbol to a reference if so (with automatic deallocation of the old zval container). This is the preferred method if speed is not a crucial issue and you'd like to keep memory usage low.

Note that ZEND_SET_SYMBOL makes use of the Zend executor globals via the macro EG. By specifying EG(active_symbol_table), you get access to the currently active symbol table, dealing with the active, local scope. The local scope may differ depending on whether the function was invoked from within a function.

If you need to optimize for speed and don't care about optimal memory usage, you can omit the check for an existing variable with the same value and instead force insertion into the symbol table by using zend_hash_update():

zval *new_variable;

/* allocate and initialize new container */
MAKE_STD_ZVAL(new_variable);

/* set type and variable contents here, see the following sections */

/* introduce this variable by the name "new_variable_name" into the symbol table */
zend_hash_update(
    EG(active_symbol_table),
    "new_variable_name",
    strlen("new_variable_name") + 1,
    &new_variable,
    sizeof(zval *),
    NULL
);
This is actually the standard method used in most modules.

The variables generated with the snippet above will always be of local scope, so they reside in the context in which the function has been called. To create new variables in the global scope, use the same method but refer to another symbol table:

zval *new_variable;

// allocate and initialize new container
MAKE_STD_ZVAL(new_variable);

//
// set type and variable contents here
//

// introduce this variable by the name "new_variable_name" into the global symbol table
ZEND_SET_SYMBOL(&EG(symbol_table), "new_variable_name", new_variable);
The macro ZEND_SET_SYMBOL is now being called with a reference to the main, global symbol table by referring EG(symbol_table).

Note: The active_symbol_table variable is a pointer, but symbol_table is not. This is why you have to use EG(active_symbol_table) and &EG(symbol_table) as parameters to ZEND_SET_SYMBOL - it requires a pointer.

Similarly, to get a more efficient version, you can hardcode the symbol table update:

zval *new_variable;

// allocate and initialize new container
MAKE_STD_ZVAL(new_variable);

//
// set type and variable contents here
//

// introduce this variable by the name "new_variable_name" into the global symbol table
zend_hash_update(
    &EG(symbol_table),
    "new_variable_name",
    strlen("new_variable_name") + 1,
    &new_variable,
    sizeof(zval *),
    NULL
);
Creating variables with different scopes. shows a sample source that creates two variables - local_variable with a local scope and global_variable with a global scope (see Figure 9.7). The full example can be found on the CD-ROM.

Note: You can see that the global variable is actually not accessible from within the function. This is because it's not imported into the local scope using global $global_variable; in the PHP source.

Örnek 9 Creating variables with different scopes.

ZEND_FUNCTION(variable_creation)
{
    zval *new_var1, *new_var2;

    MAKE_STD_ZVAL(new_var1);
    MAKE_STD_ZVAL(new_var2);

    ZVAL_LONG(new_var1, 10);
    ZVAL_LONG(new_var2, 5);

    ZEND_SET_SYMBOL(EG(active_symbol_table), "local_variable", new_var1);
    ZEND_SET_SYMBOL(&EG(symbol_table), "global_variable", new_var2);

    RETURN_NULL();

}
Creating variables with different scopes

Longs (Integers)

Now let's get to the assignment of data to variables, starting with longs. Longs are PHP's integers and are very simple to store. Looking at the zval.value container structure discussed earlier in this chapter, you can see that the long data type is directly contained in the union, namely in the lval field. The corresponding type value for longs is IS_LONG (see Creation of a long.).

Örnek 10 Creation of a long.

zval *new_long;

MAKE_STD_ZVAL(new_long);

new_long-&gt;type = IS_LONG;
new_long-&gt;value.lval = 10;
Alternatively, you can use the macro ZVAL_LONG:
zval *new_long;

MAKE_STD_ZVAL(new_long);
ZVAL_LONG(new_long, 10);

Doubles (Floats)

Doubles are PHP's floats and are as easy to assign as longs, because their value is also contained directly in the union. The member in the zval.value container is dval; the corresponding type is IS_DOUBLE.

zval *new_double;

MAKE_STD_ZVAL(new_double);

new_double-&gt;type = IS_DOUBLE;
new_double-&gt;value.dval = 3.45;
Alternatively, you can use the macro ZVAL_DOUBLE:
zval *new_double;

MAKE_STD_ZVAL(new_double);
ZVAL_DOUBLE(new_double, 3.45);

Strings

Strings need slightly more effort. As mentioned earlier, all strings that will be associated with Zend's internal data structures need to be allocated using Zend's own memory-management functions. Referencing of static strings or strings allocated with standard routines is not allowed. To assign strings, you have to access the structure str in the zval.value container. The corresponding type is IS_STRING:

zval *new_string;
char *string_contents = "This is a new string variable";

MAKE_STD_ZVAL(new_string);

new_string-&gt;type = IS_STRING;
new_string-&gt;value.str.len = strlen(string_contents);
new_string-&gt;value.str.val = estrdup(string_contents);
Note the usage of Zend's estrdup() here. Of course, you can also use the predefined macro ZVAL_STRING:
zval *new_string;
char *string_contents = "This is a new string variable";

MAKE_STD_ZVAL(new_string);
ZVAL_STRING(new_string, string_contents, 1);
ZVAL_STRING accepts a third parameter that indicates whether the supplied string contents should be duplicated (using estrdup()). Setting this parameter to 1 causes the string to be duplicated; 0 simply uses the supplied pointer for the variable contents. This is most useful if you want to create a new variable referring to a string that's already allocated in Zend internal memory.

If you want to truncate the string at a certain position or you already know its length, you can use ZVAL_STRINGL(zval, string, length, duplicate), which accepts an explicit string length to be set for the new string. This macro is faster than ZVAL_STRING and also binary-safe.

To create empty strings, set the string length to 0 and use empty_string as contents:

new_string-&gt;type = IS_STRING;
new_string-&gt;value.str.len = 0;
new_string-&gt;value.str.val = empty_string;
Of course, there's a macro for this as well (ZVAL_EMPTY_STRING):
MAKE_STD_ZVAL(new_string);
ZVAL_EMPTY_STRING(new_string);

Booleans

Booleans are created just like longs, but have the type IS_BOOL. Allowed values in lval are 0 and 1:

zval *new_bool;

MAKE_STD_ZVAL(new_bool);

new_bool-&gt;type = IS_BOOL;
new_bool-&gt;value.lval = 1;
The corresponding macros for this type are ZVAL_BOOL (allowing specification of the value) as well as ZVAL_TRUE and ZVAL_FALSE (which explicitly set the value to TRUE and FALSE, respectively).

Arrays

Arrays are stored using Zend's internal hash tables, which can be accessed using the zend_hash_*() API. For every array that you want to create, you need a new hash table handle, which will be stored in the ht member of the zval.value container.

There's a whole API solely for the creation of arrays, which is extremely handy. To start a new array, you call array_init().

zval *new_array;

MAKE_STD_ZVAL(new_array);

array_init(new_array);
array_init() always returns SUCCESS.

To add new elements to the array, you can use numerous functions, depending on what you want to do. Zend's API for Associative Arrays, Zend's API for Indexed Arrays, Part 1 and Zend's API for Indexed Arrays, Part 2 describe these functions. All functions return FAILURE on failure and SUCCESS on success.

Zend's API for Associative Arrays
Function | Description
add_assoc_long(zval *array, char *key, long n);() | Adds an element of type long.
add_assoc_unset(zval *array, char *key);() | Adds an unset element.
add_assoc_bool(zval *array, char *key, int b);() | Adds a Boolean element.
add_assoc_resource(zval *array, char *key, int r);() | Adds a resource to the array.
add_assoc_double(zval *array, char *key, double d);() | Adds a floating-point value.
add_assoc_string(zval *array, char *key, char *str, int duplicate);() | Adds a string to the array. The flag duplicate specifies whether the string contents have to be copied to Zend internal memory.
add_assoc_stringl(zval *array, char *key, char *str, uint length, int duplicate); () | Adds a string with the desired length length to the array. Otherwise, behaves like add_assoc_string().
add_assoc_zval(zval *array, char *key, zval *value);() | Adds a zval to the array. Useful for adding other arrays, objects, streams, etc...
Zend's API for Indexed Arrays, Part 1
Function | Description
add_index_long(zval *array, uint idx, long n);() | Adds an element of type long.
add_index_unset(zval *array, uint idx);() | Adds an unset element.
add_index_bool(zval *array, uint idx, int b);() | Adds a Boolean element.
add_index_resource(zval *array, uint idx, int r);() | Adds a resource to the array.
add_index_double(zval *array, uint idx, double d);() | Adds a floating-point value.
add_index_string(zval *array, uint idx, char *str, int duplicate);() | Adds a string to the array. The flag duplicate specifies whether the string contents have to be copied to Zend internal memory.
add_index_stringl(zval *array, uint idx, char *str, uint length, int duplicate);() | Adds a string with the desired length length to the array. This function is faster and binary-safe. Otherwise, behaves like add_index_string().
add_index_zval(zval *array, uint idx, zval *value);() | Adds a zval to the array. Useful for adding other arrays, objects, streams, etc...
Zend's API for Indexed Arrays, Part 2
Function | Description
add_next_index_long(zval *array, long n);() | Adds an element of type long.
add_next_index_unset(zval *array);() | Adds an unset element.
add_next_index_bool(zval *array, int b);() | Adds a Boolean element.
add_next_index_resource(zval *array, int r);() | Adds a resource to the array.
add_next_index_double(zval *array, double d);() | Adds a floating-point value.
add_next_index_string(zval *array, char *str, int duplicate);() | Adds a string to the array. The flag duplicate specifies whether the string contents have to be copied to Zend internal memory.
add_next_index_stringl(zval *array, char *str, uint length, int duplicate);() | Adds a string with the desired length length to the array. This function is faster and binary-safe. Otherwise, behaves like add_index_string().
add_next_index_zval(zval *array, zval *value);() | Adds a zval to the array. Useful for adding other arrays, objects, streams, etc...

All these functions provide a handy abstraction to Zend's internal hash API. Of course, you can also use the hash functions directly - for example, if you already have a zval container allocated that you want to insert into an array. This is done using zend_hash_update() for associative arrays (see Adding an element to an associative array.) and zend_hash_index_update() for indexed arrays (see Adding an element to an indexed array.):

Örnek 11 Adding an element to an associative array.

zval *new_array, *new_element;
char *key = "element_key";

MAKE_STD_ZVAL(new_array);
MAKE_STD_ZVAL(new_element);

array_init(new_array);

ZVAL_LONG(new_element, 10);

if(zend_hash_update(new_array-&gt;value.ht, key, strlen(key) + 1, (void *)&new_element, sizeof(zval *), NULL) == FAILURE)
{
    // do error handling here
}

Örnek 12 Adding an element to an indexed array.

zval *new_array, *new_element;
int key = 2;

MAKE_STD_ZVAL(new_array);
MAKE_STD_ZVAL(new_element);

array_init(new_array);

ZVAL_LONG(new_element, 10);

if(zend_hash_index_update(new_array-&gt;value.ht, key, (void *)&new_element, sizeof(zval *), NULL) == FAILURE)
{
    // do error handling here
}

To emulate the functionality of add_next_index_*(), you can use this:

zend_hash_next_index_insert(ht, zval **new_element, sizeof(zval *), NULL)

Note: To return arrays from a function, use array_init() and all following actions on the predefined variable return_value (given as argument to your exported function; see the earlier discussion of the call interface). You do not have to use MAKE_STD_ZVAL on this.

Tip: To avoid having to write new_array->value.ht every time, you can use HASH_OF(new_array), which is also recommended for compatibility and style reasons.

Objects

Since objects can be converted to arrays (and vice versa), you might have already guessed that they have a lot of similarities to arrays in PHP. Objects are maintained with the same hash functions, but there's a different API for creating them.

To initialize an object, you use the function object_init():

zval *new_object;

MAKE_STD_ZVAL(new_object);

if(object_init(new_object) != SUCCESS)
{
    // do error handling here
}
You can use the functions described in Zend's API for Object Creation to add members to your object.

Zend's API for Object Creation
Function | Description
add_property_long(zval *object, char *key, long l);() | Adds a long to the object.
add_property_unset(zval *object, char *key);() | Adds an unset property to the object.
add_property_bool(zval *object, char *key, int b);() | Adds a Boolean to the object.
add_property_resource(zval *object, char *key, long r);() | Adds a resource to the object.
add_property_double(zval *object, char *key, double d);() | Adds a double to the object.
add_property_string(zval *object, char *key, char *str, int duplicate);() | Adds a string to the object.
add_property_stringl(zval *object, char *key, char *str, uint length, int duplicate);() | Adds a string of the specified length to the object. This function is faster than add_property_string() and also binary-safe.
add_property_zval(zval *obect, char *key, zval *container):() | Adds a zval container to the object. This is useful if you have to add properties which aren't simple types like integers or strings but arrays or other objects.

Resources

Resources are a special kind of data type in PHP. The term resources doesn't really refer to any special kind of data, but to an abstraction method for maintaining any kind of information. Resources are kept in a special resource list within Zend. Each entry in the list has a correspondending type definition that denotes the kind of resource to which it refers. Zend then internally manages all references to this resource. Access to a resource is never possible directly - only via a provided API. As soon as all references to a specific resource are lost, a corresponding shutdown function is called.

For example, resources are used to store database links and file descriptors. The de facto standard implementation can be found in the MySQL module, but other modules such as the Oracle module also make use of resources.

Bilginize:

In fact, a resource can be a pointer to anything you need to handle in your functions (e.g. pointer to a structure) and the user only has to pass a single resource variable to your function.

To create a new resource you need to register a resource destruction handler for it. Since you can store any kind of data as a resource, Zend needs to know how to free this resource if its not longer needed. This works by registering your own resource destruction handler to Zend which in turn gets called by Zend whenever your resource can be freed (whether manually or automatically). Registering your resource handler within Zend returns you the resource type handle for that resource. This handle is needed whenever you want to access a resource of this type later and is most of time stored in a global static variable within your extension. There is no need to worry about thread safety here because you only register your resource handler once during module initialization.

The Zend function to register your resource handler is defined as:

ZEND_API int zend_register_list_destructors_ex(rsrc_dtor_func_t ld, rsrc_dtor_func_t pld, char *type_name, int module_number);

There are two different kinds of resource destruction handlers you can pass to this function: a handler for normal resources and a handler for persistent resources. Persistent resources are for example used for database connection. When registering a resource, either of these handlers must be given. For the other handler just pass NULL.

zend_register_list_destructors_ex() accepts the following parameters:

ld | Normal resource destruction handler callback
pld | Pesistent resource destruction handler callback
type_name | A string specifying the name of your resource. It's always a good thing to specify a unique name within PHP for the resource type so when the user for example calls var_dump($resource); he also gets the name of the resource.
module_number | The module_number is automatically available in your PHP_MINIT_FUNCTION function and therefore you just pass it over.
The return value is a unique integer ID for your resource type.

The resource destruction handler (either normal or persistent resources) has the following prototype:

void resource_destruction_handler(zend_rsrc_list_entry *rsrc TSRMLS_DC);
The passed rsrc is a pointer to the following structure:
typedef struct _zend_rsrc_list_entry {

    void *ptr;
    int type;
    int refcount;

} zend_rsrc_list_entry;
The member void *ptr is the actual pointer to your resource.

Now we know how to start things, we define our own resource we want register within Zend. It is only a simple structure with two integer members:

typedef struct {

    int resource_link;
    int resource_type;

} my_resource;
Our resource destruction handler is probably going to look something like this:
void my_destruction_handler(zend_rsrc_list_entry *rsrc TSRMLS_DC) {

    // You most likely cast the void pointer to your structure type

    my_resource *my_rsrc = (my_resource *) rsrc->ptr;

    // Now do whatever needs to be done with you resource. Closing
    // Files, Sockets, freeing additional memory, etc.
    // Also, don't forget to actually free the memory for your resource too!

    do_whatever_needs_to_be_done_with_the_resource(my_rsrc);
}

Bilginize:

One important thing to mention: If your resource is a rather complex structure which also contains pointers to memory you allocated during runtime you have to free them before freeing the resource itself!

Now that we have defined

  1. what our resource is and

  2. our resource destruction handler

we can go on and do the rest of the steps:

  1. create a global variable within the extension holding the resource ID so it can be accessed from every function which needs it

  2. define the resource name

  3. write the resource destruction handler

  4. and finally register the handler

// Somewhere in your extension, define the variable for your registered resources.
    // If you wondered what 'le' stands for: it simply means 'list entry'.
    static int le_myresource;

    // It's nice to define your resource name somewhere
    #define le_myresource_name  "My type of resource"

    [...]

    // Now actually define our resource destruction handler
    void my_destruction_handler(zend_rsrc_list_entry *rsrc TSRMLS_DC) {

        my_resource *my_rsrc = (my_resource *) rsrc->ptr;
        do_whatever_needs_to_be_done_with_the_resource(my_rsrc);
    }

    [...]

    PHP_MINIT_FUNCTION(my_extension) {

        // Note that 'module_number' is already provided through the
        // PHP_MINIT_FUNCTION() function definition.

        le_myresource = zend_register_list_destructors_ex(my_destruction_handler, NULL, le_myresource_name, module_number);

        // You can register additional resources, initialize
        // your global vars, constants, whatever.
    }

To actually register a new resource you use can either use the zend_register_resource() function or the ZEND_REGISTER_RESOURE() macro, both defined in zend_list.h. Although the arguments for both map 1:1 it's a good idea to always use macros to be upwards compatible:

int ZEND_REGISTER_RESOURCE(zval *rsrc_result, void *rsrc_pointer, int rsrc_type);
rsrc_result | This is an already initialized zval * container.
rsrc_pointer | Your resource pointer you want to store.
rsrc_type | The type which you received when you registered the resource destruction handler. If you followed the naming scheme this would be le_myresource.
The return value is a unique integer identifier for that resource.

What is really going on when you register a new resource is it gets inserted in an internal list in Zend and the result is just stored in the given zval * container:

rsrc_id = zend_list_insert(rsrc_pointer, rsrc_type);

    if (rsrc_result) {
        rsrc_result->value.lval = rsrc_id;
        rsrc_result->type = IS_RESOURCE;
    }

    return rsrc_id;
The returned rsrc_id uniquely identifies the newly registered resource. You can use the macro RETURN_RESOURE to return it to the user:
    RETURN_RESOURCE(rsrc_id)

Bilginize:

It is common practice that if you want to return the resource immediately to the user you specify the return_value as the zval * container.

Zend now keeps track of all references to this resource. As soon as all references to the resource are lost, the destructor that you previously registered for this resource is called. The nice thing about this setup is that you don't have to worry about memory leakages introduced by allocations in your module - just register all memory allocations that your calling script will refer to as resources. As soon as the script decides it doesn't need them anymore, Zend will find out and tell you.

Now that the user got his resource, at some point he is passing it back to one of your functions. The value.lval inside the zval * container contains the key to your resource and thus can be used to fetch the resource with the following macro: ZEND_FETCH_RESOURCE:

ZEND_FETCH_RESOURCE(rsrc, rsrc_type, rsrc_id, default_rsrc_id, resource_type_name, resource_type)
rsrc | This is your pointer which will point to your previously registered resource.
rsrc_type | This is the typecast argument for your pointer, e.g. myresource *.
rsrc_id | This is the address of the zval *container the user passed to your function, e.g. &z_resource if zval *z_resource is given.
default_rsrc_id | This integer specifies the default resource ID if no resource could be fetched or -1.
resource_type_name | This is the name of the requested resource. It's a string and is used when the resource can't be found or is invalid to form a meaningful error message.
resource_type | The resource_type you got back when registering the resource destruction handler. In our example this was le_myresource.
This macro has no return value. It is for the developers convenience and takes care of TSRMLS arguments passing and also does check if the resource could be fetched. It throws a warning message and returns the current PHP function with NULL if there was a problem retrieving the resource.

To force removal of a resource from the list, use the function zend_list_delete(). You can also force the reference count to increase if you know that you're creating another reference for a previously allocated value (for example, if you're automatically reusing a default database link). For this case, use the function zend_list_addref(). To search for previously allocated resource entries, use zend_list_find(). The complete API can be found in zend_list.h.

Macros for Automatic Global Variable Creation

In addition to the macros discussed earlier, a few macros allow easy creation of simple global variables. These are nice to know in case you want to introduce global flags, for example. This is somewhat bad practice, but Table Macros for Global Variable Creation describes macros that do exactly this task. They don't need any zval allocation; you simply have to supply a variable name and value.

Macros for Global Variable Creation
Macro | Description
SET_VAR_STRING(name, value) | Creates a new string.
SET_VAR_STRINGL(name, value, length) | Creates a new string of the specified length. This macro is faster than SET_VAR_STRING and also binary-safe.
SET_VAR_LONG(name, value) | Creates a new long.
SET_VAR_DOUBLE(name, value) | Creates a new double.

Creating Constants

Zend supports the creation of true constants (as opposed to regular variables). Constants are accessed without the typical dollar sign ($) prefix and are available in all scopes. Examples include TRUE and FALSE, to name just two.

To create your own constants, you can use the macros in Macros for Creating Constants. All the macros create a constant with the specified name and value.

You can also specify flags for each constant:

  • CONST_CS - This constant's name is to be treated as case sensitive.

  • CONST_PERSISTENT - This constant is persistent and won't be "forgotten" when the current process carrying this constant shuts down.

To use the flags, combine them using a inary OR:
 // register a new constant of type "long"
     REGISTER_LONG_CONSTANT("NEW_MEANINGFUL_CONSTANT", 324, CONST_CS |
     CONST_PERSISTENT);
There are two types of macros - REGISTER_*_CONSTANT andREGISTER_MAIN_*_CONSTANT. The first type creates constants bound to the current module. These constants are dumped from the symbol table as soon as the module that registered the constant is unloaded from memory. The second type creates constants that remain in the symbol table independently of the module.

Macros for Creating Constants
Macro | Description
REGISTER_LONG_CONSTANT(name, value, flags) REGISTER_MAIN_LONG_CONSTANT(name, value, flags) | Registers a new constant of type long.
REGISTER_DOUBLE_CONSTANT(name, value, flags) REGISTER_MAIN_DOUBLE_CONSTANT(name, value, flags) | Registers a new constant of type double.
REGISTER_STRING_CONSTANT(name, value, flags) REGISTER_MAIN_STRING_CONSTANT(name, value, flags) | Registers a new constant of type string. The specified string must reside in Zend's internal memory.
REGISTER_STRINGL_CONSTANT(name, value, length, flags) REGISTER_MAIN_STRINGL_CONSTANT(name, value, length, flags) | Registers a new constant of type string. The string length is explicitly set to length. The specified string must reside in Zend's internal memory.

Duplicating Variable Contents: The Copy Constructor

Sooner or later, you may need to assign the contents of one zval container to another. This is easier said than done, since the zval container doesn't contain only type information, but also references to places in Zend's internal data. For example, depending on their size, arrays and objects may be nested with lots of hash table entries. By assigning one zval to another, you avoid duplicating the hash table entries, using only a reference to them (at most).

To copy this complex kind of data, use the copy constructor. Copy constructors are typically defined in languages that support operator overloading, with the express purpose of copying complex types. If you define an object in such a language, you have the possibility of overloading the "=" operator, which is usually responsible for assigning the contents of the rvalue (result of the evaluation of the right side of the operator) to the lvalue (same for the left side).

Overloading means assigning a different meaning to this operator, and is usually used to assign a function call to an operator. Whenever this operator would be used on such an object in a program, this function would be called with the lvalue and rvalue as parameters. Equipped with that information, it can perform the operation it intends the "=" operator to have (usually an extended form of copying).

This same form of "extended copying" is also necessary for PHP's zval containers. Again, in the case of an array, this extended copying would imply re-creation of all hash table entries relating to this array. For strings, proper memory allocation would have to be assured, and so on.

Zend ships with such a function, called zend_copy_ctor() (the previous PHP equivalent was pval_copy_constructor()).

A most useful demonstration is a function that accepts a complex type as argument, modifies it, and then returns the argument:

zval *parameter;

if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "z", &parameter) == FAILURE)
   return;
}

// do modifications to the parameter here

// now we want to return the modified container:
*return_value = *parameter;
zval_copy_ctor(return_value);

The first part of the function is plain-vanilla argument retrieval. After the (left out) modifications, however, it gets interesting: The container of parameter is assigned to the (predefined) return_value container. Now, in order to effectively duplicate its contents, the copy constructor is called. The copy constructor works directly with the supplied argument, and the standard return values are FAILURE on failure and SUCCESS on success.

If you omit the call to the copy constructor in this example, both parameter and return_value would point to the same internal data, meaning that return_value would be an illegal additional reference to the same data structures. Whenever changes occurred in the data that parameter points to, return_value might be affected. Thus, in order to create separate copies, the copy constructor must be used.

The copy constructor's counterpart in the Zend API, the destructor zval_dtor(), does the opposite of the constructor.

Returning Values

Returning values from your functions to PHP was described briefly in an earlier section; this section gives the details. Return values are passed via the return_value variable, which is passed to your functions as argument. The return_value argument consists of a zval container (see the earlier discussion of the call interface) that you can freely modify. The container itself is already allocated, so you don't have to run MAKE_STD_ZVAL on it. Instead, you can access its members directly.

To make returning values from functions easier and to prevent hassles with accessing the internal structures of the zval container, a set of predefined macros is available (as usual). These macros automatically set the correspondent type and value, as described in Predefined Macros for Returning Values from a Function and Predefined Macros for Setting the Return Value of a Function.

Bilginize:

The macros in Predefined Macros for Returning Values from a Function automatically return from your function, those in Predefined Macros for Setting the Return Value of a Function only set the return value; they don't return from your function.

Predefined Macros for Returning Values from a Function
Macro | Description
RETURN_RESOURCE(resource) | Returns a resource.
RETURN_BOOL(bool) | Returns a Boolean.
RETURN_NULL() | Returns nothing (a NULL value).
RETURN_LONG(long) | Returns a long.
RETURN_DOUBLE(double) | Returns a double.
RETURN_STRING(string, duplicate) | Returns a string. The duplicate flag indicates whether the string should be duplicated using estrdup().
RETURN_STRINGL(string, length, duplicate) | Returns a string of the specified length; otherwise, behaves like RETURN_STRING. This macro is faster and binary-safe, however.
RETURN_EMPTY_STRING() | Returns an empty string.
RETURN_FALSE | Returns Boolean false.
RETURN_TRUE | Returns Boolean true.
Predefined Macros for Setting the Return Value of a Function
Macro | Description
RETVAL_RESOURCE(resource) | Sets the return value to the specified resource.
RETVAL_BOOL(bool) | Sets the return value to the specified Boolean value.
RETVAL_NULL | Sets the return value to NULL.
RETVAL_LONG(long) | Sets the return value to the specified long.
RETVAL_DOUBLE(double) | Sets the return value to the specified double.
RETVAL_STRING(string, duplicate) | Sets the return value to the specified string and duplicates it to Zend internal memory if desired (see also RETURN_STRING).
RETVAL_STRINGL(string, length, duplicate) | Sets the return value to the specified string and forces the length to become length (see also RETVAL_STRING). This macro is faster and binary-safe, and should be used whenever the string length is known.
RETVAL_EMPTY_STRING | Sets the return value to an empty string.
RETVAL_FALSE | Sets the return value to Boolean false.
RETVAL_TRUE | Sets the return value to Boolean true.

Complex types such as arrays and objects can be returned by using array_init() and object_init(), as well as the corresponding hash functions on return_value. Since these types cannot be constructed of trivial information, there are no predefined macros for them.

Printing Information

Often it's necessary to print messages to the output stream from your module, just as print would be used within a script. PHP offers functions for most generic tasks, such as printing warning messages, generating output for phpinfo(), and so on. The following sections provide more details. Examples of these functions can be found on the CD-ROM.

zend_printf()

zend_printf() works like the standard printf(), except that it prints to Zend's output stream.

zend_error()

zend_error() can be used to generate error messages. This function accepts two arguments; the first is the error type (see zend_errors.h), and the second is the error message.

zend_error(E_WARNING, "This function has been called with empty arguments");
Zend's Predefined Error Messages. shows a list of possible values (see below). These values are also referred to in php.ini. Depending on which error type you choose, your messages will be logged.
Zend's Predefined Error Messages.
Error | Description
E_ERROR | Signals an error and terminates execution of the script immediately.
E_WARNING | Signals a generic warning. Execution continues.
E_PARSE | Signals a parser error. Execution continues.
E_NOTICE | Signals a notice. Execution continues. Note that by default the display of this type of error messages is turned off in php.ini.
E_CORE_ERROR | Internal error by the core; shouldn't be used by user-written modules.
E_COMPILE_ERROR | Internal error by the compiler; shouldn't be used by user-written modules.
E_COMPILE_WARNING | Internal warning by the compiler; shouldn't be used by user-written modules.
Display of warning messages in the browser.

Including Output in phpinfo()

After creating a real module, you'll want to show information about the module in phpinfo() (in addition to the module name, which appears in the module list by default). PHP allows you to create your own section in the phpinfo() output with the ZEND_MINFO() function. This function should be placed in the module descriptor block (discussed earlier) and is always called whenever a script calls phpinfo().

PHP automatically prints a section in phpinfo() for you if you specify the ZEND_MINFO function, including the module name in the heading. Everything else must be formatted and printed by you.

Typically, you can print an HTML table header using php_info_print_table_start() and then use the standard functions php_info_print_table_header() and php_info_print_table_row(). As arguments, both take the number of columns (as integers) and the column contents (as strings). Source code and screenshot for output in phpinfo. shows a source example and its output. To print the table footer, use php_info_print_table_end().

Örnek 13 Source code and screenshot for output in phpinfo().

php_info_print_table_start();
php_info_print_table_header(2, "First column", "Second column");
php_info_print_table_row(2, "Entry in first row", "Another entry");
php_info_print_table_row(2, "Just to fill", "another row here");
php_info_print_table_end();
Output of phpinfo()

Execution Information

You can also print execution information, such as the current file being executed. The name of the function currently being executed can be retrieved using the function get_active_function_name(). This function returns a pointer to the function name and doesn't accept any arguments. To retrieve the name of the file currently being executed, use zend_get_executed_filename(). This function accesses the executor globals, which are passed to it using the TSRMLS_C macro. The executor globals are automatically available to every function that's called directly by Zend (they're part of the INTERNAL_FUNCTION_PARAMETERS described earlier in this chapter). If you want to access the executor globals in another function that doesn't have them available automatically, call the macro TSRMLS_FETCH() once in that function; this will introduce them to your local scope.

Finally, the line number currently being executed can be retrieved using the function zend_get_executed_lineno(). This function also requires the executor globals as arguments. For examples of these functions, see Printing execution information..

Örnek 14 Printing execution information.

zend_printf("The name of the current function is %s&lt;br&gt;", get_active_function_name(TSRMLS_C));
zend_printf("The file currently executed is %s&lt;br&gt;", zend_get_executed_filename(TSRMLS_C));
zend_printf("The current line being executed is %i&lt;br&gt;", zend_get_executed_lineno(TSRMLS_C));
Printing execution information

Startup and Shutdown Functions

Startup and shutdown functions can be used for one-time initialization and deinitialization of your modules. As discussed earlier in this chapter (see the description of the Zend module descriptor block), there are module, and request startup and shutdown events.

The module startup and shutdown functions are called whenever a module is loaded and needs initialization; the request startup and shutdown functions are called every time a request is processed (meaning that a file is being executed).

For dynamic extensions, module and request startup/shutdown events happen at the same time.

Declaration and implementation of these functions can be done with macros; see the earlier section "Declaration of the Zend Module Block" for details.

Calling User Functions

You can call user functions from your own modules, which is very handy when implementing callbacks; for example, for array walking, searching, or simply for event-based programs.

User functions can be called with the function call_user_function_ex(). It requires a hash value for the function table you want to access, a pointer to an object (if you want to call a method), the function name, return value, number of arguments, argument array, and a flag indicating whether you want to perform zval separation.

ZEND_API int call_user_function_ex(HashTable *function_table, zval *object,
zval *function_name, zval **retval_ptr_ptr,
int param_count, zval **params[],
int no_separation);

Note that you don't have to specify both function_table and object; either will do. If you want to call a method, you have to supply the object that contains this method, in which case call_user_function()automatically sets the function table to this object's function table. Otherwise, you only need to specify function_table and can set object to NULL.

Usually, the default function table is the "root" function table containing all function entries. This function table is part of the compiler globals and can be accessed using the macro CG. To introduce the compiler globals to your function, call the macro TSRMLS_FETCH once.

The function name is specified in a zval container. This might be a bit surprising at first, but is quite a logical step, since most of the time you'll accept function names as parameters from calling functions within your script, which in turn are contained in zval containers again. Thus, you only have to pass your arguments through to this function. This zval must be of type IS_STRING.

The next argument consists of a pointer to the return value. You don't have to allocate memory for this container; the function will do so by itself. However, you have to destroy this container (using zval_dtor()) afterward!

Next is the parameter count as integer and an array containing all necessary parameters. The last argument specifies whether the function should perform zval separation - this should always be set to 0. If set to 1, the function consumes less memory but fails if any of the parameters need separation.

Calling user functions. shows a small demonstration of calling a user function. The code calls a function that's supplied to it as argument and directly passes this function's return value through as its own return value. Note the use of the constructor and destructor calls at the end - it might not be necessary to do it this way here (since they should be separate values, the assignment might be safe), but this is bulletproof.

Örnek 15 Calling user functions.

zval **function_name;
zval *retval;

if((ZEND_NUM_ARGS() != 1) || (zend_get_parameters_ex(1, &function_name) != SUCCESS))
{
    WRONG_PARAM_COUNT;
}

if((*function_name)->type != IS_STRING)
{
    zend_error(E_ERROR, "Function requires string argument");
}

TSRMSLS_FETCH();

if(call_user_function_ex(CG(function_table), NULL, *function_name, &retval, 0, NULL, 0) != SUCCESS)
{
    zend_error(E_ERROR, "Function call failed");
}

zend_printf("We have %i as type\n", retval->type);

*return_value = *retval;
zval_copy_ctor(return_value);
zval_ptr_dtor(&retval);

<?php

dl("call_userland.so");

function test_function()
{
    echo "We are in the test function!\n";
    return 'hello';
}

$return_value = call_userland("test_function");

echo "Return value: '$return_value'";
?>

Yukarıdaki örneğin çıktısı:

We are in the test function!
We have 3 as type
Return value: 'hello'

Initialization File Support

PHP 4 features a redesigned initialization file support. It's now possible to specify default initialization entries directly in your code, read and change these values at runtime, and create message handlers for change notifications.

To create an .ini section in your own module, use the macros PHP_INI_BEGIN() to mark the beginning of such a section and PHP_INI_END() to mark its end. In between you can use PHP_INI_ENTRY() to create entries.

PHP_INI_BEGIN()
PHP_INI_ENTRY("first_ini_entry",  "has_string_value", PHP_INI_ALL, NULL)
PHP_INI_ENTRY("second_ini_entry", "2",                PHP_INI_SYSTEM, OnChangeSecond)
PHP_INI_ENTRY("third_ini_entry",  "xyz",              PHP_INI_USER, NULL)
PHP_INI_END()
The PHP_INI_ENTRY() macro accepts four parameters: the entry name, the entry value, its change permissions, and a pointer to a change-notification handler. Both entry name and value must be specified as strings, regardless of whether they really are strings or integers.

The permissions are grouped into three sections:PHP_INI_SYSTEM allows a change only directly in the php.ini file; PHP_INI_USER allows a change to be overridden by a user at runtime using additional configuration files, such as .htaccess; and PHP_INI_ALL allows changes to be made without restrictions. There's also a fourth level, PHP_INI_PERDIR, for which we couldn't verify its behavior yet.

The fourth parameter consists of a pointer to a change-notification handler. Whenever one of these initialization entries is changed, this handler is called. Such a handler can be declared using the PHP_INI_MH macro:

PHP_INI_MH(OnChangeSecond);             // handler for ini-entry "second_ini_entry"

// specify ini-entries here

PHP_INI_MH(OnChangeSecond)
{

    zend_printf("Message caught, our ini entry has been changed to %s&lt;br&gt;", new_value);

    return(SUCCESS);

}
The new value is given to the change handler as string in the variable new_value. When looking at the definition of PHP_INI_MH, you actually have a few parameters to use:
#define PHP_INI_MH(name) int name(php_ini_entry *entry, char *new_value,
                                  uint new_value_length, void *mh_arg1,
                                  void *mh_arg2, void *mh_arg3)
All these definitions can be found in php_ini.h. Your message handler will have access to a structure that contains the full entry, the new value, its length, and three optional arguments. These optional arguments can be specified with the additional macros PHP_INI_ENTRY1 (allowing one additional argument), PHP_INI_ENTRY2 (allowing two additional arguments), and PHP_INI_ENTRY3 (allowing three additional arguments).

The change-notification handlers should be used to cache initialization entries locally for faster access or to perform certain tasks that are required if a value changes. For example, if a constant connection to a certain host is required by a module and someone changes the hostname, automatically terminate the old connection and attempt a new one.

Access to initialization entries can also be handled with the macros shown in Macros to Access Initialization Entries in PHP.

Macros to Access Initialization Entries in PHP
Macro | Description
INI_INT(name) | Returns the current value of entry name as integer (long).
INI_FLT(name) | Returns the current value of entry name as float (double).
INI_STR(name) | Returns the current value of entry name as string. Note: This string is not duplicated, but instead points to internal data. Further access requires duplication to local memory.
INI_BOOL(name) | Returns the current value of entry name as Boolean (defined as zend_bool, which currently means unsigned char).
INI_ORIG_INT(name) | Returns the original value of entry name as integer (long).
INI_ORIG_FLT(name) | Returns the original value of entry name as float (double).
INI_ORIG_STR(name) | Returns the original value of entry name as string. Note: This string is not duplicated, but instead points to internal data. Further access requires duplication to local memory.
INI_ORIG_BOOL(name) | Returns the original value of entry name as Boolean (defined as zend_bool, which currently means unsigned char).

Finally, you have to introduce your initialization entries to PHP. This can be done in the module startup and shutdown functions, using the macros REGISTER_INI_ENTRIES() and UNREGISTER_INI_ENTRIES():

ZEND_MINIT_FUNCTION(mymodule)
{

    REGISTER_INI_ENTRIES();

}

ZEND_MSHUTDOWN_FUNCTION(mymodule)
{

    UNREGISTER_INI_ENTRIES();

}

Where to Go from Here

You've learned a lot about PHP. You now know how to create dynamic loadable modules and statically linked extensions. You've learned how PHP and Zend deal with internal storage of variables and how you can create and access these variables. You know quite a set of tool functions that do a lot of routine tasks such as printing informational texts, automatically introducing variables to the symbol table, and so on.

Even though this chapter often had a mostly "referential" character, we hope that it gave you insight on how to start writing your own extensions. For the sake of space, we had to leave out a lot; we suggest that you take the time to study the header files and some modules (especially the ones in the ext/standard directory and the MySQL module, as these implement commonly known functionality). This will give you an idea of how other people have used the API functions - particularly those that didn't make it into this chapter.

Reference: Some Configuration Macros

config.m4

The file config.m4 is processed by buildconf and must contain all the instructions to be executed during configuration. For example, these can include tests for required external files, such as header files, libraries, and so on. PHP defines a set of macros that can be used in this process, the most useful of which are described in M4 Macros for config.m4.

M4 Macros for config.m4
Macro | Description
AC_MSG_CHECKING(message) | Prints a "checking <message>" text during configure.
AC_MSG_RESULT(value) | Gives the result to AC_MSG_CHECKING; should specify either yes or no as value.
AC_MSG_ERROR(message) | Prints message as error message during configure and aborts the script.
AC_DEFINE(name,value,description) | Adds #define to php_config.h with the value of value and a comment that says description (this is useful for conditional compilation of your module).
AC_ADD_INCLUDE(path) | Adds a compiler include path; for example, used if the module needs to add search paths for header files.
AC_ADD_LIBRARY_WITH_PATH(libraryname,librarypath) | Specifies an additional library to link.
AC_ARG_WITH(modulename,description,unconditionaltest,conditionaltest) | Quite a powerful macro, adding the module with description to the configure --help output. PHP checks whether the option --with-<modulename> is given to the configure script. If so, it runs the script unconditionaltest (for example, --with-myext=yes), in which case the value of the option is contained in the variable $withval. Otherwise, it executes conditionaltest.
PHP_EXTENSION(modulename, [shared]) | This macro is a must to call for PHP to configure your extension. You can supply a second argument in addition to your module name, indicating whether you intend compilation as a shared module. This will result in a definition at compile time for your source as COMPILE_DL_<modulename>.

API Macros

A set of macros was introduced into Zend's API that simplify access to zval containers (see API Macros for Accessing zval Containers).

API Macros for Accessing zval Containers
Macro | Refers to
Z_LVAL(zval) | (zval).value.lval
Z_DVAL(zval) | (zval).value.dval
Z_STRVAL(zval) | (zval).value.str.val
Z_STRLEN(zval) | (zval).value.str.len
Z_ARRVAL(zval) | (zval).value.ht
Z_LVAL_P(zval) | (*zval).value.lval
Z_DVAL_P(zval) | (*zval).value.dval
Z_STRVAL_P(zval_p) | (*zval).value.str.val
Z_STRLEN_P(zval_p) | (*zval).value.str.len
Z_ARRVAL_P(zval_p) | (*zval).value.ht
Z_LVAL_PP(zval_pp) | (**zval).value.lval
Z_DVAL_PP(zval_pp) | (**zval).value.dval
Z_STRVAL_PP(zval_pp) | (**zval).value.str.val
Z_STRLEN_PP(zval_pp) | (**zval).value.str.len
Z_ARRVAL_PP(zval_pp) | (**zval).value.ht
Streams API for PHP Extension Authors
TSRM API
Zend Engine 1


TSRM API

Zend API; PHP Çekirdeğinin Geliştirilmesi
SSS
Zend Engine 1


Sıkça Sorulan Sorular

  • Genel Bilgi
  • Eposta listeleri — Posta Listeleri
  • PHP'nin Temini
  • Veritabanı Sorunları
  • Kurulum
  • Derleme Sorunları
  • PHP Kullanımı
  • Parola Karıştırma — Güvenli Parola Karıştırma
  • PHP ve HTML
  • PHP ve COM
  • Çeşitli Sorular
TSRM API
Genel Bilgi
PHP Kılavuzu


Genel Bilgi

Bu bölümde PHP ile ilgili en genel sorulara yer verilmiştir: Nedir ve ne yapar?

  1. PHP nedir?
  2. PHP'nin açılımı nedir?
  3. Sürümler arasındaki ilişki nedir?
  4. PHP'nin farklı sürümlerini aynı anda çalıştırabilir miyim?
  5. Bir hata buldum! Kime söylemeliyim?
PHP nedir?

Kılavuzun önsözünden bir alıntı:

PHP, HTML içine gömülebilen bir betik dilidir. Sözdiziminin çoğunu C, Java ve Perl'den almış ve bunun üzerine PHP'ye özgü bir sürü eşsiz özellik eklenmiştir. Dilin amacı site geliştirenlere devingen olarak hızla üretilen sayfalar yazabilme imkanı vermektir.

PHP'nin açılımı nedir?

PHP kısaltmasının açılımı PHP: Hypertext Preprocessor olup anlamı PHP: Hiper Metin Önişlemcisi'dir. Kısaltmanın ilk harfinin kısaltmanın kısaltması olması çoğu kişiyi şaşırtmaktadır. Bu tür kısaltmalara iç içe kısaltmalar adı verilmektedir. Meraklılar, daha ayrıntılı bilgi edinmek için » FOLDOC veya » Wikipedia'ya bakabilirler.

Sürümler arasındaki ilişki nedir?

PHP/FI 2.0 bir erken dönem ve artık desteklenmeyen bir PHP sürümüdür. PHP 3, PHP/FI 2.0'ın ardılı olup, çok daha gelişmişidir. PHP 5, PHP'nin şimdiki nesli olup, » Zend motoru 2 kullanır ve bir çok yeniliğin yanında Nesne Yönelimli Programlama özelliğine de sahiptir.

PHP'nin farklı sürümlerini aynı anda çalıştırabilir miyim?

Evet. PHP kaynak paketinin kök dizininde bulunan INSTALL dosyasını okuyunuz.

Bir hata buldum! Kime söylemeliyim?

PHP Hataları Veritabanına gitmeniz ve bulduğunuz hatanın bilinen hatalardan biri olmadığından emin olmanız gerekir. Hatayı veritabanında göremezseniz hatayı bildirmek için hata raporlama formunu kullanınız. Hatayı bir eposta listesine değil, hata veritabanına bildirmek önemlidir. Çünkü bu suretle hataya bir numara atanır ve hatanın durumunu izlemek kolaylaşır. Hata veritabanını » http://bugs.php.net/ adresinde bulabilirsiniz.

SSS
Eposta listeleri
SSS


Posta Listeleri

Bu bölümdeki sorular PHP topluluğu ile nasıl iletişime geçileceği ile ilgilidir. Bunun en iyi yolu posta listeleridir.

  1. PHP'nin eposta listeleri var mı?
  2. Başka topluluklar var mı?
  3. Kendi PHP eposta listemi açabilir miyim?
  4. İmdat! Nasıl posta listesi üyesi olacağımı (veya üyeliğinden ayrılacağımı) bulamadım!
  5. Posta listelerinin bir yerlerde arşivi var mı?
  6. Bir posta listesine ne sorabilirim?
  7. Bir posta listesine soru sorarken hangi bilgileri vermeliyim?
PHP'nin eposta listeleri var mı?

Elbette! Çeşitli konularda pek çok eposta listesi var. En bilinen topluluk eposta listelerini » Destek sayfamızda bulabilirsiniz.

En genel posta listemiz php-general olup üye olmak için » php-general-subscribe@lists.php.net adresine, üyelikten ayrılmak için ise » php-general-unsubscribe@lists.php.net adresine bir eposta gönderin.

Ayrıca, » Destek sayfamızdan erişeceğiniz arayüzü kullanarak da üye olabilir veya eposta listelerinden gönderilen iletilerin sonundaki bilgilerden yararlanarak üyelikten ayrılabilirsiniz.

Başka topluluklar var mı?

Dünyanın dört bir yanında sayısız PHP merkezli topluluk var. » Destek sayfamızda bu toplulukların bazılarına ilişkin bilgiler ve bazı bağlantılar bulabilirsiniz.

Kendi PHP eposta listemi açabilir miyim?

Elbette! Aslında buna izin vermekle kalmıyor bunu teşvik de ediyoruz. PHP ile ilgili deneyimlerinizi ve bilgilerinizi başkalarıyla paylaşarak küresel PHP topluluğunun büyümesine ve dilin kendisinin geliştirilmesine bu yolla da yardım edebilirsiniz.

İmdat! Nasıl posta listesi üyesi olacağımı (veya üyeliğinden ayrılacağımı) bulamadım!

Bir posta listesine üye olurken veya üyelikten ayrılırken sorunlar yaşıyorsanız posta listesi yazılımına doğru adresle başvurmamış olabilirsiniz. Eğer eposta adresiniz joeblow@example.com ise php-general listesine üyelik isteğinizi php-general-subscribe-joeblow=example.com@lists.php.net adresine, üyelikten ayrılma isteğinizi ise php-general-unsubscribe-joeblow=example.com@lists.php.net adresine eposta göndererek belirtebilirsiniz. Diğer posta listeleri de benzer adresleri kabul edecektir.

Eposta listelerimizden üyeliklerini sonlandırmak isteyenlerin bunu başaramamalarının başlıca sebebi eposta yönlendiricileri kullanmalarıdır. Örneğin, eposta adresiniz danbrown@example.com ise, fakat eposta listesine yönlendirilmiş php-lists@example.com adresinizle üye olmuşsanız danbrown@example.com adresinizi üyelikten çıkarmaya çalışmanız bu adres sistemlerimiz tarafından bilinmediğinden başarısızlıkla sonuçlanacaktır. Eğer bu adres yerine php-lists@example.com eposta adresinizi üyelikten çıkarmak isteseydiniz bu çaba boşa gitmeyecekti.

Posta listelerinin bir yerlerde arşivi var mı?

Evet. Arşiv sitelerinin adres listesini » mailing list sayfamızda bulabilirsiniz. Ayrıca, eposta listelerimizi arşivleyen düzinelerce site bulunmaktadır. Ara motorlarında "php mailing list archives" dizgesiyle arama yaparak bunlara ulaşabilirsiniz.

Posta listesi iletileri » news://news.php.net/ haber sunucusunda da arşivlenmektedir. Ayrıca, haber sunucumuzun deneysel bir HTML arayüzü de mevcuttur: » http://news.php.net/

Bir posta listesine ne sorabilirim?

PHP'nin bilinirliğinin giderek artışına paralel olarak php-general posta listesinin de trafiği artmaktadır. Ortalama günlük trafik 75-200 posta civarındadır. Bundan dolayı başka yerleri de araştırdıktan sonra posta listeleri en son çare olarak kullanılmalıdır.

Listeye bir ileti göndermeden önce, yardım bulmak için lütfen bu SSS'ye ve kılavuza bakınız. Hiçbir şey bulamazsanız posta listesi arşivlerini deneyiniz (yukarı bakınız). PHP'yi kurmak veya yapılandırmak konusunda sorun yaşıyorsanız lütfen konu ile ilgili tüm belgeleri ve README dosyalarını okuyunuz. Hala derdinize deva olacak bilgilere erişememişseniz posta listelerini gönül rahatlığıyla kullanabilirsiniz.

En iyi yanıtları alabilmeniz için, lütfen sorunuzu doğru eposta listesine gönderdiğiniz emin olun. Örneğin PHP kurulumunuzda yaşadığınız sorunları php-install eposta listesine göndermelisiniz. Bir yetersizlik: Bazı listeler farklı kullanım amaçlarına sahip oldukları halde benzer isimlere sahip olabilirler. Windows üzerinde PHP betiğiniz ile ilgili sorunları "Windows PHP users" listesine göndermelisiniz, "Windows Internals" listesine değil.

Soru sormadan önce lütfen » Doğru Düzgün Soru Sormanın Yolları belgesini okuyunuz.

Bir posta listesine soru sorarken hangi bilgileri vermeliyim?

"PHP'yi çalıştıramıyorum! Bana yardım edin! Neyi yanlış yapıyorum?" gibi postaları kimse dikkate almaz. PHP'yi çalıştıramıyorsanız, PHP'yi hangi işletim sisteminde kullandığınızı, PHP'nin sürümünü, nasıl temin ettiğinizi (derlenmiş paket, Git, RPM ve benzeri), çalıştırmak için neler yaptığınızı ve aldığınız hata iletilerini tam olarak belirtmelisiniz.

Aynı şeyleri başka sorunlar için de yapmalısınız. Neler yaptığınızı, nerede saplanıp kaldığınızı, bu durumdan çıkmak için neler denediğinizi varsa aldığınız hata iletilerini iletinize dahil etmelisiniz. Eğer sorun kendi yazdığınız kodlarla ilgiliyse çalışmayan kod parçasını da iletinize dahil ediniz. Gerekli olmayan kodları dahil etmeyiniz! Bu iletinizin okunmasını zorlaştıracağı için çoğu kişi iletinizi hiç okumadan geçecektir. Postanızda ne kadar bilgi vereceğinizden emin olamıyorsanız, az da olsa bilgi vermek hiç vermemekten iyidir.

Diğer önemli şey de konu başlığında sorunun özetlenmesidir. "İMDAAAT" veya "Buradaki sorun ne?" diye bir konu başlığını okuyucuların büyük çoğunluğu yok sayacaktır.

Ve son olarak, hemen herkese büyük faydası olan » Doğru Düzgün Soru Sormanın Yolları belgesini mutlaka okuyunuz.

Genel Bilgi
PHP'nin Temini
SSS


PHP'nin Temini

Bu bölümde PHP'nin indirilebileceği yerler ve işletmi sistemleri hakkında sorulara yer verilmiştir.

  1. PHP'yi nereden edinebilirim?
  2. Derlenmiş paketler var mı?
  3. Bazı seçimlik PHP eklentilerini derlemek için gerekli kütüphaneleri nereden temin edebilirim?
  4. PHP'nin bu kütüphanelerle çalışmasını nasıl sağlarım?
  5. Windows makinem için PHP'nin kaynak kodunun en son sürümünü Git'ten aldım; derlemek için neye ihtiyacım var?
  6. Tarayıcı Yetenekleri Dosyasını nereden bulabilirim?
  7. PHP karşıdan indirme yaparken güvenli evreleme ne yapar?
PHP'yi nereden edinebilirim?

PHP'yi PHP ağına üye sitelerden indirebilirsiniz. Bunları » http://www.php.net/ adresinde bulabilirsiniz. Ayrıca, kaynak kodların en son halini anonim Git kullanarak alabilirsiniz; daha fazla bilgi için » http://www.php.net/git.php adresine bakınız.

Derlenmiş paketler var mı?

Derlenmiş çalıştırılabilirleri sadece Windows sistemler için dağıtıyoruz. Her Linux/Unix platformu için eklentileriyle birlikte PHP derlememiz mümkün değil. Ayrıca, bugünlerde çoğu Linux dağıtımı derlenmiş PHP paketleriyle gelmektedir. Windows çalıştırılabilir paketleri » İndirme sayfamızdan indirilebilir. Derlenmiş Linux paketleri için dağıtımınızın sitesine bakınız.

Bazı seçimlik PHP eklentilerini derlemek için gerekli kütüphaneleri nereden temin edebilirim?

Bilginize: Aşağıdakilerden * imli olanlar çok evreli kütüphaneler değildir ve çok evreli ortamlarda bir sunucu modülü olarak kullanımı önerilmemektedir.

  • » LDAP (Unix).
  • » LDAP (Unix/Win) : Mozilla Directory (LDAP) SDK
  • » özgür LDAP sunucusu.
  • » Berkeley DB2 (Unix/Win) : http://www.sleepycat.com/.
  • » SNMP* (Unix): .
  • » GD (Unix/Win).
  • » mSQL* (Unix).
  • » PostgreSQL (Unix).
  • » IMAP* (Win/Unix).
  • » Sybase-CT* (Linux, libc5) : Available locally.
  • » FreeType (libttf):.
  • » ZLib (Unix/Win32).
  • » expat XML çözümleyici (Unix/Win32).
  • » PDFLib.
  • » mcrypt.
  • » mhash.
  • » t1lib.
  • » dmalloc.
  • » aspell.
  • » readline.

PHP'nin bu kütüphanelerle çalışmasını nasıl sağlarım?

Kütüphane ile sağlanmış talimatları izlemeniz gerekir. Bu kütüphanelerin bazıları PHP'nin 'configure' betiği çalıştırıldığı zaman özdevinimli olarak algılanır (örneğin GD kütüphanesi), bazıları da 'configure' betiğine '--with-EKLENTİ seçeneği ile belirtilir. Bunların tam listesini almak için 'configure --help' komutunu verin.

Windows makinem için PHP'nin kaynak kodunun en son sürümünü Git'ten aldım; derlemek için neye ihtiyacım var?

En son derleme adımları için PHP Wikisine bakınız: » Adım adım derleme

Tarayıcı Yetenekleri Dosyasını nereden bulabilirim?

browscap.ini dosyasını » http://browscap.org/ adresinde bulabilirsiniz.

PHP karşıdan indirme yaparken güvenli evreleme ne yapar?

Güvenli Evreleme (Thread Safety), o çalıştırılabilirin bir çok evreli HTTP sunucusunda çalışabileceği anlamına gelir, mesela Windows üzerinde Apache 2 gibi. Güvenli Evreleme her evrenin bir yerel kopyasını oluşturarak çalışır, yani veri başka bir evrenin verisine karışmaz.

O halde seçiminiz ne olmalı? Eğer PHP'yi bir CGI çalıştırılabiliri olarak çalıştırırsanız güvenli evrelemeye ihtiyacınız olmaz, çünkü her istekte başka bir çalıştırılabilir kullanılır. IIS5, IIS6 gibi çok evreli HTTP sunucularında PHP'nin evreli sürümünü kullanmalısınız.

Eposta listeleri
Veritabanı Sorunları
SSS


Veritabanı Sorunları

Bu bölümde PHP ile veritabanları arasındaki ilişkiye yönelik sıkça sorulan sorulara yer verilmiştir. Evet, PHP, günümüzde kullanılabilen her veritabanına sanal olarak erişebilmektedir.

  1. PHP'den Microsoft SQL Sunucusuna erişimin mümkün olduğunu duydum. Nasıl?
  2. Microsoft Access veritabanlarına erişebilir miyim?
  3. 10 yıldan beridir kullandığım MySQL eklentisini (ext/mysql) kullanmaktan neden vazgeçecekmişim? Kullanımı önerilmiyor mu? Yerine ne kullanacağım? Göçü nasıl gerçekleştireceğim?
  4. Neden şöyle bir hata alıyorum?: "Warning: 0 is not a MySQL result index in <file> on line <x>" veya "Warning: Supplied argument is not a valid MySQL result resource in <file> on line <x>"?
PHP'den Microsoft SQL Sunucusuna erişimin mümkün olduğunu duydum. Nasıl?

Unix makinelerde PDO_ODBC veya Unified ODBC API. kullanabilirsiniz.

Windows makinelerde, ayrıca PDO_SQLSRV veya SQLSRV de kullanabilirsiniz.

Microsoft Access veritabanlarına erişebilir miyim?

Evet. Tamamen Windows 9x/Me, veya NT/2000 üzerindeyseniz zaten gerekli bütün araçlara sahipsinizdir; ODBC ve Microsoft'un ODBC sürücülerini Microsoft Access veritabanları için kullanabilirsiniz.

Bir Unix üzerindeyseniz ve bir Windows makinedeki bir Microsoft Access veritabanına erişmek istiyorsanız Unix ODBC sürücüleri kullanmanız gerekir. » OpenLink Software, bunu yapabilen Unix temelli ODBC sürücülerine sahiptir.

Diğer bir seçenek, Windows ODBC sürücülerine sahip bir SQL sunucusu kullanmaktır. Böylece Microsoft Access (ODBC kullanarak) ve PHP'ye (yerleşik sürücüleri kullanarak) erişebilirsiniz. Başka bir seçenek ise, Microsoft Access ve PHP'nin her ikisinin de anlayabileceği düz dosyalar veya dBase veritabanları gibi bir aracı dosya biçimlerini kullanmaktır. Bu noktada OpenLink yazılımdan Tim Hayes'in yazdıklarını okuyalım:

Veritabanınıza PHP'den ODBC'yle (yani, OpenLink'in sürücüleriyle) doğrudan erişmek varken aracı dosya olarak başka bir veritabanını kullanmak hiç iyi bir fikir değildir. Mutlaka bir aracı dosya kullanmanız gerekmiyorsa, OpenLink'in NT, Linux ve diğer Unix platformları için dağıttığı Virtuoso'yu (sanal veritabanı motoru) kullanabilirsiniz. Yazılımı özgürce indirmek için » OpenLink'i ziyaret ediniz.

Başarısı kanıtlanmış tek seçenek Windows üzerinde MySQL ile MyODBC sürücülerini kullanmak ve veritabanlarını eşzamanlamaktır. Steve Lawrence şunları yazmıştır:

  • MySQL'i platformunuza talimatlara uygun olarak kurun. En son sürümü » http://www.mysql.com/ adresinden edinebilirsiniz. Bir veritabanı oluşturmak dışında özel bir yapılandırma gerekli değildir. Kullanıcı hesabını yapılandırdıktan sonra host alanına bir % imi veya MySQL ile erişmek istediğiniz Windows makinenizin konak adını yazın. Sunucu ismini, kullanıcı ismi ve parolanızı bir kenara yazmayı unutmayın.
  • Windows için MyODBC sürücüsünü MySQL sitesinden indirin ve Windows makinenize kurun. İşlemi bu programla gelen araçlarla deneyebilirsiniz.
  • Denetim Masası'ndan (veya Yönetimsel Araçlar'dan) ODBC Yöneticisini açıp bir kullanıcı veya bir sistem dsn oluşturun. MySQL veritabanını 1. adımda oluştururken kullandığınız dsn adını, konak adını, kullanıcı adı ve parolasını yazın.
  • Install Access'i tam kurulum seçeneği ile kurun. Bu, doğru eklentilerin kurulduğundan emin olmanızı sağlar; en azından ODBC desteğine ve ilintili tablo yöneticisine ihtiyacınız olacak.
  • En eğlenceli kısma geldik! Yeni bir Access veritabanı oluşturun. Tablo penceresine sağ tıklayıp Link Tables seçeneğini veya dosya menüsü seçeneği altından Get External Data ve ardından Link Tables seçeneğini seçin. Dosya tarayıcı penceresi geldiğinde ODBC türündeki dosyaları seçin. Sistem dsn'sini ve 3. adımda oluşturduğunuz kendi dsn isminizi seçin. İlintilenecek tabloyu seçtikten sonra Tamam'a tıklayın. Hepsi bu kadar! Artık, MySQL sunucunuzdan tabloyu açabilir ve veri ekleme, silme ve düzenleme işlemlerini yapabilirsiniz. Ayrıca sorgular oluşturabilir, MySQL'le tablo ithalatı ve ihracatı yapabilir, formlar ve raporlar, vs. oluşturabilirsiniz.

İpuçları:

  • Tablolarınızı Access'te oluşturabilir, bunları MySQL'e ihraç edebilir ve onları gerisin geriye ilintileyebilirsiniz. Bu işlem, tablo oluşturmayı hızlandırır.
  • Tablolarınızı Access'te oluştururken, yazma erişimine sahip olmak için bir birincil anahtar oluşturmalısınız. Tabloyu ilintilemeden önce MySQL'de de bir birincil anahtar oluşturmayı unutmayın.
  • MySQL'deki bir tabloda değişiklik yaparsanız, Access'teki ile yeniden ilintilemelisiniz. Araçlar>eklenti>ilintili tablo yöneticisi'ne gidin, ODBC DSN'nize geçin ve tabloyu seçip yeniden ilintileyin. İsterseniz, dsn kaynağınızı oradan taşıyabilirsiniz, yapacağınız tek şey Tamam'a tıklamadan önce yeni konum için daima istek yap onay kutusunu işaretlemek olacaktır.

10 yıldan beridir kullandığım MySQL eklentisini (ext/mysql) kullanmaktan neden vazgeçecekmişim? Kullanımı önerilmiyor mu? Yerine ne kullanacağım? Göçü nasıl gerçekleştireceğim?

Bir MySQL API'si seçmek bölümünde açıklandığı gibi üç MySQL eklentisi vardır. Eski API kullanılmamalıdır, PHP 5.5.0 itibariyle kullanımı önerilmemekte olup PHP 7.0.0 itibariyle PECL'ye taşınmıştır. Yeni kodların mutlaka mysqli veya PDO_MySQL ile yazılmasını teşvik ediyoruz.

Göç betikleri henüz hazır değilse de mysqli API hem yordamsal hem de nesne yönelimli API içermekte olup yordamsal sürümü ext/mysql'e benzemektedir.

Eklentileri karışık kullanmak mümkün değildir. Bu bakımdan, örneğin, bir mysqli bağlantısını PDO_MySQL veya ext/mysql'e aktarmak işe yaramayacaktır.

Neden şöyle bir hata alıyorum?: "Warning: 0 is not a MySQL result index in <file> on line <x>" veya "Warning: Supplied argument is not a valid MySQL result resource in <file> on line <x>"?

0 değerli bir sonuç belirtecini kullanmaya çalışıyorsunuzdur. Buradaki sıfır, sorgunuzun bir şekilde başarısız olduğu anlamına gelir. Dönen sonuç belirtecini kullanmaya çalışmadan önce, sorguyu gönderdikten sonra oluşan hataları incelemeniz gerekir. Bunun gerektiği gibi yapıldığı bir kod şöyle olurdu:

<?php

$result = mysql_query("SELECT * FROM tables_priv");
if (!$result) {
    echo mysql_error();
    exit;
}
?>
veya
<?php

$result = mysql_query("SELECT * FROM tables_priv")
    or die("Kötü sorgu: " . mysql_error());
?>

PHP'nin Temini
Kurulum
SSS


Kurulum

Bu bölüm, kurulum sırasında sık rastlanan sorunlarla ilgili sorular ve çözümlerden derlenmiştir. PHP hemen hemen tüm işletim sistemlerine kurulabilmekte ve hemen her HTTP sunucusu ile çalışabilmektedir.

PHP'yi kurmak için Yapılandırma ve Kurulum bölümündeki talimatları izleyin.

  1. Apache 2'yi çok evreli bir MPM ile üretim ortamında neden kullanmamalıyım?
  2. Unix/Windows: php.ini dosyamın yerini bulamıyorum!
  3. Unix: PHP'yi kurdum, fakat her belge yükleyişimde 'Document Contains No Data'! (Belge hiç veri içermiyor!) şeklinde bir ileti alıyorum. Ne yapmalıyım?
  4. Unix: PHP'yi RPM'leri kullanarak kurdum, fakat Apache, PHP sayfalarını işlemiyor! Ne yapmalıyım?
  5. Unix: Apache'yi FrontPage eklenti yamasıyla yamadım ve hemen ardından PHP çalışmaz hale geldi. PHP, Apache FrontPage eklentileriyle uyumlu değil mi?
  6. Unix/Windows: PHP'yi kurdum, fakat PHP betiğine tarayıcımla erişmeye çalıştığımda boş bir sayfa alıyorum.
  7. Unix/Windows: PHP'yi kurdum, fakat PHP betiğine tarayıcımla erişmeye çalıştığımda sunucudan 500 hatası alıyorum.
  8. Bazı işletim sistemleri: PHP'yi hatasız kurdum fakat Apache'yi başlatmak istediğimde tanımsız simge hataları aldım: [mybox:user /src/php5] root# apachectl configtest apachectl: /usr/local/apache/bin/httpd Undefined symbols: _compress _uncompress
  9. Windows: PHP'yi kurdum fakat tarayıcımla bir PHP betiğine erişmek istediğimde şöyle bir hata alıyorum: cgi error: The specified CGI application misbehaved by not returning a complete set of HTTP headers. The headers it did return are:
  10. Windows: Tüm talimatları izlememe rağmen PHP ile IIS'yi birlikte çalıştıramadım!
  11. PHP'yi IIS, PWS, OmniHTTPD veya Xitami ile CGI olarak çalıştırırken şu hatayı alıyorum: Security Alert! PHP CGI cannot be accessed directly..
  12. Hangi php.ini dosyasının okunduğunu nasıl anlayacağım? Yaptığım değişikliklerin bir etkisi olmuyor gibi gözüküyor.
  13. PHP dizinimi Windows'ta PATH değişkenine nasıl eklerim?
  14. Windows üzerinde PHP'nin php.ini dosyasını kullanabilmesini nasıl sağlarım?
  15. PHP ile Apache içerik dili uzlaşımını kullanmak (MultiViews seçeneği) mümkün mü?
  16. PHP'nin GET ve POST istekleri dışında istekleri işleme sokmaması sağlanabilir mi?
Apache 2'yi çok evreli bir MPM ile üretim ortamında neden kullanmamalıyım?

PHP üçüncü parti kütüphaneler kullanılarak muhtelif HTTP uygulamaları geliştirmeyi sağlayan bir yapıştırıcıdır. PHP'nin esnekliği ve gücü üzerinde çalıştığı platformun gücü ve kararlılığı ile sınırlıdır. Çalışmak için bir işletim sistemine, HTTP sunucusuna ve 3. parti modüllere ihtiyaç duyar ve bunlar arasında bir yapıştırıcı gibi davranır. Bunlardan biri çalışmasını durdurursa sorunu saptayıp çabucak çözümlemeniz gerekir. PHP'nin üzerinde çalıştığı ortamı, birbirlerinden bağımsız çalışma evreleri, tamamen ayrı bellek bölümleri ve her istek için ayrı bir çalışma alanı ile daha da karmaşıklaştırırsanız, PHP'nin hamuru bir bulamaca dönüşebilir.

Çok evreli bir MPM kullanmak isterseniz, PHP'nin kendi bellek uzayında çalışmasını sağlayan FastCGI yapılandırması bir çözüm olabilir.

Unix/Windows: php.ini dosyamın yerini bulamıyorum!

Öntanımlı olarak Unix üzerindeki yeri /usr/local/lib dizinidir. Çoğu kişi bu dosyanın yerini derleme sırasında --with-config-file-path seçeneğini kullanarak değiştirmektedir. Siz de isterseniz dosyanın yerini şöyle değiştirebilirsiniz:

--with-config-file-path=/etc
Böylece kaynak paketindeki php.ini-development dosyası /etc/php.ini olarak kurulur ve üzerinde istediğiniz değişiklikleri yapabilirsiniz.

--with-config-file-scan-dir=YOL

Windows'ta php.ini dosyasının öntanımlı yeri Windows dizinidir. Apache HTTP sunucusu kullanıyorsanız php.ini önce Apache'nin kurulum dizininde aranır (örn, c:\program files\apache group\apache). Bu yer aynı makinede çalışan farklı Apache sürümleri için farklı yerlerde olabilir.

Ayrıca bakınız: Yapılandırma Dosyası.

Unix: PHP'yi kurdum, fakat her belge yükleyişimde 'Document Contains No Data'! (Belge hiç veri içermiyor!) şeklinde bir ileti alıyorum. Ne yapmalıyım?

Muhtemelen PHP'nin bazı sorunları var ve core dosyası dökümlüyor olmalı. Bu durumda, sunucunuzun günlük kayıt dosyalarına bakıp sorunu küçük bir deney ortamında üretmeye çalışın. 'gdb' kullanmayı biliyorsanız, hata raporunuzda sorun hakkında geliştiricilere çok yardımcı olacak bir hata izleme çıktısı sağlayabilirsiniz. PHP'yi bir Apache modülü olarak kullanıyorsanız şunları yapmayı deneyin:

  • httpd sürecini durdurun

  • gdb httpd

  • httpd süreçlerini durdurun

  • > run -X -f /bir/yol/httpd.conf

  • Ardından soruna sebep olan adresi tarayıcınızla açın.

  • > run -X -f /bir/yol/httpd.conf

  • Bir core dosyası dökümleniyorsa gdb size bunun sebebini söyleyecektir.

  • Şunu yazın: bt

  • Hata raporunuza bu geriye doğru hata izleme bilgisini eklemeli ve raporu » http://bugs.php.net/ adresinden göndermelisiniz.

Eğer betiğinizde düzenli ifade işlevlerini (preg_match() ve benzerleri) kullanıyorsanız, PHP'yi ve Apache'yi aynı düzenli ifade paketiyle derlediğinizden emin olmalısınız. PHP ve Apache 1.3.x için bu özdevinimli olarak gerçekleşir.

Unix: PHP'yi RPM'leri kullanarak kurdum, fakat Apache, PHP sayfalarını işlemiyor! Ne yapmalıyım?

Hem Apache hem de PHP'yi RPM paketlerinden kurduğunuz varsayımıyla httpd.conf dosyanıza aşağıdaki satırların tamamını veya bir kısmını ekleyin veya başlarındaki # imlerini silip o satırları etkin kılın:

# Ek Modüller
AddModule mod_php.c
AddModule mod_perl.c

# Ek Modüller
LoadModule php_module         modules/mod_php.so
LoadModule php5_module        modules/libphp5.so
LoadModule perl_module        modules/libperl.so
Ve sunucu genelinde geçerli olacak şekilde veya PHP'nin etkin olacağı sanal konak bölümünde şu satırı ekleyin:
AddType application/x-httpd-php .php

Unix: Apache'yi FrontPage eklenti yamasıyla yamadım ve hemen ardından PHP çalışmaz hale geldi. PHP, Apache FrontPage eklentileriyle uyumlu değil mi?

PHP, FrontPage eklentileriyle gayet güzel çalışır. Sorun, FrontPage yamasının PHP'nin de çalıştığı veri yapılarını değiştirmesidir. FP yamasını uyguladıktan sonra PHP'yi yeniden derleyerek (make clean; make) sorunu çözebilirsiniz.

Unix/Windows: PHP'yi kurdum, fakat PHP betiğine tarayıcımla erişmeye çalıştığımda boş bir sayfa alıyorum.

Tarayıcınıza 'Sayfa kaynağını göster' derseniz PHP betiğinizin kaynak koduna bakarak sorunun kaynağını bulabilirsiniz. Yani, HTTP sunucusu betiği yorumlasın diye PHP'ye göndermemiştir. Sunucu yapılandırmasında birşeyler yanlış gitmiş olabilir. PHP kurulum talimatlarını tekrar uygulayarak sunucu kurulumunuzu tekrar gözden geçirin.

Unix/Windows: PHP'yi kurdum, fakat PHP betiğine tarayıcımla erişmeye çalıştığımda sunucudan 500 hatası alıyorum.

Sunucu PHP'yi çalıştırmaya uğraşırken birşeyler yanlış gitmiş. Hataları görmek için komut satırından PHP çalıştırılabilirinin (Windows'ta php.exe) bulunduğu dizine geçip php -i komutunu verin. Eğer PHP çalışırken bir sorun ortaya çıkıyorsa ne yapılması gerektiği ile ilgili ipuçları içeren bir hata iletisi gösterilir. Eğer ekranı dolduran bir dolu HTML kodu alıyorsanız (bu, phpinfo() işlevinin çıktısıdır) PHP düzgün çalışıyor demektir. Bu durumda sunucu yapılandırmanızı tekrar gözden geçirmeniz gerekir.

Bazı işletim sistemleri: PHP'yi hatasız kurdum fakat Apache'yi başlatmak istediğimde tanımsız simge hataları aldım:
[mybox:user /src/php5] root# apachectl configtest
 apachectl: /usr/local/apache/bin/httpd Undefined symbols:
  _compress
  _uncompress

Bu sorun PHP'nin kendisi ile değil, MySQL istemci kütüphanesi ile ilgilidir. Derleme sırasında --with-zlib seçeneğini kullansaydınız bu sorun çıkmayacaktı. Bu konudan MySQL SSS'sinde de bahsedilmiştir.

Windows: PHP'yi kurdum fakat tarayıcımla bir PHP betiğine erişmek istediğimde şöyle bir hata alıyorum:
cgi error:
 The specified CGI application misbehaved by not
 returning a complete set of HTTP headers.
 The headers it did return are:

Hata iletisi PHP'nin hiçbir şey çıktılamadan başarısız olduğu anlamına gelmektedir. Hataları görmek için komut satırından PHP çalıştırılabilirinin (Windows'ta php.exe) bulunduğu dizine geçip php -i komutunu verin. Eğer PHP çalışırken bir sorun ortaya çıkıyorsa ne yapılması gerektiği ile ilgili ipuçları içeren bir hata iletisi gösterilir. Eğer ekranı dolduran bir dolu HTML kodu alıyorsanız (bu, phpinfo() işlevinin çıktısıdır) PHP düzgün çalışıyor demektir.

PHP komut satırından düzgün çalışıyorsa betiğe tarayıcınızla tekrar erişmeyi deneyin. Yine aynı hatayı alıyorsanız sorun şunlardan biri olabilir:

  • Yüklemeye çalıştığınız PHP betiği, php.exe, php5ts.dll, php.ini veya PHP eklentileri gibi bazı dosyaların izinleri anonim internet kullanıcısının ISUR_<makineadı> bunlara erişebilmesine izin vermiyordur.
  • Betik dosyası mevcut değildir (veya belge kök dizinine göre sizin düşündüğünüz yerde değildir). IIS kullanıyorsanız, İnternet Hizmetleri Yöneticisinde betik eşlemlerini ayarlarken 'dosya mevcut mu diye bir bakıver' kutusunu işaretlemek suretiyle bu hatayı yakalayabilirsiniz. Betik dosyasının mevcut olmaması durumunda sunucu bu hata yerine bir 404 hatası döndürecektir. IIS kullanmanın size ek bir yararı daha olacak: Betik dosyanız üzerinde NTLanMan izinlerine dayalı olarak gerekli kimlik doğrulaması da yapılacaktır.
Windows: Tüm talimatları izlememe rağmen PHP ile IIS'yi birlikte çalıştıramadım!

PHP betiğini çalıştıracak kullanıcıların php.exe'yi çalıştırabilecek izinlere sahip olup olmadığına bakın! IIS bunun için kurulumda eklenen bir anonim kullanıcı kullanır. Bu kullanıcının php.exe'yi çalıştıracak izne sahip olması gerekir. Ayrıca, kimlik doğrulaması gerektiren kullanıcıların da php.exe'yi çalıştıracak izne sahip olması gerekir. Ve IIS4'e PHP'nin bir betik yorumlayıcı olduğunu da belirtmeniz gerekir. Ek olarak, bu SSS'yi de okumanızı öneririz.

PHP'yi IIS, PWS, OmniHTTPD veya Xitami ile CGI olarak çalıştırırken şu hatayı alıyorum: Security Alert! PHP CGI cannot be accessed directly..

cgi.force_redirect yönergesine 0 atamalısınız. Öntanımlı değeri 1 olup, php.ini dosyasında bulunduğu satırın başında bir ; varsa o noktalı virgülü silmeniz gerekir.

Öntanımlı değer 1 olduğundan değişikliği doğru php.ini dosyasında yaptığınızdan %100 emin olmalısınız. Daha ayrıntılı bilgi için bu SSS'ye bakınız.

Hangi php.ini dosyasının okunduğunu nasıl anlayacağım? Yaptığım değişikliklerin bir etkisi olmuyor gibi gözüküyor.

php.ini dosyanızın PHP tarafından okunduğundan emin olmak için phpinfo() çağrısı yapmanız gerekir. Sayfanın başına yakın bir yerlerde hangi dosyanın okunduğu bilgisini Configuration File (php.ini) altında görebilirsiniz. Böylece dosyayı nereye koyacağınızı bilirsiniz. Eğer listede sadece bir dizin varsa php.ini dosyanızı bu dizine koymalısınız. php.ini dosyanız listede gösterilen dizinlerden birindeyse okunacak demektir.

Eğer php.ini okunuyor ve siz PHP'yi bir modül olarak çalıştırıyorsanız php.ini dosyanızda değişiklik yaptıktan sonra HTTP sunucunuzu yeniden başlatmayı unutmayınız.

Ayrıca bakınız: php_ini_loaded_file().

PHP dizinimi Windows'ta PATH değişkenine nasıl eklerim?

Windows 7, XP, Vista, 2008, 2012 ve üstünde:

  • Denetim Masasına gidip Sistem simgesini açın (Başlat › Denetim Masası › Sistem).

  • Gelişmiş sekmesine gidin.

  • 'Ortam Değişkenleri' düğmesine tıklayın.

  • 'Sistem Değişkenleri' panosuna bakın.

  • Path girdisini bulun (bulmak için listeyi kaydırmanız gerekebilir)

  • Path girdisine çift tıklayın.

  • Satırın sonuna bir ';' koyup PHP dizini ekleyin (örnek: ;C:\php).

  • Tamam düğmesine tıklayın.

Windows 98/Me sistemlerinde ise autoexec.bat dosyanızı düzenlemeniz gerekecektir:

  • Notepad'i açın (Başlat › Çalıştır ve notepad yazıp enter tuşuna basın)

  • C:\autoexec.bat dosyasını açın.

  • PATH=C:\WINDOWS;C:\WINDOWS\COMMAND;..... satırını bulup satırın sonuna şunu ekleyin: ;C:\php.

  • Dosyayı kaydedin ve bilgisayarınızı yeniden başlatın.

Bilginize: PATH değişkeninde yaptığınız değişikliklerin uygulanmasını istiyorsanız yukarıdaki işlemleri yaptıktan sonra bilgisayarınızı yeniden başlatmayı unutmayınız.

PHP kılavuzunda, dosyaların Windows sistem dizinine kopyalanması salık verilebilir. Bunun sebebi bu dizinin (C:\Windows, C:\WINNT, vs.) öntanımlı olarak sistem PATH değişkeninde bulunmasıdır. Windows sistem dizinine dosya kopyalamak sorunlara yol açması sebebiyle uzun zamandır önerilmemektedir.

Windows üzerinde PHP'nin php.ini dosyasını kullanabilmesini nasıl sağlarım?

Bunu yapmanın çeşitli yolları vardır. Apache kullanıyorsanız kurulumla ilgili talimatları izleyin (Apache 1, Apache 2), aksi takdirde PHPRC ortam değişkenini atamanız gerekecek:

Windows üzerinde:

  • Denetim Masasına gidip Sistem simgesini açın (Başlat › Ayarlar › Denetim Masası › Sistem veya sadece Başlat › Denetim Masası › Sistem).

  • Gelişmiş sekmesine gidin.

  • 'Ortam Değişkenleri' düğmesine tıklayın.

  • 'Sistem Değişkenleri' panosuna bakın.

  • Click on 'Yeni' düğmesine tıklayın ve değişken ismi olarak 'PHPRC', değer olarak da php.ini dosyanızın bulunduğu yeri yazın (örnek: C:\php)

  • Tamam düğmesine tıklayın ve bilgisayarınızı yeniden başlatın.

Windows 98/Me sistemlerinde ise autoexec.bat dosyanızı düzenlemeniz gerekecektir:

  • Notepad'i açın (Başlat › Çalıştır ve notepad yazıp enter tuşuna basın)

  • C:\autoexec.bat dosyasını açın.

  • Dosyanın sonuna şu satırı ekleyin: set PHPRC=C:\php (burada C:\php yerine php.ini dosyanızın bulunduğu dizini yazın). Belirttiğiniz dizinin boşluk karakteri içermemesine dikkat ediniz. Örneğin, PHP'yi C:\Program Files\PHP altına kurduysanız bunu C:\PROGRA~1\PHP şeklinde belirtmelisiniz.

  • Dosyayı kaydedin ve bilgisayarınızı yeniden başlatın.

PHP ile Apache içerik dili uzlaşımını kullanmak (MultiViews seçeneği) mümkün mü?

PHP'yi dosya uzantıları ile ilişkilendirirseniz herşey düzgün çalışır. Bu SSS'de PHP dosyalarını uzantısız ilişkilendirdiğinizi ve içerik uzlaşımında PHP dosyalarının uzantılarına bakılmaksızın seçilmesini istediğinizi varsayacağız. Bu durumda, AddType application/x-httpd-php .php yerine şunları yazın:

AddHandler php5-script php
AddType text/html php
Bu çözüm PHP'nin bir modül olarak çalıştığı Apache 1'de php-script yakalanmayacağından çalışmayacaktır.

PHP'nin GET ve POST istekleri dışında istekleri işleme sokmaması sağlanabilir mi?

Hayır. PHP, CONNECT gibi her istek yöntemiyle çalışabilir. Doğru yanıt durumu header() ile gönderilebilir. Eğer sadece GET ve POST yöntemlerinin işleme sokulmasını istiyorsanız bunu Apache yapılandırmanızda şöyle sağlayabilirsiniz:

<LimitExcept GET POST>
Deny from all
</LimitExcept>

Veritabanı Sorunları
Derleme Sorunları
SSS


Derleme Sorunları

Bu bölüm, derleme sırasında oluşan hatalardan sık rastlananlarla ilgili sorular ve çözümlerden derlenmiştir.

  1. PHP'nin en son sürümünü anonim Git'ten aldım, fakat configure betiği yok!
  2. PHP'yi Apache ile çalışmak üzere yapılandırırken sorun çıktı. httpd.h dosyasını bulamadığını söylüyor, fakat burası bunu sorabileceğim doğru yer mi bilmiyorum!
  3. PHP'yi yapılandırırken (./configure), şöyle bir hata alıyorum: checking lex output file root... ./configure: lex: command not found configure: error: cannot find output from lex; giving up
  4. Apache'yi başlatmaya çalışırken şöyle bir hata alıyorum: fatal: relocation error: file /bir/yol/libphp4.so: symbol ap_block_alarms: referenced symbol not found
  5. configure betiğini çalıştırdığımda başlık dosyalarını veya GD, gdbm veya başka bir paketin kütüphanelerini bulamadığını söylüyor!
  6. language-parser.tab.c dosyasını derlerken yytname undeclared diye bir takım hatalar veriyor
  7. make komutunu verdiğim zaman başta herşey iyi gidiyor, fakat son ilintileme işlemlerini yaparken bazı dosyaları bulamıyor.
  8. PHP ilintilenirken bazı tanımsız gönderimler olduğundan şikayet ediyor.
  9. PHP'nin Apache 1.3 ile nasıl derleneceğini kavrayamadım.
  10. Unix üzerinde PHP'yi Apache modülü olarak derleme adımlarını izleyerek PHP'yi kurdum. Tarayıcımla PHP dosyalarını görmek istediğim zaman tarayıcım dosyayı kaydedeceği yeri soruyor.
  11. --activate-module=src/modules/php4/libphp4.a yapılandırmasını kullandığını söylüyor ama bu dosya yok. Yapılandırmayı --activate-module=src/modules/php4/libmodphp4.a olarak değiştirdiğimde ise çalışmıyor!? Ne yapmalıyım?
  12. Apache'yi PHP'yi bir duruk modül olarak kullanacak şekilde --activate-module=src/modules/php4/libphp4.a ile yapılandırırken derleyicimin ANSI uyumlu olmadığı hatasını alıyorum.
  13. PHP'yi --with-apxs yapılandırması ile derlerken tuhaf hata iletileri alıyorum.
  14. Microtime'da make sırasında RUSAGE_'li iletiler ve bazı hatalar alıyorum.
  15. PHP'yi MySQL destekli derlerken, make işlemi sırasında şuna benzer bir hata iletisi alıyorum: ext/mysql/libmysqlclient/my_tempnam.o(.text+0x46): In function my_tempnam': /php4/ext/mysql/libmysqlclient/my_tempnam.c:103: the use of tempnam' is dangerous, better use mkstemp'. Neyi yanlış yapıyorum?
  16. PHP sürümümü yükseltmek istiyorum. Mevcut PHP kurulumumun için kullanılan ./configure satırını nerede bulabilirim?
  17. PHP'yi GD kütüphanesi ile derlerken ya tuhaf derleme hataları ya da çalışma sırasında parçalama arızası alıyorum.
  18. PHP'yi derlerken rasgele hatalar alıyorum ve derleme işlemi duruyor. Bu arada, Solaris kullandığımı belirtmeliyim.
PHP'nin en son sürümünü anonim Git'ten aldım, fakat configure betiği yok!

Sisteminizde GNU autoconf paketi kuruluysa configure betiğini configure.in dosyasından üretebilirsiniz. Tek yapacağınız Git sunucusundan aldığınız kaynak kök dizininde ./buildconf komutunu vermek olacak. (Ayrıca, configure betiğini --enable-maintainer-mode seçeneğiyle çalıştırmadıkça configure.in güncellendiğinde configure betiği yeniden oluşturulmaz, bu bakımdan configure.in değiştiğine dair uyarı alırsanız ne yapılacağı konusunda emin olmalısınız.) Bunun tek belirtisi configure veya config.status çalıştırıldıktan sonra Makefile dosyanızda @VARIABLE@ gibi şeyler bulunmasıdır.)

PHP'yi Apache ile çalışmak üzere yapılandırırken sorun çıktı. httpd.h dosyasını bulamadığını söylüyor, fakat burası bunu sorabileceğim doğru yer mi bilmiyorum!

configure/setup betiğine Apache kaynak ağacınınızın en üst seviye dizininin yerini belirtmeniz lazım. Yani, seçenekte yolu --with-apache=/bir/yol/apache biçiminde belirteceksiniz, --with-apache=/bir/yol/apache/src biçiminde değil.

PHP'yi yapılandırırken (./configure), şöyle bir hata alıyorum:

checking lex output file root... ./configure: lex: command not found
configure: error: cannot find output from lex; giving up

Kurulum talimatlarını dikkatle okuyun ve PHP'yi derlemeden önce kurulması gereken bison ve flex sürümlerine dikkat edin. Dağıtımınıza ve yapılandırmanıza bağlı olarak bison ve flex'i kaynak kodlarından kendiniz derleyebileceğiniz gibi RPM gibi bir paketten de kurabilirsiniz.

Apache'yi başlatmaya çalışırken şöyle bir hata alıyorum:

fatal: relocation error: file /bir/yol/libphp4.so:
symbol ap_block_alarms: referenced symbol not found

Apache programı paylaşımlı kullanım için bir DSO kütüphanesi olarak derlendiği takdirde genelde böyle bir hata alınır. Apache'yi en azından aşağıdaki seçeneklerin bulunduğundan emin olarak yeniden yapılandırıp kurmalısınız:

--enable-shared=max --enable-rule=SHARED_CORE

Apache kaynak ağacının kök dizininde bulunan INSTALL dosyasından veya Apache » DSO kılavuz sayfasından daha ayrıntılı bilgi alabilirsiniz.

configure betiğini çalıştırdığımda başlık dosyalarını veya GD, gdbm veya başka bir paketin kütüphanelerini bulamadığını söylüyor!

configure betiğine, standart yerlerinde bulunmayan başlık dosyalarının ve kütüphanelerin yerlerini ek seçeneklerle belirterek bunların C önişlemcisine ve ilintileyiciye aktarılmasını sağlamalısınız. Örnek:

    CPPFLAGS=-I/bir/yol/include LDFLAGS=-L/bir/yol/lib ./configure
Oturum kabuğu olarak bir csh kabuğu kullanıyorsanız (nedense?), aynı şeyi şöyle yapabilirsiniz:
    env CPPFLAGS=-I/bir/yol/include LDFLAGS=-L/bir/yol/lib ./configure

language-parser.tab.c dosyasını derlerken yytname undeclared diye bir takım hatalar veriyor

Bison sürümünüzü güncellemeniz gerekiyor. En son sürümü » http://www.gnu.org/software/bison/bison.html adresinde bulabilirsiniz.

make komutunu verdiğim zaman başta herşey iyi gidiyor, fakat son ilintileme işlemlerini yaparken bazı dosyaları bulamıyor.

Eski make sürümleri functions dizinindeki dosyaların derlenmiş sürümlerini aynı dizine koymuyor. cp *.o functions komutunu verdikten sonra tekrar make komutunu çalıştırıp bunun yararı olup olmadığına bakın. Eğer işe yarıyorsa GNU make'i en son sürümüne yükseltmeniz gerekiyor demektir.

PHP ilintilenirken bazı tanımsız gönderimler olduğundan şikayet ediyor.

İlintileme satırında ilgili kütüphanelerin hepsi var mı diye bir bakın. Örneğin, '-ldl' veya bulunmasını istediğiniz veritabanı desteği için gereken kütüphaneler satırda eksik olabilir.

Bazı kişiler Apache ile ilintileme sırasında '-ldl'nın hemen ardına libphp4.a eklemek zorunda kaldıklarını bildirdiler.

PHP'nin Apache 1.3 ile nasıl derleneceğini kavrayamadım.

Bu aslında çok kolay. Aşağıdaki adımları sırayla yerine getirin:

  • En son Apache 1.3 paketini » http://httpd.apache.org/download.cgi adresinden indirin.
  • Arşiv paketinin içeriğini bir yere açın. Örnek dizin: /usr/local/src/apache-1.3
  • PHP'yi ilk olarak ./configure --with-apache=/<dizin>/apache-1.3 komutuyla yapılandıralım (<dizin> yerine kendi apache-1.3 kaynak dizininizi yazın).
  • PHP'yi derleyip gerekli dosyaları Apache kaynak ağacındaki yerlerine kopyalamak için make ve ardından make install komutunu verin.
  • /<dizin>/apache-1.3/src dizinine geçin ve Configuration dosyasını açıp şunu ekleyin: AddModule modules/php4/libphp4.a.
  • ./configure ve ardından make komutunu verin.
  • Artık PHP'nin etkin olduğu bir httpd çalıştırılabiliriniz var. Bu dosyayı sisteminizdeki mevcut çalıştırılabilirin üzerine kopyalayın.

Bilginize: İsterseniz, yeni Apache ./configure betiğini de kullanabilirsiniz. Apache kaynak paketiyle gelen README.configure dosyasındaki talimatları okuyunuz. Ayrıca PHP kaynak paketindeki INSTALL dosyasına da bakın.

Unix üzerinde PHP'yi Apache modülü olarak derleme adımlarını izleyerek PHP'yi kurdum. Tarayıcımla PHP dosyalarını görmek istediğim zaman tarayıcım dosyayı kaydedeceği yeri soruyor.

PHP modülünün bir şekilde PHP dosyalarını yorumlamak üzere devreye girmediği anlaşılıyor. Öncelikle şu üç şeyi yerine getirin:

  • httpd çalıştırılabilirinin sizin derlediğiniz çalıştırılabilir olduğundan emin olun. Bunun için /bir/yol/bin/httpd -l komutunu deneyin. Komutun çıktısında mod_php4.c yer almıyorsa doğru çalıştırılabiliri kullanmıyorsunuz demektir. Doğru çalıştırılabiliri bulup onu kurun.
  • Apache .conf dosyalarınızdan ilgili olanına PHP için doğru MIME türünü eklediğinizden emin olun. Gerekli satır: AddType application/x-httpd-php .php Ayrıca, bu AddType satırının bir <Virtualhost> veya <Directory> bloğunun içinde kalıp, betiğinizin çalıştığı konumda etkisiz olmadığından da emin olmalısınız.
  • Son olarak, Apache yapılandırma dosyalarının yerleri Apache 1.2 ve Apache 1.3 için farklıdır. Bu bakımdan AddType satırını doğru dosyaya yazdığınızdan da emin olmalısınız. httpd.conf dosyanızda, Apache başlatılırkan hata vermesine yol açacak bir söz dizimi hatası yapmanız doğru dosyayı tespit etmek için yeterli olacaktır.

--activate-module=src/modules/php4/libphp4.a yapılandırmasını kullandığını söylüyor ama bu dosya yok. Yapılandırmayı --activate-module=src/modules/php4/libmodphp4.a olarak değiştirdiğimde ise çalışmıyor!? Ne yapmalıyım?

libphp4.a dosyasının mevcut olduğunun "varsayıldığına" dikkat etmemişsiniz. Apache ikinci kez derlenirken o dosyayı kendisi üretecek!

Apache'yi PHP'yi bir duruk modül olarak kullanacak şekilde --activate-module=src/modules/php4/libphp4.a ile yapılandırırken derleyicimin ANSI uyumlu olmadığı hatasını alıyorum.

Bu Apache'nin sonraki sürümlerinde düzeltilen gözden kaçmış bir hatadır.

PHP'yi --with-apxs yapılandırması ile derlerken tuhaf hata iletileri alıyorum.

Burada bakacağınız üç şey var. Birincisi, bir sebeple Apache derlenirken apxs Perl betiği bazen hatalı derleyici ve ortam değişkenleri ile derleme yapmaya çalışabiliyor. apxs betiğini bulup (which apxs komutu yardımcı olabilir, genellikle yeri /usr/local/apache/bin/apxs veya /usr/sbin/apxs'tir) açın ve aşağıdaki satırların benzerleri var mı diye bir bakın:

my $CFG_CFLAGS_SHLIB  = ' ';          # substituted via Makefile.tmpl
my $CFG_LD_SHLIB      = ' ';          # substituted via Makefile.tmpl
my $CFG_LDFLAGS_SHLIB = ' ';          # substituted via Makefile.tmpl
Gördüğünüz bunun gibiyse sorunu buldunuz demektir. Sadece boşluklar veya 'q()' gibi hatalı değerler içerebilirler. Bu satırları aşağıdaki gibi değiştirin:
my $CFG_CFLAGS_SHLIB  = '-fpic -DSHARED_MODULE'; # substituted via Makefile.tmpl
my $CFG_LD_SHLIB      = 'gcc';                   # substituted via Makefile.tmpl
my $CFG_LDFLAGS_SHLIB = q(-shared);              # substituted via Makefile.tmpl
İkinci olası sorun kaynağı Red Hat 6.1 veya 6.2 kullanıyor olmaktır. Red Hat'ın derlediği apxs betiği hatalıdır. Şu satırı bulun:
my $CFG_LIBEXECDIR    = 'modules';         # substituted via APACI install
Ve şu satırla değiştirin:
my $CFG_LIBEXECDIR    = '/usr/lib/apache'; # substituted via APACI install
Sonuncusu, eğer Apache'yi yeniden yapılandırıp kuruyorsanız ./configure betiğini çalıştırdıktan sonra make komutunu vermeden bir make clean yapmalısınız.

Microtime'da make sırasında RUSAGE_'li iletiler ve bazı hatalar alıyorum.

Kurulumun make kısmında sorun şuna benzer bir çıktıyla kendini gösteriyorsa:

microtime.c: In function `php_if_getrusage':
microtime.c:94: storage size of `usg' isn't known
microtime.c:97: `RUSAGE_SELF' undeclared (first use in this function)
microtime.c:97: (Each undeclared identifier is reported only once
microtime.c:97: for each function it appears in.)
microtime.c:103: `RUSAGE_CHILDREN' undeclared (first use in this function)
make[3]: *** [microtime.lo] Error 1
make[3]: Leaving directory `/home/master/php-4.0.1/ext/standard'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/master/php-4.0.1/ext/standard'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/master/php-4.0.1/ext'
make: *** [all-recursive] Error 1

Sorun sisteminizde demektir. Kullandığınız glibc'nin glibc-devel paketini kurup /usr/include dosyalarınızı tamamlayın. Bunun PHP ile hiçbir alakası yoktur. Sorunu kendiniz çözmelisiniz. Basit bir deneme yapın:

$ cat >test.c <<X
#include <sys/resource.h>
X
$ gcc -E test.c >/dev/null
Sonuçta hata alıyorsanız, glibc başlık dosyaları sisteminizde kurulu değil demektir.

PHP'yi MySQL destekli derlerken, make işlemi sırasında şuna benzer bir hata iletisi alıyorum: ext/mysql/libmysqlclient/my_tempnam.o(.text+0x46): In function my_tempnam': /php4/ext/mysql/libmysqlclient/my_tempnam.c:103: the use of tempnam' is dangerous, better use mkstemp'. Neyi yanlış yapıyorum?

Önce dikkat etmeniz gereken şey bunun ölümcül bir hata değil bir uyarı (Warning) olduğudur. Bu genellikle make işleminin son çıktısı olduğundan bir ölümcül hata gibi görünür ama değildir. Eğer derleyicinizi uyarıları vermeyecek şekilde ayarlarsanız bu iletiyi bir daha almazsınız. Ayrıca, PHP 4'te MySQL desteğinin öntanımlı olarak etkin olduğunu unutmayın.

Bilginize:

PHP 4.3.2 ve sonrasında, derleme (make) işleminin bitiminde şöyle bir çıktı göreceksiniz:

Build complete.
(It is safe to ignore warnings about tempnam and tmpnam).
Türkçesi: Derleme tamamlandı. (tempnam ve tmpnam ile ilgili uyarıları rahatça gözardı edebilirsiniz).

PHP sürümümü yükseltmek istiyorum. Mevcut PHP kurulumumun için kullanılan ./configure satırını nerede bulabilirim?

PHP'yi derlediğiniz kaynak dizininzdeki config.nice dosyasında bulabilirsiniz. Bu yoksa, aşağıdaki betiği çalıştırın:

<?php phpinfo(); ?>
Çıktının başlarında PHP kurulumu için kullanılan ./configure satırını göreceksiniz.

PHP'yi GD kütüphanesi ile derlerken ya tuhaf derleme hataları ya da çalışma sırasında parçalama arızası alıyorum.

GD kütüphanesinin PHP'nin bağımlı olduğu kütüphanelerle (libpng gibi) ilintilenerek derlenmiş olduğundan emin olun.

PHP'yi derlerken rasgele hatalar alıyorum ve derleme işlemi duruyor. Bu arada, Solaris kullandığımı belirtmeliyim.

PHP'yi GNU araçları dışında araçlarla derlemek bazı sorunlara sebep olabilir. PHP'yi GNU araçlarıyla derlemeye çalışın. Örneğin, Solaris'te SunOS BSD uyumlu veya Solaris sürümü sed çalışmayacak fakat GNU veya Sun POSIX (xpg4) sürümleri çalışacaktır. Derleme için gerekli araçlar: » GNU sed, » GNU flex ve » GNU bison.

Kurulum
PHP Kullanımı
SSS


PHP Kullanımı

Bu bölüm, PHP betiklerini yazarken karşılaşabileceğiniz hatalarla ilgili sıkça sorulan sorulardan oluşturulmuştur.

  1. PHP'deki değiştirgelerin sırasını hatırlayamadıh, rasgele midir?
  2. Bir formdan gelen veriyi işleyebileceğim genel amaçlı bir PHP betiği yazmak istiyorum. Hangi POST değişkenlerinin kullanılabilir olduğunu nasıl bileceğim?
  3. Benim bütün tek tırnakları bir tersbölü ile öncelemem lazım. Bunu bir düzenli ifade ile nasıl yapabilirim? Ayrıca, " imlerini \" ve \ imlerini de \\ biçimine çevirmek istiyorum.
  4. Benim bütün " imlerim \" dizgelerine ve ' imlerim de \' dizgelerine dönüşmüş. Bu istenmeyen tersbölülerden nasıl kurtulurum? Bunlar neden ve nasıl ortaya çıktılar?
  5. PHP'nin register_globals yönergesi beni nasıl etkiler?
  6.       Aşağıdakini gerçeklerken çıktı yanlış sırada basılıyor:

<?php
function işlevim($değiştirge)
{
    echo $değiştirge + 10;
}
$değişken = 10;
echo "işlevim($değişken) = " . işlevim($değişken);
?>

     Neyi yanlış yapıyorum?
  7. Hey, satırsonu karakterleri nereye gitti? <pre> <?php echo "Bu ilk satır olmalı."; ?> <?php echo "Bu da ilk satırın altındaki satır olmalı."; ?> </pre>
  8. Şöyle bir ileti alıyorum: 'Warning: Cannot send session cookie - headers already sent...' veya 'Cannot add header information - headers already sent...'. (Tercümesi: 'Uyarı: Oturum çerezleri gönderilemiyor - başlıklar zaten gönderilmişti...' veya 'Başlık bilgisi eklenemiyor - başlıklar zaten gönderilmişti...')
  9. İstek başlığındaki bilgiye doğrudan erişmem gerekiyor. Bunu nasıl yapabilirim?
  10. IIS ile kimlik doğrulaması yapmaya çalışırken şunu alıyorum: 'No Input file specified' (Türkçesi: 'Girdi dosyası belirtilmemiş').
  11. Windows: IIS kullanarak diğer bilgisayardaki paylaşımlı dosyalara erişemiyorum.
  12. PHP betiklerinde nasıl XML kullanabilirim? <?xml etiketlerinde sorun çıkarıyor!
  13. PHP'de kullanabileceğim değişkenlerin tam listesini nerede bulabilirim?
  14. PDFLib gibi ticari ve özgür olmayan kütüphaneleri kullanmaksızın PDF dosyaları nasıl üretebilirim?
  15. Kullanıcı tanımlı bir işlevden standard CGI değişkenlerinden birine ($DOCUMENT_ROOT veya $HTTP_REFERER gibi) erişmeye çalışıyorum ama beceremiyorum. Neyi yanlış yapıyorum?
  16. Bazı PHP yönergeleri büyük bayt değerleri için Kilobayt, Megabayt birimlerin kısaltmalarını kabul edebiliyor. Bu birimlerin tam listesini nerede bulabilirim ve bunları php.inidışında da kullanabilir miyim?
  17. Windows: localhost kullanırken bağlantı sürekli zaman aşımına uğruyor, halbuki "127.0.0.1" çalışıyor. Ne yapmalıyım?
PHP'deki değiştirgelerin sırasını hatırlayamadıh, rasgele midir?

PHP yüzlerce harici kütüphaneyi bir araya getiren bir yapıştırıcıdır, dolayısıyla bu bazı düzensizlikleri yol açar. Böyle düzensizlikler için basit bir kural uygulanır:

Dizi işlevlerinin değiştirgeleri "iğne, samanlık" diye dizilirken dizge işlevlerinin değiştirgeleri tersine "samanlık, iğne" diye dizilir.

Bir formdan gelen veriyi işleyebileceğim genel amaçlı bir PHP betiği yazmak istiyorum. Hangi POST değişkenlerinin kullanılabilir olduğunu nasıl bileceğim?

PHP, $_POST süper küreseli gibi bir çok öntanımlı değişkene sahiptir. POST yöntemi ile gönderilmiş değerleri bir ilişkisel dizi olarak $_POST üzerinden döngüye sokabilirsiniz. Örnek olarak, foreach ile basit bir döngü oluşturup boş değerleri empty() ile tespit edip bütün değerleri basalım:

<?php
$empty = $post = array();
foreach ($_POST as $varname => $varvalue) {
    if (empty($varvalue)) {
        $empty[$varname] = $varvalue;
    } else {
        $post[$varname] = $varvalue;
    }
}

print "<pre>";
if (empty($empty)) {
    print "POST ile gönderilen boş değer yok; değerler:\n";
    var_dump($post);
} else {
    print count($empty) . " boş değer var.\n";
    print "Boş olmayanlar:\n"; var_dump($post);
    print "Boş olanlar:\n";  var_dump($empty);
    exit;
}
?>

Benim bütün tek tırnakları bir tersbölü ile öncelemem lazım. Bunu bir düzenli ifade ile nasıl yapabilirim? Ayrıca, " imlerini \" ve \ imlerini de \\ biçimine çevirmek istiyorum.

Bunun bir veritabanı için yapıldığını varsayarak, veritabanı ile gelen önceleme mekaizması kullanılabilir. Örneğin, MySQL ile mysql_real_escape_string(), PostgreSQL ile pg_escape_string() işlevi kullanılır. Ayrıca, PHP kodu için daha genel amaçlı olarak addslashes() ve stripslashes() işlevleri de vardır.

Bilginize: magic_quotes_gpc yönergesi hakkında

magic_quotes_gpc yönergesinin değeri öntanımlı olarak on' olup tüm GET, POST ve COOKIE verisi üzerinde addslashes() çalıştırılmasına sebep olur. Bunun etkisini ortadan kaldırmak için stripslashes() kullanılabilir.

Benim bütün " imlerim \" dizgelerine ve ' imlerim de \' dizgelerine dönüşmüş. Bu istenmeyen tersbölülerden nasıl kurtulurum? Bunlar neden ve nasıl ortaya çıktılar?

PHP'nin magic_quotes_gpc yönergesi etkin olduğu sürece tersbölüler sihirli bir biçimde ortaya çıkacaklardır. Bu PHP'nin eski bir özelliği olup iptal edilmesi ve kullanılmaması gerekir. Ayrıca, stripslashes() adlı PHP işlevi de bir dizgeden tersbölüleri ayıklamak için kullanılabilir.

Bilginize: magic_quotes_gpc yönergesi hakkında

magic_quotes_gpc yönergesinin değeri öntanımlı olarak on' olup tüm GET, POST ve COOKIE verisi üzerinde addslashes() çalıştırılmasına sebep olur. Bunun etkisini ortadan kaldırmak için stripslashes() kullanılabilir.

PHP'nin register_globals yönergesi beni nasıl etkiler?
Uyarı

Bu özelliğin kullanımı PHP 5.3.0 itibariyle ÖNERİLMEMEKTE olup PHP 5.4.0'da tamamen KALDIRILMIŞTIR.

Önce, bu ini ayarının ne işe yaradığından bahsedelim. Şöyle bir URL'miz olsun: http://gen.tr/fan.php?hayvan=kedi. Ayrıca, fan.php içinde şu PHP kodu bulunsun:

<?php
// Burada $_GET tercih ediyoruz
echo $_GET['hayvan'];

// $hayvan'ın mevcut olması için, register_globals on olmalı
// BUNU YAPMAYIN
echo $animal;

// Bu, tüm değişkenlere uygulanır, tabii $_SERVER'a da
echo $_SERVER['PHP_SELF'];

// Tekrar, $PHP_SELF'in mevcut olması için, register_globals on olmalı
// BUNU YAPMAYIN
echo $PHP_SELF;
?>

Yukarıdaki kod register_globals'in çok sayıda değişkeni nasıl oluşturduğunu göstermektedir. Yıllardır böyle bir kodlama uygun görülmediği gibi yıllardır öntanımlı olarak register_globals off'tur. Çoğu sitede register_globals kapalı olsa da hala güncellenmemiş makaleler, öğreticiler ve kitaplar değerenin 'on' olması gerektiğini belirtip durmaktalar. Bunlar bir an önce düzeltilmelidir.

Daha fazla bilgi için aşağıdaki belgelere de bakınız:

  • register_globals yönergesi
  • register_globals kullanımı ile ilgili güvenlik bölümü
  • Dış Kaynaklı Değişkenler
  • Süper küresellerin kullanımı

Bilginize:

Yukarıdaki örnekte bir sorgu dizgesi içeren bir URL kullanılmıştır. Bu tür bilgiler aktarılırken bir GET HTTP isteği yapılır. Dolayısıyla, $_GET süper küreselinin kullanılma nedeni de budur.

Aşağıdakini gerçeklerken çıktı yanlış sırada basılıyor:
<?php
function işlevim($değiştirge)
{
    echo $değiştirge + 10;
}
$değişken = 10;
echo "işlevim($değişken) = " . işlevim($değişken);
?>
Neyi yanlış yapıyorum?

İşlevinizin sonucunu bir ifadede kullanmak istiyorsanız (yukarıdaki örnekte yapıldığı gibi dizgeleri ardarda eklemek gibi), işlevinizin sonucu return ile döndürmesi echo ile çıktılamaması gerekir.

Hey, satırsonu karakterleri nereye gitti?
<pre>
<?php echo "Bu ilk satır olmalı."; ?>
<?php echo "Bu da ilk satırın altındaki satır olmalı."; ?>
</pre>

PHP'de, bir kod bloğu ya "?>" ya da "?>\n" (burada \n satırsonu karakteridir) ile biter. PHP blokların sonundaki satırsonu karakterlerini yoksaydığından yukarıdaki örnekte çıktılanan iki satır aynı satıra basılacaktır. Yani, her bloktan sonra bir satırsonu karakteri basılmasını istiyorsanız fazladan bir satırsonu karakteri yerleştirmeniz (bloklar arasına boş bir satır girmek) gerekir.

PHP bunu neden yapıyor? Normal HTML biçemlerken bloklardan sonra satırsonu karakterlerinin bulunması genelde istenmeyen bir durumdur ve PHP buna göre davranır. Bu böyle yapılmasaydı gereğinden fazla uzun satırlardan oluşan kodlar yazmak zorunda kalırdınız ve bu da kodlarınızın okunaklılığını azaltırdı.

Şöyle bir ileti alıyorum: 'Warning: Cannot send session cookie - headers already sent...' veya 'Cannot add header information - headers already sent...'. (Tercümesi: 'Uyarı: Oturum çerezleri gönderilemiyor - başlıklar zaten gönderilmişti...' veya 'Başlık bilgisi eklenemiyor - başlıklar zaten gönderilmişti...')

Başlıkları çıktı akımına eklemek için header(), setcookie() ve oturum işlevleri kullanmak gerekir. Bu işlevleri kullanmadan önce hiçbir çıktılama (HTML gibi) yapılmamış olması gerekir. headers_sent() işlevi betiğinizin evvelce başlıkları gönderip göndermediğinize bakacaktır. Ayrıca, Çıktı Denetim İşlevleri'ne de bakınız.

İstek başlığındaki bilgiye doğrudan erişmem gerekiyor. Bunu nasıl yapabilirim?

PHP'yi bir Apache modülü olarak çalıştırıyorsanız getallheaders() işlevi istediğiniz şeyi yapacaktır. Aşağıdaki küçük kod tüm istek başlıklarını gösterecektir:

<?php
$başlıklar = getallheaders();
foreach ($başlıklar as $isim => $içerik) {
    echo "başlıklar[$isim] = $içerik<br />\n";
}
?>

Ayrıca bakınız:
apache_lookup_uri(),
apache_response_headers() ve
fsockopen()

IIS ile kimlik doğrulaması yapmaya çalışırken şunu alıyorum: 'No Input file specified' (Türkçesi: 'Girdi dosyası belirtilmemiş').

IIS'nin güvenlik modeli bu noktada hata verecektir. Bu, IIS altında çalışan bütün CGI programlarının ortak sorunudur. Bu sorundan kurtulmanın tek yolu erişim için kimlik doğrulaması yapılacak dizinde girdi sayfası olarak (PHP ile çözümlenmeyecek) düz bir HTML sayfası oluşturmaktır. Ya bir META etiketi ile PHP dosyaya yönlendirme yaparsınız ya da sayfaya PHP dosya için bir bağlantı koyarsınız. Böylelikle PHP kimlik doğrulamasını doğru olarak yapacaktır. ISAPI modülü kullanıldığında böyle bir sorun ortaya çıkmaz. Bunun diğer NT HTTP sunucularını etkilememesi gerekir. Daha fazla bilgi için » http://support.microsoft.com/kb/q160422/ adresine ve bu kılavuzun HTTP Kimlik Doğrulaması bölümüne bakınız.

Windows: IIS kullanarak diğer bilgisayardaki paylaşımlı dosyalara erişemiyorum.

Internet Information Services Yöneticisini açın. PHP dosyanızı bulup özelliklerine gidin. Dosya Güvenliği sekmesine geçip, Anonim erişim ve kimlik doğrulama denetimi bölümlerini düzenleyin.

Anonim Erişim'i işaretsiz, Tümleşik Windows Kimlik Doğrulaması'nı işaretli bırakarak veya Anonim Erişim'i işaretleyip erişim izni vermek istediğiniz kullanıcıyı düzenleyerek sorunu çözümleyebilirsiniz.

PHP betiklerinde nasıl XML kullanabilirim? <?xml etiketlerinde sorun çıkarıyor!

<?xml etiketlerini PHP kodu içinde doğrudan kullanmak isterseniz, PHP'nin kısa etiketlerini, short_open_tags yönergesine 0 değerini atamak suretiyle devre dışı bırakmanız gerekir. Bu yönergeye ini_set() işleviyle değer atayamazsınız. short_open_tags yönergesinin değerinin ne olduğuna bakmaksızın bu etiketi şöyle de kullanabilirsiniz: <?php echo '<?xml'; ?>. Bu yönergenin öntanımlı değeri On'dur.

PHP'de kullanabileceğim değişkenlerin tam listesini nerede bulabilirim?

Betiğinizde kullanılabilecek öntanımlı değişkenlerin bir kısmını içeren Öntanımlı Değişkenler bölümünü okuyunuz. Kullanılabilecek değişkenlerin ve daha pek çok şeyin tam bir listesini elde etmek için phpinfo() işlevini kullanabilirsiniz. HTML formları, çerezler ve URL'ler gibi kaynaklardan elde edilen harici değişkenlerle ilgili senaryoların açıklandığı Dış Kaynaklı Değişkenler bölümünü de okumayı unutmayın.

PDFLib gibi ticari ve özgür olmayan kütüphaneleri kullanmaksızın PDF dosyaları nasıl üretebilirim?

PHP ile yazılmış bir kaç seçenek var: » FPDF ve » TCPDF.

Bundan başka, özgür libHaru harici kütüphanesini kullanan Haru eklentisi diye bir eklenti daha vardır.

Kullanıcı tanımlı bir işlevden standard CGI değişkenlerinden birine ($DOCUMENT_ROOT veya $HTTP_REFERER gibi) erişmeye çalışıyorum ama beceremiyorum. Neyi yanlış yapıyorum?

PHP'nin register_globals yönergesinin sunucu ve ortam değişkenlerini nasıl etkilediğini bilmek önemlidir. register_globals = off olduğunda (PHP 4.2.0'den beri öntanımlı olarak böyledir), $DOCUMENT_ROOT değişkeni mevcut olmayacaktır. Yerine $_SERVER['DOCUMENT_ROOT'] kullanmalısınız. register_globals = on olduğunda ise $DOCUMENT_ROOT ve $GLOBALS['DOCUMENT_ROOT'] değişkenlerinin ikisi de mevcut olacaktır.

register_globals = on olduğunda $DOCUMENT_ROOT değişkeninin işlevlerin içinde neden geçerli olmadığını merak ediyor olabilirsiniz. Bunun sebebi, diğer değişkenler gibi bunun için de global $DOCUMENT_ROOT gerekmesidir. Ayrıca, Değişken etki alanı bölümüne de bakınız. Ancak, kodlarınızı register_globals = off olduğu duruma uygun olarak yazmayı tercih etmelisiniz.

Bazı PHP yönergeleri büyük bayt değerleri için Kilobayt, Megabayt birimlerin kısaltmalarını kabul edebiliyor. Bu birimlerin tam listesini nerede bulabilirim ve bunları php.inidışında da kullanabilir miyim?

Kilobaytlar için K, Megabaytlar için M ve PHP 5.1.0'dan beri Gigabaytlar için G kullanılabilmektedir. Bunlar harf büyüklüğüne duyarlıdır. Belirtilmedikleri takdirde değerin bayt sayısını gösterdiği varsayılır. 1K bir Kilobayta veya 1024 bayta, 1M ise bir Megabayta veya 1048576 bayta eşittir. Bu birimlerin kısa gösterimlerini php.ini dışında da kullanabilirsiniz. Bu değerler arasındaki dönüşümlerin nasıl yapıldığı ini_get() belgesinde açıklanmıştır.

Bilginize: kilobayt mı, kibibayt mı?

PHP gösteriminde bir kilobayt 1024 bayta eşittir. IEC standardı bunu kibibayt olarak adlandırır. Özetle: k veya K = 1024 bayt.

Windows: localhost kullanırken bağlantı sürekli zaman aşımına uğruyor, halbuki "127.0.0.1" çalışıyor. Ne yapmalıyım?

PHP'nin ağ çözümleme kodunda, PHP 5.3.4 öncesinde, IPv6 etkinken, akımlarla ilgili tüm durumlarda localhost'un başarısız olmasına sebep olan bir yazılım hatası vardı. Bu sorundan kurtulmak için ya hosts dosyasına IPv6 çözümlemesini iptal edin ya da localhost yerine "127.0.0.1" kullanın.

Derleme Sorunları
Parola Karıştırma
SSS


Güvenli Parola Karıştırma

Bu bölümde, parolaları güvenlik altına alma da kullanılan karıştırma (hashing) işlevinin arka planını ve etkin bir şekilde nasıl uygulayabileceğimizi ele alacağız.

  1. Kullanıcıların girmiş olduğu parolaları neden karıştırmalıyım?
  2. MD5 ve SHA1 gibi genel karıştırma işlevlerini parolalar için kullanmak neden uygun değildir?
  3. Genel karıştırma teknikleri kullanışlı olmadıklarına göre, parolalarımı nasıl karıştırmalıyım?
  4. Tuzlama nedir?
  5. Tuzlarımı nasıl saklarım?
Kullanıcıların girmiş olduğu parolaları neden karıştırmalıyım?

Parola karıştırma, kullanıcıların parola girerek kullandıkları bir uygulamanın tasarımında, mutlaka göz önüne alınması gereken en temel güvenlik faktörlerinden birisidir. Parola karıştırma tekniği kullanılmadığı takdirde, uygulamanızın veri tabanında saklanan her türlü parola veritabanınızı ele geçirenler tarafından çalınabilir ve ardından sadece uygulamanız değil uygulamanızı kullanan kullanıcılar aynı parolayı başka servisler için de kullanıyorlarsa risk altında kalırlar.

Kullanıcılarınızın parolalarını veri tabanına kaydetmeden önce, uygulayacağınız karıştırma algoritması ile saldırganın özgün parolayı tahminini imkansız kılarken, ilerleyen süreçte de özgün parolayı bulma çabalarını da (kaba kuvvet saldırısı tekniğiyle) zorlaştırmış olursunuz.

Ancak, dikkat edilmesi gereken önemli nokta, parola karıştırma sadece veri kaynağınızın ele geçirilmesine karşı koruma sağlarken, uygulamanıza isteminiz dışında yerleştirilmiş zararlı kodlar aracılığıyla şifreleri ele geçirmede koruma sağlamaz.

MD5() ve SHA1() gibi genel karıştırma işlevlerini parolalar için kullanmak neden uygun değildir?

MD5, SHA1 ve SHA256 gibi karıştırma algoritmaları verimli ve çok hızlı olmaları için tasarlanmıştır. Modern teknikler ve bilgisayar ekipmanları ile, Kaba kuvvet (brute force) atak tekniği kullanarak özgün değere ulaşma sıradan bir hale gelmiştir.

Çünkü, modern bir bilgisayar, oldukça hızlı olarak bu karıştırma tekniklerini tersine çevirir, çoğu güvenlik uzmanı da bunların parola karıştırma da kullanımına karşı aleyhte tavsiye de bulunur.

Genel karıştırma teknikleri kullanışlı olmadıklarına göre, parolalarımı nasıl karıştırmalıyım?

Parolaları karıştırmada, dikkate alınması gereken iki husus vardır; hesaplamanın maliyeti ve tuzlama. Karıştırma algoritmasında daha fazla hesaplama maliyeti demek kaba kuvvet ataklarının daha fazla zaman gerektirmesi demektir.

PHP 5.5, güvenli bir şekilde karıştırma ve parola doğrulamayı birlikte güvenle sağlayan bir yerel parola karıştıma APIsi sağlamaktadır. Ayrıca PHP 5.3.7 sürümünden itibaren kullanılabilen » saf bir PHP uyumluluk kütüphanesi de vardır.

Diğer bir seçenek PHP 5.3 sürümünden itibaren çeşitli karıştırma algoritmalarını destekleyen crypt() işlevidir. Bu işlevi kullanırken, PHP, desteklenen her bir algoritmayı kendi bünyesinde barındırdığı için, algoritmalardan bir veya bir kaçı sisteminizde bulunmasa da seçtiğiniz algoritmanın varlığını ve kullanımını garanti eder.

Diğer karıştırma işlevi ise crypt() işlevinden daha fazla algoritmayı ve seçeneği destekleyen fakat crypt() işlevinin desteklediği bazı algoritmaları desteklemeyen hash() işlevidir. Hash eklentisi PHP ile birlikte gelir fakat derleme anında kullanıcı dilerse gözardı edebilir dolayısıyla crypt() işlevinde olduğu gibi algoritmaların varlığını garanti etmez.

Parola karıştırma da tavsiyemiz Blowfish algoritmasını kullanmanızdır, parola karıştırma APIsi tarafından da öntanımlı olarak kullanılan bu algoritma MD5 veya SHA1 den daha fazla hesaplama gerektirmesine rağmen hala ölçeklenebilir durumdadır.

Bir parolayı doğrulamak için crypt() kullanıyorsanız, bir sabit zaman dizgesi karşılaştırması kullanarak zamanlama saldılarını engellemeyi düşünmeniz gerekir. Ne PHP'nin == ve === işleçleri ne de strcmp() işlevi sabit zaman dizgesi karşılaştırması yapar. password_verify() bunu sizin için yapacak gibi görünse de mümkün oldğunca yerel parola karıştıma APIsini kullanmanızı şiddetle öneririz.

Tuzlama nedir?

Bir şifreleme tuzu, gökkuşağı tablosu olarak bilinen, daha önceden hesaplanarak oluşturulmuş karıştırma listesinden karşılaştırma yaparak eşleştirme ihtimalini ortadan kaldırmak için, karıştırma işlemi esnasında uygulanan bir değerdir.

Basit anlamda tuz, karıştırılmış değerinizi kırma teşebbüslerini zorlaştırmada kullanılan ek bir veridir. İnternet üzerinde, daha önceden hesaplanmış kapsamlı karıştırma değerlerinin yanı sıra özgün değerleri de barındıran bir dizi liste hizmeti vardır. Tuz kullanmak bu listelerden karıştırma değerini bulmayı mantıksız veya imkansız kılar.

Bir tane sağlanmamışsa password_hash() rasgele bir tuz oluşturacaktır ve bu genelde en kolay ve en güvenilir yaklaşımdır.

Tuzlarımı nasıl saklarım?

password_hash() veya crypt() işlevini kullanırken, dönen değer üretilen karıştırılmış parola olup tuzu da içerir. Parolaları doğrularken password_verify() veya crypt() işlevine doğrudan verilebilecek şekilde karıştırma bilgisini içeren bu değer veritabanınızda hiç değiştirlmeden harfi harfine saklanmalıdır.

Aşağıdaki şekil, crypt() veya password_hash() işlevinden dönen değerin biçimini gösterir. Görebileceğiniz gibi, ileriki bir parola doğrulaması için gereken tuzu ve algoritma ile ilgili tüm bilgiyi içinde barındırmaktadır.

password_hash veya crypt işlevinden dönen değerin bileşenleri: sırasıyla, seçilen algoritma, algoritmanın seçenekleri, kullanılan tuz ve karıştırlmış parola.

PHP Kullanımı
PHP ve HTML
SSS


PHP ve HTML

PHP ve HTML etkileşir: PHP, HTML üretir; HTML, PHP'ye bilgi aktarır. Bu SSS'yi okumaya başlamadan önce değişkenlerin dış kaynaklardan nasıl elde edildiğini öğrenmiş olmanız önemlidir. Bu konu ile igili kılavuz sayfası ayrıca örnekler de içerir.

  1. Bir değeri bir form veya URL üzerinden aktarırken nasıl kodlamak gerekir?
  2. Bir <input type="image"> etiketi kullanmayı deniyorum, ama $foo.x ve $foo.y değişkenlerini bulamıyorum. $_GET['foo.x'] mevcut değil mi? Bunlar neredeler?
  3. Bir HTML <form>'unda dizileri nasıl oluşturabilirim?
  4. Çok HTML etiketli bir select etiketinden tüm sonuçları nasıl alırım?
  5. Bir değişkeni Javascript'ten PHP'ye nasıl aktarabilirim?
Bir değeri bir form veya URL üzerinden aktarırken nasıl kodlamak gerekir?

Hangi kodlamanın hangi aşamada kullanılacağı önemlidir. İçeriğini kodlamaksızın aktarmak istediğiniz string türünde $data diye bir değişkeniniz olduğunu varsayalım. Aşamalar şunlardır:

  • HTML yorumlaması. Rasgele bir dizgeyi belirtirken dizgeyi çift tırnak içine almanız ve değerin tamamına htmlspecialchars() uygulamanız gerekir.

  • URL: Bir URL çeşitli parçalardan oluşur. Verinizin tek bir öğe olarak yorumlanmasını isterseniz, veriyi urlencode() ile kodlamanız gerekir.

Örnek 1 - Gizli bir HTML form elemanı

<?php
    echo '<input type="hidden" value="' . htmlspecialchars($data) . '" />'."\n";
?>

Bilginize: $data için urlencode() kullanmak yanlıştır, çünkü veriyi urlencode() türünde kodlamak tarayıcının sorumluluğundadır. Bunun yöntemden (yani GET veya POST) bağımsız oluşuna dikkat ediniz. Bunu sadece GET isteklerinde farkedersiniz, çünkü POST istekleri normalde gizlidir.

Örnek 2 - Kullanıcı tarafından düzenlenen veri

<?php
    echo "<textarea name='mydata'>\n";
    echo htmlspecialchars($data)."\n";
    echo "</textarea>";
?>

Bilginize: Umulduğu gibi veri tarayıcıda gösterilir, çünkü HTML öncelemeli simgeleri tarayıcının yorumlaması gerekir. Verinin GET veya POST üzerinden gönderiminde veri aktarılırken tarayıcı tarafından kodlanır (urlencode) ve bu kodlama PHP tarafından çözülür (urldecode). Böylece, sizin kodlamayla ilgili birşeyler yapmanız gerekmez, herşey özdevinimli olarak gerçekleşir.

Örnek 3 - Bir URL içinde

<?php
    echo '<a href="' . htmlspecialchars("/nextpage.php?stage=23&data=" .
        urlencode($data)) . '">'."\n";
?>

Bilginize: Aslında bir HTML GET isteğini taklit ettiğinizden veriye urlencode() uygulamanız gerekmez.

Bilginize: URL, bir HTML özniteliğinin değeri olduğundan URL'nin tümüne htmlspecialchars() kodlaması uygulamanız gerekir. Bu durumda, tarayıcı değere htmlspecialchars() çözümlemesi uyguladıktan sonra URL olarak aktarır. PHP, URL'yi doğru olarak algılayacaktır, çünkü veriye urlencode() uygulamışsınızdır. URL'deki & yerine &amp; yazıldığını farkedeceksiniz. Çoğu tarayıcı bunu sizin yerinize yaptığından bunu yapmayı unutsanız da o kadar önemli değildir. Ancak, URL'niz devingen olmasa bile, URL'ye htmlspecialchars() uygulamanız gerekir.

Bir <input type="image"> etiketi kullanmayı deniyorum, ama $foo.x ve $foo.y değişkenlerini bulamıyorum. $_GET['foo.x'] mevcut değil mi? Bunlar neredeler?

Bir formu göndermek için bir gönderi düğmesi yerine aşağıdaki gibi bir resim kullanmak da mümkündür:

<input type="image" src="dugme.gif" name="foo" />
Kullanıcı bu resmin herhangi bir yerine tıkladığında sunucuya formla birlikte ek olarak foo.x ve foo.y diye iki değişken aktarılır.

foo.x ve foo.y PHP'de geçersiz değişken isimleri olduklarından sihirli bir şekilde bunlar foo_x ve foo_y değişkenlerine dönüşürler. Yani, nokta imi yerine altçizgi imi yerleştirilir. Dolayısıyla, bu değişkenlere dış kaynaklı değişkenler bölümünde açıkladığı gibi erişebilirsiniz. Örnek: $_GET['foo_x'].

Bilginize:

İstekle aktarılan değişken isimlerindeki boşluklar da alçizgi imleri ile değiştirilir.

Bir HTML <form>'unda dizileri nasıl oluşturabilirim?

<form> sonucunu bir dizi olarak göndermek için PHP betğinizde <input>, <select> veya <textarea> elemanlarını şöyle isimlendirmeniz gerekir:

<input name="Dizim[]" />
<input name="Dizim[]" />
<input name="Dizim[]" />
<input name="Dizim[]" />
Değişken isimlerinden sonra gelen köşeli ayraçları farketmişsinizdir. Bunlar değişkeni bir dizi haline getirirler. Farklı elemanlara aynı dizi isimlerini atamak suretiyle elemanları farklı diziler içinde gruplayabilirsiniz:
<input name="Dizim[]" />
<input name="Dizim[]" />
<input name="ÖbürDizim[]" />
<input name="ÖbürDizim[]" />
Bu örnekte PHP betiğine gönderilmek üzere iki dizi üretilmektedir: Dizim ve ÖbürDizim. Dizilerinize ayrıca özel anahtarlar atamanız da mümkündür:
<input name="DiğerDizim[]" />
<input name="DiğerDizim[]" />
<input name="DiğerDizim[eposta]" />
<input name="DiğerDizim[telefon]" />
Burada, DiğerDizim dizisi 0, 1, eposta ve telefon anahtarlarını içerecektir.

Bilginize:

HTML'de dizi anahtarlarını belirtmek isteğe bağlıdır. Anahtar belirtmezseniz, dizi elemanları formda yer alış sırasına göre numaralanır. Örneğimizde anahtarlar 0, 1, 2 ve 3 olacaktır.

Ayrıca bakınız: Dizi İşlevleri ve Dış Kaynaklı Değişkenler .

Çok HTML etiketli bir select etiketinden tüm sonuçları nasıl alırım?

Bir HTML'deki çok seçenekli bir select oluşumu kullanıcıların bir listeden çok sayıda öğe seçebilmesini mümkün kılar. Seçilen öğeler form için atanmış bir eylemciye aktarılırlar. Burada sorun, hepsinin aynı değişken ismiyle aktarılmasıdır. Örnek:

<select name="var" multiple="yes">
Seçilen her seçenek eylemciye şöyle aktarılacaktır:
var=seçim1
var=seçim2
var=seçim3
Her seçenek bir önceki $var değişkeninin içeriğinin üzerine yazacaktır. Çözüm, değişken ismi olarak dizi kullanmaktır:
<select name="var[]" multiple="yes">
Bu satır PHP'ye $var değişkenini bir dizi olarak ele almasını ve her seçeneğin içeriği için bir dizi elemanı eklemesini söyler. İlk seçim $var[0], ikincisi $var[1], vs. olur. Kaç seçeneğin seçilmiş olduğunu count() işlevi ile öğrenebilir veya gerekirse sort() işleviyle seçenek dizisini sıraya sokabilirsiniz.

JavaScript kullanıyorsanız eleman ismindeki [] ayraçları, elemanlara isimleriyle başvururken sorun çıkarabilir. Ya eleman anahtarı yerine sayısal biçimi kullanın ya da değişken isimlerini tek tırnak içine alıp bunları dizi elemanlarını indislemekte kullanın. Örnek:

variable = document.forms[0].elements['var[]'];

Bir değişkeni Javascript'ten PHP'ye nasıl aktarabilirim?

Javascript'in (normal olarak) istemci taraflı, PHP'nin sunucu taraflı olması ve HTTP'nin de 'durumsuz' bir protokol olması nedeniyle iki dil değişkenleri doğrudan paylaşamazlar.

Bununla birlikte, ikisi arasında değişken alışverişi mümkündür. Bunu sağlamanın tek yolu Javascript kodunu PHP ile üretmek ve tarayıcıya tazeletip özel değişkenleri gerisin geriye PHP'ye aktarmaktır. Aşağıdaki örnekte bunun nasıl yapıldığı ayrıntılı olarak gösterilmiştir. Normalde sadece istemci tarafında mümkün olan ekran yüksekliği ve genişliğinin elde edilmesi PHP kodunda gerçeklenmektedir.

Örnek 4 - PHP ile Javascript üretimi

<?php
if (isset($_GET['width']) AND isset($_GET['height'])) {
  // Boyut değişkenlerini çıktılayalım
  echo "Ekran genişliği: ". $_GET['width'] ."<br />\n";
  echo "Ekran yüksekliği: ". $_GET['height'] ."<br />\n";
} else {
  // Boyut değişkenlerini aktaralım
  // (özgün sorgu dizgesini koruyalım
  //   -- post değişkenleri farklı şekilde elde edilecek)

  echo "<script language='javascript'>\n";
  echo "  location.href=\"${_SERVER['SCRIPT_NAME']}?${_SERVER['QUERY_STRING']}"
            . "&width=\" + screen.width + \"&height=\" + screen.height;\n";
  echo "</script>\n";
  exit();
}
?>

Parola Karıştırma
PHP ve COM
SSS


PHP ve COM

PHP, Win32 platformlarında COM ve DCOM nesnelere erişim için kullanılabilir.

  1. Bazı hesaplamalar için bir DLL derledim. Bu DLL'li PHP altında çalıştırmanın bir yolu var mı?
  2. 'Unsupported variant type: xxxx (0xxxxx)' iletisinin anlamı nedir?
  3. PHP'de görsel nesnelerle çalışmak mümkün müdür?
  4. Bir COM nesnesini bir oturumda saklayabilir miyim?
  5. COM hatalarını yakalayabilir miyim?
  6. Perl'de olduğu gibi PHP betiklerinden DLL dosyaları üretebilir miyim?
  7. 'Unable to obtain IDispatch interface for CLSID {xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}' iletisininin anlamı nedir?
  8. Bir COM nesnesini bir uzak sunucudan nasıl çalıştırabilirim?
  9. 'DCOM is disabled in C:\path...\scriptname.php on line 6' iletisini alıyorum. Ne yapabilirim?
  10. Bir ActiveX nesnesini PHP ile bir sayfaya yüklemek ve kullanmak mümkün müdür?
  11. Bir bileşenin çalışan bir örneğini almak mümkün müdür?
  12. COM nesnesinden gönderilen bir olayı işleme sokmanın bir yolu var mıdır?
  13. Birden fazla arayüz içeren bir COM nesnesinin bir yöntemini çağırmaya çalışırken sorunlarla karşılaşıyorum. Ne yapabilirim?
  14. PHP, COM ile çalıştığına göre COM+ ile de çalışır, değil mi?
  15. PHP, COM nesnelerle çalıştığına göre, özkaynakları yönetmek üzere MTS'yi PHP ile birlikte kullanmayı düşünebilir miyiz?
Bazı hesaplamalar için bir DLL derledim. Bu DLL'li PHP altında çalıştırmanın bir yolu var mı?

Bu basit bir DLL ise bunu PHP altında çalıştırmanın bir yolu yoktur. Eğer DLL bir COM sunucusu içeriyor ve IDispatch arayüzünü gerçekliyorsa bu DLL'e erişebilirsiniz.

'Unsupported variant type: xxxx (0xxxxx)' iletisinin anlamı nedir?

Düzinelerce VARIANT türü ve bunların birleşimleri vardır. Bunların çoğu desteklenmekteyse de bir kısmı halen gerçeklenme aşamasındadır. Diziler tamamen desteklenmemektedir. PHP ve COM arasında sadece tek boyutlu diziler aktarılabilmektedir. Lütfen bunu bir hata olarak raporlayın (hala raporlanmamışsa) ve bunu yaparken mümkün olduğunca fazla bilgi verin.

PHP'de görsel nesnelerle çalışmak mümkün müdür?

Genelde mümkündür, fakat PHP'deki gibi çoğunlukla HTTP sunucusu bağlamında işlem yapan bir betik dili olarak kullanılırlar. Bu bakımdan görsel nesneler hiçbir zaman sunucunun masaüstünde görünmezler. PHP'yi uygulama yazmak için kullanacaksanız (PHP-GTK örneğinde olduğu gibi), görsel nesnelerle COM üzerinden çalışmak için herhangi bir sınırlama yoktur.

Bir COM nesnesini bir oturumda saklayabilir miyim?

Hayır, saklayamazsınız. COM nesne örnekleri birer özkaynak olarak ele alınır. Bu bakımdan sadece tek betiklik bir bağlamda kullanılabilirler.

COM hatalarını yakalayabilir miyim?

COM eklentisi sizin de yakalayabileceğiniz com_exception istisnalarını yakalar. Bundan sonra ne yapılacağını belirlemek için code üyesini inceleyebilirsiniz.

COM hatalarını PHP tarafından sağlanan yollarla (@, track_errors, ...) yakalamak mümkün değildir.

Perl'de olduğu gibi PHP betiklerinden DLL dosyaları üretebilir miyim?

Hayır, maalesef PHP'de böyle bir araç yoktur.

'Unable to obtain IDispatch interface for CLSID {xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}' iletisininin anlamı nedir?

Bu hata pek çok sebepten ortaya çıkabilir:

  • CLSID yanlıştır.
  • İstenen DLL yoktur.
  • İstenen bileşen IDispatch arayüzünü gerçeklemiyordur.

Bir COM nesnesini bir uzak sunucudan nasıl çalıştırabilirim?

Tıpkı bir yerel nesne gibi çalıştırabilirsiniz. Tek yapacağınız, COM kurucusuna ikinci değiştirge olarak uzak makinenin IP adresini aktarmaktır.

php.ini dosyanızda com.allow_dcom =TRUE atamasını yapmış olmalısınız.

'DCOM is disabled in C:\path...\scriptname.php on line 6' iletisini alıyorum. Ne yapabilirim?

php.ini dosyanızı düzenlemek için açıp com.allow_dcom =TRUE atamasını yapın.

Bir ActiveX nesnesini PHP ile bir sayfaya yüklemek ve kullanmak mümkün müdür?

Bunun için PHP ile bir şey yapılamaz. HTML belge tarafından istendikleri takdirde ActiveX nesneler istemci tarafında yüklenirler. PHP betiğiyle bir ilgileri olmadığından sunucu taraflı doğrudan etkileşim mümkün değildir.

Bir bileşenin çalışan bir örneğini almak mümkün müdür?

Bu, takma adların yardımı ile mümkündür. Aynı yazı örneği için çok sayıda başvuru edinmek için örneği şöyle oluşturabilirsiniz:I

<?php
$yazı = new COM("C:\docs\yazı.doc");
?>

Çalışan bir örnek olmadığı takdirde bu yeni bir örnek oluşturur, aksi takdirde çalışan örnek için bir başvuru döndürür.

COM nesnesinden gönderilen bir olayı işleme sokmanın bir yolu var mıdır?

Bir olay alıcıyı tanımlayabilir ve bunu com_event_sink() kullanarak bağlayabilirsiniz. PHP'nin olay alıcı sınıfının bir iskeletini üretmesi için com_print_typeinfo() işlevini kullanabilirsiniz.

Birden fazla arayüz içeren bir COM nesnesinin bir yöntemini çağırmaya çalışırken sorunlarla karşılaşıyorum. Ne yapabilirim?

Yanıt pek tatmin edici değil biliyorum. Aslında tam olarak ne yapılacağını bilmiyorum ama yapılabilecek bir şeyler olmalı. Bu konuda bilgisi olar biri varsa lütfen » bana bildirsin. :)

PHP, COM ile çalıştığına göre COM+ ile de çalışır, değil mi?

COM+, COM'un bileşenlerini MTS ve MSMQ üzerinden yönetmek için bir arayüz ile genişletir. PHP'nin bu tarz nesneleri desteklemesi için yapacağı özel bir şey yoktur.

PHP, COM nesnelerle çalıştığına göre, özkaynakları yönetmek üzere MTS'yi PHP ile birlikte kullanmayı düşünebilir miyiz?

PHP henüz MTS hareketlerini işleme sokamamaktadır. Bu bakımdan, bir hata oluşursa hareketi başa sarmak mümkün değildir. MTS hareketlerini destekleyen bileşenleri kullanmak niyetindeyseniz hareket yönetimini kendiniz gerçeklemek zorundasınız.

PHP ve HTML
Çeşitli Sorular
SSS


Çeşitli Sorular

Burada, belli bir sınıfa dahil edilemeyen sorulara yer verilmiştir.

  1. .bz2 uzantılı kılavuzları Windows üzerinde nasıl açabilirim?
  2. asort gibi bazı işlev bildirimlerinde değiştirgenin başındaki & neyin nesidir?
  3. register_globals ile nasıl çalışacağım?
.bz2 uzantılı kılavuzları Windows üzerinde nasıl açabilirim?

bz2 dosyalarla çalışabilen bir arşivleme aracına sahip değilseniz komut satırı araçlarını » indirebilirsiniz (ayrıntılar için aşağıya bakınız).

Bir komut satırı aracı kullanmak istemezseniz, » Stuffit Expander, » UltimateZip, » 7-Zip, » Quick Zip gibi özgür araçları deneyebilirsiniz. » WinRAR veya » Power Archiver gibi araçlara sahipseniz onlar da bz2 dosyaları açabilmektedir. Total Commander (eskisi: Windows Commander) kullanıyorsanız, bz2 eklentisini » Total Commander sitesinden ücretsiz edinebilirsiniz.

Red Hat'in bzip2 komut satırı aracı:

Win2k Sp2 kullanıcıları için en son sürüm 1.0.2, tüm diğer Windows kullanıcıları için 1.00'dır. İndirdikten sonra çalıştırılabilirin ismini bzip2.exe yapın ve C harfi Windows'un kurulu olduğu sürücüyü belirtmek üzere C:\Windows dizinine koyun.

php_manual_dil.x.bz2 (dil: sizin diliniz, x: istenen biçim, chm gibi) arşiv dosyasının sıkıştırmasını açmak için şu talimatları izleyin:

  • Bir komut istemi penceresi açın.
  • İndirdiğiniz php_manual_dil.x.bz2 dosyasının bulunduğu dizine geçin.
  • php_manual_dil.x.bz2 arşiv dosyasının içeriğini genişletmek için şu komutu verin: bzip2 -d php_manual_dil.x.bz2

İndirdiğiniz php_manual_dil.x.bz2 dosyasının çok sayıda HTML sayfası içermesi durumunda bu işlem sonucunda php_manual_dil.tar adında bir dosya elde edeceksiniz. Tar biçemi » WinZip gibi pek çok Windows arşivleme aracı tarafından bilinmektedir.

asort() gibi bazı işlev bildirimlerinde değiştirgenin başındaki & neyin nesidir?

Bu, değiştirgenin gönderimli aktarıldığı anlamına gelir ve ilgili belgelerde de açıklandığı gibi işlev bunu değiştirecektir. Bu yolla sadece değişkenleri aktarabilirsiniz ve işlev çağrısında değiştirgenin başına & yerleştirmenize gerek yoktur (ve bu artık önerilmemektedir).

register_globals ile nasıl çalışacağım?

register_globals ile ilgili güvenlik kaygıları hakkında bilgi edinmek için güvenlik kısmında bulunan register_globals kullanımı bölümüne bakınız.

register_globals yerine süper küreselleri kullanmanız önerilir.

Eğer register_globals'in kapalı olduğu bir paylaşımlı konak üzerindeyseniz ve bu seçeneğin etkin olmasını gerektiren bazı eski uygulamaları kullanmanız gerekiyorsa veya bu özelliğin etkin olduğu bir barındırma sunucusundaysanız fakat güvenlikle ilgili riske girmek istemiyorsanız PHP ile zıt ayarları taklit etmeniz gerekebilir. PHP'nin yapılandırmasını değiştirmenin mümkün olup olmadığını önce bir sormanızda fayda var. Eğer mümkün değilse, aşağıdaki uyumluluk kodlarını kullanabilirsiniz:

Örnek 1 register_globals'in taklit edilmesi

Bu örnekte register_globals=On durumu taklit edilmektedir. Eğer variables_order yönergenizde değişiklik yaparsanız değişikliği $superglobals değişkenine de yansıtmalısınız.

<?php
// register_globals=on'u taklit edelim
if (!ini_get('register_globals')) {
    $superglobals = array($_SERVER, $_ENV,
        $_FILES, $_COOKIE, $_POST, $_GET);
    if (isset($_SESSION)) {
        array_unshift($superglobals, $_SESSION);
    }
    foreach ($superglobals as $superglobal) {
        extract($superglobal, EXTR_SKIP);
    }
}
?>

Bu örnekte ise register_globals=Off durumu taklit edilmektedir. Bu kodu betiğinizin oldukça baş taraflarına veya oturum başlatmak için kullandığınız session_start() çağrısından sonra yerleştirmeniz gerektiğini aklınızdan çıkarmayın.

<?php
// register_globals=off'u taklit edelim
function unregister_GLOBALS()
{
    if (!ini_get('register_globals')) {
        return;
    }

    // Daha hoş hatalar almak için bunu değiştirebilirsiniz
    if (isset($_REQUEST['GLOBALS']) || isset($_FILES['GLOBALS'])) {
        die('GLOBALS geçersizleştirme çabası algılandı');
    }

    // unset edilmemesi gereken değişkenler
    $noUnset = array('GLOBALS',  '_GET',
                     '_POST',    '_COOKIE',
                     '_REQUEST', '_SERVER',
                     '_ENV',     '_FILES');

    $input = array_merge($_GET,    $_POST,
                         $_COOKIE, $_SERVER,
                         $_ENV,    $_FILES,
                         isset($_SESSION) && is_array($_SESSION) ? $_SESSION : array());

    foreach ($input as $k => $v) {
        if (!in_array($k, $noUnset) && isset($GLOBALS[$k])) {
            unset($GLOBALS[$k]);
        }
    }
}

unregister_GLOBALS();

?>

PHP ve COM
Ekler
SSS


Ekler

  • History of PHP and Related Projects
    • History of PHP
    • History of PHP related projects
    • Books about PHP
    • Publications about PHP
  • Migrating from PHP 7.0.x to PHP 7.1.x
    • New features
    • New functions
    • New global constants
    • Backward incompatible changes
    • Deprecated features in PHP 7.1.x
    • Changed functions
    • Other changes
    • Windows Support
  • Migrating from PHP 5.6.x to PHP 7.0.x
    • Backward incompatible changes
    • New features
    • Deprecated features in PHP 7.0.x
    • Changed functions
    • New functions
    • New Classes and Interfaces
    • New Global Constants
    • Changes in SAPI Modules
    • Removed Extensions and SAPIs
    • Other Changes
  • Migrating from PHP 5.5.x to PHP 5.6.x
    • Backward incompatible changes
    • New features
    • Deprecated features in PHP 5.6.x
    • Changed functions
    • New functions
    • OpenSSL changes in PHP 5.6.x
    • Other changes to extensions
    • New global constants
  • Migrating from PHP 5.4.x to PHP 5.5.x
    • What has changed in PHP 5.5.x
    • Backward Incompatible Changes
    • New features
    • Deprecated features in PHP 5.5.x
    • Changed Functions
    • New Functions
    • New Classes and Interfaces
    • New Methods
    • Other changes to extensions
    • New Global Constants
    • Changes to INI file handling
    • Changes to PHP Internals
  • Migrating from PHP 5.3.x to PHP 5.4.x
    • What has changed in PHP 5.4.x
    • Backward Incompatible Changes
    • New features
    • Changes in SAPI modules
    • Deprecated features in PHP 5.4.x
    • Changed Functions
    • New Functions
    • New Classes and Interfaces
    • New Methods
    • Removed Extensions
    • Other changes to extensions
    • New Global Constants
    • Changes to INI file handling
    • Other changes
  • Migrating from PHP 5.2.x to PHP 5.3.x
    • What has changed in PHP 5.3.x
    • Backward Incompatible Changes
    • New features
    • Changes made to Windows support
    • Changes in SAPI modules
    • Deprecated features in PHP 5.3.x
    • Undeprecated features in PHP 5.3.x
    • New Parameters
    • New Functions
    • New stream wrappers
    • New stream filters
    • New Class Constants
    • New Methods
    • New Extensions
    • Removed Extensions
    • Other changes to extensions
    • New Classes
    • New Global Constants
    • Changes to INI file handling
    • Other changes
  • Migrating from PHP 5.1.x to PHP 5.2.x
    • What has changed in PHP 5.2.x
    • Backward Incompatible Changes
    • New Error Messages
    • Changes in PHP datetime support
    • New Parameters
    • New Functions
    • New Methods
    • Removed Extensions
    • New Extensions
    • New Classes
    • New Global Constants
    • New Class Constants
    • New INI Configuration Directives
    • Error Reporting
    • Other Enhancements
  • Migrating from PHP 5.0.x to PHP 5.1.x
    • Key PHP 5.1.x features
    • Changes in reference handling
    • Reading []
    • Integer values in function parameters
    • Class and object changes
    • Extensions
    • Date/time support
    • Changes in database support
    • Checking for E_STRICT
  • Migrating from PHP 4 to PHP 5.0.x
    • What has changed in PHP 5.0.x
    • Backward Incompatible Changes
    • CLI and CGI
    • Migrating Configuration Files
    • New Functions
    • New Directives
    • Databases
    • New Object Model
    • Error Reporting
  • PHP'de Hata Ayıklama
    • PHP'de hata ayıklama hakkında
  • Yapılandırma Seçenekleri
    • Temel yapılandırma seçeneklerinin listesi
  • php.ini Yönergeleri
    • php.ini yönergelerinin listesi
    • php.ini bölümlerinin listesi
    • Temel php.ini yönergelerinin tanımları
  • Eklenti Grupları/Listesi
    • Abecesel
    • Üyeler
    • Durumu Belirsizler
  • İşlev Takma Adlarının Listesi
  • Yerleşik Sözcüklerin Listesi
    • Anahtar Sözcüklerin Listesi
    • Öntanımlı Sınıflar
    • Yerleşik Sabitler
    • Diğer yerleşik sözcüklerin listesi
  • Özkaynak Türlerinin Listesi
  • Kullanılabilir Süzgeçlerin Listesi
    • Dizge Süzgeçleri
    • Dönüşüm Süzgeçleri
    • Sıkıştırma Süzgeçleri
    • Şifreleme Süzgeçleri
  • Desteklenen Soket Aktarımlarının Listesi
    • Genel Ağ Alanı: TCP, UDP, SSL ve TLS
    • Unix Alanı: Unix ve UDG
  • PHP Tür Karşılaştırma Tabloları
  • Çözümleyici Dizgeciklerinin Listesi
  • Kullanıcı Alanı İsimlendirme Kılavuzu
    • Küresel İsim alanı
    • Kurallar
    • İpuçları
  • About the manual
    • Formats
    • About user notes
    • How to read a function definition (prototype)
    • PHP versions documented in this manual
    • How to find more information about PHP
    • How to help improve the documentation
    • How we generate the formats
    • Translations
  • Creative Commons Attribution 3.0
  • Genel Dizin
    • İşlevler ve Yöntemler Dizini
    • Örnekler Dizini
  • Changelog
Çeşitli Sorular
History of PHP and Related Projects
PHP Kılavuzu


History of PHP and Related Projects

İçindekiler

  • History of PHP
  • History of PHP related projects
  • Books about PHP
  • Publications about PHP

PHP has come a long way since its birth in the mid-1990's. From humble beginnings to becoming one of the most prominent languages powering the web, the evolution of PHP is a geek's fairy tale. Mind you, such explosive growth was no easy task. Those of you interested in briefly seeing how PHP grew to become what it is today, read on. If you'd like to touch a piece of Internet history, you can find old releases of PHP in the » PHP Museum.

Ekler
History of PHP
Ekler


History of PHP

PHP Tools, FI, Construction Kit, and PHP/FI

PHP as it's known today is actually the successor to a product named PHP/FI. Created in 1994 by Rasmus Lerdorf, the very first incarnation of PHP was a simple set of Common Gateway Interface (CGI) binaries written in the C programming language. Originally used for tracking visits to his online resume, he named the suite of scripts "Personal Home Page Tools," more frequently referenced as "PHP Tools." Over time, more functionality was desired, and Rasmus rewrote PHP Tools, producing a much larger and richer implementation. This new model was capable of database interaction and more, providing a framework upon which users could develop simple dynamic web applications such as guestbooks. In June of 1995, Rasmus » released the source code for PHP Tools to the public, which allowed developers to use it as they saw fit. This also permitted - and encouraged - users to provide fixes for bugs in the code, and to generally improve upon it.

In September of that year, Rasmus expanded upon PHP and - for a short time - actually dropped the PHP name. Now referring to the tools as FI (short for "Forms Interpreter"), the new implementation included some of the basic functionality of PHP as we know it today. It had Perl-like variables, automatic interpretation of form variables, and HTML embedded syntax. The syntax itself was similar to that of Perl, albeit much more limited, simple, and somewhat inconsistent. In fact, to embed the code into an HTML file, developers had to use HTML comments. Though this method was not entirely well-received, FI continued to enjoy growth and acceptance as a CGI tool --- but still not quite as a language. However, this began to change the following month; in October, 1995, Rasmus released a complete rewrite of the code. Bringing back the PHP name, it was now (briefly) named "Personal Home Page Construction Kit," and was the first release to boast what was, at the time, considered an advanced scripting interface. The language was deliberately designed to resemble C in structure, making it an easy adoption for developers familiar with C, Perl, and similar languages. Having been thus far limited to UNIX and POSIX-compliant systems, the potential for a Windows NT implementation was being explored.

The code got another complete makeover, and in April of 1996, combining the names of past releases, Rasmus introduced PHP/FI. This second-generation implementation began to truly evolve PHP from a suite of tools into a programming language in its own right. It included built-in support for DBM, mSQL, and Postgres95 databases, cookies, user-defined function support, and much more. That June, PHP/FI was given a version 2.0 status. An interesting fact about this, however, is that there was only one single full version of PHP 2.0. When it finally graduated from beta status in November, 1997, the underlying parsing engine was already being entirely rewritten.

Though it lived a short development life, it continued to enjoy a growing popularity in still-young world of web development. In 1997 and 1998, PHP/FI had a cult of several thousand users around the world. A Netcraft survey as of May, 1998, indicated that nearly 60,000 domains reported having headers containing "PHP", indicating that the host server did indeed have it installed. This number equated to approximately 1% of all domains on the Internet at the time. Despite these impressive figures, the maturation of PHP/FI was doomed to limitations; while there were several minor contributors, it was still primarily developed by an individual.

Örnek 1 Example PHP/FI Code

<!--include /text/header.html-->

<!--getenv HTTP_USER_AGENT-->
<!--ifsubstr $exec_result Mozilla-->
  Hey, you are using Netscape!<p>
<!--endif-->

<!--sql database select * from table where user='$username'-->
<!--ifless $numentries 1-->
  Sorry, that record does not exist<p>
<!--endif exit-->
  Welcome <!--$user-->!<p>
  You have <!--$index:0--> credits left in your account.<p>

<!--include /text/footer.html-->

PHP 3

PHP 3.0 was the first version that closely resembles PHP as it exists today. Finding PHP/FI 2.0 still inefficient and lacking features they needed to power an eCommerce application they were developing for a university project, Andi Gutmans and Zeev Suraski of Tel Aviv, Israel, began yet another complete rewrite of the underlying parser in 1997. Approaching Rasmus online, they discussed various aspects of the current implementation and their redevelopment of PHP. In an effort to improve the engine and start building upon PHP/FI's existing user base, Andi, Rasmus, and Zeev decided to collaborate in the development of a new, independent programming language. This entirely new language was released under a new name, that removed the implication of limited personal use that the PHP/FI 2.0 name held. It was renamed simply 'PHP', with the meaning becoming a recursive acronym - PHP: Hypertext Preprocessor.

One of the biggest strengths of PHP 3.0 was its strong extensibility features. In addition to providing end users with a mature interface for multiple databases, protocols, and APIs, the ease of extending the language itself attracted dozens of developers who submitted a variety of modules. Arguably, this was the key to PHP 3.0's tremendous success. Other key features introduced in PHP 3.0 included object-oriented programming support and a far more powerful and consistent language syntax.

In June, 1998, with many new developers from around the world joining the effort, PHP 3.0 was announced by the new PHP Development Team as the official successor to PHP/FI 2.0. Active development of PHP/FI 2.0, which had all-but ceased as of November of the previous year, was now officially ended. After roughly nine months of open public testing, when the announcement of the official release of PHP 3.0 came, it was already installed on over 70,000 domains around the world, and was no longer limited to POSIX-compliant operating systems. A relatively small share of the domains reporting PHP as installed were hosted on servers running Windows 95, 98, and NT, and Macintosh. At its peak, PHP 3.0 was installed on approximately 10% of the web servers on the Internet.

PHP 4

By the winter of 1998, shortly after PHP 3.0 was officially released, Andi Gutmans and Zeev Suraski had begun working on a rewrite of PHP's core. The design goals were to improve performance of complex applications, and improve the modularity of PHP's code base. Such applications were made possible by PHP 3.0's new features and support for a wide variety of third party databases and APIs, but PHP 3.0 was not designed to handle such complex applications efficiently.

The new engine, dubbed 'Zend Engine' (comprised of their first names, Zeev and Andi), met these design goals successfully, and was first introduced in mid 1999. PHP 4.0, based on this engine, and coupled with a wide range of additional new features, was officially released in May 2000, almost two years after its predecessor. In addition to the highly improved performance of this version, PHP 4.0 included other key features such as support for many more web servers, HTTP sessions, output buffering, more secure ways of handling user input and several new language constructs.

PHP 5

PHP 5 was released in July 2004 after long development and several pre-releases. It is mainly driven by its core, the Zend Engine 2.0 with a new object model and dozens of other new features.

PHP's development team includes dozens of developers, as well as dozens others working on PHP-related and supporting projects, such as PEAR, PECL, and documentation, and an underlying network infrastructure of well over one-hundred individual web servers on six of the seven continents of the world. Though only an estimate based upon statistics from previous years, it is safe to presume PHP is now installed on tens or even perhaps hundreds of millions of domains around the world.

History of PHP and Related Projects
History of PHP related projects
History of PHP and Related Projects


History of PHP related projects

PEAR

» PEAR, the PHP Extension and Application Repository (originally, PHP Extension and Add-on Repository) is PHP's version of foundation classes, and may grow in the future to be one of the key ways to distribute PHP extensions among developers.

PEAR was born in discussions held in the PHP Developers' Meeting (PDM) held in January 2000 in Tel Aviv. It was created by Stig S. Bakken, and is dedicated to his first-born daughter, Malin Bakken.

Since early 2000, PEAR has grown to be a big, significant project with a large number of developers working on implementing common, reusable functionality for the benefit of the entire PHP community. PEAR today includes a wide variety of infrastructure foundation classes for database access, content caching, mathematical calculations, eCommerce and much more.

More information about PEAR can be found in » the manual.

PHP Quality Assurance Initiative

The » PHP Quality Assurance Initiative was set up in the summer of 2000 in response to criticism that PHP releases were not being tested well enough for production environments. The team now consists of a core group of developers with a good understanding of the PHP code base. These developers spend a lot of their time localizing and fixing bugs within PHP. In addition there are many other team members who test and provide feedback on these fixes using a wide variety of platforms.

PHP-GTK

» PHP-GTK is the PHP solution for writing client side GUI applications. Andrei Zmievski remembers the planing and creation process of PHP-GTK:

GUI programming has always been of my interests, and I found that Gtk+ is a very nice toolkit, except that programming with it in C is somewhat tedious. After witnessing PyGtk and GTK-Perl implementations, I decided to see if PHP could be made to interface with Gtk+, even minimally. Starting in August of 2000, I began to have a bit more free time so that is when I started experimenting. My main guideline was the PyGtk implementation as it was fairly feature complete and had a nice object-oriented interface. James Henstridge, the author of PyGtk, provided very helpful advice during those initial stages.

Hand-writing the interfaces to all the Gtk+ functions was out of the question, so I seized upon the idea of code-generator, similar to how PyGtk did it. The code generator is a PHP program that reads a set of .defs file containing the Gtk+ classes, constants, and methods information and generates C code that interfaces PHP with them. What cannot be generated automatically can be written by hand in .overrides file.

Working on the code generator and the infrastructure took some time, because I could spend little time on PHP-GTK during the fall of 2000. After I showed PHP-GTK to Frank Kromann, he got interested and started helping me out with code generator work and Win32 implementation. When we wrote the first Hello World program and fired it up, it was extremely exciting. It took a couple more months to get the project to a presentable condition and the initial version was released on March 1, 2001. The story promptly hit SlashDot.

Sensing that PHP-GTK might be extensive, I set up separate mailing lists and CVS repositories for it, as well as the gtk.php.net website with the help of Colin Viebrock. The documentation would also need to be done and James Moore came in to help with that.

Since its release PHP-GTK has been gaining popularity. We have our own documentation team, the manual keeps improving, people start writing extensions for PHP-GTK, and more and more exciting applications with it.

History of PHP
Books about PHP
History of PHP and Related Projects


Books about PHP

As PHP grew, it began to be recognized as a world-wide popular development platform. One of the most interesting ways of seeing this trend was by observing the books about PHP that came out throughout the years.

To the best of our knowledge, the first book dedicated to PHP was 'PHP - tvorba interaktivních internetovych aplikací' (PHP - Creating Interactive Internet Applications) - a Czech book published in April 1999, authored by Jirka Kosek. Next month followed a German book authored by Egon Schmid, Christian Cartus and Richard Blume. The first book in English about PHP was published shortly afterwards, and was 'Core PHP Programming' by Leon Atkinson. These books covered PHP 3.0.

While these books were the first of their kind - they were followed by a large number of books from a host of authors and publishers. There are over 400 books in English, over 100 books in German, and over 50 books in French or Spanish! In addition, you can find books about PHP in many other languages, including Korean, Japanese and Hebrew.

Clearly, this large number of books, written by different authors, published by many publishers, and their availability in so many languages - are a strong testimony for PHP's world-wide success.

History of PHP related projects
Publications about PHP
History of PHP and Related Projects


Publications about PHP

To the best of our knowledge, the first article about PHP in a hard-copy magazine was published in the Czech mutation of Computerworld in the spring of 1998, and covered PHP 3.0. As with books, this was the first in a series of many articles published about PHP in various prominent magazines.

Articles about PHP appeared in Dr. Dobbs, Linux Enterprise, Linux Magazine and many more. Articles about migrating ASP-based applications to PHP under Windows even appear on Microsoft's very own MSDN!

Books about PHP
Migrating from PHP 7.0.x to PHP 7.1.x
History of PHP and Related Projects


Migrating from PHP 7.0.x to PHP 7.1.x

İçindekiler

  • New features
  • New functions
  • New global constants
  • Backward incompatible changes
  • Deprecated features in PHP 7.1.x
  • Changed functions
  • Other changes
  • Windows Support

This new minor version brings with it a number of new features and a few incompatibilities that should be tested for before switching PHP versions in production environments.

Ayrıca, şu PHP sürümleri arasında geçiş kılavuzlarına da bakınız: 5.0.x, 5.1.x, 5.2.x, 5.3.x, 5.4.x, 5.5.x, 5.6.x and 7.0.x.

Publications about PHP
New features
Ekler


New features

Nullable types

Type declarations for parameters and return values can now be marked as nullable by prefixing the type name with a question mark. This signifies that as well as the specified type, null can be passed as an argument, or returned as a value, respectively.

<?php

function testReturn(): ?string
{
    return 'elePHPant';
}

var_dump(testReturn());

function testReturn(): ?string
{
    return null;
}

var_dump(testReturn());

function test(?string $name)
{
    var_dump($name);
}

test('elePHPant');
test(null);
test();

Yukarıdaki örneğin çıktısı:

string(10) "elePHPant"
NULL
string(10) "elePHPant"
NULL
Uncaught Error: Too few arguments to function test(), 0 passed in...

Void functions

A void return type has been introduced. Functions declared with void as their return type must either omit their return statement altogether, or use an empty return statement. null is not a valid return value for a void function.

<?php
function swap(&$left, &$right): void
{
    if ($left === $right) {
        return;
    }

    $tmp = $left;
    $left = $right;
    $right = $tmp;
}

$a = 1;
$b = 2;
var_dump(swap($a, $b), $a, $b);

Yukarıdaki örneğin çıktısı:

null
int(2)
int(1)

Attempting to use a void function's return value simply evaluates to null, with no warnings emitted. The reason for this is because warnings would implicate the use of generic higher order functions.

Symmetric array destructuring

The shorthand array syntax ([]) may now be used to destructure arrays for assignments (including within foreach), as an alternative to the existing list() syntax, which is still supported.

<?php
$data = [
    [1, 'Tom'],
    [2, 'Fred'],
];

// list() style
list($id1, $name1) = $data[0];

// [] style
[$id1, $name1] = $data[0];

// list() style
foreach ($data as list($id, $name)) {
    // logic here with $id and $name
}

// [] style
foreach ($data as [$id, $name]) {
    // logic here with $id and $name
}

Class constant visibility

Support for specifying the visibility of class constants has been added.

<?php
class ConstDemo
{
    const PUBLIC_CONST_A = 1;
    public const PUBLIC_CONST_B = 2;
    protected const PROTECTED_CONST = 3;
    private const PRIVATE_CONST = 4;
}

iterable pseudo-type

A new pseudo-type (similar to callable) called iterable has been introduced. It may be used in parameter and return types, where it accepts either arrays or objects that implement the Traversable interface. With respect to subtyping, parameter types of child classes may broaden a parent's declaration of array or Traversable to iterable. With return types, child classes may narrow a parent's return type of iterable to array or an object that implements Traversable.

<?php
function iterator(iterable $iter)
{
    foreach ($iter as $val) {
        //
    }
}

Multi catch exception handling

Multiple exceptions per catch block may now be specified using the pipe character (|). This is useful for when different exceptions from different class hierarchies are handled the same.

<?php
try {
    // some code
} catch (FirstException | SecondException $e) {
    // handle first and second exceptions
}

Support for keys in list()

You can now specify keys in list(), or its new shorthand [] syntax. This enables destructuring of arrays with non-integer or non-sequential keys.

<?php
$data = [
    ["id" => 1, "name" => 'Tom'],
    ["id" => 2, "name" => 'Fred'],
];

// list() style
list("id" => $id1, "name" => $name1) = $data[0];

// [] style
["id" => $id1, "name" => $name1] = $data[0];

// list() style
foreach ($data as list("id" => $id, "name" => $name)) {
    // logic here with $id and $name
}

// [] style
foreach ($data as ["id" => $id, "name" => $name]) {
    // logic here with $id and $name
}

Support for negative string offsets

Support for negative string offsets has been added to the string manipulation functions accepting offsets, as well as to string indexing with [] or {}. In such cases, a negative offset is interpreted as being an offset from the end of the string.

<?php
var_dump("abcdef"[-2]);
var_dump(strpos("aabbcc", "b", -3));

Yukarıdaki örneğin çıktısı:

string (1) "e"
int(3)

Negative string and array offsets are now also supported in the simple variable parsing syntax inside of strings.

<?php
$string = 'bar';
echo "The last character of '$string' is '$string[-1]'.\n";
?>

Yukarıdaki örneğin çıktısı:

The last character of 'bar' is 'r'.

Support for AEAD in ext/openssl

Support for AEAD (modes GCM and CCM) have been added by extending the openssl_encrypt() and openssl_decrypt() functions with additional parameters.

Convert callables to Closures with Closure::fromCallable()

A new static method has been introduced to the Closure class to allow for callables to be easily converted into Closure objects.

<?php
class Test
{
    public function exposeFunction()
    {
        return Closure::fromCallable([$this, 'privateFunction']);
    }

    private function privateFunction($param)
    {
        var_dump($param);
    }
}

$privFunc = (new Test)->exposeFunction();
$privFunc('some value');

Yukarıdaki örneğin çıktısı:

string(10) "some value"

Asynchronous signal handling

A new function called pcntl_async_signals() has been introduced to enable asynchronous signal handling without using ticks (which introduce a lot of overhead).

<?php
pcntl_async_signals(true); // turn on async signals

pcntl_signal(SIGHUP,  function($sig) {
    echo "SIGHUP\n";
});

posix_kill(posix_getpid(), SIGHUP);

Yukarıdaki örneğin çıktısı:

SIGHUP

HTTP/2 server push support in ext/curl

Support for server push has been added to the CURL extension (requires version 7.46 and above). This can be leveraged through the curl_multi_setopt() function with the new CURLMOPT_PUSHFUNCTION constant. The constants CURL_PUSH_OK and CURL_PUSH_DENY have also been added so that the execution of the server push callback can either be approved or denied.

Migrating from PHP 7.0.x to PHP 7.1.x
New functions
Migrating from PHP 7.0.x to PHP 7.1.x


New functions

PHP Core

  • sapi_windows_cp_get()
  • sapi_windows_cp_set()
  • sapi_windows_cp_conv()
  • sapi_windows_cp_is_utf8()

Closure

  • Closure::fromCallable()

CURL

  • curl_multi_errno()
  • curl_share_errno()
  • curl_share_strerror()

Session

  • session_create_id()
  • session_gc()

SPL

  • is_iterable()

PCNTL

  • pcntl_async_signals()
  • pcntl_signal_get_handler()
New features
New global constants
Migrating from PHP 7.0.x to PHP 7.1.x


New global constants

Core Predefined Constants

  • PHP_FD_SETSIZE

CURL

  • CURLMOPT_PUSHFUNCTION
  • CURL_PUSH_OK
  • CURL_PUSH_DENY

Data Filtering

  • FILTER_FLAG_EMAIL_UNICODE

Image Processing and GD

  • IMAGETYPE_WEBP

JSON

  • JSON_UNESCAPED_LINE_TERMINATORS

LDAP

  • LDAP_OPT_X_SASL_NOCANON
  • LDAP_OPT_X_SASL_USERNAME
  • LDAP_OPT_X_TLS_CACERTDIR
  • LDAP_OPT_X_TLS_CACERTFILE
  • LDAP_OPT_X_TLS_CERTFILE
  • LDAP_OPT_X_TLS_CIPHER_SUITE
  • LDAP_OPT_X_TLS_KEYFILE
  • LDAP_OPT_X_TLS_RANDOM_FILE
  • LDAP_OPT_X_TLS_CRLCHECK
  • LDAP_OPT_X_TLS_CRL_NONE
  • LDAP_OPT_X_TLS_CRL_PEER
  • LDAP_OPT_X_TLS_CRL_ALL
  • LDAP_OPT_X_TLS_DHFILE
  • LDAP_OPT_X_TLS_CRLFILE
  • LDAP_OPT_X_TLS_PROTOCOL_MIN
  • LDAP_OPT_X_TLS_PROTOCOL_SSL2
  • LDAP_OPT_X_TLS_PROTOCOL_SSL3
  • LDAP_OPT_X_TLS_PROTOCOL_TLS1_0
  • LDAP_OPT_X_TLS_PROTOCOL_TLS1_1
  • LDAP_OPT_X_TLS_PROTOCOL_TLS1_2
  • LDAP_OPT_X_TLS_PACKAGE
  • LDAP_OPT_X_KEEPALIVE_IDLE
  • LDAP_OPT_X_KEEPALIVE_PROBES
  • LDAP_OPT_X_KEEPALIVE_INTERVAL

PostgreSQL

  • PGSQL_NOTICE_LAST
  • PGSQL_NOTICE_ALL
  • PGSQL_NOTICE_CLEAR

SPL

  • MT_RAND_PHP
New functions
Backward incompatible changes
Migrating from PHP 7.0.x to PHP 7.1.x


Backward incompatible changes

Throw on passing too few function arguments

Previously, a warning would be emitted for invoking user-defined functions with too few arguments. Now, this warning has been promoted to an Error exception. This change only applies to user-defined functions, not internal functions. For example:

<?php
function test($param){}
test();

Yukarıdaki örnek şuna benzer bir çıktı üretir:

Fatal error: Uncaught ArgumentCountError: Too few arguments to function test(), 0 passed in %s on line %d and exactly 1 expected in %s:%d

Forbid dynamic calls to scope introspection functions

Dynamic calls for certain functions have been forbidden (in the form of $func() or array_map('extract', ...), etc). These functions either inspect or modify another scope, and present with them ambiguous and unreliable behavior. The functions are as follows:

  • assert() - with a string as the first argument
  • compact()
  • extract()
  • func_get_args()
  • func_get_arg()
  • func_num_args()
  • get_defined_vars()
  • mb_parse_str() - with one arg
  • parse_str() - with one arg
<?php
(function () {
    $func = 'func_num_args';
    $func();
})();

Yukarıdaki örneğin çıktısı:

Warning: Cannot call func_num_args() dynamically in %s on line %d

Invalid class, interface, and trait names

The following names cannot be used to name classes, interfaces, or traits:

  • void
  • iterable

Numerical string conversions now respect scientific notation

Integer operations and conversions on numerical strings now respect scientific notation. This also includes the (int) cast operation, and the following functions: intval() (where the base is 10), settype(), decbin(), decoct(), and dechex().

Fixes to mt_rand() algorithm

mt_rand() will now default to using the fixed version of the Mersenne Twister algorithm. If deterministic output from mt_srand() was relied upon, then the MT_RAND_PHP with the ability to preserve the old (incorrect) implementation via an additional optional second parameter to mt_srand().

rand() aliased to mt_rand() and srand() aliased to mt_srand()

rand() and srand() have now been made aliases to mt_rand() and mt_srand(), respectively. This means that the output for the following functions have changes: rand(), shuffle(), str_shuffle(), and array_rand().

Disallow the ASCII delete control character in identifiers

The ASCII delete control character (0x7F) can no longer be used in identifiers that are not quoted.

error_log changes with syslog value

If the error_log ini setting is set to syslog, the PHP error levels are mapped to the syslog error levels. This brings finer differentiation in the error logs in contrary to the previous approach where all the errors are logged with the notice level only.

Do not call destructors on incomplete objects

Destructors are now never called for objects that throw an exception during the execution of their constructor. In previous versions this behavior depended on whether the object was referenced outside the construcor (e.g. by an exception backtrace).

call_user_func() handling of reference arguments

call_user_func() will now always generate a warning upon calls to functions that expect references as arguments. Previously this depended on whether the call was fully qualified.

Additionally, call_user_func() and call_user_func_array() will no longer abort the function call in this case. The "expected reference" warning will be emitted, but the call will proceed as usual.

The empty index operator is not supported for strings anymore

Applying the empty index operator to a string (e.g. $str[] = $x) throws a fatal error instead of converting silently to array.

Removed ini directives

The following ini directives have been removed:

  • session.entropy_file
  • session.entropy_length
  • session.hash_function
  • session.hash_bits_per_character

Array ordering when elements are automatically created during by reference assignments has changed

The order of the elements in an array has changed when those elements have been automatically created by referencing them in a by reference assignment. For example:

<?php
$array = [];
$array["a"] =& $array["b"];
$array["b"] = 1;
var_dump($array);
?>

Output of the above example in PHP 7.0:

array(2) {
  ["a"]=>
  &int(1)
  ["b"]=>
  &int(1)
}

Output of the above example in PHP 7.1:

array(2) {
  ["b"]=>
  &int(1)
  ["a"]=>
  &int(1)
}

Sort order of equal elements

The internal sorting algorithm has been improved, what may result in different sort order of elements, which compare as equal, than before.

Bilginize:

Don't rely on the order of elements which compare as equal; it might change anytime.

Error message for E_RECOVERABLE errors

The error message for E_RECOVERABLE errors has been changed from "Catchable fatal error" to "Recoverable fatal error".

$options parameter of unserialize()

The allowed_classes element of the $options parameter of unserialize() is now strictly typed, i.e. if anything other than an array or a boolean is given, unserialize() returns FALSE and issues an E_WARNING.

DateTime constructor incorporates microseconds

DateTime and DateTimeImmutable now properly incorporate microseconds when constructed from the current time, either explicitly or with a relative string (e.g. "first day of next month"). This means that naive comparisons of two newly created instances will now more likely return FALSE instead of TRUE:

<?php
new DateTime() == new DateTime();
?>

Fatal errors to Error exceptions conversions

In the Date extension, invalid serialization data for DateTime or DatePeriod classes, or timezone initialization failure from serialized data, will now throw an Error exception from the __wakeup() or __set_state() methods, instead of resulting in a fatal error.

In the DBA extension, data modification functions (such as dba_insert()) will now throw an Error exception instead of triggering a catchable fatal error if the key does not contain exactly two elements.

In the DOM extension, invalid schema or RelaxNG validation contexts will now throw an Error exception instead of resulting in a fatal error. Similarly, attempting to register a node class that does not extend the appropriate base class, or attempting to read an invalid property or write to a readonly property, will also now throw an Error exception.

In the IMAP extension, email addresses longer than 16385 bytes will throw an Error exception instead of resulting in a fatal error.

In the Intl extension, failing to call the parent constructor in a class extending Collator before invoking the parent methods will now throw an Error instead of resulting in a recoverable fatal error. Also, cloning a Transliterator object will now throw an Error exception on failure to clone the internal transliterator instead of resulting in a fatal error.

In the LDAP extension, providing an unknown modification type to ldap_batch_modify() will now throw an Error exception instead of resulting in a fatal error.

In the mbstring extension, the mb_ereg() and mb_eregi() functions will now throw a ParseError exception if an invalid PHP expression is provided and the 'e' option is used.

In the Mcrypt extension, the mcrypt_encrypt() and mcrypt_decrypt() will now throw an Error exception instead of resulting in a fatal error if mcrypt cannot be initialized.

In the mysqli extension, attempting to read an invalid property or write to a readonly property will now throw an Error exception instead of resulting in a fatal error.

In the Reflection extension, failing to retrieve a reflection object or retrieve an object property will now throw an Error exception instead of resulting in a fatal error.

In the Session extension, custom session handlers that do not return strings for session IDs will now throw an Error exception instead of resulting in a fatal error when a function is called that must generate a session ID.

In the SimpleXML extension, creating an unnamed or duplicate attribute will now throw an Error exception instead of resulting in a fatal error.

In the SPL extension, attempting to clone an SplDirectory object will now throw an Error exception instead of resulting in a fatal error. Similarly, calling ArrayIterator::append() when iterating over an object will also now throw an Error exception.

In the standard extension, the assert() function, when provided with a string argument as its first parameter, will now throw a ParseError exception instead of resulting in a catchable fatal error if the PHP code is invalid. Similarly, calling forward_static_call() outside of a class scope will now throw an Error exception.

In the Tidy extension, creating a tidyNode manually will now throw an Error exception instead of resulting in a fatal error.

In the WDDX extension, a circular reference when serializing will now throw an Error exception instead of resulting in a fatal error.

In the XML-RPC extension, a circular reference when serializing will now throw an instance of Error exception instead of resulting in a fatal error.

In the Zip extension, the ZipArchive::addGlob() method will now throw an Error exception instead of resulting in a fatal error if glob support is not available.

Lexically bound variables cannot reuse names

Variables bound to a closure via the use construct cannot use the same name as any süper küreseller, $this, or any parameter. For example, all of these function definition will result in a fatal error:

<?php
$f = function () use ($_SERVER) {};
$f = function () use ($this) {};
$f = function ($param) use ($param) {};

JSON encoding and decoding

The serialize_precision ini setting now controls the serialization precision when encoding doubles.

Decoding an empty key now results in an empty property name, rather than _empty_ as a property name.

<?php
var_dump(json_decode(json_encode(['' => 1])));

Yukarıdaki örnek şuna benzer bir çıktı üretir:

object(stdClass)#1 (1) {
  [""]=>
  int(1)
}

When supplying the JSON_UNESCAPED_UNICODE flag to json_encode(), the sequences U+2028 and U+2029 are now escaped.

Changes to mb_ereg() and mb_eregi() parameter semantics

The third paramter to the mb_ereg() and mb_eregi() functions (regs) will now be set to an empty array if nothing was matched. Formely, the parameter would not have been modified.

Drop support for the sslv2 stream

The sslv2 stream has now been dropped in OpenSSL.

New global constants
Deprecated features in PHP 7.1.x
Migrating from PHP 7.0.x to PHP 7.1.x


Deprecated features in PHP 7.1.x

ext/mcrypt

The mcrypt extension has been abandonware for nearly a decade now, and was also fairly complex to use. It has therefore been deprecated in favour of OpenSSL, where it will be removed from the core and into PECL in PHP 7.2.

Eval option for mb_ereg_replace() and mb_eregi_replace()

The e pattern modifier has been deprecated for the mb_ereg_replace() and mb_eregi_replace() functions.

Backward incompatible changes
Changed functions
Migrating from PHP 7.0.x to PHP 7.1.x


Changed functions

PHP Core

  • getopt() has an optional third parameter that exposes the index of the next element in the argument vector list to be processed. This is done via a by-ref parameter.
  • getenv() no longer requires its parameter. If the parameter is omitted, then the current environment variables will be returned as an associative array.
  • get_headers() now has an additional parameter to enable for the passing of custom stream contexts.
  • long2ip() now also accepts an integer as a parameter.
  • output_reset_rewrite_vars() no longer resets session URL rewrite variables.
  • parse_url() is now more restrictive and supports RFC3986.
  • unpack() now accepts an optional third parameter to specify the offset to begin unpacking from.

File System

  • file_get_contents() now accepts a negative seek offset if the stream is seekable.
  • tempnam() now emits a notice when falling back to the system's temp directory.

JSON

  • json_encode() now accepts a new option, JSON_UNESCAPED_LINE_TERMINATORS, to disable the escaping of U+2028 and U+2029 characters when JSON_UNESCAPED_UNICODE is supplied.

Multibyte String

  • mb_ereg() now rejects illegal byte sequences.
  • mb_ereg_replace() now rejects illegal byte sequences.

PDO

  • PDO::lastInsertId() for PostgreSQL will now trigger an error when nextval has not been called for the current session (the postgres connection).

PostgreSQL

  • pg_last_notice() now accepts an optional parameter to specify an operation. This can be done with one of the following new constants: PGSQL_NOTICE_LAST, PGSQL_NOTICE_ALL, or PGSQL_NOTICE_CLEAR.
  • pg_fetch_all() now accepts an optional second parameter to specify the result type (similar to the third parameter of pg_fetch_array()).
  • pg_select() now accepts an optional fourth parameter to specify the result type (similar to the third parameter of pg_fetch_array()).
Deprecated features in PHP 7.1.x
Other changes
Migrating from PHP 7.0.x to PHP 7.1.x


Other changes

Notices and warnings on arithmetic with invalid strings

New E_WARNING and E_NOTICE errors have been introduced when invalid strings are coerced using operators expecting numbers (+ - * / ** % << >> | & ^) or their assignment equivalents. An E_NOTICE is emitted when the string begins with a numeric value but contains trailing non-numeric characters, and an E_WARNING is emitted when the string does not contain a numeric value.

<?php
'1b' + 'something';

Yukarıdaki örneğin çıktısı:

Notice: A non well formed numeric value encountered in %s on line %d
Warning: A non-numeric value encountered in %s on line %d

Warn on octal escape sequence overflow

Previously, 3-octet octal string escape sequences would overflow silently. Now, they will still overflow, but E_WARNING will be emitted.

<?php
var_dump("\500");

Yukarıdaki örneğin çıktısı:

Warning: Octal escape sequence overflow \500 is greater than \377 in %s on line %d
string(1) "@"

Inconsistency fixes to $this

Whilst $this is considered a special variable in PHP, it lacked proper checks to ensure it wasn't used as a variable name or reassigned. This has now been rectified to ensure that $this cannot be a user-defined variable, reassigned to a different value, or be globalised.

Session ID generation without hashing

Session IDs will no longer be hashed upon generation. With this change brings about the removal of the following four ini settings:

  • session.entropy_file
  • session.entropy_length
  • session.hash_function
  • session.hash_bits_per_character

And the addition of the following two ini settings:

  • session.sid_length - defines the length of the session ID, defaulting to 32 characters for backwards compatibility)
  • session.sid_bits_per_character - defines the number of bits to be stored per character (i.e. increases the range of characters that can be used in the session ID), defaulting to 4 for backwards compatibility

Changes to INI file handling

precision

If the value is set to -1, then the dtoa mode 0 is used. The default value is still 14.

serialize_precision

If the value is set to -1, then the dtoa mode 0 is used. The value -1 is now used by default.

gd.jpeg_ignore_warning

The default of this php.ini setting has been changed to 1, so by default libjpeg warnings are ignored.

Session ID generation with a CSPRNG only

Session IDs will now only be generated with a CSPRNG.

More informative TypeError messages when NULL is allowed

TypeError exceptions for arg_info type checks will now provide more informative error messages. If the parameter type or return type accepts NULL (by either having a default value of NULL or being a nullable type), then the error message will now mention this with a message of "must be ... or null" or "must ... or be null."

Changed functions
Windows Support
Migrating from PHP 7.0.x to PHP 7.1.x


Windows Support

readline

The readline extension is supported through the » WinEditLine library. Thereby, the interactive CLI shell is supported as well (php.exe -a).

Other changes
Migrating from PHP 5.6.x to PHP 7.0.x
Migrating from PHP 7.0.x to PHP 7.1.x


Migrating from PHP 5.6.x to PHP 7.0.x

İçindekiler

  • Backward incompatible changes
  • New features
  • Deprecated features in PHP 7.0.x
  • Changed functions
  • New functions
  • New Classes and Interfaces
  • New Global Constants
  • Changes in SAPI Modules
  • Removed Extensions and SAPIs
  • Other Changes

Despite the fact that PHP 7.0 is a new major version, efforts have been made to make migration as painless as possible. This release focuses mainly on removing functionality deprecated in previous versions and improving language consistency.

There are a few incompatibilities and new features that should be considered, and code should be tested before switching PHP versions in production environments.

Ayrıca, şu PHP sürümleri arasında geçiş kılavuzlarına da bakınız: 5.0.x, 5.1.x, 5.2.x, 5.3.x, 5.4.x, 5.5.x and 5.6.x.

Windows Support
Backward incompatible changes
Ekler


Backward incompatible changes

Changes to error and exception handling

Many fatal and recoverable fatal errors have been converted to exceptions in PHP 7. These error exceptions inherit from the Error class, which itself implements the Throwable interface (the new base interface all exceptions inherit).

This means that custom error handlers may no longer be triggered because exceptions may be thrown instead (causing new fatal errors for uncaught Error exceptions).

A fuller description of how errors operate in PHP 7 can be found on the PHP 7 errors page. This migration guide will merely enumerate the changes that affect backward compatibility.

set_exception_handler() is no longer guaranteed to receive Exception objects

Code that implements an exception handler registered with set_exception_handler() using a type declaration of Exception will cause a fatal error when an Error object is thrown.

If the handler needs to work on both PHP 5 and 7, you should remove the type declaration from the handler, while code that is being migrated to work on PHP 7 exclusively can simply replace the Exception type declaration with Throwable instead.

<?php
// PHP 5 era code that will break.
function handler(Exception $e) { ... }
set_exception_handler('handler');

// PHP 5 and 7 compatible.
function handler($e) { ... }

// PHP 7 only.
function handler(Throwable $e) { ... }
?>

Internal constructors always throw exceptions on failure

Previously, some internal classes would return NULL or an unusable object when the constructor failed. All internal classes will now throw an Exception in this case in the same way that user classes already had to.

Parse errors throw ParseError

Parser errors now throw a ParseError object. Error handling for eval() should now include a catch block that can handle this error.

E_STRICT notices severity changes

All of the E_STRICT notices have been reclassified to other levels. E_STRICT constant is retained, so calls like error_reporting(E_ALL|E_STRICT) will not cause an error.

E_STRICT notices severity changes
Situation | New level/behaviour
Indexing by a resource | E_NOTICE
Abstract static methods | Notice removed, triggers no error
"Redefining" a constructor | Notice removed, triggers no error
Signature mismatch during inheritance | E_WARNING
Same (compatible) property in two used traits | Notice removed, triggers no error
Accessing static property non-statically | E_NOTICE
Only variables should be assigned by reference | E_NOTICE
Only variables should be passed by reference | E_NOTICE
Calling non-static methods statically | E_DEPRECATED

Changes to variable handling

PHP 7 now uses an abstract syntax tree when parsing source files. This has permitted many improvements to the language which were previously impossible due to limitations in the parser used in earlier versions of PHP, but has resulted in the removal of a few special cases for consistency reasons, which has resulted in backward compatibility breaks. These cases are detailed in this section.

Changes to the handling of indirect variables, properties, and methods

Indirect access to variables, properties, and methods will now be evaluated strictly in left-to-right order, as opposed to the previous mix of special cases. The table below shows how the order of evaluation has changed.

Old and new evaluation of indirect expressions
Expression | PHP 5 interpretation | PHP 7 interpretation
$$foo['bar']['baz'] | ${$foo['bar']['baz']} | ($$foo)['bar']['baz']
$foo->$bar['baz'] | $foo->{$bar['baz']} | ($foo->$bar)['baz']
$foo->$bar['baz']() | $foo->{$bar['baz']}() | ($foo->$bar)['baz']()
Foo::$bar['baz']() | Foo::{$bar['baz']}() | (Foo::$bar)['baz']()

Code that used the old right-to-left evaluation order must be rewritten to explicitly use that evaluation order with curly braces (see the above middle column). This will make the code both forwards compatible with PHP 7.x and backwards compatible with PHP 5.x.

Changes to list() handling

list() no longer assigns variables in reverse order

list() will now assign values to variables in the order they are defined, rather than reverse order. In general, this only affects the case where list() is being used in conjunction with the array [] operator, as shown below:

<?php
list($a[], $a[], $a[]) = [1, 2, 3];
var_dump($a);
?>

Yukarıdaki örneğin PHP 5 çıktısı:

array(3) {
  [0]=>
  int(3)
  [1]=>
  int(2)
  [2]=>
  int(1)
}

Yukarıdaki örneğin PHP 7 çıktısı:

array(3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  int(3)
}

In general, it is recommended not to rely on the order in which list() assignments occur, as this is an implementation detail that may change again in the future.

Empty list() assignments have been removed

list() constructs can no longer be empty. The following are no longer allowed:

<?php
list() = $a;
list(,,) = $a;
list($x, list(), $y) = $a;
?>
list() cannot unpack strings

list() can no longer unpack string variables. str_split() should be used instead.

Array ordering when elements are automatically created during by reference assignments has changed

The order of the elements in an array has changed when those elements have been automatically created by referencing them in a by reference assignment. For example:

<?php
$array = [];
$array["a"] =& $array["b"];
$array["b"] = 1;
var_dump($array);
?>

Yukarıdaki örneğin PHP 5 çıktısı:

array(2) {
  ["b"]=>
  &int(1)
  ["a"]=>
  &int(1)
}

Yukarıdaki örneğin PHP 7 çıktısı:

array(2) {
  ["a"]=>
  &int(1)
  ["b"]=>
  &int(1)
}

global only accepts simple variables

Variable variables can no longer be used with the global keyword. The curly brace syntax can be used to emulate the previous behaviour if required:

<?php
function f() {
    // Valid in PHP 5 only.
    global $$foo->bar;

    // Valid in PHP 5 and 7.
    global ${$foo->bar};
}
?>

As a general principle, using anything other than a bare variable with global is discouraged.

Parentheses around function arguments no longer affect behaviour

In PHP 5, using redundant parentheses around a function argument could quiet strict standards warnings when the function argument was passed by reference. The warning will now always be issued.

<?php
function getArray() {
    return [1, 2, 3];
}

function squareArray(array &$a) {
    foreach ($a as &$v) {
        $v **= 2;
    }
}

// Generates a warning in PHP 7.
squareArray((getArray()));
?>

Yukarıdaki örneğin çıktısı:

Notice: Only variables should be passed by reference in /tmp/test.php on line 13

Changes to foreach

Minor changes have been made to the behaviour of the foreach control structure, primarily around the handling of the internal array pointer and modification of the array being iterated over.

foreach no longer changes the internal array pointer

Prior to PHP 7, the internal array pointer was modified while an array was being iterated over with foreach. This is no longer the case, as shown in the following example:

<?php
$array = [0, 1, 2];
foreach ($array as &$val) {
    var_dump(current($array));
}
?>

Yukarıdaki örneğin PHP 5 çıktısı:

int(1)
int(2)
bool(false)

Yukarıdaki örneğin PHP 7 çıktısı:

int(0)
int(0)
int(0)

foreach by-value operates on a copy of the array

When used in the default by-value mode, foreach will now operate on a copy of the array being iterated rather than the array itself. This means that changes to the array made during iteration will not affect the values that are iterated.

foreach by-reference has improved iteration behaviour

When iterating by-reference, foreach will now do a better job of tracking changes to the array made during iteration. For example, appending to an array while iterating will now result in the appended values being iterated over as well:

<?php
$array = [0];
foreach ($array as &$val) {
    var_dump($val);
    $array[1] = 1;
}
?>

Yukarıdaki örneğin PHP 5 çıktısı:

int(0)

Yukarıdaki örneğin PHP 7 çıktısı:

int(0)
int(1)

Iteration of non-Traversable objects

Iterating over a non-Traversable object will now have the same behaviour as iterating over by-reference arrays. This results in the improved behaviour when modifying an array during iteration also being applied when properties are added to or removed from the object.

Changes to integer handling

Invalid octal literals

Previously, octal literals that contained invalid numbers were silently truncated (0128 was taken as 012). Now, an invalid octal literal will cause a parse error.

Negative bitshifts

Bitwise shifts by negative numbers will now throw an ArithmeticError:

<?php
var_dump(1 >> -1);
?>

Yukarıdaki örneğin PHP 5 çıktısı:

int(0)

Yukarıdaki örneğin PHP 7 çıktısı:

Fatal error: Uncaught ArithmeticError: Bit shift by negative number in /tmp/test.php:2
Stack trace:
#0 {main}
  thrown in /tmp/test.php on line 2

Out of range bitshifts

Bitwise shifts (in either direction) beyond the bit width of an integer will always result in 0. Previously, the behaviour of such shifts was architecture dependent.

Changes to Division By Zero

Previously, when 0 was used as the divisor for either the divide (/) or modulus (%) operators, an E_WARNING would be emitted and false would be returned. Now, the divide operator returns a float as either +INF, -INF, or NAN, as specified by IEEE 754. The modulus operator E_WARNING has been removed and will throw a DivisionByZeroError exception.

<?php
var_dump(3/0);
var_dump(0/0);
var_dump(0%0);
?>

Yukarıdaki örneğin PHP 5 çıktısı:

Warning: Division by zero in %s on line %d
bool(false)

Warning: Division by zero in %s on line %d
bool(false)

Warning: Division by zero in %s on line %d
bool(false)

Yukarıdaki örneğin PHP 7 çıktısı:

Warning: Division by zero in %s on line %d
float(INF)

Warning: Division by zero in %s on line %d
float(NAN)

PHP Fatal error:  Uncaught DivisionByZeroError: Modulo by zero in %s line %d

Changes to string handling

Hexadecimal strings are no longer considered numeric

Strings containing hexadecimal numbers are no longer considered to be numeric. For example:

<?php
var_dump("0x123" == "291");
var_dump(is_numeric("0x123"));
var_dump("0xe" + "0x1");
var_dump(substr("foo", "0x1"));
?>

Yukarıdaki örneğin PHP 5 çıktısı:

bool(true)
bool(true)
int(15)
string(2) "oo"

Yukarıdaki örneğin PHP 7 çıktısı:

bool(false)
bool(false)
int(0)

Notice: A non well formed numeric value encountered in /tmp/test.php on line 5
string(3) "foo"

filter_var() can be used to check if a string contains a hexadecimal number, and also to convert a string of that type to an integer:

<?php
$str = "0xffff";
$int = filter_var($str, FILTER_VALIDATE_INT, FILTER_FLAG_ALLOW_HEX);
if (false === $int) {
    throw new Exception("Invalid integer!");
}
var_dump($int); // int(65535)
?>

\u{ may cause errors

Due to the addition of the new Unicode codepoint escape syntax, strings containing a literal \u{ followed by an invalid sequence will cause a fatal error. To avoid this, the leading backslash should be escaped.

Removed functions

call_user_method() and call_user_method_array()

These functions were deprecated in PHP 4.1.0 in favour of call_user_func() and call_user_func_array(). You may also want to consider using variable functions and/or the ... operator.

All ereg* functions

All ereg functions were removed. PCRE is a recommended alternative.

mcrypt aliases

The deprecated mcrypt_generic_end() function has been removed in favour of mcrypt_generic_deinit().

Additionally, the deprecated mcrypt_ecb(), mcrypt_cbc(), mcrypt_cfb() and mcrypt_ofb() functions have been removed in favour of using mcrypt_decrypt() with the appropriate MCRYPT_MODE_* constant.

All ext/mysql functions

All ext/mysql functions were removed. For details about choosing a different MySQL API, see Choosing a MySQL API.

All ext/mssql functions

All ext/mssql functions were removed. For a list of alternatives, see the MSSQL Introduction.

intl aliases

The deprecated datefmt_set_timezone_id() and
IntlDateFormatter::setTimeZoneID() aliases have been
removed in favour of datefmt_set_timezone() and
IntlDateFormatter::setTimeZone(), respectively.

set_magic_quotes_runtime()

set_magic_quotes_runtime(), along with its alias magic_quotes_runtime(), have been removed. They were deprecated in PHP 5.3.0, and became effectively non-functional with the removal of magic quotes in PHP 5.4.0.

set_socket_blocking()

The deprecated set_socket_blocking() alias has been removed in favour of stream_set_blocking().

dl() in PHP-FPM

dl() can no longer be used in PHP-FPM. It remains functional in the CLI and embed SAPIs.

GD Type1 functions

Support for PostScript Type1 fonts has been removed from the GD extension, resulting in the removal of the following functions:

  • imagepsbbox()
  • imagepsencodefont()
  • imagepsextendfont()
  • imagepsfreefont()
  • imagepsloadfont()
  • imagepsslantfont()
  • imagepstext()

Using TrueType fonts and their associated functions is recommended instead.

Removed INI directives

Removed features

The following INI directives have been removed as their associated features have also been removed:

  • always_populate_raw_post_data
  • asp_tags

xsl.security_prefs

The xsl.security_prefs directive has been removed. Instead, the XsltProcessor::setSecurityPrefs() method should be called to control the security preferences on a per-processor basis.

Other backward incompatible changes

New objects cannot be assigned by reference

The result of the new statement can no longer be assigned to a variable by reference:

<?php
class C {}
$c =& new C;
?>

Yukarıdaki örneğin PHP 5 çıktısı:

Deprecated: Assigning the return value of new by reference is deprecated in /tmp/test.php on line 3

Yukarıdaki örneğin PHP 7 çıktısı:

Parse error: syntax error, unexpected 'new' (T_NEW) in /tmp/test.php on line 3

Invalid class, interface and trait names

The following names cannot be used to name classes, interfaces or traits:

  • bool
  • int
  • float
  • string
  • NULL
  • TRUE
  • FALSE

Furthermore, the following names should not be used. Although they will not generate an error in PHP 7.0, they are reserved for future use and should be considered deprecated.

  • resource
  • object
  • mixed
  • numeric

ASP and script PHP tags removed

Support for using ASP and script tags to delimit PHP code has been removed. The affected tags are:

Removed ASP and script tags
Opening tag | Closing tag
<% | %>
<%= | %>
<script language="php"> | </script>

Calls from incompatible context removed

Previously deprecated in PHP 5.6, static calls made to a non-static method with an incompatible context will now result in the called method having an undefined $this variable and a deprecation warning being issued.

<?php
class A {
    public function test() { var_dump($this); }
}

// Note: Does NOT extend A
class B {
    public function callNonStaticMethodOfA() { A::test(); }
}

(new B)->callNonStaticMethodOfA();
?>

Yukarıdaki örneğin PHP 5.6 çıktısı:

Deprecated: Non-static method A::test() should not be called statically, assuming $this from incompatible context in /tmp/test.php on line 8
object(B)#1 (0) {
}

Yukarıdaki örneğin PHP 7 çıktısı:

Deprecated: Non-static method A::test() should not be called statically in /tmp/test.php on line 8

Notice: Undefined variable: this in /tmp/test.php on line 3
NULL

yield is now a right associative operator

The yield construct no longer requires parentheses, and has been changed to a right associative operator with precedence between print and =>. This can result in changed behaviour:

<?php
echo yield -1;
// Was previously interpreted as
echo (yield) - 1;
// And is now interpreted as
echo yield (-1);

yield $foo or die;
// Was previously interpreted as
yield ($foo or die);
// And is now interpreted as
(yield $foo) or die;
?>

Parentheses can be used to disambiguate those cases.

Functions cannot have multiple parameters with the same name

It is no longer possible to define two or more function parameters with the same name. For example, the following function will trigger an E_COMPILE_ERROR:

<?php
function foo($a, $b, $unused, $unused) {
    //
}
?>

Functions inspecting arguments report the current parameter value

func_get_arg(), func_get_args(), debug_backtrace() and exception backtraces will no longer report the original value that was passed to a parameter, but will instead provide the current value (which might have been modified).

<?php
function foo($x) {
    $x++;
    var_dump(func_get_arg(0));
}
foo(1);?>

Yukarıdaki örneğin PHP 5 çıktısı:

1

Yukarıdaki örneğin PHP 7 çıktısı:

2

Switch statements cannot have multiple default blocks

It is no longer possible to define two or more default blocks in a switch statement. For example, the following switch statement will trigger an E_COMPILE_ERROR:

<?php
switch (1) {
    default:
    break;
    default:
    break;
}
?>

$HTTP_RAW_POST_DATA removed

$HTTP_RAW_POST_DATA is no longer available. The php://input stream should be used instead.

# comments in INI files removed

Support for prefixing comments with # in INI files has been removed. ; (semi-colon) should be used instead. This change applies to php.ini, as well as files handled by parse_ini_file() and parse_ini_string().

JSON extension replaced with JSOND

The JSON extension has been replaced with JSOND, causing three minor BC breaks. Firstly, a number must not end in a decimal point (i.e. 34. must be changed to either 34.0 or 34). Secondly, when using scientific notation, the e exponent must not immediately follow a decimal point (i.e. 3.e3 must be changed to either 3.0e3 or 3e3). Finally, an empty string is no longer considered valid JSON.

Internal function failure on overflow

Previously, internal functions would silently truncate numbers produced from float-to-integer coercions when the float was too large to represent as an integer. Now, an E_WARNING will be emitted and NULL will be returned.

Fixes to custom session handler return values

Any predicate functions implemented by custom session handlers that return either FALSE or -1 will be fatal errors. If any value from these functions other than a boolean, -1, or 0 is returned, then it will fail and an E_WARNING will be emitted.

Sort order of equal elements

The internal sorting algorithm has been improved, what may result in different sort order of elements, which compare as equal, than before.

Bilginize:

Don't rely on the order of elements which compare as equal; it might change anytime.

Migrating from PHP 5.6.x to PHP 7.0.x
New features
Migrating from PHP 5.6.x to PHP 7.0.x


New features

Scalar type declarations

Scalar type declarations come in two flavours: coercive (default) and strict. The following types for parameters can now be enforced (either coercively or strictly): strings (string), integers (int), floating-point numbers (float), and booleans (bool). They augment the other types introduced in PHP 5: class names, interfaces, array and callable.

<?php
// Coercive mode
function sumOfInts(int ...$ints)
{
    return array_sum($ints);
}

var_dump(sumOfInts(2, '3', 4.1));

Yukarıdaki örneğin çıktısı:

int(9)

To enable strict mode, a single declare directive must be placed at the top of the file. This means that the strictness of typing for scalars is configured on a per-file basis. This directive not only affects the type declarations of parameters, but also a function's return type (see return type declarations, built-in PHP functions, and functions from loaded extensions.

Full documentation and examples of scalar type declarations can be found in the type declaration reference.

Return type declarations

PHP 7 adds support for return type declarations. Similarly to argument type declarations, return type declarations specify the type of the value that will be returned from a function. The same types are available for return type declarations as are available for argument type declarations.

<?php

function arraysSum(array ...$arrays): array
{
    return array_map(function(array $array): int {
        return array_sum($array);
    }, $arrays);
}

print_r(arraysSum([1,2,3], [4,5,6], [7,8,9]));

Yukarıdaki örneğin çıktısı:

Array
(
    [0] => 6
    [1] => 15
    [2] => 24
)

Full documentation and examples of return type declarations can be found in the return type declarations. reference.

Null coalescing operator

The null coalescing operator (??) has been added as syntactic sugar for the common case of needing to use a ternary in conjunction with isset(). It returns its first operand if it exists and is not NULL; otherwise it returns its second operand.

<?php
// Fetches the value of $_GET['user'] and returns 'nobody'
// if it does not exist.
$username = $_GET['user'] ?? 'nobody';
// This is equivalent to:
$username = isset($_GET['user']) ? $_GET['user'] : 'nobody';

// Coalescing can be chained: this will return the first
// defined value out of $_GET['user'], $_POST['user'], and
// 'nobody'.
$username = $_GET['user'] ?? $_POST['user'] ?? 'nobody';
?>

Spaceship operator

The spaceship operator is used for comparing two expressions. It returns -1, 0 or 1 when $a is respectively less than, equal to, or greater than $b. Comparisons are performed according to PHP's usual type comparison rules.

<?php
// Integers
echo 1 <=> 1; // 0
echo 1 <=> 2; // -1
echo 2 <=> 1; // 1

// Floats
echo 1.5 <=> 1.5; // 0
echo 1.5 <=> 2.5; // -1
echo 2.5 <=> 1.5; // 1

// Strings
echo "a" <=> "a"; // 0
echo "a" <=> "b"; // -1
echo "b" <=> "a"; // 1
?>

Constant arrays using define()

Array constants can now be defined with define(). In PHP 5.6, they could only be defined with const.

<?php
define('ANIMALS', [
    'dog',
    'cat',
    'bird'
]);

echo ANIMALS[1]; // outputs "cat"
?>

Anonymous classes

Support for anonymous classes has been added via new class. These can be used in place of full class definitions for throwaway objects:

<?php
interface Logger {
    public function log(string $msg);
}

class Application {
    private $logger;

    public function getLogger(): Logger {
         return $this->logger;
    }

    public function setLogger(Logger $logger) {
         $this->logger = $logger;
    }
}

$app = new Application;
$app->setLogger(new class implements Logger {
    public function log(string $msg) {
        echo $msg;
    }
});

var_dump($app->getLogger());
?>

Yukarıdaki örneğin çıktısı:

object(class@anonymous)#2 (0) {
}

Full documentation can be found in the anonymous class reference.

Unicode codepoint escape syntax

This takes a Unicode codepoint in hexadecimal form, and outputs that codepoint in UTF-8 to a double-quoted string or a heredoc. Any valid codepoint is accepted, with leading 0's being optional.

echo "\u{aa}";
echo "\u{0000aa}";
echo "\u{9999}";

Yukarıdaki örneğin çıktısı:

ª
ª (same as before but with optional leading 0's)
?

Closure::call()

Closure::call() is a more performant, shorthand way of temporarily binding an object scope to a closure and invoking it.

<?php
class A {private $x = 1;}

// Pre PHP 7 code
$getXCB = function() {return $this->x;};
$getX = $getXCB->bindTo(new A, 'A'); // intermediate closure
echo $getX();

// PHP 7+ code
$getX = function() {return $this->x;};
echo $getX->call(new A);

Yukarıdaki örneğin çıktısı:

1
1

Filtered unserialize()

This feature seeks to provide better security when unserializing objects on untrusted data. It prevents possible code injections by enabling the developer to whitelist classes that can be unserialized.

<?php

// converts all objects into __PHP_Incomplete_Class object
$data = unserialize($foo, ["allowed_classes" => false]);

// converts all objects into __PHP_Incomplete_Class object except those of MyClass and MyClass2
$data = unserialize($foo, ["allowed_classes" => ["MyClass", "MyClass2"]]);

// default behaviour (same as omitting the second argument) that accepts all classes
$data = unserialize($foo, ["allowed_classes" => true]);

IntlChar

The new IntlChar class seeks to expose additional ICU functionality. The class itself defines a number of static methods and constants that can be used to manipulate unicode characters.

<?php

printf('%x', IntlChar::CODEPOINT_MAX);
echo IntlChar::charName('@');
var_dump(IntlChar::ispunct('!'));

Yukarıdaki örneğin çıktısı:

10ffff
COMMERCIAL AT
bool(true)

In order to use this class, the Intl extension must be installed.

Expectations

Expectations are a backwards compatible enhancement to the older assert() function. They allow for zero-cost assertions in production code, and provide the ability to throw custom exceptions when the assertion fails.

While the old API continues to be maintained for compatibility, assert() is now a language construct, allowing the first parameter to be an expression rather than just a string to be evaluated or a boolean value to be tested.

<?php
ini_set('assert.exception', 1);

class CustomError extends AssertionError {}

assert(false, new CustomError('Some error message'));
?>

Yukarıdaki örneğin çıktısı:

Fatal error: Uncaught CustomError: Some error message

Full details on this feature, including how to configure it in both development and production environments, can be found in the expectations section of the assert() reference.

Group use declarations

Classes, functions and constants being imported from the same namespace can now be grouped together in a single use statement.

<?php
// Pre PHP 7 code
use some\namespace\ClassA;
use some\namespace\ClassB;
use some\namespace\ClassC as C;

use function some\namespace\fn_a;
use function some\namespace\fn_b;
use function some\namespace\fn_c;

use const some\namespace\ConstA;
use const some\namespace\ConstB;
use const some\namespace\ConstC;

// PHP 7+ code
use some\namespace\{ClassA, ClassB, ClassC as C};
use function some\namespace\{fn_a, fn_b, fn_c};
use const some\namespace\{ConstA, ConstB, ConstC};
?>

Generator Return Expressions

This feature builds upon the generator functionality introduced into PHP 5.5. It enables for a return statement to be used within a generator to enable for a final expression to be returned (return by reference is not allowed). This value can be fetched using the new Generator::getReturn() method, which may only be used once the generator has finished yielding values.

<?php

$gen = (function() {
    yield 1;
    yield 2;

    return 3;
})();

foreach ($gen as $val) {
    echo $val, PHP_EOL;
}

echo $gen->getReturn(), PHP_EOL;

Yukarıdaki örneğin çıktısı:

1
2
3

Being able to explicitly return a final value from a generator is a handy ability to have. This is because it enables for a final value to be returned by a generator (from perhaps some form of coroutine computation) that can be specifically handled by the client code executing the generator. This is far simpler than forcing the client code to firstly check whether the final value has been yielded, and then if so, to handle that value specifically.

Generator delegation

Generators can now delegate to another generator, Traversable object or array automatically, without needing to write boilerplate in the outermost generator by using the yield from construct.

<?php
function gen()
{
    yield 1;
    yield 2;
    yield from gen2();
}

function gen2()
{
    yield 3;
    yield 4;
}

foreach (gen() as $val)
{
    echo $val, PHP_EOL;
}
?>

Yukarıdaki örneğin çıktısı:

1
2
3
4

Integer division with intdiv()

The new intdiv() function performs an integer division of its operands and returns it.

<?php
var_dump(intdiv(10, 3));
?>

Yukarıdaki örneğin çıktısı:

int(3)

Session options

session_start() now accepts an array of options that override the session configuration directives normally set in php.ini.

These options have also been expanded to support session.lazy_write, which is on by default and causes PHP to only overwrite any session file if the session data has changed, and read_and_close, which is an option that can only be passed to session_start() to indicate that the session data should be read and then the session should immediately be closed unchanged.

For example, to set session.cache_limiter to private and immediately close the session after reading it:

<?php
session_start([
    'cache_limiter' => 'private',
    'read_and_close' => true,
]);
?>

preg_replace_callback_array()

The new preg_replace_callback_array() function enables code to be written more cleanly when using the preg_replace_callback() function. Prior to PHP 7, callbacks that needed to be executed per regular expression required the callback function to be polluted with lots of branching.

Now, callbacks can be registered to each regular expression using an associative array, where the key is a regular expression and the value is a callback.

CSPRNG Functions

Two new functions have been added to generate cryptographically secure integers and strings in a cross platform way: random_bytes() and random_int().

list() can always unpack objects implementing ArrayAccess

Previously, list() was not guaranteed to operate correctly with objects implementing ArrayAccess. This has been fixed.

Other Features

  • Class member access on cloning has been added, e.g. (clone $foo)->bar().
Backward incompatible changes
Deprecated features in PHP 7.0.x
Migrating from PHP 5.6.x to PHP 7.0.x


Deprecated features in PHP 7.0.x

PHP 4 style constructors

PHP 4 style constructors (methods that have the same name as the class they are defined in) are deprecated, and will be removed in the future. PHP 7 will emit E_DEPRECATED if a PHP 4 constructor is the only constructor defined within a class. Classes that implement a __construct() method are unaffected.

<?php
class foo {
    function foo() {
        echo 'I am the constructor';
    }
}
?>

Yukarıdaki örneğin çıktısı:

Deprecated: Methods with the same name as their class will not be constructors in a future version of PHP; foo has a deprecated constructor in example.php on line 3

Static calls to non-static methods

Static calls to methods that are not declared static are deprecated, and may be removed in the future.

<?php
class foo {
    function bar() {
        echo 'I am not static!';
    }
}

foo::bar();
?>

Yukarıdaki örneğin çıktısı:

Deprecated: Non-static method foo::bar() should not be called statically in - on line 8
I am not static!

password_hash() salt option

The salt option for the password_hash() function has been deprecated to prevent developers from generating their own (usually insecure) salts. The function itself generates a cryptographically secure salt when no salt is provided by the developer - therefore custom salt generation should not be needed.

capture_session_meta SSL context option

The capture_session_meta SSL context option has been deprecated. SSL metadata is now available through the stream_get_meta_data() function.

LDAP deprecations

The following function has been deprecated:

  • ldap_sort()
New features
Changed functions
Migrating from PHP 5.6.x to PHP 7.0.x


Changed functions

PHP Core

  • debug_zval_dump() now prints "int" instead of "long", and "float" instead of "double"
  • dirname() now optionally takes a second parameter, depth, to get the name of the directory depth levels up from the current directory.
  • getrusage() is now supported on Windows.
  • mktime() and gmmktime() functions no longer accept is_dst parameter.
  • preg_replace() function no longer supports "\e" (PREG_REPLACE_EVAL). preg_replace_callback() should be used instead.
  • setlocale() function no longer accepts category passed as string. LC_* constants must be used instead.
  • exec(), system() and passthru() functions have NULL byte protection now.
  • shmop_open() now returns a resource instead of an int, which has to be passed to shmop_size(), shmop_write(), shmop_read(), shmop_close() and shmop_delete().
  • substr() and iconv_substr() now return an empty string, if string is equal to start characters long.
  • xml_set_object() now requires to manually unset the $parser when finished, to avoid memory leaks.
Deprecated features in PHP 7.0.x
New functions
Migrating from PHP 5.6.x to PHP 7.0.x


New functions

Closure

  • Closure::call()

CSPRNG

  • random_bytes()
  • random_int()

Error Handling and Logging

  • error_clear_last()

Generator

  • Generator::getReturn()

GNU Multiple Precision

  • gmp_random_seed()

Math

  • intdiv()

PCRE

  • preg_replace_callback_array()

PHP Options/Info

  • gc_mem_caches()
  • get_resources()

POSIX

  • posix_setrlimit()

Reflection

  • ReflectionParameter::getType()
  • ReflectionParameter::hasType()
  • ReflectionFunctionAbstract::getReturnType()
  • ReflectionFunctionAbstract::hasReturnType()

Zip

  • ZipArchive::setCompressionIndex()
  • ZipArchive::setCompressionName()

Zlib Compression

  • inflate_add()
  • deflate_add()
  • inflate_init()
  • deflate_init()
Changed functions
New Classes and Interfaces
Migrating from PHP 5.6.x to PHP 7.0.x


New Classes and Interfaces

Intl

  • IntlChar

Reflection

  • ReflectionGenerator
  • ReflectionType

Session Handling

  • SessionUpdateTimestampHandlerInterface

Exception Hierarchy

  • Throwable
  • Error
  • TypeError
  • ParseError
  • AssertionError
  • ArithmeticError
  • DivisionByZeroError
New functions
New Global Constants
Migrating from PHP 5.6.x to PHP 7.0.x


New Global Constants

Core Predefined Constants

  • PHP_INT_MIN

GD

  • IMG_WEBP (as of PHP 7.0.10)

JSON

  • JSON_ERROR_INVALID_PROPERTY_NAME
  • JSON_ERROR_UTF16

LibXML

  • LIBXML_BIGLINES

PCRE

  • PREG_JIT_STACKLIMIT_ERROR

POSIX

  • POSIX_RLIMIT_AS
  • POSIX_RLIMIT_CORE
  • POSIX_RLIMIT_CPU
  • POSIX_RLIMIT_DATA
  • POSIX_RLIMIT_FSIZE
  • POSIX_RLIMIT_LOCKS
  • POSIX_RLIMIT_MEMLOCK
  • POSIX_RLIMIT_MSGQUEUE
  • POSIX_RLIMIT_NICE
  • POSIX_RLIMIT_NOFILE
  • POSIX_RLIMIT_NPROC
  • POSIX_RLIMIT_RSS
  • POSIX_RLIMIT_RTPRIO
  • POSIX_RLIMIT_RTTIME
  • POSIX_RLIMIT_SIGPENDING
  • POSIX_RLIMIT_STACK
  • POSIX_RLIMIT_INFINITY

Zlib

  • ZLIB_ENCODING_RAW
  • ZLIB_ENCODING_DEFLATE
  • ZLIB_ENCODING_GZIP
  • ZLIB_FILTERED
  • ZLIB_HUFFMAN_ONLY
  • ZLIB_FIXED
  • ZLIB_RLE
  • ZLIB_DEFAULT_STRATEGY
  • ZLIB_BLOCK
  • ZLIB_FINISH
  • ZLIB_FULL_FLUSH
  • ZLIB_NO_FLUSH
  • ZLIB_PARTIAL_FLUSH
  • ZLIB_SYNC_FLUSH
New Classes and Interfaces
Changes in SAPI Modules
Migrating from PHP 5.6.x to PHP 7.0.x


Changes in SAPI Modules

FPM

Unqualified listen ports now listen on both IPv4 and IPv6

In PHP 5, a listen directive with only a port number would listen on all interfaces, but only on IPv4. PHP 7 will now accept requests made via both IPv4 and IPv6.

This does not affect directives which include specific IP addresses; these will continue to only listen on that address and protocol.

New Global Constants
Removed Extensions and SAPIs
Migrating from PHP 5.6.x to PHP 7.0.x


Removed Extensions and SAPIs

Removed Extensions

  • ereg
  • mssql
  • mysql
  • sybase_ct

Removed SAPIs

  • aolserver
  • apache
  • apache_hooks
  • apache2filter
  • caudium
  • continuity
  • isapi
  • milter
  • nsapi
  • phttpd
  • pi3web
  • roxen
  • thttpd
  • tux
  • webjames
Changes in SAPI Modules
Other Changes
Migrating from PHP 5.6.x to PHP 7.0.x


Other Changes

Loosening Reserved Word Restrictions

Globally reserved words as property, constant, and method names within classes, interfaces, and traits are now allowed. This reduces the surface of BC breaks when new keywords are introduced and avoids naming restrictions on APIs.

This is particularly useful when creating internal DSLs with fluent interfaces:

<?php
// 'new', 'private', and 'for' were previously unusable
Project::new('Project Name')->private()->for('purpose here')->with('username here');
?>

The only limitation is that the class keyword still cannot be used as a constant name, otherwise it would conflict with the class name resolution syntax (ClassName::class).

Removal of date.timezone Warning

Previously, a warning was emitted if the date.timezone INI setting had not been set prior to using any date- or time-based functions. Now, this warning has been removed (with date.timezone still defaulting to UTC).

Removed Extensions and SAPIs
Migrating from PHP 5.5.x to PHP 5.6.x
Migrating from PHP 5.6.x to PHP 7.0.x


Migrating from PHP 5.5.x to PHP 5.6.x

İçindekiler

  • Backward incompatible changes
  • New features
  • Deprecated features in PHP 5.6.x
  • Changed functions
  • New functions
  • OpenSSL changes in PHP 5.6.x
  • Other changes to extensions
  • New global constants

Most improvements in PHP 5.6.x have no impact on existing code. There are a few incompatibilities and new features that should be considered, and code should be tested before switching PHP versions in production environments.

Ayrıca, şu PHP sürümleri arasında geçiş kılavuzlarına da bakınız: 5.0.x, 5.1.x, 5.2.x, 5.3.x, 5.4.x and 5.5.x.

Other Changes
Backward incompatible changes
Ekler


Backward incompatible changes

Although most existing PHP 5 code should work without changes, please take note of some backward incompatible changes:

Array keys won't be overwritten when defining an array as a property of a class via an array literal

Previously, arrays declared as class properties which mixed explicit and implicit keys could have array elements silently overwritten if an explicit key was the same as a sequential implicit key. For example:

<?php
class C {
    const ONE = 1;
    public $array = [
        self::ONE => 'foo',
        'bar',
        'quux',
    ];
}

var_dump((new C)->array);
?>

Yukarıdaki örneğin PHP 5.5 çıktısı:

array(2) {
  [0]=>
  string(3) "bar"
  [1]=>
  string(4) "quux"
}

Yukarıdaki örneğin PHP 5.6 çıktısı:

array(3) {
  [1]=>
  string(3) "foo"
  [2]=>
  string(3) "bar"
  [3]=>
  string(4) "quux"
}

json_decode() strictness

json_decode() now rejects non-lowercase variants of the JSON literals true, false and null at all times, as per the JSON specification, and sets json_last_error() accordingly. Previously, inputs to json_decode() that consisted solely of one of these values in upper or mixed case were accepted.

This change will only affect cases where invalid JSON was being passed to json_decode(): valid JSON input is unaffected and will continue to be parsed normally.

Stream wrappers now verify peer certificates and host names by default when using SSL/TLS

All encrypted client streams now enable peer verification by default. By default, this will use OpenSSL's default CA bundle to verify the peer certificate. In most cases, no changes will need to be made to communicate with servers with valid SSL certificates, as distributors generally configure OpenSSL to use known good CA bundles.

The default CA bundle may be overridden on a global basis by setting either the openssl.cafile or openssl.capath configuration setting, or on a per request basis by using the cafile or capath context options.

While not recommended in general, it is possible to disable peer certificate verification for a request by setting the verify_peer context option to FALSE, and to disable peer name validation by setting the verify_peer_name context option to FALSE.

GMP resources are now objects

GMP resources are now objects. The functional API implemented in the GMP extension has not changed, and code should run unmodified unless it checks explicitly for a resource using is_resource() or similar.

Mcrypt functions now require valid keys and IVs

mcrypt_encrypt(), mcrypt_decrypt(), mcrypt_cbc(), mcrypt_cfb(), mcrypt_ecb(), mcrypt_generic() and mcrypt_ofb() will no longer accept keys or IVs with incorrect sizes, and block cipher modes that require IVs will now fail if an IV isn't provided.

cURL file uploads

Uploads using the @file syntax now require CURLOPT_SAFE_UPLOAD to be set to FALSE. CURLFile should be used instead.

Migrating from PHP 5.5.x to PHP 5.6.x
New features
Migrating from PHP 5.5.x to PHP 5.6.x


New features

Constant expressions

It is now possible to provide a scalar expression involving numeric and string literals and/or constants in contexts where PHP previously expected a static value, such as constant and property declarations and default function arguments.

<?php
const ONE = 1;
const TWO = ONE * 2;

class C {
    const THREE = TWO + 1;
    const ONE_THIRD = ONE / self::THREE;
    const SENTENCE = 'The value of THREE is '.self::THREE;

    public function f($a = ONE + self::THREE) {
        return $a;
    }
}

echo (new C)->f()."\n";
echo C::SENTENCE;
?>

Yukarıdaki örneğin çıktısı:

4
The value of THREE is 3

It is also now possible to define a constant array using the const keyword:

<?php
const ARR = ['a', 'b'];

echo ARR[0];
?>

Yukarıdaki örneğin çıktısı:

a

Variadic functions via ...

Variadic functions can now be implemented using the ... operator, instead of relying on func_get_args().

<?php
function f($req, $opt = null, ...$params) {
    // $params is an array containing the remaining arguments.
    printf('$req: %d; $opt: %d; number of params: %d'."\n",
           $req, $opt, count($params));
}

f(1);
f(1, 2);
f(1, 2, 3);
f(1, 2, 3, 4);
f(1, 2, 3, 4, 5);
?>

Yukarıdaki örneğin çıktısı:

$req: 1; $opt: 0; number of params: 0
$req: 1; $opt: 2; number of params: 0
$req: 1; $opt: 2; number of params: 1
$req: 1; $opt: 2; number of params: 2
$req: 1; $opt: 2; number of params: 3

Argument unpacking via ...

Arrays and Traversable objects can be unpacked into argument lists when calling functions by using the ... operator. This is also known as the splat operator in other languages, including Ruby.

<?php
function add($a, $b, $c) {
    return $a + $b + $c;
}

$operators = [2, 3];
echo add(1, ...$operators);
?>

Yukarıdaki örneğin çıktısı:

6

Exponentiation via **

A right associative ** operator has been added to support exponentiation, along with a **= shorthand assignment operator.

<?php
printf("2 ** 3 ==      %d\n", 2 ** 3);
printf("2 ** 3 ** 2 == %d\n", 2 ** 3 ** 2);

$a = 2;
$a **= 3;
printf("a ==           %d\n", $a);
?>

Yukarıdaki örneğin çıktısı:

2 ** 3 ==      8
2 ** 3 ** 2 == 512
a ==           8

use function and use const

The use operator has been extended to support importing functions and constants in addition to classes. This is achieved via the use function and use const constructs, respectively.

<?php
namespace Name\Space {
    const FOO = 42;
    function f() { echo __FUNCTION__."\n"; }
}

namespace {
    use const Name\Space\FOO;
    use function Name\Space\f;

    echo FOO."\n";
    f();
}
?>

Yukarıdaki örneğin çıktısı:

42
Name\Space\f

phpdbg

PHP now includes an interactive debugger called phpdbg implemented as a SAPI module. For more information, please visit the » phpdbg documentation.

Default character encoding

default_charset is now used as the default character set for the htmlentities(), html_entity_decode() and htmlspecialchars() functions. Note that if the (now deprecated) iconv and mbstring encoding settings are set, they will take precedence over default_charset for iconv and mbstring functions, respectively.

The default value for this setting is UTF-8.

php://input is reusable

php://input may now be reopened and read as many times as required. This work has also resulted in a major reduction in the amount of memory required to deal with POST data.

Large file uploads

Files larger than 2 gigabytes in size are now accepted.

GMP supports operator overloading

GMP objects now support operator overloading and casting to scalar types. This allows for more expressive code using GMP:

<?php
$a = gmp_init(42);
$b = gmp_init(17);

if (version_compare(PHP_VERSION, '5.6', '<')) {
    echo gmp_intval(gmp_add($a, $b)), PHP_EOL;
    echo gmp_intval(gmp_add($a, 17)), PHP_EOL;
    echo gmp_intval(gmp_add(42, $b)), PHP_EOL;
} else {
    echo $a + $b, PHP_EOL;
    echo $a + 17, PHP_EOL;
    echo 42 + $b, PHP_EOL;
}
?>

Yukarıdaki örneğin çıktısı:

59
59
59

hash_equals() for timing attack safe string comparison

The hash_equals() function has been added to compare two strings in constant time. This should be used to mitigate timing attacks; for instance, when testing crypt() password hashes (assuming that you are unable to use password_hash() and password_verify(), which aren't susceptible to timing attacks).

<?php
$expected  = crypt('12345', '$2a$07$usesomesillystringforsalt$');
$correct   = crypt('12345', '$2a$07$usesomesillystringforsalt$');
$incorrect = crypt('1234',  '$2a$07$usesomesillystringforsalt$');

var_dump(hash_equals($expected, $correct));
var_dump(hash_equals($expected, $incorrect));
?>

Yukarıdaki örneğin çıktısı:

bool(true)
bool(false)

__debugInfo()

The __debugInfo() magic method has been added to allow objects to change the properties and values that are shown when the object is output using var_dump().

<?php
class C {
    private $prop;

    public function __construct($val) {
        $this->prop = $val;
    }

    public function __debugInfo() {
        return [
            'propSquared' => $this->prop ** 2,
        ];
    }
}

var_dump(new C(42));
?>

Yukarıdaki örneğin çıktısı:

object(C)#1 (1) {
  ["propSquared"]=>
  int(1764)
}

gost-crypto hash algorithm

The gost-crypto hash algorithm has been added. This implements the GOST hash function using the CryptoPro S-box tables as specified by » RFC 4357, section 11.2.

SSL/TLS improvements

A wide range of improvements have been made to the SSL/TLS support in PHP 5.6. These include enabling peer verification by default, supporting certificate fingerprint matching, mitigating against TLS renegotiation attacks, and many new SSL context options to allow more fine grained control over protocol and verification settings when using encrypted streams.

These changes are described in more detail in the OpenSSL changes in PHP 5.6.x section of this migration guide.

pgsql async support

The pgsql extension now supports asynchronous connections and queries, thereby enabling non-blocking behaviour when interacting with PostgreSQL databases. Asynchronous connections may be established via the PGSQL_CONNECT_ASYNC constant, and the new pg_connect_poll(), pg_socket(), pg_consume_input() and pg_flush() functions may be used to handle asynchronous connections and queries.

Backward incompatible changes
Deprecated features in PHP 5.6.x
Migrating from PHP 5.5.x to PHP 5.6.x


Deprecated features in PHP 5.6.x

Calls from incompatible context

Methods called from an incompatible context are now deprecated, and will generate E_DEPRECATED errors when invoked instead of E_STRICT. Support for these calls will be removed in a future version of PHP.

An example of such a call is:

<?php
class A {
    function f() { echo get_class($this); }
}

class B {
    function f() { A::f(); }
}

(new B)->f();
?>

Yukarıdaki örneğin çıktısı:

Deprecated: Non-static method A::f() should not be called statically, assuming $this from incompatible context in - on line 7
B

$HTTP_RAW_POST_DATA and always_populate_raw_post_data

always_populate_raw_post_data will now generate an E_DEPRECATED error when $HTTP_RAW_POST_DATA is populated. New code should use php://input instead of $HTTP_RAW_POST_DATA, which will be removed in a future release. You can opt in for the new behaviour (in which $HTTP_RAW_POST_DATA is never defined hence no E_DEPRECATED error will be generated) by setting always_populate_raw_post_data to -1.

iconv and mbstring encoding settings

The iconv and mbstring configuration options related to encoding have been deprecated in favour of default_charset. The deprecated options are:

  • iconv.input_encoding
  • iconv.output_encoding
  • iconv.internal_encoding
  • mbstring.http_input
  • mbstring.http_output
  • mbstring.internal_encoding
New features
Changed functions
Migrating from PHP 5.5.x to PHP 5.6.x


Changed functions

PHP Core

  • crypt() will now raise an E_NOTICE error if the salt parameter is omitted.
  • substr_compare() will now accept 0 for its length parameter.
  • unserialize() will now fail if passed serialised data that has been manipulated to attempt to instantiate an object without calling its constructor.

cURL

  • Uploads using the @file syntax are now only supported if the CURLOPT_SAFE_UPLOAD option is set to FALSE. CURLFile should be used instead.

Mcrypt

  • The source parameter of mcrypt_create_iv() now defaults to MCRYPT_DEV_URANDOM instead of MCRYPT_DEV_RANDOM.

OpenSSL

  • stream_socket_enable_crypto() now allows the crypto_type parameter to be optional if the stream's SSL context includes the new crypto_type option.

PostgreSQL

  • pg_insert(), pg_select(), pg_update() and pg_delete() are no longer experimental.
  • pg_send_execute(), pg_send_prepare(), pg_send_query() and pg_send_query_params() will no longer block until query write completion if the underlying socket stream for the database connection is set to non-blocking mode.

Reflection

  • ReflectionClass::newInstanceWithoutConstructor() now allows non-final internal classes to be instantiated.

XMLReader

  • XMLReader::getAttributeNs() and XMLReader::getAttributeNo() now return NULL if the attribute could not be found, like XMLReader::getAttribute().
Deprecated features in PHP 5.6.x
New functions
Migrating from PHP 5.5.x to PHP 5.6.x


New functions

Date and Time

  • DateTimeImmutable::createFromMutable()

GMP

  • gmp_root()
  • gmp_rootrem()

Hash

  • hash_equals()

LDAP

  • ldap_escape()
  • ldap_modify_batch()

MySQLi

  • mysqli_get_links_stats()

OCI8

  • oci_get_implicit_resultset()

OpenSSL

  • openssl_get_cert_locations()
  • openssl_x509_fingerprint()
  • openssl_spki_new()
  • openssl_spki_verify()
  • openssl_spki_export_challenge()
  • openssl_spki_export()

PostgreSQL

  • pg_connect_poll()
  • pg_consume_input()
  • pg_flush()
  • pg_socket()

PDO_PGSQL

  • PDO::pgsqlGetNotify()
  • PDO::pgsqlGetPid()

Session

  • session_abort()
  • session_reset()

Zip

  • ZipArchive::setPassword()
Changed functions
OpenSSL changes in PHP 5.6.x
Migrating from PHP 5.5.x to PHP 5.6.x


OpenSSL changes in PHP 5.6.x

Stream wrappers now verify peer certificates and host names by default when using SSL/TLS

All encrypted client streams now enable peer verification by default. By default, this will use OpenSSL's default CA bundle to verify the peer certificate. In most cases, no changes will need to be made to communicate with servers with valid SSL certificates, as distributors generally configure OpenSSL to use known good CA bundles.

The default CA bundle may be overridden on a global basis by setting either the openssl.cafile or openssl.capath configuration setting, or on a per request basis by using the cafile or capath context options.

While not recommended in general, it is possible to disable peer certificate verification for a request by setting the verify_peer context option to FALSE, and to disable peer name validation by setting the verify_peer_name context option to FALSE.

Certificate fingerprints

Support has been added for extracting and verifying certificate fingerprints. openssl_x509_fingerprint() has been added to extract a fingerprint from an X.509 certificate, and two SSL stream context options have been added: capture_peer_cert to capture the peer's X.509 certificate, and peer_fingerprint to assert that the peer's certificate should match the given fingerprint.

Default ciphers updated

The default ciphers used by PHP have been updated to a more secure list based on the » Mozilla cipher recommendations, with two additional exclusions: anonymous Diffie-Hellman ciphers, and RC4.

This list can be accessed via the new OPENSSL_DEFAULT_STREAM_CIPHERS constant, and can be overridden (as in previous PHP versions) by setting the ciphers context option.

Compression disabled by default

SSL/TLS compression has been disabled by default to mitigate the CRIME attack. PHP 5.4.13 added a disable_compression context option to allow compression to be disabled: this is now set to TRUE (that is, compression is disabled) by default.

Allow servers to prefer their cipher order

The honor_cipher_order SSL context option has been added to allow encrypted stream servers to mitigate BEAST vulnerabilities by preferring the server's ciphers to the client's.

Access the negotiated protocol and cipher

The protocol and cipher that were negotiated for an encrypted stream can now be accessed via stream_get_meta_data() or stream_context_get_options() when the capture_session_meta SSL context option is set to TRUE.

<?php
$ctx = stream_context_create(['ssl' => [
    'capture_session_meta' => TRUE
]]);

$html = file_get_contents('https://google.com/', FALSE, $ctx);
$meta = stream_context_get_options($ctx)['ssl']['session_meta'];
var_dump($meta);
?>

Yukarıdaki örneğin çıktısı:

array(4) {
  ["protocol"]=>
  string(5) "TLSv1"
  ["cipher_name"]=>
  string(20) "ECDHE-RSA-AES128-SHA"
  ["cipher_bits"]=>
  int(128)
  ["cipher_version"]=>
  string(11) "TLSv1/SSLv3"
}

New options for perfect forward secrecy in encrypted stream servers

Encrypted client streams already support perfect forward secrecy, as it is generally controlled by the server. PHP encrypted server streams using certificates capable of perfect forward secrecy do not need to take any additional action to enable PFS; however a number of new SSL context options have been added to allow more control over PFS and deal with any compatibility issues that may arise.

ecdh_curve

This option allows the selection of a specific curve for use with ECDH ciphers. If not specified, prime256v1 will be used.

dh_param

A path to a file containing parametrs for Diffie-Hellman key exchange, such as that created by the following command:

openssl dhparam -out /path/to/my/certs/dh-2048.pem 2048
single_dh_use

If set to TRUE, a new key pair will be created when using Diffie-Hellman parameters, thereby improving forward secrecy.

single_ecdh_use

If set to TRUE, a new key pair will always be generated when ECDH cipher suites are negotiated. This improves forward secrecy.

SSL/TLS version selection

It is now possible to select specific versions of SSL and TLS via the crypto_method SSL context option or by specifying a specific transport when creating a stream wrapper (for example, by calling stream_socket_client() or stream_socket_server()).

The crypto_method SSL context option accepts a bitmask enumerating the protocols that are permitted, as does the crypto_type of stream_socket_enable_crypto().

Selected protocol versions and corresponding options
Protocol(s) | Client flag | Server flag | Transport
Any TLS or SSL version | STREAM_CRYPTO_METHOD_ANY_CLIENT | STREAM_CRYPTO_METHOD_ANY_SERVER | ssl://
Any TLS version | STREAM_CRYPTO_METHOD_TLS_CLIENT | STREAM_CRYPTO_METHOD_TLS_SERVER | tls://
TLS 1.0 | STREAM_CRYPTO_METHOD_TLSv1_0_CLIENT | STREAM_CRYPTO_METHOD_TLSv1_0_SERVER | tlsv1.0://
TLS 1.1 | STREAM_CRYPTO_METHOD_TLSv1_1_CLIENT | STREAM_CRYPTO_METHOD_TLSv1_1_SERVER | tlsv1.1://
TLS 1.2 | STREAM_CRYPTO_METHOD_TLSv1_2_CLIENT | STREAM_CRYPTO_METHOD_TLSv1_2_SERVER | tlsv1.2://
SSL 3 | STREAM_CRYPTO_METHOD_SSLv3_CLIENT | STREAM_CRYPTO_METHOD_SSLv3_SERVER | sslv3://
<?php

// Requiring TLS 1.0 or better when using file_get_contents():
$ctx = stream_context_create([
    'ssl' => [
        'crypto_method' => STREAM_CRYPTO_METHOD_TLS_CLIENT,
    ],
]);
$html = file_get_contents('https://google.com/', false, $ctx);

// Requiring TLS 1.1 or 1.2:
$ctx = stream_context_create([
    'ssl' => [
        'crypto_method' => STREAM_CRYPTO_METHOD_TLSv1_1_CLIENT |
                           STREAM_CRYPTO_METHOD_TLSv1_2_CLIENT,
    ],
]);
$html = file_get_contents('https://google.com/', false, $ctx);

// Connecting using the tlsv1.2:// stream socket transport.
$sock = stream_socket_client('tlsv1.2://google.com:443/');

?>

openssl_get_cert_locations() added

The openssl_get_cert_locations() function has been added: it returns the default locations PHP will search when looking for CA bundles.

<?php
var_dump(openssl_get_cert_locations());
?>

Yukarıdaki örneğin çıktısı:

array(8) {
  ["default_cert_file"]=>
  string(21) "/etc/pki/tls/cert.pem"
  ["default_cert_file_env"]=>
  string(13) "SSL_CERT_FILE"
  ["default_cert_dir"]=>
  string(18) "/etc/pki/tls/certs"
  ["default_cert_dir_env"]=>
  string(12) "SSL_CERT_DIR"
  ["default_private_dir"]=>
  string(20) "/etc/pki/tls/private"
  ["default_default_cert_area"]=>
  string(12) "/etc/pki/tls"
  ["ini_cafile"]=>
  string(0) ""
  ["ini_capath"]=>
  string(0) ""
}

SPKI support

Support has been added for generating, extracting and verifying signed public key and challenges (SPKAC). openssl_spki_new(), openssl_spki_verify(), openssl_spki_export_challenge(), and openssl_spki_export() have been added to create, verify export PEM public key and associated challenge from SPKAC's generated from a KeyGen HTML5 element.

openssl_spki_new

Generates a new SPKAC using private key, challenge string and hashing algorithm.

<?php
$pkey = openssl_pkey_new();
openssl_pkey_export($pkey, 'secret passphrase');

$spkac = openssl_spki_new($pkey, 'challenge string');
?>

Yukarıdaki örneğin çıktısı:

SPKAC=MIIBXjCByDCBnzANBgkqhkiG9w0BAQEFAAOBjQAwgYkCgYEA3L0IfUijj7+A8CPC8EmhcdNoe5fUAog7OrBdhn7EkxFButUp40P7+LiYiygYG1TmoI/a5EgsLU3s9twEz3hmgY9mYIqb/rb+SF8qlD/K6KVyUORC7Wlz1Df4L8O3DuRGzx6/+3jIW6cPBpfgH1sVuYS1vDBsP/gMMIxwTsKJ4P0CAwEAARYkYjViMzYxMTktNjY5YS00ZDljLWEyYzctMGZjNGFhMjVlMmE2MA0GCSqGSIb3DQEBAwUAA4GBAF7hu0ifzmjonhAak2FhhBRsKFDzXdKIkrWxVNe8e0bZzMrWOxFM/rqBgeH3/gtOUDRS5Fnzyq425UsTYbjfiKzxGeCYCQJb1KJ2V5Ij/mIJHZr53WYEXHQTNMGR8RPm7IxwVXVSHIgAfXsXZ9IXNbFbcaLRiSTr9/N4U+MXUWL7
openssl_spki_verify

Verifies provided SPKAC.

<?php
$pkey = openssl_pkey_new();
openssl_pkey_export($pkey, 'secret passphrase');

$spkac = openssl_spki_new($pkey, 'challenge string');
var_dump(openssl_spki_verify($spkac));
?>
openssl_spki_export_challenge

Exports associated challenge from provided SPKAC.

<?php
$pkey = openssl_pkey_new();
openssl_pkey_export($pkey, 'secret passphrase');

$spkac = openssl_spki_new($pkey, 'challenge string');
$challenge = openssl_spki_export_challenge($spkac):
echo $challenge;
?>

Yukarıdaki örneğin çıktısı:

challenge string
openssl_spki_export

Exports the PEM formatted RSA public key from SPKAC.

<?php
$pkey = openssl_pkey_new();
openssl_pkey_export($pkey, 'secret passphrase');

$spkac = openssl_spki_new($pkey, 'challenge string');
echo openssl_spki_export($spkac);
?>

Yukarıdaki örneğin çıktısı:

-----BEGIN PUBLIC KEY-----
MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQDcvQh9SKOPv4DwI8LwSaFx02h7
l9QCiDs6sF2GfsSTEUG61SnjQ/v4uJiLKBgbVOagj9rkSCwtTez23ATPeGaBj2Zg
ipv+tv5IXyqUP8ropXJQ5ELtbXPUN/gvw7cO5EbPHr/7eMhbpw8Gl+AfWxW5hLW8
MGw/+AwwjHBOwong/QIDAQAB
-----END PUBLIC KEY-----
New functions
Other changes to extensions
Migrating from PHP 5.5.x to PHP 5.6.x


Other changes to extensions

cURL

A number of constants marked obsolete in the cURL library have now been removed:

  • CURLOPT_CLOSEPOLICY
  • CURLCLOSEPOLICY_CALLBACK
  • CURLCLOSEPOLICY_LEAST_RECENTLY_USED
  • CURLCLOSEPOLICY_LEAST_TRAFFIC
  • CURLCLOSEPOLICY_OLDEST
  • CURLCLOSEPOLICY_SLOWEST

OCI8

  • Support for implicit result sets for Oracle Database 12c has been added via the new oci_get_implicit_resultset() function.
  • Using oci_execute($s, OCI_NO_AUTO_COMMIT) for a SELECT no longer unnecessarily initiates an internal ROLLBACK during connection close.
  • Added DTrace probes controlled by the --enable-dtrace configure option.
  • oci_internal_debug() is now a no-op.
  • The phpinfo() output format for OCI8 has changed.

Zip

A --with-libzip configure option has been added to use a system libzip installation. libzip version 0.11 is required, with 0.11.2 or later recommended.

MySQLi

A new mysqli.rollback_on_cached_plink option was added to rollback connections put back into the persistent connection pool.

OpenSSL changes in PHP 5.6.x
New global constants
Migrating from PHP 5.5.x to PHP 5.6.x


New global constants

GD

  • IMG_WEBP (as of PHP 5.6.25)

LDAP

  • LDAP_ESCAPE_DN
  • LDAP_ESCAPE_FILTER

OpenSSL

  • OPENSSL_DEFAULT_STREAM_CIPHERS
  • STREAM_CRYPTO_METHOD_ANY_CLIENT
  • STREAM_CRYPTO_METHOD_ANY_SERVER
  • STREAM_CRYPTO_METHOD_TLSv1_0_CLIENT
  • STREAM_CRYPTO_METHOD_TLSv1_0_SERVER
  • STREAM_CRYPTO_METHOD_TLSv1_1_CLIENT
  • STREAM_CRYPTO_METHOD_TLSv1_1_SERVER
  • STREAM_CRYPTO_METHOD_TLSv1_2_CLIENT
  • STREAM_CRYPTO_METHOD_TLSv1_2_SERVER

PostgreSQL

  • PGSQL_CONNECT_ASYNC
  • PGSQL_CONNECTION_AUTH_OK
  • PGSQL_CONNECTION_AWAITING_RESPONSE
  • PGSQL_CONNECTION_MADE
  • PGSQL_CONNECTION_SETENV
  • PGSQL_CONNECTION_SSL_STARTUP
  • PGSQL_CONNECTION_STARTED
  • PGSQL_DML_ESCAPE
  • PGSQL_POLLING_ACTIVE
  • PGSQL_POLLING_FAILED
  • PGSQL_POLLING_OK
  • PGSQL_POLLING_READING
  • PGSQL_POLLING_WRITING
Other changes to extensions
Migrating from PHP 5.4.x to PHP 5.5.x
Migrating from PHP 5.5.x to PHP 5.6.x


Migrating from PHP 5.4.x to PHP 5.5.x

İçindekiler

  • What has changed in PHP 5.5.x
  • Backward Incompatible Changes
  • New features
  • Deprecated features in PHP 5.5.x
  • Changed Functions
  • New Functions
  • New Classes and Interfaces
  • New Methods
  • Other changes to extensions
  • New Global Constants
  • Changes to INI file handling
  • Changes to PHP Internals

Ayrıca, şu PHP sürümleri arasında geçiş kılavuzlarına da bakınız: 5.0.x, 5.1.x, 5.2.x, 5.3.x, 5.4.x, 5.6.x, and 7.0.x.

New global constants
What has changed in PHP 5.5.x
Ekler


What has changed in PHP 5.5.x

Most improvements in PHP 5.5.x have no impact on existing code. There are a few incompatibilities and new features that should be considered, and code should be tested before switching PHP versions in production environments.

For systems being upgraded from an older version of PHP, the relevant documentation is available at:

  • Upgrade Notes for PHP 5.4.x.
  • Upgrade Notes for PHP 5.3.x.
  • Upgrade Notes for PHP 5.2.x.
  • Upgrade Notes for PHP 5.1.x.
  • Migrating from PHP 4 to PHP 5.
Migrating from PHP 5.4.x to PHP 5.5.x
Backward Incompatible Changes
Migrating from PHP 5.4.x to PHP 5.5.x


Backward Incompatible Changes

Although most existing PHP 5 code should work without changes, please take note of some backward incompatible changes:

Windows XP and 2003 support dropped

Support for Windows XP and 2003 has been dropped. Windows builds of PHP now require Windows Vista or newer.

Case insensitivity no longer locale specific

All case insensitive matching for function, class and constant names is now performed in a locale independent manner according to ASCII rules. This improves support for languages using the Latin alphabet with unusual collating rules, such as Turkish and Azeri.

This may cause issues for code that uses case insensitive matches for non-ASCII characters in multibyte character sets (including UTF-8), such as accented characters in many European languages. If you have a non-English, non-ASCII code base, then you will need to test that you are not inadvertently relying on this behaviour before deploying PHP 5.5 to production systems.

pack() and unpack() changes

Changes were made to pack() and unpack() to make them more compatible with Perl:

  • pack() now supports the "Z" format code, which behaves identically to "a".
  • unpack() now support the "Z" format code for NULL padded strings, and behaves as "a" did in previous versions: it will strip trailing NULL bytes.
  • unpack() now keeps trailing NULL bytes when the "a" format code is used.
  • unpack() now strips all trailing ASCII whitespace when the "A" format code is used.

Writing backward compatible code that uses the "a" format code with unpack() requires the use of version_compare(), due to the backward compatibility break.

For example:

<?php
// Old code:
$data = unpack('a5', $packed);

// New code:
if (version_compare(PHP_VERSION, '5.5.0-dev', '>=')) {
  $data = unpack('Z5', $packed);
} else {
  $data = unpack('a5', $packed);
}
?>

self, parent and static are now always case insensitive

Prior to PHP 5.5, cases existed where the self, parent, and static keywords were treated in a case sensitive fashion. These have now been resolved, and these keywords are always handled case insensitively: SELF::CONSTANT is now treated identically to self::CONSTANT.

PHP logo GUIDs removed

The GUIDs that previously resulted in PHP outputting various logos have been removed. This includes the removal of the functions to return those GUIDs. The removed functions are:

  • php_logo_guid()
  • php_egg_logo_guid()
  • php_real_logo_guid()
  • zend_logo_guid()

Internal execution changes

Extension authors should note that the zend_execute() function can no longer be overridden, and that numerous changes have been made to the execute_data struct and related function and method handling opcodes.

Most extension authors are unlikely to be affected, but those writing extensions that hook deeply into the Zend Engine should read the notes on these changes.

What has changed in PHP 5.5.x
New features
Migrating from PHP 5.4.x to PHP 5.5.x


New features

Generators added

Support for generators has been added via the yield keyword. Generators provide an easy way to implement simple iterators without the overhead or complexity of implementing a class that implements the Iterator interface.

A simple example that reimplements the range() function as a generator (at least for positive step values):

<?php
function xrange($start, $limit, $step = 1) {
    for ($i = $start; $i <= $limit; $i += $step) {
        yield $i;
    }
}

echo 'Single digit odd numbers: ';

/*
 * Note that an array is never created or returned,
 * which saves memory.
 */
foreach (xrange(1, 9, 2) as $number) {
    echo "$number ";
}

echo "\n";
?>

Yukarıdaki örneğin çıktısı:

Single digit odd numbers: 1 3 5 7 9

finally keyword added

try-catch blocks now support a finally block for code that should be run regardless of whether an exception has been thrown or not.

New password hashing API

A new password hashing API that makes it easier to securely hash and manage passwords using the same underlying library as crypt() in PHP has been added. See the documentation for password_hash() for more detail.

foreach now supports list()

The foreach control structure now supports unpacking nested arrays into separate variables via the list() construct. For example:

<?php
$array = [
    [1, 2],
    [3, 4],
];

foreach ($array as list($a, $b)) {
    echo "A: $a; B: $b\n";
}
?>

Yukarıdaki örneğin çıktısı:

A: 1; B: 2
A: 3; B: 4

Further documentation is available on the foreach manual page.

empty() supports arbitrary expressions

Passing an arbitrary expression instead of a variable to empty() is now supported. For example:

<?php
function always_false() {
    return false;
}

if (empty(always_false())) {
    echo "This will be printed.\n";
}

if (empty(true)) {
    echo "This will not be printed.\n";
}
?>

Yukarıdaki örneğin çıktısı:

This will be printed.

array and string literal dereferencing

Array and string literals can now be dereferenced directly to access individual elements and characters:

<?php
echo 'Array dereferencing: ';
echo [1, 2, 3][0];
echo "\n";

echo 'String dereferencing: ';
echo 'PHP'[0];
echo "\n";
?>

Yukarıdaki örneğin çıktısı:

Array dereferencing: 1
String dereferencing: P

Class name resolution via ::class

It is possible to use ClassName::class to get a fully qualified name of class ClassName. For example:

<?php
namespace Name\Space;
class ClassName {}

echo ClassName::class;

echo "\n";
?>

Yukarıdaki örneğin çıktısı:

Name\Space\ClassName

OPcache extension added

The Zend Optimiser+ opcode cache has been added to PHP as the new OPcache extension. OPcache improves PHP performance by storing precompiled script bytecode in shared memory, thereby removing the need for PHP to load and parse scripts on each request. See the installation instructions for more detail on enabling and using OPcache.

foreach now supports non-scalar keys

foreach now supports keys of any type. While non-scalar keys cannot occur in native PHP arrays, it is possible for Iterator::key() to return a value of any type, and this will now be handled correctly.

Apache 2.4 handler supported on Windows

The Apache 2.4 handler SAPI is now supported on Windows.

Improvements to GD

Various improvements have been made to the GD extension, these include:

  • Flipping support using the new imageflip() function.
  • Advanced cropping support using the imagecrop() & imagecropauto() functions.
  • WebP read and write support using imagecreatefromwebp() & imagewebp() respectively.
Backward Incompatible Changes
Deprecated features in PHP 5.5.x
Migrating from PHP 5.4.x to PHP 5.5.x


Deprecated features in PHP 5.5.x

ext/mysql deprecation

The original MySQL extension is now deprecated, and will generate E_DEPRECATED errors when connecting to a database. Instead, use the MySQLi or PDO_MySQL extensions.

preg_replace() /e modifier

The preg_replace() /e modifier is now deprecated. Instead, use the preg_replace_callback() function.

intl deprecations

IntlDateFormatter::setTimeZoneID() and
datefmt_set_timezone_id() are now deprecated. Instead,
use the IntlDateFormatter::setTimeZone() method and
datefmt_set_timezone() function, respectively.

mcrypt deprecations

The following functions have been deprecated:

  • mcrypt_cbc()
  • mcrypt_cfb()
  • mcrypt_ecb()
  • mcrypt_ofb()
New features
Changed Functions
Migrating from PHP 5.4.x to PHP 5.5.x


Changed Functions

PHP Core

  • set_error_handler() can now be called with NULL as an argument to reset the error handler.
  • When called with NULL, set_error_handler() and set_exception_handler() now return the previous error or exception handler, respectively.
  • json_encode() now accepts depth parameter.
  • The behaviour of pack() and unpack() with the "a" and "A" format codes has changed. Detailed notes on these changes are available.

intl

  • MessageFormatter::format() and related functions now accept named arguments and mixed numeric and named arguments when PHP is linked to ICU 4.8 or later.
  • MessageFormatter::format() and related functions no longer error when an insufficient number of arguments have been provided. Instead, the placeholders will not be substituted.
  • MessageFormatter::format() and MessageFormatter::parse() are no longer limited to second precision when dealing with times.
  • IntlDateFormatter::__construct() and datefmt_create() now accept IntlTimeZone and DateTimeZone objects for the timezone argument, and IntlCalendar objects for the calendar argument. Furthermore, if the time zone is omitted and the calendar doesn't specify a time zone, PHP's default time zone from date_default_timezone_get() is now used instead of the default ICU time zone.
  • IntlDateFormatter::getCalendar() and datefmt_get_calendar() return false if the IntlDateFormatter object was created with an IntlCalendar instance instead of one of the IntlDateFormatter constants.
  • IntlDateFormatter::setCalendar() and datefmt_set_calendar() now accept IntlCalendar objects in addition to the IntlDateFormatter constants.
  • IntlDateFormatter::format() and datefmt_format() now accept IntlCalendar objects.
Deprecated features in PHP 5.5.x
New Functions
Migrating from PHP 5.4.x to PHP 5.5.x


New Functions

PHP Core

  • array_column()
  • boolval()
  • json_last_error_msg()
  • password_get_info()
  • password_hash()
  • password_needs_rehash()
  • password_verify()

Hash

  • hash_pbkdf2()

OpenSSL

  • openssl_pbkdf2()

cURL

  • curl_escape()
  • curl_file_create()
  • curl_multi_setopt()
  • curl_multi_strerror()
  • curl_pause()
  • curl_reset()
  • curl_share_close()
  • curl_share_init()
  • curl_share_setopt()
  • curl_strerror()
  • curl_unescape()

GD

  • imageaffinematrixconcat()
  • imageaffinematrixget()
  • imagecrop()
  • imagecropauto()
  • imageflip()
  • imagepalettetotruecolor()
  • imagescale()

MySQLi

  • mysqli_begin_transaction()
  • mysqli_release_savepoint()
  • mysqli_savepoint()

PostgreSQL

  • pg_escape_literal()
  • pg_escape_identifier()

Sockets

  • socket_sendmsg()
  • socket_recvmsg()
  • socket_cmsg_space()

CLI

  • cli_get_process_title()
  • cli_set_process_title()

Intl

  • datefmt_format_object()
  • datefmt_get_calendar_object()
  • datefmt_get_timezone()
  • datefmt_set_timezone()
  • datefmt_get_calendar_object()
  • intlcal_create_instance()
  • intlcal_get_keyword_values_for_locale()
  • intlcal_get_now()
  • intlcal_get_available_locales()
  • intlcal_get()
  • intlcal_get_time()
  • intlcal_set_time()
  • intlcal_add()
  • intlcal_set_time_zone()
  • intlcal_after()
  • intlcal_before()
  • intlcal_set()
  • intlcal_roll()
  • intlcal_clear()
  • intlcal_field_difference()
  • intlcal_get_actual_maximum()
  • intlcal_get_actual_minimum()
  • intlcal_get_day_of_week_type()
  • intlcal_get_first_day_of_week()
  • intlcal_get_greatest_minimum()
  • intlcal_get_least_maximum()
  • intlcal_get_locale()
  • intlcal_get_maximum()
  • intlcal_get_minimal_days_in_first_week()
  • intlcal_get_minimum()
  • intlcal_get_time_zone()
  • intlcal_get_type()
  • intlcal_get_weekend_transition()
  • intlcal_in_daylight_time()
  • intlcal_is_equivalent_to()
  • intlcal_is_lenient()
  • intlcal_is_set()
  • intlcal_is_weekend()
  • intlcal_set_first_day_of_week()
  • intlcal_set_lenient()
  • intlcal_equals()
  • intlcal_get_repeated_wall_time_option()
  • intlcal_get_skipped_wall_time_option()
  • intlcal_set_repeated_wall_time_option()
  • intlcal_set_skipped_wall_time_option()
  • intlcal_from_date_time()
  • intlcal_to_date_time()
  • intlcal_get_error_code()
  • intlcal_get_error_message()
  • intlgregcal_create_instance()
  • intlgregcal_set_gregorian_change()
  • intlgregcal_get_gregorian_change()
  • intlgregcal_is_leap_year()
  • intltz_create_time_zone()
  • intltz_create_default()
  • intltz_get_id()
  • intltz_get_gmt()
  • intltz_get_unknown()
  • intltz_create_enumeration()
  • intltz_count_equivalent_ids()
  • intltz_create_time_zone_id_enumeration()
  • intltz_get_canonical_id()
  • intltz_get_region()
  • intltz_get_tz_data_version()
  • intltz_get_equivalent_id()
  • intltz_use_daylight_time()
  • intltz_get_offset()
  • intltz_get_raw_offset()
  • intltz_has_same_rules()
  • intltz_get_display_name()
  • intltz_get_dst_savings()
  • intltz_from_date_time_zone()
  • intltz_to_date_time_zone()
  • intltz_get_error_code()
  • intltz_get_error_message()

SPL

  • SplFixedArray::__wakeup()
Changed Functions
New Classes and Interfaces
Migrating from PHP 5.4.x to PHP 5.5.x


New Classes and Interfaces

cURL

  • CURLFile

Date and Time

  • DateTimeImmutable
  • DateTimeInterface

Intl

  • IntlCalendar
  • IntlGregorianCalendar
  • IntlTimeZone
  • IntlBreakIterator
  • IntlRuleBasedBreakIterator
  • IntlCodePointBreakIterator
New Functions
New Methods
Migrating from PHP 5.4.x to PHP 5.5.x


New Methods

MySQLi

  • mysqli::begin_transaction()
  • mysqli::release_savepoint()
  • mysqli::savepoint()

Intl

  • IntlDateFormatter::formatObject()
  • IntlDateFormatter::getCalendarObject()
  • IntlDateFormatter::getTimeZone()
  • IntlDateFormatter::setTimeZone()
New Classes and Interfaces
Other changes to extensions
Migrating from PHP 5.4.x to PHP 5.5.x


Other changes to extensions

Intl

The intl extension now requires ICU 4.0 or later.

New Methods
New Global Constants
Migrating from PHP 5.4.x to PHP 5.5.x


New Global Constants

GD

  • IMG_AFFINE_TRANSLATE
  • IMG_AFFINE_SCALE
  • IMG_AFFINE_ROTATE
  • IMG_AFFINE_SHEAR_HORIZONTAL
  • IMG_AFFINE_SHEAR_VERTICAL
  • IMG_CROP_DEFAULT
  • IMG_CROP_TRANSPARENT
  • IMG_CROP_BLACK
  • IMG_CROP_WHITE
  • IMG_CROP_SIDES
  • IMG_FLIP_BOTH
  • IMG_FLIP_HORIZONTAL
  • IMG_FLIP_VERTICAL
  • IMG_BELL
  • IMG_BESSEL
  • IMG_BICUBIC
  • IMG_BICUBIC_FIXED
  • IMG_BLACKMAN
  • IMG_BOX
  • IMG_BSPLINE
  • IMG_CATMULLROM
  • IMG_GAUSSIAN
  • IMG_GENERALIZED_CUBIC
  • IMG_HERMITE
  • IMG_HAMMING
  • IMG_HANNING
  • IMG_MITCHELL
  • IMG_POWER
  • IMG_QUADRATIC
  • IMG_SINC
  • IMG_NEAREST_NEIGHBOUR
  • IMG_WEIGHTED4
  • IMG_TRIANGLE

JSON

  • JSON_ERROR_RECURSION
  • JSON_ERROR_INF_OR_NAN
  • JSON_ERROR_UNSUPPORTED_TYPE

MySQLi

The MYSQLI_SERVER_PUBLIC_KEY option has been added for use with mysqli_options().

Other changes to extensions
Changes to INI file handling
Migrating from PHP 5.4.x to PHP 5.5.x


Changes to INI file handling

Intl

The intl.use_exceptions configuration directive has been added, which controls the behaviour of intl when global errors occur in conjunction with the already extant intl.error_level configuration directive.

MySQLnd

The mysqlnd.sha256_server_public_key configuration directive has been added to allow mysqli to use the new MySQL authentication protocol.

New Global Constants
Changes to PHP Internals
Migrating from PHP 5.4.x to PHP 5.5.x


Changes to PHP Internals

  • Extensions cannot override zend_execute() any more and should override zend_execute_ex() instead. EG(current_execute_data) is already initialized in zend_execute_ex(), so for compatibility extensions may need to use EG(current_execute_data)->prev_execute_data instead.
  • Removed EG(arg_types_stack), EX(fbc), EX(called_scope) and EX(current_object).
  • Added op_array->nested_calls, which is calculated at compile time.
  • Added EX(call_slots), which is an array to store information about syntaticaly nested calls (e.g. foo(bar())) and is preallocated together with execute_data.
  • Added EX(call), which is a pointer to a current calling function, and is an element of EX(call_slots).
  • Opcodes INIT_METHOD_CALL, ZEND_INIT_STATIC_METHOD_CALL, ZEND_INIT_FCALL_BY_NAME and ZEND_INIT_NS_FCALL_BY_NAME use result.num as an index in EX(call_slots).
  • Opcode ZEND_NEW uses extended_value as an index in EX(call_slots).
  • Opcodes ZEND_DO_FCALL and ZEND_DO_FCALL_BY_NAME use op2.num as an index in EX(call_slots).
  • Added op_array->used_stack, which is calculated at compile time; the corresponding stack space is preallocated together with execute_data. As a result, the ZEND_SEND* and ZEND_DO_FCALL* opcodes no longer need to check for stack overflow.
  • Removed execute_data->Ts field. The VM temporary variables are always allocated immediately before the execute_data structure, and are now accessed by their offset from the execute_data base pointer instead of via execute_data->Ts. The compiler stores new offsets in op_array->opcodes[*].op?.num. The EX_TMP_VAR() and EX_TMP_VAR_NUM() macros can be used to access temporary variables by offset or number. You can convert the number to an offset using EX_TMP_VAR_NUM(0, num) or offset to number using (EX_TMP_VAR_NUM(0,0)-EX_TMP_VAR(0,offset)).
  • Removed the execute_data->CVs field. The VM compiled variables are always allocated immediately after the execute_data structure, and are now accessed by the offset from the execute_data base pointer instead of via execute_data->CVs. You can use the EX_CV_NUM() macro to access compiled variables by number.
Changes to INI file handling
Migrating from PHP 5.3.x to PHP 5.4.x
Migrating from PHP 5.4.x to PHP 5.5.x


Migrating from PHP 5.3.x to PHP 5.4.x

İçindekiler

  • What has changed in PHP 5.4.x
  • Backward Incompatible Changes
  • New features
  • Changes in SAPI modules
  • Deprecated features in PHP 5.4.x
  • Changed Functions
  • New Functions
  • New Classes and Interfaces
  • New Methods
  • Removed Extensions
  • Other changes to extensions
  • New Global Constants
  • Changes to INI file handling
  • Other changes

Ayrıca, şu PHP sürümleri arasında geçiş kılavuzlarına da bakınız: 5.0.x, 5.1.x, 5.2.x, 5.3.x, 5.5.x and 5.6.x.

Changes to PHP Internals
What has changed in PHP 5.4.x
Ekler


What has changed in PHP 5.4.x

Most improvements in PHP 5.4.x have no impact on existing code. There are a few incompatibilities and new features that should be considered, and code should be tested before switching PHP versions in production environments.

For systems being upgraded from an older version of PHP, the relevant documentation is available at:

  • Upgrade Notes for PHP 5.3.x.
  • Upgrade Notes for PHP 5.2.x.
  • Upgrade Notes for PHP 5.1.x.
  • Migrating from PHP 4 to PHP 5.
Migrating from PHP 5.3.x to PHP 5.4.x
Backward Incompatible Changes
Migrating from PHP 5.3.x to PHP 5.4.x


Backward Incompatible Changes

Although most existing PHP 5 code should work without changes, please take note of some backward incompatible changes:

  • Safe mode is no longer supported. Any applications that rely on safe mode may need adjustment, in terms of security.
  • Magic quotes has been removed. Applications relying on this feature may need to be updated, to avoid security issues. get_magic_quotes_gpc() and get_magic_quotes_runtime() now always return FALSE. set_magic_quotes_runtime() raises an E_CORE_ERROR level error on trying to enable Magic quotes.
  • The register_globals and register_long_arrays php.ini directives have been removed.
  • The mbstring.script_encoding directive has been removed. Use zend.script_encoding instead.
  • Call-time pass by reference has been removed.
  • The break and continue statements no longer accept variable arguments (e.g., break 1 + foo() * $bar;). Static arguments still work, such as break 2;. As a side effect of this change break 0; and continue 0; are no longer allowed.
  • In the date and time extension, the timezone can no longer be set using the TZ environment variable. Instead you have to specify a timezone using the date.timezone php.ini option or date_default_timezone_set() function. PHP will no longer attempt to guess the timezone, and will instead fall back to "UTC" and issue a E_WARNING.
  • Non-numeric string offsets - e.g. $a['foo'] where $a is a string - now return false on isset() and true on empty(), and produce a E_WARNING if you try to use them. Offsets of types double, bool and null produce a E_NOTICE. Numeric strings (e.g. $a['2']) still work as before. Note that offsets like '12.3' and '5 foobar' are considered non-numeric and produce a E_WARNING, but are converted to 12 and 5 respectively, for backward compatibility reasons. Note: Following code returns different result. $str='abc';var_dump(isset($str['x'])); // false for PHP 5.4 or later, but true for 5.3 or less
  • Converting an array to a string will now generate an E_NOTICE level error, but the result of the cast will still be the string "Array".
  • Turning NULL, FALSE, or an empty string into an object by adding a property will now emit an E_WARNING level error, instead of E_STRICT.
  • Parameter names that shadow super globals now cause a fatal error. This prohibits code like function foo($_GET, $_POST) {}.
  • The Salsa10 and Salsa20 hash algorithms have been removed.
  • array_combine() now returns array() instead of FALSE when two empty arrays are provided as parameters.
  • If you use htmlentities() with asian character sets, it works like htmlspecialchars() - this has always been the case in previous versions of PHP, but now an E_STRICT level error is emitted.
  • The third parameter of ob_start() has changed from boolean erase to integer flags. Note that code that explicitly set erase to FALSE will no longer behave as expected in PHP 5.4: please follow this example to write code that is compatible with PHP 5.3 and 5.4.

The following keywords are now reserved, and may not be used as names by functions, classes, etc.

  • trait
  • callable
  • insteadof

The following functions have been removed from PHP:

  • define_syslog_variables()
  • import_request_variables()
  • session_is_registered(), session_register() and session_unregister().
  • The aliases
mysqli_bind_param(), mysqli_bind_result(),
mysqli_client_encoding(), mysqli_fetch(),
mysqli_param_count(), mysqli_get_metadata(),
mysqli_send_long_data(), mysqli::client_encoding() and mysqli_stmt::stmt().
What has changed in PHP 5.4.x
New features
Migrating from PHP 5.3.x to PHP 5.4.x


New features

PHP 5.4.0 offers a wide range of new features:

  • Support for traits has been added.
  • Short array syntax has been added, e.g. $a = [1, 2, 3, 4]; or $a = ['one' => 1, 'two' => 2, 'three' => 3, 'four' => 4];.
  • Function array dereferencing has been added, e.g. foo()[0].
  • Closures now support $this.
  • <?= is now always available, regardless of the short_open_tag php.ini option.
  • Class member access on instantiation has been added, e.g. (new Foo)->bar().
  • Class::{expr}() syntax is now supported.
  • Binary number format has been added, e.g. 0b001001101.
  • Improved parse error messages and improved incompatible arguments warnings.
  • The session extension can now track the upload progress of files.
  • Built-in development web server in CLI mode.
Backward Incompatible Changes
Changes in SAPI modules
Migrating from PHP 5.3.x to PHP 5.4.x


Changes in SAPI modules

  • A new SAPI module named cli-server is now available.
  • Added CLI option --rz which shows information of the named Zend extension.
  • Added shortcut #inisetting=value to change php.ini settings at run-time in interactive readline CLI
  • Added apache compatible functions: apache_child_terminate(),
getallheaders(), apache_request_headers()
and apache_response_headers() for FastCGI SAPI.
  • PHP-FPM: Added the process.max setting, to control the number of processes that FPM can fork.
New features
Deprecated features in PHP 5.4.x
Migrating from PHP 5.3.x to PHP 5.4.x


Deprecated features in PHP 5.4.x

Deprecated functions:

  • mysql_list_dbs()
Changes in SAPI modules
Changed Functions
Migrating from PHP 5.3.x to PHP 5.4.x


Changed Functions

Several functions were given new, optional parameters in PHP 5.4:

PHP Core:

  • Added the optional limit parameter to debug_backtrace() and debug_print_backtrace(), to limit the amount of stack frames returned.
  • is_link() now works properly for symbolic links on Windows Vista or later. Earlier systems do not support symbolic links.
  • parse_url() now recognizes the host when a scheme is omitted, and a leading component separator is present. As of PHP 5.4.7.

OpenSSL:

  • Added a no padding option to the openssl_encrypt() and openssl_decrypt() functions.

Intl:

  • idn_to_ascii() and idn_to_utf8() now take two extra parameters, one indicating the variant (IDNA 2003 or UTS #46) and another, passed by reference, to return details about the operation in case UTS #46 is chosen.
Deprecated features in PHP 5.4.x
New Functions
Migrating from PHP 5.3.x to PHP 5.4.x


New Functions

PHP 5.4 introduced some new functions:

PHP Core:

  • hex2bin()
  • http_response_code()
  • get_declared_traits()
  • getimagesizefromstring()
  • stream_set_chunk_size()
  • socket_import_stream()
  • trait_exists()
  • header_register_callback()

SPL:

  • class_uses()

Session:

  • session_status()
  • session_register_shutdown()

Mysqli:

  • mysqli_error_list()
  • mysqli_stmt_error_list()

Libxml:

  • libxml_set_external_entity_loader()

LDAP:

  • ldap_control_paged_result()
  • ldap_control_paged_result_response()

Intl:

  • transliterator_create()
  • transliterator_create_from_rules()
  • transliterator_create_inverse()
  • transliterator_get_error_code()
  • transliterator_get_error_message()
  • transliterator_list_ids()
  • transliterator_transliterate()

Zlib:

  • zlib_decode()
  • zlib_encode()
Changed Functions
New Classes and Interfaces
Migrating from PHP 5.3.x to PHP 5.4.x


New Classes and Interfaces

The following classes were introduced in PHP 5.4.0:

SPL:

  • CallbackFilterIterator
  • RecursiveCallbackFilterIterator

Reflection:

  • ReflectionZendExtension

Json:

  • JsonSerializable

Session:

  • SessionHandler
  • SessionHandlerInterface

Snmp:

  • SNMP

Intl:

  • Transliterator
  • Spoofchecker
New Functions
New Methods
Migrating from PHP 5.3.x to PHP 5.4.x


New Methods

Several new methods were introduced in 5.4.0:

XSL:

  • XsltProcessor::setSecurityPrefs()
  • XsltProcessor::getSecurityPrefs()

SPL:

  • RegexIterator::getRegex()
  • SplObjectStorage::getHash()
  • DirectoryIterator::getExtension()
  • SplDoublyLinkedList::serialize()
  • SplDoublyLinkedList::unserialize()
  • SplFileInfo::getExtension()
  • SplFileObject::fputcsv()
  • SplQueue::serialize()
  • SplQueue::unserialize()
  • SplStack::serialize()
  • SplStack::unserialize()
  • SplTempFileObject::fputcsv()

Reflection:

  • ReflectionExtension::isPersistent()
  • ReflectionExtension::isTemporary()
  • ReflectionClass::isCloneable()

Closure:

  • Closure::bind()
  • Closure::bindTo()

PDO_dblib:

  • PDO::newRowset()

StreamWrapper:

  • StreamWrapper::stream_metadata()
  • StreamWrapper::stream_truncate()
New Classes and Interfaces
Removed Extensions
Migrating from PHP 5.3.x to PHP 5.4.x


Removed Extensions

These extensions have been moved to PECL and are no longer part of the PHP distribution. The PECL package versions of these extensions will be created according to user demand.

  • sqlite - Note that ext/sqlite3 and ext/pdo_sqlite are not affected
New Methods
Other changes to extensions
Migrating from PHP 5.3.x to PHP 5.4.x


Other changes to extensions

Changes in extension behavior, and new features:

  • mysqli - mysqli_result now implements Traversable
  • pdo_mysql - Removed support for linking with MySQL client libraries older than 4.1
  • The MySQL extensions mysql, mysqli and PDO_mysql use mysqlnd as the default library now. It is still possible to use libmysqlclient by specifying a path to the configure options.
  • mysqlnd - Added named pipes support
Removed Extensions
New Global Constants
Migrating from PHP 5.3.x to PHP 5.4.x


New Global Constants

PHP Core:

  • ENT_DISALLOWED
  • ENT_HTML401
  • ENT_HTML5
  • ENT_SUBSTITUTE
  • ENT_XML1
  • ENT_XHTML
  • IPPROTO_IP
  • IPPROTO_IPV6
  • IPV6_MULTICAST_HOPS
  • IPV6_MULTICAST_IF
  • IPV6_MULTICAST_LOOP
  • IP_MULTICAST_IF
  • IP_MULTICAST_LOOP
  • IP_MULTICAST_TTL
  • MCAST_JOIN_GROUP
  • MCAST_LEAVE_GROUP
  • MCAST_BLOCK_SOURCE
  • MCAST_UNBLOCK_SOURCE
  • MCAST_JOIN_SOURCE_GROUP
  • MCAST_LEAVE_SOURCE_GROUP

Curl:

  • CURLOPT_MAX_RECV_SPEED_LARGE
  • CURLOPT_MAX_SEND_SPEED_LARGE

LibXML:

  • LIBXML_HTML_NODEFDTD
  • LIBXML_HTML_NOIMPLIED
  • LIBXML_PEDANTIC

OpenSSL:

  • OPENSSL_CIPHER_AES_128_CBC
  • OPENSSL_CIPHER_AES_192_CBC
  • OPENSSL_CIPHER_AES_256_CBC
  • OPENSSL_RAW_DATA
  • OPENSSL_ZERO_PADDING

Output buffering:

  • PHP_OUTPUT_HANDLER_CLEAN
  • PHP_OUTPUT_HANDLER_CLEANABLE
  • PHP_OUTPUT_HANDLER_DISABLED
  • PHP_OUTPUT_HANDLER_FINAL
  • PHP_OUTPUT_HANDLER_FLUSH
  • PHP_OUTPUT_HANDLER_FLUSHABLE
  • PHP_OUTPUT_HANDLER_REMOVABLE
  • PHP_OUTPUT_HANDLER_STARTED
  • PHP_OUTPUT_HANDLER_STDFLAGS
  • PHP_OUTPUT_HANDLER_WRITE

Sessions:

  • PHP_SESSION_ACTIVE
  • PHP_SESSION_DISABLED
  • PHP_SESSION_NONE

Streams:

  • STREAM_META_ACCESS
  • STREAM_META_GROUP
  • STREAM_META_GROUP_NAME
  • STREAM_META_OWNER
  • STREAM_META_OWNER_NAME
  • STREAM_META_TOUCH

Zlib:

  • ZLIB_ENCODING_DEFLATE
  • ZLIB_ENCODING_GZIP
  • ZLIB_ENCODING_RAW

Intl:

  • U_IDNA_DOMAIN_NAME_TOO_LONG_ERROR
  • IDNA_CHECK_BIDI
  • IDNA_CHECK_CONTEXTJ
  • IDNA_NONTRANSITIONAL_TO_ASCII
  • IDNA_NONTRANSITIONAL_TO_UNICODE
  • INTL_IDNA_VARIANT_2003
  • INTL_IDNA_VARIANT_UTS46
  • IDNA_ERROR_EMPTY_LABEL
  • IDNA_ERROR_LABEL_TOO_LONG
  • IDNA_ERROR_DOMAIN_NAME_TOO_LONG
  • IDNA_ERROR_LEADING_HYPHEN
  • IDNA_ERROR_TRAILING_HYPHEN
  • IDNA_ERROR_HYPHEN_3_4
  • IDNA_ERROR_LEADING_COMBINING_MARK
  • IDNA_ERROR_DISALLOWED
  • IDNA_ERROR_PUNYCODE
  • IDNA_ERROR_LABEL_HAS_DOT
  • IDNA_ERROR_INVALID_ACE_LABEL
  • IDNA_ERROR_BIDI
  • IDNA_ERROR_CONTEXTJ

Json:

  • JSON_PRETTY_PRINT
  • JSON_UNESCAPED_SLASHES
  • JSON_NUMERIC_CHECK
  • JSON_UNESCAPED_UNICODE
  • JSON_BIGINT_AS_STRING
Other changes to extensions
Changes to INI file handling
Migrating from PHP 5.3.x to PHP 5.4.x


Changes to INI file handling

The following php.ini directives have been removed:

  • register_globals and register_long_arrays
  • magic_quotes_gpc, magic_quotes_runtime, and magic_quotes_sybase
  • allow_call_time_pass_reference
  • define_syslog_variables
  • highlight.bg
  • session.bug_compat_42 and session.bug_compat_warn
  • mbstring.script_encoding
  • y2k_compliance
  • safe_mode, safe_mode_gid, safe_mode_include_dir, safe_mode_exec_dir, safe_mode_allowed_env_vars, and safe_mode_protected_env_vars

The following php.ini directives have been added:

  • cli.pager and cli.prompt for CLI SAPI using readline in interactive mode.
  • cli_server.color to enable the built-in development web server to use ANSI color coding in terminal output.
  • max_input_vars - specifies how many GET/POST/COOKIE input variables may be accepted.
  • zend.multibyte - to control the new multibyte support.
  • zend.script_encoding - This value will be used unless a "declare(encoding=...)" directive appears at the top of the script.
  • zend.signal_check - to check for replaced signal handlers on shutdown.
  • session.upload_progress.enabled, session.upload_progress.cleanup, session.upload_progress.prefix, session.upload_progress.name, session.upload_progress.freq, session.upload_progress.min_freq
  • enable_post_data_reading - When it's disabled, the POST data is not read (and processed)
  • windows_show_crt_warning - This directive shows the Windows CRT warnings when enabled. These warnings were displayed by default until now.

The following php.ini. directives have been changed:

  • session.entropy_file now defaults to /dev/random or /dev/urandom depending on what has been guessed at compile time.
  • session.entropy_length now defaults to 32.
New Global Constants
Other changes
Migrating from PHP 5.3.x to PHP 5.4.x


Other changes

  • The default character set for htmlspecialchars() and htmlentities() is now UTF-8, instead of ISO-8859-1. Note that changing your output charset via the default_charset configuration setting does not affect htmlspecialchars/htmlentities unless you are passing "" (an empty string) as the encoding parameter to your htmlspecialchars()/htmlentities() calls. Generally we do not recommend doing this because you should be able to change your output charset without affecting the runtime charset used by these functions. The safest approach is to explicitly set the charset on each call to htmlspecialchars() and htmlentities().
  • E_ALL now includes E_STRICT level errors in the error_reporting configuration directive.
  • SNMP now has an OOP API. Functions now return FALSE on every error condition including SNMP-related (no such instance, end of MIB, etc). Thus, in particular, breaks previous behavior of get/walk functions returning an empty string on SNMP-related errors. Multi OID get/getnext/set queries are now supported. Dropped UCD-SNMP compatibility code, consider upgrading to net-snmp v5.3+, Net-SNMP v5.4+ is required for Windows version. In sake of adding support for IPv6 DNS name resolution of remote SNMP agent (peer) is done by extension now, not by Net-SNMP library anymore.
  • OpenSSL now supports AES.
  • CLI SAPI doesn't terminate any more on fatal errors when using interactive mode with readline support.
  • $_SERVER['REQUEST_TIME_FLOAT'] has been added to include microsecond precision.
  • Added new hash algorithms: fnv132, fnv164, joaat
  • Chained string offsets - e.g. $a[0][0] where $a is a string - now work.
  • Arrays cast from SimpleXMLElement now always contain all nodes instead of just the first matching node. All SimpleXMLElement children are now always printed when using var_dump(), var_export() and print_r().
  • It's now possible to enforce the class' __construct arguments in an abstract constructor in the base class.
Changes to INI file handling
Migrating from PHP 5.2.x to PHP 5.3.x
Migrating from PHP 5.3.x to PHP 5.4.x


Migrating from PHP 5.2.x to PHP 5.3.x

İçindekiler

  • What has changed in PHP 5.3.x
  • Backward Incompatible Changes
  • New features
  • Changes made to Windows support
  • Changes in SAPI modules
  • Deprecated features in PHP 5.3.x
  • Undeprecated features in PHP 5.3.x
  • New Parameters
  • New Functions
  • New stream wrappers
  • New stream filters
  • New Class Constants
  • New Methods
  • New Extensions
  • Removed Extensions
  • Other changes to extensions
  • New Classes
  • New Global Constants
  • Changes to INI file handling
  • Other changes

Ayrıca, şu PHP sürümleri arasında geçiş kılavuzlarına da bakınız: 5.0.x, 5.1.x, 5.2.x, 5.4.x, 5.5.x and 5.6.x.

Other changes
What has changed in PHP 5.3.x
Ekler


What has changed in PHP 5.3.x

Most improvements in PHP 5.3.x have no impact on existing code. There are a few incompatibilities and new features that should be considered, and code should be tested before switching PHP versions in production environments.

For systems being upgraded from an older version of PHP, the relevant documentation is available at:

  • Upgrade Notes for PHP 5.2.x.
  • Upgrade Notes for PHP 5.1.x.
  • Migrating from PHP 4 to PHP 5.
Migrating from PHP 5.2.x to PHP 5.3.x
Backward Incompatible Changes
Migrating from PHP 5.2.x to PHP 5.3.x


Backward Incompatible Changes

Although most existing PHP 5 code should work without changes, please take note of some backward incompatible changes:

  • The newer internal parameter parsing API has been applied across all the extensions bundled with PHP 5.3.x. This parameter parsing API causes functions to return NULL when passed incompatible parameters. There are some exceptions to this rule, such as the get_class() function, which will continue to return FALSE on error.
  • clearstatcache() no longer clears the realpath cache by default.
  • realpath() is now fully platform-independent. Consequence of this is that invalid relative paths such as __FILE__ . "/../x" do not work anymore.
  • The call_user_func() family of functions now propagate $this even if the callee is a parent class.
  • The array functions natsort(),
natcasesort(), usort(),
uasort(), uksort(),
array_flip(), and array_unique() no
longer accept objects passed as arguments. To apply these functions to an
object, cast the object to an array first.
  • The behaviour of functions with by-reference parameters called by value has changed. Where previously the function would accept the by-value argument, a fatal error is now emitted. Any previous code passing constants or literals to functions expecting references, will need altering to assign the value to a variable before calling the function.
  • The new mysqlnd library necessitates the use of MySQL 4.1's newer 41-byte password format. Continued use of the old 16-byte passwords will cause mysql_connect() and similar functions to emit the error, "mysqlnd cannot connect to MySQL 4.1+ using old authentication."
  • The new mysqlnd library does not read mysql configuration files (my.cnf/my.ini), as the older libmysqlclient library does. If your code relies on settings in the configuration file, you can load it explicitly with the mysqli_options() function. Note that this means the PDO specific constants PDO::MYSQL_ATTR_READ_DEFAULT_FILE and PDO::MYSQL_ATTR_READ_DEFAULT_GROUP are not defined if MySQL support in PDO is compiled with mysqlnd.
  • The trailing / has been removed from the SplFileInfo class and other related directory classes.
  • The __toString() magic method can no longer accept arguments.
  • The magic methods
__get(),
__set(),
__isset(),
__unset(), and
__call() must always
be public and can no longer be static. Method signatures are now enforced.
  • The __call() magic method is now invoked on access to private and protected methods.
  • func_get_arg(), func_get_args() and func_num_args() can no longer be called from the outermost scope of a file that has been included by calling include or require from within a function in the calling file.
  • An emulation layer for the MHASH extension to wrap around the Hash extension have been added. However not all the algorithms are covered, notable the s2k hashing algorithm. This means that s2k hashing is no longer available as of PHP 5.3.0.

The following keywords are now reserved and may not be used in function, class, etc. names.

  • goto
  • namespace
What has changed in PHP 5.3.x
New features
Migrating from PHP 5.2.x to PHP 5.3.x


New features

PHP 5.3.0 offers a wide range of new features:

  • Support for namespaces has been added.
  • Support for Late Static Bindings has been added.
  • Support for jump labels (limited goto) has been added.
  • Support for native Closures (Lambda/Anonymous functions) has been added.
  • There are two new magic methods, __callStatic() and __invoke().
  • Nowdoc syntax is now supported, similar to Heredoc syntax, but with single quotes.
  • It is now possible to use Heredocs to initialize static variables and class properties/constants.
  • Heredocs may now be declared using double quotes, complementing the Nowdoc syntax.
  • Constants can now be declared outside a class using the const keyword.
  • The ternary operator now has a shorthand form: ?:.
  • The HTTP stream wrapper now considers all status codes from 200 to 399 to be successful.
  • Dynamic access to static methods is now possible:
    <?php
    class C {
       public static     $foo = 123;
    }

    $a = "C";
    echo     $a::$foo;
    ?>

    Yukarıdaki örneğin çıktısı:

    123
  • Exceptions can now be nested:
    <?php
    class MyCustomException extends Exception {}

    try {
        throw new     MyCustomException("Exceptional", 112);
    } catch (    Exception $e) {
            /* Note the use of the third parameter to pass $e
         * into the RuntimeException. */
            throw new RuntimeException("Rethrowing", 911, $e);
    }
    ?>
  • A garbage collector for circular references has been added, and is enabled by default.
  • The mail() function now supports logging of sent email via the mail.log configuration directive. (Note: This only applies to email sent through this function.)
Backward Incompatible Changes
Changes made to Windows support
Migrating from PHP 5.2.x to PHP 5.3.x


Changes made to Windows support

Changes to the Windows releases:

  • The minimum Windows version is now Windows XP SP3; Windows 98, ME, 2000 and NT4 are no longer supported.
  • Windows binaries now target i586 and later. i386 and i486 are not supported.
  • There is now experimental support for x64 versions of PHP on Windows.
  • There is now compiler support for Visual C++ 9 (VC9), using Visual Studio 2008. Snapshots and releases will now also be available for VC9. Old binaries using VC6 are still supported and released in the line with VC9.
  • The PDO_OCI php_pdo_oci8.dll library (for use with Oracle version 8 client libraries) is no longer being built. Instead, use php_pdo_oci.dll (note no '8') with Oracle 10 or 11 client libraries. Connection to other database versions is still supported.
  • For the OCI8 extension, a new library php_oci8_11g.dll is available in addition to php_oci8.dll. Only one can be enabled at any time. Use php_oci8.dll with Oracle 10.2 client libraries. Use php_oci8_11g.dll with Oracle 11 or later client libraries. Connection to other database versions is still supported.

Windows support has been added for the following functions:

  • checkdnsrr()
  • dns_get_record()
  • fnmatch()
  • getmxrr()
  • getopt()
  • imagecolorclosesthwb()
  • inet_ntop()
  • inet_pton()
  • link()
  • linkinfo()
  • mcrypt_create_iv()
  • readlink()
  • socket_create_pair() - This function was previously available on Windows, but was disabled as of PHP 4.3.0 due to a bug.
  • stream_socket_pair()
  • symlink()
  • time_nanosleep()
  • time_sleep_until()

Other changes:

  • Improved portability of the stat(), touch(), filemtime(), filesize() functions, and other related functions (100% portable for the available data).
  • It is now possible to create hard links on Windows using the link() function, and symbolic links using the symlink() function. Hard links are available as of Windows 2000, and symbolic links as of Windows Vista.
  • The Windows version of PHP now exposes a set of constants prefixed PHP_WINDOWS_*. A list of these constants and their usage can be found at Öntanımlı Sabitler.
Uyarı

Support for the ISAPI module has been dropped. Use the improved FastCGI SAPI module instead.

Bilginize: A new dedicated site for PHP on Windows is now available, including downloads, release candidates, and snapshots in various flavors (thread-safe/not-thread-safe, VC6/VC9, x86/x64). The URL of this site is » http://windows.php.net/.

New features
Changes in SAPI modules
Migrating from PHP 5.2.x to PHP 5.3.x


Changes in SAPI modules

  • A new SAPI module named litespeed is now available.
  • FastCGI support in the CGI SAPI is now always enabled and can not be disabled. See sapi/cgi/CHANGES for more details.
  • A new CGI SAPI option, -T, can be used to measure repeated execution time of a script.
  • CGI/FastCGI now has support for .htaccess-style user-defined php.ini files.
  • The dl() function is now disabled by default, and is now available only under the CLI, CGI, and embed SAPIs.
Changes made to Windows support
Deprecated features in PHP 5.3.x
Migrating from PHP 5.2.x to PHP 5.3.x


Deprecated features in PHP 5.3.x

PHP 5.3.0 introduces two new error levels: E_DEPRECATED and E_USER_DEPRECATED. The E_DEPRECATED error level is used to indicate that a function or feature has been deprecated. The E_USER_DEPRECATED level is intended for indicating deprecated features in user code, similarly to the E_USER_ERROR and E_USER_WARNING levels.

The following is a list of deprecated INI directives. Use of any of these INI directives will cause an E_DEPRECATED error to be thrown at startup.

  • define_syslog_variables
  • register_globals
  • register_long_arrays
  • safe_mode
  • magic_quotes_gpc
  • magic_quotes_runtime
  • magic_quotes_sybase
  • Comments starting with '#' are now deprecated in .INI files.

Deprecated functions:

  • call_user_method() (use call_user_func() instead)
  • call_user_method_array() (use call_user_func_array() instead)
  • define_syslog_variables()
  • dl()
  • ereg() (use preg_match() instead)
  • ereg_replace() (use preg_replace() instead)
  • eregi() (use preg_match() with the 'i' modifier instead)
  • eregi_replace() (use preg_replace() with the 'i' modifier instead)
  • mcrypt_generic_end()
  • set_magic_quotes_runtime() and its alias, magic_quotes_runtime()
  • session_register() (use the $_SESSION superglobal instead)
  • session_unregister() (use the $_SESSION superglobal instead)
  • session_is_registered() (use the $_SESSION superglobal instead)
  • set_socket_blocking() (use stream_set_blocking() instead)
  • split() (use preg_split() instead)
  • spliti() (use preg_split() with the 'i' modifier instead)
  • sql_regcase()
  • mysql_db_query() (use mysql_select_db() and mysql_query() instead)
  • mysql_escape_string() (use mysql_real_escape_string() instead)
  • Passing locale category names as strings is now deprecated. Use the LC_* family of constants instead.
  • The is_dst parameter to mktime(). Use the new timezone handling functions instead.

Deprecated features:

  • Assigning the return value of new by reference is now deprecated.
  • Call-time pass-by-reference is now deprecated.
Changes in SAPI modules
Undeprecated features in PHP 5.3.x
Migrating from PHP 5.2.x to PHP 5.3.x


Undeprecated features in PHP 5.3.x

The is_a() function has been undeprecated by popular request; it will no longer issue an E_STRICT error.

Deprecated features in PHP 5.3.x
New Parameters
Migrating from PHP 5.2.x to PHP 5.3.x


New Parameters

Several functions were given new, optional parameters in PHP 5.3:

PHP Core:

  • clearstatcache() - Added clear_realpath_cache and filename.
  • copy() - Added a stream context parameter, context.
  • fgetcsv() - Added escape.
  • ini_get_all() - Added details.
  • nl2br() - Added is_xhtml.
  • parse_ini_file() - Added scanner_mode.
  • round() - Added mode.
  • stream_context_create() - Added params.
  • strstr() and stristr() - Added before_needle.

json:

  • json_encode() - Added options.
  • json_decode() - Added depth.

Streams:

  • stream_select(),
stream_set_blocking(),
stream_set_timeout(), and
stream_set_write_buffer() now work with user-space
stream wrappers.

sybase_ct:

  • sybase_connect() - Added new.

New method parameters in PHP 5.3.0:

PHP Core:

  • Exception::__construct() - Added previous.
Undeprecated features in PHP 5.3.x
New Functions
Migrating from PHP 5.2.x to PHP 5.3.x


New Functions

PHP 5.3 introduced some new functions:

PHP Core:

  • array_replace() - Replaces elements from passed arrays into one array.
  • array_replace_recursive() - Recursively replaces elements from passed arrays into one array.
  • class_alias() - Creates an alias for a user defined class.
  • forward_static_call() - Call a user function from a method context.
  • forward_static_call_array() - Call a user function from a method context, with the arguments contained in an array.
  • gc_collect_cycles() - Forces collection of any existing garbage cycles.
  • gc_disable() - Deactivates the circular reference collector.
  • gc_enable() - Activates the circular reference collector.
  • gc_enabled() - Returns the status of the circular reference collector.
  • get_called_class() - Return the name of the class a static method is called in.
  • gethostname() - Return the current host name for the local machine.
  • header_remove() - Removes an HTTP header previously set using the header() function.
  • lcfirst() - Make a string's first character lowercase.
  • parse_ini_string() - Parse a configuration string.
  • quoted_printable_encode() - Convert an 8 bit string to a quoted-printable string.
  • str_getcsv() - Parse a CSV string into an array.
  • stream_context_set_default() - Set the default stream context.
  • stream_supports_lock() - Return TRUE if the stream supports locking.
  • stream_context_get_params() - Retrieve parameters from a stream context.
  • streamWrapper::stream_cast() - Retrieve the underlying stream resource.
  • streamWrapper::stream_set_option() - Change stream options

Date/Time:

  • date_add() - Adds an amount of days, months, years, hours, minutes and seconds to a DateTime object.
  • date_create_from_format() - Returns a new DateTime object formatted according to the given format.
  • date_diff() - Returns the difference between two DateTime objects.
  • date_get_last_errors() - Returns the warnings and errors from the last date/time operation.
  • date_parse_from_format() - Get information about a given date.
  • date_sub() - Subtracts an amount of days, months, years, hours, minutes and seconds from a DateTime object.
  • timezone_version_get() - Returns the version of the timezonedb.

GMP:

  • gmp_testbit() - Tests whether a bit is set.

Hash:

  • hash_copy() - Copy hashing context.

IMAP:

  • imap_gc() - Clears IMAP cache.
  • imap_utf8_to_mutf7() - Encode a UTF-8 string to modified UTF-7.
  • imap_mutf7_to_utf8() - Decode a modified UTF-7 string to UTF-8.

JSON:

  • json_last_error() - Returns the last JSON error that occurred.

MySQL Improved:

  • mysqli_fetch_all() - Fetches all result rows as an associative array, a numeric array, or both.
  • mysqli_get_connection_stats() - Returns statistics about the client connection.
  • mysqli_poll() - Poll connections.
  • mysqli_reap_async_query() - Get result from async query.

OpenSSL:

  • openssl_random_pseudo_bytes() - Returns a string of the given length specified, filled with pseudo-random bytes.

PCNTL:

  • pcntl_signal_dispatch() - Calls signal handlers for pending signals.
  • pcntl_sigprocmask() - Sets and retrieves blocked signals.
  • pcntl_sigtimedwait() - Wait for signals with a timeout.
  • pcntl_sigwaitinfo() - Wait for signals.

PCRE:

  • preg_filter() - Perform a regular expression search and replace, returning only results which matched the pattern.

Semaphore:

  • msg_queue_exists() - Check whether a message queue exists.
  • shm_has_var() - Checks whether a specific key exists inside a shared memory segment.

The following functions are now natively implemented, making them available on all operating systems which can run PHP:

  • acosh()
  • asinh()
  • atanh()
  • expm1()
  • log1p()
New Parameters
New stream wrappers
Migrating from PHP 5.2.x to PHP 5.3.x


New stream wrappers

The following stream wrappers were introduced in 5.3.0:

  • glob://
  • phar://
New Functions
New stream filters
Migrating from PHP 5.2.x to PHP 5.3.x


New stream filters

The following stream filters were introduced in 5.3.0:

  • dechunk (reverses HTTP chunked encoding)
  • The bz2.decompress filter now supports concatenation.
New stream wrappers
New Class Constants
Migrating from PHP 5.2.x to PHP 5.3.x


New Class Constants

Several new class constants were introduced in 5.3.0:

PDO_FIREBIRD:

  • PDO::FB_ATTR_DATE_FORMAT - Sets the format for dates.
  • PDO::FB_ATTR_TIME_FORMAT - Sets the format for time.
  • PDO::FB_ATTR_TIMESTAMP_FORMAT - Sets the format for timestamps.
New stream filters
New Methods
Migrating from PHP 5.2.x to PHP 5.3.x


New Methods

Several new methods were introduced in 5.3.0:

Date/Time:

  • DateTime::add() - Adds an amount of days, months, years, hours, minutes and seconds to a DateTime object.
  • DateTime::createFromFormat() - Returns a new DateTime object formatted according to the given format.
  • DateTime::diff() - Returns the difference between two DateTime objects.
  • DateTime::getLastErrors() - Returns the warnings and errors from the last date/time operation.
  • DateTime::sub() - Subtracts an amount of days, months, years, hours, minutes and seconds from a DateTime object.

Exception:

  • Exception::getPrevious() - Retrieves the previous exception.

DOM:

  • DOMNode::getLineNo() - Get the line number of a parsed node.

PDO_FIREBIRD:

  • PDO::setAttribute() - Sets an attribute.

Reflection:

  • ReflectionClass::getNamespaceName() - Returns the name of namespace where this class is defined.
  • ReflectionClass::getShortName() - Returns the short name of this class (without namespace part).
  • ReflectionClass::inNamespace() - Returns whether this class is defined in a namespace.
  • ReflectionFunction::getNamespaceName() - Returns the name of namespace where this function is defined.
  • ReflectionFunction::getShortName() - Returns the short name of the function (without namespace part).
  • ReflectionFunction::inNamespace() - Returns whether this function is defined in a namespace.
  • ReflectionProperty::setAccessible() - Sets whether non-public properties can be requested.

SPL:

  • SplObjectStorage::addAll() - Add all elements from another SplObjectStorage object.
  • SplObjectStorage::removeAll() - Remove all elements from another SplObjectStorage object.

XSL:

  • XSLTProcessor::setProfiling() - Sets the profiling output file.
New Class Constants
New Extensions
Migrating from PHP 5.2.x to PHP 5.3.x


New Extensions

The following new extensions are added (by default) as of PHP 5.3.0:

  • Enchant - An abstraction layer above various spelling libraries
  • Fileinfo - An improved and more solid replacement, featuring full BC, for the Mimetype extension, which has been removed.
  • INTL - Internationalization extension. INTL is a wrapper around the » ICU library.
  • Phar - Implementation of PHP-Archive files.
  • SQLite3 - Support for SQLite version 3 databases.

mysqlnd is a new core library shipped with PHP. It is a PHP-specific replacement for libmysqlclient. mysqlnd will be used to build the mysql, mysqli and PDO_MySQL extensions if libmysqlclient isn't found on the system. It may also be used instead of libmysqlclient even when libmysqlclient is present. mysqlnd is recommended for all PHP installations for performance reasons.

New Methods
Removed Extensions
Migrating from PHP 5.2.x to PHP 5.3.x


Removed Extensions

These extensions have been moved to PECL and are no longer part of the PHP distribution. The PECL package versions of these extensions will be created according to user demand.

  • dbase - No longer maintained
  • fbsql - No longer maintained
  • fdf - Maintained
  • ming - Maintained
  • msql - No longer maintained
  • ncurses - Maintained
  • sybase - Discontinued; use the sybase_ct extension instead
  • mhash - Discontinued; use the hash extension instead. hash has full mhash compatibility; all existing applications using the old functions will continue to work.
New Extensions
Other changes to extensions
Migrating from PHP 5.2.x to PHP 5.3.x


Other changes to extensions

The following extensions can no longer be disabled during build configuration:

  • PCRE
  • Reflection
  • SPL

Changes in extension behaviour, and new features:

  • Date and Time - The TZ environment variable is no longer used to guess the timezone
  • cURL - cURL now supports SSH
  • Network - dns_check_record() now returns an extra "entries" index, containing the TXT elements.
  • Hash - The SHA-224 and salsa hash algorithms are now supported.
  • mbstring - Now supports CP850 encoding.
  • OCI8 - A call to oci_close() on a persistent connection, or a variable referencing a persistent connection going out of scope, will now roll back any uncommitted transaction. To avoid unexpected behavior, explicitly issue a commit or roll back as needed. The old behavior can be enabled with the INI directive oci8.old_oci_close_semantics. Database Resident Connection Pooling (DRCP) and Fast Application Notification (FAN) are now supported. Oracle External Authentication is now supported (except on Windows). The oci_bind_by_name() function now supports SQLT_AFC (aka the CHAR datatype).
  • OpenSSL - OpenSSL digest and cipher functions are now supported. It is also now possible to access the internal values of DSA, RSA and DH keys.
  • Session - Sessions will no longer store session-files in "/tmp" when open_basedir restrictions apply, unless "/tmp" is explicitly added to the list of allowed paths.
  • SOAP Now supports sending user supplied HTTP headers.
  • MySQLi Now supports persistent connections, by prepending the hostname with "p:".
  • Image Processing and GD The "JPG Support" index returned from gd_info() has been renamed to "JPEG Support".
Removed Extensions
New Classes
Migrating from PHP 5.2.x to PHP 5.3.x


New Classes

The following classes were introduced in PHP 5.3.0:

Date/Time:

  • DateInterval
  • DatePeriod

Phar:

  • Phar
  • PharData
  • PharException
  • PharFileInfo

SPL:

  • FilesystemIterator
  • GlobIterator
  • MultipleIterator
  • RecursiveTreeIterator
  • SplDoublyLinkedList
  • SplFixedArray
  • SplHeap
  • SplMaxHeap
  • SplMinHeap
  • SplPriorityQueue
  • SplQueue
  • SplStack
Other changes to extensions
New Global Constants
Migrating from PHP 5.2.x to PHP 5.3.x


New Global Constants

PHP Core:

  • __DIR__
  • __NAMESPACE__
  • E_DEPRECATED
  • E_USER_DEPRECATED
  • INI_SCANNER_NORMAL
  • INI_SCANNER_RAW
  • PHP_MAXPATHLEN
  • PHP_WINDOWS_NT_DOMAIN_CONTROLLER
  • PHP_WINDOWS_NT_SERVER
  • PHP_WINDOWS_NT_WORKSTATION
  • PHP_WINDOWS_VERSION_BUILD
  • PHP_WINDOWS_VERSION_MAJOR
  • PHP_WINDOWS_VERSION_MINOR
  • PHP_WINDOWS_VERSION_PLATFORM
  • PHP_WINDOWS_VERSION_PRODUCTTYPE
  • PHP_WINDOWS_VERSION_SP_MAJOR
  • PHP_WINDOWS_VERSION_SP_MINOR
  • PHP_WINDOWS_VERSION_SUITEMASK

cURL:

  • CURLOPT_PROGRESSFUNCTION

GD:

  • IMG_FILTER_PIXELATE

JSON:

  • JSON_ERROR_CTRL_CHAR
  • JSON_ERROR_DEPTH
  • JSON_ERROR_NONE
  • JSON_ERROR_STATE_MISMATCH
  • JSON_ERROR_SYNTAX
  • JSON_FORCE_OBJECT
  • JSON_HEX_TAG
  • JSON_HEX_AMP
  • JSON_HEX_APOS
  • JSON_HEX_QUOT

LDAP:

  • LDAP_OPT_NETWORK_TIMEOUT

libxml:

  • LIBXML_LOADED_VERSION

PCRE:

  • PREG_BAD_UTF8_OFFSET_ERROR

PCNTL:

  • BUS_ADRALN
  • BUS_ADRERR
  • BUS_OBJERR
  • CLD_CONTIUNED
  • CLD_DUMPED
  • CLD_EXITED
  • CLD_KILLED
  • CLD_STOPPED
  • CLD_TRAPPED
  • FPE_FLTDIV
  • FPE_FLTINV
  • FPE_FLTOVF
  • FPE_FLTRES
  • FPE_FLTSUB
  • FPE_FLTUND
  • FPE_INTDIV
  • FPE_INTOVF
  • ILL_BADSTK
  • ILL_COPROC
  • ILL_ILLADR
  • ILL_ILLOPC
  • ILL_ILLOPN
  • ILL_ILLTRP
  • ILL_PRVOPC
  • ILL_PRVREG
  • POLL_ERR
  • POLL_HUP
  • POLL_IN
  • POLL_MSG
  • POLL_OUT
  • POLL_PRI
  • SEGV_ACCERR
  • SEGV_MAPERR
  • SI_ASYNCIO
  • SI_KERNEL
  • SI_MESGQ
  • SI_NOINFO
  • SI_QUEUE
  • SI_SIGIO
  • SI_TIMER
  • SI_TKILL
  • SI_USER
  • SIG_BLOCK
  • SIG_SETMASK
  • SIG_UNBLOCK
  • TRAP_BRKPT
  • TRAP_TRACE
New Classes
Changes to INI file handling
Migrating from PHP 5.2.x to PHP 5.3.x


Changes to INI file handling

PHP 5.3.0 has significantly improved performance and parsing of INI files, and adds several new syntax features.

  • The standard php.ini files have been re-organized and renamed. php.ini-development contains settings recommded for use in development environments. php.ini-production contains settings recommended for use in production environments.
  • There is now support for two special sections: [PATH=/opt/httpd/www.example.com/] and [HOST=www.example.com]. Directives set in these sections cannot be overridden by user-defined INI files or at runtime. More information about these sections can be found here.
  • zend_extension_debug, zend_extension_debug_ts and zend_extension_ts have been removed. Use the zend_extension directive to load all Zend Extensions.
  • zend.ze1_compatibility_mode has been removed. If this INI directive is set to On, an E_ERROR error is emitted at startup.
  • It is now possible to use the full path to load modules using the extension directive.
  • "ini-variables" can now be used almost anywhere in a php.ini file.
  • open_basedir restrictions may now be tighted at runtime, and the directive is now PHP_INI_ALL.
  • It is now possible to use alphanumeric or variable indices in INI option arrays.
  • get_cfg_var() is now able to return "array" INI options.
  • Two new mail directives: mail.add_x_header and mail.log, have been added.

The following new ini directives have been added:

  • user_ini.filename and user_ini.cache_ttl have been added to control the use of user INI files.
  • exit_on_timeout has been added to force Apache 1.x children to exit if a PHP execution timeout occurs.
  • Added mbstring.http_output_conv_mimetype. This directive specifies the regex pattern of content types for which mb_output_handler() is activated.
  • Added request_order. Allows controlling which external variables will be available in $_REQUEST.

The following ini directives have new default values:

  • session.use_only_cookies is now set to "1" (enabled) by default.
  • oci8.default_prefetch has changed from "10" to "100".
New Global Constants
Other changes
Migrating from PHP 5.2.x to PHP 5.3.x


Other changes

  • SplFileInfo::getpathinfo() now returns information about the path name.
  • SplObjectStorage now has ArrayAccess support. It is now also possible to store associative information with objects in SplObjectStorage.
  • In the GD extension, there is now pixelation support available through the imagefilter() function.
  • var_dump() output now includes private object properties.
  • session_start() now returns FALSE when session startup fails.
  • property_exists() now checks the existence of a property independent of accessibility (like method_exists()).
  • Stream wrappers can now be used by include_path.
  • The initial parameter for array_reduce() can now be of any type.
  • The directory functions opendir(), scandir(), and dir() now use the default stream context if no explicit context is passed.
  • crypt() now has Blowfish and extended DES support, and crypt() features are now 100% portable. PHP has its own internal crypt implementation which drops into place when support for crypt or crypt_r is not found.
  • getopt() now accepts "long options" on all platforms. Optional values and = as a separator for short options are now supported.
  • fopen() has a new mode option (n), which passes O_NONBLOCK to the underlying open() system call. Note that this mode is not currently supported on Windows.
  • getimagesize() now supports icon files (.ico).
  • The mhash extension have moved to PECL, but the Hash extension have been modified to support mhash if PHP is compiled with --with-mhash. Note that the Hash extension does not require the mhash library to be available whether or not the mhash emulation is enabled.
Changes to INI file handling
Migrating from PHP 5.1.x to PHP 5.2.x
Migrating from PHP 5.2.x to PHP 5.3.x


Migrating from PHP 5.1.x to PHP 5.2.x

İçindekiler

  • What has changed in PHP 5.2.x
  • Backward Incompatible Changes
  • New Error Messages
  • Changes in PHP datetime support
  • New Parameters
  • New Functions
  • New Methods
  • Removed Extensions
  • New Extensions
  • New Classes
  • New Global Constants
  • New Class Constants
  • New INI Configuration Directives
  • Error Reporting
  • Other Enhancements

Ayrıca, şu PHP sürümleri arasında geçiş kılavuzlarına da bakınız: 5.0.x, 5.1.x, 5.3.x, 5.4.x, 5.5.x and 5.6.x.

Other changes
What has changed in PHP 5.2.x
Ekler


What has changed in PHP 5.2.x

Most improvements in PHP 5.2.x have no impact on existing code. There are a few incompatibilities and new error messages that should be considered, and code should be tested before switching PHP versions in production environments.

If the system is being upgraded from PHP 5.0.x, the manual section titled Upgrade Notes for PHP 5.1.x should also be read.

Similarly, if the system is being upgraded from PHP 4, the manual section titled Migrating from PHP 4 to PHP 5 should be read as well.

Migrating from PHP 5.1.x to PHP 5.2.x
Backward Incompatible Changes
Migrating from PHP 5.1.x to PHP 5.2.x


Backward Incompatible Changes

Although most existing PHP 5 code should work without changes, you should pay attention to the following backward incompatible changes:

  • getrusage() returns NULL when passed incompatible arguments as of PHP 5.2.1.
  • ZipArchive::setCommentName() returns TRUE on success as of PHP 5.2.1.
  • ZipArchive::setCommentIndex() returns TRUE on success as of PHP 5.2.1.
  • SplFileObject::getFilename() returns the filename, not relative/path/to/file, as of PHP 5.2.1.
  • Changed priority of PHPRC environment variable on Win32 The PHPRC environment variable now takes priority over the path stored in the Windows registry.
  • CLI SAPI no longer checks cwd for php.ini or the php-cli.ini file In PHP 5.1.x an undocumented feature was added that made the CLI binary check the current working directory for a PHP configuration file, potentially leading to unpredictable behavior if an unexpected configuration file were read. This functionality was removed in 5.2.0, and PHP will no longer search CWD for the presence of php.ini or php-cli.ini files. See also the command line section of the manual.
  • Added a warning when performing modulus 0 operations In earlier versions of PHP, performing integer % 0 did not emit any warning messages, instead returning an unexpected return value of FALSE. As of PHP 5.2.0, this operation will emit an E_WARNING, as is the case in all other instances where division by zero is performed.
    <?php
    print 10 % 0;
    /* Warning:  Division by zero in filename on line n */
    ?>
  • Changed __toString() to be called wherever applicable. The magic method __toString() will now be called in a string context, that is, anywhere an object is used as a string. The fallback of returning a string that contains the object identifier was dropped in PHP 5.2.0. It became problematic because an object identifier cannot be considered unique. This change will mean that your application is flawed if you have relied on the object identifier as a return value. An attempt to use that value as a string will now result in a catchable fatal error.
    <?php
    class foo {}
    $foo = new foo;
    print     $foo;
    /* Catchable fatal error:  Object of class foo could
       not be converted to string in filename on line n */
    ?>
    Even with __toString(), objects cannot be used as array indices or keys. We may add built-in hash support for this at a later date, but as of PHP 5.2.x you will need to either provide your own hashing or use the new SPL function spl_object_hash(). Exceptions can not be thrown from __toString() methods.
    <?php
    class foo {
        public function     __toString() {
            throw new     Exception;
        }
    }

    try {
        print new     foo;
            /* Fatal error:  Method foo::__toString() must
           not throw an exception in filename on line n */
    } catch(Exception $e) {}
    ?>
  • Dropped abstract static class functions. Due to an oversight, PHP 5.0.x and 5.1.x allowed abstract static functions in classes. As of PHP 5.2.x, only interfaces can have them.
    <?php
    abstract class foo {
        abstract static function     bar();
            /* Strict Standards:  Static function foo::bar()
           should not be abstract in filename on line n */
    }
    ?>
  • Oracle extension requires at least Oracle 10 on Windows.
  • Added RFC2397 (data: stream) support. The introduction of the 'data' URL scheme has the potential to lead to a change of behavior under Windows. If you are working with a NTFS file system and making use of meta streams in your application, and if you just happen to be using a file with the name 'data:' that is accessed without any path information - it won't work any more. The fix is to use the 'file:' protocol when accessing it. See also » RFC 2397
    <?php
    /* when allow_url_include is OFF (default) */
    include "data:;base64,PD9waHAgcGhwaW5mbygpOz8+";
    /* Warning:  include(): URL file-access is disabled
       in the server configuration in filename on line n */
    ?>
  • Regression in glob() patterns In version 5.2.4 a security fix caused a regression for patterns of the form "/foo/*/bar/*". Since version 5.2.5 instead of raising a warning the glob() function will return FALSE when openbase_dir restrictions are violated.
What has changed in PHP 5.2.x
New Error Messages
Migrating from PHP 5.1.x to PHP 5.2.x


New Error Messages

Below are the new error messages that have not been discussed elsewhere in this document.

Örnek 1 In PHP Core

<?php
echo " ";
session_regenerate_id();
/*  Warning:  session_regenerate_id(): Cannot regenerate
    session id - headers already sent in filename on line n */

str_word_count("string", 4);
/* Warning:  str_word_count(): Invalid format value 4
   in filename on line n */

strripos("foo", "f", 4);
/* Notice:  strripos(): Offset is greater than the
   length of haystack string in filename on line n */

strrpos("foo", "f", 4);
/* Notice:  strrpos(): Offset is greater than the
   length of haystack string in filename on line n */

/* As of PHP 5.2.1, when allow_url_include is OFF (default) */
include "php://input";
/* Warning:  include(): URL file-access is disabled
   in the server configuration in filename on line n */
?>

Örnek 2 Object Oriented Code in PHP Core

<?php
interface foo {
}
class bar implements foo, foo {
}
/* Fatal error: Class bar cannot implement previously
   implemented interface foo in filename on line n */

class foo {
    public $bar;
    function __get($var)
    {
        return $this->bar;
    }
}

$foo = new foo;
$bar =& $foo->prop;
/* Notice: Indirect modification of overloaded property
   foo::$prop has no effect in filename on line n */

class foo implements iterator {
    public function current() {
    }
    public function next() {
    }
    public function key() {
    }
    public function valid() {
    }
    public function rewind() {
    }
}

$foo = new foo();
foreach($foo as &$ref) {}
/* Fatal error: An iterator cannot be used with foreach
   by reference in filename on line n */

class foo {
    private function __construct() {
    }
}
class bar extends foo {
    public function __construct() {
        parent::__construct();
        /* Fatal error:  Cannot call private
           foo::__construct() in filename on line n */
    }
}
new bar;

stream_filter_register("", "class");
/* Warning:  stream_filter_register(): Filter name
   cannot be empty in filename on line n */

stream_filter_register("filter", "");
/* Warning:  stream_filter_register(): Class name
   cannot be empty in filename on line n */
?>

Örnek 3 In the bzip2 Extension

<?php
bzopen("", "w");
/* Warning:  bzopen(): filename cannot be empty
   in filename on line n */

bzopen("foo", "a");
/* Warning:  bzopen(): 'a' is not a valid mode for
   bzopen(). Only 'w' and 'r' are supported in
   filename on line n */

$fp = fopen("foo", "w");
bzopen($fp, "r");
/* Warning:  bzopen(): cannot read from a stream
   opened in write only mode in filename on line n */
?>

Örnek 4 In the datetime Extension

<?php
strtotime("today", "now");
/* Warning:  strtotime() expects parameter 2 to be
   long, string given in filename on line n */

/* As of PHP 5.2.1 */
new DateTime(new stdclass);
/* Fatal error: Uncaught exception 'Exception' with
   message 'DateTime::__construct() expects parameter
   1 to be string, object given' in filename:n */
?>

Örnek 5 In the dBase Extension

<?php
dbase_open("foo", -1);
/* Warning: Invalid access mode -1 in filename on line n */

/* As of PHP 5.2.1 */
dbase_open("foo", null);
/* Warning: The filename cannot be empty in filename on line n */
?>

Örnek 6 In the mcrypt Extension

<?php
$key = "this is a secret key";
$td = mcrypt_module_open('tripledes', '', 'ecb', '');
$iv = mcrypt_create_iv (mcrypt_enc_get_iv_size($td),
                        MCRYPT_RAND);
mcrypt_generic_init($td, $key, $iv);
$encrypted_data = mcrypt_generic($td, "");
/* Warning: mcrypt_generic(): An empty string was
   passed in filename on line n */
?>

Örnek 7 In the oci8 Extension

<?php
oci_connect("user", "pass", "db", "bogus_charset");
/* Warning: Invalid character set name:
   bogus_charset in filename on line n */

$oci = oci_connect("user", "pass", "db");
oci_password_change($oci, "", "old", "new");
/* Warning: username cannot be empty in filename
   on line n */

oci_password_change($oci, "user", "", "new");
/* Warning: old password cannot be empty in filename
   on line n */

oci_password_change($oci, "user", "old", "");
/* Warning: new password cannot be empty in filename
   on line n */
?>

Örnek 8 In the SPL Extension

<?php
$obj = new SplFileObject(__FILE__);
$obj->fgetcsv("foo");
/* Warning:  SplFileObject::fgetcsv(): delimiter must
   be a character in filename on line n */

$obj->fgetcsv(",", "foo");
/* Warning:  SplFileObject::fgetcsv(): enclosure must
   be a character in filename on line n */
?>

Örnek 9 In the Semaphore (sysvmsg) extension

<?php
/* Warning:  maximum size of the message has to be
   greater then zero in filename on line n */
?>

Örnek 10 A 5.2.1+ Zip Example

<?php
$obj = new ZipArchive();
$obj->open('archive.zip');
$obj->setCommentName('', 'comment');
/* Notice:  ZipArchive::setCommentName(): Empty string
   as entry name in filename on line n */

/* As of PHP 5.2.1 */
$obj->getCommentName('');
/* Notice:  ZipArchive::getCommentName(): Empty string
   as entry name in filename on line n */
?>

Backward Incompatible Changes
Changes in PHP datetime support
Migrating from PHP 5.1.x to PHP 5.2.x


Changes in PHP datetime support

Since PHP 5.1.0, there has been an extension named date in the PHP core. This is the new implementation of PHP's datetime support. Although it will attempt to guess your system's timezone setting, you should set the timezone manually. You can do this in any of three ways:

  • in your php.ini using the date.timezone INI directive
  • on your system using the TZ environmental variable
  • from your script using the convenience function date_default_timezone_set()

All supported timezones are listed in the PHP Manual.

With the advent of PHP 5.2.x, there are object representations of the date and timezone, named DateTime and DateTimeZone respectively. The methods map to existing procedural date functions.

New Error Messages
New Parameters
Migrating from PHP 5.1.x to PHP 5.2.x


New Parameters

Some functions were given new, optional, parameters in PHP 5.2.x:

PHP Core:

  • htmlentities() - added double_encode in PHP 5.2.3.
  • htmlspecialchars() - added double_encode in PHP 5.2.3.
  • base64_decode() - added strict
  • setcookie() - added httponly
  • setrawcookie() - added httponly
  • session_set_cookie_params() - added httponly
  • memory_get_usage() - added real_usage
  • get_loaded_extensions() - added zend_extensions in PHP 5.2.4

curl:

  • curl_multi_info_read() - added msgs_in_queue

datetime

  • date() - added "u" (milliseconds) format character in PHP 5.2.2

imap:

  • imap_open() - added n_retries
  • imap_reopen() - added n_retries

mbstring:

  • mb_strrpos() - added offset
    Uyarı

    The offset parameter was put in the position the encoding parameter used to be. Backward compatibility has been provided by allowing encoding to be specified as the third parameter. Using this backward compatibility mode is not recommended because it will be removed in a future release of PHP.

ming:

  • SWFMovie::streamMP3() - added skip in PHP 5.2.1

openssl:

  • openssl_verify() - added signature_algo

pgsql:

  • pg_escape_bytea() - added connection
  • pg_escape_string() - added connection

simplexml:

  • SimpleXMLElement::__construct() - added is_prefix
  • SimpleXMLElement::attributes() - added is_prefix
  • SimpleXMLElement::children() - added is_prefix
  • simplexml_load_file() - added is_prefix
  • simplexml_load_string() - added is_prefix

spl:

  • array iterator_to_array(Traversable it [, bool use_keys = true]) - added use_keys in PHP 5.2.1

xmlreader:

  • XMLReader::open() - added encoding and options
  • XMLReader::XML() - added encoding and options

XMLWriter:

  • xmlwriter_write_element() - the content became optional in PHP 5.2.3
  • xmlwriter_write_element_ns() - the content became optional in PHP 5.2.3
Changes in PHP datetime support
New Functions
Migrating from PHP 5.1.x to PHP 5.2.x


New Functions

PHP 5.2.x introduced some new functions:

PHP Core:

  • array_fill_keys() - Create an array using the elements of the first parameter as keys, each initialized to val
  • error_get_last() - Get the last occurred error as associative array. Returns NULL if there hasn't been an error yet
  • image_type_to_extension() - Get file extension for image-type returned by getimagesize(), exif_read_data(), exif_thumbnail(), exif_imagetype()
  • memory_get_peak_usage() - Returns the peak allocated by PHP memory
  • sys_get_temp_dir() - Returns directory path used for temporary files. (Added in 5.2.1)
  • timezone_abbreviations_list() - Returns associative array containing DST, offset and the timezone name
  • timezone_identifiers_list() - Returns numerically indexed array with all timezone identifiers
  • timezone_name_from_abbr() - Returns the timezone name from abbreviation
  • stream_socket_shutdown() - Causes all or part of a full-duplex connection on the socket associated with stream to be shut down. As of PHP 5.2.1.

Image:

  • imagegrabscreen() - Grabs a screenshot of the whole screen. As of PHP 5.2.2.
  • imagegrabwindow() - Captures a window. As of PHP 5.2.2.

libXML:

  • libxml_disable_entity_loader() - Disable the ability to load external entities. As of PHP 5.2.11.

mbstring:

  • mb_stripos() - Finds position of first occurrence of a string within another, case insensitive
  • mb_stristr() - Finds first occurrence of a string within another, case insensitive
  • mb_strrchr() - Finds the last occurrence of a character in a string within another
  • mb_strrichr() - Finds the last occurrence of a character in a string within another, case insensitive
  • mb_strripos() - Finds position of last occurrence of a string within another, case insensitive
  • mb_strstr() - Finds first occurrence of a string within another

ming (As of PHP 5.2.1):

  • void ming_setSWFCompression(int num) - Sets output compression
  • void swfmovie::namedanchor(string name) - Creates anchor
  • void swfmovie::protect([string password]) - Protects

openssl:

  • openssl_csr_get_public_key() - Extracts public key from a CERT and prepares it for use
  • openssl_csr_get_subject() - Returns the subject of a CERT
  • openssl_pkey_get_details() - Returns an array with the key details (bits, pkey, type)

spl:

  • spl_object_hash() - Return hash id for given object
  • int iterator_apply(Traversable it, mixed function [, mixed params]) - Calls a function for every element in an iterator

pcre:

  • preg_last_error() - Returns the error code of the last regex execution

pgsql:

  • pg_field_table() - Returns the name of the table field belongs to, or table's oid if oid_only is TRUE

posix:

  • posix_initgroups() - Calculate the group access list for the user specified in name

gmp:

  • gmp_nextprime() - Finds next prime number

xmlwriter:

  • xmlwriter_full_end_element() - End current element - returns FALSE on error
  • xmlwriter_write_raw() - Write text - returns FALSE on error
  • xmlwriter_start_dtd_entity() - Create start DTD Entity - returns FALSE on error
  • xmlwriter_end_dtd_entity() - End current DTD Entity - returns FALSE on error
  • xmlwriter_write_dtd_entity() - Write full DTD Entity tag - returns FALSE on error
New Parameters
New Methods
Migrating from PHP 5.1.x to PHP 5.2.x


New Methods

New methods were introduced in 5.2.0:

dom:

  • DOMDocument::registerNodeClass() - Register extended class used to create base node type
  • DOMElement::setIDAttribute() - Declares the attribute specified by name to be of type ID
  • DOMElement::setIDAttributeNode() - Declares the attribute specified by node to be of type ID
  • DOMElement::setIDAttributeNS() - Declares the attribute specified by local name and namespace URI to be of type ID
  • DOMNode::C14N()([bool exclusive [, bool with_comments [, array xpath [, array ns_prefixes]]]]) - Canonicalize nodes to a string
  • DOMNode::C14NFile()(string uri [, bool exclusive [, bool with_comments [, array xpath [, array ns_prefixes]]]]) - Canonicalize nodes to a file
  • DOMNode::getNodePath()() - Gets an xpath for a node

soap:

  • SoapServer::setObject()(object obj) - Sets object which will handle SOAP requests

spl:

  • int ArrayObject::asort()(void) - Sort the entries by values
  • int ArrayObject::ksort()(void) - Sort the entries by key
  • int ArrayObject::natcasesort()(void) - Sort the entries by key using case insensitive "natural order" algorithm.
  • int ArrayObject::natsort()(void) - Sort the entries by values using "natural order" algorithm.
  • int ArrayObject::uasort()(callback cmp_function) - Sort the entries by values using a user defined function
  • int ArrayObject::uksort()(callback cmp_function) - Sort the entries by key using a user defined function.
  • ArrayIterator AppendIterator::getArrayIterator()() - Get access to inner ArrayIterator
  • int AppendIterator::getIteratorIndex()() - Get index of iterator
  • bool CachingIterator::getCache()() - Return the cache
  • int CachingIterator::getFlags()() - Return the internal flags
  • bool CachingIterator::offsetExists()(mixed index) - Returns TRUE if the requested index exists
  • string CachingIterator::offsetGet()(mixed index) - Return the internal cache if used
  • void CachingIterator::offsetSet()(mixed index, mixed newval) - Set given index in cache
  • void CachingIterator::offsetUnset()(mixed index) - Unset given index in cache
  • void CachingIterator::setFlags()() - Set the internal flags
  • array("delimiter" =>, "enclosure" =>) SplFileObject::getCsvControl()(void) - Get the delimiter and enclosure character used in fgetcsv()
  • void SplFileObject::setCsvControl()([string delimiter = ',' [, string enclosure = '"']]) - Set the delimiter and enclosure character used in fgetcsv()

Tidy

  • tidyNode tidyNode::getParent()() - Returns the parent node of the current node (Added in PHP 5.2.2)

XMLReader

  • boolean XMLReader::setSchema() - Use W3C XSD schema to validate the document as it is processed. Activation is only possible before the first XMLReader::read()

zip:

  • ZipArchive::addEmptyDir()() - Creates an empty directory in the archive
New Functions
Removed Extensions
Migrating from PHP 5.1.x to PHP 5.2.x


Removed Extensions

These extensions have been moved to PECL and are no longer part of the PHP distribution. The PECL package version of these extensions will be created according to user demand.

  • filePro
  • Hyperwave API
New Methods
New Extensions
Migrating from PHP 5.1.x to PHP 5.2.x


New Extensions

The following are new extensions added (by default) as of PHP 5.2.0:

  • Filter - validates and filters data, and is designed for use with insecure data such as user input. This extension is enabled by default; the default mode RAW does not impact input data in any way.
  • JSON - implements the JavaScript Object Notation (JSON) data interchange format. This extension is enabled by default.
  • Zip - enables you to transparently read or write ZIP compressed archives and the files inside them.
Removed Extensions
New Classes
Migrating from PHP 5.1.x to PHP 5.2.x


New Classes

The following classes were introduced in PHP 5.2.0:

  • DateTime
  • DateTimeZone
  • RegexIterator - extends FilterIterator; implements Iterator, Traversable, OuterIterator Constants:
    • RegexIterator::ALL_MATCHES
    • RegexIterator::GET_MATCH
    • RegexIterator::MATCH
    • RegexIterator::REPLACE
    • RegexIterator::SPLIT
    • RegexIterator::USE_KEY
    Properties:
    • public replacement
    Methods:
    • RegexIterator::__construct(Iterator it, string regex [, int mode [, int flags [, int preg_flags]]]) - Create an RegexIterator from another iterator and a regular expression
    • bool RegexIterator::accept() - Match (string)current() against regular expression
    • bool RegexIterator::getFlags() - Returns current operation flags
    • bool RegexIterator::getMode() - Returns current operation mode
    • bool RegexIterator::getPregFlags() - Returns current PREG flags (if in use or NULL)
    • bool RegexIterator::setFlags(int new_flags) - Set operation flags
    • bool RegexIterator::setMode(int new_mode) - Set new operation mode
    • bool RegexIterator::setPregFlags(int new_flags) - Set PREG flags
  • RecursiveRegexIterator Constants:
    • RecursiveRegexIterator::ALL_MATCHES
    • RecursiveRegexIterator::GET_MATCH
    • RecursiveRegexIterator::MATCH
    • RecursiveRegexIterator::REPLACE
    • RecursiveRegexIterator::SPLIT
    • RecursiveRegexIterator::USE_KEY
    Methods:
    • RecursiveRegexIterator::__construct(RecursiveIterator it, string regex [, int mode [, int flags [, int preg_flags]]]) - Create an RecursiveRegexIterator from another recursive iterator and a regular expression
    • RecursiveRegexIterator RecursiveRegexIterator::getChildren() - Return the inner iterator's children contained in a RecursiveRegexIterator
    • bool RecursiveRegexIterator::hasChildren() - Check whether the inner iterator's current element has children
New Extensions
New Global Constants
Migrating from PHP 5.1.x to PHP 5.2.x


New Global Constants

PHP Core:

  • M_EULER
  • M_LNPI
  • M_SQRT3
  • M_SQRTPI
  • PATHINFO_FILENAME
  • PREG_BACKTRACK_LIMIT_ERROR
  • PREG_BAD_UTF8_ERROR
  • PREG_INTERNAL_ERROR
  • PREG_NO_ERROR
  • PREG_RECURSION_LIMIT_ERROR
  • UPLOAD_ERR_EXTENSION
  • STREAM_SHUT_RD
  • STREAM_SHUT_WR
  • STREAM_SHUT_RDWR

curl:

  • CURLE_FILESIZE_EXCEEDED
  • CURLE_FTP_SSL_FAILED
  • CURLE_LDAP_INVALID_URL
  • CURLFTPAUTH_DEFAULT
  • CURLFTPAUTH_SSL
  • CURLFTPAUTH_TLS
  • CURLFTPSSL_ALL
  • CURLFTPSSL_CONTROL
  • CURLFTPSSL_NONE
  • CURLFTPSSL_TRY
  • CURLOPT_FTP_SSL
  • CURLOPT_FTPSSLAUTH
  • CURLOPT_TCP_NODELAY Added in PHP 5.2.1.
  • CURLOPT_TIMEOUT_MS Added in PHP 5.2.3
  • CURLOPT_CONNECTTIMEOUT_MS Added in PHP 5.2.3

GMP:

  • GMP_VERSION Added in PHP 5.2.2.

ming:

  • SWFTEXTFIELD_USEFONT
  • SWFTEXTFIELD_AUTOSIZE
  • SWF_SOUND_NOT_COMPRESSED
  • SWF_SOUND_ADPCM_COMPRESSED
  • SWF_SOUND_MP3_COMPRESSED
  • SWF_SOUND_NOT_COMPRESSED_LE
  • SWF_SOUND_NELLY_COMPRESSED
  • SWF_SOUND_5KHZ
  • SWF_SOUND_11KHZ
  • SWF_SOUND_22KHZ
  • SWF_SOUND_44KHZ
  • SWF_SOUND_8BITS
  • SWF_SOUND_16BITS
  • SWF_SOUND_MONO
  • SWF_SOUND_STEREO

openssl:

  • OPENSSL_VERSION_NUMBER
  • OPENSSL_VERSION_TEXT

snmp:

  • SNMP_OID_OUTPUT_FULL
  • SNMP_OID_OUTPUT_NUMERIC

Semaphore:

  • MSG_EAGAIN
  • MSG_ENOMSG
New Classes
New Class Constants
Migrating from PHP 5.1.x to PHP 5.2.x


New Class Constants

pdo:

  • PDO::ATTR_DEFAULT_FETCH_MODE
  • PDO::FETCH_PROPS_LATE
  • PDO::FETCH_KEY_PAIR Fetches a 2 column result set into an associated array. (Added in PHP 5.2.3)

spl:

  • CachingIterator::FULL_CACHE
  • CachingIterator::TOSTRING_USE_INNER
  • SplFileObject::READ_AHEAD
  • SplFileObject::READ_CSV
  • SplFileObject::SKIP_EMPTY
New Global Constants
New INI Configuration Directives
Migrating from PHP 5.1.x to PHP 5.2.x


New INI Configuration Directives

New php.ini directives introduced in PHP 5.2.0:

  • allow_url_include This useful option makes it possible to differentiate between standard file operations on remote files, and the inclusion of remote files. While the former is usually desirable, the latter can be a security risk if used naively. Starting with PHP 5.2.0, you can allow remote file operations while disallowing the inclusion of remote files in local scripts. In fact, this is the default configuration.
  • pcre.backtrack_limit PCRE's backtracking limit.
  • pcre.recursion_limit PCRE's recursion limit. Please note that if you set this value to a high number you may consume all the available process stack and eventually crash PHP (due to reaching the stack size limit imposed by the Operating System).
  • session.cookie_httponly Marks the cookie as accessible only through the HTTP protocol. This means that the cookie won't be accessible by scripting languages, such as JavaScript. This setting can effectively help to reduce identity theft through XSS attacks (although it is not supported by all browsers).

New directives in PHP 5.2.2:

  • max_input_nesting_level Limits how deep input variables can be nested, default is 64.
New Class Constants
Error Reporting
Migrating from PHP 5.1.x to PHP 5.2.x


Error Reporting

Some of the existing E_ERROR conditions have been converted to something that can be caught with a user-defined error handler. If an E_RECOVERABLE_ERROR is not handled, it will behave in the same way as E_ERROR behaves in all versions of PHP. Errors of this type are logged as Catchable fatal error.

This change means that the value of the E_ALL error_reporting constant is now 6143, where the previous value was 2047. Because PHP constants have no meaning outside of PHP, in some cases the integer value is used instead so these will need to be adjusted. So for example by setting the error_reporting mode from either the httpd.conf or the .htaccess files, the value has to be changed accordingly. The same applies when the numeric values are used rather than the constants in PHP scripts.

As a side-effect of a change made to prevent duplicate error messages when track_errors is On, it is now necessary to return FALSE from user defined error handlers in order to populate $php_errormsg. This provides a fine-grain control over the levels of messages stored.

New INI Configuration Directives
Other Enhancements
Migrating from PHP 5.1.x to PHP 5.2.x


Other Enhancements

  • Improved memory manager and increased default memory limit. The new memory manager allocates less memory and works faster than the previous incarnation. It allocates memory from the system in large blocks, and then manages the heap by itself. The memory_limit value in php.ini is checked, not for each emalloc() call (as before), but for actual blocks requested from the system. This means that memory_limit is far more accurate than it used to be, since the old memory manager didn't calculate all the memory overhead used by the malloc library. Thanks to this new-found accuracy memory usage may appear to have increased, although actually it has not. To accommodate this apparent increase, the default memory_limit setting was also increased - from 8 to 16 megabytes.
  • Added support for constructors in interfaces to force constructor signature checks in implementations. Starting with PHP 5.2.0, interfaces can have constructors. However, if you choose to declare a constructor in an interface, each class implementing that interface MUST include a constructor with a signature matching that of the base interface constructor. By 'signature' we mean the parameter and return type definitions, including any type hints and including whether the data is passed by reference or by value.
Error Reporting
Migrating from PHP 5.0.x to PHP 5.1.x
Migrating from PHP 5.1.x to PHP 5.2.x


Migrating from PHP 5.0.x to PHP 5.1.x

İçindekiler

  • Key PHP 5.1.x features
  • Changes in reference handling
  • Reading []
  • Integer values in function parameters
  • Class and object changes
  • Extensions
  • Date/time support
  • Changes in database support
  • Checking for E_STRICT

Ayrıca, şu PHP sürümleri arasında geçiş kılavuzlarına da bakınız: 5.0.x, 5.2.x, 5.3.x, 5.4.x, 5.5.x and 5.6.x.

Other Enhancements
Key PHP 5.1.x features
Ekler


Key PHP 5.1.x features

Some of the key features of PHP 5.1.x include:

  • A complete rewrite of date handling code, with improved timezone support.

  • Significant performance improvements compared to PHP 5.0.X.

  • PDO extension is now enabled by default.

  • Over 30 new functions in various extensions and built-in functionality.

  • Over 400 various bug fixes.

Migrating from PHP 5.0.x to PHP 5.1.x
Changes in reference handling
Migrating from PHP 5.0.x to PHP 5.1.x


Changes in reference handling

  • Overview

  • Code that worked under PHP 4.3.x, but now fails

  • Code that worked under PHP 4.3.x, but now throws an error

  • Code that failed under PHP 4.3.x, but now works

  • Code that should have worked under PHP 5.0.x

  • Warnings that came and went

Overview

From the PHP script writer's point of view, the change most likely to impact legacy code is in the way that references are handled in all PHP versions post-dating the PHP 4.4.0 release.

Until and including PHP 4.3, it was possible to send, assign or return variables by reference that should really be returned by value, such as a constant, a temporary value (e.g. the result of an expression), or the result of a function that had itself been returned by value, as here:

<?php
$foo = "123";

function return_value() {
    global $foo;
    return $foo;
}

$bar = &return_value();
?>

Although this code would usually work as expected under PHP 4.3, in the general case the result is undefined. The Zend Engine could not act correctly on these values as references. This bug could and did lead to various hard-to-reproduce memory corruption problems, particularly where the code base was large.

In PHP 4.4.0, PHP 5.0.4 and all subsequent PHP releases, the Engine was fixed to 'know' when the reference operation is being used on a value that should not be referenced. The actual value is now used in such cases, and a warning is emitted. The warning takes the form of an E_NOTICE in PHP 4.4.0 and up, and E_STRICT in PHP 5.0.4 and up.

Code that could potentially produce memory corruption can no longer do so. However, some legacy code might work differently as a result.

Code that worked under PHP 4.3, but now fails

<?php
function func(&$arraykey) {
    return $arraykey; // function returns by value!
}

$array = array('a', 'b', 'c');
foreach (array_keys($array) as $key) {
    $y = &func($array[$key]);
    $z[] =& $y;
}

var_dump($z);
?>
<

Running the above script under any version of PHP that pre-dates the reference fix would produce this output:

array(3) {
  [0]=>
  &string(1) "a"
  [1]=>
  &string(1) "b"
  [2]=>
  &string(1) "c"
}

Following the reference fix, the same code would result in:

array(3) {
  [0]=>
  &string(1) "c"
  [1]=>
  &string(1) "c"
  [2]=>
  &string(1) "c"
}

This is because, following the changes, func() assigns by value. The value of $y is re-assigned, and reference-binding is preserved from $z. Prior to the fix, the value was assigned by reference, leading $y to be re-bound on each assignment. The attempt to bind to a temporary value by reference was the cause of the memory corruption.

Such code can be made to work identically in both the pre-fix and the post-fix PHP versions. The signature of func() can be altered to return by reference, or the reference assignment can be removed from the result of func().

<?php
function func() {
    return 'function return';
}

$x = 'original value';
$y =& $x;
$y = &func();
echo $x;
?>

In PHP 4.3 $x would be 'original value', whereas after the changes it would be 'function return' - remember that where the function does not return by reference, the reference assignment is converted to a regular assignment. Again, this can be brought to a common base, either by forcing func() to return by reference or by eliminating the by-reference assignment.

Code that worked under PHP 4.3.x, but now throws an error

<?php
class Foo {

    function getThis() {
        return $this;
    }

    function destroyThis() {
        $baz =& $this->getThis();
    }
}

$bar = new Foo();
$bar->destroyThis();
var_dump($bar);
?>

In PHP 5.0.3, $bar evaluated to NULL instead of returning an object. That happened because getThis() returns by value, but the value here is assigned by reference. Although it now works in the expected way, this is actually invalid code which will throw an E_NOTICE under PHP 4.4 or an E_STRICT under PHP 5.0.4 and up.

Code that failed under PHP 4.3.x, but now works

<?php
function &f() {
    $x = "foo";
    var_dump($x);
    print "$x\n";
    return($a);
}

for ($i = 0; $i < 3; $i++) {
    $h = &f();
}
?>

In PHP 4.3 the third call to var_dump() produces NULL, due to the memory corruption caused by returning an uninitialized value by reference. This is valid code in PHP 5.0.4 and up, but threw errors in earlier releases of PHP.

<?php
$arr = array('a1' => array('alfa' => 'ok'));
$arr =& $arr['a1'];
echo '-'.$arr['alfa']."-\n";
?>

Until PHP 5.0.5, it wasn't possible to assign an array element by reference in this way. It now is.

Code that should have worked under PHP 5.0.x

There are a couple of instances of bugs reported under PHP 5.0 prior to the reference fixes which now 'work'. However, in both cases errors are thrown by PHP 5.1.x, because the code was invalid in the first place. Returning values by reference using self:: now works in the general case but throws an E_STRICT warning, and although your mileage may vary when assigning by reference to an overloaded object, you will still see an E_ERROR when you try it, even where the assignment itself appears to work.

Warnings that came and went

Nested calls to functions returning by reference are valid code under both PHP 4.3.x and PHP 5.1.x, but threw an unwarranted E_NOTICE or E_STRICT under the intervening PHP releases.

<?php
function & foo() {
    $var = 'ok';
    return $var;
}

function & bar() {
    return foo();
}

$a =& bar();
echo "$a\n";
?>
Key PHP 5.1.x features
Reading []
Migrating from PHP 5.0.x to PHP 5.1.x


Reading []

<?php
class XmlTest {

    function test_ref(&$test) {
        $test = "ok";
    }

    function test($test) { }

    function run() {
        $ar = array();
        $this->test_ref($ar[]);
        var_dump($ar);
        $this->test($ar[]);
    }
}

$o = new XmlTest();
$o->run();
?>

This should always have thrown a fatal E_ERROR, because [] cannot be used for reading in PHP. It is invalid code in PHP 4.4.2 and PHP 5.0.5 upward.

Changes in reference handling
Integer values in function parameters
Migrating from PHP 5.0.x to PHP 5.1.x


Integer values in function parameters

With the advent of PHP 5.0.x, a new parameter parsing API was introduced which is used by a large number of PHP functions. In all versions of PHP between 5.0.x and 5.1.x, the handling of integer values was very strict and would reject non-well formed numeric values when a PHP function expected an integer. These checks have now been relaxed to support non-well formed numeric strings such as " 123" and "123 ", and will no longer fail as they did under PHP 5.0.x. However, to promote code safety and input validation, PHP functions will now emit an E_NOTICE when such strings are passed as integers.

Reading []
Class and object changes
Migrating from PHP 5.0.x to PHP 5.1.x


Class and object changes

  • instanceof, is_a(), is_subclass_of() and catch

  • Abstract private methods

  • Access modifiers in interfaces

  • Changes in inheritance rules

  • Class constants

instanceof, is_a(), is_subclass_of() and catch

In PHP 5.0, is_a() was deprecated and replaced by the instanceof operator. There were some issues with the initial implementation of instanceof, which relied on __autoload() to search for missing classes. If the class was not present, instanceof would throw a fatal E_ERROR due to the failure of __autoload() to discover that class. The same behaviour occurred in the catch operator and the is_subclass_of() function, for the same reason.

None of these functions or operators call __autoload() in PHP 5.1.x, and the class_exists() workarounds used in code written for PHP 5.0.x, while not problematic in any way, are no longer necessary.

Abstract private methods

Abstract private methods were supported between PHP 5.0.0 and PHP 5.0.4, but were then disallowed on the grounds that the behaviours of private and abstract are mutually exclusive.

Access modifiers in interfaces

Under PHP 5.0, function declarations in interfaces were treated in exactly the same way as function declarations in classes. This has not been the case since October 2004, at which point only the public access modifier was allowed in interface function declarations. Since April 2005 - which pre-dates the PHP 5.0b1 release - the static modifier has also been allowed. However, the protected and private modifiers will now throw an E_ERROR, as will abstract. Note that this change should not affect your existing code, as none of these modifiers makes sense in the context of interfaces anyway.

Changes in inheritance rules

Under PHP 5.0, it was possible to have a function declaration in a derived class that did not match the declaration of the same function in the base class, e.g.

This code will cause an E_STRICT error to be emitted under PHP 5.1.x.

<?php
class Base {
    function &return_by_ref() {
        $r = 1;
        return $r;
    }
}

class Derived extends Base {
    function return_by_ref() {
        return 1;
    }
}
?>

Class constants

Under PHP 5.0.x, the following code was valid:

Under PHP 5.1.x, redefinition of a class constant will throw a fatal E_ERROR.

<?php
class test {
    const foobar = 'foo';
    const foobar = 'bar';
}

?>
Integer values in function parameters
Extensions
Migrating from PHP 5.0.x to PHP 5.1.x


Extensions

  • Extensions that are gone from the PHP core

  • Class constants in new PHP 5.1.x extensions

Extensions that are gone from the PHP core

One of the first things you're likely to notice when you download PHP 5.1.x is that several of the older extensions have disappeared. Those extensions that are still actively maintained are available in the PHP Extension Community Library (PECL), at » http://pecl.php.net/.

Removed extensions
Extension | Alternative/Status
ext/cpdf | pecl/pdflib
ext/dbx | pecl/dbx
ext/dio | pecl/dio
ext/fam | Not actively maintained
ext/ingres_ii | pecl/ingres
ext/ircg | Not actively maintained
ext/mcve | pecl/mcve
ext/mnogosearch | Not actively maintained
ext/oracle | ext/oci8 or ext/pdo_oci
ext/ovrimos | Not actively maintained
ext/pfpro | Not actively maintained
ext/w32api | » pecl/ffi
ext/yp | Not actively maintained
ext/activescript | » pecl/activescript

Modules in PECL that are not actively maintained (i.e. have not been supported for some time, have no active maintainer working on them currently, and do not have any PECL package releases), are still available in SVN at » http://svn.php.net/viewvc/pecl. However, unreleased PHP modules are by their nature unsupported, and your mileage may vary when attempting to install or use them.

Class constants in new PHP 5.1.x extensions

The Zend Engine 2.1 API allows extension developers to declare class constants in object oriented extensions. New extensions written for PHP 5.1.x, including SPL, PDO, XMLReader and date, have their constants in the format PDO::CLASS_CONSTANT rather than in the C format PDO_CLASS_CONSTANT in order to minimise pollution of the global namespace in PHP.

Class and object changes
Date/time support
Migrating from PHP 5.0.x to PHP 5.1.x


Date/time support

Date/time support has been fully rewritten in PHP 5.1.x, and no longer uses the system settings to 'know' the timezone in operation. It will instead utilize, in the following order:

  • The timezone set using the date_default_timezone_set() function (if any)

  • The TZ environment variable (if non empty)

  • "magical" guess (if the operating system supports it)

  • If none of the above options succeeds, UTC

To ensure accuracy (and avoid an E_STRICT warning), you will need to define your timezone in your php.ini using the following format:

date.timezone = Europe/London

The supported timezones are listed, in this format, in the timezones appendix.

Also note that strtotime() now returns FALSE on failure, instead of -1.

Extensions
Changes in database support
Migrating from PHP 5.0.x to PHP 5.1.x


Changes in database support

  • PDO overview

  • Changes in MySQL support

  • Changes in SQLite support

PDO overview

PHP Data Objects (PDO) were introduced as a PECL extension under PHP 5.0, and became part of the core PHP distribution in PHP 5.1.x. The PDO extension provides a consistent interface for database access, and is used alongside database-specific PDO drivers. Each driver may also have database-specific functions of its own, but basic data access functionality such as issuing queries and fetching data is covered by PDO functions, using the driver named in PDO::__construct().

Note that the PDO extension, and its drivers, are intended to be built as shared extensions. This will enable straightforward driver upgrades from PECL, without forcing you to rebuild all of PHP.

At the point of the PHP 5.1.x release, PDO is more than ready for widespread testing and could be adopted in most situations. However, it is important to understand that PDO and its drivers are comparatively young and may be missing certain database-specific features; evaluate PDO carefully before you use it in new projects.

Legacy code will generally rely on the pre-existing database extensions, which are still maintained.

Changes in MySQL support

In PHP 4, MySQL 3 support was built-in. With the release of PHP 5.0 there were two MySQL extensions, named 'mysql' and 'mysqli', which were designed to support MySQL < 4.1 and MySQL 4.1 and up, respectively. With the introduction of PDO, which provides a very fast interface to all the database APIs supported by PHP, the PDO_MYSQL driver can support any of the current versions (MySQL 3, 4 or 5) in PHP code written for PDO, depending on the MySQL library version used during compilation. The older MySQL extensions remain in place for reasons of back compatibility, but are not enabled by default.

Changes in SQLite support

In PHP 5.0.x, SQLite 2 support was provided by the built-in sqlite extension, which was also available as a PECL extension in PHP 4.3 and PHP 4.4. With the introduction of PDO, the sqlite extension doubles up to act as a 'sqlite2' driver for PDO; it is due to this that the sqlite extension in PHP 5.1.x has a dependency upon the PDO extension.

PHP 5.1.x ships with a number of alternative interfaces to sqlite:

The sqlite extension provides the "classic" sqlite procedural/OO API that you may have used in prior versions of PHP. It also provides the PDO 'sqlite2' driver, which allows you to access legacy SQLite 2 databases using the PDO API.

PDO_SQLITE provides the 'sqlite' version 3 driver. SQLite version 3 is vastly superior to SQLite version 2, but the file formats of the two versions are not compatible.

If your SQLite-based project is already written and working against earlier PHP versions, then you can continue to use ext/sqlite without problems, but will need to explicitly enable both PDO and sqlite. New projects should use PDO and the 'sqlite' (version 3) driver, as this is faster than SQLite 2, has improved locking concurrency, and supports both prepared statements and binary columns natively.

You must enable PDO to use the SQLite extension. If you want to build the PDO extension as a shared extension, then the SQLite extension must also be built shared. The same holds true for any extension that provides a PDO driver

Date/time support
Checking for E_STRICT
Migrating from PHP 5.0.x to PHP 5.1.x


Checking for E_STRICT

If you only have a single script to check, you can pick up E_STRICT errors using PHP's commandline lint facility:

php -d error_reporting=4095 -l script_to_check.php

For larger projects, the shell script below will achieve the same task:

#!/bin/sh

directory=$1

shift

# These extensions are checked
extensions="php inc"

check_file ()
{
  echo -ne "Doing PHP syntax check on $1 ..."

  # Options:
  ERRORS=`/www/php/bin/php -d display_errors=1 -d html_errors=0 -d error_prepend_string=" " -d error_append_string=" " -d error_reporting=4095 -l $1 | grep -v "No syntax errors detected"`

  if test -z "$ERRORS"; then
    echo -ne "OK."
  else
    echo -e "Errors found!\n$ERRORS"
  fi

  echo
}

# loop over remaining file args
for FILE in "$@" ; do
  for ext in $extensions; do
     if echo $FILE | grep "\.$ext$" > /dev/null; then
       if test -f $FILE; then
         check_file "$FILE"
       fi
     fi
  done
done
Changes in database support
Migrating from PHP 4 to PHP 5.0.x
Migrating from PHP 5.0.x to PHP 5.1.x


Migrating from PHP 4 to PHP 5.0.x

İçindekiler

  • What has changed in PHP 5.0.x
  • Backward Incompatible Changes
  • CLI and CGI
  • Migrating Configuration Files
  • New Functions
  • New Directives
  • Databases
  • New Object Model
  • Error Reporting

Ayrıca, şu PHP sürümleri arasında geçiş kılavuzlarına da bakınız: 5.1.x, 5.2.x, 5.3.x, 5.4.x, 5.5.x and 5.6.x.

Checking for E_STRICT
What has changed in PHP 5.0.x
Ekler


What has changed in PHP 5.0.x

PHP 5 and the integrated Zend Engine 2 have greatly improved PHP's performance and capabilities, but great care has been taken to break as little existing code as possible. So migrating your code from PHP 4 to 5 should be very easy. Most existing PHP 4 code should be ready to run without changes, but you should still know about the few differences and take care to test your code before switching versions in production environments.

Migrating from PHP 4 to PHP 5.0.x
Backward Incompatible Changes
Migrating from PHP 4 to PHP 5.0.x


Backward Incompatible Changes

Although most existing PHP 4 code should work without changes, you should pay attention to the following backward incompatible changes:

  • There are some new reserved keywords.
  • strrpos() and strripos() now use the entire string as a needle.
  • Illegal use of string offsets causes E_ERROR instead of E_WARNING. An example illegal use is: $str = 'abc'; unset($str[0]);.
  • array_merge() was changed to accept only arrays. If a non-array variable is passed, a E_WARNING will be thrown for every such parameter. Be careful because your code may start emitting E_WARNING out of the blue.
  • PATH_TRANSLATED server variable is no longer set implicitly under Apache2 SAPI in contrast to the situation in PHP 4, where it is set to the same value as the SCRIPT_FILENAME server variable when it is not populated by Apache. This change was made to comply with the » CGI/1.1 specification. Please refer to » bug #23610 for further information, and see also the $_SERVER['PATH_TRANSLATED'] description in the manual. This issue also affects PHP versions >= 4.3.2.
  • The T_ML_COMMENT constant is no longer defined by the Tokenizer extension. If error_reporting is set to E_ALL, PHP will generate a notice. Although the T_ML_COMMENT was never used at all, it was defined in PHP 4. In both PHP 4 and PHP 5 // and /* */ are resolved as the T_COMMENT constant. However the PHPDoc style comments /** */, which starting PHP 5 are parsed by PHP, are recognized as T_DOC_COMMENT.
  • $_SERVER should be populated with argc and argv if variables_order includes "S". If you have specifically configured your system to not create $_SERVER, then of course it shouldn't be there. The change was to always make argc and argv available in the CLI version regardless of the variables_order setting. As in, the CLI version will now always populate the global $argc and $argv variables.
  • An object with no properties is no longer considered "empty".
  • In some cases classes must be declared before use. It only happens if some of the new features of PHP 5 (such as interfaces) are used. Otherwise the behaviour is the old.
  • get_class(), get_parent_class() and get_class_methods() now return the name of the classes/methods as they were declared (case-sensitive) which may lead to problems in older scripts that rely on the previous behaviour (the class/method name was always returned lowercased). A possible solution is to search for those functions in all your scripts and use strtolower(). This case sensitivity change also applies to the magical predefined constants __CLASS__, __METHOD__, and __FUNCTION__. The values are returned exactly as they're declared (case-sensitive).
  • ip2long() now returns FALSE when an invalid IP address is passed as argument to the function, and no longer -1.
  • If there are functions defined in the included file, they can be used in the main file independent if they are before return or after. If the file is included twice, PHP 5 issues fatal error because functions were already declared, while PHP 4 doesn't complain about it. It is recommended to use include_once instead of checking if the file was already included and conditionally return inside the included file.
  • include_once and require_once first normalize the path of included file on Windows so that including A.php and a.php include the file just once.
  • Passing an array to a function by value no longer resets the array's internal pointer for array accesses made within the function. In other words, in PHP 4 when you passed an array to a function, its internal pointer inside the function would be reset, while in PHP 5, when you pass an array to a function, its array pointer within the function will be wherever it was when the array was passed to the function.

Örnek 1 strrpos() and strripos() now use the entire string as a needle

<?php
var_dump(strrpos('ABCDEF','DEF')); //int(3)

var_dump(strrpos('ABCDEF','DAF')); //bool(false)
?>

Örnek 2 An object with no properties is no longer considered "empty"

<?php
class test { }
$t = new test();

var_dump(empty($t)); // echo bool(false)

if ($t) {
    // Will be executed
}
?>

Örnek 3 In some cases classes must be declared before used

<?php

//works with no errors:
$a = new a();
class a {
}

//throws an error:
$a = new b();

interface c{
}
class b implements c {
}

?>

What has changed in PHP 5.0.x
CLI and CGI
Migrating from PHP 4 to PHP 5.0.x


CLI and CGI

In PHP 5 there were some changes in CLI and CGI filenames. In PHP 5, the CGI version was renamed to php-cgi.exe (previously php.exe) and the CLI version now sits in the main directory (previously cli/php.exe).

In PHP 5 it was also introduced a new mode: php-win.exe. This is equal to the CLI version, except that php-win doesn't output anything and thus provides no console (no "dos box" appears on the screen). This behavior is similar to php-gtk.

In PHP 5, the CLI version will always populate the global $argv and $argc variables regardless of any php.ini directive setting. Even having register_argc_argv set to off will have no affect in CLI.

See also the command line reference.

Backward Incompatible Changes
Migrating Configuration Files
Migrating from PHP 4 to PHP 5.0.x


Migrating Configuration Files

Since the ISAPI modules changed their names, from php4xxx to php5xxx, you need to make some changes in the configuration files. There were also changes in the CLI and CGI filenames. Please refer to the corresponding section for more information.

Migrating the Apache configuration is extremely easy. See the example below to check the change you need to do:

Örnek 1 Migrating Apache configuration files for PHP 5

# change this line:
LoadModule php4_module /php/sapi/php4apache2.dll

# with this one:
LoadModule php5_module /php/php5apache2.dll

If your web server is running PHP in CGI mode, you should note that the CGI version has changed its name from php.exe to php-cgi.exe. In Apache, you should do something like this:

Örnek 2 Migrating Apache configuration files for PHP 5, CGI mode

# change this line:
Action application/x-httpd-php "/php/php.exe"

# with this one:
Action application/x-httpd-php "/php/php-cgi.exe"

In other web servers you need to change either the CGI or the ISAPI module filenames.

CLI and CGI
New Functions
Migrating from PHP 4 to PHP 5.0.x


New Functions

In PHP 5 there are some new functions. Here is the list of them:

Arrays:

  • array_combine() - Creates an array by using one array for keys and another for its values
  • array_diff_uassoc() - Computes the difference of arrays with additional index check which is performed by a user supplied callback function
  • array_udiff() - Computes the difference of arrays by using a callback function for data comparison
  • array_udiff_assoc() - Computes the difference of arrays with additional index check. The data is compared by using a callback function
  • array_udiff_uassoc() - Computes the difference of arrays with additional index check. The data is compared by using a callback function. The index check is done by a callback function also
  • array_walk_recursive() - Apply a user function recursively to every member of an array
  • array_uintersect_assoc() - Computes the intersection of arrays with additional index check. The data is compared by using a callback function
  • array_uintersect_uassoc() - Computes the intersection of arrays with additional index check. Both the data and the indexes are compared by using separate callback functions
  • array_uintersect() - Computes the intersection of arrays. The data is compared by using a callback function

InterBase:

  • ibase_affected_rows() - Return the number of rows that were affected by the previous query
  • ibase_backup() - Initiates a backup task in the service manager and returns immediately
  • ibase_commit_ret() - Commit a transaction without closing it
  • ibase_db_info() - Request statistics about a database
  • ibase_drop_db() - Drops a database
  • ibase_errcode() - Return an error code
  • ibase_free_event_handler() - Cancels a registered event handler
  • ibase_gen_id() - Increments the named generator and returns its new value
  • ibase_maintain_db() - Execute a maintenance command on the database server
  • ibase_name_result() - Assigns a name to a result set
  • ibase_num_params() - Return the number of parameters in a prepared query
  • ibase_param_info() - Return information about a parameter in a prepared query
  • ibase_restore() - Initiates a restore task in the service manager and returns immediately
  • ibase_rollback_ret() - Rollback transaction and retain the transaction context
  • ibase_server_info() - Request statistics about a database server
  • ibase_service_attach() - Connect to the service manager
  • ibase_service_detach() - Disconnect from the service manager
  • ibase_set_event_handler() - Register a callback function to be called when events are posted
  • ibase_wait_event() - Wait for an event to be posted by the database

iconv:

  • iconv_mime_decode() - Decodes a MIME header field
  • iconv_mime_decode_headers() - Decodes multiple MIME header fields at once
  • iconv_mime_encode() - Composes a MIME header field
  • iconv_strlen() - Returns the character count of string
  • iconv_strpos() - Finds position of first occurrence of a needle within a haystack
  • iconv_strrpos() - Finds the last occurrence of a needle within a haystack
  • iconv_substr() - Cut out part of a string

Streams:

  • stream_copy_to_stream() - Copies data from one stream to another
  • stream_get_line() - Gets line from stream resource up to a given delimiter
  • stream_socket_accept() - Accept a connection on a socket created by stream_socket_server()
  • stream_socket_client() - Open Internet or Unix domain socket connection
  • stream_socket_get_name() - Retrieve the name of the local or remote sockets
  • stream_socket_recvfrom() - Receives data from a socket, connected or not
  • stream_socket_sendto() - Sends a message to a socket, whether it is connected or not
  • stream_socket_server() - Create an Internet or Unix domain server socket

Date and time related:

  • idate() - Format a local time/date as integer
  • date_sunset() - Time of sunset for a given day and location
  • date_sunrise() - Time of sunrise for a given day and location
  • time_nanosleep() - Delay for a number of seconds and nanoseconds

Strings:

  • str_split() - Convert a string to an array
  • strpbrk() - Search a string for any of a set of characters
  • substr_compare() - Binary safe optionally case insensitive comparison of two strings from an offset, up to length characters

Other:

  • convert_uudecode() - decode a uuencoded string
  • convert_uuencode() - uuencode a string
  • curl_copy_handle() - Copy a cURL handle along with all of its preferences
  • dba_key_split() - Splits a key in string representation into array representation
  • dbase_get_header_info() - Get the header info of a dBase database
  • dbx_fetch_row() - Fetches rows from a query-result that had the DBX_RESULT_UNBUFFERED flag set
  • fbsql_set_password() - Change the password for a given user
  • file_put_contents() - Write a string to a file
  • ftp_alloc() - Allocates space for a file to be uploaded
  • get_declared_interfaces() - Returns an array of all declared interfaces
  • get_headers() - Fetches all the headers sent by the server in response to a HTTP request
  • headers_list() - Returns a list of response headers sent (or ready to send)
  • http_build_query() - Generate URL-encoded query string
  • image_type_to_extension() - Get file extension for
image-type returned by getimagesize(),
exif_read_data(),
exif_thumbnail(),
exif_imagetype()
  • imagefilter() - Applies a filter to an image using custom arguments
  • imap_getacl() - Gets the ACL for a given mailbox
  • ldap_sasl_bind() - Bind to LDAP directory using SASL
  • mb_list_encodings() - Returns an array of all supported encodings
  • pcntl_getpriority() - Get the priority of any process
  • pcntl_wait() - Waits on or returns the status of a forked child as defined by the waitpid() system call
  • pg_version() - Returns an array with client, protocol and server version (when available)
  • php_check_syntax() - Check the syntax of the specified file
  • php_strip_whitespace() - Return source with stripped comments and whitespace
  • proc_nice() - Change the priority of the current process
  • pspell_config_data_dir() - Change location of language data files
  • pspell_config_dict_dir() - Change location of the main word list
  • setrawcookie() - Send a cookie without URL-encoding the value
  • scandir() - List files and directories inside the specified path
  • snmp_read_mib() - Reads and parses a MIB file into the active MIB tree
  • sqlite_fetch_column_types() - Return an array of column types from a particular table

Bilginize:

The Tidy extension has also changed its API completely.

Migrating Configuration Files
New Directives
Migrating from PHP 4 to PHP 5.0.x


New Directives

There were some new php.ini directives introduced in PHP 5. Here is a list of them:

  • mail.force_extra_parameters - Force the addition of the specified parameters to be passed as extra parameters to the sendmail binary. These parameters will always replace the value of the 5th parameter to mail(), even in safe mode
  • register_long_arrays - allow/disallow PHP to register the deprecated long $HTTP_*_VARS
  • session.hash_function - select a hash function (MD5 or SHA-1)
  • session.hash_bits_per_character - define how many bits are stored in each character when converting the binary hash data to something readable (from 4 to 6)
  • zend.ze1_compatibility_mode - Enable compatibility mode with Zend Engine 1 (PHP 4)
New Functions
Databases
Migrating from PHP 4 to PHP 5.0.x


Databases

There were some changes in PHP 5 regarding databases (MySQL and SQLite).

In PHP 5 the MySQL client libraries are not bundled, because of license and maintenance problems. MySQL is supported with the only change being that MySQL support is no longer enabled by default in PHP 5. This essentially means that PHP doesn't include the --with-mysql option in the configure line so that you must now manually do this when compiling PHP. Windows users will need to edit php.ini and enable the php_mysql.dll DLL as in PHP 4 no such DLL existed, it was simply built into your Windows PHP binaries.

There is also a new extension, MySQLi (Improved MySQL), which is designed to work with MySQL 4.1 and above.

Since PHP 5, the SQLite extension is built-in PHP. SQLite is an embeddable SQL database engine and is not a client library used to connect to a big database server (like MySQL or PostgreSQL). The SQLite library reads and writes directly to and from the database files on disk.

New Directives
New Object Model
Migrating from PHP 4 to PHP 5.0.x


New Object Model

In PHP 5 there is a new Object Model. PHP's handling of objects has been completely rewritten, allowing for better performance and more features. In previous versions of PHP, objects were handled like primitive types (for instance integers and strings). The drawback of this method was that semantically the whole object was copied when a variable was assigned, or passed as a parameter to a method. In the new approach, objects are referenced by handle, and not by value (one can think of a handle as an object's identifier).

Many PHP programmers aren't even aware of the copying quirks of the old object model and, therefore, the majority of PHP applications will work out of the box, or with very few modifications.

The new Object Model is documented at the Language Reference.

In PHP 5, function with the name of a class is called as a constructor only if defined in the same class. In PHP 4, it is called also if defined in the parent class.

See also the zend.ze1_compatibility_mode directive for compatability with PHP 4.

Databases
Error Reporting
Migrating from PHP 4 to PHP 5.0.x


Error Reporting

As of PHP 5 the error reporting constant E_STRICT is available, with the value 2048. When enabled, messages will be issued to warn you about code usage which is deprecated or which may not be future-proof.

Bilginize: E_ALL does not include E_STRICT, so it's not enabled by default. You must explicitly set the error reporting level to include E_STRICT in order to see these messages.

See Predefined Constants for more information.

New Object Model
PHP'de Hata Ayıklama
Migrating from PHP 4 to PHP 5.0.x


PHP'de Hata Ayıklama

İçindekiler

  • PHP'de hata ayıklama hakkında
Error Reporting
PHP'de hata ayıklama hakkında
Ekler


PHP'de hata ayıklama hakkında

PHP 5.6 phpdbg etkileşimli hata ayıklayıcı ile dağıtılmışsa da önceki sürümler yerleşik bir hata ayıklama oluşumuna sahip değildir. Bunun için dış kaynaklı hata ayıklayıcılardan birini kullanabilirsiniz. » Zend IDE bir hata ayıklayıcı içermektedir. Ayrıca, DBG (» http://www.php-debugger.com/dbg/), » Advanced PHP Debugger (APD) veya » Xdebug gibi bazı özgür hata ayıklayıcılar da vardır.

PHP'de Hata Ayıklama
Yapılandırma Seçenekleri
PHP'de Hata Ayıklama


Yapılandırma Seçenekleri

İçindekiler

  • Temel yapılandırma seçeneklerinin listesi
PHP'de hata ayıklama hakkında
Temel yapılandırma seçeneklerinin listesi
Ekler


Temel yapılandırma seçeneklerinin listesi

PHP'yi Unix ve benzeri sistemlerde derlerken kullanılan PHP configure betiğinin yapılandırma seçeneklerinden bir kısmı aşağıda listelenmiştir. Burada bulunmayan yapılandırma seçeneklerinin çoğu eklenti başvuru sayfalarında ilgili oldukları yerlerde listelenmiştir. Yapılandırma seçeneklerinin güncel ve tam listesini almak için PHP kaynak dizininizde autoconf'u çalıştırdıktan sonra ./configure --help komutunu kullanabilirsiniz (ayrıca, Kurulum ve Yapılandırma bölümüne de bakınız). Ayrıca, --prefix=PREFIX gibi ek configure seçenekleri hakkında bilgi almak için » GNU configure belgelerini de okuyabilirsiniz.

Bilginize:

Bunlar sadece derleme sırasında kullanılırlar. PHP'nin çalışma anı yapılandırmasını değiştirmek isiyorsanız Çalışma anı Yapılandırması bölümüne bakınız.

  • Çeşitli
  • PHP Davranışı
  • Sunucu

PHP Yapılandırma Seçenekleri

Çeşitli Seçenekler

--enable-debug

Hata ayıklama etkinleştirilerek derlenir.

--with-layout=TÜR

Kurulacak dosyaların neye göre yerleştirileceği belirtilir. TÜR olarak PHP (öntanımlı) veya GNU belirtilebilir.

--with-pear=DiZiN

PEAR, DiZiN'e kurulur (öntanımlı: PREFIX/lib/php).

--without-pear

PEAR kurulmaz.

--enable-sigchild

PHP'nin kendi SIGCHLD eylemcisi etkin olur.

--disable-rpath

Çalışma anı ek kütüphane arama yollarının aktarımı iptal edilir.

--enable-libgcc

libgcc'ye doğrudan ilintileme etkin olur.

--enable-php-streams

Deneysel PHP akımları içerilir. Kodu denemeden kullanmayın.

--with-zlib-dir[=DiZiN]

zlib kurulum dizininin yeri tanımlanır.

--with-tsrm-pthreads

POSIX evreleri kullanılır (öntanımlıdır).

--enable-shared[=PKGS]

Paylaşımlı kütüphaneler derlenir [öntanımlı=evet].

--enable-static[=PKGS]

Duruk kütüphaneler derlenir [öntanımlı=evet].

--enable-fast-install[=PKGS]

Hızlı kurulum için en iyileme yapılır [öntanımlı=evet].

--with-gnu-ld

C derleyicinin GNU ld kullanacağı varsayılır [öntanımlı=hayır].

--disable-libtool-lock

Kilitlemeden kaçınılır (paralel derlemeleri bozabilir).

--with-pic

Sadece PIC/non-PIC nesneler kullanılmaya çalışılır [öntanımlı=ikisi de].

--enable-memory-limit

Bellek sınırlama destekli derleme yapılır (PHP 5.2.1'den beri kullanılmamaktadır - daima etkindir)

--disable-url-fopen-wrapper

Dosyalara HTTP veya FTP üzerinden erişmeye imkan veren URL bilir fopen sarmalayıcı iptal edilir (PHP 5.2.5'ten beri kullanılmamaktadır).

--enable-versioning

Sadece gerekli simgeler ihraç edilir. Daha fazla bilgi için INSTALL dosyasına bakınız.

PHP seçenekleri

--enable-maintainer-mode

Make kurallarının ve bağımlılıklarının dikkatsiz kurucuya elverişsizliği etkin kılınır.

--with-config-file-path=YOL

php.ini dosyasının aranacağı yollar atanır; PREFIX/lib öntanımlıdır.

--enable-safe-mode

Güvenli kip öntanımlı olarak etkin kılınır.

Uyarı

Bu özelliğin kullanımı PHP 5.3.0 itibariyle ÖNERİLMEMEKTE olup PHP 5.4.0'da tamamen KALDIRILMIŞTIR.

--with-exec-dir[=DiZiN]

Güvenli kip /usr/local/php/bin dizini öntanımlı olduğunda sadece DiZiN içindeki çalıştırılabilirlere izin verilir.

Uyarı

Bu özelliğin kullanımı PHP 5.3.0 itibariyle ÖNERİLMEMEKTE olup PHP 5.4.0'da tamamen KALDIRILMIŞTIR.

--enable-magic-quotes

Sihirli tırnaklar öntanımlı olarak etkindir.

Uyarı

Bu özelliğin kullanımı PHP 5.3.0 itibariyle ÖNERİLMEMEKTE olup PHP 5.4.0'da tamamen KALDIRILMIŞTIR.

--disable-short-tags

Öntanımlı olarak başlatma etiketinin <? kısa biçemi iptal edilir.

--enable-zend-multibyte

Çalıştırılacak dil çözümleyici ve tarayıcıda çok baytlı kodu etkin kılar. Bundan başka, PHP bu seçenekle derlenirse declare oluşumunda encoding yönergesini de etkin kılar.

Uyarı

Bu özelliğin kullanımı PHP 5.3.0 itibariyle ÖNERİLMEMEKTE olup PHP 5.4.0'da tamamen KALDIRILMIŞTIR.

--with-libdir

Unix sistemlerinde kütüphanelerin kurulacağı yeri belirtmek için kullanılır. 64 bitlik sistemlerde bu dizini lib64 olarak belirmek gerekir: --with-libdir=lib64.

SAPI seçenekleri

Aşağıda PHP için kullanılabilen SAPI'ler (Server Application Programming Interface kısaltması; Sunucu Uygulama Programlama Arayüzü) listelenmiştir.

--with-aolserver=DiZiN

AOLserver eklentisinin kurulum yeri belirtilir.

--with-apxs[=DOSYA]

PHP bir paylaşımlı Apache modülü olarak derlenir. DOSYAnın belirtilmesi isteğe bağlı olup Apache apxs aracının ismini belirtmek için kullanılır; apxs öntanımlıdır. Apxs'in sisteminizde kurulu sürümünü belirtmelisiniz, Apache kaynak paketindekini değil.

--with-apache[=DiZiN]

PHP bir duruk Apache modülü olarak derlenir. DiZiN, Apache'nin kurulu olduğu dizin olup /usr/local/apache öntanımlıdır.

--with-mod_charset

mod_charset (Rusça Apache) için aktarım tablolarını etkinleştirir.

--with-apxs2[=DOSYA]

PHP bir paylaşımlı Apache 2.0 modülü olarak derlenir. DOSYAnın belirtilmesi isteğe bağlı olup Apache apxs aracının ismini belirtmek için kullanılır; apxs öntanımlıdır.

--with-caudium=DiZiN

PHP, Caudium sunucu ile kullanmak için bir Pike modülü olarak derlenir. DiZiN, Caudium sunucunun kurulu olduğu dizin olup /usr/local/caudium/server öntanımlıdır.

--disable-cli

PHP 4.3.0 ile kullanılabilir. PHP'nin CLI sürümünün derlenmemesini sağlar (bu, --without-pear seçeneğinin kullanımına sebep olur). Daha fazla bilgi PHP'nin komut satırından kullanımı bölümünde bulunabilir.

--enable-phpdbg

PHP 5.6.x ve sonrasında phpdbg etkileşimli hata ayıklayıcının SAPI modül desteğini etkin kılar.

--enable-embed[=TÜR]

Gömülü SAPI kütüphanesinin kurulmasını sağlar. TÜR olarak shared veya static belirtilebilir (paylaşımlı veya duruk); shared öntanımlıdır. PHP 4.3.0 ve sonrasında kullanılabilir.

--with-fhttpd[=DiZiN]

fhttpd modülü derlenir. DiZiN, fhttpd dizini olup /usr/local/src/fhttpd öntanımlıdır. PHP 4.3.0'dan beri kullanılmamaktadır.

--with-isapi=DiZiN

PHP, Zeus ile kullanmak için bir ISAPI modülü olarak derlenir.

--with-nsapi=DiZiN

Netscape/iPlanet/SunONE HTTP Sunucusunun kurulu olduğu dizin belirtilir.

--with-phttpd=DiZiN

Henüz bir bilgi yok.

--with-pi3web=DiZiN

PHP, Pi3Web ile kullanmak için bir modül olarak derlenir.

--with-roxen=DiZiN

PHP bir Pike modülü olarak derlenir. DiZiN, ana Roxen dizini olup normalde /usr/local/roxen/server dizinidir.

--enable-roxen-zts

Roxen modülü Zend Thread Safety kullanılarak derlenir.

--with-servlet[=DiZiN]

Servlet desteği etkinleştirilir. DiZiN, JSDK'nın ana kurulum dizinidir. Bu SAPI, bir paylaşımlı geliştirme dili olarak derlenmiş java eklentisi gerektirir.

--with-thttpd=KaynakDizini

PHP bir thttpd modülü olarak derlenir.

--with-tux=ModülDizini

PHP bir TUX modülü olarak derlenir (sadece Linux'ta).

--with-webjames=KaynakDizini

PHP bir WebJames modülü olarak derlenir (sadece RISC OS'ta).

--disable-cgi

PHP'nin CGI sürümü derlenmez. PHP 4.3.0 ve sonrasında kullanılabilir.

PHP 5.3.0 ve sonrasında, FastCGI bu seçenekten önce --enable-fastcgi ile etkin kılınmışsa bunu değiştirmez ve FastCGI etkin kılınır.

--enable-force-cgi-redirect

Sunucu içi yönlendirmeler için güvenlik denetimi etkin kılınır. PHP'yi Apache ile bir CGI olarak çalıştıracaksanız bu seçeneği kullanmalısınız.

PHP 5.3.0 ve sonrasında bu bileşen öntanımlı olarak etkin olup ayrıca bir seçenek olarak mevcut değildir. Bunu iptal etmek için kurulumdan sonra cgi.force_redirect ini yönergesine 0 değeri atanmalıdır.

--enable-discard-path

Etkin kılındığı takdirde, PHP CGI çalıştırılabiliri güvenle belge ağacının dışına yerleştirilebilir ve böylece .htaccess kullanıcılarının sorun çıkarmaları engellenmiş olur.

PHP 5.3.0 ve sonrasında bu bileşen öntanımlı olarak iptal edilmiş olup bir seçenek olarak mevcut değildir. Bunu etkin kılmak için kurulumdan sonra cgi.discard_path ini yönergesine 1 değeri atanmalıdır.

--with-fastcgi

PHP bir FastCGI uygulaması olarak derlenir. PHP 4.3.0'dan beri kullanılmamaktadır, yerine --enable-fastcgi kullanılmalıdır.

--enable-fastcgi

Etkin kılındığı takdirde, PHP CGI modülü, ayrıca FastCGI desteği de içerir.

PHP 5.3.0 ve sonrasında bu seçenek artık mevcut değildir ve yerine --enable-cgi seçeneği kullanılmalıdır.

--disable-path-info-check

Kullanıldığı takdirde, /info.php/test?a=b gibi dosya yollarının çalıştırılması başarısız olur. Daha ayrıntılı bilgi için » Apache Belgelerine bakınız.

Yapılandırma Seçenekleri
php.ini Yönergeleri
Yapılandırma Seçenekleri


php.ini Yönergeleri

İçindekiler

  • php.ini yönergelerinin listesi
  • php.ini bölümlerinin listesi
  • Temel php.ini yönergelerinin tanımları
Temel yapılandırma seçeneklerinin listesi
php.ini yönergelerinin listesi
Ekler


php.ini yönergelerinin listesi

Bu liste, PHP kurulumunuzu yapılandırmak için kullanabileceğiniz php.ini yönergelerini içerir.

Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
allow_call_time_pass_reference | "1" | PHP_INI_PERDIR | PHP 4.0.0'da PHP_INI_ALL. PHP 5.4.0'da kaldırıldı.
allow_url_fopen | "1" | PHP_INI_SYSTEM | PHP <= 4.3.4'da PHP_INI_ALL.
allow_url_include | "0" | PHP_INI_ALL | PHP 5.2.0 ve sonrasında mevcuttur.
always_populate_raw_post_data | "0" | PHP_INI_PERDIR | PHP <= 4.2.3'te PHP_INI_ALL. PHP 4.1.0 ve sonrasında mevcuttur.
apc.cache_by_default | "1" | PHP_INI_ALL | APC <= 3.0.12'de PHP_INI_SYSTEM. APC 3.0.0 ve sonrasında mevcuttur.
apc.enabled | "1" | PHP_INI_SYSTEM | APC 2'de PHP_INI_SYSTEM. APC <= 3.0.12'de PHP_INI_ALL.
apc.enable_cli | "0" | PHP_INI_SYSTEM | APC 3.0.7 ve sonrasında mevcuttur.
apc.file_update_protection | "2" | PHP_INI_SYSTEM | APC 3.0.6 ve sonrasında mevcuttur.
apc.filters | NULL | PHP_INI_SYSTEM |
apc.gc_ttl | "3600" | PHP_INI_SYSTEM |
apc.include_once_override | "0" | PHP_INI_SYSTEM | APC 3.0.12 ve sonrasında mevcuttur.
apc.localcache | "0" | PHP_INI_SYSTEM | APC 3.0.14 ve sonrasında mevcuttur.
apc.localcache.size | "512" | PHP_INI_SYSTEM | APC 3.0.14 ve sonrasında mevcuttur.
apc.max_file_size | "1M" | PHP_INI_SYSTEM | APC 3.0.7 ve sonrasında mevcuttur.
apc.mmap_file_mask | NULL | PHP_INI_SYSTEM |
apc.num_files_hint | "1000" | PHP_INI_SYSTEM |
apc.optimization | "0" | PHP_INI_ALL | APC 2'de PHP_INI_SYSTEM. APC 3.0.13'te kaldırıldı.
apc.report_autofilter | "0" | PHP_INI_SYSTEM | APC 3.0.11 ve sonrasında mevcuttur.
apc.rfc1867 | "0" | PHP_INI_SYSTEM | APC 3.0.13 ve sonrasında mevcuttur.
apc.rfc1867_freq | "0" | PHP_INI_SYSTEM |
apc.rfc1867_name | "APC_UPLOAD_PROGRESS" | PHP_INI_SYSTEM |
apc.rfc1867_prefix | "upload_" | PHP_INI_SYSTEM |
apc.shm_segments | "1" | PHP_INI_SYSTEM |
apc.shm_size | "30" | PHP_INI_SYSTEM |
apc.slam_defense | "0" | PHP_INI_SYSTEM | APC 3.0.0 ve sonrasında mevcuttur.
apc.stat | "1" | PHP_INI_SYSTEM | APC 3.0.10 ve sonrasında mevcuttur.
apc.stat_ctime | "0" | PHP_INI_SYSTEM | APC 3.0.13 ve sonrasında mevcuttur.
apc.ttl | "0" | PHP_INI_SYSTEM | APC 3.0.0 ve sonrasında mevcuttur.
apc.user_entries_hint | "4096" | PHP_INI_SYSTEM | APC 3.0.0 ve sonrasında mevcuttur.
apc.user_ttl | "0" | PHP_INI_SYSTEM | APC 3.0.0 ve sonrasında mevcuttur.
apc.write_lock | "1" | PHP_INI_SYSTEM | APC 3.0.11 ve sonrasında mevcuttur.
apd.bitmask | "0" | PHP_INI_ALL | apd 0.9'da kaldırıldı.
apd.dumpdir | NULL | PHP_INI_ALL |
apd.statement_tracing | "0" | PHP_INI_ALL | apd 0.9 ve sonrasında mevcuttur.
arg_separator.input | "&" | PHP_INI_PERDIR | PHP 4.0.5 ve sonrasında mevcuttur.
arg_separator.output | "&" | PHP_INI_ALL | PHP 4.0.5 ve sonrasında mevcuttur.
asp_tags | "0" | PHP_INI_PERDIR | PHP 4.0.0'da PHP_INI_ALL.
assert.active | "1" | PHP_INI_ALL |
assert.bail | "0" | PHP_INI_ALL |
assert.callback | NULL | PHP_INI_ALL |
assert.exception | "0" | PHP_INI_ALL | PHP 7.0.0 sürümünden itibaren kullanılabilir.
assert.quiet_eval | "0" | PHP_INI_ALL |
assert.warning | "1" | PHP_INI_ALL |
auto_append_file | NULL | PHP_INI_PERDIR | PHP <= 4.2.3'de PHP_INI_ALL.
auto_detect_line_endings | "0" | PHP_INI_ALL | PHP 4.3.0 ve sonrasında mevcuttur.
auto_globals_jit | "1" | PHP_INI_PERDIR | PHP 5.0.0 ve sonrasında mevcuttur.
auto_prepend_file | NULL | PHP_INI_PERDIR | PHP <= 4.2.3'te PHP_INI_ALL.
axis2.client_home | "~/work/axisc/c/deply" | PHP_INI_ALL |
axis2.enable_exception | "1" | PHP_INI_ALL |
axis2.enable_trace | "1" | PHP_INI_ALL |
axis2.log_path | "/tmp" | PHP_INI_ALL |
bcmath.scale | "0" | PHP_INI_ALL |
bcompiler.enabled | "1" | PHP_INI_ALL | bcompiler 0.8 ve sonrasında mevcuttur.
blenc.key_file | "/usr/local/etc/blenckeys" | PHP_INI_ALL |
browscap | NULL | PHP_INI_SYSTEM |
cgi.check_shebang_line | "1" | PHP_INI_SYSTEM | PHP 5.2.1 ve sonrasında mevcuttur.
cgi.discard_path | "0" | PHP_INI_SYSTEM | PHP 5.3.0 ve sonrasında mevcuttur.
cgi.fix_pathinfo | "1" | PHP_INI_SYSTEM | PHP <= 5.2.0'da PHP_INI_ALL. PHP 4.3.0 ve sonrasında mevcuttur.
cgi.force_redirect | "1" | PHP_INI_SYSTEM | PHP <= 5.2.0'da PHP_INI_ALL. PHP 4.2.0 ve sonrasında mevcuttur.
cgi.nph | "0" | PHP_INI_ALL | PHP 4.3.5 ve sonrasında mevcuttur.
cgi.redirect_status_env | NULL | PHP_INI_SYSTEM | PHP <= 5.2.0'da PHP_INI_ALL. PHP 4.2.0 ve sonrasında mevcuttur.
cgi.rfc2616_headers | "0" | PHP_INI_ALL | PHP 4.3.0 ve sonrasında mevcuttur.
child_terminate | "0" | PHP_INI_ALL | PHP 4.0.5 ve sonrasında mevcuttur.
cli.pager | "" | PHP_INI_ALL | PHP 5.4.0 ve sonrasında mevcuttur.
cli.prompt | "\\b \\> " | PHP_INI_ALL | PHP 5.4.0 ve sonrasında mevcuttur.
cli_server.color | "0" | PHP_INI_ALL | PHP 5.4.0 ve sonrasında mevcuttur.
coin_acceptor.autoreset | "On" | PHP_INI_ALL | coin_acceptor 0.2'de kaldırıldı.
coin_acceptor.auto_initialize | "Off" | PHP_INI_ALL | coin_acceptor 0.2 ve sonrasında mevcuttur.
coin_acceptor.auto_reset | "On" | PHP_INI_ALL | coin_acceptor 0.2 ve sonrasında mevcuttur.
coin_acceptor.command_function | "Off" | PHP_INI_ALL | coin_acceptor 0.3 ve sonrasında mevcuttur.
coin_acceptor.delay | "53132" | PHP_INI_ALL | coin_acceptor 0.2'de kaldırıldı.
coin_acceptor.delay_coins | "53132" | PHP_INI_ALL | coin_acceptor 0.2 ve sonrasında mevcuttur.
coin_acceptor.delay_prom | "55748" | PHP_INI_ALL | coin_acceptor 0.2 ve sonrasında mevcuttur.
coin_acceptor.device | "/dev/ttyS1" | PHP_INI_ALL | coin_acceptor 0.2'de kaldırıldı.
coin_acceptor.lock_on_close | "Off" | PHP_INI_ALL | coin_acceptor 0.2 ve sonrasında mevcuttur.
coin_acceptor.start_unlocked | "On" | PHP_INI_ALL | coin_acceptor 0.2 ve sonrasında mevcuttur.
com.allow_dcom | "0" | PHP_INI_SYSTEM | PHP 4.0.5 ve sonrasında mevcuttur.
com.autoregister_casesensitive | "1" | PHP_INI_ALL | PHP 4'te PHP_INI_SYSTEM. PHP 4.1.0 ve sonrasında mevcuttur.
com.autoregister_typelib | "0" | PHP_INI_ALL | PHP 4'te PHP_INI_SYSTEM. PHP 4.1.0 ve sonrasında mevcuttur.
com.autoregister_verbose | "0" | PHP_INI_ALL | PHP 4'te PHP_INI_SYSTEM. PHP 4.1.0 ve sonrasında mevcuttur.
com.code_page | "" | PHP_INI_ALL | PHP 5.0.0 ve sonrasında mevcuttur.
com.typelib_file | "" | PHP_INI_SYSTEM | PHP 4.0.5 ve sonrasında mevcuttur.
curl.cainfo | NULL | PHP_INI_SYSTEM | PHP 5.3.7 ve sonrasında mevcuttur.
daffodildb.default_host | "localhost" | PHP_INI_ALL |
daffodildb.default_password | "daffodil" | PHP_INI_ALL |
daffodildb.default_socket | NULL | PHP_INI_ALL |
daffodildb.default_user | "DAFFODIL" | PHP_INI_ALL |
daffodildb.port | "3456" | PHP_INI_ALL |
date.default_latitude | "31.7667" | PHP_INI_ALL | PHP 5.0.0 ve sonrasında mevcuttur.
date.default_longitude | "35.2333" | PHP_INI_ALL | PHP 5.0.0 ve sonrasında mevcuttur.
date.sunrise_zenith | "90.583333" | PHP_INI_ALL | PHP 5.0.0 ve sonrasında mevcuttur.
date.sunset_zenith | "90.583333" | PHP_INI_ALL | PHP 5.0.0 ve sonrasında mevcuttur.
date.timezone | "" | PHP_INI_ALL | PHP 5.1.0 ve sonrasında mevcuttur.
dba.default_handler | "" | PHP_INI_ALL | PHP 4.3.3 ve sonrasında mevcuttur.
dbx.colnames_case | "unchanged" | PHP_INI_SYSTEM | PHP 4.3.0 ve sonrasında mevcuttur. PHP 5.1.0'da kaldırıldı.
default_charset | "UTF-8" | PHP_INI_ALL | PHP >= 5.6.0'dan beri "UTF-8" öntanımlıdır, PHP < 5.6.0 için boş dizgedir.
default_mimetype | "text/html" | PHP_INI_ALL |
default_socket_timeout | "60" | PHP_INI_ALL | PHP 4.3.0 ve sonrasında mevcuttur.
define_syslog_variables | "0" | PHP_INI_ALL | Bu kullanımı önerilmeyen özellik gelecekte kesinlikle KALDIRILACAKTIR.
detect_unicode | "1" | PHP_INI_ALL | PHP 5.1.0 ve sonrasında mevcuttur. PHP 5.4.0'da ismi zend.detect_unicode oldu.
disable_classes | "" | sadece php.ini | PHP 4.3.2 ve sonrasında mevcuttur.
disable_functions | "" | sadece php.ini | PHP 4.0.1 ve sonrasında mevcuttur.
display_errors | "1" | PHP_INI_ALL |
display_startup_errors | "0" | PHP_INI_ALL | PHP 4.0.3 ve sonrasında mevcuttur.
docref_ext | "" | PHP_INI_ALL | PHP 4.3.2 ve sonrasında mevcuttur.
docref_root | "" | PHP_INI_ALL | PHP 4.3.0 ve sonrasında mevcuttur.
doc_root | NULL | PHP_INI_SYSTEM |
enable_dl | "1" | PHP_INI_SYSTEM | Bu kullanımı önerilmeyen özellik gelecekte kesinlikle KALDIRILACAKTIR.
enable_post_data_reading | On | PHP_INI_PERDIR | PHP 5.4.0 ve sonrasında mevcuttur.
engine | "1" | PHP_INI_ALL | PHP 4.0.5 ve sonrasında mevcuttur.
error_append_string | NULL | PHP_INI_ALL |
error_log | NULL | PHP_INI_ALL |
error_prepend_string | NULL | PHP_INI_ALL |
error_reporting | NULL | PHP_INI_ALL |
exif.decode_jis_intel | "JIS" | PHP_INI_ALL | PHP 4.3.0 ve sonrasında mevcuttur.
exif.decode_jis_motorola | "JIS" | PHP_INI_ALL | PHP 4.3.0 ve sonrasında mevcuttur.
exif.decode_unicode_intel | "UCS-2LE" | PHP_INI_ALL | PHP 4.3.0 ve sonrasında mevcuttur.
exif.decode_unicode_motorola | "UCS-2BE" | PHP_INI_ALL | PHP 4.3.0 ve sonrasında mevcuttur.
exif.encode_jis | "" | PHP_INI_ALL | PHP 4.3.0 ve sonrasında mevcuttur.
exif.encode_unicode | "ISO-8859-15" | PHP_INI_ALL | PHP 4.3.0 ve sonrasında mevcuttur.
exit_on_timeout | "" | PHP_INI_ALL | PHP 5.3.0 ve sonrasında mevcuttur.
expect.logfile | "" | PHP_INI_ALL |
expect.loguser | "1" | PHP_INI_ALL |
expect.timeout | "10" | PHP_INI_ALL |
expose_php | "1" | sadece php.ini |
extension | NULL | sadece php.ini |
extension_dir | "/path/to/php" | PHP_INI_SYSTEM |
fastcgi.impersonate | "0" | PHP_INI_SYSTEM | PHP <= 5.2.0'da PHP_INI_ALL. PHP 4.3.0 ve sonrasında mevcuttur.
fastcgi.logging | "1" | PHP_INI_SYSTEM | PHP <= 5.2.0'da PHP_INI_ALL. PHP 4.4.0 ve sonrasında mevcuttur.
fbsql.allow_persistent | "1" | PHP_INI_SYSTEM | PHP 4.2.0 ve sonrasında mevcuttur.
fbsql.autocommit | "1" | PHP_INI_SYSTEM | PHP 4.0.6 ve sonrasında mevcuttur.
fbsql.batchSize | "1000" | PHP_INI_SYSTEM | PHP 4.2.0 ve sonrasında mevcuttur. PHP 5.1.0'da kaldırıldı.
fbsql.batchsize | "1000" | PHP_INI_ALL | PHP 5.1.0 ve sonrasında mevcuttur.
fbsql.default_database | "" | PHP_INI_SYSTEM | PHP 4.0.6 ve sonrasında mevcuttur.
fbsql.default_database_password | "" | PHP_INI_SYSTEM | PHP 4.0.6 ve sonrasında mevcuttur.
fbsql.default_host | NULL | PHP_INI_SYSTEM | PHP 4.0.6 ve sonrasında mevcuttur.
fbsql.default_password | "" | PHP_INI_SYSTEM | PHP 4.0.6 ve sonrasında mevcuttur.
fbsql.default_user | "_SYSTEM" | PHP_INI_SYSTEM | PHP 4.0.6 ve sonrasında mevcuttur.
fbsql.generate_warnings | "0" | PHP_INI_SYSTEM | PHP 4.0.6 ve sonrasında mevcuttur.
fbsql.max_connections | "128" | PHP_INI_SYSTEM | PHP 4.0.6 ve sonrasında mevcuttur.
fbsql.max_links | "128" | PHP_INI_SYSTEM | PHP 4.0.6 ve sonrasında mevcuttur.
fbsql.max_persistent | "-1" | PHP_INI_SYSTEM | PHP 4.0.6 ve sonrasında mevcuttur.
fbsql.max_results | "128" | PHP_INI_SYSTEM | PHP 4.0.6 ve sonrasında mevcuttur.
fbsql.show_timestamp_decimals | "0" | PHP_INI_SYSTEM | PHP 5.1.5 ve sonrasında mevcuttur.
file_uploads | "1" | PHP_INI_SYSTEM | PHP <= 4.2.3'te PHP_INI_ALL. PHP 4.0.3 ve sonrasında mevcuttur.
filter.default | "unsafe_raw" | PHP_INI_PERDIR | filter <= 0.9.4'te PHP_INI_ALL. PHP 5.2.0 ve sonrasında mevcuttur.
filter.default_flags | NULL | PHP_INI_PERDIR | filter <= 0.9.4'te PHP_INI_ALL. PHP 5.2.0 ve sonrasında mevcuttur.
from | "" | PHP_INI_ALL |
gd.jpeg_ignore_warning | "1" | PHP_INI_ALL | PHP 5.1.3 ve sonrasında mevcuttur.
geoip.custom_directory | NULL | PHP_INI_ALL | geoip 1.0.1 ve sonrasında mevcuttur.
geoip.database_standard | "GeoIP.dat" | PHP_INI_ALL | geoip 1.0.1'de kaldırıldı.
hidef.ini_path | (char*)default_ini_path | PHP_INI_SYSTEM |
highlight.bg | "#FFFFFF" | PHP_INI_ALL | Bu kullanımı önerilmeyen özellik gelecekte kesinlikle KALDIRILACAKTIR.
highlight.comment | "#FF8000" | PHP_INI_ALL |
highlight.default | "#0000BB" | PHP_INI_ALL |
highlight.html | "#000000" | PHP_INI_ALL |
.keyword | "#007700" | PHP_INI_ALL |
highlight.string | "#DD0000" | PHP_INI_ALL |
html_errors | "1" | PHP_INI_ALL | PHP <= 4.2.3'te PHP_INI_SYSTEM. PHP 4.0.2 ve sonrasında mevcuttur.
> htscanner.config_file | ".htaccess" | PHP_INI_SYSTEM |
htscanner.default_docroot | "/" | PHP_INI_SYSTEM |
htscanner.default_ttl | "300" | PHP_INI_SYSTEM | htscanner 0.6.0 ve sonrasında mevcuttur.
htscanner.stop_on_error | "0" | PHP_INI_SYSTEM | htscanner 0.7.0 ve sonrasında mevcuttur.
http.allowed_methods | "" | PHP_INI_ALL | pecl_http 0.4.0 ve sonrasında mevcuttur. pecl_http 0.4.0'da kaldırıldı.
http.allowed_methods_log | "" | PHP_INI_ALL | pecl_http 0.12.0 ve sonrasında mevcuttur. pecl_http 0.4.0'da kaldırıldı.
http.cache_log | "" | PHP_INI_ALL | pecl_http 0.8.0 ve sonrasında mevcuttur. pecl_http 0.4.0'da kaldırıldı.
http.composite_log | "" | PHP_INI_ALL | pecl_http 0.12.0 ve sonrasında mevcuttur. pecl_http 0.4.0'da kaldırıldı.
http.etag.mode | "MD5" | PHP_INI_ALL | pecl_http 1.0.0 ve sonrasında mevcuttur.
http.etag_mode | "MD5" | PHP_INI_ALL | pecl_http 0.12.0 ve sonrasında mevcuttur. pecl_http 0.4.0'da kaldırıldı.
http.force_exit | "1" | PHP_INI_ALL | pecl_http 0.18.0 ve sonrasında mevcuttur.
http.log.allowed_methods | "" | PHP_INI_ALL | pecl_http 1.0.0 ve sonrasında mevcuttur.
http.log.cache | "" | PHP_INI_ALL | pecl_http 1.0.0 ve sonrasında mevcuttur.
http.log.composite | "" | PHP_INI_ALL | pecl_http 1.0.0 ve sonrasında mevcuttur.
http.log.not_found | "" | PHP_INI_ALL | pecl_http 1.0.0 ve sonrasında mevcuttur.
http.log.redirect | "" | PHP_INI_ALL | pecl_http 1.0.0 ve sonrasında mevcuttur.
http.ob_deflate_auto | "0" | PHP_INI_PERDIR | pecl_http 0.21.0 ve sonrasında mevcuttur. pecl_http 0.4.0'da kaldırıldı.
http.ob_deflate_flags | "0" | PHP_INI_ALL | pecl_http 0.21.0 ve sonrasında mevcuttur. pecl_http 0.4.0'da kaldırıldı.
http.ob_inflate_auto | "0" | PHP_INI_PERDIR | pecl_http 0.21.0 ve sonrasında mevcuttur. pecl_http 0.4.0'da kaldırıldı.
http.ob_inflate_flags | "0" | PHP_INI_ALL | pecl_http 0.21.0 ve sonrasında mevcuttur. pecl_http 0.4.0'da kaldırıldı.
http.only_exceptions | "0" | PHP_INI_ALL | pecl_http 0.11.0 ve sonrasında mevcuttur.
http.persistent.handles.ident | "GLOBAL" | PHP_INI_ALL | pecl_http 1.5.0 ve sonrasında mevcuttur.
http.persistent.handles.limit | "-1" | PHP_INI_SYSTEM | pecl_http 1.5.0 ve sonrasında mevcuttur.
http.redirect_log | "" | PHP_INI_ALL | pecl_http 0.12.0 ve sonrasında mevcuttur. pecl_http 0.4.0'da kaldırıldı.
http.request.datashare.connect | "0" | PHP_INI_SYSTEM | pecl_http 1.3.0 ve sonrasında mevcuttur.
http.request.datashare.cookie | "0" | PHP_INI_SYSTEM | pecl_http 1.3.0 ve sonrasında mevcuttur.
http.request.datashare.dns | "1" | PHP_INI_SYSTEM | pecl_http 1.3.0 ve sonrasında mevcuttur.
http.request.datashare.ssl | "0" | PHP_INI_SYSTEM | pecl_http 1.3.0 ve sonrasında mevcuttur.
http.request.methods.allowed | "" | PHP_INI_ALL | pecl_http 1.0.0 ve sonrasında mevcuttur.
http.request.methods.custom | "" | PHP_INI_PERDIR | pecl_http 1.0.0 ve sonrasında mevcuttur.
http.send.deflate.start_auto | "0" | PHP_INI_PERDIR | pecl_http 1.0.0 ve sonrasında mevcuttur.
http.send.deflate.start_flags | "0" | PHP_INI_ALL | pecl_http 1.0.0 ve sonrasında mevcuttur.
http.send.inflate.start_auto | "0" | PHP_INI_PERDIR | pecl_http 1.0.0 ve sonrasında mevcuttur.
http.send.inflate.start_flags | "0" | PHP_INI_ALL | pecl_http 1.0.0 ve sonrasında mevcuttur.
http.send.not_found_404 | "1" | PHP_INI_ALL | pecl_http 1.0.0 ve sonrasında mevcuttur.
ibase.allow_persistent | "1" | PHP_INI_SYSTEM |
ibase.dateformat | "%Y-%m-%d" | PHP_INI_ALL |
ibase.default_charset | NULL | PHP_INI_ALL | PHP 5.0.0 ve sonrasında mevcuttur.
ibase.default_db | NULL | PHP_INI_SYSTEM | PHP 5.0.0 ve sonrasında mevcuttur.
ibase.default_password | NULL | PHP_INI_ALL |
ibase.default_user | NULL | PHP_INI_ALL |
ibase.max_links | "-1" | PHP_INI_SYSTEM |
ibase.max_persistent | "-1" | PHP_INI_SYSTEM |
ibase.timeformat | "%H:%M:%S" | PHP_INI_ALL |
ibase.timestampformat | "%Y-%m-%d %H:%M:%S" | PHP_INI_ALL |
ibm_db2.binmode | "1" | PHP_INI_ALL |
ibm_db2.i5_all_pconnect | "0" | PHP_INI_SYSTEM | Available since ibm_db2 1.6.5.
ibm_db2.i5_allow_commit | "0" | PHP_INI_SYSTEM | Available since ibm_db2 1.4.9.
ibm_db2.i5_dbcs_alloc | "0" | PHP_INI_SYSTEM | Available since ibm_db2 1.5.0.
ibm_db2.instance_name | NULL | PHP_INI_SYSTEM | Available since ibm_db2 1.0.2.
ibm_db2.i5_ignore_userid | "0" | PHP_INI_SYSTEM | Available since ibm_db2 1.8.0.
iconv.input_encoding | "ISO-8859-1" | PHP_INI_ALL | PHP 4.0.5 ve sonrasında mevcuttur.
iconv.internal_encoding | "ISO-8859-1" | PHP_INI_ALL | PHP 4.0.5 ve sonrasında mevcuttur.
iconv.output_encoding | "ISO-8859-1" | PHP_INI_ALL | PHP 4.0.5 ve sonrasında mevcuttur.
ifx.allow_persistent | "1" | PHP_INI_SYSTEM | PHP 5.2.1'de kaldırıldı.
ifx.blobinfile | "1" | PHP_INI_ALL | PHP 5.2.1'de kaldırıldı.
ifx.byteasvarchar | "0" | PHP_INI_ALL | PHP 5.2.1'de kaldırıldı.
ifx.charasvarchar | "0" | PHP_INI_ALL | PHP 5.2.1'de kaldırıldı.
ifx.default_host | NULL | PHP_INI_SYSTEM | PHP 5.2.1'de kaldırıldı.
ifx.default_password | NULL | PHP_INI_SYSTEM | PHP 5.2.1'de kaldırıldı.
ifx.default_user | NULL | PHP_INI_SYSTEM | PHP 5.2.1'de kaldırıldı.
ifx.max_links | "-1" | PHP_INI_SYSTEM | PHP 5.2.1'de kaldırıldı.
ifx.max_persistent | "-1" | PHP_INI_SYSTEM | PHP 5.2.1'de kaldırıldı.
ifx.nullformat | "0" | PHP_INI_ALL | PHP 5.2.1'de kaldırıldı.
ifx.textasvarchar | "0" | PHP_INI_ALL | PHP 5.2.1'de kaldırıldı.
ignore_repeated_errors | "0" | PHP_INI_ALL | PHP 4.3.0 ve sonrasında mevcuttur.
ignore_repeated_source | "0" | PHP_INI_ALL | PHP 4.3.0 ve sonrasında mevcuttur.
ignore_user_abort | "0" | PHP_INI_ALL |
imlib2.font_cache_max_size | "524288" | PHP_INI_ALL |
imlib2.font_path | "/usr/share/php/fonts/" | PHP_INI_ALL |
implicit_flush | "0" | PHP_INI_ALL | PHP <= 4.2.3'te PHP_INI_PERDIR.
include_path | ".;/path/to/php/pear" | PHP_INI_ALL |
intl.default_locale | "" | PHP_INI_ALL | 5.3.0 ve sonrasında mevcuttur.
intl.error_level | "0" | PHP_INI_ALL | 5.3.0 ve sonrasında mevcuttur.
intl.use_exceptions | "0" | PHP_INI_ALL | 5.5.0 ve sonrasında mevcuttur.
ingres.allow_persistent | "1" | PHP_INI_SYSTEM | Available since ingres 1.0.0
ingres.array_index_start | "1" | PHP_INI_ALL | Available since ingres 1.4.0.
ingres.auto | "1" | PHP_INI_ALL | Available since ingres 2.0.0.
ingres.blob_segment_length | "4096" | PHP_INI_ALL | Available since ingres 1.2.0.
ingres.cursor_mode | "0" | PHP_INI_ALL | Available since ingres 1.1.0.
ingres.default_database | NULL | PHP_INI_ALL | Available since ingres 1.0.0
ingres.default_password | NULL | PHP_INI_ALL | Available since ingres 1.0.0
ingres.default_user | NULL | PHP_INI_ALL | Available since ingres 1.0.0
ingres.describe | 1 | PHP_INI_ALL | Available since ingres 2.1.0
ingres.fetch_buffer_size | 100 | PHP_INI_ALL | Available since ingres 2.1.0
ingres.max_links | "-1" | PHP_INI_SYSTEM | Available since ingres 1.0.0
ingres.max_persistent | "-1" | PHP_INI_SYSTEM | Available since ingres 1.0.0
ingres.reuse_connection | "1" | PHP_INI_ALL | Available since ingres 2.0.0
ingres.scrollable | "1" | PHP_INI_ALL | Available since ingres 2.0.0.
ingres.trace | "0" | PHP_INI_ALL | Available since ingres 2.0.0.
ingres.trace_connect | "0" | PHP_INI_ALL | Available since ingres 1.2.1.
ingres.utf8 | "1" | PHP_INI_ALL | Available since ingres 2.0.0.
last_modified | "0" | PHP_INI_ALL | PHP 4.0.5 ve sonrasında mevcuttur.
ldap.max_links | "-1" | PHP_INI_SYSTEM |
log_errors | "0" | PHP_INI_ALL |
log_errors_max_len | "1024" | PHP_INI_ALL | PHP 4.3.0 ve sonrasında mevcuttur.
magic_quotes_gpc | "1" | PHP_INI_PERDIR | PHP <= 4.2.3'te PHP_INI_ALL. PHP 5.3.0'dan itibaren kullanımı önerilmemektedir. PHP 5.4.0'da kaldırıldı.
magic_quotes_runtime | "0" | PHP_INI_ALL | PHP 5.4.0'da kaldırıldı.
magic_quotes_sybase | "0" | PHP_INI_ALL | PHP 5.4.0'da kaldırıldı.
mail.add_x_header | "0" | PHP_INI_SYSTEM|PHP_INI_PERDIR | PHP 5.3.0 ve sonrasında mevcuttur.
mail.force_extra_parameters | NULL | sadece php.ini | PHP 5.0.0 ve sonrasında mevcuttur.
mail.log | "" | >PHP_INI_PERDIR | PHP 5.3.0 ve sonrasında mevcuttur. (PHP_INI_SYSTEM|PHP_INI_PERDIR)
maxdb.default_db | NULL | PHP_INI_ALL |
maxdb.default_host | NULL | PHP_INI_ALL |
maxdb.default_pw | NULL | PHP_INI_ALL |
maxdb.default_user | NULL | PHP_INI_ALL |
maxdb.long_readlen | "200" | PHP_INI_ALL |
max_execution_time | "30" | PHP_INI_ALL |
max_input_nesting_level | "64" | PHP_INI_PERDIR | PHP 4.4.8 ve sonrasında mevcuttur. PHP 5.0.0'da kaldırıldı.
max_input_vars | 1000 | PHP_INI_PERDIR | PHP 5.3.9 ve sonrasında mevcuttur.
max_input_time | "-1" | PHP_INI_PERDIR | PHP 4.3.0 ve sonrasında mevcuttur.
mbstring.detect_order | NULL | PHP_INI_ALL | PHP 4.0.6 ve sonrasında mevcuttur.
mbstring.encoding_translation | "0" | PHP_INI_PERDIR | PHP 4.3.0 ve sonrasında mevcuttur.
mbstring.func_overload | "0" | PHP_INI_SYSTEM | PHP <= 4.2.3'te PHP_INI_SYSTEM. PHP 4.3'ten 5.2.6'ya kadar PHP_INI_SYSTEM | PHP_INI_PERDIR. PHP 4.2.0 ve sonrasında mevcuttur.
mbstring.http_input | "pass" | PHP_INI_ALL | PHP 4.0.6 ve sonrasında mevcuttur.
mbstring.http_output | "pass" | PHP_INI_ALL | PHP 4.0.6 ve sonrasında mevcuttur.
mbstring.internal_encoding | NULL | PHP_INI_ALL | PHP 4.0.6 ve sonrasında mevcuttur.
mbstring.language | "neutral" | PHP_INI_PERDIR | PHP 4.3.0 ve sonrasında mevcuttur.
mbstring.script_encoding | NULL | PHP_INI_ALL | PHP 4.3.0 ve sonrasında mevcuttur. 5.4.0'da kaldırıldı. Yerine zend.script_encoding kullanın.
mbstring.http_output_conv_mimetypes | "^(text/|application/xhtml\+xml)" | PHP_INI_ALL | PHP 5.3.0 ve sonrasında mevcuttur.
mbstring.strict_detection | "0" | PHP_INI_ALL | PHP 5.1.2 ve sonrasında mevcuttur.
mbstring.substitute_character | NULL | PHP_INI_ALL | PHP 4.0.6 ve sonrasında mevcuttur.
mcrypt.algorithms_dir | NULL | PHP_INI_ALL | PHP 4.0.2 ve sonrasında mevcuttur.
mcrypt.modes_dir | NULL | PHP_INI_ALL | PHP 4.0.2 ve sonrasında mevcuttur.
memcache.allow_failover | "1" | PHP_INI_ALL | memcache 2.0.2 ve sonrasında mevcuttur.
memcache.chunk_size | "8192" | PHP_INI_ALL | memcache 2.0.2 ve sonrasında mevcuttur.
memcache.default_port | "11211" | PHP_INI_ALL | memcache 2.0.2 ve sonrasında mevcuttur.
memcache.hash_function | "crc32" | PHP_INI_ALL | memcache 2.2.0 ve sonrasında mevcuttur.
memcache.hash_strategy | "standard" | PHP_INI_ALL | memcache 2.2.0 ve sonrasında mevcuttur.
memcache.max_failover_attempts | "20" | PHP_INI_ALL | memcache 2.1.0 ve sonrasında mevcuttur.
memory_limit | "128M" | PHP_INI_ALL |
mime_magic.debug | "0" | PHP_INI_SYSTEM | PHP 5.0.0 ve sonrasında mevcuttur.
mime_magic.magicfile | "/path/to/php/magic.mime" | PHP_INI_SYSTEM | PHP 4.3.0 ve sonrasında mevcuttur.
mongo.allow_empty_keys | 0 | PHP_INI_ALL |
mongo.allow_persistent | 1 | PHP_INI_ALL | Removed in 1.2.0
mongo.chunk_size | 262144 | PHP_INI_ALL |
mongo.cmd | "$" | PHP_INI_ALL |
mongo.default_host | "localhost" | PHP_INI_ALL |
mongo.default_port | 27017 | PHP_INI_ALL |
mongo.is_master_interval | 15 | PHP_INI_ALL | Added in 1.2.10, before 1.3.0 the default value was 60.
mongo.long_as_object | 0 | PHP_INI_ALL |
mongo.native_long | 1 | PHP_INI_ALL | Before 1.5.0, the default value was 0.
mongo.ping_interval | 5 | PHP_INI_ALL | Added in 1.2.10
mongo.utf8 | 1 | PHP_INI_ALL |
msql.allow_persistent | "1" | PHP_INI_ALL |
msql.max_links | "-1" | PHP_INI_ALL |
msql.max_persistent | "-1" | PHP_INI_ALL |
mssql.allow_persistent | "1" | PHP_INI_SYSTEM |
mssql.batchsize | "0" | PHP_INI_ALL | PHP 4.0.4 ve sonrasında mevcuttur.
mssql.charset | "" | PHP_INI_ALL | PHP 5.1.2 ve sonrasında mevcuttur.
mssql.compatability_mode | "0" | PHP_INI_ALL |
mssql.connect_timeout | "5" | PHP_INI_ALL |
mssql.datetimeconvert | "1" | PHP_INI_ALL | PHP 4.2.0 ve sonrasında mevcuttur.
mssql.max_links | "-1" | PHP_INI_SYSTEM |
mssql.max_persistent | "-1" | PHP_INI_SYSTEM |
mssql.max_procs | "-1" | PHP_INI_ALL | PHP 4.3.0 ve sonrasında mevcuttur.
mssql.min_error_severity | "10" | PHP_INI_ALL |
mssql.min_message_severity | "10" | PHP_INI_ALL |
mssql.secure_connection | "0" | PHP_INI_SYSTEM | PHP 4.3.0 ve sonrasında mevcuttur.
mssql.textlimit | "-1" | PHP_INI_ALL |
mssql.textsize | "-1" | PHP_INI_ALL |
mssql.timeout | "60" | PHP_INI_ALL | PHP 4.1.0 ve sonrasında mevcuttur.
mysql.allow_local_infile | "1" | PHP_INI_SYSTEM |
mysql.allow_persistent | "1" | PHP_INI_SYSTEM |
mysql.max_persistent | "-1" | PHP_INI_SYSTEM |
mysql.max_links | "-1" | PHP_INI_SYSTEM |
mysql.trace_mode | "0" | PHP_INI_ALL | PHP 4.3.0'den itibaren kullanılabilir.
mysql.default_port | NULL | PHP_INI_ALL |
mysql.default_socket | NULL | PHP_INI_ALL | PHP 4.0.1'den itibaren kullanılabilir.
mysql.default_host | NULL | PHP_INI_ALL |
mysql.default_user | NULL | PHP_INI_ALL |
mysql.default_password | NULL | PHP_INI_ALL |
mysql.connect_timeout | "60" | PHP_INI_ALL | PHP <= 4.3.2'te PHP_INI_SYSTEM. PHP 4.3.0'den itibaren kullanılabilir.
mysqli.allow_local_infile | "1" | PHP_INI_SYSTEM | Available since PHP 5.2.4.
mysqli.allow_persistent | "1" | PHP_INI_SYSTEM | Available since PHP 5.3.0.
mysqli.max_persistent | "-1" | PHP_INI_SYSTEM | Available since PHP 5.3.0.
mysqli.max_links | "-1" | PHP_INI_SYSTEM | Available since PHP 5.0.0.
mysqli.default_port | "3306" | PHP_INI_ALL | Available since PHP 5.0.0.
mysqli.default_socket | NULL | PHP_INI_ALL | Available since PHP 5.0.0.
mysqli.default_host | NULL | PHP_INI_ALL | Available since PHP 5.0.0.
mysqli.default_user | NULL | PHP_INI_ALL | Available since PHP 5.0.0.
mysqli.default_pw | NULL | PHP_INI_ALL | Available since PHP 5.0.0.
mysqli.reconnect | "0" | PHP_INI_SYSTEM | Available since PHP 4.3.5.
mysqli.rollback_on_cached_plink | TRUE | PHP_INI_SYSTEM | Available since PHP 5.6.0.
mysqli.cache_size | "2000" | PHP_INI_SYSTEM | Available since PHP 5.3.0.
mysqlnd.collect_memory_statistics | "0" | PHP_INI_SYSTEM | PHP 5.3.0 ve sonrasında mevcuttur.
mysqlnd.collect_statistics | "1" | PHP_INI_ALL | PHP 5.3.0 ve sonrasında mevcuttur.
mysqlnd.debug | "" | PHP_INI_SYSTEM | PHP 5.3.0 ve sonrasında mevcuttur.
mysqlnd.log_mask | "0" | PHP_INI_ALL | PHP 5.3.0 ve sonrasında mevcuttur.
mysqlnd.mempool_default_size | "16000" | PHP_INI_ALL | PHP 5.3.0 ve sonrasında mevcuttur.
mysqlnd.net_cmd_buffer_size | "4096" | PHP_INI_ALL | PHP 5.4.0 ve sonrasında mevcuttur.
mysqlnd.net_read_buffer_size | "32768" | PHP_INI_ALL | PHP 5.3.0 ve sonrasında mevcuttur.
mysqlnd.net_read_timeout | "31536000" | PHP_INI_SYSTEM | PHP 5.4.0 ve sonrasında mevcuttur.
mysqlnd.sha256_server_public_key | "" | PHP_INI_PERDIR | PHP 5.5.0 ve sonrasında mevcuttur.
mysqlnd.trace_alloc | "" | PHP_INI_SYSTEM | PHP 5.5.0 ve sonrasında mevcuttur.
mysqlnd_memcache.enable | 1 | PHP_INI_SYSTEM | Available since 1.0.0
mysqlnd_ms.enable | 0 | PHP_INI_SYSTEM |
mysqlnd_ms.force_config_usage | 0 | PHP_INI_SYSTEM |
mysqlnd_ms.ini_file | "" | PHP_INI_SYSTEM |
mysqlnd_ms.config_file | "" | PHP_INI_SYSTEM |
mysqlnd_ms.collect_statistics | 0 | PHP_INI_SYSTEM |
mysqlnd_ms.multi_master | 0 | PHP_INI_SYSTEM |
mysqlnd_ms.disable_rw_split | 0 | PHP_INI_SYSTEM |
mysqlnd_mux.enable | 0 | PHP_INI_SYSTEM |
mysqlnd_qc.enable_qc | 1 | PHP_INI_SYSTEM |
mysqlnd_qc.ttl | 30 | PHP_INI_ALL |
mysqlnd_qc.cache_by_default | 0 | PHP_INI_ALL |
mysqlnd_qc.cache_no_table | 0 | PHP_INI_ALL |
mysqlnd_qc.use_request_time | 0 | PHP_INI_ALL |
mysqlnd_qc.time_statistics | 1 | PHP_INI_ALL |
mysqlnd_qc.collect_statistics | 0 | PHP_INI_ALL |
mysqlnd_qc.collect_statistics_log_file | /tmp/mysqlnd_qc.stats | PHP_INI_SYSTEM |
mysqlnd_qc.collect_query_trace | 0 | PHP_INI_SYSTEM |
mysqlnd_qc.query_trace_bt_depth | 3 | PHP_INI_SYSTEM |
mysqlnd_qc.collect_normalized_query_trace | 0 | PHP_INI_SYSTEM |
mysqlnd_qc.ignore_sql_comments | 1 | PHP_INI_ALL |
mysqlnd_qc.slam_defense | 0 | PHP_INI_SYSTEM |
mysqlnd_qc.slam_defense_ttl | 30 | PHP_INI_SYSTEM |
mysqlnd_qc.std_data_copy | 0 | PHP_INI_SYSTEM |
mysqlnd_qc.apc_prefix | qc_ | PHP_INI_ALL |
mysqlnd_qc.memc_server | 127.0.0.1 | PHP_INI_ALL |
mysqlnd_qc.memc_port | 11211 | PHP_INI_ALL |
mysqlnd_qc.sqlite_data_file | :memory: | PHP_INI_ALL |
mysqlnd_uh.enable | 1 | PHP_INI_SYSTEM |
mysqlnd_uh.report_wrong_types | 1 | PHP_INI_ALL |
nsapi.read_timeout | "60" | PHP_INI_ALL | PHP 4.3.3 ve sonrasında mevcuttur.
oci8.connection_class | "" | PHP_INI_ALL | PHP 5.3 ve sonrasında mevcuttur (PECL OCI8 1.3).
oci8.default_prefetch | "10" | PHP_INI_SYSTEM | PHP 5.1.2 ve sonrasında mevcuttur.
oci8.events | Off | PHP_INI_SYSTEM | PHP 5.3 ve sonrasında mevcuttur (PECL OCI8 1.3).
oci8.max_persistent | "-1" | PHP_INI_SYSTEM | PHP 5.1.2 ve sonrasında mevcuttur.
oci8.old_oci_close_semantics | "0" | PHP_INI_SYSTEM | PHP 5.1.2 ve sonrasında mevcuttur.
oci8.persistent_timeout | "-1" | PHP_INI_SYSTEM | PHP 5.1.2 ve sonrasında mevcuttur.
oci8.ping_interval | "60" | PHP_INI_SYSTEM | PHP 5.1.2 ve sonrasında mevcuttur.
oci8.privileged_connect | "0" | PHP_INI_SYSTEM | PHP 5.1.2 ve sonrasında mevcuttur.
oci8.statement_cache_size | "20" | PHP_INI_SYSTEM | PHP 5.1.2 ve sonrasında mevcuttur.
odbc.allow_persistent | "1" | PHP_INI_SYSTEM |
odbc.check_persistent | "1" | PHP_INI_SYSTEM |
odbc.defaultbinmode | "1" | PHP_INI_ALL |
odbc.defaultlrl | "4096" | PHP_INI_ALL |
odbc.default_db | NULL | PHP_INI_ALL |
odbc.default_cursortype | "3" | PHP_INI_ALL | PHP 5.3.0 ve sonrasında mevcuttur.
odbc.default_pw | NULL | PHP_INI_ALL |
odbc.default_user | NULL | PHP_INI_ALL |
odbc.max_links | "-1" | PHP_INI_SYSTEM |
odbc.max_persistent | "-1" | PHP_INI_SYSTEM |
odbtp.datetime_format | "object" | PHP_INI_ALL |
odbtp.detach_default_queries | "0" | PHP_INI_ALL |
odbtp.guid_format | "string" | PHP_INI_ALL | odbtp 1.1.3 ve sonrasında mevcuttur.
odbtp.interface_file | "/usr/local/share/odbtp.conf" | PHP_INI_ALL |
odbtp.truncation_errors | "1" | PHP_INI_ALL |
opendirectory.default_separator | "/" | PHP_INI_ALL | opendirectory 0.2.2'de kaldırıldı.
opendirectory.max_refs | "-1" | PHP_INI_ALL |
opendirectory.separator | "/" | PHP_INI_ALL | Available since opendirectory 0.2.2.
open_basedir | NULL | PHP_INI_ALL | PHP < 5.2.3'te PHP_INI_SYSTEM.
oracle.allow_persistent | "-1" | PHP_INI_ALL | PHP 5.1.0'da kaldırıldı.
oracle.max_links | "-1" | PHP_INI_ALL | PHP 5.1.0'da kaldırıldı.
oracle.max_persistent | "-1" | PHP_INI_ALL | PHP 5.1.0'da kaldırıldı.
output_buffering | "0" | PHP_INI_PERDIR |
output_handler | NULL | PHP_INI_PERDIR | PHP 4.0.4 ve sonrasında mevcuttur.
pam.servicename | "php" | PHP_INI_ALL |
pcre.backtrack_limit | "100000" | PHP_INI_ALL | PHP 5.2.0 ve sonrasında mevcuttur.
pcre.recursion_limit | "100000" | PHP_INI_ALL | PHP 5.2.0 ve sonrasında mevcuttur.
pcre.jit | "1" | PHP_INI_ALL | PHP 7.0.0 ve sonrasında mevcuttur.
pdo.dsn.* |  | php.ini only | PHP 5.1.0 ve sonrasında mevcuttur.
pdo_odbc.connection_pooling | "strict" | PHP_INI_ALL | PHP 5.1.0 ve sonrasında mevcuttur.
pdo_odbc.db2_instance_name | NULL | PHP_INI_SYSTEM | PHP 5.1.1 ve sonrasında mevcuttur. Bu kullanımı önerilmeyen özellik gelecekte kesinlikle KALDIRILACAKTIR.
pfpro.defaulthost | "test-payflow.verisign.com" | PHP_INI_ALL | PHP 4.0.2 ve sonrasında mevcuttur. PHP 5.1.0'da kaldırıldı.
pfpro.defaultport | "443" | PHP_INI_ALL | PHP 4.0.2 ve sonrasında mevcuttur. PHP 5.1.0'da kaldırıldı.
pfpro.defaulttimeout | "30" | PHP_INI_ALL | PHP 4.0.2 ve sonrasında mevcuttur. PHP 5.1.0'da kaldırıldı.
pfpro.proxyaddress | "" | PHP_INI_ALL | PHP 4.0.2 ve sonrasında mevcuttur. PHP 5.1.0'da kaldırıldı.
pfpro.proxylogon | "" | PHP_INI_ALL | PHP 4.0.2 ve sonrasında mevcuttur. PHP 5.1.0'da kaldırıldı.
pfpro.proxypassword | "" | PHP_INI_ALL | PHP 4.0.2 ve sonrasında mevcuttur. PHP 5.1.0'da kaldırıldı.
pfpro.proxyport | "" | PHP_INI_ALL | PHP 4.0.2 ve sonrasında mevcuttur. PHP 5.1.0'da kaldırıldı.
pgsql.allow_persistent | "1" | PHP_INI_SYSTEM |
pgsql.auto_reset_persistent | "0" | PHP_INI_SYSTEM | PHP 4.2.0 ve sonrasında mevcuttur.
pgsql.ignore_notice | "0" | PHP_INI_ALL | PHP 4.3.0 ve sonrasında mevcuttur.
pgsql.log_notice | "0" | PHP_INI_ALL | PHP 4.3.0 ve sonrasında mevcuttur.
pgsql.max_links | "-1" | PHP_INI_SYSTEM |
pgsql.max_persistent | "-1" | PHP_INI_SYSTEM |
phar.cache_list | "" | PHP_INI_SYSTEM | PHP 5.4.0 ve sonrasında mevcuttur.
phar.extract_list | "" | PHP_INI_ALL | phar 1.1.0 ve sonrasında mevcuttur.
phar.readonly | "1" | PHP_INI_ALL |
phar.require_hash | "1" | PHP_INI_ALL |
post_max_size | "8M" | PHP_INI_PERDIR | PHP <= 4.2.3'te PHP_INI_SYSTEM. PHP 4.0.3 ve sonrasında mevcuttur.
precision | "14" | PHP_INI_ALL |
python.append_path | "" | PHP_INI_ALL |
python.prepend_path | "." | PHP_INI_ALL |
realpath_cache_size | "16K" | PHP_INI_SYSTEM | PHP 5.1.0 ve sonrasında mevcuttur.
realpath_cache_ttl | "120" | PHP_INI_SYSTEM | PHP 5.1.0 ve sonrasında mevcuttur.
register_argc_argv | "1" | PHP_INI_PERDIR | PHP <= 4.2.3'te PHP_INI_ALL.
register_globals | "0" | PHP_INI_PERDIR | PHP <= 4.2.3'te PHP_INI_ALL. PHP 5.3.0'dan itibaren kullanımı önerilmemektedir. PHP 5.4.0'da kaldırıldı.
register_long_arrays | "1" | PHP_INI_PERDIR | PHP 5.0.0 ve sonrasında mevcuttur. PHP 5.3.0'dan itibaren kullanımı önerilmemektedir. PHP 5.4.0'da kaldırıldı.
report_memleaks | "1" | PHP_INI_ALL | PHP 4.3.0 ve sonrasında mevcuttur.
report_zend_debug | "1" | PHP_INI_ALL | PHP 5.0.0 ve sonrasında mevcuttur.
request_order | "" | PHP_INI_SYSTEM|PHP_INI_PERDIR | PHP 5.3.0 ve sonrasında mevcuttur.
runkit.internal_override | "0" | PHP_INI_SYSTEM |
runkit.superglobal | "" | PHP_INI_PERDIR |
safe_mode | "0" | PHP_INI_SYSTEM | PHP 5.3.0'dan itibaren kullanımı önerilmemektedir. PHP 5.4.0'da kaldırıldı.
safe_mode_allowed_env_vars | "PHP_" | PHP_INI_SYSTEM | PHP 5.4.0'da kaldırıldı.
safe_mode_exec_dir | "" | PHP_INI_SYSTEM | PHP 5.4.0'da kaldırıldı.
safe_mode_gid | "0" | PHP_INI_SYSTEM | PHP 4.1.0 ve sonrasında mevcuttur. PHP 5.4.0'da kaldırıldı.
safe_mode_include_dir | NULL | PHP_INI_SYSTEM | PHP 4.1.0 ve sonrasında mevcuttur. PHP 5.4.0'da kaldırıldı.
safe_mode_protected_env_vars | "LD_LIBRARY_PATH" | PHP_INI_SYSTEM | PHP 5.4.0'da kaldırıldı.
sendmail_from | NULL | PHP_INI_ALL |
sendmail_path | "/usr/sbin/sendmail -t -i" | PHP_INI_SYSTEM |
serialize_precision | "1" | PHP_INI_ALL | PHP 4.3.2 ve sonrasında mevcuttur. PHP 5.3.5'e kadar öntanımlı değer 100 idi. PHP 7.1.0'a kadar öntanımlı değer 17 idi.
session.auto_start | "0" | PHP_INI_PERDIR | PHP <= 5.4.19 ve PHP <= 5.5.1'de PHP_INI_ALL.
session.bug_compat_42 | "1" | PHP_INI_ALL | PHP 4.3.0 ve sonrasında mevcuttur. PHP 5.4.0'da kaldırıldı.
session.bug_compat_warn | "1" | PHP_INI_ALL | PHP 4.3.0 ve sonrasında mevcuttur. PHP 5.4.0'da kaldırıldı.
session.cache_expire | "180" | PHP_INI_ALL |
session.cache_limiter | "nocache" | PHP_INI_ALL |
session.cookie_domain | "" | PHP_INI_ALL |
session.cookie_httponly | "" | PHP_INI_ALL | PHP 5.2.0 ve sonrasında mevcuttur.
session.cookie_lifetime | "0" | PHP_INI_ALL |
session.cookie_path | "/" | PHP_INI_ALL |
session.cookie_secure | "" | PHP_INI_ALL | PHP 4.0.4 ve sonrasında mevcuttur.
session.entropy_file | "" | PHP_INI_ALL |
session.entropy_length | "0" | PHP_INI_ALL |
session.gc_divisor | "100" | PHP_INI_ALL | PHP 4.3.2 ve sonrasında mevcuttur.
session.gc_maxlifetime | "1440" | PHP_INI_ALL |
session.gc_probability | "1" | PHP_INI_ALL |
session.hash_bits_per_character | "4" | PHP_INI_ALL | PHP 5.0.0 ve sonrasında mevcuttur.
session.hash_function | "0" | PHP_INI_ALL | PHP 5.0.0 ve sonrasında mevcuttur.
session.lazy_write | "1" | PHP_INI_ALL | PHP 7.0.0 sürümünden itibaren kullanılabilir.
session.name | "PHPSESSID" | PHP_INI_ALL |
session.referer_check | "" | PHP_INI_ALL |
session.save_handler | "files" | PHP_INI_ALL |
session.save_path | "" | PHP_INI_ALL |
session.serialize_handler | "php" | PHP_INI_ALL |
session.upload_progress.cleanup | "1" | PHP_INI_PERDIR | PHP 5.4.0 ve sonrasında mevcuttur.
session.upload_progress.enabled | "1" | PHP_INI_PERDIR | PHP 5.4.0 ve sonrasında mevcuttur.
session.upload_progress.freq | "1%" | PHP_INI_PERDIR | PHP 5.4.0 ve sonrasında mevcuttur.
session.upload_progress.min_freq | "1" | PHP_INI_PERDIR | PHP 5.4.0 ve sonrasında mevcuttur.
session.upload_progress.name | "PHP_SESSION_UPLOAD_PROGRESS" | PHP_INI_PERDIR | PHP 5.4.0 ve sonrasında mevcuttur.
session.upload_progress.prefix | "upload_progress_" | PHP_INI_PERDIR | PHP 5.4.0 ve sonrasında mevcuttur.
session.use_strict_mode | "0" | PHP_INI_ALL | PHP 5.5.2 ve sonrasında mevcuttur.
session.use_cookies | "1" | PHP_INI_ALL |
session.use_only_cookies | "1" | PHP_INI_ALL | PHP 4.3.0 ve sonrasında mevcuttur.
session.use_trans_sid | "0" | PHP_INI_ALL | PHP <= 4.2.3'te PHP_INI_ALL. PHP < 5'te PHP_INI_PERDIR. PHP 4.0.3 ve sonrasında mevcuttur.
session_pgsql.create_table | "1" | PHP_INI_SYSTEM |
session_pgsql.db | "host=localhost dbname=php_session user=nobody" | PHP_INI_SYSTEM |
session_pgsql.disable | "0" | PHP_INI_SYSTEM |
session_pgsql.failover_mode | "0" | PHP_INI_SYSTEM |
session_pgsql.gc_interval | "3600" | PHP_INI_SYSTEM |
session_pgsql.keep_expired | "0" | PHP_INI_SYSTEM |
session_pgsql.sem_file_name | "/tmp/php_session_pgsql" | PHP_INI_SYSTEM |
session_pgsql.serializable | "0" | PHP_INI_SYSTEM |
session_pgsql.short_circuit | "0" | PHP_INI_SYSTEM |
session_pgsql.use_app_vars | "0" | PHP_INI_SYSTEM |
session_pgsql.vacuum_interval | "21600" | PHP_INI_SYSTEM |
short_open_tag | "1" | PHP_INI_PERDIR | PHP 4.0.0'da PHP_INI_ALL. PHP >= 4.0.1'de PHP_INI_PERDIR
SMTP | "localhost" | PHP_INI_ALL |
smtp_port | "25" | PHP_INI_ALL | PHP 4.3.0 ve sonrasında mevcuttur.
soap.wsdl_cache | "1" | PHP_INI_ALL | PHP 5.1.5 ve sonrasında mevcuttur.
soap.wsdl_cache_dir | "/tmp" | PHP_INI_ALL | PHP 5.0.0 ve sonrasında mevcuttur.
soap.wsdl_cache_enabled | "1" | PHP_INI_ALL | PHP 5.0.0 ve sonrasında mevcuttur.
soap.wsdl_cache_limit | "5" | PHP_INI_ALL | PHP 5.1.5 ve sonrasında mevcuttur.
soap.wsdl_cache_ttl | "86400" | PHP_INI_ALL | PHP 5.0.0 ve sonrasında mevcuttur.
sql.safe_mode | "0" | PHP_INI_SYSTEM |
sqlite.assoc_case | "0" | PHP_INI_ALL | PHP 5.0.0 ve sonrasında mevcuttur.
sqlite3.extension_dir | "" | PHP_INI_SYSTEM | PHP 5.4.11 ve sonrasında mevcuttur.
sybase.allow_persistent | "1" | PHP_INI_ALL | PHP <= 4.0.2'de PHP_INI_ALL. PHP <= 4.0.3'te PHP_INI_SYSTEM.
sybase.interface_file | "" | PHP_INI_ALL |
sybase.max_links | "-1" | PHP_INI_ALL | PHP <= 4.0.2'de PHP_INI_ALL. PHP <= 4.0.3'te PHP_INI_SYSTEM.
sybase.max_persistent | "-1" | PHP_INI_ALL | PHP <= 4.0.2'de PHP_INI_ALL. PHP <= 4.0.3'te PHP_INI_SYSTEM.
sybase.min_error_severity | "10" | PHP_INI_ALL |
sybase.min_message_severity | "10" | PHP_INI_ALL |
sybct.deadlock_retry_count | "0" | PHP_INI_ALL | PHP 4.3.0 ve sonrasında mevcuttur.
sybct.login_timeout | "-1" | PHP_INI_ALL | PHP 4.0.2 ve sonrasında mevcuttur.
sybct.packet_size | "0" | PHP_INI_ALL | PHP 4.3.5 ve sonrasında mevcuttur.
sybct.timeout | "0" | PHP_INI_ALL | PHP 4.0.2 ve sonrasında mevcuttur.
sys_temp_dir | "" | PHP_INI_SYSTEM | APHP 5.5.0 ve sonrasında mevcuttur.
sysvshm.init_mem | "10000" | PHP_INI_ALL |
tidy.clean_output | "0" | PHP_INI_USER | PHP_INI_PERDIR in PHP 5. PHP 5.0.0 ve sonrasında mevcuttur.
tidy.default_config | "" | PHP_INI_SYSTEM | PHP 5.0.0 ve sonrasında mevcuttur.
track_errors | "0" | PHP_INI_ALL |
unserialize_callback_func | NULL | PHP_INI_ALL | PHP 4.2.0 ve sonrasında mevcuttur.
uploadprogress.file.filename_template | "/tmp/upt_%s.txt" | PHP_INI_ALL |
upload_max_filesize | "2M" | PHP_INI_PERDIR | PHP <= 4.2.3'te PHP_INI_ALL.
max_file_uploads | 20 | PHP_INI_SYSTEM | PHP 5.2.12'den itbaren kullanılabilmektedir.
upload_tmp_dir | NULL | PHP_INI_SYSTEM |
url_rewriter.tags | "a=href,area=href,frame=src,form=,fieldset=" | PHP_INI_ALL | PHP 4.0.4 ve sonrasında mevcuttur.
user_agent | NULL | PHP_INI_ALL | PHP 4.3.0 ve sonrasında mevcuttur.
user_dir | NULL | PHP_INI_SYSTEM |
user_ini.cache_ttl | "300" | PHP_INI_SYSTEM | PHP 5.3.0 ve sonrasında mevcuttur.
user_ini.filename | ".user.ini" | PHP_INI_SYSTEM | PHP 5.3.0 ve sonrasında mevcuttur.
valkyrie.auto_validate | "0" | PHP_INI_ALL |
valkyrie.config_path | NULL | PHP_INI_ALL |
variables_order | "EGPCS" | PHP_INI_PERDIR | PHP <= 5.0.5'te PHP_INI_ALL.
vld.active | "0" | PHP_INI_SYSTEM |
vld.execute | "1" | PHP_INI_SYSTEM | vld 0.8.0 ve sonrasında mevcuttur.
vld.skip_append | "0" | PHP_INI_SYSTEM | vld 0.8.0 ve sonrasında mevcuttur.
vld.skip_prepend | "0" | PHP_INI_SYSTEM | vld 0.8.0 ve sonrasında mevcuttur.
windows.show_crt_warning | "0" | PHP_INI_ALL | >PHP 5.5.0 ve sonrasında mevcuttur.
xbithack | "0" | PHP_INI_ALL | PHP 4.0.5 ve sonrasında mevcuttur.
xdebug.auto_profile | "0" | PHP_INI_ALL | Xdebug 2.0.0'da kaldırıldı.
xdebug.auto_profile_mode | "0" | PHP_INI_ALL | Xdebug 2.0.0'da kaldırıldı.
xdebug.auto_trace | "0" | PHP_INI_ALL |
xdebug.collect_includes | "1" | PHP_INI_ALL | Xdebug 2.0.0 ve sonrasında mevcuttur.
xdebug.collect_params | "0" | PHP_INI_ALL |
xdebug.collect_return | "0" | PHP_INI_ALL | Xdebug 2.0.0 ve sonrasında mevcuttur.
xdebug.collect_vars | "0" | PHP_INI_ALL | Xdebug 2.0.0 ve sonrasında mevcuttur.
xdebug.default_enable | "1" | PHP_INI_ALL | PHP_INI_SYSTEM in Xdebug 1.
xdebug.dump.COOKIE | NULL | PHP_INI_ALL |
xdebug.dump.ENV | NULL | PHP_INI_ALL |
xdebug.dump.FILES | NULL | PHP_INI_ALL |
xdebug.dump.GET | NULL | PHP_INI_ALL |
xdebug.dump.POST | NULL | PHP_INI_ALL |
xdebug.dump.REQUEST | NULL | PHP_INI_ALL |
xdebug.dump.SERVER | NULL | PHP_INI_ALL |
xdebug.dump.SESSION | NULL | PHP_INI_ALL |
xdebug.dump_globals | "1" | PHP_INI_ALL | Xdebug 2.0.0 ve sonrasında mevcuttur.
xdebug.dump_once | "1" | PHP_INI_ALL |
xdebug.dump_undefined | "0" | PHP_INI_ALL |
xdebug.extended_info | "1" | PHP_INI_SYSTEM | Xdebug 2.0.0 ve sonrasında mevcuttur.
xdebug.idekey | "" | PHP_INI_ALL | Xdebug 2.0.0 ve sonrasında mevcuttur.
xdebug.manual_url | "http://www.php.net" | PHP_INI_ALL |
xdebug.max_nesting_level | "100" | PHP_INI_ALL |
xdebug.output_dir | "/tmp" | PHP_INI_PERDIR | Xdebug <= 1.2.0'da PHP_INI_SYSTEM. Xdebug 2.0.0'da kaldırıldı.
xdebug.profiler_aggregate | "0" | PHP_INI_PERDIR | Xdebug 2.0.0 ve sonrasında mevcuttur.
xdebug.profiler_append | "0" | PHP_INI_PERDIR | Xdebug 2.0.0 ve sonrasında mevcuttur.
xdebug.profiler_enable | "0" | PHP_INI_PERDIR | Xdebug 2.0.0 ve sonrasında mevcuttur.
xdebug.profiler_enable_trigger | "0" | PHP_INI_PERDIR | Xdebug 2.0.0 ve sonrasında mevcuttur.
xdebug.profiler_output_dir | "/tmp" | PHP_INI_PERDIR | Xdebug 2.0.0 ve sonrasında mevcuttur.
xdebug.profiler_output_name | "cachegrind.out.%p" | PHP_INI_PERDIR | Xdebug 2.0.0 ve sonrasında mevcuttur.
xdebug.remote_autostart | "0" | PHP_INI_ALL | Xdebug 2.0.0 ve sonrasında mevcuttur.
xdebug.remote_enable | "0" | PHP_INI_PERDIR |
xdebug.remote_handler | "dbgp" | PHP_INI_ALL |
xdebug.remote_host | "localhost" | PHP_INI_ALL |
xdebug.remote_log | "" | PHP_INI_ALL | Xdebug 2.0.0 ve sonrasında mevcuttur.
xdebug.remote_mode | "req" | PHP_INI_ALL |
xdebug.remote_port | "9000" | PHP_INI_ALL |
xdebug.show_exception_trace | "0" | PHP_INI_ALL | Xdebug 2.0.0 ve sonrasında mevcuttur.
xdebug.show_local_vars | "0" | PHP_INI_ALL | Xdebug 2.0.0 ve sonrasında mevcuttur.
xdebug.show_mem_delta | "0" | PHP_INI_ALL | Xdebug 2.0.0 ve sonrasında mevcuttur.
xdebug.trace_format | "0" | PHP_INI_ALL | Xdebug 2.0.0 ve sonrasında mevcuttur.
xdebug.trace_options | "0" | PHP_INI_ALL | Xdebug 2.0.0 ve sonrasında mevcuttur.
xdebug.trace_output_dir | "/tmp" | PHP_INI_ALL | Xdebug 2.0.0 ve sonrasında mevcuttur.
xdebug.trace_output_name | "trace.%c" | PHP_INI_ALL | Xdebug 2.0.0 ve sonrasında mevcuttur.
xdebug.var_display_max_children | "128" | PHP_INI_ALL | Xdebug 2.0.0 ve sonrasında mevcuttur.
xdebug.var_display_max_data | "512" | PHP_INI_ALL | Xdebug 2.0.0 ve sonrasında mevcuttur.
xdebug.var_display_max_depth | "3" | PHP_INI_ALL | Xdebug 2.0.0 ve sonrasında mevcuttur.
xmlrpc_errors | "0" | PHP_INI_SYSTEM | PHP 4.1.0 ve sonrasında mevcuttur.
xmlrpc_error_number | "0" | PHP_INI_ALL | PHP 4.1.0 ve sonrasında mevcuttur.
xmms.path | "/usr/bin/xmms" | PHP_INI_ALL |
xmms.session | "0" | PHP_INI_ALL |
xsl.security_prefs | "44" | PHP_INI_ALL | PHP 5.5.0 ve sonrasında mevcuttur.
y2k_compliance | "1" | PHP_INI_ALL |
yami.response.timeout | "5" | PHP_INI_ALL | yami 1.0.1 ve sonrasında mevcuttur.
yaz.keepalive | "120" | PHP_INI_ALL |
yaz.log_mask | NULL | PHP_INI_ALL | yaz 1.0.3 ve sonrasında mevcuttur.
zend.assertions | "1" | PHP_INI_ALL | PHP 7.0.0 ve sonrasında mevcuttur.
zend.detect_unicode | "1" | PHP_INI_ALL | PHP 5.4.0 ve sonrasında mevcuttur.
zend.enable_gc | "1" | PHP_INI_ALL | PHP 5.3.0 ve sonrasında mevcuttur.
zend.multibyte | "0" | PHP_INI_PERDIR | PHP 5.4.0 ve sonrasında mevcuttur.
zend.script_encoding | NULL | PHP_INI_ALL | PHP 5.4.0 ve sonrasında mevcuttur.
zend.signal_check | "0" | PHP_INI_SYSTEM | PHP 5.4.0 ve sonrasında mevcuttur.
zend.ze1_compatibility_mode | "0" | PHP_INI_ALL | PHP 5.0.0 ve sonrasında mevcuttur. PHP 5.3.0'da kaldırıldı..
zend_extension | NULL | sadece php.ini |
zend_extension_debug | NULL | sadece php.ini |
zend_extension_debug_ts | NULL | sadece php.ini |
zend_extension_ts | NULL | sadece php.ini |
zlib.output_compression | "0" | PHP_INI_ALL | PHP 4.0.5 ve sonrasında mevcuttur.
zlib.output_compression_level | "-1" | PHP_INI_ALL | PHP 4.3.0 ve sonrasında mevcuttur.
zlib.output_handler | "" | PHP_INI_ALL | PHP 4.3.0 ve sonrasında mevcuttur.

php.ini Yönergeleri
php.ini bölümlerinin listesi
php.ini Yönergeleri


php.ini bölümlerinin listesi

Bu liste, PHP kurulumunuzu her konak (HOST) veya dosya yolu (PATH) için yapılandırmakta kullanacağınız php.ini bölümlerini içerir. Bu bölümler isteğe bağlıdır.

Bu bölümler PHP'yi doğrudan etkilemez. php.ini yönergelerini aralarında ve belli bir konak veya yol için gruplamakta kullanılırlar.

Bu bölümler sadece CGI/FastCGI kipinde kullanılır; extension ve zend_extension yönergelerini tanımlamakta kullanılamaz.

Bölümler
İsim | Değişlik Yeri | Sürüm Bilgisi
[HOST=] | PHP_INI_SYSTEM | PHP 5.3.0 ve sonrasında mevcuttur.
[PATH=] | PHP_INI_SYSTEM | PHP 5.3.0 ve sonrasında mevcuttur.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

[HOST=<site.adı>]

Sadece ismi belirtilen konak üzerinde etkili olacak php.ini yönergelerini gruplamak için kullanılır.

Örnek 1 - dev.site.dom alan adı için ekranda hata raporlamayı etkin kılmak

[HOST=dev.site.dom]
error_reporting = E_ALL
display_errors = On

[PATH=<dosya/yolu>]

Sadece yolu belirtilen betikler üzerinde etkili olacak php.ini yönergelerini gruplamak için kullanılır.

Örnek 2 - Korunmuş alanlar için güvenlik betikleri eklemek

[PATH=/home/site/public/secure]
auto_prepend_file=security.php

php.ini yönergelerinin listesi
Temel php.ini yönergelerinin tanımları
php.ini Yönergeleri


Temel php.ini yönergelerinin tanımları

Bu liste PHP kurulumunuzu yapılandırmakta kullanacağınız yerleşik php.ini yönergelerini içerir. Eklentilerle ilgili yönergeler eklentinin kendi belgelerinde listelenmiş ve açıklanmışladır. Örneğin, oturum yönergeleri ile ilgili bilgileri oturumlar sayfasında bulabilirsiniz.

Bilginize:

Burada listelenen öntanımlılar php.ini yüklenirken kullanılır; değerler kullanıcı içindir ve geliştirilmekte olan php.ini farklı olabilir.

Httpd Options

HTTPd Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
async_send | "0" | PHP_INI_ALL | PHP 4.2.0 ve sonrasında mevcuttur. PHP 4.3.0'da kaldırıldı.

Dil Seçenekleri

Dil ve Çeşitli Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
short_open_tag | "1" | PHP_INI_PERDIR | PHP 4.0.0'da PHP_INI_ALL. PHP >= 4.0.1'de PHP_INI_PERDIR
asp_tags | "0" | PHP_INI_PERDIR | PHP 4.0.0'da PHP_INI_ALL. PHP 7.0.0'da kaldırıldı.
precision | "14" | PHP_INI_ALL |
serialize_precision | "17" | PHP_INI_ALL | PHP 4.3.2 ve sonrasında mevcuttur. PHP 5.3.5'e kadar öntanımlı değer 100 idi.
y2k_compliance | "1" | PHP_INI_ALL |
allow_call_time_pass_reference | "1" | PHP_INI_PERDIR | PHP 4.0.0'da PHP_INI_ALL. PHP 5.4.0'da kaldırıldı.
disable_functions | "" | sadece >PHP_INI_SYSTEM | PHP 4.0.1 ve sonrasında mevcuttur.
disable_classes | "" | sadece php.ini | PHP 4.3.2 ve sonrasında mevcuttur.
exit_on_timeout | "" | PHP_INI_ALL | PHP 5.3.0 ve sonrasında mevcuttur.
expose_php | "1" | sadece php.ini |
zend.multibyte | "0" | PHP_INI_ALL | PHP 5.4.0 ve sonrasında mevcuttur.
zend.script_encoding | NULL | PHP_INI_ALL | PHP 5.4.0 ve sonrasında mevcuttur.
zend.detect-unicode | NULL | PHP_INI_ALL | PHP 5.4.0 ve sonrasında mevcuttur.
zend.signal_check | "0" | PHP_INI_SYSTEM | PHP 5.4.0 ve sonrasında mevcuttur.
zend.assertions | "1" | Kısıtlamalarla PHP_INI_ALL | PHP 7.0.0 ve sonrasında mevcuttur.
zend.ze1_compatibility_mode | "0" | PHP_INI_ALL | PHP 5.0.0 ve sonrasında mevcuttur. PHP 5.3.0'da kaldırıldı.
detect_unicode | "1" | PHP_INI_ALL | PHP 5.1.0 ve sonrasında mevcuttur. PHP 5.4.0'da ismi zend.detect-unicode oldu.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

short_open_tag boolean

PHP'nin başlangıç etiketinin kısa gösteriminin kullanımına izin verilip verilmediğini söyler. PHP'yi XML içinde kullanmak isterseniz <?xml ?> satırını kullanmak için bu kısa etiket kullanımını iptal edip uzun etiket (<?php ?>) kullanabilirsiniz. Aksi takdirde satırı <?php echo '<?xml version="1.0"?>';?> şeklinde PHP'ye yazdırabilirsiniz.

Bilginize:

Bu yönerge ayrıca, <? echo'ya eşdeğer olan <?= kısaltmasını da etkiler. Bu kısaltmayı kullanabilmek için short_open_tag yönergesinin değeri 1 olmalıdır.

asp_tags boolean
Normal <?php ?> etiketlerine ek olarak ASP tarzı <% %> etiketlerinin kullanımını etkin kılar. Bu yönerge, değişken değerli yazdırma kısaltmasını da (<%= $değer %>) etkiler. Daha ayrıntılı bilgi için HTML'den Kaçmak bölümüne bakınız.

asp_tags ile ilgili değişiklikler
Sürüm: Açıklama
7.0.0 PHP'den kaldırıldı.

precision integer
Gerçek sayılarda ondalık noktadan sonraki anlamlı hane sayısı. -1 böyle sayıların yuvarlatılmasında geliştirilmiş bir algoritmanın kulllanılacağı anlamına gelir.
serialize_precision integer
Gerçek sayılar dizgileştirilirken saklanan ondalık noktadan sonraki anlamlı hane sayısı. -1 böyle sayıların yuvarlatılmasında geliştirilmiş bir algoritmanın kulllanılacağı anlamına gelir.
y2k_compliance boolean
2000 yılı uyumluluğunu uygular (uyumsuz tarayıcılarda sorun çıkarır)
allow_call_time_pass_reference boolean

İşlev çağrısı sırasında değiştirgeler gönderimli aktarıldığında uyarı verilip verilmeyeceğini belirler. Bu yöntemin kullanımı Hangi değiştirgelerin gönderimli aktarılacağını işlev bildiriminde belirtmek daha iyidir. Bunu yapıp, betiğinizin, dilin gelecekteki sürümlerinde de düzgün çalışabilmesi için bu yönergeye sıfır atamanız önerilir (yoksa bu özelliği her kullanışınızda bir uyarı alırsınız).

İşlev çağrısı sırasında değiştirgelerin gönderimli aktarımı kodun temizliği açısından önerilmemektedir. Eğer işlev bildiriminde değiştirgenin gönderimli aktarılacağı belirtilmemişse işlev değiştirgesini bilgi vermeden değiştirebilir. Bu yan etkilerden kaçınmak için hangi değiştirgenin gönderimli aktarılacağının sadece işlev bildiriminde belirtilmesi daha iyidir.

Ayrıca bakınız: Gönderimlerle İlgili Herşey.

allow_call_time_pass_reference için değişiklik geçmişi
Sürüm: Açıklama
5.4.0 | PHP'den kaldırıldı.
5.3.0 | E_DEPRECATED seviyesinden hata çıktılar.
5.0.0 | Kullanımı önerilmemektedir ve E_COMPILE_WARNING seviyesinden hata çıktılar.

expose_php boolean

PHP'nin kurulu olduğu sunucuda sürüm bilgisini HTTP başlığına eklemek suretiyle (örn: X-Powered-By: PHP/5.3.7) kendini karşıya gösterip göstermeyeceğini belirler. PHP 5.5.0 öncesinde PHP logo guid'leri ayrıca ilan edilir; böylece onu PHP betiğinizin URL'sine eklemek suretiyle ilgili logonun gösterilmesini sağlarsınız (örn, » http://www.php.net/?=PHPE9568F34-D428-11d2-A769-00AA001ACF42). Bu ayrıca phpinfo() çıktısını da etkiler ve iptal edildiği zaman olduğu gibi PHP logosu ve bazı bilgiler gösterilmez.

Bilginize:

PHP 5.5.0 ve sonrasında bu guid'ler ve php_logo_guid() işlevi kaldırıldı ve guid'lerin yerine veri URI'leri geldi. Bu bakımdan guid'i URL'ye ekleyerek PHP logosuna erişim artık mümkün değildir. Benzer şekilde, expose_php'nin off yapılması PHP logosunun phpinfo() içinde görünmesini etkilemez.

Ayrıca bakınız: php_logo_guid() ve phpcredits().

disable_functions string
Bu yönerge güvenlik ile ilgili sebeplerle belli işlevleri iptal etmeye yarar. İşlev isimleri aralarına virgül konarak belirtilir. Bu yönerge güvenli kipte etkili değildir.

Bu yönerge ile sadece dahili işlevler iptal edilebilir. Kullanıcı tarafından tanımlanmış işlevler etkilenmez.

Bu yönerge sadece php.ini içinde atanabilir. Örneğin httpd.conf dosyasında tanımlayamazsınız.
disable_classes string
Bu yönerge güvenlik ile ilgili sebeplerle belli sınıfları iptal etmeye yarar. Sınıf isimleri aralarına virgül konarak belirtilir. Bu yönerge güvenli kipte etkili değildir. Bu yönerge sadece php.ini içinde atanabilir. Örneğin httpd.conf dosyasında tanımlayamazsınız.
zend.assertions integer
1 atandığında, Kararlılık denetimleri kodu üretilir ve çalıştırılır (geliştirme kipi). 0 atandığında kod yine üretilir fakat çalıştırılmaz. -1 atandığında ise kod üretilmez ve bu atama kararlılık denetimlerinin maliyetini sıfırlar (üretim kipi).

Bilginize:

Bir süreç üretim kipinde başlatılmışsa, kararlılık denetimleri kodu üretilmediğinden zend.assertions çalışma anında değiştirilemez.

Bir süreç geliştirme kipinde başlatılmışsa, zend.assertions'a çalışma anında -1 atanamaz.

zend.ze1_compatibility_mode boolean

Zend Motoru 1 ile uyumluluk kipini etkin kılar (PHP 4). Nesne kopyalama, tür çarpıtma (özellikleri olmayan nesnelerin türü FALSE veya 0 olarak çarpıtılır) ve nesne karşılaştırmayı etkiler. Bu kipte nesneler öntanımlı olan gönderimle değil değerleriyle aktarılırlar.

Ayrıca bakınız: PHP 4'ten PHP 5'e yükseltme.

Uyarı

Bu özelliğin kullanımı artık ÖNERİLMEMEKTE olup PHP 5.3.0 itibariyle özellik KALDIRILMIŞTIR.

zend.multibyte boolean

Çokbaytlı kodlanmış kaynak dosyalarının çözümlenmesini etkin kılar. Çokbaytlı dizge verisi içinde özel karakterler içeren SJIS, BIG5, vs. gibi karakter kodlamalarını kullanmak için zend.multibyte etkin olmalıdır. UTF-8, EUC gibi ISO-8859-1 uyumlu kodlamalar bu seçeneğin etkinleştirilmesini gerektirmez.

zend.multibyte seçeneğinin etkin olabilmesi için mbstring eklentisi kullanımda (kurulu) olmalıdır.

zend.script_encoding string

Betiğin tepesinde declare(encoding=...) yönergesi görünmediği takdirde bu değer kullanılır. ISO-8859-1 ve UTF-8 ile uyumlu olmayan kodlamalar için zend.multibyte ve zend.script_encoding seçeneklerinin ikisi de etkin olmalıdır.

Kod dizgeleri, mb_convert_encoding() çağrılmış gibi zend.script_enconding'den mbstring.internal_encoding'e çevrilir.

zend.detect_unicode boolean

BOM'a (Bayt sıralama imi) ve dosyanın çokbaytlı karakterler içerip içermediğine bakılır. Bu saptama __halt_compiler() çalıştırılmadan önce yapılır. Sadece Zend Multibyte kipinde kullanılabilir.

zend.signal_check boolean

Sistemin kapanması sırasında sinyal eylemcilerinin yerleştirilip yerleştirilmediğini sınamak için.

detect_unicode boolean

Bayt sırası imine ve dosyanın geçerli çok baytlı karakterleri içerip içermediğine bakar. Bu işlem __halt_compiler() işleme sokulmadan önce yapılır. Sadece Çokbaytlı Zend kipinde kullanılabilir.

exit_on_timeout boolean

Bu Apache1 mod_php modülüne özgü bir yönergedir ve PHP icrası sırasında bir zaman aşımı oluştığu takdirde PHP'yi çalıştıran Apache lat sürecinin çıkmasını sağlar. Böyle bir zaman aşımı Apache1 içinde bazı eklentileri kararsız durumda bırakabilen dahili bir longjmp() çağrısına sebep olur. Süreci sonlandırmak suretiyle takılı kalmış kilitler ve bellek temizlenebilir.

Özkaynak Sınırları

Özkaynak Sınırları
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
memory_limit | "128M" | PHP_INI_ALL | PHP 5.2.0 öncesi "8M", PHP 5.2.0'da "16M"

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

memory_limit integer

Bir betiğin ayırmasına izin verilebilecek belleğin azami miktarını belirler. Bu yönerge, yetersiz betiklerin bir sunucu üzerinde mevcut belleğin tamamını tüketmesini önlemeye yardımcı olur. Belleği sınırlamak istemiyorsanız yönergeye -1 değeri atayın.

PHP 5.2.1 öncesinde, bu yönergeyi kullanabilmek için PHP'yi derlerken --enable-memory-limit yapılandırma seçeneğini kullanmak gerekirdi. 5.2.1 öncesinde bu derleme seçeneği ayrıca, memory_get_usage() ve memory_get_peak_usage() işlevlerinin de tanımlanmasını gerektirirdi.

integer türünde bir değer kullanıldığında değer baytların sayısıdır. Büyük bayt değerleri için kullanılabilecek birimlerin gösterimleri hakkında bilgiyi bu SSS altında bulabilirsiniz.

Ayrıca bakınız: max_execution_time.

Başarım Arttırma

Başarım Arttırma
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
realpath_cache_size | "16K" | PHP_INI_SYSTEM | PHP 5.1.0 ve sonrasında mevcuttur.
realpath_cache_ttl | "120" | PHP_INI_SYSTEM | PHP 5.1.0 ve sonrasında mevcuttur.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

realpath_cache_size integer

PHP tarafından kullanılan realpath önbelleğinin boyunu belirler. PHP'nin çok sayıda dosya açtığı sistemlerde gerçekleştirilen dosya işlemlerinin miktarına bağlı olarak bu değerin arttırılması gerekir.

Boyut saklanan dosyanın yol dizgesinin bayt olarak uzunluğunu artı, arabellek girdisiyle ilişkili verinin miktarını gösterir. Yani, arabellekte daha uzun dosya yolu saklamak için arabellek boyutunu arttırmanız gerekir. Bu değer arabelleklenebilen farklı yolların sayısını doğrudan saptayabilmeyi sağlamaz.

Arabellek girdisi için gereken boyut sistemden sisteme değişir.

realpath_cache_ttl integer

Belli bir dosya veya dizin için realpath bilgisini önbellekte tutma süresi (saniye cinsinden). Dosyaların nadiren değiştiği sistemlerde bu değer arttırılabilir.

Veri İşleme

Veri İşleme Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
arg_separator.output | "&" | PHP_INI_ALL | PHP 4.0.5 ve sonrasında mevcuttur.
arg_separator.input | "&" | PHP_INI_PERDIR | PHP 4.0.5 ve sonrasında mevcuttur.
variables_order | "EGPCS" | PHP_INI_PERDIR | PHP <= 5.0.5'te PHP_INI_ALL.
request_order | "" | PHP_INI_SYSTEM|PHP_INI_PERDIR | PHP 5.3.0 ve sonrasında mevcuttur.
auto_globals_jit | "1" | PHP_INI_PERDIR | PHP 5.0.0 ve sonrasında mevcuttur.
register_globals | "0" | PHP_INI_PERDIR | PHP <= 4.2.3'te PHP_INI_ALL. PHP 5.4.0'da kaldırıldı.
register_argc_argv | "1" | PHP_INI_PERDIR | PHP <= 4.2.3'te PHP_INI_ALL.
register_long_arrays | "1" | PHP_INI_PERDIR | PHP 5.0.0 ve sonrasında mevcuttur. PHP 5.3.0'dan itibaren kullanımı önerilmemektedir. PHP 5.4.0'da kaldırıldı.
enable_post_data_reading | "1" | PHP_INI_PERDIR | PHP 5.4.0 ve sonrasında mevcuttur.
post_max_size | "8M" | PHP_INI_PERDIR | PHP <= 4.2.3'te PHP_INI_SYSTEM. PHP 4.0.3 ve sonrasında mevcuttur.
auto_prepend_file | NULL | PHP_INI_PERDIR | PHP <= 4.2.3'te PHP_INI_ALL.
auto_append_file | NULL | PHP_INI_PERDIR | PHP <= 4.2.3'te PHP_INI_ALL.
default_mimetype | "text/html" | PHP_INI_ALL |
default_charset | "" | PHP_INI_ALL | PHP 5.6.0 ve sonrasında öntanımlı değer "UTF-8" öncesinde boş dizgedir.
always_populate_raw_post_data | "0" | PHP_INI_PERDIR | PHP <= 4.2.3'te PHP_INI_ALL. PHP 4.1.0 ve sonrasında mevcut olup PHP 7.0.0'da kaldırılmışır.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

arg_separator.output string

PHP'de üretilen URL'leri değiştirgelerine ayırmak için kullanılan ayraç.

arg_separator.input string

Girdi olarak verilen URL'leri değişkenlere çözümlemek için PHP tarafından kullanılan ayraçların listesi.

Bilginize:

Bu yönergede belirtilen her karakter bir ayraç olarak ele alınır!

variables_order string

EGPCS (Environment, Get, Post, Cookie ve Server) değişken çözümleme sırası belirtilir. Örneğin, değer olarak "SP" belirtilirse, PHP, $_SERVER ve $_POST süper küresellerini oluşturacak ama $_ENV, $_GET ve $_COOKIE süper küresellerini oluşturmayacaktır. Değer olarak "" atanırsa hiçbir süper küresel atanmayacaktır.

Kullanımı önerilmeyen register_globals yönergesine 1 atanırsa variables_order yönergesi ayrıca, küresel etki alanındaki ENV, GET, POST, COOKIE ve SERVER değişkenlerinin sırasını da belirler. Örneğin variables_order yönergesine "EGPCS" atanır, register_globals etkinleştirilir ve hem $_GET['action'] hem de $_POST['action'] atanırsa, $action değişkeni $_POST['action'] değerini içerecektir; bunun sebebi örnek yönergemizde P'nin G'den sonra gelmesidir.

Uyarı

CGI ve FastCGI SAPI'lerinin her ikisi için de $_SERVER dizisi ortamdaki değerlerle oluşturulur; S, E'nin yönergedeki yerinden bağımsız olarak daima ES'e eşdeğerdir.

Bilginize:

Ayrıca, $_REQUEST dizisinin içeriği ve sırası da bu yönergeden etkilenir.

request_order string

GET, POST ve Cookie değişkenlerinin $_REQUEST dizisinin içindeki sırasını belirler. Yazma işlemi soldan sağa doğru ilerleyerek yeni değerler eskileri geçersiz kılar.

Bu yönerge atanmazsa $_REQUEST dizisinin içeriği variables_order yönergesiyle belirlenir.

Güvenlik kaygılarından dolayı dağıtımla gelen öntanımlı php.ini dosyaları çerezler için 'C' içermez.

auto_globals_jit boolean

Etkinleştirildiğinde, SERVER ve ENV değişkenleri betik çalıştırıldığı zaman değil, değişkenler kullanıldığı anda (tam zamanında) oluşturulur. Bu değişkenler bir betik içinde kullanılmamışlarsa bu yönergenin varlığı bir başarım kazancıyla sonuçlanacaktır.

register_globals, register_long_arrays, ve register_argc_argv PHP yönergeleri, bu yönergenin etkili olabilmesi için etkinleştirilmemelidir. PHP 5.1.3 ve sonrasında register_argc_argv'nin etkisiz kılınmasına gerek yoktur.

Uyarı

SERVER ve ENV değişkenlerinin kullanımı derleme sırasında sınanır, dolayısıyla örneğin değişken değişkenler üzerinden kullanılmaları ilklendirilmelerine sebep olmayacaktır.

register_globals boolean

EGPCS (Environment, GET, POST, Cookie, Server) değişkenlerinin küresel değişkenler haline getirilip getirilmeyeceklerini belirler.

PHP 4.2.0 ve sonrasında, bu yönergenin öntanımlı değeri off'tur.

Daha fazla bilgi için register_globals kullanımı adlı güvenlik bölümünü okuyunuz.

register_globals yönergesine çalışma anında (ini_set() ile) değer atanamayacağına dikkat ediniz. Yine de, yukarıda açıklandığı gibi konağınız izin veriyorsa .htaccess kullanabilirsiniz. Örnek .htaccess girdisi: php_flag register_globals off.

Bilginize:

register_globals yönergesi variables_order yönergesinden etkilenir.

Uyarı

Bu özelliğin kullanımı PHP 5.3.0 itibariyle ÖNERİLMEMEKTE olup PHP 5.4.0'da tamamen KALDIRILMIŞTIR.

register_argc_argv boolean
PHP'nin, (GET bilgisini içeren) argv ve argc değişkenlerini bildirip bildirmeyeceğini belirler. Komut satırı bölümüne de bakınız. Bu yönerge PHP 4.0.0'dan itibaren kullanılabilir hale geldi ve daha önce değeri daima "on" idi.
register_long_arrays boolean
PHP'nin kullanımı artık önerilmeyen $HTTP_*_VARS türü uzun önceden tanımlanmış değişkenleri yazmaç haline getirip getirmeyeceğini belirler. Değeri on olduğunda (öntanımlıdır), $HTTP_GET_VARS gibi uzun önceden tanımlanmış değişkenler tanımlanacaktır. Bunları kullanmayacaksanız başarımı arttırmak için etkisiz kılmanızı öneririz. Bunların yerine $_GET gibi süper küresel dizileri kullanmak daha iyidir. like $_GET. Bu yönerge PHP 5.0.0'da kullanılabilir hale gelmiştir.
Uyarı

Bu özelliğin kullanımı PHP 5.3.0 itibariyle ÖNERİLMEMEKTE olup PHP 5.4.0'da tamamen KALDIRILMIŞTIR.

enable_post_data_reading boolean
Bu seçeneğin iptali $_POST ve $_FILES verilerinin toplanmamasına sebep olur. Post verisini okumanın tek yolu php://input akım sarmalayıcısı kullanmak olacaktır. POST verisini işlerken bellek tasarrufu yapmak veya isteklere vekalet etmek için kullanışlıdır.
post_max_size integer
POST verisinin azami boyutunu belirler. Bu ayar ayrıca karşıya dosya yükleme işlemlerini de etkiler. Büyük dosyaları karşıya yüklemek için bu değerin upload_max_filesize değerinden büyük olması gerekir. Genelde, memory_limit değerinin post_max_size değerinden büyük olması gerekir. integer türünde bir değer kullanıldığında değer baytların sayısıdır. Büyük bayt değerleri için kullanılabilecek birimlerin gösterimleri hakkında bilgiyi bu SSS altında bulabilirsiniz. Eğer POST verisinin boyu post_max_size değerinden büyükse $_POST ve $_FILES süper küreselleri boş olur. Bu, çeşitli yollarla izlenebilir; örneğin, veriyi işleyen betiğe $_GET değişkenini <form action="edit.php?processed=1"> ile aktararak ve ardından $_GET['processed'] atanmış mı diye sınanarak bu yapılabilir.

Bilginize:

PHP bayt değerleri için K (kilo), M (mega) ve G (giga) birim kısaltmalarını kabul eder. Bunları kullanırsanız PHP dönüşümü özdevinimli olarak yapacaktır. 32 bitlik sürümleri kullanıyorsanız, 32 bitlik işaretli tamsayı sınırını aşmamaya dikkat edin, aksi takdirde betiğiniz başarısız olacaktır.

post_max_size ile ilgili değişiklikler
Sürüm: Açıklama
5.3.4 | İçerik türü PHP'de tanımlı değilse veya içerik türü application/x-www-form-urlencoded ise post_max_size = 0 ataması sınırlamayı iptal etmez.
5.3.2 , 5.2.12 | post_max_size = 0 ataması POST boyutunu sınırsız yapar.
auto_prepend_file string

Özdevinimli olarak ana betikten önce çözümlenecek dosyanın ismi belirtilir. Dosya require ile belirtilmiş gibi ana dosyanın başına eklenir; dolayısıyla dosyayı bulmak için include_path kullanılır.

none özel değeri başa dosya eklemeyi iptal eder.

auto_append_file string

Özdevinimli olarak ana betikten sonra çözümlenecek dosyanın ismi belirtilir. Dosya require ile belirtilmiş gibi ana dosyanın sonuna eklenir; dolayısıyla dosyayı bulmak için include_path kullanılır.

none özel değeri sona dosya eklemeyi iptal eder.

Bilginize: Eğer betik exit() ile sonlanırsa özdevinimli ekleme gerçekleşmez.

default_mimetype string

Öntanımlı MIME türü. Öntanımlı olarak PHP ortam türünü Content-Type başlığını kullanarak gönderir. Ortam türünün gönderilmesini engellemek için değişkene hiçbir şey atanmamalıdır.

PHP'nin yerleşik öntanımlı ortam türü text/html olarak atanmıştır.

default_charset string

PHP 5.6 ve sonrasında, "UTF-8" öntanımlı değerdir ve eğer encoding kullanılmamışsa bu değer htmlentities(), html_entity_decode() ve htmlspecialchars() için öntanımlı karakter kodlaması olarak kullanılır. Ayrıca: iconv.input_encoding, iconv.output_encoding ve iconv.internal_encoding yapılandırma seçeneklerine değer atanmamışsa default_charset iconv işlevleri için de öntanımlı karakter kümesi olur. mbstring.http_input, mbstring.http_output ve mbstring.internal_encoding yapılandırma seçeneklerine değer atanmamışsa default_charset mbstring işlevleri için de öntanımlı karakter kümesi olur.

PHP tarafından gönderilen Content-Type başlığı header() çağrısı ile değiştirilmedikçe PHP'nin tüm sürümlerinde başlıktaki karakter kümesi değeri bu değer olacaktır.

default_charset seçeneğine boş değer atanması önerilmez.

input_encoding string

PHP 5.6.0 ve sonrasında kullanılabilir. Bu değer mbstring ve iconv gibi çokbayt modülleri için kullanılır. Öntanımlı değer boş dizgedir.

output_encoding string

PHP 5.6.0 ve sonrasında kullanılabilir. Bu değer mbstring ve iconv gibi çokbayt modülleri için kullanılır. Öntanımlı değer boş dizgedir.

internal_encoding string

PHP 5.6.0 ve sonrasında kullanılabilir. Bu değer mbstring ve iconv gibi çokbayt modülleri için kullanılır. Öntanımlı değer boş dizgedir ve böyle bir durumda default_charset kullanılır.

always_populate_raw_post_data mixed
Uyarı

Bu özelliğin kullanımı PHP 5.6.0 itibariyle ÖNERİLMEMEKTE olup PHP 7.0.0'da tamamen KALDIRILMIŞTIR.

$HTTP_RAW_POST_DATA değişkeni daima ham POST verisi içerilerek oluşturulur. Aksi takdirde, veri sadece tanınmayan MIME türünde oluşturulur.

Ham POST verisine erişmek için tercih edilen yollar php://input ve $HTTP_RAW_POST_DATA PHP 5.6.0 ve sonrasında önerilmemektedir. $HTTP_RAW_POST_DATA hiç tanımlanmadığı durumda always_populate_raw_post_data için -1 kullanmak PHP'nin gelecek sürümünde gerçeklenecek yeni davranış için bir seçenek olacaktır.

Ne atandığına bakılmaksızın $HTTP_RAW_POST_DATA enctype="multipart/form-data" ile kullanılamaz.

Ayrıca bakınız: magic_quotes_gpc, magic_quotes_runtime ve magic_quotes_sybase.

Dosya Yolları ve Dizinler

Dosya Yolları ve Dizinler için Yapılandırma seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
include_path | ".;/path/to/php/pear" | PHP_INI_ALL |
open_basedir | NULL | PHP_INI_ALL | PHP < 5.3.0'da PHP_INI_SYSTEM.
doc_root | NULL | PHP_INI_SYSTEM |
user_dir | NULL | PHP_INI_SYSTEM |
extension_dir | "/path/to/php" | PHP_INI_SYSTEM |
extension | NULL | sadece php.ini |
zend_extension | NULL | sadece php.ini |
zend_extension_debug | NULL | sadece php.ini | PHP 5.3.0 öncesinde kullanılabilir.
zend_extension_debug_ts | NULL | sadece php.ini | PHP 5.3.0 öncesinde kullanılabilir.
zend_extension_ts | NULL | sadece php.ini | PHP 5.3.0 öncesinde kullanılabilir.
cgi.check_shebang_line | "1" | PHP_INI_SYSTEM | PHP 5.2.0 ve sonrasında mevcuttur.
cgi.discard_path | "0" | PHP_INI_SYSTEM | PHP 5.3.0 ve sonrasında mevcuttur.
cgi.fix_pathinfo | "1" | PHP_INI_SYSTEM | PHP 4.3.0 ve sonrasında mevcuttur. PHP 5.2.1 öncesinde PHP_INI_ALL.
cgi.force_redirect | "1" | PHP_INI_SYSTEM | PHP 4.2.0 ve sonrasında mevcuttur. PHP 5.2.1 öncesinde PHP_INI_ALL.
cgi.nph | "0" | PHP_INI_SYSTEM | PHP 5.3.0 ve sonrasında mevcuttur.
cgi.redirect_status_env | NULL | PHP_INI_SYSTEM | PHP 4.2.0 ve sonrasında mevcuttur. PHP 5.2.1 öncesinde PHP_INI_ALL.
cgi.rfc2616_headers | "0" | PHP_INI_ALL | PHP 4.3.0 ve sonrasında mevcuttur.
fastcgi.impersonate | "0" | PHP_INI_SYSTEM | PHP 4.3.0 ve sonrasında mevcuttur. PHP 5.2.1 öncesinde PHP_INI_ALL.
fastcgi.logging | "1" | PHP_INI_SYSTEM | PHP 4.3.0 ve sonrasında mevcuttur. PHP 5.2.1 öncesinde PHP_INI_ALL.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

include_path string

require, include, fopen(), file(), readfile() ve file_get_contents() işlevleri için dosyaların aranacağı dizinler belirtilir. Dizgenin biçemi sistemin PATH ortam değişkenindeki gibidir: Dizinler Unix'te iki nokta imleriyle, Windows'ta ise noktalı virgüllerle ayrılır.

PHP, dahil edilecek dosyaları include_path içindeki yollarda her dosya için tek tek sırayla arar. Önce ilk yola bakar, sonra diğerine, böyle gider. Dosyayı bulursa döner, bulamazsa bir uyarı veya bir hata verir. Bu yönergenin değerini betiğinizin çalışması sırasında set_include_path() işleviyle değiştirebilirsiniz.

Örnek 1 Unix include_path

include_path=".:/php/includes"

Örnek 2 Windows include_path

include_path=".;c:\php\includes"

Dosya yolu olarak . belirtilmesi çalışılan dizinin arama yollarına dahil edilmesini sağlar. Ancak, dahil edilen her dosyayı PHP'nin daima denetlemesini isterseniz include './dosya' biçemini kullanmak daha iyidir.

Bilginize:

ENV değişkenlerine .ini dosyalarında daima erişilebilmektedir. Dolayısıyla, ${LOGIN} ve ${USER}.kullanarak home dizinine erişmek mümkündür.

Ortam değişkenleri sunucunun çalıştığı sisteme bağlı olarak değişiklik gösterebilir.

Örnek 3 include_path değişkeninde Unix ${USER} ortam değişkeni kullanımı

include_path = ".:${USER}/pear/php"

open_basedir string

PHP tarafından açılmış dosyaları, dosyanın kendisi de dahil olmak üzere belirtilen dizin ağacı ile sınırlar. Bu yönerge güvenli kipin etkin olup olmamasından etkilenmez.

Örneğin bir betik dosya sistemine erişmeye çalışırsa, örneğin fopen() veya gzopen() ile bir dosya açmaya çalışırsa dosyanın yerine bakılır. Dosya belirtilen dizin ağacının dışındaysa PHP bu dosyayı açmayı reddeder. Tüm sembolik bağlar çözümlenir, dolayısıyla bir sembolik bağ kullanarak bu kısıtlamayı aşmak mümkün değildir. Eğer dosya mevcut değilse sembolik bağ çözümlenemeyeceğinden dosyanın kendisi open_basedir ile karşılaştırılır.

open_basedir dosya sistemi işlevlerinden daha fazlasını etkileyebilir; örneğin, MySQL mysqlnd sürücülerini kullanacak şekilde yapılandırılmışsa LOAD DATA INFILE bu seçenekten etkilenir. PHP'nin gelişkin işlevselliğinin çoğu open_basedir'ı böyle kullanır.

Betiğin çalışma dizinini belirten nokta (.) özel değeri temel dizini belirtmek için kullanılabilir. Bunula birlikte, çalışma dizini chdir() ile kolayca değiştirilebilceğinden bunu yapmak biraz tehlikelidir.

httpd.conf içinde (örneğin bazı sanal konaklarda), open_basedir yönergesi diğer "php_admin_value open_basedir none" gibi yapılandırma yönergelerinde yapıldığı gibi kapatılabilir.

Windows altında, dizinleri aralarına noktalı virgül konarak belirtilir. Diğer tüm sistemlerde ikinokta imi kullanılır. PHP'nin Apache modülü olarak kullanıldığı durumlarda open_basedir ile belirtilen yollar artık üst dizinlerinden özdevinimli olarak miras alınmaktadır.

PHP 5.2.16 ve 5.3.4'ten beri open_basedir ile belirtilen kısıt bir dizin ismidir. Önceki sürümler bunu bir önek olarak kullanırdı. Örneğin "open_basedir = /dir/incl" ile (mevcut oldukları takdirde) "/dir/include" dizinlerine erişime izin verilir. Belli bir dizine erişimi kısıtlamak istiyorsanız yolun sonuna bir bölü çizgisi ekleyin. Örnek: open_basedir = /dir/incl/

Öntanımlı olarak bütün dosyaların açılmasına izin verilir.

Bilginize:

PHP 5.3.0'dan itibaren open_basedir çalışma anında daha da kısıtlayıcı hale getirilebilmektedir. Örneğin, php.ini içinde open_basedir yönergesinde /siteler/ dizini belirtilmişse çalışma anında ini_set() işlevi kullanılarak kısıtlama /siteler/tmp/ ile daha da daraltılabilir. Çeşitli dizinleri listelerken, işletim sisteminin kısıtlarına aldırmaksızın bir ayraç olarak PATH_SEPARATOR sabiti kullanılabilir.

doc_root string

PHP'nin sunucu üzerindeki kök dizini. Sadece boş olmadığı takdirde kullanılır. PHP safe_mode ile yapılandırılmışsa, Bu dizin dışındaki dosyalar sunulmaz. PHP, FORCE_REDIRECT ile derlenmişse, PHP'yi HTTP sunucusu altında bir CGI olarak çalıştırıyorsanız doc_root yönergesini atamanız gerekir (IIS hariç). Bunun yerine aşağıdaki cgi.force_redirect yapılandırması da kullanılabilir.

user_dir string

Kullanıcının ev dizininde PHP dosyalarının bulunduğu ana dizin. Örnek: public_html.

extension_dir string

PHP'nin devingen olarak yüklenebilen eklentileri arayacağı dizin. Ayrıca bakınız: enable_dl ve dl().

extension string

PHP başlatılırken devingen olarak yüklenecek eklentiler.

zend_extension string

PHP başlatılırken yüklenecek devingen olarak yüklenebilen Zend eklentisinin ismi (örneğin: APD).

zend_extension_debug string

Hata ayıklama bilgisi ile derlenmiş eklentiler için PHP5.3.0 öncesinde zend_extension yerine bu yönerge kullanılır.

zend_extension_debug_ts string

PHP5.3.0 öncesinde evre güvenliği ve hata ayıklama bilgisi ile derlenmiş eklentiler için zend_extension yerine bu yönerge kullanılır.

zend_extension_ts string

PHP5.3.0 öncesinde evre güvenliği ile derlenmiş eklentiler için zend_extension yerine bu yönerge kullanılır.

cgi.check_shebang_line boolean

CGI PHP'nin betiklerin başında #! ile başlayan satırın varlığına bakıp bakmayacağını belirler. Betik hem PHP CGI hem de tek başına bir betik olarak çalışabiliyorsa bu satır gerekebilir. PHP, CGI kipinde çalışırken bu satırı atlar, bu yönerge "1" olsa bile satırın içeriği yok sayılır.

cgi.discard_path boolean

Etkinse, the PHP CGI ikili site ağacının dışına güvenle yerleştirilebilir ve .htaccess güvenliğini kimse atlatamaz.

cgi.fix_pathinfo boolean

CGI için gerçek PATH_INFO/PATH_TRANSLATED desteği sağlar. PHP'nin önceki davranışı SCRIPT_FILENAME'e PATH_TRANSLATED atamak ve PATH_INFO'yu kaale almamaktı. PATH_INFO hakkında daha ayrıntılı bilgi edinmek için CGI belirtimine bakınız. Bu yönergeye 1 atamakla PHP CGI'nin CGICGI belirtimine uygun olarak dosya arama yollarını düzeltmesi sağlanmış olur. Sıfır atandığında ise PHP'nin önceki davranışı etkin olur. Öntanımlı değer sıfırdır. Betiklerinizi PATH_TRANSLATED değil SCRIPT_FILENAME kullanması için düzeltmelisiniz.

cgi.force_redirect boolean

PHP'nin çoğu HTTP sunucusunda bir CGI olarak çalışmasının güvenli olmasını sağlamak için bu yönerge gereklidir. Tanımsız bırakılmışsa PHP öntanımlı olarak yönergeyi etkin kılar. Bu yönergeyi etkisiz bırakmakla kendinizi riske atmış olursunuz.

Bilginize:

Windows Kullanıcılarına: IIS kullanıyorsanız buna rahatça sıfır atayabilirsiniz ve hatta bunu yapmalısınız. Bu, OmniHTTPD veya Xitami'nin çalışması için de yapılmalıdır.

cgi.nph boolean

Etkinse, cgi'nin her isteğe mutlaka Status: 200 göndermesini sağlar.

cgi.redirect_status_env string

cgi.force_redirect yönergesine 1 atanmışsa ve Apache veya Netscape (iPlanet) HTTP sunucularını kullanmıyorsanız, PHP'nin çalışmaya devam edebileceği bilgisini almak için bakacağı bir ortam değişkeni ismini bu yönergeye atamanız gerekebilir.

Bilginize:

Ne yaptığınız konusunda bir fikriniz yoksa bu yönergeye bir isim atamak güvenlikle ilgili sorunlara yol açabilir.

cgi.rfc2616_headers int

HTTP yanıt kodu gönderilirken hangi başlık türlerinin kullanılacağını belirler. 0 atanırsa PHP, Apache ve diğer HTTP sunucuları tarafından desteklenen bir » RFC 3875 Status: başlığı gönderir. 1 atanırsa PHP, » RFC 2616 uyumlu başlıklar gönderir.

Bu seçenek etkinse ve PHP'yi bir CGI ortamında kullanıyorsanız (PHP-FPM gibi), standard RFC 2616 tarzı HTTP durum yanıt başlıklarını değil, onların RFC 3875 eşdeğerlerini kullanmalısınız. Örneğin header("HTTP/1.0 404 Not found"); değil, header("Status: 404 Not Found"); kullanmalısınız.

Ne yapıldığı hakkında bir fikriniz yoksa bu yönergeyi 0 değeriyle bırakın.

fastcgi.impersonate string

IIS (WINNT temelli sistemlerde) altında FastCGI, çağrı yapan istemcinin güvenlik dizgeciklerinin taklit edilmesi yeteneğini destekler. Bu, IIS'ye isteğin altında çalıştığı güvenlik bağlamını tanımlama izni verir. Apache'nin mod_fastcgi modülü bu özelliği desteklemez (17-03-2002). IIS altında çalışılıyorsa yönergeye 1 atayın. Öntanımlı değer sıfırdır.

fastcgi.logging boolean

Turns on SAPI logging when using FastCGI kullanırken SAPI oturum açma etkin olur ve bu öntanımlı durumdur.

Karşıya Dosya Yükleme

Karşıya Dosya Yükleme Yapılandırma seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
file_uploads | "1" | PHP_INI_SYSTEM | PHP <= 4.2.3'te PHP_INI_ALL. PHP 4.0.3 ve sonrasında mevcuttur.
upload_tmp_dir | NULL | PHP_INI_SYSTEM |
max_input_nesting_level | 64 | PHP_INI_PERDIR | PHP 5.3.9'dan beri kullanılabilmektedir.
max_input_vars | 1000 | PHP_INI_PERDIR | PHP 5.3.9'dan beri kullanılabilmektedir.
upload_max_filesize | "2M" | PHP_INI_PERDIR | PHP <= 4.2.3'te PHP_INI_ALL.
max_file_uploads | 20 | PHP_INI_SYSTEM | PHP 5.2.12'den beri kullanılabilmektedir.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

file_uploads boolean

HTTP üzerinden karşıya dosya yüklemeye izin verilip verilmeyeceğini belirler. Ayrıca, upload_max_filesize, upload_tmp_dir ve post_max_size yönergelerine de bakınız.

upload_tmp_dir string

Karşıya dosya yüklenirken dosyaların geçici olarak saklanacağı dizin. Dizinin, PHP'yi çalıştıran kullanıcı tarafından yazılabilir olması gerekir. Bir dizin belirtilmezse PHP sistem öntanımlısını kullanır.

upload_max_filesize integer

Karşıya yüklenecek dosyalar için azami boyut.

integer türünde bir değer kullanıldığında değer baytların sayısıdır. Büyük bayt değerleri için kullanılabilecek birimlerin gösterimleri hakkında bilgiyi bu SSS altında bulabilirsiniz.
max_file_uploads integer

Aynı anda karşıya yüklenebilecek azami dosya sayısı.

Genel SQL

Genel SQL Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
sql.safe_mode | "0" | PHP_INI_SYSTEM |

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

sql.safe_mode boolean

On değeri atandığında, öntanımlı değerler belirtilmiş veritabanı bağlantı işlevleri kullanıcı tarafından sağlanan değiştirgelerin yerine bu değerleri kullanacaktır. Öntanımlı değerlerin neler olduğunu görmek için ilgili veritabanının bağlantı işlevleri belgelerine bakınız.

Windows'a Özel

Windows'a Özel Yapılandırma Seçenekleri
İsim | Öntanımlı | Değişlik Yeri | Sürüm Bilgisi
windows.show_crt_warning | "0" | PHP_INI_ALL | PHP 5.4.0'dan beri kullanılabilmektedir.

Yapılandırma yönergelerinin kısa açıklamalarını aşağıda bulabilirsiniz.

windows.show_crt_warning boolean

Etkin olduğunda Windows CRT uyarılarını gösterir. PHP 5.4.0'a kadar bu uyarılar öntanımlı olarak gösterilirdi.

php.ini bölümlerinin listesi
Eklenti Grupları/Listesi
php.ini Yönergeleri


Eklenti Grupları/Listesi

İçindekiler

  • Abecesel
  • Üyeler
  • Durumu Belirsizler

Bu bölümde PHP kılavuzunda çeşitli kurallara göre gruplanmış 150'den fazla eklenti listelenmiştir.

Temel php.ini yönergelerinin tanımları
Abecesel
Ekler


Abecesel

  • Apache
  • APC
  • APCu
  • APD
  • Diziler
  • BBCode
  • BC Math
  • bcompiler
  • BLENC
  • Bzip2 Sıkıştırma
  • Cairo
  • Takvim
  • chdb
  • Classkit
  • Sınıflar ve Nesneler
  • COM
  • Crack
  • CSPRNG
  • Ctype
  • CUBRID
  • cURL
  • Cyrus
  • Tarih ve Zaman
  • DBA
  • dBase
  • DB++
  • dbx
  • Doğrudan G/Ç
  • Dizinler
  • DOM
  • Data Structures
  • Eio
  • Enchant
  • Hata İşleme
  • Ev
  • Event
  • Program Çalıştırma
  • Exif
  • Expect
  • FAM
  • FANN
  • FrontBase
  • FDF
  • Fileinfo
  • filePro
  • Dosya Sistemi
  • Filter
  • FastCGI Process Manager
  • FriBiDi
  • FTP
  • İşlevlerle İlgili İşlemler
  • Gearman
  • Gender
  • GeoIP
  • Gettext
  • Gmagick
  • GMP
  • GnuPG
  • Gupnp
  • haru
  • Hash
  • HRTime
  • htscanner
  • Hyperwave API
  • Firebird/InterBase
  • IBM DB2
  • iconv
  • ID3
  • Informix
  • IIS
  • GD
  • ImageMagick
  • IMAP
  • inclued
  • PHP Seçenek ve Bilgileri
  • Ingres
  • Inotify
  • intl
  • JSON
  • Judy
  • KADM5
  • KTaglib
  • Lapack
  • LDAP
  • Libevent
  • libxml
  • Lua
  • LZF
  • Eposta
  • Mailparse
  • Math
  • MaxDB
  • Çok Baytlı Dizgeler
  • Mcrypt
  • MCVE
  • Memcache
  • Memcached
  • Memtrack
  • Mhash
  • MIME Türü
  • Ming
  • Muhtelif
  • mnoGoSearch
  • Mongo
  • MongoDB\Driver
  • mqseries
  • Msession
  • mSQL
  • Mssql
  • MySQL
  • MySQLi
  • Mysqlnd
  • mysqlnd_memcache
  • mysqlnd_ms
  • mysqlnd_mux
  • mysqlnd_qc
  • mysqlnd_uh
  • Ncurses
  • Gopher
  • Ağ
  • Newt
  • YP/NIS
  • NSAPI
  • OAuth
  • OCI8
  • oggvorbis
  • OPcache
  • OpenAL
  • OpenSSL
  • Çıktı Denetimi
  • Paradox
  • Parsekit
  • Password Hashing
  • PCNTL
  • Perl Uyumlu Düzenli İfadeler
  • PDF
  • PDO
  • PDO_4D sürücüsü
  • CUBRID (PDO)
  • MS SQL Sunucusu (PDO)
  • Firebird/Interbase (PDO)
  • IBM (PDO)
  • Informix (PDO)
  • MySQL (PDO)
  • Oracle (PDO)
  • ODBC ve DB2 (PDO)
  • PostgreSQL (PDO)
  • SQLite (PDO)
  • MS SQL Server (PDO)
  • PostgreSQL
  • Phar
  • POSIX
  • Proctitle
  • PS
  • Pspell
  • pthreads
  • Quickhash
  • Radius
  • Rar
  • Readline
  • Recode
  • Reflection
  • POSIX Düzenli İfadeleri
  • RPM Reader
  • RRD
  • runkit
  • SAM
  • SCA
  • scream
  • SDO
  • SDO DAS XML
  • SDO-DAS-Relational
  • Semaphore
  • Oturumlar
  • Session PgSQL
  • Shared Memory
  • Basit XML
  • SNMP
  • SOAP
  • Soketler
  • Solr
  • Sphinx
  • SPL
  • SPL Types
  • SQLite
  • SQLite3
  • SQLSRV
  • ssdeep
  • SSH2
  • Statistics
  • Stomp
  • Akımlar
  • Dizgeler
  • SVM
  • SVN
  • Swish
  • Sybase
  • Sync
  • Taint
  • TCP
  • Tidy
  • Simgeleştirici
  • tokyo_tyrant
  • Trader
  • UI
  • ODBC
  • uopz
  • URL'ler
  • V8js
  • Değişken İşlemleri
  • Varnish
  • vpopmail
  • WDDX
  • Weakref
  • win32ps
  • win32service
  • WinCache
  • xattr
  • xdiff
  • Xhprof
  • XML Çözümleyici
  • XMLReader
  • XML-RPC
  • XMLWriter
  • XSL
  • Yaf
  • Yaml
  • Yar
  • YAZ
  • Zip
  • Zlib Eklentisi
  • 0MQ messaging
  • ZooKeeper
Eklenti Grupları/Listesi
Üyeler
Eklenti Grupları/Listesi


Üyeler

Çekirdek Eklentiler

Bunlar aslında eklenti değildir. PHP çekirdeğinin parçaları olup derleme seçenekleriyle PHP çalıştırılabilirinin dışına çıkarılamazlar.

  • Diziler

  • Sınıflar ve Nesneler

  • Tarih ve Zaman

  • Dizinler

  • Hata İşleme

  • Program Çalıştırma

  • Dosya Sistemi

  • Filter

  • İşlevlerle İlgili İşlemler

  • Hash

  • PHP Seçenek ve Bilgileri

  • Eposta

  • Math

  • Muhtelif

  • Ağ

  • Çıktı Denetimi

  • Password Hashing

  • Phar

  • Reflection

  • POSIX Düzenli İfadeleri

  • Oturumlar

  • SPL

  • Akımlar

  • Dizgeler

  • Simgeleştirici

  • URL'ler

  • Değişken İşlemleri

Dahili Eklentiler

Bunlar PHP kaynak paketinin içinde dağıtılan eklentilerdir.

  • Apache

  • BC Math

  • Takvim

  • COM

  • Ctype

  • DBA

  • Exif

  • Fileinfo

  • FTP

  • iconv

  • GD

  • intl

  • JSON

  • Çok Baytlı Dizgeler

  • NSAPI

  • PCNTL

  • Perl Uyumlu Düzenli İfadeler

  • PDO

  • POSIX

  • Semaphore

  • Shared Memory

  • Soketler

  • SQLite3

  • XML-RPC

  • Zlib Eklentisi

Harici Eklentiler

Bu eklentiler PHP ile birlikte dağıtılırsa da derlenmesi sırasında harici kütüphanelere ihtiyaç duyulur.

  • Bzip2 Sıkıştırma

  • cURL

  • dBase

  • DOM

  • Enchant

  • FrontBase

  • Gettext

  • GMP

  • Firebird/InterBase

  • Informix

  • IMAP

  • LDAP

  • libxml

  • Mcrypt

  • Mhash

  • mSQL

  • Mssql

  • MySQL

  • MySQLi

  • Mysqlnd

  • OCI8

  • OpenSSL

  • MS SQL Sunucusu (PDO)

  • Firebird/Interbase (PDO)

  • MySQL (PDO)

  • Oracle (PDO)

  • ODBC ve DB2 (PDO)

  • PostgreSQL (PDO)

  • SQLite (PDO)

  • PostgreSQL

  • Pspell

  • Readline

  • Recode

  • Basit XML

  • SNMP

  • SOAP

  • Sybase

  • Tidy

  • ODBC

  • WDDX

  • XML Çözümleyici

  • XMLReader

  • XMLWriter

  • XSL

  • Zip

PECL Eklentileri

Bunlar » PECL deposundan temin edilebilen eklentilerdir. Derleme sırasında harici kütüphanelere ihtiyaç duyulur. Çok sayıda PECL eklentisi mevcut olmasına rağmen PHP Kılavuzunda tamamı hala belgelenememiştir.

  • APC

  • APD

  • BBCode

  • bcompiler

  • Cairo

  • chdb

  • Classkit

  • Crack

  • CUBRID

  • Cyrus

  • DB++

  • dbx

  • Doğrudan G/Ç

  • Eio

  • Ev

  • Event

  • Expect

  • FAM

  • FDF

  • filePro

  • FriBiDi

  • Gearman

  • Gender

  • GeoIP

  • Gmagick

  • GnuPG

  • Gupnp

  • haru

  • htscanner

  • Hyperwave API

  • IBM DB2

  • ID3

  • IIS

  • ImageMagick

  • inclued

  • Ingres

  • Inotify

  • Judy

  • KADM5

  • KTaglib

  • Lapack

  • Libevent

  • Lua

  • LZF

  • Mailparse

  • MaxDB

  • MCVE

  • Memcache

  • Memcached

  • Memtrack

  • MIME Türü

  • Ming

  • mnoGoSearch

  • Mongo

  • mqseries

  • Msession

  • mysqlnd_memcache

  • mysqlnd_ms

  • mysqlnd_mux

  • mysqlnd_qc

  • mysqlnd_uh

  • Ncurses

  • Gopher

  • Newt

  • YP/NIS

  • OAuth

  • oggvorbis

  • OpenAL

  • Paradox

  • Parsekit

  • PDF

  • PDO_4D sürücüsü

  • CUBRID (PDO)

  • IBM (PDO)

  • Informix (PDO)

  • MS SQL Server (PDO)

  • Proctitle

  • PS

  • pthreads

  • Quickhash

  • Radius

  • Rar

  • RPM Reader

  • RRD

  • runkit

  • SAM

  • SCA

  • scream

  • SDO

  • SDO DAS XML

  • SDO-DAS-Relational

  • Session PgSQL

  • Solr

  • Sphinx

  • SPL Types

  • SQLite

  • SQLSRV

  • ssdeep

  • SSH2

  • Statistics

  • Stomp

  • SVM

  • SVN

  • Swish

  • Taint

  • TCP

  • tokyo_tyrant

  • Trader

  • V8js

  • Varnish

  • vpopmail

  • Weakref

  • win32ps

  • win32service

  • WinCache

  • xattr

  • xdiff

  • Xhprof

  • Yaf

  • Yaml

  • YAZ

  • ZooKeeper

Abecesel
Durumu Belirsizler
Eklenti Grupları/Listesi


Durumu Belirsizler

Burada üretim amaçlı kullanılmayan eklentiler listelenmiştir; bunlar ya çok "eski" (önerilmez) ya da "yeni" (deneysel) eklentilerdir.

Kullanımı Önerilmeyen Eklentiler

Bunlar, daha kullanışlı başka eklentilerin varlığı nedeniyle artık kullanımı önerilmeyen eklentilerdir.

  • Memtrack

  • MIME Türü

Deneysel Eklentiler

Bu eklentilerin davranışları PHP'nin sonraki sürümlerinde bilgi verilmeksizin değiştirilebilir; buna işlevlerin isimleri ve eklentiyle ilgili her türlü belge dahildir. Bu eklentileri kullanıp kullanmama kararı size kalmıştır.

  • bcompiler

  • DB++

  • haru

  • Hash

  • ImageMagick

  • Ming

  • Ncurses

  • Newt

  • Paradox

  • MS SQL Sunucusu (PDO)

  • Firebird/Interbase (PDO)

  • Oracle (PDO)

  • PS

  • SCA

  • SDO-DAS-Relational

  • Swish

  • vpopmail

  • XML-RPC

Üyeler
İşlev Takma Adlarının Listesi
Eklenti Grupları/Listesi


İşlev Takma Adlarının Listesi

PHP'de birden fazla isimle çağırabileceğiniz pek az işlev vardır. Bazı durumlarda çok sayıda ismin arasından birinin özellikle tercih edilmediği bazı durumlar vardır; is_int() ve is_integer() işlevleri aynı oranda tercih edilmeleriyle bunlara iyi birer örnektir. Bununla birlikte, API değişmesi veya başka bir sebeple isimleri değişen işlevler vardır. Bunların eski isimleri birer takma ad olarak geriye uyumluluk için tutulmaktadır. Bu çeşit takma adları kullanmamanız gerekir, çünkü bunlar bir zaman gelir desteklenmekten vaz geçilebilir veya isimleri değiştirilebilir ve dolayısıyla betiğiniz taşınabilirlik özelliğini kaybedebilir. Bu liste eski betiklerini yeni sözdizimine güncellemek isteyenlere yardımcı olmak amacıyla oluşturulmuştur.

Takma Adlar
Takma Ad | Asıl İşlev | Bulunduğu Eklenti
_ | gettext() | Gettext
add | swfmovie_add() | Ming (flash)
add | swfsprite_add() | Ming (flash)
addaction | swfbutton_addAction() | Ming (flash)
addcolor | swfdisplayitem_addColor() | Ming (flash)
addentry | swfgradient_addEntry() | Ming (flash)
addfill | swfshape_addfill() | Ming (flash)
addshape | swfbutton_addShape() | Ming (flash)
addstring | swftext_addString() | Ming (flash)
addstring | swftextfield_addString() | Ming (flash)
align | swftextfield_align() | Ming (flash)
chop | rtrim() | Temel sözdizimi
close | closedir() | Temel sözdizimi
com_get | com_propget() | COM
com_propset | com_propput() | COM
com_set | com_propput() | COM
die | exit() | Çeşitli İşlevler
diskfreespace | disk_free_space() | Dosya Sistemi
doubleval | floatval() | Temel sözdizimi
drawarc | swfshape_drawarc() | Ming (flash)
drawcircle | swfshape_drawcircle() | Ming (flash)
drawcubic | swfshape_drawcubic() | Ming (flash)
drawcubicto | swfshape_drawcubicto() | Ming (flash)
drawcurve | swfshape_drawcurve() | Ming (flash)
drawcurveto | swfshape_drawcurveto() | Ming (flash)
drawglyph | swfshape_drawglyph() | Ming (flash)
drawline | swfshape_drawline() | Ming (flash)
drawlineto | swfshape_drawlineto() | Ming (flash)
fbsql | fbsql_db_query() | FrontBase
fputs | fwrite() | Temel sözdizimi
getascent | swffont_getAscent() | Ming (flash)
getascent | swftext_getAscent() | Ming (flash)
getdescent | swffont_getDescent() | Ming (flash)
getdescent | swftext_getDescent() | Ming (flash)
getheight | swfbitmap_getHeight() | Ming (flash)
getleading | swffont_getLeading() | Ming (flash)
getleading | swftext_getLeading() | Ming (flash)
getshape1 | swfmorph_getShape1() | Ming (flash)
getshape2 | swfmorph_getShape2() | Ming (flash)
getwidth | swfbitmap_getWidth() | Ming (flash)
getwidth | swffont_getWidth() | Ming (flash)
getwidth | swftext_getWidth() | Ming (flash)
gzputs | gzwrite() | Zlib
i18n_convert | mb_convert_encoding() | Çok baytlı dizgeler
i18n_discover_encoding | mb_detect_encoding() | Çok baytlı dizgeler
i18n_http_input | mb_http_input() | Çok baytlı dizgeler
i18n_http_output | mb_http_output() | Çok baytlı dizgeler
i18n_internal_encoding | mb_internal_encoding() | Çok baytlı dizgeler
i18n_ja_jp_hantozen | mb_convert_kana() | Çok baytlı dizgeler
i18n_mime_header_decode | mb_decode_mimeheader() | Çok baytlı dizgeler
i18n_mime_header_encode | mb_encode_mimeheader() | Çok baytlı dizgeler
imap_create | imap_createmailbox() | IMAP
imap_fetchtext | imap_body() | IMAP
imap_getmailboxes | imap_list_full() | IMAP
imap_getsubscribed | imap_lsub_full() | IMAP
imap_header | imap_headerinfo() | IMAP
imap_listmailbox | imap_list() | IMAP
imap_listsubscribed | imap_lsub() | IMAP
imap_rename | imap_renamemailbox() | IMAP
imap_scan | imap_listscan() | IMAP
imap_scanmailbox | imap_listscan() | IMAP
ini_alter | ini_set() | Temel sözdizimi
is_double | is_float() | Temel sözdizimi
is_integer | is_int() | Temel sözdizimi
is_long | is_int() | Temel sözdizimi
is_real | is_float() | Temel sözdizimi
is_writeable | is_writable() | Temel sözdizimi
join | implode() | Temel sözdizimi
key_exists | array_key_exists() | Temel sözdizimi
labelframe | swfmovie_labelFrame() | Ming (flash)
labelframe | swfsprite_labelFrame() | Ming (flash)
ldap_close | ldap_unbind() | LDAP
magic_quotes_runtime | set_magic_quotes_runtime() | Temel sözdizimi
mbstrcut | mb_strcut() | Çok baytlı dizgeler
mbstrlen | mb_strlen() | Çok baytlı dizgeler
mbstrpos | mb_strpos() | Çok baytlı dizgeler
mbstrrpos | mb_strrpos() | Çok baytlı dizgeler
mbsubstr | mb_substr() | Çok baytlı dizgeler
ming_setcubicthreshold | ming_setCubicThreshold() | Ming (flash)
ming_setscale | ming_setScale() | Ming (flash)
move | swfdisplayitem_move() | Ming (flash)
movepen | swfshape_movepen() | Ming (flash)
movepento | swfshape_movepento() | Ming (flash)
moveto | swfdisplayitem_moveTo() | Ming (flash)
moveto | swffill_moveTo() | Ming (flash)
moveto | swftext_moveTo() | Ming (flash)
msql | msql_db_query() | mSQL
msql_createdb | msql_create_db() | mSQL
msql_dbname | msql_result() | mSQL
msql_dropdb | msql_drop_db() | mSQL
msql_fieldflags | msql_field_flags() | mSQL
msql_fieldlen | msql_field_len() | mSQL
msql_fieldname | msql_field_name() | mSQL
msql_fieldtable | msql_field_table() | mSQL
msql_fieldtype | msql_field_type() | mSQL
msql_freeresult | msql_free_result() | mSQL
msql_listdbs | msql_list_dbs() | mSQL
msql_listfields | msql_list_fields() | mSQL
msql_listtables | msql_list_tables() | mSQL
msql_numfields | msql_num_fields() | mSQL
msql_numrows | msql_num_rows() | mSQL
msql_regcase | sql_regcase() | mSQL
msql_selectdb | msql_select_db() | mSQL
msql_tablename | msql_result() | mSQL
mssql_affected_rows | sybase_affected_rows() | Sybase
mssql_affected_rows | sybase_affected_rows() | Sybase
mssql_close | sybase_close() | Sybase
mssql_close | sybase_close() | Sybase
mssql_connect | sybase_connect() | Sybase
mssql_connect | sybase_connect() | Sybase
mssql_data_seek | sybase_data_seek() | Sybase
mssql_data_seek | sybase_data_seek() | Sybase
mssql_fetch_array | sybase_fetch_array() | Sybase
mssql_fetch_array | sybase_fetch_array() | Sybase
mssql_fetch_field | sybase_fetch_field() | Sybase
mssql_fetch_field | sybase_fetch_field() | Sybase
mssql_fetch_object | sybase_fetch_object() | Sybase
mssql_fetch_object | sybase_fetch_object() | Sybase
mssql_fetch_row | sybase_fetch_row() | Sybase
mssql_fetch_row | sybase_fetch_row() | Sybase
mssql_field_seek | sybase_field_seek() | Sybase
mssql_field_seek | sybase_field_seek() | Sybase
mssql_free_result | sybase_free_result() | Sybase
mssql_free_result | sybase_free_result() | Sybase
mssql_get_last_message | sybase_get_last_message() | Sybase
mssql_get_last_message | sybase_get_last_message() | Sybase
mssql_min_client_severity | sybase_min_client_severity() | Sybase
mssql_min_error_severity | sybase_min_error_severity() | Sybase
mssql_min_message_severity | sybase_min_message_severity() | Sybase
mssql_min_server_severity | sybase_min_server_severity() | Sybase
mssql_num_fields | sybase_num_fields() | Sybase
mssql_num_fields | sybase_num_fields() | Sybase
mssql_num_rows | sybase_num_rows() | Sybase
mssql_num_rows | sybase_num_rows() | Sybase
mssql_pconnect | sybase_pconnect() | Sybase
mssql_pconnect | sybase_pconnect() | Sybase
mssql_query | sybase_query() | Sybase
mssql_query | sybase_query() | Sybase
mssql_result | sybase_result() | Sybase
mssql_result | sybase_result() | Sybase
mssql_select_db | sybase_select_db() | Sybase
mssql_select_db | sybase_select_db() | Sybase
multcolor | swfdisplayitem_multColor() | Ming (flash)
mysql | mysql_db_query() | MySQL
mysql_createdb | mysql_create_db() | MySQL
mysql_db_name | mysql_result() | MySQL
mysql_dbname | mysql_result() | MySQL
mysql_dropdb | mysql_drop_db() | MySQL
mysql_fieldflags | mysql_field_flags() | MySQL
mysql_fieldlen | mysql_field_len() | MySQL
mysql_fieldname | mysql_field_name() | MySQL
mysql_fieldtable | mysql_field_table() | MySQL
mysql_fieldtype | mysql_field_type() | MySQL
mysql_freeresult | mysql_free_result() | MySQL
mysql_listdbs | mysql_list_dbs() | MySQL
mysql_listfields | mysql_list_fields() | MySQL
mysql_listtables | mysql_list_tables() | MySQL
mysql_numfields | mysql_num_fields() | MySQL
mysql_numrows | mysql_num_rows() | MySQL
mysql_selectdb | mysql_select_db() | MySQL
mysql_tablename | mysql_result() | MySQL
nextframe | swfmovie_nextFrame() | Ming (flash)
nextframe | swfsprite_nextFrame() | Ming (flash)
ociassignelem | OCI-Collection::assignElem | OCI8
ocibindbyname | oci_bind_by_name() | OCI8
ocicancel | oci_cancel() | OCI8
ocicloselob | OCI-Lob::close | OCI8
ocicollappend | OCI-Collection::append | OCI8
ocicollassign | OCI-Collection::assign | OCI8
ocicollmax | OCI-Collection::max | OCI8
ocicollsize | OCI-Collection::size | OCI8
ocicolltrim | OCI-Collection::trim | OCI8
ocicolumnisnull | oci_field_is_null() | OCI8
ocicolumnname | oci_field_name() | OCI8
ocicolumnprecision | oci_field_precision() | OCI8
ocicolumnscale | oci_field_scale() | OCI8
ocicolumnsize | oci_field_size() | OCI8
ocicolumntype | oci_field_type() | OCI8
ocicolumntyperaw | oci_field_type_raw() | OCI8
ocicommit | oci_commit() | OCI8
ocidefinebyname | oci_define_by_name() | OCI8
ocierror | oci_error() | OCI8
ociexecute | oci_execute() | OCI8
ocifetch | oci_fetch() | OCI8
ocifetchinto | oci_fetch_array(), oci_fetch_row(), oci_fetch_assoc(), oci_fetch_object() | OCI8
ocifetchstatement | oci_fetch_all() | OCI8
ocifreecollection | OCI-Collection::free | OCI8
ocifreecursor | oci_free_statement() | OCI8
ocifreedesc | oci_free_descriptor() | OCI8
ocifreestatement | oci_free_statement() | OCI8
ocigetelem | OCI-Collection::getElem | OCI8
ociinternaldebug | oci_internal_debug() | OCI8
ociloadlob | OCI-Lob::load | OCI8
ocilogon | oci_connect() | OCI8
ocinewcollection | oci_new_collection() | OCI8
ocinewcursor | oci_new_cursor() | OCI8
ocinewdescriptor | oci_new_descriptor() | OCI8
ocinlogon | oci_new_connect() | OCI8
ocinumcols | oci_num_fields() | OCI8
ociparse | oci_parse() | OCI8
ocipasswordchange | oci_password_change() | OCI8
ociplogon | oci_pconnect() | OCI8
ociresult | oci_result() | OCI8
ocirollback | oci_rollback() | OCI8
ocisavelob | OCI-Lob::save | OCI8
ocisavelobfile | OCI-Lob::import | OCI8
ociserverversion | oci_server_version() | OCI8
ocisetprefetch | oci_set_prefetch() | OCI8
ocistatementtype | oci_statement_type() | OCI8
ociwritelobtofile | OCI-Lob::export | OCI8
ociwritetemporarylob | OCI-Lob::writeTemporary | OCI8
odbc_do | odbc_exec() | ODBC
odbc_field_precision | odbc_field_len() | ODBC
output | swfmovie_output() | Ming (flash)
pdf_add_outline | pdf_add_bookmark() | PDF
pg_clientencoding | pg_client_encoding() | PostgreSQL
pg_setclientencoding | pg_set_client_encoding() | PostgreSQL
pos | current() | Temel sözdizimi
recode | recode_string() | Recode
remove | swfmovie_remove() | Ming (flash)
remove | swfsprite_remove() | Ming (flash)
rotate | swfdisplayitem_rotate() | Ming (flash)
rotateto | swfdisplayitem_rotateTo() | Ming (flash)
rotateto | swffill_rotateTo() | Ming (flash)
save | swfmovie_save() | Ming (flash)
savetofile | swfmovie_saveToFile() | Ming (flash)
scale | swfdisplayitem_scale() | Ming (flash)
scaleto | swfdisplayitem_scaleTo() | Ming (flash)
scaleto | swffill_scaleTo() | Ming (flash)
setaction | swfbutton_setAction() | Ming (flash)
setbackground | swfmovie_setBackground() | Ming (flash)
setbounds | swftextfield_setBounds() | Ming (flash)
setcolor | swftext_setColor() | Ming (flash)
setcolor | swftextfield_setColor() | Ming (flash)
setdepth | swfdisplayitem_setDepth() | Ming (flash)
setdimension | swfmovie_setDimension() | Ming (flash)
setdown | swfbutton_setDown() | Ming (flash)
setfont | swftext_setFont() | Ming (flash)
setfont | swftextfield_setFont() | Ming (flash)
setframes | swfmovie_setFrames() | Ming (flash)
setframes | swfsprite_setFrames() | Ming (flash)
setheight | swftext_setHeight() | Ming (flash)
setheight | swftextfield_setHeight() | Ming (flash)
sethit | swfbutton_setHit() | Ming (flash)
setindentation | swftextfield_setIndentation() | Ming (flash)
setleftfill | swfshape_setleftfill() | Ming (flash)
setleftmargin | swftextfield_setLeftMargin() | Ming (flash)
setline | swfshape_setline() | Ming (flash)
setlinespacing | swftextfield_setLineSpacing() | Ming (flash)
setmargins | swftextfield_setMargins() | Ming (flash)
setmatrix | swfdisplayitem_setMatrix() | Ming (flash)
setname | swfdisplayitem_setName() | Ming (flash)
setname | swftextfield_setName() | Ming (flash)
setover | swfbutton_setOver() | Ming (flash)
setrate | swfmovie_setRate() | Ming (flash)
setratio | swfdisplayitem_setRatio() | Ming (flash)
setrightfill | swfshape_setrightfill() | Ming (flash)
setrightmargin | swftextfield_setRightMargin() | Ming (flash)
setspacing | swftext_setSpacing() | Ming (flash)
setup | swfbutton_setUp() | Ming (flash)
show_source | highlight_file() | Temel sözdizimi
sizeof | count() | Temel sözdizimi
skewx | swfdisplayitem_skewX() | Ming (flash)
skewxto | swfdisplayitem_skewXTo() | Ming (flash)
skewxto | swffill_skewXTo() | Ming (flash)
skewy | swfdisplayitem_skewY() | Ming (flash)
skewyto | swfdisplayitem_skewYTo() | Ming (flash)
skewyto | swffill_skewYTo() | Ming (flash)
snmpwalkoid | snmprealwalk() | SNMP
strchr | strstr() | Temel sözdizimi
streammp3 | swfmovie_streamMp3() | Ming (flash)
swfaction | swfaction_init() | Ming (flash)
swfbitmap | swfbitmap_init() | Ming (flash)
swfbutton | swfbutton_init() | Ming (flash)
swffill | swffill_init() | Ming (flash)
swffont | swffont_init() | Ming (flash)
swfgradient | swfgradient_init() | Ming (flash)
swfmorph | swfmorph_init() | Ming (flash)
swfmovie | swfmovie_init() | Ming (flash)
swfshape | swfshape_init() | Ming (flash)
swfsprite | swfsprite_init() | Ming (flash)
swftext | swftext_init() | Ming (flash)
swftextfield | swftextfield_init() | Ming (flash)
xptr_new_context | xpath_new_context() |

Durumu Belirsizler
Yerleşik Sözcüklerin Listesi
Ekler


Yerleşik Sözcüklerin Listesi

İçindekiler

  • Anahtar Sözcüklerin Listesi
  • Öntanımlı Sınıflar
  • Yerleşik Sabitler
  • Diğer yerleşik sözcüklerin listesi

Bu bölümde PHP'de öntanımlı betimleyiciler listelenmiştir. Burada listelenmiş betimleyicilerin hiçbirini aksi açıkça belirtilmedikçe betiklerinizde betimleyici olarak kullanmamalısınız. Bu listeler, anahtar sözcükler, önceden tanımlanmış değişkenler, sabitler ve sınıf isimlerini içerir. Bu listelerde ayrıntılara yer verilmediği gibi listeler tamamlanmış da değildir.

İşlev Takma Adlarının Listesi
Anahtar Sözcüklerin Listesi
Ekler


Anahtar Sözcüklerin Listesi

PHP'de bazı sözcükler özel anlama sahiptirler. Bazıları işlevler, bazılar sabitler olarak karşımıza çıkarken bazılarıyla haya karşılaşmamış olabiliriz. Bunlar aslında dil oluşumlarıdır. Aşağıdaki sözcükleri sabit, sınıf, işlev veya yöntem ismi olarak kullanamazsınız. Değişken ismi olarak kullanılabilirlerse de karışıklığa yol açabilirler.

PHP 7.0.0 itibariyle bu anahtar sözcüklerin öznitelik, sabit ve class bir sabit ismi olarak kullanılmadıkça sınıf, arayüz ve niteliklerin yöntem isimleri olarak kullanılabilmesine izin verilmiştir.

PHP Anahtar Sözcükler
__halt_compiler() | abstract | and | array() | as
break | callable (PHP 5.4 itibariyle) | case | catch | class
clone | const | continue | declare | default
die() | do | echo | else | elseif
empty() | enddeclare | endfor | endforeach | endif
endswitch | endwhile | eval() | exit() | extends
final | finally (PHP 5.5 itibariyle) | for | foreach | function
global | goto (PHP 5.3'ten beri) | if | implements | include
include_once | instanceof | insteadof (PHP 5.4'ten beri) | interface | isset()
list() | namespace (PHP 5.3'ten beri) | new | or | print | private
protected | public | require | require_once
return | static | switch | throw | trait (PHP 5.4 itibariyle)
try | unset() | use | var | while
xor | yield (PHP 5.5 itibariyle) |  |  |
Derleme sabitleri
__CLASS__ | __DIR__ (PHP 5.3 itibariyle) | __FILE__ | __FUNCTION__ | __LINE__ | __METHOD__
__NAMESPACE__ (PHP 5.3 itibariyle) | __TRAIT__ (PHP 5.4 itibariyle) |  |  |  |
Yerleşik Sözcüklerin Listesi
Öntanımlı Sınıflar
Yerleşik Sözcüklerin Listesi


Öntanımlı Sınıflar

Bu bölümde öntanımlı standart sınıflar listelenmiştir. Diğer sınıflar çeşitli eklentilerde tanımlanmış olup bunlar dil başvuru kılavuzunda açıklanmışlardır.

Standart Tanımlı Sınıflar

Bu sınıflar PHP'ye derleme sırasında dahil edilen standart işlevlerle tanımlanır.

Directory
dir() işlevi ile oluşturuldu.
stdClass
nesneye yapılan tür zorlamaları ile oluşturulmuştur.
__PHP_Incomplete_Class
unserialize() işlevi ile oluşturulması muhtemeldir.

PHP 5 ve sonrası için Öntanımlı Sınıflar

Burada listelenen sınıflar PHP 5.0.0'da ortaya çıkmıştır.

Exception
ErrorException
PHP 5.1.0 itibariyle.
php_user_filter

Closure

Öntanımlı Closure final sınıfı PHP 5.3.0'da devreye girmiş, İsimsiz işlevleri ifade etmek için kullanılmıştır.

Daha fazla bilgi için sınıf sayfasına bakınız.

Generator Sınıfı

Öntanımlı Generator final sınıfı PHP 5.5.0'da devreye girmiştir. Üreteçleri ifade etmek için kullanılmıştır.

Daha fazla bilgi için sınıf sayfasına bakınız.

PHP 7 itibariyle öntanımlı arayüzler ve sınıflar

Bu ek öntanımlı arayüzler ve sınıflar PHP 7.0.0 ile gelmiştir.

ArithmeticError
AssertionError
DivisionByZeroError
Error
Throwable
ParseError
TypeError

Özel sınıflar

Aşağıdaki betimleyiciler özel amaçlı olup bır sınıf ismi olarak kullanılamazlar.

self
Etkin sınıf.
static
Çalışma zamanındaki etkin sınıf.
parent
Ebeveyn sınıf.
Anahtar Sözcüklerin Listesi
Yerleşik Sabitler
Yerleşik Sözcüklerin Listesi


Yerleşik Sabitler

Çekirdekte Öntanımlı Sabitler

Bu sabitler PHP çekirdeğinde tanımlanmıştır. PHP çekirdeği, PHP'nin kendisi, Zend motoru ve SAPI modüllerinden oluşur.

PHP_VERSION (string)
Şu anki PHP sürüm numarası "ana.alt.dağıtım[ek]" gösterimie sahiptir.
PHP_MAJOR_VERSION (integer)
Şu anki ana sürüm bir numara ile gösterilmektedir (örneğin, "5.2.7-extra" için ana sürüm int(5)'tir). PHP 5.2.7 ve sonrasında mevcuttur.
PHP_MINOR_VERSION (integer)
Şu anki alt sürüm bir numara ile gösterilmektedir (örneğin, "5.2.7-extra" için alt sürüm int(2)'dir). PHP 5.2.7 ve sonrasında mevcuttur.
PHP_RELEASE_VERSION (integer)
Şu anki dağıtım sürümü bir numara ile gösterilmektedir (örneğin, "5.2.7-extra" için dağıtım sürüm int(7)'dir). PHP 5.2.7 ve sonrasında mevcuttur.
PHP_VERSION_ID (integer)
Bir tamsayı olarak geçerli PHP sürümü ( örneğin, "5.2.7-extra" için int(50207)'dir. ). Sürüm karşılaştırması için faydalıdır. PHP 5.2.7 ve sonrasında mevcuttur.
PHP_EXTRA_VERSION (string)
Bir dizge olarak geçerli PHP ek sürümü ( örneğin, "5.2.7-extra" için '-extra'dır. ). Çoğunlukla paket dağıtımlarında paket sürümünü belirtmek için kullanılır. PHP 5.2.7 ve sonrasında mevcuttur.
PHP_ZTS (integer)
PHP 5.2.7 ve sonrasında mevcuttur.
PHP_DEBUG (integer)
PHP 5.2.7 ve sonrasında mevcuttur.
PHP_MAXPATHLEN (integer)
PHP derlenirken desteklenen en uzun dosya isminin (dosya yolu dahil) boyu. PHP 5.3.0 ve sonrasında mevcuttur.
PHP_OS (string)
PHP_SAPI (string)
PHP derlenirken kullanılan sunucu API'si. Ayrıca bakınız: php_sapi_name().
PHP_EOL (string)
Satır sonu ('End Of Line') sembolü. PHP 5.0.2'den beri mevcuttur.
PHP_INT_MAX (integer)
PHP derlenirken desteklenen en büyük tamsayı. Normalde int(2147483647). PHP 5.0.5'ten beri mevcuttur.
PHP_INT_MIN (integer)
PHP derlenirken desteklenen en küçük tamsayı. Normalde 32 bitlik sistemlerde int(-2147483647), 64 bitlik sistemlerde int(-9223372036854775808)'dir (PHP_INT_MIN === ~PHP_INT_MAX). PHP 7.0.0'dan beri mevcuttur.
PHP_INT_SIZE (integer)
PHP derlenirken bir tamsayının bayt cinsinden uzunluğu. PHP 5.0.5'ten beri mevcuttur.
DEFAULT_INCLUDE_PATH (string)
PEAR_INSTALL_DIR (string)
PEAR_EXTENSION_DIR (string)
PHP_EXTENSION_DIR (string)
PHP_PREFIX (string)
Yapılandırma sırasında atanan "--prefix" değeri.
PHP_BINDIR (string)
Çalıştılabilirlerin bulunduğu yer.
PHP_BINARY (string)
Betiklerin icrası için kullanılan çalıştılabilirin bulunduğu yer. PHP 5.4'ten beri mevcuttur.
PHP_MANDIR (string)
Man sayfalarının nerede kurulu olduğu belirtilir. PHP 5.3.7'den beri kullanılabilmektedir.
PHP_LIBDIR (string)
PHP_DATADIR (string)
PHP_SYSCONFDIR (string)
PHP_LOCALSTATEDIR (string)
PHP_CONFIG_FILE_PATH (string)
PHP_CONFIG_FILE_SCAN_DIR (string)
PHP_SHLIB_SUFFIX (string)
Derleme platformunun paylaşımlı kütüphane soneki. Normalde Unix'ler için "so", Windows için "dll"dir.
E_ERROR (integer)
Hata raporlama sabiti
E_WARNING (integer)
E_PARSE (integer)
E_NOTICE (integer)
E_CORE_ERROR (integer)
E_CORE_WARNING (integer)
E_COMPILE_ERROR (integer)
E_COMPILE_WARNING (integer)
E_USER_ERROR (integer)
E_USER_WARNING (integer)
E_USER_NOTICE (integer)
E_DEPRECATED (integer)
PHP 5.3.0 ve sonrasında mevcuttur.
E_USER_DEPRECATED (integer)
PHP 5.3.0 ve sonrasında mevcuttur.
E_ALL (integer)
E_STRICT (integer)
__COMPILER_HALT_OFFSET__ (integer)
PHP 5.1.0 ve sonrasında mevcuttur.
TRUE (boolean)
Ayrıca bakınız: Mantıksal veri türü.
FALSE (boolean)
Ayrıca bakınız: Mantıksal veri türü.
NULL (null)
Ayrıca bakınız: NULL veri türü.

Ayrıca bakınız: Sihirli Sabitler.

Standart Öntanımlı Sabitler

Temel eklentilerdeki tüm sabitler PHP'de öntanımlı olarak tanımlıdır.

Öntanımlı Sınıflar
Diğer yerleşik sözcüklerin listesi
Yerleşik Sözcüklerin Listesi


Diğer yerleşik sözcüklerin listesi

Aşağıdaki sözcükler bir sınıfın, arayüzün veya niteliğin ismi olarak kullanılamaz. Ayrıca, isim alanlarında kullanılmaları da yasaktır.

Yerleşik sözcükler
int (PHP 7 itibariyle) | float (PHP 7 itibariyle) | bool (PHP 7 itibariyle) | string (PHP 7 itibariyle)
true (PHP 7 itibariyle) | false (PHP 7 itibariyle) | null (PHP 7 itibariyle)

Aşağıdaki sözcükler sınıf, arayüz, ve nitelik isimleri olarak (hatta isim alanlarında bile) kullanılabilirlerse de, PHP'nin ileri sürümlerinde kullanılabilecekleri hesaba katılarak kullanılmamaya çalışılması daha iyi olacaktır.

Yerleşikliği olası sözcükler
resource (PHP 7 itibariyle) object (PHP 7 itibariyle) mixed (PHP 7 itibariyle) numeric (PHP 7 itibariyle)

Yerleşik Sabitler
Özkaynak Türlerinin Listesi
Yerleşik Sözcüklerin Listesi


Özkaynak Türlerinin Listesi

Bu bölümde PHP özkaynaklarını oluşturmak, kullanmak ve yok etmekte kullanılan işlevler listelenmiştir. is_resource() işlevi bir değişkenin bir özkaynak olup olmadığını saptamakta kullanılır. get_resource_type() işlevi ise özkaynağın türünü döndürür.

Özkaynak Türleri
Özkaynak Türünün Adı | Oluşturmak için | Kullanmak için | Yok etmek için | Tanımı
aspell | aspell_new() | aspell_check(), aspell_check_raw(), aspell_suggest() | Yok | Aspell sözlüğü
bzip2 | bzopen() | bzerrno(), bzerror(), bzerrstr(), bzflush(), bzread(), bzwrite() | bzclose() | Bzip2 dosyası
COM | com_load() | com_invoke(), com_propget(), com_get(), com_propput(), com_set(), com_propput() | Yok | COM nesne gönderimi
VARIANT
cpdf | cpdf_open() | cpdf_page_init(), cpdf_finalize_page(), cpdf_finalize(), cpdf_output_buffer(), cpdf_save_to_file(), cpdf_set_current_page(), cpdf_begin_text(), cpdf_end_text(), cpdf_show(), cpdf_show_xy(), cpdf_text(), cpdf_set_font(), cpdf_set_leading(), cpdf_set_text_rendering(), cpdf_set_horiz_scaling(), cpdf_set_text_rise(), cpdf_set_text_matrix(), cpdf_set_text_pos(), cpdf_set_text_pos(), cpdf_set_word_spacing(), cpdf_continue_text(), cpdf_stringwidth(), cpdf_save(), cpdf_translate(), cpdf_restore(), cpdf_scale(), cpdf_rotate(), cpdf_setflat(), cpdf_setlinejoin(), cpdf_setlinecap(), cpdf_setmiterlimit(), cpdf_setlinewidth(), cpdf_setdash(), cpdf_moveto(), cpdf_rmoveto(), cpdf_curveto(), cpdf_lineto(), cpdf_rlineto(), cpdf_circle(), cpdf_arc(), cpdf_rect(), cpdf_closepath(), cpdf_stroke(), cpdf_closepath_fill_stroke(), cpdf_fill_stroke(), cpdf_clip(), cpdf_fill(), cpdf_setgray_fill(), cpdf_setgray_stroke(), cpdf_setgray(), cpdf_setrgbcolor_fill(), cpdf_setrgbcolor_stroke(), cpdf_setrgbcolor(), cpdf_add_outline(), cpdf_set_page_animation(), cpdf_import_jpeg(), cpdf_place_inline_image(), cpdf_add_annotation() | cpdf_close() | CPDF kütüphanesiyle PDF belge
cpdf outline
cubrid bağlantısı | cubrid_connect() cubrid_connect_with_url() | cubrid_col_get() cubrid_col_size() cubrid_commit() cubrid_drop() cubrid_execute() cubrid_get_autocommit() cubrid_get_charset() cubrid_get_class_name() cubrid_get_db_parameter() cubrid_get_server_info() cubrid_get() cubrid_insert_id() cubrid_is_instance() cubrid_lob_export() cubrid_lob_get() cubrid_lob_send() cubrid_lock_read() cubrid_lock_write() cubrid_prepare() cubrid_put() cubrid_rollback() cubrid_schema() cubrid_seq_drop() cubrid_seq_insert() cubrid_seq_put() cubrid_set_add() cubrid_set_autocommit() cubrid_set_db_parameter() cubrid_set_drop() cubrid_affected_rows() cubrid_client_encoding() cubrid_errno() cubrid_error() cubrid_list_dbs() cubrid_ping() cubrid_query() cubrid_real_escape_string() | cubrid_close() cubrid_disconnect() | CUBRID veritabanına bağlantı
kalıcı cubrid bağlantısı | cubrid_pconnect() cubrid_pconnect_with_url() | cubrid_col_get() cubrid_col_size() cubrid_commit() cubrid_drop() cubrid_execute() cubrid_get_autocommit() cubrid_get_charset() cubrid_get_class_name() cubrid_get_db_parameter() cubrid_get_server_info() cubrid_get() cubrid_insert_id() cubrid_is_instance() cubrid_lob_export() cubrid_lob_get() cubrid_lob_send() cubrid_lock_read() cubrid_lock_write() cubrid_prepare() cubrid_put() cubrid_rollback() cubrid_schema() cubrid_seq_drop() cubrid_seq_insert() cubrid_seq_put() cubrid_set_add() cubrid_set_autocommit() cubrid_set_db_parameter() cubrid_set_drop() cubrid_affected_rows() cubrid_client_encoding() cubrid_errno() cubrid_error() cubrid_list_dbs() cubrid_ping() cubrid_query() cubrid_real_escape_string() cubrid_lob2_new() | CUBRID veritabanına kalıcı bağlantı
cubrid isteği | cubrid_prepare() cubrid_execute() cubrid_query() cubrid_unbuffered_query() | cubrid_bind() cubrid_column_names() cubrid_column_types() cubrid_current_oid() cubrid_execute() cubrid_free_result() cubrid_get_query_timeout() cubrid_move_cursor() cubrid_next_result() cubrid_num_cols() cubrid_num_rows() cubrid_set_query_timeout() cubrid_data_seek() cubrid_fetch_array() cubrid_fetch_assoc() cubrid_fetch_field() cubrid_fetch_lengths() cubrid_fetch_object() cubrid_fetch_row() cubrid_field_flags() cubrid_field_len() cubrid_field_name() cubrid_field_seek() cubrid_field_table() cubrid_field_type() cubrid_num_fields() cubrid_result() cubrid_lob2_bind() | cubrid_close_prepare() cubrid_close_request() | CUBRID isteği
cubrid lob | cubrid_lob_get() | cubrid_lob_export() cubrid_lob_send() cubrid_lob_size() | cubrid_lob_close() | None
cubrid lob2 | cubrid_lob2_new() cubrid_fetch() cubrid_fetch_row() cubrid_fetch_array() cubrid_fetch_assoc() cubrid_fetch_object() | cubrid_lob2_export() cubrid_lob2_import() cubrid_lob2_read() cubrid_lob2_write() cubrid_lob2_tell() cubrid_lob2_tell64() cubrid_lob2_seek() cubrid_lob2_seek64() cubrid_lob2_size() cubrid_lob2_size64() | cubrid_lob2_close() | None
curl | curl_copy_handle(), curl_init() | curl_copy_handle(), curl_errno(), curl_error(), curl_exec(), curl_getinfo(), curl_setopt() | curl_close() | Curl oturumu
dbm | dbmopen() | dbmexists(), dbmfetch(), dbminsert(), dbmreplace(), dbmdelete(), dbmfirstkey(), dbmnextkey() | dbmclose() | DBM veritabanına bağlantı
dba | dba_open() | dba_delete(), dba_exists(), dba_fetch(), dba_firstkey(), dba_insert(), dba_nextkey(), dba_optimize(), dba_replace(), dba_sync() | dba_close() | DBA veritabanına bağlantı
dba persistent | dba_popen() | dba_delete(), dba_exists(), dba_fetch(), dba_firstkey(), dba_insert(), dba_nextkey(), dba_optimize(), dba_replace(), dba_sync() | Yok | DBA veritabanına kalıcı bağlantı
dbase | dbase_open() | dbase_pack(), dbase_add_record(), dbase_replace_record(), dbase_delete_record(), dbase_get_record(), dbase_get_record_with_names(), dbase_numfields(), dbase_numrecords() | dbase_close() | Dbase veritabanına bağlantı
dbx_link_object | dbx_connect() | dbx_query() | dbx_close() | dbx bağlantısı
dbx_result_object | dbx_query() | Yok | dbx sonucu
xpath bağlamı
xpath nesnesi
fbsql bağlantısı | fbsql_change_user(), fbsql_connect() | fbsql_autocommit(), fbsql_blob_size(), fbsql_clob_size(), fbsql_commit(), fbsql_change_user(), fbsql_create_blob(), fbsql_create_db(), fbsql_create_clob(), fbsql_data_seek(), fbsql_database_password(), fbsql_database(), fbsql_db_query(), fbsql_db_status(), fbsql_drop_db(), fbsql_errno(), fbsql_error(), fbsql_get_autostart_info(), fbsql_hostname(), fbsql_insert_id(), fbsql_list_dbs(), fbsql_password(), fbsql_read_blob(), fbsql_read_clob(), fbsql_rollback(), fbsql_select_db(), fbsql_set_password(), fbsql_set_transaction(), fbsql_start_db(), fbsql_stop_db(), fbsql_username() | fbsql_close() | fbsql veritabanına bağlantı
fbsql plink | fbsql_change_user(), fbsql_pconnect() | fbsql_autocommit(), fbsql_change_user(), fbsql_create_db(), fbsql_data_seek(), fbsql_db_query(), fbsql_drop_db(), fbsql_select_db(), fbsql_errno(), fbsql_error(), fbsql_insert_id(), fbsql_list_dbs() | Yok | fbsql veritabanına kalıcı bağlantı
fbsql sonucu | fbsql_db_query(), fbsql_list_dbs(), fbsql_query(), fbsql_list_fields(), fbsql_list_tables(), fbsql_tablename() | fbsql_affected_rows(), fbsql_fetch_array(), fbsql_fetch_assoc(), fbsql_fetch_field(), fbsql_fetch_lengths(), fbsql_fetch_object(), fbsql_fetch_row(), fbsql_field_flags(), fbsql_field_name(), fbsql_field_len(), fbsql_field_seek(), fbsql_field_table(), fbsql_field_type(), fbsql_next_result(), fbsql_num_fields(), fbsql_num_rows(), fbsql_result(), fbsql_num_rows() | fbsql_free_result() | fbsql sonucu
fdf | fdf_open() | fdf_create(), fdf_save(), fdf_get_value(), fdf_set_value(), fdf_next_field_name(), fdf_set_ap(), fdf_set_status(), fdf_get_status(), fdf_set_file(), fdf_get_file(), fdf_set_flags(), fdf_set_opt(), fdf_set_submit_form_action(), fdf_set_javascript_action() | fdf_close() | FDF Dosyası
ftp | ftp_connect(), ftp_ssl_connect() | ftp_login(), ftp_pwd(), ftp_cdup(), ftp_chdir(), ftp_mkdir(), ftp_rmdir(), ftp_nlist(), ftp_rawlist(), ftp_systype(), ftp_pasv(), ftp_get(), ftp_fget(), ftp_put(), ftp_fput(), ftp_size(), ftp_mdtm(), ftp_rename(), ftp_delete(), ftp_site(), ftp_alloc(), ftp_chmod(), ftp_exec(), ftp_get_option(), ftp_nb_continue(), ftp_nb_fget(), ftp_nb_fput(), ftp_nb_get(), ftp_nb_put(), ftp_raw(), ftp_set_option() | ftp_close() | FTP akımı
gd | imagecreate(), imagecreatefromgd(), imagecreatefromgd2(), imagecreatefromgd2part(), imagecreatefromgif(), imagecreatefromjpeg(), imagecreatefrompng(), imagecreatefromwbmp(), imagecreatefromstring(), imagecreatefromxbm(), imagecreatefromxpm(), imagecreatetruecolor(), imagerotate() | imagearc(), imagechar(), imagecharup(), imagecolorallocate(), imagecolorat(), imagecolorclosest(), imagecolorexact(), imagecolorresolve(), imagegammacorrect(), imagegammacorrect(), imagecolorset(), imagecolorsforindex(), imagecolorstotal(), imagecolortransparent(), imagecopy(), imagecopyresized(), imagedashedline(), imagefill(), imagefilledpolygon(), imagefilledrectangle(), imagefilltoborder(), imagegif(), imagepng(), imagejpeg(), imagewbmp(), imageinterlace(), imageline(), imagepolygon(), imagepstext(), imagerectangle(), imagerotate(), imagesetpixel(), imagestring(), imagestringup(), imagesx(), imagesy(), imagettftext(), imagefilledarc(), imageellipse(), imagefilledellipse(), imagecolorclosestalpha(), imagecolorexactalpha(), imagecolorresolvealpha(), imagecopymerge(), imagecopymergegray(), imagecopyresampled(), imagetruecolortopalette(), imagesetbrush(), imagesettile(), imagesetthickness(), image2wbmp(), imagealphablending(), imageantialias(), imagecolorallocatealpha(), imagecolorclosesthwb(), imagecolordeallocate(), imagecolormatch(), imagefilter(), imagefttext(), imagegd(), imagegd2(), imageistruecolor(), imagelayereffect(), imagepalettecopy(), imagesavealpha(), imagesetstyle(), imagexbm() | imagedestroy() | GD Resmi
gd yazı tipi | imageloadfont() | imagechar(), imagecharup(), imagefontheight() | Yok | GD için yazı tipi
gd PS kodlaması
gd PS yazı tipi | imagepsloadfont() | imagepstext(), imagepsslantfont(), imagepsextendfont(), imagepsencodefont(), imagepsbbox() | imagepsfreefont() | GD için PS yazı tipi
GMP tamsayı | gmp_init() | gmp_intval(), gmp_strval(), gmp_add(), gmp_sub(), gmp_mul(), gmp_div_q(), gmp_div_r(), gmp_div_qr(), gmp_div(), gmp_mod(), gmp_divexact(), gmp_cmp(), gmp_neg(), gmp_abs(), gmp_sign(), gmp_fact(), gmp_sqrt(), gmp_sqrtrm(), gmp_perfect_square(), gmp_pow(), gmp_powm(), gmp_prob_prime(), gmp_gcd(), gmp_gcdext(), gmp_invert(), gmp_legendre(), gmp_jacobi(), gmp_random(), gmp_and(), gmp_or(), gmp_xor(), gmp_setbit(), gmp_clrbit(), gmp_scan0(), gmp_scan1(), gmp_popcount(), gmp_hamdist() | Yok | GMP Sayı
hyperwave belgesi | hw_cp(), hw_docbyanchor(), hw_getremote(), hw_getremotechildren() | hw_children(), hw_childrenobj(), hw_getparents(), hw_getparentsobj(), hw_getchildcoll(), hw_getchildcollobj(), hw_getremote(), hw_getsrcbydestobj(), hw_getandlock(), hw_gettext(), hw_getobjectbyquerycoll(), hw_getobjectbyquerycollobj(), hw_getchilddoccoll(), hw_getchilddoccollobj(), hw_getanchors(), hw_getanchorsobj(), hw_inscoll(), hw_pipedocument(), hw_unlock() | hw_deleteobject() | Hyperwave nesnesi
hyperwave bağlantısı | hw_connect() | hw_children(), hw_childrenobj(), hw_cp(), hw_deleteobject(), hw_docbyanchor(), hw_docbyanchorobj(), hw_errormsg(), hw_edittext(), hw_error(), hw_getparents(), hw_getparentsobj(), hw_getchildcoll(), hw_getchildcollobj(), hw_getremote(), hw_getremotechildren(), hw_getsrcbydestobj(), hw_getobject(), hw_getandlock(), hw_gettext(), hw_getobjectbyquery(), hw_getobjectbyqueryobj(), hw_getobjectbyquerycoll(), hw_getobjectbyquerycollobj(), hw_getchilddoccoll(), hw_getchilddoccollobj(), hw_getanchors(), hw_getanchorsobj(), hw_mv(), hw_incollections(), hw_info(), hw_inscoll(), hw_insdoc(), hw_insertdocument(), hw_insertobject(), hw_mapid(), hw_modifyobject(), hw_pipedocument(), hw_unlock(), hw_who(), hw_getusername() | hw_close(), hw_free_document() | Hyperwave sunucusuna bağlantı
hyperwave kalıcı bağlantı | hw_pconnect() | hw_children(), hw_childrenobj(), hw_cp(), hw_deleteobject(), hw_docbyanchor(), hw_docbyanchorobj(), hw_errormsg(), hw_edittext(), hw_error(), hw_getparents(), hw_getparentsobj(), hw_getchildcoll(), hw_getchildcollobj(), hw_getremote(), hw_getremotechildren(), hw_getsrcbydestobj(), hw_getobject(), hw_getandlock(), hw_gettext(), hw_getobjectbyquery(), hw_getobjectbyqueryobj(), hw_getobjectbyquerycoll(), hw_getobjectbyquerycollobj(), hw_getchilddoccoll(), hw_getchilddoccollobj(), hw_getanchors(), hw_getanchorsobj(), hw_mv(), hw_incollections(), hw_info(), hw_inscoll(), hw_insdoc(), hw_insertdocument(), hw_insertobject(), hw_mapid(), hw_modifyobject(), hw_pipedocument(), hw_unlock(), hw_who(), hw_getusername() | Yok | Hyperwave sunucusuna kalıcı bağlantı
icap | icap_open() | icap_fetch_event(), icap_list_events(), icap_store_event(), icap_snooze(), icap_list_alarms(), icap_delete_event() | icap_close() | icap sunucusuna bağlantı
imap | imap_open() | imap_append(), imap_body(), imap_check(), imap_createmailbox(), imap_delete(), imap_deletemailbox(), imap_expunge(), imap_fetchbody(), imap_fetchstructure(), imap_headerinfo(), imap_header(), imap_headers(), imap_listmailbox(), imap_getmailboxes(), imap_get_quota(), imap_status(), imap_listsubscribed(), imap_set_quota(), imap_set_quota(), imap_getsubscribed(), imap_mail_copy(), imap_mail_move(), imap_num_msg(), imap_num_recent(), imap_ping(), imap_renamemailbox(), imap_reopen(), imap_subscribe(), imap_undelete(), imap_unsubscribe(), imap_scanmailbox(), imap_mailboxmsginfo(), imap_fetchheader(), imap_uid(), imap_msgno(), imap_search(), imap_fetch_overview() | imap_close() | IMAP, POP3 sunucusuna bağlantı
imap kalıcı zinciri
imap kalıcı
ingres | ingres_connect() | ingres_query(), ingres_num_rows(), ingres_num_fields(), ingres_field_name(), ingres_field_type(), ingres_field_nullable(), ingres_field_length(), ingres_field_precision(), ingres_field_scale(), ingres_fetch_array(), ingres_fetch_row(), ingres_fetch_object(), ingres_rollback(), ingres_commit(), ingres_autocommit() | ingres_close() | ingresII base bağlantısı
ingres kalıcı | ingres_pconnect() | ingres_query(), ingres_num_rows(), ingres_num_fields(), ingres_field_name(), ingres_field_type(), ingres_field_nullable(), ingres_field_length(), ingres_field_precision(), ingres_field_scale(), ingres_fetch_array(), ingres_fetch_row(), ingres_fetch_object(), ingres_rollback(), ingres_commit(), ingres_autocommit() | Yok | ingresII base kalıcı bağlantısı
interbase blob
interbase bağlantısı | ibase_connect() | ibase_query(), ibase_prepare(), ibase_trans() | ibase_close() | Interbase veritabanına bağlantı
interbase veritabanına kalıcı bağlantı | ibase_pconnect() | ibase_query(), ibase_prepare(), ibase_trans() | Yok | Interbase veritabanına kalıcı bağlantı
interbase songusu | ibase_prepare() | ibase_execute() | ibase_free_query() | Interbase query
interbase result | ibase_query() | ibase_fetch_row(), ibase_fetch_object(), ibase_field_info(), ibase_num_fields() | ibase_free_result() | Interbase Result
interbase transaction | ibase_trans() | ibase_commit() | ibase_rollback() | Interbase hareketi
java
ldap bağlantısı | ldap_connect(), ldap_search() | ldap_count_entries(), ldap_first_attribute(), ldap_first_entry(), ldap_get_attributes(), ldap_get_dn(), ldap_get_entries(), ldap_get_values(), ldap_get_values_len(), ldap_next_attribute(), ldap_next_entry() | ldap_close() | ldap bağlantısı
ldap sonucu | ldap_read() | ldap_add(), ldap_compare(), ldap_bind(), ldap_count_entries(), ldap_delete(), ldap_errno(), ldap_error(), ldap_first_attribute(), ldap_first_entry(), ldap_get_attributes(), ldap_get_dn(), ldap_get_entries(), ldap_get_values(), ldap_get_values_len(), ldap_get_option(), ldap_list(), ldap_modify(), ldap_mod_add(), ldap_mod_replace(), ldap_next_attribute(), ldap_next_entry(), ldap_mod_del(), ldap_set_option(), ldap_unbind() | ldap_free_result() | ldap arama sonucu
ldap sonuç girdisi
mcal | mcal_open(), mcal_popen() | mcal_create_calendar(), mcal_rename_calendar(), mcal_rename_calendar(), mcal_delete_calendar(), mcal_fetch_event(), mcal_list_events(), mcal_append_event(), mcal_store_event(), mcal_delete_event(), mcal_list_alarms(), mcal_event_init(), mcal_event_set_category(), mcal_event_set_title(), mcal_event_set_description(), mcal_event_set_start(), mcal_event_set_end(), mcal_event_set_alarm(), mcal_event_set_class(), mcal_next_recurrence(), mcal_event_set_recur_none(), mcal_event_set_recur_daily(), mcal_event_set_recur_weekly(), mcal_event_set_recur_monthly_mday(), mcal_event_set_recur_monthly_wday(), mcal_event_set_recur_yearly(), mcal_fetch_current_stream_event(), mcal_event_add_attribute(), mcal_expunge() | mcal_close() | calendar sunucusuna bağlantı
SWFAction
SWFBitmap
SWFButton
SWFDisplayItem
SWFFill
SWFFont
SWFGradient
SWFMorph
SWFMovie
SWFShape
SWFSprite
SWFText
SWFTextField
mnogosearch aracısı
mnogosearch sonucu
msql bağlantısı | msql_connect() | msql(), msql_create_db(), msql_createdb(), msql_drop_db(), msql_drop_db(), msql_select_db(), msql_select_db() | msql_close() | mSQL veritabanına bağlantı
msql veritabanına kalıcı bağlantı | msql_pconnect() | msql(), msql_create_db(), msql_createdb(), msql_drop_db(), msql_drop_db(), msql_select_db(), msql_select_db() | Yok | mSQL veritabanına kalıcı bağlantı
msql sorgusu | msql_db_query(), msql_list_dbs(), msql_list_fields(), msql_list_tables(), msql_query() | msql(), msql_affected_rows(), msql_data_seek(), msql_dbname(), msql_fetch_array(), msql_fetch_field(), msql_fetch_object(), msql_fetch_row(), msql_field_seek(), msql_field_table(), msql_field_flags(), msql_field_len(), msql_field_name(), msql_field_type(), msql_num_fields(), msql_num_rows(), msql_numfields(), msql_numrows(), msql_result() | msql_free_result(), msql_free_result() | mSQL sonucu
mssql bağlantısı | mssql_connect() | mssql_query(), mssql_select_db() | mssql_close() | Microsoft SQL Server veritabanına bağlantı
mssql veritabanına kalıcı bağlantı | mssql_pconnect() | mssql_query(), mssql_select_db() | Yok | Microsoft SQL Server veritabanına kalıcı bağlantı
mssql sonucu | mssql_query() | mssql_data_seek(), mssql_fetch_array(), mssql_fetch_field(), mssql_fetch_object(), mssql_fetch_row(), mssql_field_length(), mssql_field_name(), mssql_field_seek(), mssql_field_type(), mssql_num_fields(), mssql_num_rows(), mssql_result() | mssql_free_result() | Microsoft SQL Server sonucu
mysql link | mysql_connect() | mysql_affected_rows(), mysql_change_user(), mysql_create_db(), mysql_data_seek(), mysql_db_name(), mysql_db_query(), mysql_drop_db(), mysql_errno(), mysql_error(), mysql_insert_id(), mysql_list_dbs(), mysql_list_fields(), mysql_list_tables(), mysql_query(), mysql_result(), mysql_select_db(), mysql_tablename(), mysql_get_host_info(), mysql_get_proto_info(), mysql_get_server_info() | mysql_close() | MySQL veritabanına bağlantı
mysql veritabanına kalıcı bağlantı | mysql_pconnect() | mysql_affected_rows(), mysql_change_user(), mysql_create_db(), mysql_data_seek(), mysql_db_name(), mysql_db_query(), mysql_drop_db(), mysql_errno(), mysql_error(), mysql_insert_id(), mysql_list_dbs(), mysql_list_fields(), mysql_list_tables(), mysql_query(), mysql_result(), mysql_select_db(), mysql_tablename(), mysql_get_host_info(), mysql_get_proto_info(), mysql_get_server_info() | Yok | MySQL veritabanına kalıcı bağlantı
mysql sonucu | mysql_db_query(), mysql_list_dbs(), mysql_list_fields(), mysql_list_processes(), mysql_list_tables(), mysql_query(), mysql_unbuffered_query() | mysql_data_seek(), mysql_db_name(), mysql_fetch_array(), mysql_fetch_assoc(), mysql_fetch_field(), mysql_fetch_lengths(), mysql_fetch_object(), mysql_fetch_row(), mysql_fetch_row(), mysql_field_flags(), mysql_field_name(), mysql_field_len(), mysql_field_seek(), mysql_field_table(), mysql_field_type(), mysql_num_fields(), mysql_num_rows(), mysql_result(), mysql_tablename() | mysql_free_result() | MySQL sonucu
oci8 demeti | oci_new_collection() | OCI-Collection::append(), OCI-Collection::assign(), OCI-Collection::assignElem(), OCI-Collection::getElem(), OCI-Collection::max(), OCI-Collection::size(), OCI-Collection::trim() | OCI-Collection::free() | Oracle Collection
oci8 bağlantısı | oci_connect(), oci_pconnect(), oci_new_connect() | oci_commit(), oci_error(), oci_new_cursor(), oci_parse(), oci_password_change(), oci_rollback(), oci_server_version(), oci_set_action(), oci_set_client_identifier(), oci_set_client_info(), oci_set_module_name() | oci_close() | Oracle veritabanına bağlantı
oci8 lob | oci_new_descriptor() | OCI-Lob::append(), OCI-Lob::close(), OCI-Lob::eof(), OCI-Lob::erase(), OCI-Lob::export(), OCI-Lob::flush(), OCI-Lob::getBuffering(), OCI-Lob::import(), OCI-Lob::load(), OCI-Lob::read(), OCI-Lob::rewind(), OCI-Lob::save(), OCI-Lob::saveFile(), OCI-Lob::seek(), OCI-Lob::setBuffering(), OCI-Lob::size(), OCI-Lob::tell(), OCI-Lob::truncate(), OCI-Lob::write(), OCI-Lob::writeTemporary(), OCI-Lob::writeToFile(), oci_lob_copy(), oci_lob_is_equal() | OCI-Lob::free() | Oracle büyük nesneler
oci8 deyimi | oci_parse(), oci_new_cursor() | oci_bind_array_by_name(), oci_bind_by_name(), oci_cancel(), oci_define_by_name(), oci_error() oci_execute(), oci_fetch_all(), oci_fetch_array(), oci_fetch_assoc(), oci_fetch_object(), oci_fetch_row(), oci_fetch(), oci_field_is_null(), oci_field_name(), oci_field_precision(), oci_field_scale(), oci_field_size(), oci_field_type_raw(), oci_field_type(), oci_num_fields(), oci_num_rows(), oci_result(), oci_set_prefetch(), oci_statement_type() | oci_free_statement() | Oracle cursor
odbc link | odbc_connect() | odbc_autocommit(), odbc_commit(), odbc_error(), odbc_errormsg(), odbc_exec(), odbc_tables(), odbc_tableprivileges(), odbc_do(), odbc_prepare(), odbc_columns(), odbc_columnprivileges(), odbc_procedurecolumns(), odbc_specialcolumns(), odbc_rollback(), odbc_setoption(), odbc_gettypeinfo(), odbc_primarykeys(), odbc_foreignkeys(), odbc_procedures(), odbc_statistics() | odbc_close() | ODBC veritabanına bağlantı
odbc veritabanına kalıcı bağlantıt | odbc_pconnect() | odbc_autocommit(), odbc_commit(), odbc_error(), odbc_errormsg(), odbc_exec(), odbc_tables(), odbc_tableprivileges(), odbc_do(), odbc_prepare(), odbc_columns(), odbc_columnprivileges(), odbc_procedurecolumns(), odbc_specialcolumns(), odbc_rollback(), odbc_setoption(), odbc_gettypeinfo(), odbc_primarykeys(), odbc_foreignkeys(), odbc_procedures(), odbc_statistics() | Yok | ODBC veritabanına kalıcı bağlantı
odbc sonucu | odbc_prepare() | odbc_binmode(), odbc_cursor(), odbc_execute(), odbc_fetch_into(), odbc_fetch_row(), odbc_field_name(), odbc_field_num(), odbc_field_type(), odbc_field_len(), odbc_field_precision(), odbc_field_scale(), odbc_longreadlen(), odbc_num_fields(), odbc_num_rows(), odbc_result(), odbc_result_all(), odbc_setoption() | odbc_free_result() | ODBC sonucu
birdstep bağlantısı
birdstep sonucu
OpenSSL anahtarı | openssl_get_privatekey(), openssl_get_publickey() | openssl_sign(), openssl_seal(), openssl_open(), openssl_verify() | openssl_free_key() | OpenSSL anahtarı
OpenSSL X.509 | openssl_x509_read() | openssl_x509_parse(), openssl_x509_checkpurpose() | openssl_x509_free() | Genel Anahtar
pdf belgesi | pdf_new() | pdf_add_bookmark(), pdf_add_launchlink(), pdf_add_locallink(), pdf_add_note(), pdf_add_pdflink(), pdf_add_weblink(), pdf_arc(), pdf_attach_file(), pdf_begin_page(), pdf_circle(), pdf_clip(), pdf_closepath(), pdf_closepath_fill_stroke(), pdf_closepath_stroke(), pdf_concat(), pdf_continue_text(), pdf_curveto(), pdf_end_page(), pdf_endpath(), pdf_fill(), pdf_fill_stroke(), pdf_findfont(), pdf_get_buffer(), pdf_get_image_height(), pdf_get_image_width(), pdf_get_parameter(), pdf_get_value(), pdf_lineto(), pdf_moveto(), pdf_open_ccitt(), pdf_open_file(), pdf_open_image_file(), pdf_place_image(), pdf_rect(), pdf_restore(), pdf_rotate(), pdf_save(), pdf_scale(), pdf_setdash(), pdf_setflat(), pdf_setfont(), pdf_setgray(), pdf_setgray_fill(), pdf_setgray_stroke(), pdf_setlinecap(), pdf_setlinejoin(), pdf_setlinewidth(), pdf_setmiterlimit(), pdf_setpolydash(), pdf_setrgbcolor(), pdf_setrgbcolor_fill(), pdf_setrgbcolor_stroke(), pdf_set_border_color(), pdf_set_border_dash(), pdf_set_border_style(), pdf_set_char_spacing(), pdf_set_duration(), pdf_set_font(), pdf_set_horiz_scaling(), pdf_set_parameter(), pdf_set_text_pos(), pdf_set_text_rendering(), pdf_set_value(), pdf_set_word_spacing(), pdf_show(), pdf_show_boxed(), pdf_show_xy(), pdf_skew(), pdf_stringwidth(), pdf_stroke(), pdf_translate(), pdf_add_thumbnail(), pdf_arcn(), pdf_begin_pattern(), pdf_begin_template(), pdf_end_pattern(), pdf_end_template(), pdf_initgraphics(), pdf_makespotcolor(), pdf_set_info(), pdf_setcolor(), pdf_setmatrix(), pdf_open_memory_image() | pdf_close(), pdf_delete() | PDF belgesi
pdf resmi | pdf_open_image(), pdf_open_image_file(), pdf_open_memory_image() | pdf_get_image_height(), pdf_get_image_width(), pdf_open_CCITT(), pdf_place_image() | pdf_close_image() | PDF dosyasında resim
pdf nesnesi
pdf yer imi
pgsql dev nesnesi | pg_lo_open() | pg_lo_open(), pg_lo_create(), pg_lo_read(), pg_lo_read_all(), pg_lo_seek(), pg_lo_tell(), pg_lo_unlink(), pg_lo_write() | pg_lo_close() | PostgreSQL Dev nesnesi
pgsql bağlantısı | pg_connect() | pg_affected_rows(), pg_query(), pg_send_query(), pg_get_result(), pg_connection_busy(), pg_connection_reset(), pg_connection_status(), pg_last_error(), pg_last_notice(), pg_lo_create(), pg_lo_export(), pg_lo_import(), pg_lo_open(), pg_lo_unlink(), pg_host(), pg_port(), pg_dbname(), pg_options(), pg_copy_from(), pg_copy_to(), pg_end_copy(), pg_put_line(), pg_tty(), pg_trace(), pg_untrace(), pg_set_client_encoding(), pg_client_encoding(), pg_metadata(), pg_convert(), pg_insert(), pg_select(), pg_delete(), pg_update() | pg_close() | PostgreSQL veritabanına bağlantı
pgsql veritabanına kalıcı bağlantı | pg_pconnect() | pg_affected_rows(), pg_query(), pg_send_query(), pg_get_result(), pg_connection_busy(), pg_connection_reset(), pg_connection_status(), pg_last_error(), pg_last_notice(), pg_lo_create(), pg_lo_export(), pg_lo_import(), pg_lo_open(), pg_lo_unlink(), pg_host(), pg_port(), pg_dbname(), pg_options(), pg_copy_from(), pg_copy_to(), pg_end_copy(), pg_put_line(), pg_tty(), pg_trace(), pg_untrace(), pg_set_client_encoding(), pg_client_encoding(), pg_metadata(), pg_convert(), pg_insert(), pg_select(), pg_delete(), pg_update() | Yok | PostgreSQL veritabanına kalıcı bağlantı
pgsql sonucu | pg_execute(), pg_query(), pg_query_params(), pg_get_result() | pg_fetch_array(), pg_fetch_object(), pg_fetch_result(), pg_fetch_row(), pg_field_is_null(), pg_field_name(), pg_field_num(), pg_field_prtlen(), pg_field_size(), pg_field_type(), pg_last_oid(), pg_num_fields(), pg_num_rows(), pg_result_error(), pg_result_status() | pg_free_result() | PostgreSQL sonucu
pgsql dizgesi
yazıcı
yazıcı fırçası
yazıcı yazı tipi
yazıcı kalemi
pspell | pspell_new(), pspell_new_config(), pspell_new_personal() | pspell_add_to_personal(), pspell_add_to_session(), pspell_check(), pspell_clear_session(), pspell_config_ignore(), pspell_config_mode(), pspell_config_personal(), pspell_config_repl(), pspell_config_runtogether(), pspell_config_save_repl(), pspell_save_wordlist(), pspell_store_replacement(), pspell_suggest() | Yok | pspell sözlüğü
pspell yapılandırması | pspell_config_create() | pspell_new_config() | Yok | pspell yapılandırması
Sablotron XSLT | xslt_create() | xslt_closelog(), xslt_openlog(), xslt_run(), xslt_set_sax_handler(), xslt_errno(), xslt_error(), xslt_fetch_result(), xslt_free() | xslt_free() | XSLT çözümleyici
shmop | shmop_open() | shmop_read(), shmop_write(), shmop_size(), shmop_delete() | shmop_close()
soket dosya tanıtıcı kümesi | socket() | accept_connect(), bind(), connect(), listen(), read(), write() | close() | Socket
soket g/ç vektörü
akım | opendir() | readdir(), rewinddir() | closedir() | Dizin tanıtıcı
akım | fopen(), tmpfile() | feof(), fflush(), fgetc(), fgetcsv(), fgets(), fgetss(), flock(), fpassthru(), fputs(), fwrite(), fread(), fseek(), ftell(), fstat(), ftruncate(), set_file_buffer(), rewind() | fclose() | Dosya tanıtıcı
akım | popen(), fsockopen(), pfsockopen() | feof(), fflush(), fgetc(), fgetcsv(), fgets(), fgetss(), fpassthru(), fputs(), fwrite(), fread() | pclose() | Süreç kimliği
soket | fflush(), fgetc(), fgetcsv(), fgets(), fgetss(), fpassthru(), fputs(), fwrite(), fread() | fclose() | Soket tanıtıcı
sybase-db bağlantısı | sybase_connect() | sybase_query(), sybase_select_db() | sybase_close() | DB kütüphanesi kullanarak SyBase veritabanına bağlantı
sybase-db veritabanına kalıcı bağlantı | sybase_pconnect() | sybase_query(), sybase_select_db() | Yok | DB kütüphanesi kullanarak SyBase veritabanına kalıcı bağlantı
sybase-db sonucu | sybase_query(), sybase_unbuffered_query() | sybase_data_seek(), sybase_fetch_array(), sybase_fetch_field(), sybase_fetch_object(), sybase_fetch_row(), sybase_field_seek(), sybase_num_fields(), sybase_num_rows(), sybase_result() | sybase_free_result() | DB kütüphanesi kullanarak SyBase sonucu
sybase-ct link | sybase_connect() | sybase_affected_rows(), sybase_query(), sybase_select_db() | sybase_close() | CT kütüphanesi kullanarak SyBase veritabanı bağlantısı
sybase-ct veritabanına kalıcı bağlantı | sybase_pconnect() | sybase_affected_rows(), sybase_query(), sybase_select_db() | Yok | CT kütüphanesi kullanarak SyBase veritabanı kalıcı bağlantısı
sybase-ct sonucu | sybase_query() | sybase_data_seek(), sybase_fetch_array(), sybase_fetch_field(), sybase_fetch_object(), sybase_fetch_row(), sybase_field_seek(), sybase_num_fields(), sybase_num_rows(), sybase_result() | sybase_free_result() | CT kütüphanesi kullanarak SyBase sonucu
sysvsem | sem_get() | sem_acquire() | sem_release() | System V Semaforu
sysvshm | shm_attach() | shm_remove(), shm_put_var(), shm_get_var(), shm_remove_var() | shm_detach() | System V Paylaşımlı Belleği
wddx | wddx_packet_start() | wddx_add_vars() | wddx_packet_end() | WDDX paketi
xml | xml_parser_create(), xml_parser_create_ns() | xml_set_object(), xml_set_element_handler(), xml_set_character_data_handler(), xml_set_processing_instruction_handler(), xml_set_default_handler(), xml_set_unparsed_entity_decl_handler(), xml_set_notation_decl_handler(), xml_set_external_entity_ref_handler(), xml_parse(), xml_get_error_code(), xml_error_string(), xml_get_current_line_number(), xml_get_current_column_number(), xml_get_current_byte_index(), xml_parse_into_struct(), xml_parser_set_option(), xml_parser_get_option() | xml_parser_free() | XML çözümleyici
zlib | gzopen() | gzeof(), gzgetc(), gzgets(), gzgetss(), gzpassthru(), gzputs(), gzread(), gzrewind(), gzseek(), gztell(), gzwrite() | gzclose() | gz-sıkıştırmalı dosya

Diğer yerleşik sözcüklerin listesi
Kullanılabilir Süzgeçlerin Listesi
Ekler


Kullanılabilir Süzgeçlerin Listesi

İçindekiler

  • Dizge Süzgeçleri
  • Dönüşüm Süzgeçleri
  • Sıkıştırma Süzgeçleri
  • Şifreleme Süzgeçleri

Burada, stream_filter_append() işlevi ile kullanmak için birkaç yerleşik akım süzgecinden oluşan bir liste yer almaktadır. Kurulu PHP sürümünüz burada yer alan süzgeçlerden daha fazla (veya daha az) süzgece sahip olabilir.

stream_filter_append() ve stream_filter_prepend() işlevleri arasındaki hafif bakışımsızlık oluşu dikkat çekicidir. Her PHP akımı, veriyi daha verimli bir şekilde işlemek amacıyla dosya sisteminden veya başka kaynaklardan aldığı veri bloklarını saklamak için küçük bir okuma tamponu içerir. Veri, kaynağından akımın dahili tamponuna çekilir çekilmez PHP uygulamasının veriyi okuyup okumayacağına bağlı olarak ekli süzgeçler üzerinden işleme sokulur. Veri okuma tamponundayken bir süzgeç verinin ardına eklendiği anda, veri sanki doğrudan tampondan çekiliyormuş gibi gösterilerek bu süzgeç tarafından işlenmeye başlanır. Bununla birlikte, eğer süzgeç tampondaki verinin ardına değil de önüne eklenirse tampondaki veri süzgeç tarafından işlenmez. Bunun yerine kaynaktan verinin sonraki bloğunun gelmesini bekler.

Kurulu PHP sürümünüzde bulunan süzgeçlerin bir listesini stream_get_filters() işlevi ile alabilirsiniz.

Özkaynak Türlerinin Listesi
Dizge Süzgeçleri
Ekler


Dizge Süzgeçleri

Bu süzgeçlerin her biri tam olarak isminde yazan işlemi yaparlar ve karşılığı olan yerleşik PHP dizge işleme işlevinin davranışını sergilerler. Belli bir süzgeçle ilgili ayrıntılı bilgi edinmek için ilgili işlevin kılavuz sayfasına bakınız.

string.rot13 Bu süzgecin kullanımı, tüm akım verisinin str_rot13() işlevi ile işlenmesine eşdeğerdir.

Örnek 1 - string.rot13 örneği

<?php
$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'string.rot13');
fwrite($fp, "Bu bir denemedir.\n");
/* Çıktısı:  Oh ove qrarzrqve.  */
?>

string.toupper Bu süzgecin kullanımı, tüm akım verisinin strtoupper() işlevi ile işlenmesine eşdeğerdir.

Örnek 2 - string.toupper örneği

<?php
$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'string.toupper');
fwrite($fp, "Bu küçük bir denemedir.\n");
/* Çıktısı:  BU KüçüK BIR DENEMEDIR.   */
?>

string.tolower Bu süzgecin kullanımı, tüm akım verisinin strtolower() işlevi ile işlenmesine eşdeğerdir.

Örnek 3 - string.tolower örneği

<?php
$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'string.tolower');
fwrite($fp, "Bu küçük bir denemedir.\n");
/* Çıktısı:  bu küçük bir denemedir..   */
?>

string.strip_tags (PHP 5.0.0 ve sonrası). Bu süzgecin kullanımı, tüm akım verisinin strip_tags() işlevi ile işlenmesine eşdeğerdir. Değiştirge olarak şu iki biçimden birini kabul eder: Ya strip_tags() işlevinin ikinci değiştirgesindeki gibi bir etiket listesi içeren bir dizi ya da etiket isimlerinden oluşan bir dizi.

Örnek 4 - string.strip_tags örneği

<?php
$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'string.strip_tags', STREAM_FILTER_WRITE, "<b><i><u>");
fwrite($fp, "<b>kalın metin</b> <h1>1. seviyeden bir başlık</h1> haline getirilir\n");
fclose($fp);
/* Çıktısı: <b>kalın metin</b> 1. seviyeden bir başlık haline getirilir */

$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'string.strip_tags', STREAM_FILTER_WRITE, array('b','i','u'));
fwrite($fp, "<b>kalın metin</b> <h1>1. seviyeden bir başlık</h1> haline getirilir\n");
fclose($fp);
/* Çıktısı: <b>kalın metin</b> 1. seviyeden bir başlık haline getirilir */
?>
Kullanılabilir Süzgeçlerin Listesi
Dönüşüm Süzgeçleri
Kullanılabilir Süzgeçlerin Listesi


Dönüşüm Süzgeçleri

string.* süzgeçleri gibi, the convert.* süzgeçleri de isimlerinde yazan eylemleri gerçekleştirirler. Dönüşüm süzgeçleri PHP 5.0.0'da eklenmiştir. Belli bir süzgeçle ilgili ayrıntılı bilgi edinmek için ilgili işlevin kılavuz sayfasına bakınız.

convert.base64-encode ve convert.base64-decode. Bu süzgeçlerin kullanımı, tüm akım verisinin sırasıyla base64_encode() veya base64_decode() işlevi ile işlenmesine eşdeğerdir. convert.base64-encode süzgeci değiştirgelerin bir ilişkisel dizi olarak belirtilmesini destekler. Eğer line-length değiştirgesi verilmişse base64 çıktı, her biri line-length baytlık parçalara bölünür. Eğer line-break-chars değiştirgesi verilmişse çıktının her parçası belirtilen karakterle sınırlanır. Bu değiştirgeler base64_encode() işlevinin chunk_split() ile birlikte kullanımına eşdeğer bir etkiye sebep olur.

Örnek 1 - convert.base64-encode ve convert.base64-decode örneği

<?php
$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'convert.base64-encode');
fwrite($fp, "Bu bir denemedir.\n");
echo "\n";
fclose($fp);
/* Çıktısı:  QnUgYmlyIGRlbmVtZWRpci4K */

$param = array('line-length' => 8, 'line-break-chars' => "\r\n");
$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'convert.base64-encode', STREAM_FILTER_WRITE, $param);
fwrite($fp, "Bu bir denemedir.\n");
echo "\n";
fclose($fp);
/* Çıktısı:   QnUgYmly
          :   IGRlbmVt
          :   ZWRpci4K   */

$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'convert.base64-decode');
fwrite($fp, "QnUgYmlyIGRlbmVtZWRpci4K");
echo "\n";
fclose($fp);
/* Çıktısı:  Bu bir denemedir.  */
?>

convert.quoted-printable-encode ve convert.quoted-printable-decode. Bu süzgeçlerden kod çözme (decode) ile ilgili olanın kullanımı, tüm akım verisinin quoted_printable_decode() işlevi ile işlenmesine eşdeğerdir. convert.quoted-printable-encode işlevine eşdeğer bir süzgeç yoktur. convert.quoted-printable-encode süzgeci değiştirgelerinin bir ilişkisel dizi olarak verilmesini destekler. convert.base64-encode süzgecinin değiştirgelerine ek olarak, binary ve force-encode-first değiştirgelerini de destekler. convert.quoted-printable-encode süzgeci, kodlanmış veriden yararlı yükü ayırmak için bir ipucu olarak sadece line-break-chars değiştirgesini destekler.

Örnek 2 - convert.quoted-printable-encode ve convert.quoted-printable-decode örneği

<?php
$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'convert.quoted-printable-encode');
fwrite($fp, "Bu küçük bir denemedir.\n");
/* Çıktısı:  Bu k=C3=BC=C3=A7=C3=BCk bir denemedir.=0A  */

$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'convert.quoted-printable-decode');
fwrite($fp, "Bu k=C3=BC=C3=A7=C3=BCk bir denemedir.=0A");
/* Çıktısı:  Bu küçük bir denemedir.
*/
?>
Dizge Süzgeçleri
Sıkıştırma Süzgeçleri
Kullanılabilir Süzgeçlerin Listesi


Sıkıştırma Süzgeçleri

Sıkıştırma Sarmalayıcıları yerel dosya sisteminde gzip ve bz2 uyumlu dosyalar oluşturabilmelerine rağmen ne ağ akımlarına sıkıştırma uygulayabilir ne de sıkıştırılmış ağ akımlarının sıkıştırmasını açabilirler. Bunu sağlamak için, akım kaynaklarına herhangi bir anda bir sıkıştırma süzgeci uygulanabilir.

Bilginize: Sıkıştırma süzgeçleri gzip gibi komut satırı uygulamaları tarafından kullanılan dosya baş uç ve ayak uçlarını üretmezler. Sadece sıkıştırılmış veri akımlarının yararlı yükünü sıkıştırıp açarlar.

zlib.deflate (sıkıştırma) ve zlib.inflate (açma) süzgeçleri » RFC 1951'de tanımlanan sıkıştırma yöntemlerini gerçekler. deflate (sıkıştırma) süzgeci, aktarılan üç değiştirgeyi bir ilişkisel dizi olarak kabul eder. level değiştirgesi sıkıştırmanın derecesini (1-9) belirler. Büyük numaralar, küçüklerine göre genelde daha küçük yararlı yük oluşturmasına rağmen daha uzun işlem zamanına gerektirirler. Ayrıca iki özel sıkıştırma seviyesi daha mevcuttur: 0 (hiç sıkıştırma yapılmaz) ve -1 (zlib yerleşik öntanımlısı; şimdilik 6). window değiştirgesinin değeri, sıkıştırma döngüsü pencere genişliğinin 2 tabanına göre logaritmasıdır. Yüksek değerler (yukarda 15'e -- 32768 bayta kadar) daha büyük bellek tüketimi karşılığında daha çok sıkıştırma sağlarken, düşük değerler (aşağıda 9'a -- 512 bayta kadar) daha az bellek tüketimi karşılığında daha az sıkıştırma sağlar. Öntanımlı window genişliği şimdilik 15'tir. memory değiştirgesinin değeri ne kadar bellek ayrılacağını belirleyen bir katsayıdır. Geçerli değerler 1'den (en az bellek ayırma) 9'a (en çok bellek ayırma) kadardır. Bu bellek ayırma işlemi sadece hızı etkiler, üretilen yararlı yükün boyutuna etkisi yoktur.

Bilginize: Sıkıştırma seviyesi en çok kullanılan değiştirge olduğundan bir dizi elemanı olarak belirtilebildiği gibi tek başına basit bir değiştirge olarak da belirtilebilmektedir.

zlib.* sıkıştırma süzgeçleri, zlib desteği etkin olduğu takdirde PHP'nin 5.1.0 sürümünden beri kullanılabilmektedir. Ayrıca, » zlib_filter (» PECL paketinden) kurulu olduğu takdirde 5.0.x sürümlerine de geriye dönük uyarlanabilmektedir.

Örnek 1 - zlib.deflate ve zlib.inflate örneği

<?php
$params = array('level' => 6, 'window' => 15, 'memory' => 9);

$özgün_metin = "Bu bir denemedir.\nBu sadece bir denemedir.\nBu önemli bir dizge değildir.\n";
echo "Özgün metin " . strlen($özgün_metin) . " karakter uzunluktadır.\n";

$fp = fopen('test.deflated', 'w');
stream_filter_append($fp, 'zlib.deflate', STREAM_FILTER_WRITE, $params);
fwrite($fp, $özgün_metin);
fclose($fp);

echo "Sıkıştırılmış dosya ".filesize('test.deflated')." bayt uzunluktadır.\n";
echo "Özgün metin:\n";
/* veriyi bir yere aktarmadan sıkıştırmayı açmak için
   readfile ve zlib.inflate kullanalım  */
readfile('php://filter/zlib.inflate/resource=test.deflated');

/* Üretilen çıktı:

Özgün metin 75 karakter uzunluktadır.
Sıkıştırılmış dosya 57 bayt uzunluktadır.
Özgün metin:
Bu bir denemedir.
Bu sadece bir denemedir.
Bu önemli bir dizge değildir.
 */

?>

Örnek 2 - Basit bir zlib.deflate örneği

<?php
$özgün_metin = "Bu bir denemedir.\nBu sadece bir denemedir.\nBu önemsiz bir dizgedir.\n";
echo "Özgün metin ".strlen($özgün_metin)." karakter uzunluktadır.\n";

$fp = fopen('test.deflated', 'w');
/* Buradaki "6" sıkıştırma seviyesinin 6 olduğunu göstermektedir */
stream_filter_append($fp, 'zlib.deflate', STREAM_FILTER_WRITE, 6);
fwrite($fp, $özgün_metin);
fclose($fp);

echo "Sıkıştırılmış dosya ".filesize('test.deflated')." bayt uzunluktadır.\n";

/* Üretilen çıktı:

Özgün metin 69 karakter uzunluktadır.
Sıkıştırılmış dosya 45 bayt uzunluktadır.

 */
?>

bzip2.compress ve bzip2.decompress süzgeçleri yukarıda açıklanan zlib süzgeçleriyle aynı anlamda çalışırlar. bzip2.compress süzgeci bir ilişkisel dizinin elemanları olarak iki değiştirge kabul eder: blocks değiştirgesi, çalışma alanı için ayrılacak belleğin 100 kbaytlık katları olarak 1'den 9'a kadar bir tamsayıdır. work değiştirgesi de bir tamsayı olup, son çare olarak daha yavaş fakat daha güvenilir bir yönteme başvurmadan önce normal bir sıkıştırma yöntemine ne kadar çaba harcanacağını belirten 0'dan 250'ye kadar bir değerdir. Bu değiştirge sadece hız üzerinde etkilidir. Bu ayardan ne sıkıştırılmış çıktının boyu ne de bellek kullanımı etkilenir. 0 değeri bzip kütüphanesinin yerleşik öntanımlısının kullanılacağı anlamına gelir. bzip2.decompress süzgeci tek bir değiştirge kabul eder. Ya sıradan bir mantıksal değer ya da small anahtarlı tek elemanı olan bir ilişkisel dizidir. small değiştirgesine TRUE değerinin atanması, bzip2 kütüphanesinin sıkıştırmayı açmak için hız pahasına en az belleği ayıracağı anlamına gelir.

bzip2.* sıkıştırma süzgeçleri, bz2 desteği etkin olduğu takdirde PHP'nin 5.1.0 sürümünden beri kullanılabilmektedir. » bz2_filter (» PECL paketindeki) kurulu olduğu takdirde 5.0.x sürümlerinde geriye dönük olarak kullanılabilmektedir.

Örnek 3 - bzip2.compress ve bzip2.decompress örneği

<?php
$param = array('blocks' => 9, 'work' => 0);

echo "Özgün dosya " . filesize('LICENSE') . " bayt uzunluktadır.\n";

$fp = fopen('LICENSE.compressed', 'w');
stream_filter_append($fp, 'bzip2.compress', STREAM_FILTER_WRITE, $param);
fwrite($fp, file_get_contents('LICENSE'));
fclose($fp);

echo "Sıkıştırılmış dosya " . filesize('LICENSE.compressed') . " bayt uzunluktadır.\n";

/* Üretilen çıktı:

Özgün dosya 3288 bayt uzunluktadır.
Sıkıştırılmış dosya 1488 bayt uzunluktadır.

 */
?>
Dönüşüm Süzgeçleri
Şifreleme Süzgeçleri
Kullanılabilir Süzgeçlerin Listesi


Şifreleme Süzgeçleri

mcrypt.* ve mdecrypt.* süzgeçleri libmcrypt kullanarak bakışımlı şifreleme ve şifre çözme yaparlar. Her iki süzgeç ailesi de mcrypt.şifreismi biçeminde mcrypt eklentisinde kullanılan algoritmaları desteklerler; buradaki şifreismi mcrypt_module_open() işlevine aktarıldığı şekliyle şifrenin ismidir. Ayrıca, aşağıdaki beş süzgeç değiştirgesi de kullanılabilmektedir:

mcrypt süzgeç değiştirgeleri
Değiştirge | Gereklilik | Öntanımlı | Örnek değerler
mode | seçimlik | cbc | cbc, cfb, ecb, nofb, ofb, stream
algorithms_dir | seçimlik | ini_get('mcrypt.algorithms_dir') | Algoritma modüllerinin yeri
modes_dir | seçimlik | ini_get('mcrypt.modes_dir') | Kip modüllerinin yeri
iv | gerekli | yok | Genelde 8, 16 veya 32 baytlık ikil veri. Şifreye bağlı.
key | gerekli | yok | Genelde 8, 16 veya 32 baytlık ikil veri. Şifreye bağlı.

Örnek 1 - 3DES kullanarak şifreli dosya çıktılama

<?php
$passphrase = 'Anahtar Parolam';

/* Çoğaltılabilen iv/key çiftine insanlarca
 * okunabilecek bir anahtar parolası yazalım
 */
$iv = substr(md5('iv'.$passphrase, true), 0, 8);
$key = substr(md5('pass1'.$passphrase, true) .
               md5('pass2'.$passphrase, true), 0, 24);
$opts = array('iv'=>$iv, 'key'=>$key);

$fp = fopen('gizli-dosya.enc', 'wb');
stream_filter_append($fp, 'mcrypt.tripledes', STREAM_FILTER_WRITE, $opts);
fwrite($fp, 'Gizli mi gizli gipgizli veri');
fclose($fp);
?>

Örnek 2 - Şifreli dosyanın okunması

<?php
$passphrase = 'Anahtar Parolam';

/* Çoğaltılabilen iv/key çiftine insanlarca
 * okunabilecek bir anahtar parolası yazalım
 */
$iv = substr(md5('iv'.$passphrase, true), 0, 8);
$key = substr(md5('pass1'.$passphrase, true) .
               md5('pass2'.$passphrase, true), 0, 24);
$opts = array('iv'=>$iv, 'key'=>$key);

$fp = fopen('gizli-dosya.enc', 'rb');
stream_filter_append($fp, 'mdecrypt.tripledes', STREAM_FILTER_READ, $opts);
$data = rtrim(stream_get_contents($fp));
fclose($fp);

echo $data;
?>
Sıkıştırma Süzgeçleri
Desteklenen Soket Aktarımlarının Listesi
Kullanılabilir Süzgeçlerin Listesi


Desteklenen Soket Aktarımlarının Listesi

İçindekiler

  • Genel Ağ Alanı: TCP, UDP, SSL ve TLS
  • Unix Alanı: Unix ve UDG

fsockopen() ve stream_socket_client() gibi akım temelli soket işlevlerini kullanmak için PHP'nin yerleşik olarak sahip olduğu URL tarzı soket aktarımları aşağıda liste halinde verilmiştir. Bu aktarımlar Soket Eklentisine uygulanmaz.

Kurulu PHP sürümünüzün desteklediği aktarımları listelemek için stream_get_transports() işlevini kullanabilirsiniz.

Şifreleme Süzgeçleri
Genel Ağ Alanı: TCP, UDP, SSL ve TLS
Ekler


Genel Ağ Alanı: TCP, UDP, SSL ve TLS

PHP 4, PHP 5. ssl:// ve tls:// PHP 4.3.0'dan beri, sslv2:// ve sslv3:// ise PHP 5.0.2'den beri desteklenmektedir.

Bilginize: Hiçbir aktarım belirtilmezse tcp:// öntanımlıdır.

  • 127.0.0.1
  • fe80::1
  • mesela.dom
  • tcp://127.0.0.1
  • tcp://fe80::1
  • tcp://mesela.dom
  • udp://mesela.dom
  • ssl://mesela.dom
  • sslv2://mesela.dom
  • sslv3://mesela.dom
  • tls://mesela.dom

Genel Ağ Alanının soketleri bir hedef adrese ek olara bir port numarası gerektirirler. fsockopen() işlevi için bu ikinci bir değiştirge ile belirtilir, dolayısıyla port numarasının IP adresiyle birlikte bir aktarım URLsi olarak biçimlenmesine gerek kalmaz. stream_socket_client() ve ilgili diğer işlevler için ise geleneksel URL gösterimi kullanılır, yani port numarası aktarım URL'sinin sonuna iki nokta imi ile eklemlenir.

  • tcp://127.0.0.1:80
  • tcp://[fe80::1]:80
  • tcp://mesela.dom:80

Bilginize: Port numaralı IPv6 adresleri
Dikkat ederseniz, yukarıdaki örneklerden ikincisinde IPv6 adresi köşeli ayraçlarını arasına alınmıştır ([fe80::1]). Bunun sebebi IPv6 adresin iki noktalı ayraçlarının, port numarasını eklemleyen iki nokta iminden ayırd edilmesini sağlamaktır.

ssl:// ve tls:// aktarımları (sadece PHP openssl desteği ile derlenmişse vardırlar) tcp:// aktarımının SSL şifrelemeli uzantılarıdır. OpenSSL desteği PHP 4.3.0 sürümünden beri PHP içinde duruk olarak derlenmekte ise de PHP 5.0.0'dan itibaren duruk olarak derlenebildiği gibi modül olarak da derlenebilmektedir.

ssl:// aktarımı, uzak konağın yetenek ve tercihlerine bağlı olarak SSL V2 veya SSL V3 bağlantısı kurmaya çalışacaktır. SSL V2 veya SSL V3 bağlantı istekleri sslv2:// ve sslv3:// biçeminde açıkça belirtilebilir.

Desteklenen Soket Aktarımlarının Listesi
Unix Alanı: Unix ve UDG
Desteklenen Soket Aktarımlarının Listesi


Unix Alanı: Unix ve UDG

unix:// ve (PHP 5'ten beri) udg://.

  • unix:///tmp/mysock
  • udg:///tmp/mysock

unix:// aktarımı Unix alanında bir soket akımı bağlantısına erişim sağlar. udg:// ise aynı sokete UDP protokolü kullanılarak erişim sağlar.

Unix alanı soketleri, Genel Ağ soketlerinin tersine bir port numarası gerektirmezler. Bu durumda fsockopen() işlevinin portnum değiştirgesine 0 atanmalıdır.

Genel Ağ Alanı: TCP, UDP, SSL ve TLS
PHP Tür Karşılaştırma Tabloları
Desteklenen Soket Aktarımlarının Listesi


PHP Tür Karşılaştırma Tabloları

Aşağıdaki tablolarda PHP türlerinin ve karşılaştırma işleçlerinin gevşek ve titiz karşılaştırmalarda davranışları gösterilmiştir. Bu ek bölüm ayrıca Tür Dönüşümü bölümü ile de ilgilidir. Bu tablolar çeşitli kullanıcı yorumlarından ve » BlueShoes sitesindeki çalışmadan esinlenerek oluşturulmuştur.

Bu tabloları kullanmadan önce türleri ve anlamlarını anlamış olmak önemlidir. Örneğin, "42" değeri string türünde iken 42 değeri integer türündedir. FALSE değeri boolean türünde olduğu halde "false" değeri string türündedir.

Bilginize:

HTML Formları tamsayı, gerçek sayı ve mantıksal değerleri aktarmaz; sadece dizgeleri aktarırlar. Bir dizgenin sayısal olup olmadığını öğrenmek için is_numeric() işlevini kullanabilirsiniz.

Bilginize:

$x tanımsızken if ($x) yazılırsa E_NOTICE seviyesinde bir hata üretilir. Bunun olmaması için empty() veya isset() işlevlerini kullanmanız ve/veya değişkenlerinizi ilklendirmeniz gerekir.

Bilginize:

Bazı sayısal işlemler NAN sabiti ile belirtilen bir değer üretebilir. Bu değerin diğer bir değerle (kendisi dahil) sıkı veya gevşek karşılaştırmaları FALSE sonucunu doğuracaktır. (örneğin, NAN != NAN ve NAN !== NAN) NAN üreten işlemlere örnek olarak sqrt(-1), asin(2) ve asinh(0) verilebilir.

$x ile PHP işlevlerinin karşılaştırmaları
İfade | gettype() | empty() | is_null() | isset() | boolean : if($x)
$x = ""; | string | TRUE | FALSE | TRUE | FALSE
$x = null; | NULL | TRUE | TRUE | FALSE | FALSE
var $x; | NULL | TRUE | TRUE | FALSE | FALSE
$x tanımsız | NULL | TRUE | TRUE | FALSE | FALSE
$x = array(); | array | TRUE | FALSE | TRUE | FALSE
$x = false; | boolean | TRUE | FALSE | TRUE | FALSE
$x = true; | boolean | FALSE | FALSE | TRUE | TRUE
$x = 1; | integer | FALSE | FALSE | TRUE | TRUE
$x = 42; | integer | FALSE | FALSE | TRUE | TRUE
$x = 0; | integer | TRUE | FALSE | TRUE | FALSE
$x = -1; | integer | FALSE | FALSE | TRUE | TRUE
$x = "1"; | string | FALSE | FALSE | TRUE | TRUE
$x = "0"; | string | TRUE | FALSE | TRUE | FALSE
$x = "-1"; | string | FALSE | FALSE | TRUE | TRUE
$x = "php"; | string | FALSE | FALSE | TRUE | TRUE
$x = "true"; | string | FALSE | FALSE | TRUE | TRUE
$x = "false"; | string | FALSE | FALSE | TRUE | TRUE

== ile gevşek karşılaştırmalar
 | TRUE | FALSE | 1 | 0 | -1 | "1" | "0" | "-1" | NULL | array() | "php" | ""
TRUE | TRUE | FALSE | TRUE | FALSE | TRUE | TRUE | FALSE | TRUE | FALSE | FALSE | TRUE | FALSE
FALSE | FALSE | TRUE | FALSE | TRUE | FALSE | FALSE | TRUE | FALSE | TRUE | TRUE | FALSE | TRUE
1 | TRUE | FALSE | TRUE | FALSE | FALSE | TRUE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE
0 | FALSE | TRUE | FALSE | TRUE | FALSE | FALSE | TRUE | FALSE | TRUE | FALSE | TRUE | TRUE
-1 | TRUE | FALSE | FALSE | FALSE | TRUE | FALSE | FALSE | TRUE | FALSE | FALSE | FALSE | FALSE
"1" | TRUE | FALSE | TRUE | FALSE | FALSE | TRUE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE
"0" | FALSE | TRUE | FALSE | TRUE | FALSE | FALSE | TRUE | FALSE | FALSE | FALSE | FALSE | FALSE
"-1" | TRUE | FALSE | FALSE | FALSE | TRUE | FALSE | FALSE | TRUE | FALSE | FALSE | FALSE | FALSE
NULL | FALSE | TRUE | FALSE | TRUE | FALSE | FALSE | FALSE | FALSE | TRUE | TRUE | FALSE | TRUE
array() | FALSE | TRUE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | TRUE | TRUE | FALSE | FALSE
"php" | TRUE | FALSE | FALSE | TRUE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | TRUE | FALSE
"" | FALSE | TRUE | FALSE | TRUE | FALSE | FALSE | FALSE | FALSE | TRUE | FALSE | FALSE | TRUE

=== ile titiz karşılaştırmalar
 | TRUE | FALSE | 1 | 0 | -1 | "1" | "0" | "-1" | NULL | array() | "php" | ""
TRUE | TRUE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE
FALSE | FALSE | TRUE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE
1 | FALSE | FALSE | TRUE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE
0 | FALSE | FALSE | FALSE | TRUE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE
-1 | FALSE | FALSE | FALSE | FALSE | TRUE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE
"1" | FALSE | FALSE | FALSE | FALSE | FALSE | TRUE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE
"0" | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | TRUE | FALSE | FALSE | FALSE | FALSE | FALSE
"-1" | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | TRUE | FALSE | FALSE | FALSE | FALSE
NULL | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | TRUE | FALSE | FALSE | FALSE
array() | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | TRUE | FALSE | FALSE
"php" | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | TRUE | FALSE
"" | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | TRUE

Unix Alanı: Unix ve UDG
Çözümleyici Dizgeciklerinin Listesi
Ekler


Çözümleyici Dizgeciklerinin Listesi

PHP dilinin çeşitli parçaları dahili olarak T_SR benzeri türlerle ifade edilir. PHP, çözümleme hatalarında bu gibi betimleyicileri şöyle çıktılar: "Parse error: unexpected T_SR, expecting ',' or ';' in script.php on line 10." (Çözümleme hatası: beklenmedik T_SR, script.php'nin 10. satırında ',' veya ';' umuluyor)

T_SR'nin anlamını bildiğiniz varsayılır. Bilmeyenler için bu betimleyiciler PHP söz dizimi ve kılavuzdaki açıklamalarına bağlarla burada listelenmişlerdir.

Bilginize: T_* sabitlerinin kullanımı

Aşağıda listelenmiş sabitlerin tümü aynı zamanda PHP sabiti olarak da tanımlıdır. Bunların değerleri PHP'nin temel çözümleyici alt yapısına dayalı olarak özdevinimli üretilir. Yani bir dizgeciğin somut değeri iki PHP sürümü arasında değişebilir. Örneğin T_FILE sabitinin değeri PHP 5.3'te 365 iken aynı değer PHP 5.4'te T_TRAIT sabitine atanmışken T_FILE sabitinin değeri 369'dur. Yani kodunuz PHP sürümleri arasında uyumluluk sağlamak için PHP'nin X.Y.Z sürümünden alınmış özgün T_* değerlerine güvenmemelidir. Kodunuz bunun yerine her iki PHP sürümü ile çalışacak uygun bir stratejiden, T_* değerlerinden ve özel değerlerden (10000 gibi büyük bir değer kullanmak) yararlanmalıdır.

Dizgecikler
Dizgecik | Söz dizimi | Gönderim
T_ABSTRACT | abstract | Sınıf Soyutlama (PHP 5.0.0 ve sonrasında mevcuttur).
T_AND_EQUAL | &= | atama işleçleri
T_ARRAY | array() | array(), dizi sözdizimi
T_ARRAY_CAST | (array) | tür çarpıtma
T_AS | as | foreach
T_BAD_CHARACTER |  | \t (0x09), \n (0x0a) ve \r (0x0d) hariç ASCII 32'den küçük karakterler
T_BOOLEAN_AND | && | mantıksal işleçler
T_BOOLEAN_OR | || | mantıksal işleçler
T_BOOL_CAST | (bool) veya (boolean) | tür çarpıtma
T_BREAK | break | break
T_CALLABLE | callable | callable
T_CASE | case | switch
T_CATCH | catch | İstisnalar
T_CHARACTER |  | Artık kullanılmıyor.
T_CLASS | class | sınıflar ve nesneler
T_CLASS_C | __CLASS__ | sihirli sabitler
T_CLONE | clone | sınıflar ve nesneler
T_CLOSE_TAG | ?> veya %> | HTML'den Kaçmak
T_COMMENT | // veya # ve /* */ | açıklamalar
T_CONCAT_EQUAL | .= | atama işleçleri
T_CONST | const | sınıf sabitleri
T_CONSTANT_ENCAPSED_STRING | "foo" veya 'bar' | dizge söz dizimi
T_CONTINUE | continue | continue deyimi
T_CURLY_OPEN | {$ | karmaşık değişken çözümlemeli sözdizimi
T_DEC | -- | Arttırım ve Eksiltim İşleçleri
T_DECLARE | declare | declare
T_DEFAULT | default | switch
T_DIR | __DIR__ | sihirli sabitler (PHP 5.3.0 ve sonrasında mevcuttur).
T_DIV_EQUAL | /= | atama işleçleri
T_DNUMBER | 0.12, vs. | gerçek sayılar
T_DOC_COMMENT | /** */ | PHPDoc tarzı açıklamalar.
T_DO | do | do..while
T_DOLLAR_OPEN_CURLY_BRACES | ${ | Karmaşık (kaşlı ayraçlı) sözdizimi
T_DOUBLE_ARROW | => | dizi söz dizimi
T_DOUBLE_CAST | (real), (double) veya (float) | tür çarpıtma
T_DOUBLE_COLON | :: | Bakınız: T_PAAMAYIM_NEKUDOTAYIM
T_ECHO | echo | echo
T_ELLIPSIS | ... | işlev değiştirgeleri (PHP 5.6.0 ve sonrasında mevcuttur.)
T_ELSE | else | else
T_ELSEIF | elseif | elseif
T_EMPTY | empty | empty()
T_ENCAPSED_AND_WHITESPACE | " $a" | dizge değişkenlerinde sabit kısım
T_ENDDECLARE | enddeclare | declare, denetim yapıları için diğer sözdizimi
T_ENDFOR | endfor | for, denetim yapıları için diğer sözdizimi
T_ENDFOREACH | endforeach | foreach, denetim yapıları için diğer sözdizimi
T_ENDIF | endif | if, denetim yapıları için diğer sözdizimi
T_ENDSWITCH | endswitch | switch, denetim yapıları için diğer sözdizimi
T_ENDWHILE | endwhile | while, denetim yapıları için diğer sözdizimi
T_END_HEREDOC |  | yorumlu metinler
T_EVAL | eval() | eval()
T_EXIT | exit veya die | exit(), die()
T_EXTENDS | extends | extends, sınıflar ve nesneler
T_FILE | __FILE__ | sihirli sabitler
T_FINAL | final | final Anahtar Sözcüğü
T_FINALLY | finally | İstisnalar (PHP 5.5.0 ve sonrasında mevcuttur.)
T_FOR | for | for
T_FOREACH | foreach | foreach
T_FUNCTION | function veya cfunction | işlevler
T_FUNC_C | __FUNCTION__ | sihirli sabitler
T_GLOBAL | global | değişken etki alanı
T_GOTO | goto | goto deyimi (PHP 5.3.0 ve sonrasında mevcuttur).
T_HALT_COMPILER | __halt_compiler() | __halt_compiler (PHP 5.1.0 ve sonrasında mevcuttur).
T_IF | if | if
T_IMPLEMENTS | implements | Nesne Arayüzleri
T_INC | ++ | arttırım ve eksiltim işleçleri
T_INCLUDE | include() | include
T_INCLUDE_ONCE | include_once() | include_once
T_INLINE_HTML |  | PHP dışı metin
T_INSTANCEOF | instanceof | tür işleçleri
T_INSTEADOF | insteadof | Nitelikler (PHP 5.4.0 ve sonrasında mevcuttur)
T_INT_CAST | (int) or (integer) | tür çarpıtma
T_INTERFACE | interface | Nesne Arayüzleri
T_ISSET | isset() | isset()
T_IS_EQUAL | == | karşılaştırma işleçleri
T_IS_GREATER_OR_EQUAL | >= | karşılaştırma işleçleri
T_IS_IDENTICAL | === | karşılaştırma işleçleri
T_IS_NOT_EQUAL | != or <> | karşılaştırma işleçleri
T_IS_NOT_IDENTICAL | !== | karşılaştırma işleçleri
T_IS_SMALLER_OR_EQUAL | <= | karşılaştırma işleçleri
T_SPACESHIP | <=> | karşılaştırma işleçleri (PHP 7.0.0 ve sonrasında mevcuttur.)
T_LINE | __LINE__ | sihirli sabitler
T_LIST | list() | list()
T_LNUMBER | 123, 012, 0x1ac, vs. | tamsayılar
T_LOGICAL_AND | and | mantıksal işleçler
T_LOGICAL_OR | or | mantıksal işleçler
T_LOGICAL_XOR | xor | mantıksal işleçler
T_METHOD_C | __METHOD__ | sihirli sabitler
T_MINUS_EQUAL | -= | atama işleçleri
T_MOD_EQUAL | %= | atama işleçleri
T_MUL_EQUAL | *= | atama işleçleri
T_NAMESPACE | namespace | isim alanları (PHP 5.3.0 ve sonrasında mevcuttur.)
T_NS_C | >__NAMESPACE__ | isim alanları. (PHP 5.3.0 ve sonrasında mevcuttur).
T_NS_SEPARATOR | \ | isim alanları (PHP 5.3.0 ve sonrasında mevcuttur.)
T_NEW | new | sınıflar ve nesneler
T_NUM_STRING | "$a[0]" | dizge içinde sayısal dizi indisi
T_OBJECT_CAST | (object) | tür çarpıtma
T_OBJECT_OPERATOR | -> | sınıflar ve nesneler
T_OPEN_TAG | <?php, <? veya <% | HTML'den Kaçmak
T_OPEN_TAG_WITH_ECHO | <?= veya <%= | HTML'den Kaçmak
T_OR_EQUAL | |= | atama işleçleri
T_PAAMAYIM_NEKUDOTAYIM | :: | ::. Ayrıca, T_DOUBLE_COLON olarak tanımlıdır.
T_PLUS_EQUAL | += | atama işleçleri
T_POW | ** | aritmetik işleçleri (PHP 5.6.0 ve sonrasında mevcuttur.)
T_POW_EQUAL | **= | atama işleçleri (PHP 5.6.0 ve sonrasında mevcuttur.)
T_PRINT | print() | print
T_PRIVATE | private | sınıflar ve nesneler
T_PUBLIC | public | sınıflar ve nesneler
T_PROTECTED | protected | sınıflar ve nesneler
T_REQUIRE | require() | require
T_REQUIRE_ONCE | require_once() | require_once
T_RETURN | return | dönüş değerleri
T_SL | << | bitsel işleçler
T_SL_EQUAL | <<= | atama işleçleri
T_SR | >> | bitsel işleçler
T_SR_EQUAL | >>= | atama işleçleri
T_START_HEREDOC | <<< | yorumlu metinler
T_STATIC | static | değişken etki alanı
T_STRING | parent, self, vs. | parent ve self gibi anahtar sözcükler, işlev isimleri ve sınıf isimleri gibi belirteçlerle eşleşir. Ayrıca bakınız: T_CONSTANT_ENCAPSED_STRING.
T_STRING_CAST | (string) | tür çarpıtma
T_STRING_VARNAME | "${a | karmaşık değişken çözümlemeli sözdizimi
T_SWITCH | switch | switch
T_THROW | Throw | İstisnalar
T_TRY | Try | İstisnalar
T_UNSET | unset() | unset()
T_UNSET_CAST | (unset) | tür çarpıtma
T_USE | use | isim alanları (PHP 5.3.0 ve sonrasında mevcuttur).
T_VAR | var | sınıflar ve nesneler
T_VARIABLE | $foo | değişkenler
T_WHILE | while | while, do..while
T_WHITESPACE | \t \r\n |
T_XOR_EQUAL | ^= | atama işleçleri
T_YIELD | yield | üreteçler (PHP 5.5.0 ve sonrasında mevcuttur).

Ayrıca bakınız: token_name().

PHP Tür Karşılaştırma Tabloları
Kullanıcı Alanı İsimlendirme Kılavuzu
Ekler


Kullanıcı Alanı İsimlendirme Kılavuzu

İçindekiler

  • Küresel İsim alanı
  • Kurallar
  • İpuçları

Bu belge, PHP kullanıcısı tarafından betimleyicilerin en iyi nasıl seçilebileceğini açıklayan bir kılavuzdur. Bir kodun küresel isim alanını oluşturan isimler seçilirken, bunların gelecekteki PHP sürümlerinde kullanılması olası isimlerle çakışmayacak şekilde seçilmesi için aşağıdaki açıklamaları hesaba katmak önem kazanmaktadır.

Çözümleyici Dizgeciklerinin Listesi
Küresel İsim alanı
Ekler


Küresel İsim alanı

Küresel isim alanında kullanılabilecek oluşumlar:

  • işlevler

  • sınıflar

  • arayüzler

  • sabitler (sınıf sabitleri hariç)

  • işlev/yöntemlerin dışında tanımlanmış değişkenler

Kullanıcı Alanı İsimlendirme Kılavuzu
Kurallar
Kullanıcı Alanı İsimlendirme Kılavuzu


Kurallar

Aşağıdaki listede, PHP'nin yeni yerleşik betimleyicileri için isim seçerken projeye tanıdığı haklar belirtilmiştir. Bu liste resmi kodlama standartlarından (» CODING STANDARDS) alıntıdır:

  • PHP tepe seviye isim alanını kendine ayırmış olsa da açıkça uyumsuz olmaktan kaçınılmaya ve titiz bir şekilde daha açıklayıcı isimler bulunmaya çalışılır.

  • İşlev isimlerinde sözcükler arasında altçizgi imleri kullanılırken sınıf isimlerinde hörgüçlü ve Pascal yazım tarzlarının ikisi de kullanılır.

  • PHP, eklentilerin küresel betimleyicilerinin önüne ekenti isimlerini getirir (geçmişten kalma bazı istisnalar vardır). Örnekler:

    • curl_close()

    • mysql_query()

    • PREG_SPLIT_DELIM_CAPTURE

    • new DOMDocument()

    • strpos() (geçmişte yapılan bir yanlışlık)

    • new SplFileObject()

  • Yineleyicilerin ve istisnaların betimleyicilerinin ardına "Iterator" ve "Exception" getirilir. Örnekler:

    • ArrayIterator

    • LogicException

  • PHP, __ ile başlayan tüm betimleyicileri kendine ayırmıştır. Belgelenmiş sihirli işlevselliği kullanmak dışında __ ile başlayan betimleyiciler kullanmamanızı öneririz. Örnekler:

    • __get()

    • __autoload()

Küresel İsim alanı
İpuçları
Kullanıcı Alanı İsimlendirme Kılavuzu


İpuçları

İleriye yönelik güçlü kodlar yazmak istiyorsanız, küresel alana yerleştireceğiniz bütün isimlere alt çizgi imi aracılığıyla uygun bir önek veya sonek koymanızı öneririz. Diğer projelerin isim alanları ile çakışmalardan kaçınmak için bu projelerde kullanılan önek ve sonekler için bir araştırma yapmanızı ve seçtiğiniz öneki veya soneki ilan etmenizi öneririz. Örnekler

  • MyPx_someFunc()

  • Foo_Date

  • $asdf_dbh

Kurallar
About the manual
Kullanıcı Alanı İsimlendirme Kılavuzu


About the manual

İçindekiler

  • Formats
  • About user notes
  • How to read a function definition (prototype)
  • PHP versions documented in this manual
  • How to find more information about PHP
  • How to help improve the documentation
  • How we generate the formats
  • Translations
İpuçları
Formats
Ekler


Formats

The PHP manual is provided in several formats. These formats can be divided into two groups: online readable formats, and downloadable packages.

Bilginize:

Some publishers have made available printed versions of this manual. We cannot recommend any of those, as they tend to become out-of-date very quickly.

The manual can be read online at the » PHP.net website, and on the numerous mirror sites. For best performance, choose the closest mirror. The online version of the PHP manual has currently two CSS stylesheets, web friendly and a printer-friendly stylesheet.

Two notable advantages of the online manual over most of the offline formats is the integration of user-contributed notes and the » URL shortcuts that may be used to get to the desired manual parts quickly. An obvious disadvantage is the requirement to be online to view this edition of the manual.

There are several offline formats of the manual, and the most appropriate format for depends on the operating system, and personal reading style. For information on how the manual is generated in so many formats, read the 'How we generate the formats' section of this appendix.

The most cross-platform format of the manual is the HTML version. This is provided both as a single HTML file and as a package of individual files for each section (which results in a collection of several thousand files). We provide these versions compressed, so a decompression utility is required to retrieve the files contained within the archives.

For Windows platforms, the Windows HTML Help version of the manual enhances the HTML format for use with the Windows HTML Help application. This version provides full-text search, a full index, and bookmarking. Many popular Windows PHP development environments also integrate with this version of the documentation to provide easy access. CHM viewers for Linux desktops are also available. Check out » xCHM or » GnoCHM.

There is also an » extended CHM version available, which is updated less frequently, but provides many additional features. It will only work on Microsoft Windows though, because of the technologies used to build the help pages.

About the manual
About user notes
About the manual


About user notes

The user-contributed notes play an important role in the development of this manual. By allowing readers of the manual to contribute examples, caveats, and further clarifications from their browser, we are able to incorporate that feedback into the main text of the manual. And until the notes have been incorporated, they may be viewed in their submitted form online, and in some of the offline formats.

Bilginize:

The user-contributed notes are not moderated before they appear online, so the quality of the writing or code examples, and even the veracity of the contribution, cannot be guaranteed. (Not that there is any guarantee of the quality or accuracy of the manual text itself.)

Bilginize:

For the purposes of license coverage the user-contributed notes are considered part of the PHP manual, and are therefore covered by the same license that covers this documentation (Creative Commons Attribution at the moment). For more details see the Manual's Copyright page.

Formats
How to read a function definition (prototype)
About the manual


How to read a function definition (prototype)

Each function in the manual is documented for quick reference. Knowing how to read and understand the text will make learning PHP much easier. Rather than relying on examples or cut/paste, everyone should know how to read function definitions (prototypes). Let's begin:

Bilginize: Prerequisite: Basic understanding of types

Although PHP is a loosely typed language, it's important to have a basic understanding of types as they have important meaning.

Function definitions tell us what type of value is returned. Let's use the definition for strlen() as our first example:

strlen

(PHP 4, PHP 5)
strlen -- Get string length

Description
int strlen ( string $string )

Returns the length of given string.

Explanation of a function definition
Part | Description
strlen | The function name.
(PHP 4, PHP 5) | strlen() has been around in all versions of PHP 4 and PHP 5
int | Type of value this function returns, which is an integer (i.e. the length of a string is measured in numbers).
( string $string ) | The first (and in this case the only) parameter/argument for this function is named string, and it's a string.

We could rewrite the above function definition in a generic way:

      returned type    function name    ( parameter type   parameter name )

Many functions take on multiple parameters, such as in_array(). Its prototype is as follows:

      bool in_array ( mixed $needle, array $haystack [, bool $strict = FALSE ] )

What does this mean? in_array() returns a boolean value, TRUE on success (if the needle was found in the haystack) başarısızlık durumunda FALSE döner (if the needle was not found in the haystack). The first parameter is named needle and it can be of many different types, so we call it "mixed". This mixed needle (what we're looking for) can be either a scalar value (string, integer, or float), or an array. haystack (the array we're searching in) is the second parameter. The third optional parameter is named strict. All optional parameters are seen in [ brackets ]. The manual states that the strict parameter defaults to boolean FALSE. See the manual page on each function for details on how they work.

In addition the & (ampersand) symbol prepended to a function parameter allows the parameter to be passed by reference, as seen below:

       int preg_match ( string $pattern , string $subject [, array &$matches
      [, int $flags = 0 [, int $offset = 0 ]]] )

In this example, we can see the third optional parameter &$matches will be passed as reference.

There are also functions with more complex PHP version information. Take html_entity_decode() as an example:

(PHP 4 >= 4.3.0, PHP 5)

This means that this function has only been available in a released version since PHP 4.3.0.

About user notes
PHP versions documented in this manual
About the manual


PHP versions documented in this manual

The manual contains information about past, current, and future versions of PHP. Changes in behaviour are documented as notes, changelogs, and inline text within the manual pages. The earliest documented version is PHP 5.0.0.

When documentation exists for the latest (unreleased) developmental versions of PHP, it will be labeled as either "available in Git" or "development version." And while these changes should be planned for, in rare cases they may change.

All development takes place in Git and may be checked out as described within the » anonymous Git access page.

And to clarify, the manual will refer to major, minor and point PHP releases. Using PHP 5.3.1 as an example, the 5 refers to the major version, 3 to minor, and 1 is the point release. Typically PHP only adds new features to major and minor releases, and fixes bugs in point releases. However, this convention is not always true.

Also note that the PHP manual is written in present tense, not future tense, even for documented features that are not yet available. The reason for this is so the manual can stand the test of time, thus not require tedious grammar updates with every PHP release.

Many times the PHP manual lists "Default Values" for PHP directives. These values are based on how PHP behaves without a php.ini configuration file, so this may differ from values found in the distributed php.ini-development and php.ini-production files. They also refer to the latest version of PHP, although changelog entries do mention past values. See the PHP directive appendix for details regarding these values and changes.

How to read a function definition (prototype)
How to find more information about PHP
About the manual


How to find more information about PHP

This manual does not attempt to provide instruction about general programming practices. First-time - or even just beginning - programmers may find it difficult to learn how to program in PHP using this manual exclusively. Instead, seek out a text more oriented towards beginners.

There are a number of active mailing lists for discussion on all aspects of programming with PHP. If stuck with a problem, consider using these lists. For support options, including mailing lists, view » the PHP.net support page.

PHP versions documented in this manual
How to help improve the documentation
About the manual


How to help improve the documentation

There are three ways everyone can help improve this documentation.

If an error is found in this manual, in any language, please report them using the bug system at » http://bugs.php.net/. Classify the bug as "Documentation Problem". All documentation related problems, including those about manual formats, should be submitted as bug reports.

Bilginize:

Please don't abuse the bug system by submitting requests for help. Instead, use one of the many » support options.

By contributing notes, users may provide additional examples, caveats, and clarifications for other readers. But please do not submit bug reports using the annotation system. For details, see the section titled 'About user notes'.

The PHP manual is translated into many languages. Knowing English and a foreign language allows for another way to help improve the PHP manual by working with a translation team. For information about starting a new translation, or helping a currently translated version, please read » http://doc.php.net/tutorial/.

The PHP Documentation Project also has an IRC channel where many manual authors hang out. Stop by #php.doc on irc.efnet.org and discuss ways to improve the PHP documentation.

How to find more information about PHP
How we generate the formats
About the manual


How we generate the formats

This manual is written in XML using the » DocBook XML DTD, using » PhD (The [PH]P based [D]ocBook renderer) for maintenance and formatting.

Using XML as a source format gives the ability to generate many output formats from the source files, while only maintaining one source document for all formats. The tool used for formatting the online manual is » PhD. We use » Microsoft HTML Help Workshop to generate the Windows HTML Help format of the manual, and of course PHP itself to do some additional conversions and formatting.

The PHP manual is generated in various languages and formats, see » http://www.php.net/docs.php for additional details. The XML source code may be downloaded from SVN and viewed at » http://svn.php.net/viewvc/. The documentation is stored in the phpdoc module.

How to help improve the documentation
Translations
About the manual


Translations

The PHP manual is available not only in various formats, but also in various languages. The text of the manual is first written in English, then teams of people across the world take care of translating it to their native languages. If a translation for a specified function or chapter has not yet been made, the manual's build system falls back to the English version of it.

People involved in the translations start from the XML source code available from » http://svn.php.net/viewvc/ and from it they translate to their mother language. They do not use the generated versions (like HTML or plain text) as it's the build system that takes care of the conversions from XML to human readable formats.

Bilginize:

To help translate the documentation, please get in touch with the translation/documentation team by subscribing to the phpdoc mailing list: send an empty mail to » phpdoc-subscribe@lists.php.net. The mailing list address is phpdoc@lists.php.net. State in the message an interest in translating the manual and someone will reply with feedback on moving forward by helping start a new language translation, or by contacting the existing team for the desired language.

At the moment the manual is available, partly or not, in over 10 languages.

They may all be downloaded here: » http://www.php.net/docs.php.

How we generate the formats
Creative Commons Attribution 3.0
About the manual


Creative Commons Attribution 3.0

THE WORK (AS DEFINED BELOW) IS PROVIDED UNDER THE TERMS OF THIS CREATIVE COMMONS PUBLIC LICENSE ("CCPL" OR "LICENSE"). THE WORK IS PROTECTED BY COPYRIGHT AND/OR OTHER APPLICABLE LAW. ANY USE OF THE WORK OTHER THAN AS AUTHORIZED UNDER THIS LICENSE OR COPYRIGHT LAW IS PROHIBITED.

BY EXERCISING ANY RIGHTS TO THE WORK PROVIDED HERE, YOU ACCEPT AND AGREE TO BE BOUND BY THE TERMS OF THIS LICENSE. TO THE EXTENT THIS LICENSE MAY BE CONSIDERED TO BE A CONTRACT, THE LICENSOR GRANTS YOU THE RIGHTS CONTAINED HERE IN CONSIDERATION OF YOUR ACCEPTANCE OF SUCH TERMS AND CONDITIONS.

1. Definitions

  1. "Adaptation" means a work based upon the Work, or upon the Work and other pre-existing works, such as a translation, adaptation, derivative work, arrangement of music or other alterations of a literary or artistic work, or phonogram or performance and includes cinematographic adaptations or any other form in which the Work may be recast, transformed, or adapted including in any form recognizably derived from the original, except that a work that constitutes a Collection will not be considered an Adaptation for the purpose of this License. For the avoidance of doubt, where the Work is a musical work, performance or phonogram, the synchronization of the Work in timed-relation with a moving image ("synching") will be considered an Adaptation for the purpose of this License.
  2. "Collection" means a collection of literary or artistic works, such as encyclopedias and anthologies, or performances, phonograms or broadcasts, or other works or subject matter other than works listed in Section 1(f) below, which, by reason of the selection and arrangement of their contents, constitute intellectual creations, in which the Work is included in its entirety in unmodified form along with one or more other contributions, each constituting separate and independent works in themselves, which together are assembled into a collective whole. A work that constitutes a Collection will not be considered an Adaptation (as defined above) for the purposes of this License.
  3. "Distribute" means to make available to the public the original and copies of the Work or Adaptation, as appropriate, through sale or other transfer of ownership.
  4. "Licensor" means the individual, individuals, entity or entities that offer(s) the Work under the terms of this License.
  5. "Work" means the literary and/or artistic work offered under the terms of this License including without limitation any production in the literary, scientific and artistic domain, whatever may be the mode or form of its expression including digital form, such as a book, pamphlet and other writing; a lecture, address, sermon or other work of the same nature; a dramatic or dramatico-musical work; a choreographic work or entertainment in dumb show; a musical composition with or without words; a cinematographic work to which are assimilated works expressed by a process analogous to cinematography; a work of drawing, painting, architecture, sculpture, engraving or lithography; a photographic work to which are assimilated works expressed by a process analogous to photography; a work of applied art; an illustration, map, plan, sketch or three-dimensional work relative to geography, topography, architecture or science; a performance; a broadcast; a phonogram; a compilation of data to the extent it is protected as a copyrightable work; or a work performed by a variety or circus performer to the extent it is not otherwise considered a literary or artistic work.
  6. "You" means an individual or entity exercising rights under this License who has not previously violated the terms of this License with respect to the Work, or who has received express permission from the Licensor to exercise rights under this License despite a previous violation.
  7. "Publicly Perform" means to perform public recitations of the Work and to communicate to the public those public recitations, by any means or process, including by wire or wireless means or public digital performances; to make available to the public Works in such a way that members of the public may access these Works from a place and at a place individually chosen by them; to perform the Work to the public by any means or process and the communication to the public of the performances of the Work, including by public digital performance; to broadcast and rebroadcast the Work by any means including signs, sounds or images.
  8. "Reproduce" means to make copies of the Work by any means including without limitation by sound or visual recordings and the right of fixation and reproducing fixations of the Work, including storage of a protected performance or phonogram in digital form or other electronic medium.

2. Fair Dealing Rights. Nothing in this License is intended to reduce, limit, or restrict any uses free from copyright or rights arising from limitations or exceptions that are provided for in connection with the copyright protection under copyright law or other applicable laws.

3. License Grant. Subject to the terms and conditions of this License, Licensor hereby grants You a worldwide, royalty-free, non-exclusive, perpetual (for the duration of the applicable copyright) license to exercise the rights in the Work as stated below:

  1. to Reproduce the Work, to incorporate the Work into one or more Collections, and to Reproduce the Work as incorporated in the Collections;
  2. to create and Reproduce Adaptations provided that any such Adaptation, including any translation in any medium, takes reasonable steps to clearly label, demarcate or otherwise identify that changes were made to the original Work. For example, a translation could be marked "The original work was translated from English to Spanish," or a modification could indicate "The original work has been modified.";
  3. to Distribute and Publicly Perform the Work including as incorporated in Collections; and,
  4. to Distribute and Publicly Perform Adaptations.

  5. For the avoidance of doubt:

    1. Non-waivable Compulsory License Schemes. In those jurisdictions in which the right to collect royalties through any statutory or compulsory licensing scheme cannot be waived, the Licensor reserves the exclusive right to collect such royalties for any exercise by You of the rights granted under this License;
    2. Waivable Compulsory License Schemes. In those jurisdictions in which the right to collect royalties through any statutory or compulsory licensing scheme can be waived, the Licensor waives the exclusive right to collect such royalties for any exercise by You of the rights granted under this License; and,
    3. Voluntary License Schemes. The Licensor waives the right to collect royalties, whether individually or, in the event that the Licensor is a member of a collecting society that administers voluntary licensing schemes, via that society, from any exercise by You of the rights granted under this License.

The above rights may be exercised in all media and formats whether now known or hereafter devised. The above rights include the right to make such modifications as are technically necessary to exercise the rights in other media and formats. Subject to Section 8(f), all rights not expressly granted by Licensor are hereby reserved.

4. Restrictions. The license granted in Section 3 above is expressly made subject to and limited by the following restrictions:

  1. You may Distribute or Publicly Perform the Work only under the terms of this License. You must include a copy of, or the Uniform Resource Identifier (URI) for, this License with every copy of the Work You Distribute or Publicly Perform. You may not offer or impose any terms on the Work that restrict the terms of this License or the ability of the recipient of the Work to exercise the rights granted to that recipient under the terms of the License. You may not sublicense the Work. You must keep intact all notices that refer to this License and to the disclaimer of warranties with every copy of the Work You Distribute or Publicly Perform. When You Distribute or Publicly Perform the Work, You may not impose any effective technological measures on the Work that restrict the ability of a recipient of the Work from You to exercise the rights granted to that recipient under the terms of the License. This Section 4(a) applies to the Work as incorporated in a Collection, but this does not require the Collection apart from the Work itself to be made subject to the terms of this License. If You create a Collection, upon notice from any Licensor You must, to the extent practicable, remove from the Collection any credit as required by Section 4(b), as requested. If You create an Adaptation, upon notice from any Licensor You must, to the extent practicable, remove from the Adaptation any credit as required by Section 4(b), as requested.
  2. If You Distribute, or Publicly Perform the Work or any Adaptations or Collections, You must, unless a request has been made pursuant to Section 4(a), keep intact all copyright notices for the Work and provide, reasonable to the medium or means You are utilizing: (i) the name of the Original Author (or pseudonym, if applicable) if supplied, and/or if the Original Author and/or Licensor designate another party or parties (e.g., a sponsor institute, publishing entity, journal) for attribution ("Attribution Parties") in Licensor's copyright notice, terms of service or by other reasonable means, the name of such party or parties; (ii) the title of the Work if supplied; (iii) to the extent reasonably practicable, the URI, if any, that Licensor specifies to be associated with the Work, unless such URI does not refer to the copyright notice or licensing information for the Work; and (iv) , consistent with Section 3(b), in the case of an Adaptation, a credit identifying the use of the Work in the Adaptation (e.g., "French translation of the Work by Original Author," or "Screenplay based on original Work by Original Author"). The credit required by this Section 4 (b) may be implemented in any reasonable manner; provided, however, that in the case of a Adaptation or Collection, at a minimum such credit will appear, if a credit for all contributing authors of the Adaptation or Collection appears, then as part of these credits and in a manner at least as prominent as the credits for the other contributing authors. For the avoidance of doubt, You may only use the credit required by this Section for the purpose of attribution in the manner set out above and, by exercising Your rights under this License, You may not implicitly or explicitly assert or imply any connection with, sponsorship or endorsement by the Original Author, Licensor and/or Attribution Parties, as appropriate, of You or Your use of the Work, without the separate, express prior written permission of the Original Author, Licensor and/or Attribution Parties.
  3. Except as otherwise agreed in writing by the Licensor or as may be otherwise permitted by applicable law, if You Reproduce, Distribute or Publicly Perform the Work either by itself or as part of any Adaptations or Collections, You must not distort, mutilate, modify or take other derogatory action in relation to the Work which would be prejudicial to the Original Author's honor or reputation. Licensor agrees that in those jurisdictions (e.g. Japan), in which any exercise of the right granted in Section 3(b) of this License (the right to make Adaptations) would be deemed to be a distortion, mutilation, modification or other derogatory action prejudicial to the Original Author's honor and reputation, the Licensor will waive or not assert, as appropriate, this Section, to the fullest extent permitted by the applicable national law, to enable You to reasonably exercise Your right under Section 3(b) of this License (right to make Adaptations) but not otherwise.

5. Representations, Warranties and Disclaimer

UNLESS OTHERWISE MUTUALLY AGREED TO BY THE PARTIES IN WRITING, LICENSOR OFFERS THE WORK AS-IS AND MAKES NO REPRESENTATIONS OR WARRANTIES OF ANY KIND CONCERNING THE WORK, EXPRESS, IMPLIED, STATUTORY OR OTHERWISE, INCLUDING, WITHOUT LIMITATION, WARRANTIES OF TITLE, MERCHANTIBILITY, FITNESS FOR A PARTICULAR PURPOSE, NONINFRINGEMENT, OR THE ABSENCE OF LATENT OR OTHER DEFECTS, ACCURACY, OR THE PRESENCE OF ABSENCE OF ERRORS, WHETHER OR NOT DISCOVERABLE. SOME JURISDICTIONS DO NOT ALLOW THE EXCLUSION OF IMPLIED WARRANTIES, SO SUCH EXCLUSION MAY NOT APPLY TO YOU.

6. Limitation on Liability. EXCEPT TO THE EXTENT REQUIRED BY APPLICABLE LAW, IN NO EVENT WILL LICENSOR BE LIABLE TO YOU ON ANY LEGAL THEORY FOR ANY SPECIAL, INCIDENTAL, CONSEQUENTIAL, PUNITIVE OR EXEMPLARY DAMAGES ARISING OUT OF THIS LICENSE OR THE USE OF THE WORK, EVEN IF LICENSOR HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

7. Termination.

  1. This License and the rights granted hereunder will terminate automatically upon any breach by You of the terms of this License. Individuals or entities who have received Adaptations or Collections from You under this License, however, will not have their licenses terminated provided such individuals or entities remain in full compliance with those licenses. Sections 1, 2, 5, 6, 7, and 8 will survive any termination of this License.
  2. Subject to the above terms and conditions, the license granted here is perpetual (for the duration of the applicable copyright in the Work). Notwithstanding the above, Licensor reserves the right to release the Work under different license terms or to stop distributing the Work at any time; provided, however that any such election will not serve to withdraw this License (or any other license that has been, or is required to be, granted under the terms of this License), and this License will continue in full force and effect unless terminated as stated above.

8. Miscellaneous

  1. Each time You Distribute or Publicly Perform the Work or a Collection, the Licensor offers to the recipient a license to the Work on the same terms and conditions as the license granted to You under this License.
  2. Each time You Distribute or Publicly Perform an Adaptation, Licensor offers to the recipient a license to the original Work on the same terms and conditions as the license granted to You under this License.
  3. If any provision of this License is invalid or unenforceable under applicable law, it shall not affect the validity or enforceability of the remainder of the terms of this License, and without further action by the parties to this agreement, such provision shall be reformed to the minimum extent necessary to make such provision valid and enforceable.
  4. No term or provision of this License shall be deemed waived and no breach consented to unless such waiver or consent shall be in writing and signed by the party to be charged with such waiver or consent
  5. This License constitutes the entire agreement between the parties with respect to the Work licensed here. There are no understandings, agreements or representations with respect to the Work not specified here. Licensor shall not be bound by any additional provisions that may appear in any communication from You. This License may not be modified without the mutual written agreement of the Licensor and You.
  6. The rights granted under, and the subject matter referenced, in this License were drafted utilizing the terminology of the Berne Convention for the Protection of Literary and Artistic Works (as amended on September 28, 1979), the Rome Convention of 1961, the WIPO Copyright Treaty of 1996, the WIPO Performances and Phonograms Treaty of 1996 and the Universal Copyright Convention (as revised on July 24, 1971). These rights and subject matter take effect in the relevant jurisdiction in which the License terms are sought to be enforced according to the corresponding provisions of the implementation of those treaty provisions in the applicable national law. If the standard suite of rights granted under applicable copyright law includes additional rights not granted under this License, such additional rights are deemed to be included in the License; this License is not intended to restrict the license of any rights under applicable law.
Translations
Genel Dizin
Ekler


Genel Dizin

İçindekiler

  • İşlevler ve Yöntemler Dizini
  • Örnekler Dizini
Creative Commons Attribution 3.0
İşlevler ve Yöntemler Dizini
Ekler


İşlevler ve Yöntemler Dizini

Kılavuzdaki tüm işlevler ve yöntemlerin bir listesi

4 a b c d e f g h i j k l m n o p q r s t u v w x y z _

  • 4
    • 4D tarafından kabul edilebilen SQL - PDO ve SQL 4D
  • a
    • abs - Absolute value
    • acos - Arc cosine
    • acosh - Inverse hyperbolic cosine
    • addcslashes - Dizgeye C tarzı öncelem uygular
    • addslashes - Özel karakterlerin önüne tersbölü yerleştirir
    • apache_child_terminate - Bu istekten sonra Apache sürecini sonlandırır
    • apache_getenv - Bir Apache ortam değişkeninin değerini döndürür
    • apache_get_modules - Yüklü Apache modüllerinin listesini verir
    • apache_get_version - Apache sürümünü getirir
    • apache_lookup_uri - Verilen URI için kısmi bir istekte bulunur ve hakkındaki tüm bilgileri döndürür
    • apache_note - Apache istek notlarını alır veya atar
    • apache_request_headers - Tüm HTTP istek başlıklarını alır
    • apache_reset_timeout - Apache yazma zamanlayıcısını sıfırlar
    • apache_response_headers - Tüm HTTP yanıt başlıklarını alır
    • apache_setenv - Bir Apache ortam değişkeni atar
    • APCUIterator::current - Get current item
    • APCUIterator::getTotalCount - Get total count
    • APCUIterator::getTotalHits - Get total cache hits
    • APCUIterator::getTotalSize - Get total cache size
    • APCUIterator::key - Get iterator key
    • APCUIterator::next - Move pointer to next item
    • APCUIterator::rewind - Rewinds iterator
    • APCUIterator::valid - Checks if current position is valid
    • APCUIterator::__construct - Constructs an APCUIterator iterator object
    • apcu_add - Cache a new variable in the data store
    • apcu_cache_info - Retrieves cached information from APCu's data store
    • apcu_cas - Updates an old value with a new value
    • apcu_clear_cache - Clears the APCu cache
    • apcu_dec - Decrease a stored number
    • apcu_delete - Removes a stored variable from the cache
    • apcu_entry - Atomically fetch or generate a cache entry
    • apcu_exists - Checks if entry exists
    • apcu_fetch - Fetch a stored variable from the cache
    • apcu_inc - Increase a stored number
    • apcu_sma_info - Retrieves APCu Shared Memory Allocation information
    • apcu_store - Cache a variable in the data store
    • apc_add - Bir değişkeni önbellek veri deposunda saklar
    • apc_bin_dump - Get a binary dump of the given files and user variables
    • apc_bin_dumpfile - Output a binary dump of cached files and user variables to a file
    • apc_bin_load - Load a binary dump into the APC file/user cache
    • apc_bin_loadfile - Load a binary dump from a file into the APC file/user cache
    • apc_cache_info - APC'nin veri deposundan önbellek bilgisini gösterir
    • apc_cas - Updates an old value with a new value
    • apc_clear_cache - APC önbelleğini temizler
    • apc_compile_file - Bir dosyayı, süzgeçlere aldırmadan, arakod (bytecode) önbelleğinde depolar.
    • apc_dec - Decrease a stored number
    • apc_define_constants - Yeniden çağırmak ve yığın tanımlama için bir grup sabit tanımlar
    • apc_delete - Depolanmış bir değişkeni önbellekten siler
    • apc_delete_file - Deletes files from the opcode cache
    • apc_exists - Checks if APC key exists
    • apc_fetch - Depolanmış bir değişkeni önbellekten alır
    • apc_inc - Increase a stored number
    • apc_load_constants - Önbellekten bir sabit kümesini yükler
    • apc_sma_info - APC paylaşımlı bellek tahsis durumu bilgisini verir
    • apc_store - Bir değişkeni veri deposunda saklar
    • apd_breakpoint - Yorumlayıcıyı durdurur ve soketten bir satırbaşı bekler
    • apd_callstack - Geçerli yordam dökümünü bir dizi olarak döndürür
    • apd_clunk - Bir uyarı ve yordam dökümü verip çıkar
    • apd_continue - Yorumlayıcıyı yeniden başlatır
    • apd_croak - Bir hata ve yordam dökümü verip çıkar
    • apd_dump_function_table - Geçerli işlev tablosunu çıktılar
    • apd_dump_persistent_resources - Tüm kalıcı özkaynakları bir dizi içinde döndürür
    • apd_dump_regular_resources - Geçerli normal özkaynakların tümünü bir dizi olarak döndürür
    • apd_echo - Çıktıyı hata ayıklama soketine gönderir
    • apd_get_active_symbols - Yerel etki alanında geçerli değişken isimlerinden oluşan bir dizi döndürür
    • apd_set_pprof_trace - Hata ayıklama oturumunu başlatır
    • apd_set_session - Geçerli hata ayıklama seviyesini belirtir ya da değiştirir
    • apd_set_session_trace - Hata ayıklama oturumunu başlatır
    • apd_set_session_trace_socket - Uzaktan oturumla hata ayıklamayı başlatır
    • AppendIterator::append - Appends an iterator
    • AppendIterator::current - Gets the current value
    • AppendIterator::getArrayIterator - Gets the ArrayIterator
    • AppendIterator::getInnerIterator - Gets the inner iterator
    • AppendIterator::getIteratorIndex - Gets an index of iterators
    • AppendIterator::key - Gets the current key
    • AppendIterator::next - Moves to the next element
    • AppendIterator::rewind - Rewinds the Iterator
    • AppendIterator::valid - Checks validity of the current element
    • AppendIterator::__construct - Constructs an AppendIterator
    • array - Bir dizi oluşturur
    • ArrayAccess::offsetExists - Bir konumun mevcut olup olmadığına bakar
    • ArrayAccess::offsetGet - Konumdaki değeri döndürür
    • ArrayAccess::offsetSet - Konuma değer atanır
    • ArrayAccess::offsetUnset - Konum boşaltılır
    • ArrayIterator::append - Append an element
    • ArrayIterator::asort - Sort array by values
    • ArrayIterator::count - Count elements
    • ArrayIterator::current - Return current array entry
    • ArrayIterator::getArrayCopy - Get array copy
    • ArrayIterator::getFlags - Get flags
    • ArrayIterator::key - Return current array key
    • ArrayIterator::ksort - Sort array by keys
    • ArrayIterator::natcasesort - Sort an array naturally, case insensitive
    • ArrayIterator::natsort - Sort an array naturally
    • ArrayIterator::next - Move to next entry
    • ArrayIterator::offsetExists - Check if offset exists
    • ArrayIterator::offsetGet - Get value for an offset
    • ArrayIterator::offsetSet - Set value for an offset
    • ArrayIterator::offsetUnset - Unset value for an offset
    • ArrayIterator::rewind - Rewind array back to the start
    • ArrayIterator::seek - Seek to position
    • ArrayIterator::serialize - Serialize
    • ArrayIterator::setFlags - Set behaviour flags
    • ArrayIterator::uasort - User defined sort
    • ArrayIterator::uksort - User defined sort
    • ArrayIterator::unserialize - Unserialize
    • ArrayIterator::valid - Check whether array contains more entries
    • ArrayIterator::__construct - Construct an ArrayIterator
    • ArrayObject::append - Appends the value
    • ArrayObject::asort - Sort the entries by value
    • ArrayObject::count - Get the number of public properties in the ArrayObject
    • ArrayObject::exchangeArray - Exchange the array for another one.
    • ArrayObject::getArrayCopy - Creates a copy of the ArrayObject.
    • ArrayObject::getFlags - Gets the behavior flags.
    • ArrayObject::getIterator - Create a new iterator from an ArrayObject instance
    • ArrayObject::getIteratorClass - Gets the iterator classname for the ArrayObject.
    • ArrayObject::ksort - Sort the entries by key
    • ArrayObject::natcasesort - Sort an array using a case insensitive "natural order" algorithm
    • ArrayObject::natsort - Sort entries using a "natural order" algorithm
    • ArrayObject::offsetExists - Returns whether the requested index exists
    • ArrayObject::offsetGet - Returns the value at the specified index
    • ArrayObject::offsetSet - Sets the value at the specified index to newval
    • ArrayObject::offsetUnset - Unsets the value at the specified index
    • ArrayObject::serialize - Serialize an ArrayObject
    • ArrayObject::setFlags - Sets the behavior flags.
    • ArrayObject::setIteratorClass - Sets the iterator classname for the ArrayObject.
    • ArrayObject::uasort - Sort the entries with a user-defined comparison function and maintain key association
    • ArrayObject::uksort - Sort the entries by keys using a user-defined comparison function
    • ArrayObject::unserialize - Unserialize an ArrayObject
    • ArrayObject::__construct - Construct a new array object
    • array_change_key_case - Bir dizideki tüm anahtarların harf büyüklüğünü değiştirir
    • array_chunk - Bir diziyi belli uzunlukta bölümlere ayırır
    • array_column - Return the values from a single column in the input array
    • array_combine - Anahtarlar için bir dizi, değerler için ise başka bir dizi kullanarak bir ilişkisel dizi oluşturur
    • array_count_values - Bir dizideki tüm değerleri sayar
    • array_diff - Dizilerin farkını hesaplar
    • array_diff_assoc - Dizilerin farkını hesaplarken ek olarak indisleri de karşılaştırır
    • array_diff_key - Dizilerin farkını hesaplarken indisleri karşılaştırır
    • array_diff_uassoc - Dizilerin farkını hesaplarken ek olarak bir geriçağırım işlevi üzerinden indisleri de karşılaştırır
    • array_diff_ukey - Karşılaştırma için bir geriçağırım işlevi kullanarak dizilerin farkını hesaplar
    • array_fill - Bir diziyi değerlerle doldurur
    • array_fill_keys - Anahtarları belirtilen diziyi değerlerle doldurur
    • array_filter - Bir dizinin elemanlarını bir geriçağırım işleviyle süzgeçten geçirir
    • array_flip - Bir dizideki anahtarlarla değerleri yer değiştirir
    • array_intersect - Dizilerin kesişimini hesaplar
    • array_intersect_assoc - Dizilerin kesişimini hesaplarken ek olarak indisleri de karşılaştırır
    • array_intersect_key - Karşılaştırma için anahtarları kullanarak dizilerin kesişimini hesaplar
    • array_intersect_uassoc - Dizilerin kesişimini hesaplarken ek olarak bir geriçağırım işlevi üzerinden indisleri de karşılaştırır
    • array_intersect_ukey - Anahtarları karşılaştırmak için bir geriçağırım işlevi kullanarak dizilerin kesişimini hesaplar
    • array_keys - Bir dizideki tüm anahtarları veya bir anahtar altkümesini döndürür
    • array_key_exists - Belirtilen anahtar veya indis dizide var mı diye bakar
    • array_map - Belirtilen dizilerin elemanlarına geriçağırım işlevini uygular
    • array_merge - Belirtilen dizileri ardarda ekleyerek yeni bir dizi oluşturur
    • array_merge_recursive - İki veya daha fazla sayıda diziyi ardarda ekleyerek yeni bir dizi oluşturur
    • array_multisort - Çok sayıda diziyi veya çok boyutlu dizileri sıralar
    • array_pad - Dizi boyutunu belirtilen boyuta çıkarırken, yeni elemanlara belirtilen değeri yerleştirir
    • array_pop - Dizinin sonundaki elemanı diziden çıkartır
    • array_product - Bir dizideki değerlerin çarpımını bulur
    • array_push - Belli sayıda elemanı dizinin sonuna ekler
    • array_rand - Bir diziden belli sayıda rasgele eleman döndürür
    • array_reduce - Bir geriçağırım işlevini dizinin bütün elemanlarına tek tek uygulayıp sonucu döndürür
    • array_replace - İlk dizinin elemanlarını aktarılan dizilerden günceller
    • array_replace_recursive - İlk dizinin elemanlarını aktarılan dizilerden ardışık olarak günceller
    • array_reverse - Diziyi tersine sıralayıp döndürür
    • array_search - Bir dizide belirtilen değeri arar ve bulursa ilgili anahtarı döndürür
    • array_shift - Dizini başlangıcından bir eleman çeker
    • array_slice - Bir dizinin belli bir bölümünü döndürür
    • array_splice - Bir dizinin belli bir bölümünü silip yerine başka şeyler koyar
    • array_sum - Bir dizideki değerlerin toplamını hesaplar
    • array_udiff - Veri karşılaştırması için bir geriçağırım işlevi kullanarak diziler arasındaki farkı bulur
    • array_udiff_assoc - Veri karşılaştırması için bir geriçağırım işlevi kullanarak diziler arasındaki farkı indislerine de bakarak bulur
    • array_udiff_uassoc - Veri ve indis karşılaştırması için bir geriçağırım işlevi kullanarak diziler arasındaki farkı indislerine de bakarak bulur
    • array_uintersect - Veriyi bir geriçağırım işleviyle karşılaştırarak dizilerin kesişimini hesaplar
    • array_uintersect_assoc - Veriyi bir geriçağırım işleviyle karşılaştırarak dizilerin kesişimini hesaplarken ek olarak indislere de bakar
    • array_uintersect_uassoc - Veriyi ve indisleri bir geriçağırım işleviyle karşılaştırarak dizilerin kesişimini hesaplarken ek olarak indislere de bakar
    • array_unique - Diziden yinelenen değerleri siler
    • array_unshift - Bir dizinin başlangıcına bir veya daha fazla eleman ekler
    • array_values - Bir dizinin tüm değerlerini döndürür
    • array_walk - Bir dizinin her üyesine kullanıcı tanımlı bir işlevi uygular
    • array_walk_recursive - Bir dizinin ardışık olarak her üyesine kullanıcı tanımlı bir işlevi uygular
    • arsort - Bir dizinin değerlerini anahtarlarıyla ilişkilerini bozmadan tersine sıralar
    • asin - Arc sine
    • asinh - Inverse hyperbolic sine
    • asort - Bir dizinin değerlerini anahtarlarıyla ilişkilerini bozmadan sıralar
    • assert - Checks if assertion is FALSE
    • assert_options - Çeşitli kararlılık denetim seçeneklerini açar/kapar
    • atan - Arc tangent
    • atan2 - Arc tangent of two variables
    • atanh - Inverse hyperbolic tangent
  • b
    • base64_decode - MIME base64 ile kodlanmış verinin kodunu açar
    • base64_encode - Veriye MIME base64 kodlaması uygular
    • basename - Dosya yolunun dosya ismi bileşenini döndürür
    • base_convert - Convert a number between arbitrary bases
    • Bağlam değiştirgeleri - Bağlam değiştirgesi listeleme
    • bbcode_add_element - Bir bbcode öğesi ekler
    • bbcode_add_smiley - Çözümleyiciye gülen surat ekler
    • bbcode_create - Bir BBCode özkaynağı oluşturur
    • bbcode_destroy - BBCode_Havuzu özkaynağını kapatır
    • bbcode_parse - Belirtilen dizgeyi kural kümesine göre çözümler
    • bbcode_set_arg_parser - Özkaynağa, değiştirge çözümlemesi için farklı bir kural kümesi kullanan başka bir çözümleyici ekler
    • bbcode_set_flags - Çözümleyici seçeneklerini belirler veya değiştirir
    • bcadd - İki keyfi duyarlıklı sayıyı toplar
    • bccomp - İki keyfi duyarlıklı sayıyı karşılaştırır
    • bcdiv - İki keyfi duyarlıklı sayıyı böler
    • bcmod - Keyfi duyarlıklı sayılarda bölme işleminden kalanı bulur
    • bcmul - İki keyfi duyarlıklı sayıyı çarpar
    • bcompiler_load - bz biçiminde sıkıştırılmış dosyadan, sınıfları okur ve oluşturur
    • bcompiler_load_exe - bcompiler exe dosyasından sınıfları okur ve oluşturur
    • bcompiler_parse_class - Derlenmiş koddan sınıfı okur ve kullanıcı tanımlı işleve geriçağırım yapar
    • bcompiler_read - Bir dosya tanıtıcısından sınıfları okur ve oluşturur
    • bcompiler_write_class - Tanımlanmış bir sınıfı dosyaya yazar
    • bcompiler_write_constant - Tanımlanmış sabiti dosyaya yazar
    • bcompiler_write_exe_footer - Derlenmiş kodun başlangıç konumunu ve imzasını, exe türü bir dosyanın sonuna yazar
    • bcompiler_write_file - Bir php kaynak dosyasını derleyerek yazar
    • bcompiler_write_footer - Derlenmiş verinin sona erdiğini göstermek için \x00 karakterini yazar
    • bcompiler_write_function - Tanımlı bir işlevi derlenmiş olarak yazar
    • bcompiler_write_functions_from_file - Bir dosya içinde tanımlanmış bütün işlevleri derleyerek yazar
    • bcompiler_write_header - bcompiler dosya başlığını yazar
    • bcompiler_write_included_filename - Eklenmiş bir dosyayı derlenmiş olarak yazar
    • bcpow - Keyfi duyarlıklı sayılar için üs alma işlemi yapar
    • bcpowmod - Önce bir keyfi duyarlıklı sayının diğerine göre üs alma işlemini yapar, sonra sonucun modüle göre kalanını bulur
    • bcscale - Bütün bc matematik işlevleri için öntanımlı ölçek değiştirgesini ayarlar
    • bcsqrt - Keyfi duyarlıklı bir sayının karekök alma işlemini yapar
    • bcsub - Keyfi duyarlıklı sayılar arasında çıkartma işlemi yapar
    • bin2hex - Bir ikil verinin onaltılık gösterimini elde eder
    • bindec - Binary to decimal
    • bindtextdomain - Uygulama adı için bir yol tanımlar
    • bind_textdomain_codeset - Belli bir uygulamanın iletileri için karakter kodlaması tanımlar
    • blenc_encrypt - Encrypt a PHP script with BLENC.
    • boolval - Get the boolean value of a variable
    • bson_decode - Deserializes a BSON object into a PHP array
    • bson_encode - Serializes a PHP variable into a BSON string
    • bzclose - Bzip2 dosyasını kapatır
    • bzcompress - Verilen dizgiyi bzip2 kodlamalı olarak sıkıştırır
    • bzdecompress - Bzip2 ile sıkıştırılmış veriyi açar
    • bzerrno - Bzip2 hata numarası ile döner
    • bzerror - Bzip2 hata numarasını ve hata iletisini bir dizi içerisinde döndürür
    • bzerrstr - Bzip2 hata iletisini döndürür
    • bzflush - Tampondaki bilginin tamamını yazmaya zorlar
    • bzopen - Bzip2 sıkıştırmalı bir dosyayı açar
    • bzread - Bzip2 dosyasını ikil olarak okur
    • bzwrite - Bzip2 dosyasını ikil olarak yazar
  • c
    • CachingIterator::count - The number of elements in the iterator
    • CachingIterator::current - Return the current element
    • CachingIterator::getCache - Retrieve the contents of the cache
    • CachingIterator::getFlags - Get flags used
    • CachingIterator::getInnerIterator - Returns the inner iterator
    • CachingIterator::hasNext - Check whether the inner iterator has a valid next element
    • CachingIterator::key - Return the key for the current element
    • CachingIterator::next - Move the iterator forward
    • CachingIterator::offsetExists - The offsetExists purpose
    • CachingIterator::offsetGet - The offsetGet purpose
    • CachingIterator::offsetSet - The offsetSet purpose
    • CachingIterator::offsetUnset - The offsetUnset purpose
    • CachingIterator::rewind - Rewind the iterator
    • CachingIterator::setFlags - The setFlags purpose
    • CachingIterator::valid - Check whether the current element is valid
    • CachingIterator::__construct - Construct a new CachingIterator object for the iterator.
    • CachingIterator::__toString - Return the string representation of the current element
    • Cairo::availableFonts - Retrieves the availables font types
    • Cairo::availableSurfaces - Retrieves all available surfaces
    • Cairo::statusToString - Retrieves the current status as string
    • Cairo::version - Retrives cairo's library version
    • Cairo::versionString - Retrieves cairo version as string
    • CairoContext::appendPath - Appends a path to current path
    • CairoContext::arc - Adds a circular arc
    • CairoContext::arcNegative - Adds a negative arc
    • CairoContext::clip - Establishes a new clip region
    • CairoContext::clipExtents - Computes the area inside the current clip
    • CairoContext::clipPreserve - Establishes a new clip region from the current clip
    • CairoContext::clipRectangleList - Retrieves the current clip as a list of rectangles
    • CairoContext::closePath - Closes the current path
    • CairoContext::copyPage - Emits the current page
    • CairoContext::copyPath - Creates a copy of the current path
    • CairoContext::copyPathFlat - Gets a flattened copy of the current path
    • CairoContext::curveTo - Adds a curve
    • CairoContext::deviceToUser - Transform a coordinate
    • CairoContext::deviceToUserDistance - Transform a distance
    • CairoContext::fill - Fills the current path
    • CairoContext::fillExtents - Computes the filled area
    • CairoContext::fillPreserve - Fills and preserve the current path
    • CairoContext::fontExtents - Get the font extents
    • CairoContext::getAntialias - Retrives the current antialias mode
    • CairoContext::getCurrentPoint - The getCurrentPoint purpose
    • CairoContext::getDash - The getDash purpose
    • CairoContext::getDashCount - The getDashCount purpose
    • CairoContext::getFillRule - The getFillRule purpose
    • CairoContext::getFontFace - The getFontFace purpose
    • CairoContext::getFontMatrix - The getFontMatrix purpose
    • CairoContext::getFontOptions - The getFontOptions purpose
    • CairoContext::getGroupTarget - The getGroupTarget purpose
    • CairoContext::getLineCap - The getLineCap purpose
    • CairoContext::getLineJoin - The getLineJoin purpose
    • CairoContext::getLineWidth - The getLineWidth purpose
    • CairoContext::getMatrix - The getMatrix purpose
    • CairoContext::getMiterLimit - The getMiterLimit purpose
    • CairoContext::getOperator - The getOperator purpose
    • CairoContext::getScaledFont - The getScaledFont purpose
    • CairoContext::getSource - The getSource purpose
    • CairoContext::getTarget - The getTarget purpose
    • CairoContext::getTolerance - The getTolerance purpose
    • CairoContext::glyphPath - The glyphPath purpose
    • CairoContext::hasCurrentPoint - The hasCurrentPoint purpose
    • CairoContext::identityMatrix - The identityMatrix purpose
    • CairoContext::inFill - The inFill purpose
    • CairoContext::inStroke - The inStroke purpose
    • CairoContext::lineTo - The lineTo purpose
    • CairoContext::mask - The mask purpose
    • CairoContext::maskSurface - The maskSurface purpose
    • CairoContext::moveTo - The moveTo purpose
    • CairoContext::newPath - The newPath purpose
    • CairoContext::newSubPath - The newSubPath purpose
    • CairoContext::paint - The paint purpose
    • CairoContext::paintWithAlpha - The paintWithAlpha purpose
    • CairoContext::pathExtents - The pathExtents purpose
    • CairoContext::popGroup - The popGroup purpose
    • CairoContext::popGroupToSource - The popGroupToSource purpose
    • CairoContext::pushGroup - The pushGroup purpose
    • CairoContext::pushGroupWithContent - The pushGroupWithContent purpose
    • CairoContext::rectangle - The rectangle purpose
    • CairoContext::relCurveTo - The relCurveTo purpose
    • CairoContext::relLineTo - The relLineTo purpose
    • CairoContext::relMoveTo - The relMoveTo purpose
    • CairoContext::resetClip - The resetClip purpose
    • CairoContext::restore - The restore purpose
    • CairoContext::rotate - The rotate purpose
    • CairoContext::save - The save purpose
    • CairoContext::scale - The scale purpose
    • CairoContext::selectFontFace - The selectFontFace purpose
    • CairoContext::setAntialias - The setAntialias purpose
    • CairoContext::setDash - The setDash purpose
    • CairoContext::setFillRule - The setFillRule purpose
    • CairoContext::setFontFace - The setFontFace purpose
    • CairoContext::setFontMatrix - The setFontMatrix purpose
    • CairoContext::setFontOptions - The setFontOptions purpose
    • CairoContext::setFontSize - The setFontSize purpose
    • CairoContext::setLineCap - The setLineCap purpose
    • CairoContext::setLineJoin - The setLineJoin purpose
    • CairoContext::setLineWidth - The setLineWidth purpose
    • CairoContext::setMatrix - The setMatrix purpose
    • CairoContext::setMiterLimit - The setMiterLimit purpose
    • CairoContext::setOperator - The setOperator purpose
    • CairoContext::setScaledFont - The setScaledFont purpose
    • CairoContext::setSource - The setSource purpose
    • CairoContext::setSourceRGB - The setSourceRGB purpose
    • CairoContext::setSourceRGBA - The setSourceRGBA purpose
    • CairoContext::setSourceSurface - The setSourceSurface purpose
    • CairoContext::setTolerance - The setTolerance purpose
    • CairoContext::showPage - The showPage purpose
    • CairoContext::showText - The showText purpose
    • CairoContext::status - The status purpose
    • CairoContext::stroke - The stroke purpose
    • CairoContext::strokeExtents - The strokeExtents purpose
    • CairoContext::strokePreserve - The strokePreserve purpose
    • CairoContext::textExtents - The textExtents purpose
    • CairoContext::textPath - The textPath purpose
    • CairoContext::transform - The transform purpose
    • CairoContext::translate - The translate purpose
    • CairoContext::userToDevice - The userToDevice purpose
    • CairoContext::userToDeviceDistance - The userToDeviceDistance purpose
    • CairoContext::__construct - Creates a new CairoContext
    • CairoFontFace::getType - Retrieves the font face type
    • CairoFontFace::status - Check for CairoFontFace errors
    • CairoFontFace::__construct - Creates a new CairoFontFace object
    • CairoFontOptions::equal - The equal purpose
    • CairoFontOptions::getAntialias - The getAntialias purpose
    • CairoFontOptions::getHintMetrics - The getHintMetrics purpose
    • CairoFontOptions::getHintStyle - The getHintStyle purpose
    • CairoFontOptions::getSubpixelOrder - The getSubpixelOrder purpose
    • CairoFontOptions::hash - The hash purpose
    • CairoFontOptions::merge - The merge purpose
    • CairoFontOptions::setAntialias - The setAntialias purpose
    • CairoFontOptions::setHintMetrics - The setHintMetrics purpose
    • CairoFontOptions::setHintStyle - The setHintStyle purpose
    • CairoFontOptions::setSubpixelOrder - The setSubpixelOrder purpose
    • CairoFontOptions::status - The status purpose
    • CairoFontOptions::__construct - The __construct purpose
    • CairoFormat::strideForWidth - Provides an appropiate stride to use
    • CairoGradientPattern::addColorStopRgb - The addColorStopRgb purpose
    • CairoGradientPattern::addColorStopRgba - The addColorStopRgba purpose
    • CairoGradientPattern::getColorStopCount - The getColorStopCount purpose
    • CairoGradientPattern::getColorStopRgba - The getColorStopRgba purpose
    • CairoGradientPattern::getExtend - The getExtend purpose
    • CairoGradientPattern::setExtend - The setExtend purpose
    • CairoImageSurface::createForData - The createForData purpose
    • CairoImageSurface::createFromPng - Creates a new CairoImageSurface form a png image file
    • CairoImageSurface::getData - Gets the image data as string
    • CairoImageSurface::getFormat - Get the image format
    • CairoImageSurface::getHeight - Retrieves the height of the CairoImageSurface
    • CairoImageSurface::getStride - The getStride purpose
    • CairoImageSurface::getWidth - Retrieves the width of the CairoImageSurface
    • CairoImageSurface::__construct - Creates a new CairoImageSurface
    • CairoLinearGradient::getPoints - The getPoints purpose
    • CairoLinearGradient::__construct - The __construct purpose
    • CairoMatrix::initIdentity - Creates a new identity matrix
    • CairoMatrix::initRotate - Creates a new rotated matrix
    • CairoMatrix::initScale - Creates a new scaling matrix
    • CairoMatrix::initTranslate - Creates a new translation matrix
    • CairoMatrix::invert - The invert purpose
    • CairoMatrix::multiply - The multiply purpose
    • CairoMatrix::rotate - The rotate purpose
    • CairoMatrix::scale - Applies scaling to a matrix
    • CairoMatrix::transformDistance - The transformDistance purpose
    • CairoMatrix::transformPoint - The transformPoint purpose
    • CairoMatrix::translate - The translate purpose
    • CairoMatrix::__construct - Creates a new CairoMatrix object
    • CairoPattern::getMatrix - The getMatrix purpose
    • CairoPattern::getType - The getType purpose
    • CairoPattern::setMatrix - The setMatrix purpose
    • CairoPattern::status - The status purpose
    • CairoPattern::__construct - The __construct purpose
    • CairoPdfSurface::setSize - The setSize purpose
    • CairoPdfSurface::__construct - The __construct purpose
    • CairoPsSurface::dscBeginPageSetup - The dscBeginPageSetup purpose
    • CairoPsSurface::dscBeginSetup - The dscBeginSetup purpose
    • CairoPsSurface::dscComment - The dscComment purpose
    • CairoPsSurface::getEps - The getEps purpose
    • CairoPsSurface::getLevels - The getLevels purpose
    • CairoPsSurface::levelToString - The levelToString purpose
    • CairoPsSurface::restrictToLevel - The restrictToLevel purpose
    • CairoPsSurface::setEps - The setEps purpose
    • CairoPsSurface::setSize - The setSize purpose
    • CairoPsSurface::__construct - The __construct purpose
    • CairoRadialGradient::getCircles - The getCircles purpose
    • CairoRadialGradient::__construct - The __construct purpose
    • CairoScaledFont::extents - The extents purpose
    • CairoScaledFont::getCtm - The getCtm purpose
    • CairoScaledFont::getFontFace - The getFontFace purpose
    • CairoScaledFont::getFontMatrix - The getFontMatrix purpose
    • CairoScaledFont::getFontOptions - The getFontOptions purpose
    • CairoScaledFont::getScaleMatrix - The getScaleMatrix purpose
    • CairoScaledFont::getType - The getType purpose
    • CairoScaledFont::glyphExtents - The glyphExtents purpose
    • CairoScaledFont::status - The status purpose
    • CairoScaledFont::textExtents - The textExtents purpose
    • CairoScaledFont::__construct - The __construct purpose
    • CairoSolidPattern::getRgba - The getRgba purpose
    • CairoSolidPattern::__construct - The __construct purpose
    • CairoSurface::copyPage - The copyPage purpose
    • CairoSurface::createSimilar - The createSimilar purpose
    • CairoSurface::finish - The finish purpose
    • CairoSurface::flush - The flush purpose
    • CairoSurface::getContent - The getContent purpose
    • CairoSurface::getDeviceOffset - The getDeviceOffset purpose
    • CairoSurface::getFontOptions - The getFontOptions purpose
    • CairoSurface::getType - The getType purpose
    • CairoSurface::markDirty - The markDirty purpose
    • CairoSurface::markDirtyRectangle - The markDirtyRectangle purpose
    • CairoSurface::setDeviceOffset - The setDeviceOffset purpose
    • CairoSurface::setFallbackResolution - The setFallbackResolution purpose
    • CairoSurface::showPage - The showPage purpose
    • CairoSurface::status - The status purpose
    • CairoSurface::writeToPng - The writeToPng purpose
    • CairoSurface::__construct - The __construct purpose
    • CairoSurfacePattern::getExtend - The getExtend purpose
    • CairoSurfacePattern::getFilter - The getFilter purpose
    • CairoSurfacePattern::getSurface - The getSurface purpose
    • CairoSurfacePattern::setExtend - The setExtend purpose
    • CairoSurfacePattern::setFilter - The setFilter purpose
    • CairoSurfacePattern::__construct - The __construct purpose
    • CairoSvgSurface::getVersions - Used to retrieve a list of supported SVG versions
    • CairoSvgSurface::restrictToVersion - The restrictToVersion purpose
    • CairoSvgSurface::versionToString - The versionToString purpose
    • CairoSvgSurface::__construct - The __construct purpose
    • cairo_create - Returns a new CairoContext object on the requested surface.
    • cairo_font_face_get_type - Description
    • cairo_font_options_create - Description
    • cairo_font_options_equal - Description
    • cairo_font_options_get_antialias - Description
    • cairo_font_options_get_hint_metrics - Description
    • cairo_font_options_get_hint_style - Description
    • cairo_font_options_get_subpixel_order - Description
    • cairo_font_options_hash - Description
    • cairo_font_options_merge - Description
    • cairo_font_options_set_antialias - Description
    • cairo_font_options_set_hint_metrics - Description
    • cairo_font_options_set_hint_style - Description
    • cairo_font_options_set_subpixel_order - Description
    • cairo_font_options_status - Description
    • cairo_format_stride_for_width - Description
    • cairo_image_surface_create - Description
    • cairo_image_surface_create_for_data - Description
    • cairo_image_surface_create_from_png - Description
    • cairo_image_surface_get_data - Description
    • cairo_image_surface_get_format - Description
    • cairo_image_surface_get_height - Description
    • cairo_image_surface_get_stride - Description
    • cairo_image_surface_get_width - Description
    • cairo_matrix_create_translate - Takma Adı: CairoMatrix::initTranslate
    • cairo_matrix_invert - Description
    • cairo_matrix_multiply - Description
    • cairo_matrix_rotate - Description
    • cairo_matrix_transform_distance - Description
    • cairo_matrix_transform_point - Description
    • cairo_matrix_translate - Description
    • cairo_pattern_add_color_stop_rgb - Description
    • cairo_pattern_add_color_stop_rgba - Description
    • cairo_pattern_create_for_surface - Description
    • cairo_pattern_create_linear - Description
    • cairo_pattern_create_radial - Description
    • cairo_pattern_create_rgb - Description
    • cairo_pattern_create_rgba - Description
    • cairo_pattern_get_color_stop_count - Description
    • cairo_pattern_get_color_stop_rgba - Description
    • cairo_pattern_get_extend - Description
    • cairo_pattern_get_filter - Description
    • cairo_pattern_get_linear_points - Description
    • cairo_pattern_get_matrix - Description
    • cairo_pattern_get_radial_circles - Description
    • cairo_pattern_get_rgba - Description
    • cairo_pattern_get_surface - Description
    • cairo_pattern_get_type - Description
    • cairo_pattern_set_extend - Description
    • cairo_pattern_set_filter - Description
    • cairo_pattern_set_matrix - Description
    • cairo_pattern_status - Description
    • cairo_pdf_surface_create - Description
    • cairo_pdf_surface_set_size - Description
    • cairo_ps_get_levels - Description
    • cairo_ps_level_to_string - Description
    • cairo_ps_surface_create - Description
    • cairo_ps_surface_dsc_begin_page_setup - Description
    • cairo_ps_surface_dsc_begin_setup - Description
    • cairo_ps_surface_dsc_comment - Description
    • cairo_ps_surface_get_eps - Description
    • cairo_ps_surface_restrict_to_level - Description
    • cairo_ps_surface_set_eps - Description
    • cairo_ps_surface_set_size - Description
    • cairo_scaled_font_create - Description
    • cairo_scaled_font_extents - Description
    • cairo_scaled_font_get_ctm - Description
    • cairo_scaled_font_get_font_face - Description
    • cairo_scaled_font_get_font_matrix - Description
    • cairo_scaled_font_get_font_options - Description
    • cairo_scaled_font_get_scale_matrix - Description
    • cairo_scaled_font_get_type - Description
    • cairo_scaled_font_glyph_extents - Description
    • cairo_scaled_font_status - Description
    • cairo_scaled_font_text_extents - Description
    • cairo_surface_copy_page - Description
    • cairo_surface_create_similar - Description
    • cairo_surface_finish - Description
    • cairo_surface_flush - Description
    • cairo_surface_get_content - Description
    • cairo_surface_get_device_offset - Description
    • cairo_surface_get_font_options - Description
    • cairo_surface_get_type - Description
    • cairo_surface_mark_dirty - Description
    • cairo_surface_mark_dirty_rectangle - Description
    • cairo_surface_set_device_offset - Description
    • cairo_surface_set_fallback_resolution - Description
    • cairo_surface_show_page - Description
    • cairo_surface_status - Description
    • cairo_surface_write_to_png - Description
    • cairo_svg_surface_create - Description
    • cairo_svg_surface_restrict_to_version - Description
    • cairo_svg_version_to_string - Description
    • CallbackFilterIterator::accept - Calls the callback with the current value, the current key and the inner iterator as arguments
    • CallbackFilterIterator::__construct - Create a filtered iterator from another iterator
    • call_user_func - İlk değiştirgede belirtilen kullanıcı işlevini çağırır
    • call_user_func_array - Değiştirgelerin bir dizi olarak verildiği kullanıcı işlevini çağırır
    • call_user_method - Belli bir nesnenin bir kullanıcı yöntemini çağırır [önerilmiyor]
    • call_user_method_array - Değiştirge dizisi belirtilen bir kullanıcı yöntemini çağırır [önerilmiyor]
    • cal_days_in_month - Seçilen takvime ve yıla göre istenen aydaki gün sayısını geri döndürür
    • cal_from_jd - Jülyen Gün Sayısını, istenen takvim biçimine çevirir
    • cal_info - Değiştirge olarak verilen takvim hakkında bilgi döner
    • cal_to_jd - Desteklenen bir takvimden Jülyen Gün Sayısına dönüşüm yapar
    • ceil - Round fractions up
    • chdb::get - Gets the value associated with a key
    • chdb::__construct - Creates a chdb instance
    • chdb_create - Creates a chdb file
    • chdir - Dizin değiştirir
    • checkdate - Miladi tarihi doğrular
    • checkdnsrr - Belirtilen bir konak adı veya IP adresi için DNS sorgusu yapar
    • chgrp - Dosya grubunu değiştirir
    • chmod - Dosya kipini değiştirir
    • chop - rtrim işlevinin takma adıdır
    • chown - Dosyanın sahibini değiştirir
    • chr - Kodu belirtilen karakteri döndürür
    • chroot - Kök dizini değiştirir
    • chunk_split - Bir dizgeyi daha küçük parçalara ayırır
    • classkit_import - Yeni sınıf yöntem tanımlarını, verilen dosyadan içe aktarır
    • classkit_method_add - Verilen sınıfa devingen olarak yeni bir yöntem ekler
    • classkit_method_copy - Yöntemi bir sınıftan diğerine kopyalar
    • classkit_method_redefine - Verilen yöntemin kodunu devingen olarak değiştirir
    • classkit_method_remove - Verilen yöntemi devingen olarak kaldırır
    • classkit_method_rename - Verilen yöntemin ismini devingen olarak değiştirir
    • class_alias - Creates an alias for a class
    • class_exists - Sınıf tanımlı mı diye bakar
    • class_implements - Return the interfaces which are implemented by the given class or interface
    • class_parents - Return the parent classes of the given class
    • class_uses - Return the traits used by the given class
    • clearstatcache - Dosya durum önbelleğini temizler
    • cli_get_process_title - Returns the current process title
    • cli_set_process_title - Sets the process title
    • closedir - Dizin tanıtıcısını kapatır
    • closelog - Sistem günlükçüsü bağlantısını kapatır
    • Closure::bind - Duplicates a closure with a specific bound object and class scope
    • Closure::bindTo - Duplicates the closure with a new bound object and class scope
    • Closure::call - Binds and calls the closure
    • Closure::__construct - Constructor that disallows instantiation
    • Collator::asort - Diziyi indislerin arasındaki ilişkilere göre sıralar
    • Collator::compare - İki Evrenkodlu dizgeyi karşılaştırır
    • Collator::create - Bir karşılaştırıcı oluşturur
    • Collator::getAttribute - Karşılaştırma özniteliğinin değerini döndürür
    • Collator::getErrorCode - Karşılaştırıcının son hata kodunu döndürür
    • Collator::getErrorMessage - Karşılaştırıcının son hata iletisini döndürür
    • Collator::getLocale - Karşılaştırıcının yerel ismini döndürür
    • Collator::getSortKey - Get sorting key for a string
    • Collator::getStrength - Geçerli karşılaştırma seviyesini döndürür
    • Collator::setAttribute - Karşılaştırma özniteliği tanımlar
    • Collator::setStrength - Sıralamanın seviyesini ayarlar
    • Collator::sort - Belirtilen karşılaştırıcıyı kullanarak diziyi sıralar
    • Collator::sortWithSortKeys - Bir diziyi belirtilen karşılaştırıcıyı ve sıralama anahtarlarını kullanarak sıralar
    • Collator::__construct - Bir karşılaştırıcı oluşturur
    • Collectable::isGarbage - Determine whether an object has been marked as garbage
    • Collectable::setGarbage - Mark an object as garbage
    • compact - Değişkenlerle değerlerinden oluşan bir dizi oluşturur
    • com_create_guid - Evrensel tanımlayıcı (Globally Unique Identifier) üretir
    • com_event_sink - Bir COM nesnesinden, PHP nesnesine olayları bağlar
    • com_get_active_object - COM nesnesinin çalışan bir örneği için tanıtıcı döner
    • com_load_typelib - Verilen tür kütüphanesini yükler
    • com_message_pump - COM iletilerini işler, zaman_asimi süresince uykudadır
    • com_print_typeinfo - İncelenebilecek şekilde PHP sınıf tanımını yazar
    • Cond::broadcast - Broadcast a Condition
    • Cond::create - Create a Condition
    • Cond::destroy - Destroy a Condition
    • Cond::signal - Signal a Condition
    • Cond::wait - Wait for Condition
    • connection_aborted - İstemcinin bağlantıyı terkedip terketmediğine bakar
    • connection_status - Bağlantı durumu bit maskesini döndürür
    • constant - Bir sabitin değerini döndürür
    • convert_cyr_string - Bir Kril karakter kümesini bir diğerine çevirir
    • convert_uudecode - Uuencoded ile kodlanmış bir dizgeyi eski haline getirir
    • convert_uuencode - Bir dizgeyi uuencode algoritmasıyla kodlar
    • copy - Dosya kopyalar
    • cos - Cosine
    • cosh - Hyperbolic cosine
    • count - Bir dizideki eleman sayısını veya bir nesnedeki özellik sayısını döndürür
    • Countable::count - Count elements of an object
    • Counter::bumpValue - Change the current value of a counter.
    • Counter::getMeta - Return a piece of metainformation about a counter.
    • Counter::getNamed - Retrieve an existing named counter.
    • Counter::getValue - Get the current value of a counter.
    • Counter::resetValue - Reset the current value of a counter.
    • Counter::setCounterClass - Set the class returned by Counter::getNamed.
    • Counter::__construct - Creates an instance of a Counter which maintains a single numeric value.
    • counter_bump - Update the current value of the basic counter.
    • counter_bump_value - Change the current value of a counter resource.
    • counter_create - Creates a counter which maintains a single numeric value.
    • counter_get - Get the current value of the basic counter.
    • counter_get_meta - Return a piece of metainformation about a counter resource.
    • counter_get_named - Retrieve an existing named counter as a resource.
    • counter_get_value - Get the current value of a counter resource.
    • counter_reset - Reset the current value of the basic counter.
    • counter_reset_value - Reset the current value of a counter resource.
    • count_chars - Bir dizgedeki karakterler hakkında bilgi döndürür
    • crack_check - Belirtilen parola üzerinde çapraşık bir sınama yapar
    • crack_closedict - Açık bir CrackLib sözlüğünü kapatır
    • crack_getlastmessage - Son sınamanın sonucuyla ilgili bir ileti döndürür
    • crack_opendict - Yeni bir CrackLib sözlüğü açar
    • crc32 - Bir dizgenin crc32 çok terimlisini hesaplar
    • create_function - Bir anonim (lamda tarzı) işlev oluşturur
    • crypt - Tek yönlü dizge şifrelemesi yapar
    • ctype_alnum - Sınama, abecesayısal karakterler için yapılır
    • ctype_alpha - Sınama, abecesel karakterler için yapılır
    • ctype_cntrl - Sınama, denetim karakterleri için yapılır
    • ctype_digit - Sınama, rakamlar için yapılır
    • ctype_graph - Sınama, boşluk karakterleri hariç basılabilir karakterler için yapılır
    • ctype_lower - Sınama, küçük harfler için yapılır
    • ctype_print - Sınama, basılabilir karakterler için yapılır
    • ctype_punct - Sınama, birer alfasayısal veya boşluk karakteri olmayan basılabilir karakterler için yapılır
    • ctype_space - Sınama, boşluk karakterleri için yapılır
    • ctype_upper - Sınama, büyük harfler için yapılır
    • ctype_xdigit - Sınama, onaltılık rakamlar için yapılır
    • cubrid_affected_rows - Return the number of rows affected by the last SQL statement
    • cubrid_bind - Bind variables to a prepared statement as parameters
    • cubrid_client_encoding - Return the current CUBRID connection charset
    • cubrid_close - Close CUBRID connection
    • cubrid_close_prepare - Close the request handle
    • cubrid_close_request - Close the request handle
    • cubrid_column_names - Get the column names in result
    • cubrid_column_types - Get column types in result
    • cubrid_col_get - Get contents of collection type column using OID
    • cubrid_col_size - Get the number of elements in collection type column using OID
    • cubrid_commit - Commit a transaction
    • cubrid_connect - Open a connection to a CUBRID Server
    • cubrid_connect_with_url - Establish the environment for connecting to CUBRID server
    • cubrid_current_oid - Get OID of the current cursor location
    • cubrid_data_seek - Move the internal row pointer of the CUBRID result
    • cubrid_db_name - Get db name from results of cubrid_list_dbs
    • cubrid_disconnect - Close a database connection
    • cubrid_drop - Delete an instance using OID
    • cubrid_errno - Return the numerical value of the error message from previous CUBRID operation
    • cubrid_error - Get the error message
    • cubrid_error_code - Get error code for the most recent function call
    • cubrid_error_code_facility - Get the facility code of error
    • cubrid_error_msg - Get last error message for the most recent function call
    • cubrid_execute - Execute a prepared SQL statement
    • cubrid_fetch - Fetch the next row from a result set
    • cubrid_fetch_array - Fetch a result row as an associative array, a numeric array, or both
    • cubrid_fetch_assoc - Return the associative array that corresponds to the fetched row
    • cubrid_fetch_field - Get column information from a result and return as an object
    • cubrid_fetch_lengths - Return an array with the lengths of the values of each field from the current row
    • cubrid_fetch_object - Fetch the next row and return it as an object
    • cubrid_fetch_row - Return a numerical array with the values of the current row
    • cubrid_field_flags - Return a string with the flags of the given field offset
    • cubrid_field_len - Get the maximum length of the specified field
    • cubrid_field_name - Return the name of the specified field index
    • cubrid_field_seek - Move the result set cursor to the specified field offset
    • cubrid_field_table - Return the name of the table of the specified field
    • cubrid_field_type - Return the type of the column corresponding to the given field offset
    • cubrid_free_result - Free the memory occupied by the result data
    • cubrid_get - Get a column using OID
    • cubrid_get_autocommit - Get auto-commit mode of the connection
    • cubrid_get_charset - Return the current CUBRID connection charset
    • cubrid_get_class_name - Get the class name using OID
    • cubrid_get_client_info - Return the client library version
    • cubrid_get_db_parameter - Returns the CUBRID database parameters
    • cubrid_get_query_timeout - Get the query timeout value of the request
    • cubrid_get_server_info - Return the CUBRID server version
    • cubrid_insert_id - Return the ID generated for the last updated AUTO_INCREMENT column
    • cubrid_is_instance - Check whether the instance pointed by OID exists
    • cubrid_list_dbs - Return an array with the list of all existing CUBRID databases
    • cubrid_load_from_glo - Read data from a GLO instance and save it in a file
    • cubrid_lob2_bind - Bind a lob object or a string as a lob object to a prepared statement as parameters.
    • cubrid_lob2_close - Close LOB object.
    • cubrid_lob2_export - Export the lob object to a file.
    • cubrid_lob2_import - Import BLOB/CLOB data from a file.
    • cubrid_lob2_new - Create a lob object.
    • cubrid_lob2_read - Read from BLOB/CLOB data.
    • cubrid_lob2_seek - Move the cursor of a lob object.
    • cubrid_lob2_seek64 - Move the cursor of a lob object.
    • cubrid_lob2_size - Get a lob object's size.
    • cubrid_lob2_size64 - Get a lob object's size.
    • cubrid_lob2_tell - Tell the cursor position of the LOB object.
    • cubrid_lob2_tell64 - Tell the cursor position of the LOB object.
    • cubrid_lob2_write - Write to a lob object.
    • cubrid_lob_close - Close BLOB/CLOB data
    • cubrid_lob_export - Export BLOB/CLOB data to file
    • cubrid_lob_get - Get BLOB/CLOB data
    • cubrid_lob_send - Read BLOB/CLOB data and send straight to browser
    • cubrid_lob_size - Get BLOB/CLOB data size
    • cubrid_lock_read - Set a read lock on the given OID
    • cubrid_lock_write - Set a write lock on the given OID
    • cubrid_move_cursor - Move the cursor in the result
    • cubrid_new_glo - Create a glo instance
    • cubrid_next_result - Get result of next query when executing multiple SQL statements
    • cubrid_num_cols - Return the number of columns in the result set
    • cubrid_num_fields - Return the number of columns in the result set
    • cubrid_num_rows - Get the number of rows in the result set
    • cubrid_pconnect - Open a persistent connection to a CUBRID server
    • cubrid_pconnect_with_url - Open a persistent connection to CUBRID server
    • cubrid_ping - Ping a server connection or reconnect if there is no connection
    • cubrid_prepare - Prepare a SQL statement for execution
    • cubrid_put - Update a column using OID
    • cubrid_query - Send a CUBRID query
    • cubrid_real_escape_string - Escape special characters in a string for use in an SQL statement
    • cubrid_result - Return the value of a specific field in a specific row
    • cubrid_rollback - Roll back a transaction
    • cubrid_save_to_glo - Save requested file in a GLO instance
    • cubrid_schema - Get the requested schema information
    • cubrid_send_glo - Read data from glo and send it to std output
    • cubrid_seq_drop - Delete an element from sequence type column using OID
    • cubrid_seq_insert - Insert an element to a sequence type column using OID
    • cubrid_seq_put - Update the element value of sequence type column using OID
    • cubrid_set_add - Insert a single element to set type column using OID
    • cubrid_set_autocommit - Set autocommit mode of the connection
    • cubrid_set_db_parameter - Sets the CUBRID database parameters
    • cubrid_set_drop - Delete an element from set type column using OID
    • cubrid_set_query_timeout - Set the timeout time of query execution
    • cubrid_unbuffered_query - Perform a query without fetching the results into memory
    • cubrid_version - Get the CUBRID PHP module's version
    • CURL bağlamı seçenekleri - CURL bağlamı seçeneklerinin listesi
    • CURLFile::getFilename - Get file name
    • CURLFile::getMimeType - Get MIME type
    • CURLFile::getPostFilename - Get file name for POST
    • CURLFile::setMimeType - Set MIME type
    • CURLFile::setPostFilename - Set file name for POST
    • CURLFile::__construct - Create a CURLFile object
    • CURLFile::__wakeup - Unserialization handler
    • curl_close - cURL oturumunu sonlandırır
    • curl_copy_handle - Bir cURL tanıtıcısını tüm tercihleriyle kopyalar
    • curl_errno - Belirtilen oturumdaki son hatanın kodunu döndürür
    • curl_error - Belirtilen oturumdaki son hatayı içeren bir dizge döndürür
    • curl_escape - URL encodes the given string
    • curl_exec - Bir cURL oturumunu işleme sokar
    • curl_getinfo - Belli bir oturum ile ilgili bilgi döndürür
    • curl_init - Bir cURL oturumunu ilklendirir
    • curl_multi_add_handle - Tekil cURL tanıtıcısını çoklu cURL tanıtıcısına ekler
    • curl_multi_close - Çoklu tanıtıcıyı kapatır
    • curl_multi_exec - Geçerli cURL tanıtıcısının alt bağlantılarını çalıştırır
    • curl_multi_getcontent - CURLOPT_RETURNTRANSFER etkinse bir cURL tanıtıcısının içeriği döner
    • curl_multi_info_read - Geçerli oturum hakkında bilgi döndürür
    • curl_multi_init - Yeni bir çoklu cURL tanıtıcısı döndürür
    • curl_multi_remove_handle - Bir tekil tanıtıcıyı bir çoklu tanıtıcıdan siler
    • curl_multi_select - Çoklu cURL bağlantısında bir etkinlik olsun diye bekler
    • curl_multi_setopt - Set an option for the cURL multi handle
    • curl_multi_strerror - Return string describing error code
    • curl_pause - Pause and unpause a connection
    • curl_reset - Reset all options of a libcurl session handle
    • curl_setopt - Bir cURL aktarım seçeneği tanımlar
    • curl_setopt_array - Belirtilen cURL oturumuna çok sayıda seçenek atar
    • curl_share_close - Close a cURL share handle
    • curl_share_init - Initialize a cURL share handle
    • curl_share_setopt - Set an option for a cURL share handle.
    • curl_strerror - Return string describing the given error code
    • curl_unescape - Decodes the given URL encoded string
    • curl_version - cURL sürüm bilgilerini döndürür
    • current - Bir diziden gösterici konumundaki elemanı döndürür
    • cyrus_authenticate - Authenticate against a Cyrus IMAP server
    • cyrus_bind - Bind callbacks to a Cyrus IMAP connection
    • cyrus_close - Close connection to a Cyrus IMAP server
    • cyrus_connect - Connect to a Cyrus IMAP server
    • cyrus_query - Send a query to a Cyrus IMAP server
    • cyrus_unbind - Unbind ...
  • d
    • data:// - Data (RFC 2397)
    • date - Yerel tarihi/saati biçimlendirir
    • DateInterval::createFromDateString - Dizgenin göreli kısımlarından bir DateInterval nesnesi döndürür
    • DateInterval::format - Zaman aralığını biçimler
    • DateInterval::__construct - Yeni bir DateInterval nesnesi oluşturur
    • DatePeriod::getDateInterval - Gets the interval
    • DatePeriod::getEndDate - Gets the end date
    • DatePeriod::getStartDate - Gets the start date
    • DatePeriod::__construct - Yeni bir DatePeriod nesnesi oluşturur
    • DateTime::add - Adds an amount of days, months, years, hours, minutes and seconds to a DateTime object
    • DateTime::createFromFormat - Parses a time string according to a specified format
    • DateTime::getLastErrors - Returns the warnings and errors
    • DateTime::modify - Alters the timestamp
    • DateTime::setDate - Sets the date
    • DateTime::setISODate - Sets the ISO date
    • DateTime::setTime - Sets the time
    • DateTime::setTimestamp - Sets the date and time based on an Unix timestamp
    • DateTime::setTimezone - Sets the time zone for the DateTime object
    • DateTime::sub - Subtracts an amount of days, months, years, hours, minutes and seconds from a DateTime object
    • DateTime::__construct - Returns new DateTime object
    • DateTime::__set_state - The __set_state handler
    • DateTimeZone::getLocation - Zaman dilimi konum bilgisini döndürür
    • DateTimeZone::getName - Zaman diliminin adını döndürür
    • DateTimeZone::getOffset - Returns the timezone offset from GMT
    • DateTimeZone::getTransitions - Returns all transitions for the timezone
    • DateTimeZone::listAbbreviations - Returns associative array containing dst, offset and the timezone name
    • DateTimeZone::listIdentifiers - Returns a numerically indexed array containing all defined timezone identifiers
    • DateTimeZone::__construct - Yeni bir DateTimeZone nesnesi oluşturur
    • date_add - DateTime::add işlevinin takma adıdır
    • date_create - DateTime::__construct için bir takma ad
    • date_create_from_format - DateTime::createFromFormat işlevinin takma adıdır
    • date_create_immutable - Takma Adı: DateTimeImmutable::__construct
    • date_create_immutable_from_format - Takma Adı: DateTimeImmutable::createFromFormat
    • date_date_set - DateTime::setDate işlevinin takma adıdır
    • date_default_timezone_get - Betik içerisindeki tüm tarih/zaman işlevleri tarafından kullanılan öntanımlı zaman dilimini getirir
    • date_default_timezone_set - Betik içerisindeki tüm tarih/zaman işlevleri tarafından kullanılan öntanımlı zaman dilimini ayarlar
    • date_diff - DateTime::diff işlevinin takma adıdır
    • date_format - DateTime::format işlevinin takma adıdır
    • date_get_last_errors - DateTime::getLastErrors işlevinin takma adıdır
    • date_interval_create_from_date_string - DateInterval::createFromDateString işlevinin takma adıdır
    • date_interval_format - DateInterval::format işlevinin takma adıdır
    • date_isodate_set - DateTime::setISODate işlevinin takma adıdır
    • date_modify - DateTime::modify işlevinin takma adıdır
    • date_offset_get - DateTime::getOffset işlevinin takma adıdır
    • date_parse - Verilen tarih hakkındaki ayrıntılı bilgiyi ilişkisel dizi olarak döndürür
    • date_parse_from_format - Get info about given date formatted according to the specified format
    • date_sub - DateTime::sub işlevinin takma adıdır
    • date_sunrise - Belirtilen gün ve konum için şafak zamanını döndürür
    • date_sunset - Verilen gün ve konum için günbatımı zamanını döndürür
    • date_sun_info - Güneşin doğuşu/batışı ve alacakaranlık başlangıcı/sonu hakkında bilgi içeren bir dizi döndürür
    • date_timestamp_get - DateTime::getTimestamp işlevinin takma adıdır
    • date_timestamp_set - DateTime::setTimestamp işlevinin takma adıdır
    • date_timezone_get - DateTime::getTimezone işlevinin takma adıdır
    • date_timezone_set - DateTime::setTimezone işlevinin takma adıdır
    • date_time_set - DateTime::setTime işlevinin takma adıdır
    • db2_autocommit - Returns or sets the AUTOCOMMIT state for a database connection
    • db2_bind_param - Binds a PHP variable to an SQL statement parameter
    • db2_client_info - Returns an object with properties that describe the DB2 database client
    • db2_close - Closes a database connection
    • db2_columns - Returns a result set listing the columns and associated metadata for a table
    • db2_column_privileges - Returns a result set listing the columns and associated privileges for a table
    • db2_commit - Commits a transaction
    • db2_connect - Returns a connection to a database
    • db2_conn_error - Returns a string containing the SQLSTATE returned by the last connection attempt
    • db2_conn_errormsg - Returns the last connection error message and SQLCODE value
    • db2_cursor_type - Returns the cursor type used by a statement resource
    • db2_escape_string - Used to escape certain characters
    • db2_exec - Executes an SQL statement directly
    • db2_execute - Executes a prepared SQL statement
    • db2_fetch_array - Returns an array, indexed by column position, representing a row in a result set
    • db2_fetch_assoc - Returns an array, indexed by column name, representing a row in a result set
    • db2_fetch_both - Returns an array, indexed by both column name and position, representing a row in a result set
    • db2_fetch_object - Returns an object with properties representing columns in the fetched row
    • db2_fetch_row - Sets the result set pointer to the next row or requested row
    • db2_field_display_size - Returns the maximum number of bytes required to display a column
    • db2_field_name - Returns the name of the column in the result set
    • db2_field_num - Returns the position of the named column in a result set
    • db2_field_precision - Returns the precision of the indicated column in a result set
    • db2_field_scale - Returns the scale of the indicated column in a result set
    • db2_field_type - Returns the data type of the indicated column in a result set
    • db2_field_width - Returns the width of the current value of the indicated column in a result set
    • db2_foreign_keys - Returns a result set listing the foreign keys for a table
    • db2_free_result - Frees resources associated with a result set
    • db2_free_stmt - Frees resources associated with the indicated statement resource
    • db2_get_option - Retrieves an option value for a statement resource or a connection resource
    • db2_last_insert_id - Returns the auto generated ID of the last insert query that successfully executed on this connection
    • db2_lob_read - Gets a user defined size of LOB files with each invocation
    • db2_next_result - Requests the next result set from a stored procedure
    • db2_num_fields - Returns the number of fields contained in a result set
    • db2_num_rows - Returns the number of rows affected by an SQL statement
    • db2_pclose - Closes a persistent database connection
    • db2_pconnect - Returns a persistent connection to a database
    • db2_prepare - Prepares an SQL statement to be executed
    • db2_primary_keys - Returns a result set listing primary keys for a table
    • db2_procedures - Returns a result set listing the stored procedures registered in a database
    • db2_procedure_columns - Returns a result set listing stored procedure parameters
    • db2_result - Returns a single column from a row in the result set
    • db2_rollback - Rolls back a transaction
    • db2_server_info - Returns an object with properties that describe the DB2 database server
    • db2_set_option - Set options for connection or statement resources
    • db2_special_columns - Returns a result set listing the unique row identifier columns for a table
    • db2_statistics - Returns a result set listing the index and statistics for a table
    • db2_stmt_error - Returns a string containing the SQLSTATE returned by an SQL statement
    • db2_stmt_errormsg - Returns a string containing the last SQL statement error message
    • db2_tables - Returns a result set listing the tables and associated metadata in a database
    • db2_table_privileges - Returns a result set listing the tables and associated privileges in a database
    • dbase_add_record - Adds a record to a database
    • dbase_close - Closes a database
    • dbase_create - Creates a database
    • dbase_delete_record - Deletes a record from a database
    • dbase_get_header_info - Gets the header info of a database
    • dbase_get_record - Gets a record from a database as an indexed array
    • dbase_get_record_with_names - Gets a record from a database as an associative array
    • dbase_numfields - Gets the number of fields of a database
    • dbase_numrecords - Gets the number of records in a database
    • dbase_open - Opens a database
    • dbase_pack - Packs a database
    • dbase_replace_record - Replaces a record in a database
    • dba_close - Close a DBA database
    • dba_delete - Delete DBA entry specified by key
    • dba_exists - Check whether key exists
    • dba_fetch - Fetch data specified by key
    • dba_firstkey - Fetch first key
    • dba_handlers - List all the handlers available
    • dba_insert - Insert entry
    • dba_key_split - Splits a key in string representation into array representation
    • dba_list - List all open database files
    • dba_nextkey - Fetch next key
    • dba_open - Open database
    • dba_optimize - Optimize database
    • dba_popen - Open database persistently
    • dba_replace - Replace or insert entry
    • dba_sync - Synchronize database
    • dbplus_add - Add a tuple to a relation
    • dbplus_aql - Perform AQL query
    • dbplus_chdir - Get/Set database virtual current directory
    • dbplus_close - Close a relation
    • dbplus_curr - Get current tuple from relation
    • dbplus_errcode - Get error string for given errorcode or last error
    • dbplus_errno - Get error code for last operation
    • dbplus_find - Set a constraint on a relation
    • dbplus_first - Get first tuple from relation
    • dbplus_flush - Flush all changes made on a relation
    • dbplus_freealllocks - Free all locks held by this client
    • dbplus_freelock - Release write lock on tuple
    • dbplus_freerlocks - Free all tuple locks on given relation
    • dbplus_getlock - Get a write lock on a tuple
    • dbplus_getunique - Get an id number unique to a relation
    • dbplus_info - Get information about a relation
    • dbplus_last - Get last tuple from relation
    • dbplus_lockrel - Request write lock on relation
    • dbplus_next - Get next tuple from relation
    • dbplus_open - Open relation file
    • dbplus_prev - Get previous tuple from relation
    • dbplus_rchperm - Change relation permissions
    • dbplus_rcreate - Creates a new DB++ relation
    • dbplus_rcrtexact - Creates an exact but empty copy of a relation including indices
    • dbplus_rcrtlike - Creates an empty copy of a relation with default indices
    • dbplus_resolve - Resolve host information for relation
    • dbplus_restorepos - Restore position
    • dbplus_rkeys - Specify new primary key for a relation
    • dbplus_ropen - Open relation file local
    • dbplus_rquery - Perform local (raw) AQL query
    • dbplus_rrename - Rename a relation
    • dbplus_rsecindex - Create a new secondary index for a relation
    • dbplus_runlink - Remove relation from filesystem
    • dbplus_rzap - Remove all tuples from relation
    • dbplus_savepos - Save position
    • dbplus_setindex - Set index
    • dbplus_setindexbynumber - Set index by number
    • dbplus_sql - Perform SQL query
    • dbplus_tcl - Execute TCL code on server side
    • dbplus_tremove - Remove tuple and return new current tuple
    • dbplus_undo - Undo
    • dbplus_undoprepare - Prepare undo
    • dbplus_unlockrel - Give up write lock on relation
    • dbplus_unselect - Remove a constraint from relation
    • dbplus_update - Update specified tuple in relation
    • dbplus_xlockrel - Request exclusive lock on relation
    • dbplus_xunlockrel - Free exclusive lock on relation
    • dbx_close - Close an open connection/database
    • dbx_compare - Compare two rows for sorting purposes
    • dbx_connect - Open a connection/database
    • dbx_error - Report the error message of the latest function call in the module
    • dbx_escape_string - Escape a string so it can safely be used in an sql-statement
    • dbx_fetch_row - Fetches rows from a query-result that had the DBX_RESULT_UNBUFFERED flag set
    • dbx_query - Send a query and fetch all results (if any)
    • dbx_sort - Sort a result from a dbx_query by a custom sort function
    • dcgettext - Belirtilen arama için geçerli uygulama adını değiştirir
    • dcngettext - dcgettext işlevinin çoğul biçemli sürümü
    • debug_backtrace - Hata izleme raporunu bir dizi olarak üretir
    • debug_print_backtrace - Bir hata izleme raporu basar
    • debug_zval_dump - Dahili bir zend değerinin dizgesel gösterimini çıktıya dökümler
    • decbin - Decimal to binary
    • dechex - Decimal to hexadecimal
    • decoct - Decimal to octal
    • define - Bir isimli sabit tanımlar
    • defined - Belirtilen isimli sabit tanımlı mı diye bakar
    • define_syslog_variables - Syslog ile ilgili tüm değişkenleri ilklendirir
    • deflate_add - Incrementally deflate data
    • deflate_init - Initialize an incremental deflate context
    • deg2rad - Converts the number in degrees to the radian equivalent
    • delete - unlink veya unset işlevine bakınız
    • dgettext - Geçerli uygulama adını değiştirir
    • die - exit işlevinin eşdeğeri
    • dio_close - Belirtilen dosya tanıtıcısını kapatır
    • dio_fcntl - Belirtilen dosya tanıtıcısı üzerinde komut çalıştırır
    • dio_open - Belirtilen dosyayı açar ve bu dosya için bir dosya tanıtıcısı döndürür
    • dio_read - Bir dosya tanıtıcısından baytları okur
    • dio_seek - Dosya tanıtıcısında konumu bir yerden başka bir yere taşır
    • dio_stat - Belirtilen dosya tanıtıcısı hakkında durum bilgisi döndürür
    • dio_tcsetattr - Bir seri portun veri hızını ve uçbirim özniteliklerini tanımlar
    • dio_truncate - Dosya tanıtıcısındaki bayt sayısını sınırlar
    • dio_write - Veriyi (uzunluğunu isteğe bağlı olarak kırparak) dosya tanıtıcısına yazar
    • dir - Return an instance of the Directory class
    • Directory::close - Close directory handle
    • Directory::read - Read entry from directory handle
    • Directory::rewind - Rewind directory handle
    • DirectoryIterator::current - Return the current DirectoryIterator item.
    • DirectoryIterator::getATime - Get last access time of the current DirectoryIterator item
    • DirectoryIterator::getBasename - Get base name of current DirectoryIterator item.
    • DirectoryIterator::getCTime - Get inode change time of the current DirectoryIterator item
    • DirectoryIterator::getExtension - Gets the file extension
    • DirectoryIterator::getFilename - Return file name of current DirectoryIterator item.
    • DirectoryIterator::getGroup - Get group for the current DirectoryIterator item
    • DirectoryIterator::getInode - Get inode for the current DirectoryIterator item
    • DirectoryIterator::getMTime - Get last modification time of current DirectoryIterator item
    • DirectoryIterator::getOwner - Get owner of current DirectoryIterator item
    • DirectoryIterator::getPath - Get path of current Iterator item without filename
    • DirectoryIterator::getPathname - Return path and file name of current DirectoryIterator item
    • DirectoryIterator::getPerms - Get the permissions of current DirectoryIterator item
    • DirectoryIterator::getSize - Get size of current DirectoryIterator item
    • DirectoryIterator::getType - Determine the type of the current DirectoryIterator item
    • DirectoryIterator::isDir - Determine if current DirectoryIterator item is a directory
    • DirectoryIterator::isDot - Determine if current DirectoryIterator item is '.' or '..'
    • DirectoryIterator::isExecutable - Determine if current DirectoryIterator item is executable
    • DirectoryIterator::isFile - Determine if current DirectoryIterator item is a regular file
    • DirectoryIterator::isLink - Determine if current DirectoryIterator item is a symbolic link
    • DirectoryIterator::isReadable - Determine if current DirectoryIterator item can be read
    • DirectoryIterator::isWritable - Determine if current DirectoryIterator item can be written to
    • DirectoryIterator::key - Return the key for the current DirectoryIterator item
    • DirectoryIterator::next - Move forward to next DirectoryIterator item
    • DirectoryIterator::rewind - Rewind the DirectoryIterator back to the start
    • DirectoryIterator::seek - Seek to a DirectoryIterator item
    • DirectoryIterator::valid - Check whether current DirectoryIterator position is a valid file
    • DirectoryIterator::__construct - Constructs a new directory iterator from a path
    • DirectoryIterator::__toString - Get file name as a string
    • dirname - Belirtilen dosya yolunun dizin bileşenini döndürür
    • diskfreespace - disk_free_space işlevinin takma adıdır
    • disk_free_space - Dizindeki kullanılabilir bayt sayısını döndürür
    • disk_total_space - Bir dizinin toplam boyunu döndürür
    • dl - Belirtilen PHP eklentisini çalışma anında yükler
    • dngettext - dgettext işlevinin çoğul biçemli sürümü
    • dns_check_record - checkdnsrr işlevinin takma adıdır
    • dns_get_mx - getmxrr işlevinin takma adıdır
    • dns_get_record - Belirtilen konak adı ile ilgili DNS Özkaynak Kayıtlarını getirir
    • DOMAttr::isId - Öznitelik bir ID mi tanımlıyor diye bakar
    • DOMAttr::__construct - Yeni bir DOMAttr nesnesi oluşturur
    • DOMCharacterData::appendData - Düğümün karakter verisinin sonuna bir dizge ekler
    • DOMCharacterData::deleteData - Düğümden belirtilen alt dizgeyi siler
    • DOMCharacterData::insertData - 16 bitlik birimlerle belirtilen konuma bir dizge yerleştirir
    • DOMCharacterData::replaceData - DOMCharacterData içindeki bir alt dizgeyi değiştirir
    • DOMCharacterData::substringData - Düğümden belli miktarda veri döndürür
    • DOMComment::__construct - Yeni bir DOMComment nesnesi oluşturur
    • DOMDocument::createAttribute - Yeni bir öznitelik düğümü oluşturur
    • DOMDocument::createAttributeNS - Yeni bir isim alanlı öznitelik düğümü oluşturur
    • DOMDocument::createCDATASection - Yeni bir CDATA düğümü oluşturur
    • DOMDocument::createComment - Yeni bir açıklama düğümü oluşturur
    • DOMDocument::createDocumentFragment - Yeni bir belge bölütü oluşturur
    • DOMDocument::createElement - Yeni bir eleman düğümü oluşturur
    • DOMDocument::createElementNS - İsim alanlı bir eleman düğümü oluşturur
    • DOMDocument::createEntityReference - Yeni bir öğe bildirimi düğümü oluşturur
    • DOMDocument::createProcessingInstruction - Yeni bir işlem komutu düğümü oluşturur
    • DOMDocument::createTextNode - Yeni bir metin düğümü oluşturur
    • DOMDocument::getElementById - ID'si belirtilen elemanı döndürür
    • DOMDocument::getElementsByTagName - İsmi belirtilen tüm elemanları döndürür
    • DOMDocument::getElementsByTagNameNS - İsmi ve isim alanı belirtilen tüm elemanları döndürür
    • DOMDocument::importNode - Belgeye bir düğüm dahil eder
    • DOMDocument::load - XML belgeyi bir dosyadan yükler
    • DOMDocument::loadHTML - HTML belgeyi bir dizgeden yükler
    • DOMDocument::loadHTMLFile - HTML belgeyi bir dosyadan yükler
    • DOMDocument::loadXML - XML belgeyi bir dizgeden yükler
    • DOMDocument::normalizeDocument - Belgeyi normalleştirir
    • DOMDocument::registerNodeClass - Temel düğüm türünü oluşturmakta kullanılacak türetilmiş sınıfı belirtmek için kullanılır
    • DOMDocument::relaxNGValidate - Belgeyi belirtilen RNG dosyasıyla doğrular
    • DOMDocument::relaxNGValidateSource - Belgeyi belirtilen RNG dizgesiyle doğrular
    • DOMDocument::save - Dahili XML ağacını bir dizge olarak dosyaya yazar
    • DOMDocument::saveHTML - Dahili belgeyi bir HTML dizgesi olarak çıktılar
    • DOMDocument::saveHTMLFile - Dahili belgeyi bir HTML dizge olarak dosyaya yazar
    • DOMDocument::saveXML - Dahili XML ağacını bir dizge olarak çıktılar
    • DOMDocument::schemaValidate - Belgeyi bir şema dosyasına göre doğrular
    • DOMDocument::schemaValidateSource - Belgeyi bir şema dizgesine göre doğrular
    • DOMDocument::validate - Belgeyi DTD'sine göre doğrular
    • DOMDocument::xinclude - Bir DOMDocument nesnesindeki XInclude dosyalarını belgeye dahil eder
    • DOMDocument::__construct - Yeni bir DOMDocument nesnesi oluşturur
    • DOMDocumentFragment::appendXML - Ham bir XML verisi ekler
    • DOMElement::getAttribute - İsmi belirtilen özniteliğin değerini döndürür
    • DOMElement::getAttributeNode - İsmi belirtilen öznitelik düğümünü döndürür
    • DOMElement::getAttributeNodeNS - İsmi ve isim alanı belirtilen öznitelik düğümünü döndürür
    • DOMElement::getAttributeNS - İsmi ve isim alanı belirtilen özniteliğin değerini döndürür
    • DOMElement::getElementsByTagName - İsmi belirtilen elemanları döndürür
    • DOMElement::getElementsByTagNameNS - İsmi ve isim alanı belirtilen elemanları döndürür
    • DOMElement::hasAttribute - İsmi belirtilen öznitelik mevcut mu diye bakar
    • DOMElement::hasAttributeNS - Belirtilen isim alanlı öznitelik var mı diye bakar
    • DOMElement::removeAttribute - İsmi belirtilen özniteliği siler
    • DOMElement::removeAttributeNode - Belirtilen öznitelik düğümünü siler
    • DOMElement::removeAttributeNS - İsmi ve isim alanı belirtilen özniteliği siler
    • DOMElement::setAttribute - Yeni bir öznitelik ekler
    • DOMElement::setAttributeNode - Elemana yeni bir öznitelik düğümü ekler
    • DOMElement::setAttributeNodeNS - Elemana isim alanlı yeni bir öznitelik düğümü ekler
    • DOMElement::setAttributeNS - İsim alanlı yeni bir öznitelik ekler
    • DOMElement::setIdAttribute - İsmi belirtilen özniteliği bir ID özniteliği olarak tanımlar
    • DOMElement::setIdAttributeNode - Belirtilen öznitelik düğümünü ID türünde bir öznitelik düğümü haline getirir
    • DOMElement::setIdAttributeNS - İsmi ve isim alanı belirtilen özniteliği bir ID özniteliği olarak tanımlar
    • DOMElement::__construct - Yeni bir DOMElement nesnesi oluşturur
    • DOMEntityReference::__construct - Yeni bir DOMEntityReference nesnesi oluşturur
    • DOMImplementation::createDocument - Belge elemanı belirtilen DOMDocument nesnesini oluşturur
    • DOMImplementation::createDocumentType - Boş bir DOMDocumentType nesnesi oluşturur
    • DOMImplementation::hasFeature - DOM gerçeklenimi belirtilen özelliğe sahip mi diye bakar
    • DOMImplementation::__construct - Yeni bir DOMImplementation nesnesi oluşturur
    • DOMNamedNodeMap::getNamedItem - İsmi belirtilen düğümü döndürür
    • DOMNamedNodeMap::getNamedItemNS - İsmi ve isim alanı belirtilen düğümü döndürür
    • DOMNamedNodeMap::item - İndisi belirtilen düğümü döndürür
    • DOMNode::appendChild - Listenin sonuna yeni bir çocuk ekler
    • DOMNode::C14N - Canonicalize nodes to a string
    • DOMNode::C14NFile - Canonicalize nodes to a file
    • DOMNode::cloneNode - Düğümün bir kopyasını yapar
    • DOMNode::getLineNo - Get line number for a node
    • DOMNode::getNodePath - Get an XPath for a node
    • DOMNode::hasAttributes - Düğümün öznitelikleri var mı diye bakar
    • DOMNode::hasChildNodes - Düğümün çocuk düğümleri var mı diye bakar
    • DOMNode::insertBefore - Yeni çocuğu belirtilen çocuğun öncesine yerleştirir
    • DOMNode::isDefaultNamespace - Belirtilen isim alanının öntanımlı olup olmadığına bakar
    • DOMNode::isSameNode - İki düğüm aynı mı diye bakar
    • DOMNode::isSupported - Özelliğin belirtilen sürümünün desteklenip desteklenmediğine bakar
    • DOMNode::lookupNamespaceURI - İsim alanı öneki belirtilen düğümün isim alanı betimleyicisini döndürür
    • DOMNode::lookupPrefix - Belirtilen isim alanıyla ilişkili düğümün isim alanı önekini döndürür
    • DOMNode::normalize - Düğümü normalleştirir
    • DOMNode::removeChild - Listeden belirtilen çocuğu siler
    • DOMNode::replaceChild - Bir çocuk düğümü yenisi ile değiştirir
    • DOMNodelist::item - İndisi belirtilen düğümü döndürür
    • DOMProcessingInstruction::__construct - Yeni bir DOMProcessingInstruction nesnesi oluşturur
    • DOMText::isWhitespaceInElementContent - Düğümün boşluk içerip içermediğini belirtir
    • DOMText::splitText - Düğümü belirtilen konumda iki düğüme böler
    • DOMText::__construct - Yeni bir DOMText nesnesi oluşturur
    • DOMXPath::evaluate - Belirtilen XPath ifadesini çözümler ve mümkünse yazılı bir sonuç verir
    • DOMXPath::query - Belirtilen XPath ifadesini değerlendirir
    • DOMXPath::registerNamespace - Belirtilen isim alanını DOMXPath nesnesi ile ilişkilendirir
    • DOMXPath::registerPhpFunctions - Register PHP functions as XPath functions
    • DOMXPath::__construct - Yeni bir DOMXPath nesnesi oluşturur
    • dom_import_simplexml - Bir SimpleXMLElement düğümü alıp bir DOMElement düğümü döndürür
    • doubleval - floatval işlevinin takma ismidir
    • Ds\Collection::clear - Removes all values.
    • Ds\Collection::copy - Returns a shallow copy of the collection.
    • Ds\Collection::isEmpty - Returns whether the collection is empty
    • Ds\Collection::toArray - Converts the collection to an array.
    • Ds\Deque::allocate - Allocates enough memory for a required capacity.
    • Ds\Deque::apply - Updates all values by applying a callback function to each value.
    • Ds\Deque::capacity - Returns the current capacity.
    • Ds\Deque::clear - Removes all values from the deque.
    • Ds\Deque::contains - Determines if the deque contains given values.
    • Ds\Deque::copy - Returns a shallow copy of the deque.
    • Ds\Deque::count - Returns the number of values in the collection.
    • Ds\Deque::filter - Creates a new deque using a callable to determine which values to include.
    • Ds\Deque::find - Attempts to find a value's index.
    • Ds\Deque::first - Returns the first value in the deque.
    • Ds\Deque::get - Returns the value at a given index.
    • Ds\Deque::insert - Inserts values at a given index.
    • Ds\Deque::isEmpty - Returns whether the deque is empty
    • Ds\Deque::join - Joins all values together as a string.
    • Ds\Deque::jsonSerialize - Returns a representation that can be converted to JSON.
    • Ds\Deque::last - Returns the last value.
    • Ds\Deque::map - Returns the result of applying a callback to each value.
    • Ds\Deque::merge - Returns the result of adding all given values to the deque.
    • Ds\Deque::pop - Removes and returns the last value.
    • Ds\Deque::push - Adds values to the end of the deque.
    • Ds\Deque::reduce - Reduces the deque to a single value using a callback function.
    • Ds\Deque::remove - Removes and returns a value by index.
    • Ds\Deque::reverse - Reverses the deque in-place.
    • Ds\Deque::reversed - Returns a reversed copy.
    • Ds\Deque::rotate - Rotates the deque by a given number of rotations.
    • Ds\Deque::set - Updates a value at a given index.
    • Ds\Deque::shift - Removes and returns the first value.
    • Ds\Deque::slice - Returns a sub-deque of a given range.
    • Ds\Deque::sort - Sorts the deque in-place.
    • Ds\Deque::sorted - Returns a sorted copy.
    • Ds\Deque::sum - Returns the sum of all values in the deque.
    • Ds\Deque::toArray - Converts the deque to an array.
    • Ds\Deque::unshift - Adds values to the front of the deque.
    • Ds\Deque::__construct - Creates a new instance.
    • Ds\Hashable::equals - Determines whether an object is equal to the current instance.
    • Ds\Hashable::hash - Returns a scalar value to be used as a hash value.
    • Ds\Map::allocate - Allocates enough memory for a required capacity.
    • Ds\Map::apply - Updates all values by applying a callback function to each value.
    • Ds\Map::capacity - Returns the current capacity.
    • Ds\Map::clear - Removes all values.
    • Ds\Map::copy - Returns a shallow copy of the map.
    • Ds\Map::count - Returns the number of values in the map.
    • Ds\Map::diff - Creates a new map using keys that aren't in another map.
    • Ds\Map::filter - Creates a new map using a callable to determine which pairs to include.
    • Ds\Map::first - Returns the first pair in the map.
    • Ds\Map::get - Returns the value for a given key.
    • Ds\Map::hasKey - Determines whether the map contains a given key.
    • Ds\Map::hasValue - Determines whether the map contains a given value.
    • Ds\Map::intersect - Creates a new map by intersecting keys with another map.
    • Ds\Map::isEmpty - Returns whether the map is empty
    • Ds\Map::jsonSerialize - Returns a representation that can be converted to JSON.
    • Ds\Map::keys - Returns a set of the map's keys.
    • Ds\Map::ksort - Sorts the map in-place by key.
    • Ds\Map::ksorted - Returns a copy, sorted by key.
    • Ds\Map::last - Returns the last pair of the map.
    • Ds\Map::map - Returns the result of applying a callback to each value.
    • Ds\Map::merge - Returns the result of adding all given associations.
    • Ds\Map::pairs - Returns a sequence containing all the pairs of the map.
    • Ds\Map::put - Associates a key with a value.
    • Ds\Map::putAll - Associates all key-value pairs of a traversable object or array.
    • Ds\Map::reduce - Reduces the map to a single value using a callback function.
    • Ds\Map::remove - Removes and returns a value by key.
    • Ds\Map::reverse - Reverses the map in-place.
    • Ds\Map::reversed - Returns a reversed copy.
    • Ds\Map::skip - Returns the pair at a given positional index.
    • Ds\Map::slice - Returns a subset of the map defined by a starting index and length.
    • Ds\Map::sort - Sorts the map in-place by value.
    • Ds\Map::sorted - Returns a copy, sorted by value.
    • Ds\Map::sum - Returns the sum of all values in the map.
    • Ds\Map::toArray - Converts the map to an array.
    • Ds\Map::union - Creates a new map using values from the current instance and another map.
    • Ds\Map::values - Returns a sequence of the map's values.
    • Ds\Map::xor - Creates a new map using keys of either the current instance or of another map, but not of both.
    • Ds\Map::__construct - Creates a new instance.
    • Ds\Pair::clear - Removes all values.
    • Ds\Pair::copy - Returns a shallow copy of the pair.
    • Ds\Pair::isEmpty - Returns whether the pair is empty
    • Ds\Pair::jsonSerialize - Returns a representation that can be converted to JSON.
    • Ds\Pair::toArray - Converts the pair to an array.
    • Ds\Pair::__construct - Creates a new instance.
    • Ds\PriorityQueue::allocate - Allocates enough memory for a required capacity.
    • Ds\PriorityQueue::capacity - Returns the current capacity.
    • Ds\PriorityQueue::clear - Removes all values.
    • Ds\PriorityQueue::copy - Returns a shallow copy of the queue.
    • Ds\PriorityQueue::count - Returns the number of values in the queue.
    • Ds\PriorityQueue::isEmpty - Returns whether the queue is empty
    • Ds\PriorityQueue::jsonSerialize - Returns a representation that can be converted to JSON.
    • Ds\PriorityQueue::peek - Returns the value at the front of the queue.
    • Ds\PriorityQueue::pop - Removes and returns the value with the highest priority.
    • Ds\PriorityQueue::push - Pushes values into the queue.
    • Ds\PriorityQueue::toArray - Converts the queue to an array.
    • Ds\PriorityQueue::__construct - Creates a new instance.
    • Ds\Queue::allocate - Allocates enough memory for a required capacity.
    • Ds\Queue::capacity - Returns the current capacity.
    • Ds\Queue::clear - Removes all values.
    • Ds\Queue::copy - Returns a shallow copy of the queue.
    • Ds\Queue::count - Returns the number of values in the queue.
    • Ds\Queue::isEmpty - Returns whether the queue is empty
    • Ds\Queue::jsonSerialize - Returns a representation that can be converted to JSON.
    • Ds\Queue::peek - Returns the value at the front of the queue.
    • Ds\Queue::pop - Removes and returns the value at the front of the queue.
    • Ds\Queue::push - Pushes values into the queue.
    • Ds\Queue::toArray - Converts the queue to an array.
    • Ds\Queue::__construct - Creates a new instance.
    • Ds\Sequence::allocate - Allocates enough memory for a required capacity.
    • Ds\Sequence::apply - Updates all values by applying a callback function to each value.
    • Ds\Sequence::capacity - Returns the current capacity.
    • Ds\Sequence::contains - Determines if the sequence contains given values.
    • Ds\Sequence::filter - Creates a new sequence using a callable to determine which values to include.
    • Ds\Sequence::find - Attempts to find a value's index.
    • Ds\Sequence::first - Returns the first value in the sequence.
    • Ds\Sequence::get - Returns the value at a given index.
    • Ds\Sequence::insert - Inserts values at a given index.
    • Ds\Sequence::join - Joins all values together as a string.
    • Ds\Sequence::last - Returns the last value.
    • Ds\Sequence::map - Returns the result of applying a callback to each value.
    • Ds\Sequence::merge - Returns the result of adding all given values to the sequence.
    • Ds\Sequence::pop - Removes and returns the last value.
    • Ds\Sequence::push - Adds values to the end of the sequence.
    • Ds\Sequence::reduce - Reduces the sequence to a single value using a callback function.
    • Ds\Sequence::remove - Removes and returns a value by index.
    • Ds\Sequence::reverse - Reverses the sequence in-place.
    • Ds\Sequence::reversed - Returns a reversed copy.
    • Ds\Sequence::rotate - Rotates the sequence by a given number of rotations.
    • Ds\Sequence::set - Updates a value at a given index.
    • Ds\Sequence::shift - Removes and returns the first value.
    • Ds\Sequence::slice - Returns a sub-sequence of a given range.
    • Ds\Sequence::sort - Sorts the sequence in-place.
    • Ds\Sequence::sorted - Returns a sorted copy.
    • Ds\Sequence::sum - Returns the sum of all values in the sequence.
    • Ds\Sequence::unshift - Adds values to the front of the sequence.
    • Ds\Set::add - Adds values to the set.
    • Ds\Set::allocate - Allocates enough memory for a required capacity.
    • Ds\Set::capacity - Returns the current capacity.
    • Ds\Set::clear - Removes all values.
    • Ds\Set::contains - Determines if the set contains all values.
    • Ds\Set::copy - Returns a shallow copy of the set.
    • Ds\Set::count - Returns the number of values in the set.
    • Ds\Set::diff - Creates a new set using values that aren't in another set.
    • Ds\Set::filter - Creates a new set using a callable to determine which values to include.
    • Ds\Set::first - Returns the first value in the set.
    • Ds\Set::get - Returns the value at a given index.
    • Ds\Set::intersect - Creates a new set by intersecting values with another set.
    • Ds\Set::isEmpty - Returns whether the set is empty
    • Ds\Set::join - Joins all values together as a string.
    • Ds\Set::jsonSerialize - Returns a representation that can be converted to JSON.
    • Ds\Set::last - Returns the last value in the set.
    • Ds\Set::merge - Returns the result of adding all given values to the set.
    • Ds\Set::reduce - Reduces the set to a single value using a callback function.
    • Ds\Set::remove - Removes all given values from the set.
    • Ds\Set::reverse - Reverses the set in-place.
    • Ds\Set::reversed - Returns a reversed copy.
    • Ds\Set::slice - Returns a sub-set of a given range.
    • Ds\Set::sort - Sorts the set in-place.
    • Ds\Set::sorted - Returns a sorted copy.
    • Ds\Set::sum - Returns the sum of all values in the set.
    • Ds\Set::toArray - Converts the set to an array.
    • Ds\Set::union - Creates a new set using values from the current instance and another set.
    • Ds\Set::xor - Creates a new set using values in either the current instance or in another set, but not in both.
    • Ds\Set::__construct - Creates a new instance.
    • Ds\Stack::allocate - Allocates enough memory for a required capacity.
    • Ds\Stack::capacity - Returns the current capacity.
    • Ds\Stack::clear - Removes all values.
    • Ds\Stack::copy - Returns a shallow copy of the stack.
    • Ds\Stack::count - Returns the number of values in the stack.
    • Ds\Stack::isEmpty - Returns whether the stack is empty
    • Ds\Stack::jsonSerialize - Returns a representation that can be converted to JSON.
    • Ds\Stack::peek - Returns the value at the top of the stack.
    • Ds\Stack::pop - Removes and returns the value at the top of the stack.
    • Ds\Stack::push - Pushes values onto the stack.
    • Ds\Stack::toArray - Converts the stack to an array.
    • Ds\Stack::__construct - Creates a new instance.
    • Ds\Vector::allocate - Allocates enough memory for a required capacity.
    • Ds\Vector::apply - Updates all values by applying a callback function to each value.
    • Ds\Vector::capacity - Returns the current capacity.
    • Ds\Vector::clear - Removes all values.
    • Ds\Vector::contains - Determines if the vector contains given values.
    • Ds\Vector::copy - Returns a shallow copy of the vector.
    • Ds\Vector::count - Returns the number of values in the collection.
    • Ds\Vector::filter - Creates a new vector using a callable to determine which values to include.
    • Ds\Vector::find - Attempts to find a value's index.
    • Ds\Vector::first - Returns the first value in the vector.
    • Ds\Vector::get - Returns the value at a given index.
    • Ds\Vector::insert - Inserts values at a given index.
    • Ds\Vector::isEmpty - Returns whether the vector is empty
    • Ds\Vector::join - Joins all values together as a string.
    • Ds\Vector::jsonSerialize - Returns a representation that can be converted to JSON.
    • Ds\Vector::last - Returns the last value.
    • Ds\Vector::map - Returns the result of applying a callback to each value.
    • Ds\Vector::merge - Returns the result of adding all given values to the vector.
    • Ds\Vector::pop - Removes and returns the last value.
    • Ds\Vector::push - Adds values to the end of the vector.
    • Ds\Vector::reduce - Reduces the vector to a single value using a callback function.
    • Ds\Vector::remove - Removes and returns a value by index.
    • Ds\Vector::reverse - Reverses the vector in-place.
    • Ds\Vector::reversed - Returns a reversed copy.
    • Ds\Vector::rotate - Rotates the vector by a given number of rotations.
    • Ds\Vector::set - Updates a value at a given index.
    • Ds\Vector::shift - Removes and returns the first value.
    • Ds\Vector::slice - Returns a sub-vector of a given range.
    • Ds\Vector::sort - Sorts the vector in-place.
    • Ds\Vector::sorted - Returns a sorted copy.
    • Ds\Vector::sum - Returns the sum of all values in the vector.
    • Ds\Vector::toArray - Converts the vector to an array.
    • Ds\Vector::unshift - Adds values to the front of the vector.
    • Ds\Vector::__construct - Creates a new instance.
  • e
    • each - Bir diziden, gösterici konumundaki anahtar değer çiftini döndürdükten sonra göstericiyi bir ilerletir
    • easter_date - Verilen yıl için paskalya gece yarısının unix zaman damgasını döner
    • easter_days - Verilen yıl için Paskalya zamanına, 21 Marttan sonraki kalan gün sayısını verir.
    • echo - Bir veya daha fazla dizgeyi çıktılar
    • eio_busy - Artificially increase load. Could be useful in tests, benchmarking.
    • eio_cancel - Cancels a request
    • eio_chmod - Change file/direcrory permissions.
    • eio_chown - Change file/direcrory permissions.
    • eio_close - Close file
    • eio_custom - Execute custom request like any other eio_* call.
    • eio_dup2 - Duplicate a file descriptor
    • eio_event_loop - Polls libeio until all requests proceeded
    • eio_fallocate - Allows the caller to directly manipulate the allocated disk space for a file
    • eio_fchmod - Change file permissions.
    • eio_fchown - Change file ownership
    • eio_fdatasync - Synchronize a file's in-core state with storage device.
    • eio_fstat - Get file status
    • eio_fstatvfs - Get file system statistics
    • eio_fsync - Synchronize a file's in-core state with storage device
    • eio_ftruncate - Truncate a file
    • eio_futime - Change file last access and modification times
    • eio_get_event_stream - Get stream representing a variable used in internal communications with libeio.
    • eio_get_last_error - Returns string describing the last error associated with a request resource
    • eio_grp - Creates a request group.
    • eio_grp_add - Adds a request to the request group.
    • eio_grp_cancel - Cancels a request group
    • eio_grp_limit - Set group limit
    • eio_init - (Re-)initialize Eio
    • eio_link - Create a hardlink for file
    • eio_lstat - Get file status
    • eio_mkdir - Create directory
    • eio_mknod - Create a special or ordinary file.
    • eio_nop - Does nothing, except go through the whole request cycle.
    • eio_npending - Returns number of finished, but unhandled requests
    • eio_nready - Returns number of not-yet handled requests
    • eio_nreqs - Returns number of requests to be processed
    • eio_nthreads - Returns number of threads currently in use
    • eio_open - Opens a file
    • eio_poll - Can be to be called whenever there are pending requests that need finishing.
    • eio_read - Read from a file descriptor at given offset.
    • eio_readahead - Perform file readahead into page cache
    • eio_readdir - Reads through a whole directory
    • eio_readlink - Read value of a symbolic link.
    • eio_realpath - Get the canonicalized absolute pathname.
    • eio_rename - Change the name or location of a file.
    • eio_rmdir - Remove a directory
    • eio_seek - Repositions the offset of the open file associated with the fd argument to the argument offset according to the directive whence
    • eio_sendfile - Transfer data between file descriptors
    • eio_set_max_idle - Set maximum number of idle threads.
    • eio_set_max_parallel - Set maximum parallel threads
    • eio_set_max_poll_reqs - Set maximum number of requests processed in a poll.
    • eio_set_max_poll_time - Set maximum poll time
    • eio_set_min_parallel - Set minimum parallel thread number
    • eio_stat - Get file status
    • eio_statvfs - Get file system statistics
    • eio_symlink - Create a symbolic link
    • eio_sync - Commit buffer cache to disk
    • eio_syncfs - Calls Linux' syncfs syscall, if available
    • eio_sync_file_range - Sync a file segment with disk
    • eio_truncate - Truncate a file
    • eio_unlink - Delete a name and possibly the file it refers to
    • eio_utime - Change file last access and modification times.
    • eio_write - Write to file
    • empty - Bir değişkenin boş olup olmadığını saptar
    • EmptyIterator::current - The current() method
    • EmptyIterator::key - The key() method
    • EmptyIterator::next - The next() method
    • EmptyIterator::rewind - The rewind() method
    • EmptyIterator::valid - The valid() method
    • enchant_broker_describe - Enumerates the Enchant providers
    • enchant_broker_dict_exists - Whether a dictionary exists or not. Using non-empty tag
    • enchant_broker_free - Free the broker resource and its dictionnaries
    • enchant_broker_free_dict - Free a dictionary resource
    • enchant_broker_get_dict_path - Get the directory path for a given backend
    • enchant_broker_get_error - Returns the last error of the broker
    • enchant_broker_init - create a new broker object capable of requesting
    • enchant_broker_list_dicts - Returns a list of available dictionaries
    • enchant_broker_request_dict - create a new dictionary using a tag
    • enchant_broker_request_pwl_dict - creates a dictionary using a PWL file
    • enchant_broker_set_dict_path - Set the directory path for a given backend
    • enchant_broker_set_ordering - Declares a preference of dictionaries to use for the language
    • enchant_dict_add_to_personal - add a word to personal word list
    • enchant_dict_add_to_session - add 'word' to this spell-checking session
    • enchant_dict_check - Check whether a word is correctly spelled or not
    • enchant_dict_describe - Describes an individual dictionary
    • enchant_dict_get_error - Returns the last error of the current spelling-session
    • enchant_dict_is_in_session - whether or not 'word' exists in this spelling-session
    • enchant_dict_quick_check - Check the word is correctly spelled and provide suggestions
    • enchant_dict_store_replacement - Add a correction for a word
    • enchant_dict_suggest - Will return a list of values if any of those pre-conditions are not met
    • end - Bir dizinin dahili göstericisini sonuncu elemana konumlandırır
    • ereg - Düzenli ifadeyi eşleştirir
    • eregi - Düzenli ifadeyi harf büyüklüğüne duyarsız olarak eşleştirir
    • eregi_replace - Düzenli ifadeye göre dizgede harf büyüklüğüne duyarsız olarak değişiklik yapar
    • ereg_replace - Düzenli ifadeye göre dizgede değişiklik yapar
    • ErrorException::getSeverity - İstisnanın önem derecesi ile döner
    • ErrorException::__construct - İstisna oluşturur
    • error_clear_last - Clear the most recent error
    • error_get_last - Son oluşan hata hakkında bilgi verir
    • error_log - Bir yerlere bir hata iletisi gönderir
    • error_reporting - Hangi PHP hatalarının raporlanacağını tanımlar
    • escapeshellarg - Bir komutun değiştirge dizgesini önceler
    • escapeshellcmd - Kabuk meta karakterlerini önceler
    • Ev::backend - Returns an integer describing the backend used by libev.
    • Ev::depth - Returns recursion depth
    • Ev::embeddableBackends - Returns the set of backends that are embeddable in other event loops.
    • Ev::feedSignal - Feed a signal event info Ev
    • Ev::feedSignalEvent - Feed signal event into the default loop
    • Ev::iteration - Return the number of times the default event loop has polled for new events.
    • Ev::now - Returns the time when the last iteration of the default event loop has started.
    • Ev::nowUpdate - Establishes the current time by querying the kernel, updating the time returned by Ev::now in the progress.
    • Ev::recommendedBackends - Returns a bit mask of recommended backends for current platform.
    • Ev::resume - Resume previously suspended default event loop
    • Ev::run - Begin checking for events and calling callbacks for the default loop
    • Ev::sleep - Block the process for the given number of seconds.
    • Ev::stop - Stops the default event loop
    • Ev::supportedBackends - Returns the set of backends supported by current libev configuration.
    • Ev::suspend - Suspend the default event loop
    • Ev::time - Returns the current time in fractional seconds since the epoch.
    • Ev::verify - Performs internal consistency checks(for debugging)
    • eval - Bir dizgeyi bir PHP kodu olarak yorumlar
    • EvCheck::createStopped - Create instance of a stopped EvCheck watcher
    • EvCheck::__construct - Constructs the EvCheck watcher object
    • EvChild::createStopped - Create instance of a stopped EvCheck watcher
    • EvChild::set - Configures the watcher
    • EvChild::__construct - Constructs the EvChild watcher object
    • EvEmbed::createStopped - Create stopped EvEmbed watcher object
    • EvEmbed::set - Configures the watcher
    • EvEmbed::sweep - Make a single, non-blocking sweep over the embedded loop.
    • EvEmbed::__construct - Constructs the EvEmbed object
    • Event::add - Makes event pending
    • Event::addSignal - Makes signal event pending
    • Event::addTimer - Makes timer event pending
    • Event::del - Makes event non-pending
    • Event::delSignal - Makes signal event non-pending
    • Event::delTimer - Makes timer event non-pending
    • Event::free - Make event non-pending and free resources allocated for this event.
    • Event::getSupportedMethods - Returns array with of the names of the methods supported in this version of Libevent
    • Event::pending - Detects whether event is pending or scheduled
    • Event::set - Re-configures event
    • Event::setPriority - Set event priority
    • Event::setTimer - Re-configures timer event
    • Event::signal - Constructs signal event object
    • Event::timer - Constructs timer event object
    • Event::__construct - Constructs Event object
    • EventBase::dispatch - Dispatch pending events
    • EventBase::exit - Stop dispatching events
    • EventBase::free - Free resources allocated for this event base
    • EventBase::getFeatures - Returns bitmask of features supported
    • EventBase::getMethod - Returns event method in use
    • EventBase::getTimeOfDayCached - Returns the current event base time
    • EventBase::gotExit - Checks if the event loop was told to exit
    • EventBase::gotStop - Checks if the event loop was told to exit
    • EventBase::loop - Dispatch pending events
    • EventBase::priorityInit - Sets number of priorities per event base
    • EventBase::reInit - Re-initialize event base(after a fork).
    • EventBase::stop - Tells event_base to stop dispatching events
    • EventBase::__construct - Constructs EventBase object
    • EventBuffer::add - Append data to the end of an event buffer
    • EventBuffer::addBuffer - Move all data from a buffer provided to the current instance of EventBuffer
    • EventBuffer::appendFrom - Moves the specified number of bytes from a source buffer to the end of the current buffer
    • EventBuffer::copyout - Copies out specified number of bytes from the front of the buffer
    • EventBuffer::drain - Removes specified number of bytes from the front of the buffer without copying it anywhere
    • EventBuffer::enableLocking - Açıklama
    • EventBuffer::expand - Reserves space in buffer
    • EventBuffer::freeze - Prevent calls that modify an event buffer from succeeding
    • EventBuffer::lock - Acquires a lock on buffer
    • EventBuffer::prepend - Prepend data to the front of the buffer
    • EventBuffer::prependBuffer - Moves all data from source buffer to the front of current buffer
    • EventBuffer::pullup - Linearizes data within buffer and returns it's contents as a string
    • EventBuffer::read - Read data from an evbuffer and drain the bytes read
    • EventBuffer::readFrom - Read data from a file onto the end of the buffer
    • EventBuffer::readLine - Extracts a line from the front of the buffer
    • EventBuffer::search - Scans the buffer for an occurrence of a string
    • EventBuffer::searchEol - Scans the buffer for an occurrence of an end of line
    • EventBuffer::substr - Substracts a portion of the buffer data
    • EventBuffer::unfreeze - Re-enable calls that modify an event buffer
    • EventBuffer::unlock - Releases lock acquired by EventBuffer::lock
    • EventBuffer::write - Write contents of the buffer to a file or socket
    • EventBuffer::__construct - Constructs EventBuffer object
    • EventBufferEvent::close - Closes file descriptor associated with the current buffer event
    • EventBufferEvent::connect - Connect buffer event's file descriptor to given address or UNIX socket
    • EventBufferEvent::connectHost - Connects to a hostname with optionally asyncronous DNS resolving
    • EventBufferEvent::createPair - Creates two buffer events connected to each other
    • EventBufferEvent::disable - Disable events read, write, or both on a buffer event.
    • EventBufferEvent::enable - Enable events read, write, or both on a buffer event.
    • EventBufferEvent::free - Free a buffer event
    • EventBufferEvent::getDnsErrorString - Returns string describing the last failed DNS lookup attempt
    • EventBufferEvent::getEnabled - Returns bitmask of events currently enabled on the buffer event
    • EventBufferEvent::getInput - Returns underlying input buffer associated with current buffer event
    • EventBufferEvent::getOutput - Returns underlying output buffer associated with current buffer event
    • EventBufferEvent::read - Read buffer's data
    • EventBufferEvent::readBuffer - Drains the entire contents of the input buffer and places them into buf
    • EventBufferEvent::setCallbacks - Assigns read, write and event(status) callbacks
    • EventBufferEvent::setPriority - Assign a priority to a bufferevent
    • EventBufferEvent::setTimeouts - Set the read and write timeout for a buffer event
    • EventBufferEvent::setWatermark - Adjusts read and/or write watermarks
    • EventBufferEvent::sslError - Returns most recent OpenSSL error reported on the buffer event
    • EventBufferEvent::sslFilter - Create a new SSL buffer event to send its data over another buffer event
    • EventBufferEvent::sslGetCipherInfo - Returns a textual description of the cipher.
    • EventBufferEvent::sslGetCipherName - Returns the current cipher name of the SSL connection.
    • EventBufferEvent::sslGetCipherVersion - Returns version of cipher used by current SSL connection.
    • EventBufferEvent::sslGetProtocol - Returns the name of the protocol used for current SSL connection.
    • EventBufferEvent::sslRenegotiate - Tells a bufferevent to begin SSL renegotiation.
    • EventBufferEvent::sslSocket - Creates a new SSL buffer event to send its data over an SSL on a socket
    • EventBufferEvent::write - Adds data to a buffer event's output buffer
    • EventBufferEvent::writeBuffer - Adds contents of the entire buffer to a buffer event's output buffer
    • EventBufferEvent::__construct - Constructs EventBufferEvent object
    • EventConfig::avoidMethod - Tells libevent to avoid specific event method
    • EventConfig::requireFeatures - Enters a required event method feature that the application demands
    • EventConfig::setMaxDispatchInterval - Prevents priority inversion
    • EventConfig::__construct - Constructs EventConfig object
    • EventDnsBase::addNameserverIp - Adds a nameserver to the DNS base
    • EventDnsBase::addSearch - Adds a domain to the list of search domains
    • EventDnsBase::clearSearch - Removes all current search suffixes
    • EventDnsBase::countNameservers - Gets the number of configured nameservers
    • EventDnsBase::loadHosts - Loads a hosts file (in the same format as /etc/hosts) from hosts file
    • EventDnsBase::parseResolvConf - Scans the resolv.conf-formatted file
    • EventDnsBase::setOption - Set the value of a configuration option
    • EventDnsBase::setSearchNdots - Set the 'ndots' parameter for searches
    • EventDnsBase::__construct - Constructs EventDnsBase object
    • EventHttp::accept - Makes an HTTP server accept connections on the specified socket stream or resource
    • EventHttp::addServerAlias - Adds a server alias to the HTTP server object
    • EventHttp::bind - Binds an HTTP server on the specified address and port
    • EventHttp::removeServerAlias - Removes server alias
    • EventHttp::setAllowedMethods - Sets the what HTTP methods are supported in requests accepted by this server, and passed to user callbacks
    • EventHttp::setCallback - Sets a callback for specified URI
    • EventHttp::setDefaultCallback - Sets default callback to handle requests that are not caught by specific callbacks
    • EventHttp::setMaxBodySize - Sets maximum request body size
    • EventHttp::setMaxHeadersSize - Sets maximum HTTP header size
    • EventHttp::setTimeout - Sets the timeout for an HTTP request
    • EventHttp::__construct - Constructs EventHttp object(the HTTP server)
    • EventHttpConnection::getBase - Returns event base associated with the connection
    • EventHttpConnection::getPeer - Gets the remote address and port associated with the connection
    • EventHttpConnection::makeRequest - Makes an HTTP request over the specified connection
    • EventHttpConnection::setCloseCallback - Set callback for connection close
    • EventHttpConnection::setLocalAddress - Sets the IP address from which HTTP connections are made
    • EventHttpConnection::setLocalPort - Sets the local port from which connections are made
    • EventHttpConnection::setMaxBodySize - Sets maximum body size for the connection
    • EventHttpConnection::setMaxHeadersSize - Sets maximum header size
    • EventHttpConnection::setRetries - Sets the retry limit for the connection
    • EventHttpConnection::setTimeout - Sets the timeout for the connection
    • EventHttpConnection::__construct - Constructs EventHttpConnection object
    • EventHttpRequest::addHeader - Adds an HTTP header to the headers of the request
    • EventHttpRequest::cancel - Cancels a pending HTTP request
    • EventHttpRequest::clearHeaders - Removes all output headers from the header list of the request
    • EventHttpRequest::closeConnection - Closes associated HTTP connection
    • EventHttpRequest::findHeader - Finds the value belonging a header
    • EventHttpRequest::free - Frees the object and removes associated events
    • EventHttpRequest::getBufferEvent - Returns EventBufferEvent object
    • EventHttpRequest::getCommand - Returns the request command(method)
    • EventHttpRequest::getConnection - Returns EventHttpConnection object
    • EventHttpRequest::getHost - Returns the request host
    • EventHttpRequest::getInputBuffer - Returns the input buffer
    • EventHttpRequest::getInputHeaders - Returns associative array of the input headers
    • EventHttpRequest::getOutputBuffer - Returns the output buffer of the request
    • EventHttpRequest::getOutputHeaders - Returns associative array of the output headers
    • EventHttpRequest::getResponseCode - Returns the response code
    • EventHttpRequest::getUri - Returns the request URI
    • EventHttpRequest::removeHeader - Removes an HTTP header from the headers of the request
    • EventHttpRequest::sendError - Send an HTML error message to the client
    • EventHttpRequest::sendReply - Send an HTML reply to the client
    • EventHttpRequest::sendReplyChunk - Send another data chunk as part of an ongoing chunked reply
    • EventHttpRequest::sendReplyEnd - Complete a chunked reply, freeing the request as appropriate
    • EventHttpRequest::sendReplyStart - Initiate a chunked reply
    • EventHttpRequest::__construct - Constructs EventHttpRequest object
    • EventListener::disable - Disables an event connect listener object
    • EventListener::enable - Enables an event connect listener object
    • EventListener::getBase - Returns event base associated with the event listener
    • EventListener::getSocketName - Retreives the current address to which the listener's socket is bound.
    • EventListener::setCallback - The setCallback purpose
    • EventListener::setErrorCallback - Set event listener's error callback
    • EventListener::__construct - Creates new connection listener associated with an event base
    • EventSslContext::__construct - Constructs an OpenSSL context for use with Event classes
    • EventUtil::getLastSocketErrno - Returns the most recent socket error number
    • EventUtil::getLastSocketError - Returns the most recent socket error
    • EventUtil::getSocketFd - Returns numeric file descriptor of a socket, or stream
    • EventUtil::getSocketName - Retreives the current address to which the socket is bound.
    • EventUtil::setSocketOption - Sets socket options
    • EventUtil::sslRandPoll - Generates entropy by means of OpenSSL's RAND_poll()
    • EventUtil::__construct - The abstract constructor
    • event_base_free - Destroy event base
    • event_base_loop - Handle events
    • event_base_loopbreak - Abort event loop
    • event_base_loopexit - Exit loop after a time
    • event_base_new - Create and initialize new event base
    • event_base_priority_init - Set the number of event priority levels
    • event_base_reinit - Reinitialize the event base after a fork
    • event_base_set - Associate event base with an event
    • event_buffer_base_set - Associate buffered event with an event base
    • event_buffer_disable - Disable a buffered event
    • event_buffer_enable - Enable a buffered event
    • event_buffer_fd_set - Change a buffered event file descriptor
    • event_buffer_free - Destroy buffered event
    • event_buffer_new - Create new buffered event
    • event_buffer_priority_set - Assign a priority to a buffered event
    • event_buffer_read - Read data from a buffered event
    • event_buffer_set_callback - Set or reset callbacks for a buffered event
    • event_buffer_timeout_set - Set read and write timeouts for a buffered event
    • event_buffer_watermark_set - Set the watermarks for read and write events
    • event_buffer_write - Write data to a buffered event
    • event_new - Create new event
    • event_priority_set - Assign a priority to an event.
    • event_timer_add - Takma Adı: event_add
    • event_timer_del - Takma Adı: event_del
    • event_timer_new - Takma Adı: event_new
    • event_timer_set - Prepare a timer event
    • EvFork::createStopped - Creates a stopped instance of EvFork watcher class
    • EvFork::__construct - Constructs the EvFork watcher object
    • EvIdle::createStopped - Creates instance of a stopped EvIdle watcher object
    • EvIdle::__construct - Constructs the EvIdle watcher object
    • EvIo::createStopped - Create stopped EvIo watcher object
    • EvIo::set - Configures the watcher
    • EvIo::__construct - Constructs EvIo watcher object
    • EvLoop::backend - Returns an integer describing the backend used by libev.
    • EvLoop::check - Creates EvCheck object associated with the current event loop instance
    • EvLoop::child - Creates EvChild object associated with the current event loop
    • EvLoop::defaultLoop - Returns or creates the default event loop.
    • EvLoop::embed - Creates an instance of EvEmbed watcher associated with the current EvLoop object.
    • EvLoop::fork - Creates EvFork watcher object associated with the current event loop instance
    • EvLoop::idle - Creates EvIdle watcher object associated with the current event loop instance
    • EvLoop::invokePending - Invoke all pending watchers while resetting their pending state
    • EvLoop::io - Create EvIo watcher object associated with the current event loop instance
    • EvLoop::loopFork - Must be called after a fork
    • EvLoop::now - Returns the current "event loop time"
    • EvLoop::nowUpdate - Establishes the current time by querying the kernel, updating the time returned by EvLoop::now in the progress.
    • EvLoop::periodic - Creates EvPeriodic watcher object associated with the current event loop instance
    • EvLoop::prepare - Creates EvPrepare watcher object associated with the current event loop instance
    • EvLoop::resume - Resume previously suspended default event loop
    • EvLoop::run - Begin checking for events and calling callbacks for the loop
    • EvLoop::signal - Creates EvSignal watcher object associated with the current event loop instance
    • EvLoop::stat - Creates EvStat watcher object associated with the current event loop instance
    • EvLoop::stop - Stops the event loop
    • EvLoop::suspend - Suspend the loop
    • EvLoop::timer - Creates EvTimer watcher object associated with the current event loop instance
    • EvLoop::verify - Performs internal consistency checks(for debugging)
    • EvLoop::__construct - Constructs the event loop object
    • EvPeriodic::again - Simply stops and restarts the periodic watcher again.
    • EvPeriodic::at - Returns the absolute time that this watcher is supposed to trigger next
    • EvPeriodic::createStopped - Create a stopped EvPeriodic watcher
    • EvPeriodic::set - Configures the watcher
    • EvPeriodic::__construct - Constructs EvPeriodic watcher object
    • EvPrepare::createStopped - Creates a stopped instance of EvPrepare watcher
    • EvPrepare::__construct - Constructs EvPrepare watcher object
    • EvSignal::createStopped - Create stopped EvSignal watcher object
    • EvSignal::set - Configures the watcher
    • EvSignal::__construct - Constructs EvPeriodic watcher object
    • EvStat::attr - Returns the values most recently detected by Ev
    • EvStat::createStopped - Create a stopped EvStat watcher object
    • EvStat::prev - Returns the previous set of values returned by EvStat::attr
    • EvStat::set - Configures the watcher
    • EvStat::stat - Initiates the stat call
    • EvStat::__construct - Constructs EvStat watcher object
    • EvTimer::again - Restarts the timer watcher
    • EvTimer::createStopped - Creates EvTimer stopped watcher object
    • EvTimer::set - Configures the watcher
    • EvTimer::__construct - Constructs an EvTimer watcher object
    • EvWatcher::clear - Clear watcher pending status
    • EvWatcher::feed - Feeds the given revents set into the event loop
    • EvWatcher::getLoop - Returns the loop responsible for the watcher
    • EvWatcher::invoke - Invokes the watcher callback with the given received events bit mask
    • EvWatcher::keepalive - Configures whether to keep the loop from returning
    • EvWatcher::setCallback - Sets new callback for the watcher
    • EvWatcher::start - Starts the watcher
    • EvWatcher::stop - Stops the watcher
    • EvWatcher::__construct - Abstract constructor of a watcher object
    • Exception::getCode - İstisnanın numarası ile döner
    • Exception::getFile - İstisnanın oluştuğu dosyanın adı ile döner
    • Exception::getLine - İstisnanın oluştuğu satırın numarası ile döner
    • Exception::getMessage - İstisna iletisi ile döner
    • Exception::getPrevious - Önceki istisnayı döndürür
    • Exception::getTrace - Yığıt iziyle döner
    • Exception::getTraceAsString - Yığıt izini bir dizge olarak döndürür
    • Exception::__clone - İstisna kopyası
    • Exception::__construct - İstisna oluşturur
    • Exception::__toString - İstisnanın dizgesel gösterimiyle döner
    • exec - Bir komut çalıştırır
    • exif_imagetype - Bir resmin türünü saptar
    • exif_read_data - Bir JPEG veya TIFF resminden EXIF başlıklarını okur
    • exif_tagname - Bir indis için başlık ismini döndürür
    • exif_thumbnail - Bir TIFF veya JPEG resminin içinde gömülü küçük örneği döndürür
    • exit - Bir ileti çıktılayıp çalışmakta olan betiği sonlandırır
    • exp - Calculates the exponent of e
    • expect:// - Process Interaction Streams
    • expect_expectl - Waits until the output from a process matches one of the patterns, a specified time period has passed, or an EOF is seen
    • expect_popen - Execute command via Bourne shell, and open the PTY stream to the process
    • explode - Bir dizgeyi bir ayraca göre bölüp bir dizi haline getirir
    • expm1 - Returns exp(number) - 1, computed in a way that is accurate even when the value of number is close to zero
    • extension_loaded - Belirtilen eklenti yüklü mü diye bakar
    • extract - Bir dizideki değişkenleri simge tablosuna dahil eder
    • ezmlm_hash - EZMLM için gereken ileti özetini hesaplar
  • f
    • fam_cancel_monitor - Terminate monitoring
    • fam_close - Close FAM connection
    • fam_monitor_collection - Monitor a collection of files in a directory for changes
    • fam_monitor_directory - Monitor a directory for changes
    • fam_monitor_file - Monitor a regular file for changes
    • fam_next_event - Get next pending FAM event
    • fam_open - Open connection to FAM daemon
    • fam_pending - Check for pending FAM events
    • fam_resume_monitor - Resume suspended monitoring
    • fam_suspend_monitor - Temporarily suspend monitoring
    • FANNConnection::getFromNeuron - Returns the postions of starting neuron.
    • FANNConnection::getToNeuron - Returns the postions of terminating neuron
    • FANNConnection::getWeight - Returns the connection weight
    • FANNConnection::setWeight - Sets the connections weight
    • FANNConnection::__construct - The connection constructor
    • fann_cascadetrain_on_data - Trains on an entire dataset, for a period of time using the Cascade2 training algorithm
    • fann_cascadetrain_on_file - Trains on an entire dataset read from file, for a period of time using the Cascade2 training algorithm.
    • fann_clear_scaling_params - Clears scaling parameters
    • fann_copy - Creates a copy of a fann structure
    • fann_create_from_file - Constructs a backpropagation neural network from a configuration file
    • fann_create_shortcut - Creates a standard backpropagation neural network which is not fully connectected and has shortcut connections
    • fann_create_shortcut_array - Creates a standard backpropagation neural network which is not fully connectected and has shortcut connections
    • fann_create_sparse - Creates a standard backpropagation neural network, which is not fully connected
    • fann_create_sparse_array - Creates a standard backpropagation neural network, which is not fully connected using an array of layer sizes
    • fann_create_standard - Creates a standard fully connected backpropagation neural network
    • fann_create_standard_array - Creates a standard fully connected backpropagation neural network using an array of layer sizes
    • fann_create_train - Creates an empty training data struct
    • fann_create_train_from_callback - Creates the training data struct from a user supplied function
    • fann_descale_input - Scale data in input vector after get it from ann based on previously calculated parameters
    • fann_descale_output - Scale data in output vector after get it from ann based on previously calculated parameters
    • fann_descale_train - Descale input and output data based on previously calculated parameters
    • fann_destroy - Destroys the entire network and properly freeing all the associated memory
    • fann_destroy_train - Destructs the training data
    • fann_duplicate_train_data - Returns an exact copy of a fann train data
    • fann_get_activation_function - Returns the activation function
    • fann_get_activation_steepness - Returns the activation steepness for supplied neuron and layer number
    • fann_get_bias_array - Get the number of bias in each layer in the network
    • fann_get_bit_fail - The number of fail bits
    • fann_get_bit_fail_limit - Returns the bit fail limit used during training
    • fann_get_cascade_activation_functions - Returns the cascade activation functions
    • fann_get_cascade_activation_functions_count - Returns the number of cascade activation functions
    • fann_get_cascade_activation_steepnesses - Returns the cascade activation steepnesses
    • fann_get_cascade_activation_steepnesses_count - The number of activation steepnesses
    • fann_get_cascade_candidate_change_fraction - Returns the cascade candidate change fraction
    • fann_get_cascade_candidate_limit - Return the candidate limit
    • fann_get_cascade_candidate_stagnation_epochs - Returns the number of cascade candidate stagnation epochs
    • fann_get_cascade_max_cand_epochs - Returns the maximum candidate epochs
    • fann_get_cascade_max_out_epochs - Returns the maximum out epochs
    • fann_get_cascade_min_cand_epochs - Returns the minimum candidate epochs
    • fann_get_cascade_min_out_epochs - Returns the minimum out epochs
    • fann_get_cascade_num_candidates - Returns the number of candidates used during training
    • fann_get_cascade_num_candidate_groups - Returns the number of candidate groups
    • fann_get_cascade_output_change_fraction - Returns the cascade output change fraction
    • fann_get_cascade_output_stagnation_epochs - Returns the number of cascade output stagnation epochs
    • fann_get_cascade_weight_multiplier - Returns the weight multiplier
    • fann_get_connection_array - Get connections in the network
    • fann_get_connection_rate - Get the connection rate used when the network was created
    • fann_get_errno - Returns the last error number
    • fann_get_errstr - Returns the last errstr
    • fann_get_layer_array - Get the number of neurons in each layer in the network
    • fann_get_learning_momentum - Returns the learning momentum
    • fann_get_learning_rate - Returns the learning rate
    • fann_get_MSE - Reads the mean square error from the network
    • fann_get_network_type - Get the type of neural network it was created as
    • fann_get_num_input - Get the number of input neurons
    • fann_get_num_layers - Get the number of layers in the neural network
    • fann_get_num_output - Get the number of output neurons
    • fann_get_quickprop_decay - Returns the decay which is a factor that weights should decrease in each iteration during quickprop training
    • fann_get_quickprop_mu - Returns the mu factor
    • fann_get_rprop_decrease_factor - Returns the increase factor used during RPROP training
    • fann_get_rprop_delta_max - Returns the maximum step-size
    • fann_get_rprop_delta_min - Returns the minimum step-size
    • fann_get_rprop_delta_zero - Returns the initial step-size
    • fann_get_rprop_increase_factor - Returns the increase factor used during RPROP training
    • fann_get_sarprop_step_error_shift - Returns the sarprop step error shift
    • fann_get_sarprop_step_error_threshold_factor - Returns the sarprop step error threshold factor
    • fann_get_sarprop_temperature - Returns the sarprop temperature
    • fann_get_sarprop_weight_decay_shift - Returns the sarprop weight decay shift
    • fann_get_total_connections - Get the total number of connections in the entire network
    • fann_get_total_neurons - Get the total number of neurons in the entire network
    • fann_get_training_algorithm - Returns the training algorithm
    • fann_get_train_error_function - Returns the error function used during training
    • fann_get_train_stop_function - Returns the stop function used during training
    • fann_init_weights - Initialize the weights using Widrow + Nguyen’s algorithm
    • fann_length_train_data - Returns the number of training patterns in the train data
    • fann_merge_train_data - Merges the train data
    • fann_num_input_train_data - Returns the number of inputs in each of the training patterns in the train data
    • fann_num_output_train_data - Returns the number of outputs in each of the training patterns in the train data
    • fann_print_error - Prints the error string
    • fann_randomize_weights - Give each connection a random weight between min_weight and max_weight
    • fann_read_train_from_file - Reads a file that stores training data
    • fann_reset_errno - Resets the last error number
    • fann_reset_errstr - Resets the last error string
    • fann_reset_MSE - Resets the mean square error from the network
    • fann_run - Will run input through the neural network
    • fann_save - Saves the entire network to a configuration file
    • fann_save_train - Save the training structure to a file
    • fann_scale_input - Scale data in input vector before feed it to ann based on previously calculated parameters
    • fann_scale_input_train_data - Scales the inputs in the training data to the specified range
    • fann_scale_output - Scale data in output vector before feed it to ann based on previously calculated parameters
    • fann_scale_output_train_data - Scales the outputs in the training data to the specified range
    • fann_scale_train - Scale input and output data based on previously calculated parameters
    • fann_scale_train_data - Scales the inputs and outputs in the training data to the specified range
    • fann_set_activation_function - Sets the activation function for supplied neuron and layer
    • fann_set_activation_function_hidden - Sets the activation function for all of the hidden layers
    • fann_set_activation_function_layer - Sets the activation function for all the neurons in the supplied layer.
    • fann_set_activation_function_output - Sets the activation function for the output layer
    • fann_set_activation_steepness - Sets the activation steepness for supplied neuron and layer number
    • fann_set_activation_steepness_hidden - Sets the steepness of the activation steepness for all neurons in the all hidden layers
    • fann_set_activation_steepness_layer - Sets the activation steepness for all of the neurons in the supplied layer number
    • fann_set_activation_steepness_output - Sets the steepness of the activation steepness in the output layer
    • fann_set_bit_fail_limit - Set the bit fail limit used during training
    • fann_set_callback - Sets the callback function for use during training
    • fann_set_cascade_activation_functions - Sets the array of cascade candidate activation functions
    • fann_set_cascade_activation_steepnesses - Sets the array of cascade candidate activation steepnesses
    • fann_set_cascade_candidate_change_fraction - Sets the cascade candidate change fraction
    • fann_set_cascade_candidate_limit - Sets the candidate limit
    • fann_set_cascade_candidate_stagnation_epochs - Sets the number of cascade candidate stagnation epochs
    • fann_set_cascade_max_cand_epochs - Sets the max candidate epochs
    • fann_set_cascade_max_out_epochs - Sets the maximum out epochs
    • fann_set_cascade_min_cand_epochs - Sets the min candidate epochs
    • fann_set_cascade_min_out_epochs - Sets the minimum out epochs
    • fann_set_cascade_num_candidate_groups - Sets the number of candidate groups
    • fann_set_cascade_output_change_fraction - Sets the cascade output change fraction
    • fann_set_cascade_output_stagnation_epochs - Sets the number of cascade output stagnation epochs
    • fann_set_cascade_weight_multiplier - Sets the weight multiplier
    • fann_set_error_log - Sets where the errors are logged to
    • fann_set_input_scaling_params - Calculate input scaling parameters for future use based on training data
    • fann_set_learning_momentum - Sets the learning momentum
    • fann_set_learning_rate - Sets the learning rate
    • fann_set_output_scaling_params - Calculate output scaling parameters for future use based on training data
    • fann_set_quickprop_decay - Sets the quickprop decay factor
    • fann_set_quickprop_mu - Sets the quickprop mu factor
    • fann_set_rprop_decrease_factor - Sets the decrease factor used during RPROP training
    • fann_set_rprop_delta_max - Sets the maximum step-size
    • fann_set_rprop_delta_min - Sets the minimum step-size
    • fann_set_rprop_delta_zero - Sets the initial step-size
    • fann_set_rprop_increase_factor - Sets the increase factor used during RPROP training
    • fann_set_sarprop_step_error_shift - Sets the sarprop step error shift
    • fann_set_sarprop_step_error_threshold_factor - Sets the sarprop step error threshold factor
    • fann_set_sarprop_temperature - Sets the sarprop temperature
    • fann_set_sarprop_weight_decay_shift - Sets the sarprop weight decay shift
    • fann_set_scaling_params - Calculate input and output scaling parameters for future use based on training data
    • fann_set_training_algorithm - Sets the training algorithm
    • fann_set_train_error_function - Sets the error function used during training
    • fann_set_train_stop_function - Sets the stop function used during training
    • fann_set_weight - Set a connection in the network
    • fann_set_weight_array - Set connections in the network
    • fann_shuffle_train_data - Shuffles training data, randomizing the order
    • fann_subset_train_data - Returns an copy of a subset of the train data
    • fann_test - Test with a set of inputs, and a set of desired outputs
    • fann_test_data - Test a set of training data and calculates the MSE for the training data
    • fann_train - Train one iteration with a set of inputs, and a set of desired outputs
    • fann_train_epoch - Train one epoch with a set of training data
    • fann_train_on_data - Trains on an entire dataset for a period of time
    • fann_train_on_file - Trains on an entire dataset, which is read from file, for a period of time
    • fastcgi_finish_request - Flushes all response data to the client
    • fbsql_affected_rows - Get number of affected rows in previous FrontBase operation
    • fbsql_autocommit - Enable or disable autocommit
    • fbsql_blob_size - Get the size of a BLOB
    • fbsql_change_user - Change logged in user of the active connection
    • fbsql_clob_size - Get the size of a CLOB
    • fbsql_close - Close FrontBase connection
    • fbsql_commit - Commits a transaction to the database
    • fbsql_connect - Open a connection to a FrontBase Server
    • fbsql_create_blob - Create a BLOB
    • fbsql_create_clob - Create a CLOB
    • fbsql_create_db - Create a FrontBase database
    • fbsql_database - Get or set the database name used with a connection
    • fbsql_database_password - Sets or retrieves the password for a FrontBase database
    • fbsql_data_seek - Move internal result pointer
    • fbsql_db_query - Send a FrontBase query
    • fbsql_db_status - Get the status for a given database
    • fbsql_drop_db - Drop (delete) a FrontBase database
    • fbsql_errno - Returns the error number from previous operation
    • fbsql_error - Returns the error message from previous operation
    • fbsql_fetch_array - Fetch a result row as an associative array, a numeric array, or both
    • fbsql_fetch_assoc - Fetch a result row as an associative array
    • fbsql_fetch_field - Get column information from a result and return as an object
    • fbsql_fetch_lengths - Get the length of each output in a result
    • fbsql_fetch_object - Fetch a result row as an object
    • fbsql_fetch_row - Get a result row as an enumerated array
    • fbsql_field_flags - Get the flags associated with the specified field in a result
    • fbsql_field_len - Returns the length of the specified field
    • fbsql_field_name - Get the name of the specified field in a result
    • fbsql_field_seek - Set result pointer to a specified field offset
    • fbsql_field_table - Get name of the table the specified field is in
    • fbsql_field_type - Get the type of the specified field in a result
    • fbsql_free_result - Free result memory
    • fbsql_get_autostart_info - Açıklama
    • fbsql_hostname - Get or set the host name used with a connection
    • fbsql_insert_id - Get the id generated from the previous INSERT operation
    • fbsql_list_dbs - List databases available on a FrontBase server
    • fbsql_list_fields - List FrontBase result fields
    • fbsql_list_tables - List tables in a FrontBase database
    • fbsql_next_result - Move the internal result pointer to the next result
    • fbsql_num_fields - Get number of fields in result
    • fbsql_num_rows - Get number of rows in result
    • fbsql_password - Get or set the user password used with a connection
    • fbsql_pconnect - Open a persistent connection to a FrontBase Server
    • fbsql_query - Send a FrontBase query
    • fbsql_read_blob - Read a BLOB from the database
    • fbsql_read_clob - Read a CLOB from the database
    • fbsql_result - Get result data
    • fbsql_rollback - Rollback a transaction to the database
    • fbsql_rows_fetched - Get the number of rows affected by the last statement
    • fbsql_select_db - Select a FrontBase database
    • fbsql_set_characterset - Change input/output character set
    • fbsql_set_lob_mode - Set the LOB retrieve mode for a FrontBase result set
    • fbsql_set_password - Change the password for a given user
    • fbsql_set_transaction - Set the transaction locking and isolation
    • fbsql_start_db - Start a database on local or remote server
    • fbsql_stop_db - Stop a database on local or remote server
    • fbsql_tablename - Takma Adı: fbsql_table_name
    • fbsql_table_name - Get table name of field
    • fbsql_username - Get or set the username for the connection
    • fbsql_warnings - Enable or disable FrontBase warnings
    • fclose - Açık bir dosya tanıtıcısını kapatır
    • fdf_add_doc_javascript - Adds javascript code to the FDF document
    • fdf_add_template - Adds a template into the FDF document
    • fdf_close - Close an FDF document
    • fdf_create - Create a new FDF document
    • fdf_enum_values - Call a user defined function for each document value
    • fdf_errno - Return error code for last fdf operation
    • fdf_error - Return error description for FDF error code
    • fdf_get_ap - Get the appearance of a field
    • fdf_get_attachment - Extracts uploaded file embedded in the FDF
    • fdf_get_encoding - Get the value of the /Encoding key
    • fdf_get_file - Get the value of the /F key
    • fdf_get_flags - Gets the flags of a field
    • fdf_get_opt - Gets a value from the opt array of a field
    • fdf_get_status - Get the value of the /STATUS key
    • fdf_get_value - Get the value of a field
    • fdf_get_version - Gets version number for FDF API or file
    • fdf_header - Sets FDF-specific output headers
    • fdf_next_field_name - Get the next field name
    • fdf_open - Open a FDF document
    • fdf_open_string - Read a FDF document from a string
    • fdf_remove_item - Sets target frame for form
    • fdf_save - Save a FDF document
    • fdf_save_string - Returns the FDF document as a string
    • fdf_set_ap - Set the appearance of a field
    • fdf_set_encoding - Sets FDF character encoding
    • fdf_set_file - Set PDF document to display FDF data in
    • fdf_set_flags - Sets a flag of a field
    • fdf_set_javascript_action - Sets an javascript action of a field
    • fdf_set_on_import_javascript - Adds javascript code to be executed when Acrobat opens the FDF
    • fdf_set_opt - Sets an option of a field
    • fdf_set_status - Set the value of the /STATUS key
    • fdf_set_submit_form_action - Sets a submit form action of a field
    • fdf_set_target_frame - Set target frame for form display
    • fdf_set_value - Set the value of a field
    • fdf_set_version - Sets version number for a FDF file
    • feof - Bir dosya tanıtıcısı üzerinde konum dosya sonunda mı diye bakar
    • fflush - Çıktıyı bir dosyaya boşaltır
    • fgetc - Dosya tanıtıcısından bir karakter döndürür
    • fgetcsv - Dosya tanıtıcısından CSV alanlarını çözümleyerek bir satır döndürür
    • fgets - Dosya tanıtıcısından bir satır döndürür
    • fgetss - Dosya tanıtıcısından bir satırı HTML etiketlerinden arındırarak döndürür
    • file - Dosya içeriğinin tamamını bir diziye okur
    • file:// - Accessing local filesystem
    • fileatime - Dosyaya son erişim zamanını döndürür
    • filectime - Dosyanın dosya düğümü değişiklik zamanını döndürür
    • filegroup - Dosyanın sahibi olan grubu döndürür
    • fileinode - Dosyanın düğüm numarasını döndürür
    • filemtime - Dosyanın değişiklik zamanını döndürür
    • fileowner - Dosya sahibini döndürür
    • fileperms - Dosya izinlerini döndürür
    • filepro - Read and verify the map file
    • filepro_fieldcount - Find out how many fields are in a filePro database
    • filepro_fieldname - Gets the name of a field
    • filepro_fieldtype - Gets the type of a field
    • filepro_fieldwidth - Gets the width of a field
    • filepro_retrieve - Retrieves data from a filePro database
    • filepro_rowcount - Find out how many rows are in a filePro database
    • filesize - Dosya uzunluğunu döndürür
    • FilesystemIterator::current - The current file
    • FilesystemIterator::getFlags - Get the handling flags
    • FilesystemIterator::key - Retrieve the key for the current file
    • FilesystemIterator::next - Move to the next file
    • FilesystemIterator::rewind - Rewinds back to the beginning
    • FilesystemIterator::setFlags - Sets handling flags
    • FilesystemIterator::__construct - Constructs a new filesystem iterator
    • filetype - Dosya türünü döndürür
    • file_exists - Bir dosya veya dizinin mevcut olup olmadığına bakar
    • file_get_contents - Dosya içeriğinin tamamını bir dizge olarak döndürür
    • file_put_contents - Bir dizgeyi bir dosyaya yazar
    • FilterIterator::accept - Check whether the current element of the iterator is acceptable
    • FilterIterator::current - Get the current element value
    • FilterIterator::getInnerIterator - Get the inner iterator
    • FilterIterator::key - Get the current key
    • FilterIterator::next - Move the iterator forward
    • FilterIterator::rewind - Rewind the iterator
    • FilterIterator::valid - Check whether the current element is valid
    • FilterIterator::__construct - Construct a filterIterator
    • filter_has_var - Checks if variable of specified type exists
    • filter_id - Returns the filter ID belonging to a named filter
    • filter_input - Gets a specific external variable by name and optionally filters it
    • filter_input_array - Gets external variables and optionally filters them
    • filter_list - Returns a list of all supported filters
    • filter_var - Filters a variable with a specified filter
    • filter_var_array - Gets multiple variables and optionally filters them
    • finfo_buffer - Bir dizge tamponu hakkında bilgi döndürür
    • finfo_close - Fileinfo özkaynağını kapatır
    • finfo_file - Bir dosya hakkında bilgi döndürür
    • finfo_open - Yeni bir fileinfo özkaynağı oluşturur
    • finfo_set_flags - Libmagic yapılandırma seçeneklerini ayarlar
    • floatval - Bir değişkenin gerçek sayı değerini döndürür
    • flock - Taşınabilir tavsiye niteliğinde dosya kilitleme
    • floor - Round fractions down
    • flush - Çıktı tamponunu boşaltır
    • fmod - Returns the floating point remainder (modulo) of the division of the arguments
    • fnmatch - Dosya ismi belirtilen kalıpla eşleşiyor mu diye bakar
    • fopen - Bir dosya veya URL'yi açar
    • forward_static_call - Call a static method
    • forward_static_call_array - Call a static method and pass the arguments as array
    • fpassthru - Bir dosya tanıtıcısında kalan verinin tamamını çıktılar
    • fprintf - Biçemli dizgeyi bir akıma yazar
    • fputcsv - Satırı CSV olarak biçemler ve dosya tanıtıcısına yazar
    • fputs - fwrite işlevinin takma adıdır
    • fread - Dosyayı ikil kipte okur
    • FrenchToJD - Fransız İhtilali takvim tarihini, Jülyen Gün Sayısına çevirir
    • fribidi_log2vis - Convert a logical string to a visual one
    • fscanf - Bir dosyadaki girdiyi belli bir biçeme göre çözümler
    • fseek - Dosya tanıtıcısında konumu bir yerden başka bir yere taşır
    • fsockopen - Bir internet veya Unix alan soketi bağlantısı açar
    • fstat - Bir açık dosya tanıtıcısı kullanarak bir dosya hakkında bilgi döndürür
    • ftell - Dosya okuma/yazma konumlayıcının mevcut konumu ile döner
    • ftok - Convert a pathname and a project identifier to a System V IPC key
    • ftp:// - Accessing FTP(s) URLs
    • FTP bağlamı seçenekleri - FTP bağlamı seçeneklerinin listesi
    • ftp_alloc - Karşıya dosya yüklemek için bir FTP sunucusuna yer ayırma isteği yapar
    • ftp_cdup - Üst dizine geçer
    • ftp_chdir - FTP sunucusundaki çalışma dizinini değiştirir
    • ftp_chmod - FTP üzerinden bir dosyanın erişim izinlerini değiştirir
    • ftp_close - Bir FTP bağlantısını kapatır
    • ftp_connect - Bir FTP bağlantısı açar
    • ftp_delete - Belirtilen dosyayı FTP sunucusundan siler
    • ftp_exec - FTP sunucusunda bir komut çalıştırma isteği yapar
    • ftp_fget - FTP sunucusundan dosyayı indirip bir dosya tanıtıcısına yazar
    • ftp_fput - FTP sunucusuna dosya tanıtıcısı belirtilen dosyayı yükler
    • ftp_get - FTP sunucusundan bir dosya indirir
    • ftp_get_option - Bir çalışma anı seçeneğinin değerini döndürür
    • ftp_login - FTP bağlantısında kullanıcı oturumu açar
    • ftp_mdtm - Belirtilen dosyanın son değişiklik zamanını döndürür
    • ftp_mkdir - FTP sunucusunda bir dizin oluşturur
    • ftp_nb_continue - Dosya alımını/gönderimini (engellenmeyen kipte) kaldığı yerden devam ettirir
    • ftp_nb_fget - FTP sunucusundan dosyayı (engellenmeyen kipte) indirip bir dosya tanıtıcısına yazar
    • ftp_nb_fput - FTP sunucusuna (engellenmeyen kipte) dosya yüklemek için bir dosya tanıtıcısı kullanır
    • ftp_nb_get - FTP sunucusundan (engellenmeyen kipte) bir dosya indirir
    • ftp_nb_put - Bir dosyayı FTP sunucusuna (engellenmeyen kipte) yükler
    • ftp_nlist - Belirtilen dizindeki dosyaların listesini döndürür
    • ftp_pasv - Edilgen kipi açıp kapar
    • ftp_put - FTP sunucusuna bir dosya yükler
    • ftp_pwd - Çalışılan dizinin ismini döndürür
    • ftp_quit - ftp_close işlevinin takma adıdır
    • ftp_raw - Bir FTP sunucusuna bir komut gönderir
    • ftp_rawlist - Belirtilen dizindeki dosyaların ayrıntılı bir listesini döndürür
    • ftp_rename - FTP sunucusundaki bir dosya veya dizinin adını değiştirir
    • ftp_rmdir - Bir dizini siler
    • ftp_set_option - Çalışma anı seçeneklerini belirler
    • ftp_site - Sunucuya bir SITE komutu gönderir
    • ftp_size - FTP sunucusundaki bir dosyanın boyunu döndürür
    • ftp_ssl_connect - Güvenli bir SSL-FTP bağlantısı açar
    • ftp_systype - Uzak FTP sunucusunun sistem türü tanıtıcısını döndürür
    • ftruncate - Bir dosyayı belli bir uzunlukta budar
    • function_exists - Eğer işlev tanımlanmış ise TRUE döndürür
    • func_get_arg - Değiştirge listesinden bir üyeyi döndürür
    • func_get_args - İşleve aktarılan değiştirgelerin listesini dizi olarak döndürür
    • func_num_args - İşleve aktarılan değiştirge sayısını döndürür
    • fwrite - Dosyaya ikil kipte yazar
  • g
    • gc_collect_cycles - Çöp döngülerin toplanması için zorlar
    • gc_disable - Döngüsel gönderim toplayıcısını etkisiz kılar
    • gc_enable - Döngüsel gönderim toplayıcısını etkin kılar
    • gc_enabled - Döngüsel gönderim toplayıcısının durumunu döndürür
    • gc_mem_caches - Reclaims memory used by the Zend Engine memory manager
    • gd_info - Kurulu GD kütüphanesi hakkında bilgi verir
    • GearmanClient::addOptions - Add client options
    • GearmanClient::addServer - Add a job server to the client
    • GearmanClient::addServers - Add a list of job servers to the client
    • GearmanClient::addTask - Add a task to be run in parallel
    • GearmanClient::addTaskBackground - Add a background task to be run in parallel
    • GearmanClient::addTaskHigh - Add a high priority task to run in parallel
    • GearmanClient::addTaskHighBackground - Add a high priority background task to be run in parallel
    • GearmanClient::addTaskLow - Add a low priority task to run in parallel
    • GearmanClient::addTaskLowBackground - Add a low priority background task to be run in parallel
    • GearmanClient::addTaskStatus - Add a task to get status
    • GearmanClient::clearCallbacks - Clear all task callback functions
    • GearmanClient::clone - Create a copy of a GearmanClient object
    • GearmanClient::context - Get the application context
    • GearmanClient::data - Get the application data (deprecated)
    • GearmanClient::do - Run a single task and return a result [deprecated]
    • GearmanClient::doBackground - Run a task in the background
    • GearmanClient::doHigh - Run a single high priority task
    • GearmanClient::doHighBackground - Run a high priority task in the background
    • GearmanClient::doJobHandle - Get the job handle for the running task
    • GearmanClient::doLow - Run a single low priority task
    • GearmanClient::doLowBackground - Run a low priority task in the background
    • GearmanClient::doNormal - Run a single task and return a result
    • GearmanClient::doStatus - Get the status for the running task
    • GearmanClient::echo - Send data to all job servers to see if they echo it back [deprecated]
    • GearmanClient::error - Returns an error string for the last error encountered.
    • GearmanClient::getErrno - Get an errno value
    • GearmanClient::jobStatus - Get the status of a background job
    • GearmanClient::ping - Send data to all job servers to see if they echo it back
    • GearmanClient::removeOptions - Remove client options
    • GearmanClient::returnCode - Get the last Gearman return code
    • GearmanClient::runTasks - Run a list of tasks in parallel
    • GearmanClient::setClientCallback - Callback function when there is a data packet for a task (deprecated)
    • GearmanClient::setCompleteCallback - Set a function to be called on task completion
    • GearmanClient::setContext - Set application context
    • GearmanClient::setCreatedCallback - Set a callback for when a task is queued
    • GearmanClient::setData - Set application data (deprecated)
    • GearmanClient::setDataCallback - Callback function when there is a data packet for a task
    • GearmanClient::setExceptionCallback - Set a callback for worker exceptions
    • GearmanClient::setFailCallback - Set callback for job failure
    • GearmanClient::setOptions - Set client options
    • GearmanClient::setStatusCallback - Set a callback for collecting task status
    • GearmanClient::setTimeout - Set socket I/O activity timeout
    • GearmanClient::setWarningCallback - Set a callback for worker warnings
    • GearmanClient::setWorkloadCallback - Set a callback for accepting incremental data updates
    • GearmanClient::timeout - Get current socket I/O activity timeout value
    • GearmanClient::__construct - Create a GearmanClient instance
    • GearmanJob::complete - Send the result and complete status (deprecated)
    • GearmanJob::data - Send data for a running job (deprecated)
    • GearmanJob::exception - Send exception for running job (deprecated)
    • GearmanJob::fail - Send fail status (deprecated)
    • GearmanJob::functionName - Get function name
    • GearmanJob::handle - Get the job handle
    • GearmanJob::returnCode - Get last return code
    • GearmanJob::sendComplete - Send the result and complete status
    • GearmanJob::sendData - Send data for a running job
    • GearmanJob::sendException - Send exception for running job (exception)
    • GearmanJob::sendFail - Send fail status
    • GearmanJob::sendStatus - Send status
    • GearmanJob::sendWarning - Send a warning
    • GearmanJob::setReturn - Set a return value
    • GearmanJob::status - Send status (deprecated)
    • GearmanJob::unique - Get the unique identifier
    • GearmanJob::warning - Send a warning (deprecated)
    • GearmanJob::workload - Get workload
    • GearmanJob::workloadSize - Get size of work load
    • GearmanJob::__construct - Create a GearmanJob instance
    • GearmanTask::create - Create a task (deprecated)
    • GearmanTask::data - Get data returned for a task
    • GearmanTask::dataSize - Get the size of returned data
    • GearmanTask::function - Get associated function name (deprecated)
    • GearmanTask::functionName - Get associated function name
    • GearmanTask::isKnown - Determine if task is known
    • GearmanTask::isRunning - Test whether the task is currently running
    • GearmanTask::jobHandle - Get the job handle
    • GearmanTask::recvData - Read work or result data into a buffer for a task
    • GearmanTask::returnCode - Get the last return code
    • GearmanTask::sendData - Send data for a task (deprecated)
    • GearmanTask::sendWorkload - Send data for a task
    • GearmanTask::taskDenominator - Get completion percentage denominator
    • GearmanTask::taskNumerator - Get completion percentage numerator
    • GearmanTask::unique - Get the unique identifier for a task
    • GearmanTask::uuid - Get the unique identifier for a task (deprecated)
    • GearmanTask::__construct - Create a GearmanTask instance
    • GearmanWorker::addFunction - Register and add callback function
    • GearmanWorker::addOptions - Add worker options
    • GearmanWorker::addServer - Add a job server
    • GearmanWorker::addServers - Add job servers
    • GearmanWorker::clone - Create a copy of the worker
    • GearmanWorker::echo - Test job server response
    • GearmanWorker::error - Get the last error encountered
    • GearmanWorker::getErrno - Get errno
    • GearmanWorker::options - Get worker options
    • GearmanWorker::register - Register a function with the job server
    • GearmanWorker::removeOptions - Remove worker options
    • GearmanWorker::returnCode - Get last Gearman return code
    • GearmanWorker::setId - Give the worker an identifier so it can be tracked when asking gearmand for the list of available workers.
    • GearmanWorker::setOptions - Set worker options
    • GearmanWorker::setTimeout - Set socket I/O activity timeout
    • GearmanWorker::timeout - Get socket I/O activity timeout
    • GearmanWorker::unregister - Unregister a function name with the job servers
    • GearmanWorker::unregisterAll - Unregister all function names with the job servers
    • GearmanWorker::wait - Wait for activity from one of the job servers
    • GearmanWorker::work - Wait for and perform jobs
    • GearmanWorker::__construct - Create a GearmanWorker instance
    • Gender\Gender::connect - Connect to an external name dictionary.
    • Gender\Gender::country - Get textual country representation
    • Gender\Gender::get - Get gender of a name.
    • Gender\Gender::isNick - Check if the name0 is an alias of the name1.
    • Gender\Gender::similarNames - Get similar names.
    • Gender\Gender::__construct - Construct the Gender object.
    • Generator::current - Get the yielded value
    • Generator::getReturn - Get the return value of a generator
    • Generator::key - Get the yielded key
    • Generator::next - Resume execution of the generator
    • Generator::rewind - Rewind the iterator
    • Generator::send - Send a value to the generator
    • Generator::throw - Throw an exception into the generator
    • Generator::valid - Check if the iterator has been closed
    • Generator::__wakeup - Serialize callback
    • geoip_asnum_by_name - Get the Autonomous System Numbers (ASN)
    • geoip_continent_code_by_name - Get the two letter continent code
    • geoip_country_code3_by_name - Get the three letter country code
    • geoip_country_code_by_name - Get the two letter country code
    • geoip_country_name_by_name - Get the full country name
    • geoip_database_info - Get GeoIP Database information
    • geoip_db_avail - Determine if GeoIP Database is available
    • geoip_db_filename - Returns the filename of the corresponding GeoIP Database
    • geoip_db_get_all_info - Returns detailed information about all GeoIP database types
    • geoip_domain_by_name - Get the second level domain name
    • geoip_id_by_name - Get the Internet connection type
    • geoip_isp_by_name - Get the Internet Service Provider (ISP) name
    • geoip_netspeedcell_by_name - Get the Internet connection speed
    • geoip_org_by_name - Get the organization name
    • geoip_record_by_name - Returns the detailed City information found in the GeoIP Database
    • geoip_region_by_name - Get the country code and region
    • geoip_region_name_by_code - Returns the region name for some country and region code combo
    • geoip_setup_custom_directory - Set a custom directory for the GeoIP database.
    • geoip_time_zone_by_country_and_region - Returns the time zone for some country and region code combo
    • getallheaders - Tüm HTTP istek başlıklarını getirir
    • getcwd - Geçerli çalışma dizinini döndürür
    • getdate - Tarih/zaman bilgisi getirir
    • getenv - Bir ortam değişkeninin değerini döndürür
    • gethostbyaddr - Belirtilen IP adresine çözümlenen konak ismini döndürür
    • gethostbyname - Belirtilen konak adına ait IPv4 adresini döndürür
    • gethostbynamel - Belirtilen konak adına ait IPv4 adreslerini döndürür
    • gethostname - Konak ismini döndürür
    • getimagesize - Bir resmin boyutlarını döndürür
    • getimagesizefromstring - Get the size of an image from a string
    • getlastmod - Geçerli sayfanın son değişiklik zamanını döndürür
    • getmxrr - Belirtilen konak adı ile ilgili MX kaydını döndürür
    • getmygid - PHP betiğinin sahibinin grup kimliğini döndürür
    • getmyinode - Çalışan betiğin dosya düğümü numarasını döndürür
    • getmypid - PHP'nin süreç kimliğini (PID) döndürür
    • getmyuid - PHP betiğinin sahibinin kullanıcı kimliğini döndürür
    • getopt - Komut satırı değiştirgeleri listesinden seçenekleri döndürür
    • getprotobyname - Protokol ismine karşılık düşen protokol numarasını verir
    • getprotobynumber - Protokol numarasına karşılık düşen protokol ismini verir
    • getrandmax - Show largest possible random value
    • getrusage - Geçerli özkaynak kullanımlarını döndürür
    • getservbyname - Belirtilen ağ hizmeti ve protokolle ilişkili port numarası ile döner
    • getservbyport - Belirtilen port ve protokolle ilgili ağ hizmeti ile döner
    • gettext - Geçerli uygulama alanında bir iletiyi arar
    • gettimeofday - Geçerli zamanı getirir
    • gettype - Bir değişkenin türünü döndürür
    • get_browser - Kullanıcının tarayıcısının neler yapabildiğini söyler
    • get_called_class - Çağrıldığı duruk yöntemin sınıf ismini döndürür
    • get_cfg_var - Belirtilen PHP yönergesinin değerini döndürür
    • get_class - Bir nesnenin ait olduğu sınıfın ismini döndürür
    • get_class_methods - Sınıf yöntemlerinin isimlerini döndürür
    • get_class_vars - Sınıfın öntanımlı özelliklerini döndürür
    • get_current_user - PHP betiğinin sahibininin kullanıcı ismini döndürür
    • get_declared_classes - Tanımlı sınıfların isimlerini bir dizi olarak döndürür
    • get_declared_interfaces - Bildirilmiş tüm arayüzleri bir dizi olarak döndürür
    • get_declared_traits - Returns an array of all declared traits
    • get_defined_constants - Tüm sabitlerin isimlerini ve değerlerini içeren bir ilişkisel dizi döndürür
    • get_defined_functions - Tanımlanmış bütün işlevleri içeren bir dizi döndürür
    • get_defined_vars - Tüm tanımlı değişkenleri içeren bir dizi döndürür
    • get_extension_funcs - Bir modülün işlevlerinin isimlerini içeren bir dizi döndürür
    • get_headers - Bir HTTP isteğine sunucunun verdiği yanıtta gönderilen tüm başlıkları döndürür
    • get_html_translation_table - htmlspecialchars ve htmlentities tarafından kullanılan dönüşüm tablosunu döndürür
    • get_included_files - Betiğe dahil edilen dosyaların isimlerini içeren bir dizi döndürür
    • get_include_path - include_path yönergesinin değerini döndürür
    • get_loaded_extensions - Derlenmiş ve yüklenmiş tüm modüllerin isimlerini içeren bir dizi döndürür
    • get_magic_quotes_gpc - magic_quotes_gpc yönergesinin değerini döndürür
    • get_magic_quotes_runtime - magic_quotes_runtime yönergesinin çalışma anı değerini döndürür
    • get_meta_tags - Bir HTML dosyanın meta etiketlerindeki öznitelikleri çıkarıp bir dizi olarak döndürür
    • get_object_vars - Belirtilen nesnenin özelliklerini döndürür
    • get_parent_class - Nesne veya sınıfın ebeveyn sınıfının ismini döndürür
    • get_required_files - get_included_files işlevinin takma adıdır
    • get_resources - Returns active resources
    • get_resource_type - Özkaynak türünü döndürür
    • glob - Bir kalıpla eşleşen dosya yollarını bulur
    • glob:// - Find pathnames matching pattern
    • GlobIterator::count - Get the number of directories and files
    • GlobIterator::__construct - Construct a directory using glob
    • Gmagick::addimage - Adds new image to Gmagick object image list
    • Gmagick::addnoiseimage - Adds random noise to the image
    • Gmagick::annotateimage - Annotates an image with text
    • Gmagick::blurimage - Adds blur filter to image
    • Gmagick::borderimage - Surrounds the image with a border
    • Gmagick::charcoalimage - Simulates a charcoal drawing
    • Gmagick::chopimage - Removes a region of an image and trims
    • Gmagick::clear - Clears all resources associated to Gmagick object
    • Gmagick::commentimage - Adds a comment to your image
    • Gmagick::compositeimage - Composite one image onto another
    • Gmagick::cropimage - Extracts a region of the image
    • Gmagick::cropthumbnailimage - Creates a crop thumbnail
    • Gmagick::current - The current purpose
    • Gmagick::cyclecolormapimage - Displaces an image's colormap
    • Gmagick::deconstructimages - Returns certain pixel differences between images
    • Gmagick::despeckleimage - The despeckleimage purpose
    • Gmagick::destroy - The destroy purpose
    • Gmagick::drawimage - Renders the GmagickDraw object on the current image
    • Gmagick::edgeimage - Enhance edges within the image
    • Gmagick::embossimage - Returns a grayscale image with a three-dimensional effect
    • Gmagick::enhanceimage - Improves the quality of a noisy image
    • Gmagick::equalizeimage - Equalizes the image histogram
    • Gmagick::flipimage - Creates a vertical mirror image
    • Gmagick::flopimage - The flopimage purpose
    • Gmagick::frameimage - Adds a simulated three-dimensional border
    • Gmagick::gammaimage - Gamma-corrects an image
    • Gmagick::getcopyright - Returns the GraphicsMagick API copyright as a string
    • Gmagick::getfilename - The filename associated with an image sequence
    • Gmagick::getimagebackgroundcolor - Returns the image background color
    • Gmagick::getimageblueprimary - Returns the chromaticy blue primary point
    • Gmagick::getimagebordercolor - Returns the image border color
    • Gmagick::getimagechanneldepth - Gets the depth for a particular image channel
    • Gmagick::getimagecolors - Returns the color of the specified colormap index
    • Gmagick::getimagecolorspace - Gets the image colorspace
    • Gmagick::getimagecompose - Returns the composite operator associated with the image
    • Gmagick::getimagedelay - Gets the image delay
    • Gmagick::getimagedepth - Gets the depth of the image
    • Gmagick::getimagedispose - Gets the image disposal method
    • Gmagick::getimageextrema - Gets the extrema for the image
    • Gmagick::getimagefilename - Returns the filename of a particular image in a sequence
    • Gmagick::getimageformat - Returns the format of a particular image in a sequence
    • Gmagick::getimagegamma - Gets the image gamma
    • Gmagick::getimagegreenprimary - Returns the chromaticy green primary point
    • Gmagick::getimageheight - Returns the image height
    • Gmagick::getimagehistogram - Gets the image histogram
    • Gmagick::getimageindex - Gets the index of the current active image
    • Gmagick::getimageinterlacescheme - Gets the image interlace scheme
    • Gmagick::getimageiterations - Gets the image iterations
    • Gmagick::getimagematte - Check if the image has a matte channel
    • Gmagick::getimagemattecolor - Returns the image matte color
    • Gmagick::getimageprofile - Returns the named image profile.
    • Gmagick::getimageredprimary - Returns the chromaticity red primary point
    • Gmagick::getimagerenderingintent - Gets the image rendering intent
    • Gmagick::getimageresolution - Gets the image X and Y resolution
    • Gmagick::getimagescene - Gets the image scene
    • Gmagick::getimagesignature - Generates an SHA-256 message digest
    • Gmagick::getimagetype - Gets the potential image type.
    • Gmagick::getimageunits - Gets the image units of resolution
    • Gmagick::getimagewhitepoint - Returns the chromaticity white point
    • Gmagick::getimagewidth - Returns the width of the image
    • Gmagick::getpackagename - Returns the GraphicsMagick package name.
    • Gmagick::getquantumdepth - Returns the Gmagick quantum depth as a string.
    • Gmagick::getreleasedate - Returns the GraphicsMagick release date as a string.
    • Gmagick::getsamplingfactors - Gets the horizontal and vertical sampling factor.
    • Gmagick::getsize - Returns the size associated with the Gmagick object
    • Gmagick::getversion - Returns the GraphicsMagick API version
    • Gmagick::hasnextimage - Checks if the object has more images
    • Gmagick::haspreviousimage - Checks if the object has a previous image
    • Gmagick::implodeimage - Creates a new image as a copy
    • Gmagick::labelimage - Adds a label to an image.
    • Gmagick::levelimage - Adjusts the levels of an image
    • Gmagick::magnifyimage - Scales an image proportionally 2x
    • Gmagick::mapimage - Replaces the colors of an image with the closest color from a reference image.
    • Gmagick::medianfilterimage - Applies a digital filter
    • Gmagick::minifyimage - Scales an image proportionally to half its size
    • Gmagick::modulateimage - Control the brightness, saturation, and hue
    • Gmagick::motionblurimage - Simulates motion blur
    • Gmagick::newimage - Creates a new image
    • Gmagick::nextimage - Moves to the next image
    • Gmagick::normalizeimage - Enhances the contrast of a color image
    • Gmagick::oilpaintimage - Simulates an oil painting
    • Gmagick::previousimage - Move to the previous image in the object
    • Gmagick::profileimage - Adds or removes a profile from an image
    • Gmagick::quantizeimage - Analyzes the colors within a reference image
    • Gmagick::quantizeimages - The quantizeimages purpose
    • Gmagick::queryfontmetrics - Returns an array representing the font metrics
    • Gmagick::queryfonts - Returns the configured fonts
    • Gmagick::queryformats - Returns formats supported by Gmagick.
    • Gmagick::radialblurimage - Radial blurs an image
    • Gmagick::raiseimage - Creates a simulated 3d button-like effect
    • Gmagick::read - Reads image from filename
    • Gmagick::readimage - Reads image from filename
    • Gmagick::readimageblob - Reads image from a binary string
    • Gmagick::readimagefile - The readimagefile purpose
    • Gmagick::reducenoiseimage - Smooths the contours of an image
    • Gmagick::removeimage - Removes an image from the image list
    • Gmagick::removeimageprofile - Removes the named image profile and returns it
    • Gmagick::resampleimage - Resample image to desired resolution
    • Gmagick::resizeimage - Scales an image
    • Gmagick::rollimage - Offsets an image
    • Gmagick::rotateimage - Rotates an image
    • Gmagick::scaleimage - Scales the size of an image
    • Gmagick::separateimagechannel - Separates a channel from the image
    • Gmagick::setCompressionQuality - Sets the object's default compression quality
    • Gmagick::setfilename - Sets the filename before you read or write the image
    • Gmagick::setimagebackgroundcolor - Sets the image background color.
    • Gmagick::setimageblueprimary - Sets the image chromaticity blue primary point.
    • Gmagick::setimagebordercolor - Sets the image border color.
    • Gmagick::setimagechanneldepth - Sets the depth of a particular image channel
    • Gmagick::setimagecolorspace - Sets the image colorspace
    • Gmagick::setimagecompose - Sets the image composite operator
    • Gmagick::setimagedelay - Sets the image delay
    • Gmagick::setimagedepth - Sets the image depth
    • Gmagick::setimagedispose - Sets the image disposal method
    • Gmagick::setimagefilename - Sets the filename of a particular image in a sequence
    • Gmagick::setimageformat - Sets the format of a particular image
    • Gmagick::setimagegamma - Sets the image gamma
    • Gmagick::setimagegreenprimary - Sets the image chromaticity green primary point.
    • Gmagick::setimageindex - Set the iterator to the position in the image list specified with the index parameter
    • Gmagick::setimageinterlacescheme - Sets the interlace scheme of the image.
    • Gmagick::setimageiterations - Sets the image iterations.
    • Gmagick::setimageprofile - Adds a named profile to the Gmagick object
    • Gmagick::setimageredprimary - Sets the image chromaticity red primary point.
    • Gmagick::setimagerenderingintent - Sets the image rendering intent
    • Gmagick::setimageresolution - Sets the image resolution
    • Gmagick::setimagescene - Sets the image scene
    • Gmagick::setimagetype - Sets the image type
    • Gmagick::setimageunits - Sets the image units of resolution.
    • Gmagick::setimagewhitepoint - Sets the image chromaticity white point.
    • Gmagick::setsamplingfactors - Sets the image sampling factors.
    • Gmagick::setsize - Sets the size of the Gmagick object
    • Gmagick::shearimage - Creating a parallelogram
    • Gmagick::solarizeimage - Applies a solarizing effect to the image
    • Gmagick::spreadimage - Randomly displaces each pixel in a block
    • Gmagick::stripimage - Strips an image of all profiles and comments
    • Gmagick::swirlimage - Swirls the pixels about the center of the image
    • Gmagick::thumbnailimage - Changes the size of an image
    • Gmagick::trimimage - Remove edges from the image
    • Gmagick::write - Takma Adı: Gmagick::writeimage
    • Gmagick::writeimage - Writes an image to the specified filename
    • Gmagick::__construct - The Gmagick constructor
    • GmagickDraw::annotate - Draws text on the image
    • GmagickDraw::arc - Draws an arc
    • GmagickDraw::bezier - Draws a bezier curve
    • GmagickDraw::ellipse - Draws an ellipse on the image
    • GmagickDraw::getfillcolor - Returns the fill color
    • GmagickDraw::getfillopacity - Returns the opacity used when drawing
    • GmagickDraw::getfont - Returns the font
    • GmagickDraw::getfontsize - Returns the font pointsize
    • GmagickDraw::getfontstyle - Returns the font style
    • GmagickDraw::getfontweight - Returns the font weight
    • GmagickDraw::getstrokecolor - Returns the color used for stroking object outlines
    • GmagickDraw::getstrokeopacity - Returns the opacity of stroked object outlines
    • GmagickDraw::getstrokewidth - Returns the width of the stroke used to draw object outlines
    • GmagickDraw::gettextdecoration - Returns the text decoration
    • GmagickDraw::gettextencoding - Returns the code set used for text annotations
    • GmagickDraw::line - The line purpose
    • GmagickDraw::point - Draws a point
    • GmagickDraw::polygon - Draws a polygon
    • GmagickDraw::polyline - Draws a polyline
    • GmagickDraw::rectangle - Draws a rectangle
    • GmagickDraw::rotate - Applies the specified rotation to the current coordinate space
    • GmagickDraw::roundrectangle - Draws a rounded rectangle
    • GmagickDraw::scale - Adjusts the scaling factor
    • GmagickDraw::setfillcolor - Sets the fill color to be used for drawing filled objects.
    • GmagickDraw::setfillopacity - The setfillopacity purpose
    • GmagickDraw::setfont - Sets the fully-specified font to use when annotating with text.
    • GmagickDraw::setfontsize - Sets the font pointsize to use when annotating with text.
    • GmagickDraw::setfontstyle - Sets the font style to use when annotating with text
    • GmagickDraw::setfontweight - Sets the font weight
    • GmagickDraw::setstrokecolor - Sets the color used for stroking object outlines.
    • GmagickDraw::setstrokeopacity - Specifies the opacity of stroked object outlines.
    • GmagickDraw::setstrokewidth - Sets the width of the stroke used to draw object outlines.
    • GmagickDraw::settextdecoration - Specifies a decoration
    • GmagickDraw::settextencoding - Specifies the text code set
    • GmagickPixel::getcolor - Returns the color
    • GmagickPixel::getcolorcount - Returns the color count associated with this color
    • GmagickPixel::getcolorvalue - Gets the normalized value of the provided color channel
    • GmagickPixel::setcolor - Sets the color
    • GmagickPixel::setcolorvalue - Sets the normalized value of one of the channels
    • GmagickPixel::__construct - The GmagickPixel constructor
    • gmdate - Bir tarih/saati GMT/UTC tarih/saati olarak biçemler
    • gmmktime - Bir GMT tarihi için Unix zaman damgasını döndürür
    • gmp_abs - Absolute value
    • gmp_add - Add numbers
    • gmp_and - Bitwise AND
    • gmp_clrbit - Clear bit
    • gmp_cmp - Compare numbers
    • gmp_com - Calculates one's complement
    • gmp_div - Takma Adı: gmp_div_q
    • gmp_divexact - Exact division of numbers
    • gmp_div_q - Divide numbers
    • gmp_div_qr - Divide numbers and get quotient and remainder
    • gmp_div_r - Remainder of the division of numbers
    • gmp_export - Export to a binary string
    • gmp_fact - Factorial
    • gmp_gcd - Calculate GCD
    • gmp_gcdext - Calculate GCD and multipliers
    • gmp_hamdist - Hamming distance
    • gmp_import - Import from a binary string
    • gmp_init - Create GMP number
    • gmp_intval - Convert GMP number to integer
    • gmp_invert - Inverse by modulo
    • gmp_jacobi - Jacobi symbol
    • gmp_legendre - Legendre symbol
    • gmp_mod - Modulo operation
    • gmp_mul - Multiply numbers
    • gmp_neg - Negate number
    • gmp_nextprime - Find next prime number
    • gmp_or - Bitwise OR
    • gmp_perfect_square - Perfect square check
    • gmp_popcount - Population count
    • gmp_pow - Raise number into power
    • gmp_powm - Raise number into power with modulo
    • gmp_prob_prime - Check if number is "probably prime"
    • gmp_random - Random number
    • gmp_random_bits - Random number
    • gmp_random_range - Random number
    • gmp_random_seed - Sets the RNG seed
    • gmp_root - Take the integer part of nth root
    • gmp_rootrem - Take the integer part and remainder of nth root
    • gmp_scan0 - Scan for 0
    • gmp_scan1 - Scan for 1
    • gmp_setbit - Set bit
    • gmp_sign - Sign of number
    • gmp_sqrt - Calculate square root
    • gmp_sqrtrem - Square root with remainder
    • gmp_strval - Convert GMP number to string
    • gmp_sub - Subtract numbers
    • gmp_testbit - Tests if a bit is set
    • gmp_xor - Bitwise XOR
    • gmstrftime - Yerel ayarlara göre tarih ve saati, GMT/UTC türüne çevirir
    • gnupg_adddecryptkey - Add a key for decryption
    • gnupg_addencryptkey - Add a key for encryption
    • gnupg_addsignkey - Add a key for signing
    • gnupg_cleardecryptkeys - Removes all keys which were set for decryption before
    • gnupg_clearencryptkeys - Removes all keys which were set for encryption before
    • gnupg_clearsignkeys - Removes all keys which were set for signing before
    • gnupg_decrypt - Decrypts a given text
    • gnupg_decryptverify - Decrypts and verifies a given text
    • gnupg_encrypt - Encrypts a given text
    • gnupg_encryptsign - Encrypts and signs a given text
    • gnupg_export - Exports a key
    • gnupg_geterror - Returns the errortext, if a function fails
    • gnupg_getprotocol - Returns the currently active protocol for all operations
    • gnupg_import - Imports a key
    • gnupg_init - Initialize a connection
    • gnupg_keyinfo - Returns an array with information about all keys that matches the given pattern
    • gnupg_setarmor - Toggle armored output
    • gnupg_seterrormode - Sets the mode for error_reporting
    • gnupg_setsignmode - Sets the mode for signing
    • gnupg_sign - Signs a given text
    • gnupg_verify - Verifies a signed text
    • gopher_parsedir - Translate a gopher formatted directory entry into an associative array.
    • grapheme_extract - UTF-8 kodlanmış bir metin tamponundan öntanımlı sesletim kümelerinden oluşan bir dizilimi döndürür
    • grapheme_stripos - Harf büyüklüğüne duyarsız olarak bir dizgede ilk sesletim biriminin yerini bulur
    • grapheme_stristr - Harf büyüklüğüne duyarsız olarak bir dizgedeki ilk sesletim birimine göre ilk veya ikinci parça ile döner
    • grapheme_strlen - Dizgenin sesletim birimi cinsinden uzunluğunu döndürür
    • grapheme_strpos - Bir dizgede ilk sesletim biriminin yerini bulur
    • grapheme_strripos - Harf büyüklüğüne duyarsız olarak bir dizgedeki sonuncu sesletim biriminin yerini bulur
    • grapheme_strrpos - Bir dizgedeki sonuncu sesletim biriminin yerini bulur
    • grapheme_strstr - Bir dizgedeki ilk sesletim birimine göre ilk veya ikinci parça ile döner
    • grapheme_substr - Bir alt dizge döndürür
    • GregorianToJD - Gregoryen tarihini, Jülyen Gün Sayısına çevirir
    • gupnp_context_get_host_ip - Get the IP address
    • gupnp_context_get_port - Get the port
    • gupnp_context_get_subscription_timeout - Get the event subscription timeout
    • gupnp_context_host_path - Start hosting
    • gupnp_context_new - Create a new context
    • gupnp_context_set_subscription_timeout - Sets the event subscription timeout
    • gupnp_context_timeout_add - Sets a function to be called at regular intervals
    • gupnp_context_unhost_path - Stop hosting
    • gupnp_control_point_browse_start - Start browsing
    • gupnp_control_point_browse_stop - Stop browsing
    • gupnp_control_point_callback_set - Set control point callback
    • gupnp_control_point_new - Create a new control point
    • gupnp_device_action_callback_set - Set device callback function
    • gupnp_device_info_get - Get info of root device
    • gupnp_device_info_get_service - Get the service with type
    • gupnp_root_device_get_available - Check whether root device is available
    • gupnp_root_device_get_relative_location - Get the relative location of root device.
    • gupnp_root_device_new - Create a new root device
    • gupnp_root_device_set_available - Set whether or not root_device is available
    • gupnp_root_device_start - Start main loop
    • gupnp_root_device_stop - Stop main loop
    • gupnp_service_action_get - Retrieves the specified action arguments
    • gupnp_service_action_return - Return successfully
    • gupnp_service_action_return_error - Return error code
    • gupnp_service_action_set - Sets the specified action return values
    • gupnp_service_freeze_notify - Freeze new notifications
    • gupnp_service_info_get - Get full info of service
    • gupnp_service_info_get_introspection - Get resource introspection of service
    • gupnp_service_introspection_get_state_variable - Returns the state variable data
    • gupnp_service_notify - Notifies listening clients
    • gupnp_service_proxy_action_get - Send action to the service and get value
    • gupnp_service_proxy_action_set - Send action to the service and set value
    • gupnp_service_proxy_add_notify - Sets up callback for variable change notification
    • gupnp_service_proxy_callback_set - Set service proxy callback for signal
    • gupnp_service_proxy_get_subscribed - Check whether subscription is valid to the service
    • gupnp_service_proxy_remove_notify - Cancels the variable change notification
    • gupnp_service_proxy_send_action - Send action with multiple parameters synchronously
    • gupnp_service_proxy_set_subscribed - (Un)subscribes to the service.
    • gupnp_service_thaw_notify - Sends out any pending notifications and stops queuing of new ones.
    • gzclose - Bir açık gzipli dosya tanıtıcısını kapar
    • gzcompress - Bir dizgeyi sıkıştırır
    • gzdecode - Gzipli bir dizgenin sıkıştırmasını açar
    • gzdeflate - Bir dizgeyi deflate biçeminde sıkıştırır
    • gzencode - Gzipli bir dizge oluşturur
    • gzeof - Gzipli dosya tanıtıcında dosya sonunu sınar
    • gzfile - Gzipli dosyayı bir dizi içinde döndürür
    • gzgetc - Gzipli dosya göstericisindeki karakteri döndürür
    • gzgets - Gzipli dosya tanıtıcısından bir satır döndürür
    • gzgetss - Gzipli dosya tanıtıcısından bir satır okuyup HTML etiketlerinden arındırır
    • gzinflate - Deflate sıkıştırmalı bir verinin sıkıştırmasını açar
    • gzopen - Bir gzipli dosya açar
    • gzpassthru - Gzipli dosya tanıtıcısında kalan verinin tamamını çıktılar
    • gzputs - gzwrite işlevinin takma adıdır
    • gzread - Gzipli dosyayı ikil kipte okur
    • gzrewind - Gzipli dosya göstericisini dosya başlangıcına taşır
    • gzseek - Gzipli dosya göstericisini konumlar
    • gztell - Gzipli dosya tanıtıcısının okuma/yazma konumunu döndürür
    • gzuncompress - Sıkıştırılmış bir dizgenin sıkıştırmasını açar
    • gzwrite - Bir dizgeyi bir gzipli dosyaya ikil kipte yazar
  • h
    • HaruAnnotation::setBorderStyle - Set the border style of the annotation
    • HaruAnnotation::setHighlightMode - Set the highlighting mode of the annotation
    • HaruAnnotation::setIcon - Set the icon style of the annotation
    • HaruAnnotation::setOpened - Set the initial state of the annotation
    • HaruDestination::setFit - Set the appearance of the page to fit the window
    • HaruDestination::setFitB - Set the appearance of the page to fit the bounding box of the page within the window
    • HaruDestination::setFitBH - Set the appearance of the page to fit the width of the bounding box
    • HaruDestination::setFitBV - Set the appearance of the page to fit the height of the boudning box
    • HaruDestination::setFitH - Set the appearance of the page to fit the window width
    • HaruDestination::setFitR - Set the appearance of the page to fit the specified rectangle
    • HaruDestination::setFitV - Set the appearance of the page to fit the window height
    • HaruDestination::setXYZ - Set the appearance of the page
    • HaruDoc::addPage - Add new page to the document
    • HaruDoc::addPageLabel - Set the numbering style for the specified range of pages
    • HaruDoc::createOutline - Create a HaruOutline instance
    • HaruDoc::getCurrentEncoder - Get HaruEncoder currently used in the document
    • HaruDoc::getCurrentPage - Return current page of the document
    • HaruDoc::getEncoder - Get HaruEncoder instance for the specified encoding
    • HaruDoc::getFont - Get HaruFont instance
    • HaruDoc::getInfoAttr - Get current value of the specified document attribute
    • HaruDoc::getPageLayout - Get current page layout
    • HaruDoc::getPageMode - Get current page mode
    • HaruDoc::getStreamSize - Get the size of the temporary stream
    • HaruDoc::insertPage - Insert new page just before the specified page
    • HaruDoc::loadJPEG - Load a JPEG image
    • HaruDoc::loadPNG - Load PNG image and return HaruImage instance
    • HaruDoc::loadRaw - Load a RAW image
    • HaruDoc::loadTTC - Load the font with the specified index from TTC file
    • HaruDoc::loadTTF - Load TTF font file
    • HaruDoc::loadType1 - Load Type1 font
    • HaruDoc::output - Write the document data to the output buffer
    • HaruDoc::readFromStream - Read data from the temporary stream
    • HaruDoc::resetError - Reset error state of the document handle
    • HaruDoc::resetStream - Rewind the temporary stream
    • HaruDoc::save - Save the document into the specified file
    • HaruDoc::saveToStream - Save the document into a temporary stream
    • HaruDoc::setCompressionMode - Set compression mode for the document
    • HaruDoc::setCurrentEncoder - Set the current encoder for the document
    • HaruDoc::setEncryptionMode - Set encryption mode for the document
    • HaruDoc::setInfoAttr - Set the info attribute of the document
    • HaruDoc::setInfoDateAttr - Set the datetime info attributes of the document
    • HaruDoc::setOpenAction - Define which page is shown when the document is opened
    • HaruDoc::setPageLayout - Set how pages should be displayed
    • HaruDoc::setPageMode - Set how the document should be displayed
    • HaruDoc::setPagesConfiguration - Set the number of pages per set of pages
    • HaruDoc::setPassword - Set owner and user passwords for the document
    • HaruDoc::setPermission - Set permissions for the document
    • HaruDoc::useCNSEncodings - Enable Chinese simplified encodings
    • HaruDoc::useCNSFonts - Enable builtin Chinese simplified fonts
    • HaruDoc::useCNTEncodings - Enable Chinese traditional encodings
    • HaruDoc::useCNTFonts - Enable builtin Chinese traditional fonts
    • HaruDoc::useJPEncodings - Enable Japanese encodings
    • HaruDoc::useJPFonts - Enable builtin Japanese fonts
    • HaruDoc::useKREncodings - Enable Korean encodings
    • HaruDoc::useKRFonts - Enable builtin Korean fonts
    • HaruDoc::__construct - Construct new HaruDoc instance
    • HaruEncoder::getByteType - Get the type of the byte in the text
    • HaruEncoder::getType - Get the type of the encoder
    • HaruEncoder::getUnicode - Convert the specified character to unicode
    • HaruEncoder::getWritingMode - Get the writing mode of the encoder
    • HaruFont::getAscent - Get the vertical ascent of the font
    • HaruFont::getCapHeight - Get the distance from the baseline of uppercase letters
    • HaruFont::getDescent - Get the vertical descent of the font
    • HaruFont::getEncodingName - Get the name of the encoding
    • HaruFont::getFontName - Get the name of the font
    • HaruFont::getTextWidth - Get the total width of the text, number of characters, number of words and number of spaces
    • HaruFont::getUnicodeWidth - Get the width of the character in the font
    • HaruFont::getXHeight - Get the distance from the baseline of lowercase letters
    • HaruFont::measureText - Calculate the number of characters which can be included within the specified width
    • HaruImage::getBitsPerComponent - Get the number of bits used to describe each color component of the image
    • HaruImage::getColorSpace - Get the name of the color space
    • HaruImage::getHeight - Get the height of the image
    • HaruImage::getSize - Get size of the image
    • HaruImage::getWidth - Get the width of the image
    • HaruImage::setColorMask - Set the color mask of the image
    • HaruImage::setMaskImage - Set the image mask
    • HaruOutline::setDestination - Set the destination for the outline
    • HaruOutline::setOpened - Set the initial state of the outline
    • HaruPage::arc - Append an arc to the current path
    • HaruPage::beginText - Begin a text object and set the current text position to (0,0)
    • HaruPage::circle - Append a circle to the current path
    • HaruPage::closePath - Append a straight line from the current point to the start point of the path
    • HaruPage::concat - Concatenate current transformation matrix of the page and the specified matrix
    • HaruPage::createDestination - Create new HaruDestination instance
    • HaruPage::createLinkAnnotation - Create new HaruAnnotation instance
    • HaruPage::createTextAnnotation - Create new HaruAnnotation instance
    • HaruPage::createURLAnnotation - Create and return new HaruAnnotation instance
    • HaruPage::curveTo - Append a Bezier curve to the current path
    • HaruPage::curveTo2 - Append a Bezier curve to the current path
    • HaruPage::curveTo3 - Append a Bezier curve to the current path
    • HaruPage::drawImage - Show image at the page
    • HaruPage::ellipse - Append an ellipse to the current path
    • HaruPage::endPath - End current path object without filling and painting operations
    • HaruPage::endText - End current text object
    • HaruPage::eofill - Fill current path using even-odd rule
    • HaruPage::eoFillStroke - Fill current path using even-odd rule, then paint the path
    • HaruPage::fill - Fill current path using nonzero winding number rule
    • HaruPage::fillStroke - Fill current path using nonzero winding number rule, then paint the path
    • HaruPage::getCharSpace - Get the current value of character spacing
    • HaruPage::getCMYKFill - Get the current filling color
    • HaruPage::getCMYKStroke - Get the current stroking color
    • HaruPage::getCurrentFont - Get the currently used font
    • HaruPage::getCurrentFontSize - Get the current font size
    • HaruPage::getCurrentPos - Get the current position for path painting
    • HaruPage::getCurrentTextPos - Get the current position for text printing
    • HaruPage::getDash - Get the current dash pattern
    • HaruPage::getFillingColorSpace - Get the current filling color space
    • HaruPage::getFlatness - Get the flatness of the page
    • HaruPage::getGMode - Get the current graphics mode
    • HaruPage::getGrayFill - Get the current filling color
    • HaruPage::getGrayStroke - Get the current stroking color
    • HaruPage::getHeight - Get the height of the page
    • HaruPage::getHorizontalScaling - Get the current value of horizontal scaling
    • HaruPage::getLineCap - Get the current line cap style
    • HaruPage::getLineJoin - Get the current line join style
    • HaruPage::getLineWidth - Get the current line width
    • HaruPage::getMiterLimit - Get the value of miter limit
    • HaruPage::getRGBFill - Get the current filling color
    • HaruPage::getRGBStroke - Get the current stroking color
    • HaruPage::getStrokingColorSpace - Get the current stroking color space
    • HaruPage::getTextLeading - Get the current value of line spacing
    • HaruPage::getTextMatrix - Get the current text transformation matrix of the page
    • HaruPage::getTextRenderingMode - Get the current text rendering mode
    • HaruPage::getTextRise - Get the current value of text rising
    • HaruPage::getTextWidth - Get the width of the text using current fontsize, character spacing and word spacing
    • HaruPage::getTransMatrix - Get the current transformation matrix of the page
    • HaruPage::getWidth - Get the width of the page
    • HaruPage::getWordSpace - Get the current value of word spacing
    • HaruPage::lineTo - Draw a line from the current point to the specified point
    • HaruPage::measureText - Calculate the byte length of characters which can be included on one line of the specified width
    • HaruPage::moveTextPos - Move text position to the specified offset
    • HaruPage::moveTo - Set starting point for new drawing path
    • HaruPage::moveToNextLine - Move text position to the start of the next line
    • HaruPage::rectangle - Append a rectangle to the current path
    • HaruPage::setCharSpace - Set character spacing for the page
    • HaruPage::setCMYKFill - Set filling color for the page
    • HaruPage::setCMYKStroke - Set stroking color for the page
    • HaruPage::setDash - Set the dash pattern for the page
    • HaruPage::setFlatness - Set flatness for the page
    • HaruPage::setFontAndSize - Set font and fontsize for the page
    • HaruPage::setGrayFill - Set filling color for the page
    • HaruPage::setGrayStroke - Sets stroking color for the page
    • HaruPage::setHeight - Set height of the page
    • HaruPage::setHorizontalScaling - Set horizontal scaling for the page
    • HaruPage::setLineCap - Set the shape to be used at the ends of lines
    • HaruPage::setLineJoin - Set line join style for the page
    • HaruPage::setLineWidth - Set line width for the page
    • HaruPage::setMiterLimit - Set the current value of the miter limit of the page
    • HaruPage::setRGBFill - Set filling color for the page
    • HaruPage::setRGBStroke - Set stroking color for the page
    • HaruPage::setRotate - Set rotation angle of the page
    • HaruPage::setSize - Set size and direction of the page
    • HaruPage::setSlideShow - Set transition style for the page
    • HaruPage::setTextLeading - Set text leading (line spacing) for the page
    • HaruPage::setTextMatrix - Set the current text transformation matrix of the page
    • HaruPage::setTextRenderingMode - Set text rendering mode for the page
    • HaruPage::setTextRise - Set the current value of text rising
    • HaruPage::setWidth - Set width of the page
    • HaruPage::setWordSpace - Set word spacing for the page
    • HaruPage::showText - Print text at the current position of the page
    • HaruPage::showTextNextLine - Move the current position to the start of the next line and print the text
    • HaruPage::stroke - Paint current path
    • HaruPage::textOut - Print the text on the specified position
    • HaruPage::textRect - Print the text inside the specified region
    • hash - Bir ileti özeti üretir
    • hash_algos - Kayıtlı özetleme algoritmalarının bir listesini döndürür
    • hash_copy - Özetleme bağlamını kopyalar
    • hash_equals - Timing attack safe string comparison
    • hash_file - Belirtilen dosyanın içeriğinden bir ileti özeti üretir
    • hash_final - Bir ardışık özetleme işlemini bitirip üretilen özeti döndürür
    • hash_hmac - HMAC yöntemini kullanarak bir anahtarlı ileti özeti üretir
    • hash_hmac_file - Bir dosyanın içeriğinden HMAC yöntemini kullanarak bir anahtarlı ileti özeti üretir
    • hash_init - Ardışık özetleme bağlamını ilklendirir
    • hash_pbkdf2 - Generate a PBKDF2 key derivation of a supplied password
    • hash_update - Veriyi etkin bir özetleme bağlamına dahil eder
    • hash_update_file - Veriyi bir dosyadan etkin bir özetleme bağlamına dahil eder
    • hash_update_stream - Veriyi açık bir akımdan etkin bir özetleme bağlamına dahil eder
    • header - Ham bir HTTP başlığı gönderir
    • headers_list - Gönderilmiş (veya gönderilmeye hazır) yanıt başlıklarının listesiyle döner
    • headers_sent - Başlıklar gönderilmiş mi, gönderilmişse nerede gönderilmiş diye bakar
    • header_register_callback - Call a header function
    • header_remove - Remove previously set headers
    • hebrev - Mantıksal İbranice metni görsel metne dönüştürür
    • hebrevc - Mantıksal İbranice metni satırsonlarıyla birlikte görsel metne dönüştürür
    • hex2bin - Decodes a hexadecimally encoded binary string
    • hexdec - Hexadecimal to decimal
    • highlight_file - Bir dosyadaki sözdizimini vurgular
    • highlight_string - Bir dizgedeki söz dizimini vurgular
    • HRTime\PerformanceCounter::getFrequency - Timer frequency in ticks per second
    • HRTime\PerformanceCounter::getTicks - Current ticks from the system
    • HRTime\PerformanceCounter::getTicksSince - Ticks elapsed since the given value
    • HRTime\StopWatch::getElapsedTicks - Get elapsed ticks for all intervals.
    • HRTime\StopWatch::getElapsedTime - Get elapsed time for all intervals.
    • HRTime\StopWatch::getLastElapsedTicks - Get elapsed ticks for the last interval.
    • HRTime\StopWatch::getLastElapsedTime - Get elapsed time for the last interval.
    • HRTime\StopWatch::isRunning - Whether the measurement is running.
    • HRTime\StopWatch::start - Start time measurement
    • HRTime\StopWatch::stop - Stop time measurement
    • htmlentities - Dönüştürülebilecek tüm karakterleri HTML öğeleri haline getirir
    • htmlspecialchars - Özel karakterleri HTML öğeleri haline getirir
    • htmlspecialchars_decode - Özel HTML öğelerini gerisin geriye karakterlere dönüştürür
    • html_entity_decode - Dönüştürülebilecek tüm HTML öğelerini karakter haline getirir
    • http:// - Accessing HTTP(s) URLs
    • HTTP bağlamı seçenekleri - HTTP bağlamı seçeneklerinin listesi
    • http_build_query - URL kodlamalı sorgu dizgesi üretir
    • http_response_code - Get or Set the HTTP response code
    • hwapi_attribute_new - Creates instance of class hw_api_attribute
    • hwapi_content_new - Create new instance of class hw_api_content
    • hwapi_hgcsp - Returns object of class hw_api
    • hwapi_object_new - Creates a new instance of class hwapi_object_new
    • hw_api::checkin - Checks in an object
    • hw_api::checkout - Checks out an object
    • hw_api::children - Returns children of an object
    • hw_api::content - Returns content of an object
    • hw_api::copy - Copies physically
    • hw_api::dbstat - Returns statistics about database server
    • hw_api::dcstat - Returns statistics about document cache server
    • hw_api::dstanchors - Returns a list of all destination anchors
    • hw_api::dstofsrcanchor - Returns destination of a source anchor
    • hw_api::find - Search for objects
    • hw_api::ftstat - Returns statistics about fulltext server
    • hw_api::hwstat - Returns statistics about Hyperwave server
    • hw_api::identify - Log into Hyperwave Server
    • hw_api::info - Returns information about server configuration
    • hw_api::insert - Inserts a new object
    • hw_api::insertanchor - Inserts a new object of type anchor
    • hw_api::insertcollection - Inserts a new object of type collection
    • hw_api::insertdocument - Inserts a new object of type document
    • hw_api::link - Creates a link to an object
    • hw_api::lock - Locks an object
    • hw_api::move - Moves object between collections
    • hw_api::object - Retrieve attribute information
    • hw_api::objectbyanchor - Returns the object an anchor belongs to
    • hw_api::parents - Returns parents of an object
    • hw_api::remove - Delete an object
    • hw_api::replace - Replaces an object
    • hw_api::setcommittedversion - Commits version other than last version
    • hw_api::srcanchors - Returns a list of all source anchors
    • hw_api::srcsofdst - Returns source of a destination object
    • hw_api::unlock - Unlocks a locked object
    • hw_api::user - Returns the own user object
    • hw_api::userlist - Returns a list of all logged in users
    • hw_api_attribute::key - Returns key of the attribute
    • hw_api_attribute::langdepvalue - Returns value for a given language
    • hw_api_attribute::value - Returns value of the attribute
    • hw_api_attribute::values - Returns all values of the attribute
    • hw_api_content::mimetype - Returns mimetype
    • hw_api_content::read - Read content
    • hw_api_error::count - Returns number of reasons
    • hw_api_error::reason - Returns reason of error
    • hw_api_object::assign - Clones object
    • hw_api_object::attreditable - Checks whether an attribute is editable
    • hw_api_object::count - Returns number of attributes
    • hw_api_object::insert - Inserts new attribute
    • hw_api_object::remove - Removes attribute
    • hw_api_object::title - Returns the title attribute
    • hw_api_object::value - Returns value of attribute
    • hw_api_reason::description - Returns description of reason
    • hw_api_reason::type - Returns type of reason
    • hypot - Calculate the length of the hypotenuse of a right-angle triangle
  • i
    • ibase_add_user - Add a user to a security database
    • ibase_affected_rows - Return the number of rows that were affected by the previous query
    • ibase_backup - Initiates a backup task in the service manager and returns immediately
    • ibase_blob_add - Add data into a newly created blob
    • ibase_blob_cancel - Cancel creating blob
    • ibase_blob_close - Close blob
    • ibase_blob_create - Create a new blob for adding data
    • ibase_blob_echo - Output blob contents to browser
    • ibase_blob_get - Get len bytes data from open blob
    • ibase_blob_import - Create blob, copy file in it, and close it
    • ibase_blob_info - Return blob length and other useful info
    • ibase_blob_open - Open blob for retrieving data parts
    • ibase_close - Close a connection to an InterBase database
    • ibase_commit - Commit a transaction
    • ibase_commit_ret - Commit a transaction without closing it
    • ibase_connect - Open a connection to a database
    • ibase_db_info - Request statistics about a database
    • ibase_delete_user - Delete a user from a security database
    • ibase_drop_db - Drops a database
    • ibase_errcode - Return an error code
    • ibase_errmsg - Return error messages
    • ibase_execute - Execute a previously prepared query
    • ibase_fetch_assoc - Fetch a result row from a query as an associative array
    • ibase_fetch_object - Get an object from a InterBase database
    • ibase_fetch_row - Fetch a row from an InterBase database
    • ibase_field_info - Get information about a field
    • ibase_free_event_handler - Cancels a registered event handler
    • ibase_free_query - Free memory allocated by a prepared query
    • ibase_free_result - Free a result set
    • ibase_gen_id - Increments the named generator and returns its new value
    • ibase_maintain_db - Execute a maintenance command on the database server
    • ibase_modify_user - Modify a user to a security database
    • ibase_name_result - Assigns a name to a result set
    • ibase_num_fields - Get the number of fields in a result set
    • ibase_num_params - Return the number of parameters in a prepared query
    • ibase_param_info - Return information about a parameter in a prepared query
    • ibase_pconnect - Open a persistent connection to an InterBase database
    • ibase_prepare - Prepare a query for later binding of parameter placeholders and execution
    • ibase_query - Execute a query on an InterBase database
    • ibase_restore - Initiates a restore task in the service manager and returns immediately
    • ibase_rollback - Roll back a transaction
    • ibase_rollback_ret - Roll back a transaction without closing it
    • ibase_server_info - Request information about a database server
    • ibase_service_attach - Connect to the service manager
    • ibase_service_detach - Disconnect from the service manager
    • ibase_set_event_handler - Register a callback function to be called when events are posted
    • ibase_trans - Begin a transaction
    • ibase_wait_event - Wait for an event to be posted by the database
    • iconv - Dizgenin karakter kodlamasını dönüştürür
    • iconv_get_encoding - iconv eklentisinin dahili yapılandırma değişkenlerini döndürür
    • iconv_mime_decode - Bir MIME başlık alanının kodunu çözer
    • iconv_mime_decode_headers - Bir defada birden fazla MIME başlık alanını çözümler
    • iconv_mime_encode - Bir MIME başlık alanı tertipler
    • iconv_set_encoding - Karakter kodlaması dönüşümü için geçerli karakter kümesini tanımlar
    • iconv_strlen - Dizgenin karakter sayısı ile döner
    • iconv_strpos - Samanlıktakı ilk iğneyi bulur
    • iconv_strrpos - Samanlıktakı son iğneyi bulur
    • iconv_substr - Bir dizgenin bir alt dizgesini döndürür
    • id3_get_frame_long_name - Get the long name of an ID3v2 frame
    • id3_get_frame_short_name - Get the short name of an ID3v2 frame
    • id3_get_genre_id - Get the id for a genre
    • id3_get_genre_list - Get all possible genre values
    • id3_get_genre_name - Get the name for a genre id
    • id3_get_tag - Get all information stored in an ID3 tag
    • id3_get_version - Get version of an ID3 tag
    • id3_remove_tag - Remove an existing ID3 tag
    • id3_set_tag - Update information stored in an ID3 tag
    • idate - Yerel zamanı/tarihi tamsayı olarak biçimlendirir
    • idn_to_ascii - Alan adını IDNA ASCII biçimine dönüştürür
    • idn_to_utf8 - Alan adı kodlamasını IDNA ASCII'den evrenkoda dönüştürür
    • ifxus_close_slob - Deletes the slob object
    • ifxus_create_slob - Creates an slob object and opens it
    • ifxus_free_slob - Deletes the slob object
    • ifxus_open_slob - Opens an slob object
    • ifxus_read_slob - Reads nbytes of the slob object
    • ifxus_seek_slob - Sets the current file or seek position
    • ifxus_tell_slob - Returns the current file or seek position
    • ifxus_write_slob - Writes a string into the slob object
    • ifx_affected_rows - Get number of rows affected by a query
    • ifx_blobinfile_mode - Set the default blob mode for all select queries
    • ifx_byteasvarchar - Set the default byte mode
    • ifx_close - Close Informix connection
    • ifx_connect - Open Informix server connection
    • ifx_copy_blob - Duplicates the given blob object
    • ifx_create_blob - Creates an blob object
    • ifx_create_char - Creates an char object
    • ifx_do - Execute a previously prepared SQL-statement
    • ifx_error - Returns error code of last Informix call
    • ifx_errormsg - Returns error message of last Informix call
    • ifx_fetch_row - Get row as an associative array
    • ifx_fieldproperties - List of SQL fieldproperties
    • ifx_fieldtypes - List of Informix SQL fields
    • ifx_free_blob - Deletes the blob object
    • ifx_free_char - Deletes the char object
    • ifx_free_result - Releases resources for the query
    • ifx_getsqlca - Get the contents of sqlca.sqlerrd[0..5] after a query
    • ifx_get_blob - Return the content of a blob object
    • ifx_get_char - Return the content of the char object
    • ifx_htmltbl_result - Formats all rows of a query into a HTML table
    • ifx_nullformat - Sets the default return value on a fetch row
    • ifx_num_fields - Returns the number of columns in the query
    • ifx_num_rows - Count the rows already fetched from a query
    • ifx_pconnect - Open persistent Informix connection
    • ifx_prepare - Prepare an SQL-statement for execution
    • ifx_query - Send Informix query
    • ifx_textasvarchar - Set the default text mode
    • ifx_update_blob - Updates the content of the blob object
    • ifx_update_char - Updates the content of the char object
    • ignore_user_abort - Bir istemci bağlantıyı terkettiğinde betiğin sonlandırılıp sonlandırılmayacağını belirler
    • iis_add_server - Creates a new virtual web server
    • iis_get_dir_security - Gets Directory Security
    • iis_get_script_map - Gets script mapping on a virtual directory for a specific extension
    • iis_get_server_by_comment - Return the instance number associated with the Comment
    • iis_get_server_by_path - Return the instance number associated with the Path
    • iis_get_server_rights - Gets server rights
    • iis_get_service_state - Returns the state for the service defined by ServiceId
    • iis_remove_server - Removes the virtual web server indicated by ServerInstance
    • iis_set_app_settings - Creates application scope for a virtual directory
    • iis_set_dir_security - Sets Directory Security
    • iis_set_script_map - Sets script mapping on a virtual directory
    • iis_set_server_rights - Sets server rights
    • iis_start_server - Starts the virtual web server
    • iis_start_service - Starts the service defined by ServiceId
    • iis_stop_server - Stops the virtual web server
    • iis_stop_service - Stops the service defined by ServiceId
    • image2wbmp - Bir dosyaya veya tarayıcıya bir WBMP resmi çıktılar
    • imageaffine - Return an image containing the affine transformed src image, using an optional clipping area
    • imageaffinematrixconcat - Concatenate two affine transformation matrices
    • imageaffinematrixget - Get an affine transformation matrix
    • imagealphablending - Bir resim için harmanlama kipini etkinleştirir
    • imageantialias - Kenar yumuşatma işlevlerini uygulatır
    • imagearc - Bir yay çizer
    • imagebmp - Output a BMP image to browser or file
    • imagechar - Yatay olarak bir karakter çizer
    • imagecharup - Düşey olarak bir karakter çizer
    • imagecolorallocate - Bir resim için bir renk ayırır
    • imagecolorallocatealpha - Bir resim için alfa kanallı bir renk ayırır
    • imagecolorat - Bir pikselin renk indisini döndürür
    • imagecolorclosest - Belirtilen rengin en yakın benzerinin indisini döndürür
    • imagecolorclosestalpha - Alfası ile birlikte belirtilen rengin en yakın benzerinin renk indisini verir
    • imagecolorclosesthwb - En yakın renk sıcaklığına, beyaz ve siyahlığa sahip renk indisini verir
    • imagecolordeallocate - Bir rengi tanımsız yapar
    • imagecolorexact - Belirtilen rengin indisini döndürür
    • imagecolorexactalpha - Alfası ile birlikte belirtilen rengin indisini verir
    • imagecolormatch - Bir resmin paletli sürümünün renklerini gerçek renkli sürümünün renkleriyle aynı yapar
    • imagecolorresolve - Belirtilen rengin veya en yakın benzerinin indisini döndürür
    • imagecolorresolvealpha - Alfası ile birlikte belirtilen rengin veya en yakın benzerinin renk indisini verir
    • imagecolorset - Bir palet indisi için renk tanımlar
    • imagecolorsforindex - Bir renk indisinin renk bilgisini döndürür
    • imagecolorstotal - Bir resim paletindeki renk sayısını döndürür
    • imagecolortransparent - Bir rengi şeffaflaştırır
    • imageconvolution - Bir konum ve katsayı ile 3x3'lük bir evrişim matrisini uygular
    • imagecopy - Bir resim parçasını kopyalar
    • imagecopymerge - Bir resmi kopyalar ve karıştırır
    • imagecopymergegray - Bir resmi kopyalar ve gri tonlama ile karıştırır
    • imagecopyresampled - Resmin bir parçasını örnekleyerek kopyalar ve boyutlandırır
    • imagecopyresized - Resmin bir parçasını kopyalar ve boyutlandırır
    • imagecreate - Yeni bir paletli resim oluşturur
    • imagecreatefrombmp - Bir dosya veya URL'den yeni bir resim oluşturur.
    • imagecreatefromgd - Bir GD dosyasından veya URL'sinden yeni bir resim oluşturur
    • imagecreatefromgd2 - Bir GD2 dosyasından veya URL'sinden yeni bir resim oluşturur
    • imagecreatefromgd2part - Bir GD2 parça dosyasından veya URL'sinden yeni bir resim oluşturur
    • imagecreatefromgif - Bir dosya veya URL'den yeni bir resim oluşturur.
    • imagecreatefromjpeg - Bir dosya veya URL'den yeni bir resim oluşturur.
    • imagecreatefrompng - Bir dosya veya URL'den yeni bir resim oluşturur.
    • imagecreatefromstring - Belirtilen dizgeden yeni bir resim oluşturur
    • imagecreatefromwbmp - Bir dosya veya URL'den yeni bir resim oluşturur.
    • imagecreatefromwebp - Bir dosya veya URL'den yeni bir resim oluşturur.
    • imagecreatefromxbm - Bir dosya veya URL'den yeni bir resim oluşturur.
    • imagecreatefromxpm - Bir XPM dosyasından veya URL'sinden yeni bir resim oluşturur
    • imagecreatetruecolor - Yeni bir gerçek renkli resim oluşturur
    • imagecrop - Crop an image to the given rectangle
    • imagecropauto - Crop an image automatically using one of the available modes
    • imagedashedline - Kesikli çizgi çizer
    • imagedestroy - Bir resmi bellekten siler
    • imageellipse - Bir elips çizer
    • imagefill - Resmi boyar
    • imagefilledarc - Bir yay çizer ve içini doldurur
    • imagefilledellipse - İçi dolu bir elips çizer
    • imagefilledpolygon - İçi dolu bir çokgen çizer
    • imagefilledrectangle - İçi dolu bir dikdörtgen çizer
    • imagefilltoborder - Belli bir bölgeyi belli bir renge boyar
    • imagefilter - Bir resme bir süzgeç uygular
    • imageflip - Flips an image using a given mode
    • imagefontheight - Yazı tipi yüksekliğini döndürür
    • imagefontwidth - Yazı tipi genişliğini döndürür
    • imageftbbox - Bir FreeType2 yazı tipi ile yazılacak bir metnin çerçevesini hesaplar
    • imagefttext - Bir metni bir resme bir FreeType 2 yazı tipini kullanarak yazar
    • imagegammacorrect - Bir GD resmine gamma düzeltmesi uygular
    • imagegd - Tarayıcıya veya bir dosyaya bir GD resmi çıktılar
    • imagegd2 - Tarayıcıya veya bir dosyaya bir GD2 resmi çıktılar
    • imagegetclip - Get the clipping rectangle
    • imagegif - Bir dosyaya veya tarayıcıya bir GIF resmi çıktılar
    • imagegrabscreen - Ekran görüntüsünü yakalar
    • imagegrabwindow - Bir pencereyi yakalar
    • imageinterlace - Geçişimliliği açıp kapar
    • imageistruecolor - Bir resmin gerçek renkli olup olmadığını bulur
    • imagejpeg - Tarayıcıya veya bir dosyaya bir JPEG resmi çıktılar
    • imagelayereffect - PHP ile gelen libgd'nin katmanlama etkisini kullanmak için alfa harmanlama seçeneğini ayarlar
    • imageline - Bir çizgi çizer
    • imageloadfont - Yeni bir bit eşlemli yazı tipi yükler
    • imageopenpolygon - Draws an open polygon
    • imagepalettecopy - Paleti bir resimden diğerine kopyalar
    • imagepalettetotruecolor - Converts a palette based image to true color
    • imagepng - Tarayıcıya veya bir dosyaya bir PNG resmi çıktılar
    • imagepolygon - Çokgen çizer
    • imagepsbbox - Bir PostScript Type1 yazı tipi ile yazılan bir metnin çerçevesini döndürür
    • imagepsencodefont - Bir yazı tipinin karakter kodlamasını değiştirir
    • imagepsextendfont - Bir PS yazı tipini genişletir veya daraltır
    • imagepsfreefont - Bir PostScript Type 1 yazı tipi tarafından kullanılan belleği serbest bırakır
    • imagepsloadfont - Bir dosyadan bir PostScript Type 1 yazı tipi yükler
    • imagepsslantfont - Bir yazı tipini eğer
    • imagepstext - PostScript Type1 yazı tiplerini kullanarak bir resmin üzerine bir metin çizer
    • imagerectangle - Bir dikdörtgen çizer
    • imageresolution - Get or set the resolution of the image
    • imagerotate - Bir resmi belirtilen açıya göre döndürür
    • imagesavealpha - PNG resimleri kaydederken (tek renkli şeffaflığın tersine) alfa kanalı bilgisinin kaydedilip kaydedilmeyeceğini belirtir
    • imagescale - Scale an image using the given new width and height
    • imagesetbrush - Çizgi çizmek için fırça resmi oluşturur
    • imagesetclip - Set the clipping rectangle
    • imagesetinterpolation - Set the interpolation method
    • imagesetpixel - Bir pikselin rengini değiştirir
    • imagesetstyle - Çizgi tarzını ayarlar
    • imagesetthickness - Çizgi kalınlığını ayarlar
    • imagesettile - Resmi doldurmak için döşemeyi etkin kılar
    • imagestring - Bir dizgeyi yatay olarak yazar
    • imagestringup - Bir dizgeyi 90 derece döndürülmüş olarak yazar
    • imagesx - Resmin genişliğini döndürür
    • imagesy - Resmin yüksekliğini döndürür
    • imagetruecolortopalette - Bir gerçek renkli resmi bir paletli resme dönüştürür
    • imagettfbbox - TrueType yazıtipi kullanılan bir metnin çerçevesini döndürür
    • imagettftext - Metni resme TrueType yazı tipi ile yazar
    • imagetypes - Kurulu PHP'nin desteklediği resim türlerini döndürür
    • imagewbmp - Resmi bir dosyaya veya tarayıcıya çıktılar
    • imagewebp - Output a WebP image to browser or file
    • imagexbm - Bir XBM resmini tarayıcıya veya dosyaya çıktılar
    • image_type_to_extension - Resim türü ile ilgili dosya uzantısını döndürür
    • image_type_to_mime_type - getimagesize, exif_read_data, exif_thumbnail, exif_imagetype ile döndürülen resim türü ile ilgili MIME türünü döndürür
    • Imagick::adaptiveBlurImage - Resmi uyarlamalı olarak bulanıklaştırır
    • Imagick::adaptiveResizeImage - Nirengi noktasına göre uyarlamalı olarak resmi boyutlandırır
    • Imagick::adaptiveSharpenImage - Uyarlamalı olarak resmi netleştirir
    • Imagick::adaptiveThresholdImage - Bir yoğunluk aralığına göre her piksel için bir eşik seçer
    • Imagick::addImage - Imagick resim listesine yeni bir resim ekler
    • Imagick::addNoiseImage - Resme rasgele gürültü ekler
    • Imagick::affineTransformImage - Resmi dönüştürür
    • Imagick::animateImages - Bir resmi veya resimleri canlandırır
    • Imagick::annotateImage - Resme bir metin çizer
    • Imagick::appendImages - Bir resim kümesini ekler
    • Imagick::autoLevelImage - Description
    • Imagick::averageImages - Bir resim kümesinin ortalamasını alır
    • Imagick::blackThresholdImage - Eşiğin altında kalan tüm renkleri siyaha çevirir
    • Imagick::blueShiftImage - Description
    • Imagick::blurImage - Resme bir bulanıklık süzgeci ekler
    • Imagick::borderImage - Resme bir çerçeve çizer
    • Imagick::brightnessContrastImage - Description
    • Imagick::charcoalImage - Kara kalem çizimi taklit eder
    • Imagick::chopImage - Bir resmin bir bölgesini silerek kırpar
    • Imagick::clampImage - Description
    • Imagick::clear - Imagick nesnesi ile ilgili tüm özkaynakları temizler
    • Imagick::clipImage - 8BIM profilindeki ilk yol boyunca resmi kırpar
    • Imagick::clipImagePath - Description
    • Imagick::clipPathImage - 8BIM profili boyunca isimli yolları kırpar
    • Imagick::clone - Imagick nesnesinin tam bir kopyasını yapar
    • Imagick::clutImage - Resmin renklerini değiştirir
    • Imagick::coalesceImages - Bir resim kümesini tek bir resim olarak birleştirir
    • Imagick::colorFloodfillImage - Hedefle eşleşen her pikselin rengini değiştirir
    • Imagick::colorizeImage - Resmin her pikseline dolgu rengini karıştırır
    • Imagick::colorMatrixImage - Description
    • Imagick::combineImages - Bir veya daha fazla resmi tek bir resim halinde birleştirir
    • Imagick::commentImage - Resme bir açıklama ekler
    • Imagick::compareImageChannels - Bir veya daha fazla resmin farkını döndürür
    • Imagick::compareImageLayers - Resim katmanlarını karşılaştırıp en iyilenmiş resmi döndürür
    • Imagick::compareImages - Resmi yeniden oluşturulan resimle karşılaştırır
    • Imagick::compositeImage - Bir resmi diğeriyle birleştirir
    • Imagick::contrastImage - Resmin zıtlığını değiştirir
    • Imagick::contrastStretchImage - Renkli bir resmin zıtlığını ayarlar
    • Imagick::convolveImage - Resme bir evrişim çekirdeği uygular
    • Imagick::count - Description
    • Imagick::cropImage - Resmin bir bölgesini çıkarır
    • Imagick::cropThumbnailImage - Resmin kırpık bir örneğini oluşturur
    • Imagick::current - Geçerli Imagick nesnesini döndürür
    • Imagick::cycleColormapImage - Bir resmin renk eşleminin bir kısmını değiştirir
    • Imagick::decipherImage - Şifreli bir resmin şifresini çözer
    • Imagick::deconstructImages - Resimler arasındaki farklı piksellerin kapladığı en büyük alanı döndürür
    • Imagick::deleteImageArtifact - Delete image artifact
    • Imagick::deleteImageProperty - Description
    • Imagick::deskewImage - Removes skew from the image
    • Imagick::despeckleImage - Resmin benekli görünümünü düzeltir
    • Imagick::destroy - Imagick nesnesini siler
    • Imagick::displayImage - Bir resmi gösterir
    • Imagick::displayImages - Bir resim dizisini gösterir
    • Imagick::distortImage - Çeşitli yöntemlerle resmi bozunuma uğratır
    • Imagick::drawImage - Belirtilen ImagickDraw nesnesini resme uygular
    • Imagick::edgeImage - Resmin kenarlarını evriştirir
    • Imagick::embossImage - Üç boyutluluk etkisi vermek için resmi gri tonlamaya dönüştürür
    • Imagick::encipherImage - Bir resmi şifreler
    • Imagick::enhanceImage - Resmin görüntü kalitesini arttırır
    • Imagick::equalizeImage - Resmin renk dağılımını dengeler
    • Imagick::evaluateImage - Resme bir ifade uygular
    • Imagick::exportImagePixels - Exports raw image pixels
    • Imagick::extentImage - Resim boyutlarını belirler
    • Imagick::filter - Description
    • Imagick::flattenImages - Bir resim dizisini tek bir resim halinde üstüste bindirir
    • Imagick::flipImage - Resmin düşeydeki yansımasını oluşturur
    • Imagick::floodFillPaintImage - Hedefle eşleşen piksellerin renklerini değiştirir
    • Imagick::flopImage - Resmin yataydaki yansımasını oluşturur
    • Imagick::forwardFourierTransformImage - Description
    • Imagick::frameImage - Üç boyutluluğu taklit ederek bir çerçeve ekler
    • Imagick::functionImage - Applies a function on the image
    • Imagick::fxImage - Bir ifadeyi resimdeki her piksele uygular
    • Imagick::gammaImage - Resmin gammasını düzeltir
    • Imagick::gaussianBlurImage - Resmi bulanıklaştırır
    • Imagick::getColorspace - Gets the colorspace
    • Imagick::getCompression - Nesnenin sıkıştırma türünü döndürür
    • Imagick::getCompressionQuality - Nesnenin sıkıştırma seviyesini döndürür
    • Imagick::getCopyright - ImageMagick telif hakkı bilgisini döndürür
    • Imagick::getFilename - Resim dizisi ile ilişkili dosya ismini döndürür
    • Imagick::getFont - Yazıtipini döndürür
    • Imagick::getFormat - Imagick nesnesinin biçemini döndürür
    • Imagick::getGravity - Gets the gravity
    • Imagick::getHomeURL - ImageMagick sitesinin adresini döndürür
    • Imagick::getImage - Yeni bir Imagick nesnesi döndürür
    • Imagick::getImageAlphaChannel - Gets the image alpha channel
    • Imagick::getImageArtifact - Get image artifact
    • Imagick::getImageAttribute - Description
    • Imagick::getImageBackgroundColor - Resmin artalan rengini döndürür
    • Imagick::getImageBlob - Resim dizisini ber ikil dizge olarak döndürür
    • Imagick::getImageBluePrimary - Resmin renk bileşenlerinden birincil mavi noktayı döndürür
    • Imagick::getImageBorderColor - Resmin çerçeve rengini döndürür
    • Imagick::getImageChannelDepth - Belirtilen kanalın derinliğini döndürür
    • Imagick::getImageChannelDistortion - Resmin kanallarını yeniden oluşturulan bir resimle karşılaştırır
    • Imagick::getImageChannelDistortions - Gets channel distortions
    • Imagick::getImageChannelExtrema - Belirtilen kanalların uç değerlerini döndürür
    • Imagick::getImageChannelKurtosis - The getImageChannelKurtosis purpose
    • Imagick::getImageChannelMean - Kanal ortalama ve standart sapmasını döndürür
    • Imagick::getImageChannelRange - Gets channel range
    • Imagick::getImageChannelStatistics - Resimdeki her kanalın istatistiklerini döndürür
    • Imagick::getImageClipMask - Resim kırpma maskesini döndürür
    • Imagick::getImageColormapColor - Renk eşlemi indisi belirtilen rengi döndürür
    • Imagick::getImageColors - Resimdeki eşsiz renklerin sayısını döndürür
    • Imagick::getImageColorspace - Resmin renk uzayını döndürür
    • Imagick::getImageCompose - Resimle ilgili birleştirme işlecini döndürür
    • Imagick::getImageCompression - Resmin sıkıştırma türünü döndürür
    • Imagick::getImageCompressionQuality - Resmin sıkıştırma seviyesini döndürür
    • Imagick::getImageDelay - Resim gecikmesini döndürür
    • Imagick::getImageDepth - Resim derinliğini döndürür
    • Imagick::getImageDispose - Resmin elden çıkarma yöntemini döndürür
    • Imagick::getImageDistortion - Resmi yeniden oluşturulmuş bir resimle karşılaştırır
    • Imagick::getImageExtrema - Resimle ilgili uç değerleri döndürür
    • Imagick::getImageFilename - Bir resim dizisindeki belli bir resmin dosya ismini döndürür
    • Imagick::getImageFormat - Bir resim dizisindeki belli bir resmin biçemini döndürür
    • Imagick::getImageGamma - Resmin gammasını döndürür
    • Imagick::getImageGeometry - Resmin genişliğini ve yüksekliğini bir ilişkisel dizi olarak döndürür
    • Imagick::getImageGravity - Gets the image gravity
    • Imagick::getImageGreenPrimary - Resmin renk bileşenlerinden birincil yeşil noktayı döndürür
    • Imagick::getImageHeight - Resmin yüksekliğini döndürür
    • Imagick::getImageHistogram - Resmin renk dağılımını döndürür
    • Imagick::getImageIndex - Geçerli etkin resmin indisini döndürür
    • Imagick::getImageInterlaceScheme - Resmin geçişim şemasını döndürür
    • Imagick::getImageInterpolateMethod - Aradeğerleme yöntemini döndürür
    • Imagick::getImageIterations - Resim yineleme sayısını döndürür
    • Imagick::getImageLength - Resim uzunluğunu döndürür
    • Imagick::getImageMagickLicense - ImageMagick lisans bilgisini içeren bir dizge döndürür
    • Imagick::getImageMatte - Resmin bir matlık kanalı varsa TRUE döndürür
    • Imagick::getImageMatteColor - Resmin matlık rengini döndürür
    • Imagick::getImageMimeType - Description
    • Imagick::getImageOrientation - Resim baskı yönünü döndürür
    • Imagick::getImagePage - Sayfa geometrisini döndürür
    • Imagick::getImagePixelColor - Belirtilen pikselin rengini döndürür
    • Imagick::getImageProfile - İsimli resim profilini döndürür
    • Imagick::getImageProfiles - Resim profillerini döndürür
    • Imagick::getImageProperties - Resim özelliklerini döndürür
    • Imagick::getImageProperty - İsimli resim özelliğini döndürür
    • Imagick::getImageRedPrimary - Resmin renk bileşenlerinden birincil kırmızı noktasını döndürür
    • Imagick::getImageRegion - Resmin bir bölgesini çıkarır
    • Imagick::getImageRenderingIntent - Resme komutların uygulanış tarzını döndürür
    • Imagick::getImageResolution - Resmin X ve Y çözünürlüklerini döndürür
    • Imagick::getImagesBlob - Tüm resim dizilerini bir ikil dizge olarak döndürür
    • Imagick::getImageScene - Resmin artalan dekorunu döndürür
    • Imagick::getImageSignature - Resmin SHA-256 ileti özetini üretir
    • Imagick::getImageSize - Resim uzunluğunu bayt cinsinden döndürür
    • Imagick::getImageTicksPerSecond - Resmin saniyedeki tik sayısını döndürür
    • Imagick::getImageTotalInkDensity - Resmin belli bir renginin toplam yoğunluğunu döndürür
    • Imagick::getImageType - Olası resim türünü döndürür
    • Imagick::getImageUnits - Resim çözünürlük birimlerini döndürür
    • Imagick::getImageVirtualPixelMethod - Sanal piksel yöntemini döndürür
    • Imagick::getImageWhitePoint - Resmin renk bileşenlerinden beyaz noktayı döndürür
    • Imagick::getImageWidth - Resim genişliğini döndürür
    • Imagick::getInterlaceScheme - Nesne geçişim şemasını döndürür
    • Imagick::getIteratorIndex - Geçerli etkin resmin indisini döndürür
    • Imagick::getNumberImages - Nesnedeki resim sayısını döndürür
    • Imagick::getOption - Belirtilen anahtarla ilgili değeri döndürür
    • Imagick::getPackageName - ImageMagick paket ismini döndürür
    • Imagick::getPage - Sayfa geometrisini döndürür
    • Imagick::getPixelIterator - Bir MagickPixelIterator nesnesi döndürür
    • Imagick::getPixelRegionIterator - Bir resim bölümü için bir ImagickPixelIterator nesnesi döndürür
    • Imagick::getPointSize - Punto değerini döndürür
    • Imagick::getQuantum - Description
    • Imagick::getQuantumDepth - Parçacık derinliğini döndürür
    • Imagick::getQuantumRange - Imagick parçacık aralığını döndürür
    • Imagick::getRegistry - Description
    • Imagick::getReleaseDate - ImageMagick dağıtım tarihini döndürür
    • Imagick::getResource - Belirtilen özkaynağın bellek kullanımını döndürür
    • Imagick::getResourceLimit - Belirtilen özkaynağın bellek kullanım sınırını döndürür
    • Imagick::getSamplingFactors - Yatay ve düşey örnekleme katsayısını döndürür
    • Imagick::getSize - Imagick nesnesi ile ilgili boyutları döndürür
    • Imagick::getSizeOffset - Boyut başlangıç noktasını döndürür
    • Imagick::getVersion - ImageMagick API sürümünü döndürür
    • Imagick::haldClutImage - Replaces colors in the image
    • Imagick::hasNextImage - Resmin sonrasında bir resim daha var mı diye bakar
    • Imagick::hasPreviousImage - Resmin öncesinde bir resim daha var mı diye bakar
    • Imagick::identifyFormat - Description
    • Imagick::identifyImage - Resmin özniteliklerini döndürerek resmi tanımlar
    • Imagick::implodeImage - Resmi kopyalamak suretiyle yeni bir resim oluşturur
    • Imagick::importImagePixels - Imports image pixels
    • Imagick::inverseFourierTransformImage - Description
    • Imagick::labelImage - Resme bir yafta ekler
    • Imagick::levelImage - Bir resmin seviyelerini ayarlar
    • Imagick::linearStretchImage - Resmin koyuluğunu doygunluk ile abartır
    • Imagick::liquidRescaleImage - Bir resmi veya resimleri canlandırır
    • Imagick::listRegistry - Description
    • Imagick::magnifyImage - Enboy oranını koruyarak resmi iki katına büyütür
    • Imagick::mapImage - Resmin renklerini belirtilen resimdeki en yakın renklerle değiştirir
    • Imagick::matteFloodfillImage - Bir rengin şeffaflık değerini değiştirir
    • Imagick::medianFilterImage - Resme bir sayısal süzgeç uygular
    • Imagick::mergeImageLayers - Resim katmanlarını katıştırır
    • Imagick::minifyImage - Enboy oranını koruyarak resmi yarı boyutuna indirir
    • Imagick::modulateImage - Resmin parlaklık, doygunluk ve renk sıcaklığını denetler
    • Imagick::montageImage - Birleşik bir resim oluşturur
    • Imagick::morphImages - Bir resim dizisini başkalaşıma uğratır
    • Imagick::morphology - Description
    • Imagick::mosaicImages - Resimlerden bir mozaik oluşturur
    • Imagick::motionBlurImage - Hareket bulanıklığını taklit eder
    • Imagick::negateImage - Resmin renklerini negatiflerine dönüştürür
    • Imagick::newImage - Yeni bir resim oluşturur
    • Imagick::newPseudoImage - Yeni bir resim oluşturur
    • Imagick::nextImage - Bir sonraki resme gider
    • Imagick::normalizeImage - Renkli bir resmin zıtlığını arttırır
    • Imagick::oilPaintImage - Yağlı boya resmi taklit eder
    • Imagick::opaquePaintImage - Hedef ile eşleşen piksellerin rengini değiştirir
    • Imagick::optimizeImageLayers - En iyilemek amacıyla resimlerin tekrarlanan bölümlerini siler
    • Imagick::orderedPosterizeImage - Resme kurallı titreklik uygular
    • Imagick::paintFloodfillImage - Belirtilen renkle eşleşen piksellerin rengini değiştirir
    • Imagick::paintOpaqueImage - Bir rengi bir başka renkle değiştirir
    • Imagick::paintTransparentImage - Resimdeki belli bir rengi dolgu rengiyle değiştirir
    • Imagick::pingImage - Temel resim özniteliklerini bir dosyadan okur
    • Imagick::pingImageBlob - Temel resim özniteliklerini bir dizgeden okur
    • Imagick::pingImageFile - Temel resim özniteliklerini bir akımdan okur
    • Imagick::polaroidImage - Polaroid resmi taklit eder
    • Imagick::posterizeImage - Resimdeki renkleri belli bir sayıya düşürür
    • Imagick::previewImages - Resim üzerinde yapılacak bir işlem için en uygun değiştirgenin tespitini hızlandırır
    • Imagick::previousImage - Bir önceki resme gider
    • Imagick::profileImage - Bir resme profil ekler veya çıkarır
    • Imagick::quantizeImage - Belli bir resim içindeki renk miktarını bulur
    • Imagick::quantizeImages - Bir resim kümesi içindeki renk miktarını bulur
    • Imagick::queryFontMetrics - Yazı tipinin özelliklerini içeren bir dizi döndürür
    • Imagick::queryFonts - Yapılandırımış yazı tiplerini döndürür
    • Imagick::queryFormats - Imagick tarafından desteklenen biçemleri döndürür
    • Imagick::radialBlurImage - Bir resme dairesel bulanıklık uygular
    • Imagick::raiseImage - 3 boyutlu düğme benzeri bir etki oluşturur
    • Imagick::randomThresholdImage - Yüksek zıtlığa sahip iki renkli bir resim oluşturur
    • Imagick::readImage - Resmi dosyadar okur
    • Imagick::readImageBlob - Resmi ikil bir dizgeden okur
    • Imagick::readImageFile - Resmi akımdan okur
    • Imagick::readimages - Description
    • Imagick::recolorImage - Resmi yeniden renklendirir
    • Imagick::reduceNoiseImage - Bir resmin dış hatlarını yumuşatır
    • Imagick::remapImage - Remaps image colors
    • Imagick::removeImage - Resim kümesinden bir resim siler
    • Imagick::removeImageProfile - İsimli resim profilini silip döndürür
    • Imagick::render - Evvelce verilmiş tüm çizim komutlarını uygular
    • Imagick::resampleImage - Belirtilen çözünürlüğe göre resmi yeniden örnekler
    • Imagick::resetImagePage - Resim sayfasını sıfırlar
    • Imagick::resizeImage - Bir resmi boyutlandırır
    • Imagick::rollImage - Bir resmin başlangıç noktasını tanımlar
    • Imagick::rotateImage - Resmi döndürür
    • Imagick::rotationalBlurImage - Description
    • Imagick::roundCorners - Resmin köşelerini yuvarlatır
    • Imagick::sampleImage - Resmi piksel örneklemeyle oranlar
    • Imagick::scaleImage - Bir resmin enboy oranını ayarlar
    • Imagick::segmentImage - Segments an image
    • Imagick::selectiveBlurImage - Description
    • Imagick::separateImageChannel - Resimden bir kanalı ayırır
    • Imagick::sepiaToneImage - Resme kızıl kahverengi tonlama uygular
    • Imagick::setBackgroundColor - Nesnenin öntanımlı artalan rengini tanımlar
    • Imagick::setColorspace - Set colorspace
    • Imagick::setCompression - Nesnenin öntanımlı sıkıştırma türünü tanımlar
    • Imagick::setCompressionQuality - Nesnenin öntanımlı sıkıştırma seviyesini tanımlar
    • Imagick::setFilename - Bir resim için dosya ismi tanımlar
    • Imagick::setFirstIterator - Imagick yineleyiciyi ilk resme konumlar
    • Imagick::setFont - Imagick nesnesinin yazı tipini tanımlar
    • Imagick::setFormat - Imagick nesnesinin biçemini tanımlar
    • Imagick::setGravity - Sets the gravity
    • Imagick::setImage - Nesnedeki resmi değiştirir
    • Imagick::setImageAlphaChannel - Resmin şeffaflık kanalını tanımlar
    • Imagick::setImageArtifact - Set image artifact
    • Imagick::setImageAttribute - Description
    • Imagick::setImageBackgroundColor - Resmin artalan rengini tanımlar
    • Imagick::setImageBias - Bir resmi evriştirmekte kullanılan yöntem için resim sapmasını tanımlar
    • Imagick::setImageBiasQuantum - Description
    • Imagick::setImageBluePrimary - Resmin renk bileşenlerinden birincil mavi noktasını tanımlar
    • Imagick::setImageBorderColor - Resmin çerçeve rengini tanımlar
    • Imagick::setImageChannelDepth - Belli bir resim kanalının derinliğini tanımlar
    • Imagick::setImageClipMask - Resim kırpma maskesini tanımlar
    • Imagick::setImageColormapColor - Renk eşlemi indisi belirtilen rengi tanımlar
    • Imagick::setImageColorspace - Resmin renk uzayını tanımlar
    • Imagick::setImageCompose - Resim birleştirme işlecini tanımlar
    • Imagick::setImageCompression - Resim sıkıştırma seviyesini tanımlar
    • Imagick::setImageCompressionQuality - Resim sıkıştırma seviyesini belirler
    • Imagick::setImageDelay - Resim gecikmesini tanımlar
    • Imagick::setImageDepth - Resim derinliğini tanımlar
    • Imagick::setImageDispose - Resmin elden çıkarma yöntemini tanımlar
    • Imagick::setImageExtent - Resmin boyutlarını tanımlar
    • Imagick::setImageFilename - Belli bir resmin dosya ismini tanımlar
    • Imagick::setImageFormat - Belli bir resmin biçemini tanımlar
    • Imagick::setImageGamma - Resmin gammasını tanımlar
    • Imagick::setImageGravity - Sets the image gravity
    • Imagick::setImageGreenPrimary - Resmin renk bileşenlerinden birincil yeşil noktasını tanımlar
    • Imagick::setImageIndex - Yineleyici konumunu tanımlar
    • Imagick::setImageInterlaceScheme - Resim geçişim şemasını tanımlar
    • Imagick::setImageInterpolateMethod - Resmin aradeğer pikseli yöntemini tanımlar
    • Imagick::setImageIterations - Resim yineleme sayısını tanımlar
    • Imagick::setImageMatte - Resmin matlık kanalını ayarlar
    • Imagick::setImageMatteColor - Resmin şeffaf rengini tanımlar
    • Imagick::setImageOpacity - Resmin matlık seviyesini tanımlar
    • Imagick::setImageOrientation - Resmin baskı yönünü tanımlar
    • Imagick::setImagePage - Resmin sayfa geometrisini tanımlar
    • Imagick::setImageProfile - Imagick nesnesine isimli bir profil ekler
    • Imagick::setImageProperty - Bir resim özelliğini tanımlar
    • Imagick::setImageRedPrimary - Resmin renk bileşenlerinden birincil kırmızı noktasını tanımlar
    • Imagick::setImageRenderingIntent - Resme komutların uygulanış tarzını belirler
    • Imagick::setImageResolution - Resmin çözünürlüğünü ayarlar
    • Imagick::setImageScene - Resmin dekorunu tanımlar
    • Imagick::setImageTicksPerSecond - Resmin saniyedeki tik sayısını tanımlar
    • Imagick::setImageType - Resim türünü tanımlar
    • Imagick::setImageUnits - Resmin çözünürlük birimlerini tanımlar
    • Imagick::setImageVirtualPixelMethod - Resmin sanal piksel yöntemini tanımlar
    • Imagick::setImageWhitePoint - Renk berraklığının beyaz noktasını tanımlar
    • Imagick::setInterlaceScheme - Resim geçişim şemasını tanımlar
    • Imagick::setIteratorIndex - Yineleyici konumunu belirler
    • Imagick::setLastIterator - Son resme bir Imagick yineleyicisi atar
    • Imagick::setOption - Bir seçenek tanımlar
    • Imagick::setPage - Imagick nesnesinin sayfa geometrisini tanımlar
    • Imagick::setPointSize - Yazı puntosunu belirler
    • Imagick::setProgressMonitor - Description
    • Imagick::setRegistry - Description
    • Imagick::setResolution - Resim çözünürlüğünü tanımlar
    • Imagick::setResourceLimit - Belli bir özkaynağın sınırını megabayt olarak tanımlar
    • Imagick::setSamplingFactors - Resim örnekleme çarpanlarını ayarlar
    • Imagick::setSize - Imagick nesnesinin boyutlarını ayarlar
    • Imagick::setSizeOffset - Imagick nesnesinin başlangıcını ve boyutlarını ayarlar
    • Imagick::setType - Resmin tür özniteliğini tanımlar
    • Imagick::shadeImage - Üç boyutluluk etkisi oluşturur
    • Imagick::shadowImage - Bir resimde gölgeleri taklit eder
    • Imagick::sharpenImage - Resmi netleştirir
    • Imagick::shaveImage - Bir resmin kenarındaki pikselleri rendeler
    • Imagick::shearImage - Bir paralalkenar oluşturur
    • Imagick::sigmoidalContrastImage - Bir resmin zıtlığını ayarlar
    • Imagick::sketchImage - Kara kalem çalışmasını taklit eder
    • Imagick::smushImages - Description
    • Imagick::solarizeImage - Resme uzun pozlama etkisi uygular
    • Imagick::sparseColorImage - Interpolates colors
    • Imagick::spliceImage - Bir resme bir rengi bütün halinde bindirerek birleştirir
    • Imagick::spreadImage - Bir kümedeki her pikseli rasgele gösterir
    • Imagick::statisticImage - Description
    • Imagick::steganoImage - Resmin içine sayısal bir filigran gizler
    • Imagick::stereoImage - İki resmi birleştirir
    • Imagick::stripImage - Resimden tüm profilleri ve açıklamaları ayıklar
    • Imagick::subImageMatch - Description
    • Imagick::swirlImage - Resmin merkezine yakın pikselleri girdap gibi döndürür
    • Imagick::textureImage - Doku resmini yatay ve düşeyde yineler
    • Imagick::thresholdImage - Bazı pikselleri bir eşiğe göre değiştir
    • Imagick::thumbnailImage - Resmin boyutlarını değiştirir
    • Imagick::tintImage - Resimdeki her piksele bir renk yöneyi uygular
    • Imagick::transformImage - Budama miktarını ve resim geometrisini ayarlamanın uygun yolu
    • Imagick::transformImageColorspace - Transforms an image to a new colorspace.
    • Imagick::transparentPaintImage - Pikselleri şeffaflaştırır
    • Imagick::transposeImage - Resmin düşeydeki yansımasını oluşturur
    • Imagick::transverseImage - Resmin yataydaki yansımasını oluşturur
    • Imagick::trimImage - Resmin kenarlarını siler
    • Imagick::uniqueImageColors - Biri dışında tüm piksel renklerini iptal eder
    • Imagick::unsharpMaskImage - Resmi netleştirir
    • Imagick::valid - Imagick nesnesinin geçerli olup olmadığını sınar
    • Imagick::vignetteImage - Resme bir nakış süzgeci uygular
    • Imagick::waveImage - Resme bir dalga süzgeci uygular
    • Imagick::whiteThresholdImage - Eşiğin üstündeki tüm piksellerin rengini beyaza zorlar
    • Imagick::writeImage - Resmi belirtilen dosyaya yazar
    • Imagick::writeImageFile - Bir resmi belirtilen dosya tanıtıcısına yazar
    • Imagick::writeImages - Bir resmi veya resim kümesini dosyaya yazar
    • Imagick::writeImagesFile - Resim karelerini bir dosya tanıtıcısına yazar
    • Imagick::__construct - Imagick kurucusu
    • Imagick::__toString - Returns the image as a string.
    • ImagickDraw::affine - Geçerli homojen koordinatlar matrisini ayarlar
    • ImagickDraw::annotation - Resmin üzerine bir metin çizer
    • ImagickDraw::arc - Bir yay çizer
    • ImagickDraw::bezier - Bir Bezier eğrisi çizer
    • ImagickDraw::circle - Bir daire çizer
    • ImagickDraw::clear - ImagickDraw nesnesini temizler
    • ImagickDraw::clone - Belirtilen ImagickDraw nesnesinin tam bir kopyasını yapar
    • ImagickDraw::color - Bir resmi boyar
    • ImagickDraw::comment - Bir yöney çıktı akımına bir açıklama ekler
    • ImagickDraw::composite - Bir resmi geçerli resimle bileştirir
    • ImagickDraw::destroy - ImagickDraw yıkıcısı
    • ImagickDraw::ellipse - Resmin üzerine bir elips çizer
    • ImagickDraw::getClipPath - Geçerli yalıtım maskesi kimliğini döndürür
    • ImagickDraw::getClipRule - Yalıtım maskesi tarafından kullanılan çokgen dolgu kuralını döndürür
    • ImagickDraw::getClipUnits - Yalıtım maskesi birimlerinin yorumunu döndürür
    • ImagickDraw::getFillColor - Dolgu rengini döndürür
    • ImagickDraw::getFillOpacity - Çizimde kullanılan matlık değerini döndürür
    • ImagickDraw::getFillRule - Geçerli dolgu kuralını döndürür
    • ImagickDraw::getFont - Geçerli yazı tipini döndürür
    • ImagickDraw::getFontFamily - Yazı tipi ailesini döndürür
    • ImagickDraw::getFontSize - Yazı tipi yüksekliğini döndürür
    • ImagickDraw::getFontStretch - Description
    • ImagickDraw::getFontStyle - Yazı tipi tarzını döndürür
    • ImagickDraw::getFontWeight - Yazı tipi kalınlığını döndürür
    • ImagickDraw::getGravity - Metnin çekim yönünü döndürür
    • ImagickDraw::getStrokeAntialias - Nesne dış hatlarını çizmekte kullanılan vurgu yumuşatması ayarını döndürür
    • ImagickDraw::getStrokeColor - Nesne dış hatlarını çizmekte kullanılan vurgunun rengini döndürür
    • ImagickDraw::getStrokeDashArray - Kesikli çizgi örüntüsünü oluşturmakta kullanılan tireleri ve boşlukları içeren bir dizi döndürür
    • ImagickDraw::getStrokeDashOffset - Kesikli çizgi örüntüsünde tire başlangıcını döndürür
    • ImagickDraw::getStrokeLineCap - Kalın çizgilerdeki çizgi uçlarının şeklini döndürür
    • ImagickDraw::getStrokeLineJoin - Kalın çizgi ekleminin şeklini döndürür
    • ImagickDraw::getStrokeMiterLimit - Gönyenin kesildiği sınırı döndürür
    • ImagickDraw::getStrokeOpacity - Nesne dış hatlarını çizmekte kullanılan vurgunun matlığını döndürür
    • ImagickDraw::getStrokeWidth - Nesne dış hatlarını çizmekte kullanılan vurgu genişliğini döndürür
    • ImagickDraw::getTextAlignment - Metin hizalamasını döndürür
    • ImagickDraw::getTextAntialias - Geçerli metin yumuşatma ayarını döndürür
    • ImagickDraw::getTextDecoration - Metin süslemesi türünü döndürür
    • ImagickDraw::getTextEncoding - Metin çizerken kullanılan karakter kümesi ismini döndürür
    • ImagickDraw::getTextInterlineSpacing - Description
    • ImagickDraw::getTextInterwordSpacing - Description
    • ImagickDraw::getTextKerning - Description
    • ImagickDraw::getTextUnderColor - Metin artalanındaki rengi döndürür
    • ImagickDraw::getVectorGraphics - Yöney çizgesini içeren bir dizge döner
    • ImagickDraw::line - Bir çizgi çizer
    • ImagickDraw::matte - Resmin matlık kanalını boyar
    • ImagickDraw::pathClose - Geçerli hatta son elemanı ekler
    • ImagickDraw::pathCurveToAbsolute - Üçüncü dereceden bir Bezier eğrisi çizer
    • ImagickDraw::pathCurveToQuadraticBezierAbsolute - İkinci dereceden bir Bezier eğrisi çizer
    • ImagickDraw::pathCurveToQuadraticBezierRelative - İkinci dereceden bir Bezier eğrisi çizer
    • ImagickDraw::pathCurveToQuadraticBezierSmoothAbsolute - İkinci dereceden bir Bezier eğrisi çizer
    • ImagickDraw::pathCurveToQuadraticBezierSmoothRelative - İkinci dereceden bir Bezier eğrisi çizer
    • ImagickDraw::pathCurveToRelative - Üçüncü dereceden bir Bezier eğrisi çizer
    • ImagickDraw::pathCurveToSmoothAbsolute - Üçüncü dereceden bir Bezier eğrisi çizer
    • ImagickDraw::pathCurveToSmoothRelative - Üçüncü dereceden bir Bezier eğrisi çizer
    • ImagickDraw::pathEllipticArcAbsolute - Eliptik bir yay çizer
    • ImagickDraw::pathEllipticArcRelative - Bir eliptik yay çizer
    • ImagickDraw::pathFinish - Geçerli hattı sonlandırır
    • ImagickDraw::pathLineToAbsolute - Draws a line path
    • ImagickDraw::pathLineToHorizontalAbsolute - Yatay bir hat elemanı çizer
    • ImagickDraw::pathLineToHorizontalRelative - Yatay bir hat elemanı çizer
    • ImagickDraw::pathLineToRelative - Bir hat elemanı çizer
    • ImagickDraw::pathLineToVerticalAbsolute - Düşey bir hat elemanı çizer
    • ImagickDraw::pathLineToVerticalRelative - Bir düşey hat elemanı çizer
    • ImagickDraw::pathMoveToAbsolute - Yeni bir hat elemanı başlatır
    • ImagickDraw::pathMoveToRelative - Yeni bir hat elemanı başlatır
    • ImagickDraw::pathStart - Bir hat çizim listesinin başlangıcını bildirir
    • ImagickDraw::point - Bir nokta çizer
    • ImagickDraw::polygon - Bir çokgen çizer
    • ImagickDraw::polyline - Bir çoklu çizgi çizer
    • ImagickDraw::pop - Yığıttaki geçerli ImagickDraw nesnesini silip sonraki nesneyi döndürür
    • ImagickDraw::popClipPath - Bir yalıtım maskesi tanımını sonlandırır
    • ImagickDraw::popDefs - Bir tanım listesini sonlandırır
    • ImagickDraw::popPattern - Bir örüntü tanımını sonlandırır
    • ImagickDraw::push - Geçerli ImagickDraw nesnesini kopyalar ve yığıta basar
    • ImagickDraw::pushClipPath - Bir yalıtım maskesi tanımı başlatır
    • ImagickDraw::pushDefs - Bundan sonra çağrılacak yöntemlerin ImagickDraw::popDefs yöntemi çağrılıncaya kadar isimli elemanları tanımlayacağını belirtir
    • ImagickDraw::pushPattern - Bundan sonra çağrılacak yöntemlerin ImagickDraw::popPattern yöntemi çağrılıncaya kadar bir isimli örüntüyü tanımlayacağını belirtir
    • ImagickDraw::rectangle - Bir dikdörtgen çizer
    • ImagickDraw::render - Evvelce verilmiş tüm çizim komutlarını resme uygular
    • ImagickDraw::resetVectorGraphics - Description
    • ImagickDraw::rotate - Geçerli koordinat sistemini belirtilen açıda döndürür
    • ImagickDraw::roundRectangle - Köşeleri yuvarlatılmış bir dikdörtgen çizer
    • ImagickDraw::scale - Enboy oranını ayarlar
    • ImagickDraw::setClipPath - Bir isimli yalıtım maskesini resimle ilişkilendirir
    • ImagickDraw::setClipRule - Yalıtım maskesi tarafından kullanılacak çokgen dolgu kuralını belirler
    • ImagickDraw::setClipUnits - Yalıtım maskesi birimlerinin yorumunu belirler
    • ImagickDraw::setFillAlpha - Dolgu dokusu veya dolgu rengi için kullanılacak şeffaflığı belirler
    • ImagickDraw::setFillColor - Dolgulu nesnelerin çiziminde kullanılacak dolgu rengini belirler
    • ImagickDraw::setFillOpacity - Dolgu dokusu veya dolgu rengi için kullanılacak matlığı belirler
    • ImagickDraw::setFillPatternURL - Nesne dolgu örüntüsü için kullanılacak adresi belirler
    • ImagickDraw::setFillRule - Çokgen çizerken kullanılacak dolgu kuralını belirler
    • ImagickDraw::setFont - Metni çizerken kullanılacak yazı tipini tam belirtimiyle belirler
    • ImagickDraw::setFontFamily - Yazı tipi ailesini belirler
    • ImagickDraw::setFontSize - Yazı tipi yüksekliğini belirler
    • ImagickDraw::setFontStretch - Yazı tipinin karakter genişliğini belirler
    • ImagickDraw::setFontStyle - Yazı tipi tarzını belirler
    • ImagickDraw::setFontWeight - Yazı tipi kalınlığını belirler
    • ImagickDraw::setGravity - Metnin çekim yönünü belirler
    • ImagickDraw::setResolution - Description
    • ImagickDraw::setStrokeAlpha - Vurgulu nesne dış hatlarının şeffaflığını tanımlar
    • ImagickDraw::setStrokeAntialias - Vurgulu dış hatlara kenar yumuşatma uygulanıp uygulanmayacağını denetler
    • ImagickDraw::setStrokeColor - Nesne dış hatlarını vurgulamakta kullanılacak rengi tanımlar
    • ImagickDraw::setStrokeDashArray - Kesikli çizgi örüntüsünde tireleri ve boşlukları belirler
    • ImagickDraw::setStrokeDashOffset - Kesikli çizgi örüntüsünde tire başlangıcını belirler
    • ImagickDraw::setStrokeLineCap - Kalın çizgilerde çizgi uçlarının şeklini belirler
    • ImagickDraw::setStrokeLineJoin - Kalın çizgi ekleminin şeklini belirler
    • ImagickDraw::setStrokeMiterLimit - Gönyenin kesildiği sınırı tanımlar
    • ImagickDraw::setStrokeOpacity - Vurgulanmış nesne dış hatlarının matlığını tanımlar
    • ImagickDraw::setStrokePatternURL - Nesne dış hatlarının çiziminde kullanılacak örüntüyü tanımlar
    • ImagickDraw::setStrokeWidth - Nesne dış hatlarının çiziminde kullanılacak çizgi genişliğini tanımlar
    • ImagickDraw::setTextAlignment - Metni hizalar
    • ImagickDraw::setTextAntialias - Metne kenar yumuşatma uygulanıp uygulanmayacağını denetler
    • ImagickDraw::setTextDecoration - Bir karakter süslemesi tanımlar
    • ImagickDraw::setTextEncoding - Metin karakter kümesini tanımlar
    • ImagickDraw::setTextInterlineSpacing - Description
    • ImagickDraw::setTextInterwordSpacing - Description
    • ImagickDraw::setTextKerning - Description
    • ImagickDraw::setTextUnderColor - Metin çerçevesinin artalan rengini tanımlar
    • ImagickDraw::setVectorGraphics - Yöney çizgesini tanımlar
    • ImagickDraw::setViewbox - Tuval boyutunu uçtan uca tanımlar
    • ImagickDraw::skewX - Geçerli koordinat sistemini yatayda belirtilen açıda eğer
    • ImagickDraw::skewY - Geçerli koordinat sistemini düşeyde belirtilen açıda eğer
    • ImagickDraw::translate - Geçerli koordinat sisteminin başnoktasını değiştirir
    • ImagickDraw::__construct - ImagickDraw kurucusu
    • ImagickPixel::clear - Nesne ile ilişkili özkaynakları temizler
    • ImagickPixel::destroy - Nesne ile ilgili özkaynakları serbest bırakır
    • ImagickPixel::getColor - Bir renk döndürür
    • ImagickPixel::getColorAsString - Rengi bir dizge olarak döndürür
    • ImagickPixel::getColorCount - Nesnenin renk sayısını döndürür
    • ImagickPixel::getColorQuantum - Description
    • ImagickPixel::getColorValue - Belirtilen renk kanalının normalleştirilmiş değerini döndürür
    • ImagickPixel::getColorValueQuantum - Description
    • ImagickPixel::getHSL - ImagickPixel nesnesinin normalleştirilmiş HSL rengini döndürür
    • ImagickPixel::getIndex - Description
    • ImagickPixel::isPixelSimilar - Check the distance between this color and another
    • ImagickPixel::isPixelSimilarQuantum - Description
    • ImagickPixel::isSimilar - İki renk arasındaki benzerliği hesaplar
    • ImagickPixel::setColor - Renk tanımlar
    • ImagickPixel::setColorCount - Description
    • ImagickPixel::setColorValue - Renk kanallarından birinin normalleştirilmiş değerini belirler
    • ImagickPixel::setColorValueQuantum - Description
    • ImagickPixel::setHSL - Normalleştirilmiş HSL rengini ayarlar
    • ImagickPixel::setIndex - Description
    • ImagickPixel::__construct - ImagickPixel nesnesini oluşturur
    • ImagickPixelIterator::clear - Piksel yineleyici ile ilişkili özkaynakları temizler
    • ImagickPixelIterator::destroy - Piksel yineleyici ile ilişkili özkaynakları serbest bırakır
    • ImagickPixelIterator::getCurrentIteratorRow - Piksel yineleyicinin üzerinde bulunduğu ImagickPixel nesneleri satırını döndürür
    • ImagickPixelIterator::getIteratorRow - Piksel yineleyicinin üzerinde bulunduğu satırın numarasını döndürür
    • ImagickPixelIterator::getNextIteratorRow - Piksel yineleyicinin sonraki satırını döndürür
    • ImagickPixelIterator::getPreviousIteratorRow - Önceki satırı döndürür
    • ImagickPixelIterator::newPixelIterator - Yeni bir piksel yineleyici döndürür
    • ImagickPixelIterator::newPixelRegionIterator - Yeni bir bölgesel piksel yineleyicisi döndürür
    • ImagickPixelIterator::resetIterator - Piksel yineleyiciyi sıfırlar
    • ImagickPixelIterator::setIteratorFirstRow - Piksel yineleyiciyi ilk piksel satırına hizalar
    • ImagickPixelIterator::setIteratorLastRow - Piksel yineleyiciyi son piksel satırına hizalar
    • ImagickPixelIterator::setIteratorRow - Piksel yineleyiciyi satırını tanımlar
    • ImagickPixelIterator::syncIterator - Piksel yineleyiciyi eşzamanlar
    • ImagickPixelIterator::__construct - Bir ImagickPixelIterator nesnesi oluşturur
    • imap_8bit - 8 bitlik bir dizgeyi 7 bitlik (quoted-printable) bir dizgeye dönüştürür
    • imap_alerts - Oluşan tüm IMAP uyarı iletilerini döndürür
    • imap_append - Belirtilen posta kutusuna bir dizge ileti ekler
    • imap_base64 - Base64 kodlu dizgeyi 8 bitlik dizgeye dönüştürür
    • imap_binary - 8 bitlik bir dizgeyi bir base64 dizgesine dönüştürür
    • imap_body - İleti gövdesini okur
    • imap_bodystruct - Belirtilen iletinin bir gövde bölümünün yapısını okur
    • imap_check - Posta kutusu bilgilerini döndürür
    • imap_clearflag_full - İletilerdeki imleri temizler
    • imap_close - IMAP akımını kapatır
    • imap_create - Takma Adı: imap_createmailbox
    • imap_createmailbox - Yeni bir posta kutusu oluşturur
    • imap_delete - Belirtilen iletiyi silindi olarak imler
    • imap_deletemailbox - Bir posta kutusunu siler
    • imap_errors - Oluşan tüm IMAP hatalarının iletilerini döndürür
    • imap_expunge - Silindi imli tüm iletileri gerçekten siler
    • imap_fetchbody - Belirtilen iletinin belli bir gövde bölümünü döndürür
    • imap_fetchheader - Bir iletinin başlığını döndürür
    • imap_fetchmime - Fetch MIME headers for a particular section of the message
    • imap_fetchstructure - Belli bir iletinin yapısını okur
    • imap_fetchtext - Takma Adı: imap_body
    • imap_fetch_overview - Belirtilen iletinin başlıklarından belli bilgileri toplar
    • imap_gc - IMAP önbelleğini temizler
    • imap_getacl - Belirtilen posta kutusunun erişim izinlerini döndürür
    • imap_getmailboxes - Posta kutuları hakkında ayrıntılı bilgi döndürür
    • imap_getsubscribed - Üyesi olunan tüm posta kutularını listeler
    • imap_get_quota - Belirtilen kullanıcının kota ayarlarını döndürür
    • imap_get_quotaroot - Kullanıcının kendi kota ayarlarını döndürür
    • imap_header - imap_headerinfo işlevinin takma adıdır
    • imap_headerinfo - Belirtilen iletinin başlığını okur
    • imap_headers - Bir posta kutusu içindeki tüm iletilerin başlıklarını döndürür
    • imap_last_error - Geçerli sayfa isteği sırasında oluşan son IMAP hatasının açıklamasını döndürür
    • imap_list - Posta kutularını listeler
    • imap_listmailbox - imap_list işlevinin takma adıdır
    • imap_listscan - Belirtilen metin ile eşleşen posta kutularını listeler
    • imap_listsubscribed - imap_lsub işlevinin takma adıdır
    • imap_lsub - Üyesi olunan tüm posta kutularını listeler
    • imap_mail - Bir eposta iletisi gönderir
    • imap_mailboxmsginfo - Posta kutusu hakkında bilgi döndürür
    • imap_mail_compose - Zarfı ve gövdesi belirtilen MIME iletisini oluşturur
    • imap_mail_copy - Belirtilen iletileri bir posta kutusuna kopyalar
    • imap_mail_move - Belirtilen iletiyi bir posta kutusuna taşır
    • imap_mime_header_decode - MIME başlık elemanlarının kodlamasını açar
    • imap_msgno - Belirtilen eşsiz kimlik için ileti numarasını döndürür
    • imap_num_msg - Posta kutusundaki ileti sayısını döndürür
    • imap_num_recent - Posta kutusuna en son gelen ileti sayısını döndürür
    • imap_open - Belirtilen posta kutusuna yeni bir IMAP akımı açar
    • imap_ping - Belirtilen IMAP akımı hala etkin mi diye bakar
    • imap_qprint - Bir 7 bitlik dizgeyi 8 bitlik dizgeye dönüştürür
    • imap_rename - Takma Adı: imap_renamemailbox
    • imap_renamemailbox - Posta kutusunun ismini değiştirir
    • imap_reopen - IMAP akımını yeni posta kutusunda yeniden açar
    • imap_rfc822_parse_adrlist - Bir adres dizgesini çözümler
    • imap_rfc822_parse_headers - Bir dizgedeki eposta başlıklarını çözümler
    • imap_rfc822_write_address - Posta kutusu, alan adı ve kişisel bilgi ile gerektiği gibi biçemlenmiş bir eposta adresi dönürür
    • imap_savebody - Belirtilen iletinin gövdesini bir dosyaya kaydeder
    • imap_scan - Takma Adı: imap_listscan
    • imap_scanmailbox - imap_listscan işlevinin takma adıdır
    • imap_search - Belirtilen kurala uyan iletileri bir dizi içinde döndürür
    • imap_setacl - Belirtilen posta kutusu ile ilgili erişim izinlerini tanımlar
    • imap_setflag_full - İletileri imler
    • imap_set_quota - Belirtilen posta kutusu için bir kota tanımlar
    • imap_sort - İletileri sıralar ve döndürür
    • imap_status - Bir posta kutusunun durum bilgisini döndürür
    • imap_subscribe - Bir posta kutusuna üyeliği başlatır
    • imap_thread - Bir iletinin konu ağacını döndürür
    • imap_timeout - IMAP zaman aşımını tanımlar veya döndürür
    • imap_uid - Numarası belirtilen iletiyle ilgili eşsiz kimliği döndürür
    • imap_undelete - Silindi diye imlenmiş bir iletinin imini kaldırır
    • imap_unsubscribe - Bir posta kutusundan üyeliği sonlandırır
    • imap_utf7_decode - Bir dizgenin karakter kodlamasını takviyeli UTF-7'den ISO-8859-1'e dönüştürür
    • imap_utf7_encode - ISO-8859-1 kodlu bir dizgenin kodlamasını takviyeli UTF-7'ye dönüştürür
    • imap_utf8 - MIME kodlu metni UTF-8'e dönüştürür
    • implode - Dizi elemanlarını birleştirip bir dizge elde eder
    • import_request_variables - GET/POST/Çerez değişkenlerini küresel etki alanına dahil eder
    • inclued_get_data - Get the inclued data
    • inet_ntop - Bir IP adresinin in_addr gösterimini insan okuyabilir gösterime dönüştürür
    • inet_pton - İnsan okuyabilir bir IP adresini in_addr gösterimine dönüştürür
    • InfiniteIterator::next - Moves the inner Iterator forward or rewinds it
    • InfiniteIterator::__construct - Constructs an InfiniteIterator
    • inflate_add - Incrementally inflate encoded data
    • inflate_init - Initialize an incremental inflate context
    • ingres_autocommit - Switch autocommit on or off
    • ingres_autocommit_state - Test if the connection is using autocommit
    • ingres_charset - Returns the installation character set
    • ingres_close - Close an Ingres database connection
    • ingres_commit - Commit a transaction
    • ingres_connect - Open a connection to an Ingres database
    • ingres_cursor - Get a cursor name for a given result resource
    • ingres_errno - Get the last Ingres error number generated
    • ingres_error - Get a meaningful error message for the last error generated
    • ingres_errsqlstate - Get the last SQLSTATE error code generated
    • ingres_escape_string - Escape special characters for use in a query
    • ingres_execute - Execute a prepared query
    • ingres_fetch_array - Fetch a row of result into an array
    • ingres_fetch_assoc - Fetch a row of result into an associative array
    • ingres_fetch_object - Fetch a row of result into an object
    • ingres_fetch_proc_return - Get the return value from a procedure call
    • ingres_fetch_row - Fetch a row of result into an enumerated array
    • ingres_field_length - Get the length of a field
    • ingres_field_name - Get the name of a field in a query result
    • ingres_field_nullable - Test if a field is nullable
    • ingres_field_precision - Get the precision of a field
    • ingres_field_scale - Get the scale of a field
    • ingres_field_type - Get the type of a field in a query result
    • ingres_free_result - Free the resources associated with a result identifier
    • ingres_next_error - Get the next Ingres error
    • ingres_num_fields - Get the number of fields returned by the last query
    • ingres_num_rows - Get the number of rows affected or returned by a query
    • ingres_pconnect - Open a persistent connection to an Ingres database
    • ingres_prepare - Prepare a query for later execution
    • ingres_query - Send an SQL query to Ingres
    • ingres_result_seek - Set the row position before fetching data
    • ingres_rollback - Roll back a transaction
    • ingres_set_environment - Set environment features controlling output options
    • ingres_unbuffered_query - Send an unbuffered SQL query to Ingres
    • ini_alter - ini_set işlevinin takma adıdır
    • ini_get - Bir yapılandırma yönergesinin değerini döndürür
    • ini_get_all - Tüm yapılandırma yönergelerini döndürür
    • ini_restore - Bir yapılandırma yönergesine eski değerini atar
    • ini_set - Bir yapılandırma yönergesine değer atar
    • inotify_add_watch - Add a watch to an initialized inotify instance
    • inotify_init - Initialize an inotify instance
    • inotify_queue_len - Return a number upper than zero if there are pending events
    • inotify_read - Read events from an inotify instance
    • inotify_rm_watch - Remove an existing watch from an inotify instance
    • intdiv - Integer division
    • interface_exists - Arayüz tanımlı mı diye bakar
    • IntlDateFormatter::create - Bir tarih biçemleyici oluşturur
    • IntlDateFormatter::format - Tarih/saat değerini bir dizge olarak biçemler
    • IntlDateFormatter::formatObject - Formats an object
    • IntlDateFormatter::getCalendar - IntlDateFormatter tarafından kullanılan takvimi döndürür
    • IntlDateFormatter::getCalendarObject - Get copy of formatter's calendar object
    • IntlDateFormatter::getDateType - IntlDateFormatter tarafından kullanılan tarih gösterim türünü döndürür
    • IntlDateFormatter::getErrorCode - Son işlemin hata kodunu döndürür
    • IntlDateFormatter::getErrorMessage - Son işlemin hata iletisini döndürür
    • IntlDateFormatter::getLocale - Biçemleyicinin kullandığı yereli döndürür
    • IntlDateFormatter::getPattern - IntlDateFormatter tarafından kullanılan kalıbı döndürür
    • IntlDateFormatter::getTimeType - IntlDateFormatter tarafından kullanılan zaman gösterim türünü döndürür
    • IntlDateFormatter::getTimeZone - Get formatter's timezone
    • IntlDateFormatter::getTimeZoneId - IntlDateFormatter tarafından kullanılan zaman dilimini döndürür
    • IntlDateFormatter::isLenient - IntlDateFormatter esnek çözümleme mi yapıyor diye bakar
    • IntlDateFormatter::localtime - Tarih dizgesini alanlarına çözümler
    • IntlDateFormatter::parse - Dizgeyi bir zaman damgası değerine dönüştürür
    • IntlDateFormatter::setCalendar - Kullanılacak takvimi tanımlar
    • IntlDateFormatter::setLenient - Çözümleyiciye esneklik verir
    • IntlDateFormatter::setPattern - IntlDateFormatter tarafından kullanılan kalıbı tanımlar
    • IntlDateFormatter::setTimeZone - Sets formatter's timezone
    • IntlDateFormatter::setTimeZoneId - Kullanılacak zaman dilimini tanımlar
    • intl_error_name - Belirtilen hata kodunun simgesel ismini döndürür
    • intl_get_error_code - Son hatanın kodunu döndürür
    • intl_get_error_message - Son hatayı açıklayan bir dizge ile döner
    • intl_is_failure - Belirtilen hata kodunun bir başarısızlık göstergesi olup olmadığına bakar
    • intval - Bir değişkenin tamsayı değerini döndürür
    • in_array - Bir dizide bir değerin varlığını araştırır
    • ip2long - Noktalı IP adresi gösterimini içeren bir dizgeyi sayısal adrese dönüştürür
    • iptcembed - İkil IPTC verisini bir JPEG resminin içine gömer
    • iptcparse - Bir ikil IPTC bloğunu tekil etiketlere böler
    • isset - Değişken tanımlı mı diye bakar
    • is_a - Nesne ile sınıf arasında ebeveyn/çocuk ilişkisi var mı diye bakar
    • is_array - Değişkenin bir dizi içerip içermediğine bakar
    • is_bool - Değişken boolean türünde mi diye bakar
    • is_callable - Bir değişkenin içeriğinin bir işlev olarak çağrılabilirliğini doğrular
    • is_dir - Bir dosyanın bir dizin olup olmadığını söyler
    • is_double - is_float işlevinin takma adıdır
    • is_executable - Bir dosyanın çalıştırılabilir bir dosya olup olmadığını söyler
    • is_file - Bir dosyanın sıradan bir dosya olup olmadığını söyler
    • is_finite - Finds whether a value is a legal finite number
    • is_float - Değişken float türünde mi diye bakar
    • is_infinite - Finds whether a value is infinite
    • is_int - Değişken bir tamsayı mı diye bakar
    • is_integer - is_int işlevinin takma adıdır
    • is_link - Bir dosyanın sembolik bağ olup olmadığını söyler
    • is_long - is_int işlevinin takma adıdır
    • is_nan - Finds whether a value is not a number
    • is_null - Bir değişkenin değerinin NULL olup olmadığına bakar
    • is_numeric - Değişken bir sayı veya bir sayısal dizge mi diye bakar
    • is_object - Değişken object türünde mi diye bakar
    • is_readable - Bir dosyanın mevcut ve okunabilir olup olmadığını söyler
    • is_real - is_float işlevinin takma adıdır
    • is_resource - Değişken resource türünde mi diye bakar
    • is_scalar - Bir değişken sayıl mı diye bakar
    • is_soap_fault - Checks if a SOAP call has failed
    • is_string - Değişken string türünde mi diye bakar
    • is_subclass_of - Belirtilen sınıfın belirtilen nesnenin ebeveynlerinden biri olup olmadığına bakar
    • is_tainted - Checks whether a string is tainted
    • is_uploaded_file - Bir dosya HTTP POST üzerinden karşıya yüklenebilecekse bunu söyler
    • is_writable - Bir dosyanın yazılabilir olup olmadığını söyler
    • is_writeable - is_writable işlevinin takma adıdır
    • Iterator::current - O anki elemanı döndürür
    • Iterator::key - O anki elemanın anahtarını döndürür
    • Iterator::next - Konumu sonraki elemana ilerletir
    • Iterator::rewind - Yineleyiciyi ilk elemana konumlandırır
    • Iterator::valid - O anki konum geçerli mi diye bakar
    • IteratorAggregate::getIterator - Harici bir yineleyici ile döner
    • IteratorIterator::current - Get the current value
    • IteratorIterator::getInnerIterator - Get the inner iterator
    • IteratorIterator::key - Get the key of the current element
    • IteratorIterator::next - Forward to the next element
    • IteratorIterator::rewind - Rewind to the first element
    • IteratorIterator::valid - Checks if the iterator is valid
    • IteratorIterator::__construct - Create an iterator from anything that is traversable
    • iterator_apply - Call a function for every element in an iterator
    • iterator_count - Count the elements in an iterator
    • iterator_to_array - Copy the iterator into an array
  • j
    • JDDayOfWeek - Haftanın gününü verir
    • JDMonthName - Ay adını geri döner
    • JDToFrench - Jülyen gün sayısını, Fransız İhtilali takvimine çevirir
    • JDToGregorian - Jülyen Gün Sayısını, Gregoryen tarihine çevirir
    • jdtojewish - Jülyen Gün Sayısını, Yahudi takvimine çevirir
    • JDToJulian - Jülyen Gün Sayısını, Jülyen takvim tarihine çevirir
    • jdtounix - Jülyen Gün Sayısını, Unix zaman damgasına çevirir
    • JewishToJD - Yahudi takvimindeki bir tarihi, Jülyen Gün Sayısına çevirir
    • join - implode işlevinin takma adıdır
    • jpeg2wbmp - Bir JPEG dosyasını WBMP dosyasına dönüştürür
    • json_decode - Bir JSON dizgesini çözümler.
    • json_encode - Değerin JSON karşılığını verir.
    • json_last_error - Oluşan son hatayı döndürür.
    • json_last_error_msg - Returns the error string of the last json_encode() or json_decode() call
    • Judy::byCount - Locate the Nth index present in the Judy array
    • Judy::count - Count the number of elements in the Judy array
    • Judy::first - Search for the first index in the Judy array
    • Judy::firstEmpty - Search for the first absent index in the Judy array
    • Judy::free - Free the entire Judy array
    • Judy::getType - Return the type of the current Judy array
    • Judy::last - Search for the last index in the Judy array
    • Judy::lastEmpty - Search for the last absent index in the Judy array
    • Judy::memoryUsage - Return the memory used by the Judy array
    • Judy::next - Search for the next index in the Judy array
    • Judy::nextEmpty - Search for the next absent index in the Judy array
    • Judy::offsetExists - Whether a offset exists
    • Judy::offsetGet - Offset to retrieve
    • Judy::offsetSet - Offset to set
    • Judy::offsetUnset - Offset to unset
    • Judy::prev - Search for the previous index in the Judy array
    • Judy::prevEmpty - Search for the previous absent index in the Judy array
    • Judy::size - Return the size of the current Judy array
    • Judy::__construct - Construct a new Judy object
    • Judy::__destruct - Destruct a Judy object
    • judy_type - Return the type of a Judy array
    • judy_version - Return or print the current PHP Judy version
    • JulianToJD - Jülyen takvimindeki tarihi, Jülyen Gün Sayısına çevirir
  • k
    • kadm5_chpass_principal - Changes the principal's password
    • kadm5_create_principal - Creates a kerberos principal with the given parameters
    • kadm5_delete_principal - Deletes a kerberos principal
    • kadm5_destroy - Closes the connection to the admin server and releases all related resources
    • kadm5_flush - Flush all changes to the Kerberos database
    • kadm5_get_policies - Gets all policies from the Kerberos database
    • kadm5_get_principal - Gets the principal's entries from the Kerberos database
    • kadm5_get_principals - Gets all principals from the Kerberos database
    • kadm5_init_with_password - Opens a connection to the KADM5 library
    • kadm5_modify_principal - Modifies a kerberos principal with the given parameters
    • key - Bir diziden gösterici konumundaki anahtarı döndürür
    • key_exists - Takma Adı: array_key_exists
    • krsort - Bir diziyi anahtarlarına göre tersine sıralar
    • ksort - Bir diziyi anahtarlarına göre sıralar
    • KTaglib_ID3v2_AttachedPictureFrame::getDescription - Returns a description for the picture in a picture frame
    • KTaglib_ID3v2_AttachedPictureFrame::getMimeType - Returns the mime type of the picture
    • KTaglib_ID3v2_AttachedPictureFrame::getType - Returns the type of the image
    • KTaglib_ID3v2_AttachedPictureFrame::savePicture - Saves the picture to a file
    • KTaglib_ID3v2_AttachedPictureFrame::setMimeType - Set's the mime type of the picture
    • KTaglib_ID3v2_AttachedPictureFrame::setPicture - Sets the frame picture to the given image
    • KTaglib_ID3v2_AttachedPictureFrame::setType - Set the type of the image
    • KTaglib_ID3v2_Frame::getSize - Returns the size of the frame in bytes
    • KTaglib_ID3v2_Frame::__toString - Returns a string representation of the frame
    • KTaglib_ID3v2_Tag::addFrame - Add a frame to the ID3v2 tag
    • KTaglib_ID3v2_Tag::getFrameList - Returns an array of ID3v2 frames, associated with the ID3v2 tag
    • KTaglib_MPEG_AudioProperties::getBitrate - Returns the bitrate of the MPEG file
    • KTaglib_MPEG_AudioProperties::getChannels - Returns the amount of channels of a MPEG file
    • KTaglib_MPEG_AudioProperties::getLayer - Returns the layer of a MPEG file
    • KTaglib_MPEG_AudioProperties::getLength - Returns the length of a MPEG file
    • KTaglib_MPEG_AudioProperties::getSampleBitrate - Returns the sample bitrate of a MPEG file
    • KTaglib_MPEG_AudioProperties::getVersion - Returns the version of a MPEG file
    • KTaglib_MPEG_AudioProperties::isCopyrighted - Returns the copyright status of an MPEG file
    • KTaglib_MPEG_AudioProperties::isOriginal - Returns if the file is marked as the original file
    • KTaglib_MPEG_AudioProperties::isProtectionEnabled - Returns if protection mechanisms of an MPEG file are enabled
    • KTaglib_MPEG_File::getAudioProperties - Returns an object that provides access to the audio properties
    • KTaglib_MPEG_File::getID3v1Tag - Returns an object representing an ID3v1 tag
    • KTaglib_MPEG_File::getID3v2Tag - Returns a ID3v2 object
    • KTaglib_MPEG_File::__construct - Opens a new file
    • KTaglib_Tag::getAlbum - Returns the title string from a ID3 tag
    • KTaglib_Tag::getArtist - Returns the artist string from a ID3 tag
    • KTaglib_Tag::getComment - Returns the comment from a ID3 tag
    • KTaglib_Tag::getGenre - Returns the genre from a ID3 tag
    • KTaglib_Tag::getTitle - Returns the title string from a ID3 tag
    • KTaglib_Tag::getTrack - Returns the track number from a ID3 tag
    • KTaglib_Tag::getYear - Returns the year from a ID3 tag
    • KTaglib_Tag::isEmpty - Returns true if the tag is empty
  • l
    • Lapack::eigenValues - This function returns the eigenvalues for a given square matrix
    • Lapack::identity - Return an identity matrix
    • Lapack::leastSquaresByFactorisation - Calculate the linear least squares solution of a matrix using QR factorisation
    • Lapack::leastSquaresBySVD - Solve the linear least squares problem, using SVD
    • Lapack::pseudoInverse - Calculate the inverse of a matrix
    • Lapack::singularValues - Calculated the singular values of a matrix
    • Lapack::solveLinearEquation - Solve a system of linear equations
    • lcfirst - Bir dizgenin ilk karakterini küçük harf yapar
    • lcg_value - Combined linear congruential generator
    • lchgrp - Bir sembolik bağın grubunu değiştirir
    • lchown - Bir sembolik bağın sahibini değiştirir
    • ldap_8859_to_t61 - Translate 8859 characters to t61 characters
    • ldap_add - Add entries to LDAP directory
    • ldap_bind - Bind to LDAP directory
    • ldap_close - Takma Adı: ldap_unbind
    • ldap_compare - Compare value of attribute found in entry specified with DN
    • ldap_connect - Connect to an LDAP server
    • ldap_control_paged_result - Send LDAP pagination control
    • ldap_control_paged_result_response - Retrieve the LDAP pagination cookie
    • ldap_count_entries - Count the number of entries in a search
    • ldap_delete - Delete an entry from a directory
    • ldap_dn2ufn - Convert DN to User Friendly Naming format
    • ldap_err2str - Convert LDAP error number into string error message
    • ldap_errno - Return the LDAP error number of the last LDAP command
    • ldap_error - Return the LDAP error message of the last LDAP command
    • ldap_escape - Escape a string for use in an LDAP filter or DN
    • ldap_explode_dn - Splits DN into its component parts
    • ldap_first_attribute - Return first attribute
    • ldap_first_entry - Return first result id
    • ldap_first_reference - Return first reference
    • ldap_free_result - Free result memory
    • ldap_get_attributes - Get attributes from a search result entry
    • ldap_get_dn - Get the DN of a result entry
    • ldap_get_entries - Get all result entries
    • ldap_get_option - Get the current value for given option
    • ldap_get_values - Get all values from a result entry
    • ldap_get_values_len - Get all binary values from a result entry
    • ldap_list - Single-level search
    • ldap_modify - Modify an LDAP entry
    • ldap_modify_batch - Batch and execute modifications on an LDAP entry
    • ldap_mod_add - Add attribute values to current attributes
    • ldap_mod_del - Delete attribute values from current attributes
    • ldap_mod_replace - Replace attribute values with new ones
    • ldap_next_attribute - Get the next attribute in result
    • ldap_next_entry - Get next result entry
    • ldap_next_reference - Get next reference
    • ldap_parse_reference - Extract information from reference entry
    • ldap_parse_result - Extract information from result
    • ldap_read - Read an entry
    • ldap_rename - Modify the name of an entry
    • ldap_sasl_bind - Bind to LDAP directory using SASL
    • ldap_search - Search LDAP tree
    • ldap_set_option - Set the value of the given option
    • ldap_set_rebind_proc - Set a callback function to do re-binds on referral chasing
    • ldap_sort - Sort LDAP result entries on the client side
    • ldap_start_tls - Start TLS
    • ldap_t61_to_8859 - Translate t61 characters to 8859 characters
    • ldap_unbind - Unbind from LDAP directory
    • levenshtein - İki dizge arasındaki Levenştayn mesafesini hesaplar
    • libxml_clear_errors - libxml hata tamponunu temizler
    • libxml_disable_entity_loader - Disable the ability to load external entities
    • libxml_get_errors - Hataları içeren bir dizi döndürür
    • libxml_get_last_error - libxml'den son hatayı döndürür
    • libxml_set_external_entity_loader - Changes the default external entity loader
    • libxml_set_streams_context - Yüklenecek veya yazılacak sonraki libxml belgesinin akım bağlamını belirler
    • libxml_use_internal_errors - libxml hatalarını kapatarak kullanıcı tanımlı hataları mümkün kılar
    • LimitIterator::current - Get current element
    • LimitIterator::getInnerIterator - Get inner iterator
    • LimitIterator::getPosition - Return the current position
    • LimitIterator::key - Get current key
    • LimitIterator::next - Move the iterator forward
    • LimitIterator::rewind - Rewind the iterator to the specified starting offset
    • LimitIterator::seek - Seek to the given position
    • LimitIterator::valid - Check whether the current element is valid
    • LimitIterator::__construct - Construct a LimitIterator
    • link - Sabit bir bağ oluşturur
    • linkinfo - Bir bağ hakkında bilgi verir
    • list - Değişkenlere bir dizi gibi atama yapar
    • Locale::acceptFromHttp - HTTP "Accept-Language" başlığıyla en iyi eşleşen yereli bulmaya çalışır
    • Locale::canonicalize - Canonicalize the locale string
    • Locale::composeLocale - Doğru sıralanmış yerel ile döner
    • Locale::filterMatches - Bir dil yaftasının bir yerelle eşleşip eşleşmediğine bakar
    • Locale::getAllVariants - Girdi yerelindeki tüm lehçeleri döndürür
    • Locale::getDefault - Öntanımlı yerel değerini döndürür
    • Locale::getDisplayLanguage - Girdi yerelindeki anadil kodunun yerelleştirilmiş ismini döndürür
    • Locale::getDisplayName - Girdi yerelinin yerelleştirilmiş ismini döndürür
    • Locale::getDisplayRegion - Girdi yereli için yerelleştirilmiş ülke ismini döndürür
    • Locale::getDisplayScript - Girdi yereli yazı türünün yerelleştirilmiş ismini döndürür
    • Locale::getDisplayVariant - Girdi yereli lehçesinin yerelleştirilmiş ismini döndürür
    • Locale::getKeywords - Girdi yerelindeki anahtar sözcükleri döndürür
    • Locale::getPrimaryLanguage - Girdi yerelinden anadil kodunu döndürür
    • Locale::getRegion - Girdi yerelinden ülke kodunu döndürür
    • Locale::getScript - Girdi yereli için yazı yaftasını döndürür
    • Locale::lookup - En iyi eşleşen dili bulmak için dil yaftası listesini araştırır
    • Locale::parseLocale - Yerel yaftasını oluşturan alt yaftaları içeren bir dizi döndürür
    • Locale::setDefault - Öntanımlı çalışma anı yerelini tanımlar
    • localeconv - Sayısal biçemleme bilgisini döndürür
    • localtime - Yerel zamanı getirir
    • log - Natural logarithm
    • log1p - Returns log(1 + number), computed in a way that is accurate even when the value of number is close to zero
    • log10 - Base-10 logarithm
    • log_cmd_delete - Callback When Deleting Documents
    • log_cmd_insert - Callback When Inserting Documents
    • log_cmd_update - Callback When Updating Documents
    • log_getmore - Callback When Retrieving Next Cursor Batch
    • log_killcursor - Callback When Executing KILLCURSOR operations
    • log_reply - Callback When Reading the MongoDB reply
    • log_write_batch - Callback When Writing Batches
    • long2ip - Bir (IPv4) sayısal ağ adresini noktalı gösterimi içeren bir dizgeye dönüştürür
    • lstat - Bir dosya veya sembolik bağ hakkında bilgi verir
    • ltrim - Dizgenin başındaki boşlukları (veya diğer karakterleri) budar
    • Lua::assign - Assign a PHP variable to Lua
    • Lua::call - Call Lua functions
    • Lua::eval - Evaluate a string as Lua code
    • Lua::getVersion - The getversion purpose
    • Lua::include - Parse a Lua script file
    • Lua::registerCallback - Register a PHP function to Lua
    • Lua::__construct - Lua constructor
    • LuaClosure::__invoke - invoke luaclosure
    • lzf_compress - LZF sıkıştırma işlemi
    • lzf_decompress - LZF sıkıştırmasını açma işlemi
    • lzf_optimized_for - LZF eklentisinin neye göre en iyilendirildiğini bildirir
  • m
    • magic_quotes_runtime - Takma Adı: set_magic_quotes_runtime
    • mail - Eposta gönderir
    • mailparse_determine_best_xfer_encoding - Gets the best way of encoding
    • mailparse_msg_create - Create a mime mail resource
    • mailparse_msg_extract_part - Extracts/decodes a message section
    • mailparse_msg_extract_part_file - Extracts/decodes a message section
    • mailparse_msg_extract_whole_part_file - Extracts a message section including headers without decoding the transfer encoding
    • mailparse_msg_free - Frees a MIME resource
    • mailparse_msg_get_part - Returns a handle on a given section in a mimemessage
    • mailparse_msg_get_part_data - Returns an associative array of info about the message
    • mailparse_msg_get_structure - Returns an array of mime section names in the supplied message
    • mailparse_msg_parse - Incrementally parse data into buffer
    • mailparse_msg_parse_file - Parses a file
    • mailparse_rfc822_parse_addresses - Parse RFC 822 compliant addresses
    • mailparse_stream_encode - Streams data from source file pointer, apply encoding and write to destfp
    • mailparse_uudecode_all - Scans the data from fp and extract each embedded uuencoded file
    • main - Böyle bir işlev yoktur
    • max - Find highest value
    • maxdb_affected_rows - Gets the number of affected rows in a previous MaxDB operation
    • maxdb_autocommit - Turns on or off auto-commiting database modifications
    • maxdb_bind_param - Takma Adı: maxdb_stmt_bind_param
    • maxdb_bind_result - Takma Adı: maxdb_stmt_bind_result
    • maxdb_change_user - Changes the user of the specified database connection
    • maxdb_character_set_name - Returns the default character set for the database connection
    • maxdb_client_encoding - Takma Adı: maxdb_character_set_name
    • maxdb_close - Closes a previously opened database connection
    • maxdb_close_long_data - Takma Adı: maxdb_stmt_close_long_data
    • maxdb_commit - Commits the current transaction
    • maxdb_connect - Open a new connection to the MaxDB server
    • maxdb_connect_errno - Returns the error code from last connect call
    • maxdb_connect_error - Returns a string description of the last connect error
    • maxdb_data_seek - Adjusts the result pointer to an arbitary row in the result
    • maxdb_debug - Performs debugging operations
    • maxdb_disable_reads_from_master - Disable reads from master
    • maxdb_disable_rpl_parse - Disable RPL parse
    • maxdb_dump_debug_info - Dump debugging information into the log
    • maxdb_embedded_connect - Open a connection to an embedded MaxDB server
    • maxdb_enable_reads_from_master - Enable reads from master
    • maxdb_enable_rpl_parse - Enable RPL parse
    • maxdb_errno - Returns the error code for the most recent function call
    • maxdb_error - Returns a string description of the last error
    • maxdb_escape_string - Takma Adı: maxdb_real_escape_string
    • maxdb_execute - Takma Adı: maxdb_stmt_execute
    • maxdb_fetch - Takma Adı: maxdb_stmt_fetch
    • maxdb_fetch_array - Fetch a result row as an associative, a numeric array, or both
    • maxdb_fetch_assoc - Fetch a result row as an associative array
    • maxdb_fetch_field - Returns the next field in the result set
    • maxdb_fetch_fields - Returns an array of resources representing the fields in a result set
    • maxdb_fetch_field_direct - Fetch meta-data for a single field
    • maxdb_fetch_lengths - Returns the lengths of the columns of the current row in the result set
    • maxdb_fetch_object - Returns the current row of a result set as an object
    • maxdb_fetch_row - Get a result row as an enumerated array
    • maxdb_field_count - Returns the number of columns for the most recent query
    • maxdb_field_seek - Set result pointer to a specified field offset
    • maxdb_field_tell - Get current field offset of a result pointer
    • maxdb_free_result - Frees the memory associated with a result
    • maxdb_get_client_info - Returns the MaxDB client version as a string
    • maxdb_get_client_version - Get MaxDB client info
    • maxdb_get_host_info - Returns a string representing the type of connection used
    • maxdb_get_metadata - Takma Adı: maxdb_stmt_result_metadata
    • maxdb_get_proto_info - Returns the version of the MaxDB protocol used
    • maxdb_get_server_info - Returns the version of the MaxDB server
    • maxdb_get_server_version - Returns the version of the MaxDB server as an integer
    • maxdb_info - Retrieves information about the most recently executed query
    • maxdb_init - Initializes MaxDB and returns an resource for use with maxdb_real_connect
    • maxdb_insert_id - Returns the auto generated id used in the last query
    • maxdb_kill - Disconnects from a MaxDB server
    • maxdb_master_query - Enforce execution of a query on the master in a master/slave setup
    • maxdb_more_results - Check if there any more query results from a multi query
    • maxdb_multi_query - Performs a query on the database
    • maxdb_next_result - Prepare next result from multi_query
    • maxdb_num_fields - Get the number of fields in a result
    • maxdb_num_rows - Gets the number of rows in a result
    • maxdb_options - Set options
    • maxdb_param_count - Takma Adı: maxdb_stmt_param_count
    • maxdb_ping - Pings a server connection, or tries to reconnect if the connection has gone down
    • maxdb_prepare - Prepare an SQL statement for execution
    • maxdb_query - Performs a query on the database
    • maxdb_real_connect - Opens a connection to a MaxDB server
    • maxdb_real_escape_string - Escapes special characters in a string for use in an SQL statement, taking into account the current charset of the connection
    • maxdb_real_query - Execute an SQL query
    • maxdb_report - Enables or disables internal report functions
    • maxdb_rollback - Rolls back current transaction
    • maxdb_rpl_parse_enabled - Check if RPL parse is enabled
    • maxdb_rpl_probe - RPL probe
    • maxdb_rpl_query_type - Returns RPL query type
    • maxdb_select_db - Selects the default database for database queries
    • maxdb_send_long_data - Takma Adı: maxdb_stmt_send_long_data
    • maxdb_send_query - Send the query and return
    • maxdb_server_end - Shut down the embedded server
    • maxdb_server_init - Initialize embedded server
    • maxdb_set_opt - Takma Adı: maxdb_options
    • maxdb_sqlstate - Returns the SQLSTATE error from previous MaxDB operation
    • maxdb_ssl_set - Used for establishing secure connections using SSL
    • maxdb_stat - Gets the current system status
    • maxdb_stmt_affected_rows - Returns the total number of rows changed, deleted, or inserted by the last executed statement
    • maxdb_stmt_bind_param - Binds variables to a prepared statement as parameters
    • maxdb_stmt_bind_result - Binds variables to a prepared statement for result storage
    • maxdb_stmt_close - Closes a prepared statement
    • maxdb_stmt_close_long_data - Ends a sequence of maxdb_stmt_send_long_data
    • maxdb_stmt_data_seek - Seeks to an arbitray row in statement result set
    • maxdb_stmt_errno - Returns the error code for the most recent statement call
    • maxdb_stmt_error - Returns a string description for last statement error
    • maxdb_stmt_execute - Executes a prepared Query
    • maxdb_stmt_fetch - Fetch results from a prepared statement into the bound variables
    • maxdb_stmt_free_result - Frees stored result memory for the given statement handle
    • maxdb_stmt_init - Initializes a statement and returns an resource for use with maxdb_stmt_prepare
    • maxdb_stmt_num_rows - Return the number of rows in statements result set
    • maxdb_stmt_param_count - Returns the number of parameter for the given statement
    • maxdb_stmt_prepare - Prepare an SQL statement for execution
    • maxdb_stmt_reset - Resets a prepared statement
    • maxdb_stmt_result_metadata - Returns result set metadata from a prepared statement
    • maxdb_stmt_send_long_data - Send data in blocks
    • maxdb_stmt_sqlstate - Returns SQLSTATE error from previous statement operation
    • maxdb_stmt_store_result - Transfers a result set from a prepared statement
    • maxdb_store_result - Transfers a result set from the last query
    • maxdb_thread_id - Returns the thread ID for the current connection
    • maxdb_thread_safe - Returns whether thread safety is given or not
    • maxdb_use_result - Initiate a result set retrieval
    • maxdb_warning_count - Returns the number of warnings from the last query for the given link
    • mb_check_encoding - Dizgenin belirtilen kodlama için geçerli olup olmadığını sınar
    • mb_convert_case - Bir dizgeye büyük-küçük harf dönüşümü uygular
    • mb_convert_encoding - Karakter kodlaması dönüşümü yapar
    • mb_convert_kana - Bir "kana" dizgeyi diğerine ("zen-kaku", "han-kaku" vs.) dönüştürür
    • mb_convert_variables - Değişken içeriğinin karakter kodlamasını dönüştürür
    • mb_decode_mimeheader - MIME başlık alanındaki dizgeyi dönüştürür
    • mb_decode_numericentity - HTML sayısal karakter gösterimini karaktere dönüştürür
    • mb_detect_encoding - Karakter kodlamasını algılar
    • mb_detect_order - Karakter kodlaması algılama sırasını tanımlar/döndürür
    • mb_encode_mimeheader - Dizgeyi MIME başlığı için kodlar
    • mb_encode_numericentity - Karakter kodlarını HTML sayısal karakter gösterimlerine dönüştürür
    • mb_encoding_aliases - Get aliases of a known encoding type
    • mb_ereg - Düzenli ifadeyi çok baytlı karakter desteğiyle eşleştirir
    • mb_eregi - Harf büyüklüğüne duyarsız çok baytlı düzenli ifade eşleştirmesi uygular
    • mb_eregi_replace - Harf büyüklüğüne duyarsız çok baytlı karakter destekli düzenli ifade yer değiştirmesi yapar
    • mb_ereg_match - Çok baytlı dizge için düzenli ifadeyi eşleştirir
    • mb_ereg_replace - Çok baytlı karakter destekli düzenli ifade yer değiştirmesi yapar
    • mb_ereg_replace_callback - Perform a regular expresssion seach and replace with multibyte support using a callback
    • mb_ereg_search - Evvelce tanımlanmış çok baytlı dizge için çok baytlı düzenli ifade eşleştirmesi yapar
    • mb_ereg_search_getpos - Sonraki düzenli ifade eşleşmesi için başlangıç konumunu döndürür
    • mb_ereg_search_getregs - Sonuncu çok baytlı düzenli ifade eşleşmesinin sonucunu döndürür
    • mb_ereg_search_init - Çok baytlı düzenli ifade eşleşmesi için kullanılacak dizge ve düzenli ifadeyi tanımlar
    • mb_ereg_search_pos - Evvelce tanımlanmış çok baytlı dizge için çok baytlı düzenli ifadenin eşleşen parçasının uzunluğunu ve konumunu döndürür
    • mb_ereg_search_regs - Çok baytlı düzenli ifadenin eşleşen parçası ile döner
    • mb_ereg_search_setpos - Sonraki düzenli ifade eşleşmesinin başlangıç noktasını tanımlar
    • mb_get_info - Mbstring değiştirgelerinin dahili ayarlarını döndürür
    • mb_http_input - HTTP girdi karakter kodlamasını algılar
    • mb_http_output - HTTP çıktı karakter kodlamasını tanımlar/döndürür
    • mb_internal_encoding - Dahili karakter kodlamasını tanımlar/döndürür
    • mb_language - Geçerli dili tanımlar/döndürür
    • mb_list_encodings - Desteklenen kodlamaların tamamını bir dizi olarak döndürür
    • mb_output_handler - Çıktı tamporundaki karakter kodlamasını dönüştüren geriçağırım işlevi
    • mb_parse_str - GET/POST/COOKIE verisini çözümler ve küresel değişkenleri tanımlar
    • mb_preferred_mime_name - MIME karakter kümesi dizgesini döndürür
    • mb_regex_encoding - mbregex işlevleri için geçerli kodlamayı dizge olarak döndürür
    • mb_regex_set_options - mbregex işlevleri için öntanımlı seçenekleri tanımlar/döndürür
    • mb_send_mail - Kodlanmış olarak posta gönderir
    • mb_split - Çok baytlı bir dizgeyi düzenli ifade ile parçalara ayırır
    • mb_strcut - Dizgenin başlangıcı ve uzunluğu belirtilen parçası ile döner
    • mb_strimwidth - Dizgeyi belirtilen genişlikte kırpar
    • mb_stripos - Harf büyüklüğüne duyarsız olarak, bir dizgenin içinde başka bir dizgeye ilk rastlanılan noktanın indisini döndürür
    • mb_stristr - Harf büyüklüğüne duyarsız olarak, bir dizgenin içinde başka bir dizgeye ilk rastlanılan noktaya göre dizgenin ilk veya son bölümü ile döner
    • mb_strlen - Dizge uzunluğu ile döner
    • mb_strpos - Bir dizgenin içinde başka bir dizgeye ilk rastlanılan noktanın indisini döndürür
    • mb_strrchr - Bir dizgenin içinde bulunan bir karaktere göre dizgenin ilk veya son bölümü ile döner
    • mb_strrichr - Harf büyüklüğüne duyarsız olarak bir dizgenin içinde bulunan bir karaktere göre dizgenin ilk veya son bölümü ile döner
    • mb_strripos - Bir dizgenin içinde harf büyüklüğüne duyarsız olarak başka bir dizgeye son rastlanılan noktanın indisini döndürür
    • mb_strrpos - Bir dizgenin içinde başka bir dizgeye son rastlanılan noktanın indisini döndürür
    • mb_strstr - Bir dizgenin içinde başka bir dizgeye ilk rastlanılan noktaya göre dizgenin ilk veya son bölümü ile döner
    • mb_strtolower - Dizgeyi küçük harfli yapar
    • mb_strtoupper - Dizgeyi büyük harfli yapar
    • mb_strwidth - Dizge genişliğini döndürür
    • mb_substitute_character - İkame karakteri atar/döndürür
    • mb_substr - Dizgenin bir alt dizgesini alır
    • mb_substr_count - Mevcut alt dizgelerin sayısı ile döner
    • mcrypt_cbc - Önerilmiyor: Veriyi CBC kipinde şifreler/çözer
    • mcrypt_cfb - Önerilmiyor: Veriyi CFB kipinde şifreler/çözer
    • mcrypt_create_iv - Rasgele bir kaynaktan bir ilklendirme vektörü (IV) oluşturur
    • mcrypt_decrypt - Belirtilen değiştirgelerle şifreli bir metnin şifresini çözer
    • mcrypt_ecb - Önerilmiyor: Veriyi ECB kipinde şifreler/çözer
    • mcrypt_encrypt - Salt metin veriyi belirtilen değiştirgelerle şifreler
    • mcrypt_enc_get_algorithms_name - Açık algoritmanın adını döndürür
    • mcrypt_enc_get_block_size - Açık algoritmanın küme boyunu döndürür
    • mcrypt_enc_get_iv_size - Açık algoritmanın ilklendirme vektörü uzunluğunu döndürür
    • mcrypt_enc_get_key_size - Açık kipin desteklediği azami anahtar uzunluğunu döndürür
    • mcrypt_enc_get_modes_name - Açık kipin ismini döndürür
    • mcrypt_enc_get_supported_key_sizes - Açık algoritmanın desteklediği anahtar boylarını listeler
    • mcrypt_enc_is_block_algorithm - Açık kipin algoritması bir küme algoritması mı diye bakar
    • mcrypt_enc_is_block_algorithm_mode - Açık kipte şifreleme kümeler halinde mi yapılıyor diye bakar
    • mcrypt_enc_is_block_mode - Açık kip küme çıktılayan türde mi diye bakar
    • mcrypt_enc_self_test - Şifreleme tanıtıcısı ile belirtilen modülün kendi kendini sınamasını sağlar
    • mcrypt_generic - Veriyi şifreler
    • mcrypt_generic_deinit - Bir şifreleme tanıtıcısını yeniden ilklendirir
    • mcrypt_generic_end - Şifrelemeyi sonlandırır
    • mcrypt_generic_init - Şifreleme için gerekli tüm tamponları ilklendirir
    • mcrypt_get_block_size - Belirtilen şifrenin küme uzunluğunu döndürür
    • mcrypt_get_cipher_name - Belirtilen şifrenin ismini döndürür
    • mcrypt_get_iv_size - Belirtilen şifre ve kipe özgü IV uzunluğunu döndürür
    • mcrypt_get_key_size - Belirtilen şifrenin anahtar uzunluğunu döndürür
    • mcrypt_list_algorithms - Desteklenen şifreleri listeler
    • mcrypt_list_modes - Desteklenen kiplerin listesini döndürür
    • mcrypt_module_close - Şifreleme tanıtıcısını kapatır
    • mcrypt_module_get_algo_block_size - Belirtilen algoritmanın küme boyunu döndürür
    • mcrypt_module_get_algo_key_size - Belirtilen algoritmanın desteklediği azami anahtar uzunluğunu döndürür
    • mcrypt_module_get_supported_key_sizes - Belirtilen algoritmanın desteklediği anahtar boyutlarını listeler
    • mcrypt_module_is_block_algorithm - Belirtilen algoritma bir küme algoritması mı diye bakar
    • mcrypt_module_is_block_algorithm_mode - Belirtilen kip, küme algoritmaları ile kullanılabiliryor mu diye bakar
    • mcrypt_module_is_block_mode - Belirtilen kip bir küme kipi mi diye bakar
    • mcrypt_module_open - Kullanılacak kipi ve algoritma modülünü açar
    • mcrypt_module_self_test - Belirtilen modülün kendini kendini sınamasını sağlar
    • mcrypt_ofb - Önerilmiyor: Veriyi OFB kipinde şifreler/çözer
    • md5 - Bir dizgenin md5 özetini hesaplar
    • md5_file - Belirtilen dosyanın md5 özetini hesaplar
    • mdecrypt_generic - Verinin şifresini çözer
    • Memcache::add - Add an item to the server
    • Memcache::addServer - Add a memcached server to connection pool
    • Memcache::close - Close memcached server connection
    • Memcache::connect - Open memcached server connection
    • Memcache::decrement - Decrement item's value
    • Memcache::delete - Delete item from the server
    • Memcache::flush - Flush all existing items at the server
    • Memcache::get - Retrieve item from the server
    • Memcache::getExtendedStats - Get statistics from all servers in pool
    • Memcache::getServerStatus - Returns server status
    • Memcache::getStats - Get statistics of the server
    • Memcache::getVersion - Return version of the server
    • Memcache::increment - Increment item's value
    • Memcache::pconnect - Open memcached server persistent connection
    • Memcache::replace - Replace value of the existing item
    • Memcache::set - Store data at the server
    • Memcache::setCompressThreshold - Enable automatic compression of large values
    • Memcache::setServerParams - Changes server parameters and status at runtime
    • Memcached::add - Add an item under a new key
    • Memcached::addByKey - Add an item under a new key on a specific server
    • Memcached::addServer - Add a server to the server pool
    • Memcached::addServers - Add multiple servers to the server pool
    • Memcached::append - Append data to an existing item
    • Memcached::appendByKey - Append data to an existing item on a specific server
    • Memcached::cas - Compare and swap an item
    • Memcached::casByKey - Compare and swap an item on a specific server
    • Memcached::decrement - Decrement numeric item's value
    • Memcached::decrementByKey - Decrement numeric item's value, stored on a specific server
    • Memcached::delete - Delete an item
    • Memcached::deleteByKey - Delete an item from a specific server
    • Memcached::deleteMulti - Delete multiple items
    • Memcached::deleteMultiByKey - Delete multiple items from a specific server
    • Memcached::fetch - Fetch the next result
    • Memcached::fetchAll - Fetch all the remaining results
    • Memcached::flush - Invalidate all items in the cache
    • Memcached::get - Retrieve an item
    • Memcached::getAllKeys - Gets the keys stored on all the servers
    • Memcached::getByKey - Retrieve an item from a specific server
    • Memcached::getDelayed - Request multiple items
    • Memcached::getDelayedByKey - Request multiple items from a specific server
    • Memcached::getMulti - Retrieve multiple items
    • Memcached::getMultiByKey - Retrieve multiple items from a specific server
    • Memcached::getOption - Retrieve a Memcached option value
    • Memcached::getResultCode - Return the result code of the last operation
    • Memcached::getResultMessage - Return the message describing the result of the last operation
    • Memcached::getServerByKey - Map a key to a server
    • Memcached::getServerList - Get the list of the servers in the pool
    • Memcached::getStats - Get server pool statistics
    • Memcached::getVersion - Get server pool version info
    • Memcached::increment - Increment numeric item's value
    • Memcached::incrementByKey - Increment numeric item's value, stored on a specific server
    • Memcached::isPersistent - Check if a persitent connection to memcache is being used
    • Memcached::isPristine - Check if the instance was recently created
    • Memcached::prepend - Prepend data to an existing item
    • Memcached::prependByKey - Prepend data to an existing item on a specific server
    • Memcached::quit - Close any open connections
    • Memcached::replace - Replace the item under an existing key
    • Memcached::replaceByKey - Replace the item under an existing key on a specific server
    • Memcached::resetServerList - Clears all servers from the server list
    • Memcached::set - Store an item
    • Memcached::setByKey - Store an item on a specific server
    • Memcached::setMulti - Store multiple items
    • Memcached::setMultiByKey - Store multiple items on a specific server
    • Memcached::setOption - Set a Memcached option
    • Memcached::setOptions - Set Memcached options
    • Memcached::setSaslAuthData - Set the credentials to use for authentication
    • Memcached::touch - Set a new expiration on an item
    • Memcached::touchByKey - Set a new expiration on an item on a specific server
    • Memcached::__construct - Create a Memcached instance
    • memcache_debug - Turn debug output on/off
    • memory_get_peak_usage - PHP'ye ayrılan belleğin azami miktarını döndürür
    • memory_get_usage - PHP'ye ayrılan belleğin miktarını döndürür
    • MessageFormatter::create - Yeni bir ileti biçemleyici nesne oluşturur
    • MessageFormatter::format - İleti biçemler
    • MessageFormatter::formatMessage - İletiyi çabuk biçemler
    • MessageFormatter::getErrorCode - Son işlemin hata kodunu döndürür
    • MessageFormatter::getErrorMessage - Son işlemin hata iletisini döndürür
    • MessageFormatter::getLocale - Biçemleyicinin oluşturulduğu yereli döndürür
    • MessageFormatter::getPattern - Biçemleyici tarafından kullanılan kalıbı döndürür
    • MessageFormatter::parse - Girdi dizgesini kalıba uygun olarak çözümler
    • MessageFormatter::parseMessage - Girdi dizgesini hızla çözümler
    • MessageFormatter::setPattern - Biçemleyici tarafından kullanılacak kalıbı tanımlar
    • metaphone - Bir dizgenin metafon anahtarını hesaplar
    • method_exists - Bir sınıf yöntemi mevcut mu diye bakar
    • mhash - İleti özetini hesaplar
    • mhash_count - Kullanılabilecek en yüksek algoritma kimliğini döndürür
    • mhash_get_block_size - Belirtilen algoritmanın küme boyunu döndürür
    • mhash_get_hash_name - Belirtilen algoritmanın ismini döndürür
    • mhash_keygen_s2k - Bir anahtar üretir
    • microtime - Geçerli Unix zaman damgasını mikrosaniye olarak döndürür
    • mime_content_type - Detect MIME Content-type for a file
    • min - Find lowest value
    • ming_keypress - Returns the action flag for keyPress(char)
    • ming_setcubicthreshold - Set cubic threshold
    • ming_setscale - Set the global scaling factor.
    • ming_setswfcompression - Sets the SWF output compression
    • ming_useconstants - Use constant pool
    • ming_useswfversion - Sets the SWF version
    • mkdir - Dizin oluşturur
    • mktime - Bir tarih için Unix zaman damgasını döndürür
    • money_format - Bir sayıyı para olarak biçemler
    • Mongo::connectUtil - Connects with a database server
    • Mongo::getPoolSize - Get pool size for connection pools
    • Mongo::getSlave - Returns the address being used by this for slaveOkay reads
    • Mongo::getSlaveOkay - Get slaveOkay setting for this connection
    • Mongo::poolDebug - Returns information about all connection pools.
    • Mongo::setPoolSize - Set the size for future connection pools.
    • Mongo::setSlaveOkay - Change slaveOkay setting for this connection
    • Mongo::switchSlave - Choose a new secondary for slaveOkay reads
    • Mongo::__construct - The __construct purpose
    • MongoBinData::__construct - Creates a new binary data object.
    • MongoBinData::__toString - The string representation of this binary data object.
    • MongoClient::close - Closes this connection
    • MongoClient::connect - Connects to a database server
    • MongoClient::dropDB - Drops a database [deprecated]
    • MongoClient::getConnections - Return info about all open connections
    • MongoClient::getHosts - Updates status for all associated hosts
    • MongoClient::getReadPreference - Get the read preference for this connection
    • MongoClient::getWriteConcern - Get the write concern for this connection
    • MongoClient::killCursor - Kills a specific cursor on the server
    • MongoClient::listDBs - Lists all of the databases available.
    • MongoClient::selectCollection - Gets a database collection
    • MongoClient::selectDB - Gets a database
    • MongoClient::setReadPreference - Set the read preference for this connection
    • MongoClient::setWriteConcern - Set the write concern for this connection
    • MongoClient::__construct - Creates a new database connection object
    • MongoClient::__get - Gets a database
    • MongoClient::__toString - String representation of this connection
    • MongoCode::__construct - Creates a new code object
    • MongoCode::__toString - Returns this code as a string
    • MongoCollection::aggregate - Perform an aggregation using the aggregation framework
    • MongoCollection::aggregateCursor - Execute an aggregation pipeline command and retrieve results through a cursor
    • MongoCollection::batchInsert - Inserts multiple documents into this collection
    • MongoCollection::count - Counts the number of documents in this collection
    • MongoCollection::createDBRef - Creates a database reference
    • MongoCollection::createIndex - Creates an index on the specified field(s) if it does not already exist.
    • MongoCollection::deleteIndex - Deletes an index from this collection
    • MongoCollection::deleteIndexes - Delete all indices for this collection
    • MongoCollection::distinct - Retrieve a list of distinct values for the given key across a collection.
    • MongoCollection::drop - Drops this collection
    • MongoCollection::ensureIndex - Creates an index on the specified field(s) if it does not already exist.
    • MongoCollection::find - Queries this collection, returning a MongoCursor for the result set
    • MongoCollection::findAndModify - Update a document and return it
    • MongoCollection::findOne - Queries this collection, returning a single element
    • MongoCollection::getDBRef - Fetches the document pointed to by a database reference
    • MongoCollection::getIndexInfo - Returns information about indexes on this collection
    • MongoCollection::getName - Returns this collection's name
    • MongoCollection::getReadPreference - Get the read preference for this collection
    • MongoCollection::getSlaveOkay - Get slaveOkay setting for this collection
    • MongoCollection::getWriteConcern - Get the write concern for this collection
    • MongoCollection::group - Performs an operation similar to SQL's GROUP BY command
    • MongoCollection::insert - Inserts a document into the collection
    • MongoCollection::parallelCollectionScan - Returns an array of cursors to iterator over a full collection in parallel
    • MongoCollection::remove - Remove records from this collection
    • MongoCollection::save - Saves a document to this collection
    • MongoCollection::setReadPreference - Set the read preference for this collection
    • MongoCollection::setSlaveOkay - Change slaveOkay setting for this collection
    • MongoCollection::setWriteConcern - Set the write concern for this database
    • MongoCollection::toIndexString - Converts keys specifying an index to its identifying string
    • MongoCollection::update - Update records based on a given criteria
    • MongoCollection::validate - Validates this collection
    • MongoCollection::__construct - Creates a new collection
    • MongoCollection::__get - Gets a collection
    • MongoCollection::__toString - String representation of this collection
    • MongoCommandCursor::batchSize - Limits the number of elements returned in one batch.
    • MongoCommandCursor::createFromDocument - Create a new command cursor from an existing command response document
    • MongoCommandCursor::current - Returns the current element
    • MongoCommandCursor::dead - Checks if there are results that have not yet been sent from the database
    • MongoCommandCursor::getReadPreference - Get the read preference for this command
    • MongoCommandCursor::info - Gets information about the cursor's creation and iteration
    • MongoCommandCursor::key - Returns the current result's index within the result set
    • MongoCommandCursor::next - Advances the cursor to the next result
    • MongoCommandCursor::rewind - Executes the command and resets the cursor to the start of the result set
    • MongoCommandCursor::setReadPreference - Set the read preference for this command
    • MongoCommandCursor::timeout - Sets a client-side timeout for this command
    • MongoCommandCursor::valid - Checks if the cursor is reading a valid result.
    • MongoCommandCursor::__construct - Create a new command cursor
    • MongoCursor::addOption - Adds a top-level key/value pair to a query
    • MongoCursor::awaitData - Sets whether this cursor will wait for a while for a tailable cursor to return more data
    • MongoCursor::batchSize - Limits the number of elements returned in one batch.
    • MongoCursor::count - Counts the number of results for this query
    • MongoCursor::current - Returns the current element
    • MongoCursor::dead - Checks if there are results that have not yet been sent from the database
    • MongoCursor::doQuery - Execute the query.
    • MongoCursor::explain - Return an explanation of the query, often useful for optimization and debugging
    • MongoCursor::fields - Sets the fields for a query
    • MongoCursor::getNext - Advances the cursor to the next result, and returns that result
    • MongoCursor::getReadPreference - Get the read preference for this query
    • MongoCursor::hasNext - Checks if there are any more elements in this cursor
    • MongoCursor::hint - Gives the database a hint about the query
    • MongoCursor::immortal - Sets whether this cursor will timeout
    • MongoCursor::info - Gets information about the cursor's creation and iteration
    • MongoCursor::key - Returns the current result's _id, or its index within the result set
    • MongoCursor::limit - Limits the number of results returned
    • MongoCursor::maxTimeMS - Sets a server-side timeout for this query
    • MongoCursor::next - Advances the cursor to the next result, and returns that result
    • MongoCursor::partial - If this query should fetch partial results from mongos if a shard is down
    • MongoCursor::reset - Clears the cursor
    • MongoCursor::rewind - Returns the cursor to the beginning of the result set
    • MongoCursor::setFlag - Sets arbitrary flags in case there is no method available the specific flag
    • MongoCursor::setReadPreference - Set the read preference for this query
    • MongoCursor::skip - Skips a number of results
    • MongoCursor::slaveOkay - Sets whether this query can be done on a secondary [deprecated]
    • MongoCursor::snapshot - Use snapshot mode for the query
    • MongoCursor::sort - Sorts the results by given fields
    • MongoCursor::tailable - Sets whether this cursor will be left open after fetching the last results
    • MongoCursor::timeout - Sets a client-side timeout for this query
    • MongoCursor::valid - Checks if the cursor is reading a valid result.
    • MongoCursor::__construct - Create a new cursor
    • MongoCursorException::getHost - The hostname of the server that encountered the error
    • MongoCursorInterface::batchSize - Limits the number of elements returned in one batch.
    • MongoCursorInterface::dead - Checks if there are results that have not yet been sent from the database
    • MongoCursorInterface::getReadPreference - Get the read preference for this query
    • MongoCursorInterface::info - Gets information about the cursor's creation and iteration
    • MongoCursorInterface::setReadPreference - Set the read preference for this query
    • MongoCursorInterface::timeout - Sets a client-side timeout for this query
    • MongoDate::toDateTime - Returns a DateTime object representing this date
    • MongoDate::__construct - Creates a new date.
    • MongoDate::__toString - Returns a string representation of this date
    • MongoDB::authenticate - Log in to this database
    • MongoDB::command - Execute a database command
    • MongoDB::createCollection - Creates a collection
    • MongoDB::createDBRef - Creates a database reference
    • MongoDB::drop - Drops this database
    • MongoDB::dropCollection - Drops a collection [deprecated]
    • MongoDB::execute - Runs JavaScript code on the database server [deprecated]
    • MongoDB::forceError - Creates a database error
    • MongoDB::getCollectionInfo - Returns information about collections in this database
    • MongoDB::getCollectionNames - Gets an array of names for all collections in this database
    • MongoDB::getDBRef - Fetches the document pointed to by a database reference
    • MongoDB::getGridFS - Fetches toolkit for dealing with files stored in this database
    • MongoDB::getProfilingLevel - Gets this database's profiling level
    • MongoDB::getReadPreference - Get the read preference for this database
    • MongoDB::getSlaveOkay - Get slaveOkay setting for this database
    • MongoDB::getWriteConcern - Get the write concern for this database
    • MongoDB::lastError - Check if there was an error on the most recent db operation performed
    • MongoDB::listCollections - Gets an array of MongoCollection objects for all collections in this database
    • MongoDB::prevError - Checks for the last error thrown during a database operation
    • MongoDB::repair - Repairs and compacts this database
    • MongoDB::resetError - Clears any flagged errors on the database
    • MongoDB::selectCollection - Gets a collection
    • MongoDB::setProfilingLevel - Sets this database's profiling level
    • MongoDB::setReadPreference - Set the read preference for this database
    • MongoDB::setSlaveOkay - Change slaveOkay setting for this database
    • MongoDB::setWriteConcern - Set the write concern for this database
    • MongoDB::__construct - Creates a new database
    • MongoDB::__get - Gets a collection
    • MongoDB::__toString - The name of this database
    • MongoDB için bağlamsal seçenekler - MongoDB için bağlamsal seçeneklerin listesi
    • MongoDBRef::create - Creates a new database reference
    • MongoDBRef::get - Fetches the object pointed to by a reference
    • MongoDBRef::isRef - Checks if an array is a database reference
    • MongoDB\BSON\Binary::getData - Returns the Binary's data
    • MongoDB\BSON\Binary::getType - Returns the Binary's type
    • MongoDB\BSON\Binary::jsonSerialize - Returns a representation that can be converted to JSON
    • MongoDB\BSON\Binary::serialize - Serialize a Binary
    • MongoDB\BSON\Binary::unserialize - Unserialize a Binary
    • MongoDB\BSON\Binary::__construct - Construct a new Binary
    • MongoDB\BSON\Binary::__toString - Returns the Binary's data
    • MongoDB\BSON\Decimal128::jsonSerialize - Returns a representation that can be converted to JSON
    • MongoDB\BSON\Decimal128::serialize - Serialize a Decimal128
    • MongoDB\BSON\Decimal128::unserialize - Unserialize a Decimal128
    • MongoDB\BSON\Decimal128::__construct - Construct a new Decimal128
    • MongoDB\BSON\Decimal128::__toString - Returns the string representation of this Decimal128
    • MongoDB\BSON\fromJSON - Returns the BSON representation of a JSON value
    • MongoDB\BSON\fromPHP - Returns the BSON representation of a PHP value
    • MongoDB\BSON\Javascript::getCode - Returns the Javascript's code
    • MongoDB\BSON\Javascript::getScope - Returns the Javascript's scope document
    • MongoDB\BSON\Javascript::jsonSerialize - Returns a representation that can be converted to JSON
    • MongoDB\BSON\Javascript::serialize - Serialize a Javascript
    • MongoDB\BSON\Javascript::unserialize - Unserialize a Javascript
    • MongoDB\BSON\Javascript::__construct - Construct a new Javascript
    • MongoDB\BSON\Javascript::__toString - Returns the Javascript's code
    • MongoDB\BSON\MaxKey::jsonSerialize - Returns a representation that can be converted to JSON
    • MongoDB\BSON\MaxKey::serialize - Serialize a MaxKey
    • MongoDB\BSON\MaxKey::unserialize - Unserialize a MaxKey
    • MongoDB\BSON\MaxKey::__construct - Construct a new MaxKey
    • MongoDB\BSON\MinKey::jsonSerialize - Returns a representation that can be converted to JSON
    • MongoDB\BSON\MinKey::serialize - Serialize a MinKey
    • MongoDB\BSON\MinKey::unserialize - Unserialize a MinKey
    • MongoDB\BSON\MinKey::__construct - Construct a new MinKey
    • MongoDB\BSON\ObjectID::getTimestamp - Returns the timestamp component of this ObjectID
    • MongoDB\BSON\ObjectID::jsonSerialize - Returns a representation that can be converted to JSON
    • MongoDB\BSON\ObjectID::serialize - Serialize an ObjectID
    • MongoDB\BSON\ObjectID::unserialize - Unserialize an ObjectID
    • MongoDB\BSON\ObjectID::__construct - Construct a new ObjectID
    • MongoDB\BSON\ObjectID::__toString - Returns the hexidecimal representation of this ObjectID
    • MongoDB\BSON\Regex::getFlags - Returns the Regex's flags
    • MongoDB\BSON\Regex::getPattern - Returns the Regex's pattern
    • MongoDB\BSON\Regex::jsonSerialize - Returns a representation that can be converted to JSON
    • MongoDB\BSON\Regex::serialize - Serialize a Regex
    • MongoDB\BSON\Regex::unserialize - Unserialize a Regex
    • MongoDB\BSON\Regex::__construct - Construct a new Regex
    • MongoDB\BSON\Regex::__toString - Returns the string representation of this Regex
    • MongoDB\BSON\Serializable::bsonSerialize - Provides an array or document to serialize as BSON
    • MongoDB\BSON\Timestamp::jsonSerialize - Returns a representation that can be converted to JSON
    • MongoDB\BSON\Timestamp::serialize - Serialize a Timestamp
    • MongoDB\BSON\Timestamp::unserialize - Unserialize a Timestamp
    • MongoDB\BSON\Timestamp::__construct - Construct a new Timestamp
    • MongoDB\BSON\Timestamp::__toString - Returns the string representation of this Timestamp
    • MongoDB\BSON\toJSON - Returns the JSON representation of a BSON value
    • MongoDB\BSON\toPHP - Returns the PHP representation of a BSON value
    • MongoDB\BSON\Unserializable::bsonUnserialize - Constructs the object from a BSON array or document
    • MongoDB\BSON\UTCDateTime::jsonSerialize - Returns a representation that can be converted to JSON
    • MongoDB\BSON\UTCDateTime::serialize - Serialize a UTCDateTime
    • MongoDB\BSON\UTCDateTime::toDateTime - Returns the DateTime representation of this UTCDateTime
    • MongoDB\BSON\UTCDateTime::unserialize - Unserialize a UTCDateTime
    • MongoDB\BSON\UTCDateTime::__construct - Construct a new UTCDateTime
    • MongoDB\BSON\UTCDateTime::__toString - Returns the string representation of this UTCDateTime
    • MongoDB\Driver\BulkWrite::count - Count number of write operations in the bulk
    • MongoDB\Driver\BulkWrite::delete - Add a delete operation to the bulk
    • MongoDB\Driver\BulkWrite::insert - Add an insert operation to the bulk
    • MongoDB\Driver\BulkWrite::update - Add an update operation to the bulk
    • MongoDB\Driver\BulkWrite::__construct - Create a new BulkWrite
    • MongoDB\Driver\Command::__construct - Create a new Command
    • MongoDB\Driver\Cursor::getId - Returns the ID for this cursor
    • MongoDB\Driver\Cursor::getServer - Returns the server associated with this cursor
    • MongoDB\Driver\Cursor::isDead - Checks if the cursor is still open on the server
    • MongoDB\Driver\Cursor::setTypeMap - Sets a type map to use for BSON unserialization
    • MongoDB\Driver\Cursor::toArray - Returns an array containing all results for this cursor
    • MongoDB\Driver\Cursor::__construct - Create a new Cursor (not used)
    • MongoDB\Driver\CursorId::__construct - Create a new CursorId (not used)
    • MongoDB\Driver\CursorId::__toString - String representation of the cursor ID
    • MongoDB\Driver\Exception\WriteException::getWriteResult - Returns the WriteResult for the failed write operation
    • MongoDB\Driver\Manager::executeBulkWrite - Execute one or more write operations
    • MongoDB\Driver\Manager::executeCommand - Execute a database command
    • MongoDB\Driver\Manager::executeQuery - Execute a database query
    • MongoDB\Driver\Manager::getReadConcern - Return the ReadConcern for the Manager
    • MongoDB\Driver\Manager::getReadPreference - Return the ReadPreference for the Manager
    • MongoDB\Driver\Manager::getServers - Return the servers to which this manager is connected
    • MongoDB\Driver\Manager::getWriteConcern - Return the WriteConcern for the Manager
    • MongoDB\Driver\Manager::selectServer - Select a server matching a read preference
    • MongoDB\Driver\Manager::__construct - Create new MongoDB Manager
    • MongoDB\Driver\Query::__construct - Construct new Query
    • MongoDB\Driver\ReadConcern::bsonSerialize - Returns an object for BSON serialization
    • MongoDB\Driver\ReadConcern::getLevel - Returns the ReadConcern's "level" option
    • MongoDB\Driver\ReadConcern::__construct - Construct immutable ReadConcern
    • MongoDB\Driver\ReadPreference::bsonSerialize - Returns an object for BSON serialization
    • MongoDB\Driver\ReadPreference::getMaxStalenessSeconds - Returns the ReadPreference's "maxStalenessSeconds" option
    • MongoDB\Driver\ReadPreference::getMode - Returns the ReadPreference's "mode" option
    • MongoDB\Driver\ReadPreference::getTagSets - Returns the ReadPreference's "tagSets" option
    • MongoDB\Driver\ReadPreference::__construct - Construct immutable ReadPreference
    • MongoDB\Driver\Server::executeBulkWrite - Execute one or more write operations on this server
    • MongoDB\Driver\Server::executeCommand - Execute a database command on this server
    • MongoDB\Driver\Server::executeQuery - Execute a database query on this server
    • MongoDB\Driver\Server::getHost - Returns the hostname of this server
    • MongoDB\Driver\Server::getInfo - Returns an array of information about this server
    • MongoDB\Driver\Server::getLatency - Returns the latency of this server
    • MongoDB\Driver\Server::getPort - Returns the port on which this server is listening
    • MongoDB\Driver\Server::getTags - Returns an array of tags describing this server in a replica set
    • MongoDB\Driver\Server::getType - Returns an integer denoting the type of this server
    • MongoDB\Driver\Server::isArbiter - Checks if this server is an arbiter member of a replica set
    • MongoDB\Driver\Server::isHidden - Checks if this server is a hidden member of a replica set
    • MongoDB\Driver\Server::isPassive - Checks if this server is a passive member of a replica set
    • MongoDB\Driver\Server::isPrimary - Checks if this server is a primary member of a replica set
    • MongoDB\Driver\Server::isSecondary - Checks if this server is a secondary member of a replica set
    • MongoDB\Driver\Server::__construct - Create a new Server (not used)
    • MongoDB\Driver\WriteConcern::bsonSerialize - Returns an object for BSON serialization
    • MongoDB\Driver\WriteConcern::getJournal - Returns the WriteConcern's "journal" option
    • MongoDB\Driver\WriteConcern::getW - Returns the WriteConcern's "w" option
    • MongoDB\Driver\WriteConcern::getWtimeout - Returns the WriteConcern's "wtimeout" option
    • MongoDB\Driver\WriteConcern::__construct - Construct immutable WriteConcern
    • MongoDB\Driver\WriteConcernError::getCode - Returns the WriteConcernError's error code
    • MongoDB\Driver\WriteConcernError::getInfo - Returns additional metadata for the WriteConcernError
    • MongoDB\Driver\WriteConcernError::getMessage - Returns the WriteConcernError's error message
    • MongoDB\Driver\WriteError::getCode - Returns the WriteError's error code
    • MongoDB\Driver\WriteError::getIndex - Returns the index of the write operation corresponding to this WriteError
    • MongoDB\Driver\WriteError::getInfo - Returns additional metadata for the WriteError
    • MongoDB\Driver\WriteError::getMessage - Returns the WriteError's error message
    • MongoDB\Driver\WriteResult::getDeletedCount - Returns the number of documents deleted
    • MongoDB\Driver\WriteResult::getInsertedCount - Returns the number of documents inserted (excluding upserts)
    • MongoDB\Driver\WriteResult::getMatchedCount - Returns the number of documents selected for update
    • MongoDB\Driver\WriteResult::getModifiedCount - Returns the number of existing documents updated
    • MongoDB\Driver\WriteResult::getServer - Returns the server associated with this write result
    • MongoDB\Driver\WriteResult::getUpsertedCount - Returns the number of documents inserted by an upsert
    • MongoDB\Driver\WriteResult::getUpsertedIds - Returns an array of identifiers for upserted documents
    • MongoDB\Driver\WriteResult::getWriteConcernError - Returns any write concern error that occurred
    • MongoDB\Driver\WriteResult::getWriteErrors - Returns any write errors that occurred
    • MongoDB\Driver\WriteResult::isAcknowledged - Returns whether the write was acknowledged
    • MongoDeleteBatch::__construct - Description
    • MongoGridFS::delete - Remove a file and its chunks from the database
    • MongoGridFS::drop - Drops the files and chunks collections
    • MongoGridFS::find - Queries for files
    • MongoGridFS::findOne - Returns a single file matching the criteria
    • MongoGridFS::get - Retrieve a file from the database
    • MongoGridFS::put - Stores a file in the database
    • MongoGridFS::remove - Remove files and their chunks from the database
    • MongoGridFS::storeBytes - Stores a string of bytes in the database
    • MongoGridFS::storeFile - Stores a file in the database
    • MongoGridFS::storeUpload - Stores an uploaded file in the database
    • MongoGridFS::__construct - Creates new file collections
    • MongoGridFSCursor::current - Returns the current file
    • MongoGridFSCursor::getNext - Return the next file to which this cursor points, and advance the cursor
    • MongoGridFSCursor::key - Returns the current result's filename
    • MongoGridFSCursor::__construct - Create a new cursor
    • MongoGridFSFile::getBytes - Returns this file's contents as a string of bytes
    • MongoGridFSFile::getFilename - Returns this file's filename
    • MongoGridFSFile::getResource - Returns a resource that can be used to read the stored file
    • MongoGridFSFile::getSize - Returns this file's size
    • MongoGridFSFile::write - Writes this file to the filesystem
    • MongoGridfsFile::__construct - Create a new GridFS file
    • MongoId::getHostname - Gets the hostname being used for this machine's ids
    • MongoId::getInc - Gets the incremented value to create this id
    • MongoId::getPID - Gets the process ID
    • MongoId::getTimestamp - Gets the number of seconds since the epoch that this id was created
    • MongoId::isValid - Check if a value is a valid ObjectId
    • MongoId::__construct - Creates a new id
    • MongoId::__set_state - Create a dummy MongoId
    • MongoId::__toString - Returns a hexidecimal representation of this id
    • MongoInsertBatch::__construct - Description
    • MongoInt32::__construct - Creates a new 32-bit integer.
    • MongoInt32::__toString - Returns the string representation of this 32-bit integer.
    • MongoInt64::__construct - Creates a new 64-bit integer.
    • MongoInt64::__toString - Returns the string representation of this 64-bit integer.
    • MongoLog::getCallback - Gets the previously set callback function
    • MongoLog::getLevel - Gets the level(s) currently being logged
    • MongoLog::getModule - Gets the module(s) currently being logged
    • MongoLog::setCallback - Sets a callback function to be invoked for events
    • MongoLog::setLevel - Sets the level(s) to be logged
    • MongoLog::setModule - Sets the module(s) to be logged
    • MongoPool::getSize - Get pool size for connection pools
    • MongoPool::info - Returns information about all connection pools.
    • MongoPool::setSize - Set the size for future connection pools.
    • MongoRegex::__construct - Creates a new regular expression
    • MongoRegex::__toString - A string representation of this regular expression
    • MongoResultException::getDocument - Retrieve the full result document
    • MongoTimestamp::__construct - Creates a new timestamp.
    • MongoTimestamp::__toString - Returns a string representation of this timestamp
    • MongoUpdateBatch::__construct - Description
    • MongoWriteBatch::add - Adds a write operation to a batch
    • MongoWriteBatch::execute - Executes a batch of write operations
    • MongoWriteBatch::__construct - Creates a new batch of write operations
    • MongoWriteConcernException::getDocument - Get the error document
    • move_uploaded_file - Karşıya yüklenen bir dosyayı yeni bir yere taşır
    • mqseries_back - MQSeries MQBACK
    • mqseries_begin - MQseries MQBEGIN
    • mqseries_close - MQSeries MQCLOSE
    • mqseries_cmit - MQSeries MQCMIT
    • mqseries_conn - MQSeries MQCONN
    • mqseries_connx - MQSeries MQCONNX
    • mqseries_disc - MQSeries MQDISC
    • mqseries_get - MQSeries MQGET
    • mqseries_inq - MQSeries MQINQ
    • mqseries_open - MQSeries MQOPEN
    • mqseries_put - MQSeries MQPUT
    • mqseries_put1 - MQSeries MQPUT1
    • mqseries_set - MQSeries MQSET
    • mqseries_strerror - Returns the error message corresponding to a result code (MQRC).
    • msession_connect - Connect to msession server
    • msession_count - Get session count
    • msession_create - Create a session
    • msession_destroy - Destroy a session
    • msession_disconnect - Close connection to msession server
    • msession_find - Find all sessions with name and value
    • msession_get - Get value from session
    • msession_get_array - Get array of msession variables
    • msession_get_data - Get data session unstructured data
    • msession_inc - Increment value in session
    • msession_list - List all sessions
    • msession_listvar - List sessions with variable
    • msession_lock - Lock a session
    • msession_plugin - Call an escape function within the msession personality plugin
    • msession_randstr - Get random string
    • msession_set - Set value in session
    • msession_set_array - Set msession variables from an array
    • msession_set_data - Set data session unstructured data
    • msession_timeout - Set/get session timeout
    • msession_uniq - Get unique id
    • msession_unlock - Unlock a session
    • msg_get_queue - Create or attach to a message queue
    • msg_queue_exists - Check whether a message queue exists
    • msg_receive - Receive a message from a message queue
    • msg_remove_queue - Destroy a message queue
    • msg_send - Send a message to a message queue
    • msg_set_queue - Set information in the message queue data structure
    • msg_stat_queue - Returns information from the message queue data structure
    • msql - Alias of msql_db_query
    • msql_affected_rows - Returns number of affected rows
    • msql_close - Close mSQL connection
    • msql_connect - Open mSQL connection
    • msql_createdb - Takma Adı: msql_create_db
    • msql_create_db - Create mSQL database
    • msql_data_seek - Move internal row pointer
    • msql_dbname - Takma Adı: msql_result
    • msql_db_query - Send mSQL query
    • msql_drop_db - Drop (delete) mSQL database
    • msql_error - Returns error message of last msql call
    • msql_fetch_array - Fetch row as array
    • msql_fetch_field - Get field information
    • msql_fetch_object - Fetch row as object
    • msql_fetch_row - Get row as enumerated array
    • msql_fieldflags - Alias of msql_field_flags
    • msql_fieldlen - Alias of msql_field_len
    • msql_fieldname - Alias of msql_field_name
    • msql_fieldtable - Alias of msql_field_table
    • msql_fieldtype - Alias of msql_field_type
    • msql_field_flags - Get field flags
    • msql_field_len - Get field length
    • msql_field_name - Get the name of the specified field in a result
    • msql_field_seek - Set field offset
    • msql_field_table - Get table name for field
    • msql_field_type - Get field type
    • msql_free_result - Free result memory
    • msql_list_dbs - List mSQL databases on server
    • msql_list_fields - List result fields
    • msql_list_tables - List tables in an mSQL database
    • msql_numfields - Alias of msql_num_fields
    • msql_numrows - Alias of msql_num_rows
    • msql_num_fields - Get number of fields in result
    • msql_num_rows - Get number of rows in result
    • msql_pconnect - Open persistent mSQL connection
    • msql_query - Send mSQL query
    • msql_regcase - Alias of sql_regcase
    • msql_result - Get result data
    • msql_select_db - Select mSQL database
    • msql_tablename - Alias of msql_result
    • mssql_bind - Adds a parameter to a stored procedure or a remote stored procedure
    • mssql_close - Close MS SQL Server connection
    • mssql_connect - Open MS SQL server connection
    • mssql_data_seek - Moves internal row pointer
    • mssql_execute - Executes a stored procedure on a MS SQL server database
    • mssql_fetch_array - Fetch a result row as an associative array, a numeric array, or both
    • mssql_fetch_assoc - Returns an associative array of the current row in the result
    • mssql_fetch_batch - Returns the next batch of records
    • mssql_fetch_field - Get field information
    • mssql_fetch_object - Fetch row as object
    • mssql_fetch_row - Get row as enumerated array
    • mssql_field_length - Get the length of a field
    • mssql_field_name - Get the name of a field
    • mssql_field_seek - Seeks to the specified field offset
    • mssql_field_type - Gets the type of a field
    • mssql_free_result - Free result memory
    • mssql_free_statement - Free statement memory
    • mssql_get_last_message - Returns the last message from the server
    • mssql_guid_string - Converts a 16 byte binary GUID to a string
    • mssql_init - Initializes a stored procedure or a remote stored procedure
    • mssql_min_error_severity - Sets the minimum error severity
    • mssql_min_message_severity - Sets the minimum message severity
    • mssql_next_result - Move the internal result pointer to the next result
    • mssql_num_fields - Gets the number of fields in result
    • mssql_num_rows - Gets the number of rows in result
    • mssql_pconnect - Open persistent MS SQL connection
    • mssql_query - Send MS SQL query
    • mssql_result - Get result data
    • mssql_rows_affected - Returns the number of records affected by the query
    • mssql_select_db - Select MS SQL database
    • mt_getrandmax - Show largest possible random value
    • mt_rand - Generate a random value via the Mersenne Twister Random Number Generator
    • mt_srand - Seeds the Mersenne Twister Random Number Generator
    • MultipleIterator::attachIterator - Attaches iterator information
    • MultipleIterator::containsIterator - Checks if an iterator is attached
    • MultipleIterator::countIterators - Gets the number of attached iterator instances
    • MultipleIterator::current - Gets the registered iterator instances
    • MultipleIterator::detachIterator - Detaches an iterator
    • MultipleIterator::getFlags - Gets the flag information
    • MultipleIterator::key - Gets the registered iterator instances
    • MultipleIterator::next - Moves all attached iterator instances forward
    • MultipleIterator::rewind - Rewinds all attached iterator instances
    • MultipleIterator::setFlags - Sets flags
    • MultipleIterator::valid - Checks the validity of sub iterators
    • MultipleIterator::__construct - Constructs a new MultipleIterator
    • Mutex::create - Create a Mutex
    • Mutex::destroy - Destroy Mutex
    • Mutex::lock - Acquire Mutex
    • Mutex::trylock - Attempt to Acquire Mutex
    • Mutex::unlock - Release Mutex
    • mysqli::$affected_rows - Gets the number of affected rows in a previous MySQL operation
    • mysqli::$client_info - Get MySQL client info
    • mysqli::$connect_errno - Returns the error code from last connect call
    • mysqli::$connect_error - Returns a string description of the last connect error
    • mysqli::$errno - Returns the error code for the most recent function call
    • mysqli::$error - Returns a string description of the last error
    • mysqli::$error_list - Returns a list of errors from the last command executed
    • mysqli::$field_count - Returns the number of columns for the most recent query
    • mysqli::$host_info - Returns a string representing the type of connection used
    • mysqli::$info - Retrieves information about the most recently executed query
    • mysqli::$insert_id - Returns the auto generated id used in the latest query
    • mysqli::$protocol_version - Returns the version of the MySQL protocol used
    • mysqli::$server_info - Returns the version of the MySQL server
    • mysqli::$server_version - Returns the version of the MySQL server as an integer
    • mysqli::$sqlstate - Returns the SQLSTATE error from previous MySQL operation
    • mysqli::$thread_id - Returns the thread ID for the current connection
    • mysqli::$warning_count - Returns the number of warnings from the last query for the given link
    • mysqli::autocommit - Turns on or off auto-committing database modifications
    • mysqli::begin_transaction - Starts a transaction
    • mysqli::change_user - Changes the user of the specified database connection
    • mysqli::character_set_name - Returns the default character set for the database connection
    • mysqli::close - Closes a previously opened database connection
    • mysqli::commit - Commits the current transaction
    • mysqli::debug - Performs debugging operations
    • mysqli::disable_reads_from_master - Disable reads from master
    • mysqli::dump_debug_info - Dump debugging information into the log
    • mysqli::get_charset - Returns a character set object
    • mysqli::get_client_info - Get MySQL client info
    • mysqli::get_connection_stats - Returns statistics about the client connection
    • mysqli::get_warnings - Get result of SHOW WARNINGS
    • mysqli::init - Initializes MySQLi and returns a resource for use with mysqli_real_connect()
    • mysqli::kill - Asks the server to kill a MySQL thread
    • mysqli::more_results - Check if there are any more query results from a multi query
    • mysqli::multi_query - Performs a query on the database
    • mysqli::next_result - Prepare next result from multi_query
    • mysqli::options - Set options
    • mysqli::ping - Pings a server connection, or tries to reconnect if the connection has gone down
    • mysqli::poll - Poll connections
    • mysqli::prepare - Prepare an SQL statement for execution
    • mysqli::query - Performs a query on the database
    • mysqli::real_connect - Opens a connection to a mysql server
    • mysqli::real_escape_string - Escapes special characters in a string for use in an SQL statement, taking into account the current charset of the connection
    • mysqli::real_query - Execute an SQL query
    • mysqli::reap_async_query - Get result from async query
    • mysqli::refresh - Refreshes
    • mysqli::release_savepoint - Removes the named savepoint from the set of savepoints of the current transaction
    • mysqli::rollback - Rolls back current transaction
    • mysqli::rpl_query_type - Returns RPL query type
    • mysqli::savepoint - Set a named transaction savepoint
    • mysqli::select_db - Selects the default database for database queries
    • mysqli::send_query - Send the query and return
    • mysqli::set_charset - Sets the default client character set
    • mysqli::set_local_infile_default - Unsets user defined handler for load local infile command
    • mysqli::set_local_infile_handler - Set callback function for LOAD DATA LOCAL INFILE command
    • mysqli::set_opt - Alias of mysqli_options
    • mysqli::ssl_set - Used for establishing secure connections using SSL
    • mysqli::stat - Gets the current system status
    • mysqli::stmt_init - Initializes a statement and returns an object for use with mysqli_stmt_prepare
    • mysqli::store_result - Transfers a result set from the last query
    • mysqli::thread_safe - Returns whether thread safety is given or not
    • mysqli::use_result - Initiate a result set retrieval
    • mysqli::__construct - Open a new connection to the MySQL server
    • mysqli_bind_param - Alias for mysqli_stmt_bind_param
    • mysqli_bind_result - Alias for mysqli_stmt_bind_result
    • mysqli_client_encoding - Alias of mysqli_character_set_name
    • mysqli_connect - Takma Adı: mysqli::__construct
    • mysqli_disable_rpl_parse - Disable RPL parse
    • mysqli_driver::$report_mode - Enables or disables internal report functions
    • mysqli_driver::embedded_server_end - Stop embedded server
    • mysqli_driver::embedded_server_start - Initialize and start embedded server
    • mysqli_enable_reads_from_master - Enable reads from master
    • mysqli_enable_rpl_parse - Enable RPL parse
    • mysqli_escape_string - Takma Adı: mysqli_real_escape_string
    • mysqli_execute - Alias for mysqli_stmt_execute
    • mysqli_fetch - Alias for mysqli_stmt_fetch
    • mysqli_get_cache_stats - Returns client Zval cache statistics
    • mysqli_get_client_stats - Returns client per-process statistics
    • mysqli_get_client_version - Returns the MySQL client version as an integer
    • mysqli_get_links_stats - Return information about open and cached links
    • mysqli_get_metadata - Alias for mysqli_stmt_result_metadata
    • mysqli_master_query - Enforce execution of a query on the master in a master/slave setup
    • mysqli_param_count - Alias for mysqli_stmt_param_count
    • mysqli_report - Takma Adı: mysqli_driver->report_mode
    • mysqli_result::$current_field - Get current field offset of a result pointer
    • mysqli_result::$field_count - Get the number of fields in a result
    • mysqli_result::$lengths - Returns the lengths of the columns of the current row in the result set
    • mysqli_result::$num_rows - Gets the number of rows in a result
    • mysqli_result::data_seek - Adjusts the result pointer to an arbitrary row in the result
    • mysqli_result::fetch_all - Fetches all result rows as an associative array, a numeric array, or both
    • mysqli_result::fetch_array - Fetch a result row as an associative, a numeric array, or both
    • mysqli_result::fetch_assoc - Fetch a result row as an associative array
    • mysqli_result::fetch_field - Returns the next field in the result set
    • mysqli_result::fetch_fields - Returns an array of objects representing the fields in a result set
    • mysqli_result::fetch_field_direct - Fetch meta-data for a single field
    • mysqli_result::fetch_object - Returns the current row of a result set as an object
    • mysqli_result::fetch_row - Get a result row as an enumerated array
    • mysqli_result::field_seek - Set result pointer to a specified field offset
    • mysqli_result::free - Frees the memory associated with a result
    • mysqli_rpl_parse_enabled - Check if RPL parse is enabled
    • mysqli_rpl_probe - RPL probe
    • mysqli_send_long_data - Alias for mysqli_stmt_send_long_data
    • mysqli_slave_query - Force execution of a query on a slave in a master/slave setup
    • mysqli_stmt::$affected_rows - Returns the total number of rows changed, deleted, or inserted by the last executed statement
    • mysqli_stmt::$errno - Returns the error code for the most recent statement call
    • mysqli_stmt::$error - Returns a string description for last statement error
    • mysqli_stmt::$error_list - Returns a list of errors from the last statement executed
    • mysqli_stmt::$field_count - Returns the number of field in the given statement
    • mysqli_stmt::$insert_id - Get the ID generated from the previous INSERT operation
    • mysqli_stmt::$num_rows - Return the number of rows in statements result set
    • mysqli_stmt::$param_count - Returns the number of parameter for the given statement
    • mysqli_stmt::$sqlstate - Returns SQLSTATE error from previous statement operation
    • mysqli_stmt::attr_get - Used to get the current value of a statement attribute
    • mysqli_stmt::attr_set - Used to modify the behavior of a prepared statement
    • mysqli_stmt::bind_param - Binds variables to a prepared statement as parameters
    • mysqli_stmt::bind_result - Binds variables to a prepared statement for result storage
    • mysqli_stmt::close - Closes a prepared statement
    • mysqli_stmt::data_seek - Seeks to an arbitrary row in statement result set
    • mysqli_stmt::execute - Executes a prepared Query
    • mysqli_stmt::fetch - Fetch results from a prepared statement into the bound variables
    • mysqli_stmt::free_result - Frees stored result memory for the given statement handle
    • mysqli_stmt::get_result - Gets a result set from a prepared statement
    • mysqli_stmt::get_warnings - Get result of SHOW WARNINGS
    • mysqli_stmt::more_results - Check if there are more query results from a multiple query
    • mysqli_stmt::next_result - Reads the next result from a multiple query
    • mysqli_stmt::prepare - Prepare an SQL statement for execution
    • mysqli_stmt::reset - Resets a prepared statement
    • mysqli_stmt::result_metadata - Returns result set metadata from a prepared statement
    • mysqli_stmt::send_long_data - Send data in blocks
    • mysqli_stmt::store_result - Transfers a result set from a prepared statement
    • mysqli_stmt::__construct - Constructs a new mysqli_stmt object
    • mysqli_warning::next - The next purpose
    • mysqli_warning::__construct - The __construct purpose
    • MysqlndUhConnection::changeUser - Changes the user of the specified mysqlnd database connection
    • MysqlndUhConnection::charsetName - Returns the default character set for the database connection
    • MysqlndUhConnection::close - Closes a previously opened database connection
    • MysqlndUhConnection::connect - Open a new connection to the MySQL server
    • MysqlndUhConnection::endPSession - End a persistent connection
    • MysqlndUhConnection::escapeString - Escapes special characters in a string for use in an SQL statement, taking into account the current charset of the connection
    • MysqlndUhConnection::getAffectedRows - Gets the number of affected rows in a previous MySQL operation
    • MysqlndUhConnection::getErrorNumber - Returns the error code for the most recent function call
    • MysqlndUhConnection::getErrorString - Returns a string description of the last error
    • MysqlndUhConnection::getFieldCount - Returns the number of columns for the most recent query
    • MysqlndUhConnection::getHostInformation - Returns a string representing the type of connection used
    • MysqlndUhConnection::getLastInsertId - Returns the auto generated id used in the last query.
    • MysqlndUhConnection::getLastMessage - Retrieves information about the most recently executed query
    • MysqlndUhConnection::getProtocolInformation - Returns the version of the MySQL protocol used
    • MysqlndUhConnection::getServerInformation - Returns the version of the MySQL server
    • MysqlndUhConnection::getServerStatistics - Gets the current system status
    • MysqlndUhConnection::getServerVersion - Returns the version of the MySQL server as an integer
    • MysqlndUhConnection::getSqlstate - Returns the SQLSTATE error from previous MySQL operation
    • MysqlndUhConnection::getStatistics - Returns statistics about the client connection.
    • MysqlndUhConnection::getThreadId - Returns the thread ID for the current connection
    • MysqlndUhConnection::getWarningCount - Returns the number of warnings from the last query for the given link
    • MysqlndUhConnection::init - Initialize mysqlnd connection
    • MysqlndUhConnection::killConnection - Asks the server to kill a MySQL thread
    • MysqlndUhConnection::listFields - List MySQL table fields
    • MysqlndUhConnection::listMethod - Wrapper for assorted list commands
    • MysqlndUhConnection::moreResults - Check if there are any more query results from a multi query
    • MysqlndUhConnection::nextResult - Prepare next result from multi_query
    • MysqlndUhConnection::ping - Pings a server connection, or tries to reconnect if the connection has gone down
    • MysqlndUhConnection::query - Performs a query on the database
    • MysqlndUhConnection::queryReadResultsetHeader - Read a result set header
    • MysqlndUhConnection::reapQuery - Get result from async query
    • MysqlndUhConnection::refreshServer - Flush or reset tables and caches
    • MysqlndUhConnection::restartPSession - Restart a persistent mysqlnd connection
    • MysqlndUhConnection::selectDb - Selects the default database for database queries
    • MysqlndUhConnection::sendClose - Sends a close command to MySQL
    • MysqlndUhConnection::sendQuery - Sends a query to MySQL
    • MysqlndUhConnection::serverDumpDebugInformation - Dump debugging information into the log for the MySQL server
    • MysqlndUhConnection::setAutocommit - Turns on or off auto-committing database modifications
    • MysqlndUhConnection::setCharset - Sets the default client character set
    • MysqlndUhConnection::setClientOption - Sets a client option
    • MysqlndUhConnection::setServerOption - Sets a server option
    • MysqlndUhConnection::shutdownServer - The shutdownServer purpose
    • MysqlndUhConnection::simpleCommand - Sends a basic COM_* command
    • MysqlndUhConnection::simpleCommandHandleResponse - Process a response for a basic COM_* command send to the client
    • MysqlndUhConnection::sslSet - Used for establishing secure connections using SSL
    • MysqlndUhConnection::stmtInit - Initializes a statement and returns a resource for use with mysqli_statement::prepare
    • MysqlndUhConnection::storeResult - Transfers a result set from the last query
    • MysqlndUhConnection::txCommit - Commits the current transaction
    • MysqlndUhConnection::txRollback - Rolls back current transaction
    • MysqlndUhConnection::useResult - Initiate a result set retrieval
    • MysqlndUhConnection::__construct - The __construct purpose
    • MysqlndUhPreparedStatement::execute - Executes a prepared Query
    • MysqlndUhPreparedStatement::prepare - Prepare an SQL statement for execution
    • MysqlndUhPreparedStatement::__construct - The __construct purpose
    • mysqlnd_memcache_get_config - Returns information about the plugin configuration
    • mysqlnd_memcache_set - Associate a MySQL connection with a Memcache connection
    • mysqlnd_ms_dump_servers - Returns a list of currently configured servers
    • mysqlnd_ms_fabric_select_global - Switch to global sharding server for a given table
    • mysqlnd_ms_fabric_select_shard - Switch to shard
    • mysqlnd_ms_get_last_gtid - Returns the latest global transaction ID
    • mysqlnd_ms_get_last_used_connection - Returns an array which describes the last used connection
    • mysqlnd_ms_get_stats - Returns query distribution and connection statistics
    • mysqlnd_ms_match_wild - Finds whether a table name matches a wildcard pattern or not
    • mysqlnd_ms_query_is_select - Find whether to send the query to the master, the slave or the last used MySQL server
    • mysqlnd_ms_set_qos - Sets the quality of service needed from the cluster
    • mysqlnd_ms_set_user_pick_server - Sets a callback for user-defined read/write splitting
    • mysqlnd_ms_xa_begin - Starts a distributed/XA transaction among MySQL servers
    • mysqlnd_ms_xa_commit - Commits a distributed/XA transaction among MySQL servers
    • mysqlnd_ms_xa_gc - Garbage collects unfinished XA transactions after severe errors
    • mysqlnd_ms_xa_rollback - Rolls back a distributed/XA transaction among MySQL servers
    • mysqlnd_qc_clear_cache - Flush all cache contents
    • mysqlnd_qc_get_available_handlers - Returns a list of available storage handler
    • mysqlnd_qc_get_cache_info - Returns information on the current handler, the number of cache entries and cache entries, if available
    • mysqlnd_qc_get_core_stats - Statistics collected by the core of the query cache
    • mysqlnd_qc_get_normalized_query_trace_log - Returns a normalized query trace log for each query inspected by the query cache
    • mysqlnd_qc_get_query_trace_log - Returns a backtrace for each query inspected by the query cache
    • mysqlnd_qc_set_cache_condition - Set conditions for automatic caching
    • mysqlnd_qc_set_is_select - Installs a callback which decides whether a statement is cached
    • mysqlnd_qc_set_storage_handler - Change current storage handler
    • mysqlnd_qc_set_user_handlers - Sets the callback functions for a user-defined procedural storage handler
    • mysqlnd_uh_convert_to_mysqlnd - Converts a MySQL connection handle into a mysqlnd connection handle
    • mysqlnd_uh_set_connection_proxy - Installs a proxy for mysqlnd connections
    • mysqlnd_uh_set_statement_proxy - Installs a proxy for mysqlnd statements
    • mysql_affected_rows - Önceki MySQL işleminde etkilenen satırların sayısını al
    • mysql_client_encoding - Karakter kümesinin adını döndürür
    • mysql_close - MySQL bağlantısını kapatır
    • mysql_connect - MySQL Sunucusuna bir bağlantı açar
    • mysql_create_db - Bir MySQL veritabanı oluşturur
    • mysql_data_seek - Move internal result pointer
    • mysql_db_name - Sonuç verisini al
    • mysql_db_query - Bir MySQL sorgusu gönderir
    • mysql_drop_db - Drop (delete) a MySQL database
    • mysql_errno - Returns the numerical value of the error message from previous MySQL operation
    • mysql_error - Returns the text of the error message from previous MySQL operation
    • mysql_escape_string - Escapes a string for use in a mysql_query
    • mysql_fetch_array - Fetch a result row as an associative array, a numeric array, or both
    • mysql_fetch_assoc - Fetch a result row as an associative array
    • mysql_fetch_field - Get column information from a result and return as an object
    • mysql_fetch_lengths - Bir sonuçtaki her bir çıktının uzunluğunu al
    • mysql_fetch_object - Fetch a result row as an object
    • mysql_fetch_row - Get a result row as an enumerated array
    • mysql_field_flags - Get the flags associated with the specified field in a result
    • mysql_field_len - Belirtilen alanın uzunluğunu döndürür
    • mysql_field_name - Get the name of the specified field in a result
    • mysql_field_seek - Sonuç göstericisini belirtilen alan konumuna ayarla
    • mysql_field_table - Belirtilen alanı içeren tablonun adını al
    • mysql_field_type - Get the type of the specified field in a result
    • mysql_free_result - Sonuç belleğini serbest bırakır
    • mysql_get_client_info - MySQL istemci sürüm bilgisini al
    • mysql_get_host_info - MySQL konak bilgisini al
    • mysql_get_proto_info - MySQL protokol sürüm bilgisini al
    • mysql_get_server_info - MySQL sunucu bilgisini al
    • mysql_info - En son sorgu hakkında bilgi al
    • mysql_insert_id - Get the ID generated in the last query
    • mysql_list_dbs - Bir MySQL sunucusundaki kullanılabilir veritabanlarını listeler
    • mysql_list_fields - MySQL tablosunun alanlarını listeler
    • mysql_list_processes - MySQL süreçlerini listeler
    • mysql_list_tables - Bir MySQL veritabanındaki tabloları listele
    • mysql_num_fields - Sonuçtaki alan sayısını al
    • mysql_num_rows - Sonuçtaki satır sayısını al
    • mysql_pconnect - Open a persistent connection to a MySQL server
    • mysql_ping - Bir sunucu bağlantısına ping at, bağlantı yoksa tekrar bağlan
    • mysql_query - Send a MySQL query
    • mysql_real_escape_string - Escapes special characters in a string for use in an SQL statement
    • mysql_result - Get result data
    • mysql_select_db - Bir MySQL veritabanı seçer
    • mysql_set_charset - Sets the client character set
    • mysql_stat - Geçerli sunucu durumunu döndürür
    • mysql_tablename - Alanın tablo adını al
    • mysql_thread_id - Geçerli evre numarasını döndür
    • mysql_unbuffered_query - Sonuç kümesi tamponlanmayan ve alınmayan bir SQL sorgusu gönderir
    • m_checkstatus - Check to see if a transaction has completed
    • m_completeauthorizations - Number of complete authorizations in queue, returning an array of their identifiers
    • m_connect - Establish the connection to MCVE
    • m_connectionerror - Get a textual representation of why a connection failed
    • m_deletetrans - Delete specified transaction from MCVE_CONN structure
    • m_destroyconn - Destroy the connection and MCVE_CONN structure
    • m_destroyengine - Free memory associated with IP/SSL connectivity
    • m_getcell - Get a specific cell from a comma delimited response by column name
    • m_getcellbynum - Get a specific cell from a comma delimited response by column number
    • m_getcommadelimited - Get the RAW comma delimited data returned from MCVE
    • m_getheader - Get the name of the column in a comma-delimited response
    • m_initconn - Create and initialize an MCVE_CONN structure
    • m_initengine - Ready the client for IP/SSL Communication
    • m_iscommadelimited - Checks to see if response is comma delimited
    • m_maxconntimeout - The maximum amount of time the API will attempt a connection to MCVE
    • m_monitor - Perform communication with MCVE (send/receive data) Non-blocking
    • m_numcolumns - Number of columns returned in a comma delimited response
    • m_numrows - Number of rows returned in a comma delimited response
    • m_parsecommadelimited - Parse the comma delimited response so m_getcell, etc will work
    • m_responsekeys - Returns array of strings which represents the keys that can be used for response parameters on this transaction
    • m_responseparam - Get a custom response parameter
    • m_returnstatus - Check to see if the transaction was successful
    • m_setblocking - Set blocking/non-blocking mode for connection
    • m_setdropfile - Set the connection method to Drop-File
    • m_setip - Set the connection method to IP
    • m_setssl - Set the connection method to SSL
    • m_setssl_cafile - Set SSL CA (Certificate Authority) file for verification of server certificate
    • m_setssl_files - Set certificate key files and certificates if server requires client certificate verification
    • m_settimeout - Set maximum transaction time (per trans)
    • m_sslcert_gen_hash - Generate hash for SSL client certificate verification
    • m_transactionssent - Check to see if outgoing buffer is clear
    • m_transinqueue - Number of transactions in client-queue
    • m_transkeyval - Add key/value pair to a transaction. Replaces deprecated transparam()
    • m_transnew - Start a new transaction
    • m_transsend - Finalize and send the transaction
    • m_uwait - Wait x microsecs
    • m_validateidentifier - Whether or not to validate the passed identifier on any transaction it is passed to
    • m_verifyconnection - Set whether or not to PING upon connect to verify connection
    • m_verifysslcert - Set whether or not to verify the server ssl certificate
  • n
    • natcasesort - Bir diziyi harf büyüklüğüne duyarsız "doğal sıralama" algoritmasıyla sıralar
    • natsort - Bir diziyi "doğal sıralama" algoritmasıyla sıralar
    • ncurses_addch - Add character at current position and advance cursor
    • ncurses_addchnstr - Add attributed string with specified length at current position
    • ncurses_addchstr - Add attributed string at current position
    • ncurses_addnstr - Add string with specified length at current position
    • ncurses_addstr - Output text at current position
    • ncurses_assume_default_colors - Define default colors for color 0
    • ncurses_attroff - Turn off the given attributes
    • ncurses_attron - Turn on the given attributes
    • ncurses_attrset - Set given attributes
    • ncurses_baudrate - Returns baudrate of terminal
    • ncurses_beep - Let the terminal beep
    • ncurses_bkgd - Set background property for terminal screen
    • ncurses_bkgdset - Control screen background
    • ncurses_border - Draw a border around the screen using attributed characters
    • ncurses_bottom_panel - Moves a visible panel to the bottom of the stack
    • ncurses_can_change_color - Checks if terminal color definitions can be changed
    • ncurses_cbreak - Switch off input buffering
    • ncurses_clear - Clear screen
    • ncurses_clrtobot - Clear screen from current position to bottom
    • ncurses_clrtoeol - Clear screen from current position to end of line
    • ncurses_color_content - Retrieves RGB components of a color
    • ncurses_color_set - Set active foreground and background colors
    • ncurses_curs_set - Set cursor state
    • ncurses_define_key - Define a keycode
    • ncurses_def_prog_mode - Saves terminals (program) mode
    • ncurses_def_shell_mode - Saves terminals (shell) mode
    • ncurses_delay_output - Delay output on terminal using padding characters
    • ncurses_delch - Delete character at current position, move rest of line left
    • ncurses_deleteln - Delete line at current position, move rest of screen up
    • ncurses_delwin - Delete a ncurses window
    • ncurses_del_panel - Remove panel from the stack and delete it (but not the associated window)
    • ncurses_doupdate - Write all prepared refreshes to terminal
    • ncurses_echo - Activate keyboard input echo
    • ncurses_echochar - Single character output including refresh
    • ncurses_end - Stop using ncurses, clean up the screen
    • ncurses_erase - Erase terminal screen
    • ncurses_erasechar - Returns current erase character
    • ncurses_filter - Set LINES for iniscr() and newterm() to 1
    • ncurses_flash - Flash terminal screen (visual bell)
    • ncurses_flushinp - Flush keyboard input buffer
    • ncurses_getch - Read a character from keyboard
    • ncurses_getmaxyx - Returns the size of a window
    • ncurses_getmouse - Reads mouse event
    • ncurses_getyx - Returns the current cursor position for a window
    • ncurses_halfdelay - Put terminal into halfdelay mode
    • ncurses_has_colors - Checks if terminal has color capabilities
    • ncurses_has_ic - Check for insert- and delete-capabilities
    • ncurses_has_il - Check for line insert- and delete-capabilities
    • ncurses_has_key - Check for presence of a function key on terminal keyboard
    • ncurses_hide_panel - Remove panel from the stack, making it invisible
    • ncurses_hline - Draw a horizontal line at current position using an attributed character and max. n characters long
    • ncurses_inch - Get character and attribute at current position
    • ncurses_init - Initialize ncurses
    • ncurses_init_color - Define a terminal color
    • ncurses_init_pair - Define a color pair
    • ncurses_insch - Insert character moving rest of line including character at current position
    • ncurses_insdelln - Insert lines before current line scrolling down (negative numbers delete and scroll up)
    • ncurses_insertln - Insert a line, move rest of screen down
    • ncurses_insstr - Insert string at current position, moving rest of line right
    • ncurses_instr - Reads string from terminal screen
    • ncurses_isendwin - Ncurses is in endwin mode, normal screen output may be performed
    • ncurses_keyok - Enable or disable a keycode
    • ncurses_keypad - Turns keypad on or off
    • ncurses_killchar - Returns current line kill character
    • ncurses_longname - Returns terminals description
    • ncurses_meta - Enables/Disable 8-bit meta key information
    • ncurses_mouseinterval - Set timeout for mouse button clicks
    • ncurses_mousemask - Sets mouse options
    • ncurses_mouse_trafo - Transforms coordinates
    • ncurses_move - Move output position
    • ncurses_move_panel - Moves a panel so that its upper-left corner is at [startx, starty]
    • ncurses_mvaddch - Move current position and add character
    • ncurses_mvaddchnstr - Move position and add attributed string with specified length
    • ncurses_mvaddchstr - Move position and add attributed string
    • ncurses_mvaddnstr - Move position and add string with specified length
    • ncurses_mvaddstr - Move position and add string
    • ncurses_mvcur - Move cursor immediately
    • ncurses_mvdelch - Move position and delete character, shift rest of line left
    • ncurses_mvgetch - Move position and get character at new position
    • ncurses_mvhline - Set new position and draw a horizontal line using an attributed character and max. n characters long
    • ncurses_mvinch - Move position and get attributed character at new position
    • ncurses_mvvline - Set new position and draw a vertical line using an attributed character and max. n characters long
    • ncurses_mvwaddstr - Add string at new position in window
    • ncurses_napms - Sleep
    • ncurses_newpad - Creates a new pad (window)
    • ncurses_newwin - Create a new window
    • ncurses_new_panel - Create a new panel and associate it with window
    • ncurses_nl - Translate newline and carriage return / line feed
    • ncurses_nocbreak - Switch terminal to cooked mode
    • ncurses_noecho - Switch off keyboard input echo
    • ncurses_nonl - Do not translate newline and carriage return / line feed
    • ncurses_noqiflush - Do not flush on signal characters
    • ncurses_noraw - Switch terminal out of raw mode
    • ncurses_pair_content - Retrieves foreground and background colors of a color pair
    • ncurses_panel_above - Returns the panel above panel
    • ncurses_panel_below - Returns the panel below panel
    • ncurses_panel_window - Returns the window associated with panel
    • ncurses_pnoutrefresh - Copies a region from a pad into the virtual screen
    • ncurses_prefresh - Copies a region from a pad into the virtual screen
    • ncurses_putp - Apply padding information to the string and output it
    • ncurses_qiflush - Flush on signal characters
    • ncurses_raw - Switch terminal into raw mode
    • ncurses_refresh - Refresh screen
    • ncurses_replace_panel - Replaces the window associated with panel
    • ncurses_resetty - Restores saved terminal state
    • ncurses_reset_prog_mode - Resets the prog mode saved by def_prog_mode
    • ncurses_reset_shell_mode - Resets the shell mode saved by def_shell_mode
    • ncurses_savetty - Saves terminal state
    • ncurses_scrl - Scroll window content up or down without changing current position
    • ncurses_scr_dump - Dump screen content to file
    • ncurses_scr_init - Initialize screen from file dump
    • ncurses_scr_restore - Restore screen from file dump
    • ncurses_scr_set - Inherit screen from file dump
    • ncurses_show_panel - Places an invisible panel on top of the stack, making it visible
    • ncurses_slk_attr - Returns current soft label key attribute
    • ncurses_slk_attroff - Turn off the given attributes for soft function-key labels
    • ncurses_slk_attron - Turn on the given attributes for soft function-key labels
    • ncurses_slk_attrset - Set given attributes for soft function-key labels
    • ncurses_slk_clear - Clears soft labels from screen
    • ncurses_slk_color - Sets color for soft label keys
    • ncurses_slk_init - Initializes soft label key functions
    • ncurses_slk_noutrefresh - Copies soft label keys to virtual screen
    • ncurses_slk_refresh - Copies soft label keys to screen
    • ncurses_slk_restore - Restores soft label keys
    • ncurses_slk_set - Sets function key labels
    • ncurses_slk_touch - Forces output when ncurses_slk_noutrefresh is performed
    • ncurses_standend - Stop using 'standout' attribute
    • ncurses_standout - Start using 'standout' attribute
    • ncurses_start_color - Initializes color functionality
    • ncurses_termattrs - Returns a logical OR of all attribute flags supported by terminal
    • ncurses_termname - Returns terminals (short)-name
    • ncurses_timeout - Set timeout for special key sequences
    • ncurses_top_panel - Moves a visible panel to the top of the stack
    • ncurses_typeahead - Specify different filedescriptor for typeahead checking
    • ncurses_ungetch - Put a character back into the input stream
    • ncurses_ungetmouse - Pushes mouse event to queue
    • ncurses_update_panels - Refreshes the virtual screen to reflect the relations between panels in the stack
    • ncurses_use_default_colors - Assign terminal default colors to color id -1
    • ncurses_use_env - Control use of environment information about terminal size
    • ncurses_use_extended_names - Control use of extended names in terminfo descriptions
    • ncurses_vidattr - Display the string on the terminal in the video attribute mode
    • ncurses_vline - Draw a vertical line at current position using an attributed character and max. n characters long
    • ncurses_waddch - Adds character at current position in a window and advance cursor
    • ncurses_waddstr - Outputs text at current postion in window
    • ncurses_wattroff - Turns off attributes for a window
    • ncurses_wattron - Turns on attributes for a window
    • ncurses_wattrset - Set the attributes for a window
    • ncurses_wborder - Draws a border around the window using attributed characters
    • ncurses_wclear - Clears window
    • ncurses_wcolor_set - Sets windows color pairings
    • ncurses_werase - Erase window contents
    • ncurses_wgetch - Reads a character from keyboard (window)
    • ncurses_whline - Draws a horizontal line in a window at current position using an attributed character and max. n characters long
    • ncurses_wmouse_trafo - Transforms window/stdscr coordinates
    • ncurses_wmove - Moves windows output position
    • ncurses_wnoutrefresh - Copies window to virtual screen
    • ncurses_wrefresh - Refresh window on terminal screen
    • ncurses_wstandend - End standout mode for a window
    • ncurses_wstandout - Enter standout mode for a window
    • ncurses_wvline - Draws a vertical line in a window at current position using an attributed character and max. n characters long
    • newt_bell - Send a beep to the terminal
    • newt_button - Create a new button
    • newt_button_bar - This function returns a grid containing the buttons created.
    • newt_centered_window - Open a centered window of the specified size
    • newt_checkbox - Açıklama
    • newt_checkbox_get_value - Retreives value of checkox resource
    • newt_checkbox_set_flags - Configures checkbox resource
    • newt_checkbox_set_value - Sets the value of the checkbox
    • newt_checkbox_tree - Açıklama
    • newt_checkbox_tree_add_item - Adds new item to the checkbox tree
    • newt_checkbox_tree_find_item - Finds an item in the checkbox tree
    • newt_checkbox_tree_get_current - Returns checkbox tree selected item
    • newt_checkbox_tree_get_entry_value - Açıklama
    • newt_checkbox_tree_get_multi_selection - Açıklama
    • newt_checkbox_tree_get_selection - Açıklama
    • newt_checkbox_tree_multi - Açıklama
    • newt_checkbox_tree_set_current - Açıklama
    • newt_checkbox_tree_set_entry - Açıklama
    • newt_checkbox_tree_set_entry_value - Açıklama
    • newt_checkbox_tree_set_width - Açıklama
    • newt_clear_key_buffer - Discards the contents of the terminal's input buffer without waiting for additional input
    • newt_cls - Açıklama
    • newt_compact_button - Açıklama
    • newt_component_add_callback - Açıklama
    • newt_component_takes_focus - Açıklama
    • newt_create_grid - Açıklama
    • newt_cursor_off - Açıklama
    • newt_cursor_on - Açıklama
    • newt_delay - Açıklama
    • newt_draw_form - Açıklama
    • newt_draw_root_text - Displays the string text at the position indicated
    • newt_entry - Açıklama
    • newt_entry_get_value - Açıklama
    • newt_entry_set - Açıklama
    • newt_entry_set_filter - Açıklama
    • newt_entry_set_flags - Açıklama
    • newt_finished - Uninitializes newt interface
    • newt_form - Create a form
    • newt_form_add_component - Adds a single component to the form
    • newt_form_add_components - Add several components to the form
    • newt_form_add_hot_key - Açıklama
    • newt_form_destroy - Destroys a form
    • newt_form_get_current - Açıklama
    • newt_form_run - Runs a form
    • newt_form_set_background - Açıklama
    • newt_form_set_height - Açıklama
    • newt_form_set_size - Açıklama
    • newt_form_set_timer - Açıklama
    • newt_form_set_width - Açıklama
    • newt_form_watch_fd - Açıklama
    • newt_get_screen_size - Fills in the passed references with the current size of the terminal
    • newt_grid_add_components_to_form - Açıklama
    • newt_grid_basic_window - Açıklama
    • newt_grid_free - Açıklama
    • newt_grid_get_size - Açıklama
    • newt_grid_h_close_stacked - Açıklama
    • newt_grid_h_stacked - Açıklama
    • newt_grid_place - Açıklama
    • newt_grid_set_field - Açıklama
    • newt_grid_simple_window - Açıklama
    • newt_grid_v_close_stacked - Açıklama
    • newt_grid_v_stacked - Açıklama
    • newt_grid_wrapped_window - Açıklama
    • newt_grid_wrapped_window_at - Açıklama
    • newt_init - Initialize newt
    • newt_label - Açıklama
    • newt_label_set_text - Açıklama
    • newt_listbox - Açıklama
    • newt_listbox_append_entry - Açıklama
    • newt_listbox_clear - Açıklama
    • newt_listbox_clear_selection - Açıklama
    • newt_listbox_delete_entry - Açıklama
    • newt_listbox_get_current - Açıklama
    • newt_listbox_get_selection - Açıklama
    • newt_listbox_insert_entry - Açıklama
    • newt_listbox_item_count - Açıklama
    • newt_listbox_select_item - Açıklama
    • newt_listbox_set_current - Açıklama
    • newt_listbox_set_current_by_key - Açıklama
    • newt_listbox_set_data - Açıklama
    • newt_listbox_set_entry - Açıklama
    • newt_listbox_set_width - Açıklama
    • newt_listitem - Açıklama
    • newt_listitem_get_data - Açıklama
    • newt_listitem_set - Açıklama
    • newt_open_window - Open a window of the specified size and position
    • newt_pop_help_line - Replaces the current help line with the one from the stack
    • newt_pop_window - Removes the top window from the display
    • newt_push_help_line - Saves the current help line on a stack, and displays the new line
    • newt_radiobutton - Açıklama
    • newt_radio_get_current - Açıklama
    • newt_redraw_help_line - Açıklama
    • newt_reflow_text - Açıklama
    • newt_refresh - Updates modified portions of the screen
    • newt_resize_screen - Açıklama
    • newt_resume - Resume using the newt interface after calling newt_suspend
    • newt_run_form - Runs a form
    • newt_scale - Açıklama
    • newt_scale_set - Açıklama
    • newt_scrollbar_set - Açıklama
    • newt_set_help_callback - Açıklama
    • newt_set_suspend_callback - Set a callback function which gets invoked when user presses the suspend key
    • newt_suspend - Tells newt to return the terminal to its initial state
    • newt_textbox - Açıklama
    • newt_textbox_get_num_lines - Açıklama
    • newt_textbox_reflowed - Açıklama
    • newt_textbox_set_height - Açıklama
    • newt_textbox_set_text - Açıklama
    • newt_vertical_scrollbar - Açıklama
    • newt_wait_for_key - Doesn't return until a key has been pressed
    • newt_win_choice - Açıklama
    • newt_win_entries - Açıklama
    • newt_win_menu - Açıklama
    • newt_win_message - Açıklama
    • newt_win_messagev - Açıklama
    • newt_win_ternary - Açıklama
    • next - Dahili dizi göstericisini bir ilerletir
    • ngettext - gettext işlevinin çoğul biçemli sürümü
    • nl2br - Dizgedeki tüm satırsonlarının yerine HTML satır katlayıcıları yerleştirilir
    • nl_langinfo - Dili ve yerel bilgisini sorgular
    • NoRewindIterator::current - Get the current value
    • NoRewindIterator::getInnerIterator - Get the inner iterator
    • NoRewindIterator::key - Get the current key
    • NoRewindIterator::next - Forward to the next element
    • NoRewindIterator::rewind - Prevents the rewind operation on the inner iterator.
    • NoRewindIterator::valid - Validates the iterator
    • NoRewindIterator::__construct - Construct a NoRewindIterator
    • Normalizer::isNormalized - Belirtilen dizge normalleştirilmiş mi diye bakar
    • Normalizer::normalize - Belirtilen girdiyi normalleştirir ve dizge olarak döndürür
    • nsapi_request_headers - Fetch all HTTP request headers
    • nsapi_response_headers - Fetch all HTTP response headers
    • nsapi_virtual - Perform an NSAPI sub-request
    • NumberFormatter::create - Bir sayı biçemleyici oluşturur
    • NumberFormatter::format - Bir sayıyı biçemler
    • NumberFormatter::formatCurrency - Bir para değerini biçemler
    • NumberFormatter::getAttribute - Bir sayısal öznitelikle döner
    • NumberFormatter::getErrorCode - Biçemleyicinin son hata numarası ile döner
    • NumberFormatter::getErrorMessage - Biçemleyicinin son hata iletisini döndürür
    • NumberFormatter::getLocale - Biçemleyici yerelin ismi ile döner
    • NumberFormatter::getPattern - biçemleyici tarafından kullanılan kalıp dizgesi ile döner
    • NumberFormatter::getSymbol - Simge değeri ile döner
    • NumberFormatter::getTextAttribute - Bir metin öznitelik ile döner
    • NumberFormatter::parse - Bir sayı dizgesini sayıya dönüştürür
    • NumberFormatter::parseCurrency - Bir para gösteriminin sayısal değeri ile döner
    • NumberFormatter::setAttribute - Bir öznitelik tanımlar
    • NumberFormatter::setPattern - Biçemleyici kalıbı tanımlar
    • NumberFormatter::setSymbol - Bir simge değeri tanımlar
    • NumberFormatter::setTextAttribute - Bir metin öznitelik tanımlar
    • number_format - Sayıyı binlik bölümlere ayırır
  • o
    • OAuth::disableDebug - Turn off verbose debugging
    • OAuth::disableRedirects - Turn off redirects
    • OAuth::disableSSLChecks - Turn off SSL checks
    • OAuth::enableDebug - Turn on verbose debugging
    • OAuth::enableRedirects - Turn on redirects
    • OAuth::enableSSLChecks - Turn on SSL checks
    • OAuth::fetch - Fetch an OAuth protected resource
    • OAuth::generateSignature - Generate a signature
    • OAuth::getAccessToken - Fetch an access token
    • OAuth::getCAPath - Gets CA information
    • OAuth::getLastResponse - Get the last response
    • OAuth::getLastResponseHeaders - Get headers for last response
    • OAuth::getLastResponseInfo - Get HTTP information about the last response
    • OAuth::getRequestHeader - Generate OAuth header string signature
    • OAuth::getRequestToken - Fetch a request token
    • OAuth::setAuthType - Set authorization type
    • OAuth::setCAPath - Set CA path and info
    • OAuth::setNonce - Set the nonce for subsequent requests
    • OAuth::setRequestEngine - The setRequestEngine purpose
    • OAuth::setRSACertificate - Set the RSA certificate
    • OAuth::setSSLChecks - Tweak specific SSL checks for requests.
    • OAuth::setTimestamp - Set the timestamp
    • OAuth::setToken - Sets the token and secret
    • OAuth::setVersion - Set the OAuth version
    • OAuth::__construct - Create a new OAuth object
    • OAuth::__destruct - The destructor
    • OAuthProvider::addRequiredParameter - Add required parameters
    • OAuthProvider::callconsumerHandler - Calls the consumerNonceHandler callback
    • OAuthProvider::callTimestampNonceHandler - Calls the timestampNonceHandler callback
    • OAuthProvider::calltokenHandler - Calls the tokenNonceHandler callback
    • OAuthProvider::checkOAuthRequest - Check an oauth request
    • OAuthProvider::consumerHandler - Set the consumerHandler handler callback
    • OAuthProvider::generateToken - Generate a random token
    • OAuthProvider::is2LeggedEndpoint - is2LeggedEndpoint
    • OAuthProvider::isRequestTokenEndpoint - Sets isRequestTokenEndpoint
    • OAuthProvider::removeRequiredParameter - Remove a required parameter
    • OAuthProvider::reportProblem - Report a problem
    • OAuthProvider::setParam - Set a parameter
    • OAuthProvider::setRequestTokenPath - Set request token path
    • OAuthProvider::timestampNonceHandler - Set the timestampNonceHandler handler callback
    • OAuthProvider::tokenHandler - Set the tokenHandler handler callback
    • OAuthProvider::__construct - Constructs a new OAuthProvider object
    • oauth_get_sbs - Generate a Signature Base String
    • oauth_urlencode - Encode a URI to RFC 3986
    • ob_clean - Çıktı tamponunu temizler (siler)
    • ob_end_clean - Çıktı tamponunu temizler (siler) ve tamponu kapatır
    • ob_end_flush - Çıktı tamponunu boşaltır (gönderir) ve tamponu kapatır
    • ob_flush - Çıktı tamponunu boşaltır (gönderir)
    • ob_get_clean - Geçerli çıktı tamponun içeriğini döndürüp tamponu siler
    • ob_get_contents - Çıktı tamponunun içeriği ile döner
    • ob_get_flush - Çıktı tamponunu boşaltır, içeriğini bir dizge olarak döndürür ve çıktı tamponlamasını kapatır
    • ob_get_length - Çıktı tamponunundaki içeriğin uzunluğunu döndürür
    • ob_get_level - Çıktı tamponlama mekanizmasının iç içelik seviyesini döndürür
    • ob_get_status - Çıktı tamponlarının durumu ile döner
    • ob_gzhandler - Çıktı tamponunu gziplemek için ob_start geriçağırım işlevi
    • ob_iconv_handler - Çıktı tamponu eylemcisi olarak karakter kodlaması dönüşümü yapar
    • ob_implicit_flush - Örtük boşaltmayı açar/kapar
    • ob_list_handlers - Kullanımdaki çıktı eylemcileri listeler
    • ob_start - Çıktı tamponlamasını başlatır
    • ob_tidyhandler - Tampon onarımı için ob_start geriçağırım işlevi
    • OCI-Collection::append - Appends element to the collection
    • OCI-Collection::assign - Assigns a value to the collection from another existing collection
    • OCI-Collection::assignElem - Assigns a value to the element of the collection
    • OCI-Collection::free - Frees the resources associated with the collection object
    • OCI-Collection::getElem - Returns value of the element
    • OCI-Collection::max - Returns the maximum number of elements in the collection
    • OCI-Collection::size - Returns size of the collection
    • OCI-Collection::trim - Trims elements from the end of the collection
    • OCI-Lob::append - Appends data from the large object to another large object
    • OCI-Lob::close - Closes LOB descriptor
    • OCI-Lob::eof - Tests for end-of-file on a large object's descriptor
    • OCI-Lob::erase - Erases a specified portion of the internal LOB data
    • OCI-Lob::export - Exports LOB's contents to a file
    • OCI-Lob::flush - Flushes/writes buffer of the LOB to the server
    • OCI-Lob::free - Frees resources associated with the LOB descriptor
    • OCI-Lob::getBuffering - Returns current state of buffering for the large object
    • OCI-Lob::import - Imports file data to the LOB
    • OCI-Lob::load - Returns large object's contents
    • OCI-Lob::read - Reads part of the large object
    • OCI-Lob::rewind - Moves the internal pointer to the beginning of the large object
    • OCI-Lob::save - Saves data to the large object
    • OCI-Lob::saveFile - Takma Adı: OCI-Lob::import
    • OCI-Lob::seek - Sets the internal pointer of the large object
    • OCI-Lob::setBuffering - Changes current state of buffering for the large object
    • OCI-Lob::size - Returns size of large object
    • OCI-Lob::tell - Returns the current position of internal pointer of large object
    • OCI-Lob::truncate - Truncates large object
    • OCI-Lob::write - Writes data to the large object
    • OCI-Lob::writeTemporary - Writes a temporary large object
    • OCI-Lob::writeToFile - Takma Adı: OCI-Lob::export
    • ocibindbyname - Takma Adı: oci_bind_by_name
    • ocicancel - Takma Adı: oci_cancel
    • ocicloselob - Takma Adı: OCI-Lob::close
    • ocicollappend - Takma Adı: OCI-Collection::append
    • ocicollassign - Takma Adı: OCI-Collection::assign
    • ocicollassignelem - Takma Adı: OCI-Collection::assignElem
    • ocicollgetelem - Takma Adı: OCI-Collection::getElem
    • ocicollmax - Takma Adı: OCI-Collection::max
    • ocicollsize - Takma Adı: OCI-Collection::size
    • ocicolltrim - Takma Adı: OCI-Collection::trim
    • ocicolumnisnull - Takma Adı: oci_field_is_null
    • ocicolumnname - Takma Adı: oci_field_name
    • ocicolumnprecision - Takma Adı: oci_field_precision
    • ocicolumnscale - Takma Adı: oci_field_scale
    • ocicolumnsize - Takma Adı: oci_field_size
    • ocicolumntype - Takma Adı: oci_field_type
    • ocicolumntyperaw - Takma Adı: oci_field_type_raw
    • ocicommit - Takma Adı: oci_commit
    • ocidefinebyname - Takma Adı: oci_define_by_name
    • ocierror - Takma Adı: oci_error
    • ociexecute - Takma Adı: oci_execute
    • ocifetch - Takma Adı: oci_fetch
    • ocifetchinto - Obsolete variant of oci_fetch_array, oci_fetch_object, oci_fetch_assoc and oci_fetch_row
    • ocifetchstatement - Takma Adı: oci_fetch_all
    • ocifreecollection - Takma Adı: OCI-Collection::free
    • ocifreecursor - Takma Adı: oci_free_statement
    • ocifreedesc - Takma Adı: OCI-Lob::free
    • ocifreestatement - Takma Adı: oci_free_statement
    • ociinternaldebug - Takma Adı: oci_internal_debug
    • ociloadlob - Takma Adı: OCI-Lob::load
    • ocilogoff - Takma Adı: oci_close
    • ocilogon - Takma Adı: oci_connect
    • ocinewcollection - Takma Adı: oci_new_collection
    • ocinewcursor - Takma Adı: oci_new_cursor
    • ocinewdescriptor - Takma Adı: oci_new_descriptor
    • ocinlogon - Takma Adı: oci_new_connect
    • ocinumcols - Takma Adı: oci_num_fields
    • ociparse - Takma Adı: oci_parse
    • ociplogon - Takma Adı: oci_pconnect
    • ociresult - Takma Adı: oci_result
    • ocirollback - Takma Adı: oci_rollback
    • ocirowcount - Takma Adı: oci_num_rows
    • ocisavelob - Takma Adı: OCI-Lob::save
    • ocisavelobfile - Takma Adı: OCI-Lob::import
    • ociserverversion - Takma Adı: oci_server_version
    • ocisetprefetch - Takma Adı: oci_set_prefetch
    • ocistatementtype - Takma Adı: oci_statement_type
    • ociwritelobtofile - Takma Adı: OCI-Lob::export
    • ociwritetemporarylob - Takma Adı: OCI-Lob::writeTemporary
    • oci_bind_array_by_name - Binds a PHP array to an Oracle PL/SQL array parameter
    • oci_bind_by_name - Binds a PHP variable to an Oracle placeholder
    • oci_cancel - Cancels reading from cursor
    • oci_client_version - Returns the Oracle client library version
    • oci_close - Closes an Oracle connection
    • oci_commit - Commits the outstanding database transaction
    • oci_connect - Connect to an Oracle database
    • oci_define_by_name - Associates a PHP variable with a column for query fetches
    • oci_error - Returns the last error found
    • oci_execute - Executes a statement
    • oci_fetch - Fetches the next row from a query into internal buffers
    • oci_fetch_all - Fetches multiple rows from a query into a two-dimensional array
    • oci_fetch_array - Returns the next row from a query as an associative or numeric array
    • oci_fetch_assoc - Returns the next row from a query as an associative array
    • oci_fetch_object - Returns the next row from a query as an object
    • oci_fetch_row - Returns the next row from a query as a numeric array
    • oci_field_is_null - Checks if a field in the currently fetched row is NULL
    • oci_field_name - Returns the name of a field from the statement
    • oci_field_precision - Tell the precision of a field
    • oci_field_scale - Tell the scale of the field
    • oci_field_size - Returns field's size
    • oci_field_type - Returns a field's data type name
    • oci_field_type_raw - Tell the raw Oracle data type of the field
    • oci_free_descriptor - Frees a descriptor
    • oci_free_statement - Frees all resources associated with statement or cursor
    • oci_get_implicit_resultset - Returns the next child statement resource from a parent statement resource that has Oracle Database 12c Implicit Result Sets
    • oci_internal_debug - Enables or disables internal debug output
    • oci_lob_copy - Copies large object
    • oci_lob_is_equal - Compares two LOB/FILE locators for equality
    • oci_new_collection - Allocates new collection object
    • oci_new_connect - Connect to the Oracle server using a unique connection
    • oci_new_cursor - Allocates and returns a new cursor (statement handle)
    • oci_new_descriptor - Initializes a new empty LOB or FILE descriptor
    • oci_num_fields - Returns the number of result columns in a statement
    • oci_num_rows - Returns number of rows affected during statement execution
    • oci_parse - Prepares an Oracle statement for execution
    • oci_password_change - Changes password of Oracle's user
    • oci_pconnect - Connect to an Oracle database using a persistent connection
    • oci_result - Returns field's value from the fetched row
    • oci_rollback - Rolls back the outstanding database transaction
    • oci_server_version - Returns the Oracle Database version
    • oci_set_action - Sets the action name
    • oci_set_client_identifier - Sets the client identifier
    • oci_set_client_info - Sets the client information
    • oci_set_edition - Sets the database edition
    • oci_set_module_name - Sets the module name
    • oci_set_prefetch - Sets number of rows to be prefetched by queries
    • oci_statement_type - Returns the type of a statement
    • octdec - Octal to decimal
    • odbc_alan_adı - Sütun ismini döndürür
    • odbc_autocommit - Özdevinimli teslimat davranışını açıp kapar
    • odbc_binmode - İkil sütun verileri ile çalışmayı etkin kılar
    • odbc_close - Bir ODBC bağlantısını kapatır
    • odbc_close_all - Tüm ODBC bağlantılarını kapatır
    • odbc_columnprivileges - Belirtilen tablo ile ilgili izinleri ve sütunları listeler
    • odbc_columns - Belirtilen tablolardaki sütun isimlerini listeler
    • odbc_commit - Bir ODBC hareket listesi gönderir
    • odbc_connect - Bir veri kaynağına bağlanır
    • odbc_cursor - İmleç ismini döndürür
    • odbc_data_source - Belirtilen bağlantı hakkında bilgi döndürür
    • odbc_do - odbc_exec işlevinin takma adıdır
    • odbc_error - Son hata kodunu döndürür
    • odbc_errormsg - Son hata iletisini döndürür
    • odbc_exec - Bir SQL deyimini hazırlar veya çalıştırır
    • odbc_execute - Bir hazır deyimi çalıştırır
    • odbc_fetch_array - Sonuç satırını bir ilişkisel dizi olarak döndürür
    • odbc_fetch_into - Sonuç satırını bir dizi olarak döndürür
    • odbc_fetch_object - Sonuç satırını bir nesne olarak döndürür
    • odbc_fetch_row - Bir satır döndürür
    • odbc_field_len - Bir alanın uzunluğunu (hassasiyetini) döndürür
    • odbc_field_num - Sütun numarasını döndürür
    • odbc_field_precision - odbc_field_len işlevinin takma adıdır
    • odbc_field_scale - Bir alanın skalasını döndürür
    • odbc_field_type - Bir alanın veri türünü döndürür
    • odbc_foreignkeys - Bir tablonun yabancı anahtarlarını listeler
    • odbc_free_result - Bir sonuç ile ilgili özkaynakları serbest bırakır
    • odbc_gettypeinfo - Veri kaynağınca desteklenen veri türleri hakkında bilgi döndürür
    • odbc_longreadlen - LONG sütunlarla çalışmayı etkin kılar
    • odbc_next_result - Kullanılabilecek çok sayıda sonuç var mı diye bakar
    • odbc_num_fields - Bir sonuçtaki sütun sayısını döndürür
    • odbc_num_rows - Bir sonuçtaki satır sayısını döndürür
    • odbc_pconnect - Bir kalıcı veritabanı bağlantısı açar
    • odbc_prepare - Çalıştırılmak üzere bir deyim hazırlar
    • odbc_primarykeys - Bir tablonun birincil anahtarlarını döndürür
    • odbc_procedurecolumns - Yordamların değiştirgeleri hakkında bilgi döndürür
    • odbc_procedures - Belirtilen veri kaynağında saklı yordamların listesini döndürür
    • odbc_result - Sonuçtan veri döndürür
    • odbc_result_all - Sonucu bir HTML tablosu olarak basar
    • odbc_rollback - Bir hareketi başa döndürür
    • odbc_setoption - ODBC ayarlarını yapar
    • odbc_specialcolumns - Özel sütunları döndürür
    • odbc_statistics - Bir tablo hakkındaki istatistikleri döndürür
    • odbc_tableprivileges - Tabloları izinleriyle birlikte listeler
    • odbc_tables - Belli bir veri kaynağında bulunan tablo isimlerini döndürür
    • ogg:// - Audio streams
    • opcache_compile_file - Compiles and caches a PHP script without executing it
    • opcache_get_configuration - Get configuration information about the cache
    • opcache_get_status - Get status information about the cache
    • opcache_invalidate - Invalidates a cached script
    • opcache_is_script_cached - Tells whether a script is cached in OPCache
    • opcache_reset - Resets the contents of the opcode cache
    • openal_buffer_create - Generate OpenAL buffer
    • openal_buffer_data - Load a buffer with data
    • openal_buffer_destroy - Destroys an OpenAL buffer
    • openal_buffer_get - Retrieve an OpenAL buffer property
    • openal_buffer_loadwav - Load a .wav file into a buffer
    • openal_context_create - Create an audio processing context
    • openal_context_current - Make the specified context current
    • openal_context_destroy - Destroys a context
    • openal_context_process - Process the specified context
    • openal_context_suspend - Suspend the specified context
    • openal_device_close - Close an OpenAL device
    • openal_device_open - Initialize the OpenAL audio layer
    • openal_listener_get - Retrieve a listener property
    • openal_listener_set - Set a listener property
    • openal_source_create - Generate a source resource
    • openal_source_destroy - Destroy a source resource
    • openal_source_get - Retrieve an OpenAL source property
    • openal_source_pause - Pause the source
    • openal_source_play - Start playing the source
    • openal_source_rewind - Rewind the source
    • openal_source_set - Set source property
    • openal_source_stop - Stop playing the source
    • openal_stream - Begin streaming on a source
    • opendir - Belirtilen dizin için bir tanıtıcı döndürür
    • openlog - Sistem günlükçüsüne erişim için bağlantı açar
    • openssl_cipher_iv_length - Gets the cipher iv length
    • openssl_csr_export - Belirtilen CSR'yi bir dizge olarak döndürür
    • openssl_csr_export_to_file - Belirtilen CSR'yi bir dosyaya kaydeder
    • openssl_csr_get_public_key - Belirtilen sertifikanın genel anahtarını döndürür
    • openssl_csr_get_subject - Bir sertifika konusu döndürür
    • openssl_csr_new - Bir sertifika imzalama isteği (CSR) üretir
    • openssl_csr_sign - Bir CSR'yi başka bir sertifika (veya kendisi) ile imzalayıp bir sertifika üretir
    • openssl_decrypt - Verinin şifresini çözer
    • openssl_dh_compute_key - Uzak ve yerel özet hesaplama anahtarları için paylaşımlı anahtarı hesaplar
    • openssl_digest - Bir özet hesaplar
    • openssl_encrypt - Veriyi şifreler
    • openssl_error_string - OpenSSL hata iletisini döndürür
    • openssl_free_key - Anahtar özkaynağını serbest bırakır
    • openssl_get_cert_locations - Retrieve the available certificate locations
    • openssl_get_cipher_methods - Kullanılabilecek şifreleme yöntemlerini döndürür
    • openssl_get_md_methods - Kullanılabilecek özet yöntemlerini döndürür
    • openssl_get_privatekey - openssl_pkey_get_private işlevinin takma adıdır
    • openssl_get_publickey - openssl_pkey_get_public işlevinin takma adıdır
    • openssl_open - Mühürlü veriyi açar
    • openssl_pbkdf2 - Generates a PKCS5 v2 PBKDF2 string, defaults to SHA-1
    • openssl_pkcs7_decrypt - S/MIME şifreli bir iletinin şifresini çözer
    • openssl_pkcs7_encrypt - Bir S/MIME iletiyi şifreler
    • openssl_pkcs7_sign - Bir S/MIME iletiyi imzalar
    • openssl_pkcs7_verify - S/MIME imzalı bir iletinin imzasını doğrular
    • openssl_pkcs12_export - PKCS#12 uyumlu sertifika deposu dosyasını bir değişkene yerleştirir
    • openssl_pkcs12_export_to_file - Bir PKCS#12 uyumlu sertifika deposunu bir dosyaya kaydeder
    • openssl_pkcs12_read - Bir PKCS#12 Sertifika Deposunu bir diziye çözümler
    • openssl_pkey_export - Bir anahtarın ihraç edilebilir gösterimini bir dizge olarak döndürür
    • openssl_pkey_export_to_file - Bir anahtarın ihraç edilebilir gösterimini bir dosyaya kaydeder
    • openssl_pkey_free - Bir gizli anahtarı serbest bırakır
    • openssl_pkey_get_details - Anahtarla ilgili ayrıntıları bir dizi içinde döndürür
    • openssl_pkey_get_private - Bir gizli anahtar döndürür
    • openssl_pkey_get_public - Genel anahtarı sertifikadan elde edip kullanıma hazırlar
    • openssl_pkey_new - Yeni bir anahtar çifti üretir
    • openssl_private_decrypt - Genel anahtarla şifrelenmiş verinin şifresini gizli anahtarla çözer
    • openssl_private_encrypt - Veriyi gizli anahtarla şifreler
    • openssl_public_decrypt - Gizli anahtarla şifrelenmiş verinin şifresini genel anahtarla çözer
    • openssl_public_encrypt - Veriyi genel anahtarla şifreler
    • openssl_random_pseudo_bytes - Yarı-rasgele dizge üretir
    • openssl_seal - Veriyi mühürler
    • openssl_sign - İmza üretir
    • openssl_spki_export - Exports a valid PEM formatted public key signed public key and challenge
    • openssl_spki_export_challenge - Exports the challenge assoicated with a signed public key and challenge
    • openssl_spki_new - Generate a new signed public key and challenge
    • openssl_spki_verify - Verifies a signed public key and challenge
    • openssl_verify - İmzayı doğrular
    • openssl_x509_checkpurpose - Sertifikanın belli bir amaçla kulanılıp kullanılmayacağına bakar
    • openssl_x509_check_private_key - Bir gizli anahtarın bir sertifikaya karşılık olup olmadığına bakar
    • openssl_x509_export - Belirtilen sertifikayı bir dizge olarak döndürür
    • openssl_x509_export_to_file - Belirtilen sertifikayı bir dosyaya kaydeder
    • openssl_x509_fingerprint - Calculates the fingerprint, or digest, of a given X.509 certificate
    • openssl_x509_free - Sertifika özkaynağını serbest bırakır
    • openssl_x509_parse - Bir X509 sertifikasını çözümleyip bilgileri bir dizi içinde döndürür
    • openssl_x509_read - Bir X.509 sertifikasını çözümleyip sertifika için bir tanıtıcı döndürür
    • ord - Karakterin ASCII değerini döndürür
    • OuterIterator::getInnerIterator - Returns the inner iterator for the current entry.
    • output_add_rewrite_var - URL yeniden yazım değerlerini ekler
    • output_reset_rewrite_vars - URL yeniden yazma değerlerini sıfırlar
    • override_function - Yerleşik işlevleri geçersiz kılar
  • p
    • pack - Veriyi bir ikil dizge halinde paketler
    • ParentIterator::accept - Determines acceptability
    • ParentIterator::getChildren - Return the inner iterator's children contained in a ParentIterator
    • ParentIterator::hasChildren - Check whether the inner iterator's current element has children
    • ParentIterator::next - Move the iterator forward
    • ParentIterator::rewind - Rewind the iterator
    • ParentIterator::__construct - Constructs a ParentIterator
    • parsekit_compile_file - Compile a PHP file and return the resulting op array
    • parsekit_compile_string - Compile a string of PHP code and return the resulting op array
    • parsekit_func_arginfo - Return information regarding function argument(s)
    • parse_ini_file - Bir yapılandırma dosyasını çözümler
    • parse_ini_string - Bir yapılandırma dizgesini çözümler
    • parse_str - Dizge içindeki değişkenleri çözümler
    • parse_url - Bir URL'yi bileşenlerine ayırır
    • passthru - Harici bir programı çalıştırır ve çıktısını ham olarak gösterir
    • password_get_info - Returns information about the given hash
    • password_hash - Creates a password hash
    • password_needs_rehash - Checks if the given hash matches the given options
    • password_verify - Verifies that a password matches a hash
    • pathinfo - Bir dosya yolu hakkında bilgi döndürür
    • pclose - Bir süreç tanıtıcısını kapatır
    • pcntl_alarm - Belli bir süre sonra SIGALRM sinyali gönderir
    • pcntl_errno - Takma Adı: pcntl_get_last_error
    • pcntl_exec - Belirtilen programı geçerli süreç ortamında çalıştırır
    • pcntl_fork - Çalışan süreci çatallar
    • pcntl_getpriority - Bir sürecin önceliğini döndürür
    • pcntl_get_last_error - Retrieve the error number set by the last pcntl function which failed
    • pcntl_setpriority - Sürecin önceliğini değiştirir
    • pcntl_signal - Bir sinyal eylemci belirtir
    • pcntl_signal_dispatch - Askıdaki sinyaller için sinyal eylemciyi çağırır
    • pcntl_signal_get_handler - Get the current handler for specified signal
    • pcntl_sigprocmask - Sinyalleri ekler, siler veya engeller
    • pcntl_sigtimedwait - Sinyalleri zaman aşımı dolana kadar bekler
    • pcntl_sigwaitinfo - Belirtilen sinyalleri bekler
    • pcntl_strerror - Retrieve the system error message associated with the given errno
    • pcntl_wait - Çatallanmış bir çocuğun durum kodu için bekler
    • pcntl_waitpid - Bir çocuk sürecin çıkmasını bekler ve durum kodunu döndürür
    • pcntl_wexitstatus - Sonlanmış çocuk sürecin dönüş kodunu döndürür
    • pcntl_wifexited - Durum kodunun normal bir çıkışı mı işaret ettiğine bakar
    • pcntl_wifsignaled - Durum kodunun bir sinyal sebebiyle bir sonlanmayı mı işaret ettiğine bakar
    • pcntl_wifstopped - Çocuk sürecin durmuş olup olmadığına bakar
    • pcntl_wstopsig - Çocuk sürecin durmasına sebep olan sinyali döndürür
    • pcntl_wtermsig - Çocuk sürecin sonlanmasına sebep olan sinyali döndürür
    • PDF_activate_item - Activate structure element or other content item
    • PDF_add_annotation - Add annotation [deprecated]
    • PDF_add_bookmark - Add bookmark for current page [deprecated]
    • PDF_add_launchlink - Add launch annotation for current page [deprecated]
    • PDF_add_locallink - Add link annotation for current page [deprecated]
    • PDF_add_nameddest - Create named destination
    • PDF_add_note - Set annotation for current page [deprecated]
    • PDF_add_outline - Add bookmark for current page [deprecated]
    • PDF_add_pdflink - Add file link annotation for current page [deprecated]
    • PDF_add_table_cell - Add a cell to a new or existing table
    • PDF_add_textflow - Create Textflow or add text to existing Textflow
    • PDF_add_thumbnail - Add thumbnail for current page
    • PDF_add_weblink - Add weblink for current page [deprecated]
    • PDF_arc - Draw a counterclockwise circular arc segment
    • PDF_arcn - Draw a clockwise circular arc segment
    • PDF_attach_file - Add file attachment for current page [deprecated]
    • PDF_begin_document - Create new PDF file
    • PDF_begin_font - Start a Type 3 font definition
    • PDF_begin_glyph - Start glyph definition for Type 3 font
    • PDF_begin_item - Open structure element or other content item
    • PDF_begin_layer - Start layer
    • PDF_begin_page - Start new page [deprecated]
    • PDF_begin_page_ext - Start new page
    • PDF_begin_pattern - Start pattern definition
    • PDF_begin_template - Start template definition [deprecated]
    • PDF_begin_template_ext - Start template definition
    • PDF_circle - Draw a circle
    • PDF_clip - Clip to current path
    • PDF_close - Close pdf resource [deprecated]
    • PDF_closepath - Close current path
    • PDF_closepath_fill_stroke - Close, fill and stroke current path
    • PDF_closepath_stroke - Close and stroke path
    • PDF_close_image - Close image
    • PDF_close_pdi - Close the input PDF document [deprecated]
    • PDF_close_pdi_page - Close the page handle
    • PDF_concat - Concatenate a matrix to the CTM
    • PDF_continue_text - Output text in next line
    • PDF_create_3dview - Create 3D view
    • PDF_create_action - Create action for objects or events
    • PDF_create_annotation - Create rectangular annotation
    • PDF_create_bookmark - Create bookmark
    • PDF_create_field - Create form field
    • PDF_create_fieldgroup - Create form field group
    • PDF_create_gstate - Create graphics state object
    • PDF_create_pvf - Create PDFlib virtual file
    • PDF_create_textflow - Create textflow object
    • PDF_curveto - Draw Bezier curve
    • PDF_define_layer - Create layer definition
    • PDF_delete - Delete PDFlib object
    • PDF_delete_pvf - Delete PDFlib virtual file
    • PDF_delete_table - Delete table object
    • PDF_delete_textflow - Delete textflow object
    • PDF_encoding_set_char - Add glyph name and/or Unicode value
    • PDF_endpath - End current path
    • PDF_end_document - Close PDF file
    • PDF_end_font - Terminate Type 3 font definition
    • PDF_end_glyph - Terminate glyph definition for Type 3 font
    • PDF_end_item - Close structure element or other content item
    • PDF_end_layer - Deactivate all active layers
    • PDF_end_page - Finish page
    • PDF_end_page_ext - Finish page
    • PDF_end_pattern - Finish pattern
    • PDF_end_template - Finish template
    • PDF_fill - Fill current path
    • PDF_fill_imageblock - Fill image block with variable data
    • PDF_fill_pdfblock - Fill PDF block with variable data
    • PDF_fill_stroke - Fill and stroke path
    • PDF_fill_textblock - Fill text block with variable data
    • PDF_findfont - Prepare font for later use [deprecated]
    • PDF_fit_image - Place image or template
    • PDF_fit_pdi_page - Place imported PDF page
    • PDF_fit_table - Place table on page
    • PDF_fit_textflow - Format textflow in rectangular area
    • PDF_fit_textline - Place single line of text
    • PDF_get_apiname - Get name of unsuccessfull API function
    • PDF_get_buffer - Get PDF output buffer
    • PDF_get_errmsg - Get error text
    • PDF_get_errnum - Get error number
    • PDF_get_font - Get font [deprecated]
    • PDF_get_fontname - Get font name [deprecated]
    • PDF_get_fontsize - Font handling [deprecated]
    • PDF_get_image_height - Get image height [deprecated]
    • PDF_get_image_width - Get image width [deprecated]
    • PDF_get_majorversion - Get major version number [deprecated]
    • PDF_get_minorversion - Get minor version number [deprecated]
    • PDF_get_parameter - Get string parameter
    • PDF_get_pdi_parameter - Get PDI string parameter [deprecated]
    • PDF_get_pdi_value - Get PDI numerical parameter [deprecated]
    • PDF_get_value - Get numerical parameter
    • PDF_info_font - Query detailed information about a loaded font
    • PDF_info_matchbox - Query matchbox information
    • PDF_info_table - Retrieve table information
    • PDF_info_textflow - Query textflow state
    • PDF_info_textline - Perform textline formatting and query metrics
    • PDF_initgraphics - Reset graphic state
    • PDF_lineto - Draw a line
    • PDF_load_3ddata - Load 3D model
    • PDF_load_font - Search and prepare font
    • PDF_load_iccprofile - Search and prepare ICC profile
    • PDF_load_image - Open image file
    • PDF_makespotcolor - Make spot color
    • PDF_moveto - Set current point
    • PDF_new - Create PDFlib object
    • PDF_open_ccitt - Open raw CCITT image [deprecated]
    • PDF_open_file - Create PDF file [deprecated]
    • PDF_open_gif - Open GIF image [deprecated]
    • PDF_open_image - Use image data [deprecated]
    • PDF_open_image_file - Read image from file [deprecated]
    • PDF_open_jpeg - Open JPEG image [deprecated]
    • PDF_open_memory_image - Open image created with PHP's image functions [not supported]
    • PDF_open_pdi - Open PDF file [deprecated]
    • PDF_open_pdi_document - Prepare a pdi document
    • PDF_open_pdi_page - Prepare a page
    • PDF_open_tiff - Open TIFF image [deprecated]
    • PDF_pcos_get_number - Get value of pCOS path with type number or boolean
    • PDF_pcos_get_stream - Get contents of pCOS path with type stream, fstream, or string
    • PDF_pcos_get_string - Get value of pCOS path with type name, string, or boolean
    • PDF_place_image - Place image on the page [deprecated]
    • PDF_place_pdi_page - Place PDF page [deprecated]
    • PDF_process_pdi - Process imported PDF document
    • PDF_rect - Draw rectangle
    • PDF_restore - Restore graphics state
    • PDF_resume_page - Resume page
    • PDF_rotate - Rotate coordinate system
    • PDF_save - Save graphics state
    • PDF_scale - Scale coordinate system
    • PDF_setcolor - Set fill and stroke color
    • PDF_setdash - Set simple dash pattern
    • PDF_setdashpattern - Set dash pattern
    • PDF_setflat - Set flatness
    • PDF_setfont - Set font
    • PDF_setgray - Set color to gray [deprecated]
    • PDF_setgray_fill - Set fill color to gray [deprecated]
    • PDF_setgray_stroke - Set stroke color to gray [deprecated]
    • PDF_setlinecap - Set linecap parameter
    • PDF_setlinejoin - Set linejoin parameter
    • PDF_setlinewidth - Set line width
    • PDF_setmatrix - Set current transformation matrix
    • PDF_setmiterlimit - Set miter limit
    • PDF_setpolydash - Set complicated dash pattern [deprecated]
    • PDF_setrgbcolor - Set fill and stroke rgb color values [deprecated]
    • PDF_setrgbcolor_fill - Set fill rgb color values [deprecated]
    • PDF_setrgbcolor_stroke - Set stroke rgb color values [deprecated]
    • PDF_set_border_color - Set border color of annotations [deprecated]
    • PDF_set_border_dash - Set border dash style of annotations [deprecated]
    • PDF_set_border_style - Set border style of annotations [deprecated]
    • PDF_set_char_spacing - Set character spacing [deprecated]
    • PDF_set_duration - Set duration between pages [deprecated]
    • PDF_set_gstate - Activate graphics state object
    • PDF_set_horiz_scaling - Set horizontal text scaling [deprecated]
    • PDF_set_info - Fill document info field
    • PDF_set_info_author - Fill the author document info field [deprecated]
    • PDF_set_info_creator - Fill the creator document info field [deprecated]
    • PDF_set_info_keywords - Fill the keywords document info field [deprecated]
    • PDF_set_info_subject - Fill the subject document info field [deprecated]
    • PDF_set_info_title - Fill the title document info field [deprecated]
    • PDF_set_layer_dependency - Define relationships among layers
    • PDF_set_leading - Set distance between text lines [deprecated]
    • PDF_set_parameter - Set string parameter
    • PDF_set_text_matrix - Set text matrix [deprecated]
    • PDF_set_text_pos - Set text position
    • PDF_set_text_rendering - Determine text rendering [deprecated]
    • PDF_set_text_rise - Set text rise [deprecated]
    • PDF_set_value - Set numerical parameter
    • PDF_set_word_spacing - Set spacing between words [deprecated]
    • PDF_shading - Define blend
    • PDF_shading_pattern - Define shading pattern
    • PDF_shfill - Fill area with shading
    • PDF_show - Output text at current position
    • PDF_show_boxed - Output text in a box [deprecated]
    • PDF_show_xy - Output text at given position
    • PDF_skew - Skew the coordinate system
    • PDF_stringwidth - Return width of text
    • PDF_stroke - Stroke path
    • PDF_suspend_page - Suspend page
    • PDF_translate - Set origin of coordinate system
    • PDF_utf8_to_utf16 - Convert string from UTF-8 to UTF-16
    • PDF_utf16_to_utf8 - Convert string from UTF-16 to UTF-8
    • PDF_utf32_to_utf16 - Convert string from UTF-32 to UTF-16
    • PDO::beginTransaction - Bir toplu hareketi ilklendirir
    • PDO::commit - Bir toplu hareketi veritabanına gönderir
    • PDO::cubrid_schema - Get the requested schema information
    • PDO::errorCode - Veritabanındaki son işlemle ilgili SQLSTATE kodunu döndürür
    • PDO::errorInfo - Veritabanındaki son işlemle ilgili hata bilgisini döndürür
    • PDO::exec - Belirtilen SQL deyimini çalıştırır ve etkilenen satır sayısını döndürür
    • PDO::getAttribute - Bir veritabanı bağlantı özniteliğinin değerini döndürür
    • PDO::getAvailableDrivers - Kullanılabilen PDO sürücülerini içeren bir dizi döndürür
    • PDO::inTransaction - Checks if inside a transaction
    • PDO::lastInsertId - Son yerleştirilen satırın veya sıradaki değerin kimliğini döndürür
    • PDO::pgsqlCopyFromArray - Copy data from PHP array into table
    • PDO::pgsqlCopyFromFile - Copy data from file into table
    • PDO::pgsqlCopyToArray - Copy data from database table into PHP array
    • PDO::pgsqlCopyToFile - Copy data from table into file
    • PDO::pgsqlGetNotify - Get asynchronous notification
    • PDO::pgsqlGetPid - Get the server PID
    • PDO::pgsqlLOBCreate - Creates a new large object
    • PDO::pgsqlLOBOpen - Opens an existing large object stream
    • PDO::pgsqlLOBUnlink - Deletes the large object
    • PDO::prepare - Çalıştırılmak üzere bir deyimi hazırlar ve bir deyim nesnesi olarak döndürür
    • PDO::query - Bir SQL deyimini çalıştırıp sonucu bir PDOStatement nesnesi olarak döndürür
    • PDO::quote - Bir sorguda kullanılmak üzere bir dizgeyi önceler
    • PDO::rollBack - Bir toplu hareketi geri alır
    • PDO::setAttribute - Bir öznitelik tanımlar
    • PDO::sqliteCreateAggregate - Registers an aggregating User Defined Function for use in SQL statements
    • PDO::sqliteCreateCollation - Registers a User Defined Function for use as a collating function in SQL statements
    • PDO::sqliteCreateFunction - Registers a User Defined Function for use in SQL statements
    • PDO::__construct - Bir veritabanı bağlantısını temsil eden bir PDO nesnesi oluşturur
    • PDOStatement->bindColumn - Bir sütunu bir PHP değişkeni ile ilişkilendirir
    • PDOStatement->bindParam - Bir değiştirgeyi belirtilen değişkenle ilişkilendirir
    • PDOStatement->bindValue - Bir değeri bir değiştirge ile ilişkilendirir
    • PDOStatement->closeCursor - Göstericiyi kapatarak deyimin tekrar çalıştırılabilmesini sağlar
    • PDOStatement->columnCount - Sonuç kümesindeki sütun sayısını döndürür
    • PDOStatement->debugDumpParams - Bir SQL hazır komutunu dökümler
    • PDOStatement->errorCode - Deyim üzerindeki son işlemle ilgili SQLSTATE hata kodunu döndürür
    • PDOStatement->errorInfo - Deyim üzerindeki son işlemle ilgili hata bilgisini döndürür
    • PDOStatement->execute - Bir hazır deyimi çalıştırır
    • PDOStatement->fetch - Sonuç kümesindeki sonraki satırı döndürür
    • PDOStatement->fetchAll - Sonuç kümesinin tüm satırlarını içeren bir dizi döndürür
    • PDOStatement->fetchColumn - Sonuç kümesindeki sonraki satırdan tek bir sütun döndürür
    • PDOStatement->fetchObject - Sonraki satırı bir nesne olarak döndürür
    • PDOStatement->getAttribute - Bir deyim özniteliğinin değerini döndürür
    • PDOStatement->getColumnMeta - Sonuç kümesindeki bir sütunla ilgili temel veriyi döndürür
    • PDOStatement->nextRowset - Çok satır kümeli bir sonuçtaki sonraki satır kümesini geçerli satır kümesi yapar
    • PDOStatement->rowCount - Son SQL deyiminden etkilenen satır sayısını döndürür
    • PDOStatement->setAttribute - Bir deyim özniteliğini tanımlar
    • PDOStatement->setFetchMode - Deyim için öntanımlı veri alım kipini belirler
    • PDO_4D örnekleri - PDO_4D Örnekleri
    • PDO_4D DSN - 4D SQL sunucusuna bağlantı
    • PDO_4D Sabitleri - PDO_4D Sabitleri
    • PDO_4D ve PHP ile SQL türleri - PDO_4D ve PHP ile SQL türleri
    • PDO_CUBRID DSN - Connecting to CUBRID databases
    • PDO_DBLIB DSN - Microsoft SQL Sunucusu ve Sybase veritabanlarına bağlantı
    • PDO_FIREBIRD DSN - Firebird ve Interbase veritabanı bağlantısı
    • PDO_IBM DSN - IBM veritabanı bağlantısı
    • PDO_INFORMIX DSN - Informix veritabanı bağlantısı
    • PDO_MYSQL DSN - MySQL veritabanı bağlantısı
    • PDO_OCI DSN - Oracle veritabanlarına bağlantı
    • PDO_ODBC DSN - ODBC veya DB2 veritabanlarına bağlantı
    • PDO_PGSQL DSN - PostgreSQL veritabanı bağlantısı
    • PDO_SQLITE DSN - SQLite veritabanı bağlantısı
    • PDO_SQLSRV DSN - Connecting to MS SQL Server and SQL Azure databases
    • pfsockopen - Kalıcı bir internet veya Unix alan soketi bağlantısı açar
    • pg_affected_rows - Returns number of affected records (tuples)
    • pg_cancel_query - Cancel an asynchronous query
    • pg_client_encoding - Gets the client encoding
    • pg_close - Closes a PostgreSQL connection
    • pg_connect - Open a PostgreSQL connection
    • pg_connection_busy - Get connection is busy or not
    • pg_connection_reset - Reset connection (reconnect)
    • pg_connection_status - Get connection status
    • pg_connect_poll - Poll the status of an in-progress asynchronous PostgreSQL connection attempt.
    • pg_consume_input - Reads input on the connection
    • pg_convert - Convert associative array values into suitable for SQL statement
    • pg_copy_from - Insert records into a table from an array
    • pg_copy_to - Copy a table to an array
    • pg_dbname - Get the database name
    • pg_delete - Deletes records
    • pg_end_copy - Sync with PostgreSQL backend
    • pg_escape_bytea - Escape a string for insertion into a bytea field
    • pg_escape_identifier - Escape a identifier for insertion into a text field
    • pg_escape_literal - Escape a literal for insertion into a text field
    • pg_escape_string - Escape a string for query
    • pg_execute - Sends a request to execute a prepared statement with given parameters, and waits for the result.
    • pg_fetch_all - Fetches all rows from a result as an array
    • pg_fetch_all_columns - Fetches all rows in a particular result column as an array
    • pg_fetch_array - Fetch a row as an array
    • pg_fetch_assoc - Fetch a row as an associative array
    • pg_fetch_object - Fetch a row as an object
    • pg_fetch_result - Returns values from a result resource
    • pg_fetch_row - Get a row as an enumerated array
    • pg_field_is_null - Test if a field is SQL NULL
    • pg_field_name - Returns the name of a field
    • pg_field_num - Returns the field number of the named field
    • pg_field_prtlen - Returns the printed length
    • pg_field_size - Returns the internal storage size of the named field
    • pg_field_table - Returns the name or oid of the tables field
    • pg_field_type - Returns the type name for the corresponding field number
    • pg_field_type_oid - Returns the type ID (OID) for the corresponding field number
    • pg_flush - Flush outbound query data on the connection
    • pg_free_result - Free result memory
    • pg_get_notify - Gets SQL NOTIFY message
    • pg_get_pid - Gets the backend's process ID
    • pg_get_result - Get asynchronous query result
    • pg_host - Returns the host name associated with the connection
    • pg_insert - Insert array into table
    • pg_last_error - Get the last error message string of a connection
    • pg_last_notice - Returns the last notice message from PostgreSQL server
    • pg_last_oid - Returns the last row's OID
    • pg_lo_close - Close a large object
    • pg_lo_create - Create a large object
    • pg_lo_export - Export a large object to file
    • pg_lo_import - Import a large object from file
    • pg_lo_open - Open a large object
    • pg_lo_read - Read a large object
    • pg_lo_read_all - Reads an entire large object and send straight to browser
    • pg_lo_seek - Seeks position within a large object
    • pg_lo_tell - Returns current seek position a of large object
    • pg_lo_truncate - Truncates a large object
    • pg_lo_unlink - Delete a large object
    • pg_lo_write - Write to a large object
    • pg_meta_data - Get meta data for table
    • pg_num_fields - Returns the number of fields in a result
    • pg_num_rows - Returns the number of rows in a result
    • pg_options - Get the options associated with the connection
    • pg_parameter_status - Looks up a current parameter setting of the server.
    • pg_pconnect - Open a persistent PostgreSQL connection
    • pg_ping - Ping database connection
    • pg_port - Return the port number associated with the connection
    • pg_prepare - Submits a request to create a prepared statement with the given parameters, and waits for completion.
    • pg_put_line - Send a NULL-terminated string to PostgreSQL backend
    • pg_query - Execute a query
    • pg_query_params - Submits a command to the server and waits for the result, with the ability to pass parameters separately from the SQL command text.
    • pg_result_error - Get error message associated with result
    • pg_result_error_field - Returns an individual field of an error report.
    • pg_result_seek - Set internal row offset in result resource
    • pg_result_status - Get status of query result
    • pg_select - Select records
    • pg_send_execute - Sends a request to execute a prepared statement with given parameters, without waiting for the result(s).
    • pg_send_prepare - Sends a request to create a prepared statement with the given parameters, without waiting for completion.
    • pg_send_query - Sends asynchronous query
    • pg_send_query_params - Submits a command and separate parameters to the server without waiting for the result(s).
    • pg_set_client_encoding - Set the client encoding
    • pg_set_error_verbosity - Determines the verbosity of messages returned by pg_last_error and pg_result_error.
    • pg_socket - Get a read only handle to the socket underlying a PostgreSQL connection
    • pg_trace - Enable tracing a PostgreSQL connection
    • pg_transaction_status - Returns the current in-transaction status of the server.
    • pg_tty - Return the TTY name associated with the connection
    • pg_unescape_bytea - Unescape binary for bytea type
    • pg_untrace - Disable tracing of a PostgreSQL connection
    • pg_update - Update table
    • pg_version - Returns an array with client, protocol and server version (when available)
    • phar:// - PHP Archive
    • Phar::addEmptyDir - Add an empty directory to the phar archive
    • Phar::addFile - Add a file from the filesystem to the phar archive
    • Phar::addFromString - Add a file from a string to the phar archive
    • Phar::apiVersion - Returns the api version
    • Phar::buildFromDirectory - Construct a phar archive from the files within a directory.
    • Phar::buildFromIterator - Construct a phar archive from an iterator.
    • Phar::canCompress - Returns whether phar extension supports compression using either zlib or bzip2
    • Phar::canWrite - Returns whether phar extension supports writing and creating phars
    • Phar::compress - Compresses the entire Phar archive using Gzip or Bzip2 compression
    • Phar::compressAllFilesBZIP2 - Compresses all files in the current Phar archive using Bzip2 compression
    • Phar::compressAllFilesGZ - Compresses all files in the current Phar archive using Gzip compression
    • Phar::compressFiles - Compresses all files in the current Phar archive
    • Phar::convertToData - Convert a phar archive to a non-executable tar or zip file
    • Phar::convertToExecutable - Convert a phar archive to another executable phar archive file format
    • Phar::copy - Copy a file internal to the phar archive to another new file within the phar
    • Phar::count - Returns the number of entries (files) in the Phar archive
    • Phar::createDefaultStub - Create a phar-file format specific stub
    • Phar::decompress - Decompresses the entire Phar archive
    • Phar::decompressFiles - Decompresses all files in the current Phar archive
    • Phar::delete - Delete a file within a phar archive
    • Phar::delMetadata - Deletes the global metadata of the phar
    • Phar::extractTo - Extract the contents of a phar archive to a directory
    • Phar::getMetadata - Returns phar archive meta-data
    • Phar::getModified - Return whether phar was modified
    • Phar::getSignature - Return MD5/SHA1/SHA256/SHA512/OpenSSL signature of a Phar archive
    • Phar::getStub - Return the PHP loader or bootstrap stub of a Phar archive
    • Phar::getSupportedCompression - Return array of supported compression algorithms
    • Phar::getSupportedSignatures - Return array of supported signature types
    • Phar::getVersion - Return version info of Phar archive
    • Phar::hasMetadata - Returns whether phar has global meta-data
    • Phar::interceptFileFuncs - instructs phar to intercept fopen, file_get_contents, opendir, and all of the stat-related functions
    • Phar::isBuffering - Used to determine whether Phar write operations are being buffered, or are flushing directly to disk
    • Phar::isCompressed - Returns Phar::GZ or PHAR::BZ2 if the entire phar archive is compressed (.tar.gz/tar.bz and so on)
    • Phar::isFileFormat - Returns true if the phar archive is based on the tar/phar/zip file format depending on the parameter
    • Phar::isValidPharFilename - Returns whether the given filename is a valid phar filename
    • Phar::isWritable - Returns true if the phar archive can be modified
    • Phar::loadPhar - Loads any phar archive with an alias
    • Phar::mapPhar - Reads the currently executed file (a phar) and registers its manifest
    • Phar::mount - Mount an external path or file to a virtual location within the phar archive
    • Phar::mungServer - Defines a list of up to 4 $_SERVER variables that should be modified for execution
    • Phar::offsetExists - determines whether a file exists in the phar
    • Phar::offsetGet - Gets a PharFileInfo object for a specific file
    • Phar::offsetSet - set the contents of an internal file to those of an external file
    • Phar::offsetUnset - remove a file from a phar
    • Phar::running - Returns the full path on disk or full phar URL to the currently executing Phar archive
    • Phar::setAlias - Set the alias for the Phar archive
    • Phar::setDefaultStub - Used to set the PHP loader or bootstrap stub of a Phar archive to the default loader
    • Phar::setMetadata - Sets phar archive meta-data
    • Phar::setSignatureAlgorithm - set the signature algorithm for a phar and apply it.
    • Phar::setStub - Used to set the PHP loader or bootstrap stub of a Phar archive
    • Phar::startBuffering - Start buffering Phar write operations, do not modify the Phar object on disk
    • Phar::stopBuffering - Stop buffering write requests to the Phar archive, and save changes to disk
    • Phar::uncompressAllFiles - Uncompresses all files in the current Phar archive
    • Phar::unlinkArchive - Completely remove a phar archive from disk and from memory
    • Phar::webPhar - mapPhar for web-based phars. front controller for web applications
    • Phar::__construct - Construct a Phar archive object
    • Phar bağlam seçenekleri - Phar bağlamı seçeneklerinin listesi
    • PharData::addEmptyDir - Add an empty directory to the tar/zip archive
    • PharData::addFile - Add a file from the filesystem to the tar/zip archive
    • PharData::addFromString - Add a file from the filesystem to the tar/zip archive
    • PharData::buildFromDirectory - Construct a tar/zip archive from the files within a directory.
    • PharData::buildFromIterator - Construct a tar or zip archive from an iterator.
    • PharData::compress - Compresses the entire tar/zip archive using Gzip or Bzip2 compression
    • PharData::compressFiles - Compresses all files in the current tar/zip archive
    • PharData::convertToData - Convert a phar archive to a non-executable tar or zip file
    • PharData::convertToExecutable - Convert a non-executable tar/zip archive to an executable phar archive
    • PharData::copy - Copy a file internal to the phar archive to another new file within the phar
    • PharData::decompress - Decompresses the entire Phar archive
    • PharData::decompressFiles - Decompresses all files in the current zip archive
    • PharData::delete - Delete a file within a tar/zip archive
    • PharData::delMetadata - Deletes the global metadata of a zip archive
    • PharData::extractTo - Extract the contents of a tar/zip archive to a directory
    • PharData::isWritable - Returns true if the tar/zip archive can be modified
    • PharData::offsetSet - set the contents of a file within the tar/zip to those of an external file or string
    • PharData::offsetUnset - remove a file from a tar/zip archive
    • PharData::setAlias - dummy function (Phar::setAlias is not valid for PharData)
    • PharData::setDefaultStub - dummy function (Phar::setDefaultStub is not valid for PharData)
    • PharData::setStub - dummy function (Phar::setStub is not valid for PharData)
    • PharData::__construct - Construct a non-executable tar or zip archive object
    • PharException - The PharException class provides a phar-specific exception class for try/catch blocks.
    • PharFileInfo::chmod - Sets file-specific permission bits
    • PharFileInfo::compress - Compresses the current Phar entry with either zlib or bzip2 compression
    • PharFileInfo::decompress - Decompresses the current Phar entry within the phar
    • PharFileInfo::delMetadata - Deletes the metadata of the entry
    • PharFileInfo::getCompressedSize - Returns the actual size of the file (with compression) inside the Phar archive
    • PharFileInfo::getCRC32 - Returns CRC32 code or throws an exception if CRC has not been verified
    • PharFileInfo::getMetadata - Returns file-specific meta-data saved with a file
    • PharFileInfo::getPharFlags - Returns the Phar file entry flags
    • PharFileInfo::hasMetadata - Returns the metadata of the entry
    • PharFileInfo::isCompressed - Returns whether the entry is compressed
    • PharFileInfo::isCompressedBZIP2 - Returns whether the entry is compressed using bzip2
    • PharFileInfo::isCompressedGZ - Returns whether the entry is compressed using gz
    • PharFileInfo::isCRCChecked - Returns whether file entry has had its CRC verified
    • PharFileInfo::setCompressedBZIP2 - Compresses the current Phar entry within the phar using Bzip2 compression
    • PharFileInfo::setCompressedGZ - Compresses the current Phar entry within the phar using gz compression
    • PharFileInfo::setMetadata - Sets file-specific meta-data saved with a file
    • PharFileInfo::setUncompressed - Uncompresses the current Phar entry within the phar, if it is compressed
    • PharFileInfo::__construct - Construct a Phar entry object
    • php:// - Accessing various I/O streams
    • phpcredits - PHP'ya katkıda bulunanları gösterir
    • phpinfo - PHP'nin o anki durumu hakkında büyük miktarda bilgi çıktılar
    • phpversion - Çalışan PHP'nin sürümünü döndürür
    • php_check_syntax - Belirtilen (veya çalışan) dosyanın PHP sözdizimini denetler
    • php_ini_loaded_file - Yüklü php.ini dosyasının dosya yolunu döndürür
    • php_ini_scanned_files - Ek ini dizininden ayrıştırılan dosyaların listesi ile döner
    • php_logo_guid - PHP logo kimliğini döndürür
    • php_sapi_name - HTTP sunucusu ile PHP arasındaki arayüzün türünü döndürür
    • php_strip_whitespace - Boşlukları ve açıklamaları ayıklanmış kaynak kodla döner
    • php_uname - PHP'nin çalıştığı işletim sistemi hakkında bilgi döndürür
    • pi - Get value of pi
    • png2wbmp - Bir PNG dosyasını WBMP dosyasına dönüştürür
    • Pool::collect - Collect references to completed tasks
    • Pool::resize - Resize the Pool
    • Pool::shutdown - Shutdown all workers
    • Pool::submit - Submits an object for execution
    • Pool::submitTo - Submits a task to a specific worker for execution
    • Pool::__construct - Creates a new Pool of Workers
    • popen - Bir süreç tanıtıcısı açar
    • pos - current işlevinin takma adıdır
    • posix_access - Bir dosyanın izinlerine bakar
    • posix_ctermid - Denetim uçbiriminin dosya yolunu döndürür
    • posix_errno - Takma Adı: posix_get_last_error
    • posix_getcwd - Çalışılan dizinin tam yolunu döndürür
    • posix_getegid - Çalışan sürecin etkin grup kimliğini döndürür
    • posix_geteuid - Çalışan sürecin etkin kullanıcı kimliğini döndürür
    • posix_getgid - Çalışan sürecin gerçek grup kimliğini döndürür
    • posix_getgrgid - Grup kimliği belirtilen grup hakkında bilgi verir
    • posix_getgrnam - İsmi belirtilen grup hakkında bilgi verir
    • posix_getgroups - Çalışan sürecin üyesi olduğu grupları döndürür
    • posix_getlogin - Oturumu açan kullanıcının ismini döndürür
    • posix_getpgid - Süreç kimliği belirtilen sürecin süreç grup kimliğini döndürür
    • posix_getpgrp - Çalışan sürecin süreç grup kimliğini döndürür
    • posix_getpid - Çalışan sürecin süreç kimliğini döndürür
    • posix_getppid - Üst süreç kimliğini döndürür
    • posix_getpwnam - Kullanıcı adı belirtilen kullanıcı hakkında bilgi döndürür
    • posix_getpwuid - Kullanıcı kimliği belirtilen kullanıcı hakkında bilgi döndürür
    • posix_getrlimit - Sistem özkaynak sınırları hakkında bilgi verir
    • posix_getsid - Geçerli sürecin oturum kimliğini döndürür
    • posix_getuid - Geçerli sürecin gerçek kullanıcı kimliğini döndürür
    • posix_get_last_error - Başarısız olan son POSIX işlevinden atanan hata numarasını döndürür
    • posix_initgroups - Grup erişim listesini hesaplar
    • posix_isatty - Dosya tanıtıcısı bir etkileşimli uçbirimle ilişkili mi diye bakar
    • posix_kill - Bir sürece bir sinyal gönderir
    • posix_mkfifo - Bir isimli boru dosyası (FIFO) oluşturur
    • posix_mknod - Özel veya sıralı (POSIX.1) bir dosya oluşturur
    • posix_setegid - Geçerli sürecin etkin grup kimliğini belirler
    • posix_seteuid - Geçerli sürecin etkin kullanıcı kimliğini belirler
    • posix_setgid - Geçerli sürecin grup kimliğini tanımlar
    • posix_setpgid - İş denetimi için süreç grup kimliğini tanımlar
    • posix_setrlimit - Set system resource limits
    • posix_setsid - Geçerli süreci bir oturumun lider süreci haline getirir
    • posix_setuid - Geçerli sürecin kullanıcı kimliğini tanımlar
    • posix_strerror - Belirtilen hatanum ile ilgili sistem hata iletisini döndürür
    • posix_times - Süreçle ilgili işlemci zamanlarını döndürür
    • posix_ttyname - Uçbirim aygıt ismini belirler
    • posix_uname - Sistem hakkında bilgi verir
    • pow - Exponential expression
    • preg_filter - Bir düzenli ifade arama ve değiştirmesi yapar
    • preg_grep - Düzenli ifadeyle eşleşenleri içeren bir dizi döndürür
    • preg_last_error - Son PCRE düzenli ifade aramasından dönen hatayı döndürür
    • preg_match - Bir düzenli ifadeyi eşleştirmeye çalışır
    • preg_match_all - Kapsamlı bir düzenli ifade eşleştirmesi yapar
    • preg_quote - Düzenli ifadelerin özel karakterlerini önceler
    • preg_replace - Düzenli ifadeye göre dizgede değişiklik yapar
    • preg_replace_callback - Geriçağırım işlevi kullanarak düzenli ifadeye göre dizgede değişiklik yapar
    • preg_replace_callback_array - Perform a regular expression search and replace using callbacks
    • preg_split - Dizgeyi düzenli ifadeye göre böler
    • prev - Dahili dizi göstericisini bir geriletir
    • print - Bir dizge çıktılar
    • printf - Biçemli bir dizge çıktılar
    • print_r - Bir değişkenin insanlarca okunabilecek gösterimini basar
    • proc_close - proc_open tarafından açılmış bir süreci kapatır ve sürecin çıkış kodunu döndürür
    • proc_get_status - proc_open tarafından açılmış bir süreç hakkında bilgi döndürür
    • proc_nice - Çalışan sürecin önceliğini değiştirir
    • proc_open - Bir komutu çalıştırır ve G/Ç için bir dosya tanıtıcı açar
    • proc_terminate - proc_open ile açılmış bir süreci öldürür
    • property_exists - Bir nesne veya sınıfın belirtilen özelliğe sahip olup olmadığına bakar
    • pspell_add_to_personal - Add the word to a personal wordlist
    • pspell_add_to_session - Add the word to the wordlist in the current session
    • pspell_check - Check a word
    • pspell_clear_session - Clear the current session
    • pspell_config_create - Create a config used to open a dictionary
    • pspell_config_data_dir - location of language data files
    • pspell_config_dict_dir - Location of the main word list
    • pspell_config_ignore - Ignore words less than N characters long
    • pspell_config_mode - Change the mode number of suggestions returned
    • pspell_config_personal - Set a file that contains personal wordlist
    • pspell_config_repl - Set a file that contains replacement pairs
    • pspell_config_runtogether - Consider run-together words as valid compounds
    • pspell_config_save_repl - Determine whether to save a replacement pairs list along with the wordlist
    • pspell_new - Load a new dictionary
    • pspell_new_config - Load a new dictionary with settings based on a given config
    • pspell_new_personal - Load a new dictionary with personal wordlist
    • pspell_save_wordlist - Save the personal wordlist to a file
    • pspell_store_replacement - Store a replacement pair for a word
    • pspell_suggest - Suggest spellings of a word
    • ps_add_bookmark - Add bookmark to current page
    • ps_add_launchlink - Adds link which launches file
    • ps_add_locallink - Adds link to a page in the same document
    • ps_add_note - Adds note to current page
    • ps_add_pdflink - Adds link to a page in a second pdf document
    • ps_add_weblink - Adds link to a web location
    • ps_arc - Draws an arc counterclockwise
    • ps_arcn - Draws an arc clockwise
    • ps_begin_page - Start a new page
    • ps_begin_pattern - Start a new pattern
    • ps_begin_template - Start a new template
    • ps_circle - Draws a circle
    • ps_clip - Clips drawing to current path
    • ps_close - Closes a PostScript document
    • ps_closepath - Closes path
    • ps_closepath_stroke - Closes and strokes path
    • ps_close_image - Closes image and frees memory
    • ps_continue_text - Continue text in next line
    • ps_curveto - Draws a curve
    • ps_delete - Deletes all resources of a PostScript document
    • ps_end_page - End a page
    • ps_end_pattern - End a pattern
    • ps_end_template - End a template
    • ps_fill - Fills the current path
    • ps_fill_stroke - Fills and strokes the current path
    • ps_findfont - Loads a font
    • ps_get_buffer - Fetches the full buffer containig the generated PS data
    • ps_get_parameter - Gets certain parameters
    • ps_get_value - Gets certain values
    • ps_hyphenate - Hyphenates a word
    • ps_include_file - Reads an external file with raw PostScript code
    • ps_lineto - Draws a line
    • ps_makespotcolor - Create spot color
    • ps_moveto - Sets current point
    • ps_new - Creates a new PostScript document object
    • ps_open_file - Opens a file for output
    • ps_open_image - Reads an image for later placement
    • ps_open_image_file - Opens image from file
    • ps_open_memory_image - Takes an GD image and returns an image for placement in a PS document
    • ps_place_image - Places image on the page
    • ps_rect - Draws a rectangle
    • ps_restore - Restore previously save context
    • ps_rotate - Sets rotation factor
    • ps_save - Save current context
    • ps_scale - Sets scaling factor
    • ps_setcolor - Sets current color
    • ps_setdash - Sets appearance of a dashed line
    • ps_setflat - Sets flatness
    • ps_setfont - Sets font to use for following output
    • ps_setgray - Sets gray value
    • ps_setlinecap - Sets appearance of line ends
    • ps_setlinejoin - Sets how contected lines are joined
    • ps_setlinewidth - Sets width of a line
    • ps_setmiterlimit - Sets the miter limit
    • ps_setoverprintmode - Sets overprint mode
    • ps_setpolydash - Sets appearance of a dashed line
    • ps_set_border_color - Sets color of border for annotations
    • ps_set_border_dash - Sets length of dashes for border of annotations
    • ps_set_border_style - Sets border style of annotations
    • ps_set_info - Sets information fields of document
    • ps_set_parameter - Sets certain parameters
    • ps_set_text_pos - Sets position for text output
    • ps_set_value - Sets certain values
    • ps_shading - Creates a shading for later use
    • ps_shading_pattern - Creates a pattern based on a shading
    • ps_shfill - Fills an area with a shading
    • ps_show - Output text
    • ps_show2 - Output a text at current position
    • ps_show_boxed - Output text in a box
    • ps_show_xy - Output text at given position
    • ps_show_xy2 - Output text at position
    • ps_stringwidth - Gets width of a string
    • ps_string_geometry - Gets geometry of a string
    • ps_stroke - Draws the current path
    • ps_symbol - Output a glyph
    • ps_symbol_name - Gets name of a glyph
    • ps_symbol_width - Gets width of a glyph
    • ps_translate - Sets translation
    • putenv - Bir ortam değişkenine değer atar
    • px_close - Closes a paradox database
    • px_create_fp - Create a new paradox database
    • px_date2string - Converts a date into a string.
    • px_delete - Deletes resource of paradox database
    • px_delete_record - Deletes record from paradox database
    • px_get_field - Returns the specification of a single field
    • px_get_info - Return lots of information about a paradox file
    • px_get_parameter - Gets a parameter
    • px_get_record - Returns record of paradox database
    • px_get_schema - Returns the database schema
    • px_get_value - Gets a value
    • px_insert_record - Inserts record into paradox database
    • px_new - Create a new paradox object
    • px_numfields - Returns number of fields in a database
    • px_numrecords - Returns number of records in a database
    • px_open_fp - Open paradox database
    • px_put_record - Stores record into paradox database
    • px_retrieve_record - Returns record of paradox database
    • px_set_blob_file - Sets the file where blobs are read from
    • px_set_parameter - Sets a parameter
    • px_set_tablename - Sets the name of a table (deprecated)
    • px_set_targetencoding - Sets the encoding for character fields (deprecated)
    • px_set_value - Sets a value
    • px_timestamp2string - Converts the timestamp into a string.
    • px_update_record - Updates record in paradox database
  • q
    • QuickHashIntHash::add - This method adds a new entry to the hash
    • QuickHashIntHash::delete - This method deletes am entry from the hash
    • QuickHashIntHash::exists - This method checks whether a key is part of the hash
    • QuickHashIntHash::get - This method retrieves a value from the hash by its key
    • QuickHashIntHash::getSize - Returns the number of elements in the hash
    • QuickHashIntHash::loadFromFile - This factory method creates a hash from a file
    • QuickHashIntHash::loadFromString - This factory method creates a hash from a string
    • QuickHashIntHash::saveToFile - This method stores an in-memory hash to disk
    • QuickHashIntHash::saveToString - This method returns a serialized version of the hash
    • QuickHashIntHash::set - This method updates an entry in the hash with a new value, or adds a new one if the entry doesn't exist
    • QuickHashIntHash::update - This method updates an entry in the hash with a new value
    • QuickHashIntHash::__construct - Creates a new QuickHashIntHash object
    • QuickHashIntSet::add - This method adds a new entry to the set
    • QuickHashIntSet::delete - This method deletes an entry from the set
    • QuickHashIntSet::exists - This method checks whether a key is part of the set
    • QuickHashIntSet::getSize - Returns the number of elements in the set
    • QuickHashIntSet::loadFromFile - This factory method creates a set from a file
    • QuickHashIntSet::loadFromString - This factory method creates a set from a string
    • QuickHashIntSet::saveToFile - This method stores an in-memory set to disk
    • QuickHashIntSet::saveToString - This method returns a serialized version of the set
    • QuickHashIntSet::__construct - Creates a new QuickHashIntSet object
    • QuickHashIntStringHash::add - This method adds a new entry to the hash
    • QuickHashIntStringHash::delete - This method deletes am entry from the hash
    • QuickHashIntStringHash::exists - This method checks whether a key is part of the hash
    • QuickHashIntStringHash::get - This method retrieves a value from the hash by its key
    • QuickHashIntStringHash::getSize - Returns the number of elements in the hash
    • QuickHashIntStringHash::loadFromFile - This factory method creates a hash from a file
    • QuickHashIntStringHash::loadFromString - This factory method creates a hash from a string
    • QuickHashIntStringHash::saveToFile - This method stores an in-memory hash to disk
    • QuickHashIntStringHash::saveToString - This method returns a serialized version of the hash
    • QuickHashIntStringHash::set - This method updates an entry in the hash with a new value, or adds a new one if the entry doesn't exist
    • QuickHashIntStringHash::update - This method updates an entry in the hash with a new value
    • QuickHashIntStringHash::__construct - Creates a new QuickHashIntStringHash object
    • QuickHashStringIntHash::add - This method adds a new entry to the hash
    • QuickHashStringIntHash::delete - This method deletes am entry from the hash
    • QuickHashStringIntHash::exists - This method checks whether a key is part of the hash
    • QuickHashStringIntHash::get - This method retrieves a value from the hash by its key
    • QuickHashStringIntHash::getSize - Returns the number of elements in the hash
    • QuickHashStringIntHash::loadFromFile - This factory method creates a hash from a file
    • QuickHashStringIntHash::loadFromString - This factory method creates a hash from a string
    • QuickHashStringIntHash::saveToFile - This method stores an in-memory hash to disk
    • QuickHashStringIntHash::saveToString - This method returns a serialized version of the hash
    • QuickHashStringIntHash::set - This method updates an entry in the hash with a new value, or adds a new one if the entry doesn't exist
    • QuickHashStringIntHash::update - This method updates an entry in the hash with a new value
    • QuickHashStringIntHash::__construct - Creates a new QuickHashStringIntHash object
    • quoted_printable_decode - ASCII olarak basılabilir (quoted-printable) bir dizgenin 8 bitlik sürümünü döndürür
    • quoted_printable_encode - 8 bitlik bir dizgenin ASCII olarak basılabilir (quoted-printable) sürümünü döndürür
    • quotemeta - Özel anlamı olan karakterleri tersbölü ile önceler
  • r
    • rad2deg - Converts the radian number to the equivalent number in degrees
    • radius_acct_open - Creates a Radius handle for accounting
    • radius_add_server - Adds a server
    • radius_auth_open - Creates a Radius handle for authentication
    • radius_close - Frees all ressources
    • radius_config - Causes the library to read the given configuration file
    • radius_create_request - Create accounting or authentication request
    • radius_cvt_addr - Converts raw data to IP-Address
    • radius_cvt_int - Converts raw data to integer
    • radius_cvt_string - Converts raw data to string
    • radius_demangle - Demangles data
    • radius_demangle_mppe_key - Derives mppe-keys from mangled data
    • radius_get_attr - Extracts an attribute
    • radius_get_tagged_attr_data - Extracts the data from a tagged attribute
    • radius_get_tagged_attr_tag - Extracts the tag from a tagged attribute
    • radius_get_vendor_attr - Extracts a vendor specific attribute
    • radius_put_addr - Attaches an IP address attribute
    • radius_put_attr - Attaches a binary attribute
    • radius_put_int - Attaches an integer attribute
    • radius_put_string - Attaches a string attribute
    • radius_put_vendor_addr - Attaches a vendor specific IP address attribute
    • radius_put_vendor_attr - Attaches a vendor specific binary attribute
    • radius_put_vendor_int - Attaches a vendor specific integer attribute
    • radius_put_vendor_string - Attaches a vendor specific string attribute
    • radius_request_authenticator - Returns the request authenticator
    • radius_salt_encrypt_attr - Salt-encrypts a value
    • radius_send_request - Sends the request and waites for a reply
    • radius_server_secret - Returns the shared secret
    • radius_strerror - Returns an error message
    • rand - Generate a random integer
    • random_bytes - Generates cryptographically secure pseudo-random bytes
    • random_int - Generates cryptographically secure pseudo-random integers
    • range - Belli bir eleman aralığını içeren bir dizi oluşturur
    • rar:// - RAR
    • RarArchive::close - Close RAR archive and free all resources
    • RarArchive::getComment - Get comment text from the RAR archive
    • RarArchive::getEntries - Get full list of entries from the RAR archive
    • RarArchive::getEntry - Get entry object from the RAR archive
    • RarArchive::isBroken - Test whether an archive is broken (incomplete)
    • RarArchive::isSolid - Check whether the RAR archive is solid
    • RarArchive::open - Open RAR archive
    • RarArchive::setAllowBroken - Whether opening broken archives is allowed
    • RarArchive::__toString - Get text representation
    • RarEntry::extract - Extract entry from the archive
    • RarEntry::getAttr - Get attributes of the entry
    • RarEntry::getCrc - Get CRC of the entry
    • RarEntry::getFileTime - Get entry last modification time
    • RarEntry::getHostOs - Get entry host OS
    • RarEntry::getMethod - Get pack method of the entry
    • RarEntry::getName - Get name of the entry
    • RarEntry::getPackedSize - Get packed size of the entry
    • RarEntry::getStream - Get file handler for entry
    • RarEntry::getUnpackedSize - Get unpacked size of the entry
    • RarEntry::getVersion - Get minimum version of RAR program required to unpack the entry
    • RarEntry::isDirectory - Test whether an entry represents a directory
    • RarEntry::isEncrypted - Test whether an entry is encrypted
    • RarEntry::__toString - Get text representation of entry
    • RarException::isUsingExceptions - Check whether error handling with exceptions is in use
    • RarException::setUsingExceptions - Activate and deactivate error handling with exceptions
    • rar_wrapper_cache_stats - Cache hits and misses for the URL wrapper
    • rawurldecode - URL kodlamalı dizgenin kodlamasını kaldırır
    • rawurlencode - RFC 1738'e uygun URL kodlaması yapar
    • readdir - Dizinden bir girdinin ismini okur
    • readfile - Bir dosyayı çıktılar
    • readgzfile - Bir .gz dosyası çıktılar
    • readline - Reads a line
    • readline_add_history - Adds a line to the history
    • readline_callback_handler_install - Initializes the readline callback interface and terminal, prints the prompt and returns immediately
    • readline_callback_handler_remove - Removes a previously installed callback handler and restores terminal settings
    • readline_callback_read_char - Reads a character and informs the readline callback interface when a line is received
    • readline_clear_history - Clears the history
    • readline_completion_function - Registers a completion function
    • readline_info - Gets/sets various internal readline variables
    • readline_list_history - Lists the history
    • readline_on_new_line - Inform readline that the cursor has moved to a new line
    • readline_read_history - Reads the history
    • readline_redisplay - Redraws the display
    • readline_write_history - Writes the history
    • readlink - Bir sembolik bağın hedefi ile döner
    • read_exif_data - exif_read_data işlevinin takma adıdır
    • realpath - Normalleştirilmiş mutlak dosya yolunu döndürür
    • realpath_cache_get - Get realpath cache entries
    • realpath_cache_size - Get realpath cache size
    • recode - recode_string işlevinin takma adıdır
    • recode_file - Dosyadan dosyaya karakter kodlaması dönüşümü yapar
    • recode_string - Yapılan isteğe bağlı olarak bir dizgeyi yeniden kodlar
    • RecursiveArrayIterator::getChildren - Returns an iterator for the current entry if it is an array or an object.
    • RecursiveArrayIterator::hasChildren - Returns whether current entry is an array or an object.
    • RecursiveCachingIterator::getChildren - Return the inner iterator's children as a RecursiveCachingIterator
    • RecursiveCachingIterator::hasChildren - Check whether the current element of the inner iterator has children
    • RecursiveCachingIterator::__construct - Construct
    • RecursiveCallbackFilterIterator::getChildren - Return the inner iterator's children contained in a RecursiveCallbackFilterIterator
    • RecursiveCallbackFilterIterator::hasChildren - Check whether the inner iterator's current element has children
    • RecursiveCallbackFilterIterator::__construct - Create a RecursiveCallbackFilterIterator from a RecursiveIterator
    • RecursiveDirectoryIterator::getChildren - Returns an iterator for the current entry if it is a directory
    • RecursiveDirectoryIterator::getSubPath - Get sub path
    • RecursiveDirectoryIterator::getSubPathname - Get sub path and name
    • RecursiveDirectoryIterator::hasChildren - Returns whether current entry is a directory and not '.' or '..'
    • RecursiveDirectoryIterator::key - Return path and filename of current dir entry
    • RecursiveDirectoryIterator::next - Move to next entry
    • RecursiveDirectoryIterator::rewind - Rewind dir back to the start
    • RecursiveDirectoryIterator::__construct - Constructs a RecursiveDirectoryIterator
    • RecursiveFilterIterator::getChildren - Return the inner iterator's children contained in a RecursiveFilterIterator
    • RecursiveFilterIterator::hasChildren - Check whether the inner iterator's current element has children
    • RecursiveFilterIterator::__construct - Create a RecursiveFilterIterator from a RecursiveIterator
    • RecursiveIterator::getChildren - Returns an iterator for the current entry.
    • RecursiveIterator::hasChildren - Returns if an iterator can be created fot the current entry.
    • RecursiveIteratorIterator::beginChildren - Begin children
    • RecursiveIteratorIterator::beginIteration - Begin Iteration
    • RecursiveIteratorIterator::callGetChildren - Get children
    • RecursiveIteratorIterator::callHasChildren - Has children
    • RecursiveIteratorIterator::current - Access the current element value
    • RecursiveIteratorIterator::endChildren - End children
    • RecursiveIteratorIterator::endIteration - End Iteration
    • RecursiveIteratorIterator::getDepth - Get the current depth of the recursive iteration
    • RecursiveIteratorIterator::getInnerIterator - Get inner iterator
    • RecursiveIteratorIterator::getMaxDepth - Get max depth
    • RecursiveIteratorIterator::getSubIterator - The current active sub iterator
    • RecursiveIteratorIterator::key - Access the current key
    • RecursiveIteratorIterator::next - Move forward to the next element
    • RecursiveIteratorIterator::nextElement - Next element
    • RecursiveIteratorIterator::rewind - Rewind the iterator to the first element of the top level inner iterator
    • RecursiveIteratorIterator::setMaxDepth - Set max depth
    • RecursiveIteratorIterator::valid - Check whether the current position is valid
    • RecursiveIteratorIterator::__construct - Construct a RecursiveIteratorIterator
    • RecursiveRegexIterator::getChildren - Returns an iterator for the current entry.
    • RecursiveRegexIterator::hasChildren - Returns whether an iterator can be obtained for the current entry.
    • RecursiveRegexIterator::__construct - Creates a new RecursiveRegexIterator.
    • RecursiveTreeIterator::beginChildren - Begin children
    • RecursiveTreeIterator::beginIteration - Begin iteration
    • RecursiveTreeIterator::callGetChildren - Get children
    • RecursiveTreeIterator::callHasChildren - Has children
    • RecursiveTreeIterator::current - Get current element
    • RecursiveTreeIterator::endChildren - End children
    • RecursiveTreeIterator::endIteration - End iteration
    • RecursiveTreeIterator::getEntry - Get current entry
    • RecursiveTreeIterator::getPostfix - Get the postfix
    • RecursiveTreeIterator::getPrefix - Get the prefix
    • RecursiveTreeIterator::key - Get the key of the current element
    • RecursiveTreeIterator::next - Move to next element
    • RecursiveTreeIterator::nextElement - Next element
    • RecursiveTreeIterator::rewind - Rewind iterator
    • RecursiveTreeIterator::setPrefixPart - Set a part of the prefix
    • RecursiveTreeIterator::valid - Check validity
    • RecursiveTreeIterator::__construct - Construct a RecursiveTreeIterator
    • Reflection::export - Sınıfı ihraç eder
    • Reflection::getModifierNames - Değiştirici isimlerini döndürür
    • ReflectionClass::export - Bir sınıf ihraç eder
    • ReflectionClass::getConstant - Tanımlı sabitleri döndürür
    • ReflectionClass::getConstants - Sabitleri döndürür
    • ReflectionClass::getConstructor - Kurucuyu döndürür
    • ReflectionClass::getDefaultProperties - Öntanımlı özellikleri döndürür
    • ReflectionClass::getDocComment - Belgelendirici açıklamaları döndürür
    • ReflectionClass::getEndLine - Son satırın numarasını döndürür
    • ReflectionClass::getExtension - Eklenti bilgilerini döndürür
    • ReflectionClass::getExtensionName - Eklentinin ismini döndürür
    • ReflectionClass::getFileName - Bir dosya adı döndürür
    • ReflectionClass::getInterfaceNames - Arayüz isimlerini döndürür
    • ReflectionClass::getInterfaces - Arayüzleri döndürür
    • ReflectionClass::getMethod - Bir yöntemle ilgili bir ReflectionMethod nesnesi döndürür
    • ReflectionClass::getMethods - Yöntem listesini döndürür
    • ReflectionClass::getModifiers - Değiştiricileri döndürür
    • ReflectionClass::getName - Sınıf ismini döndürür
    • ReflectionClass::getNamespaceName - İsim alanı ismini döndürür
    • ReflectionClass::getParentClass - Ebeveyn sınıfı döndürür
    • ReflectionClass::getProperties - Özellikleri döndürür
    • ReflectionClass::getProperty - Bir özellik döndürür
    • ReflectionClass::getShortName - Kısa adı döndürür
    • ReflectionClass::getStartLine - Başlangıç satır numarasını döndürür
    • ReflectionClass::getStaticProperties - Duruk özellikleri döndürür
    • ReflectionClass::getStaticPropertyValue - Duruk özelliğin değerini döndürür
    • ReflectionClass::getTraitAliases - Returns an array of trait aliases
    • ReflectionClass::getTraitNames - Returns an array of names of traits used by this class
    • ReflectionClass::getTraits - Returns an array of traits used by this class
    • ReflectionClass::hasConstant - Sabit tanımlı mı diye bakar
    • ReflectionClass::hasMethod - Yöntem tanımlı mı diye bakar
    • ReflectionClass::hasProperty - Özellik tanımlı mı diye bakar
    • ReflectionClass::implementsInterface - Arayüz gerçeklenmiş mi diye bakar
    • ReflectionClass::inNamespace - Sınıf isim alanında mı diye bakar
    • ReflectionClass::isAbstract - Sınıf soyut mu diye bakar
    • ReflectionClass::isAnonymous - Checks if class is anonymous
    • ReflectionClass::isCloneable - Returns whether this class is cloneable
    • ReflectionClass::isFinal - Sınıf bir final sınıf mı diye bakar
    • ReflectionClass::isInstance - Sınıf bir nesne örneği mi diye bakar
    • ReflectionClass::isInstantiable - Sınıf örneklenebilir mi diye bakar
    • ReflectionClass::isInterface - Sınıf bir arayüz mü diye bakar
    • ReflectionClass::isInternal - Sınıf yerleşik bir sınıf mı diye bakar
    • ReflectionClass::isIterateable - Sınıf yinelenebilir mi diye bakar
    • ReflectionClass::isSubclassOf - Sınıf bir alt sınıf mı diye bakar
    • ReflectionClass::isTrait - Returns whether this is a trait
    • ReflectionClass::isUserDefined - Sınıf bir kullanıcı tanımlı sınıf mı diye bakar
    • ReflectionClass::newInstance - Yeni örnek
    • ReflectionClass::newInstanceArgs - Yeni örnek değiştirgeleri
    • ReflectionClass::newInstanceWithoutConstructor - Creates a new class instance without invoking the constructor.
    • ReflectionClass::setStaticPropertyValue - Duruk özelliğe değer atar
    • ReflectionClass::__construct - Bir ReflectionClass nesnesi oluşturur
    • ReflectionClass::__toString - Dizgesel tepkiyi görselleştirir
    • ReflectionExtension::export - Sınıfı ihraç eder
    • ReflectionExtension::getClasses - Eklentinin sınıflarını döndürür
    • ReflectionExtension::getClassNames - Eklentide tanımlı sınıf isimlerini döndürür
    • ReflectionExtension::getConstants - Eklentinin sabitlerini döndürür
    • ReflectionExtension::getDependencies - Bağımlılıkları döndürür
    • ReflectionExtension::getFunctions - Eklenti işlevlerini döndürür
    • ReflectionExtension::getINIEntries - Eklentinin ini girdilerini döndürür
    • ReflectionExtension::getName - Eklenti ismini döndürür
    • ReflectionExtension::getVersion - Eklentinin sürüm bilgisini döndürür
    • ReflectionExtension::info - Eklenti bilgilerini döndürür
    • ReflectionExtension::isPersistent - Returns whether this extension is persistent
    • ReflectionExtension::isTemporary - Returns whether this extension is temporary
    • ReflectionExtension::__clone - Nesnenin bir kopyasını oluşturur
    • ReflectionExtension::__construct - Bir ReflectionExtension nesnesi oluşturur
    • ReflectionExtension::__toString - Dizgesel tepkiyi görselleştirir
    • ReflectionFunction::export - İşlevi ihraç eder
    • ReflectionFunction::getClosure - Returns a dynamically created closure for the function
    • ReflectionFunction::invoke - İşlevi çağırır
    • ReflectionFunction::invokeArgs - İşlev değiştirgelerini çağırır
    • ReflectionFunction::isDisabled - İşlevin iptal edilip edilmediğine bakar
    • ReflectionFunction::__construct - Bir ReflectionFunction nesnesi oluşturur
    • ReflectionFunction::__toString - Dizgesel tepkiyi görselleştirir
    • ReflectionFunctionAbstract::getClosureScopeClass - Returns the scope associated to the closure
    • ReflectionFunctionAbstract::getClosureThis - Returns this pointer bound to closure
    • ReflectionFunctionAbstract::getDocComment - Belgelendirici açıklamaları döndürür
    • ReflectionFunctionAbstract::getEndLine - Son satır numarasını döndürür
    • ReflectionFunctionAbstract::getExtension - Eklenti bilgilerini döndürür
    • ReflectionFunctionAbstract::getExtensionName - Eklenti ismini döndürür
    • ReflectionFunctionAbstract::getFileName - Dosya ismini döndürür
    • ReflectionFunctionAbstract::getName - İşlev ismini döndürür
    • ReflectionFunctionAbstract::getNamespaceName - İsim alanı adını döndürür
    • ReflectionFunctionAbstract::getNumberOfParameters - Değiştirge sayısını döndürür
    • ReflectionFunctionAbstract::getNumberOfRequiredParameters - Zorunlu değiştirge sayısını döndürür
    • ReflectionFunctionAbstract::getParameters - Değiştirgeleri döndürür
    • ReflectionFunctionAbstract::getReturnType - Gets the specified return type of a function
    • ReflectionFunctionAbstract::getShortName - İşlevin kısa ismini döndürür
    • ReflectionFunctionAbstract::getStartLine - Başlangıç satır numarasını döndürür
    • ReflectionFunctionAbstract::getStaticVariables - Duruk değişkenleri döndürür
    • ReflectionFunctionAbstract::hasReturnType - Checks if the function has a specified return type
    • ReflectionFunctionAbstract::inNamespace - İşlev isim alanına ait mi diye bakar
    • ReflectionFunctionAbstract::isClosure - Bir anonim işlev mi diye bakar
    • ReflectionFunctionAbstract::isDeprecated - Kullanımı önerilmiyor mu diye bakar
    • ReflectionFunctionAbstract::isGenerator - Returns whether this function is a generator
    • ReflectionFunctionAbstract::isInternal - İşlev yerleşik mi diye bakar
    • ReflectionFunctionAbstract::isUserDefined - İşlev kullanıcı tanımlı bir işlev mi diye bakar
    • ReflectionFunctionAbstract::isVariadic - Checks if the function is variadic
    • ReflectionFunctionAbstract::returnsReference - İşlev dönüş değeri gönderimli mi diye bakar
    • ReflectionFunctionAbstract::__clone - İşlevi kopyalar
    • ReflectionFunctionAbstract::__toString - Dizgesel tepkiyi görselleştirir
    • ReflectionMethod::export - Sınıfı ihraç eder
    • ReflectionMethod::getClosure - Returns a dynamically created closure for the method
    • ReflectionMethod::getDeclaringClass - Bildiren sınıfı döndürür
    • ReflectionMethod::getModifiers - Değiştirici sayısını döndürür
    • ReflectionMethod::getPrototype - Bildirimi döndürür
    • ReflectionMethod::invoke - Yöntemi çağırır
    • ReflectionMethod::invokeArgs - Değiştirgeleri çağırır
    • ReflectionMethod::isAbstract - Yöntem soyut mu diye bakar
    • ReflectionMethod::isConstructor - Yöntem bir kurucu mu diye bakar
    • ReflectionMethod::isDestructor - Yöntem bir yıkıcı mı diye bakar
    • ReflectionMethod::isFinal - Yöntem final olarak mı bildirilmiş diye bakar
    • ReflectionMethod::isPrivate - Yöntem private olarak mı bildirilmiş diye bakar
    • ReflectionMethod::isProtected - Yöntem protected olarak mı bildirilmiş diye bakar
    • ReflectionMethod::isPublic - Yöntem public olarak mı bildirilmiş diye bakar
    • ReflectionMethod::isStatic - Yöntem bir duruk yöntem mi diye bakar
    • ReflectionMethod::setAccessible - Set method accessibility
    • ReflectionMethod::__construct - Yeni bir ReflectionMethod nesnesi oluşturur
    • ReflectionMethod::__toString - Dizgesel tepkiyi görselleştirir
    • ReflectionObject::export - Sınıfı ihraç eder
    • ReflectionObject::__construct - Bir ReflectionObject nesnesi oluşturur
    • ReflectionParameter::allowsNull - NULL değere izin veriliyor mu diye bakar
    • ReflectionParameter::canBePassedByValue - Returns whether this parameter can be passed by value
    • ReflectionParameter::export - Sınıfı ihraç eder
    • ReflectionParameter::getClass - Sınıfı döndürür
    • ReflectionParameter::getDeclaringClass - Bildiren sınıfı döndürür
    • ReflectionParameter::getDeclaringFunction - Bildiren işlevi döndürür
    • ReflectionParameter::getDefaultValue - Değiştirgenin öntanımlı değerini döndürür
    • ReflectionParameter::getDefaultValueConstantName - Returns the default value's constant name if default value is constant or null
    • ReflectionParameter::getName - Değiştirgenin ismini döndürür
    • ReflectionParameter::getPosition - Değiştirgenin konumunu döndürür
    • ReflectionParameter::getType - Gets a parameter's type
    • ReflectionParameter::hasType - Checks if parameter has a type
    • ReflectionParameter::isArray - Değiştirge değeri bir dizi mi olacak diye bakar
    • ReflectionParameter::isCallable - Returns whether parameter MUST be callable
    • ReflectionParameter::isDefaultValueAvailable - Öntanımlı bir değerin kullanılabilir olup olmadığına bakar
    • ReflectionParameter::isDefaultValueConstant - Returns whether the default value of this parameter is constant
    • ReflectionParameter::isOptional - Değiştirge seçimlik mi diye bakar
    • ReflectionParameter::isPassedByReference - Değiştirge gönderimli aktarılabilir mi diye bakar
    • ReflectionParameter::isVariadic - Checks if the parameter is variadic
    • ReflectionParameter::__clone - Nesneyi kopyalar
    • ReflectionParameter::__construct - Bir ReflectionParameter nesnesi oluşturur
    • ReflectionParameter::__toString - Dizgesel tepkiyi görselleştirir
    • ReflectionProperty::export - Özelliği ihraç eder
    • ReflectionProperty::getDeclaringClass - Bildiren sınıfı döndürür
    • ReflectionProperty::getDocComment - Bilgilendirici açıklamaları döndürür
    • ReflectionProperty::getModifiers - Değiştirici sayısını döndürür
    • ReflectionProperty::getName - Özelliğin ismini döndürür
    • ReflectionProperty::getValue - Özelliğin değerini döndürür
    • ReflectionProperty::isDefault - Öntanımlı değer mi atanmış diye bakar
    • ReflectionProperty::isPrivate - Özellik private olarak mı bildirilmiş diye bakar
    • ReflectionProperty::isProtected - Özellik protected olarak mı bildirilmiş diye bakar
    • ReflectionProperty::isPublic - Özellik public olarak mı bildirilmiş diye bakar
    • ReflectionProperty::isStatic - Özellik duruk mu diye bakar
    • ReflectionProperty::setAccessible - Özelliği erişilebilir kılar
    • ReflectionProperty::setValue - Özelliğe değer atar
    • ReflectionProperty::__clone - Özelliği kopyalar
    • ReflectionProperty::__construct - Bir ReflectionProperty nesnesi oluşturur
    • ReflectionProperty::__toString - Dizgesel tepkiyi görselleştirir
    • Reflector::export - Sınıfı ihraç eder
    • Reflector::__toString - Dizgesel tepkiyi görselleştirir
    • RegexIterator::accept - Get accept status
    • RegexIterator::getFlags - Get flags
    • RegexIterator::getMode - Returns operation mode.
    • RegexIterator::getPregFlags - Returns the regular expression flags.
    • RegexIterator::getRegex - Returns current regular expression
    • RegexIterator::setFlags - Sets the flags.
    • RegexIterator::setMode - Sets the operation mode.
    • RegexIterator::setPregFlags - Sets the regular expression flags.
    • RegexIterator::__construct - Create a new RegexIterator
    • register_shutdown_function - Betiğin işi bittiğinde çalıştırılacak işlevi tanımlar
    • register_tick_function - Her tikte çalıştırılacak işlevi tanımlar
    • rename - Bir dosya veya dizinin ismini değiştirir
    • rename_function - Küresel işlev tablosunda bir işlevin ismini değiştirir
    • reset - Bir dizinin dahili göstericisini ilk elemana konumlar
    • restore_error_handler - Bir önceki hata eylemcisini devreye sokar
    • restore_exception_handler - Bir önceki istisna eylemcisini devreye sokar
    • restore_include_path - include_path yönergesini eski değerine ayarlar
    • rewind - Bir dosya tanıtıcısında konumu başa taşır
    • rewinddir - Dizin tanıtıcısını dizin başlangıcına konumlar
    • rmdir - Dizin siler
    • round - Rounds a float
    • rpm_close - Closes an RPM file
    • rpm_get_tag - Retrieves a header tag from an RPM file
    • rpm_is_valid - Tests a filename for validity as an RPM file
    • rpm_open - Opens an RPM file
    • rpm_version - Returns a string representing the current version of the rpmreader extension
    • RRDCreator::addArchive - Adds RRA - archive of data values for each data source.
    • RRDCreator::addDataSource - Adds data source definition for RRD database.
    • RRDCreator::save - Saves the RRD database to a file
    • RRDCreator::__construct - Creates new RRDCreator instance
    • rrdc_disconnect - Close any outstanding connection to rrd caching daemon
    • RRDGraph::save - Saves the result of query into image
    • RRDGraph::saveVerbose - Saves the RRD database query into image and returns the verbose information about generated graph.
    • RRDGraph::setOptions - Sets the options for rrd graph export
    • RRDGraph::__construct - Creates new RRDGraph instance
    • RRDUpdater::update - Update the RRD database file
    • RRDUpdater::__construct - Creates new RRDUpdater instance
    • rrd_create - Creates rrd database file
    • rrd_error - Gets latest error message.
    • rrd_fetch - Fetch the data for graph as array.
    • rrd_first - Gets the timestamp of the first sample from rrd file.
    • rrd_graph - Creates image from a data.
    • rrd_info - Gets information about rrd file
    • rrd_last - Gets unix timestamp of the last sample.
    • rrd_lastupdate - Gets information about last updated data.
    • rrd_restore - Restores the RRD file from XML dump.
    • rrd_tune - Tunes some RRD database file header options.
    • rrd_update - Updates the RRD database.
    • rrd_version - Gets information about underlying rrdtool library
    • rrd_xport - Exports the information about RRD database.
    • rsort - Bir diziyi tersine sıralar
    • rtrim - Dizgenin sonundaki boşlukları (veya diğer karakterleri) budar
    • runkit_class_adopt - Convert a base class to an inherited class, add ancestral methods when appropriate
    • runkit_class_emancipate - Convert an inherited class to a base class, removes any method whose scope is ancestral
    • runkit_constant_add - Similar to define(), but allows defining in class definitions as well
    • runkit_constant_redefine - Redefine an already defined constant
    • runkit_constant_remove - Remove/Delete an already defined constant
    • runkit_function_add - Add a new function, similar to create_function
    • runkit_function_copy - Copy a function to a new function name
    • runkit_function_redefine - Replace a function definition with a new implementation
    • runkit_function_remove - Remove a function definition
    • runkit_function_rename - Change a function's name
    • runkit_import - Process a PHP file importing function and class definitions, overwriting where appropriate
    • runkit_lint - Check the PHP syntax of the specified php code
    • runkit_lint_file - Check the PHP syntax of the specified file
    • runkit_method_add - Dynamically adds a new method to a given class
    • runkit_method_copy - Copies a method from class to another
    • runkit_method_redefine - Dynamically changes the code of the given method
    • runkit_method_remove - Dynamically removes the given method
    • runkit_method_rename - Dynamically changes the name of the given method
    • runkit_return_value_used - Determines if the current functions return value will be used
    • Runkit_Sandbox - Runkit Sandbox Class -- PHP Virtual Machine
    • runkit_sandbox_output_handler - Specify a function to capture and/or process output from a runkit sandbox
    • Runkit_Sandbox_Parent - Runkit Anti-Sandbox Class
    • runkit_superglobals - Return numerically indexed array of registered superglobals
  • s
    • SAMConnection::commit - Commits (completes) the current unit of work.
    • SAMConnection::connect - Establishes a connection to a Messaging Server
    • SAMConnection::disconnect - Disconnects from a Messaging Server
    • SAMConnection::errno - Contains the unique numeric error code of the last executed SAM operation.
    • SAMConnection::error - Contains the text description of the last failed SAM operation.
    • SAMConnection::isConnected - Queries whether a connection is established to a Messaging Server
    • SAMConnection::peek - Read a message from a queue without removing it from the queue.
    • SAMConnection::peekAll - Read one or more messages from a queue without removing it from the queue.
    • SAMConnection::receive - Receive a message from a queue or subscription.
    • SAMConnection::remove - Remove a message from a queue.
    • SAMConnection::rollback - Cancels (rolls back) an in-flight unit of work.
    • SAMConnection::send - Send a message to a queue or publish an item to a topic.
    • SAMConnection::setDebug - Turn on or off additional debugging output.
    • SAMConnection::subscribe - Create a subscription to a specified topic.
    • SAMConnection::unsubscribe - Cancel a subscription to a specified topic.
    • SAMConnection::__construct - Creates a new connection to a Messaging Server
    • SAMMessage::body - The body of the message.
    • SAMMessage::header - The header properties of the message.
    • SAMMessage::__construct - Creates a new Message object
    • SCA::createDataObject - create an SDO
    • SCA::getService - Obtain a proxy for a service
    • scandir - Belirtilen dizindeki alt dizinleri ve dosyaları listeler
    • SCA_LocalProxy::createDataObject - create an SDO
    • SCA_SoapProxy::createDataObject - create an SDO
    • SDO_DAS_ChangeSummary::beginLogging - Begin change logging
    • SDO_DAS_ChangeSummary::endLogging - End change logging
    • SDO_DAS_ChangeSummary::getChangedDataObjects - Get the changed data objects from a change summary
    • SDO_DAS_ChangeSummary::getChangeType - Get the type of change made to an SDO_DataObject
    • SDO_DAS_ChangeSummary::getOldContainer - Get the old container for a deleted SDO_DataObject
    • SDO_DAS_ChangeSummary::getOldValues - Get the old values for a given changed SDO_DataObject
    • SDO_DAS_ChangeSummary::isLogging - Test to see whether change logging is switched on
    • SDO_DAS_DataFactory::addPropertyToType - Adds a property to a type
    • SDO_DAS_DataFactory::addType - Add a new type to a model
    • SDO_DAS_DataFactory::getDataFactory - Get a data factory instance
    • SDO_DAS_DataObject::getChangeSummary - Get a data object's change summary
    • SDO_DAS_Relational::applyChanges - Applies the changes made to a data graph back to the database.
    • SDO_DAS_Relational::createRootDataObject - Returns the special root object in an otherwise empty data graph. Used when creating a data graph from scratch.
    • SDO_DAS_Relational::executePreparedQuery - Executes an SQL query passed as a prepared statement, with a list of values to substitute for placeholders, and return the results as a normalised data graph.
    • SDO_DAS_Relational::executeQuery - Executes a given SQL query against a relational database and returns the results as a normalised data graph.
    • SDO_DAS_Relational::__construct - Creates an instance of a Relational Data Access Service
    • SDO_DAS_Setting::getListIndex - Get the list index for a changed many-valued property
    • SDO_DAS_Setting::getPropertyIndex - Get the property index for a changed property
    • SDO_DAS_Setting::getPropertyName - Get the property name for a changed property
    • SDO_DAS_Setting::getValue - Get the old value for the changed property
    • SDO_DAS_Setting::isSet - Test whether a property was set prior to being modified
    • SDO_DAS_XML::addTypes - To load a second or subsequent schema file to a SDO_DAS_XML object
    • SDO_DAS_XML::create - To create SDO_DAS_XML object for a given schema file
    • SDO_DAS_XML::createDataObject - Creates SDO_DataObject for a given namespace URI and type name
    • SDO_DAS_XML::createDocument - Creates an XML Document object from scratch, without the need to load a document from a file or string.
    • SDO_DAS_XML::loadFile - Returns SDO_DAS_XML_Document object for a given path to xml instance document
    • SDO_DAS_XML::loadString - Returns SDO_DAS_XML_Document for a given xml instance string
    • SDO_DAS_XML::saveFile - Saves the SDO_DAS_XML_Document object to a file
    • SDO_DAS_XML::saveString - Saves the SDO_DAS_XML_Document object to a string
    • SDO_DAS_XML_Document::getRootDataObject - Returns the root SDO_DataObject
    • SDO_DAS_XML_Document::getRootElementName - Returns root element's name
    • SDO_DAS_XML_Document::getRootElementURI - Returns root element's URI string
    • SDO_DAS_XML_Document::setEncoding - Sets the given string as encoding
    • SDO_DAS_XML_Document::setXMLDeclaration - Sets the xml declaration
    • SDO_DAS_XML_Document::setXMLVersion - Sets the given string as xml version
    • SDO_DataFactory::create - Create an SDO_DataObject
    • SDO_DataObject::clear - Clear an SDO_DataObject's properties
    • SDO_DataObject::createDataObject - Create a child SDO_DataObject
    • SDO_DataObject::getContainer - Get a data object's container
    • SDO_DataObject::getSequence - Get the sequence for a data object
    • SDO_DataObject::getTypeName - Return the name of the type for a data object.
    • SDO_DataObject::getTypeNamespaceURI - Return the namespace URI of the type for a data object.
    • SDO_Exception::getCause - Get the cause of the exception.
    • SDO_List::insert - Insert into a list
    • SDO_Model_Property::getContainingType - Get the SDO_Model_Type which contains this property
    • SDO_Model_Property::getDefault - Get the default value for the property
    • SDO_Model_Property::getName - Get the name of the SDO_Model_Property
    • SDO_Model_Property::getType - Get the SDO_Model_Type of the property
    • SDO_Model_Property::isContainment - Test to see if the property defines a containment relationship
    • SDO_Model_Property::isMany - Test to see if the property is many-valued
    • SDO_Model_ReflectionDataObject::export - Get a string describing the SDO_DataObject.
    • SDO_Model_ReflectionDataObject::getContainmentProperty - Get the property which defines the containment relationship to the data object
    • SDO_Model_ReflectionDataObject::getInstanceProperties - Get the instance properties of the SDO_DataObject
    • SDO_Model_ReflectionDataObject::getType - Get the SDO_Model_Type for the SDO_DataObject
    • SDO_Model_ReflectionDataObject::__construct - Construct an SDO_Model_ReflectionDataObject
    • SDO_Model_Type::getBaseType - Get the base type for this type
    • SDO_Model_Type::getName - Get the name of the type
    • SDO_Model_Type::getNamespaceURI - Get the namespace URI of the type
    • SDO_Model_Type::getProperties - Get the SDO_Model_Property objects defined for the type
    • SDO_Model_Type::getProperty - Get an SDO_Model_Property of the type
    • SDO_Model_Type::isAbstractType - Test to see if this SDO_Model_Type is an abstract data type
    • SDO_Model_Type::isDataType - Test to see if this SDO_Model_Type is a primitive data type
    • SDO_Model_Type::isInstance - Test for an SDO_DataObject being an instance of this SDO_Model_Type
    • SDO_Model_Type::isOpenType - Test to see if this type is an open type
    • SDO_Model_Type::isSequencedType - Test to see if this is a sequenced type
    • SDO_Sequence::getProperty - Return the property for the specified sequence index.
    • SDO_Sequence::insert - Insert into a sequence
    • SDO_Sequence::move - Move an item to another sequence position
    • SeekableIterator::seek - Seeks to a position
    • sem_acquire - Acquire a semaphore
    • sem_get - Get a semaphore id
    • sem_release - Release a semaphore
    • sem_remove - Remove a semaphore
    • Serializable::serialize - Nesnenin dizgesel gösterimiyle döner
    • Serializable::unserialize - Dizgeleştirilmiş nesneyi yeniden oluşturur
    • serialize - Bir değerin saklanabilir bir gösterimini üretir
    • SessionHandler::close - Close the session
    • SessionHandler::create_sid - Return a new session ID
    • SessionHandler::destroy - Destroy a session
    • SessionHandler::gc - Cleanup old sessions
    • SessionHandler::open - Initialize session
    • SessionHandler::read - Read session data
    • SessionHandler::write - Write session data
    • SessionHandlerInterface::close - Close the session
    • SessionHandlerInterface::destroy - Destroy a session
    • SessionHandlerInterface::gc - Cleanup old sessions
    • SessionHandlerInterface::open - Initialize session
    • SessionHandlerInterface::read - Read session data
    • SessionHandlerInterface::write - Write session data
    • session_abort - Discard session array changes and finish session
    • session_cache_expire - Önbelleğe alınan oturumun ömrünü döndürür
    • session_cache_limiter - Geçerli önbellek sınırlayıcısını döndürür ve/veya tanımlar
    • session_commit - session_write_close işlevinin takma adıdır
    • session_create_id - Create new session id
    • session_decode - Oturum verisini bir dizgeden elde eder
    • session_destroy - Bir oturumla ilişkilendirilmiş tüm veriyi yokeder
    • session_encode - Geçerli oturum verisini bir dizge olarak kodlar
    • session_gc - Perform session data garbage collection
    • session_get_cookie_params - Oturum çerezi değiştirgelerini döndürür
    • session_id - Geçerli oturum kimliğini döndürür ve/veya tanımlar
    • session_is_registered - Bir küresel değişkenin oturumda kayıtlı olup olmadığına bakar
    • session_module_name - Geçerli oturum modülünü döndürür ve/veya tanımlar
    • session_name - Geçerli oturum ismini döndürür ve/veya tanımlar
    • session_pgsql_add_error - Increments error counts and sets last error message
    • session_pgsql_get_error - Returns number of errors and last error message
    • session_pgsql_get_field - Get custom field value
    • session_pgsql_reset - Reset connection to session database servers
    • session_pgsql_set_field - Set custom field value
    • session_pgsql_status - Get current save handler status
    • session_regenerate_id - Geçerli oturum kimliğini yenisiyle değiştirir
    • session_register - Geçerli oturuma bir veya daha fazla küresel değişkeni kaydeder
    • session_register_shutdown - Session shutdown function
    • session_reset - Re-initialize session array with original values
    • session_save_path - Geçerli oturum kayıt yolunu tanımlar ve/veya döndürür
    • session_set_cookie_params - Oturum çerezi değiştirgelerini tanımlar
    • session_set_save_handler - Kullanıcı seviyesi oturum saklama işlevlerini bildirir
    • session_start - Oturum verisini ilklendirir
    • session_status - Returns the current session status
    • session_unregister - Geçerli oturumdaki bir küresel değişkeni kayıtdışı yapar
    • session_unset - Free all session variables
    • session_write_close - Oturum verisini yazıp oturumu kapatır
    • setcookie - Bir çerez gönderir
    • setlocale - Yereli ayarlar
    • setproctitle - Set the process title
    • setrawcookie - Bir çerezi değerini URL kodlamasından geçirmeden gönderir
    • setthreadtitle - Set the thread title
    • settype - Bir değişkenin türünü belirler
    • set_error_handler - Kullanıcı tanımlı bir hata eylemcisi bildirir
    • set_exception_handler - Kullanıcı tanımlı bir istisna eylemcisi bildirir
    • set_file_buffer - stream_set_write_buffer işlevinin takma adıdır
    • set_include_path - include_path yönergesinin çalışma anı değerini belirler
    • set_magic_quotes_runtime - magic_quotes_runtime yönergesinin çalışma anı değerini belirler
    • set_socket_blocking - Takma Adı: stream_set_blocking
    • set_time_limit - Azami çalıştırma süresini sınırlar
    • sha1 - Bir dizgenin sha1 özetini hesaplar
    • sha1_file - Bir dosyanın sha1 özetini hesaplar
    • shell_exec - Komutu kabukta çalıştırır ve çıktısının tamamını bir dizge olarak döndürür
    • shmop_close - Close shared memory block
    • shmop_delete - Delete shared memory block
    • shmop_open - Create or open shared memory block
    • shmop_read - Read data from shared memory block
    • shmop_size - Get size of shared memory block
    • shmop_write - Write data into shared memory block
    • shm_attach - Creates or open a shared memory segment
    • shm_detach - Disconnects from shared memory segment
    • shm_get_var - Returns a variable from shared memory
    • shm_has_var - Check whether a specific entry exists
    • shm_put_var - Inserts or updates a variable in shared memory
    • shm_remove - Removes shared memory from Unix systems
    • shm_remove_var - Removes a variable from shared memory
    • show_source - highlight_file işlevinin takma adıdır
    • shuffle - Bir diziyi karar
    • similar_text - İki dizge arasındaki benzerliği hesaplar
    • SimpleXMLElement::addAttribute - XML elemanına bir öznitelik ekler
    • SimpleXMLElement::addChild - XML düğümüne bir çocuk düğüm ekler
    • SimpleXMLElement::asXML - Nesnenin içerdiği belgeyi iyi biçemli bir XML dizge olarak döndürür
    • SimpleXMLElement::attributes - Bir elemanın özniteliklerine erişim sağlar
    • SimpleXMLElement::children - Belirtilen düğümün çocuklarını bulur
    • SimpleXMLElement::count - Counts the children of an element
    • SimpleXMLElement::getDocNamespaces - Belgede bildirilmiş isim alanlarını döndürür
    • SimpleXMLElement::getName - XML eleman ismi döndürür
    • SimpleXMLElement::getNamespaces - Belgede kullanılan isim alanlarını döndürür
    • SimpleXMLElement::registerXPathNamespace - Sonraki XPath ifadesi için bir önek/isim alanı bağlamı oluşturur
    • SimpleXMLElement::saveXML - Takma Adı: SimpleXMLElement::asXML
    • SimpleXMLElement::xpath - Bir XML veri üzerinde bir XPath sorgusu çalıştırır
    • SimpleXMLElement::__construct - Yeni bir SimpleXMLElement nesnesi oluşturur
    • SimpleXMLElement::__toString - Returns the string content
    • simplexml_import_dom - Bir DOM düğümü alıp bir SimpleXMLElement nesnesi döndürür
    • simplexml_load_file - Bir XML dosyasının içeriğini bir nesne haline getirir
    • simplexml_load_string - Bir XML dizgesini bir nesne haline getirir
    • sin - Sine
    • sinh - Hyperbolic sine
    • sizeof - count işlevinin takma adıdır
    • sleep - Çalışmayı geciktirir
    • snmp2_get - Fetch an SNMP object
    • snmp2_getnext - Fetch the SNMP object which follows the given object id
    • snmp2_real_walk - Return all objects including their respective object ID within the specified one
    • snmp2_set - Set the value of an SNMP object
    • snmp2_walk - Fetch all the SNMP objects from an agent
    • snmp3_get - Fetch an SNMP object
    • snmp3_getnext - Fetch the SNMP object which follows the given object id
    • snmp3_real_walk - Return all objects including their respective object ID within the specified one
    • snmp3_set - Set the value of an SNMP object
    • snmp3_walk - Fetch all the SNMP objects from an agent
    • SNMP::close - Close SNMP session
    • SNMP::get - Fetch an SNMP object
    • SNMP::getErrno - Get last error code
    • SNMP::getError - Get last error message
    • SNMP::getnext - Fetch an SNMP object which follows the given object id
    • SNMP::set - Set the value of an SNMP object
    • SNMP::setSecurity - Configures security-related SNMPv3 session parameters
    • SNMP::walk - Fetch SNMP object subtree
    • SNMP::__construct - Creates SNMP instance representing session to remote SNMP agent
    • snmpget - Fetch an SNMP object
    • snmpgetnext - Fetch the SNMP object which follows the given object id
    • snmprealwalk - Return all objects including their respective object ID within the specified one
    • snmpset - Set the value of an SNMP object
    • snmpwalk - Fetch all the SNMP objects from an agent
    • snmpwalkoid - Query for a tree of information about a network entity
    • snmp_get_quick_print - Fetches the current value of the UCD library's quick_print setting
    • snmp_get_valueretrieval - Return the method how the SNMP values will be returned
    • snmp_read_mib - Reads and parses a MIB file into the active MIB tree
    • snmp_set_enum_print - Return all values that are enums with their enum value instead of the raw integer
    • snmp_set_oid_numeric_print - Set the OID output format
    • snmp_set_oid_output_format - Set the OID output format
    • snmp_set_quick_print - Set the value of quick_print within the UCD SNMP library
    • snmp_set_valueretrieval - Specify the method how the SNMP values will be returned
    • SoapClient::SoapClient - SoapClient constructor
    • SoapClient::__call - Calls a SOAP function (deprecated)
    • SoapClient::__construct - SoapClient constructor
    • SoapClient::__doRequest - Performs a SOAP request
    • SoapClient::__getFunctions - Returns list of available SOAP functions
    • SoapClient::__getLastRequest - Returns last SOAP request
    • SoapClient::__getLastRequestHeaders - Returns the SOAP headers from the last request
    • SoapClient::__getLastResponse - Returns last SOAP response
    • SoapClient::__getLastResponseHeaders - Returns the SOAP headers from the last response
    • SoapClient::__getTypes - Returns a list of SOAP types
    • SoapClient::__setCookie - The __setCookie purpose
    • SoapClient::__setLocation - Sets the location of the Web service to use
    • SoapClient::__setSoapHeaders - Sets SOAP headers for subsequent calls
    • SoapClient::__soapCall - Calls a SOAP function
    • SoapFault::SoapFault - SoapFault constructor
    • SoapFault::__construct - SoapFault constructor
    • SoapFault::__toString - Obtain a string representation of a SoapFault
    • SoapHeader::SoapHeader - SoapHeader constructor
    • SoapHeader::__construct - SoapHeader constructor
    • SoapParam::SoapParam - SoapParam constructor
    • SoapParam::__construct - SoapParam constructor
    • SoapServer::addFunction - Adds one or more functions to handle SOAP requests
    • SoapServer::addSoapHeader - Add a SOAP header to the response
    • SoapServer::fault - Issue SoapServer fault indicating an error
    • SoapServer::getFunctions - Returns list of defined functions
    • SoapServer::handle - Handles a SOAP request
    • SoapServer::setClass - Sets the class which handles SOAP requests
    • SoapServer::setObject - Sets the object which will be used to handle SOAP requests
    • SoapServer::setPersistence - Sets SoapServer persistence mode
    • SoapServer::SoapServer - SoapServer constructor
    • SoapServer::__construct - SoapServer constructor
    • SoapVar::SoapVar - SoapVar constructor
    • SoapVar::__construct - SoapVar constructor
    • socket_accept - Soket üzerinden bağlantı kabul eder
    • socket_bind - Soketi bir isimle ilişkilendirir
    • socket_clear_error - Soket üzerindeki hatayı veya son hata kodunu siler
    • socket_close - Bir soket özkaynağını serbest bırakır
    • socket_cmsg_space - Calculate message buffer size
    • socket_connect - Soket üzerinde bir bağlantıyı ilklendirir
    • socket_create - Bir soket oluşturur (iletişim için bir uç)
    • socket_create_listen - Bağlantı kabul etmek için port üzerinde bir soket açar
    • socket_create_pair - Ayrılması olanaksız bir soket çifti oluşturur ve bunları bir dizide saklar
    • socket_getopt - Takma Adı: socket_get_option
    • socket_getpeername - Belirtilen soketin yerel tarafını sorgulayıp soket türüne göre ya bir konak/port çifti ya da bir Unix dosya yolu döndürür
    • socket_getsockname - Belirtilen soketin yerel tarafını sorgulayıp soket türüne göre ya bir konak/port çifti ya da bir Unix dosya yolu döndürür
    • socket_get_option - Soketle ilgili bir seçeneğin değerini döndürür
    • socket_get_status - Takma Adı: stream_get_meta_data
    • socket_import_stream - Import a stream
    • socket_last_error - Soket üzerindeki son hatanın kodunu döndürür
    • socket_listen - Bir soketi bağlantı kabul etmek için dinler
    • socket_read - Bir soketten belli sayıda bayta kadar okuma yapar
    • socket_recv - Bağlı bir soketten veri alır
    • socket_recvfrom - Bağlantılı olsun olmasın bir soketten veri alır
    • socket_recvmsg - Read a message
    • socket_select - Belirtilen soket dizileri üzerinde belirtilen zaman aşımı ile select() sistem çağrısını çalıştırır
    • socket_send - Bağlı bir sokete veri gönderir
    • socket_sendmsg - Send a message
    • socket_sendto - Bağlı olsun olmasın bir sokete ileti gönderir
    • socket_setopt - Takma Adı: socket_set_option
    • socket_set_block - Soketi engelleme kipine sokar
    • socket_set_blocking - Takma Adı: stream_set_blocking
    • socket_set_nonblock - Belirtilen dosya tanıtıcısı için beklememe kipini etkinleştirir
    • socket_set_option - Soketle ilgili seçenekleri belirler
    • socket_set_timeout - Takma Adı: stream_set_timeout
    • socket_shutdown - Bir soketi kapatır
    • socket_strerror - Bir soket hatasıyla ilgili açıklamayı döndürür
    • socket_write - Bir sokete yazar
    • Soket bağlamı seçenekleri - Soket bağlamı seçeneklerinin listesi
    • SolrClient::addDocument - Adds a document to the index
    • SolrClient::addDocuments - Adds a collection of SolrInputDocument instances to the index
    • SolrClient::commit - Finalizes all add/deletes made to the index
    • SolrClient::deleteById - Delete by Id
    • SolrClient::deleteByIds - Deletes by Ids
    • SolrClient::deleteByQueries - Removes all documents matching any of the queries
    • SolrClient::deleteByQuery - Deletes all documents matching the given query
    • SolrClient::getById - Get Document By Id. Utilizes Solr Realtime Get (RTG).
    • SolrClient::getByIds - Get Documents by their Ids. Utilizes Solr Realtime Get (RTG).
    • SolrClient::getDebug - Returns the debug data for the last connection attempt
    • SolrClient::getOptions - Returns the client options set internally
    • SolrClient::optimize - Defragments the index
    • SolrClient::ping - Checks if Solr server is still up
    • SolrClient::query - Sends a query to the server
    • SolrClient::request - Sends a raw update request
    • SolrClient::rollback - Rollbacks all add/deletes made to the index since the last commit
    • SolrClient::setResponseWriter - Sets the response writer used to prepare the response from Solr
    • SolrClient::setServlet - Changes the specified servlet type to a new value
    • SolrClient::system - Retrieve Solr Server information
    • SolrClient::threads - Checks the threads status
    • SolrClient::__construct - Constructor for the SolrClient object
    • SolrClient::__destruct - Destructor for SolrClient
    • SolrClientException::getInternalInfo - Returns internal information where the Exception was thrown
    • SolrCollapseFunction::getField - Returns the field that is being collapsed on.
    • SolrCollapseFunction::getHint - Returns collapse hint
    • SolrCollapseFunction::getMax - Returns max parameter
    • SolrCollapseFunction::getMin - Returns min parameter
    • SolrCollapseFunction::getNullPolicy - Returns null policy
    • SolrCollapseFunction::getSize - Returns size parameter
    • SolrCollapseFunction::setField - Sets the field to collapse on
    • SolrCollapseFunction::setHint - Sets collapse hint
    • SolrCollapseFunction::setMax - Selects the group heads by the max value of a numeric field or function query.
    • SolrCollapseFunction::setMin - Sets the initial size of the collapse data structures when collapsing on a numeric field only
    • SolrCollapseFunction::setNullPolicy - Sets the NULL Policy
    • SolrCollapseFunction::setSize - Sets the initial size of the collapse data structures when collapsing on a numeric field only.
    • SolrCollapseFunction::__construct - Constructor
    • SolrCollapseFunction::__toString - Returns a string representing the constructed collapse function
    • SolrDisMaxQuery::addBigramPhraseField - Adds a Phrase Bigram Field (pf2 parameter)
    • SolrDisMaxQuery::addBoostQuery - Adds a boost query field with value and optional boost (bq parameter)
    • SolrDisMaxQuery::addPhraseField - Adds a Phrase Field (pf parameter)
    • SolrDisMaxQuery::addQueryField - Add a query field with optional boost (qf parameter)
    • SolrDisMaxQuery::addTrigramPhraseField - Adds a Trigram Phrase Field (pf3 parameter)
    • SolrDisMaxQuery::addUserField - Adds a field to User Fields Parameter (uf)
    • SolrDisMaxQuery::removeBigramPhraseField - Removes phrase bigram field (pf2 parameter)
    • SolrDisMaxQuery::removeBoostQuery - Removes a boost query partial by field name (bq)
    • SolrDisMaxQuery::removePhraseField - Removes a Phrase Field (pf parameter)
    • SolrDisMaxQuery::removeQueryField - Removes a Query Field (qf parameter)
    • SolrDisMaxQuery::removeTrigramPhraseField - Removes a Trigram Phrase Field (pf3 parameter)
    • SolrDisMaxQuery::removeUserField - Removes a field from The User Fields Parameter (uf)
    • SolrDisMaxQuery::setBigramPhraseFields - Sets Bigram Phrase Fields and their boosts (and slops) using pf2 parameter
    • SolrDisMaxQuery::setBigramPhraseSlop - Sets Bigram Phrase Slop (ps2 parameter)
    • SolrDisMaxQuery::setBoostFunction - Sets a Boost Function (bf parameter).
    • SolrDisMaxQuery::setBoostQuery - Directly Sets Boost Query Parameter (bq)
    • SolrDisMaxQuery::setMinimumMatch - Set Minimum "Should" Match (mm)
    • SolrDisMaxQuery::setPhraseFields - Sets Phrase Fields and their boosts (and slops) using pf2 parameter
    • SolrDisMaxQuery::setPhraseSlop - Sets the default slop on phrase queries (ps parameter)
    • SolrDisMaxQuery::setQueryAlt - Set Query Alternate (q.alt parameter)
    • SolrDisMaxQuery::setQueryPhraseSlop - specifies the amount of slop permitted on phrase queries explicitly included in the user's query string (qf parameter)
    • SolrDisMaxQuery::setTieBreaker - Sets Tie Breaker parameter (tie parameter)
    • SolrDisMaxQuery::setTrigramPhraseFields - Directly Sets Trigram Phrase Fields (pf3 parameter)
    • SolrDisMaxQuery::setTrigramPhraseSlop - Sets Trigram Phrase Slop (ps3 parameter)
    • SolrDisMaxQuery::setUserFields - Sets User Fields parameter (uf)
    • SolrDisMaxQuery::useDisMaxQueryParser - Switch QueryParser to be DisMax Query Parser
    • SolrDisMaxQuery::useEDisMaxQueryParser - Switch QueryParser to be EDisMax
    • SolrDisMaxQuery::__construct - Class Constructor
    • SolrDocument::addField - Adds a field to the document
    • SolrDocument::clear - Drops all the fields in the document
    • SolrDocument::current - Retrieves the current field
    • SolrDocument::deleteField - Removes a field from the document
    • SolrDocument::fieldExists - Checks if a field exists in the document
    • SolrDocument::getChildDocuments - Returns an array of child documents (SolrDocument)
    • SolrDocument::getChildDocumentsCount - Returns the number of child documents
    • SolrDocument::getField - Retrieves a field by name
    • SolrDocument::getFieldCount - Returns the number of fields in this document
    • SolrDocument::getFieldNames - Returns an array of fields names in the document
    • SolrDocument::getInputDocument - Returns a SolrInputDocument equivalent of the object
    • SolrDocument::hasChildDocuments - Checks whether the document has any child documents
    • SolrDocument::key - Retrieves the current key
    • SolrDocument::merge - Merges source to the current SolrDocument
    • SolrDocument::next - Moves the internal pointer to the next field
    • SolrDocument::offsetExists - Checks if a particular field exists
    • SolrDocument::offsetGet - Retrieves a field
    • SolrDocument::offsetSet - Adds a field to the document
    • SolrDocument::offsetUnset - Removes a field
    • SolrDocument::reset - This is an alias to SolrDocument::clear()
    • SolrDocument::rewind - Resets the internal pointer to the beginning
    • SolrDocument::serialize - Used for custom serialization
    • SolrDocument::sort - Sorts the fields in the document
    • SolrDocument::toArray - Returns an array representation of the document
    • SolrDocument::unserialize - Custom serialization of SolrDocument objects
    • SolrDocument::valid - Checks if the current position internally is still valid
    • SolrDocument::__clone - Creates a copy of a SolrDocument object
    • SolrDocument::__construct - Constructor
    • SolrDocument::__destruct - Destructor
    • SolrDocument::__get - Access the field as a property
    • SolrDocument::__isset - Checks if a field exists
    • SolrDocument::__set - Adds another field to the document
    • SolrDocument::__unset - Removes a field from the document
    • SolrDocumentField::__construct - Constructor
    • SolrDocumentField::__destruct - Destructor
    • SolrException::getInternalInfo - Returns internal information where the Exception was thrown
    • SolrGenericResponse::__construct - Constructor
    • SolrGenericResponse::__destruct - Destructor
    • SolrIllegalArgumentException::getInternalInfo - Returns internal information where the Exception was thrown
    • SolrIllegalOperationException::getInternalInfo - Returns internal information where the Exception was thrown
    • SolrInputDocument::addChildDocument - Adds a child document for block indexing
    • SolrInputDocument::addChildDocuments - Adds an array of child documents
    • SolrInputDocument::addField - Adds a field to the document
    • SolrInputDocument::clear - Resets the input document
    • SolrInputDocument::deleteField - Removes a field from the document
    • SolrInputDocument::fieldExists - Checks if a field exists
    • SolrInputDocument::getBoost - Retrieves the current boost value for the document
    • SolrInputDocument::getChildDocuments - Returns an array of child documents (SolrInputDocument)
    • SolrInputDocument::getChildDocumentsCount - Returns the number of child documents
    • SolrInputDocument::getField - Retrieves a field by name
    • SolrInputDocument::getFieldBoost - Retrieves the boost value for a particular field
    • SolrInputDocument::getFieldCount - Returns the number of fields in the document
    • SolrInputDocument::getFieldNames - Returns an array containing all the fields in the document
    • SolrInputDocument::hasChildDocuments - Returns true if the document has any child documents
    • SolrInputDocument::merge - Merges one input document into another
    • SolrInputDocument::reset - This is an alias of SolrInputDocument::clear
    • SolrInputDocument::setBoost - Sets the boost value for this document
    • SolrInputDocument::setFieldBoost - Sets the index-time boost value for a field
    • SolrInputDocument::sort - Sorts the fields within the document
    • SolrInputDocument::toArray - Returns an array representation of the input document
    • SolrInputDocument::__clone - Creates a copy of a SolrDocument
    • SolrInputDocument::__construct - Constructor
    • SolrInputDocument::__destruct - Destructor
    • SolrModifiableParams::__construct - Constructor
    • SolrModifiableParams::__destruct - Destructor
    • SolrObject::getPropertyNames - Returns an array of all the names of the properties
    • SolrObject::offsetExists - Checks if the property exists
    • SolrObject::offsetGet - Used to retrieve a property
    • SolrObject::offsetSet - Sets the value for a property
    • SolrObject::offsetUnset - Unsets the value for the property
    • SolrObject::__construct - Creates Solr object
    • SolrObject::__destruct - Destructor
    • SolrParams::add - This is an alias for SolrParams::addParam
    • SolrParams::addParam - Adds a parameter to the object
    • SolrParams::get - This is an alias for SolrParams::getParam
    • SolrParams::getParam - Returns a parameter value
    • SolrParams::getParams - Returns an array of non URL-encoded parameters
    • SolrParams::getPreparedParams - Returns an array of URL-encoded parameters
    • SolrParams::serialize - Used for custom serialization
    • SolrParams::set - An alias of SolrParams::setParam
    • SolrParams::setParam - Sets the parameter to the specified value
    • SolrParams::toString - Returns all the name-value pair parameters in the object
    • SolrParams::unserialize - Used for custom serialization
    • SolrPingResponse::getResponse - Returns the response from the server
    • SolrPingResponse::__construct - Constructor
    • SolrPingResponse::__destruct - Destructor
    • SolrQuery::addExpandFilterQuery - Overrides main filter query, determines which documents to include in the main group.
    • SolrQuery::addExpandSortField - Orders the documents within the expanded groups (expand.sort parameter).
    • SolrQuery::addFacetDateField - Maps to facet.date
    • SolrQuery::addFacetDateOther - Adds another facet.date.other parameter
    • SolrQuery::addFacetField - Adds another field to the facet
    • SolrQuery::addFacetQuery - Adds a facet query
    • SolrQuery::addField - Specifies which fields to return in the result
    • SolrQuery::addFilterQuery - Specifies a filter query
    • SolrQuery::addGroupField - Add a field to be used to group results.
    • SolrQuery::addGroupFunction - Allows grouping results based on the unique values of a function query (group.func parameter).
    • SolrQuery::addGroupQuery - Allows grouping of documents that match the given query.
    • SolrQuery::addGroupSortField - Add a group sort field (group.sort parameter).
    • SolrQuery::addHighlightField - Maps to hl.fl
    • SolrQuery::addMltField - Sets a field to use for similarity
    • SolrQuery::addMltQueryField - Maps to mlt.qf
    • SolrQuery::addSortField - Used to control how the results should be sorted
    • SolrQuery::addStatsFacet - Requests a return of sub results for values within the given facet
    • SolrQuery::addStatsField - Maps to stats.field parameter
    • SolrQuery::collapse - Collapses the result set to a single document per group
    • SolrQuery::getExpand - Returns true if group expanding is enabled
    • SolrQuery::getExpandFilterQueries - Returns the expand filter queries
    • SolrQuery::getExpandQuery - Returns the expand query expand.q parameter
    • SolrQuery::getExpandRows - Returns The number of rows to display in each group (expand.rows)
    • SolrQuery::getExpandSortFields - Returns an array of fields
    • SolrQuery::getFacet - Returns the value of the facet parameter
    • SolrQuery::getFacetDateEnd - Returns the value for the facet.date.end parameter
    • SolrQuery::getFacetDateFields - Returns all the facet.date fields
    • SolrQuery::getFacetDateGap - Returns the value of the facet.date.gap parameter
    • SolrQuery::getFacetDateHardEnd - Returns the value of the facet.date.hardend parameter
    • SolrQuery::getFacetDateOther - Returns the value for the facet.date.other parameter
    • SolrQuery::getFacetDateStart - Returns the lower bound for the first date range for all date faceting on this field
    • SolrQuery::getFacetFields - Returns all the facet fields
    • SolrQuery::getFacetLimit - Returns the maximum number of constraint counts that should be returned for the facet fields
    • SolrQuery::getFacetMethod - Returns the value of the facet.method parameter
    • SolrQuery::getFacetMinCount - Returns the minimum counts for facet fields should be included in the response
    • SolrQuery::getFacetMissing - Returns the current state of the facet.missing parameter
    • SolrQuery::getFacetOffset - Returns an offset into the list of constraints to be used for pagination
    • SolrQuery::getFacetPrefix - Returns the facet prefix
    • SolrQuery::getFacetQueries - Returns all the facet queries
    • SolrQuery::getFacetSort - Returns the facet sort type
    • SolrQuery::getFields - Returns the list of fields that will be returned in the response
    • SolrQuery::getFilterQueries - Returns an array of filter queries
    • SolrQuery::getGroup - Returns true if grouping is enabled
    • SolrQuery::getGroupCachePercent - Returns group cache percent value
    • SolrQuery::getGroupFacet - Returns the group.facet parameter value
    • SolrQuery::getGroupFields - Returns group fields (group.field parameter values)
    • SolrQuery::getGroupFormat - Returns the group.format value
    • SolrQuery::getGroupFunctions - Returns group functions (group.func parameter values)
    • SolrQuery::getGroupLimit - Returns the group.limit value
    • SolrQuery::getGroupMain - Returns the group.main value
    • SolrQuery::getGroupNGroups - Returns the group.ngroups value
    • SolrQuery::getGroupOffset - Returns the group.offset value
    • SolrQuery::getGroupQueries - Returns all the group.query parameter values
    • SolrQuery::getGroupSortFields - Returns the group.sort value
    • SolrQuery::getGroupTruncate - Returns the group.truncate value
    • SolrQuery::getHighlight - Returns the state of the hl parameter
    • SolrQuery::getHighlightAlternateField - Returns the highlight field to use as backup or default
    • SolrQuery::getHighlightFields - Returns all the fields that Solr should generate highlighted snippets for
    • SolrQuery::getHighlightFormatter - Returns the formatter for the highlighted output
    • SolrQuery::getHighlightFragmenter - Returns the text snippet generator for highlighted text
    • SolrQuery::getHighlightFragsize - Returns the number of characters of fragments to consider for highlighting
    • SolrQuery::getHighlightHighlightMultiTerm - Returns whether or not to enable highlighting for range/wildcard/fuzzy/prefix queries
    • SolrQuery::getHighlightMaxAlternateFieldLength - Returns the maximum number of characters of the field to return
    • SolrQuery::getHighlightMaxAnalyzedChars - Returns the maximum number of characters into a document to look for suitable snippets
    • SolrQuery::getHighlightMergeContiguous - Returns whether or not the collapse contiguous fragments into a single fragment
    • SolrQuery::getHighlightRegexMaxAnalyzedChars - Returns the maximum number of characters from a field when using the regex fragmenter
    • SolrQuery::getHighlightRegexPattern - Returns the regular expression for fragmenting
    • SolrQuery::getHighlightRegexSlop - Returns the deviation factor from the ideal fragment size
    • SolrQuery::getHighlightRequireFieldMatch - Returns if a field will only be highlighted if the query matched in this particular field
    • SolrQuery::getHighlightSimplePost - Returns the text which appears after a highlighted term
    • SolrQuery::getHighlightSimplePre - Returns the text which appears before a highlighted term
    • SolrQuery::getHighlightSnippets - Returns the maximum number of highlighted snippets to generate per field
    • SolrQuery::getHighlightUsePhraseHighlighter - Returns the state of the hl.usePhraseHighlighter parameter
    • SolrQuery::getMlt - Returns whether or not MoreLikeThis results should be enabled
    • SolrQuery::getMltBoost - Returns whether or not the query will be boosted by the interesting term relevance
    • SolrQuery::getMltCount - Returns the number of similar documents to return for each result
    • SolrQuery::getMltFields - Returns all the fields to use for similarity
    • SolrQuery::getMltMaxNumQueryTerms - Returns the maximum number of query terms that will be included in any generated query
    • SolrQuery::getMltMaxNumTokens - Returns the maximum number of tokens to parse in each document field that is not stored with TermVector support
    • SolrQuery::getMltMaxWordLength - Returns the maximum word length above which words will be ignored
    • SolrQuery::getMltMinDocFrequency - Returns the treshold frequency at which words will be ignored which do not occur in at least this many docs
    • SolrQuery::getMltMinTermFrequency - Returns the frequency below which terms will be ignored in the source document
    • SolrQuery::getMltMinWordLength - Returns the minimum word length below which words will be ignored
    • SolrQuery::getMltQueryFields - Returns the query fields and their boosts
    • SolrQuery::getQuery - Returns the main query
    • SolrQuery::getRows - Returns the maximum number of documents
    • SolrQuery::getSortFields - Returns all the sort fields
    • SolrQuery::getStart - Returns the offset in the complete result set
    • SolrQuery::getStats - Returns whether or not stats is enabled
    • SolrQuery::getStatsFacets - Returns all the stats facets that were set
    • SolrQuery::getStatsFields - Returns all the statistics fields
    • SolrQuery::getTerms - Returns whether or not the TermsComponent is enabled
    • SolrQuery::getTermsField - Returns the field from which the terms are retrieved
    • SolrQuery::getTermsIncludeLowerBound - Returns whether or not to include the lower bound in the result set
    • SolrQuery::getTermsIncludeUpperBound - Returns whether or not to include the upper bound term in the result set
    • SolrQuery::getTermsLimit - Returns the maximum number of terms Solr should return
    • SolrQuery::getTermsLowerBound - Returns the term to start at
    • SolrQuery::getTermsMaxCount - Returns the maximum document frequency
    • SolrQuery::getTermsMinCount - Returns the minimum document frequency to return in order to be included
    • SolrQuery::getTermsPrefix - Returns the term prefix
    • SolrQuery::getTermsReturnRaw - Whether or not to return raw characters
    • SolrQuery::getTermsSort - Returns an integer indicating how terms are sorted
    • SolrQuery::getTermsUpperBound - Returns the term to stop at
    • SolrQuery::getTimeAllowed - Returns the time in milliseconds allowed for the query to finish
    • SolrQuery::removeExpandFilterQuery - Removes an expand filter query
    • SolrQuery::removeExpandSortField - Removes an expand sort field from the expand.sort parameter.
    • SolrQuery::removeFacetDateField - Removes one of the facet date fields
    • SolrQuery::removeFacetDateOther - Removes one of the facet.date.other parameters
    • SolrQuery::removeFacetField - Removes one of the facet.date parameters
    • SolrQuery::removeFacetQuery - Removes one of the facet.query parameters
    • SolrQuery::removeField - Removes a field from the list of fields
    • SolrQuery::removeFilterQuery - Removes a filter query
    • SolrQuery::removeHighlightField - Removes one of the fields used for highlighting
    • SolrQuery::removeMltField - Removes one of the moreLikeThis fields
    • SolrQuery::removeMltQueryField - Removes one of the moreLikeThis query fields
    • SolrQuery::removeSortField - Removes one of the sort fields
    • SolrQuery::removeStatsFacet - Removes one of the stats.facet parameters
    • SolrQuery::removeStatsField - Removes one of the stats.field parameters
    • SolrQuery::setEchoHandler - Toggles the echoHandler parameter
    • SolrQuery::setEchoParams - Determines what kind of parameters to include in the response
    • SolrQuery::setExpand - Enables/Disables the Expand Component
    • SolrQuery::setExpandQuery - Sets the expand.q parameter
    • SolrQuery::setExpandRows - Sets the number of rows to display in each group (expand.rows). Server Default 5
    • SolrQuery::setExplainOther - Sets the explainOther common query parameter
    • SolrQuery::setFacet - Maps to the facet parameter. Enables or disables facetting
    • SolrQuery::setFacetDateEnd - Maps to facet.date.end
    • SolrQuery::setFacetDateGap - Maps to facet.date.gap
    • SolrQuery::setFacetDateHardEnd - Maps to facet.date.hardend
    • SolrQuery::setFacetDateStart - Maps to facet.date.start
    • SolrQuery::setFacetEnumCacheMinDefaultFrequency - Sets the minimum document frequency used for determining term count
    • SolrQuery::setFacetLimit - Maps to facet.limit
    • SolrQuery::setFacetMethod - Specifies the type of algorithm to use when faceting a field
    • SolrQuery::setFacetMinCount - Maps to facet.mincount
    • SolrQuery::setFacetMissing - Maps to facet.missing
    • SolrQuery::setFacetOffset - Sets the offset into the list of constraints to allow for pagination
    • SolrQuery::setFacetPrefix - Specifies a string prefix with which to limits the terms on which to facet
    • SolrQuery::setFacetSort - Determines the ordering of the facet field constraints
    • SolrQuery::setGroup - Enable/Disable result grouping (group parameter)
    • SolrQuery::setGroupCachePercent - Enables caching for result grouping
    • SolrQuery::setGroupFacet - Sets group.facet parameter
    • SolrQuery::setGroupFormat - Sets the group format, result structure (group.format parameter).
    • SolrQuery::setGroupLimit - Specifies the number of results to return for each group. The server default value is 1.
    • SolrQuery::setGroupMain - If true, the result of the first field grouping command is used as the main result list in the response, using group.format=simple.
    • SolrQuery::setGroupNGroups - If true, Solr includes the number of groups that have matched the query in the results.
    • SolrQuery::setGroupOffset - Sets the group.offset parameter.
    • SolrQuery::setGroupTruncate - If true, facet counts are based on the most relevant document of each group matching the query.
    • SolrQuery::setHighlight - Enables or disables highlighting
    • SolrQuery::setHighlightAlternateField - Specifies the backup field to use
    • SolrQuery::setHighlightFormatter - Specify a formatter for the highlight output
    • SolrQuery::setHighlightFragmenter - Sets a text snippet generator for highlighted text
    • SolrQuery::setHighlightFragsize - The size of fragments to consider for highlighting
    • SolrQuery::setHighlightHighlightMultiTerm - Use SpanScorer to highlight phrase terms
    • SolrQuery::setHighlightMaxAlternateFieldLength - Sets the maximum number of characters of the field to return
    • SolrQuery::setHighlightMaxAnalyzedChars - Specifies the number of characters into a document to look for suitable snippets
    • SolrQuery::setHighlightMergeContiguous - Whether or not to collapse contiguous fragments into a single fragment
    • SolrQuery::setHighlightRegexMaxAnalyzedChars - Specify the maximum number of characters to analyze
    • SolrQuery::setHighlightRegexPattern - Specify the regular expression for fragmenting
    • SolrQuery::setHighlightRegexSlop - Sets the factor by which the regex fragmenter can stray from the ideal fragment size
    • SolrQuery::setHighlightRequireFieldMatch - Require field matching during highlighting
    • SolrQuery::setHighlightSimplePost - Sets the text which appears after a highlighted term
    • SolrQuery::setHighlightSimplePre - Sets the text which appears before a highlighted term
    • SolrQuery::setHighlightSnippets - Sets the maximum number of highlighted snippets to generate per field
    • SolrQuery::setHighlightUsePhraseHighlighter - Whether to highlight phrase terms only when they appear within the query phrase
    • SolrQuery::setMlt - Enables or disables moreLikeThis
    • SolrQuery::setMltBoost - Set if the query will be boosted by the interesting term relevance
    • SolrQuery::setMltCount - Set the number of similar documents to return for each result
    • SolrQuery::setMltMaxNumQueryTerms - Sets the maximum number of query terms included
    • SolrQuery::setMltMaxNumTokens - Specifies the maximum number of tokens to parse
    • SolrQuery::setMltMaxWordLength - Sets the maximum word length
    • SolrQuery::setMltMinDocFrequency - Sets the mltMinDoc frequency
    • SolrQuery::setMltMinTermFrequency - Sets the frequency below which terms will be ignored in the source docs
    • SolrQuery::setMltMinWordLength - Sets the minimum word length
    • SolrQuery::setOmitHeader - Exclude the header from the returned results
    • SolrQuery::setQuery - Sets the search query
    • SolrQuery::setRows - Specifies the maximum number of rows to return in the result
    • SolrQuery::setShowDebugInfo - Flag to show debug information
    • SolrQuery::setStart - Specifies the number of rows to skip
    • SolrQuery::setStats - Enables or disables the Stats component
    • SolrQuery::setTerms - Enables or disables the TermsComponent
    • SolrQuery::setTermsField - Sets the name of the field to get the Terms from
    • SolrQuery::setTermsIncludeLowerBound - Include the lower bound term in the result set
    • SolrQuery::setTermsIncludeUpperBound - Include the upper bound term in the result set
    • SolrQuery::setTermsLimit - Sets the maximum number of terms to return
    • SolrQuery::setTermsLowerBound - Specifies the Term to start from
    • SolrQuery::setTermsMaxCount - Sets the maximum document frequency
    • SolrQuery::setTermsMinCount - Sets the minimum document frequency
    • SolrQuery::setTermsPrefix - Restrict matches to terms that start with the prefix
    • SolrQuery::setTermsReturnRaw - Return the raw characters of the indexed term
    • SolrQuery::setTermsSort - Specifies how to sort the returned terms
    • SolrQuery::setTermsUpperBound - Sets the term to stop at
    • SolrQuery::setTimeAllowed - The time allowed for search to finish
    • SolrQuery::__construct - Constructor
    • SolrQuery::__destruct - Destructor
    • SolrQueryResponse::__construct - Constructor
    • SolrQueryResponse::__destruct - Destructor
    • SolrResponse::getDigestedResponse - Returns the XML response as serialized PHP data
    • SolrResponse::getHttpStatus - Returns the HTTP status of the response
    • SolrResponse::getHttpStatusMessage - Returns more details on the HTTP status
    • SolrResponse::getRawRequest - Returns the raw request sent to the Solr server
    • SolrResponse::getRawRequestHeaders - Returns the raw request headers sent to the Solr server
    • SolrResponse::getRawResponse - Returns the raw response from the server
    • SolrResponse::getRawResponseHeaders - Returns the raw response headers from the server
    • SolrResponse::getRequestUrl - Returns the full URL the request was sent to
    • SolrResponse::getResponse - Returns a SolrObject representing the XML response from the server
    • SolrResponse::setParseMode - Sets the parse mode
    • SolrResponse::success - Was the request a success
    • SolrServerException::getInternalInfo - Returns internal information where the Exception was thrown
    • SolrUpdateResponse::__construct - Constructor
    • SolrUpdateResponse::__destruct - Destructor
    • SolrUtils::digestXmlResponse - Parses an response XML string into a SolrObject
    • SolrUtils::escapeQueryChars - Escapes a lucene query string
    • SolrUtils::getSolrVersion - Returns the current version of the Solr extension
    • SolrUtils::queryPhrase - Prepares a phrase from an unescaped lucene string
    • solr_get_version - Returns the current version of the Apache Solr extension
    • sort - Bir diziyi sıralar
    • soundex - Bir dizgenin sestek anahtarını hesaplar
    • SphinxClient::addQuery - Add query to multi-query batch
    • SphinxClient::buildExcerpts - Build text snippets
    • SphinxClient::buildKeywords - Extract keywords from query
    • SphinxClient::close - Closes previously opened persistent connection
    • SphinxClient::escapeString - Escape special characters
    • SphinxClient::getLastError - Get the last error message
    • SphinxClient::getLastWarning - Get the last warning
    • SphinxClient::open - Opens persistent connection to the server
    • SphinxClient::query - Execute search query
    • SphinxClient::resetFilters - Clear all filters
    • SphinxClient::resetGroupBy - Clear all group-by settings
    • SphinxClient::runQueries - Run a batch of search queries
    • SphinxClient::setArrayResult - Change the format of result set array
    • SphinxClient::setConnectTimeout - Set connection timeout
    • SphinxClient::setFieldWeights - Set field weights
    • SphinxClient::setFilter - Add new integer values set filter
    • SphinxClient::setFilterFloatRange - Add new float range filter
    • SphinxClient::setFilterRange - Add new integer range filter
    • SphinxClient::setGeoAnchor - Set anchor point for a geosphere distance calculations
    • SphinxClient::setGroupBy - Set grouping attribute
    • SphinxClient::setGroupDistinct - Set attribute name for per-group distinct values count calculations
    • SphinxClient::setIDRange - Set a range of accepted document IDs
    • SphinxClient::setIndexWeights - Set per-index weights
    • SphinxClient::setLimits - Set offset and limit of the result set
    • SphinxClient::setMatchMode - Set full-text query matching mode
    • SphinxClient::setMaxQueryTime - Set maximum query time
    • SphinxClient::setOverride - Sets temporary per-document attribute value overrides
    • SphinxClient::setRankingMode - Set ranking mode
    • SphinxClient::setRetries - Set retry count and delay
    • SphinxClient::setSelect - Set select clause
    • SphinxClient::setServer - Set searchd host and port
    • SphinxClient::setSortMode - Set matches sorting mode
    • SphinxClient::status - Queries searchd status
    • SphinxClient::updateAttributes - Update document attributes
    • SphinxClient::__construct - Create a new SphinxClient object
    • SplDoublyLinkedList::add - Add/insert a new value at the specified index
    • SplDoublyLinkedList::bottom - Peeks at the node from the beginning of the doubly linked list
    • SplDoublyLinkedList::count - Counts the number of elements in the doubly linked list.
    • SplDoublyLinkedList::current - Return current array entry
    • SplDoublyLinkedList::getIteratorMode - Returns the mode of iteration
    • SplDoublyLinkedList::isEmpty - Checks whether the doubly linked list is empty.
    • SplDoublyLinkedList::key - Return current node index
    • SplDoublyLinkedList::next - Move to next entry
    • SplDoublyLinkedList::offsetExists - Returns whether the requested $index exists
    • SplDoublyLinkedList::offsetGet - Returns the value at the specified $index
    • SplDoublyLinkedList::offsetSet - Sets the value at the specified $index to $newval
    • SplDoublyLinkedList::offsetUnset - Unsets the value at the specified $index
    • SplDoublyLinkedList::pop - Pops a node from the end of the doubly linked list
    • SplDoublyLinkedList::prev - Move to previous entry
    • SplDoublyLinkedList::push - Pushes an element at the end of the doubly linked list
    • SplDoublyLinkedList::rewind - Rewind iterator back to the start
    • SplDoublyLinkedList::serialize - Serializes the storage
    • SplDoublyLinkedList::setIteratorMode - Sets the mode of iteration
    • SplDoublyLinkedList::shift - Shifts a node from the beginning of the doubly linked list
    • SplDoublyLinkedList::top - Peeks at the node from the end of the doubly linked list
    • SplDoublyLinkedList::unserialize - Unserializes the storage
    • SplDoublyLinkedList::unshift - Prepends the doubly linked list with an element
    • SplDoublyLinkedList::valid - Check whether the doubly linked list contains more nodes
    • SplDoublyLinkedList::__construct - Constructs a new doubly linked list
    • SplEnum::getConstList - Returns all consts (possible values) as an array.
    • SplFileInfo::getATime - Gets last access time of the file
    • SplFileInfo::getBasename - Gets the base name of the file
    • SplFileInfo::getCTime - Gets the inode change time
    • SplFileInfo::getExtension - Gets the file extension
    • SplFileInfo::getFileInfo - Gets an SplFileInfo object for the file
    • SplFileInfo::getFilename - Gets the filename
    • SplFileInfo::getGroup - Gets the file group
    • SplFileInfo::getInode - Gets the inode for the file
    • SplFileInfo::getLinkTarget - Gets the target of a link
    • SplFileInfo::getMTime - Gets the last modified time
    • SplFileInfo::getOwner - Gets the owner of the file
    • SplFileInfo::getPath - Gets the path without filename
    • SplFileInfo::getPathInfo - Gets an SplFileInfo object for the path
    • SplFileInfo::getPathname - Gets the path to the file
    • SplFileInfo::getPerms - Gets file permissions
    • SplFileInfo::getRealPath - Gets absolute path to file
    • SplFileInfo::getSize - Gets file size
    • SplFileInfo::getType - Gets file type
    • SplFileInfo::isDir - Tells if the file is a directory
    • SplFileInfo::isExecutable - Tells if the file is executable
    • SplFileInfo::isFile - Tells if the object references a regular file
    • SplFileInfo::isLink - Tells if the file is a link
    • SplFileInfo::isReadable - Tells if file is readable
    • SplFileInfo::isWritable - Tells if the entry is writable
    • SplFileInfo::openFile - Gets an SplFileObject object for the file
    • SplFileInfo::setFileClass - Sets the class used with SplFileInfo::openFile
    • SplFileInfo::setInfoClass - Sets the class used with SplFileInfo::getFileInfo and SplFileInfo::getPathInfo
    • SplFileInfo::__construct - Construct a new SplFileInfo object
    • SplFileInfo::__toString - Returns the path to the file as a string
    • SplFileObject::current - Retrieve current line of file
    • SplFileObject::eof - Reached end of file
    • SplFileObject::fflush - Flushes the output to the file
    • SplFileObject::fgetc - Gets character from file
    • SplFileObject::fgetcsv - Gets line from file and parse as CSV fields
    • SplFileObject::fgets - Gets line from file
    • SplFileObject::fgetss - Gets line from file and strip HTML tags
    • SplFileObject::flock - Portable file locking
    • SplFileObject::fpassthru - Output all remaining data on a file pointer
    • SplFileObject::fputcsv - Write a field array as a CSV line
    • SplFileObject::fread - Read from file
    • SplFileObject::fscanf - Parses input from file according to a format
    • SplFileObject::fseek - Seek to a position
    • SplFileObject::fstat - Gets information about the file
    • SplFileObject::ftell - Return current file position
    • SplFileObject::ftruncate - Truncates the file to a given length
    • SplFileObject::fwrite - Write to file
    • SplFileObject::getChildren - No purpose
    • SplFileObject::getCsvControl - Get the delimiter, enclosure and escape character for CSV
    • SplFileObject::getCurrentLine - Alias of SplFileObject::fgets
    • SplFileObject::getFlags - Gets flags for the SplFileObject
    • SplFileObject::getMaxLineLen - Get maximum line length
    • SplFileObject::hasChildren - SplFileObject does not have children
    • SplFileObject::key - Get line number
    • SplFileObject::next - Read next line
    • SplFileObject::rewind - Rewind the file to the first line
    • SplFileObject::seek - Seek to specified line
    • SplFileObject::setCsvControl - Set the delimiter, enclosure and escape character for CSV
    • SplFileObject::setFlags - Sets flags for the SplFileObject
    • SplFileObject::setMaxLineLen - Set maximum line length
    • SplFileObject::valid - Not at EOF
    • SplFileObject::__construct - Construct a new file object.
    • SplFileObject::__toString - Alias of SplFileObject::current
    • SplFixedArray::count - Returns the size of the array
    • SplFixedArray::current - Return current array entry
    • SplFixedArray::fromArray - Import a PHP array in a SplFixedArray instance
    • SplFixedArray::getSize - Gets the size of the array
    • SplFixedArray::key - Return current array index
    • SplFixedArray::next - Move to next entry
    • SplFixedArray::offsetExists - Returns whether the requested index exists
    • SplFixedArray::offsetGet - Returns the value at the specified index
    • SplFixedArray::offsetSet - Sets a new value at a specified index
    • SplFixedArray::offsetUnset - Unsets the value at the specified $index
    • SplFixedArray::rewind - Rewind iterator back to the start
    • SplFixedArray::setSize - Change the size of an array
    • SplFixedArray::toArray - Returns a PHP array from the fixed array
    • SplFixedArray::valid - Check whether the array contains more elements
    • SplFixedArray::__construct - Constructs a new fixed array
    • SplFixedArray::__wakeup - Reinitialises the array after being unserialised
    • SplHeap::compare - Compare elements in order to place them correctly in the heap while sifting up.
    • SplHeap::count - Counts the number of elements in the heap.
    • SplHeap::current - Return current node pointed by the iterator
    • SplHeap::extract - Extracts a node from top of the heap and sift up.
    • SplHeap::insert - Inserts an element in the heap by sifting it up.
    • SplHeap::isEmpty - Checks whether the heap is empty.
    • SplHeap::key - Return current node index
    • SplHeap::next - Move to the next node
    • SplHeap::recoverFromCorruption - Recover from the corrupted state and allow further actions on the heap.
    • SplHeap::rewind - Rewind iterator back to the start (no-op)
    • SplHeap::top - Peeks at the node from the top of the heap
    • SplHeap::valid - Check whether the heap contains more nodes
    • SplHeap::__construct - Constructs a new empty heap
    • split - Belirtilen dizgeyi düzenli ifadeye göre dizi elemanlarına böler
    • spliti - Belirtilen dizgeyi harf büyüklüğüne duyarsız olarak düzenli ifadeye göre dizi elemanlarına böler
    • SplMaxHeap::compare - Compare elements in order to place them correctly in the heap while sifting up.
    • SplMinHeap::compare - Compare elements in order to place them correctly in the heap while sifting up.
    • SplObjectStorage::addAll - Adds all objects from another storage
    • SplObjectStorage::attach - Adds an object in the storage
    • SplObjectStorage::contains - Checks if the storage contains a specific object
    • SplObjectStorage::count - Returns the number of objects in the storage
    • SplObjectStorage::current - Returns the current storage entry
    • SplObjectStorage::detach - Removes an object from the storage
    • SplObjectStorage::getHash - Calculate a unique identifier for the contained objects
    • SplObjectStorage::getInfo - Returns the data associated with the current iterator entry
    • SplObjectStorage::key - Returns the index at which the iterator currently is
    • SplObjectStorage::next - Move to the next entry
    • SplObjectStorage::offsetExists - Checks whether an object exists in the storage
    • SplObjectStorage::offsetGet - Returns the data associated with an object
    • SplObjectStorage::offsetSet - Associates data to an object in the storage
    • SplObjectStorage::offsetUnset - Removes an object from the storage
    • SplObjectStorage::removeAll - Removes objects contained in another storage from the current storage
    • SplObjectStorage::removeAllExcept - Removes all objects except for those contained in another storage from the current storage
    • SplObjectStorage::rewind - Rewind the iterator to the first storage element
    • SplObjectStorage::serialize - Serializes the storage
    • SplObjectStorage::setInfo - Sets the data associated with the current iterator entry
    • SplObjectStorage::unserialize - Unserializes a storage from its string representation
    • SplObjectStorage::valid - Returns if the current iterator entry is valid
    • SplObserver::update - Receive update from subject
    • SplPriorityQueue::compare - Compare priorities in order to place elements correctly in the heap while sifting up.
    • SplPriorityQueue::count - Counts the number of elements in the queue.
    • SplPriorityQueue::current - Return current node pointed by the iterator
    • SplPriorityQueue::extract - Extracts a node from top of the heap and shift up.
    • SplPriorityQueue::insert - Inserts an element in the queue by sifting it up.
    • SplPriorityQueue::isEmpty - Checks whether the queue is empty.
    • SplPriorityQueue::key - Return current node index
    • SplPriorityQueue::next - Move to the next node
    • SplPriorityQueue::recoverFromCorruption - Recover from the corrupted state and allow further actions on the queue.
    • SplPriorityQueue::rewind - Rewind iterator back to the start (no-op)
    • SplPriorityQueue::setExtractFlags - Sets the mode of extraction
    • SplPriorityQueue::top - Peeks at the node from the top of the queue
    • SplPriorityQueue::valid - Check whether the queue contains more nodes
    • SplPriorityQueue::__construct - Constructs a new empty queue
    • SplQueue::dequeue - Dequeues a node from the queue
    • SplQueue::enqueue - Adds an element to the queue.
    • SplQueue::setIteratorMode - Sets the mode of iteration
    • SplQueue::__construct - Constructs a new queue implemented using a doubly linked list
    • SplStack::setIteratorMode - Sets the mode of iteration
    • SplStack::__construct - Constructs a new stack implemented using a doubly linked list
    • SplSubject::attach - Attach an SplObserver
    • SplSubject::detach - Detach an observer
    • SplSubject::notify - Notify an observer
    • SplTempFileObject::__construct - Construct a new temporary file object
    • SplType::__construct - Creates a new value of some type
    • spl_autoload - Default implementation for __autoload()
    • spl_autoload_call - Try all registered __autoload() function to load the requested class
    • spl_autoload_extensions - Register and return default file extensions for spl_autoload
    • spl_autoload_functions - Return all registered __autoload() functions
    • spl_autoload_register - Register given function as __autoload() implementation
    • spl_autoload_unregister - Unregister given function as __autoload() implementation
    • spl_classes - Return available SPL classes
    • spl_object_hash - Return hash id for given object
    • sprintf - Biçemli bir dizge döndürür
    • SQLite3::busyTimeout - Sets the busy connection handler
    • SQLite3::changes - Veritabanında son SQL deyimi ile işlem gören satır sayısını döndürür
    • SQLite3::close - Veritabanı bağlantısını kapatır
    • SQLite3::createAggregate - Toparlayıcı bir SQL işlevi olarak kullanılmak üzere bir PHP işlevini kayda geçirir
    • SQLite3::createCollation - Registers a PHP function for use as an SQL collating function
    • SQLite3::createFunction - Sayıl bir SQL işlevi olarak kullanılmak üzere bir PHP işlevini kayda geçirir
    • SQLite3::enableExceptions - Enable throwing exceptions
    • SQLite3::escapeString - Gerektiği gibi öncelenmiş bir dizge döndürür
    • SQLite3::exec - Sonuç döndürmeyen bir SQL sorgusu çalıştırır
    • SQLite3::lastErrorCode - Başarısız olan son SQLite isteğinin sayısal sonuç kodunu döndürür
    • SQLite3::lastErrorMsg - Başarısız olan son SQLite isteği ile ilgili İngilizce iletiyi döndürür
    • SQLite3::lastInsertRowID - Veritabanına en son yerleştirilen satırın kimliğini döndürür
    • SQLite3::loadExtension - Belirtilen SQLite eklenti kütüphanesini yüklemeye çalışır
    • SQLite3::open - Bir SQLite veritabanını açar
    • SQLite3::openBlob - Opens a stream resource to read a BLOB
    • SQLite3::prepare - Çalıştırılmak üzere bir SQL sorgusu hazırlar
    • SQLite3::query - Bir SQL sorgusu çalıştırır
    • SQLite3::querySingle - Bir sorgu çalıştırıp tek bir sonuç döndürür
    • SQLite3::version - SQLite3 kütüphanesinin sürüm numarasını dizge ve sayı olarak döndürür
    • SQLite3::__construct - Yeni bir SQLite3 nesnesini ilklendirdikten sonra bir SQLite veritabanını açar
    • SQLite3Result::columnName - Numarası belirtilen sütunun ismini döndürür
    • SQLite3Result::columnType - Numarası belirtilen sütunun türünü döndürür
    • SQLite3Result::fetchArray - Sonuç satırını bir dizi olarak döndürür
    • SQLite3Result::finalize - Sonuç kümesini kapatır
    • SQLite3Result::numColumns - Sonuç kümesindeki sütun sayısını döndürür
    • SQLite3Result::reset - Sonuç kümesindeki geçerli satırı ilk satır yapar
    • SQLite3Stmt::bindParam - Bir değiştirgeyi bir deyim değişkeni ile ilişkilendirir
    • SQLite3Stmt::bindValue - Bir değiştirgenin değerini bir deyim değişkeni ile ilişkilendirir
    • SQLite3Stmt::clear - Tüm değiştirge ilişkilendirmelerini temizler
    • SQLite3Stmt::close - Hazır deyimi kapatır
    • SQLite3Stmt::execute - Hazır deyimi çalıştırır ve sonuç kümesini bir nesne olarak döndürür
    • SQLite3Stmt::paramCount - Hazır deyimdeki değişken sayısını döndürür
    • SQLite3Stmt::readOnly() - Returns whether a statement is definitely read only
    • SQLite3Stmt::reset - Hazır deyimi sıfırlar
    • sqlite_array_query - Belirtilen veritabanı üzerinde bir sorgu çalıştırıp sonucu bir dizi içinde döndürür
    • sqlite_busy_timeout - Meşgul bekleme zaman aşımını belirler
    • sqlite_changes - En son SQL deyiminin değiştirdiği satır sayısını döndürür
    • sqlite_close - Açık bir SQLite veritabanını kapatır
    • sqlite_column - Sonuç kümesindeki geçerli satırdan belirtilen sütunu döndürür
    • sqlite_create_aggregate - SQL deyimlerinde kullanmak üzere toparlayıcı bir kullanıcı tanımlı işlevi kayda geçirir
    • sqlite_create_function - SQL deyimlerinde kullanmak üzere bir kullanıcı tanımlı işlevi kayda geçirir
    • sqlite_current - Sonuç kümesindeki geçerli satırı bir dizi içinde döndürür
    • sqlite_error_string - Bir hata kodu ile ilgili açıklamayı döndürür
    • sqlite_escape_string - Bir sorgu değiştirgesi olarak kullanmak üzere bir dizgeyi önceler
    • sqlite_exec - Belirtilen veritabanı üzerinde sonuç döndürmeyen bir sorgu çalıştırır
    • sqlite_factory - Bir SQLite veritabanı açıp bir SQLiteDatabase nesnesi döndürür
    • sqlite_fetch_all - Sonuç kümesindeki tüm satırları bir satır dizileri dizisi olarak döndürür
    • sqlite_fetch_array - Sonuç kümesindeki sonraki satırı bir dizi içinde döndürür
    • sqlite_fetch_column_types - Belli bir tablodaki sütun türlerini bir dizi içinde döndürür
    • sqlite_fetch_object - Sonuç kümesindeki sonraki satırı bir nesne olarak döndürür
    • sqlite_fetch_single - Sonuç kümesindeki ilk sütunu bir dizge olarak döndürür
    • sqlite_fetch_string - sqlite_fetch_single işlevinin takma adıdır
    • sqlite_field_name - Sonuç kümesindeki belli bir alanın ismini döndürür
    • sqlite_has_more - Sonuç kümesinde başka satır kaldı mı diye bakar
    • sqlite_has_prev - Geçerli satırın öncesinde satır var mı diye bakar
    • sqlite_key - Geçerli satırın indisini döndürür
    • sqlite_last_error - Veritabanındaki son hatanın kodunu döndürür
    • sqlite_last_insert_rowid - Son yerleştirilen satırın satır kimliğini döndürür
    • sqlite_libencoding - İlintili SQLite kütüphanesinin karakter kodlamasını döndürür
    • sqlite_libversion - İlintili SQLite kütüphanesinin sürüm numarasını döndürür
    • sqlite_next - Sonraki satıra gider
    • sqlite_num_fields - Sonuç kümesindeki alan sayısını döndürür
    • sqlite_num_rows - Tamponlu bir sonuç kümesindeki satır sayısını döndürür
    • sqlite_open - Bir SQLite veritabanı için bir tanıtıcı açar, veritabanı mevcut değilse oluşturur
    • sqlite_popen - Bir SQLite veritabanı için kalıcı bir tanıtıcı açar, veritabanı mevcut değilse oluşturur
    • sqlite_prev - Sonuç kümesindeki önceki satıra gider
    • sqlite_query - Belirtilen veritabanında bir sorgu çalıştırıp bir sonuç tanıtıcısı döndürür
    • sqlite_rewind - İlk satırı geçerli satır yapar
    • sqlite_seek - Tamponlu bir sonuç kümesinde belli bir satır numarasına gider
    • sqlite_single_query - Bir sorgu çalıştırıp sonucu tek bir sütunluk veya tek bir satırlık bir dizi olarak döndürür
    • sqlite_udf_decode_binary - Kullanıcı tanımlı bir işleve değiştirge olarak aktarılacak ikil veriyi çözümler
    • sqlite_udf_encode_binary - Bir kullanıcı tanımlı işlevden dönecek ikil veriyi döndürmeden önce kodlamak için kullanılır
    • sqlite_unbuffered_query - Sonuçların alınıp bir tampona konmadığı bir sorgu çalıştırır
    • sqlite_valid - Başka satır var mı diye bakar
    • sqlsrv_begin_transaction - Begins a database transaction
    • sqlsrv_cancel - Cancels a statement
    • sqlsrv_client_info - Returns information about the client and specified connection
    • sqlsrv_close - Closes an open connection and releases resourses associated with the connection
    • sqlsrv_commit - Commits a transaction that was begun with sqlsrv_begin_transaction
    • sqlsrv_configure - Changes the driver error handling and logging configurations
    • sqlsrv_connect - Opens a connection to a Microsoft SQL Server database
    • sqlsrv_errors - Returns error and warning information about the last SQLSRV operation performed
    • sqlsrv_execute - Executes a statement prepared with sqlsrv_prepare
    • sqlsrv_fetch - Makes the next row in a result set available for reading
    • sqlsrv_fetch_array - Returns a row as an array
    • sqlsrv_fetch_object - Retrieves the next row of data in a result set as an object
    • sqlsrv_field_metadata - Retrieves metadata for the fields of a statement prepared by sqlsrv_prepare or sqlsrv_query
    • sqlsrv_free_stmt - Frees all resources for the specified statement
    • sqlsrv_get_config - Returns the value of the specified configuration setting
    • sqlsrv_get_field - Gets field data from the currently selected row
    • sqlsrv_has_rows - Indicates whether the specified statement has rows
    • sqlsrv_next_result - Makes the next result of the specified statement active
    • sqlsrv_num_fields - Retrieves the number of fields (columns) on a statement
    • sqlsrv_num_rows - Retrieves the number of rows in a result set
    • sqlsrv_prepare - Prepares a query for execution
    • sqlsrv_query - Prepares and executes a query.
    • sqlsrv_rollback - Rolls back a transaction that was begun with sqlsrv_begin_transaction
    • sqlsrv_rows_affected - Returns the number of rows modified by the last INSERT, UPDATE, or DELETE query executed
    • sqlsrv_send_stream_data - Sends data from parameter streams to the server
    • sqlsrv_server_info - Returns information about the server
    • sql_regcase - Harf büyüklüğüne duyarsız eşleşme için düzenli ifade oluşturur
    • sqrt - Square root
    • srand - Seed the random number generator
    • sscanf - Girdi dizgesini belli bir biçeme göre yorumlar
    • ssdeep_fuzzy_compare - Calculates the match score between two fuzzy hash signatures
    • ssdeep_fuzzy_hash - Create a fuzzy hash from a string
    • ssdeep_fuzzy_hash_filename - Create a fuzzy hash from a file
    • ssh2:// - Secure Shell 2
    • ssh2_auth_agent - Authenticate over SSH using the ssh agent
    • ssh2_auth_hostbased_file - Bir genel konak anahtarı kullanarak kimlik doğrulaması yapar
    • ssh2_auth_none - "none" kimlik doğrulaması yapar
    • ssh2_auth_password - Parola kullanarak kimlik doğrulaması yapar
    • ssh2_auth_pubkey_file - Bir genel anahtar kullanarak kimlik doğrulaması yapar
    • ssh2_connect - Bir SSH sunucusuna bağlanır
    • ssh2_exec - Uzak sunucu üzerinde bir komut çalıştırır
    • ssh2_fetch_stream - Başka bir veri akımı döndürür
    • ssh2_fingerprint - Uzak sunucunu parmakizini döndürür
    • ssh2_methods_negotiated - Müzakere yöntemlerini listeler
    • ssh2_publickey_add - Yetkili bir genel anahtar ekler
    • ssh2_publickey_init - Genel anahtar alt sistemini ilklendirir
    • ssh2_publickey_list - Yetkili genel anahtarları listeler
    • ssh2_publickey_remove - Bir genel anahtarı siler
    • ssh2_scp_recv - SCP üzerinden bir dosya alır
    • ssh2_scp_send - SCP üzerinden bir dosya gönderir
    • ssh2_sftp - SFTP alt sistemini ilklendirir
    • ssh2_sftp_chmod - Changes file mode
    • ssh2_sftp_lstat - Uzak sunucudaki bir sembolik bağın durum bilgisini döndürür
    • ssh2_sftp_mkdir - Uzak konakta bir dizin oluşturur
    • ssh2_sftp_readlink - Bir sembolik bağın hedefini döndürür
    • ssh2_sftp_realpath - Belirtilen dosya yolu dizgesinden gerçek yolu elde eder
    • ssh2_sftp_rename - Bir uzak dosyanın ismini değiştirir
    • ssh2_sftp_rmdir - Karşıdan bir dizin siler
    • ssh2_sftp_stat - Uzak dosya sistemindeki bir dosyanın durum bilgisini döndürür
    • ssh2_sftp_symlink - Karşıda bir sembolik bağ oluşturur
    • ssh2_sftp_unlink - Bir dosyayı siler
    • ssh2_shell - Bir etkileşimli kabuk isteği yapar
    • ssh2_tunnel - Uzak bir sunucuya doğru bir tünel açar
    • SSL bağlamı seçenekleri - SSL bağlamı seçeneklerinin listesi
    • stat - Bir dosya hakkında bilgi döndürür
    • stats_absolute_deviation - Returns the absolute deviation of an array of values
    • stats_cdf_beta - CDF function for BETA Distribution. Calculates any one parameter of the beta distribution given values for the others.
    • stats_cdf_binomial - Calculates any one parameter of the binomial distribution given values for the others.
    • stats_cdf_cauchy - Not documented
    • stats_cdf_chisquare - Calculates any one parameter of the chi-square distribution given values for the others.
    • stats_cdf_exponential - Not documented
    • stats_cdf_f - Calculates any one parameter of the F distribution given values for the others.
    • stats_cdf_gamma - Calculates any one parameter of the gamma distribution given values for the others.
    • stats_cdf_laplace - Not documented
    • stats_cdf_logistic - Not documented
    • stats_cdf_negative_binomial - Calculates any one parameter of the negative binomial distribution given values for the others.
    • stats_cdf_noncentral_chisquare - Calculates any one parameter of the non-central chi-square distribution given values for the others.
    • stats_cdf_noncentral_f - Calculates any one parameter of the Non-central F distribution given values for the others.
    • stats_cdf_poisson - Calculates any one parameter of the Poisson distribution given values for the others.
    • stats_cdf_t - Calculates any one parameter of the T distribution given values for the others.
    • stats_cdf_uniform - Not documented
    • stats_cdf_weibull - Not documented
    • stats_covariance - Computes the covariance of two data sets
    • stats_dens_beta - Not documented
    • stats_dens_cauchy - Not documented
    • stats_dens_chisquare - Not documented
    • stats_dens_exponential - Not documented
    • stats_dens_f - Açıklama
    • stats_dens_gamma - Not documented
    • stats_dens_laplace - Not documented
    • stats_dens_logistic - Not documented
    • stats_dens_negative_binomial - Not documented
    • stats_dens_normal - Not documented
    • stats_dens_pmf_binomial - Not documented
    • stats_dens_pmf_hypergeometric - Açıklama
    • stats_dens_pmf_poisson - Not documented
    • stats_dens_t - Not documented
    • stats_dens_weibull - Not documented
    • stats_den_uniform - Not documented
    • stats_harmonic_mean - Returns the harmonic mean of an array of values
    • stats_kurtosis - Computes the kurtosis of the data in the array
    • stats_rand_gen_beta - Generates beta random deviate
    • stats_rand_gen_chisquare - Generates random deviate from the distribution of a chisquare with "df" degrees of freedom random variable.
    • stats_rand_gen_exponential - Generates a single random deviate from an exponential distribution with mean "av"
    • stats_rand_gen_f - Generates a random deviate
    • stats_rand_gen_funiform - Generates uniform float between low (exclusive) and high (exclusive)
    • stats_rand_gen_gamma - Generates random deviates from a gamma distribution
    • stats_rand_gen_ibinomial - Generates a single random deviate from a binomial distribution whose number of trials is "n" (n >= 0) and whose probability of an event in each trial is "pp" ([0;1]). Method : algorithm BTPE
    • stats_rand_gen_ibinomial_negative - Generates a single random deviate from a negative binomial distribution. Arguments : n - the number of trials in the negative binomial distribution from which a random deviate is to be generated (n > 0), p - the probability of an event (0 < p < 1)).
    • stats_rand_gen_int - Generates random integer between 1 and 2147483562
    • stats_rand_gen_ipoisson - Generates a single random deviate from a Poisson distribution with mean "mu" (mu >= 0.0).
    • stats_rand_gen_iuniform - Generates integer uniformly distributed between LOW (inclusive) and HIGH (inclusive)
    • stats_rand_gen_noncenral_chisquare - Generates random deviate from the distribution of a noncentral chisquare with "df" degrees of freedom and noncentrality parameter "xnonc". d must be >= 1.0, xnonc must >= 0.0
    • stats_rand_gen_noncentral_f - Generates a random deviate from the noncentral F (variance ratio) distribution with "dfn" degrees of freedom in the numerator, and "dfd" degrees of freedom in the denominator, and noncentrality parameter "xnonc". Method : directly generates ratio of noncentral numerator chisquare variate to central denominator chisquare variate.
    • stats_rand_gen_noncentral_t - Generates a single random deviate from a noncentral T distribution
    • stats_rand_gen_normal - Generates a single random deviate from a normal distribution with mean, av, and standard deviation, sd (sd >= 0). Method : Renames SNORM from TOMS as slightly modified by BWB to use RANF instead of SUNIF.
    • stats_rand_gen_t - Generates a single random deviate from a T distribution
    • stats_rand_get_seeds - Not documented
    • stats_rand_phrase_to_seeds - generate two seeds for the RGN random number generator
    • stats_rand_ranf - Returns a random floating point number from a uniform distribution over 0 - 1 (endpoints of this interval are not returned) using the current generator
    • stats_rand_setall - Not documented
    • stats_skew - Computes the skewness of the data in the array
    • stats_standard_deviation - Returns the standard deviation
    • stats_stat_binomial_coef - Not documented
    • stats_stat_correlation - Not documented
    • stats_stat_gennch - Not documented
    • stats_stat_independent_t - Not documented
    • stats_stat_innerproduct - Açıklama
    • stats_stat_noncentral_t - Calculates any one parameter of the noncentral t distribution give values for the others.
    • stats_stat_paired_t - Not documented
    • stats_stat_percentile - Not documented
    • stats_stat_powersum - Not documented
    • stats_variance - Returns the population variance
    • Stomp::abort - Rolls back a transaction in progress
    • Stomp::ack - Acknowledges consumption of a message
    • Stomp::begin - Starts a transaction
    • Stomp::commit - Commits a transaction in progress
    • Stomp::error - Gets the last stomp error
    • Stomp::getReadTimeout - Gets read timeout
    • Stomp::getSessionId - Gets the current stomp session ID
    • Stomp::hasFrame - Indicates whether or not there is a frame ready to read
    • Stomp::readFrame - Reads the next frame
    • Stomp::send - Sends a message
    • Stomp::setReadTimeout - Sets read timeout
    • Stomp::subscribe - Registers to listen to a given destination
    • Stomp::unsubscribe - Removes an existing subscription
    • Stomp::__construct - Opens a connection
    • Stomp::__destruct - Closes stomp connection
    • StompException::getDetails - Get exception details
    • StompFrame::__construct - Constructor
    • stomp_connect_error - Returns a string description of the last connect error
    • stomp_version - Gets the current stomp extension version
    • strcasecmp - İkil olarak güvenilir ve harf büyüklüğüne duyarsız dizge karşılaştırması yapar
    • strchr - strstr işlevinin takma adıdır
    • strcmp - İkil olarak güvenilir dizge karşılaştırması yapar
    • strcoll - Yerele göre dizge karşılaştırma
    • strcspn - Maske ile eşleşMEyen ilk parçanın uzunluğunu bulur
    • streamWrapper::dir_closedir - Dizin tanıtıcısını kapatır
    • streamWrapper::dir_opendir - Dizin tanıtıcısı açar
    • streamWrapper::dir_readdir - Dizinden bir girdi okur
    • streamWrapper::dir_rewinddir - Dizin tanıtıcısını dizin başlangıcına konumlar
    • streamWrapper::mkdir - Bir dizin oluşturur
    • streamWrapper::rename - Bir dosya veya dizinin ismini değiştirir
    • streamWrapper::rmdir - Bir dizini siler
    • streamWrapper::stream_cast - Temel özkaynağı döndürür
    • streamWrapper::stream_close - Bir özkaynağı kapatır
    • streamWrapper::stream_eof - Dosya göstericisinin dosya sonunda olup olmadığına bakar
    • streamWrapper::stream_flush - Çıktıyı boşaltır
    • streamWrapper::stream_lock - Tavsiye niteliğinde dosya kilitleme
    • streamWrapper::stream_metadata - Change stream metadata
    • streamWrapper::stream_open - Bir dosya veya URL açar
    • streamWrapper::stream_read - Akımdan veri okur
    • streamWrapper::stream_seek - Akım üzerinde belli bir konuma gidilir
    • streamWrapper::stream_set_option - Akım seçeneklerini değiştirir
    • streamWrapper::stream_stat - Bir dosya özkaynağı hakkında bilgi döndürür
    • streamWrapper::stream_tell - Bir akımdan geçerli konumu döndürür
    • streamWrapper::stream_truncate - Truncate stream
    • streamWrapper::stream_write - Akıma yazar
    • streamWrapper::unlink - Bir dosyayı siler
    • streamWrapper::url_stat - Bir dosya hakkında bilgi döndürür
    • streamWrapper::__construct - Yeni bir akım sarmalayıcı oluşturur
    • streamWrapper::__destruct - Destructs an existing stream wrapper
    • stream_bucket_append - Zincirin sonuna bir biriktirici ekler
    • stream_bucket_make_writeable - Üzerinde işlem yapmak için zincirden bir biriktirici nesnesi döndürür
    • stream_bucket_new - Geçerli akımda kullanmak için yeni bir biriktirici oluşturur
    • stream_bucket_prepend - Zincirin önüne bir biriktirici ekler
    • stream_context_create - Bir akım bağlamı oluşturur
    • stream_context_get_default - Öntanımlı akım bağlamını döndürür
    • stream_context_get_options - Bir akım/sarmalayıcı/bağlam için atanmış seçenekleri döndürür
    • stream_context_get_params - Bir bağlamın değiştirgelerini döndürür
    • stream_context_set_default - Akımları içeren öntanımlı bağlamı tanımlar
    • stream_context_set_option - Bir akım/sarmalayıcı/bağlam için bir seçenek tanımlar
    • stream_context_set_params - Bir akım/sarmalayıcı/bağlam için değiştirgeleri tanımlar
    • stream_copy_to_stream - Veriyi bir akımdan diğerine kopyalar
    • stream_encoding - Akımı kodlayacak karakter kümesini belirler
    • stream_filter_append - Süzgeç zincirinin sonuna bir süzgeç ekler
    • stream_filter_prepend - Süzgeç zincirinin başına bir süzgeç ekler
    • stream_filter_register - Kullanıcı tanımlı bir akım süzgecini etkin kılar
    • stream_filter_remove - Akımdan bir süzgeci kaldırır
    • stream_get_contents - Akımdan kalanı bir dizgeye okur
    • stream_get_filters - Etkin süzgeçlerin listesini döndürür
    • stream_get_line - Akımdan belirtilen ayraca kadar bir satır döndürür
    • stream_get_meta_data - Akımdan başlıkları/meta verileri döndürür
    • stream_get_transports - Etkin soket aktarımlarının listesini döndürür
    • stream_get_wrappers - Etkin akımların listesini döndürür
    • stream_is_local - Akım, bir yerel akımsa TRUE döner
    • stream_notification_callback - notification bağlam değiştirgesi için bir geri çağırım işlevi
    • stream_register_wrapper - stream_wrapper_register işlevinin takma adıdır
    • stream_resolve_include_path - Bir göreli yol ile yapılacak fopen çağrısıyla açılacak dosyayı belirler
    • stream_select - Belirtilen akım dizisi üzerinde belirtilen zaman aşımı ile select() sistem çağrısının eşdeğeri olarak çalışır
    • stream_set_blocking - Akımın engelleme kipini ayarlar
    • stream_set_chunk_size - Set the stream chunk size
    • stream_set_read_buffer - Set read file buffering on the given stream
    • stream_set_timeout - Akımın zaman aşımı süresini ayarlar
    • stream_set_write_buffer - Dosya tamponunu ayarlar
    • stream_socket_accept - stream_socket_server ile oluşturulmuş bir soketten bağlantı kabul eder
    • stream_socket_client - Bir Genel Ağ veya Unix alan soketi bağlantısı açar
    • stream_socket_enable_crypto - Bağlı bir soket üzerinde şifrelemeyi açıp kapatır
    • stream_socket_get_name - Yerel veya uzak soketin ismini döndürür
    • stream_socket_pair - Soket akımlarınca ayırt edilebilen bir bağlantı çifti oluşturur
    • stream_socket_recvfrom - Bağlı olsun ya da olmasın bir soketten veri alır
    • stream_socket_sendto - Bir sokete bağlı olsun ya da olmasın, bir ileti gönderir
    • stream_socket_server - Bir Genel Ağ veya Unix alan sunucusu soketi oluşturur
    • stream_socket_shutdown - Çift yönlü bağlantıyı kapatır
    • stream_supports_lock - Akımın kilitlemeyi destekleyip desteklemediğine bakar
    • stream_wrapper_register - Bir PHP sınıfı olarak gerçeklenmiş bir URL sarmalayıcısını etkin kılar
    • stream_wrapper_restore - İptal edilmiş yerleşik bir sarmalayıcıyı tekrar etkin kılar
    • stream_wrapper_unregister - Bir URL sarmalayıcısını iptal eder
    • strftime - Format a local time/date according to locale settings
    • stripcslashes - addcslashes ile öncelenmiş dizgeyi eski haline getirir
    • stripos - Harf büyüklüğüne duyarsız olarak bir alt dizgenin ilkinin konumunu bulur
    • stripslashes - Bir dizgeden tersbölüleri ayıklar
    • strip_tags - Bir dizgeden HTML ve PHP etiketlerini ayıklar
    • stristr - Harf büyüklüğüne duyarsız olarak ilk alt dizgeyi bulur
    • strlen - Dizge uzunluğunu döndürür
    • strnatcasecmp - "Doğal sıralama" algoritmasını kullanarak dizgeleri harf büyüklüğüne duyarsız olarak karşılaştırır
    • strnatcmp - "Doğal sıralama" algoritmasını kullanarak dizgeleri karşılaştırır
    • strncasecmp - İlk n karakteri ikil ve harf büyüklüğüne duyarsız olarak karşılaştırır
    • strncmp - İlk n karakteri ikil olarak karşılaştırır
    • strpbrk - Belirtilen karakterleri bir dizge içinde arar
    • strpos - Bir alt dizgenin ilkinin konumunu bulur
    • strptime - strftime işleviyle üretilen zaman ve tarihleri çözümler
    • strrchr - Bir dizgede belli bir karakterin sonuncusuna göre dizgenin bir parçasıyla döner
    • strrev - Bir dizgeyi ters çevirir
    • strripos - Bir dizgede harf büyüklüğüne duyarsız olarak bir alt dizgenin sonuncusunu bulur
    • strrpos - Bir dizgede bir karakterin sonuncusunu bulur
    • strspn - Dizgenin, maskenin tam karakterleri ile eşleşen ilk parçasının uzunluğunu bulur
    • strstr - İlk alt dizgeyi bulur
    • strtok - Dizgeyi bir dizgeciğe göre böler
    • strtolower - Bir dizgenin harflerini küçük harfe çevirir
    • strtotime - Parse about any English textual datetime description into a Unix timestamp
    • strtoupper - Bir dizgenin harflerini büyük harfe çevirir
    • strtr - Belli karakterleri dönüştürür
    • strval - Bir değişkenin dizgesel değerini döndürür
    • str_getcsv - Bir CSV dizgesinin girdilerini bir dizinin elemanlarına paylaştırır
    • str_ireplace - Bir alt dizgenin bütün örneklerini yenisiyle değiştirirken harf büyüklüklerini dikkate almaz
    • str_pad - Bir dizgeyi belli bir uzunlukta diğer dizgeyle doldurur
    • str_repeat - Bir dizgeyi yineler
    • str_replace - Bir alt dizgenin bütün örneklerini yenisiyle değiştirir
    • str_rot13 - Bir dizgeye rot13 dönüşümü uygular
    • str_shuffle - Bir dizgenin karakterlerini devşirir
    • str_split - Bir dizgeyi bir diziye dönüştürür
    • str_word_count - Bir dizgedeki sözcükler hakkında bilgi verir
    • substr - Dizgenin bir kısmını döndürür
    • substr_compare - İki dizgenin belli bir konumdan itibaren belli uzunluktaki parçalarını bayt bayt karşılaştırır
    • substr_count - Bir dizge içinde belli bir alt dizgeden kaç tane bulunduğunu bulur
    • substr_replace - Bir dizgenin belli bir bölümünü değiştirir
    • SVM::crossvalidate - Test training params on subsets of the training data.
    • SVM::getOptions - Return the current training parameters
    • SVM::setOptions - Set training parameters
    • SVM::train - Create a SVMModel based on training data
    • SVM::__construct - Construct a new SVM object
    • SVMModel::checkProbabilityModel - Returns true if the model has probability information
    • SVMModel::getLabels - Get the labels the model was trained on
    • SVMModel::getNrClass - Returns the number of classes the model was trained with
    • SVMModel::getSvmType - Get the SVM type the model was trained with
    • SVMModel::getSvrProbability - Get the sigma value for regression types
    • SVMModel::load - Load a saved SVM Model
    • SVMModel::predict - Predict a value for previously unseen data
    • SVMModel::predict_probability - Return class probabilities for previous unseen data
    • SVMModel::save - Save a model to a file
    • SVMModel::__construct - Construct a new SVMModel
    • svn_add - Schedules the addition of an item in a working directory
    • svn_auth_get_parameter - Retrieves authentication parameter
    • svn_auth_set_parameter - Sets an authentication parameter
    • svn_blame - Get the SVN blame for a file
    • svn_cat - Returns the contents of a file in a repository
    • svn_checkout - Checks out a working copy from the repository
    • svn_cleanup - Recursively cleanup a working copy directory, finishing incomplete operations and removing locks
    • svn_client_version - Returns the version of the SVN client libraries
    • svn_commit - Sends changes from the local working copy to the repository
    • svn_delete - Delete items from a working copy or repository.
    • svn_diff - Recursively diffs two paths
    • svn_export - Export the contents of a SVN directory
    • svn_fs_abort_txn - Abort a transaction, returns true if everything is okay, false otherwise
    • svn_fs_apply_text - Creates and returns a stream that will be used to replace
    • svn_fs_begin_txn2 - Create a new transaction
    • svn_fs_change_node_prop - Return true if everything is ok, false otherwise
    • svn_fs_check_path - Determines what kind of item lives at path in a given repository fsroot
    • svn_fs_contents_changed - Return true if content is different, false otherwise
    • svn_fs_copy - Copies a file or a directory, returns true if all is ok, false otherwise
    • svn_fs_delete - Deletes a file or a directory, return true if all is ok, false otherwise
    • svn_fs_dir_entries - Enumerates the directory entries under path; returns a hash of dir names to file type
    • svn_fs_file_contents - Returns a stream to access the contents of a file from a given version of the fs
    • svn_fs_file_length - Returns the length of a file from a given version of the fs
    • svn_fs_is_dir - Return true if the path points to a directory, false otherwise
    • svn_fs_is_file - Return true if the path points to a file, false otherwise
    • svn_fs_make_dir - Creates a new empty directory, returns true if all is ok, false otherwise
    • svn_fs_make_file - Creates a new empty file, returns true if all is ok, false otherwise
    • svn_fs_node_created_rev - Returns the revision in which path under fsroot was created
    • svn_fs_node_prop - Returns the value of a property for a node
    • svn_fs_props_changed - Return true if props are different, false otherwise
    • svn_fs_revision_prop - Fetches the value of a named property
    • svn_fs_revision_root - Get a handle on a specific version of the repository root
    • svn_fs_txn_root - Creates and returns a transaction root
    • svn_fs_youngest_rev - Returns the number of the youngest revision in the filesystem
    • svn_import - Imports an unversioned path into a repository
    • svn_log - Returns the commit log messages of a repository URL
    • svn_ls - Returns list of directory contents in repository URL, optionally at revision number
    • svn_mkdir - Creates a directory in a working copy or repository
    • svn_repos_create - Create a new subversion repository at path
    • svn_repos_fs - Gets a handle on the filesystem for a repository
    • svn_repos_fs_begin_txn_for_commit - Create a new transaction
    • svn_repos_fs_commit_txn - Commits a transaction and returns the new revision
    • svn_repos_hotcopy - Make a hot-copy of the repos at repospath; copy it to destpath
    • svn_repos_open - Open a shared lock on a repository.
    • svn_repos_recover - Run recovery procedures on the repository located at path.
    • svn_revert - Revert changes to the working copy
    • svn_status - Returns the status of working copy files and directories
    • svn_update - Update working copy
    • SWFAction::__construct - Creates a new SWFAction
    • SWFBitmap::getHeight - Returns the bitmap's height
    • SWFBitmap::getWidth - Returns the bitmap's width
    • SWFBitmap::__construct - Loads Bitmap object
    • SWFButton::addAction - Adds an action
    • SWFButton::addASound - Associates a sound with a button transition
    • SWFButton::addShape - Adds a shape to a button
    • SWFButton::setAction - Sets the action
    • SWFButton::setDown - Alias for addShape(shape, SWFBUTTON_DOWN)
    • SWFButton::setHit - Alias for addShape(shape, SWFBUTTON_HIT)
    • SWFButton::setMenu - enable track as menu button behaviour
    • SWFButton::setOver - Alias for addShape(shape, SWFBUTTON_OVER)
    • SWFButton::setUp - Alias for addShape(shape, SWFBUTTON_UP)
    • SWFButton::__construct - Creates a new Button
    • SWFDisplayItem::addAction - Adds this SWFAction to the given SWFSprite instance
    • SWFDisplayItem::addColor - Adds the given color to this item's color transform
    • SWFDisplayItem::endMask - Another way of defining a MASK layer
    • SWFDisplayItem::getRot - Açıklama
    • SWFDisplayItem::getX - Açıklama
    • SWFDisplayItem::getXScale - Açıklama
    • SWFDisplayItem::getXSkew - Açıklama
    • SWFDisplayItem::getY - Açıklama
    • SWFDisplayItem::getYScale - Açıklama
    • SWFDisplayItem::getYSkew - Açıklama
    • SWFDisplayItem::move - Moves object in relative coordinates
    • SWFDisplayItem::moveTo - Moves object in global coordinates
    • SWFDisplayItem::multColor - Multiplies the item's color transform
    • SWFDisplayItem::remove - Removes the object from the movie
    • SWFDisplayItem::rotate - Rotates in relative coordinates
    • SWFDisplayItem::rotateTo - Rotates the object in global coordinates
    • SWFDisplayItem::scale - Scales the object in relative coordinates
    • SWFDisplayItem::scaleTo - Scales the object in global coordinates
    • SWFDisplayItem::setDepth - Sets z-order
    • SWFDisplayItem::setMaskLevel - Defines a MASK layer at level
    • SWFDisplayItem::setMatrix - Sets the item's transform matrix
    • SWFDisplayItem::setName - Sets the object's name
    • SWFDisplayItem::setRatio - Sets the object's ratio
    • SWFDisplayItem::skewX - Sets the X-skew
    • SWFDisplayItem::skewXTo - Sets the X-skew
    • SWFDisplayItem::skewY - Sets the Y-skew
    • SWFDisplayItem::skewYTo - Sets the Y-skew
    • SWFFill::moveTo - Moves fill origin
    • SWFFill::rotateTo - Sets fill's rotation
    • SWFFill::scaleTo - Sets fill's scale
    • SWFFill::skewXTo - Sets fill x-skew
    • SWFFill::skewYTo - Sets fill y-skew
    • SWFFont::getAscent - Returns the ascent of the font, or 0 if not available
    • SWFFont::getDescent - Returns the descent of the font, or 0 if not available
    • SWFFont::getLeading - Returns the leading of the font, or 0 if not available
    • SWFFont::getShape - Returns the glyph shape of a char as a text string
    • SWFFont::getUTF8Width - Calculates the width of the given string in this font at full height
    • SWFFont::getWidth - Returns the string's width
    • SWFFont::__construct - Loads a font definition
    • SWFFontChar::addChars - Adds characters to a font for exporting font
    • SWFFontChar::addUTF8Chars - Adds characters to a font for exporting font
    • SWFGradient::addEntry - Adds an entry to the gradient list
    • SWFGradient::__construct - Creates a gradient object
    • SWFMorph::getShape1 - Gets a handle to the starting shape
    • SWFMorph::getShape2 - Gets a handle to the ending shape
    • SWFMorph::__construct - Creates a new SWFMorph object
    • SWFMovie::add - Adds any type of data to a movie
    • SWFMovie::addExport - Açıklama
    • SWFMovie::addFont - Açıklama
    • SWFMovie::importChar - Açıklama
    • SWFMovie::importFont - Açıklama
    • SWFMovie::labelFrame - Labels a frame
    • SWFMovie::nextFrame - Moves to the next frame of the animation
    • SWFMovie::output - Dumps your lovingly prepared movie out
    • SWFMovie::remove - Removes the object instance from the display list
    • SWFMovie::save - Saves the SWF movie in a file
    • SWFMovie::saveToFile - Açıklama
    • SWFMovie::setbackground - Sets the background color
    • SWFMovie::setDimension - Sets the movie's width and height
    • SWFMovie::setFrames - Sets the total number of frames in the animation
    • SWFMovie::setRate - Sets the animation's frame rate
    • SWFMovie::startSound - Açıklama
    • SWFMovie::stopSound - Açıklama
    • SWFMovie::streamMP3 - Streams a MP3 file
    • SWFMovie::writeExports - Açıklama
    • SWFMovie::__construct - Creates a new movie object, representing an SWF version 4 movie
    • SWFPrebuiltClip::__construct - Returns a SWFPrebuiltClip object
    • SWFShape::addFill - Adds a solid fill to the shape
    • SWFShape::drawArc - Draws an arc of radius r centered at the current location, from angle startAngle to angle endAngle measured clockwise from 12 o'clock
    • SWFShape::drawCircle - Draws a circle of radius r centered at the current location, in a counter-clockwise fashion
    • SWFShape::drawCubic - Draws a cubic bezier curve using the current position and the three given points as control points
    • SWFShape::drawCubicTo - Draws a cubic bezier curve using the current position and the three given points as control points
    • SWFShape::drawCurve - Draws a curve (relative)
    • SWFShape::drawCurveTo - Draws a curve
    • SWFShape::drawGlyph - Draws the first character in the given string into the shape using the glyph definition from the given font
    • SWFShape::drawLine - Draws a line (relative)
    • SWFShape::drawLineTo - Draws a line
    • SWFShape::movePen - Moves the shape's pen (relative)
    • SWFShape::movePenTo - Moves the shape's pen
    • SWFShape::setLeftFill - Sets left rasterizing color
    • SWFShape::setLine - Sets the shape's line style
    • SWFShape::setRightFill - Sets right rasterizing color
    • SWFShape::__construct - Creates a new shape object
    • SWFSound::__construct - Returns a new SWFSound object from given file
    • SWFSoundInstance::loopCount - Açıklama
    • SWFSoundInstance::loopInPoint - Açıklama
    • SWFSoundInstance::loopOutPoint - Açıklama
    • SWFSoundInstance::noMultiple - Açıklama
    • SWFSprite::add - Adds an object to a sprite
    • SWFSprite::labelFrame - Labels frame
    • SWFSprite::nextFrame - Moves to the next frame of the animation
    • SWFSprite::remove - Removes an object to a sprite
    • SWFSprite::setFrames - Sets the total number of frames in the animation
    • SWFSprite::startSound - Açıklama
    • SWFSprite::stopSound - Açıklama
    • SWFSprite::__construct - Creates a movie clip (a sprite)
    • SWFText::addString - Draws a string
    • SWFText::addUTF8String - Writes the given text into this SWFText object at the current pen position, using the current font, height, spacing, and color
    • SWFText::getAscent - Returns the ascent of the current font at its current size, or 0 if not available
    • SWFText::getDescent - Returns the descent of the current font at its current size, or 0 if not available
    • SWFText::getLeading - Returns the leading of the current font at its current size, or 0 if not available
    • SWFText::getUTF8Width - calculates the width of the given string in this text objects current font and size
    • SWFText::getWidth - Computes string's width
    • SWFText::moveTo - Moves the pen
    • SWFText::setColor - Sets the current text color
    • SWFText::setFont - Sets the current font
    • SWFText::setHeight - Sets the current font height
    • SWFText::setSpacing - Sets the current font spacing
    • SWFText::__construct - Creates a new SWFText object
    • SWFTextField::addChars - adds characters to a font that will be available within a textfield
    • SWFTextField::addString - Concatenates the given string to the text field
    • SWFTextField::align - Sets the text field alignment
    • SWFTextField::setBounds - Sets the text field width and height
    • SWFTextField::setColor - Sets the color of the text field
    • SWFTextField::setFont - Sets the text field font
    • SWFTextField::setHeight - Sets the font height of this text field font
    • SWFTextField::setIndentation - Sets the indentation of the first line
    • SWFTextField::setLeftMargin - Sets the left margin width of the text field
    • SWFTextField::setLineSpacing - Sets the line spacing of the text field
    • SWFTextField::setMargins - Sets the margins width of the text field
    • SWFTextField::setName - Sets the variable name
    • SWFTextField::setPadding - Sets the padding of this textfield
    • SWFTextField::setRightMargin - Sets the right margin width of the text field
    • SWFTextField::__construct - Creates a text field object
    • SWFVideoStream::getNumFrames - Returns the number of frames in the video
    • SWFVideoStream::setDimension - Sets video dimension
    • SWFVideoStream::__construct - Returns a SWFVideoStream object
    • Swish::getMetaList - Get the list of meta entries for the index
    • Swish::getPropertyList - Get the list of properties for the index
    • Swish::prepare - Prepare a search query
    • Swish::query - Execute a query and return results object
    • Swish::__construct - Construct a Swish object
    • SwishResult::getMetaList - Get a list of meta entries
    • SwishResult::stem - Stems the given word
    • SwishResults::getParsedWords - Get an array of parsed words
    • SwishResults::getRemovedStopwords - Get an array of stopwords removed from the query
    • SwishResults::nextResult - Get the next search result
    • SwishResults::seekResult - Set current seek pointer to the given position
    • SwishSearch::execute - Execute the search and get the results
    • SwishSearch::resetLimit - Reset the search limits
    • SwishSearch::setLimit - Set the search limits
    • SwishSearch::setPhraseDelimiter - Set the phrase delimiter
    • SwishSearch::setSort - Set the sort order
    • SwishSearch::setStructure - Set the structure flag in the search object
    • sybase_affected_rows - Gets number of affected rows in last query
    • sybase_close - Closes a Sybase connection
    • sybase_connect - Opens a Sybase server connection
    • sybase_data_seek - Moves internal row pointer
    • sybase_deadlock_retry_count - Sets the deadlock retry count
    • sybase_fetch_array - Fetch row as array
    • sybase_fetch_assoc - Fetch a result row as an associative array
    • sybase_fetch_field - Get field information from a result
    • sybase_fetch_object - Fetch a row as an object
    • sybase_fetch_row - Get a result row as an enumerated array
    • sybase_field_seek - Sets field offset
    • sybase_free_result - Frees result memory
    • sybase_get_last_message - Returns the last message from the server
    • sybase_min_client_severity - Sets minimum client severity
    • sybase_min_error_severity - Sets minimum error severity
    • sybase_min_message_severity - Sets minimum message severity
    • sybase_min_server_severity - Sets minimum server severity
    • sybase_num_fields - Gets the number of fields in a result set
    • sybase_num_rows - Get number of rows in a result set
    • sybase_pconnect - Open persistent Sybase connection
    • sybase_query - Sends a Sybase query
    • sybase_result - Get result data
    • sybase_select_db - Selects a Sybase database
    • sybase_set_message_handler - Sets the handler called when a server message is raised
    • sybase_unbuffered_query - Send a Sybase query and do not block
    • symlink - Bir sembolik bağ oluşturur
    • SyncEvent::fire - Fires/sets the event
    • SyncEvent::reset - Resets a manual event
    • SyncEvent::wait - Waits for the event to be fired/set
    • SyncEvent::__construct - Constructs a new SyncEvent object
    • SyncMutex::lock - Waits for an exclusive lock
    • SyncMutex::unlock - Unlocks the mutex
    • SyncMutex::__construct - Constructs a new SyncMutex object
    • SyncReaderWriter::readlock - Waits for a read lock
    • SyncReaderWriter::readunlock - Releases a read lock
    • SyncReaderWriter::writelock - Waits for an exclusive write lock
    • SyncReaderWriter::writeunlock - Releases a write lock
    • SyncReaderWriter::__construct - Constructs a new SyncReaderWriter object
    • SyncSemaphore::lock - Decreases the count of the semaphore or waits
    • SyncSemaphore::unlock - Increases the count of the semaphore
    • SyncSemaphore::__construct - Constructs a new SyncSemaphore object
    • SyncSharedMemory::first - Check to see if the object is the first instance system-wide of named shared memory
    • SyncSharedMemory::read - Copy data from named shared memory
    • SyncSharedMemory::size - Returns the size of the named shared memory
    • SyncSharedMemory::write - Copy data to named shared memory
    • SyncSharedMemory::__construct - Constructs a new SyncSharedMemory object
    • syslog - Bir sistem günlüğü iletisi üretir
    • system - Belirtilen harici komutu çalıştırır ve çıktısını gösterir
    • sys_getloadavg - Ortalama sistem yükünü döndürür
    • sys_get_temp_dir - Geçici dosyalar için kullanılan dizini döndürür
  • t
    • taint - Taint a string
    • tan - Tangent
    • tanh - Hyperbolic tangent
    • tcpwrap_check - Bir tcpwrap sınaması yapar
    • tempnam - Eşsiz bir isimle dosya oluşturur
    • textdomain - Öntanımlı uygulama adını tanımlar
    • Thread::detach - Execution
    • Thread::getCreatorId - Identification
    • Thread::getCurrentThread - Identification
    • Thread::getCurrentThreadId - Identification
    • Thread::getThreadId - Identification
    • Thread::globally - Execution
    • Thread::isJoined - State Detection
    • Thread::isStarted - State Detection
    • Thread::join - Synchronization
    • Thread::kill - Execution
    • Thread::start - Execution
    • Threaded::chunk - Manipulation
    • Threaded::count - Manipulation
    • Threaded::extend - Runtime Manipulation
    • Threaded::from - Creation
    • Threaded::getTerminationInfo - Error Detection
    • Threaded::isRunning - State Detection
    • Threaded::isTerminated - State Detection
    • Threaded::isWaiting - State Detection
    • Threaded::lock - Synchronization
    • Threaded::merge - Manipulation
    • Threaded::notify - Synchronization
    • Threaded::pop - Manipulation
    • Threaded::run - Execution
    • Threaded::shift - Manipulation
    • Threaded::synchronized - Synchronization
    • Threaded::unlock - Synchronization
    • Threaded::wait - Synchronization
    • tidy::$errorBuffer - Return warnings and errors which occurred parsing the specified document
    • tidy::body - Çözümleme ağacının <body> etiketiyle başlayan tidyNode nesnesini döndürür
    • tidy::cleanRepair - Çözümlenen imlenim üzerinde bakım ve onarım yapar
    • tidy::diagnose - Çözümlenen veya onarılan imlenim üzerinde tanılama yapar
    • tidy::getConfig - Geçerli Tidy yapılandırmasını döndürür
    • tidy::getOpt - Belirtilen yapılandırma seçeneğinin değerini döndürür
    • tidy::getoptdoc - Belirtilen seçenekle ilgili belgeyi döndürür
    • tidy::getRelease - Tidy kütüphanesinin dağıtım tarihini döndürür
    • tidy::getStatus - Belgenin durumunu döndürür
    • tidy::head - Çözümleme ağacının <head> etiketiyle başlayan tidyNode nesnesini döndürür
    • tidy::html - Çözümleme ağacının <html> etiketiyle başlayan tidyNode nesnesini döndürür
    • tidy::htmlver - Belgenin algılanan HTML sürümünü döndürür
    • tidy::isXhtml - Belge bir XHTML belge mi diye bakar
    • tidy::isXml - Belge salt bir XML (HTML/XHTML değil) belge mi diye bakar
    • tidy::parseFile - Belirtilen URI veya dosyadaki imlenimi çözümler
    • tidy::parseString - Bir dizge olarak belirtilen bir belgeyi çözümler
    • tidy::repairFile - Bir dosyayı onarıp bir dizge olarak döndürür
    • tidy::repairString - Seçimlik bir yapılandırma dosyasını kullanarak bir dizgeyi onarır
    • tidy::root - Çözümleme ağacının kökünü temsil eden bir tidyNode nesnesi döndürür
    • tidy::__construct - Yeni bir tidy nesnesi oluşturur
    • tidyNode::getParent - Geçerli düğümün ebeveynini döndürür
    • tidyNode::hasChildren - Düğümün çocukları olup olmadığına bakar
    • tidyNode::hasSiblings - Düğümün kardeşleri olup olmadığına bakar
    • tidyNode::isAsp - Düğümün bir ASP düğümü olup olmadığına bakar
    • tidyNode::isComment - Düğüm bir açıklama düğümü mü diye bakar
    • tidyNode::isHtml - Düğümün bir HTML belge parçası olup olmadığına bakar
    • tidyNode::isJste - Düğümün bir JSTE düğümü olup olmadığına bakar
    • tidyNode::isPhp - Düğümün bir PHP düğümü olup olmadığına bakar
    • tidyNode::isText - Düğümün bir metin düğümü olup olmadığına bakar
    • tidy_access_count - Belgede saptanan Tidy erişilebilirlik uyarılarının sayısını döndürür
    • tidy_config_count - Belgede saptanan Tidy yapılandırma hatalarının sayısını döndürür
    • tidy_error_count - Belgede saptanan Tidy hatalarının sayısını döndürür
    • tidy_get_output - Çözümlenen Tidy imlenimini bir dizge olarak döndürür
    • tidy_load_config - Bir Tidy yapılandırma dosyasını belirtilen kodlama ile yükler
    • tidy_reset_config - Tidy yapılandırmasını öntanımlı değerlere ayarlar
    • tidy_save_config - Geçerli ayarları belirtilen dosyaya kaydeder
    • tidy_setopt - Belgenin yapılandırma seçeneklerini günceller
    • tidy_set_encoding - Çözümlenecek imlenim için girdi/çıktı karakter kodlamasını belirler
    • tidy_warning_count - Belgede saptanan Tidy uyarılarının sayısını döndürür
    • time - Geçerli Unix zaman damgasını döndürür
    • timezone_abbreviations_list - DateTimeZone::listAbbreviations işlevinin takma adıdır
    • timezone_identifiers_list - DateTimeZone::listIdentifiers işlevinin takma adıdır
    • timezone_location_get - DateTimeZone::getLocation işlevinin takma adıdır
    • timezone_name_from_abbr - Kısaltmasından, zaman diliminin adını döndürür
    • timezone_name_get - DateTimeZone::getName işlevinin takma adıdır
    • timezone_offset_get - DateTimeZone::getOffset işlevinin takma adıdır
    • timezone_open - DateTimeZone::__construct için takma ad
    • timezone_transitions_get - DateTimeZone::getTransitions işlevinin takma adıdır
    • timezone_version_get - Gets the version of the timezonedb
    • time_nanosleep - Çalışmayı saniye ve nanosaniye cinsinden geciktirir
    • time_sleep_until - Belirtilen zamana kadar betiği uyutur
    • tmpfile - Geçici bir dosya oluşturur
    • token_get_all - Belirtilen kaynağı PHP dizgeciklerine ayırır
    • token_name - Belirtilen PHP dizgeciğinin simgesel ismini döndürür
    • TokyoTyrant::add - Adds to a numeric key
    • TokyoTyrant::connect - Connect to a database
    • TokyoTyrant::connectUri - Connects to a database
    • TokyoTyrant::copy - Copies the database
    • TokyoTyrant::ext - Execute a remote script
    • TokyoTyrant::fwmKeys - Returns the forward matching keys
    • TokyoTyrant::get - The get purpose
    • TokyoTyrant::getIterator - Get an iterator
    • TokyoTyrant::num - Number of records in the database
    • TokyoTyrant::out - Removes records
    • TokyoTyrant::put - Puts values
    • TokyoTyrant::putCat - Concatenates to a record
    • TokyoTyrant::putKeep - Puts a record
    • TokyoTyrant::putNr - Puts value
    • TokyoTyrant::putShl - Concatenates to a record
    • TokyoTyrant::restore - Restore the database
    • TokyoTyrant::setMaster - Set the replication master
    • TokyoTyrant::size - Returns the size of the value
    • TokyoTyrant::stat - Get statistics
    • TokyoTyrant::sync - Synchronize the database
    • TokyoTyrant::tune - Tunes connection values
    • TokyoTyrant::vanish - Empties the database
    • TokyoTyrant::__construct - Construct a new TokyoTyrant object
    • TokyoTyrantIterator::current - Get the current value
    • TokyoTyrantIterator::key - Returns the current key
    • TokyoTyrantIterator::next - Move to next key
    • TokyoTyrantIterator::rewind - Rewinds the iterator
    • TokyoTyrantIterator::valid - Rewinds the iterator
    • TokyoTyrantIterator::__construct - Construct an iterator
    • TokyoTyrantQuery::addCond - Adds a condition to the query
    • TokyoTyrantQuery::count - Counts records
    • TokyoTyrantQuery::current - Returns the current element
    • TokyoTyrantQuery::hint - Get the hint string of the query
    • TokyoTyrantQuery::key - Returns the current key
    • TokyoTyrantQuery::metaSearch - Retrieve records with multiple queries
    • TokyoTyrantQuery::next - Moves the iterator to next entry
    • TokyoTyrantQuery::out - Removes records based on query
    • TokyoTyrantQuery::rewind - Rewinds the iterator
    • TokyoTyrantQuery::search - Searches records
    • TokyoTyrantQuery::setLimit - Limit results
    • TokyoTyrantQuery::setOrder - Orders results
    • TokyoTyrantQuery::valid - Checks the validity of current item
    • TokyoTyrantQuery::__construct - Construct a new query
    • TokyoTyrantTable::add - Adds a record
    • TokyoTyrantTable::genUid - Generate unique id
    • TokyoTyrantTable::get - Get a row
    • TokyoTyrantTable::getIterator - Get an iterator
    • TokyoTyrantTable::getQuery - Get a query object
    • TokyoTyrantTable::out - Remove records
    • TokyoTyrantTable::put - Store a row
    • TokyoTyrantTable::putCat - Concatenates to a row
    • TokyoTyrantTable::putKeep - Put a new record
    • TokyoTyrantTable::putNr - Puts value
    • TokyoTyrantTable::putShl - Concatenates to a record
    • TokyoTyrantTable::setIndex - Sets index
    • touch - Dosyanın erişim ve değişiklik zamanını ayarlar
    • trader_acos - Vector Trigonometric ACos
    • trader_ad - Chaikin A/D Line
    • trader_add - Vector Arithmetic Add
    • trader_adosc - Chaikin A/D Oscillator
    • trader_adx - Average Directional Movement Index
    • trader_adxr - Average Directional Movement Index Rating
    • trader_apo - Absolute Price Oscillator
    • trader_aroon - Aroon
    • trader_aroonosc - Aroon Oscillator
    • trader_asin - Vector Trigonometric ASin
    • trader_atan - Vector Trigonometric ATan
    • trader_atr - Average True Range
    • trader_avgprice - Average Price
    • trader_bbands - Bollinger Bands
    • trader_beta - Beta
    • trader_bop - Balance Of Power
    • trader_cci - Commodity Channel Index
    • trader_cdl2crows - Two Crows
    • trader_cdl3blackcrows - Three Black Crows
    • trader_cdl3inside - Three Inside Up/Down
    • trader_cdl3linestrike - Three-Line Strike
    • trader_cdl3outside - Three Outside Up/Down
    • trader_cdl3starsinsouth - Three Stars In The South
    • trader_cdl3whitesoldiers - Three Advancing White Soldiers
    • trader_cdlabandonedbaby - Abandoned Baby
    • trader_cdladvanceblock - Advance Block
    • trader_cdlbelthold - Belt-hold
    • trader_cdlbreakaway - Breakaway
    • trader_cdlclosingmarubozu - Closing Marubozu
    • trader_cdlconcealbabyswall - Concealing Baby Swallow
    • trader_cdlcounterattack - Counterattack
    • trader_cdldarkcloudcover - Dark Cloud Cover
    • trader_cdldoji - Doji
    • trader_cdldojistar - Doji Star
    • trader_cdldragonflydoji - Dragonfly Doji
    • trader_cdlengulfing - Engulfing Pattern
    • trader_cdleveningdojistar - Evening Doji Star
    • trader_cdleveningstar - Evening Star
    • trader_cdlgapsidesidewhite - Up/Down-gap side-by-side white lines
    • trader_cdlgravestonedoji - Gravestone Doji
    • trader_cdlhammer - Hammer
    • trader_cdlhangingman - Hanging Man
    • trader_cdlharami - Harami Pattern
    • trader_cdlharamicross - Harami Cross Pattern
    • trader_cdlhighwave - High-Wave Candle
    • trader_cdlhikkake - Hikkake Pattern
    • trader_cdlhikkakemod - Modified Hikkake Pattern
    • trader_cdlhomingpigeon - Homing Pigeon
    • trader_cdlidentical3crows - Identical Three Crows
    • trader_cdlinneck - In-Neck Pattern
    • trader_cdlinvertedhammer - Inverted Hammer
    • trader_cdlkicking - Kicking
    • trader_cdlkickingbylength - Kicking - bull/bear determined by the longer marubozu
    • trader_cdlladderbottom - Ladder Bottom
    • trader_cdllongleggeddoji - Long Legged Doji
    • trader_cdllongline - Long Line Candle
    • trader_cdlmarubozu - Marubozu
    • trader_cdlmatchinglow - Matching Low
    • trader_cdlmathold - Mat Hold
    • trader_cdlmorningdojistar - Morning Doji Star
    • trader_cdlmorningstar - Morning Star
    • trader_cdlonneck - On-Neck Pattern
    • trader_cdlpiercing - Piercing Pattern
    • trader_cdlrickshawman - Rickshaw Man
    • trader_cdlrisefall3methods - Rising/Falling Three Methods
    • trader_cdlseparatinglines - Separating Lines
    • trader_cdlshootingstar - Shooting Star
    • trader_cdlshortline - Short Line Candle
    • trader_cdlspinningtop - Spinning Top
    • trader_cdlstalledpattern - Stalled Pattern
    • trader_cdlsticksandwich - Stick Sandwich
    • trader_cdltakuri - Takuri (Dragonfly Doji with very long lower shadow)
    • trader_cdltasukigap - Tasuki Gap
    • trader_cdlthrusting - Thrusting Pattern
    • trader_cdltristar - Tristar Pattern
    • trader_cdlunique3river - Unique 3 River
    • trader_cdlupsidegap2crows - Upside Gap Two Crows
    • trader_cdlxsidegap3methods - Upside/Downside Gap Three Methods
    • trader_ceil - Vector Ceil
    • trader_cmo - Chande Momentum Oscillator
    • trader_correl - Pearson's Correlation Coefficient (r)
    • trader_cos - Vector Trigonometric Cos
    • trader_cosh - Vector Trigonometric Cosh
    • trader_dema - Double Exponential Moving Average
    • trader_div - Vector Arithmetic Div
    • trader_dx - Directional Movement Index
    • trader_ema - Exponential Moving Average
    • trader_errno - Get error code
    • trader_exp - Vector Arithmetic Exp
    • trader_floor - Vector Floor
    • trader_get_compat - Get compatibility mode
    • trader_get_unstable_period - Get unstable period
    • trader_ht_dcperiod - Hilbert Transform - Dominant Cycle Period
    • trader_ht_dcphase - Hilbert Transform - Dominant Cycle Phase
    • trader_ht_phasor - Hilbert Transform - Phasor Components
    • trader_ht_sine - Hilbert Transform - SineWave
    • trader_ht_trendline - Hilbert Transform - Instantaneous Trendline
    • trader_ht_trendmode - Hilbert Transform - Trend vs Cycle Mode
    • trader_kama - Kaufman Adaptive Moving Average
    • trader_linearreg - Linear Regression
    • trader_linearreg_angle - Linear Regression Angle
    • trader_linearreg_intercept - Linear Regression Intercept
    • trader_linearreg_slope - Linear Regression Slope
    • trader_ln - Vector Log Natural
    • trader_log10 - Vector Log10
    • trader_ma - Moving average
    • trader_macd - Moving Average Convergence/Divergence
    • trader_macdext - MACD with controllable MA type
    • trader_macdfix - Moving Average Convergence/Divergence Fix 12/26
    • trader_mama - MESA Adaptive Moving Average
    • trader_mavp - Moving average with variable period
    • trader_max - Highest value over a specified period
    • trader_maxindex - Index of highest value over a specified period
    • trader_medprice - Median Price
    • trader_mfi - Money Flow Index
    • trader_midpoint - MidPoint over period
    • trader_midprice - Midpoint Price over period
    • trader_min - Lowest value over a specified period
    • trader_minindex - Index of lowest value over a specified period
    • trader_minmax - Lowest and highest values over a specified period
    • trader_minmaxindex - Indexes of lowest and highest values over a specified period
    • trader_minus_di - Minus Directional Indicator
    • trader_minus_dm - Minus Directional Movement
    • trader_mom - Momentum
    • trader_mult - Vector Arithmetic Mult
    • trader_natr - Normalized Average True Range
    • trader_obv - On Balance Volume
    • trader_plus_di - Plus Directional Indicator
    • trader_plus_dm - Plus Directional Movement
    • trader_ppo - Percentage Price Oscillator
    • trader_roc - Rate of change : ((price/prevPrice)-1)*100
    • trader_rocp - Rate of change Percentage: (price-prevPrice)/prevPrice
    • trader_rocr - Rate of change ratio: (price/prevPrice)
    • trader_rocr100 - Rate of change ratio 100 scale: (price/prevPrice)*100
    • trader_rsi - Relative Strength Index
    • trader_sar - Parabolic SAR
    • trader_sarext - Parabolic SAR - Extended
    • trader_set_compat - Set compatibility mode
    • trader_set_unstable_period - Set unstable period
    • trader_sin - Vector Trigonometric Sin
    • trader_sinh - Vector Trigonometric Sinh
    • trader_sma - Simple Moving Average
    • trader_sqrt - Vector Square Root
    • trader_stddev - Standard Deviation
    • trader_stoch - Stochastic
    • trader_stochf - Stochastic Fast
    • trader_stochrsi - Stochastic Relative Strength Index
    • trader_sub - Vector Arithmetic Subtraction
    • trader_sum - Summation
    • trader_t3 - Triple Exponential Moving Average (T3)
    • trader_tan - Vector Trigonometric Tan
    • trader_tanh - Vector Trigonometric Tanh
    • trader_tema - Triple Exponential Moving Average
    • trader_trange - True Range
    • trader_trima - Triangular Moving Average
    • trader_trix - 1-day Rate-Of-Change (ROC) of a Triple Smooth EMA
    • trader_tsf - Time Series Forecast
    • trader_typprice - Typical Price
    • trader_ultosc - Ultimate Oscillator
    • trader_var - Variance
    • trader_wclprice - Weighted Close Price
    • trader_willr - Williams' %R
    • trader_wma - Weighted Moving Average
    • trait_exists - Checks if the trait exists
    • trigger_error - Kullanıcı seviyesinde bir hata/uyarı/bilgi iletisi üretir
    • trim - Dizgenin başındaki ve sonundaki boşlukları (veya diğer karakterleri) budar
  • u
    • uasort - Bir diziyi kullanıcı tanımlı bir işlev kullanarak indislerine göre sıralarken anahtar/değer ilişkisini korur
    • ucfirst - Dizgenin ilk karakterini büyük harfe çevirir
    • ucwords - Dizgedeki her sözcüğün ilk harfini büyük harf yapar
    • udm_add_search_limit - Add various search limits
    • udm_alloc_agent - Allocate mnoGoSearch session
    • udm_alloc_agent_array - Allocate mnoGoSearch session
    • udm_api_version - Get mnoGoSearch API version
    • udm_cat_list - Get all the categories on the same level with the current one
    • udm_cat_path - Get the path to the current category
    • udm_check_charset - Check if the given charset is known to mnogosearch
    • udm_clear_search_limits - Clear all mnoGoSearch search restrictions
    • udm_crc32 - Return CRC32 checksum of given string
    • udm_errno - Get mnoGoSearch error number
    • udm_error - Get mnoGoSearch error message
    • udm_find - Perform search
    • udm_free_agent - Free mnoGoSearch session
    • udm_free_ispell_data - Free memory allocated for ispell data
    • udm_free_res - Free mnoGoSearch result
    • udm_get_doc_count - Get total number of documents in database
    • udm_get_res_field - Fetch a result field
    • udm_get_res_param - Get mnoGoSearch result parameters
    • udm_hash32 - Return Hash32 checksum of given string
    • udm_load_ispell_data - Load ispell data
    • udm_set_agent_param - Set mnoGoSearch agent session parameters
    • UI\Area::onDraw - Draw Callback
    • UI\Area::onKey - Key Callback
    • UI\Area::onMouse - Mouse Callback
    • UI\Area::redraw - Redraw Area
    • UI\Area::scrollTo - Area Scroll
    • UI\Area::setSize - Set Size
    • UI\Control::destroy - Destroy Control
    • UI\Control::disable - Disable Control
    • UI\Control::enable - Enable Control
    • UI\Control::getParent - Get Parent Control
    • UI\Control::getTopLevel - Get Top Level
    • UI\Control::hide - Hide Control
    • UI\Control::isEnabled - Determine if Control is enabled
    • UI\Control::isVisible - Determine if Control is visible
    • UI\Control::setParent - Set Parent Control
    • UI\Control::show - Control Show
    • UI\Controls\Box::append - Append Control
    • UI\Controls\Box::delete - Delete Control
    • UI\Controls\Box::getOrientation - Get Orientation
    • UI\Controls\Box::isPadded - Padding Detection
    • UI\Controls\Box::setPadded - Set Padding
    • UI\Controls\Box::__construct - Construct a new Box
    • UI\Controls\Button::getText - Get Text
    • UI\Controls\Button::onClick - Click Handler
    • UI\Controls\Button::setText - Set Text
    • UI\Controls\Button::__construct - Construct a new Button
    • UI\Controls\Check::getText - Get Text
    • UI\Controls\Check::isChecked - Checked Detection
    • UI\Controls\Check::onToggle - Toggle Callback
    • UI\Controls\Check::setChecked - Set Checked
    • UI\Controls\Check::setText - Set Text
    • UI\Controls\Check::__construct - Construct a new Check
    • UI\Controls\ColorButton::getColor - Get Color
    • UI\Controls\ColorButton::onChange - Change Handler
    • UI\Controls\ColorButton::setColor - Set Color
    • UI\Controls\Combo::append - Append Option
    • UI\Controls\Combo::getSelected - Get Selected Option
    • UI\Controls\Combo::onSelected - Selected Handler
    • UI\Controls\Combo::setSelected - Set Selected Option
    • UI\Controls\EditableCombo::append - Append Option
    • UI\Controls\EditableCombo::getText - Get Text
    • UI\Controls\EditableCombo::onChange - Change Handler
    • UI\Controls\EditableCombo::setText - Set Text
    • UI\Controls\Entry::getText - Get Text
    • UI\Controls\Entry::isReadOnly - Detect Read Only
    • UI\Controls\Entry::onChange - Change Handler
    • UI\Controls\Entry::setReadOnly - Set Read Only
    • UI\Controls\Entry::setText - Set Text
    • UI\Controls\Entry::__construct - Construct a new Entry
    • UI\Controls\Form::append - Append Control
    • UI\Controls\Form::delete - Delete Control
    • UI\Controls\Form::isPadded - Padding Detection
    • UI\Controls\Form::setPadded - Set Padding
    • UI\Controls\Grid::append - Append Control
    • UI\Controls\Grid::isPadded - Padding Detection
    • UI\Controls\Grid::setPadded - Set Padding
    • UI\Controls\Group::append - Append Control
    • UI\Controls\Group::getTitle - Get Title
    • UI\Controls\Group::hasMargin - Margin Detection
    • UI\Controls\Group::setMargin - Set Margin
    • UI\Controls\Group::setTitle - Set Title
    • UI\Controls\Group::__construct - Construct a new Group
    • UI\Controls\Label::getText - Get Text
    • UI\Controls\Label::setText - Set Text
    • UI\Controls\Label::__construct - Construct a new Label
    • UI\Controls\MultilineEntry::append - Append Text
    • UI\Controls\MultilineEntry::getText - Get Text
    • UI\Controls\MultilineEntry::isReadOnly - Read Only Detection
    • UI\Controls\MultilineEntry::onChange - Change Handler
    • UI\Controls\MultilineEntry::setReadOnly - Set Read Only
    • UI\Controls\MultilineEntry::setText - Set Text
    • UI\Controls\MultilineEntry::__construct - Construct a new Multiline Entry
    • UI\Controls\Picker::__construct - Construct a new Picker
    • UI\Controls\Progress::getValue - Get Value
    • UI\Controls\Progress::setValue - Set Value
    • UI\Controls\Radio::append - Append Option
    • UI\Controls\Radio::getSelected - Get Selected Option
    • UI\Controls\Radio::onSelected - Selected Handler
    • UI\Controls\Radio::setSelected - Set Selected Option
    • UI\Controls\Separator::__construct - Construct a new Separator
    • UI\Controls\Slider::getValue - Get Value
    • UI\Controls\Slider::onChange - Change Handler
    • UI\Controls\Slider::setValue - Set Value
    • UI\Controls\Slider::__construct - Construct a new Slider
    • UI\Controls\Spin::getValue - Get Value
    • UI\Controls\Spin::onChange - Change Handler
    • UI\Controls\Spin::setValue - Set Value
    • UI\Controls\Spin::__construct - Construct a new Spin
    • UI\Controls\Tab::append - Append Page
    • UI\Controls\Tab::delete - Delete Page
    • UI\Controls\Tab::hasMargin - Margin Detection
    • UI\Controls\Tab::insertAt - Insert Page
    • UI\Controls\Tab::pages - Page Count
    • UI\Controls\Tab::setMargin - Set Margin
    • UI\Draw\Brush::getColor - Get Color
    • UI\Draw\Brush::setColor - Set Color
    • UI\Draw\Brush::__construct - Construct a new Brush
    • UI\Draw\Brush\Gradient::addStop - Stop Manipulation
    • UI\Draw\Brush\Gradient::delStop - Stop Manipulation
    • UI\Draw\Brush\Gradient::setStop - Stop Manipulation
    • UI\Draw\Brush\LinearGradient::__construct - Construct a Linear Gradient
    • UI\Draw\Brush\RadialGradient::__construct - Construct a new Radial Gradient
    • UI\Draw\Color::getChannel - Color Manipulation
    • UI\Draw\Color::setChannel - Color Manipulation
    • UI\Draw\Color::__construct - Construct new Color
    • UI\Draw\Matrix::invert - Invert Matrix
    • UI\Draw\Matrix::isInvertible - Invertible Detection
    • UI\Draw\Matrix::multiply - Multiply Matrix
    • UI\Draw\Matrix::rotate - Rotate Matrix
    • UI\Draw\Matrix::scale - Scale Matrix
    • UI\Draw\Matrix::skew - Skew Matrix
    • UI\Draw\Matrix::translate - Translate Matrix
    • UI\Draw\Path::addRectangle - Draw a Rectangle
    • UI\Draw\Path::arcTo - Draw an Arc
    • UI\Draw\Path::bezierTo - Draw Bezier Curve
    • UI\Draw\Path::closeFigure - Close Figure
    • UI\Draw\Path::end - Finalize Path
    • UI\Draw\Path::lineTo - Draw a Line
    • UI\Draw\Path::newFigure - Draw Figure
    • UI\Draw\Path::newFigureWithArc - Draw Figure with Arc
    • UI\Draw\Path::__construct - Construct a new Path
    • UI\Draw\Pen::clip - Clip a Path
    • UI\Draw\Pen::fill - Fill a Path
    • UI\Draw\Pen::restore - Restore
    • UI\Draw\Pen::save - Save
    • UI\Draw\Pen::stroke - Stroke a Path
    • UI\Draw\Pen::transform - Matrix Transform
    • UI\Draw\Pen::write - Draw Text at Point
    • UI\Draw\Stroke::getCap - Get Line Cap
    • UI\Draw\Stroke::getJoin - Get Line Join
    • UI\Draw\Stroke::getMiterLimit - Get Miter Limit
    • UI\Draw\Stroke::getThickness - Get Thickness
    • UI\Draw\Stroke::setCap - Set Line Cap
    • UI\Draw\Stroke::setJoin - Set Line Join
    • UI\Draw\Stroke::setMiterLimit - Set Miter Limit
    • UI\Draw\Stroke::setThickness - Set Thickness
    • UI\Draw\Stroke::__construct - Construct a new Stroke
    • UI\Draw\Text\Font::getAscent - Font Metrics
    • UI\Draw\Text\Font::getDescent - Font Metrics
    • UI\Draw\Text\Font::getLeading - Font Metrics
    • UI\Draw\Text\Font::getUnderlinePosition - Font Metrics
    • UI\Draw\Text\Font::getUnderlineThickness - Font Metrics
    • UI\Draw\Text\Font::__construct - Construct a new Font
    • UI\Draw\Text\Font\Descriptor::getFamily - Get Font Family
    • UI\Draw\Text\Font\Descriptor::getItalic - Style Detection
    • UI\Draw\Text\Font\Descriptor::getSize - Size Detection
    • UI\Draw\Text\Font\Descriptor::getStretch - Style Detection
    • UI\Draw\Text\Font\Descriptor::getWeight - Weight Detection
    • UI\Draw\Text\Font\Descriptor::__construct - Construct a new Font Descriptor
    • UI\Draw\Text\Font\fontFamilies - Retrieve Font Families
    • UI\Draw\Text\Layout::setColor - Set Color
    • UI\Draw\Text\Layout::setWidth - Set Width
    • UI\Draw\Text\Layout::__construct - Construct a new Text Layout
    • UI\Executor::kill - Stop Executor
    • UI\Executor::onExecute - Execution Callback
    • UI\Executor::setInterval - Interval Manipulation
    • UI\Executor::__construct - Construct a new Executor
    • UI\Menu::append - Append Menu Item
    • UI\Menu::appendAbout - Append About Menu Item
    • UI\Menu::appendCheck - Append Checkable Menu Item
    • UI\Menu::appendPreferences - Append Preferences Menu Item
    • UI\Menu::appendQuit - Append Quit Menu Item
    • UI\Menu::appendSeparator - Append Menu Item Separator
    • UI\Menu::__construct - Construct a new Menu
    • UI\MenuItem::disable - Disable Menu Item
    • UI\MenuItem::enable - Enable Menu Item
    • UI\MenuItem::isChecked - Detect Checked
    • UI\MenuItem::onClick - On Click Callback
    • UI\MenuItem::setChecked - Set Checked
    • UI\Point::at - Size Coercion
    • UI\Point::getX - Retrieves X
    • UI\Point::getY - Retrieves Y
    • UI\Point::setX - Set X
    • UI\Point::setY - Set Y
    • UI\Point::__construct - Construct a new Point
    • UI\quit - Quit UI Loop
    • UI\run - Enter UI Loop
    • UI\Size::getHeight - Retrieves Height
    • UI\Size::getWidth - Retrives Width
    • UI\Size::of - Point Coercion
    • UI\Size::setHeight - Set Height
    • UI\Size::setWidth - Set Width
    • UI\Size::__construct - Construct a new Size
    • UI\Window::add - Add a Control
    • UI\Window::error - Show Error Box
    • UI\Window::getSize - Get Window Size
    • UI\Window::getTitle - Get Title
    • UI\Window::hasBorders - Border Detection
    • UI\Window::hasMargin - Margin Detection
    • UI\Window::isFullScreen - Full Screen Detection
    • UI\Window::msg - Show Message Box
    • UI\Window::onClosing - Closing Callback
    • UI\Window::open - Open Dialog
    • UI\Window::save - Save Dialog
    • UI\Window::setBorders - Border Use
    • UI\Window::setFullScreen - Full Screen Use
    • UI\Window::setMargin - Margin Use
    • UI\Window::setSize - Set Size
    • UI\Window::setTitle - Window Title
    • UI\Window::__construct - Construct a new Window
    • uksort - Bir diziyi kullanıcı tanımlı bir işlev kullanarak anahtarlarına göre sıralar
    • umask - Geçerli izin maskesini değiştirir
    • uniqid - Eşsiz bir kimlik dizgesi üretir
    • unixtojd - Unix zaman damgasını, Jülyen Gün Sayısına çevirir
    • unlink - Bir dosyayı siler
    • unpack - Paketlenmiş bir ikil dizgeden verileri ayrıştırır
    • unregister_tick_function - Her tikte çalıştırılacak işlevi tanımsız yapar
    • unserialize - Bir PHP değerini saklanmış gösteriminden oluşturur
    • unset - Belirtilen değişkeni tanımsız yapar
    • untaint - Untaint strings
    • uopz_backup - Backup a function
    • uopz_compose - Compose a class
    • uopz_copy - Copy a function
    • uopz_delete - Delete a function
    • uopz_extend - Extend a class at runtime
    • uopz_flags - Get or set flags on function or class
    • uopz_function - Creates a function at runtime
    • uopz_implement - Implements an interface at runtime
    • uopz_overload - Overload a VM opcode
    • uopz_redefine - Redefine a constant
    • uopz_rename - Rename a function at runtime
    • uopz_restore - Restore a previously backed up function
    • uopz_undefine - Undefine a constant
    • urldecode - URL kodlamalı dizgenin kodlamasını çözer
    • urlencode - Dizgeye URL kodlaması uygular
    • user_error - trigger_error işlevinin takma adıdır
    • use_soap_error_handler - Set whether to use the SOAP error handler
    • usleep - Çalışmayı mikrosaniye cinsinden geciktirir
    • usort - Bir diziyi kullanıcı tanımlı bir işlev kullanarak değerlerine göre sıralar
    • utf8_decode - ISO-8859-1 karakterlerinin UTF-8 gösterimlerini ISO-8859-1 gösterimlerine dönüştürür
    • utf8_encode - Bir ISO-8859-1 dizgeyi UTF-8'e dönüştürür
  • v
    • V8Js::executeString - Execute a string as Javascript code
    • V8Js::getExtensions - Return an array of registered extensions
    • V8Js::getPendingException - Return pending uncaught Javascript exception
    • V8Js::registerExtension - Register Javascript extensions for V8Js
    • V8Js::__construct - Construct a new V8Js object
    • V8JsException::getJsFileName - The getJsFileName purpose
    • V8JsException::getJsLineNumber - The getJsLineNumber purpose
    • V8JsException::getJsSourceLine - The getJsSourceLine purpose
    • V8JsException::getJsTrace - The getJsTrace purpose
    • variant_abs - Bir varyantın mutlak değerini döndürür
    • variant_add - İki varyant değeri birleştirir ve sonucu geri döndürür
    • variant_and - İki varyant üzerinde ikilik VE işlemi yapar
    • variant_cast - Varyantı başka türde bir varyant nesneye dönüştürür
    • variant_cat - İki varyant değeri birleştirir ve sonucu geri döndürür
    • variant_cmp - İki varyant değerini karşılaştırır
    • variant_date_from_timestamp - Unix zaman damgasının varyant tarih gösterimini döndürür
    • variant_date_to_timestamp - Varyant tarih/zaman değerini Unix zaman damgasına çevirir
    • variant_div - İki varyant değerin bölme sonucunu döndürür
    • variant_eqv - İki varyant arasında ikilik denklik karşılaştırması yapar
    • variant_fix - Varyantın tamsayı kısmını geri döndürür
    • variant_get_type - Varyant nesnenin türünü geri döndürür
    • variant_idiv - Varyant değerleri tamsayıya çevirir ve bölme yaparak sonucu döndürür
    • variant_imp - İki varyant üzerinde ikilik çıkarım yapar
    • variant_int - Varyantın tamsayı kısmını döndürür
    • variant_mod - İki varyantın bölme işleminden kalanı geri döndürür
    • variant_mul - İki varyant değerleri için çarpma işlemi yapar
    • variant_neg - Bir varyant üzerinde mantıksal değil işlemi yapar
    • variant_not - Bir varyant üzerinde ikilik değil işlemi yapar
    • variant_or - İki varyant üzerinde mantıksal ayırma işlemi yapar
    • variant_pow - Üs alma işlemi yaparak sonucu döndürür
    • variant_round - Bir varyantı verilen ondalık basamağa yuvarlar
    • variant_set - Varyant nesnesine yeni bir değer verir
    • variant_set_type - Varyantı başka bir türe "yerinde" dönüştürür
    • variant_sub - Sağ varyant değerini sol varyant değerinden çıkartır
    • variant_xor - İki varyant arasında mantıksal çıkarma yapar
    • VarnishAdmin::auth - Authenticate on a varnish instance
    • VarnishAdmin::ban - Ban URLs using a VCL expression
    • VarnishAdmin::banUrl - Ban an URL using a VCL expression
    • VarnishAdmin::clearPanic - Clear varnish instance panic messages
    • VarnishAdmin::connect - Connect to a varnish instance administration interface
    • VarnishAdmin::disconnect - Disconnect from a varnish instance administration interface
    • VarnishAdmin::getPanic - Get the last panic message on a varnish instance
    • VarnishAdmin::getParams - Fetch current varnish instance configuration parameters
    • VarnishAdmin::isRunning - Check if the varnish slave process is currently running
    • VarnishAdmin::setCompat - Set the class compat configuration param
    • VarnishAdmin::setHost - Set the class host configuration param
    • VarnishAdmin::setIdent - Set the class ident configuration param
    • VarnishAdmin::setParam - Set configuration param on the current varnish instance
    • VarnishAdmin::setPort - Set the class port configuration param
    • VarnishAdmin::setSecret - Set the class secret configuration param
    • VarnishAdmin::setTimeout - Set the class timeout configuration param
    • VarnishAdmin::start - Start varnish worker process
    • VarnishAdmin::stop - Stop varnish worker process
    • VarnishAdmin::__construct - VarnishAdmin constructor
    • VarnishLog::getLine - Get next log line
    • VarnishLog::getTagName - Get the log tag string representation by its index
    • VarnishLog::__construct - Varnishlog constructor
    • VarnishStat::getSnapshot - Get the current varnish instance statistics snapshot
    • VarnishStat::__construct - VarnishStat constructor
    • var_dump - Bir değişkenle ilgili bilgiyi dökümler
    • var_export - Bir değişkenin çözümlenebilir dizge gösterimini döndürür veya çıktılar
    • version_compare - PHP standardına uygun hale getirilmiş iki sürüm numarası dizgesini karşılaştırır
    • vfprintf - Biçemli dizgeyi bir akıma yazar
    • virtual - Bir Apache alt isteği gerçekleştirir
    • vpopmail_add_alias_domain - Bir sanal alan için bir takma ad ekler
    • vpopmail_add_alias_domain_ex - Mevcut bir sanal alana takma ad ekler.
    • vpopmail_add_domain - Yeni bir sanal alan adı ekler
    • vpopmail_add_domain_ex - Yeni bir sanal alan adı ekler
    • vpopmail_add_user - Belirtilen sanal alana yeni bir kullanıcı ekler
    • vpopmail_alias_add - Bir sanal takma ad ekler
    • vpopmail_alias_del - Bir kullanıcının tüm sanal takma adlarını siler
    • vpopmail_alias_del_domain - Bir alan adının tüm sanal takma adlarını siler
    • vpopmail_alias_get - Bir alan adı için bir rumuzun tüm satırlarını döndürür
    • vpopmail_alias_get_all - Bir alan adı için bir takma adın tüm satırlarını döndürür
    • vpopmail_auth_user - Bir kullanıcı/alan/parolayı doğrulatmaya çalışır.
    • vpopmail_del_domain - Bir sanal alanı siler
    • vpopmail_del_domain_ex - Bir sanal alanı siler
    • vpopmail_del_user - Sanal alandan belirtilen kullanıcıyı siler
    • vpopmail_error - Son vpopmail hatasının iletisini döndürür
    • vpopmail_passwd - Bir sanal kullanıcının parolasını değiştirir
    • vpopmail_set_user_quota - Bir sanal kullanıcıya kota koyar
    • vprintf - Biçemli bir dizge çıktılar
    • vsprintf - Biçemli bir dizge döndürür
  • w
    • wddx_add_vars - Tanıtıcısı belirtilen WDDX paketine değişken ekler
    • wddx_deserialize - wddx_unserialize işlevinin takma adıdır
    • wddx_packet_end - Tanıtıcısı belirtilen WDDX paketini kapatır
    • wddx_packet_start - Bir veri yapısı içeren yeni bir WDDX paketi başlatır
    • wddx_serialize_value - Tek bir değeri bir WDDX paketi içinde dizgeleştirir
    • wddx_serialize_vars - Değişkenleri bir WDDX paketi olara dizgeleştirir
    • WeakMap::count - Counts the number of live entries in the map
    • WeakMap::current - Returns the current value under iteration
    • WeakMap::key - Returns the current key under iteration.
    • WeakMap::next - Advances to the next map element
    • WeakMap::offsetExists - Checks whether a certain object is in the map
    • WeakMap::offsetGet - Returns the value pointed to by a certain object
    • WeakMap::offsetSet - Updates the map with a new key-value pair
    • WeakMap::offsetUnset - Removes an entry from the map
    • WeakMap::rewind - Rewinds the iterator to the beginning of the map
    • WeakMap::valid - Returns whether the iterator is still on a valid map element
    • WeakMap::__construct - Constructs a new map
    • Weakref::acquire - Acquires a strong reference on that object
    • Weakref::get - Returns the object pointed to by the weak reference
    • Weakref::release - Releases a previously acquired reference
    • Weakref::valid - Checks whether the object referenced still exists
    • Weakref::__construct - Constructs a new weak reference
    • win32_continue_service - Resumes a paused service
    • win32_create_service - Hizmet yönetim veritabanında yeni bir hizmet girdisi oluşturur
    • win32_delete_service - Bir hizmet girdisini Hizmet yönetim veritabanından siler
    • win32_get_last_control_message - Hizmete gönderilmiş son denetim kodunu döndürür
    • win32_pause_service - Pauses a service
    • win32_ps_list_procs - Çalışan süreçleri listeler
    • win32_ps_stat_mem - Bellek kullanımı ile ilgili istatistikleri döndürür
    • win32_ps_stat_proc - Belirtilen süreçle ilgili istatistikleri döndürür
    • win32_query_service_status - Bir hizmetin durumunu sorgular
    • win32_set_service_status - Hizmet durumunu günceller
    • win32_start_service - Bir hizmeti başlatır
    • win32_start_service_ctrl_dispatcher - Hizmet yöneticisine ismi belirtilen hizmet gibi davranacak bir betik tanıtır
    • win32_stop_service - Bir hizmeti durdurur
    • wincache_fcache_fileinfo - Retrieves information about files cached in the file cache
    • wincache_fcache_meminfo - Retrieves information about file cache memory usage
    • wincache_lock - Acquires an exclusive lock on a given key
    • wincache_ocache_fileinfo - Retrieves information about files cached in the opcode cache
    • wincache_ocache_meminfo - Retrieves information about opcode cache memory usage
    • wincache_refresh_if_changed - Refreshes the cache entries for the cached files
    • wincache_rplist_fileinfo - Retrieves information about resolve file path cache
    • wincache_rplist_meminfo - Retrieves information about memory usage by the resolve file path cache
    • wincache_scache_info - Retrieves information about files cached in the session cache
    • wincache_scache_meminfo - Retrieves information about session cache memory usage
    • wincache_ucache_add - Adds a variable in user cache only if variable does not already exist in the cache
    • wincache_ucache_cas - Compares the variable with old value and assigns new value to it
    • wincache_ucache_clear - Deletes entire content of the user cache
    • wincache_ucache_dec - Decrements the value associated with the key
    • wincache_ucache_delete - Deletes variables from the user cache
    • wincache_ucache_exists - Checks if a variable exists in the user cache
    • wincache_ucache_get - Gets a variable stored in the user cache
    • wincache_ucache_inc - Increments the value associated with the key
    • wincache_ucache_info - Retrieves information about data stored in the user cache
    • wincache_ucache_meminfo - Retrieves information about user cache memory usage
    • wincache_ucache_set - Adds a variable in user cache and overwrites a variable if it already exists in the cache
    • wincache_unlock - Releases an exclusive lock on a given key
    • wordwrap - Bir dizgeyi belli bir uzunlukta katlar
    • Worker::collect - Collect references to completed tasks
    • Worker::getStacked - Gets the remaining stack size
    • Worker::isShutdown - State Detection
    • Worker::isWorking - State Detection
    • Worker::shutdown - Shutdown the worker
    • Worker::stack - Stacking work
    • Worker::unstack - Unstacking work
  • x
    • xattr_get - Bir özniteliğin değerini döndürür
    • xattr_list - Ek özniteliklerin listesini döndürür
    • xattr_remove - Bir ek özniteliği siler
    • xattr_set - Bir ek özniteliği tanımlar
    • xattr_supported - Dosya sistemi ek öznitelikleri destekliyor mu diye bakar
    • xdiff_file_bdiff - İki dosyanın ikil farkını alır
    • xdiff_file_bdiff_size - Belirtilen ikil yama uygulanarak oluşturulacak dosyanın boyutunu döndürür
    • xdiff_file_bpatch - Bir dosyaya bir ikil yama uygular
    • xdiff_file_diff - İki dosyanın tekil farkını alır
    • xdiff_file_diff_binary - xdiff_file_bdiff işlevinin takma adıdır
    • xdiff_file_merge3 - Üç dosyayı tek dosya haline getirir
    • xdiff_file_patch - Bir dosyaya bir tekil yama uygular
    • xdiff_file_patch_binary - xdiff_file_bpatch işlevinin takma adıdır
    • xdiff_file_rabdiff - Rabin'in çok terimli parmakizi algoritmasını kullanarak iki dizgenin ikil olarak farkını alır
    • xdiff_string_bdiff - İki dizgenin ikil farkını alır
    • xdiff_string_bdiff_size - Belirtilen ikil yama uygulanarak oluşturulacak dosyanın boyutunu döndürür
    • xdiff_string_bpatch - Bir dizgeyi bir ikil fark dizgesiyle yamar
    • xdiff_string_diff - İki dizgenin tekil farkını alır
    • xdiff_string_diff_binary - xdiff_string_bdiff işlevinin takma adıdır
    • xdiff_string_merge3 - Üç dizgeyi tek bir dizge haline getirir
    • xdiff_string_patch - Bir dizgeyi bir tekil fark dizgesi ile yamar
    • xdiff_string_patch_binary - xdiff_string_bpatch işlevinin takma ismidir
    • xdiff_string_rabdiff - Rabin'in çok terimli parmakizi algoritmasını kullanarak iki dizgenin ikil olarak farkını alır
    • xhprof_disable - Stops xhprof profiler
    • xhprof_enable - Start xhprof profiler
    • xhprof_sample_disable - Stops xhprof sample profiler
    • xhprof_sample_enable - Start XHProf profiling in sampling mode
    • XMLDiff\Base::diff - Produce diff of two XML documents
    • XMLDiff\Base::merge - Produce new XML document based on diff
    • XMLDiff\Base::__construct - Constructor
    • XMLDiff\DOM::diff - Diff two DOMDocument objects
    • XMLDiff\DOM::merge - Produce merged DOMDocument
    • XMLDiff\File::diff - Diff two XML files
    • XMLDiff\File::merge - Produce merged XML document
    • XMLDiff\Memory::diff - Diff two XML documents
    • XMLDiff\Memory::merge - Produce merged XML document
    • XMLReader::close - XMLReader girdisini kapatır
    • XMLReader::expand - Geçerli düğümün bir kopyasını bir DOM nesnesi olarak döndürür
    • XMLReader::getAttribute - İsmi belirtilen özniteliğin değerini döndürür
    • XMLReader::getAttributeNo - İndisi belirtilen özniteliğin değerini döndürür
    • XMLReader::getAttributeNs - İsmi ve isim alanı belirtilen özniteliğin değerini döndürür
    • XMLReader::getParserProperty - Belirtilen özelliğin tanımlı olup olmadığına bakar
    • XMLReader::isValid - Çözümlenen belgenin geçerli olup olmadığına bakar
    • XMLReader::lookupNamespace - Bir önek için isim alanına bakar
    • XMLReader::moveToAttribute - İmleci ismi belirtilen özniteliğe konumlar
    • XMLReader::moveToAttributeNo - Move cursor to an attribute by index
    • XMLReader::moveToAttributeNs - Move cursor to a named attribute
    • XMLReader::moveToElement - İmleci geçerli özniteliğin ebeveyn elemanına konumlar
    • XMLReader::moveToFirstAttribute - İmleci ilk özniteliğe konumlar
    • XMLReader::moveToNextAttribute - İmleci sonraki özniteliğe konumlar
    • XMLReader::next - Alt ağaçların tümünü atlayıp sonraki düğüme gider
    • XMLReader::open - Çözemlenecek XML belgeyi içeren adresi belirler
    • XMLReader::read - Belgedeki sonraki düğüme gidilir
    • XMLReader::readInnerXML - Geçerli düğümün içeriğini okur
    • XMLReader::readOuterXML - Geçerli düğümün içeriğini düğümün kendisiyle birlikte okur
    • XMLReader::readString - Geçerli düğümün içeriğini bir dizge olarak okur
    • XMLReader::setParserProperty - Çözümleyici seçeneklerini tanımlar
    • XMLReader::setRelaxNGSchema - Belgeyi RelaxNG şemasına göre doğrular
    • XMLReader::setRelaxNGSchemaSource - Belgeyi dizge olarak belirtilen RelaxNG şemasına göre doğrular
    • XMLReader::setSchema - Belgeyi XSD şemasına göre doğrular
    • XMLReader::XML - Çözümlenecek XML belge içeriği belirtilir
    • xmlrpc_decode - XML'i doğal PHP türlerine dönüştürür
    • xmlrpc_decode_request - XML'i doğal PHP türlerine dönüştürür
    • xmlrpc_encode - Bir PHP değeri için XML üretir
    • xmlrpc_encode_request - Bir yöntem çağrısı için XML üretir
    • xmlrpc_get_type - Bir PHP değerinin xmlrpc türünü döndürür
    • xmlrpc_is_fault - Bir dizinin bir XMLRPC hatasını gösterip göstermediğini tespit eder
    • xmlrpc_parse_method_descriptions - XML'i bir yöntem açıklamaları listesine dönüştürür
    • xmlrpc_server_add_introspection_data - Kendiliğinden üretilen belgeleme ekler
    • xmlrpc_server_call_method - XML isteklerini ve yöntem çağrılarını çözümler
    • xmlrpc_server_create - Bir xmlrpc sunucusu oluşturur
    • xmlrpc_server_destroy - Sunucuya ayrılan özkaynakları serbest bırakır
    • xmlrpc_server_register_introspection_callback - Belge üretimi için bir PHP işlevi atar
    • xmlrpc_server_register_method - Belirtilen yöntemle eşleşen özkaynak için bir PHP işlevi atar
    • xmlrpc_set_type - Bir PHP dizge değeri için xmlrpc türünü base64 veya datetime türüne dönüştürür
    • XMLWriter::endAttribute - Geçerli özniteliği sonlandırır
    • XMLWriter::endCData - Geçerli CDATA bölümünü kapatır
    • XMLWriter::endComment - Geçerli açıklamayı kapatır
    • XMLWriter::endDocument - Geçerli belgeyi sonlandırır
    • XMLWriter::endDTD - Geçerli DTD'yi kapatır
    • XMLWriter::endDTDAttlist - Geçerli DTD öznitelik listesi bildirimini kapatır
    • XMLWriter::endDTDElement - Geçerli DTD eleman bildirimini kapatır
    • XMLWriter::endDTDEntity - Geçerli DTD öğe bildirimini kapatır
    • XMLWriter::endElement - Geçerli elemanı kapatır
    • XMLWriter::endPI - Geçerli işlem komutunu kapatır
    • XMLWriter::flush - Geçerli tamponu boşaltır
    • XMLWriter::fullEndElement - Geçerli elemanı kapatır
    • XMLWriter::openMemory - Dizge çıktılamak için belleği kullanmak üzere yeni bir XMLWriter nesnesi oluşturur
    • XMLWriter::openURI - Çıktı için kaynak adresini kullanarak yeni bir XMLWriter nesnesi oluşturur
    • XMLWriter::outputMemory - Geçerli tamponu döndürür
    • XMLWriter::setIndent - Girintilemeyi açıp kapar
    • XMLWriter::setIndentString - Girintileme için kullanılacak dizgeyi belirler
    • XMLWriter::startAttribute - Bir öznitelik başlatır
    • XMLWriter::startAttributeNS - İsim alanlı bir öznitelik başlatır
    • XMLWriter::startCData - Bir CDATA bölümü başlatır
    • XMLWriter::startComment - Bir açıklama başlatır
    • XMLWriter::startDocument - Belgenin XML bildirimini yazar
    • XMLWriter::startDTD - Bir DTD başlangıç etiketi oluşturur
    • XMLWriter::startDTDAttlist - Bir DTD öznitelik listesi bildirimini başlatır
    • XMLWriter::startDTDElement - Bir DTD eleman bildirimini başlatır
    • XMLWriter::startDTDEntity - Bir DTD öğe bildirimini başlatır
    • XMLWriter::startElement - Bir eleman başlangıç etiketi oluşturur
    • XMLWriter::startElementNS - Bir isim alanlı eleman başlangıç etiketi oluşturur
    • XMLWriter::startPI - Bir işlem komutu başlangıç etiketi oluşturur
    • XMLWriter::text - Bir metni yazar
    • XMLWriter::writeAttribute - Öznitelik yazar
    • XMLWriter::writeAttributeNS - İsim alanlı öznitelik yazar
    • XMLWriter::writeCData - CDATA yazar
    • XMLWriter::writeComment - Açıklama yazar
    • XMLWriter::writeDTD - DTD'yi yazar
    • XMLWriter::writeDTDAttlist - DTD öznitelik listesi yazar
    • XMLWriter::writeDTDElement - DTD elemanını yazar
    • XMLWriter::writeDTDEntity - DTD öğesini yazar
    • XMLWriter::writeElement - Elemanı içeriğiyle birlikte yazar
    • XMLWriter::writeElementNS - İsim alanlı elemanı içeriğiyle birlikte yazar
    • XMLWriter::writePI - Bir işlem komutu (PI) yazar
    • XMLWriter::writeRaw - Ham XML metni yazar
    • xml_error_string - XML çözümleyici hata iletisini döndürür
    • xml_get_current_byte_index - XML çözümleyicinin geçerli bayt indisini döndürür
    • xml_get_current_column_number - XML çözümleyicide hatanın oluştuğu satırdaki sütun numarasını döndürür
    • xml_get_current_line_number - XML çözümleyicide hatanın oluştuğu satırı döndürür
    • xml_get_error_code - XML çözümleyici hata kodunu döndürür
    • xml_parse - Bir XML belgeyi çözümler
    • xml_parser_create - Bir XML çözümleyici oluşturur
    • xml_parser_create_ns - İsim alanı destekli bir XML çözümleyici oluşturur
    • xml_parser_free - XML çözümleyiciyi serbest bırakır
    • xml_parser_get_option - XML çözümleyici seçeneklerini döndürür
    • xml_parser_set_option - XML çözümleyici seçeneklerini belirler
    • xml_parse_into_struct - XML veriyi çözümleyip sonucu bir dizi içinde döndürür
    • xml_set_character_data_handler - Karakter verisi eylemcisini belirler
    • xml_set_default_handler - Öntanımlı eylemciyi belirler
    • xml_set_element_handler - Açılış ve kapanış etiketi eylemcilerini belirler
    • xml_set_end_namespace_decl_handler - İsim alanı bildirimi sonlandırma eylemcisini belirler
    • xml_set_external_entity_ref_handler - Harici öğe gönderimi eylemcisini belirler
    • xml_set_notation_decl_handler - Gösterim bildirimi eylemcisini belirler
    • xml_set_object - XML çözümleyici, nesne içinde kullanılır
    • xml_set_processing_instruction_handler - İşlem komutu (PI) eylemcisini belirler
    • xml_set_start_namespace_decl_handler - İsim alanı bildirimi başlatma eylemcisini belirler
    • xml_set_unparsed_entity_decl_handler - Çözümlenmeyen öğe bildirimi eylemcisini belirler
    • XSLTProcessor::getParameter - Bir değiştirgenin değerini döndürür
    • XsltProcessor::getSecurityPrefs - Get security preferences
    • XSLTProcessor::hasExsltSupport - PHP, EXSLT desteğine sahip mi diye bakar
    • XSLTProcessor::importStylesheet - Biçembent ithal eder
    • XSLTProcessor::registerPHPFunctions - XSLT işlevleri olarak PHP işlevlerinin kullanılması yeteneğini etkin kılar
    • XSLTProcessor::removeParameter - Değiştirge siler
    • XSLTProcessor::setParameter - Bir değiştirgeye bir değer atar
    • XSLTProcessor::setProfiling - Profil çıktı dosyasını belirler
    • XsltProcessor::setSecurityPrefs - Set security preferences
    • XSLTProcessor::transformToDoc - Dönüşüm sonucunu bir DOMDocument olarak döndürür
    • XSLTProcessor::transformToUri - Dönüşüm sonucunu bir dosyaya yazar
    • XSLTProcessor::transformToXML - Dönüşümü bir dizge olarak döndürür
    • XSLTProcessor::__construct - Yeni bir XSLTProcessor nesnesi oluşturur
  • y
    • Yaf_Action_Abstract::execute - Action entry point
    • Yaf_Action_Abstract::getController - Retrieve controller object
    • Yaf_Application::app - Retrieve an Application instance
    • Yaf_Application::bootstrap - Call bootstrap
    • Yaf_Application::clearLastError - Clear the last error info
    • Yaf_Application::environ - Retrive environ
    • Yaf_Application::execute - Execute a callback
    • Yaf_Application::getAppDirectory - Get the application directory
    • Yaf_Application::getConfig - Retrive the config instance
    • Yaf_Application::getDispatcher - Get Yaf_Dispatcher instance
    • Yaf_Application::getLastErrorMsg - Get message of the last occurred error
    • Yaf_Application::getLastErrorNo - Get code of last occurred error
    • Yaf_Application::getModules - Get defined module names
    • Yaf_Application::run - Start Yaf_Application
    • Yaf_Application::setAppDirectory - Change the application directory
    • Yaf_Application::__clone - Yaf_Application can not be cloned
    • Yaf_Application::__construct - Yaf_Application constructor
    • Yaf_Application::__destruct - The __destruct purpose
    • Yaf_Application::__sleep - Yaf_Application can not be serialized
    • Yaf_Application::__wakeup - Yaf_Application can not be unserialized
    • Yaf_Config_Abstract::get - Getter
    • Yaf_Config_Abstract::readonly - Find a config whether readonly
    • Yaf_Config_Abstract::set - Setter
    • Yaf_Config_Abstract::toArray - Cast to array
    • Yaf_Config_Ini::count - The count purpose
    • Yaf_Config_Ini::current - The current purpose
    • Yaf_Config_Ini::key - The key purpose
    • Yaf_Config_Ini::next - The next purpose
    • Yaf_Config_Ini::offsetExists - The offsetExists purpose
    • Yaf_Config_Ini::offsetGet - The offsetGet purpose
    • Yaf_Config_Ini::offsetSet - The offsetSet purpose
    • Yaf_Config_Ini::offsetUnset - The offsetUnset purpose
    • Yaf_Config_Ini::readonly - The readonly purpose
    • Yaf_Config_Ini::rewind - The rewind purpose
    • Yaf_Config_Ini::toArray - Returns a PHP array
    • Yaf_Config_Ini::valid - The valid purpose
    • Yaf_Config_Ini::__construct - Yaf_Config_Ini constructor
    • Yaf_Config_Ini::__get - The __get purpose
    • Yaf_Config_Ini::__isset - The __isset purpose
    • Yaf_Config_Ini::__set - The __set purpose
    • Yaf_Config_Simple::count - The count purpose
    • Yaf_Config_Simple::current - The current purpose
    • Yaf_Config_Simple::key - The key purpose
    • Yaf_Config_Simple::next - The next purpose
    • Yaf_Config_Simple::offsetExists - The offsetExists purpose
    • Yaf_Config_Simple::offsetGet - The offsetGet purpose
    • Yaf_Config_Simple::offsetSet - The offsetSet purpose
    • Yaf_Config_Simple::offsetUnset - The offsetUnset purpose
    • Yaf_Config_Simple::readonly - The readonly purpose
    • Yaf_Config_Simple::rewind - The rewind purpose
    • Yaf_Config_Simple::toArray - Returns a PHP array
    • Yaf_Config_Simple::valid - The valid purpose
    • Yaf_Config_Simple::__construct - The __construct purpose
    • Yaf_Config_Simple::__get - The __get purpose
    • Yaf_Config_Simple::__isset - The __isset purpose
    • Yaf_Config_Simple::__set - The __set purpose
    • Yaf_Controller_Abstract::display - The display purpose
    • Yaf_Controller_Abstract::forward - foward to another action
    • Yaf_Controller_Abstract::getInvokeArg - The getInvokeArg purpose
    • Yaf_Controller_Abstract::getInvokeArgs - The getInvokeArgs purpose
    • Yaf_Controller_Abstract::getModuleName - Get module name
    • Yaf_Controller_Abstract::getRequest - Retrieve current request object
    • Yaf_Controller_Abstract::getResponse - Retrieve current response object
    • Yaf_Controller_Abstract::getView - Retrieve the view engine
    • Yaf_Controller_Abstract::getViewpath - The getViewpath purpose
    • Yaf_Controller_Abstract::init - Controller initializer
    • Yaf_Controller_Abstract::initView - The initView purpose
    • Yaf_Controller_Abstract::redirect - Redirect to a URL
    • Yaf_Controller_Abstract::render - Render view template
    • Yaf_Controller_Abstract::setViewpath - The setViewpath purpose
    • Yaf_Controller_Abstract::__clone - Yaf_Controller_Abstract can not be cloned
    • Yaf_Controller_Abstract::__construct - Yaf_Controller_Abstract constructor
    • Yaf_Dispatcher::autoRender - Switch on/off autorendering
    • Yaf_Dispatcher::catchException - Switch on/off exception catching
    • Yaf_Dispatcher::disableView - Disable view rendering
    • Yaf_Dispatcher::dispatch - Dispatch a request
    • Yaf_Dispatcher::enableView - enable view rendering
    • Yaf_Dispatcher::flushInstantly - Switch on/off the instant flushing
    • Yaf_Dispatcher::getApplication - Retrive the application
    • Yaf_Dispatcher::getInstance - Retrive the dispatcher instance
    • Yaf_Dispatcher::getRequest - Retrive the request instance
    • Yaf_Dispatcher::getRouter - Retrive router instance
    • Yaf_Dispatcher::initView - Initialize view and return it
    • Yaf_Dispatcher::registerPlugin - Register a plugin
    • Yaf_Dispatcher::returnResponse - The returnResponse purpose
    • Yaf_Dispatcher::setDefaultAction - Change default action name
    • Yaf_Dispatcher::setDefaultController - Change default controller name
    • Yaf_Dispatcher::setDefaultModule - Change default module name
    • Yaf_Dispatcher::setErrorHandler - Set error handler
    • Yaf_Dispatcher::setRequest - The setRequest purpose
    • Yaf_Dispatcher::setView - Set a custom view engine
    • Yaf_Dispatcher::throwException - Switch on/off exception throwing
    • Yaf_Dispatcher::__clone - Yaf_Dispatcher can not be cloned
    • Yaf_Dispatcher::__construct - Yaf_Dispatcher constructor
    • Yaf_Dispatcher::__sleep - Yaf_Dispatcher can not be serialized
    • Yaf_Dispatcher::__wakeup - Yaf_Dispatcher can not be unserialized
    • Yaf_Exception::getPrevious - The getPrevious purpose
    • Yaf_Exception::__construct - The __construct purpose
    • Yaf_Loader::autoload - The autoload purpose
    • Yaf_Loader::clearLocalNamespace - The clearLocalNamespace purpose
    • Yaf_Loader::getInstance - The getInstance purpose
    • Yaf_Loader::getLibraryPath - get the library path
    • Yaf_Loader::getLocalNamespace - The getLocalNamespace purpose
    • Yaf_Loader::import - The import purpose
    • Yaf_Loader::isLocalName - The isLocalName purpose
    • Yaf_Loader::registerLocalNamespace - register local class prefix
    • Yaf_Loader::setLibraryPath - Change the library path
    • Yaf_Loader::__clone - The __clone purpose
    • Yaf_Loader::__construct - The __construct purpose
    • Yaf_Loader::__sleep - The __sleep purpose
    • Yaf_Loader::__wakeup - The __wakeup purpose
    • Yaf_Plugin_Abstract::dispatchLoopShutdown - The dispatchLoopShutdown purpose
    • Yaf_Plugin_Abstract::dispatchLoopStartup - The dispatchLoopStartup purpose
    • Yaf_Plugin_Abstract::postDispatch - The postDispatch purpose
    • Yaf_Plugin_Abstract::preDispatch - The preDispatch purpose
    • Yaf_Plugin_Abstract::preResponse - The preResponse purpose
    • Yaf_Plugin_Abstract::routerShutdown - The routerShutdown purpose
    • Yaf_Plugin_Abstract::routerStartup - RouterStartup hook
    • Yaf_Registry::del - Remove an item from registry
    • Yaf_Registry::get - Retrieve an item from registry
    • Yaf_Registry::has - Check whether an item exists
    • Yaf_Registry::set - Add an item into registry
    • Yaf_Registry::__clone - The __clone purpose
    • Yaf_Registry::__construct - Yaf_Registry implements singleton
    • Yaf_Request_Abstract::getActionName - The getActionName purpose
    • Yaf_Request_Abstract::getBaseUri - The getBaseUri purpose
    • Yaf_Request_Abstract::getControllerName - The getControllerName purpose
    • Yaf_Request_Abstract::getEnv - Retrieve ENV varialbe
    • Yaf_Request_Abstract::getException - The getException purpose
    • Yaf_Request_Abstract::getLanguage - The getLanguage purpose
    • Yaf_Request_Abstract::getMethod - The getMethod purpose
    • Yaf_Request_Abstract::getModuleName - The getModuleName purpose
    • Yaf_Request_Abstract::getParam - The getParam purpose
    • Yaf_Request_Abstract::getParams - The getParams purpose
    • Yaf_Request_Abstract::getRequestUri - The getRequestUri purpose
    • Yaf_Request_Abstract::getServer - Retrieve SERVER variable
    • Yaf_Request_Abstract::isCli - The isCli purpose
    • Yaf_Request_Abstract::isDispatched - The isDispatched purpose
    • Yaf_Request_Abstract::isGet - The isGet purpose
    • Yaf_Request_Abstract::isHead - The isHead purpose
    • Yaf_Request_Abstract::isOptions - The isOptions purpose
    • Yaf_Request_Abstract::isPost - The isPost purpose
    • Yaf_Request_Abstract::isPut - The isPut purpose
    • Yaf_Request_Abstract::isRouted - The isRouted purpose
    • Yaf_Request_Abstract::isXmlHttpRequest - The isXmlHttpRequest purpose
    • Yaf_Request_Abstract::setActionName - The setActionName purpose
    • Yaf_Request_Abstract::setBaseUri - set base URI
    • Yaf_Request_Abstract::setControllerName - The setControllerName purpose
    • Yaf_Request_Abstract::setDispatched - The setDispatched purpose
    • Yaf_Request_Abstract::setModuleName - The setModuleName purpose
    • Yaf_Request_Abstract::setParam - The setParam purpose
    • Yaf_Request_Abstract::setRequestUri - The setRequestUri purpose
    • Yaf_Request_Abstract::setRouted - The setRouted purpose
    • Yaf_Request_Http::get - Retrieve variable from client
    • Yaf_Request_Http::getCookie - Retrieve Cookie variable
    • Yaf_Request_Http::getFiles - The getFiles purpose
    • Yaf_Request_Http::getPost - Retrieve POST variable
    • Yaf_Request_Http::getQuery - Fetch a query parameter
    • Yaf_Request_Http::getRequest - The getRequest purpose
    • Yaf_Request_Http::isXmlHttpRequest - Whether a Ajax Request
    • Yaf_Request_Http::__clone - The __clone purpose
    • Yaf_Request_Http::__construct - Constructor of Yaf_Request_Http
    • Yaf_Request_Simple::get - The get purpose
    • Yaf_Request_Simple::getCookie - The getCookie purpose
    • Yaf_Request_Simple::getFiles - The getFiles purpose
    • Yaf_Request_Simple::getPost - The getPost purpose
    • Yaf_Request_Simple::getQuery - The getQuery purpose
    • Yaf_Request_Simple::getRequest - The getRequest purpose
    • Yaf_Request_Simple::isXmlHttpRequest - The isXmlHttpRequest purpose
    • Yaf_Request_Simple::__clone - The __clone purpose
    • Yaf_Request_Simple::__construct - Constructor of Yaf_Request_Simple
    • Yaf_Response_Abstract::appendBody - append to body
    • Yaf_Response_Abstract::clearBody - The clearBody purpose
    • Yaf_Response_Abstract::clearHeaders - The clearHeaders purpose
    • Yaf_Response_Abstract::getBody - Retrieve a exists content
    • Yaf_Response_Abstract::getHeader - The getHeader purpose
    • Yaf_Response_Abstract::prependBody - The prependBody purpose
    • Yaf_Response_Abstract::response - send response
    • Yaf_Response_Abstract::setAllHeaders - The setAllHeaders purpose
    • Yaf_Response_Abstract::setBody - Set content to response
    • Yaf_Response_Abstract::setHeader - The setHeader purpose
    • Yaf_Response_Abstract::setRedirect - The setRedirect purpose
    • Yaf_Response_Abstract::__clone - The __clone purpose
    • Yaf_Response_Abstract::__construct - The __construct purpose
    • Yaf_Response_Abstract::__destruct - The __destruct purpose
    • Yaf_Response_Abstract::__toString - The __toString purpose
    • Yaf_Router::addConfig - Add config-defined routes into Router
    • Yaf_Router::addRoute - Add new Route into Router
    • Yaf_Router::getCurrentRoute - Get the effective route name
    • Yaf_Router::getRoute - Retrieve a route by name
    • Yaf_Router::getRoutes - Retrieve registered routes
    • Yaf_Router::route - The route purpose
    • Yaf_Router::__construct - Yaf_Router constructor
    • Yaf_Route_Interface::assemble - assemble a request
    • Yaf_Route_Interface::route - route a request
    • Yaf_Route_Map::assemble - Assemble a url
    • Yaf_Route_Map::route - The route purpose
    • Yaf_Route_Map::__construct - The __construct purpose
    • Yaf_Route_Regex::assemble - Assemble a url
    • Yaf_Route_Regex::route - The route purpose
    • Yaf_Route_Regex::__construct - Yaf_Route_Regex constructor
    • Yaf_Route_Rewrite::assemble - Assemble a url
    • Yaf_Route_Rewrite::route - The route purpose
    • Yaf_Route_Rewrite::__construct - Yaf_Route_Rewrite constructor
    • Yaf_Route_Simple::assemble - Assemble a url
    • Yaf_Route_Simple::route - Route a request
    • Yaf_Route_Simple::__construct - Yaf_Route_Simple constructor
    • Yaf_Route_Static::assemble - Assemble a url
    • Yaf_Route_Static::match - The match purpose
    • Yaf_Route_Static::route - Route a request
    • Yaf_Route_Supervar::assemble - Assemble a url
    • Yaf_Route_Supervar::route - The route purpose
    • Yaf_Route_Supervar::__construct - The __construct purpose
    • Yaf_Session::count - The count purpose
    • Yaf_Session::current - The current purpose
    • Yaf_Session::del - The del purpose
    • Yaf_Session::getInstance - The getInstance purpose
    • Yaf_Session::has - The has purpose
    • Yaf_Session::key - The key purpose
    • Yaf_Session::next - The next purpose
    • Yaf_Session::offsetExists - The offsetExists purpose
    • Yaf_Session::offsetGet - The offsetGet purpose
    • Yaf_Session::offsetSet - The offsetSet purpose
    • Yaf_Session::offsetUnset - The offsetUnset purpose
    • Yaf_Session::rewind - The rewind purpose
    • Yaf_Session::start - The start purpose
    • Yaf_Session::valid - The valid purpose
    • Yaf_Session::__clone - The __clone purpose
    • Yaf_Session::__construct - Constructor of Yaf_Session
    • Yaf_Session::__get - The __get purpose
    • Yaf_Session::__isset - The __isset purpose
    • Yaf_Session::__set - The __set purpose
    • Yaf_Session::__sleep - The __sleep purpose
    • Yaf_Session::__unset - The __unset purpose
    • Yaf_Session::__wakeup - The __wakeup purpose
    • Yaf_View_Interface::assign - Assign value to View engine
    • Yaf_View_Interface::display - Render and output a template
    • Yaf_View_Interface::getScriptPath - The getScriptPath purpose
    • Yaf_View_Interface::render - Render a template
    • Yaf_View_Interface::setScriptPath - The setScriptPath purpose
    • Yaf_View_Simple::assign - Assign values
    • Yaf_View_Simple::assignRef - The assignRef purpose
    • Yaf_View_Simple::clear - Clear Assigned values
    • Yaf_View_Simple::display - Render and display
    • Yaf_View_Simple::eval - Render template
    • Yaf_View_Simple::getScriptPath - Get templates directory
    • Yaf_View_Simple::render - Render template
    • Yaf_View_Simple::setScriptPath - Set tempaltes directory
    • Yaf_View_Simple::__construct - Constructor of Yaf_View_Simple
    • Yaf_View_Simple::__get - Retrieve assigned variable
    • Yaf_View_Simple::__isset - The __isset purpose
    • Yaf_View_Simple::__set - Set value to engine
    • yaml_emit - Returns the YAML representation of a value
    • yaml_emit_file - Send the YAML representation of a value to a file
    • yaml_parse - Parse a YAML stream
    • yaml_parse_file - Parse a YAML stream from a file
    • yaml_parse_url - Parse a Yaml stream from a URL
    • Yar_Client::setOpt - Set calling contexts
    • Yar_Client::__call - Call service
    • Yar_Client::__construct - Create a client
    • Yar_Client_Exception::getType - The getType purpose
    • Yar_Concurrent_Client::call - Register a concurrent call
    • Yar_Concurrent_Client::loop - Send all calls
    • Yar_Concurrent_Client::reset - Clean all registered calls
    • Yar_Server::handle - Start RPC Server
    • Yar_Server::__construct - Register a server
    • Yar_Server_Exception::getType - The getType purpose
    • yaz_addinfo - Ek hata bilgisi döndürür
    • yaz_ccl_conf - CCL çözümleyecisini yapılandırır
    • yaz_ccl_parse - CCL çözümleyiciyi devreye sokar
    • yaz_close - YAZ bağlantısını kapatır
    • yaz_connect - Bir Z39.50 sunucusuna bir bağlantı düzenler
    • yaz_database - Bir oturum içindeki veritabanlarını belirler
    • yaz_element - Alım için eleman kümesi ismi tanımlar
    • yaz_errno - Hata numarasını döndürür
    • yaz_error - Hatanın açıklaması döner
    • yaz_es - Bir ek hizmet isteği (Extended Service Request) düzenler
    • yaz_es_result - Ek hizmetlerin sonucunu döndürür
    • yaz_get_option - Bir bağlantı seçeneğinin değerini döndürür
    • yaz_hits - Son arama ile eşleşenlerin sayısını döndürür
    • yaz_itemorder - Bir ILL-Request paketli Z39.50 Item Order için hazırlık yapar
    • yaz_present - Bir alım (Z39.50 present) düzenler
    • yaz_range - Edinilecek kayıtlar için bir aralık belirler
    • yaz_record - Bir kayıt döndürür
    • yaz_scan - Bir tarama düzenler
    • yaz_scan_result - Tarama sonucunu döndürür
    • yaz_schema - Alım için şema belirtir
    • yaz_search - Bir arama düzenler
    • yaz_set_option - Bağlantı ile ilgili seçenekleri belirler
    • yaz_sort - Sıralama kuralını belirler
    • yaz_syntax - Alım için tercih edilen kayıt sözdizimini belirler
    • yaz_wait - Z39.50 isteklerinin tamamlanmasını bekler
    • yp_all - Traverse the map and call a function on each entry
    • yp_cat - Return an array containing the entire map
    • yp_errno - Returns the error code of the previous operation
    • yp_err_string - Returns the error string associated with the given error code
    • yp_first - Returns the first key-value pair from the named map
    • yp_get_default_domain - Fetches the machine's default NIS domain
    • yp_master - Returns the machine name of the master NIS server for a map
    • yp_match - Returns the matched line
    • yp_next - Returns the next key-value pair in the named map
    • yp_order - Returns the order number for a map
  • z
    • zend_logo_guid - Zend logo kimliğini döndürür
    • zend_thread_id - Geçerli evre için eşsiz bir betimleyici döndürür
    • zend_version - Zend motorunun sürümünü döndürür
    • ZipArchive::addEmptyDir - Yeni bir dizin ekler
    • ZipArchive::addFile - Yolu belirtilen dosyayı arşive ekler
    • ZipArchive::addFromString - İsmi ve içeriği belirtilen dosyayı arşive ekler
    • ZipArchive::addGlob - Add files from a directory by glob pattern
    • ZipArchive::addPattern - Add files from a directory by PCRE pattern
    • ZipArchive::close - Etkin (açık veya oluşturulmuş) arşivi kapatır
    • ZipArchive::deleteIndex - İndisi belirtilen girdiyi siler
    • ZipArchive::deleteName - İsmi belirtilen girdiyi siler
    • ZipArchive::extractTo - Arşiv içeriğini çıkarır
    • ZipArchive::getArchiveComment - Zip arşivinin açıklamasını döndürür
    • ZipArchive::getCommentIndex - İndisi belirtilen girdinin açıklamasını döndürür
    • ZipArchive::getCommentName - İsmi belirtilen girdinin açıklamasını döndürür
    • ZipArchive::getExternalAttributesIndex - Retrieve the external attributes of an entry defined by its index
    • ZipArchive::getExternalAttributesName - Retrieve the external attributes of an entry defined by its name
    • ZipArchive::getFromIndex - İndisi belirtilen girdinin içeriğini döndürür
    • ZipArchive::getFromName - İsmi belirtilen girdinin içeriğini döndürür
    • ZipArchive::getNameIndex - İndisi belirtilen girdinin ismini döndürür
    • ZipArchive::GetStatusString - Durum hata iletilerini, sistem ve/veya zip iletilerini döndürür
    • ZipArchive::getStream - İsmi belirtilen girdi için dosya tanıtıcısı (salt okunur) döndürür
    • ZipArchive::locateName - İsmi belirtilen girdinin indisini döndürür
    • ZipArchive::open - Bir ZIP dosya arşivi açar
    • ZipArchive::renameIndex - İndisi belirtilen girdinin ismini değiştirir
    • ZipArchive::renameName - İsmi belirtilen girdinin ismini değiştirir
    • ZipArchive::setArchiveComment - Bir ZIP arşivine açıklama ekler
    • ZipArchive::setCommentIndex - İndisi belirtilen girdiye bir açıklama ekler
    • ZipArchive::setCommentName - İsmi belirtilen girdiye bir açıklama ekler
    • ZipArchive::setCompressionIndex - Set the compression method of an entry defined by its index
    • ZipArchive::setCompressionName - Set the compression method of an entry defined by its name
    • ZipArchive::setExternalAttributesIndex - Set the external attributes of an entry defined by its index
    • ZipArchive::setExternalAttributesName - Set the external attributes of an entry defined by its name
    • ZipArchive::setPassword - Set the password for the active archive
    • ZipArchive::statIndex - İndisi belirtilen girdiyle ilgili bilgileri döndürür
    • ZipArchive::statName - İsmi belirtilen girdiyle ilgili bilgileri döndürür
    • ZipArchive::unchangeAll - Arşivde yapılmış değişikliklerin tamamını geri alır
    • ZipArchive::unchangeArchive - Arşiv bilgilerinde yapılmış değişiklikleri geri alır
    • ZipArchive::unchangeIndex - İndisi belirtilen girdideki değişiklikleri geri alır
    • ZipArchive::unchangeName - İsmi belirtilen girdideki değişiklikleri geri alır
    • zip_close - Bir ZIP dosya arşivini kapatır
    • zip_entry_close - Bir dizin girdisini kapatır
    • zip_entry_compressedsize - Dizin girdisinin sıkıştırılmış uzunluğunu döndürür
    • zip_entry_compressionmethod - Dizin girdisinin sıkıştırma yöntemini döndürür
    • zip_entry_filesize - Bir dizin girdisinin uzunluğunu döndürür
    • zip_entry_name - Bir dizin girdisinin ismini döndürür
    • zip_entry_open - Okumak için bir dizin girdisi açar
    • zip_entry_read - Bir açık dizin girdisini okur
    • zip_open - Bir ZIP dosya arşivi açar
    • zip_read - Bir ZIP dosya arşivindeki bir sonraki girdiyi okur
    • zlib:// - Compression Streams
    • zlib_decode - Uncompress any raw/gzip/zlib encoded data
    • zlib_encode - Compress data with the specified encoding
    • zlib_get_coding_type - Çıktı sıkıştırması için kullanılan kodlama türünü döndürür
    • ZMQ::__construct - ZMQ constructor
    • ZMQContext::getOpt - Get context option
    • ZMQContext::getSocket - Create a new socket
    • ZMQContext::isPersistent - Whether the context is persistent
    • ZMQContext::setOpt - Set a socket option
    • ZMQContext::__construct - Construct a new ZMQContext object
    • ZMQDevice::getIdleTimeout - Get the idle timeout
    • ZMQDevice::getTimerTimeout - Get the timer timeout
    • ZMQDevice::run - Run the new device
    • ZMQDevice::setIdleCallback - Set the idle callback function
    • ZMQDevice::setIdleTimeout - Set the idle timeout
    • ZMQDevice::setTimerCallback - Set the timer callback function
    • ZMQDevice::setTimerTimeout - Set the timer timeout
    • ZMQDevice::__construct - Construct a new device
    • ZMQPoll::add - Add item to the poll set
    • ZMQPoll::clear - Clear the poll set
    • ZMQPoll::count - Count items in the poll set
    • ZMQPoll::getLastErrors - Get poll errors
    • ZMQPoll::poll - Poll the items
    • ZMQPoll::remove - Remove item from poll set
    • ZMQSocket::bind - Bind the socket
    • ZMQSocket::connect - Connect the socket
    • ZMQSocket::disconnect - Disconnect a socket
    • ZMQSocket::getEndpoints - Get list of endpoints
    • ZMQSocket::getPersistentId - Get the persistent id
    • ZMQSocket::getSocketType - Get the socket type
    • ZMQSocket::getSockOpt - Get socket option
    • ZMQSocket::isPersistent - Whether the socket is persistent
    • ZMQSocket::recv - Receives a message
    • ZMQSocket::recvMulti - Receives a multipart message
    • ZMQSocket::send - Sends a message
    • ZMQSocket::sendmulti - Sends a multipart message
    • ZMQSocket::setSockOpt - Set a socket option
    • ZMQSocket::unbind - Unbind the socket
    • ZMQSocket::__construct - Construct a new ZMQSocket
    • Zookeeper::addAuth - Specify application credentials.
    • Zookeeper::connect - Create a handle to used communicate with zookeeper.
    • Zookeeper::create - Create a node synchronously.
    • Zookeeper::delete - Delete a node in zookeeper synchronously.
    • Zookeeper::exists - Checks the existence of a node in zookeeper synchronously.
    • Zookeeper::get - Gets the data associated with a node synchronously.
    • Zookeeper::getAcl - Gets the acl associated with a node synchronously.
    • Zookeeper::getClientId - return the client session id, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE)
    • Zookeeper::getRecvTimeout - Return the timeout for this session, only valid if the connections is currently connected (ie. last watcher state is ZOO_CONNECTED_STATE). This value may change after a server re-connect.
    • Zookeeper::getState - Get the state of the zookeeper connection.
    • Zookeeper::isRecoverable - Checks if the current zookeeper connection state can be recovered.
    • Zookeeper::set - Sets the data associated with a node.
    • Zookeeper::setAcl - Sets the acl associated with a node synchronously.
    • Zookeeper::setDebugLevel - Sets the debugging level for the library.
    • Zookeeper::setDeterministicConnOrder - Enable/disable quorum endpoint order randomization.
    • Zookeeper::setLogStream - Sets the stream to be used by the library for logging.
    • Zookeeper::setWatcher - Set a watcher function.
    • Zookeeper::__construct - Create a handle to used communicate with zookeeper.
  • _
    • __autoload - Attempt to load undefined class
    • __halt_compiler - Derleyicinin çalışmasını durdurur
Genel Dizin
Örnekler Dizini
Genel Dizin


Örnekler Dizini

Kılavuzdaki tüm örneklerin bir listesi

  • Example#0 - - Başlangıç olarak bir örnek
  • Example#1 - - İlk PHP betiğimiz: merhaba.php
  • Example#2 - - PHP ile sistem bilgisine ulaşmak
  • Example#3 - - Bir değişkeni (dizi öğesini) yazdırmak
  • Example#4 - - Denetim yapılarının ve işlevlerin kullanım örneği
  • Example#5 - - HTML ve PHP kiplerini karıştırmak
  • Example#6 - - Örnek bir HTML formu
  • Example#7 - - Formdan veri yazdırmak
  • Example#8 - - PHP'nin Paylaşımlı Apache Modülü olarak kurulumu
  • Example#9 - - PHP'nin Duruk Apache Modülü olarak kurulumu
  • Example#10 - - Apache'yi yeniden başlatmak için örnek komutlar
  • Example#11 -
  • Example#12 -
  • Example#13 -
  • Example#14 -
  • Example#15 -
  • Example#16 -
  • Example#17 -
  • Example#18 -
  • Example#19 -
  • Example#20 -
  • Example#21 -
  • Example#22 -
  • Example#23 -
  • Example#24 -
  • Example#25 -
  • Example#26 -
  • Example#27 -
  • Example#28 -
  • Example#29 -
  • Example#30 -
  • Example#31 -
  • Example#32 -
  • Example#33 -
  • Example#34 -
  • Example#35 -
  • Example#36 -
  • Example#37 -
  • Example#38 -
  • Example#39 - - lighttpd.conf'tan bir bölüm
  • Example#40 - - FastCGI Yanıtçılarının Çatallanması
  • Example#41 - - Uzak FCGI örneklerine bağlanmak
  • Example#42 - - OpenBSD Paket Kurulum Örneği
  • Example#43 - - Apache2 ile kurulum örneği
  • Example#44 - - PHP kurulduktan sonra Apache2'nin dirdirilip yeniden başlatılması
  • Example#45 - - Ek PHP 5 paketleri listesinin alınma yöntemleri
  • Example#46 - - MySQL ve cURL PHP modüllerinin kurulumu
  • Example#47 - Recommended OpCache configuration
  • Example#48 - Recommended WinCache configuration
  • Example#49 - Command line to configure IIS and PHP
  • Example#50 - PHP 5 package structure
  • Example#51 - CGI and FastCGI settings in php.ini
  • Example#52 - Configuring FastCGI extension to handle PHP requests
  • Example#53 - Configuring file access permissions
  • Example#54 - Configuring FastCGI and PHP recycling
  • Example#55 - Configuring FastCGI timeout settings
  • Example#56 - Changing the location of php.ini file
  • Example#57 - CGI and FastCGI settings in php.ini
  • Example#58 - Creating IIS FastCGI process pool
  • Example#59 - Creating handler mapping for PHP requests
  • Example#60 - Determining the account used as IIS anonymous identity
  • Example#61 - Configuring file access permissions
  • Example#62 - Set index.php as a default document in IIS
  • Example#63 - Configuring FastCGI and PHP recycling
  • Example#64 - Configuring FastCGI timeout settings
  • Example#65 - Changing the location of php.ini file
  • Example#66 - PHP as an Apache 1.3.x module
  • Example#67 - PHP and Apache 1.3.x as CGI
  • Example#68 - PHP and Apache 2.x as handler
  • Example#69 -
  • Example#70 - PHP and Apache 2.x as CGI
  • Example#71 - Configure Apache to run PHP as FastCGI
  • Example#72 - ISAPI configuration of Sambar
  • Example#73 - Enable Bzip2 extension for PHP-Windows
  • Example#74 - Registry changes
  • Example#75 - Passing environment variables and PHP settings to a pool
  • Example#76 - set PHP settings in nginx.conf
  • Example#77 - phpinfo kullanımı
  • Example#78 - php.ini Ortam Değişkenleri
  • Example#79 - - php.ini örneği
  • Example#80 - - Apache yapılandırma örneği
  • Example#81 - - Gelişmiş önceleme
  • Example#82 - - PHP Açılış ve Kapanış Etiketleri
  • Example#83 - - Tamsayı sayıllar
  • Example#84 - - Sekizlik garabeti
  • Example#85 - 32 bitlik sistemlerde tamsayı taşması
  • Example#86 - 64 bitlik sistemlerde tamsayı taşması
  • Example#87 - - Geçersiz örnek
  • Example#88 - - Yorumlu metin örneği
  • Example#89 - - Değiştirgelerde yorumlu metin kullanımı
  • Example#90 - - Duruk değer olarak yorumlu metin kullanımı
  • Example#91 - - Yorumlu metin bildiriminde çift tırnak kullanımı
  • Example#92 - - Yorumsuz metin örneği
  • Example#93 - - Duruk veri örneği
  • Example#94 - - Bazı dizge örnekleri
  • Example#95 - - array kullanımı
  • Example#96 - - Döngü içinde elemen değiştirme
  • Example#97 - - Derlem
  • Example#98 - - İndisi 1'den başlatmak
  • Example#99 - - Diziyi doldurmak
  • Example#100 - - Dizi elemanlarının sıraya sokulması
  • Example#101 - - İç içe ve çok boyutlu diziler
  • Example#102 - Geriçağırım işlev örnekleri
  • Example#103 - Örtme kullanan Geriçağırım örneği
  • Example#104 - - Geriçağırım işlevi örnekleri
  • Example#105 - - Anonim işlev kullanan bir geriçağırım işlevi örneği
  • Example#106 - - İlklendirilmemiş değişkenlerin öntanımlı değerleri
  • Example#107 - - global kullanımı
  • Example#108 - - global yerine $GLOBALS kullanımı
  • Example#109 - - Süper küreselleri ve etki alanlarını gösteren örnek
  • Example#110 - - Duruk değişkenlere ihtiyacı gösteren örnek
  • Example#111 - - Duruk değişkenlerin kullanım örneği
  • Example#112 - - Kendini çağıran işlevlerle duruk değişkenler
  • Example#113 - - Duruk değişken bildirimi
  • Example#114 - - Değişken özellik örneği
  • Example#115 - - Basit bir HTML formu
  • Example#116 - - Basit bir POST HTML formundan bilgiye erişim
  • Example#117 - Old methods of accessing user input
  • Example#118 - - Daha karmaşık form değişkenleri
  • Example#119 - - setcookie örneği
  • Example#120 - - Geçerli ve geçersiz sabit isimleri
  • Example#121 - - Sabitlerin Tanımlanması
  • Example#122 - - Sabitlerin const ile tanımlanması
  • Example#123 - - Öncelik yönü
  • Example#124 - - Tamsayılar üzerinde bitsel işlemler
  • Example#125 - - Dizgeler üzerinde bitsel işlemler
  • Example#126 - - Tamsayılarda bit kaydırma
  • Example#127 - - Özetle Standard Dizi Karşılaştırması
  • Example#128 - - Öntanımlı bir değer atama
  • Example#129 - - İç içe üç terimli davranışı
  • Example#130 - - Karakter değişkenleri üzerinde aritmetik işlemler
  • Example#131 - - Örneklerle mantıksal işleçler
  • Example#132 - - Dizilerin karşılaştırılması
  • Example#133 - - instanceof ve sınıflar
  • Example#134 - - Miras alınan sınıflar ve instanceof kullanımı
  • Example#135 - - Bir sınıfın örneği olmayan bir sınıfın instanceof ile sınanması
  • Example#136 - - Arayüzler için instanceof kullanımı
  • Example#137 - - Başka değişkenlerle instanceof kullanımı
  • Example#138 - - PHP 5.0'da instanceof ile ölümcül hatalardan ve sınıf ismi aramalarından kaçınmak
  • Example#139 - - switch yapısı
  • Example#140 - - switch ile dizge kullanımı
  • Example#141 - - Tik kullanım örneği 1
  • Example#142 - - Tik kullanım örneği 2
  • Example#143 - - Betik için kodlama belirtmek
  • Example#144 - - Basit bir include örneği
  • Example#145 - - İşlev içi include kullanımı
  • Example#146 - - HTTP üzerinden include
  • Example#147 - - include dönüş değerinin karşılaştırılması
  • Example#148 - - include ve return deyimleri
  • Example#149 - - Bir PHP dosyasını bir dizgeye dahil etmek için tampon kullanımı
  • Example#150 - - Harf büyükyüğüne duyarsız işletim sistemlerinde include_once
  • Example#151 - - goto örneği
  • Example#152 - - Döngüden goto ile çıkma örneği
  • Example#153 - - Bu çalışmaz
  • Example#154 - - İşlev kullanımını gösteren sözde kod
  • Example#155 - - Koşula bağlı işlevler
  • Example#156 - - İşlev içinde işlev
  • Example#157 - - Kendini çağıran işlev
  • Example#158 - - İşlevlere dizi aktarımı
  • Example#159 - - Gönderimli işlev değiştirgelerinin aktarımı
  • Example#160 - - İşlev içinde öntanımlı değiştirge kullanımı
  • Example#161 - - Sayıl olmayan türlerin öntanımlı değer olarak kullanımı
  • Example#162 - - Öntanımlı değiştirgelerin hatalı kullanımı
  • Example#163 - - Öntanımlı değiştirgelerin doğru kullanımı
  • Example#164 -
  • Example#165 - Temel sınıf türü bildirimi
  • Example#166 - Temel arayüz türü bildirimi
  • Example#167 - Boş olabilen tür bildirimi
  • Example#168 - Kesin tür örneği
  • Example#169 - Zayıf tür örneği
  • Example#170 - TypeError yakalama
  • Example#171 - Değişkenin değiştirgelerine erişim için ... kullanımı
  • Example#172 - Değiştirgelere erişmek için ... kullanımı
  • Example#173 - Değişken değiştirgelerinde tür dayatma
  • Example#174 - PHP 5.5 ve öncesinde değişken değiştirgelerine erişim
  • Example#175 - - return kullanımı
  • Example#176 - - Bir diziyle birden fazla değerin döndürülmesi
  • Example#177 - - Bir işlevden gönderimli değer döndürmek
  • Example#178 - Temel dönen tür bildirimi
  • Example#179 - Kesin kip işe karışırsa
  • Example#180 - Bir nesne döndürmek
  • Example#181 - - Değişken işlev örneği
  • Example#182 - - Değişken yöntem örneği
  • Example#183 - Duruk özellikli yöntem çağrısı örneği
  • Example#184 - Karmaşık çağrılar
  • Example#185 - - Anonim işlev örneği
  • Example#186 - - Değişkene anonim işlev atama örneği
  • Example#187 - Değikenleri üst etki alanından miras almak
  • Example#188 - - Anonim işlevler ve etki alanı
  • Example#189 - $this'in özdevinimli bağlanması
  • Example#190 - - Duruk anonim bir işlevin içinde $this kullanmaya çalışmak
  • Example#191 - - Duruk anonim bir işleve bir nesne bağlamaya çalışmak
  • Example#192 - - Basit bir sınıf tanımı
  • Example#193 - - $this sözde değişkeninin kullanımı
  • Example#194 - - Bir sınıf örneğinin oluşturulması
  • Example#195 - - Nesne Atama
  • Example#196 - - Yeni nesneler oluşturmak
  • Example#197 - - Basit bir sınıfın miras alınması
  • Example#198 - - Sınıf adı çözünürlüğü
  • Example#199 - - Özellik bildirimi
  • Example#200 - - Özellik ilklendirmede yorumsuz metin kullanımı
  • Example#201 - - Bir sabitin tanımlanması ve kullanımı
  • Example#202 - - Duruk veri örneği
  • Example#203 - - Özdevinimli yükleme örneği
  • Example#204 - - Başka bir özdevinimli yükleme örneği
  • Example#205 - - 5.3.0 ve sonrasında istisnalı özdevinimli yükleme
  • Example#206 - Autoloading with exception handling for 5.3.0+ - Missing custom exception
  • Example#207 - - Yeni tekilleşmiş kurucuların kullanımı
  • Example#208 - - İsim alanlı sınıflarda kurucular
  • Example#209 - - Yıkıcı Örneği
  • Example#210 - - Özellik bildirimi
  • Example#211 - - Yöntem bildirimi
  • Example#212 - Kalıtım Örneği
  • Example#213 - - Sınıf tanımı dışında ::
  • Example#214 - - Sınıf tanımı içinde ::
  • Example#215 - - Ebeveynin yöntemini çağırmak
  • Example#216 - - Duruk özellik örneği
  • Example#217 - - Duruk yöntem örneği
  • Example#218 - - Soyut sınıf örneği
  • Example#219 - - Arayüz örneği
  • Example#220 - - Genişletilebilir Arayüzler
  • Example#221 - - Çok sayıda anayüz oluşturma
  • Example#222 - - Arayüzler ve sabitleri
  • Example#223 - Nitelik örneği
  • Example#224 - Öncelik sırası örneği
  • Example#225 - Bir diğer öncelik sırası örneği
  • Example#226 - Çok sayıda niteliğin kullanımı
  • Example#227 - Çelişki çözümleme örneği
  • Example#228 - Yöntem görünürlüğünü değiştirme örneği
  • Example#229 - Niteliklerden nitelik oluşturma örneği
  • Example#230 - Gereksinimlerin soyut yöntemlerle ifadesi
  • Example#231 - Duruk Değişkenler
  • Example#232 - Duruk Yöntemler
  • Example#233 - Özellik tanımlama örneği
  • Example#234 - Çelişki yaratma örneği
  • Example#235 - - __get(),
    __set(),
    __isset() ve
    __unset() ile
    aşırı yükleme örneği
  • Example#236 - - __call() ve __callStatic() ile aşırı yüklü örneklenmiş yöntemler
  • Example#237 - - Basit Nesne Yineleme
  • Example#238 - - Iterator kullanılarak Nesne Yineleme
  • Example#239 - - IteratorAggregate ile Nesne Yineleme
  • Example#240 - - Uyutma ve uyandırma
  • Example#241 - - Basit bir örnek
  • Example#242 - - __invoke() kullanımı
  • Example#243 - - __set_state() kullanımı (PHP 5.1.0 ve sonrası)
  • Example#244 - __debugInfo() kullanımı
  • Example#245 - - final yöntem örneği
  • Example#246 - - final sınıf örneği
  • Example#247 - - Bir nesnenin kopyalanması
  • Example#248 - - PHP 5'te nesne karşılaştırma örneği
  • Example#249 - - Tür dayatma örnekleri
  • Example#250 - - self:: kullanımı
  • Example#251 - - static:: kullanımı
  • Example#252 - - Duruk olmayan bağlamda static:: kullanımı
  • Example#253 - Ötelenen ve ötelenmeyen çağrılar
  • Example#254 - - Sihirli yöntemlerin içinde duruk içselleştirim
  • Example#255 - - Gönderimler ve Nesneler
  • Example#256 - - İsim alanı söz dizimi örneği
  • Example#257 - - Tek bir isim alanı bildirimi
  • Example#258 - - Tek bir isim alanı bildirimi
  • Example#259 - - Tek bir isim alanının hiyerarşik bildirimi
  • Example#260 - - Birden fazla isim alanın ayrımsız ardarda bildirilmesi
  • Example#261 - - Birden fazla isim alanın ayraçlı olarak bildirilmesi
  • Example#262 - - Birden fazla isim alanın isim alansız kodla birlikte bildirilmesi
  • Example#263 - - Birden fazla isim alanın isim alansız kodla birlikte bildirilmesi
  • Example#264 - - Küresel sınıf, işlev ve sabitlere bir isim alanı içinden erişim
  • Example#265 - - Devingen olarak erişilen elemanlar
  • Example#266 - - Devingen olarak erişilen isim alanlı elemanlar
  • Example#267 - - İsim alanlı kod, __NAMESPACE__ örneği
  • Example#268 - - Küresel kod, __NAMESPACE__ örneği
  • Example#269 - - Devingen isim oluşturmak için __NAMESPACE__ kullanımı
  • Example#270 - - Bir isim alanı içinde namespace işleci
  • Example#271 - - Küresel kod içinde namespace işleci
  • Example#272 - - use işleci ile ithal/rumuz kullanımı
  • Example#273 - - use işleci ile rumuz/ithal, çoklu use kullanımı
  • Example#274 - - İthal işlemi ve devingen isimler
  • Example#275 - - İthal işlemi ve tamamen nitelenmiş isimler
  • Example#276 - - Küresel alan belirtiminin kullanımı
  • Example#277 - - Küresel sınıflara bir isim alanı içinde erişim
  • Example#278 - - Bir isim alanı içinde son çare olarak küresel işlev ve sabitlerin kullanımı
  • Example#279 - - Örneklerle İsim Çözünürlüğü
  • Example#280 - - Küresel sınıflara bir isim alanı dışından erişim
  • Example#281 - - Küresel sınıflara bir isim alanı dışından erişim
  • Example#282 - - İsim alanı içinden yerleşik sınıflara erişim
  • Example#283 - - İsim alanındaki dahili sınıf, işlev ve sabitlere erişim
  • Example#284 - - Tamamen nitelenmiş isimler
  • Example#285 - - Nitelenmiş isimler
  • Example#286 - - Nitelenmemiş sınıf isimleri
  • Example#287 - - Nitelenmemiş işlev veya sabit isimleri
  • Example#288 - - İsim alanlı isimleri çift tırnaklar arasında kullanmak tehlikelidir
  • Example#289 - - Tanımsız sabitler
  • Example#290 - - Tanımsız sabitler
  • Example#291 - - Yerleşik Exception sınıfı
  • Example#292 - - Exception sınıfının genişletilmesi (PHP 5.3.0+)
  • Example#293 - - Bir İstisna Oluşturmak
  • Example#294 - - Bir finally bloğu ile istisnanın işleme sokulması
  • Example#295 - - İç içe istisnalar
  • Example#296 - Implementing range as a generator
  • Example#297 - A simple example of yielding values
  • Example#298 - Yielding a key/value pair
  • Example#299 - Yielding NULLs
  • Example#300 - Yielding values by reference
  • Example#301 - yield from with iterator_to_array
  • Example#302 - Basic use of yield from
  • Example#303 - yield from and return values
  • Example#304 - - Gönderimlerin tanımlanmamış değişkenlerle kullanımı
  • Example#305 - - İşlev içinde küresel değişkenlere gönderim
  • Example#306 - - foreach döngüsü içinde gönderim
  • Example#307 - - $GLOBALS örneği
  • Example#308 - - $_SERVER örneği
  • Example#309 - - $_GET örneği
  • Example#310 - - $_POST örneği
  • Example#311 - - $_ENV örneği
  • Example#312 - $_COOKIE örneği
  • Example#313 - - $php_errormsg örneği
  • Example#314 - - $http_response_header örneği
  • Example#315 - - $argc örneği
  • Example#316 - - $argv örneği
  • Example#317 - - Exception::getMessage örneği
  • Example#318 - - Exception::getPrevious örneği
  • Example#319 - - Exception::getCode örneği
  • Example#320 - - Exception::getFile örneği
  • Example#321 - - Exception::getLine örneği
  • Example#322 - - Exception::getTrace örneği
  • Example#323 - - Exception::getTraceAsString örneği
  • Example#324 - - Exception::__toString örneği
  • Example#325 - - Hata iletilerinin set_error_handler ile ErrorException içinde döndürülmesi
  • Example#326 - - ErrorException::getSeverity örneği
  • Example#327 - Temel Kullanımı
  • Example#328 - - Temel kullanımı
  • Example#329 - Temel kullanım
  • Example#330 - - ArrayAccess::offsetExists örneği
  • Example#331 - Temel kullanım
  • Example#332 - Closure::bind example
  • Example#333 - Closure::bindTo example
  • Example#334 - Closure::call example
  • Example#335 - Generator::getReturn example
  • Example#336 - Generator::key example
  • Example#337 - Using Generator::send to inject values
  • Example#338 - Throwing an exception into a generator
  • Example#339 - - Temel bindto kullanım örneği
  • Example#340 - - Bir sayfayı çekip veriyi POST ile göndermek
  • Example#341 - - Bir sayfayı çekip veriyi POST ile göndermek
  • Example#342 - Detecting which URL we ended up on after redirects
  • Example#343 - php://temp/maxmemory
  • Example#344 - php://filter/resource=<stream to be filtered>
  • Example#345 - php://filter/read=<filter list to apply to read chain>
  • Example#346 - php://filter/write=<filter list to apply to write chain>
  • Example#347 - php://memory and php://temp are not reusable
  • Example#348 - Print data:// contents
  • Example#349 - Fetch the media type
  • Example#350 - Basic usage
  • Example#351 - Opening a stream from an active connection
  • Example#352 - This $session variable must be kept available!
  • Example#353 - Traversing a RAR archive
  • Example#354 - Opening an encrypted file (header encryption)
  • Example#355 - - Değişkenler başınıza iş açabilir...
  • Example#356 - ... Bir dosya sistemi saldırısı
  • Example#357 - - Daha güvenilir bir dosya silme betiği
  • Example#358 - - Daha da güvenilir bir dosya silme betiği
  • Example#359 - - Boş baytlardan olumsuz etkilenen bir betik
  • Example#360 - - Girdiyi doğru şekilde ele almak
  • Example#361 - Hashing password field
  • Example#362 - Hashing password using crypts
  • Example#363 - Splitting the result set into pages ... and making superusers (PostgreSQL)
  • Example#364 - Listing out articles ... and some passwords (any database server)
  • Example#365 - From resetting a password ... to gaining more privileges (any database server)
  • Example#366 - Attacking the database hosts operating system (MSSQL Server)
  • Example#367 - A more secure way to compose a query for paging
  • Example#368 - Attacking Variables with a custom HTML page
  • Example#369 - Exploiting common debugging variables
  • Example#370 - Finding dangerous variables with E_ALL
  • Example#371 - - register_globals = on ile yanlış kullanım örneği
  • Example#372 - - register_globals On veya Off iken oturum örneği
  • Example#373 - - Basit değişken sahteciliğinin saptanması
  • Example#374 - - Tehlikeli Değişken Kullanımı
  • Example#375 - - Sihirli tırnakların sunucu taraflı iptali
  • Example#376 - - Sihirli tırnakların çalışma anında iptali
  • Example#377 - - PHP'yi başka bir dil olarak göstermek
  • Example#378 - - PHP uzantısı olarak bilinmeyen bir uzantı kullanmak
  • Example#379 - - PHP uzantısı olarak HTML uzantılarını kullanmak
  • Example#380 - - Temel HTTP Kimlik Doğrulaması örneği
  • Example#381 - - Özet HTTP Kimlik Doğrulaması örneği
  • Example#382 - - Yeni kullanıcı adı va parolası girmeye zorlayan bir HTTP kimlik doğrulama örneği
  • Example#383 - - Basit bir XForms arama formu
  • Example#384 - - $_POST elde etmek için bir XFrom kullanımı
  • Example#385 - - Karşıya Dosya Yükleme Formu
  • Example#386 - - Dosya yüklemelerinin doğrulanması
  • Example#387 - - Dosya dizisi yükleme
  • Example#388 - - Çoklu dosya yükleme
  • Example#389 - - HTTP PUT dosyalarının kaydedilmesi
  • Example#390 - - Uzak sayfanın başlığını elde etmek
  • Example#391 - - Veriyi uzak sunucuda saklamak
  • Example#392 - - CLI SAPI farkını gösteren örnek:
  • Example#393 -
  • Example#394 - - Yerleşik (ve yüklü) PHP ve Zend modüllerinin listelenmesi
  • Example#395 - Çift tırnak kullanımında bir çözümleme hatasının gösterilmesi
  • Example#396 - Kabuğun değişken dönüşümü yapmasını engellemek için tek tırnakların kullanımı
  • Example#397 - - Bir projedeki satır sayısını saymak için -B, -R ve -E seçeneklerinin kullanımı
  • Example#398 - PHP ve Zend sürümleri ile SAPI ismini çıktılamak için -v kullanımı
  • Example#399 - --ini örneği
  • Example#400 - - Temel --rf kullanımı
  • Example#401 - --rc örneği
  • Example#402 - --re örneği
  • Example#403 - --ri örneği
  • Example#404 - - PHP betiğini kabuk betiği olarak çalıştırmak
  • Example#405 - - Komut satırından çalıştırılması planlanan betik (betik.php)
  • Example#406 - - Bir komut satırı PHP betiği çalıştırmak için yığın dosyası (betik.bat)
  • Example#407 - - Etkileşimli kabuk kullanarak kod çalıştırmak
  • Example#408 - Kod tamamlama
  • Example#409 - Etkileşimli kabukta php.ini ayarlarını değiştirmek
  • Example#410 - HTTP sunucusunun başlatılması
  • Example#411 - - Belge kök dizini belirterek başlatma
  • Example#412 - - Yönlendirici betik belirtmek
  • Example#413 - Checking for CLI Web Server Use
  • Example#414 - Desteklenmeyen Dosya Türlerinin İşlenmesi
  • Example#415 - CLI sunucusuna uzak makinelerden erişim
  • Example#416 - Creating a new zval container
  • Example#417 - Displaying zval information
  • Example#418 - Increasing refcount of a zval
  • Example#419 - Decreasing zval refcount
  • Example#420 - Creating a array zval
  • Example#421 - Adding already existing element to an array
  • Example#422 - Removing an element from an array
  • Example#423 - Adding the array itself as an element of it self
  • Example#424 - Unsetting $a
  • Example#425 - Memory usage example
  • Example#426 - GC performance influences
  • Example#427 - Running the above script
  • Example#428 - Recompiling PHP to enable GC benchmarking
  • Example#429 - GC statistics
  • Example#430 - all_probes.d for tracing all PHP Static Probes with DTrace
  • Example#431 - all_probes.stp for tracing all PHP Static Probes with SystemTap
  • Example#432 - - Bir apc.rfc1867 örneği
  • Example#433 - - apc_add örneği
  • Example#434 - apc_bin_load example
  • Example#435 - Bir apc_cache_info örneği
  • Example#436 - apc_cas example
  • Example#437 - apc_dec example
  • Example#438 - - apc_define_constants örneği
  • Example#439 - apc_delete_file example
  • Example#440 - - apc_delete örneği
  • Example#441 - apc_exists example
  • Example#442 - - apc_fetch örneği
  • Example#443 - apc_inc example
  • Example#444 - - apc_load_constants örneği
  • Example#445 - - apc_sma_info örneği
  • Example#446 - - apc_store örneği
  • Example#447 - An apc.rfc1867 example
  • Example#448 - A apcu_add example
  • Example#449 - A apcu_cache_info example
  • Example#450 - apcu_cas example
  • Example#451 - apcu_dec example
  • Example#452 - A apcu_delete example
  • Example#453 - An apcu_entry example
  • Example#454 - apcu_exists example
  • Example#455 - A apcu_fetch example
  • Example#456 - apcu_inc example
  • Example#457 - A apcu_sma_info example
  • Example#458 - A apcu_store example
  • Example#459 - A APCUIterator::__construct example
  • Example#460 - - tcplisten kullanılan sıradan bir oturum
  • Example#461 - - apd_callstack örneği
  • Example#462 - - apd_clunk örneği
  • Example#463 - - apd_continue örneği
  • Example#464 - - apd_croak örneği
  • Example#465 - - apd_dump_function_table örneği
  • Example#466 - - apd_dump_persistent_resources örneği
  • Example#467 - - apd_dump_regular_resources örneği
  • Example#468 - - apd_echo örneği
  • Example#469 - - apd_get_active_symbols örneği
  • Example#470 - - apd_set_pprof_trace örneği
  • Example#471 - - apd_set_session_trace_socket örneği
  • Example#472 - - apd_set_session_trace örneği
  • Example#473 - - apd_set_session örneği
  • Example#474 - - override_function örneği
  • Example#475 - - rename_function örneği
  • Example#476 - - bcompiler_load_exe örneği
  • Example#477 - - bcompiler_load örneği
  • Example#478 - - bcompiler_parse_class örneği
  • Example#479 - - bcompiler_read örneği
  • Example#480 - - bcompiler_write_class örneği
  • Example#481 - - bcompiler_write_constant örneği
  • Example#482 - - bcompiler_write_exe_footer örneği
  • Example#483 - - bcompiler_write_file örneği
  • Example#484 - - bcompiler_write_footer örneği
  • Example#485 - - bcompiler_write_function örneği
  • Example#486 - - bcompiler_write_functions_from_file örneği
  • Example#487 - - bcompiler_write_header örneği
  • Example#488 - blenc_encrypt example
  • Example#489 - Bir betikte hataların yakalanıp işleme sokulması
  • Example#490 - - debug_backtrace örneği
  • Example#491 - - debug_print_backtrace örneği
  • Example#492 - An error_clear_last example
  • Example#493 - - error_get_last örneği
  • Example#494 - - error_log örnekleri
  • Example#495 - - error_reporting örnekleri
  • Example#496 - - restore_error_handler örneği
  • Example#497 - - restore_exception_handler örneği
  • Example#498 - - set_error_handler ve trigger_error ile hataların ele alınması
  • Example#499 - - set_exception_handler örneği
  • Example#500 - - trigger_error örneği
  • Example#501 - Getting the data within the PHP application itself (function)
  • Example#502 - Example use of gengraph.php
  • Example#503 - Listing data via inclued dumps (configuration)
  • Example#504 - inclued_get_data example
  • Example#505 - Creating large array in a function
  • Example#506 - - Çıktı Denetimi örneği
  • Example#507 - - ob_end_clean örneği
  • Example#508 - - ob_end_flush örneği
  • Example#509 - - Basit bir ob_get_clean örneği
  • Example#510 - - ob_get_contents örneği
  • Example#511 - - ob_get_flush örneği
  • Example#512 - - ob_get_length örneği
  • Example#513 - - ob_gzhandler örneği
  • Example#514 - - ob_list_handlers işlevi
  • Example#515 - - Kullanıcı tanımlı geriçağırım işlevi örneği
  • Example#516 - Çıktı tamponunun hem PHP 5.3 hem de 5.4 ile uyumlu olmasını sağlayan ve çıktı tamponunun silinmesini önleyen kod örneği
  • Example#517 - - output_add_rewrite_var örneği
  • Example#518 - - output_reset_rewrite_vars örneği
  • Example#519 - - assert_options örneği
  • Example#520 - Handle a failed assertion with a custom handler
  • Example#521 - Using a custom handler to print a description
  • Example#522 - Expectations without a custom exception
  • Example#523 - Expectations with a custom exception
  • Example#524 - cli_get_process_title example
  • Example#525 - cli_set_process_title example
  • Example#526 - - dl örnekleri
  • Example#527 - - extension_loaded örneği
  • Example#528 - - get_current_user örneği
  • Example#529 - - get_defined_constants örneği
  • Example#530 - - XML işlevlerinin listesi
  • Example#531 - - get_include_path örneği
  • Example#532 - - get_included_files örneği
  • Example#533 - - get_loaded_extensions örneği
  • Example#534 - - get_magic_quotes_gpc örneği
  • Example#535 - - get_magic_quotes_runtime örneği
  • Example#536 - Unfiltered get_resources
  • Example#537 - Filtered get_resources
  • Example#538 - - getenv örneği
  • Example#539 - - getlastmod örneği
  • Example#540 - - getopt örneği - 1
  • Example#541 - - getopt örneği - 2
  • Example#542 - - getopt örneği - 3
  • Example#543 - - getrusage örneği
  • Example#544 - - ini_get_all örnekleri
  • Example#545 - - Ayrıntısız listeleme
  • Example#546 - - ini_get örnekleri
  • Example#547 - - ini_restore örneği
  • Example#548 - - Bir INI yönergesine değer atamak
  • Example#549 - - memory_get_usage örneği
  • Example#550 - - php_ini_loaded_file örneği
  • Example#551 - - Dönen ini dosyalarının listelenmesi
  • Example#552 - - php_logo_guid örneği
  • Example#553 - - php_sapi_name örneği
  • Example#554 - - php_uname örnekleri
  • Example#555 - - İşletim sistemine göre bazı sabit örnekleri
  • Example#556 - - Genel katkıcıların listelenmesi
  • Example#557 - - Çekirdek geliştiricilerin ve belgelendirme ekibinin listelenmesi
  • Example#558 - - Tüm katkıcıların listelenmesi
  • Example#559 - - phpinfo örneği
  • Example#560 - - phpversion örneği
  • Example#561 - - PHP_VERSION_ID örneği
  • Example#562 - - Bir ortam değişkeninin atanması
  • Example#563 - - restore_include_path örneği
  • Example#564 - - set_include_path örneği
  • Example#565 - - İçerilecek dosyaların aranacağı yollara bir yenisini eklemek
  • Example#566 - - set_magic_quotes_runtime örneği
  • Example#567 - - sys_get_temp_dir örneği
  • Example#568 - - version_compare örnekleri
  • Example#569 - zend_logo_guid örneği
  • Example#570 - - zend_thread_id örneği
  • Example#571 - - zend_version örneği
  • Example#572 - Custom Superglobals with runkit.superglobal=_FOO,_BAR in php.ini
  • Example#573 - Instantiating a restricted sandbox
  • Example#574 - Working with variables in a sandbox
  • Example#575 - Calling sandbox functions
  • Example#576 - Passing arguments to sandbox functions
  • Example#577 - Working with variables in a sandbox
  • Example#578 - Accessing parental variables
  • Example#579 - A runkit_class_adopt example
  • Example#580 - A runkit_class_emancipate example
  • Example#581 - A runkit_function_add example
  • Example#582 - A runkit_function_copy example
  • Example#583 - A runkit_function_redefine example
  • Example#584 - runkit_import example
  • Example#585 - runkit_method_add example
  • Example#586 - runkit_method_copy example
  • Example#587 - runkit_method_redefine example
  • Example#588 - runkit_method_remove example
  • Example#589 - runkit_method_rename example
  • Example#590 - runkit_return_value_used example
  • Example#591 - Feeding output to a variable
  • Example#592 - Enabling and disabling scream at runtime
  • Example#593 - uopz_backup example
  • Example#594 - uopz_compose example
  • Example#595 - uopz_copy example
  • Example#596 - uopz_delete example
  • Example#597 - uopz_delete class example
  • Example#598 - uopz_extend example
  • Example#599 - uopz_flags example
  • Example#600 - uopz_function example
  • Example#601 - uopz_function class example
  • Example#602 - uopz_implement example
  • Example#603 - uopz_overload example
  • Example#604 - uopz_redefine example
  • Example#605 - uopz_rename example
  • Example#606 - uopz_rename class example
  • Example#607 - uopz_restore example
  • Example#608 - uopz_undefine example
  • Example#609 - Weakref usage example
  • Example#610 - WeakRef usage example
  • Example#611 - Weakref::acquire example
  • Example#612 - Nested acquire/release example
  • Example#613 - Weakref::__construct example
  • Example#614 - Weakref::release example
  • Example#615 - Weakmap usage example
  • Example#616 - wincache.ignorelist example
  • Example#617 - Authentication configuration for wincache.php
  • Example#618 - Enabling WinCache session handler
  • Example#619 - Enabling WinCache functions reroutes
  • Example#620 - Reroute.ini file content
  • Example#621 - A wincache_fcache_fileinfo example
  • Example#622 - A wincache_fcache_meminfo example
  • Example#623 - Using wincache_lock
  • Example#624 - A wincache_ocache_fileinfo example
  • Example#625 - A wincache_ocache_meminfo example
  • Example#626 - A wincache_refresh_if_changed example
  • Example#627 - A wincache_rplist_fileinfo example
  • Example#628 - A wincache_rplist_meminfo example
  • Example#629 - A wincache_scache_info example
  • Example#630 - A wincache_scache_meminfo example
  • Example#631 - wincache_ucache_add with key as a string
  • Example#632 - wincache_ucache_add with key as an array
  • Example#633 - Using wincache_ucache_cas
  • Example#634 - using wincache_ucache_clear
  • Example#635 - Using wincache_ucache_dec
  • Example#636 - Using wincache_ucache_delete with key as a string
  • Example#637 - Usingwincache_ucache_delete with key as an array
  • Example#638 - Using wincache_ucache_delete with key as an array where some elements cannot be deleted
  • Example#639 - Using wincache_ucache_exists
  • Example#640 - wincache_ucache_get with key as a string
  • Example#641 - wincache_ucache_get with key as an array
  • Example#642 - Using wincache_ucache_inc
  • Example#643 - Using wincache_ucache_info
  • Example#644 - A wincache_ucache_meminfo example
  • Example#645 - wincache_ucache_set with key as a string
  • Example#646 - wincache_ucache_set with key as an array
  • Example#647 - Using wincache_unlock
  • Example#648 - Xhprof example with the optional GUI
  • Example#649 - xhprof_disable example
  • Example#650 - xhprof_enable examples
  • Example#651 - xhprof_sample_disable example
  • Example#652 - id3_get_frame_long_name example
  • Example#653 - id3_get_frame_short_name example
  • Example#654 - id3_get_genre_id example
  • Example#655 - id3_get_genre_list example
  • Example#656 - id3_get_genre_name example
  • Example#657 - id3_get_tag example
  • Example#658 - id3_get_tag example
  • Example#659 - id3_get_version example
  • Example#660 - id3_remove_tag example
  • Example#661 - id3_set_tag example
  • Example#662 - Opens a new MP3 file and read the title
  • Example#663 - Reading an OGG/Vorbis file
  • Example#664 - Encode an audio file to OGG/Vorbis
  • Example#665 - KADM5 extension overview example
  • Example#666 - Example of changing principal's password
  • Example#667 - Example of principal's creation
  • Example#668 - kadm5_delete_principal example
  • Example#669 - kadm5_get_policies example
  • Example#670 - kadm5_get_principal example
  • Example#671 - kadm5_get_principals example
  • Example#672 - KADM5 initialization example
  • Example#673 - Example of modifying principal
  • Example#674 - Using CHAP passwords
  • Example#675 - radius_acct_open example
  • Example#676 - radius_add_server example
  • Example#677 - radius_auth_open example
  • Example#678 - radius_create_request example
  • Example#679 - radius_cvt_addr example
  • Example#680 - radius_cvt_int example
  • Example#681 - radius_cvt_string example
  • Example#682 - radius_get_attr example
  • Example#683 - radius_get_tagged_attr_data example
  • Example#684 - radius_get_tagged_attr_tag example
  • Example#685 - radius_get_vendor_attr example
  • Example#686 - radius_put_attr example
  • Example#687 - radius_put_int example
  • Example#688 - radius_put_string example
  • Example#689 - radius_put_vendor_attr example
  • Example#690 - Writing a string with a specified color to the screen
  • Example#691 - ncurses_getmouse example
  • Example#692 - Writing a string with a specified color to the screen
  • Example#693 - Writing a string with a specified color to the screen
  • Example#694 - ncurses_mousemask example
  • Example#695 - Writing a string with a specified color to the screen
  • Example#696 - Newt Usage Example
  • Example#697 - A newt_button example
  • Example#698 - A newt_draw_root_text example
  • Example#699 - A newt_form_add_component example
  • Example#700 - A newt_form_add_components example
  • Example#701 - A newt_form example
  • Example#702 - A newt_get_screen_size example
  • Example#703 - A newt_win_entries example
  • Example#704 - Readline Callback Interface Example
  • Example#705 - readline Example
  • Example#706 - - Basit bzip2 örneği
  • Example#707 - - Veri sıkıştırma
  • Example#708 - - Bir dizgenin sıkıştırmasının açılması
  • Example#709 - - bzerror örneği
  • Example#710 - - bzopen örneği
  • Example#711 - - bzread örneği
  • Example#712 - - bzwrite örneği
  • Example#713 - Using an external file
  • Example#714 - Using a file within a phar archive
  • Example#715 - Converting a phar archive from phar to tar file format
  • Example#716 - phar.extract_list usage example
  • Example#717 - phar.cache_list usage example
  • Example#718 - A Phar::addEmptyDir example
  • Example#719 - A Phar::addFile example
  • Example#720 - A Phar::addFromString example
  • Example#721 - A Phar::apiVersion example
  • Example#722 - A Phar::buildFromDirectory example
  • Example#723 - A Phar::buildFromIterator with SplFileInfo
  • Example#724 - A Phar::buildFromIterator with other iterators
  • Example#725 - A Phar::canCompress example
  • Example#726 - A Phar::canWrite example
  • Example#727 - A Phar::compress example
  • Example#728 - A Phar::compressAllFilesBZIP2 example
  • Example#729 - A Phar::compressAllFilesGZ example
  • Example#730 - A Phar::compressFiles example
  • Example#731 - A Phar::__construct example
  • Example#732 - A Phar::convertToData example
  • Example#733 - A Phar::convertToExecutable example
  • Example#734 - A Phar::copy example
  • Example#735 - A Phar::count example
  • Example#736 - A Phar::createDefaultStub example
  • Example#737 - A Phar::decompress example
  • Example#738 - A Phar::decompressFiles example
  • Example#739 - A Phar::delMetaData example
  • Example#740 - A Phar::delete example
  • Example#741 - A Phar::extractTo example
  • Example#742 - A Phar::getMetadata example
  • Example#743 - A Phar::getStub example
  • Example#744 - A Phar::hasMetadata example
  • Example#745 - A Phar::interceptFileFuncs example
  • Example#746 - A Phar::interceptFileFuncs example
  • Example#747 - A Phar::isBuffering example
  • Example#748 - A Phar::isCompressed example
  • Example#749 - A Phar::loadPhar example
  • Example#750 - A Phar::mapPhar example
  • Example#751 - A Phar::mount example
  • Example#752 - A Phar::mungServer example
  • Example#753 - A Phar::offsetExists example
  • Example#754 - Phar::offsetGet example
  • Example#755 - A Phar::offsetSet example
  • Example#756 - A Phar::offsetUnset example
  • Example#757 - A Phar::running example
  • Example#758 - A Phar::setAlias example
  • Example#759 - A Phar::setDefaultStub example
  • Example#760 - A Phar::setMetadata example
  • Example#761 - A Phar::setStub example
  • Example#762 - A Phar::startBuffering example
  • Example#763 - A Phar::stopBuffering example
  • Example#764 - A Phar::uncompressAllFiles example
  • Example#765 - A Phar::unlinkArchive example
  • Example#766 - A Phar::webPhar example
  • Example#767 - A PharData::addEmptyDir example
  • Example#768 - A PharData::addFile example
  • Example#769 - A PharData::addFromString example
  • Example#770 - A PharData::buildFromDirectory example
  • Example#771 - A PharData::buildFromIterator with SplFileInfo
  • Example#772 - A PharData::buildFromIterator with other iterators
  • Example#773 - A PharData::compress example
  • Example#774 - A PharData::compressFiles example
  • Example#775 - A PharData::__construct example
  • Example#776 - A PharData::convertToData example
  • Example#777 - A PharData::convertToExecutable example
  • Example#778 - A PharData::copy example
  • Example#779 - A PharData::decompress example
  • Example#780 - A PharData::decompressFiles example
  • Example#781 - A PharData::delMetaData example
  • Example#782 - A PharData::delete example
  • Example#783 - A PharData::extractTo example
  • Example#784 - A PharData::offsetSet example
  • Example#785 - A PharData::offsetUnset example
  • Example#786 - A Phar::setMetadata example
  • Example#787 - A PharFileInfo::chmod example
  • Example#788 - A PharFileInfo::compress example
  • Example#789 - A PharFileInfo::__construct example
  • Example#790 - A PharFileInfo::decompress example
  • Example#791 - A PharFileInfo::delMetaData example
  • Example#792 - A PharFileInfo::getCRC32 example
  • Example#793 - A PharFileInfo::getCompressedSize example
  • Example#794 - A PharFileInfo::getMetadata example
  • Example#795 - A PharFileInfo::getPharFlags example
  • Example#796 - A PharFileInfo::isCRCChecked example
  • Example#797 - A PharFileInfo::isCompressed example
  • Example#798 - A PharFileInfo::isCompressedBZIP2 example
  • Example#799 - A PharFileInfo::isCompressedGZ example
  • Example#800 - A PharFileInfo::setCompressedBZIP2 example
  • Example#801 - A PharFileInfo::setCompressedGZ example
  • Example#802 - A PharFileInfo::setMetadata example
  • Example#803 - A PharFileInfo::setUncompressed example
  • Example#804 - Rar installation
  • Example#805 - On-the-fly decompression
  • Example#806 - RAR extension filesystem extraction example
  • Example#807 - Nesne yönelimli kullanım
  • Example#808 - Yordamsal kullanım
  • Example#809 - Nesne yönelimli kullanım
  • Example#810 - Yordamsal kullanım
  • Example#811 - Nesne yönelimli kullanım
  • Example#812 - Yordamsal kullanım
  • Example#813 - Nesne yönelimli kullanım
  • Example#814 - Yordamsal kullanım
  • Example#815 - Nesne yönelimli kullanım
  • Example#816 - Yordamsal kullanım
  • Example#817 - Nesne yönelimli kullanım
  • Example#818 - Yordamsal kullanım
  • Example#819 - Nesne yönelimli kullanım
  • Example#820 - Yordamsal kullanım
  • Example#821 - Volume Callback
  • Example#822 - Nesne yönelimli kullanım
  • Example#823 - Yordamsal kullanım
  • Example#824 - RarArchive::__toString example
  • Example#825 - RarEntry::extract example
  • Example#826 - How to extract all files in archive:
  • Example#827 - RarEntry::getAttr example
  • Example#828 - RarEntry::getHostOs example (version >= 2.0.0)
  • Example#829 - RarEntry::getHostOs example (version <= 1.0.0)
  • Example#830 - RarEntry::getMethod example
  • Example#831 - RarEntry::getName example
  • Example#832 - RarEntry::getPackedSize example
  • Example#833 - RarEntry::getStream example
  • Example#834 - RarEntry::getUnpackedSize example
  • Example#835 - RarEntry::getVersion example
  • Example#836 - RarException::isUsingExceptions example
  • Example#837 - RarException::setUsingExceptions example
  • Example#838 - - Bir Zip arşivi oluşturmak
  • Example#839 - - Arşiv bilgilerinin dökümü ve listelenmesi
  • Example#840 - - Zip akım sarmalayıcı; bir OpenOffice meta bilgisini okur
  • Example#841 - - Zip kullanım örneği (PHP 4)
  • Example#842 - - Bir arşivde boş bir dizin oluşturmak
  • Example#843 - - Aç ve ekle
  • Example#844 - - Arşive yeni bir girdi eklemek
  • Example#845 - - Bir dosyayı arşivdeki bir dizine eklemek
  • Example#846 - ZipArchive::addGlob example
  • Example#847 - ZipArchive::addPattern example
  • Example#848 - - İndisini kullanarak arşivden bir dosya silmek
  • Example#849 - - İsmini kullanarak arşivden bir dosya silmek
  • Example#850 - - Tüm girdileri çıkarmak
  • Example#851 - - Sadece iki girdi çıkarmak
  • Example#852 - - Bir arşiv açıklamasını basmak
  • Example#853 - - Bir girdinin açıklamasını basmak
  • Example#854 - - Bir girdinin açıklamasını basmak
  • Example#855 - Extract all entries with Unix rights
  • Example#856 - - Dosya içeriğini basmak
  • Example#857 - - Dosya içeriğinin basılması
  • Example#858 - - Bir zip girdisindeki resimde dönüşüm
  • Example#859 - - Girdi içeriğini fread ile alıp saklamak
  • Example#860 - - fopen ve zip akım sarmalayıcı kullanmak dışında yukarıdaki ile aynı
  • Example#861 - - Akım sarmalayıcı ve resim, XML işleviyle de kullanılabilir
  • Example#862 - - Bir arşiv oluşturup üzerinde ZipArchive::locateName kullanmak
  • Example#863 - - Bir arşivi açıp içeriğini dökmek
  • Example#864 - - Bir arşiv oluşturmak
  • Example#865 - - Bir girdinin ismini değiştirmek
  • Example#866 - - Bir girdinin ismini değiştirmek
  • Example#867 - - Bir arşiv oluşturup bir açıklama eklemek
  • Example#868 - Bir arşiv açıp bir girdiye açıklama eklemek
  • Example#869 - - Bir arşiv açıp bir girdiye açıklama eklemek
  • Example#870 - Add files with different compression methods to an archive
  • Example#871 - Add files with different compression methods to an archive
  • Example#872 - Archive a file, with its Unix rights
  • Example#873 - - Bir girdiyli ilgili bilgilerin dökümü
  • Example#874 - - Bir girdiyli ilgili bilgilerin dökümü
  • Example#875 - - Küçük bir Zlib örneği
  • Example#876 - - gzclose örneği
  • Example#877 - - gzcompress örneği
  • Example#878 - - gzdeflate örneği
  • Example#879 - - Bir gzip dosyası oluşturmak
  • Example#880 - - gzeof örneği
  • Example#881 - - gzfile örneği
  • Example#882 - - gzgetc örneği
  • Example#883 - - gzgets örneği
  • Example#884 - - gzgetss örneği
  • Example#885 - - gzinflate örneği
  • Example#886 - - gzopen örneği
  • Example#887 - - gzpassthru örneği
  • Example#888 - - gzread örneği
  • Example#889 - - gzseek örneği
  • Example#890 - - gzuncompress örneği
  • Example#891 - - gzwrite örneği
  • Example#892 - zlib_encode example
  • Example#893 - - CrackLib örneği
  • Example#894 - random_bytes example
  • Example#895 - random_int example
  • Example#896 - - hash_algos örneği
  • Example#897 - - hash_copy örneği
  • Example#898 - example
  • Example#899 - - hash_file örneği
  • Example#900 - - hash_final örneği
  • Example#901 - - hash_hmac_file örneği
  • Example#902 - - hash_hmac örneği
  • Example#903 - - Ardışık özetleme örneği
  • Example#904 - hash_pbkdf2 example, basic usage
  • Example#905 - - hash_update_stream örneği
  • Example#906 - - hash örneği
  • Example#907 - - Bir girdi değerinin 2.2.x altında ECB kipinde TripleDES ile şifrelenmesi
  • Example#908 - - Bir girdi değerinin 2.4.x altında ECB kipinde TripleDES ile şifrelenmesi
  • Example#909 - - mcrypt_create_iv örneği
  • Example#910 - - mcrypt_enc_get_algorithms_name örneği
  • Example#911 - - mcrypt_enc_get_modes_name örneği
  • Example#912 - - mcrypt_enc_get_supported_key_sizes örneği
  • Example#913 - - mcrypt_encrypt örneği
  • Example#914 - - mcrypt_get_block_size örneği
  • Example#915 - - mcrypt_get_cipher_name örneği
  • Example#916 - - mcrypt_get_iv_size örneği
  • Example#917 - - mcrypt_get_key_size örneği
  • Example#918 - - mcrypt_list_algorithms örneği
  • Example#919 - - mcrypt_list_modes örneği
  • Example#920 - - mcrypt_module_open örnekleri
  • Example#921 - - Şifreleme için mcrypt_module_open kullanımı
  • Example#922 - - mcrypt_module_self_test örneği
  • Example#923 - - mdecrypt_generic örneği
  • Example#924 - - Bir dizgenin MD5 ve HMAC özetlerini hesaplayıp sonuçları birer onaltılık dizge olarak çıktılamak
  • Example#925 - - Tüm algoritmaları sıradan geçmek
  • Example#926 - - mhash_get_block_size örneği
  • Example#927 - - mhash_get_hash_name örneği
  • Example#928 - openssl_cipher_iv_length example
  • Example#929 - - Öz-imzalı sertifika üretimi
  • Example#930 - - openssl_csr_sign örneği - CSR imzalama (Kendi Sertifika Yetkilinizi nasıl oluşturursunuz?)
  • Example#931 - - openssl_error_string örneği
  • Example#932 - openssl_get_cert_locations example
  • Example#933 - - openssl_get_cipher_methods örneği
  • Example#934 - - openssl_get_md_methods örneği
  • Example#935 - - openssl_open örneği
  • Example#936 - - openssl_pkcs7_decrypt örneği
  • Example#937 - - openssl_pkcs7_encrypt örneği
  • Example#938 - - openssl_pkcs7_sign örneği
  • Example#939 - - openssl_random_pseudo_bytes örneği
  • Example#940 - - openssl_seal örneği
  • Example#941 - - openssl_sign örneği
  • Example#942 - openssl_spki_export_challenge example
  • Example#943 - openssl_spki_export_challenge example from <keygen>
  • Example#944 - openssl_spki_export example
  • Example#945 - openssl_spki_export example from <keygen>
  • Example#946 - openssl_spki_new example
  • Example#947 - openssl_spki_verify example
  • Example#948 - openssl_spki_verify example from <keygen>
  • Example#949 - - openssl_verify örneği
  • Example#950 - password_hash example
  • Example#951 - password_hash example setting cost manually
  • Example#952 - password_hash example setting salt manually
  • Example#953 - password_hash example finding a good cost
  • Example#954 - Usage of password_needs_rehash
  • Example#955 - password_verify example
  • Example#956 - DBA example
  • Example#957 - Traversing a database
  • Example#958 - dba_handlers Example
  • Example#959 - dbx_close example
  • Example#960 - dbx_compare example
  • Example#961 - dbx_connect example
  • Example#962 - dbx_error example
  • Example#963 - dbx_escape_string example
  • Example#964 - How to handle the returned value
  • Example#965 - lists each field's name and type
  • Example#966 - outputs the content of data property into HTML table
  • Example#967 - How to handle UNBUFFERED queries
  • Example#968 - How to handle the returned value
  • Example#969 - dbx_sort example
  • Example#970 - DNS'siz bağlantı
  • Example#971 - - odbc_execute ve odbc_prepare örneği
  • Example#972 - - odbc_fetch_into örnekleri
  • Example#973 - - odbc_next_result örneği
  • Example#974 - - odbc_execute ve odbc_prepare örneği
  • Example#975 - - odbc_result örnekleri
  • Example#976 - - odbc_setoption örnekleri
  • Example#977 - - PDO::ATTR_DRIVER_NAME kullanımı
  • Example#978 - - MySQL'e bağlanma
  • Example#979 - - Bağlantı hatalarının ele alınışı
  • Example#980 - - Bir bağlantının kapatılışı
  • Example#981 - - Kalıcı bağlantılar
  • Example#982 - - Bir toplu hareket betiğinin çalıştırılması
  • Example#983 - - Hazır deyimlerle değiştirge ismine göre veri girişi
  • Example#984 - - Hazır deyimlerle değiştirge indisine göre veri girişi
  • Example#985 - - Hazır deyimle veri almak
  • Example#986 - - Bir saklı yordamın çıktı değiştirgesi ile kullanımı
  • Example#987 - - Bir saklı yordamın girdi/çıktı değiştirgesi ile kullanımı
  • Example#988 - - Geçersiz değiştirge kullanımı
  • Example#989 - - Veritabanındaki bir resmin gösterilmesi
  • Example#990 - - Bir resmin veritabanına yerleştirilmesi
  • Example#991 - - Oracle'da bir resmi veritabanına yerleştirmek
  • Example#992 - - ir toplu hareketi geri almak
  • Example#993 - - Bir toplu hareketin teslim edilmesi
  • Example#994 - - Sürücü isteğiyle PDO örneğinin oluşturulması
  • Example#995 - - URI isteğiyle PDO örneğinin oluşturulması
  • Example#996 - - Bir takma ad kullanarak PDO örneğinin oluşturulması
  • Example#997 - - Bir SQLSTATE kodunun döndürülmesi
  • Example#998 - - Bir DB2 veiitabanına kurulan bir PDO_ODBC bağlantısıyla ilgili hata bilgisinin gösterilmesi
  • Example#999 - - Bir DELETE deyiminin çalıştırılması
  • Example#1000 - - Veritabanı bağlantı özniteliklerinin öğrenilmesi
  • Example#1001 - - PDO::getAvailableDrivers örneği
  • Example#1002 - - İsimli değiştirgelerle bir SQL deyiminin hazırlanması
  • Example#1003 - - Soru imli değiştirgelerle bir SQL deyiminin hazırlanması
  • Example#1004 - - PDO::query örneği
  • Example#1005 - - Normal bir dizgeyi öncelemek
  • Example#1006 - - Tehlikeli bir dizgeyi öncelemek
  • Example#1007 - - Karmaşık bir dizgeyi öncelemek
  • Example#1008 - - Bir toplu hareketin geri alınması
  • Example#1009 - - Sonuç kümesi çıktısının PHP değişkenleri ile ilişkilendirilmesi
  • Example#1010 - - İsimli değiştirgelerle PDOStatement::bindParam örneği
  • Example#1011 - - Soru imli değiştirgelerle PDOStatement::bindParam örneği
  • Example#1012 - - Girdi/Çıktı değiştirgesi kullanımı
  • Example#1013 - - İsimli değiştirgelerle PDOStatement::bindValue örneği
  • Example#1014 - - Soru imli değiştirgelerle PDOStatement::bindValue örneği
  • Example#1015 - - PDOStatement::closeCursor örneği
  • Example#1016 - - Sütunları saymak
  • Example#1017 - - İsimli değiştirgelerle PDOStatement::debugDumpParams örneği
  • Example#1018 - - İsimsiz değiştirgelerle PDOStatement::debugDumpParams örneği
  • Example#1019 - - SQLSTATE kodunun döndürülmesi
  • Example#1020 - - Bir DB2 veritabanına açılan bir ODBC bağlantısından hata bilgisinin alınması
  • Example#1021 - - Değişkenlerle ilişkili bir hazır deyimin çalıştırılması
  • Example#1022 - - Yerleştirilecek değerlere (isimli değiştirgelere) sahip bir hazır deyimin çalıştırılması
  • Example#1023 - - - Yerleştirilecek değerlere (soru imli değiştirgelere) sahip bir hazır deyimin çalıştırılması
  • Example#1024 - Soru imli bir hazır deyimin çalıştırılması
  • Example#1025 - - Farklı alım tarzlarıyla satırların döndürülmesi
  • Example#1026 - - Satırları bir kaydırılabilir gösterici ile döndürmek
  • Example#1027 - - Bir sonuç kümesinde kalan tüm satırları almak
  • Example#1028 - - Sonuç kümesinden tek bir sütunun tüm değerlerini almak
  • Example#1029 - - Tüm değerleri tek bir sütuna göre gruplamak
  • Example#1030 - - Sonraki satırın ilk sütununu döndürmek
  • Example#1031 - - Sütun temel verilerinin alınması
  • Example#1032 - - Bir kayıtlı yordamdan dönen çok sayıda satır kümesine erişim
  • Example#1033 - - Silinen satır sayısının döndürülmesi
  • Example#1034 - - Bir SELECT deyiminden etkilenen satırların sayılması
  • Example#1035 - - Veri alım kipinin belirlenmesi
  • Example#1036 - Insert LOBs in CUBRID PDO
  • Example#1037 - Fetch LOBs in CUBRID PDO
  • Example#1038 - Insert set in CUBRID PDO with default data type.
  • Example#1039 - Specify data type when insert set in CUBRID PDO
  • Example#1040 - PDO_CUBRID DSN examples
  • Example#1041 - A PDO::cubrid_schema example
  • Example#1042 - - PDO_DBLIB DSN örnekleri
  • Example#1043 - - PDO_FIREBIRD DSN örneği
  • Example#1044 - - db2cli.ini kullanarak PDO_IBM DSN örneği
  • Example#1045 - - Bağlantı dizgeli PDO_IBM DSN'si örneği
  • Example#1046 - - odbc.ini kullanan PDO_INFORMIX DSN örneği
  • Example#1047 - - Bağlantı dizgeli PDO_INFORMIX DSN örneği
  • Example#1048 - - Sorguların tamponlanmasına zorlamak
  • Example#1049 - - PDO_MYSQL DSN örnekleri
  • Example#1050 - PDO_SQLSRV DSN examples
  • Example#1051 - - PDO_OCI DSN örnekleri
  • Example#1052 - - PDO_ODBC DSN örneği (ODBC sürücüsünün yöneticisi)
  • Example#1053 - - PDO_ODBC DSN örneği (IBM DB2 katalogsuz bağlantısı)
  • Example#1054 - - PDO_ODBC DSN örneği (Microsoft Access katalogsuz bağlantısı)
  • Example#1055 - - PDO_PGSQL DSN örneği
  • Example#1056 - A PDO::pgsqlLOBCreate example
  • Example#1057 - A PDO::pgsqlLOBOpen example
  • Example#1058 - A PDO::pgsqlLOBUnlink example
  • Example#1059 - - PDO_SQLITE DSN örnekleri
  • Example#1060 - max_length aggregation function example
  • Example#1061 - PDO::sqliteCreateCollation example
  • Example#1062 - PDO::sqliteCreateFunction example
  • Example#1063 - - PDO_4D için DSN örnekleri
  • Example#1064 - - PDO_4D için bir temel örnek
  • Example#1065 - PDO_4D üzerinden bir 4D veritabanına bağlanmak
  • Example#1066 - - 4D'de bir LEFT JOIN çalıştırmak
  • Example#1067 - - 4D tablo isimlerinin öncelenmesi
  • Example#1068 - Example of Data Retrieval
  • Example#1069 - Example of Data Insertion
  • Example#1070 - cubrid_bind example
  • Example#1071 - cubrid_bind BLOB/CLOB example
  • Example#1072 - cubrid_bind BLOB/CLOB example
  • Example#1073 - cubrid_close_prepare example
  • Example#1074 - cubrid_close_request example
  • Example#1075 - cubrid_col_get example
  • Example#1076 - cubrid_col_size example
  • Example#1077 - cubrid_column_names example
  • Example#1078 - cubrid_column_types example
  • Example#1079 - cubrid_commit example
  • Example#1080 - cubrid_connect_with_url url without properties example
  • Example#1081 - cubrid_connect_with_url url with properties example
  • Example#1082 - cubrid_connect example
  • Example#1083 - cubrid_current_oid example
  • Example#1084 - cubrid_disconnect example
  • Example#1085 - cubrid_drop example
  • Example#1086 - cubrid_error_code_facility example
  • Example#1087 - cubrid_error_code example
  • Example#1088 - cubrid_error_msg example
  • Example#1089 - cubrid_execute example
  • Example#1090 - cubrid_fetch example
  • Example#1091 - cubrid_free_result example
  • Example#1092 - cubrid_get_charset example
  • Example#1093 - cubrid_get_class_name example
  • Example#1094 - cubrid_get_client_info example
  • Example#1095 - cubrid_get_db_parameter example
  • Example#1096 - cubrid_get_query_timeout example
  • Example#1097 - cubrid_get_server_info example
  • Example#1098 - cubrid_get example
  • Example#1099 - cubrid_insert_id example
  • Example#1100 - cubrid_is_instance example
  • Example#1101 - cubrid_lob_close example
  • Example#1102 - cubrid_lob_export example
  • Example#1103 - cubrid_lob_get example
  • Example#1104 - cubrid_lob_send example
  • Example#1105 - cubrid_lob_size example
  • Example#1106 - cubrid_lob2_bind example
  • Example#1107 - cubrid_lob2_export example
  • Example#1108 - cubrid_lob2_export example
  • Example#1109 - cubrid_lob2_read example 1
  • Example#1110 - cubrid_lob2_read example 2
  • Example#1111 - cubrid_lob2_seek64 example
  • Example#1112 - cubrid_lob2_seek example
  • Example#1113 - cubrid_lob2_write example 1
  • Example#1114 - cubrid_lob2_write example 2
  • Example#1115 - cubrid_lock_read example
  • Example#1116 - cubrid_lock_write example
  • Example#1117 - cubrid_move_cursor example
  • Example#1118 - cubrid_next_result example
  • Example#1119 - cubrid_num_cols example
  • Example#1120 - cubrid_num_rows example
  • Example#1121 - cubrid_pconnect_with_url url without properties example
  • Example#1122 - cubrid_pconnect_with_url url with properties example
  • Example#1123 - cubrid_connect example
  • Example#1124 - cubrid_prepare example
  • Example#1125 - cubrid_put example
  • Example#1126 - cubrid_rollback example
  • Example#1127 - cubrid_schema example
  • Example#1128 - cubrid_seq_drop example
  • Example#1129 - cubrid_seq_insert example
  • Example#1130 - cubrid_seq_put example
  • Example#1131 - cubrid_set_add example
  • Example#1132 - cubrid_get_db_parameter example
  • Example#1133 - cubrid_set_drop example
  • Example#1134 - cubrid_version example
  • Example#1135 - cubrid_affected_rows example
  • Example#1136 - cubrid_client_encoding example
  • Example#1137 - cubrid_close example
  • Example#1138 - cubrid_data_seek example
  • Example#1139 - cubrid_db_name example
  • Example#1140 - cubrid_errno example
  • Example#1141 - cubrid_error example
  • Example#1142 - cubrid_fetch_array example
  • Example#1143 - cubrid_fetch_assoc example
  • Example#1144 - cubrid_fetch_field example
  • Example#1145 - cubrid_fetch_lengths example
  • Example#1146 - cubrid_fetch_object example
  • Example#1147 - cubrid_fetch_row example
  • Example#1148 - cubrid_field_flags example
  • Example#1149 - cubrid_field_len example
  • Example#1150 - cubrid_field_name example
  • Example#1151 - cubrid_field_seek example
  • Example#1152 - cubrid_field_table example
  • Example#1153 - cubrid_field_type example
  • Example#1154 - cubrid_list_dbs example
  • Example#1155 - cubrid_num_fields example
  • Example#1156 - cubrid_ping example
  • Example#1157 - Invalid Query
  • Example#1158 - Valid Query
  • Example#1159 - cubrid_real_escape_string example
  • Example#1160 - cubrid_result example
  • Example#1161 - cubrid_unbuffered_query example
  • Example#1162 - cubrid_load_from_glo example
  • Example#1163 - cubrid_new_glo example
  • Example#1164 - cubrid_save_to_glo example
  • Example#1165 - cubrid_send_glo example
  • Example#1166 - Inserting a record in a dBase database
  • Example#1167 - Closing a dBase database file
  • Example#1168 - Creating a dBase database file
  • Example#1169 - Showing header information for a dBase database file
  • Example#1170 - Listing all the registered members in the database
  • Example#1171 - dbase_numfields Example
  • Example#1172 - Looping over all the records of the database
  • Example#1173 - Opening a dBase database file
  • Example#1174 - Emptying a dBase database
  • Example#1175 - Updating a record in the database
  • Example#1176 - ibase_blob_get example
  • Example#1177 - ibase_blob_import example
  • Example#1178 - ibase_connect example
  • Example#1179 - ibase_execute example
  • Example#1180 - ibase_fetch_object example
  • Example#1181 - ibase_field_info example
  • Example#1182 - ibase_name_result example
  • Example#1183 - ibase_num_fields example
  • Example#1184 - ibase_query example
  • Example#1185 - ibase_set_event_handler example
  • Example#1186 - fbsql_close example
  • Example#1187 - fbsql_connect example
  • Example#1188 - fbsql_create_blob example
  • Example#1189 - fbsql_create_clob example
  • Example#1190 - fbsql_create_db example
  • Example#1191 - fbsql_data_seek example
  • Example#1192 - fbsql_create_clob example
  • Example#1193 - fbsql_errno Example
  • Example#1194 - fbsql_error Example
  • Example#1195 - fbsql_fetch_array example
  • Example#1196 - fbsql_fetch_assoc example
  • Example#1197 - fbsql_fetch_field example
  • Example#1198 - fbsql_fetch_object example
  • Example#1199 - fbsql_field_name example
  • Example#1200 - fbsql_field_type example
  • Example#1201 - fbsql_list_dbs example
  • Example#1202 - fbsql_list_fields example
  • Example#1203 - fbsql_next_result example
  • Example#1204 - fbsql_num_rows example
  • Example#1205 - fbsql_query example
  • Example#1206 - fbsql_query example
  • Example#1207 - fbsql_read_blob example
  • Example#1208 - fbsql_read_clob example
  • Example#1209 - fbsql_table_name example
  • Example#1210 - Retrieving the AUTOCOMMIT value for a connection
  • Example#1211 - Setting the AUTOCOMMIT value for a connection
  • Example#1212 - Binding PHP variables to a prepared statement
  • Example#1213 - Calling stored procedures with IN and OUT parameters
  • Example#1214 - Inserting a binary large object (BLOB) directly from a file
  • Example#1215 - A db2_client_info example
  • Example#1216 - Closing a connection
  • Example#1217 - Retrieving an SQLSTATE value for a failed connection attempt
  • Example#1218 - Retrieving the error message returned by a failed connection attempt
  • Example#1219 - Creating a cataloged connection
  • Example#1220 - Creating an uncataloged connection
  • Example#1221 - Creating a connection with autocommit off by default
  • Example#1222 - i5/OS best performance
  • Example#1223 - Using trusted context
  • Example#1224 - A db2_escape_string example
  • Example#1225 - Creating a table with db2_exec
  • Example#1226 - Executing a SELECT statement with a scrollable cursor
  • Example#1227 - Returning XML data as an SQL ResultSet
  • Example#1228 - Performing a "JOIN" with XML data
  • Example#1229 - Returning SQL data as part of a larger XML document
  • Example#1230 - Preparing and executing an SQL statement with parameter markers
  • Example#1231 - Calling a stored procedure with an OUT parameter
  • Example#1232 - Returning XML data as an SQL ResultSet
  • Example#1233 - Performing a "JOIN" with XML data
  • Example#1234 - Returning SQL data as part of a larger XML document
  • Example#1235 - Iterating through a forward-only cursor
  • Example#1236 - Retrieving specific rows with db2_fetch_array from a scrollable cursor
  • Example#1237 - Iterating through a forward-only cursor
  • Example#1238 - Retrieving specific rows with db2_fetch_assoc from a scrollable cursor
  • Example#1239 - Iterating through a forward-only cursor
  • Example#1240 - Retrieving specific rows with db2_fetch_both from a scrollable cursor
  • Example#1241 - A db2_fetch_object example
  • Example#1242 - Iterating through a result set
  • Example#1243 - i5/OS recommended alternatives to db2_fetch_row/db2_result
  • Example#1244 - Setting and retrieving parameters through a connection resource
  • Example#1245 - A db2_last_insert_id example
  • Example#1246 - Iterating through different types of data
  • Example#1247 - Calling a stored procedure that returns multiple result sets
  • Example#1248 - Retrieving the number of fields in a result set
  • Example#1249 - Closing a persistent connection
  • Example#1250 - A db2_pconnect example
  • Example#1251 - Using trusted context
  • Example#1252 - Preparing and executing an SQL statement with parameter markers
  • Example#1253 - A db2_result example
  • Example#1254 - Rolling back a DELETE statement
  • Example#1255 - A db2_server_info example
  • Example#1256 - Setting one parameter with a connection resource
  • Example#1257 - Setting multiple parameters with a connection resource
  • Example#1258 - Setting multiple parameters with an invalid key
  • Example#1259 - Setting multiple parameters with an invalid value
  • Example#1260 - Setting multiple parameters with a connection resource and the wrong type
  • Example#1261 - Setting multiple parameters with the wrong resource
  • Example#1262 - Putting it all together
  • Example#1263 - i5/OS cursors are read-only
  • Example#1264 - Informix affected rows
  • Example#1265 - Closing a Informix connection
  • Example#1266 - Connect to a Informix database
  • Example#1267 - ifx_do Example
  • Example#1268 - ifx_errormsg example
  • Example#1269 - Informix fetch rows
  • Example#1270 - Informix SQL fieldproperties
  • Example#1271 - Fieldnames and SQL fieldtypes
  • Example#1272 - Retrieve Informix sqlca.sqlerrd[x] values
  • Example#1273 - Informix results as HTML table
  • Example#1274 - ifx_num_fields Example
  • Example#1275 - Show all rows of the "orders" table as a HTML table
  • Example#1276 - Insert some values into the "catalog" table
  • Example#1277 - Example usage of PassEnv for Ingres
  • Example#1278 - Simple Ingres Example
  • Example#1279 - ingres_charset - Get the installation character set
  • Example#1280 - Open a connection to an Ingres database
  • Example#1281 - Get cursor name for a query resource
  • Example#1282 - Get the last Ingres error number generated
  • Example#1283 - Get a message for the last error generated
  • Example#1284 - Get the last SQLSTATE error code generated
  • Example#1285 - Escape special characters for use in a query
  • Example#1286 - Fetch a row of result into an array
  • Example#1287 - Fetch a row into an associative array
  • Example#1288 - Fetch a row into an object
  • Example#1289 - Get the return value from a procedure call
  • Example#1290 - Fetch a row of result into an enumerated array
  • Example#1291 - Free a result resource
  • Example#1292 - Send a simple select
  • Example#1293 - Passing query parameters to ingres_query
  • Example#1294 - Inserting a BLOB with parameter types
  • Example#1295 - Position the cursor on the 3rd row
  • Example#1296 - Set date_format to ISO4
  • Example#1297 - Set timezone to HONG-KONG
  • Example#1298 - Issue a simple un-buffered select
  • Example#1299 - Passing query parameters to ingres_unbuffered_query
  • Example#1300 - Inserting a BLOB with parameter types
  • Example#1301 - MaxDB extension overview example
  • Example#1302 - Example for use of SELECT INTO statements
  • Example#1303 - Example fore using database procedures
  • Example#1304 - Nesne yönelimli kullanım
  • Example#1305 - Yordamsal kullanım
  • Example#1306 - Nesne yönelimli kullanım
  • Example#1307 - Yordamsal kullanım
  • Example#1308 - Nesne yönelimli kullanım
  • Example#1309 - Yordamsal kullanım
  • Example#1310 - Nesne yönelimli kullanım
  • Example#1311 - Yordamsal kullanım
  • Example#1312 - Nesne yönelimli kullanım
  • Example#1313 - Yordamsal kullanım
  • Example#1314 - maxdb_connect_errno sample
  • Example#1315 - maxdb_connect_error sample
  • Example#1316 - Nesne yönelimli kullanım
  • Example#1317 - Yordamsal kullanım
  • Example#1318 - Nesne yönelimli kullanım
  • Example#1319 - Yordamsal kullanım
  • Example#1320 - Yordamsal kullanım
  • Example#1321 - Nesne yönelimli kullanım
  • Example#1322 - Yordamsal kullanım
  • Example#1323 - Nesne yönelimli kullanım
  • Example#1324 - Yordamsal kullanım
  • Example#1325 - Nesne yönelimli kullanım
  • Example#1326 - Yordamsal kullanım
  • Example#1327 - Nesne yönelimli kullanım
  • Example#1328 - Yordamsal kullanım
  • Example#1329 - Nesne yönelimli kullanım
  • Example#1330 - Yordamsal kullanım
  • Example#1331 - Nesne yönelimli kullanım
  • Example#1332 - Yordamsal kullanım
  • Example#1333 - Nesne yönelimli kullanım
  • Example#1334 - Yordamsal kullanım
  • Example#1335 - Nesne yönelimli kullanım
  • Example#1336 - Yordamsal kullanım
  • Example#1337 - Nesne yönelimli kullanım
  • Example#1338 - Yordamsal kullanım
  • Example#1339 - Nesne yönelimli kullanım
  • Example#1340 - Yordamsal kullanım
  • Example#1341 - Nesne yönelimli kullanım
  • Example#1342 - Yordamsal kullanım
  • Example#1343 - Nesne yönelimli kullanım
  • Example#1344 - Yordamsal kullanım
  • Example#1345 - Nesne yönelimli kullanım
  • Example#1346 - Yordamsal kullanım
  • Example#1347 - maxdb_get_client_info
  • Example#1348 - maxdb_get_client_version
  • Example#1349 - Nesne yönelimli kullanım
  • Example#1350 - Yordamsal kullanım
  • Example#1351 - Nesne yönelimli kullanım
  • Example#1352 - Yordamsal kullanım
  • Example#1353 - Nesne yönelimli kullanım
  • Example#1354 - Yordamsal kullanım
  • Example#1355 - Nesne yönelimli kullanım
  • Example#1356 - Yordamsal kullanım
  • Example#1357 - Nesne yönelimli kullanım
  • Example#1358 - Yordamsal kullanım
  • Example#1359 - Nesne yönelimli kullanım
  • Example#1360 - Yordamsal kullanım
  • Example#1361 - Nesne yönelimli kullanım
  • Example#1362 - Yordamsal kullanım
  • Example#1363 - Nesne yönelimli kullanım
  • Example#1364 - Yordamsal kullanım
  • Example#1365 - Nesne yönelimli kullanım
  • Example#1366 - Yordamsal kullanım
  • Example#1367 - Nesne yönelimli kullanım
  • Example#1368 - Yordamsal kullanım
  • Example#1369 - Nesne yönelimli kullanım
  • Example#1370 - Yordamsal kullanım
  • Example#1371 - Nesne yönelimli kullanım
  • Example#1372 - Yordamsal kullanım
  • Example#1373 - Nesne yönelimli kullanım
  • Example#1374 - Yordamsal kullanım
  • Example#1375 - Nesne yönelimli kullanım
  • Example#1376 - Yordamsal kullanım
  • Example#1377 - Nesne yönelimli kullanım
  • Example#1378 - Yordamsal kullanım
  • Example#1379 - Yordamsal kullanım
  • Example#1380 - Nesne yönelimli kullanım
  • Example#1381 - Yordamsal kullanım
  • Example#1382 - Nesne yönelimli kullanım
  • Example#1383 - Yordamsal kullanım
  • Example#1384 - Nesne yönelimli kullanım
  • Example#1385 - Yordamsal kullanım
  • Example#1386 - Nesne yönelimli kullanım
  • Example#1387 - Yordamsal kullanım
  • Example#1388 - Nesne yönelimli kullanım
  • Example#1389 - Yordamsal kullanım
  • Example#1390 - Nesne yönelimli kullanım
  • Example#1391 - Yordamsal kullanım
  • Example#1392 - Yordamsal kullanım (SELECT INTO)
  • Example#1393 - Yordamsal kullanım (DB procedure)
  • Example#1394 - Nesne yönelimli kullanım (extended syntax)
  • Example#1395 - Nesne yönelimli kullanım
  • Example#1396 - Yordamsal kullanım
  • Example#1397 - Nesne yönelimli kullanım
  • Example#1398 - Yordamsal kullanım
  • Example#1399 - Nesne yönelimli kullanım
  • Example#1400 - Yordamsal kullanım
  • Example#1401 - Nesne yönelimli kullanım
  • Example#1402 - Yordamsal kullanım
  • Example#1403 - Nesne yönelimli kullanım
  • Example#1404 - Yordamsal kullanım
  • Example#1405 - Nesne yönelimli kullanım
  • Example#1406 - Yordamsal kullanım
  • Example#1407 - Nesne yönelimli kullanım
  • Example#1408 - Yordamsal kullanım
  • Example#1409 - Nesne yönelimli kullanım
  • Example#1410 - Yordamsal kullanım
  • Example#1411 - Nesne yönelimli kullanım
  • Example#1412 - Yordamsal kullanım
  • Example#1413 - Nesne yönelimli kullanım
  • Example#1414 - Yordamsal kullanım
  • Example#1415 - Nesne yönelimli kullanım
  • Example#1416 - Yordamsal kullanım
  • Example#1417 - Nesne yönelimli kullanım
  • Example#1418 - Yordamsal kullanım
  • Example#1419 - Nesne yönelimli kullanım
  • Example#1420 - Yordamsal kullanım
  • Example#1421 - Nesne yönelimli kullanım
  • Example#1422 - Yordamsal kullanım
  • Example#1423 - Nesne yönelimli kullanım
  • Example#1424 - Yordamsal kullanım
  • Example#1425 -
  • Example#1426 -
  • Example#1427 -
  • Example#1428 -
  • Example#1429 -
  • Example#1430 -
  • Example#1431 -
  • Example#1432 -
  • Example#1433 -
  • Example#1434 -
  • Example#1435 -
  • Example#1436 -
  • Example#1437 -
  • Example#1438 -
  • Example#1439 -
  • Example#1440 - Connection URI read preferences with query string syntax
  • Example#1441 - Setting read preferences with array syntax for tag sets
  • Example#1442 - Passing a WriteConcern to a write operation
  • Example#1443 - Connection string WriteConcerns
  • Example#1444 - MongoDB::setWriteConcern and MongoCollection::setWriteConcern
  • Example#1445 - Unacknowledged WriteConcern, followed with Acknowledged Write
  • Example#1446 - Acknowledged Writes
  • Example#1447 - Majority Acknowledged Write
  • Example#1448 - Acknowledged and Journaled Write
  • Example#1449 - Connect to MongoDB Instance with SSL Encryption
  • Example#1450 - Connect to MongoDB Instance with SSL Encryption, verifying it is who we think it is
  • Example#1451 - Connect to MongoDB Instance that Requires Client Certificates
  • Example#1452 - Authenticating with X.509 certificates
  • Example#1453 - Authenticating against the "admin" database
  • Example#1454 - Authenticating against normal databases
  • Example#1455 - ReplicaSet seed list
  • Example#1456 - Wrong replica set name duplication
  • Example#1457 - Correct use of two replica set names
  • Example#1458 -
  • Example#1459 -
  • Example#1460 -
  • Example#1461 -
  • Example#1462 -
  • Example#1463 -
  • Example#1464 - Inheriting read preferences from the database level down to the cursor
  • Example#1465 -
  • Example#1466 -
  • Example#1467 -
  • Example#1468 -
  • Example#1469 -
  • Example#1470 -
  • Example#1471 -
  • Example#1472 - MongoClient basic usage
  • Example#1473 - MongoClient::close example
  • Example#1474 - MongoClient::__construct replica set example
  • Example#1475 - Connecting to a domain socket
  • Example#1476 - MongoClient::__construct authentication example
  • Example#1477 - MongoClient::__construct read preference example
  • Example#1478 - MongoClient::__construct options example
  • Example#1479 - MongoClient::__construct read preference example
  • Example#1480 - MongoClient::getConnections example
  • Example#1481 - MongoClient::getReadPreference return value example
  • Example#1482 - MongoClient::getWriteConcern return value example
  • Example#1483 - MongoClient::killCursor example
  • Example#1484 - MongoClient::listDBs example
  • Example#1485 - MongoClient::selectCollection example
  • Example#1486 - MongoClient::setReadPreference tag set array syntax example
  • Example#1487 - MongoClient::setWriteConcern example
  • Example#1488 - Selecting a database
  • Example#1489 - MongoDB::command "distinct" example
  • Example#1490 - MongoDB::command "distinct" example
  • Example#1491 - MongoDB::command MapReduce example
  • Example#1492 - MongoDB::command "geoNear" example
  • Example#1493 - MongoDB::createCollection capped collection example
  • Example#1494 - MongoDB::createDBRef example
  • Example#1495 - MongoDB::createDBRef example
  • Example#1496 - MongoDB::drop example
  • Example#1497 - Simple MongoDB::execute example
  • Example#1498 - Parameter MongoDB::execute example
  • Example#1499 - Scope example
  • Example#1500 - MongoDB::getCollectionInfo example
  • Example#1501 - MongoDB::getCollectionNames example
  • Example#1502 - MongoDB::getDBRef example
  • Example#1503 - MongoDB::getGridFS example
  • Example#1504 - MongoDB::getReadPreference return value example
  • Example#1505 - MongoDB::getWriteConcern return value example
  • Example#1506 - MongoDB::lastError NULL error example
  • Example#1507 - MongoDB::lastError duplicate key example
  • Example#1508 - MongoDB::listCollections example
  • Example#1509 - MongoDB::repair example
  • Example#1510 - MongoDB::setReadPreference tag set array syntax example
  • Example#1511 - MongoDB::setWriteConcern example
  • Example#1512 - MongoCollection::aggregate example
  • Example#1513 - MongoCollection::aggregate example
  • Example#1514 - MongoCollection::aggregate example
  • Example#1515 - MongoCollection::aggregate with command options
  • Example#1516 - MongoCollection::aggregateCursor example
  • Example#1517 - MongoCollection::aggregateCursor example with different initial batch size
  • Example#1518 - MongoCollection::batchInsert example
  • Example#1519 - MongoCollection::batchInsert example with ignoring errors
  • Example#1520 - MongoCollection::count example
  • Example#1521 - MongoCollection::createDBRef example
  • Example#1522 - MongoCollection::createIndex example
  • Example#1523 - Geospatial Indexing
  • Example#1524 - Drop duplicates example
  • Example#1525 - MongoCollection::deleteIndex example
  • Example#1526 - MongoCollection::deleteIndexes example
  • Example#1527 - MongoCollection::distinct example
  • Example#1528 - MongoCollection::distinct example on a embedded document
  • Example#1529 - MongoCollection::drop example
  • Example#1530 - MongoCollection::ensureIndex example
  • Example#1531 - Geospatial Indexing
  • Example#1532 - Drop duplicates example
  • Example#1533 - MongoCollection::find example
  • Example#1534 - MongoCollection::find example
  • Example#1535 - MongoCollection::find example using $where
  • Example#1536 - MongoCollection::find example using $in
  • Example#1537 - Getting results as an array
  • Example#1538 - MongoCollection::findAndModify example
  • Example#1539 - MongoCollection::findAndModify error handling
  • Example#1540 - MongoCollection::findOne document by its id.
  • Example#1541 - MongoCollection::findOne document by some condition.
  • Example#1542 - MongoCollection::getDBRef example
  • Example#1543 - MongoCollection::getIndexInfo example
  • Example#1544 - MongoCollection::getName example
  • Example#1545 - MongoCollection::getReadPreference return value example
  • Example#1546 - MongoCollection::getWriteConcern return value example
  • Example#1547 - MongoCollection::group example
  • Example#1548 - MongoCollection::group example
  • Example#1549 - Passing a keys function
  • Example#1550 - MongoCollection::insert _id example
  • Example#1551 - MongoCollection::insert acknowledged write example
  • Example#1552 - MongoCollection::parallelCollectionScan example
  • Example#1553 - MongoCollection::remove with justOne example
  • Example#1554 - MongoCollection::save example
  • Example#1555 - MongoCollection::setReadPreference tag set array syntax example
  • Example#1556 - MongoDB::setWriteConcern example
  • Example#1557 - MongoCollection::toIndexString example
  • Example#1558 - MongoCollection::__toString example
  • Example#1559 - MongoCollection::update
  • Example#1560 - MongoCollection::update upsert examples
  • Example#1561 - MongoCollection::update multiple example
  • Example#1562 - MongoCursor basic usage
  • Example#1563 - Iterating over MongoCursor
  • Example#1564 - Adding options to MongoCursor
  • Example#1565 - Adding a comment with MongoCursor::addOption example
  • Example#1566 - MongoCursor::addOption example
  • Example#1567 - MongoCursor::awaitData example
  • Example#1568 - MongoCursor::batchSize and combinations with MongoCursor::limit
  • Example#1569 - MongoCursor::count example
  • Example#1570 - MongoCursor::doQuery example
  • Example#1571 - MongoCursor::explain example
  • Example#1572 - MongoCursor::getReadPreference return value example
  • Example#1573 - MongoCursor::info example
  • Example#1574 - MongoCursor::maxTimeMS example
  • Example#1575 - MongoCursor::setFlag example
  • Example#1576 - MongoCursor::setReadPreference tag set array syntax example
  • Example#1577 - MongoCursor::slaveOkay example
  • Example#1578 - MongoCursor::sort example
  • Example#1579 - MongoCursor::tailable example
  • Example#1580 - MongoCursor::timeout example
  • Example#1581 - Adding options to MongoCommandCursor
  • Example#1582 - MongoCommandCursor::batchSize
  • Example#1583 - MongoCommandCursor example
  • Example#1584 - MongoCommandCursor::createFromDocument
  • Example#1585 - MongoCommandCursor::getReadPreference return value example
  • Example#1586 - MongoCommandCursor::info example
  • Example#1587 - MongoCommandCursor::rewind
  • Example#1588 - MongoCommandCursor::setReadPreference tag set array syntax example
  • Example#1589 - MongoCommandCursor::timeout example
  • Example#1590 - MongoId::__construct example
  • Example#1591 - Parameter example
  • Example#1592 - MongoId::__toString example
  • Example#1593 - MongoCode::__construct example
  • Example#1594 - Using MongoCode with $where
  • Example#1595 - MongoCode::__toString example
  • Example#1596 - Storing dates with MongoDate
  • Example#1597 - MongoDate::__construct example
  • Example#1598 - MongoDate::toDateTime example
  • Example#1599 - Regular expression pattern
  • Example#1600 - MongoRegex::__construct example
  • Example#1601 - MongoRegex::__toString example
  • Example#1602 -
  • Example#1603 - Linking documents
  • Example#1604 - Creating MongoDBRef links
  • Example#1605 - MongoDBRef::create example
  • Example#1606 - MongoCollection::createDBRef example
  • Example#1607 - MongoGridFS::findOne example
  • Example#1608 - MongoGridFS::storeBytes with additional metadata
  • Example#1609 - MongoGridFS::storeFile with additional metadata
  • Example#1610 - MongoGridFS::storeUpload HTML form example
  • Example#1611 - MongoGridFSFile::getBytes example
  • Example#1612 - MongoGridFSFile::getResource example
  • Example#1613 - MongoGridFSFile::write example
  • Example#1614 - MongoWriteBatch example
  • Example#1615 - MongoWriteBatch::add example
  • Example#1616 - MongoWriteBatch::add example
  • Example#1617 - MongoWriteBatch::add example
  • Example#1618 - MongoWriteBatch::add example
  • Example#1619 - MongoWriteBatch::add example
  • Example#1620 - MongoWriteBatch::add example
  • Example#1621 - MongoLog::setCallback example
  • Example#1622 - Changing pool size
  • Example#1623 - Mongo::setPoolSize example
  • Example#1624 - Changing pool size
  • Example#1625 - Mongo::setPoolSize example
  • Example#1626 - MongoResultException::getDocument example
  • Example#1627 - Catching MongoDuplicateKeyException
  • Example#1628 - Catching MongoProtocolException
  • Example#1629 - MongoDB\Driver\Manager::__construct basic example
  • Example#1630 - MongoDB\Driver\Manager::__construct basic examples
  • Example#1631 - MongoDB\Driver\Manager::executeBulkWrite example
  • Example#1632 - MongoDB\Driver\Manager::executeCommand with a command returning a single result document
  • Example#1633 - MongoDB\Driver\Manager::executeCommand with a command returning a cursor
  • Example#1634 - MongoDB\Driver\Manager::executeQuery example
  • Example#1635 - MongoDB\Driver\Manager::getReadConcern example
  • Example#1636 - MongoDB\Driver\Manager::getReadPreference example
  • Example#1637 - MongoDB\Driver\Manager::getServers example
  • Example#1638 - MongoDB\Driver\Manager::getWriteConcern example
  • Example#1639 - Composing MongoDB\Driver\Command to provide a helper to create collections
  • Example#1640 - MongoDB\Driver\Command::__construct example
  • Example#1641 - MongoDB\Driver\Query::__construct example
  • Example#1642 - Mixed write operations are grouped by type
  • Example#1643 - Ordered write operations causing an error
  • Example#1644 - MongoDB\Driver\BulkWrite::__construct example
  • Example#1645 - MongoDB\Driver\BulkWrite::count example
  • Example#1646 - MongoDB\Driver\BulkWrite::delete example
  • Example#1647 - MongoDB\Driver\BulkWrite::insert example
  • Example#1648 - MongoDB\Driver\BulkWrite::update example
  • Example#1649 - MongoDB\Driver\WriteConcern::bsonSerialize with majority write concern
  • Example#1650 - MongoDB\Driver\WriteConcern::bsonSerialize with wtimeout and journal
  • Example#1651 - MongoDB\Driver\WriteConcern::__construct example
  • Example#1652 - MongoDB\Driver\WriteConcern::getJournal example
  • Example#1653 - MongoDB\Driver\WriteConcern::getW example
  • Example#1654 - MongoDB\Driver\WriteConcern::getWtimeout example
  • Example#1655 - MongoDB\Driver\ReadPreference::bsonSerialize with primary read preference
  • Example#1656 - MongoDB\Driver\ReadPreference::bsonSerialize with secondary read preference and tag sets
  • Example#1657 - MongoDB\Driver\ReadPreference::bsonSerialize with secondary read preference and max staleness
  • Example#1658 - MongoDB\Driver\ReadPreference::__construct example
  • Example#1659 - MongoDB\Driver\ReadPreference::getMaxStalenessSeconds example
  • Example#1660 - MongoDB\Driver\ReadPreference::getMode example
  • Example#1661 - MongoDB\Driver\ReadPreference::getTagSets example
  • Example#1662 - MongoDB\Driver\ReadConcern::bsonSerialize with empty read concern
  • Example#1663 - MongoDB\Driver\ReadConcern::bsonSerialize with local read concern
  • Example#1664 - MongoDB\Driver\ReadConcern::__construct example
  • Example#1665 - MongoDB\Driver\ReadConcern::getLevel example
  • Example#1666 - MongoDB\Driver\Cursor::getId example
  • Example#1667 - MongoDB\Driver\Cursor::getServer example
  • Example#1668 - MongoDB\Driver\Cursor::isDead example
  • Example#1669 - MongoDB\Driver\Cursor::setTypeMap example
  • Example#1670 - MongoDB\Driver\Cursor::toArray example
  • Example#1671 - MongoDB\Driver\CursorId::__toString example
  • Example#1672 - MongoDB\Driver\Server::getHost example
  • Example#1673 - MongoDB\Driver\Server::getInfo example
  • Example#1674 - MongoDB\Driver\Server::getLatency example
  • Example#1675 - MongoDB\Driver\Server::getPort example
  • Example#1676 - MongoDB\Driver\WriteConcernError::getCode example
  • Example#1677 - MongoDB\Driver\WriteConcernError::getInfo example
  • Example#1678 - MongoDB\Driver\WriteConcernError::getMessage example
  • Example#1679 - MongoDB\Driver\WriteError::getCode example
  • Example#1680 - MongoDB\Driver\WriteError::getIndex example
  • Example#1681 - MongoDB\Driver\WriteError::getMessage example
  • Example#1682 - MongoDB\Driver\WriteResult::getDeletedCount example
  • Example#1683 - MongoDB\Driver\WriteResult::getInsertedCount example
  • Example#1684 - MongoDB\Driver\WriteResult::getMatchedCount example
  • Example#1685 - MongoDB\Driver\WriteResult::getModifiedCount example
  • Example#1686 - MongoDB\Driver\WriteResult::getServer example
  • Example#1687 - MongoDB\Driver\WriteResult::getUpsertedCount example
  • Example#1688 - MongoDB\Driver\WriteResult::getUpsertedIds example
  • Example#1689 - MongoDB\Driver\WriteResult::getWriteConcernError example
  • Example#1690 - MongoDB\Driver\WriteResult::getWriteErrors with a single error
  • Example#1691 - MongoDB\Driver\WriteResult::getWriteErrors with multiple errors
  • Example#1692 - MongoDB\Driver\WriteResult::isAcknowledged with acknowledged write concern
  • Example#1693 - MongoDB\Driver\WriteResult::isAcknowledged with unacknowledged write concern
  • Example#1694 - MongoDB\BSON\fromJSON example
  • Example#1695 - MongoDB\BSON\fromPHP example
  • Example#1696 - MongoDB\BSON\toJSON example
  • Example#1697 - MongoDB\BSON\toPHP example
  • Example#1698 - MongoDB\BSON\Binary::__construct example
  • Example#1699 - MongoDB\BSON\Binary::getData example
  • Example#1700 - MongoDB\BSON\Binary::getType example
  • Example#1701 - MongoDB\BSON\Binary::__toString example
  • Example#1702 - MongoDB\BSON\Decimal128::__construct example
  • Example#1703 - MongoDB\BSON\Decimal128::__toString example
  • Example#1704 - MongoDB\BSON\Javascript::__construct example
  • Example#1705 - MongoDB\BSON\Javascript::getCode example
  • Example#1706 - MongoDB\BSON\Javascript::getScope example
  • Example#1707 - MongoDB\BSON\Javascript::__toString example
  • Example#1708 - MongoDB\BSON\MaxKey::__construct example
  • Example#1709 - MongoDB\BSON\MinKey::__construct example
  • Example#1710 - MongoDB\BSON\ObjectID::__construct example
  • Example#1711 - MongoDB\BSON\ObjectID::getTimestamp example
  • Example#1712 - MongoDB\BSON\ObjectID::__toString example
  • Example#1713 - MongoDB\BSON\Regex::__construct example
  • Example#1714 - MongoDB\BSON\Regex::getFlags example
  • Example#1715 - MongoDB\BSON\Regex::getPattern example
  • Example#1716 - MongoDB\BSON\Regex::__toString example
  • Example#1717 - MongoDB\BSON\Timestamp::__construct example
  • Example#1718 - MongoDB\BSON\Timestamp::__toString example
  • Example#1719 - MongoDB\BSON\UTCDateTime::__construct example
  • Example#1720 - MongoDB\BSON\UTCDatetime::toDateTime example
  • Example#1721 - MongoDB\BSON\UTCDateTime::__toString example
  • Example#1722 - MongoDB\BSON\Serializable::bsonSerialize returning an associative array for root document
  • Example#1723 - MongoDB\BSON\Serializable::bsonSerialize returning a sequential array for root document
  • Example#1724 - MongoDB\BSON\Serializable::bsonSerialize returning an associative array for document field
  • Example#1725 - MongoDB\BSON\Serializable::bsonSerialize returning a sequential array for document field
  • Example#1726 - MongoDB\BSON\Unserializable::bsonUnserialize example
  • Example#1727 - MongoDB\Driver\Exception\WriteException::getWriteResult example
  • Example#1728 - mSQL usage example
  • Example#1729 - msql_fetch_array example
  • Example#1730 - msql_fetch_object example
  • Example#1731 - msql_fetch_row example
  • Example#1732 - msql_query example
  • Example#1733 - mssql_bind example
  • Example#1734 - mssql_close example
  • Example#1735 - mssql_connect example
  • Example#1736 - mssql_data_seek example
  • Example#1737 - mssql_execute example
  • Example#1738 - mssql_fetch_array example
  • Example#1739 - mssql_fetch_assoc example
  • Example#1740 - mssql_fetch_batch example
  • Example#1741 - mssql_fetch_field example
  • Example#1742 - mssql_fetch_object example
  • Example#1743 - mssql_fetch_row example
  • Example#1744 - mssql_field_length example
  • Example#1745 - mssql_field_name example
  • Example#1746 - Using mssql_field_seek on the example for mssql_fetch_field
  • Example#1747 - mssql_field_type example
  • Example#1748 - mssql_free_result example
  • Example#1749 - mssql_free_statement example
  • Example#1750 - mssql_get_last_message example
  • Example#1751 - mssql_guid_string example
  • Example#1752 - mssql_init example
  • Example#1753 - mssql_min_error_severity example
  • Example#1754 - mssql_min_message_severity example
  • Example#1755 - mssql_next_result example
  • Example#1756 - mssql_num_fields example
  • Example#1757 - mssql_num_rows example
  • Example#1758 - mssql_pconnect using the new_link parameter
  • Example#1759 - mssql_query example
  • Example#1760 - mssql_result example
  • Example#1761 - Faster alternative to above example
  • Example#1762 - mssql_rows_affected example
  • Example#1763 - mssql_select_db example
  • Example#1764 - Escaping the database name with square brackets
  • Example#1765 - Comparing the three MySQL APIs
  • Example#1766 - Configure commands for using mysqlnd or libmysqlclient
  • Example#1767 - Unbuffered query example: mysqli
  • Example#1768 - Unbuffered query example: pdo_mysql
  • Example#1769 - Unbuffered query example: mysql
  • Example#1770 - Problems with setting the character set with SQL
  • Example#1771 - Setting the character set example: mysqli
  • Example#1772 - Setting the character set example: pdo_mysql
  • Example#1773 - Setting the character set example: mysql
  • Example#1774 - Easy migration from the old mysql extension
  • Example#1775 - Object-oriented and procedural interface
  • Example#1776 - Bad coding style
  • Example#1777 - Special meaning of localhost
  • Example#1778 - Setting defaults
  • Example#1779 - Connecting to MySQL
  • Example#1780 - Navigation through buffered results
  • Example#1781 - Navigation through unbuffered results
  • Example#1782 - Text protocol returns strings by default
  • Example#1783 - Native data types with mysqlnd and connection option
  • Example#1784 - First stage: prepare
  • Example#1785 - Second stage: bind and execute
  • Example#1786 - INSERT prepared once, executed multiple times
  • Example#1787 - Less round trips using multi-INSERT SQL
  • Example#1788 - Native datatypes
  • Example#1789 - Output variable binding
  • Example#1790 - Using mysqli_result to fetch results
  • Example#1791 - Buffered result set for flexible read out
  • Example#1792 - Calling a stored procedure
  • Example#1793 - Using session variables
  • Example#1794 - Fetching results from stored procedures
  • Example#1795 - Stored Procedures and Prepared Statements
  • Example#1796 - Stored Procedures and Prepared Statements using bind API
  • Example#1797 - Multiple Statements
  • Example#1798 - SQL Injection
  • Example#1799 - Setting auto commit mode with SQL and through the API
  • Example#1800 - Commit and rollback
  • Example#1801 - Accessing result set meta data
  • Example#1802 - Prepared statements metadata
  • Example#1803 - MySQLi extension overview example
  • Example#1804 - $mysqli->affected_rows example
  • Example#1805 - mysqli::autocommit example
  • Example#1806 - $mysqli->begin_transaction example
  • Example#1807 - mysqli::change_user example
  • Example#1808 - mysqli::character_set_name example
  • Example#1809 - mysqli_get_client_info
  • Example#1810 - mysqli_get_client_version
  • Example#1811 - mysqli::commit example
  • Example#1812 - $mysqli->connect_errno example
  • Example#1813 - $mysqli->connect_error example
  • Example#1814 - mysqli::__construct example
  • Example#1815 - Generating a Trace File
  • Example#1816 - $mysqli->errno example
  • Example#1817 - $mysqli->error_list example
  • Example#1818 - $mysqli->error example
  • Example#1819 - $mysqli->field_count example
  • Example#1820 - mysqli::get_charset example
  • Example#1821 - mysqli_get_client_info
  • Example#1822 - A mysqli_get_client_stats example
  • Example#1823 - mysqli_get_client_version
  • Example#1824 - A mysqli_get_connection_stats example
  • Example#1825 - $mysqli->host_info example
  • Example#1826 - $mysqli->protocol_version example
  • Example#1827 - $mysqli->server_info example
  • Example#1828 - $mysqli->server_version example
  • Example#1829 - $mysqli->info example
  • Example#1830 - $mysqli->insert_id example
  • Example#1831 - mysqli::kill example
  • Example#1832 - mysqli::multi_query example
  • Example#1833 - mysqli::ping example
  • Example#1834 - A mysqli_poll example
  • Example#1835 - mysqli::prepare example
  • Example#1836 - mysqli::query example
  • Example#1837 - mysqli::real_connect example
  • Example#1838 - mysqli::real_escape_string example
  • Example#1839 - mysqli::rollback example
  • Example#1840 - mysqli::select_db example
  • Example#1841 - mysqli::set_charset example
  • Example#1842 - mysqli::set_local_infile_handler example
  • Example#1843 - $mysqli->sqlstate example
  • Example#1844 - mysqli::stat example
  • Example#1845 - $mysqli->thread_id example
  • Example#1846 - mysqli::use_result example
  • Example#1847 - $mysqli->warning_count example
  • Example#1848 - Nesne yönelimli kullanım
  • Example#1849 - Yordamsal kullanım
  • Example#1850 - Nesne yönelimli kullanım
  • Example#1851 - Yordamsal kullanım
  • Example#1852 - Nesne yönelimli kullanım
  • Example#1853 - Yordamsal kullanım
  • Example#1854 - Nesne yönelimli kullanım
  • Example#1855 - Yordamsal kullanım
  • Example#1856 - Nesne yönelimli kullanım
  • Example#1857 - Yordamsal kullanım
  • Example#1858 - Nesne yönelimli kullanım
  • Example#1859 - Yordamsal kullanım
  • Example#1860 - Nesne yönelimli kullanım
  • Example#1861 - Yordamsal kullanım
  • Example#1862 - Nesne yönelimli kullanım
  • Example#1863 - Yordamsal kullanım
  • Example#1864 - Nesne yönelimli kullanım
  • Example#1865 - Yordamsal kullanım
  • Example#1866 - Nesne yönelimli kullanım
  • Example#1867 - Yordamsal kullanım
  • Example#1868 - Nesne yönelimli kullanım
  • Example#1869 - Yordamsal kullanım
  • Example#1870 - Nesne yönelimli kullanım
  • Example#1871 - Yordamsal kullanım
  • Example#1872 - Nesne yönelimli kullanım
  • Example#1873 - Yordamsal kullanım
  • Example#1874 - Nesne yönelimli kullanım
  • Example#1875 - Yordamsal kullanım
  • Example#1876 - Nesne yönelimli kullanım
  • Example#1877 - Nesne yönelimli kullanım
  • Example#1878 - Yordamsal kullanım
  • Example#1879 - Nesne yönelimli kullanım
  • Example#1880 - Yordamsal kullanım
  • Example#1881 - Nesne yönelimli kullanım
  • Example#1882 - Yordamsal kullanım
  • Example#1883 - Nesne yönelimli kullanım
  • Example#1884 - Yordamsal kullanım
  • Example#1885 - Nesne yönelimli kullanım
  • Example#1886 - Yordamsal kullanım
  • Example#1887 - Nesne yönelimli kullanım
  • Example#1888 - Yordamsal kullanım
  • Example#1889 - A mysqli_result example comparing iterator usage
  • Example#1890 - Nesne yönelimli kullanım
  • Example#1891 - Yordamsal kullanım
  • Example#1892 - Nesne yönelimli kullanım
  • Example#1893 - Yordamsal kullanım
  • Example#1894 - Nesne yönelimli kullanım
  • Example#1895 - Yordamsal kullanım
  • Example#1896 - Nesne yönelimli kullanım
  • Example#1897 - Yordamsal kullanım
  • Example#1898 - Nesne yönelimli kullanım
  • Example#1899 - Yordamsal kullanım
  • Example#1900 - Nesne yönelimli kullanım
  • Example#1901 - Yordamsal kullanım
  • Example#1902 - Nesne yönelimli kullanım
  • Example#1903 - Yordamsal kullanım
  • Example#1904 - Nesne yönelimli kullanım
  • Example#1905 - Yordamsal kullanım
  • Example#1906 - Nesne yönelimli kullanım
  • Example#1907 - Yordamsal kullanım
  • Example#1908 - Nesne yönelimli kullanım
  • Example#1909 - Yordamsal kullanım
  • Example#1910 - mysqli_connect example
  • Example#1911 - - MySQL eklentisi örneği
  • Example#1912 - - mysql_affected_rows örneği
  • Example#1913 - - Hareket kullananılan mysql_affected_rows örneği
  • Example#1914 - - mysql_client_encoding örneği
  • Example#1915 - - mysql_close örneği
  • Example#1916 - - mysql_connect örneği
  • Example#1917 - - konak_adı:port sözdizimini kullanan mysql_connect örneği
  • Example#1918 - - ":/bir/yol/soket" sözdizimini kullanan mysql_connect örneği
  • Example#1919 - - mysql_create_db yerine kullanılacak kod örneği
  • Example#1920 - mysql_data_seek example
  • Example#1921 - - mysql_db_name örneği
  • Example#1922 - - mysql_db_query yerine kullanılabilecek kod örneği
  • Example#1923 - mysql_drop_db alternative example
  • Example#1924 - mysql_errno example
  • Example#1925 - mysql_error example
  • Example#1926 - mysql_escape_string example
  • Example#1927 - Query with aliased duplicate field names
  • Example#1928 - mysql_fetch_array with MYSQL_NUM
  • Example#1929 - mysql_fetch_array with MYSQL_ASSOC
  • Example#1930 - mysql_fetch_array with MYSQL_BOTH
  • Example#1931 - An expanded mysql_fetch_assoc example
  • Example#1932 - mysql_fetch_field example
  • Example#1933 - - mysql_fetch_lengths örneği
  • Example#1934 - mysql_fetch_object example
  • Example#1935 - mysql_fetch_object example
  • Example#1936 - Fetching one row with mysql_fetch_row
  • Example#1937 - A mysql_field_flags example
  • Example#1938 - - mysql_field_len örneği
  • Example#1939 - mysql_field_name example
  • Example#1940 - - mysql_field_table örneği
  • Example#1941 - mysql_field_type example
  • Example#1942 - - mysql_free_result örneği
  • Example#1943 - - mysql_get_client_info örneği
  • Example#1944 - - mysql_get_host_info örneği
  • Example#1945 - - mysql_get_proto_info örneği
  • Example#1946 - - mysql_get_server_info örneği
  • Example#1947 - - İlgili MySQL Deyimleri
  • Example#1948 - mysql_insert_id example
  • Example#1949 - - mysql_list_dbs örneği
  • Example#1950 - - mysql_list_fields yerine kullanılabilecek kod örneği
  • Example#1951 - - mysql_list_processes örneği
  • Example#1952 - - mysql_list_tables yerine kullanılabilecek kod örneği
  • Example#1953 - - mysql_num_fields örneği
  • Example#1954 - - mysql_num_rows örneği
  • Example#1955 - - mysql_ping örneği
  • Example#1956 - Invalid Query
  • Example#1957 - Valid Query
  • Example#1958 - Simple mysql_real_escape_string example
  • Example#1959 - mysql_real_escape_string requires a connection example
  • Example#1960 - An example SQL Injection Attack
  • Example#1961 - mysql_result example
  • Example#1962 - - mysql_select_db örneği
  • Example#1963 - - mysql_stat örneği
  • Example#1964 - - Bir başka mysql_stat örneği
  • Example#1965 - - mysql_tablename örneği
  • Example#1966 - - mysql_thread_id örneği
  • Example#1967 - Enabling the plugin (php.ini)
  • Example#1968 - Minimal plugin-specific configuration file (mysqlnd_ms_plugin.ini)
  • Example#1969 - Recommended minimal plugin-specific config (mysqlnd_ms_plugin.ini)
  • Example#1970 - Using one server as a master and as a slave (testing only!)
  • Example#1971 - Plugin specific configuration file (mysqlnd_ms_plugin.ini)
  • Example#1972 - Opening a load balanced connection
  • Example#1973 - Executing statements
  • Example#1974 - Plugin config with one slave and one master
  • Example#1975 - Pitfall: connection state and SQL user variables
  • Example#1976 - Plugin config with one slave and one master
  • Example#1977 - SQL hints to prevent connection switches
  • Example#1978 - Fighting replication lag
  • Example#1979 - Table creation on a slave
  • Example#1980 - Plugin config with one slave and one master
  • Example#1981 - Using SQL hints for transactions
  • Example#1982 - Transaction aware load balancing: trx_stickiness setting
  • Example#1983 - Transaction aware
  • Example#1984 - General pattern for XA transactions
  • Example#1985 - Local and global transactions are mutually exclusive
  • Example#1986 - Transaction coordinator state store
  • Example#1987 - Session consistency: read your writes
  • Example#1988 - Requesting session consistency
  • Example#1989 - Maximum age/slave lag
  • Example#1990 - Limiting slave lag
  • Example#1991 - Fail over not set
  • Example#1992 - No slave within time limit
  • Example#1993 - Create counter table on master
  • Example#1994 - Plugin config: SQL for client-side GTID injection
  • Example#1995 - Transparent global transaction ID injection
  • Example#1996 - Plugin config: SQL for fetching GTID
  • Example#1997 - Obtaining GTID after injection
  • Example#1998 - Plugin config: Checking for a certain GTID
  • Example#1999 - Session consistency service level and GTID combined
  • Example#2000 - Plugin config: using MySQL 5.6.5-m8 built-in GTID feature
  • Example#2001 - Recap: quality of service to request read your writes
  • Example#2002 - Plugin config: no special entries for caching
  • Example#2003 - Caching a slave request
  • Example#2004 - Read your writes and caching combined
  • Example#2005 - Manual failover, automatic optional
  • Example#2006 - Manual failover
  • Example#2007 - Cluster node groups
  • Example#2008 - Manual partitioning using SQL hints
  • Example#2009 - Plugin config: Fabric hosts instead of MySQL servers
  • Example#2010 - Manual partitioning using SQL hints
  • Example#2011 - Provoking a connection error
  • Example#2012 - Connection error on query execution
  • Example#2013 - Provoking a connection error
  • Example#2014 - Most basic failover
  • Example#2015 - Provoking a transient error
  • Example#2016 - Transient error retry loop
  • Example#2017 - Enabling the plugin (php.ini)
  • Example#2018 - Basic plugin configuration (mysqlnd_ms_plugin.ini) for MySQL Replication
  • Example#2019 - Multiple primaries - multi master (php.ini)
  • Example#2020 - Primary copy with multiple primaries and paritioning
  • Example#2021 - Multiple primaries - multi master (php.ini)
  • Example#2022 - Synchronous update anywhere cluster
  • Example#2023 - General pattern for XA transactions
  • Example#2024 - Converting a PHP array (hash) into JSON format
  • Example#2025 - Using section names example
  • Example#2026 - List of anonymous slaves
  • Example#2027 - Master list using symbolic names
  • Example#2028 - Keywords to configure a server
  • Example#2029 - New roundrobin filter, old functionality
  • Example#2030 - The user filter replaces mysqlnd_ms_set_user_pick_server
  • Example#2031 - Common error message in case of configuration file issues (upto version 1.5.0)
  • Example#2032 - Improved configuration file validation since 1.5.0
  • Example#2033 - Possibly more precise error due to mysqlnd_ms.force_config_usage=1
  • Example#2034 - Minimum pluging configuration for use with MySQL Fabric
  • Example#2035 - Optional timeout for communication with Fabric
  • Example#2036 - Warnings about the violation of transaction boundaries
  • Example#2037 - Invalid filter sequence
  • Example#2038 - Random load balancing with random filter
  • Example#2039 - Random once load balancing with random filter
  • Example#2040 - Referencing error
  • Example#2041 - Assigning a weight for load balancing
  • Example#2042 - roundrobin filter
  • Example#2043 - Setting a callback
  • Example#2044 - Using a callback
  • Example#2045 - Returning random masters and slaves
  • Example#2046 - Manual partitioning
  • Example#2047 - Global limit on slave lag
  • Example#2048 - Optional master failover when failing to connect to slave (PECL/mysqlnd_ms < 1.4.0)
  • Example#2049 - New syntax since 1.4.0
  • Example#2050 - Disabling lazy connection
  • Example#2051 - String escaping on a lazy connection handle
  • Example#2052 - Master on write for consistent reads
  • Example#2053 - Using master to execute transactions
  • Example#2054 - No automatic failover, error handling pitfall
  • Example#2055 - Retry loop for transient errors
  • Example#2056 - SQL definition for the MySQL state store transaction table
  • Example#2057 - SQL definition for the MySQL state store transaction table
  • Example#2058 - SQL definition for the MySQL state store garbage collection table
  • Example#2059 - Using section names example
  • Example#2060 - List-like syntax
  • Example#2061 - Verify plugin activity in a non-threaded deployment model
  • Example#2062 - Recording statistics during shutdown
  • Example#2063 - Example demonstrating the usage of mysqlnd_ms constants
  • Example#2064 - mysqlnd_ms_dump_servers example
  • Example#2065 - mysqlnd_ms_get_last_gtid example
  • Example#2066 - mysqlnd_ms_get_last_used_connection example
  • Example#2067 - mysqlnd_ms_get_stats example
  • Example#2068 - mysqlnd_ms_match_wild example
  • Example#2069 - mysqlnd_ms_query_is_select example
  • Example#2070 - mysqlnd_ms_set_qos example
  • Example#2071 - mysqlnd_ms_set_user_pick_server example
  • Example#2072 - Enabling the plugin (php.ini)
  • Example#2073 - Using the MYSQLND_QC_ENABLE_SWITCH SQL hint
  • Example#2074 - Using the MYSQLND_QC_DISABLE_SWITCH SQL hint
  • Example#2075 - Example showing which type of statements are not cached
  • Example#2076 - Enabling caching for all statements using the mysqlnd_qc.cache_no_table ini setting
  • Example#2077 - Setting the TTL with the mysqlnd_qc.ttl ini setting
  • Example#2078 - Setting TTL with SQL hints
  • Example#2079 - Setting a callback with mysqlnd_qc_set_is_select
  • Example#2080 - Enabling the slam defense mechanism
  • Example#2081 - Collecting a query trace
  • Example#2082 - Setting the backtrace depth with the mysqlnd_qc.query_trace_bt_depth ini setting
  • Example#2083 - Collecting statistics data with the mysqlnd_qc.time_statistics ini setting
  • Example#2084 - Example mysqlnd_qc_get_cache_info usage
  • Example#2085 - Example mysqlnd_qc_get_normalized_query_trace_log usage
  • Example#2086 - Using a user-defined storage handler
  • Example#2087 - Using SQL hint constants
  • Example#2088 - Example mysqlnd_qc_set_cache_condition usage
  • Example#2089 - mysqlnd_qc_get_available_handlers example
  • Example#2090 - mysqlnd_qc_get_cache_info example
  • Example#2091 - mysqlnd_qc_get_core_stats example
  • Example#2092 - mysqlnd_qc_get_normalized_query_trace_log example
  • Example#2093 - mysqlnd_qc_get_query_trace_log example
  • Example#2094 - mysqlnd_qc_set_cache_condition example
  • Example#2095 - mysqlnd_qc_set_is_select example
  • Example#2096 - mysqlnd_qc_set_storage_handler example
  • Example#2097 - Enabling the plugin (php.ini)
  • Example#2098 - Pseudo-code: what a built-in class does
  • Example#2099 - Installing a proxy
  • Example#2100 - Proxy registration, mysqlnd_uh.enable=1
  • Example#2101 - Proxy installation disabled
  • Example#2102 - Connection proxy
  • Example#2103 - Prepared statement proxy
  • Example#2104 - Basic Monitoring
  • Example#2105 - MysqlndUhConnection::changeUser example
  • Example#2106 - MysqlndUhConnection::charsetName example
  • Example#2107 - MysqlndUhConnection::close example
  • Example#2108 - MysqlndUhConnection::connect example
  • Example#2109 - MysqlndUhConnection::endPSession example
  • Example#2110 - MysqlndUhConnection::escapeString example
  • Example#2111 - MysqlndUhConnection::getAffectedRows example
  • Example#2112 - MysqlndUhConnection::getErrorNumber example
  • Example#2113 - MysqlndUhConnection::getErrorString example
  • Example#2114 - MysqlndUhConnection::getFieldCount example
  • Example#2115 - MysqlndUhConnection::getHostInformation example
  • Example#2116 - MysqlndUhConnection::getLastInsertId example
  • Example#2117 - MysqlndUhConnection::getLastMessage example
  • Example#2118 - MysqlndUhConnection::getProtocolInformation example
  • Example#2119 - MysqlndUhConnection::getServerInformation example
  • Example#2120 - MysqlndUhConnection::getServerStatistics example
  • Example#2121 - MysqlndUhConnection::getServerVersion example
  • Example#2122 - MysqlndUhConnection::getSqlstate example
  • Example#2123 - MysqlndUhConnection::getStatistics example
  • Example#2124 - MysqlndUhConnection::getThreadId example
  • Example#2125 - MysqlndUhConnection::getWarningCount example
  • Example#2126 - MysqlndUhConnection::init example
  • Example#2127 - MysqlndUhConnection::kill example
  • Example#2128 - MysqlndUhConnection::listFields example
  • Example#2129 - MysqlndUhConnection::listMethod example
  • Example#2130 - MysqlndUhConnection::moreResults example
  • Example#2131 - MysqlndUhConnection::nextResult example
  • Example#2132 - MysqlndUhConnection::ping example
  • Example#2133 - MysqlndUhConnection::query example
  • Example#2134 - MysqlndUhConnection::queryReadResultsetHeader example
  • Example#2135 - MysqlndUhConnection::reapQuery example
  • Example#2136 - MysqlndUhConnection::refreshServer example
  • Example#2137 - MysqlndUhConnection::restartPSession example
  • Example#2138 - MysqlndUhConnection::selectDb example
  • Example#2139 - MysqlndUhConnection::sendClose example
  • Example#2140 - MysqlndUhConnection::sendQuery example
  • Example#2141 - MysqlndUhConnection::serverDumpDebugInformation example
  • Example#2142 - MysqlndUhConnection::setAutocommit example
  • Example#2143 - MysqlndUhConnection::setCharset example
  • Example#2144 - MysqlndUhConnection::setClientOption example
  • Example#2145 - MysqlndUhConnection::setServerOption example
  • Example#2146 - MysqlndUhConnection::simpleCommand example
  • Example#2147 - MysqlndUhConnection::simpleCommandHandleResponse example
  • Example#2148 - MysqlndUhConnection::sslSet example
  • Example#2149 - MysqlndUhConnection::stmtInit example
  • Example#2150 - MysqlndUhConnection::storeResult example
  • Example#2151 - MysqlndUhConnection::txCommit example
  • Example#2152 - MysqlndUhConnection::txRollback example
  • Example#2153 - MysqlndUhConnection::useResult example
  • Example#2154 - MysqlndUhPreparedStatement::execute example
  • Example#2155 - MysqlndUhPreparedStatement::prepare example
  • Example#2156 - mysqlnd_uh_convert_to_mysqlnd example
  • Example#2157 - mysqlnd_uh_set_connection_proxy example
  • Example#2158 - Enabling the plugin (php.ini)
  • Example#2159 - SQL table used for the Quickstart
  • Example#2160 - Basic example.
  • Example#2161 - mysqlnd_memcache_get_config example
  • Example#2162 - mysqlnd_memcache_set example with var_dump as a simple debugging callback.
  • Example#2163 - Basic query
  • Example#2164 - Inserting with bind variables
  • Example#2165 - Binding in the WHERE clause of a query
  • Example#2166 - Inserting and fetching a CLOB
  • Example#2167 - Using a PL/SQL stored function
  • Example#2168 - Using a PL/SQL stored procedure
  • Example#2169 - Calling a PL/SQL function that returns a REF CURSOR
  • Example#2170 - user_oci8_probes.d for tracing all user-level PHP OCI8 Static Probes with DTrace
  • Example#2171 - oci_bind_array_by_name example
  • Example#2172 - Inserting data with oci_bind_by_name
  • Example#2173 - Binding once for multiple executions
  • Example#2174 - Binding with a foreach loop
  • Example#2175 - Binding in a WHERE clause
  • Example#2176 - Binding with a LIKE clause
  • Example#2177 - Binding with REGEXP_LIKE
  • Example#2178 - Binding Multiple Values in an IN Clause
  • Example#2179 - Binding a ROWID returned by a query
  • Example#2180 - Binding a ROWID on INSERT
  • Example#2181 - Binding for a PL/SQL stored function
  • Example#2182 - Binding parameters for a PL/SQL stored procedure
  • Example#2183 - Binding a CLOB column
  • Example#2184 - Binding a PL/SQL BOOLEAN
  • Example#2185 - oci_client_version example
  • Example#2186 - Closing a connection
  • Example#2187 - Database connections are not closed until all references are closed
  • Example#2188 - Closing a connection opened more than once
  • Example#2189 - Connections are closed when variables go out of scope
  • Example#2190 - oci_commit example
  • Example#2191 - Basic oci_connect using Easy Connect syntax
  • Example#2192 - Basic oci_connect using a Network Connect name
  • Example#2193 - oci_connect with an explicit character set
  • Example#2194 - Using multiple calls to oci_connect
  • Example#2195 - oci_define_by_name example
  • Example#2196 - oci_define_by_name with case sensitive column names
  • Example#2197 - oci_define_by_name with LOB columns
  • Example#2198 - oci_define_by_name with an explicit type
  • Example#2199 - Displaying the Oracle error message after a connection error
  • Example#2200 - Displaying the Oracle error message after a parsing error
  • Example#2201 - Displaying the Oracle error message, the problematic statement, and the position of the problem of an execution error
  • Example#2202 - oci_execute for queries
  • Example#2203 - oci_execute without specifying a mode example
  • Example#2204 - oci_execute with OCI_NO_AUTO_COMMIT example
  • Example#2205 - oci_execute with different commit modes example
  • Example#2206 - oci_execute with OCI_DESCRIBE_ONLY example
  • Example#2207 - oci_fetch_all example
  • Example#2208 - oci_fetch_all example with OCI_FETCHSTATEMENT_BY_ROW
  • Example#2209 - oci_fetch_all with OCI_NUM
  • Example#2210 - oci_fetch_array with OCI_BOTH
  • Example#2211 - oci_fetch_array with OCI_NUM
  • Example#2212 - oci_fetch_array with OCI_ASSOC
  • Example#2213 - oci_fetch_array with OCI_RETURN_NULLS
  • Example#2214 - oci_fetch_array with OCI_RETURN_LOBS
  • Example#2215 - oci_fetch_array with case sensitive column names
  • Example#2216 - oci_fetch_array with columns having duplicate names
  • Example#2217 - oci_fetch_array with DATE columns
  • Example#2218 - oci_fetch_array with REF CURSOR
  • Example#2219 - Pagination with oci_fetch_array using a LIMIT-like query
  • Example#2220 - oci_fetch_array with Oracle Database 12c Implicit Result Sets
  • Example#2221 - oci_fetch_assoc Example
  • Example#2222 - oci_fetch_object example
  • Example#2223 - oci_fetch_object with case sensitive column names
  • Example#2224 - oci_fetch_object with LOBs
  • Example#2225 - oci_fetch_row Example
  • Example#2226 - oci_fetch with defined variables
  • Example#2227 - oci_fetch with oci_result
  • Example#2228 - oci_field_name example
  • Example#2229 - oci_field_name example
  • Example#2230 - oci_field_precision Example
  • Example#2231 - oci_field_scale Example
  • Example#2232 - oci_field_size example
  • Example#2233 - oci_field_type_raw Example
  • Example#2234 - oci_field_type example
  • Example#2235 - Fetching Implicit Result Sets in a loop
  • Example#2236 - Getting child statement handles individually
  • Example#2237 - Explicitly setting the Prefetch Count
  • Example#2238 - Implicit Result Set example without using oci_get_implicit_resultset
  • Example#2239 - oci_new_connect example
  • Example#2240 - Binding a REF CURSOR in an Oracle stored procedure call
  • Example#2241 - oci_new_descriptor example
  • Example#2242 - oci_new_descriptor example
  • Example#2243 - oci_num_fields example
  • Example#2244 - oci_num_rows example
  • Example#2245 - oci_parse example for SQL statements
  • Example#2246 - oci_parse example for PL/SQL statements
  • Example#2247 - oci_password_change example changing the password of an already connected user
  • Example#2248 - oci_password_change example of connecting and changing the password in one step
  • Example#2249 - Basic oci_pconnect Example using Easy Connect syntax
  • Example#2250 - oci_fetch with oci_result
  • Example#2251 - oci_rollback example
  • Example#2252 - Rolling back to a SAVEPOINT example
  • Example#2253 - oci_server_version example
  • Example#2254 - Setting the action
  • Example#2255 - Setting the client identifier to the application user
  • Example#2256 - Setting the client information
  • Example#2257 - Two scripts can use different versions of myfunc() at the same time
  • Example#2258 - Setting the module name
  • Example#2259 - Changing the default prefetch value for a query
  • Example#2260 - Changing the default prefetch for a REF CURSOR fetch
  • Example#2261 - Setting the prefetch value when passing a REF CURSOR back to Oracle
  • Example#2262 - oci_statement_type example
  • Example#2263 - Creating a Paradox database with two fields
  • Example#2264 - Turn a paradox date into a human readable form
  • Example#2265 - Set the date/time fields in a paradox database to the current date/time
  • Example#2266 - Opening a Paradox database
  • Example#2267 - Opening a Paradox database
  • Example#2268 - Turn a paradox timestamp into a human readable form
  • Example#2269 - PostgreSQL extension overview example
  • Example#2270 - pg_affected_rows example
  • Example#2271 - pg_cancel_query example
  • Example#2272 - pg_client_encoding example
  • Example#2273 - pg_close example
  • Example#2274 - Using pg_connect
  • Example#2275 - pg_connection_busy example
  • Example#2276 - pg_connection_reset example
  • Example#2277 - pg_connection_status example
  • Example#2278 - pg_convert example
  • Example#2279 - pg_copy_from example
  • Example#2280 - pg_copy_to example
  • Example#2281 - pg_dbname example
  • Example#2282 - pg_delete example
  • Example#2283 - pg_end_copy example
  • Example#2284 - pg_escape_bytea example
  • Example#2285 - pg_escape_identifier example
  • Example#2286 - pg_escape_literal example
  • Example#2287 - pg_escape_string example
  • Example#2288 - Using pg_execute
  • Example#2289 - pg_fetch_all_columns example
  • Example#2290 - PostgreSQL fetch all
  • Example#2291 - pg_fetch_array example
  • Example#2292 - pg_fetch_assoc example
  • Example#2293 - pg_fetch_object example
  • Example#2294 - pg_fetch_result example
  • Example#2295 - pg_fetch_row example
  • Example#2296 - pg_field_is_null example
  • Example#2297 - Getting information about fields
  • Example#2298 - Getting information about fields
  • Example#2299 - Getting information about fields
  • Example#2300 - Getting information about fields
  • Example#2301 - Getting table information about a field
  • Example#2302 - Getting information about fields
  • Example#2303 - Getting information about fields
  • Example#2304 - pg_free_result example
  • Example#2305 - PostgreSQL NOTIFY message
  • Example#2306 - PostgreSQL backend PID
  • Example#2307 - pg_get_result example
  • Example#2308 - pg_host example
  • Example#2309 - pg_insert example
  • Example#2310 - pg_last_error example
  • Example#2311 - pg_last_notice example
  • Example#2312 - pg_last_oid example
  • Example#2313 - pg_lo_close example
  • Example#2314 - pg_lo_create example
  • Example#2315 - pg_lo_export example
  • Example#2316 - pg_lo_import example
  • Example#2317 - pg_lo_open example
  • Example#2318 - pg_lo_read_all example
  • Example#2319 - pg_lo_read example
  • Example#2320 - pg_lo_seek example
  • Example#2321 - pg_lo_tell example
  • Example#2322 - pg_lo_truncate example
  • Example#2323 - pg_lo_unlink example
  • Example#2324 - pg_lo_write example
  • Example#2325 - Getting table metadata
  • Example#2326 - pg_num_fields example
  • Example#2327 - pg_num_rows example
  • Example#2328 - pg_options example
  • Example#2329 - pg_parameter_status example
  • Example#2330 - Using pg_pconnect
  • Example#2331 - pg_ping example
  • Example#2332 - pg_port example
  • Example#2333 - Using pg_prepare
  • Example#2334 - pg_put_line example
  • Example#2335 - Using pg_query_params
  • Example#2336 - pg_query example
  • Example#2337 - Using pg_query with multiple statements
  • Example#2338 - pg_result_error_field example
  • Example#2339 - pg_result_error example
  • Example#2340 - pg_result_seek example
  • Example#2341 - pg_result_status example
  • Example#2342 - pg_select example
  • Example#2343 - Using pg_send_execute
  • Example#2344 - Using pg_send_prepare
  • Example#2345 - Using pg_send_query_params
  • Example#2346 - pg_send_query example
  • Example#2347 - pg_set_client_encoding example
  • Example#2348 - pg_set_error_verbosity example
  • Example#2349 - pg_trace example
  • Example#2350 - pg_transaction_status example
  • Example#2351 - pg_tty example
  • Example#2352 - pg_unescape_bytea example
  • Example#2353 - pg_untrace example
  • Example#2354 - pg_update example
  • Example#2355 - pg_version example
  • Example#2356 - - Yordamsal kullanım örneği
  • Example#2357 - - Nesne yönelimli kullanım örneği
  • Example#2358 - - Yordamsal kullanım örneği
  • Example#2359 - - Nesne yönelimli kullanım örneği
  • Example#2360 - - Yordamsal kullanım örneği
  • Example#2361 - - Nesne yönelimli kullanım örneği
  • Example#2362 - - sqlite_close örneği
  • Example#2363 - - azami_uzunluk işlevi örneği
  • Example#2364 - - sqlite_create_function örneği
  • Example#2365 - - php işlevi kullanım örneği
  • Example#2366 - - Yordamsal kullanım örneği
  • Example#2367 - - Nesne yönelimli kullanım örneği
  • Example#2368 - - sqlite_factory örneği
  • Example#2369 - - Yordamsal kullanım örneği
  • Example#2370 - - Nesne yönelimli kullanım örneği
  • Example#2371 - - Yordamsal kullanım örneği
  • Example#2372 - - Nesne yönelimli kullanım örneği
  • Example#2373 - - Yordamsal kullanım örneği
  • Example#2374 - - Nesne yönelimli kullanım örneği
  • Example#2375 - - sqlite_fetch_single örneği
  • Example#2376 - - Yordamsal kullanım örneği
  • Example#2377 - - Nesne yönelimli kullanım örneği
  • Example#2378 - - sqlite_open örneği
  • Example#2379 - - İkil olarak güvenli azami_uzunluk işlevi örneği
  • Example#2380 - - SQLite3::changes örneği
  • Example#2381 - - SQLite3::close örneği
  • Example#2382 - - SQLite3::__construct örneği
  • Example#2383 - SQLite3::createCollation example
  • Example#2384 - - SQLite3::createFunction örneği
  • Example#2385 - SQLite3::enableExceptions example
  • Example#2386 - - SQLite3::exec örneği
  • Example#2387 - - SQLite3::loadExtension örneği
  • Example#2388 - - SQLite3::open örneği
  • Example#2389 - SQLite3::openBlob example
  • Example#2390 - - SQLite3::prepare örneği
  • Example#2391 - - SQLite3::query örneği
  • Example#2392 - - SQLite3::querySingle örneği
  • Example#2393 - - SQLite3::version örneği
  • Example#2394 - - SQLite3Stmt::bindValue örneği
  • Example#2395 - sqlsrv_begin_transaction example
  • Example#2396 - sqlsrv_cancel example
  • Example#2397 - sqlsrv_client_info example
  • Example#2398 - sqlsrv_close example
  • Example#2399 - sqlsrv_commit example
  • Example#2400 - Connect using Windows Authentication.
  • Example#2401 - Connect by specifying a user name and password.
  • Example#2402 - Connect on a specifed port.
  • Example#2403 - functionname example
  • Example#2404 - sqlsrv_execute example
  • Example#2405 - Retrieving an associative array.
  • Example#2406 - Retrieving a numeric array.
  • Example#2407 - sqlsrv_fetch_object example
  • Example#2408 - sqlsrv_fetch example
  • Example#2409 - sqlsrv_field_metadata example
  • Example#2410 - sqlsrv_free_stmt example
  • Example#2411 - sqlsrv_get_field example
  • Example#2412 - sqlsrv_has_rows example
  • Example#2413 - sqlsrv_next_result example
  • Example#2414 - sqlsrv_num_fields example
  • Example#2415 - sqlsrv_num_rows example
  • Example#2416 - sqlsrv_prepare example
  • Example#2417 - sqlsrv_query example
  • Example#2418 - sqlsrv_rollback example
  • Example#2419 - sqlsrv_rows_affected example
  • Example#2420 - sqlsrv_send_stream_data example
  • Example#2421 - sqlsrv_server_info example
  • Example#2422 - Delete-Query
  • Example#2423 - sybase_connect example
  • Example#2424 - Identical fieldnames
  • Example#2425 - sybase_fetch_object return as Foo
  • Example#2426 - sybase_set_message_handler callback function
  • Example#2427 - sybase_set_message_handler callback to a class
  • Example#2428 - sybase_set_message_handler unhandled messages
  • Example#2429 - sybase_unbuffered_query example
  • Example#2430 - Putting and getting a key-value pair
  • Example#2431 - TokyoTyrant::add example
  • Example#2432 - TokyoTyrant::connect example
  • Example#2433 - TokyoTyrant::connectUri example
  • Example#2434 - TokyoTyrant::copy example
  • Example#2435 - TokyoTyrant::ext example
  • Example#2436 - TokyoTyrant::fwmKeys example
  • Example#2437 - TokyoTyrant::get example
  • Example#2438 - TokyoTyrant::getIterator example
  • Example#2439 - TokyoTyrant::num example
  • Example#2440 - TokyoTyrant::out example
  • Example#2441 - TokyoTyrant::put example
  • Example#2442 - TokyoTyrant::putCat example
  • Example#2443 - tokyotyrant::putKeep example
  • Example#2444 - TokyoTyrant::putNr example
  • Example#2445 - TokyoTyrant::putShl example
  • Example#2446 - TokyoTyrant::setMaster example
  • Example#2447 - TokyoTyrant::size example
  • Example#2448 - TokyoTyrant::stat example
  • Example#2449 - TokyoTyrant::vanish example
  • Example#2450 - TokyoTyrantTable::genUid example
  • Example#2451 - TokyoTyrantTable::get example
  • Example#2452 - TokyoTyrantTable::getIterator example
  • Example#2453 - TokyoTyrantTable::getQuery example
  • Example#2454 - TokyoTyrantTable::out example
  • Example#2455 - TokyoTyrantTable::put example
  • Example#2456 - TokyoTyrantTable::putCat example
  • Example#2457 - TokyoTyrantTable::putKeep example
  • Example#2458 - TokyoTyrantQuery::addCond example
  • Example#2459 - TokyoTyrantQuery::__construct example
  • Example#2460 - TokyoTyrantQuery::count example
  • Example#2461 - TokyoTyrantQuery iterator example
  • Example#2462 - TokyoTyrantQuery::hint example
  • Example#2463 - TokyoTyrantQuery iterator example
  • Example#2464 - TokyoTyrantQuery::metaSearch example
  • Example#2465 - TokyoTyrantQuery iterator example
  • Example#2466 - TokyoTyrantQuery::out example
  • Example#2467 - TokyoTyrantQuery iterator example
  • Example#2468 - TokyoTyrantQuery::search example
  • Example#2469 - TokyoTyrantQuery iterator example
  • Example#2470 - TokyoTyrantIterator::__construct example
  • Example#2471 - cal_days_in_month örneği
  • Example#2472 - cal_from_jd örneği
  • Example#2473 - cal_info örneği
  • Example#2474 - easter_date örneği
  • Example#2475 - easter_days örneği
  • Example#2476 - Takvim işlevleri örneği
  • Example#2477 - jdtojewish örneği
  • Example#2478 - DateTime::add example
  • Example#2479 - Further DateTime::add examples
  • Example#2480 - Beware when adding months
  • Example#2481 - DateTime::__construct example
  • Example#2482 - Intricacies of DateTime::__construct
  • Example#2483 - DateTime::createFromFormat example
  • Example#2484 - Intricacies of DateTime::createFromFormat
  • Example#2485 - Format string with literal characters
  • Example#2486 - DateTime::getLastErrors example
  • Example#2487 - DateTime::modify example
  • Example#2488 - Beware when adding or subtracting months
  • Example#2489 - DateTime::setDate example
  • Example#2490 - Values exceeding ranges are added to their parent values
  • Example#2491 - DateTime::setISODate example
  • Example#2492 - Values exceeding ranges are added to their parent values
  • Example#2493 - Finding the month a week is in
  • Example#2494 - DateTime::setTime example
  • Example#2495 - Values exceeding ranges are added to their parent values
  • Example#2496 - DateTime::setTimestamp example
  • Example#2497 - DateTime::setTimestamp alternative in PHP 5.2
  • Example#2498 - DateTime::setTimeZone example
  • Example#2499 - DateTime::sub example
  • Example#2500 - Further DateTime::sub examples
  • Example#2501 - Beware when subtracting months
  • Example#2502 - - DateTimeZone örneklenirken hataların yakalanması
  • Example#2503 - - DateTimeZone::getLocation örneği
  • Example#2504 - DateTimeZone::getOffset examples
  • Example#2505 - A timezone_transitions_get example
  • Example#2506 - A timezone_abbreviations_list example
  • Example#2507 - A timezone_identifiers_list example
  • Example#2508 -
  • Example#2509 - - DateInterval örneği
  • Example#2510 - - DateInterval ve büyük değerler
  • Example#2511 - - DateInterval ve DateTime::diff ile %a ve %d değiştiricileri
  • Example#2512 - DatePeriod::getDateInterval example
  • Example#2513 - DatePeriod::getEndDate example
  • Example#2514 - DatePeriod::getEndDate without an end date
  • Example#2515 - DatePeriod::getStartDate example
  • Example#2516 - - checkdate örneği
  • Example#2517 - - Öntanımlı zaman diliminin getirilmesi
  • Example#2518 - - Zaman diliminin kısaltmasının getirilmesi
  • Example#2519 - - Öntanımlı zaman dilimini almak
  • Example#2520 - date_parse_from_format example
  • Example#2521 - - date_parse örneği
  • Example#2522 - - date_sun_info örneği
  • Example#2523 - - date_sunrise örneği
  • Example#2524 - - date_sunset örneği
  • Example#2525 - - date örnekleri
  • Example#2526 - - date işlevinde önceleme karakterleri
  • Example#2527 - - date ve mktime örneği
  • Example#2528 - - date Biçemlemesi
  • Example#2529 - - getdate örneği
  • Example#2530 - - gettimeofday örneği
  • Example#2531 - - gmdate örneği
  • Example#2532 - - Windows üzerinde gmmktime işlevi
  • Example#2533 - - gmstrftime örneği
  • Example#2534 - - idate örneği
  • Example#2535 - - localtime örneği
  • Example#2536 - - microtime ile zamanlama betiği
  • Example#2537 - - PHP 5'de zamanlama betiği
  • Example#2538 - - Basit bir mktime örneği
  • Example#2539 - - mktime örneği
  • Example#2540 - - Gelecek ayın son günü
  • Example#2541 - strftime locale examples
  • Example#2542 - ISO 8601:1988 week number example
  • Example#2543 - Cross platform compatible example using the %e modifier
  • Example#2544 - Display all known and unknown formats.
  • Example#2545 - - strptime örneği
  • Example#2546 - A strtotime example
  • Example#2547 - Checking for failure
  • Example#2548 - - time örneği
  • Example#2549 - - timezone_name_from_abbr örneği
  • Example#2550 - Getting the timezonedb version
  • Example#2551 - Measure several code blocks execution and get the total
  • Example#2552 - - Açık bir dosya tanıtıcısının kapatılması
  • Example#2553 - - Bir kilidin atanması ve silinmesi
  • Example#2554 - - Bir dosya tanıtıcısının açılması
  • Example#2555 - - Bir dosyada belli bir konuma gitmek
  • Example#2556 - - Bir seri portun hızının ayarlanması
  • Example#2557 - - chdir örneği
  • Example#2558 - - closedir örneği
  • Example#2559 - dir example
  • Example#2560 - - getcwd örneği
  • Example#2561 - - opendir örneği
  • Example#2562 - - Bir dizin içeriğinin listelenmesi
  • Example#2563 - - . ve .. girdileri ayıklanarak dizin içeriğinin listelenmesi
  • Example#2564 - - Basit bir scandir örneği
  • Example#2565 - - PHP 4 için scandir örneği
  • Example#2566 - - finfo_buffer örneği
  • Example#2567 - - finfo_file örneği
  • Example#2568 - - Nesne yönelimli kullanım örneği
  • Example#2569 - - Yordamsal kullanım örneği
  • Example#2570 - mime_content_type Example
  • Example#2571 - - basename örneği
  • Example#2572 - - Bir dosyanın grubunun değiştirilmesi
  • Example#2573 - - chown örneği
  • Example#2574 - - clearstatcache örneği
  • Example#2575 - - copy örneği
  • Example#2576 - - dirname örneği
  • Example#2577 - - disk_free_space örneği
  • Example#2578 - - disk_total_space örneği
  • Example#2579 - - Basit bir fclose örneği
  • Example#2580 - - Geçersiz dosya tanıtıcılı feof örneği
  • Example#2581 - - fflush kullanarak dosyaya yazma örneği
  • Example#2582 - - fgetc örneği
  • Example#2583 - - Bir CSV dosyasının okunup basılması
  • Example#2584 - - Bir dosyanın satır satır okunması
  • Example#2585 - - Bir PHP dosyasının satır satır okunması
  • Example#2586 - - Bir dosyanın varlığının sınanması
  • Example#2587 - - Site başsayfasının kaynak kodunun çıktılanması
  • Example#2588 - - include_path içinde arama
  • Example#2589 - - Bir dosyanın belli bir bölümünün okunması
  • Example#2590 - - Akım bağlamı kullanımı
  • Example#2591 - - Basit kullanım örneği
  • Example#2592 - - Seçenek kullanımı
  • Example#2593 - - file örneği
  • Example#2594 - - fileatime örneği
  • Example#2595 - - filectime örneği
  • Example#2596 - - Bir dosyanın grubunun bulunması
  • Example#2597 - - Bir dosyanın düğüm numarasının geçerli dosya ile karşılaştırılması
  • Example#2598 - - filemtime örneği
  • Example#2599 - - Bir dosyanın sahibinin bulunması
  • Example#2600 - - İzinlerin sekizlik değer olarak gösterilmesi
  • Example#2601 - - Tüm izinlerin gösterilmesi
  • Example#2602 - - filesize örneği
  • Example#2603 - - filetype örneği
  • Example#2604 - - flock örneği
  • Example#2605 - - Bir renk isminin bir kabuk dosya kalıbıyla eşleştirilmesi
  • Example#2606 - - fopen örnekleri
  • Example#2607 - - İkil dosyalarla fpassthru kullanımı
  • Example#2608 - - fputcsv örneği
  • Example#2609 - - Basit bir fread örneği
  • Example#2610 - -İkil fread örneği
  • Example#2611 - - Uzak fread örnekleri
  • Example#2612 - - fscanf örneği
  • Example#2613 - - kişiler.txt içeriği
  • Example#2614 - - fseek örneği
  • Example#2615 - - fstat örneği
  • Example#2616 - - ftell örneği
  • Example#2617 - - Dosya boyutunu sınırlama örneği
  • Example#2618 - - Basit bir fwrite örneği
  • Example#2619 - glob işlevini opendir ve arkadaşları ile değiştirmenin uygun yolu
  • Example#2620 - - is_dir örneği
  • Example#2621 - - is_executable örneği
  • Example#2622 - - is_file örneği
  • Example#2623 - - Bir sembolik bağın oluşturulup sınanması
  • Example#2624 - - is_readable örneği
  • Example#2625 - - is_uploaded_file örneği
  • Example#2626 - - is_writable örneği
  • Example#2627 - - Bir sembolik bağın grubunun değiştirilmesi
  • Example#2628 - - Bir sembolik bağın sahibinin değiştirilmesi
  • Example#2629 - - Basit bir sabit bağ oluşturma örneği
  • Example#2630 - - linkinfo örneği
  • Example#2631 - - stat ve lstat karşılaştırması
  • Example#2632 - - mkdir örneği
  • Example#2633 - - Çok sayıda dosyanın karşıya yüklenmesi
  • Example#2634 - - misal.ini içeriği
  • Example#2635 - - parse_ini_file örneği
  • Example#2636 - - Bir php.ini dosyasının parse_ini_file ile çözümlenmesi
  • Example#2637 - - pathinfo örneği
  • Example#2638 - - pclose örneği
  • Example#2639 - - popen örneği
  • Example#2640 - - Hata döndüren popen örneği
  • Example#2641 - readfile kullanarak dosya indirmeyi zorlamak
  • Example#2642 - - readlink örneği
  • Example#2643 - realpath_cache_get example
  • Example#2644 - realpath_cache_size example
  • Example#2645 - - realpath örneği
  • Example#2646 - - Windows'ta realpath
  • Example#2647 - - renameörneği
  • Example#2648 - - rewind üste yazma örneği
  • Example#2649 - - rmdir örneği
  • Example#2650 - - stat örneği
  • Example#2651 - - stat bilgisinin touch ile birlikte kullanımı
  • Example#2652 - - Bir sembolik bağ oluşturmak
  • Example#2653 - - tempnam örneği
  • Example#2654 - - tmpfile örneği
  • Example#2655 - - touch örneği
  • Example#2656 - -touch ve zaman kullanımı
  • Example#2657 - - umask örneği
  • Example#2658 - - Basit unlink kullanımı
  • Example#2659 - Example usage of inotify
  • Example#2660 - - magic.mime dosya yolunun belirtilmesi
  • Example#2661 - setproctitle example
  • Example#2662 - setthreadtitle example
  • Example#2663 - - Yönetici dosyayı imzalamış mı diye bakmak
  • Example#2664 - - Bir dosyanın tüm özniteliklerini listelemek
  • Example#2665 - - Bir dosyanın ek özniteliklerinin tamamını silmek
  • Example#2666 - - Bir .wav dosyasında ek öznitelik tanımlamak
  • Example#2667 - - xattr_supported örneği
  • Example#2668 - - xdiff_file_bdiff_size örneği
  • Example#2669 - - xdiff_file_bdiff örneği
  • Example#2670 - - xdiff_file_bpatch örneği
  • Example#2671 - - xdiff_file_diff_binary örneği
  • Example#2672 - - xdiff_file_diff örneği
  • Example#2673 - - xdiff_file_merge3 örneği
  • Example#2674 - - xdiff_file_patch_binary örneği
  • Example#2675 - - xdiff_file_patch örneği
  • Example#2676 - - Yamayı geri alma örneği
  • Example#2677 - - xdiff_file_rabdiff örneği
  • Example#2678 - - xdiff_string_bdiff_size örneği
  • Example#2679 - - xdiff_string_diff örneği
  • Example#2680 - - xdiff_string_patch örneği
  • Example#2681 - Enchant Usage Example
  • Example#2682 - List the backends provided by the given broker
  • Example#2683 - A enchant_broker_dict_exists example
  • Example#2684 - List all available dictionaries for one broker
  • Example#2685 - A enchant_broker_request_dict example
  • Example#2686 - Adding a word to a PWL
  • Example#2687 - A enchant_dict_describe example
  • Example#2688 - A enchant_dict_quick_check example
  • Example#2689 - A enchant_dict_suggest example
  • Example#2690 - Usage example.
  • Example#2691 - Using Gender\Gender::country
  • Example#2692 - - bindtextdomain örneği
  • Example#2693 - - gettext örneği
  • Example#2694 - ngettext örneği
  • Example#2695 - - iconv_get_encoding örneği
  • Example#2696 - - iconv_mime_decode_headers örneği
  • Example#2697 - - iconv_mime_decode örneği
  • Example#2698 - - iconv_mime_encode örneği
  • Example#2699 - - iconv_set_encoding örneği
  • Example#2700 - - iconv örneği
  • Example#2701 - - ob_iconv_handler örneği
  • Example#2702 - - Yordamsal API kullanım örneği
  • Example#2703 - - Nesne yönelimli API kullanım örneği
  • Example#2704 - - FRENCH_COLLATION kuralları
  • Example#2705 - - ALTERNATE_HANDLING kuralları
  • Example#2706 - - CASE_FIRST kuralları
  • Example#2707 - - CASE_LEVEL kuralları
  • Example#2708 - - collator_asort örneği
  • Example#2709 - - collator_compare örneği
  • Example#2710 - - Collator::__construct örneği
  • Example#2711 - - collator_create örneği
  • Example#2712 - - collator_get_attribute örneği
  • Example#2713 - - collator_get_error_code örneği
  • Example#2714 - - collator_get_error_message örneği
  • Example#2715 - - collator_get_locale örneği
  • Example#2716 - collator_get_sort_keyexample
  • Example#2717 - - collator_get_strength örneği
  • Example#2718 - - collator_set_attribute örneği
  • Example#2719 - - collator_set_strength örneği
  • Example#2720 - - collator_sort_with_sort_keys örneği
  • Example#2721 - - collator_sort örneği
  • Example#2722 - - numfmt_create örneği
  • Example#2723 - - Nesne yönelimli kullanım örneği
  • Example#2724 - - numfmt_format_currency örneği
  • Example#2725 - - Nesne yönelimli kullanım örneği
  • Example#2726 - - numfmt_format örneği
  • Example#2727 - - Nesne yönelimli kullanım örneği
  • Example#2728 - - numfmt_get_attribute örneği
  • Example#2729 - - Nesne yönelimli kullanım örneği
  • Example#2730 - - numfmt_get_error_code örneği
  • Example#2731 - - Nesne yönelimli kullanım örneği
  • Example#2732 - - numfmt_get_error_message örneği
  • Example#2733 - - Nesne yönelimli kullanım örneği
  • Example#2734 - - numfmt_get_locale örneği
  • Example#2735 - - numfmt_get_pattern örneği
  • Example#2736 - - Nesne yönelimli kullanım örneği
  • Example#2737 - - numfmt_get_symbol örneği
  • Example#2738 - - Nesne yönelimli kullanım örneği
  • Example#2739 - - numfmt_get_text_attribute örneği
  • Example#2740 - - Nesne yönelimli kullanım örneği
  • Example#2741 - - numfmt_parse_currency örneği
  • Example#2742 - - Nesne yönelimli kullanım örneği
  • Example#2743 - - numfmt_parse örneği
  • Example#2744 - - Nesne yönelimli kullanım örneği
  • Example#2745 - - numfmt_set_attribute örneği
  • Example#2746 - - Nesne yönelimli kullanım örneği
  • Example#2747 - numfmt_set_pattern örneği
  • Example#2748 - - Nesne yönelimli kullanım örneği
  • Example#2749 - - numfmt_set_symbol örneği
  • Example#2750 - - Nesne yönelimli kullanım örneği
  • Example#2751 - - Yordamsal kullanım örneği
  • Example#2752 - - Nesne yönelimli kullanım örneği
  • Example#2753 - - locale_accept_from_http örneği
  • Example#2754 - - Nesne yönelimli kullanım örneği
  • Example#2755 - - locale_compose örneği
  • Example#2756 - - Nesne yönelimli kullanım örneği
  • Example#2757 - - locale_filter_matches örneği
  • Example#2758 - - Nesne yönelimli kullanım örneği
  • Example#2759 - - locale_get_all_variants örneği
  • Example#2760 - - Nesne yönelimli kullanım örneği
  • Example#2761 - - locale_get_default örneği
  • Example#2762 - - Nesne yönelimli kullanım örneği
  • Example#2763 - - locale_get_display_language örneği
  • Example#2764 - - Nesne yönelimli kullanım örneği
  • Example#2765 - - locale_get_display_name örneği
  • Example#2766 - - Nesne yönelimli kullanım örneği
  • Example#2767 - - locale_get_display_region örneği
  • Example#2768 - - Nesne yönelimli kullanım örneği
  • Example#2769 - - locale_get_display_script örneği
  • Example#2770 - - Nesne yönelimli kullanım örneği
  • Example#2771 - - locale_get_display_variant örneği
  • Example#2772 - - Nesne yönelimli kullanım örneği
  • Example#2773 - - locale_get_keywords örneği
  • Example#2774 - - Nesne yönelimli kullanım örneği
  • Example#2775 - - locale_get_primary_language örneği
  • Example#2776 - - Nesne yönelimli kullanım örneği
  • Example#2777 - - locale_get_region örneği
  • Example#2778 - - Nesne yönelimli kullanım örneği
  • Example#2779 - locale_get_script örneği
  • Example#2780 - - Nesne yönelimli kullanım örneği
  • Example#2781 - - locale_lookup örneği
  • Example#2782 - - Nesne yönelimli kullanım örneği
  • Example#2783 - - locale_parse örneği
  • Example#2784 - - Nesne yönelimli kullanım örneği
  • Example#2785 - - locale_set_default örneği
  • Example#2786 - - Nesne yönelimli kullanım örneği
  • Example#2787 - - normalizer_is_normalized örneği
  • Example#2788 - - Nesne yönelimli örnek
  • Example#2789 - - normalizer_normalize örneği
  • Example#2790 - - Nesne yönelimli örnek
  • Example#2791 - - msgfmt_create örneği
  • Example#2792 - - Nesne yönelimli örnek
  • Example#2793 - - msgfmt_format_message örneği
  • Example#2794 - - Nesne yönelimli örnek
  • Example#2795 - - msgfmt_format örneği
  • Example#2796 - - Nesne yönelimli örnek
  • Example#2797 - - msgfmt_get_error_code örneği
  • Example#2798 - - Nesne yönelimli örnek
  • Example#2799 - - msgfmt_get_error_message örneği
  • Example#2800 - - Nesne yönelimli örnek
  • Example#2801 - - msgfmt_get_locale örneği
  • Example#2802 - - Nesne yönelimli örnek
  • Example#2803 - - msgfmt_get_pattern örneği
  • Example#2804 - - Nesne yönelimli örnek
  • Example#2805 - - msgfmt_parse_message örneği
  • Example#2806 - - Nesne yönelimli örnek
  • Example#2807 - - msgfmt_parse örneği
  • Example#2808 - - Nesne yönelimli örnek
  • Example#2809 - - msgfmt_set_pattern örneği
  • Example#2810 - - Nesne yönelimli örnek
  • Example#2811 - - datefmt_create örneği
  • Example#2812 - - Nesne yönelimli kullanım örneği
  • Example#2813 - - datefmt_format örneği
  • Example#2814 - - Nesne yönelimli kullanım örneği
  • Example#2815 - IntlDateFormatter::formatObject examples
  • Example#2816 - - datefmt_get_calendar örneği
  • Example#2817 - - Nesne yönelimli kullanım örneği
  • Example#2818 - - datefmt_get_datetype örneği
  • Example#2819 - - Nesne yönelimli kullanım örneği
  • Example#2820 - - datefmt_get_error_code örneği
  • Example#2821 - - Nesne yönelimli kullanım örneği
  • Example#2822 - - datefmt_get_error_message örneği
  • Example#2823 - - Nesne yönelimli kullanım örneği
  • Example#2824 - - datefmt_get_locale örneği
  • Example#2825 - - Nesne yönelimli kullanım örneği
  • Example#2826 - - datefmt_get_pattern örneği
  • Example#2827 - - Nesne yönelimli kullanım örneği
  • Example#2828 - - datefmt_get_timetype örneği
  • Example#2829 - - Nesne yönelimli kullanım örneği
  • Example#2830 - - datefmt_get_timezone_id örneği
  • Example#2831 - - Nesne yönelimli kullanım örneği
  • Example#2832 - IntlDateFormatter::getCalendarObject example
  • Example#2833 - IntlDateFormatter::getTimeZone examples
  • Example#2834 - - datefmt_is_lenient örneği
  • Example#2835 - - Nesne yönelimli kullanım örneği
  • Example#2836 - - datefmt_localtime örneği
  • Example#2837 - - Nesne yönelimli kullanım örneği
  • Example#2838 - - datefmt_parse örneği
  • Example#2839 - - Nesne yönelimli kullanım örneği
  • Example#2840 - - datefmt_set_calendar örneği
  • Example#2841 - - Nesne yönelimli kullanım örneği
  • Example#2842 - - datefmt_set_lenient örneği
  • Example#2843 - - Nesne yönelimli kullanım örneği
  • Example#2844 - - datefmt_set_pattern örneği
  • Example#2845 - - Nesne yönelimli kullanım örneği
  • Example#2846 - - datefmt_set_timezone_id örneği
  • Example#2847 - - Nesne yönelimli kullanım örneği
  • Example#2848 - IntlDateFormatter::setTimeZone examples
  • Example#2849 - - grapheme_extract örneği
  • Example#2850 - - grapheme_stripos örneği
  • Example#2851 - - grapheme_stristr örneği
  • Example#2852 - - grapheme_strlen örneği
  • Example#2853 - - grapheme_strpos örneği
  • Example#2854 - - grapheme_strripos örneği
  • Example#2855 - - grapheme_strrpos örneği
  • Example#2856 - - grapheme_strstr örneği
  • Example#2857 - - grapheme_substr örneği
  • Example#2858 - - idn_to_ascii örneği
  • Example#2859 - - idn_to_utf8 örneği
  • Example#2860 - - intl_error_name örneği
  • Example#2861 - - intl_get_error_code örneği
  • Example#2862 - - intl_get_error_message örneği
  • Example#2863 - - intl_is_failure örneği
  • Example#2864 - - php.ini ayar örnekleri
  • Example#2865 - - EUC-JP kullanıcıları için php.ini ayarları
  • Example#2866 - - SJIS kullanıcıları için php.ini ayarları
  • Example#2867 - - HTTP girdi dönüşümünün php.ini'de kapatılması
  • Example#2868 - - php.ini ayarları örneği
  • Example#2869 - - Betik örneği
  • Example#2870 - - mb_convert_case örneği
  • Example#2871 - - mb_convert_encoding örneği
  • Example#2872 - - mb_convert_kana örneği
  • Example#2873 - - mb_convert_variables örneği
  • Example#2874 - - bölge örneği
  • Example#2875 - - mb_detect_encoding örneği
  • Example#2876 - - Kullanışsız algı sırası örneği
  • Example#2877 - - mb_detect_order örnekleri
  • Example#2878 - - mb_encode_mimeheader örneği
  • Example#2879 - - bölge örneği
  • Example#2880 - - mb_encode_numericentity örneği
  • Example#2881 - mb_encoding_aliases example
  • Example#2882 - mb_ereg_replace_callback example
  • Example#2883 - mb_ereg_replace_callback using anonymous function supported in PHP 5.3.0 or later
  • Example#2884 - - mb_internal_encoding örneği
  • Example#2885 - - mb_list_encodings örneği
  • Example#2886 - - mb_output_handler örneği
  • Example#2887 - - mb_preferred_mime_name örneği
  • Example#2888 - - mb_strimwidth örneği
  • Example#2889 - - mb_strtolower örneği
  • Example#2890 - - mb_strtoupper örneği
  • Example#2891 - - mb_substitute_character örneği
  • Example#2892 - - mb_substr_count örneği
  • Example#2893 - pspell_add_to_personal
  • Example#2894 - pspell_check Example
  • Example#2895 - pspell_add_to_personal Example
  • Example#2896 - pspell_config_create
  • Example#2897 - pspell_config_ignore
  • Example#2898 - pspell_config_mode Example
  • Example#2899 - pspell_config_personal
  • Example#2900 - pspell_config_repl
  • Example#2901 - pspell_config_runtogether
  • Example#2902 - pspell_new_config
  • Example#2903 - pspell_new_personal
  • Example#2904 - pspell_new
  • Example#2905 - pspell_add_to_personal
  • Example#2906 - pspell_store_replacement
  • Example#2907 - pspell_suggest example
  • Example#2908 - - Basit bir recode_file örneği
  • Example#2909 - - Basit bir recode_string örneği
  • Example#2910 - Cairo Example
  • Example#2911 - cairo_create example
  • Example#2912 - cairo_font_face_get_type example
  • Example#2913 - cairo_font_face_status example
  • Example#2914 - cairo_font_options_create example
  • Example#2915 - cairo_font_options_equal example
  • Example#2916 - cairo_font_options_get_antialias example
  • Example#2917 - cairo_font_options_get_hint_metrics example
  • Example#2918 - cairo_font_options_get_hint_style example
  • Example#2919 - cairo_font_options_get_subpixel_order example
  • Example#2920 - cairo_font_options_hash example
  • Example#2921 - cairo_font_options_merge example
  • Example#2922 - cairo_font_options_set_antialias example
  • Example#2923 - cairo_font_options_set_hint_metrics example
  • Example#2924 - cairo_font_options_set_hint_style example
  • Example#2925 - cairo_font_options_set_subpixel_order example
  • Example#2926 - cairo_font_options_status example
  • Example#2927 - cairo_format_stride_for_width example
  • Example#2928 - cairo_image_surface_create_for_data example
  • Example#2929 - cairo_image_surface_create_from_png example
  • Example#2930 - cairo_image_surface_create example
  • Example#2931 - cairo_image_surface_get_data example
  • Example#2932 - cairo_image_surface_get_format example
  • Example#2933 - cairo_image_surface_get_height example
  • Example#2934 - cairo_image_surface_get_stride example
  • Example#2935 - cairo_image_surface_get_width example
  • Example#2936 - cairo_matrix_invert example
  • Example#2937 - cairo_matrix_multiply example
  • Example#2938 - cairo_matrix_rotate example
  • Example#2939 - cairo_matrix_transform_distance example
  • Example#2940 - cairo_matrix_transform_point example
  • Example#2941 - cairo_matrix_translate example
  • Example#2942 - cairo_pattern_add_color_stop_rgb example
  • Example#2943 - cairo_pattern_add_color_stop_rgba example
  • Example#2944 - cairo_pattern_create_for_surface example
  • Example#2945 - cairo_pattern_create_linear example
  • Example#2946 - cairo_pattern_create_radial example
  • Example#2947 - cairo_pattern_create_rgb example
  • Example#2948 - cairo_pattern_create_rgba example
  • Example#2949 - cairo_pattern_get_color_stop_count example
  • Example#2950 - cairo_pattern_get_color_stop_rgba example
  • Example#2951 - cairo_pattern_get_extend example
  • Example#2952 - cairo_pattern_get_filter example
  • Example#2953 - cairo_pattern_get_linear_points example
  • Example#2954 - cairo_pattern_get_matrix example
  • Example#2955 - cairo_pattern_get_radial_circles example
  • Example#2956 - cairo_pattern_get_rgba example
  • Example#2957 - cairo_pattern_get_surface example
  • Example#2958 - cairo_pattern_get_type example
  • Example#2959 - cairo_pattern_set_extend example
  • Example#2960 - cairo_pattern_set_filter example
  • Example#2961 - cairo_pattern_set_matrix example
  • Example#2962 - cairo_pattern_status example
  • Example#2963 - cairo_pdf_surface_create example
  • Example#2964 - cairo_pdf_surface_set_size example
  • Example#2965 - cairo_ps_get_levels example
  • Example#2966 - cairo_ps_level_to_string example
  • Example#2967 - cairo_ps_surface_create example
  • Example#2968 - cairo_ps_surface_dsc_begin_page_setup example
  • Example#2969 - cairo_ps_surface_dsc_begin_setup example
  • Example#2970 - cairo_ps_surface_dsc_comment example
  • Example#2971 - cairo_ps_surface_get_eps example
  • Example#2972 - cairo_ps_surface_restrict_to_level example
  • Example#2973 - cairo_ps_surface_set_eps example
  • Example#2974 - cairo_ps_surface_set_size example
  • Example#2975 - cairo_scaled_font_create example
  • Example#2976 - cairo_scaled_font_extents example
  • Example#2977 - cairo_scaled_font_get_ctm example
  • Example#2978 - cairo_scaled_font_get_font_face example
  • Example#2979 - cairo_scaled_font_get_font_matrix example
  • Example#2980 - cairo_scaled_font_get_font_options example
  • Example#2981 - cairo_scaled_font_get_scale_matrix example
  • Example#2982 - cairo_scaled_font_get_type example
  • Example#2983 - cairo_scaled_font_glyph_extents example
  • Example#2984 - cairo_scaled_font_status example
  • Example#2985 - cairo_scaled_font_text_extents example
  • Example#2986 - cairo_surface_copy_page example
  • Example#2987 - cairo_surface_create_similar example
  • Example#2988 - cairo_surface_finish example
  • Example#2989 - cairo_surface_flush example
  • Example#2990 - cairo_surface_get_content example
  • Example#2991 - cairo_surface_get_device_offset example
  • Example#2992 - cairo_surface_get_font_options example
  • Example#2993 - cairo_surface_get_type example
  • Example#2994 - cairo_surface_mark_dirty_rectangle example
  • Example#2995 - cairo_surface_mark_dirty example
  • Example#2996 - cairo_surface_set_device_offset example
  • Example#2997 - cairo_surface_set_fallback_resolution example
  • Example#2998 - cairo_surface_show_page example
  • Example#2999 - cairo_surface_status example
  • Example#3000 - cairo_surface_write_to_png example
  • Example#3001 - cairo_svg_surface_create example
  • Example#3002 - cairo_svg_surface_restrict_to_version example
  • Example#3003 - cairo_svg_version_to_string example
  • Example#3004 - Nesne yönelimli kullanım
  • Example#3005 - Yordamsal kullanım
  • Example#3006 - Nesne yönelimli kullanım
  • Example#3007 - Yordamsal kullanım
  • Example#3008 - Nesne yönelimli kullanım
  • Example#3009 - Yordamsal kullanım
  • Example#3010 - Nesne yönelimli kullanım
  • Example#3011 - Yordamsal kullanım
  • Example#3012 - Nesne yönelimli kullanım
  • Example#3013 - Yordamsal kullanım
  • Example#3014 - Nesne yönelimli kullanım
  • Example#3015 - Yordamsal kullanım
  • Example#3016 - Nesne yönelimli kullanım
  • Example#3017 - Yordamsal kullanım
  • Example#3018 - Nesne yönelimli kullanım
  • Example#3019 - Yordamsal kullanım
  • Example#3020 - Nesne yönelimli kullanım
  • Example#3021 - Yordamsal kullanım
  • Example#3022 - Nesne yönelimli kullanım
  • Example#3023 - Yordamsal kullanım
  • Example#3024 - Nesne yönelimli kullanım
  • Example#3025 - Yordamsal kullanım
  • Example#3026 - Nesne yönelimli kullanım
  • Example#3027 - Yordamsal kullanım
  • Example#3028 - Nesne yönelimli kullanım
  • Example#3029 - Yordamsal kullanım
  • Example#3030 - CairoContext::__construct example
  • Example#3031 - Nesne yönelimli kullanım
  • Example#3032 - Yordamsal kullanım
  • Example#3033 - Nesne yönelimli kullanım
  • Example#3034 - Yordamsal kullanım
  • Example#3035 - Nesne yönelimli kullanım
  • Example#3036 - Yordamsal kullanım
  • Example#3037 - Nesne yönelimli kullanım
  • Example#3038 - Yordamsal kullanım
  • Example#3039 - Nesne yönelimli kullanım
  • Example#3040 - Yordamsal kullanım
  • Example#3041 - Nesne yönelimli kullanım
  • Example#3042 - Yordamsal kullanım
  • Example#3043 - Nesne yönelimli kullanım
  • Example#3044 - Yordamsal kullanım
  • Example#3045 - Nesne yönelimli kullanım
  • Example#3046 - Yordamsal kullanım
  • Example#3047 - Nesne yönelimli kullanım
  • Example#3048 - Yordamsal kullanım
  • Example#3049 - Nesne yönelimli kullanım
  • Example#3050 - Yordamsal kullanım
  • Example#3051 - Nesne yönelimli kullanım
  • Example#3052 - Yordamsal kullanım
  • Example#3053 - Nesne yönelimli kullanım
  • Example#3054 - Yordamsal kullanım
  • Example#3055 - Nesne yönelimli kullanım
  • Example#3056 - Yordamsal kullanım
  • Example#3057 - Nesne yönelimli kullanım
  • Example#3058 - Yordamsal kullanım
  • Example#3059 - Nesne yönelimli kullanım
  • Example#3060 - Yordamsal kullanım
  • Example#3061 - Nesne yönelimli kullanım
  • Example#3062 - Yordamsal kullanım
  • Example#3063 - Nesne yönelimli kullanım
  • Example#3064 - Yordamsal kullanım
  • Example#3065 - Nesne yönelimli kullanım
  • Example#3066 - Yordamsal kullanım
  • Example#3067 - Nesne yönelimli kullanım
  • Example#3068 - Yordamsal kullanım
  • Example#3069 - Nesne yönelimli kullanım
  • Example#3070 - Yordamsal kullanım
  • Example#3071 - Nesne yönelimli kullanım
  • Example#3072 - Yordamsal kullanım
  • Example#3073 - Nesne yönelimli kullanım
  • Example#3074 - Yordamsal kullanım
  • Example#3075 - Nesne yönelimli kullanım
  • Example#3076 - Yordamsal kullanım
  • Example#3077 - Nesne yönelimli kullanım
  • Example#3078 - Yordamsal kullanım
  • Example#3079 - Nesne yönelimli kullanım
  • Example#3080 - Yordamsal kullanım
  • Example#3081 - Nesne yönelimli kullanım
  • Example#3082 - Yordamsal kullanım
  • Example#3083 - Nesne yönelimli kullanım
  • Example#3084 - Yordamsal kullanım
  • Example#3085 - Nesne yönelimli kullanım
  • Example#3086 - Yordamsal kullanım
  • Example#3087 - Nesne yönelimli kullanım
  • Example#3088 - Yordamsal kullanım
  • Example#3089 - Nesne yönelimli kullanım
  • Example#3090 - Yordamsal kullanım
  • Example#3091 - Nesne yönelimli kullanım
  • Example#3092 - Yordamsal kullanım
  • Example#3093 - Nesne yönelimli kullanım
  • Example#3094 - Yordamsal kullanım
  • Example#3095 - Nesne yönelimli kullanım
  • Example#3096 - Yordamsal kullanım
  • Example#3097 - Nesne yönelimli kullanım
  • Example#3098 - Yordamsal kullanım
  • Example#3099 - Nesne yönelimli kullanım
  • Example#3100 - Yordamsal kullanım
  • Example#3101 - Nesne yönelimli kullanım
  • Example#3102 - Yordamsal kullanım
  • Example#3103 - Nesne yönelimli kullanım
  • Example#3104 - Yordamsal kullanım
  • Example#3105 - Nesne yönelimli kullanım
  • Example#3106 - Yordamsal kullanım
  • Example#3107 - Nesne yönelimli kullanım
  • Example#3108 - Yordamsal kullanım
  • Example#3109 - Nesne yönelimli kullanım
  • Example#3110 - Yordamsal kullanım
  • Example#3111 - Nesne yönelimli kullanım
  • Example#3112 - Yordamsal kullanım
  • Example#3113 - Nesne yönelimli kullanım
  • Example#3114 - Yordamsal kullanım
  • Example#3115 - Nesne yönelimli kullanım
  • Example#3116 - Yordamsal kullanım
  • Example#3117 - Nesne yönelimli kullanım
  • Example#3118 - Yordamsal kullanım
  • Example#3119 - Nesne yönelimli kullanım
  • Example#3120 - Yordamsal kullanım
  • Example#3121 - Nesne yönelimli kullanım
  • Example#3122 - Yordamsal kullanım
  • Example#3123 - Nesne yönelimli kullanım
  • Example#3124 - Yordamsal kullanım
  • Example#3125 - Nesne yönelimli kullanım
  • Example#3126 - Yordamsal kullanım
  • Example#3127 - Nesne yönelimli kullanım
  • Example#3128 - Yordamsal kullanım
  • Example#3129 - Nesne yönelimli kullanım
  • Example#3130 - Yordamsal kullanım
  • Example#3131 - Nesne yönelimli kullanım
  • Example#3132 - Yordamsal kullanım
  • Example#3133 - Nesne yönelimli kullanım
  • Example#3134 - Yordamsal kullanım
  • Example#3135 - Nesne yönelimli kullanım
  • Example#3136 - Yordamsal kullanım
  • Example#3137 - Nesne yönelimli kullanım
  • Example#3138 - Yordamsal kullanım
  • Example#3139 - Nesne yönelimli kullanım
  • Example#3140 - Yordamsal kullanım
  • Example#3141 - Nesne yönelimli kullanım
  • Example#3142 - Yordamsal kullanım
  • Example#3143 - Nesne yönelimli kullanım
  • Example#3144 - Yordamsal kullanım
  • Example#3145 - Nesne yönelimli kullanım
  • Example#3146 - Yordamsal kullanım
  • Example#3147 - Nesne yönelimli kullanım
  • Example#3148 - Yordamsal kullanım
  • Example#3149 - Nesne yönelimli kullanım
  • Example#3150 - Yordamsal kullanım
  • Example#3151 - Nesne yönelimli kullanım
  • Example#3152 - Yordamsal kullanım
  • Example#3153 - Nesne yönelimli kullanım
  • Example#3154 - Yordamsal kullanım
  • Example#3155 - Nesne yönelimli kullanım
  • Example#3156 - Yordamsal kullanım
  • Example#3157 - Nesne yönelimli kullanım
  • Example#3158 - Yordamsal kullanım
  • Example#3159 - Nesne yönelimli kullanım
  • Example#3160 - Yordamsal kullanım
  • Example#3161 - Nesne yönelimli kullanım
  • Example#3162 - Yordamsal kullanım
  • Example#3163 - Nesne yönelimli kullanım
  • Example#3164 - Yordamsal kullanım
  • Example#3165 - Nesne yönelimli kullanım
  • Example#3166 - Yordamsal kullanım
  • Example#3167 - Nesne yönelimli kullanım
  • Example#3168 - Yordamsal kullanım
  • Example#3169 - Nesne yönelimli kullanım
  • Example#3170 - Yordamsal kullanım
  • Example#3171 - Nesne yönelimli kullanım
  • Example#3172 - Yordamsal kullanım
  • Example#3173 - Nesne yönelimli kullanım
  • Example#3174 - Yordamsal kullanım
  • Example#3175 - Nesne yönelimli kullanım
  • Example#3176 - Yordamsal kullanım
  • Example#3177 - Nesne yönelimli kullanım
  • Example#3178 - Yordamsal kullanım
  • Example#3179 - Nesne yönelimli kullanım
  • Example#3180 - Yordamsal kullanım
  • Example#3181 - Nesne yönelimli kullanım
  • Example#3182 - Yordamsal kullanım
  • Example#3183 - Nesne yönelimli kullanım
  • Example#3184 - Yordamsal kullanım
  • Example#3185 - Nesne yönelimli kullanım
  • Example#3186 - Yordamsal kullanım
  • Example#3187 - Nesne yönelimli kullanım
  • Example#3188 - Yordamsal kullanım
  • Example#3189 - Nesne yönelimli kullanım
  • Example#3190 - Yordamsal kullanım
  • Example#3191 - Nesne yönelimli kullanım
  • Example#3192 - Yordamsal kullanım
  • Example#3193 - Nesne yönelimli kullanım
  • Example#3194 - Yordamsal kullanım
  • Example#3195 - Nesne yönelimli kullanım
  • Example#3196 - Yordamsal kullanım
  • Example#3197 - Nesne yönelimli kullanım
  • Example#3198 - Yordamsal kullanım
  • Example#3199 - Nesne yönelimli kullanım
  • Example#3200 - Yordamsal kullanım
  • Example#3201 - Nesne yönelimli kullanım
  • Example#3202 - Yordamsal kullanım
  • Example#3203 - Nesne yönelimli kullanım
  • Example#3204 - Yordamsal kullanım
  • Example#3205 - CairoSurface::createSimilar example
  • Example#3206 - CairoSurface::finish example
  • Example#3207 - CairoSurface::flush example
  • Example#3208 - CairoSurface::getContent example
  • Example#3209 - CairoSurface::getDeviceOffset example
  • Example#3210 - Nesne yönelimli kullanım
  • Example#3211 - Yordamsal kullanım
  • Example#3212 - CairoSurface::getType example
  • Example#3213 - CairoSurface::markDirty example
  • Example#3214 - CairoSurface::markDirtyRectangle example
  • Example#3215 - CairoSurface::setDeviceOffset example
  • Example#3216 - CairoSurface::setFallbackResolution example
  • Example#3217 - Nesne yönelimli kullanım
  • Example#3218 - Yordamsal kullanım
  • Example#3219 - Nesne yönelimli kullanım
  • Example#3220 - Yordamsal kullanım
  • Example#3221 - CairoSurface::writeToPng example
  • Example#3222 - CairoSvgSurface::__construct example
  • Example#3223 - CairoSvgSurface::getVersions example
  • Example#3224 - Yordamsal kullanım
  • Example#3225 - CairoSvgSurface::restrictToVersion example
  • Example#3226 - CairoSvgSurface::versionToString example
  • Example#3227 - CairoImageSurface::__construct example
  • Example#3228 - CairoImageSurface::createForData example
  • Example#3229 - CairoImageSurface::createFromPng example
  • Example#3230 - CairoImageSurface::getData example
  • Example#3231 - CairoImageSurface::getFormat example
  • Example#3232 - CairoImageSurface::getHeight example
  • Example#3233 - CairoImageSurface::getStride example
  • Example#3234 - CairoImageSurface::getWidth example
  • Example#3235 - CairoPdfSurface::__construct example
  • Example#3236 - CairoPdfSurface::setSize example
  • Example#3237 - CairoPsSurface::__construct example
  • Example#3238 - CairoPsSurface::dscBeginPageSetup example
  • Example#3239 - CairoPsSurface::dscBeginSetup example
  • Example#3240 - CairoPsSurface::dscComment example
  • Example#3241 - CairoPsSurface::getEps example
  • Example#3242 - CairoPsSurface::getLevels example
  • Example#3243 - CairoPsSurface::levelToString example
  • Example#3244 - CairoPsSurface::restrictToLevel example
  • Example#3245 - CairoPsSurface::setEps example
  • Example#3246 - CairoPsSurface::setSize example
  • Example#3247 - CairoFontFace::__construct example
  • Example#3248 - CairoFontFace::getType example
  • Example#3249 - Nesne yönelimli kullanım
  • Example#3250 - Yordamsal kullanım
  • Example#3251 - CairoFontOptions::__construct example
  • Example#3252 - CairoFontOptions::equal example
  • Example#3253 - Nesne yönelimli kullanım
  • Example#3254 - Yordamsal kullanım
  • Example#3255 - CairoFontOptions::getHintMetrics example
  • Example#3256 - CairoFontOptions::getHintStyle example
  • Example#3257 - CairoFontOptions::getSubpixelOrder example
  • Example#3258 - CairoFontOptions::hash example
  • Example#3259 - CairoFontOptions::merge example
  • Example#3260 - Nesne yönelimli kullanım
  • Example#3261 - Yordamsal kullanım
  • Example#3262 - CairoFontOptions::setHintMetrics example
  • Example#3263 - CairoFontOptions::setHintStyle example
  • Example#3264 - CairoFontOptions::setSubpixelOrder example
  • Example#3265 - Nesne yönelimli kullanım
  • Example#3266 - Yordamsal kullanım
  • Example#3267 - CairoScaledFont::__construct example
  • Example#3268 - CairoScaledFont::extents example
  • Example#3269 - CairoScaledFont::getCtm example
  • Example#3270 - Nesne yönelimli kullanım
  • Example#3271 - Yordamsal kullanım
  • Example#3272 - Nesne yönelimli kullanım
  • Example#3273 - Yordamsal kullanım
  • Example#3274 - Nesne yönelimli kullanım
  • Example#3275 - Yordamsal kullanım
  • Example#3276 - CairoScaledFont::getScaleMatrix example
  • Example#3277 - CairoScaledFont::getType example
  • Example#3278 - CairoScaledFont::glyphExtents example
  • Example#3279 - Nesne yönelimli kullanım
  • Example#3280 - Yordamsal kullanım
  • Example#3281 - Nesne yönelimli kullanım
  • Example#3282 - Yordamsal kullanım
  • Example#3283 - CairoPattern::__construct example
  • Example#3284 - Nesne yönelimli kullanım
  • Example#3285 - Yordamsal kullanım
  • Example#3286 - CairoPattern::getType example
  • Example#3287 - Nesne yönelimli kullanım
  • Example#3288 - Yordamsal kullanım
  • Example#3289 - Nesne yönelimli kullanım
  • Example#3290 - Yordamsal kullanım
  • Example#3291 - CairoGradientPattern::addColorStopRgb example
  • Example#3292 - CairoGradientPattern::addColorStopRgba example
  • Example#3293 - CairoGradientPattern::getColorStopCount example
  • Example#3294 - CairoGradientPattern::getColorStopRgba example
  • Example#3295 - CairoGradientPattern::getExtend example
  • Example#3296 - CairoGradientPattern::setExtend example
  • Example#3297 - CairoSolidPattern::__construct example
  • Example#3298 - CairoSolidPattern::getRgba example
  • Example#3299 - CairoSurfacePattern::__construct example
  • Example#3300 - CairoSurfacePattern::getExtend example
  • Example#3301 - CairoSurfacePattern::getFilter example
  • Example#3302 - CairoSurfacePattern::getSurface example
  • Example#3303 - CairoSurfacePattern::setExtend example
  • Example#3304 - CairoSurfacePattern::setFilter example
  • Example#3305 - CairoLinearGradient::__construct example
  • Example#3306 - CairoLinearGradient::getPoints example
  • Example#3307 - CairoRadialGradient::__construct example
  • Example#3308 - CairoRadialGradient::getCircles example
  • Example#3309 - CairoFormat::strideForWidth example
  • Example#3310 - Nesne yönelimli kullanım
  • Example#3311 - Yordamsal kullanım
  • Example#3312 - Nesne yönelimli kullanım
  • Example#3313 - Yordamsal kullanım
  • Example#3314 - Nesne yönelimli kullanım
  • Example#3315 - Yordamsal kullanım
  • Example#3316 - Nesne yönelimli kullanım
  • Example#3317 - Yordamsal kullanım
  • Example#3318 - Nesne yönelimli kullanım
  • Example#3319 - Yordamsal kullanım
  • Example#3320 - CairoMatrix::invert example
  • Example#3321 - CairoMatrix::multiply example
  • Example#3322 - Nesne yönelimli kullanım
  • Example#3323 - Yordamsal kullanım
  • Example#3324 - Nesne yönelimli kullanım
  • Example#3325 - Yordamsal kullanım
  • Example#3326 - CairoMatrix::transformDistance example
  • Example#3327 - CairoMatrix::transformPoint example
  • Example#3328 - Nesne yönelimli kullanım
  • Example#3329 - Yordamsal kullanım
  • Example#3330 - - exif_imagetype örneği
  • Example#3331 - - exif_read_data örneği
  • Example#3332 - - exif_thumbnail örneği
  • Example#3333 - PHP ile PNG oluşturmak
  • Example#3334 - Alfa kanallarını kullanarak resme damga basmak
  • Example#3335 - imagecopymerge kullanarak yarı geçirgen filigran oluşturmak
  • Example#3336 - gd_info kullanımı
  • Example#3337 - - getimagesize ve MIME türleri
  • Example#3338 - - >getimagesize dosya örneği
  • Example#3339 - - getimagesize (URL)
  • Example#3340 - - IPTC döndüren getimagesize() örneği
  • Example#3341 - getimagesizefromstring example
  • Example#3342 - - image_type_to_extension örneği
  • Example#3343 - - image_type_to_mime_type örneği
  • Example#3344 - - image2wbmp örneği
  • Example#3345 - imageaffinematrixconcat example
  • Example#3346 - imageaffinematrixget example
  • Example#3347 - - imagealphablending örneği
  • Example#3348 - - Kenar yumuşatmalı çizginin normal çizgiyle karşılaştırılması
  • Example#3349 - - imagearc ile çember çizmek
  • Example#3350 - Saving a BMP file
  • Example#3351 - - imagechar örneği
  • Example#3352 - - imagecharup örneği
  • Example#3353 - - imagecolorallocate örneği
  • Example#3354 - - imagecolorallocatealpha örneği
  • Example#3355 - - Hesapla RGB değeri bileşenlerine ayırmak
  • Example#3356 - - imagecolorsforindex ile RGB değeri bileşenlerine ayırmak
  • Example#3357 - - Bir resimde renk aramak
  • Example#3358 - - Bir resimde renk aramak
  • Example#3359 - - imagecolorclosesthwb örneği
  • Example#3360 - - imagecolordeallocate örneği
  • Example#3361 - - GD logosunun renklerini öğrenelim
  • Example#3362 - - GD logosunun renklerini öğrenelim
  • Example#3363 - - imagecolormatch örneği
  • Example#3364 - - Bir resimdeki renkleri öğrenmek için imagecoloresolve kullanımı
  • Example#3365 - - Bir resimdeki renkleri öğrenmek için imagecolorresolvealpha kullanımı
  • Example#3366 - - imagecolorset örneği
  • Example#3367 - - imagecolorsforindex örneği
  • Example#3368 - - imagecolorstotal örneği
  • Example#3369 - - imagecolortransparent örneği
  • Example#3370 - - PHP.net logosuna kabartma etkisi vermek
  • Example#3371 - - Gauss bulanıklığı
  • Example#3372 - - PHP.net logosunun kırpılması
  • Example#3373 - - PHP.net logo'sunun iki kopyasının %75 şeffaflıkla karıştırılması
  • Example#3374 - - imagecopymergegray örneği
  • Example#3375 - - Basit örnek
  • Example#3376 - - Bir resmin orantılı olarak örneklenmesi
  • Example#3377 - - Bir remin boyutlandırılması
  • Example#3378 - - Yeni bir GD resim akımı oluşturup bir resim çıktılamak
  • Example#3379 - Convert an BMP image to a PNG image using imagecreatefrombmp
  • Example#3380 - - imagecreatefromgd2 örneği
  • Example#3381 - - imagecreatefromgd2part örneği
  • Example#3382 - - imagecreatefromgd örneği
  • Example#3383 - - Bir GIF yüklerken oluşan bir hatanın ele alınması
  • Example#3384 - - Bir JPEG yüklerken oluşan bir hatanın ele alınması
  • Example#3385 - - Bir PNG yüklerken oluşan bir hatanın ele alınması
  • Example#3386 - - imagecreatefromstring örneği
  • Example#3387 - - Bir WBMP yüklerken oluşan bir hatanın ele alınması
  • Example#3388 - Convert an WebP image to a jpeg image using imagecreatefromwebp
  • Example#3389 - - imagecreatefromxbm örneği
  • Example#3390 - - imagecreatefromxpm örneği
  • Example#3391 - Yeni bir GD2 resim akımı oluşturup bir resim çıktılamak
  • Example#3392 - imagecrop example
  • Example#3393 - Proper handling of auto-cropping
  • Example#3394 - - imagedashedline örneği
  • Example#3395 - - Başka bir imagedashedline örneği
  • Example#3396 - - imagedestroy örneği
  • Example#3397 - - imageellipse örneği
  • Example#3398 - - imagefill örneği
  • Example#3399 - - 3 boyutlu bir pasta oluşturmak
  • Example#3400 - - imagefilledellipse örneği
  • Example#3401 - - imagefilledpolygon örneği
  • Example#3402 - - imagefilledrectangle örneği
  • Example#3403 - - Bir elipsi belli bir renge boyamak
  • Example#3404 - - imagefilter gri tonlama örneği
  • Example#3405 - - imagefilter parlaklık örneği
  • Example#3406 - - imagefilter renklendirme örneği
  • Example#3407 - imagefilter negatiflik örneği
  • Example#3408 - imagefilter mozaikleştirme örneği
  • Example#3409 - Flips an image vertically
  • Example#3410 - Flips the image horizontally
  • Example#3411 - - Yerleşik yazı tipleri üzerinde imagefontheight
  • Example#3412 - - imagefontheight ile imageloadfont işlevinin birlikte kullanımı
  • Example#3413 - - Yerleşik yazı tipleri üzerinde imagefontwidth
  • Example#3414 - imagefontwidth ile imageloadfont işlevinin birlikte kullanımı
  • Example#3415 - - imageftbbox örneği
  • Example#3416 - - imagefttext örneği
  • Example#3417 - - imagegammacorrect örneği
  • Example#3418 - - Bir GD2 resminin çıktılanması
  • Example#3419 - - Bir GD2 resminin kaydedilmesi
  • Example#3420 - - Bir GD resminin çıktılanması
  • Example#3421 - - Bir GD resminin kaydedilmesi
  • Example#3422 - imagegetclip example
  • Example#3423 - - imagegif ile bir resmi çıktılamak
  • Example#3424 - - Bir PNG resmini imagegif ile bir GIF resmine dönüştürmek
  • Example#3425 - - imagegrabscreen örneği
  • Example#3426 - - imagegrabwindow örneği
  • Example#3427 - - imageinterlace ile geçişimi etkin kılmak
  • Example#3428 - - imageistruecolor ile resmin gerçek renkli olup olmadığının saptanması
  • Example#3429 - - Bir JPEG resmi çıktılamak
  • Example#3430 - - Bir JPEG resmi kaydetmek
  • Example#3431 - - Resmi 75% kaliteyle oluşturmak
  • Example#3432 - - imagelayereffect örneği
  • Example#3433 - - Kalın bir çizgi çizelim
  • Example#3434 - - imageloadfont örneği
  • Example#3435 - imageopenpolygon example
  • Example#3436 - - imagepalettecopy örneği
  • Example#3437 - Converts any image resource to true color
  • Example#3438 - - imagepolygon örneği
  • Example#3439 - - imagepsbbox örneği
  • Example#3440 - - imagepsencodefont örneği
  • Example#3441 - - imagepsextendfont örneği
  • Example#3442 - - imagepsfreefont örneği
  • Example#3443 - - imagepsloadfont örneğ
  • Example#3444 - - imagepsslantfont örneği
  • Example#3445 - - imagepstext örneği
  • Example#3446 - - imagerectangle örneği
  • Example#3447 - Setting and getting the resolution of an image
  • Example#3448 - Bir remin 180° döndürülmesi
  • Example#3449 - - imagesavealpha örneği
  • Example#3450 - - imagesetbrush örneği
  • Example#3451 - imagesetinterpolation example
  • Example#3452 - - imagesetpixel örneği
  • Example#3453 - - imagesetstyle örneği
  • Example#3454 - - imagesetthickness örneği
  • Example#3455 - - imagesettile örneği
  • Example#3456 - - imagestring örneği
  • Example#3457 - - imagestring örneği
  • Example#3458 - - imagesx örneği
  • Example#3459 - - imagesy örneği
  • Example#3460 - - Bir gerçek renkli resmi bir paletli resme dönüştürmek
  • Example#3461 - - imagettfbbox örneği
  • Example#3462 - - imagettftext örneği
  • Example#3463 - - PNG desteğinin sınanması
  • Example#3464 - - Bir WBMP resmini çıktılamak
  • Example#3465 - - Bir WBMP resminin kaydedilmesi
  • Example#3466 - - Resmi farklı bir artalan rengi ile çıktılamak
  • Example#3467 - Saving an WebP file
  • Example#3468 - - Bir XBM dosyasının kaydedilmesi
  • Example#3469 - - XBM dosyasını farklı bir artalan rengi ile çıktılamak
  • Example#3470 - - IPTC verisinin bir JPEG içine gömülmesi
  • Example#3471 - - getimagesize ile iptcparse kullanımı
  • Example#3472 - - jpeg2wbmp örneği
  • Example#3473 - - png2wbmp örneği
  • Example#3474 - Gmagick Example
  • Example#3475 - Gmagick::despeckleimage example
  • Example#3476 - Gmagick::setCompressionQuality
  • Example#3477 - - Imagick ile resim örneği (thumbnail) oluşturmak
  • Example#3478 - - Bir dizindeki tüm JPG dosyalarının küçük örneklerinin elde edilmesi
  • Example#3479 - - Bir resmin yansımasının oluşturulması
  • Example#3480 - - Metni bir örüntü ile kaplamak
  • Example#3481 - - GIF resmini okumak ve tüm kareleri boyutlandırmak
  • Example#3482 - - Imagick::adaptiveBlurImage örneği
  • Example#3483 - - Imagick::adaptiveResizeImageörneği
  • Example#3484 - - Imagick::adaptiveSharpenImage örneği
  • Example#3485 - - Imagick::annotateImage örneği
  • Example#3486 - - Imagick::appendImages örneği
  • Example#3487 - Imagick::autoLevelImage
  • Example#3488 - Imagick::blueShiftImage
  • Example#3489 - - Imagick::blurImage örneği
  • Example#3490 - Imagick::brightnessContrastImage
  • Example#3491 - - Imagick::chopImage örneği
  • Example#3492 - - Imagick::clutImage örneği
  • Example#3493 - Imagick::colorMatrixImage
  • Example#3494 - - Imagick::commentImage kullanımı
  • Example#3495 - - Imagick::compareImageLayers örneği
  • Example#3496 - - Imagick::compareImages örneği
  • Example#3497 - Imagick::deskewImage
  • Example#3498 - - Imagick::distortImage örneği
  • Example#3499 - Using Imagick::exportImagePixels
  • Example#3500 - Imagick::filter
  • Example#3501 - - Imagick::floodfillPaintImage örneği
  • Example#3502 - Imagick::forwardFourierTransformImage
  • Example#3503 - Create a sinusoidal gradient
  • Example#3504 - Create a gradient from the polynomial (4x^2 - 4x + 1)
  • Example#3505 - Create a complex gradient from the polynomial (4x^2 - 4x^2 + 1) modulated by a sinusoidal gradient
  • Example#3506 - - Imagick::getImageLength örneği
  • Example#3507 - - Imagick::getImageProperties örneği
  • Example#3508 - - Imagick::getImageProperty örneği
  • Example#3509 - - Imagick::getIteratorIndex örneği
  • Example#3510 - Imagick::haldClutImage
  • Example#3511 - Imagick::identifyFormat
  • Example#3512 - Imagick::importImagePixels example
  • Example#3513 - Convolve Imagick::morphology
  • Example#3514 - Correlate Imagick::morphology
  • Example#3515 - Erode Imagick::morphology
  • Example#3516 - Erode Intensity Imagick::morphology
  • Example#3517 - Dilate Imagick::morphology
  • Example#3518 - Dilate intensity Imagick::morphology
  • Example#3519 - Distance with Chebyshev kernel Imagick::morphology
  • Example#3520 - Distance with Manhattan kernel Imagick::morphology
  • Example#3521 - Distance with ocatagonal kernel Imagick::morphology
  • Example#3522 - Distance with Euclidean kernel Imagick::morphology
  • Example#3523 - Edge Imagick::morphology
  • Example#3524 - Open Imagick::morphology
  • Example#3525 - Open intensity Imagick::morphology
  • Example#3526 - Close Imagick::morphology
  • Example#3527 - Close Intensity Imagick::morphology
  • Example#3528 - Smooth Imagick::morphology
  • Example#3529 - Edge in Imagick::morphology
  • Example#3530 - Edge out Imagick::morphology
  • Example#3531 - The 'TopHat' method, or more specifically 'White Top Hat', returns the pixels that were removed by a Opening of the shape, that is the pixels that were removed to round off the points, and the connecting bridged between shapes. Imagick::morphology
  • Example#3532 - The 'BottomHat' method, also known as 'Black TopHat' is the pixels that a Closing of the shape adds to the image. That is the the pixels that were used to fill in the 'holes', 'gaps', and 'bridges'. Imagick::morphology
  • Example#3533 - Hit and Miss Imagick::morphology
  • Example#3534 - Thinning Imagick::morphology
  • Example#3535 - Thicken Imagick::morphology
  • Example#3536 - Thick to generate a convex hull Imagick::morphology
  • Example#3537 - Iterative morphology Imagick::morphology
  • Example#3538 - Helper functon to get an image silhouette Imagick::morphology
  • Example#3539 - - Imagick::newImage örneği
  • Example#3540 - - Imagick::optimizeImageLayers örneği
  • Example#3541 - - Imagick::pingImageBlob örneği
  • Example#3542 - - Imagick::pingImageFile örneği
  • Example#3543 - - Imagick::polaroidImage örneği
  • Example#3544 - - Imagick::queryFontMetrics örneği
  • Example#3545 - Imagick::rotationalBlurImage
  • Example#3546 - - Imagick::roundCorners örneği
  • Example#3547 - Imagick::segmentImage
  • Example#3548 - Imagick::selectiveBlurImage
  • Example#3549 - - Imagick::setFont örneği
  • Example#3550 - - Imagick::setImage örneği
  • Example#3551 - Imagick::setImageArtifact
  • Example#3552 - - Imagick::setImageOpacity örneği
  • Example#3553 - - Imagick::setImageProperty örneği
  • Example#3554 - - Imagick::setIteratorIndex örneği
  • Example#3555 - - Imagick::setPointSize örneği
  • Example#3556 - Imagick::setProgressMonitor
  • Example#3557 - Imagick::smushImages
  • Example#3558 - SPARSECOLORMETHOD_BARYCENTRIC Imagick::sparseColorImage
  • Example#3559 - SPARSECOLORMETHOD_BILINEAR Imagick::sparseColorImage
  • Example#3560 - SPARSECOLORMETHOD_SPEPARDS Imagick::sparseColorImage
  • Example#3561 - SPARSECOLORMETHOD_VORONOI Imagick::sparseColorImage
  • Example#3562 - SPARSECOLORMETHOD_BARYCENTRIC Imagick::sparseColorImage
  • Example#3563 - createGradientImage is used by other examples. Imagick::sparseColorImage
  • Example#3564 - Imagick::statisticImage
  • Example#3565 - Imagick::subImageMatch
  • Example#3566 - Imagick::transformImage örneği
  • Example#3567 - Imagick::transformImageColorspace example
  • Example#3568 - Imagick::transformImageColorspace
  • Example#3569 - - Imagick::trimImage örneği
  • Example#3570 - ImagickPixel::getColorValueQuantum
  • Example#3571 - ImagickPixel::setColorValueQuantum
  • Example#3572 - - imap_append örneği
  • Example#3573 - - imap_check örneği
  • Example#3574 - - imap_createmailbox örneği
  • Example#3575 - - imap_delete örneği
  • Example#3576 - - imap_fetch_overview örneği
  • Example#3577 - - imap_gc örneği
  • Example#3578 - - imap_get_quota örneği
  • Example#3579 - - imap_get_quota 4.3 ve üstü örneği
  • Example#3580 - - imap_get_quotaroot örneği
  • Example#3581 - - imap_getacl örneği
  • Example#3582 - - imap_getmailboxes örneği
  • Example#3583 - - imap_list örneği
  • Example#3584 - - imap_mail_compose örneği
  • Example#3585 - - imap_mailboxmsginfo örneği
  • Example#3586 - - imap_mime_header_decode örneği
  • Example#3587 - - imap_open işlevinin farklı kullanımları
  • Example#3588 - - imap_open örneği
  • Example#3589 - - imap_ping örneği
  • Example#3590 - - imap_reopen örneği
  • Example#3591 - - imap_rfc822_parse_adrlist örneği
  • Example#3592 - - imap_rfc822_write_address örneği
  • Example#3593 - - imap_set_quota örneği
  • Example#3594 - - imap_setflag_full örneği
  • Example#3595 - - imap_status örneği
  • Example#3596 - - imap_thread örneği
  • Example#3597 - - imap_timeout örneği
  • Example#3598 - - Adres özetinin hesaplanıp bir kullanıcının üye yapılması
  • Example#3599 - - Eposta gönderimi
  • Example#3600 - - Ek başlıklarla eposta gönderimi
  • Example#3601 - - Ek komut satırı seçenekleriyle eposta gönderimi
  • Example#3602 - - HTML eposta gönderimi
  • Example#3603 - mailparse_determine_best_xfer_encoding example
  • Example#3604 - mailparse_rfc822_parse_addresses example
  • Example#3605 - mailparse_stream_encode example
  • Example#3606 - mailparse_uudecode_all example
  • Example#3607 - bcadd örneği
  • Example#3608 - bccomp örneği
  • Example#3609 - bcdiv örneği
  • Example#3610 - bcmod örneği
  • Example#3611 - bcmul örneği
  • Example#3612 - bcpow örneği
  • Example#3613 - bcscale örneği
  • Example#3614 - bcsqrt örneği
  • Example#3615 - bcsub örneği
  • Example#3616 - Factorial function using GMP
  • Example#3617 - gmp_abs example
  • Example#3618 - gmp_add example
  • Example#3619 - gmp_and example
  • Example#3620 - gmp_clrbit example
  • Example#3621 - gmp_cmp example
  • Example#3622 - gmp_com example
  • Example#3623 - gmp_div_q example
  • Example#3624 - Division of GMP numbers
  • Example#3625 - gmp_div_r example
  • Example#3626 - gmp_divexact example
  • Example#3627 - gmp_export example
  • Example#3628 - gmp_fact example
  • Example#3629 - gmp_gcd example
  • Example#3630 - Solving a linear Diophantine equation
  • Example#3631 - gmp_hamdist example
  • Example#3632 - gmp_import example
  • Example#3633 - Creating GMP number
  • Example#3634 - gmp_intval example
  • Example#3635 - gmp_invert example
  • Example#3636 - gmp_jacobi example
  • Example#3637 - gmp_legendre example
  • Example#3638 - gmp_mod example
  • Example#3639 - gmp_mul example
  • Example#3640 - gmp_neg example
  • Example#3641 - gmp_nextprime example
  • Example#3642 - gmp_or example
  • Example#3643 - gmp_perfect_square example
  • Example#3644 - gmp_popcount example
  • Example#3645 - gmp_pow example
  • Example#3646 - gmp_powm example
  • Example#3647 - gmp_prob_prime example
  • Example#3648 - gmp_random_bits example
  • Example#3649 - gmp_random_range example
  • Example#3650 - gmp_random_seed example
  • Example#3651 - gmp_random example
  • Example#3652 - gmp_scan0 example
  • Example#3653 - gmp_scan1 example
  • Example#3654 - gmp_setbit example - 0 index
  • Example#3655 - gmp_setbit example - 1 index
  • Example#3656 - gmp_setbit example - clearing a bit
  • Example#3657 - gmp_sign example
  • Example#3658 - gmp_sqrt example
  • Example#3659 - gmp_sqrtrem example
  • Example#3660 - Converting a GMP number to a string
  • Example#3661 - gmp_sub example
  • Example#3662 - gmp_testbit example
  • Example#3663 - gmp_xor example
  • Example#3664 - Using Lapack::eigenValues:
  • Example#3665 - Using Lapack::leastSquaresByFactorisation:
  • Example#3666 - Using Lapack::leastSquaresBySVD:
  • Example#3667 - Using Lapack::pseudoInverse:
  • Example#3668 - Using Lapack::singularValues:
  • Example#3669 - Using Lapack::singularValues:
  • Example#3670 - abs example
  • Example#3671 - base_convert example
  • Example#3672 - bindec example
  • Example#3673 - bindec interprets input as unsigned integers
  • Example#3674 - ceil example
  • Example#3675 - cos example
  • Example#3676 - decbin example
  • Example#3677 - dechex example
  • Example#3678 - dechex example with large integers
  • Example#3679 - decoct example
  • Example#3680 - deg2rad example
  • Example#3681 - exp example
  • Example#3682 - floor example
  • Example#3683 - Using fmod
  • Example#3684 - hexdec example
  • Example#3685 - intdiv example
  • Example#3686 - is_nan example
  • Example#3687 - Example uses of max
  • Example#3688 - Example uses of min
  • Example#3689 - Calculate a random floating-point number
  • Example#3690 - mt_rand example
  • Example#3691 - mt_srand example
  • Example#3692 - octdec example
  • Example#3693 - pi example
  • Example#3694 - Some examples of pow
  • Example#3695 - rad2deg example
  • Example#3696 - rand example
  • Example#3697 - round examples
  • Example#3698 - mode examples
  • Example#3699 - mode with precision examples
  • Example#3700 - sin example
  • Example#3701 - sqrt example
  • Example#3702 - srand example
  • Example#3703 - tan example
  • Example#3704 - Evaluating a FDF document
  • Example#3705 - Adding JavaScript code to a FDF
  • Example#3706 - Populating a PDF document
  • Example#3707 - Storing an uploaded file
  • Example#3708 - Detecting all fieldnames in a FDF
  • Example#3709 - Accessing the form data
  • Example#3710 - Accessing the form data
  • Example#3711 - Retrieving FDF as a string
  • Example#3712 - Passing FDF data to a second form
  • Example#3713 - gnupg clearsign example (procedural)
  • Example#3714 - gnupg clearsign example (OO)
  • Example#3715 - keylistiterator
  • Example#3716 - Procedural gnupg_adddecryptkey example
  • Example#3717 - OO gnupg_adddecryptkey example
  • Example#3718 - Procedural gnupg_addencryptkey example
  • Example#3719 - OO gnupg_addencryptkey example
  • Example#3720 - Procedural gnupg_addsignkey example
  • Example#3721 - OO gnupg_addsignkey example
  • Example#3722 - Procedural gnupg_cleardecryptkeys example
  • Example#3723 - OO gnupg_cleardecryptkeys example
  • Example#3724 - Procedural gnupg_clearencryptkeys example
  • Example#3725 - OO gnupg_clearencryptkeys example
  • Example#3726 - Procedural gnupg_clearsignkeys example
  • Example#3727 - OO gnupg_clearsignkeys example
  • Example#3728 - Procedural gnupg_decrypt example
  • Example#3729 - OO gnupg_encrypt example
  • Example#3730 - Procedural gnupg_decryptverify example
  • Example#3731 - OO gnupg_decryptverify example
  • Example#3732 - Procedural gnupg_encrypt example
  • Example#3733 - OO gnupg_encrypt example
  • Example#3734 - Procedural gnupg_encryptsign example
  • Example#3735 - OO gnupg_encryptsign example
  • Example#3736 - Procedural gnupg_export example
  • Example#3737 - OO gnupg_export example
  • Example#3738 - Procedural gnupg_geterror example
  • Example#3739 - OO gnupg_geterror example
  • Example#3740 - Procedural gnupg_getprotocol example
  • Example#3741 - OO gnupg_getprotocol example
  • Example#3742 - Procedural gnupg_import example
  • Example#3743 - OO gnupg_import example
  • Example#3744 - Procedural gnupg_init example
  • Example#3745 - OO gnupg initializer example
  • Example#3746 - Procedural gnupg_keyinfo example
  • Example#3747 - OO gnupg_keyinfo example
  • Example#3748 - Procedural gnupg_setarmor example
  • Example#3749 - OO gnupg_setarmor example
  • Example#3750 - Procedural gnupg_seterrormode example
  • Example#3751 - OO gnupg_seterrormode example
  • Example#3752 - Procedural gnupg_setsignmode example
  • Example#3753 - OO gnupg_setsignmode example
  • Example#3754 - Procedural gnupg_sign example
  • Example#3755 - OO gnupg_sign example
  • Example#3756 - Procedural gnupg_verify example
  • Example#3757 - OO gnupg_verify example
  • Example#3758 - Fancy "Hello world"
  • Example#3759 - swfaction example
  • Example#3760 - swfaction example
  • Example#3761 - swfaction example
  • Example#3762 - swfsprite example
  • Example#3763 - ming_useswfversion example
  • Example#3764 - Importing a DBL file
  • Example#3765 - Using an alpha mask
  • Example#3766 - Usual interactions with buttons
  • Example#3767 - Drag example
  • Example#3768 - swfdisplayitem::multcolor example
  • Example#3769 - swfdisplayitem::rotateto example
  • Example#3770 - swfdisplayitem::setname example
  • Example#3771 - swfgradient example
  • Example#3772 - swfmorph example
  • Example#3773 - Displaying your $movie in a browser
  • Example#3774 - Streaming example
  • Example#3775 - SWFShape::addFill example
  • Example#3776 - swfshape example
  • Example#3777 - swfshape::setline example
  • Example#3778 - swftext example
  • Example#3779 - Hello World example from PDFlib distribution for PHP 4
  • Example#3780 - Hello World example from PDFlib distribution for PHP 5
  • Example#3781 - Creating and using a pattern
  • Example#3782 - Creating and using a template
  • Example#3783 - Hyphennate a text
  • Example#3784 - Drawing a rectangle
  • Example#3785 - Creating and using a spot color
  • Example#3786 - Rotation of the coordinate system
  • Example#3787 - Placing text at a given position
  • Example#3788 - Drawing a dashed line
  • Example#3789 - Translation of the coordinate system
  • Example#3790 - Basic RPMReader Example
  • Example#3791 - rpm_close example
  • Example#3792 - rpm_get_tag example
  • Example#3793 - rpm_is_valid example
  • Example#3794 - rpm_open example
  • Example#3795 - rpm_version example
  • Example#3796 - Incorrect requests
  • Example#3797 - Calling request from a request callback
  • Example#3798 - Calling request from a request callback
  • Example#3799 - Using eio with libevent
  • Example#3800 - Cancelling a request
  • Example#3801 - Calling eio_chmod
  • Example#3802 - Making a custom request
  • Example#3803 - Grouping requests
  • Example#3804 - Using eio with libevent extension
  • Example#3805 - Using eio with event extension
  • Example#3806 - eio_cancel example
  • Example#3807 - eio_custom example
  • Example#3808 - eio_event_loop example
  • Example#3809 - eio_lstat example
  • Example#3810 - Using eio with libevent
  • Example#3811 - Grouping requests
  • Example#3812 - eio_grp example
  • Example#3813 - eio_link example
  • Example#3814 - eio_lstat example
  • Example#3815 - eio_mkdir example
  • Example#3816 - eio_mknod example
  • Example#3817 - eio_nreqs example
  • Example#3818 - eio_open example
  • Example#3819 - eio_poll example
  • Example#3820 - eio_read example
  • Example#3821 - eio_readdir example
  • Example#3822 - eio_readlink example
  • Example#3823 - eio_realpath example
  • Example#3824 - eio_rename example
  • Example#3825 - eio_rmdir example
  • Example#3826 - eio_stat example
  • Example#3827 - eio_statvfs example
  • Example#3828 - eio_symlink example
  • Example#3829 - Simple timers
  • Example#3830 - Periodic timer. Tick each 10.5 seconds
  • Example#3831 - Periodic timer. Use reschedule callback
  • Example#3832 - Periodic timer. Tick every 10.5 seconds starting at now
  • Example#3833 - Wait until STDIN is readable
  • Example#3834 - Use some async I/O to access a socket
  • Example#3835 - Embedding one loop into another
  • Example#3836 - Embedding loop created with kqueue backend into the default loop
  • Example#3837 - Handle SIGTERM signal
  • Example#3838 - Monitor changes of /var/log/messages
  • Example#3839 - Monotor changes of /var/log/messages. Avoid missing updates by means of one second delay
  • Example#3840 - Process status changes
  • Example#3841 - Using reschedule callback
  • Example#3842 - Embedding loop created with kqueue backend into the default loop
  • Example#3843 - Embedding one loop into another
  • Example#3844 - Embedding loop created with kqueue backend into the default loop
  • Example#3845 - Embedding loop created with kqueue backend into the default loop
  • Example#3846 - Periodic timer. Use reschedule callback
  • Example#3847 - Periodic timer. Tick every 10.5 seconds starting at now
  • Example#3848 - Hourly watcher
  • Example#3849 - Handle SIGTERM signal
  • Example#3850 - Monitor changes of /var/log/messages
  • Example#3851 - Monitor changes of /var/log/messages
  • Example#3852 - Simple timers
  • Example#3853 - Monotor changes of /var/log/messages. Avoid missing updates by means of one second delay
  • Example#3854 - Register an I/O watcher for some UDP socket but do not keep the event loop from running just because of that watcher.
  • Example#3855 - Expect Usage Example
  • Example#3856 - Another Expect Usage Example
  • Example#3857 - expect_expectl example
  • Example#3858 - expect_popen example
  • Example#3859 - polling STDIN using basic API
  • Example#3860 - polling STDIN using buffered event API
  • Example#3861 - Süreç Denetimi örneği
  • Example#3862 - - pcntl_fork örneği
  • Example#3863 - - pcntl_signal_dispatch örneği
  • Example#3864 - pcntl_signal_get_handler example
  • Example#3865 - - pcntl_signal örneği
  • Example#3866 - - pcntl_sigprocmask örneği
  • Example#3867 - - pcntl_sigwaitinfo örneği
  • Example#3868 - - posix_access örneği
  • Example#3869 - - posix_ctermid örneği
  • Example#3870 - - posix_get_last_error örneği
  • Example#3871 - - posix_getcwd örneği
  • Example#3872 - - posix_getegid örneği
  • Example#3873 - - posix_geteuid örneği
  • Example#3874 - - posix_getgid örneği
  • Example#3875 - - posix_getgrgid örneği
  • Example#3876 - - posix_getgrnam örneği
  • Example#3877 - - posix_getgroups örneği
  • Example#3878 - - posix_getlogin örneği
  • Example#3879 - - posix_getpgid örneği
  • Example#3880 - - posix_getpid örneği
  • Example#3881 - - posix_getppid örneği
  • Example#3882 - - posix_getpwnam örneği
  • Example#3883 - - posix_getpwuid örneği
  • Example#3884 - - posix_getrlimit örneği
  • Example#3885 - - posix_getsid örneği
  • Example#3886 - - posix_getuid örneği
  • Example#3887 - - posix_mknod örneği
  • Example#3888 - - posix_setegid örneği
  • Example#3889 - - posix_setgid örneği
  • Example#3890 - - posix_setuid örneği
  • Example#3891 - - posix_strerror örneği
  • Example#3892 - - posix_times örneği
  • Example#3893 - - posix_uname örneği
  • Example#3894 - - escapeshellarg örneği
  • Example#3895 - - escapeshellcmd örneği
  • Example#3896 - - exec örneği
  • Example#3897 - - proc_open örneği
  • Example#3898 - - shell_exec örneği
  • Example#3899 - - system örneği
  • Example#3900 - Fetch a chunk of the property table
  • Example#3901 - Counting the properties of an object
  • Example#3902 - Runtime inheritance
  • Example#3903 - Thread safe objects from closures
  • Example#3904 - Detecting fatal errors in Threads
  • Example#3905 - Detect the state of the referenced object
  • Example#3906 - Detect the state of the referenced object
  • Example#3907 - Detect the state of the referenced object
  • Example#3908 - Locking Object Properties
  • Example#3909 - Merging into the property table of a threaded object
  • Example#3910 - Notifications and Waiting
  • Example#3911 - Popping the last item from the property table of a threaded object
  • Example#3912 - Shifting the first item from the property table of a threaded object
  • Example#3913 - Synchronizing
  • Example#3914 - Locking the property table of a threaded object
  • Example#3915 - Notifications and Waiting
  • Example#3916 - Return the identity of the Thread or Process that created the referenced Thread
  • Example#3917 - Return the currently executing Thread
  • Example#3918 - Return the identity of the currently executing Thread
  • Example#3919 - Return the identity of the referenced Thread
  • Example#3920 - Execute in the global scope
  • Example#3921 - Detect the state of the referenced Thread
  • Example#3922 - Tell if the referenced Thread was started
  • Example#3923 - Join with the referenced Thread
  • Example#3924 - Kill the referenced Thread
  • Example#3925 - Starting Threads
  • Example#3926 - A basic example of Worker::collect
  • Example#3927 - A basic example of Worker::getStacked
  • Example#3928 - Detect the state of a worker
  • Example#3929 - Detect the state of a Worker
  • Example#3930 - Shutdown the referenced worker
  • Example#3931 - Stacking a task for execution onto a worker
  • Example#3932 - Removing objects from the stack of Workers
  • Example#3933 - protected method example: protected methods can only be executed by one Thread at a time.
  • Example#3934 - private method example: private methods may only be executed by the Threaded object during execution
  • Example#3935 - A basic example of Pool::collect
  • Example#3936 - Creating Pools
  • Example#3937 - Shutting down a pool
  • Example#3938 - Submitting Tasks
  • Example#3939 - Submitting tasks to a specific worker
  • Example#3940 - Mutex Creation and Destruction
  • Example#3941 - Mutex Creation and Destruction
  • Example#3942 - Mutex Locking and Unlocking
  • Example#3943 - Mutex Locking and Unlocking
  • Example#3944 - Mutex Locking and Unlocking
  • Example#3945 - Condition Broadcasting
  • Example#3946 - Condition Creation and Destruction
  • Example#3947 - Condition Creation and Destruction
  • Example#3948 - Condition Signalling
  • Example#3949 - Waiting for Conditions
  • Example#3950 -
  • Example#3951 - Shared Memory Operations Overview
  • Example#3952 - Closing shared memory block
  • Example#3953 - Deleting shared memory block
  • Example#3954 - Create a new shared memory block
  • Example#3955 - Reading shared memory block
  • Example#3956 - Getting the size of the shared memory block
  • Example#3957 - Writing to shared memory block
  • Example#3958 - SyncMutex::__construct named mutex with lock timeout example
  • Example#3959 - SyncMutex::__construct unnamed mutex example
  • Example#3960 - SyncMutex::lock example
  • Example#3961 - SyncMutex::unlock example
  • Example#3962 - SyncSemaphore::__construct example
  • Example#3963 - SyncSemaphore::lock example
  • Example#3964 - SyncSemaphore::unlock example
  • Example#3965 - SyncEvent::__construct example
  • Example#3966 - SyncEvent::fire example
  • Example#3967 - SyncEvent::reset example
  • Example#3968 - SyncEvent::wait example
  • Example#3969 - SyncReaderWriter::__construct example
  • Example#3970 - SyncReaderWriter::readlock example
  • Example#3971 - SyncReaderWriter::readunlock example
  • Example#3972 - SyncReaderWriter::writelock example
  • Example#3973 - SyncReaderWriter::writeunlock example
  • Example#3974 - SyncSharedMemory::__construct example
  • Example#3975 - SyncSharedMemory::first example
  • Example#3976 - SyncSharedMemory::__construct example
  • Example#3977 - SyncSharedMemory::size example
  • Example#3978 - SyncSharedMemory::write example
  • Example#3979 - A geoip_asnum_by_name example
  • Example#3980 - A geoip_continent_code_by_name example
  • Example#3981 - A geoip_country_code_by_name example
  • Example#3982 - A geoip_country_code3_by_name example
  • Example#3983 - A geoip_country_name_by_name example
  • Example#3984 - A geoip_database_info example
  • Example#3985 - A geoip_db_avail example
  • Example#3986 - A geoip_db_filename example
  • Example#3987 - A geoip_db_get_all_info example
  • Example#3988 - A geoip_db_get_all_info example
  • Example#3989 - A geoip_domain_by_name example
  • Example#3990 - A geoip_id_by_name example
  • Example#3991 - A geoip_isp_by_name example
  • Example#3992 - A geoip_netspeedcell_by_name example
  • Example#3993 - A geoip_org_by_name example
  • Example#3994 - A geoip_record_by_name example
  • Example#3995 - A geoip_region_by_name example
  • Example#3996 - A geoip_region_name_by_code example using region code for US/Canada
  • Example#3997 - A geoip_region_name_by_code example using FIPS codes
  • Example#3998 - A geoip_setup_custom_directory example
  • Example#3999 - A geoip_time_zone_by_country_and_region example using region code for US/Canada
  • Example#4000 - A geoip_time_zone_by_country_and_region example using FIPS codes
  • Example#4001 - xor.data file
  • Example#4002 - Simple train
  • Example#4003 - Simple test
  • Example#4004 - fann_create_train_from_callback example
  • Example#4005 - fann_read_train_from_file example
  • Example#4006 - - json_decode örnekleri
  • Example#4007 - - Diğer örnek
  • Example#4008 - - json_decode kullanırken yapılan genel bir hata.
  • Example#4009 - - depth hataları
  • Example#4010 - - json_encode örneği
  • Example#4011 - - json_encode işlevinin tüm seçeneklerini gösteren bir örnek
  • Example#4012 - json_last_error örneği
  • Example#4013 - Judy array example
  • Example#4014 - Lua::assignexample
  • Example#4015 - Lua::callexample
  • Example#4016 - Lua::evalexample
  • Example#4017 - Lua::registerCallbackexample
  • Example#4018 - LuaClosure::__invokeexample
  • Example#4019 - - constant örneği
  • Example#4020 - - Sabit tanımlamak
  • Example#4021 - - Sabitlerin tanımlılığını sınamak
  • Example#4022 - - eval örneği
  • Example#4023 - - exit örneği
  • Example#4024 - - Çıkış durumu örneği
  • Example#4025 - Kullanıcının tarayıcısı ile ilgili tüm bilginin listelenmesi
  • Example#4026 - - __halt_compiler örneği
  • Example#4027 - - highlight_string örneği
  • Example#4028 - - ignore_user_abort örneği
  • Example#4029 - - pack örneği
  • Example#4030 - - php_strip_whitespace örneği
  • Example#4031 - - sleep örneği
  • Example#4032 - - sys_getloadavg örneği
  • Example#4033 - - time_nanosleep örneği
  • Example#4034 - - time_sleep_until örneği
  • Example#4035 - - uniqid örneği
  • Example#4036 - - unpack örneği
  • Example#4037 - - usleep örneği
  • Example#4038 - parsekit_compile_file example
  • Example#4039 - parsekit_compile_string example
  • Example#4040 - parsekit_func_arginfo example
  • Example#4041 - SplDoublyLinkedList::__construct example
  • Example#4042 - SplStack::__construct example
  • Example#4043 - SplQueue::__construct example
  • Example#4044 - Efficiently handling tasks with SplQueue
  • Example#4045 - SplFixedArray usage example
  • Example#4046 - SplFixedArray::__construct example
  • Example#4047 - SplFixedArray::count example
  • Example#4048 - SplFixedArray::fromArray example
  • Example#4049 - SplFixedArray::getSize example
  • Example#4050 - SplFixedArray::setSize example
  • Example#4051 - SplFixedArray::toArray example
  • Example#4052 - SplObjectStorage as a set
  • Example#4053 - SplObjectStorage as a map
  • Example#4054 - SplObjectStorage::addAll example
  • Example#4055 - SplObjectStorage::attach example
  • Example#4056 - SplObjectStorage::contains example
  • Example#4057 - SplObjectStorage::count example
  • Example#4058 - SplObjectStorage::current example
  • Example#4059 - SplObjectStorage::detach example
  • Example#4060 - SplObjectStorage::getHash example
  • Example#4061 - SplObjectStorage::getInfo example
  • Example#4062 - SplObjectStorage::key example
  • Example#4063 - SplObjectStorage::next example
  • Example#4064 - SplObjectStorage::offsetExists example
  • Example#4065 - SplObjectStorage::offsetGet example
  • Example#4066 - SplObjectStorage::offsetSet example
  • Example#4067 - SplObjectStorage::offsetUnset example
  • Example#4068 - SplObjectStorage::removeAll example
  • Example#4069 - SplObjectStorage::removeAllExcept example
  • Example#4070 - SplObjectStorage::rewind example
  • Example#4071 - SplObjectStorage::serialize example
  • Example#4072 - SplObjectStorage::setInfo example
  • Example#4073 - SplObjectStorage::unserialize example
  • Example#4074 - SplObjectStorage::valid example
  • Example#4075 - AppendIterator::append example
  • Example#4076 - Iterating AppendIterator with foreach
  • Example#4077 - Iterating AppendIterator with the AppendIterator API
  • Example#4078 - AppendIterator::getInnerIterator example
  • Example#4079 - AppendIterator.getIteratorIndex basic example
  • Example#4080 - AppendIterator::key basic example
  • Example#4081 - ArrayIterator::current example
  • Example#4082 - ArrayIterator::key example
  • Example#4083 - ArrayIterator::next example
  • Example#4084 - ArrayIterator::rewind example
  • Example#4085 - ArrayIterator::valid example
  • Example#4086 - CachingIterator::getCache example
  • Example#4087 - Available callback arguments
  • Example#4088 - Callback basic examples
  • Example#4089 - A DirectoryIterator::__construct example
  • Example#4090 - A DirectoryIterator::current example
  • Example#4091 - A DirectoryIterator::getATime example
  • Example#4092 - A DirectoryIterator::getBasename example
  • Example#4093 - DirectoryIterator::getCTime example
  • Example#4094 - DirectoryIterator::getExtension example
  • Example#4095 -
  • Example#4096 - A DirectoryIterator::getFilename example
  • Example#4097 - DirectoryIterator::getGroup example
  • Example#4098 - DirectoryIterator::getInode example
  • Example#4099 - A DirectoryIterator::getMTime example
  • Example#4100 - DirectoryIterator::getOwner example
  • Example#4101 - DirectoryIterator::getPath example
  • Example#4102 - DirectoryIterator::getPathname example
  • Example#4103 - DirectoryIterator::getPerms example
  • Example#4104 - DirectoryIterator::getSize example
  • Example#4105 - DirectoryIterator::getType example
  • Example#4106 - DirectoryIterator::isDir example
  • Example#4107 - A DirectoryIterator::isDot example
  • Example#4108 - DirectoryIterator::isExecutable example
  • Example#4109 - DirectoryIterator::isFile example
  • Example#4110 - A DirectoryIterator::isLink example
  • Example#4111 - DirectoryIterator::isReadable example
  • Example#4112 - DirectoryIterator::isWritable example
  • Example#4113 - A DirectoryIterator::key example
  • Example#4114 - DirectoryIterator::next example
  • Example#4115 - DirectoryIterator::rewind example
  • Example#4116 - DirectoryIterator::seek example
  • Example#4117 - A DirectoryIterator::__toString example
  • Example#4118 - A DirectoryIterator::valid example
  • Example#4119 - FilesystemIterator::__construct example
  • Example#4120 - FilesystemIterator::current example
  • Example#4121 - FilesystemIterator::key example
  • Example#4122 - FilesystemIterator::next example
  • Example#4123 - FilesystemIterator::rewind example
  • Example#4124 - FilesystemIterator::key example
  • Example#4125 - FilterIterator::accept example
  • Example#4126 - GlobIterator example
  • Example#4127 - GlobIterator::count example
  • Example#4128 - InfiniteIterator::__construct example
  • Example#4129 - LimitIterator usage example
  • Example#4130 - LimitIterator::__construct example
  • Example#4131 - LimitIterator::getPosition example
  • Example#4132 - Iterating a MultipleIterator
  • Example#4133 - NoRewindIterator::__construct example
  • Example#4134 - NoRewindIterator::rewind example
  • Example#4135 - RecursiveArrayIterator::getChildren example
  • Example#4136 - RecursiveArrayIterator::hasChildren example
  • Example#4137 - Available callback arguments
  • Example#4138 - Recursive callback basic example
  • Example#4139 - RecursiveCallbackFilterIterator::hasChildren basic usage
  • Example#4140 - RecursiveDirectoryIterator example
  • Example#4141 - Basic RecursiveFilterIterator example
  • Example#4142 - RecursiveFilterIterator example
  • Example#4143 - Iterating a RecursiveIteratorIterator
  • Example#4144 - RecursiveRegexIterator::__construct example
  • Example#4145 - RecursiveRegexIterator::getChildren example
  • Example#4146 - RecursiveRegexIterator::hasChildren example
  • Example#4147 - RegexIterator::accept example
  • Example#4148 - RegexIterator::__construct example
  • Example#4149 - RegexIterator::getFlags example
  • Example#4150 - RegexIterator::getMode example
  • Example#4151 - RegexIterator::getPregFlags example
  • Example#4152 - RegexIterator::setFlags example
  • Example#4153 - RegexIterator::setMode example
  • Example#4154 - RegexIterator::setPregFlags example
  • Example#4155 - Countable::count example
  • Example#4156 - Basic usage
  • Example#4157 - SeekableIterator::seek example
  • Example#4158 - class_implements example
  • Example#4159 - class_parents example
  • Example#4160 - class_uses example
  • Example#4161 - iterator_apply example
  • Example#4162 - iterator_count example
  • Example#4163 - iterator_count modifies position
  • Example#4164 - iterator_count in foreach loops
  • Example#4165 - iterator_to_array example
  • Example#4166 - spl_autoload_register as a replacement for an __autoload function
  • Example#4167 - spl_autoload_register example where the class is not loaded
  • Example#4168 - spl_classes example
  • Example#4169 - A spl_object_hash example
  • Example#4170 - SplFileInfo::__construct example
  • Example#4171 - SplFileInfo::getBasename example
  • Example#4172 - SplFileInfo::getCTime example
  • Example#4173 - SplFileInfo::getExtension example
  • Example#4174 -
  • Example#4175 - SplFileInfo::getFilename example
  • Example#4176 - SplFileInfo::getGroup example
  • Example#4177 - SplFileInfo::getLinkTarget example
  • Example#4178 - SplFileInfo::getOwner example
  • Example#4179 - SplFileInfo::getPath example
  • Example#4180 - SplFileInfo::getPathInfo example
  • Example#4181 - SplFileInfo::getPathname example
  • Example#4182 - SplFileInfo::getPerms example
  • Example#4183 - SplFileInfo::getRealPath example
  • Example#4184 - SplFileInfo::getType example
  • Example#4185 - SplFileInfo::isDir example
  • Example#4186 - SplFileInfo::isExecutable example
  • Example#4187 - SplFileInfo::isFile example
  • Example#4188 - SplFileInfo::isLink example
  • Example#4189 - SplFileInfo::isReadable example
  • Example#4190 - SplFileInfo::openFile example
  • Example#4191 - SplFileInfo::setFileClass example
  • Example#4192 - SplFileInfo::setFileClass example
  • Example#4193 - SplFileInfo::__toString example
  • Example#4194 - SplFileObject::__construct example
  • Example#4195 - SplFileObject::current example
  • Example#4196 - SplFileObject::eof example
  • Example#4197 - SplFileObject::fflush example
  • Example#4198 - SplFileObject::fgetc example
  • Example#4199 - SplFileObject::fgetcsv example
  • Example#4200 - SplFileObject::READ_CSV example
  • Example#4201 - SplFileObject::fgets example
  • Example#4202 - SplFileObject::fgetss example
  • Example#4203 - SplFileObject::flock example
  • Example#4204 - SplFileObject::fpassthru example
  • Example#4205 - SplFileObject::fputcsv example
  • Example#4206 - SplFileObject::fread example
  • Example#4207 - SplFileObject::fscanf example
  • Example#4208 - SplFileObject::fseek example
  • Example#4209 - SplFileObject::fstat example
  • Example#4210 - SplFileObject::ftell example
  • Example#4211 - SplFileObject::ftruncate example
  • Example#4212 - SplFileObject::fwrite example
  • Example#4213 - SplFileObject::getCsvControl example
  • Example#4214 - SplFileObject::getFlags example
  • Example#4215 - SplFileObject::getMaxLineLen example
  • Example#4216 - SplFileObject::key example
  • Example#4217 - SplFileObject::key example with SplFileObject::setMaxLineLen
  • Example#4218 - SplFileObject::next example
  • Example#4219 - SplFileObject::rewind example
  • Example#4220 - SplFileObject::seek example
  • Example#4221 - SplFileObject::setCsvControl example
  • Example#4222 - SplFileObject::setFlags example
  • Example#4223 - SplFileObject::setMaxLineLen example
  • Example#4224 - SplFileObject::valid example
  • Example#4225 - SplTempFileObject example
  • Example#4226 - ArrayObject::append example
  • Example#4227 - ArrayObject::asort example
  • Example#4228 - ArrayObject::__construct example
  • Example#4229 - ArrayObject::count example
  • Example#4230 - ArrayObject::exchangeArray example
  • Example#4231 - ArrayObject::getArrayCopy example
  • Example#4232 - ArrayObject::getFlags example
  • Example#4233 - ArrayObject::getIterator example
  • Example#4234 - ArrayObject::getIteratorClass example
  • Example#4235 - ArrayObject::ksort example
  • Example#4236 - ArrayObject::natcasesort example
  • Example#4237 - ArrayObject::natsort example
  • Example#4238 - ArrayObject::offsetExists example
  • Example#4239 - ArrayObject::offsetGet example
  • Example#4240 - ArrayObject::offsetSet example
  • Example#4241 - ArrayObject::offsetUnset example
  • Example#4242 - ArrayObject::serialize example
  • Example#4243 - ArrayObject::setFlags example
  • Example#4244 - ArrayObject::setIteratorClass example
  • Example#4245 - ArrayObject::uasort example
  • Example#4246 - ArrayObject::uksort example
  • Example#4247 - SplInt usage example
  • Example#4248 - SplFloat usage example
  • Example#4249 - SplEnum usage example
  • Example#4250 - SplEnum::getConstList example
  • Example#4251 - SplBool usage example
  • Example#4252 - SplString usage example
  • Example#4253 - - Çok sayıda kaynaktan veri almak için file_get_contents kullanımı
  • Example#4254 - - Bir HTTPS sunucusundan bir POST isteği yapmak
  • Example#4255 - - Sıkıştırılmış bir dosyaya veri yazmak
  • Example#4256 - - Küresel değişkenlere veri okuyup yazan bir akım
  • Example#4257 - - Tar arşivindeki dosyaları listelemek
  • Example#4258 - - stream_context_create örneği
  • Example#4259 - - stream_context_get_default örneği
  • Example#4260 - - stream_context_get_options örneği
  • Example#4261 - - stream_context_get_params örneği
  • Example#4262 - - stream_context_set_default örneği
  • Example#4263 - - stream_copy_to_stream örneği
  • Example#4264 - - Süzgeçlerin uygulanacağı yerin belirlenmesi
  • Example#4265 - - foo-bar.txt akımında büyük harfe dönüşüm süzgeci
  • Example#4266 - - Çok sayıda süzgeç ismiyle eşleşen soysal bir süzgeç sınıfının tanıtımı
  • Example#4267 - - Bir akımın devingen olarak süzülmesi
  • Example#4268 - - stream_get_contents örneği
  • Example#4269 - - stream_get_filters örneği
  • Example#4270 - - stream_get_meta_data örneği
  • Example#4271 - - stream_get_transports örneği
  • Example#4272 - - stream_get_wrappers örneği
  • Example#4273 - - Bir akım sarmalayıcının varlığının sınanması
  • Example#4274 - - stream_is_local örneği
  • Example#4275 - - stream_notification_callback örneği
  • Example#4276 - - Komut satırı istemcisi için basit bir ilerleme çubuğu
  • Example#4277 - - stream_select örneği
  • Example#4278 - - stream_set_timeout örneği
  • Example#4279 - - stream_set_write_buffer örneği
  • Example#4280 - - stream_socket_client örneği
  • Example#4281 - - UDP bağlantı kullanımı
  • Example#4282 - - stream_socket_enable_crypto örneği
  • Example#4283 - - stream_socket_pair örneği
  • Example#4284 - - stream_socket_recvfrom örneği
  • Example#4285 - - stream_socket_sendto örneği
  • Example#4286 - - TCP sunucu soketlerinin kullanımı
  • Example#4287 - - UDP sunucu soketlerinin kullanımı
  • Example#4288 - - stream_socket_shutdown örneği
  • Example#4289 - - Bir akım sarmalayıcının etkin kılınması
  • Example#4290 - - PHP 4.3.x'te tidy kurulumu
  • Example#4291 - - Temel Tidy Kullanımı
  • Example#4292 - - tidy::getBody örneği
  • Example#4293 - - tidy::cleanrepair örneği
  • Example#4294 - - tidy::__construct örneği
  • Example#4295 - - tidy::diagnose örneği
  • Example#4296 - tidy_get_error_buffer example
  • Example#4297 - - tidy::getConfig örneği
  • Example#4298 - - tidy_getopt örneği
  • Example#4299 - - Tüm seçeneklerin belgelerini ve öntanımlı değerlerini almak
  • Example#4300 - - tidy::getStatus örneği
  • Example#4301 - - tidy::head örneği
  • Example#4302 - - tidy::html örneği
  • Example#4303 - - tidy::parseFile örneği
  • Example#4304 - - tidy::parseString örneği
  • Example#4305 - - tidy::repairFile örneği
  • Example#4306 - - tidy::repairString örneği
  • Example#4307 - - tidy::root örneği
  • Example#4308 - - tidyNode::getParent örneği
  • Example#4309 - - tidyNode::hasChildren örneği
  • Example#4310 - - tidyNode::hasSiblings örneği
  • Example#4311 - - Karışık bir HTML belgeden ASP kodunu çıkarmak
  • Example#4312 - - Karışık bir HTML belgeden açıklamaları çıkarmak
  • Example#4313 - - Karışık bir HTML belgeden HTML kodunu çıkarmak
  • Example#4314 - - Karışık bir HTML belgeden JSTE kodunu çıkarmak
  • Example#4315 - - Karışık bir HTML belgeden PHP kodunu çıkarmak
  • Example#4316 - - Karışık bir HTML belgeden metni çıkarmak
  • Example#4317 - - ob_tidyhandler örneği
  • Example#4318 - - tidy_access_count örneği
  • Example#4319 - - tidy_config_count örneği
  • Example#4320 - - tidy_error_count örneği
  • Example#4321 - - tidy_get_output örneği
  • Example#4322 - - tidy_setopt örneği
  • Example#4323 - - tidy_warning_count örneği
  • Example#4324 - - Açıklamaları simgeleştirici ile ayıklamak
  • Example#4325 - - token_get_all örnekleri
  • Example#4326 - - token_name örneği
  • Example#4327 - - base64_decode örneği
  • Example#4328 - - base64_encode örneği
  • Example#4329 - - get_headers örneği
  • Example#4330 - - get_meta_tags bunları çözümler
  • Example#4331 - - get_meta_tags örneği
  • Example#4332 - - http_build_query basit kullanımı
  • Example#4333 - - Sayısal indisli elemanlarla http_build_query
  • Example#4334 - - http_build_query ve çok boyutlu diziler
  • Example#4335 - - http_build_query ve bir nesne
  • Example#4336 - - parse_url örneği
  • Example#4337 - - rawurldecode örneği
  • Example#4338 - - Bir FTP URL'sinde parola belirtmek
  • Example#4339 - - Başka bir rawurlencode örneği
  • Example#4340 - - urldecode örneği
  • Example#4341 - - urlencode örneği
  • Example#4342 - - urlencode ve htmlentities örneği
  • Example#4343 - Basic Javascript execution
  • Example#4344 - Yaml Example
  • Example#4345 - Parse callback example
  • Example#4346 - Emit callback example
  • Example#4347 - yaml_emit example
  • Example#4348 - yaml_parse example
  • Example#4349 - A classic Application directory layout
  • Example#4350 - Entry
  • Example#4351 - Rewrite rule
  • Example#4352 - Application config
  • Example#4353 - Default controller
  • Example#4354 - Default view template
  • Example#4355 - Run the Applicatioin
  • Example#4356 - An PHP array example
  • Example#4357 - An ini file example
  • Example#4358 - A Bootstrapexample
  • Example#4359 - Yaf_Application::bootstrapexample
  • Example#4360 - Yaf_Application::clearLastErrorexample
  • Example#4361 - A ini config file example
  • Example#4362 - Yaf_Application::__constructexample
  • Example#4363 - Yaf_Application::__constructexample
  • Example#4364 - Yaf_Application::environexample
  • Example#4365 - Yaf_Application::executeexample
  • Example#4366 - Yaf_Application::getConfigexample
  • Example#4367 - Yaf_Application::getDispatcherexample
  • Example#4368 - Yaf_Application::getLastErrorMsgexample
  • Example#4369 - Yaf_Application::getLastErrorNoexample
  • Example#4370 - Yaf_Application::getModulesexample
  • Example#4371 - Bootstrap example
  • Example#4372 - Yaf_Dispatcher::autoRenderexample
  • Example#4373 - Yaf_Dispatcher::catchExceptionexample
  • Example#4374 - Yaf_Dispatcher::registerPluginexample
  • Example#4375 - A custom View engineexample
  • Example#4376 - Yaf_Dispatcher::setViewexample
  • Example#4377 - Yaf_Dispatcher::throwexceptionexample
  • Example#4378 - Yaf_Dispatcher::throwexceptionexample
  • Example#4379 - Yaf_Config_Iniexample
  • Example#4380 - define action in a separate file
  • Example#4381 - Dummy_action.php
  • Example#4382 - Yaf_Controller_Abstract::forwardexample
  • Example#4383 - Yaf_Action_Abstract::executeexample
  • Example#4384 - Yaf_Action_Abstract::executeexample
  • Example#4385 - Yaf_View_Simple::assignexample
  • Example#4386 - templateexample
  • Example#4387 - Yaf_View_Simple::assignRefexample
  • Example#4388 - templateexample
  • Example#4389 - Yaf_View_Simple::clearexample
  • Example#4390 - Yaf_View_Simple::__constructorexample
  • Example#4391 - Yaf_View_Simple::__setexample
  • Example#4392 - Config example
  • Example#4393 - Register localnamespace
  • Example#4394 - Load class example
  • Example#4395 - Load namespace class example
  • Example#4396 - MVC class loading example
  • Example#4397 - MVC class distinctions
  • Example#4398 - MVC loading example
  • Example#4399 - Yaf_Loader::registerLocalNamespaceexample
  • Example#4400 - Plugin example
  • Example#4401 - Yaf_Plugin_Abstract::routerShutdownexample
  • Example#4402 - Yaf_Response_Abstract::appendBodyexample
  • Example#4403 - Yaf_Response_Abstract::getBodyexample
  • Example#4404 - Yaf_Response_Abstract::prependBodyexample
  • Example#4405 - Yaf_Response_Abstract::responseexample
  • Example#4406 - Yaf_Response_Abstract::setBodyexample
  • Example#4407 - Yaf_Route_Map::assembleexample
  • Example#4408 - Yaf_Route_Mapexample
  • Example#4409 - Yaf_Route_Mapexample
  • Example#4410 - Yaf_Route_Mapexample
  • Example#4411 - Yaf_Route_Regex::assembleexample
  • Example#4412 - Yaf_Route_Regexexample
  • Example#4413 - Yaf_Route_Regex(as of 2.3.0)example
  • Example#4414 - Yaf_Route_Regex and named capture ground(as of 2.3.0)example
  • Example#4415 - Yaf_Route_Regexexample
  • Example#4416 - Yaf_Route_Rewrite::assembleexample
  • Example#4417 - Yaf_Route_Rewriteexample
  • Example#4418 - Yaf_Route_Rewriteexample
  • Example#4419 - Yaf_Route_Rewrite(as of 2.3.0)example
  • Example#4420 - Rewrite rule for Apache
  • Example#4421 - Rewrite rule for Apache
  • Example#4422 - Rewrite rule for Lighttpd
  • Example#4423 - Rewrite rule for Nginx
  • Example#4424 - Yaf_Route_Static(default route)example
  • Example#4425 - application.iniexample
  • Example#4426 - Yaf_Dispatcher::autoConfigexample
  • Example#4427 - Yaf_Dispatcher::autoRenderexample
  • Example#4428 - Register some routes in Bootstrap
  • Example#4429 - plugin Dummy.php (under application.directory/plugins)
  • Example#4430 - Yaf_Route_Simple::assembleexample
  • Example#4431 - Yaf_Route_Simple::routeexample
  • Example#4432 - Yaf_Route_Simple::routeexample
  • Example#4433 - Yaf_Route_Static::assembleexample
  • Example#4434 - Yaf_Route_Static::routeexample
  • Example#4435 - Yaf_Route_Supervar::assembleexample
  • Example#4436 - Yaf_Route_Supervarexample
  • Example#4437 - Taintexample
  • Example#4438 - Creating a chdb file
  • Example#4439 - Loading and looking up a chdb file
  • Example#4440 - chdb::get example
  • Example#4441 - chdb_create example
  • Example#4442 - - example.com ana sayfasını bir dosyaya aktarmak amacıyla cURL işlevlerinin kullanımı
  • Example#4443 - - Yeni bir cURL oturumunun ilklendirilmesi ve bir HTML sayfasının alınması
  • Example#4444 - - Bir cURL tanıtıcısının kopyalanması
  • Example#4445 - - curl_errno örneği
  • Example#4446 - - curl_error örneği
  • Example#4447 - curl_escape example
  • Example#4448 - - Yeni bir cURL oturumunun ilklendirilmesi ve bir HTML sayfasının alınması
  • Example#4449 - - curl_getinfo örneği
  • Example#4450 - - Yeni bir cURL oturumunun ilklendirilmesi ve bir HTML sayfasının alınması
  • Example#4451 - - curl_multi_add_handle örneği
  • Example#4452 - - curl_multi_close örneği
  • Example#4453 - - curl_multi_exec örneği
  • Example#4454 - - curl_multi_init örneği
  • Example#4455 - curl_multi_strerror example
  • Example#4456 - curl_reset example
  • Example#4457 - - Yeni bir cURL oturumunun ilklendirilmesi ve bir HTML sayfasının alınması
  • Example#4458 - - curl_setopt_array için kendi gerçeklenimimiz
  • Example#4459 - - Yeni bir cURL oturumunun ilklendirilmesi ve bir HTML sayfasının alınması
  • Example#4460 - - Karşıya dosya yüklemek
  • Example#4461 - curl_share_setopt example
  • Example#4462 - curl_share_init example
  • Example#4463 - curl_share_setopt example
  • Example#4464 - curl_errno example
  • Example#4465 - curl_escape example
  • Example#4466 - - curl_version örneği
  • Example#4467 - CURLFile::__construct example
  • Example#4468 - Simple HTTP client
  • Example#4469 - HTTP client using asynchronous DNS resolver
  • Example#4470 - Echo server
  • Example#4471 - SSL echo server
  • Example#4472 - Signal handler
  • Example#4473 - Use libevent's loop to process requests of `eio' extension
  • Example#4474 - Miscellaneous
  • Example#4475 - Simple HTTP server
  • Example#4476 - Simple HTTPS server
  • Example#4477 - OpenSSL connection
  • Example#4478 - EventHttpConnection::makeRequest example
  • Example#4479 - Connection listener based on a UNIX domain socket
  • Example#4480 - Simple SMTP server
  • Example#4481 - Handling SIGTERM signal
  • Example#4482 - Event::addSignal example
  • Example#4483 - Event::addTimer example
  • Example#4484 - EventBase::getFeatures example
  • Example#4485 - EventBase::getMethod example
  • Example#4486 - EventBuffer::search example
  • Example#4487 - EventBufferEvent::connect example
  • Example#4488 - Connect to UNIX domain socket which presumably is served by a server, read response from the server and output it to the console
  • Example#4489 - EventBufferEvent::connectHost example
  • Example#4490 - Buffer event's read callback
  • Example#4491 - EventBufferEvent::getOutput example
  • Example#4492 - EventBufferEvent::sslError example
  • Example#4493 - Simple SMTP server
  • Example#4494 - EventConfig::avoidMethod example
  • Example#4495 - EventConfig::__construct example
  • Example#4496 - EventConfig::requireFeatures example
  • Example#4497 - EventHttp::accept example
  • Example#4498 - EventHttp::addServerAlias example
  • Example#4499 - EventHttp::bind example
  • Example#4500 - Simple HTTP server
  • Example#4501 - EventHttp::setCallback example
  • Example#4502 - EventHttp::setDefaultCallback example
  • Example#4503 - EventHttpConnection::makeRequest example
  • Example#4504 - EventHttpConnection::setCloseCallback example
  • Example#4505 - EventHttpRequest::__construct example
  • Example#4506 - EventHttpRequest::sendError example
  • Example#4507 - EventListener::__construct example
  • Example#4508 - EventSslContext::__construct example
  • Example#4509 - - FTP örneği
  • Example#4510 - - ftp_alloc örneği
  • Example#4511 - - ftp_cdup örneği
  • Example#4512 - - ftp_chdir örneği
  • Example#4513 - - ftp_chmod örneği
  • Example#4514 - - ftp_close örneği
  • Example#4515 - - ftp_connect örneği
  • Example#4516 - - ftp_delete örneği
  • Example#4517 - - ftp_exec örneği
  • Example#4518 - - ftp_fget örneği
  • Example#4519 - - ftp_fput örneği
  • Example#4520 - - ftp_get_option örneği
  • Example#4521 - - ftp_get örneği
  • Example#4522 - - ftp_login örneği
  • Example#4523 - - ftp_mdtm örneği
  • Example#4524 - - ftp_mkdir örneği
  • Example#4525 - - ftp_nb_continue örneği
  • Example#4526 - - ftp_nb_fget örneği
  • Example#4527 - - ftp_nb_fput örneği
  • Example#4528 - - ftp_nb_get örneği
  • Example#4529 - - ftp_nb_get ile indirmeyi devam ettirmek
  • Example#4530 - - ftp_nb_get ile indirmeyi yeni bir dosyanın 100. baytından sürdürmek
  • Example#4531 - - ftp_nb_put örneği
  • Example#4532 - - ftp_nb_put ile yüklemeyi devam ettirmek
  • Example#4533 - - ftp_nlist örneği
  • Example#4534 - - ftp_pasv örneği
  • Example#4535 - - ftp_put örneği
  • Example#4536 - - ftp_pwd örneği
  • Example#4537 - - Bir FTP sunucusuna ftp_raw kullanarak el yordamıyla oturum açmak
  • Example#4538 - - ftp_rawlist örneği
  • Example#4539 - - ftp_rename örneği
  • Example#4540 - - ftp_rmdir örneği
  • Example#4541 - - ftp_set_option örneği
  • Example#4542 - - Bir FTP sunucusuna bir SITE komutu göndermek
  • Example#4543 - - ftp_size örneği
  • Example#4544 - - ftp_ssl_connect örneği
  • Example#4545 - - ftp_systype örneği
  • Example#4546 - Basic Gearman client and worker
  • Example#4547 - Basic Gearman client and worker, background
  • Example#4548 - Basic Gearman client and worker, submitting tasks
  • Example#4549 - Adding two job servers
  • Example#4550 - Add two job servers
  • Example#4551 - Basic submission of two tasks
  • Example#4552 - Basic submission of two tasks with passing application context
  • Example#4553 - Two tasks, one background and one not
  • Example#4554 - A high priority task along with two normal tasks
  • Example#4555 - A low priority task along with two normal tasks
  • Example#4556 - Monitor completion of multiple background tasks
  • Example#4557 - Simple job submission with immediate return
  • Example#4558 - Submitting a job and retrieving incremental status
  • Example#4559 - Submit and monitor a background job
  • Example#4560 - Simple job submission with immediate return
  • Example#4561 - Submitting a job and retrieving incremental status
  • Example#4562 - Get the status of a long running job
  • Example#4563 - Monitor the status of a long running background job
  • Example#4564 - Simple worker making use of extra application context data
  • Example#4565 - Add alternate Gearman servers
  • Example#4566 - Add two job servers
  • Example#4567 - GearmanWorker::setId example
  • Example#4568 - A simple worker with a 5 second timeout
  • Example#4569 - Running worker in non-blocking mode
  • Example#4570 - GearmanWorker::work example
  • Example#4571 - Hypothetical output from gopher://gopher.example.com/
  • Example#4572 - Using gopher_parsedir
  • Example#4573 - Search for all UPnP devices and services.
  • Example#4574 - Implementing light server
  • Example#4575 - Implementing light client
  • Example#4576 - Create new UPnP context and get IP address of the host
  • Example#4577 - Create new UPnP context and get port number
  • Example#4578 - Create new UPnP context and set host path
  • Example#4579 - Create new UPnP context
  • Example#4580 - Create new UPnP context and set callback
  • Example#4581 - Create new UPnP context and start browsing
  • Example#4582 - Create new UPnP context and start browsing
  • Example#4583 - Create new UPnP context and get device info service
  • Example#4584 - Create new UPnP context and get device info service
  • Example#4585 - Retrieve an object
  • Example#4586 - LDAP search example
  • Example#4587 - Complete example with authenticated bind
  • Example#4588 - Using LDAP Bind
  • Example#4589 - Using LDAP Bind Anonymously
  • Example#4590 - Complete example of password check
  • Example#4591 - Example of connecting to LDAP server.
  • Example#4592 - Example of connecting securely to LDAP server.
  • Example#4593 - LDAP pagination
  • Example#4594 - LDAP pagination
  • Example#4595 - ldap-count-entries example
  • Example#4596 - Enumerating all LDAP error messages
  • Example#4597 - Generating and catching an error
  • Example#4598 - Show the list of attributes held for a particular directory entry
  • Example#4599 - Check protocol version
  • Example#4600 - List all values of the "mail" attribute for a directory entry
  • Example#4601 - Produce a list of all organizational units of an organization
  • Example#4602 - Add a telephone number to a contact
  • Example#4603 - Rename a user
  • Example#4604 - Add two e-mail addresses to a user
  • Example#4605 - Change a user's password
  • Example#4606 - Change a user's password (Active Directory)
  • Example#4607 - ldap_parse_result example
  • Example#4608 - LDAP search
  • Example#4609 - Set protocol version
  • Example#4610 - Set server controls
  • Example#4611 - LDAP sort
  • Example#4612 - memcache extension overview example
  • Example#4613 - Using memcache session handler
  • Example#4614 - Memcache::add example
  • Example#4615 - Memcache::addServer example
  • Example#4616 - Memcache::close example
  • Example#4617 - Memcache::connect example
  • Example#4618 - Memcache::decrement example
  • Example#4619 - Memcache::delete example
  • Example#4620 - Memcache::flush example
  • Example#4621 - Memcache::get example
  • Example#4622 - Memcache::getExtendedStats example
  • Example#4623 - Memcache::getServerStatus example
  • Example#4624 - Memcache::getVersion example
  • Example#4625 - Memcache::increment example
  • Example#4626 - Memcache::pconnect example
  • Example#4627 - Memcache::replace example
  • Example#4628 - Memcache::set example
  • Example#4629 - Memcache::set example
  • Example#4630 - Memcache::setCompressThreshold example
  • Example#4631 - Memcache::setServerParams example
  • Example#4632 - Result callback example
  • Example#4633 - Read-through callback example
  • Example#4634 - Memcached::addServer example
  • Example#4635 - Memcached::addServers example
  • Example#4636 - Memcached::append example
  • Example#4637 - Memcached::cas example
  • Example#4638 - Creating a Memcached object
  • Example#4639 - Memcached::decrement example
  • Example#4640 - Memcached::delete example
  • Example#4641 - Memcached::fetch example
  • Example#4642 - Memcached::getDelayed example
  • Example#4643 - Memcached::flush example
  • Example#4644 - Memcached::get example #1
  • Example#4645 - Memcached::get example #2
  • Example#4646 - Memcached::getDelayed example
  • Example#4647 - Memcached::getMulti example
  • Example#4648 - Memcached::GET_PRESERVE_ORDER example
  • Example#4649 - Retrieving Memcached options
  • Example#4650 - Memcached::getResultCode example
  • Example#4651 - Memcached::getResultMessage example
  • Example#4652 - Memcached::getServerByKey example
  • Example#4653 - Memcached::getServerList example
  • Example#4654 - Memcached::getStats example
  • Example#4655 - Memcached::getVersion example
  • Example#4656 - Memcached::increment example
  • Example#4657 - Memcached::prepend example
  • Example#4658 - Memcached::set example
  • Example#4659 - Memcached::setByKey example
  • Example#4660 - Memcached::setMulti example
  • Example#4661 - Setting a Memcached option
  • Example#4662 - Setting Memcached options
  • Example#4663 - mqseries_back example
  • Example#4664 - mqseries_begin example
  • Example#4665 - mqseries_close example
  • Example#4666 - mqseries_cmit example
  • Example#4667 - mqseries_conn example
  • Example#4668 - mqseries_connx example
  • Example#4669 - mqseries_connx example using SSL connection & OCSP Responder URL
  • Example#4670 - mqseries_disc example
  • Example#4671 - mqseries_get example
  • Example#4672 - mqseries_inq example
  • Example#4673 - mqseries_open example
  • Example#4674 - mqseries_put example
  • Example#4675 - mqseries_strerror example
  • Example#4676 - - define_syslog_variables örneği
  • Example#4677 - - dns_get_record kullanımı
  • Example#4678 - - dns_get_record ve DNS_ANY kullanımı
  • Example#4679 - - fsockopen örneği
  • Example#4680 - - UDP bağlantısı kullanımı
  • Example#4681 - - gethostbyaddr örnek
  • Example#4682 - - gethostbyname örneği
  • Example#4683 - - gethostbynamel örneği
  • Example#4684 - - gethostname örneği
  • Example#4685 - - getprotobyname örneği
  • Example#4686 - - getservbyname örneği
  • Example#4687 - header_register_callback example
  • Example#4688 - Unsetting specific header.
  • Example#4689 - Unsetting all previously set headers.
  • Example#4690 - - İndirme söyleşisi
  • Example#4691 - - Yönergelerin önbelleklenmesi
  • Example#4692 - - headers_list kullanım örneği
  • Example#4693 - - headers_sent kullanım örnekleri
  • Example#4694 - Using http_response_code in a web server environment
  • Example#4695 - Using http_response_code in a CLI environment
  • Example#4696 - - inet_ntop örneği
  • Example#4697 - - inet_pton örneği
  • Example#4698 - - ip2long Örneği
  • Example#4699 - - Bir IP adresinin gösterilmesi
  • Example#4700 - - IP doğrulama
  • Example#4701 - - setcookie gönderim örneği
  • Example#4702 - - setcookie silme örneği
  • Example#4703 - - setcookie ve diziler
  • Example#4704 - - syslog kullanımı
  • Example#4705 - Procedural usage of rrd
  • Example#4706 - OO usage of rrd
  • Example#4707 - RRDGraph::setOptions example
  • Example#4708 - Set multiple color options
  • Example#4709 - RRDUpdater::update examples
  • Example#4710 - Creating a connection and connecting to a remote WebSphere MQSeries Messaging Server
  • Example#4711 - Creating a connection and connecting to a remote WebSphere Application Server
  • Example#4712 - Creating a connection and connecting to an MQTT server
  • Example#4713 - Creating a message with a simple text body
  • Example#4714 - Setting a text format property using the default syntax
  • Example#4715 - Setting a property using a type hint
  • Example#4716 - Retrieving a property from a message header
  • Example#4717 - Adding a message to a queue and receiving a response
  • Example#4718 - Creating a durable subscription to a topic
  • Example#4719 - Subscribing to a topic using a WebSphere Platform Messaging (WPM) server
  • Example#4720 - Receiving published data using a durable subscription
  • Example#4721 - Deleting a durable subscription to a topic
  • Example#4722 - Handling an error from a method that returns no result
  • Example#4723 - Handling an error from a method that returns a result
  • Example#4724 - Committing the current unit of work
  • Example#4725 - Creating a connection to a Messaging Server using the IBM MQSeries protocol (WMQ)
  • Example#4726 - Creating a connection with application transaction control and default host and port values
  • Example#4727 - Creating a connection to a Messaging Server using the IBM WebSphere Platform Messaging protocol (WPM)
  • Example#4728 - Creating a connection object and connecting to a Messaging Server
  • Example#4729 - Disconnecting from a Messaging Server
  • Example#4730 - Using the error number and description properties
  • Example#4731 - Using the error number and description properties
  • Example#4732 - Checking whether there us a connection to a Messaging Server
  • Example#4733 - Retrieve the next message from a queue without removing it
  • Example#4734 - Retrieve a specific message from a queue without removing it from the queue
  • Example#4735 - Retrieve all messages in a queue without removing them
  • Example#4736 - Retrieve all messages from a queue with a matching correlation id
  • Example#4737 - Receiving a message from a queue
  • Example#4738 - Receiving a message from a queue with options
  • Example#4739 - Receiving a message from a subscription
  • Example#4740 - Removing a message from a queue by message id
  • Example#4741 - Cancelling an in-flight unit of work
  • Example#4742 - Send a message to a queue
  • Example#4743 - Publish a message to a topic
  • Example#4744 - Send a request and receive a response
  • Example#4745 - Turn on debugging output
  • Example#4746 - Turn off debugging output
  • Example#4747 - Subscribe to a topic
  • Example#4748 - Delete a subscription
  • Example#4749 - Setting a text string into the body of a message
  • Example#4750 - Creating a message
  • Example#4751 - Creating a message with a simple text payload
  • Example#4752 - Setting a text format property using the default syntax
  • Example#4753 - Setting a text format property using a type hint
  • Example#4754 - Setting properties as the sender of a message
  • Example#4755 - Retreiving property values from a message
  • Example#4756 - snmp_get_quick_print example
  • Example#4757 - Using snmp_get_valueretrieval
  • Example#4758 - Using snmp_read_mib
  • Example#4759 - Using snmp_set_enum_print
  • Example#4760 - Using snmprealwalk
  • Example#4761 - Using snmp_set_quick_print
  • Example#4762 - Using snmp_set_valueretrieval
  • Example#4763 - Using snmp2_get
  • Example#4764 - Using snmp2_get_next
  • Example#4765 - Using snmp2_real_walk
  • Example#4766 - Using snmp2_set
  • Example#4767 - Using snmp2_set for setting BITS SNMP object id
  • Example#4768 - snm2_pwalk Example
  • Example#4769 - Using snmp3_get
  • Example#4770 - Using snmp3_getnext
  • Example#4771 - Using snmp3_real_walk
  • Example#4772 - Using snmp3_set
  • Example#4773 - Using snmp3_set for setting BITS SNMP object id
  • Example#4774 - snmp3_walk Example
  • Example#4775 - Using snmpget
  • Example#4776 - Using snmpgetnext
  • Example#4777 - Using snmprealwalk
  • Example#4778 - Using snmpset
  • Example#4779 - Using snmpset for setting BITS SNMP object id
  • Example#4780 - snmpwalk Example
  • Example#4781 - snmpwalkoid Example
  • Example#4782 - SNMP::close example
  • Example#4783 - Fetching sysLocation
  • Example#4784 - Single SNMP object
  • Example#4785 - Multiple SNMP objects
  • Example#4786 - SNMP::getErrno example
  • Example#4787 - SNMP::getError example
  • Example#4788 - Single SNMP object
  • Example#4789 - Miltiple SNMP objects
  • Example#4790 - Set single SNMP object id
  • Example#4791 - Set multiple values using single SNMP::set call
  • Example#4792 - Using SNMP::set for setting BITS SNMP object id
  • Example#4793 - SNMP::setSecurity example
  • Example#4794 - SNMP::walk example
  • Example#4795 - suffix_as_key example
  • Example#4796 - - Soket örneği: Basit bir TCP/IP sunucu
  • Example#4797 - - Soket örneği: Basit TCP/IP istemci
  • Example#4798 - - Kaynak adresini belirtmek için socket_bind kullanımı
  • Example#4799 - - socket_create_pair örneği
  • Example#4800 - -socket_create_pair IPC örneği
  • Example#4801 - - socket_get_option örneği
  • Example#4802 - socket_import_stream example
  • Example#4803 - - socket_last_error örneği
  • Example#4804 - - socket_recv örneği
  • Example#4805 - - socket_recvfrom örneği
  • Example#4806 - - socket_select ile NULL kullanımı
  • Example#4807 - - socket_select sonucunu anlamak
  • Example#4808 - - socket_select örneği
  • Example#4809 - - socket_sendto örneği
  • Example#4810 - - socket_set_block örneği
  • Example#4811 - - socket_set_nonblock örneği
  • Example#4812 - - socket_set_option örneği
  • Example#4813 - - socket_strerror örneği
  • Example#4814 - Authenticating with a ssh agent
  • Example#4815 - - Genel konak anahtarlı kimlik doğrulama
  • Example#4816 - - Kimlik doğrulama yöntemlerinin öğrenilmesi
  • Example#4817 - - Parolalı kimlik doğrulama
  • Example#4818 - - Genel anahtarlı kimlik doğrulama
  • Example#4819 - - ssh2_connect örneği
  • Example#4820 - - Karşıda bir komut çalıştırmak
  • Example#4821 - - Bir kabuk açıp kabukla ilgili standart hataya erişmek
  • Example#4822 - - Parmakizini karşılaştırmak
  • Example#4823 - - Müzakere yöntemlerini öğrenmek
  • Example#4824 - - ssh2_publickey_add örneği
  • Example#4825 - - ssh2_publickey_list örneği
  • Example#4826 - - SCP üzerinden dosya indirmek
  • Example#4827 - - SCP üzerinden karşıya dosya yükleme
  • Example#4828 - Changing the mode of a file on a remote server
  • Example#4829 - - SFTP üzerinden bir sembolik bağın durum bilgisini almak
  • Example#4830 - - Karşıda bir dizin oluşturmak
  • Example#4831 - - Bir sembolik bağı okumak
  • Example#4832 - - Bir dosya yolunun çözümlenmesi
  • Example#4833 - - SFTP üzerinden bır dosyanın ismini değiştirmek
  • Example#4834 - - Uzak sunucudan bir dizini silmek
  • Example#4835 - - SFTP üzerinden bir dosyanın durum bilgisini almak
  • Example#4836 - - Karşıya bir sembolik bağ oluşturmak
  • Example#4837 - - Karşıdan bir dosya silmek
  • Example#4838 - - SFTP üzerinden bir dosya açmak
  • Example#4839 - - Bir kabuk oturumunun açılması
  • Example#4840 - - Belli bir konağa bir tünel açmak
  • Example#4841 - Nesne yönelimli kullanım
  • Example#4842 - Yordamsal kullanım
  • Example#4843 - stomp_connect_error example
  • Example#4844 - stomp_version example
  • Example#4845 - Nesne yönelimli kullanım
  • Example#4846 - Yordamsal kullanım
  • Example#4847 - Nesne yönelimli kullanım
  • Example#4848 - Yordamsal kullanım
  • Example#4849 - Nesne yönelimli kullanım
  • Example#4850 - Yordamsal kullanım
  • Example#4851 - Nesne yönelimli kullanım
  • Example#4852 - Yordamsal kullanım
  • Example#4853 - Nesne yönelimli kullanım
  • Example#4854 - Yordamsal kullanım
  • Example#4855 - Nesne yönelimli kullanım
  • Example#4856 - Yordamsal kullanım
  • Example#4857 - Nesne yönelimli kullanım
  • Example#4858 - Yordamsal kullanım
  • Example#4859 - Nesne yönelimli kullanım
  • Example#4860 - Yordamsal kullanım
  • Example#4861 - Nesne yönelimli kullanım
  • Example#4862 - Yordamsal kullanım
  • Example#4863 - Train from array
  • Example#4864 - Train from a file
  • Example#4865 - svn_add example
  • Example#4866 - Default authentication example
  • Example#4867 - svn_blame example
  • Example#4868 - Basic example
  • Example#4869 - Basic example
  • Example#4870 - Basic example
  • Example#4871 - Basic example
  • Example#4872 - Basic example
  • Example#4873 - Basic example
  • Example#4874 - Diffing two revisions of a repository path
  • Example#4875 - Portably diffing two local files
  • Example#4876 - svn_export example
  • Example#4877 - Basic example
  • Example#4878 - svn_log example
  • Example#4879 - svn_ls example
  • Example#4880 - Basic example
  • Example#4881 - Basic example
  • Example#4882 - - localhost'tan tüm bağlantıları yasaklamak
  • Example#4883 - Ban an URL
  • Example#4884 - Get statistic snapshot
  • Example#4885 - Read varnish shared memory log
  • Example#4886 - VarnishAdmin::__construct example
  • Example#4887 - - Unix üzerinde YAZ destekli PHP 4 kurulumu
  • Example#4888 - YAZ kullanarak paralel arama
  • Example#4889 - - CCL yapılandırması
  • Example#4890 - - CCL çözümlemesi
  • Example#4891 - - Kayıt Güncelleme
  • Example#4892 - - GRS-1 kaydı için bir dizi
  • Example#4893 - - MARCXML ile çalışma
  • Example#4894 - - Başlıkları tarayan PHP işlevi
  • Example#4895 - - Sorgu örnekleri - Aşağıdaki gibi basit ifadeleri aratabilirsiniz
  • Example#4896 - - Sıralama kuralları
  • Example#4897 - Example for NIS errors
  • Example#4898 - Example for the NIS first
  • Example#4899 - Example for the default domain
  • Example#4900 - Example for the NIS master
  • Example#4901 - Example for NIS match
  • Example#4902 - Example for NIS next
  • Example#4903 - Example for the NIS order
  • Example#4904 - A ZMQContext example
  • Example#4905 - A ZMQContext example
  • Example#4906 - A ZMQContext example
  • Example#4907 - A ZMQSocket example
  • Example#4908 - A send/recv example
  • Example#4909 - A ZMQPoll example
  • Example#4910 - Zookeeper::addAuth example
  • Example#4911 - Zookeeper::create example
  • Example#4912 - Zookeeper::delete example
  • Example#4913 - Zookeeper::exists example
  • Example#4914 - Zookeeper::get example
  • Example#4915 - Zookeeper::getAcl example
  • Example#4916 - Zookeeper::set example
  • Example#4917 - Zookeeper::setAcl example
  • Example#4918 - Zookeeper::setDebugLevel example
  • Example#4919 -
  • Example#4920 - udm_api_version example
  • Example#4921 - udm_cat_listexample
  • Example#4922 - Specifying path to the current category in the following format: '> Root > Sport > Auto > Ferrari'
  • Example#4923 - udm_load_ispell_data example
  • Example#4924 - udm_load_ispell_data example
  • Example#4925 - solr_get_version example
  • Example#4926 - Contents of the BootStrap file
  • Example#4927 - Adding a document to the index
  • Example#4928 - Merging one document into another document
  • Example#4929 - Searching for documents - SolrObject responses
  • Example#4930 - Searching for documents - SolrDocument responses
  • Example#4931 - Simple TermsComponent example - basic
  • Example#4932 - Simple TermsComponent example - using a prefix
  • Example#4933 - Simple TermsComponent example - specifying a minimum frequency
  • Example#4934 - Simple Facet Example
  • Example#4935 - Simple Facet Example - with optional field override for mincount
  • Example#4936 - Facet Date Example
  • Example#4937 - Connecting to SSL-Enabled Server
  • Example#4938 - Collapsing a SolrQuery
  • Example#4939 - Solr Real Time Get (RTG) example SolrClient::getById
  • Example#4940 - SolrInputDocument::addChildDocument example
  • Example#4941 - SolrInputDocument::addChildDocuments example
  • Example#4942 - SolrDocument::toArray example
  • Example#4943 - SolrObject::__construct example
  • Example#4944 - SolrObject::offsetUnset example
  • Example#4945 - SolrClient::addDocument example
  • Example#4946 - SolrClient::addDocument example 2
  • Example#4947 - SolrClient::addDocuments example
  • Example#4948 - SolrClient::__construct example
  • Example#4949 - SolrQuery::deleteByQuery example
  • Example#4950 - SolrClient::getById example
  • Example#4951 - SolrClient::getByIds example
  • Example#4952 - SolrClient::ping example
  • Example#4953 - SolrClient::query example
  • Example#4954 - SolrClient::request example
  • Example#4955 - SolrClient::setResponseWriter example
  • Example#4956 - SolrParams::setParam example
  • Example#4957 - SolrQuery::addFacetField example
  • Example#4958 - SolrQuery::addFacetField example
  • Example#4959 - SolrQuery::addFilterQuery example
  • Example#4960 - SolrQuery::addGroupSortField example
  • Example#4961 - SolrQuery::collapse example
  • Example#4962 - SolrQuery::setExpand example
  • Example#4963 - SolrDisMaxQuery::addBigramPhraseField example
  • Example#4964 - SolrDisMaxQuery::addBoostQuery example
  • Example#4965 - SolrDisMaxQuery::addPhraseField example
  • Example#4966 - SolrDisMaxQuery::addQueryField example
  • Example#4967 - SolrDisMaxQuery::addTrigramPhraseField example
  • Example#4968 - SolrDisMaxQuery::addUserField example
  • Example#4969 - SolrDisMaxQuery::__construct example
  • Example#4970 - SolrDisMaxQuery::removeBigramPhraseField example
  • Example#4971 - SolrDisMaxQuery::removeBoostQuery example
  • Example#4972 - SolrDisMaxQuery::removePhraseField example
  • Example#4973 - SolrDisMaxQuery::removeQueryField example
  • Example#4974 - SolrDisMaxQuery::removeTrigramPhraseField example
  • Example#4975 - SolrDisMaxQuery::removeUserField example
  • Example#4976 - SolrDisMaxQuery::setBigramPhraseFields example
  • Example#4977 - SolrDisMaxQuery::setBigramPhraseSlop example
  • Example#4978 - SolrDisMaxQuery::setBoostFunction example
  • Example#4979 - SolrDisMaxQuery::setBoostQuery example
  • Example#4980 - SolrDisMaxQuery::setMinimumMatch example
  • Example#4981 - SolrDisMaxQuery::setPhraseFields example
  • Example#4982 - SolrDisMaxQuery::setPhraseSlop example
  • Example#4983 - SolrDisMaxQuery::setQueryAlt example
  • Example#4984 - SolrDisMaxQuery::setQueryPhraseSlop example
  • Example#4985 - SolrDisMaxQuery::setTieBreaker example
  • Example#4986 - SolrDisMaxQuery::setTrigramPhraseFields example
  • Example#4987 - SolrDisMaxQuery::setTrigramPhraseSlop example
  • Example#4988 - SolrDisMaxQuery::setUserFields example
  • Example#4989 - SolrDisMaxQuery::useDisMaxQueryParser example
  • Example#4990 - SolrDisMaxQuery::useEDisMaxQueryParser example
  • Example#4991 - SolrCollapseFunction::__construct example
  • Example#4992 - SolrCollapseFunction::setHint example
  • Example#4993 - SolrCollapseFunction::setMax example
  • Example#4994 - Basic usage example
  • Example#4995 - Basic search query
  • Example#4996 - A Swish::__construct example
  • Example#4997 - Basic Swish::getMetaList example
  • Example#4998 - Basic Swish::getPropertyList example
  • Example#4999 - Basic Swish::prepare example
  • Example#5000 - Basic Swish::query example
  • Example#5001 - Basic SwishResult::stem example
  • Example#5002 - Basic SwishResults::getParsedWords example
  • Example#5003 - Basic SwishResults::nextResult example
  • Example#5004 - Basic SwishResults::seekResult example
  • Example#5005 - Basic SwishSearch::execute example
  • Example#5006 - Basic SwishSearch::resetLimit example
  • Example#5007 - Basic SwishSearch::setLimit example
  • Example#5008 - Basic SwishSearch::setPhraseDelimiter example
  • Example#5009 - Basic SwishSearch::setSort example
  • Example#5010 - Basic SwishSearch::setStructure example
  • Example#5011 - - .htaccess kullanarak PHP yorumlamasının bir dizinde kapatılması
  • Example#5012 - - apache_get_modules örneği
  • Example#5013 - - apache_get_version örneği
  • Example#5014 - - apache_getenv örneği
  • Example#5015 - - apache_lookup_uri örneği
  • Example#5016 - PHP ve Perl arasında bilgi aktarımı
  • Example#5017 - - access.log dosyasındaki oturum değerleri
  • Example#5018 - - apache_request_headers örneği
  • Example#5019 - - apache_response_headers örneği
  • Example#5020 - - apache_setenv ile bir Apache ortam değişkenini atamak
  • Example#5021 - - getallheaders örneği
  • Example#5022 - nsapi_request_headers example
  • Example#5023 - - Bir değişkeni $_SESSION ile kayıt altına almak
  • Example#5024 - - register_globals etkin değilken $_SESSION ile bir değişkeni tanımsız yapmak
  • Example#5025 - - Tek bir kullanıcının sayfa erişimlerinin sayılması
  • Example#5026 - Example information
  • Example#5027 - - session_cache_expire örneği
  • Example#5028 - - session_cache_limiter örneği
  • Example#5029 - session_create_id example with session_regenerate_id
  • Example#5030 - - Bir oturumun $_SESSION ile yokedilmesi
  • Example#5031 - session_gc example for task managers like cron
  • Example#5032 - session_gc example for user accessible script
  • Example#5033 - - session_name örneği
  • Example#5034 - - session_regenerate_id örneği
  • Example#5035 - - session_set_save_handler örneği
  • Example#5036 - - Bir oturum örneği: sayfa1.php
  • Example#5037 - - Bir oturum örneği: sayfa2.php
  • Example#5038 - Using SessionHandler to add encryption to internal PHP save handlers.
  • Example#5039 - Example using SessionHandlerInterface
  • Example#5040 - - bbcode_add_smiley örneği
  • Example#5041 - - bbcode_create örneği
  • Example#5042 - - bbcode_set_arg_parser örneği
  • Example#5043 - - bbcode_set_flags örneği
  • Example#5044 - - Geçerli şablon örnekleri
  • Example#5045 - - Geçersiz şablon örnekleri
  • Example#5046 - - preg_filter ile preg_replace işlevini karşılaştırma örneği
  • Example#5047 - - preg_grep örneği
  • Example#5048 - - preg_last_error örneği
  • Example#5049 - - Bir metinden telefon numaralarının toplanması
  • Example#5050 - - HTML etiketlerini bulmak (tamahkarca)
  • Example#5051 - İsimli alt şablon kullanımı
  • Example#5052 - - Metin içinde "php" dizgesini bulmak
  • Example#5053 - - "cebir" sözcüğünü bulmak
  • Example#5054 - - Bir adresten alan ismini çekip almak
  • Example#5055 - - İsimli alt şablon kullanımı
  • Example#5056 - - preg_quote örneği
  • Example#5057 - - Bir metnin içindeki bir kelimeyi vurgulamak
  • Example#5058 - preg_replace_callback_array example
  • Example#5059 - preg_replace_callback ve create_function
  • Example#5060 - - 1. preg_replace_callback örneği
  • Example#5061 - - 2. preg_replace_callback örneği
  • Example#5062 - - Ardından bir sayı gelen geriye gönderim kullanımı
  • Example#5063 - - preg_replace ile indisli dizi kullanımı
  • Example#5064 - - Çeşitli değerlerin değiştirilmesi
  • Example#5065 - - 'e' değiştiricisinin kullanımı
  • Example#5066 - - Boşluk ayıklama
  • Example#5067 - - sayı değiştirgesinin kullanımı
  • Example#5068 - - preg_split örneği
  • Example#5069 - - Bir dizgeyi karakterlerine bölmek
  • Example#5070 - - Bir dizgeyi sözcüklerine ayırıp başlangıçlarıyla döndürmek
  • Example#5071 - Düzenli İfade Örnekleri
  • Example#5072 - - ereg_replace örneği - 1
  • Example#5073 - - ereg_replace örneği - 2
  • Example#5074 - - URL'den bağlantı oluşturma
  • Example#5075 - - ereg örneği
  • Example#5076 - - Arama sonuçlarını göster
  • Example#5077 - - eregi örneği
  • Example#5078 - - split örneği - 1
  • Example#5079 - - split örneği - 2
  • Example#5080 - - spliti örneği
  • Example#5081 - - sql_regcase örneği
  • Example#5082 - - addcslashes örneği
  • Example#5083 - - addslashes örneği
  • Example#5084 - - chr örneği
  • Example#5085 - - chunk_split örneği
  • Example#5086 - - convert_uudecode örneği
  • Example#5087 - - convert_uuencode örneği
  • Example#5088 - - count_chars örneği
  • Example#5089 - - Bir crc32 sağlamasının gösterilmesi
  • Example#5090 - - crypt örnekleri
  • Example#5091 - - htpasswd ile crypt kullanımı
  • Example#5092 - - crypt işlevinin farklı şifreleme türleri ile kullanımı
  • Example#5093 - - echo örnekleri
  • Example#5094 - - explode örneği
  • Example#5095 - - sınır değiştirgesi örnekleri
  • Example#5096 - - fprintf: Sıfır dolgulu tamsayılar
  • Example#5097 - - fprintf: para biçemleme
  • Example#5098 - - Dönüşüm tablosu örneği
  • Example#5099 - hex2bin example
  • Example#5100 - - HTML öğelerinin karakterlere dönüştürülmesi
  • Example#5101 - - htmlentities örneği
  • Example#5102 - - htmlspecialchars_decode örneği
  • Example#5103 - - htmlspecialchars örneği
  • Example#5104 - - implode örneği
  • Example#5105 - - lcfirst örneği
  • Example#5106 - - levenshtein örneği
  • Example#5107 - - localeconv örneği
  • Example#5108 - - ltrim örneği
  • Example#5109 - - md5_fileörneği
  • Example#5110 - - md5 örneği
  • Example#5111 - - money_format örneği
  • Example#5112 - - nl2br örneği
  • Example#5113 - - xhtml değiştirgesi kullanımı
  • Example#5114 - - number_format örneği
  • Example#5115 - - ord örneği
  • Example#5116 - - parse_str kullanımı
  • Example#5117 - - print örnekleri
  • Example#5118 - - rtrim örneği
  • Example#5119 - - setlocale örnekleri
  • Example#5120 - - Windows için setlocale örnekleri
  • Example#5121 - - sha1_file örneği
  • Example#5122 - - sha1 örneği
  • Example#5123 - - soundex örnekleri
  • Example#5124 - - Değiştirge takaslama
  • Example#5125 - - Değiştirge takaslama
  • Example#5126 - - Değiştirge takaslama
  • Example#5127 - - Değiştirge takaslama
  • Example#5128 - - Çeşitli printförnekleri
  • Example#5129 - - printf dizge belirtimleri
  • Example#5130 - - sprintf ve sıfır dolgulu tamsayılar
  • Example#5131 - - sprintf ve para biçemleme
  • Example#5132 - - sprintf ve bilimsel gösterim
  • Example#5133 - - sscanf örneği
  • Example#5134 - - Seçimlik değiştirgelerle sscanf kullanımı
  • Example#5135 - - str_ireplace örneği
  • Example#5136 - - str_pad örneği
  • Example#5137 - - str_repeat örneği
  • Example#5138 - - Basit str_replace örnekleri
  • Example#5139 - - str_replacestr_replace ile ilgili olası sorunlar
  • Example#5140 - - str_rot13 örneği
  • Example#5141 - - str_shuffle örneği
  • Example#5142 - - str_split örneği
  • Example#5143 - - str_word_count örneği
  • Example#5144 - - strcasecmp örneği
  • Example#5145 - - strip_tags örneği
  • Example#5146 - - stripos örnekleri
  • Example#5147 - - stripslashes örneği
  • Example#5148 - - Dizi üzerinde stripslashes kullanımı
  • Example#5149 - - stristr örneği
  • Example#5150 - Bir dizgenin varlığına bakmak
  • Example#5151 - - Dizge olmayan iğne kullanımı
  • Example#5152 - - strlen örneği
  • Example#5153 - - strpbrk örneği
  • Example#5154 - - Aynılık işlecinin (===) kullanımı
  • Example#5155 - - Farklılık işlecinin (!==) kullanımı
  • Example#5156 - - Bir başlangıç kullanımı
  • Example#5157 - - strrchr örneği
  • Example#5158 - - strrev örneği
  • Example#5159 - - strripos örneği
  • Example#5160 - - strspn örneği
  • Example#5161 - - strstr örneği
  • Example#5162 - - strtok örneği
  • Example#5163 - - Eski strtok davranışı
  • Example#5164 - Yeni strtok davranışı
  • Example#5165 - - strtolower örneği
  • Example#5166 - - strtoupper örneği
  • Example#5167 - - strtr örneği
  • Example#5168 - - İki değiştirgeli strtr örneği
  • Example#5169 - - substr_compare örneği
  • Example#5170 - - substr_count örneği
  • Example#5171 - - substr_replace örneği
  • Example#5172 - - Negatif başlangıç kullanımı
  • Example#5173 - - Negatif uzunluk kullanımı
  • Example#5174 - - Basit substr kullanımı
  • Example#5175 -
  • Example#5176 - - trim işlevinin kullanımı
  • Example#5177 - - trim işlevini dizi değerlerine uygulama
  • Example#5178 - - ucfirst örneği
  • Example#5179 - - ucwords örneği
  • Example#5180 - vfprintf: sıfır dolgulu tamsayılar
  • Example#5181 - - vprintf: sıfır dolgulu tamsayılar
  • Example#5182 - - vsprintf: sıfır dolgulu tamsayılar
  • Example#5183 - - wordwrap örneği
  • Example#5184 - - Kesmeli wordwrap örneği
  • Example#5185 - - array_change_key_case örneği
  • Example#5186 - - array_chunk örneği
  • Example#5187 - Get the column of first names from a recordset
  • Example#5188 - Get the column of last names from a recordset, indexed by the "id" column
  • Example#5189 - Get the column of usernames from the public "username" property of an object
  • Example#5190 - Get the column of names from the private "name" property of an object using the magic __get method.
  • Example#5191 - - array_combine örneği
  • Example#5192 - - array_count_values örneği
  • Example#5193 - - array_diff_assoc örneği - 1
  • Example#5194 - - array_diff_assoc örneği - 2
  • Example#5195 - - array_diff_key örneği
  • Example#5196 - - array_diff_uassoc örneği
  • Example#5197 - - array_diff_ukey örneği
  • Example#5198 - - array_diff örneği
  • Example#5199 - - array_fill_keys örneği
  • Example#5200 - - array_fill örneği
  • Example#5201 - - array_filter örneği
  • Example#5202 - - işlevsiz array_filter örneği
  • Example#5203 - array_filter ile seçenek kullanımı
  • Example#5204 - - array_flip örneği
  • Example#5205 - - Kayıplı array_flip örneği
  • Example#5206 - - array_intersect_assoc örneği
  • Example#5207 - - array_intersect_key örneği
  • Example#5208 - - array_intersect_uassoc örneği
  • Example#5209 - - array_intersect_ukey örneği
  • Example#5210 - - array_intersect örneği
  • Example#5211 - - array_key_exists örneği
  • Example#5212 - - array_key_exists işlevine karşı isset
  • Example#5213 - - array_keys örneği
  • Example#5214 - - array_map örneği
  • Example#5215 - - Lamda işlevi kullanan array_map örneği (PHP 5.3.0 ve sonrası)
  • Example#5216 - - Birden fazla diziyle array_map örneği
  • Example#5217 - - Bir diziler dizisi oluşturmak
  • Example#5218 - - Dizgesel anahtarlarla array_map örneği
  • Example#5219 - - array_merge_recursive örneği
  • Example#5220 - - array_merge örneği
  • Example#5221 - - Basit array_merge örneği
  • Example#5222 - - array türünde olmayan dizilerle array_merge
  • Example#5223 - - Çok sayıda diziyi sıralamak
  • Example#5224 - - Çok boyutlu diziyi sıralamak
  • Example#5225 - - Veritabanı sonuçlarının sıralanması
  • Example#5226 - - Harf büyüklüğüne duyarsız sıralama
  • Example#5227 - - array_pad örneği
  • Example#5228 - - array_pop örneği
  • Example#5229 - - array_product örneği
  • Example#5230 - - array_push örneği
  • Example#5231 - - array_rand örneği
  • Example#5232 - - array_reduce örneği
  • Example#5233 - - array_replace_recursive örneği
  • Example#5234 - - array_replace_recursiveve ardışık işlem
  • Example#5235 - - array_replace örneği
  • Example#5236 - - array_reverse örneği
  • Example#5237 - - array_search örneği
  • Example#5238 - - array_shift örneği
  • Example#5239 - - array_slice örnekleri
  • Example#5240 - - array_splice örnekleri
  • Example#5241 - - array_splice örnekleri
  • Example#5242 - - array_sum örnekleri
  • Example#5243 - - array_udiff_assoc örneği
  • Example#5244 - - array_udiff_uassoc örneği
  • Example#5245 - - array_udiff örneği
  • Example#5246 - - array_uintersect_assoc örneği
  • Example#5247 - - array_uintersect_uassoc örneği
  • Example#5248 - - array_uintersect örneği
  • Example#5249 - - array_unique örneği
  • Example#5250 - - array_unique ve türler
  • Example#5251 - - array_unshift örneği
  • Example#5252 - - array_values örneği
  • Example#5253 - - array_walk_recursive örneği
  • Example#5254 - - array_walk örneği
  • Example#5255 - - array örneği
  • Example#5256 - array ile özdevinimli indis üretimi
  • Example#5257 - - İlk indisi 1 olan dizi üretimi
  • Example#5258 - - Çift tırnak içine alınmış bir diziye erişim
  • Example#5259 - - arsort örneği
  • Example#5260 - - asort örneği
  • Example#5261 - - compact örneği
  • Example#5262 - - count örneği
  • Example#5263 - - Ardışık count örneği
  • Example#5264 - - current örneği
  • Example#5265 - - each örnekleri
  • Example#5266 - - each ile bir dizinin taranması
  • Example#5267 - - end örneği
  • Example#5268 - - extract örneği
  • Example#5269 - - in_array örneği
  • Example#5270 - - Türe de bakan in_array örneği
  • Example#5271 - - iğnenin bir dizi olduğu in_array örneği
  • Example#5272 - - key örneği
  • Example#5273 - - krsort örneği
  • Example#5274 - - ksort örneği
  • Example#5275 - - list örnekleri
  • Example#5276 - - list kullanım örneği
  • Example#5277 - - İç içe list kullanımı
  • Example#5278 - - Dizi indisleri ile list kullanımı
  • Example#5279 - - natcasesort örneği
  • Example#5280 - - natsort örneği
  • Example#5281 - - next ve şürekası
  • Example#5282 - - prev ve şürekası
  • Example#5283 - - range örnekleri
  • Example#5284 - - reset örneği
  • Example#5285 - - rsort örneği
  • Example#5286 - - shuffle örneği
  • Example#5287 - - sort örneği
  • Example#5288 - - uasort örneği
  • Example#5289 - - uksort örneği
  • Example#5290 - - usort örneği
  • Example#5291 - - usort ve çok boyutlu dizi
  • Example#5292 - - Bir nesnenin üye yöntemini kullanan usort örneği
  • Example#5293 - sınıflar.inc
  • Example#5294 - dnm.php
  • Example#5295 - - call_user_method_array yerine call_user_func_array kullanın
  • Example#5296 - - call_user_method yerine call_user_func kullanın
  • Example#5297 - class_alias example
  • Example#5298 - class_exists example
  • Example#5299 - autoload parameter example
  • Example#5300 - - get_called_class örneği
  • Example#5301 - - get_class_methods örneği
  • Example#5302 - - get_class_vars örneği
  • Example#5303 - - get_class_vars ve etki alanı
  • Example#5304 - - get_class örneği
  • Example#5305 - - Alt sınıftan get_class çağrısı
  • Example#5306 - - get_declared_classes örneği
  • Example#5307 - - get_declared_interfaces örneği
  • Example#5308 - - get_object_vars örneği
  • Example#5309 - - get_parent_class örneği
  • Example#5310 - - interface_exists örneği
  • Example#5311 - - is_a örneği
  • Example#5312 - - PHP 5'teki instanceof işlecinin kullanımı
  • Example#5313 - - is_subclass_of örneği
  • Example#5314 - - method_exists örneği
  • Example#5315 - - Duruk method_exists örneği
  • Example#5316 - - property_exists örneği
  • Example#5317 - - classkit_import örneği
  • Example#5318 - - classkit_method_add örneği
  • Example#5319 - - classkit_method_copy örneği
  • Example#5320 - - classkit_method_redefine örneği
  • Example#5321 - - classkit_method_remove örneği
  • Example#5322 - classkit_method_rename örneği
  • Example#5323 - - ctype_alnum örneği (öntanımlı yerel kullanılarak)
  • Example#5324 - - ctype_alpha örneği (öntanımlı yerel kullanılarak)
  • Example#5325 - - ctype_cntrl örneği
  • Example#5326 - - ctype_digit örneği
  • Example#5327 - - ctype_digit (dizgelerle tamsayıları karşılaştırma) örneği
  • Example#5328 - - ctype_graph örneği
  • Example#5329 - - ctype_lower örneği (öntanımlı yerel kullanılarak)
  • Example#5330 - - ctype_print örneği
  • Example#5331 - - ctype_punct örneği
  • Example#5332 - - ctype_space örneği
  • Example#5333 - - ctype_upper örneği (öntanımlı yereli kullanarak)
  • Example#5334 - - ctype_xdigit örneği
  • Example#5335 - Vector
  • Example#5336 - Map
  • Example#5337 - Ds\Collection::clear example
  • Example#5338 - Ds\Collection::copy example
  • Example#5339 - Ds\Collection::isEmpty example
  • Example#5340 - Ds\Collection::toArray example
  • Example#5341 - Ds\Hashable::hash example
  • Example#5342 - Ds\Sequence::allocate example
  • Example#5343 - Ds\Sequence::apply example
  • Example#5344 - Ds\Sequence::capacity example
  • Example#5345 - Ds\Sequence::contains example
  • Example#5346 - Ds\Sequence::filter example using callback function
  • Example#5347 - Ds\Sequence::filter example without a callback function
  • Example#5348 - Ds\Sequence::find example
  • Example#5349 - Ds\Sequence::first example
  • Example#5350 - Ds\Sequence::get example
  • Example#5351 - Ds\Sequence::get example using array syntax
  • Example#5352 - Ds\Sequence::insert example
  • Example#5353 - Ds\Sequence::join example using a separator string
  • Example#5354 - Ds\Sequence::join example without a separator string
  • Example#5355 - Ds\Sequence::last example
  • Example#5356 - Ds\Sequence::map example
  • Example#5357 - Ds\Sequence::merge example
  • Example#5358 - Ds\Sequence::pop example
  • Example#5359 - Ds\Sequence::push example
  • Example#5360 - Ds\Sequence::reduce with initial value example
  • Example#5361 - Ds\Sequence::reduce without an initial value example
  • Example#5362 - Ds\Sequence::remove example
  • Example#5363 - Ds\Sequence::reverse example
  • Example#5364 - Ds\Sequence::reversed example
  • Example#5365 - Ds\Sequence::rotate example
  • Example#5366 - Ds\Sequence::set example
  • Example#5367 - Ds\Sequence::set example using array syntax
  • Example#5368 - Ds\Sequence::shift example
  • Example#5369 - Ds\Sequence::slice example
  • Example#5370 - Ds\Sequence::sort example
  • Example#5371 - Ds\Sequence::sort example using a comparator
  • Example#5372 - Ds\Sequence::sorted example
  • Example#5373 - Ds\Sequence::sorted example using a comparator
  • Example#5374 - Ds\Sequence::sum integer example
  • Example#5375 - Ds\Sequence::sum float example
  • Example#5376 - Ds\Sequence::unshift example
  • Example#5377 - Ds\Vector::allocate example
  • Example#5378 - Ds\Vector::apply example
  • Example#5379 - Ds\Vector::capacity example
  • Example#5380 - Ds\Vector::clear example
  • Example#5381 - Ds\Vector::__construct example
  • Example#5382 - Ds\Vector::contains example
  • Example#5383 - Ds\Vector::copy example
  • Example#5384 - Ds\Vector::filter example using callback function
  • Example#5385 - Ds\Vector::filter example without a callback function
  • Example#5386 - Ds\Vector::find example
  • Example#5387 - Ds\Vector::first example
  • Example#5388 - Ds\Vector::get example
  • Example#5389 - Ds\Vector::get example using array syntax
  • Example#5390 - Ds\Vector::insert example
  • Example#5391 - Ds\Vector::isEmpty example
  • Example#5392 - Ds\Vector::join example using a separator string
  • Example#5393 - Ds\Vector::join example without a separator string
  • Example#5394 - Ds\Vector::last example
  • Example#5395 - Ds\Vector::map example
  • Example#5396 - Ds\Vector::merge example
  • Example#5397 - Ds\Vector::pop example
  • Example#5398 - Ds\Vector::push example
  • Example#5399 - Ds\Vector::reduce with initial value example
  • Example#5400 - Ds\Vector::reduce without an initial value example
  • Example#5401 - Ds\Vector::remove example
  • Example#5402 - Ds\Vector::reverse example
  • Example#5403 - Ds\Vector::reversed example
  • Example#5404 - Ds\Vector::rotate example
  • Example#5405 - Ds\Vector::set example
  • Example#5406 - Ds\Vector::set example using array syntax
  • Example#5407 - Ds\Vector::shift example
  • Example#5408 - Ds\Vector::slice example
  • Example#5409 - Ds\Vector::sort example
  • Example#5410 - Ds\Vector::sort example using a comparator
  • Example#5411 - Ds\Vector::sorted example
  • Example#5412 - Ds\Vector::sorted example using a comparator
  • Example#5413 - Ds\Vector::sum integer example
  • Example#5414 - Ds\Vector::sum float example
  • Example#5415 - Ds\Vector::toArray example
  • Example#5416 - Ds\Vector::unshift example
  • Example#5417 - Ds\Deque::allocate example
  • Example#5418 - Ds\Deque::apply example
  • Example#5419 - Ds\Deque::capacity example
  • Example#5420 - Ds\Deque::clear example
  • Example#5421 - Ds\Deque::__construct example
  • Example#5422 - Ds\Deque::contains example
  • Example#5423 - Ds\Deque::copy example
  • Example#5424 - Ds\Deque::filter example using callback function
  • Example#5425 - Ds\Deque::filter example without a callback function
  • Example#5426 - Ds\Deque::find example
  • Example#5427 - Ds\Deque::first example
  • Example#5428 - Ds\Deque::get example
  • Example#5429 - Ds\Deque::get example using array syntax
  • Example#5430 - Ds\Deque::insert example
  • Example#5431 - Ds\Deque::isEmpty example
  • Example#5432 - Ds\Deque::join example using a separator string
  • Example#5433 - Ds\Deque::join example without a separator string
  • Example#5434 - Ds\Deque::last example
  • Example#5435 - Ds\Deque::map example
  • Example#5436 - Ds\Deque::merge example
  • Example#5437 - Ds\Deque::pop example
  • Example#5438 - Ds\Deque::push example
  • Example#5439 - Ds\Deque::reduce with initial value example
  • Example#5440 - Ds\Deque::reduce without an initial value example
  • Example#5441 - Ds\Deque::remove example
  • Example#5442 - Ds\Deque::reverse example
  • Example#5443 - Ds\Deque::reversed example
  • Example#5444 - Ds\Deque::rotate example
  • Example#5445 - Ds\Deque::set example
  • Example#5446 - Ds\Deque::set example using array syntax
  • Example#5447 - Ds\Deque::shift example
  • Example#5448 - Ds\Deque::slice example
  • Example#5449 - Ds\Deque::sort example
  • Example#5450 - Ds\Deque::sort example using a comparator
  • Example#5451 - Ds\Deque::sorted example
  • Example#5452 - Ds\Deque::sorted example using a comparator
  • Example#5453 - Ds\Deque::sum integer example
  • Example#5454 - Ds\Deque::sum float example
  • Example#5455 - Ds\Deque::toArray example
  • Example#5456 - Ds\Deque::unshift example
  • Example#5457 - Ds\Map::allocate example
  • Example#5458 - Ds\Map::apply example
  • Example#5459 - Ds\Map::capacity example
  • Example#5460 - Ds\Map::clear example
  • Example#5461 - Ds\Map::__construct example
  • Example#5462 - Ds\Map::copy example
  • Example#5463 - Ds\Map::diff example
  • Example#5464 - Ds\Map::filter example using callback function
  • Example#5465 - Ds\Map::filter example without a callback function
  • Example#5466 - Ds\Map::first example
  • Example#5467 - Ds\Map::get example
  • Example#5468 - Ds\Map::get example using array syntax
  • Example#5469 - Ds\Map::hasKey example
  • Example#5470 - Ds\Map::hasValue example
  • Example#5471 - Ds\Map::intersect example
  • Example#5472 - Ds\Map::isEmpty example
  • Example#5473 - Ds\Map::keys example
  • Example#5474 - Ds\Map::ksort example
  • Example#5475 - Ds\Map::ksort example using a comparator
  • Example#5476 - Ds\Map::ksorted example
  • Example#5477 - Ds\Map::ksorted example using a comparator
  • Example#5478 - Ds\Map::last example
  • Example#5479 - Ds\Map::map example
  • Example#5480 - Ds\Map::merge example
  • Example#5481 - Ds\Map::pairs example
  • Example#5482 - Ds\Map::put example
  • Example#5483 - Ds\Map::put example using objects as keys
  • Example#5484 - Ds\Map::putAll example
  • Example#5485 - Ds\Map::reduce with initial value example
  • Example#5486 - Ds\Map::reduce without an initial value example
  • Example#5487 - Ds\Map::remove example
  • Example#5488 - Ds\Map::reverse example
  • Example#5489 - Ds\Map::reversed example
  • Example#5490 - Ds\Map::skip example
  • Example#5491 - Ds\Map::slice example
  • Example#5492 - Ds\Map::sort example
  • Example#5493 - Ds\Map::sort example using a comparator
  • Example#5494 - Ds\Map::sort example
  • Example#5495 - Ds\Map::sort example using a comparator
  • Example#5496 - Ds\Map::sum integer example
  • Example#5497 - Ds\Map::sum float example
  • Example#5498 - Ds\Map::toArray example
  • Example#5499 - Ds\Map::union example
  • Example#5500 - Ds\Map::values example
  • Example#5501 - Ds\Map::xor example
  • Example#5502 - Ds\Pair::clear example
  • Example#5503 - Ds\Pair::copy example
  • Example#5504 - Ds\Pair::isEmpty example
  • Example#5505 - Ds\Pair::toArray example
  • Example#5506 - Ds\Set::add example using integers
  • Example#5507 - Ds\Set::add example using objects
  • Example#5508 - Ds\Set::allocate example
  • Example#5509 - Ds\Set::capacity example
  • Example#5510 - Ds\Set::clear example
  • Example#5511 - Ds\Set::__construct example
  • Example#5512 - Ds\Set::contains example
  • Example#5513 - Ds\Set::copy example
  • Example#5514 - Ds\Set::diff example
  • Example#5515 - Ds\Set::filter example using callback function
  • Example#5516 - Ds\Set::filter example without a callback function
  • Example#5517 - Ds\Set::first example
  • Example#5518 - Ds\Set::get example
  • Example#5519 - Ds\Set::get example using array syntax
  • Example#5520 - Ds\Set::intersect example
  • Example#5521 - Ds\Set::isEmpty example
  • Example#5522 - Ds\Set::join example using a separator string
  • Example#5523 - Ds\Set::join example without a separator string
  • Example#5524 - Ds\Set::last example
  • Example#5525 - Ds\Set::merge example
  • Example#5526 - Ds\Set::reduce with initial value example
  • Example#5527 - Ds\Set::reduce without an initial value example
  • Example#5528 - Ds\Set::remove example
  • Example#5529 - Ds\Set::reverse example
  • Example#5530 - Ds\Set::reversed example
  • Example#5531 - Ds\Set::slice example
  • Example#5532 - Ds\Set::sort example
  • Example#5533 - Ds\Set::sort example using a comparator
  • Example#5534 - Ds\Set::sorted example
  • Example#5535 - Ds\Set::sorted example using a comparator
  • Example#5536 - Ds\Set::sum integer example
  • Example#5537 - Ds\Set::sum float example
  • Example#5538 - Ds\Set::toArray example
  • Example#5539 - Ds\Set::union example
  • Example#5540 - Ds\Set::xor example
  • Example#5541 - Ds\Stack::clear example
  • Example#5542 - Ds\Stack::__construct example
  • Example#5543 - Ds\Stack::copy example
  • Example#5544 - Ds\Stack::isEmpty example
  • Example#5545 - Ds\Stack::peek example
  • Example#5546 - Ds\Stack::pop example
  • Example#5547 - Ds\Stack::push example
  • Example#5548 - Ds\Stack::toArray example
  • Example#5549 - Ds\Queue::allocate example
  • Example#5550 - Ds\Queue::capacity example
  • Example#5551 - Ds\Queue::clear example
  • Example#5552 - Ds\Queue::__construct example
  • Example#5553 - Ds\Queue::copy example
  • Example#5554 - Ds\Queue::isEmpty example
  • Example#5555 - Ds\Queue::peek example
  • Example#5556 - Ds\Queue::pop example
  • Example#5557 - Ds\Queue::push example
  • Example#5558 - Ds\Queue::toArray example
  • Example#5559 - Ds\PriorityQueue::allocate example
  • Example#5560 - Ds\PriorityQueue::capacity example
  • Example#5561 - Ds\PriorityQueue::clear example
  • Example#5562 - Ds\PriorityQueue::__construct example
  • Example#5563 - Ds\PriorityQueue::copy example
  • Example#5564 - Ds\PriorityQueue::isEmpty example
  • Example#5565 - Ds\PriorityQueue::peek example
  • Example#5566 - Ds\PriorityQueue::pop example
  • Example#5567 - Ds\PriorityQueue::push example
  • Example#5568 - Ds\PriorityQueue::toArray example
  • Example#5569 - Configuring the default filter to act like htmlspecialchars
  • Example#5570 - Configuring the default filter to act like htmlspecialchars
  • Example#5571 - Validating email addresses with filter_var
  • Example#5572 - Validating IP addresses with filter_var
  • Example#5573 - Passing options to filter_var
  • Example#5574 - Sanitizing and validating email addresses
  • Example#5575 - Configuring a default filter
  • Example#5576 - A filter_input_array example
  • Example#5577 - A filter_input example
  • Example#5578 - A filter_list example
  • Example#5579 - A filter_var_array example
  • Example#5580 - A filter_var example
  • Example#5581 - - call_user_func_array örneği
  • Example#5582 - - İsim alanı ismi kullanarak call_user_func_array
  • Example#5583 - - Lamda işlevi kullanımı
  • Example#5584 - - call_user_func örneği ve gönderimler
  • Example#5585 - - call_user_func örneği
  • Example#5586 - - İsim alanı ismi kullanarak call_user_func
  • Example#5587 - - Sınıf yöntemi kullanarak call_user_func
  • Example#5588 - - Lamda işlevi kullanarak call_user_func
  • Example#5589 - - create_function ile isimsiz işlev oluşturmak
  • Example#5590 - - create_function işlevi ile bir genel işlem işlevi oluşturmak
  • Example#5591 - - İsimsiz işlevlerin geriçağırım işlevlerinde kullanımı
  • Example#5592 - forward_static_call_array example
  • Example#5593 - forward_static_call example
  • Example#5594 - - func_get_arg örneği
  • Example#5595 - - PHP 5.3 sonrası func_get_argörneği
  • Example#5596 - - func_get_args örneği
  • Example#5597 - - PHP 5.3 sonrası func_get_argörneği
  • Example#5598 - - func_num_args örneği
  • Example#5599 - - PHP 5.3 sonrası func_get_argörneği
  • Example#5600 - - function_exists örneği
  • Example#5601 - - get_defined_functions örneği
  • Example#5602 - - register_shutdown_function örneği
  • Example#5603 - - register_tick_function örneği
  • Example#5604 - Quickhash Example
  • Example#5605 - Quickhash ArrayAccess Example
  • Example#5606 - Quickhash Iterator Example
  • Example#5607 - Quickhash String Values Example
  • Example#5608 - QuickHashIntSet::add example
  • Example#5609 - QuickHashIntSet::__construct example
  • Example#5610 - QuickHashIntSet::delete example
  • Example#5611 - QuickHashIntSet::exists example
  • Example#5612 - QuickHashIntSet::getSize example
  • Example#5613 - QuickHashIntSet::loadFromFile example
  • Example#5614 - QuickHashIntSet::loadFromString example
  • Example#5615 - QuickHashIntSet::saveToFile example
  • Example#5616 - QuickHashIntSet::saveToString example
  • Example#5617 - QuickHashIntHash::add example
  • Example#5618 - QuickHashIntHash::__construct example
  • Example#5619 - QuickHashIntHash::delete example
  • Example#5620 - QuickHashIntHash::exists example
  • Example#5621 - QuickHashIntHash::get example
  • Example#5622 - QuickHashIntHash::getSize example
  • Example#5623 - QuickHash IntHash file format
  • Example#5624 - QuickHash IntHash file format
  • Example#5625 - QuickHashIntHash::loadFromFile example
  • Example#5626 - QuickHashIntHash::loadFromString example
  • Example#5627 - QuickHashIntHash::saveToFile example
  • Example#5628 - QuickHashIntHash::saveToString example
  • Example#5629 - QuickHashIntHash::set example
  • Example#5630 - QuickHashIntHash::update example
  • Example#5631 - QuickHashStringIntHash::add example
  • Example#5632 - QuickHashStringIntHash::__construct example
  • Example#5633 - QuickHashStringIntHash::delete example
  • Example#5634 - QuickHashStringIntHash::get example
  • Example#5635 - QuickHashStringIntHash::getSize example
  • Example#5636 - QuickHash StringIntHash file format
  • Example#5637 - QuickHash IntHash file format
  • Example#5638 - QuickHashStringIntHash::loadFromFile example
  • Example#5639 - QuickHashStringIntHash::loadFromString example
  • Example#5640 - QuickHashStringIntHash::saveToFile example
  • Example#5641 - QuickHashStringIntHash::saveToString example
  • Example#5642 - QuickHashStringIntHash::set example
  • Example#5643 - QuickHashStringIntHash::update example
  • Example#5644 - QuickHashIntStringHash::add example
  • Example#5645 - QuickHashIntStringHash::__construct example
  • Example#5646 - QuickHashIntStringHash::delete example
  • Example#5647 - QuickHashIntStringHash::get example
  • Example#5648 - QuickHashIntStringHash::getSize example
  • Example#5649 - QuickHash IntString file format
  • Example#5650 - QuickHash IntString file format
  • Example#5651 - QuickHashIntStringHash::loadFromFile example
  • Example#5652 - QuickHashIntStringHash::loadFromString example
  • Example#5653 - QuickHashIntStringHash::saveToFile example
  • Example#5654 - QuickHashIntStringHash::saveToString example
  • Example#5655 - QuickHashIntStringHash::set example
  • Example#5656 - QuickHashIntStringHash::update example
  • Example#5657 - - Reflection eklentisinin kabuktan kullanımı
  • Example#5658 - - Yerleşik sınıfların genişletilmesi
  • Example#5659 - - Temel kullanım örneği
  • Example#5660 - - ReflectionClass::getDocComment örneği
  • Example#5661 - - ReflectionClass::getEndLine örneği
  • Example#5662 - - ReflectionClass::getInterfaceNames örneği
  • Example#5663 - - ReflectionClass::getInterfaces örneği
  • Example#5664 - - ReflectionClass::getName örneği
  • Example#5665 - - ReflectionClass::getNamespaceName örneği
  • Example#5666 - - ReflectionClass::getProperties süzgeç örneği
  • Example#5667 - - ReflectionClass::getShortName örneği
  • Example#5668 - - ReflectionClass::hasConstant örneği
  • Example#5669 - - ReflectionClass::hasMethod örneği
  • Example#5670 - - ReflectionClass::hasProperty örneği
  • Example#5671 - - ReflectionClass::inNamespace örneği
  • Example#5672 - - ReflectionClass::isAbstract örneği
  • Example#5673 - ReflectionClass::isAnonymous example
  • Example#5674 - Basic usage of ReflectionClass::isCloneable
  • Example#5675 - - ReflectionClass::isAbstract örneği
  • Example#5676 - - ReflectionClass::isInstance örneği
  • Example#5677 - - ReflectionClass::isInstantiable örneği
  • Example#5678 - - ReflectionClass::isIterateable örneği
  • Example#5679 - ReflectionExtension::getClasses örneği
  • Example#5680 - ReflectionExtension::getClassNames örneği
  • Example#5681 - ReflectionExtension::getClasses örneği
  • Example#5682 - ReflectionExtension::getDependencies örneği
  • Example#5683 - - ReflectionExtension::getFunctions örneği
  • Example#5684 - - ReflectionExtension::getFunctions örneği
  • Example#5685 - - ReflectionExtension::getName örneği
  • Example#5686 - - ReflectionExtension::getVersion örneği
  • Example#5687 - - ReflectionExtension::info örneği
  • Example#5688 - - ReflectionFunction::__construct örneği
  • Example#5689 - ReflectionFunctionAbstract::getReturnType example
  • Example#5690 - Usage on built-in functions
  • Example#5691 - ReflectionFunctionAbstract::hasReturnType example
  • Example#5692 - Usage on built-in functions
  • Example#5693 - - ReflectionMethod::__construct örneği
  • Example#5694 - - ReflectionMethod::getModifiers örneği
  • Example#5695 - - ReflectionParameter örneği
  • Example#5696 - ReflectionParameter::getType example
  • Example#5697 - ReflectionParameter::hasType example
  • Example#5698 - - ReflectionProperty::__construct örneği
  • Example#5699 - - ReflectionProperty sınıfından private ve protected özelliklerin değerlerini öğrenmek
  • Example#5700 - boolval examples
  • Example#5701 - - debug_zval_dump örneği
  • Example#5702 -
  • Example#5703 -
  • Example#5704 - - Basit bir empty / isset karşılaştırması
  • Example#5705 - - floatval örneği
  • Example#5706 - - get_defined_vars örneği
  • Example#5707 - - get_resource_type örneği
  • Example#5708 - - gettype örneği
  • Example#5709 - - import_request_variables örneği
  • Example#5710 - - intval örnekleri
  • Example#5711 - - Değişken içeriğinin bir dizi olup olmadığının sınanması
  • Example#5712 - - is_bool örnekleri
  • Example#5713 - - is_callable örneği
  • Example#5714 - - is_float örneği
  • Example#5715 - - is_int örneği
  • Example#5716 - - is_null örneği
  • Example#5717 - - is_numeric örnekleri
  • Example#5718 - - is_object örneği
  • Example#5719 - - is_resource örneği
  • Example#5720 - - is_scalar örneği
  • Example#5721 - - is_string örneği
  • Example#5722 - - isset örnekleri
  • Example#5723 - - print_r örneği
  • Example#5724 - - döndür değiştirgeli örnek
  • Example#5725 - - serialize örneği
  • Example#5726 - - settype örneği
  • Example#5727 - - PHP5'in sihirli __toString yöntemini kullanan strval örneği
  • Example#5728 - - unserialize örneği
  • Example#5729 - - unserialize_callback_func örneği
  • Example#5730 - - unset örneği
  • Example#5731 - - (unset) - NULL'a dönüşüm örneği (PHP 5 ve sonrası)
  • Example#5732 - - var_dump örneği
  • Example#5733 - - var_export örnekleri
  • Example#5734 - - PHP 5.1.0'den beri sınıfların çıktılanması
  • Example#5735 - - __set_state kullanımı (PHP 5.1.0'dan beri)
  • Example#5736 -
  • Example#5737 - OAuth::fetch example
  • Example#5738 - OAuth::getAccessToken example
  • Example#5739 - OAuth::getRequestToken example
  • Example#5740 - OAuth::setRequestEngine example
  • Example#5741 - An OAuth::setRsaCertificate example
  • Example#5742 - OAuth::setToken example
  • Example#5743 - OAuthProvider::__construct example
  • Example#5744 - Example OAuthProvider::consumerHandler callback
  • Example#5745 - OAuthProvider::generateToken example
  • Example#5746 - OAuthProvider::is2LeggedEndpoint example
  • Example#5747 - Example OAuthProvider::timestampNonceHandler callback
  • Example#5748 - Example OAuthProvider::tokenHandler callback
  • Example#5749 - A sample SCA component
  • Example#5750 - The structure of an SCA for PHP component
  • Example#5751 - Obtaining a proxy for a local PHP class
  • Example#5752 - Obtaining a proxy for a web service
  • Example#5753 - Calling services
  • Example#5754 - Obtaining a proxy using getService
  • Example#5755 - Making calls on the proxy
  • Example#5756 - StockQuote Service
  • Example#5757 - Generated WSDL
  • Example#5758 - Generated WSDL
  • Example#5759 - location attribute
  • Example#5760 - method with two arguments
  • Example#5761 - types section illustrating named parameters
  • Example#5762 - A Component that uses Data Structures
  • Example#5763 - An SCA::getService example
  • Example#5764 - is_soap_fault example
  • Example#5765 - SOAP's standard method for error reporting is exceptions
  • Example#5766 - SoapClient::__doRequest example
  • Example#5767 - SoapClient::__getFunctions example
  • Example#5768 - SoapClient::__getLastRequest() example
  • Example#5769 - SoapClient::__getLastRequestHeaders() example
  • Example#5770 - SoapClient::__getLastResponse() example
  • Example#5771 - SoapClient::__getLastResponse() example
  • Example#5772 - SoapClient::__getTypes example
  • Example#5773 - SoapClient::__setLocation example
  • Example#5774 - SoapClient::__setSoapHeaders example
  • Example#5775 - Set Multiple Headers
  • Example#5776 - SoapClient::__soapCall example
  • Example#5777 - SoapClient::SoapClient example
  • Example#5778 - SoapServer::addFunction example
  • Example#5779 - SoapServer::getFunctions example
  • Example#5780 - SoapServer::handle example
  • Example#5781 - SoapServer::setPersistence example
  • Example#5782 - SoapServer::SoapServer example
  • Example#5783 - Some examples
  • Example#5784 - Some examples
  • Example#5785 - SoapHeader::SoapHeader example
  • Example#5786 - SoapParam::SoapParam example
  • Example#5787 - SoapVar::SoapVar example
  • Example#5788 - Yar Server Example
  • Example#5789 - Access the server in borwser(GET request)
  • Example#5790 - Yar Client Example
  • Example#5791 - Yar Concurrent Client Example
  • Example#5792 - Yar_Server::__construct example
  • Example#5793 - Yar_Server::handle example
  • Example#5794 - Yar_Client::__call example
  • Example#5795 - Yar_Client::__construct example
  • Example#5796 - Yar_Client::setOpt example
  • Example#5797 - Yar_Concurrent_Client::call example
  • Example#5798 - Yar_Concurrent_Client::loop example
  • Example#5799 - Yar_Concurrent_Client::reset example
  • Example#5800 - Yar_Server_Exception::getType example
  • Example#5801 - Yar_Client_Exception::getType example
  • Example#5802 - - XMLRPC istemci işlevleri örneği
  • Example#5803 - - xmlrpc_set_type örneği
  • Example#5804 - ASP'de For Each
  • Example#5805 - PHP 4'de while() ... Next()
  • Example#5806 - PHP 5'de foreach
  • Example#5807 - COM example (1)
  • Example#5808 - COM example (2)
  • Example#5809 - DOTNET example
  • Example#5810 - Variant example, PHP 4.x style
  • Example#5811 - Variant example, PHP 5 style
  • Example#5812 - COM olay bağlayıcı örneği
  • Example#5813 - - PHP süreciyle ilgili istatistikler
  • Example#5814 - - Küresel bellek kullanımı ile ilgili istatistikler
  • Example#5815 - - Bir PHP betiğinin hizmet olarak çalışacağını belirtmek
  • Example#5816 - - Bir hizmeti kullanımdan kaldırmak
  • Example#5817 - - Bir hizmet olarak çalıştırmak
  • Example#5818 - - win32_create_service örneği
  • Example#5819 - - win32_delete_service örneği
  • Example#5820 - - win32_start_service_ctrl_dispatcher örneği
  • Example#5821 - - Yeni bir DOMAttr oluşturmak
  • Example#5822 - - DOMAttr::isId örneği
  • Example#5823 - - Yeni bir DOMComment oluşturmak
  • Example#5824 - - Yeni bir DOMDocument oluşturmak
  • Example#5825 - - Yeni bir eleman oluşturup belge elemanı yapmak
  • Example#5826 - - Yeni bir eleman oluşturup belge elemanı yapmak
  • Example#5827 - - İsim alanı öneki örneği
  • Example#5828 - - DOMDocument::getElementById örneği
  • Example#5829 - - Tüm XInclude elemanlarını döndürmek
  • Example#5830 - - DOMDocument::importNode örneği
  • Example#5831 - - Bir belge oluşturmak
  • Example#5832 - - Bir HTML belge oluşturmak
  • Example#5833 - - Bir belge oluşturmak
  • Example#5834 - - Bir belge oluşturmak
  • Example#5835 - - Duruk DOMDocument::loadXML çağrısı
  • Example#5836 - - Kolaylık olsun diye DOMElement sınıfına yeni bir yöntem eklemek
  • Example#5837 - - Elemanların özel bir sınıf olarak döndürülmesi
  • Example#5838 - - Asıl belgeyi döndürmek
  • Example#5839 - - Bir DOM ağacının bir dosyaya kaydedilmesi
  • Example#5840 - - Bir HTML ağacının dizge olarak çıktılanması
  • Example#5841 - - Bir HTML ağacının bir dosyaya kaydedilmesi
  • Example#5842 - - Bir DOM ağacının dizge olarak çıktılanması
  • Example#5843 - - DTD'ye göre doğrulama örneği
  • Example#5844 - - DOMDocument::xinclude örneği
  • Example#5845 - - Belgeye XML veri eklemek
  • Example#5846 - - Yeni bir DOMElement oluşturmak
  • Example#5847 - - Bir özniteliğin atanması
  • Example#5848 - Yeni bir DOMEntityReference oluşturmak
  • Example#5849 - - Bir DTD ekleyerek bir belge oluşturmak
  • Example#5850 - - DOM Gerçekleniminin özellikleri
  • Example#5851 - - Bir çocuk düğüm eklemek
  • Example#5852 - DOMNode::getLineNo example
  • Example#5853 - DOMNode::getNodePath example
  • Example#5854 - Removing a child
  • Example#5855 - - Bir tablonun tüm girdilerini çıktılamak
  • Example#5856 - - Yeni bir DOMProcessingInstruction oluşturmak
  • Example#5857 - - Yeni bir DOMText nesnesi oluşturmak
  • Example#5858 - - Tüm İngilizce kitapların sayısını döndürmek
  • Example#5859 - - Tüm İngilizce kitapları listelemek
  • Example#5860 - book.xml
  • Example#5861 - DOMXPath::registerPHPFunctions with php:functionString
  • Example#5862 - DOMXPath::registerPHPFunctions with php:function
  • Example#5863 - - dom_import_simplexml ile DOM'a SimpleXML ithali
  • Example#5864 - - libxml_get_errors örneği
  • Example#5865 - libxml_set_external_entity_loader example
  • Example#5866 - - libxml_set_streams_context örneği
  • Example#5867 - - libxml_use_internal_errors örneği
  • Example#5868 - Access via property name
  • Example#5869 - Access via property name as array index
  • Example#5870 - Data Object iteration
  • Example#5871 - Access many-valued property by name
  • Example#5872 - Many-valued element access
  • Example#5873 - Many-valued property iteration
  • Example#5874 - Chained property access
  • Example#5875 - XPath navigation
  • Example#5876 - XPath querying
  • Example#5877 - Creating child data objects
  • Example#5878 - Unset a primitive property
  • Example#5879 - Unset a data object
  • Example#5880 - Unset a referenced data object
  • Example#5881 - Access via property index
  • Example#5882 - Getting the SDO_Sequence interface
  • Example#5883 - Get/set sequence values
  • Example#5884 - Sequence iteration
  • Example#5885 - Sequence versus Data Object
  • Example#5886 - Adding to a sequence
  • Example#5887 - Removing from a sequence
  • Example#5888 - Reflecting on a Data Object
  • Example#5889 - Accessing the type information
  • Example#5890 - A SDO_DAS_DataFactory::addPropertyToType example
  • Example#5891 - A SDO_DAS_DataFactory::addType example
  • Example#5892 - Creating a data object
  • Example#5893 - Retrieving a data object
  • Example#5894 - Updating a data object
  • Example#5895 - Deleting a data object
  • Example#5896 - One company, one department - Create
  • Example#5897 - One company, one department - Retrieve and Update
  • Example#5898 - One company, two departments - Retrieve and Delete
  • Example#5899 - One company, one department, one employee - Create
  • Example#5900 - One company, one department, one employee - Retrieve and update
  • Example#5901 - One company, two departments, two employees - Retrieve and delete
  • Example#5902 - Retrieving a data object using executePreparedQuery
  • Example#5903 - Loading, altering, and saving an XML document
  • Example#5904 - Creating a new XML document
  • Example#5905 - Setting XML document properties
  • Example#5906 - Using an open type
  • Example#5907 - Finding out what you can from the document
  • Example#5908 - Printing the SDO model
  • Example#5909 - - XML dizge olarak içerilecek example.php dosyası
  • Example#5910 - - <plot> içeriğinin eldesi
  • Example#5911 - - <line> içeriğinin eldesi
  • Example#5912 - - Bir elemanın birden fazla örneğine erişim
  • Example#5913 - - Özniteliklerin kullanımı
  • Example#5914 - - Elemanları ve öznitelikleri karşılaştırmak
  • Example#5915 - - İki elemanı karşılaştırmak
  • Example#5916 - - XPath kullanımı
  • Example#5917 - - Değer atamak
  • Example#5918 - - Eleman ve öznitelik eklemek
  • Example#5919 - - DOM ile çalışabilirlik
  • Example#5920 - - Hatalı bir XML dizgesinin yüklenmesi
  • Example#5921 - - Bir SimpleXMLElement nesnesine öznitelikler ve çocuk elemanlar eklemek
  • Example#5922 - - Bir SimpleXMLElement nesnesine öznitelikleriyle çocuk elemanlar eklemek
  • Example#5923 - - XML belgenin döndürülmesi
  • Example#5924 - - SimpleXMLElement::xpath sonucundan bir XML belge döndürmek
  • Example#5925 - - Bir XML dizgenin yorumlanması
  • Example#5926 - - children() dizimsisi
  • Example#5927 - - Bir dizgeden bir SimpleXMLElement nesnesi oluşturmak
  • Example#5928 - - Bir dosyadan bir SimpleXMLElement nesnesi oluşturmak
  • Example#5929 - Counting the number of children
  • Example#5930 - - Belge isim alanlarının döndürülmesi
  • Example#5931 - - Çok sayıda isim alanı ile çalışma
  • Example#5932 - - XML eleman isimlerinin döndürülmesi
  • Example#5933 - - Kullanılan belge isim alanlarının döndürülmesi
  • Example#5934 - - Bir XPath ifadesinde kullanılacak isim alanı önekinin belirtilmesi
  • Example#5935 - Get string content
  • Example#5936 - - Xpath örneği
  • Example#5937 - - DOM ithali
  • Example#5938 - - Bir XML belgenin yorumlanması
  • Example#5939 - - Bir XML belgenin yorumlanması
  • Example#5940 - - WDDX ile tek bir değerin dizgeleştirilmesi
  • Example#5941 - - WDDX ile artırımsal paketlerin kullanımı
  • Example#5942 - - wddx_serialize_vars örneği
  • Example#5943 - - XML Eleman yapısının gösterimi
  • Example#5944 - - XML etiketlerini HTML etiketlerine eşleme
  • Example#5945 - - Harici Öğe Örneği
  • Example#5946 - xmltest.xml
  • Example#5947 - xmltest2.xml
  • Example#5948 - - xml_parse_into_struct örneği
  • Example#5949 - - moldb.xml - küçük bir moleküler bilgi veritabanı
  • Example#5950 - - parsemoldb.php - moldb.xml dosyasını bir moleküler nesne dizisine çözümler
  • Example#5951 - - xml_set_object örneği
  • Example#5952 - - XML belgenin doğrulanması
  • Example#5953 - - collection.xml
  • Example#5954 - - collection.xsl
  • Example#5955 - - Bir XSLTProcessor oluşturmak
  • Example#5956 - - EXSLT desteğinin sınanması
  • Example#5957 - - Bir biçembentten bir PHP işlevinin çağrılması
  • Example#5958 - - Dönüşüm öncesi sahip değişimi
  • Example#5959 - - Profil bilgisi çıktılama örneği
  • Example#5960 - - Bir DOMDocument nesnesine dönüşüm
  • Example#5961 - - Bir HTML dosyaya dönüşüm
  • Example#5962 - - Bir dizgeye dönüşüm
  • Example#5963 - "counter"'s basic interface
  • Example#5964 - "counter"'s extended interface
  • Example#5965 - "counter"'s objective interface
  • Example#5966 - An example config.m4 file
  • Example#5967 - Sample configure output
  • Example#5968 - counter's config.m4 file
  • Example#5969 - An example config.w32 file
  • Example#5970 - counter's config.w32 file
  • Example#5971 - Files in the counter extension, in no particular order
  • Example#5972 - zend_module declaration in the counter extension
  • Example#5973 - zend_module definition in PHP 5.3
  • Example#5974 - Counter extension module definition
  • Example#5975 - The wrong way to store the basic counter interface's value
  • Example#5976 - The counter module's globals
  • Example#5977 - The counter module's global structure declaration
  • Example#5978 - Accessor macros for per-module globals
  • Example#5979 - The right way to store the basic counter interface's value
  • Example#5980 - counter's PHP_MINFO function
  • Example#5981 - Example macros for invoking pdo_SKEL_error
  • Example#5982 - Using pdo_parse_params
  • Example#5983 - Implementing preparer for drivers that don't support native prepared statements
  • Example#5984 - simple stream example that displays the PHP home page
  • Example#5985 - How to accept a stream as a parameter
  • Example#5986 - How to return a stream from a function
  • Example#5987 - The default config.m4.
  • Example#5988 - A simple extension.
  • Example#5989 - A test file for first_module.so.
  • Example#5990 - Internal declaration of zend_function_entry.
  • Example#5991 - Internal declaration of zend_module_entry.
  • Example#5992 - PHP's implementation of variable arguments in fsockopen().
  • Example#5993 - PHP/Zend zval type definition.
  • Example#5994 - Testing for referenced parameter passing.
  • Example#5995 - Creating variables with different scopes.
  • Example#5996 - Creation of a long.
  • Example#5997 - Adding an element to an associative array.
  • Example#5998 - Adding an element to an indexed array.
  • Example#5999 - Source code and screenshot for output in phpinfo.
  • Example#6000 - Printing execution information.
  • Example#6001 - Calling user functions.
  • Example#6002 -
  • Example#6003 -
  • Example#6004 -
  • Example#6005 -
  • Example#6006 -
  • Example#6007 -
  • Example#6008 -
  • Example#6009 - - Gizli bir HTML form elemanı
  • Example#6010 - - Kullanıcı tarafından düzenlenen veri
  • Example#6011 - - Bir URL içinde
  • Example#6012 - - PHP ile Javascript üretimi
  • Example#6013 -
  • Example#6014 - register_globals'in taklit edilmesi
  • Example#6015 - Example PHP/FI Code
  • Example#6016 - In PHP Core
  • Example#6017 - Object Oriented Code in PHP Core
  • Example#6018 - In the bzip2 Extension
  • Example#6019 - In the datetime Extension
  • Example#6020 - In the dBase Extension
  • Example#6021 - In the mcrypt Extension
  • Example#6022 - In the oci8 Extension
  • Example#6023 - In the SPL Extension
  • Example#6024 - In the Semaphore (sysvmsg) extension
  • Example#6025 - A 5.2.1+ Zip Example
  • Example#6026 - strrpos and strripos now use the entire string as a needle
  • Example#6027 - An object with no properties is no longer considered "empty"
  • Example#6028 - In some cases classes must be declared before used
  • Example#6029 - Migrating Apache configuration files for PHP 5
  • Example#6030 - Migrating Apache configuration files for PHP 5, CGI mode
  • Example#6031 - - dev.site.dom alan adı için ekranda hata raporlamayı etkin kılmak
  • Example#6032 - - Korunmuş alanlar için güvenlik betikleri eklemek
  • Example#6033 - Unix include_path
  • Example#6034 - Windows include_path
  • Example#6035 - include_path değişkeninde Unix ${USER} ortam değişkeni kullanımı
  • Example#6036 - - string.rot13 örneği
  • Example#6037 - - string.toupper örneği
  • Example#6038 - - string.tolower örneği
  • Example#6039 - - string.strip_tags örneği
  • Example#6040 - - convert.base64-encode ve convert.base64-decode örneği
  • Example#6041 - - convert.quoted-printable-encode ve convert.quoted-printable-decode örneği
  • Example#6042 - - zlib.deflate ve zlib.inflate örneği
  • Example#6043 - - Basit bir zlib.deflate örneği
  • Example#6044 - - bzip2.compress ve bzip2.decompress örneği
  • Example#6045 - - 3DES kullanarak şifreli dosya çıktılama
  • Example#6046 - - Şifreli dosyanın okunması
İşlevler ve Yöntemler Dizini
Changelog
Genel Dizin


Changelog

The following changes have been made to functions of bundled extensions.

Version | Function | Description
dbase 7.0.0 | dbase_add_record | dbase_identifier is now a resource instead of an int.
 | dbase_close | dbase_identifier is now a resource instead of an int.
 | dbase_create | The return value is now a resource instead of an int.
 | dbase_delete_record | dbase_identifier is now a resource instead of an int.
 | dbase_get_header_info | dbase_identifier is now a resource instead of an int.
 | dbase_get_record | dbase_identifier is now a resource instead of an int.
 | dbase_get_record_with_names | dbase_identifier is now a resource instead of an int.
 | dbase_numfields | dbase_identifier is now a resource instead of an int.
 | dbase_numrecords | dbase_identifier is now a resource instead of an int.
 | dbase_open | The return value is now a resource instead of an int.
 | dbase_pack | dbase_identifier is now a resource instead of an int.
 | dbase_replace_record | dbase_identifier is now a resource instead of an int.
7.1.0 | curl_multi_setopt | Introduced CURLMOPT_PUSHFUNCTION.
 | mt_rand | mt_randhas been updated to use the fixed, correct, version of the Mersenne Twister algorithm. To fall back to the old behaviour, use mt_srand with MT_RAND_PHP as the second paramter.
 | mt_rand | rand has been made an alias of mt_rand.
 | mt_srand | mt_randhas been updated to use the fixed, correct, version of the Mersenne Twister algorithm. To fall back to the old behaviour, use mt_srand with MT_RAND_PHP as the second paramter.
 | mt_srand | srand has been made an alias of mt_srand.
 | rand | rand has been made an alias of mt_rand.
 | srand | srand has been made an alias of mt_srand.
7.0.7 | curl_multi_setopt | Introduced CURLMOPT_CHUNK_LENGTH_PENALTY_SIZE, CURLMOPT_CONTENT_LENGTH_PENALTY_SIZE, CURLMOPT_MAX_HOST_CONNECTIONS, CURLMOPT_MAX_PIPELINE_LENGTH and CURLMOPT_MAX_TOTAL_CONNECTIONS.
7.0.0 | array_column | Added the ability for the input parameter to be an array of objects.
 | shmop_close | The type of shmid has been changed from int to resource.
 | shmop_delete | The type of shmid has been changed from int to resource.
 | shmop_open | The return type of shmop_open has been changed from int to resource.
 | shmop_read | The type of shmid has been changed from int to resource.
 | shmop_size | The type of shmid has been changed from int to resource.
 | shmop_write | The type of shmid has been changed from int to resource.
5.6.25, 7.0.10 | SplFileObject::getCsvControl | Added the escape character to the returned array.
5.6.16 | mysqli::real_connect | Added the MYSQLI_CLIENT_SSL_DONT_VERIFY_SERVER_CERT flag for MySQL Native Driver
5.6.1 | sem_acquire | The $nowait parameter was added.
5.6.0 | array_filter | Seçimlik seçenek değiştirgesi ve ARRAY_FILTER_USE_KEY ile ARRAY_FILTER_USE_BOTH sabiti eklendi.
 | pg_connect | Support for giving the PGSQL_CONNECT_ASYNC constant as the connect_type was added.
 | pg_convert | No longer experimental. Boolean/NULL data types are supported. Unknown/unsupported data types are escaped without validation. pg_convert could be used with any data types.
 | pg_delete | No longer experimental. Added PGSQL_DML_ESCAPE constant, TRUE/FALSE and NULL data type support.
 | pg_insert | No longer experimental. Added PGSQL_DML_ESCAPE constant, TRUE/FALSE and NULL data type support.
 | pg_insert | Unless PGSQL_DML_STRING is passed, the function now returns the connection resource instead of TRUE on success.
 | pg_lo_seek | Added PostgreSQL 9.3's 64bit large object support. Both client and server must support PostgreSQL 9.3 and PHP must be 64bit build to use 64bit large object.
 | pg_lo_tell | Added PostgreSQL 9.3's 64bit large object support. Both client and server must support PostgreSQL 9.3 and PHP must be 64bit build to use 64bit large object.
 | pg_lo_truncate | Added truncate function. It supports PostgreSQL 9.3's 64bit large object. Both client and server must support PostgreSQL 9.3 and PHP must be 64bit build to use 64bit large object.
 | pg_meta_data | No longer experimental. Added "is enum" as default attribute. extended flag is added.
 | pg_select | No longer experimental. Added PGSQL_DML_ESCAPE constant, TRUE/FALSE and NULL data type support.
 | pg_update | No longer experimental. Added PGSQL_DML_ESCAPE constant, TRUE/FALSE and NULL data type support.
5.5.21, 5.6.5 | SplFileObject::fputcsv | Added the escape parameter.
5.5.7 | apache_request_headers | Bu işlev CLI sunucusunda kullanılabilir hale geldi.
 | apache_response_headers | Bu işlev CLI sunucusunda kullanılabilir hale geldi.
 | getallheaders | Bu işlev CLI sunucusunda kullanılabilir hale geldi.
5.5.3/5.4.19 | pg_delete | Direct SQL injection to table_name and Indirect SQL injection to identifiers are fixed.
 | pg_insert | Direct SQL injection to table_name and Indirect SQL injection to identifiers are fixed.
 | pg_select | Direct SQL injection to table_name and Indirect SQL injection to identifiers are fixed.
 | pg_update | Direct SQL injection to table_name and Indirect SQL injection to identifiers are fixed.
5.5.1 | pg_unescape_bytea | A warning is thrown if the input string is invalid.
5.5.0 | iterator_to_array | iterator_to_array gained support for key types other than integer and string when the use_keys parameter is enabled.
 | mysqli::commit | Added flags and name parameters.
 | mysqli::options | The MYSQLI_SERVER_PUBLIC_KEY and MYSQLI_SERVER_PUBLIC_KEY options were added.
 | mysqli::rollback | Added flags and name parameters.
 | SoapClient::SoapClient | New ssl_method option.
5.4.0 | apache_child_terminate | Bu işlev FastCGI altında kullanılabilir hale geldi. Evvelce, sadece PHP bir Apache modülü olarak kurulduğu takdirde destekleniyordu.
 | apache_request_headers | Bu işlev FastCGI altında kullanılabilir hale geldi. Evvelce, sadece PHP bir Apache modülü olarak veya Netscape/iPlanet/SunONE sunucularında NSAPI sunucu modülü olarak kurulduğu takdirde destekleniyordu.
 | apache_response_headers | Bu işlev FastCGI altında kullanılabilir hale geldi. Evvelce, sadece PHP bir Apache modülü olarak veya Netscape/iPlanet/SunONE sunucularında NSAPI sunucu modülü olarak kurulduğu takdirde destekleniyordu.
 | array_combine | Önceki sürümler boş dizilerde için FALSE döndürür ve bir E_WARNINGoluştururdu.
 | filter_input_array | Added add_empty parameter.
 | filter_var_array | Added add_empty parameter.
 | getallheaders | Bu işlev FastCGI altında kullanılabilir hale geldi. Evvelce, sadece PHP bir Apache modülü olarak veya Netscape/iPlanet/SunONE sunucularında NSAPI sunucu modülü olarak kurulduğu takdirde destekleniyordu.
 | gzcompress | kodlama değiştirgesi eklendi.
 | gzdeflate | kodlama değiştirgesi eklendi.
 | gzencode | FORCE_DEFLATE artık RFC 1950 uyumlu bir çıktı üretiyor.
 | mysqli_get_cache_stats | The mysqli_get_cache_stats was removed.
 | snmp_set_valueretrieval | Constants SNMP_VALUE_PLAIN or SNMP_VALUE_LIBRARY may be combined with SNMP_VALUE_OBJECT resulting different way of representing contents of value array element in return value of GET-function. If no SNMP_VALUE_{PLAIN,LIBRARY} constant is accompanying SNMP_VALUE_OBJECT, SNMP_VALUE_LIBRARY is used. Prior to 5.4.0 SNMP_VALUE_OBJECT effecively meant SNMP_VALUE_OBJECT|SNMP_VALUE_PLAIN.
 | Phar::setStub | Added len parameter.
 | PharData::setStub | Added len parameter.
 | SoapClient::SoapClient | New keep_alive option.
5.3.4 | mt_rand | Issues an E_WARNING and returns FALSE if max < min.
 | mysqli_driver::$report_mode | Changing the reporting mode is now be per-request, rather than per-process.
5.3.3 | ldap_sasl_bind | Support on Windows was added.
5.3.2 (PECL OCI8 1.4) | oci_set_prefetch | Before this release, rows must be >= 1.
5.3.2 | gmp_init | The base was extended from 2 to 36, to 2 to 62 and -2 to -36.
 | gmp_strval | The base was extended from 2 to 36, to 2 to 62 and -2 to -36.
5.3.1 | ibase_query | On success the function now returns TRUE if there were no affected rows, where it previously returned 0 (a zero followed by an empty space).
5.3.0 (PECL OCI8 1.3.4) | oci_set_prefetch | Before this release, prefetching was limited to the lesser of rows rows and 1024 * rows bytes. The byte size restriction has now been removed.
5.3.0 | DirectoryIterator::__construct | Throws UnexpectedValueException if the path cannot be opened.
 | acosh | This function is now available on all platforms
 | asinh | This function is now available on all platforms
 | atanh | This function is now available on all platforms
 | expm1 | This function is now available on all platforms
 | log1p | This function is now available on all platforms
 | mysqli_get_cache_stats | The mysqli_get_cache_stats was added as stub.
 | pg_lo_create | The optional object_id was added.
 | pg_lo_import | The optional object_id was added.
 | round | The mode parameter was introduced.
 | shm_attach | This function now returns a resource instead of an integer.
 | spl_autoload_register | The prepend parameter was added.
 | spl_autoload_register | Namespaces support was introduced.
 | sybase_connect | The new parameter was added.
 | mysqli::__construct | Added the ability of persistent connections.
 | mysqli::options | The MYSQLI_OPT_INT_AND_FLOAT_NATIVE, MYSQLI_OPT_NET_CMD_BUFFER_SIZE, MYSQLI_OPT_NET_READ_BUFFER_SIZE, and MYSQLI_OPT_SSL_VERIFY_SERVER_CERT options were added.
 | mysqli::query | Added the ability of async queries.
 | SplFileObject::setCsvControl | Added the escape parameter.
 | SplObjectStorage::attach | Added the data parameter.
5.2.15 | mysqli_driver::$report_mode | Changing the reporting mode is now be per-request, rather than per-process.
5.2.10 | array_rand | Elde edilen anahtar dizisi artık karılmıyor.
 | array_unique | seçenekler değiştirgesinin öntanımlı değeri tekrar SORT_STRING yapıldı.
 | curl_setopt | CURLOPT_PROTOCOLS ve CURLOPT_REDIR_PROTOCOLS kullanılabilir oldu.
5.2.9 | array_unique | Seçimlik seçenekler değiştirgesi, öntanımlı SORT_REGULAR değeri ile eklendi. 5.2.9 öncesinde işlev dahili olarak SORT_STRING ile diziyi sıralardı.
5.2.7 | round | The inner workings of round was changed to conform to the C99 standard.
5.2.4 | ldap_first_attribute | The ber_identifier was removed. This is now handled automatically by PHP.
 | ldap_next_attribute | The ber_identifier was removed. This is now handled automatically by PHP.
5.2.1 | iterator_to_array | The use_keys parameter was added.
 | mt_srand | The Mersenne Twister implementation in PHP now uses a new seeding algorithm by Richard Wagner. Identical seeds no longer produce the same sequence of values they did in previous versions. This behavior is not expected to change again, but it is considered unsafe to rely upon it nonetheless.
5.2.0 | curl_multi_info_read | iletiler değiştirgesi eklendi.
 | pg_escape_bytea | connection added
 | pg_escape_string | connection added
 | snmp_set_oid_numeric_print | Since PHP 5.2.0.
 | SoapServer::SoapServer | Added the typemap option.
5.1.3 | DirectoryIterator::__construct | Throws RuntimeException if the path is an empty string.
 | curl_getinfo | CURLINFO_HEADER_OUT devreye girdi.
 | SoapClient::__doRequest | The one_way parameter was added.
5.1.0 | DirectoryIterator::__construct | Throws RuntimeException on error. Previously, threw Exception.
 | class_implements | Added the option to pass the class parameter as a string. Added the autoload parameter.
 | class_parents | Added the option to pass the class parameter as a string. Added the autoload parameter.
 | curl_setopt | CURLOPT_AUTOREFERER, CURLOPT_BINARYTRANSFER, CURLOPT_FTPSSLAUTH, CURLOPT_AUTOREFERER, CURLOPT_PROXYAUTH ve CURLOPT_TIMECONDITION kullanılabilir oldu.
 | mssql_connect | The new_link parameter was added
5.0.4 | msql_fetch_array | A bug was fixed when retrieving data from columns containing NULL values. Such columns were not placed into the resulting array.
 | msql_fetch_object | A bug was fixed when retrieving data from columns containing NULL values. Such columns were not placed into the resulting array.
 | msql_fetch_row | A bug was fixed when retrieving data from columns containing NULL values. Such columns were not placed into the resulting array.
5.0.2 | array_slice | İsteğe bağlı preserve_keys değiştirgesi eklendi.
5.0.0 | apache_get_modules | Apache 1 ya da PHP Apache 2 filtre API'si kullanıldığında kullanılabilinir. Bundan önce sadece Apache 2 handler API'si kullanılırken kullanılabiliyordu.
 | curl_setopt | CURLOPT_FTP_USE_EPRT, CURLOPT_NOSIGNAL, CURLOPT_UNRESTRICTED_AUTH, CURLOPT_BUFFERSIZE, CURLOPT_HTTPAUTH, CURLOPT_PROXYPORT, CURLOPT_PROXYTYPE, CURLOPT_SSLCERTTYPE ve CURLOPT_HTTP200ALIASES kullanılabilir oldu.
 | opendir | dizin değiştirgesinde ftp:// sarmalayıcısı da kabul edilmeye başlandı.
 | range | İsteğe bağlı adım değiştirgesi eklendi.
Örnekler Dizini
HTML Yardım Dosyası (.chm) Sürümü
Ekler


HTML Yardım Dosyası (.chm) Sürümü

  • About This Edition
  • Using PHP Manual CHM Edition
    • The HTML Help Toolbar
    • The Navigation Pane
    • Keyboard Shortcuts
  • The Full Text Search
    • General searching rules
    • Searching for words or phrases
    • Defining search terms
    • Using nested expressions when searching
  • Integrating the PHP Manual
Changelog
About This Edition
PHP Kılavuzu


About This Edition

The Windows HTML Help Edition of the PHP Manual is aimed at developers, who want the manual at hand every time, and would like to read manual pages and user notes without waiting for a remote web page to download. This edition gives you the full content of the manual plus the user notes, with some great features provided by the viewer application by the scripts we use to generate this format and by other contributors in the form of skins.

This distribution of the PHP Manual contains many files, including the main manual file php_manual_en.chm. You can view the manual by double clicking on this file (as you already guessed). You may also see a php_manual_en.chw file in the directory, it's generated the first time you use the index tab, and it contains an index with the manual's pages.

For those interested in technical details about Microsoft HTML Help, » http://www.helpware.net/ is a great resource. For more information and positioning of Windows HTML Help in the Microsoft help formats and services history, see this » WinWriters article.

HTML Yardım Dosyası (.chm) Sürümü
Using PHP Manual CHM Edition
HTML Yardım Dosyası (.chm) Sürümü


Using PHP Manual CHM Edition

İçindekiler

  • The HTML Help Toolbar
  • The Navigation Pane
  • Keyboard Shortcuts

When you double click on a CHM, a HTML Help Viewer window opens with three panes. On the left side of the window is the Navigation pane. It contains four navigational tabs: the Contents, Index, Search and Favorites tabs. On the right side of the window is the Topic pane. It displays the selected help topic, or the default help topic on startup. The help pages are all separate HTML files, your Internet Explorer displays the pages in the Topic pane. The third pane is the toolbar, which is located below the help window title bar. You can adjust the horizontal layout with dragging the vertical border between the Navigation pane and the Topic pane.

Note, that when you open the CHM the first time, it may appear in a strange position and size. From then, Windows remembers the window position, size and the last opened tab. All these including your favorites are stored in a file named hh.dat. If you move your file to another directory, all these remembered settings will be lost (including your favorites listing!). If you replace your CHM file with a new one, with the same name, this is not a problem though. The file names and path values are stored in hh.dat.

About This Edition
The HTML Help Toolbar
HTML Yardım Dosyası (.chm) Sürümü


The HTML Help Toolbar

The HTML Help Toolbar contains the following icons, when you view the PHP Manual:

  • Hide/Show - Hides/shows the navigation pane.
  • Locate - Locates a topic in the contents tab (in case you reached a topic with search, index or favorites, and would like to see where it is in the table of contents tree view).
  • Back - Goes back in the history.
  • Forward - Goes forward in the history.
  • Refresh - Reloads the current page.
  • Home - Opens the startup page of the CHM.
  • Print - Opens the print dialog box.
  • Options - Provides a dropdown with more options.
Using this toolbar is really easy, many of the toolbar icons are strongly related to their Internet Explorer equivalents.

Using PHP Manual CHM Edition
The Navigation Pane
Using PHP Manual CHM Edition


The Navigation Pane

The Navigation Pane contains four navigational tabs: the Contents, Index, Search and Favorites tabs. These all provide different methods to access a topic in the help file.

  • The contents tab reveals a tree like table of contents, where you can navigate to the desired topic by opening and closing parts of the tree. You can even access the deepest sections using this TOC. If you right click on an item here and choose "Print...", you'll have the option to print the selected topic or the selected topic and all subtopics. However printing is not the initial goal of this representation of the manual (the PDF version is suitable for printing).
  • The index tab lists a huge number of "keywords" (actually manual page titles). You can pick one, or start to type a keyword, see the list adjusting to your input, and then click on a topic, or press enter if the selected topic is the one you would like to see.
  • The search tab shows one of the most powerful features of the HTML Help Viewer, the full text search (also known as FTS). Here you can type in your search expression, optionally connecting words with AND/OR/NEAR/NOT. Before you click 'List topics', you can also set some options at the bottom. After the search results are displayed, you'll realize that manual text and user note results are separated. To sort out the two types, click on the 'Location' column header. Now from the search results list, you can pick a topic, and see it's page. The keywords you searched for are highlighted on the page.
  • The favorites tab enables you to store your most used topics in a list, easily accessible. Here you can see the list, add the current topic to it, remove one, or display a selected item. You can also specify your own title for the favorite, by typing it into the 'Current topic:' box. The user note page titles are prepended with a 'N:' string so you can distinguish them from normal manual pages in the favorites listing.

The HTML Help Toolbar
Keyboard Shortcuts
Using PHP Manual CHM Edition


Keyboard Shortcuts

There are many keyboard shortcuts you can use to increase your productivity. Many users find it more appropriate to use these keyboard shortcuts to access topics, instead of clicking.

General Help Viewer Shortcuts
To | Press
Close the Help Viewer | ALT+F4
Display the Options menu | ALT+O
Hide or show the Navigation pane | ALT+O, and then T
Print a topic | ALT+O, and then P
Move back to the previous topic | ALT+LEFT ARROW
Move forward to the next topic (provided you have viewed it just previously) | ALT+RIGHT ARROW
Turn on or off search highlighting. | ALT+O, and then O
Return to the help file home page | ALT+O, and then H
Switch between the Navigation pane and the Topic pane | F6
Scroll through all the links in a topic or through all the options on a Navigation pane tab | TAB
Display context (right click) menu | SHIFT+F10
Contents Tab Shortcuts
To | Press
Display the Contents tab | ALT+C
Open and close a book or folder | PLUS SIGN and MINUS SIGN, or LEFT ARROW and RIGHT ARROW
Select a topic | DOWN ARROW and UP ARROW
Display the selected topic | ENTER
Index Tab Shortcuts
To | Press
Display the Index tab | ALT+N
Type a keyword to search for | ALT+W, and then type the word
Select a keyword in the list | UP ARROW and DOWN ARROW
Display the associated topic | ENTER or ALT+D
Search Tab shortcuts
To | Press
Display the Search tab | ALT+S
Type a keyword to search for | ALT+W, and then type the word
Start a search | ALT+L
Select a topic in the results list | ALT+T, and then UP ARROW and DOWN ARROW
Display the selected topic | ENTER or ALT+D
Search for a keyword in the result list of a prior search | ALT+U
Search for words similar to the keyword. For example, to find words like "running" and "runs" for the keyword "run" | ALT+M
Only search through topic titles | ALT+R
Favorites Tab Shortcuts
To | Press
Display the Favorites tab | ALT+I
Add the currently displayed topic to the Favorites list | ALT+A
Select a topic in the Favorites list | ALT+P, and then UP ARROW and DOWN ARROW
Display the selected topic | ENTER or ALT+D
Remove the selected topic from the list | ALT+R
Topic Pane Shortcuts
To | Press
Index Lookup | Select the words you would like to look up and press F1
Find on page | CTRL+F, and then adjust options
Refresh page | F5

The Navigation Pane
The Full Text Search
Using PHP Manual CHM Edition


The Full Text Search

İçindekiler

  • General searching rules
  • Searching for words or phrases
  • Defining search terms
  • Using nested expressions when searching

This edition of the PHP Manual includes an advanced full text search possibility provided by the viewer application. This enables users to search through every word in the help file to find a match. For example, if a user does a full-text search on the word "Apache", every topic that contains the word "Apache" will be listed. Advanced full-text search allows a user to search using boolean, wildcard, and nested expressions. A user can also limit the search to previous results, match similar words, or search topic titles only.

The usage of the search feature is fairly straightforward. Click on the search tab, type in the desired words and press ENTER (or click on "List Topics"). Then you'll receive a list of matches from the PHP Manual (and the notes). You can use the button with a right arrow on it to add boolean operators to your search (or you can type them in). As you see the results, you can use the column headings (Title, Location and Rank) to sort the topic list. The default order is by Rank. You can also adjust some parameters at the bottom of this tab.

The words found are highlighted on the current page in the Topic pane by default. You can turn off this feature by choosing the "Search Highlight Off" menu item in the Options menu. To can get this feature back similarly. If you are viewing a long topic, only the first 500 instances of a search word or phrase will be highlighted, due to a limitation of the viewer.

Keyboard Shortcuts
General searching rules
HTML Yardım Dosyası (.chm) Sürümü


General searching rules

A basic search consists of the word or phrase you want to find. You can use wildcard expressions, nested expressions, boolean operators, similar word matches, a previous results list, or topic titles to further define your search.

The basic rules for formulating queries are as follows:

  • Searches are not case-sensitive, so you can type your search in uppercase or lowercase characters.
  • You may search for any combination of letters (a-z) and numbers (0-9). You cannot search for single letters (a, b, c, etc.) and common words, like: an, and, as, at, be, but, by, do, for, from, have, he, in, it, not, of, on, or, she, that, the, there, they, this, to, we, which, with, you.
  • Punctuation marks such as the period (.), colon (:), semicolon (;), comma (,), and hyphen (-) are ignored during a search.
  • Group the elements of your search using double quotes or parentheses to set apart each element. You cannot search for quotation marks.

Bilginize:

If you are searching for a file name with an extension, you should group the entire string in double quotes, ("filename.ext"). Otherwise, the period will break the file name into two separate terms. The default operation between terms is AND, so you will create the logical equivalent to "filename AND ext."

The Full Text Search
Searching for words or phrases
The Full Text Search


Searching for words or phrases

You can search for words or phrases and use wildcard expressions. Wildcard expressions allow you to search for one or more characters using a question mark or asterisk. The table below describes the results of these different kinds of searches.

Word and phrase searches
Search for | Example | Results
A single word | select | Topics that contain the word "select". (You will also find its grammatical variations, such as "selector" and "selection".)
A phrase | "new operator" or new operator | Topics that contain the literal phrase "new operator" and all its grammatical variations. Without the quotation marks, the query is equivalent to specifying "new AND operator," which will find topics containing both of the individual words, instead of the phrase.
Wildcard expressions | esc* or HT?? | Results for the first example include topics that contain the terms "ESC", "escape", "escalation", and so on. The asterisk cannot be the only character in the term. Results for the second example include topics that contain the terms "HTTP", "HTML" and so on. The question mark cannot be the only character in the term.

Bilginize:

Select the Match similar words check box to include minor grammatical variations for the phrase you search. This feature only locates variations of the word with common suffixes. For example, a search on the word "add" will find "added," but it will not find "additive". This option is independent of other options or syntax. If you do a titles-only search, variations in titles will be matched. If you use quotes (or any other query operator) any variation of the word can appear; for example, "stemmed search" will also match "stemming search".

General searching rules
Defining search terms
The Full Text Search


Defining search terms

The AND, OR, NOT, and NEAR operators enable you to precisely define your search by creating a relationship between search terms. The following table shows how you can use each of these operators. If no operator is specified, AND is used. For example, the query "server cgi security" is equivalent to "server AND cgi AND security".

Search operators
Search for | Example | Results
Both terms in the same topic | http AND apache | Topics containing both the words "http" and "apache".
Either term in a topic | ming OR swflib | Topics containing either the word "ming" or the word "swflib" or both.
The first term without the second term | xml NOT expat | Topics containing the word "xml" but not the word "expat".
Both terms in the same topic, close together | database NEAR security | Topics containing the word "database" within eight words of the word "security".

Bilginize:

The |, &, and ! characters can also be used in place of OR AND and NOT respectively. This may not work if you use a very old version of the viewer.

Searching for words or phrases
Using nested expressions when searching
The Full Text Search


Using nested expressions when searching

Nested expressions allow you to create complex searches for information. For example, "html AND ((smtp OR pop3) NEAR mail)" finds topics containing the word "html" along with the words "smtp" and "mail" close together, or containing "html" along with the words "pop3" and "mail" close together.

The basic rules for searching help topics using nested expressions are as follows:

  • You can use parentheses to nest expressions within a query. The expressions in parentheses are evaluated before the rest of the query.
  • If a query does not contain a nested expression, it is evaluated from left to right. For example: "mail NOT pop3 OR smtp" finds topics containing the word "mail" without the word "pop3" or topics containing the word "smtp". On the other hand, "mail NOT (pop3 OR smtp)" finds topics containing the word "mail" without either of the words "pop3" or "smtp".
  • You cannot nest expressions more than five levels deep.

Defining search terms
Integrating the PHP Manual
The Full Text Search


Integrating the PHP Manual

Bilginize:

The information provided here is mainly aimed at IDE authors, or advanced users who would like to integrate this CHM file to their favorite IDEs or other production environment components.

There are several editors out there with support for CHM integration, but you may need to know a few things about what the CHM contains to successfully integrate the manual into your environment.

The CHM is built using XSL style sheets from XML sources. This is unique currently in the PHP Manual family, as all other versions are generated using DSSSL style sheets. This also means, that non-intentional rendering differences may come up. A special conversion script is run on the XSLT output, adding several cute features, and packing up the manual with the preferences files and skin examples.

If you never worked with CHMs, you can think of them as compressed files with OS supported access for files inside and some added search and index support. However CHMs can only be viewed using the HTML Help Viewer, you can directly access files inside them using a special URL prefix, the CHM file name and the file you request from inside. As all the help content is stored in HTML files, you can show pages of the CHM in Internet Explorer.

Assume that you placed your php_manual_en.chm to c:\phpmanual the index file in the manual (which you see the first time) can be accessed with the following URL: mk:@MSITStore:C:\phpmanual\php_manual_en.chm::/_index.html. Here mk:@MSITStore: is the special "protocol", C:\phpmanual\php_manual_en.chm is the CHM with it's full path. The /_index.html part is the path to the index file inside the CHM and :: is just what you need to put between the CHM path and this file path.

Bilginize:

All files are in the root directory of the CHM, unlike the previous CHM versions which included a language directory. Images, style sheets and other supplemental files have names starting with an underscore (like the main index shown above), to avoid name collisions.

The names of generated files follow the same rules as the online manual, except that the extension is .html and not .php. The most important is that function documentation files are named function.FUNCNAME.html where FUNCNAME is the function name, with all underscores converted to hyphens. Some examples are function.echo.html, function.mysql-close.html, function.imagecopy.html.

Using all this information, you can show a manual page for a function requested by a user. A simple example is included in the distribution, named php_quickref.hta. This is a » HTML Application to demonstrate the simple process of showing a manual page for a function. The quickRef() function defined therein does the job.

If you would like to integrate the manual into an IDE without direct support for the PHP manual (actually the underscore to hyphen conversion), you can use the included _function.html file to access a function page. This file is simply a redirector, and can be parameterized via the URL, as _function.html#mysql_close. This page will redirect you to the mysql_close function page (function.mysql-close.html) automatically. You can provide the full path of this file if your IDE supports context sensitive help, and provide the IDE specified string as the parameter. An example for this is the UltraEdit 9 intergation (see the edition's website).

The index of the manual (accessible via the index tab on the navigation pane) can also be used for integrational purposes. All the HTML pages are included in the index with their titles as index terms (including function description pages).

If you are a desktop application developer and would like to tightly integrate the CHM into your program (such as displaying the TOC tree in your IDE's help box), you can find more information at » http://www.helpware.net/, as well as links to other useful resources. The official site for HTML Help is at » http://www.microsoft.com/download/en/details.aspx?id=21138.

Using nested expressions when searching
HTML Yardım Dosyası (.chm) Sürümü